URLConnection (Java SE 9 & JDK 9 )

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class URLConnection

  • java.lang.Object
    • java.net.URLConnection
  • 已知直接子类：
    HttpURLConnection ， JarURLConnection

    public abstract class URLConnection
extends Object
    抽象类URLConnection是表示应用程序和URL之间的通信链接的所有类的超类。 该类的实例可以用于从URL引用的资源中读取和写入。 通常，创建与URL的连接是一个多步骤过程：
    Describes the process of creating a connection to a URL: openConnection() and connect() over time. openConnection() connect() Manipulate parameters that affect the connection to the remote resource. Interact with the resource; query header fields and contents.
    ---------------------------->
    时间
    1. 通过在URL上调用openConnection方法创建连接对象。
    2. 设置参数和一般请求属性被操纵。
    3. 使用connect方法实现与远程对象的实际连接。
    4. 远程对象变得可用。 可以访问头字段和远程对象的内容。

    使用以下方法修改设置参数：

    • setAllowUserInteraction
    • setDoInput
    • setDoOutput
    • setIfModifiedSince
    • setUseCaches

    并且使用以下方法修改一般请求属性：

    • setRequestProperty

    可以使用方法setDefaultAllowUserInteraction和setDefaultUseCaches设置AllowUserInteraction和UseCaches参数的默认值。

    上述每个set方法都有相应的get方法来检索参数或一般请求属性的值。 适用的具体参数和一般请求属性是特定于协议的。

    使用以下方法访问头域和连接远程对象后的内容：

    • getContent
    • getHeaderField
    • getInputStream
    • getOutputStream

    某些头字段经常被访问。 方法：

    • getContentEncoding
    • getContentLength
    • getContentType
    • getDate
    • getExpiration
    • getLastModified

    提供方便的访问这些领域。 getContentType方法由getContent方法用于确定远程对象的类型; 子类可能会方便地覆盖getContentType方法。

    在常见情况下，所有预连接参数和一般请求属性都可以忽略：预连接参数和请求属性默认为明智的值。 对于这个界面的大多数客户端，只有两个有趣的方法： getInputStream和getContent ，它们通过方便的方法镜像在URL类中。

    有关http连接的请求属性和标头字段的更多信息，请参见：

     http://www.ietf.org/rfc/rfc2616.txt
    调用close()的方法InputStream或OutputStream一个的URLConnection的请求后，可能释放与此实例相关联的网络资源，除非特定的协议规范为其指定不同的行为。
    从以下版本开始：
    1.0
    另请参见：
    URL.openConnection() ，
connect() ，
getContent() ，
getContentEncoding() ，
getContentLength() ，
getContentType() ，
getDate() ，
getExpiration() ，
getHeaderField(int) ，
getHeaderField(java.lang.String) ，
getInputStream() ，
getLastModified() ，
getOutputStream() ，
setAllowUserInteraction(boolean) ，
setDefaultUseCaches(boolean) ，
setDoInput(boolean) ，
setDoOutput(boolean) ，
setIfModifiedSince(long) ，
setRequestProperty(java.lang.String, java.lang.String) ，
setUseCaches(boolean)

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected boolean allowUserInteraction
      如果是 true ，这个 URL正在上下文中进行检查，其中允许用户交互（例如弹出验证对话）是有意义的。
      protected boolean connected
      如果是 false ，则此连接对象尚未创建指定URL的通信链接。
      protected boolean doInput
      此变量由 setDoInput方法设置。
      protected boolean doOutput
      该变量由 setDoOutput方法设置。
      protected long ifModifiedSince
      某些协议支持跳过对象的提取，除非对象在某个时间以前已被更新。
      protected URL url
      URL表示打开此连接的万维网上的远程对象。
      protected boolean useCaches
      如果是 true ，则允许协议使用缓存。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected URLConnection​(URL url)
      构造与指定URL的URL连接。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addRequestProperty​(String key, String value)
      添加由键值对指定的一般请求属性。
      abstract void connect​()
      打开与此URL引用的资源的通信链接，如果此类连接尚未建立。
      boolean getAllowUserInteraction​()
      返回此对象的 allowUserInteraction字段的值。
      int getConnectTimeout​()
      返回连接超时的设置。
      Object getContent​()
      检索此URL连接的内容。
      Object getContent​(Class<?>[] classes)
      检索此URL连接的内容。
      String getContentEncoding​()
      返回 content-encoding标题字段的值。
      int getContentLength​()
      返回 content-length标题字段的值。
      long getContentLengthLong​()
      返回 content-length标题字段的值为long。
      String getContentType​()
      返回 content-type标题字段的值。
      long getDate​()
      返回 date标题字段的值。
      static boolean getDefaultAllowUserInteraction​()
      返回 allowUserInteraction字段的默认值。
      static String getDefaultRequestProperty​(String key)
      已过时。
      在获得适当的URLConnection实例之后，应该使用实例特定的getRequestProperty方法。
      boolean getDefaultUseCaches​()
      返回默认值为 URLConnection的 useCaches标志。
      static boolean getDefaultUseCaches​(String protocol)
      返回给定协议的 useCaches标志的默认值。
      boolean getDoInput​()
      返回该值为 URLConnection的 doInput标志。
      boolean getDoOutput​()
      返回此值 URLConnection的 doOutput标志。
      long getExpiration​()
      返回 expires标题字段的值。
      static FileNameMap getFileNameMap​()
      从数据文件加载文件名映射（模拟）。
      String getHeaderField​(int n)
      返回的值 n th头字段。
      String getHeaderField​(String name)
      返回命名头字段的值。
      long getHeaderFieldDate​(String name, long Default)
      返回以日期解析的命名字段的值。
      int getHeaderFieldInt​(String name, int Default)
      返回被解析为命名字段的值。
      String getHeaderFieldKey​(int n)
      返回的关键 n th头字段。
      long getHeaderFieldLong​(String name, long Default)
      返回被解析为命名字段的值。
      Map<String,List<String>> getHeaderFields​()
      返回不可修改的标题字段的映射。
      long getIfModifiedSince​()
      返回此对象的 ifModifiedSince字段的值。
      InputStream getInputStream​()
      返回从此打开的连接读取的输入流。
      long getLastModified​()
      返回 last-modified标题字段的值。
      OutputStream getOutputStream​()
      返回写入此连接的输出流。
      Permission getPermission​()
      返回一个权限对象，该对象表示创建此对象所表示的连接所需的权限。
      int getReadTimeout​()
      返回读取超时的设置。 0返回意味着该选项被禁用（即无限超时）。
      Map<String,List<String>> getRequestProperties​()
      返回此连接的一般请求属性的不可修改映射。
      String getRequestProperty​(String key)
      返回此连接的命名的常规请求属性的值。
      URL getURL​()
      返回此 URLConnection的 URL字段的值。
      boolean getUseCaches​()
      返回此 URLConnection的 useCaches字段的值。
      static String guessContentTypeFromName​(String fname)
      根据URL的指定“文件”组件，尝试确定对象的内容类型。
      static String guessContentTypeFromStream​(InputStream is)
      根据输入流开头的字符，尝试确定输入流的类型。
      void setAllowUserInteraction​(boolean allowuserinteraction)
      设置这个 URLConnection的 allowUserInteraction字段的 URLConnection 。
      void setConnectTimeout​(int timeout)
      设置打开与此URLConnection引用的资源的通信链接时使用的指定超时值（以毫秒为单位）。
      static void setContentHandlerFactory​(ContentHandlerFactory fac)
      设置应用程序的 ContentHandlerFactory 。
      static void setDefaultAllowUserInteraction​(boolean defaultallowuserinteraction)
      将所有未来 URLConnection对象的 allowUserInteraction字段的默认值设置为指定的值。
      static void setDefaultRequestProperty​(String key, String value)
      已过时。
      在获得适当的URLConnection实例之后，应该使用实例特定的setRequestProperty方法。 调用此方法将不起作用。
      void setDefaultUseCaches​(boolean defaultusecaches)
      将 useCaches字段的默认值设置为指定的值。
      static void setDefaultUseCaches​(String protocol, boolean defaultVal)
      将命名协议的 useCaches字段的默认值设置为给定值。
      void setDoInput​(boolean doinput)
      将此 URLConnection的 doInput字段的值设置为指定值。
      void setDoOutput​(boolean dooutput)
      将此 URLConnection的 doOutput字段的值设置为指定值。
      static void setFileNameMap​(FileNameMap map)
      设置FileNameMap。
      void setIfModifiedSince​(long ifmodifiedsince)
      将此 URLConnection的 ifModifiedSince字段的值设置为指定值。
      void setReadTimeout​(int timeout)
      将读取超时设置为指定的超时时间，以毫秒为单位。
      void setRequestProperty​(String key, String value)
      设置一般请求属性。
      void setUseCaches​(boolean usecaches)
      将此 URLConnection的 useCaches字段的值设置为指定值。
      String toString​()
      返回此URL连接的 String表示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • url

        protected URL url
        URL表示打开此连接的万维网上的远程对象。

        该字段的值可以通过getURL方法访问。

        该变量的默认值是URLConnection构造函数中的URL参数的值。

        另请参见：
        getURL() ， url

      • doInput

        protected boolean doInput
        此变量由setDoInput方法设置。 其值由getDoInput返回。

        URL连接可用于输入和/或输出。 将doInput标志设置为true表示应用程序打算从URL连接中读取数据。

        该字段的默认值为true 。

        另请参见：
        getDoInput() ， setDoInput(boolean)

      • doOutput

        protected boolean doOutput
        此变量由setDoOutput方法设置。 其值由getDoOutput方法返回。

        URL连接可用于输入和/或输出。 将doOutput标志设置为true表示应用程序打算将数据写入URL连接。

        该字段的默认值为false 。

        另请参见：
        getDoOutput() ， setDoOutput(boolean)

      • allowUserInteraction

        protected boolean allowUserInteraction
        如果是true ，这个URL正在上下文中进行检查，其中允许用户交互（例如弹出认证对话）是有意义的。 如果是false ，则不允许用户交互。

        该字段的值可以通过setAllowUserInteraction方法设置。 其值由getAllowUserInteraction方法返回。 其默认值是上次调用setDefaultAllowUserInteraction方法中的参数的值。

        另请参见：
        getAllowUserInteraction() ， setAllowUserInteraction(boolean) ， setDefaultAllowUserInteraction(boolean)

      • useCaches

        protected boolean useCaches
        如果是true ，则允许协议使用缓存。 如果false ，协议必须始终尝试获取对象的新副本。

        该字段由setUseCaches方法设置。 其值由getUseCaches返回。

        其默认值是上次调用setDefaultUseCaches方法时给出的值。

        默认设置可以通过setDefaultUseCaches(String,boolean)按协议覆盖。

        另请参见：
        setUseCaches(boolean) ， getUseCaches() ， setDefaultUseCaches(boolean)

      • ifModifiedSince

        protected long ifModifiedSince
        某些协议支持跳过对象的提取，除非对象在某个时间以前已被更新。

        非零值给出了1970年1月1日GMT之后的毫秒数。 该对象只有在最近被修改的时间才被提取。

        此变量由setIfModifiedSince方法设置。 其值由getIfModifiedSince方法返回。

        该字段的默认值为0 ，表示提取必须始终发生。

        另请参见：
        getIfModifiedSince() ， setIfModifiedSince(long)

      • connected

        protected boolean connected
        如果是false ，则此连接对象尚未创建指定URL的通信链接。 如果是true ，通信链路已建立。

    • 构造方法详细信息

      • URLConnection

        protected URLConnection​(URL url)
        构造与指定URL的URL连接。 与URL引用的对象的连接不会创建。
        参数
        url - 指定的URL。

    • 方法详细信息

      • getFileNameMap

        public static FileNameMap getFileNameMap​()
        从数据文件加载文件名映射（模拟）。 它将首先尝试加载由“content.types.user.table”属性定义的用户特定表。 如果失败，它会尝试加载默认内置表。
        结果
        FileNameMap
        从以下版本开始：
        1.2
        另请参见：
        setFileNameMap(java.net.FileNameMap)

      • setFileNameMap

        public static void setFileNameMap​(FileNameMap map)
        设置FileNameMap。

        如果有安全管理员，则该方法首先调用安全管理员的checkSetFactory方法，以确保允许操作。 这可能会导致SecurityException。

        参数
        map - 要设置的FileNameMap
        异常
        SecurityException - 如果存在安全管理员，并且其 checkSetFactory方法不允许该操作。
        从以下版本开始：
        1.2
        另请参见：
        SecurityManager.checkSetFactory() ， getFileNameMap()

      • connect

        public abstract void connect​()
                      throws IOException
        打开与此URL引用的资源的通信链接，如果此类连接尚未建立。

        如果connect当连接已经打开方法被调用（由表示connected具有值字段true ），通话将被忽略。

        URLConnection对象经历两个阶段：首先创建它们，然后它们被连接。 在创建之后，在连接之前，可以指定各种选项（例如doInput和UseCaches）。 连接后，尝试设置它们是一个错误。 依赖于连接的操作（如getContentLength）将在必要时隐式执行连接。

        异常
        SocketTimeoutException - 如果在建立连接之前超时时间超时
        IOException - 如果在打开连接时发生I / O错误。
        另请参见：
        connected ， getConnectTimeout() ， setConnectTimeout(int)

      • setConnectTimeout

        public void setConnectTimeout​(int timeout)
        设置打开与此URLConnection引用的资源的通信链接时使用的指定超时值（以毫秒为单位）。 如果在建立连接之前超时超时，则引发java.net.SocketTimeoutException。 超时为零被解释为无限超时。

        这种方法的一些非标准实现可能会忽略指定的超时。 要查看连接超时设置，请调用getConnectTimeout（）。

        参数
        timeout - 一个 int ，以毫秒为单位指定连接超时值
        异常
        IllegalArgumentException - 如果timeout参数为负
        从以下版本开始：
        1.5
        另请参见：
        getConnectTimeout() ， connect()

      • getConnectTimeout

        public int getConnectTimeout​()
        返回连接超时的设置。

        0返回意味着该选项被禁用（即无限超时）。

        结果
        一个表示连接超时值（毫秒）的 int
        从以下版本开始：
        1.5
        另请参见：
        setConnectTimeout(int) ， connect()

      • setReadTimeout

        public void setReadTimeout​(int timeout)
        将读取超时设置为指定的超时时间，以毫秒为单位。 非零值指定当连接建立到资源时从Input stream读取的超时。 如果在数据可用于读取之前超时超时，则会引发java.net.SocketTimeoutException。 超时为零被解释为无限超时。

        此方法的一些非标准实现忽略指定的超时。 要查看读取超时集，请调用getReadTimeout（）。

        参数
        timeout - 一个 int ，指定要以毫秒为单位的超时值
        异常
        IllegalArgumentException - 如果timeout参数为负
        从以下版本开始：
        1.5
        另请参见：
        getReadTimeout() ， InputStream.read()

      • getReadTimeout

        public int getReadTimeout​()
        返回读取超时的设置。 0返回意味着该选项被禁用（即无限超时）。
        结果
        一个 int ，表示读取超时值（以毫秒为单位）
        从以下版本开始：
        1.5
        另请参见：
        setReadTimeout(int) ， InputStream.read()

      • getURL

        public URL getURL​()
        返回此 URLConnection的 URL字段的值。
        结果
        该值为 URLConnection的 URL字段。
        另请参见：
        url

      • getContentLength

        public int getContentLength​()
        返回content-length标题字段的值。

        注意 ： getContentLengthLong()应该优于此方法，因为它返回一个long ，因此更便于携带。

        结果
        如果内容长度未知，或者内容长度大于Integer.MAX_VALUE，则该连接的URL引用的资源的内容长度为 -1 。

      • getContentLengthLong

        public long getContentLengthLong​()
        返回 content-length标题字段的值为long。
        结果
        该连接的URL引用的资源的内容长度，如果内容长度未知， -1 。
        从以下版本开始：
        1.7

      • getContentType

        public String getContentType​()
        返回 content-type标题字段的值。
        结果
        URL引用的资源的内容类型，如果不知道， null 。
        另请参见：
        getHeaderField(java.lang.String)

      • getContentEncoding

        public String getContentEncoding​()
        返回 content-encoding标题字段的值。
        结果
        URL引用的资源的内容编码，如果不知道， null 。
        另请参见：
        getHeaderField(java.lang.String)

      • getExpiration

        public long getExpiration​()
        返回 expires标题字段的值。
        结果
        该URL引用的资源的到期日期，如果不知道，则为0。 值为1970年1月1日GMT以来的毫秒数。
        另请参见：
        getHeaderField(java.lang.String)

      • getDate

        public long getDate​()
        返回 date标题字段的值。
        结果
        URL引用的资源的发送日期，如果不知道， 0 。 返回的值是自1970年1月1日GMT以来的毫秒数。
        另请参见：
        getHeaderField(java.lang.String)

      • getLastModified

        public long getLastModified​()
        返回last-modified标题字段的值。 结果是自1970年1月1日GMT以来的毫秒数。
        结果
        该 URLConnection引用的资源的日期是最后一次修改，如果不知道，则为0。
        另请参见：
        getHeaderField(java.lang.String)

      • getHeaderField

        public String getHeaderField​(String name)
        返回命名头字段的值。

        如果对可能不同的值多次设置相同标题的连接进行调用，则只返回最后一个值。

        参数
        name - 标题字段的名称。
        结果
        命名头字段的值，如果在标题中没有这样的字段， null 。

      • getHeaderFields

        public Map<String,List<String>> getHeaderFields​()
        返回不可修改的标题字段的映射。 Map键是表示响应头字段名称的字符串。 每个Map值是一个不可修改的字符串列表，表示相应的字段值。
        结果
        头字段地图
        从以下版本开始：
        1.4

      • getHeaderFieldInt

        public int getHeaderFieldInt​(String name,
                             int Default)
        返回被解析为命名字段的值。

        存在此形式的getHeaderField ，因为某些连接类型（例如， http-ng ）具有预解析头。 该连接类型的类可以覆盖此方法并使解析短路。

        参数
        name - 标题字段的名称。
        Default - 默认值。
        结果
        命名字段的值，解析为整数。 如果字段丢失或格式错误，则返回Default值。

      • getHeaderFieldLong

        public long getHeaderFieldLong​(String name,
                               long Default)
        返回被解析为命名字段的值。

        存在此形式的getHeaderField ，因为某些连接类型（例如， http-ng ）具有预解析头。 该连接类型的类可以覆盖此方法并使解析短路。

        参数
        name - 标题字段的名称。
        Default - 默认值。
        结果
        命名字段的值，解析为长。 如果字段丢失或格式错误，则返回Default值。
        从以下版本开始：
        1.7

      • getHeaderFieldDate

        public long getHeaderFieldDate​(String name,
                               long Default)
        返回以日期解析的命名字段的值。 结果是自1970年1月1日GMT以指定字段表示的毫秒数。

        存在这种形式的getHeaderField ，因为某些连接类型（例如， http-ng ）具有预分析头。 该连接类型的类可以覆盖此方法并使解析短路。

        参数
        name - 标题字段的名称。
        Default - 默认值。
        结果
        该字段的值被解析为日期。 如果字段丢失或格式错误，则返回Default参数的值。

      • getHeaderFieldKey

        public String getHeaderFieldKey​(int n)
        返回的关键n th头字段。 如果少于n+1字段，则返回null 。
        参数
        n - 一个索引，其中 n>=0
        结果
        键为 n th头字段，或者 null ，如果有不是较少 n+1字段。

      • getHeaderField

        public String getHeaderField​(int n)
        返回的值n th头字段。 如果少于n+1字段，则返回null 。

        该方法可以与getHeaderFieldKey方法结合使用，以遍历消息中的所有头。

        参数
        n - 一个索引，其中 n>=0
        结果
        所述的值 n th头字段或 null ，如果有少于 n+1字段
        另请参见：
        getHeaderFieldKey(int)

      • getContent

        public Object getContent​()
                  throws IOException
        检索此URL连接的内容。

        该方法首先通过调用getContentType方法来确定对象的内容类型。 如果这是应用程序第一次看到特定内容类型，则会创建该内容类型的内容处理程序。

        这样做如下：

        1. 如果应用程序使用setContentHandlerFactory方法设置了内容处理程序工厂实例，那么createContentHandler内容类型作为参数调用该实例的createContentHandler方法; 结果是该内容类型的内容处理程序。
        2. 如果还没有设置ContentHandlerFactory ，或者如果工厂的createContentHandler方法返回null ，则使用ServiceLoader机制来使用系统类加载器来定位ContentHandlerFactory实现。 工厂所在的订单是具体实施，实施可以自由地缓存位于工厂的工厂。 一个ServiceConfigurationError ， Error或者RuntimeException从抛出createContentHandler ，如果遇到，将传播到调用线程。 每个工厂的createContentHandler方法（如果被实例化）都被调用，内容类型，直到工厂返回非空，或者所有工厂都已用尽。
        3. 否则，此方法尝试加载由ContentHandler定义的内容处理程序类。 如果类不存在，或者不是ContentHandler的子类，那么抛出一个UnknownServiceException 。
        结果
        提取对象。 应使用instanceof操作符来确定返回的对象的具体类型。
        异常
        IOException - 如果在获取内容时发生I / O错误。
        UnknownServiceException - 如果协议不支持内容类型。
        另请参见：
        ContentHandlerFactory.createContentHandler(java.lang.String) ，
getContentType() ，
setContentHandlerFactory(java.net.ContentHandlerFactory)

      • getContent

        public Object getContent​(Class<?>[] classes)
                  throws IOException
        检索此URL连接的内容。
        参数
        classes - 表示请求的类型的 Class数组
        结果
        提取的对象是类数组中指定类型的第一个匹配项。 如果不支持请求的类型，则为null。 应该使用instanceof操作符来确定返回的对象的具体类型。
        异常
        IOException - 如果在获取内容时发生I / O错误。
        UnknownServiceException - 如果协议不支持内容类型。
        从以下版本开始：
        1.3
        另请参见：
        getContent() ，
ContentHandlerFactory.createContentHandler(java.lang.String) ，
getContent(java.lang.Class[]) ，
setContentHandlerFactory(java.net.ContentHandlerFactory)

      • getPermission

        public Permission getPermission​()
                         throws IOException
        返回一个权限对象，该对象表示创建此对象所表示的连接所需的权限。 如果不需要权限进行连接，此方法返回null。 默认情况下，此方法返回java.security.AllPermission 。 子类应该覆盖此方法，并返回最能代表连接到URL所需的权限的权限。 例如， URLConnection表示file: URL将返回java.io.FilePermission对象。

        返回的权限可能取决于连接的状态。 例如，连接前的许可可能与连接后的许可不同。 例如，HTTP服务器（如foo.com）可能将连接重定向到不同的主机，例如bar.com。 连接之前连接权限将代表连接到foo.com所需的权限，连接后返回的权限将是bar.com。

        权限通常用于两个目的：保护通过URLConnections获取的对象的缓存，并检查收件人了解特定URL的权限。 在第一种情况下，在获得对象后应该获得许可。 例如，在HTTP连接中，这将表示连接到最终获取数据的主机的权限。 在第二种情况下，应在连接前获得并测试许可。

        结果
        表示由该URLConnection表示的连接所需的权限的许可对象。
        异常
        IOException - 如果权限的计算需要网络或文件I / O，并在计算时发生异常。

      • getInputStream

        public InputStream getInputStream​()
                           throws IOException
        返回从此打开的连接读取的输入流。 如果读取超时在数据可用于读取之前超时，则可以从返回的输入流中读取SocketTimeoutException。
        结果
        从这个打开的连接读取的输入流。
        异常
        IOException - 如果在创建输入流时发生I / O错误。
        UnknownServiceException - 如果协议不支持输入。
        另请参见：
        setReadTimeout(int) ， getReadTimeout()

      • getOutputStream

        public OutputStream getOutputStream​()
                             throws IOException
        返回写入此连接的输出流。
        结果
        一个写入此连接的输出流。
        异常
        IOException - 如果在创建输出流时发生I / O错误。
        UnknownServiceException - 如果协议不支持输出。

      • toString

        public String toString​()
        返回此URL连接的 String表示。
        重写：
        toString在 Object
        结果
        这个 URLConnection的字符串表示 URLConnection 。

      • setDoInput

        public void setDoInput​(boolean doinput)
        将此URLConnection的doInput字段的值设置为指定值。

        URL连接可用于输入和/或输出。 如果您打算使用URL连接进行输入，请将DoInput标志设置为true，否则返回false。 默认值为true。

        参数
        doinput - 新的价值。
        异常
        IllegalStateException - 如果已连接
        另请参见：
        doInput ， getDoInput()

      • getDoInput

        public boolean getDoInput​()
        返回这个 URLConnection的 doInput标志的值。
        结果
        该值为 URLConnection的 doInput标志。
        另请参见：
        setDoInput(boolean)

      • setDoOutput

        public void setDoOutput​(boolean dooutput)
        将此URLConnection的doOutput字段的值设置为指定值。

        URL连接可用于输入和/或输出。 如果您打算使用URL连接输出，请将DoOutput标志设置为true，否则返回false。 默认值为false。

        参数
        dooutput - 新的价值。
        异常
        IllegalStateException - 已连接
        另请参见：
        getDoOutput()

      • getDoOutput

        public boolean getDoOutput​()
        返回此值 URLConnection的 doOutput标志。
        结果
        该值为 URLConnection的 doOutput标志。
        另请参见：
        setDoOutput(boolean)

      • setAllowUserInteraction

        public void setAllowUserInteraction​(boolean allowuserinteraction)
        设置这个 URLConnection的 allowUserInteraction字段的 URLConnection 。
        参数
        allowuserinteraction - 新值。
        异常
        IllegalStateException - 如果已经连接
        另请参见：
        getAllowUserInteraction()

      • getAllowUserInteraction

        public boolean getAllowUserInteraction​()
        返回此对象的 allowUserInteraction字段的值。
        结果
        该对象的 allowUserInteraction字段的值。
        另请参见：
        setAllowUserInteraction(boolean)

      • setDefaultAllowUserInteraction

        public static void setDefaultAllowUserInteraction​(boolean defaultallowuserinteraction)
        将所有将来的 URLConnection对象的 allowUserInteraction字段的默认值设置为指定的值。
        参数
        defaultallowuserinteraction - 新值。
        另请参见：
        getDefaultAllowUserInteraction()

      • getDefaultAllowUserInteraction

        public static boolean getDefaultAllowUserInteraction​()
        返回allowUserInteraction字段的默认值。

        默认是“粘性”，是所有URLConnections的静态状态的一部分。 此标志适用于下一个，以及创建的所有以下URLConnections。

        结果
        默认值为 allowUserInteraction字段。
        另请参见：
        setDefaultAllowUserInteraction(boolean)

      • setUseCaches

        public void setUseCaches​(boolean usecaches)
        将此URLConnection的useCaches字段的值设置为指定值。

        一些协议执行缓存文档。 偶尔，重要的是能够“通过”并忽略高速缓存（例如浏览器中的“重新加载”按钮）。 如果连接上的UseCaches标志为true，则允许连接使用任何可以缓存的缓存。 如果是false，缓存将被忽略。 默认值来自DefaultUseCaches，默认值为true。 也可以使用setDefaultUseCaches(String,boolean)设置每个协议的默认值。

        参数
        usecaches - 表示是否允许缓存的 boolean
        异常
        IllegalStateException - 如果已连接
        另请参见：
        getUseCaches()

      • getUseCaches

        public boolean getUseCaches​()
        返回此 URLConnection的 useCaches字段的值。
        结果
        该值为 URLConnection的 useCaches字段。
        另请参见：
        setUseCaches(boolean)

      • setIfModifiedSince

        public void setIfModifiedSince​(long ifmodifiedsince)
        将此 URLConnection的 ifModifiedSince字段的值设置为指定值。
        参数
        ifmodifiedsince - 新值。
        异常
        IllegalStateException - 如果已连接
        另请参见：
        getIfModifiedSince()

      • getIfModifiedSince

        public long getIfModifiedSince​()
        返回此对象的 ifModifiedSince字段的值。
        结果
        该对象的 ifModifiedSince字段。
        另请参见：
        setIfModifiedSince(long)

      • getDefaultUseCaches

        public boolean getDefaultUseCaches​()
        返回默认值为URLConnection的useCaches标志。

        这个默认值是“粘性”，是所有URLConnections的静态状态的一部分。 此标志适用于下一个，以及创建的所有以下URLConnections。 每个协议可以使用setDefaultUseCaches(String,boolean)覆盖此默认值

        结果
        默认值为 useCaches标志为 URLConnection 。
        另请参见：
        setDefaultUseCaches(boolean)

      • setDefaultUseCaches

        public void setDefaultUseCaches​(boolean defaultusecaches)
        将useCaches字段的默认值设置为指定值。 使用setDefaultUseCaches(String,boolean)，每个协议可以覆盖此默认值
        参数
        defaultusecaches - 新值。
        另请参见：
        getDefaultUseCaches()

      • setDefaultUseCaches

        public static void setDefaultUseCaches​(String protocol,
                                       boolean defaultVal)
        将命名协议的useCaches字段的默认值设置为给定值。 该值将覆盖给定协议的setDefaultUseCaches(boolean)设置的任何默认设置。 对此方法的连续调用会更改设置，并影响该协议的所有未来连接的默认值。 协议名称不区分大小写。
        参数
        protocol - 设置默认的协议
        defaultVal - 是否为给定协议默认启用高速缓存
        从以下版本开始：
        9

      • getDefaultUseCaches

        public static boolean getDefaultUseCaches​(String protocol)
        返回给定协议的useCaches标志的默认值。 如果为给定协议调用了setDefaultUseCaches(String,boolean) ，则返回该值。 否则，如果调用了setDefaultUseCaches(boolean) ，则返回该值。 如果两个方法都没有被调用，则返回值为true 。 协议名称不区分大小写。
        参数
        protocol - 需要其defaultUseCaches设置的协议
        结果
        给定协议的默认值为 useCaches标志。
        从以下版本开始：
        9

      • setRequestProperty

        public void setRequestProperty​(String key,
                               String value)
        设置一般请求属性。 如果具有密钥的属性已存在，则使用新值覆盖其值。

        注意：HTTP需要所有请求属性，它们可以合法地使用相同键的多个实例来使用逗号分隔的列表语法，这样可以将多个属性附加到单个属性中。

        参数
        key - 请求已知的关键字（例如，“ Accept ”）。
        value - 与之相关联的值。
        异常
        IllegalStateException - 如果已连接
        NullPointerException - 如果键是 null
        另请参见：
        getRequestProperty(java.lang.String)

      • addRequestProperty

        public void addRequestProperty​(String key,
                               String value)
        添加由键值对指定的一般请求属性。 此方法不会覆盖与相同键相关联的现有值。
        参数
        key - 请求已知的关键字（例如，“ Accept ”）。
        value - 与之相关联的值。
        异常
        IllegalStateException - 如果已连接
        NullPointerException - 如果键为空
        从以下版本开始：
        1.4
        另请参见：
        getRequestProperties()

      • getRequestProperty

        public String getRequestProperty​(String key)
        返回此连接的命名的常规请求属性的值。
        参数
        key - 请求已知的关键字（例如，“接受”）。
        结果
        此连接的命名的常规请求属性的值。 如果key为null，则返回null。
        异常
        IllegalStateException - 如果已经连接
        另请参见：
        setRequestProperty(java.lang.String, java.lang.String)

      • getRequestProperties

        public Map<String,List<String>> getRequestProperties​()
        返回此连接的一般请求属性的不可修改映射。 地图键是表示请求头字段名称的字符串。 每个Map值是一个不可修改的字符串列表，表示相应的字段值。
        结果
        该连接的一般请求属性的映射。
        异常
        IllegalStateException - 如果已经连接
        从以下版本开始：
        1.4

      • setDefaultRequestProperty

        @Deprecated
public static void setDefaultRequestProperty​(String key,
                                             String value)
        已过时。 在获得适当的URLConnection实例之后，应该使用实例特定的setRequestProperty方法。 调用此方法将不起作用。
        设置一般请求属性的默认值。 创建URLConnection ，将使用这些属性进行初始化。
        参数
        key - 请求已知的关键字（例如，“ Accept ”）。
        value - 与密钥相关联的值。
        另请参见：
        setRequestProperty(java.lang.String,java.lang.String) ， getDefaultRequestProperty(java.lang.String)

      • getDefaultRequestProperty

        @Deprecated
public static String getDefaultRequestProperty​(String key)
        已过时。 在获得适当的URLConnection实例之后，应该使用实例特定的getRequestProperty方法。
        返回默认请求属性的值。 为每个连接设置默认请求属性。
        参数
        key - 请求已知的关键字（例如，“接受”）。
        结果
        指定键的默认请求属性的值。
        另请参见：
        getRequestProperty(java.lang.String) ， setDefaultRequestProperty(java.lang.String, java.lang.String)

      • setContentHandlerFactory

        public static void setContentHandlerFactory​(ContentHandlerFactory fac)
        设置应用程序的ContentHandlerFactory 。 应用程序最多可以调用一次。

        ContentHandlerFactory实例用于从内容类型构造内容处理程序

        如果有安全管理员，则该方法首先调用安全管理员的checkSetFactory方法，以确保操作是允许的。 这可能会导致SecurityException。

        参数
        fac - 所需的工厂。
        异常
        Error - 如果工厂已经被定义了。
        SecurityException - 如果存在安全管理员，并且其 checkSetFactory方法不允许该操作。
        另请参见：
        ContentHandlerFactory ， getContent() ， SecurityManager.checkSetFactory()

      • guessContentTypeFromName

        public static String guessContentTypeFromName​(String fname)
        根据URL的指定“文件”组件，尝试确定对象的内容类型。 这是可以覆盖getContentType方法的子类使用的getContentType方法。
        参数
        fname - 一个文件名。
        结果
        根据其文件名，猜测对象的内容类型。
        另请参见：
        getContentType()

      • guessContentTypeFromStream

        public static String guessContentTypeFromStream​(InputStream is)
                                         throws IOException
        根据输入流开头的字符，尝试确定输入流的类型。 该方法可以覆盖getContentType方法的子类使用。

        理想情况下，不需要这个程序。 但是许多http服务器返回不正确的内容类型; 此外，还有许多非标准扩展。 直接检查字节以确定内容类型通常比相信http服务器声明的内容类型更准确。

        参数
        is - 支持标记的输入流。
        结果
        内容类型的猜测，或 null如果无法确定。
        异常
        IOException - 读取输入流时是否发生I / O错误。
        另请参见：
        InputStream.mark(int) ，
InputStream.markSupported() ，
getContentType()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement
For further API reference and developer documentation see the Java SE Documentation, which contains more detailed, developer-targeted descriptions with conceptual overviews, definitions of terms, workarounds, and working code examples.


URLDecoder (Java SE 9 & JDK 9 )

  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class URLDecoder

  • java.lang.Object
    • java.net.URLDecoder

  • public class URLDecoder
extends Object
    HTML表单解码的实用类。 此类包含从application/x-www-form-urlencoded MIME格式解码字符串的静态方法。

    转换过程与URLEncoder类使用的转换过程相反。 假设编码字符串中的所有字符都是以下之一：“ a ”至“ z ”，“ A ”至“ Z ”，“ 0 ”至“ 9 ”和“ - ”，“ _ ”，“ . “和” * “。 字符“ % ”被允许，但被解释为特殊转义序列的开始。

    在转换中应用以下规则：

    • “ a ”至“ z ”，“ A ”至“ Z ”和“ 0 ”至“ 9 ”中的字母数字字符保持不变。
    • 特殊字符“ . ”，“ - ”，“ * ”和“ _ ”保持不变。
    • 加号“ + ”被转换为空格字符“”。
    • 格式“ %xy ”的序列将被视为表示一个字节，其中xy是8位的两位十六进制表示。 然后，连续包含这些字节序列中的一个或多个的所有子字符串将被编码将导致这些连续字节的字符替换。 可以指定用于解码这些字符的编码方案，或者如果未指定，则将使用平台的默认编码。

    解码器可以处理非法字符串的两种可能方式。 它可以单独留下非法字符，也可以抛出一个IllegalArgumentException 。 解码器采用的方法是实现。

    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      URLDecoder​()

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static String decode​(String s)
      已过时。
      结果字符串可能会因平台的默认编码而异。 而是使用decode（String，String）方法来指定编码。
      static String decode​(String s, String enc)
      使用特定的编码方案解码 application/x-www-form-urlencoded字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • URLDecoder

        public URLDecoder​()

    • 方法详细信息

      • decode

        @Deprecated
public static String decode​(String s)
        已过时。 结果字符串可能会因平台的默认编码而异。 而是使用decode（String，String）方法来指定编码。
        解码x-www-form-urlencoded字符串。 平台的默认编码用于确定由“ %xy ”形式的任何连续序列表示的字符。
        参数
        s - 要解码的 String
        结果
        新解码的 String

      • decode

        public static String decode​(String s,
                            String enc)
                     throws UnsupportedEncodingException
        使用特定的编码方案解码application/x-www-form-urlencoded字符串。 提供的编码用于确定由“ %xy ”形式的任何连续序列表示的字符。

        注意： World Wide Web Consortium Recommendation规定应使用UTF-8。 不这样做可能会引起不兼容。

        参数
        s - 要解码的 String
        enc - 支持的名称 character encoding 。
        结果
        新解码的 String
        异常
        UnsupportedEncodingException - 如果需要查询字符编码，但不支持命名字符编码
        从以下版本开始：
        1.4
        另请参见：
        URLEncoder.encode(java.lang.String, java.lang.String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


URLEncoder (Java SE 9 & JDK 9 )

  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class URLEncoder

  • java.lang.Object
    • java.net.URLEncoder

  • public class URLEncoder
extends Object
    HTML表单编码的实用类。 这个类包含一个字符串转换为静态方法application/x-www-form-urlencoded MIME格式。 有关HTML表单编码的更多信息，请参阅HTML specification 。

    编码字符串时，适用以下规则：

    • “ a ”至“ z ”，“ A ”至“ Z ”和“ 0 ”至“ 9 ”的字母数字字符保持不变。
    • 特殊字符“ . ”，“ - ”，“ * ”和“ _ ”保持不变。
    • 空格字符“”被转换为加号“ + ”。
    • 所有其他字符都不安全，并且首先使用一些编码方案将其转换为一个或多个字节。 然后每个字节由3个字符串“ %xy ”表示，其中xy是字节的两位十六进制表示。 推荐使用的编码方案是UTF-8。 但是，出于兼容性原因，如果未指定编码，则使用平台的默认编码。

    例如，使用UTF-8作为编码方案，字符串“Ã@ foo-bar”将被转换为“The + string +％C3％BC％40foo-bar”，因为在UTF-8中，字符¼被编码为2字节C3（十六进制）和BC（十六进制），字符@被编码为一个字节40（十六进制）。

    从以下版本开始：
    1.0

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static String encode​(String s)
      已过时。
      结果字符串可能会因平台的默认编码而异。 而是使用encode（String，String）方法来指定编码。
      static String encode​(String s, String enc)
      使用特定的编码方案将字符串转换为 application/x-www-form-urlencoded格式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • encode

        @Deprecated
public static String encode​(String s)
        已过时。 结果字符串可能会因平台的默认编码而异。 而是使用encode（String，String）方法来指定编码。
        将字符串转换为x-www-form-urlencoded格式。 该方法使用平台的默认编码作为编码方案来获取不安全字符的字节。
        参数
        s - String待翻译。
        结果
        翻译 String 。

      • encode

        public static String encode​(String s,
                            String enc)
                     throws UnsupportedEncodingException
        使用特定的编码方案将字符串转换为application/x-www-form-urlencoded格式。 此方法使用提供的编码方案来获取不安全字符的字节。

        注意： World Wide Web Consortium Recommendation规定应使用UTF-8。 不这样做可能会引起不兼容。

        参数
        s - String待翻译。
        enc - 支持的名称 character encoding 。
        结果
        翻译 String 。
        异常
        UnsupportedEncodingException - 如果不支持命名编码
        从以下版本开始：
        1.4
        另请参见：
        URLDecoder.decode(java.lang.String, java.lang.String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


URLPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class URLPermission

  • java.lang.Object
    • java.security.Permission
      • java.net.URLPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class URLPermission
extends Permission
    表示访问由给定网址定义的资源或资源集的权限，以及给定的一组用户可设置的请求方法和请求标头。 权限的名称是url字符串。 actions字符串是请求方法和标题的连接。 方法和标题名称的范围不受此类限制。

    网址

    url字符串具有以下预期结构。

      scheme : // authority [ / path ]
    方案通常是http或https，但不受此类限制。 权限被指定为：
      authority = [ userinfo @ ] hostrange [ : portrange ]
     portrange = portnumber | -portnumber | portnumber-[portnumber] | *
     hostrange = ([*.] dnsname) | IPv4address | IPv6address
    dnsname是标准的DNS主机或域名，即。 一个或多个标签用“。”分隔。 IPv4address是一个标准的文字IPv4地址和IPv6address限定如RFC 2732 。 但是，文字IPv6地址必须用'[]'字符括起来。 dnsname规范前面可以有“*”。 这意味着名称将匹配其最右域名标签与此名称相同的任何主机名。 例如，“* .oracle.com”匹配“foo.bar.oracle.com”

    portrange用于指定端口号，或此限制适用于的有限或无限制的端口范围。 如果portrange不存在或无效，则如果方案为http （默认为80）或https （默认为443），则假定使用默认端口号。 其他方案没有默认值。 可以指定通配符，这意味着所有端口。

    userinfo是可选的。 如果存在userinfo组件，则在创建URLPermission时将被忽略，并且不影响此类定义的任何其他方法。

    路径组件包括由“/”字符分隔的路段段序列。 路径也可能是空的。 路径以类似于FilePermission中的路径的方式指定。 以下示例显示了三种不同的方式：

    URL Examples Example url Description http://www.oracle.com/a/b/c.html A url which identifies a specific (single) resource http://www.oracle.com/a/b/* The '*' character refers to all resources in the same "directory" - in other words all resources with the same number of path components, and which only differ in the final path component, represented by the '*'. http://www.oracle.com/a/b/- The '-' character refers to all resources recursively below the preceding path (eg. http://www.oracle.com/a/b/c/d/e.html matches this example).

    '*'和' - '只能在路径的最后一段中指定，并且必须是该段中唯一的字符。 构造URLPermissions时，URL的任何查询或片段组件都将被忽略。

    作为一个特殊情况，形式的“scheme：*”形式的URL被认为是给定方案的任何url。

    url字符串的方案和权限组件被处理，而不考虑情况。 这意味着equals(Object) ， hashCode()和implies(Permission)区分相对于这些成分不敏感的。 如果权限包含字面IP地址，则该地址被标准化以进行比较。 路径组件区分大小写。

    动作字符串

    URLPermission的操作字符串是方法列表和请求标头列表的连接 。 这些是允许的请求方法和允许的请求头（分别）的列表。 两个列表用冒号“：”分隔，每个列表的元素都以逗号分隔。 一些例子是：

      "POST,GET,DELETE"
         "GET:X-Foo-Request,X-Bar-Request"
         "POST,GET:Header1,Header2"
    第一个示例指定了以下方法：POST，GET和DELETE，但没有请求头。 第二个示例指定一个请求方法和两个头。 第三个示例指定两个请求方法和两个头。

    如果请求头列表为空，则不需要存在冒号分隔符。 动作字符串中不允许有空格。 提供给URLPermission构造函数的操作字符串不区分大小写，通过将方法名称转换为大写和标题名称到RFC2616中定义的格式（每个单词大写的小写字母）进行标准化。 任一列表都可以包含一个通配符'*'字符，分别表示所有请求方法或头。

    注意。 根据使用的上下文，可以随时允许一些请求方法和标题，并且其他可能在任何时候都不被允许。 例如，HTTP协议处理程序可能不允许某些标头（如Content-Length）由应用程序代码设置，而不管有效的安全策略是否允许。

    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      URLPermission​(String url)
      使用给定的url字符串和无限制的方法创建一个URLPermission，并通过调用两个参数构造函数来请求头，如下所示：URLPermission（url，“*：*”）
      URLPermission​(String url, String actions)
      从url字符串创建一个新的URLPermission，并允许给定的请求方法和用户可设置的请求头。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object p)
      如果this.getActions（）。equals（p.getActions（））和p的url等于这个url，则返回true。
      String getActions​()
      返回标准化方法列表和请求头列表，格式如下：
      int hashCode​()
      返回从动作字符串和url字符串的哈希码计算的哈希码。
      boolean implies​(Permission p)
      检查此URLPermission是否意味着给定的权限。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, newPermissionCollection, toString

    • 构造方法详细信息

      • URLPermission

        public URLPermission​(String url,
                     String actions)
        从url字符串创建一个新的URLPermission，并允许给定的请求方法和用户可设置的请求头。 权限的名称是与其一起创建的url字符串。 只有url的方案，权限和路径组件在内部使用。 任何片段或查询组件都将被忽略。 权限操作字符串如上所述。
        参数
        url - url字符串
        actions - 操作字符串
        异常
        IllegalArgumentException - 如果网址无效或动作包含空格。

      • URLPermission

        public URLPermission​(String url)
        使用给定的url字符串和无限制的方法创建一个URLPermission，并通过调用两个参数构造函数来请求头，如下所示：URLPermission（url，“*：*”）
        参数
        url - url字符串
        异常
        IllegalArgumentException - 如果网址不会导致有效的URI

    • 方法详细信息

      • getActions

        public String getActions​()
        返回标准化方法列表和请求头列表，格式如下：
          "method-names : header-names"

        其中method-names是由逗号分隔的方法列表，header-names是允许的标题列表，以逗号分隔。 返回的String中没有空格。 如果标题名为空，则冒号分隔符可能不存在。

        Specified by:
        getActions在 Permission
        结果
        这个权限的动作。

      • implies

        public boolean implies​(Permission p)
        检查此URLPermission是否意味着给定的权限。 具体来说，按照以下顺序进行以下检查：
        • 如果'p'不是URLPermission的实例，则返回false
        • 如果这个方法列表中没有p的方法，并且如果这个方法列表不等于“*”，那么返回false。
        • 如果任何p的头部不在此请求头列表中，并且如果此请求头列表不等于“*”，则返回false。
        • 如果这个url方案不等于p的url方案返回false
        • 如果这个url的具体部分是'*'返回true
        • 如果由p的url hostrange定义的主机集不是这个url hostrange的一个子集，那么返回false。 例如，“* .foo.oracle.com”是“* .oracle.com”的子集。 “foo.bar.oracle.com”不是“* .foo.oracle.com”的子集
        • 如果由p的url定义的portrange不是由该URL定义的portrange的子集，则返回false。
        • 如果由p的url指定的路径或路径包含在由此URL指定的路径集中，则返回true
        • 否则返回false

        路径匹配的一些示例如下所示：

        Examples of Path Matching this's path p's path match /a/b /a/b yes /a/b/* /a/b/c yes /a/b/* /a/b/c/d no /a/b/- /a/b/c/d yes /a/b/- /a/b/c/d/e yes /a/b/- /a/b/c/* yes /a/b/* /a/b/c/- no
        Specified by:
        implies在 Permission
        参数
        p - 允许检查。
        结果
        如果此对象隐含指定的权限，则为true，否则为false。

      • equals

        public boolean equals​(Object p)
        如果this.getActions（）。equals（p.getActions（））和p的url等于这个url，则返回true。 否则返回false。
        Specified by:
        equals在 Permission
        参数
        p - 我们正在测试与此对象相等的对象。
        结果
        如果两个Permission对象都是等效的，则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回从动作字符串和url字符串的哈希码计算的哈希码。
        Specified by:
        hashCode在 Permission
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


URLStreamHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class URLStreamHandler

  • java.lang.Object
    • java.net.URLStreamHandler

  • public abstract class URLStreamHandler
extends Object
    抽象类URLStreamHandler是所有流协议处理程序的公共超类。 流协议处理程序知道如何为特定协议类型建立连接，例如http或https 。

    在大多数情况下， URLStreamHandler子类的实例不是由应用程序直接创建的。 相反，在构建URL时，首次遇到协议名称，相应的流协议处理程序将自动加载。

    从以下版本开始：
    1.0
    另请参见：
    URL(java.lang.String, java.lang.String, int, java.lang.String)

    • 构造方法摘要

      构造方法
      Constructor 描述
      URLStreamHandler​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      protected boolean equals​(URL u1, URL u2)
      提供默认的equals计算。
      protected int getDefaultPort​()
      返回此处理程序解析的URL的默认端口。
      protected InetAddress getHostAddress​(URL u)
      获取我们的主机的IP地址。
      protected int hashCode​(URL u)
      提供默认散列计算。
      protected boolean hostsEqual​(URL u1, URL u2)
      比较两个URL的主机组件。
      protected abstract URLConnection openConnection​(URL u)
      打开与 URL参数引用的对象的连接。
      protected URLConnection openConnection​(URL u, Proxy p)
      与openConnection（URL）相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
      protected void parseURL​(URL u, String spec, int start, int limit)
      将 URL的字符串表示法 URL为 URL对象。
      protected boolean sameFile​(URL u1, URL u2)
      比较两个URL以查看它们是否引用相同的文件，即具有相同的协议，主机，端口和路径。
      protected void setURL​(URL u, String protocol, String host, int port, String file, String ref)
      已过时。
      使用setURL（URL，String，String，int，String，String，String，String）;
      protected void setURL​(URL u, String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)
      将 URL参数的字段设置为指示的值。
      protected String toExternalForm​(URL u)
      一个转换 URL特定协议到的 String 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • URLStreamHandler

        public URLStreamHandler​()

    • 方法详细信息

      • openConnection

        protected abstract URLConnection openConnection​(URL u)
                                         throws IOException
        打开与URL参数引用的对象的连接。 这个方法应该被一个子类覆盖。

        如果对于处理程序的协议（例如HTTP或JAR），则存在属于以下软件包或其子包之一的公共专用URLConnection子类：java.lang，java.io，java.util，java.net，返回的连接将是该子类。 例如，对于HTTP，将返回一个HttpURLConnection，对于JAR，将返回一个JarURLConnection。

        参数
        u - 连接到的URL。
        结果
        一个 URLConnection对象为 URL 。
        异常
        IOException - 如果在打开连接时发生I / O错误。

      • openConnection

        protected URLConnection openConnection​(URL u,
                                       Proxy p)
                                throws IOException
        与openConnection（URL）相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。 调用此方法可抢占系统默认的ProxySelector设置。
        参数
        u - 连接到的URL。
        p - 将通过其连接的代理。 如果需要直接连接，则应指定Proxy.NO_PROXY。
        结果
        一个 URLConnection对象为 URL 。
        异常
        IOException - 如果在打开连接时发生I / O错误。
        IllegalArgumentException - 如果u或p为空，或者p的类型为错误。
        UnsupportedOperationException - 如果实现协议的子类不支持此方法。
        从以下版本开始：
        1.5

      • parseURL

        protected void parseURL​(URL u,
                        String spec,
                        int start,
                        int limit)
        将URL的字符串表示解析为URL对象。

        如果有任何继承的上下文，那么它已被复制到URL参数中。

        该parseURL的方法URLStreamHandler解析字符串表示，好像它是一个http规范。 大多数URL协议族具有类似的解析。 具有不同语法的协议的流协议处理程序必须覆盖此例程。

        参数
        u - URL接收解析规范的结果。
        spec - 表示必须解析的URL的 String 。
        start - 开始解析的字符索引。 这只是通过' : '（如果有的话）指定协议名称的确定。
        limit - 停止解析的字符位置。 这是字符串的结尾或“ # ”字符的位置（如果存在）。 尖锐标志后的所有信息表示锚点。

      • getDefaultPort

        protected int getDefaultPort​()
        返回此处理程序解析的URL的默认端口。 该方法意图被默认端口号的处理程序覆盖。
        结果
        此处理程序解析的 URL的默认端口。
        从以下版本开始：
        1.3

      • equals

        protected boolean equals​(URL u1,
                         URL u2)
        提供默认的equals计算。 对于对equals（）有不同要求的其他协议可能会被处理程序所掩盖。 该方法要求它的参数都不为空。 这是由java.net.URL类调用的事实来保证的。
        参数
        u1 - 一个URL对象
        u2 - 一个URL对象
        结果
        true如果两个网址被认为是相等的，即 它们引用同一文件中的相同片段。
        从以下版本开始：
        1.3

      • hashCode

        protected int hashCode​(URL u)
        提供默认散列计算。 对于对hashCode计算有不同要求的其他协议，可能会被处理程序覆盖。
        参数
        u - 一个URL对象
        结果
        一个 int适合哈希表索引
        从以下版本开始：
        1.3

      • sameFile

        protected boolean sameFile​(URL u1,
                           URL u2)
        比较两个URL以查看它们是否引用相同的文件，即具有相同的协议，主机，端口和路径。 该方法要求它的参数都不为空。 这是由java.net.URL类间接调用的事实来保证的。
        参数
        u1 - 一个URL对象
        u2 - 一个URL对象
        结果
        如果u1和u2指的是同一个文件，则为true
        从以下版本开始：
        1.3

      • getHostAddress

        protected InetAddress getHostAddress​(URL u)
        获取我们的主机的IP地址。 空主机字段或DNS故障将导致空返回。
        参数
        u - 一个URL对象
        结果
        一个表示主机IP地址的 InetAddress 。
        从以下版本开始：
        1.3

      • hostsEqual

        protected boolean hostsEqual​(URL u1,
                             URL u2)
        比较两个URL的主机组件。
        参数
        u1 - 要比较的第一个主机的URL
        u2 - 要比较的第二个主机的URL
        结果
        true如果且仅当它们相等时，否则为 false 。
        从以下版本开始：
        1.3

      • toExternalForm

        protected String toExternalForm​(URL u)
        将 URL的特定协议转换为 String 。
        参数
        u - 网址。
        结果
        一个字符串表示的 URL参数。

      • setURL

        protected void setURL​(URL u,
                      String protocol,
                      String host,
                      int port,
                      String authority,
                      String userInfo,
                      String path,
                      String query,
                      String ref)
        将URL参数的字段设置为指示的值。 只有派生自URLStreamHandler的类能够使用此方法来设置URL字段的值。
        参数
        u - 要修改的URL。
        protocol - 协议名称。
        host - URL的远程主机值。
        port - 远程机器上的端口。
        authority - URL的权限部分。
        userInfo - userInfo的一部分URL。
        path - URL的路径组件。
        query - URL的查询部分。
        ref - 参考。
        异常
        SecurityException - 如果URL的协议处理程序与此不同
        从以下版本开始：
        1.3
        另请参见：
        URL.set(java.lang.String, java.lang.String, int, java.lang.String, java.lang.String)

      • setURL

        @Deprecated
protected void setURL​(URL u,
                      String protocol,
                      String host,
                      int port,
                      String file,
                      String ref)
        已过时。 使用setURL（URL，String，String，int，String，String，String，String）;
        将URL参数的字段设置为指示的值。 只有派生自URLStreamHandler的类能够使用此方法来设置URL字段的值。
        参数
        u - 要修改的URL。
        protocol - 协议名称。 自1.2以来，此值将被忽略。
        host - URL的远程主机值。
        port - 远程机器上的端口。
        file - 该文件。
        ref - 参考。
        异常
        SecurityException - 如果URL的协议处理程序与此不同
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


URLStreamHandlerFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface URLStreamHandlerFactory

  • 所有已知实现类：
    URLStreamHandlerProvider

    public interface URLStreamHandlerFactory
    该界面为URL流协议处理程序定义了工厂。

    使用URL constructor中指定的URL流处理程序工厂。

    从以下版本开始：
    1.0
    另请参见：
    URL ， URLStreamHandler

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      URLStreamHandler createURLStreamHandler​(String protocol)
      创建具有指定协议的新的 URLStreamHandler实例。

    • 方法详细信息

      • createURLStreamHandler

        URLStreamHandler createURLStreamHandler​(String protocol)
        使用指定的协议创建一个新的 URLStreamHandler实例。
        参数
        protocol - 协议（“ ftp ”，“ http ”，“ nntp ”等）。
        结果
        一个 URLStreamHandler的特定协议，或 null如果这个工厂不能创建一个特定协议的处理程序
        另请参见：
        URLStreamHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.net (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.net

  • Packages that use java.net
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.security.auth.login
    提供Configuration的实现。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.net.spi
    java.net包的服务提供商类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。
    java.rmi
    提供RMI包。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.activation
    javax.imageio
    Java Image I / O API的主要包。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.net
    提供网络应用程序的类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.midi.spi
    为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sound.sampled.spi
    为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的课程。
    javax.xml.validation
    提供用于验证XML文档的API。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。
    jdk.security.jarsigner
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
  • Classes in java.net used by com.sun.jarsigner
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by com.sun.net.httpserver
    Class 描述
    InetSocketAddress
    该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by com.sun.net.httpserver.spi
    Class 描述
    InetSocketAddress
    该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。
  • Classes in java.net used by com.sun.nio.sctp
    Class 描述
    InetAddress
    此类表示Internet协议（IP）地址。
    SocketAddress
    这个类代表一个没有协议附件的Socket地址。
    SocketOption
    与套接字关联的套接字选项。
  • Classes in java.net used by com.sun.security.auth.login
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by java.applet
    Class 描述
    URL
    URL类表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by java.awt
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
    URL
    类别 URL表示统一资源定位符，指向万维网上的“资源”的指针。
  • Classes in java.net used by java.awt.desktop
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by java.beans.beancontext
    Class 描述
    URL
    URL代表统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by java.io
    Class 描述
    MalformedURLException
    抛出以表示发生格式不正确的网址。
    URI
    表示统一资源标识符（URI）参考。
    URL
    URL代表统一资源定位器，指向万维网上“资源”的指针。
  • Classes in java.net used by java.lang
    Class 描述
    InetAddress
    此类表示Internet协议（IP）地址。
    URL
    URL表示统一资源定位器，指向万维网上“资源”的指针。
  • Classes in java.net used by java.lang.module
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by java.net
    Class 描述
    Authenticator
    Authenticator类代表一个知道如何获取网络连接认证的对象。
    Authenticator.RequestorType
    请求认证的实体的类型。
    CacheRequest
    表示在ResponseCache中存储资源的通道。
    CacheResponse
    代表从ResponseCache中检索资源的通道。
    ContentHandler
    抽象类 ContentHandler是从 URLConnection读取 Object的所有类的超类。
    ContentHandlerFactory
    该界面为内容处理程序定义了一个工厂。
    CookieHandler
    CookieHandler对象提供一个回调机制，将HTTP状态管理策略实现连接到HTTP协议处理程序中。
    CookiePolicy
    CookiePolicy实现决定哪些Cookie应该被接受，哪些应该被拒绝。
    CookieStore
    CookieStore对象表示Cookie的存储。
    DatagramPacket
    该类表示数据报包。
    DatagramSocket
    此类表示用于发送和接收数据报数据包的套接字。
    DatagramSocketImpl
    抽象数据报和组播套接字实现基类。
    DatagramSocketImplFactory
    该接口为数据报套接字实现定义了一个工厂。
    FileNameMap
    一个简单的界面，提供了一种在文件名和MIME类型字符串之间映射的机制。
    HttpCookie
    HttpCookie对象表示HTTP cookie，它承载服务器和用户代理之间的状态信息。
    Inet6Address
    该类表示Internet协议版本6（IPv6）地址。
    InetAddress
    此类表示Internet协议（IP）地址。
    InetSocketAddress
    该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。
    InterfaceAddress
    此类表示网络接口地址。
    MalformedURLException
    抛出以表示发生格式不正确的网址。
    NetworkInterface
    此类表示由名称组成的网络接口和分配给此接口的IP地址列表。
    PasswordAuthentication
    PasswordAuthentication类是Authenticator使用的数据持有者。
    ProtocolException
    抛出以表示底层协议有错误，如TCP错误。
    ProtocolFamily
    代表一系列通信协议。
    Proxy
    此类表示代理设置，通常是类型（http，socks）和套接字地址。
    Proxy.Type
    代表代理类型。
    ProxySelector
    选择在连接到URL引用的网络资源时使用的代理服务器（如果有）。
    ResponseCache
    表示URLConnection缓存的实现。
    ServerSocket
    这个类实现了服务器套接字。
    Socket
    该类实现客户端套接字（也称为“套接字”）。
    SocketAddress
    这个类代表一个没有协议附件的Socket地址。
    SocketException
    抛出以表示创建或访问Socket时出错。
    SocketImpl
    抽象类 SocketImpl是实际实现套接字的所有类的常用超类。
    SocketImplFactory
    该接口定义了一个工厂用于套接字实现。
    SocketOption
    与套接字关联的套接字选项。
    SocketOptions
    获取/设置套接字选项的方法的接口。
    StandardProtocolFamily
    定义通信协议的标准系列。
    UnknownHostException
    抛出以表示无法确定主机的IP地址。
    URI
    表示统一资源标识符（URI）参考。
    URISyntaxException
    检查的异常抛出以指示不能将字符串解析为URI引用。
    URL
    URL类表示统一资源定位器，指向万维网上“资源”的指针。
    URLClassLoader
    此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。
    URLConnection
    抽象类 URLConnection是表示应用程序和URL之间的通信链接的所有类的超类。
    URLStreamHandler
    抽象类 URLStreamHandler是所有流协议处理程序的公共超类。
    URLStreamHandlerFactory
    该接口为 URL流协议处理程序定义了一个工厂。
  • Classes in java.net used by java.net.spi
    Class 描述
    URLStreamHandlerFactory
    该界面为 URL流协议处理程序定义了一个工厂。
  • Classes in java.net used by java.nio.channels
    Class 描述
    DatagramSocket
    此类表示用于发送和接收数据报数据包的套接字。
    InetAddress
    此类表示Internet协议（IP）地址。
    NetworkInterface
    此类表示由名称组成的网络接口和分配给此接口的IP地址列表。
    ProtocolFamily
    代表一系列通信协议。
    ServerSocket
    这个类实现了服务器套接字。
    Socket
    该类实现客户端套接字（也称为“套接字”）。
    SocketAddress
    这个类代表一个没有协议附件的Socket地址。
    SocketOption
    与套接字关联的套接字选项。
  • Classes in java.net used by java.nio.channels.spi
    Class 描述
    ProtocolFamily
    代表一系列通信协议。
  • Classes in java.net used by java.nio.file
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by java.nio.file.spi
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by java.rmi
    Class 描述
    MalformedURLException
    抛出以表示发生格式不正确的网址。
  • Classes in java.net used by java.rmi.server
    Class 描述
    MalformedURLException
    抛出以表示发生格式不正确的网址。
    ServerSocket
    这个类实现了服务器套接字。
    Socket
    该类实现客户端套接字（也称为“套接字”）。
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by java.security
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
    URL
    URL类表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by java.security.cert
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by java.sql
    Class 描述
    URL
    URL类表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javafx.css
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javafx.fxml
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.activation
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.imageio
    Class 描述
    URL
    URL表示统一资源定位器，指向万维网上的“资源”的指针。
  • Classes in java.net used by javax.jnlp
    Class 描述
    MalformedURLException
    抛出以表示发生格式不正确的网址。
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.management.loading
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
    URLClassLoader
    此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。
    URLStreamHandlerFactory
    该界面为 URL流协议处理程序定义了一个工厂。
  • Classes in java.net used by javax.management.remote
    Class 描述
    MalformedURLException
    抛出以表示发生格式不正确的网址。
  • Classes in java.net used by javax.net
    Class 描述
    InetAddress
    此类表示Internet协议（IP）地址。
    ServerSocket
    这个类实现了服务器套接字。
    Socket
    该类实现客户端套接字（也称为“套接字”）。
    UnknownHostException
    抛出以表示无法确定主机的IP地址。
  • Classes in java.net used by javax.net.ssl
    Class 描述
    HttpURLConnection
    支持HTTP特定功能的URLConnection。
    InetAddress
    此类表示Internet协议（IP）地址。
    ServerSocket
    这个类实现了服务器套接字。
    Socket
    该类实现客户端套接字（也称为“套接字”）。
    UnknownHostException
    抛出以表示无法确定主机的IP地址。
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
    URLConnection
    抽象类 URLConnection是表示应用程序和URL之间的通信链接的所有类的超类。
  • Classes in java.net used by javax.print
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by javax.print.attribute
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by javax.print.attribute.standard
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by javax.rmi.ssl
    Class 描述
    ServerSocket
    这个类实现了服务器套接字。
    Socket
    该类实现客户端套接字（也称为“套接字”）。
  • Classes in java.net used by javax.security.auth.kerberos
    Class 描述
    InetAddress
    此类表示Internet协议（IP）地址。
  • Classes in java.net used by javax.sound.midi
    Class 描述
    URL
    类别 URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.sound.midi.spi
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.sound.sampled
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.sound.sampled.spi
    Class 描述
    URL
    URL代表统一资源定位器，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.sql
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.sql.rowset
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.sql.rowset.serial
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.swing
    Class 描述
    URL
    URL表示统一资源定位器，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.swing.event
    Class 描述
    URL
    URL表示统一资源定位器，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.swing.plaf.synth
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.swing.text.html
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.tools
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by javax.xml.bind
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
    URL
    URL类表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.xml.bind.helpers
    Class 描述
    URL
    URL类表示统一资源定位符，指向万维网上的“资源”的指针。
  • Classes in java.net used by javax.xml.catalog
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by javax.xml.validation
    Class 描述
    URL
    类别 URL表示统一资源定位符，指向万维网上的“资源”的指针。
  • Classes in java.net used by javax.xml.ws
    Class 描述
    URL
    URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.xml.ws.spi
    Class 描述
    URL
    URL类表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by javax.xml.ws.spi.http
    Class 描述
    InetSocketAddress
    该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。
  • Classes in java.net used by jdk.incubator.http
    Class 描述
    Authenticator
    Authenticator类代表一个知道如何获取网络连接认证的对象。
    CookieManager
    CookieManager提供了一个CookieHandler的具体实现， 它将 Cookie的存储与接受和拒绝Cookie的策略分开。
    ProxySelector
    选择在连接到URL引用的网络资源时使用的代理服务器（如果有）。
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by jdk.nashorn.api.scripting
    Class 描述
    URL
    URL类代表统一资源定位器，指向万维网上“资源”的指针。
  • Classes in java.net used by jdk.nashorn.api.tree
    Class 描述
    URL
    类别 URL表示统一资源定位符，指向万维网上“资源”的指针。
  • Classes in java.net used by jdk.net
    Class 描述
    DatagramSocket
    此类表示用于发送和接收数据报数据包的套接字。
    ServerSocket
    这个类实现了服务器套接字。
    Socket
    该类实现客户端套接字（也称为“套接字”）。
    SocketOption
    与套接字关联的套接字选项。
  • Classes in java.net used by jdk.security.jarsigner
    Class 描述
    URI
    表示统一资源标识符（URI）参考。
  • Classes in java.net used by org.ietf.jgss
    Class 描述
    InetAddress
    此类表示Internet协议（IP）地址。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.Authenticator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.Authenticator

  • Packages that use Authenticator
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of Authenticator in java.net

      Methods in java.net that return Authenticator
      Modifier and Type 方法 描述
      static Authenticator Authenticator.getDefault​()
      获取默认验证器。
      Methods in java.net with parameters of type Authenticator
      Modifier and Type 方法 描述
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(Authenticator authenticator, String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      询问给定的 authenticator密码。
      void HttpURLConnection.setAuthenticator​(Authenticator auth)
      提供一个Authenticator ，通过HTTP协议为此HttpURLConnection请求认证时使用。
      static void Authenticator.setDefault​(Authenticator a)
      设置代理或HTTP服务器要求进行身份验证时由网络代码使用的身份验证器。

    • Uses of Authenticator in jdk.incubator.http

      Methods in jdk.incubator.http that return types with arguments of type Authenticator
      Modifier and Type 方法 描述
      abstract Optional<Authenticator> HttpClient.authenticator​()
      返回一个Optional其中包含此客户端上的Authenticator集。
      Methods in jdk.incubator.http with parameters of type Authenticator
      Modifier and Type 方法 描述
      abstract HttpClient.Builder HttpClient.Builder.authenticator​(Authenticator a)
      设置用于HTTP身份验证的身份验证器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.Authenticator.RequestorType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.Authenticator.RequestorType

  • Packages that use Authenticator.RequestorType
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of Authenticator.RequestorType in java.net

      Methods in java.net that return Authenticator.RequestorType
      Modifier and Type 方法 描述
      protected Authenticator.RequestorType Authenticator.getRequestorType​()
      返回请求者是Proxy还是Server。
      static Authenticator.RequestorType Authenticator.RequestorType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Authenticator.RequestorType[] Authenticator.RequestorType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.net with parameters of type Authenticator.RequestorType
      Modifier and Type 方法 描述
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      请向系统注册的验证者询问密码。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(Authenticator authenticator, String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      询问给定的 authenticator密码。
      PasswordAuthentication Authenticator.requestPasswordAuthenticationInstance​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      Ask this authenticator for a password.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.BindException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.BindException

No usage of java.net.BindException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.CacheRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.CacheRequest

  • Packages that use CacheRequest
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of CacheRequest in java.net

      Methods in java.net that return CacheRequest
      Modifier and Type 方法 描述
      abstract CacheRequest ResponseCache.put​(URI uri, URLConnection conn)
      协议处理程序在检索到资源后调用此方法，ResponseCache必须决定是否将资源存储在其缓存中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.CacheResponse (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.CacheResponse

  • Packages that use CacheResponse
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of CacheResponse in java.net

      Subclasses of CacheResponse in java.net
      Modifier and Type Class 描述
      class  SecureCacheResponse
      表示最初通过安全手段（例如TLS）检索的缓存响应。
      Methods in java.net that return CacheResponse
      Modifier and Type 方法 描述
      abstract CacheResponse ResponseCache.get​(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
      根据请求的uri，请求方法和请求标头检索缓存的响应。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.ConnectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.ConnectException

No usage of java.net.ConnectException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.ContentHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.ContentHandler

  • Packages that use ContentHandler
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of ContentHandler in java.net

      Methods in java.net that return ContentHandler
      Modifier and Type 方法 描述
      ContentHandler ContentHandlerFactory.createContentHandler​(String mimetype)
      创建一个新的 ContentHandler从 URLStreamHandler读取一个对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.CookieHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.CookieHandler

  • Packages that use CookieHandler
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of CookieHandler in java.net

      Subclasses of CookieHandler in java.net
      Modifier and Type Class 描述
      class  CookieManager
      CookieManager提供了一个CookieHandler的具体实现， 它将 cookie的存储与接受和拒绝cookie的策略分开。
      Methods in java.net that return CookieHandler
      Modifier and Type 方法 描述
      static CookieHandler CookieHandler.getDefault​()
      获取系统范围的Cookie处理程序。
      Methods in java.net with parameters of type CookieHandler
      Modifier and Type 方法 描述
      static void CookieHandler.setDefault​(CookieHandler cHandler)
      设置（或取消）系统范围的Cookie处理程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.CookieManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.CookieManager

  • Packages that use CookieManager
    软件包 描述
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of CookieManager in jdk.incubator.http

      Methods in jdk.incubator.http that return types with arguments of type CookieManager
      Modifier and Type 方法 描述
      abstract Optional<CookieManager> HttpClient.cookieManager​()
      返回一个Optional ，其中包含该客户端的CookieManager 。
      Methods in jdk.incubator.http with parameters of type CookieManager
      Modifier and Type 方法 描述
      abstract HttpClient.Builder HttpClient.Builder.cookieManager​(CookieManager cookieManager)
      设置一个cookie管理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.DatagramPacket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.DatagramPacket

  • Packages that use DatagramPacket
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of DatagramPacket in java.net

      Methods in java.net with parameters of type DatagramPacket
      Modifier and Type 方法 描述
      protected abstract int DatagramSocketImpl.peekData​(DatagramPacket p)
      仔细看看它是从哪里来的。
      void DatagramSocket.receive​(DatagramPacket p)
      从此套接字接收数据报包。
      protected abstract void DatagramSocketImpl.receive​(DatagramPacket p)
      接收数据报包。
      void DatagramSocket.send​(DatagramPacket p)
      从此套接字发送数据报包。
      protected abstract void DatagramSocketImpl.send​(DatagramPacket p)
      发送数据报包。
      void MulticastSocket.send​(DatagramPacket p, byte ttl)
      已过时。
      使用以下代码或其等价物：...... int ttl = mcastSocket.getTimeToLive（）;
mcastSocket.setTimeToLive（newttl）;
mcastSocket.send（P）;
mcastSocket.setTimeToLive（TTL）;
......
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.DatagramSocket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.DatagramSocket

  • Packages that use DatagramSocket
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    jdk.net
    适用于 java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of DatagramSocket in java.net

      Subclasses of DatagramSocket in java.net
      Modifier and Type Class 描述
      class  MulticastSocket
      组播数据报套接字类对发送和接收IP组播数据包很有用。
      Methods in java.net that return DatagramSocket
      Modifier and Type 方法 描述
      <T> DatagramSocket DatagramSocket.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。

    • Uses of DatagramSocket in java.nio.channels

      Methods in java.nio.channels that return DatagramSocket
      Modifier and Type 方法 描述
      abstract DatagramSocket DatagramChannel.socket​()
      检索与此通道相关联的数据报套接字。

    • Uses of DatagramSocket in jdk.net

      Methods in jdk.net with parameters of type DatagramSocket
      Modifier and Type 方法 描述
      static <T> T Sockets.getOption​(DatagramSocket s, SocketOption<T> name)
      从DatagramSocket或MulticastSocket返回套接字选项的值
      static <T> void Sockets.setOption​(DatagramSocket s, SocketOption<T> name, T value)
      在DatagramSocket或MulticastSocket上设置套接字选项的值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.DatagramSocketImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.DatagramSocketImpl

  • Packages that use DatagramSocketImpl
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of DatagramSocketImpl in java.net

      Methods in java.net that return DatagramSocketImpl
      Modifier and Type 方法 描述
      DatagramSocketImpl DatagramSocketImplFactory.createDatagramSocketImpl​()
      创建一个新的 DatagramSocketImpl实例。
      Constructors in java.net with parameters of type DatagramSocketImpl
      Constructor 描述
      DatagramSocket​(DatagramSocketImpl impl)
      使用指定的DatagramSocketImpl创建一个未绑定的数据报套接字。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.HttpCookie (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.HttpCookie

  • Packages that use HttpCookie
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of HttpCookie in java.net

      Methods in java.net that return types with arguments of type HttpCookie
      Modifier and Type 方法 描述
      List<HttpCookie> CookieStore.get​(URI uri)
      检索与给定URI相关联的Cookie，或者其域与给定的URI匹配。
      List<HttpCookie> CookieStore.getCookies​()
      在Cookie商店中获取所有未过期的Cookie。
      static List<HttpCookie> HttpCookie.parse​(String header)
      从set-cookie或set-cookie2头字符串构造cookie。
      Methods in java.net with parameters of type HttpCookie
      Modifier and Type 方法 描述
      void CookieStore.add​(URI uri, HttpCookie cookie)
      向商店添加一个HTTP cookie。
      boolean CookieStore.remove​(URI uri, HttpCookie cookie)
      从商店中删除一个cookie。
      boolean CookiePolicy.shouldAccept​(URI uri, HttpCookie cookie)
      Will be called to see whether or not this cookie should be accepted.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.HttpRetryException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.HttpRetryException

No usage of java.net.HttpRetryException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.HttpURLConnection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.HttpURLConnection

  • Packages that use HttpURLConnection
    软件包 描述
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of HttpURLConnection in javax.net.ssl

      Subclasses of HttpURLConnection in javax.net.ssl
      Modifier and Type Class 描述
      class  HttpsURLConnection
      HttpsURLConnection扩展了 HttpURLConnection ，支持https特定的功能。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.IDN (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.IDN

No usage of java.net.IDN
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.Inet4Address (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.Inet4Address

No usage of java.net.Inet4Address
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.Inet6Address (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.Inet6Address

  • Packages that use Inet6Address
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of Inet6Address in java.net

      Methods in java.net that return Inet6Address
      Modifier and Type 方法 描述
      static Inet6Address Inet6Address.getByAddress​(String host, byte[] addr, int scope_id)
      以 InetAddress.getByAddress(String,byte[])的确切方式创建Inet6Address，但将IPv6范围 ID设置为给定的数值。
      static Inet6Address Inet6Address.getByAddress​(String host, byte[] addr, NetworkInterface nif)
      以 InetAddress.getByAddress(String,byte[])的确切方式创建Inet6Address，但将IPv6范围 ID设置为与 addr指定的地址类型的给定接口相对应的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.InetAddress (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.InetAddress

  • Packages that use InetAddress
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    javax.net
    提供网络应用程序的类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。

    • Uses of InetAddress in com.sun.nio.sctp

      Methods in com.sun.nio.sctp with parameters of type InetAddress
      Modifier and Type 方法 描述
      abstract SctpChannel SctpChannel.bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract SctpMultiChannel SctpMultiChannel.bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract SctpServerChannel SctpServerChannel.bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract SctpChannel SctpChannel.unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。
      abstract SctpMultiChannel SctpMultiChannel.unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。
      abstract SctpServerChannel SctpServerChannel.unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。

    • Uses of InetAddress in java.lang

      Methods in java.lang with parameters of type InetAddress
      Modifier and Type 方法 描述
      void SecurityManager.checkMulticast​(InetAddress maddr)
      如果调用线程不允许使用（加入/离开/发送/接收）IP组播，则抛出一个 SecurityException 。
      void SecurityManager.checkMulticast​(InetAddress maddr, byte ttl)
      已过时。
      请改用#checkPermission（java.security.Permission）

    • Uses of InetAddress in java.net

      Subclasses of InetAddress in java.net
      Modifier and Type Class 描述
      class  Inet4Address
      该类表示Internet协议版本4（IPv4）地址。
      class  Inet6Address
      该类表示Internet协议版本6（IPv6）地址。
      Fields in java.net declared as InetAddress
      Modifier and Type Field 描述
      protected InetAddress SocketImpl.address
      该套接字远端的IP地址。
      Methods in java.net that return InetAddress
      Modifier and Type 方法 描述
      InetAddress DatagramPacket.getAddress​()
      返回该数据报发送或接收数据报的计算机的IP地址。
      InetAddress InetSocketAddress.getAddress​()
      获得 InetAddress 。
      InetAddress InterfaceAddress.getAddress​()
      返回此地址的 InetAddress 。
      static InetAddress[] InetAddress.getAllByName​(String host)
      给定主机的名称，根据系统上配置的名称服务返回其IP地址数组。
      InetAddress InterfaceAddress.getBroadcast​()
      为此InterfaceAddress的广播地址返回 InetAddress 。
      static InetAddress InetAddress.getByAddress​(byte[] addr)
      给出原始IP地址的 InetAddress对象。
      static InetAddress InetAddress.getByAddress​(String host, byte[] addr)
      根据提供的主机名和IP地址创建InetAddress。
      static InetAddress InetAddress.getByName​(String host)
      确定主机名称的IP地址。
      protected InetAddress URLStreamHandler.getHostAddress​(URL u)
      获取我们的主机的IP地址。
      InetAddress DatagramSocket.getInetAddress​()
      返回此套接字连接到的地址。
      InetAddress ServerSocket.getInetAddress​()
      返回此服务器套接字的本地地址。
      InetAddress Socket.getInetAddress​()
      返回套接字所连接的地址。
      protected InetAddress SocketImpl.getInetAddress​()
      返回此套接字 address字段的值。
      InetAddress MulticastSocket.getInterface​()
      检索用于组播数据包的网络接口的地址。
      InetAddress DatagramSocket.getLocalAddress​()
      获取套接字所绑定的本地地址。
      InetAddress Socket.getLocalAddress​()
      获取套接字所绑定的本地地址。
      static InetAddress InetAddress.getLocalHost​()
      返回本地主机的地址。
      static InetAddress InetAddress.getLoopbackAddress​()
      返回回送地址。
      protected InetAddress Authenticator.getRequestingSite​()
      获取 InetAddress请求授权的站点，或者 null如果不可用。
      Methods in java.net that return types with arguments of type InetAddress
      Modifier and Type 方法 描述
      Enumeration<InetAddress> NetworkInterface.getInetAddresses​()
      获取绑定到此网络接口的所有或一部分InetAddress的枚举。
      Stream<InetAddress> NetworkInterface.inetAddresses​()
      获取绑定到此网络接口的InetAddresses的全部或一部分子流。
      Methods in java.net with parameters of type InetAddress
      Modifier and Type 方法 描述
      protected abstract void DatagramSocketImpl.bind​(int lport, InetAddress laddr)
      将数据报套接字绑定到本地端口和地址。
      protected abstract void SocketImpl.bind​(InetAddress host, int port)
      将此套接字绑定到指定的本地IP地址和端口号。
      void DatagramSocket.connect​(InetAddress address, int port)
      将套接字连接到此套接字的远程地址。
      protected void DatagramSocketImpl.connect​(InetAddress address, int port)
      将数据报套接字连接到远程目标。
      protected abstract void SocketImpl.connect​(InetAddress address, int port)
      将此套接字连接到指定主机上的指定端口号。
      static NetworkInterface NetworkInterface.getByInetAddress​(InetAddress addr)
      搜索具有绑定到指定的Internet协议（IP）地址的网络接口的便利方法。
      protected abstract void DatagramSocketImpl.join​(InetAddress inetaddr)
      加入组播组。
      void MulticastSocket.joinGroup​(InetAddress mcastaddr)
      加入组播组。
      protected abstract void DatagramSocketImpl.leave​(InetAddress inetaddr)
      离开组播组。
      void MulticastSocket.leaveGroup​(InetAddress mcastaddr)
      离开多播组。
      protected abstract int DatagramSocketImpl.peek​(InetAddress i)
      仔细看看它是从哪里来的。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme)
      请向系统注册的验证者询问密码。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      请向系统注册的验证者询问密码。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(Authenticator authenticator, String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      询问给定的 authenticator密码。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(InetAddress addr, int port, String protocol, String prompt, String scheme)
      请向系统注册的验证者询问密码。
      PasswordAuthentication Authenticator.requestPasswordAuthenticationInstance​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      向该验证者询问密码。
      void DatagramPacket.setAddress​(InetAddress iaddr)
      设置该数据报发送到的机器的IP地址。
      void MulticastSocket.setInterface​(InetAddress inf)
      设置由行为受网络接口值影响的方法使用的组播网络接口。
      Constructors in java.net with parameters of type InetAddress
      Constructor 描述
      DatagramPacket​(byte[] buf, int offset, int length, InetAddress address, int port)
      构造一个数据包，发送长度为 length的数据包， length包含指定主机上指定的端口号，偏移量为 ioffset 。
      DatagramPacket​(byte[] buf, int length, InetAddress address, int port)
      构造一个数据报包，将数据包长度为 length ，发送到指定主机上的指定端口号。
      DatagramSocket​(int port, InetAddress laddr)
      创建一个数据报套接字，绑定到指定的本地地址。
      InetSocketAddress​(InetAddress addr, int port)
      从IP地址和端口号创建套接字地址。
      ServerSocket​(int port, int backlog, InetAddress bindAddr)
      创建一个具有指定端口的服务器，侦听backlog和本地IP地址绑定。
      Socket​(String host, int port, InetAddress localAddr, int localPort)
      创建套接字并将其连接到指定远程端口上的指定远程主机。
      Socket​(InetAddress address, int port)
      创建流套接字并将其连接到指定IP地址的指定端口号。
      Socket​(InetAddress host, int port, boolean stream)
      已过时。
      使用DatagramSocket代替UDP传输。
      Socket​(InetAddress address, int port, InetAddress localAddr, int localPort)
      创建套接字并将其连接到指定的远程端口上指定的远程地址。

    • Uses of InetAddress in java.nio.channels

      Methods in java.nio.channels that return InetAddress
      Modifier and Type 方法 描述
      abstract InetAddress MembershipKey.group​()
      返回创建此成员资格密钥的多播组。
      abstract InetAddress MembershipKey.sourceAddress​()
      如果此成员资格密钥是源特定的，则返回源地址，如果此成员资格不是源特定的，则返回 null 。
      Methods in java.nio.channels with parameters of type InetAddress
      Modifier and Type 方法 描述
      abstract MembershipKey MembershipKey.block​(InetAddress source)
      阻止来自给定源地址的组播数据报。
      MembershipKey MulticastChannel.join​(InetAddress group, NetworkInterface interf)
      加入组播组，开始接收发送到组的所有数据报，返回成员密钥。
      MembershipKey MulticastChannel.join​(InetAddress group, NetworkInterface interf, InetAddress source)
      加入组播组，开始从给定的源地址接收发送到组的数据报。
      abstract MembershipKey MembershipKey.unblock​(InetAddress source)
      从先前使用 block方法阻止的给定源地址中解除阻塞多播数据报。

    • Uses of InetAddress in javax.net

      Methods in javax.net with parameters of type InetAddress
      Modifier and Type 方法 描述
      abstract ServerSocket ServerSocketFactory.createServerSocket​(int port, int backlog, InetAddress ifAddress)
      返回绑定到指定端口的服务器套接字，具有指定的listen backlog和本地IP。
      abstract Socket SocketFactory.createSocket​(String host, int port, InetAddress localHost, int localPort)
      创建套接字并将其连接到指定远程端口上的指定远程主机。
      abstract Socket SocketFactory.createSocket​(InetAddress host, int port)
      创建套接字并将其连接到指定地址处的指定端口号。
      abstract Socket SocketFactory.createSocket​(InetAddress address, int port, InetAddress localAddress, int localPort)
      创建套接字并将其连接到指定远程端口上指定的远程地址。

    • Uses of InetAddress in javax.net.ssl

      Constructors in javax.net.ssl with parameters of type InetAddress
      Constructor 描述
      SSLServerSocket​(int port, int backlog, InetAddress address)
      仅由子类使用。
      SSLSocket​(String host, int port, InetAddress clientAddress, int clientPort)
      仅由子类使用。
      SSLSocket​(InetAddress address, int port)
      仅由子类使用。
      SSLSocket​(InetAddress address, int port, InetAddress clientAddress, int clientPort)
      仅由子类使用。

    • Uses of InetAddress in javax.security.auth.kerberos

      Methods in javax.security.auth.kerberos that return InetAddress
      Modifier and Type 方法 描述
      InetAddress[] KerberosTicket.getClientAddresses​()
      返回可以使用票证的地址列表。
      Constructors in javax.security.auth.kerberos with parameters of type InetAddress
      Constructor 描述
      KerberosTicket​(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
      构造 KerberosTicket使用客户端从KDC接收或从缓存读取的凭据信息。

    • Uses of InetAddress in org.ietf.jgss

      Methods in org.ietf.jgss that return InetAddress
      Modifier and Type 方法 描述
      InetAddress ChannelBinding.getAcceptorAddress​()
      获取该通道绑定的接受者地址。
      InetAddress ChannelBinding.getInitiatorAddress​()
      获取此通道绑定的启动器地址。
      Constructors in org.ietf.jgss with parameters of type InetAddress
      Constructor 描述
      ChannelBinding​(InetAddress initAddr, InetAddress acceptAddr, byte[] appData)
      使用用户提供的地址信息和数据创建ChannelBinding对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.InetSocketAddress (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.InetSocketAddress

  • Packages that use InetSocketAddress
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。
    java.net
    提供实现网络应用程序的类。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。

    • Uses of InetSocketAddress in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return InetSocketAddress
      Modifier and Type 方法 描述
      abstract InetSocketAddress HttpServer.getAddress​()
      返回服务器正在侦听的地址
      abstract InetSocketAddress HttpsParameters.getClientAddress​()
      返回启动连接的远程客户端的地址。
      abstract InetSocketAddress HttpExchange.getLocalAddress​()
      返回接收请求的本地地址
      abstract InetSocketAddress HttpExchange.getRemoteAddress​()
      返回调用此请求的远程实体的地址
      Methods in com.sun.net.httpserver with parameters of type InetSocketAddress
      Modifier and Type 方法 描述
      abstract void HttpServer.bind​(InetSocketAddress addr, int backlog)
      将当前未绑定的HttpServer绑定到给定的地址和端口号。
      static HttpServer HttpServer.create​(InetSocketAddress addr, int backlog)
      创建一个HttpServer实例，它将绑定到指定的InetSocketAddress （IP地址和端口号）也可以指定最大的积压。
      static HttpsServer HttpsServer.create​(InetSocketAddress addr, int backlog)
      创建一个HttpsServer实例，它将绑定到指定的InetSocketAddress （IP地址和端口号）也可以指定最大的积压。

    • Uses of InetSocketAddress in com.sun.net.httpserver.spi

      Methods in com.sun.net.httpserver.spi with parameters of type InetSocketAddress
      Modifier and Type 方法 描述
      abstract HttpServer HttpServerProvider.createHttpServer​(InetSocketAddress addr, int backlog)
      从此提供程序创建一个HttpServer
      abstract HttpsServer HttpServerProvider.createHttpsServer​(InetSocketAddress addr, int backlog)
      从此提供程序创建一个HttpsServer

    • Uses of InetSocketAddress in java.net

      Methods in java.net that return InetSocketAddress
      Modifier and Type 方法 描述
      static InetSocketAddress InetSocketAddress.createUnresolved​(String host, int port)
      从主机名和端口号创建未解析的套接字地址。
      Methods in java.net with parameters of type InetSocketAddress
      Modifier and Type 方法 描述
      static ProxySelector ProxySelector.of​(InetSocketAddress proxyAddress)
      返回一个ProxySelector，它为所有HTTP和HTTPS请求使用给定的代理地址。

    • Uses of InetSocketAddress in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return InetSocketAddress
      Modifier and Type 方法 描述
      abstract InetSocketAddress HttpExchange.getLocalAddress​()
      返回收到请求的未解决的本地地址。
      abstract InetSocketAddress HttpExchange.getRemoteAddress​()
      返回调用此请求的远程实体的未解析地址。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.InterfaceAddress (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.InterfaceAddress

  • Packages that use InterfaceAddress
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of InterfaceAddress in java.net

      Methods in java.net that return types with arguments of type InterfaceAddress
      Modifier and Type 方法 描述
      List<InterfaceAddress> NetworkInterface.getInterfaceAddresses​()
      获取此网络接口的 InterfaceAddresses的全部或部分的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.JarURLConnection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.JarURLConnection

No usage of java.net.JarURLConnection
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.MalformedURLException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.MalformedURLException

  • Packages that use MalformedURLException
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.net
    提供实现网络应用程序的类。
    java.rmi
    提供RMI包。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。

    • Uses of MalformedURLException in java.io

      Methods in java.io that throw MalformedURLException
      Modifier and Type 方法 描述
      URL File.toURL​()
      已过时。
      此方法不会自动转义URL中非法的字符。 建议在新的代码转换的抽象路径到URL通过先转换成URI，经由toURI方法，然后经由转换URI为URL URI.toURL方法。

    • Uses of MalformedURLException in java.net

      Methods in java.net that throw MalformedURLException
      Modifier and Type 方法 描述
      URL URI.toURL​()
      从此URI构造一个URL。
      Constructors in java.net that throw MalformedURLException
      Constructor 描述
      JarURLConnection​(URL url)
      创建新的JarURLConnection到指定的URL。
      URL​(String spec)
      从 String表示中创建一个 URL对象。
      URL​(String protocol, String host, int port, String file)
      创建 URL从指定对象 protocol ， host ， port号码，和 file 。
      URL​(String protocol, String host, int port, String file, URLStreamHandler handler)
      创建 URL从指定对象 protocol ， host ， port号码， file ，和 handler 。
      URL​(String protocol, String host, String file)
      从指定的 protocol名称， host名称和 file名称创建一个URL。
      URL​(URL context, String spec)
      通过在指定的上下文中解析给定的规范来创建一个URL。
      URL​(URL context, String spec, URLStreamHandler handler)
      通过在指定上下文中使用指定的处理程序解析给定规范来创建URL。

    • Uses of MalformedURLException in java.rmi

      Methods in java.rmi that throw MalformedURLException
      Modifier and Type 方法 描述
      static void Naming.bind​(String name, Remote obj)
      将指定的 name绑定到远程对象。
      static String[] Naming.list​(String name)
      返回在注册表中绑定的名称的数组。
      static Remote Naming.lookup​(String name)
      返回与指定的 name关联的远程对象的引用（stub）。
      static void Naming.rebind​(String name, Remote obj)
      将指定的名称重新绑定到一个新的远程对象。
      static void Naming.unbind​(String name)
      销毁与远程对象关联的指定名称的绑定。

    • Uses of MalformedURLException in java.rmi.server

      Methods in java.rmi.server that throw MalformedURLException
      Modifier and Type 方法 描述
      static ClassLoader RMIClassLoader.getClassLoader​(String codebase)
      返回从给定的代码库URL路径加载类的类加载器。
      abstract ClassLoader RMIClassLoaderSpi.getClassLoader​(String codebase)
      提供 RMIClassLoader.getClassLoader(String)的实现。
      Class<?> LoaderHandler.loadClass​(String name)
      已过时。
      没有替换
      Class<?> LoaderHandler.loadClass​(URL codebase, String name)
      已过时。
      没有替换
      static Class<?> RMIClassLoader.loadClass​(String name)
      已过时。
      替换为loadClass(String,String)方法
      static Class<?> RMIClassLoader.loadClass​(String codebase, String name)
      从代码库URL路径加载一个类。
      static Class<?> RMIClassLoader.loadClass​(String codebase, String name, ClassLoader defaultLoader)
      从代码库URL路径加载类，可选地使用提供的加载程序。
      static Class<?> RMIClassLoader.loadClass​(URL codebase, String name)
      从代码库URL加载一个类。
      abstract Class<?> RMIClassLoaderSpi.loadClass​(String codebase, String name, ClassLoader defaultLoader)
       为贯彻
RMIClassLoader.loadClass(URL,String) ，
RMIClassLoader.loadClass(String,String) ，并
RMIClassLoader.loadClass(String,String,ClassLoader) 。
      static Class<?> RMIClassLoader.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      加载一个动态代理类（参见Proxy ），它从代码库URL路径中实现了一组具有给定名称的接口。
      abstract Class<?> RMIClassLoaderSpi.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader)的实现。

    • Uses of MalformedURLException in javax.jnlp

      Methods in javax.jnlp that throw MalformedURLException
      Modifier and Type 方法 描述
      long PersistenceService.create​(URL url, long maxsize)
      在客户端创建一个以给定的URL命名的永久存储条目。
      void PersistenceService.delete​(URL url)
      从客户端日期持久性存储中删除与给定URL相关联的流。
      FileContents PersistenceService.get​(URL url)
      返回表示此文件内容的 FileContents对象。
      String[] PersistenceService.getNames​(URL url)
      返回一个字符串数组，其中包含给定URL的所有条目的名称。
      int PersistenceService.getTag​(URL url)
      返回对应于与给定URL相关联的持久性数据存储条目的标记的当前值的 int 。
      void PersistenceService.setTag​(URL url, int tag)
      使用给定的标签值标记与给定URL相关联的持久数据存储条目。

    • Uses of MalformedURLException in javax.management.remote

      Constructors in javax.management.remote that throw MalformedURLException
      Constructor 描述
      JMXServiceURL​(String serviceURL)
      通过解析服务URL字符串构造一个 JMXServiceURL 。
      JMXServiceURL​(String protocol, String host, int port)
      使用给定的协议，主机和端口构造一个 JMXServiceURL 。
      JMXServiceURL​(String protocol, String host, int port, String urlPath)
      构造一个 JMXServiceURL与给定的部分。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.MulticastSocket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.MulticastSocket

No usage of java.net.MulticastSocket
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.NetPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.NetPermission

No usage of java.net.NetPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.NetworkInterface (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.NetworkInterface

  • Packages that use NetworkInterface
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of NetworkInterface in java.net

      Fields in java.net with type parameters of type NetworkInterface
      Modifier and Type Field 描述
      static SocketOption<NetworkInterface> StandardSocketOptions.IP_MULTICAST_IF
      互联网协议（IP）组播数据报的网络接口。
      Methods in java.net that return NetworkInterface
      Modifier and Type 方法 描述
      static NetworkInterface NetworkInterface.getByIndex​(int index)
      获取一个网络接口给它的索引。
      static NetworkInterface NetworkInterface.getByInetAddress​(InetAddress addr)
      搜索具有绑定到指定的Internet协议（IP）地址的网络接口的便利方法。
      static NetworkInterface NetworkInterface.getByName​(String name)
      搜索具有指定名称的网络接口。
      NetworkInterface MulticastSocket.getNetworkInterface​()
      获取组播网络接口集。
      NetworkInterface NetworkInterface.getParent​()
      如果这是一个子接口，则返回此接口的父网络接口，如果它是物理（非虚拟）接口或没有父接口，则返回 null 。
      NetworkInterface Inet6Address.getScopedInterface​()
      如果此实例是使用范围界面创建的，则返回范围界面。
      Methods in java.net that return types with arguments of type NetworkInterface
      Modifier and Type 方法 描述
      static Enumeration<NetworkInterface> NetworkInterface.getNetworkInterfaces​()
      返回本机上所有接口的 Enumeration 。
      Enumeration<NetworkInterface> NetworkInterface.getSubInterfaces​()
      获取连接到此网络接口的所有子接口（也称为虚拟接口）的枚举。
      static Stream<NetworkInterface> NetworkInterface.networkInterfaces​()
      返回本机上所有接口的 Stream 。
      Stream<NetworkInterface> NetworkInterface.subInterfaces​()
      获取附加到此网络接口的所有子接口（也称为虚拟接口）的流。
      Methods in java.net with parameters of type NetworkInterface
      Modifier and Type 方法 描述
      static Inet6Address Inet6Address.getByAddress​(String host, byte[] addr, NetworkInterface nif)
      在的确切方式创建Inet6Address， InetAddress.getByAddress(String,byte[])不同之处在于将IPv6 scope_id设置为对应于在指定的地址类型的给定接口的值 addr 。
      boolean InetAddress.isReachable​(NetworkInterface netif, int ttl, int timeout)
      测试该地址是否可达。
      protected abstract void DatagramSocketImpl.joinGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      加入组播组。
      void MulticastSocket.joinGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      在指定的接口加入指定的组播组。
      protected abstract void DatagramSocketImpl.leaveGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      离开组播组。
      void MulticastSocket.leaveGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      在指定的本地接口上留下组播组。
      void MulticastSocket.setNetworkInterface​(NetworkInterface netIf)
      指定在此套接字上发送的出站组播数据报的网络接口。

    • Uses of NetworkInterface in java.nio.channels

      Methods in java.nio.channels that return NetworkInterface
      Modifier and Type 方法 描述
      abstract NetworkInterface MembershipKey.networkInterface​()
      返回创建此会员密钥的网络接口。
      Methods in java.nio.channels with parameters of type NetworkInterface
      Modifier and Type 方法 描述
      MembershipKey MulticastChannel.join​(InetAddress group, NetworkInterface interf)
      加入组播组，开始接收发送到组的所有数据报，返回成员密钥。
      MembershipKey MulticastChannel.join​(InetAddress group, NetworkInterface interf, InetAddress source)
      加入组播组，开始从给定的源地址接收发送到组的数据报。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.NoRouteToHostException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.NoRouteToHostException

No usage of java.net.NoRouteToHostException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.PasswordAuthentication (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.PasswordAuthentication

  • Packages that use PasswordAuthentication
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of PasswordAuthentication in java.net

      Methods in java.net that return PasswordAuthentication
      Modifier and Type 方法 描述
      protected PasswordAuthentication Authenticator.getPasswordAuthentication​()
      当需要密码授权时调用。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme)
      请向系统注册的验证者询问密码。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      请向系统注册的验证者询问密码。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(Authenticator authenticator, String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      询问给定的 authenticator密码。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(InetAddress addr, int port, String protocol, String prompt, String scheme)
      请向系统注册的验证者询问密码。
      PasswordAuthentication Authenticator.requestPasswordAuthenticationInstance​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      Ask this authenticator for a password.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.PortUnreachableException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.PortUnreachableException

No usage of java.net.PortUnreachableException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.ProtocolException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.ProtocolException

  • Packages that use ProtocolException
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of ProtocolException in java.net

      Methods in java.net that throw ProtocolException
      Modifier and Type 方法 描述
      void HttpURLConnection.setRequestMethod​(String method)
      设置URL请求的方法，其中之一是：GET POST HEAD OPTIONS PUT DELETE TRACE是符合协议限制的合法的。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.Proxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.Proxy

  • Packages that use Proxy
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of Proxy in java.net

      Fields in java.net declared as Proxy
      Modifier and Type Field 描述
      static Proxy Proxy.NO_PROXY
      代理设置代表一个 DIRECT连接，基本上告诉协议处理程序不使用任何代理。
      Methods in java.net that return types with arguments of type Proxy
      Modifier and Type 方法 描述
      abstract List<Proxy> ProxySelector.select​(URI uri)
      根据访问资源的协议选择所有适用的代理以及访问资源的目标地址。
      Methods in java.net with parameters of type Proxy
      Modifier and Type 方法 描述
      URLConnection URL.openConnection​(Proxy proxy)
      与URL.openConnection()相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
      protected URLConnection URLStreamHandler.openConnection​(URL u, Proxy p)
      与openConnection（URL）相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
      Constructors in java.net with parameters of type Proxy
      Constructor 描述
      Socket​(Proxy proxy)
      创建一个未连接的套接字，指定应该使用的代理类型（如果有的话），无论其他任何设置如何。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.Proxy.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.Proxy.Type

  • Packages that use Proxy.Type
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of Proxy.Type in java.net

      Methods in java.net that return Proxy.Type
      Modifier and Type 方法 描述
      Proxy.Type Proxy.type​()
      返回代理类型。
      static Proxy.Type Proxy.Type.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Proxy.Type[] Proxy.Type.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in java.net with parameters of type Proxy.Type
      Constructor 描述
      Proxy​(Proxy.Type type, SocketAddress sa)
      创建一个表示PROXY连接的条目。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.ProxySelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.ProxySelector

  • Packages that use ProxySelector
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of ProxySelector in java.net

      Methods in java.net that return ProxySelector
      Modifier and Type 方法 描述
      static ProxySelector ProxySelector.getDefault​()
      获取系统范围的代理选择器。
      static ProxySelector ProxySelector.of​(InetSocketAddress proxyAddress)
      返回一个ProxySelector，它为所有HTTP和HTTPS请求使用给定的代理地址。
      Methods in java.net with parameters of type ProxySelector
      Modifier and Type 方法 描述
      static void ProxySelector.setDefault​(ProxySelector ps)
      设置（或取消）系统范围的代理选择器。

    • Uses of ProxySelector in jdk.incubator.http

      Methods in jdk.incubator.http that return types with arguments of type ProxySelector
      Modifier and Type 方法 描述
      abstract Optional<ProxySelector> HttpClient.proxy​()
      返回一个包含此客户端的 Optional的 ProxySelector 。
      Methods in jdk.incubator.http with parameters of type ProxySelector
      Modifier and Type 方法 描述
      abstract HttpClient.Builder HttpClient.Builder.proxy​(ProxySelector selector)
      Sets a ProxySelector for this client.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.ResponseCache (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.ResponseCache

  • Packages that use ResponseCache
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of ResponseCache in java.net

      Methods in java.net that return ResponseCache
      Modifier and Type 方法 描述
      static ResponseCache ResponseCache.getDefault​()
      获取系统范围的响应缓存。
      Methods in java.net with parameters of type ResponseCache
      Modifier and Type 方法 描述
      static void ResponseCache.setDefault​(ResponseCache responseCache)
      设置（或取消）系统级缓存。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.SecureCacheResponse (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.SecureCacheResponse

No usage of java.net.SecureCacheResponse
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.ServerSocket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.ServerSocket

  • Packages that use ServerSocket
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.net
    提供网络应用程序的类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
    jdk.net
    java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of ServerSocket in java.net

      Methods in java.net that return ServerSocket
      Modifier and Type 方法 描述
      <T> ServerSocket ServerSocket.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。

    • Uses of ServerSocket in java.nio.channels

      Methods in java.nio.channels that return ServerSocket
      Modifier and Type 方法 描述
      abstract ServerSocket ServerSocketChannel.socket​()
      检索与此通道关联的服务器套接字。

    • Uses of ServerSocket in java.rmi.server

      Methods in java.rmi.server that return ServerSocket
      Modifier and Type 方法 描述
      ServerSocket RMIServerSocketFactory.createServerSocket​(int port)
      在指定端口上创建服务器套接字（端口0表示匿名端口）。
      abstract ServerSocket RMISocketFactory.createServerSocket​(int port)
      在指定端口上创建服务器套接字（端口0表示匿名端口）。

    • Uses of ServerSocket in javax.net

      Methods in javax.net that return ServerSocket
      Modifier and Type 方法 描述
      ServerSocket ServerSocketFactory.createServerSocket​()
      返回未绑定的服务器套接字。
      abstract ServerSocket ServerSocketFactory.createServerSocket​(int port)
      返回绑定到指定端口的服务器套接字。
      abstract ServerSocket ServerSocketFactory.createServerSocket​(int port, int backlog)
      返回绑定到指定端口的服务器套接字，并使用指定的连接积压。
      abstract ServerSocket ServerSocketFactory.createServerSocket​(int port, int backlog, InetAddress ifAddress)
      返回绑定到指定端口的服务器套接字，具有指定的listen backlog和本地IP。

    • Uses of ServerSocket in javax.net.ssl

      Subclasses of ServerSocket in javax.net.ssl
      Modifier and Type Class 描述
      class  SSLServerSocket
      此类扩展了 ServerSocket s，并使用安全套接字层（SSL）或传输层安全（TLS）协议等协议提供安全的服务器套接字。

    • Uses of ServerSocket in javax.rmi.ssl

      Methods in javax.rmi.ssl that return ServerSocket
      Modifier and Type 方法 描述
      ServerSocket SslRMIServerSocketFactory.createServerSocket​(int port)
      创建一个服务器套接字，接受根据本工厂的SSL套接字配置参数配置的SSL连接。

    • Uses of ServerSocket in jdk.net

      Methods in jdk.net with parameters of type ServerSocket
      Modifier and Type 方法 描述
      static <T> T Sockets.getOption​(ServerSocket s, SocketOption<T> name)
      从ServerSocket返回套接字选项的值
      static <T> void Sockets.setOption​(ServerSocket s, SocketOption<T> name, T value)
      Sets the value of a socket option on a ServerSocket
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.Socket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.Socket

  • Packages that use Socket
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.net
    提供网络应用程序的类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
    jdk.net
    java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of Socket in java.net

      Methods in java.net that return Socket
      Modifier and Type 方法 描述
      Socket ServerSocket.accept​()
      侦听要连接到此套接字并接受它。
      <T> Socket Socket.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      Methods in java.net with parameters of type Socket
      Modifier and Type 方法 描述
      protected void ServerSocket.implAccept​(Socket s)
      ServerSocket的子类使用这个方法来覆盖accept（）来返回自己的套接字子类。

    • Uses of Socket in java.nio.channels

      Methods in java.nio.channels that return Socket
      Modifier and Type 方法 描述
      abstract Socket SocketChannel.socket​()
      检索与此通道相关联的套接字。

    • Uses of Socket in java.rmi.server

      Methods in java.rmi.server that return Socket
      Modifier and Type 方法 描述
      Socket RMIClientSocketFactory.createSocket​(String host, int port)
      创建连接到指定主机和端口的客户端套接字。
      abstract Socket RMISocketFactory.createSocket​(String host, int port)
      创建连接到指定主机和端口的客户端套接字。

    • Uses of Socket in javax.net

      Methods in javax.net that return Socket
      Modifier and Type 方法 描述
      Socket SocketFactory.createSocket​()
      创建一个未连接的套接字。
      abstract Socket SocketFactory.createSocket​(String host, int port)
      创建套接字并将其连接到指定的远程端口上的指定远程主机。
      abstract Socket SocketFactory.createSocket​(String host, int port, InetAddress localHost, int localPort)
      创建套接字并将其连接到指定远程端口上的指定远程主机。
      abstract Socket SocketFactory.createSocket​(InetAddress host, int port)
      创建套接字并将其连接到指定地址处的指定端口号。
      abstract Socket SocketFactory.createSocket​(InetAddress address, int port, InetAddress localAddress, int localPort)
      创建套接字并将其连接到指定远程端口上指定的远程地址。

    • Uses of Socket in javax.net.ssl

      Subclasses of Socket in javax.net.ssl
      Modifier and Type Class 描述
      class  SSLSocket
      此类扩展了 Socket s，并使用诸如“安全套接字层”（SSL）或IETF“传输层安全”（TLS）协议之类的协议来提供安全套接字。
      Methods in javax.net.ssl that return Socket
      Modifier and Type 方法 描述
      Socket SSLSocketFactory.createSocket​(Socket s, InputStream consumed, boolean autoClose)
      创建服务器模式Socket在现有连接的套接字上分层，并且能够读取已从Socket的底层InputStream中消耗/删除的数据 。
      abstract Socket SSLSocketFactory.createSocket​(Socket s, String host, int port, boolean autoClose)
      返回在给定端口上分层连接到指定主机的现有套接字上的套接字。
      Methods in javax.net.ssl with parameters of type Socket
      Modifier and Type 方法 描述
      abstract void X509ExtendedTrustManager.checkClientTrusted​(X509Certificate[] chain, String authType, Socket socket)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      abstract void X509ExtendedTrustManager.checkServerTrusted​(X509Certificate[] chain, String authType, Socket socket)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      String X509KeyManager.chooseClientAlias​(String[] keyType, Principal[] issuers, Socket socket)
      选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，来认证安全套接字的客户端。
      String X509KeyManager.chooseServerAlias​(String keyType, Principal[] issuers, Socket socket)
      选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，对安全套接字的服务器端进行身份验证。
      Socket SSLSocketFactory.createSocket​(Socket s, InputStream consumed, boolean autoClose)
      创建服务器模式Socket分层在现有连接的套接字上，并且能够读取已从Socket的底层InputStream中消耗/删除的数据 。
      abstract Socket SSLSocketFactory.createSocket​(Socket s, String host, int port, boolean autoClose)
      返回在给定端口上分层连接到指定主机的现有套接字上的套接字。

    • Uses of Socket in javax.rmi.ssl

      Methods in javax.rmi.ssl that return Socket
      Modifier and Type 方法 描述
      Socket SslRMIClientSocketFactory.createSocket​(String host, int port)
      创建一个SSL套接字。

    • Uses of Socket in jdk.net

      Methods in jdk.net with parameters of type Socket
      Modifier and Type 方法 描述
      static <T> T Sockets.getOption​(Socket s, SocketOption<T> name)
      从Socket返回套接字选项的值
      static <T> void Sockets.setOption​(Socket s, SocketOption<T> name, T value)
      在Socket上设置套接字选项的值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.SocketAddress (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.SocketAddress

  • Packages that use SocketAddress
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of SocketAddress in com.sun.nio.sctp

      Fields in com.sun.nio.sctp with type parameters of type SocketAddress
      Modifier and Type Field 描述
      static SctpSocketOption<SocketAddress> SctpStandardSocketOptions.SCTP_PRIMARY_ADDR
      请求本地SCTP堆栈使用给定对等体地址作为关联主节点。
      static SctpSocketOption<SocketAddress> SctpStandardSocketOptions.SCTP_SET_PEER_PRIMARY_ADDR
      请求对等方将附带的地址标记为关联主。
      Methods in com.sun.nio.sctp that return SocketAddress
      Modifier and Type 方法 描述
      abstract SocketAddress MessageInfo.address​()
      如果接收到消息，则返回源套接字地址，否则将发送消息的首选目标。
      abstract SocketAddress PeerAddressChangeNotification.address​()
      返回对等地址。
      abstract SocketAddress SendFailedNotification.address​()
      返回地址。
      Methods in com.sun.nio.sctp that return types with arguments of type SocketAddress
      Modifier and Type 方法 描述
      abstract Set<SocketAddress> SctpChannel.getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract Set<SocketAddress> SctpMultiChannel.getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract Set<SocketAddress> SctpServerChannel.getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract Set<SocketAddress> SctpChannel.getRemoteAddresses​()
      返回此通道的套接字所连接的所有远程地址。
      abstract Set<SocketAddress> SctpMultiChannel.getRemoteAddresses​(Association association)
      返回此通道的套接字连接给定关联的所有远程地址。
      Methods in com.sun.nio.sctp with parameters of type SocketAddress
      Modifier and Type 方法 描述
      abstract SctpChannel SctpChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      SctpMultiChannel SctpMultiChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SctpMultiChannel SctpMultiChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      SctpServerChannel SctpServerChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
      abstract SctpServerChannel SctpServerChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
      abstract boolean SctpChannel.connect​(SocketAddress remote)
      连接此通道的插座。
      abstract boolean SctpChannel.connect​(SocketAddress remote, int maxOutStreams, int maxInStreams)
      连接此通道的插座。
      static MessageInfo MessageInfo.createOutgoing​(Association association, SocketAddress address, int streamNumber)
      创建适用于向给定关联发送消息时使用的 MessageInfo实例。
      static MessageInfo MessageInfo.createOutgoing​(SocketAddress address, int streamNumber)
      创建适用于发送消息时使用的 MessageInfo实例。
      static SctpChannel SctpChannel.open​(SocketAddress remote, int maxOutStreams, int maxInStreams)
      打开SCTP通道并将其连接到远程地址。

    • Uses of SocketAddress in java.net

      Subclasses of SocketAddress in java.net
      Modifier and Type Class 描述
      class  InetSocketAddress
      该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。
      Methods in java.net that return SocketAddress
      Modifier and Type 方法 描述
      SocketAddress Proxy.address​()
      返回代理的套接字地址，如果是 null则直接连接。
      SocketAddress DatagramSocket.getLocalSocketAddress​()
      返回此套接字绑定到的端点的地址。
      SocketAddress ServerSocket.getLocalSocketAddress​()
      返回此套接字绑定到的端点的地址。
      SocketAddress Socket.getLocalSocketAddress​()
      返回此套接字绑定到的端点的地址。
      SocketAddress DatagramSocket.getRemoteSocketAddress​()
      返回此套接字连接到的端点的地址，如果未连接，则 null 。
      SocketAddress Socket.getRemoteSocketAddress​()
      返回此套接字连接到的端点的地址，如果未连接，则 null 。
      SocketAddress DatagramPacket.getSocketAddress​()
      获取该数据包发送到或正在从其发送的远程主机的SocketAddress（通常为IP地址+端口号）。
      Methods in java.net with parameters of type SocketAddress
      Modifier and Type 方法 描述
      void DatagramSocket.bind​(SocketAddress addr)
      将此DatagramSocket绑定到特定的地址和端口。
      void ServerSocket.bind​(SocketAddress endpoint)
      将 ServerSocket绑定到特定地址（IP地址和端口号）。
      void ServerSocket.bind​(SocketAddress endpoint, int backlog)
      将 ServerSocket绑定到特定地址（IP地址和端口号）。
      void Socket.bind​(SocketAddress bindpoint)
      将套接字绑定到本地地址。
      void DatagramSocket.connect​(SocketAddress addr)
      将此套接字连接到远程套接字地址（IP地址+端口号）。
      void Socket.connect​(SocketAddress endpoint)
      将此套接字连接到服务器。
      void Socket.connect​(SocketAddress endpoint, int timeout)
      将此套接字连接到具有指定超时值的服务器。
      protected abstract void SocketImpl.connect​(SocketAddress address, int timeout)
      将此套接字连接到指定主机上的指定端口号。
      abstract void ProxySelector.connectFailed​(URI uri, SocketAddress sa, IOException ioe)
      被称为表示连接不能建立到代理/袜子服务器。
      protected abstract void DatagramSocketImpl.joinGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      加入组播组。
      void MulticastSocket.joinGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      在指定的接口加入指定的组播组。
      protected abstract void DatagramSocketImpl.leaveGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      离开组播组。
      void MulticastSocket.leaveGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      在指定的本地接口上留下组播组。
      void DatagramPacket.setSocketAddress​(SocketAddress address)
      设置该数据报发送到的远程主机的SocketAddress（通常是IP地址+端口号）。
      Constructors in java.net with parameters of type SocketAddress
      Constructor 描述
      DatagramPacket​(byte[] buf, int offset, int length, SocketAddress address)
      构造一个数据报包，发送长度为 length的数据包，并将偏移量为 ioffset到指定主机上的指定端口号。
      DatagramPacket​(byte[] buf, int length, SocketAddress address)
      构造一个数据报包，将数据包长度为 length ，发送到指定主机上的指定端口号。
      DatagramSocket​(SocketAddress bindaddr)
      创建一个数据报套接字，绑定到指定的本地套接字地址。
      MulticastSocket​(SocketAddress bindaddr)
      创建一个绑定到指定套接字地址的MulticastSocket。
      Proxy​(Proxy.Type type, SocketAddress sa)
      创建一个表示PROXY连接的条目。

    • Uses of SocketAddress in java.nio.channels

      Methods in java.nio.channels that return SocketAddress
      Modifier and Type 方法 描述
      abstract SocketAddress AsynchronousServerSocketChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress AsynchronousSocketChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress DatagramChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      SocketAddress NetworkChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress ServerSocketChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress SocketChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress AsynchronousSocketChannel.getRemoteAddress​()
      返回此通道的插座所连接的远程地址。
      abstract SocketAddress DatagramChannel.getRemoteAddress​()
      返回此通道的插座所连接的远程地址。
      abstract SocketAddress SocketChannel.getRemoteAddress​()
      返回此通道的插座所连接的远程地址。
      abstract SocketAddress DatagramChannel.receive​(ByteBuffer dst)
      通过该频道接收数据报。
      Methods in java.nio.channels with parameters of type SocketAddress
      Modifier and Type | 方法 | 描述
      AsynchronousServerSocketChannel AsynchronousServerSocketChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract AsynchronousServerSocketChannel AsynchronousServerSocketChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract AsynchronousSocketChannel | AsynchronousSocketChannel.bind​(SocketAddress local)
      abstract DatagramChannel | DatagramChannel.bind​(SocketAddress local)
      NetworkChannel NetworkChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      ServerSocketChannel ServerSocketChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract ServerSocketChannel ServerSocketChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SocketChannel | SocketChannel.bind​(SocketAddress local)
      abstract Future<Void> AsynchronousSocketChannel.connect​(SocketAddress remote)
      连接此频道。
      abstract <A> void AsynchronousSocketChannel.connect​(SocketAddress remote, A attachment, CompletionHandler<Void,? super A> handler)
      连接此频道。
      abstract DatagramChannel DatagramChannel.connect​(SocketAddress remote)
      连接此通道的插座。
      abstract boolean SocketChannel.connect​(SocketAddress remote)
      连接此通道的插座。
      static SocketChannel SocketChannel.open​(SocketAddress remote)
      打开套接字通道并将其连接到远程地址。
      abstract int DatagramChannel.send​(ByteBuffer src, SocketAddress target)
      通过此频道发送数据报。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.SocketException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.SocketException

  • Packages that use SocketException
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of SocketException in java.net

      Subclasses of SocketException in java.net
      Modifier and Type Class 描述
      class  BindException
      指示尝试将套接字绑定到本地地址和端口时发生错误。
      class  ConnectException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  NoRouteToHostException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  PortUnreachableException
      指示在连接的数据报上收到了ICMP端口不可达消息。
      Methods in java.net that throw SocketException
      Modifier and Type 方法 描述
      void DatagramSocket.bind​(SocketAddress addr)
      将此DatagramSocket绑定到特定的地址和端口。
      protected abstract void DatagramSocketImpl.bind​(int lport, InetAddress laddr)
      将数据报套接字绑定到本地端口和地址。
      void DatagramSocket.connect​(SocketAddress addr)
      将此套接字连接到远程套接字地址（IP地址+端口号）。
      protected void DatagramSocketImpl.connect​(InetAddress address, int port)
      将数据报套接字连接到远程目标。
      protected abstract void DatagramSocketImpl.create​()
      创建数据报套接字。
      boolean DatagramSocket.getBroadcast​()
      测试是否启用了SO_BROADCAST。
      static NetworkInterface NetworkInterface.getByIndex​(int index)
      获取一个网络接口给它的索引。
      static NetworkInterface NetworkInterface.getByInetAddress​(InetAddress addr)
      搜索具有绑定到指定的Internet协议（IP）地址的网络接口的便利方法。
      static NetworkInterface NetworkInterface.getByName​(String name)
      搜索具有指定名称的网络接口。
      byte[] NetworkInterface.getHardwareAddress​()
      返回接口的硬件地址（通常是MAC），如果它有一个，如果可以访问给定当前权限。
      InetAddress MulticastSocket.getInterface​()
      检索用于组播数据包的网络接口的地址。
      boolean Socket.getKeepAlive​()
      测试是否启用了 SO_KEEPALIVE 。
      boolean MulticastSocket.getLoopbackMode​()
      获取组播数据报的本地环回设置。
      int NetworkInterface.getMTU​()
      返回此接口的最大传输单元（MTU）。
      NetworkInterface MulticastSocket.getNetworkInterface​()
      获取组播网络接口集。
      static Enumeration<NetworkInterface> NetworkInterface.getNetworkInterfaces​()
      返回此机器上所有接口的 Enumeration 。
      boolean Socket.getOOBInline​()
      测试是否启用了 SO_OOBINLINE 。
      Object SocketOptions.getOption​(int optID)
      获取选项的值。
      int DatagramSocket.getReceiveBufferSize​()
      获取此 DatagramSocket的SO_RCVBUF选项的值，即平台在此 DatagramSocket上输入的缓冲区大小。
      int ServerSocket.getReceiveBufferSize​()
      获取的价值 SO_RCVBUF选择这个 ServerSocket ，那就是将用于从该接受的套接字的建议缓冲区大小 ServerSocket 。
      int Socket.getReceiveBufferSize​()
      获取此 Socket的 SO_RCVBUF选项的值，即该平台在此 Socket上输入的缓冲区大小。
      boolean DatagramSocket.getReuseAddress​()
      测试是否启用了SO_REUSEADDR。
      boolean ServerSocket.getReuseAddress​()
      测试是否启用了 SO_REUSEADDR 。
      boolean Socket.getReuseAddress​()
      测试是否启用了 SO_REUSEADDR 。
      int DatagramSocket.getSendBufferSize​()
      获取此 DatagramSocket的SO_SNDBUF选项的值，即该平台用于在此 DatagramSocket上输出的缓冲区大小。
      int Socket.getSendBufferSize​()
      获取此 Socket的 SO_SNDBUF选项的值，即该平台在此 Socket上输出的缓冲区大小。
      int Socket.getSoLinger​()
      退回设置为 SO_LINGER 。
      int DatagramSocket.getSoTimeout​()
      检索SO_TIMEOUT的设置。 0返回意味着该选项被禁用（即无限超时）。
      int Socket.getSoTimeout​()
      退货设置为SO_TIMEOUT 。 0返回意味着该选项被禁用（即无限超时）。
      boolean Socket.getTcpNoDelay​()
      测试是否启用了 TCP_NODELAY 。
      int DatagramSocket.getTrafficClass​()
      在从该DatagramSocket发送的数据包的IP数据报头中获取流量类或服务类型。
      int Socket.getTrafficClass​()
      在从此Socket发送的数据包的IP头中获取流量类或服务类型
      boolean NetworkInterface.isLoopback​()
      返回网络接口是否是环回接口。
      boolean NetworkInterface.isPointToPoint​()
      返回网络接口是否是点对点接口。
      boolean NetworkInterface.isUp​()
      返回网络接口是否启动并运行。
      static Stream<NetworkInterface> NetworkInterface.networkInterfaces​()
      返回此机器上所有接口的 Stream 。
      void DatagramSocket.setBroadcast​(boolean on)
      启用/禁用SO_BROADCAST。
      void MulticastSocket.setInterface​(InetAddress inf)
      设置由行为受网络接口值影响的方法使用的组播网络接口。
      void Socket.setKeepAlive​(boolean on)
      启用/禁用 SO_KEEPALIVE 。
      void MulticastSocket.setLoopbackMode​(boolean disable)
      禁用/启用组播数据报的本地环回该选项由平台的网络代码用作设置组播数据是否将环回到本地套接字的提示。
      void MulticastSocket.setNetworkInterface​(NetworkInterface netIf)
      指定在此套接字上发送的出站组播数据报的网络接口。
      void Socket.setOOBInline​(boolean on)
      启用/禁用 SO_OOBINLINE （接收TCP紧急数据）默认情况下，此选项被禁用，并且在套接字上接收的TCP紧急数据被静默地丢弃。
      void SocketOptions.setOption​(int optID, Object value)
      启用/禁用 optID指定的选项。
      void DatagramSocket.setReceiveBufferSize​(int size)
      将SO_RCVBUF选项设置为此 DatagramSocket的指定值。
      void ServerSocket.setReceiveBufferSize​(int size)
      设置从该 ServerSocket接受的套接字的 SO_RCVBUF选项的默认建议值。
      void Socket.setReceiveBufferSize​(int size)
      设置 SO_RCVBUF选项，此规定值 Socket 。
      void DatagramSocket.setReuseAddress​(boolean on)
      启用/禁用SO_REUSEADDR套接字选项。
      void ServerSocket.setReuseAddress​(boolean on)
      启用/禁用 SO_REUSEADDR套接字选项。
      void Socket.setReuseAddress​(boolean on)
      启用/禁用 SO_REUSEADDR套接字选项。
      void DatagramSocket.setSendBufferSize​(int size)
      将SO_SNDBUF选项设置为此 DatagramSocket的指定值。
      void Socket.setSendBufferSize​(int size)
      设置 SO_SNDBUF选项，此规定值 Socket 。
      void Socket.setSoLinger​(boolean on, int linger)
      启用/禁用 SO_LINGER具有指定的逗留时间（以秒为单位）。
      void DatagramSocket.setSoTimeout​(int timeout)
      以指定的超时（以毫秒为单位）启用/禁用SO_TIMEOUT。
      void ServerSocket.setSoTimeout​(int timeout)
      启用/禁用指定超时的 SO_TIMEOUT （以毫秒为单位）。
      void Socket.setSoTimeout​(int timeout)
      启用/禁用指定超时的 SO_TIMEOUT （以毫秒为单位）。
      void Socket.setTcpNoDelay​(boolean on)
      启用/禁用 TCP_NODELAY （禁用/启用Nagle的算法）。
      void DatagramSocket.setTrafficClass​(int tc)
      在从该DatagramSocket发送的数据报的IP数据报头中设置流量类别或服务类型的八位字节。
      void Socket.setTrafficClass​(int tc)
      在从此Socket发送的数据包的IP头中设置流量类或服务类型字节。
      boolean NetworkInterface.supportsMulticast​()
      返回网络接口是否支持多播。
      Constructors in java.net that throw SocketException
      Constructor 描述
      DatagramSocket​()
      构造数据报套接字并将其绑定到本地主机上的任何可用端口。
      DatagramSocket​(int port)
      构造数据报套接字并将其绑定到本地主机上的指定端口。
      DatagramSocket​(int port, InetAddress laddr)
      创建一个数据报套接字，绑定到指定的本地地址。
      DatagramSocket​(SocketAddress bindaddr)
      创建一个数据报套接字，绑定到指定的本地套接字地址。
      Socket​(SocketImpl impl)
      使用用户指定的SocketImpl创建一个未连接的Socket。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.SocketImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.SocketImpl

  • Packages that use SocketImpl
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of SocketImpl in java.net

      Methods in java.net that return SocketImpl
      Modifier and Type 方法 描述
      SocketImpl SocketImplFactory.createSocketImpl​()
      创建一个新的 SocketImpl实例。
      Methods in java.net with parameters of type SocketImpl
      Modifier and Type 方法 描述
      protected abstract void SocketImpl.accept​(SocketImpl s)
      接受连接。
      Constructors in java.net with parameters of type SocketImpl
      Constructor 描述
      Socket​(SocketImpl impl)
      使用用户指定的SocketImpl创建一个未连接的Socket。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.SocketPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.SocketPermission

No usage of java.net.SocketPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.SocketTimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.SocketTimeoutException

No usage of java.net.SocketTimeoutException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.StandardProtocolFamily (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.StandardProtocolFamily

  • Packages that use StandardProtocolFamily
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of StandardProtocolFamily in java.net

      Methods in java.net that return StandardProtocolFamily
      Modifier and Type 方法 描述
      static StandardProtocolFamily StandardProtocolFamily.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StandardProtocolFamily[] StandardProtocolFamily.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.StandardSocketOptions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.StandardSocketOptions

No usage of java.net.StandardSocketOptions
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.UnknownHostException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.UnknownHostException

  • Packages that use UnknownHostException
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    javax.net
    提供网络应用程序的类。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of UnknownHostException in java.net

      Methods in java.net that throw UnknownHostException
      Modifier and Type 方法 描述
      static InetAddress[] InetAddress.getAllByName​(String host)
      给定主机的名称，根据系统上配置的名称服务返回其IP地址数组。
      static Inet6Address Inet6Address.getByAddress​(String host, byte[] addr, int scope_id)
      以 InetAddress.getByAddress(String,byte[])的确切方式创建Inet6Address，但将IPv6范围 ID设置为给定的数值。
      static Inet6Address Inet6Address.getByAddress​(String host, byte[] addr, NetworkInterface nif)
      在的确切方式创建Inet6Address， InetAddress.getByAddress(String,byte[])不同之处在于将IPv6 scope_id设置为对应于在指定的地址类型的给定接口的值 addr 。
      static InetAddress InetAddress.getByAddress​(byte[] addr)
      给出原始IP地址的 InetAddress对象。
      static InetAddress InetAddress.getByAddress​(String host, byte[] addr)
      根据提供的主机名和IP地址创建InetAddress。
      static InetAddress InetAddress.getByName​(String host)
      确定主机名称的IP地址。
      static InetAddress InetAddress.getLocalHost​()
      返回本地主机的地址。
      Constructors in java.net that throw UnknownHostException
      Constructor 描述
      Socket​(String host, int port)
      创建流套接字并将其连接到指定主机上的指定端口号。

    • Uses of UnknownHostException in javax.net

      Methods in javax.net that throw UnknownHostException
      Modifier and Type 方法 描述
      abstract Socket SocketFactory.createSocket​(String host, int port)
      创建套接字并将其连接到指定的远程端口上的指定远程主机。
      abstract Socket SocketFactory.createSocket​(String host, int port, InetAddress localHost, int localPort)
      创建套接字并将其连接到指定远程端口上的指定远程主机。

    • Uses of UnknownHostException in javax.net.ssl

      Constructors in javax.net.ssl that throw UnknownHostException
      Constructor 描述
      SSLSocket​(String host, int port)
      仅由子类使用。
      SSLSocket​(String host, int port, InetAddress clientAddress, int clientPort)
      仅由子类使用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.UnknownServiceException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.UnknownServiceException

No usage of java.net.UnknownServiceException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.URI (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.URI

  • Packages that use URI
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.security.auth.login
    提供Configuration的实现。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.security.jarsigner

    • Uses of URI in com.sun.jarsigner

      Methods in com.sun.jarsigner that return URI
      Modifier and Type 方法 描述
      URI ContentSignerParameters.getTimestampingAuthority​()
      已过时。
      检索时间戳管理机构（TSA）的标识符。

    • Uses of URI in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return URI
      Modifier and Type 方法 描述
      abstract URI HttpExchange.getRequestURI​()
      获取请求URI

    • Uses of URI in com.sun.security.auth.login

      Constructors in com.sun.security.auth.login with parameters of type URI
      Constructor 描述
      ConfigFile​(URI uri)
      从指定的 URI创建一个新的 Configuration对象。

    • Uses of URI in java.awt

      Methods in java.awt with parameters of type URI
      Modifier and Type 方法 描述
      void Desktop.browse​(URI uri)
      启动默认浏览器以显示一个 URI 。
      void Desktop.mail​(URI mailtoURI)
      启动用户默认邮件客户端的邮件组合窗口，填写由 mailto: URI指定的邮件字段。

    • Uses of URI in java.awt.desktop

      Methods in java.awt.desktop that return URI
      Modifier and Type 方法 描述
      URI OpenURIEvent.getURI​()
      获取 URI该应用被要求打开
      Constructors in java.awt.desktop with parameters of type URI
      Constructor 描述
      OpenURIEvent​(URI uri)
      构造一个 OpenURIEvent

    • Uses of URI in java.io

      Methods in java.io that return URI
      Modifier and Type 方法 描述
      URI File.toURI​()
      构造一个表示此抽象路径名的 file: URI。
      Constructors in java.io with parameters of type URI
      Constructor 描述
      File​(URI uri)
      通过将给定的 file: URI转换为抽象路径名来创建新的 File实例。

    • Uses of URI in java.lang.module

      Methods in java.lang.module that return types with arguments of type URI
      Modifier and Type 方法 描述
      Optional<URI> ModuleReader.find​(String name)
      查找资源，将URI返回给模块中的资源。
      Optional<URI> ModuleReference.location​()
      如果已知，返回此模块内容的位置。
      Constructors in java.lang.module with parameters of type URI
      Constructor 描述
      ModuleReference​(ModuleDescriptor descriptor, URI location)
      构造一个这个类的新实例。

    • Uses of URI in java.net

      Methods in java.net that return URI
      Modifier and Type 方法 描述
      static URI URI.create​(String str)
      通过解析给定的字符串创建一个URI。
      URI URI.normalize​()
      规范此URI的路径。
      URI URI.parseServerAuthority​()
      尝试将此URI的权限组件（如果已定义）解析为用户信息，主机和端口组件。
      URI URI.relativize​(URI uri)
      相对于此URI的给定URI。
      URI URI.resolve​(String str)
      通过解析给定的字符串构造一个新的URI，然后根据此URI进行解析。
      URI URI.resolve​(URI uri)
      根据此URI解析给定的URI。
      URI URL.toURI​()
      返回相当于此URL的URI 。
      Methods in java.net that return types with arguments of type URI
      Modifier and Type 方法 描述
      List<URI> CookieStore.getURIs​()
      获取标识Cookie存储区中的Cookie的所有URI。
      Methods in java.net with parameters of type URI
      Modifier and Type | 方法 | 描述
      void CookieStore.add​(URI uri, HttpCookie cookie)
      向商店添加一个HTTP cookie。
      int URI.compareTo​(URI that)
      将此URI与另一个对象进行比较，该对象必须是URI。
      abstract void ProxySelector.connectFailed​(URI uri, SocketAddress sa, IOException ioe)
      被称为表示连接不能建立到代理/袜子服务器。
      abstract Map<String,List<String>> CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)
      从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。
      Map<String,List<String>> | CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)
      List<HttpCookie> CookieStore.get​(URI uri)
      检索与给定URI相关联的Cookie，或者其域与给定的URI匹配。
      abstract CacheResponse ResponseCache.get​(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
      根据请求的uri，请求方法和请求标头检索缓存的响应。
      abstract void CookieHandler.put​(URI uri, Map<String,List<String>> responseHeaders)
      设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。
      void | CookieManager.put​(URI uri, Map<String,List<String>> responseHeaders)
      abstract CacheRequest ResponseCache.put​(URI uri, URLConnection conn)
      协议处理程序在检索到资源后调用此方法，ResponseCache必须决定是否将资源存储在其缓存中。
      URI URI.relativize​(URI uri)
      相对于此URI的给定URI。
      boolean CookieStore.remove​(URI uri, HttpCookie cookie)
      从商店中删除一个cookie。
      URI URI.resolve​(URI uri)
      根据此URI解析给定的URI。
      abstract List<Proxy> ProxySelector.select​(URI uri)
      根据访问资源的协议选择所有适用的代理以及访问资源的目标地址。
      boolean CookiePolicy.shouldAccept​(URI uri, HttpCookie cookie)
      将被调用来查看是否应该接受该cookie。

    • Uses of URI in java.nio.file

      Methods in java.nio.file that return URI
      Modifier and Type 方法 描述
      URI Path.toUri​()
      返回一个URI来表示此路径。
      Methods in java.nio.file with parameters of type URI
      Modifier and Type 方法 描述
      static Path Paths.get​(URI uri)
      将给定的URI转换为Path对象。
      static FileSystem FileSystems.getFileSystem​(URI uri)
      返回对现有的 FileSystem的引用。
      static FileSystem FileSystems.newFileSystem​(URI uri, Map<String,?> env)
      构造一个由URI标识的新文件系统
      static FileSystem FileSystems.newFileSystem​(URI uri, Map<String,?> env, ClassLoader loader)
      构造一个由URI标识的新文件系统

    • Uses of URI in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type URI
      Modifier and Type 方法 描述
      abstract FileSystem FileSystemProvider.getFileSystem​(URI uri)
      返回此提供商创建的现有 FileSystem 。
      abstract Path FileSystemProvider.getPath​(URI uri)
      通过转换给定的URI返回一个Path对象。
      abstract FileSystem FileSystemProvider.newFileSystem​(URI uri, Map<String,?> env)
      构造由URI标识的新的 FileSystem对象。

    • Uses of URI in java.security

      Methods in java.security that return URI
      Modifier and Type 方法 描述
      URI DomainLoadStoreParameter.getConfiguration​()
      获取域配置数据的标识符。
      URI URIParameter.getURI​()
      返回URI。
      Constructors in java.security with parameters of type URI
      Constructor 描述
      DomainLoadStoreParameter​(URI configuration, Map<String,KeyStore.ProtectionParameter> protectionParams)
      使用用于保护密钥库数据的参数构建密钥库域的DomainLoadStoreParameter。
      URIParameter​(URI uri)
      构造URIParameter，URI指向用于SPI实现的数据。

    • Uses of URI in java.security.cert

      Methods in java.security.cert that return URI
      Modifier and Type 方法 描述
      URI PKIXRevocationChecker.getOcspResponder​()
      获取标识OCSP响应器位置的URI。
      URI URICertStoreParameters.getURI​()
      返回用于构造此 URICertStoreParameters对象的URI。
      Methods in java.security.cert with parameters of type URI
      Modifier and Type 方法 描述
      void PKIXRevocationChecker.setOcspResponder​(URI uri)
      设置标识OCSP响应器位置的URI。
      Constructors in java.security.cert with parameters of type URI
      Constructor 描述
      URICertStoreParameters​(URI uri)
      使用指定的URI创建一个 URICertStoreParameters的实例。

    • Uses of URI in javax.print

      Methods in javax.print that return URI
      Modifier and Type 方法 描述
      URI URIException.getUnsupportedURI​()
      返回URI。

    • Uses of URI in javax.print.attribute

      Methods in javax.print.attribute that return URI
      Modifier and Type 方法 描述
      URI URISyntax.getURI​()
      返回此URI属性的URI值。
      Constructors in javax.print.attribute with parameters of type URI
      Constructor 描述
      URISyntax​(URI uri)
      构造具有指定URI的URI属性。

    • Uses of URI in javax.print.attribute.standard

      Constructors in javax.print.attribute.standard with parameters of type URI
      Constructor 描述
      Destination​(URI uri)
      使用指定的URI构造新的目标属性。
      PrinterMoreInfo​(URI uri)
      使用指定的URI构造一个新的打印机more info属性。
      PrinterMoreInfoManufacturer​(URI uri)
      使用指定的URI构造新的打印机更多信息制造商属性。
      PrinterURI​(URI uri)
      使用指定的URI构造一个新的PrinterURI属性。

    • Uses of URI in javax.tools

      Fields in javax.tools declared as URI
      Modifier and Type Field 描述
      protected URI SimpleJavaFileObject.uri
      此文件对象的URI。
      Methods in javax.tools that return URI
      Modifier and Type | 方法 | 描述
      URI FileObject.toUri​()
      返回标识此文件对象的URI。
      URI | ForwardingFileObject.toUri​()
      URI | SimpleJavaFileObject.toUri​()
      Constructors in javax.tools with parameters of type URI
      Constructor 描述
      SimpleJavaFileObject​(URI uri, JavaFileObject.Kind kind)
      构造给定类型的SimpleJavaFileObject和给定的URI。

    • Uses of URI in javax.xml.bind

      Methods in javax.xml.bind with parameters of type URI
      Modifier and Type 方法 描述
      static void JAXB.marshal​(Object jaxbObject, URI xml)
      将Java对象树写入XML并将其存储到指定的位置。
      static <T> T JAXB.unmarshal​(URI xml, Class<T> type)
      从给定的XML输入中读取Java对象树。

    • Uses of URI in javax.xml.catalog

      Methods in javax.xml.catalog with parameters of type URI
      Modifier and Type 方法 描述
      static Catalog CatalogManager.catalog​(CatalogFeatures features, URI... uris)
      使用指定的功能设置和uri创建一个 Catalog对象到一个或多个目录文件。
      static CatalogResolver CatalogManager.catalogResolver​(CatalogFeatures features, URI... uris)
      使用指定的功能设置和uri创建一个 CatalogResolver的实例到一个或多个目录文件。

    • Uses of URI in jdk.incubator.http

      Methods in jdk.incubator.http that return URI
      Modifier and Type 方法 描述
      abstract URI HttpRequest.uri​()
      返回此请求的请求 URI 。
      abstract URI HttpResponse.uri​()
      返回收到的响应的 URI 。
      Methods in jdk.incubator.http with parameters of type URI
      Modifier and Type 方法 描述
      static HttpRequest.Builder HttpRequest.newBuilder​(URI uri)
      创建一个 HttpRequest构建器。
      WebSocket.Builder HttpClient.newWebSocketBuilder​(URI uri, WebSocket.Listener listener)
      创建连接到给定URI的WebSocket实例的构建器，并接收给定的Listener事件和消息。
      abstract HttpRequest.Builder HttpRequest.Builder.uri​(URI uri)
      设置 HttpRequest的请求 URI 。

    • Uses of URI in jdk.security.jarsigner

      Methods in jdk.security.jarsigner that return URI
      Modifier and Type 方法 描述
      URI JarSigner.getTsa​()
      返回时间戳局（TSA）的URI。
      Methods in jdk.security.jarsigner with parameters of type URI
      Modifier and Type 方法 描述
      JarSigner.Builder JarSigner.Builder.tsa​(URI uri)
      设置时间戳局（TSA）的URI。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.URISyntaxException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.URISyntaxException

  • Packages that use URISyntaxException
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of URISyntaxException in java.net

      Methods in java.net that throw URISyntaxException
      Modifier and Type 方法 描述
      URI URI.parseServerAuthority​()
      尝试将此URI的权限组件（如果已定义）解析为用户信息，主机和端口组件。
      URI URL.toURI​()
      返回相当于此URL的URI 。
      Constructors in java.net that throw URISyntaxException
      Constructor 描述
      URI​(String str)
      通过解析给定的字符串构造一个URI。
      URI​(String scheme, String ssp, String fragment)
      从给定的组件构造一个URI。
      URI​(String scheme, String userInfo, String host, int port, String path, String query, String fragment)
      从给定的组件构造一个分层URI。
      URI​(String scheme, String host, String path, String fragment)
      从给定的组件构造一个分层URI。
      URI​(String scheme, String authority, String path, String query, String fragment)
      从给定的组件构造一个分层URI。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.URL (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.URL

  • Packages that use URL
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.activation
    javax.imageio
    Java Image I / O API的主要包。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.midi.spi
    为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sound.sampled.spi
    为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.validation
    提供用于验证XML文档的API。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。

    • Uses of URL in java.applet

      Methods in java.applet that return URL
      Modifier and Type 方法 描述
      URL Applet.getCodeBase​()
      已过时。
      获取基本URL。
      URL AppletStub.getCodeBase​()
      已过时。
      获取基本URL。
      URL Applet.getDocumentBase​()
      已过时。
      获取嵌入此小程序的文档的URL。
      URL AppletStub.getDocumentBase​()
      已过时。
      获取嵌入小程序的文档的URL。
      Methods in java.applet with parameters of type URL
      Modifier and Type 方法 描述
      AudioClip Applet.getAudioClip​(URL url)
      已过时。
      返回由 URL参数指定的 AudioClip对象。
      AudioClip Applet.getAudioClip​(URL url, String name)
      已过时。
      返回由 URL和 name参数指定的 AudioClip对象。
      AudioClip AppletContext.getAudioClip​(URL url)
      已过时。
      创建音频剪辑。
      Image Applet.getImage​(URL url)
      已过时。
      返回一个 Image对象，然后可以在屏幕上绘制。
      Image Applet.getImage​(URL url, String name)
      已过时。
      返回一个 Image对象，然后可以在屏幕上绘制。
      Image AppletContext.getImage​(URL url)
      已过时。
      返回一个 Image对象，然后可以在屏幕上绘制。
      static AudioClip Applet.newAudioClip​(URL url)
      已过时。
      从给定的URL获取音频剪辑。
      void Applet.play​(URL url)
      已过时。
      以指定的绝对URL播放音频剪辑。
      void Applet.play​(URL url, String name)
      已过时。
      播放给定URL的音频剪辑和与之相关的说明符。
      void AppletContext.showDocument​(URL url)
      已过时。
      请求浏览器或小程序查看器显示由 url参数指示的 url 。
      void AppletContext.showDocument​(URL url, String target)
      已过时。
      请求浏览器或小程序查看器显示由 url参数指示的 url 。

    • Uses of URL in java.awt

      Methods in java.awt that return URL
      Modifier and Type 方法 描述
      URL SplashScreen.getImageURL​()
      返回当前的闪屏图像。
      Methods in java.awt with parameters of type URL
      Modifier and Type 方法 描述
      abstract Image Toolkit.createImage​(URL url)
      返回从指定的URL获取像素数据的图像。
      abstract Image Toolkit.getImage​(URL url)
      返回从指定的URL获取像素数据的图像。
      void SplashScreen.setImageURL​(URL imageURL)
      更改启动屏幕图像。

    • Uses of URL in java.beans.beancontext

      Methods in java.beans.beancontext that return URL
      Modifier and Type | 方法 | 描述
      URL BeanContext.getResource​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResource() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。
      URL | BeanContextSupport.getResource​(String name, BeanContextChild bcc)

    • Uses of URL in java.io

      Methods in java.io that return URL
      Modifier and Type 方法 描述
      URL File.toURL​()
      已过时。
      此方法不会自动转义URL中非法的字符。 建议在新的代码转换的抽象路径到URL通过先转换成URI，经由toURI方法，然后经由转换URI为URL URI.toURL方法。

    • Uses of URL in java.lang

      Methods in java.lang that return URL
      Modifier and Type 方法 描述
      protected URL ClassLoader.findResource​(String name)
      找到具有给定名称的资源。
      protected URL ClassLoader.findResource​(String moduleName, String name)
      返回一个URL定义到此类加载器的模块中的资源。
      URL Class.getResource​(String name)
      查找具有给定名称的资源。
      URL ClassLoader.getResource​(String name)
      找到具有给定名称的资源。
      static URL ClassLoader.getSystemResource​(String name)
      从用于加载类的搜索路径中查找指定名称的资源。
      Methods in java.lang that return types with arguments of type URL
      Modifier and Type 方法 描述
      protected Enumeration<URL> ClassLoader.findResources​(String name)
      返回表示具有给定名称的所有资源的URL对象的枚举。
      Enumeration<URL> ClassLoader.getResources​(String name)
      查找具有给定名称的所有资源。
      static Enumeration<URL> ClassLoader.getSystemResources​(String name)
      从用于加载类的搜索路径中查找指定名称的所有资源。
      Stream<URL> ClassLoader.resources​(String name)
      返回一个流，其元素是具有给定名称的所有资源的URL。
      Methods in java.lang with parameters of type URL
      Modifier and Type 方法 描述
      protected 软件包 ClassLoader.definePackage​(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase)
      通过定义一个包 name在这个 ClassLoader 。
      boolean Package.isSealed​(URL url)
      如果此封装相对于指定的代码源 url进行了密封，则返回true。

    • Uses of URL in java.net

      Fields in java.net declared as URL
      Modifier and Type Field 描述
      protected URL URLConnection.url
      URL表示打开此连接的万维网上的远程对象。
      Methods in java.net that return URL
      Modifier and Type 方法 描述
      URL URLClassLoader.findResource​(String name)
      在URL搜索路径上查找具有指定名称的资源。
      URL JarURLConnection.getJarFileURL​()
      返回此连接的Jar文件的URL。
      protected URL Authenticator.getRequestingURL​()
      返回导致此请求验证的URL。
      URL URLConnection.getURL​()
      返回此 URLConnection的 URL字段的值。
      URL[] URLClassLoader.getURLs​()
      返回加载类和资源的URL的搜索路径。
      URL URI.toURL​()
      从此URI构造一个URL。
      Methods in java.net that return types with arguments of type URL
      Modifier and Type 方法 描述
      Enumeration<URL> URLClassLoader.findResources​(String name)
      返回表示URL搜索路径上具有指定名称的所有资源的URL的枚举。
      Methods in java.net with parameters of type URL
      Modifier and Type 方法 描述
      protected void URLClassLoader.addURL​(URL url)
      将指定的URL附加到URL列表中以搜索类和资源。
      protected 软件包 URLClassLoader.definePackage​(String name, Manifest man, URL url)
      在这个 URLClassLoader按名称定义一个新的包。
      protected boolean URLStreamHandler.equals​(URL u1, URL u2)
      提供默认的equals计算。
      protected InetAddress URLStreamHandler.getHostAddress​(URL u)
      获取我们的主机的IP地址。
      protected int URLStreamHandler.hashCode​(URL u)
      提供默认散列计算。
      protected boolean URLStreamHandler.hostsEqual​(URL u1, URL u2)
      比较两个URL的主机组件。
      static URLClassLoader URLClassLoader.newInstance​(URL[] urls)
      为指定的URL和默认父类加载器创建URLClassLoader的新实例。
      static URLClassLoader URLClassLoader.newInstance​(URL[] urls, ClassLoader parent)
      为指定的URL和父类加载器创建URLClassLoader的新实例。
      protected abstract URLConnection URLStreamHandler.openConnection​(URL u)
      打开与 URL参数引用的对象的连接。
      protected URLConnection URLStreamHandler.openConnection​(URL u, Proxy p)
      与openConnection（URL）相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
      protected void URLStreamHandler.parseURL​(URL u, String spec, int start, int limit)
      将 URL的字符串表示解析为 URL对象。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      请向系统注册的验证者询问密码。
      static PasswordAuthentication Authenticator.requestPasswordAuthentication​(Authenticator authenticator, String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      询问给定的 authenticator密码。
      PasswordAuthentication Authenticator.requestPasswordAuthenticationInstance​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      向该验证者询问密码。
      boolean URL.sameFile​(URL other)
      比较两个URL，不包括片段组件。
      protected boolean URLStreamHandler.sameFile​(URL u1, URL u2)
      比较两个URL以查看它们是否引用相同的文件，即具有相同的协议，主机，端口和路径。
      protected void URLStreamHandler.setURL​(URL u, String protocol, String host, int port, String file, String ref)
      已过时。
      使用setURL（URL，String，String，int，String，String，String，String）;
      protected void URLStreamHandler.setURL​(URL u, String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)
      将 URL参数的字段设置为指示的值。
      protected String URLStreamHandler.toExternalForm​(URL u)
      一个转换 URL特定协议到的 String 。
      Constructors in java.net with parameters of type URL
      Constructor 描述
      HttpURLConnection​(URL u)
      HttpURLConnection的构造方法。
      JarURLConnection​(URL url)
      创建新的JarURLConnection到指定的URL。
      URL​(URL context, String spec)
      通过在指定的上下文中解析给定的规范来创建一个URL。
      URL​(URL context, String spec, URLStreamHandler handler)
      通过在指定上下文中使用指定的处理程序解析给定规范来创建URL。
      URLClassLoader​(String name, URL[] urls, ClassLoader parent)
      为指定的URL构造一个新的命名为 URLClassLoader 。
      URLClassLoader​(String name, URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的命名为 URLClassLoader 。
      URLClassLoader​(URL[] urls)
      使用默认委托父母 ClassLoader为指定的URL构造一个新的URLClassLoader。
      URLClassLoader​(URL[] urls, ClassLoader parent)
      为给定的URL构造一个新的URLClassLoader。
      URLClassLoader​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的URLClassLoader。
      URLConnection​(URL url)
      构造与指定URL的URL连接。

    • Uses of URL in java.rmi.server

      Methods in java.rmi.server with parameters of type URL
      Modifier and Type 方法 描述
      Class<?> LoaderHandler.loadClass​(URL codebase, String name)
      已过时。
      没有替换
      static Class<?> RMIClassLoader.loadClass​(URL codebase, String name)
      从代码库URL加载一个类。

    • Uses of URL in java.security

      Methods in java.security that return URL
      Modifier and Type 方法 描述
      URL CodeSource.getLocation​()
      返回与此CodeSource关联的位置。
      Constructors in java.security with parameters of type URL
      Constructor 描述
      CodeSource​(URL url, Certificate[] certs)
      构造一个CodeSource并将其与指定的位置和证书集合相关联。
      CodeSource​(URL url, CodeSigner[] signers)
      构造CodeSource并将其与指定的位置和代码签名者集合相关联。

    • Uses of URL in java.sql

      Methods in java.sql that return URL
      Modifier and Type 方法 描述
      URL CallableStatement.getURL​(int parameterIndex)
      以 java.net.URL对象的形式获取指定的JDBC DATALINK参数的值。
      URL CallableStatement.getURL​(String parameterName)
      检索作为 java.net.URL对象的JDBC DATALINK参数的值。
      URL ResultSet.getURL​(int columnIndex)
      将该 ResultSet对象的当前行中的指定列的值作为Java编程语言中的 java.net.URL对象 java.net.URL 。
      URL ResultSet.getURL​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.net.URL对象。
      URL SQLInput.readURL​()
      从流中读取SQL DATALINK值，并将其作为Java编程语言中的 java.net.URL对象返回。
      Methods in java.sql with parameters of type URL
      Modifier and Type 方法 描述
      void CallableStatement.setURL​(String parameterName, URL val)
      将指定的参数设置为给定的 java.net.URL对象。
      void PreparedStatement.setURL​(int parameterIndex, URL x)
      将指定的参数设置为给定的 java.net.URL值。
      void SQLOutput.writeURL​(URL x)
      向流中写入一个SQL DATALINK值。

    • Uses of URL in javafx.css

      Methods in javafx.css with parameters of type URL
      Modifier and Type 方法 描述
      static Stylesheet Stylesheet.loadBinary​(URL url)
      从输入流加载二进制样式表文件。
      Stylesheet CssParser.parse​(URL url)
      通过从URL读取CSS文档来更新给定的样式表，假设UTF-8编码。

    • Uses of URL in javafx.fxml

      Methods in javafx.fxml that return URL
      Modifier and Type 方法 描述
      URL FXMLLoader.getLocation​()
      返回用于解析相对路径属性值的位置。
      Methods in javafx.fxml with parameters of type URL
      Modifier and Type 方法 描述
      void Initializable.initialize​(URL location, ResourceBundle resources)
      被调用以在其根元素被完全处理之后初始化控制器。
      static <T> T FXMLLoader.load​(URL location)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      从FXML文档加载对象层次结构。
      void FXMLLoader.setLocation​(URL location)
      设置用于解析相对路径属性值的位置。
      Constructors in javafx.fxml with parameters of type URL
      Constructor 描述
      FXMLLoader​(URL location)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)
      创建一个新的FXMLLoader实例。

    • Uses of URL in javax.activation

      Methods in javax.activation that return URL
      Modifier and Type 方法 描述
      URL URLDataSource.getURL​()
      返回用于创建此DataSource的URL。
      Constructors in javax.activation with parameters of type URL
      Constructor 描述
      DataHandler​(URL url)
      创建引用URL的 DataHandler实例。
      URLDataSource​(URL url)
      URLDataSource构造函数。

    • Uses of URL in javax.imageio

      Methods in javax.imageio with parameters of type URL
      Modifier and Type 方法 描述
      static BufferedImage ImageIO.read​(URL input)
      作为对所提供的 URL进行解码的结果，返回 BufferedImage ，其中自动从当前注册的 ImageReader选择一个 ImageReader 。

    • Uses of URL in javax.jnlp

      Methods in javax.jnlp that return URL
      Modifier and Type 方法 描述
      URL BasicService.getCodeBase​()
      返回应用程序的代码库。
      URL ExtensionInstallerService.getExtensionLocation​()
      返回正在安装的扩展的位置
      Methods in javax.jnlp with parameters of type URL
      Modifier and Type 方法 描述
      long PersistenceService.create​(URL url, long maxsize)
      在客户端创建一个以给定的URL命名的永久存储条目。
      void PersistenceService.delete​(URL url)
      从客户端日期持久性存储中删除与给定URL相关联的流。
      void DownloadServiceListener.downloadFailed​(URL url, String version)
      如果下载失败或意外中止，JNLP客户端的 DownloadService实现应该调用此方法。
      FileContents PersistenceService.get​(URL url)
      返回表示此文件内容的 FileContents对象。
      String ExtensionInstallerService.getInstalledJRE​(URL url, String version)
      返回给定JRE的可执行文件的路径。
      String[] PersistenceService.getNames​(URL url)
      返回一个字符串数组，其中包含给定URL的所有条目的名称。
      int PersistenceService.getTag​(URL url)
      返回对应于与给定URL相关联的持久性数据存储条目的标签的当前值的 int 。
      boolean DownloadService.isExtensionPartCached​(URL ref, String version, String part)
      如果给定的扩展名的给定部分被缓存，并且在应用程序的JNLP文件中提到扩展名和部分，则返回 true 。
      boolean DownloadService.isExtensionPartCached​(URL ref, String version, String[] parts)
      如果给定的扩展名的给定部分被缓存，并且该应用程序的JNLP文件中提到了扩展名和部分，则返回 true 。
      boolean DownloadService.isResourceCached​(URL ref, String version)
      如果给定的URL和版本引用的资源被缓存，并且该资源在调用应用程序JNLP文件中被提及，则在调用应用程序JNLP文件的代码库中，或者调用应用程序已被授予所有权限，则返回true 。 。
      void DownloadService.loadExtensionPart​(URL ref, String version, String[] parts, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了部件和扩展名，请下载给定扩展的给定部分。
      void DownloadService.loadExtensionPart​(URL ref, String version, String part, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了部分和扩展名，请下载给定扩展的给定部分。
      void DownloadService.loadResource​(URL ref, String version, DownloadServiceListener progress)
      如果在调用的应用程序JNLP文件中提到资源，请下载给定的资源，是在调用应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。
      void DownloadServiceListener.progress​(URL url, String version, long readSoFar, long total, int overallPercent)
      JNLP客户端的 DownloadService实现在下载过程中应该多次调用此方法。
      void DownloadService.removeExtensionPart​(URL ref, String version, String part)
      如果在应用程序的JNLP文件中提到了部分和扩展名，则从缓存中删除给定扩展的给定部分。
      void DownloadService.removeExtensionPart​(URL ref, String version, String[] parts)
      如果在应用程序的JNLP文件中提到了部件和扩展名，则从缓存中删除给定扩展的给定部分。
      void DownloadService.removeResource​(URL ref, String version)
      如果在调用应用程序JNLP文件中提到资源，则从缓存中删除给定的资源，在调用的应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。
      void PersistenceService.setTag​(URL url, int tag)
      使用给定的标签值标记与给定URL相关联的持久数据存储条目。
      boolean BasicService.showDocument​(URL url)
      指导客户端上的浏览器显示给定的URL。
      void DownloadServiceListener.upgradingArchive​(URL url, String version, int patchPercent, int overallPercent)
      JNLP客户端的 DownloadService实现应该在缓存资源中应用增量更新时至少应该调用此方法。
      void DownloadServiceListener.validating​(URL url, String version, long entry, long total, int overallPercent)
      在验证下载过程中，JNLP客户端的 DownloadService实现应至少调用此方法。

    • Uses of URL in javax.management.loading

      Methods in javax.management.loading that return URL
      Modifier and Type 方法 描述
      protected URL MLet.check​(String version, URL codebase, String jarfile, MLetContent mlet)
      当扩展此服务以支持缓存和版本控制时，此方法将被覆盖。
      URL MLetContent.getCodeBase​()
      获取代码库URL。
      URL MLetContent.getDocumentBase​()
      获取MLet文本文件的基本URL。
      URL MLetMBean.getResource​(String name)
      找到具有给定名称的资源。
      URL[] MLet.getURLs​()
      返回加载类和资源的URL的搜索路径。
      URL[] MLetMBean.getURLs​()
      返回加载类和资源的URL的搜索路径。
      Methods in javax.management.loading that return types with arguments of type URL
      Modifier and Type 方法 描述
      Enumeration<URL> MLetMBean.getResources​(String name)
      查找具有给定名称的所有资源。
      Methods in javax.management.loading with parameters of type URL
      Modifier and Type 方法 描述
      void MLet.addURL​(URL url)
      将指定的URL附加到URL列表中以搜索类和资源。
      void MLetMBean.addURL​(URL url)
      将指定的URL附加到URL列表中以搜索类和资源。
      protected URL MLet.check​(String version, URL codebase, String jarfile, MLetContent mlet)
      当扩展此服务以支持缓存和版本控制时，此方法将被覆盖。
      Set<Object> MLet.getMBeansFromURL​(URL url)
      加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。
      Set<Object> MLetMBean.getMBeansFromURL​(URL url)
      加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。
      Constructors in javax.management.loading with parameters of type URL
      Constructor 描述
      MLet​(URL[] urls)
      使用默认的委派父类ClassLoader构造指定URL的新MLet。
      MLet​(URL[] urls, boolean delegateToCLR)
      使用默认的委派父类ClassLoader构造指定URL的新MLet。
      MLet​(URL[] urls, ClassLoader parent)
      为给定的URL构造一个新的MLet。
      MLet​(URL[] urls, ClassLoader parent, boolean delegateToCLR)
      为给定的URL构造一个新的MLet。
      MLet​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的MLet。
      MLet​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的MLet。
      MLetContent​(URL url, Map<String,String> attributes, List<String> types, List<String> values)
      创建一个 MLet实例，使用从MLet文本文件中的 MLET标记读取的属性初始化。
      PrivateMLet​(URL[] urls, boolean delegateToCLR)
      使用默认的委派父类ClassLoader构造一个新的指定URL的PrivateMLet。
      PrivateMLet​(URL[] urls, ClassLoader parent, boolean delegateToCLR)
      为给定的URL构造一个新的PrivateMLet。
      PrivateMLet​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的PrivateMLet。

    • Uses of URL in javax.net.ssl

      Constructors in javax.net.ssl with parameters of type URL
      Constructor 描述
      HttpsURLConnection​(URL url)
      使用指定的URL创建一个 HttpsURLConnection 。

    • Uses of URL in javax.sound.midi

      Methods in javax.sound.midi with parameters of type URL
      Modifier and Type 方法 描述
      static MidiFileFormat MidiSystem.getMidiFileFormat​(URL url)
      获取指定URL中数据的MIDI文件格式。
      static Sequence MidiSystem.getSequence​(URL url)
      从指定的URL获取MIDI序列。
      static Soundbank MidiSystem.getSoundbank​(URL url)
      通过从指定的URL读取它构建一个 Soundbank 。

    • Uses of URL in javax.sound.midi.spi

      Methods in javax.sound.midi.spi with parameters of type URL
      Modifier and Type 方法 描述
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat​(URL url)
      获取提供的URL的MIDI文件格式。
      abstract Sequence MidiFileReader.getSequence​(URL url)
      从提供的URL获取MIDI序列。
      abstract Soundbank SoundbankReader.getSoundbank​(URL url)
      从提供的URL获取声音库对象。

    • Uses of URL in javax.sound.sampled

      Methods in javax.sound.sampled with parameters of type URL
      Modifier and Type 方法 描述
      static AudioFileFormat AudioSystem.getAudioFileFormat​(URL url)
      获取指定URL的音频文件格式。
      static AudioInputStream AudioSystem.getAudioInputStream​(URL url)
      从提供的URL获取音频输入流。

    • Uses of URL in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi with parameters of type URL
      Modifier and Type 方法 描述
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat​(URL url)
      获取提供的URL的音频文件格式。
      abstract AudioInputStream AudioFileReader.getAudioInputStream​(URL url)
      从提供的URL获取音频输入流。

    • Uses of URL in javax.sql

      Methods in javax.sql with parameters of type URL
      Modifier and Type 方法 描述
      void RowSet.setURL​(int parameterIndex, URL x)
      将指定的参数设置为给定的 java.net.URL值。

    • Uses of URL in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type URL
      Modifier and Type 方法 描述
      void BaseRowSet.setURL​(int parameterIndex, URL x)
      将指定的参数设置为给定的 java.net.URL值。

    • Uses of URL in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return URL
      Modifier and Type 方法 描述
      URL SerialDatalink.getDatalink​()
      返回一个新的URL，该URL是此 SerialDatalink对象的副本。
      URL SQLInputImpl.readURL​()
      从流中读取SQL DATALINK值，并将其作为Java编程语言中的 URL对象返回。
      Methods in javax.sql.rowset.serial with parameters of type URL
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeURL​(URL url)
      将Java编程语言中的一个 java.sql.Type.DATALINK对象写入此 SQLOutputImpl对象。
      Constructors in javax.sql.rowset.serial with parameters of type URL
      Constructor 描述
      SerialDatalink​(URL url)
      构造一个新 SerialDatalink从给定对象 java.net.URL对象。

    • Uses of URL in javax.swing

      Methods in javax.swing that return URL
      Modifier and Type 方法 描述
      URL JEditorPane.getPage​()
      获取正在显示的当前URL。
      Methods in javax.swing with parameters of type URL
      Modifier and Type 方法 描述
      protected InputStream JEditorPane.getStream​(URL page)
      获取给定URL的流，即将由 setPage方法加载。
      void JEditorPane.setPage​(URL page)
      设置显示的当前URL。
      Constructors in javax.swing with parameters of type URL
      Constructor 描述
      ImageIcon​(URL location)
      从指定的URL创建一个ImageIcon。
      ImageIcon​(URL location, String description)
      从指定的URL创建一个ImageIcon。
      JEditorPane​(URL initialPage)
      根据指定的URL创建 JEditorPane以进行输入。

    • Uses of URL in javax.swing.event

      Methods in javax.swing.event that return URL
      Modifier and Type 方法 描述
      URL HyperlinkEvent.getURL​()
      获取链接引用的URL。
      Constructors in javax.swing.event with parameters of type URL
      Constructor 描述
      HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u)
      创建一个表示超文本链接事件的新对象。
      HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc)
      创建一个表示超文本链接事件的新对象。
      HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
      创建一个表示超文本链接事件的新对象。
      HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement, InputEvent inputEvent)
      创建一个表示超文本链接事件的新对象。

    • Uses of URL in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type URL
      Modifier and Type 方法 描述
      void SynthLookAndFeel.load​(URL url)
      加载组 SynthStyle将由本使用的S SynthLookAndFeel 。

    • Uses of URL in javax.swing.text.html

      Methods in javax.swing.text.html that return URL
      Modifier and Type 方法 描述
      URL HTMLDocument.getBase​()
      返回相对URL的位置。
      URL StyleSheet.getBase​()
      返回基数。
      URL ImageView.getImageURL​()
      返回图像源的URL，如果无法确定，则返回null。
      Methods in javax.swing.text.html with parameters of type URL
      Modifier and Type 方法 描述
      void StyleSheet.importStyleSheet​(URL url)
      从 url导入样式表。
      void StyleSheet.loadRules​(Reader in, URL ref)
      加载一组以CSS1语法指定的规则。
      void HTMLDocument.setBase​(URL u)
      设置解析相对URL的位置。
      void StyleSheet.setBase​(URL base)
      设置基数。
      Constructors in javax.swing.text.html with parameters of type URL
      Constructor 描述
      HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
      创建一个表示html框架超文本链接事件的新对象。
      HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
      创建一个表示超文本链接事件的新对象。
      HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, InputEvent inputEvent, String targetFrame)
      创建一个表示超文本链接事件的新对象。
      HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
      创建一个表示超文本链接事件的新对象。
      HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
      创建一个表示超文本链接事件的新对象。

    • Uses of URL in javax.xml.bind

      Methods in javax.xml.bind that return URL
      Modifier and Type 方法 描述
      URL ValidationEventLocator.getURL​()
      返回XML源的名称作为URL（如果可用）
      Methods in javax.xml.bind with parameters of type URL
      Modifier and Type 方法 描述
      static void JAXB.marshal​(Object jaxbObject, URL xml)
      将Java对象树写入XML并将其存储到指定的位置。
      static <T> T JAXB.unmarshal​(URL xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      Object Unmarshaller.unmarshal​(URL url)
      从指定的URL解组XML数据并返回生成的内容树。

    • Uses of URL in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return URL
      Modifier and Type | 方法 | 描述
      URL | ValidationEventLocatorImpl.getURL​()
      Methods in javax.xml.bind.helpers with parameters of type URL
      Modifier and Type | 方法 | 描述
      void ValidationEventLocatorImpl.setURL​(URL _url)
      设置此事件定位器上的URL字段。
      Object | AbstractUnmarshallerImpl.unmarshal​(URL url)

    • Uses of URL in javax.xml.validation

      Methods in javax.xml.validation with parameters of type URL
      Modifier and Type 方法 描述
      Schema SchemaFactory.newSchema​(URL schema)
      将指定的 URL解析为模式，并将其作为 Schema返回。

    • Uses of URL in javax.xml.ws

      Methods in javax.xml.ws that return URL
      Modifier and Type 方法 描述
      URL Service.getWSDLDocumentLocation​()
      获取此服务的WSDL文档的位置。
      Methods in javax.xml.ws with parameters of type URL
      Modifier and Type 方法 描述
      static Service Service.create​(URL wsdlDocumentLocation, QName serviceName)
      创建一个 Service实例。
      static Service Service.create​(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      创建一个 Service实例。
      Constructors in javax.xml.ws with parameters of type URL
      Constructor 描述
      Service​(URL wsdlDocumentLocation, QName serviceName)
      创建一个 Service 。
      Service​(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      创建一个 Service 。

    • Uses of URL in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return URL
      Modifier and Type 方法 描述
      abstract URL ServiceDelegate.getWSDLDocumentLocation​()
      获取此服务的WSDL文档的位置。
      Methods in javax.xml.ws.spi with parameters of type URL
      Modifier and Type 方法 描述
      abstract ServiceDelegate Provider.createServiceDelegate​(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass)
      创建服务委托对象。
      ServiceDelegate Provider.createServiceDelegate​(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      创建服务委托对象。

    • Uses of URL in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that return URL
      Modifier and Type 方法 描述
      URL URLReader.getURL​()
      这位读者的网址
      Constructors in jdk.nashorn.api.scripting with parameters of type URL
      Constructor 描述
      URLReader​(URL url)
      构造函数
      URLReader​(URL url, String charsetName)
      构造函数
      URLReader​(URL url, Charset cs)
      构造函数

    • Uses of URL in jdk.nashorn.api.tree

      Methods in jdk.nashorn.api.tree with parameters of type URL
      Modifier and Type 方法 描述
      CompilationUnitTree Parser.parse​(URL url, DiagnosticListener listener)
      解析源URL并返回编译单元树
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.URLClassLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.URLClassLoader

  • Packages that use URLClassLoader
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    javax.management.loading
    提供实现高级动态加载的类。

    • Uses of URLClassLoader in java.net

      Methods in java.net that return URLClassLoader
      Modifier and Type 方法 描述
      static URLClassLoader URLClassLoader.newInstance​(URL[] urls)
      为指定的URL和默认父类加载器创建URLClassLoader的新实例。
      static URLClassLoader URLClassLoader.newInstance​(URL[] urls, ClassLoader parent)
      为指定的URL和父类加载器创建URLClassLoader的新实例。

    • Uses of URLClassLoader in javax.management.loading

      Subclasses of URLClassLoader in javax.management.loading
      Modifier and Type Class 描述
      class  MLet
      允许您在来自远程URL的MBean服务器中实例化和注册一个或多个MBean。
      class  PrivateMLet
      未添加到ClassLoaderRepository的MLet。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.URLConnection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.URLConnection

  • Packages that use URLConnection
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of URLConnection in java.net

      Subclasses of URLConnection in java.net
      Modifier and Type Class 描述
      class  HttpURLConnection
      支持HTTP特定功能的URLConnection。
      class  JarURLConnection
      与Java ARchive（JAR）文件或JAR文件中的条目的URL连接。
      Fields in java.net declared as URLConnection
      Modifier and Type Field 描述
      protected URLConnection JarURLConnection.jarFileURLConnection
      与JAR文件URL的连接，如果连接已启动。
      Methods in java.net that return URLConnection
      Modifier and Type 方法 描述
      URLConnection URL.openConnection​()
      返回一个URLConnection实例表示由所引用的远程对象的连接URL 。
      URLConnection URL.openConnection​(Proxy proxy)
      与URL.openConnection()相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
      protected abstract URLConnection URLStreamHandler.openConnection​(URL u)
      打开与 URL参数引用的对象的连接。
      protected URLConnection URLStreamHandler.openConnection​(URL u, Proxy p)
      与openConnection（URL）相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
      Methods in java.net with parameters of type URLConnection
      Modifier and Type 方法 描述
      abstract Object ContentHandler.getContent​(URLConnection urlc)
      给定位于对象表示开头的URL连接流，该方法读取该流并从中创建一个对象。
      Object ContentHandler.getContent​(URLConnection urlc, Class[] classes)
      给定位于对象表示开始处的URL连接流，该方法读取该流并创建一个与指定类型匹配的对象。
      abstract CacheRequest ResponseCache.put​(URI uri, URLConnection conn)
      协议处理程序在检索到资源后调用此方法，ResponseCache必须决定是否将资源存储在其缓存中。

    • Uses of URLConnection in javax.net.ssl

      Subclasses of URLConnection in javax.net.ssl
      Modifier and Type Class 描述
      class  HttpsURLConnection
      HttpsURLConnection extends HttpURLConnection with support for https-specific features.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.URLDecoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.URLDecoder

No usage of java.net.URLDecoder
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.URLEncoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.URLEncoder

No usage of java.net.URLEncoder
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.URLPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.URLPermission

No usage of java.net.URLPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.URLStreamHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.URLStreamHandler

  • Packages that use URLStreamHandler
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of URLStreamHandler in java.net

      Methods in java.net that return URLStreamHandler
      Modifier and Type 方法 描述
      URLStreamHandler URLStreamHandlerFactory.createURLStreamHandler​(String protocol)
      使用指定的协议创建一个新的 URLStreamHandler实例。
      Constructors in java.net with parameters of type URLStreamHandler
      Constructor 描述
      URL​(String protocol, String host, int port, String file, URLStreamHandler handler)
      创建 URL从指定对象 protocol ， host ， port号码， file ，和 handler 。
      URL​(URL context, String spec, URLStreamHandler handler)
      通过在指定上下文中使用指定的处理程序解析给定规范来创建URL。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.ContentHandlerFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.ContentHandlerFactory

  • Packages that use ContentHandlerFactory
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of ContentHandlerFactory in java.net

      Methods in java.net with parameters of type ContentHandlerFactory
      Modifier and Type 方法 描述
      static void URLConnection.setContentHandlerFactory​(ContentHandlerFactory fac)
      设置应用程序的 ContentHandlerFactory 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.CookiePolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.CookiePolicy

  • Packages that use CookiePolicy
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of CookiePolicy in java.net

      Fields in java.net declared as CookiePolicy
      Modifier and Type Field 描述
      static CookiePolicy CookiePolicy.ACCEPT_ALL
      一个预定义的政策接受所有的cookies。
      static CookiePolicy CookiePolicy.ACCEPT_NONE
      一个预先定义的政策，不接受Cookie。
      static CookiePolicy CookiePolicy.ACCEPT_ORIGINAL_SERVER
      一个预先定义的政策，只接受来自原始服务器的Cookie。
      Methods in java.net with parameters of type CookiePolicy
      Modifier and Type 方法 描述
      void CookieManager.setCookiePolicy​(CookiePolicy cookiePolicy)
      设置此Cookie管理器的Cookie策略。
      Constructors in java.net with parameters of type CookiePolicy
      Constructor 描述
      CookieManager​(CookieStore store, CookiePolicy cookiePolicy)
      使用指定的Cookie存储和Cookie策略创建一个新的cookie管理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.CookieStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.CookieStore

  • Packages that use CookieStore
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of CookieStore in java.net

      Methods in java.net that return CookieStore
      Modifier and Type 方法 描述
      CookieStore CookieManager.getCookieStore​()
      检索当前cookie存储。
      Constructors in java.net with parameters of type CookieStore
      Constructor 描述
      CookieManager​(CookieStore store, CookiePolicy cookiePolicy)
      使用指定的Cookie存储和Cookie策略创建一个新的cookie管理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.DatagramSocketImplFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.DatagramSocketImplFactory

  • Packages that use DatagramSocketImplFactory
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of DatagramSocketImplFactory in java.net

      Methods in java.net with parameters of type DatagramSocketImplFactory
      Modifier and Type 方法 描述
      static void DatagramSocket.setDatagramSocketImplFactory​(DatagramSocketImplFactory fac)
      设置应用程序的数据报套接字实现工厂。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.FileNameMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.FileNameMap

  • Packages that use FileNameMap
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of FileNameMap in java.net

      Methods in java.net that return FileNameMap
      Modifier and Type 方法 描述
      static FileNameMap URLConnection.getFileNameMap​()
      从数据文件加载文件名映射（模拟）。
      Methods in java.net with parameters of type FileNameMap
      Modifier and Type 方法 描述
      static void URLConnection.setFileNameMap​(FileNameMap map)
      设置FileNameMap。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.ProtocolFamily (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.ProtocolFamily

  • Packages that use ProtocolFamily
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels软件包的服务提供程序类。

    • Uses of ProtocolFamily in java.net

      Classes in java.net that implement ProtocolFamily
      Modifier and Type Class 描述
      class  StandardProtocolFamily
      定义通信协议的标准系列。

    • Uses of ProtocolFamily in java.nio.channels

      Methods in java.nio.channels with parameters of type ProtocolFamily
      Modifier and Type 方法 描述
      static DatagramChannel DatagramChannel.open​(ProtocolFamily family)
      打开数据报通道。

    • Uses of ProtocolFamily in java.nio.channels.spi

      Methods in java.nio.channels.spi with parameters of type ProtocolFamily
      Modifier and Type 方法 描述
      abstract DatagramChannel SelectorProvider.openDatagramChannel​(ProtocolFamily family)
      打开数据报通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.SocketImplFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.SocketImplFactory

  • Packages that use SocketImplFactory
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of SocketImplFactory in java.net

      Methods in java.net with parameters of type SocketImplFactory
      Modifier and Type 方法 描述
      static void ServerSocket.setSocketFactory​(SocketImplFactory fac)
      设置应用程序的服务器套接字实现工厂。
      static void Socket.setSocketImplFactory​(SocketImplFactory fac)
      设置应用程序的客户端套接字实现工厂。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.SocketOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.SocketOption

  • Packages that use SocketOption
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of SocketOption in com.sun.nio.sctp

      Subinterfaces of SocketOption in com.sun.nio.sctp
      Modifier and Type 接口 描述
      interface  SctpSocketOption<T>
      与SCTP通道相关联的插座选项。

    • Uses of SocketOption in java.net

      Fields in java.net declared as SocketOption
      Modifier and Type Field 描述
      static SocketOption<NetworkInterface> StandardSocketOptions.IP_MULTICAST_IF
      互联网协议（IP）组播数据报的网络接口。
      static SocketOption<Boolean> StandardSocketOptions.IP_MULTICAST_LOOP
      互联网协议（IP）组播数据报的环回。
      static SocketOption<Integer> StandardSocketOptions.IP_MULTICAST_TTL
      互联网协议（IP）组播数据报 的生存时间 。
      static SocketOption<Integer> StandardSocketOptions.IP_TOS
      互联网协议（IP）头中的服务类型（ToS）八位字节。
      static SocketOption<Boolean> StandardSocketOptions.SO_BROADCAST
      允许传输广播数据报。
      static SocketOption<Boolean> StandardSocketOptions.SO_KEEPALIVE
      保持连接活着。
      static SocketOption<Integer> StandardSocketOptions.SO_LINGER
      如果数据存在，则关闭。
      static SocketOption<Integer> StandardSocketOptions.SO_RCVBUF
      套接字的大小接收缓冲区。
      static SocketOption<Boolean> StandardSocketOptions.SO_REUSEADDR
      重用地址。
      static SocketOption<Boolean> StandardSocketOptions.SO_REUSEPORT
      重新使用端口。
      static SocketOption<Integer> StandardSocketOptions.SO_SNDBUF
      套接字发送缓冲区的大小。
      static SocketOption<Boolean> StandardSocketOptions.TCP_NODELAY
      禁用Nagle算法。
      Methods in java.net that return types with arguments of type SocketOption
      Modifier and Type | 方法 | 描述
      Set<SocketOption<?>> DatagramSocket.supportedOptions​()
      返回此套接字支持的一组套接字选项。
      protected Set<SocketOption<?>> DatagramSocketImpl.supportedOptions​()
      返回一个由此impl和该impl的套接字（DatagramSocket或MulticastSocket）支持的SocketOptions，
      Set<SocketOption<?>> | MulticastSocket.supportedOptions​()
      Set<SocketOption<?>> ServerSocket.supportedOptions​()
      返回此服务器套接字支持的一组套接字选项。
      Set<SocketOption<?>> Socket.supportedOptions​()
      返回此套接字支持的一组套接字选项。
      protected Set<SocketOption<?>> SocketImpl.supportedOptions​()
      返回一个由此impl和该impl的套接字支持的SocketOptions（Socket或ServerSocket）
      Methods in java.net with parameters of type SocketOption
      Modifier and Type 方法 描述
      <T> T DatagramSocket.getOption​(SocketOption<T> name)
      返回套接字选项的值。
      protected <T> T DatagramSocketImpl.getOption​(SocketOption<T> name)
      被称为获取套接字选项。
      <T> T ServerSocket.getOption​(SocketOption<T> name)
      返回套接字选项的值。
      <T> T Socket.getOption​(SocketOption<T> name)
      返回套接字选项的值。
      protected <T> T SocketImpl.getOption​(SocketOption<T> name)
      被称为获取套接字选项。
      <T> DatagramSocket DatagramSocket.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      protected <T> void DatagramSocketImpl.setOption​(SocketOption<T> name, T value)
      调用设置套接字选项。
      <T> ServerSocket ServerSocket.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      <T> Socket Socket.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      protected <T> void SocketImpl.setOption​(SocketOption<T> name, T value)
      调用设置套接字选项。

    • Uses of SocketOption in java.nio.channels

      Methods in java.nio.channels that return types with arguments of type SocketOption
      Modifier and Type 方法 描述
      Set<SocketOption<?>> NetworkChannel.supportedOptions​()
      返回此通道支持的一组套接字选项。
      Methods in java.nio.channels with parameters of type SocketOption
      Modifier and Type | 方法 | 描述
      <T> T NetworkChannel.getOption​(SocketOption<T> name)
      返回套接字选项的值。
      abstract <T> AsynchronousServerSocketChannel | AsynchronousServerSocketChannel.setOption​(SocketOption<T> name, T value)
      abstract <T> AsynchronousSocketChannel | AsynchronousSocketChannel.setOption​(SocketOption<T> name, T value)
      abstract <T> DatagramChannel | DatagramChannel.setOption​(SocketOption<T> name, T value)
      <T> NetworkChannel NetworkChannel.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      abstract <T> ServerSocketChannel | ServerSocketChannel.setOption​(SocketOption<T> name, T value)
      abstract <T> SocketChannel | SocketChannel.setOption​(SocketOption<T> name, T value)

    • Uses of SocketOption in jdk.net

      Fields in jdk.net declared as SocketOption
      Modifier and Type Field 描述
      static SocketOption<SocketFlow> ExtendedSocketOptions.SO_FLOW_SLA
      服务级属性。
      Methods in jdk.net that return types with arguments of type SocketOption
      Modifier and Type 方法 描述
      static Set<SocketOption<?>> Sockets.supportedOptions​(Class<?> socketType)
      返回给定套接字类型支持的一组SocketOption 。
      Methods in jdk.net with parameters of type SocketOption
      Modifier and Type 方法 描述
      static <T> T Sockets.getOption​(DatagramSocket s, SocketOption<T> name)
      从DatagramSocket或MulticastSocket返回套接字选项的值
      static <T> T Sockets.getOption​(ServerSocket s, SocketOption<T> name)
      从ServerSocket返回套接字选项的值
      static <T> T Sockets.getOption​(Socket s, SocketOption<T> name)
      从Socket返回套接字选项的值
      static <T> void Sockets.setOption​(DatagramSocket s, SocketOption<T> name, T value)
      在DatagramSocket或MulticastSocket上设置套接字选项的值
      static <T> void Sockets.setOption​(ServerSocket s, SocketOption<T> name, T value)
      在ServerSocket上设置套接字选项的值
      static <T> void Sockets.setOption​(Socket s, SocketOption<T> name, T value)
      Sets the value of a socket option on a Socket
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.SocketOptions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.SocketOptions

  • Packages that use SocketOptions
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of SocketOptions in java.net

      Classes in java.net that implement SocketOptions
      Modifier and Type Class 描述
      class  DatagramSocketImpl
      抽象数据报和组播套接字实现基类。
      class  SocketImpl
      抽象类 SocketImpl是实际实现套接字的所有类的常用超类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.net.URLStreamHandlerFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.net.URLStreamHandlerFactory

  • Packages that use URLStreamHandlerFactory
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.net.spi
    服务提供商类为 java.net包。
    javax.management.loading
    提供实现高级动态加载的类。

    • Uses of URLStreamHandlerFactory in java.net

      Methods in java.net with parameters of type URLStreamHandlerFactory
      Modifier and Type 方法 描述
      static void URL.setURLStreamHandlerFactory​(URLStreamHandlerFactory fac)
      设置应用程序的 URLStreamHandlerFactory 。
      Constructors in java.net with parameters of type URLStreamHandlerFactory
      Constructor 描述
      URLClassLoader​(String name, URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的命名为 URLClassLoader 。
      URLClassLoader​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的URLClassLoader。

    • Uses of URLStreamHandlerFactory in java.net.spi

      Classes in java.net.spi that implement URLStreamHandlerFactory
      Modifier and Type Class 描述
      class  URLStreamHandlerProvider
      URL流处理程序服务提供程序类。

    • Uses of URLStreamHandlerFactory in javax.management.loading

      Constructors in javax.management.loading with parameters of type URLStreamHandlerFactory
      Constructor 描述
      MLet​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的MLet。
      MLet​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的MLet。
      PrivateMLet​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的PrivateMLet。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Networking Properties

There are a few standard system properties used to alter the mechanisms and behavior of the various classes of the java.net package. Some are checked only once at startup of the VM, and therefore are best set using the -D option of the java command, while others have a more dynamic nature and can also be changed using the System.setProperty() API. The purpose of this document is to list and detail all of these properties.

If there is no special note, a property value is checked every time it is used.

IPv4 / IPv6

  • java.net.preferIPv4Stack (default: false)
    If IPv6 is available on the operating system the underlying native socket will be, by default, an IPv6 socket which lets applications connect to, and accept connections from, both IPv4 and IPv6 hosts. However, in the case an application would rather use IPv4 only sockets, then this property can be set to true. The implication is that it will not be possible for the application to communicate with IPv6 only hosts.

  • java.net.preferIPv6Addresses (default: false)
    When dealing with a host which has both IPv4 and IPv6 addresses, and if IPv6 is available on the operating system, the default behavior is to prefer using IPv4 addresses over IPv6 ones. This is to ensure backward compatibility, for example applications that depend on the representation of an IPv4 address (e.g. 192.168.1.1). This property can be set to true to change that preference and use IPv6 addresses over IPv4 ones where possible, or system to preserve the order of the addresses as returned by the operating system.

Both of these properties are checked only once, at startup.

Proxies

A proxy server allows indirect connection to network services and is used mainly for security (to get through firewalls) and performance reasons (proxies often do provide caching mechanisms). The following properties allow for configuration of the various type of proxies.

  • HTTP

    The following proxy settings are used by the HTTP protocol handler.

    • http.proxyHost (default: <none>)
      The hostname, or address, of the proxy server

    • http.proxyPort (default: 80)
      The port number of the proxy server.

    • http.nonProxyHosts (default: localhost|127.*|[::1])
      Indicates the hosts that should be accessed without going through the proxy. Typically this defines internal hosts. The value of this property is a list of hosts, separated by the '|' character. In addition the wildcard character '*' can be used for pattern matching. For example -Dhttp.nonProxyHosts=”*.foo.com|localhost” will indicate that every hosts in the foo.com domain and the localhost should be accessed directly even if a proxy server is specified.

      The default value excludes all common variations of the loopback address.

  • HTTPS
    This is HTTP over SSL, a secure version of HTTP mainly used when confidentiality (like on payment sites) is needed.

    The following proxy settings are used by the HTTPS protocol handler.

    • https.proxyHost(default: <none>)
      The hostname, or address, of the proxy server

    • https.proxyPort (default: 443)
      The port number of the proxy server.

      The HTTPS protocol handler will use the same nonProxyHosts property as the HTTP protocol.

  • FTP

    The following proxy settings are used by the FTP protocol handler.

    • ftp.proxyHost(default: <none>)
      The hostname, or address, of the proxy server

    • ftp.proxyPort (default: 80)
      The port number of the proxy server.

    • ftp.nonProxyHosts (default: localhost|127.*|[::1])
      Indicates the hosts that should be accessed without going through the proxy. Typically this defines internal hosts. The value of this property is a list of hosts, separated by the '|' character. In addition the wildcard character '*' can be used for pattern matching. For example -Dhttp.nonProxyHosts=”*.foo.com|localhost” will indicate that every hosts in the foo.com domain and the localhost should be accessed directly even if a proxy server is specified.

      The default value excludes all common variations of the loopback address.

  • SOCKS
    This is another type of proxy. It allows for lower level type of tunneling since it works at the TCP level. In effect, in the Java(tm) platform setting a SOCKS proxy server will result in all TCP connections to go through that proxy, unless other proxies are specified. If SOCKS is supported by a Java SE implementation, the following properties will be used:

    • socksProxyHost (default: <none>)
      The hostname, or address, of the proxy server.

    • socksProxyPort (default: 1080)
      The port number of the proxy server.

    • socksProxyVersion (default: 5)
      The version of the SOCKS protocol supported by the server. The default is 5 indicating SOCKS V5, alternatively 4 can be specified for SOCKS V4. Setting the property to values other than these leads to unspecified behavior.

    • java.net.socks.username (default: <none>)
      Username to use if the SOCKSv5 server asks for authentication and no java.net.Authenticator instance was found.

    • java.net.socks.password (default: <none>)
      Password to use if the SOCKSv5 server asks for authentication and no java.net.Authenticator instance was found.

      Note that if no authentication is provided with either the above properties or an Authenticator, and the proxy requires one, then the user.name property will be used with no password.

  • java.net.useSystemProxies (default: false)
    On Windows systems, macOS systems and on Gnome systems it is possible to tell the java.net stack, setting this property to true, to use the system proxy settings (both these systems let you set proxies globally through their user interface). Note that this property is checked only once at startup.

Misc HTTP properties

  • http.agent (default: “Java/<version>”)
    Defines the string sent in the User-Agent request header in http requests. Note that the string “Java/<version>” will be appended to the one provided in the property (e.g. if -Dhttp.agent=”foobar” is used, the User-Agent header will contain “foobar Java/1.5.0” if the version of the VM is 1.5.0). This property is checked only once at startup.

  • http.keepalive (default: true)
    Indicates if persistent connections should be supported. They improve performance by allowing the underlying socket connection to be reused for multiple http requests. If this is set to true then persistent connections will be requested with HTTP 1.1 servers.

  • http.maxConnections (default: 5)
    If HTTP keepalive is enabled (see above) this value determines the maximum number of idle connections that will be simultaneously kept alive, per destination.

  • http.maxRedirects (default: 20)
    This integer value determines the maximum number, for a given request, of HTTP redirects that will be automatically followed by the protocol handler.

  • http.auth.digest.validateServer (default: false)

  • http.auth.digest.validateProxy (default: false)

  • http.auth.digest.cnonceRepeat (default: 5)

    These 3 properties modify the behavior of the HTTP digest authentication mechanism. Digest authentication provides a limited ability for the server to authenticate itself to the client (i.e. By proving it knows the user's password). However not all HTTP servers support this capability and by default it is turned off. The first two properties can be set to true to enforce this check for authentication with either an origin or proxy server, respectively.

    It is usually not necessary to change the third property. It determines how many times a cnonce value is re-used. This can be useful when the MD5-sess algorithm is being used. Increasing this value reduces the computational overhead on both client and server by reducing the amount of material that has to be hashed for each HTTP request.

  • http.auth.ntlm.domain (default: <none>)
    NTLM is another authentication scheme. It uses the java.net.Authenticator class to acquire usernames and passwords when they are needed. However NTLM also needs the NT domain name. There are 3 options for specifying that domain:

    1. Do not specify it. In some environments the domain is actually not required and the application does not have to specify it.

    2. The domain name can be encoded within the username by prefixing the domain name, followed by a back-slash '\' before the username. With this method existing applications that use the authenticator class do not need to be modified, as long as users are made aware that this notation must be used.

    3. If a domain name is not specified as in method 2) and these property is defined, then its value will be used a the domain name.

All these properties are checked only once at startup.

Address Cache

The java.net package, when doing name resolution, uses an address cache for both security and performance reasons. Any address resolution attempt, be it forward (name to IP address) or reverse (IP address to name), will have its result cached, whether it was successful or not, so that subsequent identical requests will not have to access the naming service. These properties allow for some tuning on how the cache is operating.

  • networkaddress.cache.ttl (default: see below)
    Value is an integer corresponding to the number of seconds successful name lookups will be kept in the cache. A value of -1, or any other negative value for that matter, indicates a “cache forever” policy, while a value of 0 (zero) means no caching. The default value is -1 (forever) if a security manager is installed, and implementation specific when no security manager is installed.

  • networkaddress.cache.negative.ttl (default: 10)
    Value is an integer corresponding to the number of seconds an unsuccessful name lookup will be kept in the cache. A value of -1, or any negative value, means “cache forever”, while a value of 0 (zero) means no caching.

Since these 2 properties are part of the security policy, they are not set by either the -D option or the System.setProperty() API, instead they are set as security properties.


java.net.spi (Java SE 9 & JDK 9 )

java.net.spi

Classes

  • URLStreamHandlerProvider


java.net.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.net.spi

java.net包的服务提供者类。

只有定义新的URL流处理程序提供者的开发者才需要直接使用这个包。

从以下版本开始：
9
  • 类摘要
    Class 描述
    URLStreamHandlerProvider
    URL流处理程序服务提供程序类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.net.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.net.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.net.spi.URLStreamHandlerProvider (implements java.net.URLStreamHandlerFactory)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


URLStreamHandlerProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net.spi

Class URLStreamHandlerProvider

  • java.lang.Object
    • java.net.spi.URLStreamHandlerProvider
  • All Implemented Interfaces:
    URLStreamHandlerFactory

    public abstract class URLStreamHandlerProvider
extends Object
implements URLStreamHandlerFactory
    URL流处理程序服务提供程序类。

    URL流处理程序提供程序是具有零参数构造函数的此类的具体子类。 URL流处理程序提供程序可以通过将它们添加到应用程序类路径中来安装在Java平台的实例中。

    URL流处理程序提供程序在资源目录META-INF / services中使用名为java.net.spi.URLStreamHandlerProvider的提供程序配置文件来标识自身。 该文件应包含一个完整的具体URL流处理程序提供程序类名称列表，每行一个。

    URL流处理程序提供程序位于运行时，如URL constructor中所述。

    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected URLStreamHandlerProvider​()
      初始化一个新的URL流处理程序提供程序。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.net.URLStreamHandlerFactory

        createURLStreamHandler

    • 构造方法详细信息

      • URLStreamHandlerProvider

        protected URLStreamHandlerProvider​()
        初始化一个新的URL流处理程序提供程序。
        异常
        SecurityException - 如果安全管理器已安装，并且它拒绝RuntimePermission ("setFactory") 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.net.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.net.spi

No usage of java.net.spi
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.net.spi.URLStreamHandlerProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.net.spi.URLStreamHandlerProvider

No usage of java.net.spi.URLStreamHandlerProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Buffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class Buffer

  • java.lang.Object
    • java.nio.Buffer
  • 已知直接子类：
    ByteBuffer ， CharBuffer ， DoubleBuffer ， FloatBuffer ， IntBuffer ， LongBuffer ， ShortBuffer

    public abstract class Buffer
extends Object
    用于特定原始类型的数据的容器。

    缓冲器是特定原始类型的元素的线性有限序列。 除了其内容，缓冲区的基本属性是其容量，限制和位置：

    A buffer's capacity is the number of elements it contains. The capacity of a buffer is never negative and never changes.

    A buffer's limit is the index of the first element that should not be read or written. A buffer's limit is never negative and is never greater than its capacity.

    A buffer's position is the index of the next element to be read or written. A buffer's position is never negative and is never greater than its limit.

    每个非布尔基元类型都有这个类的一个子类。

    传输数据

    该类的每个子类定义了两类get和put操作：

    Relative operations read or write one or more elements starting at the current position and then increment the position by the number of elements transferred. If the requested transfer exceeds the limit then a relative get operation throws a BufferUnderflowException and a relative put operation throws a BufferOverflowException; in either case, no data is transferred.

    Absolute operations take an explicit element index and do not affect the position. Absolute get and put operations throw an IndexOutOfBoundsException if the index argument exceeds the limit.

    数据当然也可以通过相对于当前位置的相应通道的I / O操作被传送到或者从缓冲器传送出去。

    标记和重置

    当调用reset方法时，缓冲区的标记是其位置将被重置的索引 。 标记并不总是定义，但是当它被定义时，它不会是负的，并且永远不会大于位置。 如果标记被定义，则当位置或极限被调整为小于标记的值时，它被丢弃。 如果未定义标记，则调用reset方法将导致抛出InvalidMarkException 。

    不变

    标记，位置，极限和容量值的以下不变量保持不变：

    0 <= mark <= position <= limit <= capacity

    新创建的缓冲区始终具有零位置和未定义的标记。 初始限制可以为零，或者可以是取决于缓冲器的类型和构造方式的某些其他值。 新分配的缓冲区的每个元素被初始化为零。

    附加操作

    除了访问位置，限制和容量值以及标记和重置的方法之外，此类还定义了缓冲区上的以下操作：

    • clear()使缓冲区准备好新的通道读取或相对放置操作序列：它将容量和位置的限制设置为零。

    • flip()使缓冲区准备好新的通道写入或相对获取操作序列：它将限制设置为当前位置，然后将位置设置为零。

    • rewind()使缓冲区准备好重新读取它已经包含的数据：它保持限制不变，并将位置设置为零。

    • slice()创建一个缓冲区的子序列：它保留极限和位置不变。

    • duplicate()创建一个缓冲区的浅拷贝：它保留极限和位置不变。

    只读缓冲区

    每个缓冲区都是可读的，但并不是每个缓冲区都是可写的。 每个缓冲区类的变异方法被指定为可选操作 ，当在只读缓冲区上调用时，它将抛出一个ReadOnlyBufferException 。 只读缓冲区不允许更改其内容，但其标记，位置和限制值是可变的。 缓冲区是否为只读可以通过调用其isReadOnly方法来确定。

    线程安全

    缓冲区不能安全地被多个并发线程使用。 如果一个缓冲区被多个线程使用，则应该通过适当的同步来控制对缓冲区的访问。

    调用链接

    指定此类中没有值返回值的方法返回调用它们的缓冲区。 这允许方法调用被链接; 例如，语句序列

     b.flip();
 b.position(23);
 b.limit(42);
    可以由单一，更紧凑的语句替代
     b.flip().position(23).limit(42);
    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Object array​()
      返回支持此缓冲区的数组 （可选操作） 。
      abstract int arrayOffset​()
      返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
      int capacity​()
      返回此缓冲区的容量。
      Buffer clear​()
      清除此缓冲区。
      abstract Buffer duplicate​()
      创建一个共享此缓冲区内容的新缓冲区。
      Buffer flip​()
      翻转这个缓冲区。
      abstract boolean hasArray​()
      告诉这个缓冲区是否由可访问的数组支持。
      boolean hasRemaining​()
      告诉当前位置和极限之间是否存在任何元素。
      abstract boolean isDirect​()
      告诉这个缓冲区是否是 direct 。
      abstract boolean isReadOnly​()
      告知这个缓冲区是否是只读的。
      int limit​()
      返回此缓冲区的限制。
      Buffer limit​(int newLimit)
      设置此缓冲区的限制。
      Buffer mark​()
      将此缓冲区的标记设置在其位置。
      int position​()
      返回此缓冲区的位置。
      Buffer position​(int newPosition)
      设置这个缓冲区的位置。
      int remaining​()
      返回当前位置和限制之间的元素数。
      Buffer reset​()
      将此缓冲区的位置重置为先前标记的位置。
      Buffer rewind​()
      倒带这个缓冲区。
      abstract Buffer slice​()
      创建一个新的缓冲区，其内容是此缓冲区内容的共享子序列。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • capacity

        public final int capacity​()
        返回此缓冲区的容量。
        结果
        这个缓冲区的容量

      • position

        public final int position​()
        返回此缓冲区的位置。
        结果
        这个缓冲区的位置

      • position

        public Buffer position​(int newPosition)
        设置这个缓冲区的位置。 如果标记被定义并且大于新位置，则它被丢弃。
        参数
        newPosition - 新位置值; 必须是非负数，不得大于当前限制
        结果
        这个缓冲区
        异常
        IllegalArgumentException -如果前提 newPosition不成立

      • limit

        public final int limit​()
        返回此缓冲区的限制。
        结果
        这个缓冲区的极限

      • limit

        public Buffer limit​(int newLimit)
        设置此缓冲区的限制。 如果位置大于新的限制，那么它被设置为新的限制。 如果标记被定义并且大于新限制，则它被丢弃。
        参数
        newLimit - 新限制值; 必须是非负数，不大于此缓冲区的容量
        结果
        这个缓冲区
        异常
        IllegalArgumentException -如果前提 newLimit不成立

      • mark

        public Buffer mark​()
        将此缓冲区的标记设置在其位置。
        结果
        这个缓冲区

      • reset

        public Buffer reset​()
        将此缓冲区的位置重置为先前标记的位置。

        调用此方法既不会更改也不丢弃该标记的值。

        结果
        这个缓冲区
        异常
        InvalidMarkException - 如果标记尚未设置

      • clear

        public Buffer clear​()
        清除此缓冲区。 位置设置为零，限制设置为容量，标记被丢弃。

        在使用一系列通道读取或放置操作填充此缓冲区之前调用此方法。 例如：

         buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

        该方法实际上并不会清除缓冲区中的数据，而是将其命名为它的确因为它最常用于情况也是如此。

        结果
        这个缓冲区

      • flip

        public Buffer flip​()
        翻转这个缓冲区。 该限制设置为当前位置，然后将该位置设置为零。 如果标记被定义，则它被丢弃。

        在通道读取或放置操作的序列之后，调用此方法来准备一系列通道写入或相对获取操作。 例如：

         buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

        当将数据从一个地方传输到另一个地址时，该方法通常与compact方法结合使用。

        结果
        这个缓冲区

      • rewind

        public Buffer rewind​()
        倒带这个缓冲区。 位置设置为零，标记被丢弃。

        在通道写入或获取操作的序列之前调用此方法，假设已经设置了相应的限制。 例如：

         out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array
        结果
        这个缓冲区

      • remaining

        public final int remaining​()
        返回当前位置和限制之间的元素数。
        结果
        此缓冲区中剩余的元素数

      • hasRemaining

        public final boolean hasRemaining​()
        告诉当前位置和极限之间是否存在任何元素。
        结果
        true如果，并且只有在此缓冲区中至少有一个元素

      • isReadOnly

        public abstract boolean isReadOnly​()
        告知这个缓冲区是否是只读的。
        结果
        true如果，并且只有这个缓冲区是只读的

      • hasArray

        public abstract boolean hasArray​()
        告诉这个缓冲区是否由可访问的数组支持。

        如果此方法返回true则可以安全地调用array和arrayOffset方法。

        结果
        true如果，且仅当此缓冲区由数组支持并且不是只读
        从以下版本开始：
        1.6

      • array

        public abstract Object array​()
        返回支持此缓冲区的数组（可选操作） 。

        该方法旨在使阵列支持的缓冲区更有效地传递到本地代码。 具体的子类为此方法提供了更强类型的返回值。

        对此缓冲区内容的修改将导致返回的数组的内容被修改，反之亦然。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        结果
        支持这个缓冲区的数组
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持
        从以下版本开始：
        1.6

      • arrayOffset

        public abstract int arrayOffset​()
        返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量（可选操作） 。

        如果此缓冲区由数组支持，则缓冲区p对应于数组索引p + arrayOffset() 。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        结果
        缓冲区的第一个元素的缓冲区数组中的偏移量
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持
        从以下版本开始：
        1.6

      • isDirect

        public abstract boolean isDirect​()
        告诉这个缓冲区是否是 direct 。
        结果
        true如果，并且只有这个缓冲区是直接的
        从以下版本开始：
        1.6

      • slice

        public abstract Buffer slice​()
        创建一个新的缓冲区，其内容是此缓冲区内容的共享子序列。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是此缓冲区中剩余的元素数量，其标记将不定义。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        结果
        新的缓冲区
        从以下版本开始：
        9

      • duplicate

        public abstract Buffer duplicate​()
        创建一个共享此缓冲区内容的新缓冲区。

        新缓冲区的内容将是这个缓冲区的内容。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置和标记值将与此缓冲区的容量相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        结果
        新的缓冲区
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BufferOverflowException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class BufferOverflowException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.nio.BufferOverflowException
  • All Implemented Interfaces:
    Serializable

    public class BufferOverflowException
extends RuntimeException
    相对 放置操作达到目标缓冲区限制时抛出的未检查异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferOverflowException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • BufferOverflowException

        public BufferOverflowException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BufferUnderflowException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class BufferUnderflowException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.nio.BufferUnderflowException
  • All Implemented Interfaces:
    Serializable

    public class BufferUnderflowException
extends RuntimeException
    当相对 get操作达到源缓冲区的限制时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferUnderflowException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • BufferUnderflowException

        public BufferUnderflowException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ByteBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class ByteBuffer

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.ByteBuffer
  • All Implemented Interfaces:
    Comparable<ByteBuffer>
    已知直接子类：
    MappedByteBuffer

    public abstract class ByteBuffer
extends Buffer
implements Comparable<ByteBuffer>
    一个字节缓冲区。

    这个类在字节缓冲区中定义了六类操作：

    • 绝对和相对get和put读写单字节的方法;

    • 相对bulk get方法将连续的字节序列从该缓冲区传输到数组中;

    • 相对bulk put方法，将字节数组或其他字节缓冲区的连续字节序列传输到此缓冲区中;

    • 绝对和相对的get和put方法，读取和写入其他原始类型的值，将它们转换为特定字节顺序的字节序列;

    • 创建view buffers的方法，允许将字节缓冲区视为包含某些其他原始类型的值的缓冲区; 和

    • 一种方法为compacting一个字节缓冲区。

    字节缓冲区可以由allocation创建，它为缓冲区的内容分配空间，或者通过wrapping将现有字节数组分配到缓冲区中。

    直接与非直接缓冲区

    字节缓冲区是直接 或非直接的 。 给定一个直接的字节缓冲区，Java虚拟机将尽力在其上直接执行本地I / O操作。 也就是说，它将尝试避免在每次调用其中一个底层操作系统的本机I / O操作之前（或之后）将缓冲区的内容复制到（或从）中间缓冲区。

    可以通过调用此类的allocateDirect工厂方法来创建直接字节缓冲区。 此方法返回的缓冲区通常比非直接缓冲区具有更高的分配和释放成本。 直接缓冲区的内容可能驻留在正常垃圾回收堆之外，因此它们对应用程序的内存占用的影响可能不明显。 因此，建议直接缓冲区主要用于受基础系统本机I / O操作影响的大型长寿命缓冲区。 一般来说，最好只在产生程序性能可测量的增益时才分配直接缓冲区。

    一个直接字节缓冲区也可以通过mapping一个文件的区域直接创建到内存中。 Java平台的实现可以可选地支持通过JNI从本地代码创建直接字节缓冲器。 如果这些缓冲区之一的实例指的是存储器的不可访问的区域，则访问该区域的尝试将不会改变缓冲区的内容，并且将导致在访问时或之后的某个未指定的异常时间。

    字节缓冲区是直接还是非直接可以通过调用其isDirect方法来确定。 提供了这种方法，使得可以在性能关键代码中进行显式缓冲区管理。

    访问二进制数据

    该类定义了读取和写入所有其他原始类型的值的方法，除了boolean 。 原始值根据缓冲区的当前字节顺序转换为（或从）字节序列，可以通过order方法检索和修改。 特定字节顺序由ByteOrder类的实例表示。 字节缓冲区的初始顺序始终为BIG_ENDIAN 。

    对于访问异构二进制数据，即不同类型的值序列，此类定义了每个类型的绝对和相对get和put方法族。 例如，对于32位浮点值，此类定义：

     float  getFloat()
 float  getFloat(int index)
  void  putFloat(float f)
  void  putFloat(int index, float f)

    对于类型char, short, int, long和double定义了相应的方法。 绝对get和put方法的索引参数是以字节为单位，而不是读取或写入的类型。

    对于访问同构二进制数据，即相同类型的值序列，该类定义了可以创建给定字节缓冲区的视图的方法。 视图缓冲区只是另一个缓冲区，其内容由字节缓冲区支持。 对字节缓冲区内容的更改将在视图缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值是独立的。 例如， asFloatBuffer方法创建一个FloatBuffer类的实例，该实例由调用该方法的字节缓冲区支持。 相应的视图创建方法是针对类型char, short, int, long和double 。

    与上述类型特定的get和put方法相比，查看缓冲区有三个重要的优点：

    • 视图缓冲区不是以字节为单位，而是根据其值的类型特定大小进行索引;

    • 视图缓冲器提供相对的批量获取和放置方法，该方法可以在缓冲区和数组之间传递连续序列值或者相同类型的其他缓冲区; 和

    • 视图缓冲区可能会更有效率，因为只有当它的后备字节缓冲区是直接的时才会是直接的。

    在创建视图时，视图缓冲区的字节顺序被固定为其字节缓冲区的字节顺序。

    调用链接

    指定此类中没有值返回值的方法返回调用它们的缓冲区。 这允许方法调用被链接。 语句序列

     bb.putInt(0xCAFEBABE);
 bb.putShort(3);
 bb.putShort(45);
    例如，可以用单个语句来替换
     bb.putInt(0xCAFEBABE).putShort(3).putShort(45);
    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      ByteBuffer alignedSlice​(int unitSize)
      创建一个新的字节缓冲区，其内容是此缓冲区内容的共享和对齐子序列。
      int alignmentOffset​(int index, int unitSize)
      返回内存地址，指向给定索引处的字节，模拟给定的单位大小。
      static ByteBuffer allocate​(int capacity)
      分配一个新的字节缓冲区。
      static ByteBuffer allocateDirect​(int capacity)
      分配一个新的直接字节缓冲区。
      byte[] array​()
      返回支持此缓冲区的字节数组 （可选操作） 。
      int arrayOffset​()
      返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
      abstract CharBuffer asCharBuffer​()
      创建一个字节缓冲区作为char缓冲区的视图。
      abstract DoubleBuffer asDoubleBuffer​()
      将此字节缓冲区的视图创建为双缓冲区。
      abstract FloatBuffer asFloatBuffer​()
      将此字节缓冲区的视图创建为浮动缓冲区。
      abstract IntBuffer asIntBuffer​()
      将此字节缓冲区的视图创建为int缓冲区。
      abstract LongBuffer asLongBuffer​()
      将此字节缓冲区的视图创建为长缓冲区。
      abstract ByteBuffer asReadOnlyBuffer​()
      创建一个新的只读字节缓冲区，共享此缓冲区的内容。
      abstract ShortBuffer asShortBuffer​()
      将此字节缓冲区的视图创建为短缓冲区。
      ByteBuffer clear​()
      清除此缓冲区。
      abstract ByteBuffer compact​()
      压缩此缓冲区 （可选操作） 。
      int compareTo​(ByteBuffer that)
      将此缓冲区与另一个缓冲区进
      abstract ByteBuffer duplicate​()
      创建一个新的字节缓冲区，共享此缓冲区的内容。
      boolean equals​(Object ob)
      告诉这个缓冲区是否等于另一个对象。
      ByteBuffer flip​()
      翻转这个缓冲区。
      abstract byte get​()
      相对 获取方法。
      ByteBuffer get​(byte[] dst)
      相对批量 获取方法。
      ByteBuffer get​(byte[] dst, int offset, int length)
      相对批量 获取方法。
      abstract byte get​(int index)
      绝对 获取方法。
      abstract char getChar​()
      读取char值的相对 get方法。
      abstract char getChar​(int index)
      绝对 获取方法来读取一个char值。
      abstract double getDouble​()
      读取双重值的相对 get方法。
      abstract double getDouble​(int index)
      绝对 获取读取双重值的方法。
      abstract float getFloat​()
      读取浮点值的相对 get方法。
      abstract float getFloat​(int index)
      用于读取浮点值的绝对 get方法。
      abstract int getInt​()
      用于读取int值的相对 get方法。
      abstract int getInt​(int index)
      用于读取int值的绝对 get方法。
      abstract long getLong​()
      读取长值的相对 get方法。
      abstract long getLong​(int index)
      绝对 获取读取长值的方法。
      abstract short getShort​()
      相对 获取方法读取一个简短的值。
      abstract short getShort​(int index)
      绝对 获取读取一个简短值的方法。
      boolean hasArray​()
      告诉这个缓冲区是否由可访问的字节数组支持。
      int hashCode​()
      返回此缓冲区的当前哈希码。
      abstract boolean isDirect​()
      告诉这个字节缓冲区是否是直接的。
      ByteBuffer limit​(int newLimit)
      设置此缓冲区的限制。
      ByteBuffer mark​()
      将此缓冲区的标记设置在其位置。
      ByteOrder order​()
      检索此缓冲区的字节顺序。
      ByteBuffer order​(ByteOrder bo)
      修改缓冲区的字节顺序。
      ByteBuffer position​(int newPosition)
      设置这个缓冲区的位置。
      abstract ByteBuffer put​(byte b)
      相对 放置法 （可选操作） 。
      ByteBuffer put​(byte[] src)
      相对大容量 put方法 （可选操作） 。
      ByteBuffer put​(byte[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract ByteBuffer put​(int index, byte b)
      绝对 put方法 （可选操作） 。
      ByteBuffer put​(ByteBuffer src)
      相对大容量 put方法 （可选操作） 。
      abstract ByteBuffer putChar​(char value)
      写入char值的相对 put方法 （可选操作） 。
      abstract ByteBuffer putChar​(int index, char value)
      用于写入char值的绝对 put方法 （可选操作） 。
      abstract ByteBuffer putDouble​(double value)
      写入double值的相对 put方法 （可选操作） 。
      abstract ByteBuffer putDouble​(int index, double value)
      用于写入双精度值的绝对 put方法 （可选操作） 。
      abstract ByteBuffer putFloat​(float value)
      编写浮点值的相对 put方法 （可选操作） 。
      abstract ByteBuffer putFloat​(int index, float value)
      用于写入浮点值的绝对 put方法 （可选操作） 。
      abstract ByteBuffer putInt​(int value)
      编写int值的相对 put方法 （可选操作） 。
      abstract ByteBuffer putInt​(int index, int value)
      用于写入int值的绝对 put方法 （可选操作） 。
      abstract ByteBuffer putLong​(int index, long value)
      绝对 put方法写入一个长的值 （可选操作） 。
      abstract ByteBuffer putLong​(long value)
      写入长值的相对 put方法 （可选操作） 。
      abstract ByteBuffer putShort​(int index, short value)
      绝对 put方法写入一个简短的值 （可选操作） 。
      abstract ByteBuffer putShort​(short value)
      写入一个短值的相对 放置方法 （可选操作） 。
      ByteBuffer reset​()
      将此缓冲区的位置重置为先前标记的位置。
      ByteBuffer rewind​()
      倒带这个缓冲区。
      abstract ByteBuffer slice​()
      创建一个新的字节缓冲区，其内容是此缓冲区内容的共享子序列。
      String toString​()
      返回一个汇总此缓冲区状态的字符串。
      static ByteBuffer wrap​(byte[] array)
      将一个字节数组包装到缓冲区中。
      static ByteBuffer wrap​(byte[] array, int offset, int length)
      将一个字节数组包装到缓冲区中。

      • Methods inherited from class java.nio.Buffer

        capacity, hasRemaining, isReadOnly, limit, position, remaining

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • allocateDirect

        public static ByteBuffer allocateDirect​(int capacity)
        分配一个新的直接字节缓冲区。

        新缓冲区的位置将为零，其限制将为其容量，其标记将不定义，其每个元素将被初始化为零，其字节顺序将为BIG_ENDIAN 。 是否有一个backing array是未指定的。

        参数
        capacity - 新的缓冲区的容量，以字节为单位
        结果
        新的字节缓冲区
        异常
        IllegalArgumentException - 如果 capacity是负整数

      • allocate

        public static ByteBuffer allocate​(int capacity)
        分配一个新的字节缓冲区。

        新缓冲区的位置将为零，其限制将为其容量，其标记将不定义，其每个元素将被初始化为零，其字节顺序将为BIG_ENDIAN 。 它将有一个backing array ，其array offset将为零。

        参数
        capacity - 新的缓冲区的容量，以字节为单位
        结果
        新的字节缓冲区
        异常
        IllegalArgumentException - 如果 capacity是负整数

      • wrap

        public static ByteBuffer wrap​(byte[] array,
                              int offset,
                              int length)
        将一个字节数组包装到缓冲区中。

        新的缓冲区将由给定的字节数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新增的缓冲区容量将为array.length ，其位置将为offset ，其限制将为offset + length ，其标记将不定义，其字节顺序为BIG_ENDIAN 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回新缓冲区的数组
        offset - 要使用的子阵列的偏移量; 必须是非负数，不得大于array.length 。 新缓冲区的位置将被设置为此值。
        length - 要使用的子阵列的长度; 必须是非负数，不得大于array.length - offset 。 新缓冲区的限制将设置为offset + length 。
        结果
        新的字节缓冲区
        异常
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • wrap

        public static ByteBuffer wrap​(byte[] array)
        将一个字节数组包装到缓冲区中。

        新的缓冲区将由给定的字节数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新缓冲区的容量和限制将为array.length ，其位置将为零，其标记将不定义，其字节顺序将为BIG_ENDIAN 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回此缓冲区的数组
        结果
        新的字节缓冲区

      • slice

        public abstract ByteBuffer slice​()
        创建一个新的字节缓冲区，其内容是此缓冲区内容的共享子序列。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是此缓冲区中剩余的字节数，其标记将不定义，其字节顺序将为BIG_ENDIAN 。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        slice在 Buffer
        结果
        新的字节缓冲区
        另请参见：
        alignedSlice(int)

      • duplicate

        public abstract ByteBuffer duplicate​()
        创建一个新的字节缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置和标记值将与该缓冲区的容量，位置和标记值相同，其字节顺序将为BIG_ENDIAN 。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        duplicate在 Buffer
        结果
        新的字节缓冲区

      • asReadOnlyBuffer

        public abstract ByteBuffer asReadOnlyBuffer​()
        创建一个新的只读字节缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 这个缓冲区内容的更改将在新的缓冲区中显示; 但是，新的缓冲区本身将是只读的，不允许修改共享内容。 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置和标记值将与此缓冲区的容量相同，其字节顺序将为BIG_ENDIAN 。

        如果这个缓冲区本身是只读的，那么这个方法的行为与duplicate的方法完全相同。

        结果
        新的只读字节缓冲区

      • get

        public abstract byte get​()
        相对获取方法。 读取该缓冲区当前位置的字节，然后增加位置。
        结果
        缓冲区当前位置的字节
        异常
        BufferUnderflowException - 如果缓冲区的当前位置不小于其限制

      • put

        public abstract ByteBuffer put​(byte b)
        相对放置法（可选操作） 。

        将给定字节写入当前位置的缓冲区，然后增加位置。

        参数
        b - 要写入的字节
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区的当前位置不小于其限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public abstract byte get​(int index)
        绝对获取方法。 读取给定索引处的字节。
        参数
        index - 读取字节的索引
        结果
        给定索引处的字节
        异常
        IndexOutOfBoundsException - 如果 index为负值或不小于缓冲区限制值

      • put

        public abstract ByteBuffer put​(int index,
                               byte b)
        绝对put方法（可选操作） 。

        将给定字节写入给定索引的缓冲区。

        参数
        index - 要写入字节的索引
        b - 要写入的字节值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public ByteBuffer get​(byte[] dst,
                      int offset,
                      int length)
        相对批量获取方法。

        此方法将字节从此缓冲区传输到给定的目标数组。 如果缓冲区中剩余的字节少于满足请求所需的字节数，即length > remaining() ，则不会传输任何字节，并抛出一个BufferUnderflowException 。

        否则，该方法将length字节从此缓冲区复制到给定的数组中，从该缓冲区的当前位置开始，并在数组中给定的偏移量。 然后将该缓冲区的位置增加length 。

        换句话说，这种形式为src.get(dst, off, len)方法的调用与src.get(dst, off, len)具有完全相同的效果

           for (int i = off; i < off + len; i++) dst[i] = src.get():
        除了它首先检查这个缓冲区中是否有足够的字节，并且它可能更有效率。
        参数
        dst - 要写入字节的数组
        offset - 要写入的第一个字节的数组内的偏移量; 必须是非负数，不得大于dst.length
        length - 要写入给定数组的最大字节数; 必须是非负数，不得大于dst.length - offset
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的字节少于 length个字节
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • get

        public ByteBuffer get​(byte[] dst)
        相对批量获取方法。

        此方法将字节从此缓冲区传输到给定的目标数组。 这种src.get(a)形式的方法的调用与调用的方式完全相同

          src.get(a, 0, a.length)
        参数
        dst - 目的地阵列
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的字节少于 length个字节

      • put

        public ByteBuffer put​(ByteBuffer src)
        相对大容量put方法（可选操作） 。

        此方法将给定源缓冲区中剩余的字节传输到此缓冲区。 如果源缓冲区中剩余的字节多于此缓冲区中的字节数，即src.remaining() > remaining() ，则不会传输任何字节，并抛出BufferOverflowException 。

        否则，该方法将n = src.remaining()字节从给定缓冲区复制到此缓冲区中，从每个缓冲区的当前位置开始。 然后将两个缓冲器的位置递增n 。

        换句话说，这种dst.put(src)形式的方法的调用与循环完全相同

          while (src.hasRemaining())
         dst.put(src.get());
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取字节的源缓冲区; 不能是这个缓冲区
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中的源缓冲区中剩余字节的空间不足
        IllegalArgumentException - 如果源缓冲区是这个缓冲区
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public ByteBuffer put​(byte[] src,
                      int offset,
                      int length)
        相对大容量put方法（可选操作） 。

        此方法将字节从给定的源数组传输到此缓冲区。 如果从数组中复制的字节数多于保留在该缓冲区中的字节数，即length > remaining() ，则不会传输任何字节，并抛出BufferOverflowException 。

        否则，该方法将length个字节从给定的数组复制到此缓冲区中，从阵列中的给定偏移量和此缓冲区的当前位置开始。 此缓冲区的位置然后增加length 。

        换句话说，这种形式为dst.put(src, off, len)方法的调用与dst.put(src, off, len)具有完全相同的效果

           for (int i = off; i < off + len; i++) dst.put(a[i]);
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取字节的数组
        offset - 要读取的第一个字节的数组中的偏移量; 必须是非负数，不得大于array.length
        length - 从给定数组读取的字节数; 必须是非负数，不得大于array.length - offset
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区空间不足
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public final ByteBuffer put​(byte[] src)
        相对大容量put方法（可选操作） 。

        此方法将给定源字节数组的整个内容传输到此缓冲区。 对这种形式为dst.put(a)的方法的调用与调用的方式完全相同

          dst.put(a, 0, a.length)
        参数
        src - 源数组
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • hasArray

        public final boolean hasArray​()
        告诉这个缓冲区是否由可访问的字节数组支持。

        如果此方法返回true则可以安全地调用array和arrayOffset方法。

        Specified by:
        hasArray在类 Buffer
        结果
        true如果且仅当此缓冲区由数组支持并且不是只读的

      • array

        public final byte[] array​()
        返回支持此缓冲区的字节数组（可选操作） 。

        对此缓冲区内容的修改将导致返回的数组的内容被修改，反之亦然。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        array中的 Buffer
        结果
        支持这个缓冲区的数组
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • arrayOffset

        public final int arrayOffset​()
        返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量（可选操作） 。

        如果缓冲区由数组支持，则缓冲区p对应于数组索引p + arrayOffset() 。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        arrayOffset在 Buffer
        结果
        缓冲区的第一个元素的缓冲区数组中的偏移量
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • position

        public ByteBuffer position​(int newPosition)
        设置这个缓冲区的位置。 如果标记被定义并且大于新位置，则它被丢弃。
        重写：
        position在 Buffer
        参数
        newPosition - 新的位置值; 必须是非负数，不得大于当前限制
        结果
        这个缓冲区

      • limit

        public ByteBuffer limit​(int newLimit)
        设置此缓冲区的限制。 如果位置大于新的限制，那么它被设置为新的限制。 如果标记被定义并且大于新限制，则它被丢弃。
        重写：
        limit在 Buffer
        参数
        newLimit - 新限制值 必须是非负数，不大于此缓冲区的容量
        结果
        这个缓冲区

      • mark

        public ByteBuffer mark​()
        将此缓冲区的标记设置在其位置。
        重写：
        mark在 Buffer
        结果
        这个缓冲区

      • reset

        public ByteBuffer reset​()
        将此缓冲区的位置重置为先前标记的位置。

        调用此方法既不会更改也不丢弃该标记的值。

        重写：
        reset在 Buffer
        结果
        这个缓冲区

      • clear

        public ByteBuffer clear​()
        清除此缓冲区。 位置设置为零，限制设置为容量，标记被丢弃。

        在使用一系列通道读取或放置操作填充此缓冲区之前调用此方法。 例如：

         buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

        该方法实际上并不会清除缓冲区中的数据，而是将其命名为它的确因为它最常用于情况也是如此。

        重写：
        clear中的 Buffer
        结果
        这个缓冲区

      • flip

        public ByteBuffer flip​()
        翻转这个缓冲区。 该限制设置为当前位置，然后将该位置设置为零。 如果标记被定义，则它被丢弃。

        在通道读取或放置操作的序列之后，调用此方法来准备一系列通道写入或相对获取操作。 例如：

         buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

        当将数据从一个地方传输到另一个地址时，该方法通常与compact方法结合使用。

        重写：
        flip在 Buffer
        结果
        这个缓冲区

      • rewind

        public ByteBuffer rewind​()
        倒带这个缓冲区。 位置设置为零，标记被丢弃。

        在通道写入或获取操作的序列之前调用此方法，假设已经设置了相应的限制。 例如：

         out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array
        重写：
        rewind的 Buffer
        结果
        这个缓冲区

      • compact

        public abstract ByteBuffer compact​()
        压缩此缓冲区（可选操作） 。

        缓冲区当前位置与其限制（如果有的话）之间的字节被复制到缓冲区的开头。 即，在索引p =字节position()被复制到索引0，在索引p + 1的字节被复制到索引1，依此类推，直到在索引的字节limit() - 1被复制到索引n = limit() - 1 - p 。 然后将缓冲区的位置设置为n + 1，并将其限制设置为其容量。 标记如果被定义，则被丢弃。

        缓冲区的位置设置为复制的字节数，而不是零，因此可以通过调用另一个相对put方法来立即调用此方法。

        在写入不完整的情况下从缓冲区写入数据后调用此方法。 例如，以下循环通过缓冲区将字节从一个通道复制到另一个通道buf ：

   buf.clear();          // Prepare buffer for use
   while (in.read(buf) >= 0 || buf.position != 0) {
       buf.flip();
       out.write(buf);
       buf.compact();    // In case of partial write
   }
        结果
        这个缓冲区
        异常
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • isDirect

        public abstract boolean isDirect​()
        告诉这个字节缓冲区是否是直接的。
        Specified by:
        isDirect在 Buffer
        结果
        true如果，并且只有这个缓冲区是直接的

      • toString

        public String toString​()
        返回一个汇总此缓冲区状态的字符串。
        重写：
        toString中的 Object
        结果
        摘要字符串

      • hashCode

        public int hashCode​()
        返回此缓冲区的当前哈希码。

        字节缓冲区的哈希码仅取决于其剩余的元素; 也就是说，元素从position()直到并包括元素在limit() - 1 。

        因为缓冲区哈希码是内容依赖的，所以使用缓冲区作为哈希映射或类似数据结构中的密钥是不合适的，除非知道它们的内容不会改变。

        重写：
        hashCode在 Object
        结果
        这个缓冲区的当前哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        告诉这个缓冲区是否等于另一个对象。

        两个字节的缓冲区是相等的，

        1. 它们具有相同的元素类型，

        2. 他们有相同数量的剩余元素，和

        3. 独立于其起始位置的剩余元素的两个序列是相等的。

        字节缓冲区不等于任何其他类型的对象。

        重写：
        equals在 Object
        参数
        ob - 要比较此缓冲区的对象
        结果
        true如果，并且只有当这个缓冲区等于给定的对象
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(ByteBuffer that)
        将此缓冲区与另一个缓冲区进

        通过以字面的方式比较其剩余元素的序列来比较两个字节缓冲区，而不考虑其相应缓冲器内每个序列的起始位置。 成对的byte元素比较好像是通过调用Byte.compare(byte,byte) 。

        一个字节缓冲区不能与任何其他类型的对象相媲美。

        Specified by:
        compareTo接口 Comparable<ByteBuffer>
        参数
        that - 要比较的对象。
        结果
        负整数，零或正整数，因为此缓冲区小于，等于或大于给定的缓冲区

      • order

        public final ByteOrder order​()
        检索此缓冲区的字节顺序。

        读取或写入多字节值时使用字节顺序，当创建作为此字节缓冲区视图的缓冲区时使用。 新创建的字节缓冲区的顺序始终为BIG_ENDIAN 。

        结果
        这个缓冲区的字节顺序

      • order

        public final ByteBuffer order​(ByteOrder bo)
        修改缓冲区的字节顺序。
        参数
        bo - 新的字节顺序， BIG_ENDIAN或 LITTLE_ENDIAN
        结果
        这个缓冲区

      • alignmentOffset

        public final int alignmentOffset​(int index,
                                 int unitSize)
        返回内存地址，指向给定索引处的字节，模拟给定的单位大小。

        大于零的返回值表示索引处的字节的地址对于单位大小而不对齐，并且值的数量表示索引应向上或向下四舍五入以在对齐的地址上定位一个字节。 否则，值为0表示索引处的字节的地址对应于单位大小。

        API Note:
        如果本地平台支持，则可以使用该方法来确定来自索引的单元大小字节是否可以被原子访问。
        Implementation Note:
        此实现抛出 UnsupportedOperationException非直接缓冲区时给定的单元尺寸大于 8 。
        参数
        index - 查询对齐偏移的索引必须是非负的，不执行上限检查
        unitSize - 以字节为单位的单位大小，必须是 2
        结果
        索引字节的内存地址模数单位大小
        异常
        IllegalArgumentException - 如果索引为负数或单位大小不是 2的权力
        UnsupportedOperationException - 如果在管理与该缓冲区（直接或非直接）相同种类的缓冲区的存储区域时，本地平台不能保证给定单元大小的稳定的对齐偏移值。 例如，如果垃圾收集将导致由非直接缓冲区覆盖的存储器区域从一个位置移动到另一个位置，并且两个位置具有不同的对准特性。
        从以下版本开始：
        9
        另请参见：
        alignedSlice(int)

      • alignedSlice

        public final ByteBuffer alignedSlice​(int unitSize)
        创建一个新的字节缓冲区，其内容是此缓冲区内容的共享和对齐子序列。

        新缓冲区的内容将从该缓冲区的当前位置开始，四舍五入到给定单位大小的最近对齐字节的索引，并以该缓冲区的极限结束，舍入到给定单位大小的最近对齐字节的索引。 如果舍入导致超出限制值，则新缓冲区的容量和限制将为零。 如果舍入在边界范围内，新的缓冲区nb和单元大小unitSize的以下表达式将成立：

           nb.alignmentOffset(0, unitSize) == 0 nb.alignmentOffset(nb.limit(), unitSize) == 0

        对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新的缓冲区的位置将为零，其容量和限制将是此缓冲区中剩余的字节数或更少的对齐方式，其标记将不定义，其字节顺序将为BIG_ENDIAN 。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        API Note:
        如果本地平台支持，则可以使用该方法来创建新的缓冲区，其中来自索引的单位大小字节（即单位大小的倍数）可被原子访问。
        Implementation Note:
        此实现抛出 UnsupportedOperationException非直接缓冲区时给定的单元尺寸大于 8 。
        参数
        unitSize - 以字节为单位的单位大小必须是 2
        结果
        新的字节缓冲区
        异常
        IllegalArgumentException - 如果单位大小不是 2的权力
        UnsupportedOperationException - 如果在管理与该缓冲区（直接或非直接）相同种类的缓冲区的存储器区域时，本地平台不能保证给定单元大小的稳定对齐的片段。 例如，如果垃圾收集将导致由非直接缓冲区覆盖的存储器区域从一个位置移动到另一个位置，并且两个位置具有不同的对准特性。
        从以下版本开始：
        9
        另请参见：
        alignmentOffset(int, int) ， slice()

      • getChar

        public abstract char getChar​()
        读取char值的相对get方法。

        在此缓冲区的当前位置读取接下来的两个字节，根据当前字节顺序将它们组合成一个char值，然后将位置递增2。

        结果
        缓冲区当前位置的char值
        异常
        BufferUnderflowException - 如果此缓冲区中剩余少于两个字节

      • putChar

        public abstract ByteBuffer putChar​(char value)
        写入char值的相对put方法（可选操作） 。

        将当前字节顺序中包含给定char值的两个字节写入此缓冲区中的当前位置，然后将位置递增2。

        参数
        value - 要写入的char值
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中剩余少于两个字节
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • getChar

        public abstract char getChar​(int index)
        绝对获取方法来读取一个char值。

        在给定索引处读取两个字节，根据当前字节顺序将它们组合成一个char值。

        参数
        index - 读取字节的索引
        结果
        给定索引处的char值
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则减1

      • putChar

        public abstract ByteBuffer putChar​(int index,
                                   char value)
        用于写入char值的绝对put方法（可选操作） 。

        将给定的char值的两个字节以当前字节顺序写入给定索引的缓冲区。

        参数
        index - 要写入字节的索引
        value - 要写入的字符值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则减1
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • asCharBuffer

        public abstract CharBuffer asCharBuffer​()
        创建一个字节缓冲区作为char缓冲区的视图。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是此缓冲区中剩余的字节数除以2，其标记将不定义，并且其字节顺序将是视图为字节缓冲区的字节顺序创建。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        结果
        一个新的char缓冲区

      • getShort

        public abstract short getShort​()
        相对获取方法读取一个简短的值。

        在该缓冲区的当前位置读取接下来的两个字节，根据当前字节顺序将它们组合成一个短值，然后将位置递增2。

        结果
        缓冲区当前位置的短值
        异常
        BufferUnderflowException - 如果此缓冲区中剩余少于两个字节

      • putShort

        public abstract ByteBuffer putShort​(short value)
        写入一个短值的相对放置方法（可选操作） 。

        以当前字节顺序将包含给定短值的两个字节写入此缓冲区，然后将位置递增2。

        参数
        value - value的短值
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中剩余少于两个字节
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • getShort

        public abstract short getShort​(int index)
        绝对获取读取一个简短值的方法。

        在给定索引处读取两个字节，根据当前字节顺序将它们组合成一个短值。

        参数
        index - 从中读取字节的索引
        结果
        给定指数的短期价值
        异常
        IndexOutOfBoundsException - 如果 index为负值或不小于缓冲区限制，则减去1

      • putShort

        public abstract ByteBuffer putShort​(int index,
                                    short value)
        绝对put方法写入一个简短的值（可选操作） 。

        以给定的索引将包含给定短值的两个字节以当前字节顺序写入此缓冲区。

        参数
        index - 要写入字节的索引
        value - value的短价值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则减1
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • asShortBuffer

        public abstract ShortBuffer asShortBuffer​()
        将此字节缓冲区的视图创建为短缓冲区。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是此缓冲区中剩余的字节数除以2，其标记将不定义，并且其字节顺序将是视图为字节缓冲区的字节顺序创建。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        结果
        一个新的缓冲区

      • getInt

        public abstract int getInt​()
        用于读取int值的相对get方法。

        在该缓冲区的当前位置读取接下来的四个字节，根据当前字节顺序将它们组合成一个int值，然后将位置递增四。

        结果
        缓冲区当前位置的int值
        异常
        BufferUnderflowException - 如果此缓冲区中剩余少于四个字节

      • putInt

        public abstract ByteBuffer putInt​(int value)
        编写int值的相对put方法（可选操作） 。

        以当前字节顺序将包含给定int值的四个字节写入当前位置的缓冲区，然后将位置递增四。

        参数
        value - 要写入的int值
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中剩余少于四个字节
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • getInt

        public abstract int getInt​(int index)
        用于读取int值的绝对get方法。

        在给定索引处读取四个字节，根据当前字节顺序将它们组合成一个int值。

        参数
        index - 读取字节的索引
        结果
        给定索引处的int值
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则为负数

      • putInt

        public abstract ByteBuffer putInt​(int index,
                                  int value)
        用于写入int值的绝对put方法（可选操作） 。

        以给定的索引将包含给定int值的四个字节以当前字节顺序写入此缓冲区。

        参数
        index - 要写入字节的索引
        value - 要写入的int值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负值或不小于缓冲区限制，则减去3
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • asIntBuffer

        public abstract IntBuffer asIntBuffer​()
        将此字节缓冲区的视图创建为int缓冲区。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是该缓冲区中剩余的字节数除以4，其标记将不定义，并且其字节顺序将是视图为字节缓冲区的字节顺序创建。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        结果
        一个新的int缓冲区

      • getLong

        public abstract long getLong​()
        读取长值的相对get方法。

        在该缓冲区的当前位置读取接下来的八个字节，根据当前字节顺序将它们组合成一个长的值，然后将位置增加八位。

        结果
        缓冲区当前位置的长值
        异常
        BufferUnderflowException - 如果此缓冲区中剩余少于8个字节

      • putLong

        public abstract ByteBuffer putLong​(long value)
        写入长值的相对put方法（可选操作） 。

        以当前字节顺序将包含给定长值的八个字节写入当前位置的缓冲区，然后将位置递增8。

        参数
        value - value的长的值
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中剩余少于8个字节
        ReadOnlyBufferException - 如果此缓冲区为只读

      • getLong

        public abstract long getLong​(int index)
        绝对获取读取长值的方法。

        在给定索引处读取八个字节，根据当前字节顺序将它们组合成一个长整型值。

        参数
        index - 读取字节的索引
        结果
        给定指数的长期价值
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则为负数

      • putLong

        public abstract ByteBuffer putLong​(int index,
                                   long value)
        绝对put方法写入一个长的值（可选操作） 。

        以给定的索引将包含给定long值的八个字节以当前字节顺序写入此缓冲区。

        参数
        index - 要写入字节的索引
        value - value的长的价值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则为负数
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • asLongBuffer

        public abstract LongBuffer asLongBuffer​()
        将此字节缓冲区的视图创建为长缓冲区。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是该缓冲区中剩余的字节数除以8，其标记将不定义，并且其字节顺序将是视图为字节缓冲区的字节顺序创建。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        结果
        一个新的长缓冲区

      • getFloat

        public abstract float getFloat​()
        读取浮点值的相对get方法。

        在该缓冲区的当前位置读取接下来的四个字节，根据当前字节顺序将它们组合成一个浮点值，然后将位置递增四。

        结果
        缓冲区当前位置的浮点值
        异常
        BufferUnderflowException - 如果此缓冲区中剩余少于四个字节

      • putFloat

        public abstract ByteBuffer putFloat​(float value)
        编写浮点值的相对put方法（可选操作） 。

        以当前字节顺序将包含给定浮点值的四个字节写入此缓冲区中的当前位置，然后将位置递增四。

        参数
        value - 要写入的浮点值
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中剩余少于四个字节
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • getFloat

        public abstract float getFloat​(int index)
        用于读取浮点值的绝对get方法。

        在给定索引处读取四个字节，根据当前字节顺序将它们组合成一个浮点值。

        参数
        index - 从中读取字节的索引
        结果
        给定索引处的浮点值
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则减去3

      • putFloat

        public abstract ByteBuffer putFloat​(int index,
                                    float value)
        用于写入浮点值的绝对put方法（可选操作） 。

        以给定的索引将包含给定浮点值的四个字节以当前字节顺序写入此缓冲区。

        参数
        index - 要写入字节的索引
        value - 要写入的浮点值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则减去3
        ReadOnlyBufferException - 如果此缓冲区为只读

      • asFloatBuffer

        public abstract FloatBuffer asFloatBuffer​()
        将此字节缓冲区的视图创建为浮动缓冲区。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是该缓冲区中剩余的字节数除以4，其标记将不定义，并且其字节顺序将是视图为字节缓冲区的字节顺序创建。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        结果
        一个新的浮动缓冲区

      • getDouble

        public abstract double getDouble​()
        读取双重值的相对get方法。

        在该缓冲区的当前位置读取接下来的八个字节，根据当前字节顺序将它们组合成一个双精度值，然后将位置递增8。

        结果
        缓冲区当前位置的double值
        异常
        BufferUnderflowException - 如果此缓冲区中剩余少于8个字节

      • putDouble

        public abstract ByteBuffer putDouble​(double value)
        写入double值的相对put方法（可选操作） 。

        以当前字节顺序将包含给定双值的八个字节写入当前位置的缓冲区，然后将位置递增8。

        参数
        value - 要写入的双重值
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中剩余少于8个字节
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • getDouble

        public abstract double getDouble​(int index)
        绝对获取读取双重值的方法。

        在给定索引处读取八个字节，根据当前字节顺序将它们组合成双精度值。

        参数
        index - 从中读取字节的索引
        结果
        给定指数的双重值
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则为负数

      • putDouble

        public abstract ByteBuffer putDouble​(int index,
                                     double value)
        用于写入双精度值的绝对put方法（可选操作） 。

        以给定的索引将包含给定双值的八个字节以当前字节顺序写入此缓冲区。

        参数
        index - 要写入字节的索引
        value - 要写入的双重值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制，则为负数
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • asDoubleBuffer

        public abstract DoubleBuffer asDoubleBuffer​()
        将此字节缓冲区的视图创建为双缓冲区。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是该缓冲区中剩余的字节数除以8，其标记将不定义，并且其字节顺序将是视图为字节缓冲区的字节顺序创建。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        结果
        一个新的双缓冲区
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ByteOrder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class ByteOrder

  • java.lang.Object
    • java.nio.ByteOrder

  • public final class ByteOrder
extends Object
    字节顺序的类型安全枚举。
    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static ByteOrder BIG_ENDIAN
      常量表示大字节顺序。
      static ByteOrder LITTLE_ENDIAN
      常量表示小端字节顺序。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static ByteOrder nativeOrder​()
      检索底层平台的本机字节顺序。
      String toString​()
      构造描述此对象的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • BIG_ENDIAN

        public static final ByteOrder BIG_ENDIAN
        常量表示大字节顺序。 按照这个顺序，多字节值的字节从最高有效位到最低有效位排序。

      • LITTLE_ENDIAN

        public static final ByteOrder LITTLE_ENDIAN
        常量表示小端字节顺序。 按照这个顺序，多字节值的字节从最低有效到最高有序排序。

    • 方法详细信息

      • nativeOrder

        public static ByteOrder nativeOrder​()
        检索底层平台的本机字节顺序。

        定义了这种方法，使得性能敏感的Java代码可以以与硬件相同的字节顺序分配直接缓冲区。 当使用这种缓冲区时，本地代码库通常更有效率。

        结果
        运行此Java虚拟机的硬件的本机字节顺序

      • toString

        public String toString​()
        构造描述此对象的字符串。

        此方法返回"BIG_ENDIAN"的字符串"BIG_ENDIAN"和"LITTLE_ENDIAN"的"LITTLE_ENDIAN" 。

        重写：
        toString在 Object
        结果
        The specified string
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


CharBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class CharBuffer

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.CharBuffer
  • All Implemented Interfaces:
    Appendable ， CharSequence ， Comparable<CharBuffer> ， Readable

    public abstract class CharBuffer
extends Buffer
implements Comparable<CharBuffer>, Appendable, CharSequence, Readable
    一个char缓冲区。

    这个类在char缓冲区中定义了四类操作：

    • 绝对和相对的get和put读写单个字符的方法;

    • 相对bulk get方法将连续的字符序列从该缓冲区传输到数组中; 和

    • 相对bulk put方法，将char数组，字符串或其他一些其他char缓冲区中的字符串连续传输到此缓冲区中; 和

    • 一个方法compacting一个char缓冲区。

    Char缓冲区可以由allocation创建，它为缓冲区的内容分配空间， wrapping将现有的char数组或字符串分配到缓冲区中，或者通过创建现有字节缓冲区的view 。

    像一个字节缓冲区一样，char缓冲区是direct or non-direct 。 通过wrap方法创建的char缓冲区将是非直接的。 作为字节缓冲区视图创建的char缓冲区将是直接的，只有当字节缓冲区本身是直接的。 char缓冲区是否直接可以通过调用isDirect方法来确定。

    该类实现CharSequence接口，使得可以在字符序列被接受的地方使用字符缓冲器，例如在正则表达式包java.util.regex中 。

    指定此类中没有值返回值的方法返回调用它们的缓冲区。 这允许方法调用被链接。 语句序列

     cb.put("text/");
 cb.put(subtype);
 cb.put("; charset=");
 cb.put(enc);
    例如，可以用单个语句来替换
     cb.put("text/").put(subtype).put("; charset=").put(enc);
    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static CharBuffer allocate​(int capacity)
      分配一个新的char缓冲区。
      CharBuffer append​(char c)
      将指定的字符追加到此缓冲区 （可选操作） 。
      CharBuffer append​(CharSequence csq)
      将指定的字符序列追加到此缓冲区 （可选操作） 。
      CharBuffer append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此缓冲区 （可选操作） 。
      char[] array​()
      返回支持此缓冲区的char数组 （可选操作） 。
      int arrayOffset​()
      返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
      abstract CharBuffer asReadOnlyBuffer​()
      创建一个新的只读char缓冲区，共享此缓冲区的内容。
      char charAt​(int index)
      以相对于当前位置的给定索引读取字符。
      IntStream chars​()
      返回一个 int的流，从这个序列中扩展 char值。
      CharBuffer clear​()
      清除此缓冲区。
      abstract CharBuffer compact​()
      压缩此缓冲区 （可选操作） 。
      int compareTo​(CharBuffer that)
      将此缓冲区与另一个缓冲区进
      abstract CharBuffer duplicate​()
      创建一个新的char缓冲区，共享此缓冲区的内容。
      boolean equals​(Object ob)
      告诉这个缓冲区是否等于另一个对象。
      CharBuffer flip​()
      翻转这个缓冲区。
      abstract char get​()
      相对 获取方法。
      CharBuffer get​(char[] dst)
      相对批量 获取方法。
      CharBuffer get​(char[] dst, int offset, int length)
      相对批量 获取方法。
      abstract char get​(int index)
      绝对 获取方法。
      boolean hasArray​()
      告诉这个缓冲区是否由可访问的字符数组支持。
      int hashCode​()
      返回此缓冲区的当前哈希码。
      abstract boolean isDirect​()
      告诉这个char缓冲区是否直接。
      int length​()
      返回此字符缓冲区的长度。
      CharBuffer limit​(int newLimit)
      设置此缓冲区的限制。
      CharBuffer mark​()
      将此缓冲区的标记设置在其位置。
      abstract ByteOrder order​()
      检索此缓冲区的字节顺序。
      CharBuffer position​(int newPosition)
      设置这个缓冲区的位置。
      abstract CharBuffer put​(char c)
      相对 放置法 （可选操作） 。
      CharBuffer put​(char[] src)
      相对大容量 put方法 （可选操作） 。
      CharBuffer put​(char[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract CharBuffer put​(int index, char c)
      绝对 put方法 （可选操作） 。
      CharBuffer put​(String src)
      相对大容量 put方法 （可选操作） 。
      CharBuffer put​(String src, int start, int end)
      相对大容量 put方法 （可选操作） 。
      CharBuffer put​(CharBuffer src)
      相对大容量 put方法 （可选操作） 。
      int read​(CharBuffer target)
      尝试将字符读入指定的字符缓冲区。
      CharBuffer reset​()
      将此缓冲区的位置重置为先前标记的位置。
      CharBuffer rewind​()
      倒带这个缓冲区。
      abstract CharBuffer slice​()
      创建一个新的char缓冲区，其内容是此缓冲区内容的共享子序列。
      abstract CharBuffer subSequence​(int start, int end)
      创建一个新的字符缓冲区，代表该缓冲区相对于当前位置的指定子序列。
      String toString​()
      返回一个包含此缓冲区中字符的字符串。
      static CharBuffer wrap​(char[] array)
      将一个char数组包装到缓冲区中。
      static CharBuffer wrap​(char[] array, int offset, int length)
      将一个char数组包装到缓冲区中。
      static CharBuffer wrap​(CharSequence csq)
      将字符序列包装到缓冲区中。
      static CharBuffer wrap​(CharSequence csq, int start, int end)
      将字符序列包装到缓冲区中。

      • Methods inherited from class java.nio.Buffer

        capacity, hasRemaining, isReadOnly, limit, position, remaining

      • Methods inherited from interface java.lang.CharSequence

        codePoints

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • allocate

        public static CharBuffer allocate​(int capacity)
        分配一个新的char缓冲区。

        新缓冲区的位置将为零，其限制将为其容量，其标记将不定义，其每个元素将被初始化为零，其字节顺序将为底层硬件的native order 。 它将有一个backing array ，其array offset将为零。

        参数
        capacity - 新的缓冲区的容量，字符
        结果
        新的char缓冲区
        异常
        IllegalArgumentException - 如果 capacity是负整数

      • wrap

        public static CharBuffer wrap​(char[] array,
                              int offset,
                              int length)
        将一个char数组包装到缓冲区中。

        新缓冲区将由给定的char数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区容量将为array.length ，其位置将为offset ，其限制将为offset + length ，其标记将不定义，其字节顺序将为底层硬件的native order 。 它的backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回新缓冲区的数组
        offset - 要使用的子阵列的偏移量; 必须是非负数，不得大于array.length 。 新缓冲区的位置将被设置为此值。
        length - 要使用的子阵列的长度; 必须是非负数，不得大于array.length - offset 。 新缓冲区的限制将设置为offset + length 。
        结果
        新的char缓冲区
        异常
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • wrap

        public static CharBuffer wrap​(char[] array)
        将一个char数组包装到缓冲区中。

        新缓冲区将由给定的char数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区的容量和限制将为array.length ，其位置将为零，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回此缓冲区的数组
        结果
        新的char缓冲区

      • read

        public int read​(CharBuffer target)
         throws IOException
        尝试将字符读入指定的字符缓冲区。 缓冲区用作字符存储库：唯一的更改是put操作的结果。 不执行缓冲器的翻转或倒带。
        Specified by:
        read在接口 Readable
        参数
        target - 读取字符的缓冲区
        结果
        添加到缓冲区的字符数，如果此字符源结束，则为-1
        异常
        IOException - 如果发生I / O错误
        NullPointerException - 如果目标为null
        ReadOnlyBufferException - 如果目标是只读缓冲区
        从以下版本开始：
        1.5

      • wrap

        public static CharBuffer wrap​(CharSequence csq,
                              int start,
                              int end)
        将字符序列包装到缓冲区中。

        新的只读缓冲区的内容将是给定字符序列的内容。 缓冲区的容量将为csq.length() ，其位置将为start ，其限制将为end ，其标记将不定。

        参数
        csq - 要创建新字符缓冲区的字符序列
        start - 要使用的第一个字符的索引; 必须是非负数，不得大于csq.length() 。 新缓冲区的位置将被设置为此值。
        end - 要使用的最后一个字符后面的字符的索引; 必须不小于start ，不得大于csq.length() 。 新缓冲区的限制将被设置为此值。
        结果
        新的字符缓冲区
        异常
        IndexOutOfBoundsException - 如果 start和 end参数的前提条件不成立

      • wrap

        public static CharBuffer wrap​(CharSequence csq)
        将字符序列包装到缓冲区中。

        新的只读缓冲区的内容将是给定字符序列的内容。 新增缓存的容量和限制将为csq.length() ，其位置将为零，其标志将不明确。

        参数
        csq - 要创建新字符缓冲区的字符序列
        结果
        新的字符缓冲区

      • slice

        public abstract CharBuffer slice​()
        创建一个新的char缓冲区，其内容是此缓冲区内容的共享子序列。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是此缓冲区中剩余的字符数，其标记将不定义，并且其字节顺序将与此缓冲区的字节顺序相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        slice在 Buffer
        结果
        新的char缓冲区

      • duplicate

        public abstract CharBuffer duplicate​()
        创建一个新的char缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        duplicate在 Buffer
        结果
        新的char缓冲区

      • asReadOnlyBuffer

        public abstract CharBuffer asReadOnlyBuffer​()
        创建一个新的只读char缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 这个缓冲区内容的更改将在新的缓冲区中显示; 但是，新的缓冲区本身将是只读的，不允许修改共享内容。 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。

        如果这个缓冲区本身是只读的，那么这个方法的行为与duplicate的方法完全相同。

        结果
        新的只读char缓冲区

      • get

        public abstract char get​()
        相对获取方法。 读取此缓冲区当前位置的字符，然后增加位置。
        结果
        在缓冲区的当前位置的char
        异常
        BufferUnderflowException - 如果缓冲区的当前位置不小于其限制

      • put

        public abstract CharBuffer put​(char c)
        相对放置法（可选操作） 。

        将给定的字符写入当前位置的缓冲区，然后增加位置。

        参数
        c - c的字符
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区的当前位置不小于其限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public abstract char get​(int index)
        绝对获取方法。 读取给定索引的char。
        参数
        index - 从中读取char的索引
        结果
        给定索引的字符
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制

      • put

        public abstract CharBuffer put​(int index,
                               char c)
        绝对put方法（可选操作） 。

        将给定的char写入给定索引的缓冲区。

        参数
        index - 将写入字符的索引
        c - 要写入的字符值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public CharBuffer get​(char[] dst,
                      int offset,
                      int length)
        相对批量获取方法。

        此方法将chars从此缓冲区传输到给定的目标数组。 如果缓冲区中剩余的字符少于满足请求所需的字符数，即length > remaining() ，则不会传输字符并抛出BufferUnderflowException 。

        否则，此方法将length这个缓冲区的字符复制到给定的数组中，从该缓冲区的当前位置开始，并在数组中给定的偏移量。 此缓冲区的位置然后增加length 。

        换句话说，这种src.get(dst, off, len)形式的方法的调用与循环完全相同

           for (int i = off; i < off + len; i++) dst[i] = src.get():
        除了它首先检查这个缓冲区中是否有足够的字符，并且它可能更有效率。
        参数
        dst - 要写入字符的数组
        offset - 要写入的第一个char的数组中的偏移量; 必须是非负数，不得大于dst.length
        length - 要写入给定数组的最大字符数; 必须是非负数，不得大于dst.length - offset
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的字符少于 length字符
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • get

        public CharBuffer get​(char[] dst)
        相对批量获取方法。

        此方法将chars从此缓冲区传输到给定的目标数组。 对这种src.get(a)形式的方法的调用与调用的方式完全相同

          src.get(a, 0, a.length)
        参数
        dst - 目的数组
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的字符少于 length字符

      • put

        public CharBuffer put​(CharBuffer src)
        相对大容量put方法（可选操作） 。

        此方法将给定源缓冲区中剩余的字符传输到此缓冲区。 如果源缓冲区中存在的字符多于此缓冲区中的字符数，即src.remaining() > remaining() ，则不会传输字符并抛出BufferOverflowException 。

        否则，该方法将n = src.remaining()字符从给定缓冲区复制到此缓冲区，从每个缓冲区的当前位置开始。 然后将两个缓冲器的位置递增n 。

        换句话说，这种dst.put(src)形式的方法的调用与循环完全相同

          while (src.hasRemaining())
         dst.put(src.get());
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取字符的源缓冲区; 不能是这个缓冲区
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果源缓冲区中剩余字符的此缓冲区空间不足
        IllegalArgumentException - 如果源缓冲区是此缓冲区
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public CharBuffer put​(char[] src,
                      int offset,
                      int length)
        相对大容量put方法（可选操作） 。

        此方法将chars从给定的源数组传入此缓冲区。 如果从数组中复制的字符多于保留在此缓冲区中的字符数，即length > remaining() ，则不会传输字符并抛出BufferOverflowException 。

        否则，该方法length定数组中的length字符复制到此缓冲区中，从数组中给定的偏移量和此缓冲区的当前位置开始。 此缓冲区的位置然后增加length 。

        换句话说，这种dst.put(src, off, len)形式的方法的调用与循环完全相同

           for (int i = off; i < off + len; i++) dst.put(a[i]);
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要从中读取字符的数组
        offset - 要读取的第一个字符的数组中的偏移量; 必须是非负数，不得大于array.length
        length - 从给定数组读取的字符数; 必须是非负数，不得大于array.length - offset
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立
        ReadOnlyBufferException - 如果此缓冲区为只读

      • put

        public final CharBuffer put​(char[] src)
        相对大容量put方法（可选操作） 。

        此方法将给定源字符数组的整个内容传输到此缓冲区。 对这种dst.put(a)形式的方法的调用与调用的方式完全相同

          dst.put(a, 0, a.length)
        参数
        src - 源数组
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public CharBuffer put​(String src,
                      int start,
                      int end)
        相对大容量put方法（可选操作） 。

        此方法将字符串从给定的字符串传输到此缓冲区。 如果要从字符串中复制的字符数多于保留在此缓冲区中的字符数，即end - start > remaining() ，则不会传输字符并抛出BufferOverflowException 。

        否则，此方法将给定字符串中的n = end - start字符复制到此缓冲区中，从给定的start索引和此缓冲区的当前位置开始。 然后将该缓冲器的位置增加n 。

        换句话说，这种形式为dst.put(src, start, end)方法的调用与dst.put(src, start, end)具有完全相同的效果

           for (int i = start; i < end; i++) dst.put(src.charAt(i));
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要从中读取字符的字符串
        start - 要读取的第一个字符串的字符串中的偏移量; 必须是非负数，不得大于string.length()
        end - 要读取的最后一个字符串的字符串中的偏移量，加1; 必须是非负数，不得大于string.length()
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区空间不足
        IndexOutOfBoundsException - 如果 start和 end参数的前提条件不成立
        ReadOnlyBufferException - 如果这个缓冲区是只读的

      • put

        public final CharBuffer put​(String src)
        相对大容量put方法（可选操作） 。

        此方法将给定源字符串的整个内容传输到此缓冲区。 这种dst.put(s)形式的方法的调用与调用的方式完全相同

          dst.put(s, 0, s.length())
        参数
        src - 源字符串
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • hasArray

        public final boolean hasArray​()
        告诉这个缓冲区是否由可访问的字符数组支持。

        如果此方法返回true则可以安全地调用array和arrayOffset方法。

        Specified by:
        hasArray在 Buffer
        结果
        true如果并且只有这个缓冲区由数组支持并且不是只读的

      • array

        public final char[] array​()
        返回支持此缓冲区的char数组（可选操作） 。

        对此缓冲区内容的修改将导致返回的数组的内容被修改，反之亦然。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        array在 Buffer
        结果
        支持这个缓冲区的数组
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • arrayOffset

        public final int arrayOffset​()
        返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量（可选操作） 。

        如果此缓冲区由数组支持，则缓冲区p对应于数组索引p + arrayOffset() 。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        arrayOffset在 Buffer
        结果
        缓冲区的第一个元素的缓冲区数组中的偏移量
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • position

        public final CharBuffer position​(int newPosition)
        设置这个缓冲区的位置。 如果标记被定义并且大于新位置，则它被丢弃。
        重写：
        position在 Buffer
        参数
        newPosition - 新的位置值; 必须是非负数，不得大于当前限制
        结果
        这个缓冲区

      • limit

        public final CharBuffer limit​(int newLimit)
        设置此缓冲区的限制。 如果位置大于新的限制，那么它被设置为新的限制。 如果标记被定义并且大于新限制，则它被丢弃。
        重写：
        limit在 Buffer
        参数
        newLimit - 新限制值; 必须是非负数，不大于此缓冲区的容量
        结果
        这个缓冲区

      • mark

        public final CharBuffer mark​()
        将此缓冲区的标记设置在其位置。
        重写：
        mark在类 Buffer
        结果
        这个缓冲区

      • reset

        public final CharBuffer reset​()
        将此缓冲区的位置重置为先前标记的位置。

        调用此方法既不会更改也不丢弃该标记的值。

        重写：
        reset在 Buffer
        结果
        这个缓冲区

      • clear

        public final CharBuffer clear​()
        清除此缓冲区。 位置设置为零，限制设置为容量，标记被丢弃。

        在使用一系列通道读取或放置操作填充此缓冲区之前调用此方法。 例如：

         buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

        该方法实际上并不会清除缓冲区中的数据，而是将其命名为它的确因为它最常用于情况也是如此。

        重写：
        clear在 Buffer
        结果
        这个缓冲区

      • flip

        public final CharBuffer flip​()
        翻转这个缓冲区。 该限制设置为当前位置，然后将该位置设置为零。 如果标记被定义，则它被丢弃。

        在通道读取或放置操作的序列之后，调用此方法来准备一系列通道写入或相对获取操作。 例如：

         buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

        当将数据从一个地方传输到另一个地址时，该方法通常与compact方法结合使用。

        重写：
        flip在 Buffer
        结果
        这个缓冲区

      • rewind

        public final CharBuffer rewind​()
        倒带这个缓冲区。 位置设置为零，标记被丢弃。

        在通道写入或获取操作的序列之前调用此方法，假设已经设置了相应的限制。 例如：

         out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array
        重写：
        rewind在类 Buffer
        结果
        这个缓冲区

      • compact

        public abstract CharBuffer compact​()
        压缩此缓冲区（可选操作） 。

        缓冲区当前位置和其限制（如果有的话）之间的字符将被复制到缓冲区的开头。 也就是说，索引p = position()处的字符被复制到索引零，索引p + 1处的字符被复制到索引1，依此类推，直到索引limit()的字符被复制到索引n = limit() - 1 - p 。 然后将缓冲区的位置设置为n + 1，并将其限制设置为其容量。 标记如果被定义，则被丢弃。

        缓冲区的位置设置为复制的字符数，而不是零，因此可以通过调用另一个相对put方法来立即调用此方法。

        结果
        这个缓冲区
        异常
        ReadOnlyBufferException - 如果这个缓冲区是只读的

      • isDirect

        public abstract boolean isDirect​()
        告诉这个char缓冲区是否直接。
        Specified by:
        isDirect在 Buffer
        结果
        true如果，只有这个缓冲区是直接的

      • hashCode

        public int hashCode​()
        返回此缓冲区的当前哈希码。

        char缓冲区的哈希码仅依赖于它的剩余元素; 也就是说，元素从position()直到并包括元素在limit() - 1 。

        因为缓冲区哈希码是内容依赖的，所以使用缓冲区作为哈希映射或类似数据结构中的密钥是不合适的，除非知道它们的内容不会改变。

        重写：
        hashCode在 Object
        结果
        这个缓冲区的当前哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        告诉这个缓冲区是否等于另一个对象。

        两个char缓冲区是相等的，如果，只有这样，

        1. 它们具有相同的元素类型，

        2. 他们有相同数量的剩余元素，和

        3. 独立于其起始位置的剩余元素的两个序列是相等的。

        char缓冲区不等于任何其他类型的对象。

        重写：
        equals在 Object
        参数
        ob - 要比较此缓冲区的对象
        结果
        true如果，并且只有当这个缓冲区等于给定的对象
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(CharBuffer that)
        将此缓冲区与另一个缓冲区进

        通过比较其字母顺序的剩余元素序列来比较两个字符缓冲区，而不考虑其相应缓冲区内每个序列的起始位置。 对char元素进行比较，仿佛通过调用Character.compare(char,char) 。

        char缓冲区与任何其他类型的对象不可比较。

        Specified by:
        compareTo在接口 Comparable<CharBuffer>
        参数
        that - 要比较的对象。
        结果
        负整数，零或正整数，因为此缓冲区小于，等于或大于给定的缓冲区

      • toString

        public String toString​()
        返回一个包含此缓冲区中字符的字符串。

        结果字符串的第一个字符将是此缓冲区位置的字符，而最后一个字符将是索引号limit() - 1处的字符。调用此方法不会更改缓冲区的位置。

        Specified by:
        toString在接口 CharSequence
        重写：
        toString在 Object
        结果
        指定的字符串

      • length

        public final int length​()
        返回此字符缓冲区的长度。

        当被视为字符序列时，字符缓冲区的长度只是位置（包括）和限制（排除）之间的字符数; 也就是说，它相当于remaining() 。

        Specified by:
        length在接口 CharSequence
        结果
        这个字符缓冲区的长度

      • charAt

        public final char charAt​(int index)
        以相对于当前位置的给定索引读取字符。
        Specified by:
        charAt在接口 CharSequence
        参数
        index - 要读取的字符的索引，相对于位置; 必须是非负数，小于remaining()
        结果
        索引号为 position() + index的字符
        异常
        IndexOutOfBoundsException -如果前提 index不成立

      • subSequence

        public abstract CharBuffer subSequence​(int start,
                                       int end)
        创建一个新的字符缓冲区，代表该缓冲区相对于当前位置的指定子序列。

        新缓冲区将共享此缓冲区的内容; 也就是说，如果此缓冲区的内容是可变的，则对一个缓冲区的修改将导致另一个缓冲区被修改。 新缓冲区的容量将是这个缓冲区的容量，其位置将为position() + start ，其限制将为position() + end 。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        subSequence在接口 CharSequence
        参数
        start - 子序列中第一个字符的相对于当前位置的索引; 必须是非负数，不得大于remaining()
        end - 子序列中最后一个字符之后的字符的相对于当前位置的索引; 必须不小于start ，不得大于remaining()
        结果
        新的字符缓冲区
        异常
        IndexOutOfBoundsException - 如果 start和 end的前提条件不成立

      • append

        public CharBuffer append​(CharSequence csq)
        将指定的字符序列追加到此缓冲区（可选操作） 。

        对这种dst.append(csq)形式的方法的调用与调用的方式完全相同

          dst.put(csq.toString())

        取决于规范toString字符序列csq ，整个序列可以不追加。 例如，调用字符缓冲区的toString方法将返回其内容取决于缓冲区的位置和限制的子序列。

        Specified by:
        append在接口 Appendable
        参数
        csq - 要追加的字符序列。 如果csq为null ，则四个字符"null"附加到该字符缓冲区。
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        ReadOnlyBufferException - 如果此缓冲区是只读的
        从以下版本开始：
        1.5

      • append

        public CharBuffer append​(CharSequence csq,
                         int start,
                         int end)
        将指定字符序列的子序列附加到此缓冲区（可选操作） 。

        形式的这种方法的调用dst.append(csq, start, end)时csq不是null ，行为以完全相同的方式调用

          dst.put(csq.subSequence(start, end).toString())
        Specified by:
        append在接口 Appendable
        参数
        csq - 附加子序列的字符序列。 如果csq是null ，则会附加字符，因为csq包含四个字符"null" 。
        start - 子序列中第一个字符的索引
        end - 子序列中最后一个字符后面的字符的索引
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        IndexOutOfBoundsException - 如果 start或 end为负，则 start大于 end ，或 end大于 csq.length()
        ReadOnlyBufferException - 如果此缓冲区是只读的
        从以下版本开始：
        1.5

      • append

        public CharBuffer append​(char c)
        将指定的字符追加到此缓冲区（可选操作） 。

        对这种dst.append(c)形式的方法的调用与调用的方式完全相同

          dst.put(c)
        Specified by:
        append在接口 Appendable
        参数
        c - 要追加的16位字符
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区空间不足
        ReadOnlyBufferException - 如果此缓冲区是只读的
        从以下版本开始：
        1.5

      • order

        public abstract ByteOrder order​()
        检索此缓冲区的字节顺序。

        通过分配或通过包装现有的char阵列创建的char缓冲区的字节顺序是底层硬件的native order 。 作为字节缓冲区的view创建的char缓冲区的字节顺序是创建视图时的字节缓冲区的字节顺序。

        结果
        这个缓冲区的字节顺序

      • chars

        public IntStream chars​()
        说明从接口CharSequence复制
        返回一个int的流，从这个序列中扩展char值。 映射到surrogate code point的任何字符将通过未解释的方式传递。

        当终端流操作开始时（特别地，对于可变序列，流的分流器是late-binding ），流与该序列绑定。 如果序列在该操作期间被修改，则结果是未定义的。

        Specified by:
        chars在接口 CharSequence
        结果
        这个序列中的char值的IntStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class DoubleBuffer

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.DoubleBuffer
  • All Implemented Interfaces:
    Comparable<DoubleBuffer>

    public abstract class DoubleBuffer
extends Buffer
implements Comparable<DoubleBuffer>
    双缓冲。

    此类定义了双缓冲区中的四类操作：

    • 绝对和相对的get和put读和写双重的方法;

    • 相对bulk get方法将连续的双倍序列从此缓冲区传输到数组中; 和

    • 相对的bulk put方法，将来自双阵列或其他双缓冲区的连续双精度序列传输到该缓冲区中; 和

    • 一种compacting双缓冲区的方法。

    双缓冲区可以由allocation创建，它为缓冲区的内容分配空间wrapping现有的双阵列到缓冲区中，或通过创建现有字节缓冲区的view 。

    像一个字节缓冲区一样，双缓冲区是direct or non-direct 。 通过wrap方法创建的双缓冲区将是非直接的。 创建为字节缓冲区视图的双缓冲区将是直接的，只有当字节缓冲区本身是直接的。 双缓冲区是否直接可以通过调用isDirect方法来确定。

    指定此类中没有值返回值的方法返回调用它们的缓冲区。 这允许方法调用被链接。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static DoubleBuffer allocate​(int capacity)
      分配一个新的双缓冲区。
      double[] array​()
      返回支持此缓冲区的双数组 （可选操作） 。
      int arrayOffset​()
      返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
      abstract DoubleBuffer asReadOnlyBuffer​()
      创建一个新的只读双缓冲区，共享此缓冲区的内容。
      DoubleBuffer clear​()
      清除此缓冲区。
      abstract DoubleBuffer compact​()
      压缩此缓冲区 （可选操作） 。
      int compareTo​(DoubleBuffer that)
      将此缓冲区与另一个缓冲区进
      abstract DoubleBuffer duplicate​()
      创建一个新的双缓冲区，共享此缓冲区的内容。
      boolean equals​(Object ob)
      告诉这个缓冲区是否等于另一个对象。
      DoubleBuffer flip​()
      翻转这个缓冲区。
      abstract double get​()
      相对 获取方法。
      DoubleBuffer get​(double[] dst)
      相对批量 获取方法。
      DoubleBuffer get​(double[] dst, int offset, int length)
      相对批量 获取方法。
      abstract double get​(int index)
      绝对 获取方法。
      boolean hasArray​()
      告诉这个缓冲区是否由可访问的双阵列支持。
      int hashCode​()
      返回此缓冲区的当前哈希码。
      abstract boolean isDirect​()
      告诉这个双缓冲区是否直接。
      DoubleBuffer limit​(int newLimit)
      设置此缓冲区的限制。
      DoubleBuffer mark​()
      将此缓冲区的标记设置在其位置。
      abstract ByteOrder order​()
      检索此缓冲区的字节顺序。
      DoubleBuffer position​(int newPosition)
      设置这个缓冲区的位置。
      abstract DoubleBuffer put​(double d)
      相对 放置法 （可选操作） 。
      DoubleBuffer put​(double[] src)
      相对大容量 put方法 （可选操作） 。
      DoubleBuffer put​(double[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract DoubleBuffer put​(int index, double d)
      绝对 put方法 （可选操作） 。
      DoubleBuffer put​(DoubleBuffer src)
      相对大容量 put方法 （可选操作） 。
      DoubleBuffer reset​()
      将此缓冲区的位置重置为先前标记的位置。
      DoubleBuffer rewind​()
      倒带这个缓冲区。
      abstract DoubleBuffer slice​()
      创建一个新的双缓冲区，其内容是此缓冲区内容的共享子序列。
      String toString​()
      返回一个汇总此缓冲区状态的字符串。
      static DoubleBuffer wrap​(double[] array)
      将双阵列包装到缓冲区中。
      static DoubleBuffer wrap​(double[] array, int offset, int length)
      将双阵列包装到缓冲区中。

      • Methods inherited from class java.nio.Buffer

        capacity, hasRemaining, isReadOnly, limit, position, remaining

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • allocate

        public static DoubleBuffer allocate​(int capacity)
        分配一个新的双缓冲区。

        新缓冲区的位置将为零，其限制将为其容量，其标记将不定义，其每个元素将被初始化为零，其字节顺序将为底层硬件的native order 。 它将有一个backing array ，其array offset将为零。

        参数
        capacity - 新的缓冲区的容量，双打
        结果
        新的双缓冲
        异常
        IllegalArgumentException - 如果 capacity是负整数

      • wrap

        public static DoubleBuffer wrap​(double[] array,
                                int offset,
                                int length)
        将双阵列包装到缓冲区中。

        新缓冲区将由给定的双数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区容量将为array.length ，其位置将为offset ，其限制将为offset + length ，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的阵列，其array offset将为零。

        参数
        array - 将返回新缓冲区的数组
        offset - 要使用的子阵列的偏移量; 必须是非负数，不得大于array.length 。 新缓冲区的位置将被设置为此值。
        length - 要使用的子阵列的长度; 必须是非负数，不得大于array.length - offset 。 新缓冲区的限制将设置为offset + length 。
        结果
        新的双缓冲
        异常
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • wrap

        public static DoubleBuffer wrap​(double[] array)
        将双阵列包装到缓冲区中。

        新缓冲区将由给定的双数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区的容量和限制将为array.length ，其位置将为零，其标记将不定义，其字节顺序将为底层硬件的native order 。 它的backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回此缓冲区的数组
        结果
        新的双缓冲

      • slice

        public abstract DoubleBuffer slice​()
        创建一个新的双缓冲区，其内容是此缓冲区内容的共享子序列。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是此缓冲区中剩余的双精度数，其标记将不定义，并且其字节顺序将与此缓冲区相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        slice在 Buffer
        结果
        新的双缓冲

      • duplicate

        public abstract DoubleBuffer duplicate​()
        创建一个新的双缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        duplicate在 Buffer
        结果
        新的双缓冲

      • asReadOnlyBuffer

        public abstract DoubleBuffer asReadOnlyBuffer​()
        创建一个新的只读双缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 这个缓冲区内容的更改将在新的缓冲区中显示; 但是，新的缓冲区本身将是只读的，不允许修改共享内容。 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。

        如果此缓冲区本身是只读的，则该方法的行为与duplicate方法完全相同。

        结果
        新的只读双缓冲区

      • get

        public abstract double get​()
        相对获取方法。 在此缓冲区的当前位置读取double，然后增加位置。
        结果
        缓冲区当前位置的双倍
        异常
        BufferUnderflowException - 如果缓冲区的当前位置不小于其限制

      • put

        public abstract DoubleBuffer put​(double d)
        相对放置法（可选操作） 。

        将给定的double写入到当前位置的缓冲区中，然后增加位置。

        参数
        d - d的双
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区的当前位置不小于其限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public abstract double get​(int index)
        绝对获取方法。 读取给定索引的双倍。
        参数
        index - 将从中读取双 index的索引
        结果
        给定指数的双倍
        异常
        IndexOutOfBoundsException - 如果 index为负值或不小于缓冲区限制

      • put

        public abstract DoubleBuffer put​(int index,
                                 double d)
        绝对put方法（可选操作） 。

        将给定的double写入给定索引的缓冲区。

        参数
        index - 将双面写入的索引
        d - 要写入的双重值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public DoubleBuffer get​(double[] dst,
                        int offset,
                        int length)
        相对批量获取方法。

        此方法将双缓冲区从该缓冲区传输到给定的目标数组。 如果缓冲区中剩余的双精度少于满足请求所需的双精度，即length > remaining() ，则不会传输双精度并抛出BufferUnderflowException 。

        否则，该方法将length从该缓冲区复制到给定的数组中，从该缓冲区的当前位置开始，并在数组中给定的偏移量。 然后将该缓冲区的位置增加length 。

        换句话说，这种形式为src.get(dst, off, len)方法的调用与循环完全相同

           for (int i = off; i < off + len; i++) dst[i] = src.get():
        除了它首先检查这个缓冲区中是否有足够的双打，并且它可能更有效率。
        参数
        dst - 要写入双精度数组
        offset - 要写入的第一个double的数组中的偏移量; 必须是非负数，不得大于dst.length
        length - 要写入给定数组的最大双精度数; 必须是非负数，不得大于dst.length - offset
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的数字少于 length双倍
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • get

        public DoubleBuffer get​(double[] dst)
        相对批量获取方法。

        此方法将双缓冲区从该缓冲区传输到给定的目标数组。 对这种src.get(a)形式的方法的调用与调用的方式完全相同

          src.get(a, 0, a.length)
        参数
        dst - 目的数组
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的数字少于 length双倍

      • put

        public DoubleBuffer put​(DoubleBuffer src)
        相对大容量put方法（可选操作） 。

        该方法将给定源缓冲区中剩余的双精度传输到此缓冲区。 如果源缓冲区中剩余的src.remaining() >比这个缓冲区多，那就是src.remaining() > remaining() ，那么没有传输双精度 ，抛出一个BufferOverflowException 。

        否则，该方法将n = src.remaining()从给定缓冲区复制到此缓冲区中，从每个缓冲区的当前位置开始。 然后将两个缓冲器的位置递增n 。

        换句话说，这种形式为dst.put(src)方法的调用与dst.put(src)具有完全相同的效果

          while (src.hasRemaining())
         dst.put(src.get());
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取双精度的源缓冲区; 不能是这个缓冲区
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果源缓冲区中剩余的双精度缓冲区中没有足够的空间
        IllegalArgumentException - 如果源缓冲区是这个缓冲区
        ReadOnlyBufferException - 如果这个缓冲区是只读的

      • put

        public DoubleBuffer put​(double[] src,
                        int offset,
                        int length)
        相对大容量put方法（可选操作） 。

        该方法从给定的源数组传输到该缓冲区的双精度。 如果从数组中复制的数量多于保留在此缓冲区中的length ，也就是length > remaining() ，则不会传输双精度，并抛出BufferOverflowException 。

        否则，该方法将length从给定的数组复制到此缓冲区中，从阵列中的给定偏移量和此缓冲区的当前位置开始。 此缓冲区的位置然后增加length 。

        换句话说，这种形式为dst.put(src, off, len)方法的调用与dst.put(src, off, len)具有完全相同的效果

           for (int i = off; i < off + len; i++) dst.put(a[i]);
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取双精度的数组
        offset - 要读取的第一个double数组中的偏移量; 必须是非负数，不得大于array.length
        length - 从给定数组读取的双精度数; 必须是非负数，不得大于array.length - offset
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public final DoubleBuffer put​(double[] src)
        相对大容量put方法（可选操作） 。

        此方法将给定源双数组的整个内容传输到此缓冲区。 这种dst.put(a)形式的方法的调用与调用的方式完全相同

          dst.put(a, 0, a.length)
        参数
        src - 源数组
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • hasArray

        public final boolean hasArray​()
        告诉这个缓冲区是否由可访问的双阵列支持。

        如果此方法返回true则可以安全地调用array和arrayOffset方法。

        Specified by:
        hasArray在 Buffer
        结果
        true如果，且仅当此缓冲区由数组支持并且不是只读

      • array

        public final double[] array​()
        返回支持此缓冲区的双数组（可选操作） 。

        对此缓冲区内容的修改将导致返回的数组的内容被修改，反之亦然。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        array在 Buffer
        结果
        支持这个缓冲区的数组
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区不由可访问阵列支持

      • arrayOffset

        public final int arrayOffset​()
        返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量（可选操作） 。

        如果此缓冲区由数组支持，则缓冲区位置p对应于数组索引p + arrayOffset() 。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后备数组。

        Specified by:
        arrayOffset在 Buffer
        结果
        缓冲区的第一个元素的缓冲区数组中的偏移量
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • position

        public final DoubleBuffer position​(int newPosition)
        设置这个缓冲区的位置。 如果标记被定义并且大于新位置，则它被丢弃。
        重写：
        position在 Buffer
        参数
        newPosition - 新位置值; 必须是非负数，不得大于当前限制
        结果
        这个缓冲区

      • limit

        public final DoubleBuffer limit​(int newLimit)
        设置此缓冲区的限制。 如果位置大于新的限制，那么它被设置为新的限制。 如果标记被定义并且大于新限制，则它被丢弃。
        重写：
        limit在类 Buffer
        参数
        newLimit - 新限制值 必须是非负数，不大于此缓冲区的容量
        结果
        这个缓冲区

      • mark

        public final DoubleBuffer mark​()
        将此缓冲区的标记设置在其位置。
        重写：
        mark在类 Buffer
        结果
        这个缓冲区

      • reset

        public final DoubleBuffer reset​()
        将此缓冲区的位置重置为先前标记的位置。

        调用此方法既不会更改也不丢弃该标记的值。

        重写：
        reset在类 Buffer
        结果
        这个缓冲区

      • clear

        public final DoubleBuffer clear​()
        清除此缓冲区。 位置设置为零，限制设置为容量，标记被丢弃。

        在使用一系列通道读取或放置操作填充此缓冲区之前调用此方法。 例如：

         buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

        该方法实际上并不会清除缓冲区中的数据，而是将其命名为它的确因为它最常用于情况也是如此。

        重写：
        clear在 Buffer
        结果
        这个缓冲区

      • flip

        public final DoubleBuffer flip​()
        翻转这个缓冲区。 该限制设置为当前位置，然后将该位置设置为零。 如果标记被定义，则它被丢弃。

        在通道读取或放置操作的序列之后，调用此方法来准备一系列通道写入或相对获取操作。 例如：

         buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

        当将数据从一个地方传输到另一个地址时，该方法通常与compact方法结合使用。

        重写：
        flip在 Buffer
        结果
        这个缓冲区

      • rewind

        public final DoubleBuffer rewind​()
        倒带这个缓冲区。 位置设置为零，标记被丢弃。

        在通道写入或获取操作的序列之前调用此方法，假设已经设置了相应的限制。 例如：

         out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array
        重写：
        rewind在 Buffer
        结果
        这个缓冲区

      • compact

        public abstract DoubleBuffer compact​()
        压缩此缓冲区（可选操作） 。

        缓冲区的当前位置和其限制（如果有的话）之间的双精度被复制到缓冲区的开头。 也就是说，索引p = position()被复制到索引零，索引p + 1处的double被复制到索引1，直到索引号limit()的double被复制到索引n = limit() - 1 - p 。 然后将缓冲区的位置设置为n + 1，并将其限制设置为其容量。 标记如果被定义，则被丢弃。

        缓冲区的位置设置为复制的双精度数，而不是零，因此可以通过调用另一个相对put方法来立即调用此方法。

        结果
        这个缓冲区
        异常
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • isDirect

        public abstract boolean isDirect​()
        告诉这个双缓冲区是否直接。
        Specified by:
        isDirect在 Buffer
        结果
        true如果，只有这个缓冲区是直接的

      • toString

        public String toString​()
        返回一个汇总此缓冲区状态的字符串。
        重写：
        toString在 Object类
        结果
        摘要字符串

      • hashCode

        public int hashCode​()
        返回此缓冲区的当前哈希码。

        双缓冲区的哈希码仅取决于其剩余的元素; 也就是说，元素从position()到，包括元素在limit() - 1 。

        因为缓冲区哈希码是内容依赖的，所以使用缓冲区作为哈希映射或类似数据结构中的密钥是不合适的，除非知道它们的内容不会改变。

        重写：
        hashCode在 Object
        结果
        这个缓冲区的当前哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        告诉这个缓冲区是否等于另一个对象。

        两个双缓冲区是相等的，如果，只有如果，

        1. 它们具有相同的元素类型，

        2. 他们有相同数量的剩余元素，和

        3. 独立于其起始位置的剩余元素的两个序列是相等的。 该方法认为两个双元件a和b是如果等于(a == b) || (Double.isNaN(a) && Double.isNaN(b)) 。 值-0.0和+0.0被认为是相等的，不像Double.equals(Object) 。

        双缓冲区不等于任何其他类型的对象。

        重写：
        equals在 Object
        参数
        ob - 要比较此缓冲区的对象
        结果
        true如果，并且只有当这个缓冲区等于给定的对象
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(DoubleBuffer that)
        将此缓冲区与另一个缓冲区进

        将两个双缓冲区进行比较，比较其顺序的剩余元素的词典，而不考虑每个序列的起始位置在其相应的缓冲区内。 对double元素进行比较，仿佛通过调用Double.compare(double,double) ，除了-0.0和0.0被认为是相等的。 Double.NaN被认为是等于自己和大于所有其他double值（包括Double.POSITIVE_INFINITY ）。

        双缓冲区与任何其他类型的对象无法比较。

        Specified by:
        compareTo在接口 Comparable<DoubleBuffer>
        参数
        that - 要比较的对象。
        结果
        负整数，零或正整数，因为此缓冲区小于，等于或大于给定的缓冲区

      • order

        public abstract ByteOrder order​()
        检索此缓冲区的字节顺序。

        通过分配或通过包装现有的double阵列创建的双缓冲区的字节顺序是底层硬件的native order 。 创建为字节缓冲区view的双缓冲区的字节顺序是创建视图时的字节缓冲区的字节顺序。

        结果
        这个缓冲区的字节顺序
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FloatBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class FloatBuffer

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.FloatBuffer
  • All Implemented Interfaces:
    Comparable<FloatBuffer>

    public abstract class FloatBuffer
extends Buffer
implements Comparable<FloatBuffer>
    一个浮动缓冲区。

    这个类在浮动缓冲区上定义了四类操作：

    • 绝对和相对的get和put读写单个浮点数的方法;

    • 相对bulk get方法将相邻序列的浮点数从该缓冲区传输到数组中; 和

    • 相对bulk put方法将浮点数的浮动数组或其他浮动缓冲区的连续序列传输到此缓冲区中; 和

    • 一个compacting一个浮点缓冲区的方法。

    浮动缓冲区可以由allocation创建，它为缓冲区的内容分配空间， wrapping现有的浮点数组到缓冲区中，或者通过创建现有字节缓冲区的view 。

    像一个字节缓冲区，一个浮点缓冲区是direct or non-direct 。 通过wrap方法创建的浮动缓冲区将是非直接的。 作为字节缓冲区视图创建的浮动缓冲区将是直接的，只有当字节缓冲区本身是直接的。 浮动缓冲区是否直接可以通过调用isDirect方法来确定。

    指定此类中没有值返回值的方法返回调用它们的缓冲区。 这允许方法调用被链接。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static FloatBuffer allocate​(int capacity)
      分配一个新的浮动缓冲区。
      float[] array​()
      返回支持此缓冲区的float数组 （可选操作） 。
      int arrayOffset​()
      返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
      abstract FloatBuffer asReadOnlyBuffer​()
      创建一个新的只读浮动缓冲区，共享此缓冲区的内容。
      FloatBuffer clear​()
      清除此缓冲区。
      abstract FloatBuffer compact​()
      压缩此缓冲区 （可选操作） 。
      int compareTo​(FloatBuffer that)
      将此缓冲区与另一个缓冲区进
      abstract FloatBuffer duplicate​()
      创建一个新的浮动缓冲区，共享此缓冲区的内容。
      boolean equals​(Object ob)
      告诉这个缓冲区是否等于另一个对象。
      FloatBuffer flip​()
      翻转这个缓冲区。
      abstract float get​()
      相对 获取方法。
      FloatBuffer get​(float[] dst)
      相对批量 获取方法。
      FloatBuffer get​(float[] dst, int offset, int length)
      相对批量 获取方法。
      abstract float get​(int index)
      绝对 获取方法。
      boolean hasArray​()
      告诉这个缓冲区是否由可访问的浮点数组支持。
      int hashCode​()
      返回此缓冲区的当前哈希码。
      abstract boolean isDirect​()
      告诉这个浮动缓冲区是否直接。
      FloatBuffer limit​(int newLimit)
      设置此缓冲区的限制。
      FloatBuffer mark​()
      将此缓冲区的标记设置在其位置。
      abstract ByteOrder order​()
      检索此缓冲区的字节顺序。
      FloatBuffer position​(int newPosition)
      设置这个缓冲区的位置。
      abstract FloatBuffer put​(float f)
      相对 放置法 （可选操作） 。
      FloatBuffer put​(float[] src)
      相对大容量 put方法 （可选操作） 。
      FloatBuffer put​(float[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract FloatBuffer put​(int index, float f)
      绝对 put方法 （可选操作） 。
      FloatBuffer put​(FloatBuffer src)
      相对大容量 put方法 （可选操作） 。
      FloatBuffer reset​()
      将此缓冲区的位置重置为先前标记的位置。
      FloatBuffer rewind​()
      倒带这个缓冲区。
      abstract FloatBuffer slice​()
      创建一个新的浮动缓冲区，其内容是此缓冲区内容的共享子序列。
      String toString​()
      返回一个汇总此缓冲区状态的字符串。
      static FloatBuffer wrap​(float[] array)
      将一个浮点数组放入缓冲区。
      static FloatBuffer wrap​(float[] array, int offset, int length)
      将一个浮点数组放入缓冲区。

      • Methods inherited from class java.nio.Buffer

        capacity, hasRemaining, isReadOnly, limit, position, remaining

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • allocate

        public static FloatBuffer allocate​(int capacity)
        分配一个新的浮动缓冲区。

        新缓冲区的位置将为零，其限制将为其容量，其标记将不定义，其每个元素将被初始化为零，其字节顺序将为底层硬件的native order 。 它将有一个backing array ，其array offset将为零。

        参数
        capacity - 新的缓冲区的容量，在浮点数
        结果
        新的浮动缓冲区
        异常
        IllegalArgumentException - 如果 capacity是负整数

      • wrap

        public static FloatBuffer wrap​(float[] array,
                               int offset,
                               int length)
        将一个浮点数组放入缓冲区。

        新的缓冲区将由给定的float数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区容量将为array.length ，其位置将为offset ，其限制将为offset + length ，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回新缓冲区的数组
        offset - 要使用的子阵列的偏移量; 必须是非负数，不得大于array.length 。 新缓冲区的位置将被设置为此值。
        length - 要使用的子阵列的长度; 必须是非负数，不得大于array.length - offset 。 新缓冲区的限制将设置为offset + length 。
        结果
        新的浮动缓冲区
        异常
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • wrap

        public static FloatBuffer wrap​(float[] array)
        将一个浮点数组放入缓冲区。

        新的缓冲区将由给定的float数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区的容量和限制将为array.length ，其位置将为零，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回此缓冲区的数组
        结果
        新的浮动缓冲区

      • slice

        public abstract FloatBuffer slice​()
        创建一个新的浮动缓冲区，其内容是此缓冲区内容的共享子序列。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是该缓冲区中剩余的浮点数，其标记将不定义，并且其字节顺序将与该缓冲区的顺序相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        slice在 Buffer
        结果
        新的浮动缓冲区

      • duplicate

        public abstract FloatBuffer duplicate​()
        创建一个新的浮动缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        duplicate在 Buffer
        结果
        新的浮动缓冲区

      • asReadOnlyBuffer

        public abstract FloatBuffer asReadOnlyBuffer​()
        创建一个新的只读浮动缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 这个缓冲区内容的更改将在新的缓冲区中显示; 但是，新的缓冲区本身将是只读的，不允许修改共享内容。 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。

        如果这个缓冲区本身是只读的，那么这个方法的行为与duplicate方法完全相同。

        结果
        新的只读浮动缓冲区

      • get

        public abstract float get​()
        相对获取方法。 在此缓冲区的当前位置读取浮点数，然后增加该位置。
        结果
        浮点在缓冲区的当前位置
        异常
        BufferUnderflowException - 如果缓冲区的当前位置不小于其限制

      • put

        public abstract FloatBuffer put​(float f)
        相对放置法（可选操作） 。

        将给定的浮点数写入当前位置的缓冲区，然后增加位置。

        参数
        f - f的浮动
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区的当前位置不小于其限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public abstract float get​(int index)
        绝对获取方法。 读取给定索引的浮点数。
        参数
        index - 读取浮点数的索引
        结果
        浮动在给定的索引
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制

      • put

        public abstract FloatBuffer put​(int index,
                                float f)
        绝对put方法（可选操作） 。

        将给定的浮点数写入给定索引的缓冲区。

        参数
        index - 将写入浮点数的索引
        f - 要写入的浮点值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public FloatBuffer get​(float[] dst,
                       int offset,
                       int length)
        相对批量获取方法。

        此方法将浮点数从该缓冲区传输到给定的目标数组。 如果缓冲区中剩余的浮点数少于满足请求所需的浮点数，即length > remaining() ，则不会传输浮点数并抛出BufferUnderflowException 。

        否则，此方法将length浮点数从该缓冲区复制到给定的数组中，从该缓冲区的当前位置开始，并在数组中给定的偏移量。 然后将该缓冲区的位置增加length 。

        换句话说，这种形式为src.get(dst, off, len)方法的调用与循环完全相同

           for (int i = off; i < off + len; i++) dst[i] = src.get():
        除了它首先检查这个缓冲区中是否有足够的浮点数，并且可能会更有效率。
        参数
        dst - 要写入浮点数的数组
        offset - 要写入的第一个浮点数组中的偏移量; 必须是非负数，不得大于dst.length
        length - 要写入给定数组的最大浮点数; 必须是非负数，不得大于dst.length - offset
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的浮点数少于 length浮点数
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • get

        public FloatBuffer get​(float[] dst)
        相对批量获取方法。

        此方法将浮点数从该缓冲区传输到给定的目标数组。 对这种src.get(a)形式的方法的调用与调用的方式完全相同

          src.get(a, 0, a.length)
        参数
        dst - 目的地阵列
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的浮点数少于 length浮点数

      • put

        public FloatBuffer put​(FloatBuffer src)
        相对大容量put方法（可选操作） 。

        该方法将给定源缓冲区中剩余的浮点数传送到此缓冲区。 如果源缓冲区中剩余的浮点数比此缓冲区中的浮点数更多，也就是说，如果src.remaining() > remaining() ，则不会传输浮点数并抛出BufferOverflowException 。

        否则，该方法将n = src.remaining()浮点从给定缓冲区复制到此缓冲区中，从每个缓冲区的当前位置开始。 然后将两个缓冲器的位置递增n 。

        换句话说，这种形式为dst.put(src)方法的调用与循环完全相同

          while (src.hasRemaining())
         dst.put(src.get());
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取浮点数的源缓冲区; 不能是这个缓冲区
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果缓冲区中的剩余浮点数在源缓冲区中没有足够的空间
        IllegalArgumentException - 如果源缓冲区是这个缓冲区
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public FloatBuffer put​(float[] src,
                       int offset,
                       int length)
        相对大容量put方法（可选操作） 。

        该方法将浮点数从给定的源数组传输到该缓冲区。 如果从数组中复制的浮点数多于保留在此缓冲区中的浮点数，即length > remaining() ，则不会传输浮点数并抛出BufferOverflowException 。

        否则，该方法将length浮点数从给定的数组复制到此缓冲区中，从阵列中的给定偏移量和该缓冲区的当前位置开始。 此缓冲区的位置然后增加length 。

        换句话说，这种dst.put(src, off, len)形式的方法的调用与循环完全相同

           for (int i = off; i < off + len; i++) dst.put(a[i]);
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取浮点数的数组
        offset - 要读取的第一个浮点数组中的偏移量; 必须是非负数，不得大于array.length
        length - 从给定数组读取的浮点数; 必须是非负数，不得大于array.length - offset
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立
        ReadOnlyBufferException - 如果这个缓冲区是只读的

      • put

        public final FloatBuffer put​(float[] src)
        相对大容量put方法（可选操作） 。

        此方法将给定源float数组的整个内容传输到此缓冲区。 对这种dst.put(a)形式的方法的调用与调用的方式完全相同

          dst.put(a, 0, a.length)
        参数
        src - 源数组
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • hasArray

        public final boolean hasArray​()
        告诉这个缓冲区是否由可访问的浮点数组支持。

        如果此方法返回true则可以安全地调用array和arrayOffset方法。

        Specified by:
        hasArray在 Buffer
        结果
        true如果且仅当此缓冲区由数组支持且不是只读

      • array

        public final float[] array​()
        返回支持此缓冲区的float数组（可选操作） 。

        对此缓冲区内容的修改将导致返回的数组的内容被修改，反之亦然。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        array在 Buffer
        结果
        支持这个缓冲区的数组
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • arrayOffset

        public final int arrayOffset​()
        返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量（可选操作） 。

        如果此缓冲区由数组支持，则缓冲区p对应于数组索引p + arrayOffset() 。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        arrayOffset在 Buffer
        结果
        缓冲区的第一个元素的缓冲区数组中的偏移量
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • position

        public final FloatBuffer position​(int newPosition)
        设置这个缓冲区的位置。 如果标记被定义并且大于新位置，则它被丢弃。
        重写：
        position在 Buffer
        参数
        newPosition - 新的位置值; 必须是非负数，不得大于当前限制
        结果
        这个缓冲区

      • limit

        public final FloatBuffer limit​(int newLimit)
        设置此缓冲区的限制。 如果位置大于新的限制，那么它被设置为新的限制。 如果标记被定义并且大于新限制，则它被丢弃。
        重写：
        limit在 Buffer
        参数
        newLimit - 新限制值 必须是非负数，不大于此缓冲区的容量
        结果
        这个缓冲区

      • mark

        public final FloatBuffer mark​()
        将此缓冲区的标记设置在其位置。
        重写：
        mark在 Buffer
        结果
        这个缓冲区

      • reset

        public final FloatBuffer reset​()
        将此缓冲区的位置重置为先前标记的位置。

        调用此方法既不会更改也不丢弃该标记的值。

        重写：
        reset在 Buffer
        结果
        这个缓冲区

      • clear

        public final FloatBuffer clear​()
        清除此缓冲区。 位置设置为零，限制设置为容量，标记被丢弃。

        在使用一系列通道读取或放置操作填充此缓冲区之前调用此方法。 例如：

         buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

        该方法实际上并不会清除缓冲区中的数据，而是将其命名为它的确因为它最常用于情况也是如此。

        重写：
        clear在 Buffer
        结果
        这个缓冲区

      • flip

        public final FloatBuffer flip​()
        翻转这个缓冲区。 该限制设置为当前位置，然后将该位置设置为零。 如果标记被定义，则它被丢弃。

        在通道读取或放置操作的序列之后，调用此方法来准备一系列通道写入或相对获取操作。 例如：

         buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

        当将数据从一个地方传输到另一个地址时，该方法通常与compact方法结合使用。

        重写：
        flip在 Buffer
        结果
        这个缓冲区

      • rewind

        public final FloatBuffer rewind​()
        倒带这个缓冲区。 位置设置为零，标记被丢弃。

        在通道写入或获取操作的序列之前调用此方法，假设已经设置了相应的限制。 例如：

         out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array
        重写：
        rewind在类 Buffer
        结果
        这个缓冲区

      • compact

        public abstract FloatBuffer compact​()
        压缩此缓冲区（可选操作） 。

        缓冲区当前位置与其限制（如果有的话）之间的浮点数被复制到缓冲区的开头。 也就是说，索引p = position()处的浮点数被复制到索引零，将索引p + 1处的浮点复制到索引1，等等，直到索引limit()的浮点复制到索引n = limit() - 1 - p 。 然后将缓冲区的位置设置为n + 1，并将其限制设置为其容量。 标记如果被定义，则被丢弃。

        缓冲区的位置设置为复制的浮点数，而不是为零，因此可以通过调用另一个相对put方法来立即调用此方法。

        结果
        这个缓冲区
        异常
        ReadOnlyBufferException - 如果这个缓冲区是只读的

      • isDirect

        public abstract boolean isDirect​()
        告诉这个浮动缓冲区是否直接。
        Specified by:
        isDirect在 Buffer
        结果
        true如果，只有这个缓冲区是直接的

      • toString

        public String toString​()
        返回一个汇总此缓冲区状态的字符串。
        重写：
        toString在 Object
        结果
        摘要字符串

      • hashCode

        public int hashCode​()
        返回此缓冲区的当前哈希码。

        浮动缓冲区的哈希码仅取决于其余的元素; 也就是说，元素从position()到，并包括元素在limit() - 1 。

        因为缓冲区哈希码是内容依赖的，所以使用缓冲区作为哈希映射或类似数据结构中的密钥是不合适的，除非知道它们的内容不会改变。

        重写：
        hashCode在 Object
        结果
        这个缓冲区的当前哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        告诉这个缓冲区是否等于另一个对象。

        两个浮动缓冲区相等，如果只有

        1. 它们具有相同的元素类型，

        2. 他们有相同数量的剩余元素，和

        3. 独立于其起始位置的剩余元素的两个序列是相等的。 该方法认为如果为(a == b) || (Float.isNaN(a) && Float.isNaN(b))两个浮点元素a和b相等。 值-0.0和+0.0被认为是相等的，不像Float.equals(Object) 。

        浮动缓冲区不等于任何其他类型的对象。

        重写：
        equals在 Object
        参数
        ob - 要比较此缓冲区的对象
        结果
        true如果，并且只有当这个缓冲区等于给定的对象
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(FloatBuffer that)
        将此缓冲区与另一个缓冲区进

        通过将词汇的剩余元素序列进行比较来比较两个浮动缓冲区，而不考虑其相应缓冲区内每个序列的起始位置。 对float元素的比较，仿佛通过调用Float.compare(float,float) ，除了-0.0和0.0被认为是相等的。 Float.NaN被认为是等于自身和大于所有其他float值（包括Float.POSITIVE_INFINITY ）。

        浮动缓冲区与任何其他类型的对象无法比较。

        Specified by:
        compareTo在接口 Comparable<FloatBuffer>
        参数
        that - 要比较的对象。
        结果
        负整数，零或正整数，因为此缓冲区小于，等于或大于给定的缓冲区

      • order

        public abstract ByteOrder order​()
        检索此缓冲区的字节顺序。

        通过分配或通过包装现有的float阵列创建的浮动缓冲区的字节顺序是底层硬件的native order 。 作为字节缓冲区的view创建的浮点缓冲区的字节顺序是创建视图时的字节缓冲区的字节顺序。

        结果
        这个缓冲区的字节顺序
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class IntBuffer

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.IntBuffer
  • All Implemented Interfaces:
    Comparable<IntBuffer>

    public abstract class IntBuffer
extends Buffer
implements Comparable<IntBuffer>
    一个int缓冲区

    该类定义了int缓冲区中的四类操作：

    • 绝对和相对的get和put读取和写入单个int的方法;

    • 相对bulk get方法将连续的ints序列从该缓冲区传输到数组中; 和

    • 相对的bulk put方法，将连续的int数组从int数组或其他int缓冲区传输到该缓冲区中; 和

    • 一个方法为compacting一个int缓冲区。

    Int缓冲区可以由allocation创建，它为缓冲区的内容分配wrapping现有的int数组到缓冲区中，或通过创建现有字节缓冲区的view来创建空间 。

    像一个字节缓冲区一样，一个int缓冲区是direct or non-direct 。 通过wrap方法创建的int缓冲区将是非直接的。 作为字节缓冲区视图创建的int缓冲区将是直接的，只有当字节缓冲区本身是直接的。 int缓冲区是否直接可以通过调用isDirect方法来确定。

    指定此类中没有值返回值的方法返回调用它们的缓冲区。 这允许方法调用被链接。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static IntBuffer allocate​(int capacity)
      分配一个新的int缓冲区。
      int[] array​()
      返回支持此缓冲区的int数组 （可选操作） 。
      int arrayOffset​()
      返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
      abstract IntBuffer asReadOnlyBuffer​()
      创建一个新的只读int缓冲区，共享此缓冲区的内容。
      IntBuffer clear​()
      清除此缓冲区。
      abstract IntBuffer compact​()
      压缩此缓冲区 （可选操作） 。
      int compareTo​(IntBuffer that)
      将此缓冲区与另一个缓冲区进
      abstract IntBuffer duplicate​()
      创建一个共享此缓冲区内容的新int缓冲区。
      boolean equals​(Object ob)
      告诉这个缓冲区是否等于另一个对象。
      IntBuffer flip​()
      翻转这个缓冲区。
      abstract int get​()
      相对 获取方法。
      abstract int get​(int index)
      绝对 获取方法。
      IntBuffer get​(int[] dst)
      相对批量 获取方法。
      IntBuffer get​(int[] dst, int offset, int length)
      相对批量 获取方法。
      boolean hasArray​()
      告诉这个缓冲区是否由可访问的int数组支持。
      int hashCode​()
      返回此缓冲区的当前哈希码。
      abstract boolean isDirect​()
      告诉这个int缓冲区是否直接。
      IntBuffer limit​(int newLimit)
      设置此缓冲区的限制。
      IntBuffer mark​()
      将此缓冲区的标记设置在其位置。
      abstract ByteOrder order​()
      检索此缓冲区的字节顺序。
      IntBuffer position​(int newPosition)
      设置这个缓冲区的位置。
      abstract IntBuffer put​(int i)
      相对 放置法 （可选操作） 。
      IntBuffer put​(int[] src)
      相对大容量 put方法 （可选操作） 。
      IntBuffer put​(int[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract IntBuffer put​(int index, int i)
      绝对 put方法 （可选操作） 。
      IntBuffer put​(IntBuffer src)
      相对大容量 put方法 （可选操作） 。
      IntBuffer reset​()
      将此缓冲区的位置重置为先前标记的位置。
      IntBuffer rewind​()
      倒带这个缓冲区。
      abstract IntBuffer slice​()
      创建一个新的int缓冲区，其内容是此缓冲区内容的共享子序列。
      String toString​()
      返回一个汇总此缓冲区状态的字符串。
      static IntBuffer wrap​(int[] array)
      将int数组包装到缓冲区中。
      static IntBuffer wrap​(int[] array, int offset, int length)
      将int数组包装到缓冲区中。

      • Methods inherited from class java.nio.Buffer

        capacity, hasRemaining, isReadOnly, limit, position, remaining

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • allocate

        public static IntBuffer allocate​(int capacity)
        分配一个新的int缓冲区。

        新缓冲区的位置将为零，其限制将为其容量，其标记将不定义，其每个元素将被初始化为零，其字节顺序将为底层硬件的native order 。 它将有一个backing array ，其array offset将为零。

        参数
        capacity - 新的缓冲区的容量，在ints
        结果
        新的int缓冲区
        异常
        IllegalArgumentException - 如果 capacity是负整数

      • wrap

        public static IntBuffer wrap​(int[] array,
                             int offset,
                             int length)
        将int数组包装到缓冲区中。

        新的缓冲区将由给定的int数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区容量将为array.length ，其位置将为offset ，其限制将为offset + length ，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回新缓冲区的数组
        offset - 要使用的子阵列的偏移量; 必须是非负数，不得大于array.length 。 新缓冲区的位置将被设置为此值。
        length - 要使用的子阵列的长度; 必须是非负数，不得大于array.length - offset 。 新缓冲区的限制将设置为offset + length 。
        结果
        新的int缓冲区
        异常
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • wrap

        public static IntBuffer wrap​(int[] array)
        将int数组包装到缓冲区中。

        新的缓冲区将由给定的int数组支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新缓冲区的容量和限制将为array.length ，其位置将为零，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回此缓冲区的数组
        结果
        新的int缓冲区

      • slice

        public abstract IntBuffer slice​()
        创建一个新的int缓冲区，其内容是此缓冲区内容的共享子序列。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是该缓冲区中剩余的int数，其标记将不定义，并且其字节顺序将与此缓冲区的字节顺序相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        slice在 Buffer
        结果
        新的int缓冲区

      • duplicate

        public abstract IntBuffer duplicate​()
        创建一个共享此缓冲区内容的新int缓冲区。

        新缓冲区的内容将是这个缓冲区的内容。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        duplicate在 Buffer
        结果
        新的int缓冲区

      • asReadOnlyBuffer

        public abstract IntBuffer asReadOnlyBuffer​()
        创建一个新的只读int缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 这个缓冲区内容的更改将在新的缓冲区中显示; 但是，新的缓冲区本身将是只读的，不允许修改共享内容。 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。

        如果这个缓冲区本身是只读的，那么这个方法的行为与duplicate的方法完全相同。

        结果
        新的只读int缓冲区

      • get

        public abstract int get​()
        相对获取方法。 在此缓冲区的当前位置读取int，然后增加位置。
        结果
        int在缓冲区的当前位置
        异常
        BufferUnderflowException - 如果缓冲区的当前位置不小于其限制

      • put

        public abstract IntBuffer put​(int i)
        相对放置法（可选操作） 。

        将给定的int写入到当前位置的缓冲区中，然后增加位置。

        参数
        i - i的int
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区的当前位置不小于其限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public abstract int get​(int index)
        绝对获取方法。 读取给定索引的int。
        参数
        index - 从中读取的索引
        结果
        在给定索引的int
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制

      • put

        public abstract IntBuffer put​(int index,
                              int i)
        绝对put方法（可选操作） 。

        将给定的int写入给定索引的缓冲区。

        参数
        index - 将写入int的索引
        i - 要写入的int值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public IntBuffer get​(int[] dst,
                     int offset,
                     int length)
        相对批量获取方法。

        此方法将int从此缓冲区传输到给定的目标数组。 如果缓冲区中剩余的内容少于满足请求所需的int，那么，如果length > remaining() ，则不传输int，并抛出一个BufferUnderflowException 。

        否则，此方法将length int从此缓冲区复制到给定的数组中，从该缓冲区的当前位置开始，并在数组中给定的偏移量。 然后将该缓冲区的位置增加length 。

        换句话说，这种src.get(dst, off, len)形式的方法的调用与循环完全相同

           for (int i = off; i < off + len; i++) dst[i] = src.get():
        除了它首先检查这个缓冲区中是否有足够的int，并且它可能更有效率。
        参数
        dst - 要写入int的数组
        offset - 要写入的第一个int的数组中的偏移量; 必须是非负数，不得大于dst.length
        length - 要写入给定数组的最大int数; 必须是非负数，不得大于dst.length - offset
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的内容不足 length
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • get

        public IntBuffer get​(int[] dst)
        相对批量获取方法。

        此方法将int从此缓冲区传输到给定的目标数组。 调用此方法的形式为src.get(a)行为方式与调用完全相同

          src.get(a, 0, a.length)
        参数
        dst - 目的地阵列
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的数字少于 length int

      • put

        public IntBuffer put​(IntBuffer src)
        相对大容量put方法（可选操作） 。

        该方法将给定源缓冲区中剩余的int传输到此缓冲区。 如果源缓冲区中存在比在此缓冲区中剩余的多个int，也就是说，如果src.remaining() > remaining() ，则不传输int，并抛出一个27056926636363639 。

        否则，该方法将n = src.remaining() int从给定缓冲区复制到此缓冲区中，从每个缓冲区的当前位置开始。 然后将两个缓冲器的位置递增n 。

        换句话说，这种形式为dst.put(src)方法的调用与循环完全相同

          while (src.hasRemaining())
         dst.put(src.get());
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取int的源缓冲区; 不能是这个缓冲区
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中的源缓冲区中剩余的int没有足够的空间
        IllegalArgumentException - 如果源缓冲区是这个缓冲区
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public IntBuffer put​(int[] src,
                     int offset,
                     int length)
        相对大容量put方法（可选操作） 。

        此方法将ints从给定的源数组传输到这个缓冲区。 如果从数组中复制的内容多于保留在此缓冲区中，即length > remaining() ，则不会传输任何int，并抛出一个BufferOverflowException 。

        否则，该方法length定数组中的length int复制到此缓冲区中，从阵列中的给定偏移量和此缓冲区的当前位置开始。 此缓冲区的位置然后增加length 。

        换句话说，这种形式为dst.put(src, off, len)方法的调用与dst.put(src, off, len)具有完全相同的效果

           for (int i = off; i < off + len; i++) dst.put(a[i]);
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要从中读取int的数组
        offset - 要读取的第一个int的数组中的偏移量; 必须是非负数，不得大于array.length
        length - 要从给定数组读取的int数; 必须是非负数，不得大于array.length - offset
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立
        ReadOnlyBufferException - 如果此缓冲区为只读

      • put

        public final IntBuffer put​(int[] src)
        相对大容量put方法（可选操作） 。

        此方法将给定源int数组的整个内容传输到此缓冲区。 对这种dst.put(a)形式的方法的调用与调用的方式完全相同

          dst.put(a, 0, a.length)
        参数
        src - 源数组
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        ReadOnlyBufferException - 如果这个缓冲区是只读的

      • hasArray

        public final boolean hasArray​()
        告诉这个缓冲区是否由可访问的int数组支持。

        如果此方法返回true则可以安全地调用array和arrayOffset方法。

        Specified by:
        hasArray在 Buffer
        结果
        true如果且仅当此缓冲区由数组支持并且不是只读

      • array

        public final int[] array​()
        返回支持此缓冲区的int数组（可选操作） 。

        对此缓冲区内容的修改将导致返回的数组的内容被修改，反之亦然。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        array在 Buffer
        结果
        支持这个缓冲区的数组
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • arrayOffset

        public final int arrayOffset​()
        返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量（可选操作） 。

        如果此缓冲区由数组支持，则缓冲区p对应于数组索引p + arrayOffset() 。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        arrayOffset在 Buffer
        结果
        缓冲区的第一个元素的缓冲区数组中的偏移量
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • position

        public final IntBuffer position​(int newPosition)
        设置这个缓冲区的位置。 如果标记被定义并且大于新位置，则它被丢弃。
        重写：
        position在 Buffer
        参数
        newPosition - 新的位置值; 必须是非负数，不得大于当前限制
        结果
        这个缓冲区

      • limit

        public final IntBuffer limit​(int newLimit)
        设置此缓冲区的限制。 如果位置大于新的限制，那么它被设置为新的限制。 如果标记被定义并且大于新限制，则它被丢弃。
        重写：
        limit在 Buffer
        参数
        newLimit - 新限制值 必须是非负数，不大于此缓冲区的容量
        结果
        这个缓冲区

      • mark

        public final IntBuffer mark​()
        将此缓冲区的标记设置在其位置。
        重写：
        mark在 Buffer
        结果
        这个缓冲区

      • reset

        public final IntBuffer reset​()
        将此缓冲区的位置重置为先前标记的位置。

        调用此方法既不会更改也不丢弃该标记的值。

        重写：
        reset在 Buffer
        结果
        这个缓冲区

      • clear

        public final IntBuffer clear​()
        清除此缓冲区。 位置设置为零，限制设置为容量，标记被丢弃。

        在使用一系列通道读取或放置操作填充此缓冲区之前调用此方法。 例如：

         buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

        该方法实际上并不会清除缓冲区中的数据，而是将其命名为它的确因为它最常用于情况也是如此。

        重写：
        clear在 Buffer
        结果
        这个缓冲区

      • flip

        public final IntBuffer flip​()
        翻转这个缓冲区。 该限制设置为当前位置，然后将该位置设置为零。 如果标记被定义，则它被丢弃。

        在通道读取或放置操作的序列之后，调用此方法来准备一系列通道写入或相对获取操作。 例如：

         buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

        当将数据从一个地方传输到另一个地址时，该方法通常与compact方法结合使用。

        重写：
        flip在 Buffer
        结果
        这个缓冲区

      • rewind

        public final IntBuffer rewind​()
        倒带这个缓冲区。 位置设置为零，标记被丢弃。

        在通道写入或获取操作的序列之前调用此方法，假设已经设置了相应的限制。 例如：

         out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array
        重写：
        rewind在 Buffer
        结果
        这个缓冲区

      • compact

        public abstract IntBuffer compact​()
        压缩此缓冲区（可选操作） 。

        缓冲区当前位置与其限制（如果有的话）之间的int被复制到缓冲区的开头。 也就是说，索引p = position()处的int被复制到索引零，索引p + 1处的int被复制到索引1，等等，直到索引limit()的int被复制到索引n = limit() - 1 - p 。 然后将缓冲区的位置设置为n + 1，并将其限制设置为其容量。 标记如果被定义，则被丢弃。

        缓冲区的位置设置为复制的int数，而不是为零，因此可以通过调用另一个相对put方法来立即调用此方法。

        结果
        这个缓冲区
        异常
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • isDirect

        public abstract boolean isDirect​()
        告诉这个int缓冲区是否直接。
        Specified by:
        isDirect在 Buffer
        结果
        true如果，并且只有这个缓冲区是直接的

      • toString

        public String toString​()
        返回一个汇总此缓冲区状态的字符串。
        重写：
        toString在 Object
        结果
        摘要字符串

      • hashCode

        public int hashCode​()
        返回此缓冲区的当前哈希码。

        int缓冲区的哈希码仅取决于其剩余的元素; 也就是说，元素从position()直到并包括元素在limit() - 1 。

        因为缓冲区哈希码是内容依赖的，所以使用缓冲区作为哈希映射或类似数据结构中的密钥是不合适的，除非知道它们的内容不会改变。

        重写：
        hashCode在 Object
        结果
        这个缓冲区的当前哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        告诉这个缓冲区是否等于另一个对象。

        两个int缓冲区相等，如果只有

        1. 它们具有相同的元素类型，

        2. 他们有相同数量的剩余元素，和

        3. 独立于其起始位置的剩余元素的两个序列是相等的。

        int缓冲区不等于任何其他类型的对象。

        重写：
        equals在 Object
        参数
        ob - 要比较此缓冲区的对象
        结果
        true如果，且仅当此缓冲区等于给定对象时
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(IntBuffer that)
        将此缓冲区与另一个缓冲区进

        通过将字母顺序的剩余元素的序列进行比较来比较两个int缓冲区，而不考虑其相应缓冲区内每个序列的起始位置。 对int元素进行比较，仿佛通过调用Integer.compare(int,int) 。

        int缓冲区不能与任何其他类型的对象相媲美。

        Specified by:
        compareTo在接口 Comparable<IntBuffer>
        参数
        that - 要比较的对象。
        结果
        负整数，零或正整数，因为此缓冲区小于，等于或大于给定的缓冲区

      • order

        public abstract ByteOrder order​()
        检索此缓冲区的字节顺序。

        通过分配或通过包装现有的int阵列创建的int缓冲区的字节顺序是底层硬件的native order 。 创建为字节缓冲区的view的int缓冲区的字节顺序是创建视图时的字节缓冲区的字节顺序。

        结果
        这个缓冲区的字节顺序
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidMarkException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class InvalidMarkException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.InvalidMarkException
  • All Implemented Interfaces:
    Serializable

    public class InvalidMarkException
extends IllegalStateException
    当未定义其标记时尝试复位缓冲区时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidMarkException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidMarkException

        public InvalidMarkException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.nio (Java SE 9 & JDK 9 )

java.nio

Classes

  • Buffer
  • ByteBuffer
  • ByteOrder
  • CharBuffer
  • DoubleBuffer
  • FloatBuffer
  • IntBuffer
  • LongBuffer
  • MappedByteBuffer
  • ShortBuffer

Exceptions

  • BufferOverflowException
  • BufferUnderflowException
  • InvalidMarkException
  • ReadOnlyBufferException


java.nio (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.nio

定义缓冲区，它们是数据容器，并提供其他NIO包的概述。

NIO API的中心抽象是：

  • Buffers ，它们是数据的容器;

  • Charsets及其相关的解码器和编码器 ，
    它在字节和Unicode字符之间进行转换;

  • 各种类型的Channels ，代表连接
    能够执行I / O操作的实体; 和

  • 选择器和选择键 ，与
    可选择的渠道定义了一个multiplexed, non-blocking
    I/O    设施。

java.nio包定义了缓冲区类，这些缓冲区在整个NIO API中都被使用。 charset API在java.nio.charset包中定义，通道和选择器API在java.nio.channels包中定义。 这些子包中的每一个都有自己的服务提供商（SPI）子包，其内容可以用于扩展平台的默认实现或构建替代实现。

Description of the various buffers
Buffers | 描述
Buffer Position, limit, and capacity;
clear, flip, rewind, and mark/reset
ByteBuffer | Get/put, compact, views; allocate, wrap
MappedByteBuffer | A byte buffer mapped to a file
CharBuffer | Get/put, compact; allocate, wrap
DoubleBuffer ' '
FloatBuffer ' '
IntBuffer ' '
LongBuffer ' '
ShortBuffer ' '
ByteOrder | Typesafe enumeration for byte orders

缓冲区是用于固定数量的特定原始类型的数据的容器。 除了内容之外，缓冲区还有一个位置 ，它是要读取或写入的下一个元素的索引，以及一个限制 ，它是不应被读取或写入的第一个元素的索引。 基座Buffer类定义了这些属性以及用于清除 ， 翻转和倒带的方法 ，用于标记当前位置，并将位置重置为上一个标记。

每个非布尔基元类型都有一个缓冲区类。 每个类定义一组用于将数据移出和移入缓冲区的get和put方法，用于压缩 ， 复制和分割缓冲区的方法，以及用于分配新缓冲区以及将现有阵列包装到一个缓冲区中的静态方法缓冲。

字节缓冲区的区别在于它们可以用作I / O操作的源和目标。 它们还支持在其他缓冲区中找不到的几个功能：

  • 字节缓冲区可以分配为direct缓冲区，在这种情况下，Java虚拟机将尽力在其上直接执行本地I / O操作。

  • 字节缓冲区可以通过mapping文件的一个区域直接创建到内存中，在这种情况下， MappedByteBuffer类中定义的一些额外的文件相关操作是可用的。

  • 字节缓冲区可以访问其内容，作为任何非布尔基元类型的异或或同分序列binary data ，大码或小端byte order 。

除非另有说明，否则将null参数传递给此程序包中任何类或接口中的构造函数或方法将导致抛出27056945626382 。

从以下版本开始：
1.4
  • 类摘要
    Class 描述
    Buffer
    用于特定原始类型的数据的容器。
    ByteBuffer
    一个字节缓冲区。
    ByteOrder
    字节顺序的类型安全枚举。
    CharBuffer
    一个char缓冲区。
    DoubleBuffer
    双缓冲。
    FloatBuffer
    一个浮动缓冲区。
    IntBuffer
    一个int缓冲区
    LongBuffer
    一个长缓冲区。
    MappedByteBuffer
    直接字节缓冲器，其内容是文件的存储器映射区域。
    ShortBuffer
    一个短暂的缓冲。
  • 异常摘要
    异常 描述
    BufferOverflowException
    相对 放置操作达到目标缓冲区限制时抛出的未检查异常。
    BufferUnderflowException
    当相对 get操作达到源缓冲区的限制时抛出未检查的异常。
    InvalidMarkException
    当未定义其标记时尝试复位缓冲区时抛出未检查的异常。
    ReadOnlyBufferException
    在只读缓冲区中调用诸如 put或 compact类的内容突变方法时抛出的未检查异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.nio Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.nio

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.ByteBuffer (implements java.lang.Comparable<T>)
        • java.nio.MappedByteBuffer
      • java.nio.CharBuffer (implements java.lang.Appendable, java.lang.CharSequence, java.lang.Comparable<T>, java.lang.Readable)
      • java.nio.DoubleBuffer (implements java.lang.Comparable<T>)
      • java.nio.FloatBuffer (implements java.lang.Comparable<T>)
      • java.nio.IntBuffer (implements java.lang.Comparable<T>)
      • java.nio.LongBuffer (implements java.lang.Comparable<T>)
      • java.nio.ShortBuffer (implements java.lang.Comparable<T>)
    • java.nio.ByteOrder
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.nio.BufferOverflowException
          • java.nio.BufferUnderflowException
          • java.lang.IllegalStateException
            • java.nio.InvalidMarkException
          • java.lang.UnsupportedOperationException
            • java.nio.ReadOnlyBufferException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LongBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class LongBuffer

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.LongBuffer
  • All Implemented Interfaces:
    Comparable<LongBuffer>

    public abstract class LongBuffer
extends Buffer
implements Comparable<LongBuffer>
    一个长缓冲区。

    该类定义了长缓冲区中的四类操作：

    • 绝对和相对的get和put读取和写入单个长度的方法;

    • 相对bulk get方法将连续的长整序列从该缓冲区传输到数组中; 和

    • 相对bulk put方法，将长阵列或其他长缓冲区的连续序列传输到此缓冲区中; 和

    • 一种方法为compacting一个长缓冲区。

    长缓冲区可以由allocation创建，它为缓冲区的内容分配空间wrapping现有的长阵列到缓冲区中，或通过创建现有字节缓冲区的view 。

    像一个字节缓冲区一样，长缓冲区是direct or non-direct 。 通过wrap方法创建的长缓冲区将是非直接的。 作为字节缓冲区视图创建的长缓冲区将是直接的，只有当字节缓冲区本身是直接的。 长缓冲区是否直接可以通过调用isDirect方法来确定。

    指定此类中没有值返回值的方法返回调用它们的缓冲区。 这允许方法调用被链接。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static LongBuffer allocate​(int capacity)
      分配一个新的长缓冲区。
      long[] array​()
      返回支持此缓冲区的长数组 （可选操作） 。
      int arrayOffset​()
      返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
      abstract LongBuffer asReadOnlyBuffer​()
      创建一个新的只读长缓冲区，共享此缓冲区的内容。
      LongBuffer clear​()
      清除此缓冲区。
      abstract LongBuffer compact​()
      压缩此缓冲区 （可选操作） 。
      int compareTo​(LongBuffer that)
      将此缓冲区与另一个缓冲区进
      abstract LongBuffer duplicate​()
      创建一个新的长缓冲区，共享此缓冲区的内容。
      boolean equals​(Object ob)
      告诉这个缓冲区是否等于另一个对象。
      LongBuffer flip​()
      翻转这个缓冲区。
      abstract long get​()
      相对 获取方法。
      abstract long get​(int index)
      绝对 获取方法。
      LongBuffer get​(long[] dst)
      相对批量 获取方法。
      LongBuffer get​(long[] dst, int offset, int length)
      相对批量 获取方法。
      boolean hasArray​()
      告诉这个缓冲区是否由可访问的长阵列支持。
      int hashCode​()
      返回此缓冲区的当前哈希码。
      abstract boolean isDirect​()
      告诉这个长缓冲区是否直接。
      LongBuffer limit​(int newLimit)
      设置此缓冲区的限制。
      LongBuffer mark​()
      将此缓冲区的标记设置在其位置。
      abstract ByteOrder order​()
      检索此缓冲区的字节顺序。
      LongBuffer position​(int newPosition)
      设置这个缓冲区的位置。
      abstract LongBuffer put​(int index, long l)
      绝对 put方法 （可选操作） 。
      abstract LongBuffer put​(long l)
      相对 放置法 （可选操作） 。
      LongBuffer put​(long[] src)
      相对大容量 put方法 （可选操作） 。
      LongBuffer put​(long[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      LongBuffer put​(LongBuffer src)
      相对大容量 put方法 （可选操作） 。
      LongBuffer reset​()
      将此缓冲区的位置重置为先前标记的位置。
      LongBuffer rewind​()
      倒带这个缓冲区。
      abstract LongBuffer slice​()
      创建一个新的长缓冲区，其内容是此缓冲区内容的共享子序列。
      String toString​()
      返回一个汇总此缓冲区状态的字符串。
      static LongBuffer wrap​(long[] array)
      将长阵列包装到缓冲区中。
      static LongBuffer wrap​(long[] array, int offset, int length)
      将长阵列包装到缓冲区中。

      • Methods inherited from class java.nio.Buffer

        capacity, hasRemaining, isReadOnly, limit, position, remaining

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • allocate

        public static LongBuffer allocate​(int capacity)
        分配一个新的长缓冲区。

        新缓冲区的位置将为零，其限制将为其容量，其标记将不定义，其每个元素将被初始化为零，其字节顺序将为底层硬件的native order 。 它将有一个backing array ，其array offset将为零。

        参数
        capacity - 新的缓冲区的容量，在longs
        结果
        新的长缓冲区
        异常
        IllegalArgumentException - 如果 capacity是负整数

      • wrap

        public static LongBuffer wrap​(long[] array,
                              int offset,
                              int length)
        将长阵列包装到缓冲区中。

        新缓冲区将由给定的长阵列支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区的容量将为array.length ，其位置将为offset ，其限制将为offset + length ，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回新缓冲区的数组
        offset - 要使用的子阵列的偏移量; 必须是非负数，不得大于array.length 。 新缓冲区的位置将被设置为此值。
        length - 要使用的子阵列的长度; 必须是非负数，不得大于array.length - offset 。 新缓冲区的限制将设置为offset + length 。
        结果
        新的长缓冲区
        异常
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • wrap

        public static LongBuffer wrap​(long[] array)
        将长阵列包装到缓冲区中。

        新缓冲区将由给定的长阵列支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区的容量和限制将为array.length ，其位置将为零，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回此缓冲区的数组
        结果
        新的长缓冲区

      • slice

        public abstract LongBuffer slice​()
        创建一个新的长缓冲区，其内容是此缓冲区内容的共享子序列。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是此缓冲区中剩余的长度数，其标记将不定义，并且其字节顺序将与该缓冲区的字节顺序相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        slice在 Buffer
        结果
        新的长缓冲区

      • duplicate

        public abstract LongBuffer duplicate​()
        创建一个新的长缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        duplicate在 Buffer
        结果
        新的长缓冲区

      • asReadOnlyBuffer

        public abstract LongBuffer asReadOnlyBuffer​()
        创建一个新的只读长缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 这个缓冲区内容的更改将在新的缓冲区中显示; 但是，新的缓冲区本身将是只读的，不允许修改共享内容。 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。

        如果这个缓冲区本身是只读的，那么这个方法的行为与duplicate的方法完全相同。

        结果
        新的只读长缓冲区

      • get

        public abstract long get​()
        相对获取方法。 读取这个缓冲区当前位置的长度，然后增加位置。
        结果
        在缓冲区的当前位置很长
        异常
        BufferUnderflowException - 如果缓冲区的当前位置不小于其限制

      • put

        public abstract LongBuffer put​(long l)
        相对放置法（可选操作） 。

        将给定的长时间写入当前位置的缓冲区，然后增加位置。

        参数
        l - 很久以前写的
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区的当前位置不小于其限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public abstract long get​(int index)
        绝对获取方法。 读取给定索引的长。
        参数
        index - 读取长的索引
        结果
        在指定的时间长
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制

      • put

        public abstract LongBuffer put​(int index,
                               long l)
        绝对put方法（可选操作） 。

        将给定的长度写入给定索引的缓冲区。

        参数
        index - 写入长的索引
        l - l的长的价值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • get

        public LongBuffer get​(long[] dst,
                      int offset,
                      int length)
        相对批量获取方法。

        该方法从这个缓冲区传递给给定的目标数组。 如果缓冲区中的剩余余数少于满足请求所需的length > ，即length > remaining() ，则不会传输长信息并抛出一个BufferUnderflowException 。

        否则，该方法将length从此缓冲区复制到给定的数组中，从该缓冲区的当前位置开始，并在数组中给定的偏移量。 此缓冲区的位置然后增加length 。

        换句话说，这种形式为src.get(dst, off, len)方法的调用与循环完全相同

           for (int i = off; i < off + len; i++) dst[i] = src.get():
        除了它首先检查这个缓冲区中是否有足够的长度，并且它可能更有效率。
        参数
        dst - 要写入longs的数组
        offset - 要写入的第一个long的数组内的偏移量; 必须是非负数，不得大于dst.length
        length - 要写入给定数组的最大length数; 必须是非负数，不得大于dst.length - offset
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的数字少于 length
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • get

        public LongBuffer get​(long[] dst)
        相对批量获取方法。

        该方法从这个缓冲区传递给给定的目标数组。 对这种src.get(a)形式的方法的调用与调用的方式完全相同

          src.get(a, 0, a.length)
        参数
        dst - 目的地阵列
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的长度少于 length

      • put

        public LongBuffer put​(LongBuffer src)
        相对大容量put方法（可选操作） 。

        该方法将给定源缓冲区中的剩余长度传输到此缓冲区。 如果源缓冲区中剩余的长度比此缓冲区多，即src.remaining() > remaining() ，则不传输长信号并抛出BufferOverflowException 。

        否则，该方法将n = src.remaining()从给定缓冲区的src.remaining()复制到此缓冲区，从每个缓冲区的当前位置开始。 然后将两个缓冲器的位置递增n 。

        换句话说，这种形式为dst.put(src)方法的调用与dst.put(src)具有完全相同的效果

          while (src.hasRemaining())
         dst.put(src.get());
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取长src的源缓冲区; 不能是这个缓冲区
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果该缓冲区中的剩余长度在源缓冲区中没有足够的空间
        IllegalArgumentException - 如果源缓冲区是这个缓冲区
        ReadOnlyBufferException - 如果此缓冲区为只读

      • put

        public LongBuffer put​(long[] src,
                      int offset,
                      int length)
        相对大容量put方法（可选操作） 。

        该方法从给定的源数组传输到这个缓冲区。 如果从数组中复制的数量多于保留在此缓冲区中的长度，即length > remaining() ，则不会传输长信息并抛出BufferOverflowException 。

        否则，该方法将length从给定的数组复制到此缓冲区中，从阵列中的给定偏移量和此缓冲区的当前位置开始。 此缓冲区的位置然后增加length 。

        换句话说，这种形式为dst.put(src, off, len)方法的调用与dst.put(src, off, len)具有完全相同的效果

           for (int i = off; i < off + len; i++) dst.put(a[i]);
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取longs的数组
        offset - 要读取的第一个长度的数组内的偏移量; 必须是非负数，不得大于array.length
        length - 从给定数组读取的length数; 必须是非负数，不得大于array.length - offset
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public final LongBuffer put​(long[] src)
        相对大容量put方法（可选操作） 。

        此方法将给定源长数组的整个内容传输到此缓冲区。 这种dst.put(a)形式的方法的调用与调用的方式完全相同

          dst.put(a, 0, a.length)
        参数
        src - 源数组
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区空间不足
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • hasArray

        public final boolean hasArray​()
        告诉这个缓冲区是否由可访问的长阵列支持。

        如果此方法返回true则可以安全地调用array和arrayOffset方法。

        Specified by:
        hasArray在 Buffer
        结果
        true如果，且仅当此缓冲区由数组支持并且不是只读

      • array

        public final long[] array​()
        返回支持此缓冲区的长数组（可选操作） 。

        对此缓冲区内容的修改将导致返回的数组的内容被修改，反之亦然。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        array在 Buffer
        结果
        支持这个缓冲区的数组
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • arrayOffset

        public final int arrayOffset​()
        返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量（可选操作） 。

        如果此缓冲区由数组支持，则缓冲区p对应于数组索引p + arrayOffset() 。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        arrayOffset在 Buffer
        结果
        缓冲区的第一个元素的缓冲区数组中的偏移量
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • position

        public final LongBuffer position​(int newPosition)
        设置这个缓冲区的位置。 如果标记被定义并且大于新位置，则它被丢弃。
        重写：
        position在 Buffer
        参数
        newPosition - 新位置值; 必须是非负数，不得大于当前限制
        结果
        这个缓冲区

      • limit

        public final LongBuffer limit​(int newLimit)
        设置此缓冲区的限制。 如果位置大于新的限制，那么它被设置为新的限制。 如果标记被定义并且大于新限制，则它被丢弃。
        重写：
        limit在 Buffer
        参数
        newLimit - 新限制值 必须是非负数，不大于此缓冲区的容量
        结果
        这个缓冲区

      • mark

        public final LongBuffer mark​()
        将此缓冲区的标记设置在其位置。
        重写：
        mark在 Buffer
        结果
        这个缓冲区

      • reset

        public final LongBuffer reset​()
        将此缓冲区的位置重置为先前标记的位置。

        调用此方法既不会更改也不丢弃该标记的值。

        重写：
        reset在 Buffer
        结果
        这个缓冲区

      • clear

        public final LongBuffer clear​()
        清除此缓冲区。 位置设置为零，限制设置为容量，标记被丢弃。

        在使用一系列通道读取或放置操作填充此缓冲区之前调用此方法。 例如：

         buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

        该方法实际上并不会清除缓冲区中的数据，而是将其命名为它的确因为它最常用于情况也是如此。

        重写：
        clear在 Buffer
        结果
        这个缓冲区

      • flip

        public final LongBuffer flip​()
        翻转这个缓冲区。 该限制设置为当前位置，然后将该位置设置为零。 如果标记被定义，则它被丢弃。

        在通道读取或放置操作的序列之后，调用此方法来准备一系列通道写入或相对获取操作。 例如：

         buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

        当将数据从一个地方传输到另一个地址时，该方法通常与compact方法结合使用。

        重写：
        flip在 Buffer
        结果
        这个缓冲区

      • rewind

        public final LongBuffer rewind​()
        倒带这个缓冲区。 位置设置为零，标记被丢弃。

        在通道写入或获取操作的序列之前调用此方法，假设已经设置了相应的限制。 例如：

         out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array
        重写：
        rewind在 Buffer
        结果
        这个缓冲区

      • compact

        public abstract LongBuffer compact​()
        压缩此缓冲区（可选操作） 。

        缓冲区当前位置和其限制（如果有的话）之间的长度将被复制到缓冲区的开头。 也就是说，索引p = position()索引被复制到索引零，索引p + 1的长度被复制到索引1，等等，直到索引limit()被复制到索引n = limit() - 1 - p 。 然后将缓冲区的位置设置为n + 1，并将其限制设置为其容量。 标记如果被定义，则被丢弃。

        缓冲区的位置设置为复制的长度数，而不是为零，因此可以通过调用另一个相对put方法立即跟踪此方法的调用。

        结果
        这个缓冲区
        异常
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • isDirect

        public abstract boolean isDirect​()
        告诉这个长缓冲区是否直接。
        Specified by:
        isDirect在 Buffer
        结果
        true如果，并且只有这个缓冲区是直接的

      • toString

        public String toString​()
        返回一个汇总此缓冲区状态的字符串。
        重写：
        toString在 Object
        结果
        摘要字符串

      • hashCode

        public int hashCode​()
        返回此缓冲区的当前哈希码。

        长缓冲区的哈希码仅取决于其剩余的元素; 也就是说，元素从position()到，并包括元素在limit() - 1 。

        因为缓冲区哈希码是内容依赖的，所以使用缓冲区作为哈希映射或类似数据结构中的密钥是不合适的，除非知道它们的内容不会改变。

        重写：
        hashCode在 Object
        结果
        这个缓冲区的当前哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        告诉这个缓冲区是否等于另一个对象。

        两个长缓冲区是相等的，只有，

        1. 它们具有相同的元素类型，

        2. 他们有相同数量的剩余元素，和

        3. 独立于其起始位置的剩余元素的两个序列是相等的。

        长缓冲区不等于任何其他类型的对象。

        重写：
        equals在 Object
        参数
        ob - 要比较此缓冲区的对象
        结果
        true如果，且仅当此缓冲区等于给定对象时
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(LongBuffer that)
        将此缓冲区与另一个缓冲区进

        将两个长的缓冲区进行比较，比较其顺序的剩余元素的词典，而不考虑每个序列的起始位置在其相应的缓冲区内。 对long元素进行比较，仿佛通过调用Long.compare(long,long) 。

        长缓冲区与任何其他类型的对象无法比较。

        Specified by:
        compareTo在接口 Comparable<LongBuffer>
        参数
        that - 要比较的对象。
        结果
        负整数，零或正整数，因为此缓冲区小于，等于或大于给定的缓冲区

      • order

        public abstract ByteOrder order​()
        检索此缓冲区的字节顺序。

        通过分配或通过包装现有的long阵列创建的长缓冲区的字节顺序是底层硬件的native order 。 作为字节缓冲区的view创建的长缓冲区的字节顺序是创建视图时的字节缓冲区的字节顺序。

        结果
        这个缓冲区的字节顺序
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MappedByteBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class MappedByteBuffer

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.ByteBuffer
        • java.nio.MappedByteBuffer
  • All Implemented Interfaces:
    Comparable<ByteBuffer>

    public abstract class MappedByteBuffer
extends ByteBuffer
    直接字节缓冲器，其内容是文件的存储器映射区域。

    映射的字节缓冲区是通过FileChannel.map方法创建的。 该类使用特定于内存映射文件区域的操作来扩展ByteBuffer类。

    映射字节缓冲区及其表示的文件映射在缓冲区本身被垃圾回收之前保持有效。

    映射字节缓冲区的内容可以随时更改，例如，如果该程序或其他映射文件的对应区域的内容被更改。 这种变化是否发生，何时发生，是操作系统依赖的，因此是未指定的。

    映射字节缓冲区的全部或部分可能在任何时候变得无法访问，例如映射文件被截断。 访问映射字节缓冲区的不可访问区域的尝试不会更改缓冲区的内容，并将导致在访问时或稍后的时候抛出未指定的异常。 因此，强烈建议您采取适当的预防措施，以避免该程序或同时运行的程序对映射文件进行操作，但读取或写入文件的内容除外。

    映射的字节缓冲区的行为与普通的直接字节缓冲区不同。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MappedByteBuffer clear​()
      清除此缓冲区。
      MappedByteBuffer flip​()
      翻转这个缓冲区。
      MappedByteBuffer force​()
      强制将此缓冲区内容的任何更改写入包含映射文件的存储设备。
      boolean isLoaded​()
      告诉这个缓冲区的内容是否驻留在物理内存中。
      MappedByteBuffer limit​(int newLimit)
      设置此缓冲区的限制。
      MappedByteBuffer load​()
      将此缓冲区的内容加载到物理内存中。
      MappedByteBuffer mark​()
      将此缓冲区的标记设置在其位置。
      MappedByteBuffer position​(int newPosition)
      设置这个缓冲区的位置。
      MappedByteBuffer reset​()
      将此缓冲区的位置重置为先前标记的位置。
      MappedByteBuffer rewind​()
      倒带这个缓冲区。

      • Methods inherited from class java.nio.Buffer

        capacity, hasRemaining, isReadOnly, limit, position, remaining

      • Methods inherited from class java.nio.ByteBuffer

        alignedSlice, alignmentOffset, allocate, allocateDirect, array, arrayOffset, asCharBuffer, asDoubleBuffer, asFloatBuffer, asIntBuffer, asLongBuffer, asReadOnlyBuffer, asShortBuffer, compact, compareTo, duplicate, equals, get, get, get, get, getChar, getChar, getDouble, getDouble, getFloat, getFloat, getInt, getInt, getLong, getLong, getShort, getShort, hasArray, hashCode, isDirect, order, order, put, put, put, put, put, putChar, putChar, putDouble, putDouble, putFloat, putFloat, putInt, putInt, putLong, putLong, putShort, putShort, slice, toString, wrap, wrap

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • isLoaded

        public final boolean isLoaded​()
        告诉这个缓冲区的内容是否驻留在物理内存中。

        返回值为true意味着该缓冲区中的所有数据很可能驻留在物理内存中，因此可能会被访问，而不会导致任何虚拟内存页面错误或I / O操作。 返回值为false不一定意味着缓冲区的内容不驻留在物理内存中。

        返回的值是一个提示，而不是一个保证，因为底层操作系统可能会在调用此方法时返回一些缓冲区的数据。

        结果
        true如果这个缓冲区的内容很可能驻留在物理内存中

      • load

        public final MappedByteBuffer load​()
        将此缓冲区的内容加载到物理内存中。

        这种方法尽最大努力确保当它返回时，该缓冲区的内容驻留在物理内存中。 调用此方法可能会导致一些页面错误和I / O操作发生。

        结果
        这个缓冲区

      • force

        public final MappedByteBuffer force​()
        强制将此缓冲区内容的任何更改写入包含映射文件的存储设备。

        如果映射到此缓冲区的文件驻留在本地存储设备上，那么当此方法返回时，将保证自从创建缓冲区以来所做的所有更改，或自上次调用该方法后，都将被写入该设备。

        如果文件不在本地设备上，则不会提供此类保证。

        如果此缓冲区未以读/写模式映射（ FileChannel.MapMode.READ_WRITE ），则调用此方法将不起作用。

        结果
        这个缓冲区

      • position

        public final MappedByteBuffer position​(int newPosition)
        设置这个缓冲区的位置。 如果标记被定义并且大于新位置，则它被丢弃。
        重写：
        position在 ByteBuffer
        参数
        newPosition - 新的位置值 必须是非负数，不得大于当前限制
        结果
        这个缓冲区

      • limit

        public final MappedByteBuffer limit​(int newLimit)
        设置此缓冲区的限制。 如果位置大于新的限制，那么它被设置为新的限制。 如果标记被定义并且大于新限制，则它被丢弃。
        重写：
        limit在 ByteBuffer
        参数
        newLimit - 新限制值; 必须是非负数，不大于此缓冲区的容量
        结果
        这个缓冲区

      • mark

        public final MappedByteBuffer mark​()
        将此缓冲区的标记设置在其位置。
        重写：
        mark在 ByteBuffer
        结果
        这个缓冲区

      • reset

        public final MappedByteBuffer reset​()
        将此缓冲区的位置重置为先前标记的位置。

        调用此方法既不会更改也不丢弃该标记的值。

        重写：
        reset在 ByteBuffer
        结果
        这个缓冲区

      • clear

        public final MappedByteBuffer clear​()
        清除此缓冲区。 位置设置为零，限制设置为容量，标记被丢弃。

        在使用一系列通道读取或放置操作填充此缓冲区之前调用此方法。 例如：

         buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

        该方法实际上并不会清除缓冲区中的数据，而是将其命名为它的确因为它最常用于情况也是如此。

        重写：
        clear在 ByteBuffer
        结果
        这个缓冲区

      • flip

        public final MappedByteBuffer flip​()
        翻转这个缓冲区。 该限制设置为当前位置，然后将该位置设置为零。 如果标记被定义，则它被丢弃。

        在通道读取或放置操作的序列之后，调用此方法来准备一系列通道写入或相对获取操作。 例如：

         buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

        当将数据从一个地方传输到另一个地址时，该方法通常与compact方法结合使用。

        重写：
        flip在 ByteBuffer
        结果
        这个缓冲区

      • rewind

        public final MappedByteBuffer rewind​()
        倒带这个缓冲区。 位置设置为零，标记被丢弃。

        在通道写入或获取操作的序列之前调用此方法，假设已经设置了相应的限制。 例如：

         out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array
        重写：
        rewind在 ByteBuffer
        结果
        这个缓冲区
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyBufferException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class ReadOnlyBufferException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.UnsupportedOperationException
            • java.nio.ReadOnlyBufferException
  • All Implemented Interfaces:
    Serializable

    public class ReadOnlyBufferException
extends UnsupportedOperationException
    在只读缓冲区中调用诸如 put或 compact类的内容突变方法时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyBufferException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ReadOnlyBufferException

        public ReadOnlyBufferException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ShortBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio

Class ShortBuffer

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.ShortBuffer
  • All Implemented Interfaces:
    Comparable<ShortBuffer>

    public abstract class ShortBuffer
extends Buffer
implements Comparable<ShortBuffer>
    一个短暂的缓冲。

    此类定义了缓冲区中的四类操作：

    • 绝对和相对的get和put读写单个短裤的方法;

    • 相对bulk get方法将连续的短片序列从该缓冲区传送到数组中; 和

    • 相对的bulk put方法，将短阵列的连续序列或一些其他短缓冲区传输到该缓冲区中; 和

    • 一个compacting一个短缓冲区的方法。

    短缓冲区可以由allocation创建，它为缓冲区的内容分配空间wrapping现有的短阵列到缓冲区中，或通过创建现有字节缓冲区的view 。

    像一个字节缓冲区一样，一个短缓冲区是direct or non-direct 。 通过wrap方法创建的缓冲区将是非直接的。 作为字节缓冲区视图创建的短缓冲区将是直接的，只有当字节缓冲区本身是直接的。 短缓冲区是否直接可以通过调用isDirect方法来确定。

    指定此类中没有值返回值的方法返回调用它们的缓冲区。 这允许方法调用被链接。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static ShortBuffer allocate​(int capacity)
      分配一个新的缓冲区。
      short[] array​()
      返回支持此缓冲区的短数组 （可选操作） 。
      int arrayOffset​()
      返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
      abstract ShortBuffer asReadOnlyBuffer​()
      创建一个新的只读缓冲区，共享此缓冲区的内容。
      ShortBuffer clear​()
      清除此缓冲区。
      abstract ShortBuffer compact​()
      压缩此缓冲区 （可选操作） 。
      int compareTo​(ShortBuffer that)
      将此缓冲区与另一个缓冲区进
      abstract ShortBuffer duplicate​()
      创建一个新的缓冲区，共享此缓冲区的内容。
      boolean equals​(Object ob)
      告诉这个缓冲区是否等于另一个对象。
      ShortBuffer flip​()
      翻转这个缓冲区。
      abstract short get​()
      相对 获取方法。
      abstract short get​(int index)
      绝对 获取方法。
      ShortBuffer get​(short[] dst)
      相对批量 获取方法。
      ShortBuffer get​(short[] dst, int offset, int length)
      相对批量 获取方法。
      boolean hasArray​()
      告诉这个缓冲区是否由可访问的短阵列支持。
      int hashCode​()
      返回此缓冲区的当前哈希码。
      abstract boolean isDirect​()
      告诉这个短缓冲区是否直接。
      ShortBuffer limit​(int newLimit)
      设置此缓冲区的限制。
      ShortBuffer mark​()
      将此缓冲区的标记设置在其位置。
      abstract ByteOrder order​()
      检索此缓冲区的字节顺序。
      ShortBuffer position​(int newPosition)
      设置这个缓冲区的位置。
      abstract ShortBuffer put​(int index, short s)
      绝对 put方法 （可选操作） 。
      abstract ShortBuffer put​(short s)
      相对 放置法 （可选操作） 。
      ShortBuffer put​(short[] src)
      相对大容量 put方法 （可选操作） 。
      ShortBuffer put​(short[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      ShortBuffer put​(ShortBuffer src)
      相对大容量 put方法 （可选操作） 。
      ShortBuffer reset​()
      将此缓冲区的位置重置为先前标记的位置。
      ShortBuffer rewind​()
      倒带这个缓冲区。
      abstract ShortBuffer slice​()
      创建一个新的短缓冲区，其内容是此缓冲区内容的共享子序列。
      String toString​()
      返回一个汇总此缓冲区状态的字符串。
      static ShortBuffer wrap​(short[] array)
      将一个短阵列包装到缓冲区中。
      static ShortBuffer wrap​(short[] array, int offset, int length)
      将一个短阵列包装到缓冲区中。

      • Methods inherited from class java.nio.Buffer

        capacity, hasRemaining, isReadOnly, limit, position, remaining

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • allocate

        public static ShortBuffer allocate​(int capacity)
        分配一个新的缓冲区。

        新缓冲区的位置将为零，其限制将为其容量，其标记将不定义，其每个元素将被初始化为零，其字节顺序将为底层硬件的native order 。 它将有一个backing array ，其array offset将为零。

        参数
        capacity - 新的缓冲区的容量，短裤
        结果
        新的缓冲区
        异常
        IllegalArgumentException - 如果 capacity是负整数

      • wrap

        public static ShortBuffer wrap​(short[] array,
                               int offset,
                               int length)
        将一个短阵列包装到缓冲区中。

        新缓冲区将由给定的短阵列支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新的缓冲区的容量将为array.length ，其位置将为offset ，其限制将为offset + length ，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回新缓冲区的数组
        offset - 要使用的子阵列的偏移量; 必须是非负数，不得大于array.length 。 新缓冲区的位置将被设置为此值。
        length - 要使用的子阵列的长度; 必须是非负数，不得大于array.length - offset 。 新缓冲区的限制将设置为offset + length 。
        结果
        新的缓冲区
        异常
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • wrap

        public static ShortBuffer wrap​(short[] array)
        将一个短阵列包装到缓冲区中。

        新缓冲区将由给定的短阵列支持; 也就是说，对缓冲区的修改将导致数组被修改，反之亦然。 新缓冲区的容量和限制将为array.length ，其位置将为零，其标记将不定义，其字节顺序将为底层硬件的native order 。 其backing array将是给定的数组，其array offset将为零。

        参数
        array - 将返回此缓冲区的数组
        结果
        新的缓冲区

      • slice

        public abstract ShortBuffer slice​()
        创建一个新的短缓冲区，其内容是此缓冲区内容的共享子序列。

        新缓冲区的内容将从此缓冲区的当前位置开始。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的位置将为零，其容量和限制将是此缓冲区中剩余的短路数，其标记将不定义，并且其字节顺序将与此缓冲区的字节顺序相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        slice在 Buffer
        结果
        新的缓冲区

      • duplicate

        public abstract ShortBuffer duplicate​()
        创建一个新的缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 对这个缓冲区内容的更改将在新的缓冲区中可见，反之亦然; 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。 如果只有这个缓冲区是直接的，并且只有当这个缓冲区是只读的时，这个缓冲区将是只读的。

        Specified by:
        duplicate在 Buffer
        结果
        新的缓冲区

      • asReadOnlyBuffer

        public abstract ShortBuffer asReadOnlyBuffer​()
        创建一个新的只读缓冲区，共享此缓冲区的内容。

        新缓冲区的内容将是这个缓冲区的内容。 这个缓冲区内容的更改将在新的缓冲区中显示; 但是，新的缓冲区本身将是只读的，不允许修改共享内容。 两个缓冲区的位置，极限和标记值将是独立的。

        新缓冲区的容量，限制，位置，标记值和字节顺序将与此缓冲区的容量相同。

        如果这个缓冲区本身是只读的，那么这个方法的行为与duplicate的方法完全相同。

        结果
        新的只读缓冲区

      • get

        public abstract short get​()
        相对获取方法。 读取该缓冲区当前位置的短路，然后增加位置。
        结果
        缓冲区当前位置的短路
        异常
        BufferUnderflowException - 如果缓冲区的当前位置不小于其限制

      • put

        public abstract ShortBuffer put​(short s)
        相对放置法（可选操作） 。

        将给定的短文写入当前位置的缓冲区，然后增加位置。

        参数
        s - s的短
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区的当前位置不小于其限制
        ReadOnlyBufferException - 如果此缓冲区为只读

      • get

        public abstract short get​(int index)
        绝对获取方法。 读取给定索引的短。
        参数
        index - 将从中读取短的索引
        结果
        给定指数的短线
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制

      • put

        public abstract ShortBuffer put​(int index,
                                short s)
        绝对put方法（可选操作） 。

        将给定的短文写入给定索引的缓冲区。

        参数
        index - 短信将被写入的指数
        s - s的短价值
        结果
        这个缓冲区
        异常
        IndexOutOfBoundsException - 如果 index为负数或不小于缓冲区限制
        ReadOnlyBufferException - 如果这个缓冲区是只读的

      • get

        public ShortBuffer get​(short[] dst,
                       int offset,
                       int length)
        相对批量获取方法。

        此方法将此缓冲区的短路传输到给定的目标数组。 如果缓冲区中剩余的短路比满足请求所需的短路短，即length > remaining() ，则不会传输短路，并抛出BufferUnderflowException 。

        否则，此方法将length短片从此缓冲区复制到给定的数组中，从该缓冲区的当前位置开始，并在数组中给定的偏移量。 此缓冲区的位置然后增加length 。

        换句话说，这种形式为src.get(dst, off, len)方法的调用与src.get(dst, off, len)具有完全相同的效果

           for (int i = off; i < off + len; i++) dst[i] = src.get():
        除了它首先检查这个缓冲区中是否有足够的短路，并且它可能更有效率。
        参数
        dst - 要写入短片的数组
        offset - 要写入的第一个短的数组中的偏移量; 必须是非负数，不得大于dst.length
        length - 要写入给定数组的最大短路数; 必须是非负数，不得大于dst.length - offset
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余的短路数少于 length
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立

      • get

        public ShortBuffer get​(short[] dst)
        相对批量获取方法。

        此方法将此缓冲区的短路传输到给定的目标数组。 这种src.get(a)形式的方法的调用与调用的方式完全相同

          src.get(a, 0, a.length)
        参数
        dst - 目的地阵列
        结果
        这个缓冲区
        异常
        BufferUnderflowException - 如果此缓冲区中剩余少于 length短裤

      • put

        public ShortBuffer put​(ShortBuffer src)
        相对大容量put方法（可选操作） 。

        此方法将给定源缓冲区中剩余的短路传输到此缓冲区。 如果源缓冲区中存在比在此缓冲区中更多的短路，也就是说，如果src.remaining() > remaining() ，则不传输短路，并抛出BufferOverflowException 。

        否则，该方法将n = src.remaining()从给定缓冲区中的短裤复制到此缓冲区中，从每个缓冲区的当前位置开始。 然后将两个缓冲器的位置递增n 。

        换句话说，这种形式为dst.put(src)方法的调用与dst.put(src)具有完全相同的效果

          while (src.hasRemaining())
         dst.put(src.get());
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取src的源缓冲区; 不能是这个缓冲区
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果缓冲区中的剩余短路在源缓冲区中没有足够的空间
        IllegalArgumentException - 如果源缓冲区是这个缓冲区
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public ShortBuffer put​(short[] src,
                       int offset,
                       int length)
        相对大容量put方法（可选操作） 。

        此方法从给定的源数据库将短路传输到此缓冲区。 如果从数组中复制的数据多于保留在此缓冲区中的length ，即length > remaining() ，则不会传输短信，并抛出BufferOverflowException 。

        否则，该方法将length从给定的数组中的短裤复制到此缓冲区中，从阵列中的给定偏移量和此缓冲区的当前位置开始。 然后将该缓冲区的位置增加length 。

        换句话说，这种形式为dst.put(src, off, len)方法的调用与dst.put(src, off, len)具有完全相同的效果

           for (int i = off; i < off + len; i++) dst.put(a[i]);
        除了它首先检查这个缓冲区中是否有足够的空间，并且它可能更有效率。
        参数
        src - 要读取短片的数组
        offset - 要读取的第一个short的数组内的偏移量; 必须是非负数，不得大于array.length
        length - 从给定数组读取的短裤数量; 必须是非负数，不得大于array.length - offset
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • put

        public final ShortBuffer put​(short[] src)
        相对大容量put方法（可选操作） 。

        此方法将给定源短数组的整个内容传输到此缓冲区。 这种dst.put(a)形式的方法的调用与调用的方式完全相同

          dst.put(a, 0, a.length)
        参数
        src - 源数组
        结果
        这个缓冲区
        异常
        BufferOverflowException - 如果此缓冲区中没有足够的空间
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • hasArray

        public final boolean hasArray​()
        告诉这个缓冲区是否由可访问的短阵列支持。

        如果此方法返回true则可以安全地调用array和arrayOffset方法。

        Specified by:
        hasArray在 Buffer
        结果
        true如果且仅当此缓冲区由数组支持且不是只读

      • array

        public final short[] array​()
        返回支持此缓冲区的短数组（可选操作） 。

        对此缓冲区内容的修改将导致返回的数组的内容被修改，反之亦然。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        array在 Buffer
        结果
        支持这个缓冲区的数组
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区未由可访问阵列支持

      • arrayOffset

        public final int arrayOffset​()
        返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量（可选操作） 。

        如果此缓冲区由数组支持，则缓冲区位置p对应于数组索引p + arrayOffset() 。

        在调用此方法之前调用hasArray方法，以确保此缓冲区具有可访问的后台阵列。

        Specified by:
        arrayOffset在 Buffer
        结果
        缓冲区的第一个元素的缓冲区数组中的偏移量
        异常
        ReadOnlyBufferException - 如果此缓冲区由数组支持但是只读
        UnsupportedOperationException - 如果此缓冲区不由可访问阵列支持

      • position

        public final ShortBuffer position​(int newPosition)
        设置这个缓冲区的位置。 如果标记被定义并且大于新位置，则它被丢弃。
        重写：
        position在 Buffer
        参数
        newPosition - 新的位置值; 必须是非负数，不得大于当前限制
        结果
        这个缓冲区

      • limit

        public final ShortBuffer limit​(int newLimit)
        设置此缓冲区的限制。 如果位置大于新的限制，那么它被设置为新的限制。 如果标记被定义并且大于新限制，则它被丢弃。
        重写：
        limit在 Buffer
        参数
        newLimit - 新限制值 必须是非负数，不大于此缓冲区的容量
        结果
        这个缓冲区

      • mark

        public final ShortBuffer mark​()
        将此缓冲区的标记设置在其位置。
        重写：
        mark中的 Buffer
        结果
        这个缓冲区

      • reset

        public final ShortBuffer reset​()
        将此缓冲区的位置重置为先前标记的位置。

        调用此方法既不会更改也不丢弃该标记的值。

        重写：
        reset在 Buffer
        结果
        这个缓冲区

      • clear

        public final ShortBuffer clear​()
        清除此缓冲区。 位置设置为零，限制设置为容量，标记被丢弃。

        在使用一系列通道读取或放置操作填充此缓冲区之前调用此方法。 例如：

         buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

        该方法实际上并不会清除缓冲区中的数据，而是将其命名为它的确因为它最常用于情况也是如此。

        重写：
        clear在 Buffer
        结果
        这个缓冲区

      • flip

        public final ShortBuffer flip​()
        翻转这个缓冲区。 该限制设置为当前位置，然后将该位置设置为零。 如果标记被定义，则它被丢弃。

        在通道读取或放置操作的序列之后，调用此方法来准备一系列通道写入或相对获取操作。 例如：

         buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

        当将数据从一个地方传输到另一个地址时，该方法通常与compact方法结合使用。

        重写：
        flip在 Buffer
        结果
        这个缓冲区

      • rewind

        public final ShortBuffer rewind​()
        倒带这个缓冲区。 位置设置为零，标记被丢弃。

        在通道写入或获取操作的序列之前调用此方法，假设已经设置了相应的限制。 例如：

         out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array
        重写：
        rewind在 Buffer
        结果
        这个缓冲区

      • compact

        public abstract ShortBuffer compact​()
        压缩此缓冲区（可选操作） 。

        缓冲区当前位置与其限制（如果有的话）之间的短路将被复制到缓冲区的开头。 即，短于索引p = position()复制到索引零，短于索引p + 1被复制到索引1，依此类推，直到短的索引limit() - 1被复制到索引n = limit() - 1 - p 。 然后将缓冲区的位置设置为n + 1，并将其限制设置为其容量。 标记如果被定义，则被丢弃。

        缓冲区的位置设置为复制的短路数，而不是零，因此可以通过调用另一个相对put方法来立即调用此方法。

        结果
        这个缓冲区
        异常
        ReadOnlyBufferException - 如果此缓冲区是只读的

      • isDirect

        public abstract boolean isDirect​()
        告诉这个短缓冲区是否直接。
        Specified by:
        isDirect在 Buffer
        结果
        true如果，只有这个缓冲区是直接的

      • toString

        public String toString​()
        返回一个汇总此缓冲区状态的字符串。
        重写：
        toString在 Object
        结果
        摘要字符串

      • hashCode

        public int hashCode​()
        返回此缓冲区的当前哈希码。

        短缓冲区的哈希码仅取决于其剩余的元素; 也就是说，元素从position()到，包括元素在limit() - 1 。

        因为缓冲区哈希码是内容依赖的，所以使用缓冲区作为哈希映射或类似数据结构中的密钥是不合适的，除非知道它们的内容不会改变。

        重写：
        hashCode在 Object
        结果
        这个缓冲区的当前哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        告诉这个缓冲区是否等于另一个对象。

        两个短缓冲区是相等的，如果，只有这样，

        1. 它们具有相同的元素类型，

        2. 他们有相同数量的剩余元素，和

        3. 独立于其起始位置的剩余元素的两个序列是相等的。

        短暂的缓冲区不等于任何其他类型的对象。

        重写：
        equals在 Object
        参数
        ob - 要比较此缓冲区的对象
        结果
        true如果，并且只有这个缓冲区等于给定的对象
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(ShortBuffer that)
        将此缓冲区与另一个缓冲区进

        通过将词汇的剩余元素的序列进行比较来比较两个短的缓冲区，而不考虑其相应缓冲区内每个序列的起始位置。 对short元素进行比较，仿佛通过调用Short.compare(short,short) 。

        短暂的缓冲区与任何其他类型的对象都不相称。

        Specified by:
        compareTo在接口 Comparable<ShortBuffer>
        参数
        that - 要比较的对象。
        结果
        负整数，零或正整数，因为此缓冲区小于，等于或大于给定的缓冲区

      • order

        public abstract ByteOrder order​()
        检索此缓冲区的字节顺序。

        通过分配或通过包装现有的short阵列创建的短缓冲区的字节顺序是底层硬件的native order 。 作为字节缓冲区的view创建的短缓冲区的字节顺序是创建视图时的字节缓冲区的字节顺序。

        结果
        这个缓冲区的字节顺序
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.nio (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.nio

  • Packages that use java.nio
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.net.ssl
    为安全套接字包提供类。
    javax.smartcardio
    Java™智能卡I / O API
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方法。
  • Classes in java.nio used by com.sun.nio.sctp
    Class 描述
    ByteBuffer
    一个字节缓冲区。
  • Classes in java.nio used by java.io
    Class 描述
    CharBuffer
    一个char缓冲区。
  • Classes in java.nio used by java.lang
    Class 描述
    ByteBuffer
    一个字节缓冲区。
    CharBuffer
    一个char缓冲区。
  • Classes in java.nio used by java.lang.invoke
    Class 描述
    ByteOrder
    字节顺序的类型安全枚举。
  • Classes in java.nio used by java.lang.module
    Class 描述
    ByteBuffer
    一个字节缓冲区。
  • Classes in java.nio used by java.nio
    Class 描述
    Buffer
    用于特定原始类型的数据的容器。
    ByteBuffer
    一个字节缓冲区。
    ByteOrder
    字节顺序的类型安全枚举。
    CharBuffer
    一个char缓冲区。
    DoubleBuffer
    双缓冲。
    FloatBuffer
    一个浮动缓冲区。
    IntBuffer
    一个int缓冲区
    LongBuffer
    一个长缓冲区。
    MappedByteBuffer
    直接字节缓冲器，其内容是文件的存储器映射区域。
    ShortBuffer
    一个短暂的缓冲。
  • Classes in java.nio used by java.nio.channels
    Class 描述
    ByteBuffer
    一个字节缓冲区。
    MappedByteBuffer
    直接字节缓冲器，其内容是文件的存储器映射区域。
  • Classes in java.nio used by java.nio.charset
    Class 描述
    ByteBuffer
    一个字节缓冲区。
    CharBuffer
    一个char缓冲区。
  • Classes in java.nio used by java.nio.file.attribute
    Class 描述
    ByteBuffer
    一个字节缓冲区。
  • Classes in java.nio used by java.security
    Class 描述
    ByteBuffer
    一个字节缓冲区。
  • Classes in java.nio used by java.util
    Class 描述
    ByteBuffer
    一个字节缓冲区。
    LongBuffer
    一个长缓冲区。
  • Classes in java.nio used by java.util.zip
    Class 描述
    ByteBuffer
    一个字节缓冲区。
  • Classes in java.nio used by javafx.scene.image
    Class 描述
    Buffer
    用于特定原始类型的数据的容器。
    ByteBuffer
    一个字节缓冲区。
    IntBuffer
    一个int缓冲区
  • Classes in java.nio used by javax.crypto
    Class 描述
    ByteBuffer
    一个字节缓冲区。
  • Classes in java.nio used by javax.imageio.stream
    Class 描述
    ByteOrder
    字节顺序的类型安全枚举。
  • Classes in java.nio used by javax.net.ssl
    Class 描述
    ByteBuffer
    一个字节缓冲区。
  • Classes in java.nio used by javax.smartcardio
    Class 描述
    ByteBuffer
    一个字节缓冲区。
  • Classes in java.nio used by jdk.incubator.http
    Class 描述
    ByteBuffer
    一个字节缓冲区。
  • Classes in java.nio used by jdk.nashorn.api.scripting
    Class 描述
    ByteBuffer
    一个字节缓冲区。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AcceptPendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class AcceptPendingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.AcceptPendingException
  • All Implemented Interfaces:
    Serializable

    public class AcceptPendingException
extends IllegalStateException
    尝试在通道上启动接受操作并且以前的接受操作尚未完成时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AcceptPendingException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AcceptPendingException

        public AcceptPendingException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AlreadyBoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class AlreadyBoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.AlreadyBoundException
  • All Implemented Interfaces:
    Serializable

    public class AlreadyBoundException
extends IllegalStateException
    尝试将套接字绑定到已绑定的面向网络的通道时抛出未经检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AlreadyBoundException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AlreadyBoundException

        public AlreadyBoundException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AlreadyConnectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class AlreadyConnectedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.AlreadyConnectedException
  • All Implemented Interfaces:
    Serializable

    public class AlreadyConnectedException
extends IllegalStateException
    尝试连接已连接的SocketChannel时 ，会引发未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AlreadyConnectedException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AlreadyConnectedException

        public AlreadyConnectedException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AsynchronousByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface AsynchronousByteChannel

  • All Superinterfaces:
    AsynchronousChannel ， AutoCloseable ， Channel ， Closeable
    所有已知实现类：
    AsynchronousSocketChannel

    public interface AsynchronousByteChannel
extends AsynchronousChannel
    一个可以读写字节的异步通道。

    某些频道在任何给定的时间可能不允许多于一个读或写。 如果线程在先前的读取操作完成之前调用读取方法，那么将抛出一个ReadPendingException 。 类似地，如果在先前写入完成之前调用了写入方法，则抛出WritePendingException 。 其他类型的I / O操作是否可以与读取操作同时进行取决于通道的类型。

    请注意， ByteBuffers不适合多个并发线程使用。 当启动读或写操作时，必须注意确保在操作完成之前不访问缓冲区。

    从以下版本开始：
    1.7
    另请参见：
    Channels.newInputStream(AsynchronousByteChannel) ， Channels.newOutputStream(AsynchronousByteChannel)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Future<Integer> read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      <A> void read​(ByteBuffer dst, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      Future<Integer> write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      <A> void write​(ByteBuffer src, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向该通道写入一个字节序列。

      • Methods inherited from interface java.nio.channels.AsynchronousChannel

        close

      • Methods inherited from interface java.nio.channels.Channel

        isOpen

    • 方法详细信息

      • read

        <A> void read​(ByteBuffer dst,
              A attachment,
              CompletionHandler<Integer,? super A> handler)
        从该通道读取到给定缓冲区的字节序列。

        该方法启动异步读取操作，以从该通道读取到给定缓冲器中的字节序列。 handler参数是一个完成处理程序，在读取操作完成（或失败）时调用该处理程序。 传递给完成处理程序的结果是读取的字节数或-1如果没有字节可以读取，因为通道已达到流出尾。

        读取操作可以从通道读取r个字节，其中r是缓冲区中剩余的字节数，即尝试读取时的dst.remaining() 。 其中r为0，读操作立即完成，结果为0而不启动I / O操作。

        假设长度为n的字节序列被读取，其中0 < n <= r 。 该字节序列将被转移到缓冲器，使得序列中的第一个字节是在索引p和最后一个字节是在索引p + Ñ - 1 ，其中p为缓冲区的位置在执行读取的时刻。 完成后，缓冲区的位置将等于p + n ; 其限制将不会改变。

        缓冲区不能安全地被多个并发线程使用，因此在操作完成之前，请注意不要访问缓冲区。

        可以随时调用此方法。 某些渠道类型在任何给定时间可能不允许多于一个读取。 如果线程在先前的读取操作完成之前启动读取操作，那么将抛出一个ReadPendingException 。

        参数类型
        A - 附件的类型
        参数
        dst - 要传输字节的缓冲区
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 完成处理程序
        异常
        IllegalArgumentException - 如果缓冲区是只读的
        ReadPendingException - 如果通道不允许多个读取未完成，并且以前的读取尚未完成
        ShutdownChannelGroupException - 如果通道与已终止的group关联

      • read

        Future<Integer> read​(ByteBuffer dst)
        从该通道读取到给定缓冲区的字节序列。

        该方法启动异步读取操作，以从该通道读取到给定缓冲器中的字节序列。 该方法的行为方式与read(ByteBuffer,Object,CompletionHandler)方法完全相同，不同之处在于，该方法不是指定完成处理程序，而是返回表示待处理结果的Future 。 Future的get方法返回读取的字节数或-1如果没有字节可以读取，因为通道已经到达流终止。

        参数
        dst - 要传输字节的缓冲区
        结果
        代表操作结果的未来
        异常
        IllegalArgumentException - 如果缓冲区是只读的
        ReadPendingException - 如果通道不允许多个读取未完成，并且以前的读取尚未完成

      • write

        <A> void write​(ByteBuffer src,
               A attachment,
               CompletionHandler<Integer,? super A> handler)
        从给定的缓冲区向该通道写入一个字节序列。

        该方法启动异步写入操作，以从给定的缓冲区向该通道写入字节序列。 handler参数是在写操作完成（或失败）时调用的完成处理程序。 传递给完成处理程序的结果是写入的字节数。

        写入操作可以写入r字节到通道，其中r是缓冲区中剩余的字节数，即在尝试写入时的src.remaining() 。 其中r为0，写操作立即完成，结果为0而不启动I / O操作。

        假设写入长度为n的字节序列，其中0 < n <= r 。 该字节序列将从索引p开始从缓冲区传送，其中p是执行写入时的缓冲区的位置; 写入的最后一个字节的索引将为p + n - 1 。 完成后，缓冲区的位置将等于p + n ; 其限制将不会改变。

        缓冲区不能安全地被多个并发线程使用，因此在操作完成之前，请注意不要访问缓冲区。

        可以随时调用此方法。 某些频道类型可能不允许在任何给定时间多出一个写入。 如果线程在先前写入操作完成之前启动了写入操作，那么将抛出一个WritePendingException 。

        参数类型
        A - 附件的类型
        参数
        src - 要检索字节的缓冲区
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 完成处理程序对象
        异常
        WritePendingException - 如果通道不允许多个写入未完成，并且以前的写入尚未完成
        ShutdownChannelGroupException - 如果通道与已终止的group关联

      • write

        Future<Integer> write​(ByteBuffer src)
        从给定的缓冲区向该通道写入一个字节序列。

        该方法启动异步写入操作，以从给定的缓冲区向该通道写入字节序列。 该方法的行为方式与write(ByteBuffer,Object,CompletionHandler)方法完全相同，不同之处在于，该方法不是指定完成处理程序，而是返回表示待处理结果的Future 。 Future的get方法返回写入的字节数。

        参数
        src - 要检索字节的缓冲区
        结果
        代表操作结果的未来
        异常
        WritePendingException - 如果通道不允许多个写入未完成，并且以前的写入尚未完成
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AsynchronousChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface AsynchronousChannel

  • All Superinterfaces:
    AutoCloseable ， Channel ， Closeable
    All Known Subinterfaces:
    AsynchronousByteChannel
    所有已知实现类：
    AsynchronousFileChannel ， AsynchronousServerSocketChannel ， AsynchronousSocketChannel

    public interface AsynchronousChannel
extends Channel
    支持异步I / O操作的通道。 异步I / O操作通常采用以下两种形式之一：
    1.   Future<V> operation(...)
    2.   void operation(... A attachment, CompletionHandler<V,? super A> handler)
    其中操作是I / O操作的名称（例如读或写）， V是I / O操作的结果类型， A是附加到I / O操作以提供上下文的对象的类型消耗结果。 对于无状态 CompletionHandler用于消耗许多I / O操作的结果的情况，附件很重要。

    在第一种形式中，由Future接口定义的方法可用于检查操作是否已经完成，等待其完成，并检索结果。 在第二种形式中，一个CompletionHandler被调用以在完成或失败时消耗I / O操作的结果。

    实现此接口的通道是异步关闭的 ：如果通道上的I / O操作未完成，并且调用通道的close方法，则I / O操作将失败，异常情况为AsynchronousCloseException 。

    异步通道可以安全地被多个并发线程使用。 一些通道实现可以支持并发读取和写入，但是在任何给定时间可能不允许多于一个读取和一个写入操作。

    消除

    Future接口定义了取消执行的cancel方法。 这导致所有线程等待I / O操作的结果抛出CancellationException 。 是否可以取消基础I / O操作是高度实现具体的，因此未指定。 如果取消离开通道或其连接的实体处于不一致的状态，则该通道将被置于实现特定的错误状态 ，以防止进一步尝试启动类似于已取消操作的I / O操作。 例如，如果读取操作被取消，但实现不能保证字节没有从通道读取，那么它将通道置于错误状态; 进一步尝试启动read操作会引起未指定的运行时异常。 类似地，如果写入操作被取消，但是实现不能保证字节尚未被写入通道，则后续的启动write尝试将失败并且未指定运行时异常。

    在cancel方法调用mayInterruptIfRunning参数设置为true的情况下，I / O操作可能会由于关闭通道而中断。 在这种情况下，等待I / O操作结果的所有线程抛出CancellationException并且通道上的其他任何其他I / O操作都完成，异常AsynchronousCloseException 。

    在调用cancel方法以取消读取或写入操作的情况下，建议丢弃I / O操作中使用的所有缓冲区，或注意确保在通道保持打开状态时不访问缓冲区。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭此频道。

      • Methods inherited from interface java.nio.channels.Channel

        isOpen

    • 方法详细信息

      • close

        void close​()
    throws IOException
        关闭此频道。

        此通道上的任何未完成的异步操作将完成，异常情况为AsynchronousCloseException 。 关闭通道后，进一步尝试启动异步I / O操作，立即完成原因ClosedChannelException 。

        该方法的行为与Channel接口的规定完全相同。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Channel
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AsynchronousChannelGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class AsynchronousChannelGroup

  • java.lang.Object
    • java.nio.channels.AsynchronousChannelGroup

  • public abstract class AsynchronousChannelGroup
extends Object
    用于资源共享的一组异步通道。

    异步通道组封装了处理由组合启动的asynchronous channels启动的I / O操作完成所需的机制。 一个组有一个相关联的线程池，任务被提交到其中来处理I / O事件， 并发送到completion-handlers ，消耗组中的通道执行异步操作的结果。 除了处理I / O事件之外，汇集的线程还可以执行支持执行异步I / O操作所需的其他任务。

    通过调用此处定义的withFixedThreadPool或withCachedThreadPool方法创建异步通道组。 通道在构建通道时通过指定组来绑定到一个组。 相关联的线程池由组拥有 ; 组的终止导致关联线程池的关闭。

    除了明确创建的组之外，Java虚拟机还会维护自动构建的系统范围的默认组 。 在构建时不指定组的异步通道绑定到默认组。 默认组具有相关联的线程池，根据需要创建新线程。 默认组可以通过下表中定义的系统属性进行配置。 其中默认组的ThreadFactory未配置，则默认组的合并线程为daemon线程。

    System properties System property Description java.nio.channels.DefaultThreadPool.threadFactory The value of this property is taken to be the fully-qualified name of a concrete ThreadFactory class. The class is loaded using the system class loader and instantiated. The factory's newThread method is invoked to create each thread for the default group's thread pool. If the process to load and instantiate the value of the property fails then an unspecified error is thrown during the construction of the default group. java.nio.channels.DefaultThreadPool.initialSize The value of the initialSize parameter for the default group (see withCachedThreadPool). The value of the property is taken to be the String representation of an Integer that is the initial size parameter. If the value cannot be parsed as an Integer it causes an unspecified error to be thrown during the construction of the default group.

    穿线

    在绑定到组的通道上启动的I / O操作的完成处理程序将被保证由组中的一个合并线程调用。 这确保完成处理程序由具有预期标识的线程运行。

    在I / O操作立即完成的情况下，启动线程是组中的一个汇集线程，那么完成处理程序可能会被启动线程直接调用。 为了避免堆栈溢出，实现可能会对线程堆栈上的激活次数施加限制。 一些I / O操作可能会禁止启动线程直接调用完成处理程序（请参阅accept ）。

    关机和终止

    shutdown方法用于启动组的有序关闭 。 有序关闭将该组标记为关机; 进一步尝试构建绑定到该组的通道将抛出ShutdownChannelGroupException 。 一个组是否关机可以使用isShutdown方法进行测试。 一旦关闭，当所有绑定到该组的异步通道关闭时，该组将终止 ，所有主动执行的完成处理程序都已完成，并且该组使用的资源被释放。 没有尝试停止或中断执行完成处理程序的线程。 isTerminated方法用于测试组是否终止，并且可以使用awaitTermination方法阻止，直到组终止。

    shutdownNow方法可用于启动组的强制关闭 。 除了通过有序关闭执行的操作之外， shutdownNow方法会关闭组中的所有打开的通道，就像通过调用close方法一样。

    从以下版本开始：
    1.7
    另请参见：
    AsynchronousSocketChannel.open(AsynchronousChannelGroup) ， AsynchronousServerSocketChannel.open(AsynchronousChannelGroup)

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AsynchronousChannelGroup​(AsynchronousChannelProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract boolean awaitTermination​(long timeout, TimeUnit unit)
      等待该组终止。
      abstract boolean isShutdown​()
      告知这个异步通道组是否关闭。
      abstract boolean isTerminated​()
      告诉本组是否已经终止。
      AsynchronousChannelProvider provider​()
      返回创建此通道组的提供程序。
      abstract void shutdown​()
      启动组的有序关闭。
      abstract void shutdownNow​()
      关闭组并关闭组中的所有打开的通道。
      static AsynchronousChannelGroup withCachedThreadPool​(ExecutorService executor, int initialSize)
      创建具有给定线程池的异步通道组，根据需要创建新线程。
      static AsynchronousChannelGroup withFixedThreadPool​(int nThreads, ThreadFactory threadFactory)
      创建具有固定线程池的异步通道组。
      static AsynchronousChannelGroup withThreadPool​(ExecutorService executor)
      使用给定的线程池创建异步通道组。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AsynchronousChannelGroup

        protected AsynchronousChannelGroup​(AsynchronousChannelProvider provider)
        初始化此类的新实例。
        参数
        provider - 此组的异步通道提供程序

    • 方法详细信息

      • provider

        public final AsynchronousChannelProvider provider​()
        返回创建此通道组的提供程序。
        结果
        创建此通道组的提供程序

      • withFixedThreadPool

        public static AsynchronousChannelGroup withFixedThreadPool​(int nThreads,
                                                           ThreadFactory threadFactory)
                                                    throws IOException
        创建具有固定线程池的异步通道组。

        所产生的异步通道组重新使用固定数量的线程。 在任何时候，最多nThreads线程将是被提交处理I / O事件的主动处理任务，并且为组中异步通道发起的操作调度完成结果。

        该组是通过调用系统范围默认的AsynchronousChannelProvider对象的openAsynchronousChannelGroup(int,ThreadFactory)方法创建的。

        参数
        nThreads - 池中的线程数
        threadFactory - 创建新线程时使用的工厂
        结果
        一个新的异步通道组
        异常
        IllegalArgumentException - 如果是 nThreads <= 0
        IOException - 如果发生I / O错误

      • withCachedThreadPool

        public static AsynchronousChannelGroup withCachedThreadPool​(ExecutorService executor,
                                                            int initialSize)
                                                     throws IOException
        创建具有给定线程池的异步通道组，根据需要创建新线程。

        executor参数是一个ExecutorService ，根据需要创建新线程来执行提交处理I / O事件的任务，并为组中的异步通道启动的操作分派完成结果。 当它们可用时，它可以重用以前构造的线程。

        实施中可以使用initialSize参数作为其可能提交的初始任务数量的提示 。 例如，它可以用于指示等待I / O事件的初始线程数。

        执行器意图由所产生的异步通道组专门使用。 该组的终止导致了执行人服务的有序shutdown 。 以其他方式关闭执行者服务会导致未指定的行为。

        该组是通过调用系统范围默认的AsynchronousChannelProvider对象的openAsynchronousChannelGroup(ExecutorService,int)方法创建的。

        参数
        executor - 生成组的线程池
        initialSize - 值为 >=0或实现特定默认值的负值
        结果
        一个新的异步通道组
        异常
        IOException - 如果发生I / O错误
        另请参见：
        Executors.newCachedThreadPool()

      • withThreadPool

        public static AsynchronousChannelGroup withThreadPool​(ExecutorService executor)
                                               throws IOException
        使用给定的线程池创建异步通道组。

        executor参数是一个ExecutorService ，它执行提交到ExecutorService完成结果的任务，用于在组中的异步通道上启动的操作。

        配置执行程序服务时应小心。 它应该支持直接切换或提交的任务的无限排队 ，并且调用execute方法的线程不应该直接调用该任务。 一个实施可能需要额外的限制。

        执行器意图由所产生的异步通道组专门使用。 该组的终止导致执行者服务的有序shutdown 。 以其他方式关闭执行者服务会导致未指定的行为。

        该组通过使用0的initialSize调用系统范围默认的AsynchronousChannelProvider对象的initialSize方法0 。

        参数
        executor - 生成组的线程池
        结果
        一个新的异步通道组
        异常
        IOException - 如果发生I / O错误

      • isShutdown

        public abstract boolean isShutdown​()
        告知这个异步通道组是否关闭。
        结果
        true如果此异步通道组已关闭或已标记为关闭。

      • isTerminated

        public abstract boolean isTerminated​()
        告诉本组是否已经终止。

        在此方法返回true ，相关线程池也有terminated 。

        结果
        true如果该组已经终止

      • shutdown

        public abstract void shutdown​()
        启动组的有序关闭。

        此方法将该组标记为关闭。 进一步尝试构建与此组绑定的通道将抛出ShutdownChannelGroupException 。 当组中的所有异步通道关闭时，组终止，所有主动执行的完成处理程序都已完成运行，并且所有资源都已被释放。 如果组已经关闭，则此方法无效。

      • shutdownNow

        public abstract void shutdownNow​()
                          throws IOException
        关闭组并关闭组中的所有打开的通道。

        除了shutdown方法执行的操作之外 ，此方法也会在组中的所有打开的通道上调用close方法。 该方法不会阻止或中断正在执行完成处理程序的线程。 当所有主动执行的完成处理程序都运行到完成并且所有资源已经被释放时，该组终止。 可以随时调用此方法。 如果一些其他线程已经调用它，那么另一个调用将阻塞，直到第一次调用完成，之后它将不起作用。

        异常
        IOException - 如果发生I / O错误

      • awaitTermination

        public abstract boolean awaitTermination​(long timeout,
                                         TimeUnit unit)
                                  throws InterruptedException
        等待该组终止。

        该方法阻塞，直到组终止，或超时发生，或当前线程中断，以先发生者为准。

        参数
        timeout - 等待的最长时间，或零或更少等待不等待
        unit - 超时参数的时间单位
        结果
        true如果该组已经终止; false如果在终止前超时
        异常
        InterruptedException - 如果在等待时中断
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AsynchronousCloseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class AsynchronousCloseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.channels.ClosedChannelException
            • java.nio.channels.AsynchronousCloseException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ClosedByInterruptException

    public class AsynchronousCloseException
extends ClosedChannelException
    当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AsynchronousCloseException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AsynchronousCloseException

        public AsynchronousCloseException​()
        Constructs an instance of this class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AsynchronousFileChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class AsynchronousFileChannel

  • java.lang.Object
    • java.nio.channels.AsynchronousFileChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， AsynchronousChannel ， Channel

    public abstract class AsynchronousFileChannel
extends Object
implements AsynchronousChannel
    用于读取，写入和操作文件的异步通道。

    当通过调用此类定义的一个open方法打开文件时，将创建异步文件通道。 该文件包含一个可变长度的可读写字节序列，当前大小可以是queried 。 当字节写入超过其当前大小时，文件的大小增加; 文件大小在truncated时会减小 。

    异步文件通道在文件中没有当前位置 。 而是将文件位置指定给启动异步操作的每个读写方法。 A CompletionHandler被指定为参数，并被调用以消耗I / O操作的结果。 此类还定义了启动异步操作的读取和写入方法，返回一个Future以表示待处理的操作结果。 Future可用于检查操作是否完成，等待其完成，并检索结果。

    除了读写操作之外，此类还定义了以下操作：

    • 对文件进行的更新可能是底层存储设备的forced out，以确保数据在系统崩溃时不会丢失。

    • 一个文件的区域可能是locked反对其他程序的访问。

    一个AsynchronousFileChannel与提交任务以处理I / O事件的线程池相关联，并分派到消耗通道上的I / O操作结果的完成处理程序。 在通道上启动的I / O操作的完成处理程序保证由线程池中的一个线程调用（这样可以确保完成处理程序由具有预期标识的线程运行）。 I / O操作立即完成，并且启动线程本身是线程池中的线程，则完成处理程序可以由启动线程直接调用。 当创建AsynchronousFileChannel而不指定线程池时，该通道与可能与其他通道共享的系统相关的默认线程池相关联。 默认线程池由AsynchronousChannelGroup类定义的系统属性配置。

    这种类型的通道可以安全地被多个并发线程使用。 close方法可以随时被调用，由Channel接口指定。 这导致通道上的所有未完成的异步操作完成，异常AsynchronousCloseException 。 多个读写操作可能同时出现。 当多个读写操作未完成时，未指定I / O操作的顺序和调用完成处理程序的顺序; 它们并不特别保证按照操作开始的顺序执行。 读取或写入时使用的ByteBuffers对于多个并发I / O操作不能安全使用。 此外，在I / O操作开始之后，应注意确保缓冲区在操作完成后才被访问。

    与FileChannel一样 ，由该类的实例提供的文件的视图保证与同一程序中的其他实例提供的同一文件的其他视图一致。 但是，由于此类的实例提供的视图可能与也可能不一致，这是由于底层操作系统执行的缓存和网络文件系统协议引起的延迟而由其他同时运行的程序所看到的视图。 无论这些其他程序的编写语言如何，以及它们是在同一台机器还是在其他机器上运行，都是如此。 任何这种不一致的确切性质是系统依赖性的，因此是未指定的。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AsynchronousFileChannel​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void force​(boolean metaData)
      强制将此通道文件的任何更新写入包含该通道的存储设备。
      Future<FileLock> lock​()
      获取此通道文件的排他锁。
      abstract Future<FileLock> lock​(long position, long size, boolean shared)
      获取此通道文件的给定区域的锁定。
      abstract <A> void lock​(long position, long size, boolean shared, A attachment, CompletionHandler<FileLock,? super A> handler)
      获取此通道文件的给定区域的锁定。
      <A> void lock​(A attachment, CompletionHandler<FileLock,? super A> handler)
      获取此通道文件的排他锁。
      static AsynchronousFileChannel open​(Path file, OpenOption... options)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static AsynchronousFileChannel open​(Path file, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      abstract Future<Integer> read​(ByteBuffer dst, long position)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      abstract <A> void read​(ByteBuffer dst, long position, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      abstract long size​()
      返回此通道文件的当前大小。
      abstract AsynchronousFileChannel truncate​(long size)
      将此频道的文件截断为给定大小。
      FileLock tryLock​()
      尝试获取此频道文件的排他锁。
      abstract FileLock tryLock​(long position, long size, boolean shared)
      尝试获取此通道文件的给定区域的锁定。
      abstract Future<Integer> write​(ByteBuffer src, long position)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
      abstract <A> void write​(ByteBuffer src, long position, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。

      • Methods inherited from interface java.nio.channels.AsynchronousChannel

        close

      • Methods inherited from interface java.nio.channels.Channel

        isOpen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AsynchronousFileChannel

        protected AsynchronousFileChannel​()
        初始化此类的新实例。

    • 方法详细信息

      • open

        public static AsynchronousFileChannel open​(Path file,
                                           Set<? extends OpenOption> options,
                                           ExecutorService executor,
                                           FileAttribute<?>... attrs)
                                    throws IOException
        打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。

        options参数确定文件的打开方式。 READ和WRITE选项确定文件是否应打开以进行读取和/或写入。 如果数组中没有包含任何选项，则打开一个现有文件进行阅读。

        除了READ和WRITE ，还可能存在以下选项：

        additional options Option Description TRUNCATE_EXISTING When opening an existing file, the file is first truncated to a size of 0 bytes. This option is ignored when the file is opened only for reading. CREATE_NEW If this option is present then a new file is created, failing if the file already exists. When creating a file the check for the existence of the file and the creation of the file if it does not exist is atomic with respect to other file system operations. This option is ignored when the file is opened only for reading. CREATE If this option is present then an existing file is opened if it exists, otherwise a new file is created. When creating a file the check for the existence of the file and the creation of the file if it does not exist is atomic with respect to other file system operations. This option is ignored if the CREATE_NEW option is also present or the file is opened only for reading. DELETE_ON_CLOSE When this option is present then the implementation makes a best effort attempt to delete the file when closed by the the close method. If the close method is not invoked then a best effort attempt is made to delete the file when the Java virtual machine terminates. SPARSE When creating a new file this option is a hint that the new file will be sparse. This option is ignored when not creating a new file. SYNC Requires that every update to the file's content or metadata be written synchronously to the underlying storage device. (see Synchronized I/O file integrity). DSYNC Requires that every update to the file's content be written synchronously to the underlying storage device. (see Synchronized I/O file integrity).

        实施还可以支持其他选项。

        executor参数是ExecutorService ，其中提交的任务用于处理I / O事件，并为结果通道启动的操作调度完成结果。 这些任务的性质是高度实现具体的，并且在配置Executor时应该小心。 最小应该支持一个无界的工作队列，不应该在execute方法的调用者线程上运行任务。 在通道打开时关闭执行程序服务会导致未指定的行为。

        attrs参数是文件file-attributes的可选数组，用于在创建文件时以原子方式进行设置。

        新的信道是通过调用创建newFileChannel上创建该提供商方法Path 。

        参数
        file - 打开或创建文件的路径
        options - 指定文件打开方式的选项
        executor - 将通道与默认线程池关联的线程池或 null
        attrs - 创建文件时以原子方式设置的文件属性的可选列表
        结果
        一个新的异步文件通道
        异常
        IllegalArgumentException - 如果集合包含无效的选项组合
        UnsupportedOperationException - 如果 file与不支持创建异步文件通道的提供程序关联，或者指定了不支持的打开选项，或者数组包含创建文件时无法原子设置的属性
        IOException - 如果发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝执行所需的未指定的权限。 在默认提供程序的情况下，如果打开文件进行阅读，则调用SecurityManager.checkRead(String)方法来检查读访问。 如果打开文件写入，则调用SecurityManager.checkWrite(String)方法来检查写访问

      • open

        public static AsynchronousFileChannel open​(Path file,
                                           OpenOption... options)
                                    throws IOException
        打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。

        调用此方法的行为方式与调用完全相同

          ch.open(file, opts, null, new FileAttribute<?>[0]);
        其中opts是一个Set其中包含为此方法指定的选项。

        所产生的通道与默认线程池相关联，任务被提交到处理I / O事件并发送到完成处理程序，该处理程序消耗在最终通道上执行的异步操作的结果。

        参数
        file - 打开或创建文件的路径
        options - 指定文件打开方式的选项
        结果
        一个新的异步文件通道
        异常
        IllegalArgumentException - 如果集合包含无效的选项组合
        UnsupportedOperationException - 如果 file与不支持创建文件通道的提供程序相关联，或者指定了不支持的打开选项
        IOException - 如果发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝实现所需的未指定的权限。 在默认提供程序的情况下，如果文件打开以供阅读，则调用SecurityManager.checkRead(String)方法来检查读访问。 如果打开文件写入，则调用SecurityManager.checkWrite(String)方法来检查写访问

      • size

        public abstract long size​()
                   throws IOException
        返回此通道文件的当前大小。
        结果
        该通道文件的当前大小，以字节为单位
        异常
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误

      • truncate

        public abstract AsynchronousFileChannel truncate​(long size)
                                          throws IOException
        将此频道的文件截断为给定大小。

        如果给定的大小小于文件的当前大小，则文件将被截断，丢弃超出文件新端的任何字节。 如果给定的大小大于或等于文件的当前大小，则该文件不会被修改。

        参数
        size - 新的大小，非负字节数
        结果
        此文件通道
        异常
        NonWritableChannelException - 如果此通道未打开以进行写入
        ClosedChannelException - 如果此通道关闭
        IllegalArgumentException - 如果新的大小为负数
        IOException - 如果发生其他I / O错误

      • force

        public abstract void force​(boolean metaData)
                    throws IOException
        强制将此通道文件的任何更新写入包含该通道的存储设备。

        如果此通道的文件驻留在本地存储设备上，那么当该方法返回时，保证自创建该通道以来创建或自从上次调用该方法以来对文件所做的所有更改都将写入该设备。 这对于确保系统崩溃时不会丢失关键信息非常有用。

        如果文件不在本地设备上，则不会提供此类保证。

        metaData参数可用于限制此方法执行所需的I / O操作数。 传递此参数的false表示仅对文件内容的更新需要写入存储; 通过true表示，必须写入文件的内容和元数据的更新，通常需要至少一个I / O操作。 该参数实际上是否具有任何效果取决于底层操作系统，因此未指定。

        调用此方法可能会导致I / O操作发生，即使通道仅打开读取。 例如，某些操作系统将最后访问时间作为文件的元数据的一部分进行维护，并且每次读取文件时都会更新此时间。 这是否实际上是系统依赖的，因此是未指定的。

        此方法只能通过此类中定义的方法强制对此通道文件进行的更改。

        参数
        metaData - 如果是true则需要这种方法来强制更改文件的内容和要写入存储的元数据; 否则，它只需要强制更改内容
        异常
        ClosedChannelException - 如果此频道关闭
        IOException - 如果发生其他I / O错误

      • lock

        public abstract <A> void lock​(long position,
                              long size,
                              boolean shared,
                              A attachment,
                              CompletionHandler<FileLock,? super A> handler)
        获取此通道文件的给定区域的锁定。

        该方法启动一个操作，以获取此通道文件的给定区域的锁定。 handler参数是在获取锁定时调用的完成处理程序（或操作失败）。 结果传递给完成处理程序是由此产生的FileLock 。

        由position和size参数指定的区域不需要包含在实际的底层文件内，甚至不重叠。 锁定区域的大小固定; 如果锁定区域最初包含文件的结尾，并且文件增长超出该区域，那么该文件的新部分将不会被该锁覆盖。 如果文件的大小增加，并且整个文件都需要锁定，则应该锁定从零开始并且不小于文件的预期最大大小的区域。 双参数lock(Object,CompletionHandler)方法简单地锁定大小为Long.MAX_VALUE的区域。 如果与Java请求区域重叠的锁已被该Java虚拟机保存，或者已调用此方法来锁定重叠区域，并且该操作尚未完成，则此方法将抛出OverlappingFileLockException 。

        某些操作系统不支持以异步方式获取文件锁的机制。 因此，实现可以获取后台线程中的文件锁或从相关线程池中的线程执行的任务获取。 如果有许多锁定操作未完成，那么可能会在Java虚拟机中消耗线程无限期。

        某些操作系统不支持共享锁，在这种情况下，共享锁的请求将自动转换为独占锁的请求。 新获取的锁是共享的还是独占的都可以通过调用生成的锁对象的isShared方法进行测试。

        文件锁代表整个Java虚拟机。 它们不适用于通过同一虚拟机中的多个线程控制对文件的访问。

        参数类型
        A - 附件的类型
        参数
        position - 锁定区域要启动的位置; 必须是非负的
        size - 锁定区域的大小; 必须是非负数，并且position + size的总和必须是非负数
        shared - true请求共享锁，在这种情况下，该通道必须打开才能读取（可能写入）; false要求排他锁，在这种情况下，该频道必须开放写作（可能阅读）
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消费结果的处理程序
        异常
        OverlappingFileLockException - 如果与该请求区域重叠的锁已由该Java虚拟机保存，或者已经有一个挂起尝试锁定重叠区域
        IllegalArgumentException - 如果参数的前提条件不成立
        NonReadableChannelException - 如果 shared是真的，但这个频道没有打开阅读
        NonWritableChannelException - 如果 shared为假，但此通道未打开以进行写入

      • lock

        public final <A> void lock​(A attachment,
                           CompletionHandler<FileLock,? super A> handler)
        获取此通道文件的排他锁。

        该方法启动一个操作，以获取此通道文件的给定区域的锁定。 handler参数是一个完成处理程序，在获取锁定时（或操作失败）时调用该处理程序。 结果传递给完成处理程序是由此产生的FileLock 。

        这种ch.lock(att,handler)形式的方法的调用与调用的方式完全相同

          ch.lock(0L, Long.MAX_VALUE, false, att, handler)
        参数类型
        A - 附件的类型
        参数
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消费结果的处理程序
        异常
        OverlappingFileLockException - 如果此Java虚拟机已经保留了锁定，或者已经有一个暂停尝试锁定一个区域
        NonWritableChannelException - 如果此通道未打开以进行写入

      • lock

        public abstract Future<FileLock> lock​(long position,
                                      long size,
                                      boolean shared)
        获取此通道文件的给定区域的锁定。

        该方法启动一个操作，以获取此通道文件的给定区域的锁定。 该方法的行为方式与lock(long, long, boolean, Object, CompletionHandler)方法完全相同，不同之处在于，该方法不是指定完成处理程序，而是返回表示待处理结果的Future 。 Future的get方法在成功完成后返回FileLock 。

        参数
        position - 锁定区域要启动的位置; 必须是非负的
        size - 锁定区域的大小; 必须是非负数，并且position + size必须为非负数
        shared - true以请求共享锁，在这种情况下，该通道必须打开才能读取（可能写入）; false要求排他锁，在这种情况下，此通道必须打开以进行写入（可能读取）
        结果
        表示待处理结果的 Future对象
        异常
        OverlappingFileLockException - 如果此Java虚拟机已经保留了锁定，或者已经有一个暂停尝试锁定一个区域
        IllegalArgumentException - 如果参数的前提条件不成立
        NonReadableChannelException - 如果 shared是真的，但这个频道没有打开阅读
        NonWritableChannelException - 如果 shared为false，但此通道未打开以进行写入

      • lock

        public final Future<FileLock> lock​()
        获取此通道文件的排他锁。

        此方法启动一个操作来获取该通道文件的排他锁。 该方法返回一个Future表示该操作的待处理结果。 Future的get方法在成功完成后返回FileLock 。

        调用此方法的行为方式与调用完全相同

          ch.lock(0L, Long.MAX_VALUE, false)
        结果
        表示待处理结果的 Future对象
        异常
        OverlappingFileLockException - 如果该Java虚拟机已经保留了锁定，或者已经有一个暂停尝试锁定一个区域
        NonWritableChannelException - 如果此通道未打开以进行写入

      • tryLock

        public abstract FileLock tryLock​(long position,
                                 long size,
                                 boolean shared)
                          throws IOException
        尝试获取此通道文件的给定区域的锁定。

        此方法不阻止。 调用总是立即返回，要么获取了请求的区域的锁定，要么没有这样做。 如果由于重叠锁由另一个程序持有而无法获取锁定，则它将返回null 。 如果由于任何其他原因无法获取锁，则抛出适当的异常。

        参数
        position - 锁定区域要启动的位置; 必须是非负的
        size - 锁定区域的大小; 必须是非负数，并且position + size的和必须是非负数
        shared - true要求共享锁 false请求独占锁
        结果
        表示新获取的锁的锁定对象，如果由于另一个程序持有重叠的锁而无法获取锁， null
        异常
        IllegalArgumentException - 如果参数的前提条件不成立
        ClosedChannelException - 如果此通道关闭
        OverlappingFileLockException - 如果与该请求区域重叠的锁已由该Java虚拟机保留，或者该方法中已阻止另一个线程，并尝试锁定同一文件的重叠区域
        NonReadableChannelException - 如果 shared是真的，但这个频道没有打开阅读
        NonWritableChannelException - 如果 shared为假，但此通道未打开以进行写入
        IOException - 如果发生其他I / O错误
        另请参见：
        lock(Object,CompletionHandler) ，
lock(long,long,boolean,Object,CompletionHandler) ，
tryLock()

      • tryLock

        public final FileLock tryLock​()
                       throws IOException
        尝试获取此频道文件的排他锁。

        这种ch.tryLock()形式的方法的调用与调用的方式完全相同

          ch.tryLock(0L, Long.MAX_VALUE, false)
        结果
        表示新获取的锁的锁定对象，如果由于另一个程序持有重叠锁而无法获取锁， null
        异常
        ClosedChannelException - 如果此通道关闭
        OverlappingFileLockException - 如果与该请求区域重叠的锁已由该Java虚拟机保存，或者在此方法中已阻止另一个线程，并尝试锁定重叠区域
        NonWritableChannelException - 如果 shared为假，但此通道未打开以进行写入
        IOException - 如果发生其他I / O错误
        另请参见：
        lock(Object,CompletionHandler) ，
lock(long,long,boolean,Object,CompletionHandler) ，
tryLock(long,long,boolean)

      • read

        public abstract <A> void read​(ByteBuffer dst,
                              long position,
                              A attachment,
                              CompletionHandler<Integer,? super A> handler)
        从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。

        该方法从给定的文件位置开始从该通道读取字节序列到给定的缓冲区。 读取的结果是读取的字节数或-1如果给定位置大于或等于尝试读取时文件的大小。

        该方法的工作方式与AsynchronousByteChannel.read(ByteBuffer,Object,CompletionHandler)方法相同，只是从给定文件位置开始读取字节。 如果给定的文件位置大于尝试读取时的文件大小，则不会读取任何字节。

        参数类型
        A - 附件的类型
        参数
        dst - 要传输字节的缓冲区
        position - 传输开始的文件位置; 必须是非负的
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消费结果的处理程序
        异常
        IllegalArgumentException - 如果位置为负或缓冲区为只读
        NonReadableChannelException - 如果此频道未打开阅读

      • read

        public abstract Future<Integer> read​(ByteBuffer dst,
                                     long position)
        从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。

        该方法从给定的文件位置开始从该通道读取字节序列到给定的缓冲区。 此方法返回一个Future表示该操作的待处理结果。 Future的get方法返回读取的字节数或-1如果给定的位置大于或等于在尝试读取时文件的大小。

        该方法的工作方式与AsynchronousByteChannel.read(ByteBuffer)方法相同，只是从给定的文件位置开始读取字节。 如果给定的文件位置大于尝试读取时的文件大小，则不会读取任何字节。

        参数
        dst - 要传输字节的缓冲区
        position - 传输开始的文件位置; 必须是非负的
        结果
        表示待处理结果的 Future对象
        异常
        IllegalArgumentException - 如果位置为负或缓冲区为只读
        NonReadableChannelException - 如果此频道未打开阅读

      • write

        public abstract <A> void write​(ByteBuffer src,
                               long position,
                               A attachment,
                               CompletionHandler<Integer,? super A> handler)
        从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。

        该方法的工作方式与AsynchronousByteChannel.write(ByteBuffer,Object,CompletionHandler)方法相同，只是字节从给定的文件位置开始写入。 如果给定的位置大于文件的大小，则在尝试写入时，该文件将生长以适应新的字节; 未指定上一个文件结尾和新写入的字节之间的任何字节的值。

        参数类型
        A - 附件的类型
        参数
        src - 要传输字节的缓冲区
        position - 传输开始的文件位置; 必须是非负的
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消费结果的处理程序
        异常
        IllegalArgumentException - 如果位置为负
        NonWritableChannelException - 如果此通道未打开以进行写入

      • write

        public abstract Future<Integer> write​(ByteBuffer src,
                                      long position)
        从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。

        该方法从给定的缓冲区开始向该通道写入字节序列，从给定的文件位置开始。 该方法返回一个Future表示写操作的挂起结果。 Future的get方法返回写入的字节数。

        该方法的工作方式与AsynchronousByteChannel.write(ByteBuffer)方法相同，只是字节从给定的文件位置开始写入。 如果给定的位置大于文件的大小，则在尝试写入时，该文件将生长以适应新的字节; 未指定上一个文件结尾和新写入的字节之间的任何字节的值。

        参数
        src - 要传输字节的缓冲区
        position - 传输开始的文件位置; 必须是非负的
        结果
        表示待处理结果的 Future对象
        异常
        IllegalArgumentException - 如果位置为负
        NonWritableChannelException - 如果此通道未打开以进行写入
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AsynchronousServerSocketChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class AsynchronousServerSocketChannel

  • java.lang.Object
    • java.nio.channels.AsynchronousServerSocketChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， AsynchronousChannel ， Channel ， NetworkChannel

    public abstract class AsynchronousServerSocketChannel
extends Object
implements AsynchronousChannel, NetworkChannel
    用于面向流的侦听套接字的异步通道。

    通过调用此类的open方法创建异步服务器套接字通道。 新创建的异步服务器套接字通道已打开但尚未绑定。 它可以绑定到本地地址，并配置为通过调用bind方法监听连接。 一旦绑定，则使用accept方法启动接受通道插座的连接。 在未绑定通道上调用accept方法的尝试将导致抛出NotYetBoundException 。

    这种类型的通道可以安全地被多个并发线程使用，尽管在任何时候最多只能接受一个操作。 如果线程在先前接受操作完成之前启动接受操作，那么将抛出一个AcceptPendingException 。

    套接字选项使用setOption方法进行配置。 此类型的频道支持以下选项：

    Socket options
    Option Name | 描述
    SO_RCVBUF | The size of the socket receive buffer
    SO_REUSEADDR | Re-use address
    还可以支持附加（实现特定）选项。

    用法示例：

      final AsynchronousServerSocketChannel listener =
      AsynchronousServerSocketChannel.open().bind(new InetSocketAddress(5000));

  listener.accept(null, new CompletionHandler<AsynchronousSocketChannel,Void>() {
      public void completed(AsynchronousSocketChannel ch, Void att) {
          // accept the next connection
          listener.accept(null, this);

          // handle this connection
          handle(ch);
      }
      public void failed(Throwable exc, Void att) {
          ...
      }
  });
    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AsynchronousServerSocketChannel​(AsynchronousChannelProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Future<AsynchronousSocketChannel> accept​()
      接受连接。
      abstract <A> void accept​(A attachment, CompletionHandler<AsynchronousSocketChannel,? super A> handler)
      接受连接。
      AsynchronousServerSocketChannel bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract AsynchronousServerSocketChannel bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SocketAddress getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      static AsynchronousServerSocketChannel open​()
      打开异步服务器套接字通道。
      static AsynchronousServerSocketChannel open​(AsynchronousChannelGroup group)
      打开异步服务器套接字通道。
      AsynchronousChannelProvider provider​()
      返回创建此通道的提供程序。
      abstract <T> AsynchronousServerSocketChannel setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。

      • Methods inherited from interface java.nio.channels.AsynchronousChannel

        close

      • Methods inherited from interface java.nio.channels.Channel

        isOpen

      • Methods inherited from interface java.nio.channels.NetworkChannel

        getOption, supportedOptions

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AsynchronousServerSocketChannel

        protected AsynchronousServerSocketChannel​(AsynchronousChannelProvider provider)
        初始化此类的新实例。
        参数
        provider - 创建此频道的提供商

    • 方法详细信息

      • provider

        public final AsynchronousChannelProvider provider​()
        返回创建此通道的提供程序。
        结果
        创建此频道的提供商

      • open

        public static AsynchronousServerSocketChannel open​(AsynchronousChannelGroup group)
                                            throws IOException
        打开异步服务器套接字通道。

        通过在创建给定组的AsynchronousChannelProvider对象上调用openAsynchronousServerSocketChannel方法创建新通道。 如果组参数为null则生成的通道由系统级默认提供程序创建，并绑定到默认组 。

        参数
        group - 新建通道应绑定的组，或默认组的 null
        结果
        一个新的异步服务器插槽通道
        异常
        ShutdownChannelGroupException - 如果通道组关闭
        IOException - 如果发生I / O错误

      • open

        public static AsynchronousServerSocketChannel open​()
                                            throws IOException
        打开异步服务器套接字通道。

        此方法返回绑定到默认组的异步服务器套接字通道。 此方法等效于评估表达式：

         open((AsynchronousChannelGroup)null);
        结果
        一个新的异步服务器插槽通道
        异常
        IOException - 如果发生I / O错误

      • bind

        public final AsynchronousServerSocketChannel bind​(SocketAddress local)
                                           throws IOException
        将通道的套接字绑定到本地地址，并配置套接字以监听连接。

        此方法的调用等同于以下内容：

         bind(local, 0);
        Specified by:
        bind在接口 NetworkChannel
        参数
        local - 绑定套接字的本地地址，或 null绑定到自动分配的套接字地址
        结果
        这个频道
        异常
        AlreadyBoundException - 如果套接字已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        SecurityException - 如果安装了一个安全管理器，并且它拒绝了未指定的权限。 此接口的实现应指定任何所需的权限。
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生其他I / O错误
        另请参见：
        NetworkChannel.getLocalAddress()

      • bind

        public abstract AsynchronousServerSocketChannel bind​(SocketAddress local,
                                                     int backlog)
                                              throws IOException
        将通道的套接字绑定到本地地址，并配置套接字以监听连接。

        该方法用于在套接字和本地地址之间建立关联。 一旦建立了关联，则套接字保持绑定，直到关联的信道被关闭。

        backlog参数是套接字上挂起的连接的最大数量。 其确切语义是实现具体的。 特别地，实现可以施加最大长度，或者可以选择忽略参数altogther。 如果backlog参数的值为0或负值，则使用实现特定的默认值。

        参数
        local - 绑定套接字的本地地址，或 null绑定到自动分配的套接字地址
        backlog - 挂起连接的最大数量
        结果
        这个频道
        异常
        AlreadyBoundException - 如果套接字已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生其他I / O错误

      • setOption

        public abstract <T> AsynchronousServerSocketChannel setOption​(SocketOption<T> name,
                                                              T value)
                                                       throws IOException
        描述从接口NetworkChannel复制
        设置套接字选项的值。
        Specified by:
        setOption在接口 NetworkChannel
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能是某些套接字选项的有效值。
        结果
        这个频道
        异常
        IllegalArgumentException - 如果该值不是此套接字选项的有效值
        ClosedChannelException - 如果此频道关闭
        IOException - 如果发生I / O错误
        另请参见：
        StandardSocketOptions

      • accept

        public abstract <A> void accept​(A attachment,
                                CompletionHandler<AsynchronousSocketChannel,? super A> handler)
        接受连接。

        此方法启动异步操作以接受对该通道的套接字进行的连接。 handler参数是一个完成处理程序，在连接被接受时被调用（或者操作失败）。 传递给完成处理程序的结果是新连接的AsynchronousSocketChannel 。

        当接受新的连接时，所产生的AsynchronousSocketChannel将被绑定到与该频道相同的AsynchronousChannelGroup 。 如果该基团是shutdown和连接被接受，则所述连接被关闭，并且操作与完成IOException并引起ShutdownChannelGroupException 。

        为了允许新连接的并发处理，当立即接受新连接时，完成处理程序不会被启动线程直接调用（请参阅Threading ）。

        如果安装了一个安全管理器，那么它将通过安全管理器的checkAccept方法验证连接的远程端点的地址和端口号是否被允许。 权限检查由受此方法的调用上下文限制的权限执行。 如果权限检查失败，则连接被关闭，并且操作完成与一个SecurityException 。

        参数类型
        A - 附件的类型
        参数
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消耗结果的处理程序
        异常
        AcceptPendingException - 如果此通道上已经接受了接受操作
        NotYetBoundException - 如果此通道的套接字尚未绑定
        ShutdownChannelGroupException - 如果通道组已终止

      • accept

        public abstract Future<AsynchronousSocketChannel> accept​()
        接受连接。

        此方法启动异步操作以接受对该通道的套接字进行的连接。 该方法的行为方式与accept(Object, CompletionHandler)方法完全相同，不同之处在于，该方法不是指定完成处理程序，而是返回表示待处理结果的Future 。 Future的get方法在成功完成后返回新连接的AsynchronousSocketChannel 。

        结果
        表示待处理结果的 Future对象
        异常
        AcceptPendingException - 如果此通道上已经有接受操作
        NotYetBoundException - 如果此通道的套接字尚未绑定

      • getLocalAddress

        public abstract SocketAddress getLocalAddress​()
                                       throws IOException
        返回此通道的套接字所绑定的套接字地址。

        通道为Internet协议套接字地址的bound ，则此方法的返回值为InetSocketAddress 。

        如果有一个安全管理器集，它的checkConnect方法被调用本地地址和-1作为参数来查看是否允许该操作。 如果不允许操作，则SocketAddress表示loopback地址的SocketAddress和通道插座的本地端口。

        Specified by:
        getLocalAddress接口 NetworkChannel
        结果
        该 SocketAddress的套接字绑定到，或 SocketAddress代表的环回地址，如果安全管理器拒绝，或者 null如果通道的套接字不绑定
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AsynchronousSocketChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class AsynchronousSocketChannel

  • java.lang.Object
    • java.nio.channels.AsynchronousSocketChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， AsynchronousByteChannel ， AsynchronousChannel ， Channel ， NetworkChannel

    public abstract class AsynchronousSocketChannel
extends Object
implements AsynchronousByteChannel, NetworkChannel
    用于面向流的连接插座的异步通道。

    异步套接字通道以两种方式之一创建。 新创建的AsynchronousSocketChannel是通过调用此类定义的一个open方法创建的。 新创建的频道已打开但尚未连接。 A相连接AsynchronousSocketChannel当连接到的插座制成创建AsynchronousServerSocketChannel 。 不可能为任意的，预先存在的socket创建异步套接字通道。

    新创建的通道通过调用其connect方法进行连接; 一旦连接，通道保持连接，直到它被关闭。 是否连接套接字通道可以通过调用其getRemoteAddress方法来确定。 尝试在未连接的通道上调用I / O操作将导致抛出NotYetConnectedException 。

    这种类型的通道可以安全地被多个并发线程使用。 它们支持并发读写，但最多只能读取一次读写操作，一次写操作可以随时进行。 如果线程在先前的读取操作完成之前启动了读取操作，那么将抛出一个ReadPendingException 。 类似地，在前一次写入完成之前尝试启动写入操作将抛出一个WritePendingException 。

    套接字选项使用setOption方法进行配置。 异步套接字通道支持以下选项：

    Socket options
    Option Name | 描述
    SO_SNDBUF | The size of the socket send buffer
    SO_RCVBUF | The size of the socket receive buffer
    SO_KEEPALIVE | Keep connection alive
    SO_REUSEADDR | Re-use address
    TCP_NODELAY | Disable the Nagle algorithm
    还可以支持附加（实现特定）选项。

    超时

    此类定义的read和write方法允许在启动读取或写入操作时指定超时。 如果在操作完成之前经过了超时，则操作完成，异常InterruptedByTimeoutException 。 超时可能会使通道或底层连接处于不一致的状态。 在实现不能保证字节没有从通道读取的情况下，它将通道置于实现特定的错误状态 。 随后尝试启动read操作会导致未指定的运行时异常被抛出。 类似地，如果write操作超时，并且实现不能保证字节尚未写入通道，则进一步尝试write通道发送write会导致未指定的运行时异常被抛出。 当超时过后，则不会定义用于I / O操作的ByteBuffer或缓冲区序列的状态。 应该丢弃缓冲区，或者至少要小心，以确保在通道保持打开状态时缓冲区不被访问。 接受超时参数的所有方法都将小于或等于0的值表示为I / O操作不超时。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AsynchronousSocketChannel​(AsynchronousChannelProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract AsynchronousSocketChannel bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      abstract Future<Void> connect​(SocketAddress remote)
      连接此频道。
      abstract <A> void connect​(SocketAddress remote, A attachment, CompletionHandler<Void,? super A> handler)
      连接此频道。
      abstract SocketAddress getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress getRemoteAddress​()
      返回此通道的插座所连接的远程地址。
      static AsynchronousSocketChannel open​()
      打开异步套接字通道。
      static AsynchronousSocketChannel open​(AsynchronousChannelGroup group)
      打开异步套接字通道。
      AsynchronousChannelProvider provider​()
      返回创建此通道的提供程序。
      abstract Future<Integer> read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      abstract <A> void read​(ByteBuffer[] dsts, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从该通道读取字节序列到给定缓冲区的子序列中。
      abstract <A> void read​(ByteBuffer dst, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      <A> void read​(ByteBuffer dst, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      abstract <T> AsynchronousSocketChannel setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      abstract AsynchronousSocketChannel shutdownInput​()
      关闭连接进行阅读，不关闭频道。
      abstract AsynchronousSocketChannel shutdownOutput​()
      关闭连接以进行写入，而不关闭通道。
      abstract Future<Integer> write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      abstract <A> void write​(ByteBuffer[] srcs, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从给定缓冲区的子序列将一个字节序列写入该通道。
      abstract <A> void write​(ByteBuffer src, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向该通道写入一个字节序列。
      <A> void write​(ByteBuffer src, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向该通道写入一个字节序列。

      • Methods inherited from interface java.nio.channels.AsynchronousChannel

        close

      • Methods inherited from interface java.nio.channels.Channel

        isOpen

      • Methods inherited from interface java.nio.channels.NetworkChannel

        getOption, supportedOptions

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AsynchronousSocketChannel

        protected AsynchronousSocketChannel​(AsynchronousChannelProvider provider)
        初始化此类的新实例。
        参数
        provider - 创建此频道的提供商

    • 方法详细信息

      • provider

        public final AsynchronousChannelProvider provider​()
        返回创建此通道的提供程序。
        结果
        创建此频道的提供商

      • open

        public static AsynchronousSocketChannel open​(AsynchronousChannelGroup group)
                                      throws IOException
        打开异步套接字通道。

        新的信道是通过调用创建openAsynchronousSocketChannel的方法AsynchronousChannelProvider创建该组。 如果组参数为null则生成的通道由系统范围的默认提供程序创建，并绑定到默认组 。

        参数
        group - 新建通道应绑定的组，或默认组的 null
        结果
        一个新的异步套接字通道
        异常
        ShutdownChannelGroupException - 如果通道组关闭
        IOException - 如果发生I / O错误

      • open

        public static AsynchronousSocketChannel open​()
                                      throws IOException
        打开异步套接字通道。

        此方法返回绑定到默认组的异步套接字通道。此方法等效于评估表达式：

         open((AsynchronousChannelGroup)null);
        结果
        一个新的异步套接字通道
        异常
        IOException - 如果发生I / O错误

      • bind

        public abstract AsynchronousSocketChannel bind​(SocketAddress local)
                                        throws IOException
        说明从界面NetworkChannel复制
        将通道的套接字绑定到本地地址。

        该方法用于在套接字和本地地址之间建立关联。 一旦建立关联，则套接字保持绑定，直到通道关闭。 如果local参数的值为null则套接字将被绑定到自动分配的地址。

        Specified by:
        bind在接口 NetworkChannel
        参数
        local - 绑定套接字的地址，或 null将套接字绑定到自动分配的套接字地址
        结果
        这个频道
        异常
        ConnectionPendingException - 如果此通道上已经进行了连接操作
        AlreadyBoundException - 如果套接字已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生其他I / O错误
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作
        另请参见：
        NetworkChannel.getLocalAddress()

      • setOption

        public abstract <T> AsynchronousSocketChannel setOption​(SocketOption<T> name,
                                                        T value)
                                                 throws IOException
        说明从界面NetworkChannel复制
        设置套接字选项的值。
        Specified by:
        setOption在接口 NetworkChannel
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能是某些套接字选项的有效值。
        结果
        这个频道
        异常
        IllegalArgumentException - 如果该值不是此套接字选项的有效值
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        另请参见：
        StandardSocketOptions

      • shutdownInput

        public abstract AsynchronousSocketChannel shutdownInput​()
                                                 throws IOException
        关闭连接进行阅读，不关闭频道。

        一旦关闭读取，则通道上的进一步读取将返回-1 ，流末端指示。 如果连接的输入端已经关闭，则调用此方法没有任何作用。 对未完成的读取操作的影响是系统依赖的，因此未指定。 如果有的话，如果套接字接收缓冲区中尚未读取数据或数据到达的影响，也是系统依赖的。

        结果
        这个频道
        异常
        NotYetConnectedException - 如果此通道尚未连接
        ClosedChannelException - 如果此频道关闭
        IOException - 如果发生其他I / O错误

      • shutdownOutput

        public abstract AsynchronousSocketChannel shutdownOutput​()
                                                  throws IOException
        关闭连接以进行写入，而不关闭通道。

        一旦关闭写入，则进一步尝试写入通道将抛出ClosedChannelException 。 如果连接的输出端已经关闭，则调用此方法不起作用。 对未完成的写入操作的影响是依赖于系统的，因此未指定。

        结果
        这个频道
        异常
        NotYetConnectedException - 如果此频道尚未连接
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误

      • getRemoteAddress

        public abstract SocketAddress getRemoteAddress​()
                                        throws IOException
        返回此通道的插座所连接的远程地址。

        通道绑定并连接到Internet协议套接字地址时，此方法的返回值为InetSocketAddress 。

        结果
        远程地址; null如果通道的插座未连接
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误

      • connect

        public abstract <A> void connect​(SocketAddress remote,
                                 A attachment,
                                 CompletionHandler<Void,? super A> handler)
        连接此频道。

        此方法启动连接此通道的操作。 handler参数是一个完成处理程序，在连接成功建立或无法建立连接时调用。 如果无法建立连接，则通道关闭。

        该方法执行与Socket类完全相同的安全检查。 也就是说，如果安装了一个安全管理器，则该方法验证其checkConnect方法是否允许连接到给定远程端点的地址和端口号。

        参数类型
        A - 附件的类型
        参数
        remote - 要连接该通道的远程地址
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消费结果的处理程序
        异常
        UnresolvedAddressException - 如果给定的远程地址未完全解析
        UnsupportedAddressTypeException - 如果不支持给定远程地址的类型
        AlreadyConnectedException - 如果此频道已连接
        ConnectionPendingException - 如果此通道上已经进行了连接操作
        ShutdownChannelGroupException - 如果通道组已终止
        SecurityException - 如果已安装安全管理器，并且不允许访问给定的远程端点
        另请参见：
        getRemoteAddress()

      • connect

        public abstract Future<Void> connect​(SocketAddress remote)
        连接此频道。

        此方法启动连接此通道的操作。 此方法的行为方式与connect(SocketAddress, Object, CompletionHandler)方法完全相同，不同之处在于，该方法不是指定完成处理程序，而是返回表示待处理结果的Future 。 Future的get方法在成功完成后返回null 。

        参数
        remote - 要连接此通道的远程地址
        结果
        表示待处理结果的 Future对象
        异常
        UnresolvedAddressException - 如果给定的远程地址未完全解析
        UnsupportedAddressTypeException - 如果不支持给定远程地址的类型
        AlreadyConnectedException - 如果此频道已连接
        ConnectionPendingException - 如果此通道上已经进行了连接操作
        SecurityException - 如果已安装安全管理器，并且不允许访问给定的远程端点

      • read

        public abstract <A> void read​(ByteBuffer dst,
                              long timeout,
                              TimeUnit unit,
                              A attachment,
                              CompletionHandler<Integer,? super A> handler)
        从该通道读取到给定缓冲区的字节序列。

        该方法启动异步读取操作，以从该通道读取到给定缓冲器中的字节序列。 handler参数是一个完成处理程序，在读取操作完成（或失败）时调用该处理程序。 传递给完成处理程序的结果是读取的字节数或-1如果没有字节可以读取，因为通道已经到达流终止。

        如果指定了超时，并且在操作完成之前超时，则操作将完成，异常InterruptedByTimeoutException 。 在发生超时的情况下，实现不能保证字节未被读取，或者不会从通道读入给定的缓冲区，所以进一步尝试从通道中读取将导致抛出非特定的运行时异常。

        否则该方法的工作方式与AsynchronousByteChannel.read(ByteBuffer,Object,CompletionHandler)方法相同。

        参数类型
        A - 附件的类型
        参数
        dst - 要传输字节的缓冲区
        timeout - 完成I / O操作的最长时间
        unit - timeout参数的时间单位
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消费结果的处理程序
        异常
        IllegalArgumentException - 如果缓冲区是只读的
        ReadPendingException - 如果此通道上的读取操作已在进行中
        NotYetConnectedException - 如果此频道尚未连接
        ShutdownChannelGroupException - 如果通道组已终止

      • read

        public final <A> void read​(ByteBuffer dst,
                           A attachment,
                           CompletionHandler<Integer,? super A> handler)
        说明从接口AsynchronousByteChannel复制
        从该通道读取到给定缓冲区的字节序列。

        该方法启动异步读取操作，以从该通道读取到给定缓冲器中的字节序列。 handler参数是一个完成处理程序，在读取操作完成（或失败）时调用该处理程序。 传递给完成处理程序的结果是读取的字节数或-1如果没有字节可以读取，因为通道已经到达流终止。

        读取操作可以从通道读取r个字节，其中r是缓冲区中剩余的字节数，即在尝试读取时为dst.remaining() 。 其中r为0，读操作立即完成，结果为0而不启动I / O操作。

        假设长度为n的字节序列被读出，其中0 < Ñ <= 河 该字节序列将被转移到缓冲器，使得序列中的第一个字节是在索引p和最后一个字节是在索引p + Ñ - 1 ，其中p为缓冲区的位置在执行读取的时刻。 完成后，缓冲区的位置将等于p + n ; 其限制将不会改变。

        缓冲区不能安全地被多个并发线程使用，因此在操作完成之前，请注意不要访问缓冲区。

        可以随时调用此方法。 某些渠道类型在任何给定时间可能不允许多于一个读取。 如果线程在先前的读取操作完成之前启动了读取操作，那么将抛出一个ReadPendingException 。

        Specified by:
        read在接口 AsynchronousByteChannel
        参数类型
        A - 附件的类型
        参数
        dst - 要传输字节的缓冲区
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 完成处理程序
        异常
        IllegalArgumentException - 如果缓冲区是只读的
        ReadPendingException - 如果通道不允许多个读取未完成，并且以前的读取尚未完成
        NotYetConnectedException - 如果此频道尚未连接
        ShutdownChannelGroupException - 如果通道组已终止

      • read

        public abstract Future<Integer> read​(ByteBuffer dst)
        描述从接口AsynchronousByteChannel复制
        从该通道读取到给定缓冲区的字节序列。

        该方法启动异步读取操作，以从该通道读取到给定缓冲器中的字节序列。 该方法的行为方式与read(ByteBuffer,Object,CompletionHandler)方法完全相同，不同的是，该方法不是指定完成处理程序，而是返回表示待处理结果的Future 。 Future的get方法返回读取的字节数或-1如果没有字节可以读取，因为通道已达到流出尾。

        Specified by:
        read在接口 AsynchronousByteChannel
        参数
        dst - 要传输字节的缓冲区
        结果
        代表操作结果的未来
        异常
        IllegalArgumentException - 如果缓冲区是只读的
        ReadPendingException - 如果通道不允许多个读取未完成，并且以前的读取尚未完成
        NotYetConnectedException - 如果此通道尚未连接

      • read

        public abstract <A> void read​(ByteBuffer[] dsts,
                              int offset,
                              int length,
                              long timeout,
                              TimeUnit unit,
                              A attachment,
                              CompletionHandler<Long,? super A> handler)
        从该通道读取字节序列到给定缓冲区的子序列中。 这种操作（有时称为散射读取 ）通常在实现将数据分组成由一个或多个固定长度的标题后跟可变长度主体组成的段的网络协议时很有用。 handler参数是一个完成处理程序，在读取操作完成（或失败）时调用该处理程序。 传递给完成处理程序的结果是读取的字节数或-1如果没有字节可以读取，因为通道已达到流出尾。

        该方法从该通道开始读取最多r个字节，其中r是给定缓冲区数组的指定子序列中剩余的总字节数，也就是说，

         dsts[offset].remaining()
     + dsts[offset+1].remaining()
     + ... + dsts[offset+length-1].remaining()
        在尝试阅读的时刻。

        假设长度为n的字节序列被读出，其中0 < Ñ <= 河 该序列的最初dsts[offset].remaining()个字节被传送到缓冲区dsts[offset] ，直到下一个dsts[offset+1].remaining()字节被传送到缓冲区dsts[offset+1]等等，直到整个字节序列被传送到给定的缓冲区。 尽可能多的字节被传送到每个缓冲器中，因此除了最后更新的缓冲器之外，每个更新的缓冲器的最终位置被保证等于该缓冲器的限制。 底层操作系统可能对可能在I / O操作中使用的缓冲区数量施加限制。 当缓冲区的数量（剩余字节数）超过此限制时，I / O操作将由操作系统允许的最大缓冲区数来执行。

        如果指定了超时，并且操作完成之前超时已过，则完成异常InterruptedByTimeoutException 。 在发生超时的情况下，实现不能保证字节未被读取，或者不会从通道读入给定的缓冲区，所以进一步尝试从通道中读取将导致抛出非特定的运行时异常。

        参数类型
        A - 附件的类型
        参数
        dsts - 要传输字节的缓冲区
        offset - 要传输字节的第一个缓冲区的缓冲区数组中的偏移量; 必须是非负数，不得大于dsts.length
        length - 要访问的缓冲区的最大数量; 必须是非负数，不得大于dsts.length - offset
        timeout - 完成I / O操作的最长时间
        unit - timeout参数的时间单位
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消费结果的处理程序
        异常
        IndexOutOfBoundsException - 如果不符合 offset和 length参数的前提条件
        IllegalArgumentException - 如果缓冲区是只读的
        ReadPendingException - 如果此通道上的读取操作已在进行中
        NotYetConnectedException - 如果此通道尚未连接
        ShutdownChannelGroupException - 如果通道组已终止

      • write

        public abstract <A> void write​(ByteBuffer src,
                               long timeout,
                               TimeUnit unit,
                               A attachment,
                               CompletionHandler<Integer,? super A> handler)
        从给定的缓冲区向该通道写入一个字节序列。

        该方法启动异步写入操作，以从给定的缓冲区向该通道写入字节序列。 handler参数是在写操作完成（或失败）时调用的完成处理程序。 传递给完成处理程序的结果是写入的字节数。

        如果指定了超时，并且操作完成之前超时已过，则完成异常InterruptedByTimeoutException 。 在发生超时的情况下，实现不能保证字节未被写入或不会从给定缓冲区写入通道，所以进一步尝试写入通道将导致抛出非特定的运行时异常。

        否则，此方法的工作方式与AsynchronousByteChannel.write(ByteBuffer,Object,CompletionHandler)方法相同。

        参数类型
        A - 附件的类型
        参数
        src - 要检索字节的缓冲区
        timeout - 完成I / O操作的最长时间
        unit - timeout参数的时间单位
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消费结果的处理程序
        异常
        WritePendingException - 如果此通道上的写操作已在进行中
        NotYetConnectedException - 如果此通道尚未连接
        ShutdownChannelGroupException - 如果通道组已经终止

      • write

        public final <A> void write​(ByteBuffer src,
                            A attachment,
                            CompletionHandler<Integer,? super A> handler)
        说明从界面AsynchronousByteChannel复制
        从给定的缓冲区向该通道写入一个字节序列。

        该方法启动异步写入操作，以从给定的缓冲区向该通道写入字节序列。 handler参数是在写操作完成（或失败）时调用的完成处理程序。 传递给完成处理程序的结果是写入的字节数。

        写入操作可以写入r字节到通道，其中r是缓冲区中剩余的字节数，即在尝试写入时的src.remaining() 。 其中r为0，写操作立即完成，结果为0而不启动I / O操作。

        假设长度为n的字节序列写入，其中0 < Ñ <= 河 该字节序列将从索引p开始从缓冲区传送，其中p是执行写入时的缓冲区的位置; 写入的最后一个字节的索引将为p + n - 1 。 完成后，缓冲区的位置将等于p + n ; 其限制将不会改变。

        缓冲区不能安全地被多个并发线程使用，因此在操作完成之前，请注意不要访问缓冲区。

        可以随时调用此方法。 某些频道类型可能不允许在任何给定时间多出一个写入。 如果线程在先前写入操作完成之前启动写入操作，那么将抛出一个WritePendingException 。

        Specified by:
        write在接口 AsynchronousByteChannel
        参数类型
        A - 附件的类型
        参数
        src - 要检索字节的缓冲区
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 完成处理程序对象
        异常
        WritePendingException - 如果通道不允许多个写入未完成，并且以前的写入尚未完成
        NotYetConnectedException - 如果此频道尚未连接
        ShutdownChannelGroupException - 如果通道组已经终止

      • write

        public abstract Future<Integer> write​(ByteBuffer src)
        说明从接口AsynchronousByteChannel复制
        从给定的缓冲区向该通道写入一个字节序列。

        该方法启动异步写入操作，以从给定的缓冲区向该通道写入字节序列。 该方法的行为方式与write(ByteBuffer,Object,CompletionHandler)方法完全相同，不同的是，该方法不是指定一个完成处理程序，而是返回一个Future表示待处理结果。 Future的get方法返回写入的字节数。

        Specified by:
        write在接口 AsynchronousByteChannel
        参数
        src - 要检索字节的缓冲区
        结果
        代表操作结果的未来
        异常
        WritePendingException - 如果通道不允许多个写入未完成，并且以前的写入尚未完成
        NotYetConnectedException - 如果此通道尚未连接

      • write

        public abstract <A> void write​(ByteBuffer[] srcs,
                               int offset,
                               int length,
                               long timeout,
                               TimeUnit unit,
                               A attachment,
                               CompletionHandler<Long,? super A> handler)
        从给定缓冲区的子序列将一个字节序列写入该通道。 这种操作（有时称为采集写入 ）通常用于实现将数据分组到由一个或多个固定长度的标题后跟可变长度主体组成的段的网络协议。 handler参数是在写操作完成（或失败）时调用的完成处理程序。 传递给完成处理程序的结果是写入的字节数。

        该方法启动对该通道的最多r个字节的写入，其中r是给定缓冲区数组的指定子序列中剩余的总字节数，也就是说，

         srcs[offset].remaining()
     + srcs[offset+1].remaining()
     + ... + srcs[offset+length-1].remaining()
        在尝试写入的时刻。

        假设写入长度为n的字节序列，其中0 < n <= r 。 直到该序列的第一个srcs[offset].remaining()字节从缓冲器srcs[offset]写入，直到下一个srcs[offset+1].remaining()字节从缓冲器srcs[offset+1]写入，等等，直到整个字节序列被写入。 尽可能多的字节从每个缓冲区写入，因此除了最后更新的缓冲区之外，每个更新的缓冲区的最终位置被保证等于该缓冲区的限制。 底层操作系统可能对可能在I / O操作中使用的缓冲区数量施加限制。 当缓冲区的数量（剩余字节数）超过此限制时，I / O操作将由操作系统允许的最大缓冲区数来执行。

        如果指定了超时，并且操作完成之前超时已过，则完成异常InterruptedByTimeoutException 。 在发生超时的情况下，实现不能保证字节未被写入，或者不会从给定的缓冲区写入通道，所以进一步尝试写入通道将导致抛出非特定的运行时异常。

        参数类型
        A - 附件的类型
        参数
        srcs - 要检索字节的缓冲区
        offset - 要检索字节的第一个缓冲区的缓冲区数组中的偏移量; 必须是非负数，不得大于srcs.length
        length - 要访问的缓冲区的最大数量; 必须是非负数，不得大于srcs.length - offset
        timeout - 完成I / O操作的最长时间
        unit - timeout参数的时间单位
        attachment - 要附加到I / O操作的对象; 可以是null
        handler - 消费结果的处理程序
        异常
        IndexOutOfBoundsException - 如果不符合 offset和 length参数的前提条件
        WritePendingException - 如果此通道上的写操作已经进行中
        NotYetConnectedException - 如果此频道尚未连接
        ShutdownChannelGroupException - 如果通道组已经终止

      • getLocalAddress

        public abstract SocketAddress getLocalAddress​()
                                       throws IOException
        返回此通道的套接字所绑定的套接字地址。

        通道为Internet协议套接字地址的bound ，则此方法的返回值为InetSocketAddress 。

        如果有一个安全管理器设置，它的checkConnect方法被调用本地地址和-1作为参数来查看是否允许该操作。 如果不允许操作，则SocketAddress表示loopback地址的SocketAddress和通道套接字的本地端口。

        Specified by:
        getLocalAddress在接口 NetworkChannel
        结果
        该 SocketAddress的套接字绑定到，或 SocketAddress代表的环回地址，如果安全管理器拒绝，或者 null如果通道的套接字不绑定
        异常
        ClosedChannelException - 如果通道关闭
        IOException - If an I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface ByteChannel

  • All Superinterfaces:
    AutoCloseable ， Channel ， Closeable ， ReadableByteChannel ， WritableByteChannel
    All Known Subinterfaces:
    SeekableByteChannel
    所有已知实现类：
    DatagramChannel ， FileChannel ， SocketChannel

    public interface ByteChannel
extends ReadableByteChannel, WritableByteChannel
    一个可以读写字节的通道。 该接口简单统一ReadableByteChannel和WritableByteChannel ; 它没有指定任何新的操作。
    从以下版本开始：
    1.4

    • 方法摘要

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from interface java.nio.channels.ReadableByteChannel

        read

      • Methods inherited from interface java.nio.channels.WritableByteChannel

        write
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CancelledKeyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class CancelledKeyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.CancelledKeyException
  • All Implemented Interfaces:
    Serializable

    public class CancelledKeyException
extends IllegalStateException
    当试图使用不再有效的选择键时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CancelledKeyException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CancelledKeyException

        public CancelledKeyException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Channel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface Channel

  • All Superinterfaces:
    AutoCloseable ， Closeable
    All Known Subinterfaces:
    AsynchronousByteChannel ， AsynchronousChannel ， ByteChannel ， GatheringByteChannel ， InterruptibleChannel ， MulticastChannel ， NetworkChannel ， ReadableByteChannel ， ScatteringByteChannel ， SeekableByteChannel ， WritableByteChannel
    所有已知实现类：
    AbstractInterruptibleChannel ， AbstractSelectableChannel ， AsynchronousFileChannel ， AsynchronousServerSocketChannel ， AsynchronousSocketChannel ， DatagramChannel ， FileChannel ， Pipe.SinkChannel ， Pipe.SourceChannel ， SctpChannel ， SctpMultiChannel ， SctpServerChannel ， SelectableChannel ， ServerSocketChannel ， SocketChannel

    public interface Channel
extends Closeable
    I / O操作的联系。

    信道表示与诸如硬件设备，文件，网络套接字或能够执行一个或多个不同I / O操作（例如读取或写入）的程序组件的实体的开放连接。

    通道是打开的还是关闭的。 一个通道在创建时打开，一旦关闭，它仍然关闭。 一旦通道关闭，任何尝试调用I / O操作将导致抛出ClosedChannelException 。 频道是否打开可以通过调用其isOpen方法进行测试。

    一般来说，通道旨在为多线程访问安全，如扩展和实现此接口的接口和类的规范中所述。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭此频道。
      boolean isOpen​()
      告诉这个频道是否开放。

    • 方法详细信息

      • isOpen

        boolean isOpen​()
        告诉这个频道是否开放。
        结果
        true如果，只有这个频道是开放的

      • close

        void close​()
    throws IOException
        关闭此频道。

        关闭通道后，任何进一步调用I / O操作的尝试将导致抛出ClosedChannelException 。

        如果此通道已经关闭，则调用此方法不起作用。

        可以随时调用此方法。 然而，如果一些其他线程已经调用了它，那么另一个调用将阻塞，直到第一次调用完成，之后它将不起作用。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - If an I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Channels (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class Channels

  • java.lang.Object
    • java.nio.channels.Channels

  • public final class Channels
extends Object
    通道和流的实用方法。

    该类定义了支持java.io包的流类与此包的通道类的互操作的静态方法。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ReadableByteChannel newChannel​(InputStream in)
      构造从给定流读取字节的通道。
      static WritableByteChannel newChannel​(OutputStream out)
      构造一个向给定流写入字节的通道。
      static InputStream newInputStream​(AsynchronousByteChannel ch)
      构造从给定通道读取字节的流。
      static InputStream newInputStream​(ReadableByteChannel ch)
      构造从给定通道读取字节的流。
      static OutputStream newOutputStream​(AsynchronousByteChannel ch)
      构造将字节写入给定通道的流。
      static OutputStream newOutputStream​(WritableByteChannel ch)
      构造将字节写入给定通道的流。
      static Reader newReader​(ReadableByteChannel ch, String csName)
      构造一个读取器，根据命名的字符集解码来自给定通道的字节。
      static Reader newReader​(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap)
      构造一个读取器，使用给定的解码器解码来自给定通道的字节。
      static Writer newWriter​(WritableByteChannel ch, String csName)
      构造一个根据命名的字符集对字符进行编码的写入程序，并将生成的字节写入给定的通道。
      static Writer newWriter​(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap)
      构造一个使用给定编码器编码字符的写入器，并将生成的字节写入给定的通道。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • newInputStream

        public static InputStream newInputStream​(ReadableByteChannel ch)
        构造从给定通道读取字节的流。

        如果在底层通道处于非阻塞模式时调用，则产生的流的read方法将抛出IllegalBlockingModeException 。 流不会被缓冲，并且不支持mark或reset方法。 流可以安全地访问多个并发线程。 关闭流将反过来导致通道关闭。

        参数
        ch - 读取字节的通道
        结果
        一个新的输入流

      • newOutputStream

        public static OutputStream newOutputStream​(WritableByteChannel ch)
        构造将字节写入给定通道的流。

        如果在基础通道处于非阻塞模式时调用，则产生的流的write方法将抛出IllegalBlockingModeException 。 流不会被缓冲。 流可以安全地访问多个并发线程。 关闭流将反过来导致通道关闭。

        参数
        ch - 要写入字节的通道
        结果
        一个新的输出流

      • newInputStream

        public static InputStream newInputStream​(AsynchronousByteChannel ch)
        构造从给定通道读取字节的流。

        流不会被缓冲，并且不支持mark或reset方法。 流可以安全地访问多个并发线程。 关闭流将反过来导致通道关闭。

        参数
        ch - 读取字节的通道
        结果
        一个新的输入流
        从以下版本开始：
        1.7

      • newOutputStream

        public static OutputStream newOutputStream​(AsynchronousByteChannel ch)
        构造将字节写入给定通道的流。

        流不会被缓冲。 流可以安全地访问多个并发线程。 关闭流将反过来导致通道关闭。

        参数
        ch - 要写入字节的通道
        结果
        一个新的输出流
        从以下版本开始：
        1.7

      • newChannel

        public static ReadableByteChannel newChannel​(InputStream in)
        构造从给定流读取字节的通道。

        结果通道不会被缓冲; 它将简单地将其I / O操作重定向到给定流。 关闭通道又会导致流关闭。

        参数
        in - 要读取字节的流
        结果
        一个新的可读字节通道

      • newChannel

        public static WritableByteChannel newChannel​(OutputStream out)
        构造一个向给定流写入字节的通道。

        结果通道不会被缓冲; 它将简单地将其I / O操作重定向到给定流。 关闭通道又会导致流关闭。

        参数
        out - 要写入字节的流
        结果
        一个新的可写字节通道

      • newReader

        public static Reader newReader​(ReadableByteChannel ch,
                               CharsetDecoder dec,
                               int minBufferCap)
        构造一个读取器，使用给定的解码器解码来自给定通道的字节。

        所得到的流将包含至少minBufferCap个字节的内部输入缓冲区。 根据需要，流的read方法将通过从底层通道读取字节来填充缓冲区; 如果要读取字节时通道处于非阻塞模式，则将抛出IllegalBlockingModeException 。 所得到的流将不会被缓冲，并且不支持mark或reset方法。 关闭流将反过来导致通道关闭。

        参数
        ch - 从中读取字节的通道
        dec - 要使用的字符集解码器
        minBufferCap - 内部字节缓冲区的最小容量，如果要使用实现相关的默认容量， -1
        结果
        一个新的读者

      • newReader

        public static Reader newReader​(ReadableByteChannel ch,
                               String csName)
        构造一个读取器，根据命名的字符集解码来自给定通道的字节。

        调用此方法的形式

           Channels.newReader(ch, csname)
        表现方式与表达式完全相同
           Channels.newReader(ch, Charset.forName(csName).newDecoder(), -1)
        参数
        ch - 读取字节的通道
        csName - 要使用的字符集的名称
        结果
        一个新的读者
        异常
        UnsupportedCharsetException - 如果在Java虚拟机的此实例中不支持命名的字符集

      • newWriter

        public static Writer newWriter​(WritableByteChannel ch,
                               CharsetEncoder enc,
                               int minBufferCap)
        构造一个使用给定编码器编码字符的写入器，并将生成的字节写入给定的通道。

        结果流将包含至少minBufferCap字节的内部输出缓冲区。 流的write方法将根据需要通过向基础通道写入字节来刷新缓冲区; 如果要写入字节时通道处于非阻塞模式，则将抛出IllegalBlockingModeException 。 所得到的流将不会被缓冲。 关闭流将反过来导致通道关闭。

        参数
        ch - 要写入字节的通道
        enc - 要使用的字符集编码器
        minBufferCap - 内部字节缓冲区的最小容量，如果要使用实现相关的默认容量， -1
        结果
        一个新作家

      • newWriter

        public static Writer newWriter​(WritableByteChannel ch,
                               String csName)
        构造一个根据命名的字符集对字符进行编码的写入程序，并将生成的字节写入给定的通道。

        调用此方法的形式

           Channels.newWriter(ch, csname)
        表现方式与表达式完全相同
           Channels.newWriter(ch, Charset.forName(csName).newEncoder(), -1)
        参数
        ch - 要写入字节的通道
        csName - 要使用的字符集的名称
        结果
        一个新作家
        异常
        UnsupportedCharsetException - 如果在Java虚拟机的此实例中不支持命名的字符集
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClosedByInterruptException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class ClosedByInterruptException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.channels.ClosedChannelException
            • java.nio.channels.AsynchronousCloseException
              • java.nio.channels.ClosedByInterruptException
  • All Implemented Interfaces:
    Serializable

    public class ClosedByInterruptException
extends AsynchronousCloseException
    另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。 在引发异常之前，通道将被关闭，并且先前阻止的线程的中断状态将被设置。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClosedByInterruptException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClosedByInterruptException

        public ClosedByInterruptException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClosedChannelException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class ClosedChannelException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.channels.ClosedChannelException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AsynchronousCloseException

    public class ClosedChannelException
extends IOException
    当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。 抛出此异常并不一定意味着该通道完全关闭。 例如，写半封闭的插座通道仍然可以打开以供阅读。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClosedChannelException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClosedChannelException

        public ClosedChannelException​()
        Constructs an instance of this class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClosedSelectorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class ClosedSelectorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.ClosedSelectorException
  • All Implemented Interfaces:
    Serializable

    public class ClosedSelectorException
extends IllegalStateException
    尝试在闭合选择器上调用I / O操作时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClosedSelectorException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClosedSelectorException

        public ClosedSelectorException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompletionHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface CompletionHandler<V,A>

  • 参数类型
    V - I / O操作的结果类型
    A - 附加到I / O操作的对象的类型

    public interface CompletionHandler<V,A>
    用于消除异步I / O操作结果的处理程序。

    在此包中定义的异步通道允许指定完成处理程序以消耗异步操作的结果。 当I / O操作成功完成时，将调用completed方法。 如果I / O操作失败，则调用failed方法。 这些方法的实现应该及时完成，以避免将调用线程调度到其他完成处理程序。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void completed​(V result, A attachment)
      操作完成后调用。
      void failed​(Throwable exc, A attachment)
      当操作失败时调用。

    • 方法详细信息

      • completed

        void completed​(V result,
               A attachment)
        操作完成后调用。
        参数
        result - I / O操作的结果。
        attachment - 启动时附加到I / O操作的对象。

      • failed

        void failed​(Throwable exc,
            A attachment)
        当操作失败时调用。
        参数
        exc - 表示I / O操作失败的原因的例外
        attachment - 启动时附加到I / O操作的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConnectionPendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class ConnectionPendingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.ConnectionPendingException
  • All Implemented Interfaces:
    Serializable

    public class ConnectionPendingException
extends IllegalStateException
    尝试连接未阻塞连接操作的SocketChannel时，会引发未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConnectionPendingException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ConnectionPendingException

        public ConnectionPendingException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DatagramChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class DatagramChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.DatagramChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， ByteChannel ， Channel ， GatheringByteChannel ， InterruptibleChannel ， MulticastChannel ， NetworkChannel ， ReadableByteChannel ， ScatteringByteChannel ， WritableByteChannel

    public abstract class DatagramChannel
extends AbstractSelectableChannel
implements ByteChannel, ScatteringByteChannel, GatheringByteChannel, MulticastChannel
    面向数据报的套接字的可选通道。

    通过调用此类的open方法之一创建数据报通道。 不可能为任意的，预先存在的数据报套接字创建一个通道。 新创建的数据报通道已打开但未连接。 无需连接数据报通道，以便使用send和receive方法。 可以通过调用其connect方法来连接数据报信道 ，以避免安全检查的开销作为每个发送和接收操作的一部分。 必须连接数据报通道才能使用read和write方法，因为这些方法不接受或返回套接字地址。

    一旦连接，数据报通道保持连接，直到断开或关闭。 数据报信道是否连接可以通过调用其isConnected方法来确定。

    套接字选项使用setOption方法进行配置。 Internet协议套接字的数据报通道支持以下选项：

    Socket options
    Option Name | 描述
    SO_SNDBUF | The size of the socket send buffer
    SO_RCVBUF | The size of the socket receive buffer
    SO_REUSEADDR | Re-use address
    SO_BROADCAST | Allow transmission of broadcast datagrams
    IP_TOS | The Type of Service (ToS) octet in the Internet Protocol (IP) header
    IP_MULTICAST_IF | The network interface for Internet Protocol (IP) multicast datagrams
    IP_MULTICAST_TTL | The time-to-live for Internet Protocol (IP) multicast datagrams
    IP_MULTICAST_LOOP | Loopback for Internet Protocol (IP) multicast datagrams
    还可以支持附加（实现特定）选项。

    数据报通道可以安全使用多个并发线程。 他们支持并发阅读和写作，尽管最多只有一个线程可能正在读取，并且最多一个线程可能在任何给定的时间写入。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected DatagramChannel​(SelectorProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract DatagramChannel bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      abstract DatagramChannel connect​(SocketAddress remote)
      连接此通道的插座。
      abstract DatagramChannel disconnect​()
      断开此通道的插座。
      abstract SocketAddress getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress getRemoteAddress​()
      返回此通道的插座所连接的远程地址。
      abstract boolean isConnected​()
      告诉这个通道的插座是否连接。
      static DatagramChannel open​()
      打开数据报通道。
      static DatagramChannel open​(ProtocolFamily family)
      打开数据报通道。
      abstract int read​(ByteBuffer dst)
      从此频道读取数据报。
      long read​(ByteBuffer[] dsts)
      从此频道读取数据报。
      abstract long read​(ByteBuffer[] dsts, int offset, int length)
      从此频道读取数据报。
      abstract SocketAddress receive​(ByteBuffer dst)
      通过该频道接收数据报。
      abstract int send​(ByteBuffer src, SocketAddress target)
      通过此频道发送数据报。
      abstract <T> DatagramChannel setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      abstract DatagramSocket socket​()
      检索与此通道相关联的数据报套接字。
      int validOps​()
      返回确定此频道支持的操作的操作集。
      abstract int write​(ByteBuffer src)
      将数据报写入此通道。
      long write​(ByteBuffer[] srcs)
      将数据报写入此通道。
      abstract long write​(ByteBuffer[] srcs, int offset, int length)
      将数据报写入此通道。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, isOpen

      • Methods inherited from class java.nio.channels.spi.AbstractSelectableChannel

        blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register

      • Methods inherited from interface java.nio.channels.Channel

        isOpen

      • Methods inherited from interface java.nio.channels.MulticastChannel

        close, join, join

      • Methods inherited from interface java.nio.channels.NetworkChannel

        getOption, supportedOptions

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.SelectableChannel

        register

    • 构造方法详细信息

      • DatagramChannel

        protected DatagramChannel​(SelectorProvider provider)
        初始化此类的新实例。
        参数
        provider - 创建此频道的提供商

    • 方法详细信息

      • open

        public static DatagramChannel open​()
                            throws IOException
        打开数据报通道。

        新通道是通过调用系统范围默认的SelectorProvider对象的openDatagramChannel方法创建的。 通道不会连接。

        通道插座的ProtocolFamily是平台（可能是配置）依赖，因此未指定。 open允许在打开数据报通道时选择协议族，并且应该用于打开用于Internet协议组播的数据报通道。

        结果
        一个新的数据报通道
        异常
        IOException - 如果发生I / O错误

      • open

        public static DatagramChannel open​(ProtocolFamily family)
                            throws IOException
        打开数据报通道。

        family参数用于指定ProtocolFamily 。 如果要将数据报通道用于IP组播，则应该与该通道将加入的组播组的地址类型相对应。

        新通道是通过调用系统范围默认的SelectorProvider对象的openDatagramChannel方法创建的。 通道不会连接。

        参数
        family - 协议族
        结果
        一个新的数据报通道
        异常
        UnsupportedOperationException - 如果不支持指定的协议族。 例如，假设参数被指定为StandardProtocolFamily.INET6，但是平台上未启用IPv6。
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.7

      • validOps

        public final int validOps​()
        返回确定此频道支持的操作的操作集。

        数据报通道支持读写，所以此方法返回( SelectionKey.OP_READ | SelectionKey.OP_WRITE ) 。

        Specified by:
        validOps在 SelectableChannel
        结果
        有效操作集

      • bind

        public abstract DatagramChannel bind​(SocketAddress local)
                              throws IOException
        描述从接口NetworkChannel复制
        将通道的套接字绑定到本地地址。

        该方法用于在套接字和本地地址之间建立关联。 一旦建立关联，则套接字保持绑定，直到通道关闭。 如果local参数的值为null则套接字将被绑定到自动分配的地址。

        Specified by:
        bind在接口 NetworkChannel
        参数
        local - 绑定套接字的地址，或 null将套接字绑定到自动分配的套接字地址
        结果
        这个频道
        异常
        AlreadyBoundException - 如果套接字已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生其他I / O错误
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作
        从以下版本开始：
        1.7
        另请参见：
        NetworkChannel.getLocalAddress()

      • setOption

        public abstract <T> DatagramChannel setOption​(SocketOption<T> name,
                                              T value)
                                       throws IOException
        说明从界面NetworkChannel复制
        设置套接字选项的值。
        Specified by:
        setOption在接口 NetworkChannel
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能是某些套接字选项的有效值。
        结果
        这个频道
        异常
        UnsupportedOperationException - 如果此通道不支持套接字选项
        IllegalArgumentException - 如果该值不是此套接字选项的有效值
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.7
        另请参见：
        StandardSocketOptions

      • socket

        public abstract DatagramSocket socket​()
        检索与此通道相关联的数据报套接字。

        返回的对象不会声明任何未在DatagramSocket类中声明的公共方法。

        结果
        与此通道相关联的数据报套接字

      • isConnected

        public abstract boolean isConnected​()
        告诉这个通道的插座是否连接。
        结果
        true如果，且仅当此通道的插座是 open并连接

      • connect

        public abstract DatagramChannel connect​(SocketAddress remote)
                                 throws IOException
        连接此通道的插座。

        通道的套接字被配置为仅从给定的远程对等地址接收数据报，并发送数据报。 一旦连接，数据报可能不会被接收或发送到任何其他地址。 数据报套接字保持连接，直到它被明确地断开或直到它被关闭。

        该方法执行与DatagramSocket类的connect方法完全相同的安全检查。 也就是说，如果已经安装了安全管理器，则该方法验证其270560369231283和checkConnect方法是否允许分别从给定的远程地址接收数据报并将其发送给给定的远程地址。

        可以随时调用此方法。 它在对被调用的时刻已经进行的读取或写入操作不会有任何影响。 如果此通道的套接字未绑定，则此方法将首先使套接字绑定到自动分配的地址，就像调用参数为null的bind方法null 。

        参数
        remote - 要连接该通道的远程地址
        结果
        这个数据报通道
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在连接操作进行过程中关闭此通道
        ClosedByInterruptException - 如果另一个线程在连接操作进行过程中中断当前线程，从而关闭通道并设置当前线程的中断状态
        SecurityException - 如果已安装安全管理器，并且不允许访问指定的远程地址
        IOException - 如果发生其他I / O错误

      • disconnect

        public abstract DatagramChannel disconnect​()
                                    throws IOException
        断开此通道的插座。

        通道的套接字被配置为使得它可以从任何远程地址接收数据报，并发送数据报，只要安全管理器（如果已安装）就允许它。

        可以随时调用此方法。 它在对被调用的时刻已经进行的读取或写入操作不会有任何影响。

        如果此通道的插座未连接，或者通道关闭，则调用此方法不起作用。

        结果
        这个数据报通道
        异常
        IOException - 如果发生其他I / O错误

      • getRemoteAddress

        public abstract SocketAddress getRemoteAddress​()
                                        throws IOException
        返回此通道的插座所连接的远程地址。
        结果
        远程地址; null如果通道的插座未连接
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.7

      • receive

        public abstract SocketAddress receive​(ByteBuffer dst)
                               throws IOException
        通过该频道接收数据报。

        如果数据报可以立即可用，或者如果此通道处于阻塞模式，并且最终变为可用，则将数据报复制到给定的字节缓冲区中，并返回其源地址。 如果此通道处于非阻塞模式，并且数据报不能立即可用，则此方法立即返回null 。

        数据报从当前位置开始传输到给定的字节缓冲区，就像通常的read操作一样。 如果缓冲区中剩余的字节比保存数据报所需的字节少，则数据报的其余部分将被静默地丢弃。

        该方法执行与DatagramSocket类的receive方法完全相同的安全检查。 也就是说，如果套接字没有连接到特定的远程地址，并且已经安装了安全管理器，那么对于接收到的每个数据报，此方法验证安全管理器的checkAccept方法是否允许源的地址和端口号。 首先通过connect方法连接插座可以避免此安全检查的开销。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了读取操作，那么此方法的调用将阻塞，直到第一个操作完成。 如果此通道的套接字未绑定，则此方法将首先使套接字绑定到自动分配的地址，就像调用参数为null的bind方法null 。

        参数
        dst - 要传输数据报的缓冲区
        结果
        数据报的源地址，或 null如果此通道处于非阻塞模式，并且没有数据报立即可用
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        SecurityException - 如果已安装安全管理器，并且不允许从数据报发件人接受数据报
        IOException - 如果发生其他I / O错误

      • send

        public abstract int send​(ByteBuffer src,
                         SocketAddress target)
                  throws IOException
        通过此频道发送数据报。

        如果该通道处于非阻塞模式，并且底层输出缓冲区中有足够的空间，或者如果该通道处于阻塞模式并且充足的空间变得可用，则给定缓冲区中的剩余字节作为单个数据报传输到给定目标地址。

        数据报从字节缓冲区传输，就像通过常规的write操作一样。

        该方法执行与DatagramSocket类的send方法完全相同的安全检查。 也就是说，如果套接字未连接到特定的远程地址，并且已安装安全管理器，则对于发送的每个数据报，此方法验证安全管理器的checkConnect方法允许目标地址和端口号。 首先通过connect方法连接插座可以避免此安全检查的开销。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了写入操作，那么此方法的调用将阻塞，直到第一个操作完成。 如果此通道的套接字未绑定，则此方法将首先使套接字绑定到自动分配的地址，如同通过调用参数为null的bind方法null 。

        参数
        src - 包含要发送的数据报的缓冲区
        target - 要发送数据报的地址
        结果
        发送的字节数，这是调用此方法时在源缓冲区中剩余的字节数，或者如果此通道不阻塞，则可能为零，如果底层中的数据报的空间不足输出缓冲区
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        SecurityException - 如果已安装安全管理器，并且不允许将数据报发送到给定地址
        IOException - 如果发生其他I / O错误

      • read

        public abstract int read​(ByteBuffer dst)
                  throws IOException
        从此频道读取数据报。

        此方法只能在该通道的套接字连接时被调用，并且只接受套接字对等体的数据报。 如果数据报中存在比保留在给定缓冲区中更多的字节，则数据报的其余部分将被静默地丢弃。 否则，此方法的行为与ReadableByteChannel界面中的规定完全相同。

        Specified by:
        read在接口 ReadableByteChannel
        参数
        dst - 要传输字节的缓冲区
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        NotYetConnectedException - 如果此通道的插座未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • read

        public abstract long read​(ByteBuffer[] dsts,
                          int offset,
                          int length)
                   throws IOException
        从此频道读取数据报。

        此方法只能在该通道的套接字连接时被调用，并且只接受套接字对等体的数据报。 如果数据报中存在比保留在给定缓冲区中更多的字节，则数据报的其余部分将被静默地丢弃。 否则，此方法的行为与ScatteringByteChannel接口中的规定完全相同。

        Specified by:
        read在接口 ScatteringByteChannel
        参数
        dsts - 要传输字节的缓冲区
        offset - 要传输字节的第一个缓冲区的缓冲区中的偏移量; 必须是非负数，不得大于dsts.length
        length - 要访问的缓冲区的最大数量; 必须是非负数，不得大于dsts.length - offset
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        NotYetConnectedException - 如果此通道的插座未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • read

        public final long read​(ByteBuffer[] dsts)
                throws IOException
        从此频道读取数据报。

        此方法只能在该通道的套接字连接时被调用，并且只接受套接字对等体的数据报。 如果数据报中存在比保留在给定缓冲区中更多的字节，则数据报的其余部分将被静默地丢弃。 否则，此方法的行为与ScatteringByteChannel接口中的规定完全相同。

        Specified by:
        read在接口 ScatteringByteChannel
        参数
        dsts - 要传输字节的缓冲区
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        NotYetConnectedException - 如果此通道的插座未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public abstract int write​(ByteBuffer src)
                   throws IOException
        将数据报写入此通道。

        此方法只能在该通道的套接字连接时被调用，在这种情况下，它将数据报直接发送到套接字的对等体。 否则它的行为与WritableByteChannel界面中的规定完全相同。

        Specified by:
        write在接口 WritableByteChannel
        参数
        src - 要检索字节的缓冲区
        结果
        写入的字节数，可能为零
        异常
        NotYetConnectedException - 如果此通道的插座未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写入操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public abstract long write​(ByteBuffer[] srcs,
                           int offset,
                           int length)
                    throws IOException
        将数据报写入此通道。

        此方法只能在该通道的套接字连接时被调用，在这种情况下，它将数据报直接发送到套接字的对等体。 否则它的行为与GatheringByteChannel接口中的规定完全相同。

        Specified by:
        write在接口 GatheringByteChannel
        参数
        srcs - 要检索字节的缓冲区
        offset - 要从中检索字节的第一个缓冲区的缓冲区数组中的偏移量; 必须是非负数，不得大于srcs.length
        length - 要访问的缓冲区的最大数量; 必须是非负数，不得大于srcs.length - offset
        结果
        发送的字节数，这是调用此方法时在源缓冲区中剩余的字节数，或者如果此通道不阻塞，则可能为零，如果底层中的数据报的空间不足输出缓冲区
        异常
        NotYetConnectedException - 如果此通道的插座未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public final long write​(ByteBuffer[] srcs)
                 throws IOException
        将数据报写入此通道。

        此方法只能在该通道的套接字连接时被调用，在这种情况下，它将数据报直接发送到套接字的对等体。 否则它的行为与GatheringByteChannel界面中的规定完全相同。

        Specified by:
        write在接口 GatheringByteChannel
        参数
        srcs - 要检索字节的缓冲区
        结果
        发送的字节数，这是调用此方法时在源缓冲区中剩余的字节数，或者如果此通道不阻塞，则可能为零，如果底层中的数据报的空间不足输出缓冲区
        异常
        NotYetConnectedException - 如果此通道的插座未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • getLocalAddress

        public abstract SocketAddress getLocalAddress​()
                                       throws IOException
        返回此通道的套接字所绑定的套接字地址。

        通道为Internet协议套接字地址的通道为bound ，则此方法的返回值为InetSocketAddress 。

        如果有一个安全管理器集，其checkConnect方法将以本地地址和-1作为参数来调用，以查看是否允许该操作。 如果不允许操作，则SocketAddress表示loopback地址的SocketAddress和通道插座的本地端口。

        Specified by:
        getLocalAddress在接口 NetworkChannel
        结果
        SocketAddress表示该套接字绑定，或 SocketAddress表示环回地址，如果安全管理员拒绝，或 null如果该通道的套接字未绑定
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class FileChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.FileChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， ByteChannel ， Channel ， GatheringByteChannel ， InterruptibleChannel ， ReadableByteChannel ， ScatteringByteChannel ， SeekableByteChannel ， WritableByteChannel

    public abstract class FileChannel
extends AbstractInterruptibleChannel
implements SeekableByteChannel, GatheringByteChannel, ScatteringByteChannel
    用于读取，写入，映射和操作文件的通道。

    文件通道是连接到文件的SeekableByteChannel 。 它的文件中的当前位置可以是queried和modified 。 该文件本身包含一个可变长度的字节序列，可以被读取和写入，并且可以查询其当前的size 。 当字节写入超过其当前大小时，文件的大小增加; 文件大小在truncated时会减小 。 该文件还可以具有一些关联的元数据，例如访问权限，内容类型和最后修改时间; 这个类没有定义元数据访问的方法。

    除了熟悉的字节通道的读，写和关闭操作外，此类定义了以下特定于文件的操作：

    • 字节可以是read或written ，在文件中的绝对位置，不会影响通道的当前位置。

    • 一个文件的区域可能是mapped直接进入内存; 对于大文件，这通常比调用通常的read或write方法要高得多。

    • 对文件进行的更新可能是底层存储设备的forced out ，确保数据在系统崩溃时不会丢失。

    • 字节可以从文件to some other channel和vice versa传送 ，方式可以由许多操作系统进行优化，直接传输到或从文件系统缓存传输。

    • 一个文件的区域可能是locked反对其他程序访问。

    文件通道可以安全使用多个并发线程。 close方法可以随时被调用，由Channel接口指定。 任何涉及频道的位置或可以更改文件大小的操作只能在任何给定的时间进行; 当第一个仍在进行时尝试启动第二个此类操作将阻止，直到第一个操作完成。 其他行动，特别是那些采取明确立场的行为，可以同时进行; 它们是否实际上依赖于潜在的实现，因此是未指定的。

    由该类的实例提供的文件的视图保证与同一程序中其他实例提供的同一文件的其他视图一致。 但是，由于此类的实例提供的视图可能与也可能不一致，这是由于底层操作系统执行的缓存和网络文件系统协议引起的延迟而由其他同时运行的程序所看到的视图。 无论这些其他程序的编写语言如何，以及它们是在同一台机器还是在其他机器上运行，都是如此。 任何这种不一致的确切性质是系统依赖性的，因此是未指定的。

    通过调用此类定义的一个open方法创建文件通道。 的文件信道也可以从现有的得到FileInputStream ， FileOutputStream ，或RandomAccessFile对象通过调用该对象的getChannel方法，它返回被连接到相同的基本文件的文件信道。 在从现有流或随机访问文件获取文件通道的情况下，文件通道的状态与getChannel方法返回通道的对象的状态密切相关。 更改频道的位置，无论是显式地还是通过读取或写入字节，都会改变原始对象的文件位置，反之亦然。 通过文件通道更改文件的长度将会改变通过始发对象所看到的长度，反之亦然。 通过写入字节来更改文件的内容将会改变原始对象所看到的内容，反之亦然。

    在这个类中，这个类指定一个“开放阅读”，“开放写作”或“开放阅读和写作”的实例是必需的。 通过270560335200836实例的getChannel方法获得的频道将被开放供阅读。 通过FileOutputStream实例的getChannel方法获得的通道将被开放供写入。 最后，通过所获得的信道getChannel一个的方法RandomAccessFile实例将是开放的，如果该实例用模式下创建阅读"r"和将开放阅读和如果该实例用模式下创建的写"rw" 。

    打开写入的文件通道可能处于附加模式 ，例如，如果是从通过调用FileOutputStream(File,boolean)构造函数创建的文件输出流获取并传递第二个参数的true 。 在该模式中，相对写入操作的每次调用首先将位置前进到文件的末尾，然后写入所请求的数据。 在单一原子操作中是否提升位置和写入数据是依赖于系统的，因此是未指定的。

    从以下版本开始：
    1.4
    另请参见：
    FileInputStream.getChannel() ，
FileOutputStream.getChannel() ，
RandomAccessFile.getChannel()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  FileChannel.MapMode
      文件映射模式的类型安全枚举。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FileChannel​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void force​(boolean metaData)
      强制将此通道文件的任何更新写入包含该通道的存储设备。
      FileLock lock​()
      获取此通道文件的排他锁。
      abstract FileLock lock​(long position, long size, boolean shared)
      获取此通道文件的给定区域的锁定。
      abstract MappedByteBuffer map​(FileChannel.MapMode mode, long position, long size)
      将此频道文件的区域直接映射到内存中。
      static FileChannel open​(Path path, OpenOption... options)
      打开或创建文件，返回文件通道以访问该文件。
      static FileChannel open​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回文件通道以访问该文件。
      abstract long position​()
      返回此频道的文件位置。
      abstract FileChannel position​(long newPosition)
      设置此通道的文件位置。
      abstract int read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      long read​(ByteBuffer[] dsts)
      从该通道读取到给定缓冲区的字节序列。
      abstract long read​(ByteBuffer[] dsts, int offset, int length)
      从该通道读取字节序列到给定缓冲区的子序列中。
      abstract int read​(ByteBuffer dst, long position)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      abstract long size​()
      返回此通道文件的当前大小。
      abstract long transferFrom​(ReadableByteChannel src, long position, long count)
      从给定的可读字节通道将字节传输到该通道的文件中。
      abstract long transferTo​(long position, long count, WritableByteChannel target)
      将该通道文件的字节传输到给定的可写字节通道。
      abstract FileChannel truncate​(long size)
      将此频道的文件截断为给定大小。
      FileLock tryLock​()
      尝试获取此频道文件的排他锁。
      abstract FileLock tryLock​(long position, long size, boolean shared)
      尝试获取此通道文件的给定区域的锁定。
      abstract int write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      long write​(ByteBuffer[] srcs)
      从给定的缓冲区向该通道写入一系列字节。
      abstract long write​(ByteBuffer[] srcs, int offset, int length)
      从给定缓冲区的子序列将一个字节序列写入该通道。
      abstract int write​(ByteBuffer src, long position)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, implCloseChannel, isOpen

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileChannel

        protected FileChannel​()
        初始化此类的新实例。

    • 方法详细信息

      • open

        public static FileChannel open​(Path path,
                               Set<? extends OpenOption> options,
                               FileAttribute<?>... attrs)
                        throws IOException
        打开或创建文件，返回文件通道以访问该文件。

        options参数确定文件的打开方式。 READ和WRITE选项确定文件是否应打开以进行读取和/或写入。 如果数组中没有包含选项（或APPEND选项），则打开文件进行阅读。 默认情况下，文件开始时开始读写。

        除了READ和WRITE ，还可能存在以下选项：

        additional options Option Description APPEND If this option is present then the file is opened for writing and each invocation of the channel's write method first advances the position to the end of the file and then writes the requested data. Whether the advancement of the position and the writing of the data are done in a single atomic operation is system-dependent and therefore unspecified. This option may not be used in conjunction with the READ or TRUNCATE_EXISTING options. TRUNCATE_EXISTING If this option is present then the existing file is truncated to a size of 0 bytes. This option is ignored when the file is opened only for reading. CREATE_NEW If this option is present then a new file is created, failing if the file already exists. When creating a file the check for the existence of the file and the creation of the file if it does not exist is atomic with respect to other file system operations. This option is ignored when the file is opened only for reading. CREATE If this option is present then an existing file is opened if it exists, otherwise a new file is created. When creating a file the check for the existence of the file and the creation of the file if it does not exist is atomic with respect to other file system operations. This option is ignored if the CREATE_NEW option is also present or the file is opened only for reading. DELETE_ON_CLOSE When this option is present then the implementation makes a best effort attempt to delete the file when closed by the the close method. If the close method is not invoked then a best effort attempt is made to delete the file when the Java virtual machine terminates. SPARSE When creating a new file this option is a hint that the new file will be sparse. This option is ignored when not creating a new file. SYNC Requires that every update to the file's content or metadata be written synchronously to the underlying storage device. (see Synchronized I/O file integrity). DSYNC Requires that every update to the file's content be written synchronously to the underlying storage device. (see Synchronized I/O file integrity).

        实施还可以支持其他选项。

        attrs参数是文件file-attributes的可选数组，用于在创建文件时以原子方式进行设置。

        新的信道是通过调用创建newFileChannel上创建该提供商方法Path 。

        参数
        path - 打开或创建文件的路径
        options - 指定文件打开方式的选项
        attrs - 创建文件时以原子方式设置的文件属性的可选列表
        结果
        一个新的文件通道
        异常
        IllegalArgumentException - 如果集合包含无效的选项组合
        UnsupportedOperationException - 如果 path与不支持创建文件通道的提供程序相关联，或者指定了不支持的打开选项，或者数组包含创建文件时无法原子设置的属性
        IOException - 如果发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝执行所需的未指定的权限。 在默认提供程序的情况下，如果打开文件进行阅读，则调用SecurityManager.checkRead(String)方法来检查读访问。 如果打开文件写入，则调用SecurityManager.checkWrite(String)方法来检查写访问
        从以下版本开始：
        1.7

      • open

        public static FileChannel open​(Path path,
                               OpenOption... options)
                        throws IOException
        打开或创建文件，返回文件通道以访问该文件。

        调用此方法的行为方式与调用完全相同

          fc.open(file, opts, new FileAttribute<?>[0]);
        其中opts是options数组中指定的一组选项。
        参数
        path - 打开或创建文件的路径
        options - 指定文件打开方式的选项
        结果
        一个新的文件通道
        异常
        IllegalArgumentException - 如果集合包含无效的选项组合
        UnsupportedOperationException - 如果 path与不支持创建文件通道的提供程序相关联，或者指定了不支持的打开选项
        IOException - 如果发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝了实现所需的未指定的许可。 在默认提供程序的情况下，如果打开文件进行读取，则调用SecurityManager.checkRead(String)方法来检查读访问。 如果打开文件写入，则调用SecurityManager.checkWrite(String)方法来检查写访问
        从以下版本开始：
        1.7

      • read

        public abstract int read​(ByteBuffer dst)
                  throws IOException
        从该通道读取到给定缓冲区的字节序列。

        从该通道的当前文件位置开始读取字节，然后以实际读取的字节数更新文件位置。 否则，此方法的行为与ReadableByteChannel界面中的规定完全相同。

        Specified by:
        read在接口 ReadableByteChannel
        Specified by:
        read在接口 SeekableByteChannel
        参数
        dst - 要传输字节的缓冲区
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行中关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • read

        public abstract long read​(ByteBuffer[] dsts,
                          int offset,
                          int length)
                   throws IOException
        从该通道读取字节序列到给定缓冲区的子序列中。

        从该通道的当前文件位置开始读取字节，然后以实际读取的字节数更新文件位置。 否则，此方法的行为与ScatteringByteChannel界面中的规定完全相同。

        Specified by:
        read在接口 ScatteringByteChannel
        参数
        dsts - 要传输字节的缓冲区
        offset - 要传输字节的第一个缓冲区的缓冲区中的偏移量; 必须是非负数，不得大于dsts.length
        length - 要访问的缓冲区的最大数量; 必须是非负数，不得大于dsts.length - offset
        结果
        读取的字节数，可能为零，如果通道已达到流出尾， -1
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • read

        public final long read​(ByteBuffer[] dsts)
                throws IOException
        从该通道读取到给定缓冲区的字节序列。

        从该通道的当前文件位置开始读取字节，然后以实际读取的字节数更新文件位置。 否则，此方法的行为与ScatteringByteChannel界面中的规定完全相同。

        Specified by:
        read在接口 ScatteringByteChannel
        参数
        dsts - 要传输字节的缓冲区
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public abstract int write​(ByteBuffer src)
                   throws IOException
        从给定的缓冲区向该通道写入一个字节序列。

        字节从该通道的当前文件位置开始写入，除非通道处于附加模式，在这种情况下，位置首先提前到文件的末尾。 如果需要，文件生长以容纳写入的字节，然后文件位置用实际写入的字节数更新。 否则，此方法的行为与WritableByteChannel接口的规定完全相同。

        Specified by:
        write在接口 SeekableByteChannel
        Specified by:
        write在接口 WritableByteChannel
        参数
        src - 要检索字节的缓冲区
        结果
        写入的字节数，可能为零
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public abstract long write​(ByteBuffer[] srcs,
                           int offset,
                           int length)
                    throws IOException
        从给定缓冲区的子序列将一个字节序列写入该通道。

        字节从该通道的当前文件位置开始写入，除非通道处于附加模式，在这种情况下，位置首先提前到文件的末尾。 如果需要，文件生长以容纳写入的字节，然后文件位置用实际写入的字节数更新。 否则，此方法的行为与GatheringByteChannel接口中的规定完全相同。

        Specified by:
        write在接口 GatheringByteChannel
        参数
        srcs - 要检索字节的缓冲区
        offset - 要检索字节的第一个缓冲区的缓冲区数组中的偏移量; 必须是非负数，不得大于srcs.length
        length - 要访问的缓冲区的最大数量; 必须是非负数，不得大于srcs.length - offset
        结果
        写入的字节数，可能为零
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public final long write​(ByteBuffer[] srcs)
                 throws IOException
        从给定的缓冲区向该通道写入一系列字节。

        字节从该通道的当前文件位置开始写入，除非通道处于附加模式，在这种情况下，位置首先提前到文件的末尾。 如果需要，文件生长以容纳写入的字节，然后文件位置用实际写入的字节数更新。 否则，此方法的行为与GatheringByteChannel界面中的规定完全相同。

        Specified by:
        write在接口 GatheringByteChannel
        参数
        srcs - 要检索字节的缓冲区
        结果
        写入的字节数，可能为零
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • position

        public abstract long position​()
                       throws IOException
        返回此频道的文件位置。
        Specified by:
        position在接口 SeekableByteChannel
        结果
        该通道的文件位置是从文件开始到当前位置的非负整数
        异常
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误

      • position

        public abstract FileChannel position​(long newPosition)
                              throws IOException
        设置此通道的文件位置。

        将位置设置为大于文件当前大小的值是合法的，但不会更改文件的大小。 稍后在这样的位置读取字节的尝试将立即返回文件结束指示。 稍后在这样的位置写入字节的尝试将导致文件生长以适应新的字节; 未指定上一个文件结尾和新写入的字节之间的任何字节的值。

        Specified by:
        position在接口 SeekableByteChannel
        参数
        newPosition - 新位置，从文件开头计数字节数的非负整数
        结果
        此文件通道
        异常
        ClosedChannelException - 如果此通道关闭
        IllegalArgumentException - 如果新位置为负
        IOException - 如果发生其他I / O错误

      • size

        public abstract long size​()
                   throws IOException
        返回此通道文件的当前大小。
        Specified by:
        size在接口 SeekableByteChannel
        结果
        该通道文件的当前大小，以字节为单位
        异常
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误

      • truncate

        public abstract FileChannel truncate​(long size)
                              throws IOException
        将此频道的文件截断为给定大小。

        如果给定的大小小于文件的当前大小，则文件将被截断，丢弃超出文件新端的任何字节。 如果给定的大小大于或等于文件的当前大小，则该文件不会被修改。 在任一种情况下，如果此通道的文件位置大于给定的大小，则将其设置为该大小。

        Specified by:
        truncate在接口 SeekableByteChannel
        参数
        size - 新的大小，非负字节数
        结果
        此文件通道
        异常
        NonWritableChannelException - 如果此通道未打开以进行写入
        ClosedChannelException - 如果此通道关闭
        IllegalArgumentException - 如果新的大小为负数
        IOException - 如果发生其他I / O错误

      • force

        public abstract void force​(boolean metaData)
                    throws IOException
        强制将此通道文件的任何更新写入包含该通道的存储设备。

        如果此通道的文件驻留在本地存储设备上，那么当该方法返回时，保证自创建该通道以来创建或自从上次调用该方法以来对文件所做的所有更改都将写入该设备。 这对于确保系统崩溃时不会丢失关键信息非常有用。

        如果文件不在本地设备上，则不会提供此类保证。

        metaData参数可用于限制此方法执行所需的I / O操作数。 传递此参数的false表示仅对文件内容的更新需要写入存储; 通过true表示必须写入文件的内容和元数据的更新，通常需要至少一个I / O操作。 该参数实际上是否具有任何效果取决于底层操作系统，因此未指定。

        调用此方法可能会导致I / O操作发生，即使通道仅打开读取。 例如，某些操作系统将最后访问时间作为文件的元数据的一部分进行维护，并且每次读取文件时都会更新此时间。 这是否实际上是系统依赖的，因此是未指定的。

        此方法只能通过此类中定义的方法强制对此通道文件进行的更改。 它可能或不会强制通过修改通过调用map方法获得的mapped byte buffer的内容而进行的更改。 调用映射字节缓冲区的force方法将强制对缓冲区内容进行写入。

        参数
        metaData - 如果是true则需要这种方法强制更改文件的内容和元数据以写入存储; 否则，它只需要强制更改内容
        异常
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误

      • transferTo

        public abstract long transferTo​(long position,
                                long count,
                                WritableByteChannel target)
                         throws IOException
        将该通道文件的字节传输到给定的可写字节通道。

        尝试从该通道的文件中给定的position开始读取最多count个字节，并将其写入目标通道。 此方法的调用可能会传送或不传送所有请求的字节; 是否这样做取决于渠道的性质和状态。 如果该通道的文件从给定的position开始包含少于count个字节，或者如果目标通道不阻塞，并且其输出缓冲区中的字节数少于count个字节，则传输的字节数少于所请求的字节数。

        此方法不会修改此频道的位置。 如果给定的位置大于文件的当前大小，则不会传输任何字节。 如果目标通道具有位置，则从该位置开始写入字节，然后将该位置递增写入的字节数。

        该方法比从该通道读取并写入目标通道的简单循环更有效。 许多操作系统可以将字节直接从文件系统缓存传输到目标通道，而无需实际复制它们。

        参数
        position - 传输开始的文件中的位置; 必须是非负的
        count - 要传输的最大字节数; 必须是非负的
        target - 目标频道
        结果
        实际传输的字节数，可能为零
        异常
        IllegalArgumentException - 如果参数的前提条件不成立
        NonReadableChannelException - 如果此频道未打开阅读
        NonWritableChannelException - 如果目标通道未打开以进行写入
        ClosedChannelException - 如果此通道或目标通道关闭
        AsynchronousCloseException - 如果另一个线程在传输进行过程中关闭任一通道
        ClosedByInterruptException - 如果另一个线程在传输过程中中断当前线程，从而关闭两个通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • transferFrom

        public abstract long transferFrom​(ReadableByteChannel src,
                                  long position,
                                  long count)
                           throws IOException
        从给定的可读字节通道将字节传输到该通道的文件中。

        尝试从源通道读取最多count个字节，并将其写入此通道的文件，从给定的position 。 此方法的调用可能会传送或不传送所有请求的字节; 是否这样做取决于渠道的性质和状态。 如果源通道剩余少于count个字节，或者源通道不阻塞，并且其输入缓冲区中可立即可用的字节少于count字节， count少于所count字节数。

        此方法不会修改此频道的位置。 如果给定的位置大于文件的当前大小，则不会传输任何字节。 如果源通道具有位置，则从该位置开始读取字节，然后将该位置递增读取的字节数。

        该方法比从源通道读取并写入此通道的简单循环可能更有效。 许多操作系统可以将字节直接从源通道传输到文件系统高速缓存中，而无需实际复制它们。

        参数
        src - 源频道
        position - 文件中要进行传输的位置; 必须是非负的
        count - 要传输的最大字节数; 必须是非负的
        结果
        实际传输的字节数，可能为零
        异常
        IllegalArgumentException - 如果参数的前提条件不成立
        NonReadableChannelException - 如果源通道未打开读取
        NonWritableChannelException - 如果这个频道没有开放写作
        ClosedChannelException - 如果此通道或源通道关闭
        AsynchronousCloseException - 如果另一个线程在传输过程中关闭任一通道
        ClosedByInterruptException - 如果另一个线程在传输过程中中断当前线程，从而关闭两个通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • read

        public abstract int read​(ByteBuffer dst,
                         long position)
                  throws IOException
        从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。

        该方法的工作原理与read(ByteBuffer)方法相同，只是从给定文件位置而不是在通道的当前位置读取字节。 此方法不会修改此频道的位置。 如果给定的位置大于文件的当前大小，则不会读取任何字节。

        参数
        dst - 要传输字节的缓冲区
        position - 要开始传输的文件位置; 必须是非负的
        结果
        读取的字节数，可能为零，如果给定的位置大于或等于文件的当前大小， -1
        异常
        IllegalArgumentException - 如果位置为负
        NonReadableChannelException - 如果此频道未打开阅读
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public abstract int write​(ByteBuffer src,
                          long position)
                   throws IOException
        从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。

        该方法的工作方式与write(ByteBuffer)方法相同，只是字节从给定的文件位置而不是在通道的当前位置写入。 此方法不会修改此频道的位置。 如果给定的位置大于文件的当前大小，那么该文件将被生长以适应新的字节; 未指定上一个文件结尾和新写入的字节之间的任何字节的值。

        参数
        src - 要传输字节的缓冲区
        position - 传输开始的文件位置; 必须是非负的
        结果
        写入的字节数，可能为零
        异常
        IllegalArgumentException - 如果位置为负
        NonWritableChannelException - 如果这个频道没有开放写作
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • map

        public abstract MappedByteBuffer map​(FileChannel.MapMode mode,
                                     long position,
                                     long size)
                              throws IOException
        将此频道文件的区域直接映射到内存中。

        文件的区域可以以三种模式之一映射到存储器中：

        • 只读：任何尝试修改生成的缓冲区将导致抛出ReadOnlyBufferException 。 （ MapMode.READ_ONLY ）

        • 读/写：对结果缓冲区所做的更改将最终传播到文件中; 它们可能也可能不会被映射到同一文件的其他程序可见。 （ MapMode.READ_WRITE ）

        • 私有：对结果缓冲区所做的更改不会传播到该文件，并且对于映射了相同文件的其他程序将不可见; 相反，它们将导致要创建的缓冲区的修改部分的私有副本。 （ MapMode.PRIVATE ）

        对于只读映射，此通道必须已打开才能读取; 对于读/写或私有映射，此通道必须已打开以供读写。

        该方法返回的mapped byte buffer的位置为零，容量为size ; 它的标记将是未定义的。 缓冲区及其表示的映射将保持有效，直到缓冲区本身被垃圾回收为止。

        映射一旦建立，就不依赖于用于创建它的文件通道。 关闭通道，特别是对映射的有效性没有影响。

        内存映射文件的许多细节固有地依赖于底层操作系统，因此是未指定的。 当请求的区域未完全包含在该通道的文件中时，此方法的行为是未指定的。 对该程序或另一个的底层文件的内容或大小进行的更改是否被传播到缓冲区是未指定的。 缓冲区的更改传播到文件的速率是未指定的。

        对于大多数操作系统，将文件映射到内存中比通过通常的read和write方法读取或写入几十千字节的数据更昂贵。 从性能的角度来看，通常只能将较大的文件映射到内存中。

        参数
        mode -一个常量READ_ONLY ， READ_WRITE ，或PRIVATE在所定义FileChannel.MapMode类，根据该文件是否是要被映射的只读，读/写，或私人（写入时复制），分别
        position - 映射区域要启动的文件中的位置; 必须是非负的
        size - 要映射的区域的大小; 必须是非负数，不得大于Integer.MAX_VALUE
        结果
        映射的字节缓冲区
        异常
        NonReadableChannelException - 如果 mode是 READ_ONLY，但这个频道没有打开阅读
        NonWritableChannelException - 如果 mode是 READ_WRITE或 PRIVATE，但这个频道没有打开读写
        IllegalArgumentException - 如果参数的前提条件不成立
        IOException - 如果发生其他I / O错误
        另请参见：
        FileChannel.MapMode ， MappedByteBuffer

      • lock

        public abstract FileLock lock​(long position,
                              long size,
                              boolean shared)
                       throws IOException
        获取此通道文件的给定区域的锁定。

        此方法的调用将阻塞，直到该区域被锁定，此通道关闭或调用的线程被中断（以先到者为准）。

        如果此通道在调用此方法时由另一个线程关闭，那么将抛出一个AsynchronousCloseException 。

        如果调用线程在等待获取锁定时中断，则其中断状态将被设置， 并且将抛出一个FileLockInterruptionException 。 如果在调用此方法时调用了调用者的中断状态，那么将立即抛出该异常; 线程的中断状态不会改变。

        由position和size参数指定的区域不需要包含在实际的底层文件内，甚至与其重叠。 锁定区域的大小固定; 如果锁定区域最初包含文件的结尾，并且文件增长超出该区域，那么该文件的新部分将不会被该锁覆盖。 如果文件的大小增加，并且整个文件都需要锁定，则应该锁定从零开始并且不小于文件的预期最大大小的区域。 零参数lock()方法简单地锁定一个大小为Long.MAX_VALUE的区域。

        某些操作系统不支持共享锁，在这种情况下，共享锁的请求将自动转换为独占锁的请求。 新获取的锁是共享的还是独占的都可以通过调用生成的锁对象的isShared方法进行测试。

        文件锁代表整个Java虚拟机。 它们不适用于通过同一虚拟机中的多个线程控制对文件的访问。

        参数
        position - 锁定区域要启动的位置; 必须是非负的
        size - 锁定区域的大小; 必须是非负数，并且position + size的总和必须是非负数
        shared - true以请求共享锁，在这种情况下，该通道必须打开才能读取（可能写入）; false要求排他锁，在这种情况下，此通道必须打开以进行写入（可能读取）
        结果
        表示新获取的锁的锁定对象
        异常
        IllegalArgumentException - 如果参数的前提条件不成立
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在此方法中阻止调用线程时关闭此通道
        FileLockInterruptionException - 如果调用线程在此方法中被阻止时中断
        OverlappingFileLockException - 如果与该请求区域重叠的锁已由该Java虚拟机保存，或者该方法中是否已阻止另一个线程，并尝试锁定重叠区域
        NonReadableChannelException - 如果 shared是 true这个频道没有打开阅读
        NonWritableChannelException - 如果 shared是 false但这个频道没有开放写作
        IOException - 如果发生其他I / O错误
        另请参见：
        lock() ，
tryLock() ，
tryLock(long,long,boolean)

      • lock

        public final FileLock lock​()
                    throws IOException
        获取此通道文件的排他锁。

        对这种fc.lock()形式的方法的调用与调用的方式完全相同

          fc.lock(0L, Long.MAX_VALUE, false)
        结果
        表示新获取的锁的锁定对象
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在此方法中阻止调用线程时关闭此通道
        FileLockInterruptionException - 如果调用线程在此方法中被阻止时中断
        OverlappingFileLockException - 如果与该请求区域重叠的锁已由该Java虚拟机保存，或者该方法中是否已阻止另一个线程，并尝试锁定同一文件的重叠区域
        NonWritableChannelException - 如果此通道未打开以进行写入
        IOException - 如果发生其他I / O错误
        另请参见：
        lock(long,long,boolean) ，
tryLock() ，
tryLock(long,long,boolean)

      • tryLock

        public abstract FileLock tryLock​(long position,
                                 long size,
                                 boolean shared)
                          throws IOException
        尝试获取此通道文件的给定区域的锁定。

        此方法不阻止。 调用总是立即返回，要么获取了请求的区域的锁定，要么没有这样做。 如果由于重叠的锁被另一个程序持有而无法获取锁定，则它将返回null 。 如果由于任何其他原因无法获取锁，则抛出适当的异常。

        由position和size参数指定的区域不需要包含在实际底层文件内，甚至与实际的底层文件重叠。 锁定区域的大小固定; 如果锁定区域最初包含文件的结尾，并且文件增长超出该区域，那么该文件的新部分将不会被该锁覆盖。 如果文件的大小增加，并且整个文件都需要锁定，则应该锁定从零开始并且不小于文件的预期最大大小的区域。 零参数tryLock()方法简单地锁定大小为Long.MAX_VALUE的区域。

        某些操作系统不支持共享锁，在这种情况下，共享锁的请求将自动转换为独占锁的请求。 新获取的锁是共享的还是独占的都可以通过调用生成的锁对象的isShared方法进行测试。

        文件锁代表整个Java虚拟机。 它们不适用于通过同一虚拟机中的多个线程控制对文件的访问。

        参数
        position - 锁定区域要启动的位置; 必须是非负的
        size - 锁定区域的大小; 必须是非负数，并且position + size必须为非负数
        shared - true要求共享锁， false要求排他锁
        结果
        表示新获取的锁的锁定对象，如果由于另一个程序持有重叠的锁而无法获取锁， null
        异常
        IllegalArgumentException - 如果参数的前提条件不成立
        ClosedChannelException - 如果此通道关闭
        OverlappingFileLockException - 如果与该请求区域重叠的锁已由该Java虚拟机保存，或者该方法中已阻止另一个线程，并尝试锁定同一文件的重叠区域
        IOException - 如果发生其他I / O错误
        另请参见：
        lock() ，
lock(long,long,boolean) ，
tryLock()

      • tryLock

        public final FileLock tryLock​()
                       throws IOException
        尝试获取此频道文件的排他锁。

        对这种fc.tryLock()形式的方法的调用与调用的方式完全相同

          fc.tryLock(0L, Long.MAX_VALUE, false)
        结果
        表示新获取的锁的锁定对象，如果由于另一个程序持有重叠的锁而无法获取锁， null
        异常
        ClosedChannelException - 如果此通道关闭
        OverlappingFileLockException - 如果与该请求区域重叠的锁已由该Java虚拟机保存，或者该方法中已阻止另一个线程，并尝试锁定重叠区域
        IOException - 如果发生其他I / O错误
        另请参见：
        lock() ，
lock(long,long,boolean) ，
tryLock(long,long,boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileChannel.MapMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class FileChannel.MapMode

  • java.lang.Object
    • java.nio.channels.FileChannel.MapMode
  • Enclosing class:
    FileChannel

    public static class FileChannel.MapMode
extends Object
    文件映射模式的类型安全枚举。
    从以下版本开始：
    1.4
    另请参见：
    FileChannel.map(java.nio.channels.FileChannel.MapMode, long, long)

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static FileChannel.MapMode PRIVATE
      私有（写时复制）映射模式。
      static FileChannel.MapMode READ_ONLY
      只读映射的模式。
      static FileChannel.MapMode READ_WRITE
      读/写映射模式。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回描述此文件映射模式的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • READ_ONLY

        public static final FileChannel.MapMode READ_ONLY
        只读映射的模式。

      • READ_WRITE

        public static final FileChannel.MapMode READ_WRITE
        读/写映射模式。

      • PRIVATE

        public static final FileChannel.MapMode PRIVATE
        私有（写时复制）映射模式。

    • 方法详细信息

      • toString

        public String toString​()
        返回描述此文件映射模式的字符串。
        重写：
        toString在 Object
        结果
        一个描述性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


FileLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class FileLock

  • java.lang.Object
    • java.nio.channels.FileLock
  • All Implemented Interfaces:
    AutoCloseable

    public abstract class FileLock
extends Object
implements AutoCloseable
    表示文件区域上的锁的令牌。

    甲文件的锁对象被创建每一个锁经由的一个上的文件获取的时间lock种或tryLock的方法FileChannel类或lock种或tryLock的方法AsynchronousFileChannel类。

    文件锁定对象最初有效。 通过调用release方法，通过关闭用于获取锁定的通道，或通过Java虚拟机的终止（以先到者为准）释放锁定，它仍然有效。 可以通过调用其isValid方法来测试锁的有效性。

    文件锁是独占的或共享的 。 共享锁可防止其他并发运行的程序获取重叠的排他锁，但是允许它们获取重叠的共享锁。 排他锁可防止其他程序获取任一类型的重叠锁。 一旦释放，锁对其他程序可能获得的锁就不再产生影响。

    锁是独占还是共享可以通过调用其isShared方法来确定。 某些平台不支持共享锁，在这种情况下，共享锁的请求将自动转换为独占锁的请求。

    由单个Java虚拟机在特定文件上保存的锁不重叠。 overlaps方法可用于测试候选锁定范围是否与现有锁重叠。

    文件锁定对象记录保存文件的文件通道，锁的类型和有效性以及锁定区域的位置和大小。 只有锁的有效性随时间而变化; 锁的状态的所有其他方面是不可变的。

    文件锁代表整个Java虚拟机。 它们不适用于通过同一虚拟机中的多个线程控制对文件的访问。

    文件锁对象可以安全地被多个并发线程使用。

    平台依赖

    此文件锁定API旨在直接映射到底层操作系统的本机锁定工具。 因此，对于能够访问该文件的所有程序，不管写入哪些程序的语言，文件夹上的锁都应该可见。

    锁实际上是否阻止另一个程序访问锁定区域的内容是系统依赖的，因此是未指定的。 一些系统的本地文件锁定设施只是建议 ，这意味着程序必须协调地观察已知的锁定协议，以保证数据的完整性。 在其他系统上，本地文件锁是必需的 ，这意味着如果一个程序锁定一个文件的区域，那么实际上阻止其他程序以违反该锁的方式访问该区域。 在其他系统上，无论是本地文件锁是辅助还是强制性，都可以在每个文件的基础上进行配置。 为确保跨平台的一致和正确的行为，强烈建议使用该API提供的锁，就像它们是建议锁一样。

    在某些系统上，获取文件区域上的强制锁可防止该区域为mapped into memory ，反之亦然。 应该准备组合锁定和映射的程序以使此组合失败。

    在某些系统上，关闭通道会释放基础文件上的Java虚拟机所持有的锁，无论是通过该通道获取锁还是通过在同一文件上打开的其他通道。 强烈建议在程序中使用唯一的通道来获取任何给定文件上的所有锁。

    一些网络文件系统只有当锁定区域是页面对齐的和底层硬件的页面大小的整数倍时，才允许文件锁定与内存映射文件一起使用。 某些网络文件系统不会在延伸到某一位置（通常为2 30或2 31）的区域上实现文件锁定。 通常，在锁定驻留在网络文件系统上的文件时，应特别小心。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FileLock​(AsynchronousFileChannel channel, long position, long size, boolean shared)
      初始化此类的新实例。
      protected FileLock​(FileChannel channel, long position, long size, boolean shared)
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Channel acquiredBy​()
      返回获取此锁的文件的通道。
      FileChannel channel​()
      返回获取此锁的文件通道。
      void close​()
      此方法调用 release()方法。
      boolean isShared​()
      告诉这个锁是否共享。
      abstract boolean isValid​()
      告诉这个锁是否有效。
      boolean overlaps​(long position, long size)
      告诉这个锁是否与给定的锁定范围重叠。
      long position​()
      返回锁定区域的第一个字节的文件中的位置。
      abstract void release​()
      释放这个锁
      long size​()
      以字节为单位返回锁定区域的大小。
      String toString​()
      返回描述此锁的范围，类型和有效性的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FileLock

        protected FileLock​(FileChannel channel,
                   long position,
                   long size,
                   boolean shared)
        初始化此类的新实例。
        参数
        channel - 保存此锁的文件通道
        position - 锁定区域开始的文件中的位置; 必须是非负的
        size - 锁定区域的大小; 必须是非负数，并且position + size的总和必须是非负数
        shared - true如果这个锁是共享的， false如果是排他的
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

      • FileLock

        protected FileLock​(AsynchronousFileChannel channel,
                   long position,
                   long size,
                   boolean shared)
        初始化此类的新实例。
        参数
        channel - 保存此锁的文件的通道
        position - 锁定区域启动的文件中的位置; 必须是非负的
        size - 锁定区域的大小; 必须是非负数，并且总和position + size必须是非负数
        shared - true如果这个锁是共享的， false如果是排他的
        异常
        IllegalArgumentException - 如果参数的前提条件不成立
        从以下版本开始：
        1.7

    • 方法详细信息

      • channel

        public final FileChannel channel​()
        返回获取此锁的文件通道。

        该方法已被acquiredBy方法所取代。

        结果
        文件通道，或 null如果文件锁没有被文件通道获取。

      • acquiredBy

        public Channel acquiredBy​()
        返回获取此锁的文件的通道。
        结果
        获取此锁的通道。
        从以下版本开始：
        1.7

      • position

        public final long position​()
        返回锁定区域的第一个字节的文件中的位置。

        锁定区域不需要包含在实际的底层文件内，甚至重叠，因此此方法返回的值可能会超过文件的当前大小。

        结果
        的位置

      • size

        public final long size​()
        以字节为单位返回锁定区域的大小。

        锁定区域不需要包含在实际的底层文件内，甚至重叠，因此此方法返回的值可能会超过文件的当前大小。

        结果
        锁定区域的大小

      • isShared

        public final boolean isShared​()
        告诉这个锁是否共享。
        结果
        true如果锁是共享的， false如果是排他的

      • overlaps

        public final boolean overlaps​(long position,
                              long size)
        告诉这个锁是否与给定的锁定范围重叠。
        参数
        position - 锁定范围的起始位置
        size - 锁定范围的大小
        结果
        true如果，并且只有这个锁和给定的锁定范围重叠至少一个字节

      • isValid

        public abstract boolean isValid​()
        告诉这个锁是否有效。

        锁定对象在释放之前保持有效，或关联的文件通道关闭，以先到者为准。

        结果
        true如果，且仅当此锁定有效

      • release

        public abstract void release​()
                      throws IOException
        释放这个锁

        如果此锁对象有效，则调用此方法将释放该锁并使该对象无效。 如果此锁对象无效，则调用此方法将不起作用。

        异常
        ClosedChannelException - 如果用于获取此锁的通道不再打开
        IOException - 如果发生I / O错误

      • close

        public final void close​()
                 throws IOException
        此方法调用release()方法。 它被添加到类中，以便它可以与自动资源管理块结构一起使用。
        Specified by:
        close在接口 AutoCloseable
        异常
        IOException
        从以下版本开始：
        1.7

      • toString

        public final String toString​()
        返回描述此锁的范围，类型和有效性的字符串。
        重写：
        toString在 Object
        结果
        A descriptive string
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileLockInterruptionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class FileLockInterruptionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.channels.FileLockInterruptionException
  • All Implemented Interfaces:
    Serializable

    public class FileLockInterruptionException
extends IOException
    另一个线程在等待获取文件锁时中断它时线程接收到的异常检查。 在引发异常之前，先前阻止的线程的中断状态将被设置。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileLockInterruptionException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FileLockInterruptionException

        public FileLockInterruptionException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GatheringByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface GatheringByteChannel

  • All Superinterfaces:
    AutoCloseable ， Channel ， Closeable ， WritableByteChannel
    所有已知实现类：
    DatagramChannel ， FileChannel ， Pipe.SinkChannel ， SocketChannel

    public interface GatheringByteChannel
extends WritableByteChannel
    可以从缓冲区序列中写入字节的通道。

    采集写入操作在单个调用中写入一个或多个缓冲器序列中的一个或多个字节序列。 在实现网络协议或文件格式时，收集写入通常很有用，例如，将数据分组到由一个或多个固定长度的标题后跟可变长度的主体组成的段中。 类似的散射读取操作在ScatteringByteChannel界面中定义。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long write​(ByteBuffer[] srcs)
      从给定的缓冲区向该通道写入一系列字节。
      long write​(ByteBuffer[] srcs, int offset, int length)
      从给定缓冲区的子序列将一个字节序列写入该通道。

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from interface java.nio.channels.WritableByteChannel

        write

    • 方法详细信息

      • write

        long write​(ByteBuffer[] srcs,
           int offset,
           int length)
    throws IOException
        从给定缓冲区的子序列将一个字节序列写入该通道。

        尝试写入r个字节到该通道，其中r是给定缓冲区数组的指定子序列中剩余的总字节数，也就是说，

         srcs[offset].remaining()
     + srcs[offset+1].remaining()
     + ... + srcs[offset+length-1].remaining()
        在此方法被调用的时刻。

        假设长度为n的字节序列写入，其中0 <= Ñ <= 河 直到该序列的第一个srcs[offset].remaining()字节从缓冲器srcs[offset]写入，直到下一个srcs[offset+1].remaining()字节从缓冲器srcs[offset+1]写入，等等，直到写入整个字节序列。 尽可能多的字节从每个缓冲区写入，因此除了最后更新的缓冲区之外，每个更新的缓冲区的最终位置被保证等于该缓冲区的限制。

        除非另有规定，写入操作将仅在写入所有r个请求的字节后才会返回。 某些类型的通道取决于它们的状态，可能仅写入一些字节，或者可能只写入一些字节。 例如，在非阻塞模式下的套接字通道不能写入任何比套接字输出缓冲区中的任何字节更多的字节。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了写入操作，那么此方法的调用将阻塞，直到第一个操作完成。

        参数
        srcs - 要检索字节的缓冲区
        offset - 要从中检索字节的第一个缓冲区的缓冲区数组中的偏移量; 必须是非负数，不得大于srcs.length
        length - 要访问的缓冲区的最大数量; 必须是非负数，不大于srcs.length - offset
        结果
        写入的字节数，可能为零
        异常
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立
        NonWritableChannelException - 如果此通道未打开以进行写入
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写入操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        long write​(ByteBuffer[] srcs)
    throws IOException
        从给定的缓冲区向该通道写入一系列字节。

        对这种c.write(srcs)形式的方法的调用与调用的方式完全相同

         c.write(srcs, 0, srcs.length);
        参数
        srcs - 要检索字节的缓冲区
        结果
        写入的字节数，可能为零
        异常
        NonWritableChannelException - 如果此通道未打开以进行写入
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写入操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - If some other I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalBlockingModeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class IllegalBlockingModeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.IllegalBlockingModeException
  • All Implemented Interfaces:
    Serializable

    public class IllegalBlockingModeException
extends IllegalStateException
    当在不正确的阻塞模式下在通道上调用特定于阻止模式的操作时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalBlockingModeException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalBlockingModeException

        public IllegalBlockingModeException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalChannelGroupException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class IllegalChannelGroupException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.channels.IllegalChannelGroupException
  • All Implemented Interfaces:
    Serializable

    public class IllegalChannelGroupException
extends IllegalArgumentException
    尝试打开不是由同一提供商创建的组中的通道时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalChannelGroupException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalChannelGroupException

        public IllegalChannelGroupException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalSelectorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class IllegalSelectorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.channels.IllegalSelectorException
  • All Implemented Interfaces:
    Serializable

    public class IllegalSelectorException
extends IllegalArgumentException
    当尝试向创建该通道的提供商创建的选择器注册一个通道时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalSelectorException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalSelectorException

        public IllegalSelectorException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InterruptedByTimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class InterruptedByTimeoutException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.channels.InterruptedByTimeoutException
  • All Implemented Interfaces:
    Serializable

    public class InterruptedByTimeoutException
extends IOException
    在异步操作完成之前经过一段时间后线程接收到的异常检查。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InterruptedByTimeoutException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InterruptedByTimeoutException

        public InterruptedByTimeoutException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InterruptibleChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface InterruptibleChannel

  • All Superinterfaces:
    AutoCloseable ， Channel ， Closeable
    所有已知实现类：
    AbstractInterruptibleChannel ， AbstractSelectableChannel ， DatagramChannel ， FileChannel ， Pipe.SinkChannel ， Pipe.SourceChannel ， SctpChannel ， SctpMultiChannel ， SctpServerChannel ， SelectableChannel ， ServerSocketChannel ， SocketChannel

    public interface InterruptibleChannel
extends Channel
    可以异步关闭和中断的通道。

    实现此接口的通道是异步关闭的：如果线程在可中断通道上的I / O操作中被阻塞，则另一个线程可能会调用通道的close方法。 这将导致阻塞的线程接收到一个AsynchronousCloseException 。

    实现此接口的通道也是可中断的：如果线程在可中断通道上的I / O操作中被阻塞，则另一个线程可能会调用阻塞线程的interrupt方法。 这将导致通道关闭，阻塞线程接收到一个ClosedByInterruptException ，并阻塞线程的中断状态被设置。

    如果线程的中断状态已经设置，并且在通道上调用阻塞I / O操作，则通道将被关闭，并且线程将立即接收到一个ClosedByInterruptException ; 其中断状态将保持置位。

    一个通道支持异步关闭和中断，只要它实现了这个接口。 如果需要，可以在运行时通过instanceof操作符进行测试。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭此频道。

      • Methods inherited from interface java.nio.channels.Channel

        isOpen

    • 方法详细信息

      • close

        void close​()
    throws IOException
        关闭此频道。

        目前在此频道上I / O操作中阻塞的任何线程都将收到一个AsynchronousCloseException 。

        该方法的行为与Channel接口的规定完全相同。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Channel
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.nio.channels (Java SE 9 & JDK 9 )

java.nio.channels

Interfaces

  • AsynchronousByteChannel
  • AsynchronousChannel
  • ByteChannel
  • Channel
  • CompletionHandler
  • GatheringByteChannel
  • InterruptibleChannel
  • MulticastChannel
  • NetworkChannel
  • ReadableByteChannel
  • ScatteringByteChannel
  • SeekableByteChannel
  • WritableByteChannel

Classes

  • AsynchronousChannelGroup
  • AsynchronousFileChannel
  • AsynchronousServerSocketChannel
  • AsynchronousSocketChannel
  • Channels
  • DatagramChannel
  • FileChannel
  • FileChannel.MapMode
  • FileLock
  • MembershipKey
  • Pipe
  • Pipe.SinkChannel
  • Pipe.SourceChannel
  • SelectableChannel
  • SelectionKey
  • Selector
  • ServerSocketChannel
  • SocketChannel

Exceptions

  • AcceptPendingException
  • AlreadyBoundException
  • AlreadyConnectedException
  • AsynchronousCloseException
  • CancelledKeyException
  • ClosedByInterruptException
  • ClosedChannelException
  • ClosedSelectorException
  • ConnectionPendingException
  • FileLockInterruptionException
  • IllegalBlockingModeException
  • IllegalChannelGroupException
  • IllegalSelectorException
  • InterruptedByTimeoutException
  • NoConnectionPendingException
  • NonReadableChannelException
  • NonWritableChannelException
  • NotYetBoundException
  • NotYetConnectedException
  • OverlappingFileLockException
  • ReadPendingException
  • ShutdownChannelGroupException
  • UnresolvedAddressException
  • UnsupportedAddressTypeException
  • WritePendingException


java.nio.channels (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.nio.channels

定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
Lists channels and their descriptions
Channels | 描述
Channel | A nexus for I/O operations
ReadableByteChannel | Can read into a buffer
ScatteringByteChannel | Can read into a sequence of buffers
WritableByteChannel | Can write from a buffer
GatheringByteChannel | Can write from a sequence of buffers
ByteChannel | Can read/write to/from a buffer
SeekableByteChannel | A ByteChannel connected to an entity that contains a variable-length sequence of bytes
AsynchronousChannel | Supports asynchronous I/O operations.
AsynchronousByteChannel | Can read and write bytes asynchronously
NetworkChannel | A channel to a network socket
MulticastChannel | Can join Internet Protocol (IP) multicast groups
Channels | Utility methods for channel/stream interoperation

信道表示与诸如硬件设备，文件，网络套接字或能够执行一个或多个不同I / O操作（例如读取或写入）的程序组件的实体的开放连接。 如Channel接口中所规定的，通道是打开的或者关闭的，它们都是异步关闭和可 中断的 。

Channel接口由其他几个接口扩展。

ReadableByteChannel接口指定一个read方法，将字节从通道读入缓冲区; 类似地， WritableByteChannel接口指定了将缓冲区中的字节写入通道的write方法。 ByteChannel接口将这两个接口统一起来，用于可以读取和写入字节的通道的常见情况。 SeekableByteChannel接口将ByteChannel接口的方法扩展到query和modify的通道当前位置，其size 。

ScatteringByteChannel和GatheringByteChannel接口分别扩展了ReadableByteChannel和WritableByteChannel接口，添加了read和write方法，它们采用缓冲区序列而不是单个缓冲区。

NetworkChannel接口指定了通道的套接字bind的方法，获取套接字绑定的地址，以及get和set套接字选项的方法。 MulticastChannel接口指定加入Internet协议（IP）组播组的方法。

Channels实用程序类定义了支持java.io包的流类与此包的通道类的互操作的静态方法。 可以从InputStream或OutputStream构建适当的通道，相反地可以从通道构建InputStream或OutputStream 。 可以构造一个Reader ，它使用给定的字符集来从给定的可读字节通道解码字节，相反，可以构造一个使用给定字符集将字符编码为字节并将其写入给定可写字节通道的Writer 。

Lists file channels and their descriptions
File channels | 描述
FileChannel | Reads, writes, maps, and manipulates files
FileLock | A lock on a (region of a) file
MappedByteBuffer | A direct byte buffer mapped to a region of a file

FileChannel类支持从连接到文件的通道读取字节和写入字节的通常操作，以及查询和修改当前文件位置以及将文件截断为特定大小的操作。 它定义了在整个文件或文件的特定区域上获取锁的方法; 这些方法返回FileLock类的实例。 最后，它定义了强制更新要写入到其中的存储设备的文件的方法，用于在文件和其他通道之间高效传输字节，并将文件的一个区域直接映射到内存中。

甲FileChannel通过调用其静态之一创建open种方法，或通过调用getChannel的方法FileInputStream ， FileOutputStream ，或RandomAccessFile返回连接到相同的基本文件作为一个文件通道java.io类。

Lists multiplexed, non-blocking channels and their descriptions
Multiplexed, non-blocking I/O | 描述
SelectableChannel | A channel that can be multiplexed
DatagramChannel | A channel to a datagram-oriented socket
Pipe.SinkChannel | The write end of a pipe
Pipe.SourceChannel | The read end of a pipe
ServerSocketChannel | A channel to a stream-oriented listening socket
SocketChannel | A channel for a stream-oriented connecting socket
Selector | A multiplexor of selectable channels
SelectionKey A token representing the registration
of a channel with a selector
Pipe | Two channels that form a unidirectional pipe

多路复用的非阻塞I / O由选择器 ， 可选择的通道和选择键提供，它比面向线程的阻塞I / O更为可扩展。

A selector是selectable channels的多路复用器 ，其又是可以放入non-blocking mode的特殊类型的信道。 要执行复用I / O操作，首先创建一个或多个可选通道，进入非阻塞模式，并选择registered 。 注册通道指定将通过选择器进行测试的I / O操作集，并返回表示注册的selection key 。

一旦某些频道已经被选择器注册，可以执行一个selection operation ，以便发现哪些频道（如果有的话）已经准备好执行一个或多个以前声明了兴趣的操作。 如果通道准备就绪，则在注册时返回的密钥将被添加到选择器的选定密钥集中 。 可以检查密钥集合及其中的密钥，以确定每个信道准备好的操作。 从每个密钥可以检索相应的通道，以执行所需的任何I / O操作。

选择键指示其通道准备好进行某些操作是一个提示，但不能保证这样的操作可以由线程执行而不会导致线程阻塞。 执行复用I / O的代码必须被写入，以便在证明不正确时忽略这些提示。

这个包定义对应于所述选择的信道的类DatagramSocket ， ServerSocket和Socket在定义的类java.net包。 为了支持与通道相关的套接字，已经对这些类进行了微小的更改。 该包还定义了一个实现单向管道的简单类。 在所有情况下，通过调用相应类的静态open方法创建新的可选通道。 如果一个通道需要相关的套接字，那么将创建一个套接字作为此操作的副作用。

可以通过“插入” java.nio.channels.spi中定义的SelectorProvider类的替代定义或实例来替换选择器，可选通道和选择键的实现 。 预计很多开发人员实际上不会使用这个设施; 它主要提供，以便在需要非常高的性能时，复杂的用户可以利用操作系统特定的I / O复用机制。

多执行复用的I / O抽象所需的簿记和同步是由执行AbstractInterruptibleChannel ， AbstractSelectableChannel ， AbstractSelectionKey和AbstractSelector类在java.nio.channels.spi包。 定义一个自定义选择器提供者时，只有AbstractSelector和AbstractSelectionKey类应该直接进行子类化; 自定义渠道类应该扩展此包中定义的适当的SelectableChannel子类。

Lists asynchronous channels and their descriptions
Asynchronous I/O | 描述
AsynchronousFileChannel | An asynchronous channel for reading, writing, and manipulating a file
AsynchronousSocketChannel | An asynchronous channel to a stream-oriented connecting socket
AsynchronousServerSocketChannel | An asynchronous channel to a stream-oriented listening socket
CompletionHandler | A handler for consuming the result of an asynchronous operation
AsynchronousChannelGroup | A grouping of asynchronous channels for the purpose of resource sharing

Asynchronous channels是能够进行异步I / O操作的特殊类型的通道。 异步通道是非阻塞的，并且定义了启动异步操作的方法，返回一个表示每个操作待处理结果的Future 。 Future可用于轮询或等待操作结果。 异步I / O操作也可以指定一个CompletionHandler在操作完成时调用。 完成处理程序是用户提供的代码，用于执行以消耗I / O操作的结果。

此包定义了连接到面向流的连接或侦听套接字或面向数据包的套接字的异步通道类。 它还定义了用于异步读取，写入和操作文件的AsynchronousFileChannel类。 与FileChannel一样，它支持将文件截断为特定大小的操作，强制更新要写入存储设备的文件，或获取整个文件或文件特定区域上的锁定。 与FileChannel不同，它没有定义将文件的一个区域直接映射到内存中的方法。 在需要内存映射的I / O的情况下，可以使用FileChannel 。

为了资源共享的目的，异步信道被绑定到异步信道组。 一个组有一个关联的ExecutorService ，其中提交任务来处理I / O事件， 并发送到使用组中的通道执行异步操作的结果的完成处理程序。 可以在创建频道时指定组，也可以将频道绑定到默认组 。 复杂的用户可能希望创建自己的异步通道组或配置将用于默认组的ExecutorService 。

与选择器，异步通道的实现可以通过“堵漏”的一个替代的定义或实例来替换AsynchronousChannelProvider在定义的类java.nio.channels.spi包。 预计很多开发人员实际上不会使用这个设施; 主要提供这样的功能，以便在需要非常高的性能时，复杂的用户可以利用操作系统特定的异步I / O机制。

除非另有说明，否则将null参数传递给此程序包中任何类或接口中的构造函数或方法将导致抛出NullPointerException 。

从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    AsynchronousByteChannel
    一个可以读写字节的异步通道。
    AsynchronousChannel
    支持异步I / O操作的通道。
    ByteChannel
    一个可以读写字节的通道。
    Channel
    I / O操作的联系。
    CompletionHandler<V,A>
    用于消除异步I / O操作结果的处理程序。
    GatheringByteChannel
    可以从缓冲区序列中写入字节的通道。
    InterruptibleChannel
    可以异步关闭和中断的通道。
    MulticastChannel
    支持互联网协议（IP）组播的网络通道。
    NetworkChannel
    到网络插座的通道。
    ReadableByteChannel
    一个可以读取字节的通道。
    ScatteringByteChannel
    可以将字节读入缓冲区序列的通道。
    SeekableByteChannel
    保持当前 位置并允许更改 位置的字节通道。
    WritableByteChannel
    一个可以写字节的通道。
  • 类摘要
    Class 描述
    AsynchronousChannelGroup
    用于资源共享的一组异步通道。
    AsynchronousFileChannel
    用于读取，写入和操作文件的异步通道。
    AsynchronousServerSocketChannel
    用于面向流的侦听套接字的异步通道。
    AsynchronousSocketChannel
    用于面向流的连接插座的异步通道。
    Channels
    通道和流的实用方法。
    DatagramChannel
    面向数据报的套接字的可选通道。
    FileChannel
    用于读取，写入，映射和操作文件的通道。
    FileChannel.MapMode
    文件映射模式的类型安全枚举。
    FileLock
    表示文件区域上的锁的令牌。
    MembershipKey
    代表互联网协议（IP）组播组成员身份的令牌。
    Pipe
    实现单向管道的一对通道。
    Pipe.SinkChannel
    一个代表Pipe的可写端的通道 。
    Pipe.SourceChannel
    表示Pipe的可读端的通道 。
    SelectableChannel
    可通过Selector复用的频道 。
    SelectionKey
    一个表示SelectableChannel与Selector的注册的令牌。
    Selector
    SelectableChannel对象的多路复用器。
    ServerSocketChannel
    用于面向流的侦听套接字的可选通道。
    SocketChannel
    用于面向流的连接插座的可选通道。
  • 异常摘要
    异常 描述
    AcceptPendingException
    尝试在通道上启动接受操作并且以前的接受操作尚未完成时抛出未检查的异常。
    AlreadyBoundException
    尝试将套接字绑定到已绑定的面向网络的通道时抛出未经检查的异常。
    AlreadyConnectedException
    尝试连接已连接的SocketChannel时 ，会引发未检查的异常。
    AsynchronousCloseException
    当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
    CancelledKeyException
    当试图使用不再有效的选择键时抛出未检查的异常。
    ClosedByInterruptException
    另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。
    ClosedChannelException
    当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。
    ClosedSelectorException
    尝试在闭合选择器上调用I / O操作时抛出未检查的异常。
    ConnectionPendingException
    尝试连接已经进行非阻塞连接操作的SocketChannel时引发未检查的异常。
    FileLockInterruptionException
    另一个线程在等待获取文件锁时中断它时线程接收到的异常检查。
    IllegalBlockingModeException
    当在不正确的阻塞模式下在通道上调用特定于阻止模式的操作时抛出未检查的异常。
    IllegalChannelGroupException
    尝试打开不是由同一提供商创建的组中的通道时抛出未检查的异常。
    IllegalSelectorException
    当尝试向创建该通道的提供商创建的选择器注册一个通道时抛出未检查的异常。
    InterruptedByTimeoutException
    在异步操作完成之前经过一段时间后线程接收到的异常检查。
    NoConnectionPendingException
    当未经检查的异常finishConnect一个方法SocketChannel没有首先成功调用被调用connect方法。
    NonReadableChannelException
    尝试从最初打开阅读的频道中读取时未抛出的异常。
    NonWritableChannelException
    尝试写入最初未打开的通道进行写入时抛出未检查的异常。
    NotYetBoundException
    尝试在尚未绑定的服务器套接字通道上调用I / O操作时抛出未检查的异常。
    NotYetConnectedException
    当尝试在尚未连接的套接字通道上调用I / O操作时抛出未检查的异常。
    OverlappingFileLockException
    当尝试获取与已经被同一Java虚拟机锁定的区域重叠的文件的区域上，或者当另一个线程已经在等待锁定同一文件的重叠区域时尝试获取未锁定的异常。
    ReadPendingException
    尝试从异步套接字通道读取并且之前的读取尚未完成时抛出未检查的异常。
    ShutdownChannelGroupException
    当尝试构造一个关闭组的通道或I / O操作的完成处理程序无法调用时，抛出未检查的异常，因为通道组已终止。
    UnresolvedAddressException
    尝试在未解析的套接字地址上调用网络操作时抛出未检查的异常。
    UnsupportedAddressTypeException
    尝试绑定或连接到不支持的类型的套接字地址时抛出未检查的异常。
    WritePendingException
    尝试写入异步套接字通道并且之前的写入尚未完成时抛出未检查的异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.nio.channels Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.nio.channels

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel (implements java.nio.channels.Channel, java.nio.channels.InterruptibleChannel)
      • java.nio.channels.FileChannel (implements java.nio.channels.GatheringByteChannel, java.nio.channels.ScatteringByteChannel, java.nio.channels.SeekableByteChannel)
      • java.nio.channels.SelectableChannel (implements java.nio.channels.Channel)
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.DatagramChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.MulticastChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.Pipe.SinkChannel (implements java.nio.channels.GatheringByteChannel, java.nio.channels.WritableByteChannel)
          • java.nio.channels.Pipe.SourceChannel (implements java.nio.channels.ReadableByteChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.ServerSocketChannel (implements java.nio.channels.NetworkChannel)
          • java.nio.channels.SocketChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.NetworkChannel, java.nio.channels.ScatteringByteChannel)
    • java.nio.channels.AsynchronousChannelGroup
    • java.nio.channels.AsynchronousFileChannel (implements java.nio.channels.AsynchronousChannel)
    • java.nio.channels.AsynchronousServerSocketChannel (implements java.nio.channels.AsynchronousChannel, java.nio.channels.NetworkChannel)
    • java.nio.channels.AsynchronousSocketChannel (implements java.nio.channels.AsynchronousByteChannel, java.nio.channels.NetworkChannel)
    • java.nio.channels.Channels
    • java.nio.channels.FileChannel.MapMode
    • java.nio.channels.FileLock (implements java.lang.AutoCloseable)
    • java.nio.channels.MembershipKey
    • java.nio.channels.Pipe
    • java.nio.channels.SelectionKey
    • java.nio.channels.Selector (implements java.io.Closeable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • java.nio.channels.ClosedChannelException
            • java.nio.channels.AsynchronousCloseException
              • java.nio.channels.ClosedByInterruptException
          • java.nio.channels.FileLockInterruptionException
          • java.nio.channels.InterruptedByTimeoutException
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.channels.IllegalChannelGroupException
            • java.nio.channels.IllegalSelectorException
            • java.nio.channels.UnresolvedAddressException
            • java.nio.channels.UnsupportedAddressTypeException
          • java.lang.IllegalStateException
            • java.nio.channels.AcceptPendingException
            • java.nio.channels.AlreadyBoundException
            • java.nio.channels.AlreadyConnectedException
            • java.nio.channels.CancelledKeyException
            • java.nio.channels.ClosedSelectorException
            • java.nio.channels.ConnectionPendingException
            • java.nio.channels.IllegalBlockingModeException
            • java.nio.channels.NoConnectionPendingException
            • java.nio.channels.NonReadableChannelException
            • java.nio.channels.NonWritableChannelException
            • java.nio.channels.NotYetBoundException
            • java.nio.channels.NotYetConnectedException
            • java.nio.channels.OverlappingFileLockException
            • java.nio.channels.ReadPendingException
            • java.nio.channels.ShutdownChannelGroupException
            • java.nio.channels.WritePendingException

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • java.nio.channels.Channel
        • java.nio.channels.AsynchronousChannel
          • java.nio.channels.AsynchronousByteChannel
        • java.nio.channels.InterruptibleChannel
        • java.nio.channels.NetworkChannel
          • java.nio.channels.MulticastChannel
        • java.nio.channels.ReadableByteChannel
          • java.nio.channels.ByteChannel (also extends java.nio.channels.WritableByteChannel)
            • java.nio.channels.SeekableByteChannel
          • java.nio.channels.ScatteringByteChannel
        • java.nio.channels.WritableByteChannel
          • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel)
            • java.nio.channels.SeekableByteChannel
          • java.nio.channels.GatheringByteChannel
  • java.nio.channels.CompletionHandler<V,A>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


MembershipKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class MembershipKey

  • java.lang.Object
    • java.nio.channels.MembershipKey

  • public abstract class MembershipKey
extends Object
    代表互联网协议（IP）组播组成员身份的令牌。

    会员密钥可以表示用于接收发送到组的所有数据报的成员资格，或者它可以是源特定的 ，这意味着它表示仅从特定源地址接收数据报的成员资格。 会员密钥是否是特定于源的可以通过调用其sourceAddress方法来确定。

    会员密钥在创建时有效，并保持有效，直到通过调用drop方法删除会员资格，或者该通道关闭。 会员密钥的有效性可以通过调用其isValid方法来测试。

    在会员密钥不是源特定且底层操作系统支持源过滤的情况下，可以使用block和unblock方法来阻止或解除来自特定源地址的组播数据报。

    从以下版本开始：
    1.7
    另请参见：
    MulticastChannel

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected MembershipKey​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract MembershipKey block​(InetAddress source)
      阻止来自给定源地址的组播数据报。
      abstract MulticastChannel channel​()
      返回创建此成员资格密钥的通道。
      abstract void drop​()
      删除会员资格
      abstract InetAddress group​()
      返回创建此成员资格密钥的多播组。
      abstract boolean isValid​()
      告知这个会员资格是否有效。
      abstract NetworkInterface networkInterface​()
      返回创建此会员密钥的网络接口。
      abstract InetAddress sourceAddress​()
      如果此成员资格密钥是源特定的，则返回源地址，如果此成员资格不是源特定的，则返回 null 。
      abstract MembershipKey unblock​(InetAddress source)
      从以前使用 block方法阻止的给定源地址中解除阻塞多播数据报。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MembershipKey

        protected MembershipKey​()
        初始化此类的新实例。

    • 方法详细信息

      • isValid

        public abstract boolean isValid​()
        告知这个会员资格是否有效。

        多播组成员身份在创建时有效，并保持有效，直到通过调用drop方法删除成员资格，或者通道关闭。

        结果
        true如果该会员密钥有效，否则为 false

      • drop

        public abstract void drop​()
        删除会员资格

        如果会员密钥表示接收所有数据报的会员资格，那么会员资格被删除，并且该频道将不再接收发送到该组的任何数据报。 如果会员密钥是源特定的，则该信道将不再接收从该源地址发送到该组的数据报。

        丢弃成员资格后，仍然可以接收发送给组的数据报。 当数据报等待在套接字的接收缓冲区中接收时，可能会出现这种情况。 成员身份被删除之后，该频道可以再次组合该组，在这种情况下返回一个新的会员密钥。

        返回时，此会员对象将为invalid 。 如果组播组成员身份已经无效，则调用此方法不起作用。 一旦多播组成员资格无效，它将永远无效。

      • block

        public abstract MembershipKey block​(InetAddress source)
                             throws IOException
        阻止来自给定源地址的组播数据报。

        如果此成员密钥不是源特定的，并且底层操作系统支持源过滤，则该方法将阻止来自给定源地址的组播数据报。 如果给定的源地址已经被阻止，那么这个方法没有任何效果。 在源地址被阻塞之后，仍然可以从该源接收数据报。 当数据报等待在套接字的接收缓冲区中接收时，可能会出现这种情况。

        参数
        source - 要阻止的源地址
        结果
        这个会员密钥
        异常
        IllegalArgumentException - 如果 source参数不是单播地址或与组播组不同的地址类型
        IllegalStateException - 如果此会员密钥是源特定的或不再有效
        UnsupportedOperationException - 如果底层操作系统不支持源过滤
        IOException - 如果发生I / O错误

      • unblock

        public abstract MembershipKey unblock​(InetAddress source)
        从以前使用 block方法阻止的给定源地址解除阻塞多播数据报。
        参数
        source - 要解除封锁的源地址
        结果
        这个会员密钥
        异常
        IllegalStateException - 如果给定的源地址当前未被阻止或成员密钥不再有效

      • channel

        public abstract MulticastChannel channel​()
        返回创建此成员资格密钥的通道。 即使成员资格成为invalid，此方法也将继续返回。
        结果
        这个频道

      • group

        public abstract InetAddress group​()
        返回创建此成员资格密钥的多播组。 即使成员资格成为invalid后，此方法也将继续返回该组。
        结果
        组播组

      • networkInterface

        public abstract NetworkInterface networkInterface​()
        返回创建此会员密钥的网络接口。 即使成员资格成为invalid，该方法也将继续返回网络接口。
        结果
        网络接口

      • sourceAddress

        public abstract InetAddress sourceAddress​()
        如果此成员资格密钥是源特定的，则返回源地址，如果此成员资格不是源特定的，则返回 null 。
        结果
        源地址，如果此成员密钥是源特定的，否则为 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MulticastChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface MulticastChannel

  • All Superinterfaces:
    AutoCloseable ， Channel ， Closeable ， NetworkChannel
    所有已知实现类：
    DatagramChannel

    public interface MulticastChannel
extends NetworkChannel
    支持互联网协议（IP）组播的网络通道。

    IP组播是将IP数据报传输到由单个目标地址标识的零个或多个主机的组的成员。

    在通道到IPv4插槽的情况下，底层操作系统可选地支持RFC 2236: Internet Group Management Protocol, Version 2 (IGMPv2) 。 当支持IGMPv2时，操作系统可以另外支持由RFC 3376: Internet Group Management Protocol, Version 3 (IGMPv3)指定的源过滤。 对于IPv6插槽的通道，等效标准为RFC 2710: Multicast Listener Discovery (MLD) for IPv6和RFC 3810: Multicast Listener Discovery Version 2 (MLDv2) for IPv6 。

    join(InetAddress,NetworkInterface)方法用于加入组并接收发送到组的所有组播数据报。 一个频道可以加入多个组播组，并且可以在几个interfaces上加入同一组。 通过在返回的MembershipKey上调用drop方法来删除成员资格。 如果底层平台支持源过滤，则可以使用block和unblock方法来阻止或解除来自特定源地址的组播数据报。

    join(InetAddress,NetworkInterface,InetAddress)方法用于开始接收发送到源地址与给定源地址匹配的组的数据报。 如果基础平台不支持源过滤，此方法将抛出UnsupportedOperationException 。 成员资格是累积的，并且可以使用相同的组和接口再次调用此方法，以允许从其他源地址接收数据报。 该方法返回一个MembershipKey ，表示从给定源地址接收数据报的成员资格。 调用密钥的drop方法删除成员身份，以便不再接收来自源地址的数据报。

    平台依赖

    多播实现旨在直接映射到本地多播设施。 因此，在开发接收IP组播数据报的应用程序时，应考虑以下项目：

    1. 通道的创建应指定与通道将加入的多播组的地址类型相对应的ProtocolFamily 。 当组播组的地址对应于另一个协议族时，不能保证一个协议族中的套接字的通道可以加入和接收组播数据报。 例如，如果到IPv6套接字的通道可以加入IPv4组播组并接收发送到该组的组播数据报，那么它是实现特定的。

    2. 频道的套接字应该绑定到wildcard地址。 如果套接字绑定到特定地址，而不是通配符地址，那么如果套接字接收到组播数据报，那么它是实现特定的。

    3. SO_REUSEADDR选项应在binding套接字之前启用。 这是允许组中的多个成员绑定到相同地址所必需的。

    用法示例：

      // join multicast group on this interface, and also use this
     // interface for outgoing multicast datagrams
     NetworkInterface ni = NetworkInterface.getByName("hme0");

     DatagramChannel dc = DatagramChannel.open(StandardProtocolFamily.INET)
         .setOption(StandardSocketOptions.SO_REUSEADDR, true)
         .bind(new InetSocketAddress(5000))
         .setOption(StandardSocketOptions.IP_MULTICAST_IF, ni);

     InetAddress group = InetAddress.getByName("225.4.5.6");

     MembershipKey key = dc.join(group, ni);
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭此频道。
      MembershipKey join​(InetAddress group, NetworkInterface interf)
      加入组播组，开始接收发送到组的所有数据报，返回成员密钥。
      MembershipKey join​(InetAddress group, NetworkInterface interf, InetAddress source)
      加入组播组，开始从给定的源地址接收发送到组的数据报。

      • Methods inherited from interface java.nio.channels.Channel

        isOpen

      • Methods inherited from interface java.nio.channels.NetworkChannel

        bind, getLocalAddress, getOption, setOption, supportedOptions

    • 方法详细信息

      • close

        void close​()
    throws IOException
        关闭此频道。

        如果频道是多播组的成员，那么会员资格是dropped 。 返回时， membership-key将为invalid 。

        该方法的行为与Channel接口的规定完全相同。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Channel
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误

      • join

        MembershipKey join​(InetAddress group,
                   NetworkInterface interf)
            throws IOException
        加入组播组，开始接收发送到组的所有数据报，返回成员密钥。

        如果此通道当前是给定接口上的组的成员以接收所有数据报，则返回表示该成员身份的成员资格。 否则，此通道加入组，并返回所得到的新会员密钥。 所得到的会员密钥不是source-specific 。

        组播信道可以加入多个组播组，包括多个接口上的同一组播组。 实施可能会对可能同时加入的组的数量施加限制。

        参数
        group - 要加入的组播地址
        interf - 要加入组的网络接口
        结果
        会员密钥
        异常
        IllegalArgumentException - 如果组参数不是 multicast地址，或者组参数是此通道不支持的地址类型
        IllegalStateException - 如果通道在接口上已经具有该组的源特定成员资格
        UnsupportedOperationException - 如果通道的套接字不是Internet协议套接字，或者平台不支持组播
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        SecurityException - 如果设置了安全管理器，并且其 checkMulticast方法拒绝对多组组的访问

      • join

        MembershipKey join​(InetAddress group,
                   NetworkInterface interf,
                   InetAddress source)
            throws IOException
        加入组播组，开始从给定的源地址接收发送到组的数据报。

        如果此通道当前是给定接口上的组的成员，以从给定的源地址接收数据报，则返回表示该成员资格的成员资格。 否则，此通道加入组，并返回所得到的新会员密钥。 所得的会员密钥为source-specific 。

        成员资格是累积的，并且可以使用相同的组和接口再次调用此方法，以允许接收其他源地址发送给组的数据报。

        参数
        group - 要加入的组播地址
        interf - 要加入组的网络接口
        source - 源地址
        结果
        会员密钥
        异常
        IllegalArgumentException - 如果组参数不是 multicast地址，则源参数不是单播地址，组参数是此通道不支持的地址类型，或者源参数与组的地址类型不同
        IllegalStateException - 如果通道当前是给定接口上的组的成员以接收所有数据报
        UnsupportedOperationException - 如果通道的套接字不是Internet协议套接字，或不支持源过滤，或者平台不支持组播
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        SecurityException - 如果设置了安全管理员，并且其 checkMulticast方法拒绝对多组组的访问
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NetworkChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface NetworkChannel

  • All Superinterfaces:
    AutoCloseable ， Channel ， Closeable
    All Known Subinterfaces:
    MulticastChannel
    所有已知实现类：
    AsynchronousServerSocketChannel ， AsynchronousSocketChannel ， DatagramChannel ， ServerSocketChannel ， SocketChannel

    public interface NetworkChannel
extends Channel
    到网络插座的通道。

    实现此接口的通道是通向网络套接字的通道。 该bind方法用于套接字绑定到本地address ，所述getLocalAddress方法返回套接字绑定到的地址，所述setOption种getOption方法用于设置和查询套接字选项。 此接口的实现应指定其支持的套接字选项。

    指定了否则不具有返回值的bind和setOption方法，以返回调用它们的网络通道。 这允许方法调用被链接。 该接口的实现应该专门化返回类型，以便可以链接实现类上的方法调用。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      NetworkChannel bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      SocketAddress getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      <T> T getOption​(SocketOption<T> name)
      返回套接字选项的值。
      <T> NetworkChannel setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      Set<SocketOption<?>> supportedOptions​()
      返回此通道支持的一组套接字选项。

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

    • 方法详细信息

      • bind

        NetworkChannel bind​(SocketAddress local)
             throws IOException
        将通道的套接字绑定到本地地址。

        该方法用于在套接字和本地地址之间建立关联。 一旦建立关联，则套接字保持绑定，直到通道关闭。 如果local参数的值为null则套接字将被绑定到自动分配的地址。

        参数
        local - 绑定套接字的地址，或 null将套接字绑定到自动分配的套接字地址
        结果
        这个频道
        异常
        AlreadyBoundException - 如果套接字已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生其他I / O错误
        SecurityException - 如果安装了安全管理器，并且拒绝了未指定的权限。 此接口的实现应指定任何所需的权限。
        另请参见：
        getLocalAddress()

      • getLocalAddress

        SocketAddress getLocalAddress​()
                       throws IOException
        返回此通道的套接字所绑定的套接字地址。

        通道为Internet协议套接字地址的通道为bound ，则此方法的返回值为InetSocketAddress 。

        结果
        套接字绑定的套接字地址，如果通道的套接字未绑定， null
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误

      • setOption

        <T> NetworkChannel setOption​(SocketOption<T> name,
                             T value)
                      throws IOException
        设置套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能是某些套接字选项的有效值。
        结果
        这个频道
        异常
        UnsupportedOperationException - 如果此通道不支持套接字选项
        IllegalArgumentException - 如果该值不是此套接字选项的有效值
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        另请参见：
        StandardSocketOptions

      • getOption

        <T> T getOption​(SocketOption<T> name)
         throws IOException
        返回套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        结果
        套接字选项的值。 值为null可能是某些套接字选项的有效值。
        异常
        UnsupportedOperationException - 如果该通道不支持套接字选项
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        另请参见：
        StandardSocketOptions

      • supportedOptions

        Set<SocketOption<?>> supportedOptions​()
        返回此通道支持的一组套接字选项。

        即使通道关闭后，此方法仍将继续返回该选项。

        结果
        A set of the socket options supported by this channel
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NoConnectionPendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class NoConnectionPendingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.NoConnectionPendingException
  • All Implemented Interfaces:
    Serializable

    public class NoConnectionPendingException
extends IllegalStateException
    当未经检查的异常finishConnect一个方法SocketChannel没有首先成功调用被调用connect方法。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoConnectionPendingException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoConnectionPendingException

        public NoConnectionPendingException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NonReadableChannelException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class NonReadableChannelException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.NonReadableChannelException
  • All Implemented Interfaces:
    Serializable

    public class NonReadableChannelException
extends IllegalStateException
    尝试从最初打开阅读的频道中读取时未抛出的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NonReadableChannelException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NonReadableChannelException

        public NonReadableChannelException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NonWritableChannelException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class NonWritableChannelException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.NonWritableChannelException
  • All Implemented Interfaces:
    Serializable

    public class NonWritableChannelException
extends IllegalStateException
    尝试写入最初未打开的通道进行写入时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NonWritableChannelException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NonWritableChannelException

        public NonWritableChannelException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NotYetBoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class NotYetBoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.NotYetBoundException
  • All Implemented Interfaces:
    Serializable

    public class NotYetBoundException
extends IllegalStateException
    尝试在尚未绑定的服务器套接字通道上调用I / O操作时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NotYetBoundException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NotYetBoundException

        public NotYetBoundException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NotYetConnectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class NotYetConnectedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.NotYetConnectedException
  • All Implemented Interfaces:
    Serializable

    public class NotYetConnectedException
extends IllegalStateException
    当尝试在尚未连接的套接字通道上调用I / O操作时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NotYetConnectedException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NotYetConnectedException

        public NotYetConnectedException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OverlappingFileLockException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class OverlappingFileLockException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.OverlappingFileLockException
  • All Implemented Interfaces:
    Serializable

    public class OverlappingFileLockException
extends IllegalStateException
    当尝试获取与已经被同一Java虚拟机锁定的区域重叠的文件的区域上，或者当另一个线程已经在等待锁定同一文件的重叠区域时尝试获取未锁定的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      OverlappingFileLockException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • OverlappingFileLockException

        public OverlappingFileLockException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Pipe (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class Pipe

  • java.lang.Object
    • java.nio.channels.Pipe

  • public abstract class Pipe
extends Object
    实现单向管道的一对通道。

    管道由一对通道组成：可写sink通道和可读的source通道。 一旦将某些字节写入接收器通道，就可以从源通道按照它们写入的顺序读取它们。

    是否将线程写入管道的字节将阻塞，直到另一个线程从管道读取这些字节或某些先前写入的字节为依赖系统，因此未指定。 许多管道实现将在宿和源通道之间缓冲达一定数量的字节，但是不应该假定这样的缓冲。

    从以下版本开始：
    1.4

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Pipe.SinkChannel
      一个代表Pipe可写端的通道 。
      static class  Pipe.SourceChannel
      表示Pipe的可读端的通道 。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Pipe​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static Pipe open​()
      打开管道。
      abstract Pipe.SinkChannel sink​()
      返回此管道的接收通道。
      abstract Pipe.SourceChannel source​()
      返回此管道的源通道。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Pipe

        protected Pipe​()
        初始化此类的新实例。

    • 方法详细信息

      • source

        public abstract Pipe.SourceChannel source​()
        返回此管道的源通道。
        结果
        这个管道的渠道

      • sink

        public abstract Pipe.SinkChannel sink​()
        返回此管道的接收通道。
        结果
        这个管道的水槽通道

      • open

        public static Pipe open​()
                 throws IOException
        打开管道。

        新管道是通过调用系统范围默认的SelectorProvider对象的openPipe方法创建的。

        结果
        一个新的管道
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Pipe.SinkChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class Pipe.SinkChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.Pipe.SinkChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Channel ， GatheringByteChannel ， InterruptibleChannel ， WritableByteChannel
    Enclosing class:
    Pipe

    public abstract static class Pipe.SinkChannel
extends AbstractSelectableChannel
implements WritableByteChannel, GatheringByteChannel
    一个代表Pipe可写端的通道 。
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SinkChannel​(SelectorProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int validOps​()
      返回确定此频道支持的操作的操作集。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, isOpen

      • Methods inherited from class java.nio.channels.spi.AbstractSelectableChannel

        blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from interface java.nio.channels.GatheringByteChannel

        write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.SelectableChannel

        register

      • Methods inherited from interface java.nio.channels.WritableByteChannel

        write

    • 构造方法详细信息

      • SinkChannel

        protected SinkChannel​(SelectorProvider provider)
        初始化此类的新实例。
        参数
        provider - 选择器提供程序

    • 方法详细信息

      • validOps

        public final int validOps​()
        返回确定此频道支持的操作的操作集。

        管道通道只支持写入，所以此方法返回SelectionKey.OP_WRITE 。

        Specified by:
        validOps在 SelectableChannel
        结果
        有效操作集
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Pipe.SourceChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class Pipe.SourceChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.Pipe.SourceChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Channel ， InterruptibleChannel ， ReadableByteChannel ， ScatteringByteChannel
    Enclosing class:
    Pipe

    public abstract static class Pipe.SourceChannel
extends AbstractSelectableChannel
implements ReadableByteChannel, ScatteringByteChannel
    表示Pipe的可读端的通道 。
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SourceChannel​(SelectorProvider provider)
      构造一个这个类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int validOps​()
      返回确定此频道支持的操作的操作集。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, isOpen

      • Methods inherited from class java.nio.channels.spi.AbstractSelectableChannel

        blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.nio.channels.ReadableByteChannel

        read

      • Methods inherited from interface java.nio.channels.ScatteringByteChannel

        read, read

      • Methods inherited from class java.nio.channels.SelectableChannel

        register

    • 构造方法详细信息

      • SourceChannel

        protected SourceChannel​(SelectorProvider provider)
        构造一个这个类的新实例。
        参数
        provider - 选择器提供程序

    • 方法详细信息

      • validOps

        public final int validOps​()
        返回确定此频道支持的操作的操作集。

        管道信道仅支持读取，所以此方法返回SelectionKey.OP_READ 。

        Specified by:
        validOps在 SelectableChannel
        结果
        有效操作集
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadableByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface ReadableByteChannel

  • All Superinterfaces:
    AutoCloseable ， Channel ， Closeable
    All Known Subinterfaces:
    ByteChannel ， ScatteringByteChannel ， SeekableByteChannel
    所有已知实现类：
    DatagramChannel ， FileChannel ， Pipe.SourceChannel ， SocketChannel

    public interface ReadableByteChannel
extends Channel
    一个可以读取字节的通道。

    在任何给定的时间，只有一个可读通道上的读操作才能进行。 如果一个线程在通道上启动读取操作，那么尝试启动另一个读取操作的任何其他线程将阻塞，直到第一个操作完成。 其他类型的I / O操作是否可以与读取操作同时进行取决于通道的类型。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

    • 方法详细信息

      • read

        int read​(ByteBuffer dst)
  throws IOException
        从该通道读取到给定缓冲区的字节序列。

        尝试从通道读取r个字节，其中r是缓冲区中剩余的字节数，即dst.remaining() ，在此方法被调用的时刻。

        假设长度为n的字节序列被读取，其中0 <= n <= r 。 该字节序列将被转移到缓冲器，使得序列中的第一个字节是在索引p和最后一个字节是在索引p + Ñ - 1 ，其中p是该缓冲区的在调用此方法的瞬间位置。 缓冲区的返回位置将等于p + n ; 其限制将不会改变。

        读取操作可能不会填充缓冲区，实际上它可能不会读取任何字节。 是否这样做取决于渠道的性质和状态。 例如，非阻塞模式的套接字通道不能再读取比从套接字的输入缓冲区立即可用的任何字节数; 类似地，文件通道不能读取比保留在文件中的任何更多的字节。 但是，如果通道处于阻塞模式，并且缓冲区中至少剩余一个字节，则该方法将被阻塞，直到读取至少一个字节为止。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了读取操作，那么此方法的调用将阻塞，直到第一个操作完成。

        参数
        dst - 要传输字节的缓冲区
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        NonReadableChannelException - 如果此频道未打开阅读
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadPendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class ReadPendingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.ReadPendingException
  • All Implemented Interfaces:
    Serializable

    public class ReadPendingException
extends IllegalStateException
    尝试从异步套接字通道读取并且之前的读取尚未完成时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadPendingException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ReadPendingException

        public ReadPendingException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScatteringByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface ScatteringByteChannel

  • All Superinterfaces:
    AutoCloseable ， Channel ， Closeable ， ReadableByteChannel
    所有已知实现类：
    DatagramChannel ， FileChannel ， Pipe.SourceChannel ， SocketChannel

    public interface ScatteringByteChannel
extends ReadableByteChannel
    可以将字节读入缓冲区序列的通道。

    散射读取操作在单个调用中将字节序列读入给定的缓冲器序列中的一个或多个。 当实现网络协议或文件格式时，散射读取通常是有用的，例如，将数据分组成由一个或多个固定长度的标题后跟可变长度的主体组成的段。 GatheringByteChannel界面中定义了类似的采集写入操作。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long read​(ByteBuffer[] dsts)
      从该通道读取到给定缓冲区的字节序列。
      long read​(ByteBuffer[] dsts, int offset, int length)
      从该通道读取字节序列到给定缓冲区的子序列中。

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from interface java.nio.channels.ReadableByteChannel

        read

    • 方法详细信息

      • read

        long read​(ByteBuffer[] dsts,
          int offset,
          int length)
   throws IOException
        从该通道读取字节序列到给定缓冲区的子序列中。

        该方法的调用尝试从该通道读取r个字节，其中r是给定缓冲区数组的指定子序列剩余的总字节数，也就是说，

         dsts[offset].remaining()
     + dsts[offset+1].remaining()
     + ... + dsts[offset+length-1].remaining()
        在此方法被调用的时刻。

        假设长度为n的字节序列被读取，其中0 <= n <= r 。 该序列的最初dsts[offset].remaining()个字节被传送到缓冲区dsts[offset] ，直到下一个dsts[offset+1].remaining()字节被传送到缓冲区dsts[offset+1]等等，直到整个字节序列被传送到给定的缓冲区。 尽可能多的字节被传送到每个缓冲器中，因此除了最后更新的缓冲器之外，每个更新的缓冲器的最终位置被保证等于该缓冲器的限制。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了读取操作，那么此方法的调用将阻塞，直到第一个操作完成。

        参数
        dsts - 要传输字节的缓冲区
        offset - 要传输字节的第一个缓冲区的缓冲区中的偏移量; 必须是非负数，不得大于dsts.length
        length - 要访问的缓冲区的最大数量; 必须是非负数，不得大于dsts.length - offset
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        IndexOutOfBoundsException - 如果 offset和 length参数的前提条件不成立
        NonReadableChannelException - 如果此通道未打开阅读
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • read

        long read​(ByteBuffer[] dsts)
   throws IOException
        从该通道读取到给定缓冲区的字节序列。

        对这种c.read(dsts)形式的方法的调用与调用的方式完全相同

         c.read(dsts, 0, dsts.length);
        参数
        dsts - 要传输字节的缓冲区
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        NonReadableChannelException - 如果此通道未打开读取
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - If some other I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SeekableByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface SeekableByteChannel

  • All Superinterfaces:
    AutoCloseable ， ByteChannel ， Channel ， Closeable ， ReadableByteChannel ， WritableByteChannel
    所有已知实现类：
    FileChannel

    public interface SeekableByteChannel
extends ByteChannel
    保持当前位置并允许更改位置的字节通道。

    可寻址字节通道连接到一个实体，通常是一个文件，它包含可读取和写入的可变长度的字节序列。 当前位置可以是queried和modified 。 通道还可以访问通道所连接的实体的当前大小 。 当字节写入超过其当前大小时，大小增加; 当它是truncated时，尺寸减小。

    指定不另外具有值返回的position和truncate方法来返回它们被调用的通道。 这允许方法调用被链接。 该接口的实现应该专门化返回类型，以便可以链接实现类上的方法调用。

    从以下版本开始：
    1.7
    另请参见：
    Files.newByteChannel(java.nio.file.Path, java.util.Set<? extends java.nio.file.OpenOption>, java.nio.file.attribute.FileAttribute<?>...)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long position​()
      返回此频道的位置。
      SeekableByteChannel position​(long newPosition)
      设置此频道的位置。
      int read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      long size​()
      返回此通道连接到的实体的当前大小。
      SeekableByteChannel truncate​(long size)
      将连接此通道的实体截断为给定的大小。
      int write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

    • 方法详细信息

      • read

        int read​(ByteBuffer dst)
  throws IOException
        从该通道读取到给定缓冲区的字节序列。

        从该通道的当前位置开始读取字节，然后使用实际读取的字节数来更新位置。 否则，此方法的行为与ReadableByteChannel接口中的规定完全相同。

        Specified by:
        read在接口 ReadableByteChannel
        参数
        dst - 要传输字节的缓冲区
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        ClosedChannelException - 如果此频道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        int write​(ByteBuffer src)
   throws IOException
        从给定的缓冲区向该通道写入一个字节序列。

        字节从该通道的当前位置开始写入，除非通道连接到一个实体，例如使用APPEND选项打开的文件，在这种情况下，该位置首先提前到最后。 如果需要，生成通道所连接的实体以容纳写入的字节，然后用实际写入的字节数来更新位置。 否则，此方法的行为与WritableByteChannel接口的规定完全相同。

        Specified by:
        write接口 WritableByteChannel
        参数
        src - 要检索字节的缓冲区
        结果
        写入的字节数，可能为零
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • position

        long position​()
       throws IOException
        返回此频道的位置。
        结果
        该通道的位置是从实体开始到当前位置的非负整数
        异常
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误

      • position

        SeekableByteChannel position​(long newPosition)
                      throws IOException
        设置此频道的位置。

        将位置设置为大于当前大小的值是合法的，但不会更改实体的大小。 稍后在这样的位置读取字节的尝试将立即返回文件结束指示。 稍后在这样的位置写入字节的尝试将导致实体增长以适应新字节; 未指定上一个文件结尾和新写入的字节之间的任何字节的值。

        连接到通过APPEND选项打开的实体（通常为文件）时，不建议设置通道的位置。 当打开追加时，该位置首先在写入之前提前到最后。

        参数
        newPosition - 新位置，一个非负整数，从实体的开始计数字节数
        结果
        这个频道
        异常
        ClosedChannelException - 如果此通道关闭
        IllegalArgumentException - 如果新位置为负
        IOException - 如果发生其他I / O错误

      • size

        long size​()
   throws IOException
        返回此通道连接到的实体的当前大小。
        结果
        当前大小，以字节为单位
        异常
        ClosedChannelException - 如果此频道关闭
        IOException - 如果发生其他I / O错误

      • truncate

        SeekableByteChannel truncate​(long size)
                      throws IOException
        将连接此通道的实体截断为给定的大小。

        如果给定的大小小于当前大小，那么实体将被截断，丢弃超出新端的字节。 如果给定的大小大于或等于当前大小，则实体不被修改。 在任一种情况下，如果当前位置大于给定大小，则将其设置为该大小。

        此接口的实现可能会禁止在连接到通过APPEND选项打开的实体（通常为文件）时进行截断。

        参数
        size - 新的大小，非负字节数
        结果
        这个频道
        异常
        NonWritableChannelException - 如果这个频道没有开放写作
        ClosedChannelException - 如果此通道关闭
        IllegalArgumentException - 如果新的大小为负数
        IOException - 如果发生其他I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SelectableChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class SelectableChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Channel ， InterruptibleChannel
    已知直接子类：
    AbstractSelectableChannel

    public abstract class SelectableChannel
extends AbstractInterruptibleChannel
implements Channel
    可通过Selector复用的通道 。

    为了与选择器一起使用，此类的实例必须首先通过register方法注册 。 此方法返回一个新的SelectionKey对象，表示通道对选择器的注册。

    一旦注册了选择器，通道保持注册，直到它被注销 。 这包括通过选择器取消分配给频道的任何资源。

    渠道不能直接注销; 而是代表其注册的密钥必须被取消 。 取消密钥请求在选择器的下一个选择操作期间注销通道。 可以通过调用其cancel方法明确地取消密钥。 无论通过调用其close方法还是通过中断在通道上I / O操作中阻塞的线程，通道关闭时，所有通道的密钥都将被隐式取消。

    如果选择器本身被关闭，那么该通道将被注销，并且表示其注册的密钥将被无效，而不再延迟。

    任何特定选择器最多可以注册一个通道。

    可以通过调用isRegistered方法来确定频道是否向一个或多个选择器注册。

    可选择的通道可安全使用多个并发线程。

    阻塞模式

    可选通道处于阻塞模式或非阻塞模式。 在阻塞模式下，通道上调用的每个I / O操作将阻塞直到完成。 在非阻塞模式下，I / O操作将永远不会阻塞，并且可能会传输比所请求的字节更少的字节，或者根本没有字节。 可选择的信道的阻塞模式可以通过调用其isBlocking方法来确定。

    新创建的可选通道始终处于阻止模式。 非阻塞模式与基于选择器的复用最为有用。 一个通道在被注册到选择器之前必须被置于非阻塞模式，并且在被注销之前可能不会返回到阻塞模式。

    从以下版本开始：
    1.4
    另请参见：
    SelectionKey ， Selector

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SelectableChannel​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Object blockingLock​()
      检索 configureBlocking和 register方法同步的对象。
      abstract SelectableChannel configureBlocking​(boolean block)
      调整此频道的屏蔽模式。
      abstract boolean isBlocking​()
      告诉这个通道上的每个I / O操作是否会阻塞直到完成。
      abstract boolean isRegistered​()
      告知这个频道当前是否在任何选择器上注册。
      abstract SelectionKey keyFor​(Selector sel)
      检索表示频道注册的键与给定的选择器。
      abstract SelectorProvider provider​()
      返回创建此通道的提供程序。
      SelectionKey register​(Selector sel, int ops)
      使用给定的选择器注册此频道，返回一个选择键。
      abstract SelectionKey register​(Selector sel, int ops, Object att)
      使用给定的选择器注册此频道，返回一个选择键。
      abstract int validOps​()
      返回一个 operation set标识该频道支持的操作。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, implCloseChannel, isOpen

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SelectableChannel

        protected SelectableChannel​()
        初始化此类的新实例。

    • 方法详细信息

      • provider

        public abstract SelectorProvider provider​()
        返回创建此通道的提供程序。
        结果
        创建此频道的提供商

      • validOps

        public abstract int validOps​()
        返回一个operation set标识该频道支持的操作。 在此整数值中设置的位正好表示对该通道有效的操作。 该方法总是为给定的具体通道类返回相同的值。
        结果
        有效操作集

      • isRegistered

        public abstract boolean isRegistered​()
        告知这个频道当前是否在任何选择器上注册。 新创建的频道未注册。

        由于键取消和通道注销之间的固有延迟，在所有键被取消之后，频道可能会保留一段时间。 通道关闭后也可能会保留一段时间。

        结果
        true如果，且仅当此频道注册

      • keyFor

        public abstract SelectionKey keyFor​(Selector sel)
        检索表示频道注册的键与给定的选择器。
        参数
        sel - 选择器
        结果
        当该频道最后一次向给定选择器注册时返回该键，如果该频道当前未注册该选择器，则 null

      • register

        public abstract SelectionKey register​(Selector sel,
                                      int ops,
                                      Object att)
                               throws ClosedChannelException
        使用给定的选择器注册此频道，返回一个选择键。

        如果该通道当前已经向给定的选择器注册，则返回表示该注册的选择键。 密钥的兴趣集将更改为ops ，好像通过调用interestOps(int)方法。 如果att参数不是null则键的附件将被设置为该值。 如果该键已被取消，将抛出CancelledKeyException 。

        否则，此通道尚未注册到给定的选择器，因此已注册，并返回所产生的新密钥。 关键的初始利息为ops ，其附件为att 。

        可以随时调用此方法。 如果在方法或configureBlocking方法的另一个调用中调用此方法，那么它将首先阻止，直到另一个操作完成。 然后，该方法将在选择器的密钥集上同步，因此如果与涉及相同选择器的另一个注册或选择操作同时调用，则可能会阻止该方法。

        如果此通道在此操作进行中关闭，则此方法返回的密钥将被取消，因此将无效。

        参数
        sel - 要注册该通道的选择器
        ops - 为结果键设置的兴趣
        att - 所得密钥的附件; 可以是null
        结果
        表示该通道与给定选择器的注册的键
        异常
        ClosedChannelException - 如果此通道关闭
        ClosedSelectorException - 如果选择器关闭
        IllegalBlockingModeException - 如果此通道处于阻塞模式
        IllegalSelectorException - 如果此通道不是由与给定选择器相同的提供程序创建的
        CancelledKeyException - 如果此通道当前已注册到给定的选择器，但相应的键已被取消
        IllegalArgumentException - 如果 ops集合中的某个位与此通道支持的操作不对应，即 set & ~validOps() != 0

      • register

        public final SelectionKey register​(Selector sel,
                                   int ops)
                            throws ClosedChannelException
        使用给定的选择器注册此频道，返回一个选择键。

        调用这种方便的方式的形式

        sc.register(sel, ops)
        行为与调用完全相同
        sc. register(sel, ops, null)
        参数
        sel - 要注册该频道的选择器
        ops - 为结果键设置的兴趣
        结果
        表示该通道与给定选择器的注册的键
        异常
        ClosedChannelException - 如果此通道关闭
        ClosedSelectorException - 如果选择器关闭
        IllegalBlockingModeException - 如果此通道处于阻塞模式
        IllegalSelectorException - 如果此通道不是由与给定选择器相同的提供程序创建的
        CancelledKeyException - 如果此频道当前已向给定的选择器注册，但对应的密钥已被取消
        IllegalArgumentException - 如果 IllegalArgumentException中的 ops与本频道支持的操作不对应，即 set & ~validOps() != 0

      • configureBlocking

        public abstract SelectableChannel configureBlocking​(boolean block)
                                             throws IOException
        调整此频道的屏蔽模式。

        如果该通道已经被一个或多个选择器注册，那么尝试将其置于阻塞模式将导致抛出IllegalBlockingModeException 。

        可以随时调用此方法。 新的阻塞模式将仅影响此方法返回后启动的I / O操作。 对于一些实现，这可能需要阻塞，直到所有待处理的I / O操作完成。

        如果此方法被调用，而此方法或register方法的另一个调用正在进行中，则它将首先阻止，直到另一个操作完成。

        参数
        block - 如果true那么这个通道将被置于阻塞模式; 如果false那么它将被放置为非阻塞模式
        结果
        这个可选频道
        异常
        ClosedChannelException - 如果此频道关闭
        IllegalBlockingModeException - 如果 block是 true并且该信道被注册到一个或多个选择器
        IOException - 如果发生I / O错误

      • isBlocking

        public abstract boolean isBlocking​()
        告诉这个通道上的每个I / O操作是否会阻塞直到完成。 新创建的通道始终处于阻止模式。

        如果此通道关闭，则此方法返回的值未指定。

        结果
        true如果且仅当此通道处于阻止模式时

      • blockingLock

        public abstract Object blockingLock​()
        检索configureBlocking和register方法同步的对象。 这在实现需要在短时间内保持特定阻塞模式的适配器通常是有用的。
        结果
        阻塞模式锁定对象
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SelectionKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class SelectionKey

  • java.lang.Object
    • java.nio.channels.SelectionKey
  • 已知直接子类：
    AbstractSelectionKey

    public abstract class SelectionKey
extends Object
    代表SelectableChannel与Selector的注册的令牌。

    每当通道被选择器注册时，都会创建一个选择键。 直到它被调用其取消一个关键保持有效cancel方法，通过关闭它的信道，或通过关闭它的选择器。 取消键不会立即将其从选择器中删除; 而是在下一个选择操作期间将其添加到选择器的cancelled-key set中以进行删除。 密钥的有效性可以通过调用其isValid方法来测试。

    选择键包含以整数值表示的两个操作集 。 操作集的每一位表示由密钥通道支持的可选择操作的类别。

    • 兴趣集确定下一次调用选择器的选择方法之一后，准备测试哪些操作类别。 兴趣集在创建密钥时用给定的值初始化; 它可以稍后通过interestOps(int)方法进行更改。

    • 准备集标识了键的选择器已经检测到密钥通道已准备就绪的操作类别。 当创建密钥时，就绪集被初始化为零; 可能在选择操作期间可能会被选择器更新，但不能直接更新。

    选择键的就绪集表示其通道对某些操作类别做好准备是一个提示，但不能保证这样的类别中的操作可以由线程执行而不会导致线程阻塞。 在完成选择操作之后，准备好的集合很可能是准确的。 外部事件和相应通道上调用的I / O操作可能不准确。

    该类定义了所有已知的操作设置位，但是确切地说，给定通道支持哪些位取决于通道的类型。 SelectableChannel的每个子类定义了一个validOps()方法，它返回一组仅识别通道支持的操作的集合。 尝试设置或测试密钥通道不支持的操作集位将导致适当的运行时异常。

    通常需要将某些特定于应用程序的数据与选择密钥相关联，例如表示较高级别协议的状态的对象，并处理就绪通知以实现该协议。 因此，选择键支持将单个任意对象附加到键。 可以通过attach方法附加一个对象，然后通过attachment方法检索。

    多个并发线程使用选择键是安全的。 通常，读取和写入兴趣集的操作将与选择器的某些操作同步。 正是这种同步的执行方式取决于实现：在天真的实现中，如果选择操作已经进行，则读取或写入兴趣集可能会无限期地阻止; 在高性能的实施中，阅读或写入兴趣集可能会暂时阻止，如果有的话。 在任何情况下，选择操作将始终使用在操作开始时当前的兴趣值。

    从以下版本开始：
    1.4
    另请参见：
    SelectableChannel ， Selector

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int OP_ACCEPT
      操作集位用于插座接受操作。
      static int OP_CONNECT
      用于套接字连接操作的操作集位。
      static int OP_READ
      读操作的操作位。
      static int OP_WRITE
      写操作的操作位。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SelectionKey​()
      构造这个类的一个实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object attach​(Object ob)
      将给定对象附加到此键。
      Object attachment​()
      检索当前附件。
      abstract void cancel​()
      要求取消该密钥的通道与其选择器的注册。
      abstract SelectableChannel channel​()
      返回创建此键的通道。
      abstract int interestOps​()
      检索此密钥的兴趣集。
      abstract SelectionKey interestOps​(int ops)
      将此键的兴趣设置为给定值。
      boolean isAcceptable​()
      测试此密钥的通道是否已准备好接受新的套接字连接。
      boolean isConnectable​()
      测试此密钥的通道是否已完成或未完成其套接字连接操作。
      boolean isReadable​()
      测试此密钥的频道是否可以阅读。
      abstract boolean isValid​()
      告知这个密钥是否有效。
      boolean isWritable​()
      测试此密钥的通道是否准备好进行写入。
      abstract int readyOps​()
      检索此密钥的即用操作集。
      abstract Selector selector​()
      返回创建此键的选择器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OP_READ

        public static final int OP_READ
        读操作的操作位。

        假设选择键的兴趣集在OP_READ开始时包含OP_READ 。 如果选择器检测到相应的通道已准备好进行读取，已经达到流出端，已被远程关闭以进一步读取，或者出现错误等待，那么它将添加OP_READ到密钥的就绪操作集并添加它的选择键集的关键。

        另请参见：
        Constant Field Values

      • OP_WRITE

        public static final int OP_WRITE
        写操作的操作位。

        假设选择键的兴趣集在OP_WRITE开始时包含OP_WRITE 。 如果选择器检测到相应的通道已准备好进行写入，则已被远程关闭进一步写入，或者出现错误等待，那么将会将OP_WRITE添加到密钥的准备集中，并将密钥添加到其选定的密钥集中。

        另请参见：
        Constant Field Values

      • OP_CONNECT

        public static final int OP_CONNECT
        用于套接字连接操作的操作集位。

        假设选择键的兴趣集在OP_CONNECT开始时包含OP_CONNECT 。 如果选择器检测到相应的套接字通道准备好完成其连接顺序，或者出现错误等待，那么它将添加OP_CONNECT到密钥的准备集合，并将密钥添加到其选定密钥集。

        另请参见：
        Constant Field Values

      • OP_ACCEPT

        public static final int OP_ACCEPT
        操作集位用于插座接受操作。

        假设选择键的兴趣集在OP_ACCEPT的开头包含OP_ACCEPT 。 如果选择器检测到相应的服务器套接字通道准备好接受另一个连接，或者出现错误等待，那么它将添加OP_ACCEPT到密钥的准备集合，并将密钥添加到其选定的密钥集。

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SelectionKey

        protected SelectionKey​()
        构造这个类的一个实例。

    • 方法详细信息

      • channel

        public abstract SelectableChannel channel​()
        返回创建此键的通道。 该方法即使在取消键之后仍将继续返回通道。
        结果
        这个键的通道

      • selector

        public abstract Selector selector​()
        返回创建此键的选择器。 该方法即使在取消键之后也会继续返回选择器。
        结果
        此键的选择器

      • isValid

        public abstract boolean isValid​()
        告知这个密钥是否有效。

        钥匙在创建时有效，并保持原样，直到它被取消，其通道关闭或其选择器关闭。

        结果
        true如果，且仅当此密钥有效

      • cancel

        public abstract void cancel​()
        要求取消该密钥的通道与其选择器的注册。 返回后，密钥将无效，并将被添加到其选择器的已取消密钥集中。 在下一次选择操作期间，钥匙将从所有选择器的钥匙组中移除。

        如果此键已被取消，则调用此方法不起作用。 一旦取消，钥匙永远无效。

        可以随时调用此方法。 它在选择器的取消键集合上同步，因此如果同时使用涉及相同选择器的取消或选择操作同时调用。

      • interestOps

        public abstract int interestOps​()
        检索此密钥的兴趣集。

        保证返回的集合只包含对该密钥的通道有效的操作位。

        可以随时调用此方法。 它是否阻止，以及实施依赖于多长时间。

        结果
        这个钥匙的兴趣集
        异常
        CancelledKeyException - 如果该键已被取消

      • interestOps

        public abstract SelectionKey interestOps​(int ops)
        将此键的兴趣设置为给定值。

        可以随时调用此方法。 它是否阻止，以及实施依赖于多长时间。

        参数
        ops - 新的兴趣集
        结果
        该选择键
        异常
        IllegalArgumentException - 如果集合中的某个位不对应于此密钥通道支持的操作，即 (ops & ~channel().validOps()) != 0
        CancelledKeyException - 如果此键已取消

      • readyOps

        public abstract int readyOps​()
        检索此密钥的即用操作集。

        保证返回的集合只包含对该密钥的通道有效的操作位。

        结果
        这个钥匙的就绪操作集
        异常
        CancelledKeyException - 如果此键已取消

      • isReadable

        public final boolean isReadable​()
        测试此密钥的频道是否可以阅读。

        对这种k.isReadable()形式的方法的调用与表达式完全相同

 k.readyOps() & OP_READ != 0

        如果此键的通道不支持读取操作，则此方法始终返回false 。

        结果
        true如果，并且只有 readyOps() & OP_READ是非零
        异常
        CancelledKeyException - 如果此键已取消

      • isWritable

        public final boolean isWritable​()
        测试此密钥的通道是否准备好进行写入。

        表达式k.isWritable()的此方法的调用与表达式完全相同

 k.readyOps() & OP_WRITE != 0

        如果此键的通道不支持写操作，则此方法始终返回false 。

        结果
        true如果，且仅当 readyOps() & OP_WRITE为非零
        异常
        CancelledKeyException - 如果该键已被取消

      • isConnectable

        public final boolean isConnectable​()
        测试此密钥的通道是否已完成或未完成其套接字连接操作。

        这种k.isConnectable()形式的方法的调用与表达式完全相同

 k.readyOps() & OP_CONNECT != 0

        如果此键的通道不支持套接字连接操作，则此方法始终返回false 。

        结果
        true如果，且仅当 readyOps() & OP_CONNECT为非零
        异常
        CancelledKeyException - 如果此键已取消

      • isAcceptable

        public final boolean isAcceptable​()
        测试此密钥的通道是否已准备好接受新的套接字连接。

        这种k.isAcceptable()形式的方法的调用与表达式完全相同

 k.readyOps() & OP_ACCEPT != 0

        如果此键的通道不支持套接字接受操作，则此方法始终返回false 。

        结果
        true如果，且仅当 readyOps() & OP_ACCEPT为非零
        异常
        CancelledKeyException - 如果此键已取消

      • attach

        public final Object attach​(Object ob)
        将给定对象附加到此键。

        随后可以通过attachment方法检索附件 。 一次只能附加一件物品; 调用此方法将导致任何先前的附件被丢弃。 目前的附件可以通过附加null来丢弃。

        参数
        ob - 要附加的对象; 可能是null
        结果
        先前附加的对象，如果有的话，否则为 null

      • attachment

        public final Object attachment​()
        检索当前附件。
        结果
        当前附加到该键的对象，如果没有附件， null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Selector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class Selector

  • java.lang.Object
    • java.nio.channels.Selector
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    AbstractSelector

    public abstract class Selector
extends Object
implements Closeable
    SelectableChannel对象的多路复用器。

    可以通过调用此类的open方法来创建一个选择器，该方法将使用系统的默认值selector provider创建一个新的选择器。 还可以通过调用自定义选择器提供程序的openSelector方法来创建选择器。 选择器保持打开，直到通过其close方法关闭。

    可选频道对选择器的注册由SelectionKey对象表示。 选择器保存三组选择键：

    • 密钥集包含表示此选择器当前通道注册的键。 此集由keys方法返回。

    • 所选择的密钥集是一组密钥，使得每个密钥的信道被检测为在先前选择操作期间的密钥的兴趣集中识别的至少一个操作准备好。 该集合由selectedKeys方法返回。 所选密钥集始终是密钥集的子集。

    • 取消的密钥集是已经被取消但其通道尚未被注销的密钥的集合。 此集不能直接访问。 取消的密钥集始终是密钥集的子集。

    新创建的选择器中的所有三组都为空。

    通过频道的register方法，将密钥添加到选择器的密钥集中，作为注册频道的副作用 。 在选择操作期间，从键集中删除取消的键。 密钥集本身不能直接修改。

    无论是通过关闭其频道还是通过调用其cancel方法，钥匙将被取消，将其添加到选择器取消的钥匙组中。 取消键将导致其通道在下一次选择操作期间被取消注册，此时该键将从所有选择器的键集中移除。

    键通过选择操作被添加到所选择的键集中。 一个关键的可直接从通过调用该组的设定的选择键被移除remove方法或通过调用remove一个的方法iterator从集合获得的。 密钥永远不会以任何其他方式从所选密钥集中删除; 特别是作为选择操作的副作用而不被删除。 键可能不会直接添加到选定的键集。

    选择

    在每个选择操作期间，键可以被添加到选择器的选择键集合并从其中移除，并且可以从其键和取消的键集合中移除。 选择由执行select() ， select(long) ，并selectNow()方法，以及包括三个步骤：

    1. 取消密钥集中的每个密钥从其作为其成员的每个密钥集中移除，并且其信道被注销。 此步骤将取消的密钥设置为空。

    2. 查询底层操作系统，以便更新每个剩余通道的准备状态，以便在选择操作开始的时刻执行由其密钥的兴趣集确定的任何操作。 对于准备进行至少一个此类操作的通道，执行以下两个操作之一：

      1. 如果频道的密钥尚未在选择的密钥集中，则将其添加到该集合中，并且其即时操作集被修改，以便准确地标识该信道现在被报告准备好的那些操作。 先前记录在就绪集中的任何就绪信息被丢弃。

      2. 否则，频道的密钥已经在选择密钥集中，因此其即时操作集被修改，以识别通道报告准备就绪的任何新操作。 以前记录在就绪集中的任何准备信息都将被保留; 换句话说，由底层系统返回的准备集被按位分离到键的当前准备集中。

      如果在此步骤开始时设置的密钥中的所有密钥都有空的兴趣集，那么所选密钥集和任何密钥的即时操作集都将不被更新。

    3. 如果在步骤（2）进行中将任何键添加到取消的键集合，则它们将如步骤（1）中那样处理。

    选择操作是否阻止等待一个或多个通道准备就绪，如果是这样，多长时间是三种选择方法之间唯一的本质区别。

    并发

    选择器本身可以安全地被多个并发线程使用; 不过，他们的钥匙不是。

    选择操作在选择器本身，按键集合和所选键集上以该顺序同步。 它们还在上述步骤（1）和（3）中的取消键集上进行同步。

    在选择操作正在进行时，对选择器的键的兴趣集进行的更改对该操作没有影响; 他们将在下一个选择操作中看到。

    钥匙可能会被取消，渠道可能随时关闭。 因此，在一个或多个选择器的密钥组中存在密钥并不意味着密钥是有效的或其信道是打开的。 如果有可能另一个线程将取消键或关闭通道，应用程序代码应小心同步并根据需要检查这些条件。

    在其中一个select()或select(long)方法中阻塞的线程可能会被其他线程以三种方式之一中断：

    • 通过调用选择器的wakeup方法，

    • 通过调用选择器的close方法，或

    • 通过调用阻塞线程的interrupt方法，在这种情况下，它的中断状态将被设置，并且将调用选择器的wakeup方法。

    close方法以与选择操作相同的顺序在选择器和所有三个按键组上同步。

    选择器的密钥和选择密钥集合通常不会被多个并发线程安全使用。 如果这样的线程可以直接修改这些集合中的一个，则应该通过对集合本身进行同步来控制访问。 这些集合' iterator方法返回的迭代器是故障快速的：如果在迭代器创建之后修改集合，除了通过调用迭代器自己的remove方法之外，以任何方式都将被修改， 因此将抛出一个ConcurrentModificationException 。

    从以下版本开始：
    1.4
    另请参见：
    SelectableChannel ， SelectionKey

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Selector​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void close​()
      关闭此选择器。
      abstract boolean isOpen​()
      告诉这个选择器是否打开。
      abstract Set<SelectionKey> keys​()
      返回此选择器的键集。
      static Selector open​()
      打开选择器。
      abstract SelectorProvider provider​()
      返回创建此通道的提供程序。
      abstract int select​()
      选择一组其相应通道准备好进行I / O操作的键。
      abstract int select​(long timeout)
      选择一组其相应通道准备好进行I / O操作的键。
      abstract Set<SelectionKey> selectedKeys​()
      返回此选择器的选择键集。
      abstract int selectNow​()
      选择一组其相应通道准备好进行I / O操作的键。
      abstract Selector wakeup​()
      导致尚未返回的第一个选择操作立即返回。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Selector

        protected Selector​()
        初始化此类的新实例。

    • 方法详细信息

      • open

        public static Selector open​()
                     throws IOException
        打开选择器。

        新的选择器是通过调用系统范围默认的SelectorProvider对象的openSelector方法来创建的。

        结果
        一个新的选择器
        异常
        IOException - 如果发生I / O错误

      • isOpen

        public abstract boolean isOpen​()
        告诉这个选择器是否打开。
        结果
        true如果，并且只有这个选择器是打开的

      • provider

        public abstract SelectorProvider provider​()
        返回创建此通道的提供程序。
        结果
        创建此频道的提供商

      • keys

        public abstract Set<SelectionKey> keys​()
        返回此选择器的键集。

        密钥集不能直接修改。 一旦钥匙被取消并且其通道已被注销，该钥匙将被移除。 任何修改密钥集的尝试将导致抛出UnsupportedOperationException 。

        钥匙组为not thread-safe 。

        结果
        这个选择器的钥匙组
        异常
        ClosedSelectorException - 如果此选择器已关闭

      • selectedKeys

        public abstract Set<SelectionKey> selectedKeys​()
        返回此选择器的选择键集。

        密钥可以从所选密钥集中移除，但不能直接添加。 任何尝试将对象添加到密钥集将导致抛出UnsupportedOperationException 。

        所选密钥集是not thread-safe 。

        结果
        此选择器的选择键集
        异常
        ClosedSelectorException - 如果此选择器已关闭

      • selectNow

        public abstract int selectNow​()
                       throws IOException
        选择一组其相应通道准备好进行I / O操作的键。

        此方法执行非阻塞selection operation 。 如果以前的选择操作没有频道变为可选择，则该方法立即返回零。

        调用此方法将清除wakeup方法之前任何调用的效果。

        结果
        键的数量，可能为零，其准备操作集由选择操作更新
        异常
        IOException - 如果发生I / O错误
        ClosedSelectorException - 如果此选择器已关闭

      • select

        public abstract int select​(long timeout)
                    throws IOException
        选择一组其相应通道准备好进行I / O操作的键。

        此方法执行阻止selection operation 。 只有在至少选择一个通道之后，才会返回此选择器的wakeup方法，当前线程被中断，或给定的超时期限到期，以先到者为准。

        该方法不提供实时保证：它调用超时，就像调用Object.wait(long)方法一样。

        参数
        timeout - 如果为正，则阻止最多timeout毫秒，或多或少，同时等待通道准备就绪; 如果零，无限期地阻止; 不能是负面的
        结果
        键的数量，可能为零，其即时操作集更新
        异常
        IOException - 如果发生I / O错误
        ClosedSelectorException - 如果此选择器已关闭
        IllegalArgumentException - 如果timeout参数的值为负

      • select

        public abstract int select​()
                    throws IOException
        选择一组其相应通道准备好进行I / O操作的键。

        此方法执行阻止selection operation 。 只有在至少选择一个通道之后，才会返回此选择器的wakeup方法，或当前线程中断，以先到者为准。

        结果
        键的数量，可能为零，其即时操作集更新
        异常
        IOException - 如果发生I / O错误
        ClosedSelectorException - 如果此选择器已关闭

      • wakeup

        public abstract Selector wakeup​()
        导致尚未返回的第一个选择操作立即返回。

        如果另一个线程在调用select()或select(long)方法时被阻止，则该调用将立即返回。 如果当前没有选择操作，则下一次调用这些方法之一将立即返回，除非同时调用了selectNow()方法。 无论如何，该调用返回的值可能不为零。 select()或select(long)方法的后续调用将像往常一样阻止，除非此时再次调用此方法。

        在两次连续的选择操作之间多次调用此方法的效果与调用一次只有一次相同。

        结果
        这个选择器

      • close

        public abstract void close​()
                    throws IOException
        关闭此选择器。

        如果一个线程当前被阻塞在这个选择器的选择方法之一，那么它被中断，好像通过调用选择器的wakeup方法。

        仍然与此选择器相关联的任何未经取消的密钥无效，其通道被注销，并且释放与此选择器相关联的任何其他资源。

        如果此选择器已关闭，则调用此方法将不起作用。

        选择器关闭后，除了通过调用此方法或wakeup方法外，任何进一步尝试使用它将导致抛出ClosedSelectorException 。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServerSocketChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class ServerSocketChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.ServerSocketChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Channel ， InterruptibleChannel ， NetworkChannel

    public abstract class ServerSocketChannel
extends AbstractSelectableChannel
implements NetworkChannel
    用于面向流的侦听套接字的可选通道。

    通过调用此类的open方法创建服务器套接字通道。 不可能为任意的，预先存在的ServerSocket创建一个通道。 新创建的服务器套接字通道已打开但尚未绑定。 尝试调用未绑定服务器套接字通道的accept方法将导致抛出NotYetBoundException 。 可以通过调用此类定义的一个bind方法来绑定服务器套接字通道。

    套接字选项使用setOption方法进行配置。 服务器端口通道支持以下选项：

    Socket options
    Option Name | 描述
    SO_RCVBUF | The size of the socket receive buffer
    SO_REUSEADDR | Re-use address
    还可以支持附加（实现特定）选项。

    服务器套接字通道可以安全地被多个并发线程使用。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ServerSocketChannel​(SelectorProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract SocketChannel accept​()
      接受与此频道套接字的连接。
      ServerSocketChannel bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract ServerSocketChannel bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SocketAddress getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      static ServerSocketChannel open​()
      打开服务器插槽通道。
      abstract <T> ServerSocketChannel setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      abstract ServerSocket socket​()
      检索与此通道关联的服务器套接字。
      int validOps​()
      返回确定此频道支持的操作的操作集。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, isOpen

      • Methods inherited from class java.nio.channels.spi.AbstractSelectableChannel

        blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from interface java.nio.channels.NetworkChannel

        getOption, supportedOptions

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.SelectableChannel

        register

    • 构造方法详细信息

      • ServerSocketChannel

        protected ServerSocketChannel​(SelectorProvider provider)
        初始化此类的新实例。
        参数
        provider - 创建此频道的提供商

    • 方法详细信息

      • open

        public static ServerSocketChannel open​()
                                throws IOException
        打开服务器插槽通道。

        新通道是通过调用系统范围默认的SelectorProvider对象的openServerSocketChannel方法创建的。

        新频道的套接字最初未绑定; 必须通过其套接字的bind方法将其绑定到特定地址，才能接受连接。

        结果
        一个新的套接字通道
        异常
        IOException - 如果发生I / O错误

      • validOps

        public final int validOps​()
        返回确定此频道支持的操作的操作集。

        服务器套接字通道仅支持接受新连接，因此此方法返回SelectionKey.OP_ACCEPT 。

        Specified by:
        validOps在 SelectableChannel
        结果
        有效操作集

      • bind

        public final ServerSocketChannel bind​(SocketAddress local)
                               throws IOException
        将通道的套接字绑定到本地地址，并配置套接字以监听连接。

        此方法的调用等同于以下内容：

         bind(local, 0);
        Specified by:
        bind在接口 NetworkChannel
        参数
        local - 绑定套接字的本地地址，或 null绑定到自动分配的套接字地址
        结果
        这个频道
        异常
        AlreadyBoundException - 如果套接字已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生其他I / O错误
        SecurityException - 如果已安装安全管理器，并且其 checkListen方法拒绝操作
        从以下版本开始：
        1.7
        另请参见：
        NetworkChannel.getLocalAddress()

      • bind

        public abstract ServerSocketChannel bind​(SocketAddress local,
                                         int backlog)
                                  throws IOException
        将通道的套接字绑定到本地地址，并配置套接字以监听连接。

        该方法用于在套接字和本地地址之间建立关联。 一旦建立关联，则套接字保持绑定，直到通道关闭。

        backlog参数是套接字上挂起的连接的最大数量。 其确切语义是实现具体的。 特别地，实现可以施加最大长度，或者可以选择忽略参数altogther。 如果backlog参数的值为0或负值，则使用实现特定的默认值。

        参数
        local - 绑定套接字的地址，或 null绑定到自动分配的套接字地址
        backlog - 挂起连接的最大数量
        结果
        这个频道
        异常
        AlreadyBoundException - 如果套接字已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作
        从以下版本开始：
        1.7

      • setOption

        public abstract <T> ServerSocketChannel setOption​(SocketOption<T> name,
                                                  T value)
                                           throws IOException
        描述从接口NetworkChannel复制
        设置套接字选项的值。
        Specified by:
        setOption在接口 NetworkChannel
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能是某些套接字选项的有效值。
        结果
        这个频道
        异常
        UnsupportedOperationException - 如果此通道不支持套接字选项
        IllegalArgumentException - 如果该值不是此套接字选项的有效值
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.7
        另请参见：
        StandardSocketOptions

      • socket

        public abstract ServerSocket socket​()
        检索与此通道关联的服务器套接字。

        返回的对象不会声明任何未在ServerSocket类中声明的公共方法。

        结果
        与此通道关联的服务器套接字

      • accept

        public abstract SocketChannel accept​()
                              throws IOException
        接受与此频道套接字的连接。

        如果此通道处于非阻塞模式，则如果没有挂起连接，则此方法将立即返回null 。 否则，它将无限期地阻塞，直到有新的连接或发生I / O错误。

        无论此通道的阻塞模式如何，通过此方法返回的套接字通道（如果有）将处于阻塞模式。

        该方法执行与ServerSocket类的accept方法完全相同的安全检查。 也就是说，如果已经安装了一个安全管理器，那么对于每个新的连接，该方法将通过安全管理器的checkAccept方法验证连接的远程端点的地址和端口号是否被允许。

        结果
        新连接的套接字通道，或 null如果此通道处于非阻塞模式，并且没有连接可用于接受
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在接受操作进行过程中关闭此通道
        ClosedByInterruptException - 如果另一个线程在接受操作进行过程中中断当前线程，从而关闭通道并设置当前线程的中断状态
        NotYetBoundException - 如果此通道的套接字尚未绑定
        SecurityException - 如果已安装安全管理器，并且不允许访问新连接的远程端点
        IOException - 如果发生其他I / O错误

      • getLocalAddress

        public abstract SocketAddress getLocalAddress​()
                                       throws IOException
        返回此通道的套接字所绑定的套接字地址。

        通道为互联网协议套接字地址的bound ，则此方法的返回值为InetSocketAddress 。

        如果有一个安全管理器集，其checkConnect方法将以本地地址和-1作为参数来调用，以查看是否允许该操作。 如果不允许操作，则SocketAddress表示loopback地址的SocketAddress和通道插座的本地端口。

        Specified by:
        getLocalAddress在接口 NetworkChannel
        结果
        该 SocketAddress的套接字绑定到，或 SocketAddress代表的环回地址，如果安全管理器拒绝，或者 null如果通道的套接字不绑定
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ShutdownChannelGroupException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class ShutdownChannelGroupException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.ShutdownChannelGroupException
  • All Implemented Interfaces:
    Serializable

    public class ShutdownChannelGroupException
extends IllegalStateException
    当尝试构造一个关闭组的通道或I / O操作的完成处理程序无法调用时，抛出未检查的异常，因为通道组已终止。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ShutdownChannelGroupException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ShutdownChannelGroupException

        public ShutdownChannelGroupException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SocketChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class SocketChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.SocketChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， ByteChannel ， Channel ， GatheringByteChannel ， InterruptibleChannel ， NetworkChannel ， ReadableByteChannel ， ScatteringByteChannel ， WritableByteChannel

    public abstract class SocketChannel
extends AbstractSelectableChannel
implements ByteChannel, ScatteringByteChannel, GatheringByteChannel, NetworkChannel
    用于面向流的连接插座的可选通道。

    通过调用此类的open方法之一创建套接字通道。 不可能为任意的预先存在的套接字创建一个通道。 新创建的套接字通道已打开但尚未连接。 尝试在未连接的通道上调用I / O操作将导致抛出NotYetConnectedException 。 可以通过调用其connect方法连接套接字通道; 一旦连接，插座通道保持连接，直到其闭合。 可以通过调用其isConnected方法来确定套接字信道是否连接。

    套接字通道支持非阻塞连接：可以创建套接字通道，并且可以通过connect方法启动建立到远程套接字的链接的过程，以便稍后通过finishConnect方法完成。 连接操作是否正在进行可以通过调用isConnectionPending方法来确定。

    Socket通道支持异步关闭，类似于Channel类中指定的异步关闭操作。 如果套接字的输入端被一个线程关闭，而另一个线程在套接字通道的读操作中被阻塞，则阻塞线程中的读操作将完成，而不读取任何字节，并将返回-1 。 如果套接字的输出端由一个线程关闭，而另一个线程在套接字通道的写操作中被阻塞，则阻塞的线程将接收到一个AsynchronousCloseException 。

    套接字选项使用setOption方法进行配置。 套接字通道支持以下选项：

    Socket options
    Option Name | 描述
    SO_SNDBUF | The size of the socket send buffer
    SO_RCVBUF | The size of the socket receive buffer
    SO_KEEPALIVE | Keep connection alive
    SO_REUSEADDR | Re-use address
    SO_LINGER | Linger on close if data is present (when configured in blocking mode only)
    TCP_NODELAY | Disable the Nagle algorithm
    还可以支持附加（实现特定）选项。

    套接字通道可以安全地被多个并发线程使用。 他们支持并发阅读和写作，尽管最多只有一个线程可能正在读取，并且最多一个线程可能在任何给定的时间写入。 connect和finishConnect方法彼此相互同步，并且在调用这些方法之一时正在进行的启动读取或写入操作的尝试将被阻塞，直到该调用完成。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SocketChannel​(SelectorProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract SocketChannel bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      abstract boolean connect​(SocketAddress remote)
      连接此通道的插座。
      abstract boolean finishConnect​()
      完成连接插座通道的过程。
      abstract SocketAddress getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress getRemoteAddress​()
      返回此通道的插座所连接的远程地址。
      abstract boolean isConnected​()
      告知本频道的网络插座是否连接。
      abstract boolean isConnectionPending​()
      告知此频道是否正在进行连接操作。
      static SocketChannel open​()
      打开套接字通道。
      static SocketChannel open​(SocketAddress remote)
      打开套接字通道并将其连接到远程地址。
      abstract int read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      long read​(ByteBuffer[] dsts)
      从该通道读取到给定缓冲区的字节序列。
      abstract long read​(ByteBuffer[] dsts, int offset, int length)
      从该通道读取字节序列到给定缓冲区的子序列中。
      abstract <T> SocketChannel setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      abstract SocketChannel shutdownInput​()
      关闭连接进行阅读，不关闭频道。
      abstract SocketChannel shutdownOutput​()
      关闭连接以进行写入，而不关闭通道。
      abstract Socket socket​()
      检索与此通道相关联的套接字。
      int validOps​()
      返回确定此频道支持的操作的操作集。
      abstract int write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      long write​(ByteBuffer[] srcs)
      从给定的缓冲区向该通道写入一系列字节。
      abstract long write​(ByteBuffer[] srcs, int offset, int length)
      从给定缓冲区的子序列将一个字节序列写入该通道。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, isOpen

      • Methods inherited from class java.nio.channels.spi.AbstractSelectableChannel

        blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from interface java.nio.channels.NetworkChannel

        getOption, supportedOptions

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.SelectableChannel

        register

    • 构造方法详细信息

      • SocketChannel

        protected SocketChannel​(SelectorProvider provider)
        初始化此类的新实例。
        参数
        provider - 创建此频道的提供商

    • 方法详细信息

      • open

        public static SocketChannel open​()
                          throws IOException
        打开套接字通道。

        通过调用系统范围默认的SelectorProvider对象的openSocketChannel方法创建新通道。

        结果
        一个新的套接字通道
        异常
        IOException - 如果发生I / O错误

      • open

        public static SocketChannel open​(SocketAddress remote)
                          throws IOException
        打开套接字通道并将其连接到远程地址。

        这种方便的方法就像调用open()方法一样，在最终的套接字通道上调用connect方法，传递给它remote ，然后返回该通道。

        参数
        remote - 要连接新通道的远程地址
        结果
        一个新的和连接的插座通道
        异常
        AsynchronousCloseException - 如果另一个线程在连接操作进行过程中关闭此通道
        ClosedByInterruptException - 如果另一个线程在连接操作进行过程中中断当前线程，则关闭通道并设置当前线程的中断状态
        UnresolvedAddressException - 如果给定的远程地址未完全解析
        UnsupportedAddressTypeException - 如果不支持给定的远程地址的类型
        SecurityException - 如果已安装安全管理器，并且不允许访问给定的远程端点
        IOException - 如果发生其他I / O错误

      • validOps

        public final int validOps​()
        返回确定此频道支持的操作的操作集。

        套接字通道支持连接，读取和写入，所以此方法返回( SelectionKey.OP_CONNECT | SelectionKey.OP_READ | SelectionKey.OP_WRITE ) 。

        Specified by:
        validOps在 SelectableChannel
        结果
        有效操作集

      • bind

        public abstract SocketChannel bind​(SocketAddress local)
                            throws IOException
        说明从接口NetworkChannel复制
        将通道的套接字绑定到本地地址。

        该方法用于在套接字和本地地址之间建立关联。 一旦建立关联，则套接字保持绑定，直到通道关闭。 如果local参数的值为null则套接字将被绑定到自动分配的地址。

        Specified by:
        bind接口 NetworkChannel
        参数
        local - 绑定套接字的地址，或 null将套接字绑定到自动分配的套接字地址
        结果
        这个频道
        异常
        ConnectionPendingException - 如果此通道上已经在进行非阻塞连接操作
        AlreadyBoundException - 如果套接字已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生其他I / O错误
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作
        从以下版本开始：
        1.7
        另请参见：
        NetworkChannel.getLocalAddress()

      • setOption

        public abstract <T> SocketChannel setOption​(SocketOption<T> name,
                                            T value)
                                     throws IOException
        描述从接口NetworkChannel复制
        设置套接字选项的值。
        Specified by:
        setOption在接口 NetworkChannel
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能是某些套接字选项的有效值。
        结果
        这个频道
        异常
        UnsupportedOperationException - 如果此通道不支持套接字选项
        IllegalArgumentException - 如果该值不是此套接字选项的有效值
        ClosedChannelException - 如果此频道关闭
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.7
        另请参见：
        StandardSocketOptions

      • shutdownInput

        public abstract SocketChannel shutdownInput​()
                                     throws IOException
        关闭连接进行阅读，不关闭频道。

        一旦关机进行读取，则通道上的进一步读取将返回-1流末端指示。 如果连接的输入端已经关闭，则调用此方法没有任何作用。

        结果
        这个频道
        异常
        NotYetConnectedException - 如果此频道尚未连接
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误
        从以下版本开始：
        1.7

      • shutdownOutput

        public abstract SocketChannel shutdownOutput​()
                                      throws IOException
        关闭连接以进行写入，而不关闭通道。

        一旦关闭写入，则进一步尝试写入通道将抛出ClosedChannelException 。 如果连接的输出端已经关闭，则调用此方法不起作用。

        结果
        这个频道
        异常
        NotYetConnectedException - 如果此频道尚未连接
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误
        从以下版本开始：
        1.7

      • socket

        public abstract Socket socket​()
        检索与此通道相关联的套接字。

        返回的对象不会声明任何未在Socket类中声明的公共方法。

        结果
        与此通道相关联的插座

      • isConnected

        public abstract boolean isConnected​()
        告知本频道的网络插座是否连接。
        结果
        true如果，并且只有这个通道的网络套接字是 open并连接

      • isConnectionPending

        public abstract boolean isConnectionPending​()
        告知此频道是否正在进行连接操作。
        结果
        true如果并且只有在此通道上启动了连接操作但尚未通过调用 finishConnect方法完成

      • connect

        public abstract boolean connect​(SocketAddress remote)
                         throws IOException
        连接此通道的插座。

        如果此通道处于非阻塞模式，则此方法的调用将启动非阻塞连接操作。 如果立即建立连接，就像本地连接一样，该方法返回true 。 否则，此方法返回false ，并且连接操作必须稍后通过调用finishConnect方法完成。

        如果此通道处于阻塞模式，则该方法的调用将阻塞，直到建立连接或发生I / O错误。

        此方法执行与Socket类完全相同的安全检查。 也就是说，如果安装了一个安全管理器，那么这个方法会验证它的checkConnect方法是否允许连接到给定远程端点的地址和端口号。

        可以随时调用此方法。 如果在调用此方法时调用此通道的读取或写入操作，则该操作将首先阻止，直到此调用完成。 如果连接尝试启动但失败，也就是说，如果此方法的调用抛出已检查的异常，则该通道将被关闭。

        参数
        remote - 要连接该通道的远程地址
        结果
        true如果连接建立， false如果此通道处于非阻塞模式并且连接操作正在进行中
        异常
        AlreadyConnectedException - 如果此频道已连接
        ConnectionPendingException - 如果此通道上已经进行了非阻塞连接操作
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在连接操作进行过程中关闭此通道
        ClosedByInterruptException - 如果另一个线程在连接操作进行过程中中断当前线程，从而关闭通道并设置当前线程的中断状态
        UnresolvedAddressException - 如果给定的远程地址未完全解析
        UnsupportedAddressTypeException - 如果不支持给定的远程地址的类型
        SecurityException - 如果已安装安全管理器，并且不允许访问给定的远程端点
        IOException - 如果发生其他I / O错误

      • finishConnect

        public abstract boolean finishConnect​()
                               throws IOException
        完成连接插座通道的过程。

        通过将套接字通道置于非阻塞模式，然后调用其connect方法来启动非阻塞连接操作。 一旦建立了连接，或尝试失败，套接字通道将变得可连接，并且可以调用该方法来完成连接顺序。 如果连接操作失败，则调用此方法将导致适当的IOException抛出。

        如果此通道已连接，则此方法将不会阻止，并将立即返回true 。 如果此通道处于非阻塞模式，则如果连接过程尚未完成，则此方法将返回false 。 如果此通道处于阻塞模式，则该方法将阻塞，直到连接完成或失败，并且将始终返回true或抛出描述故障的检查异常。

        可以随时调用此方法。 如果在调用此方法时调用此通道的读取或写入操作，则该操作将首先阻止，直到此调用完成。 如果连接尝试失败，也就是说，如果此方法的调用引发已检查的异常，那么该通道将被关闭。

        结果
        true如果，且仅当此通道的插座现在已连接
        异常
        NoConnectionPendingException - 如果该通道未连接，并且没有启动连接操作
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在连接操作进行过程中关闭此通道
        ClosedByInterruptException - 如果另一个线程在连接操作进行过程中中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • getRemoteAddress

        public abstract SocketAddress getRemoteAddress​()
                                        throws IOException
        返回此通道的插座所连接的远程地址。

        通道绑定并连接到Internet协议套接字地址时，此方法的返回值为InetSocketAddress 。

        结果
        远程地址; null如果通道的插座未连接
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.7

      • read

        public abstract int read​(ByteBuffer dst)
                  throws IOException
        描述从接口ReadableByteChannel复制
        从该通道读取到给定缓冲区的字节序列。

        尝试从通道读取r个字节，其中r是缓冲区中剩余的字节数，即dst.remaining() ，在此方法被调用的时刻。

        假设读取长度为n的字节序列，其中0 <= n <= r 。 该字节序列将被转移到缓冲器，使得序列中的第一个字节是在索引p和最后一个字节是在索引p + Ñ - 1 ，其中p是该缓冲区的在调用此方法的瞬间位置。 一旦返回缓冲区的位置将等于p + n ; 其限制将不会改变。

        读取操作可能不会填充缓冲区，实际上它可能不会读取任何字节。 是否这样做取决于渠道的性质和状态。 例如，非阻塞模式的套接字通道不能再读取比从套接字的输入缓冲区立即可用的任何字节数; 类似地，文件通道不能读取比保留在文件中的任何更多的字节。 但是，如果通道处于阻塞模式，并且缓冲区中至少剩余一个字节，则该方法将被阻塞，直到读取至少一个字节为止。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了读取操作，那么此方法的调用将阻塞，直到第一个操作完成。

        Specified by:
        read在接口 ReadableByteChannel
        参数
        dst - 要传输字节的缓冲区
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        NotYetConnectedException - 如果此频道尚未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • read

        public abstract long read​(ByteBuffer[] dsts,
                          int offset,
                          int length)
                   throws IOException
        说明从界面ScatteringByteChannel复制
        从该通道读取字节序列到给定缓冲区的子序列中。

        该方法的调用尝试从该通道读取r个字节，其中r是给定缓冲区数组的指定子序列剩余的总字节数，也就是说，

         dsts[offset].remaining()
     + dsts[offset+1].remaining()
     + ... + dsts[offset+length-1].remaining()
        在此方法被调用的时刻。

        假设读取长度为n的字节序列，其中0 <= n <= r 。 直到该序列的第一个dsts[offset].remaining()字节被传送到缓冲器dsts[offset] ，直到下一个dsts[offset+1].remaining()字节被传送到缓冲器dsts[offset+1]等等，直到整个字节序列被传送到给定的缓冲器。 尽可能多的字节被传送到每个缓冲器中，因此除了最后更新的缓冲器之外，每个更新的缓冲器的最终位置被保证等于该缓冲器的限制。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了读取操作，那么此方法的调用将阻塞，直到第一个操作完成。

        Specified by:
        read接口 ScatteringByteChannel
        参数
        dsts - 要传输字节的缓冲区
        offset - 要传输字节的第一个缓冲区的缓冲区数组中的偏移量; 必须是非负数，不得大于dsts.length
        length - 要访问的最大缓冲区数; 必须是非负数，不得大于dsts.length - offset
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        NotYetConnectedException - 如果此频道尚未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • read

        public final long read​(ByteBuffer[] dsts)
                throws IOException
        描述从接口ScatteringByteChannel复制
        从该通道读取到给定缓冲区的字节序列。

        这种c.read(dsts)形式的方法的调用与调用的方式完全相同

         c.read(dsts, 0, dsts.length);
        Specified by:
        read在接口 ScatteringByteChannel
        参数
        dsts - 要传输字节的缓冲区
        结果
        读取的字节数，可能为零，如果通道已达到流出端， -1
        异常
        NotYetConnectedException - 如果此频道尚未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public abstract int write​(ByteBuffer src)
                   throws IOException
        描述从接口WritableByteChannel复制
        从给定的缓冲区向该通道写入一个字节序列。

        尝试写入r个字节到通道，其中r是缓冲区中剩余的字节数，即src.remaining() ，在此方法被调用的时刻。

        假设长度为n的字节序列被写入，其中0 <= n <= r 。 该字节序列将从索引p开始从缓冲区传送，其中p是调用该方法时缓冲区的位置; 写入的最后一个字节的索引将为p + n - 1 。 一旦返回缓冲区的位置将等于p + n ; 其限制将不会改变。

        除非另有规定，写入操作将仅在写入所有r个请求的字节后才会返回。 某些类型的通道取决于它们的状态，可能仅写入一些字节，或者可能只写入一些字节。 例如，在非阻塞模式下的套接字通道不能写入任何比套接字输出缓冲区中的任何字节更多的字节。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了写入操作，那么此方法的调用将阻塞，直到第一个操作完成。

        Specified by:
        write在接口 WritableByteChannel
        参数
        src - 要检索字节的缓冲区
        结果
        写入的字节数，可能为零
        异常
        NotYetConnectedException - 如果此频道尚未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public abstract long write​(ByteBuffer[] srcs,
                           int offset,
                           int length)
                    throws IOException
        描述从接口GatheringByteChannel复制
        从给定缓冲区的子序列将一个字节序列写入该通道。

        尝试写入r个字节到该通道，其中r是给定缓冲区数组的指定子序列中剩余的总字节数，也就是说，

         srcs[offset].remaining()
     + srcs[offset+1].remaining()
     + ... + srcs[offset+length-1].remaining()
        在此方法被调用的时刻。

        假设写入长度为n的字节序列，其中0 <= n <= r 。 直到该序列的第一个srcs[offset].remaining()字节从缓冲器srcs[offset]写入，直到下一个srcs[offset+1].remaining()字节从缓冲器srcs[offset+1]写入，等等，直到写入整个字节序列。 尽可能多的字节从每个缓冲区写入，因此除了最后更新的缓冲区之外，每个更新的缓冲区的最终位置被保证等于该缓冲区的限制。

        除非另有规定，写入操作将仅在写入所有r个请求的字节后才会返回。 某些类型的通道取决于它们的状态，可能仅写入一些字节，或者可能只写入一些字节。 例如，在非阻塞模式下的套接字通道不能写入任何比套接字输出缓冲区中的任何字节更多的字节。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了写入操作，那么此方法的调用将阻塞，直到第一个操作完成。

        Specified by:
        write在接口 GatheringByteChannel
        参数
        srcs - 要检索字节的缓冲区
        offset - 要检索字节的第一个缓冲区的缓冲区数组中的偏移量; 必须是非负数，不得大于srcs.length
        length - 要访问的缓冲区的最大数量; 必须是非负数，不得大于srcs.length - offset
        结果
        写入的字节数，可能为零
        异常
        NotYetConnectedException - 如果此频道尚未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • write

        public final long write​(ByteBuffer[] srcs)
                 throws IOException
        描述从接口GatheringByteChannel复制
        从给定的缓冲区向该通道写入一系列字节。

        这种c.write(srcs)形式的方法的调用与调用的方式完全相同

         c.write(srcs, 0, srcs.length);
        Specified by:
        write在接口 GatheringByteChannel
        参数
        srcs - 要检索字节的缓冲区
        结果
        写入的字节数，可能为零
        异常
        NotYetConnectedException - 如果此频道尚未连接
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在写入操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • getLocalAddress

        public abstract SocketAddress getLocalAddress​()
                                       throws IOException
        返回此通道的套接字所绑定的套接字地址。

        通道为Internet协议套接字地址的bound ，则此方法的返回值为InetSocketAddress 。

        如果有一个安全管理器集，其checkConnect方法将以本地地址和-1作为参数来调用，以查看是否允许该操作。 如果不允许操作，则SocketAddress表示loopback地址的SocketAddress和通道插座的本地端口。

        Specified by:
        getLocalAddress接口 NetworkChannel
        结果
        该 SocketAddress的套接字绑定到，或 SocketAddress代表的环回地址，如果安全管理器拒绝，或者 null如果通道的套接字不绑定
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnresolvedAddressException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class UnresolvedAddressException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.channels.UnresolvedAddressException
  • All Implemented Interfaces:
    Serializable

    public class UnresolvedAddressException
extends IllegalArgumentException
    尝试在未解析的套接字地址上调用网络操作时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnresolvedAddressException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnresolvedAddressException

        public UnresolvedAddressException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnsupportedAddressTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class UnsupportedAddressTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.channels.UnsupportedAddressTypeException
  • All Implemented Interfaces:
    Serializable

    public class UnsupportedAddressTypeException
extends IllegalArgumentException
    尝试绑定或连接到不支持的类型的套接字地址时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnsupportedAddressTypeException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnsupportedAddressTypeException

        public UnsupportedAddressTypeException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.nio.channels (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.nio.channels

  • Packages that use java.nio.channels
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    服务提供者类为 java.nio.channels包。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供商类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
  • Classes in java.nio.channels used by com.sun.nio.sctp
    Class 描述
    Channel
    I / O操作的联系。
    InterruptibleChannel
    可以异步关闭和中断的通道。
    SelectableChannel
    可通过Selector复用的通道 。
  • Classes in java.nio.channels used by java.io
    Class 描述
    FileChannel
    用于读取，写入，映射和操作文件的通道。
  • Classes in java.nio.channels used by java.lang
    Class 描述
    Channel
    I / O操作的联系。
  • Classes in java.nio.channels used by java.net
    Class 描述
    DatagramChannel
    面向数据报的套接字的可选通道。
    ServerSocketChannel
    用于面向流的侦听套接字的可选通道。
    SocketChannel
    用于面向流的连接插座的可选通道。
  • Classes in java.nio.channels used by java.nio.channels
    Class 描述
    AsynchronousByteChannel
    一个可以读写字节的异步通道。
    AsynchronousChannel
    支持异步I / O操作的通道。
    AsynchronousChannelGroup
    用于资源共享的一组异步通道。
    AsynchronousCloseException
    当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
    AsynchronousFileChannel
    用于读取，写入和操作文件的异步通道。
    AsynchronousServerSocketChannel
    用于面向流的侦听套接字的异步通道。
    AsynchronousSocketChannel
    用于面向流的连接插座的异步通道。
    ByteChannel
    一个可以读写字节的通道。
    Channel
    I / O操作的联系。
    ClosedChannelException
    当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。
    CompletionHandler
    用于消除异步I / O操作结果的处理程序。
    DatagramChannel
    面向数据报的套接字的可选通道。
    FileChannel
    用于读取，写入，映射和操作文件的通道。
    FileChannel.MapMode
    文件映射模式的类型安全枚举。
    FileLock
    表示文件区域上的锁的令牌。
    GatheringByteChannel
    可以从缓冲区序列中写入字节的通道。
    InterruptibleChannel
    可以异步关闭和中断的通道。
    MembershipKey
    代表互联网协议（IP）组播组成员身份的令牌。
    MulticastChannel
    支持互联网协议（IP）组播的网络通道。
    NetworkChannel
    到网络插座的通道。
    Pipe
    实现单向管道的一对通道。
    Pipe.SinkChannel
    一个代表Pipe可写端的通道 。
    Pipe.SourceChannel
    代表Pipe可读端的通道 。
    ReadableByteChannel
    一个可以读取字节的通道。
    ScatteringByteChannel
    可以将字节读入缓冲区序列的通道。
    SeekableByteChannel
    保持当前 位置并允许更改 位置的字节通道。
    SelectableChannel
    可通过Selector复用的通道 。
    SelectionKey
    表示SelectableChannel与Selector的注册的令牌。
    Selector
    SelectableChannel对象的多路复用器。
    ServerSocketChannel
    用于面向流的侦听套接字的可选通道。
    SocketChannel
    用于面向流的连接插座的可选通道。
    WritableByteChannel
    一个可以写字节的通道。
  • Classes in java.nio.channels used by java.nio.channels.spi
    Class 描述
    AsynchronousChannelGroup
    用于资源共享的一组异步通道。
    AsynchronousCloseException
    当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
    AsynchronousServerSocketChannel
    用于面向流的侦听套接字的异步通道。
    AsynchronousSocketChannel
    用于面向流的连接插座的异步通道。
    Channel
    I / O操作的联系。
    ClosedChannelException
    当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。
    DatagramChannel
    面向数据报的套接字的可选通道。
    InterruptibleChannel
    可以异步关闭和中断的通道。
    Pipe
    实现单向管道的一对通道。
    SelectableChannel
    可通过Selector复用的通道 。
    SelectionKey
    表示SelectableChannel与Selector的注册的令牌。
    Selector
    SelectableChannel对象的多路复用器。
    ServerSocketChannel
    用于面向流的侦听套接字的可选通道。
    SocketChannel
    用于面向流的连接插座的可选通道。
  • Classes in java.nio.channels used by java.nio.file
    Class 描述
    SeekableByteChannel
    保持当前 位置并允许更改 位置的字节通道。
  • Classes in java.nio.channels used by java.nio.file.spi
    Class 描述
    AsynchronousFileChannel
    用于读取，写入和操作文件的异步通道。
    FileChannel
    用于读取，写入，映射和操作文件的通道。
    SeekableByteChannel
    保持当前 位置并允许更改 位置的字节通道。
  • Classes in java.nio.channels used by java.util
    Class 描述
    ReadableByteChannel
    一个可以读取字节的通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


WritableByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Interface WritableByteChannel

  • All Superinterfaces:
    AutoCloseable ， Channel ， Closeable
    All Known Subinterfaces:
    ByteChannel ， GatheringByteChannel ， SeekableByteChannel
    所有已知实现类：
    DatagramChannel ， FileChannel ， Pipe.SinkChannel ， SocketChannel

    public interface WritableByteChannel
extends Channel
    一个可以写字节的通道。

    在可写信道上只能进行一次写入操作。 如果一个线程在通道上启动写入操作，那么尝试发起另一个写入操作的任何其他线程将阻塞，直到第一个操作完成。 其他类型的I / O操作是否可以与写入操作同时进行取决于通道的类型。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

    • 方法详细信息

      • write

        int write​(ByteBuffer src)
   throws IOException
        从给定的缓冲区向该通道写入一个字节序列。

        尝试写入r个字节到通道，其中r是缓冲区中剩余的字节数，即src.remaining() ，在此方法被调用的时刻。

        假设写入长度为n的字节序列，其中0 <= n <= r 。 该字节序列将从索引p开始从缓冲区传送，其中p是调用该方法时缓冲区的位置; 写入的最后一个字节的索引将为p + n - 1 。 缓冲区的返回位置将等于p + n ; 其限制将不会改变。

        除非另有规定，写入操作将仅在写入所有r个请求的字节后才会返回。 某些类型的通道取决于它们的状态，可能仅写入一些字节，或者可能只写入一些字节。 例如，在非阻塞模式下的套接字通道不能写入任何比套接字输出缓冲区中的任何字节更多的字节。

        可以随时调用此方法。 但是，如果另一个线程已经在该通道上启动了写入操作，那么此方法的调用将阻塞，直到第一个操作完成。

        参数
        src - 要检索字节的缓冲区
        结果
        写入的字节数，可能为零
        异常
        NonWritableChannelException - 如果这个频道没有开放写作
        ClosedChannelException - 如果此频道关闭
        AsynchronousCloseException - 如果另一个线程在写操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在写操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritePendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels

Class WritePendingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.channels.WritePendingException
  • All Implemented Interfaces:
    Serializable

    public class WritePendingException
extends IllegalStateException
    尝试写入异步套接字通道并且之前的写入尚未完成时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      WritePendingException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • WritePendingException

        public WritePendingException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class java.nio.channels.AcceptPendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.AcceptPendingException

No usage of java.nio.channels.AcceptPendingException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.AlreadyBoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.AlreadyBoundException

No usage of java.nio.channels.AlreadyBoundException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.AlreadyConnectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.AlreadyConnectedException

No usage of java.nio.channels.AlreadyConnectedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.AsynchronousChannelGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.AsynchronousChannelGroup

  • Packages that use AsynchronousChannelGroup
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。

    • Uses of AsynchronousChannelGroup in java.nio.channels

      Methods in java.nio.channels that return AsynchronousChannelGroup
      Modifier and Type 方法 描述
      static AsynchronousChannelGroup AsynchronousChannelGroup.withCachedThreadPool​(ExecutorService executor, int initialSize)
      创建具有给定线程池的异步通道组，根据需要创建新线程。
      static AsynchronousChannelGroup AsynchronousChannelGroup.withFixedThreadPool​(int nThreads, ThreadFactory threadFactory)
      创建具有固定线程池的异步通道组。
      static AsynchronousChannelGroup AsynchronousChannelGroup.withThreadPool​(ExecutorService executor)
      使用给定的线程池创建异步通道组。
      Methods in java.nio.channels with parameters of type AsynchronousChannelGroup
      Modifier and Type 方法 描述
      static AsynchronousServerSocketChannel AsynchronousServerSocketChannel.open​(AsynchronousChannelGroup group)
      打开异步服务器套接字通道。
      static AsynchronousSocketChannel AsynchronousSocketChannel.open​(AsynchronousChannelGroup group)
      打开异步套接字通道。

    • Uses of AsynchronousChannelGroup in java.nio.channels.spi

      Methods in java.nio.channels.spi that return AsynchronousChannelGroup
      Modifier and Type 方法 描述
      abstract AsynchronousChannelGroup AsynchronousChannelProvider.openAsynchronousChannelGroup​(int nThreads, ThreadFactory threadFactory)
      构造一个具有固定线程池的新的异步通道组。
      abstract AsynchronousChannelGroup AsynchronousChannelProvider.openAsynchronousChannelGroup​(ExecutorService executor, int initialSize)
      使用给定的线程池构造新的异步通道组。
      Methods in java.nio.channels.spi with parameters of type AsynchronousChannelGroup
      Modifier and Type 方法 描述
      abstract AsynchronousServerSocketChannel AsynchronousChannelProvider.openAsynchronousServerSocketChannel​(AsynchronousChannelGroup group)
      打开异步服务器套接字通道。
      abstract AsynchronousSocketChannel AsynchronousChannelProvider.openAsynchronousSocketChannel​(AsynchronousChannelGroup group)
      打开异步套接字通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.AsynchronousCloseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.AsynchronousCloseException

  • Packages that use AsynchronousCloseException
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。

    • Uses of AsynchronousCloseException in java.nio.channels

      Subclasses of AsynchronousCloseException in java.nio.channels
      Modifier and Type Class 描述
      class  ClosedByInterruptException
      另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。

    • Uses of AsynchronousCloseException in java.nio.channels.spi

      Methods in java.nio.channels.spi that throw AsynchronousCloseException
      Modifier and Type 方法 描述
      protected void AbstractInterruptibleChannel.end​(boolean completed)
      标记可能无限期阻止的I / O操作的结束。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.AsynchronousFileChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.AsynchronousFileChannel

  • Packages that use AsynchronousFileChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file.spi
    java.nio.file包的服务提供者类。

    • Uses of AsynchronousFileChannel in java.nio.channels

      Methods in java.nio.channels that return AsynchronousFileChannel
      Modifier and Type 方法 描述
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, OpenOption... options)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      abstract AsynchronousFileChannel AsynchronousFileChannel.truncate​(long size)
      将此频道的文件截断为给定大小。
      Constructors in java.nio.channels with parameters of type AsynchronousFileChannel
      Constructor 描述
      FileLock​(AsynchronousFileChannel channel, long position, long size, boolean shared)
      初始化此类的新实例。

    • Uses of AsynchronousFileChannel in java.nio.file.spi

      Methods in java.nio.file.spi that return AsynchronousFileChannel
      Modifier and Type 方法 描述
      AsynchronousFileChannel FileSystemProvider.newAsynchronousFileChannel​(Path path, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      Opens or creates a file for reading and/or writing, returning an asynchronous file channel to access the file.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.AsynchronousServerSocketChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.AsynchronousServerSocketChannel

  • Packages that use AsynchronousServerSocketChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    服务提供商类为 java.nio.channels包。

    • Uses of AsynchronousServerSocketChannel in java.nio.channels

      Methods in java.nio.channels that return AsynchronousServerSocketChannel
      Modifier and Type | 方法 | 描述
      AsynchronousServerSocketChannel AsynchronousServerSocketChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract AsynchronousServerSocketChannel AsynchronousServerSocketChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      static AsynchronousServerSocketChannel AsynchronousServerSocketChannel.open​()
      打开异步服务器套接字通道。
      static AsynchronousServerSocketChannel AsynchronousServerSocketChannel.open​(AsynchronousChannelGroup group)
      打开异步服务器套接字通道。
      abstract <T> AsynchronousServerSocketChannel | AsynchronousServerSocketChannel.setOption​(SocketOption<T> name, T value)

    • Uses of AsynchronousServerSocketChannel in java.nio.channels.spi

      Methods in java.nio.channels.spi that return AsynchronousServerSocketChannel
      Modifier and Type 方法 描述
      abstract AsynchronousServerSocketChannel AsynchronousChannelProvider.openAsynchronousServerSocketChannel​(AsynchronousChannelGroup group)
      Opens an asynchronous server-socket channel.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.AsynchronousSocketChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.AsynchronousSocketChannel

  • Packages that use AsynchronousSocketChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    服务提供商类为 java.nio.channels包。

    • Uses of AsynchronousSocketChannel in java.nio.channels

      Methods in java.nio.channels that return AsynchronousSocketChannel
      Modifier and Type | 方法 | 描述
      abstract AsynchronousSocketChannel | AsynchronousSocketChannel.bind​(SocketAddress local)
      static AsynchronousSocketChannel AsynchronousSocketChannel.open​()
      打开异步套接字通道。
      static AsynchronousSocketChannel AsynchronousSocketChannel.open​(AsynchronousChannelGroup group)
      打开异步套接字通道。
      abstract <T> AsynchronousSocketChannel | AsynchronousSocketChannel.setOption​(SocketOption<T> name, T value)
      abstract AsynchronousSocketChannel AsynchronousSocketChannel.shutdownInput​()
      关闭连接进行阅读，不关闭频道。
      abstract AsynchronousSocketChannel AsynchronousSocketChannel.shutdownOutput​()
      关闭连接以进行写入，而不关闭通道。
      Methods in java.nio.channels that return types with arguments of type AsynchronousSocketChannel
      Modifier and Type 方法 描述
      abstract Future<AsynchronousSocketChannel> AsynchronousServerSocketChannel.accept​()
      接受连接。
      Method parameters in java.nio.channels with type arguments of type AsynchronousSocketChannel
      Modifier and Type 方法 描述
      abstract <A> void AsynchronousServerSocketChannel.accept​(A attachment, CompletionHandler<AsynchronousSocketChannel,? super A> handler)
      接受连接。

    • Uses of AsynchronousSocketChannel in java.nio.channels.spi

      Methods in java.nio.channels.spi that return AsynchronousSocketChannel
      Modifier and Type 方法 描述
      abstract AsynchronousSocketChannel AsynchronousChannelProvider.openAsynchronousSocketChannel​(AsynchronousChannelGroup group)
      打开异步套接字通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.CancelledKeyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.CancelledKeyException

No usage of java.nio.channels.CancelledKeyException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.Channels (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.Channels

No usage of java.nio.channels.Channels
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.ClosedByInterruptException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.ClosedByInterruptException

No usage of java.nio.channels.ClosedByInterruptException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.ClosedChannelException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.ClosedChannelException

  • Packages that use ClosedChannelException
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供者类。

    • Uses of ClosedChannelException in java.nio.channels

      Subclasses of ClosedChannelException in java.nio.channels
      Modifier and Type Class 描述
      class  AsynchronousCloseException
      当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
      class  ClosedByInterruptException
      另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。
      Methods in java.nio.channels that throw ClosedChannelException
      Modifier and Type 方法 描述
      SelectionKey SelectableChannel.register​(Selector sel, int ops)
      使用给定的选择器注册此频道，返回一个选择键。
      abstract SelectionKey SelectableChannel.register​(Selector sel, int ops, Object att)
      使用给定的选择器注册此频道，返回一个选择键。

    • Uses of ClosedChannelException in java.nio.channels.spi

      Methods in java.nio.channels.spi that throw ClosedChannelException
      Modifier and Type 方法 描述
      SelectionKey AbstractSelectableChannel.register​(Selector sel, int ops, Object att)
      Registers this channel with the given selector, returning a selection key.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.ClosedSelectorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.ClosedSelectorException

No usage of java.nio.channels.ClosedSelectorException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.ConnectionPendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.ConnectionPendingException

No usage of java.nio.channels.ConnectionPendingException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.DatagramChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.DatagramChannel

  • Packages that use DatagramChannel
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供者类。

    • Uses of DatagramChannel in java.net

      Methods in java.net that return DatagramChannel
      Modifier and Type 方法 描述
      DatagramChannel DatagramSocket.getChannel​()
      返回与此数据报套接字相关联的唯一的DatagramChannel对象（如果有）。

    • Uses of DatagramChannel in java.nio.channels

      Methods in java.nio.channels that return DatagramChannel
      Modifier and Type | 方法 | 描述
      abstract DatagramChannel | DatagramChannel.bind​(SocketAddress local)
      abstract DatagramChannel DatagramChannel.connect​(SocketAddress remote)
      连接此通道的插座。
      abstract DatagramChannel DatagramChannel.disconnect​()
      断开此通道的插座。
      static DatagramChannel DatagramChannel.open​()
      打开数据报通道。
      static DatagramChannel DatagramChannel.open​(ProtocolFamily family)
      打开数据报通道。
      abstract <T> DatagramChannel | DatagramChannel.setOption​(SocketOption<T> name, T value)

    • Uses of DatagramChannel in java.nio.channels.spi

      Methods in java.nio.channels.spi that return DatagramChannel
      Modifier and Type 方法 描述
      abstract DatagramChannel SelectorProvider.openDatagramChannel​()
      打开数据报通道。
      abstract DatagramChannel SelectorProvider.openDatagramChannel​(ProtocolFamily family)
      打开数据报通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.FileChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.FileChannel

  • Packages that use FileChannel
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file.spi
    java.nio.file包的服务提供商类。

    • Uses of FileChannel in java.io

      Methods in java.io that return FileChannel
      Modifier and Type 方法 描述
      FileChannel FileInputStream.getChannel​()
      返回与此文件输入流关联的唯一的FileChannel对象。
      FileChannel FileOutputStream.getChannel​()
      返回与此文件输出流关联的唯一的FileChannel对象。
      FileChannel RandomAccessFile.getChannel​()
      返回与此文件关联的唯一的FileChannel对象。

    • Uses of FileChannel in java.nio.channels

      Methods in java.nio.channels that return FileChannel
      Modifier and Type 方法 描述
      FileChannel FileLock.channel​()
      返回获取此锁的文件通道。
      static FileChannel FileChannel.open​(Path path, OpenOption... options)
      打开或创建文件，返回文件通道以访问该文件。
      static FileChannel FileChannel.open​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回文件通道以访问该文件。
      abstract FileChannel FileChannel.position​(long newPosition)
      设置此通道的文件位置。
      abstract FileChannel FileChannel.truncate​(long size)
      将此频道的文件截断为给定大小。
      Constructors in java.nio.channels with parameters of type FileChannel
      Constructor 描述
      FileLock​(FileChannel channel, long position, long size, boolean shared)
      初始化此类的新实例。

    • Uses of FileChannel in java.nio.file.spi

      Methods in java.nio.file.spi that return FileChannel
      Modifier and Type 方法 描述
      FileChannel FileSystemProvider.newFileChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      Opens or creates a file for reading and/or writing, returning a file channel to access the file.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.FileChannel.MapMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.FileChannel.MapMode

  • Packages that use FileChannel.MapMode
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of FileChannel.MapMode in java.nio.channels

      Fields in java.nio.channels declared as FileChannel.MapMode
      Modifier and Type Field 描述
      static FileChannel.MapMode FileChannel.MapMode.PRIVATE
      私有（写时复制）映射模式。
      static FileChannel.MapMode FileChannel.MapMode.READ_ONLY
      只读映射的模式。
      static FileChannel.MapMode FileChannel.MapMode.READ_WRITE
      读/写映射模式。
      Methods in java.nio.channels with parameters of type FileChannel.MapMode
      Modifier and Type 方法 描述
      abstract MappedByteBuffer FileChannel.map​(FileChannel.MapMode mode, long position, long size)
      将此频道文件的区域直接映射到内存中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.FileLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.FileLock

  • Packages that use FileLock
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of FileLock in java.nio.channels

      Methods in java.nio.channels that return FileLock
      Modifier and Type 方法 描述
      FileLock FileChannel.lock​()
      获取此通道文件的排他锁。
      abstract FileLock FileChannel.lock​(long position, long size, boolean shared)
      获取此通道文件的给定区域的锁定。
      FileLock AsynchronousFileChannel.tryLock​()
      尝试获取此频道文件的排他锁。
      abstract FileLock AsynchronousFileChannel.tryLock​(long position, long size, boolean shared)
      尝试获取此通道文件的给定区域的锁定。
      FileLock FileChannel.tryLock​()
      尝试获取此频道文件的排他锁。
      abstract FileLock FileChannel.tryLock​(long position, long size, boolean shared)
      尝试获取此通道文件的给定区域的锁定。
      Methods in java.nio.channels that return types with arguments of type FileLock
      Modifier and Type 方法 描述
      Future<FileLock> AsynchronousFileChannel.lock​()
      获取此通道文件的排他锁。
      abstract Future<FileLock> AsynchronousFileChannel.lock​(long position, long size, boolean shared)
      获取此通道文件的给定区域的锁定。
      Method parameters in java.nio.channels with type arguments of type FileLock
      Modifier and Type 方法 描述
      abstract <A> void AsynchronousFileChannel.lock​(long position, long size, boolean shared, A attachment, CompletionHandler<FileLock,? super A> handler)
      获取此通道文件的给定区域的锁定。
      <A> void AsynchronousFileChannel.lock​(A attachment, CompletionHandler<FileLock,? super A> handler)
      获取此通道文件的排他锁。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.FileLockInterruptionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.FileLockInterruptionException

No usage of java.nio.channels.FileLockInterruptionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.IllegalBlockingModeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.IllegalBlockingModeException

No usage of java.nio.channels.IllegalBlockingModeException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.IllegalChannelGroupException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.IllegalChannelGroupException

No usage of java.nio.channels.IllegalChannelGroupException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.IllegalSelectorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.IllegalSelectorException

No usage of java.nio.channels.IllegalSelectorException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.InterruptedByTimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.InterruptedByTimeoutException

No usage of java.nio.channels.InterruptedByTimeoutException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.MembershipKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.MembershipKey

  • Packages that use MembershipKey
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of MembershipKey in java.nio.channels

      Methods in java.nio.channels that return MembershipKey
      Modifier and Type 方法 描述
      abstract MembershipKey MembershipKey.block​(InetAddress source)
      阻止来自给定源地址的组播数据报。
      MembershipKey MulticastChannel.join​(InetAddress group, NetworkInterface interf)
      加入组播组，开始接收发送到组的所有数据报，返回成员密钥。
      MembershipKey MulticastChannel.join​(InetAddress group, NetworkInterface interf, InetAddress source)
      加入组播组，开始从给定的源地址接收发送到组的数据报。
      abstract MembershipKey MembershipKey.unblock​(InetAddress source)
      从以前使用 block方法阻止的给定源地址中解除阻塞多播数据报。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.NoConnectionPendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.NoConnectionPendingException

No usage of java.nio.channels.NoConnectionPendingException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.NonReadableChannelException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.NonReadableChannelException

No usage of java.nio.channels.NonReadableChannelException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.NonWritableChannelException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.NonWritableChannelException

No usage of java.nio.channels.NonWritableChannelException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.NotYetBoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.NotYetBoundException

No usage of java.nio.channels.NotYetBoundException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.NotYetConnectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.NotYetConnectedException

No usage of java.nio.channels.NotYetConnectedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.OverlappingFileLockException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.OverlappingFileLockException

No usage of java.nio.channels.OverlappingFileLockException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.Pipe (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.Pipe

  • Packages that use Pipe
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供者类。

    • Uses of Pipe in java.nio.channels

      Methods in java.nio.channels that return Pipe
      Modifier and Type 方法 描述
      static Pipe Pipe.open​()
      打开管道。

    • Uses of Pipe in java.nio.channels.spi

      Methods in java.nio.channels.spi that return Pipe
      Modifier and Type 方法 描述
      abstract Pipe SelectorProvider.openPipe​()
      打开管道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.Pipe.SinkChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.Pipe.SinkChannel

  • Packages that use Pipe.SinkChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of Pipe.SinkChannel in java.nio.channels

      Methods in java.nio.channels that return Pipe.SinkChannel
      Modifier and Type 方法 描述
      abstract Pipe.SinkChannel Pipe.sink​()
      返回此管道的接收通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.Pipe.SourceChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.Pipe.SourceChannel

  • Packages that use Pipe.SourceChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of Pipe.SourceChannel in java.nio.channels

      Methods in java.nio.channels that return Pipe.SourceChannel
      Modifier and Type 方法 描述
      abstract Pipe.SourceChannel Pipe.source​()
      返回此管道的源通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.ReadPendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.ReadPendingException

No usage of java.nio.channels.ReadPendingException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.SelectableChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.SelectableChannel

  • Packages that use SelectableChannel
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。

    • Uses of SelectableChannel in com.sun.nio.sctp

      Subclasses of SelectableChannel in com.sun.nio.sctp
      Modifier and Type Class 描述
      class  SctpChannel
      用于面向消息的连接SCTP套接字的可选通道。
      class  SctpMultiChannel
      用于面向消息的SCTP套接字的可选通道。
      class  SctpServerChannel
      用于面向消息的侦听SCTP插座的可选通道。

    • Uses of SelectableChannel in java.nio.channels

      Subclasses of SelectableChannel in java.nio.channels
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      static class  Pipe.SinkChannel
      一个代表Pipe的可写端的通道 。
      static class  Pipe.SourceChannel
      表示Pipe的可读末端的通道 。
      class  ServerSocketChannel
      用于面向流的侦听套接字的可选通道。
      class  SocketChannel
      用于面向流的连接插座的可选通道。
      Methods in java.nio.channels that return SelectableChannel
      Modifier and Type 方法 描述
      abstract SelectableChannel SelectionKey.channel​()
      返回创建此键的通道。
      abstract SelectableChannel SelectableChannel.configureBlocking​(boolean block)
      调整此频道的屏蔽模式。

    • Uses of SelectableChannel in java.nio.channels.spi

      Subclasses of SelectableChannel in java.nio.channels.spi
      Modifier and Type Class 描述
      class  AbstractSelectableChannel
      可选通道的基本实现类。
      Methods in java.nio.channels.spi that return SelectableChannel
      Modifier and Type 方法 描述
      SelectableChannel AbstractSelectableChannel.configureBlocking​(boolean block)
      调整此频道的屏蔽模式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.SelectionKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.SelectionKey

  • Packages that use SelectionKey
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供者类。

    • Uses of SelectionKey in java.nio.channels

      Methods in java.nio.channels that return SelectionKey
      Modifier and Type 方法 描述
      abstract SelectionKey SelectionKey.interestOps​(int ops)
      将此键的兴趣设置为给定值。
      abstract SelectionKey SelectableChannel.keyFor​(Selector sel)
      检索表示频道注册的键与给定的选择器。
      SelectionKey SelectableChannel.register​(Selector sel, int ops)
      使用给定的选择器注册此频道，返回一个选择键。
      abstract SelectionKey SelectableChannel.register​(Selector sel, int ops, Object att)
      使用给定的选择器注册此频道，返回一个选择键。
      Methods in java.nio.channels that return types with arguments of type SelectionKey
      Modifier and Type 方法 描述
      abstract Set<SelectionKey> Selector.keys​()
      返回此选择器的键集。
      abstract Set<SelectionKey> Selector.selectedKeys​()
      返回此选择器的选择键集。

    • Uses of SelectionKey in java.nio.channels.spi

      Subclasses of SelectionKey in java.nio.channels.spi
      Modifier and Type Class 描述
      class  AbstractSelectionKey
      选择键的基本实现类。
      Methods in java.nio.channels.spi that return SelectionKey
      Modifier and Type | 方法 | 描述
      SelectionKey | AbstractSelectableChannel.keyFor​(Selector sel)
      SelectionKey AbstractSelectableChannel.register​(Selector sel, int ops, Object att)
      使用给定的选择器注册此频道，返回一个选择键。
      protected abstract SelectionKey AbstractSelector.register​(AbstractSelectableChannel ch, int ops, Object att)
      使用此选择器注册给定通道。
      Methods in java.nio.channels.spi that return types with arguments of type SelectionKey
      Modifier and Type 方法 描述
      protected Set<SelectionKey> AbstractSelector.cancelledKeys​()
      检索此选择器的已取消键集。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.Selector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.Selector

  • Packages that use Selector
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供者类。

    • Uses of Selector in java.nio.channels

      Methods in java.nio.channels that return Selector
      Modifier and Type 方法 描述
      static Selector Selector.open​()
      打开选择器。
      abstract Selector SelectionKey.selector​()
      返回创建此键的选择器。
      abstract Selector Selector.wakeup​()
      导致尚未返回的第一个选择操作立即返回。
      Methods in java.nio.channels with parameters of type Selector
      Modifier and Type 方法 描述
      abstract SelectionKey SelectableChannel.keyFor​(Selector sel)
      检索表示频道注册的键与给定的选择器。
      SelectionKey SelectableChannel.register​(Selector sel, int ops)
      使用给定的选择器注册此频道，返回一个选择键。
      abstract SelectionKey SelectableChannel.register​(Selector sel, int ops, Object att)
      使用给定的选择器注册此频道，返回一个选择键。

    • Uses of Selector in java.nio.channels.spi

      Subclasses of Selector in java.nio.channels.spi
      Modifier and Type Class 描述
      class  AbstractSelector
      选择器的基本实现类。
      Methods in java.nio.channels.spi with parameters of type Selector
      Modifier and Type | 方法 | 描述
      SelectionKey | AbstractSelectableChannel.keyFor​(Selector sel)
      SelectionKey AbstractSelectableChannel.register​(Selector sel, int ops, Object att)
      使用给定的选择器注册此频道，返回一个选择键。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.ServerSocketChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.ServerSocketChannel

  • Packages that use ServerSocketChannel
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    27055986843675包的服务提供者类。

    • Uses of ServerSocketChannel in java.net

      Methods in java.net that return ServerSocketChannel
      Modifier and Type 方法 描述
      ServerSocketChannel ServerSocket.getChannel​()
      返回与此套接字相关联的唯一的ServerSocketChannel对象（如果有）。

    • Uses of ServerSocketChannel in java.nio.channels

      Methods in java.nio.channels that return ServerSocketChannel
      Modifier and Type | 方法 | 描述
      ServerSocketChannel ServerSocketChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract ServerSocketChannel ServerSocketChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      static ServerSocketChannel ServerSocketChannel.open​()
      打开服务器插槽通道。
      abstract <T> ServerSocketChannel | ServerSocketChannel.setOption​(SocketOption<T> name, T value)

    • Uses of ServerSocketChannel in java.nio.channels.spi

      Methods in java.nio.channels.spi that return ServerSocketChannel
      Modifier and Type 方法 描述
      abstract ServerSocketChannel SelectorProvider.openServerSocketChannel​()
      打开服务器插槽通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.ShutdownChannelGroupException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.ShutdownChannelGroupException

No usage of java.nio.channels.ShutdownChannelGroupException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.SocketChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.SocketChannel

  • Packages that use SocketChannel
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供者类。

    • Uses of SocketChannel in java.net

      Methods in java.net that return SocketChannel
      Modifier and Type 方法 描述
      SocketChannel Socket.getChannel​()
      返回与此套接字相关联的唯一的SocketChannel对象（如果有）。

    • Uses of SocketChannel in java.nio.channels

      Methods in java.nio.channels that return SocketChannel
      Modifier and Type | 方法 | 描述
      abstract SocketChannel ServerSocketChannel.accept​()
      接受与此频道套接字的连接。
      abstract SocketChannel | SocketChannel.bind​(SocketAddress local)
      static SocketChannel SocketChannel.open​()
      打开套接字通道。
      static SocketChannel SocketChannel.open​(SocketAddress remote)
      打开套接字通道并将其连接到远程地址。
      abstract <T> SocketChannel | SocketChannel.setOption​(SocketOption<T> name, T value)
      abstract SocketChannel SocketChannel.shutdownInput​()
      关闭连接进行阅读，不关闭频道。
      abstract SocketChannel SocketChannel.shutdownOutput​()
      关闭连接以进行写入，而不关闭通道。

    • Uses of SocketChannel in java.nio.channels.spi

      Methods in java.nio.channels.spi that return SocketChannel
      Modifier and Type 方法 描述
      abstract SocketChannel SelectorProvider.openSocketChannel​()
      打开套接字通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.UnresolvedAddressException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.UnresolvedAddressException

No usage of java.nio.channels.UnresolvedAddressException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.UnsupportedAddressTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.UnsupportedAddressTypeException

No usage of java.nio.channels.UnsupportedAddressTypeException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.WritePendingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.WritePendingException

No usage of java.nio.channels.WritePendingException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.AsynchronousByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.AsynchronousByteChannel

  • Packages that use AsynchronousByteChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of AsynchronousByteChannel in java.nio.channels

      Classes in java.nio.channels that implement AsynchronousByteChannel
      Modifier and Type Class 描述
      class  AsynchronousSocketChannel
      用于面向流的连接插座的异步通道。
      Methods in java.nio.channels with parameters of type AsynchronousByteChannel
      Modifier and Type 方法 描述
      static InputStream Channels.newInputStream​(AsynchronousByteChannel ch)
      构造从给定通道读取字节的流。
      static OutputStream Channels.newOutputStream​(AsynchronousByteChannel ch)
      构造将字节写入给定通道的流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.AsynchronousChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.AsynchronousChannel

  • Packages that use AsynchronousChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of AsynchronousChannel in java.nio.channels

      Subinterfaces of AsynchronousChannel in java.nio.channels
      Modifier and Type 接口 描述
      interface  AsynchronousByteChannel
      一个可以读写字节的异步通道。
      Classes in java.nio.channels that implement AsynchronousChannel
      Modifier and Type Class 描述
      class  AsynchronousFileChannel
      用于读取，写入和操作文件的异步通道。
      class  AsynchronousServerSocketChannel
      用于面向流的侦听套接字的异步通道。
      class  AsynchronousSocketChannel
      用于面向流的连接插座的异步通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.ByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.ByteChannel

  • Packages that use ByteChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of ByteChannel in java.nio.channels

      Subinterfaces of ByteChannel in java.nio.channels
      Modifier and Type 接口 描述
      interface  SeekableByteChannel
      保持当前 位置并允许更改 位置的字节通道。
      Classes in java.nio.channels that implement ByteChannel
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      class  SocketChannel
      用于面向流的连接插座的可选通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.Channel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.Channel

  • Packages that use Channel
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供者类。

    • Uses of Channel in com.sun.nio.sctp

      Classes in com.sun.nio.sctp that implement Channel
      Modifier and Type Class 描述
      class  SctpChannel
      用于面向消息的连接SCTP套接字的可选通道。
      class  SctpMultiChannel
      用于面向消息的SCTP套接字的可选通道。
      class  SctpServerChannel
      用于面向消息的侦听SCTP插座的可选通道。

    • Uses of Channel in java.lang

      Methods in java.lang that return Channel
      Modifier and Type 方法 描述
      static Channel System.inheritedChannel​()
      返回从创建此Java虚拟机的实体继承的通道。

    • Uses of Channel in java.nio.channels

      Subinterfaces of Channel in java.nio.channels
      Modifier and Type 接口 描述
      interface  AsynchronousByteChannel
      一个可以读写字节的异步通道。
      interface  AsynchronousChannel
      支持异步I / O操作的通道。
      interface  ByteChannel
      一个可以读写字节的通道。
      interface  GatheringByteChannel
      可以从缓冲区序列中写入字节的通道。
      interface  InterruptibleChannel
      可以异步关闭和中断的通道。
      interface  MulticastChannel
      支持互联网协议（IP）组播的网络通道。
      interface  NetworkChannel
      到网络插座的通道。
      interface  ReadableByteChannel
      一个可以读取字节的通道。
      interface  ScatteringByteChannel
      可以将字节读入缓冲区序列的通道。
      interface  SeekableByteChannel
      保持当前 位置并允许更改 位置的字节通道。
      interface  WritableByteChannel
      一个可以写字节的通道。
      Classes in java.nio.channels that implement Channel
      Modifier and Type Class 描述
      class  AsynchronousFileChannel
      用于读取，写入和操作文件的异步通道。
      class  AsynchronousServerSocketChannel
      用于面向流的侦听套接字的异步通道。
      class  AsynchronousSocketChannel
      用于面向流的连接插座的异步通道。
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      static class  Pipe.SinkChannel
      一个代表Pipe可写端的通道 。
      static class  Pipe.SourceChannel
      表示Pipe的可读末端的通道 。
      class  SelectableChannel
      可通过Selector复用的通道 。
      class  ServerSocketChannel
      用于面向流的侦听套接字的可选通道。
      class  SocketChannel
      用于面向流的连接插座的可选通道。
      Methods in java.nio.channels that return Channel
      Modifier and Type 方法 描述
      Channel FileLock.acquiredBy​()
      返回获取此锁的文件的通道。

    • Uses of Channel in java.nio.channels.spi

      Classes in java.nio.channels.spi that implement Channel
      Modifier and Type Class 描述
      class  AbstractInterruptibleChannel
      可中断通道的基本实现类。
      class  AbstractSelectableChannel
      可选通道的基本实现类。
      Methods in java.nio.channels.spi that return Channel
      Modifier and Type 方法 描述
      Channel SelectorProvider.inheritedChannel​()
      返回从创建此Java虚拟机的实体继承的通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.CompletionHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.CompletionHandler

  • Packages that use CompletionHandler
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of CompletionHandler in java.nio.channels

      Methods in java.nio.channels with parameters of type CompletionHandler
      Modifier and Type | 方法 | 描述
      abstract <A> void AsynchronousServerSocketChannel.accept​(A attachment, CompletionHandler<AsynchronousSocketChannel,? super A> handler)
      接受连接。
      abstract <A> void AsynchronousSocketChannel.connect​(SocketAddress remote, A attachment, CompletionHandler<Void,? super A> handler)
      连接此频道。
      abstract <A> void AsynchronousFileChannel.lock​(long position, long size, boolean shared, A attachment, CompletionHandler<FileLock,? super A> handler)
      获取此通道文件的给定区域的锁定。
      <A> void AsynchronousFileChannel.lock​(A attachment, CompletionHandler<FileLock,? super A> handler)
      获取此通道文件的排他锁。
      <A> void AsynchronousByteChannel.read​(ByteBuffer dst, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      abstract <A> void AsynchronousFileChannel.read​(ByteBuffer dst, long position, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      abstract <A> void AsynchronousSocketChannel.read​(ByteBuffer[] dsts, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从该通道读取字节序列到给定缓冲区的子序列中。
      abstract <A> void AsynchronousSocketChannel.read​(ByteBuffer dst, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      <A> void | AsynchronousSocketChannel.read​(ByteBuffer dst, A attachment, CompletionHandler<Integer,? super A> handler)
      <A> void AsynchronousByteChannel.write​(ByteBuffer src, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向该通道写入一个字节序列。
      abstract <A> void AsynchronousFileChannel.write​(ByteBuffer src, long position, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
      abstract <A> void AsynchronousSocketChannel.write​(ByteBuffer[] srcs, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从给定缓冲区的子序列将一个字节序列写入该通道。
      abstract <A> void AsynchronousSocketChannel.write​(ByteBuffer src, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      Writes a sequence of bytes to this channel from the given buffer.
      <A> void | AsynchronousSocketChannel.write​(ByteBuffer src, A attachment, CompletionHandler<Integer,? super A> handler)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.GatheringByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.GatheringByteChannel

  • Packages that use GatheringByteChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of GatheringByteChannel in java.nio.channels

      Classes in java.nio.channels that implement GatheringByteChannel
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      static class  Pipe.SinkChannel
      一个代表Pipe可写端的通道 。
      class  SocketChannel
      用于面向流的连接插座的可选通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.InterruptibleChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.InterruptibleChannel

  • Packages that use InterruptibleChannel
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    服务提供商类为 java.nio.channels包。

    • Uses of InterruptibleChannel in com.sun.nio.sctp

      Classes in com.sun.nio.sctp that implement InterruptibleChannel
      Modifier and Type Class 描述
      class  SctpChannel
      用于面向消息的连接SCTP套接字的可选通道。
      class  SctpMultiChannel
      用于面向消息的SCTP套接字的可选通道。
      class  SctpServerChannel
      用于面向消息的侦听SCTP插座的可选通道。

    • Uses of InterruptibleChannel in java.nio.channels

      Classes in java.nio.channels that implement InterruptibleChannel
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      static class  Pipe.SinkChannel
      一个代表Pipe的可写端的通道 。
      static class  Pipe.SourceChannel
      表示Pipe的可读端的通道 。
      class  SelectableChannel
      可通过Selector复用的频道 。
      class  ServerSocketChannel
      用于面向流的侦听套接字的可选通道。
      class  SocketChannel
      用于面向流的连接插座的可选通道。

    • Uses of InterruptibleChannel in java.nio.channels.spi

      Classes in java.nio.channels.spi that implement InterruptibleChannel
      Modifier and Type Class 描述
      class  AbstractInterruptibleChannel
      可中断通道的基本实现类。
      class  AbstractSelectableChannel
      可选通道的基本实现类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.MulticastChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.MulticastChannel

  • Packages that use MulticastChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of MulticastChannel in java.nio.channels

      Classes in java.nio.channels that implement MulticastChannel
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      Methods in java.nio.channels that return MulticastChannel
      Modifier and Type 方法 描述
      abstract MulticastChannel MembershipKey.channel​()
      返回创建此成员资格密钥的通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.NetworkChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.NetworkChannel

  • Packages that use NetworkChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of NetworkChannel in java.nio.channels

      Subinterfaces of NetworkChannel in java.nio.channels
      Modifier and Type 接口 描述
      interface  MulticastChannel
      支持互联网协议（IP）组播的网络通道。
      Classes in java.nio.channels that implement NetworkChannel
      Modifier and Type Class 描述
      class  AsynchronousServerSocketChannel
      用于面向流的侦听套接字的异步通道。
      class  AsynchronousSocketChannel
      用于面向流的连接插座的异步通道。
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  ServerSocketChannel
      用于面向流的侦听套接字的可选通道。
      class  SocketChannel
      用于面向流的连接插座的可选通道。
      Methods in java.nio.channels that return NetworkChannel
      Modifier and Type 方法 描述
      NetworkChannel NetworkChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      <T> NetworkChannel NetworkChannel.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.ReadableByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.ReadableByteChannel

  • Packages that use ReadableByteChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of ReadableByteChannel in java.nio.channels

      Subinterfaces of ReadableByteChannel in java.nio.channels
      Modifier and Type 接口 描述
      interface  ByteChannel
      一个可以读写字节的通道。
      interface  ScatteringByteChannel
      可以将字节读入缓冲区序列的通道。
      interface  SeekableByteChannel
      保持当前 位置并允许更改 位置的字节通道。
      Classes in java.nio.channels that implement ReadableByteChannel
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      static class  Pipe.SourceChannel
      代表Pipe的可读端的通道 。
      class  SocketChannel
      用于面向流的连接插座的可选通道。
      Methods in java.nio.channels that return ReadableByteChannel
      Modifier and Type 方法 描述
      static ReadableByteChannel Channels.newChannel​(InputStream in)
      构造从给定流读取字节的通道。
      Methods in java.nio.channels with parameters of type ReadableByteChannel
      Modifier and Type 方法 描述
      static InputStream Channels.newInputStream​(ReadableByteChannel ch)
      构造从给定通道读取字节的流。
      static Reader Channels.newReader​(ReadableByteChannel ch, String csName)
      构造一个读取器，根据命名的字符集解码来自给定通道的字节。
      static Reader Channels.newReader​(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap)
      构造一个读取器，使用给定的解码器解码来自给定通道的字节。
      abstract long FileChannel.transferFrom​(ReadableByteChannel src, long position, long count)
      从给定的可读字节通道将字节传输到该通道的文件中。

    • Uses of ReadableByteChannel in java.util

      Constructors in java.util with parameters of type ReadableByteChannel
      Constructor 描述
      Scanner​(ReadableByteChannel source)
      构造一个新的 Scanner ，产生从指定通道扫描的值。
      Scanner​(ReadableByteChannel source, String charsetName)
      构造一个新的 Scanner ，产生从指定通道扫描的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.ScatteringByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.ScatteringByteChannel

  • Packages that use ScatteringByteChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of ScatteringByteChannel in java.nio.channels

      Classes in java.nio.channels that implement ScatteringByteChannel
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      static class  Pipe.SourceChannel
      表示Pipe的可读末端的通道 。
      class  SocketChannel
      用于面向流的连接插座的可选通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.SeekableByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.SeekableByteChannel

  • Packages that use SeekableByteChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。

    • Uses of SeekableByteChannel in java.nio.channels

      Classes in java.nio.channels that implement SeekableByteChannel
      Modifier and Type Class 描述
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      Methods in java.nio.channels that return SeekableByteChannel
      Modifier and Type 方法 描述
      SeekableByteChannel SeekableByteChannel.position​(long newPosition)
      设置此频道的位置。
      SeekableByteChannel SeekableByteChannel.truncate​(long size)
      将连接此通道的实体截断为给定的大小。

    • Uses of SeekableByteChannel in java.nio.file

      Methods in java.nio.file that return SeekableByteChannel
      Modifier and Type 方法 描述
      static SeekableByteChannel Files.newByteChannel​(Path path, OpenOption... options)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      static SeekableByteChannel Files.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      SeekableByteChannel SecureDirectoryStream.newByteChannel​(T path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      在此目录中打开或创建一个文件，返回可访问的字节通道以访问该文件。

    • Uses of SeekableByteChannel in java.nio.file.spi

      Methods in java.nio.file.spi that return SeekableByteChannel
      Modifier and Type 方法 描述
      abstract SeekableByteChannel FileSystemProvider.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.channels.WritableByteChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.channels.WritableByteChannel

  • Packages that use WritableByteChannel
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of WritableByteChannel in java.nio.channels

      Subinterfaces of WritableByteChannel in java.nio.channels
      Modifier and Type 接口 描述
      interface  ByteChannel
      一个可以读写字节的通道。
      interface  GatheringByteChannel
      可以从缓冲区序列中写入字节的通道。
      interface  SeekableByteChannel
      保持当前 位置并允许更改 位置的字节通道。
      Classes in java.nio.channels that implement WritableByteChannel
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      static class  Pipe.SinkChannel
      一个代表Pipe可写端的通道 。
      class  SocketChannel
      用于面向流的连接插座的可选通道。
      Methods in java.nio.channels that return WritableByteChannel
      Modifier and Type 方法 描述
      static WritableByteChannel Channels.newChannel​(OutputStream out)
      构造一个向给定流写入字节的通道。
      Methods in java.nio.channels with parameters of type WritableByteChannel
      Modifier and Type 方法 描述
      static OutputStream Channels.newOutputStream​(WritableByteChannel ch)
      构造将字节写入给定通道的流。
      static Writer Channels.newWriter​(WritableByteChannel ch, String csName)
      构造一个根据命名的字符集对字符进行编码的写入程序，并将生成的字节写入给定的通道。
      static Writer Channels.newWriter​(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap)
      构造一个使用给定编码器编码字符的写入器，并将生成的字节写入给定的通道。
      abstract long FileChannel.transferTo​(long position, long count, WritableByteChannel target)
      Transfers bytes from this channel's file to the given writable byte channel.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AbstractInterruptibleChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels.spi

Class AbstractInterruptibleChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Channel ， InterruptibleChannel
    已知直接子类：
    FileChannel ， SelectableChannel

    public abstract class AbstractInterruptibleChannel
extends Object
implements Channel, InterruptibleChannel
    可中断通道的基本实现类。

    该类封装了实现异步关闭和中断通道所需的低级机器。 具体的通道类必须分别调用begin和end方法，调用可能无限期阻塞的I / O操作。 为了确保总是调用end方法，这些方法应该在一个try ... finally块内使用：

     boolean completed = false;
 try {
     begin();
     completed = ...;    // Perform blocking I/O operation
     return ...;         // Return result
 } finally {
     end(completed);
 }

    end方法的completed参数说明I / O操作是否实际完成，即是否具有对调用者可见的任何影响。 例如，在读取字节的操作的情况下，如果仅当某些字节实际传输到调用者的目标缓冲区中时，该参数应为true 。

    具体的通道类还必须实现implCloseChannel方法，如果在通道上的本地I / O操作中阻止另一个线程时被调用，则该操作将立即返回，通过抛出异常或正常返回。 如果一个线程被中断或被阻塞的通道异步关闭，那么通道的end方法将抛出适当的异常。

    该类执行实现Channel规范所需的同步。 implCloseChannel方法的实现不需要与可能尝试关闭通道的其他线程同步。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractInterruptibleChannel​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected void begin​()
      标记可能无限期阻止的I / O操作的开始。
      void close​()
      关闭此频道。
      protected void end​(boolean completed)
      标记可能无限期阻止的I / O操作的结束。
      protected abstract void implCloseChannel​()
      关闭此频道。
      boolean isOpen​()
      告诉这个频道是否开放。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractInterruptibleChannel

        protected AbstractInterruptibleChannel​()
        初始化此类的新实例。

    • 方法详细信息

      • close

        public final void close​()
                 throws IOException
        关闭此频道。

        如果通道已经关闭，则此方法将立即返回。 否则，将通道标记为关闭，然后调用implCloseChannel方法以完成关闭操作。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Channel
        Specified by:
        close在接口 Closeable
        Specified by:
        close在接口 InterruptibleChannel
        异常
        IOException - 如果发生I / O错误

      • implCloseChannel

        protected abstract void implCloseChannel​()
                                  throws IOException
        关闭此频道。

        该方法由close方法调用，以执行关闭通道的实际工作。 该方法仅在通道尚未关闭的情况下被调用，并且不会多次调用。

        该方法的实现必须安排在该通道上被I / O操作阻塞的任何其他线程立即返回，通过抛出异常或返回正常。

        异常
        IOException - 如果在关闭通道时发生I / O错误

      • isOpen

        public final boolean isOpen​()
        描述从接口Channel复制
        告诉这个频道是否开放。
        Specified by:
        isOpen在接口 Channel
        结果
        true如果，只有这个频道是开放的

      • begin

        protected final void begin​()
        标记可能无限期阻止的I / O操作的开始。

        该方法应与串联调用end方法，使用try ... finally块如图above ，为了实现此通道异步关闭和中断。

      • end

        protected final void end​(boolean completed)
                  throws AsynchronousCloseException
        标记可能无限期阻止的I / O操作的结束。

        该方法应与begin方法一起调用，使用try ... finally块如above所示，以实现此通道的异步关闭和中断。

        参数
        completed - true如果且仅当I / O操作成功完成，即具有对操作的调用者可见的某些效果
        异常
        AsynchronousCloseException - 如果通道异步关闭
        ClosedByInterruptException - 如果在I / O操作中阻塞的线程中断
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractSelectableChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels.spi

Class AbstractSelectableChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
        • java.nio.channels.spi.AbstractSelectableChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Channel ， InterruptibleChannel
    已知直接子类：
    DatagramChannel ， Pipe.SinkChannel ， Pipe.SourceChannel ， SctpChannel ， SctpMultiChannel ， SctpServerChannel ， ServerSocketChannel ， SocketChannel

    public abstract class AbstractSelectableChannel
extends SelectableChannel
    可选通道的基本实现类。

    这个类定义了处理通道注册，注销和关闭的机制的方法。 它保持该通道的当前阻塞模式以及其当前的选择键组。 它执行实现SelectableChannel规范所需的所有同步。 在此类中定义的抽象受保护方法的实现不需要与可能从事相同操作的其他线程同步。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractSelectableChannel​(SelectorProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object blockingLock​()
      检索 configureBlocking和 register方法同步的对象。
      SelectableChannel configureBlocking​(boolean block)
      调整此频道的屏蔽模式。
      protected void implCloseChannel​()
      关闭此频道。
      protected abstract void implCloseSelectableChannel​()
      关闭此可选择的频道。
      protected abstract void implConfigureBlocking​(boolean block)
      调整此频道的屏蔽模式。
      boolean isBlocking​()
      告诉这个通道上的每个I / O操作是否会阻塞直到完成。
      boolean isRegistered​()
      告知这个频道当前是否在任何选择器上注册。
      SelectionKey keyFor​(Selector sel)
      检索表示频道注册的键与给定的选择器。
      SelectorProvider provider​()
      返回创建此通道的提供程序。
      SelectionKey register​(Selector sel, int ops, Object att)
      使用给定的选择器注册此频道，返回一个选择键。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, isOpen

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.SelectableChannel

        register, validOps

    • 构造方法详细信息

      • AbstractSelectableChannel

        protected AbstractSelectableChannel​(SelectorProvider provider)
        初始化此类的新实例。
        参数
        provider - 创建此频道的提供商

    • 方法详细信息

      • provider

        public final SelectorProvider provider​()
        返回创建此通道的提供程序。
        Specified by:
        provider在 SelectableChannel
        结果
        创建此频道的提供商

      • isRegistered

        public final boolean isRegistered​()
        描述从类别复制： SelectableChannel
        告知这个频道当前是否在任何选择器上注册。 新创建的频道未注册。

        由于键取消和通道注销之间的固有延迟，在所有键被取消之后，频道可能会保留一段时间。 通道关闭后也可能会保留一段时间。

        Specified by:
        isRegistered在 SelectableChannel
        结果
        true如果，并且仅当该频道被注册

      • keyFor

        public final SelectionKey keyFor​(Selector sel)
        描述从类别复制SelectableChannel
        检索表示频道注册的键与给定的选择器。
        Specified by:
        keyFor在 SelectableChannel
        参数
        sel - 选择器
        结果
        当该频道最后一次向给定选择器注册时返回该键，如果该频道当前未注册该选择器，则 null

      • register

        public final SelectionKey register​(Selector sel,
                                   int ops,
                                   Object att)
                            throws ClosedChannelException
        使用给定的选择器注册此频道，返回一个选择键。

        该方法首先验证该通道是否打开，并且给定的初始兴趣集合是有效的。

        如果该通道已经向给定的选择器注册，那么在将其兴趣设置为给定值之后，返回表示该注册的选择键。

        否则，此通道尚未注册到给定的选择器，因此在保持适当的锁定的同时调用选择器的register方法。 生成的密钥将在返回之前添加到此通道的密钥集中。

        Specified by:
        register在 SelectableChannel
        参数
        sel - 要注册该通道的选择器
        ops - 为结果键设置的兴趣
        att - 结果密钥的附件; 可以是null
        结果
        表示该通道与给定选择器的注册的键
        异常
        ClosedSelectorException - 如果选择器关闭
        IllegalBlockingModeException - 如果此通道处于阻塞模式
        IllegalSelectorException - 如果此频道并非与给定选择器相同的提供商创建
        CancelledKeyException - 如果此通道当前已注册到给定的选择器，但相应的键已被取消
        IllegalArgumentException - 如果 ops集合中的某个位与此通道支持的操作不对应，即 set & ~validOps() != 0
        ClosedChannelException - 如果此通道关闭

      • implCloseChannel

        protected final void implCloseChannel​()
                               throws IOException
        关闭此频道。

        该方法在AbstractInterruptibleChannel类中指定并由close方法调用，依次调用implCloseSelectableChannel方法，以执行关闭此通道的实际工作。 然后取消所有此频道的密钥。

        Specified by:
        implCloseChannel在 AbstractInterruptibleChannel
        异常
        IOException - 如果在关闭通道时发生I / O错误

      • implCloseSelectableChannel

        protected abstract void implCloseSelectableChannel​()
                                            throws IOException
        关闭此可选择的频道。

        该方法由close方法调用，以执行关闭通道的实际工作。 该方法仅在通道尚未关闭的情况下被调用，并且不会多次调用。

        该方法的实现必须安排在该通道上被I / O操作阻塞的任何其他线程立即返回，通过抛出异常或返回正常。

        异常
        IOException - 如果发生I / O错误

      • isBlocking

        public final boolean isBlocking​()
        说明从类别复制： SelectableChannel
        告诉这个通道上的每个I / O操作是否会阻塞直到完成。 新创建的通道始终处于阻止模式。

        如果此通道关闭，则此方法返回的值未指定。

        Specified by:
        isBlocking在 SelectableChannel
        结果
        true如果，且仅当此通道处于阻塞模式时

      • blockingLock

        public final Object blockingLock​()
        描述从类别复制SelectableChannel
        检索configureBlocking和register方法同步的对象。 这在实现需要在短时间内保持特定阻塞模式的适配器通常是有用的。
        Specified by:
        blockingLock在 SelectableChannel
        结果
        阻塞模式锁定对象

      • configureBlocking

        public final SelectableChannel configureBlocking​(boolean block)
                                          throws IOException
        调整此频道的屏蔽模式。

        如果给定的阻塞模式与当前阻塞模式不同，则该方法调用implConfigureBlocking方法，同时保持适当的锁，以便更改模式。

        Specified by:
        configureBlocking在 SelectableChannel
        参数
        block - 如果true那么这个通道将被置于阻塞模式; 如果是false那么会被放置为非阻塞模式
        结果
        这个可选频道
        异常
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误

      • implConfigureBlocking

        protected abstract void implConfigureBlocking​(boolean block)
                                       throws IOException
        调整此频道的屏蔽模式。

        该方法由configureBlocking方法调用，以便执行更改阻塞模式的实际工作。 仅当新模式与当前模式不同时才调用此方法。

        参数
        block - 如果是true则该通道将被置于阻塞模式; 如果是false那么会被放置为非阻塞模式
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractSelectionKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels.spi

Class AbstractSelectionKey

  • java.lang.Object
    • java.nio.channels.SelectionKey
      • java.nio.channels.spi.AbstractSelectionKey

  • public abstract class AbstractSelectionKey
extends SelectionKey
    选择键的基本实现类。

    该类跟踪密钥的有效性并实现取消。

    从以下版本开始：
    1.4

    • Field Summary

      • Fields inherited from class java.nio.channels.SelectionKey

        OP_ACCEPT, OP_CONNECT, OP_READ, OP_WRITE

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractSelectionKey​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancel​()
      取消此键。
      boolean isValid​()
      告知这个密钥是否有效。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.SelectionKey

        attach, attachment, channel, interestOps, interestOps, isAcceptable, isConnectable, isReadable, isWritable, readyOps, selector

    • 构造方法详细信息

      • AbstractSelectionKey

        protected AbstractSelectionKey​()
        初始化此类的新实例。

    • 方法详细信息

      • isValid

        public final boolean isValid​()
        描述从类别复制SelectionKey
        告知这个密钥是否有效。

        钥匙在创建时有效，并保持原样，直到它被取消，其通道关闭或其选择器关闭。

        Specified by:
        isValid在 SelectionKey
        结果
        true如果，且仅当此密钥有效

      • cancel

        public final void cancel​()
        取消此键。

        如果此键尚未被取消，则在该组同步时将其添加到其选择器的取消键集合中。

        Specified by:
        cancel在 SelectionKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels.spi

Class AbstractSelector

  • java.lang.Object
    • java.nio.channels.Selector
      • java.nio.channels.spi.AbstractSelector
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public abstract class AbstractSelector
extends Selector
    选择器的基本实现类。

    该类封装了实施选择操作中断所需的低级机器。 具体的选择器类必须分别调用begin和end方法，调用可能无限期阻塞的I / O操作。 为了确保end方法总是被调用，这些方法应该在一个try ... finally块内使用：

     try {
     begin();
     // Perform blocking I/O operation here
     ...
 } finally {
     end();
 }

    该类还定义了方法，用于保持选择器的取消键集以及用于除去从其通道的键组中的键，并声明抽象register方法，其由可选择通道的调用register方法，以执行注册的信道的实际工作。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractSelector​(SelectorProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected void begin​()
      标记可能无限期阻止的I / O操作的开始。
      protected Set<SelectionKey> cancelledKeys​()
      检索此选择器的已取消键集。
      void close​()
      关闭此选择器。
      protected void deregister​(AbstractSelectionKey key)
      从其频道的密钥集中删除给定的密钥。
      protected void end​()
      标记可能无限期阻止的I / O操作的结束。
      protected abstract void implCloseSelector​()
      关闭此选择器。
      boolean isOpen​()
      告诉这个选择器是否打开。
      SelectorProvider provider​()
      返回创建此通道的提供程序。
      protected abstract SelectionKey register​(AbstractSelectableChannel ch, int ops, Object att)
      使用此选择器注册给定通道。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.Selector

        keys, open, select, select, selectedKeys, selectNow, wakeup

    • 构造方法详细信息

      • AbstractSelector

        protected AbstractSelector​(SelectorProvider provider)
        初始化此类的新实例。
        参数
        provider - 创建此选择器的提供程序

    • 方法详细信息

      • close

        public final void close​()
                 throws IOException
        关闭此选择器。

        如果选择器已经关闭，则该方法将立即返回。 否则它将选择器标记为已关闭，然后调用implCloseSelector方法以完成关闭操作。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close中的 Selector
        异常
        IOException - 如果发生I / O错误

      • implCloseSelector

        protected abstract void implCloseSelector​()
                                   throws IOException
        关闭此选择器。

        该方法由close方法调用，以执行关闭选择器的实际工作。 只有当选择器尚未关闭时，才会调用此方法，并且不会多次调用此方法。

        此方法的实现必须安排在选择操作中被阻止的任何其他线程立即返回，就像调用wakeup方法一样。

        异常
        IOException - 如果在关闭选择器时发生I / O错误

      • isOpen

        public final boolean isOpen​()
        描述从类别复制Selector
        告诉这个选择器是否打开。
        Specified by:
        isOpen在 Selector
        结果
        true如果，并且只有这个选择器是打开的

      • provider

        public final SelectorProvider provider​()
        返回创建此通道的提供程序。
        Specified by:
        provider在 Selector
        结果
        创建此频道的提供商

      • cancelledKeys

        protected final Set<SelectionKey> cancelledKeys​()
        检索此选择器的已取消键集。

        该集合只能在同步时使用。

        结果
        取消的密钥集

      • register

        protected abstract SelectionKey register​(AbstractSelectableChannel ch,
                                         int ops,
                                         Object att)
        使用此选择器注册给定通道。

        该方法由通道的register方法调用，以便执行此选择器注册通道的实际工作。

        参数
        ch - 要注册的频道
        ops - 初始利息集，必须是有效的
        att - 生成的密钥的初始附件
        结果
        表示给定频道注册的新密钥与此选择器

      • deregister

        protected final void deregister​(AbstractSelectionKey key)
        从其频道的密钥集中删除给定的密钥。

        该方法必须由选择器对每个要注销的通道进行调用。

        参数
        key - 要删除的选择键

      • begin

        protected final void begin​()
        标记可能无限期阻止的I / O操作的开始。

        应该使用end方法调用此方法，使用try ... finally块（如above所示），以实现此选择器的中断。

        如果在选择器上的I / O操作中线程被阻塞时调用线程的interrupt方法，则调用此方法将安排选择器的wakeup方法。

      • end

        protected final void end​()
        标记可能无限期阻止的I / O操作的结束。

        应使用begin方法调用此方法，使用try ... finally块（如above所示），以实现此选择器的中断。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AsynchronousChannelProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels.spi

Class AsynchronousChannelProvider

  • java.lang.Object
    • java.nio.channels.spi.AsynchronousChannelProvider

  • public abstract class AsynchronousChannelProvider
extends Object
    用于异步通道的服务提供程序类。

    异步通道提供程序是此类的具体子类，具有零参数构造函数，并实现下面指定的抽象方法。 Java虚拟机的给定调用维护一个系统范围默认的提供者实例，由provider方法返回。 该方法的首次调用将定位如下所述的默认提供程序。

    此类中的所有方法都可以安全地被多个并发线程使用。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AsynchronousChannelProvider​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract AsynchronousChannelGroup openAsynchronousChannelGroup​(int nThreads, ThreadFactory threadFactory)
      构造一个具有固定线程池的新的异步通道组。
      abstract AsynchronousChannelGroup openAsynchronousChannelGroup​(ExecutorService executor, int initialSize)
      使用给定的线程池构造新的异步通道组。
      abstract AsynchronousServerSocketChannel openAsynchronousServerSocketChannel​(AsynchronousChannelGroup group)
      打开异步服务器套接字通道。
      abstract AsynchronousSocketChannel openAsynchronousSocketChannel​(AsynchronousChannelGroup group)
      打开异步套接字通道。
      static AsynchronousChannelProvider provider​()
      返回用于Java虚拟机调用的系统级默认异步通道提供程序。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AsynchronousChannelProvider

        protected AsynchronousChannelProvider​()
        初始化此类的新实例。
        异常
        SecurityException - 如果安全管理器已安装，并且它已拒绝RuntimePermission ("asynchronousChannelProvider")

    • 方法详细信息

      • provider

        public static AsynchronousChannelProvider provider​()
        返回用于Java虚拟机调用的系统级默认异步通道提供程序。

        此方法的第一次调用将定位默认提供程序对象，如下所示：

        1. 如果系统属性java.nio.channels.spi.AsynchronousChannelProvider被定义，那么它被认为是具体提供者类的完全限定名。 该类被加载和实例化; 如果此过程失败，则抛出未指定的错误。

        2. 如果提供程序类已安装在系统类加载程序可见的jar文件中，并且该jar文件在资源目录META-INF/services包含名为java.nio.channels.spi.AsynchronousChannelProvider的提供程序配置文件，则将在该文件中指定第一个类名。 该类被加载和实例化; 如果此过程失败，则抛出未指定的错误。

        3. 最后，如果没有通过上述任何一种方式指定提供程序，那么系统默认提供程序类将被实例化，并返回结果。

        此方法的后续调用返回由第一次调用返回的提供程序。

        结果
        系统级默认的AsynchronousChannel提供程序

      • openAsynchronousChannelGroup

        public abstract AsynchronousChannelGroup openAsynchronousChannelGroup​(int nThreads,
                                                                      ThreadFactory threadFactory)
                                                               throws IOException
        构造一个具有固定线程池的新的异步通道组。
        参数
        nThreads - 池中的线程数
        threadFactory - 创建新线程时使用的工厂
        结果
        一个新的异步通道组
        异常
        IllegalArgumentException - 如果是 nThreads <= 0
        IOException - 如果发生I / O错误
        另请参见：
        AsynchronousChannelGroup.withFixedThreadPool(int, java.util.concurrent.ThreadFactory)

      • openAsynchronousChannelGroup

        public abstract AsynchronousChannelGroup openAsynchronousChannelGroup​(ExecutorService executor,
                                                                      int initialSize)
                                                               throws IOException
        使用给定的线程池构造新的异步通道组。
        参数
        executor - 线程池
        initialSize - 值 >=0或实现特定默认值的负值
        结果
        一个新的异步通道组
        异常
        IOException - 如果发生I / O错误
        另请参见：
        AsynchronousChannelGroup.withCachedThreadPool(java.util.concurrent.ExecutorService, int)

      • openAsynchronousServerSocketChannel

        public abstract AsynchronousServerSocketChannel openAsynchronousServerSocketChannel​(AsynchronousChannelGroup group)
                                                                             throws IOException
        打开异步服务器套接字通道。
        参数
        group - 绑定通道的组，或 null绑定到默认组
        结果
        新频道
        异常
        IllegalChannelGroupException - 如果创建组的提供者与此提供程序不同
        ShutdownChannelGroupException - 该组已关闭
        IOException - 如果发生I / O错误

      • openAsynchronousSocketChannel

        public abstract AsynchronousSocketChannel openAsynchronousSocketChannel​(AsynchronousChannelGroup group)
                                                                 throws IOException
        打开异步套接字通道。
        参数
        group - 绑定通道的组，或 null绑定到默认组
        结果
        新频道
        异常
        IllegalChannelGroupException - 如果创建组的提供者与此提供程序不同
        ShutdownChannelGroupException - 该组已关闭
        IOException - If an I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.nio.channels.spi (Java SE 9 & JDK 9 )

java.nio.channels.spi

Classes

  • AbstractInterruptibleChannel
  • AbstractSelectableChannel
  • AbstractSelectionKey
  • AbstractSelector
  • AsynchronousChannelProvider
  • SelectorProvider


java.nio.channels.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.nio.channels.spi

java.nio.channels包的服务提供商类。

只有定义新的选择器提供者或异步通道提供者的开发者才需要直接使用这个包。

除非另有说明，否则将null参数传递给此程序包中任何类或接口中的构造函数或方法将导致抛出NullPointerException 。

从以下版本开始：
1.4
  • 类摘要
    Class 描述
    AbstractInterruptibleChannel
    可中断通道的基本实现类。
    AbstractSelectableChannel
    可选通道的基本实现类。
    AbstractSelectionKey
    选择键的基本实现类。
    AbstractSelector
    选择器的基本实现类。
    AsynchronousChannelProvider
    用于异步通道的服务提供程序类。
    SelectorProvider
    Service-provider class for selectors and selectable channels.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.nio.channels.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.nio.channels.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel (implements java.nio.channels.Channel, java.nio.channels.InterruptibleChannel)
      • java.nio.channels.SelectableChannel (implements java.nio.channels.Channel)
        • java.nio.channels.spi.AbstractSelectableChannel
    • java.nio.channels.spi.AsynchronousChannelProvider
    • java.nio.channels.SelectionKey
      • java.nio.channels.spi.AbstractSelectionKey
    • java.nio.channels.Selector (implements java.io.Closeable)
      • java.nio.channels.spi.AbstractSelector
    • java.nio.channels.spi.SelectorProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


SelectorProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.channels.spi

Class SelectorProvider

  • java.lang.Object
    • java.nio.channels.spi.SelectorProvider

  • public abstract class SelectorProvider
extends Object
    选择器和可选择通道的服务提供者类。

    选择器提供程序是该类的具体子类，它具有零参数构造函数，并实现下面指定的抽象方法。 给定的Java虚拟机的调用维护一个系统范围默认的提供者实例，由provider方法返回。 该方法的首次调用将定位如下所述的默认提供程序。

    全系统默认提供由静态使用open的方法DatagramChannel ， Pipe ， Selector ， ServerSocketChannel ，并SocketChannel类。 它也由System.inheritedChannel()方法使用。 程序可以通过实例化该提供者然后直接调用open定义的open方法来使用除默认提供者之外的提供者。

    此类中的所有方法都可以安全地被多个并发线程使用。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SelectorProvider​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Channel inheritedChannel​()
      返回从创建此Java虚拟机的实体继承的通道。
      abstract DatagramChannel openDatagramChannel​()
      打开数据报通道。
      abstract DatagramChannel openDatagramChannel​(ProtocolFamily family)
      打开数据报通道。
      abstract Pipe openPipe​()
      打开管道。
      abstract AbstractSelector openSelector​()
      打开选择器。
      abstract ServerSocketChannel openServerSocketChannel​()
      打开服务器插槽通道。
      abstract SocketChannel openSocketChannel​()
      打开套接字通道。
      static SelectorProvider provider​()
      返回用于Java虚拟机的此调用的系统级默认选择器提供程序。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SelectorProvider

        protected SelectorProvider​()
        初始化此类的新实例。
        异常
        SecurityException - 如果安全管理器已安装并且它已拒绝RuntimePermission ("selectorProvider")

    • 方法详细信息

      • provider

        public static SelectorProvider provider​()
        返回用于Java虚拟机的此调用的系统级默认选择器提供程序。

        此方法的第一次调用将定位默认提供程序对象，如下所示：

        1. 如果定义了系统属性java.nio.channels.spi.SelectorProvider ，则将其视为具体提供程序类的完全限定名称。 该类被加载和实例化; 如果此过程失败，则抛出未指定的错误。

        2. 如果提供程序类已安装在系统类加载程序可见的jar文件中，并且该jar文件在资源目录META-INF/services包含名为java.nio.channels.spi.SelectorProvider的提供程序配置文件，则将在该文件中指定第一个类名称。 该类被加载和实例化; 如果此过程失败，则抛出未指定的错误。

        3. 最后，如果没有通过上述任何一种方式指定提供程序，那么系统默认提供程序类将被实例化，并返回结果。

        此方法的后续调用返回由第一次调用返回的提供程序。

        结果
        系统范围的默认选择器提供程序

      • openDatagramChannel

        public abstract DatagramChannel openDatagramChannel​()
                                             throws IOException
        打开数据报通道。
        结果
        新频道
        异常
        IOException - 如果发生I / O错误

      • openDatagramChannel

        public abstract DatagramChannel openDatagramChannel​(ProtocolFamily family)
                                             throws IOException
        打开数据报通道。
        参数
        family - 协议族
        结果
        一个新的数据报通道
        异常
        UnsupportedOperationException - 如果不支持指定的协议族
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.7

      • openPipe

        public abstract Pipe openPipe​()
                       throws IOException
        打开管道。
        结果
        新的管道
        异常
        IOException - 如果发生I / O错误

      • openSelector

        public abstract AbstractSelector openSelector​()
                                       throws IOException
        打开选择器。
        结果
        新的选择器
        异常
        IOException - 如果发生I / O错误

      • openServerSocketChannel

        public abstract ServerSocketChannel openServerSocketChannel​()
                                                     throws IOException
        打开服务器插槽通道。
        结果
        新频道
        异常
        IOException - 如果发生I / O错误

      • openSocketChannel

        public abstract SocketChannel openSocketChannel​()
                                         throws IOException
        打开套接字通道。
        结果
        新频道
        异常
        IOException - 如果发生I / O错误

      • inheritedChannel

        public Channel inheritedChannel​()
                         throws IOException
        返回从创建此Java虚拟机的实体继承的通道。

        在许多操作系统上，可以以允许进程从创建该进程的实体继承一个通道的方式启动诸如Java虚拟机的进程。 这样做的方式是系统依赖的，通道可能连接到的可能实体也是如此。 例如，在UNIX系统上，当请求到达相关联的网络端口时，Internet服务守护程序（ inetd ）用于启动程序来服务请求。 在此示例中，启动的进程继承代表网络套接字的通道。

        在继承的通道表示网络套接字的情况下，此方法返回的Channel类型的确定如下：

        • 如果继承的通道表示面向流的连接套接字，则返回一个SocketChannel 。 套接字通道至少最初处于阻塞模式，绑定到套接字地址，并连接到对等体。

        • 如果继承的通道表示一个面向流的侦听套接字，则返回一个ServerSocketChannel 。 服务器套接字通道至少最初处于阻塞模式，并绑定到套接字地址。

        • 如果继承的通道是面向数据包的套接字，则返回一个DatagramChannel 。 数据报信道至少最初处于阻塞模式，并绑定到套接字地址。

        除了描述的面向网络的渠道之外，这种方法可能会在将来返回其他类型的频道。

        此方法的第一次调用将创建返回的通道。 此方法的后续调用返回相同的通道。

        结果
        继承的渠道，如果有，否则 null 。
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果安全管理器已安装，并且它已拒绝RuntimePermission ("inheritedChannel")
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.nio.channels.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.nio.channels.spi

  • Packages that use java.nio.channels.spi
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供者类。
  • Classes in java.nio.channels.spi used by com.sun.nio.sctp
    Class 描述
    AbstractInterruptibleChannel
    可中断通道的基本实现类。
    AbstractSelectableChannel
    可选通道的基本实现类。
    SelectorProvider
    选择器和可选择通道的服务提供者类。
  • Classes in java.nio.channels.spi used by java.nio.channels
    Class 描述
    AbstractInterruptibleChannel
    可中断通道的基本实现类。
    AbstractSelectableChannel
    可选通道的基本实现类。
    AsynchronousChannelProvider
    用于异步通道的服务提供程序类。
    SelectorProvider
    选择器和可选择通道的服务提供者类。
  • Classes in java.nio.channels.spi used by java.nio.channels.spi
    Class 描述
    AbstractInterruptibleChannel
    可中断通道的基本实现类。
    AbstractSelectableChannel
    可选通道的基本实现类。
    AbstractSelectionKey
    选择键的基本实现类。
    AbstractSelector
    选择器的基本实现类。
    AsynchronousChannelProvider
    用于异步通道的服务提供程序类。
    SelectorProvider
    选择器和可选择通道的服务提供者类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.spi.AbstractInterruptibleChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.spi.AbstractInterruptibleChannel

  • Packages that use AbstractInterruptibleChannel
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供者类。

    • Uses of AbstractInterruptibleChannel in com.sun.nio.sctp

      Subclasses of AbstractInterruptibleChannel in com.sun.nio.sctp
      Modifier and Type Class 描述
      class  SctpChannel
      用于面向消息的连接SCTP套接字的可选通道。
      class  SctpMultiChannel
      用于面向消息的SCTP套接字的可选通道。
      class  SctpServerChannel
      用于面向消息的侦听SCTP插座的可选通道。

    • Uses of AbstractInterruptibleChannel in java.nio.channels

      Subclasses of AbstractInterruptibleChannel in java.nio.channels
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      static class  Pipe.SinkChannel
      一个代表Pipe可写端的通道 。
      static class  Pipe.SourceChannel
      表示Pipe的可读端的通道 。
      class  SelectableChannel
      可通过Selector复用的通道 。
      class  ServerSocketChannel
      用于面向流的侦听套接字的可选通道。
      class  SocketChannel
      用于面向流的连接插座的可选通道。

    • Uses of AbstractInterruptibleChannel in java.nio.channels.spi

      Subclasses of AbstractInterruptibleChannel in java.nio.channels.spi
      Modifier and Type Class 描述
      class  AbstractSelectableChannel
      可选通道的基本实现类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.spi.AbstractSelectableChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.spi.AbstractSelectableChannel

  • Packages that use AbstractSelectableChannel
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。

    • Uses of AbstractSelectableChannel in com.sun.nio.sctp

      Subclasses of AbstractSelectableChannel in com.sun.nio.sctp
      Modifier and Type Class 描述
      class  SctpChannel
      用于面向消息的连接SCTP套接字的可选通道。
      class  SctpMultiChannel
      用于面向消息的SCTP套接字的可选通道。
      class  SctpServerChannel
      用于面向消息的侦听SCTP插座的可选通道。

    • Uses of AbstractSelectableChannel in java.nio.channels

      Subclasses of AbstractSelectableChannel in java.nio.channels
      Modifier and Type Class 描述
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      static class  Pipe.SinkChannel
      一个代表Pipe可写端的通道 。
      static class  Pipe.SourceChannel
      表示Pipe的可读端的通道 。
      class  ServerSocketChannel
      用于面向流的侦听套接字的可选通道。
      class  SocketChannel
      用于面向流的连接插座的可选通道。

    • Uses of AbstractSelectableChannel in java.nio.channels.spi

      Methods in java.nio.channels.spi with parameters of type AbstractSelectableChannel
      Modifier and Type 方法 描述
      protected abstract SelectionKey AbstractSelector.register​(AbstractSelectableChannel ch, int ops, Object att)
      使用此选择器注册给定通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.spi.AbstractSelectionKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.spi.AbstractSelectionKey

  • Packages that use AbstractSelectionKey
    软件包 描述
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。

    • Uses of AbstractSelectionKey in java.nio.channels.spi

      Methods in java.nio.channels.spi with parameters of type AbstractSelectionKey
      Modifier and Type 方法 描述
      protected void AbstractSelector.deregister​(AbstractSelectionKey key)
      从其频道的密钥集中删除给定的密钥。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.spi.AbstractSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.spi.AbstractSelector

  • Packages that use AbstractSelector
    软件包 描述
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。

    • Uses of AbstractSelector in java.nio.channels.spi

      Methods in java.nio.channels.spi that return AbstractSelector
      Modifier and Type 方法 描述
      abstract AbstractSelector SelectorProvider.openSelector​()
      打开选择器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.spi.AsynchronousChannelProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.spi.AsynchronousChannelProvider

  • Packages that use AsynchronousChannelProvider
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    服务提供商类为 java.nio.channels包。

    • Uses of AsynchronousChannelProvider in java.nio.channels

      Methods in java.nio.channels that return AsynchronousChannelProvider
      Modifier and Type 方法 描述
      AsynchronousChannelProvider AsynchronousChannelGroup.provider​()
      返回创建此通道组的提供程序。
      AsynchronousChannelProvider AsynchronousServerSocketChannel.provider​()
      返回创建此通道的提供程序。
      AsynchronousChannelProvider AsynchronousSocketChannel.provider​()
      返回创建此通道的提供程序。
      Constructors in java.nio.channels with parameters of type AsynchronousChannelProvider
      Constructor 描述
      AsynchronousChannelGroup​(AsynchronousChannelProvider provider)
      初始化此类的新实例。
      AsynchronousServerSocketChannel​(AsynchronousChannelProvider provider)
      初始化此类的新实例。
      AsynchronousSocketChannel​(AsynchronousChannelProvider provider)
      初始化此类的新实例。

    • Uses of AsynchronousChannelProvider in java.nio.channels.spi

      Methods in java.nio.channels.spi that return AsynchronousChannelProvider
      Modifier and Type 方法 描述
      static AsynchronousChannelProvider AsynchronousChannelProvider.provider​()
      返回用于Java虚拟机调用的系统级默认异步通道提供程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.channels.spi.SelectorProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.channels.spi.SelectorProvider

  • Packages that use SelectorProvider
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。

    • Uses of SelectorProvider in com.sun.nio.sctp

      Constructors in com.sun.nio.sctp with parameters of type SelectorProvider
      Constructor 描述
      SctpChannel​(SelectorProvider provider)
      初始化此类的新实例。
      SctpMultiChannel​(SelectorProvider provider)
      初始化此类的新实例。
      SctpServerChannel​(SelectorProvider provider)
      初始化此类的新实例。

    • Uses of SelectorProvider in java.nio.channels

      Methods in java.nio.channels that return SelectorProvider
      Modifier and Type 方法 描述
      abstract SelectorProvider SelectableChannel.provider​()
      返回创建此通道的提供程序。
      abstract SelectorProvider Selector.provider​()
      返回创建此通道的提供程序。
      Constructors in java.nio.channels with parameters of type SelectorProvider
      Constructor 描述
      DatagramChannel​(SelectorProvider provider)
      初始化此类的新实例。
      ServerSocketChannel​(SelectorProvider provider)
      初始化此类的新实例。
      SinkChannel​(SelectorProvider provider)
      初始化此类的新实例。
      SocketChannel​(SelectorProvider provider)
      初始化此类的新实例。
      SourceChannel​(SelectorProvider provider)
      构造一个这个类的新实例。

    • Uses of SelectorProvider in java.nio.channels.spi

      Methods in java.nio.channels.spi that return SelectorProvider
      Modifier and Type 方法 描述
      SelectorProvider AbstractSelectableChannel.provider​()
      返回创建此通道的提供程序。
      SelectorProvider AbstractSelector.provider​()
      返回创建此通道的提供程序。
      static SelectorProvider SelectorProvider.provider​()
      返回用于Java虚拟机的此调用的系统级默认选择器提供程序。
      Constructors in java.nio.channels.spi with parameters of type SelectorProvider
      Constructor 描述
      AbstractSelectableChannel​(SelectorProvider provider)
      初始化此类的新实例。
      AbstractSelector​(SelectorProvider provider)
      初始化此类的新实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


CharacterCodingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class CharacterCodingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.charset.CharacterCodingException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    MalformedInputException ， UnmappableCharacterException

    public class CharacterCodingException
extends IOException
    发生字符编码或解码错误时抛出的检查异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CharacterCodingException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CharacterCodingException

        public CharacterCodingException​()
        Constructs an instance of this class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Charset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class Charset

  • java.lang.Object
    • java.nio.charset.Charset
  • All Implemented Interfaces:
    Comparable<Charset>

    public abstract class Charset
extends Object
implements Comparable<Charset>
    16位Unicode code units和字节序列的序列之间的命名映射。 该类定义了用于创建解码器和编码器以及检索与字符集关联的各种名称的方法。 这个类的实例是不可变的。

    此类还定义了用于测试是否支持特定字符集的静态方法，用于通过名称查找字符集实例，以及构造包含当前Java虚拟机中可用的每个字符集的映射。 可以通过CharsetProvider类中定义的服务提供程序接口添加对新字符集的支持。

    此类中定义的所有方法都可以安全地被多个并发线程使用。

    字符串名称

    字符串由以下字符组成的字符串命名：

    • 大写字母'A'至'Z' （ '\u0041'至'\u005a' ），
    • 小写字母'a'至'z' （ '\u0061'至'\u007a' ），
    • 数字'0'至'9' （ '\u0030'至'\u0039' ），
    • 短划线字符'-' （ '\u002d' ， HYPHEN-MINUS ），
    • 加字'+' （ '\u002b' ， 加号 ），
    • 期间字符'.' （ '\u002e' ， FULL STOP ），
    • 冒号字符':' （ '\u003a' ， COLON ）和
    • 下划线字符'_' （ '\u005f' ， LOW LINE ）。
    字符集名称必须以字母或数字开头。 空字符串不是合法的字符集名称。 字符串名称不区分大小写; 也就是说，比较字符集名称时总是忽略大小写。 字符集名称通常遵循RFC 2278: IANA Charset Registration Procedures中记录的约定 。

    每个字符集都有一个规范名称 ，也可能有一个或多个别名 。 规范名称由本类的name方法返回。 常规名称通常是大写的。 字符集的别名由aliases方法返回。

    Some charsets have an historical name that is defined for compatibility with previous versions of the Java platform.字符集的历史名称是其规范名称或其别名之一。 历史名称由InputStreamReader和OutputStreamWriter类的getEncoding()方法返回。

    如果列出一个字符集IANA Charset Registry由Java平台的实现支持那么它的规范名称必须是注册表中列出的名字。 许多字符集在注册表中都有多个名称，在这种情况下，注册表将其中一个名称标识为MIME首选项 。 如果一个字符集有多个注册表名称，那么其规范名称必须是MIME首选名称，注册表中的其他名称必须是有效的别名。 如果支持的字符集未列在IANA注册表中，则其规范名称必须以字符串"X-"或"x-" 。

    IANA字符集注册表确实随时间而变化，因此特定字符集的规范名称和别名也可能随时间而变化。 为确保兼容性，建议不要从字符集中删除任何别名，如果字符集的规范名称被更改，那么其以前的规范名称将被做成一个别名。

    标准字符集

    Every implementation of the Java platform is required to support the following standard charsets.请参阅实现的发行文档，以查看是否支持其他字符集。 这种可选字符集的行为在实现之间可能不同。

    Description of standard charsets
    Charset | 描述
    US-ASCII | Seven-bit ASCII, a.k.a. ISO646-US, a.k.a. the Basic Latin block of the Unicode character set
    ISO-8859-1   | ISO Latin Alphabet No. 1, a.k.a. ISO-LATIN-1
    UTF-8 | Eight-bit UCS Transformation Format
    UTF-16BE | Sixteen-bit UCS Transformation Format, big-endian byte order
    UTF-16LE | Sixteen-bit UCS Transformation Format, little-endian byte order
    UTF-16 | Sixteen-bit UCS Transformation Format, byte order identified by an optional byte-order mark

    UTF-8字符集由RFC 2279指定; 其所依据的转换格式在ISO 10646-1的修正案2中规定，并在Unicode Standard中进行了说明 。

    UTF-16字符集由RFC 2781指定; 它们所依据的转换格式在ISO 10646-1的修正案1中规定，并在Unicode Standard中进行了描述 。

    UTF-16字符集使用十六位数量，因此对字节顺序敏感。 在这些编码中，流的字节顺序可以由Unicode字符'\uFEFF'表示的初始字节顺序标记 '\uFEFF' 。 字节顺序标记处理如下：

    • 解码时， UTF-16BE和UTF-16LE字符集将初始字节顺序标记解释为ZERO-WIDTH NON-BREAKING SPACE ; 当编码时，它们不会写入字节顺序标记。

    • 当解码时， UTF-16字符集解释输入流开始处的字节顺序标记，以指示流的字节顺序，如果没有字节顺序标记则默认为大字节序; 当编码时，它使用大字节字节顺序并写入大字节字节顺序标记。

    在任何情况下，在输入序列的第一个元素之后发生的字节顺序标记不被省略，因为使用相同的代码来表示ZERO-WIDTH NON-BREAKING SPACE 。

    Java虚拟机的每个实例都有一个默认字符集，它可能是也可能不是标准字符集之一。 默认字符集在虚拟机启动期间确定，通常取决于底层操作系统正在使用的区域设置和字符集。

    StandardCharsets类定义了每个标准字符集的常量。

    术语

    该类的名称取自RFC 2278中使用的术语 。 在该文档中， 字符集被定义为一个或多个编码字符集和字符编码方案的组合。 （这个定义很混乱;一些其他软件系统将charset定义为编码字符集的同义词。）

    编码字符集是一组抽象字符和一组整数之间的映射。 US-ASCII，ISO 8859-1，JIS X 0201和Unicode是编码字符集的示例。

    一些标准将字符集定义为简单的一组抽象字符，而没有相关的分配编号。 字母表是这样的字符集的示例。 然而， 字符集和编码字符集之间的微妙区别在实践中很少使用; 前者已经成为后者的缩写，包括Java API规范。

    字符编码方案是一个或多个编码字符集和一组八位字节（八位字节）序列之间的映射。 UTF-8，UTF-16，ISO 2022和EUC是字符编码方案的例子。 编码方案通常与特定编码字符集相关联; 例如，UTF-8仅用于编码Unicode。 然而，一些方案与多个编码字符集相关联; 例如，EUC可用于对各种亚洲编码字符集中的字符进行编码。

    当编码字符集专用于单个字符编码方案时，相应的字符集通常被命名为编码字符集; 否则字符集通常被命名为编码方案，并且可能是其支持的编码字符集的区域设置。 因此， US-ASCII既是编码字符集的名称，也是编码字符集的名称，而EUC-JP是编码EUC-JP的JIS X 0201，JIS X 0208和JIS X 0212编码字符集的字符集的名称。

    Java编程语言的本机字符编码是UTF-16。 因此，Java平台中的字符集定义了十六位UTF-16代码单元（即字符序列）和字节序列的序列之间的映射。

    从以下版本开始：
    1.4
    另请参见：
    CharsetDecoder ， CharsetEncoder ， CharsetProvider ， Character

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Charset​(String canonicalName, String[] aliases)
      使用给定的规范名称和别名集初始化新的字符集。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Set<String> aliases​()
      返回一个包含此字符集的别名的集合。
      static SortedMap<String,Charset> availableCharsets​()
      构造从规范字符集名称到字符集对象的排序映射。
      boolean canEncode​()
      告诉这个字符集是否支持编码。
      int compareTo​(Charset that)
      将此字符串与另一个字符集进行比较
      abstract boolean contains​(Charset cs)
      告知这个字符集是否包含给定的字符集。
      CharBuffer decode​(ByteBuffer bb)
      便利方法，将此字符集中的字节解码为Unicode字符。
      static Charset defaultCharset​()
      返回此Java虚拟机的默认字符集。
      String displayName​()
      返回此字符集的默认语言环境的可读名称。
      String displayName​(Locale locale)
      返回此字符集的给定语言环境的人类可读名称。
      ByteBuffer encode​(String str)
      在此字符集中将字符串编码为字节的便捷方法。
      ByteBuffer encode​(CharBuffer cb)
      在这个字符集中将Unicode字符编码为字节的便捷方法。
      boolean equals​(Object ob)
      告诉这个对象是否等于另一个。
      static Charset forName​(String charsetName)
      返回名为charset的charset对象。
      int hashCode​()
      计算此字符集的哈希码。
      boolean isRegistered​()
      告知这个字符集是否在 IANA Charset Registry中注册。
      static boolean isSupported​(String charsetName)
      告诉是否支持命名的字符集。
      String name​()
      返回此字符集的规范名称。
      abstract CharsetDecoder newDecoder​()
      为此字符集构造一个新的解码器。
      abstract CharsetEncoder newEncoder​()
      为此字符集构造一个新的编码器。
      String toString​()
      返回描述此字符集的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Charset

        protected Charset​(String canonicalName,
                  String[] aliases)
        使用给定的规范名称和别名集初始化新的字符集。
        参数
        canonicalName - 此字符集的规范名称
        aliases - 这个字符集的别名的数组，如果没有别名，则为null
        异常
        IllegalCharsetNameException - 如果规范名称或任何别名是非法的

    • 方法详细信息

      • isSupported

        public static boolean isSupported​(String charsetName)
        告诉是否支持命名的字符集。
        参数
        charsetName - 请求的字符集的名称; 可能是规范名称或别名
        结果
        true如果并且只有在当前Java虚拟机中支持命名的字符集才可用
        异常
        IllegalCharsetNameException - 如果给定的字符集名称是非法的
        IllegalArgumentException - 如果给定的 charsetName为空

      • forName

        public static Charset forName​(String charsetName)
        返回名为charset的charset对象。
        参数
        charsetName - 请求的字符集的名称; 可能是规范名称或别名
        结果
        命名字符集的字符集对象
        异常
        IllegalCharsetNameException - 如果给定的字符集名称是非法的
        IllegalArgumentException - 如果给定的 charsetName为空
        UnsupportedCharsetException - 如果在Java虚拟机的此实例中不支持命名的字符集

      • availableCharsets

        public static SortedMap<String,Charset> availableCharsets​()
        构造从规范字符集名称到字符集对象的排序映射。

        此方法返回的映射将为当前Java虚拟机中可用的每个字符集都有一个条目。 如果两个或多个支持的字符集具有相同的规范名称，则生成的映射将仅包含其中的一个; 它将包含哪一个没有指定。

        调用此方法以及后续使用生成的映射可能会导致耗时的磁盘或网络I / O操作发生。 为需要枚举所有可用字符集的应用程序提供此方法，例如允许用户选择字符集。 forName方法不使用此方法，而是采用有效的增量查找算法。

        如果新的字符集提供程序动态地可用于当前Java虚拟机，则此方法可能会在不同时间返回不同的结果。 在没有这种更改的情况下，通过此方法返回的字符集恰好是可以通过forName方法检索的字符集。

        结果
        从规范字符集名称到字符集对象的不可变的，不区分大小写的映射

      • defaultCharset

        public static Charset defaultCharset​()
        返回此Java虚拟机的默认字符集。

        默认字符集在虚拟机启动期间确定，通常取决于底层操作系统的区域设置和字符集。

        结果
        默认字符集的字符集对象
        从以下版本开始：
        1.5

      • name

        public final String name​()
        返回此字符集的规范名称。
        结果
        这个字符集的规范名称

      • aliases

        public final Set<String> aliases​()
        返回一个包含此字符集的别名的集合。
        结果
        这个字符集的不可替代的别名

      • displayName

        public String displayName​()
        返回此字符集的默认语言环境的可读名称。

        这个方法的默认实现只是返回这个charset的规范名称。 此类的具体子类可以覆盖此方法，以提供本地化显示名称。

        结果
        默认语言环境中此字符集的显示名称

      • isRegistered

        public final boolean isRegistered​()
        告知这个字符集是否在 IANA Charset Registry中注册。
        结果
        true如果并且只有这个字符集被其实现者知道才能在IANA注册

      • displayName

        public String displayName​(Locale locale)
        返回此字符集的给定语言环境的人类可读名称。

        这个方法的默认实现只是返回这个charset的规范名称。 此类的具体子类可以覆盖此方法，以提供本地化显示名称。

        参数
        locale - 要检索显示名称的区域设置
        结果
        此字符集在给定语言环境中的显示名称

      • contains

        public abstract boolean contains​(Charset cs)
        告知这个字符集是否包含给定的字符集。

        据说C字符集包含一个字符集D，如果只有在D中表示的每个字符也可以在C中表示。 如果这种关系成立，那么可以保证在D中编码的每个字符串也可以在C中进行编码，而不进行任何替换。

        该C包含D并不意味着通过特定字节序列在C中表示的每个字符在D中以相同的字节序列表示，尽管有时是这种情况。

        每个字符集都包含自身。

        该方法计算遏制关系的近似值：如果返回true则该字符集将包含给定的字符集; 但是，如果它返回false ，则不一定是这个字符集中不包含给定的字符集。

        参数
        cs - 给定的字符集
        结果
        true如果给定的字符集包含在此字符集中

      • newDecoder

        public abstract CharsetDecoder newDecoder​()
        为此字符集构造一个新的解码器。
        结果
        这个字符集的新解码器

      • newEncoder

        public abstract CharsetEncoder newEncoder​()
        为此字符集构造一个新的编码器。
        结果
        用于此字符集的新编码器
        异常
        UnsupportedOperationException - 如果此字符集不支持编码

      • canEncode

        public boolean canEncode​()
        告诉这个字符集是否支持编码。

        几乎所有的字符集都支持编码。 主要的例外是专用自动检测字符集，其解码器可以通过检查输入字节序列来确定几种可能的编码方案中的哪一种。 这样的字符集不支持编码，因为无法确定在输出中应使用哪个编码。 这种字符集的实现应该覆盖此方法以返回false 。

        结果
        true如果，并且只有这个字符集支持编码

      • decode

        public final CharBuffer decode​(ByteBuffer bb)
        便利方法，将此字符集中的字节解码为Unicode字符。

        在字符集cs调用此方法返回与表达式相同的结果

          cs.newDecoder()
       .onMalformedInput(CodingErrorAction.REPLACE)
       .onUnmappableCharacter(CodingErrorAction.REPLACE)
       .decode(bb);
        除了它可能更有效，因为它可以在连续调用之间缓存解码器。

        此方法总是用此字符集的默认替换字节数组替换格式错误的输入和不可映射字符序列。 为了检测这样的序列，直接使用CharsetDecoder.decode(java.nio.ByteBuffer)方法。

        参数
        bb - 要解码的字节缓冲区
        结果
        包含解码字符的char缓冲区

      • encode

        public final ByteBuffer encode​(CharBuffer cb)
        在这个字符集中将Unicode字符编码为字节的便捷方法。

        在字符集cs调用此方法返回与表达式相同的结果

          cs.newEncoder()
       .onMalformedInput(CodingErrorAction.REPLACE)
       .onUnmappableCharacter(CodingErrorAction.REPLACE)
       .encode(bb);
        除了它可能更有效率，因为它可以在连续调用之间缓存编码器。

        此方法总是用此字符集的默认替换字符串替换格式错误的输入和不可映射字符序列。 为了检测这样的序列，直接使用CharsetEncoder.encode(java.nio.CharBuffer)方法。

        参数
        cb - 要编码的char缓冲区
        结果
        包含编码字符的字节缓冲区

      • encode

        public final ByteBuffer encode​(String str)
        在此字符集中将字符串编码为字节的便捷方法。

        在字符集cs调用此方法返回与表达式相同的结果

          cs.encode(CharBuffer.wrap(s));
        参数
        str - 要编码的字符串
        结果
        包含编码字符的字节缓冲区

      • compareTo

        public final int compareTo​(Charset that)
        将此字符串与另一个字符集进行比较

        字符串按其规范名称排序，不考虑案例。

        Specified by:
        compareTo在接口 Comparable<Charset>
        参数
        that - 要比较此字符集的字符集
        结果
        负整数，零或正整数，因为此字符集小于，等于或大于指定的字符集

      • hashCode

        public final int hashCode​()
        计算此字符集的哈希码。
        重写：
        hashCode在 Object
        结果
        一个整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public final boolean equals​(Object ob)
        告诉这个对象是否等于另一个。

        两个字符串是相等的，只有当他们有相同的规范名称。 字符集从不等于任何其他类型的对象。

        重写：
        equals在 Object
        参数
        ob - 与之比较的参考对象。
        结果
        true如果，并且只有当这个字符集等于给定的对象
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public final String toString​()
        返回描述此字符集的字符串。
        重写：
        toString在 Object
        结果
        A string describing this charset
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CharsetDecoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class CharsetDecoder

  • java.lang.Object
    • java.nio.charset.CharsetDecoder

  • public abstract class CharsetDecoder
extends Object
    可以将特定字符集中的字节序列转换为十六位Unicode字符序列的引擎。

    输入字节序列被提供在一个字节缓冲器或一系列这样的缓冲器中。 输出字符序列被写入字符缓冲区或一系列这样的缓冲区。 应通过下列方法调用顺序来始终使用解码器，以下称为解码操作 ：

    1. 通过reset方法复位解码器，除非以前没有使用过;

    2. 调用decode方法零次或更多次，只要附加输入可用，通过false为endOfInput参数填充输入缓冲区并在调用之间刷新输出缓冲区;

    3. 最后一次调用decode方法，通过true为endOfInput参数; 接着

    4. 调用flush方法，使解码器可以将任何内部状态刷新到输出缓冲区。

    decode方法的每次调用都将从输入缓冲区解码尽可能多的字节，将生成的字符写入输出缓冲区。 当需要更多输入时，输出缓冲区中没有足够的空间或发生解码错误时， decode方法返回。 在每种情况下，返回一个CoderResult对象来描述终止的原因。 调用者可以检查此对象并填写输入缓冲区，刷新输出缓冲区，或尝试从解码错误中恢复，并重试。

    有两种一般类型的解码错误。 如果输入字节序列对于该字符集不合法，那么输入被认为是格式错误的 。 如果输入字节序列是合法的，但不能映射到有效的Unicode字符，则遇到不可映射的字符 。

    如何处理解码错误取决于为该类型的错误所请求的操作，这由CodingErrorAction类的实例描述。 可能的错误动作是通过CoderResult错误的输入， report的错误给调用者通过返回的CoderResult对象，或replace的错误输入与替换字符串的当前值。 替换的初始值为"\uFFFD" ; 其值可以通过replaceWith方法更改。

    错误输入和不可映射字符错误的默认操作为report 。 畸形输入错误动作可以通过onMalformedInput方法更改; 可以通过onUnmappableCharacter方法更改不可映射的字符动作。

    该类旨在处理解码过程的许多细节，包括执行错误操作。 特定字符集的解码器是该类的具体子类，只需要实现抽象的decodeLoop方法，该方法封装了基本的解码循环。 维护内部状态的子类应另外覆盖implFlush和implReset方法。

    此类的实例不能安全地被多个并发线程使用。

    从以下版本开始：
    1.4
    另请参见：
    ByteBuffer ， CharBuffer ， Charset ， CharsetEncoder

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CharsetDecoder​(Charset cs, float averageCharsPerByte, float maxCharsPerByte)
      初始化一个新的解码器。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      float averageCharsPerByte​()
      返回每个字节输入的平均字符数。
      Charset charset​()
      返回创建此解码器的字符集。
      CharBuffer decode​(ByteBuffer in)
      将单个输入字节缓冲器的剩余内容解码为新分配的字符缓冲区的方便方法。
      CoderResult decode​(ByteBuffer in, CharBuffer out, boolean endOfInput)
      从给定的输入缓冲区解码尽可能多的字节，将结果写入给定的输出缓冲区。
      protected abstract CoderResult decodeLoop​(ByteBuffer in, CharBuffer out)
      将一个或多个字节解码为一个或多个字符。
      Charset detectedCharset​()
      检索该解码器检测到的字符集 （可选操作） 。
      CoderResult flush​(CharBuffer out)
      刷新此解码器。
      protected CoderResult implFlush​(CharBuffer out)
      刷新此解码器。
      protected void implOnMalformedInput​(CodingErrorAction newAction)
      报告对此解码器的格式错误的输入操作的更改。
      protected void implOnUnmappableCharacter​(CodingErrorAction newAction)
      报告对此解码器的不可映射角色操作的更改。
      protected void implReplaceWith​(String newReplacement)
      报告对该解码器的替换值的更改。
      protected void implReset​()
      重置此解码器，清除特定于字符集的内部状态。
      boolean isAutoDetecting​()
      告知该解码器是否实现自动检测字符集。
      boolean isCharsetDetected​()
      告知该解码器是否还检测到字符集 （可选操作） 。
      CodingErrorAction malformedInputAction​()
      返回此解码器当前的格式输入错误的操作。
      float maxCharsPerByte​()
      返回每个字节输入的最大字符数。
      CharsetDecoder onMalformedInput​(CodingErrorAction newAction)
      更改此解码器的错误格式输入错误的操作。
      CharsetDecoder onUnmappableCharacter​(CodingErrorAction newAction)
      更改此解码器的操作为不可映射的字符错误。
      String replacement​()
      返回此解码器的替换值。
      CharsetDecoder replaceWith​(String newReplacement)
      更改此解码器的替换值。
      CharsetDecoder reset​()
      复位该解码器，清除任何内部状态。
      CodingErrorAction unmappableCharacterAction​()
      返回此解码器当前的不可映射字符错误的操作。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CharsetDecoder

        protected CharsetDecoder​(Charset cs,
                         float averageCharsPerByte,
                         float maxCharsPerByte)
        初始化一个新的解码器。 新的解码器将具有给定的每字节字符值，并且其替换将是字符串"\uFFFD" 。
        参数
        cs - 创建此解码器的字符集
        averageCharsPerByte - 一个正的浮点值，表示将为每个输入字节产生的预期字符数
        maxCharsPerByte - 表示每个输入字节将产生的最大字符数的正浮点数
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

    • 方法详细信息

      • charset

        public final Charset charset​()
        返回创建此解码器的字符集。
        结果
        这个解码器的字符集

      • replacement

        public final String replacement​()
        返回此解码器的替换值。
        结果
        这个解码器的当前替换，从来不是 null ，并且不会是空的

      • replaceWith

        public final CharsetDecoder replaceWith​(String newReplacement)
        更改此解码器的替换值。

        此方法调用implReplaceWith方法后，通过新的替换，检查新的替换是否可以接受。

        参数
        newReplacement - 新的替换; 不得为null ，必须具有非零长度，并且不得超过maxCharsPerByte方法返回的值
        结果
        这个解码器
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

      • implReplaceWith

        protected void implReplaceWith​(String newReplacement)
        报告对该解码器的替换值的更改。

        这种方法的默认实现什么都不做。 这个方法应该被需要通知更换更改的解码器所覆盖。

        参数
        newReplacement - 替换值

      • malformedInputAction

        public CodingErrorAction malformedInputAction​()
        返回此解码器当前的格式输入错误的操作。
        结果
        目前的格式错误的输入动作，从不 null

      • onMalformedInput

        public final CharsetDecoder onMalformedInput​(CodingErrorAction newAction)
        更改此解码器的错误格式输入错误的操作。

        此方法调用implOnMalformedInput方法，传递新操作。

        参数
        newAction - 新动作 不能是null
        结果
        这个解码器
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

      • implOnMalformedInput

        protected void implOnMalformedInput​(CodingErrorAction newAction)
        报告对此解码器的格式错误的输入操作的更改。

        这种方法的默认实现什么都不做。 应该通过需要通知变更输入错误的操作的解码器覆盖此方法。

        参数
        newAction - 新的行动

      • unmappableCharacterAction

        public CodingErrorAction unmappableCharacterAction​()
        返回此解码器当前的不可映射字符错误的操作。
        结果
        当前不可映射的角色动作，从不 null

      • onUnmappableCharacter

        public final CharsetDecoder onUnmappableCharacter​(CodingErrorAction newAction)
        更改此解码器的操作为不可映射的字符错误。

        此方法调用implOnUnmappableCharacter方法，传递新操作。

        参数
        newAction - 新动作; 不能是null
        结果
        这个解码器
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

      • implOnUnmappableCharacter

        protected void implOnUnmappableCharacter​(CodingErrorAction newAction)
        报告对此解码器的不可映射角色操作的更改。

        这种方法的默认实现什么都不做。 应该通过需要通知不可映射角色动作更改的解码器覆盖此方法。

        参数
        newAction - 新的动作

      • averageCharsPerByte

        public final float averageCharsPerByte​()
        返回每个字节输入的平均字符数。 该启发式值可用于估计给定输入序列所需的输出缓冲区的大小。
        结果
        每字节输入的平均字符数

      • maxCharsPerByte

        public final float maxCharsPerByte​()
        返回每个字节输入的最大字符数。 该值可用于计算给定输入序列所需的输出缓冲区的最坏情况大小。
        结果
        每个字节输入的最大字符数

      • decode

        public final CoderResult decode​(ByteBuffer in,
                                CharBuffer out,
                                boolean endOfInput)
        从给定的输入缓冲区解码尽可能多的字节，将结果写入给定的输出缓冲区。

        缓冲区从其当前位置开始读取并写入。 将读取最多in.remaining()个字节，最多写入out.remaining()个字符。 缓冲区的位置将被提前以反映读取的字节和写入的字符，但是它们的标记和限制将不被修改。

        除了从输入缓冲区读取字节并将字符写入输出缓冲区之外，该方法返回一个CoderResult对象来描述其终止原因：

        • CoderResult.UNDERFLOW表示尽可能多的输入缓冲器已被解码。 如果没有进一步的输入，那么调用者可以进入decoding operation的下一步 。 否则，此方法应再次调用再输入。

        • CoderResult.OVERFLOW表示输出缓冲区中没有足够的空间来解码任何更多的字节。 应该使用一个输出缓冲区再次调用此方法，该缓冲区具有remaining个字符。 这通常通过从输出缓冲器中排出任何解码的字符来完成。

        • A malformed-input结果表明已检测到格式错误的输入错误。 格式错误的字节从输入缓冲区（可能递增）的位置开始; 可以通过调用结果对象的length方法来确定格式错误的字节数。 这种情况只适用于当malformed action此解码器为CodingErrorAction.REPORT ; 否则，将根据要求忽略或替换格式错误的输入。

        • 一个unmappable-character结果表示已检测到不可映射的字符错误。 解码不可映射字符的字节从输入缓冲区（可能递增）的位置开始; 可以通过调用结果对象的length方法来确定这样的字节的数量。 这种情况只适用于当unmappable action此解码器为CodingErrorAction.REPORT ; 否则不可映射的字符将被忽略或替换，根据要求。

        在任何情况下，如果要在相同的解码操作中重新启用此方法，则应注意保留输入缓冲区中剩余的任何字节，以便它们可用于下一次调用。

        endOfInput参数建议这种方法，以确定调用者是否可以提供超出给定输入缓冲区中的输入。 如果有可能提供额外的输入，那么调用者应通过此参数的false ; 如果没有提供进一步输入的可能性，则调用者应通过true 。 这并不是错误的，实际上很常见的是在一次调用中传递false ，后来发现没有其他输入实际上可用。 然而，至关重要的是，在调用序列中最终调用此方法总是通过true以便任何剩余的未解码的输入将被视为格式错误。

        该方法通过调用decodeLoop方法，解释其结果，处理错误条件以及根据需要重新启动它来工作。

        参数
        in - 输入字节缓冲区
        out - 输出字符缓冲区
        endOfInput - true如果且仅当调用者不能提供超出给定缓冲区中的额外输入字节
        结果
        描述终止原因的编码器结果对象
        异常
        IllegalStateException -如果解码操作已在进行中和之前的步骤是一个调用既不的 reset方法，也没有这种方法具有的值的 false为 endOfInput参数，也不该方法具有的值的 true为 endOfInput参数而是指示不完整的解码操作的返回值
        CoderMalfunctionError - 如果对decodeLoop方法的调用抛出了意外的异常

      • flush

        public final CoderResult flush​(CharBuffer out)
        刷新此解码器。

        一些解码器保持内部状态，并且可能需要在读取总体输入序列后将一些最终字符写入输出缓冲区。

        任何额外的输出从其当前位置开始写入输出缓冲区。 最多写入out.remaining()个字符。 缓冲区的位置将适当地提前，但其标记和限制将不会被修改。

        如果此方法成功完成，则返回CoderResult.UNDERFLOW 。 如果输出缓冲区的空间不足，则返回CoderResult.OVERFLOW 。 如果发生这种情况，则必须再次调用此方法，输出缓冲区有更多的空间，以便完成当前的decoding operation 。

        如果此解码器已被刷新，则调用此方法将无效。

        此方法调用implFlush方法来执行实际的刷新操作。

        参数
        out - 输出字符缓冲区
        结果
        编码器结果对象， CoderResult.UNDERFLOW或 CoderResult.OVERFLOW
        异常
        IllegalStateException -如果当前解码操作的前一步骤既不是的调用 flush方法也不三个参数的 decode具有的值的方法 true为 endOfInput参数

      • implFlush

        protected CoderResult implFlush​(CharBuffer out)
        刷新此解码器。

        这个方法的默认实现什么都不做，总是返回CoderResult.UNDERFLOW 。 一旦读取了整个输入序列，这个方法就应该被解码器所覆盖。

        参数
        out - 输出字符缓冲区
        结果
        编码结果对象， CoderResult.UNDERFLOW或 CoderResult.OVERFLOW

      • reset

        public final CharsetDecoder reset​()
        复位该解码器，清除任何内部状态。

        此方法重置与字符集无关的状态，并且还调用implReset方法以执行任何特定于字符集的重置操作。

        结果
        这个解码器

      • implReset

        protected void implReset​()
        重置此解码器，清除特定于字符集的内部状态。

        这种方法的默认实现什么都不做。 该方法应由维护内部状态的解码器覆盖。

      • decodeLoop

        protected abstract CoderResult decodeLoop​(ByteBuffer in,
                                          CharBuffer out)
        将一个或多个字节解码为一个或多个字符。

        该方法封装了基本的解码循环，解码尽可能多的字节，直到其用完输出，在输出缓冲区中用完，或遇到解码错误。 该方法由decode方法调用，它处理结果解释和错误恢复。

        缓冲区从其当前位置开始读取并写入。 将读取最多in.remaining()个字节，最多写入out.remaining()个字符。 缓冲区的位置将被提前以反映读取的字节和写入的字符，但是它们的标记和限制将不被修改。

        该方法返回一个CoderResult对象来描述其终止原因，方式与decode方法相同。 该方法的大多数实现将通过返回适当的结果对象来解决decode方法来处理解码错误。 优化的实现可能会检查相关的错误操作，并实现该操作本身。

        该方法的实现可以通过返回CoderResult.UNDERFLOW来执行任意的前瞻，直到它接收足够的输入。

        参数
        in - 输入字节缓冲区
        out - 输出字符缓冲区
        结果
        描述终止原因的编码器结果对象

      • decode

        public final CharBuffer decode​(ByteBuffer in)
                        throws CharacterCodingException
        将单个输入字节缓冲器的剩余内容解码为新分配的字符缓冲区的方便方法。

        该方法实现整个decoding operation ; 也就是说，它复位该解码器，然后解码给定字节缓冲区中的字节，最后它刷新该解码器。 因此，如果解码操作已经进行，则不应该调用此方法。

        参数
        in - 输入字节缓冲区
        结果
        包含解码操作结果的新分配字符缓冲器。 缓冲区的位置将为零，其限制将遵循写入的最后一个字符。
        异常
        IllegalStateException - 如果解码操作已经进行中
        MalformedInputException - 如果从输入缓冲区的当前位置开始的字节序列对于此字符集不合法，并且当前格式错误的输入操作是 CodingErrorAction.REPORT
        UnmappableCharacterException - 如果从输入缓冲区当前位置开始的字节序列不能映射到等效字符序列，并且当前不可 映像字符操作是 CodingErrorAction.REPORT
        CharacterCodingException

      • isAutoDetecting

        public boolean isAutoDetecting​()
        告知该解码器是否实现自动检测字符集。

        此方法的默认实现始终返回false ; 它应该被自动检测解码器覆盖，以返回true 。

        结果
        true如果并且仅当该解码器实现自动检测字符集

      • isCharsetDetected

        public boolean isCharsetDetected​()
        告知该解码器是否还检测到字符集（可选操作） 。

        如果该解码器在解码操作期间在单个点实现自动检测字符集，则该方法可以开始返回true以指示在输入字节序列中检测到特定字符集。 一旦发生这种情况，可以调用detectedCharset方法来检索检测到的字符集。

        该方法返回false并不意味着没有字节尚未解码。 一些自动检测解码器能够解码输入字节序列的一些或甚至全部，而不固定在特定字符集上。

        该方法的默认实现总是抛出一个UnsupportedOperationException ; 输入字符集确定后，自动检测解码器将被覆盖，以返回true 。

        结果
        true如果，且仅当该解码器检测到特定的字符集
        异常
        UnsupportedOperationException - 如果该解码器不实现自动检测字符集

      • detectedCharset

        public Charset detectedCharset​()
        检索该解码器检测到的字符集（可选操作） 。

        如果该解码器实现了自动检测字符集，则该方法一旦检测到该字符集即返回实际的字符集。 此后，该方法在当前解码操作的持续时间内返回相同的值。 如果还没有足够的输入字节被读取来确定实际的字符集，那么这个方法会抛出一个IllegalStateException 。

        这种方法的默认实现总是抛出一个UnsupportedOperationException ; 应通过自动检测解码器来覆盖，以返回适当的值。

        结果
        此自动检测解码器检测到的字符集，如果字符集尚未确定， null
        异常
        IllegalStateException - 如果读取不足够的字节来确定字符集
        UnsupportedOperationException - 如果此解码器不实现自动检测字符集
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CharsetEncoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class CharsetEncoder

  • java.lang.Object
    • java.nio.charset.CharsetEncoder

  • public abstract class CharsetEncoder
extends Object
    一种引擎，可以将一系列十六位Unicode字符转换为特定字符集中的字节序列。

    输入字符序列被提供在字符缓冲器或一系列这样的缓冲器中。 输出字节序列被写入一个字节缓冲区或一系列这样的缓冲区。 通过进行以下的方法调用顺序，以下简称为编码操作 ，应始终使用编码器：

    1. 通过reset方法复位编码器，除非以前没有使用过;

    2. 调用encode方法零次或更多次，只要附加输入可用，通过false为endOfInput参数填充输入缓冲区并在调用之间刷新输出缓冲区;

    3. 最后一次调用encode方法，通过true查询endOfInput参数; 接着

    4. 调用flush方法，使编码器可以将任何内部状态刷新到输出缓冲区。

    encode方法的每次调用都将从输入缓冲区编码尽可能多的字符，将生成的字节写入输出缓冲区。 当需要更多输入时，当输出缓冲区中没有足够的空间或发生编码错误时， encode方法返回。 在每种情况下，返回一个CoderResult对象来描述终止的原因。 调用者可以检查此对象并填写输入缓冲区，刷新输出缓冲区，或尝试从编码错误中恢复，并重试。

    有两种一般类型的编码错误。 如果输入字符序列不是合法的16位Unicode序列，那么输入被认为是格式错误的 。 如果输入字符序列是合法的，但不能映射到给定字符集中的有效字节序列，则会遇到不可映射的字符 。

    如何处理编码错误取决于为该类型的错误所请求的操作，这由CodingErrorAction类的实例描述。 可能的错误动作是将错误的输入， report的错误输入， report通过返回的CoderResult对象给调用者的错误，或replace错误的输入与替换字节数组的当前值。 最初将替换设置为编码器的默认替换，通常（但不总是）初始值为{ (byte)'?' } ; 其值可以通过replaceWith方法更改。

    错误输入和不可映射字符错误的默认操作为report 。 畸形输入错误动作可以通过onMalformedInput方法更改; 可以通过onUnmappableCharacter方法更改不可映射的字符动作。

    该类旨在处理编码过程的许多细节，包括执行错误操作。 特定字符集的编码器是该类的具体子类，仅需实现封装基本编码循环的抽象encodeLoop方法。 另外，维护内部状态的子类应该覆盖implFlush和implReset方法。

    此类的实例不能安全地被多个并发线程使用。

    从以下版本开始：
    1.4
    另请参见：
    ByteBuffer ， CharBuffer ， Charset ， CharsetDecoder

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CharsetEncoder​(Charset cs, float averageBytesPerChar, float maxBytesPerChar)
      初始化新的编码器。
      protected CharsetEncoder​(Charset cs, float averageBytesPerChar, float maxBytesPerChar, byte[] replacement)
      初始化新的编码器。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      float averageBytesPerChar​()
      返回为每个输入字符产生的平均字节数。
      boolean canEncode​(char c)
      告知编码器是否可以对给定的字符进行编码。
      boolean canEncode​(CharSequence cs)
      告知编码器是否可以对给定的字符序列进行编码。
      Charset charset​()
      返回创建此编码器的字符集。
      ByteBuffer encode​(CharBuffer in)
      便捷方法，将单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区中。
      CoderResult encode​(CharBuffer in, ByteBuffer out, boolean endOfInput)
      从给定的输入缓冲区编码尽可能多的字符，将结果写入给定的输出缓冲区。
      protected abstract CoderResult encodeLoop​(CharBuffer in, ByteBuffer out)
      将一个或多个字符编码为一个或多个字节。
      CoderResult flush​(ByteBuffer out)
      刷新编码器。
      protected CoderResult implFlush​(ByteBuffer out)
      刷新编码器。
      protected void implOnMalformedInput​(CodingErrorAction newAction)
      报告对该编码器的格式错误的输入操作的更改。
      protected void implOnUnmappableCharacter​(CodingErrorAction newAction)
      报告此编码器的不可映射角色动作的更改。
      protected void implReplaceWith​(byte[] newReplacement)
      报告对该编码器的替换值的更改。
      protected void implReset​()
      复位该编码器，清除任何字符集特定的内部状态。
      boolean isLegalReplacement​(byte[] repl)
      告知给定的字节数组是否是该编码器的合法替换值。
      CodingErrorAction malformedInputAction​()
      返回此编码器当前针对格式错误输入错误的操作。
      float maxBytesPerChar​()
      返回为每个输入字符产生的最大字节数。
      CharsetEncoder onMalformedInput​(CodingErrorAction newAction)
      更改编码器对格式错误输入错误的操作。
      CharsetEncoder onUnmappableCharacter​(CodingErrorAction newAction)
      更改此编码器对不可映射字符错误的操作。
      byte[] replacement​()
      返回此编码器的替换值。
      CharsetEncoder replaceWith​(byte[] newReplacement)
      更改此编码器的替换值。
      CharsetEncoder reset​()
      复位该编码器，清除任何内部状态。
      CodingErrorAction unmappableCharacterAction​()
      返回此编码器当前对不可映射字符错误的操作。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CharsetEncoder

        protected CharsetEncoder​(Charset cs,
                         float averageBytesPerChar,
                         float maxBytesPerChar,
                         byte[] replacement)
        初始化新的编码器。 新的编码器将具有给定的每字节字节和替换值。
        参数
        cs - 创建此编码器的字符集
        averageBytesPerChar - 一个正值，表示将为每个输入字符产生的预期字节数
        maxBytesPerChar - 一个正值，表示将为每个输入字符产生的最大字节数
        replacement - 初次更换; 一定不能是null ，必须有非零长度，不能超过maxBytesPerChar，而且必须是legal
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

      • CharsetEncoder

        protected CharsetEncoder​(Charset cs,
                         float averageBytesPerChar,
                         float maxBytesPerChar)
        初始化新的编码器。 新的编码器将具有给定的每字节字节值，并且其替换将是字节阵列{ (byte)'?' } 。
        参数
        cs - 创建此编码器的字符集
        averageBytesPerChar - 一个正值，表示将为每个输入字符产生的预期字节数
        maxBytesPerChar - 一个正值，表示将为每个输入字符产生的最大字节数
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

    • 方法详细信息

      • charset

        public final Charset charset​()
        返回创建此编码器的字符集。
        结果
        这个编码器的字符集

      • replacement

        public final byte[] replacement​()
        返回此编码器的替换值。
        结果
        这个编码器当前的替换，从来不是 null ，并且不会是空的

      • replaceWith

        public final CharsetEncoder replaceWith​(byte[] newReplacement)
        更改此编码器的替换值。

        此方法调用implReplaceWith方法，通过新的替换，检查新的替换是否可以接受。

        参数
        newReplacement - 新的替换; 不能是null ，必须具有非零长度，不得超过maxBytesPerChar方法返回的值，并且必须为legal
        结果
        这个编码器
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

      • implReplaceWith

        protected void implReplaceWith​(byte[] newReplacement)
        报告对该编码器的替换值的更改。

        这种方法的默认实现什么都不做。 该方法应由需要通知更换更改的编码器覆盖。

        参数
        newReplacement - 替换值

      • isLegalReplacement

        public boolean isLegalReplacement​(byte[] repl)
        告知给定的字节数组是否是该编码器的合法替换值。

        如果并且只有在编码器的字符集中是一个合法的字节序列，则替换是合法的; 也就是说，必须可以将替换解码为一个或多个16位Unicode字符。

        该方法的默认实现不是很有效; 通常应该覆盖以提高性能。

        参数
        repl - 要测试的字节数组
        结果
        true如果并且只有给定的字节数组是该编码器的合法替换值

      • malformedInputAction

        public CodingErrorAction malformedInputAction​()
        返回此编码器当前针对格式错误输入错误的操作。
        结果
        目前的格式错误的输入动作，从不 null

      • onMalformedInput

        public final CharsetEncoder onMalformedInput​(CodingErrorAction newAction)
        更改编码器对格式错误输入错误的操作。

        此方法调用implOnMalformedInput方法，传递新操作。

        参数
        newAction - 新动作 不能是null
        结果
        这个编码器
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

      • implOnMalformedInput

        protected void implOnMalformedInput​(CodingErrorAction newAction)
        报告对该编码器的格式错误的输入操作的更改。

        这种方法的默认实现什么都不做。 应该通过需要通知错误输入操作更改的编码器来覆盖此方法。

        参数
        newAction - 新的动作

      • unmappableCharacterAction

        public CodingErrorAction unmappableCharacterAction​()
        返回此编码器当前对不可映射字符错误的操作。
        结果
        当前的不可映射角色动作，从不 null

      • onUnmappableCharacter

        public final CharsetEncoder onUnmappableCharacter​(CodingErrorAction newAction)
        更改此编码器对不可映射字符错误的操作。

        此方法调用implOnUnmappableCharacter方法，传递新操作。

        参数
        newAction - 新动作; 不能是null
        结果
        这个编码器
        异常
        IllegalArgumentException - 如果参数的前提条件不成立

      • implOnUnmappableCharacter

        protected void implOnUnmappableCharacter​(CodingErrorAction newAction)
        报告此编码器的不可映射角色动作的更改。

        这种方法的默认实现什么都不做。 该方法应该被需要通知不可映射角色动作的更改的编码器覆盖。

        参数
        newAction - 新的动作

      • averageBytesPerChar

        public final float averageBytesPerChar​()
        返回为每个输入字符产生的平均字节数。 该启发式值可用于估计给定输入序列所需的输出缓冲区的大小。
        结果
        每个字符输入的平均字节数

      • maxBytesPerChar

        public final float maxBytesPerChar​()
        返回为每个输入字符产生的最大字节数。 该值可用于计算给定输入序列所需的输出缓冲区的最坏情况大小。
        结果
        每个字符输入的最大字节数

      • encode

        public final CoderResult encode​(CharBuffer in,
                                ByteBuffer out,
                                boolean endOfInput)
        从给定的输入缓冲区编码尽可能多的字符，将结果写入给定的输出缓冲区。

        缓冲区从其当前位置开始读取并写入。 在大多数in.remaining()个字符将被读取和最out.remaining()个字节将被写入。 缓冲区的位置将被提前以反映读取的字符和写入的字节，但是它们的标记和限制将不被修改。

        除了从输入缓冲区读取字符并将字节写入输出缓冲区之外，此方法返回一个CoderResult对象来描述其终止原因：

        • CoderResult.UNDERFLOW表示尽可能多的输入缓冲器已被编码。 如果没有进一步的输入，那么调用者可以进入encoding operation的下一步 。 否则，此方法应再次调用再输入。

        • CoderResult.OVERFLOW指示输出缓冲区中没有足够的空间来编码任何更多的字符。 应该再次使用具有remaining字节的输出缓冲区来调用此方法。 这通常通过从输出缓冲器中排出任何编码字节来完成。

        • A malformed-input结果表示已检测到格式错误的输入错误。 格式错误的字符从输入缓冲区（可能增加）的位置开始; 可以通过调用结果对象的length方法来确定格式错误的字符数。 这种情况只适用于当malformed action这个编码器是CodingErrorAction.REPORT ; 否则，将根据要求忽略或替换格式错误的输入。

        • 一个unmappable-character结果表示已检测到不匹配的字符错误。 编码不可映射字符的字符从输入缓冲区（可能增加）的位置开始; 可以通过调用结果对象的length方法来确定这样的字符的数量。 这种情况只适用于当unmappable action这个编码器是CodingErrorAction.REPORT ; 否则不可映射的字符将被忽略或替换，根据要求。

        在任何情况下，如果要在相同的编码操作中重新启用此方法，则应注意保留输入缓冲区中剩余的任何字符，以便它们可用于下一个调用。

        endOfInput参数建议您使用此方法来确定调用者是否可以提供超出给定输入缓冲区中的输入值。 如果有可能提供额外的输入，那么调用者应该通过此参数的false ; 如果不可能提供进一步的输入，则调用者应通过true 。 这并不是错误的，事实上它是很常见的，通过false在一个调用，后来发现没有进一步的输入实际上是可用的。 然而，至关重要的是，以一系列调用方式最终调用此方法总是通过true以便任何剩余的未编码的输入将被视为格式错误。

        该方法通过调用encodeLoop方法，解释其结果，处理错误条件以及根据需要重新启动它。

        参数
        in - 输入字符缓冲区
        out - 输出字节缓冲区
        endOfInput - true如果并且仅当调用者不能提供超出给定缓冲区中的额外输入字符
        结果
        描述终止原因的编码器结果对象
        异常
        IllegalStateException -如果编码操作已在进行中和之前的步骤是一个调用既不的 reset方法，也没有这种方法具有的值的 false为 endOfInput参数，也不该方法具有的值的 true为 endOfInput参数而是返回值，表示不完整的编码操作
        CoderMalfunctionError - 如果对encodeLoop方法的调用抛出了一个意外的异常

      • flush

        public final CoderResult flush​(ByteBuffer out)
        刷新编码器。

        一些编码器保持内部状态，并且可能需要在读取整个输入序列后将一些最后的字节写入输出缓冲区。

        任何额外的输出从其当前位置开始写入输出缓冲区。 将写入最多out.remaining()个字节。 缓冲区的位置将适当地提前，但其标记和限制将不会被修改。

        如果此方法成功完成，则返回CoderResult.UNDERFLOW 。 如果输出缓冲区空间不足，则返回CoderResult.OVERFLOW 。 如果发生这种情况，则必须再次调用此方法，输出缓冲区有更多的空间，以完成当前的encoding operation 。

        如果此编码器已被刷新，则调用此方法将无效。

        此方法调用implFlush方法来执行实际的刷新操作。

        参数
        out - 输出字节缓冲区
        结果
        编码结果对象， CoderResult.UNDERFLOW或 CoderResult.OVERFLOW
        异常
        IllegalStateException -如果当前编码操作的前一步骤既不是的调用 flush方法也不三个参数的 encode具有的值的方法 true为 endOfInput参数

      • implFlush

        protected CoderResult implFlush​(ByteBuffer out)
        刷新编码器。

        这个方法的默认实现什么都不做，总是返回CoderResult.UNDERFLOW 。 一旦整个输入序列被读取，编码器就可能需要将最后一个字节写入输出缓冲区来覆盖此方法。

        参数
        out - 输出字节缓冲区
        结果
        编码结果对象， CoderResult.UNDERFLOW或 CoderResult.OVERFLOW

      • reset

        public final CharsetEncoder reset​()
        复位该编码器，清除任何内部状态。

        该方法重置与字符集无关的状态，并且还调用implReset方法以执行任何特定于字符集的重置操作。

        结果
        这个编码器

      • implReset

        protected void implReset​()
        复位该编码器，清除任何字符集特定的内部状态。

        这种方法的默认实现什么都不做。 该方法应由维护内部状态的编码器覆盖。

      • encodeLoop

        protected abstract CoderResult encodeLoop​(CharBuffer in,
                                          ByteBuffer out)
        将一个或多个字符编码为一个或多个字节。

        该方法封装了基本的编码循环，编码尽可能多的字符，直到其输出不足，在输出缓冲区中用完，或遇到编码错误。 该方法由encode方法调用，它处理结果解释和错误恢复。

        缓冲区从其当前位置开始读取并写入。 最多读取in.remaining()个字符，最多写入out.remaining()个字节。 缓冲区的位置将被提前以反映读取的字符和写入的字节，但是它们的标记和限制将不被修改。

        该方法返回一个CoderResult对象来描述其终止原因，方式与encode方法相同。 该方法的大多数实现将通过返回一个适当的结果对象来解决编码错误，由encode方法进行解释。 优化的实现可能会检查相关的错误操作，并实现该操作本身。

        该方法的实现可以通过返回CoderResult.UNDERFLOW来执行任意的前瞻，直到它接收足够的输入。

        参数
        in - 输入字符缓冲区
        out - 输出字节缓冲区
        结果
        描述终止原因的编码器结果对象

      • encode

        public final ByteBuffer encode​(CharBuffer in)
                        throws CharacterCodingException
        便捷方法，将单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区中。

        该方法实现整个encoding operation ; 也就是说，它复位该编码器，然后对给定字符缓冲区中的字符进行编码，最后刷新该编码器。 因此，如果编码操作已经在进行中，则不能调用此方法。

        参数
        in - 输入字符缓冲区
        结果
        包含编码操作结果的新分配的字节缓冲器。 缓冲区的位置将为零，其限制将跟随写入的最后一个字节。
        异常
        IllegalStateException - 如果编码操作已在进行中
        MalformedInputException - 如果从输入缓冲区当前位置开始的字符序列不是合法的16位Unicode序列，并且当前格式错误的输入操作是 CodingErrorAction.REPORT
        UnmappableCharacterException - 如果从输入缓冲区的当前位置开始的字符序列不能映射到等效的字节序列，而当前的不可 映像字符操作是 CodingErrorAction.REPORT
        CharacterCodingException

      • canEncode

        public boolean canEncode​(char c)
        告知编码器是否可以对给定的字符进行编码。

        如果给定的字符是代理字符，此方法返回false ; 这样的字符只有当它们是由高替代物和低替代品组成的成员的对象时才能被解释。 可以使用canEncode(CharSequence)方法来测试字符序列是否可以被编码。

        该方法可能会修改该编码器的状态; 因此，如果一个encoding operation已经在进行中，则不应该调用它。

        该方法的默认实现不是很有效; 通常应该覆盖以提高性能。

        参数
        c - 给定的字符
        结果
        true如果并且只有这个编码器可以对给定的字符进行编码
        异常
        IllegalStateException - 如果编码操作已在进行中

      • canEncode

        public boolean canEncode​(CharSequence cs)
        告知编码器是否可以对给定的字符序列进行编码。

        如果该方法对于特定字符序列返回false ，则可以通过执行完整的encoding operation获得关于为什么不编码序列的更多信息。

        该方法可能会修改该编码器的状态; 因此，如果编码操作已经在进行中，则不应该调用它。

        该方法的默认实现不是很有效; 通常应该覆盖以提高性能。

        参数
        cs - 给定的字符序列
        结果
        true如果并且仅当该编码器可以编码给定字符而不抛出任何异常并且不执行任何替换
        异常
        IllegalStateException - 如果编码操作已在进行中
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CoderMalfunctionError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class CoderMalfunctionError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.nio.charset.CoderMalfunctionError
  • All Implemented Interfaces:
    Serializable

    public class CoderMalfunctionError
extends Error
    错误抛出当decodeLoop方法的CharsetDecoder ，或encodeLoop一个的方法CharsetEncoder ，抛出意外的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CoderMalfunctionError​(异常 cause)
      初始化此类的实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CoderMalfunctionError

        public CoderMalfunctionError​(异常 cause)
        初始化此类的实例。
        参数
        cause - The unexpected exception that was thrown
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CoderResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class CoderResult

  • java.lang.Object
    • java.nio.charset.CoderResult

  • public class CoderResult
extends Object
    编码器的结果状态的描述。

    字符集编码器，即解码器或编码器，从输入缓冲器中消耗字节（或字符），将其转换，并将生成的字符（或字节）写入输出缓冲区。 编码过程以四类原因之一终止，这些原因由本类的实例描述：

    • 当没有更多的输入被处理或输入不足，需要额外的输入时，会报告下溢 。 该条件由唯一的结果对象UNDERFLOW表示 ，其isUnderflow方法返回true 。

    • 当输出缓冲区中剩余的空间不足时，会报告溢出 。 此条件由唯一的结果对象OVERFLOW表示 ，其isOverflow方法返回true 。

    • 当一系列输入单元格式不正确时，会报错格式输入错误 。 此类错误由该类的实例描述，其isMalformed方法返回true ，其length方法返回畸形序列的长度。 对于给定长度的所有格式错误的输入错误，此类有一个唯一的实例。

    • 当输入单元的序列表示不能在输出字符集中表示的字符时，会报告不可映射的字符错误 。 此类错误由isUnmappable方法返回true并且其length方法返回表示不可映射字符的输入序列的长度的该类的实例描述。 对于给定长度的所有不可映射字符错误，此类都有一个唯一的实例。

    为了方便起见， isError方法对于描述错误输入和不可映射字符错误的结果对象返回true ，但false对于描述下溢或溢出条件的对象返回true 。

    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static CoderResult OVERFLOW
      指示溢出的结果对象，意味着输出缓冲区空间不足。
      static CoderResult UNDERFLOW
      指示下溢的结果对象，意味着输入缓冲区已经完全消耗，或者如果输入缓冲区尚未为空，则需要额外的输入。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean isError​()
      告知该对象是否描述错误状况。
      boolean isMalformed​()
      告知这个对象是否描述了格式错误的输入错误。
      boolean isOverflow​()
      告知该对象是否描述溢出状况。
      boolean isUnderflow​()
      告知该对象是否描述了下溢条件。
      boolean isUnmappable​()
      告知该对象是否描述不可映射的字符错误。
      int length​()
      返回此对象描述的错误输入的长度 （可选操作） 。
      static CoderResult malformedForLength​(int length)
      静态工厂方法返回描述给定长度的格式错误的唯一对象。
      void throwException​()
      抛出与此对象描述的结果相适应的异常。
      String toString​()
      返回描述此编码器结果的字符串。
      static CoderResult unmappableForLength​(int length)
      静态工厂方法返回描述给定长度的不可映射字符错误的唯一结果对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • UNDERFLOW

        public static final CoderResult UNDERFLOW
        指示下溢的结果对象，意味着输入缓冲区已经完全消耗，或者如果输入缓冲区尚未为空，则需要额外的输入。

      • OVERFLOW

        public static final CoderResult OVERFLOW
        指示溢出的结果对象，意味着输出缓冲区空间不足。

    • 方法详细信息

      • toString

        public String toString​()
        返回描述此编码器结果的字符串。
        重写：
        toString Object
        结果
        一个描述性的字符串

      • isUnderflow

        public boolean isUnderflow​()
        告知该对象是否描述了下溢条件。
        结果
        true如果，且仅当此对象表示下溢

      • isOverflow

        public boolean isOverflow​()
        告知该对象是否描述溢出状况。
        结果
        true如果，只有当这个对象表示溢出

      • isError

        public boolean isError​()
        告知该对象是否描述错误状况。
        结果
        true如果并且只有当此对象表示格式错误输入错误或不可映射字符错误

      • isMalformed

        public boolean isMalformed​()
        告知这个对象是否描述了格式错误的输入错误。
        结果
        true如果，且仅当此对象表示格式错误时输入错误

      • isUnmappable

        public boolean isUnmappable​()
        告知该对象是否描述不可映射的字符错误。
        结果
        true如果且仅当此对象表示不可映射字符错误

      • length

        public int length​()
        返回此对象描述的错误输入的长度 （可选操作） 。
        结果
        错误输入的长度，正整数
        异常
        UnsupportedOperationException - 如果此对象没有描述错误条件，也就是说，如果 isError不返回 true

      • malformedForLength

        public static CoderResult malformedForLength​(int length)
        静态工厂方法返回描述给定长度的格式错误的唯一对象。
        参数
        length - 给定的长度
        结果
        请求的编码器结果对象

      • unmappableForLength

        public static CoderResult unmappableForLength​(int length)
        静态工厂方法返回描述给定长度的不可映射字符错误的唯一结果对象。
        参数
        length - 给定的长度
        结果
        请求的编码器结果对象

      • throwException

        public void throwException​()
                    throws CharacterCodingException
        抛出与此对象描述的结果相适应的异常。
        异常
        BufferUnderflowException - 如果此对象为 UNDERFLOW
        BufferOverflowException - 如果此对象为 OVERFLOW
        MalformedInputException - 如果此对象表示格式错误输入错误; 异常的长度值将是该对象的长度值
        UnmappableCharacterException - 如果此对象表示不可映射的字符错误; 异常长度值将是该对象的长度值
        CharacterCodingException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


CodingErrorAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class CodingErrorAction

  • java.lang.Object
    • java.nio.charset.CodingErrorAction

  • public class CodingErrorAction
extends Object
    用于编码错误操作的类型安全枚举。

    此类的实例用于指定字符集decoders和encoders如何处理格式错误的输入和不可映射的字符错误。

    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static CodingErrorAction IGNORE
      指示通过丢弃错误输入并恢复编码操作来处理编码错误的动作。
      static CodingErrorAction REPLACE
      指示通过丢弃错误输入来处理编码错误的动作，将编码器的替换值附加到输出缓冲器，并恢复编码操作。
      static CodingErrorAction REPORT
      通过返回一个CoderResult对象或者通过抛出一个CharacterCodingException ，以适用于实现编码过程的方法为准，报告编码错误的动作。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回描述此操作的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • IGNORE

        public static final CodingErrorAction IGNORE
        指示通过丢弃错误输入并恢复编码操作来处理编码错误的动作。

      • REPLACE

        public static final CodingErrorAction REPLACE
        指示通过丢弃错误输入来处理编码错误的动作，将编码器的替换值附加到输出缓冲器，并恢复编码操作。

      • REPORT

        public static final CodingErrorAction REPORT
        通过返回一个CoderResult对象或抛出一个CharacterCodingException ， 取决于实现编码过程的方法，可以报告编码错误的动作。

    • 方法详细信息

      • toString

        public String toString​()
        返回描述此操作的字符串。
        重写：
        toString在 Object
        结果
        一个描述性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


IllegalCharsetNameException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class IllegalCharsetNameException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.charset.IllegalCharsetNameException
  • All Implemented Interfaces:
    Serializable

    public class IllegalCharsetNameException
extends IllegalArgumentException
    当使用不是 legal charset name的字符串时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalCharsetNameException​(String charsetName)
      构造这个类的一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getCharsetName​()
      检索非法字符集名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalCharsetNameException

        public IllegalCharsetNameException​(String charsetName)
        构造这个类的一个实例。
        参数
        charsetName - 非法字符集名称

    • 方法详细信息

      • getCharsetName

        public String getCharsetName​()
        检索非法字符集名称。
        结果
        非法字符集名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.nio.charset (Java SE 9 & JDK 9 )

java.nio.charset

Classes

  • Charset
  • CharsetDecoder
  • CharsetEncoder
  • CoderResult
  • CodingErrorAction
  • StandardCharsets

Exceptions

  • CharacterCodingException
  • IllegalCharsetNameException
  • MalformedInputException
  • UnmappableCharacterException
  • UnsupportedCharsetException

Errors

  • CoderMalfunctionError


java.nio.charset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.nio.charset

定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
Summary of charsets, decoders, and encoders in this package
Class name | DescriptiPath
Charset A named mapping between characters
and bytes
CharsetDecoder | Decodes bytes into characters
CharsetEncoder | Encodes characters into bytes
CoderResult | Describes coder results
CodingErrorAction Describes actions to take when
coding errors are detected

字符集被命名为十六位Unicode字符和字节序列的序列之间的映射，在RFC 2278中定义。 解码器是将特定字符集中的字节转换为字符的引擎， 编码器是将字符转换为字节的引擎。 编码器和解码器对字节和字符缓冲区进行操作。 它们统称为编码器 。

Charset类定义了为给定字符集创建编码器和检索与字符集关联的各种名称的方法。 它还定义了用于测试是否支持特定字符集的静态方法，用于通过名称查找字符集实例，以及构造包含当前Java虚拟机中可用的每个字符集的映射。

大多数用户不会直接使用这些类; 相反，它们将使用String类中现有的与charset相关的构造函数和方法，以及现有的InputStreamReader和OutputStreamWriter类，所有这些类的实现都已经重做，以利用此包中定义的字符集。 对InputStreamReader和OutputStreamWriter类进行了少量 更改 ，以便在构建这些类的实例时指定显式字符集对象。

可以通过java.nio.charset.spi包中的CharsetProvider类中定义的接口提供对新字符集的支持。

除非另有说明，否则将null参数传递给此程序包中任何类或接口中的构造函数或方法将导致抛出NullPointerException 。

从以下版本开始：
1.4
  • 类摘要
    Class 描述
    Charset
    16位Unicode code units和字节序列的序列之间的命名映射。
    CharsetDecoder
    可以将特定字符集中的字节序列转换为十六位Unicode字符序列的引擎。
    CharsetEncoder
    一种引擎，可以将一系列十六位Unicode字符转换为特定字符集中的字节序列。
    CoderResult
    编码器的结果状态的描述。
    CodingErrorAction
    用于编码错误操作的类型安全枚举。
    StandardCharsets
    标准的常量定义Charsets 。
  • 异常摘要
    异常 描述
    CharacterCodingException
    发生字符编码或解码错误时抛出的检查异常。
    IllegalCharsetNameException
    当使用不是 legal charset name的字符串时抛出未检查的异常。
    MalformedInputException
    当输入字节序列对于给定的字符集不合法时，检查的异常抛出，或输入字符序列不是合法的16位Unicode序列。
    UnmappableCharacterException
    输入字符（或字节）序列有效但无法映射到输出字节（或字符）序列时抛出的检查异常。
    UnsupportedCharsetException
    对于请求的字符集，当没有可用的支持时抛出未检查的异常。
  • Error Summary
    Error 描述
    CoderMalfunctionError
    Error thrown when the decodeLoop method of a CharsetDecoder, or the encodeLoop method of a CharsetEncoder, throws an unexpected exception.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.nio.charset Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.nio.charset

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.nio.charset.Charset (implements java.lang.Comparable<T>)
    • java.nio.charset.CharsetDecoder
    • java.nio.charset.CharsetEncoder
    • java.nio.charset.CoderResult
    • java.nio.charset.CodingErrorAction
    • java.nio.charset.StandardCharsets
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.nio.charset.CoderMalfunctionError
      • java.lang.异常
        • java.io.IOException
          • java.nio.charset.CharacterCodingException
            • java.nio.charset.MalformedInputException
            • java.nio.charset.UnmappableCharacterException
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.charset.IllegalCharsetNameException
            • java.nio.charset.UnsupportedCharsetException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


MalformedInputException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class MalformedInputException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.charset.CharacterCodingException
            • java.nio.charset.MalformedInputException
  • All Implemented Interfaces:
    Serializable

    public class MalformedInputException
extends CharacterCodingException
    当输入字节序列对于给定的字符集不合法时，检查的异常抛出，或输入字符序列不是合法的16位Unicode序列。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MalformedInputException​(int inputLength)
      构造一个给定长度的 MalformedInputException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getInputLength​()
      返回输入的长度。
      String getMessage​()
      返回消息。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MalformedInputException

        public MalformedInputException​(int inputLength)
        构造一个给定长度的 MalformedInputException 。
        参数
        inputLength - 输入的长度

    • 方法详细信息

      • getInputLength

        public int getInputLength​()
        返回输入的长度。
        结果
        输入的长度

      • getMessage

        public String getMessage​()
        返回消息。
        重写：
        getMessage在 Throwable
        结果
        消息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StandardCharsets (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class StandardCharsets

  • java.lang.Object
    • java.nio.charset.StandardCharsets

  • public final class StandardCharsets
extends Object
    常规定义的标准Charsets 。 这些字符集保证在Java平台的每个实现上都可用。
    从以下版本开始：
    1.7
    另请参见：
    Standard Charsets

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Charset ISO_8859_1
      ISO拉丁字母1号，又名
      static Charset US_ASCII
      七位ASCII，又名
      static Charset UTF_16
      十六位UCS转换格式，由可选字节顺序标记标识的字节顺序
      static Charset UTF_16BE
      十六位UCS转换格式，大字节顺序
      static Charset UTF_16LE
      十六位UCS转换格式，小端字节顺序
      static Charset UTF_8
      八位UCS转换格式

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • US_ASCII

        public static final Charset US_ASCII
        七位ASCII，也称为ISO646-US，也称为Unicode字符集的基本拉丁方块

      • ISO_8859_1

        public static final Charset ISO_8859_1
        ISO拉丁字母1号，也称为ISO-LATIN-1

      • UTF_8

        public static final Charset UTF_8
        八位UCS转换格式

      • UTF_16BE

        public static final Charset UTF_16BE
        十六位UCS转换格式，大字节顺序

      • UTF_16LE

        public static final Charset UTF_16LE
        十六位UCS转换格式，小端字节顺序

      • UTF_16

        public static final Charset UTF_16
        十六位UCS转换格式，由可选字节顺序标记标识的字节顺序
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


UnmappableCharacterException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class UnmappableCharacterException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.charset.CharacterCodingException
            • java.nio.charset.UnmappableCharacterException
  • All Implemented Interfaces:
    Serializable

    public class UnmappableCharacterException
extends CharacterCodingException
    输入字符（或字节）序列有效但无法映射到输出字节（或字符）序列时抛出的检查异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnmappableCharacterException​(int inputLength)
      构造一个给定长度的 UnmappableCharacterException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getInputLength​()
      返回输入的长度。
      String getMessage​()
      返回消息。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnmappableCharacterException

        public UnmappableCharacterException​(int inputLength)
        构造一个给定长度的 UnmappableCharacterException 。
        参数
        inputLength - 输入的长度

    • 方法详细信息

      • getInputLength

        public int getInputLength​()
        返回输入的长度。
        结果
        输入的长度

      • getMessage

        public String getMessage​()
        返回消息。
        重写：
        getMessage在 Throwable
        结果
        消息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnsupportedCharsetException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset

Class UnsupportedCharsetException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.charset.UnsupportedCharsetException
  • All Implemented Interfaces:
    Serializable

    public class UnsupportedCharsetException
extends IllegalArgumentException
    对于请求的字符集，当没有可用的支持时抛出未检查的异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnsupportedCharsetException​(String charsetName)
      构造这个类的一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getCharsetName​()
      检索不支持的字符集的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnsupportedCharsetException

        public UnsupportedCharsetException​(String charsetName)
        构造这个类的一个实例。
        参数
        charsetName - 不支持的字符集的名称

    • 方法详细信息

      • getCharsetName

        public String getCharsetName​()
        检索不支持的字符集的名称。
        结果
        不支持的字符集的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.nio.charset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.nio.charset

  • Packages that use java.nio.charset
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.charset.spi
    java.nio.charset包的服务提供者类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方法。
  • Classes in java.nio.charset used by java.io
    Class 描述
    Charset
    16位Unicode code units和字节序列的序列之间的命名映射。
    CharsetDecoder
    可以将特定字符集中的字节序列转换为十六位Unicode字符序列的引擎。
    CharsetEncoder
    一种引擎，可以将一系列十六位Unicode字符转换为特定字符集中的字节序列。
  • Classes in java.nio.charset used by java.lang
    Class 描述
    Charset
    16位Unicode code units和字节序列的序列之间的命名映射。
  • Classes in java.nio.charset used by java.nio.channels
    Class 描述
    CharsetDecoder
    可以将特定字符集中的字节序列转换为十六位Unicode字符序列的引擎。
    CharsetEncoder
    一种引擎，可以将一系列十六位Unicode字符转换为特定字符集中的字节序列。
  • Classes in java.nio.charset used by java.nio.charset
    Class 描述
    CharacterCodingException
    发生字符编码或解码错误时抛出的检查异常。
    Charset
    16位Unicode code units序列和字节序列之间的命名映射。
    CharsetDecoder
    可以将特定字符集中的字节序列转换为十六位Unicode字符序列的引擎。
    CharsetEncoder
    一种引擎，可以将一系列十六位Unicode字符转换为特定字符集中的字节序列。
    CoderResult
    编码器的结果状态的描述。
    CodingErrorAction
    用于编码错误操作的类型安全枚举。
  • Classes in java.nio.charset used by java.nio.charset.spi
    Class 描述
    Charset
    16位Unicode code units和字节序列的序列之间的命名映射。
  • Classes in java.nio.charset used by java.nio.file
    Class 描述
    Charset
    16位Unicode code units和字节序列的序列之间的命名映射。
  • Classes in java.nio.charset used by java.util.zip
    Class 描述
    Charset
    16位Unicode code units和字节序列的序列之间的命名映射。
  • Classes in java.nio.charset used by javafx.fxml
    Class 描述
    Charset
    16位Unicode code units序列和字节序列之间的命名映射。
  • Classes in java.nio.charset used by javax.tools
    Class 描述
    Charset
    16位Unicode code units序列和字节序列之间的命名映射。
  • Classes in java.nio.charset used by jdk.incubator.http
    Class 描述
    Charset
    16位Unicode code units和字节序列的序列之间的命名映射。
  • Classes in java.nio.charset used by jdk.nashorn.api.scripting
    Class 描述
    Charset
    16位Unicode code units和字节序列的序列之间的命名映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.CharacterCodingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.CharacterCodingException

  • Packages that use CharacterCodingException
    软件包 描述
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。

    • Uses of CharacterCodingException in java.nio.charset

      Subclasses of CharacterCodingException in java.nio.charset
      Modifier and Type Class 描述
      class  MalformedInputException
      当输入字节序列对于给定的字符集不合法时，检查的异常抛出，或输入字符序列不是合法的16位Unicode序列。
      class  UnmappableCharacterException
      输入字符（或字节）序列有效但无法映射到输出字节（或字符）序列时抛出的检查异常。
      Methods in java.nio.charset that throw CharacterCodingException
      Modifier and Type 方法 描述
      CharBuffer CharsetDecoder.decode​(ByteBuffer in)
      将单个输入字节缓冲器的剩余内容解码为新分配的字符缓冲区的方便方法。
      ByteBuffer CharsetEncoder.encode​(CharBuffer in)
      便捷方法，将单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区中。
      void CoderResult.throwException​()
      抛出与此对象描述的结果相适应的异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.Charset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.Charset

  • Packages that use Charset
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.charset.spi
    java.nio.charset包的服务提供商类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

    • Uses of Charset in java.io

      Constructors in java.io with parameters of type Charset
      Constructor 描述
      InputStreamReader​(InputStream in, Charset cs)
      创建一个使用给定字符集的InputStreamReader。
      OutputStreamWriter​(OutputStream out, Charset cs)
      创建一个使用给定字符集的OutputStreamWriter。

    • Uses of Charset in java.lang

      Methods in java.lang with parameters of type Charset
      Modifier and Type 方法 描述
      byte[] String.getBytes​(Charset charset)
      使用给定的charset将该String编码为字节序列，将结果存储到新的字节数组中。
      Constructors in java.lang with parameters of type Charset
      Constructor 描述
      String​(byte[] bytes, int offset, int length, Charset charset)
      构造一个新的String通过使用指定的指定字节子阵列解码charset 。
      String​(byte[] bytes, Charset charset)
      构造一个新的String由指定用指定的字节的数组解码charset 。

    • Uses of Charset in java.nio.charset

      Fields in java.nio.charset declared as Charset
      Modifier and Type Field 描述
      static Charset StandardCharsets.ISO_8859_1
      ISO拉丁字母1号，又名
      static Charset StandardCharsets.US_ASCII
      七位ASCII，又名
      static Charset StandardCharsets.UTF_16
      十六位UCS转换格式，由可选字节顺序标记标识的字节顺序
      static Charset StandardCharsets.UTF_16BE
      十六位UCS转换格式，大字节顺序
      static Charset StandardCharsets.UTF_16LE
      十六位UCS转换格式，小端字节顺序
      static Charset StandardCharsets.UTF_8
      八位UCS转换格式
      Methods in java.nio.charset that return Charset
      Modifier and Type 方法 描述
      Charset CharsetDecoder.charset​()
      返回创建此解码器的字符集。
      Charset CharsetEncoder.charset​()
      返回创建此编码器的字符集。
      static Charset Charset.defaultCharset​()
      返回此Java虚拟机的默认字符集。
      Charset CharsetDecoder.detectedCharset​()
      检索该解码器检测到的字符集 （可选操作） 。
      static Charset Charset.forName​(String charsetName)
      返回名为charset的charset对象。
      Methods in java.nio.charset that return types with arguments of type Charset
      Modifier and Type 方法 描述
      static SortedMap<String,Charset> Charset.availableCharsets​()
      构造从规范字符集名称到字符集对象的排序映射。
      Methods in java.nio.charset with parameters of type Charset
      Modifier and Type 方法 描述
      int Charset.compareTo​(Charset that)
      将此字符串与另一个字符集进行比较
      abstract boolean Charset.contains​(Charset cs)
      告知这个字符集是否包含给定的字符集。
      Constructors in java.nio.charset with parameters of type Charset
      Constructor 描述
      CharsetDecoder​(Charset cs, float averageCharsPerByte, float maxCharsPerByte)
      初始化一个新的解码器。
      CharsetEncoder​(Charset cs, float averageBytesPerChar, float maxBytesPerChar)
      初始化新的编码器。
      CharsetEncoder​(Charset cs, float averageBytesPerChar, float maxBytesPerChar, byte[] replacement)
      初始化新的编码器。

    • Uses of Charset in java.nio.charset.spi

      Methods in java.nio.charset.spi that return Charset
      Modifier and Type 方法 描述
      abstract Charset CharsetProvider.charsetForName​(String charsetName)
      检索给定字符集名称的字符集。
      Methods in java.nio.charset.spi that return types with arguments of type Charset
      Modifier and Type 方法 描述
      abstract Iterator<Charset> CharsetProvider.charsets​()
      创建一个迭代器来迭代此提供程序支持的字符集。

    • Uses of Charset in java.nio.file

      Methods in java.nio.file with parameters of type Charset
      Modifier and Type 方法 描述
      static Stream<String> Files.lines​(Path path, Charset cs)
      从文件中读取所有行作为 Stream 。
      static BufferedReader Files.newBufferedReader​(Path path, Charset cs)
      打开一个文件进行阅读，返回一个 BufferedReader ，可以用来以有效的方式从文件读取文本。
      static BufferedWriter Files.newBufferedWriter​(Path path, Charset cs, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter ，可用于以有效的方式将文本写入文件。
      static List<String> Files.readAllLines​(Path path, Charset cs)
      从文件中读取所有行。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, Charset cs, OpenOption... options)
      将文本行写入文件。

    • Uses of Charset in java.util.zip

      Constructors in java.util.zip with parameters of type Charset
      Constructor 描述
      ZipFile​(File file, int mode, Charset charset)
      打开新的 ZipFile ，在指定的模式下从指定的 File对象中读取。
      ZipFile​(File file, Charset charset)
      打开一个ZIP文件，读取指定的File对象。
      ZipFile​(String name, Charset charset)
      打开一个zip文件进行阅读。
      ZipInputStream​(InputStream in, Charset charset)
      创建一个新的ZIP输入流。
      ZipOutputStream​(OutputStream out, Charset charset)
      创建一个新的ZIP输出流。

    • Uses of Charset in javafx.fxml

      Methods in javafx.fxml that return Charset
      Modifier and Type 方法 描述
      Charset FXMLLoader.getCharset​()
      返回此装载器使用的字符集。
      Methods in javafx.fxml with parameters of type Charset
      Modifier and Type 方法 描述
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      从FXML文档加载对象层次结构。
      void FXMLLoader.setCharset​(Charset charset)
      设置此装载器使用的字符集。
      Constructors in javafx.fxml with parameters of type Charset
      Constructor 描述
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(Charset charset)
      创建一个新的FXMLLoader实例。

    • Uses of Charset in javax.tools

      Methods in javax.tools with parameters of type Charset
      Modifier and Type 方法 描述
      StandardJavaFileManager DocumentationTool.getStandardFileManager​(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      返回此工具的标准文件管理器实现的新实例。
      StandardJavaFileManager JavaCompiler.getStandardFileManager​(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      返回此工具的标准文件管理器实现的新实例。

    • Uses of Charset in jdk.incubator.http

      Methods in jdk.incubator.http with parameters of type Charset
      Modifier and Type 方法 描述
      static HttpResponse.BodyHandler<String> HttpResponse.BodyHandler.asString​(Charset charset)
      返回一个BodyHandler<String> ，返回一个从 <String>获得的BodyProcessor <String> 。
      static HttpResponse.BodyProcessor<String> HttpResponse.BodyProcessor.asString​(Charset charset)
      返回一个主体处理器，其存储响应主体作为 String使用给定的转换 Charset 。
      static HttpRequest.BodyProcessor HttpRequest.BodyProcessor.fromString​(String s, Charset charset)
      返回一个请求体处理器，其身体是给定的 String ，使用给定的字符集进行转换。

    • Uses of Charset in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that return Charset
      Modifier and Type 方法 描述
      Charset URLReader.getCharset​()
      这个读者使用的字符串
      Constructors in jdk.nashorn.api.scripting with parameters of type Charset
      Constructor 描述
      URLReader​(URL url, Charset cs)
      构造函数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.CharsetDecoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.CharsetDecoder

  • Packages that use CharsetDecoder
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。

    • Uses of CharsetDecoder in java.io

      Constructors in java.io with parameters of type CharsetDecoder
      Constructor 描述
      InputStreamReader​(InputStream in, CharsetDecoder dec)
      创建一个使用给定字符集解码器的InputStreamReader。

    • Uses of CharsetDecoder in java.nio.channels

      Methods in java.nio.channels with parameters of type CharsetDecoder
      Modifier and Type 方法 描述
      static Reader Channels.newReader​(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap)
      构造一个读取器，使用给定的解码器解码来自给定通道的字节。

    • Uses of CharsetDecoder in java.nio.charset

      Methods in java.nio.charset that return CharsetDecoder
      Modifier and Type 方法 描述
      abstract CharsetDecoder Charset.newDecoder​()
      为此字符集构造一个新的解码器。
      CharsetDecoder CharsetDecoder.onMalformedInput​(CodingErrorAction newAction)
      更改此解码器的错误格式输入错误的操作。
      CharsetDecoder CharsetDecoder.onUnmappableCharacter​(CodingErrorAction newAction)
      更改此解码器的操作为不可映射的字符错误。
      CharsetDecoder CharsetDecoder.replaceWith​(String newReplacement)
      更改此解码器的替换值。
      CharsetDecoder CharsetDecoder.reset​()
      复位该解码器，清除任何内部状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.CharsetEncoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.CharsetEncoder

  • Packages that use CharsetEncoder
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。

    • Uses of CharsetEncoder in java.io

      Constructors in java.io with parameters of type CharsetEncoder
      Constructor 描述
      OutputStreamWriter​(OutputStream out, CharsetEncoder enc)
      创建一个使用给定字符集编码器的OutputStreamWriter。

    • Uses of CharsetEncoder in java.nio.channels

      Methods in java.nio.channels with parameters of type CharsetEncoder
      Modifier and Type 方法 描述
      static Writer Channels.newWriter​(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap)
      构造一个使用给定编码器编码字符的写入器，并将生成的字节写入给定的通道。

    • Uses of CharsetEncoder in java.nio.charset

      Methods in java.nio.charset that return CharsetEncoder
      Modifier and Type 方法 描述
      abstract CharsetEncoder Charset.newEncoder​()
      为此字符集构造一个新的编码器。
      CharsetEncoder CharsetEncoder.onMalformedInput​(CodingErrorAction newAction)
      更改编码器对格式错误输入错误的操作。
      CharsetEncoder CharsetEncoder.onUnmappableCharacter​(CodingErrorAction newAction)
      更改此编码器对不可映射字符错误的操作。
      CharsetEncoder CharsetEncoder.replaceWith​(byte[] newReplacement)
      更改此编码器的替换值。
      CharsetEncoder CharsetEncoder.reset​()
      复位该编码器，清除任何内部状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.CoderMalfunctionError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.CoderMalfunctionError

No usage of java.nio.charset.CoderMalfunctionError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.CoderResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.CoderResult

  • Packages that use CoderResult
    软件包 描述
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。

    • Uses of CoderResult in java.nio.charset

      Fields in java.nio.charset declared as CoderResult
      Modifier and Type Field 描述
      static CoderResult CoderResult.OVERFLOW
      指示溢出的结果对象，意味着输出缓冲区空间不足。
      static CoderResult CoderResult.UNDERFLOW
      指示下溢的结果对象，意味着输入缓冲区已经完全消耗，或者如果输入缓冲区尚未为空，则需要额外的输入。
      Methods in java.nio.charset that return CoderResult
      Modifier and Type 方法 描述
      CoderResult CharsetDecoder.decode​(ByteBuffer in, CharBuffer out, boolean endOfInput)
      从给定的输入缓冲区解码尽可能多的字节，将结果写入给定的输出缓冲区。
      protected abstract CoderResult CharsetDecoder.decodeLoop​(ByteBuffer in, CharBuffer out)
      将一个或多个字节解码为一个或多个字符。
      CoderResult CharsetEncoder.encode​(CharBuffer in, ByteBuffer out, boolean endOfInput)
      从给定的输入缓冲区编码尽可能多的字符，将结果写入给定的输出缓冲区。
      protected abstract CoderResult CharsetEncoder.encodeLoop​(CharBuffer in, ByteBuffer out)
      将一个或多个字符编码为一个或多个字节。
      CoderResult CharsetDecoder.flush​(CharBuffer out)
      刷新此解码器。
      CoderResult CharsetEncoder.flush​(ByteBuffer out)
      刷新编码器。
      protected CoderResult CharsetDecoder.implFlush​(CharBuffer out)
      刷新此解码器。
      protected CoderResult CharsetEncoder.implFlush​(ByteBuffer out)
      刷新编码器。
      static CoderResult CoderResult.malformedForLength​(int length)
      静态工厂方法返回描述给定长度的格式错误的唯一对象。
      static CoderResult CoderResult.unmappableForLength​(int length)
      Static factory method that returns the unique result object describing an unmappable-character error of the given length.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.CodingErrorAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.CodingErrorAction

  • Packages that use CodingErrorAction
    软件包 描述
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。

    • Uses of CodingErrorAction in java.nio.charset

      Fields in java.nio.charset declared as CodingErrorAction
      Modifier and Type Field 描述
      static CodingErrorAction CodingErrorAction.IGNORE
      指示通过丢弃错误输入并恢复编码操作来处理编码错误的动作。
      static CodingErrorAction CodingErrorAction.REPLACE
      指示通过丢弃错误输入来处理编码错误的动作，将编码器的替换值附加到输出缓冲器，并恢复编码操作。
      static CodingErrorAction CodingErrorAction.REPORT
      通过返回一个CoderResult对象或抛出一个CharacterCodingException（取决于实现编码过程的方法）来指示编码错误的报告。
      Methods in java.nio.charset that return CodingErrorAction
      Modifier and Type 方法 描述
      CodingErrorAction CharsetDecoder.malformedInputAction​()
      返回此解码器当前的格式输入错误的操作。
      CodingErrorAction CharsetEncoder.malformedInputAction​()
      返回此编码器当前针对格式错误输入错误的操作。
      CodingErrorAction CharsetDecoder.unmappableCharacterAction​()
      返回此解码器当前的不可映射字符错误的操作。
      CodingErrorAction CharsetEncoder.unmappableCharacterAction​()
      返回此编码器当前对不可映射字符错误的操作。
      Methods in java.nio.charset with parameters of type CodingErrorAction
      Modifier and Type 方法 描述
      protected void CharsetDecoder.implOnMalformedInput​(CodingErrorAction newAction)
      报告对此解码器的格式错误的输入操作的更改。
      protected void CharsetEncoder.implOnMalformedInput​(CodingErrorAction newAction)
      报告对该编码器的格式错误的输入操作的更改。
      protected void CharsetDecoder.implOnUnmappableCharacter​(CodingErrorAction newAction)
      报告对此解码器的不可映射角色操作的更改。
      protected void CharsetEncoder.implOnUnmappableCharacter​(CodingErrorAction newAction)
      报告此编码器的不可映射角色动作的更改。
      CharsetDecoder CharsetDecoder.onMalformedInput​(CodingErrorAction newAction)
      更改此解码器的错误格式输入错误的操作。
      CharsetEncoder CharsetEncoder.onMalformedInput​(CodingErrorAction newAction)
      更改编码器对格式错误输入错误的操作。
      CharsetDecoder CharsetDecoder.onUnmappableCharacter​(CodingErrorAction newAction)
      更改此解码器的操作为不可映射的字符错误。
      CharsetEncoder CharsetEncoder.onUnmappableCharacter​(CodingErrorAction newAction)
      更改此编码器对不可映射字符错误的操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.IllegalCharsetNameException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.IllegalCharsetNameException

No usage of java.nio.charset.IllegalCharsetNameException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.MalformedInputException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.MalformedInputException

No usage of java.nio.charset.MalformedInputException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.StandardCharsets (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.StandardCharsets

No usage of java.nio.charset.StandardCharsets
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.UnmappableCharacterException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.UnmappableCharacterException

No usage of java.nio.charset.UnmappableCharacterException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.UnsupportedCharsetException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.UnsupportedCharsetException

No usage of java.nio.charset.UnsupportedCharsetException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


CharsetProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.charset.spi

Class CharsetProvider

  • java.lang.Object
    • java.nio.charset.spi.CharsetProvider

  • public abstract class CharsetProvider
extends Object
    字符集服务提供者类。

    charset提供程序是此类的具体子类，它具有零参数构造函数和一些关联的charset实现类。 字符串提供程序可能作为扩展安装在Java平台的实例中。 提供商也可以通过将它们添加到小程序或应用程序类路径或某些其他平台特定的方式来提供。 通过当前线程的context class loader查询 Charset提供程序。

    charset提供程序使用资源目录META-INF/services名为java.nio.charset.spi.CharsetProvider的提供程序配置文件来标识自身。 该文件应包含一个完全限定的具体字符集提供程序类名称列表，每行一个。 一行由任何换行符（ '\n' ），回车（ '\r' ）或随后的'\r' 。 忽略每个名称周围的空格和制表符，以及空白行。 评论的字符是'#' （ '\u0023' ）; 在每行上，忽略第一个注释字符之后的所有字符。 文件必须以UTF-8编码。

    如果一个特定的具体字符集提供程序类在多个配置文件中命名，或者在同一配置文件中多次命名，那么重复项将被忽略。 命名特定提供者的配置文件不需要与提供者本身在同一个jar文件或其他分发单元中。 提供程序必须可以从初始查询的相同类加载器访问以查找配置文件; 这不一定是加载文件的类加载器。

    从以下版本开始：
    1.4
    另请参见：
    Charset

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CharsetProvider​()
      初始化一个新的字符集提供程序。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Charset charsetForName​(String charsetName)
      检索给定字符集名称的字符集。
      abstract Iterator<Charset> charsets​()
      创建一个迭代器来迭代此提供程序支持的字符集。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CharsetProvider

        protected CharsetProvider​()
        初始化一个新的字符集提供程序。
        异常
        SecurityException - 如果安全管理器已安装，并且它已拒绝RuntimePermission ("charsetProvider")

    • 方法详细信息

      • charsets

        public abstract Iterator<Charset> charsets​()
        创建一个迭代器来迭代此提供程序支持的字符集。 该方法用于实现Charset.availableCharsets方法。
        结果
        新的迭代器

      • charsetForName

        public abstract Charset charsetForName​(String charsetName)
        检索给定字符集名称的字符集。
        参数
        charsetName - 请求的字符集的名称; 可能是规范名称或别名
        结果
        A charset object for the named charset, or null if the named charset is not supported by this provider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.nio.charset.spi (Java SE 9 & JDK 9 )

java.nio.charset.spi

Classes

  • CharsetProvider


java.nio.charset.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.nio.charset.spi

java.nio.charset包的服务提供商类。

只有定义新字符集的开发者才需要直接使用这个包。

除非另有说明，否则传递一个null参数到此程序包中任何类或接口中的构造函数或方法将导致抛出NullPointerException 。

从以下版本开始：
1.4
  • 类摘要
    Class 描述
    CharsetProvider
    字符集服务提供者类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.nio.charset.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.nio.charset.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.nio.charset.spi.CharsetProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package java.nio.charset.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.nio.charset.spi

No usage of java.nio.charset.spi
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.charset.spi.CharsetProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.charset.spi.CharsetProvider

No usage of java.nio.charset.spi.CharsetProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.Buffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.Buffer

  • Packages that use Buffer
    软件包 描述
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    javafx.scene.image
    提供加载和显示图像的一组类。

    • Uses of Buffer in java.nio

      Subclasses of Buffer in java.nio
      Modifier and Type Class 描述
      class  ByteBuffer
      一个字节缓冲区。
      class  CharBuffer
      一个char缓冲区。
      class  DoubleBuffer
      双缓冲。
      class  FloatBuffer
      一个浮动缓冲区。
      class  IntBuffer
      一个int缓冲区
      class  LongBuffer
      一个长缓冲区。
      class  MappedByteBuffer
      直接字节缓冲器，其内容是文件的存储器映射区域。
      class  ShortBuffer
      一个短暂的缓冲。
      Methods in java.nio that return Buffer
      Modifier and Type 方法 描述
      Buffer Buffer.clear​()
      清除此缓冲区。
      abstract Buffer Buffer.duplicate​()
      创建一个共享此缓冲区内容的新缓冲区。
      Buffer Buffer.flip​()
      翻转这个缓冲区。
      Buffer Buffer.limit​(int newLimit)
      设置此缓冲区的限制。
      Buffer Buffer.mark​()
      将此缓冲区的标记设置在其位置。
      Buffer Buffer.position​(int newPosition)
      设置这个缓冲区的位置。
      Buffer Buffer.reset​()
      将此缓冲区的位置重置为先前标记的位置。
      Buffer Buffer.rewind​()
      倒带这个缓冲区。
      abstract Buffer Buffer.slice​()
      创建一个新的缓冲区，其内容是此缓冲区内容的共享子序列。

    • Uses of Buffer in javafx.scene.image

      Classes in javafx.scene.image with type parameters of type Buffer
      Modifier and Type Class 描述
      class  PixelFormat<T extends Buffer>
      PixelFormat对象定义给定格式的像素的数据布局。
      class  WritablePixelFormat<T extends Buffer>
      表示可以存储全色的像素格式的物体PixelFormat可以用作从任意图像写入像素数据的目的地格式。
      Methods in javafx.scene.image with type parameters of type Buffer
      Modifier and Type 方法 描述
      <T extends Buffer>
      void             		PixelReader.getPixels​(int x, int y, int w, int h, WritablePixelFormat<T> pixelformat, T buffer, int scanlineStride)
      将像素数据从表面的矩形区域读入指定的缓冲区。
      <T extends Buffer>
      void             		PixelWriter.setPixels​(int x, int y, int w, int h, PixelFormat<T> pixelformat, T buffer, int scanlineStride)
      将像素数据从缓冲区存储到表面的矩形区域。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.BufferOverflowException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.BufferOverflowException

No usage of java.nio.BufferOverflowException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.BufferUnderflowException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.BufferUnderflowException

No usage of java.nio.BufferUnderflowException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.ByteBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.ByteBuffer

  • Packages that use ByteBuffer
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javax.crypto
    提供加密操作的类和接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.smartcardio
    Java™智能卡I / O API
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

    • Uses of ByteBuffer in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return ByteBuffer
      Modifier and Type 方法 描述
      abstract ByteBuffer SendFailedNotification.buffer​()
      返回要发送的数据。
      Methods in com.sun.nio.sctp with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      abstract <T> MessageInfo SctpChannel.receive​(ByteBuffer dst, T attachment, NotificationHandler<T> handler)
      在给定的缓冲区中接收消息和/或处理通知。
      abstract <T> MessageInfo SctpMultiChannel.receive​(ByteBuffer buffer, T attachment, NotificationHandler<T> handler)
      接收消息和/或通过此频道处理通知。
      abstract int SctpChannel.send​(ByteBuffer src, MessageInfo messageInfo)
      通过此频道发送消息。
      abstract int SctpMultiChannel.send​(ByteBuffer buffer, MessageInfo messageInfo)
      通过此频道发送消息。

    • Uses of ByteBuffer in java.lang

      Methods in java.lang with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      protected Class<?> ClassLoader.defineClass​(String name, ByteBuffer b, ProtectionDomain protectionDomain)
      一个转换ByteBuffer成类的实例Class ，与给定ProtectionDomain 。

    • Uses of ByteBuffer in java.lang.module

      Methods in java.lang.module that return types with arguments of type ByteBuffer
      Modifier and Type 方法 描述
      default Optional<ByteBuffer> ModuleReader.read​(String name)
      读取资源，返回一个具有资源内容的字节缓冲区。
      Methods in java.lang.module with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      static ModuleDescriptor ModuleDescriptor.read​(ByteBuffer bb)
      从字节缓冲区中读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor ModuleDescriptor.read​(ByteBuffer bb, Supplier<Set<String>> packageFinder)
      从字节缓冲区中读取模块声明的二进制形式作为模块描述符。
      default void ModuleReader.release​(ByteBuffer bb)
      释放一个字节缓冲区。

    • Uses of ByteBuffer in java.nio

      Subclasses of ByteBuffer in java.nio
      Modifier and Type Class 描述
      class  MappedByteBuffer
      直接字节缓冲器，其内容是文件的存储器映射区域。
      Methods in java.nio that return ByteBuffer
      Modifier and Type 方法 描述
      ByteBuffer ByteBuffer.alignedSlice​(int unitSize)
      创建一个新的字节缓冲区，其内容是此缓冲区内容的共享和对齐子序列。
      static ByteBuffer ByteBuffer.allocate​(int capacity)
      分配一个新的字节缓冲区。
      static ByteBuffer ByteBuffer.allocateDirect​(int capacity)
      分配一个新的直接字节缓冲区。
      abstract ByteBuffer ByteBuffer.asReadOnlyBuffer​()
      创建一个新的只读字节缓冲区，共享此缓冲区的内容。
      ByteBuffer ByteBuffer.clear​()
      清除此缓冲区。
      abstract ByteBuffer ByteBuffer.compact​()
      压缩此缓冲区 （可选操作） 。
      abstract ByteBuffer ByteBuffer.duplicate​()
      创建一个新的字节缓冲区，共享此缓冲区的内容。
      ByteBuffer ByteBuffer.flip​()
      翻转这个缓冲区。
      ByteBuffer ByteBuffer.get​(byte[] dst)
      相对批量 获取方法。
      ByteBuffer ByteBuffer.get​(byte[] dst, int offset, int length)
      相对批量 获取方法。
      ByteBuffer ByteBuffer.limit​(int newLimit)
      设置此缓冲区的限制。
      ByteBuffer ByteBuffer.mark​()
      将此缓冲区的标记设置在其位置。
      ByteBuffer ByteBuffer.order​(ByteOrder bo)
      修改缓冲区的字节顺序。
      ByteBuffer ByteBuffer.position​(int newPosition)
      设置这个缓冲区的位置。
      abstract ByteBuffer ByteBuffer.put​(byte b)
      相对 放置法 （可选操作） 。
      ByteBuffer ByteBuffer.put​(byte[] src)
      相对大容量 put方法 （可选操作） 。
      ByteBuffer ByteBuffer.put​(byte[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.put​(int index, byte b)
      绝对 put方法 （可选操作） 。
      ByteBuffer ByteBuffer.put​(ByteBuffer src)
      相对大容量 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putChar​(char value)
      写入char值的相对 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putChar​(int index, char value)
      用于写入char值的绝对 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putDouble​(double value)
      写入double值的相对 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putDouble​(int index, double value)
      用于写入双精度值的绝对 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putFloat​(float value)
      编写浮点值的相对 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putFloat​(int index, float value)
      用于写入浮点值的绝对 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putInt​(int value)
      编写int值的相对 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putInt​(int index, int value)
      用于写入int值的绝对 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putLong​(int index, long value)
      绝对 put方法写入一个长的值 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putLong​(long value)
      写入长值的相对 put方法 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putShort​(int index, short value)
      绝对 put方法写入一个简短的值 （可选操作） 。
      abstract ByteBuffer ByteBuffer.putShort​(short value)
      写入一个短值的相对 放置方法 （可选操作） 。
      ByteBuffer ByteBuffer.reset​()
      将此缓冲区的位置重置为先前标记的位置。
      ByteBuffer ByteBuffer.rewind​()
      倒带这个缓冲区。
      abstract ByteBuffer ByteBuffer.slice​()
      创建一个新的字节缓冲区，其内容是此缓冲区内容的共享子序列。
      static ByteBuffer ByteBuffer.wrap​(byte[] array)
      将一个字节数组包装到缓冲区中。
      static ByteBuffer ByteBuffer.wrap​(byte[] array, int offset, int length)
      将一个字节数组包装到缓冲区中。
      Methods in java.nio with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      int ByteBuffer.compareTo​(ByteBuffer that)
      将此缓冲区与另一个缓冲区进
      ByteBuffer ByteBuffer.put​(ByteBuffer src)
      相对大容量 put方法 （可选操作） 。

    • Uses of ByteBuffer in java.nio.channels

      Methods in java.nio.channels with parameters of type ByteBuffer
      Modifier and Type | 方法 | 描述
      Future<Integer> AsynchronousByteChannel.read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      <A> void AsynchronousByteChannel.read​(ByteBuffer dst, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      abstract Future<Integer> AsynchronousFileChannel.read​(ByteBuffer dst, long position)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      abstract <A> void AsynchronousFileChannel.read​(ByteBuffer dst, long position, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      abstract Future<Integer> | AsynchronousSocketChannel.read​(ByteBuffer dst)
      abstract <A> void AsynchronousSocketChannel.read​(ByteBuffer[] dsts, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从该通道读取字节序列到给定缓冲区的子序列中。
      abstract <A> void AsynchronousSocketChannel.read​(ByteBuffer dst, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      <A> void | AsynchronousSocketChannel.read​(ByteBuffer dst, A attachment, CompletionHandler<Integer,? super A> handler)
      abstract int DatagramChannel.read​(ByteBuffer dst)
      从此频道读取数据报。
      long DatagramChannel.read​(ByteBuffer[] dsts)
      从此频道读取数据报。
      abstract long DatagramChannel.read​(ByteBuffer[] dsts, int offset, int length)
      从此频道读取数据报。
      abstract int FileChannel.read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      long FileChannel.read​(ByteBuffer[] dsts)
      从该通道读取到给定缓冲区的字节序列。
      abstract long FileChannel.read​(ByteBuffer[] dsts, int offset, int length)
      从该通道读取字节序列到给定缓冲区的子序列中。
      abstract int FileChannel.read​(ByteBuffer dst, long position)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      int ReadableByteChannel.read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      long ScatteringByteChannel.read​(ByteBuffer[] dsts)
      从该通道读取到给定缓冲区的字节序列。
      long ScatteringByteChannel.read​(ByteBuffer[] dsts, int offset, int length)
      从该通道读取字节序列到给定缓冲区的子序列中。
      int SeekableByteChannel.read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      abstract int | SocketChannel.read​(ByteBuffer dst)
      long | SocketChannel.read​(ByteBuffer[] dsts)
      abstract long | SocketChannel.read​(ByteBuffer[] dsts, int offset, int length)
      abstract SocketAddress DatagramChannel.receive​(ByteBuffer dst)
      通过该频道接收数据报。
      abstract int DatagramChannel.send​(ByteBuffer src, SocketAddress target)
      通过此频道发送数据报。
      Future<Integer> AsynchronousByteChannel.write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      <A> void AsynchronousByteChannel.write​(ByteBuffer src, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向该通道写入一个字节序列。
      abstract Future<Integer> AsynchronousFileChannel.write​(ByteBuffer src, long position)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
      abstract <A> void AsynchronousFileChannel.write​(ByteBuffer src, long position, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
      abstract Future<Integer> | AsynchronousSocketChannel.write​(ByteBuffer src)
      abstract <A> void AsynchronousSocketChannel.write​(ByteBuffer[] srcs, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从给定缓冲区的子序列将一个字节序列写入该通道。
      abstract <A> void AsynchronousSocketChannel.write​(ByteBuffer src, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向该通道写入一个字节序列。
      <A> void | AsynchronousSocketChannel.write​(ByteBuffer src, A attachment, CompletionHandler<Integer,? super A> handler)
      abstract int DatagramChannel.write​(ByteBuffer src)
      将数据报写入此通道。
      long DatagramChannel.write​(ByteBuffer[] srcs)
      将数据报写入此通道。
      abstract long DatagramChannel.write​(ByteBuffer[] srcs, int offset, int length)
      将数据报写入此通道。
      abstract int FileChannel.write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      long FileChannel.write​(ByteBuffer[] srcs)
      从给定的缓冲区向该通道写入一系列字节。
      abstract long FileChannel.write​(ByteBuffer[] srcs, int offset, int length)
      从给定缓冲区的子序列将一个字节序列写入该通道。
      abstract int FileChannel.write​(ByteBuffer src, long position)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
      long GatheringByteChannel.write​(ByteBuffer[] srcs)
      从给定的缓冲区向该通道写入一系列字节。
      long GatheringByteChannel.write​(ByteBuffer[] srcs, int offset, int length)
      从给定缓冲区的子序列将一个字节序列写入该通道。
      int SeekableByteChannel.write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      abstract int | SocketChannel.write​(ByteBuffer src)
      long | SocketChannel.write​(ByteBuffer[] srcs)
      abstract long | SocketChannel.write​(ByteBuffer[] srcs, int offset, int length)
      int WritableByteChannel.write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。

    • Uses of ByteBuffer in java.nio.charset

      Methods in java.nio.charset that return ByteBuffer
      Modifier and Type 方法 描述
      ByteBuffer Charset.encode​(String str)
      在此字符集中将字符串编码为字节的便捷方法。
      ByteBuffer Charset.encode​(CharBuffer cb)
      在这个字符集中将Unicode字符编码为字节的便捷方法。
      ByteBuffer CharsetEncoder.encode​(CharBuffer in)
      便捷方法，将单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区中。
      Methods in java.nio.charset with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      CharBuffer Charset.decode​(ByteBuffer bb)
      便利方法，将此字符集中的字节解码为Unicode字符。
      CharBuffer CharsetDecoder.decode​(ByteBuffer in)
      将单个输入字节缓冲器的剩余内容解码为新分配的字符缓冲区的方便方法。
      CoderResult CharsetDecoder.decode​(ByteBuffer in, CharBuffer out, boolean endOfInput)
      从给定的输入缓冲区解码尽可能多的字节，将结果写入给定的输出缓冲区。
      protected abstract CoderResult CharsetDecoder.decodeLoop​(ByteBuffer in, CharBuffer out)
      将一个或多个字节解码为一个或多个字符。
      CoderResult CharsetEncoder.encode​(CharBuffer in, ByteBuffer out, boolean endOfInput)
      从给定的输入缓冲区编码尽可能多的字符，将结果写入给定的输出缓冲区。
      protected abstract CoderResult CharsetEncoder.encodeLoop​(CharBuffer in, ByteBuffer out)
      将一个或多个字符编码为一个或多个字节。
      CoderResult CharsetEncoder.flush​(ByteBuffer out)
      刷新编码器。
      protected CoderResult CharsetEncoder.implFlush​(ByteBuffer out)
      刷新编码器。

    • Uses of ByteBuffer in java.nio.file.attribute

      Methods in java.nio.file.attribute with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      int UserDefinedFileAttributeView.read​(String name, ByteBuffer dst)
      将用户定义属性的值读入缓冲区。
      int UserDefinedFileAttributeView.write​(String name, ByteBuffer src)
      从缓冲区写入用户定义属性的值。

    • Uses of ByteBuffer in java.security

      Methods in java.security with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      protected Class<?> SecureClassLoader.defineClass​(String name, ByteBuffer b, CodeSource cs)
      一个转换ByteBuffer成类的实例Class ，使用可选的CodeSource。
      protected void MessageDigestSpi.engineUpdate​(ByteBuffer input)
      使用指定的ByteBuffer更新摘要。
      protected void SignatureSpi.engineUpdate​(ByteBuffer input)
      使用指定的ByteBuffer更新要签名或验证的数据。
      void MessageDigest.update​(ByteBuffer input)
      使用指定的ByteBuffer更新摘要。
      void Signature.update​(ByteBuffer data)
      使用指定的ByteBuffer更新要签名或验证的数据。

    • Uses of ByteBuffer in java.util

      Methods in java.util that return ByteBuffer
      Modifier and Type 方法 描述
      ByteBuffer Base64.Decoder.decode​(ByteBuffer buffer)
      使用Base64编码方案从输入字节缓冲区中解码所有字节，将结果写入新分配的ByteBuffer。
      ByteBuffer Base64.Encoder.encode​(ByteBuffer buffer)
      使用Base64编码方案将所有剩余字节从指定的字节缓冲区编码为新分配的ByteBuffer。
      Methods in java.util with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      ByteBuffer Base64.Decoder.decode​(ByteBuffer buffer)
      使用Base64编码方案从输入字节缓冲区中解码所有字节，将结果写入新分配的ByteBuffer。
      ByteBuffer Base64.Encoder.encode​(ByteBuffer buffer)
      使用Base64编码方案将所有剩余字节从指定的字节缓冲区编码为新分配的ByteBuffer。
      static BitSet BitSet.valueOf​(ByteBuffer bb)
      返回一个包含给定字节缓冲区中所有位在其位置和极限之间的新位集合。

    • Uses of ByteBuffer in java.util.zip

      Methods in java.util.zip with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      void Adler32.update​(ByteBuffer buffer)
      使用指定缓冲区的字节更新校验和。
      default void Checksum.update​(ByteBuffer buffer)
      使用指定缓冲区的字节更新当前校验和。
      void CRC32.update​(ByteBuffer buffer)
      用指定缓冲区的字节更新CRC-32校验和。
      void CRC32C.update​(ByteBuffer buffer)
      用指定缓冲区的字节更新CRC-32C校验和。

    • Uses of ByteBuffer in javafx.scene.image

      Methods in javafx.scene.image that return types with arguments of type ByteBuffer
      Modifier and Type 方法 描述
      static PixelFormat<ByteBuffer> PixelFormat.createByteIndexedInstance​(int[] colors)
      创建描述像素布局的 PixelFormat实例，其中像素存储为单字节，表示索引到 INT_ARGB格式的 非预乘颜色值的指定查找表中。
      static PixelFormat<ByteBuffer> PixelFormat.createByteIndexedPremultipliedInstance​(int[] colors)
      创建描述像素布局的 PixelFormat实例，其中像素存储为单个字节，表示 INT_ARGB_PRE格式的 预乘颜色值的指定查找表中的 索引 。
      static WritablePixelFormat<ByteBuffer> PixelFormat.getByteBgraInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中存储在相邻字节中的像素与 非预乘数组件以增加的索引：蓝色，绿色，红色，alpha的顺序存储。
      static WritablePixelFormat<ByteBuffer> PixelFormat.getByteBgraPreInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中存储在相邻字节中的像素，其中 预乘数组件按照增加索引的顺序存储：蓝色，绿色，红色，alpha。
      static PixelFormat<ByteBuffer> PixelFormat.getByteRgbInstance​()
      返回描述像素布局的 PixelFormat实例，其中存储在相邻字节中的像素的颜色分量按照增加的索引顺序存储：红，绿，蓝。
      Method parameters in javafx.scene.image with type arguments of type ByteBuffer
      Modifier and Type 方法 描述
      void PixelReader.getPixels​(int x, int y, int w, int h, WritablePixelFormat<ByteBuffer> pixelformat, byte[] buffer, int offset, int scanlineStride)
      将像素数据从表面的矩形区域读入指定的字节数组。
      void PixelWriter.setPixels​(int x, int y, int w, int h, PixelFormat<ByteBuffer> pixelformat, byte[] buffer, int offset, int scanlineStride)
      将来自字节数组的像素数据存储到表面的矩形区域中。

    • Uses of ByteBuffer in javax.crypto

      Methods in javax.crypto with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      int Cipher.doFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected int CipherSpi.engineDoFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected int CipherSpi.engineUpdate​(ByteBuffer input, ByteBuffer output)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      protected void MacSpi.engineUpdate​(ByteBuffer input)
      处理 input.remaining()字节的ByteBuffer input ，从 input.position()开始。
      protected void CipherSpi.engineUpdateAAD​(ByteBuffer src)
      继续进行附加认证数据（AAD）的多部分更新。
      int Cipher.update​(ByteBuffer input, ByteBuffer output)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      void Mac.update​(ByteBuffer input)
      处理 input.remaining()字节的ByteBuffer input ，从 input.position()开始。
      void Cipher.updateAAD​(ByteBuffer src)
      继续进行附加认证数据（AAD）的多部分更新。

    • Uses of ByteBuffer in javax.net.ssl

      Methods in javax.net.ssl with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      SSLEngineResult SSLEngine.unwrap​(ByteBuffer src, ByteBuffer dst)
      尝试将SSL / TLS / DTLS网络数据解码为明文应用数据缓冲区。
      SSLEngineResult SSLEngine.unwrap​(ByteBuffer src, ByteBuffer[] dsts)
      尝试将SSL / TLS / DTLS网络数据解码为一系列明文应用程序数据缓冲区。
      abstract SSLEngineResult SSLEngine.unwrap​(ByteBuffer src, ByteBuffer[] dsts, int offset, int length)
      尝试将SSL / TLS / DTLS网络数据解码为明文应用程序数据缓冲区的子序列。
      abstract SSLEngineResult SSLEngine.wrap​(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst)
      尝试将明文字节从数据缓冲区的子序列编码为SSL / TLS / DTLS网络数据。
      SSLEngineResult SSLEngine.wrap​(ByteBuffer[] srcs, ByteBuffer dst)
      尝试将明文字节从一系列数据缓冲区编码为SSL / TLS / DTLS网络数据。
      SSLEngineResult SSLEngine.wrap​(ByteBuffer src, ByteBuffer dst)
      尝试将明文应用程序数据的缓冲区编码到SSL / TLS / DTLS网络数据中。

    • Uses of ByteBuffer in javax.smartcardio

      Methods in javax.smartcardio with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      abstract int CardChannel.transmit​(ByteBuffer command, ByteBuffer response)
      发送存储在命令ByteBuffer中的命令APDU，并在响应ByteBuffer中接收响应APDU。
      Constructors in javax.smartcardio with parameters of type ByteBuffer
      Constructor 描述
      CommandAPDU​(ByteBuffer apdu)
      从包含完整的APDU内容（标题和正文）的ByteBuffer创建一个CommandAPDU。

    • Uses of ByteBuffer in jdk.incubator.http

      Methods in jdk.incubator.http with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      default CompletionStage<?> WebSocket.Listener.onBinary​(WebSocket webSocket, ByteBuffer message, WebSocket.MessagePart part)
      接收二进制消息。
      default CompletionStage<?> WebSocket.Listener.onPing​(WebSocket webSocket, ByteBuffer message)
      接收Ping消息。
      default CompletionStage<?> WebSocket.Listener.onPong​(WebSocket webSocket, ByteBuffer message)
      收到乒乓消息。
      CompletableFuture<WebSocket> WebSocket.sendBinary​(ByteBuffer message, boolean isLast)
      从给定的 ByteBuffer发送带有字节的二进制消息。
      CompletableFuture<WebSocket> WebSocket.sendPing​(ByteBuffer message)
      从给定的ByteBuffer发送带有字节的Ping消息。
      CompletableFuture<WebSocket> WebSocket.sendPong​(ByteBuffer message)
      从给定的ByteBuffer发送带有字节的Pong消息。

    • Uses of ByteBuffer in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting with parameters of type ByteBuffer
      Modifier and Type 方法 描述
      void ScriptObjectMirror.setIndexedPropertiesToExternalArrayData​(ByteBuffer buf)
      Nashorn扩展名：setIndexedPropertiesToExternalArrayData。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.ByteOrder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.ByteOrder

  • Packages that use ByteOrder
    软件包 描述
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

    • Uses of ByteOrder in java.lang.invoke

      Methods in java.lang.invoke with parameters of type ByteOrder
      Modifier and Type 方法 描述
      static VarHandle MethodHandles.byteArrayViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生一个VarHandle，可以访问 byte[]数组的元素，就像它是不同的基元数组类型一样，如 int[]或 long[] 。
      static VarHandle MethodHandles.byteBufferViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生VarHandle给予访问的元素 ByteBuffer视为好像它是一个不同的基本组件类型到的元件的阵列 byte ，如 int[]或 long[] 。

    • Uses of ByteOrder in java.nio

      Fields in java.nio declared as ByteOrder
      Modifier and Type Field 描述
      static ByteOrder ByteOrder.BIG_ENDIAN
      常量表示大字节顺序。
      static ByteOrder ByteOrder.LITTLE_ENDIAN
      常量表示小端字节顺序。
      Methods in java.nio that return ByteOrder
      Modifier and Type 方法 描述
      static ByteOrder ByteOrder.nativeOrder​()
      检索底层平台的本机字节顺序。
      ByteOrder ByteBuffer.order​()
      检索此缓冲区的字节顺序。
      abstract ByteOrder CharBuffer.order​()
      检索此缓冲区的字节顺序。
      abstract ByteOrder DoubleBuffer.order​()
      检索此缓冲区的字节顺序。
      abstract ByteOrder FloatBuffer.order​()
      检索此缓冲区的字节顺序。
      abstract ByteOrder IntBuffer.order​()
      检索此缓冲区的字节顺序。
      abstract ByteOrder LongBuffer.order​()
      检索此缓冲区的字节顺序。
      abstract ByteOrder ShortBuffer.order​()
      检索此缓冲区的字节顺序。
      Methods in java.nio with parameters of type ByteOrder
      Modifier and Type 方法 描述
      ByteBuffer ByteBuffer.order​(ByteOrder bo)
      修改缓冲区的字节顺序。

    • Uses of ByteOrder in javax.imageio.stream

      Fields in javax.imageio.stream declared as ByteOrder
      Modifier and Type Field 描述
      protected ByteOrder ImageInputStreamImpl.byteOrder
      作为枚举类 java.nio.ByteOrder的实例的流的字节顺序，其中 ByteOrder.BIG_ENDIAN指示网络字节顺序和 ByteOrder.LITTLE_ENDIAN表示相反的顺序。
      Methods in javax.imageio.stream that return ByteOrder
      Modifier and Type | 方法 | 描述
      ByteOrder ImageInputStream.getByteOrder​()
      作为 java.nio.ByteOrder枚举的实例，返回从该流读取数据值的字节顺序。
      ByteOrder | ImageInputStreamImpl.getByteOrder​()
      Methods in javax.imageio.stream with parameters of type ByteOrder
      Modifier and Type | 方法 | 描述
      void ImageInputStream.setByteOrder​(ByteOrder byteOrder)
      Sets the desired byte order for future reads of data values from this stream.
      void | ImageInputStreamImpl.setByteOrder​(ByteOrder byteOrder)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.CharBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.CharBuffer

  • Packages that use CharBuffer
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。

    • Uses of CharBuffer in java.io

      Methods in java.io with parameters of type CharBuffer
      Modifier and Type 方法 描述
      int Reader.read​(CharBuffer target)
      尝试将字符读入指定的字符缓冲区。

    • Uses of CharBuffer in java.lang

      Methods in java.lang with parameters of type CharBuffer
      Modifier and Type 方法 描述
      int Readable.read​(CharBuffer cb)
      尝试将字符读入指定的字符缓冲区。

    • Uses of CharBuffer in java.nio

      Methods in java.nio that return CharBuffer
      Modifier and Type 方法 描述
      static CharBuffer CharBuffer.allocate​(int capacity)
      分配一个新的char缓冲区。
      CharBuffer CharBuffer.append​(char c)
      将指定的字符追加到此缓冲区 （可选操作） 。
      CharBuffer CharBuffer.append​(CharSequence csq)
      将指定的字符序列追加到此缓冲区 （可选操作） 。
      CharBuffer CharBuffer.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此缓冲区 （可选操作） 。
      abstract CharBuffer ByteBuffer.asCharBuffer​()
      创建一个字节缓冲区作为char缓冲区的视图。
      abstract CharBuffer CharBuffer.asReadOnlyBuffer​()
      创建一个新的只读char缓冲区，共享此缓冲区的内容。
      CharBuffer CharBuffer.clear​()
      清除此缓冲区。
      abstract CharBuffer CharBuffer.compact​()
      压缩此缓冲区 （可选操作） 。
      abstract CharBuffer CharBuffer.duplicate​()
      创建一个新的char缓冲区，共享此缓冲区的内容。
      CharBuffer CharBuffer.flip​()
      翻转这个缓冲区。
      CharBuffer CharBuffer.get​(char[] dst)
      相对批量 获取方法。
      CharBuffer CharBuffer.get​(char[] dst, int offset, int length)
      相对批量 获取方法。
      CharBuffer CharBuffer.limit​(int newLimit)
      设置此缓冲区的限制。
      CharBuffer CharBuffer.mark​()
      将此缓冲区的标记设置在其位置。
      CharBuffer CharBuffer.position​(int newPosition)
      设置这个缓冲区的位置。
      abstract CharBuffer CharBuffer.put​(char c)
      相对 放置法 （可选操作） 。
      CharBuffer CharBuffer.put​(char[] src)
      相对大容量 put方法 （可选操作） 。
      CharBuffer CharBuffer.put​(char[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract CharBuffer CharBuffer.put​(int index, char c)
      绝对 put方法 （可选操作） 。
      CharBuffer CharBuffer.put​(String src)
      相对大容量 put方法 （可选操作） 。
      CharBuffer CharBuffer.put​(String src, int start, int end)
      相对大容量 put方法 （可选操作） 。
      CharBuffer CharBuffer.put​(CharBuffer src)
      相对大容量 put方法 （可选操作） 。
      CharBuffer CharBuffer.reset​()
      将此缓冲区的位置重置为先前标记的位置。
      CharBuffer CharBuffer.rewind​()
      倒带这个缓冲区。
      abstract CharBuffer CharBuffer.slice​()
      创建一个新的char缓冲区，其内容是此缓冲区内容的共享子序列。
      abstract CharBuffer CharBuffer.subSequence​(int start, int end)
      创建一个新的字符缓冲区，代表该缓冲区相对于当前位置的指定子序列。
      static CharBuffer CharBuffer.wrap​(char[] array)
      将一个char数组包装到缓冲区中。
      static CharBuffer CharBuffer.wrap​(char[] array, int offset, int length)
      将一个char数组包装到缓冲区中。
      static CharBuffer CharBuffer.wrap​(CharSequence csq)
      将字符序列包装到缓冲区中。
      static CharBuffer CharBuffer.wrap​(CharSequence csq, int start, int end)
      将字符序列包装到缓冲区中。
      Methods in java.nio with parameters of type CharBuffer
      Modifier and Type 方法 描述
      int CharBuffer.compareTo​(CharBuffer that)
      将此缓冲区与另一个缓冲区进
      CharBuffer CharBuffer.put​(CharBuffer src)
      相对大容量 put方法 （可选操作） 。
      int CharBuffer.read​(CharBuffer target)
      尝试将字符读入指定的字符缓冲区。

    • Uses of CharBuffer in java.nio.charset

      Methods in java.nio.charset that return CharBuffer
      Modifier and Type 方法 描述
      CharBuffer Charset.decode​(ByteBuffer bb)
      便利方法，将此字符集中的字节解码为Unicode字符。
      CharBuffer CharsetDecoder.decode​(ByteBuffer in)
      将单个输入字节缓冲器的剩余内容解码为新分配的字符缓冲区的方便方法。
      Methods in java.nio.charset with parameters of type CharBuffer
      Modifier and Type 方法 描述
      CoderResult CharsetDecoder.decode​(ByteBuffer in, CharBuffer out, boolean endOfInput)
      从给定的输入缓冲区解码尽可能多的字节，将结果写入给定的输出缓冲区。
      protected abstract CoderResult CharsetDecoder.decodeLoop​(ByteBuffer in, CharBuffer out)
      将一个或多个字节解码为一个或多个字符。
      ByteBuffer Charset.encode​(CharBuffer cb)
      在这个字符集中将Unicode字符编码为字节的便捷方法。
      ByteBuffer CharsetEncoder.encode​(CharBuffer in)
      便捷方法，将单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区中。
      CoderResult CharsetEncoder.encode​(CharBuffer in, ByteBuffer out, boolean endOfInput)
      从给定的输入缓冲区编码尽可能多的字符，将结果写入给定的输出缓冲区。
      protected abstract CoderResult CharsetEncoder.encodeLoop​(CharBuffer in, ByteBuffer out)
      将一个或多个字符编码为一个或多个字节。
      CoderResult CharsetDecoder.flush​(CharBuffer out)
      刷新此解码器。
      protected CoderResult CharsetDecoder.implFlush​(CharBuffer out)
      Flushes this decoder.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.DoubleBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.DoubleBuffer

  • Packages that use DoubleBuffer
    软件包 描述
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。

    • Uses of DoubleBuffer in java.nio

      Methods in java.nio that return DoubleBuffer
      Modifier and Type 方法 描述
      static DoubleBuffer DoubleBuffer.allocate​(int capacity)
      分配一个新的双缓冲区。
      abstract DoubleBuffer ByteBuffer.asDoubleBuffer​()
      将此字节缓冲区的视图创建为双缓冲区。
      abstract DoubleBuffer DoubleBuffer.asReadOnlyBuffer​()
      创建一个新的只读双缓冲区，共享此缓冲区的内容。
      DoubleBuffer DoubleBuffer.clear​()
      清除此缓冲区。
      abstract DoubleBuffer DoubleBuffer.compact​()
      压缩此缓冲区 （可选操作） 。
      abstract DoubleBuffer DoubleBuffer.duplicate​()
      创建一个新的双缓冲区，共享此缓冲区的内容。
      DoubleBuffer DoubleBuffer.flip​()
      翻转这个缓冲区。
      DoubleBuffer DoubleBuffer.get​(double[] dst)
      相对批量 获取方法。
      DoubleBuffer DoubleBuffer.get​(double[] dst, int offset, int length)
      相对批量 获取方法。
      DoubleBuffer DoubleBuffer.limit​(int newLimit)
      设置此缓冲区的限制。
      DoubleBuffer DoubleBuffer.mark​()
      将此缓冲区的标记设置在其位置。
      DoubleBuffer DoubleBuffer.position​(int newPosition)
      设置这个缓冲区的位置。
      abstract DoubleBuffer DoubleBuffer.put​(double d)
      相对 放置法 （可选操作） 。
      DoubleBuffer DoubleBuffer.put​(double[] src)
      相对大容量 put方法 （可选操作） 。
      DoubleBuffer DoubleBuffer.put​(double[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract DoubleBuffer DoubleBuffer.put​(int index, double d)
      绝对 put方法 （可选操作） 。
      DoubleBuffer DoubleBuffer.put​(DoubleBuffer src)
      相对大容量 put方法 （可选操作） 。
      DoubleBuffer DoubleBuffer.reset​()
      将此缓冲区的位置重置为先前标记的位置。
      DoubleBuffer DoubleBuffer.rewind​()
      倒带这个缓冲区。
      abstract DoubleBuffer DoubleBuffer.slice​()
      创建一个新的双缓冲区，其内容是此缓冲区内容的共享子序列。
      static DoubleBuffer DoubleBuffer.wrap​(double[] array)
      将双阵列包装到缓冲区中。
      static DoubleBuffer DoubleBuffer.wrap​(double[] array, int offset, int length)
      将双阵列包装到缓冲区中。
      Methods in java.nio with parameters of type DoubleBuffer
      Modifier and Type 方法 描述
      int DoubleBuffer.compareTo​(DoubleBuffer that)
      将此缓冲区与另一个缓冲区进
      DoubleBuffer DoubleBuffer.put​(DoubleBuffer src)
      Relative bulk put method (optional operation).
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.FloatBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.FloatBuffer

  • Packages that use FloatBuffer
    软件包 描述
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。

    • Uses of FloatBuffer in java.nio

      Methods in java.nio that return FloatBuffer
      Modifier and Type 方法 描述
      static FloatBuffer FloatBuffer.allocate​(int capacity)
      分配一个新的浮动缓冲区。
      abstract FloatBuffer ByteBuffer.asFloatBuffer​()
      将此字节缓冲区的视图创建为浮动缓冲区。
      abstract FloatBuffer FloatBuffer.asReadOnlyBuffer​()
      创建一个新的只读浮动缓冲区，共享此缓冲区的内容。
      FloatBuffer FloatBuffer.clear​()
      清除此缓冲区。
      abstract FloatBuffer FloatBuffer.compact​()
      压缩此缓冲区 （可选操作） 。
      abstract FloatBuffer FloatBuffer.duplicate​()
      创建一个新的浮动缓冲区，共享此缓冲区的内容。
      FloatBuffer FloatBuffer.flip​()
      翻转这个缓冲区。
      FloatBuffer FloatBuffer.get​(float[] dst)
      相对批量 获取方法。
      FloatBuffer FloatBuffer.get​(float[] dst, int offset, int length)
      相对批量 获取方法。
      FloatBuffer FloatBuffer.limit​(int newLimit)
      设置此缓冲区的限制。
      FloatBuffer FloatBuffer.mark​()
      将此缓冲区的标记设置在其位置。
      FloatBuffer FloatBuffer.position​(int newPosition)
      设置这个缓冲区的位置。
      abstract FloatBuffer FloatBuffer.put​(float f)
      相对 放置法 （可选操作） 。
      FloatBuffer FloatBuffer.put​(float[] src)
      相对大容量 put方法 （可选操作） 。
      FloatBuffer FloatBuffer.put​(float[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract FloatBuffer FloatBuffer.put​(int index, float f)
      绝对 put方法 （可选操作） 。
      FloatBuffer FloatBuffer.put​(FloatBuffer src)
      相对大容量 put方法 （可选操作） 。
      FloatBuffer FloatBuffer.reset​()
      将此缓冲区的位置重置为先前标记的位置。
      FloatBuffer FloatBuffer.rewind​()
      倒带这个缓冲区。
      abstract FloatBuffer FloatBuffer.slice​()
      创建一个新的浮动缓冲区，其内容是此缓冲区内容的共享子序列。
      static FloatBuffer FloatBuffer.wrap​(float[] array)
      将一个浮点数组放入缓冲区。
      static FloatBuffer FloatBuffer.wrap​(float[] array, int offset, int length)
      将一个浮点数组放入缓冲区。
      Methods in java.nio with parameters of type FloatBuffer
      Modifier and Type 方法 描述
      int FloatBuffer.compareTo​(FloatBuffer that)
      将此缓冲区与另一个缓冲区进
      FloatBuffer FloatBuffer.put​(FloatBuffer src)
      Relative bulk put method (optional operation).
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.IntBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.IntBuffer

  • Packages that use IntBuffer
    软件包 描述
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    javafx.scene.image
    提供加载和显示图像的一组类。

    • Uses of IntBuffer in java.nio

      Methods in java.nio that return IntBuffer
      Modifier and Type 方法 描述
      static IntBuffer IntBuffer.allocate​(int capacity)
      分配一个新的int缓冲区。
      abstract IntBuffer ByteBuffer.asIntBuffer​()
      将此字节缓冲区的视图创建为int缓冲区。
      abstract IntBuffer IntBuffer.asReadOnlyBuffer​()
      创建一个新的只读int缓冲区，共享此缓冲区的内容。
      IntBuffer IntBuffer.clear​()
      清除此缓冲区。
      abstract IntBuffer IntBuffer.compact​()
      压缩此缓冲区 （可选操作） 。
      abstract IntBuffer IntBuffer.duplicate​()
      创建一个共享此缓冲区内容的新int缓冲区。
      IntBuffer IntBuffer.flip​()
      翻转这个缓冲区。
      IntBuffer IntBuffer.get​(int[] dst)
      相对批量 获取方法。
      IntBuffer IntBuffer.get​(int[] dst, int offset, int length)
      相对批量 获取方法。
      IntBuffer IntBuffer.limit​(int newLimit)
      设置此缓冲区的限制。
      IntBuffer IntBuffer.mark​()
      将此缓冲区的标记设置在其位置。
      IntBuffer IntBuffer.position​(int newPosition)
      设置这个缓冲区的位置。
      abstract IntBuffer IntBuffer.put​(int i)
      相对 放置法 （可选操作） 。
      IntBuffer IntBuffer.put​(int[] src)
      相对大容量 put方法 （可选操作） 。
      IntBuffer IntBuffer.put​(int[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      abstract IntBuffer IntBuffer.put​(int index, int i)
      绝对 put方法 （可选操作） 。
      IntBuffer IntBuffer.put​(IntBuffer src)
      相对大容量 put方法 （可选操作） 。
      IntBuffer IntBuffer.reset​()
      将此缓冲区的位置重置为先前标记的位置。
      IntBuffer IntBuffer.rewind​()
      倒带这个缓冲区。
      abstract IntBuffer IntBuffer.slice​()
      创建一个新的int缓冲区，其内容是此缓冲区内容的共享子序列。
      static IntBuffer IntBuffer.wrap​(int[] array)
      将int数组包装到缓冲区中。
      static IntBuffer IntBuffer.wrap​(int[] array, int offset, int length)
      将int数组包装到缓冲区中。
      Methods in java.nio with parameters of type IntBuffer
      Modifier and Type 方法 描述
      int IntBuffer.compareTo​(IntBuffer that)
      将此缓冲区与另一个缓冲区进
      IntBuffer IntBuffer.put​(IntBuffer src)
      相对大容量 put方法 （可选操作） 。

    • Uses of IntBuffer in javafx.scene.image

      Methods in javafx.scene.image that return types with arguments of type IntBuffer
      Modifier and Type 方法 描述
      static WritablePixelFormat<IntBuffer> PixelFormat.getIntArgbInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中以32位整数存储的像素与 非预乘数组件按顺序存储，从MSb到LSb：alpha，红，绿，蓝。
      static WritablePixelFormat<IntBuffer> PixelFormat.getIntArgbPreInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中以32位整数存储的像素，其中 预乘数组件按顺序存储，从MSb到LSb：alpha，红，绿，蓝。
      Method parameters in javafx.scene.image with type arguments of type IntBuffer
      Modifier and Type 方法 描述
      void PixelReader.getPixels​(int x, int y, int w, int h, WritablePixelFormat<IntBuffer> pixelformat, int[] buffer, int offset, int scanlineStride)
      将像素数据从表面的矩形区域读入指定的int数组。
      void PixelWriter.setPixels​(int x, int y, int w, int h, PixelFormat<IntBuffer> pixelformat, int[] buffer, int offset, int scanlineStride)
      将来自int数组的像素数据存储到表面的矩形区域中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.InvalidMarkException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.InvalidMarkException

No usage of java.nio.InvalidMarkException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.LongBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.LongBuffer

  • Packages that use LongBuffer
    软件包 描述
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of LongBuffer in java.nio

      Methods in java.nio that return LongBuffer
      Modifier and Type 方法 描述
      static LongBuffer LongBuffer.allocate​(int capacity)
      分配一个新的长缓冲区。
      abstract LongBuffer ByteBuffer.asLongBuffer​()
      将此字节缓冲区的视图创建为长缓冲区。
      abstract LongBuffer LongBuffer.asReadOnlyBuffer​()
      创建一个新的只读长缓冲区，共享此缓冲区的内容。
      LongBuffer LongBuffer.clear​()
      清除此缓冲区。
      abstract LongBuffer LongBuffer.compact​()
      压缩此缓冲区 （可选操作） 。
      abstract LongBuffer LongBuffer.duplicate​()
      创建一个新的长缓冲区，共享此缓冲区的内容。
      LongBuffer LongBuffer.flip​()
      翻转这个缓冲区。
      LongBuffer LongBuffer.get​(long[] dst)
      相对批量 获取方法。
      LongBuffer LongBuffer.get​(long[] dst, int offset, int length)
      相对批量 获取方法。
      LongBuffer LongBuffer.limit​(int newLimit)
      设置此缓冲区的限制。
      LongBuffer LongBuffer.mark​()
      将此缓冲区的标记设置在其位置。
      LongBuffer LongBuffer.position​(int newPosition)
      设置这个缓冲区的位置。
      abstract LongBuffer LongBuffer.put​(int index, long l)
      绝对 put方法 （可选操作） 。
      abstract LongBuffer LongBuffer.put​(long l)
      相对 放置法 （可选操作） 。
      LongBuffer LongBuffer.put​(long[] src)
      相对大容量 put方法 （可选操作） 。
      LongBuffer LongBuffer.put​(long[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      LongBuffer LongBuffer.put​(LongBuffer src)
      相对大容量 put方法 （可选操作） 。
      LongBuffer LongBuffer.reset​()
      将此缓冲区的位置重置为先前标记的位置。
      LongBuffer LongBuffer.rewind​()
      倒带这个缓冲区。
      abstract LongBuffer LongBuffer.slice​()
      创建一个新的长缓冲区，其内容是此缓冲区内容的共享子序列。
      static LongBuffer LongBuffer.wrap​(long[] array)
      将长阵列包装到缓冲区中。
      static LongBuffer LongBuffer.wrap​(long[] array, int offset, int length)
      将长阵列包装到缓冲区中。
      Methods in java.nio with parameters of type LongBuffer
      Modifier and Type 方法 描述
      int LongBuffer.compareTo​(LongBuffer that)
      将此缓冲区与另一个缓冲区进
      LongBuffer LongBuffer.put​(LongBuffer src)
      相对大容量 put方法 （可选操作） 。

    • Uses of LongBuffer in java.util

      Methods in java.util with parameters of type LongBuffer
      Modifier and Type 方法 描述
      static BitSet BitSet.valueOf​(LongBuffer lb)
      返回包含给定长缓冲区中其位置和极限之间的所有位的新位集合。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.MappedByteBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.MappedByteBuffer

  • Packages that use MappedByteBuffer
    软件包 描述
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

    • Uses of MappedByteBuffer in java.nio

      Methods in java.nio that return MappedByteBuffer
      Modifier and Type 方法 描述
      MappedByteBuffer MappedByteBuffer.clear​()
      清除此缓冲区。
      MappedByteBuffer MappedByteBuffer.flip​()
      翻转这个缓冲区。
      MappedByteBuffer MappedByteBuffer.force​()
      强制将此缓冲区内容的任何更改写入包含映射文件的存储设备。
      MappedByteBuffer MappedByteBuffer.limit​(int newLimit)
      设置此缓冲区的限制。
      MappedByteBuffer MappedByteBuffer.load​()
      将此缓冲区的内容加载到物理内存中。
      MappedByteBuffer MappedByteBuffer.mark​()
      将此缓冲区的标记设置在其位置。
      MappedByteBuffer MappedByteBuffer.position​(int newPosition)
      设置这个缓冲区的位置。
      MappedByteBuffer MappedByteBuffer.reset​()
      将此缓冲区的位置重置为先前标记的位置。
      MappedByteBuffer MappedByteBuffer.rewind​()
      倒带这个缓冲区。

    • Uses of MappedByteBuffer in java.nio.channels

      Methods in java.nio.channels that return MappedByteBuffer
      Modifier and Type 方法 描述
      abstract MappedByteBuffer FileChannel.map​(FileChannel.MapMode mode, long position, long size)
      将此频道文件的区域直接映射到内存中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.ReadOnlyBufferException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.ReadOnlyBufferException

No usage of java.nio.ReadOnlyBufferException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.ShortBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.ShortBuffer

  • Packages that use ShortBuffer
    软件包 描述
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。

    • Uses of ShortBuffer in java.nio

      Methods in java.nio that return ShortBuffer
      Modifier and Type 方法 描述
      static ShortBuffer ShortBuffer.allocate​(int capacity)
      分配一个新的缓冲区。
      abstract ShortBuffer ShortBuffer.asReadOnlyBuffer​()
      创建一个新的只读缓冲区，共享此缓冲区的内容。
      abstract ShortBuffer ByteBuffer.asShortBuffer​()
      将此字节缓冲区的视图创建为短缓冲区。
      ShortBuffer ShortBuffer.clear​()
      清除此缓冲区。
      abstract ShortBuffer ShortBuffer.compact​()
      压缩此缓冲区 （可选操作） 。
      abstract ShortBuffer ShortBuffer.duplicate​()
      创建一个新的缓冲区，共享此缓冲区的内容。
      ShortBuffer ShortBuffer.flip​()
      翻转这个缓冲区。
      ShortBuffer ShortBuffer.get​(short[] dst)
      相对批量 获取方法。
      ShortBuffer ShortBuffer.get​(short[] dst, int offset, int length)
      相对批量 获取方法。
      ShortBuffer ShortBuffer.limit​(int newLimit)
      设置此缓冲区的限制。
      ShortBuffer ShortBuffer.mark​()
      将此缓冲区的标记设置在其位置。
      ShortBuffer ShortBuffer.position​(int newPosition)
      设置这个缓冲区的位置。
      abstract ShortBuffer ShortBuffer.put​(int index, short s)
      绝对 put方法 （可选操作） 。
      abstract ShortBuffer ShortBuffer.put​(short s)
      相对 放置法 （可选操作） 。
      ShortBuffer ShortBuffer.put​(short[] src)
      相对大容量 put方法 （可选操作） 。
      ShortBuffer ShortBuffer.put​(short[] src, int offset, int length)
      相对大容量 put方法 （可选操作） 。
      ShortBuffer ShortBuffer.put​(ShortBuffer src)
      相对大容量 put方法 （可选操作） 。
      ShortBuffer ShortBuffer.reset​()
      将此缓冲区的位置重置为先前标记的位置。
      ShortBuffer ShortBuffer.rewind​()
      倒带这个缓冲区。
      abstract ShortBuffer ShortBuffer.slice​()
      创建一个新的短缓冲区，其内容是此缓冲区内容的共享子序列。
      static ShortBuffer ShortBuffer.wrap​(short[] array)
      将一个短阵列包装到缓冲区中。
      static ShortBuffer ShortBuffer.wrap​(short[] array, int offset, int length)
      将一个短阵列包装到缓冲区中。
      Methods in java.nio with parameters of type ShortBuffer
      Modifier and Type 方法 描述
      int ShortBuffer.compareTo​(ShortBuffer that)
      将此缓冲区与另一个缓冲区进
      ShortBuffer ShortBuffer.put​(ShortBuffer src)
      Relative bulk put method (optional operation).
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AccessDeniedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class AccessDeniedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.FileSystemException
            • java.nio.file.AccessDeniedException
  • All Implemented Interfaces:
    Serializable

    public class AccessDeniedException
extends FileSystemException
    文件系统操作被拒绝时引发的检查异常，通常是由于文件权限或其他访问检查。

    访问控制器或安全管理员在拒绝对文件进行访问时抛出的AccessControlException或SecurityException异常。

    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessDeniedException​(String file)
      构造这个类的一个实例。
      AccessDeniedException​(String file, String other, String reason)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.nio.file.FileSystemException

        getFile, getMessage, getOtherFile, getReason

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AccessDeniedException

        public AccessDeniedException​(String file)
        构造这个类的一个实例。
        参数
        file - 如果不知道，则标识文件的字符串或 null

      • AccessDeniedException

        public AccessDeniedException​(String file,
                             String other,
                             String reason)
        构造这个类的一个实例。
        参数
        file - 如果不知道，则标识文件的字符串或 null
        other - 如果不知道，则标识另一个文件的字符串或 null
        reason - 带有附加信息的原因信息或 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.nio.file

Enum AccessMode

  • java.lang.Object
    • java.lang.Enum<AccessMode>
      • java.nio.file.AccessMode
  • All Implemented Interfaces:
    Serializable ， Comparable<AccessMode>

    public enum AccessMode
extends Enum<AccessMode>
    定义用于测试文件可访问性的访问模式。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      EXECUTE
      测试执行访问。
      READ
      测试读取访问。
      WRITE
      测试写入权限

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static AccessMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AccessMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • READ

        public static final AccessMode READ
        测试读取访问。

      • WRITE

        public static final AccessMode WRITE
        测试写入权限

      • EXECUTE

        public static final AccessMode EXECUTE
        测试执行访问。

    • 方法详细信息

      • values

        public static AccessMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (AccessMode c : AccessMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static AccessMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


AtomicMoveNotSupportedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class AtomicMoveNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.FileSystemException
            • java.nio.file.AtomicMoveNotSupportedException
  • All Implemented Interfaces:
    Serializable

    public class AtomicMoveNotSupportedException
extends FileSystemException
    当文件不能作为原子文件系统操作移动时，检查的异常抛出。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicMoveNotSupportedException​(String source, String target, String reason)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.nio.file.FileSystemException

        getFile, getMessage, getOtherFile, getReason

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AtomicMoveNotSupportedException

        public AtomicMoveNotSupportedException​(String source,
                                       String target,
                                       String reason)
        构造这个类的一个实例。
        参数
        source - 如果不知道，则标识源文件的字符串或 null
        target - 如果不知道，则标识目标文件的字符串或 null
        reason - 带有附加信息的原因信息或 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClosedDirectoryStreamException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class ClosedDirectoryStreamException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.file.ClosedDirectoryStreamException
  • All Implemented Interfaces:
    Serializable

    public class ClosedDirectoryStreamException
extends IllegalStateException
    尝试在关闭的目录流上调用操作时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClosedDirectoryStreamException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClosedDirectoryStreamException

        public ClosedDirectoryStreamException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClosedFileSystemException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class ClosedFileSystemException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.file.ClosedFileSystemException
  • All Implemented Interfaces:
    Serializable

    public class ClosedFileSystemException
extends IllegalStateException
    尝试在文件上调用操作并关闭文件系统时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClosedFileSystemException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClosedFileSystemException

        public ClosedFileSystemException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClosedWatchServiceException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class ClosedWatchServiceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.nio.file.ClosedWatchServiceException
  • All Implemented Interfaces:
    Serializable

    public class ClosedWatchServiceException
extends IllegalStateException
    尝试在关闭的手表服务上调用操作时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClosedWatchServiceException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClosedWatchServiceException

        public ClosedWatchServiceException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CopyOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface CopyOption

  • 所有已知实现类：
    LinkOption ， StandardCopyOption

    public interface CopyOption
    配置如何复制或移动文件的对象。

    这种类型的对象可以与使用Files.copy(Path,Path,CopyOption...) ， Files.copy(InputStream,Path,CopyOption...)和Files.move(Path,Path,CopyOption...)方法来配置一个文件是如何复制或移动。

    StandardCopyOption枚举类型定义了标准选项。

    从以下版本开始：
    1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DirectoryIteratorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class DirectoryIteratorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.util.ConcurrentModificationException
            • java.nio.file.DirectoryIteratorException
  • All Implemented Interfaces:
    Serializable

    public final class DirectoryIteratorException
extends ConcurrentModificationException
    如果在遍历目录中的条目时遇到I / O错误，则抛出运行时异常。 使用getCause()方法检索作为IOException的I / O错误。
    从以下版本开始：
    1.7
    另请参见：
    DirectoryStream ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DirectoryIteratorException​(IOException cause)
      构造这个类的一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      IOException getCause​()
      返回此异常的原因。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • DirectoryIteratorException

        public DirectoryIteratorException​(IOException cause)
        构造这个类的一个实例。
        参数
        cause - 导致目录迭代失败的 IOException
        异常
        NullPointerException - 如果原因是 null

    • 方法详细信息

      • getCause

        public IOException getCause​()
        返回此异常的原因。
        重写：
        getCause在 Throwable
        结果
        的原因
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DirectoryNotEmptyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class DirectoryNotEmptyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.FileSystemException
            • java.nio.file.DirectoryNotEmptyException
  • All Implemented Interfaces:
    Serializable

    public class DirectoryNotEmptyException
extends FileSystemException
    由于目录不为空，文件系统操作失败时抛出的检查异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DirectoryNotEmptyException​(String dir)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.nio.file.FileSystemException

        getFile, getMessage, getOtherFile, getReason

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • DirectoryNotEmptyException

        public DirectoryNotEmptyException​(String dir)
        构造这个类的一个实例。
        参数
        dir - a string identifying the directory or null if not known
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DirectoryStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface DirectoryStream<T>

  • 参数类型
    T - 迭代器返回的元素的类型
    All Superinterfaces:
    AutoCloseable ， Closeable ， Iterable<T>
    All Known Subinterfaces:
    SecureDirectoryStream<T>

    public interface DirectoryStream<T>
extends Closeable, Iterable<T>
    一个对象来迭代目录中的条目。 目录流允许方便地使用for-each结构来遍历目录。

    虽然DirectoryStream扩展了Iterable ，但它不是通用的Iterable因为它只支持一个Iterator ; 调用iterator方法来获取第二个或后续的迭代器抛出IllegalStateException 。

    目录流Iterator一个重要属性是它的hasNext方法被保证通过至少一个元素预读。 如果hasNext方法返回true ，并且随后调用了next方法，则保证next方法不会因I / O错误而引起异常，或者因为流已经是closed 。 Iterator不支持remove操作。

    A DirectoryStream在创建时打开，并通过调用close方法关闭。 关闭目录流将释放与流相关联的任何资源。 未能关闭流可能会导致资源泄漏。 try-with-resources语句提供了一个有用的结构，以确保流被关闭：

      Path dir = ...
   try (DirectoryStream<Path> stream = Files.newDirectoryStream(dir)) {
       for (Path entry: stream) {
           ...
       }
   }

    一旦目录流关闭，则使用Iterator对目录的进一步访问就像已达到流的末尾一样。 由于Iterator读， Iterator可能会在目录流关闭后返回一个或多个元素。 一旦这些缓冲元素被读取，那么对hasNext方法的后续调用将返回false ，并且对next方法的后续调用将抛出NoSuchElementException 。

    目录流不需要异步关闭 。 如果从目录中读取的目录流的迭代器上的线程被阻塞，另一个线程调用close方法，则第二个线程可能会阻塞，直到读取操作完成。

    如果在访问目录时遇到I / O错误，则导致Iterator的hasNext或next方法以IOException作为原因抛出DirectoryIteratorException 。 如上所述， hasNext方法保证通过至少一个元素hasNext读。 这意味着如果hasNext方法返回true ，并且后跟调用next方法，则可以保证next方法不会与DirectoryIteratorException失败。

    迭代器返回的元素没有特定的顺序。 某些文件系统维护目录本身和目录的父目录的特殊链接。 代表这些链接的条目不会由迭代器返回。

    迭代器弱一致 。 它是线程安全的，但是在迭代时不冻结目录，因此它可能（或可能不）反映在创建DirectoryStream之后发生的目录的更新。

    使用示例：假设我们想要一个目录中的源文件的列表。 此示例同时使用for-each和try-with-resources构造。

      List<Path> listSourceFiles(Path dir) throws IOException {
       List<Path> result = new ArrayList<>();
       try (DirectoryStream<Path> stream = Files.newDirectoryStream(dir, "*.{c,h,cpp,hpp,java}")) {
           for (Path entry: stream) {
               result.add(entry);
           }
       } catch (DirectoryIteratorException ex) {
           // I/O error encounted during the iteration, the cause is an IOException
           throw ex.getCause();
       }
       return result;
   }
    从以下版本开始：
    1.7
    另请参见：
    Files.newDirectoryStream(Path)

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  DirectoryStream.Filter<T>
      由对象执行的接口，用于确定是否应接受或过滤目录条目。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Iterator<T> iterator​()
      返回与此 DirectoryStream关联的迭代器。

      • Methods inherited from interface java.io.Closeable

        close

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

    • 方法详细信息

      • iterator

        Iterator<T> iterator​()
        返回与此 DirectoryStream相关联的迭代器。
        Specified by:
        iterator在接口 Iterable<T>
        结果
        与此 DirectoryStream相关联的迭代器
        异常
        IllegalStateException - 如果此目录流已关闭或迭代器已被返回
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DirectoryStream.Filter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface DirectoryStream.Filter<T>

  • 参数类型
    T - 目录条目的类型
    Enclosing interface:
    DirectoryStream < T >
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public static interface DirectoryStream.Filter<T>
    由对象执行的接口，用于确定是否应接受或过滤目录条目。 甲Filter被作为参数传递给传递Files.newDirectoryStream(Path,DirectoryStream.Filter)打开一个目录遍历该目录中的条目时方法。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean accept​(T entry)
      决定是否接受或过滤给定的目录条目。

    • 方法详细信息

      • accept

        boolean accept​(T entry)
        throws IOException
        决定是否接受或过滤给定的目录条目。
        参数
        entry - 要测试的目录条目
        结果
        true如果目录条目应该被接受
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileAlreadyExistsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class FileAlreadyExistsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.FileSystemException
            • java.nio.file.FileAlreadyExistsException
  • All Implemented Interfaces:
    Serializable

    public class FileAlreadyExistsException
extends FileSystemException
    尝试创建文件或目录并且该名称的文件已存在时，检查的异常抛出。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileAlreadyExistsException​(String file)
      构造这个类的一个实例。
      FileAlreadyExistsException​(String file, String other, String reason)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.nio.file.FileSystemException

        getFile, getMessage, getOtherFile, getReason

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FileAlreadyExistsException

        public FileAlreadyExistsException​(String file)
        构造这个类的一个实例。
        参数
        file - 如果不知道，则标识文件的字符串或 null

      • FileAlreadyExistsException

        public FileAlreadyExistsException​(String file,
                                  String other,
                                  String reason)
        构造这个类的一个实例。
        参数
        file - 如果不知道，则标识文件的字符串或 null
        other - 如果不知道，则标识另一个文件的字符串或 null
        reason - 带有附加信息的原因信息或 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Files (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class Files

  • java.lang.Object
    • java.nio.file.Files

  • public final class Files
extends Object
    该类只包含对文件，目录或其他类型文件进行操作的静态方法。

    在大多数情况下，这里定义的方法将委托给相关的文件系统提供程序来执行文件操作。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static long copy​(InputStream in, Path target, CopyOption... options)
      将输入流中的所有字节复制到文件。
      static long copy​(Path source, OutputStream out)
      将文件中的所有字节复制到输出流。
      static Path copy​(Path source, Path target, CopyOption... options)
      将文件复制到目标文件。
      static Path createDirectories​(Path dir, FileAttribute<?>... attrs)
      首先创建所有不存在的父目录来创建目录。
      static Path createDirectory​(Path dir, FileAttribute<?>... attrs)
      创建一个新的目录。
      static Path createFile​(Path path, FileAttribute<?>... attrs)
      创建一个新的和空的文件，如果该文件已存在失败。
      static Path createLink​(Path link, Path existing)
      为现有文件创建新的链接（目录条目） （可选操作） 。
      static Path createSymbolicLink​(Path link, Path target, FileAttribute<?>... attrs)
      创建到目标的符号链接 （可选操作） 。
      static Path createTempDirectory​(String prefix, FileAttribute<?>... attrs)
      在默认临时文件目录中创建一个新目录，使用给定的前缀生成其名称。
      static Path createTempDirectory​(Path dir, String prefix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新目录，使用给定的前缀生成其名称。
      static Path createTempFile​(String prefix, String suffix, FileAttribute<?>... attrs)
      在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。
      static Path createTempFile​(Path dir, String prefix, String suffix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
      static void delete​(Path path)
      删除文件。
      static boolean deleteIfExists​(Path path)
      删除文件（如果存在）。
      static boolean exists​(Path path, LinkOption... options)
      测试文件是否存在。
      static Stream<Path> find​(Path start, int maxDepth, BiPredicate<Path,BasicFileAttributes> matcher, FileVisitOption... options)
      返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件来懒惰地填充 Path 。
      static Object getAttribute​(Path path, String attribute, LinkOption... options)
      读取文件属性的值。
      static <V extends FileAttributeView>
      V             		getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
      static FileStore getFileStore​(Path path)
      返回表示文件所在文件存储区的FileStore 。
      static FileTime getLastModifiedTime​(Path path, LinkOption... options)
      返回文件的上次修改时间。
      static UserPrincipal getOwner​(Path path, LinkOption... options)
      返回文件的所有者。
      static Set<PosixFilePermission> getPosixFilePermissions​(Path path, LinkOption... options)
      返回文件的POSIX文件权限。
      static boolean isDirectory​(Path path, LinkOption... options)
      测试文件是否是目录。
      static boolean isExecutable​(Path path)
      测试文件是否可执行。
      static boolean isHidden​(Path path)
      告知文件是否被 隐藏 。
      static boolean isReadable​(Path path)
      测试文件是否可读。
      static boolean isRegularFile​(Path path, LinkOption... options)
      测试文件是否是具有不透明内容的常规文件。
      static boolean isSameFile​(Path path, Path path2)
      测试两个路径是否找到相同的文件。
      static boolean isSymbolicLink​(Path path)
      测试文件是否是符号链接。
      static boolean isWritable​(Path path)
      测试文件是否可写。
      static Stream<String> lines​(Path path)
      从文件中读取所有行作为 Stream 。
      static Stream<String> lines​(Path path, Charset cs)
      从文件中读取所有行作为 Stream 。
      static Stream<Path> list​(Path dir)
      返回一个懒惰的 Stream ，其中的元素是目录中的条目。
      static Path move​(Path source, Path target, CopyOption... options)
      将文件移动或重命名为目标文件。
      static BufferedReader newBufferedReader​(Path path)
      打开一个文件进行阅读，返回一个 BufferedReader以高效的方式从文件读取文本。
      static BufferedReader newBufferedReader​(Path path, Charset cs)
      打开一个文件进行阅读，返回一个 BufferedReader ，可以用来以有效的方式从文件读取文本。
      static BufferedWriter newBufferedWriter​(Path path, Charset cs, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter ，可以用来以有效的方式将文本写入文件。
      static BufferedWriter newBufferedWriter​(Path path, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter以有效的方式写入文件。
      static SeekableByteChannel newByteChannel​(Path path, OpenOption... options)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      static SeekableByteChannel newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      static DirectoryStream<Path> newDirectoryStream​(Path dir)
      打开一个目录，返回一个DirectoryStream以遍历目录中的所有条目。
      static DirectoryStream<Path> newDirectoryStream​(Path dir, String glob)
      打开一个目录，返回一个DirectoryStream来迭代目录中的条目。
      static DirectoryStream<Path> newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个DirectoryStream以遍历目录中的条目。
      static InputStream newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。
      static OutputStream newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。
      static boolean notExists​(Path path, LinkOption... options)
      测试此路径所在的文件是否不存在。
      static String probeContentType​(Path path)
      探测文件的内容类型。
      static byte[] readAllBytes​(Path path)
      读取文件中的所有字节。
      static List<String> readAllLines​(Path path)
      从文件中读取所有行。
      static List<String> readAllLines​(Path path, Charset cs)
      从文件中读取所有行。
      static <A extends BasicFileAttributes>
      A             		readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      static Map<String,Object> readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      static Path readSymbolicLink​(Path link)
      读取符号链接的目标 （可选操作） 。
      static Path setAttribute​(Path path, String attribute, Object value, LinkOption... options)
      设置文件属性的值。
      static Path setLastModifiedTime​(Path path, FileTime time)
      更新文件上次修改的时间属性。
      static Path setOwner​(Path path, UserPrincipal owner)
      更新文件所有者。
      static Path setPosixFilePermissions​(Path path, Set<PosixFilePermission> perms)
      设置文件的POSIX权限。
      static long size​(Path path)
      返回文件的大小（以字节为单位）。
      static Stream<Path> walk​(Path start, int maxDepth, FileVisitOption... options)
      返回一个 Stream ，它是通过走在一个给定的起始文件的根文件树，它是惰性填充 Path 。
      static Stream<Path> walk​(Path start, FileVisitOption... options)
      返回一个 Stream ，它通过走出一个以给定的起始文件为根的文件树，这是惰性的 Path 。
      static Path walkFileTree​(Path start, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path walkFileTree​(Path start, Set<FileVisitOption> options, int maxDepth, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path write​(Path path, byte[] bytes, OpenOption... options)
      将字节写入文件。
      static Path write​(Path path, Iterable<? extends CharSequence> lines, Charset cs, OpenOption... options)
      将文本行写入文件。
      static Path write​(Path path, Iterable<? extends CharSequence> lines, OpenOption... options)
      将文本行写入文件。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • newInputStream

        public static InputStream newInputStream​(Path path,
                                         OpenOption... options)
                                  throws IOException
        打开一个文件，返回输入流以从文件中读取。 流不会被缓冲，不需要支持mark或reset方法。 流可以安全地访问多个并发线程。 阅读从文件开头开始。 返回的流是否异步可关闭和/或可中断是高度文件系统提供程序特定的，因此未指定。

        options参数确定文件的打开方式。 如果没有选项存在，则相当于使用READ选项打开文件。 除了READ选项之外，实现还可以支持额外的实现特定选项。

        参数
        path - 要打开文件的路径
        options - 指定文件打开方式的选项
        结果
        一个新的输入流
        异常
        IllegalArgumentException - 如果指定了无效的选项组合
        UnsupportedOperationException - 如果指定了不支持的选项
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。

      • newOutputStream

        public static OutputStream newOutputStream​(Path path,
                                           OpenOption... options)
                                    throws IOException
        打开或创建文件，返回可用于向文件写入字节的输出流。 生成的流将不被缓冲。 流可以安全地访问多个并发线程。 返回的流是否异步可关闭和/或可中断是高度文件系统提供程序特定的，因此未指定。

        此方法以newByteChannel方法指定的方式打开或创建文件，但READ选项可能不存在于选项阵列中。 如果不存在任何选项，则此方法的工作原理犹如CREATE ， TRUNCATE_EXISTING ，并WRITE个选项都存在。 换句话说，它打开写入文件，创建文件（如果不存在），或者最初截断现有的regular-file大小为0如果存在）。

        用法示例：

          Path path = ...

     // truncate and overwrite an existing file, or create the file if
     // it doesn't initially exist
     OutputStream out = Files.newOutputStream(path);

     // append to an existing file, fail if the file does not exist
     out = Files.newOutputStream(path, APPEND);

     // append to an existing file, create file if it doesn't initially exist
     out = Files.newOutputStream(path, CREATE, APPEND);

     // always create new file, failing if it already exists
     out = Files.newOutputStream(path, CREATE_NEW);
        参数
        path - 要打开或创建文件的路径
        options - 指定文件打开方式的选项
        结果
        一个新的输出流
        异常
        IllegalArgumentException - 如果 options包含选项的无效组合
        UnsupportedOperationException - 如果指定了不支持的选项
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用checkWrite方法来检查对该文件的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。

      • newByteChannel

        public static SeekableByteChannel newByteChannel​(Path path,
                                                 Set<? extends OpenOption> options,
                                                 FileAttribute<?>... attrs)
                                          throws IOException
        打开或创建文件，返回可访问的字节通道以访问该文件。

        options参数确定文件的打开方式。 READ和WRITE选项确定文件是否应打开以进行读取和/或写入。 如果两个选项（或APPEND选项）都不存在，则打开该文件进行阅读。 默认情况下，文件开始时读取或写入。

        除了READ和WRITE ，还可能存在以下选项：

        Options Option Description APPEND If this option is present then the file is opened for writing and each invocation of the channel's write method first advances the position to the end of the file and then writes the requested data. Whether the advancement of the position and the writing of the data are done in a single atomic operation is system-dependent and therefore unspecified. This option may not be used in conjunction with the READ or TRUNCATE_EXISTING options. TRUNCATE_EXISTING If this option is present then the existing file is truncated to a size of 0 bytes. This option is ignored when the file is opened only for reading. CREATE_NEW If this option is present then a new file is created, failing if the file already exists or is a symbolic link. When creating a file the check for the existence of the file and the creation of the file if it does not exist is atomic with respect to other file system operations. This option is ignored when the file is opened only for reading. CREATE If this option is present then an existing file is opened if it exists, otherwise a new file is created. This option is ignored if the CREATE_NEW option is also present or the file is opened only for reading. DELETE_ON_CLOSE When this option is present then the implementation makes a best effort attempt to delete the file when closed by the close method. If the close method is not invoked then a best effort attempt is made to delete the file when the Java virtual machine terminates. SPARSE When creating a new file this option is a hint that the new file will be sparse. This option is ignored when not creating a new file. SYNC Requires that every update to the file's content or metadata be written synchronously to the underlying storage device. (see Synchronized I/O file integrity). DSYNC Requires that every update to the file's content be written synchronously to the underlying storage device. (see Synchronized I/O file integrity).

        实现还可以支持附加的实现特定选项。

        当创建新文件时， attrs参数是可选的file-attributes以原子方式设置。

        在默认提供程序的情况下，返回的可寻找字节通道是FileChannel 。

        用法示例：

           Path path = ... // open file for reading ReadableByteChannel rbc = Files.newByteChannel(path, EnumSet.of(READ))); // open file for writing to the end of an existing file, creating // the file if it doesn't already exist WritableByteChannel wbc = Files.newByteChannel(path, EnumSet.of(CREATE,APPEND)); // create file with initial permissions, opening it for both reading and writing FileAttribute<Set<PosixFilePermission>> perms = ... SeekableByteChannel sbc = Files.newByteChannel(path, EnumSet.of(CREATE_NEW,READ,WRITE), perms);
        参数
        path - 要打开或创建文件的路径
        options - 指定文件打开方式的选项
        attrs - 创建文件时以原子方式设置的文件属性的可选列表
        结果
        一个新的可寻找字节通道
        异常
        IllegalArgumentException - 如果集合包含无效的选项组合
        UnsupportedOperationException - 如果指定了不受支持的打开选项，或者数组包含创建文件时无法原子设置的属性
        FileAlreadyExistsException - 如果该名称的文件已存在，并指定了 CREATE_NEW选项 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并且安装了一个安全管理器，则会调用checkRead方法来检查该文件是否被读取访问路径。 如果打开文件写入，则调用checkWrite方法来检查对路径的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。
        另请参见：
        FileChannel.open(Path,Set,FileAttribute[])

      • newByteChannel

        public static SeekableByteChannel newByteChannel​(Path path,
                                                 OpenOption... options)
                                          throws IOException
        打开或创建文件，返回可访问的字节通道以访问该文件。

        该方法以newByteChannel方法指定的方式打开或创建文件。

        参数
        path - 要打开或创建文件的路径
        options - 指定文件打开方式的选项
        结果
        一个新的可寻找字节通道
        异常
        IllegalArgumentException - 如果集合包含选项的无效组合
        UnsupportedOperationException - 如果指定了不受支持的打开选项
        FileAlreadyExistsException - 如果该名称的文件已存在，并指定了 CREATE_NEW选项 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并且安装了安全管理器，则会调用checkRead方法来检查对该路径的读取访问，如果该文件被打开以供阅读。 如果打开文件写入，则调用checkWrite方法来检查对路径的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。
        另请参见：
        FileChannel.open(Path,OpenOption[])

      • newDirectoryStream

        public static DirectoryStream<Path> newDirectoryStream​(Path dir)
                                                throws IOException
        打开一个目录，返回一个DirectoryStream来遍历目录中的所有条目。 由目录流iterator返回的元素的类型为Path ，每个元素表示目录中的条目。 Path对象获得，如resolving ，目录条目的名称反对dir 。

        当不使用try-with-resources构造时，应该在迭代完成之后调用目录流的close方法，以便释放保持打开目录的任何资源。

        当一个实现支持以无竞争的方式执行的目录中的条目的操作时，返回的目录流是一个SecureDirectoryStream 。

        参数
        dir - 目录的路径
        结果
        一个新的和开放的 DirectoryStream对象
        异常
        NotDirectoryException - 如果文件无法打开，因为它不是目录 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该目录的读取访问。

      • newDirectoryStream

        public static DirectoryStream<Path> newDirectoryStream​(Path dir,
                                                       String glob)
                                                throws IOException
        打开一个目录，返回一个DirectoryStream来迭代目录中的条目。 目录流iterator返回的元素的类型为Path ，每个元素表示目录中的条目。 Path对象被获取，如同通过resolving的目录条目的名称相对于dir 。 迭代器返回的条目通过将其文件名的String表示与给定的globbing模式相匹配来进行过滤。

        例如，假设我们要遍历一个目录中以“.java”结尾的文件：

          Path dir = ...
     try (DirectoryStream<Path> stream = Files.newDirectoryStream(dir, "*.java")) {
         :
     }

        球形图案由getPathMatcher方法指定。

        当不使用try-with-resources构造时，应该在迭代完成之后调用目录流的close方法，以释放保留的打开目录的任何资源。

        当一个实现支持以无竞争的方式执行的目录中的条目的操作时，返回的目录流是一个SecureDirectoryStream 。

        参数
        dir - 目录的路径
        glob - glob模式
        结果
        一个新的和开放的 DirectoryStream对象
        异常
        PatternSyntaxException - 如果模式无效
        NotDirectoryException - 如果文件无法打开，因为它不是一个目录 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该目录的读取访问。

      • newDirectoryStream

        public static DirectoryStream<Path> newDirectoryStream​(Path dir,
                                                       DirectoryStream.Filter<? super Path> filter)
                                                throws IOException
        打开一个目录，返回一个DirectoryStream以遍历目录中的条目。 目录流iterator返回的元素的类型为Path ，每个元素表示目录中的条目。 Path对象的获取方式如resolving那样 ，目录条目的名称相对于dir 。 由迭代器返回的条目由给定的filter进行过滤。

        当不使用try-with-resources构造时，应该在迭代完成之后调用目录流的close方法，以便释放保持打开目录的任何资源。

        由于未捕获的错误或运行时异常，过滤器终止，则传播到hasNext或next方法。 凡IOException被抛出，它导致hasNext或者next方法抛出DirectoryIteratorException与IOException的原因。

        当实现支持以无竞争方式执行的目录中的条目的操作时，返回的目录流是一个SecureDirectoryStream 。

        用法示例：假设我们要遍历大于8K的目录中的文件。

          DirectoryStream.Filter<Path> filter = new DirectoryStream.Filter<Path>() {
         public boolean accept(Path file) throws IOException {
             return (Files.size(file) > 8192L);
         }
     };
     Path dir = ...
     try (DirectoryStream<Path> stream = Files.newDirectoryStream(dir, filter)) {
         :
     }
        参数
        dir - 目录的路径
        filter - 目录流过滤器
        结果
        一个新的和开放的 DirectoryStream对象
        异常
        NotDirectoryException - 如果文件无法打开，因为它不是目录 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该目录的读取访问。

      • createFile

        public static Path createFile​(Path path,
                              FileAttribute<?>... attrs)
                       throws IOException
        创建一个新的和空的文件，如果该文件已存在失败。 如果文件的存在和新文件的创建（如果不存在）的检查是对可能影响目录的所有其他文件系统活动是单一的操作。

        attrs参数是可选的， file-attributes在创建文件时以原子方式设置。 每个属性由其name标识。 如果数组中包含多个同名的属性，则忽略除最后一个事件之外的所有属性。

        参数
        path - 要创建的文件的路径
        attrs - 创建文件时以原子方式设置的文件属性的可选列表
        结果
        文件
        异常
        UnsupportedOperationException - 如果数组包含创建文件时无法原子设置的属性
        FileAlreadyExistsException - 如果该名称的文件已存在 （可选特定异常）
        IOException - 如果发生I / O错误或父目录不存在
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkWrite方法来检查对新文件的写入访问。

      • createDirectory

        public static Path createDirectory​(Path dir,
                                   FileAttribute<?>... attrs)
                            throws IOException
        创建一个新的目录。 检查文件的存在和目录的创建（如果不存在）是对可能影响目录的所有其他文件系统活动是单一的操作。 应该使用createDirectories方法来首先创建所有不存在的父目录。

        attrs参数是可选的file-attributes ，可在创建目录时原子设置。 每个属性由其name标识。 如果数组中包含多个同名的属性，则忽略除最后一个事件之外的所有属性。

        参数
        dir - 要创建的目录
        attrs - 创建目录时以原子方式设置的文件属性的可选列表
        结果
        目录
        异常
        UnsupportedOperationException - 如果数组包含创建目录时无法原子设置的属性
        FileAlreadyExistsException - 如果无法创建目录，因为该名称的文件已存在 （可选的特殊异常）
        IOException - 如果发生I / O错误或父目录不存在
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkWrite方法来检查对新目录的写入访问。

      • createDirectories

        public static Path createDirectories​(Path dir,
                                     FileAttribute<?>... attrs)
                              throws IOException
        首先创建所有不存在的父目录来创建目录。 与createDirectory方法不同，如果目录无法创建，因为它已经存在，则不会抛出异常。

        attrs参数是可选的， file-attributes可以在创建不存在的目录时原子设置。 每个文件属性由其name标识。 如果数组中包含多个同名的属性，则忽略除最后一个事件之外的所有属性。

        如果此方法失败，则可能会在创建一些但不是全部的父目录之后执行此操作。

        参数
        dir - 要创建的目录
        attrs - 创建目录时原子设置的文件属性的可选列表
        结果
        目录
        异常
        UnsupportedOperationException - 如果数组包含创建目录时不能以原子方式设置的属性
        FileAlreadyExistsException - 如果存在 dir但不是目录 （可选的特定异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了安全管理器，将在尝试创建目录之前调用checkWrite方法，并为每个检查的父目录调用其checkRead 。 如果dir不是绝对路径，那么它的toAbsolutePath可能需要被调用来获取其绝对路径。 这可能会调用安全管理员的checkPropertyAccess方法来检查对系统属性的访问user.dir

      • createTempFile

        public static Path createTempFile​(Path dir,
                                  String prefix,
                                  String suffix,
                                  FileAttribute<?>... attrs)
                           throws IOException
        在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。 所得到的Path与给定目录相同的FileSystem 。

        关于如何构造文件的名称的细节是依赖于实现的，因此不被指定。 在可能的情况下， prefix和suffix用于以与File.createTempFile(String,String,File)方法相同的方式构建候选名称。

        与File.createTempFile方法一样，此方法只是临时文件设施的一部分。 当用作工作文件时 ，可以使用DELETE_ON_CLOSE选项打开生成的文件，以便在调用适当的close方法时删除该文件。 或者，可以使用shutdown-hook或File.deleteOnExit()机制自动删除文件。

        attrs参数是可选的， file-attributes在创建文件时以原子方式设置。 每个属性由其name标识。 如果数组中包含多个同名的属性，则忽略除最后一个事件之外的所有属性。 当没有指定文件属性时，生成的文件可能对由File.createTempFile(String,String,File)方法创建的文件具有更多的限制性访问权限。

        参数
        dir - 创建文件的目录路径
        prefix - 用于生成文件名的前缀字符串; 可能是null
        suffix - 用于生成文件名的后缀字符串; 可以是null ，在这种情况下使用“ .tmp ”
        attrs - 创建文件时以原子方式设置的文件属性的可选列表
        结果
        在调用此方法之前，新创建的文件的路径不存在
        异常
        IllegalArgumentException - 如果前缀或后缀参数不能用于生成候选文件名
        UnsupportedOperationException - 如果数组包含创建目录时无法原子设置的属性
        IOException - 如果发生I / O错误或 dir不存在
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 checkWrite方法来检查对该文件的写入访问。

      • createTempFile

        public static Path createTempFile​(String prefix,
                                  String suffix,
                                  FileAttribute<?>... attrs)
                           throws IOException
        在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。 结果Path与默认FileSystem相关联。

        对于dir参数是临时文件目录的情况，此方法的工作方式与createTempFile(Path,String,String,FileAttribute[])方法规定的方式完全相同。

        参数
        prefix - 用于生成文件名的前缀字符串; 可能是null
        suffix - 用于生成文件名称的后缀字符串; 可以是null ，在这种情况下使用“ .tmp ”
        attrs - 创建文件时以原子方式设置的文件属性的可选列表
        结果
        在调用此方法之前，新创建的文件的路径不存在
        异常
        IllegalArgumentException - 如果前缀或后缀参数不能用于生成候选文件名
        UnsupportedOperationException - 如果数组包含创建目录时无法原子设置的属性
        IOException - 如果发生I / O错误或临时文件目录不存在
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkWrite方法来检查对该文件的写入访问。

      • createTempDirectory

        public static Path createTempDirectory​(Path dir,
                                       String prefix,
                                       FileAttribute<?>... attrs)
                                throws IOException
        在指定的目录中创建一个新目录，使用给定的前缀生成其名称。 所得到的Path与给定目录相同的FileSystem 。

        关于如何构造目录的名称的细节是依赖于实现的，因此不被指定。 在可能的情况下， prefix用于构建候选名称。

        与createTempFile方法一样，此方法只是临时文件设施的一部分。 A shutdown-hook或File.deleteOnExit()机制可能会自动删除目录。

        attrs参数是可选的， file-attributes在创建目录时设置为原子。 每个属性由其name标识。 如果数组中包含多个同名的属性，则忽略除最后一个事件之外的所有属性。

        参数
        dir - 创建目录的目录路径
        prefix - 用于生成目录名称的前缀字符串; 可以是null
        attrs - 创建目录时原子设置的文件属性的可选列表
        结果
        在调用此方法之前，新创建的目录的路径不存在
        异常
        IllegalArgumentException - 如果前缀不能用于生成候选目录名称
        UnsupportedOperationException - 如果数组包含在创建目录时无法原子设置的属性
        IOException - 如果发生I / O错误或 dir不存在
        SecurityException - 在默认提供程序和安全管理器的情况下，调用 checkWrite方法以在创建目录时检查写访问。

      • createTempDirectory

        public static Path createTempDirectory​(String prefix,
                                       FileAttribute<?>... attrs)
                                throws IOException
        在默认临时文件目录中创建一个新目录，使用给定的前缀生成其名称。 所得到的Path与默认值FileSystem相关联。

        对于dir参数是临时文件目录的情况，此方法的工作方式与createTempDirectory(Path,String,FileAttribute[])方法所指定的方式完全相同。

        参数
        prefix - 用于生成目录名称的前缀字符串; 可能是null
        attrs - 创建目录时以原子方式设置的文件属性的可选列表
        结果
        在调用此方法之前，新创建的目录的路径不存在
        异常
        IllegalArgumentException - 如果前缀不能用于生成候选目录名称
        UnsupportedOperationException - 如果数组包含创建目录时无法原子设置的属性
        IOException - 如果发生I / O错误或临时文件目录不存在
        SecurityException - 在默认提供程序和安全管理器的情况下，调用 checkWrite方法以在创建目录时检查写访问。

      • createSymbolicLink

        public static Path createSymbolicLink​(Path link,
                                      Path target,
                                      FileAttribute<?>... attrs)
                               throws IOException
        创建到目标的符号链接（可选操作） 。

        target参数是链接的目标。 它可能是一个absolute或相对路径，可能不存在。 当目标是相对路径时，生成的链接上的文件系统操作相对于链接的路径。

        attrs参数是可选的， attributes在创建链接时设置为原子。 每个属性由其name标识。 如果数组中包含多个同名的属性，则忽略除最后一个事件之外的所有属性。

        在支持符号链接的地方，但底层的FileStore不支持符号链接，那么这可能会与IOException失败。 另外，一些操作系统可能要求Java虚拟机启动具有实现特定权限来创建符号链接，在这种情况下，此方法可能会抛出IOException 。

        参数
        link - 要创建的符号链接的路径
        target - 符号链接的目标
        attrs - 创建符号链接时以原子方式设置的属性数组
        结果
        到符号链接的路径
        异常
        UnsupportedOperationException - 如果实现不支持符号链接，或者数组包含在创建符号链接时无法原子地设置的属性
        FileAlreadyExistsException - 如果名称已经存在的文件 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，它将拒绝LinkPermission ("symbolic")或其checkWrite方法拒绝对符号链接的路径的写入访问。

      • createLink

        public static Path createLink​(Path link,
                              Path existing)
                       throws IOException
        为现有文件创建新的链接（目录条目） （可选操作） 。

        link参数定位要创建的目录条目。 existing参数是现有文件的路径。 此方法为文件创建一个新的目录条目，以便可以使用link作为路径来访问该目录条目。 在某些文件系统中，这被称为创建“硬链接”。 是否为文件或每个目录条目维护文件属性是文件系统特定的，因此未指定。 通常，文件系统要求文件的所有链接（目录条目）都在同一文件系统上。 此外，在某些平台上，Java虚拟机可能需要以实现特定权限启动以创建硬链接或创建到目录的链接。

        参数
        link - 要创建的链接（目录条目）
        existing - 现有文件的路径
        结果
        链接的路径（目录条目）
        异常
        UnsupportedOperationException - 如果实现不支持将现有文件添加到目录中
        FileAlreadyExistsException - 如果由于该名称的文件已存在，否则无法创建该条目 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 对于默认提供程序和安全管理器，它将拒绝LinkPermission ("hard")或其checkWrite方法拒绝对链接或现有文件的写入访问。

      • delete

        public static void delete​(Path path)
                   throws IOException
        删除文件。

        实现可能需要检查文件以确定文件是否是目录。 因此，这种方法对于其他文件系统操作可能不是原子的。 如果文件是符号链接，那么符号链接本身而不是链接的最终目标被删除。

        如果文件是目录，那么该目录必须为空。 在某些实现中，目录具有创建目录时创建的特殊文件或链接的条目。 在这种实现中，只有特殊条目存在时，目录被认为是空的。 该方法可以与walkFileTree方法一起使用，以删除目录和目录中的所有条目，或者需要的整个文件树 。

        在某些操作系统上，当文件打开并被该Java虚拟机或其他程序使用时，可能无法删除文件。

        参数
        path - 要删除的文件的路径
        异常
        NoSuchFileException - 如果文件不存在 （可选的特殊异常）
        DirectoryNotEmptyException - 如果文件是一个目录，并且由于目录不为空，否则无法删除 （可选的特定异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 SecurityManager.checkDelete(String)方法来检查对该文件的删除访问

      • deleteIfExists

        public static boolean deleteIfExists​(Path path)
                              throws IOException
        删除文件（如果存在）。

        与delete(Path)方法一样，实现可能需要检查文件以确定文件是否是目录。 因此，这种方法对于其他文件系统操作可能不是原子的。 如果文件是符号链接，那么符号链接本身而不是链接的最终目标被删除。

        如果文件是目录，那么该目录必须为空。 在某些实现中，目录具有创建目录时创建的特殊文件或链接的条目。 在这种实现中，只有特殊条目存在时，目录被认为是空的。

        在某些操作系统上，当文件打开并被该Java虚拟机或其他程序使用时，可能无法删除文件。

        参数
        path - 要删除的文件的路径
        结果
        true如果文件被该方法删除; false如果文件不存在，则无法删除
        异常
        DirectoryNotEmptyException - 如果文件是一个目录，并且由于目录不为空而无法删除 （可选的特定异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 SecurityManager.checkDelete(String)方法来检查对该文件的删除访问。

      • copy

        public static Path copy​(Path source,
                        Path target,
                        CopyOption... options)
                 throws IOException
        将文件复制到目标文件。

        此方法将文件复制到目标文件，其中options参数指定如何执行副本。 默认情况下，如果目标文件已经存在或者是符号链接，则副本将失败，除非源和目标是same文件， 否则该方法在没有复制文件的情况下完成。 文件属性不需要复制到目标文件。 如果支持符号链接，并且文件是符号链接，那么链接的最终目标将被复制。 如果文件是目录，那么它将在目标位置创建一个空目录（目录中的条目不被复制）。 该方法可以与walkFileTree方法一起使用，以复制目录和目录中的所有条目，或者需要的整个文件树 。

        options参数可能包括以下任何一项：

        Options Option Description REPLACE_EXISTING If the target file exists, then the target file is replaced if it is not a non-empty directory. If the target file exists and is a symbolic link, then the symbolic link itself, not the target of the link, is replaced. COPY_ATTRIBUTES Attempts to copy the file attributes associated with this file to the target file. The exact file attributes that are copied is platform and file system dependent and therefore unspecified. Minimally, the last-modified-time is copied to the target file if supported by both the source and target file stores. Copying of file timestamps may result in precision loss. NOFOLLOW_LINKS Symbolic links are not followed. If the file is a symbolic link, then the symbolic link itself, not the target of the link, is copied. It is implementation specific if file attributes can be copied to the new link. In other words, the COPY_ATTRIBUTES option may be ignored when copying a symbolic link.

        该接口的实现可以支持附加的实现特定选项。

        复制文件不是原子操作。 如果抛出一个IOException ，则目标文件可能不完整，或者某些文件属性尚未从源文件复制。 当指定了REPLACE_EXISTING选项并且目标文件存在时，将替换目标文件。 对于其他文件系统活动，检查文件的存在和创建新文件可能不是原子的。

        使用示例：假设我们要将文件复制到目录中，给出与源文件相同的文件名：

          Path source = ...
     Path newdir = ...
     Files.copy(source, newdir.resolve(source.getFileName());
        参数
        source - 要复制的文件的路径
        target - 目标文件的路径（可能与源路径的不同提供程序相关联）
        options - 指定应如何完成副本的选项
        结果
        目标文件的路径
        异常
        UnsupportedOperationException - 如果数组包含不支持的副本选项
        FileAlreadyExistsException - 如果目标文件存在但无法替换，因为未指定 REPLACE_EXISTING选项 （可选特定异常）
        DirectoryNotEmptyException - 指定了 REPLACE_EXISTING选项，但由于它是非空目录 （可选的特殊异常），因此无法替换该文件。
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，调用checkRead方法来检查对源文件的读取访问，调用checkWrite以检查对目标文件的写入访问。 如果复制了符号链接，则调用安全管理器来检查LinkPermission ("symbolic") 。

      • move

        public static Path move​(Path source,
                        Path target,
                        CopyOption... options)
                 throws IOException
        将文件移动或重命名为目标文件。

        默认情况下，该方法尝试将文件移动到目标文件，如果目标文件存在，则失败，除非源和目标是same文件，在这种情况下，此方法不起作用。 如果文件是符号链接，则符号链接本身，而不是链接的目标被移动。 可以调用此方法来移动空目录。 在某些实现中，目录具有创建目录时创建的特殊文件或链接的条目。 在这种实现中，只有特殊条目存在时，目录被认为是空的。 当调用移动不为空的目录时，如果不需要移动目录中的条目，则该目录将被移动。 例如，重命名相同的目录FileStore通常不需要移动目录中的条目。 当移动目录时，需要移动目录，否则此方法将失败（通过抛出一个IOException ）。 移动文件树可能涉及复制而不是移动目录，这可以使用copy方法与Files.walkFileTree实用程序方法相结合。

        options参数可能包括以下任何一项：

        Options Option Description REPLACE_EXISTING If the target file exists, then the target file is replaced if it is not a non-empty directory. If the target file exists and is a symbolic link, then the symbolic link itself, not the target of the link, is replaced. ATOMIC_MOVE The move is performed as an atomic file system operation and all other options are ignored. If the target file exists then it is implementation specific if the existing file is replaced or this method fails by throwing an IOException. If the move cannot be performed as an atomic file system operation then AtomicMoveNotSupportedException is thrown. This can arise, for example, when the target location is on a different FileStore and would require that the file be copied, or target location is associated with a different provider to this object.

        该接口的实现可以支持附加的实现特定选项。

        如果源文件和目标文件存储都支持，移动文件将复制last-modified-time到目标文件。 复制文件时间戳可能导致精度损失。 实现也可以尝试复制其他文件属性，但如果文件属性无法复制，则不需要它们失败。 当作为非原子操作执行移动，并且抛出IOException ，则未定义文件的状态。 原始文件和目标文件都可能存在，目标文件可能不完整，或者某些文件属性可能未被复制到原始文件中。

        使用示例：假设我们要将文件重命名为“newname”，将文件保留在同一目录中：

          Path source = ...
     Files.move(source, source.resolveSibling("newname"));
        或者，假设我们要将文件移动到新目录，保留相同的文件名，并替换目录中该名称的任何现有文件：
          Path source = ...
     Path newdir = ...
     Files.move(source, newdir.resolve(source.getFileName()), REPLACE_EXISTING);
        参数
        source - 要移动的文件的路径
        target - 目标文件的路径（可能与源路径的不同提供程序相关联）
        options - 指定如何执行移动的选项
        结果
        目标文件的路径
        异常
        UnsupportedOperationException - 如果数组包含不支持的副本选项
        FileAlreadyExistsException - 如果目标文件存在但无法替换，因为未指定 REPLACE_EXISTING选项 （可选特定异常）
        DirectoryNotEmptyException - 指定了 REPLACE_EXISTING选项，但由于它是非空目录 （可选的特定异常），因此无法替换该文件。
        AtomicMoveNotSupportedException - 如果options数组包含 ATOMIC_MOVE选项，但该文件不能作为原子文件系统操作移动。
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkWrite方法来检查对源文件和目标文件的写入访问。

      • readSymbolicLink

        public static Path readSymbolicLink​(Path link)
                             throws IOException
        读取符号链接的目标（可选操作） 。

        如果文件系统支持symbolic links，则该方法用于读取链接的目标，如果文件不是符号链接，则失败。 链接的目标不需要存在。 返回的Path对象将与link相同的文件系统。

        参数
        link - 符号链接的路径
        结果
        表示链接目标的 Path对象
        异常
        UnsupportedOperationException - 如果实现不支持符号链接
        NotLinkException - 如果目标文件不能被读取，因为该文件不是符号链接 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供者，并且安装了一个安全管理器，它将检查 FilePermission是否被授予“ readlink ”操作以读取该链接。

      • getFileStore

        public static FileStore getFileStore​(Path path)
                              throws IOException
        返回表示文件所在文件存储区的FileStore 。

        一旦获得对FileStore的引用，如果对FileStore获取的返回的FileStore或FileStoreAttributeView对象的操作继续依赖于文件的存在，则它是实现特定的。 特别地，对于文件被删除或移动到不同的文件存储的情况，没有定义行为。

        参数
        path - 文件的路径
        结果
        存储文件的文件存储区
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，调用checkRead方法来检查对该文件的读取访问，此外还检查RuntimePermission ("getFileStoreAttributes")

      • isSameFile

        public static boolean isSameFile​(Path path,
                                 Path path2)
                          throws IOException
        测试两个路径是否找到相同的文件。

        如果Path对象都是equal，那么此方法返回true而不检查文件是否存在。 如果两个Path对象与不同的提供者关联，则此方法返回false 。 否则，此方法将检查Path对象是否找到相同的文件，并且根据实现，可能需要打开或访问这两个文件。

        如果文件系统和文件保持静态，则该方法实现非空值Paths的等价关系。

        • 自反性 ：为Path f ， isSameFile(f,f)应该返回true 。
        • 它是对称的 ：两个Paths f和g ， isSameFile(f,g)将等于isSameFile(g,f) 。
        • 传递性 ：三Paths f ， g ，并h ，如果isSameFile(f,g)回报true和isSameFile(g,h)回报true ，然后isSameFile(f,h)将返回true 。
        参数
        path - 文件的一个路径
        path2 - 其他路径
        结果
        true如果，并且只有当两个路径找到相同的文件
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对这两个文件的读取访问。
        另请参见：
        BasicFileAttributes.fileKey()

      • isHidden

        public static boolean isHidden​(Path path)
                        throws IOException
        告知文件是否被隐藏 。 隐藏的确切定义是平台或提供者依赖。 在UNIX上，例如，如果文件的名称以句点（'。'）开头，则视为隐藏文件。 在Windows上，如果文件不是目录，并且设置了DOS hidden属性，则文件被认为是隐藏的。

        根据该方法可能需要访问文件系统以确定该文件是否被视为隐藏的实现。

        参数
        path - 要测试文件的路径
        结果
        true如果文件被认为是隐藏的
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 checkRead方法来检查对该文件的读取访问。

      • probeContentType

        public static String probeContentType​(Path path)
                               throws IOException
        探测文件的内容类型。

        此方法使用安装的FileTypeDetector实现来探测给定文件以确定其内容类型。 调用每个文件类型检测器的probeContentType ，然后调用文件类型。 如果文件被识别，则返回内容类型。 如果任何安装的文件类型检测器无法识别该文件，则会调用系统默认文件类型检测器来猜测内容类型。

        给定的Java虚拟机的调用维护一个系统范围的文件类型检测器列表。 安装的文件类型检测器使用由ServiceLoader类定义的服务提供程序加载工具进行加载。 使用系统类加载器加载安装的文件类型检测器。 如果无法找到系统类加载器，则使用平台类加载器。 文件类型检测器通常安装在应用程序类路径上的JAR文件中，JAR文件包含资源目录META-INF/services名为java.nio.file.spi.FileTypeDetector的提供程序配置文件，该文件列出了一个或多个具体子类的完全限定名称的FileTypeDetector具有零参数构造函数。 如果定位或实例化安装的文件类型检测器的过程失败，则会抛出未指定的错误。 安装提供商所在的订购是具体的实现。

        此方法的返回值是由RFC 2045: Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies定义的多用途Internet邮件扩展（MIME）内容类型的值的字符串形式。 根据RFC中的语法，字符串保证是可解析的。

        参数
        path - 要探测的文件的路径
        结果
        文件的内容类型，如果内容类型无法确定， null
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝文件类型检测器实现所需的未指定权限。

      • getFileAttributeView

        public static <V extends FileAttributeView> V getFileAttributeView​(Path path,
                                                                   Class<V> type,
                                                                   LinkOption... options)
        返回给定类型的文件属性视图。

        文件属性视图提供一组文件属性的只读或可更新视图。 该方法旨在用于文件属性视图定义类型安全方法来读取或更新文件属性。 type参数是所需的属性视图的类型，如果支持该方法，该方法返回该类型的实例。 BasicFileAttributeView类型支持访问文件的基本属性。 调用此方法来选择该类型的文件属性视图将始终返回该类的实例。

        options数组可以用于指示如果文件是符号链接的情况，则生成的文件属性视图如何处理符号链接。 默认情况下，遵循符号链接。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。 此选项被不支持符号链接的实现忽略。

        使用示例：假设我们想要读取或设置文件的ACL，如果支持的话：

          Path path = ...
     AclFileAttributeView view = Files.getFileAttributeView(path, AclFileAttributeView.class);
     if (view != null) {
         List<AclEntry> acl = view.getAcl();
         :
     }
        参数类型
        V - FileAttributeView类型
        参数
        path - 文件的路径
        type - 对应于文件属性视图的 Class对象
        options - 表示如何处理符号链接的选项
        结果
        指定类型的文件属性视图，如果属性视图类型不可用， null

      • readAttributes

        public static <A extends BasicFileAttributes> A readAttributes​(Path path,
                                                               Class<A> type,
                                                               LinkOption... options)
                                                        throws IOException
        读取文件的属性作为批量操作。

        type参数是所需属性的类型，如果支持，此方法返回该类型的实例。 所有实现都支持一组基本的文件属性，因此使用type参数BasicFileAttributes.class调用此方法将不会抛出UnsupportedOperationException 。

        options数组可用于指示如何处理符号链接，以便文件是符号链接的情况。 默认情况下，遵循符号链接，并读取链接的最终目标的文件属性。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。

        如果所有文件属性都被读取为相对于其他文件系统操作的原子操作，则是实现特定的。

        使用示例：假设我们要批量读取文件的属性：

          Path path = ...
    BasicFileAttributes attrs = Files.readAttributes(path, BasicFileAttributes.class);
        或者，假设我们想要读取文件的POSIX属性，而不需要遵循符号链接：
          PosixFileAttributes attrs =
        Files.readAttributes(path, PosixFileAttributes.class, NOFOLLOW_LINKS);
        参数类型
        A - BasicFileAttributes类型
        参数
        path - 文件的路径
        type - 需要阅读的文件属性的 Class
        options - 表示如何处理符号链接的选项
        结果
        文件属性
        异常
        UnsupportedOperationException - 如果不支持给定类型的属性
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了安全管理器，调用其checkRead方法来检查对该文件的读取访问。 如果调用此方法来读取安全敏感属性，则可能会调用安全管理器来检查其他权限。

      • setAttribute

        public static Path setAttribute​(Path path,
                                String attribute,
                                Object value,
                                LinkOption... options)
                         throws IOException
        设置文件属性的值。

        attribute参数标识要设置的属性，并采取以下格式：

        [ view-name :] attribute-name
        其中方括号[...]描绘可选组件，字符':'代表自身。

        view-name是标识一组文件属性的FileAttributeView的name 。 如果未指定，则默认为"basic" ，该文件属性视图的名称标识许多文件系统通用的基本文件属性集。 attribute-name是集合中属性的名称。

        options数组可用于指示如果文件是符号链接的情况下，如何处理符号链接。 默认情况下，遵循符号链接，并设置链接的最终目标的文件属性。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。

        使用示例：假设我们要设置DOS“隐藏”属性：

          Path path = ...
    Files.setAttribute(path, "dos:hidden", true);
        参数
        path - 文件的路径
        attribute - 要设置的属性
        value - 属性值
        options - 表示如何处理符号链接的选项
        结果
        给定的路径
        异常
        UnsupportedOperationException - 如果属性视图不可用
        IllegalArgumentException - 如果属性名称未指定或无法识别，或属性值是正确的类型但具有不适当的值
        ClassCastException - 如果属性值不是预期类型，或者是包含不是预期类型的元素的集合
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，并安装了安全管理器，其checkWrite方法拒绝对该文件的写入访问。 如果调用此方法来设置安全敏感属性，则可以调用安全管理器以检查其他权限。

      • getAttribute

        public static Object getAttribute​(Path path,
                                  String attribute,
                                  LinkOption... options)
                           throws IOException
        读取文件属性的值。

        attribute参数标识要读取的属性，并采取以下格式：

        [ view-name :] attribute-name
        其中方括号[...]描绘可选组件，而字符':'代表自身。

        view-name是标识一组文件属性的FileAttributeView的name 。 如果未指定，则默认为"basic" ，该文件属性视图的名称标识了许多文件系统通用的基本文件属性集。 attribute-name是属性的名称 。

        options阵列可用于指示如何处理符号链接，以便文件是符号链接的情况。 默认情况下，遵循符号链接，并读取链接的最终目标的文件属性。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。

        使用示例：假设我们需要在支持“ unix ”视图的系统上的文件所有者的用户ID：

          Path path = ...
    int uid = (Integer)Files.getAttribute(path, "unix:uid");
        参数
        path - 文件的路径
        attribute - 要读取的属性
        options - 表示如何处理符号链接的选项
        结果
        属性值
        异常
        UnsupportedOperationException - 如果属性视图不可用
        IllegalArgumentException - 如果属性名称未指定或无法识别
        IOException - 如果发生I / O错误
        SecurityException - 对于默认提供程序和安全管理器，其checkRead方法拒绝对该文件的读取访问。 如果调用此方法来读取安全敏感属性，则可以调用安全管理器来检查其他权限。

      • readAttributes

        public static Map<String,Object> readAttributes​(Path path,
                                                String attributes,
                                                LinkOption... options)
                                         throws IOException
        读取一组文件属性作为批量操作。

        attributes参数标识要读取的属性，并采取以下格式：

        [ view-name :] attribute-list
        其中方括号[...]描绘可选组件，字符':'表示自身。

        view-name是标识一组文件属性的FileAttributeView的name 。 如果未指定，则默认为"basic" ，该文件属性视图的名称标识了许多文件系统通用的基本文件属性集。

        属性列表组件是要读取的一个或多个属性名称的逗号分隔列表。 如果列表包含值"*"则会读取所有属性。 不支持的属性将被忽略，不会显示在返回的映射中。 如果所有属性都被读取为相对于其他文件系统操作的原子操作，则是实现特定的。

        以下示例说明了attributes参数的可能值：

        Possible values
        "*" Read all basic-file-attributes.
        "size,lastModifiedTime,lastAccessTime" | Reads the file size, last modified time, and last access time attributes.
        "posix:*" | Read all POSIX-file-attributes.
        "posix:permissions,owner,size" | Reads the POSIX file permissions, owner, and file size.

        options阵列可用于指示如何处理符号链接，以便文件是符号链接的情况。 默认情况下，遵循符号链接，并读取链接的最终目标的文件属性。 如果选项NOFOLLOW_LINKS存在，则不遵循符号链接。

        参数
        path - 文件的路径
        attributes - 要读取的属性
        options - 表示如何处理符号链接的选项
        结果
        返回属性的地图; 地图的键是属性名称，其值是属性值
        异常
        UnsupportedOperationException - 如果属性视图不可用
        IllegalArgumentException - 如果没有指定属性或指定了无法识别的属性
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，其checkRead方法拒绝对该文件的读取访问。 如果调用此方法来读取安全敏感属性，则可能会调用安全管理器来检查其他权限。

      • getPosixFilePermissions

        public static Set<PosixFilePermission> getPosixFilePermissions​(Path path,
                                                               LinkOption... options)
                                                        throws IOException
        返回文件的POSIX文件权限。

        path参数与支持PosixFileAttributeView的FileSystem相关联。 该属性视图提供对通常与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件相关联的文件属性的访问。

        options数组可用于指示如何处理符号链接，以便文件是符号链接的情况。 默认情况下，遵循符号链接，并读取链接的最终目标的文件属性。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。

        参数
        path - 文件的路径
        options - 指示如何处理符号链接的选项
        结果
        文件权限
        异常
        UnsupportedOperationException - 如果相关的文件系统不支持 PosixFileAttributeView
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，它将拒绝RuntimePermission ("accessUserInformation")或其checkRead方法拒绝对该文件的读取访问。

      • setPosixFilePermissions

        public static Path setPosixFilePermissions​(Path path,
                                           Set<PosixFilePermission> perms)
                                    throws IOException
        设置文件的POSIX权限。

        path参数与支持PosixFileAttributeView的FileSystem相关联。 该属性视图提供对通常与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件相关联的文件属性的访问。

        参数
        path - 文件的路径
        perms - 新的权限集
        结果
        给定的路径
        异常
        UnsupportedOperationException - 如果相关的文件系统不支持 PosixFileAttributeView
        ClassCastException - 如果集合包含不是类型 PosixFilePermission
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，它将拒绝RuntimePermission ("accessUserInformation")或其checkWrite方法拒绝对该文件的写入访问。

      • getOwner

        public static UserPrincipal getOwner​(Path path,
                                     LinkOption... options)
                              throws IOException
        返回文件的所有者。

        path参数与支持FileOwnerAttributeView的文件系统相关联。 此文件属性视图提供对文件所有者的文件属性的访问。

        参数
        path - 文件的路径
        options - 指示如何处理符号链接的选项
        结果
        代表文件所有者的用户主体
        异常
        UnsupportedOperationException - 如果相关的文件系统不支持 FileOwnerAttributeView
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，它将拒绝RuntimePermission ("accessUserInformation")或其checkRead方法拒绝对该文件的读取访问。

      • setOwner

        public static Path setOwner​(Path path,
                            UserPrincipal owner)
                     throws IOException
        更新文件所有者。

        path参数与支持FileOwnerAttributeView的文件系统相关联。 此文件属性视图提供对文件所有者的文件属性的访问。

        使用示例：假设我们要让“joe”文件的所有者：

          Path path = ...
     UserPrincipalLookupService lookupService =
         provider(path).getUserPrincipalLookupService();
     UserPrincipal joe = lookupService.lookupPrincipalByName("joe");
     Files.setOwner(path, joe);
        参数
        path - 文件的路径
        owner - 新的文件所有者
        结果
        给定的路径
        异常
        UnsupportedOperationException - 如果相关的文件系统不支持 FileOwnerAttributeView
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，它将拒绝RuntimePermission ("accessUserInformation")或其checkWrite方法拒绝对该文件的写入访问。
        另请参见：
        FileSystem.getUserPrincipalLookupService() ， UserPrincipalLookupService

      • isSymbolicLink

        public static boolean isSymbolicLink​(Path path)
        测试文件是否是符号链接。

        其中要求区分该文件是不是一个符号链接，则文件属性可以与被读取的情况下的I / O异常readAttributes方法，并与所测试的文件类型BasicFileAttributes.isSymbolicLink()方法。

        参数
        path - 文件的路径
        结果
        true如果文件是符号链接; false如果文件不存在，不是符号链接，或者无法确定文件是否是符号链接。
        异常
        SecurityException - 在默认提供程序的情况下，安装了安全管理器，其 checkRead方法拒绝对该文件的读取访问。

      • isDirectory

        public static boolean isDirectory​(Path path,
                                  LinkOption... options)
        测试文件是否是目录。

        options数组可用于指示如何处理符号链接，以便文件是符号链接的情况。 默认情况下，遵循符号链接，并读取链接的最终目标的文件属性。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。

        其中要求区分该文件是不是一个目录，则文件属性可以与被读取的情况下的I / O异常readAttributes方法，并与所测试的文件类型BasicFileAttributes.isDirectory()方法。

        参数
        path - 要测试的文件的路径
        options - 表示如何处理符号链接的选项
        结果
        true如果文件是一个目录; false如果该文件不存在，不是一个目录，或者该文件是否是目录无法确定。
        异常
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，其 checkRead方法拒绝对该文件的读取访问。

      • isRegularFile

        public static boolean isRegularFile​(Path path,
                                    LinkOption... options)
        测试文件是否是具有不透明内容的常规文件。

        options阵列可用于指示如何处理符号链接，以便文件是符号链接的情况。 默认情况下，遵循符号链接，并读取链接的最终目标的文件属性。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。

        其中要求区分该文件是不是一个普通文件，则文件属性可以与被读取的情况下的I / O异常readAttributes方法，并与所测试的文件类型BasicFileAttributes.isRegularFile()方法。

        参数
        path - 文件的路径
        options - 表示如何处理符号链接的选项
        结果
        true如果文件是普通文件; false如果文件不存在，不是常规文件，或者无法确定文件是否为普通文件。
        异常
        SecurityException - 在默认提供程序和安全管理器的情况下，其 checkRead方法拒绝对该文件的读取访问。

      • getLastModifiedTime

        public static FileTime getLastModifiedTime​(Path path,
                                           LinkOption... options)
                                    throws IOException
        返回文件的上次修改时间。

        options数组可用于指示如何处理符号链接，以便文件是符号链接的情况。 默认情况下，遵循符号链接，并读取链接的最终目标的文件属性。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。

        参数
        path - 文件的路径
        options - 指示如何处理符号链接的选项
        结果
        表示上次修改文件的时间的 FileTime或指定文件系统不支持上次修改时间的时间戳的实现特定默认值
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，其 checkRead方法拒绝对该文件的读取访问。
        另请参见：
        BasicFileAttributes.lastModifiedTime()

      • setLastModifiedTime

        public static Path setLastModifiedTime​(Path path,
                                       FileTime time)
                                throws IOException
        更新文件上次修改的时间属性。 文件时间被转换为文件系统支持的时代和精度。 从精细到粗粒度的转换会导致精度损失。 尝试设置文件系统不支持的最后修改时间或超出底层文件存储区支持的范围时，此方法的行为未定义。 投掷IOException可能会失败。

        使用示例：假设我们要将上次修改的时间设置为当前时间：

          Path path = ...
    FileTime now = FileTime.fromMillis(System.currentTimeMillis());
    Files.setLastModifiedTime(path, now);
        参数
        path - 文件的路径
        time - 最新修改的时间
        结果
        给定的路径
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，其 checkWrite方法拒绝对该文件的写入访问。
        另请参见：
        BasicFileAttributeView.setTimes(java.nio.file.attribute.FileTime, java.nio.file.attribute.FileTime, java.nio.file.attribute.FileTime)

      • size

        public static long size​(Path path)
                 throws IOException
        返回文件的大小（以字节为单位）。 由于压缩，支持稀疏文件或其他原因，大小可能与文件系统上的实际大小不同。 不是regular文件的文件的大小是实现特定的，因此是未指定的。
        参数
        path - 文件的路径
        结果
        文件大小，以字节为单位
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，其 checkRead方法拒绝对该文件的读取访问。
        另请参见：
        BasicFileAttributes.size()

      • exists

        public static boolean exists​(Path path,
                             LinkOption... options)
        测试文件是否存在。

        options参数可用于指示如果文件是符号链接的情况下如何处理符号链接。 默认情况下，遵循符号链接。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。

        请注意，此方法的结果已经过时了。 如果此方法指示文件存在，则不保证子序列访问将成功。 在安全敏感应用程序中使用此方法时，请注意。

        参数
        path - 要测试的文件的路径
        options - 表示如何处理符号链接的选项。
        结果
        true如果文件存在; false如果文件不存在或其存在无法确定。
        异常
        SecurityException - 在默认提供程序的情况下，将调用 SecurityManager.checkRead(String)以检查对该文件的读取访问。
        另请参见：
        notExists(java.nio.file.Path, java.nio.file.LinkOption...)

      • notExists

        public static boolean notExists​(Path path,
                                LinkOption... options)
        测试此路径所在的文件是否不存在。 该方法适用于在确认文件不存在时需要采取措施的情况。

        options参数可用于指示如果文件是符号链接的情况下，如何处理符号链接。 默认情况下，遵循符号链接。 如果存在选项NOFOLLOW_LINKS ，则不遵循符号链接。

        请注意，此方法不是exists方法的补充。 在无法确定文件是否存在的情况下，两种方法都将返回false 。 与exists方法一样，此方法的结果立即过时。 如果此方法指示文件确实存在，则不能保证子序列尝试创建该文件将成功。 在安全敏感应用程序中使用此方法时，请注意。

        参数
        path - 要测试文件的路径
        options - 表示如何处理符号链接的选项
        结果
        true如果文件不存在; false如果文件存在或其存在无法确定
        异常
        SecurityException - 在默认提供程序的情况下，将调用 SecurityManager.checkRead(String)以检查对该文件的读取访问。

      • isReadable

        public static boolean isReadable​(Path path)
        测试文件是否可读。 此方法检查文件是否存在，并且此Java虚拟机具有允许其打开文件进行阅读的适当权限。 根据实现，此方法可能需要读取文件权限，访问控制列表或其他文件属性，以便检查对文件的有效访问。 因此，相对于其他文件系统操作，该方法可能不是原子的。

        请注意，该方法的结果已经过时了，不能保证随后尝试打开文件进行读取（甚至可以访问同一个文件）。 在安全敏感应用程序中使用此方法时，请注意。

        参数
        path - 要检查的文件的路径
        结果
        true如果文件存在并且是可读的; false如果文件不存在，读取访问将被拒绝，因为Java虚拟机没有足够的权限，或访问无法确定
        异常
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead以检查对该文件的读取访问。

      • isWritable

        public static boolean isWritable​(Path path)
        测试文件是否可写。 此方法检查文件是否存在，并且此Java虚拟机具有允许打开该文件以进行写入的适当权限。 根据实现，此方法可能需要读取文件权限，访问控制列表或其他文件属性，以便检查对文件的有效访问。 因此，相对于其他文件系统操作，该方法可能不是原子的。

        请注意，此方法的结果立即过时，不能保证随后尝试打开文件以进行写入（甚至可以访问同一个文件）。 在安全敏感应用程序中使用此方法时，请注意。

        参数
        path - 要检查的文件的路径
        结果
        true如果文件存在并且是可写的; false如果文件不存在，写入访问将被拒绝，因为Java虚拟机没有足够的权限，或访问无法确定
        异常
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkWrite以检查对该文件的写入访问。

      • isExecutable

        public static boolean isExecutable​(Path path)
        测试文件是否可执行。 此方法检查文件是否存在，并且此Java虚拟机具有execute文件的适当权限。 当检查对目录的访问时，语义可能会有所不同。 例如，在UNIX系统上，检查执行访问会检查Java虚拟机是否具有搜索目录以访问文件或子目录的权限。

        根据实现，此方法可能需要读取文件权限，访问控制列表或其他文件属性，以便检查对文件的有效访问。 因此，相对于其他文件系统操作，该方法可能不是原子的。

        请注意，该方法的结果是立即过时的，不能保证后续的执行该文件的尝试将成功（甚至可以访问相同的文件）。 在安全敏感应用程序中使用此方法时，请注意。

        参数
        path - 要检查的文件的路径
        结果
        true如果文件存在并且是可执行的; false如果文件不存在，执行访问将被拒绝，因为Java虚拟机没有足够的权限，或访问无法确定
        异常
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkExec以检查对该文件的执行访问。

      • walkFileTree

        public static Path walkFileTree​(Path start,
                                Set<FileVisitOption> options,
                                int maxDepth,
                                FileVisitor<? super Path> visitor)
                         throws IOException
        走一个文件树。

        此方法将以一个给定的起始文件为根。 文件树遍历是深度优先的 ，为每个遇到的文件调用给定的FileVisitor 。 访问树中的所有可访问文件或访问方法返回TERMINATE的结果时，文件树遍历完成。 由于IOException ，未捕获的错误或运行时异常，访问方法终止，则遍历遍历，并将错误或异常传播到此方法的调用者。

        对于遇到的每个文件，此方法尝试读取其BasicFileAttributes 。 如果文件不是目录，则使用文件属性调用visitFile方法。 如果文件属性无法读取，由于I / O异常，那么将使用I / O异常调用visitFileFailed方法。

        在文件是目录，目录无法打开的情况下，将使用I / O异常来调用visitFileFailed方法，之后，文件树的步骤将继续，默认情况下是目录的下一个兄弟节点。

        在目录成功打开的地方，目录中的条目及其后代被访问。 当所有条目被访问，或在目录的迭代期间发生I / O错误时，目录被关闭，并且访问者的postVisitDirectory方法被调用。 默认情况下，文件树步行继续在目录的下一个兄弟节点。

        默认情况下，此方法不会自动跟随符号链接。 如果options参数包含FOLLOW_LINKS选项，则遵循符号链接。 当跟随链接，并且目标的属性不能被读取时，则该方法尝试获取BasicFileAttributes的链接。 如果可以读取，那么使用链接的属性调用visitFile方法（否则， visitFileFailed调用了visitFileFailed方法）。

        如果options参数包含FOLLOW_LINKS选项，则此方法会跟踪所访问的目录，以便可以检测到周期。 当目录中存在作为目录的祖先的条目时，会出现一个循环。 通过记录目录的file-key或者文件密钥不可用，通过调用isSameFile方法来测试目录是否与祖先相同的文件来进行周期检测。 当检测到一个周期时，它被视为I / O错误，并且visitFileFailed方法被调用，其实例为FileSystemLoopException 。

        maxDepth参数是要访问的目录的最大级别数。 值0表示仅访问起始文件，除非安全管理器被拒绝。 可以使用值MAX_VALUE来表示应该访问所有级别。 除非基本的文件属性无法读取，否则将调用visitFile方法，包括所有文件（包括目录）在maxDepth遇到的文件，在这种情况下将调用visitFileFailed方法。

        如果访客返回null的结果，则抛出NullPointerException 。

        当一个安全管理器被安装并且它拒绝对一个文件（或目录）的访问时，它被忽略，访问者没有被调用该文件（或目录）。

        参数
        start - 起始文件
        options - 配置遍历的选项
        maxDepth - 要访问的目录级别的最大数量
        visitor - 为每个文件调用的文件访问者
        结果
        起始文件
        异常
        IllegalArgumentException - 如果 maxDepth参数为负
        SecurityException - 如果安全管理器拒绝对起始文件的访问。 在默认提供程序的情况下，将调用checkRead方法来检查对该目录的读取访问。
        IOException - 如果访问者方法抛出了I / O错误

      • walkFileTree

        public static Path walkFileTree​(Path start,
                                FileVisitor<? super Path> visitor)
                         throws IOException
        走一个文件树。

        这个方法的工作原理就像调用它相当于评估表达式：

         walkFileTree(start, EnumSet.noneOf(FileVisitOption.class), Integer.MAX_VALUE, visitor)
        换句话说，它不遵循符号链接，并访问文件树的所有级别。
        参数
        start - 起始文件
        visitor - 为每个文件调用的文件访问者
        结果
        起始文件
        异常
        SecurityException - 如果安全管理员拒绝对起始文件的访问。 在默认提供程序的情况下，将调用checkRead方法来检查对该目录的读取访问。
        IOException - 如果访问者方法抛出了I / O错误

      • newBufferedReader

        public static BufferedReader newBufferedReader​(Path path,
                                               Charset cs)
                                        throws IOException
        打开一个文件进行阅读，返回一个BufferedReader ，可以用来以有效的方式从文件读取文本。 使用指定的字符集将文件中的字节解码为字符。 阅读从文件开头开始。

        如果读取格式不正确或不可映射的字节序列，则从文件中读取的Reader方法抛出IOException 。

        参数
        path - 文件的路径
        cs - 用于解码的字符集
        结果
        一个新的缓冲读取器，具有默认缓冲区大小，可以从文件读取文本
        异常
        IOException - 如果打开文件时出现I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。
        另请参见：
        readAllLines(java.nio.file.Path, java.nio.charset.Charset)

      • newBufferedReader

        public static BufferedReader newBufferedReader​(Path path)
                                        throws IOException
        打开一个文件进行阅读，返回一个BufferedReader以高效的方式从文件读取文本。 使用UTF-8 charset将文件中的字节解码为字符。

        这个方法的工作原理就像调用它相当于评估表达式：

           Files.newBufferedReader(path, StandardCharsets.UTF_8)
        参数
        path - 文件的路径
        结果
        一个新的缓冲读取器，具有默认缓冲区大小，可以从文件读取文本
        异常
        IOException - 如果打开文件时出现I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。
        从以下版本开始：
        1.8

      • newBufferedWriter

        public static BufferedWriter newBufferedWriter​(Path path,
                                               Charset cs,
                                               OpenOption... options)
                                        throws IOException
        打开或创建一个写入文件，返回一个BufferedWriter ，可用于以有效的方式将文本写入文件。 options参数指定文件的创建或打开方式。 如果不存在任何选项，则此方法的工作原理犹如CREATE ， TRUNCATE_EXISTING ，并WRITE个选项都存在。 换句话说，它打开写入文件，创建文件（如果不存在），或者最初截断现有的regular-file大小为0如果存在）。

        Writer写入文本的方法抛出IOException如果文本无法使用指定的字符集进行编码。

        参数
        path - 文件的路径
        cs - 用于编码的字符集
        options - 指定文件打开方式的选项
        结果
        一个新的缓冲写入器，具有默认缓冲区大小，可以将文本写入文件
        异常
        IllegalArgumentException - 如果 options包含无效的选项组合
        IOException - 如果打开或创建文件时出现I / O错误
        UnsupportedOperationException - 如果指定了不支持的选项
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用checkWrite方法来检查对该文件的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。
        另请参见：
        write(Path,Iterable,Charset,OpenOption[])

      • newBufferedWriter

        public static BufferedWriter newBufferedWriter​(Path path,
                                               OpenOption... options)
                                        throws IOException
        打开或创建一个写入文件，返回一个BufferedWriter以有效的方式向文件写入文本。 使用UTF-8 charset将文本编码为字节。

        这个方法的工作原理就像调用它相当于评估表达式：

           Files.newBufferedWriter(path, StandardCharsets.UTF_8, options)
        参数
        path - 文件的路径
        options - 指定文件打开方式的选项
        结果
        一个新的缓冲写入器，具有默认缓冲区大小，可以将文本写入文件
        异常
        IllegalArgumentException - 如果 options包含无效的选项组合
        IOException - 如果打开或创建文件时出现I / O错误
        UnsupportedOperationException - 如果指定了不受支持的选项
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用checkWrite方法来检查对该文件的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。
        从以下版本开始：
        1.8

      • copy

        public static long copy​(InputStream in,
                        Path target,
                        CopyOption... options)
                 throws IOException
        将输入流中的所有字节复制到文件。 返回时，输入流将处于流的末尾。

        默认情况下，如果目标文件已存在或是符号链接，则副本将失败。 如果指定了REPLACE_EXISTING选项，并且目标文件已经存在，则如果它不是非空目录，那么它将被替换。 如果目标文件存在并且是符号链接，则替换符号链接。 在此版本中， REPLACE_EXISTING选项是此方法所需的唯一选项。 以后的版本可能会支持其他选项。

        如果从输入流读取或写入文件时发生I / O错误，则可能在创建目标文件并且在读取或写入某些字节之后执行此操作。 因此，输入流可能不是流的结尾，并且可能处于不一致的状态。 如果发生I / O错误，强烈建议输入流被及时关闭。

        此方法可能阻止从输入流（或写入文件）无限期地读取。 在复制期间输入流异步关闭或线程中断的情况的行为是高度输入流和文件系统提供程序特定的，因此未指定。

        使用示例 ：假设我们要捕获网页并将其保存到文件中：

          Path path = ...
     URI u = URI.create("http://java.sun.com/");
     try (InputStream in = u.toURL().openStream()) {
         Files.copy(in, path);
     }
        参数
        in - 要读取的输入流
        target - 文件的路径
        options - 指定应如何完成副本的选项
        结果
        读取或写入的字节数
        异常
        IOException - 读/写时是否发生I / O错误
        FileAlreadyExistsException - 如果目标文件存在但无法替换，因为未指定 REPLACE_EXISTING选项 （可选特定异常）
        DirectoryNotEmptyException - 指定了 REPLACE_EXISTING选项，但是由于它是非空目录 （可选的特殊异常），因此无法替换该文件*
        UnsupportedOperationException - 如果 options包含不支持的副本选项
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用checkWrite方法来检查对该文件的写入访问。 在指定了REPLACE_EXISTING选项的情况下，将调用安全管理器的checkDelete方法来检查现有文件是否可以被删除。

      • copy

        public static long copy​(Path source,
                        OutputStream out)
                 throws IOException
        将文件中的所有字节复制到输出流。

        如果从文件读取或写入输出流发生I / O错误，则可能会在读取或写入某些字节后执行此操作。 因此，输出流可能处于不一致状态。 强烈建议如果发生I / O错误，则会立即关闭输出流。

        此方法可能无限期地写入输出流（或从文件读取）。 输出流异步关闭或在复制期间线程中断的情况的行为是高度输出流和文件系统提供者特定的，因此未指定。

        请注意，如果给定的输出流是Flushable，那么它的flush方法可能需要在此方法完成后调用，以便刷新任何缓冲的输出。

        参数
        source - 文件的路径
        out - 要写入的输出流
        结果
        读取或写入的字节数
        异常
        IOException - 读/写时是否发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。

      • readAllBytes

        public static byte[] readAllBytes​(Path path)
                           throws IOException
        读取文件中的所有字节。 该方法确保在读取所有字节或抛出I / O错误或其他运行时异常时关闭文件。

        请注意，此方法适用于将所有字节读入字节数组的简单情况。 它不是用于阅读大文件。

        参数
        path - 文件的路径
        结果
        一个包含从文件读取的字节的字节数组
        异常
        IOException - 如果从流中读取I / O错误
        OutOfMemoryError - 如果不能分配所需大小的数组，例如文件大于 2GB
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。

      • readAllLines

        public static List<String> readAllLines​(Path path,
                                        Charset cs)
                                 throws IOException
        从文件中读取所有行。 此方法可确保在读取所有字节或抛出I / O错误或其他运行时异常时关闭文件。 使用指定的字符集将文件中的字节解码为字符。

        该方法将以下内容识别为行终止符：

        • \u000D其次是\u000A ， \u000A返回后跟LINE FEED
        • \u000A ，LINE FEED
        • \u000D ， \u000D返回

        其他Unicode行终止符可能会在将来的版本中被识别。

        请注意，此方法适用于在单个操作中读取所有行的简单情况。 它不是用于阅读大文件。

        参数
        path - 文件的路径
        cs - 用于解码的字符集
        结果
        从文件的行List ; List是否可修改是否依赖于实现，因此未指定
        异常
        IOException - 如果从文件读取I / O错误或读取格式不正确或不可映射的字节序列
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 checkRead方法来检查对该文件的读取访问。
        另请参见：
        newBufferedReader(java.nio.file.Path, java.nio.charset.Charset)

      • readAllLines

        public static List<String> readAllLines​(Path path)
                                 throws IOException
        从文件中读取所有行。 文件中的字节将使用UTF-8 charset解码为字符。

        这个方法的工作原理就像调用它相当于评估表达式：

           Files.readAllLines(path, StandardCharsets.UTF_8)
        参数
        path - 文件的路径
        结果
        从文件的List ; List是否可修改是否依赖于实现，因此未指定
        异常
        IOException - 如果从文件读取I / O错误或读取格式不正确或不可映像的字节序列
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。
        从以下版本开始：
        1.8

      • write

        public static Path write​(Path path,
                         byte[] bytes,
                         OpenOption... options)
                  throws IOException
        将字节写入文件。 options参数指定文件的创建或打开方式。 如果不存在任何选项，则此方法的工作原理犹如CREATE ， TRUNCATE_EXISTING ，并WRITE个选项都存在。 换句话说，它打开写入文件，创建文件（如果不存在），或者最初截断现有的regular-file大小为0 。 字节数组中的所有字节都将写入文件。 该方法确保在写入所有字节时（或抛出I / O错误或其他运行时异常）时关闭文件。 如果发生I / O错误，则可能会在文件创建或截断后或在将某些字节写入文件之后执行此操作。

        使用示例 ：默认情况下，该方法将创建一个新文件或覆盖现有文件。 假设您想要将字节追加到现有文件中：

          Path path = ...
     byte[] bytes = ...
     Files.write(path, bytes, StandardOpenOption.APPEND);
        参数
        path - 文件的路径
        bytes - 要写入的字节数组
        options - 指定文件打开方式的选项
        结果
        路径
        异常
        IllegalArgumentException - 如果 options包含无效的选项组合
        IOException - 如果在写入或创建文件时发生I / O错误
        UnsupportedOperationException - 如果指定了不支持的选项
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用checkWrite方法来检查对该文件的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。

      • write

        public static Path write​(Path path,
                         Iterable<? extends CharSequence> lines,
                         Charset cs,
                         OpenOption... options)
                  throws IOException
        将文本行写入文件。 每一行都是一个字符序列，并按照系统属性line.separator定义的每行由平台的行分隔符终止的顺序写入文件。 使用指定的字符集将字符编码为字节。

        options参数指定文件的创建或打开方式。 如果不存在任何选项，则此方法的工作原理犹如CREATE ， TRUNCATE_EXISTING ，并WRITE个选项都存在。 换句话说，它打开写入文件，创建文件（如果不存在），或者最初截断现有的regular-file大小为0 。 该方法确保在写入所有行时（或抛出I / O错误或其他运行时异常）时关闭文件。 如果发生I / O错误，则可能会在文件创建或截断后或在将某些字节写入文件之后执行此操作。

        参数
        path - 文件的路径
        lines - 一个遍历char序列的对象
        cs - 用于编码的字符集
        options - 指定文件打开方式的选项
        结果
        路径
        异常
        IllegalArgumentException - 如果 options包含无效的选项组合
        IOException - 如果在写入或创建文件时出现I / O错误，或者文本无法使用指定的字符集进行编码
        UnsupportedOperationException - 如果指定了不支持的选项
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用checkWrite方法来检查对该文件的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。

      • write

        public static Path write​(Path path,
                         Iterable<? extends CharSequence> lines,
                         OpenOption... options)
                  throws IOException
        将文本行写入文件。 使用UTF-8 charset将字符编码为字节。

        这个方法的工作原理就像调用它相当于评估表达式：

           Files.write(path, lines, StandardCharsets.UTF_8, options);
        参数
        path - 文件的路径
        lines - 一个遍历char序列的对象
        options - 指定文件打开方式的选项
        结果
        路径
        异常
        IllegalArgumentException - 如果 options包含选项的无效组合
        IOException - 如果在写入或创建文件时发生I / O错误，或者文本无法编码为 UTF-8
        UnsupportedOperationException - 如果指定了不支持的选项
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用checkWrite方法来检查对该文件的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。
        从以下版本开始：
        1.8

      • list

        public static Stream<Path> list​(Path dir)
                         throws IOException
        返回一个懒惰的Stream ，其中的元素是目录中的条目。 列表不是递归的。

        流的元素是Path对象，如resolving所示 ，目录条目的名称反对dir 。 某些文件系统维护目录本身和目录的父目录的特殊链接。 不包括代表这些链接的条目。

        流量弱一致 。 它是线程安全的，但是在迭代时不冻结目录，因此它可能（或可能不）反映从此方法返回后发生的目录的更新。

        返回的流包含对打开目录的引用。 通过关闭流来关闭目录。

        在封闭的流上运行，就像流已经达到一样。 由于预读，流已关闭后可能会返回一个或多个元素。

        如果在此方法返回后访问目录时抛出一个IOException ，它将被包装在一个UncheckedIOException中 ，这将导致导致访问的方法。

        API Note:
        必须在try-with-resources语句或类似的控制结构中使用此方法，以确保在流的操作完成后，流的打开目录被及时关闭。
        参数
        dir - 目录的路径
        结果
        Stream描述目录的内容
        异常
        NotDirectoryException - 如果文件无法打开，因为它不是目录 （可选的特殊异常）
        IOException - 打开目录时是否发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该目录的读取访问。
        从以下版本开始：
        1.8
        另请参见：
        newDirectoryStream(Path)

      • walk

        public static Stream<Path> walk​(Path start,
                                int maxDepth,
                                FileVisitOption... options)
                         throws IOException
        返回一个Stream ，它通过走在一个给定的起始文件的根文件树上， Path 。 文件树被深度优先地遍历，流中的元素是Path对象，如resolving所示 ，相对路径为start 。

        stream文件树，因为元素被消耗。 返回的Stream保证至少有一个元素，起始文件本身。 对于访问的每个文件，流尝试读取其BasicFileAttributes 。 如果文件是目录并且可以被成功打开，则目录中的条目及其后代将在流中遇到目录。 当所有条目都被访问时，目录被关闭。 然后，文件树步行在目录的下一个兄弟节点继续。

        流量弱一致 。 它不会在迭代时冻结文件树，因此它可能（或可能不）反映从此方法返回后发生的文件树的更新。

        默认情况下，此方法不会自动跟随符号链接。 如果options参数包含FOLLOW_LINKS选项，则遵循符号链接。 当跟随链接时，目标的属性无法读取，则此方法会尝试获取链接的BasicFileAttributes 。

        如果options参数包含FOLLOW_LINKS选项，则流将跟踪所访问的目录，以便可以检测到周期。 当目录中存在作为目录的祖先的条目时，会出现一个循环。 循环检测是通过记录file-key的目录，或者如果文件密钥不可用，则通过调用isSameFile方法来测试目录是否与祖先相同的文件来完成。 当检测到一个周期时，它被视为具有FileSystemLoopException实例的I / O错误。

        maxDepth参数是要访问的目录的最大级别数。 值0意味着只有启动文件被访问，除非安全管理器被拒绝。 可以使用值MAX_VALUE来表示应该访问所有级别。

        当一个安全管理器被安装并且它拒绝访问一个文件（或目录）时，它被忽略，不包括在流中。

        返回的流包含对一个或多个打开目录的引用。 通过关闭流来关闭目录。

        如果在此方法返回后访问目录时抛出一个IOException ，它将被包装在一个UncheckedIOException中 ，这将导致导致访问的方法。

        API Note:
        必须在try-with-resources语句或类似的控制结构中使用此方法，以确保在流的操作完成后，流的打开目录被及时关闭。
        参数
        start - 起始文件
        maxDepth - 要访问的目录级别的最大数量
        options - 配置遍历的选项
        结果
        Stream的Path
        异常
        IllegalArgumentException - 如果 maxDepth参数为负数
        SecurityException - 如果安全管理员拒绝对起始文件的访问。 在默认提供程序的情况下，将调用checkRead方法来检查对该目录的读取访问。
        IOException - 如果在访问起始文件时抛出I / O错误。
        从以下版本开始：
        1.8

      • walk

        public static Stream<Path> walk​(Path start,
                                FileVisitOption... options)
                         throws IOException
        返回一个Stream ，它通过走在一个给定的起始文件的文件树上，而懒惰地填充了Path 。 文件树被深度优先地遍历，流中的元素是Path个对象，如resolving所示 ，相对路径为start 。

        这个方法的工作原理就像调用它相当于评估表达式：

         walk(start, Integer.MAX_VALUE, options)
        换句话说，它访问文件树的所有级别。

        返回的流包含对一个或多个打开目录的引用。 通过关闭流来关闭目录。

        API Note:
        必须在try-with-resources语句或类似的控制结构中使用此方法，以确保在流的操作完成后，流的打开目录被及时关闭。
        参数
        start - 起始文件
        options - 配置遍历的选项
        结果
        Stream的Path
        异常
        SecurityException - 如果安全管理器拒绝对起始文件的访问。 在默认提供程序的情况下，将调用checkRead方法来检查对该目录的读取访问。
        IOException - 如果在访问起始文件时抛出I / O错误。
        从以下版本开始：
        1.8
        另请参见：
        walk(Path, int, FileVisitOption...)

      • find

        public static Stream<Path> find​(Path start,
                                int maxDepth,
                                BiPredicate<Path,BasicFileAttributes> matcher,
                                FileVisitOption... options)
                         throws IOException
        返回一个Stream ，它通过搜索基于给定起始文件的文件树中的文件来懒惰地填充Path 。

        此方法以完全由walk方法指定的方式移动文件树。 对于遇到的每个文件，给定BiPredicate调用其Path和BasicFileAttributes 。 所述Path对象被获得为如果由resolving的相对路径对start ，并且仅包含在返回的Stream如果BiPredicate返回true。 比较主叫filter上Stream通过返回walk方法，这个方法可以是通过避免冗余检索更有效BasicFileAttributes 。

        返回的流包含对一个或多个打开目录的引用。 通过关闭流来关闭目录。

        如果在从此方法返回后访问目录时抛出一个IOException ，它将被包裹在一个UncheckedIOException中 ，这将导致导致访问的方法。

        API Note:
        必须在try-with-resources语句或类似的控制结构中使用此方法，以确保在流的操作完成后，流的打开目录被及时关闭。
        参数
        start - 起始文件
        maxDepth - 要搜索的目录级别的最大数量
        matcher - 用于决定文件是否应包含在返回的流中的函数
        options - 配置遍历的选项
        结果
        Stream的Path
        异常
        IllegalArgumentException - 如果 maxDepth参数为负
        SecurityException - 如果安全管理员拒绝访问起始文件。 在默认提供程序的情况下，将调用checkRead方法来检查对该目录的读取访问。
        IOException - 如果在访问起始文件时抛出I / O错误。
        从以下版本开始：
        1.8
        另请参见：
        walk(Path, int, FileVisitOption...)

      • lines

        public static Stream<String> lines​(Path path,
                                   Charset cs)
                            throws IOException
        从文件中读取所有行作为Stream 。 与readAllLines不同，此方法不会将所有行都读入List ，而是在流消耗时懒惰地填充。

        使用指定的字符集将文件中的字节解码为字符，并支持readAllLines指定的行终止符。

        返回的流包含对打开文件的引用。 关闭流即可关闭该文件。

        在执行终端流操作时不应修改文件内容。 否则，终端流操作的结果未定义。

        此方法返回后，从文件读取或读取错误格式或不可映射字节序列时发生的任何后续I / O异常都将包含在UncheckedIOException中 ，将从引用读取的Stream方法抛出。 如果在关闭文件时抛出一个IOException ，它也被包装成一个UncheckedIOException 。

        API Note:
        必须在try-with-resources语句或类似的控制结构中使用此方法，以确保在流的操作完成后，流的打开文件被及时关闭。
        Implementation Note:
        该实现支持标准字符串 UTF-8,US-ASCII和ISO-8859-1的良好并行流性能。 这种线条优化字符集具有随机访问文件的字节时，可以从其他编码字符高效地识别换行（'\ n'）或回车符（'\ r'）的编码字节的属性。

        对于非线优化字符集，流源的分割器具有差的分割属性，类似于与迭代器相关联的或与从BufferedReader.lines()返回的流相关联的分割器的分割属性。 分流性差可能导致平行流性能差。

        对于线优化字符集，流源的分割器具有良好的分割属性，假设文件包含一个规则的行序列。 良好的分离性能可以获得良好的并行流性能。 线条最佳字符集的拼接器利用字符集属性（换行符或回车可高效识别），以便在分割时可以将覆盖线数量大致分为两半。

        参数
        path - 文件的路径
        cs - 用于解码的字符集
        结果
        从文件的 Stream
        异常
        IOException - 如果打开文件时出现I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。
        从以下版本开始：
        1.8
        另请参见：
        readAllLines(Path, Charset) ，
newBufferedReader(Path, Charset) ，
BufferedReader.lines()

      • lines

        public static Stream<String> lines​(Path path)
                            throws IOException
        从文件中读取所有行作为Stream 。 文件中的字节使用UTF-8 charset解码为字符。

        返回的流包含对打开文件的引用。 关闭流即可关闭该文件。

        在执行终端流操作时不应修改文件内容。 否则，终端流操作的结果未定义。

        这个方法的工作原理就像调用它相当于评估表达式：

           Files.lines(path, StandardCharsets.UTF_8)
        API Note:
        必须在try-with-resources语句或类似的控制结构中使用此方法，以确保在流的操作完成后，流的打开文件被及时关闭。
        参数
        path - 文件的路径
        结果
        从文件中的 Stream
        异常
        IOException - 如果打开文件时出现I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class FileStore

  • java.lang.Object
    • java.nio.file.FileStore

  • public abstract class FileStore
extends Object
    文件存储 A FileStore表示存储池，设备，分区，卷，具体文件系统或其他实现文件存储的具体方式。 所述FileStore用于文件的存储位置是通过调用得到getFileStore的方法，或所有文件存储可以通过调用被枚举getFileStores方法。

    除了此类定义的方法之外，文件存储可以支持一个或多个FileStoreAttributeView类，它们提供一组文件存储属性的只读或可更新视图。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FileStore​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Object getAttribute​(String attribute)
      读取文件存储属性的值。
      abstract <V extends FileStoreAttributeView>
      V             		getFileStoreAttributeView​(Class<V> type)
      返回给定类型的 FileStoreAttributeView 。
      abstract long getTotalSpace​()
      返回文件存储的大小（以字节为单位）。
      abstract long getUnallocatedSpace​()
      返回文件存储区中未分配字节的数量。
      abstract long getUsableSpace​()
      返回文件存储上此Java虚拟机可用的字节数。
      abstract boolean isReadOnly​()
      告诉这个文件存储是否是只读的。
      abstract String name​()
      返回此文件存储的名称。
      abstract boolean supportsFileAttributeView​(Class<? extends FileAttributeView> type)
      告诉这个文件存储是否支持由给定文件属性视图标识的文件属性。
      abstract boolean supportsFileAttributeView​(String name)
      告诉这个文件存储是否支持由给定文件属性视图标识的文件属性。
      abstract String type​()
      返回此文件存储的 类型 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileStore

        protected FileStore​()
        初始化此类的新实例。

    • 方法详细信息

      • name

        public abstract String name​()
        返回此文件存储的名称。 名称的格式高度实现具体。 它通常是存储池或卷的名称。

        此方法返回的字符串可能与toString方法返回的字符串不同。

        结果
        该文件存储的名称

      • type

        public abstract String type​()
        返回此文件存储的类型 。 此方法返回的字符串的格式具有高度实现性。 它可以指示例如所使用的格式或者文件存储是本地还是远程的。
        结果
        一个表示此文件存储类型的字符串

      • isReadOnly

        public abstract boolean isReadOnly​()
        告诉这个文件存储是否是只读的。 如果文件不支持写入操作或文件的其他更改，则文件存储是只读的。 任何尝试创建文件，打开现有文件以进行写入等都会导致抛出IOException 。
        结果
        true如果，并且只有这个文件存储是只读的

      • getTotalSpace

        public abstract long getTotalSpace​()
                            throws IOException
        返回文件存储的大小（以字节为单位）。
        结果
        文件存储的大小（以字节为单位）
        异常
        IOException - 如果发生I / O错误

      • getUsableSpace

        public abstract long getUsableSpace​()
                             throws IOException
        返回文件存储上此Java虚拟机可用的字节数。

        返回的可用字节数是一个提示，但不是保证，可以使用大多数或任何这些字节。 在获得空间属性之后，可用字节数很可能是准确的。 任何外部I / O操作（包括在此Java虚拟机之外的系统上进行的操作）都可能导致不准确。

        结果
        可用字节数
        异常
        IOException - 如果发生I / O错误

      • getUnallocatedSpace

        public abstract long getUnallocatedSpace​()
                                  throws IOException
        返回文件存储区中未分配字节的数量。

        返回的未分配字节数是一个提示，但不是保证，可以使用大多数或任何这些字节。 在获得空间属性之后，未分配字节的数量很可能是准确的。 任何外部I / O操作（包括在该虚拟机之外的系统上进行的操作）都可能导致不准确。

        结果
        未分配字节数
        异常
        IOException - 如果发生I / O错误

      • supportsFileAttributeView

        public abstract boolean supportsFileAttributeView​(Class<? extends FileAttributeView> type)
        告诉这个文件存储是否支持由给定文件属性视图标识的文件属性。

        调用此方法来测试文件库是否支持BasicFileAttributeView将始终返回true 。 在默认提供程序的情况下，当文件存储不是本地存储设备时，此方法不能保证给出正确的结果。 其原因是实施具体的，因此是未指定的。

        参数
        type - 文件属性视图类型
        结果
        true如果，且仅当支持文件属性视图

      • supportsFileAttributeView

        public abstract boolean supportsFileAttributeView​(String name)
        告诉这个文件存储是否支持由给定文件属性视图标识的文件属性。

        调用此方法来测试文件库是否支持BasicFileAttributeView ，由名称“ basic ”标识将始终返回true 。 在默认提供程序的情况下，当文件存储不是本地存储设备时，此方法不能保证给出正确的结果。 其原因是实施具体的，因此是未指定的。

        参数
        name - 文件属性视图的 name
        结果
        true如果并且仅当支持文件属性视图

      • getFileStoreAttributeView

        public abstract <V extends FileStoreAttributeView> V getFileStoreAttributeView​(Class<V> type)
        返回给定类型的FileStoreAttributeView 。

        该方法旨在用于文件存储属性视图定义类型安全方法来读取或更新文件存储属性。 type参数是所需的属性视图的类型，如果支持该方法，该方法返回该类型的实例。

        参数类型
        V - FileStoreAttributeView类型
        参数
        type - 对应于属性视图的 Class对象
        结果
        指定类型的文件存储属性视图，如果属性视图不可用， null

      • getAttribute

        public abstract Object getAttribute​(String attribute)
                             throws IOException
        读取文件存储属性的值。

        attribute参数标识要读取的属性，并采取以下格式：

        view-name : attribute-name
        字符':'代表自身。

        view-name是标识一组文件属性的AttributeView的name 。 attribute-name是属性的名称 。

        使用示例：假设我们想知道是否启用了ZFS压缩（假设支持“zfs”视图）：

          boolean compression = (Boolean)fs.getAttribute("zfs:compression");
        参数
        attribute - 要读取的属性
        结果
        属性值 null可能对某些属性有效
        异常
        UnsupportedOperationException - 如果属性视图不可用或不支持读取属性
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class FileSystem

  • java.lang.Object
    • java.nio.file.FileSystem
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public abstract class FileSystem
extends Object
implements Closeable
    提供文件系统的接口，并且是工厂用于访问文件系统中的文件和其他对象的对象。

    通过调用FileSystems.getDefault方法获得的默认文件系统提供对Java虚拟机可访问的文件系统的访问。 FileSystems类定义了创建可以访问其他类型（自定义）文件系统的文件系统的方法。

    文件系统是几种类型对象的工厂：

    • getPath方法转换系统相关的路径字符串 ，返回可用于查找和访问文件的Path对象。

    • getPathMatcher方法用于创建在路径上执行匹配操作的PathMatcher 。

    • getFileStores方法返回底层file-stores的迭代器。

    • getUserPrincipalLookupService方法返回UserPrincipalLookupService按名称查找用户或组。

    • newWatchService方法创建一个WatchService ，可用于监视对象的更改和事件。

    文件系统差别很大。 在某些情况下，文件系统是具有一个顶级根目录的单个文件层次结构。 在其他情况下，它可能有几个不同的文件层次结构，每个都有自己的顶级根目录。 getRootDirectories方法可用于遍历文件系统中的根目录。 文件系统通常由提供文件存储的一个或多个底层file-stores组成。 这些文件存储还可以在其支持的功能以及与文件相关联的文件属性或元数据中不同。

    文件系统在创建时打开，可以通过调用其close方法关闭文件系统。 一旦关闭，进一步尝试访问文件系统中的对象将导致ClosedFileSystemException被抛出。 默认情况下创建的文件系统不能关闭provider 。

    A FileSystem可以提供对文件系统的只读或读写访问。 当创建FileSystem时，是否建立文件系统提供只读访问，并可以通过调用其isReadOnly方法进行测试。 通过与只读文件系统相关联的对象写入文件存储库的尝试将抛出ReadOnlyFileSystemException 。

    文件系统是安全的多个并发线程使用。 可以随时调用close方法来关闭文件系统，但文件系统是否是异步可关闭的是提供者特定的，因此未指定。 换句话说，如果线程正在访问文件系统中的对象，而另一个线程调用close方法，则可能需要阻止直到第一个操作完成。 关闭文件系统会导致与文件系统关联的所有打开的通道，监视服务和其他closeable对象关闭。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FileSystem​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract void close​()
      关闭此文件系统。
      abstract Iterable<FileStore> getFileStores​()
      返回一个对象，以遍历底层文件存储。
      abstract Path getPath​(String first, String... more)
      将路径字符串或将连接到路径字符串的字符串序列转换为 Path 。
      abstract PathMatcher getPathMatcher​(String syntaxAndPattern)
      返回一个PathMatcher ，通过解释给定的模式，对Path对象的String表示执行匹配操作。
      abstract Iterable<Path> getRootDirectories​()
      返回一个对象来遍历根目录的路径。
      abstract String getSeparator​()
      返回名称分隔符，表示为字符串。
      abstract UserPrincipalLookupService getUserPrincipalLookupService​()
      返回此文件系统的 UserPrincipalLookupService （可选操作） 。
      abstract boolean isOpen​()
      告诉这个文件系统是否打开。
      abstract boolean isReadOnly​()
      告诉这个文件系统是否只允许只读访问其文件存储。
      abstract WatchService newWatchService​()
      构造新的WatchService （可选操作） 。
      abstract FileSystemProvider provider​()
      返回创建此文件系统的提供程序。
      abstract Set<String> supportedFileAttributeViews​()
      返回集的 names的该支持的文件属性意见 FileSystem 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileSystem

        protected FileSystem​()
        初始化此类的新实例。

    • 方法详细信息

      • provider

        public abstract FileSystemProvider provider​()
        返回创建此文件系统的提供程序。
        结果
        创建此文件系统的提供程序。

      • close

        public abstract void close​()
                    throws IOException
        关闭此文件系统。

        文件系统关闭后，所有后续访问文件系统，无论是通过此类定义的方法或与此文件系统相关的对象，都会抛出ClosedFileSystemException 。 如果文件系统已经关闭，则调用此方法没有任何作用。

        关闭文件系统将关闭所有打开的channels ， directory-streams ， watch-service与该文件系统关联，以及其它可关闭的对象。 default文件系统无法关闭。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误
        UnsupportedOperationException - 在默认文件系统的情况下抛出

      • isOpen

        public abstract boolean isOpen​()
        告诉这个文件系统是否打开。

        默认提供程序创建的文件系统始终打开。

        结果
        true如果，并且只有这个文件系统是打开的

      • isReadOnly

        public abstract boolean isReadOnly​()
        告诉这个文件系统是否只允许只读访问其文件存储。
        结果
        true如果，且仅当此文件系统提供只读访问权限

      • getSeparator

        public abstract String getSeparator​()
        返回名称分隔符，表示为字符串。

        名称分隔符用于分隔路径字符串中的名称。 实现可以支持多个名称分隔符，在这种情况下，此方法返回一个实现特定的默认名称分隔符。 通过调用toString()方法创建路径字符串时使用此分隔符。

        在默认提供程序的情况下，此方法返回与File.separator相同的分隔符。

        结果
        名称分隔符

      • getRootDirectories

        public abstract Iterable<Path> getRootDirectories​()
        返回一个对象来遍历根目录的路径。

        文件系统提供对文件存储的访问，该文件存储可以由多个不同的文件层次结构组成，每个具有其自己的顶级根目录。 除非安全管理器被拒绝，否则返回的迭代器中的每个元素都对应于不同文件层次结构的根目录。 元素的顺序没有定义。 文件层次结构可能会在Java虚拟机的生命周期内更改。 例如，在一些实现中，可移动介质的插入可能导致用其自己的顶级目录创建新的文件层次结构。

        安装安全管理器时，会调用它来检查对每个根目录的访问。 如果被拒绝，则根目录不会由迭代器返回。 在默认提供程序的情况下，将调用SecurityManager.checkRead(String)方法来检查对每个根目录的读取访问。 如果获取迭代器或迭代时执行权限检查，则系统依赖。

        结果
        一个对象来遍历根目录

      • getFileStores

        public abstract Iterable<FileStore> getFileStores​()
        返回一个对象，以遍历底层文件存储。

        返回的迭代器的元素是这个文件系统的FileStores 。 未定义元素的顺序，并且文件存储可能会在Java虚拟机的生命周期内更改。 当发生I / O错误时，可能是因为文件存储不可访问，那么它不会被迭代器返回。

        在默认提供程序的情况下，并安装了安全管理器，将调用安全管理器以检查RuntimePermission ("getFileStoreAttributes") 。 如果被拒绝，则迭代器不会返回任何文件存储。 另外，调用安全管理器的SecurityManager.checkRead(String)方法来检查对文件存储最顶层目录的读取访问。 如果被拒绝，文件存储不会被迭代器返回。 如果获取迭代器或迭代时执行权限检查，则系统依赖。

        使用示例：假设我们要打印所有文件存储的空间使用情况：

          for (FileStore store: FileSystems.getDefault().getFileStores()) {
         long total = store.getTotalSpace() / 1024;
         long used = (store.getTotalSpace() - store.getUnallocatedSpace()) / 1024;
         long avail = store.getUsableSpace() / 1024;
         System.out.format("%-20s %12d %12d %12d%n", store, total, used, avail);
     }
        结果
        一个对象来迭代备份文件存储

      • supportedFileAttributeViews

        public abstract Set<String> supportedFileAttributeViews​()
        返回FileSystem支持的文件属性视图的FileSystem 。

        BasicFileAttributeView需要被支持，因此该集合至少包含一个元素“basic”。

        supportsFileAttributeView(String)方法可用于测试底层的FileStore是否支持由文件属性视图标识的文件属性。

        结果
        支持的文件属性视图的名称不可修改的集合

      • getPath

        public abstract Path getPath​(String first,
                             String... more)
        将路径字符串或连接到路径字符串的字符串序列转换为Path 。 如果more没有指定任何元素，那么first参数的值是要转换的路径字符串。 如果more指定一个或多个元素，则每个非空字符串（包括first ）都被认为是一系列名称元素（见Path ），并被连接形成路径字符串。 关于字符串如何连接的细节是提供者特定的，但通常它们将使用name-separator作为分隔符来连接。 例如，如果名称分隔符为“ / ”并且调用了getPath("/foo","bar","gus") ，则路径字符串"/foo/bar/gus"将转换为Path 。 一个Path表示空路径如果返回first为空字符串，并且more不包含任何非空字符串。

        对路径对象的解析和转换是固有的依赖于实现的。 在最简单的情况下，路径字符串被拒绝，并且抛出InvalidPathException ，如果路径字符串包含不能转换为与文件存储合法的字符的字符。 例如，在UNIX系统上，NUL（\ u0000）字符不允许存在于路径中。 实现可以选择拒绝包含比任何文件存储允许的名称长的路径字符串，并且在实现支持复杂路径语法的情况下，它可以选择拒绝严重形成的路径字符串。

        在默认提供程序的情况下，路径字符串将根据平台或虚拟文件系统级别的路径定义进行解析。 例如，操作系统可能不允许在文件名中存在特定字符，但是特定的底层文件存储可能对该组合法字符施加不同的或附加的限制。

        当路径字符串无法转换为路径时，此方法将抛出InvalidPathException 。 在可能的情况下，如果适用，创建一个异常，其值为index，表示path参数中导致路径字符串被拒绝的第一个位置。

        参数
        first - 路径字符串或路径字符串的初始部分
        more - 要连接以形成路径字符串的其他字符串
        结果
        结果 Path
        异常
        InvalidPathException - 如果路径字符串无法转换

      • getPathMatcher

        public abstract PathMatcher getPathMatcher​(String syntaxAndPattern)
        返回一个PathMatcher ，通过解释给定的模式对Path对象的String表示执行匹配操作。 syntaxAndPattern参数标识语法和模式，并采取以下格式：
         syntax:pattern
        其中':'代表自己。

        A FileSystem实现支持“ glob ”和“ regex ”语法，并可能支持其他语言。 比较语法组件的值而不考虑情况。

        当语法为“ glob ”时，路径的String表示将使用类似正则表达式但具有更简单语法的有限模式语言进行匹配。 例如：

        Pattern Language
        *.java | Matches a path that represents a file name ending in .java
        *.* Matches file names containing a dot
        *.{java,class} | Matches file names ending with .java or .class
        foo.? | Matches file names starting with foo. and a single character extension
        /home/*/* | Matches /home/gus/data on UNIX platforms
        /home/** | Matches /home/gus and /home/gus/data on UNIX platforms
        C:\\* | Matches C:\foo and C:\bar on the Windows platform (note that the backslash is escaped; as a string literal in the Java Language the pattern would be "C:\\\\*")

        以下规则用于解释glob模式：

        • 所述*字符匹配零个或多个characters一个的name部件不交叉目录边界。

        • **字符匹配零个或多个characters跨越目录边界。

        • ?字符匹配一个名称组件的一个字符。

        • 反斜杠字符（ \ ）用于转义否则将被解释为特殊字符的字符。 表达式\\匹配单个反斜杠，“\ {”匹配左括号例如。

        • [ ]字符是一个括号表达式 ，与一组字符中的名称组件的单个字符匹配。 例如， [abc]匹配"a" ， "b" ，或"c" 。 连字号（ - ）可用于指定范围，因此[a-z]指定从"a"到"z" （含）的匹配范围。 这些形式可以被混合，从而[ABCE-G]匹配"a" ， "b" ， "c" ， "e" ， "f"或"g" 。 如果之后的字符[是!然后它被用于否定所以[!a-c]匹配的任何字符以外"a" ， "b" ，或"c" 。

          在括号表达式的* ， ?和\字符匹配自身。 （ - ）字符匹配自己，如果它是括号中的第一个字符，或!之后的第一个字符，如果否定。

        • { }字符是一组子模式，组中的任何子模式匹配时，组匹配。 ","字符用于分隔子模式。 组不能嵌套。

        • 领导期/文件名中的点字符在匹配操作中被视为常规字符。 例如， "*" glob模式匹配文件名".login" 。 可以使用Files.isHidden(java.nio.file.Path)方法来测试文件是否被隐藏。

        • 所有其他角色都以实现依赖的方式进行匹配。 这包括代表任何name-separators的字符。

        • root组件的匹配高度依赖于实现，并未指定。

        当语法为“ regex ”时，模式组件是由Pattern类定义的正则表达式。

        对于glob和正则表达式语法，匹配的细节（例如匹配是否区分大小写）是否依赖于实现，因此未指定。

        参数
        syntaxAndPattern - 语法和模式
        结果
        路径匹配器，可用于匹配与模式相匹配的路径
        异常
        IllegalArgumentException - 如果参数不采取以下形式： syntax:pattern
        PatternSyntaxException - 如果模式无效
        UnsupportedOperationException - 如果模式语法对实现不了解
        另请参见：
        Files.newDirectoryStream(Path,String)

      • getUserPrincipalLookupService

        public abstract UserPrincipalLookupService getUserPrincipalLookupService​()
        返回此文件系统的UserPrincipalLookupService （可选操作） 。 所得到的查找服务可用于查找用户或组名称。

        使用示例：假设我们要让“joe”文件的所有者：

          UserPrincipalLookupService lookupService = FileSystems.getDefault().getUserPrincipalLookupService();
     Files.setOwner(path, lookupService.lookupPrincipalByName("joe"));
        结果
        这个文件系统的 UserPrincipalLookupService
        异常
        UnsupportedOperationException - 如果这个 FileSystem没有查找服务

      • newWatchService

        public abstract WatchService newWatchService​()
                                      throws IOException
        构造新的WatchService （可选操作） 。

        此方法构造一个新的watch服务，可以用于监视注册对象的更改和事件。

        结果
        新的手表服务
        异常
        UnsupportedOperationException - 如果这个FileSystem不支持观察文件系统对象的更改和事件。 由默认提供程序创建的FileSystems不会抛出此异常。
        IOException - If an I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileSystemAlreadyExistsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class FileSystemAlreadyExistsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.nio.file.FileSystemAlreadyExistsException
  • All Implemented Interfaces:
    Serializable

    public class FileSystemAlreadyExistsException
extends RuntimeException
    新新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileSystemAlreadyExistsException​()
      构造这个类的一个实例。
      FileSystemAlreadyExistsException​(String msg)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FileSystemAlreadyExistsException

        public FileSystemAlreadyExistsException​()
        构造这个类的一个实例。

      • FileSystemAlreadyExistsException

        public FileSystemAlreadyExistsException​(String msg)
        构造这个类的一个实例。
        参数
        msg - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileSystemException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class FileSystemException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.FileSystemException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AccessDeniedException ， AtomicMoveNotSupportedException ， DirectoryNotEmptyException ， FileAlreadyExistsException ， FileSystemLoopException ， NoSuchFileException ， NotDirectoryException ， NotLinkException

    public class FileSystemException
extends IOException
    在一个或两个文件上的文件系统操作失败时抛出。 这个类是文件系统异常的一般类。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileSystemException​(String file)
      构造这个类的一个实例。
      FileSystemException​(String file, String other, String reason)
      构造这个类的一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getFile​()
      返回用于创建此异常的文件。
      String getMessage​()
      返回详细消息字符串。
      String getOtherFile​()
      返回用于创建此异常的另一个文件。
      String getReason​()
      返回解释为什么文件系统操作失败的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FileSystemException

        public FileSystemException​(String file)
        构造这个类的一个实例。 当涉及一个文件的操作失败并且没有任何其他信息来解释原因时，应使用此构造函数。
        参数
        file - 如果不知道，则标识文件的字符串或 null 。

      • FileSystemException

        public FileSystemException​(String file,
                           String other,
                           String reason)
        构造这个类的一个实例。 当涉及两个文件的操作失败或者有其他信息来解释原因时，应该使用此构造函数。
        参数
        file - 如果不知道，则标识文件的字符串或 null 。
        other - 如果没有另一个文件，或者如果不知道，则标识另一个文件或 null的字符串
        reason - 带有附加信息的原因信息或 null

    • 方法详细信息

      • getFile

        public String getFile​()
        返回用于创建此异常的文件。
        结果
        该文件（可以是 null ）

      • getOtherFile

        public String getOtherFile​()
        返回用于创建此异常的另一个文件。
        结果
        另一个文件（可以是 null ）

      • getReason

        public String getReason​()
        返回解释为什么文件系统操作失败的字符串。
        结果
        该字符串解释为什么文件系统操作失败

      • getMessage

        public String getMessage​()
        返回详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能是 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileSystemLoopException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class FileSystemLoopException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.FileSystemException
            • java.nio.file.FileSystemLoopException
  • All Implemented Interfaces:
    Serializable

    public class FileSystemLoopException
extends FileSystemException
    当遇到文件系统循环或循环时抛出的检查异常。
    从以下版本开始：
    1.7
    另请参见：
    Files.walkFileTree(java.nio.file.Path, java.util.Set<java.nio.file.FileVisitOption>, int, java.nio.file.FileVisitor<? super java.nio.file.Path>) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileSystemLoopException​(String file)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.nio.file.FileSystemException

        getFile, getMessage, getOtherFile, getReason

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FileSystemLoopException

        public FileSystemLoopException​(String file)
        构造这个类的一个实例。
        参数
        file - a string identifying the file causing the cycle or null if not known
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileSystemNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class FileSystemNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.nio.file.FileSystemNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class FileSystemNotFoundException
extends RuntimeException
    无法找到文件系统时抛出的运行时异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileSystemNotFoundException​()
      构造这个类的一个实例。
      FileSystemNotFoundException​(String msg)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FileSystemNotFoundException

        public FileSystemNotFoundException​()
        构造这个类的一个实例。

      • FileSystemNotFoundException

        public FileSystemNotFoundException​(String msg)
        构造这个类的一个实例。
        参数
        msg - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileSystems (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class FileSystems

  • java.lang.Object
    • java.nio.file.FileSystems

  • public final class FileSystems
extends Object
    文件系统的工厂方法。 该类定义了getDefault方法来获取默认文件系统和工厂方法来构建其他类型的文件系统。

    第一次调用此类定义的任何方法将导致默认的provider被加载。 由URI方案“文件”标识的默认提供程序创建了可以访问Java虚拟机可访问的文件系统的FileSystem 。 如果加载或初始化默认提供程序的过程失败，则抛出未指定的错误。

    通过调用newFileSystem定义的任何newFileSystem方法，首次调用installedProviders方法可查找并加载所有已安装的文件系统提供程序。 使用由ServiceLoader类定义的服务提供商加载设施来加载已安装的提供程序。 使用系统类加载器加载安装的提供程序。 如果无法找到系统类加载器，则使用平台类加载器。 提供者通常通过将它们放置在应用程序类路径上的JAR文件中进行安装，JAR文件包含资源目录META-INF/services名为java.nio.file.spi.FileSystemProvider的提供程序配置文件，并且该文件列出了一个或多个具体子类的完全限定名称FileSystemProvider它有一个零参数构造函数。 安装提供商所在的订购是具体的实现。 如果提供程序被实例化，并且其getScheme返回先前实例化的提供程序的相同URI方案，则最近实例化的副本将被丢弃。 比较URI方案而不考虑情况。 在施工期间，提供商可以安全地访问与默认提供商相关的文件，但需要注意避免其他已安装提供程序的循环加载。 如果检测到已安装提供程序的循环加载，则会抛出未指定的错误。

    此类还定义了工厂方法，允许在定位提供程序时指定ClassLoader 。 与安装的提供程序一样，通过将提供程序配置文件放在资源目录META-INF/services来标识提供程序类。

    如果一个线程启动了安装的文件系统提供程序的加载，另一个线程调用一个也试图加载提供程序的方法，那么该方法将阻塞，直到加载完成。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FileSystem getDefault​()
      返回默认值 FileSystem 。
      static FileSystem getFileSystem​(URI uri)
      返回对现有的 FileSystem的引用。
      static FileSystem newFileSystem​(URI uri, Map<String,?> env)
      构造一个由URI标识的新文件系统
      static FileSystem newFileSystem​(URI uri, Map<String,?> env, ClassLoader loader)
      构造一个由URI标识的新文件系统
      static FileSystem newFileSystem​(Path path, ClassLoader loader)
      构造新的 FileSystem作为文件系统访问文件的内容。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getDefault

        public static FileSystem getDefault​()
        返回默认值FileSystem 。 默认文件系统创建可以访问Java虚拟机可访问的文件系统的对象。 文件系统的工作目录是当前的用户目录，由系统属性user.dir命名。 这允许与java.io.File类的互操作性。

        第一次调用此类定义的任何方法定位默认的provider对象。 在未定义系统属性java.nio.file.spi.DefaultFileSystemProvider的情况下，默认提供程序是调用以创建默认文件系统的系统默认提供程序。

        如果定义了系统属性java.nio.file.spi.DefaultFileSystemProvider ，则将其视为由URI方案"file"标识的具体提供者类的一个或多个完全限定名称的"file" 。 如果属性是多个名称的列表，则名称将以逗号分隔。 使用系统类加载器加载每个类，并通过调用形式参数类型为FileSystemProvider的一个参数构造函数实例化。 提供者按照属性中列出的顺序加载和实例化。 如果此过程失败或提供程序的方案不等于"file"则会抛出未指定的错误。 通常比较URI方案，而不考虑情况，但对于默认提供程序，方案需要为"file" 。 第一个提供程序类通过使用对系统默认提供程序的引用进行调用来实例化。 第二个提供者类通过使用对第一个提供者实例的引用进行调用来实例化。 第三个提供者类通过使用对第二个实例的引用进行调用来实例化，依此类推。 要实例化的最后一个提供者将成为默认提供者; 使用URI "file:///"调用其getFileSystem方法来获取对默认文件系统的引用。

        此方法的后续调用返回由第一次调用返回的文件系统。

        结果
        默认文件系统

      • getFileSystem

        public static FileSystem getFileSystem​(URI uri)
        返回对现有的FileSystem的引用。

        该方法遍历installed提供程序，以查找由给定URI的URI scheme标识的提供程序。 比较URI方案而不考虑情况。 URI的确切形式依赖于高度依赖于提供商。 如果发现，提供者的getFileSystem方法被调用以获得对FileSystem的引用。

        一旦由此提供商创建的文件系统是closed它是依赖提供者，如果此方法返回对封闭的文件系统的引用或抛出FileSystemNotFoundException 。 如果提供程序允许创建与之前创建的文件系统相同的URI的新文件系统，那么如果在文件系统关闭后（在newFileSystem方法创建新实例之前），则此方法将抛出异常。

        如果安装了安全管理器，则提供者实现可能需要在返回对现有文件系统的引用之前检查权限。 在default文件系统的情况下，不需要进行权限检查。

        参数
        uri - 查找文件系统的URI
        结果
        引用文件系统
        异常
        IllegalArgumentException - 如果不符合 uri参数的前提条件
        FileSystemNotFoundException - 如果由URI标识的文件系统不存在
        ProviderNotFoundException - 如果没有安装支持URI方案的提供者
        SecurityException - 如果安装了一个安全管理器，并且它拒绝了未指定的权限

      • newFileSystem

        public static FileSystem newFileSystem​(URI uri,
                                       Map<String,?> env)
                                throws IOException
        构造一个由URI标识的新文件系统

        该方法遍历installed提供程序，以查找由给定URI的URI scheme标识的提供程序。 比较URI方案而不考虑情况。 URI的确切形式依赖于高度依赖于提供商。 如果找到，则提供者的newFileSystem(URI,Map)方法被调用来构造新的文件系统。

        一旦文件系统为closed ，如果提供程序允许使用与之前创建的文件系统相同的URI来创建新的文件系统，则依赖于提供程序。

        使用示例：假设有一个由方案"memory"标识的提供商：

          Map<String,String> env = new HashMap<>();
   env.put("capacity", "16G");
   env.put("blockSize", "4k");
   FileSystem fs = FileSystems.newFileSystem(URI.create("memory:///?name=logfs"), env);
        参数
        uri - 标识文件系统的URI
        env - 配置文件系统的提供者特定属性的映射; 可能是空的
        结果
        一个新的文件系统
        异常
        IllegalArgumentException - 如果 uri参数的前提条件未满足，或 env参数不包含提供程序所需的属性，或属性值无效
        FileSystemAlreadyExistsException - 如果文件系统已经创建
        ProviderNotFoundException - 如果没有安装支持URI方案的提供者
        IOException - 如果在创建文件系统时发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝文件系统提供程序实现所需的未指定权限

      • newFileSystem

        public static FileSystem newFileSystem​(URI uri,
                                       Map<String,?> env,
                                       ClassLoader loader)
                                throws IOException
        构造一个由URI标识的新文件系统

        该方法首先尝试以与newFileSystem(URI,Map)方法完全相同的方式查找已安装的提供程序。 如果没有一个安装的提供程序支持URI方案，则尝试使用给定的类加载器来定位提供程序。 如果提供者支持URI方案，那么它的newFileSystem(URI,Map)被调用来构造新的文件系统。

        参数
        uri - 标识文件系统的URI
        env - 配置文件系统的提供者特定属性的映射; 可能是空的
        loader - 用于查找提供商的类加载器或 null仅尝试查找已安装的提供程序
        结果
        一个新的文件系统
        异常
        IllegalArgumentException - 如果不符合 uri参数的前提条件，或 env参数不包含提供程序所需的属性，或属性值无效
        FileSystemAlreadyExistsException - 如果URI方案标识已安装的提供程序，并且文件系统已经创建
        ProviderNotFoundException - 如果没有找到支持URI方案的提供者
        ServiceConfigurationError - 加载服务提供商时发生错误
        IOException - 创建文件系统时发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝文件系统提供程序实现所需的未指定权限

      • newFileSystem

        public static FileSystem newFileSystem​(Path path,
                                       ClassLoader loader)
                                throws IOException
        构造新的FileSystem以访问文件的内容作为文件系统。

        该方法利用专门的提供者创建伪文件系统，其中一个或多个文件的内容被视为一个文件系统。

        该方法遍历installed提供程序。 它依次使用空的地图调用每个提供者的newFileSystem(Path,Map)方法。 如果提供者返回文件系统，则迭代将终止，并返回文件系统。 如果没有一个安装的提供程序返回一个FileSystem那么尝试使用给定的类加载器来定位提供程序。 如果提供程序返回文件系统，则查找将终止，并返回文件系统。

        参数
        path - 文件的路径
        loader - 找到提供商的类加载器或 null只尝试找到已安装的提供程序
        结果
        一个新的文件系统
        异常
        ProviderNotFoundException - 如果无法找到支持此文件类型的提供程序
        ServiceConfigurationError - 加载服务提供商时发生错误
        IOException - 如果发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝了未指定的权限
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileVisitOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.nio.file

Enum FileVisitOption

  • java.lang.Object
    • java.lang.Enum<FileVisitOption>
      • java.nio.file.FileVisitOption
  • All Implemented Interfaces:
    Serializable ， Comparable<FileVisitOption>

    public enum FileVisitOption
extends Enum<FileVisitOption>
    定义文件树遍历选项。
    从以下版本开始：
    1.7
    另请参见：
    Files.walkFileTree(java.nio.file.Path, java.util.Set<java.nio.file.FileVisitOption>, int, java.nio.file.FileVisitor<? super java.nio.file.Path>)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      FOLLOW_LINKS
      遵循符号链接。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FileVisitOption valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FileVisitOption[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • FOLLOW_LINKS

        public static final FileVisitOption FOLLOW_LINKS
        遵循符号链接。

    • 方法详细信息

      • values

        public static FileVisitOption[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (FileVisitOption c : FileVisitOption.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static FileVisitOption valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


FileVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface FileVisitor<T>

  • 所有已知实现类：
    SimpleFileVisitor

    public interface FileVisitor<T>
    文件访问者 该接口的实现提供给Files.walkFileTree方法来访问文件树中的每个文件。

    使用示例：假设我们要删除文件树。 在这种情况下，删除目录中的条目后，应删除每个目录。

      Path start = ...
     Files.walkFileTree(start, new SimpleFileVisitor<Path>() {
         @Override
         public FileVisitResult visitFile(Path file, BasicFileAttributes attrs)
             throws IOException
         {
             Files.delete(file);
             return FileVisitResult.CONTINUE;
         }
         @Override
         public FileVisitResult postVisitDirectory(Path dir, IOException e)
             throws IOException
         {
             if (e == null) {
                 Files.delete(dir);
                 return FileVisitResult.CONTINUE;
             } else {
                 // directory iteration failed
                 throw e;
             }
         }
     });

    此外，假设我们要将文件树复制到目标位置。 在这种情况下，应遵循符号链接，并在目录中的条目复制之前创建目标目录。

      final Path source = ...
     final Path target = ...

     Files.walkFileTree(source, EnumSet.of(FileVisitOption.FOLLOW_LINKS), Integer.MAX_VALUE,
         new SimpleFileVisitor<Path>() {
             @Override
             public FileVisitResult preVisitDirectory(Path dir, BasicFileAttributes attrs)
                 throws IOException
             {
                 Path targetdir = target.resolve(source.relativize(dir));
                 try {
                     Files.copy(dir, targetdir);
                 } catch (FileAlreadyExistsException e) {
                      if (!Files.isDirectory(targetdir))
                          throw e;
                 }
                 return CONTINUE;
             }
             @Override
             public FileVisitResult visitFile(Path file, BasicFileAttributes attrs)
                 throws IOException
             {
                 Files.copy(file, target.resolve(source.relativize(file)));
                 return CONTINUE;
             }
         });
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      FileVisitResult postVisitDirectory​(T dir, IOException exc)
      在目录中的条目之后调用目录，并且已经访问了所有的后代。
      FileVisitResult preVisitDirectory​(T dir, BasicFileAttributes attrs)
      在目录中的条目被访问之前调用一个目录。
      FileVisitResult visitFile​(T file, BasicFileAttributes attrs)
      为目录中的文件调用。
      FileVisitResult visitFileFailed​(T file, IOException exc)
      为无法访问的文件调用。

    • 方法详细信息

      • preVisitDirectory

        FileVisitResult preVisitDirectory​(T dir,
                                  BasicFileAttributes attrs)
                           throws IOException
        在目录中的条目被访问之前调用一个目录。

        如果此方法返回CONTINUE ，则会访问目录中的条目。 如果此方法返回SKIP_SUBTREE或SKIP_SIBLINGS，则目录（和任何后代）中的条目将不被访问。

        参数
        dir - 对目录的引用
        attrs - 目录的基本属性
        结果
        访问结果
        异常
        IOException - 如果发生I / O错误

      • visitFile

        FileVisitResult visitFile​(T file,
                          BasicFileAttributes attrs)
                   throws IOException
        为目录中的文件调用。
        参数
        file - 对该文件的引用
        attrs - 文件的基本属性
        结果
        访问结果
        异常
        IOException - 如果发生I / O错误

      • visitFileFailed

        FileVisitResult visitFileFailed​(T file,
                                IOException exc)
                         throws IOException
        为无法访问的文件调用。 如果文件的属性无法读取，该文件是无法打开的目录以及其他原因，则调用此方法。
        参数
        file - 对该文件的引用
        exc - 阻止文件被访问的I / O异常
        结果
        访问结果
        异常
        IOException - 如果发生I / O错误

      • postVisitDirectory

        FileVisitResult postVisitDirectory​(T dir,
                                   IOException exc)
                            throws IOException
        在目录中的条目之后调用目录，并且已经访问了所有的后代。 当该目录的迭代过早完成（通过返回SKIP_SIBLINGS的visitFile方法或者在遍历目录时发生I / O错误），也会调用此方法。
        参数
        dir - 对目录的引用
        exc - null如果目录的迭代完成没有错误; 否则会导致目录的迭代过早完成的I / O异常
        结果
        访问结果
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileVisitResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.nio.file

Enum FileVisitResult

  • java.lang.Object
    • java.lang.Enum<FileVisitResult>
      • java.nio.file.FileVisitResult
  • All Implemented Interfaces:
    Serializable ， Comparable<FileVisitResult>

    public enum FileVisitResult
extends Enum<FileVisitResult>
    结果类型为FileVisitor 。
    从以下版本开始：
    1.7
    另请参见：
    Files.walkFileTree(java.nio.file.Path, java.util.Set<java.nio.file.FileVisitOption>, int, java.nio.file.FileVisitor<? super java.nio.file.Path>)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CONTINUE
      继续。
      SKIP_SIBLINGS
      继续，不要访问此文件或目录的 兄弟姐妹 。
      SKIP_SUBTREE
      继续访问此目录中的条目。
      TERMINATE
      终止。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FileVisitResult valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FileVisitResult[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONTINUE

        public static final FileVisitResult CONTINUE
        继续。 当从preVisitDirectory方法返回时，目录中的条目也应该被访问。

      • TERMINATE

        public static final FileVisitResult TERMINATE
        终止。

      • SKIP_SUBTREE

        public static final FileVisitResult SKIP_SUBTREE
        继续访问此目录中的条目。 此结果仅在从preVisitDirectory方法返回时才有意义; 否则此结果类型与返回CONTINUE相同。

      • SKIP_SIBLINGS

        public static final FileVisitResult SKIP_SIBLINGS
        继续，不要访问此文件或目录的兄弟姐妹 。 如果从preVisitDirectory方法返回，那么目录中的条目也将被跳过，并且不会调用postVisitDirectory方法。

    • 方法详细信息

      • values

        public static FileVisitResult[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (FileVisitResult c : FileVisitResult.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static FileVisitResult valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


InvalidPathException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class InvalidPathException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.file.InvalidPathException
  • All Implemented Interfaces:
    Serializable

    public class InvalidPathException
extends IllegalArgumentException
    当路径字符串无法转换为Path时，由于路径字符串包含无效字符或路径字符串对于其他文件系统特定的原因无效，因此抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidPathException​(String input, String reason)
      从给定的输入字符串构造一个实例和原因。
      InvalidPathException​(String input, String reason, int index)
      从给定的输入字符串，原因和错误索引构造一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getIndex​()
      返回到发生错误的位置的输入字符串中的索引，如果此位置 -1则 -1 。
      String getInput​()
      返回输入字符串。
      String getMessage​()
      返回描述错误的字符串。
      String getReason​()
      返回一个字符串，解释为什么输入字符串被拒绝。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidPathException

        public InvalidPathException​(String input,
                            String reason,
                            int index)
        从给定的输入字符串，原因和错误索引构造一个实例。
        参数
        input - 输入字符串
        reason - 一个解释为什么输入被拒绝的字符串
        index - 发生错误的索引，如果索引未知， -1
        异常
        NullPointerException - 输入或原因字符串是否为 null
        IllegalArgumentException - 如果错误索引小于 -1

      • InvalidPathException

        public InvalidPathException​(String input,
                            String reason)
        从给定的输入字符串构造一个实例和原因。 结果对象的错误索引-1 。
        参数
        input - 输入字符串
        reason - 一个字符串，解释为什么输入被拒绝
        异常
        NullPointerException - 输入或原因字符串是否为 null

    • 方法详细信息

      • getInput

        public String getInput​()
        返回输入字符串。
        结果
        输入字符串

      • getReason

        public String getReason​()
        返回一个字符串，解释为什么输入字符串被拒绝。
        结果
        原因是字符串

      • getIndex

        public int getIndex​()
        返回到发生错误的位置的输入字符串中的索引，如果此位置不知道，则 -1 。
        结果
        错误索引

      • getMessage

        public String getMessage​()
        返回描述错误的字符串。 生成的字符串由原因字符串后面跟一个冒号字符（ ':' ），空格和输入字符串组成。 如果定义了错误索引，则字符串" at index "后跟索引（十进制）插入到原因字符串之后和冒号字符之前。
        重写：
        getMessage在 Throwable
        结果
        描述错误的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.nio.file (Java SE 9 & JDK 9 )

java.nio.file

Interfaces

  • CopyOption
  • DirectoryStream
  • DirectoryStream.Filter
  • FileVisitor
  • OpenOption
  • Path
  • PathMatcher
  • SecureDirectoryStream
  • Watchable
  • WatchEvent
  • WatchEvent.Kind
  • WatchEvent.Modifier
  • WatchKey
  • WatchService

Classes

  • Files
  • FileStore
  • FileSystem
  • FileSystems
  • LinkPermission
  • Paths
  • SimpleFileVisitor
  • StandardWatchEventKinds

Enums

  • AccessMode
  • FileVisitOption
  • FileVisitResult
  • LinkOption
  • StandardCopyOption
  • StandardOpenOption

Exceptions

  • AccessDeniedException
  • AtomicMoveNotSupportedException
  • ClosedDirectoryStreamException
  • ClosedFileSystemException
  • ClosedWatchServiceException
  • DirectoryIteratorException
  • DirectoryNotEmptyException
  • FileAlreadyExistsException
  • FileSystemAlreadyExistsException
  • FileSystemException
  • FileSystemLoopException
  • FileSystemNotFoundException
  • InvalidPathException
  • NoSuchFileException
  • NotDirectoryException
  • NotLinkException
  • ProviderMismatchException
  • ProviderNotFoundException
  • ReadOnlyFileSystemException


java.nio.file (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.nio.file

定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

java.nio.file包定义了访问文件和文件系统的类。 访问文件和文件系统属性的API在java.nio.file.attribute包中定义。 java.nio.file.spi包由希望扩展平台默认提供商的服务提供商实现者使用，或构建其他提供商实现。

Symbolic Links

许多操作系统和文件系统支持符号链接 。 符号链接是一个特殊的文件，用作对另一个文件的引用。 在大多数情况下，符号链接对应用程序是透明的，符号链接上的操作将自动重定向到链接的目标 。 例外情况是，当删除或重命名/移动符号链接时，链接被删除或删除而不是链接的目标。 该包包括对实现提供这些语义的符号链接的支持。 文件系统可能支持语义上相似的其他类型，但这些其他类型的链接的支持不包括在此包中。

Interoperability

File类通过转换由java.io.File对象表示的抽象路径来定义toPath方法来构造一个Path 。 所得到的Path可用于与File对象相同的文件操作。 所述Path规范提供了关于所述另外的信息interoperability之间Path和java.io.File对象。

能见度

该包中的类提供的文件和文件系统的视图保证与同一Java虚拟机中的其他实例提供的其他视图一致。 然而，由于底层操作系统执行的缓存和网络文件系统协议引起的延迟，视图可能也可能不与其他并发运行的程序所见的文件系统的视图一致。 无论这些其他程序的编写语言如何，以及它们是在同一台机器还是在其他机器上运行，都是如此。 任何这种不一致的确切性质是系统依赖性的，因此是未指定的。

Synchronized I/O File Integrity

当打开文件以使文件的更新与底层存储设备同步写入时，将使用SYNC和DSYNC选项。 在默认提供程序的情况下，并且该文件驻留在本地存储设备上，并且seekable通道已连接到使用其中一个选项打开的文件，则仅保证write方法的调用在所有通过该调用对文件所做的更改已写入设备。 这些选项对于确保在系统崩溃时不会丢失关键信息非常有用。 如果文件不在本地设备上，则不会提供此类保证。 与其他provider实现是否可以保证是提供者特定的。

一般例外

除非另有说明，否则将null参数传递给此程序包中任何类或接口的构造函数或方法将导致抛出NullPointerException 。 另外，除非另有说明，否则调用包含null元素的数组或集合的方法将导致一个NullPointerException 。

除非另有说明，尝试访问文件系统的方法将引发ClosedFileSystemException上有关联的对象调用时FileSystem已经closed 。 此外，当与仅提供只读访问的FileSystem相关联的对象上调用时，尝试写入文件系统的任何方法将抛出ReadOnlyFileSystemException 。

除非另有说明，否则调用由一个provider创建的任何类或接口的方法，该参数是由另一个提供者创建的对象的参数，将抛出ProviderMismatchException 。

可选具体异常

访问文件系统的此包中的类定义的大多数方法指定当发生I / O错误时抛出IOException 。 在某些情况下，这些方法定义了常见情况下的特定I / O异常。 这些例外，被注意为可选的特殊例外 ，由实现方法抛出，可以检测到特定的错误。 在无法检测到特定错误的IOException则抛出更一般的IOException 。
从以下版本开始：
1.7
  • 接口摘要
    接口 描述
    CopyOption
    配置如何复制或移动文件的对象。
    DirectoryStream<T>
    一个对象来迭代目录中的条目。
    DirectoryStream.Filter<T>
    由对象执行的接口，用于确定是否应接受或过滤目录条目。
    FileVisitor<T>
    文件访问者
    OpenOption
    配置如何打开或创建文件的对象。
    Path
    可用于在文件系统中定位文件的对象。
    PathMatcher
    由对路径执行匹配操作的对象实现的接口。
    SecureDirectoryStream<T>
    A DirectoryStream ，它定义相对于打开的目录定位的文件的操作。
    Watchable
    可以注册到手表服务的对象，以便可以 观看更改和事件。
    WatchEvent<T>
    对WatchService注册的对象的事件或重复事件。
    WatchEvent.Kind<T>
    一种事件类型，用于识别。
    WatchEvent.Modifier
    一个事件修饰符，符合Watchable如何注册WatchService 。
    WatchKey
    表示watchable对象与WatchService的注册的令牌。
    WatchService
    手表服务， 手表已注册的对象的变化和事件。
  • 类摘要
    Class 描述
    Files
    该类只包含对文件，目录或其他类型文件进行操作的静态方法。
    FileStore
    文件存储
    FileSystem
    提供文件系统的接口，并且是工厂用于访问文件系统中的文件和其他对象的对象。
    FileSystems
    文件系统的工厂方法。
    LinkPermission
    Permission类链接创建操作。
    Paths
    该类由静态方法组成，通过转换路径字符串返回Path或URI 。
    SimpleFileVisitor<T>
    具有默认行为的简单文件访问者访问所有文件并重新抛出I / O错误。
    StandardWatchEventKinds
    定义 标准事件种类。
  • 枚举摘要
    Enum 描述
    AccessMode
    定义用于测试文件可访问性的访问模式。
    FileVisitOption
    定义文件树遍历选项。
    FileVisitResult
    结果类型为FileVisitor 。
    LinkOption
    定义如何处理符号链接的选项。
    StandardCopyOption
    定义标准复制选项。
    StandardOpenOption
    定义标准的开放选项。
  • 异常摘要
    异常 描述
    AccessDeniedException
    文件系统操作被拒绝时引发的检查异常，通常是由于文件权限或其他访问检查。
    AtomicMoveNotSupportedException
    当文件不能作为原子文件系统操作移动时，检查的异常抛出。
    ClosedDirectoryStreamException
    尝试在关闭的目录流上调用操作时抛出未检查的异常。
    ClosedFileSystemException
    尝试在文件上调用操作并关闭文件系统时抛出未检查的异常。
    ClosedWatchServiceException
    尝试在关闭的手表服务上调用操作时抛出未检查的异常。
    DirectoryIteratorException
    如果在遍历目录中的条目时遇到I / O错误，则抛出运行时异常。
    DirectoryNotEmptyException
    由于目录不为空，文件系统操作失败时抛出的检查异常。
    FileAlreadyExistsException
    尝试创建文件或目录并且该名称的文件已存在时，检查的异常抛出。
    FileSystemAlreadyExistsException
    新新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新
    FileSystemException
    在一个或两个文件上的文件系统操作失败时抛出。
    FileSystemLoopException
    当遇到文件系统循环或循环时抛出的检查异常。
    FileSystemNotFoundException
    无法找到文件系统时抛出的运行时异常。
    InvalidPathException
    当路径字符串不能转换为Path时，由于路径字符串包含无效字符或路径字符串对于其他文件系统特定的原因无效，因此抛出未检查的异常。
    NoSuchFileException
    当尝试访问不存在的文件时抛出检查的异常。
    NotDirectoryException
    当文件系统操作用于目录时，由于文件不是目录而导致失败的检查异常。
    NotLinkException
    由于文件不是符号链接，文件系统操作失败时抛出的检查异常。
    ProviderMismatchException
    当尝试使用由不同文件系统提供程序创建的参数在一个文件系统提供程序创建的对象上调用方法时抛出未检查的异常。
    ProviderNotFoundException
    无法找到所需类型的提供者时抛出的运行时异常。
    ReadOnlyFileSystemException
    尝试更新与 read-only FileSystem相关联的对象时抛出未检查的异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.nio.file Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.nio.file

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.nio.file.Files
    • java.nio.file.FileStore
    • java.nio.file.FileSystem (implements java.io.Closeable)
    • java.nio.file.FileSystems
    • java.nio.file.Paths
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.nio.file.LinkPermission
    • java.nio.file.SimpleFileVisitor<T> (implements java.nio.file.FileVisitor<T>)
    • java.nio.file.StandardWatchEventKinds
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • java.nio.file.FileSystemException
            • java.nio.file.AccessDeniedException
            • java.nio.file.AtomicMoveNotSupportedException
            • java.nio.file.DirectoryNotEmptyException
            • java.nio.file.FileAlreadyExistsException
            • java.nio.file.FileSystemLoopException
            • java.nio.file.NoSuchFileException
            • java.nio.file.NotDirectoryException
            • java.nio.file.NotLinkException
        • java.lang.RuntimeException
          • java.util.ConcurrentModificationException
            • java.nio.file.DirectoryIteratorException
          • java.nio.file.FileSystemAlreadyExistsException
          • java.nio.file.FileSystemNotFoundException
          • java.lang.IllegalArgumentException
            • java.nio.file.InvalidPathException
            • java.nio.file.ProviderMismatchException
          • java.lang.IllegalStateException
            • java.nio.file.ClosedDirectoryStreamException
            • java.nio.file.ClosedFileSystemException
            • java.nio.file.ClosedWatchServiceException
          • java.nio.file.ProviderNotFoundException
          • java.lang.UnsupportedOperationException
            • java.nio.file.ReadOnlyFileSystemException

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • java.nio.file.DirectoryStream<T> (also extends java.lang.Iterable<T>)
        • java.nio.file.SecureDirectoryStream<T>
      • java.nio.file.WatchService
  • java.lang.Comparable<T>
    • java.nio.file.Path (also extends java.lang.Iterable<T>, java.nio.file.Watchable)
  • java.nio.file.CopyOption
  • java.nio.file.DirectoryStream.Filter<T>
  • java.nio.file.FileVisitor<T>
  • java.lang.Iterable<T>
    • java.nio.file.DirectoryStream<T> (also extends java.io.Closeable)
      • java.nio.file.SecureDirectoryStream<T>
    • java.nio.file.Path (also extends java.lang.Comparable<T>, java.nio.file.Watchable)
  • java.nio.file.OpenOption
  • java.nio.file.PathMatcher
  • java.nio.file.Watchable
    • java.nio.file.Path (also extends java.lang.Comparable<T>, java.lang.Iterable<T>)
  • java.nio.file.WatchEvent<T>
  • java.nio.file.WatchEvent.Kind<T>
  • java.nio.file.WatchEvent.Modifier
  • java.nio.file.WatchKey

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.nio.file.AccessMode
      • java.nio.file.FileVisitOption
      • java.nio.file.FileVisitResult
      • java.nio.file.LinkOption (implements java.nio.file.CopyOption, java.nio.file.OpenOption)
      • java.nio.file.StandardCopyOption (implements java.nio.file.CopyOption)
      • java.nio.file.StandardOpenOption (implements java.nio.file.OpenOption)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LinkOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.nio.file

Enum LinkOption

  • java.lang.Object
    • java.lang.Enum<LinkOption>
      • java.nio.file.LinkOption
  • All Implemented Interfaces:
    Serializable ， Comparable<LinkOption> ， CopyOption ， OpenOption

    public enum LinkOption
extends Enum<LinkOption>
implements OpenOption, CopyOption
    定义如何处理符号链接的选项。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NOFOLLOW_LINKS
      不要跟随符号链接。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static LinkOption valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static LinkOption[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NOFOLLOW_LINKS

        public static final LinkOption NOFOLLOW_LINKS
        不要跟随符号链接。
        另请参见：
        Files.getFileAttributeView(Path,Class,LinkOption[]) ，
Files.copy(java.nio.file.Path, java.nio.file.Path, java.nio.file.CopyOption...) ，
SecureDirectoryStream.newByteChannel(T, java.util.Set<? extends java.nio.file.OpenOption>, java.nio.file.attribute.FileAttribute<?>...)

    • 方法详细信息

      • values

        public static LinkOption[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (LinkOption c : LinkOption.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static LinkOption valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


LinkPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class LinkPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.nio.file.LinkPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class LinkPermission
extends BasicPermission
    Permission类链接创建操作。

    下表提供了许可允许的简要说明，并讨论了授予代码许可的风险。

    Table shows permission target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission hard Ability to add an existing file to a directory. This is sometimes known as creating a link, or hard link. Extreme care should be taken when granting this permission. It allows linking to any file or directory in the file system thus allowing the attacker access to all files. symbolic Ability to create symbolic links. Extreme care should be taken when granting this permission. It allows linking to any file or directory in the file system thus allowing the attacker to access to all files.
    从以下版本开始：
    1.7
    另请参见：
    Files.createLink(java.nio.file.Path, java.nio.file.Path) ， Files.createSymbolicLink(java.nio.file.Path, java.nio.file.Path, java.nio.file.attribute.FileAttribute<?>...) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinkPermission​(String name)
      构造具有指定名称的 LinkPermission 。
      LinkPermission​(String name, String actions)
      构造具有指定名称的 LinkPermission 。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • LinkPermission

        public LinkPermission​(String name)
        构造具有指定名称的 LinkPermission 。
        参数
        name - 权限的名称。 它必须是“硬”或“象征性”的。
        异常
        IllegalArgumentException - 如果名称为空或无效

      • LinkPermission

        public LinkPermission​(String name,
                      String actions)
        构造具有指定名称的 LinkPermission 。
        参数
        name - 许可的名称; 必须是“硬”或“象征性”的。
        actions - 许可的动作; 必须是空字符串或null
        异常
        IllegalArgumentException - if name is empty or invalid, or actions is a non-empty string
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NoSuchFileException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class NoSuchFileException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.FileSystemException
            • java.nio.file.NoSuchFileException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchFileException
extends FileSystemException
    当尝试访问不存在的文件时抛出检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchFileException​(String file)
      构造这个类的一个实例。
      NoSuchFileException​(String file, String other, String reason)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.nio.file.FileSystemException

        getFile, getMessage, getOtherFile, getReason

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchFileException

        public NoSuchFileException​(String file)
        构造这个类的一个实例。
        参数
        file - 如果不知道，则标识文件的字符串或 null 。

      • NoSuchFileException

        public NoSuchFileException​(String file,
                           String other,
                           String reason)
        构造这个类的一个实例。
        参数
        file - 如果不知道，则标识文件的字符串或 null 。
        other - 如果不知道，则标识另一个文件或 null的字符串。
        reason - 含有附加信息的原因信息或 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NotDirectoryException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class NotDirectoryException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.FileSystemException
            • java.nio.file.NotDirectoryException
  • All Implemented Interfaces:
    Serializable

    public class NotDirectoryException
extends FileSystemException
    当文件系统操作用于目录时，由于文件不是目录而导致失败的检查异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NotDirectoryException​(String file)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.nio.file.FileSystemException

        getFile, getMessage, getOtherFile, getReason

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NotDirectoryException

        public NotDirectoryException​(String file)
        构造这个类的一个实例。
        参数
        file - a string identifying the file or null if not known
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NotLinkException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class NotLinkException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.FileSystemException
            • java.nio.file.NotLinkException
  • All Implemented Interfaces:
    Serializable

    public class NotLinkException
extends FileSystemException
    由于文件不是符号链接，文件系统操作失败时抛出的检查异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NotLinkException​(String file)
      构造这个类的一个实例。
      NotLinkException​(String file, String other, String reason)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.nio.file.FileSystemException

        getFile, getMessage, getOtherFile, getReason

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NotLinkException

        public NotLinkException​(String file)
        构造这个类的一个实例。
        参数
        file - 如果不知道，则标识文件或 null的字符串

      • NotLinkException

        public NotLinkException​(String file,
                        String other,
                        String reason)
        构造这个类的一个实例。
        参数
        file - 如果不知道，则标识文件的字符串或 null
        other - 如果不知道，则标识另一个文件的字符串或 null
        reason - 含有附加信息的原因信息或 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OpenOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface OpenOption

  • 所有已知实现类：
    LinkOption ， StandardOpenOption

    public interface OpenOption
    配置如何打开或创建文件的对象。

    这种类型的目的是通过如方法中使用newOutputStream ， newByteChannel ， FileChannel.open ，和AsynchronousFileChannel.open打开或创建文件时。

    StandardOpenOption枚举类型定义了标准选项。

    从以下版本开始：
    1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Path (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface Path

  • All Superinterfaces:
    Comparable<Path> ， Iterable<Path> ， Watchable

    public interface Path
extends Comparable<Path>, Iterable<Path>, Watchable
    可用于在文件系统中定位文件的对象。 它通常表示系统相关的文件路径。

    A Path表示一个分层的路径，由一系列由特殊的分隔符或分隔符分隔的目录和文件名元素组成。 也可以存在标识文件系统层次结构的根组件 。 距离目录层次结构根目录最远的名称元素是文件或目录的名称。 其他名称元素是目录名称。 A Path可以表示根，根和序列的名称，或简单的一个或多个名称元素。 如果一个Path仅由一个空的名称元素组成，则认为是一个空的路径 。 使用空路径访问文件等同于访问文件系统的默认目录。 Path定义getFileName ， getParent ， getRoot和subpath方法来访问路径部件或它的名称元素的子序列。

    除了访问路径的组件之外， Path还定义了resolve和resolveSibling方法来组合路径。 可用于构建两个路径之间的相对路径的relativize方法。 路径可以是compared ，并使用startsWith和endsWith方法相互测试。

    此接口扩展了Watchable接口，使得路径所在的目录可以是registered，具有一个WatchService和目录中的条目。

    警告：此接口仅用于开发自定义文件系统实现的那些实现。 方法可能会在以后的版本添加到此界面。

    访问文件

    路径可以与Files类一起使用，以对文件，目录和其他类型的文件进行操作。 例如，假设我们想要一个BufferedReader从文件“ access.log ”读取文本。 该文件位于相对于当前工作目录的目录“ logs ”中，并且是UTF-8编码的。

      Path path = FileSystems.getDefault().getPath("logs", "access.log");
     BufferedReader reader = Files.newBufferedReader(path, StandardCharsets.UTF_8);

    互通性

    与默认provider相关联的路径通常可与java.io.File类互操作。 由其他提供商创建的路径不太可能与由java.io.File表示的抽象路径名称互操作。 该toPath方法可以被用于获得Path从由A表示的抽象路径名java.io.File对象。 所得到的Path可用于与java.io.File对象相同的文件操作。 此外， toFile方法是有用的构建File从String一个的表示Path 。

    并发

    该接口的实现是不可变且安全的，可供多个并发线程使用。

    从以下版本开始：
    1.7
    另请参见：
    Paths

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      int compareTo​(Path other)
      比较两个抽象的路径词典。
      default boolean endsWith​(String other)
      测试此路径是否以 Path结束，通过转换给定的路径字符串，完全由 endsWith(Path)方法指定的方式 构建 。
      boolean endsWith​(Path other)
      测试此路径是否以给定的路径结束。
      boolean equals​(Object other)
      测试此路径与给定对象的相等性。
      Path getFileName​()
      将此路径表示的文件或目录的名称作为 Path对象返回。
      FileSystem getFileSystem​()
      返回创建此对象的文件系统。
      Path getName​(int index)
      返回此路径的名称元素作为 Path对象。
      int getNameCount​()
      返回路径中的名称元素的数量。
      Path getParent​()
      返回 父路径 ，如果此路径没有 父项 ，则返回 null 。
      Path getRoot​()
      返回此路径的根组分作为 Path对象，或 null如果该路径不具有根组件。
      int hashCode​()
      计算此路径的哈希码。
      boolean isAbsolute​()
      告诉这条路是否是绝对的。
      default Iterator<Path> iterator​()
      返回此路径的名称元素的迭代器。
      Path normalize​()
      返回一个路径，该路径是冗余名称元素的消除。
      default WatchKey register​(WatchService watcher, WatchEvent.Kind<?>... events)
      使用手表服务注册此路径所在的文件。
      WatchKey register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      使用手表服务注册此路径所在的文件。
      Path relativize​(Path other)
      构造此路径和给定路径之间的相对路径。
      default Path resolve​(String other)
      一个给定的路径字符串转换为 Path并解析它针对此 Path在完全按规定的方式 resolve方法。
      Path resolve​(Path other)
      根据这条路径解决给定的路径。
      default Path resolveSibling​(String other)
      将给定的路径字符串转换为 Path并按照 resolveSibling方法指定的方式将其解析为该路径的 parent路径。
      default Path resolveSibling​(Path other)
      根据此路径的 parent路径解析给定路径。
      default boolean startsWith​(String other)
      测试此路径是否以 Path ，通过转换给定的路径字符串，完全由 startsWith(Path)方法指定的方式 构建 。
      boolean startsWith​(Path other)
      测试此路径是否以给定的路径开始。
      Path subpath​(int beginIndex, int endIndex)
      返回一个相对的 Path ，它是此路径的名称元素的子序列。
      Path toAbsolutePath​()
      返回表示此路径的绝对路径的 Path对象。
      default File toFile​()
      返回一个表示此路径的File对象。
      Path toRealPath​(LinkOption... options)
      返回现有文件的 真实路径。
      String toString​()
      返回此路径的字符串表示形式。
      URI toUri​()
      返回一个URI来表示此路径。

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

    • 方法详细信息

      • getFileSystem

        FileSystem getFileSystem​()
        返回创建此对象的文件系统。
        结果
        创建此对象的文件系统

      • isAbsolute

        boolean isAbsolute​()
        告诉这条路是否是绝对的。

        绝对路径是完整的，因为它不需要与其他路径信息组合以便定位文件。

        结果
        true如果，只有这个路径是绝对的

      • getRoot

        Path getRoot​()
        返回此路径的根组分作为 Path对象，或 null如果该路径不具有根组件。
        结果
        一个表示此路径的根组件的路径，或 null

      • getFileName

        Path getFileName​()
        将该路径表示的文件或目录的名称返回为Path对象。 文件名是目录层次结构中根目录中最远的元素。
        结果
        表示文件或目录的名称的路径，如果此路径具有零个元素， null

      • getParent

        Path getParent​()
        返回父路径 ，如果此路径没有父项 ，则返回null 。

        此路径对象的父对象由此路径的根组件（如果有）和路径中的每个元素组成，除了距目录层次结构中最远的根。 此方法不访问文件系统; 路径或其父可能不存在。 此外，该方法不会消除诸如“。”之类的特殊名称。 和“..”，可以在一些实现中使用。 例如，在UNIX上，“ /a/b/c ”的父/a/b/c为“ /a/b ”， /a/b的父"x/y/.为“ x/y ”，该方法可与normalize方法一起使用，以消除冗余名称，对于类似shell的导航为需要。

        如果此路径具有多个元素，并且没有根组件，则此方法等效于评估表达式：

         subpath(0, getNameCount()-1);
        结果
        路径表示路径的父节点

      • getNameCount

        int getNameCount​()
        返回路径中的名称元素的数量。
        结果
        路径中的元素数，或 0如果此路径仅表示根组件

      • getName

        Path getName​(int index)
        返回此路径的名称元素作为Path对象。

        index参数是要返回的name元素的索引。 目录层次结构中最靠近根的元素具有索引0 。 离根最远的元素具有索引count -1 。

        参数
        index - 元素的索引
        结果
        名称元素
        异常
        IllegalArgumentException - 如果 index为负，则 index大于或等于元素数，或此路径具有零名称元素

      • subpath

        Path subpath​(int beginIndex,
             int endIndex)
        返回一个相对的Path ，它是该路径的名称元素的子序列。

        beginIndex和endIndex参数指定名称元素的子序列。 目录层次结构中最靠近根目录的名称具有索引0 。 距离根距离最远的名称具有索引count -1 。 返回的Path对象的名称元素从beginIndex开始，并扩展到索引号为endIndex-1的元素。

        参数
        beginIndex - 第一个元素的索引（包括）
        endIndex - 最后一个元素的索引，独占
        结果
        一个新的 Path对象，这是 Path中的名称元素的子 Path
        异常
        IllegalArgumentException - 如果beginIndex为负数，或大于或等于元素数。 如果endIndex小于或等于beginIndex ，或大于元素数量。

      • startsWith

        boolean startsWith​(Path other)
        测试此路径是否以给定的路径开始。

        这条道路给定的路径开始后 ，如果这个路径的根组件给定的路径的根组件开始 ，这条路径具有相同名称元素作为给定的路径开始。 如果给定路径具有比此路径更多的名称元素，则返回false 。

        该路径的根组件是否以给定路径的根组件开头是文件系统特定的。 如果此路径没有根组件，并且给定路径具有根组件，则此路径不以给定路径开始。

        如果给定的路径与该路径不同的FileSystem相关联，则返回false 。

        参数
        other - 给定的路径
        结果
        true如果此路径以给定路径开头; 否则false

      • startsWith

        default boolean startsWith​(String other)
        测试此路径是否以Path ，通过转换给定的路径字符串，完全按照startsWith(Path)方法指定的方式构建 。 例如，在UNIX上，路径“ foo/bar ”以“ foo ”和“ foo/bar ” foo/bar 。 它不以“ f ”或“ fo ” fo 。
        实现要求：
        默认实现与以下路径相当：
           startsWith(getFileSystem().getPath(other));
        参数
        other - 给定的路径字符串
        结果
        true如果这个路径从给定的路径开始; 否则false
        异常
        InvalidPathException - 如果路径字符串不能转换为路径。

      • endsWith

        boolean endsWith​(Path other)
        测试此路径是否以给定的路径结束。

        如果给定路径具有N个元素，并且没有根组件，并且该路径具有N个或更多个元素，则如果从距离根最远的元素开始的每个路径的最后N个元素相等，则该路径以给定路径结束。

        如果给定路径具有根组件，则如果此路径的根组件以给定路径的根组件结束，则该路径以给定路径结束 ，并且两个路径的相应元素相等。 该路径的根组件是否以给定路径的根组件结束是文件系统特定的。 如果此路径没有根组件，并且给定路径具有根组件，则此路径不以给定路径结束。

        如果给定路径与此路径的不同FileSystem相关联，则返回false 。

        参数
        other - 给定的路径
        结果
        true如果此路径以给定路径结束; 否则false

      • endsWith

        default boolean endsWith​(String other)
        测试此路径是否以Path ，通过转换给定的路径字符串，完全按照endsWith(Path)方法指定的方式构建 。 例如，在UNIX上，路径“ foo/bar ”以“ foo/bar ”和“ bar ” bar 。 它不以“ r ”或“ /bar ” /bar 。 请注意，尾部分隔符不被考虑，因此在Path “ foo/bar ” String “ bar/ ”返回true调用此方法。
        实现要求：
        默认实现与以下路径相当：
           endsWith(getFileSystem().getPath(other));
        参数
        other - 给定的路径字符串
        结果
        true如果此路径以给定路径结束; 否则false
        异常
        InvalidPathException - 如果路径字符串不能转换为路径。

      • normalize

        Path normalize​()
        返回一个路径，该路径是冗余名称元素的消除。

        该方法的精确定义是依赖于实现的，但通常来说，该方法源自此路径，不包含冗余名称元素的路径。 在许多文件系统中，“ . ”和“ .. ”是用于指示当前目录和父目录的特殊名称。 在这样的文件系统中，所有出现的“ . ”都被认为是冗余的。 如果“ .. ”前面有一个非“ .. ”的名称，则两个名称都被认为是冗余的（重复此过程以识别这些名称，直到不再适用）。

        此方法不访问文件系统; 该路径可能找不到存在的文件。 从路径中.. “ .. ”和前面的名称可能导致定位与原始路径不同的文件的路径。 当前面的名称是符号链接时，可能会出现这种情况。

        结果
        生成的路径或此路径，如果它不包含冗余的名称元素; 如果此路径没有根组件，并且所有名称元素都是冗余的，则返回空路径
        另请参见：
        getParent() ， toRealPath(java.nio.file.LinkOption...)

      • resolve

        Path resolve​(Path other)
        根据这条路径解决给定的路径。

        如果other参数是absolute路径，那么这个方法平常返回other 。 如果other是一个空的路径，那么这个方法平常返回这个路径。 否则，此方法将此路径视为目录，并根据此路径解析给定路径。 在最简单的情况下，给定的路径不具有一个root组件，在这种情况下，该方法将给定的路径加入到该路径中，并返回一条带有给定路径的结果路径ends 。 在给定路径具有根组件的地方，则分辨率高度依赖于实现，因此未指定。

        参数
        other - 解决此路径的路径
        结果
        结果路径
        另请参见：
        relativize(java.nio.file.Path)

      • resolve

        default Path resolve​(String other)
        一个给定的路径字符串转换为Path并解析它针对此Path在完全按规定的方式resolve方法。 例如，假设名称分隔符为“ / ”，路径表示“ foo/bar ”，则使用路径字符串“ gus ”调用此方法将导致Path “ foo/bar/gus ”。
        实现要求：
        默认实现与以下路径相当：
           resolve(getFileSystem().getPath(other));
        参数
        other - 要解决此路径的路径字符串
        结果
        结果路径
        异常
        InvalidPathException - 如果路径字符串不能转换为路径。
        另请参见：
        FileSystem.getPath(java.lang.String, java.lang.String...)

      • resolveSibling

        default Path resolveSibling​(Path other)
        根据此路径的parent路径解决给定的路径。 如果文件名需要替换为其他文件名，这是非常有用的。 例如，假设名称分隔符为“ / ”，路径表示“ dir1/dir2/foo ”，则使用Path “ bar ”调用此方法将导致Path “ dir1/dir2/bar ”。 如果此路径没有父路径，或other为absolute ，则此方法返回other 。 如果other是一个空的路径，那么这个方法返回这个路径的父，或者这个路径没有父，空的路径。
        实现要求：
        默认实现与以下路径相当：
           (getParent() == null) ? other : getParent().resolve(other);
        除非是other == null ，在这种情况下抛出一个NullPointerException 。
        参数
        other - 解决此路径父 other的路径
        结果
        结果路径
        另请参见：
        resolve(Path)

      • resolveSibling

        default Path resolveSibling​(String other)
        将给定的路径字符串转换为 Path并按照 resolveSibling方法指定的方式将其解析为该路径的 parent路径。
        实现要求：
        默认实现与以下路径相当：
           resolveSibling(getFileSystem().getPath(other));
        参数
        other - 要解决此路径父级的路径字符串
        结果
        结果路径
        异常
        InvalidPathException - 如果路径字符串不能转换为路径。
        另请参见：
        FileSystem.getPath(java.lang.String, java.lang.String...)

      • relativize

        Path relativize​(Path other)
        构造此路径和给定路径之间的相对路径。

        相对论是resolution的倒数。 该方法试图以构建relative路径，当resolved针对此路径，产生用于定位相同的文件中给定的路径的路径。 例如，在UNIX上，如果此路径为"/a/b" ，给定路径为"/a/b/c/d"则生成的相对路径为"c/d" 。 在此路径和给定路径中没有一个root组件的情况下，可以构建一个相对路径。 如果只有一个路径具有根组件，则不能构造相对路径。 如果两个路径都有一个根组件，那么如果可以构造一个相对路径，那么它是依赖于实现的。 如果此路径和给定路径为equal，则返回空路径 。

        对于任何两个normalized路径p和q ，其中q没有根组件，

        p .relativize( p .resolve( q )).equals( q )

        当支持符号链接时，结果路径是否在针对该路径解析时产生可用于定位270568298353782文件的路径，因为other是依赖于实现的。 例如，如果该路径是"/a/b" ，并且给定的路径是"/a/x"则所得到的相对路径可以是"../x" 。 如果"b"是符号链接，则实现依赖，如果"a/b/../x"将找到与"/a/x"相同的文件。

        参数
        other - 相对于此路径的路径
        结果
        所生成的相对路径，或两条路径相等的空路径
        异常
        IllegalArgumentException - 如果 other不是可以相对于此路径的 Path

      • toUri

        URI toUri​()
        返回一个URI来表示此路径。

        该方法构造一个绝对的URI ，其中scheme等于标识提供者的URI方案。 方案具体部分的确切形式依赖于提供商。

        在默认提供程序的情况下，URI是分层的，具有绝对的path组件。 查询和片段组件未定义。 是否定义了权限组件是否依赖于实现。 不能保证URI可以用来构建一个java.io.File 。 特别地，如果该路径表示通用命名约定（UNC）路径，则可以在所得到的URI的权限组件中编码UNC服务器名称。 在默认提供程序的情况下，文件存在，并且可以确定该文件是目录，则生成的URI将以斜线结尾。

        默认提供商为File类提供了类似的往返保证。 对于给定的Path p，这是有保证的

        Paths.get ( p .toUri()).equals( p . toAbsolutePath ())
        只要原Path ，该URI ，新Path都在（可能是不同的调用）相同的Java虚拟机创建。 其他提供者是否提供任何保证是提供者特定的，因此未指定。

        当构建文件系统以访问文件的内容作为文件系统时，如果返回的URI表示文件系统中的给定路径，则它是高度实现特定的，或者它表示对包含文件系统的URI进行编码的复合 URI 。 此版本中未定义复合URI的格式; 这样的方案可以在将来的版本中添加。

        结果
        表示此路径的URI
        异常
        IOError - 如果获取绝对路径发生I / O错误，或文件系统被构造为访问作为文件系统的文件内容，并且无法获取封闭文件系统的URI
        SecurityException - 在默认提供程序和安全管理器的情况下， toAbsolutePath方法会引发安全异常。

      • toAbsolutePath

        Path toAbsolutePath​()
        返回表示此路径的绝对路径的Path对象。

        如果这个路径已经是absolute，那么这个方法只是返回这个路径。 否则，此方法通过依赖于实现方式来解析路径，通常通过解析文件系统默认目录的路径。 根据实现情况，如果文件系统不可访问，此方法可能会导致I / O错误。

        结果
        一个表示绝对路径的 Path对象
        异常
        IOError - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，并且该路径不是绝对的，然后调用安全管理器的 checkPropertyAccess方法来检查对系统属性的访问 user.dir

      • toRealPath

        Path toRealPath​(LinkOption... options)
         throws IOException
        返回现有文件的真实路径。

        该方法的确切定义是依赖于实现的，但通常来说，该路径来源于一个27056829938585路径，该路径将same文件定位为此路径，但是具有表示目录和文件的实际名称的名称元素。 例如，在文件系统上的文件名比较不区分大小写的情况下，名称元素表示实际情况下的名称。 此外，生成的路径具有删除的冗余名称元素。

        如果这个路径是相对的，那么首先得到它的绝对路径，好像通过调用toAbsolutePath方法。

        options数组可用于指示如何处理符号链接。 默认情况下，符号链接被解析为最终目标。 如果选项NOFOLLOW_LINKS存在，则此方法不会解析符号链接。 一些实现允许使用诸如“ .. ”的特殊名称来引用父目录。 当导出实际路径时 ，“ .. ”（或等价物）前面有一个非“ .. ”名称，那么实现通常会导致两个名称被删除。 当不解析符号链接并且前面的名称是一个符号链接时，只有当它保证生成的路径将找到与该路径相同的文件时，这些名称才被删除。

        参数
        options - 表示如何处理符号链接的选项
        结果
        绝对路径代表由该对象定位的文件的 真实路径
        异常
        IOException - 如果文件不存在或发生I / O错误
        SecurityException - 如果是默认提供程序，并且安装了一个安全管理器，则会调用其 checkRead方法来检查对该文件的读取访问，并且该路径不是绝对的，其 checkPropertyAccess方法被调用以检查对系统属性的访问 user.dir

      • toFile

        default File toFile​()
        返回一个表示此路径的File对象。 在这个Path与默认提供程序相关联的情况下，该方法相当于返回一个使用此路径的String表示构造的一个File对象。

        如果这个路径是通过调用创建File toPath方法那么就不能保证File通过这个方法返回的对象是equal原来的File 。

        实现要求：
        默认实现与以下路径相当：
           new File(toString());
        如果FileSystem这创造了这个Path是默认的文件系统; 否则抛出一个UnsupportedOperationException 。
        结果
        一个表示此路径的 File对象
        异常
        UnsupportedOperationException - 如果此 Path未与默认提供程序相关联

      • register

        WatchKey register​(WatchService watcher,
                  WatchEvent.Kind<?>[] events,
                  WatchEvent.Modifier... modifiers)
           throws IOException
        使用手表服务注册此路径所在的文件。

        在此版本中，此路径定位存在的目录。 该目录已注册到手表服务，以便可以观看目录中的条目。 events参数是要注册的事件，可能包含以下事件：

        • ENTRY_CREATE - 创建或移动到目录中的条目
        • ENTRY_DELETE - 条目删除或移出目录
        • ENTRY_MODIFY - 目录中的条目已修改

        这些事件的context是由此路径定位的目录和找到创建，删除或修改的目录条目的路径之间的相对路径。

        该事件集可能包括未由枚举StandardWatchEventKinds定义的附加实现特定事件

        modifiers参数指定限定目录注册方式的修饰符 。 此版本未定义任何标准修饰符。 它可能包含实现特定的修饰符。

        如果文件通过符号链接注册到手表服务，那么如果手表在注册后继续依赖于符号链接的存在，那么它是具体的实现。

        Specified by:
        register在接口 Watchable
        参数
        watcher - 要注册该对象的监视服务
        events - 应该注册此对象的事件
        modifiers - 修改器（如果有的话）修改对象的注册方式
        结果
        表示使用给定的手表服务注册此对象的键
        异常
        UnsupportedOperationException - 如果指定了不支持的事件或修饰符
        IllegalArgumentException - 如果指定了事件或修饰符的无效组合
        ClosedWatchServiceException - 如果手表服务关闭
        NotDirectoryException - 如果该文件已注册以观看目录中的条目，并且该文件不是目录 （可选的特定异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。

      • register

        default WatchKey register​(WatchService watcher,
                          WatchEvent.Kind<?>... events)
                   throws IOException
        使用手表服务注册此路径所在的文件。

        调用此方法的行为方式与调用完全相同

          watchable.register(watcher, events, new WatchEvent.Modifier[0]);

        使用示例：假设我们要注册一个目录来创建，删除和修改事件：

          Path dir = ...
     WatchService watcher = ...

     WatchKey key = dir.register(watcher, ENTRY_CREATE, ENTRY_DELETE, ENTRY_MODIFY);
        Specified by:
        register在接口 Watchable
        实现要求：
        默认实现与以下路径相当：
           register(watcher, events, new WatchEvent.Modifier[0]);
        参数
        watcher - 要注册该对象的监视服务
        events - 应该注册此对象的事件
        结果
        表示使用指定监视服务注册此对象的键
        异常
        UnsupportedOperationException - 如果指定了不支持的事件
        IllegalArgumentException - 如果指定了无效的事件组合
        ClosedWatchServiceException - 如果手表服务关闭
        NotDirectoryException - 如果该文件已注册以观看目录中的条目，并且该文件不是目录 （可选的特定异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 checkRead方法来检查对该文件的读取访问。

      • iterator

        default Iterator<Path> iterator​()
        返回此路径的名称元素的迭代器。

        迭代器返回的第一个元素表示目录层次结构中最接近根的名称元素，第二个元素是下一个元素，依此类推。 返回的最后一个元素是由此路径表示的文件或目录的名称。 root组件（如果存在）不由迭代器返回。

        Specified by:
        iterator在接口 Iterable<Path>
        实现要求：
        默认实现返回一个 Iterator<Path> ，对于该路径， Path遍历 Path返回的 getName(index) ，其中 index范围从零到 getNameCount() - 1 （包括）。
        结果
        这个路径的名称元素的迭代器。

      • compareTo

        int compareTo​(Path other)
        比较两个抽象的路径词典。 由此方法定义的排序是提供者特定的，在默认提供程序的情况下，具体为平台。 此方法不访问文件系统，并且都不需要文件存在。

        该方法可能不用于比较与不同文件系统提供程序相关联的路径。

        Specified by:
        compareTo在接口 Comparable<Path>
        参数
        other - 与此路径相比的路径。
        结果
        如果参数为该路径的 equal ，则为零，如果此路径在字典上小于参数，则该值小于零，或者如果该路径在字典上大于参数，则该值大于零
        异常
        ClassCastException - 如果路径与不同的提供者相关联

      • equals

        boolean equals​(Object other)
        测试此路径与给定对象的相等性。

        如果给定的对象不是路径，或者是与不同的FileSystem相关联的路径，则此方法返回false 。

        两条路径是否相等取决于文件系统的实现。 在某些情况下，不考虑情况比较路径，而其他路径是区分大小写的。 该方法不访问文件系统，并且不需要该文件。 如果需要，可以使用isSameFile方法来检查两个路径是否找到相同的文件。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在 Object
        参数
        other - 要比较此对象的对象
        结果
        true如果，并且只有当给定的对象是一个 Path与 Path相同
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        计算此路径的哈希码。

        散列码基于路径的组成部分，并满足Object.hashCode方法的一般合同。

        重写：
        hashCode在 Object
        结果
        该路径的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        String toString​()
        返回此路径的字符串表示形式。

        如果通过使用getPath方法转换路径字符串创建此路径，则此方法返回的路径字符串可能与用于创建路径的原始String不同。

        返回的路径字符串使用默认名称separator来分隔路径中的名称。

        重写：
        toString在 Object
        结果
        该路径的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PathMatcher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface PathMatcher

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface PathMatcher
    由对路径执行匹配操作的对象实现的接口。
    从以下版本开始：
    1.7
    另请参见：
    FileSystem.getPathMatcher(java.lang.String) ， Files.newDirectoryStream(Path,String)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean matches​(Path path)
      告诉给定路径是否匹配该匹配器的模式。

    • 方法详细信息

      • matches

        boolean matches​(Path path)
        告诉给定路径是否匹配该匹配器的模式。
        参数
        path - 匹配的路径
        结果
        true如果，并且只有当路径匹配该匹配器的模式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Paths (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class Paths

  • java.lang.Object
    • java.nio.file.Paths

  • public final class Paths
extends Object
    该类完全由返回一个静态方法Path通过转换路径字符串或URI 。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Path get​(String first, String... more)
      将路径字符串或连接到路径字符串的字符串序列转换为 Path 。
      static Path get​(URI uri)
      将给定的URI转换为Path对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • get

        public static Path get​(String first,
                       String... more)
        将路径字符串或连接到路径字符串的字符串序列转换为Path 。 如果more没有指定任何元素，那么first参数的值是要转换的路径字符串。 如果more指定一个或多个元素，则每个非空字符串（包括first ）被认为是名称元素的序列（参见Path ），并被连接以形成路径字符串。 关于字符串如何连接的细节是提供者特定的，但通常将使用name-separator作为分隔符来连接。 例如，如果名称分隔符为“ / ”并且调用了getPath("/foo","bar","gus") ，则路径字符串"/foo/bar/gus"将转换为Path 。 一个Path表示空路径如果返回first为空字符串，并且more不包含任何非空字符串。

        Path是通过调用default default FileSystem的getPath方法获得的。

        请注意，虽然这种方法非常方便，但使用它将意味着假定引用默认的FileSystem并限制调用代码的实用性。 因此，它不应该用于旨在灵活重用的库代码。 更灵活的替代方法是使用现有的Path实例作为锚点，例如：

          Path dir = ...
     Path path = dir.resolve("file");
        参数
        first - 路径字符串或路径字符串的初始部分
        more - 要连接的附加字符串以形成路径字符串
        结果
        由此产生 Path
        异常
        InvalidPathException - 如果路径字符串不能转换为 Path
        另请参见：
        FileSystem.getPath(java.lang.String, java.lang.String...)

      • get

        public static Path get​(URI uri)
        将给定的URI转换为Path对象。

        该方法遍历installed提供程序来定位由给定URI的URI scheme标识的提供程序。 比较URI方案而不考虑情况。 如果提供者被发现，则调用其getPath方法来转换URI。

        在由URI方案“file”标识的默认提供者的情况下，给定的URI具有非空路径组件，以及未定义的查询和片段组件。 权限组件是否可以存在是平台特定的。 返回的Path与default文件系统相关联。

        默认提供商为File类提供了类似的往返保证。 对于给定的Path p，这是有保证的

        Paths.get( p . toUri ()).equals( p . toAbsolutePath ())
        只要原Path ，该URI ，新Path都在（可能是不同的调用）相同的Java虚拟机创建。 其他提供者是否提供任何保证是提供者特定的，因此未指定。
        参数
        uri - 要转换的URI
        结果
        由此产生 Path
        异常
        IllegalArgumentException - 如果uri参数的前提条件不成立。 URI的格式是提供者特定的。
        FileSystemNotFoundException - 由URI标识的文件系统不存在，不能自动创建，或者由URI的方案组件标识的提供程序未安装
        SecurityException - 如果安装了一个安全管理器，并且它拒绝访问文件系统的未指定权限
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProviderMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class ProviderMismatchException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.file.ProviderMismatchException
  • All Implemented Interfaces:
    Serializable

    public class ProviderMismatchException
extends IllegalArgumentException
    当尝试使用由不同文件系统提供程序创建的参数在一个文件系统提供程序创建的对象上调用方法时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProviderMismatchException​()
      构造这个类的一个实例。
      ProviderMismatchException​(String msg)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ProviderMismatchException

        public ProviderMismatchException​()
        构造这个类的一个实例。

      • ProviderMismatchException

        public ProviderMismatchException​(String msg)
        构造这个类的一个实例。
        参数
        msg - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProviderNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class ProviderNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.nio.file.ProviderNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class ProviderNotFoundException
extends RuntimeException
    无法找到所需类型的提供者时抛出的运行时异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProviderNotFoundException​()
      构造这个类的一个实例。
      ProviderNotFoundException​(String msg)
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ProviderNotFoundException

        public ProviderNotFoundException​()
        构造这个类的一个实例。

      • ProviderNotFoundException

        public ProviderNotFoundException​(String msg)
        构造这个类的一个实例。
        参数
        msg - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyFileSystemException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class ReadOnlyFileSystemException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.UnsupportedOperationException
            • java.nio.file.ReadOnlyFileSystemException
  • All Implemented Interfaces:
    Serializable

    public class ReadOnlyFileSystemException
extends UnsupportedOperationException
    尝试更新与 read-only FileSystem相关联的对象时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyFileSystemException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ReadOnlyFileSystemException

        public ReadOnlyFileSystemException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SecureDirectoryStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface SecureDirectoryStream<T>

  • All Superinterfaces:
    AutoCloseable ， Closeable ， DirectoryStream<T> ， Iterable<T>

    public interface SecureDirectoryStream<T>
extends DirectoryStream<T>
    A DirectoryStream可以定义相对于打开目录定位的文件的操作。 A SecureDirectoryStream旨在供复杂或安全敏感的应用程序使用，需要遍历文件树或以无竞争的方式操作目录。 当一系列文件操作不能单独执行时，可能会出现竞争条件。 由此接口定义的每个文件操作都指定相对路径。 无论目录何时被打开，目录被攻击者移动或替换，对文件的所有访问都是相对于打开的目录。 A SecureDirectoryStream也可以用作虚拟工作目录 。

    A SecureDirectoryStream需要来自底层操作系统的相应支持。 在实现支持此功能的DirectoryStream由newDirectoryStream方法返回的DirectoryStream将为SecureDirectoryStream并且必须转换为该类型才能调用此接口定义的方法。

    在默认情况下为provider ，并且设置了安全管理器，则使用通过解决相对于目录的原始路径的给定相对路径而获得的路径来执行权限检查（不管该目录是否被打开以来是否被移动） ）。

    从以下版本开始：
    1.7

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.nio.file.DirectoryStream

        DirectoryStream.Filter<T>

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void deleteDirectory​(T path)
      删除目录。
      void deleteFile​(T path)
      删除文件。
      <V extends FileAttributeView>
      V             		getFileAttributeView​(Class<V> type)
      返回一个新的文件属性视图来访问此目录的文件属性。
      <V extends FileAttributeView>
      V             		getFileAttributeView​(T path, Class<V> type, LinkOption... options)
      返回一个新的文件属性视图来访问此目录中文件的文件属性。
      void move​(T srcpath, SecureDirectoryStream<T> targetdir, T targetpath)
      将文件从该目录移动到另一个目录。
      SeekableByteChannel newByteChannel​(T path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      在此目录中打开或创建一个文件，返回可访问的字节通道以访问该文件。
      SecureDirectoryStream<T> newDirectoryStream​(T path, LinkOption... options)
      打开由给定路径标识的目录，返回一个 SecureDirectoryStream以遍历目录中的条目。

      • Methods inherited from interface java.io.Closeable

        close

      • Methods inherited from interface java.nio.file.DirectoryStream

        iterator

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

    • 方法详细信息

      • newDirectoryStream

        SecureDirectoryStream<T> newDirectoryStream​(T path,
                                            LinkOption... options)
                                     throws IOException
        打开由给定路径标识的目录，返回一个SecureDirectoryStream以遍历目录中的条目。

        对于path参数为absolute路径的情况，此方法的工作原理与newDirectoryStream方法指定的方式相同 。 当参数是相对路径时，打开的目录是相对于此打开的目录。 如果文件是符号链接，则可以使用NOFOLLOW_LINKS选项来确保此方法失败。

        一旦创建，新的目录流不依赖于用于创建它的目录流。 关闭此目录流对新创建的目录流没有影响。

        参数
        path - 打开目录的路径
        options - 表示如何处理符号链接的选项
        结果
        一个新的和开放的 SecureDirectoryStream对象
        异常
        ClosedDirectoryStreamException - 如果目录流关闭
        NotDirectoryException - 如果文件无法打开，因为它不是目录 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该目录的读取访问。

      • newByteChannel

        SeekableByteChannel newByteChannel​(T path,
                                   Set<? extends OpenOption> options,
                                   FileAttribute<?>... attrs)
                            throws IOException
        在此目录中打开或创建一个文件，返回可访问的字节通道以访问该文件。

        对于path参数为absolute路径的情况，此方法的工作原理与Files.newByteChannel方法规定的方式相同 。 当参数是相对路径时，要打开或创建的文件与此打开的目录相关。 除了Files.newByteChannel方法定义的选项之外，如果文件是符号链接，则可以使用NOFOLLOW_LINKS选项来确保此方法失败。

        一旦创建，该通道不依赖于用于创建它的目录流。 关闭此目录流对通道没有影响。

        参数
        path - 要打开或创建文件的路径
        options - 指定文件打开方式的选项
        attrs - 创建文件时以原子方式设置的属性的可选列表
        结果
        可寻址字节通道
        异常
        ClosedDirectoryStreamException - 如果目录流关闭
        IllegalArgumentException - 如果集合包含无效的选项组合
        UnsupportedOperationException - 如果指定了不受支持的打开选项，或者数组包含创建文件时无法原子设置的属性
        FileAlreadyExistsException - 如果该名称的文件已存在，并指定了 CREATE_NEW选项 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，如果文件打开以供读取，则调用checkRead方法来检查对路径的读取访问。 如果打开文件写入，则调用checkWrite方法来检查对路径的写入访问。

      • deleteFile

        void deleteFile​(T path)
         throws IOException
        删除文件。

        与delete()方法不同，此方法不会首先检查文件以确定该文件是否为目录。 是否通过此方法删除目录是系统依赖的，因此未指定。 如果文件是符号链接，则链接本身而不是链接的最终目标被删除。 当参数是相对路径时，要删除的文件是相对于此打开的目录。

        参数
        path - 要删除的文件的路径
        异常
        ClosedDirectoryStreamException - 如果目录流关闭
        NoSuchFileException - 如果文件不存在 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 checkDelete方法来检查对该文件的删除访问

      • deleteDirectory

        void deleteDirectory​(T path)
              throws IOException
        删除目录。

        与delete()方法不同，此方法不会首先检查文件以确定该文件是否为目录。 是否通过此方法删除非目录是系统依赖的，因此未指定。 当参数是相对路径时，要删除的目录是相对于此打开的目录。

        参数
        path - 要删除的目录的路径
        异常
        ClosedDirectoryStreamException - 如果目录流关闭
        NoSuchFileException - 如果目录不存在 （可选的特殊异常）
        DirectoryNotEmptyException - 如果该目录不能被删除，因为它不是空的 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 checkDelete方法来检查删除对该目录的访问

      • move

        void move​(T srcpath,
          SecureDirectoryStream<T> targetdir,
          T targetpath)
   throws IOException
        将文件从该目录移动到另一个目录。

        当指定ATOMIC_MOVE选项时，此方法与move方法类似。 也就是说，该方法将文件作为原子文件系统操作移动。 如果srcpath参数是absolute路径，那么它将定位源文件。 如果参数是相对路径，那么它将相对于此打开的目录定位。 如果targetpath参数为绝对值，则定位目标文件（ targetdir参数被忽略）。 如果参数是相对路径，它相对于由targetdir参数标识的打开目录位于。 在所有情况下，如果目标文件存在，那么如果被替换或该方法失败，那么它是实现特定的。

        参数
        srcpath - 要移动的文件的名称
        targetdir - 目的地目录
        targetpath - 在目的地目录中提供文件的名称
        异常
        ClosedDirectoryStreamException - 如果这个或目标目录流关闭
        FileAlreadyExistsException - 如果文件已存在于目标目录中，无法替换 （可选的特殊异常）
        AtomicMoveNotSupportedException - 如果文件不能作为原子文件系统操作移动
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkWrite方法来检查对源文件和目标文件的写入访问。

      • getFileAttributeView

        <V extends FileAttributeView> V getFileAttributeView​(Class<V> type)
        返回一个新的文件属性视图来访问此目录的文件属性。

        生成的文件属性视图可用于读取或更新此（打开）目录的属性。 type参数指定属性视图的类型，如果支持，该方法返回该类型的实例。 调用此方法以获取BasicFileAttributeView始终返回绑定到此打开目录的该类的实例。

        生成的文件属性视图的状态与此目录流密切相关。 一旦目录流是closed ，那么读取或更新属性的所有方法将抛出ClosedDirectoryStreamException 。

        参数类型
        V - FileAttributeView类型
        参数
        type - 对应于文件属性视图的 Class对象
        结果
        绑定到此目录流的指定类型的新文件属性视图，如果属性视图类型不可用， null

      • getFileAttributeView

        <V extends FileAttributeView> V getFileAttributeView​(T path,
                                                     Class<V> type,
                                                     LinkOption... options)
        返回一个新的文件属性视图来访问此目录中文件的文件属性。

        生成的文件属性视图可用于读取或更新此目录中文件的属性。 type参数指定属性视图的类型，如果支持，该方法返回该类型的实例。 调用此方法来获取一个BasicFileAttributeView总是返回该类的实例绑定到目录中的文件。

        生成的文件属性视图的状态与此目录流密切相关。 一旦目录流closed ，那么所有方法读取或更新属性将抛出ClosedDirectoryStreamException 。 在创建文件属性视图时，该文件不需要存在，但是在调用文件并且文件不存在时，读取或更新文件属性的方法将失败。

        参数类型
        V - FileAttributeView类型
        参数
        path - 文件的路径
        type - 对应于文件属性视图的 Class对象
        options - 表示如何处理符号链接的选项
        结果
        a new file attribute view of the specified type bound to a this directory stream, or null if the attribute view type is not available
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleFileVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class SimpleFileVisitor<T>

  • java.lang.Object
    • java.nio.file.SimpleFileVisitor<T>
  • 参数类型
    T - 文件的引用类型
    All Implemented Interfaces:
    FileVisitor<T>

    public class SimpleFileVisitor<T>
extends Object
implements FileVisitor<T>
    具有默认行为的简单文件访问者访问所有文件并重新抛出I / O错误。

    本课程中的方法可能会因其总体合同而被覆盖。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SimpleFileVisitor​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      FileVisitResult postVisitDirectory​(T dir, IOException exc)
      在目录中的条目之后调用目录，并且已经访问了所有的后代。
      FileVisitResult preVisitDirectory​(T dir, BasicFileAttributes attrs)
      在目录中的条目被访问之前调用一个目录。
      FileVisitResult visitFile​(T file, BasicFileAttributes attrs)
      为目录中的文件调用。
      FileVisitResult visitFileFailed​(T file, IOException exc)
      为无法访问的文件调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SimpleFileVisitor

        protected SimpleFileVisitor​()
        初始化此类的新实例。

    • 方法详细信息

      • preVisitDirectory

        public FileVisitResult preVisitDirectory​(T dir,
                                         BasicFileAttributes attrs)
                                  throws IOException
        在目录中的条目被访问之前调用一个目录。

        除非被覆盖，否则此方法返回CONTINUE 。

        Specified by:
        preVisitDirectory在接口 FileVisitor<T>
        参数
        dir - 对目录的引用
        attrs - 目录的基本属性
        结果
        访问结果
        异常
        IOException - 如果发生I / O错误

      • visitFile

        public FileVisitResult visitFile​(T file,
                                 BasicFileAttributes attrs)
                          throws IOException
        为目录中的文件调用。

        除非被覆盖，否则此方法返回CONTINUE 。

        Specified by:
        visitFile在接口 FileVisitor<T>
        参数
        file - 对该文件的引用
        attrs - 文件的基本属性
        结果
        访问结果
        异常
        IOException - 如果发生I / O错误

      • visitFileFailed

        public FileVisitResult visitFileFailed​(T file,
                                       IOException exc)
                                throws IOException
        为无法访问的文件调用。

        除非被覆盖，否则此方法将重新抛出阻止文件被访问的I / O异常。

        Specified by:
        visitFileFailed在接口 FileVisitor<T>
        参数
        file - 对该文件的引用
        exc - 阻止文件被访问的I / O异常
        结果
        访问结果
        异常
        IOException - 如果发生I / O错误

      • postVisitDirectory

        public FileVisitResult postVisitDirectory​(T dir,
                                          IOException exc)
                                   throws IOException
        在目录中的条目之后调用目录，并且已经访问了所有的后代。

        除非被覆盖，如果目录迭代完成没有I / O异常，此方法返回CONTINUE ; 否则这种方法重新抛出引起该目录的迭代的I / O异常，以过早终止。

        Specified by:
        postVisitDirectory在接口 FileVisitor<T>
        参数
        dir - 对目录的引用
        exc - null如果目录的迭代完成没有错误; 否则会导致目录的迭代过早完成的I / O异常
        结果
        访问结果
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StandardCopyOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.nio.file

Enum StandardCopyOption

  • java.lang.Object
    • java.lang.Enum<StandardCopyOption>
      • java.nio.file.StandardCopyOption
  • All Implemented Interfaces:
    Serializable ， Comparable<StandardCopyOption> ， CopyOption

    public enum StandardCopyOption
extends Enum<StandardCopyOption>
implements CopyOption
    定义标准复制选项。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ATOMIC_MOVE
      将文件作为原子文件系统操作移动。
      COPY_ATTRIBUTES
      将属性复制到新文件。
      REPLACE_EXISTING
      替换现有文件（如果存在）。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static StandardCopyOption valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StandardCopyOption[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • REPLACE_EXISTING

        public static final StandardCopyOption REPLACE_EXISTING
        替换现有文件（如果存在）。

      • COPY_ATTRIBUTES

        public static final StandardCopyOption COPY_ATTRIBUTES
        将属性复制到新文件。

      • ATOMIC_MOVE

        public static final StandardCopyOption ATOMIC_MOVE
        将文件作为原子文件系统操作移动。

    • 方法详细信息

      • values

        public static StandardCopyOption[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (StandardCopyOption c : StandardCopyOption.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static StandardCopyOption valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


StandardOpenOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.nio.file

Enum StandardOpenOption

  • java.lang.Object
    • java.lang.Enum<StandardOpenOption>
      • java.nio.file.StandardOpenOption
  • All Implemented Interfaces:
    Serializable ， Comparable<StandardOpenOption> ， OpenOption

    public enum StandardOpenOption
extends Enum<StandardOpenOption>
implements OpenOption
    定义标准的开放选项。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APPEND
      如果文件打开 WRITE访问，则字节将被写入文件的末尾而不是开头。
      CREATE
      创建一个新文件（如果不存在）。
      CREATE_NEW
      创建一个新的文件，如果该文件已经存在失败。
      DELETE_ON_CLOSE
      关闭时删除。
      DSYNC
      要求将文件内容的每次更新都与底层存储设备同步写入。
      READ
      打开阅读权限。
      SPARSE
      稀疏文件
      SYNC
      要求将文件内容或元数据的每次更新都同步写入底层存储设备。
      TRUNCATE_EXISTING
      如果文件已经存在，并且打开 WRITE访问，则其长度将截断为0。
      WRITE
      打开以进行写入。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static StandardOpenOption valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StandardOpenOption[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • READ

        public static final StandardOpenOption READ
        打开阅读权限。

      • WRITE

        public static final StandardOpenOption WRITE
        打开以进行写入。

      • APPEND

        public static final StandardOpenOption APPEND
        如果文件打开WRITE访问，则字节将被写入文件的末尾，而不是开头。

        如果文件被打开以供其他程序的写访问，那么如果写入文件的末尾是原子的，那么它是文件系统特定的。

      • TRUNCATE_EXISTING

        public static final StandardOpenOption TRUNCATE_EXISTING
        如果文件已经存在，并且打开 WRITE访问，则其长度将被截断为0.如果文件仅对 READ访问打开，则忽略该选项。

      • CREATE

        public static final StandardOpenOption CREATE
        创建一个新文件（如果不存在）。 如果还设置了CREATE_NEW选项，则忽略此选项。 检查文件的存在和文件的创建（如果不存在）相对于其他文件系统操作是原子的。

      • CREATE_NEW

        public static final StandardOpenOption CREATE_NEW
        创建一个新的文件，如果该文件已经存在失败。 检查文件的存在和文件的创建（如果不存在）相对于其他文件系统操作是原子的。

      • DELETE_ON_CLOSE

        public static final StandardOpenOption DELETE_ON_CLOSE
        关闭时删除。 当此选项存在时，实施将尽最大努力尝试在通过适当的close方法关闭时删除该文件。 如果close方法并不然后调用，将尽力而为试图删除文件时，Java虚拟机终止（或者通常，如由Java语言规范，或在可能的情况，异常定义）。 此选项主要用于仅由Java虚拟机的单个实例使用的工作文件 。 当打开其他实体同时打开的文件时，不建议使用此选项。 关于什么时候和如何删除文件的许多细节是实现特定的，因此没有指定。 特别地，当文件打开时，实现可能不能保证在被攻击者替换时删除预期文件。 因此，使用此选项时，安全敏感应用程序应该小心。

        出于安全考虑，此选项可能意味着LinkOption.NOFOLLOW_LINKS选项。 换句话说，如果在打开作为符号链接的现有文件时存在该选项，那么它可能会失败（通过抛出IOException ）。

      • SPARSE

        public static final StandardOpenOption SPARSE
        稀疏文件 当与CREATE_NEW选项一起使用时，此选项提供了一个提示 ，新文件将是稀疏的。 当文件系统不支持创建稀疏文件时，该选项将被忽略。

      • SYNC

        public static final StandardOpenOption SYNC
        要求将文件内容或元数据的每次更新都同步写入底层存储设备。
        另请参见：
        Synchronized I/O file integrity

      • DSYNC

        public static final StandardOpenOption DSYNC
        要求将文件内容的每次更新都与底层存储设备同步写入。
        另请参见：
        Synchronized I/O file integrity

    • 方法详细信息

      • values

        public static StandardOpenOption[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (StandardOpenOption c : StandardOpenOption.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static StandardOpenOption valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


StandardWatchEventKinds (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Class StandardWatchEventKinds

  • java.lang.Object
    • java.nio.file.StandardWatchEventKinds

  • public final class StandardWatchEventKinds
extends Object
    定义 标准事件种类。
    从以下版本开始：
    1.7

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static WatchEvent.Kind<Path> ENTRY_CREATE
      创建目录条目。
      static WatchEvent.Kind<Path> ENTRY_DELETE
      目录条目已删除。
      static WatchEvent.Kind<Path> ENTRY_MODIFY
      目录条目修改。
      static WatchEvent.Kind<Object> OVERFLOW
      一个特殊事件，表明事件可能已丢失或丢弃。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OVERFLOW

        public static final WatchEvent.Kind<Object> OVERFLOW
        一个特殊事件，表明事件可能已丢失或丢弃。

        该事件的context是具体实现，可能是null 。 事件count可能大于1 。

        另请参见：
        WatchService

      • ENTRY_CREATE

        public static final WatchEvent.Kind<Path> ENTRY_CREATE
        创建目录条目。

        当为此事件注册目录时，当观察到在目录中创建条目或重命名为目录时， WatchKey将排队。 此事件的事件count始终为1 。

      • ENTRY_DELETE

        public static final WatchEvent.Kind<Path> ENTRY_DELETE
        目录条目已删除。

        当为此事件注册目录时，当观察到条目被删除或重命名为目录时， WatchKey将排队。 此事件的事件count始终为1 。

      • ENTRY_MODIFY

        public static final WatchEvent.Kind<Path> ENTRY_MODIFY
        目录条目修改。

        当为此事件注册目录时，当观察到目录中的条目已被修改时， WatchKey排队。 事件count为1或更高。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Package java.nio.file (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.nio.file

  • Packages that use java.nio.file
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供商类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
  • Classes in java.nio.file used by java.io
    Class 描述
    Path
    可用于在文件系统中定位文件的对象。
  • Classes in java.nio.file used by java.lang.module
    Class 描述
    Path
    可用于在文件系统中定位文件的对象。
  • Classes in java.nio.file used by java.nio.channels
    Class 描述
    OpenOption
    配置如何打开或创建文件的对象。
    Path
    可用于在文件系统中定位文件的对象。
  • Classes in java.nio.file used by java.nio.file
    Class 描述
    AccessMode
    定义用于测试文件可访问性的访问模式。
    CopyOption
    配置如何复制或移动文件的对象。
    DirectoryStream
    一个对象来迭代目录中的条目。
    DirectoryStream.Filter
    由对象执行的接口，用于确定是否应接受或过滤目录条目。
    FileStore
    文件存储
    FileSystem
    提供文件系统的接口，并且是工厂用于访问文件系统中的文件和其他对象的对象。
    FileSystemException
    在一个或两个文件上的文件系统操作失败时抛出。
    FileVisitOption
    定义文件树遍历选项。
    FileVisitor
    文件访问者
    FileVisitResult
    结果类型为FileVisitor 。
    LinkOption
    定义如何处理符号链接的选项。
    OpenOption
    配置如何打开或创建文件的对象。
    Path
    可用于在文件系统中定位文件的对象。
    PathMatcher
    由对路径执行匹配操作的对象实现的接口。
    SecureDirectoryStream
    A DirectoryStream ，它定义了相对于打开目录定位的文件的操作。
    StandardCopyOption
    定义标准复制选项。
    StandardOpenOption
    定义标准的开放选项。
    Watchable
    可以注册到手表服务的对象，以便可以 观看更改和事件。
    WatchEvent
    对WatchService注册的对象的事件或重复事件。
    WatchEvent.Kind
    一种事件类型，用于识别。
    WatchEvent.Modifier
    事件修饰符，用于量化如何Watchable与注册WatchService 。
    WatchKey
    表示watchable对象与WatchService的注册的令牌。
    WatchService
    手表服务， 手表已注册的对象的变化和事件。
  • Classes in java.nio.file used by java.nio.file.spi
    Class 描述
    AccessMode
    定义用于测试文件可访问性的访问模式。
    CopyOption
    配置如何复制或移动文件的对象。
    DirectoryStream
    一个对象来迭代目录中的条目。
    DirectoryStream.Filter
    由对象执行的接口，用于确定是否应接受或过滤目录条目。
    FileStore
    文件存储
    FileSystem
    提供文件系统的接口，并且是工厂用于访问文件系统中的文件和其他对象的对象。
    LinkOption
    定义如何处理符号链接的选项。
    OpenOption
    配置如何打开或创建文件的对象。
    Path
    可用于在文件系统中定位文件的对象。
  • Classes in java.nio.file used by java.util
    Class 描述
    Path
    可用于在文件系统中定位文件的对象。
  • Classes in java.nio.file used by javax.tools
    Class 描述
    Path
    可用于在文件系统中定位文件的对象。
  • Classes in java.nio.file used by jdk.incubator.http
    Class 描述
    OpenOption
    配置如何打开或创建文件的对象。
    Path
    可用于在文件系统中定位文件的对象。
  • Classes in java.nio.file used by jdk.nashorn.api.tree
    Class 描述
    Path
    可用于在文件系统中定位文件的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Watchable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface Watchable

  • All Known Subinterfaces:
    Path

    public interface Watchable
    可以注册到手表服务的对象，以便可以观看更改和事件。

    该接口定义了register方法来注册该对象，一个WatchService返回一个WatchKey来表示注册。 一个对象可以注册一个以上的监视服务。 通过调用密钥的cancel方法注销手表服务。

    从以下版本开始：
    1.7
    另请参见：
    Path.register(java.nio.file.WatchService, java.nio.file.WatchEvent.Kind<?>[], java.nio.file.WatchEvent.Modifier...)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      WatchKey register​(WatchService watcher, WatchEvent.Kind<?>... events)
      用手表服务注册一个对象。
      WatchKey register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      用手表服务注册一个对象。

    • 方法详细信息

      • register

        WatchKey register​(WatchService watcher,
                  WatchEvent.Kind<?>[] events,
                  WatchEvent.Modifier... modifiers)
           throws IOException
        用手表服务注册一个对象。

        如果由该对象标识的文件系统对象当前已注册到监视服务，那么在将事件集或修饰符更改为由events和modifiers参数指定的那些参数之后，返回表示该注册的监视键。 更改事件集不会导致待抛弃的对象事件。 对象将自动注册为OVERFLOW事件。 此事件不需要存在于事件数组中。

        否则文件系统对象尚未注册到给定的监视服务，因此已注册，并返回生成的新密钥。

        此接口的实现应指定它们支持的事件。

        参数
        watcher - 要注册此对象的监视服务
        events - 应该注册此对象的事件
        modifiers - 修改器（如果有的话）修改对象的注册方式
        结果
        表示使用给定的手表服务注册此对象的键
        异常
        UnsupportedOperationException - 如果指定了不支持的事件或修饰符
        IllegalArgumentException - 如果事件的组合无效是指定的修饰符
        ClosedWatchServiceException - 如果手表服务关闭
        IOException - 如果发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝监视该对象所需的未指定的权限。 此接口的实现应指定权限检查。

      • register

        WatchKey register​(WatchService watcher,
                  WatchEvent.Kind<?>... events)
           throws IOException
        用手表服务注册一个对象。

        调用此方法的行为方式与调用完全相同

          watchable.register(watcher, events, new WatchEvent.Modifier[0]);
        参数
        watcher - 要注册该对象的监视服务
        events - 应该注册此对象的事件
        结果
        表示使用给定的手表服务注册此对象的键
        异常
        UnsupportedOperationException - 如果指定了不支持的事件
        IllegalArgumentException - 如果指定了事件组合无效
        ClosedWatchServiceException - 如果手表服务关闭
        IOException - 如果发生I / O错误
        SecurityException - if a security manager is installed and it denies an unspecified permission required to monitor this object. Implementations of this interface should specify the permission checks.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WatchEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface WatchEvent<T>

  • 参数类型
    T - 与事件关联的上下文对象的类型

    public interface WatchEvent<T>
    一个事件或一个对象的重复事件，注册了一个WatchService 。

    事件按其kind进行分类，并有一个count来表示事件被观察的次数。 这样可以有效地表示重复的事件。 context方法返回与事件相关联的任何上下文。 在重复事件的情况下，所有事件的上下文是相同的。

    监视事件是不可变的，安全的可供多个并发线程使用。

    从以下版本开始：
    1.7

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  WatchEvent.Kind<T>
      一种事件类型，用于识别。
      static interface  WatchEvent.Modifier
      一个事件修饰符，符合Watchable如何注册WatchService 。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      T context​()
      返回事件的上下文。
      int count​()
      返回事件计数。
      WatchEvent.Kind<T> kind​()
      返回事件类型。

    • 方法详细信息

      • kind

        WatchEvent.Kind<T> kind​()
        返回事件类型。
        结果
        事件种类

      • count

        int count​()
        返回事件计数。 如果事件计数大于1那么这是一个重复的事件。
        结果
        事件计数

      • context

        T context​()
        返回事件的上下文。

        在的情况下ENTRY_CREATE ， ENTRY_DELETE ，并ENTRY_MODIFY事件的背景是Path那是relative的手表服务注册的目录，以及创建，删除或修改条目之间的路径。

        结果
        事件上下文; 可能是null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WatchEvent.Kind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface WatchEvent.Kind<T>

  • Enclosing interface:
    WatchEvent < T >

    public static interface WatchEvent.Kind<T>
    一种事件类型，用于识别。
    从以下版本开始：
    1.7
    另请参见：
    StandardWatchEventKinds

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回事件类型的名称。
      Class<T> type​()
      返回 context值的类型。

    • 方法详细信息

      • name

        String name​()
        返回事件类型的名称。
        结果
        事件类型的名称

      • type

        Class<T> type​()
        返回 context值的类型。
        结果
        上下文值的类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WatchEvent.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface WatchEvent.Modifier

  • Enclosing interface:
    WatchEvent < T >

    public static interface WatchEvent.Modifier
    事件修饰符，用于量化如何Watchable与注册WatchService 。

    此版本未定义任何标准修饰符。

    从以下版本开始：
    1.7
    另请参见：
    Watchable.register(java.nio.file.WatchService, java.nio.file.WatchEvent.Kind<?>[], java.nio.file.WatchEvent.Modifier...)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回修饰符的名称。

    • 方法详细信息

      • name

        String name​()
        返回修饰符的名称。
        结果
        the name of the modifier
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WatchKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface WatchKey

  • public interface WatchKey
    表示watchable对象与WatchService的注册的令牌。

    当观察对象注册到手表服务时，创建手表键。 关键还是valid直到：

    1. 通过调用其cancel方法，或者
    2. 因为对象不再可访问，或者
    3. 由closing手表服务。

    手表键有一个状态。 最初创建的密钥据说已经准备就绪 。 当检测到事件时，该信号通知并排队，以便可以通过调用监视服务的poll或take方法来检索该密钥。 一旦发信号通知，一键保留在此状态，直到其reset方法被调用以将该键返回到就绪状态。 当钥匙处于信号状态时检测到的事件被排队，但不会使钥匙重新排队等待从手表服务检索。 通过调用密钥的pollEvents方法检索事件。 此方法检索并删除为该对象累积的所有事件。 初始创建时，观察键不具有未决事件。 通常情况下，当钥匙处于发信号状态时会导致以下成语：

      for (;;) {
         // retrieve key
         WatchKey key = watcher.take();

         // process events
         for (WatchEvent<?> event: key.pollEvents()) {
             :
         }

         // reset the key
         boolean valid = key.reset();
         if (!valid) {
             // object no longer registered
         }
     }

    监视键可以安全地被多个并发线程使用。 在有几个线程从监视服务器检索信号的密钥的情况下，应注意确保reset方法仅在对象的事件已被处理之后被调用。 这确保一个线程随时处理对象的事件。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void cancel​()
      取消对手表服务的注册。
      boolean isValid​()
      告知这个手表键是否有效。
      List<WatchEvent<?>> pollEvents​()
      检索并删除此监视键的所有挂起的事件，返回 List到的事件的 List 。
      boolean reset​()
      重置此手表键。
      Watchable watchable​()
      返回创建该观察键的对象。

    • 方法详细信息

      • isValid

        boolean isValid​()
        告知这个手表键是否有效。

        手表钥匙在创建时有效，并保留，直到取消，或其手表服务关闭。

        结果
        true如果并且只有这个手表键是有效的

      • pollEvents

        List<WatchEvent<?>> pollEvents​()
        检索并删除此监视键的所有挂起的事件，返回一个List的检索事件。

        请注意，如果没有事件挂起，该方法不会等待。

        结果
        检索事件的列表; 可能是空的

      • reset

        boolean reset​()
        重置此手表键。

        如果该手表键已被取消，或者该手表键已经处于就绪状态，则调用该方法将无效。 否则，如果对象有待处理的事件，那么此watch键将立即重新排队到watch服务。 如果没有待处理的事件，那么Watch键将进入就绪状态，并且将保持在该状态，直到检测到事件或者取消了监视键。

        结果
        true如果手表钥匙是有效的，并已复位， false ，如果因为它不再是手表钥匙不能复位 valid

      • cancel

        void cancel​()
        取消对手表服务的注册。 返回时，手表键将无效。 如果watch键入队，等待从watch服务中检索，那么它将保留在队列中，直到它被删除。 待处理的事件（如果有的话）仍然处于待处理状态，并且可以通过在取消密钥后调用pollEvents方法来检索。

        如果此手表键已被取消，则调用此方法无效。 一旦取消，手表钥匙将永远无效。

      • watchable

        Watchable watchable​()
        返回创建该观察键的对象。 即使在取消键之后，此方法也将继续返回对象。

        由于WatchService旨在直接映射到本地文件事件通知工具（如果可用的话），那么关于注册对象被监视的许多细节是高度实现特定的。 当观察目录进行更改时，例如，目录在文件系统中移动或重命名，则不能保证手表键将被取消，因此此方法返回的对象可能不再是目录的有效路径。

        结果
        该手表键被创建的对象
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WatchService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file

Interface WatchService

  • All Superinterfaces:
    AutoCloseable ， Closeable

    public interface WatchService
extends Closeable
    手表服务， 手表已注册的对象的变化和事件。 例如，文件管理器可以使用监视服务来监视目录以进行更改，以便可以在创建或删除文件时更新其文件列表的显示。

    A Watchable对象通过调用其register方法向手表服务注册，返回一个WatchKey来表示注册。 当检测到对象的事件时，用信号通知密钥，如果当前未发出信号，则将其排队到监视服务器，以便可以由调用poll或take方法检索密钥和处理事件的消费者检索。 一旦事件被处理，消费者将调用密钥的reset方法来重置密钥，该密钥允许密钥被发信号并且进一步重新排队。

    通过调用密钥的cancel方法注销手表服务。 在被取消的时间排队的密钥保留在队列中，直到它被检索为止。 根据对象，可能会自动取消键。 例如，假设目录被监视，并且监视服务检测到它已被删除或其文件系统不再可访问。 当以这种方式取消密钥时，它将被发信号通知并排队，如果当前没有发出信号。 为了确保消费者被通知， reset方法的返回值表示该密钥是否有效。

    手表服务可以安全使用多个并发消费者。 为了确保只有一个消费者随时处理特定对象的事件，则应注意确保密钥的reset方法仅在其事件处理完毕后才被调用。 可以随时调用close方法关闭导致任何线程等待检索密钥的服务，以抛出ClosedWatchServiceException 。

    文件系统可以比可以检索或处理的事件更快地报告事件，并且实现可能会对其可能累积的事件数量施加未指定的限制。 如果一个实现知道丢弃事件，那么它会安排密钥的pollEvents方法返回事件类型为OVERFLOW的元素。 消费者可以使用此事件作为重新检查对象状态的触发器。

    当一个事件被报告以指示被监视的目录中的文件已被修改时，则不能保证修改该文件的程序（或程序）已经完成。 应注意与可能正在更新文件的其他程序协调访问。 FileChannel类定义了将文件的区域锁定到其他程序访问的方法。

    平台依赖

    从文件系统观察事件的实现旨在直接映射到可用的本机文件事件通知工具，或者在本机设备不可用时使用原始机制（如轮询）。 因此，关于如何检测事件，及时性以及是否保存其顺序的许多细节都是具体实现的。 例如，当观察目录中的文件被修改时，它可能导致一些实现中的单个ENTRY_MODIFY事件，而在其他实现中可能导致一些事件。 短期文件（意味着在创建后被非常快速地删除的文件）可能不会被定期轮询文件系统以检测更改的原始实现来检测。

    如果观看的文件不在本地存储设备上，那么如果可以检测到文件的更改，那么它是实现特定的。 特别地，不需要检测在远程系统上执行的文件的更改。

    从以下版本开始：
    1.7
    另请参见：
    FileSystem.newWatchService()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭这个手表服务。
      WatchKey poll​()
      检索并删除下一个监视键，如果没有，则 null 。
      WatchKey poll​(long timeout, TimeUnit unit)
      检索并删除下一个watch键，如果还没有，则等待必要时直到指定的等待时间。
      WatchKey take​()
      检索并删除下一个Watch键，等待是否还没有。

    • 方法详细信息

      • close

        void close​()
    throws IOException
        关闭这个手表服务。

        如果一个线程当前被阻塞在take或poll方法等待一个密钥排队，那么它会立即收到一个ClosedWatchServiceException 。 与此手表服务相关联的任何有效密钥为invalidated 。

        在关闭手表服务之后，任何进一步调用操作的尝试将会抛出ClosedWatchServiceException 。 如果这个watch服务已经关闭了，那么调用这个方法就没有效果。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误

      • poll

        WatchKey poll​()
        检索并删除下一个监视键，如果不存在，则 null 。
        结果
        下一个手表键，或 null
        异常
        ClosedWatchServiceException - 如果这个手表服务是关闭的

      • poll

        WatchKey poll​(long timeout,
              TimeUnit unit)
       throws InterruptedException
        检索并删除下一个watch键，如果还没有，则等待必要时直到指定的等待时间。
        参数
        timeout - 如何等待，放弃之前，以单位为单位
        unit - a TimeUnit确定如何解释超时参数
        结果
        下一个手表键，或 null
        异常
        ClosedWatchServiceException - 如果此手表服务关闭，或者在等待下一个键时关闭
        InterruptedException - 如果在等待时中断

      • take

        WatchKey take​()
       throws InterruptedException
        检索并删除下一个Watch键，等待是否还没有。
        结果
        下一个手表键
        异常
        ClosedWatchServiceException - 如果此手表服务关闭，或者在等待下一个键时关闭
        InterruptedException - if interrupted while waiting
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AclEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Class AclEntry

  • java.lang.Object
    • java.nio.file.attribute.AclEntry

  • public final class AclEntry
extends Object
    访问控制列表（ACL）中的条目。

    此类表示的ACL条目基于RFC 3530: Network File System (NFS) version 4 Protocol中指定的ACL模型。 每个条目有四个组件如下：

    1. type组件确定条目是否准予或拒绝访问。

    2. principal组件，有时称为“谁”组件，是一个UserPrincipal对应于该条目授予或拒绝访问的身份

    3. permissions组件是一组permissions

    4. flags组件是一组flags，用于指示条目如何继承和传播

    使用关联的AclEntry.Builder对象通过调用其build方法创建ACL条目。

    ACL条目是不可变的，并且可以安全地被多个并发线程使用。

    从以下版本开始：
    1.7

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  AclEntry.Builder
      一个AclEntry对象的生成器。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object ob)
      将指定的对象与此ACL条目进行比较以获得相等性。
      Set<AclEntryFlag> flags​()
      返回flags组件的副本。
      int hashCode​()
      返回此ACL条目的哈希码值。
      static AclEntry.Builder newBuilder​()
      构建一个新的构建器。
      static AclEntry.Builder newBuilder​(AclEntry entry)
      使用现有ACL条目的组件构造一个新构建器。
      Set<AclEntryPermission> permissions​()
      返回权限组件的副本。
      UserPrincipal principal​()
      返回主成分。
      String toString​()
      返回此ACL条目的字符串表示形式。
      AclEntryType type​()
      返回ACL条目类型。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • newBuilder

        public static AclEntry.Builder newBuilder​()
        构建一个新的构建器。 类型的初始值和组件是null 。 权限和标志组件的初始值为空集。
        结果
        一个新的建设者

      • newBuilder

        public static AclEntry.Builder newBuilder​(AclEntry entry)
        使用现有ACL条目的组件构造一个新构建器。
        参数
        entry - 一个ACL条目
        结果
        一个新的建设者

      • type

        public AclEntryType type​()
        返回ACL条目类型。
        结果
        ACL条目类型

      • principal

        public UserPrincipal principal​()
        返回主成分。
        结果
        主要组成部分

      • permissions

        public Set<AclEntryPermission> permissions​()
        返回权限组件的副本。

        返回的集合是一个可修改的权限副本。

        结果
        权限组件

      • flags

        public Set<AclEntryFlag> flags​()
        返回flags组件的副本。

        返回的集合是标记的可修改副本。

        结果
        标志组件

      • equals

        public boolean equals​(Object ob)
        将指定的对象与此ACL条目进行比较以获得相等性。

        如果给定的对象不是一个AclEntry那么这个方法立即返回false 。

        对于要考虑的两个ACL条目为等式，需要它们是相同的类型，它们的组件是相等的，它们的权限组件是相等的，并且它们的标志组件是相等的。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果，并且仅当给定对象是AclEntry与此AclEntry相同时
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此ACL条目的哈希码值。

        该方法满足Object.hashCode()方法的一般合同。

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此ACL条目的字符串表示形式。
        重写：
        toString在 Object
        结果
        the string representation of this entry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AclEntry.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Class AclEntry.Builder

  • java.lang.Object
    • java.nio.file.attribute.AclEntry.Builder
  • Enclosing class:
    AclEntry

    public static final class AclEntry.Builder
extends Object
    一个AclEntry对象的生成器。

    通过调用由AclEntry类定义的newBuilder方法之一获得一个Builder对象。

    Builder对象是可变的，并且不安全地被多个并发线程使用而没有适当的同步。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AclEntry build​()
      从此构建器的组件构造一个AclEntry 。
      AclEntry.Builder setFlags​(AclEntryFlag... flags)
      设置此构建器的标志组件。
      AclEntry.Builder setFlags​(Set<AclEntryFlag> flags)
      设置此构建器的标志组件。
      AclEntry.Builder setPermissions​(AclEntryPermission... perms)
      设置此构建器的权限组件。
      AclEntry.Builder setPermissions​(Set<AclEntryPermission> perms)
      设置此构建器的权限组件。
      AclEntry.Builder setPrincipal​(UserPrincipal who)
      设置此构建器的主要组件。
      AclEntry.Builder setType​(AclEntryType type)
      设置此构建器的类型组件。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • build

        public AclEntry build​()
        从此构建器的组件构造一个AclEntry 。 需要设置类型和组件才能构建一个AclEntry 。
        结果
        一个新的ACL条目
        异常
        IllegalStateException - 如果类型或组件尚未设置

      • setType

        public AclEntry.Builder setType​(AclEntryType type)
        设置此构建器的类型组件。
        参数
        type - 组件类型
        结果
        这个建设者

      • setPrincipal

        public AclEntry.Builder setPrincipal​(UserPrincipal who)
        设置此构建器的主要组件。
        参数
        who - 主要组成部分
        结果
        这个建设者

      • setPermissions

        public AclEntry.Builder setPermissions​(Set<AclEntryPermission> perms)
        设置此构建器的权限组件。 返回时，此构建器的权限组件是给定集的副本。
        参数
        perms - 权限组件
        结果
        这个建设者
        异常
        ClassCastException - 如果集合包含不是类型 AclEntryPermission

      • setPermissions

        public AclEntry.Builder setPermissions​(AclEntryPermission... perms)
        设置此构建器的权限组件。 返回时，此构建器的权限组件是给定数组中权限的副本。
        参数
        perms - 权限组件
        结果
        这个建设者

      • setFlags

        public AclEntry.Builder setFlags​(Set<AclEntryFlag> flags)
        设置此构建器的标志组件。 返回时，此构建器的flags组件是给定集的副本。
        参数
        flags - 标志组件
        结果
        这个建设者
        异常
        ClassCastException - 如果集合包含不是类型 AclEntryFlag

      • setFlags

        public AclEntry.Builder setFlags​(AclEntryFlag... flags)
        设置此构建器的标志组件。 返回时，此构建器的flags组件是给定数组中的标志的副本。
        参数
        flags - 标志组件
        结果
        这个建设者
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AclEntryFlag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Enum AclEntryFlag

  • java.lang.Object
    • java.lang.Enum<AclEntryFlag>
      • java.nio.file.attribute.AclEntryFlag
  • All Implemented Interfaces:
    Serializable ， Comparable<AclEntryFlag>

    public enum AclEntryFlag
extends Enum<AclEntryFlag>
    定义ACL entry的标志组件使用的标志。

    在此版本中，此类不定义与AclEntryType.AUDIT和AclEntryType.ALARM条目类型相关的标志。

    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DIRECTORY_INHERIT
      可以放在一个目录上，并指示ACL条目应该添加到创建的每个新目录中。
      FILE_INHERIT
      可以放在一个目录上，并指示ACL条目应该添加到每个新创建的非目录文件中。
      INHERIT_ONLY
      可以放在目录上，但不适用于目录，只适用于由 FILE_INHERIT和 DIRECTORY_INHERIT标志指定的新创建的文件/目录。
      NO_PROPAGATE_INHERIT
      可以放置在目录上，以指示ACL条目不应放置在创建的目录的子目录可继承的新创建的目录上。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static AclEntryFlag valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AclEntryFlag[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • FILE_INHERIT

        public static final AclEntryFlag FILE_INHERIT
        可以放在一个目录上，并指示ACL条目应该添加到每个新创建的非目录文件中。

      • DIRECTORY_INHERIT

        public static final AclEntryFlag DIRECTORY_INHERIT
        可以放在一个目录上，并指示ACL条目应该添加到创建的每个新目录中。

      • NO_PROPAGATE_INHERIT

        public static final AclEntryFlag NO_PROPAGATE_INHERIT
        可以放置在目录上，以指示ACL条目不应放置在创建的目录的子目录可继承的新创建的目录上。

      • INHERIT_ONLY

        public static final AclEntryFlag INHERIT_ONLY
        可以放在目录上，但不适用于目录，只适用于 FILE_INHERIT和 DIRECTORY_INHERIT标志指定的新创建的文件/目录。

    • 方法详细信息

      • values

        public static AclEntryFlag[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (AclEntryFlag c : AclEntryFlag.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static AclEntryFlag valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


AclEntryPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • Field |
  • 方法
  • 详细信息：
  • Enum Constants |
  • Field |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Enum AclEntryPermission

  • java.lang.Object
    • java.lang.Enum<AclEntryPermission>
      • java.nio.file.attribute.AclEntryPermission
  • All Implemented Interfaces:
    Serializable ， Comparable<AclEntryPermission>

    public enum AclEntryPermission
extends Enum<AclEntryPermission>
    定义与ACL entry的权限组件一起使用的权限。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APPEND_DATA
      将数据附加到文件的权限。
      DELETE
      允许删除文件。
      DELETE_CHILD
      删除目录中的文件或目录的权限。
      EXECUTE
      执行文件的权限
      READ_ACL
      读取ACL属性的权限。
      READ_ATTRIBUTES
      读取（非acl）文件属性的能力。
      READ_DATA
      读取文件数据的权限。
      READ_NAMED_ATTRS
      读取文件的命名属性的权限。
      SYNCHRONIZE
      通过同步读写在本地访问服务器的权限。
      WRITE_ACL
      编写ACL属性的权限。
      WRITE_ATTRIBUTES
      写入（非acl）文件属性的能力。
      WRITE_DATA
      许可修改文件的数据。
      WRITE_NAMED_ATTRS
      写入文件的命名属性的权限。
      WRITE_OWNER
      允许更改所有者。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static AclEntryPermission ADD_FILE
      将新文件添加到目录的权限（等于 WRITE_DATA ）
      static AclEntryPermission ADD_SUBDIRECTORY
      创建目录的子目录的权限（等于 APPEND_DATA ）
      static AclEntryPermission LIST_DIRECTORY
      列出目录条目的权限（等于 READ_DATA ）

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static AclEntryPermission valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AclEntryPermission[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • READ_DATA

        public static final AclEntryPermission READ_DATA
        读取文件数据的权限。

      • WRITE_DATA

        public static final AclEntryPermission WRITE_DATA
        许可修改文件的数据。

      • APPEND_DATA

        public static final AclEntryPermission APPEND_DATA
        将数据附加到文件的权限。

      • READ_NAMED_ATTRS

        public static final AclEntryPermission READ_NAMED_ATTRS
        读取文件的命名属性的权限。

        RFC 3530: Network File System (NFS) version 4 Protocol将命名属性定义为与文件系统中的文件相关联的不透明文件。

      • WRITE_NAMED_ATTRS

        public static final AclEntryPermission WRITE_NAMED_ATTRS
        写入文件的命名属性的权限。

        RFC 3530: Network File System (NFS) version 4 Protocol将命名属性定义为与文件系统中的文件相关联的不透明文件。

      • EXECUTE

        public static final AclEntryPermission EXECUTE
        执行文件的权限

      • DELETE_CHILD

        public static final AclEntryPermission DELETE_CHILD
        删除目录中的文件或目录的权限。

      • READ_ATTRIBUTES

        public static final AclEntryPermission READ_ATTRIBUTES
        读取（非acl）文件属性的能力。

      • WRITE_ATTRIBUTES

        public static final AclEntryPermission WRITE_ATTRIBUTES
        写入（非acl）文件属性的能力。

      • DELETE

        public static final AclEntryPermission DELETE
        允许删除文件。

      • READ_ACL

        public static final AclEntryPermission READ_ACL
        读取ACL属性的权限。

      • WRITE_ACL

        public static final AclEntryPermission WRITE_ACL
        编写ACL属性的权限。

      • WRITE_OWNER

        public static final AclEntryPermission WRITE_OWNER
        允许更改所有者。

      • SYNCHRONIZE

        public static final AclEntryPermission SYNCHRONIZE
        通过同步读写在本地访问服务器的权限。

    • 字段详细信息

      • LIST_DIRECTORY

        public static final AclEntryPermission LIST_DIRECTORY
        列出目录条目的权限（等于 READ_DATA ）

      • ADD_FILE

        public static final AclEntryPermission ADD_FILE
        向目录添加新文件的权限（等于 WRITE_DATA ）

      • ADD_SUBDIRECTORY

        public static final AclEntryPermission ADD_SUBDIRECTORY
        创建目录的子目录的权限（等于 APPEND_DATA ）

    • 方法详细信息

      • values

        public static AclEntryPermission[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (AclEntryPermission c : AclEntryPermission.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static AclEntryPermission valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • Field |
  • 方法
  • 详细信息：
  • Enum Constants |
  • Field |
  • 方法


AclEntryType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Enum AclEntryType

  • java.lang.Object
    • java.lang.Enum<AclEntryType>
      • java.nio.file.attribute.AclEntryType
  • All Implemented Interfaces:
    Serializable ， Comparable<AclEntryType>

    public enum AclEntryType
extends Enum<AclEntryType>
    访问控制条目类型的类型安全枚举。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALARM
      以系统依赖的方式生成在ACL条目的权限组件中指定的访问的警报。
      ALLOW
      明确授予对文件或目录的访问权限。
      AUDIT
      以系统依赖的方式记录ACL条目的权限组件中指定的访问。
      DENY
      显式地拒绝对文件或目录的访问。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static AclEntryType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AclEntryType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ALLOW

        public static final AclEntryType ALLOW
        明确授予对文件或目录的访问权限。

      • DENY

        public static final AclEntryType DENY
        显式地拒绝对文件或目录的访问。

      • AUDIT

        public static final AclEntryType AUDIT
        以系统依赖的方式记录ACL条目的权限组件中指定的访问。

      • ALARM

        public static final AclEntryType ALARM
        以系统依赖的方式生成在ACL条目的权限组件中指定的访问的警报。

    • 方法详细信息

      • values

        public static AclEntryType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (AclEntryType c : AclEntryType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static AclEntryType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


AclFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface AclFileAttributeView

  • All Superinterfaces:
    AttributeView ， FileAttributeView ， FileOwnerAttributeView

    public interface AclFileAttributeView
extends FileOwnerAttributeView
    支持读取或更新文件的访问控制列表（ACL）或文件所有者属性的文件属性视图。

    ACL用于指定文件系统对象的访问权限。 ACL是access-control-entries的有序列表，每个都指定一个UserPrincipal以及该用户主体的访问级别。 该文件属性视图定义getAcl ，和setAcl方法读取和写入基于在指定的ACL模型的ACL RFC 3530: Network File System (NFS) version 4 Protocol 。 此文件属性视图适用于支持NFSv4 ACL模型或在NFSv4 ACL模型与文件系统使用的ACL模型之间的定义良好的映射的文件系统实现。 这种映射的细节依赖于实现，因此是未指定的。

    这个类还扩展了FileOwnerAttributeView ，以便定义获取和设置文件所有者的方法。

    当一个文件系统提供访问不一致的一组file-systems时 ，只有一些文件系统可能支持ACL。 supportsFileAttributeView方法可用于测试文件系统是否支持ACL。

    互通性

    RFC 3530允许在支持POSIX定义的访问权限的平台上使用特殊用户身份。 特殊用户身份是“ OWNER@ ”，“ GROUP@ ”和“ EVERYONE@ ”。 当支持AclFileAttributeView和PosixFileAttributeView时 ，这些特殊用户身份可能被包含在被读取或写入的ACL entries中。 文件系统的UserPrincipalLookupService可以通过调用lookupPrincipalByName方法来获得UserPrincipal来表示这些特殊身份。

    使用示例：假设我们希望将一个条目添加到现有的ACL以授予“joe”访问权限：

      // lookup "joe"
     UserPrincipal joe = file.getFileSystem().getUserPrincipalLookupService()
         .lookupPrincipalByName("joe");

     // get view
     AclFileAttributeView view = Files.getFileAttributeView(file, AclFileAttributeView.class);

     // create ACE to give "joe" read access
     AclEntry entry = AclEntry.newBuilder()
         .setType(AclEntryType.ALLOW)
         .setPrincipal(joe)
         .setPermissions(AclEntryPermission.READ_DATA, AclEntryPermission.READ_ATTRIBUTES)
         .build();

     // read ACL, insert ACE, re-write ACL
     List<AclEntry> acl = view.getAcl();
     acl.add(0, entry);   // insert before any DENY entries
     view.setAcl(acl);

    动态访问

    需要动态访问文件属性的属性视图支持的属性如下：

    Supported attributes
    Name | Type
    "acl" | List<AclEntry>
    "owner" | UserPrincipal

    getAttribute方法可以用于读取ACL或所有者属性，就像通过调用getAcl或getOwner方法一样。

    setAttribute方法可以用于更新ACL或所有者属性，就像通过调用setAcl或setOwner方法一样。

    创建文件时设置ACL

    支持此属性视图的实现还可以支持在创建文件或目录时设置初始ACL。 可以将初始ACL提供给诸如createFile或createDirectory的方法作为FileAttribute，其中name "acl:acl"和value是AclEntry对象的列表。

    在实现支持与NFSv4定义的ACL模型不同的ACL模型的情况下，创建文件时设置初始ACL必须将ACL转换为文件系统支持的模型。 创建文件的方法应该拒绝（通过抛出IOException ）任何尝试创建由于翻译而不太安全的文件。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<AclEntry> getAcl​()
      读取访问控制列表。
      String name​()
      返回属性视图的名称。
      void setAcl​(List<AclEntry> acl)
      更新（替换）访问控制列表。

      • Methods inherited from interface java.nio.file.attribute.FileOwnerAttributeView

        getOwner, setOwner

    • 方法详细信息

      • name

        String name​()
        返回属性视图的名称。 此类型的属性视图名称为"acl" 。
        Specified by:
        name在接口 AttributeView
        Specified by:
        name在接口 FileOwnerAttributeView
        结果
        属性视图的名称

      • getAcl

        List<AclEntry> getAcl​()
               throws IOException
        读取访问控制列表。

        当文件系统使用与NFSv4定义的ACL模型不同的ACL模型时，该方法返回ACL，该ACL是将NFS转换为NFSv4 ACL模型。

        返回的列表是可修改的，以便于更改现有的ACL。 setAcl方法用于更新文件的ACL属性。

        结果
        表示ACL的entries的有序列表
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，它将拒绝RuntimePermission ("accessUserInformation")或其checkRead方法拒绝对该文件的读取访问。

      • setAcl

        void setAcl​(List<AclEntry> acl)
     throws IOException
        更新（替换）访问控制列表。

        文件系统支持访问控制列表的位置，并且使用与NFSv4定义的ACL模型不同的ACL模型，则该方法必须将ACL转换为文件系统支持的模型。 这种方法应该拒绝（通过抛出IOException ）任何尝试编写一个ACL，这样做会使文件比ACL更新时更安全。 在实现不支持AclEntryType.AUDIT或AclEntryType.ALARM条目的映射的情况下 ，此方法在写入ACL时将忽略这些条目。

        如果ACL条目包含一个user-principal不与相同的提供这个属性视图，则相关ProviderMismatchException被抛出。 额外的验证（如果有的话）依赖于实现。

        如果文件系统支持其他与安全相关的文件属性（例如，例如文件access-permissions ），更新访问控制列表也可能导致这些与安全性有关的属性被更新。

        参数
        acl - 新的访问控制列表
        异常
        IOException - 如果发生I / O错误或ACL无效
        SecurityException - 在默认提供程序的情况下，安装了安全管理器，它将拒绝RuntimePermission ("accessUserInformation")或其checkWrite方法拒绝对文件的写入访问。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface AttributeView

  • All Known Subinterfaces:
    AclFileAttributeView ， BasicFileAttributeView ， DosFileAttributeView ， FileAttributeView ， FileOwnerAttributeView ， FileStoreAttributeView ， PosixFileAttributeView ， UserDefinedFileAttributeView

    public interface AttributeView
    提供与文件系统中的对象相关联的非不透明值的只读或可更新视图的对象。 此接口通过定义视图支持的属性的特定属性视图进行扩展或实现。 特定的属性视图通常会定义类型安全的方法来读取或更新其支持的属性。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回属性视图的名称。

    • 方法详细信息

      • name

        String name​()
        返回属性视图的名称。
        结果
        属性视图的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicFileAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface BasicFileAttributes

  • All Known Subinterfaces:
    DosFileAttributes ， PosixFileAttributes

    public interface BasicFileAttributes
    与文件系统中的文件相关联的基本属性。

    基本文件属性是许多文件系统通用的属性，由该接口定义的强制和可选文件属性组成。

    用法示例：

      Path file = ...
    BasicFileAttributes attrs = Files.readAttributes(file, BasicFileAttributes.class);
    从以下版本开始：
    1.7
    另请参见：
    BasicFileAttributeView

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      FileTime creationTime​()
      返回创建时间。
      Object fileKey​()
      返回唯一标识给定文件的对象，如果文件密钥不可用，则返回 null 。
      boolean isDirectory​()
      告诉文件是否是目录。
      boolean isOther​()
      告诉该文件是否是常规文件，目录或符号链接以外的其他内容。
      boolean isRegularFile​()
      告知文件是否是具有不透明内容的常规文件。
      boolean isSymbolicLink​()
      告诉文件是否是符号链接。
      FileTime lastAccessTime​()
      返回上一次访问的时间。
      FileTime lastModifiedTime​()
      返回上次修改的时间。
      long size​()
      返回文件的大小（以字节为单位）。

    • 方法详细信息

      • lastModifiedTime

        FileTime lastModifiedTime​()
        返回上次修改的时间。

        如果文件系统实现不支持时间戳来指示上次修改的时间，则该方法返回一个实现特定的默认值，通常是表示时代（1970-01-01T00：00：00Z）的FileTime 。

        结果
        一个 FileTime表示文件上次修改的时间

      • lastAccessTime

        FileTime lastAccessTime​()
        返回上一次访问的时间。

        如果文件系统实现不支持时间戳来指示上一次访问的时间，则该方法返回一个实现特定的默认值，通常为last-modified-time或表示时代（1970-01-01T00：00：00Z）的FileTime 。

        结果
        一个 FileTime代表上次访问的时间

      • creationTime

        FileTime creationTime​()
        返回创建时间。 创建时间是创建文件的时间。

        如果文件系统实现不支持时间戳来指示创建文件的时间，则该方法返回一个实现特定的默认值，通常为last-modified-time或代表时代（1970-01-01T00：00：00Z）的FileTime ） 。

        结果
        一个表示文件创建时间的 FileTime

      • isRegularFile

        boolean isRegularFile​()
        告知文件是否是具有不透明内容的常规文件。
        结果
        true如果文件是具有不透明内容的常规文件

      • isDirectory

        boolean isDirectory​()
        告诉文件是否是目录。
        结果
        true如果文件是一个目录

      • isSymbolicLink

        boolean isSymbolicLink​()
        告诉文件是否是符号链接。
        结果
        true如果文件是一个符号链接

      • isOther

        boolean isOther​()
        告诉该文件是否是常规文件，目录或符号链接以外的其他内容。
        结果
        true如果文件不是一般的文件，目录或符号链接

      • size

        long size​()
        返回文件的大小（以字节为单位）。 由于压缩，支持稀疏文件或其他原因，大小可能与文件系统上的实际大小不同。 不是regular文件的文件的大小是实现特定的，因此是未指定的。
        结果
        文件大小，以字节为单位

      • fileKey

        Object fileKey​()
        返回唯一标识给定文件的对象，如果文件密钥不可用，则返回null 。 在某些平台或文件系统上，可以使用标识符或标识符的组合来唯一标识文件。 这样的标识符对于支持symbolic links的文件系统中的文件树遍历或允许文件作为多个目录中的条目的文件系统的操作是重要的。 例如，在UNIX文件系统上， 设备ID和inode通常用于此目的。

        如果文件系统和文件保持静态，则此方法返回的文件密钥只能保证是唯一的。 在文件被删除后文件系统是否重新使用标识符是依赖于实现的，因此是未指定的。

        可以比较通过此方法返回的文件密钥是否相同，适用于集合。 如果文件系统和文件保持不变，而两个文件是same与非null文件密钥，那么他们的文件密钥是相同的。

        结果
        唯一标识给定文件的对象，或 null
        另请参见：
        Files.walkFileTree(java.nio.file.Path, java.util.Set<java.nio.file.FileVisitOption>, int, java.nio.file.FileVisitor<? super java.nio.file.Path>)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface BasicFileAttributeView

  • All Superinterfaces:
    AttributeView ， FileAttributeView
    All Known Subinterfaces:
    DosFileAttributeView ， PosixFileAttributeView

    public interface BasicFileAttributeView
extends FileAttributeView
    文件属性视图，提供许多文件系统通用的基本文件属性集的视图。 文件属性的基本集由2705655559529接口定义的强制和可选文件属性组成。

    通过调用readAttributes方法，通过批量操作从文件系统检索文件属性。 此类还定义了更新文件的时间属性的setTimes方法。

    在需要动态访问文件属性的地方，此属性视图支持的属性具有以下名称和类型：

    Supported attributes
    Name | Type
    "lastModifiedTime" | FileTime
    "lastAccessTime" | FileTime
    "creationTime" | FileTime
    "size" | Long
    "isRegularFile" | Boolean
    "isDirectory" | Boolean
    "isSymbolicLink" | Boolean
    "isOther" | Boolean
    "fileKey" | Object

    getAttribute方法可以用于通过调用readAttributes()方法来读取任何这些属性。

    setAttribute方法可以用于更新文件的最后修改时间，上次访问时间或创建时间属性，就好像通过调用setTimes方法一样。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回属性视图的名称。
      BasicFileAttributes readAttributes​()
      读取大量操作的基本文件属性。
      void setTimes​(FileTime lastModifiedTime, FileTime lastAccessTime, FileTime createTime)
      更新文件的最后修改时间，上次访问时间和创建时间属性的任何或全部。

    • 方法详细信息

      • name

        String name​()
        返回属性视图的名称。 此类型的属性视图名称为"basic" 。
        Specified by:
        name在接口 AttributeView
        结果
        属性视图的名称

      • readAttributes

        BasicFileAttributes readAttributes​()
                            throws IOException
        读取大量操作的基本文件属性。

        如果所有文件属性都被读取为相对于其他文件系统操作的原子操作，则是实现特定的。

        结果
        文件属性
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，它的 checkRead方法被调用来检查对该文件的读访问

      • setTimes

        void setTimes​(FileTime lastModifiedTime,
              FileTime lastAccessTime,
              FileTime createTime)
       throws IOException
        更新文件的最后修改时间，上次访问时间和创建时间属性的任何或全部。

        此方法更新文件的时间戳属性。 这些值被转换为文件系统支持的时代和精度。 从精细到粗粒度的转换会导致精度损失。 尝试设置不支持的时间戳或超出底层文件存储区支持范围的值时，此方法的行为未定义。 投掷IOException可能会失败。

        如果任何的lastModifiedTime ， lastAccessTime ，或createTime参数具有值null那么相应的时间戳没有改变。 当仅更新时间戳属性的一些但不是全部时，实现可能需要读取文件属性的现有值。 因此，该方法可能不是关于其他文件系统操作的原子操作。 读取和重写现有值也可能导致精度损失。 如果所有的lastModifiedTime ， lastAccessTime和createTime参数为null ，则此方法没有任何效果。

        使用示例：假设我们要更改文件的最后访问时间。

          Path path = ...
    FileTime time = ...
    Files.getFileAttributeView(path, BasicFileAttributeView.class).setTimes(null, time, null);
        参数
        lastModifiedTime - 新上次修改的时间，或 null不更改值
        lastAccessTime - 最后访问时间，或 null不更改值
        createTime - 文件的创建时间，或 null不更改值
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了安全管理器，调用其 checkWrite方法来检查对该文件的写入访问
        另请参见：
        Files.setLastModifiedTime(java.nio.file.Path, java.nio.file.attribute.FileTime)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DosFileAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface DosFileAttributes

  • All Superinterfaces:
    BasicFileAttributes

    public interface DosFileAttributes
extends BasicFileAttributes
    与支持旧版“DOS”属性的文件系统中的文件相关联的文件属性。

    用法示例：

      Path file = ...
    DosFileAttributes attrs = Files.readAttributes(file, DosFileAttributes.class);
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean isArchive​()
      返回归档属性的值。
      boolean isHidden​()
      返回隐藏属性的值。
      boolean isReadOnly​()
      返回只读属性的值。
      boolean isSystem​()
      返回系统属性的值。

      • Methods inherited from interface java.nio.file.attribute.BasicFileAttributes

        creationTime, fileKey, isDirectory, isOther, isRegularFile, isSymbolicLink, lastAccessTime, lastModifiedTime, size

    • 方法详细信息

      • isReadOnly

        boolean isReadOnly​()
        返回只读属性的值。

        此属性通常用作简单的访问控制机制，以防止文件被删除或更新。 文件系统或平台是否执行任何强制以防止只读文件被更新是具体的实现。

        结果
        只读属性的值

      • isHidden

        boolean isHidden​()
        返回隐藏属性的值。

        此属性通常用于指示该文件是否对用户可见。

        结果
        隐藏属性的值

      • isArchive

        boolean isArchive​()
        返回归档属性的值。

        此属性通常由备份程序使用。

        结果
        存档属性的值

      • isSystem

        boolean isSystem​()
        返回系统属性的值。

        此属性通常用于指示该文件是操作系统的组件。

        结果
        系统属性的值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DosFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface DosFileAttributeView

  • All Superinterfaces:
    AttributeView ， BasicFileAttributeView ， FileAttributeView

    public interface DosFileAttributeView
extends BasicFileAttributeView
    提供传统“DOS”文件属性视图的文件属性视图。 文件系统支持这些属性，例如消费者设备中常用的文件分配表（FAT）格式。

    A DosFileAttributeView是一个BasicFileAttributeView ，另外还支持访问用于指示文件是只读，隐藏，系统文件还是存档的DOS属性标志的集合。

    在需要动态访问文件属性的情况下，此属性视图支持的属性由BasicFileAttributeView定义，此外还支持以下属性：

    Supported attributes
    Name | Type
    readonly | Boolean
    hidden | Boolean
    system | Boolean
    archive | Boolean

    getAttribute方法可以用于读取这些属性中的任何一个，或BasicFileAttributeView定义的任何属性，就好像通过调用readAttributes()方法一样。

    该setAttribute方法可以用于更新该文件的上次修改时间，最后访问时间或者创建时间所定义的属性BasicFileAttributeView 。 它也可用于更新，如果通过调用作为DOS属性setReadOnly ， setHidden ， setSystem ，和setArchive方法分别。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回属性视图的名称。
      DosFileAttributes readAttributes​()
      读取大量操作的基本文件属性。
      void setArchive​(boolean value)
      更新归档属性的值。
      void setHidden​(boolean value)
      更新隐藏属性的值。
      void setReadOnly​(boolean value)
      更新只读属性的值。
      void setSystem​(boolean value)
      更新系统属性的值。

      • Methods inherited from interface java.nio.file.attribute.BasicFileAttributeView

        setTimes

    • 方法详细信息

      • name

        String name​()
        返回属性视图的名称。 此类型的属性视图名称为"dos" 。
        Specified by:
        name在接口 AttributeView
        Specified by:
        name在接口 BasicFileAttributeView
        结果
        属性视图的名称

      • readAttributes

        DosFileAttributes readAttributes​()
                          throws IOException
        说明从接口BasicFileAttributeView复制
        读取大量操作的基本文件属性。

        如果所有文件属性都被读取为相对于其他文件系统操作的原子操作，则是实现特定的。

        Specified by:
        readAttributes在接口 BasicFileAttributeView
        结果
        文件属性
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了安全管理器，调用其 checkRead方法来检查对文件的读取访问

      • setReadOnly

        void setReadOnly​(boolean value)
          throws IOException
        更新只读属性的值。

        如果属性可以作为相对于其他文件系统操作的原子操作更新，则是实现特定的。 例如，实现可能需要读取DOS属性的现有值才能更新此属性。

        参数
        value - 属性的新值
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认情况下，并安装了安全管理器，将调用其 checkWrite方法来检查对该文件的写入访问

      • setHidden

        void setHidden​(boolean value)
        throws IOException
        更新隐藏属性的值。

        如果属性可以作为相对于其他文件系统操作的原子操作更新，则是实现特定的。 例如，实现可能需要读取DOS属性的现有值才能更新此属性。

        参数
        value - 属性的新值
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认情况下，并安装了安全管理器，将调用其 checkWrite方法来检查对该文件的写入访问

      • setSystem

        void setSystem​(boolean value)
        throws IOException
        更新系统属性的值。

        如果属性可以作为相对于其他文件系统操作的原子操作更新，则是实现特定的。 例如，实现可能需要读取DOS属性的现有值才能更新此属性。

        参数
        value - 属性的新值
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认情况下，安装了安全管理器，将调用其 checkWrite方法来检查对该文件的写入访问

      • setArchive

        void setArchive​(boolean value)
         throws IOException
        更新归档属性的值。

        如果属性可以作为相对于其他文件系统操作的原子操作更新，则是实现特定的。 例如，实现可能需要读取DOS属性的现有值才能更新此属性。

        参数
        value - 属性的新值
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认情况下，安装了安全管理器，将调用其 checkWrite方法来检查对该文件的写入访问
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface FileAttribute<T>

  • 参数类型
    T - 文件属性值的类型

    public interface FileAttribute<T>
    封装了通过调用 27056629619414或 createDirectory方法创建新文件或目录时可以原子地设置的文件属性的值的对象。
    从以下版本开始：
    1.7
    另请参见：
    PosixFilePermissions.asFileAttribute(java.util.Set<java.nio.file.attribute.PosixFilePermission>)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回属性名称。
      T value​()
      返回属性值。

    • 方法详细信息

      • name

        String name​()
        返回属性名称。
        结果
        属性名称

      • value

        T value​()
        返回属性值。
        结果
        属性值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface FileAttributeView

  • All Superinterfaces:
    AttributeView
    All Known Subinterfaces:
    AclFileAttributeView ， BasicFileAttributeView ， DosFileAttributeView ， FileOwnerAttributeView ， PosixFileAttributeView ， UserDefinedFileAttributeView

    public interface FileAttributeView
extends AttributeView
    属性视图，它是与文件系统中的文件相关联的非不透明值的只读或可更新视图。 该接口由特定的文件属性视图进行扩展或实现，该视图定义了读取和/或更新文件属性的方法。
    从以下版本开始：
    1.7
    另请参见：
    Files.getFileAttributeView(Path,Class,java.nio.file.LinkOption[])

    • 方法摘要

      • Methods inherited from interface java.nio.file.attribute.AttributeView

        name
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileOwnerAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface FileOwnerAttributeView

  • All Superinterfaces:
    AttributeView ， FileAttributeView
    All Known Subinterfaces:
    AclFileAttributeView ， PosixFileAttributeView

    public interface FileOwnerAttributeView
extends FileAttributeView
    支持阅读或更新文件所有者的文件属性视图。 此文件属性视图适用于支持文件属性的文件系统实现，该文件属性表示作为文件所有者的身份。 通常，文件的所有者是创建文件的实体的身份。

    getOwner或setOwner方法可用于读取或更新文件的所有者。

    getAttribute和setAttribute方法也可用于读取或更新所有者。 在这种情况下，所有者属性由名称"owner"标识，属性值为UserPrincipal 。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      UserPrincipal getOwner​()
      阅读文件所有者。
      String name​()
      返回属性视图的名称。
      void setOwner​(UserPrincipal owner)
      更新文件所有者。

    • 方法详细信息

      • name

        String name​()
        返回属性视图的名称。 此类型的属性视图名称为"owner" 。
        Specified by:
        name在接口 AttributeView
        结果
        属性视图的名称

      • getOwner

        UserPrincipal getOwner​()
                throws IOException
        阅读文件所有者。

        如果文件所有者可以是一个group，那就是具体的实现 。

        结果
        文件所有者
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，将安装安全管理器，并且它将拒绝RuntimePermission ("accessUserInformation")或其checkRead方法拒绝对该文件的读取访问。

      • setOwner

        void setOwner​(UserPrincipal owner)
       throws IOException
        更新文件所有者。

        如果文件所有者可以是一个group，那就是具体的实现 。 为了确保跨平台的一致和正确的行为，建议仅使用此方法将文件所有者设置为不是组的用户主体。

        参数
        owner - 新的文件所有者
        异常
        IOException - 如果发生I / O错误，或者 owner参数是一个组，并且此实现不支持将所有者设置为组
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，它将拒绝RuntimePermission ("accessUserInformation")或其checkWrite方法拒绝对该文件的写访问。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileStoreAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface FileStoreAttributeView

  • All Superinterfaces:
    AttributeView

    public interface FileStoreAttributeView
extends AttributeView
    属性视图，它是FileStore的属性的只读或可更新视图。
    从以下版本开始：
    1.7

    • 方法摘要

      • Methods inherited from interface java.nio.file.attribute.AttributeView

        name
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Class FileTime

  • java.lang.Object
    • java.nio.file.attribute.FileTime
  • All Implemented Interfaces:
    Comparable<FileTime>

    public final class FileTime
extends Object
implements Comparable<FileTime>
    表示文件时间戳属性的值。 例如，它可以代表该文件的最后时间modified ， accessed ，或created 。

    这个类的实例是不可变的。

    从以下版本开始：
    1.7
    另请参见：
    Files.setLastModifiedTime(java.nio.file.Path, java.nio.file.attribute.FileTime) ， Files.getLastModifiedTime(java.nio.file.Path, java.nio.file.LinkOption...)

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(FileTime other)
      比较两个 FileTime对象的价值。
      boolean equals​(Object obj)
      测试此 FileTime与给定对象的相等性。
      static FileTime from​(long value, TimeUnit unit)
      返回一个 FileTime表示给定的粒度单位的值。
      static FileTime from​(Instant instant)
      返回一个 FileTime表示与所提供的 Instant对象相同的时间点值。
      static FileTime fromMillis​(long value)
      返回一个 FileTime ，以毫秒为单位表示给定值。
      int hashCode​()
      计算此文件时间的哈希码。
      long to​(TimeUnit unit)
      返回给定的粒度单位的值。
      Instant toInstant​()
      将此 FileTime对象转换为 Instant 。
      long toMillis​()
      返回以毫秒为单位的值。
      String toString​()
      返回此 FileTime的字符串表示 FileTime 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • from

        public static FileTime from​(long value,
                            TimeUnit unit)
        返回一个 FileTime表示给定的粒度单位的值。
        参数
        value - 自纪元以来的价值（1970-01-01T00：00：00Z）; 可以是负数
        unit - 解释价值的粒度单位
        结果
        一个表示给定值的 FileTime

      • fromMillis

        public static FileTime fromMillis​(long value)
        返回一个 FileTime ，以毫秒为单位表示给定值。
        参数
        value - 自纪元（1970-01-01T00：00：00Z）以来的值（以毫秒为单位）; 可以是负数
        结果
        一个表示给定值的 FileTime

      • from

        public static FileTime from​(Instant instant)
        返回一个 FileTime代表所提供的 Instant对象在时间线上的相同时间点值。
        参数
        instant - 即时转换
        结果
        一个 FileTime代表在提供的时刻的时间线上的相同点
        从以下版本开始：
        1.8

      • to

        public long to​(TimeUnit unit)
        返回给定的粒度单位的值。

        从数值溢出饱和的较粗粒度转换为Long.MIN_VALUE如果为负）或Long.MAX_VALUE如果为正）。

        参数
        unit - 返回值的粒度单位
        结果
        价值在给定的粒度单位，自从时代以来的时代（1970-01-01T00：00：00Z）; 可以是负数

      • toMillis

        public long toMillis​()
        返回以毫秒为单位的值。

        从数值溢出饱和的较粗粒度转换为Long.MIN_VALUE如果为负）或Long.MAX_VALUE如果为正。

        结果
        自从时代以来的毫秒数值（1970-01-01T00：00：00Z）

      • toInstant

        public Instant toInstant​()
        将此FileTime对象转换为Instant 。

        转换创建Instant ，表示基于时间线，因为这同一点FileTime 。

        FileTime可以在未来进一步存储时间点上的积分，并且在过去比Instant进一步。 从这样的进一步的时间点转换饱和到Instant.MIN ，如果早于Instant.MIN或Instant.MAX如果迟于Instant.MAX 。

        结果
        表示与 FileTime对象在时间线上相同点的瞬间
        从以下版本开始：
        1.8

      • equals

        public boolean equals​(Object obj)
        测试此FileTime与给定对象的相等性。

        当且仅当该参数不是null且为代表同一时间的FileTime ，结果为true 。 该方法满足Object.equals方法的一般合同。

        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        true如果，只有当给定的对象是代表同一时间的 FileTime
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算此文件时间的哈希码。

        哈希码基于所表示的值，并满足Object.hashCode()方法的一般合同。

        重写：
        hashCode在 Object
        结果
        散列码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • compareTo

        public int compareTo​(FileTime other)
        比较两个 FileTime对象的值进行排序。
        Specified by:
        compareTo在接口 Comparable<FileTime>
        参数
        other - 另外 FileTime要进行比较
        结果
        0如果这个 FileTime等于 other ，如果这个 FileTime表示 other之前的时间，则该值小于0，如果此 FileTime表示 other之后的 other

      • toString

        public String toString​()
        返回此FileTime的字符串表示FileTime 。 字符串以ISO 8601格式返回：
          YYYY-MM-DDThh:mm:ss[.s+]Z
        其中“ [.s+] ”表示一个点，后面是一秒的小数位数。 只有当秒的小数部分不为零时才存在。 例如， FileTime.fromMillis(1234567890000L).toString()产生"2009-02-13T23:31:30Z" ，而FileTime.fromMillis(1234567890123L).toString()产生"2009-02-13T23:31:30.123Z" 。

        A FileTime主要用于表示文件时间戳的值。 如果用于表示极值 ，如果该年度小于“ 0001 ”或大于“ 9999 ”，则该方法与XML Schema language相同，偏离ISO 8601。 也就是说，年份可能会扩大到四位以上，可能是负号。 如果超过四位数，则前导零不存在。 前一年“ 0001 ”为“ -0001 ”。

        重写：
        toString在类 Object
        结果
        the string representation of this file time
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface GroupPrincipal

  • All Superinterfaces:
    Principal ， UserPrincipal

    public interface GroupPrincipal
extends UserPrincipal
    A UserPrincipal表示组身份 ，用于确定文件系统中对象的访问权限。 组的确切定义是实现特定的，但通常，它代表为管理目的而创建的身份，以便确定组成员的访问权限。 实体是否可以是多个组的成员，以及组是否可以嵌套，是指定的实现，因此未指定。
    从以下版本开始：
    1.7
    另请参见：
    UserPrincipalLookupService.lookupPrincipalByGroupName(java.lang.String)

    • 方法摘要

      • Methods inherited from interface java.security.Principal

        equals, getName, hashCode, implies, toString
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.nio.file.attribute (Java SE 9 & JDK 9 )

java.nio.file.attribute

Interfaces

  • AclFileAttributeView
  • AttributeView
  • BasicFileAttributes
  • BasicFileAttributeView
  • DosFileAttributes
  • DosFileAttributeView
  • FileAttribute
  • FileAttributeView
  • FileOwnerAttributeView
  • FileStoreAttributeView
  • GroupPrincipal
  • PosixFileAttributes
  • PosixFileAttributeView
  • UserDefinedFileAttributeView
  • UserPrincipal

Classes

  • AclEntry
  • AclEntry.Builder
  • FileTime
  • PosixFilePermissions
  • UserPrincipalLookupService

Enums

  • AclEntryFlag
  • AclEntryPermission
  • AclEntryType
  • PosixFilePermission

Exceptions

  • UserPrincipalNotFoundException


java.nio.file.attribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.nio.file.attribute

提供访问文件和文件系统属性的接口和类。
Attribute views
Attribute views | 描述
AttributeView | Can read or update non-opaque values associated with objects in a file system
FileAttributeView | Can read or update file attributes
BasicFileAttributeView | Can read or update a basic set of file attributes
PosixFileAttributeView | Can read or update POSIX defined file attributes
DosFileAttributeView | Can read or update FAT file attributes
FileOwnerAttributeView | Can read or update the owner of a file
AclFileAttributeView | Can read or update Access Control Lists
UserDefinedFileAttributeView | Can read or update user-defined file attributes
FileStoreAttributeView | Can read or update file system attributes

属性视图提供与文件系统中的对象相关联的非不透明值或元数据的只读或可更新视图。 FileAttributeView接口由几个其他接口扩展，提供对特定文件属性集的视图。 FileAttributeViews通过调用选择Files.getFileAttributeView(java.nio.file.Path, java.lang.Class<V>, java.nio.file.LinkOption...)与类型令牌的方法来确定所需的视图。 视图也可以通过名称来识别。 FileStoreAttributeView接口提供对文件存储属性的访问。 甲FileStoreAttributeView给定类型的通过调用得到FileStore.getFileStoreAttributeView(java.lang.Class<V>)方法。

BasicFileAttributeView类定义了读取和更新许多文件系统通用的基本文件属性集的方法。

PosixFileAttributeView接口通过定义方法来访问文件系统和实现便携式操作系统接口（POSIX）系列标准的操作系统通常使用的文件属性，扩展了BasicFileAttributeView 。

DosFileAttributeView类扩展了BasicFileAttributeView ，定义了访问文件系统（例如消费者设备中通常使用的文件分配表格（FAT））支持的传统“DOS”文件属性的方法。

AclFileAttributeView类定义了读取和写入访问控制列表（ACL）文件属性的方法。 此文件属性视图使用的ACL模型基于RFC 3530: Network File System (NFS) version 4 Protocol定义的模型。

除了属性视图，此包还定义了访问属性时使用的类和接口：

  • UserPrincipal和GroupPrincipal接口表示身份或组标识。
  • UserPrincipalLookupService界面定义了查找用户或组主体的方法。
  • FileAttribute接口表示在文件系统中创建对象时需要将属性值设置为原子的情况下属性的值。

除非另有说明，否则将null参数传递给此程序包中任何类或接口中的构造函数或方法将导致抛出NullPointerException 。

从以下版本开始：
1.7
  • 接口摘要
    接口 描述
    AclFileAttributeView
    支持读取或更新文件的访问控制列表（ACL）或文件所有者属性的文件属性视图。
    AttributeView
    提供与文件系统中的对象相关联的非不透明值的只读或可更新 视图的对象。
    BasicFileAttributes
    与文件系统中的文件相关联的基本属性。
    BasicFileAttributeView
    文件属性视图，提供许多文件系统通用的 基本文件属性 集的视图。
    DosFileAttributes
    与支持旧版“DOS”属性的文件系统中的文件相关联的文件属性。
    DosFileAttributeView
    提供传统“DOS”文件属性视图的文件属性视图。
    FileAttribute<T>
    封装通过调用 createFile或 createDirectory方法创建新文件或目录时可以原子地设置的文件属性的值的对象。
    FileAttributeView
    属性视图，它是与文件系统中的文件相关联的非不透明值的只读或可更新视图。
    FileOwnerAttributeView
    支持阅读或更新文件所有者的文件属性视图。
    FileStoreAttributeView
    属性视图，它是FileStore的属性的只读或可更新视图。
    GroupPrincipal
    A UserPrincipal表示 组身份 ，用于确定文件系统中对象的访问权限。
    PosixFileAttributes
    与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件相关联的文件属性。
    PosixFileAttributeView
    文件属性视图，提供通常与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件关联的文件属性视图。
    UserDefinedFileAttributeView
    文件属性视图，提供文件的用户定义属性（有时称为 扩展属性）的视图。
    UserPrincipal
    A Principal表示用于确定对文件系统中的对象的访问权限的身份。
  • 类摘要
    Class 描述
    AclEntry
    访问控制列表（ACL）中的条目。
    AclEntry.Builder
    一个AclEntry对象的生成器。
    FileTime
    表示文件时间戳属性的值。
    PosixFilePermissions
    该类只包含对PosixFilePermission对象进行操作的静态方法。
    UserPrincipalLookupService
    按名称查找用户和组主体的对象。
  • 枚举摘要
    Enum 描述
    AclEntryFlag
    定义ACL entry的标志组件使用的标志。
    AclEntryPermission
    定义与ACL entry的权限组件一起使用的权限。
    AclEntryType
    访问控制条目类型的类型安全枚举。
    PosixFilePermission
    定义与 permissions属性一起使用的位。
  • 异常摘要
    异常 描述
    UserPrincipalNotFoundException
    当查询UserPrincipal失败，因为主体不存在时抛出的检查异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.nio.file.attribute Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.nio.file.attribute

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.nio.file.attribute.AclEntry
    • java.nio.file.attribute.AclEntry.Builder
    • java.nio.file.attribute.FileTime (implements java.lang.Comparable<T>)
    • java.nio.file.attribute.PosixFilePermissions
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • java.nio.file.attribute.UserPrincipalNotFoundException
    • java.nio.file.attribute.UserPrincipalLookupService

Interface Hierarchy

  • java.nio.file.attribute.AttributeView
    • java.nio.file.attribute.FileAttributeView
      • java.nio.file.attribute.BasicFileAttributeView
        • java.nio.file.attribute.DosFileAttributeView
        • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.FileOwnerAttributeView)
      • java.nio.file.attribute.FileOwnerAttributeView
        • java.nio.file.attribute.AclFileAttributeView
        • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.BasicFileAttributeView)
      • java.nio.file.attribute.UserDefinedFileAttributeView
    • java.nio.file.attribute.FileStoreAttributeView
  • java.nio.file.attribute.BasicFileAttributes
    • java.nio.file.attribute.DosFileAttributes
    • java.nio.file.attribute.PosixFileAttributes
  • java.nio.file.attribute.FileAttribute<T>
  • java.security.Principal
    • java.nio.file.attribute.UserPrincipal
      • java.nio.file.attribute.GroupPrincipal

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.nio.file.attribute.AclEntryFlag
      • java.nio.file.attribute.AclEntryPermission
      • java.nio.file.attribute.AclEntryType
      • java.nio.file.attribute.PosixFilePermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


PosixFileAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface PosixFileAttributes

  • All Superinterfaces:
    BasicFileAttributes

    public interface PosixFileAttributes
extends BasicFileAttributes
    与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件相关联的文件属性。

    使用PosixFileAttributeView通过调用其readAttributes方法检索文件的POSIX属性。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      GroupPrincipal group​()
      返回该文件的组所有者。
      UserPrincipal owner​()
      返回文件的所有者。
      Set<PosixFilePermission> permissions​()
      返回文件的权限。

      • Methods inherited from interface java.nio.file.attribute.BasicFileAttributes

        creationTime, fileKey, isDirectory, isOther, isRegularFile, isSymbolicLink, lastAccessTime, lastModifiedTime, size

    • 方法详细信息

      • owner

        UserPrincipal owner​()
        返回文件的所有者。
        结果
        文件所有者
        另请参见：
        FileOwnerAttributeView.setOwner(java.nio.file.attribute.UserPrincipal)

      • group

        GroupPrincipal group​()
        返回该文件的组所有者。
        结果
        文件组所有者
        另请参见：
        PosixFileAttributeView.setGroup(java.nio.file.attribute.GroupPrincipal)

      • permissions

        Set<PosixFilePermission> permissions​()
        返回文件的权限。 文件权限作为一组PosixFilePermission元素返回。 返回的集合是文件权限的副本，可以修改。 这样可以将结果修改并传递给setPermissions方法来更新文件的权限。
        结果
        文件权限
        另请参见：
        PosixFileAttributeView.setPermissions(java.util.Set<java.nio.file.attribute.PosixFilePermission>)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PosixFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface PosixFileAttributeView

  • All Superinterfaces:
    AttributeView ， BasicFileAttributeView ， FileAttributeView ， FileOwnerAttributeView

    public interface PosixFileAttributeView
extends BasicFileAttributeView, FileOwnerAttributeView
    文件属性视图，提供通常与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件关联的文件属性视图。

    实现POSIX系列标准的操作系统通常使用具有文件所有者 ， 组所有者和相关访问权限的文件系统。 此文件属性视图提供对这些属性的读取和写入访问。

    readAttributes方法用于读取文件的属性。 文件owner由用于访问控制的目的的文件所有者的身份的UserPrincipal表示。 由GroupPrincipal代表的group-owner是组所有者的身份，其中组是为管理目的而创建的身份，以确定组成员的访问权限。

    permissions属性是一组访问权限。 此文件属性视图提供对由PosixFilePermission类定义的九个权限的访问。 这9个许可位确定文件所有者，组和其他人的读取 ， 写入和执行访问权限（其他意思是除了所有者和组成员之外的身份）。 某些操作系统和文件系统可能会提供额外的权限位，但此版本中此类不定义访问这些其他位。

    使用示例：假设我们需要打印一个文件的所有者和访问权限：

      Path file = ...
     PosixFileAttributes attrs = Files.getFileAttributeView(file, PosixFileAttributeView.class)
         .readAttributes();
     System.out.format("%s %s%n",
         attrs.owner().getName(),
         PosixFilePermissions.toString(attrs.permissions()));

    动态访问

    在需要动态访问文件属性的情况下，此属性视图支持的属性由BasicFileAttributeView和FileOwnerAttributeView定义，此外还支持以下属性：

    Supported attributes
    Name | Type
    "permissions" | Set<PosixFilePermission>
    "group" | GroupPrincipal

    getAttribute方法可用于读取这些属性中的任何一个，或BasicFileAttributeView定义的任何属性，如同通过调用readAttributes()方法一样。

    setAttribute方法可用于更新文件的上一次修改时间，上次访问时间或创建由BasicFileAttributeView定义的时间属性。 它也可用于通过调用来更新权限，拥有者，或好象基的所有者setPermissions ， setOwner ，和setGroup分别方法。

    设置初始权限

    支持此属性视图的实现也可以支持在创建文件或目录时设置初始权限。 初始权限提供给createFile或createDirectory方法作为FileAttribute与name "posix:permissions"和一个value这是一组权限。 以下示例在创建文件时使用asFileAttribute方法构建FileAttribute ：

      Path path = ...
     Set<PosixFilePermission> perms =
         EnumSet.of(OWNER_READ, OWNER_WRITE, OWNER_EXECUTE, GROUP_READ);
     Files.createFile(path, PosixFilePermissions.asFileAttribute(perms));

    当访问权限设置为文件创建时间时，权限的实际值可能会与属性对象的值不同。 其原因是具体实施。 例如，在UNIX系统上，进程具有影响新创建文件的权限位的umask 。 如果实现支持访问权限的设置，并且底层文件系统支持访问权限，则需要实际访问权限的值将等于或小于提供给createFile或createDirectory方法的属性的值。 换句话说，该文件可能比请求更安全。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回属性视图的名称。
      PosixFileAttributes readAttributes​()
      读取大量操作的基本文件属性。
      void setGroup​(GroupPrincipal group)
      更新文件组所有者。
      void setPermissions​(Set<PosixFilePermission> perms)
      更新文件权限。

      • Methods inherited from interface java.nio.file.attribute.BasicFileAttributeView

        setTimes

      • Methods inherited from interface java.nio.file.attribute.FileOwnerAttributeView

        getOwner, setOwner

    • 方法详细信息

      • name

        String name​()
        返回属性视图的名称。 此类型的属性视图名称为"posix" 。
        Specified by:
        name在接口 AttributeView
        Specified by:
        name在接口 BasicFileAttributeView
        Specified by:
        name在接口 FileOwnerAttributeView
        结果
        属性视图的名称

      • readAttributes

        PosixFileAttributes readAttributes​()
                            throws IOException
        说明从接口BasicFileAttributeView复制
        读取大量操作的基本文件属性。

        如果所有文件属性都被读取为相对于其他文件系统操作的原子操作，则是实现特定的。

        Specified by:
        readAttributes在接口 BasicFileAttributeView
        结果
        文件属性
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，将安装一个安全管理器，它将拒绝RuntimePermission ("accessUserInformation")或其checkRead方法拒绝对该文件的读取访问。

      • setPermissions

        void setPermissions​(Set<PosixFilePermission> perms)
             throws IOException
        更新文件权限。
        参数
        perms - 新的权限集
        异常
        ClassCastException - 如果集合包含不是类型为 PosixFilePermission
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，并且它拒绝RuntimePermission ("accessUserInformation")或其checkWrite方法拒绝对该文件的写访问。

      • setGroup

        void setGroup​(GroupPrincipal group)
       throws IOException
        更新文件组所有者。
        参数
        group - 新的文件组所有者
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，它将拒绝RuntimePermission ("accessUserInformation")或其checkWrite方法拒绝对该文件的写入访问。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PosixFilePermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Enum PosixFilePermission

  • java.lang.Object
    • java.lang.Enum<PosixFilePermission>
      • java.nio.file.attribute.PosixFilePermission
  • All Implemented Interfaces:
    Serializable ， Comparable<PosixFilePermission>

    public enum PosixFilePermission
extends Enum<PosixFilePermission>
    定义与permissions属性一起使用的位。

    PosixFilePermissions类定义了操纵权限集的方法。

    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      GROUP_EXECUTE
      执行/搜索权限，组。
      GROUP_READ
      读权限，组。
      GROUP_WRITE
      写权限，组。
      OTHERS_EXECUTE
      执行/搜索许可，其他。
      OTHERS_READ
      阅读权限，其他人。
      OTHERS_WRITE
      写许可，其他。
      OWNER_EXECUTE
      执行/搜索权限，所有者。
      OWNER_READ
      读权限，所有者。
      OWNER_WRITE
      书面许可，所有者。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PosixFilePermission valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PosixFilePermission[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • OWNER_READ

        public static final PosixFilePermission OWNER_READ
        读权限，所有者。

      • OWNER_WRITE

        public static final PosixFilePermission OWNER_WRITE
        书面许可，所有者。

      • OWNER_EXECUTE

        public static final PosixFilePermission OWNER_EXECUTE
        执行/搜索权限，所有者。

      • GROUP_READ

        public static final PosixFilePermission GROUP_READ
        读权限，组。

      • GROUP_WRITE

        public static final PosixFilePermission GROUP_WRITE
        写权限，组。

      • GROUP_EXECUTE

        public static final PosixFilePermission GROUP_EXECUTE
        执行/搜索权限，组。

      • OTHERS_READ

        public static final PosixFilePermission OTHERS_READ
        阅读权限，其他人。

      • OTHERS_WRITE

        public static final PosixFilePermission OTHERS_WRITE
        写许可，其他。

      • OTHERS_EXECUTE

        public static final PosixFilePermission OTHERS_EXECUTE
        执行/搜索许可，其他。

    • 方法详细信息

      • values

        public static PosixFilePermission[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PosixFilePermission c : PosixFilePermission.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PosixFilePermission valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PosixFilePermissions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Class PosixFilePermissions

  • java.lang.Object
    • java.nio.file.attribute.PosixFilePermissions

  • public final class PosixFilePermissions
extends Object
    此类仅由静态方法组成，可用于PosixFilePermission个对象的集合。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FileAttribute<Set<PosixFilePermission>> asFileAttribute​(Set<PosixFilePermission> perms)
      创建一个FileAttribute ，封装给定文件权限的副本，适合传递给createFile或createDirectory方法。
      static Set<PosixFilePermission> fromString​(String perms)
      返回与给定的 String表示相对应的一组权限。
      static String toString​(Set<PosixFilePermission> perms)
      返回一组权限的 String表示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • toString

        public static String toString​(Set<PosixFilePermission> perms)
        返回一组权限的String表示。 确保返回的String可以通过fromString(java.lang.String)方法进行解析。

        如果集合包含null或不是类型为PosixFilePermission元素，那么这些元素将被忽略。

        参数
        perms - 权限集
        结果
        该权限集的字符串表示形式

      • fromString

        public static Set<PosixFilePermission> fromString​(String perms)
        返回与给定的String表示相对应的一组权限。

        perms参数是表示权限的String 。 它有9个字符被解释为三组三个。 第一组是指所有者的权限; 旁边的组权限和最后给别人。 在每个集合中，第一个字符是'r' ，表示允许读取，第二个字符是'w'表示许可写入，第三个字符是'x'用于执行许可。 如果未设置权限，则相应的字符将设置为'-' 。

        使用示例：假设我们需要一组权限，指示所有者具有读取，写入和执行权限，该组具有读取和执行权限，而其他人没有。

          Set<PosixFilePermission> perms = PosixFilePermissions.fromString("rwxr-x---");
        参数
        perms - 表示一组权限的字符串
        结果
        由此产生的一组权限
        异常
        IllegalArgumentException - 如果字符串不能转换为一组权限
        另请参见：
        toString(Set)

      • asFileAttribute

        public static FileAttribute<Set<PosixFilePermission>> asFileAttribute​(Set<PosixFilePermission> perms)
        创建一个FileAttribute ，封装给定文件权限的副本，适合传递给createFile或createDirectory的方法。
        参数
        perms - 权限集
        结果
        封装给定文件权限的属性为 name "posix:permissions"
        异常
        ClassCastException - 如果集合包含不是类型为 PosixFilePermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UserDefinedFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface UserDefinedFileAttributeView

  • All Superinterfaces:
    AttributeView ， FileAttributeView

    public interface UserDefinedFileAttributeView
extends FileAttributeView
    文件属性视图，提供文件的用户定义属性（有时称为扩展属性）的视图。 用户定义的文件属性用于存储具有对文件系统无意义的文件的元数据。 它主要用于直接支持这种能力但可能被仿真的文件系统实现。 这种仿真的细节是高度实现具体的，因此没有指定。

    此FileAttributeView提供了一个文件的用户定义属性作为一组名称/值对的视图，其中属性名称由String表示。 当访问属性时，实现可能需要从平台或文件系统表示进行编码和解码。 该值具有不透明的内容。 此属性视图定义了read和write方法，以从ByteBuffer读取或写入值。 此FileAttributeView不适用于属性值的大小大于Integer.MAX_VALUE的位置 。

    在一些实现中可以使用用户定义的属性来存储与安全相关的属性，因此，至少在默认提供者的情况下，访问用户定义属性的所有方法在安装安全管理器时都需要RuntimePermission("accessUserDefinedAttributes")权限。

    supportsFileAttributeView方法可用于测试特定的FileStore是否支持用户定义属性的存储。

    在需要动态访问文件属性的地方，可以使用getAttribute方法来读取属性值。 属性值作为字节数组返回（byte []）。 setAttribute方法可用于从缓冲区（如通过调用write方法）或字节数组（byte []）写入用户定义属性的值。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void delete​(String name)
      删除用户定义的属性。
      List<String> list​()
      返回包含用户定义属性名称的列表。
      String name​()
      返回此属性视图的名称。
      int read​(String name, ByteBuffer dst)
      将用户定义属性的值读入缓冲区。
      int size​(String name)
      返回用户定义属性值的大小。
      int write​(String name, ByteBuffer src)
      从缓冲区写入用户定义属性的值。

    • 方法详细信息

      • name

        String name​()
        返回此属性视图的名称。 此类型的属性视图名称为"user" 。
        Specified by:
        name在接口 AttributeView
        结果
        属性视图的名称

      • list

        List<String> list​()
           throws IOException
        返回包含用户定义属性名称的列表。
        结果
        一个不可修改的列表，其中包含文件用户定义的名称
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，并且它拒绝RuntimePermission ("accessUserDefinedAttributes")或其checkRead方法拒绝对该文件的读取访问。

      • size

        int size​(String name)
  throws IOException
        返回用户定义属性值的大小。
        参数
        name - 属性名称
        结果
        属性值的大小，以字节为单位。
        异常
        ArithmeticException - 如果属性的大小大于 Integer.MAX_VALUE
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，将安装安全管理器，并且它将拒绝RuntimePermission ("accessUserDefinedAttributes")或其checkRead方法拒绝对该文件的读取访问。

      • read

        int read​(String name,
         ByteBuffer dst)
  throws IOException
        将用户定义属性的值读入缓冲区。

        此方法将属性值作为字节序列读入给定的缓冲区，如果缓冲区中剩余的字节数不足以读取完整的属性值，则会失败。 传输到缓冲区的字节数为n ，其中n是属性值的大小。 序列中的第一个字节的索引为p和最后一个字节是指数p + n - 1 ，其中p是缓冲区的位置。 缓冲区的返回位置将等于p + n ; 其限制将不会改变。

        用法示例：假设我们要读取一个文件的MIME类型，该类型以用户定义的属性存储，名称为“ user.mimetype ”。

          UserDefinedFileAttributeView view =
        Files.getFileAttributeView(path, UserDefinedFileAttributeView.class);
    String name = "user.mimetype";
    ByteBuffer buf = ByteBuffer.allocate(view.size(name));
    view.read(name, buf);
    buf.flip();
    String value = Charset.defaultCharset().decode(buf).toString();
        参数
        name - 属性名称
        dst - 目的缓冲区
        结果
        读取的字节数，可能为零
        异常
        IllegalArgumentException - 如果目标缓冲区是只读的
        IOException - 如果发生I / O错误或目标缓冲区中的属性值空间不足
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，它将拒绝RuntimePermission ("accessUserDefinedAttributes")或其checkRead方法拒绝对该文件的读取访问。
        另请参见：
        size(java.lang.String)

      • write

        int write​(String name,
          ByteBuffer src)
   throws IOException
        从缓冲区写入用户定义属性的值。

        该方法将给定缓冲区中的属性值作为字节序列。 要传输的值的大小是r ，其中r是缓冲区中剩余的字节数，即src.remaining() 。 字节序列从索引p开始的缓冲区p ，其中p是缓冲区的位置。 一旦返回，缓冲区的位置将等于p + n ，其中n是传输的字节数; 其限制将不会改变。

        如果给定名称的属性已经存在，那么它的值将被替换。 如果属性不存在，则创建它。 如果实现具体，如果检查属性的存在和属性的创建的测试对于其他文件系统活动是原子的。

        如果没有足够的空间存储属性，或者属性名称或值超过实现特定的最大大小，则抛出IOException 。

        使用示例：假设我们要将文件的MIME类型写成用户定义的属性：

          UserDefinedFileAttributeView view =
        FIles.getFileAttributeView(path, UserDefinedFileAttributeView.class);
    view.write("user.mimetype", Charset.defaultCharset().encode("text/html"));
        参数
        name - 属性名称
        src - 包含属性值的缓冲区
        结果
        写入的字节数，可能为零
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，并且它拒绝270566674487878 ("accessUserDefinedAttributes")或其checkWrite方法拒绝对该文件的写访问。

      • delete

        void delete​(String name)
     throws IOException
        删除用户定义的属性。
        参数
        name - 属性名称
        异常
        IOException - 如果发生I / O错误或属性不存在
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，它将拒绝RuntimePermission ("accessUserDefinedAttributes")或其checkWrite方法拒绝对该文件的写入访问。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Interface UserPrincipal

  • All Superinterfaces:
    Principal
    All Known Subinterfaces:
    GroupPrincipal

    public interface UserPrincipal
extends Principal
    A Principal表示用于确定对文件系统中的对象的访问权限的身份。

    在许多平台和文件系统上，实体需要适当的访问权限才能访问文件系统中的对象。 通常通过检查实体的身份来执行访问权限。 例如，在使用访问控制列表（ACL）执行权限分离的实现上，文件系统中的文件可能具有关联的ACL，该ACL确定ACL中指定的身份的访问权限。

    A UserPrincipal对象是身份的抽象表示。 它有一个name ，通常是其所代表的用户名或帐户名称。 可以使用UserPrincipalLookupService获得用户主体对象，或者由提供对身份相关属性的访问的FileAttributeView实现返回。 例如， AclFileAttributeView和PosixFileAttributeView提供对文件的访问owner 。

    从以下版本开始：
    1.7

    • 方法摘要

      • Methods inherited from interface java.security.Principal

        equals, getName, hashCode, implies, toString
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UserPrincipalLookupService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Class UserPrincipalLookupService

  • java.lang.Object
    • java.nio.file.attribute.UserPrincipalLookupService

  • public abstract class UserPrincipalLookupService
extends Object
    按名称查找用户和组主体的对象。 A UserPrincipal表示可以用于确定对文件系统中的对象的访问权限的身份。 A GroupPrincipal表示组身份 。 A UserPrincipalLookupService定义了通过名称或组名称（通常是用户或帐户名称）查找身份的方法。 名称和组名称是否区分大小写取决于实现。 组的确切定义是实现特定的，但通常组代表为管理目的而创建的身份，以便确定组成员的访问权限。 特别地，如果名称和组的名称空间相同或不同，则具体实现。 为了确保跨平台的一致和正确的行为，建议使用这个API，就像命名空间是不同的。 换句话说， lookupPrincipalByName应该用于查找用户，而lookupPrincipalByGroupName应该用于查找组。
    从以下版本开始：
    1.7
    另请参见：
    FileSystem.getUserPrincipalLookupService()

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected UserPrincipalLookupService​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract GroupPrincipal lookupPrincipalByGroupName​(String group)
      按组名查找组主体。
      abstract UserPrincipal lookupPrincipalByName​(String name)
      按名称查找用户主体。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • UserPrincipalLookupService

        protected UserPrincipalLookupService​()
        初始化此类的新实例。

    • 方法详细信息

      • lookupPrincipalByName

        public abstract UserPrincipal lookupPrincipalByName​(String name)
                                             throws IOException
        按名称查找用户主体。
        参数
        name - 要查找的用户主体的字符串表示形式
        结果
        用户主体
        异常
        UserPrincipalNotFoundException - 校长不存在
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，它检查RuntimePermission ("lookupUserInformation")

      • lookupPrincipalByGroupName

        public abstract GroupPrincipal lookupPrincipalByGroupName​(String group)
                                                   throws IOException
        按组名查找组主体。

        如果一个实现不支持group的概念，那么这个方法总是会抛出UserPrincipalNotFoundException 。 在用户帐户和组的命名空间相同的地方，该方法与调用lookupPrincipalByName相同。

        参数
        group - 要查找的组的字符串表示形式
        结果
        一个团体负责人
        异常
        UserPrincipalNotFoundException - 校长不存在或不是组
        IOException - 如果发生I / O错误
        SecurityException - In the case of the default provider, and a security manager is installed, it checks RuntimePermission ("lookupUserInformation")
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UserPrincipalNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.attribute

Class UserPrincipalNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.nio.file.attribute.UserPrincipalNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class UserPrincipalNotFoundException
extends IOException
    当UserPrincipal的查找失败，因为主体不存在时抛出的检查异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UserPrincipalNotFoundException​(String name)
      构造这个类的一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getName​()
      如果使用未找到的用户主体名称创建此异常，则返回用户主体名称，否则为 null 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UserPrincipalNotFoundException

        public UserPrincipalNotFoundException​(String name)
        构造这个类的一个实例。
        参数
        name - 主名; 可能是null

    • 方法详细信息

      • getName

        public String getName​()
        如果使用未找到的用户主体名称创建此异常，则返回用户主体名称，否则为 null 。
        结果
        用户主体名称或 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.nio.file.attribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.nio.file.attribute

  • Packages that use java.nio.file.attribute
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供商类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
  • Classes in java.nio.file.attribute used by java.nio.channels
    Class 描述
    FileAttribute
    封装了通过调用 createFile或 createDirectory方法创建新文件或目录时可以原子地设置的文件属性的值的对象。
  • Classes in java.nio.file.attribute used by java.nio.file
    Class 描述
    BasicFileAttributes
    与文件系统中的文件相关联的基本属性。
    FileAttribute
    封装通过调用 createFile或 createDirectory方法创建新文件或目录时可以原子设置的文件属性值的对象。
    FileAttributeView
    属性视图，它是与文件系统中的文件相关联的非不透明值的只读或可更新视图。
    FileStoreAttributeView
    属性视图是FileStore的属性的只读或可更新视图。
    FileTime
    表示文件时间戳属性的值。
    PosixFilePermission
    定义与 permissions属性一起使用的位。
    UserPrincipal
    A Principal表示用于确定文件系统中对象的访问权限的身份。
    UserPrincipalLookupService
    按名称查找用户和组主体的对象。
  • Classes in java.nio.file.attribute used by java.nio.file.attribute
    Class 描述
    AclEntry
    访问控制列表（ACL）中的条目。
    AclEntry.Builder
    一个AclEntry对象的生成器。
    AclEntryFlag
    定义ACL entry的标志组件使用的标志。
    AclEntryPermission
    定义与ACL entry的权限组件一起使用的权限。
    AclEntryType
    访问控制条目类型的类型安全枚举。
    AttributeView
    提供与文件系统中的对象相关联的非不透明值的只读或可更新 视图的对象。
    BasicFileAttributes
    与文件系统中的文件相关联的基本属性。
    BasicFileAttributeView
    文件属性视图，提供许多文件系统通用的 基本文件属性 集的视图。
    DosFileAttributes
    与支持旧版“DOS”属性的文件系统中的文件相关联的文件属性。
    FileAttribute
    封装通过调用 createFile或 createDirectory方法创建新文件或目录时可以原子设置的文件属性的值的对象。
    FileAttributeView
    属性视图，它是与文件系统中的文件相关联的非不透明值的只读或可更新视图。
    FileOwnerAttributeView
    支持阅读或更新文件所有者的文件属性视图。
    FileTime
    表示文件时间戳属性的值。
    GroupPrincipal
    A UserPrincipal表示 组身份 ，用于确定文件系统中对象的访问权限。
    PosixFileAttributes
    与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件相关联的文件属性。
    PosixFilePermission
    定义与 permissions属性一起使用的位。
    UserPrincipal
    A Principal表示用于确定文件系统中对象的访问权限的身份。
  • Classes in java.nio.file.attribute used by java.nio.file.spi
    Class 描述
    BasicFileAttributes
    与文件系统中的文件相关联的基本属性。
    FileAttribute
    封装通过调用 createFile或 createDirectory方法创建新文件或目录时可以原子地设置的文件属性的值的对象。
    FileAttributeView
    属性视图，它是与文件系统中的文件相关联的非不透明值的只读或可更新视图。
  • Classes in java.nio.file.attribute used by java.util.zip
    Class 描述
    FileTime
    表示文件时间戳属性的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.AclEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.AclEntry

  • Packages that use AclEntry
    软件包 描述
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of AclEntry in java.nio.file.attribute

      Methods in java.nio.file.attribute that return AclEntry
      Modifier and Type 方法 描述
      AclEntry AclEntry.Builder.build​()
      从此构建器的组件构造一个AclEntry 。
      Methods in java.nio.file.attribute that return types with arguments of type AclEntry
      Modifier and Type 方法 描述
      List<AclEntry> AclFileAttributeView.getAcl​()
      读取访问控制列表。
      Methods in java.nio.file.attribute with parameters of type AclEntry
      Modifier and Type 方法 描述
      static AclEntry.Builder AclEntry.newBuilder​(AclEntry entry)
      使用现有ACL条目的组件构造一个新构建器。
      Method parameters in java.nio.file.attribute with type arguments of type AclEntry
      Modifier and Type 方法 描述
      void AclFileAttributeView.setAcl​(List<AclEntry> acl)
      更新（替换）访问控制列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.AclEntry.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.AclEntry.Builder

  • Packages that use AclEntry.Builder
    软件包 描述
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of AclEntry.Builder in java.nio.file.attribute

      Methods in java.nio.file.attribute that return AclEntry.Builder
      Modifier and Type 方法 描述
      static AclEntry.Builder AclEntry.newBuilder​()
      构建一个新的构建器。
      static AclEntry.Builder AclEntry.newBuilder​(AclEntry entry)
      使用现有ACL条目的组件构造一个新构建器。
      AclEntry.Builder AclEntry.Builder.setFlags​(AclEntryFlag... flags)
      设置此构建器的标志组件。
      AclEntry.Builder AclEntry.Builder.setFlags​(Set<AclEntryFlag> flags)
      设置此构建器的标志组件。
      AclEntry.Builder AclEntry.Builder.setPermissions​(AclEntryPermission... perms)
      设置此构建器的权限组件。
      AclEntry.Builder AclEntry.Builder.setPermissions​(Set<AclEntryPermission> perms)
      设置此构建器的权限组件。
      AclEntry.Builder AclEntry.Builder.setPrincipal​(UserPrincipal who)
      设置此构建器的主要组件。
      AclEntry.Builder AclEntry.Builder.setType​(AclEntryType type)
      设置此构建器的类型组件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.AclEntryFlag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.AclEntryFlag

  • Packages that use AclEntryFlag
    软件包 描述
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of AclEntryFlag in java.nio.file.attribute

      Methods in java.nio.file.attribute that return AclEntryFlag
      Modifier and Type 方法 描述
      static AclEntryFlag AclEntryFlag.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AclEntryFlag[] AclEntryFlag.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.nio.file.attribute that return types with arguments of type AclEntryFlag
      Modifier and Type 方法 描述
      Set<AclEntryFlag> AclEntry.flags​()
      返回flags组件的副本。
      Methods in java.nio.file.attribute with parameters of type AclEntryFlag
      Modifier and Type 方法 描述
      AclEntry.Builder AclEntry.Builder.setFlags​(AclEntryFlag... flags)
      设置此构建器的标志组件。
      Method parameters in java.nio.file.attribute with type arguments of type AclEntryFlag
      Modifier and Type 方法 描述
      AclEntry.Builder AclEntry.Builder.setFlags​(Set<AclEntryFlag> flags)
      设置此构建器的标志组件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.AclEntryPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.AclEntryPermission

  • Packages that use AclEntryPermission
    软件包 描述
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of AclEntryPermission in java.nio.file.attribute

      Fields in java.nio.file.attribute declared as AclEntryPermission
      Modifier and Type Field 描述
      static AclEntryPermission AclEntryPermission.ADD_FILE
      向目录添加新文件的权限（等于 WRITE_DATA ）
      static AclEntryPermission AclEntryPermission.ADD_SUBDIRECTORY
      创建目录的子目录的权限（等于 APPEND_DATA ）
      static AclEntryPermission AclEntryPermission.LIST_DIRECTORY
      列出目录条目的权限（等于 READ_DATA ）
      Methods in java.nio.file.attribute that return AclEntryPermission
      Modifier and Type 方法 描述
      static AclEntryPermission AclEntryPermission.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AclEntryPermission[] AclEntryPermission.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.nio.file.attribute that return types with arguments of type AclEntryPermission
      Modifier and Type 方法 描述
      Set<AclEntryPermission> AclEntry.permissions​()
      返回权限组件的副本。
      Methods in java.nio.file.attribute with parameters of type AclEntryPermission
      Modifier and Type 方法 描述
      AclEntry.Builder AclEntry.Builder.setPermissions​(AclEntryPermission... perms)
      设置此构建器的权限组件。
      Method parameters in java.nio.file.attribute with type arguments of type AclEntryPermission
      Modifier and Type 方法 描述
      AclEntry.Builder AclEntry.Builder.setPermissions​(Set<AclEntryPermission> perms)
      设置此构建器的权限组件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.AclEntryType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.AclEntryType

  • Packages that use AclEntryType
    软件包 描述
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of AclEntryType in java.nio.file.attribute

      Methods in java.nio.file.attribute that return AclEntryType
      Modifier and Type 方法 描述
      AclEntryType AclEntry.type​()
      返回ACL条目类型。
      static AclEntryType AclEntryType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AclEntryType[] AclEntryType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.nio.file.attribute with parameters of type AclEntryType
      Modifier and Type 方法 描述
      AclEntry.Builder AclEntry.Builder.setType​(AclEntryType type)
      设置此构建器的类型组件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.FileTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.FileTime

  • Packages that use FileTime
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of FileTime in java.nio.file

      Methods in java.nio.file that return FileTime
      Modifier and Type 方法 描述
      static FileTime Files.getLastModifiedTime​(Path path, LinkOption... options)
      返回文件的上次修改时间。
      Methods in java.nio.file with parameters of type FileTime
      Modifier and Type 方法 描述
      static Path Files.setLastModifiedTime​(Path path, FileTime time)
      更新文件上次修改的时间属性。

    • Uses of FileTime in java.nio.file.attribute

      Methods in java.nio.file.attribute that return FileTime
      Modifier and Type 方法 描述
      FileTime BasicFileAttributes.creationTime​()
      返回创建时间。
      static FileTime FileTime.from​(long value, TimeUnit unit)
      返回一个 FileTime表示给定的粒度单位的值。
      static FileTime FileTime.from​(Instant instant)
      返回一个 FileTime表示与所提供的 Instant对象相同的时间点值。
      static FileTime FileTime.fromMillis​(long value)
      返回一个 FileTime ，以毫秒为单位表示给定值。
      FileTime BasicFileAttributes.lastAccessTime​()
      返回上一次访问的时间。
      FileTime BasicFileAttributes.lastModifiedTime​()
      返回上次修改的时间。
      Methods in java.nio.file.attribute with parameters of type FileTime
      Modifier and Type 方法 描述
      int FileTime.compareTo​(FileTime other)
      比较两个 FileTime对象的价值。
      void BasicFileAttributeView.setTimes​(FileTime lastModifiedTime, FileTime lastAccessTime, FileTime createTime)
      更新文件的最后修改时间，上次访问时间和创建时间属性的任何或全部。

    • Uses of FileTime in java.util.zip

      Methods in java.util.zip that return FileTime
      Modifier and Type 方法 描述
      FileTime ZipEntry.getCreationTime​()
      返回条目的创建时间。
      FileTime ZipEntry.getLastAccessTime​()
      返回条目的最后访问时间。
      FileTime ZipEntry.getLastModifiedTime​()
      返回条目的最后修改时间。
      Methods in java.util.zip with parameters of type FileTime
      Modifier and Type 方法 描述
      ZipEntry ZipEntry.setCreationTime​(FileTime time)
      设置条目的创建时间。
      ZipEntry ZipEntry.setLastAccessTime​(FileTime time)
      设置条目的最后访问时间。
      ZipEntry ZipEntry.setLastModifiedTime​(FileTime time)
      Sets the last modification time of the entry.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.PosixFilePermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.PosixFilePermission

  • Packages that use PosixFilePermission
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of PosixFilePermission in java.nio.file

      Methods in java.nio.file that return types with arguments of type PosixFilePermission
      Modifier and Type 方法 描述
      static Set<PosixFilePermission> Files.getPosixFilePermissions​(Path path, LinkOption... options)
      返回文件的POSIX文件权限。
      Method parameters in java.nio.file with type arguments of type PosixFilePermission
      Modifier and Type 方法 描述
      static Path Files.setPosixFilePermissions​(Path path, Set<PosixFilePermission> perms)
      设置文件的POSIX权限。

    • Uses of PosixFilePermission in java.nio.file.attribute

      Methods in java.nio.file.attribute that return PosixFilePermission
      Modifier and Type 方法 描述
      static PosixFilePermission PosixFilePermission.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PosixFilePermission[] PosixFilePermission.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.nio.file.attribute that return types with arguments of type PosixFilePermission
      Modifier and Type 方法 描述
      static FileAttribute<Set<PosixFilePermission>> PosixFilePermissions.asFileAttribute​(Set<PosixFilePermission> perms)
      创建一个FileAttribute ，封装给定文件的权限，适合传递给createFile或createDirectory的方法。
      static Set<PosixFilePermission> PosixFilePermissions.fromString​(String perms)
      返回与给定的 String表示相对应的一组权限。
      Set<PosixFilePermission> PosixFileAttributes.permissions​()
      返回文件的权限。
      Method parameters in java.nio.file.attribute with type arguments of type PosixFilePermission
      Modifier and Type 方法 描述
      static FileAttribute<Set<PosixFilePermission>> PosixFilePermissions.asFileAttribute​(Set<PosixFilePermission> perms)
      创建一个FileAttribute ，封装给定文件权限的副本，适合传递给createFile或createDirectory的方法。
      void PosixFileAttributeView.setPermissions​(Set<PosixFilePermission> perms)
      更新文件权限。
      static String PosixFilePermissions.toString​(Set<PosixFilePermission> perms)
      返回一组权限的 String表示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.PosixFilePermissions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.PosixFilePermissions

No usage of java.nio.file.attribute.PosixFilePermissions
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.UserPrincipalLookupService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.UserPrincipalLookupService

  • Packages that use UserPrincipalLookupService
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of UserPrincipalLookupService in java.nio.file

      Methods in java.nio.file that return UserPrincipalLookupService
      Modifier and Type 方法 描述
      abstract UserPrincipalLookupService FileSystem.getUserPrincipalLookupService​()
      返回此文件系统的 UserPrincipalLookupService （可选操作） 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.attribute.UserPrincipalNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.attribute.UserPrincipalNotFoundException

No usage of java.nio.file.attribute.UserPrincipalNotFoundException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.AclFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.AclFileAttributeView

No usage of java.nio.file.attribute.AclFileAttributeView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.AttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.AttributeView

  • Packages that use AttributeView
    软件包 描述
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of AttributeView in java.nio.file.attribute

      Subinterfaces of AttributeView in java.nio.file.attribute
      Modifier and Type 接口 描述
      interface  AclFileAttributeView
      支持读取或更新文件的访问控制列表（ACL）或文件所有者属性的文件属性视图。
      interface  BasicFileAttributeView
      文件属性视图，提供许多文件系统通用的 基本文件属性 集的视图。
      interface  DosFileAttributeView
      提供传统“DOS”文件属性视图的文件属性视图。
      interface  FileAttributeView
      属性视图，它是与文件系统中的文件相关联的非不透明值的只读或可更新视图。
      interface  FileOwnerAttributeView
      支持阅读或更新文件所有者的文件属性视图。
      interface  FileStoreAttributeView
      属性视图是FileStore的属性的只读或可更新视图。
      interface  PosixFileAttributeView
      文件属性视图，提供通常与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件关联的文件属性视图。
      interface  UserDefinedFileAttributeView
      文件属性视图，提供文件的用户定义属性（有时称为 扩展属性）的视图。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.BasicFileAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.BasicFileAttributes

  • Packages that use BasicFileAttributes
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供商类。

    • Uses of BasicFileAttributes in java.nio.file

      Methods in java.nio.file with type parameters of type BasicFileAttributes
      Modifier and Type 方法 描述
      static <A extends BasicFileAttributes>
      A             		Files.readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      Methods in java.nio.file with parameters of type BasicFileAttributes
      Modifier and Type 方法 描述
      FileVisitResult FileVisitor.preVisitDirectory​(T dir, BasicFileAttributes attrs)
      在目录中的条目被访问之前调用一个目录。
      FileVisitResult SimpleFileVisitor.preVisitDirectory​(T dir, BasicFileAttributes attrs)
      在目录中的条目被访问之前调用一个目录。
      FileVisitResult FileVisitor.visitFile​(T file, BasicFileAttributes attrs)
      为目录中的文件调用。
      FileVisitResult SimpleFileVisitor.visitFile​(T file, BasicFileAttributes attrs)
      为目录中的文件调用。
      Method parameters in java.nio.file with type arguments of type BasicFileAttributes
      Modifier and Type 方法 描述
      static Stream<Path> Files.find​(Path start, int maxDepth, BiPredicate<Path,BasicFileAttributes> matcher, FileVisitOption... options)
      返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件来懒惰地填充 Path 。

    • Uses of BasicFileAttributes in java.nio.file.attribute

      Subinterfaces of BasicFileAttributes in java.nio.file.attribute
      Modifier and Type 接口 描述
      interface  DosFileAttributes
      与支持旧版“DOS”属性的文件系统中的文件相关联的文件属性。
      interface  PosixFileAttributes
      与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件相关联的文件属性。
      Methods in java.nio.file.attribute that return BasicFileAttributes
      Modifier and Type 方法 描述
      BasicFileAttributes BasicFileAttributeView.readAttributes​()
      读取大量操作的基本文件属性。

    • Uses of BasicFileAttributes in java.nio.file.spi

      Methods in java.nio.file.spi with type parameters of type BasicFileAttributes
      Modifier and Type 方法 描述
      abstract <A extends BasicFileAttributes>
      A             		FileSystemProvider.readAttributes​(Path path, Class<A> type, LinkOption... options)
      Reads a file's attributes as a bulk operation.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.BasicFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.BasicFileAttributeView

  • Packages that use BasicFileAttributeView
    软件包 描述
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of BasicFileAttributeView in java.nio.file.attribute

      Subinterfaces of BasicFileAttributeView in java.nio.file.attribute
      Modifier and Type 接口 描述
      interface  DosFileAttributeView
      提供传统“DOS”文件属性视图的文件属性视图。
      interface  PosixFileAttributeView
      文件属性视图，提供通常与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件关联的文件属性视图。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.DosFileAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.DosFileAttributes

  • Packages that use DosFileAttributes
    软件包 描述
    java.nio.file.attribute
    Interfaces and classes providing access to file and file system attributes.

    • Uses of DosFileAttributes in java.nio.file.attribute

      Methods in java.nio.file.attribute that return DosFileAttributes
      Modifier and Type | 方法 | 描述
      DosFileAttributes | DosFileAttributeView.readAttributes​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.DosFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.DosFileAttributeView

No usage of java.nio.file.attribute.DosFileAttributeView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.FileAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.FileAttribute

  • Packages that use FileAttribute
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供商类。

    • Uses of FileAttribute in java.nio.channels

      Methods in java.nio.channels with parameters of type FileAttribute
      Modifier and Type 方法 描述
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static FileChannel FileChannel.open​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回文件通道以访问该文件。

    • Uses of FileAttribute in java.nio.file

      Methods in java.nio.file with parameters of type FileAttribute
      Modifier and Type 方法 描述
      static Path Files.createDirectories​(Path dir, FileAttribute<?>... attrs)
      首先创建所有不存在的父目录来创建目录。
      static Path Files.createDirectory​(Path dir, FileAttribute<?>... attrs)
      创建一个新的目录。
      static Path Files.createFile​(Path path, FileAttribute<?>... attrs)
      创建一个新的和空的文件，如果该文件已存在失败。
      static Path Files.createSymbolicLink​(Path link, Path target, FileAttribute<?>... attrs)
      创建到目标的符号链接 （可选操作） 。
      static Path Files.createTempDirectory​(String prefix, FileAttribute<?>... attrs)
      在默认临时文件目录中创建一个新目录，使用给定的前缀生成其名称。
      static Path Files.createTempDirectory​(Path dir, String prefix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新目录，使用给定的前缀生成其名称。
      static Path Files.createTempFile​(String prefix, String suffix, FileAttribute<?>... attrs)
      在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。
      static Path Files.createTempFile​(Path dir, String prefix, String suffix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
      static SeekableByteChannel Files.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      SeekableByteChannel SecureDirectoryStream.newByteChannel​(T path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      在此目录中打开或创建一个文件，返回可访问的字节通道以访问该文件。

    • Uses of FileAttribute in java.nio.file.attribute

      Methods in java.nio.file.attribute that return FileAttribute
      Modifier and Type 方法 描述
      static FileAttribute<Set<PosixFilePermission>> PosixFilePermissions.asFileAttribute​(Set<PosixFilePermission> perms)
      创建一个FileAttribute ，封装给定文件权限的副本，适合传递给createFile或createDirectory的方法。

    • Uses of FileAttribute in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type FileAttribute
      Modifier and Type 方法 描述
      abstract void FileSystemProvider.createDirectory​(Path dir, FileAttribute<?>... attrs)
      创建一个新的目录。
      void FileSystemProvider.createSymbolicLink​(Path link, Path target, FileAttribute<?>... attrs)
      创建一个到目标的符号链接。
      AsynchronousFileChannel FileSystemProvider.newAsynchronousFileChannel​(Path path, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      abstract SeekableByteChannel FileSystemProvider.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      FileChannel FileSystemProvider.newFileChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回文件通道以访问该文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.FileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.FileAttributeView

  • Packages that use FileAttributeView
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。

    • Uses of FileAttributeView in java.nio.file

      Methods in java.nio.file with type parameters of type FileAttributeView
      Modifier and Type 方法 描述
      static <V extends FileAttributeView>
      V             		Files.getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
      <V extends FileAttributeView>
      V             		SecureDirectoryStream.getFileAttributeView​(Class<V> type)
      返回一个新的文件属性视图来访问此目录的文件属性。
      <V extends FileAttributeView>
      V             		SecureDirectoryStream.getFileAttributeView​(T path, Class<V> type, LinkOption... options)
      返回一个新的文件属性视图来访问此目录中文件的文件属性。
      Method parameters in java.nio.file with type arguments of type FileAttributeView
      Modifier and Type 方法 描述
      abstract boolean FileStore.supportsFileAttributeView​(Class<? extends FileAttributeView> type)
      告诉这个文件存储是否支持由给定文件属性视图标识的文件属性。

    • Uses of FileAttributeView in java.nio.file.attribute

      Subinterfaces of FileAttributeView in java.nio.file.attribute
      Modifier and Type 接口 描述
      interface  AclFileAttributeView
      支持读取或更新文件的访问控制列表（ACL）或文件所有者属性的文件属性视图。
      interface  BasicFileAttributeView
      文件属性视图，提供许多文件系统通用的 基本文件属性 集的视图。
      interface  DosFileAttributeView
      提供传统“DOS”文件属性视图的文件属性视图。
      interface  FileOwnerAttributeView
      支持阅读或更新文件所有者的文件属性视图。
      interface  PosixFileAttributeView
      文件属性视图，提供通常与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件关联的文件属性视图。
      interface  UserDefinedFileAttributeView
      文件属性视图，提供文件的用户定义属性（有时称为 扩展属性）的视图。

    • Uses of FileAttributeView in java.nio.file.spi

      Methods in java.nio.file.spi with type parameters of type FileAttributeView
      Modifier and Type 方法 描述
      abstract <V extends FileAttributeView>
      V             		FileSystemProvider.getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.FileOwnerAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.FileOwnerAttributeView

  • Packages that use FileOwnerAttributeView
    软件包 描述
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of FileOwnerAttributeView in java.nio.file.attribute

      Subinterfaces of FileOwnerAttributeView in java.nio.file.attribute
      Modifier and Type 接口 描述
      interface  AclFileAttributeView
      支持读取或更新文件的访问控制列表（ACL）或文件所有者属性的文件属性视图。
      interface  PosixFileAttributeView
      文件属性视图，提供通常与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件关联的文件属性视图。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.FileStoreAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.FileStoreAttributeView

  • Packages that use FileStoreAttributeView
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of FileStoreAttributeView in java.nio.file

      Methods in java.nio.file with type parameters of type FileStoreAttributeView
      Modifier and Type 方法 描述
      abstract <V extends FileStoreAttributeView>
      V             		FileStore.getFileStoreAttributeView​(Class<V> type)
      返回给定类型的 FileStoreAttributeView 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.GroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.GroupPrincipal

  • Packages that use GroupPrincipal
    软件包 描述
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of GroupPrincipal in java.nio.file.attribute

      Methods in java.nio.file.attribute that return GroupPrincipal
      Modifier and Type 方法 描述
      GroupPrincipal PosixFileAttributes.group​()
      返回该文件的组所有者。
      abstract GroupPrincipal UserPrincipalLookupService.lookupPrincipalByGroupName​(String group)
      按组名查找组主体。
      Methods in java.nio.file.attribute with parameters of type GroupPrincipal
      Modifier and Type 方法 描述
      void PosixFileAttributeView.setGroup​(GroupPrincipal group)
      更新文件组所有者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.PosixFileAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.PosixFileAttributes

  • Packages that use PosixFileAttributes
    软件包 描述
    java.nio.file.attribute
    Interfaces and classes providing access to file and file system attributes.

    • Uses of PosixFileAttributes in java.nio.file.attribute

      Methods in java.nio.file.attribute that return PosixFileAttributes
      Modifier and Type | 方法 | 描述
      PosixFileAttributes | PosixFileAttributeView.readAttributes​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.PosixFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.PosixFileAttributeView

No usage of java.nio.file.attribute.PosixFileAttributeView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.UserDefinedFileAttributeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.UserDefinedFileAttributeView

No usage of java.nio.file.attribute.UserDefinedFileAttributeView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.attribute.UserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.attribute.UserPrincipal

  • Packages that use UserPrincipal
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。

    • Uses of UserPrincipal in java.nio.file

      Methods in java.nio.file that return UserPrincipal
      Modifier and Type 方法 描述
      static UserPrincipal Files.getOwner​(Path path, LinkOption... options)
      返回文件的所有者。
      Methods in java.nio.file with parameters of type UserPrincipal
      Modifier and Type 方法 描述
      static Path Files.setOwner​(Path path, UserPrincipal owner)
      更新文件所有者。

    • Uses of UserPrincipal in java.nio.file.attribute

      Subinterfaces of UserPrincipal in java.nio.file.attribute
      Modifier and Type 接口 描述
      interface  GroupPrincipal
      A UserPrincipal表示 组身份 ，用于确定文件系统中对象的访问权限。
      Methods in java.nio.file.attribute that return UserPrincipal
      Modifier and Type 方法 描述
      UserPrincipal FileOwnerAttributeView.getOwner​()
      阅读文件所有者。
      abstract UserPrincipal UserPrincipalLookupService.lookupPrincipalByName​(String name)
      按名称查找用户主体。
      UserPrincipal PosixFileAttributes.owner​()
      返回文件的所有者。
      UserPrincipal AclEntry.principal​()
      返回主成分。
      Methods in java.nio.file.attribute with parameters of type UserPrincipal
      Modifier and Type 方法 描述
      void FileOwnerAttributeView.setOwner​(UserPrincipal owner)
      更新文件所有者。
      AclEntry.Builder AclEntry.Builder.setPrincipal​(UserPrincipal who)
      设置此构建器的主要组件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.AccessDeniedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.AccessDeniedException

No usage of java.nio.file.AccessDeniedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.AccessMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.AccessMode

  • Packages that use AccessMode
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。

    • Uses of AccessMode in java.nio.file

      Methods in java.nio.file that return AccessMode
      Modifier and Type 方法 描述
      static AccessMode AccessMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AccessMode[] AccessMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of AccessMode in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type AccessMode
      Modifier and Type 方法 描述
      abstract void FileSystemProvider.checkAccess​(Path path, AccessMode... modes)
      检查文件的存在，以及可选的可访问性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.AtomicMoveNotSupportedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.AtomicMoveNotSupportedException

No usage of java.nio.file.AtomicMoveNotSupportedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.ClosedDirectoryStreamException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.ClosedDirectoryStreamException

No usage of java.nio.file.ClosedDirectoryStreamException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.ClosedFileSystemException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.ClosedFileSystemException

No usage of java.nio.file.ClosedFileSystemException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.ClosedWatchServiceException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.ClosedWatchServiceException

No usage of java.nio.file.ClosedWatchServiceException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.DirectoryIteratorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.DirectoryIteratorException

No usage of java.nio.file.DirectoryIteratorException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.DirectoryNotEmptyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.DirectoryNotEmptyException

No usage of java.nio.file.DirectoryNotEmptyException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileAlreadyExistsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileAlreadyExistsException

No usage of java.nio.file.FileAlreadyExistsException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.Files (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.Files

No usage of java.nio.file.Files
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileStore

  • Packages that use FileStore
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。

    • Uses of FileStore in java.nio.file

      Methods in java.nio.file that return FileStore
      Modifier and Type 方法 描述
      static FileStore Files.getFileStore​(Path path)
      返回表示文件所在文件存储区的FileStore 。
      Methods in java.nio.file that return types with arguments of type FileStore
      Modifier and Type 方法 描述
      abstract Iterable<FileStore> FileSystem.getFileStores​()
      返回一个对象，以遍历底层文件存储。

    • Uses of FileStore in java.nio.file.spi

      Methods in java.nio.file.spi that return FileStore
      Modifier and Type 方法 描述
      abstract FileStore FileSystemProvider.getFileStore​(Path path)
      返回表示文件所在文件库的FileStore 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileSystem

  • Packages that use FileSystem
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。

    • Uses of FileSystem in java.nio.file

      Methods in java.nio.file that return FileSystem
      Modifier and Type 方法 描述
      static FileSystem FileSystems.getDefault​()
      返回默认值 FileSystem 。
      static FileSystem FileSystems.getFileSystem​(URI uri)
      返回对现有的 FileSystem的引用。
      FileSystem Path.getFileSystem​()
      返回创建此对象的文件系统。
      static FileSystem FileSystems.newFileSystem​(URI uri, Map<String,?> env)
      构造一个由URI标识的新文件系统
      static FileSystem FileSystems.newFileSystem​(URI uri, Map<String,?> env, ClassLoader loader)
      构造一个由URI标识的新文件系统
      static FileSystem FileSystems.newFileSystem​(Path path, ClassLoader loader)
      构造新的 FileSystem以访问文件的内容作为文件系统。

    • Uses of FileSystem in java.nio.file.spi

      Methods in java.nio.file.spi that return FileSystem
      Modifier and Type 方法 描述
      abstract FileSystem FileSystemProvider.getFileSystem​(URI uri)
      返回此提供商创建的现有 FileSystem 。
      abstract FileSystem FileSystemProvider.newFileSystem​(URI uri, Map<String,?> env)
      构造由URI标识的新的 FileSystem对象。
      FileSystem FileSystemProvider.newFileSystem​(Path path, Map<String,?> env)
      构造新的 FileSystem以访问文件的内容作为文件系统。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileSystemAlreadyExistsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileSystemAlreadyExistsException

No usage of java.nio.file.FileSystemAlreadyExistsException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileSystemException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileSystemException

  • Packages that use FileSystemException
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of FileSystemException in java.nio.file

      Subclasses of FileSystemException in java.nio.file
      Modifier and Type Class 描述
      class  AccessDeniedException
      文件系统操作被拒绝时引发的检查异常，通常是由于文件权限或其他访问检查。
      class  AtomicMoveNotSupportedException
      当文件不能作为原子文件系统操作移动时，检查的异常抛出。
      class  DirectoryNotEmptyException
      由于目录不为空，文件系统操作失败时抛出的检查异常。
      class  FileAlreadyExistsException
      尝试创建文件或目录并且该名称的文件已存在时，检查的异常抛出。
      class  FileSystemLoopException
      当遇到文件系统循环或循环时抛出的检查异常。
      class  NoSuchFileException
      当尝试访问不存在的文件时抛出检查的异常。
      class  NotDirectoryException
      当文件系统操作用于目录时，由于文件不是目录而导致失败的检查异常。
      class  NotLinkException
      由于文件不是符号链接，文件系统操作失败时抛出的检查异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileSystemLoopException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileSystemLoopException

No usage of java.nio.file.FileSystemLoopException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileSystemNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileSystemNotFoundException

No usage of java.nio.file.FileSystemNotFoundException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileSystems (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileSystems

No usage of java.nio.file.FileSystems
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileVisitOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileVisitOption

  • Packages that use FileVisitOption
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of FileVisitOption in java.nio.file

      Methods in java.nio.file that return FileVisitOption
      Modifier and Type 方法 描述
      static FileVisitOption FileVisitOption.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FileVisitOption[] FileVisitOption.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.nio.file with parameters of type FileVisitOption
      Modifier and Type 方法 描述
      static Stream<Path> Files.find​(Path start, int maxDepth, BiPredicate<Path,BasicFileAttributes> matcher, FileVisitOption... options)
      返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件来懒惰地填充 Path 。
      static Stream<Path> Files.walk​(Path start, int maxDepth, FileVisitOption... options)
      返回一个 Stream ，它是通过走根据给定的起始文件的文件树懒惰地填充 Path 。
      static Stream<Path> Files.walk​(Path start, FileVisitOption... options)
      返回一个 Stream ，它通过走出一个以给定的起始文件为根的文件树来延迟填充 Path 。
      Method parameters in java.nio.file with type arguments of type FileVisitOption
      Modifier and Type 方法 描述
      static Path Files.walkFileTree​(Path start, Set<FileVisitOption> options, int maxDepth, FileVisitor<? super Path> visitor)
      Walks a file tree.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.FileVisitResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.FileVisitResult

  • Packages that use FileVisitResult
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of FileVisitResult in java.nio.file

      Methods in java.nio.file that return FileVisitResult
      Modifier and Type 方法 描述
      FileVisitResult FileVisitor.postVisitDirectory​(T dir, IOException exc)
      在目录中的条目之后调用目录，并且已经访问了所有的后代。
      FileVisitResult SimpleFileVisitor.postVisitDirectory​(T dir, IOException exc)
      在目录中的条目之后调用目录，并且已经访问了所有的后代。
      FileVisitResult FileVisitor.preVisitDirectory​(T dir, BasicFileAttributes attrs)
      在目录中的条目被访问之前调用一个目录。
      FileVisitResult SimpleFileVisitor.preVisitDirectory​(T dir, BasicFileAttributes attrs)
      在目录中的条目被访问之前调用一个目录。
      static FileVisitResult FileVisitResult.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FileVisitResult[] FileVisitResult.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      FileVisitResult FileVisitor.visitFile​(T file, BasicFileAttributes attrs)
      为目录中的文件调用。
      FileVisitResult SimpleFileVisitor.visitFile​(T file, BasicFileAttributes attrs)
      为目录中的文件调用。
      FileVisitResult FileVisitor.visitFileFailed​(T file, IOException exc)
      为无法访问的文件调用。
      FileVisitResult SimpleFileVisitor.visitFileFailed​(T file, IOException exc)
      为无法访问的文件调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.InvalidPathException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.InvalidPathException

No usage of java.nio.file.InvalidPathException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.LinkOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.LinkOption

  • Packages that use LinkOption
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。

    • Uses of LinkOption in java.nio.file

      Methods in java.nio.file that return LinkOption
      Modifier and Type 方法 描述
      static LinkOption LinkOption.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static LinkOption[] LinkOption.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.nio.file with parameters of type LinkOption
      Modifier and Type 方法 描述
      static boolean Files.exists​(Path path, LinkOption... options)
      测试文件是否存在。
      static Object Files.getAttribute​(Path path, String attribute, LinkOption... options)
      读取文件属性的值。
      static <V extends FileAttributeView>
      V             		Files.getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
      <V extends FileAttributeView>
      V             		SecureDirectoryStream.getFileAttributeView​(T path, Class<V> type, LinkOption... options)
      返回一个新的文件属性视图来访问此目录中文件的文件属性。
      static FileTime Files.getLastModifiedTime​(Path path, LinkOption... options)
      返回文件的上次修改时间。
      static UserPrincipal Files.getOwner​(Path path, LinkOption... options)
      返回文件的所有者。
      static Set<PosixFilePermission> Files.getPosixFilePermissions​(Path path, LinkOption... options)
      返回文件的POSIX文件权限。
      static boolean Files.isDirectory​(Path path, LinkOption... options)
      测试文件是否是目录。
      static boolean Files.isRegularFile​(Path path, LinkOption... options)
      测试文件是否是具有不透明内容的常规文件。
      SecureDirectoryStream<T> SecureDirectoryStream.newDirectoryStream​(T path, LinkOption... options)
      打开由给定路径标识的目录，返回一个 SecureDirectoryStream以遍历目录中的条目。
      static boolean Files.notExists​(Path path, LinkOption... options)
      测试此路径所在的文件是否不存在。
      static <A extends BasicFileAttributes>
      A             		Files.readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      static Map<String,Object> Files.readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      static Path Files.setAttribute​(Path path, String attribute, Object value, LinkOption... options)
      设置文件属性的值。
      Path Path.toRealPath​(LinkOption... options)
      返回现有文件的 真实路径。

    • Uses of LinkOption in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type LinkOption
      Modifier and Type 方法 描述
      abstract <V extends FileAttributeView>
      V             		FileSystemProvider.getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
      abstract <A extends BasicFileAttributes>
      A             		FileSystemProvider.readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      abstract Map<String,Object> FileSystemProvider.readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      abstract void FileSystemProvider.setAttribute​(Path path, String attribute, Object value, LinkOption... options)
      设置文件属性的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.LinkPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.LinkPermission

No usage of java.nio.file.LinkPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.NoSuchFileException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.NoSuchFileException

No usage of java.nio.file.NoSuchFileException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.NotDirectoryException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.NotDirectoryException

No usage of java.nio.file.NotDirectoryException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.NotLinkException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.NotLinkException

No usage of java.nio.file.NotLinkException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.Paths (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.Paths

No usage of java.nio.file.Paths
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.ProviderMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.ProviderMismatchException

No usage of java.nio.file.ProviderMismatchException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.ProviderNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.ProviderNotFoundException

No usage of java.nio.file.ProviderNotFoundException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.ReadOnlyFileSystemException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.ReadOnlyFileSystemException

No usage of java.nio.file.ReadOnlyFileSystemException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.SimpleFileVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.SimpleFileVisitor

No usage of java.nio.file.SimpleFileVisitor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.StandardCopyOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.StandardCopyOption

  • Packages that use StandardCopyOption
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of StandardCopyOption in java.nio.file

      Methods in java.nio.file that return StandardCopyOption
      Modifier and Type 方法 描述
      static StandardCopyOption StandardCopyOption.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StandardCopyOption[] StandardCopyOption.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.StandardOpenOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.StandardOpenOption

  • Packages that use StandardOpenOption
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of StandardOpenOption in java.nio.file

      Methods in java.nio.file that return StandardOpenOption
      Modifier and Type 方法 描述
      static StandardOpenOption StandardOpenOption.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StandardOpenOption[] StandardOpenOption.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.StandardWatchEventKinds (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.StandardWatchEventKinds

No usage of java.nio.file.StandardWatchEventKinds
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.CopyOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.CopyOption

  • Packages that use CopyOption
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。

    • Uses of CopyOption in java.nio.file

      Classes in java.nio.file that implement CopyOption
      Modifier and Type Class 描述
      class  LinkOption
      定义如何处理符号链接的选项。
      class  StandardCopyOption
      定义标准复制选项。
      Methods in java.nio.file with parameters of type CopyOption
      Modifier and Type 方法 描述
      static long Files.copy​(InputStream in, Path target, CopyOption... options)
      将输入流中的所有字节复制到文件。
      static Path Files.copy​(Path source, Path target, CopyOption... options)
      将文件复制到目标文件。
      static Path Files.move​(Path source, Path target, CopyOption... options)
      将文件移动或重命名为目标文件。

    • Uses of CopyOption in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type CopyOption
      Modifier and Type 方法 描述
      abstract void FileSystemProvider.copy​(Path source, Path target, CopyOption... options)
      将文件复制到目标文件。
      abstract void FileSystemProvider.move​(Path source, Path target, CopyOption... options)
      将文件移动或重命名为目标文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.DirectoryStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.DirectoryStream

  • Packages that use DirectoryStream
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。

    • Uses of DirectoryStream in java.nio.file

      Subinterfaces of DirectoryStream in java.nio.file
      Modifier and Type 接口 描述
      interface  SecureDirectoryStream<T>
      A DirectoryStream ，它定义了相对于打开目录定位的文件的操作。
      Methods in java.nio.file that return DirectoryStream
      Modifier and Type 方法 描述
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir)
      打开一个目录，返回一个DirectoryStream来迭代目录中的所有条目。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, String glob)
      打开一个目录，返回一个DirectoryStream以遍历目录中的条目。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个DirectoryStream来迭代目录中的条目。

    • Uses of DirectoryStream in java.nio.file.spi

      Methods in java.nio.file.spi that return DirectoryStream
      Modifier and Type 方法 描述
      abstract DirectoryStream<Path> FileSystemProvider.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      Opens a directory, returning a DirectoryStream to iterate over the entries in the directory.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.DirectoryStream.Filter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.DirectoryStream.Filter

  • Packages that use DirectoryStream.Filter
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file软件包的服务提供程序类。

    • Uses of DirectoryStream.Filter in java.nio.file

      Methods in java.nio.file with parameters of type DirectoryStream.Filter
      Modifier and Type 方法 描述
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个DirectoryStream以遍历目录中的条目。

    • Uses of DirectoryStream.Filter in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type DirectoryStream.Filter
      Modifier and Type 方法 描述
      abstract DirectoryStream<Path> FileSystemProvider.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个 DirectoryStream来迭代目录中的条目。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.FileVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.FileVisitor

  • Packages that use FileVisitor
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of FileVisitor in java.nio.file

      Classes in java.nio.file that implement FileVisitor
      Modifier and Type Class 描述
      class  SimpleFileVisitor<T>
      具有默认行为的简单文件访问者访问所有文件并重新抛出I / O错误。
      Methods in java.nio.file with parameters of type FileVisitor
      Modifier and Type 方法 描述
      static Path Files.walkFileTree​(Path start, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path Files.walkFileTree​(Path start, Set<FileVisitOption> options, int maxDepth, FileVisitor<? super Path> visitor)
      走一个文件树。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.OpenOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.OpenOption

  • Packages that use OpenOption
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of OpenOption in java.nio.channels

      Methods in java.nio.channels with parameters of type OpenOption
      Modifier and Type 方法 描述
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, OpenOption... options)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static FileChannel FileChannel.open​(Path path, OpenOption... options)
      打开或创建文件，返回文件通道以访问该文件。
      Method parameters in java.nio.channels with type arguments of type OpenOption
      Modifier and Type 方法 描述
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static FileChannel FileChannel.open​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回文件通道以访问该文件。

    • Uses of OpenOption in java.nio.file

      Classes in java.nio.file that implement OpenOption
      Modifier and Type Class 描述
      class  LinkOption
      定义如何处理符号链接的选项。
      class  StandardOpenOption
      定义标准的开放选项。
      Methods in java.nio.file with parameters of type OpenOption
      Modifier and Type 方法 描述
      static BufferedWriter Files.newBufferedWriter​(Path path, Charset cs, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter ，可以用来以有效的方式将文本写入文件。
      static BufferedWriter Files.newBufferedWriter​(Path path, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter以高效的方式写入文件。
      static SeekableByteChannel Files.newByteChannel​(Path path, OpenOption... options)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      static InputStream Files.newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。
      static OutputStream Files.newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。
      static Path Files.write​(Path path, byte[] bytes, OpenOption... options)
      将字节写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, Charset cs, OpenOption... options)
      将文本行写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, OpenOption... options)
      将文本行写入文件。
      Method parameters in java.nio.file with type arguments of type OpenOption
      Modifier and Type 方法 描述
      static SeekableByteChannel Files.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      SeekableByteChannel SecureDirectoryStream.newByteChannel​(T path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      在此目录中打开或创建一个文件，返回可访问的字节通道以访问该文件。

    • Uses of OpenOption in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type OpenOption
      Modifier and Type 方法 描述
      InputStream FileSystemProvider.newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。
      OutputStream FileSystemProvider.newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。
      Method parameters in java.nio.file.spi with type arguments of type OpenOption
      Modifier and Type 方法 描述
      AsynchronousFileChannel FileSystemProvider.newAsynchronousFileChannel​(Path path, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      abstract SeekableByteChannel FileSystemProvider.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      FileChannel FileSystemProvider.newFileChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回文件通道以访问该文件。

    • Uses of OpenOption in jdk.incubator.http

      Methods in jdk.incubator.http with parameters of type OpenOption
      Modifier and Type 方法 描述
      static HttpResponse.BodyHandler<Path> HttpResponse.BodyHandler.asFile​(Path file, OpenOption... openOptions)
      返回一个BodyHandler<Path> ，返回一个从 <Path>获得的BodyProcessor <Path> 。
      static HttpResponse.BodyProcessor<Path> HttpResponse.BodyProcessor.asFile​(Path file, OpenOption... openOptions)
      返回一个 BodyProcessor ，它将响应体存储在使用给定选项和名称打开的文件中。
      static HttpResponse.BodyHandler<Path> HttpResponse.BodyHandler.asFileDownload​(Path directory, OpenOption... openOptions)
      返回一个BodyHandler<Path> ，返回一个BodyProcessor < Path >其中指定了下载目录，但文件名是从Content-Disposition响应头获取的。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.Path (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.Path

  • Packages that use Path
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file软件包的服务提供程序类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。

    • Uses of Path in java.io

      Methods in java.io that return Path
      Modifier and Type 方法 描述
      Path File.toPath​()
      返回从该抽象路径构造的一个java.nio.file.Path对象。

    • Uses of Path in java.lang.module

      Methods in java.lang.module with parameters of type Path
      Modifier and Type 方法 描述
      static ModuleFinder ModuleFinder.of​(Path... entries)
      返回通过搜索一系列目录和/或打包模块来定位文件系统上的模块的模块查找器。

    • Uses of Path in java.nio.channels

      Methods in java.nio.channels with parameters of type Path
      Modifier and Type 方法 描述
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, OpenOption... options)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static FileChannel FileChannel.open​(Path path, OpenOption... options)
      打开或创建文件，返回文件通道以访问该文件。
      static FileChannel FileChannel.open​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回文件通道以访问该文件。

    • Uses of Path in java.nio.file

      Fields in java.nio.file with type parameters of type Path
      Modifier and Type Field 描述
      static WatchEvent.Kind<Path> StandardWatchEventKinds.ENTRY_CREATE
      创建目录条目。
      static WatchEvent.Kind<Path> StandardWatchEventKinds.ENTRY_DELETE
      目录条目已删除。
      static WatchEvent.Kind<Path> StandardWatchEventKinds.ENTRY_MODIFY
      目录条目修改。
      Methods in java.nio.file that return Path
      Modifier and Type 方法 描述
      static Path Files.copy​(Path source, Path target, CopyOption... options)
      将文件复制到目标文件。
      static Path Files.createDirectories​(Path dir, FileAttribute<?>... attrs)
      首先创建所有不存在的父目录来创建目录。
      static Path Files.createDirectory​(Path dir, FileAttribute<?>... attrs)
      创建一个新的目录。
      static Path Files.createFile​(Path path, FileAttribute<?>... attrs)
      创建一个新的和空的文件，如果该文件已存在失败。
      static Path Files.createLink​(Path link, Path existing)
      为现有文件创建新的链接（目录条目） （可选操作） 。
      static Path Files.createSymbolicLink​(Path link, Path target, FileAttribute<?>... attrs)
      创建到目标的符号链接 （可选操作） 。
      static Path Files.createTempDirectory​(String prefix, FileAttribute<?>... attrs)
      在默认临时文件目录中创建一个新目录，使用给定的前缀生成其名称。
      static Path Files.createTempDirectory​(Path dir, String prefix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新目录，使用给定的前缀生成其名称。
      static Path Files.createTempFile​(String prefix, String suffix, FileAttribute<?>... attrs)
      在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。
      static Path Files.createTempFile​(Path dir, String prefix, String suffix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
      static Path Paths.get​(String first, String... more)
      将路径字符串或 Path路径字符串连接起来的字符串序列转换为 Path 。
      static Path Paths.get​(URI uri)
      将给定的URI转换为Path对象。
      Path Path.getFileName​()
      将此路径表示的文件或目录的名称作为 Path对象返回。
      Path Path.getName​(int index)
      将该路径的名称元素作为 Path对象返回。
      Path Path.getParent​()
      返回 父路径 ，如果此路径没有 父项 ，则返回 null 。
      abstract Path FileSystem.getPath​(String first, String... more)
      将路径字符串或将连接到路径字符串的字符串序列转换为 Path 。
      Path Path.getRoot​()
      返回此路径的根组分作为 Path对象，或 null如果该路径不具有根组件。
      static Path Files.move​(Path source, Path target, CopyOption... options)
      将文件移动或重命名为目标文件。
      Path Path.normalize​()
      返回一个路径，该路径是冗余名称元素的消除。
      static Path Files.readSymbolicLink​(Path link)
      读取符号链接的目标 （可选操作） 。
      Path Path.relativize​(Path other)
      构造此路径和给定路径之间的相对路径。
      default Path Path.resolve​(String other)
      一个给定的路径字符串转换为 Path并解析它针对此 Path在完全按规定的方式 resolve方法。
      Path Path.resolve​(Path other)
      根据这条路径解决给定的路径。
      default Path Path.resolveSibling​(String other)
      将给定的路径字符串转换为 Path并按照 resolveSibling方法指定的方式将其解析为该路径的 parent路径。
      default Path Path.resolveSibling​(Path other)
      根据此路径的 parent路径解析给定路径。
      static Path Files.setAttribute​(Path path, String attribute, Object value, LinkOption... options)
      设置文件属性的值。
      static Path Files.setLastModifiedTime​(Path path, FileTime time)
      更新文件上次修改的时间属性。
      static Path Files.setOwner​(Path path, UserPrincipal owner)
      更新文件所有者。
      static Path Files.setPosixFilePermissions​(Path path, Set<PosixFilePermission> perms)
      设置文件的POSIX权限。
      Path Path.subpath​(int beginIndex, int endIndex)
      返回一个相对的 Path ，它是该路径的名称元素的子序列。
      Path Path.toAbsolutePath​()
      返回表示此路径的绝对路径的 Path对象。
      Path Path.toRealPath​(LinkOption... options)
      返回现有文件的 真实路径。
      static Path Files.walkFileTree​(Path start, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path Files.walkFileTree​(Path start, Set<FileVisitOption> options, int maxDepth, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path Files.write​(Path path, byte[] bytes, OpenOption... options)
      将字节写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, Charset cs, OpenOption... options)
      将文本行写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, OpenOption... options)
      将文本行写入文件。
      Methods in java.nio.file that return types with arguments of type Path
      Modifier and Type 方法 描述
      static Stream<Path> Files.find​(Path start, int maxDepth, BiPredicate<Path,BasicFileAttributes> matcher, FileVisitOption... options)
      返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件而惰性地填充 Path 。
      abstract Iterable<Path> FileSystem.getRootDirectories​()
      返回一个对象来遍历根目录的路径。
      default Iterator<Path> Path.iterator​()
      返回此路径的名称元素的迭代器。
      static Stream<Path> Files.list​(Path dir)
      返回一个懒惰的 Stream ，其中的元素是目录中的条目。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir)
      打开一个目录，返回一个DirectoryStream，以遍历目录中的所有条目。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, String glob)
      打开一个目录，返回一个DirectoryStream来迭代目录中的条目。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个DirectoryStream来迭代目录中的条目。
      static Stream<Path> Files.walk​(Path start, int maxDepth, FileVisitOption... options)
      返回一个 Stream ，它通过走在一个给定的起始文件的根文件树上， Path 。
      static Stream<Path> Files.walk​(Path start, FileVisitOption... options)
      返回一个 Stream ，它通过走根据给定起始文件的文件树而惰性地填充 Path 。
      Methods in java.nio.file with parameters of type Path
      Modifier and Type 方法 描述
      int Path.compareTo​(Path other)
      比较两个抽象的路径词典。
      static long Files.copy​(InputStream in, Path target, CopyOption... options)
      将输入流中的所有字节复制到文件。
      static long Files.copy​(Path source, OutputStream out)
      将文件中的所有字节复制到输出流。
      static Path Files.copy​(Path source, Path target, CopyOption... options)
      将文件复制到目标文件。
      static Path Files.createDirectories​(Path dir, FileAttribute<?>... attrs)
      首先创建所有不存在的父目录来创建目录。
      static Path Files.createDirectory​(Path dir, FileAttribute<?>... attrs)
      创建一个新的目录。
      static Path Files.createFile​(Path path, FileAttribute<?>... attrs)
      创建一个新的和空的文件，如果该文件已存在失败。
      static Path Files.createLink​(Path link, Path existing)
      为现有文件创建新的链接（目录条目） （可选操作） 。
      static Path Files.createSymbolicLink​(Path link, Path target, FileAttribute<?>... attrs)
      创建到目标的符号链接 （可选操作） 。
      static Path Files.createTempDirectory​(Path dir, String prefix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新目录，使用给定的前缀生成其名称。
      static Path Files.createTempFile​(Path dir, String prefix, String suffix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
      static void Files.delete​(Path path)
      删除文件。
      static boolean Files.deleteIfExists​(Path path)
      删除文件（如果存在）。
      boolean Path.endsWith​(Path other)
      测试此路径是否以给定的路径结束。
      static boolean Files.exists​(Path path, LinkOption... options)
      测试文件是否存在。
      static Stream<Path> Files.find​(Path start, int maxDepth, BiPredicate<Path,BasicFileAttributes> matcher, FileVisitOption... options)
      返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件而惰性地填充 Path 。
      static Object Files.getAttribute​(Path path, String attribute, LinkOption... options)
      读取文件属性的值。
      static <V extends FileAttributeView>
      V             		Files.getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
      static FileStore Files.getFileStore​(Path path)
      返回表示文件所在文件存储区的FileStore 。
      static FileTime Files.getLastModifiedTime​(Path path, LinkOption... options)
      返回文件的上次修改时间。
      static UserPrincipal Files.getOwner​(Path path, LinkOption... options)
      返回文件的所有者。
      static Set<PosixFilePermission> Files.getPosixFilePermissions​(Path path, LinkOption... options)
      返回文件的POSIX文件权限。
      static boolean Files.isDirectory​(Path path, LinkOption... options)
      测试文件是否是目录。
      static boolean Files.isExecutable​(Path path)
      测试文件是否可执行。
      static boolean Files.isHidden​(Path path)
      告知文件是否被 隐藏 。
      static boolean Files.isReadable​(Path path)
      测试文件是否可读。
      static boolean Files.isRegularFile​(Path path, LinkOption... options)
      测试文件是否是具有不透明内容的常规文件。
      static boolean Files.isSameFile​(Path path, Path path2)
      测试两个路径是否找到相同的文件。
      static boolean Files.isSymbolicLink​(Path path)
      测试文件是否是符号链接。
      static boolean Files.isWritable​(Path path)
      测试文件是否可写。
      static Stream<String> Files.lines​(Path path)
      从文件中读取所有行作为 Stream 。
      static Stream<String> Files.lines​(Path path, Charset cs)
      从文件中读取所有行作为 Stream 。
      static Stream<Path> Files.list​(Path dir)
      返回一个懒惰的 Stream ，其中的元素是目录中的条目。
      boolean PathMatcher.matches​(Path path)
      告诉给定路径是否匹配该匹配器的模式。
      static Path Files.move​(Path source, Path target, CopyOption... options)
      将文件移动或重命名为目标文件。
      static BufferedReader Files.newBufferedReader​(Path path)
      打开一个文件进行阅读，返回一个 BufferedReader以高效的方式从文件读取文本。
      static BufferedReader Files.newBufferedReader​(Path path, Charset cs)
      打开一个文件进行阅读，返回一个 BufferedReader ，可用于以有效的方式从文件读取文本。
      static BufferedWriter Files.newBufferedWriter​(Path path, Charset cs, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter ，可以用来以有效的方式将文本写入文件。
      static BufferedWriter Files.newBufferedWriter​(Path path, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter以高效的方式写入文件。
      static SeekableByteChannel Files.newByteChannel​(Path path, OpenOption... options)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      static SeekableByteChannel Files.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir)
      打开一个目录，返回一个DirectoryStream以遍历目录中的所有条目。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, String glob)
      打开一个目录，返回一个DirectoryStream来迭代目录中的条目。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个DirectoryStream来迭代目录中的条目。
      static FileSystem FileSystems.newFileSystem​(Path path, ClassLoader loader)
      构造新的 FileSystem以访问文件的内容作为文件系统。
      static InputStream Files.newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。
      static OutputStream Files.newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。
      static boolean Files.notExists​(Path path, LinkOption... options)
      测试此路径所在的文件是否不存在。
      static String Files.probeContentType​(Path path)
      探测文件的内容类型。
      static byte[] Files.readAllBytes​(Path path)
      读取文件中的所有字节。
      static List<String> Files.readAllLines​(Path path)
      从文件中读取所有行。
      static List<String> Files.readAllLines​(Path path, Charset cs)
      从文件中读取所有行。
      static <A extends BasicFileAttributes>
      A             		Files.readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      static Map<String,Object> Files.readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      static Path Files.readSymbolicLink​(Path link)
      读取符号链接的目标 （可选操作） 。
      Path Path.relativize​(Path other)
      构造此路径和给定路径之间的相对路径。
      Path Path.resolve​(Path other)
      根据这条路径解决给定的路径。
      default Path Path.resolveSibling​(Path other)
      根据此路径的 parent路径解决给定的路径。
      static Path Files.setAttribute​(Path path, String attribute, Object value, LinkOption... options)
      设置文件属性的值。
      static Path Files.setLastModifiedTime​(Path path, FileTime time)
      更新文件上次修改的时间属性。
      static Path Files.setOwner​(Path path, UserPrincipal owner)
      更新文件所有者。
      static Path Files.setPosixFilePermissions​(Path path, Set<PosixFilePermission> perms)
      设置文件的POSIX权限。
      static long Files.size​(Path path)
      返回文件的大小（以字节为单位）。
      boolean Path.startsWith​(Path other)
      测试此路径是否以给定的路径开始。
      static Stream<Path> Files.walk​(Path start, int maxDepth, FileVisitOption... options)
      返回一个 Stream ，它是通过走根据给定的起始文件的文件树懒惰地填充 Path 。
      static Stream<Path> Files.walk​(Path start, FileVisitOption... options)
      返回一个 Stream ，它是通过走根据给定的起始文件的文件树懒惰地填充 Path 。
      static Path Files.walkFileTree​(Path start, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path Files.walkFileTree​(Path start, Set<FileVisitOption> options, int maxDepth, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path Files.write​(Path path, byte[] bytes, OpenOption... options)
      将字节写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, Charset cs, OpenOption... options)
      将文本行写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, OpenOption... options)
      将文本行写入文件。
      Method parameters in java.nio.file with type arguments of type Path
      Modifier and Type 方法 描述
      static Stream<Path> Files.find​(Path start, int maxDepth, BiPredicate<Path,BasicFileAttributes> matcher, FileVisitOption... options)
      返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件来懒惰地填充 Path 。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个DirectoryStream以遍历目录中的条目。
      static Path Files.walkFileTree​(Path start, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path Files.walkFileTree​(Path start, Set<FileVisitOption> options, int maxDepth, FileVisitor<? super Path> visitor)
      走一个文件树。

    • Uses of Path in java.nio.file.spi

      Methods in java.nio.file.spi that return Path
      Modifier and Type 方法 描述
      abstract Path FileSystemProvider.getPath​(URI uri)
      通过转换给定的URI来返回一个Path对象。
      Path FileSystemProvider.readSymbolicLink​(Path link)
      读取符号链接的目标。
      Methods in java.nio.file.spi that return types with arguments of type Path
      Modifier and Type 方法 描述
      abstract DirectoryStream<Path> FileSystemProvider.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个 DirectoryStream以遍历目录中的条目。
      Methods in java.nio.file.spi with parameters of type Path
      Modifier and Type 方法 描述
      abstract void FileSystemProvider.checkAccess​(Path path, AccessMode... modes)
      检查文件的存在，以及可选的可访问性。
      abstract void FileSystemProvider.copy​(Path source, Path target, CopyOption... options)
      将文件复制到目标文件。
      abstract void FileSystemProvider.createDirectory​(Path dir, FileAttribute<?>... attrs)
      创建一个新的目录。
      void FileSystemProvider.createLink​(Path link, Path existing)
      为现有文件创建一个新的链接（目录条目）。
      void FileSystemProvider.createSymbolicLink​(Path link, Path target, FileAttribute<?>... attrs)
      创建一个到目标的符号链接。
      abstract void FileSystemProvider.delete​(Path path)
      删除文件。
      boolean FileSystemProvider.deleteIfExists​(Path path)
      删除文件（如果存在）。
      abstract <V extends FileAttributeView>
      V             		FileSystemProvider.getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
      abstract FileStore FileSystemProvider.getFileStore​(Path path)
      返回表示文件所在文件存储区的FileStore 。
      abstract boolean FileSystemProvider.isHidden​(Path path)
      告知文件是否被 隐藏 。
      abstract boolean FileSystemProvider.isSameFile​(Path path, Path path2)
      测试两个路径是否找到相同的文件。
      abstract void FileSystemProvider.move​(Path source, Path target, CopyOption... options)
      将文件移动或重命名为目标文件。
      AsynchronousFileChannel FileSystemProvider.newAsynchronousFileChannel​(Path path, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      abstract SeekableByteChannel FileSystemProvider.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      abstract DirectoryStream<Path> FileSystemProvider.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个 DirectoryStream以遍历目录中的条目。
      FileChannel FileSystemProvider.newFileChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回文件通道以访问该文件。
      FileSystem FileSystemProvider.newFileSystem​(Path path, Map<String,?> env)
      构造一个新的 FileSystem作为文件系统访问文件的内容。
      InputStream FileSystemProvider.newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。
      OutputStream FileSystemProvider.newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。
      abstract String FileTypeDetector.probeContentType​(Path path)
      探测给定的文件来猜测其内容类型。
      abstract <A extends BasicFileAttributes>
      A             		FileSystemProvider.readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      abstract Map<String,Object> FileSystemProvider.readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      Path FileSystemProvider.readSymbolicLink​(Path link)
      读取符号链接的目标。
      abstract void FileSystemProvider.setAttribute​(Path path, String attribute, Object value, LinkOption... options)
      设置文件属性的值。
      Method parameters in java.nio.file.spi with type arguments of type Path
      Modifier and Type 方法 描述
      abstract DirectoryStream<Path> FileSystemProvider.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个 DirectoryStream来迭代目录中的条目。

    • Uses of Path in java.util

      Constructors in java.util with parameters of type Path
      Constructor 描述
      Scanner​(Path source)
      构造一个新的 Scanner ，产生从指定文件扫描的值。
      Scanner​(Path source, String charsetName)
      构造一个新的 Scanner ，产生从指定文件扫描的值。

    • Uses of Path in javax.tools

      Methods in javax.tools that return Path
      Modifier and Type 方法 描述
      default Path StandardJavaFileManager.asPath​(FileObject file)
      返回此文件对象下的路径（如果有）（可选操作）。
      Path StandardJavaFileManager.PathFactory.getPath​(String first, String... more)
      将路径字符串或将路径字符串连接时的字符串序列转换为路径。
      Methods in javax.tools that return types with arguments of type Path
      Modifier and Type 方法 描述
      default Iterable<? extends Path> StandardJavaFileManager.getLocationAsPaths​(JavaFileManager.Location location)
      返回与给定位置相关联的搜索路径。
      Methods in javax.tools with parameters of type Path
      Modifier and Type 方法 描述
      default Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects​(Path... paths)
      返回表示给定路径的文件对象。
      Method parameters in javax.tools with type arguments of type Path
      Modifier and Type 方法 描述
      default Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromPaths​(Iterable<? extends Path> paths)
      返回表示给定路径的文件对象。
      default void StandardJavaFileManager.setLocationForModule​(JavaFileManager.Location location, String moduleName, Collection<? extends Path> paths)
      将给定的搜索路径与给定的模块和位置相关联，该模块和位置必须是面向模块或输出位置。
      default void StandardJavaFileManager.setLocationFromPaths​(JavaFileManager.Location location, Collection<? extends Path> paths)
      将给定的搜索路径与给定位置相关联。

    • Uses of Path in jdk.incubator.http

      Methods in jdk.incubator.http that return types with arguments of type Path
      Modifier and Type 方法 描述
      static HttpResponse.BodyHandler<Path> HttpResponse.BodyHandler.asFile​(Path file)
      返回一个BodyHandler<Path> ，返回一个从 <Path>获得的BodyProcessor <Path> 。
      static HttpResponse.BodyHandler<Path> HttpResponse.BodyHandler.asFile​(Path file, OpenOption... openOptions)
      返回一个BodyHandler<Path> ，返回一个从 <Path>获得的BodyProcessor <Path> 。
      static HttpResponse.BodyProcessor<Path> HttpResponse.BodyProcessor.asFile​(Path file)
      返回一个 BodyProcessor ，它将响应正文放在使用给定名称打开的文件中。
      static HttpResponse.BodyProcessor<Path> HttpResponse.BodyProcessor.asFile​(Path file, OpenOption... openOptions)
      返回一个 BodyProcessor ，它将响应体存储在使用给定选项和名称打开的文件中。
      static HttpResponse.BodyHandler<Path> HttpResponse.BodyHandler.asFileDownload​(Path directory, OpenOption... openOptions)
      返回一个BodyHandler<Path> ，返回一个指定了下载目录的BodyProcessor < Path >，但文件名是从Content-Disposition响应头获取的。
      Methods in jdk.incubator.http with parameters of type Path
      Modifier and Type 方法 描述
      static HttpResponse.BodyHandler<Path> HttpResponse.BodyHandler.asFile​(Path file)
      返回一个BodyHandler<Path> ，返回一个从 <Path>获得的BodyProcessor <Path> 。
      static HttpResponse.BodyHandler<Path> HttpResponse.BodyHandler.asFile​(Path file, OpenOption... openOptions)
      返回一个BodyHandler<Path> ，它返回一个从 <Path>获得的BodyProcessor <Path> 。
      static HttpResponse.BodyProcessor<Path> HttpResponse.BodyProcessor.asFile​(Path file)
      返回一个 BodyProcessor ，它将响应正文放在使用给定名称打开的文件中。
      static HttpResponse.BodyProcessor<Path> HttpResponse.BodyProcessor.asFile​(Path file, OpenOption... openOptions)
      返回一个 BodyProcessor ，它将响应正文放在使用给定选项和名称打开的文件中。
      static HttpResponse.BodyHandler<Path> HttpResponse.BodyHandler.asFileDownload​(Path directory, OpenOption... openOptions)
      返回一个BodyHandler<Path> ，返回一个BodyProcessor < Path >其中指定了下载目录，但文件名是从Content-Disposition响应头获取的。
      static HttpRequest.BodyProcessor HttpRequest.BodyProcessor.fromFile​(Path path)
      从文件的内容获取数据的请求体处理器。

    • Uses of Path in jdk.nashorn.api.tree

      Methods in jdk.nashorn.api.tree with parameters of type Path
      Modifier and Type 方法 描述
      CompilationUnitTree Parser.parse​(Path path, DiagnosticListener listener)
      解析源路径并返回编译单元树
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.PathMatcher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.PathMatcher

  • Packages that use PathMatcher
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of PathMatcher in java.nio.file

      Methods in java.nio.file that return PathMatcher
      Modifier and Type 方法 描述
      abstract PathMatcher FileSystem.getPathMatcher​(String syntaxAndPattern)
      返回一个PathMatcher ，通过解释给定的模式，对Path对象的String表示执行匹配操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.SecureDirectoryStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.SecureDirectoryStream

  • Packages that use SecureDirectoryStream
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of SecureDirectoryStream in java.nio.file

      Methods in java.nio.file that return SecureDirectoryStream
      Modifier and Type 方法 描述
      SecureDirectoryStream<T> SecureDirectoryStream.newDirectoryStream​(T path, LinkOption... options)
      打开由给定路径标识的目录，返回一个 SecureDirectoryStream以遍历目录中的条目。
      Methods in java.nio.file with parameters of type SecureDirectoryStream
      Modifier and Type 方法 描述
      void SecureDirectoryStream.move​(T srcpath, SecureDirectoryStream<T> targetdir, T targetpath)
      将文件从该目录移动到另一个目录。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.Watchable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.Watchable

  • Packages that use Watchable
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of Watchable in java.nio.file

      Subinterfaces of Watchable in java.nio.file
      Modifier and Type 接口 描述
      interface  Path
      可用于在文件系统中定位文件的对象。
      Methods in java.nio.file that return Watchable
      Modifier and Type 方法 描述
      Watchable WatchKey.watchable​()
      返回创建该观察键的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.WatchEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.WatchEvent

  • Packages that use WatchEvent
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of WatchEvent in java.nio.file

      Methods in java.nio.file that return types with arguments of type WatchEvent
      Modifier and Type 方法 描述
      List<WatchEvent<?>> WatchKey.pollEvents​()
      检索并删除此watch键的所有待处理事件，并返回 List到的事件的 List 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.WatchEvent.Kind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.WatchEvent.Kind

  • Packages that use WatchEvent.Kind
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of WatchEvent.Kind in java.nio.file

      Fields in java.nio.file declared as WatchEvent.Kind
      Modifier and Type Field 描述
      static WatchEvent.Kind<Path> StandardWatchEventKinds.ENTRY_CREATE
      创建目录条目。
      static WatchEvent.Kind<Path> StandardWatchEventKinds.ENTRY_DELETE
      目录条目已删除。
      static WatchEvent.Kind<Path> StandardWatchEventKinds.ENTRY_MODIFY
      目录条目修改。
      static WatchEvent.Kind<Object> StandardWatchEventKinds.OVERFLOW
      一个特殊事件，表明事件可能已丢失或丢弃。
      Methods in java.nio.file that return WatchEvent.Kind
      Modifier and Type 方法 描述
      WatchEvent.Kind<T> WatchEvent.kind​()
      返回事件类型。
      Methods in java.nio.file with parameters of type WatchEvent.Kind
      Modifier and Type 方法 描述
      default WatchKey Path.register​(WatchService watcher, WatchEvent.Kind<?>... events)
      使用手表服务注册此路径所在的文件。
      WatchKey Path.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      使用手表服务注册此路径所在的文件。
      WatchKey Watchable.register​(WatchService watcher, WatchEvent.Kind<?>... events)
      用手表服务注册一个对象。
      WatchKey Watchable.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      用手表服务注册一个对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.WatchEvent.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.WatchEvent.Modifier

  • Packages that use WatchEvent.Modifier
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of WatchEvent.Modifier in java.nio.file

      Methods in java.nio.file with parameters of type WatchEvent.Modifier
      Modifier and Type 方法 描述
      WatchKey Path.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      使用手表服务注册此路径所在的文件。
      WatchKey Watchable.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      用手表服务注册一个对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.WatchKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.WatchKey

  • Packages that use WatchKey
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of WatchKey in java.nio.file

      Methods in java.nio.file that return WatchKey
      Modifier and Type 方法 描述
      WatchKey WatchService.poll​()
      检索并删除下一个watch键，如果没有，则 null 。
      WatchKey WatchService.poll​(long timeout, TimeUnit unit)
      检索并删除下一个watch键，如果还没有，则等待必要时直到指定的等待时间。
      default WatchKey Path.register​(WatchService watcher, WatchEvent.Kind<?>... events)
      使用手表服务注册此路径所在的文件。
      WatchKey Path.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      使用手表服务注册此路径所在的文件。
      WatchKey Watchable.register​(WatchService watcher, WatchEvent.Kind<?>... events)
      用手表服务注册一个对象。
      WatchKey Watchable.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      用手表服务注册一个对象。
      WatchKey WatchService.take​()
      检索并删除下一个Watch键，等待是否还没有。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.nio.file.WatchService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.nio.file.WatchService

  • Packages that use WatchService
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of WatchService in java.nio.file

      Methods in java.nio.file that return WatchService
      Modifier and Type 方法 描述
      abstract WatchService FileSystem.newWatchService​()
      构造新的WatchService （可选操作） 。
      Methods in java.nio.file with parameters of type WatchService
      Modifier and Type 方法 描述
      default WatchKey Path.register​(WatchService watcher, WatchEvent.Kind<?>... events)
      使用手表服务注册此路径所在的文件。
      WatchKey Path.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      使用手表服务注册此路径所在的文件。
      WatchKey Watchable.register​(WatchService watcher, WatchEvent.Kind<?>... events)
      用手表服务注册一个对象。
      WatchKey Watchable.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      用手表服务注册一个对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


FileSystemProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.spi

Class FileSystemProvider

  • java.lang.Object
    • java.nio.file.spi.FileSystemProvider

  • public abstract class FileSystemProvider
extends Object
    文件系统的服务提供者类。 Files类定义的方法通常会委托给该类的一个实例。

    文件系统提供程序是实现由该类定义的抽象方法的该类的具体实现。 提供者由URI识别scheme 。 默认提供程序由URI方案“文件”标识。 它创建了可以访问Java虚拟机可访问的文件系统的FileSystem 。 FileSystems类定义文件系统提供程序的位置和加载方式。 默认提供程序通常是系统默认提供程序，但如果系统属性java.nio.file.spi.DefaultFileSystemProvider为java.nio.file.spi.DefaultFileSystemProvider则可能会被覆盖。 在这种情况下，提供程序具有一个参数构造函数，其形式参数类型为FileSystemProvider 。 所有其他提供程序都有一个零参数构造函数来初始化提供程序。

    提供商是一个或多个FileSystem实例的工厂。 每个文件系统由URI标识，其URI的方案与提供商的scheme相匹配。 例如，默认文件系统由URI "file:///" 。 例如，基于存储器的文件系统可以由诸如"memory:///?name=logfs"的URI来标识。 可以使用newFileSystem方法来创建文件系统，并且可以使用getFileSystem方法来获取对由提供者创建的现有文件系统的引用。 如果提供商是单个文件系统的工厂，那么如果在提供程序初始化时创建文件系统，或稍后在调用newFileSystem方法时，则依赖于提供程序。 在默认提供程序的情况下， FileSystem是在提供程序初始化时创建的。

    此类中的所有方法都可以安全地被多个并发线程使用。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FileSystemProvider​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void checkAccess​(Path path, AccessMode... modes)
      检查文件的存在，以及可选的可访问性。
      abstract void copy​(Path source, Path target, CopyOption... options)
      将文件复制到目标文件。
      abstract void createDirectory​(Path dir, FileAttribute<?>... attrs)
      创建一个新的目录。
      void createLink​(Path link, Path existing)
      为现有文件创建一个新的链接（目录条目）。
      void createSymbolicLink​(Path link, Path target, FileAttribute<?>... attrs)
      创建一个到目标的符号链接。
      abstract void delete​(Path path)
      删除文件。
      boolean deleteIfExists​(Path path)
      删除文件（如果存在）。
      abstract <V extends FileAttributeView>
      V             		getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
      abstract FileStore getFileStore​(Path path)
      返回表示文件所在文件存储区的FileStore 。
      abstract FileSystem getFileSystem​(URI uri)
      返回此提供者创建的现有 FileSystem 。
      abstract Path getPath​(URI uri)
      通过转换给定的URI返回一个Path对象。
      abstract String getScheme​()
      返回标识此提供程序的URI方案。
      static List<FileSystemProvider> installedProviders​()
      返回已安装文件系统提供程序的列表。
      abstract boolean isHidden​(Path path)
      告知文件是否被 隐藏 。
      abstract boolean isSameFile​(Path path, Path path2)
      测试两个路径是否找到相同的文件。
      abstract void move​(Path source, Path target, CopyOption... options)
      将文件移动或重命名为目标文件。
      AsynchronousFileChannel newAsynchronousFileChannel​(Path path, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      abstract SeekableByteChannel newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      abstract DirectoryStream<Path> newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个 DirectoryStream以遍历目录中的条目。
      FileChannel newFileChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回文件通道以访问该文件。
      abstract FileSystem newFileSystem​(URI uri, Map<String,?> env)
      构造由URI标识的新的 FileSystem对象。
      FileSystem newFileSystem​(Path path, Map<String,?> env)
      构造新的 FileSystem以访问文件的内容作为文件系统。
      InputStream newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。
      OutputStream newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。
      abstract <A extends BasicFileAttributes>
      A             		readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      abstract Map<String,Object> readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      Path readSymbolicLink​(Path link)
      读取符号链接的目标。
      abstract void setAttribute​(Path path, String attribute, Object value, LinkOption... options)
      设置文件属性的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileSystemProvider

        protected FileSystemProvider​()
        初始化此类的新实例。

        在施工期间，提供商可以安全地访问与默认提供商相关的文件，但需要注意避免其他已安装提供程序的循环加载。 如果检测到已安装提供程序的循环加载，则会抛出未指定的错误。

        异常
        SecurityException - 如果安全管理员已经安装，并且它拒绝RuntimePermission ("fileSystemProvider")

    • 方法详细信息

      • installedProviders

        public static List<FileSystemProvider> installedProviders​()
        返回已安装文件系统提供程序的列表。

        首先调用此方法会导致默认提供程序被初始化（如果尚未初始化），并加载由FileSystems类描述的任何其他已安装的提供程序。

        结果
        已安装的文件系统提供程序的不可修改的列表。 该列表至少包含一个元素，即默认文件系统提供程序
        异常
        ServiceConfigurationError - 加载服务提供商时发生错误

      • getScheme

        public abstract String getScheme​()
        返回标识此提供程序的URI方案。
        结果
        URI方案

      • newFileSystem

        public abstract FileSystem newFileSystem​(URI uri,
                                         Map<String,?> env)
                                  throws IOException
        构造由URI标识的新的FileSystem对象。 该方法由FileSystems.newFileSystem(URI,Map)方法调用以打开由URI标识的新文件系统。

        uri参数是一个绝对的分层URI，其方案与此提供程序支持的方案相等（不考虑情况）。 URI的确切形式依赖于高度依赖于提供商。 env参数是配置文件系统的提供程序特定属性的映射。

        如果文件系统已经存在，则此方法将抛出FileSystemAlreadyExistsException ，因为它以前是通过调用此方法创建的。 一旦文件系统是closed ，如果提供程序允许使用与之前创建的文件系统相同的URI创建新文件系统，则依赖于提供程序。

        参数
        uri - URI参考
        env - 配置文件系统的提供程序特定属性的映射; 可能是空的
        结果
        一个新的文件系统
        异常
        IllegalArgumentException - 如果 uri参数的前提条件未满足，或 env参数不包含提供程序所需的属性，或属性值无效
        IOException - 创建文件系统时出现I / O错误
        SecurityException - 如果安装了安全管理器，并且它拒绝文件系统提供程序实现所需的未指定的权限
        FileSystemAlreadyExistsException - 如果文件系统已创建

      • getFileSystem

        public abstract FileSystem getFileSystem​(URI uri)
        返回此提供商创建的现有FileSystem 。

        此方法返回到基准FileSystem这是通过调用创建newFileSystem(URI,Map)方法。 创建newFileSystem(Path,Map)方法的文件系统不会由此方法返回。 文件系统由其URI标识。 其确切形式依赖于提供商。 在默认提供程序的情况下，URI的路径组件为"/" ，并且权限，查询和片段组件未定义（未定义的组件由null表示）。

        一旦由此提供商创建的文件系统是closed它是依赖提供者的，如果此方法返回对封闭文件系统的引用或抛出FileSystemNotFoundException 。 如果提供者允许使用与之前创建的文件系统相同的URI来创建新的文件系统，那么如果在文件系统关闭后（在newFileSystem方法创建新实例之前），则此方法将抛出异常。

        如果安装了安全管理器，则提供者实现可能需要在返回对现有文件系统的引用之前检查权限。 在default文件系统的情况下，不需要权限检查。

        参数
        uri - URI引用
        结果
        文件系统
        异常
        IllegalArgumentException - 如果不符合 uri参数的前提条件
        FileSystemNotFoundException - 如果文件系统不存在
        SecurityException - 如果安装了一个安全管理器，并且它拒绝了未指定的权限。

      • getPath

        public abstract Path getPath​(URI uri)
        通过转换给定的URI返回一个Path对象。 所产生的Path与已经存在或自动构建的FileSystem相关联。

        URI的确切形式是文件系统提供者依赖。 在默认提供程序的情况下，URI方案为"file" ，给定的URI具有非空路径组件，未定义的查询和片段组件。 由此产生的Path与默认值default FileSystem相关联。

        如果安装了一个安全管理器，那么提供者实现可能需要检查许可。 在default文件系统的情况下，不需要进行权限检查。

        参数
        uri - 要转换的URI
        结果
        结果 Path
        异常
        IllegalArgumentException - 如果URI方案不标识此提供程序或uri参数的其他前提条件不成立
        FileSystemNotFoundException - 由URI标识的文件系统不存在，不能自动创建
        SecurityException - 如果安装了安全管理器，并且拒绝了未指定的权限。

      • newFileSystem

        public FileSystem newFileSystem​(Path path,
                                Map<String,?> env)
                         throws IOException
        构造一个新的FileSystem以访问文件的内容作为文件系统。

        该方法适用于将一个或多个文件的内容视为文件系统的伪文件系统的专门提供商。 env参数是配置文件系统的提供程序特定属性的映射。

        如果此提供程序不支持创建此类文件系统，或者如果提供程序无法识别给定文件的文件类型，则它将抛出UnsupportedOperationException 。 此方法的默认实现将抛出UnsupportedOperationException 。

        参数
        path - 文件的路径
        env - 配置文件系统的提供者特定属性的映射; 可能是空的
        结果
        一个新的文件系统
        异常
        UnsupportedOperationException - 如果此提供商不支持以文件系统的形式访问内容，或者不识别给定文件的文件类型
        IllegalArgumentException - 如果 env参数不包含提供程序所需的属性，或属性值无效
        IOException - 如果发生I / O错误
        SecurityException - 如果安装了一个安全管理器，并且它拒绝了未指定的权限。

      • newInputStream

        public InputStream newInputStream​(Path path,
                                  OpenOption... options)
                           throws IOException
        打开一个文件，返回输入流以从文件中读取。 该方法的工作原理与Files.newInputStream(java.nio.file.Path, java.nio.file.OpenOption...)方法规定的方式相同 。

        此方法的默认实现将打开该文件的通道，就像调用newByteChannel(java.nio.file.Path, java.util.Set<? extends java.nio.file.OpenOption>, java.nio.file.attribute.FileAttribute<?>...)方法一样，并构建从通道读取字节的流。 这种方法应该在适当的时候被覆盖。

        参数
        path - 要打开文件的路径
        options - 指定文件打开方式的选项
        结果
        一个新的输入流
        异常
        IllegalArgumentException - 如果指定了无效的选项组合
        UnsupportedOperationException - 如果指定了不受支持的选项
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。

      • newOutputStream

        public OutputStream newOutputStream​(Path path,
                                    OpenOption... options)
                             throws IOException
        打开或创建文件，返回可用于向文件写入字节的输出流。 此方法的工作原理与Files.newOutputStream(java.nio.file.Path, java.nio.file.OpenOption...)方法规定的方式相同 。

        此方法的默认实现将打开一个通道到文件，就像通过调用newByteChannel(java.nio.file.Path, java.util.Set<? extends java.nio.file.OpenOption>, java.nio.file.attribute.FileAttribute<?>...)方法并构造一个向通道写入字节的流。 这种方法应该在适当的时候被覆盖。

        参数
        path - 打开或创建文件的路径
        options - 指定文件打开方式的选项
        结果
        一个新的输出流
        异常
        IllegalArgumentException - 如果 options包含选项的无效组合
        UnsupportedOperationException - 如果指定了不受支持的选项
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用checkWrite方法来检查对该文件的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。

      • newFileChannel

        public FileChannel newFileChannel​(Path path,
                                  Set<? extends OpenOption> options,
                                  FileAttribute<?>... attrs)
                           throws IOException
        打开或创建用于读取和/或写入的文件，返回文件通道以访问该文件。 该方法的工作原理与FileChannel.open方法规定的方式相同 。 不支持构建文件通道所需的所有功能的提供者将抛出UnsupportedOperationException 。 默认提供程序需要支持创建文件通道。 当不覆盖时，默认实现将抛出UnsupportedOperationException 。
        参数
        path - 打开或创建文件的路径
        options - 指定文件打开方式的选项
        attrs - 创建文件时以原子方式设置的文件属性的可选列表
        结果
        一个新的文件通道
        异常
        IllegalArgumentException - 如果集合包含无效的选项组合
        UnsupportedOperationException - 如果此提供程序不支持创建文件通道，或指定不受支持的打开选项或文件属性
        IOException - 如果发生I / O错误
        SecurityException - 在默认文件系统的情况下，如果打开文件进行读取，则调用SecurityManager.checkRead(String)方法来检查读取访问。 如果打开文件写入，则调用SecurityManager.checkWrite(String)方法来检查写访问

      • newAsynchronousFileChannel

        public AsynchronousFileChannel newAsynchronousFileChannel​(Path path,
                                                          Set<? extends OpenOption> options,
                                                          ExecutorService executor,
                                                          FileAttribute<?>... attrs)
                                                   throws IOException
        打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。 该方法的工作原理与AsynchronousFileChannel.open方法规定的方式相同 。 不支持构建异步文件通道所需的所有功能的提供程序将抛出UnsupportedOperationException 。 需要默认提供程序来支持创建异步文件通道。 当不被覆盖时，此方法的默认实现将抛出UnsupportedOperationException 。
        参数
        path - 要打开或创建文件的路径
        options - 指定文件打开方式的选项
        executor - 线程池或 null将通道与默认线程池相关联
        attrs - 创建文件时以原子方式设置的文件属性的可选列表
        结果
        一个新的异步文件通道
        异常
        IllegalArgumentException - 如果集合包含无效的选项组合
        UnsupportedOperationException - 如果此提供程序不支持创建异步文件通道，或者指定不支持的打开选项或文件属性
        IOException - 如果发生I / O错误
        SecurityException - 在默认文件系统的情况下，如果文件打开以供阅读，则调用SecurityManager.checkRead(String)方法来检查读访问。 如果打开文件写入，则调用SecurityManager.checkWrite(String)方法来检查写访问

      • newByteChannel

        public abstract SeekableByteChannel newByteChannel​(Path path,
                                                   Set<? extends OpenOption> options,
                                                   FileAttribute<?>... attrs)
                                            throws IOException
        打开或创建文件，返回可访问的字节通道以访问该文件。 此方法的工作原理与Files.newByteChannel(Path,Set,FileAttribute[])方法规定的方式相同 。
        参数
        path - 打开或创建文件的路径
        options - 指定文件打开方式的选项
        attrs - 创建文件时以原子方式设置的文件属性的可选列表
        结果
        一个新的可寻找字节通道
        异常
        IllegalArgumentException - 如果集合包含选项的无效组合
        UnsupportedOperationException - 如果指定了不受支持的打开选项，或者数组包含创建文件时无法原子设置的属性
        FileAlreadyExistsException - 如果该名称的文件已存在，并指定了 CREATE_NEW选项 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用checkRead方法来检查该文件是否被读取访问路径。 如果打开文件进行写入，则调用checkWrite方法来检查对路径的写入访问。 如果使用DELETE_ON_CLOSE选项打开文件，则调用checkDelete方法来检查删除访问。

      • newDirectoryStream

        public abstract DirectoryStream<Path> newDirectoryStream​(Path dir,
                                                         DirectoryStream.Filter<? super Path> filter)
                                                  throws IOException
        打开一个目录，返回一个DirectoryStream以遍历目录中的条目。 该方法的工作原理与Files.newDirectoryStream(java.nio.file.Path, java.nio.file.DirectoryStream.Filter)方法规定的方式相同 。
        参数
        dir - 目录的路径
        filter - 目录流过滤器
        结果
        一个新的和开放的 DirectoryStream对象
        异常
        NotDirectoryException - 如果文件无法打开，因为它不是目录 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 checkRead方法来检查对该目录的读取访问。

      • createDirectory

        public abstract void createDirectory​(Path dir,
                                     FileAttribute<?>... attrs)
                              throws IOException
        创建一个新的目录。 此方法的工作原理与Files.createDirectory(java.nio.file.Path, java.nio.file.attribute.FileAttribute<?>...)方法规定的方式相同 。
        参数
        dir - 要创建的目录
        attrs - 创建目录时原子设置的文件属性的可选列表
        异常
        UnsupportedOperationException - 如果数组包含创建目录时无法原子设置的属性
        FileAlreadyExistsException - 如果无法创建目录，因为该名称的文件已存在 （可选的特殊异常）
        IOException - 如果发生I / O错误或父目录不存在
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkWrite方法来检查对新目录的写入访问。

      • createSymbolicLink

        public void createSymbolicLink​(Path link,
                               Path target,
                               FileAttribute<?>... attrs)
                        throws IOException
        创建一个到目标的符号链接。 该方法的工作原理与Files.createSymbolicLink(java.nio.file.Path, java.nio.file.Path, java.nio.file.attribute.FileAttribute<?>...)方法规定的方式相同 。

        此方法的默认实现将抛出UnsupportedOperationException 。

        参数
        link - 要创建的符号链接的路径
        target - 符号链接的目标
        attrs - 创建符号链接时以原子方式设置的属性数组
        异常
        UnsupportedOperationException - 如果实现不支持符号链接，或者数组包含在创建符号链接时无法原子地设置的属性
        FileAlreadyExistsException - 如果具有该名称的文件已存在 （可选特定异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，它将拒绝LinkPermission ("symbolic")或其checkWrite方法拒绝对符号链接的路径的写入访问。

      • createLink

        public void createLink​(Path link,
                       Path existing)
                throws IOException
        为现有文件创建一个新的链接（目录条目）。 此方法的工作原理与Files.createLink(java.nio.file.Path, java.nio.file.Path)方法规定的方式相同 。

        此方法的默认实现将抛出UnsupportedOperationException 。

        参数
        link - 要创建的链接（目录条目）
        existing - 现有文件的路径
        异常
        UnsupportedOperationException - 如果实现不支持将现有文件添加到目录中
        FileAlreadyExistsException - 如果由于该名称的文件已存在，否则无法创建该条目 （可选的特定异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，它将拒绝LinkPermission ("hard")或其checkWrite方法拒绝对链接或现有文件的写入访问。

      • delete

        public abstract void delete​(Path path)
                     throws IOException
        删除文件。 该方法的工作原理与Files.delete(java.nio.file.Path)方法规定的方式相同 。
        参数
        path - 要删除的文件的路径
        异常
        NoSuchFileException - 如果文件不存在 （可选的特殊异常）
        DirectoryNotEmptyException - 如果文件是目录，并且由于目录不为空，否则无法删除 （可选的特定异常）
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 SecurityManager.checkDelete(String)方法来检查对该文件的删除访问

      • deleteIfExists

        public boolean deleteIfExists​(Path path)
                       throws IOException
        删除文件（如果存在）。 该方法的工作原理与Files.deleteIfExists(java.nio.file.Path)方法规定的方式相同 。

        该方法的默认实现只需调用delete(java.nio.file.Path) ，当文件不存在时忽略NoSuchFileException 。 在适当情况下可能会被覆盖。

        参数
        path - 要删除的文件的路径
        结果
        true如果文件被该方法删除; false如果文件不存在，则无法删除
        异常
        DirectoryNotEmptyException - 如果该文件是一个目录，并且由于目录不为空，否则无法删除 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException - 如果是默认提供程序，并安装了安全管理器，则会调用 SecurityManager.checkDelete(String)方法来检查对该文件的删除访问

      • readSymbolicLink

        public Path readSymbolicLink​(Path link)
                      throws IOException
        读取符号链接的目标。 此方法的工作原理与Files.readSymbolicLink(java.nio.file.Path)方法规定的方式相同 。

        此方法的默认实现将抛出UnsupportedOperationException 。

        参数
        link - 符号链接的路径
        结果
        符号链接的目标
        异常
        UnsupportedOperationException - 如果实现不支持符号链接
        NotLinkException - 如果目标文件不能被读取，因为该文件不是符号链接 （可选的特殊异常）
        IOException - 如果发生I / O错误
        SecurityException -在默认的供应商，安全管理器的情况下被安装，它会检查 FilePermission已被授予的“ readlink ”的行动阅读的链接。

      • copy

        public abstract void copy​(Path source,
                          Path target,
                          CopyOption... options)
                   throws IOException
        将文件复制到目标文件。 该方法的工作原理与Files.copy(Path,Path,CopyOption[])方法规定的方式相同，只是源路径和目标路径必须与此提供程序相关联。
        参数
        source - 要复制的文件的路径
        target - 目标文件的路径
        options - 指定应如何完成副本的选项
        异常
        UnsupportedOperationException - 如果数组包含不支持的副本选项
        FileAlreadyExistsException - 如果目标文件存在但无法替换，因为未指定 REPLACE_EXISTING选项 （可选特定异常）
        DirectoryNotEmptyException - 指定了 REPLACE_EXISTING选项，但是由于它是非空目录 （可选的特殊异常），因此无法替换该文件。
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用checkRead方法来检查对源文件的读取访问，调用checkWrite以检查对目标文件的写入访问。 如果复制了符号链接，则调用安全管理器来检查LinkPermission ("symbolic") 。

      • move

        public abstract void move​(Path source,
                          Path target,
                          CopyOption... options)
                   throws IOException
        将文件移动或重命名为目标文件。 此方法的工作原理与Files.move(java.nio.file.Path, java.nio.file.Path, java.nio.file.CopyOption...)方法所指定的方式相同，只是源路径和目标路径必须与此提供程序相关联。
        参数
        source - 要移动的文件的路径
        target - 目标文件的路径
        options - 指定移动应该如何完成的选项
        异常
        UnsupportedOperationException - 如果数组包含不支持的副本选项
        FileAlreadyExistsException - 如果目标文件存在但无法替换，因为未指定 REPLACE_EXISTING选项 （可选特定异常）
        DirectoryNotEmptyException - 指定了 REPLACE_EXISTING选项，但由于它是非空目录 （可选的特殊异常），因此无法替换该文件。
        AtomicMoveNotSupportedException - 如果options数组包含 ATOMIC_MOVE选项，但该文件不能作为原子文件系统操作移动。
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkWrite方法来检查对源文件和目标文件的写入访问。

      • isSameFile

        public abstract boolean isSameFile​(Path path,
                                   Path path2)
                            throws IOException
        测试两个路径是否找到相同的文件。 该方法的工作原理与Files.isSameFile(java.nio.file.Path, java.nio.file.Path)方法规定的方式相同 。
        参数
        path - 文件的一条路径
        path2 - 其他路径
        结果
        true如果，并且只有当两个路径找到相同的文件时
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对这两个文件的读取访问。

      • isHidden

        public abstract boolean isHidden​(Path path)
                          throws IOException
        告知文件是否被隐藏 。 此方法的工作原理与Files.isHidden(java.nio.file.Path)方法规定的方式相同 。

        该方法由isHidden方法调用。

        参数
        path - 要测试文件的路径
        结果
        true如果文件被认为是隐藏的
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用 checkRead方法来检查对该文件的读取访问。

      • getFileStore

        public abstract FileStore getFileStore​(Path path)
                                throws IOException
        返回表示文件所在文件存储区的FileStore 。 此方法的工作原理与Files.getFileStore(java.nio.file.Path)方法规定的方式相同 。
        参数
        path - 文件的路径
        结果
        存储文件的文件存储区
        异常
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序和安全管理器的情况下，将调用checkRead方法来检查对该文件的读取访问，此外还检查RuntimePermission ("getFileStoreAttributes")

      • checkAccess

        public abstract void checkAccess​(Path path,
                                 AccessMode... modes)
                          throws IOException
        检查文件的存在，以及可选的可访问性。

        这种方法可以由使用isReadable ， isWritable和isExecutable方法来检查的文件的可访问性。

        该方法检查文件的存在，并且该Java虚拟机具有适当的权限，允许其根据modes参数中指定的所有访问模式访问该文件，如下所示：

        Access Modes Value Description READ Checks that the file exists and that the Java virtual machine has permission to read the file. WRITE Checks that the file exists and that the Java virtual machine has permission to write to the file, EXECUTE Checks that the file exists and that the Java virtual machine has permission to execute the file. The semantics may differ when checking access to a directory. For example, on UNIX systems, checking for EXECUTE access checks that the Java virtual machine has permission to search the directory in order to access file or subdirectories.

        如果modes参数的长度为零，则检查文件的存在。

        如果此对象引用的文件是符号链接，则此方法遵循符号链接。 根据实现，此方法可能需要读取文件权限，访问控制列表或其他文件属性，以便检查对文件的有效访问。 要确定对文件的有效访问可能需要访问多个属性，因此在某些实现中，该方法可能不是相对于其他文件系统操作的原子。

        参数
        path - 要检查的文件的路径
        modes - 检查的访问模式; 可能有零个元素
        异常
        UnsupportedOperationException -的实现，则需要支持检查READ ， WRITE ，并EXECUTE访问。 此异常被指定为允许在将来的版本中扩展Access枚举。
        NoSuchFileException - 如果文件不存在 （可选特定异常）
        AccessDeniedException - 所请求的访问将被拒绝或无法确定访问，因为Java虚拟机没有足够的权限或其他原因。 （可选具体例外）
        IOException - 如果发生I / O错误
        SecurityException -在安装的默认提供的情况，以及安全管理器，该 checkRead被检查时读访问文件或只有文件的存在，调用 checkWrite检查该文件的写访问时被调用，并 checkExec在检查执行访问时被调用。

      • getFileAttributeView

        public abstract <V extends FileAttributeView> V getFileAttributeView​(Path path,
                                                                     Class<V> type,
                                                                     LinkOption... options)
        返回给定类型的文件属性视图。 此方法的工作原理与Files.getFileAttributeView(java.nio.file.Path, java.lang.Class<V>, java.nio.file.LinkOption...)方法规定的方式相同 。
        参数类型
        V - FileAttributeView类型
        参数
        path - 文件的路径
        type - 对应于文件属性视图的 Class对象
        options - 表示如何处理符号链接的选项
        结果
        指定类型的文件属性视图，如果属性视图类型不可用， null

      • readAttributes

        public abstract <A extends BasicFileAttributes> A readAttributes​(Path path,
                                                                 Class<A> type,
                                                                 LinkOption... options)
                                                          throws IOException
        读取文件的属性作为批量操作。 该方法的工作原理与Files.readAttributes(Path,Class,LinkOption[])方法规定的方式相同 。
        参数类型
        A - BasicFileAttributes类型
        参数
        path - 文件的路径
        type - 需要阅读的文件属性的 Class
        options - 表示如何处理符号链接的选项
        结果
        文件属性
        异常
        UnsupportedOperationException - 如果不支持给定类型的属性
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，调用其 checkRead方法来检查对该文件的读取访问

      • readAttributes

        public abstract Map<String,Object> readAttributes​(Path path,
                                                  String attributes,
                                                  LinkOption... options)
                                           throws IOException
        读取一组文件属性作为批量操作。 此方法的工作原理与Files.readAttributes(Path,String,LinkOption[])方法规定的方式相同 。
        参数
        path - 文件的路径
        attributes - 要读取的属性
        options - 表示如何处理符号链接的选项
        结果
        返回属性的地图; 可能是空的。 地图的键是属性名称，其值是属性值
        异常
        UnsupportedOperationException - 如果属性视图不可用
        IllegalArgumentException - 如果没有指定属性或指定了无法识别的属性
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，其checkRead方法拒绝对该文件的读取访问。 如果调用此方法来读取安全敏感属性，则可能会调用安全管理器来检查其他权限。

      • setAttribute

        public abstract void setAttribute​(Path path,
                                  String attribute,
                                  Object value,
                                  LinkOption... options)
                           throws IOException
        设置文件属性的值。 此方法的工作原理与Files.setAttribute(java.nio.file.Path, java.lang.String, java.lang.Object, java.nio.file.LinkOption...)方法规定的方式相同 。
        参数
        path - 文件的路径
        attribute - 要设置的属性
        value - 属性值
        options - 表示如何处理符号链接的选项
        异常
        UnsupportedOperationException - 如果属性视图不可用
        IllegalArgumentException - 如果属性名称未指定或无法识别，或属性值是正确的类型但具有不适当的值
        ClassCastException - 如果属性值不是预期类型，或者是包含不是预期类型的元素的集合
        IOException - 如果发生I / O错误
        SecurityException - 在默认提供程序的情况下，安装了一个安全管理器，其checkWrite方法拒绝对该文件的写入访问。 如果调用此方法来设置安全敏感属性，则可以调用安全管理器以检查其他权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileTypeDetector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.nio.file.spi

Class FileTypeDetector

  • java.lang.Object
    • java.nio.file.spi.FileTypeDetector

  • public abstract class FileTypeDetector
extends Object
    用于探测文件以猜测其文件类型的文件类型检测器。

    文件类型检测器是此类的具体实现，具有零参数构造函数，并实现下面指定的抽象方法。

    文件类型检测器确定文件类型的方式具有高度的实现特定性。 一个简单的实现可能会检查文件扩展名 （某些平台中使用的约定），并将其映射到文件类型。 在其他情况下，文件类型可以存储为文件attribute，或文件中的字节可能被检查以猜测其文件类型。

    从以下版本开始：
    1.7
    另请参见：
    Files.probeContentType(Path)

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FileTypeDetector​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract String probeContentType​(Path path)
      探测给定的文件来猜测其内容类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileTypeDetector

        protected FileTypeDetector​()
        初始化此类的新实例。
        异常
        SecurityException - 如果安全管理器已安装，并且它已拒绝RuntimePermission ("fileTypeDetector")

    • 方法详细信息

      • probeContentType

        public abstract String probeContentType​(Path path)
                                 throws IOException
        探测给定的文件来猜测其内容类型。

        该方法确定文件类型的方法具有高度实现性。 它可以简单地检查文件名，它可以使用文件attribute ，或者它可以检查文件中的字节。

        探测结果是由RFC 2045: Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies定义的多用途Internet邮件扩展（MIME）内容类型的值的字符串形式。 该字符串必须根据RFC 2045中的语法进行解析。

        参数
        path - 要探测的文件的路径
        结果
        内容类型或 null如果文件类型无法识别
        异常
        IOException - 发生I / O错误
        SecurityException - 如果实现需要访问该文件，并且安装了一个安全管理器，并且它拒绝文件系统提供程序实现所需的未指定的权限。 如果文件引用与默认文件系统提供程序相关联，则调用SecurityManager.checkRead(String)方法来检查对该文件的读取访问。
        另请参见：
        Files.probeContentType(java.nio.file.Path)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.nio.file.spi (Java SE 9 & JDK 9 )

java.nio.file.spi

Classes

  • FileSystemProvider
  • FileTypeDetector


java.nio.file.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.nio.file.spi

java.nio.file包的服务提供商类。

只有定义新的文件系统提供程序或文件类型检测器的开发人员才需要直接使用这个包。

除非另有说明，否则将null参数传递给此程序包中任何类或接口中的构造函数或方法将导致抛出NullPointerException 。

从以下版本开始：
1.7
  • 类摘要
    Class 描述
    FileSystemProvider
    文件系统的服务提供者类。
    FileTypeDetector
    用于探测文件以猜测其文件类型的文件类型检测器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.nio.file.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.nio.file.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.nio.file.spi.FileSystemProvider
    • java.nio.file.spi.FileTypeDetector
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package java.nio.file.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.nio.file.spi

  • Packages that use java.nio.file.spi
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。
  • Classes in java.nio.file.spi used by java.nio.file
    Class 描述
    FileSystemProvider
    文件系统的服务提供者类。
  • Classes in java.nio.file.spi used by java.nio.file.spi
    Class 描述
    FileSystemProvider
    文件系统的服务提供者类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.spi.FileSystemProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.spi.FileSystemProvider

  • Packages that use FileSystemProvider
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。

    • Uses of FileSystemProvider in java.nio.file

      Methods in java.nio.file that return FileSystemProvider
      Modifier and Type 方法 描述
      abstract FileSystemProvider FileSystem.provider​()
      返回创建此文件系统的提供程序。

    • Uses of FileSystemProvider in java.nio.file.spi

      Methods in java.nio.file.spi that return types with arguments of type FileSystemProvider
      Modifier and Type 方法 描述
      static List<FileSystemProvider> FileSystemProvider.installedProviders​()
      返回已安装文件系统提供程序的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.nio.file.spi.FileTypeDetector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.nio.file.spi.FileTypeDetector

No usage of java.nio.file.spi.FileTypeDetector
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AccessException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class AccessException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.AccessException
  • All Implemented Interfaces:
    Serializable

    public class AccessException
extends RemoteException
    一个AccessException通过一定的方法抛出java.rmi.Naming类（具体bind ， rebind ，和unbind ）和方法java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。 如果从非本地主机调用该方法，则抛出一个AccessException 。
    从以下版本开始：
    1.1
    另请参见：
    Naming ， ActivationSystem ， Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessException​(String s)
      构造具有指定详细消息的 AccessException 。
      AccessException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 AccessException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AccessException

        public AccessException​(String s)
        构造具有指定详细消息的 AccessException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • AccessException

        public AccessException​(String s,
                       异常 ex)
        构造具有指定的详细消息和嵌套异常的 AccessException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AlreadyBoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class AlreadyBoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.rmi.AlreadyBoundException
  • All Implemented Interfaces:
    Serializable

    public class AlreadyBoundException
extends 异常
    如果尝试将注册表中的对象绑定到已经具有关联绑定的名称，则抛出一个 AlreadyBoundException 。
    从以下版本开始：
    1.1
    另请参见：
    Naming.bind(String, java.rmi.Remote) ， Registry.bind(String, java.rmi.Remote) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AlreadyBoundException​()
      构造一个没有指定详细信息的 AlreadyBoundException 。
      AlreadyBoundException​(String s)
      构造具有指定详细消息的 AlreadyBoundException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AlreadyBoundException

        public AlreadyBoundException​()
        构造一个没有指定详细消息的 AlreadyBoundException 。
        从以下版本开始：
        1.1

      • AlreadyBoundException

        public AlreadyBoundException​(String s)
        构造具有指定详细消息的 AlreadyBoundException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConnectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class ConnectException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.ConnectException
  • All Implemented Interfaces:
    Serializable

    public class ConnectException
extends RemoteException
    如果连接拒绝远程主机进行远程方法调用，则抛出 ConnectException 。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConnectException​(String s)
      构造具有指定详细消息的 ConnectException 。
      ConnectException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ConnectException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ConnectException

        public ConnectException​(String s)
        构造具有指定详细消息的 ConnectException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • ConnectException

        public ConnectException​(String s,
                        异常 ex)
        构造具有指定的详细消息和嵌套异常的 ConnectException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConnectIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class ConnectIOException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.ConnectIOException
  • All Implemented Interfaces:
    Serializable

    public class ConnectIOException
extends RemoteException
    如果在与远程主机进行远程方法调用的连接时发生 ConnectIOException则抛出 IOException 。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConnectIOException​(String s)
      构造具有指定详细消息的 ConnectIOException 。
      ConnectIOException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ConnectIOException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ConnectIOException

        public ConnectIOException​(String s)
        构造具有指定详细消息的 ConnectIOException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • ConnectIOException

        public ConnectIOException​(String s,
                          异常 ex)
        构造具有指定的详细消息和嵌套异常的 ConnectIOException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.rmi (Java SE 9 & JDK 9 )

java.rmi

Interfaces

  • Remote

Classes

  • MarshalledObject
  • Naming
  • RMISecurityManager

Exceptions

  • AccessException
  • AlreadyBoundException
  • ConnectException
  • ConnectIOException
  • MarshalException
  • NoSuchObjectException
  • NotBoundException
  • RemoteException
  • RMISecurityException
  • ServerError
  • ServerException
  • ServerRuntimeException
  • StubNotFoundException
  • UnexpectedException
  • UnknownHostException
  • UnmarshalException


java.rmi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.rmi

Package java.rmi

提供RMI包。 RMI是远程方法调用。 这是一种使一个Java虚拟机上的对象能够调用另一个Java虚拟机中对象的方法的机制。 可以以这种方式调用的任何对象都必须实现Remote接口。 当调用这样一个对象时，它的参数是“marshalled”，并从本地虚拟机发送到远程对象，其中参数是“未编组的”。当方法终止时，结果从远程机器编组并发送给呼叫者的虚拟机。 如果方法调用导致抛出异常，则会向调用者指示异常。
从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
  • 类摘要
    Class 描述
    MarshalledObject<T>
    A MarshalledObject包含具有给它的构造函数的对象的序列化表示的字节流。
    Naming
    Naming类提供了存储和获取对远程对象注册表中远程对象的引用的方法。
    RMISecurityManager Deprecated.
    改用SecurityManager 。
  • 异常摘要
    异常 描述
    AccessException
    一个 AccessException通过一定的方法抛出 java.rmi.Naming类（具体 bind ， rebind ，和 unbind ）和方法 java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。
    AlreadyBoundException
    如果尝试将注册表中的对象绑定到已经具有关联绑定的名称，则抛出一个 AlreadyBoundException 。
    ConnectException
    如果连接被拒绝到远程主机进行远程方法调用，则抛出 ConnectException 。
    ConnectIOException
    如果在与远程主机进行远程方法调用的连接时发生 ConnectIOException则抛出 IOException 。
    MarshalException
    如果在编组远程调用头，远程方法调用的参数或返回值时发生 MarshalException则抛出 java.io.IOException 。
    NoSuchObjectException
    如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
    NotBoundException
    如果尝试在注册表中查找或取消绑定没有关联绑定的名称，则抛出 NotBoundException 。
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
    RMISecurityException Deprecated.
    改用SecurityException 。
    ServerError
    甲 ServerError被抛出作为远程方法调用的结果，当一个 Error任而解编参数，执行远程方法本身，或编组返回值在处理服务器上的调用，被抛出。
    ServerException
    甲 ServerException当被抛出作为远程方法调用的结果 RemoteException在处理服务器上的调用，要么同时解编参数或执行远程方法本身被抛出。
    ServerRuntimeException Deprecated.
    没有替换
    StubNotFoundException
    如果远程对象在导出时无法找到有效的存根类，则抛出 StubNotFoundException 。
    UnexpectedException
    如果远程方法调用的客户机接收到调用的结果，那么抛出一个 UnexpectedException ，该检查异常不在远程接口的方法的 throws子句中声明的检查的异常类型中。
    UnknownHostException
    如果在创建与远程主机的远程方法调用的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。
    UnmarshalException
    如果发生以下任何一种 UnmarshalException可以在解组远程方法调用的参数或结果时抛出一个 UnmarshalException ：如果在解组调用头时 java.io.IOException调用头，如果一个 java.io.IOException发生解组参数（on服务器端）或返回值（在客户端）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.rmi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.rmi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.rmi.MarshalledObject<T> (implements java.io.Serializable)
    • java.rmi.Naming
    • java.lang.SecurityManager
      • java.rmi.RMISecurityManager
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.rmi.AlreadyBoundException
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.AccessException
            • java.rmi.ConnectException
            • java.rmi.ConnectIOException
            • java.rmi.MarshalException
            • java.rmi.NoSuchObjectException
            • java.rmi.ServerError
            • java.rmi.ServerException
            • java.rmi.ServerRuntimeException
            • java.rmi.StubNotFoundException
            • java.rmi.UnexpectedException
            • java.rmi.UnknownHostException
            • java.rmi.UnmarshalException
        • java.rmi.NotBoundException
        • java.lang.RuntimeException
          • java.lang.SecurityException
            • java.rmi.RMISecurityException

Interface Hierarchy

  • java.rmi.Remote
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


MarshalException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class MarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.MarshalException
  • All Implemented Interfaces:
    Serializable

    public class MarshalException
extends RemoteException
    如果在编组远程调用头，远程方法调用的参数或返回值时发生MarshalException则抛出java.io.IOException 。 如果接收方不支持发送方的协议版本，也会抛出A MarshalException 。

    如果在远程方法调用期间发生MarshalException ，则呼叫可能已经或可能没有到达服务器。 如果呼叫到达服务器，参数可能已被反序列化。 在MarshalException之后可能不会重传呼叫，并可靠地保留“最多一次”呼叫语义。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      MarshalException​(String s)
      构造具有指定详细消息的 MarshalException 。
      MarshalException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 MarshalException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MarshalException

        public MarshalException​(String s)
        构造具有指定详细消息的 MarshalException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • MarshalException

        public MarshalException​(String s,
                        异常 ex)
        构造具有指定的详细消息和嵌套异常的 MarshalException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MarshalledObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class MarshalledObject<T>

  • java.lang.Object
    • java.rmi.MarshalledObject<T>
  • 参数类型
    T - 此 MarshalledObject包含的对象的类型
    All Implemented Interfaces:
    Serializable

    public final class MarshalledObject<T>
extends Object
implements Serializable
    A MarshalledObject包含具有给其构造函数的对象的序列化表示的字节流。 get方法返回原始对象的新副本，从包含的字节流中反序列化。 包含的对象被序列化和反序列化，具有用于编组和解组参数的相同的序列化语义和RMI调用的返回值：当创建序列化表单时：
    • 类使用可以加载类的代码库URL进行注释（如果可用），以及
    • MarshalledObject中的任何远程对象由其存根的序列化实例表示。

    检索对象的副本（通过get方法），如果该类在本地不可用，则将从适当的位置加载（指定在类被序列化时用类描述符注释的URL。

    MarshalledObject有助于在远程对等体立即自动反序列化的RMI调用中传递对象。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MarshalledObject​(T obj)
      创建一个新的 MarshalledObject ，其中包含所提供对象的当前状态的序列化表示。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此 MarshalledObject与另一个对象进行比较。
      T get​()
      返回包含的编组对象的新副本。
      int hashCode​()
      返回这个 MarshalledObject的哈希码。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MarshalledObject

        public MarshalledObject​(T obj)
                 throws IOException
        创建一个新的MarshalledObject ，其中包含所提供对象的当前状态的序列化表示。 对象使用用于RMI调用的编组参数的语义进行序列化。
        参数
        obj - 要序列化的对象（必须是可序列化的）
        异常
        IOException - 如果发生IOException ; 一个IOException如果可能会出现obj不是可序列化。
        从以下版本开始：
        1.2

    • 方法详细信息

      • get

        public T get​()
      throws IOException,
             ClassNotFoundException
        返回包含的编组对象的新副本。 内部表示被反序列化，用于解密RMI调用参数的语义。 如果从一个ObjectInputStream读取MarshalledObject，该流的过滤器用于反序列化该对象。
        结果
        包含对象的副本
        异常
        IOException - 如果从其内部表示反序列化对象时发生 IOException 。
        ClassNotFoundException - 如果从其内部表示反序列化对象时发生ClassNotFoundException 。 找不到
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回这个 MarshalledObject的哈希码。
        重写：
        hashCode在 Object
        结果
        一个哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将此MarshalledObject与另一个对象进行比较。 当且仅当参数引用包含与此对象完全相同的序列化表示形式的MarshalledObject ，才返回true。 比较忽略任何类代码库注释，这意味着如果两个对象具有相同的序列化表示， 但序列化表示中的每个类的代码除外 。
        重写：
        equals在 Object
        参数
        obj - 与此 MarshalledObject比较的对象
        结果
        true如果参数包含一个等效的序列化对象; 否则为false
        从以下版本开始：
        1.2
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Naming (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class Naming

  • java.lang.Object
    • java.rmi.Naming

  • public final class Naming
extends Object
    Naming类提供了存储和获取对远程对象注册表中远程对象的引用的方法。 Naming类的每个方法都将其作为参数的一个名称java.lang.String URL格式的java.lang.String （不带方案组件）：
      //host:port/name

    其中host是注册表所在的主机（远程或本地）， port是注册表接受调用的端口号，而name是注册表未解释的简单字符串。 host和port都是可选的。 如果省略host ，则主机默认为本地主机。 如果省略了port ，则端口默认为1099，RMI的注册表（ rmiregistry ）使用的“知名”端口。

    绑定远程对象的名称是关联或注册远程对象的名称，以便稍后可以使用它来查找该远程对象。 远程对象可以使用Naming类的bind或rebind方法与名称相关联。

    一旦远程对象与本地主机上的RMI注册表注册（绑定），远程（或本地）主机上的呼叫者可以通过名称查找远程对象，获取其引用，然后调用对象上的远程方法。 注册表可以由主机上运行的所有服务器共享，或者单个服务器进程可以根据需要创建并使用自己的注册表（有关详细信息，请参阅java.rmi.registry.LocateRegistry.createRegistry方法）。

    从以下版本开始：
    1.1
    另请参见：
    Registry ， LocateRegistry ， LocateRegistry.createRegistry(int)

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static void bind​(String name, Remote obj)
      将指定的 name绑定到远程对象。
      static String[] list​(String name)
      返回在注册表中绑定的名称的数组。
      static Remote lookup​(String name)
      返回与指定的 name相关联的远程对象的引用，存根。
      static void rebind​(String name, Remote obj)
      将指定的名称重新绑定到一个新的远程对象。
      static void unbind​(String name)
      销毁与远程对象关联的指定名称的绑定。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • lookup

        public static Remote lookup​(String name)
                     throws NotBoundException,
                            MalformedURLException,
                            RemoteException
        返回与指定的 name关联的远程对象的引用，存根。
        参数
        name - URL格式的名称（不包含方案组件）
        结果
        远程对象的引用
        异常
        NotBoundException - 如果名称当前未绑定
        RemoteException - 如果无法联系注册表
        AccessException - 如果不允许此操作
        MalformedURLException - 如果名称不是格式正确的URL
        从以下版本开始：
        1.1

      • bind

        public static void bind​(String name,
                        Remote obj)
                 throws AlreadyBoundException,
                        MalformedURLException,
                        RemoteException
        将指定的 name绑定到远程对象。
        参数
        name - URL格式的名称（不包括方案组件）
        obj - 远程对象的引用（通常是存根）
        异常
        AlreadyBoundException - 如果名称已经绑定
        MalformedURLException - 如果名称不是格式正确的URL
        RemoteException - 如果无法联系注册表
        AccessException - 如果不允许此操作（例如，源自非本地主机）
        从以下版本开始：
        1.1

      • unbind

        public static void unbind​(String name)
                   throws RemoteException,
                          NotBoundException,
                          MalformedURLException
        销毁与远程对象关联的指定名称的绑定。
        参数
        name - URL格式的名称（没有方案组件）
        异常
        NotBoundException - 如果名称当前未绑定
        MalformedURLException - 如果名称不是格式正确的URL
        RemoteException - 如果无法联系注册表
        AccessException - 如果不允许此操作（例如，源自非本地主机）
        从以下版本开始：
        1.1

      • rebind

        public static void rebind​(String name,
                          Remote obj)
                   throws RemoteException,
                          MalformedURLException
        将指定的名称重新绑定到一个新的远程对象。 任何现有的名称绑定被替换。
        参数
        name - URL格式的名称（不包含方案组件）
        obj - 与该名称相关联的新远程对象
        异常
        MalformedURLException - 如果名称不是格式正确的URL
        RemoteException - 如果无法联系注册表
        AccessException - 如果不允许此操作（例如源自非本地主机）
        从以下版本开始：
        1.1

      • list

        public static String[] list​(String name)
                     throws RemoteException,
                            MalformedURLException
        返回在注册表中绑定的名称的数组。 这些名称是URL格式的（没有方案组件）的字符串。 该数组包含在调用时注册表中存在的名称的快照。
        参数
        name - URL格式的注册表名称（不包括方案组件）
        结果
        在注册表中绑定的一组名称（以适当的格式）
        异常
        MalformedURLException - 如果名称不是格式正确的URL
        RemoteException - 如果无法联系注册表。
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NoSuchObjectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class NoSuchObjectException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.NoSuchObjectException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchObjectException
extends RemoteException
    如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出NoSuchObjectException 。 如果尝试在远程对象上调用方法发生NoSuchObjectException ，则可以重传该呼叫，并仍保留RMI的“至多一次”调用语义。 甲NoSuchObjectException也由方法引发java.rmi.server.RemoteObject.toStub和由unexportObject的方法java.rmi.server.UnicastRemoteObject和java.rmi.activation.Activatable和
    从以下版本开始：
    1.1
    另请参见：
    RemoteObject.toStub(Remote) ，
UnicastRemoteObject.unexportObject(Remote,boolean) ，
Activatable.unexportObject(Remote,boolean) ，
Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchObjectException​(String s)
      构造具有指定详细消息的 NoSuchObjectException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchObjectException

        public NoSuchObjectException​(String s)
        构造具有指定详细消息的 NoSuchObjectException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NotBoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class NotBoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.rmi.NotBoundException
  • All Implemented Interfaces:
    Serializable

    public class NotBoundException
extends 异常
    如果尝试在注册表中查找或取消绑定没有关联绑定的名称，则抛出 NotBoundException 。
    从以下版本开始：
    1.1
    另请参见：
    Naming.lookup(String) ，
Naming.unbind(String) ，
Registry.lookup(String) ，
Registry.unbind(String) ，
Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NotBoundException​()
      构造一个没有指定详细消息的 NotBoundException 。
      NotBoundException​(String s)
      构造具有指定详细消息的 NotBoundException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NotBoundException

        public NotBoundException​()
        构造一个没有指定详细信息的 NotBoundException 。
        从以下版本开始：
        1.1

      • NotBoundException

        public NotBoundException​(String s)
        构造具有指定详细消息的 NotBoundException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Remote (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Interface Remote

  • All Known Subinterfaces:
    ActivationInstantiator ， ActivationMonitor ， ActivationSystem ， Activator ， DGC ， Registry ， RMIConnection ， RMIServer
    所有已知实现类：
    _Remote_Stub ， Activatable ， ActivationGroup ， ActivationGroup_Stub ， RemoteObject ， RemoteObjectInvocationHandler ， RemoteServer ， RemoteStub ， RMIConnectionImpl ， RMIConnectionImpl_Stub ， RMIIIOPServerImpl ， RMIJRMPServerImpl ， RMIServerImpl ， RMIServerImpl_Stub ， UnicastRemoteObject

    public interface Remote
    Remote 作为远程对象的任何对象都必须直接或间接实现此接口。 只有在“远程接口”中指定的方法，扩展java.rmi.Remote的接口才可远程使用。

    实现类可以实现任意数量的远程接口，并可以扩展其他远程实现类。 RMI提供了远程对象实现可以扩展的一些便利类，这有助于远程对象创建。 这些类别是java.rmi.server.UnicastRemoteObject和java.rmi.activation.Activatable 。

    有关RMI的完整详细信息，请参阅描述RMI API和系统的RMI Specification 。

    从以下版本开始：
    1.1
    另请参见：
    UnicastRemoteObject ， Activatable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RemoteException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class RemoteException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AccessException ， ActivateFailedException ， ActivityCompletedException ， ActivityRequiredException ， ConnectException ， ConnectIOException ， ExportException ， InvalidActivityException ， InvalidTransactionException ， MarshalException ， NoSuchObjectException ， ServerError ， ServerException ， ServerRuntimeException ， SkeletonMismatchException ， SkeletonNotFoundException ， StubNotFoundException ， TransactionRequiredException ， TransactionRolledbackException ， UnexpectedException ， UnknownHostException ， UnmarshalException

    public class RemoteException
extends IOException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。 远程接口的每种方法，扩展java.rmi.Remote的接口必须在其throws子句中列出RemoteException 。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 可以在施工时间提供并通过公共detail字段访问的“包裹的远程异常”现在被称为原因 ，并且可以通过Throwable.getCause()方法以及前述的“传统字段”来访问。

    调用方法Throwable.initCause(Throwable)上的一个实例RemoteException总是抛出IllegalStateException 。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      Throwable detail
      远程异常的原因。

    • 构造方法摘要

      构造方法
      Constructor 描述
      RemoteException​()
      构造一个 RemoteException 。
      RemoteException​(String s)
      构造具有指定详细消息的 RemoteException 。
      RemoteException​(String s, Throwable cause)
      构造一个具有指定的详细消息和原因的 RemoteException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回此异常的原因。
      String getMessage​()
      返回详细信息，包括原因的消息（如果有的话）的异常。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 字段详细信息

      • detail

        public Throwable detail
        远程异常的原因。

        该领域早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

    • 构造方法详细信息

      • RemoteException

        public RemoteException​()
        构造一个 RemoteException 。

      • RemoteException

        public RemoteException​(String s)
        构造具有指定详细消息的 RemoteException 。
        参数
        s - 详细信息

      • RemoteException

        public RemoteException​(String s,
                       Throwable cause)
        构造一个具有指定的详细信息和原因的RemoteException 。 该构造函数将detail字段设置为指定的Throwable 。
        参数
        s - 详细信息
        cause - 原因

    • 方法详细信息

      • getMessage

        public String getMessage​()
        返回详细信息，包括原因的消息（如果有的话）的异常。
        重写：
        getMessage在 Throwable
        结果
        详细信息

      • getCause

        public Throwable getCause​()
        返回此异常的原因。 此方法返回值为detail的字段。
        重写：
        getCause在 Throwable
        结果
        原因，可能是 null 。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RMISecurityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class RMISecurityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.SecurityException
            • java.rmi.RMISecurityException
  • All Implemented Interfaces:
    Serializable
    已过时。
    改用SecurityException 。 应用程式代码永远不应该直接引用这个类，而RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。

    @Deprecated
public class RMISecurityException
extends SecurityException
    一个 RMISecurityException表示在执行 java.rmi.RMISecurityManager的方法之一时发生安全异常。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      RMISecurityException​(String name)
      已过时。
      没有替换
      RMISecurityException​(String name, String arg)
      已过时。
      没有替换

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • RMISecurityException

        @Deprecated
public RMISecurityException​(String name)
        已过时。 没有替换
        构造一个 RMISecurityException的详细信息。
        参数
        name - 详细信息
        从以下版本开始：
        1.1

      • RMISecurityException

        @Deprecated
public RMISecurityException​(String name,
                            String arg)
        已过时。 没有替换
        构造一个 RMISecurityException的详细消息。
        参数
        name - 详细信息
        arg - 忽略
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RMISecurityManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class RMISecurityManager

  • java.lang.Object
    • java.lang.SecurityManager
      • java.rmi.RMISecurityManager
  • 已过时。
    改用SecurityManager 。

    @Deprecated
public class RMISecurityManager
extends SecurityManager
    RMISecurityManager实现与通过实施该策略的政策SecurityManager 。 RMI应用程序应该使用SecurityManager类或其他适当的SecurityManager实现而不是此类。 RMI的类加载器只有在设置了安全管理器后才会从远程位置下载类。
    Implementation Note:

    Applet通常运行在已经有安全管理器的容器中，因此通常不需要applet来设置安全管理器。 如果您有一个独立的应用程序，您可能需要设置一个SecurityManager以启用类下载。 这可以通过在您的代码中添加以下内容来完成。 （在RMI可以从远程主机下载代码之前需要执行它，因此很可能需要出现在应用程序的main方法中。）

       if (System.getSecurityManager() == null) { System.setSecurityManager(new SecurityManager()); }
    从以下版本开始：
    1.1

    • Field Summary

      • Fields inherited from class java.lang.SecurityManager

        inCheck

    • 构造方法摘要

      构造方法
      Constructor 描述
      RMISecurityManager​()
      已过时。
      构造新的 RMISecurityManager 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.lang.SecurityManager

        checkAccept, checkAccess, checkAccess, checkAwtEventQueueAccess, checkConnect, checkConnect, checkCreateClassLoader, checkDelete, checkExec, checkExit, checkLink, checkListen, checkMemberAccess, checkMulticast, checkMulticast, checkPackageAccess, checkPackageDefinition, checkPermission, checkPermission, checkPrintJobAccess, checkPropertiesAccess, checkPropertyAccess, checkRead, checkRead, checkRead, checkSecurityAccess, checkSetFactory, checkSystemClipboardAccess, checkTopLevelWindow, checkWrite, checkWrite, classDepth, classLoaderDepth, currentClassLoader, currentLoadedClass, getClassContext, getInCheck, getSecurityContext, getThreadGroup, inClass, inClassLoader

    • 构造方法详细信息

      • RMISecurityManager

        public RMISecurityManager​()
        已过时。
        构造新的 RMISecurityManager 。
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServerError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class ServerError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.ServerError
  • All Implemented Interfaces:
    Serializable

    public class ServerError
extends RemoteException
    甲ServerError被抛出作为远程方法调用的结果，当一个Error任而解编参数，执行远程方法本身，或编组返回值在处理服务器上的调用，被抛出。 A ServerError实例包含作为其原因的原始Error 。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      ServerError​(String s, Error err)
      构造具有指定的详细消息和嵌套错误的 ServerError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ServerError

        public ServerError​(String s,
                   Error err)
        构造具有指定的详细消息和嵌套错误的 ServerError 。
        参数
        s - 详细信息
        err - 嵌套错误
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class ServerException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.ServerException
  • All Implemented Interfaces:
    Serializable

    public class ServerException
extends RemoteException
    甲ServerException当被抛出作为远程方法调用的结果RemoteException在处理服务器上的调用，要么同时解编参数或执行远程方法本身被抛出。 A ServerException实例包含原始的RemoteException作为其原因。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      ServerException​(String s)
      构造具有指定详细消息的 ServerException 。
      ServerException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ServerException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ServerException

        public ServerException​(String s)
        构造具有指定详细消息的 ServerException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • ServerException

        public ServerException​(String s,
                       异常 ex)
        构造具有指定的详细消息和嵌套异常的 ServerException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServerRuntimeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class ServerRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.ServerRuntimeException
  • All Implemented Interfaces:
    Serializable
    已过时。
    没有替换

    @Deprecated
public class ServerRuntimeException
extends RemoteException
    从JDK 1.1执行的服务器执行时，抛出ServerRuntimeException作为远程方法调用的结果，当处理服务器上的调用时抛出一个RuntimeException ，或者在解组参数，执行远程方法本身或编组返回值时。 A ServerRuntimeException实例包含作为其原因发生的原始RuntimeException 。

    不会在Java 2平台v1.2或更高版本上执行的服务器中抛出ServerRuntimeException 。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      ServerRuntimeException​(String s, 异常 ex)
      已过时。
      没有替换

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ServerRuntimeException

        @Deprecated
public ServerRuntimeException​(String s,
                              异常 ex)
        已过时。 没有替换
        构造具有指定的详细消息和嵌套异常的 ServerRuntimeException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StubNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class StubNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.StubNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class StubNotFoundException
extends RemoteException
    如果远程对象导出时无法找到有效的存根类，则抛出StubNotFoundException 。 当通过java.rmi.activation.Activatable.register方法注册可激活对象时，也可以抛出A StubNotFoundException 。
    从以下版本开始：
    1.1
    另请参见：
    UnicastRemoteObject ， Activatable ， Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      StubNotFoundException​(String s)
      构造具有指定详细消息的 StubNotFoundException 。
      StubNotFoundException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 StubNotFoundException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • StubNotFoundException

        public StubNotFoundException​(String s)
        构造具有指定详细消息的 StubNotFoundException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • StubNotFoundException

        public StubNotFoundException​(String s,
                             异常 ex)
        构造具有指定的详细消息和嵌套异常的 StubNotFoundException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnexpectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class UnexpectedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.UnexpectedException
  • All Implemented Interfaces:
    Serializable

    public class UnexpectedException
extends RemoteException
    如果远程方法调用的客户机接收到调用的结果，那么抛出一个 UnexpectedException ，该检查异常不在远程接口的方法的 throws子句中声明的检查的异常类型中。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnexpectedException​(String s)
      构造具有指定详细消息的 UnexpectedException 。
      UnexpectedException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 UnexpectedException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnexpectedException

        public UnexpectedException​(String s)
        构造具有指定详细消息的 UnexpectedException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • UnexpectedException

        public UnexpectedException​(String s,
                           异常 ex)
        构造具有指定的详细消息和嵌套异常的 UnexpectedException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnknownHostException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class UnknownHostException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.UnknownHostException
  • All Implemented Interfaces:
    Serializable

    public class UnknownHostException
extends RemoteException
    如果在创建与远程主机的远程方法调用的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownHostException​(String s)
      构造具有指定详细消息的 UnknownHostException 。
      UnknownHostException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 UnknownHostException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownHostException

        public UnknownHostException​(String s)
        构造具有指定详细消息的 UnknownHostException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • UnknownHostException

        public UnknownHostException​(String s,
                            异常 ex)
        构造具有指定的详细消息和嵌套异常的 UnknownHostException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnmarshalException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi

Class UnmarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.UnmarshalException
  • All Implemented Interfaces:
    Serializable

    public class UnmarshalException
extends RemoteException
    如果发生以下任何一种UnmarshalException可以在解组远程方法调用的参数或结果时抛出UnmarshalException ：
    • 如果在解组调用头部时发生异常
    • 如果返回值的协议无效
    • 如果java.io.IOException发生解组参数（在服务器端）或返回值（在客户端）。
    • 如果在解组参数或返回值期间发生java.lang.ClassNotFoundException
    • 如果没有骨架可以在服务器端加载; 请注意，在1.1 stub协议中需要骨架，但不在1.2 stub协议中。
    • 如果方法哈希无效（即，缺少方法）。
    • 如果在未组态远程对象的存根时，如果无法创建远程引用对象。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnmarshalException​(String s)
      构造具有指定详细消息的 UnmarshalException 。
      UnmarshalException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 UnmarshalException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnmarshalException

        public UnmarshalException​(String s)
        构造具有指定详细消息的 UnmarshalException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • UnmarshalException

        public UnmarshalException​(String s,
                          异常 ex)
        构造具有指定的详细消息和嵌套异常的 UnmarshalException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.rmi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.rmi

  • Packages that use java.rmi
    软件包 描述
    java.rmi
    提供RMI包。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.activity
    包含ORB机械在解组时抛出的活动服务相关异常。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.rmi
    包含RMI-IIOP的用户API。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.transaction
    包含ORB机械在解组期间抛出的三个异常。
    org.omg.stub.java.rmi
    包含 java.rmi软件包中出现的远程类型的RMI-IIOP存根。
  • Classes in java.rmi used by java.rmi
    Class 描述
    AlreadyBoundException
    如果尝试将注册表中的对象绑定到已经具有关联绑定的名称，则抛出 AlreadyBoundException 。
    NotBoundException
    如果尝试在注册表中查找或取消绑定没有关联绑定的名称，则抛出 NotBoundException 。
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
  • Classes in java.rmi used by java.rmi.activation
    Class 描述
    MarshalledObject
    A MarshalledObject包含具有给它的构造函数的对象的序列化表示的字节流。
    NoSuchObjectException
    如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
  • Classes in java.rmi used by java.rmi.dgc
    Class 描述
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
  • Classes in java.rmi used by java.rmi.registry
    Class 描述
    AccessException
    一个 AccessException通过一定的方法抛出 java.rmi.Naming类（具体 bind ， rebind ，和 unbind ）和方法 java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。
    AlreadyBoundException
    如果尝试将注册表中的对象绑定到已经具有关联绑定的名称，则抛出 AlreadyBoundException 。
    NotBoundException
    如果尝试在注册表中查找或取消绑定没有关联绑定的名称，则抛出一个 NotBoundException 。
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
    UnknownHostException
    如果在创建与远程主机的远程方法调用的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。
  • Classes in java.rmi used by java.rmi.server
    Class 描述
    NoSuchObjectException
    如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
  • Classes in java.rmi used by javax.activity
    Class 描述
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
  • Classes in java.rmi used by javax.management.remote.rmi
    Class 描述
    MarshalledObject
    A MarshalledObject包含具有给其构造函数的对象的序列化表示的字节流。
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
  • Classes in java.rmi used by javax.rmi
    Class 描述
    NoSuchObjectException
    如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
  • Classes in java.rmi used by javax.rmi.CORBA
    Class 描述
    NoSuchObjectException
    如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
  • Classes in java.rmi used by javax.transaction
    Class 描述
    RemoteException
    A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
  • Classes in java.rmi used by org.omg.stub.java.rmi
    Class 描述
    Remote
    Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Activatable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class Activatable

  • java.lang.Object
    • java.rmi.server.RemoteObject
      • java.rmi.server.RemoteServer
        • java.rmi.activation.Activatable
  • All Implemented Interfaces:
    Serializable ， Remote

    public abstract class Activatable
extends RemoteServer
    Activatable类为需要持久访问的远程对象提供支持，并且可以由系统激活。

    对于构造函数和静态的exportObject方法，如UnicastRemoteObject所述，获取要导出的远程对象的存根。

    明确序列化此类的实例的尝试将失败。

    从以下版本开始：
    1.2

    • Field Summary

      • Fields inherited from class java.rmi.server.RemoteObject

        ref

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Activatable​(String location, MarshalledObject<?> data, boolean restart, int port)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并使用指定的端口导出对象。
      protected Activatable​(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并导出具有指定端口的对象以及指定的客户端和服务器套接字工厂。
      protected Activatable​(ActivationID id, int port)
      用于在指定端口上激活/导出对象的构造方法。
      protected Activatable​(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      用于在指定端口上激活/导出对象的构造方法。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static ActivationID exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port)
      为指定的对象注册激活描述符（具有指定的位置，数据和重新启动模式），并使用指定的端口导出该对象。
      static ActivationID exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。
      static Remote exportObject​(Remote obj, ActivationID id, int port)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      static Remote exportObject​(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      protected ActivationID getID​()
      返回对象的激活标识符。
      static boolean inactive​(ActivationID id)
      通知系统当前激活的对象 id当前处于非活动状态。
      static Remote register​(ActivationDesc desc)
      注册可激活的远程对象的对象描述符，以便可以按需激活。
      static boolean unexportObject​(Remote obj, boolean force)
      从RMI运行时中删除远程对象obj。
      static void unregister​(ActivationID id)
      id与 id关联的激活描述符的先前注册。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.server.RemoteObject

        equals, getRef, hashCode, toString, toStub

      • Methods inherited from class java.rmi.server.RemoteServer

        getClientHost, getLog, setLog

    • 构造方法详细信息

      • Activatable

        protected Activatable​(String location,
                      MarshalledObject<?> data,
                      boolean restart,
                      int port)
               throws ActivationException,
                      RemoteException
        通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并使用指定的端口导出对象。

        注意：强烈建议不要使用注册和导出可激活远程对象的Activatable构造函数，因为注册和导出远程对象的操作不能保证是原子的。 相反，应用程序应该注册激活描述符并分别导出远程对象，以便正常处理异常。

        此方法使用此对象调用exportObject方法，以及指定的位置，数据，重新启动模式和端口。 对getID()的后续调用将返回从呼叫返回的激活标识为exportObject 。

        参数
        location - 此对象的类的位置
        data - 对象的初始化数据
        port - 导出对象的端口（如果端口= 0，则使用匿名端口）
        restart - 如果为true，则当激活程序重新启动或对象的激活组在意外崩溃后重新启动时，对象将重新启动（重新激活）; 如果是虚假的，对象只能按需激活。 指定restart为true不强制初始立即激活新注册的对象; 初始激活是懒惰的。
        异常
        ActivationException - 如果对象注册失败。
        RemoteException - 如果以下任何一种失败：a）使用激活系统注册对象，或b）将对象导出到RMI运行时。
        UnsupportedOperationException - 当且仅当此实现不支持激活时。
        从以下版本开始：
        1.2

      • Activatable

        protected Activatable​(String location,
                      MarshalledObject<?> data,
                      boolean restart,
                      int port,
                      RMIClientSocketFactory csf,
                      RMIServerSocketFactory ssf)
               throws ActivationException,
                      RemoteException
        通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并导出具有指定端口的对象以及指定的客户端和服务器套接字工厂。

        注意：使用注册和导出可激活远程对象的Activatable构造函数是非常不鼓励的，因为注册和导出远程对象的操作不能保证是原子的。 相反，应用程序应该注册激活描述符并分别导出远程对象，以便正常处理异常。

        此方法使用此对象以及指定的位置，数据，重新启动模式，端口以及客户端和服务器套接字工厂调用exportObject方法。 对getID()的后续调用将返回从呼叫返回的激活标识为exportObject 。

        参数
        location - 此对象的类的位置
        data - 对象的初始化数据
        restart - 如果为true，则当激活程序重新启动或对象的激活组在意外崩溃后重新启动时，对象将重新启动（重新激活）; 如果是虚假的，对象只能按需激活。 指定restart是true不会强制新登记对象的初始立即激活; 初始激活是懒惰的。
        port - 导出对象的端口（如果端口= 0，则使用匿名端口）
        csf - 用于调用远程对象的客户端套接字工厂
        ssf - 用于接收远程调用的服务器端套接字工厂
        异常
        ActivationException - 如果对象注册失败。
        RemoteException - 如果以下任何一种失败：a）使用激活系统注册对象，或b）将对象导出到RMI运行时。
        UnsupportedOperationException - 当且仅当此实现不支持激活时。
        从以下版本开始：
        1.2

      • Activatable

        protected Activatable​(ActivationID id,
                      int port)
               throws RemoteException
        用于在指定端口上激活/导出对象的构造方法。 一个“可激活的”远程对象必须具有一个构造函数，它需要两个参数：
        • 对象的激活标识符（ ActivationID ），和
        • 对象的初始化数据（一个MarshalledObject ）。

        当通过上述两个参数构造函数激活时，此类的具体子类必须调用此构造函数。 作为构造的副作用，远程对象“导出”到RMI运行时（在指定的port ），并且可用于接受来自客户端的来电。

        参数
        id - 对象的激活标识符
        port - 导出对象的端口号
        异常
        RemoteException - 如果将对象导出到RMI运行时失败
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • Activatable

        protected Activatable​(ActivationID id,
                      int port,
                      RMIClientSocketFactory csf,
                      RMIServerSocketFactory ssf)
               throws RemoteException
        用于在指定端口上激活/导出对象的构造方法。 一个“可激活的”远程对象必须具有一个构造函数，它需要两个参数：
        • 对象的激活标识符（ ActivationID ）和
        • 对象的初始化数据（一个MarshalledObject ）。

        当通过上述两个参数构造函数激活时，此类的具体子类必须调用此构造函数。 作为构造的副作用，远程对象“导出”到RMI运行时（在指定的port ），可用于接受来自客户端的来电。

        参数
        id - 对象的激活标识符
        port - 导出对象的端口号
        csf - 用于调用远程对象的客户端套接字工厂
        ssf - 用于接收远程调用的服务器端套接字工厂
        异常
        RemoteException - 如果将对象导出到RMI运行时失败
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

    • 方法详细信息

      • getID

        protected ActivationID getID​()
        返回对象的激活标识符。 该方法受到保护，因此只有子类可以获取对象的标识符。
        结果
        对象的激活标识符
        从以下版本开始：
        1.2

      • register

        public static Remote register​(ActivationDesc desc)
                       throws UnknownGroupException,
                              ActivationException,
                              RemoteException
        注册可激活的远程对象的对象描述符，以便可以按需激活。
        参数
        desc - 对象的描述符
        结果
        可激活的远程对象的存根
        异常
        UnknownGroupException -如果组ID desc不与激活系统注册
        ActivationException - 如果激活系统未运行
        RemoteException - 如果远程调用失败
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • inactive

        public static boolean inactive​(ActivationID id)
                        throws UnknownObjectException,
                               ActivationException,
                               RemoteException
        通知系统当前激活的对象id当前处于非活动状态。 如果对象当前处于活动状态，则对象将从RMI运行时“取消导出”（仅当没有挂起或正在进行的呼叫时），因此该对象将无法再接收来电。 此呼叫通知该虚拟机的ActivationGroup对象处于非活动状态，反过来通知其ActivationMonitor。 如果此调用成功完成，对激活程序的后续激活请求将导致对象重新激活。 如果该对象被认为是活动的，但已经自身已经取消导出，操作可能仍然会成功。
        参数
        id - 对象的激活标识符
        结果
        如果操作成功，则为true（如果当前已知已激活的对象已被取消导出或当前导出并且没有待处理/执行调用，则操作将成功）; 如果对象有挂起/执行的调用，则返回false，在这种情况下，它不能被禁用
        异常
        UnknownObjectException - 如果对象不知道（它可能已经处于非活动状态）
        ActivationException - 如果组不活动
        RemoteException - 如果呼叫通知监视器出现故障
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • unregister

        public static void unregister​(ActivationID id)
                       throws UnknownObjectException,
                              ActivationException,
                              RemoteException
        id与id相关联的激活描述符的先前注册。 一个对象不能再通过id激活了。
        参数
        id - 对象的激活标识符
        异常
        UnknownObjectException - 如果对象（ id ）未知
        ActivationException - 如果激活系统未运行
        RemoteException - 如果远程调用激活系统失败
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • exportObject

        public static ActivationID exportObject​(Remote obj,
                                        String location,
                                        MarshalledObject<?> data,
                                        boolean restart,
                                        int port)
                                 throws ActivationException,
                                        RemoteException
        为指定的对象注册激活描述符（具有指定的位置，数据和重新启动模式），并使用指定的端口导出该对象。

        注意： Activatable不鼓励使用此方法（以及注册和导出可激活的远程对象的Activatable构造函数），因为注册和导出远程对象的操作不能保证是原子的。 相反，应用程序应该注册激活描述符并分别导出远程对象，以便正常处理异常。

        此方法使用指定的对象，位置，数据，重新启动模式和端口调用exportObject方法，并为客户端和服务器套接字工厂null ，然后返回生成的激活标识符。

        参数
        obj - 要导出的对象
        location - 对象的代码位置
        data - 对象的引导数据
        restart - 如果为true，则当启动程序重新启动或对象的激活组在意外崩溃后重新启动时，对象将重新启动（重新激活）; 如果是虚假的，对象只能按需激活。 指定restart是true不会强制新登记对象的初始立即激活; 初始激活是懒惰的。
        port - 导出对象的端口（如果port = 0，则使用匿名端口）
        结果
        从注册描述符获得的激活标识符， desc与激活系统错误的组
        异常
        ActivationException - 如果激活组未激活
        RemoteException - 如果对象注册或导出失败
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • exportObject

        public static ActivationID exportObject​(Remote obj,
                                        String location,
                                        MarshalledObject<?> data,
                                        boolean restart,
                                        int port,
                                        RMIClientSocketFactory csf,
                                        RMIServerSocketFactory ssf)
                                 throws ActivationException,
                                        RemoteException
        注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。

        注意： Activatable不鼓励使用此方法（以及注册和导出可激活的远程对象的Activatable构造函数），因为注册和导出远程对象的操作不能保证是原子的。 相反，应用程序应该注册激活描述符并分别导出远程对象，以便正常处理异常。

        该方法首先注册指定对象的激活描述符，如下所示。 它通过调用方法ActivationGroup.getSystem获得激活系统。 然后，此方法获得的ActivationID通过调用激活系统的用于物体registerObject与方法ActivationDesc与指定对象的类名构成，指定位置，数据和重启模式。 如果获取激活系统或注册激活描述符发生异常，该异常将被抛出给调用者。

        接下来，该方法通过调用具有指定远程对象的exportObject方法，从注册获取的激活标识符，指定的端口以及指定的客户端和服务器套接字工厂来导出对象。 如果导出对象发生异常，则此方法将通过使用激活标识符调用激活系统的unregisterObject方法来尝试注销激活标识符（从注册获取）。 如果异常发生取消注册标识符，该异常将被忽略，导出对象的原始异常被抛出到调用者。

        最后，此方法使用激活标识符和指定的远程对象调用此VM中的激活组上的activeObject方法，并将激活标识符返回给调用者。

        参数
        obj - 要导出的对象
        location - 对象的代码位置
        data - 对象的引导数据
        restart - 如果为true，当启动程序重新启动或对象的激活组在意外崩溃后重新启动时，对象将重新启动（重新激活）; 如果是虚假的，对象只能按需激活。 指定restart是true不会强制新登记对象的初始立即激活; 初始激活是懒惰的。
        port - 导出对象的端口（如果端口= 0，则使用匿名端口）
        csf - 用于调用远程对象的客户端套接字工厂
        ssf - 用于接收远程调用的服务器端套接字工厂
        结果
        从激活系统注册描述符获得的激活标识符
        异常
        ActivationException - 如果激活组未激活
        RemoteException - 如果对象注册或导出失败
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • exportObject

        public static Remote exportObject​(Remote obj,
                                  ActivationID id,
                                  int port)
                           throws RemoteException
        将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。 如果port为零，则对象将导出在匿名端口上。

        在激活期间，此exportObject方法应由“可激活”对象显式调用，不会扩展Activatable类。 不需要扩展Activatable类的对象直接调用此方法，因为在构造期间导出对象。

        参数
        obj - 远程对象实现
        id - 对象的激活标识符
        port - 导出对象的端口（如果port = 0，则使用匿名端口）
        结果
        可激活的远程对象的存根
        异常
        RemoteException - 如果对象导出失败
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • exportObject

        public static Remote exportObject​(Remote obj,
                                  ActivationID id,
                                  int port,
                                  RMIClientSocketFactory csf,
                                  RMIServerSocketFactory ssf)
                           throws RemoteException
        将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。 如果port为零，则对象将导出在匿名端口上。

        在激活期间，此exportObject方法应由“可激活”对象显式调用，不会扩展Activatable类。 不需要扩展Activatable类的对象直接调用此方法，因为在构造过程中导出对象。

        参数
        obj - 远程对象实现
        id - 对象的激活标识符
        port - 导出对象的端口（如果port = 0，则使用匿名端口）
        csf - 用于调用远程对象的客户端套接字工厂
        ssf - 用于接收远程调用的服务器端套接字工厂
        结果
        可激活的远程对象的存根
        异常
        RemoteException - 如果对象导出失败
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • unexportObject

        public static boolean unexportObject​(Remote obj,
                                     boolean force)
                              throws NoSuchObjectException
        从RMI运行时中删除远程对象obj。 如果成功，对象不能再接受传入的RMI调用。 如果force参数为true，即使有远程对象的挂起调用或远程对象仍在进行调用，该对象也被强制取消导出。 如果force参数为false，则只有当对象没有待处理或正在进行调用时，对象才会取消导出。
        参数
        obj - 要取消导出的远程对象
        force - 如果为true，即使有待处理或正在进行的调用，也会force对象; 如果为false，则只有在没有待处理或正在进行的调用时，才会取消对象的输出
        结果
        如果操作成功，则为true，否则为false
        异常
        NoSuchObjectException - 如果远程对象当前未导出
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivateFailedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class ActivateFailedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.activation.ActivateFailedException
  • All Implemented Interfaces:
    Serializable

    public class ActivateFailedException
extends RemoteException
    在远程调用可激活对象时激活失败时，RMI运行时抛出此异常。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivateFailedException​(String s)
      构造具有指定详细消息的 ActivateFailedException 。
      ActivateFailedException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ActivateFailedException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ActivateFailedException

        public ActivateFailedException​(String s)
        构造具有指定详细消息的 ActivateFailedException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.2

      • ActivateFailedException

        public ActivateFailedException​(String s,
                               异常 ex)
        构造具有指定的详细消息和嵌套异常的 ActivateFailedException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationDesc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class ActivationDesc

  • java.lang.Object
    • java.rmi.activation.ActivationDesc
  • All Implemented Interfaces:
    Serializable

    public final class ActivationDesc
extends Object
implements Serializable
    激活描述符包含激活对象所需的信息：
    • 对象的组标识符，
    • 该对象的全限定类名，
    • 对象的代码位置（类的位置），代码库URL路径，
    • 对象的重启“模式”，并且，
    • 一个可以包含对象特定初始化数据的“编组”对象。

    可以使用激活系统注册的描述符来重新创建/激活由描述符指定的对象。 对象描述符中的MarshalledObject作为第二个参数传递给远程对象的构造函数，以便在重新初始化/激活期间使用对象。

    从以下版本开始：
    1.2
    另请参见：
    Activatable ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivationDesc​(String className, String location, MarshalledObject<?> data)
      为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
      ActivationDesc​(String className, String location, MarshalledObject<?> data, boolean restart)
      为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
      ActivationDesc​(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
      为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
      ActivationDesc​(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
      为类名为 className的对象构造一个对象描述符，该对象描述符可以从代码 location加载，其初始化信息为 data 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      比较两个激活描述符的内容相等性。
      String getClassName​()
      返回此描述符指定的对象的类名。
      MarshalledObject<?> getData​()
      返回一个包含由该描述符指定的对象的初始化/激活数据的“编组对象”。
      ActivationGroupID getGroupID​()
      返回由此描述符指定的对象的组标识符。
      String getLocation​()
      返回由此描述符指定的对象的代码位置。
      boolean getRestartMode​()
      返回与此激活描述符关联的对象的“重启”模式。
      int hashCode​()
      返回相同的hashCode类似的 ActivationDesc s。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ActivationDesc

        public ActivationDesc​(String className,
                      String location,
                      MarshalledObject<?> data)
               throws ActivationException
        为类名为className的对象构造一个对象描述符，可以从代码location加载，其初始化信息为data 。 如果使用此构造方法，则groupID默认为此VM的当前标识为ActivationGroup 。 具有相同ActivationGroupID所有对象在同一个虚拟机中被激活。

        请注意，使用此构造函数创建的描述符指定的对象只能根据需要激活（默认情况下，重新启动模式为false ）。 如果可激活的对象需要重新启动服务，请使用ActivationDesc构造函数中的一个，该构造函数采用布尔参数restart 。

        如果此VM没有当前激活组，此构造函数将抛出ActivationException 。 要创建ActivationGroup使用ActivationGroup.createGroup方法。

        参数
        className - 对象的完全包限定类名
        location - 对象的代码位置（从该类加载的位置）
        data - 对象的初始化（激活）数据以编组形式包含。
        异常
        ActivationException - 如果当前组不存在
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • ActivationDesc

        public ActivationDesc​(String className,
                      String location,
                      MarshalledObject<?> data,
                      boolean restart)
               throws ActivationException
        为类名为className的对象构造一个对象描述符，可以从代码location加载，其初始化信息为data 。 如果使用了此形式的构造函数，那么groupID默认为此VM的ActivationGroup的当前ID。 具有相同ActivationGroupID所有对象在同一虚拟机中被激活。

        如果此虚拟机没有当前激活组，此构造函数将抛出ActivationException 。 要创建一个ActivationGroup使用ActivationGroup.createGroup方法。

        参数
        className - 对象的完全包合格类名
        location - 对象的代码位置（从该类加载的位置）
        data - 对象的初始化（激活）数据以编组形式包含。
        restart - 如果为true，则当激活程序重新启动或者在意外崩溃后重新启动对象的激活组时，对象将重新启动（重新激活）; 如果是虚假的，对象只能按需激活。 指定restart为true不强制初始立即激活新注册的对象; 初始激活是懒惰的。
        异常
        ActivationException - 如果当前组不存在
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • ActivationDesc

        public ActivationDesc​(ActivationGroupID groupID,
                      String className,
                      String location,
                      MarshalledObject<?> data)
        为类名为className的对象构造一个对象描述符，该对象描述符可以从代码location加载，其初始化信息为data 。 具有相同groupID所有对象在同一个Java VM中被激活。

        请注意，使用此构造函数创建的描述符指定的对象只能根据需要激活（默认情况下，重新启动模式为false ）。 如果可激活的对象需要重新启动服务，请使用ActivationDesc构造函数中的一个，该构造函数采用布尔参数restart 。

        参数
        groupID - 组的标识符（从注册ActivationSystem.registerGroup方法获得）。 该组指示应激活对象的VM。
        className - 对象的完全包装合格的类名
        location - 对象的代码位置（从该类加载的位置）
        data - 对象的初始化（激活）数据以编组形式包含。
        异常
        IllegalArgumentException - 如果 groupID为空
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • ActivationDesc

        public ActivationDesc​(ActivationGroupID groupID,
                      String className,
                      String location,
                      MarshalledObject<?> data,
                      boolean restart)
        为类名为className的对象构造一个对象描述符，可以从代码location加载，其初始化信息为data 。 具有相同groupID所有对象在相同的Java VM中被激活。
        参数
        groupID - 组的标识符（从注册ActivationSystem.registerGroup方法获得）。 该组指示应激活对象的VM。
        className - 对象的完全包装合格的类名
        location - 对象的代码位置（从该类加载的位置）
        data - 对象的初始化（激活）数据以编组形式包含。
        restart - 如果为true，则当激活器重新启动或者在意外崩溃后重新启动对象的激活组时，对象将重新启动（重新激活）; 如果是虚假的，对象只能按需激活。 指定restart是true不会强制新登记对象的初始立即激活; 初始激活是懒惰的。
        异常
        IllegalArgumentException - 如果 groupID为空
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

    • 方法详细信息

      • getGroupID

        public ActivationGroupID getGroupID​()
        返回由此描述符指定的对象的组标识符。 组提供了将对象聚合到单个Java虚拟机中的方法。 RMI使用相同的虚拟机中的groupID创建/激活对象。
        结果
        组标识符
        从以下版本开始：
        1.2

      • getClassName

        public String getClassName​()
        返回此描述符指定的对象的类名。
        结果
        类名
        从以下版本开始：
        1.2

      • getLocation

        public String getLocation​()
        返回由此描述符指定的对象的代码位置。
        结果
        代码位置
        从以下版本开始：
        1.2

      • getData

        public MarshalledObject<?> getData​()
        返回一个包含由该描述符指定的对象的初始化/激活数据的“编组对象”。
        结果
        对象具体的“初始化”数据
        从以下版本开始：
        1.2

      • getRestartMode

        public boolean getRestartMode​()
        返回与此激活描述符关联的对象的“重启”模式。
        结果
        如果与该激活描述符相关联的可激活对象在守护程序出现时或者在意外崩溃后重新启动对象的组，则通过激活守护程序重新启动; 否则返回false，这意味着该对象仅通过方法调用按需激活。 请注意，如果重新启动模式为true ，则激活器不强制初始立即激活新注册的对象; 初始激活是懒惰的。
        从以下版本开始：
        1.2

      • equals

        public boolean equals​(Object obj)
        比较两个激活描述符的内容相等性。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        如果这些对象相等则为true; 否则为假。
        从以下版本开始：
        1.2
        另请参见：
        Hashtable

      • hashCode

        public int hashCode​()
        返回相同的hashCode类似的 ActivationDesc s。
        重写：
        hashCode在 Object
        结果
        一个整数
        另请参见：
        Hashtable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class ActivationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.rmi.activation.ActivationException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    UnknownGroupException ， UnknownObjectException

    public class ActivationException
extends 异常
    激活界面使用的常规异常。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 可以在施工时间提供并通过公共detail字段访问的“详细例外”现在被称为原因 ，并且可以通过Throwable.getCause()方法以及前述的“传统字段”来访问。

    调用方法Throwable.initCause(Throwable)上的一个实例ActivationException总是抛出IllegalStateException 。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      Throwable detail
      激活异常的原因。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivationException​()
      构造一个 ActivationException 。
      ActivationException​(String s)
      构造具有指定详细消息的 ActivationException 。
      ActivationException​(String s, Throwable cause)
      构造一个具有指定的详细信息和原因的 ActivationException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回此异常的原因。
      String getMessage​()
      返回详细信息，包括原因的消息（如果有的话）的异常。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 字段详细信息

      • detail

        public Throwable detail
        激活异常的原因。

        该领域早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

    • 构造方法详细信息

      • ActivationException

        public ActivationException​()
        构造一个 ActivationException 。

      • ActivationException

        public ActivationException​(String s)
        构造具有指定详细消息的 ActivationException 。
        参数
        s - 详细信息

      • ActivationException

        public ActivationException​(String s,
                           Throwable cause)
        构造一个具有指定的详细信息和原因的ActivationException 。 此构造函数将detail字段设置为指定的Throwable 。
        参数
        s - 详细信息
        cause - 原因

    • 方法详细信息

      • getMessage

        public String getMessage​()
        返回详细信息，包括原因的消息（如果有的话）的异常。
        重写：
        getMessage在 Throwable
        结果
        详细信息

      • getCause

        public Throwable getCause​()
        返回此异常的原因。 此方法返回detail字段的值。
        重写：
        getCause在 Throwable
        结果
        原因，可能是 null 。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ActivationGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class ActivationGroup

  • java.lang.Object
    • java.rmi.server.RemoteObject
      • java.rmi.server.RemoteServer
        • java.rmi.server.UnicastRemoteObject
          • java.rmi.activation.ActivationGroup
  • All Implemented Interfaces:
    Serializable ， ActivationInstantiator ， Remote

    public abstract class ActivationGroup
extends UnicastRemoteObject
implements ActivationInstantiator
    一个ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其ActivationMonitor何时：其对象变为活动或非活动，或组作为一个整体变为不活动。

    一个ActivationGroup 最初是通过以下几种方式之一创建的：

    • 作为创建ActivationDesc没有明确的ActivationGroupID用于组中的第一个可激活对象，或
    • 通过ActivationGroup.createGroup方法
    • 作为激活ActivationGroupDesc仅注册的组中的第一个对象的ActivationGroupDesc 。

    只有激活者才能重新创建一个ActivationGroup 。 激活器根据需要产生一个单独的VM（例如，作为一个子进程）为每个注册的激活组，并将激活请求指向适当的组。 实现具体如何产生虚拟机。 通过ActivationGroup.createGroup静态方法创建一个激活组。 createGroup方法对要创建的组有两个要求：1）该组必须是ActivationGroup的具体子类，2）组必须具有两个参数的构造函数：

    • 该集团的ActivationGroupID ，和
    • 该组的初始化数据（在java.rmi.MarshalledObject ）

    当创建的默认实现ActivationGroup将覆盖与性能的系统属性要求其当ActivationGroupDesc创建，并会设置一个SecurityManager作为默认的系统安全管理。 如果您的应用程序要求当对象在组中被激活时设置特定的属性，应用程序应该创建一个特殊Properties包含这些属性的对象，然后创建一个ActivationGroupDesc与Properties对象，并使用ActivationGroup.createGroup创建任何前ActivationDesc默认前S（创建ActivationGroupDesc ）。 如果您的应用程序需要使用SecurityManager以外的安全管理器，则在ActivativationGroupDescriptor属性列表中，您可以将java.security.manager属性设置为要安装的安全管理器的名称。

    从以下版本开始：
    1.2
    另请参见：
    ActivationInstantiator ， ActivationGroupDesc ， ActivationGroupID ， Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.server.RemoteObject

        ref

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ActivationGroup​(ActivationGroupID groupID)
      构造具有给定激活组标识符的激活组。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected void activeObject​(ActivationID id, MarshalledObject<? extends Remote> mobj)
      这个受保护的方法对于子类来说使得 activeObject回调到组的监视器是必要的。
      abstract void activeObject​(ActivationID id, Remote obj)
      当对象被导出（由 Activatable对象构造或显式调用到 Activatable.exportObject时），将调用该组的 activeObject方法。
      static ActivationGroup createGroup​(ActivationGroupID id, ActivationGroupDesc desc, long incarnation)
      创建并设置当前虚拟机的激活组。
      static ActivationGroupID currentGroupID​()
      返回当前激活组的标识符。
      static ActivationSystem getSystem​()
      返回VM的激活系统。
      protected void inactiveGroup​()
      这个受保护的方法对于子类来说使 inactiveGroup回调到组的监视器是必要的。
      boolean inactiveObject​(ActivationID id)
      该组的 inactiveObject方法通过调用 Activatable.inactive方法间接调用。
      static void setSystem​(ActivationSystem system)
      设置VM的激活系统。

      • Methods inherited from interface java.rmi.activation.ActivationInstantiator

        newInstance

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.server.RemoteObject

        equals, getRef, hashCode, toString, toStub

      • Methods inherited from class java.rmi.server.RemoteServer

        getClientHost, getLog, setLog

      • Methods inherited from class java.rmi.server.UnicastRemoteObject

        clone, exportObject, exportObject, exportObject, exportObject, exportObject, unexportObject

    • 构造方法详细信息

      • ActivationGroup

        protected ActivationGroup​(ActivationGroupID groupID)
                   throws RemoteException
        构造具有给定激活组标识符的激活组。 该组出口为java.rmi.server.UnicastRemoteObject 。
        参数
        groupID - 组的标识符
        异常
        RemoteException - 如果此组无法导出
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

    • 方法详细信息

      • inactiveObject

        public boolean inactiveObject​(ActivationID id)
                       throws ActivationException,
                              UnknownObjectException,
                              RemoteException
        该组的inactiveObject方法通过调用Activatable.inactive方法间接调用。 远程对象实现必须在该对象停用时调用Activatable的inactive方法（该对象认为它不再处于活动状态）。 如果对象在停用时不调用Activatable.inactive ，则该对象永远不会被垃圾回收，因为该组对其创建的对象保持强烈引用。

        该组的inactiveObject方法从RMI运行时inactiveObject导出远程对象，以使对象不再能够接收传入的RMI调用。 如果对象没有挂起或执行调用，对象将只会被取消导出。 ActivationGroup的子类必须覆盖此方法并取消导出该对象。

        从RMI运行时中删除对象后，组必须通知其ActivationMonitor （通过监视器的inactiveObject方法）远程对象当前未处于活动状态，以便远程对象将在后续激活请求时由激活程序重新激活。

        该方法只是通知组的监视器对象是否处于非活动状态。 由ActivationGroup的具体子类来满足解除对象的附加要求。

        参数
        id - 对象的激活标识符
        结果
        如果对象成功停用，则为true; 否则返回false。
        异常
        UnknownObjectException - 如果对象未知（可能已处于非活动状态）
        RemoteException - 如果呼叫通知监视器出现故障
        ActivationException - 如果组不活动
        从以下版本开始：
        1.2

      • activeObject

        public abstract void activeObject​(ActivationID id,
                                  Remote obj)
                           throws ActivationException,
                                  UnknownObjectException,
                                  RemoteException
        当对象被导出（通过 Activatable对象构造或显式调用到 Activatable.exportObject时，将调用该组的 activeObject方法。该组必须通知其 ActivationMonitor该对象是活动的（通过监视器的 activeObject方法），如果该组尚未完成所以。
        参数
        id - 对象的标识符
        obj - 远程对象实现
        异常
        UnknownObjectException - 如果对象未注册
        RemoteException - 如果呼叫通知监视器失败
        ActivationException - 如果组不活动
        从以下版本开始：
        1.2

      • createGroup

        public static ActivationGroup createGroup​(ActivationGroupID id,
                                          ActivationGroupDesc desc,
                                          long incarnation)
                                   throws ActivationException
        创建并设置当前虚拟机的激活组。 激活组只能在当前设置时才能设置。 当Activator启动重新创建激活组以便执行传入的activate请求时，使用createGroup方法设置激活组。 必须首先向ActivationSystem注册，才能通过此方法创建。

        由指定的组类ActivationGroupDesc必须的具体子类ActivationGroup并具有公共构造两个参数： ActivationGroupID为组和MarshalledObject含有组的初始化数据（从所获得的ActivationGroupDesc 。

        如果ActivationGroupDesc指定的组类名称为null ，则该方法将表现为组描述符包含默认激活组实现类的名称。

        请注意，如果您的应用程序创建自己的自定义激活组，则必须为该组设置安全管理器。 否则在组中无法激活对象。 默认设置为SecurityManager 。

        如果组VM中已经设置了安全管理器，则该方法首先调用安全管理器的checkSetFactory方法。 这可能会导致一个SecurityException 。 如果您的应用程序需要设置不同的安全管理器，则必须确保组ActivationGroupDesc指定的策略文件授予组必要的权限以设置新的安全管理器。 （注意：如果您的小组下载并设置了安全管理器，这将是必要的）。

        创建组后，通过调用该组返回ActivationMonitor的activeGroup方法，通知ActivationSystem该组处于活动状态。 应用程序不需要独立调用activeGroup因为它是通过这种方法来处理的。

        一旦创建了组，对currentGroupID方法的后续调用将返回该组的标识符，直到组变为非活动状态。

        参数
        id - 激活组的标识符
        desc - 激活组的描述符
        incarnation - 组的化身数（组初始创建时为零）
        结果
        虚拟机的激活组
        异常
        ActivationException - 如果组已存在或组创建过程中发生错误
        SecurityException - 如果创建组的权限被拒绝。 （注意：安全管理器checkSetFactory的默认实现方法需要RuntimePermission“setFactory”）
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2
        另请参见：
        SecurityManager.checkSetFactory()

      • currentGroupID

        public static ActivationGroupID currentGroupID​()
        返回当前激活组的标识符。 如果该VM当前没有活动组，则返回null。
        结果
        激活组的标识符
        异常
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

      • setSystem

        public static void setSystem​(ActivationSystem system)
                      throws ActivationException
        设置VM的激活系统。 激活系统只能在没有组当前处于活动状态时进行设置。 如果激活系统未通过此调用设置，那么getSystem方法将通过查找激活器注册表中的名称“java.rmi.activation.ActivationSystem”来尝试获取对ActivationSystem的引用。 默认情况下，用于查找激活系统的端口号由ActivationSystem.SYSTEM_PORT定义。 该端口可以通过设置属性java.rmi.activation.port来覆盖。

        如果有安全管理员，则该方法首先调用安全管理员的checkSetFactory方法。 这可能会导致SecurityException。

        参数
        system - 远程参考 ActivationSystem
        异常
        ActivationException - 如果激活系统已设置
        SecurityException - 如果设置激活系统的权限被拒绝。 （注意：安全管理器checkSetFactory的默认实现方法需要RuntimePermission“setFactory”）
        UnsupportedOperationException - 当且仅当该实现不支持激活时
        从以下版本开始：
        1.2
        另请参见：
        getSystem() ， SecurityManager.checkSetFactory()

      • getSystem

        public static ActivationSystem getSystem​()
                                  throws ActivationException
        返回VM的激活系统。 激活系统可以通过setSystem方法设置。 如果未通过setSystem方法设置激活系统，则getSystem方法将通过查看激活器注册表中的名称“java.rmi.activation.ActivationSystem”来尝试获取对ActivationSystem的引用。 默认情况下，用于查找激活系统的端口号由ActivationSystem.SYSTEM_PORT定义。 该端口可以通过设置属性java.rmi.activation.port来覆盖。
        结果
        VM /组的激活系统
        异常
        ActivationException - 如果无法获取或未绑定激活系统（意味着它未运行）
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2
        另请参见：
        setSystem(java.rmi.activation.ActivationSystem)

      • activeObject

        protected void activeObject​(ActivationID id,
                            MarshalledObject<? extends Remote> mobj)
                     throws ActivationException,
                            UnknownObjectException,
                            RemoteException
        这个受保护的方法对于子类来说使得activeObject回调到组的监视器是必要的。 该呼叫简单地转发到该组的ActivationMonitor 。
        参数
        id - 对象的标识符
        mobj - 一个包含远程对象的存根的编组对象
        异常
        UnknownObjectException - 如果对象未注册
        RemoteException - 如果呼叫通知监视器失败
        ActivationException - 如果发生激活错误
        从以下版本开始：
        1.2

      • inactiveGroup

        protected void inactiveGroup​()
                      throws UnknownGroupException,
                             RemoteException
        这个受保护的方法对于子类来说使inactiveGroup回调到组的监视器是必要的。 呼叫简单地转发到该组的ActivationMonitor 。 此外，VM的当前组设置为null。
        异常
        UnknownGroupException - 如果组没有注册
        RemoteException - 如果呼叫通知监视器失败
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationGroup_Stub (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class ActivationGroup_Stub

  • java.lang.Object
    • java.rmi.server.RemoteObject
      • java.rmi.server.RemoteStub
        • java.rmi.activation.ActivationGroup_Stub
  • All Implemented Interfaces:
    Serializable ， ActivationInstantiator ， Remote

    public final class ActivationGroup_Stub
extends RemoteStub
implements ActivationInstantiator, Remote
    ActivationGroup_Stub是导出为 java.rmi.server.UnicastRemoteObject的 java.rmi.activation.ActivationGroup的子类的存根类。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.server.RemoteObject

        ref

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivationGroup_Stub​(RemoteRef ref)
      为 ActivationGroup类构造一个存根。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MarshalledObject newInstance​(ActivationID id, ActivationDesc desc)
      存根方法为 ActivationGroup.newInstance 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.server.RemoteObject

        equals, getRef, hashCode, toString, toStub

      • Methods inherited from class java.rmi.server.RemoteStub

        setRef

    • 构造方法详细信息

      • ActivationGroup_Stub

        public ActivationGroup_Stub​(RemoteRef ref)
        为ActivationGroup类构造一个存根。 它调用超类RemoteStub(RemoteRef)构造函数，其参数为ref 。
        参数
        ref - 一个远程参考

    • 方法详细信息

      • newInstance

        public MarshalledObject newInstance​(ActivationID id,
                                    ActivationDesc desc)
                             throws RemoteException,
                                    ActivationException
        存根方法ActivationGroup.newInstance 。 在该实例的RemoteObject.ref字段上调用invoke方法，其中this作为第一个参数，双元素Object[]作为第二个参数（以id作为第一个元素， desc作为第二个元素），以及-5274445189091581345L作为第三个参数，以及返回结果。 如果调用抛出一个RuntimeException ， RemoteException ，或ActivationException ，那么抛出异常给调用者。 如果该调用引发了任何其他的java.lang.Exception ，那么一个java.rmi.UnexpectedException原始异常作为原因抛出给调用者。
        Specified by:
        newInstance在接口 ActivationInstantiator
        参数
        id - 激活标识符
        desc - 激活描述符
        结果
        调用的结果
        异常
        RemoteException - 如果调用结果是 RemoteException
        ActivationException - 如果调用结果为 ActivationException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationGroupDesc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class ActivationGroupDesc

  • java.lang.Object
    • java.rmi.activation.ActivationGroupDesc
  • All Implemented Interfaces:
    Serializable

    public final class ActivationGroupDesc
extends Object
implements Serializable
    激活组描述符包含创建/重新创建激活对象的激活组所需的信息。 这样的描述符包含：
    • 该小组的班级名称，
    • 组的代码位置（组的类的位置）和
    • 可以包含特定于组的初始化数据的“编组”对象。

    该组的类必须是具体的子类ActivationGroup 。 通过ActivationGroup.createGroup静态方法创建/重新创建一个ActivationGroup的子类，该方法调用一个特殊的构造函数，该构造函数需要两个参数：

    • 该组的ActivationGroupID和
    • 该组的初始化数据（在java.rmi.MarshalledObject ）
    从以下版本开始：
    1.2
    另请参见：
    ActivationGroup ， ActivationGroupID ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ActivationGroupDesc.CommandEnvironment
      ActivationGroup实现的启动选项。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivationGroupDesc​(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
      指定要用于组的备用组实现和执行环境。
      ActivationGroupDesc​(Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
      构造一个使用系统默认值进行组实现和代码位置的组描述符。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      比较两个激活组描述符的内容相等性。
      String getClassName​()
      返回组的类名（可能为 null ）。
      ActivationGroupDesc.CommandEnvironment getCommandEnvironment​()
      返回组的命令环境控制对象。
      MarshalledObject<?> getData​()
      返回组的初始化数据。
      String getLocation​()
      返回组的代码位置。
      Properties getPropertyOverrides​()
      返回组的属性覆盖列表。
      int hashCode​()
      为类似的 ActivationGroupDesc生成相同的数字。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ActivationGroupDesc

        public ActivationGroupDesc​(Properties overrides,
                           ActivationGroupDesc.CommandEnvironment cmd)
        构造一个使用系统默认值进行组实现和代码位置的组描述符。 属性指定Java环境覆盖（这将覆盖组实现的VM中的系统属性）。 命令环境可以控制启动子VM时使用的确切命令/选项，或者可以使用null接受null的默认命令。

        该构造函数将创建一个ActivationGroupDesc的null组类别名，这表示系统默认的ActivationGroup实现。

        参数
        overrides - 组重新创建时设置的属性集。
        cmd - 用于在另一个进程中执行VM的控制选项（或 null ）。
        从以下版本开始：
        1.2

      • ActivationGroupDesc

        public ActivationGroupDesc​(String className,
                           String location,
                           MarshalledObject<?> data,
                           Properties overrides,
                           ActivationGroupDesc.CommandEnvironment cmd)
        指定要用于组的备用组实现和执行环境。
        参数
        className - 该组的包合格类名或null 。 A null组类名称表示系统默认的ActivationGroup实现。
        location - 从哪里加载小组的班级的位置
        data - 组的初始化数据以编组形式（可能包含属性）
        overrides -一个属性映射将覆盖那些默认子进程环境设定（将被翻译成 -D选项），或 null 。
        cmd - 在另一个进程中执行VM的控制选项（或 null ）。
        从以下版本开始：
        1.2

    • 方法详细信息

      • getClassName

        public String getClassName​()
        返回组的类名（可能为null ）。 一个null组类名称表示系统默认的ActivationGroup实现。
        结果
        该小组的班级名称
        从以下版本开始：
        1.2

      • getLocation

        public String getLocation​()
        返回组的代码位置。
        结果
        该组的代码位置
        从以下版本开始：
        1.2

      • getData

        public MarshalledObject<?> getData​()
        返回组的初始化数据。
        结果
        该组的初始化数据
        从以下版本开始：
        1.2

      • getPropertyOverrides

        public Properties getPropertyOverrides​()
        返回组的属性覆盖列表。
        结果
        属性覆盖列表，或 null
        从以下版本开始：
        1.2

      • getCommandEnvironment

        public ActivationGroupDesc.CommandEnvironment getCommandEnvironment​()
        返回组的命令环境控制对象。
        结果
        命令环境对象，或 null
        从以下版本开始：
        1.2

      • equals

        public boolean equals​(Object obj)
        比较两个激活组描述符的内容相等性。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        如果这些对象相等则为true; 否则为假。
        从以下版本开始：
        1.2
        另请参见：
        Hashtable

      • hashCode

        public int hashCode​()
        为类似的 ActivationGroupDesc生成相同的数字。
        重写：
        hashCode在 Object
        结果
        一个整数
        另请参见：
        Hashtable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationGroupDesc.CommandEnvironment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class ActivationGroupDesc.CommandEnvironment

  • java.lang.Object
    • java.rmi.activation.ActivationGroupDesc.CommandEnvironment
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    ActivationGroupDesc

    public static class ActivationGroupDesc.CommandEnvironment
extends Object
implements Serializable
    ActivationGroup实现的启动选项。 此类允许覆盖默认系统属性并为ActivationGroups指定实现定义的选项。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CommandEnvironment​(String cmdpath, String[] argv)
      创建一个具有所有必要信息的CommandEnvironment。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      比较两个命令环境的内容相等性。
      String[] getCommandOptions​()
      获取配置的java命令选项。
      String getCommandPath​()
      获取配置的路径限定的java命令名称。
      int hashCode​()
      返回相似值 CommandEnvironment s。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CommandEnvironment

        public CommandEnvironment​(String cmdpath,
                          String[] argv)
        创建一个具有所有必要信息的CommandEnvironment。
        参数
        cmdpath - java可执行文件的名称，包括完整路径，或者是null ，意思是“使用null的默认值”。 命名的程序必须能够接受多个-Dpropname=value选项（如“java”工具所述）
        argv - 用于创建ActivationGroup的额外选项。 Null与空列表具有相同的效果。
        从以下版本开始：
        1.2

    • 方法详细信息

      • getCommandPath

        public String getCommandPath​()
        获取配置的路径限定的java命令名称。
        结果
        配置的名称，或 null如果配置为接受默认值
        从以下版本开始：
        1.2

      • getCommandOptions

        public String[] getCommandOptions​()
        获取配置的java命令选项。
        结果
        命令选项的数组将由rmid传递给新的子命令。 请注意，rmid可能会在这些选项之前或之后添加其他选项，或两者。 永远不会返回null 。
        从以下版本开始：
        1.2

      • equals

        public boolean equals​(Object obj)
        比较两个命令环境的内容相等性。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        如果这些对象相等则为true; 否则为假。
        从以下版本开始：
        1.2
        另请参见：
        Hashtable

      • hashCode

        public int hashCode​()
        为类似的 CommandEnvironment返回相同的值。
        重写：
        hashCode在 Object
        结果
        一个整数
        另请参见：
        Hashtable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationGroupID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class ActivationGroupID

  • java.lang.Object
    • java.rmi.activation.ActivationGroupID
  • All Implemented Interfaces:
    Serializable

    public class ActivationGroupID
extends Object
implements Serializable
    注册激活组的标识符有几个目的：
    • 在激活系统内唯一标识组，以及
    • 包含对组的激活系统的引用，以便组可以在必要时联系其激活系统。

    ActivationGroupID从调用返回到ActivationSystem.registerGroup ，用于标识激活系统中的组。 当创建/重新创建激活组时，此组ID将作为参数传递给激活组的特殊构造函数。

    从以下版本开始：
    1.2
    另请参见：
    ActivationGroup ， ActivationGroupDesc ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivationGroupID​(ActivationSystem system)
      构造一个唯一的组ID。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      比较两个组标识符的内容相等性。
      ActivationSystem getSystem​()
      返回组的激活系统。
      int hashCode​()
      返回组的标识符的哈希码。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ActivationGroupID

        public ActivationGroupID​(ActivationSystem system)
        构造一个唯一的组ID。
        参数
        system - 该组的激活系统
        异常
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

    • 方法详细信息

      • getSystem

        public ActivationSystem getSystem​()
        返回组的激活系统。
        结果
        该组的激活系统
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回组的标识符的哈希码。 引用同一个远程组的两个组标识符将具有相同的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        从以下版本开始：
        1.2
        另请参见：
        Hashtable

      • equals

        public boolean equals​(Object obj)
        比较两个组标识符的内容相等性。 如果满足以下两个条件，则返回true：1）唯一标识符等同于内容; 2）每个引用的激活系统引用同一个远程对象。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        如果这些对象相等则为true; 否则为假。
        从以下版本开始：
        1.2
        另请参见：
        Hashtable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class ActivationID

  • java.lang.Object
    • java.rmi.activation.ActivationID
  • All Implemented Interfaces:
    Serializable

    public class ActivationID
extends Object
implements Serializable
    激活使用特殊标识符来表示可以随时间激活的远程对象。 激活标识符（ ActivationID类的实例）包含激活对象所需的几个信息：
    • 对对象的激活器（ RemoteRef实例）的远程引用，以及
    • 对象的唯一标识符（一个UID实例）。

    可以通过用激活系统注册对象来获得对象的激活标识符。 注册是以几种方式完成的：

    • 通过Activatable.register方法
    • 通过第一个Activatable构造函数（它接受三个参数，两个寄存器和导出对象，以及
    • 通过将激活描述符，对象和端口作为参数的第一个Activatable.exportObject方法; 这种方法都注册和导出对象。
    从以下版本开始：
    1.2
    另请参见：
    Activatable ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivationID​(Activator activator)
      ActivationID的构造 ActivationID采用一个参数，即激活器，它指定了负责激活与此标识符关联的对象的激活程序的远程引用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Remote activate​(boolean force)
      激活该ID的对象。
      boolean equals​(Object obj)
      比较两个激活ID用于内容相等。
      int hashCode​()
      返回激活ID的哈希码。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ActivationID

        public ActivationID​(Activator activator)
        ActivationID的构造ActivationID接受一个参数，即激活器，它指定了负责激活与此标识符相关联的对象的激活器的远程引用。 ActivationID一个实例是全球唯一的。
        参数
        activator - 引用负责激活对象的激活器
        异常
        UnsupportedOperationException - 当且仅当此实现不支持激活时
        从以下版本开始：
        1.2

    • 方法详细信息

      • activate

        public Remote activate​(boolean force)
                throws ActivationException,
                       UnknownObjectException,
                       RemoteException
        激活该ID的对象。
        参数
        force - 如果为真，则在激活对象时强制激活器与组联系（而不是返回缓存引用）; 如果为false，则返回缓存值是可以接受的。
        结果
        对活动远程对象的引用
        异常
        ActivationException - 如果激活失败
        UnknownObjectException - 如果对象未知
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回激活ID的哈希码。 引用同一个远程对象的两个标识符将具有相同的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        从以下版本开始：
        1.2
        另请参见：
        Hashtable

      • equals

        public boolean equals​(Object obj)
        比较两个激活ID用于内容相等。 如果满足以下两个条件，则返回true：1）唯一标识符等效（按内容），以及2）每个标识符中指定的激活程序引用相同的远程对象。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        如果这些对象相等则为true; 否则为假。
        从以下版本开始：
        1.2
        另请参见：
        Hashtable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationInstantiator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Interface ActivationInstantiator

  • All Superinterfaces:
    Remote
    所有已知实现类：
    ActivationGroup ， ActivationGroup_Stub

    public interface ActivationInstantiator
extends Remote
    一个ActivationInstantiator负责创建“可激活”对象的实例。 ActivationGroup的具体子类实现了newInstance方法来处理组内的创建对象。
    从以下版本开始：
    1.2
    另请参见：
    ActivationGroup

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      MarshalledObject<? extends Remote> newInstance​(ActivationID id, ActivationDesc desc)
      激活者调用实例化器的 newInstance方法，以便在该组中重新创建具有激活标识符 id和描述符 desc 。

    • 方法详细信息

      • newInstance

        MarshalledObject<? extends Remote> newInstance​(ActivationID id,
                                               ActivationDesc desc)
                                        throws ActivationException,
                                               RemoteException
        激活者调用实例化器的newInstance方法，以便在该组中重新创建具有激活标识符id和描述符desc 。 实例负责人：
        • 使用描述符的getClassName方法确定对象的类，
        • 从从描述符获取的代码位置加载类（使用getLocation方法），
        • 通过调用对象的类的特殊“激活”构造函数来创建类的实例，该对象的类具有两个参数：对象的ActivationID和包含对象特定初始化数据的MarshalledObject ，以及
        • 返回包含其创建的远程对象的存根的MarshalledObject。

        为了激活成功，必须满足以下要求之一，否则将抛出ActivationException ：

        • 要激活的类和特殊的激活构造函数都是public的，并且类位于至少为java.rmi模块的包中，为exported ; 要么
        • 要激活的类位于至少为java.rmi模块的包中，为open 。
        参数
        id - 对象的激活标识符
        desc - 对象的描述符
        结果
        包含远程对象的存根的序列化表示的编组对象
        异常
        ActivationException - 如果对象激活失败
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Interface ActivationMonitor

  • All Superinterfaces:
    Remote

    public interface ActivationMonitor
extends Remote
    一个ActivationMonitor是专门针对一个ActivationGroup ，当通过调用ActivationSystem.activeGroup （这是在内部完成）报告一个组被激活时获得。 激活组负责通知其ActivationMonitor何时：其对象变为活动或非活动，或组作为一个整体变为不活动。
    从以下版本开始：
    1.2
    另请参见：
    Activator ， ActivationSystem ， ActivationGroup

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void activeObject​(ActivationID id, MarshalledObject<? extends Remote> obj)
      通知对象现在处于活动状态。
      void inactiveGroup​(ActivationGroupID id, long incarnation)
      通知组现在处于非活动状态。
      void inactiveObject​(ActivationID id)
      激活组在其组中的对象变为无效（停用）时调用其监视器的 inactiveObject方法。

    • 方法详细信息

      • inactiveObject

        void inactiveObject​(ActivationID id)
             throws UnknownObjectException,
                    RemoteException
        激活组在其组中的对象变为不活动（停用）时调用其监视器的inactiveObject方法。 激活组通过调用激活组的inactiveObject方法，发现其VM中的对象（其参与激活）不再有效。

        inactiveObject调用通知ActivationMonitor对于具有激活标识符（ id的对象的远程对象引用不再有效。 监视器将与id相关联的引用视为过时引用。 由于引用被认为是过时的，因此随后的activate调用相同的激活标识符导致重新激活远程对象。

        参数
        id - 对象的激活标识符
        异常
        UnknownObjectException - 如果对象未知
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2

      • activeObject

        void activeObject​(ActivationID id,
                  MarshalledObject<? extends Remote> obj)
           throws UnknownObjectException,
                  RemoteException
        通知对象现在处于活动状态。 一个ActivationGroup通知其监视器中的对象是否通过直接激活的其他方式（即，对象被注册和“激活”）本身ActivationGroup通知其监视器。
        参数
        id - 活动对象的ID
        obj - 对象的存根的编组形式
        异常
        UnknownObjectException - 如果对象未知
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2

      • inactiveGroup

        void inactiveGroup​(ActivationGroupID id,
                   long incarnation)
            throws UnknownGroupException,
                   RemoteException
        通知组现在处于非活动状态。 该组将在后续请求激活组内的对象时重新创建。 组中的所有对象报告它们处于非活动状态时，组将变为非活动状态。
        参数
        id - 该组的id
        incarnation - 该组织的化身号码
        异常
        UnknownGroupException - 如果组未知
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivationSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Interface ActivationSystem

  • All Superinterfaces:
    Remote

    public interface ActivationSystem
extends Remote
    ActivationSystem提供了一种注册组和“激活”对象在这些组内被激活的方法。 所述ActivationSystem与密切合作Activator ，其激活经由注册的对象ActivationSystem和ActivationMonitor ，其获取关于活动和非活动的对象，和不活动组的信息。
    从以下版本开始：
    1.2
    另请参见：
    Activator ， ActivationMonitor

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int SYSTEM_PORT
      查找激活系统的端口。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ActivationMonitor activeGroup​(ActivationGroupID id, ActivationInstantiator group, long incarnation)
      回调通知激活系统该组现在处于活动状态。
      ActivationDesc getActivationDesc​(ActivationID id)
      返回激活描述符，对于具有激活标识符的对象为 id 。
      ActivationGroupDesc getActivationGroupDesc​(ActivationGroupID id)
      返回激活组描述符，具有激活组标识符的组 id 。
      ActivationGroupID registerGroup​(ActivationGroupDesc desc)
      注册激活组。
      ActivationID registerObject​(ActivationDesc desc)
      registerObject方法用于注册激活描述符 desc ，并获得可激活远程对象的激活标识符。
      ActivationDesc setActivationDesc​(ActivationID id, ActivationDesc desc)
      使用激活标识符 desc为对象设置激活描述符 id 。
      ActivationGroupDesc setActivationGroupDesc​(ActivationGroupID id, ActivationGroupDesc desc)
      使用激活组标识符 desc为对象设置激活组描述符 id 。
      void shutdown​()
      关闭激活系统。
      void unregisterGroup​(ActivationGroupID id)
      删除激活组。
      void unregisterObject​(ActivationID id)
      删除先前注册的激活标识和相关描述符ActivationSystem ; 该对象不能再通过对象的激活标识被激活。

    • 字段详细信息

      • SYSTEM_PORT

        static final int SYSTEM_PORT
        查找激活系统的端口。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • registerObject

        ActivationID registerObject​(ActivationDesc desc)
                     throws ActivationException,
                            UnknownGroupException,
                            RemoteException
        registerObject方法用于注册激活描述符desc ，并获得可激活远程对象的激活标识符。 ActivationSystem为描述符desc指定的对象创建一个ActivationID （激活标识符），并在稳定存储中记录激活描述符及其关联的标识符供以后使用。 当Activator接收activate特定标识符请求时，它查找该指定的标识符的激活描述符（先前登记的），并使用该信息来激活对象。
        参数
        desc - 对象的激活描述符
        结果
        可用于激活对象的激活ID
        异常
        ActivationException - 如果注册失败（例如，数据库更新失败等）。
        UnknownGroupException -如果组中称为 desc不与该系统中登记的
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2

      • unregisterObject

        void unregisterObject​(ActivationID id)
               throws ActivationException,
                      UnknownObjectException,
                      RemoteException
        删除以前注册的激活标识和相关描述符ActivationSystem ; 该对象不能再通过对象的激活标识被激活。
        参数
        id - 对象的激活标识（从上次注册）
        异常
        ActivationException - 如果注销失败（例如，数据库更新失败等）。
        UnknownObjectException - 如果对象未知（未注册）
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2

      • registerGroup

        ActivationGroupID registerGroup​(ActivationGroupDesc desc)
                         throws ActivationException,
                                RemoteException
        注册激活组。 必须向ActivationSystem注册激活组，才能在该组内注册对象。
        参数
        desc - 该组的描述符
        结果
        该组的标识符
        异常
        ActivationException - 如果组注册失败
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2

      • activeGroup

        ActivationMonitor activeGroup​(ActivationGroupID id,
                              ActivationInstantiator group,
                              long incarnation)
                       throws UnknownGroupException,
                              ActivationException,
                              RemoteException
        回调通知激活系统该组现在处于活动状态。 该通话由内部通过ActivationGroup.createGroup方法通知ActivationSystem该组现在处于活动状态。
        参数
        id - 激活组的标识符
        group - 该组的实例
        incarnation - 该组织的化身号码
        结果
        监视激活组
        异常
        UnknownGroupException - 如果组未注册
        ActivationException - 如果指定的 id的组已经处于活动状态，并且该组不等于指定的 group或该组与指定的不同的 incarnation不同的 group
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2

      • unregisterGroup

        void unregisterGroup​(ActivationGroupID id)
              throws ActivationException,
                     UnknownGroupException,
                     RemoteException
        删除激活组。 激活组使此回调通知激活器组应该被删除（销毁）。 如果此呼叫成功完成，则无法再在组内注册或激活对象。 从系统中删除组及其关联对象的所有信息。
        参数
        id - 激活组的标识符
        异常
        ActivationException - 如果注销失败（例如数据库更新失败等）。
        UnknownGroupException - 如果组未注册
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2

      • shutdown

        void shutdown​()
       throws RemoteException
        关闭激活系统。 销毁激活守护进程产生的所有组，并退出激活守护程序。
        异常
        RemoteException - 如果无法联系/关闭激活守护程序
        从以下版本开始：
        1.2

      • setActivationDesc

        ActivationDesc setActivationDesc​(ActivationID id,
                                 ActivationDesc desc)
                          throws ActivationException,
                                 UnknownObjectException,
                                 UnknownGroupException,
                                 RemoteException
        使用激活标识符desc为对象设置激活描述符id 。 该更改将在后续激活对象时生效。
        参数
        id - 可激活对象的激活标识符
        desc - 可激活对象的激活描述符
        结果
        激活描述符的先前值
        异常
        UnknownGroupException - 与 desc相关联的组不是注册组
        UnknownObjectException - 未注册激活 id
        ActivationException - 对于一般故障（例如，无法更新日志）
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2
        另请参见：
        getActivationDesc(java.rmi.activation.ActivationID)

      • setActivationGroupDesc

        ActivationGroupDesc setActivationGroupDesc​(ActivationGroupID id,
                                           ActivationGroupDesc desc)
                                    throws ActivationException,
                                           UnknownGroupException,
                                           RemoteException
        使用激活组标识符desc为对象设置激活组描述符id 。 该更改将在后续激活该组时生效。
        参数
        id - 激活组的激活组标识符
        desc - 激活组的激活组描述符
        结果
        激活组描述符的先前值
        异常
        UnknownGroupException - 与 id相关联的组不是注册组
        ActivationException - 对于一般故障（例如，无法更新日志）
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2
        另请参见：
        getActivationGroupDesc(java.rmi.activation.ActivationGroupID)

      • getActivationDesc

        ActivationDesc getActivationDesc​(ActivationID id)
                          throws ActivationException,
                                 UnknownObjectException,
                                 RemoteException
        返回激活描述符，对于具有激活标识符的对象， id 。
        参数
        id - 可激活对象的激活标识符
        结果
        激活描述符
        异常
        UnknownObjectException - 如果 id未注册
        ActivationException - 一般故障
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2
        另请参见：
        setActivationDesc(java.rmi.activation.ActivationID, java.rmi.activation.ActivationDesc)

      • getActivationGroupDesc

        ActivationGroupDesc getActivationGroupDesc​(ActivationGroupID id)
                                    throws ActivationException,
                                           UnknownGroupException,
                                           RemoteException
        返回激活组描述符，具有激活组标识符的组 id 。
        参数
        id - 组的激活组标识符
        结果
        激活组描述符
        异常
        UnknownGroupException - 如果 id未注册
        ActivationException - 一般故障
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2
        另请参见：
        setActivationGroupDesc(java.rmi.activation.ActivationGroupID, java.rmi.activation.ActivationGroupDesc)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Activator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Interface Activator

  • All Superinterfaces:
    Remote

    public interface Activator
extends Remote
    Activator有助于远程对象激活。 “故障”远程引用调用激活器的activate方法来获取对“可激活”远程对象的“实时”引用。 在接收到激活请求时，激活器查找激活标识符的激活描述符， id确定应激活对象的组，通过组ActivationInstantiator （通过调用newInstance方法）来启动对象重新创建。 激活器根据需要启动激活组的执行。 例如，如果特定组标识符的激活组尚未执行，则激活程序启动该组的VM的执行。

    Activator与ActivationSystem紧密合作，它提供了注册组和对象在这些组中的方法，以及ActivationMonitor ，它接收有关活动和非活动对象和非活动组的信息。

    激活器负责监视和检测激活组何时失败，以便它可以删除对这些组中的组和活动对象的陈旧的远程引用。

    从以下版本开始：
    1.2
    另请参见：
    ActivationInstantiator ， ActivationGroupDesc ， ActivationGroupID

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      MarshalledObject<? extends Remote> activate​(ActivationID id, boolean force)
      激活与激活标识符相关联的对象， id 。

    • 方法详细信息

      • activate

        MarshalledObject<? extends Remote> activate​(ActivationID id,
                                            boolean force)
                                     throws ActivationException,
                                            UnknownObjectException,
                                            RemoteException
        激活与激活标识符相关联的对象， id 。 如果激活器知道该对象已经被激活，并且force为假，则具有“活动”引用的存根立即返回给调用者; 否则，如果激活器不知道对应的远程对象是活动的，则激活器使用激活描述符信息（先前注册的）来确定应该激活对象的组（VM）。 如果对象的组描述符对应的ActivationInstantiator已经存在，则激活程序将调用激活组的newInstance方法传递对象的id和描述符。

        如果对象的组描述符的激活组不存在，则激活器启动ActivationInstantiator执行（例如通过生成子进程）。 当激活器接收到激活组的回叫（通过ActivationSystem的activeGroup方法）指定激活组的引用时，激活器然后可以调用激活实例化器的newInstance方法将每个待处理的激活请求转发到激活组并返回结果（a编组的远程对象引用，存根）到调用者。

        请注意，激活程序接收“编组”对象而不是Remote对象，以便激活程序不需要加载该对象的代码，也可以参与该对象的分布式垃圾回收。 如果激活器保持对远程对象的强烈引用，则激活器将防止对象在正常分布式垃圾收集机制下被垃圾收集。

        参数
        id - 正在激活的对象的激活标识符
        force - 如果为真，则激活器接触组以获得远程对象的引用; 如果为false，则返回缓存值是允许的。
        结果
        远程对象（一个存根）以编组形式存在
        异常
        ActivationException - 如果对象激活失败
        UnknownObjectException - 如果对象未知（未注册）
        RemoteException - 如果远程调用失败
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.rmi.activation (Java SE 9 & JDK 9 )

java.rmi.activation

Interfaces

  • ActivationInstantiator
  • ActivationMonitor
  • ActivationSystem
  • Activator

Classes

  • Activatable
  • ActivationDesc
  • ActivationGroup
  • ActivationGroup_Stub
  • ActivationGroupDesc
  • ActivationGroupDesc.CommandEnvironment
  • ActivationGroupID
  • ActivationID

Exceptions

  • ActivateFailedException
  • ActivationException
  • UnknownGroupException
  • UnknownObjectException


java.rmi.activation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.rmi

Package java.rmi.activation

提供对RMI对象激活的支持。 一个远程对象的引用可以被做成“持久”，然后使用RMI激活机制激活成一个“活”对象。

不需要实现支持激活机制。 如果此实现不支持激活，则需要几个特定的激活API方法才能抛出UnsupportedOperationException 。 如果此实现支持激活，则这些方法绝不能抛出UnsupportedOperationException 。 这些方法由每个方法规范的“ 投掷”部分中存在UnsupportedOperationException的条目表示。

从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    ActivationInstantiator
    一个 ActivationInstantiator负责创建“可激活”对象的实例。
    ActivationMonitor
    一个 ActivationMonitor是专门针对一个 ActivationGroup ，当一个组通过调用 ActivationSystem.activeGroup （这是内部完成）报告为活动时获得。
    ActivationSystem
    ActivationSystem提供了一种注册组和“激活”对象在这些组中激活的方法。
    Activator
    Activator有助于远程对象激活。
  • 类摘要
    Class 描述
    Activatable
    Activatable类提供对需要持续访问的远程对象的支持，并且可以由系统激活。
    ActivationDesc
    激活描述符包含激活对象所需的信息：对象的组标识符，对象的全限定类名，对象的代码位置（类的位置），代码库URL路径，对象的重新启动“模式”，以及，一个可以包含对象特定初始化数据的“编组”对象。
    ActivationGroup
    一个 ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor何时：其对象变为活动或非活动，或组作为整体变为不活动。
    ActivationGroup_Stub
    ActivationGroup_Stub是导出为 java.rmi.server.UnicastRemoteObject的 java.rmi.activation.ActivationGroup的子类的存根类。
    ActivationGroupDesc
    激活组描述符包含创建/重新创建激活对象的激活组所需的信息。
    ActivationGroupDesc.CommandEnvironment
    ActivationGroup实现的启动选项。
    ActivationGroupID
    注册激活组的标识符有几个目的：在激活系统中唯一标识组，并包含对组的激活系统的引用，以便组可以在必要时联系其激活系统。
    ActivationID
    激活使用特殊标识符来表示可以随时间激活的远程对象。
  • 异常摘要
    异常 描述
    ActivateFailedException
    在远程调用可激活对象时激活失败时，RMI运行时抛出此异常。
    ActivationException
    激活界面使用的常规异常。
    UnknownGroupException
    一个 UnknownGroupException通过在类和接口方法抛出 java.rmi.activation包时 ActivationGroupID参数的方法被确定为是无效的，即，不通过已知 ActivationSystem 。
    UnknownObjectException
    当方法的 ActivationID参数被确定为无效时，通过 java.rmi.activation包中的类和接口的方法抛出一个 UnknownObjectException 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.rmi.activation Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.rmi.activation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.rmi.activation.ActivationDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc.CommandEnvironment (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupID (implements java.io.Serializable)
    • java.rmi.activation.ActivationID (implements java.io.Serializable)
    • java.rmi.server.RemoteObject (implements java.rmi.Remote, java.io.Serializable)
      • java.rmi.server.RemoteServer
        • java.rmi.activation.Activatable
        • java.rmi.server.UnicastRemoteObject
          • java.rmi.activation.ActivationGroup (implements java.rmi.activation.ActivationInstantiator)
      • java.rmi.server.RemoteStub
        • java.rmi.activation.ActivationGroup_Stub (implements java.rmi.activation.ActivationInstantiator, java.rmi.Remote)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.rmi.activation.ActivationException
          • java.rmi.activation.UnknownGroupException
          • java.rmi.activation.UnknownObjectException
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.activation.ActivateFailedException

Interface Hierarchy

  • java.rmi.Remote
    • java.rmi.activation.ActivationInstantiator
    • java.rmi.activation.ActivationMonitor
    • java.rmi.activation.ActivationSystem
    • java.rmi.activation.Activator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


UnknownGroupException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class UnknownGroupException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.rmi.activation.ActivationException
          • java.rmi.activation.UnknownGroupException
  • All Implemented Interfaces:
    Serializable

    public class UnknownGroupException
extends ActivationException
    一个UnknownGroupException通过在类和接口方法抛出java.rmi.activation包时ActivationGroupID参数的方法被确定为是无效的，即，不通过已知ActivationSystem 。 一个UnknownGroupException也被抛出，如果一个ActivationGroupID中的ActivationDesc是指没有注册到ActivationSystem
    从以下版本开始：
    1.2
    另请参见：
    Activatable ， ActivationGroup ， ActivationGroupID ， ActivationMonitor ， ActivationSystem ， Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.activation.ActivationException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownGroupException​(String s)
      构造具有指定详细消息的 UnknownGroupException 。

    • 方法摘要

      • Methods inherited from class java.rmi.activation.ActivationException

        getCause, getMessage

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownGroupException

        public UnknownGroupException​(String s)
        构造具有指定详细消息的 UnknownGroupException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnknownObjectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.activation

Class UnknownObjectException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.rmi.activation.ActivationException
          • java.rmi.activation.UnknownObjectException
  • All Implemented Interfaces:
    Serializable

    public class UnknownObjectException
extends ActivationException
    当方法的ActivationID参数被确定为无效时，通过java.rmi.activation包中的类和接口的方法抛出一个UnknownObjectException 。 如果ActivationID当前不知道，则ActivationSystem 。 一个ActivationID是通过ActivationSystem.registerObject方法获得的。 一个ActivationID的过程中也得到Activatable.register电话。
    从以下版本开始：
    1.2
    另请参见：
    Activatable ， ActivationGroup ， ActivationID ， ActivationMonitor ， ActivationSystem ， Activator ， Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.activation.ActivationException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownObjectException​(String s)
      构造具有指定详细消息的 UnknownObjectException 。

    • 方法摘要

      • Methods inherited from class java.rmi.activation.ActivationException

        getCause, getMessage

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownObjectException

        public UnknownObjectException​(String s)
        构造具有指定详细消息的 UnknownObjectException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.rmi.activation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.rmi.activation

  • Packages that use java.rmi.activation
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
  • Classes in java.rmi.activation used by java.rmi.activation
    Class 描述
    ActivationDesc
    激活描述符包含激活对象所需的信息：对象的组标识符，对象的全限定类名，对象的代码位置（类的位置），代码库URL路径，对象的重新启动“模式”，以及，一个可以包含对象特定初始化数据的“编组”对象。
    ActivationException
    激活界面使用的常规异常。
    ActivationGroup
    一个 ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor何时：其对象变为活动或非活动，或组作为一个整体变为不活动。
    ActivationGroupDesc
    激活组描述符包含创建/重新创建激活对象的激活组所需的信息。
    ActivationGroupDesc.CommandEnvironment
    ActivationGroup实现的启动选项。
    ActivationGroupID
    注册激活组的标识符有几个目的：在激活系统中唯一标识组，并包含对组的激活系统的引用，以便组可以在必要时联系其激活系统。
    ActivationID
    激活使用特殊标识符来表示可以随时间激活的远程对象。
    ActivationInstantiator
    一个 ActivationInstantiator负责创建“可激活”对象的实例。
    ActivationMonitor
    一个 ActivationMonitor是专门针对一个 ActivationGroup ，当通过一个呼叫被报告为一个组 ActivationSystem.activeGroup （这是内部完成）时获得的。
    ActivationSystem
    ActivationSystem提供了一种注册组和“活动”对象在这些组内被激活的方法。
    Activator
    Activator有助于远程对象激活。
    UnknownGroupException
    一个 UnknownGroupException通过在类和接口方法抛出 java.rmi.activation包时 ActivationGroupID参数的方法被确定为是无效的，即，不通过已知 ActivationSystem 。
    UnknownObjectException
    当方法的 ActivationID参数被确定为无效时，通过 java.rmi.activation包中的类和接口的方法抛出一个 UnknownObjectException 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.Activatable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.Activatable

No usage of java.rmi.activation.Activatable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.ActivateFailedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.ActivateFailedException

No usage of java.rmi.activation.ActivateFailedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.ActivationDesc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.ActivationDesc

  • Packages that use ActivationDesc
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationDesc in java.rmi.activation

      Methods in java.rmi.activation that return ActivationDesc
      Modifier and Type 方法 描述
      ActivationDesc ActivationSystem.getActivationDesc​(ActivationID id)
      返回激活描述符，对于具有激活标识符的对象， id 。
      ActivationDesc ActivationSystem.setActivationDesc​(ActivationID id, ActivationDesc desc)
      使用激活标识符 desc为对象设置激活描述符 id 。
      Methods in java.rmi.activation with parameters of type ActivationDesc
      Modifier and Type 方法 描述
      MarshalledObject ActivationGroup_Stub.newInstance​(ActivationID id, ActivationDesc desc)
      存根方法 ActivationGroup.newInstance 。
      MarshalledObject<? extends Remote> ActivationInstantiator.newInstance​(ActivationID id, ActivationDesc desc)
      激活者调用实例化器的 newInstance方法，以便在该组中重新创建具有激活标识符 id和描述符 desc 。
      static Remote Activatable.register​(ActivationDesc desc)
      注册可激活的远程对象的对象描述符，以便可以按需激活。
      ActivationID ActivationSystem.registerObject​(ActivationDesc desc)
      registerObject方法用于注册激活描述符 desc ，并获得可激活远程对象的激活标识符。
      ActivationDesc ActivationSystem.setActivationDesc​(ActivationID id, ActivationDesc desc)
      设置激活描述符， desc用于与激活标识符，对象 id 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.ActivationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.ActivationException

  • Packages that use ActivationException
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationException in java.rmi.activation

      Subclasses of ActivationException in java.rmi.activation
      Modifier and Type Class 描述
      class  UnknownGroupException
      一个 UnknownGroupException通过在类和接口方法抛出 java.rmi.activation包时 ActivationGroupID参数的方法被确定为是无效的，即，不通过已知 ActivationSystem 。
      class  UnknownObjectException
      当方法的 ActivationID参数被确定为无效时，将通过 java.rmi.activation包中的类和接口的方法抛出一个 UnknownObjectException 。
      Methods in java.rmi.activation that throw ActivationException
      Modifier and Type 方法 描述
      Remote ActivationID.activate​(boolean force)
      激活该ID的对象。
      MarshalledObject<? extends Remote> Activator.activate​(ActivationID id, boolean force)
      激活与激活标识符相关联的对象， id 。
      ActivationMonitor ActivationSystem.activeGroup​(ActivationGroupID id, ActivationInstantiator group, long incarnation)
      回调通知激活系统该组现在处于活动状态。
      protected void ActivationGroup.activeObject​(ActivationID id, MarshalledObject<? extends Remote> mobj)
      这个受保护的方法对于子类来说使 activeObject回调到组的监视器是必要的。
      abstract void ActivationGroup.activeObject​(ActivationID id, Remote obj)
      当对象被导出（通过 Activatable对象构造或显式调用到 Activatable.exportObject时，将调用该组的 activeObject方法。
      static ActivationGroup ActivationGroup.createGroup​(ActivationGroupID id, ActivationGroupDesc desc, long incarnation)
      创建并设置当前虚拟机的激活组。
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port)
      为指定的对象注册激活描述符（具有指定的位置，数据和重新启动模式），并使用指定的端口导出该对象。
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。
      ActivationDesc ActivationSystem.getActivationDesc​(ActivationID id)
      返回激活描述符，对于具有激活标识符的对象， id 。
      ActivationGroupDesc ActivationSystem.getActivationGroupDesc​(ActivationGroupID id)
      返回激活组描述符，具有激活组标识符的组 id 。
      static ActivationSystem ActivationGroup.getSystem​()
      返回VM的激活系统。
      static boolean Activatable.inactive​(ActivationID id)
      通知系统当前没有激活对象 id的对象。
      boolean ActivationGroup.inactiveObject​(ActivationID id)
      该组的 inactiveObject方法通过调用 Activatable.inactive方法间接调用。
      MarshalledObject ActivationGroup_Stub.newInstance​(ActivationID id, ActivationDesc desc)
      存根方法 ActivationGroup.newInstance 。
      MarshalledObject<? extends Remote> ActivationInstantiator.newInstance​(ActivationID id, ActivationDesc desc)
      激活者调用实例化器的 newInstance方法，以便在该组中重新创建具有激活标识符 id和描述符 desc 。
      static Remote Activatable.register​(ActivationDesc desc)
      注册可激活的远程对象的对象描述符，以便可以按需激活。
      ActivationGroupID ActivationSystem.registerGroup​(ActivationGroupDesc desc)
      注册激活组。
      ActivationID ActivationSystem.registerObject​(ActivationDesc desc)
      registerObject方法用于注册激活描述符 desc ，并获取可激活远程对象的激活标识符。
      ActivationDesc ActivationSystem.setActivationDesc​(ActivationID id, ActivationDesc desc)
      使用激活标识符 desc为对象设置激活描述符 id 。
      ActivationGroupDesc ActivationSystem.setActivationGroupDesc​(ActivationGroupID id, ActivationGroupDesc desc)
      设置激活组描述符， desc用于与激活组标识符，对象 id 。
      static void ActivationGroup.setSystem​(ActivationSystem system)
      设置VM的激活系统。
      static void Activatable.unregister​(ActivationID id)
      id与 id关联的激活描述符的先前注册。
      void ActivationSystem.unregisterGroup​(ActivationGroupID id)
      删除激活组。
      void ActivationSystem.unregisterObject​(ActivationID id)
      删除以前注册的激活标识和相关描述符ActivationSystem ; 该对象不能再通过对象的激活标识被激活。
      Constructors in java.rmi.activation that throw ActivationException
      Constructor 描述
      Activatable​(String location, MarshalledObject<?> data, boolean restart, int port)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并使用指定的端口导出对象。
      Activatable​(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并导出具有指定端口的对象以及指定的客户端和服务器套接字工厂。
      ActivationDesc​(String className, String location, MarshalledObject<?> data)
      为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
      ActivationDesc​(String className, String location, MarshalledObject<?> data, boolean restart)
      Constructs an object descriptor for an object whose class name is className, that can be loaded from the code location and whose initialization information is data.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.ActivationGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.ActivationGroup

  • Packages that use ActivationGroup
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationGroup in java.rmi.activation

      Methods in java.rmi.activation that return ActivationGroup
      Modifier and Type 方法 描述
      static ActivationGroup ActivationGroup.createGroup​(ActivationGroupID id, ActivationGroupDesc desc, long incarnation)
      创建并设置当前虚拟机的激活组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.ActivationGroup_Stub (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.ActivationGroup_Stub

No usage of java.rmi.activation.ActivationGroup_Stub
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.ActivationGroupDesc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.ActivationGroupDesc

  • Packages that use ActivationGroupDesc
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationGroupDesc in java.rmi.activation

      Methods in java.rmi.activation that return ActivationGroupDesc
      Modifier and Type 方法 描述
      ActivationGroupDesc ActivationSystem.getActivationGroupDesc​(ActivationGroupID id)
      返回激活组描述符，具有激活组标识符的组 id 。
      ActivationGroupDesc ActivationSystem.setActivationGroupDesc​(ActivationGroupID id, ActivationGroupDesc desc)
      使用激活组标识符 desc为对象设置激活组描述符 id 。
      Methods in java.rmi.activation with parameters of type ActivationGroupDesc
      Modifier and Type 方法 描述
      static ActivationGroup ActivationGroup.createGroup​(ActivationGroupID id, ActivationGroupDesc desc, long incarnation)
      创建并设置当前虚拟机的激活组。
      ActivationGroupID ActivationSystem.registerGroup​(ActivationGroupDesc desc)
      注册激活组。
      ActivationGroupDesc ActivationSystem.setActivationGroupDesc​(ActivationGroupID id, ActivationGroupDesc desc)
      使用激活组标识符 desc为对象设置激活组描述符 id 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.ActivationGroupDesc.CommandEnvironment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.ActivationGroupDesc.CommandEnvironment

  • Packages that use ActivationGroupDesc.CommandEnvironment
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationGroupDesc.CommandEnvironment in java.rmi.activation

      Methods in java.rmi.activation that return ActivationGroupDesc.CommandEnvironment
      Modifier and Type 方法 描述
      ActivationGroupDesc.CommandEnvironment ActivationGroupDesc.getCommandEnvironment​()
      返回组的命令环境控制对象。
      Constructors in java.rmi.activation with parameters of type ActivationGroupDesc.CommandEnvironment
      Constructor 描述
      ActivationGroupDesc​(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
      指定要用于组的备用组实现和执行环境。
      ActivationGroupDesc​(Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
      构造一个使用系统默认值进行组实现和代码位置的组描述符。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.ActivationGroupID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.ActivationGroupID

  • Packages that use ActivationGroupID
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationGroupID in java.rmi.activation

      Methods in java.rmi.activation that return ActivationGroupID
      Modifier and Type 方法 描述
      static ActivationGroupID ActivationGroup.currentGroupID​()
      返回当前激活组的标识符。
      ActivationGroupID ActivationDesc.getGroupID​()
      返回由此描述符指定的对象的组标识符。
      ActivationGroupID ActivationSystem.registerGroup​(ActivationGroupDesc desc)
      注册激活组。
      Methods in java.rmi.activation with parameters of type ActivationGroupID
      Modifier and Type 方法 描述
      ActivationMonitor ActivationSystem.activeGroup​(ActivationGroupID id, ActivationInstantiator group, long incarnation)
      回调通知激活系统该组现在处于活动状态。
      static ActivationGroup ActivationGroup.createGroup​(ActivationGroupID id, ActivationGroupDesc desc, long incarnation)
      创建并设置当前虚拟机的激活组。
      ActivationGroupDesc ActivationSystem.getActivationGroupDesc​(ActivationGroupID id)
      返回激活组描述符，具有激活组标识符的组 id 。
      void ActivationMonitor.inactiveGroup​(ActivationGroupID id, long incarnation)
      通知组现在处于非活动状态。
      ActivationGroupDesc ActivationSystem.setActivationGroupDesc​(ActivationGroupID id, ActivationGroupDesc desc)
      设置激活组描述符， desc用于与激活组标识符，对象 id 。
      void ActivationSystem.unregisterGroup​(ActivationGroupID id)
      删除激活组。
      Constructors in java.rmi.activation with parameters of type ActivationGroupID
      Constructor 描述
      ActivationDesc​(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
      为类名为 className的对象构造一个对象描述符，该对象可以从代码 location加载，其初始化信息为 data 。
      ActivationDesc​(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
      为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
      ActivationGroup​(ActivationGroupID groupID)
      Constructs an activation group with the given activation group identifier.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.ActivationID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.ActivationID

  • Packages that use ActivationID
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationID in java.rmi.activation

      Methods in java.rmi.activation that return ActivationID
      Modifier and Type 方法 描述
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port)
      为指定的对象注册激活描述符（具有指定的位置，数据和重新启动模式），并使用指定的端口导出该对象。
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。
      protected ActivationID Activatable.getID​()
      返回对象的激活标识符。
      ActivationID ActivationSystem.registerObject​(ActivationDesc desc)
      registerObject方法用于注册激活描述符 desc ，并获得可激活远程对象的激活标识符。
      Methods in java.rmi.activation with parameters of type ActivationID
      Modifier and Type 方法 描述
      MarshalledObject<? extends Remote> Activator.activate​(ActivationID id, boolean force)
      激活与激活标识符相关联的对象， id 。
      protected void ActivationGroup.activeObject​(ActivationID id, MarshalledObject<? extends Remote> mobj)
      这个受保护的方法对于子类来说是必需的，以使 activeObject回调到组的监视器。
      abstract void ActivationGroup.activeObject​(ActivationID id, Remote obj)
      当对象导出时（通过 Activatable对象构造或显式调用 Activatable.exportObject将调用该组的 activeObject方法。
      void ActivationMonitor.activeObject​(ActivationID id, MarshalledObject<? extends Remote> obj)
      通知对象现在处于活动状态。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      ActivationDesc ActivationSystem.getActivationDesc​(ActivationID id)
      返回激活描述符，对于具有激活标识符的对象为 id 。
      static boolean Activatable.inactive​(ActivationID id)
      通知系统当前激活的对象 id当前处于非活动状态。
      boolean ActivationGroup.inactiveObject​(ActivationID id)
      该组的 inactiveObject方法通过调用 Activatable.inactive方法间接调用。
      void ActivationMonitor.inactiveObject​(ActivationID id)
      当组中的对象变为无效（禁用）时，激活组会调用其监视器的 inactiveObject方法。
      MarshalledObject ActivationGroup_Stub.newInstance​(ActivationID id, ActivationDesc desc)
      存根方法 ActivationGroup.newInstance 。
      MarshalledObject<? extends Remote> ActivationInstantiator.newInstance​(ActivationID id, ActivationDesc desc)
      激活者调用实例化器的 newInstance方法，以便在该组中重新创建具有激活标识符 id和描述符 desc 。
      ActivationDesc ActivationSystem.setActivationDesc​(ActivationID id, ActivationDesc desc)
      设置激活描述符， desc用于与激活标识符，对象 id 。
      static void Activatable.unregister​(ActivationID id)
      id与 id关联的激活描述符的先前注册。
      void ActivationSystem.unregisterObject​(ActivationID id)
      删除以前注册的激活ID和关联的描述符ActivationSystem ; 该对象不能再通过对象的激活标识被激活。
      Constructors in java.rmi.activation with parameters of type ActivationID
      Constructor 描述
      Activatable​(ActivationID id, int port)
      用于在指定端口上激活/导出对象的构造方法。
      Activatable​(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      用于在指定端口上激活/导出对象的构造方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.UnknownGroupException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.UnknownGroupException

  • Packages that use UnknownGroupException
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of UnknownGroupException in java.rmi.activation

      Methods in java.rmi.activation that throw UnknownGroupException
      Modifier and Type 方法 描述
      ActivationMonitor ActivationSystem.activeGroup​(ActivationGroupID id, ActivationInstantiator group, long incarnation)
      回调通知激活系统该组现在处于活动状态。
      ActivationGroupDesc ActivationSystem.getActivationGroupDesc​(ActivationGroupID id)
      返回激活组描述符，具有激活组标识符的组 id 。
      protected void ActivationGroup.inactiveGroup​()
      这个受保护的方法对于子类来说是必需的，以使 inactiveGroup回调到组的监视器。
      void ActivationMonitor.inactiveGroup​(ActivationGroupID id, long incarnation)
      通知组现在处于非活动状态。
      static Remote Activatable.register​(ActivationDesc desc)
      注册可激活的远程对象的对象描述符，以便可以按需激活。
      ActivationID ActivationSystem.registerObject​(ActivationDesc desc)
      registerObject方法用于注册激活描述符 desc ，并获得可激活远程对象的激活标识符。
      ActivationDesc ActivationSystem.setActivationDesc​(ActivationID id, ActivationDesc desc)
      使用激活标识符 desc为对象设置激活描述符 id 。
      ActivationGroupDesc ActivationSystem.setActivationGroupDesc​(ActivationGroupID id, ActivationGroupDesc desc)
      使用激活组标识符 desc为对象设置激活组描述符 id 。
      void ActivationSystem.unregisterGroup​(ActivationGroupID id)
      删除激活组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.activation.UnknownObjectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.activation.UnknownObjectException

  • Packages that use UnknownObjectException
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of UnknownObjectException in java.rmi.activation

      Methods in java.rmi.activation that throw UnknownObjectException
      Modifier and Type 方法 描述
      Remote ActivationID.activate​(boolean force)
      激活该ID的对象。
      MarshalledObject<? extends Remote> Activator.activate​(ActivationID id, boolean force)
      激活与激活标识符相关联的对象， id 。
      protected void ActivationGroup.activeObject​(ActivationID id, MarshalledObject<? extends Remote> mobj)
      这个受保护的方法对于子类来说使 activeObject回调到组的监视器是必要的。
      abstract void ActivationGroup.activeObject​(ActivationID id, Remote obj)
      当对象被导出（由 Activatable对象构造或显式调用到 Activatable.exportObject时，将调用该组的 activeObject方法。
      void ActivationMonitor.activeObject​(ActivationID id, MarshalledObject<? extends Remote> obj)
      通知对象现在处于活动状态。
      ActivationDesc ActivationSystem.getActivationDesc​(ActivationID id)
      返回激活描述符，对于具有激活标识符的对象为 id 。
      static boolean Activatable.inactive​(ActivationID id)
      通知系统当前处于活动状态的对象已激活 id 。
      boolean ActivationGroup.inactiveObject​(ActivationID id)
      该组的 inactiveObject方法通过调用 Activatable.inactive方法间接调用。
      void ActivationMonitor.inactiveObject​(ActivationID id)
      当组中的对象变为无效（禁用）时，激活组会调用其监视器的 inactiveObject方法。
      ActivationDesc ActivationSystem.setActivationDesc​(ActivationID id, ActivationDesc desc)
      使用激活标识符 desc为对象设置激活描述符 id 。
      static void Activatable.unregister​(ActivationID id)
      id与 id相关联的激活描述符的先前注册。
      void ActivationSystem.unregisterObject​(ActivationID id)
      Remove the activation id and associated descriptor previously registered with the ActivationSystem; the object can no longer be activated via the object's activation id.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.activation.ActivationInstantiator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.activation.ActivationInstantiator

  • Packages that use ActivationInstantiator
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationInstantiator in java.rmi.activation

      Classes in java.rmi.activation that implement ActivationInstantiator
      Modifier and Type Class 描述
      class  ActivationGroup
      一个 ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor何时：其对象变为活动或非活动，或组作为整体变为不活动。
      class  ActivationGroup_Stub
      ActivationGroup_Stub是导出为 java.rmi.server.UnicastRemoteObject的 java.rmi.activation.ActivationGroup子类的存根类。
      Methods in java.rmi.activation with parameters of type ActivationInstantiator
      Modifier and Type 方法 描述
      ActivationMonitor ActivationSystem.activeGroup​(ActivationGroupID id, ActivationInstantiator group, long incarnation)
      回调通知激活系统该组现在处于活动状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.activation.ActivationMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.activation.ActivationMonitor

  • Packages that use ActivationMonitor
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationMonitor in java.rmi.activation

      Methods in java.rmi.activation that return ActivationMonitor
      Modifier and Type 方法 描述
      ActivationMonitor ActivationSystem.activeGroup​(ActivationGroupID id, ActivationInstantiator group, long incarnation)
      回调通知激活系统该组现在处于活动状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.activation.ActivationSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.activation.ActivationSystem

  • Packages that use ActivationSystem
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of ActivationSystem in java.rmi.activation

      Methods in java.rmi.activation that return ActivationSystem
      Modifier and Type 方法 描述
      static ActivationSystem ActivationGroup.getSystem​()
      返回VM的激活系统。
      ActivationSystem ActivationGroupID.getSystem​()
      返回组的激活系统。
      Methods in java.rmi.activation with parameters of type ActivationSystem
      Modifier and Type 方法 描述
      static void ActivationGroup.setSystem​(ActivationSystem system)
      设置VM的激活系统。
      Constructors in java.rmi.activation with parameters of type ActivationSystem
      Constructor 描述
      ActivationGroupID​(ActivationSystem system)
      构造一个唯一的组ID。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.activation.Activator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.activation.Activator

  • Packages that use Activator
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of Activator in java.rmi.activation

      Constructors in java.rmi.activation with parameters of type Activator
      Constructor 描述
      ActivationID​(Activator activator)
      ActivationID的构造函数使用一个参数，激活器，它指定了激活与此标识符关联的对象的激活程序的远程引用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.AccessException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.AccessException

  • Packages that use AccessException
    软件包 描述
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。

    • Uses of AccessException in java.rmi.registry

      Methods in java.rmi.registry that throw AccessException
      Modifier and Type 方法 描述
      void Registry.bind​(String name, Remote obj)
      绑定到此注册表中指定的 name的远程引用。
      String[] Registry.list​()
      返回在此注册表中绑定的名称的数组。
      Remote Registry.lookup​(String name)
      返回绑定到此注册表中指定的 name的远程引用。
      void Registry.rebind​(String name, Remote obj)
      使用提供的远程引用替换此注册表中指定的 name的绑定。
      void Registry.unbind​(String name)
      删除此注册表中指定的 name的绑定。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.AlreadyBoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.AlreadyBoundException

  • Packages that use AlreadyBoundException
    软件包 描述
    java.rmi
    提供RMI包。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。

    • Uses of AlreadyBoundException in java.rmi

      Methods in java.rmi that throw AlreadyBoundException
      Modifier and Type 方法 描述
      static void Naming.bind​(String name, Remote obj)
      将指定的 name绑定到远程对象。

    • Uses of AlreadyBoundException in java.rmi.registry

      Methods in java.rmi.registry that throw AlreadyBoundException
      Modifier and Type 方法 描述
      void Registry.bind​(String name, Remote obj)
      将远程引用绑定到此注册表中指定的 name 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.ConnectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.ConnectException

No usage of java.rmi.ConnectException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.ConnectIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.ConnectIOException

No usage of java.rmi.ConnectIOException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.MarshalException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.MarshalException

No usage of java.rmi.MarshalException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.MarshalledObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.MarshalledObject

  • Packages that use MarshalledObject
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。

    • Uses of MarshalledObject in java.rmi.activation

      Methods in java.rmi.activation that return MarshalledObject
      Modifier and Type 方法 描述
      MarshalledObject<? extends Remote> Activator.activate​(ActivationID id, boolean force)
      激活与激活标识符相关联的对象， id 。
      MarshalledObject<?> ActivationDesc.getData​()
      返回一个包含由该描述符指定的对象的初始化/激活数据的“编组对象”。
      MarshalledObject<?> ActivationGroupDesc.getData​()
      返回组的初始化数据。
      MarshalledObject ActivationGroup_Stub.newInstance​(ActivationID id, ActivationDesc desc)
      存根方法 ActivationGroup.newInstance 。
      MarshalledObject<? extends Remote> ActivationInstantiator.newInstance​(ActivationID id, ActivationDesc desc)
      激活器调用实例化器的 newInstance方法，以便在该组中重新创建具有激活标识符 id和描述符 desc 。
      Methods in java.rmi.activation with parameters of type MarshalledObject
      Modifier and Type 方法 描述
      protected void ActivationGroup.activeObject​(ActivationID id, MarshalledObject<? extends Remote> mobj)
      这种受保护的方法对于子类来说使得 activeObject回调到组的监视器是必要的。
      void ActivationMonitor.activeObject​(ActivationID id, MarshalledObject<? extends Remote> obj)
      通知对象现在处于活动状态。
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port)
      为指定的对象注册激活描述符（具有指定的位置，数据和重新启动模式），并使用指定的端口导出该对象。
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。
      Constructors in java.rmi.activation with parameters of type MarshalledObject
      Constructor 描述
      Activatable​(String location, MarshalledObject<?> data, boolean restart, int port)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并使用指定的端口导出对象。
      Activatable​(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并导出具有指定端口的对象以及指定的客户端和服务器套接字工厂。
      ActivationDesc​(String className, String location, MarshalledObject<?> data)
      为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
      ActivationDesc​(String className, String location, MarshalledObject<?> data, boolean restart)
      为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
      ActivationDesc​(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
      为类名为 className的对象构造一个对象描述符，该对象描述符可以从代码 location加载，其初始化信息为 data 。
      ActivationDesc​(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
      为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
      ActivationGroupDesc​(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
      指定要用于组的备用组实现和执行环境。

    • Uses of MarshalledObject in javax.management.remote.rmi

      Methods in javax.management.remote.rmi with parameters of type MarshalledObject
      Modifier and Type | 方法 | 描述
      void RMIConnection.addNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      处理方法 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 。
      void | RMIConnectionImpl_Stub.addNotificationListener​(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      void | RMIConnectionImpl.addNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Integer[] RMIConnection.addNotificationListeners​(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      处理方法 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 。
      Integer[] | RMIConnectionImpl_Stub.addNotificationListeners​(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
      Integer[] | RMIConnectionImpl.addNotificationListeners​(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      ObjectInstance RMIConnection.createMBean​(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      处理方法 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 。
      ObjectInstance RMIConnection.createMBean​(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      处理方法 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 。
      ObjectInstance | RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      ObjectInstance | RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
      ObjectInstance | RMIConnectionImpl.createMBean​(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance | RMIConnectionImpl.createMBean​(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Object RMIConnection.invoke​(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      处理方法 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 。
      Object | RMIConnectionImpl_Stub.invoke​(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      Object | RMIConnectionImpl.invoke​(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Set<ObjectInstance> RMIConnection.queryMBeans​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      处理方法 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 。
      Set | RMIConnectionImpl_Stub.queryMBeans​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectInstance> | RMIConnectionImpl.queryMBeans​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectName> RMIConnection.queryNames​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      处理方法 MBeanServerConnection.queryNames(ObjectName, QueryExp) 。
      Set | RMIConnectionImpl_Stub.queryNames​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectName> | RMIConnectionImpl.queryNames​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      void RMIConnection.removeNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      处理方法 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 。
      void | RMIConnectionImpl_Stub.removeNotificationListener​(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      void | RMIConnectionImpl.removeNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      void RMIConnection.setAttribute​(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      处理方法 MBeanServerConnection.setAttribute(ObjectName, Attribute) 。
      void | RMIConnectionImpl_Stub.setAttribute​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.setAttribute​(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      AttributeList RMIConnection.setAttributes​(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      处理方法 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 。
      AttributeList | RMIConnectionImpl_Stub.setAttributes​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      AttributeList | RMIConnectionImpl.setAttributes​(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.Naming (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.Naming

No usage of java.rmi.Naming
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.NoSuchObjectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.NoSuchObjectException

  • Packages that use NoSuchObjectException
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.rmi
    包含RMI-IIOP的用户API。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。

    • Uses of NoSuchObjectException in java.rmi.activation

      Methods in java.rmi.activation that throw NoSuchObjectException
      Modifier and Type 方法 描述
      static boolean Activatable.unexportObject​(Remote obj, boolean force)
      从RMI运行时中删除远程对象obj。

    • Uses of NoSuchObjectException in java.rmi.server

      Methods in java.rmi.server that throw NoSuchObjectException
      Modifier and Type 方法 描述
      static Remote RemoteObject.toStub​(Remote obj)
      返回作为参数传递的远程对象 obj的存根。
      static boolean UnicastRemoteObject.unexportObject​(Remote obj, boolean force)
      从RMI运行时中删除远程对象obj。

    • Uses of NoSuchObjectException in javax.rmi

      Methods in javax.rmi that throw NoSuchObjectException
      Modifier and Type 方法 描述
      static Remote PortableRemoteObject.toStub​(Remote obj)
      返回给定服务器对象的存根。
      static void PortableRemoteObject.unexportObject​(Remote obj)
      从运行时取消注册服务器对象，允许对象可用于垃圾回收。

    • Uses of NoSuchObjectException in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that throw NoSuchObjectException
      Modifier and Type 方法 描述
      void Tie.deactivate​()
      取消这个领带所代表的目标对象。
      Remote PortableRemoteObjectDelegate.toStub​(Remote obj)
      代表团要求 PortableRemoteObject.toStub(java.rmi.Remote) 。
      void PortableRemoteObjectDelegate.unexportObject​(Remote obj)
      代表团要求 PortableRemoteObject.unexportObject(java.rmi.Remote) 。
      static void Util.unexportObject​(Remote target)
      从内部表中删除相关联的绑定，并调用 Tie.deactivate()以停用该对象。
      void UtilDelegate.unexportObject​(Remote target)
      代表团要求 Util.unexportObject(java.rmi.Remote) 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.NotBoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.NotBoundException

  • Packages that use NotBoundException
    软件包 描述
    java.rmi
    提供RMI包。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。

    • Uses of NotBoundException in java.rmi

      Methods in java.rmi that throw NotBoundException
      Modifier and Type 方法 描述
      static Remote Naming.lookup​(String name)
      返回与指定的 name相关联的远程对象的引用（stub）。
      static void Naming.unbind​(String name)
      销毁与远程对象关联的指定名称的绑定。

    • Uses of NotBoundException in java.rmi.registry

      Methods in java.rmi.registry that throw NotBoundException
      Modifier and Type 方法 描述
      Remote Registry.lookup​(String name)
      返回绑定到此注册表中指定的 name的远程引用。
      void Registry.unbind​(String name)
      删除此注册表中指定的 name的绑定。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.RemoteException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.RemoteException

  • Packages that use RemoteException
    软件包 描述
    java.rmi
    提供RMI包。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.activity
    包含ORB机械在解组时抛出的活动服务相关异常。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.rmi
    包含RMI-IIOP的用户API。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.transaction
    包含ORB机械在解组期间抛出的三个异常。

    • Uses of RemoteException in java.rmi

      Subclasses of RemoteException in java.rmi
      Modifier and Type Class 描述
      class  AccessException
      一个 AccessException通过一定的方法抛出 java.rmi.Naming类（具体 bind ， rebind ，和 unbind ）和方法 java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。
      class  ConnectException
      如果连接被拒绝到远程主机进行远程方法调用，则抛出 ConnectException 。
      class  ConnectIOException
      如果在与远程主机进行远程方法调用的连接时发生 ConnectIOException则抛出 IOException 。
      class  MarshalException
      如果在编组远程调用头，远程方法调用的参数或返回值时发生 MarshalException则抛出 java.io.IOException 。
      class  NoSuchObjectException
      如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
      class  ServerError
      甲 ServerError被抛出作为远程方法调用的结果，当一个 Error任而解编参数，执行远程方法本身，或编组返回值在处理服务器上的调用，被抛出。
      class  ServerException
      甲 ServerException当被抛出作为远程方法调用的结果 RemoteException在处理服务器上的调用，要么同时解编参数或执行远程方法本身被抛出。
      class  ServerRuntimeException
      已过时。
      没有替换
      class  StubNotFoundException
      如果远程对象在导出时无法找到有效的存根类，则抛出 StubNotFoundException 。
      class  UnexpectedException
      如果远程方法调用的客户机接收到调用的结果，那么抛出一个 UnexpectedException ，该检查异常不在远程接口的方法的 throws子句中声明的检查的异常类型中。
      class  UnknownHostException
      如果在创建与远程主机的远程方法调用的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。
      class  UnmarshalException
      如果发生以下任何一种 UnmarshalException可以在解组远程方法调用的参数或结果时抛出一个 UnmarshalException ：如果如果一个 java.io.IOException发生解组参数（返回值为无效），如果返回值的协议无效，则发生 java.io.IOException时 java.io.IOException调用头服务器端）或返回值（在客户端）。
      Methods in java.rmi that throw RemoteException
      Modifier and Type 方法 描述
      static void Naming.bind​(String name, Remote obj)
      将指定的 name绑定到远程对象。
      static String[] Naming.list​(String name)
      返回在注册表中绑定的名称的数组。
      static Remote Naming.lookup​(String name)
      返回与指定的 name相关联的远程对象的引用（stub）。
      static void Naming.rebind​(String name, Remote obj)
      将指定的名称重新绑定到一个新的远程对象。
      static void Naming.unbind​(String name)
      销毁与远程对象关联的指定名称的绑定。

    • Uses of RemoteException in java.rmi.activation

      Subclasses of RemoteException in java.rmi.activation
      Modifier and Type Class 描述
      class  ActivateFailedException
      在远程调用可激活对象时激活失败时，RMI运行时抛出此异常。
      Methods in java.rmi.activation that throw RemoteException
      Modifier and Type 方法 描述
      Remote ActivationID.activate​(boolean force)
      激活该ID的对象。
      MarshalledObject<? extends Remote> Activator.activate​(ActivationID id, boolean force)
      激活与激活标识符相关联的对象， id 。
      ActivationMonitor ActivationSystem.activeGroup​(ActivationGroupID id, ActivationInstantiator group, long incarnation)
      回调通知激活系统该组现在处于活动状态。
      protected void ActivationGroup.activeObject​(ActivationID id, MarshalledObject<? extends Remote> mobj)
      这种受保护的方法对于子类来说使得 activeObject回调到组的监视器是必需的。
      abstract void ActivationGroup.activeObject​(ActivationID id, Remote obj)
      当对象被导出（由 Activatable对象构造或显式调用到 Activatable.exportObject时，将调用该组的 activeObject方法。
      void ActivationMonitor.activeObject​(ActivationID id, MarshalledObject<? extends Remote> obj)
      通知对象现在处于活动状态。
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port)
      为指定的对象注册激活描述符（具有指定的位置，数据和重新启动模式），并使用指定的端口导出该对象。
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      ActivationDesc ActivationSystem.getActivationDesc​(ActivationID id)
      返回激活描述符，对于具有激活标识符的对象为 id 。
      ActivationGroupDesc ActivationSystem.getActivationGroupDesc​(ActivationGroupID id)
      返回激活组描述符，具有激活组标识符的组 id 。
      static boolean Activatable.inactive​(ActivationID id)
      通知系统当前激活的对象 id当前处于非活动状态。
      protected void ActivationGroup.inactiveGroup​()
      这个受保护的方法对于子类来说使 inactiveGroup回调到组的监视器是必要的。
      void ActivationMonitor.inactiveGroup​(ActivationGroupID id, long incarnation)
      通知组现在处于非活动状态。
      boolean ActivationGroup.inactiveObject​(ActivationID id)
      该组的 inactiveObject方法通过调用 Activatable.inactive方法间接调用。
      void ActivationMonitor.inactiveObject​(ActivationID id)
      激活组在其组中的对象变为无效（停用）时调用其监视器的 inactiveObject方法。
      MarshalledObject ActivationGroup_Stub.newInstance​(ActivationID id, ActivationDesc desc)
      存根方法 ActivationGroup.newInstance 。
      MarshalledObject<? extends Remote> ActivationInstantiator.newInstance​(ActivationID id, ActivationDesc desc)
      激活者调用实例化器的 newInstance方法，以便在该组中重新创建具有激活标识符 id和描述符 desc 。
      static Remote Activatable.register​(ActivationDesc desc)
      注册可激活的远程对象的对象描述符，以便可以按需激活。
      ActivationGroupID ActivationSystem.registerGroup​(ActivationGroupDesc desc)
      注册激活组。
      ActivationID ActivationSystem.registerObject​(ActivationDesc desc)
      registerObject方法用于注册激活描述符 desc ，并获得可激活远程对象的激活标识符。
      ActivationDesc ActivationSystem.setActivationDesc​(ActivationID id, ActivationDesc desc)
      设置激活描述符， desc用于与激活标识符，对象 id 。
      ActivationGroupDesc ActivationSystem.setActivationGroupDesc​(ActivationGroupID id, ActivationGroupDesc desc)
      使用激活组标识符 desc为对象设置激活组描述符 id 。
      void ActivationSystem.shutdown​()
      关闭激活系统。
      static void Activatable.unregister​(ActivationID id)
      id与 id相关联的激活描述符的先前注册。
      void ActivationSystem.unregisterGroup​(ActivationGroupID id)
      删除激活组。
      void ActivationSystem.unregisterObject​(ActivationID id)
      删除先前使用ActivationSystem注册的激活ID和关联的描述符; 该对象不能再通过对象的激活标识被激活。
      Constructors in java.rmi.activation that throw RemoteException
      Constructor 描述
      Activatable​(String location, MarshalledObject<?> data, boolean restart, int port)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并使用指定的端口导出对象。
      Activatable​(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并导出具有指定端口的对象以及指定的客户端和服务器套接字工厂。
      Activatable​(ActivationID id, int port)
      用于在指定端口上激活/导出对象的构造方法。
      Activatable​(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      用于在指定端口上激活/导出对象的构造方法。
      ActivationGroup​(ActivationGroupID groupID)
      构造具有给定激活组标识符的激活组。

    • Uses of RemoteException in java.rmi.dgc

      Methods in java.rmi.dgc that throw RemoteException
      Modifier and Type 方法 描述
      void DGC.clean​(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong)
      干净的呼叫从'id'中指示的每个远程对象的引用列表中删除'vmid'。
      Lease DGC.dirty​(ObjID[] ids, long sequenceNum, Lease lease)
      对于与数组“ids”中包含的对象标识符相关联的远程对象引用的脏调用请求。

    • Uses of RemoteException in java.rmi.registry

      Methods in java.rmi.registry that throw RemoteException
      Modifier and Type 方法 描述
      void Registry.bind​(String name, Remote obj)
      绑定到此注册表中指定的 name的远程引用。
      static Registry LocateRegistry.createRegistry​(int port)
      在本地主机上创建并导出 Registry实例，该实例接受指定的 port请求。
      static Registry LocateRegistry.createRegistry​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      在本地主机上创建并导出 Registry实例，该实例使用自定义套接字工厂进行与该实例的通信。
      static Registry LocateRegistry.getRegistry​()
      返回对默认注册表端口1099的本地主机的远程对象 Registry的引用。
      static Registry LocateRegistry.getRegistry​(int port)
      在指定的 port上返回对本地主机的远程对象 Registry的引用。
      static Registry LocateRegistry.getRegistry​(String host)
      返回对默认注册表端口1099上指定的 host上的远程对象 Registry的引用。
      static Registry LocateRegistry.getRegistry​(String host, int port)
      返回对指定的 host和 port上的远程对象 Registry的 port 。
      static Registry LocateRegistry.getRegistry​(String host, int port, RMIClientSocketFactory csf)
      返回本地创建的对指定的 host和 port上的远程对象 Registry远程引用。
      String[] Registry.list​()
      返回在此注册表中绑定的名称的数组。
      Remote Registry.lookup​(String name)
      返回绑定到此注册表中指定的 name的远程引用。
      void Registry.rebind​(String name, Remote obj)
      使用提供的远程引用替换此注册表中指定的 name的绑定。
      Registry RegistryHandler.registryImpl​(int port)
      已过时。
      没有替换。 从Java 2平台v1.2开始，RMI不再使用RegistryHandler来获取注册表的实现。
      Registry RegistryHandler.registryStub​(String host, int port)
      已过时。
      没有替换。 作为Java 2平台v1.2，RMI不再使用RegistryHandler获取注册表的存根。
      void Registry.unbind​(String name)
      删除此注册表中指定的 name的绑定。

    • Uses of RemoteException in java.rmi.server

      Subclasses of RemoteException in java.rmi.server
      Modifier and Type Class 描述
      class  ExportException
      如果尝试导出远程对象失败，则 ExportException是抛出的 RemoteException 。
      class  SkeletonMismatchException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SkeletonNotFoundException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SocketSecurityException
      已过时。
      这个班已经过时了 改用ExportException 。
      Methods in java.rmi.server that throw RemoteException
      Modifier and Type 方法 描述
      void RemoteRef.done​(RemoteCall call)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
      RemoteStub ServerRef.exportObject​(Remote obj, Object data)
      已过时。
      为所提供的Remote对象创建客户端存根对象。
      static RemoteStub UnicastRemoteObject.exportObject​(Remote obj)
      已过时。
      此方法已被弃用，因为它仅支持静态存根。 请改用exportObject(Remote, port)或exportObject(Remote, port, csf, ssf) 。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port)
      使用特定提供的端口导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, ObjectInputFilter filter)
      使用特定提供的端口和filter导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用给定套接字工厂指定的传输导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, ObjectInputFilter filter)
      使用指定的套接字工厂指定的传输和filter ，导出远程对象以使其可用于接收来电。
      RemoteCall RemoteRef.newCall​(RemoteObject obj, Operation[] op, int opnum, long hash)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法调用的顺序上短截线的远程引用（的newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回的值。
      Constructors in java.rmi.server that throw RemoteException
      Constructor 描述
      UnicastRemoteObject​()
      使用匿名端口创建并导出新的UnicastRemoteObject对象。
      UnicastRemoteObject​(int port)
      使用特定提供的端口创建并导出新的UnicastRemoteObject对象。
      UnicastRemoteObject​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用特定提供的端口和套接字工厂创建并导出新的UnicastRemoteObject对象。

    • Uses of RemoteException in javax.activity

      Subclasses of RemoteException in javax.activity
      Modifier and Type Class 描述
      class  ActivityCompletedException
      可能会在访问活动上下文的任何方法上抛出此异常，并指示活动中正在进行的工作是不可能的。
      class  ActivityRequiredException
      如果活动上下文是强制性的方法未收到活动上下文，则容器将抛出此异常。
      class  InvalidActivityException
      可以在访问Activity上下文的任何方法上抛出此异常，并指示与尝试调用相关联的尝试调用或活动上下文与Activity的当前状态不兼容。

    • Uses of RemoteException in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that throw RemoteException
      Modifier and Type | 方法 | 描述
      String RMIServer.getVersion​()
      该连接器服务器了解的RMI连接器协议版本。
      String | RMIServerImpl_Stub.getVersion​()

    • Uses of RemoteException in javax.rmi

      Methods in javax.rmi that throw RemoteException
      Modifier and Type 方法 描述
      static void PortableRemoteObject.connect​(Remote target, Remote source)
      使远程对象准备好进行远程通信。
      static void PortableRemoteObject.exportObject​(Remote obj)
      使服务器对象准备好接收远程调用。
      Constructors in javax.rmi that throw RemoteException
      Constructor 描述
      PortableRemoteObject​()
      通过调用 exportObject(this)初始化对象。

    • Uses of RemoteException in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that return RemoteException
      Modifier and Type 方法 描述
      static RemoteException Util.mapSystemException​(SystemException ex)
      将SystemException映射到RemoteException。
      RemoteException UtilDelegate.mapSystemException​(SystemException ex)
      代表团要求 Util.mapSystemException(org.omg.CORBA.SystemException) 。
      static RemoteException Util.wrapException​(Throwable orig)
      包装一个实现方法抛出的异常。
      RemoteException UtilDelegate.wrapException​(Throwable obj)
      代表团要求 Util.wrapException(java.lang.Throwable) 。
      Methods in javax.rmi.CORBA that throw RemoteException
      Modifier and Type 方法 描述
      void PortableRemoteObjectDelegate.connect​(Remote target, Remote source)
      代表团要求 PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 。
      void Stub.connect​(ORB orb)
      将此存根连接到ORB。
      void StubDelegate.connect​(Stub self, ORB orb)
      代表团要求 Stub.connect(org.omg.CORBA.ORB) 。
      static Object Util.copyObject​(Object obj, ORB orb)
      复制或连接对象。
      Object UtilDelegate.copyObject​(Object obj, ORB orb)
      代表团要求 Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 。
      static Object[] Util.copyObjects​(Object[] obj, ORB orb)
      复制或连接对象数组。
      Object[] UtilDelegate.copyObjects​(Object[] obj, ORB orb)
      代表团要求 Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 。
      void PortableRemoteObjectDelegate.exportObject​(Remote obj)
      代表团要求 PortableRemoteObject.exportObject(java.rmi.Remote) 。
      static boolean Util.isLocal​(Stub stub)
      该 isLocal方法具有相同的语义 ObjectImpl._is_local方法，不同之处在于它可以抛出一个 RemoteException 。
      boolean UtilDelegate.isLocal​(Stub stub)
      代表团要求 Util.isLocal(javax.rmi.CORBA.Stub) 。

    • Uses of RemoteException in javax.transaction

      Subclasses of RemoteException in javax.transaction
      Modifier and Type Class 描述
      class  InvalidTransactionException
      此异常表示请求携带无效的事务上下文。
      class  TransactionRequiredException
      此异常指示请求携带空事务上下文，但目标对象需要激活事务。
      class  TransactionRolledbackException
      此异常表示与请求的处理关联的事务已回滚，或标记为回滚。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.RMISecurityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.RMISecurityException

No usage of java.rmi.RMISecurityException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.RMISecurityManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.RMISecurityManager

No usage of java.rmi.RMISecurityManager
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.ServerError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.ServerError

No usage of java.rmi.ServerError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.ServerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.ServerException

No usage of java.rmi.ServerException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.ServerRuntimeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.ServerRuntimeException

No usage of java.rmi.ServerRuntimeException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.StubNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.StubNotFoundException

No usage of java.rmi.StubNotFoundException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.UnexpectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.UnexpectedException

No usage of java.rmi.UnexpectedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.UnknownHostException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.UnknownHostException

  • Packages that use UnknownHostException
    软件包 描述
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。

    • Uses of UnknownHostException in java.rmi.registry

      Methods in java.rmi.registry that throw UnknownHostException
      Modifier and Type 方法 描述
      Registry RegistryHandler.registryStub​(String host, int port)
      已过时。
      没有替换。 从Java 2平台v1.2开始，RMI不再使用RegistryHandler获取注册表的存根。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.UnmarshalException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.UnmarshalException

No usage of java.rmi.UnmarshalException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.Remote (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.Remote

  • Packages that use Remote
    软件包 描述
    java.rmi
    提供RMI包。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.rmi
    包含RMI-IIOP的用户API。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    org.omg.stub.java.rmi
    包含在 java.rmi包中发生的远程类型的RMI-IIOP存根。

    • Uses of Remote in java.rmi

      Methods in java.rmi that return Remote
      Modifier and Type 方法 描述
      static Remote Naming.lookup​(String name)
      返回与指定的 name关联的远程对象的引用（stub）。
      Methods in java.rmi with parameters of type Remote
      Modifier and Type 方法 描述
      static void Naming.bind​(String name, Remote obj)
      将指定的 name绑定到远程对象。
      static void Naming.rebind​(String name, Remote obj)
      将指定的名称重新绑定到一个新的远程对象。

    • Uses of Remote in java.rmi.activation

      Subinterfaces of Remote in java.rmi.activation
      Modifier and Type 接口 描述
      interface  ActivationInstantiator
      一个 ActivationInstantiator负责创建“可激活”对象的实例。
      interface  ActivationMonitor
      一个 ActivationMonitor是专门针对一个 ActivationGroup ，当通过一个呼叫报告一个组被报告为 ActivationSystem.activeGroup （这是在内部完成）时获得的。
      interface  ActivationSystem
      ActivationSystem提供了一种注册组和“激活”对象在这些组内被激活的方法。
      interface  Activator
      Activator促进远程对象激活。
      Classes in java.rmi.activation that implement Remote
      Modifier and Type Class 描述
      class  Activatable
      Activatable类为需要持续访问的远程对象提供支持，并可由系统激活。
      class  ActivationGroup
      ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor何时：其对象变为活动或非活动，或组作为整体变为不活动。
      class  ActivationGroup_Stub
      ActivationGroup_Stub是导出为 java.rmi.server.UnicastRemoteObject的 java.rmi.activation.ActivationGroup的子类的存根类。
      Methods in java.rmi.activation that return Remote
      Modifier and Type 方法 描述
      Remote ActivationID.activate​(boolean force)
      激活该ID的对象。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      static Remote Activatable.register​(ActivationDesc desc)
      注册可激活的远程对象的对象描述符，以便可以按需激活。
      Methods in java.rmi.activation that return types with arguments of type Remote
      Modifier and Type 方法 描述
      MarshalledObject<? extends Remote> Activator.activate​(ActivationID id, boolean force)
      激活与激活标识符相关联的对象， id 。
      MarshalledObject<? extends Remote> ActivationInstantiator.newInstance​(ActivationID id, ActivationDesc desc)
      激活器调用实例化器的 newInstance方法，以便在该组中重新创建具有激活标识符 id和描述符 desc 。
      Methods in java.rmi.activation with parameters of type Remote
      Modifier and Type 方法 描述
      abstract void ActivationGroup.activeObject​(ActivationID id, Remote obj)
      当对象被导出（由 Activatable对象构造或显式调用到 Activatable.exportObject时，将调用该组的 activeObject方法。
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port)
      为指定的对象注册激活描述符（具有指定的位置，数据和重新启动模式），并使用指定的端口导出该对象。
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      static boolean Activatable.unexportObject​(Remote obj, boolean force)
      从RMI运行时中删除远程对象obj。
      Method parameters in java.rmi.activation with type arguments of type Remote
      Modifier and Type 方法 描述
      protected void ActivationGroup.activeObject​(ActivationID id, MarshalledObject<? extends Remote> mobj)
      这种受保护的方法对于子类来说使 activeObject回调到组的监视器是必要的。
      void ActivationMonitor.activeObject​(ActivationID id, MarshalledObject<? extends Remote> obj)
      通知对象现在处于活动状态。

    • Uses of Remote in java.rmi.dgc

      Subinterfaces of Remote in java.rmi.dgc
      Modifier and Type 接口 描述
      interface  DGC
      DGC抽象用于分布式垃圾回收算法的服务器端。

    • Uses of Remote in java.rmi.registry

      Subinterfaces of Remote in java.rmi.registry
      Modifier and Type 接口 描述
      interface  Registry
      Registry是一个简单的远程对象注册表的远程接口，提供用于存储和检索与任意字符串名称绑定的远程对象引用的方法。
      Methods in java.rmi.registry that return Remote
      Modifier and Type 方法 描述
      Remote Registry.lookup​(String name)
      返回绑定到此注册表中指定的 name的远程引用。
      Methods in java.rmi.registry with parameters of type Remote
      Modifier and Type 方法 描述
      void Registry.bind​(String name, Remote obj)
      将远程引用绑定到此注册表中指定的 name 。
      void Registry.rebind​(String name, Remote obj)
      使用提供的远程引用替换此注册表中指定的 name的绑定。

    • Uses of Remote in java.rmi.server

      Classes in java.rmi.server that implement Remote
      Modifier and Type Class 描述
      class  RemoteObject
      RemoteObject类实现了远程对象的 java.lang.Object行为。
      class  RemoteObjectInvocationHandler
      用于Java Remote Method Invocation（Java RMI）的 InvocationHandler接口的实现。
      class  RemoteServer
      RemoteServer类是服务器实现的常见超类，并提供了支持各种远程引用语义的框架。
      class  RemoteStub
      已过时。
      静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。
      class  UnicastRemoteObject
      用于使用JRMP导出远程对象并获取与远程对象通信的存根。
      Methods in java.rmi.server that return Remote
      Modifier and Type 方法 描述
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port)
      使用特定提供的端口导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, ObjectInputFilter filter)
      使用特定提供的端口和filter导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用给定套接字工厂指定的传输导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, ObjectInputFilter filter)
      导出远程对象以使其可用于接收来电，使用给定套接字工厂指定的传输和filter 。
      static Remote RemoteObject.toStub​(Remote obj)
      返回作为参数传递的远程对象的存根 obj 。
      Methods in java.rmi.server with parameters of type Remote
      Modifier and Type 方法 描述
      void Skeleton.dispatch​(Remote obj, RemoteCall theCall, int opnum, long hash)
      已过时。
      没有替换
      RemoteStub ServerRef.exportObject​(Remote obj, Object data)
      已过时。
      为所提供的Remote对象创建客户端存根对象。
      static RemoteStub UnicastRemoteObject.exportObject​(Remote obj)
      已过时。
      此方法已被弃用，因为它仅支持静态存根。 请改用exportObject(Remote, port)或exportObject(Remote, port, csf, ssf) 。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port)
      使用特定提供的端口导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, ObjectInputFilter filter)
      使用特定提供的端口和filter导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用给定套接字工厂指定的传输导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, ObjectInputFilter filter)
      导出远程对象以使其可用于接收来电，使用由给定的套接字工厂指定的传输和filter 。
      Object RemoteRef.invoke​(Remote obj, 方法 method, Object[] params, long opnum)
      调用方法。
      static Remote RemoteObject.toStub​(Remote obj)
      返回作为参数传递的远程对象 obj的存根。
      static boolean UnicastRemoteObject.unexportObject​(Remote obj, boolean force)
      从RMI运行时中删除远程对象obj。

    • Uses of Remote in javax.management.remote.rmi

      Subinterfaces of Remote in javax.management.remote.rmi
      Modifier and Type 接口 描述
      interface  RMIConnection
      用于将MBeanServer请求从客户端转发到其在服务器端的MBeanServer实现的RMI对象。
      interface  RMIServer
      用于建立与RMI连接器的连接的RMI对象。
      Classes in javax.management.remote.rmi that implement Remote
      Modifier and Type | Class | 描述
      class  RMIConnectionImpl
      实现RMIConnection接口。
      class  | RMIConnectionImpl_Stub
      class  RMIIIOPServerImpl
      已过时。
      此运输已不再受支持。
      class  RMIJRMPServerImpl
      一个RMIServer对象，通过JRMP导出，并将客户端连接创建为通过JRMP导出的RMI对象。
      class  RMIServerImpl
      表示连接器服务器的RMI对象。
      class  | RMIServerImpl_Stub
      Methods in javax.management.remote.rmi that return Remote
      Modifier and Type 方法 描述
      Remote RMIIIOPServerImpl.toStub​()
      已过时。
      Remote RMIJRMPServerImpl.toStub​()
      返回此RMIServer对象的可序列存根。
      abstract Remote RMIServerImpl.toStub​()
      返回此服务器对象的远程存根。

    • Uses of Remote in javax.rmi

      Methods in javax.rmi that return Remote
      Modifier and Type 方法 描述
      static Remote PortableRemoteObject.toStub​(Remote obj)
      返回给定服务器对象的存根。
      Methods in javax.rmi with parameters of type Remote
      Modifier and Type 方法 描述
      static void PortableRemoteObject.connect​(Remote target, Remote source)
      使远程对象准备好进行远程通信。
      static void PortableRemoteObject.exportObject​(Remote obj)
      使服务器对象准备好接收远程调用。
      static Remote PortableRemoteObject.toStub​(Remote obj)
      返回给定服务器对象的存根。
      static void PortableRemoteObject.unexportObject​(Remote obj)
      从运行时取消注册服务器对象，允许对象可用于垃圾回收。

    • Uses of Remote in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that return Remote
      Modifier and Type 方法 描述
      Remote Tie.getTarget​()
      返回此领带的目标。
      Remote PortableRemoteObjectDelegate.toStub​(Remote obj)
      代表团要求 PortableRemoteObject.toStub(java.rmi.Remote) 。
      Methods in javax.rmi.CORBA with parameters of type Remote
      Modifier and Type 方法 描述
      void PortableRemoteObjectDelegate.connect​(Remote target, Remote source)
      代表团要求 PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 。
      void PortableRemoteObjectDelegate.exportObject​(Remote obj)
      代表团要求 PortableRemoteObject.exportObject(java.rmi.Remote) 。
      static Tie Util.getTie​(Remote target)
      返回给定目标对象的tie（如果有）。
      Tie UtilDelegate.getTie​(Remote target)
      代表团要求 Util.getTie(java.rmi.Remote) 。
      static void Util.registerTarget​(Tie tie, Remote target)
      注册一个领带的目标。
      void UtilDelegate.registerTarget​(Tie tie, Remote target)
      代表团要求 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 。
      void Tie.setTarget​(Remote target)
      由 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote)呼吁设定这个领带的目标。
      Remote PortableRemoteObjectDelegate.toStub​(Remote obj)
      代表团要求 PortableRemoteObject.toStub(java.rmi.Remote) 。
      void PortableRemoteObjectDelegate.unexportObject​(Remote obj)
      代表团要求 PortableRemoteObject.unexportObject(java.rmi.Remote) 。
      static void Util.unexportObject​(Remote target)
      从内部表中删除相关联的绑定，并调用 Tie.deactivate()以停用该对象。
      void UtilDelegate.unexportObject​(Remote target)
      代表团要求 Util.unexportObject(java.rmi.Remote) 。

    • Uses of Remote in org.omg.stub.java.rmi

      Classes in org.omg.stub.java.rmi that implement Remote
      Modifier and Type Class 描述
      class  _Remote_Stub
      This class provides the Stub for the Remote Type.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


DGC (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.dgc

Interface DGC

  • All Superinterfaces:
    Remote

    public interface DGC
extends Remote
    DGC抽象用于分布式垃圾回收算法的服务器端。 此界面包含两种方法：脏和干净。 当远程引用在客户机中解组（客户端由其VMID指示）时，会发出脏调用。 当客户端中不再有对远程引用的引用时，将进行相应的干净调用。 一个失败的脏呼叫必须安排一个强大的干净的呼叫，以便可以保留呼叫的序列号，以便检测分布式垃圾回收器按顺序接收到的未来呼叫。 对远程对象的引用由持有引用的客户端租用一段时间。 接收到脏呼叫时，租约期开始。 客户有义务通过在租赁期满之前对其所拥有的远程引用进行额外的肮脏呼叫来更新租约。 如果客户端在租期过期之前不更新租约，则分布式垃圾收集器将假定远程对象不再被该客户端引用。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void clean​(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong)
      干净的呼叫从'id'中指示的每个远程对象的引用列表中删除'vmid'。
      Lease dirty​(ObjID[] ids, long sequenceNum, Lease lease)
      对于与数组“ids”中包含的对象标识符相关联的远程对象引用的脏调用请求。

    • 方法详细信息

      • dirty

        Lease dirty​(ObjID[] ids,
            long sequenceNum,
            Lease lease)
     throws RemoteException
        对于与数组“ids”中包含的对象标识符相关联的远程对象引用的脏调用请求。 “租赁”包含客户端的唯一VM标识符（VMID）和请求的租期。 对于在本地VM中导出的每个远程对象，垃圾收集器维护一个引用列表 - 一个包含对它的引用的客户端列表。 如果租赁被授予，垃圾收集器将客户端的VMID添加到“ids”中指示的每个远程对象的引用列表。 'sequenceNum'参数是一个序列号，用于检测和丢弃对垃圾回收器的延迟调用。 对于垃圾回收器的每次后续调用，序列号应始终增加。 某些客户端无法生成VMID，因为VMID是一个通用唯一标识符，其中包含由于安全限制而导致某些客户端无法获取的主机地址。 在这种情况下，客户端可以使用空值为VM的VMID，分布式垃圾回收器将为客户端分配VMID。 脏调用返回一个包含所使用的VMID和为远程引用授予的租赁期的租赁对象（服务器可能决定授予比客户端请求更小的租约期）。 客户端必须使用垃圾回收器使用的VMID，以便在客户端丢弃远程对象引用时进行相应的干净调用。 客户端VM只需要为虚拟机中引用的每个远程引用创建一个初始的脏调用（即使它具有对同一个远程对象的多个引用）。 客户还必须在此类租赁期满之前，对远程引用的租约进行更换。 当客户端不再具有对特定远程对象的引用时，它必须为与引用相关联的对象ID调度一个干净的调用。
        参数
        ids - 通过调用客户机引用标记的对象的ID
        sequenceNum - 序列号
        lease - 请求租赁
        结果
        授予租赁
        异常
        RemoteException - 如果脏调用失败

      • clean

        void clean​(ObjID[] ids,
           long sequenceNum,
           VMID vmid,
           boolean strong)
    throws RemoteException
        干净的呼叫从'id'中指示的每个远程对象的引用列表中删除'vmid'。 序列号用于检测较晚的清洁呼叫。 如果参数'strong'为真，那么干净的调用是一个失败的脏调用的结果，因此客户'vmid'的序列号需要被记住。
        参数
        ids - 通过调用客户端标记为未引用的对象的ID
        sequenceNum - 序列号
        vmid - 客户机VMID
        strong - 使'强'干净的通话
        异常
        RemoteException - 如果干净的通话失败
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.rmi.dgc (Java SE 9 & JDK 9 )

java.rmi.dgc

Interfaces

  • DGC

Classes

  • Lease
  • VMID


java.rmi.dgc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.rmi

Package java.rmi.dgc

提供RMI分布式垃圾收集（DGC）的类和接口。 当RMI服务器将对象返回给其客户端（远程方法的调用者）时，它会跟踪远程对象在客户端中的使用情况。 当没有更多的对客户端上的远程对象的引用，或者如果引用的“租约”过期而未更新，则服务器将垃圾收集远程对象。
从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    DGC
    DGC抽象用于分布式垃圾回收算法的服务器端。
  • 类摘要
    Class 描述
    Lease
    租赁包含唯一的VM标识符和租期。
    VMID
    VMID是所有Java虚拟机中唯一的标识符。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.rmi.dgc Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.rmi.dgc

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.rmi.dgc.Lease (implements java.io.Serializable)
    • java.rmi.dgc.VMID (implements java.io.Serializable)

Interface Hierarchy

  • java.rmi.Remote
    • java.rmi.dgc.DGC
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Lease (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.dgc

Class Lease

  • java.lang.Object
    • java.rmi.dgc.Lease
  • All Implemented Interfaces:
    Serializable

    public final class Lease
extends Object
implements Serializable
    租赁包含唯一的VM标识符和租期。 租赁对象用于向远程对象引用请求和授予租约。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Lease​(VMID id, long duration)
      构建具有特定VMID和租期的租约。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      long getValue​()
      返回租期。
      VMID getVMID​()
      返回与租约相关联的客户端VMID。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Lease

        public Lease​(VMID id,
             long duration)
        构建具有特定VMID和租期的租约。 vmid可能为null。
        参数
        id - 与此租约相关联的VMID
        duration - 租期

    • 方法详细信息

      • getVMID

        public VMID getVMID​()
        返回与租约相关联的客户端VMID。
        结果
        客户机VMID

      • getValue

        public long getValue​()
        返回租期。
        结果
        lease duration
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.rmi.dgc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.rmi.dgc

  • Packages that use java.rmi.dgc
    软件包 描述
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
  • Classes in java.rmi.dgc used by java.rmi.dgc
    Class 描述
    Lease
    租赁包含唯一的VM标识符和租期。
    VMID
    VMID是所有Java虚拟机中唯一的标识符。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


VMID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.dgc

Class VMID

  • java.lang.Object
    • java.rmi.dgc.VMID
  • All Implemented Interfaces:
    Serializable

    public final class VMID
extends Object
implements Serializable
    VMID是所有Java虚拟机中唯一的标识符。 分布式垃圾收集器使用VMID来识别客户端虚拟机。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      VMID​()
      创建一个新的VMID。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此VMID与另一个进行比较，如果它们是相同的标识符，则返回true。
      int hashCode​()
      计算此VMID的哈希码。
      static boolean isUnique​()
      已过时。
      String toString​()
      返回此VMID的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • VMID

        public VMID​()
        创建一个新的VMID。 在以下条件下，从此构造函数返回的每个新的VMID对于所有Java虚拟机都是唯一的：a）满足java.rmi.server.UID类的对象的唯一性条件，b）可以为该主机获取唯一和常数的地址在这个对象的一生中。

    • 方法详细信息

      • isUnique

        @Deprecated
public static boolean isUnique​()
        已过时。
        如果可以为此主机确定准确的地址，则返回true。 如果为false，则无法从此主机生成可靠的VMID
        结果
        如果可以确定主机地址，则为true，否则为false

      • hashCode

        public int hashCode​()
        计算此VMID的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将此VMID与另一个进行比较，如果它们是相同的标识符，则返回true。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果此对象与obj参数相同， true ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回此VMID的字符串表示形式。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class java.rmi.dgc.Lease (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.dgc.Lease

  • Packages that use Lease
    软件包 描述
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。

    • Uses of Lease in java.rmi.dgc

      Methods in java.rmi.dgc that return Lease
      Modifier and Type 方法 描述
      Lease DGC.dirty​(ObjID[] ids, long sequenceNum, Lease lease)
      对于与数组“ids”中包含的对象标识符相关联的远程对象引用的脏调用请求。
      Methods in java.rmi.dgc with parameters of type Lease
      Modifier and Type 方法 描述
      Lease DGC.dirty​(ObjID[] ids, long sequenceNum, Lease lease)
      对于与数组“ids”中包含的对象标识符相关联的远程对象引用的脏调用请求。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.dgc.VMID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.dgc.VMID

  • Packages that use VMID
    软件包 描述
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。

    • Uses of VMID in java.rmi.dgc

      Methods in java.rmi.dgc that return VMID
      Modifier and Type 方法 描述
      VMID Lease.getVMID​()
      返回与租约相关联的客户端VMID。
      Methods in java.rmi.dgc with parameters of type VMID
      Modifier and Type 方法 描述
      void DGC.clean​(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong)
      干净的呼叫从'id'中指示的每个远程对象的引用列表中删除'vmid'。
      Constructors in java.rmi.dgc with parameters of type VMID
      Constructor 描述
      Lease​(VMID id, long duration)
      构建具有特定VMID和租期的租约。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.dgc.DGC (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.dgc.DGC

No usage of java.rmi.dgc.DGC
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


java.rmi.registry (Java SE 9 & JDK 9 )

java.rmi.registry

Interfaces

  • Registry
  • RegistryHandler

Classes

  • LocateRegistry


java.rmi.registry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.rmi

Package java.rmi.registry

为RMI注册表提供一个类和两个接口。 注册表是将名称映射到远程对象的远程对象。 服务器将其远程对象注册到注册表中，以便查找它们。 200的X- 200 X- 200 X- 200 200 200 X- 200 200 X- 200 200 X- 200 200 X- 新新200新新200新新新新旗新新200新新200新200新新200新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新Version
从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    Registry
    Registry是一个简单的远程对象注册表的远程接口，提供了用于存储和检索与任意字符串名称绑定的远程对象引用的方法。
    RegistryHandler Deprecated.
    没有替换
  • 类摘要
    Class 描述
    LocateRegistry
    LocateRegistry用于获取对特定主机（包括本地主机）上的引导远程对象注册表的引用，或用于创建接受特定端口上的调用的远程对象注册表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.rmi.registry Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.rmi.registry

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.rmi.registry.LocateRegistry

Interface Hierarchy

  • java.rmi.registry.RegistryHandler
  • java.rmi.Remote
    • java.rmi.registry.Registry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LocateRegistry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.registry

Class LocateRegistry

  • java.lang.Object
    • java.rmi.registry.LocateRegistry

  • public final class LocateRegistry
extends Object
    LocateRegistry用于获取对特定主机（包括本地主机）上的引导远程对象注册表的引用，或用于创建接受特定端口上的调用的远程对象注册表。

    请注意， getRegistry呼叫实际上并不连接到远程主机。 它只是创建对远程注册表的本地引用，并且即使没有在远程主机上运行注册表，也将成功。 因此，作为此方法的结果返回的远程注册表的后续方法调用可能会失败。

    从以下版本开始：
    1.1
    另请参见：
    Registry

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Registry createRegistry​(int port)
      在本地主机上创建并导出 Registry实例，该实例接受指定的 port请求。
      static Registry createRegistry​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      在本地主机上创建和导出 Registry实例，该实例使用自定义套接字工厂进行与该实例的通信。
      static Registry getRegistry​()
      返回对默认注册表端口1099的本地主机的远程对象 Registry的引用。
      static Registry getRegistry​(int port)
      返回对指定的 port的本地主机的远程对象 Registry的引用。
      static Registry getRegistry​(String host)
      返回对默认注册表端口1099上指定的 host上的远程对象 Registry的引用。
      static Registry getRegistry​(String host, int port)
      返回对指定的 host和 port上的远程对象 Registry的 port 。
      static Registry getRegistry​(String host, int port, RMIClientSocketFactory csf)
      返回本地创建的对指定的 host和 port的远程对象 Registry远程引用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getRegistry

        public static Registry getRegistry​()
                            throws RemoteException
        返回对默认注册表端口1099的本地主机的远程对象 Registry的引用。
        结果
        引用（stub）到远程对象注册表
        异常
        RemoteException - 如果无法创建引用
        从以下版本开始：
        1.1

      • getRegistry

        public static Registry getRegistry​(int port)
                            throws RemoteException
        在指定的 port上返回对本地主机的远程对象 Registry的引用。
        参数
        port - 注册表接受请求的端口
        结果
        引用（stub）到远程对象注册表
        异常
        RemoteException - 如果无法创建引用
        从以下版本开始：
        1.1

      • getRegistry

        public static Registry getRegistry​(String host)
                            throws RemoteException
        返回对默认注册表端口1099上指定的 host上的远程对象 Registry的引用。如果 host为 null ，则使用本地主机。
        参数
        host - 远程注册表的主机
        结果
        引用（stub）到远程对象注册表
        异常
        RemoteException - 如果无法创建引用
        从以下版本开始：
        1.1

      • getRegistry

        public static Registry getRegistry​(String host,
                                   int port)
                            throws RemoteException
        在指定的host和port上返回对远程对象Registry的port 。 如果host是null ，则使用本地主机。
        参数
        host - 远程注册表的主机
        port - 注册表接受请求的端口
        结果
        引用（stub）到远程对象注册表
        异常
        RemoteException - 如果无法创建引用
        从以下版本开始：
        1.1

      • getRegistry

        public static Registry getRegistry​(String host,
                                   int port,
                                   RMIClientSocketFactory csf)
                            throws RemoteException
        返回本地创建的对指定的host和port的远程对象Registry远程引用。 与此远程注册表的通信将使用随附的RMIClientSocketFactory csf创建Socket连接到远程host和port的注册表。
        参数
        host - 远程注册表的主机
        port - 注册表接受请求的端口
        csf - 客户端Socket工厂用于连接注册表。 如果csf为空，则默认的客户端Socket工厂将在注册表存根中使用。
        结果
        引用（存根）到远程注册表
        异常
        RemoteException - 如果无法创建引用
        从以下版本开始：
        1.2

      • createRegistry

        public static Registry createRegistry​(int port)
                               throws RemoteException
        在本地主机上创建并导出Registry实例，该实例接受指定的port请求。

        所述Registry实例被导出为如果静态UnicastRemoteObject.exportObject方法被调用时，使所述Registry实例和指定port作为参数，不同的是Registry实例与公知的对象标识符，导出ObjID与值构建的实例ObjID.REGISTRY_ID 。

        参数
        port - 注册表接受请求的端口
        结果
        注册表
        异常
        RemoteException - 如果注册表无法导出
        从以下版本开始：
        1.1

      • createRegistry

        public static Registry createRegistry​(int port,
                                      RMIClientSocketFactory csf,
                                      RMIServerSocketFactory ssf)
                               throws RemoteException
        在本地主机上创建和导出Registry实例，该实例使用自定义套接字工厂进行与该实例的通信。 所创建的注册表监听给定传入请求port使用ServerSocket从所提供的创建RMIServerSocketFactory 。

        Registry实例被导出，就像调用静态的UnicastRemoteObject.exportObject方法一样，传递Registry实例，指定的port ，指定的RMIClientSocketFactory和指定的RMIServerSocketFactory作为参数，不同之处在于使用一个公知的对象标识符导出Registry实例， ObjID实例与值构造ObjID.REGISTRY_ID 。

        参数
        port - 注册表接受请求的端口
        csf - 客户端 Socket工厂用于连接注册表
        ssf - 服务器端 ServerSocket工厂用于接受注册表的连接
        结果
        注册表
        异常
        RemoteException - 如果无法导出注册表
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Registry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.registry

Interface Registry

  • All Superinterfaces:
    Remote

    public interface Registry
extends Remote
    Registry是一个简单的远程对象注册表的远程接口，提供用于存储和检索与任意字符串名称绑定的远程对象引用的方法。 该bind ， unbind ，并rebind方法用于改变注册表中的名称绑定，以及lookup种list方法用于查询当前的名称绑定。

    在其典型用法中， Registry启用RMI客户端引导：它为客户端获取对远程对象的初始引用提供了一种简单的方法。 因此，注册表的远程对象实现通常使用公知的地址导出，例如使用众所周知的ObjID和TCP端口号（默认为1099 ）。

    LocateRegistry类提供了一个编程API，用于构建对远程地址（参见静态getRegistry方法）的Registry的引导引用， Registry在特定本地地址上的当前虚拟机中创建和导出Registry （请参阅静态createRegistry方法）。

    A Registry实现可以选择限制对其部分或全部方法的访问（例如，将注册表绑定变异的方法可能被限制为源自本地主机的呼叫）。 如果Registry方法选择拒绝给定调用的访问，则其实现可能会抛出AccessException （由于扩展RemoteException ）将被远程客户端捕获时包装在一个ServerException中 。

    Registry 在Registry存储其远程引用的Registry可能希望在名称绑定中使用包名称作为前缀，以减少注册表中名称冲突的可能性。

    从以下版本开始：
    1.1
    另请参见：
    LocateRegistry

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int REGISTRY_PORT
      众所周知的注册端口。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void bind​(String name, Remote obj)
      绑定到此注册表中指定的 name的远程引用。
      String[] list​()
      返回在此注册表中绑定的名称的数组。
      Remote lookup​(String name)
      返回绑定到此注册表中指定的 name的远程引用。
      void rebind​(String name, Remote obj)
      将该注册表中指定的 name的绑定替换为附带的远程引用。
      void unbind​(String name)
      删除此注册表中指定的 name的绑定。

    • 字段详细信息

      • REGISTRY_PORT

        static final int REGISTRY_PORT
        众所周知的注册端口。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • lookup

        Remote lookup​(String name)
       throws RemoteException,
              NotBoundException,
              AccessException
        返回绑定到此注册表中指定的 name的远程引用。
        参数
        name - 要查找的远程参考的名称
        结果
        对远程对象的引用
        异常
        NotBoundException - 如果 name当前未绑定
        RemoteException - 如果与注册表的远程通信失败; 如果异常是ServerException含有AccessException ，则注册表拒绝访问呼叫者来执行此操作
        AccessException - 如果此注册表是本地注册表，并且它拒绝主叫方访问以执行此操作
        NullPointerException - 如果 name是 null

      • bind

        void bind​(String name,
          Remote obj)
   throws RemoteException,
          AlreadyBoundException,
          AccessException
        绑定到此注册表中指定的 name的远程引用。
        参数
        name - 与远程引用关联的名称
        obj - 对远程对象的引用（通常是存根）
        异常
        AlreadyBoundException - 如果已经绑定了 name
        RemoteException - 如果与注册表的远程通信失败; 如果异常是包含ServerException的AccessException ，则注册表拒绝主叫方访问来执行此操作（例如，源自非本地主机）
        AccessException - 如果此注册表是本地注册表，并且拒绝来电者访问以执行此操作
        NullPointerException - 如果 name是 null ，或者如果 obj是 null

      • unbind

        void unbind​(String name)
     throws RemoteException,
            NotBoundException,
            AccessException
        删除此注册表中指定的 name的绑定。
        参数
        name - 要删除的绑定的名称
        异常
        NotBoundException - 如果 name当前未绑定
        RemoteException - 如果与注册表的远程通信失败; 如果异常是包含ServerException的AccessException ，则注册表拒绝主叫方访问来执行此操作（例如，来自非本地主机）
        AccessException - 如果此注册表是本地注册表，并且拒绝来电者访问以执行此操作
        NullPointerException - 如果 name是 null

      • rebind

        void rebind​(String name,
            Remote obj)
     throws RemoteException,
            AccessException
        使用提供的远程引用替换此注册表中指定的name的绑定。 如果对于指定的name有现有绑定，则会被丢弃。
        参数
        name - 与远程引用关联的名称
        obj - 对远程对象的引用（通常是存根）
        异常
        RemoteException - 如果与注册表的远程通信失败; 如果异常是ServerException含有AccessException ，则注册表拒绝访问呼叫者来执行此操作（如果源自非本地主机，例如）
        AccessException - 如果此注册表是本地注册表，并且拒绝来电者访问以执行此操作
        NullPointerException - 如果 name是 null ，或者如果 obj是 null

      • list

        String[] list​()
       throws RemoteException,
              AccessException
        返回在此注册表中绑定的名称的数组。 在该方法的给定调用时，数组将包含在此注册表中绑定的名称的快照。
        结果
        在这个注册表中绑定的名称的数组
        异常
        RemoteException - 如果与注册表的远程通信失败; 如果异常是ServerException含有AccessException ，则注册表拒绝访问呼叫者来执行此操作
        AccessException - 如果此注册表是本地注册表，并且拒绝主叫方访问以执行此操作
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RegistryHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.registry

Interface RegistryHandler

  • 已过时。
    没有替换

    @Deprecated
public interface RegistryHandler
    RegistryHandler就新新新RegistryHandler就新RegistryHandler 它不应该被应用程序代码访问。
    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      Registry registryImpl​(int port)
      已过时。
      没有替换。 从Java 2平台v1.2开始，RMI不再使用RegistryHandler获取注册表的实现。
      Registry registryStub​(String host, int port)
      已过时。
      没有替换。 从Java 2平台v1.2开始，RMI不再使用RegistryHandler获取注册表的存根。

    • 方法详细信息

      • registryStub

        @Deprecated
Registry registryStub​(String host,
                      int port)
               throws RemoteException,
                      UnknownHostException
        已过时。 没有替换。 从Java 2平台v1.2起，RMI不再使用RegistryHandler获取注册表的存根。
        返回用于联系指定主机和端口上的远程注册表的“存根”。
        参数
        host - 远程注册表主机的名称
        port - 远程注册表端口
        结果
        远程注册表存根
        异常
        RemoteException - 如果发生远程错误
        UnknownHostException - 如果无法解析给定的主机名

      • registryImpl

        @Deprecated
Registry registryImpl​(int port)
               throws RemoteException
        已过时。 没有替换。 从Java 2平台v1.2起，RMI不再使用RegistryHandler来获取注册表的实现。
        在指定端口上构造和导出注册表。 端口必须非零。
        参数
        port - 端口导出注册表
        结果
        注册表存根
        异常
        RemoteException - 如果发生远程错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.rmi.registry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.rmi.registry

  • Packages that use java.rmi.registry
    软件包 描述
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。
  • Classes in java.rmi.registry used by java.rmi.registry
    Class 描述
    Registry
    Registry是一个简单的远程对象注册表的远程接口，提供了用于存储和检索与任意字符串名称绑定的远程对象引用的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.registry.LocateRegistry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.registry.LocateRegistry

No usage of java.rmi.registry.LocateRegistry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.registry.Registry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.registry.Registry

  • Packages that use Registry
    软件包 描述
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。

    • Uses of Registry in java.rmi.registry

      Methods in java.rmi.registry that return Registry
      Modifier and Type 方法 描述
      static Registry LocateRegistry.createRegistry​(int port)
      在本地主机上创建并导出 Registry实例，该实例接受指定的 port上的请求。
      static Registry LocateRegistry.createRegistry​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      在本地主机上创建并导出 Registry实例，该实例使用自定义套接字工厂进行与该实例的通信。
      static Registry LocateRegistry.getRegistry​()
      返回对默认注册表端口1099的本地主机的远程对象 Registry的引用。
      static Registry LocateRegistry.getRegistry​(int port)
      在指定的 port上返回对本地主机的远程对象 Registry的引用。
      static Registry LocateRegistry.getRegistry​(String host)
      返回对默认注册表端口1099上指定的 host上的远程对象 Registry的引用。
      static Registry LocateRegistry.getRegistry​(String host, int port)
      返回对指定的 host和 port上的远程对象 Registry的 port 。
      static Registry LocateRegistry.getRegistry​(String host, int port, RMIClientSocketFactory csf)
      返回在指定的 host和 port上的远程对象 Registry的本地创建的远程引用。
      Registry RegistryHandler.registryImpl​(int port)
      已过时。
      没有替换。 从Java 2平台v1.2开始，RMI不再使用RegistryHandler获取注册表的实现。
      Registry RegistryHandler.registryStub​(String host, int port)
      已过时。
      没有替换。 从Java 2平台v1.2开始，RMI不再使用RegistryHandler获取注册表的存根。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.registry.RegistryHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.registry.RegistryHandler

No usage of java.rmi.registry.RegistryHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ExportException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class ExportException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.server.ExportException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    SocketSecurityException

    public class ExportException
extends RemoteException
    如果尝试导出远程对象失败，则ExportException是抛出的一个RemoteException 。 远程对象通过构造和出口exportObject的方法java.rmi.server.UnicastRemoteObject和java.rmi.activation.Activatable 。
    从以下版本开始：
    1.1
    另请参见：
    UnicastRemoteObject ， Activatable ， Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      ExportException​(String s)
      构造具有指定详细消息的 ExportException 。
      ExportException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ExportException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ExportException

        public ExportException​(String s)
        构造具有指定详细消息的 ExportException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.1

      • ExportException

        public ExportException​(String s,
                       异常 ex)
        构造具有指定的详细消息和嵌套异常的 ExportException 。
        参数
        s - 详细信息
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.rmi.server (Java SE 9 & JDK 9 )

java.rmi.server

Interfaces

  • LoaderHandler
  • RemoteCall
  • RemoteRef
  • RMIClientSocketFactory
  • RMIFailureHandler
  • RMIServerSocketFactory
  • ServerRef
  • Skeleton
  • Unreferenced

Classes

  • LogStream
  • ObjID
  • Operation
  • RemoteObject
  • RemoteObjectInvocationHandler
  • RemoteServer
  • RemoteStub
  • RMIClassLoader
  • RMIClassLoaderSpi
  • RMISocketFactory
  • UID
  • UnicastRemoteObject

Exceptions

  • ExportException
  • ServerCloneException
  • ServerNotActiveException
  • SkeletonMismatchException
  • SkeletonNotFoundException
  • SocketSecurityException


java.rmi.server (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.rmi

Package java.rmi.server

提供用于支持RMI服务器端的类和接口。 由rmic stub编译器生成的存根和骨架使用一组类。 另一组类实现了RMI传输协议和HTTP隧道。

已弃用：HTTP隧道。 HTTP隧道机制已被弃用。 详见RMISocketFactory 。

已弃用：骨架和静态存根。 骷髅和静态生成的存根已被弃用。 这包括此包中需要使用骨架或静态存根的API，对它们的运行时支持以及使用rmic存根编译器生成它们。 在平台的将来版本中，可以删除对骨架和静态存根的支持。 骨架是不必要的，因为服务器端方法调度由RMI运行时直接处理。 静态生成的存根是不必要的，因为使用Proxy对象动态生成存根。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。 通常通过调用rmic工具来生成骨架和静态桩，作为应用程序构建过程的rmic 。 这是不必要的，并且可以简单地省略对rmic调用。

从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    LoaderHandler Deprecated.
    没有替换
    RemoteCall Deprecated.
    没有替换。
    RemoteRef
    RemoteRef表示远程对象的句柄。
    RMIClientSocketFactory
    RMI运行时使用 RMIClientSocketFactory实例，以获取RMI调用的客户端套接字。
    RMIFailureHandler
    一个 RMIFailureHandler可以通过 RMISocketFactory.setFailureHandler通话进行注册。
    RMIServerSocketFactory
    RMI运行时使用一个 RMIServerSocketFactory实例，以获取RMI调用的服务器套接字。
    ServerRef Deprecated.
    没有替换
    Skeleton Deprecated.
    没有替换。
    Unreferenced
    当没有更多的客户端引用该远程对象时，远程对象实现应实现 Unreferenced接口以接收通知。
  • 类摘要
    Class 描述
    LogStream Deprecated.
    没有替换
    ObjID
    ObjID用于标识导出到RMI运行时的远程对象。
    Operation Deprecated.
    没有替换
    RemoteObject
    RemoteObject类实现了远程对象的 java.lang.Object行为。
    RemoteObjectInvocationHandler
    用于Java远程方法调用（Java RMI）的 InvocationHandler接口的实现。
    RemoteServer
    RemoteServer类是服务器实现的常见超类，并提供了支持各种远程引用语义的框架。
    RemoteStub Deprecated.
    静态生成的存根被不推荐使用，因为存根是动态生成的。
    RMIClassLoader
    RMIClassLoader包含支持使用RMI的动态类加载的静态方法。
    RMIClassLoaderSpi
    RMIClassLoaderSpi是服务提供者接口 RMIClassLoader 。
    RMISocketFactory
    RMI运行时使用 RMISocketFactory实例，以获取RMI调用的客户端和服务器套接字。
    UID
    A UID表示相对于其在其上生成的主机或者 16个 “知名”标识符之一的时间而言是唯一的标识符。
    UnicastRemoteObject
    用于使用JRMP导出远程对象并获取与远程对象通信的存根。
  • 异常摘要
    异常 描述
    ExportException
    如果尝试导出远程对象失败，则 ExportException是抛出的 RemoteException 。
    ServerCloneException
    甲 ServerCloneException如果一个的克隆过程中发生远程抛出异常 UnicastRemoteObject 。
    ServerNotActiveException
    如果在服务远程方法调用之外调用getClientHost方法，则 ServerNotActiveException是在调用 异常期间抛出的 RemoteServer.getClientHost 。
    SkeletonMismatchException Deprecated.
    没有替换。
    SkeletonNotFoundException Deprecated.
    没有替换。
    SocketSecurityException Deprecated.
    这个班已经过时了
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.rmi.server Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.rmi.server

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.rmi.server.ObjID (implements java.io.Serializable)
    • java.rmi.server.Operation
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • java.io.PrintStream (implements java.lang.Appendable, java.io.Closeable)
          • java.rmi.server.LogStream
    • java.rmi.server.RemoteObject (implements java.rmi.Remote, java.io.Serializable)
      • java.rmi.server.RemoteObjectInvocationHandler (implements java.lang.reflect.InvocationHandler)
      • java.rmi.server.RemoteServer
        • java.rmi.server.UnicastRemoteObject
      • java.rmi.server.RemoteStub
    • java.rmi.server.RMIClassLoader
    • java.rmi.server.RMIClassLoaderSpi
    • java.rmi.server.RMISocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.rmi.server.RMIServerSocketFactory)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.CloneNotSupportedException
          • java.rmi.server.ServerCloneException
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.server.ExportException
              • java.rmi.server.SocketSecurityException
            • java.rmi.server.SkeletonMismatchException
            • java.rmi.server.SkeletonNotFoundException
        • java.rmi.server.ServerNotActiveException
    • java.rmi.server.UID (implements java.io.Serializable)

Interface Hierarchy

  • java.rmi.server.LoaderHandler
  • java.rmi.server.RemoteCall
  • java.rmi.server.RMIClientSocketFactory
  • java.rmi.server.RMIFailureHandler
  • java.rmi.server.RMIServerSocketFactory
  • java.io.Serializable
    • java.io.Externalizable
      • java.rmi.server.RemoteRef
        • java.rmi.server.ServerRef
  • java.rmi.server.Skeleton
  • java.rmi.server.Unreferenced
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LoaderHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Interface LoaderHandler

  • 已过时。
    没有替换

    @Deprecated
public interface LoaderHandler
    LoaderHandler是在以前的实现版本中由RMI运行时内部使用的接口。 它不应该被应用程序代码访问。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String packagePrefix
      已过时。
      系统封装 LoaderHandler实现。

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      Object getSecurityContext​(ClassLoader loader)
      已过时。
      没有替换
      Class<?> loadClass​(String name)
      已过时。
      没有替换
      Class<?> loadClass​(URL codebase, String name)
      已过时。
      没有替换

    • 字段详细信息

      • packagePrefix

        static final String packagePrefix
        已过时。
        系统封装 LoaderHandler实现。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • loadClass

        @Deprecated
Class<?> loadClass​(String name)
            throws MalformedURLException,
                   ClassNotFoundException
        已过时。 没有替换
        从 java.rmi.server.codebase属性指定的位置加载课程。
        参数
        name - 要加载的类的名称
        结果
        表示加载类的 Class对象
        异常
        MalformedURLException - 如果系统属性 java.rmi.server.codebase包含无效的URL
        ClassNotFoundException - 如果在代码库位置找不到类的定义。
        从以下版本开始：
        1.1

      • loadClass

        @Deprecated
Class<?> loadClass​(URL codebase,
                   String name)
            throws MalformedURLException,
                   ClassNotFoundException
        已过时。 没有替换
        从URL加载一个类。
        参数
        codebase - 加载类的URL
        name - 要加载的类的名称
        结果
        表示加载的类的 Class对象
        异常
        MalformedURLException - 如果 codebase参数包含无效的URL
        ClassNotFoundException - 如果在指定的URL处找不到类的定义
        从以下版本开始：
        1.1

      • getSecurityContext

        @Deprecated
Object getSecurityContext​(ClassLoader loader)
        已过时。 没有替换
        返回给定类加载器的安全上下文。
        参数
        loader - 从中获取安全上下文的类加载器
        结果
        安全上下文
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


LogStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class LogStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.io.PrintStream
          • java.rmi.server.LogStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable
    已过时。
    没有替换

    @Deprecated
public class LogStream
extends PrintStream
    LogStream提供了一种用于记录对监视系统的用户可能感兴趣的错误的机制。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BRIEF
      已过时。
      日志级别常量（简短日志记录）。
      static int SILENT
      已过时。
      日志级别常量（无日志记录）。
      static int VERBOSE
      已过时。
      日志级别常量（详细日志记录）。

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static PrintStream getDefaultStream​()
      已过时。
      没有替换
      OutputStream getOutputStream​()
      已过时。
      没有替换
      static LogStream log​(String name)
      已过时。
      没有替换
      static int parseLevel​(String s)
      已过时。
      没有替换
      static void setDefaultStream​(PrintStream newDefault)
      已过时。
      没有替换
      void setOutputStream​(OutputStream out)
      已过时。
      没有替换
      String toString​()
      已过时。
      没有替换
      void write​(byte[] b, int off, int len)
      已过时。
      没有替换
      void write​(int b)
      已过时。
      没有替换

      • Methods inherited from class java.io.FilterOutputStream

        write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.io.PrintStream

        append, append, append, checkError, clearError, close, flush, format, format, print, print, print, print, print, print, print, print, print, printf, printf, println, println, println, println, println, println, println, println, println, println, setError

    • 字段详细信息

      • SILENT

        public static final int SILENT
        已过时。
        日志级别常量（无日志记录）。
        另请参见：
        Constant Field Values

      • BRIEF

        public static final int BRIEF
        已过时。
        日志级别常量（简短日志记录）。
        另请参见：
        Constant Field Values

      • VERBOSE

        public static final int VERBOSE
        已过时。
        日志级别常量（详细日志记录）。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • log

        @Deprecated
public static LogStream log​(String name)
        已过时。 没有替换
        返回由给定名称标识的LogStream。 如果对应于“name”的日志不存在，则会创建使用默认流的日志。
        参数
        name - 标识所需 name名称
        结果
        与给定名称关联的日志
        从以下版本开始：
        1.1

      • getDefaultStream

        @Deprecated
public static PrintStream getDefaultStream​()
        已过时。 没有替换
        返回新日志的当前默认流。
        结果
        默认日志流
        从以下版本开始：
        1.1
        另请参见：
        setDefaultStream(java.io.PrintStream)

      • setDefaultStream

        @Deprecated
public static void setDefaultStream​(PrintStream newDefault)
        已过时。 没有替换
        设置新日志的默认流。
        参数
        newDefault - 新的默认日志流
        从以下版本开始：
        1.1
        另请参见：
        getDefaultStream()

      • getOutputStream

        @Deprecated
public OutputStream getOutputStream​()
        已过时。 没有替换
        返回发送到该日志的输出的当前流。
        结果
        输出流为此日志
        从以下版本开始：
        1.1
        另请参见：
        setOutputStream(java.io.OutputStream)

      • setOutputStream

        @Deprecated
public void setOutputStream​(OutputStream out)
        已过时。 没有替换
        设置发送此日志的输出流。
        参数
        out - 此日志的新输出流
        从以下版本开始：
        1.1
        另请参见：
        getOutputStream()

      • write

        @Deprecated
public void write​(int b)
        已过时。 没有替换
        向流中写入一个字节的数据。 如果不是换行符，那么该字节将附加到内部缓冲区。 如果是换行符，则将当前缓存的行发送到日志的输出流，前缀为相应的日志信息。
        重写：
        write在 PrintStream
        参数
        b - 要写入的字节
        从以下版本开始：
        1.1
        另请参见：
        PrintStream.print(char) ， PrintStream.println(char)

      • write

        @Deprecated
public void write​(byte[] b,
                  int off,
                  int len)
        已过时。 没有替换
        写一个字节的子阵列。 通过写字节方法传递。
        重写：
        write在 PrintStream
        参数
        b - 一个字节数组
        off - off开始 off字节的偏移量
        len - 要写入的字节数
        从以下版本开始：
        1.1
        另请参见：
        FilterOutputStream.write(int)

      • toString

        @Deprecated
public String toString​()
        已过时。 没有替换
        返回日志名称作为字符串表示。
        重写：
        toString在 Object
        结果
        日志名称
        从以下版本开始：
        1.1

      • parseLevel

        @Deprecated
public static int parseLevel​(String s)
        已过时。 没有替换
        将日志记录级别的字符串名称转换为其内部整数表示形式。
        参数
        s - 记录级别的名称（例如，“SILENT”，“ s ”，“VERBOSE”）
        结果
        对应的整数日志级别
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ObjID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class ObjID

  • java.lang.Object
    • java.rmi.server.ObjID
  • All Implemented Interfaces:
    Serializable

    public final class ObjID
extends Object
implements Serializable
    ObjID用于标识导出到RMI运行时的远程对象。 导出远程对象时，将根据用于导出的API来隐式或明确地分配一个对象标识符。

    ObjID()构造函数可用于生成唯一的对象标识符。 这样一个ObjID是相对于生成的主机而言是独一无二的。 ObjID(int)构造函数可用于创建“知名”对象标识符。 众所周知的ObjID的范围取决于导出到的RMI运行时间。

    一个ObjID实例包含对象号（类型long ）和地址空间标识符（类型为UID ）。 在独特的ObjID ，地址空间标识符对于给定的主机随时间而言是唯一的。 在众所周知的ObjID ，地址空间标识符等效于通过调用值为零的UID(short)构造函数返回的一个。

    如果将系统属性java.rmi.server.randomIDs定义为等于字符串"true" （不区分大小写），则ObjID()构造函数将使用加密强随机数生成器来选择返回的对象编号ObjID 。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ACTIVATOR_ID
      对象编号为知名的 ObjID的激活剂。
      static int DGC_ID
      对象编号为知名的 ObjID的分布式垃圾收集器。
      static int REGISTRY_ID
      对象编号为着名的 ObjID注册表。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObjID​()
      生成唯一的对象标识符。
      ObjID​(int objNum)
      创建一个“众所周知”的对象标识符。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的对象与此 ObjID进行比较以获得相等性。
      int hashCode​()
      返回此对象标识符（对象编号）的哈希码值。
      static ObjID read​(ObjectInput in)
      构造并返回一个新的 ObjID实例，通过从 ObjectInput实例解组二进制表示。
      String toString​()
      返回此对象标识符的字符串表示形式。
      void write​(ObjectOutput out)
      将这个 ObjID的二进制表示法 ObjID交给 ObjectOutput实例。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • REGISTRY_ID

        public static final int REGISTRY_ID
        对象编号为着名的 ObjID的注册表。
        另请参见：
        Constant Field Values

      • ACTIVATOR_ID

        public static final int ACTIVATOR_ID
        对象编号为知名的 ObjID的激活剂。
        另请参见：
        Constant Field Values

      • DGC_ID

        public static final int DGC_ID
        对象编号为知名的 ObjID的分布式垃圾收集器。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ObjID

        public ObjID​()
        生成唯一的对象标识符。

        如果将系统属性java.rmi.server.randomIDs定义为字符串"true" （不区分大小写），则该构造函数将使用加密强的随机数生成器来选择返回的对象编号ObjID 。

      • ObjID

        public ObjID​(int objNum)
        创建一个“众所周知”的对象标识符。

        通过此构造函数创建的一个ObjID不会与通过no-arg构造函数生成的任何ObjID冲突。

        参数
        objNum - 用于公知对象标识符的对象号

    • 方法详细信息

      • write

        public void write​(ObjectOutput out)
           throws IOException
        将这个ObjID的二进制表示法ObjID交给ObjectOutput实例。

        具体来说，该方法首先使用该对象标识符的对象号调用给定流的DataOutput.writeLong(long)方法，然后通过使用流来调用其UID.write(DataOutput)方法来写入其地址空间标识符。

        参数
        out - ObjectOutput实例写这个 ObjID到
        异常
        IOException - 如果执行此操作时发生I / O错误

      • read

        public static ObjID read​(ObjectInput in)
                  throws IOException
        构造并返回一个新的ObjID实例，通过从ObjectInput实例解组二进制表示。

        具体来说，该方法首先调用给定的流的DataInput.readLong()方法来读取一个对象号，然后它用流来调用UID.read(DataInput)来读取地址空间标识符，然后创建并返回一个包含对象号和地址空间标识符的新的ObjID实例从流中读取。

        参数
        in - ObjectInput实例，请阅读 ObjID从
        结果
        未编组 ObjID实例
        异常
        IOException - 执行此操作时是否发生I / O错误

      • hashCode

        public int hashCode​()
        返回此对象标识符（对象编号）的哈希码值。
        重写：
        hashCode在 Object
        结果
        该对象标识符的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将指定的对象与此ObjID进行比较以获得相等性。 当且仅当指定对象为具有相同对象编号和地址空间标识符的ObjID实例时，此方法返回true 。
        重写：
        equals在 Object
        参数
        obj - 对比这个 ObjID的对象
        结果
        true如果给定的对象相当于这个对象，而另外 false
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回此对象标识符的字符串表示形式。
        重写：
        toString在 Object
        结果
        该对象标识符的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Operation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class Operation

  • java.lang.Object
    • java.rmi.server.Operation
  • 已过时。
    没有替换

    @Deprecated
public class Operation
extends Object
    一个Operation包含一个Java方法的描述。 在JDK1.1版本存根和骨架中使用了Operation对象。 对于1.2样式存根，不需要Operation类（使用rmic -v1.2生成的存根）; 因此，此类已被弃用。
    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      Operation​(String op)
      已过时。
      没有替换

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      String getOperation​()
      已过时。
      没有替换
      String toString​()
      已过时。
      没有替换

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Operation

        @Deprecated
public Operation​(String op)
        已过时。 没有替换
        创建一个新的Operation对象。
        参数
        op - 方法名称
        从以下版本开始：
        1.1

    • 方法详细信息

      • getOperation

        @Deprecated
public String getOperation​()
        已过时。 没有替换
        返回方法的名称。
        结果
        方法名称
        从以下版本开始：
        1.1

      • toString

        @Deprecated
public String toString​()
        已过时。 没有替换
        返回操作的字符串表示形式。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RemoteCall (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Interface RemoteCall

  • 已过时。
    没有替换。

    @Deprecated
public interface RemoteCall
    RemoteCall是由RMI运行时（与远程对象的存根和骨架结合使用）执行对远程对象的调用所使用的抽象。 RemoteCall接口不推荐使用，因为它仅由不推荐使用的方法使用java.rmi.server.RemoteRef 。
    从以下版本开始：
    1.1
    另请参见：
    RemoteRef

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      void done​()
      已过时。
      没有替换
      void executeCall​()
      已过时。
      没有替换
      ObjectInput getInputStream​()
      已过时。
      没有替换
      ObjectOutput getOutputStream​()
      已过时。
      没有替换
      ObjectOutput getResultStream​(boolean success)
      已过时。
      没有替换
      void releaseInputStream​()
      已过时。
      没有替换
      void releaseOutputStream​()
      已过时。
      没有替换

    • 方法详细信息

      • getOutputStream

        @Deprecated
ObjectOutput getOutputStream​()
                      throws IOException
        已过时。 没有替换
        返回输出流stub / skeleton应该把参数/结果放入。
        结果
        输出流为参数/结果
        异常
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.1

      • releaseOutputStream

        @Deprecated
void releaseOutputStream​()
                  throws IOException
        已过时。 没有替换
        释放输出流; 在一些运输中，这将释放流。
        异常
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.1

      • getInputStream

        @Deprecated
ObjectInput getInputStream​()
                    throws IOException
        已过时。 没有替换
        获取输入流，stub / skeleton应该从中获取结果/参数。
        结果
        用于读取参数/结果的输入流
        异常
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.1

      • releaseInputStream

        @Deprecated
void releaseInputStream​()
                 throws IOException
        已过时。 没有替换
        释放输入流。 这将允许一些运输提前释放频道。
        异常
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.1

      • getResultStream

        @Deprecated
ObjectOutput getResultStream​(boolean success)
                      throws IOException,
                             StreamCorruptedException
        已过时。 没有替换
        返回输出流（可以输出与呼叫成功有关的头信息）。 每个远程呼叫应该只能成功一次。
        参数
        success - 如果为真，表示正常返回，否则表示异常返回。
        结果
        输出流用于写入呼叫结果
        异常
        IOException - 如果发生I / O错误。
        StreamCorruptedException - 如果已经被调用。
        从以下版本开始：
        1.1

      • executeCall

        @Deprecated
void executeCall​()
          throws 异常
        已过时。 没有替换
        做任何执行呼叫所需要的
        异常
        异常 - 如果发生一般异常。
        从以下版本开始：
        1.1

      • done

        @Deprecated
void done​()
   throws IOException
        已过时。 没有替换
        远程呼叫完成后允许清除。
        异常
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RemoteObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class RemoteObject

  • java.lang.Object
    • java.rmi.server.RemoteObject
  • All Implemented Interfaces:
    Serializable ， Remote
    已知直接子类：
    RemoteObjectInvocationHandler ， RemoteServer ， RemoteStub

    public abstract class RemoteObject
extends Object
implements Remote, Serializable
    RemoteObject类实现了远程对象的java.lang.Object行为。 RemoteObject通过实现hashCode，equals和toString的方法来提供Object的远程语义。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected RemoteRef ref
      对象的远程引用。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected RemoteObject​()
      创建一个远程对象。
      protected RemoteObject​(RemoteRef newref)
      创建一个远程对象，使用指定的远程引用进行初始化。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      比较两个远程对象的相等性。
      RemoteRef getRef​()
      返回远程对象的远程引用。
      int hashCode​()
      返回一个远程对象的哈希码。
      String toString​()
      返回一个表示该远程对象的值的字符串。
      static Remote toStub​(Remote obj)
      返回作为参数传递的远程对象 obj的存根。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ref

        protected transient RemoteRef ref
        对象的远程引用。

    • 构造方法详细信息

      • RemoteObject

        protected RemoteObject​()
        创建一个远程对象。

      • RemoteObject

        protected RemoteObject​(RemoteRef newref)
        创建一个远程对象，使用指定的远程引用进行初始化。
        参数
        newref - 远程参考

    • 方法详细信息

      • getRef

        public RemoteRef getRef​()
        返回远程对象的远程引用。

        注意：从此方法返回的对象可能是实现特定类的实例。 RemoteObject类通过其自定义的writeObject和readObject方法的行为确保其实例的远程引用的序列化可移植性。 RemoteRef的实例不应该在其RemoteObject包装器实例之外进行序列化，否则结果可能不可移植。

        结果
        远程对象的远程引用
        从以下版本开始：
        1.2

      • toStub

        public static Remote toStub​(Remote obj)
                     throws NoSuchObjectException
        返回作为参数传递的远程对象obj的存根。 此操作仅在导出对象后有效。
        参数
        obj - 需要存根的远程对象
        结果
        远程对象的存根， obj 。
        异常
        NoSuchObjectException - 如果无法找到远程对象的存根。
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回一个远程对象的哈希码。 引用同一个远程对象的两个远程对象存根将具有相同的哈希码（为了支持远程对象作为哈希表中的键）。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Hashtable

      • equals

        public boolean equals​(Object obj)
        比较两个远程对象的相等性。 返回一个布尔值，指示该远程对象是否等同于指定的对象。 当远程对象存储在散列表中时，将使用此方法。 如果指定的对象本身不是RemoteObject的实例，则该方法通过返回与该远程对象作为参数调用其参数的equals方法的结果进行委托。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        如果这些对象相等则为true; 否则为假。
        另请参见：
        Hashtable

      • toString

        public String toString​()
        返回一个表示该远程对象的值的字符串。
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RemoteObjectInvocationHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class RemoteObjectInvocationHandler

  • java.lang.Object
    • java.rmi.server.RemoteObject
      • java.rmi.server.RemoteObjectInvocationHandler
  • All Implemented Interfaces:
    Serializable ， InvocationHandler ， Remote

    public class RemoteObjectInvocationHandler
extends RemoteObject
implements InvocationHandler
    用于Java Remote Method Invocation（Java RMI）的InvocationHandler接口的实现。 此调用处理程序可以与动态代理实例一起使用，作为预生存存根类的替代。

    应用程序不会直接使用此类。 导出为使用具有UnicastRemoteObject或Activatable的动态代理的远程对象具有该类的实例作为该代理的调用处理程序。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.server.RemoteObject

        ref

    • 构造方法摘要

      构造方法
      Constructor 描述
      RemoteObjectInvocationHandler​(RemoteRef ref)
      创建一个新的 RemoteObjectInvocationHandler构造与指定的 RemoteRef 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object invoke​(Object proxy, 方法 method, Object[] args)
      处理封装代理实例 proxy上的方法调用，并返回结果。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.server.RemoteObject

        equals, getRef, hashCode, toString, toStub

    • 构造方法详细信息

      • RemoteObjectInvocationHandler

        public RemoteObjectInvocationHandler​(RemoteRef ref)
        创建一个新的 RemoteObjectInvocationHandler构造与指定的 RemoteRef 。
        参数
        ref - 远程参考
        异常
        NullPointerException - 如果 ref是 null

    • 方法详细信息

      • invoke

        public Object invoke​(Object proxy,
                     方法 method,
                     Object[] args)
              throws Throwable
        处理在封装代理实例proxy上进行的方法调用，并返回结果。

        RemoteObjectInvocationHandler实现这个方法如下：

        如果method是以下方法之一， method如下所示进行处理：

        • Object.hashCode ：返回代理的哈希代码值。
        • Object.equals ：返回true如果参数（ args[0] ）是一个动态代理类的一个实例和本调用处理程序等于自变量的调用处理程序，并返回false否则。
        • Object.toString ：返回代理的字符串表示形式。

        如果method覆盖Object.finalize ，则会被忽略。

        否则，进行远程呼叫如下：

        • 如果proxy不是接口Remote的实例，则抛出一个IllegalArgumentException 。
        • 否则， invoke方法被调用在该调用处理程序的RemoteRef ，传递proxy ， method ， args ，并且该方法散列（在“Java远程方法调用（RMI）规范”的第8.3节中定义） method ，并且将结果返回。
        • 如果RemoteRef.invoke抛出异常，并且该异常是由proxy的类实现的方法的throws子句中不能分配给任何异常的检查异常，则该异常被包装在一个UnexpectedException中，并且引发了包装的异常。 否则，此方法抛出invoke抛出的异常。

        如果参数不能由包含此调用处理程序的一些有效动态代理类的实例生成，则该方法的语义是未指定的。

        Specified by:
        invoke在接口 InvocationHandler
        参数
        proxy - 调用该方法的代理实例
        method - 对应于在代理实例上调用的接口方法的 方法实例
        args - 包含代理实例上方法调用中传递的参数值的对象数组，如果该方法没有参数， null
        结果
        从代理实例上的方法调用返回的值
        异常
        Throwable - 从代理实例上的方法调用抛出的异常
        另请参见：
        UndeclaredThrowableException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RemoteRef (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Interface RemoteRef

  • All Superinterfaces:
    Externalizable ， Serializable
    All Known Subinterfaces:
    ServerRef

    public interface RemoteRef
extends Externalizable
    RemoteRef表示远程对象的句柄。 A RemoteStub使用远程引用对远程对象执行远程方法调用。
    从以下版本开始：
    1.1
    另请参见：
    RemoteStub

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String packagePrefix
      初始化服务器包前缀：假定服务器参考类的实现（例如，UnicastRef，UnicastServerRef）位于由前缀定义的包中。
      static long serialVersionUID
      表示与JDK 1.1.x版本的类的兼容性。

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      void done​(RemoteCall call)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
      String getRefClass​(ObjectOutput out)
      将要序列化的引用类型的类名返回到流“out”。
      Object invoke​(Remote obj, 方法 method, Object[] params, long opnum)
      调用方法。
      void invoke​(RemoteCall call)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
      RemoteCall newCall​(RemoteObject obj, Operation[] op, int opnum, long hash)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法调用的顺序上短截线的远程引用（的newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回的值。
      boolean remoteEquals​(RemoteRef obj)
      比较两个远程对象的相等性。
      int remoteHashCode​()
      返回一个远程对象的哈希码。
      String remoteToString​()
      返回一个表示此远程对象引用的字符串。

      • Methods inherited from interface java.io.Externalizable

        readExternal, writeExternal

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        表示与JDK 1.1.x版本的类的兼容性。
        另请参见：
        Constant Field Values

      • packagePrefix

        static final String packagePrefix
        初始化服务器包前缀：假定服务器参考类的实现（例如，UnicastRef，UnicastServerRef）位于由前缀定义的包中。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • invoke

        Object invoke​(Remote obj,
              方法 method,
              Object[] params,
              long opnum)
       throws 异常
        调用方法。 这种委托方式调用到引用的形式允许引用来设置与远程主机的连接，为方法和参数编组一些表示，然后将方法调用传递给远程主机。 该方法或者返回驻留在远程主机上的远程对象上的方法调用的结果，或者如果调用失败则抛出RemoteException，或者如果远程调用引发异常，则返回应用程序级异常。
        参数
        obj - 包含RemoteRef的对象（例如，对象的RemoteStub）。
        method - 要调用的方法
        params - 参数列表
        opnum - 可用于表示方法的散列
        结果
        远程方法调用的结果
        异常
        异常 - 如果在远程方法调用期间发生任何异常
        从以下版本开始：
        1.2

      • newCall

        @Deprecated
RemoteCall newCall​(RemoteObject obj,
                   Operation[] op,
                   int opnum,
                   long hash)
            throws RemoteException
        已过时。 1.2样式存根不再使用这种方法。 代替使用方法调用的顺序上短截线的远程引用（的newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回的值。
        为此对象创建新的远程方法调用的适当调用对象。 传递操作数组和索引，允许存根生成器分配操作索引并进行解释。 远程引用可能需要在呼叫中进行编码的操作。
        参数
        obj - 通过其进行通话的远程存根
        op - 存根操作数组
        opnum - 操作编号
        hash - stub / skeleton接口哈希
        结果
        代表远程调用的调用对象
        异常
        RemoteException - 如果无法启动新的远程调用
        从以下版本开始：
        1.1
        另请参见：
        invoke(Remote,java.lang.reflect.Method,Object[],long)

      • invoke

        @Deprecated
void invoke​(RemoteCall call)
     throws 异常
        已过时。 1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
        执行远程调用。 调用将引发任何应该通过的用户异常，而不被该存根捕获。 如果在远程调用期间引发异常，则调用在升级“用户”或远程异常之前，请注意清除连接。
        参数
        call - 表示远程调用的对象
        异常
        异常 - 如果在远程方法中发生任何异常
        从以下版本开始：
        1.1
        另请参见：
        invoke(Remote,java.lang.reflect.Method,Object[],long)

      • done

        @Deprecated
void done​(RemoteCall call)
   throws RemoteException
        已过时。 1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
        允许远程引用清理（或重新使用）连接。 只有当调用成功（非特别地）返回到存根时才调用完成。
        参数
        call - 表示远程调用的对象
        异常
        RemoteException - 如果在呼叫清理期间发生远程错误
        从以下版本开始：
        1.1
        另请参见：
        invoke(Remote,java.lang.reflect.Method,Object[],long)

      • getRefClass

        String getRefClass​(ObjectOutput out)
        将要序列化的引用类型的类名返回到流“out”。
        参数
        out - 引用将被序列化的输出流
        结果
        参考类型的类名（不含包资质）
        从以下版本开始：
        1.1

      • remoteHashCode

        int remoteHashCode​()
        返回一个远程对象的哈希码。 引用同一个远程对象的两个远程对象存根将具有相同的哈希码（为了支持远程对象作为哈希表中的键）。
        结果
        远程对象哈希码
        从以下版本开始：
        1.1
        另请参见：
        Hashtable

      • remoteEquals

        boolean remoteEquals​(RemoteRef obj)
        比较两个远程对象的相等性。 返回一个布尔值，指示该远程对象是否等同于指定的对象。 当远程对象存储在散列表中时，将使用此方法。
        参数
        obj - 要比较的对象
        结果
        如果这些对象相等则为true; 否则为假。
        从以下版本开始：
        1.1
        另请参见：
        Hashtable

      • remoteToString

        String remoteToString​()
        返回一个表示此远程对象引用的字符串。
        结果
        字符串表示远程对象引用
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RemoteServer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class RemoteServer

  • java.lang.Object
    • java.rmi.server.RemoteObject
      • java.rmi.server.RemoteServer
  • All Implemented Interfaces:
    Serializable ， Remote
    已知直接子类：
    Activatable ， UnicastRemoteObject

    public abstract class RemoteServer
extends RemoteObject
    RemoteServer类是服务器实现的常见超类，并提供了支持各种远程引用语义的框架。 具体来说，创建和导出远程对象所需的功能（即使其远程可用）由RemoteServer抽象提供，具体地由其子类提供。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.server.RemoteObject

        ref

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected RemoteServer​()
      构造一个 RemoteServer 。
      protected RemoteServer​(RemoteRef ref)
      构造具有给定参考类型的 RemoteServer 。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static String getClientHost​()
      返回在当前线程中正在处理的远程方法调用的客户端主机的字符串表示形式。
      static PrintStream getLog​()
      返回RMI通话记录的流。
      static void setLog​(OutputStream out)
      将RMI调用记录到输出流 out 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.server.RemoteObject

        equals, getRef, hashCode, toString, toStub

    • 构造方法详细信息

      • RemoteServer

        protected RemoteServer​()
        构造一个 RemoteServer 。
        从以下版本开始：
        1.1

      • RemoteServer

        protected RemoteServer​(RemoteRef ref)
        构造具有给定参考类型的 RemoteServer 。
        参数
        ref - 远程引用
        从以下版本开始：
        1.1

    • 方法详细信息

      • getClientHost

        public static String getClientHost​()
                            throws ServerNotActiveException
        返回在当前线程中正在处理的远程方法调用的客户端主机的字符串表示形式。
        结果
        客户端主机的字符串表示形式
        异常
        ServerNotActiveException - 如果当前线程中没有处理远程方法调用
        从以下版本开始：
        1.1

      • setLog

        public static void setLog​(OutputStream out)
        将RMI调用记录到输出流out 。 如果out是null ，则呼叫记录被关闭。

        如果有安全管理员，其checkPermission方法将被调用java.util.logging.LoggingPermission("control")权限; 这可能会导致一个SecurityException 。

        参数
        out - 应记录RMI调用的输出流
        异常
        SecurityException - 如果有安全管理器，并且调用其 checkPermission方法失败
        从以下版本开始：
        1.1
        另请参见：
        getLog()

      • getLog

        public static PrintStream getLog​()
        返回RMI通话记录的流。
        结果
        通话记录
        从以下版本开始：
        1.1
        另请参见：
        setLog(java.io.OutputStream)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RemoteStub (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class RemoteStub

  • java.lang.Object
    • java.rmi.server.RemoteObject
      • java.rmi.server.RemoteStub
  • All Implemented Interfaces:
    Serializable ， Remote
    已知直接子类：
    ActivationGroup_Stub ， RMIConnectionImpl_Stub ， RMIServerImpl_Stub
    已过时。
    静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。

    @Deprecated
public abstract class RemoteStub
extends RemoteObject
    RemoteStub类是静态生成的客户端存根的常见超类，并提供了支持各种远程引用语义的框架。 Stub对象是支持由远程对象的实际实现定义的完全相同的远程接口集的代理。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.server.RemoteObject

        ref

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected RemoteStub​()
      已过时。
      构造一个 RemoteStub 。
      protected RemoteStub​(RemoteRef ref)
      已过时。
      使用指定的远程引用构造一个 RemoteStub 。

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      protected static void setRef​(RemoteStub stub, RemoteRef ref)
      已过时。
      没有替换 setRef方法用于设置远程存根的远程引用。 这是不必要的，因为RemoteStub可以创建和通过使用的远程引用初始化小号RemoteStub(RemoteRef)构造。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.server.RemoteObject

        equals, getRef, hashCode, toString, toStub

    • 构造方法详细信息

      • RemoteStub

        protected RemoteStub​()
        已过时。
        构造一个 RemoteStub 。

      • RemoteStub

        protected RemoteStub​(RemoteRef ref)
        已过时。
        使用指定的远程引用构造一个 RemoteStub 。
        参数
        ref - 远程参考
        从以下版本开始：
        1.1

    • 方法详细信息

      • setRef

        @Deprecated
protected static void setRef​(RemoteStub stub,
                             RemoteRef ref)
        已过时。 没有替换 setRef方法用于设置远程存根的远程引用。 这是不必要的，因为RemoteStub可以创建和通过使用的远程引用初始化小号RemoteStub(RemoteRef)构造。
        抛出UnsupportedOperationException 。
        参数
        stub - 远程存根
        ref - 远程参考
        异常
        UnsupportedOperationException - 永远
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RMIClassLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class RMIClassLoader

  • java.lang.Object
    • java.rmi.server.RMIClassLoader

  • public class RMIClassLoader
extends Object
    RMIClassLoader包含静态方法来支持使用RMI的动态类加载。 包括从网络位置（一个或多个URL）加载类的方法，并获取远程方应由现有类加载的位置。 这些方法由RMI运行时使用，当编组和解组合包含在远程方法调用的参数和返回值中时，它们也可以被应用程序直接调用，以模仿RMI的动态类加载行为。

    执行以下静态方法

    • loadClass(URL,String)
    • loadClass(String,String)
    • loadClass(String,String,ClassLoader)
    • loadProxyClass(String,String[],ClassLoader)
    • getClassLoader(String)
    • getClassAnnotation(Class)
    由RMIClassLoaderSpi的实例提供，这些方法的服务提供程序接口。 当调用其中一种方法时，其行为是委托给服务提供者实例上的相应方法。 每个方法委托给提供者实例的详细信息，请参见每个特定方法的文档。

    服务提供商实例选择如下：

    • 如果定义了系统属性java.rmi.server.RMIClassLoaderSpi ，那么如果其值等于字符串"default" ，则提供者实例将是通过调用getDefaultProviderInstance()方法返回的值，对于任何其他值，如果使用属性值命名的类可以由系统类加载器加载（参见ClassLoader.getSystemClassLoader() ），该类可分配给RMIClassLoaderSpi并具有公共无参数构造函数，那么将调用该构造函数来创建提供者实例。 如果属性被定义，但这些条件中的任何其他条件都不为真，那么未指定的Error将被抛出到尝试使用RMIClassLoader代码中，表示无法获取提供者实例。
    • 如果名为META-INF/services/java.rmi.server.RMIClassLoaderSpi的资源对于系统类加载器是可见的，则该资源的内容将被解释为提供者配置文件，并且该文件中指定的第一个类名被用作提供者类名称。 如果具有该名称的类可以由系统类加载器加载，并且该类可以分配给RMIClassLoaderSpi并具有公共无参构造函数，则将调用该构造函数来创建提供者实例。 如果找到资源，但提供程序不能如所述实例化，那么未指定的Error将被抛出到尝试使用RMIClassLoader代码，指示无法获取提供程序实例。
    • 否则，提供者实例将是通过调用getDefaultProviderInstance()方法返回的值。
    从以下版本开始：
    1.1
    另请参见：
    RMIClassLoaderSpi

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static String getClassAnnotation​(Class<?> cl)
      返回在编组给定类的对象时，RMI将用于注释类描述符的注释字符串（表示类定义的位置）。
      static ClassLoader getClassLoader​(String codebase)
      返回从给定的代码库URL路径加载类的类加载器。
      static RMIClassLoaderSpi getDefaultProviderInstance​()
      返回服务提供商接口RMIClassLoaderSpi的默认提供程序的规范实例。
      static Object getSecurityContext​(ClassLoader loader)
      已过时。
      没有替换。 从Java 2平台v1.2开始，RMI不再使用此方法来获取类加载器的安全上下文。
      static Class<?> loadClass​(String name)
      已过时。
      替换为loadClass(String,String)方法
      static Class<?> loadClass​(String codebase, String name)
      从代码库URL路径加载一个类。
      static Class<?> loadClass​(String codebase, String name, ClassLoader defaultLoader)
      从代码库URL路径加载类，可选地使用提供的加载程序。
      static Class<?> loadClass​(URL codebase, String name)
      从代码库URL加载一个类。
      static Class<?> loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      加载一个动态代理类（请参阅Proxy ），它从代码库URL路径中实现了一组具有给定名称的接口。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • loadClass

        @Deprecated
public static Class<?> loadClass​(String name)
                          throws MalformedURLException,
                                 ClassNotFoundException
        已过时。 替换为loadClass(String,String)方法
        加载指定的name 。

        该方法委托给loadClass(String,String) ，作为第二个参数传递null ，第二个参数为name 。

        参数
        name - 要加载的类的名称
        结果
        表示加载类的 Class对象
        异常
        MalformedURLException - 如果用于加载类的提供者特定URL无效
        ClassNotFoundException - 如果在代码库位置找不到类的定义
        另请参见：
        loadClass(String,String)

      • loadClass

        public static Class<?> loadClass​(URL codebase,
                                 String name)
                          throws MalformedURLException,
                                 ClassNotFoundException
        从代码库URL加载一个类。 如果codebase是null ，那么这个方法将与loadClass(String,String)的null codebase和给定的类名相同。

        该方法委托给提供者实例的RMIClassLoaderSpi.loadClass(String,String,ClassLoader)方法，传递给定URL（或null如果codebase为空）时调用URL.toString()的结果）作为第二个参数， name作为第二个参数，而null作为第三个参数。

        参数
        codebase - 加载类的URL，或 null
        name - 要加载的类的名称
        结果
        表示加载类的 Class对象
        异常
        MalformedURLException - 如果 codebase为 null并且用于加载类的提供程序特定URL无效
        ClassNotFoundException - 如果在指定的URL处找不到类的定义

      • loadClass

        public static Class<?> loadClass​(String codebase,
                                 String name)
                          throws MalformedURLException,
                                 ClassNotFoundException
        从代码库URL路径加载一个类。

        此方法委托给提供者实例的RMIClassLoaderSpi.loadClass(String,String,ClassLoader)方法，将codebase作为第一个参数， name作为第二个参数，以null作为第三个参数。

        参数
        codebase - 加载类的URL列表（由空格分隔），或 null
        name - 要加载的类的名称
        结果
        表示加载类的 Class对象
        异常
        MalformedURLException - 如果 codebase非 null并且包含无效的URL，或者如果 codebase是 null并且用于加载类的提供程序特定的URL无效
        ClassNotFoundException - 如果在指定位置找不到类的定义
        从以下版本开始：
        1.2

      • loadClass

        public static Class<?> loadClass​(String codebase,
                                 String name,
                                 ClassLoader defaultLoader)
                          throws MalformedURLException,
                                 ClassNotFoundException
        从代码库URL路径加载类，可选地使用提供的加载程序。 当调用者想要向提供者实现提供一个要考虑的附加上下文类加载器时，应该使用此方法，例如堆栈上的调用者的加载程序。 通常，在尝试从代码库URL路径解析类之前，提供者实现将尝试使用给定的defaultLoader （如果指定）来解析命名类。

        此方法委托给RMIClassLoaderSpi.loadClass(String,String,ClassLoader)提供程序实例的方法，传递codebase作为第一个参数， name作为第二个参数，和defaultLoader作为第三个参数。

        参数
        codebase - 加载类的URL列表（由空格分隔），或 null
        name - 要加载的类的名称
        defaultLoader - 要使用的附加上下文类加载器，或 null
        结果
        表示加载类的 Class对象
        异常
        MalformedURLException - 如果 codebase不是 null并且包含无效的URL，或者如果 codebase是 null并且用于加载类的提供商特定的URL无效
        ClassNotFoundException - 如果在指定位置找不到类的定义
        从以下版本开始：
        1.4

      • loadProxyClass

        public static Class<?> loadProxyClass​(String codebase,
                                      String[] interfaces,
                                      ClassLoader defaultLoader)
                               throws ClassNotFoundException,
                                      MalformedURLException
        加载动态代理类（请参阅Proxy ），该代码类从代码库URL路径中实现了一组具有给定名称的接口。

        接口将被解析为类似于使用给定的codebase通过loadClass(String,String)方法加载的类。

        此方法委托给提供者实例的RMIClassLoaderSpi.loadProxyClass(String,String[],ClassLoader)方法，作为第二个参数传递codebase作为第二个参数， interfaces作为第二个参数， defaultLoader作为第三个参数。

        参数
        codebase - 加载类的URL列表（空格分隔），或 null
        interfaces - 代理类实现的接口的名称
        defaultLoader - 要使用的附加上下文类加载器，或 null
        结果
        一个实现命名接口的动态代理类
        异常
        MalformedURLException - 如果 codebase不是 null并且包含无效的URL，或者如果 codebase是 null并且用于加载类的提供者特定URL无效
        ClassNotFoundException - 如果在指定位置找不到某个命名接口的定义，或者如果动态代理类的创建失败（例如，如果 Proxy.getProxyClass(ClassLoader,Class[])将为给定接口列表抛出一个 IllegalArgumentException ）
        从以下版本开始：
        1.4

      • getClassLoader

        public static ClassLoader getClassLoader​(String codebase)
                                  throws MalformedURLException,
                                         SecurityException
        返回从给定的代码库URL路径加载类的类加载器。

        返回的类加载器是loadClass(String,String)方法用于为相同的codebase参数加载类的类加载器。

        该方法委托给提供者实例的RMIClassLoaderSpi.getClassLoader(String)方法，传递codebase作为参数。

        如果有一个安全管理员，它的checkPermission方法将被调用一个RuntimePermission("getClassLoader")权限; 这可能会导致一个SecurityException 。 该方法的提供者实现还可以执行进一步的安全检查，以验证呼叫上下文是否具有连接到代码库URL路径中的所有URL的权限。

        参数
        codebase - 返回的类加载器从其加载类的URL（空格分隔）列表，或 null
        结果
        一个类加载器，它从给定的代码库URL路径加载类
        异常
        MalformedURLException - 如果 codebase不是 null并且包含无效的URL，或者如果 codebase是 null并且用于标识类加载器的提供者特定URL无效
        SecurityException - 如果有安全管理器，并且其 checkPermission方法的调用失败，或者主叫方没有权限连接到代码库URL路径中的所有URL
        从以下版本开始：
        1.3

      • getClassAnnotation

        public static String getClassAnnotation​(Class<?> cl)
        返回在编组给定类的对象时，RMI将用于注释类描述符的注释字符串（表示类定义的位置）。

        该方法委托给提供者实例的RMIClassLoaderSpi.getClassAnnotation(Class)方法，作为参数传递cl 。

        参数
        cl - 获取注释的类
        结果
        一个字符串，用于在给定的类进行编组时用于注释，或者是 null
        异常
        NullPointerException - 如果 cl是 null
        从以下版本开始：
        1.2

      • getDefaultProviderInstance

        public static RMIClassLoaderSpi getDefaultProviderInstance​()
        返回服务提供商接口RMIClassLoaderSpi的默认提供程序的规范实例。 如果系统属性java.rmi.server.RMIClassLoaderSpi没有定义，那么RMIClassLoader静态方法
        • loadClass(URL,String)
        • loadClass(String,String)
        • loadClass(String,String,ClassLoader)
        • loadProxyClass(String,String[],ClassLoader)
        • getClassLoader(String)
        • getClassAnnotation(Class)
        将使用默认提供者的规范实例作为服务提供者实例。

        如果有安全管理员，其checkPermission方法将被调用RuntimePermission("setFactory")权限; 这可能会导致一个SecurityException 。

        默认服务提供商实例实现RMIClassLoaderSpi如下：

        The getClassAnnotation method returns a String representing the codebase URL path that a remote party should use to download the definition for the specified class. The format of the returned string is a path of URLs separated by spaces. The codebase string returned depends on the defining class loader of the specified class:

        • If the class loader is the system class loader (see ClassLoader.getSystemClassLoader()), a parent of the system class loader such as the loader used for installed extensions, or the bootstrap class loader (which may be represented by null), then the value of the java.rmi.server.codebase property (or possibly an earlier cached value) is returned, or null is returned if that property is not set.

        • Otherwise, if the class loader is an instance of URLClassLoader, then the returned string is a space-separated list of the external forms of the URLs returned by invoking the getURLs methods of the loader. If the URLClassLoader was created by this provider to service an invocation of its loadClass or loadProxyClass methods, then no permissions are required to get the associated codebase string. If it is an arbitrary other URLClassLoader instance, then if there is a security manager, its checkPermission method will be invoked once for each URL returned by the getURLs method, with the permission returned by invoking openConnection().getPermission() on each URL; if any of those invocations throws a SecurityException or an IOException, then the value of the java.rmi.server.codebase property (or possibly an earlier cached value) is returned, or null is returned if that property is not set.

        • Finally, if the class loader is not an instance of URLClassLoader, then the value of the java.rmi.server.codebase property (or possibly an earlier cached value) is returned, or null is returned if that property is not set.

        For the implementations of the methods described below, which all take a String parameter named codebase that is a space-separated list of URLs, each invocation has an associated codebase loader that is identified using the codebase argument in conjunction with the current thread's context class loader (see Thread.getContextClassLoader()). When there is a security manager, this provider maintains an internal table of class loader instances (which are at least instances of URLClassLoader) keyed by the pair of their parent class loader and their codebase URL path (an ordered list of URLs). If the codebase argument is null, the codebase URL path is the value of the system property java.rmi.server.codebase or possibly an earlier cached value. For a given codebase URL path passed as the codebase argument to an invocation of one of the below methods in a given context, the codebase loader is the loader in the table with the specified codebase URL path and the current thread's context class loader as its parent. If no such loader exists, then one is created and added to the table. The table does not maintain strong references to its contained loaders, in order to allow them and their defined classes to be garbage collected when not otherwise reachable. In order to prevent arbitrary untrusted code from being implicitly loaded into a virtual machine with no security manager, if there is no security manager set, the codebase loader is just the current thread's context class loader (the supplied codebase URL path is ignored, so remote class loading is disabled).

        The getClassLoader method returns the codebase loader for the specified codebase URL path. If there is a security manager, then if the calling context does not have permission to connect to all of the URLs in the codebase URL path, a SecurityException will be thrown.

        The loadClass method attempts to load the class with the specified name as follows:

        If the defaultLoader argument is non- null, it first attempts to load the class with the specified name using the defaultLoader, such as by evaluating
             Class.forName(name, false, defaultLoader)
        If the class is successfully loaded from the defaultLoader, that class is returned. If an exception other than ClassNotFoundException is thrown, that exception is thrown to the caller.

        Next, the loadClass method attempts to load the class with the specified name using the codebase loader for the specified codebase URL path. If there is a security manager, then the calling context must have permission to connect to all of the URLs in the codebase URL path; otherwise, the current thread's context class loader will be used instead of the codebase loader.

        The loadProxyClass method attempts to return a dynamic proxy class with the named interface as follows:

        If the defaultLoader argument is non-null and all of the named interfaces can be resolved through that loader, then,

        • if all of the resolved interfaces are public, then it first attempts to obtain a dynamic proxy class (using Proxy.getProxyClass) for the resolved interfaces defined in the codebase loader; if that attempt throws an IllegalArgumentException, it then attempts to obtain a dynamic proxy class for the resolved interfaces defined in the defaultLoader. If both attempts throw IllegalArgumentException, then this method throws a ClassNotFoundException. If any other exception is thrown, that exception is thrown to the caller.
        • if all of the non-public resolved interfaces are defined in the same class loader, then it attempts to obtain a dynamic proxy class for the resolved interfaces defined in that loader.
        • otherwise, a LinkageError is thrown (because a class that implements all of the specified interfaces cannot be defined in any loader).

        Otherwise, if all of the named interfaces can be resolved through the codebase loader, then,

        • if all of the resolved interfaces are public, then it attempts to obtain a dynamic proxy class for the resolved interfaces in the codebase loader. If the attempt throws an IllegalArgumentException, then this method throws a ClassNotFoundException.
        • if all of the non-public resolved interfaces are defined in the same class loader, then it attempts to obtain a dynamic proxy class for the resolved interfaces defined in that loader.
        • otherwise, a LinkageError is thrown (because a class that implements all of the specified interfaces cannot be defined in any loader).

        Otherwise, a ClassNotFoundException is thrown for one of the named interfaces that could not be resolved.

        结果
        默认服务提供商的规范实例
        异常
        SecurityException - 如果有安全管理器，并且其 checkPermission方法的调用失败
        从以下版本开始：
        1.4

      • getSecurityContext

        @Deprecated
public static Object getSecurityContext​(ClassLoader loader)
        已过时。 没有替换。 从Java 2平台v1.2开始，RMI不再使用此方法来获取类加载器的安全上下文。
        返回给定类加载器的安全上下文。
        参数
        loader - 从中获取安全上下文的类加载器
        结果
        安全上下文
        另请参见：
        SecurityManager.getSecurityContext()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RMIClassLoaderSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class RMIClassLoaderSpi

  • java.lang.Object
    • java.rmi.server.RMIClassLoaderSpi

  • public abstract class RMIClassLoaderSpi
extends Object
    RMIClassLoaderSpi是服务提供者接口RMIClassLoader 。 特别地， RMIClassLoaderSpi实例提供了以下静态方法的RMIClassLoader ： RMIClassLoader ：
    • RMIClassLoader.loadClass(URL,String)
    • RMIClassLoader.loadClass(String,String)
    • RMIClassLoader.loadClass(String,String,ClassLoader)
    • RMIClassLoader.loadProxyClass(String,String[],ClassLoader)
    • RMIClassLoader.getClassLoader(String)
    • RMIClassLoader.getClassAnnotation(Class)
    当调用其中一个方法时，它的行为是委托给这个类的一个实例上的一个相应的方法。 每个方法委托给提供者实例的详细信息，请参见每个特定方法的文档。 有关如何选择供应商实例的说明，请参阅RMIClassLoader的文档。
    从以下版本开始：
    1.4
    另请参见：
    RMIClassLoader

    • 构造方法摘要

      构造方法
      Constructor 描述
      RMIClassLoaderSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract String getClassAnnotation​(Class<?> cl)
      提供 RMIClassLoader.getClassAnnotation(Class)的实现。
      abstract ClassLoader getClassLoader​(String codebase)
      提供 RMIClassLoader.getClassLoader(String)的实现。
      abstract Class<?> loadClass​(String codebase, String name, ClassLoader defaultLoader)
       为贯彻
RMIClassLoader.loadClass(URL,String) ，
RMIClassLoader.loadClass(String,String) ，并
RMIClassLoader.loadClass(String,String,ClassLoader) 。
      abstract Class<?> loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader)的实现。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RMIClassLoaderSpi

        public RMIClassLoaderSpi​()

    • 方法详细信息

      • loadClass

        public abstract Class<?> loadClass​(String codebase,
                                   String name,
                                   ClassLoader defaultLoader)
                            throws MalformedURLException,
                                   ClassNotFoundException
        为贯彻RMIClassLoader.loadClass(URL,String) ， RMIClassLoader.loadClass(String,String) ，并RMIClassLoader.loadClass(String,String,ClassLoader) 。 从代码库URL路径加载类，可选地使用提供的加载程序。 通常，在尝试从代码库URL路径解析类之前，提供者实现将尝试使用给定的defaultLoader （如果指定）来解析命名类。

        该方法的实现必须返回具有给定名称的类或引发异常。

        参数
        codebase - 加载类的URL列表（由空格分隔），或 null
        name - 要加载的类的名称
        defaultLoader - 要使用的附加上下文类加载器，或 null
        结果
        表示加载的类的 Class对象
        异常
        MalformedURLException - 如果 codebase不是 null并且包含无效的URL，或者如果 codebase是 null并且用于加载类的提供程序特定URL无效
        ClassNotFoundException - 如果在指定位置找不到类的定义

      • loadProxyClass

        public abstract Class<?> loadProxyClass​(String codebase,
                                        String[] interfaces,
                                        ClassLoader defaultLoader)
                                 throws MalformedURLException,
                                        ClassNotFoundException
        提供RMIClassLoader.loadProxyClass(String,String[],ClassLoader)的实现。 加载一个动态代理类（参见Proxy ，可以从代码库URL路径中实现一组与给定名称的接口，可选地使用提供的加载程序。

        此方法的实现必须返回实现命名接口的代理类或抛出异常。

        参数
        codebase - 加载类的URL列表（空格分隔），或 null
        interfaces - 要实现的代理类的接口的名称
        defaultLoader - 要使用的附加上下文类加载器，或 null
        结果
        一个实现命名接口的动态代理类
        异常
        MalformedURLException - 如果 codebase不是 null并且包含无效的URL，或者如果 codebase是 null并且用于加载类的提供者特定的URL无效
        ClassNotFoundException - 如果在指定位置找不到某个命名接口的定义，或者如果动态代理类的创建失败（例如，如果 Proxy.getProxyClass(ClassLoader,Class[])将为给定接口列表抛出一个 IllegalArgumentException ）

      • getClassLoader

        public abstract ClassLoader getClassLoader​(String codebase)
                                    throws MalformedURLException
        提供RMIClassLoader.getClassLoader(String)的实现。 返回从给定的代码库URL路径加载类的类加载器。

        如果有一个安全管理员，它的checkPermission方法将被调用一个RuntimePermission("getClassLoader")权限; 这可能会导致一个SecurityException 。 该方法的实现还可以执行进一步的安全检查，以验证呼叫上下文是否具有连接到代码库URL路径中的所有URL的权限。

        参数
        codebase - 返回的类加载器从其加载类的URL（空格分隔）列表，或 null
        结果
        一个类加载器，它从给定的代码库URL路径加载类
        异常
        MalformedURLException - 如果 codebase是非 null并且包含无效URL，或者如果 codebase是 null并且用于标识类加载器的提供者特定URL无效
        SecurityException - 如果有安全管理器，并且其 checkPermission方法的调用失败，或者主叫方没有权限连接到代码库URL路径中的所有URL

      • getClassAnnotation

        public abstract String getClassAnnotation​(Class<?> cl)
        提供RMIClassLoader.getClassAnnotation(Class)的实现。 返回在编组给定类的对象时，RMI将用于注释类描述符的注释字符串（表示类定义的位置）。
        参数
        cl - 获取注释的类
        结果
        一个字符串，用于在给定的类进行编组时用于注释，或者是 null
        异常
        NullPointerException - 如果 cl是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RMIClientSocketFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Interface RMIClientSocketFactory

  • 所有已知实现类：
    RMISocketFactory ， SslRMIClientSocketFactory

    public interface RMIClientSocketFactory
    RMI运行时使用RMIClientSocketFactory实例来获取RMI调用的客户端套接字。 远程对象可以与相关联RMIClientSocketFactory经由构造或出口时被创建/ exportObject的方法java.rmi.server.UnicastRemoteObject和java.rmi.activation.Activatable 。

    当远程对象的引用在RMI调用中传输时，与远程对象相关联的RMIClientSocketFactory实例将被下载到客户端。 此RMIClientSocketFactory将用于创建与远程方法调用的远程对象的连接。

    一个RMIClientSocketFactory实例也可以与远程对象注册表相关联，以便客户端可以使用与远程对象注册表的定制套接字通信。

    该接口的实现应该是可序列化的，并且应该实现Object.equals(java.lang.Object) ，当通过代表相同（功能相当的）客户端套接字工厂的实例时，返回true ，否则应为false （并且还应该与其Object.equals实现一致地实现Object.hashCode() ）。

    从以下版本开始：
    1.2
    另请参见：
    UnicastRemoteObject ， Activatable ， LocateRegistry

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Socket createSocket​(String host, int port)
      创建连接到指定主机和端口的客户端套接字。

    • 方法详细信息

      • createSocket

        Socket createSocket​(String host,
                    int port)
             throws IOException
        创建连接到指定主机和端口的客户端套接字。
        参数
        host - 主机名
        port - 端口号
        结果
        一个连接到指定主机和端口的套接字。
        异常
        IOException - 如果套接字创建期间发生I / O错误
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RMIFailureHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Interface RMIFailureHandler

  • public interface RMIFailureHandler
    一个RMIFailureHandler可以通过RMISocketFactory.setFailureHandler通话进行注册。 当RMI运行时无法创建ServerSocket以侦听来电时，调用处理程序的failure方法。 failure方法返回一个布尔值，指示运行时是否应尝试重新创建ServerSocket 。
    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean failure​(异常 ex)
      当RMI运行时无法通过 RMISocketFactory创建 ServerSocket时，将调用 failure回调。

    • 方法详细信息

      • failure

        boolean failure​(异常 ex)
        当RMI运行时无法通过RMISocketFactory创建ServerSocket时，将调用failure回调。 一个RMIFailureHandler通过呼叫RMISocketFacotry.setFailureHandler注册。 如果没有安装故障处理程序，则默认行为是尝试重新创建ServerSocket。
        参数
        ex - 在创建 ServerSocket期间发生的例外
        结果
        如果为true，RMI运行时将尝试重试 ServerSocket创建
        从以下版本开始：
        1.1
        另请参见：
        RMISocketFactory.setFailureHandler(RMIFailureHandler)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RMIServerSocketFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Interface RMIServerSocketFactory

  • 所有已知实现类：
    RMISocketFactory ， SslRMIServerSocketFactory

    public interface RMIServerSocketFactory
    RMI运行时使用RMIServerSocketFactory实例，以获取RMI调用的服务器套接字。 远程对象可以与相关联RMIServerSocketFactory经由构造或出口时被创建/ exportObject的方法java.rmi.server.UnicastRemoteObject和java.rmi.activation.Activatable 。

    使用与远程对象相关联的RMIServerSocketFactory实例来获取用于接收来自客户端的来电的ServerSocket 。

    一个RMIServerSocketFactory实例也可以与远程对象注册表关联，以便客户端可以使用与远程对象注册表的定制套接字通信。

    当通过代表相同（功能等效）服务器套接字工厂的实例时，该接口的实现应实现Object.equals(java.lang.Object)，以返回true ，否则将使用false （并且还应该与其Object.equals实现一致地实现Object.hashCode() ）。

    从以下版本开始：
    1.2
    另请参见：
    UnicastRemoteObject ， Activatable ， LocateRegistry

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ServerSocket createServerSocket​(int port)
      在指定端口上创建服务器套接字（端口0表示匿名端口）。

    • 方法详细信息

      • createServerSocket

        ServerSocket createServerSocket​(int port)
                         throws IOException
        在指定端口上创建服务器套接字（端口0表示匿名端口）。
        参数
        port - 端口号
        结果
        指定端口上的服务器套接字
        异常
        IOException - 如果在创建服务器套接字期间发生I / O错误
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RMISocketFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class RMISocketFactory

  • java.lang.Object
    • java.rmi.server.RMISocketFactory
  • All Implemented Interfaces:
    RMIClientSocketFactory ， RMIServerSocketFactory

    public abstract class RMISocketFactory
extends Object
implements RMIClientSocketFactory, RMIServerSocketFactory
    RMI运行时使用一个RMISocketFactory实例，以获取RMI调用的客户端和服务器套接字。 应用程序可以使用setSocketFactory方法请求RMI运行时使用其套接字工厂实例而不是默认实现。

    默认的套接字工厂实现创建到远程主机的直接套接字连接。

    默认套接字工厂实现创建绑定到通配符地址的服务器套接字，该通配符地址接受来自所有网络接口的请求。

    Implementation Note:

    您可以使用RMISocketFactory类创建绑定到特定地址的服务器套接字，限制请求的来源。 例如，以下代码实现将服务器套接字绑定到IPv4环回地址的套接字工厂。 这将限制RMI仅处理来自本地主机的请求。

       class LoopbackSocketFactory extends RMISocketFactory { public ServerSocket createServerSocket(int port) throws IOException { return new ServerSocket(port, 5, InetAddress.getByName("127.0.0.1")); } public Socket createSocket(String host, int port) throws IOException { // just call the default client socket factory return RMISocketFactory.getDefaultSocketFactory() .createSocket(host, port); } } // ... RMISocketFactory.setSocketFactory(new LoopbackSocketFactory());
    将java.rmi.server.hostname系统属性设置为127.0.0.1以确保生成的存根连接到正确的网络接口。
    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      RMISocketFactory​()
      构造一个 RMISocketFactory 。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract ServerSocket createServerSocket​(int port)
      在指定端口上创建服务器套接字（端口0表示匿名端口）。
      abstract Socket createSocket​(String host, int port)
      创建连接到指定主机和端口的客户端套接字。
      static RMISocketFactory getDefaultSocketFactory​()
      返回对此RMI实现使用的默认套接字工厂的引用。
      static RMIFailureHandler getFailureHandler​()
      返回由 setFailureHandler方法设置的套接字创建失败的处理程序。
      static RMISocketFactory getSocketFactory​()
      返回由 setSocketFactory方法设置的套接字工厂。
      static void setFailureHandler​(RMIFailureHandler fh)
      如果服务器套接字创建失败，则设置由RMI运行时调用的故障处理程序。
      static void setSocketFactory​(RMISocketFactory fac)
      设置RMI获取套接字的全局套接字工厂（如果远程对象与特定客户端和/或服务器套接字工厂没有关联）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RMISocketFactory

        public RMISocketFactory​()
        构造一个 RMISocketFactory 。
        从以下版本开始：
        1.1

    • 方法详细信息

      • createSocket

        public abstract Socket createSocket​(String host,
                                    int port)
                             throws IOException
        创建连接到指定主机和端口的客户端套接字。
        Specified by:
        createSocket在接口 RMIClientSocketFactory
        参数
        host - 主机名
        port - 端口号
        结果
        一个连接到指定主机和端口的套接字。
        异常
        IOException - 如果套接字创建期间发生I / O错误
        从以下版本开始：
        1.1

      • createServerSocket

        public abstract ServerSocket createServerSocket​(int port)
                                         throws IOException
        在指定端口上创建服务器套接字（端口0表示匿名端口）。
        Specified by:
        createServerSocket在接口 RMIServerSocketFactory
        参数
        port - 端口号
        结果
        指定端口上的服务器套接字
        异常
        IOException - 如果在创建服务器套接字期间发生I / O错误
        从以下版本开始：
        1.1

      • setSocketFactory

        public static void setSocketFactory​(RMISocketFactory fac)
                             throws IOException
        设置RMI获取套接字的全局套接字工厂（如果远程对象与特定客户端和/或服务器套接字工厂没有关联）。 RMI插座工厂只能设置一次。 注意：只有当当前安全管理器允许设置套接字工厂时，才可以设置RMISocketFactory; 如果不允许，将抛出SecurityException。
        参数
        fac - 套接字工厂
        异常
        IOException - 如果已经设置了RMI套接字工厂
        SecurityException - 如果存在安全管理员，并且其 checkSetFactory方法不允许操作。
        从以下版本开始：
        1.1
        另请参见：
        getSocketFactory() ， SecurityManager.checkSetFactory()

      • getSocketFactory

        public static RMISocketFactory getSocketFactory​()
        返回由setSocketFactory方法设置的套接字工厂。 如果没有设置套接字工厂，则返回null 。
        结果
        插座工厂
        从以下版本开始：
        1.1
        另请参见：
        setSocketFactory(RMISocketFactory)

      • getDefaultSocketFactory

        public static RMISocketFactory getDefaultSocketFactory​()
        返回对此RMI实现使用的默认套接字工厂的引用。 这将是RMI运行时使用的工厂， getSocketFactory返回null 。
        结果
        默认的RMI套接字工厂
        从以下版本开始：
        1.1

      • setFailureHandler

        public static void setFailureHandler​(RMIFailureHandler fh)
        如果服务器套接字创建失败，则设置由RMI运行时调用的故障处理程序。 默认情况下，如果没有安装故障处理程序并且服务器套接字创建失败，则RMI运行时会尝试重新创建服务器套接字。

        如果有安全管理员，则该方法首先调用安全管理器的checkSetFactory方法，以确保允许操作。 这可能会导致一个SecurityException 。

        参数
        fh - 故障处理程序
        异常
        SecurityException - 如果安全管理器存在，并且其 checkSetFactory方法不允许操作。
        从以下版本开始：
        1.1
        另请参见：
        getFailureHandler() ， RMIFailureHandler.failure(Exception)

      • getFailureHandler

        public static RMIFailureHandler getFailureHandler​()
        返回由 setFailureHandler方法设置的套接字创建失败的处理程序。
        结果
        故障处理程序
        从以下版本开始：
        1.1
        另请参见：
        setFailureHandler(RMIFailureHandler)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServerCloneException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class ServerCloneException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.CloneNotSupportedException
          • java.rmi.server.ServerCloneException
  • All Implemented Interfaces:
    Serializable

    public class ServerCloneException
extends CloneNotSupportedException
    甲ServerCloneException如果一个的克隆过程中发生远程抛出异常UnicastRemoteObject 。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 可以在建造时提供并通过公共detail字段访问的“嵌套异常”现在被称为原因 ，并且可以通过Throwable.getCause()方法以及前述的“传统字段”来访问。

    调用方法Throwable.initCause(Throwable)上的一个实例ServerCloneException总是抛出IllegalStateException 。

    从以下版本开始：
    1.1
    另请参见：
    UnicastRemoteObject.clone() ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      异常 detail
      造成异常的原因。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ServerCloneException​(String s)
      构造具有指定详细消息的 ServerCloneException 。
      ServerCloneException​(String s, 异常 cause)
      构造具有指定的详细信息和原因的 ServerCloneException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回此异常的原因。
      String getMessage​()
      返回详细信息，包括原因的消息（如果有的话）的异常。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 字段详细信息

      • detail

        public 异常 detail
        造成异常的原因。

        该领域早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

    • 构造方法详细信息

      • ServerCloneException

        public ServerCloneException​(String s)
        构造具有指定详细消息的 ServerCloneException 。
        参数
        s - 详细信息。

      • ServerCloneException

        public ServerCloneException​(String s,
                            异常 cause)
        构造一个具有指定的详细消息和原因的 ServerCloneException 。
        参数
        s - 详细信息。
        cause - 原因

    • 方法详细信息

      • getMessage

        public String getMessage​()
        返回详细信息，包括原因的消息（如果有的话）的异常。
        重写：
        getMessage在 Throwable
        结果
        详细信息

      • getCause

        public Throwable getCause​()
        返回此异常的原因。 此方法返回值为detail的字段。
        重写：
        getCause在 Throwable
        结果
        原因，可能是 null 。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ServerNotActiveException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class ServerNotActiveException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.rmi.server.ServerNotActiveException
  • All Implemented Interfaces:
    Serializable

    public class ServerNotActiveException
extends 异常
    如果在服务远程方法调用之外调用getClientHost方法，则 ServerNotActiveException是在调用 异常期间抛出的 RemoteServer.getClientHost 。
    从以下版本开始：
    1.1
    另请参见：
    RemoteServer.getClientHost() ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ServerNotActiveException​()
      构造一个没有指定详细信息的 ServerNotActiveException 。
      ServerNotActiveException​(String s)
      构造具有指定详细消息的 ServerNotActiveException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ServerNotActiveException

        public ServerNotActiveException​()
        构造一个没有指定详细消息的 ServerNotActiveException 。
        从以下版本开始：
        1.1

      • ServerNotActiveException

        public ServerNotActiveException​(String s)
        构造具有指定详细消息的 ServerNotActiveException 。
        参数
        s - 详细信息。
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServerRef (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Interface ServerRef

  • All Superinterfaces:
    Externalizable ， RemoteRef ， Serializable
    已过时。
    没有替换 此接口未使用，已过时。

    @Deprecated
public interface ServerRef
extends RemoteRef
    ServerRef表示远程对象实现的服务器端句柄。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      已过时。
      表示与JDK 1.1.x版本的类的兼容性。

      • Fields inherited from interface java.rmi.server.RemoteRef

        packagePrefix

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      RemoteStub exportObject​(Remote obj, Object data)
      已过时。
      为所提供的Remote对象创建客户端存根对象。
      String getClientHost​()
      已过时。
      返回当前客户端的主机名。

      • Methods inherited from interface java.io.Externalizable

        readExternal, writeExternal

      • Methods inherited from interface java.rmi.server.RemoteRef

        done, getRefClass, invoke, invoke, newCall, remoteEquals, remoteHashCode, remoteToString

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        已过时。
        表示与JDK 1.1.x版本的类的兼容性。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • exportObject

        RemoteStub exportObject​(Remote obj,
                        Object data)
                 throws RemoteException
        已过时。
        为所提供的Remote对象创建客户端存根对象。 如果呼叫成功完成，远程对象应该能够接受来自客户端的来电。
        参数
        obj - 远程对象实现
        data - 导出对象所需的信息
        结果
        远程对象的存根
        异常
        RemoteException - 如果尝试导出对象时出现异常（例如，无法找到存根类）
        从以下版本开始：
        1.1

      • getClientHost

        String getClientHost​()
              throws ServerNotActiveException
        已过时。
        返回当前客户端的主机名。 当主动处理远程方法调用的线程调用时，返回客户端的主机名。
        结果
        客户端的主机名
        异常
        ServerNotActiveException - 如果在服务远程方法调用之外调用
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Skeleton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Interface Skeleton

  • 已过时。
    没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。

    @Deprecated
public interface Skeleton
    Skeleton接口仅由RMI实现使用。

    由rmic stub编译器生成的每个版本1.1（和版本1.1兼容的骨架在1.2使用rmic -vcompat生成）实现了这个接口。 远程对象的骨架是将调用调度到实际远程对象实现的服务器端实体。

    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      void dispatch​(Remote obj, RemoteCall theCall, int opnum, long hash)
      已过时。
      没有替换
      Operation[] getOperations​()
      已过时。
      没有替换

    • 方法详细信息

      • dispatch

        @Deprecated
void dispatch​(Remote obj,
              RemoteCall theCall,
              int opnum,
              long hash)
       throws 异常
        已过时。 没有替换
        Unmarshals参数，调用实际的远程对象实现，并传递返回值或任何异常。
        参数
        obj - 远程实现调度调用
        theCall - 表示远程调用的对象
        opnum - 操作号
        hash - stub / skeleton接口哈希
        异常
        异常 - 如果发生一般异常。
        从以下版本开始：
        1.1

      • getOperations

        @Deprecated
Operation[] getOperations​()
        已过时。 没有替换
        返回骨架支持的操作。
        结果
        由骨架支持的操作
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SkeletonMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class SkeletonMismatchException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.server.SkeletonMismatchException
  • All Implemented Interfaces:
    Serializable
    已过时。
    没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。

    @Deprecated
public class SkeletonMismatchException
extends RemoteException
    当收到与可用骨架不匹配的调用时，会抛出此异常。 它指示此接口中的远程方法名称或签名已更改，或用于进行调用的Stub类和接收到调用的骨架不是由同一版本的存根编译器（ rmic ）生成的。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      SkeletonMismatchException​(String s)
      已过时。
      没有替换

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SkeletonMismatchException

        @Deprecated
public SkeletonMismatchException​(String s)
        已过时。 没有替换
        构造一个新的 SkeletonMismatchException具有指定的详细消息。
        参数
        s - 详细信息
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SkeletonNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class SkeletonNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.server.SkeletonNotFoundException
  • All Implemented Interfaces:
    Serializable
    已过时。
    没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。

    @Deprecated
public class SkeletonNotFoundException
extends RemoteException
    如果未找到与要导出的远程对象相对应的SkeletonNotFoundException则抛出Skeleton 。 骨骼不再需要，所以这个异常永远不会被抛出。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      SkeletonNotFoundException​(String s)
      已过时。
      构造具有指定详细消息的 SkeletonNotFoundException 。
      SkeletonNotFoundException​(String s, 异常 ex)
      已过时。
      构造具有指定的详细消息和嵌套异常的 SkeletonNotFoundException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SkeletonNotFoundException

        public SkeletonNotFoundException​(String s)
        已过时。
        构造具有指定详细消息的 SkeletonNotFoundException 。
        参数
        s - 详细信息。
        从以下版本开始：
        1.1

      • SkeletonNotFoundException

        public SkeletonNotFoundException​(String s,
                                 异常 ex)
        已过时。
        构造具有指定的详细消息和嵌套异常的 SkeletonNotFoundException 。
        参数
        s - 详细信息。
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SocketSecurityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class SocketSecurityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.server.ExportException
              • java.rmi.server.SocketSecurityException
  • All Implemented Interfaces:
    Serializable
    已过时。
    这个班已经过时了 改用ExportException 。

    @Deprecated
public class SocketSecurityException
extends ExportException
    一个过时的子类ExportException 。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      SocketSecurityException​(String s)
      已过时。
      构造一个具有指定详细信息的 SocketSecurityException 。
      SocketSecurityException​(String s, 异常 ex)
      已过时。
      构造具有指定的详细消息和嵌套异常的 SocketSecurityException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SocketSecurityException

        public SocketSecurityException​(String s)
        已过时。
        构造具有指定详细消息的 SocketSecurityException 。
        参数
        s - 详细信息。
        从以下版本开始：
        1.1

      • SocketSecurityException

        public SocketSecurityException​(String s,
                               异常 ex)
        已过时。
        构造具有指定的详细消息和嵌套异常的 SocketSecurityException 。
        参数
        s - 详细信息。
        ex - 嵌套异常
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class UID

  • java.lang.Object
    • java.rmi.server.UID
  • All Implemented Interfaces:
    Serializable

    public final class UID
extends Object
implements Serializable
    A UID表示相对于在其上生成的主机或者16个 “知名”标识符中的一个，其随着时间而言是唯一的标识符。

    UID()构造函数可用于生成相对于其生成的主机而言随时间而言是唯一的标识符。 UID(short)构造函数可用于创建2 16个已知标识符之一。

    A UID实例包含三个基元值：

    • unique ，一个int唯一标识VM这UID产生在相对于它的主体和由表示的时间time值（的示例实现unique值将是一个进程标识符）用于阱，或零UID
    • time ，一个long等于一个时间（如通过返回System.currentTimeMillis()在该VM，这一） UID在一个公知的产生在世时，或零UID
    • count ，一个short区分UID在同一个VM中产生的time值相同的值

    独立生成的UID实例对于主机而言随着时间的推移是独一无二的，只要主机需要超过一毫秒重新启动并且其系统时钟从不被设置为反向。 可以通过将UID实例与唯一主机标识符（如IP地址）进行配对来构建全局唯一标识符。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UID​()
      生成一个 UID ，它相对于生成的 UID而言是独一无二的。
      UID​(short num)
      创建“知名” UID 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的对象与此 UID进行比较以获得相等性。
      int hashCode​()
      返回此 UID的哈希码值。
      static UID read​(DataInput in)
      构造并返回一个新的 UID实例，通过从 DataInput实例解组二进制表示。
      String toString​()
      返回此 UID的字符串表示 UID 。
      void write​(DataOutput out)
      将 UID的二进制表示法 UID交给 DataOutput实例。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UID

        public UID​()
        生成一个 UID ，它是相对于生成的 UID而言是独一无二的。

      • UID

        public UID​(short num)
        创建了“知名” UID 。 有2116 个这样的知名ids。

        通过此构造函数创建的一个UID不会与通过no-arg构造函数生成的任何UID冲突。

        参数
        num - 着名的数字 UID

    • 方法详细信息

      • hashCode

        public int hashCode​()
        返回此 UID的哈希码值。
        重写：
        hashCode在 Object
        结果
        这个哈希码值为 UID
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将指定的对象与此UID进行比较以获得相等性。 此方法返回true当且仅当指定对象为UID实例具有相同unique ， time和count值作为这一个。
        重写：
        equals中的 Object
        参数
        obj - 对比这个 UID的对象
        结果
        true如果给定的对象相当于这个对象，而另外 false
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回此 UID的字符串表示 UID 。
        重写：
        toString在 Object
        结果
        这是 UID的字符串表示

      • write

        public void write​(DataOutput out)
           throws IOException
        将这个UID的二进制表示法UID交给DataOutput实例。

        具体地，此方法首先调用给定流的DataOutput.writeInt(int)方法与此UID的unique值，则调用流的DataOutput.writeLong(long)方法与此UID的time值，然后它调用流的DataOutput.writeShort(int)方法与此UID的count值。

        参数
        out - DataOutput实例写这个 UID到
        异常
        IOException - 执行此操作时是否发生I / O错误

      • read

        public static UID read​(DataInput in)
                throws IOException
        构造并返回一个新的UID实例，通过从DataInput实例解组二进制表示。

        具体来说，该方法首先调用给定流的DataInput.readInt()方法来读取一个unique值，然后调用该流的DataInput.readLong()方法来读取一个time值，然后调用该流的DataInput.readShort()方法来读取一个count值，然后创建并返回一个新UID包含实例unique ， time ，并count从流中读取的值。

        参数
        in - DataInput实例，从 UID从
        结果
        未编组 UID实例
        异常
        IOException - 执行此操作时是否发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnicastRemoteObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Class UnicastRemoteObject

  • java.lang.Object
    • java.rmi.server.RemoteObject
      • java.rmi.server.RemoteServer
        • java.rmi.server.UnicastRemoteObject
  • All Implemented Interfaces:
    Serializable ， Remote
    已知直接子类：
    ActivationGroup

    public class UnicastRemoteObject
extends RemoteServer
    用于使用JRMP导出远程对象并获取与远程对象通信的存根。 存根是使用动态代理对象在运行时生成的，或者它们在生成时静态生成，通常使用rmic工具。

    已弃用：静态存根。 支持静态生成的存根已被弃用。 这包括此类中需要使用静态存根的API，以及加载静态存根的运行时支持。 动态生成存根是首选的，使用以下列出的不推荐的导出对象之一。 不要运行rmic生成静态存根类。 这是不必要的，也是不推荐的。

    导出远程对象有八种方式：

    1. 子类UnicastRemoteObject并调用UnicastRemoteObject()构造函数。
    2. 分类UnicastRemoteObject并调用UnicastRemoteObject(port)构造函数。
    3. 分类UnicastRemoteObject并调用UnicastRemoteObject(port, csf, ssf)构造函数。
    4. 调用exportObject(Remote)方法。 已过时。
    5. 调用exportObject(Remote, port)方法。
    6. 调用exportObject(Remote, port, csf, ssf)方法。
    7. 调用exportObject(Remote, port, filter)方法。
    8. 调用exportObject(Remote, port, csf, ssf, filter)方法。

    第四种技术， exportObject(Remote) ，始终使用静态生成的存根，不推荐使用。

    其他技术都使用以下方法：如果java.rmi.server.ignoreStubClasses属性为true （不区分大小写），或者如果找不到静态存根，则使用Proxy对象动态生成存根。 否则，使用静态存根。

    java.rmi.server.ignoreStubClasses属性的默认值为false 。

    静态生成的存根通常使用rmic工具从远程对象的类中rmic 。 加载一个静态存根，并且如下所述构造该存根类的一个实例。

    • “根类”确定如下：如果远程对象的类直接实现扩展Remote的接口，那么远程对象的类是根类; 否则，根类是远程对象的类的最多派生超类，它直接实现扩展Remote的接口。
    • 要加载的存根类的名称是通过将根类的二进制名称与后缀_Stub连接来确定的。
    • 存根类使用根类的类加载器由名称加载。 存根类必须是公共的，它必须扩展到RemoteStub ，它必须驻留在导出到至少java.rmi模块的包中，并且它必须具有一个参数为RemoteRef的公共构造函数 。
    • 最后，一个stub类的一个实例是用一个RemoteRef构造的。
    • 如果无法找到适当的stub类，或者无法加载stub类，或者如果创建存根实例时出现问题，则抛出一个StubNotFoundException 。

    通过构造具有以下特征的Proxy的实例来动态生成存根：

    • 代理的类是根据Proxy类的规范定义的，使用远程对象的类的类加载器。
    • 代理实现远程对象的类实现的所有远程接口。
    • 每个远程接口必须是公共和驻留在一个包，是exported到至少java.rmi模块，或者它必须驻留在一个包，是open到至少java.rmi模块。
    • 代理的调用处理程序是RemoteObjectInvocationHandler用构建的实例RemoteRef 。
    • 如果无法创建代理，将抛出一个StubNotFoundException 。

    导出的远程对象将按照RMI规范中的描述接收来自存根的方法调用。 每个调用的操作和参数都使用自定义的ObjectInputStream解组 。 如果提供了一个ObjectInputFilter ，并且当对象被导出时，它不是null ，它用于过滤参数，因为它们是从流中解组的。 该过滤器用于所有调用和所有参数，无论调用的方法如何，或参数值。 如果没有提供过滤器或是null为导出的对象则ObjectInputStream默认过滤器，如果有的话，被使用。 默认过滤器配置为ObjectInputFilter.Config.setSerialFilter 。 如果过滤器拒绝的任何参数中， InvalidClassException通过抛出ObjectInputStream被报告为一个的原因UnmarshalException 。

    Implementation Note:
    根据使用哪种构造函数或静态方法导出对象，可以使用RMISocketFactory创建套接字。 默认情况下， RMISocketFactory创建的服务器套接字在所有网络接口上侦听。 见RMISocketFactory类和RMI Socket Factories中的Java RMI Specification 。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.server.RemoteObject

        ref

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected UnicastRemoteObject​()
      使用匿名端口创建并导出新的UnicastRemoteObject对象。
      protected UnicastRemoteObject​(int port)
      使用特定提供的端口创建并导出新的UnicastRemoteObject对象。
      protected UnicastRemoteObject​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用特定提供的端口和套接字工厂创建并导出新的UnicastRemoteObject对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Object clone​()
      返回与原始对象不同的远程对象的克隆。
      static RemoteStub exportObject​(Remote obj)
      已过时。
      此方法已被弃用，因为它仅支持静态存根。 改用exportObject(Remote, port)或exportObject(Remote, port, csf, ssf) 。
      static Remote exportObject​(Remote obj, int port)
      使用特定提供的端口导出远程对象以使其可用于接收来电。
      static Remote exportObject​(Remote obj, int port, ObjectInputFilter filter)
      使用特定提供的端口和filter导出远程对象以使其可用于接收来电。
      static Remote exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用给定套接字工厂指定的传输导出远程对象以使其可用于接收来电。
      static Remote exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, ObjectInputFilter filter)
      使用指定的套接字工厂指定的传输和filter ，导出远程对象以使其可用于接收来电。
      static boolean unexportObject​(Remote obj, boolean force)
      从RMI运行时中删除远程对象obj。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.server.RemoteObject

        equals, getRef, hashCode, toString, toStub

      • Methods inherited from class java.rmi.server.RemoteServer

        getClientHost, getLog, setLog

    • 构造方法详细信息

      • UnicastRemoteObject

        protected UnicastRemoteObject​()
                       throws RemoteException
        使用匿名端口创建并导出新的UnicastRemoteObject对象。

        导出的对象与使用RMISocketFactory类创建的服务器套接字。

        异常
        RemoteException - 如果无法导出对象
        从以下版本开始：
        1.1

      • UnicastRemoteObject

        protected UnicastRemoteObject​(int port)
                       throws RemoteException
        使用特定提供的端口创建并导出新的UnicastRemoteObject对象。

        导出的对象与使用RMISocketFactory类创建的服务器套接字。

        参数
        port - 远程对象接收呼叫的端口号（如果 port为零，则选择一个匿名端口）
        异常
        RemoteException - 如果无法导出对象
        从以下版本开始：
        1.2

      • UnicastRemoteObject

        protected UnicastRemoteObject​(int port,
                              RMIClientSocketFactory csf,
                              RMIServerSocketFactory ssf)
                       throws RemoteException
        使用特定提供的端口和套接字工厂创建并导出新的UnicastRemoteObject对象。

        插座工厂可能是null ，在这种情况下，使用相应的客户端或服务器套接字创建方法为RMISocketFactory 。

        参数
        port - 远程对象接收呼叫的端口号（如果 port为零，则选择一个匿名端口）
        csf - 用于调用远程对象的客户端套接字工厂
        ssf - 用于接收远程调用的服务器端套接字工厂
        异常
        RemoteException - 如果无法导出对象
        从以下版本开始：
        1.2

    • 方法详细信息

      • clone

        public Object clone​()
             throws CloneNotSupportedException
        返回与原始对象不同的远程对象的克隆。
        重写：
        clone在 Object
        结果
        新的远程对象
        异常
        CloneNotSupportedException - 如果由于RemoteException导致克隆失败。
        从以下版本开始：
        1.1
        另请参见：
        Cloneable

      • exportObject

        @Deprecated
public static RemoteStub exportObject​(Remote obj)
                               throws RemoteException
        已过时。 此方法已被弃用，因为它仅支持静态存根。 请改用exportObject(Remote, port)或exportObject(Remote, port, csf, ssf) 。
        导出远程对象使其可用于使用匿名端口接收来电。 此方法将始终返回静态生成的存根。

        导出的对象与使用RMISocketFactory类创建的服务器套接字。

        参数
        obj - 要导出的远程对象
        结果
        远程对象存根
        异常
        RemoteException - 如果导出失败
        从以下版本开始：
        1.1

      • exportObject

        public static Remote exportObject​(Remote obj,
                                  int port)
                           throws RemoteException
        使用特定提供的端口导出远程对象以使其可用于接收来电。

        使用RMISocketFactory类创建的服务器套接字导出对象。

        参数
        obj - 要导出的远程对象
        port - 导出对象的端口
        结果
        远程对象存根
        异常
        RemoteException - 如果导出失败
        从以下版本开始：
        1.2

      • exportObject

        public static Remote exportObject​(Remote obj,
                                  int port,
                                  RMIClientSocketFactory csf,
                                  RMIServerSocketFactory ssf)
                           throws RemoteException
        使用给定套接字工厂指定的传输导出远程对象以使其可用于接收来电。

        插座工厂可能是null ，在这种情况下，使用相应的客户端或服务器套接字创建方法RMISocketFactory 。

        参数
        obj - 要导出的远程对象
        port - 导出对象的端口
        csf - 用于调用远程对象的客户端套接字工厂
        ssf - 用于接收远程调用的服务器端套接字工厂
        结果
        远程对象存根
        异常
        RemoteException - 如果导出失败
        从以下版本开始：
        1.2

      • exportObject

        public static Remote exportObject​(Remote obj,
                                  int port,
                                  ObjectInputFilter filter)
                           throws RemoteException
        使用特定提供的端口和filter导出远程对象以使其可用于接收来电。

        导出的对象与使用RMISocketFactory类创建的服务器套接字。

        参数
        obj - 要导出的远程对象
        port - 导出对象的端口
        filter - 反序列化调用参数时应用的ObjectInputFilter; 可能是null
        结果
        远程对象存根
        异常
        RemoteException - 如果导出失败
        从以下版本开始：
        9

      • exportObject

        public static Remote exportObject​(Remote obj,
                                  int port,
                                  RMIClientSocketFactory csf,
                                  RMIServerSocketFactory ssf,
                                  ObjectInputFilter filter)
                           throws RemoteException
        导出远程对象以使其可用于接收来电，使用给定套接字工厂指定的传输和filter 。

        插座工厂可能是null ，在这种情况下，使用相应的客户端或服务器套接字创建方法为RMISocketFactory 。

        参数
        obj - 要导出的远程对象
        port - 导出对象的端口
        csf - 用于调用远程对象的客户端套接字工厂
        ssf - 用于接收远程调用的服务器端套接字工厂
        filter - 反序列化调用参数时应用的ObjectInputFilter; 可以是null
        结果
        远程对象存根
        异常
        RemoteException - 如果导出失败
        从以下版本开始：
        9

      • unexportObject

        public static boolean unexportObject​(Remote obj,
                                     boolean force)
                              throws NoSuchObjectException
        从RMI运行时中删除远程对象obj。 如果成功，对象不能再接受传入的RMI调用。 如果force参数为true，即使有远程对象的挂起调用或远程对象仍在进行调用，该对象也被强制取消导出。 如果force参数为false，则只有当对象没有待处理或正在进行调用时，对象才会取消导出。
        参数
        obj - 要取消导出的远程对象
        force - 如果为true，即使有待处理或正在进行的调用，也会force对象; 如果为false，则只有在没有待处理或正在进行的调用时，才会取消对象的输出
        结果
        如果操作成功，则为true，否则为false
        异常
        NoSuchObjectException - 如果远程对象当前未导出
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Unreferenced (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.rmi
软件包 java.rmi.server

Interface Unreferenced

  • 所有已知实现类：
    RMIConnectionImpl

    public interface Unreferenced
    当没有更多客户端引用该远程对象时，远程对象实现应实现 Unreferenced接口以接收通知。
    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void unreferenced​()
      运行时确定引用列表（引用远程对象的客户端列表）变为空时，由RMI运行时调用。

    • 方法详细信息

      • unreferenced

        void unreferenced​()
        运行时确定引用列表（引用远程对象的客户端列表）变为空时，由RMI运行时调用。
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.rmi.server (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.rmi.server

  • Packages that use java.rmi.server
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
  • Classes in java.rmi.server used by java.rmi.activation
    Class 描述
    RemoteObject
    RemoteObject类实现了远程对象的 java.lang.Object行为。
    RemoteRef
    RemoteRef表示远程对象的句柄。
    RemoteServer
    RemoteServer类是服务器实现的常见超类，并提供了支持各种远程引用语义的框架。
    RemoteStub
    已过时。
    静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。
    RMIClientSocketFactory
    RMI运行时使用 RMIClientSocketFactory实例来获取RMI调用的客户端套接字。
    RMIServerSocketFactory
    RMI运行时使用一个 RMIServerSocketFactory实例来获取RMI调用的服务器套接字。
    UnicastRemoteObject
    用于使用JRMP导出远程对象并获取与远程对象通信的存根。
  • Classes in java.rmi.server used by java.rmi.dgc
    Class 描述
    ObjID
    ObjID用于标识导出到RMI运行时的远程对象。
  • Classes in java.rmi.server used by java.rmi.registry
    Class 描述
    RMIClientSocketFactory
    RMI运行时使用 RMIClientSocketFactory实例来获取RMI调用的客户端套接字。
    RMIServerSocketFactory
    RMI运行时使用一个 RMIServerSocketFactory实例，以获取RMI调用的服务器套接字。
  • Classes in java.rmi.server used by java.rmi.server
    Class 描述
    ExportException
    如果尝试导出远程对象失败，则 ExportException是抛出的 RemoteException 。
    LogStream
    已过时。
    没有替换
    ObjID
    ObjID用于标识导出到RMI运行时的远程对象。
    Operation
    已过时。
    没有替换
    RemoteCall
    已过时。
    没有替换。
    RemoteObject
    RemoteObject类实现了远程对象的 java.lang.Object行为。
    RemoteRef
    RemoteRef表示远程对象的句柄。
    RemoteServer
    RemoteServer类是服务器实现的常见超类，并提供了支持各种远程引用语义的框架。
    RemoteStub
    已过时。
    静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。
    RMIClassLoaderSpi
    RMIClassLoaderSpi是服务提供者接口 RMIClassLoader 。
    RMIClientSocketFactory
    RMI运行时使用一个 RMIClientSocketFactory实例，以获取RMI调用的客户端套接字。
    RMIFailureHandler
    一个 RMIFailureHandler可以通过 RMISocketFactory.setFailureHandler通话进行注册。
    RMIServerSocketFactory
    RMI运行时使用 RMIServerSocketFactory实例，以获取RMI调用的服务器套接字。
    RMISocketFactory
    RMI运行时使用一个 RMISocketFactory实例，以获取RMI调用的客户端和服务器套接字。
    ServerNotActiveException
    如果在服务远程方法调用之外调用getClientHost方法，那么 ServerNotActiveException是在调用 异常期间抛出的 RemoteServer.getClientHost 。
    UID
    A UID表示相对于其在其上生成的主机或者 16个 “知名”标识符之一的时间而言是唯一的标识符。
  • Classes in java.rmi.server used by javax.management.remote.rmi
    Class 描述
    RemoteObject
    RemoteObject类实现了远程对象的 java.lang.Object行为。
    RemoteRef
    RemoteRef表示远程对象的句柄。
    RemoteStub
    已过时。
    静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。
    RMIClientSocketFactory
    RMI运行时使用 RMIClientSocketFactory实例来获取RMI调用的客户端套接字。
    RMIServerSocketFactory
    RMI运行时使用一个 RMIServerSocketFactory实例，以获取RMI调用的服务器套接字。
    Unreferenced
    当没有更多的客户端引用该远程对象时，远程对象实现应实现 Unreferenced接口以接收通知。
  • Classes in java.rmi.server used by javax.rmi.ssl
    Class 描述
    RMIClientSocketFactory
    RMI运行时使用 RMIClientSocketFactory实例，以获取RMI调用的客户端套接字。
    RMIServerSocketFactory
    RMI运行时使用 RMIServerSocketFactory实例来获取RMI调用的服务器套接字。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.ExportException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.ExportException

  • Packages that use ExportException
    软件包 描述
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of ExportException in java.rmi.server

      Subclasses of ExportException in java.rmi.server
      Modifier and Type Class 描述
      class  SocketSecurityException
      已过时。
      这个班已经过时了 改用ExportException 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.LogStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.LogStream

  • Packages that use LogStream
    软件包 描述
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of LogStream in java.rmi.server

      Methods in java.rmi.server that return LogStream
      Modifier and Type 方法 描述
      static LogStream LogStream.log​(String name)
      已过时。
      没有替换
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.ObjID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.ObjID

  • Packages that use ObjID
    软件包 描述
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of ObjID in java.rmi.dgc

      Methods in java.rmi.dgc with parameters of type ObjID
      Modifier and Type 方法 描述
      void DGC.clean​(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong)
      干净的呼叫从'id'中指示的每个远程对象的引用列表中删除'vmid'。
      Lease DGC.dirty​(ObjID[] ids, long sequenceNum, Lease lease)
      对于与数组“ids”中包含的对象标识符相关联的远程对象引用的脏调用请求。

    • Uses of ObjID in java.rmi.server

      Methods in java.rmi.server that return ObjID
      Modifier and Type 方法 描述
      static ObjID ObjID.read​(ObjectInput in)
      构造并返回一个新的 ObjID实例，通过从 ObjectInput实例解组二进制表示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.Operation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.Operation

  • Packages that use Operation
    软件包 描述
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of Operation in java.rmi.server

      Methods in java.rmi.server that return Operation
      Modifier and Type 方法 描述
      Operation[] Skeleton.getOperations​()
      已过时。
      没有替换
      Methods in java.rmi.server with parameters of type Operation
      Modifier and Type 方法 描述
      RemoteCall RemoteRef.newCall​(RemoteObject obj, Operation[] op, int opnum, long hash)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法调用的顺序上短截线的远程引用（的newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.RemoteObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.RemoteObject

  • Packages that use RemoteObject
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。

    • Uses of RemoteObject in java.rmi.activation

      Subclasses of RemoteObject in java.rmi.activation
      Modifier and Type Class 描述
      class  Activatable
      Activatable类为需要持续访问的远程对象提供支持，并且可以由系统激活。
      class  ActivationGroup
      一个 ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor何时：其对象变为活动或非活动，或组作为整体变为不活动。
      class  ActivationGroup_Stub
      ActivationGroup_Stub是导出为 java.rmi.server.UnicastRemoteObject的 java.rmi.activation.ActivationGroup的子类的存根类。

    • Uses of RemoteObject in java.rmi.server

      Subclasses of RemoteObject in java.rmi.server
      Modifier and Type Class 描述
      class  RemoteObjectInvocationHandler
      用于Java Remote Method Invocation（Java RMI）的 InvocationHandler接口的实现。
      class  RemoteServer
      RemoteServer类是服务器实现的常见超类，并提供了支持各种远程引用语义的框架。
      class  RemoteStub
      已过时。
      静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。
      class  UnicastRemoteObject
      用于使用JRMP导出远程对象并获取与远程对象通信的存根。
      Methods in java.rmi.server with parameters of type RemoteObject
      Modifier and Type 方法 描述
      RemoteCall RemoteRef.newCall​(RemoteObject obj, Operation[] op, int opnum, long hash)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法调用的顺序上短截线的远程引用（的newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回的值。

    • Uses of RemoteObject in javax.management.remote.rmi

      Subclasses of RemoteObject in javax.management.remote.rmi
      Modifier and Type | Class | 描述
      class  | RMIConnectionImpl_Stub
      class  | RMIServerImpl_Stub
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.RemoteObjectInvocationHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.RemoteObjectInvocationHandler

No usage of java.rmi.server.RemoteObjectInvocationHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.RemoteServer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.RemoteServer

  • Packages that use RemoteServer
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of RemoteServer in java.rmi.activation

      Subclasses of RemoteServer in java.rmi.activation
      Modifier and Type Class 描述
      class  Activatable
      Activatable类为需要持续访问的远程对象提供支持，并且可以由系统激活。
      class  ActivationGroup
      一个 ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor何时：其对象变为活动或非活动，或组作为一个整体变为非活动状态。

    • Uses of RemoteServer in java.rmi.server

      Subclasses of RemoteServer in java.rmi.server
      Modifier and Type Class 描述
      class  UnicastRemoteObject
      用于使用JRMP导出远程对象并获取与远程对象通信的存根。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.RemoteStub (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.RemoteStub

  • Packages that use RemoteStub
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。

    • Uses of RemoteStub in java.rmi.activation

      Subclasses of RemoteStub in java.rmi.activation
      Modifier and Type Class 描述
      class  ActivationGroup_Stub
      ActivationGroup_Stub是导出为 java.rmi.server.UnicastRemoteObject的 java.rmi.activation.ActivationGroup子类的存根类。

    • Uses of RemoteStub in java.rmi.server

      Methods in java.rmi.server that return RemoteStub
      Modifier and Type 方法 描述
      RemoteStub ServerRef.exportObject​(Remote obj, Object data)
      已过时。
      为所提供的Remote对象创建客户端存根对象。
      static RemoteStub UnicastRemoteObject.exportObject​(Remote obj)
      已过时。
      此方法已被弃用，因为它仅支持静态存根。 请改用exportObject(Remote, port)或exportObject(Remote, port, csf, ssf) 。
      Methods in java.rmi.server with parameters of type RemoteStub
      Modifier and Type 方法 描述
      protected static void RemoteStub.setRef​(RemoteStub stub, RemoteRef ref)
      已过时。
      没有替换 setRef方法用于设置远程存根的远程引用。 这是不必要的，因为RemoteStub可以创建和通过使用的远程引用初始化小号RemoteStub(RemoteRef)构造。

    • Uses of RemoteStub in javax.management.remote.rmi

      Subclasses of RemoteStub in javax.management.remote.rmi
      Modifier and Type | Class | 描述
      class  | RMIConnectionImpl_Stub
      class  | RMIServerImpl_Stub
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.RMIClassLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.RMIClassLoader

No usage of java.rmi.server.RMIClassLoader
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.RMIClassLoaderSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.RMIClassLoaderSpi

  • Packages that use RMIClassLoaderSpi
    软件包 描述
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of RMIClassLoaderSpi in java.rmi.server

      Methods in java.rmi.server that return RMIClassLoaderSpi
      Modifier and Type 方法 描述
      static RMIClassLoaderSpi RMIClassLoader.getDefaultProviderInstance​()
      返回服务提供商接口RMIClassLoaderSpi的默认提供程序的规范实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.RMISocketFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.RMISocketFactory

  • Packages that use RMISocketFactory
    软件包 描述
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of RMISocketFactory in java.rmi.server

      Methods in java.rmi.server that return RMISocketFactory
      Modifier and Type 方法 描述
      static RMISocketFactory RMISocketFactory.getDefaultSocketFactory​()
      返回对此RMI实现使用的默认套接字工厂的引用。
      static RMISocketFactory RMISocketFactory.getSocketFactory​()
      返回由 setSocketFactory方法设置的套接字工厂。
      Methods in java.rmi.server with parameters of type RMISocketFactory
      Modifier and Type 方法 描述
      static void RMISocketFactory.setSocketFactory​(RMISocketFactory fac)
      设置RMI获取套接字的全局套接字工厂（如果远程对象与特定客户端和/或服务器套接字工厂没有关联）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.ServerCloneException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.ServerCloneException

No usage of java.rmi.server.ServerCloneException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.ServerNotActiveException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.ServerNotActiveException

  • Packages that use ServerNotActiveException
    软件包 描述
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of ServerNotActiveException in java.rmi.server

      Methods in java.rmi.server that throw ServerNotActiveException
      Modifier and Type 方法 描述
      static String RemoteServer.getClientHost​()
      返回在当前线程中正在处理的远程方法调用的客户端主机的字符串表示形式。
      String ServerRef.getClientHost​()
      已过时。
      返回当前客户端的主机名。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.SkeletonMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.SkeletonMismatchException

No usage of java.rmi.server.SkeletonMismatchException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.SkeletonNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.SkeletonNotFoundException

No usage of java.rmi.server.SkeletonNotFoundException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.SocketSecurityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.SocketSecurityException

No usage of java.rmi.server.SocketSecurityException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.UID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.UID

  • Packages that use UID
    软件包 描述
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of UID in java.rmi.server

      Methods in java.rmi.server that return UID
      Modifier and Type 方法 描述
      static UID UID.read​(DataInput in)
      构造并返回一个新的 UID实例，通过从 DataInput实例解组二进制表示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.rmi.server.UnicastRemoteObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.rmi.server.UnicastRemoteObject

  • Packages that use UnicastRemoteObject
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。

    • Uses of UnicastRemoteObject in java.rmi.activation

      Subclasses of UnicastRemoteObject in java.rmi.activation
      Modifier and Type Class 描述
      class  ActivationGroup
      一个 ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor何时：其对象变为活动或非活动，或该组作为一个整体变为非活动状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.server.LoaderHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.server.LoaderHandler

No usage of java.rmi.server.LoaderHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.server.RemoteCall (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.server.RemoteCall

  • Packages that use RemoteCall
    软件包 描述
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of RemoteCall in java.rmi.server

      Methods in java.rmi.server that return RemoteCall
      Modifier and Type 方法 描述
      RemoteCall RemoteRef.newCall​(RemoteObject obj, Operation[] op, int opnum, long hash)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法调用的顺序上短截线的远程引用（的newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回的值。
      Methods in java.rmi.server with parameters of type RemoteCall
      Modifier and Type 方法 描述
      void Skeleton.dispatch​(Remote obj, RemoteCall theCall, int opnum, long hash)
      已过时。
      没有替换
      void RemoteRef.done​(RemoteCall call)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
      void RemoteRef.invoke​(RemoteCall call)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.server.RemoteRef (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.server.RemoteRef

  • Packages that use RemoteRef
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。

    • Uses of RemoteRef in java.rmi.activation

      Constructors in java.rmi.activation with parameters of type RemoteRef
      Constructor 描述
      ActivationGroup_Stub​(RemoteRef ref)
      为 ActivationGroup类构造一个存根。

    • Uses of RemoteRef in java.rmi.server

      Subinterfaces of RemoteRef in java.rmi.server
      Modifier and Type 接口 描述
      interface  ServerRef
      已过时。
      没有替换 此接口未使用，已过时。
      Fields in java.rmi.server declared as RemoteRef
      Modifier and Type Field 描述
      protected RemoteRef RemoteObject.ref
      对象的远程引用。
      Methods in java.rmi.server that return RemoteRef
      Modifier and Type 方法 描述
      RemoteRef RemoteObject.getRef​()
      返回远程对象的远程引用。
      Methods in java.rmi.server with parameters of type RemoteRef
      Modifier and Type 方法 描述
      boolean RemoteRef.remoteEquals​(RemoteRef obj)
      比较两个远程对象的相等性。
      protected static void RemoteStub.setRef​(RemoteStub stub, RemoteRef ref)
      已过时。
      没有替换 setRef方法用于设置远程存根的远程引用。 这是不必要的，因为RemoteStub可以创建和通过使用的远程引用初始化小号RemoteStub(RemoteRef)构造。
      Constructors in java.rmi.server with parameters of type RemoteRef
      Constructor 描述
      RemoteObject​(RemoteRef newref)
      创建一个远程对象，使用指定的远程引用进行初始化。
      RemoteObjectInvocationHandler​(RemoteRef ref)
      创建一个新的 RemoteObjectInvocationHandler构造与指定的 RemoteRef 。
      RemoteServer​(RemoteRef ref)
      构造具有给定参考类型的 RemoteServer 。
      RemoteStub​(RemoteRef ref)
      已过时。
      使用指定的远程引用构造一个 RemoteStub 。

    • Uses of RemoteRef in javax.management.remote.rmi

      Constructors in javax.management.remote.rmi with parameters of type RemoteRef
      Constructor 描述
      RMIConnectionImpl_Stub​(RemoteRef ref)
      RMIServerImpl_Stub​(RemoteRef ref)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.server.RMIClientSocketFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.server.RMIClientSocketFactory

  • Packages that use RMIClientSocketFactory
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。

    • Uses of RMIClientSocketFactory in java.rmi.activation

      Methods in java.rmi.activation with parameters of type RMIClientSocketFactory
      Modifier and Type 方法 描述
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      Constructors in java.rmi.activation with parameters of type RMIClientSocketFactory
      Constructor 描述
      Activatable​(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并导出具有指定端口的对象以及指定的客户端和服务器套接字工厂。
      Activatable​(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      用于在指定端口上激活/导出对象的构造方法。

    • Uses of RMIClientSocketFactory in java.rmi.registry

      Methods in java.rmi.registry with parameters of type RMIClientSocketFactory
      Modifier and Type 方法 描述
      static Registry LocateRegistry.createRegistry​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      在本地主机上创建并导出 Registry实例，该实例使用自定义套接字工厂进行与该实例的通信。
      static Registry LocateRegistry.getRegistry​(String host, int port, RMIClientSocketFactory csf)
      返回在指定的 host和 port上的远程对象 Registry的本地创建的远程引用。

    • Uses of RMIClientSocketFactory in java.rmi.server

      Classes in java.rmi.server that implement RMIClientSocketFactory
      Modifier and Type Class 描述
      class  RMISocketFactory
      RMI运行时使用 RMISocketFactory实例，以获取RMI调用的客户端和服务器套接字。
      Methods in java.rmi.server with parameters of type RMIClientSocketFactory
      Modifier and Type 方法 描述
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用给定套接字工厂指定的传输导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, ObjectInputFilter filter)
      导出远程对象以使其可用于接收来电，使用给定套接字工厂指定的传输和filter 。
      Constructors in java.rmi.server with parameters of type RMIClientSocketFactory
      Constructor 描述
      UnicastRemoteObject​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用特定提供的端口和套接字工厂创建并导出新的UnicastRemoteObject对象。

    • Uses of RMIClientSocketFactory in javax.management.remote.rmi

      Constructors in javax.management.remote.rmi with parameters of type RMIClientSocketFactory
      Constructor 描述
      RMIJRMPServerImpl​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
      创建一个新的RMIServer对象，该对象将使用给定的套接字工厂在给定端口上导出。

    • Uses of RMIClientSocketFactory in javax.rmi.ssl

      Classes in javax.rmi.ssl that implement RMIClientSocketFactory
      Modifier and Type Class 描述
      class  SslRMIClientSocketFactory
      RMI运行时使用一个 SslRMIClientSocketFactory实例，以便通过SSL获取RMI调用的客户端套接字。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.server.RMIFailureHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.server.RMIFailureHandler

  • Packages that use RMIFailureHandler
    软件包 描述
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of RMIFailureHandler in java.rmi.server

      Methods in java.rmi.server that return RMIFailureHandler
      Modifier and Type 方法 描述
      static RMIFailureHandler RMISocketFactory.getFailureHandler​()
      返回由 setFailureHandler方法设置的套接字创建失败的处理程序。
      Methods in java.rmi.server with parameters of type RMIFailureHandler
      Modifier and Type 方法 描述
      static void RMISocketFactory.setFailureHandler​(RMIFailureHandler fh)
      如果服务器套接字创建失败，则设置由RMI运行时调用的故障处理程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.server.RMIServerSocketFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.server.RMIServerSocketFactory

  • Packages that use RMIServerSocketFactory
    软件包 描述
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。

    • Uses of RMIServerSocketFactory in java.rmi.activation

      Methods in java.rmi.activation with parameters of type RMIServerSocketFactory
      Modifier and Type 方法 描述
      static ActivationID Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。
      static Remote Activatable.exportObject​(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
      Constructors in java.rmi.activation with parameters of type RMIServerSocketFactory
      Constructor 描述
      Activatable​(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并导出具有指定端口的对象以及指定的客户端和服务器套接字工厂。
      Activatable​(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      用于在指定端口上激活/导出对象的构造方法。

    • Uses of RMIServerSocketFactory in java.rmi.registry

      Methods in java.rmi.registry with parameters of type RMIServerSocketFactory
      Modifier and Type 方法 描述
      static Registry LocateRegistry.createRegistry​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      在本地主机上创建并导出 Registry实例，该实例使用自定义套接字工厂进行与该实例的通信。

    • Uses of RMIServerSocketFactory in java.rmi.server

      Classes in java.rmi.server that implement RMIServerSocketFactory
      Modifier and Type Class 描述
      class  RMISocketFactory
      RMI运行时使用 RMISocketFactory实例，以获取RMI调用的客户端和服务器套接字。
      Methods in java.rmi.server with parameters of type RMIServerSocketFactory
      Modifier and Type 方法 描述
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用给定套接字工厂指定的传输导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, ObjectInputFilter filter)
      使用指定的套接字工厂指定的传输和filter导出远程对象以使其可用于接收来电。
      Constructors in java.rmi.server with parameters of type RMIServerSocketFactory
      Constructor 描述
      UnicastRemoteObject​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
      使用特定提供的端口和套接字工厂创建并导出新的UnicastRemoteObject对象。

    • Uses of RMIServerSocketFactory in javax.management.remote.rmi

      Constructors in javax.management.remote.rmi with parameters of type RMIServerSocketFactory
      Constructor 描述
      RMIJRMPServerImpl​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
      创建一个新的RMIServer对象，该对象将使用给定的套接字工厂在给定端口上导出。

    • Uses of RMIServerSocketFactory in javax.rmi.ssl

      Classes in javax.rmi.ssl that implement RMIServerSocketFactory
      Modifier and Type Class 描述
      class  SslRMIServerSocketFactory
      RMI运行时使用 SslRMIServerSocketFactory实例，以通过SSL获取用于RMI调用的服务器套接字。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.server.ServerRef (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.server.ServerRef

No usage of java.rmi.server.ServerRef
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.server.Skeleton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.server.Skeleton

No usage of java.rmi.server.Skeleton
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.rmi.server.Unreferenced (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.rmi.server.Unreferenced

  • Packages that use Unreferenced
    软件包 描述
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。

    • Uses of Unreferenced in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement Unreferenced
      Modifier and Type Class 描述
      class  RMIConnectionImpl
      实现RMIConnection接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AccessControlContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class AccessControlContext

  • java.lang.Object
    • java.security.AccessControlContext

  • public final class AccessControlContext
extends Object
    AccessControlContext用于根据其封装的上下文来进行系统资源访问决策。

    更具体地，它封装了一个上下文，并且具有单一的方法， checkPermission ，即相当于checkPermission在AccessController类方法，有一点不同：所述的AccessControlContext checkPermission方法使得访问决策基于它所封装的上下文，而不是的当前执行线程。

    因此，AccessControlContext的目的是针对那些在给定上下文中应该进行安全检查的情况实际上需要从不同的上下文（例如，从工作线程）内完成的情况。

    通过调用AccessController.getContext方法创建一个AccessControlContext。 getContext方法使用当前调用上下文的“快照”，并将其放置在AccessControlContext对象中，该对象返回。 示例呼叫如下：

      AccessControlContext acc = AccessController.getContext()

    随后可以在先前保存的AccessControlContext对象中调用checkPermission方法。 示例呼叫如下：

      acc.checkPermission(permission)
    从以下版本开始：
    1.2
    另请参见：
    AccessController

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessControlContext​(AccessControlContext acc, DomainCombiner combiner)
      创建一个新的 AccessControlContext与给定的 AccessControlContext和 DomainCombiner 。
      AccessControlContext​(ProtectionDomain[] context)
      使用给定的ProtectionDomains数组创建一个AccessControlContext。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void checkPermission​(Permission perm)
      根据当前有效的安全策略以及此对象中的上下文确定是否允许或拒绝由指定权限指定的访问请求。
      boolean equals​(Object obj)
      检查两个AccessControlContext对象的相等性。
      DomainCombiner getDomainCombiner​()
      获取 DomainCombiner与此 AccessControlContext相关联。
      int hashCode​()
      返回此上下文的哈希码值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessControlContext

        public AccessControlContext​(ProtectionDomain[] context)
        使用给定的ProtectionDomains数组创建一个AccessControlContext。 上下文不能为空。 重复的域将从上下文中删除。
        参数
        context - 与此上下文相关联的ProtectionDomains。 不重复的域从数组复制。 对数组的后续更改不会影响此AccessControlContext。
        异常
        NullPointerException - 如果 context是 null

      • AccessControlContext

        public AccessControlContext​(AccessControlContext acc,
                            DomainCombiner combiner)
        创建一个新的AccessControlContext与给定的AccessControlContext和DomainCombiner 。 此构造函数将所提供的DomainCombiner与所提供的AccessControlContext相关联。
        参数
        acc -在 AccessControlContext与所提供的相关 DomainCombiner 。
        combiner - 要与 DomainCombiner相关联的 AccessControlContext 。
        异常
        NullPointerException - 如果提供的 context是 null 。
        SecurityException - 如果安装了一个安全管理器，并且调用者没有“createAccessControlContext” SecurityPermission
        从以下版本开始：
        1.3

    • 方法详细信息

      • getDomainCombiner

        public DomainCombiner getDomainCombiner​()
        获取 DomainCombiner与此 AccessControlContext相关联。
        结果
        在 DomainCombiner与此相关 AccessControlContext ，或 null如果是没有的。
        异常
        SecurityException - 如果安装了一个安全管理器，并且调用者没有“getDomainCombiner” SecurityPermission
        从以下版本开始：
        1.3

      • checkPermission

        public void checkPermission​(Permission perm)
                     throws AccessControlException
        根据当前有效的安全策略以及此对象中的上下文确定是否允许或拒绝由指定权限指定的访问请求。 仅当上下文中的每个ProtectionDomain意味着权限时，才允许该请求。 否则请求被拒绝。

        如果允许访问请求，此方法静默返回，否则抛出适当的AccessControlException。

        参数
        perm - 请求的权限。
        异常
        AccessControlException - 如果不允许指定的权限，则基于当前安全策略和此对象封装的上下文。
        NullPointerException - 如果检查的权限为空。

      • equals

        public boolean equals​(Object obj)
        检查两个AccessControlContext对象的相等性。 检查obj是AccessControlContext，并具有与此上下文相同的ProtectionDomains集。
        重写：
        equals在 Object
        参数
        obj - 我们正在测试与此对象相等的对象。
        结果
        如果 obj是AccessControlContext， obj true，并且与此上下文具有相同的ProtectionDomain集合，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此上下文的哈希码值。 哈希码是通过将上下文中所有保护域的哈希码排除在一起来计算的。
        重写：
        hashCode在 Object
        结果
        这个上下文的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessControlException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class AccessControlException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.SecurityException
            • java.security.AccessControlException
  • All Implemented Interfaces:
    Serializable

    public class AccessControlException
extends SecurityException

    AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。

    否认访问的原因可能有所不同。 例如，所请求的权限可能是不正确的类型，包含无效值，或请求根据安全策略不允许的访问。 这样的信息应该尽可能在抛出异常时给出。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessControlException​(String s)
      构造一个 AccessControlException具有指定的详细消息。
      AccessControlException​(String s, Permission p)
      构造具有指定的详细消息的 AccessControlException以及引起异常的请求权限。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Permission getPermission​()
      获取与此异常关联的Permission对象，如果没有相应的Permission对象，则为null。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AccessControlException

        public AccessControlException​(String s)
        构造一个 AccessControlException具有指定的详细消息。
        参数
        s - 详细信息。

      • AccessControlException

        public AccessControlException​(String s,
                              Permission p)
        构造具有指定的详细消息的 AccessControlException以及引起异常的请求权限。
        参数
        s - 详细信息。
        p - 导致异常的权限。

    • 方法详细信息

      • getPermission

        public Permission getPermission​()
        获取与此异常关联的Permission对象，如果没有相应的Permission对象，则为null。
        结果
        权限对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessController (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class AccessController

  • java.lang.Object
    • java.security.AccessController

  • public final class AccessController
extends Object

    AccessController类用于访问控制操作和决策。

    更具体地说，AccessController类用于三个目的：

    • 根据当前有效的安全策略来决定是否允许或拒绝对关键系统资源的访问，
    • 将代码标记为“特权”，从而影响随后的访问确定
    • 为了获得当前呼叫上下文的“快照”，可以针对保存的上下文进行来自不同上下文的访问控制决定。

    checkPermission方法确定是否应该授予或拒绝由指定权限指定的访问请求。 以下示例呼叫。 在此示例中， checkPermission将确定是否授予“读取”对“/ temp”目录中名为“testFile”的文件的访问权限。

      FilePermission perm = new FilePermission("/temp/testFile", "read");
 AccessController.checkPermission(perm);

    如果允许访问请求，则checkPermission返回。 如果被拒绝，则抛出AccessControlException。 如果请求的权限类型不正确或包含无效值，则也可以抛出AccessControlException。 尽可能提供这些信息。 假设当前线程遍历m个呼叫者，按照呼叫者1到呼叫者2到呼叫者m的顺序。 然后调用者m调用了checkPermission方法。 checkPermission方法基于以下算法确定是否授予或拒绝访问：

       for (int i = m; i > 0; i--) { if (caller i's domain does not have the permission) throw AccessControlException else if (caller i is marked as privileged) { if (a context was specified in the call to doPrivileged) context.checkPermission(permission) if (limited permissions were specified in the call to doPrivileged) { for (each limited permission) { if (the limited permission implies the requested permission) return; } } else return; } } // Next, check the context inherited when the thread was created. // Whenever a new thread is created, the AccessControlContext at // that time is stored and associated with the new thread, as the // "inherited" context. inheritedContext.checkPermission(permission);

    主叫方可以被标记为“特权”（见doPrivileged及以下）。 进行访问控制决定时， checkPermission方法将停止检查是否通过没有上下文参数的doPrivileged呼叫到达被标记为“特权”的doPrivileged （有关上下文参数的信息，请参阅下文）。 如果该呼叫者的域具有指定的权限，并且至少有一个限制许可参数（如果有的话）意味着请求的权限，则不进行进一步的检查，并且checkPermission返回，表示允许请求的访问。 如果该域没有指定的权限，那么会照常抛出异常。 如果来电者的域名具有指定的许可权，但是在调用doPrivileged给出的任何限制权限参数并不暗示权限检查，直到没有更多的呼叫者或其他doPrivileged呼叫与所请求的权限匹配并且正常返回。

    正常使用“特权”功能如下。 如果您不需要从“特权”块中返回值，请执行以下操作：

       somemethod() { ...normal code here... AccessController.doPrivileged(new PrivilegedAction<Void>() { public Void run() { // privileged code goes here, for example: System.loadLibrary("awt"); return null; // nothing to return } }); ...normal code here... }

    PrivilegedAction是一种具有单一方法的接口，名称为run 。 上面的例子显示了该接口的实现的创建; 提供了run方法的具体实现。 当调用doPrivileged时， doPrivileged PrivilegedAction实现的实例传递给它。 doPrivileged方法在启用权限后从PrivilegedAction实现调用run方法，并返回run方法的返回值作为doPrivileged返回值（在此示例doPrivileged被忽略）。

    如果需要返回值，可以执行以下操作：

       somemethod() { ...normal code here... String user = AccessController.doPrivileged( new PrivilegedAction<String>() { public String run() { return System.getProperty("user.name"); } }); ...normal code here... }

    如果您的run方法中执行的操作可能会引发“检查”异常（方法的throws子句中列出的异常），则需要使用PrivilegedExceptionAction接口，而不是PrivilegedAction接口：

       somemethod() throws FileNotFoundException { ...normal code here... try { FileInputStream fis = AccessController.doPrivileged( new PrivilegedExceptionAction<FileInputStream>() { public FileInputStream run() throws FileNotFoundException { return new FileInputStream("someFile"); } }); } catch (PrivilegedActionException e) { // e.getException() should be an instance of FileNotFoundException, // as only "checked" exceptions will be "wrapped" in a // PrivilegedActionException. throw (FileNotFoundException) e.getException(); } ...normal code here... }

    在使用“特权”结构时，请注意*，并始终记住使特权代码部分尽可能小。 您可以通过Permission参数来进一步限制“特权”的范围（见下文）。

    请注意， checkPermission始终在当前正在执行的线程的上下文中执行安全检查。 有时，在特定上下文中应该进行的安全检查实际上需要在不同的上下文（例如，从工作线程中）完成。 为这种情况提供了getContext方法和AccessControlContext类。 getContext方法使用当前调用上下文的“快照”，并将其放置在AccessControlContext对象中，该对象返回。 示例呼叫如下：

      AccessControlContext acc = AccessController.getContext()

    AccessControlContext本身具有一个checkPermission方法，可以根据其封装的上下文而不是当前执行线程进行访问决策。 因此，不同上下文中的代码可以在先前保存的AccessControlContext对象上调用该方法。 示例呼叫如下：

      acc.checkPermission(permission)

    还有一些时间，您不知道先验哪些权限来检查上下文。 在这些情况下，您可以使用采用上下文的doPrivileged方法。 您也可以传递额外的Permission参数来限制特权代码的范围。

       somemethod() { AccessController.doPrivileged(new PrivilegedAction<Object>() { public Object run() { // Code goes here. Any permission checks within this // run method will require that the intersection of the // caller's protection domain and the snapshot's // context have the desired permission. If a requested // permission is not implied by the limiting FilePermission // argument then checking of the thread continues beyond the // caller of doPrivileged. } }, acc, new FilePermission("/temp/*", read)); ...normal code here... }

    传递限制Permission的一个实例的参数AllPermission相当于调用等效doPrivileged而不限制方法Permission参数。 传递Permission的零长度数组将禁用代码权限，以便检查始终超出doPrivileged方法的调用者。

    从以下版本开始：
    1.2
    另请参见：
    AccessControlContext

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static void checkPermission​(Permission perm)
      根据当前的AccessControlContext和安全策略确定是否允许或拒绝由指定的权限指定的访问请求。
      static <T> T doPrivileged​(PrivilegedAction<T> action)
      执行指定的 PrivilegedAction启用特权。
      static <T> T doPrivileged​(PrivilegedAction<T> action, AccessControlContext context)
      执行指定的 PrivilegedAction ，启用特权并限制指定的 AccessControlContext 。
      static <T> T doPrivileged​(PrivilegedAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedAction ，其特权启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
      static <T> T doPrivileged​(PrivilegedExceptionAction<T> action)
      执行指定的 PrivilegedExceptionAction启用特权。
      static <T> T doPrivileged​(PrivilegedExceptionAction<T> action, AccessControlContext context)
      执行指定的 PrivilegedExceptionAction具有启用和限制的特定 AccessControlContext 。
      static <T> T doPrivileged​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction具有启用并受指定的 AccessControlContext限制的特权，并且特权范围受指定的 Permission参数限制。
      static <T> T doPrivilegedWithCombiner​(PrivilegedAction<T> action)
      执行指定的 PrivilegedAction启用特权。
      static <T> T doPrivilegedWithCombiner​(PrivilegedAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
      static <T> T doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action)
      执行指定的 PrivilegedExceptionAction ，启用特权。
      static <T> T doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction具有启用并受指定的 AccessControlContext限制的特权，并且特权范围受指定的 Permission参数限制。
      static AccessControlContext getContext​()
      此方法将获取当前调用上下文的“快照”，其中包括当前Thread的继承的AccessControlContext和任何有限权限范围，并将其放置在AccessControlContext对象中。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • doPrivileged

        public static <T> T doPrivileged​(PrivilegedAction<T> action)
        执行指定的PrivilegedAction启用特权。 该操作是由呼叫者的保护域拥有的所有权限执行的。

        如果动作的run方法抛出（未检查）异常，它将通过此方法传播。

        请注意，执行操作时，将忽略与当前AccessControlContext关联的任何DomainCombiner。

        参数类型
        T - PrivilegedAction的 run方法返回的值的类型。
        参数
        action - 要执行的动作。
        结果
        由该操作的 run方法返回的值。
        异常
        NullPointerException - 如果动作是 null
        另请参见：
        doPrivileged(PrivilegedAction,AccessControlContext) ， doPrivileged(PrivilegedExceptionAction) ， doPrivilegedWithCombiner(PrivilegedAction) ， DomainCombiner

      • doPrivilegedWithCombiner

        public static <T> T doPrivilegedWithCombiner​(PrivilegedAction<T> action)
        执行指定的PrivilegedAction启用特权。 该操作是由呼叫者的保护域拥有的所有权限执行的。

        如果动作的run方法抛出（未选中）异常，它将通过此方法传播。

        该方法在执行操作时保留当前的AccessControlContext的DomainCombiner（可能为null）。

        参数类型
        T - PrivilegedAction的 run方法返回的值的类型。
        参数
        action - 要执行的动作。
        结果
        由该操作的 run方法返回的值。
        异常
        NullPointerException - 如果操作是 null
        从以下版本开始：
        1.6
        另请参见：
        doPrivileged(PrivilegedAction) ， DomainCombiner

      • doPrivileged

        public static <T> T doPrivileged​(PrivilegedAction<T> action,
                                 AccessControlContext context)
        执行指定的PrivilegedAction具有启用和限制的特定AccessControlContext 。 该操作是由呼叫者的保护域所拥有的权限与由指定的AccessControlContext表示的域所拥有的权限进行AccessControlContext 。

        如果动作的run方法抛出一个（未经检查的）异常，它将通过此方法传播。

        如果安装了一个安全管理器，并且系统代码未创建指定的AccessControlContext ，并且调用方的ProtectionDomain尚未被授予“createAccessControlContext” SecurityPermission ，那么该操作将在没有权限的情况下执行。

        参数类型
        T - PrivilegedAction的 run方法返回的值的类型。
        参数
        action - 要执行的动作。
        context - 表示在执行指定操作之前应用于调用方域的权限的限制的访问控制上下文 。 如果上下文为null ，则不再应用其他限制。
        结果
        由操作的 run方法返回的值。
        异常
        NullPointerException - 如果动作是 null
        另请参见：
        doPrivileged(PrivilegedAction) ， doPrivileged(PrivilegedExceptionAction,AccessControlContext)

      • doPrivileged

        public static <T> T doPrivileged​(PrivilegedAction<T> action,
                                 AccessControlContext context,
                                 Permission... perms)
        执行指定的PrivilegedAction ，该权限启用并受指定的AccessControlContext限制，特权范围受指定的Permission参数限制。 该行为是由呼叫者的保护域所拥有的权限与由指定的AccessControlContext表示的域所拥有的权限进行AccessControlContext 。

        如果动作的run方法抛出（未选中）异常，它将通过此方法传播。

        如果安装了一个安全管理器，并且没有由系统代码创建指定的AccessControlContext ，并且调用方的ProtectionDomain尚未被授予“createAccessControlContext” SecurityPermission ，则该操作将在没有权限的情况下执行。

        参数类型
        T - PrivilegedAction的 run方法返回的值的类型。
        参数
        action - 要执行的动作。
        context - 表示在执行指定操作之前应用于调用方域的权限的限制的访问控制上下文 。 如果上下文是null ，则不应用附加限制。
        perms - Permission参数，限制了调用者权限的范围。 参数的数量是可变的。
        结果
        由该操作的 run方法返回的值。
        异常
        NullPointerException - 如果动作或 NullPointerException或任何perms元素是 null
        从以下版本开始：
        1.8
        另请参见：
        doPrivileged(PrivilegedAction) ， doPrivileged(PrivilegedExceptionAction,AccessControlContext)

      • doPrivilegedWithCombiner

        public static <T> T doPrivilegedWithCombiner​(PrivilegedAction<T> action,
                                             AccessControlContext context,
                                             Permission... perms)
        执行指定的PrivilegedAction ，启用并受限于指定的AccessControlContext ，并且特权范围受指定的Permission参数限制。 该行为是由呼叫者的保护域所拥有的权限与由指定的AccessControlContext表示的域所拥有的权限进行AccessControlContext 。

        如果动作的run方法抛出（未选中）异常，它将通过此方法传播。

        该方法在执行操作时保留当前的AccessControlContext的DomainCombiner（可能为null）。

        如果安装了安全管理器，并且系统代码未创建指定的AccessControlContext并且未通过调用方的ProtectionDomain授予“createAccessControlContext” SecurityPermission ，则该操作将以无权限执行。

        参数类型
        T - PrivilegedAction的 run方法返回的值的类型。
        参数
        action - 要执行的动作。
        context - 表示在执行指定操作之前应用于调用方域的权限的限制的访问控制上下文 。 如果上下文是null ，则不应用附加限制。
        perms - 限制调用者权限范围的Permission参数。 参数的数量是可变的。
        结果
        由该操作的 run方法返回的值。
        异常
        NullPointerException - 如果动作或perms或任何perms元素是 null
        从以下版本开始：
        1.8
        另请参见：
        doPrivileged(PrivilegedAction) ， doPrivileged(PrivilegedExceptionAction,AccessControlContext) ， DomainCombiner

      • doPrivileged

        public static <T> T doPrivileged​(PrivilegedExceptionAction<T> action)
                          throws PrivilegedActionException
        执行指定的PrivilegedExceptionAction启用特权。 该操作是由呼叫者的保护域拥有的所有权限执行的。

        如果动作的run方法抛出未经检查的异常，它将通过此方法传播。

        请注意，执行操作时，将忽略与当前AccessControlContext关联的任何DomainCombiner。

        参数类型
        T - PrivilegedExceptionAction的 run方法返回的值的类型。
        参数
        action - 要执行的动作
        结果
        由该操作的 run方法返回的值
        异常
        PrivilegedActionException - 如果指定的动作的 run方法抛出一个 被检查的异常
        NullPointerException - 如果动作是 null
        另请参见：
        doPrivileged(PrivilegedAction) ， doPrivileged(PrivilegedExceptionAction,AccessControlContext) ， doPrivilegedWithCombiner(PrivilegedExceptionAction) ， DomainCombiner

      • doPrivilegedWithCombiner

        public static <T> T doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action)
                                      throws PrivilegedActionException
        执行指定的PrivilegedExceptionAction启用特权。 该操作是由呼叫者的保护域拥有的所有权限执行的。

        如果动作的run方法抛出未经检查的异常，它将通过此方法传播。

        该方法在执行操作时保留当前的AccessControlContext的DomainCombiner（可能为null）。

        参数类型
        T - PrivilegedExceptionAction的 run方法返回的值的类型。
        参数
        action - 要执行的动作。
        结果
        由该操作的 run方法返回的值
        异常
        PrivilegedActionException - 如果指定的动作的 run方法抛出一个 被检查的异常
        NullPointerException - 如果动作是 null
        从以下版本开始：
        1.6
        另请参见：
        doPrivileged(PrivilegedAction) ， doPrivileged(PrivilegedExceptionAction,AccessControlContext) ， DomainCombiner

      • doPrivileged

        public static <T> T doPrivileged​(PrivilegedExceptionAction<T> action,
                                 AccessControlContext context)
                          throws PrivilegedActionException
        执行指定的PrivilegedExceptionAction ，其特权被启用并受指定的AccessControlContext限制。 该操作是由呼叫者的保护域所拥有的权限和由指定的AccessControlContext表示的域拥有的AccessControlContext 。

        如果动作的run方法抛出未经检查的异常，它将通过此方法传播。

        如果安装了安全管理器，并且系统代码未创建指定的AccessControlContext ，并且调用方的ProtectionDomain尚未被授予“createAccessControlContext” SecurityPermission ，则该操作将以无权限执行。

        参数类型
        T - 由PrivilegedExceptionAction的 run方法返回的值的类型。
        参数
        action - 要执行的操作
        context - 表示在执行指定操作之前应用于调用方域的权限的限制的访问控制上下文 。 如果上下文为null ，则不再应用其他限制。
        结果
        由该操作的 run方法返回的值
        异常
        PrivilegedActionException - 如果指定的动作的 run方法抛出一个 被检查的异常
        NullPointerException - 如果动作是 null
        另请参见：
        doPrivileged(PrivilegedAction) ， doPrivileged(PrivilegedAction,AccessControlContext)

      • doPrivileged

        public static <T> T doPrivileged​(PrivilegedExceptionAction<T> action,
                                 AccessControlContext context,
                                 Permission... perms)
                          throws PrivilegedActionException
        执行指定的PrivilegedExceptionAction ，该权限启用并受指定的AccessControlContext限制，特权范围受指定的Permission参数限制。 该操作是由呼叫者的保护域所拥有的权限与由指定的AccessControlContext表示的域所拥有的权限进行AccessControlContext 。

        如果动作的run方法抛出（未检查）异常，它将通过此方法传播。

        如果安装了一个安全管理器，并且系统代码没有创建指定的AccessControlContext ，并且调用者的ProtectionDomain尚未被授予“createAccessControlContext” SecurityPermission ，那么该操作将在没有权限的情况下执行。

        参数类型
        T - PrivilegedExceptionAction的 run方法返回的值的类型。
        参数
        action - 要执行的动作。
        context - 表示在执行指定操作之前应用于调用方域的权限的限制的访问控制上下文 。 如果上下文是null ，则不应用附加限制。
        perms - 限制调用者权限范围的Permission参数。 参数的数量是可变的。
        结果
        该操作返回的值为 run方法。
        异常
        PrivilegedActionException - 如果指定的动作的 run方法抛出一个 被检查的异常
        NullPointerException - 如果动作或perms或任何perms元素是 null
        从以下版本开始：
        1.8
        另请参见：
        doPrivileged(PrivilegedAction) ， doPrivileged(PrivilegedAction,AccessControlContext)

      • doPrivilegedWithCombiner

        public static <T> T doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action,
                                             AccessControlContext context,
                                             Permission... perms)
                                      throws PrivilegedActionException
        执行指定的PrivilegedExceptionAction具有启用并受指定的AccessControlContext限制的特权，特权范围受指定的Permission参数限制。 该操作是由呼叫者的保护域所拥有的权限与由指定的AccessControlContext表示的域所拥有的权限进行AccessControlContext 。

        如果动作的run方法抛出（未检查）异常，它将通过此方法传播。

        该方法在执行操作时保留当前的AccessControlContext的DomainCombiner（可能为null）。

        如果安装了一个安全管理器，并且没有由系统代码创建指定的AccessControlContext ，并且调用者的ProtectionDomain尚未被授予“createAccessControlContext” SecurityPermission ，则该操作将在没有权限的情况下执行。

        参数类型
        T - 由PrivilegedExceptionAction的 run方法返回的值的类型。
        参数
        action - 要执行的动作。
        context - 表示在执行指定操作之前应用于调用方域的权限的限制的访问控制上下文 。 如果上下文为null ，则不再应用其他限制。
        perms - 限制呼叫者权限范围的Permission参数。 参数的数量是可变的。
        结果
        由该操作的 run方法返回的值。
        异常
        PrivilegedActionException - 如果指定的动作的 run方法抛出一个 被检查的异常
        NullPointerException - 如果动作或 NullPointerException或任何 null元素是 null
        从以下版本开始：
        1.8
        另请参见：
        doPrivileged(PrivilegedAction) ， doPrivileged(PrivilegedAction,AccessControlContext) ， DomainCombiner

      • getContext

        public static AccessControlContext getContext​()
        此方法将获取当前调用上下文的“快照”，其中包括当前Thread的继承的AccessControlContext和任何有限权限范围，并将其放置在AccessControlContext对象中。 然后可以在稍后的点可能在另一个线程中检查该上下文。
        结果
        基于当前上下文的AccessControlContext。
        另请参见：
        AccessControlContext

      • checkPermission

        public static void checkPermission​(Permission perm)
                            throws AccessControlException
        根据当前的AccessControlContext和安全策略确定是否允许或拒绝由指定的权限指定的访问请求。 如果允许访问请求，此方法静默返回，否则抛出AccessControlException。 AccessControlException的getPermission方法返回perm权限对象实例。
        参数
        perm - 请求的权限。
        异常
        AccessControlException - 如果不允许指定的权限，则基于当前的安全策略。
        NullPointerException - if the specified permission is null and is checked based on the security policy currently in effect.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AlgorithmConstraints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface AlgorithmConstraints

  • public interface AlgorithmConstraints
    该接口指定加密算法，密钥（密钥大小）和其他算法参数的约束。

    AlgorithmConstraints对象是不可变的。 该接口的实现不应该提供可以在创建实例后更改实例的状态的方法。

    注意， AlgorithmConstraints可以用于表示安全属性jdk.certpath.disabledAlgorithms和jdk.tls.disabledAlgorithms描述的限制，或者可以由具体的PKIXCertPathChecker用于检查认证路径中的指定证书是否包含所需的算法约束。

    从以下版本开始：
    1.7
    另请参见：
    SSLParameters.getAlgorithmConstraints() ， SSLParameters.setAlgorithmConstraints(AlgorithmConstraints)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean permits​(Set<CryptoPrimitive> primitives, String algorithm, AlgorithmParameters parameters)
      确定是否为算法授予了指定的加密原语的权限。
      boolean permits​(Set<CryptoPrimitive> primitives, String algorithm, Key key, AlgorithmParameters parameters)
      确定算法和相应的密钥是否被授予对指定的加密原语的许可。
      boolean permits​(Set<CryptoPrimitive> primitives, Key key)
      确定一个密钥是否被授予了指定的加密原语的权限。

    • 方法详细信息

      • permits

        boolean permits​(Set<CryptoPrimitive> primitives,
                String algorithm,
                AlgorithmParameters parameters)
        确定是否为算法授予了指定的加密原语的权限。
        参数
        primitives - 一组加密原语
        algorithm - 算法名称
        parameters - 算法参数，如果没有附加参数，则为null
        结果
        如果算法被允许并且可以用于所有指定的加密原语，则为真
        异常
        IllegalArgumentException - 如果原语或算法为空或为空

      • permits

        boolean permits​(Set<CryptoPrimitive> primitives,
                Key key)
        确定一个密钥是否被授予了指定的加密原语的权限。

        此方法通常用于检查密钥大小和密钥使用情况。

        参数
        primitives - 一组加密原语
        key - 关键
        结果
        如果密钥可以用于所有指定的加密原语，则为true
        异常
        IllegalArgumentException - 如果原语为空或空，或键为空

      • permits

        boolean permits​(Set<CryptoPrimitive> primitives,
                String algorithm,
                Key key,
                AlgorithmParameters parameters)
        确定算法和相应的密钥是否被授予对指定的加密原语的许可。
        参数
        primitives - 一组加密原语
        algorithm - 算法名称
        key - 关键
        parameters - 算法参数，如果没有附加参数，则为null
        结果
        如果密钥和算法可以用于所有指定的加密原语，则为true
        异常
        IllegalArgumentException - 如果原语或算法为空或为空，或键为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AlgorithmParameterGenerator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class AlgorithmParameterGenerator

  • java.lang.Object
    • java.security.AlgorithmParameterGenerator

  • public class AlgorithmParameterGenerator
extends Object
    AlgorithmParameterGenerator类用于生成一组要用于某种算法的参数。 使用getInstance工厂方法（返回给定类的实例的静态方法）构造参数生成器。

    将生成参数的对象可以通过两种不同的方式进行初始化：以独立于算法的方式，或以特定于算法的方式进行初始化：

    • 与算法无关的方法使用所有参数生成器共享“大小”和随机源的概念。 所有算法参数都可以共享大小的尺寸，尽管对于不同的算法来说，其尺寸是不同的。 例如，在DSA算法的参数的情况下，“大小”对应于素数模量的大小（以比特为单位）。 当使用此方法时，特定于算法的参数生成值（如果有）默认为某些标准值，除非它们可以从指定的大小派生。
    • 另一种方法使用特定于算法的语义来初始化参数生成器对象，该语义由一组特定于算法的参数生成值表示。 为了生成Diffie-Hellman系统参数，例如，参数生成值通常由质数模数的大小和随机指数的大小组成，均以位数指定。

    如果客户端没有显式初始化AlgorithmParameterGenerator（通过调用init方法），则每个提供程序都必须提供（并记录）默认的初始化。 有关JDK提供程序使用的AlgorithmParameterGenerator默认值的信息，请参阅JDK Providers文档的Keysize Restriction部分。 不过，请注意，不同提供商的默认值可能会有所不同。 此外，提供者的默认值可能会在将来的版本中更改。 因此，建议明确地初始化AlgorithmParameterGenerator，而不是依赖于提供者特定的默认值。

    Java平台的每个实现都需要支持以下标准的AlgorithmParameterGenerator算法，并在括号中键入：

    • DiffieHellman （ DiffieHellman ）
    • DSA （ DSA ）
    这些算法在Java安全标准算法名称规范的AlgorithmParameterGenerator section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.2
    另请参见：
    AlgorithmParameters ， AlgorithmParameterSpec

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AlgorithmParameterGenerator​(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
      创建一个AlgorithmParameterGenerator对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AlgorithmParameters generateParameters​()
      生成参数。
      String getAlgorithm​()
      返回此参数生成器关联的算法的标准名称。
      static AlgorithmParameterGenerator getInstance​(String algorithm)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      static AlgorithmParameterGenerator getInstance​(String algorithm, String provider)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      static AlgorithmParameterGenerator getInstance​(String algorithm, Provider provider)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      Provider getProvider​()
      返回此算法参数生成器对象的提供者。
      void init​(int size)
      初始化此参数生成器达一定大小。
      void init​(int size, SecureRandom random)
      初始化此参数生成器以获得一定的大小和随机源。
      void init​(AlgorithmParameterSpec genParamSpec)
      使用一组特定于算法的参数生成值初始化此参数生成器。
      void init​(AlgorithmParameterSpec genParamSpec, SecureRandom random)
      使用一组特定于算法的参数生成值初始化此参数生成器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AlgorithmParameterGenerator

        protected AlgorithmParameterGenerator​(AlgorithmParameterGeneratorSpi paramGenSpi,
                                      Provider provider,
                                      String algorithm)
        创建一个AlgorithmParameterGenerator对象。
        参数
        paramGenSpi - 代表
        provider - 提供商
        algorithm - 算法

    • 方法详细信息

      • getAlgorithm

        public final String getAlgorithm​()
        返回此参数生成器关联的算法的标准名称。
        结果
        算法的字符串名称。

      • getInstance

        public static AlgorithmParameterGenerator getInstance​(String algorithm)
                                               throws NoSuchAlgorithmException
        返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装AlgorithmParameterGeneratorSpi实现的新AlgorithmParameterGenerator对象。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        Implementation Note:
        JDK参考实现还使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 此参数生成器关联的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的AlgorithmParameterGenerator部分。
        结果
        新的 AlgorithmParameterGenerator对象
        异常
        NoSuchAlgorithmException - 如果没有 Provider支持指定算法的 AlgorithmParameterGeneratorSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static AlgorithmParameterGenerator getInstance​(String algorithm,
                                                      String provider)
                                               throws NoSuchAlgorithmException,
                                                      NoSuchProviderException
        返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。

        返回从指定提供程序封装AlgorithmParameterGeneratorSpi实现的新AlgorithmParameterGenerator对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        algorithm - 此参数生成器与之关联的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的AlgorithmParameterGenerator部分。
        provider - 提供程序的字符串名称。
        结果
        新的 AlgorithmParameterGenerator对象
        异常
        IllegalArgumentException - 如果提供商名称为 null或为空
        NoSuchAlgorithmException - 如果指定算法的 AlgorithmParameterGeneratorSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static AlgorithmParameterGenerator getInstance​(String algorithm,
                                                      Provider provider)
                                               throws NoSuchAlgorithmException
        返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。

        返回从指定的Provider对象封装AlgorithmParameterGeneratorSpi实现的新AlgorithmParameterGenerator对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 该参数生成器关联的算法的字符串名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的AlgorithmParameterGenerator部分。
        provider - Provider对象。
        结果
        新的 AlgorithmParameterGenerator对象
        异常
        IllegalArgumentException - 如果指定的提供者是 null
        NoSuchAlgorithmException - 如果指定的算法的 AlgorithmParameterGeneratorSpi实现从指定的 Provider对象不可用
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        1.4
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此算法参数生成器对象的提供者。
        结果
        该算法参数生成器对象的提供者

      • init

        public final void init​(int size)
        初始化此参数生成器达一定大小。 要创建参数，最高优先级的安装提供程序的SecureRandom实现被用作随机的来源。 （如果没有一个已安装的提供商提供SecureRandom的实现，则使用系统提供的随机源。）
        参数
        size - 大小（位数）。

      • init

        public final void init​(int size,
                       SecureRandom random)
        初始化此参数生成器以获得一定的大小和随机源。
        参数
        size - 大小（位数）。
        random - 随机的来源。

      • init

        public final void init​(AlgorithmParameterSpec genParamSpec)
                throws InvalidAlgorithmParameterException
        使用一组特定于算法的参数生成值初始化此参数生成器。 要生成参数，最高优先级的安装提供程序的SecureRandom实现被用作随机的来源。 （如果没有一个已安装的提供商提供了一个SecureRandom的实现，则使用系统提供的随机源。）
        参数
        genParamSpec - 算法特定参数生成值的集合。
        异常
        InvalidAlgorithmParameterException - 如果给定的参数生成值不适合此参数生成器。

      • init

        public final void init​(AlgorithmParameterSpec genParamSpec,
                       SecureRandom random)
                throws InvalidAlgorithmParameterException
        使用一组特定于算法的参数生成值初始化此参数生成器。
        参数
        genParamSpec - 算法特定参数生成值的集合。
        random - 随机性的来源。
        异常
        InvalidAlgorithmParameterException - 如果给定的参数生成值不适合该参数生成器。

      • generateParameters

        public final AlgorithmParameters generateParameters​()
        生成参数。
        结果
        the new AlgorithmParameters object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AlgorithmParameterGeneratorSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class AlgorithmParameterGeneratorSpi

  • java.lang.Object
    • java.security.AlgorithmParameterGeneratorSpi

  • public abstract class AlgorithmParameterGeneratorSpi
extends Object
    该类定义了AlgorithmParameterGenerator类的 （ SPI ），用于生成一组要与特定算法一起使用的参数。

    该类中的所有抽象方法必须由希望提供特定算法的参数生成器的实现的每个加密服务提供者来实现。

    如果客户端没有显式初始化AlgorithmParameterGenerator（通过调用engineInit方法），则每个提供程序都必须提供（并记录）默认的初始化。 有关JDK提供程序使用的AlgorithmParameterGenerator默认值的信息，请参阅JDK Providers文档的Keysize Restriction部分。 不过，请注意，不同提供商的默认值可能会有所不同。 此外，提供者的默认值可能会在将来的版本中更改。 因此，建议明确地初始化AlgorithmParameterGenerator，而不是依赖于提供者特定的默认值。

    从以下版本开始：
    1.2
    另请参见：
    AlgorithmParameterGenerator ， AlgorithmParameters ， AlgorithmParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      AlgorithmParameterGeneratorSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      protected abstract AlgorithmParameters engineGenerateParameters​()
      生成参数。
      protected abstract void engineInit​(int size, SecureRandom random)
      初始化此参数生成器以获得一定的大小和随机源。
      protected abstract void engineInit​(AlgorithmParameterSpec genParamSpec, SecureRandom random)
      使用一组特定于算法的参数生成值初始化此参数生成器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AlgorithmParameterGeneratorSpi

        public AlgorithmParameterGeneratorSpi​()

    • 方法详细信息

      • engineInit

        protected abstract void engineInit​(int size,
                                   SecureRandom random)
        初始化此参数生成器以获得一定的大小和随机源。
        参数
        size - 大小（位数）。
        random - 随机的来源。

      • engineInit

        protected abstract void engineInit​(AlgorithmParameterSpec genParamSpec,
                                   SecureRandom random)
                            throws InvalidAlgorithmParameterException
        使用一组特定于算法的参数生成值初始化此参数生成器。
        参数
        genParamSpec - 算法特定参数生成值的集合。
        random - 随机的来源。
        异常
        InvalidAlgorithmParameterException - 如果给定的参数生成值不适合此参数生成器。

      • engineGenerateParameters

        protected abstract AlgorithmParameters engineGenerateParameters​()
        生成参数。
        结果
        新的AlgorithmParameters对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AlgorithmParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class AlgorithmParameters

  • java.lang.Object
    • java.security.AlgorithmParameters

  • public class AlgorithmParameters
extends Object
    此类用作加密参数的不透明表示。

    可以通过调用getInstance工厂方法（返回给定类的实例的静态方法）来获得用于管理特定算法的参数的AlgorithmParameters对象。

    一旦获得了一个AlgorithmParameters对象，它必须通过使用适当的参数规范或参数编码通过调用init进行初始化。

    通过调用getParameterSpec从AlgorithmParameters对象获得透明参数规范，并通过调用getEncoded获取参数的字节编码。

    Java平台的每个实现都需要支持以下标准的AlgorithmParameters算法：

    • AES
    • DES
    • DESede
    • DiffieHellman
    • DSA
    这些算法在Java安全标准算法名称规范的AlgorithmParameters section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.2
    另请参见：
    AlgorithmParameterSpec ， DSAParameterSpec ， KeyPairGenerator

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AlgorithmParameters​(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
      创建一个AlgorithmParameters对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getAlgorithm​()
      返回与此参数对象关联的算法的名称。
      byte[] getEncoded​()
      返回其主要编码格式的参数。
      byte[] getEncoded​(String format)
      返回在指定方案中编码的参数。
      static AlgorithmParameters getInstance​(String algorithm)
      返回指定算法的参数对象。
      static AlgorithmParameters getInstance​(String algorithm, String provider)
      返回指定算法的参数对象。
      static AlgorithmParameters getInstance​(String algorithm, Provider provider)
      返回指定算法的参数对象。
      <T extends AlgorithmParameterSpec>
      T             		getParameterSpec​(Class<T> paramSpec)
      返回此参数对象的（透明）规范。
      Provider getProvider​()
      返回此参数对象的提供者。
      void init​(byte[] params)
      导入指定的参数，并根据参数的主要解码格式进行解码。
      void init​(byte[] params, String format)
      从 params导入参数，并根据指定的解码方案进行解码。
      void init​(AlgorithmParameterSpec paramSpec)
      使用 paramSpec指定的参数初始化此参数对象。
      String toString​()
      返回描述参数的格式化字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AlgorithmParameters

        protected AlgorithmParameters​(AlgorithmParametersSpi paramSpi,
                              Provider provider,
                              String algorithm)
        创建一个AlgorithmParameters对象。
        参数
        paramSpi - 代表
        provider - 提供商
        algorithm - 算法

    • 方法详细信息

      • getAlgorithm

        public final String getAlgorithm​()
        返回与此参数对象关联的算法的名称。
        结果
        算法名称。

      • getInstance

        public static AlgorithmParameters getInstance​(String algorithm)
                                       throws NoSuchAlgorithmException
        返回指定算法的参数对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装AlgorithmParametersSpi实现的新AlgorithmParameters对象。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        返回的参数对象必须通过调用init进行初始化，使用适当的参数规范或参数编码。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 请求的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的AlgorithmParameters部分。
        结果
        新的参数对象
        异常
        NoSuchAlgorithmException - 如果没有 Provider支持指定算法的 AlgorithmParametersSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static AlgorithmParameters getInstance​(String algorithm,
                                              String provider)
                                       throws NoSuchAlgorithmException,
                                              NoSuchProviderException
        返回指定算法的参数对象。

        返回从指定提供程序封装AlgorithmParametersSpi实现的新AlgorithmParameters对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        返回的参数对象必须通过调用init进行初始化，使用适当的参数规范或参数编码。

        参数
        algorithm - 请求的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的AlgorithmParameters部分。
        provider - 提供商的名称。
        结果
        新的参数对象
        异常
        IllegalArgumentException - 提供者名称是否为 null或为空
        NoSuchAlgorithmException - 如果指定算法的一个 AlgorithmParametersSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static AlgorithmParameters getInstance​(String algorithm,
                                              Provider provider)
                                       throws NoSuchAlgorithmException
        返回指定算法的参数对象。

        返回从指定的Provider对象封装AlgorithmParametersSpi实现的新AlgorithmParameters对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        返回的参数对象必须通过调用init进行初始化，使用适当的参数规范或参数编码。

        参数
        algorithm - 请求的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的AlgorithmParameters部分。
        provider - 提供商的名称。
        结果
        新的参数对象
        异常
        IllegalArgumentException - 如果提供者是 null
        NoSuchAlgorithmException - 如果指定的算法的 AlgorithmParameterGeneratorSpi实现不能从指定的 Provider对象获得
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        1.4
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此参数对象的提供者。
        结果
        该参数对象的提供者

      • init

        public final void init​(AlgorithmParameterSpec paramSpec)
                throws InvalidParameterSpecException
        使用 paramSpec指定的参数初始化此参数对象。
        参数
        paramSpec - 参数规格。
        异常
        InvalidParameterSpecException - 如果给定的参数规范不适用于此参数对象的初始化，或者该参数对象是否已被初始化。

      • init

        public final void init​(byte[] params)
                throws IOException
        导入指定的参数，并根据参数的主要解码格式进行解码。 参数的主要解码格式是ASN.1，如果存在此类参数的ASN.1规范。
        参数
        params - 编码参数。
        异常
        IOException - 解码错误，或者该参数对象是否已被初始化。

      • init

        public final void init​(byte[] params,
                       String format)
                throws IOException
        从params导入参数，并根据指定的解码方案进行解码。 如果format为null，则使用参数的主要解码格式。 主要解码格式为ASN.1，如果存在这些参数的ASN.1规范。
        参数
        params - 编码参数。
        format - 解码方案的名称。
        异常
        IOException - 解码错误，或者该参数对象是否已被初始化。

      • getParameterSpec

        public final <T extends AlgorithmParameterSpec> T getParameterSpec​(Class<T> paramSpec)
                                                            throws InvalidParameterSpecException
        返回此参数对象的（透明）规范。 paramSpec标识应该返回参数的规范类。 例如，它可以是DSAParameterSpec.class ，以表明在DSAParameterSpec类的实例中应该返回参数。
        参数类型
        T - 要重新执行的参数规范的类型
        参数
        paramSpec - 应该返回参数的规范类。
        结果
        参数规格。
        异常
        InvalidParameterSpecException - 如果请求的参数规范不适合此参数对象，或者该参数对象尚未初始化。

      • getEncoded

        public final byte[] getEncoded​()
                        throws IOException
        返回其主要编码格式的参数。 参数的主要编码格式是ASN.1，如果存在此类参数的ASN.1规范。
        结果
        使用其主编码格式编码的参数。
        异常
        IOException - 对编码错误，或者该参数对象尚未初始化。

      • getEncoded

        public final byte[] getEncoded​(String format)
                        throws IOException
        返回在指定方案中编码的参数。 如果format为null，则使用参数的主编码格式。 如果存在这些参数的ASN.1规范，则主编码格式为ASN.1。
        参数
        format - 编码格式的名称。
        结果
        使用指定编码方案编码的参数。
        异常
        IOException - 关于编码错误，或者该参数对象尚未初始化。

      • toString

        public final String toString​()
        返回描述参数的格式化字符串。
        重写：
        toString在 Object
        结果
        描述参数的格式化字符串，如果此参数对象尚未初始化，则为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AlgorithmParametersSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class AlgorithmParametersSpi

  • java.lang.Object
    • java.security.AlgorithmParametersSpi

  • public abstract class AlgorithmParametersSpi
extends Object
    该类定义了AlgorithmParameters类的 （ SPI ），用于管理算法参数。

    该类中的所有抽象方法必须由希望为特定算法提供参数管理的每个加密服务提供商实现。

    从以下版本开始：
    1.2
    另请参见：
    AlgorithmParameters ， AlgorithmParameterSpec ， DSAParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      AlgorithmParametersSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      protected abstract byte[] engineGetEncoded​()
      返回其主要编码格式的参数。
      protected abstract byte[] engineGetEncoded​(String format)
      返回以指定格式编码的参数。
      protected abstract <T extends AlgorithmParameterSpec>
      T             		engineGetParameterSpec​(Class<T> paramSpec)
      返回此参数对象的（透明）规范。
      protected abstract void engineInit​(byte[] params)
      导入指定的参数，并根据参数的主要解码格式进行解码。
      protected abstract void engineInit​(byte[] params, String format)
      从 params导入参数，并根据指定的解码格式进行解码。
      protected abstract void engineInit​(AlgorithmParameterSpec paramSpec)
      使用 paramSpec指定的参数初始化此参数对象。
      protected abstract String engineToString​()
      返回描述参数的格式化字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AlgorithmParametersSpi

        public AlgorithmParametersSpi​()

    • 方法详细信息

      • engineInit

        protected abstract void engineInit​(AlgorithmParameterSpec paramSpec)
                            throws InvalidParameterSpecException
        使用 paramSpec指定的参数初始化此参数对象。
        参数
        paramSpec - 参数说明。
        异常
        InvalidParameterSpecException - 如果给定的参数规范不适用于此参数对象的初始化。

      • engineInit

        protected abstract void engineInit​(byte[] params)
                            throws IOException
        导入指定的参数，并根据参数的主要解码格式进行解码。 参数的主要解码格式是ASN.1，如果存在此类参数的ASN.1规范。
        参数
        params - 编码参数。
        异常
        IOException - 解码错误

      • engineInit

        protected abstract void engineInit​(byte[] params,
                                   String format)
                            throws IOException
        从params导入参数，并根据指定的解码格式进行解码。 如果format为空，则使用参数的主要解码格式。 主要解码格式为ASN.1，如果存在这些参数的ASN.1规范。
        参数
        params - 编码参数。
        format - 解码格式的名称。
        异常
        IOException - 解码错误

      • engineGetParameterSpec

        protected abstract <T extends AlgorithmParameterSpec> T engineGetParameterSpec​(Class<T> paramSpec)
                                                                        throws InvalidParameterSpecException
        返回此参数对象的（透明）规范。 paramSpec标识了应在其中返回参数的规范类。 例如，它可以是DSAParameterSpec.class ，以表明在DSAParameterSpec类的实例中应该返回参数。
        参数类型
        T - 要返回的参数规范的类型
        参数
        paramSpec - 应该返回参数的规范类。
        结果
        参数规格。
        异常
        InvalidParameterSpecException - 如果请求的参数规范不适合此参数对象。

      • engineGetEncoded

        protected abstract byte[] engineGetEncoded​()
                                    throws IOException
        返回其主要编码格式的参数。 参数的主要编码格式是ASN.1，如果存在此类参数的ASN.1规范。
        结果
        使用其主编码格式编码的参数。
        异常
        IOException - 编码错误。

      • engineGetEncoded

        protected abstract byte[] engineGetEncoded​(String format)
                                    throws IOException
        返回以指定格式编码的参数。 如果format为空，则使用参数的主编码格式。 如果存在这些参数的ASN.1规范，则主编码格式为ASN.1。
        参数
        format - 编码格式的名称。
        结果
        使用指定编码方案编码的参数。
        异常
        IOException - 编码错误。

      • engineToString

        protected abstract String engineToString​()
        返回描述参数的格式化字符串。
        结果
        描述参数的格式化字符串。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AllPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class AllPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.AllPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class AllPermission
extends Permission
    AllPermission是一个隐含所有其他权限的权限。

    注意：授予AllPermission应该非常小心，因为它意味着所有其他权限。 因此，它允许代码运行与禁用安全性的能力。 在给予此类许可之前，应特别小心。 只有在测试期间才能使用此权限，或者在非常罕见的情况下，应用程序或小程序完全受信任，并且为策略添加必要的权限是非常麻烦的。

    从以下版本开始：
    1.2
    另请参见：
    Permission ， AccessController ， Permissions ， PermissionCollection ， SecurityManager

    • 构造方法摘要

      构造方法
      Constructor 描述
      AllPermission​()
      创建一个新的AllPermission对象。
      AllPermission​(String name, String actions)
      创建一个新的AllPermission对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查两个AllPermission对象是否相等。
      String getActions​()
      返回动作的规范字符串表示形式。
      int hashCode​()
      返回此对象的哈希码值。
      boolean implies​(Permission p)
      检查指定的权限是否被该对象“隐含”。
      PermissionCollection newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储AllPermission对象。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • AllPermission

        public AllPermission​()
        创建一个新的AllPermission对象。

      • AllPermission

        public AllPermission​(String name,
                     String actions)
        创建一个新的AllPermission对象。 此构造函数存在供Policy对象用于实例化新的权限对象。
        参数
        name - 忽略
        actions - 忽略。

    • 方法详细信息

      • implies

        public boolean implies​(Permission p)
        检查指定的权限是否被该对象“隐含”。 此方法始终返回true。
        Specified by:
        implies在 Permission
        参数
        p - 允许检查。
        结果
        返回

      • equals

        public boolean equals​(Object obj)
        检查两个AllPermission对象是否相等。 两个AllPermission对象总是相等的。
        Specified by:
        equals在 Permission
        参数
        obj - 我们正在测试与该对象相等的对象。
        结果
        如果 obj是AllPermission， obj true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此对象的哈希码值。
        Specified by:
        hashCode在 Permission
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getActions

        public String getActions​()
        返回动作的规范字符串表示形式。
        Specified by:
        getActions在 Permission
        结果
        行动。

      • newPermissionCollection

        public PermissionCollection newPermissionCollection​()
        返回一个新的PermissionCollection对象，用于存储AllPermission对象。
        重写：
        newPermissionCollection在 Permission
        结果
        适用于存储AllPermissions的新PermissionCollection对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AuthProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class AuthProvider

  • java.lang.Object
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<Object,Object>
        • java.util.Properties
          • java.security.Provider
            • java.security.AuthProvider
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Map<Object,Object>

    public abstract class AuthProvider
extends Provider
    此类为提供程序定义登录和注销方法。

    虽然呼叫者可以直接调用login ，但是如果确定在某些操作之前必须执行登录，则提供商也可以代表呼叫者调用login 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.security.Provider

        Provider.Service

    • Field Summary

      • Fields inherited from class java.util.Properties

        defaults

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AuthProvider​(String name, double version, String info)
      已过时。
      改用AuthProvider(String, String, String) 。
      protected AuthProvider​(String name, String versionStr, String info)
      构造具有指定名称，版本字符串和信息的提供程序。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract void login​(Subject subject, CallbackHandler handler)
      登录此提供商。
      abstract void logout​()
      从此提供商注销。
      abstract void setCallbackHandler​(CallbackHandler handler)
      设置一个 CallbackHandler 。

      • Methods inherited from interface java.util.Map

        entry, of, of, of, of, of, of, of, of, of, of, of, ofEntries

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.util.Properties

        clone, contains, containsKey, containsValue, equals, getProperty, hashCode, isEmpty, list, list, load, loadFromXML, propertyNames, rehash, save, setProperty, size, store, store, storeToXML, storeToXML, stringPropertyNames

      • Methods inherited from class java.security.Provider

        clear, compute, computeIfAbsent, computeIfPresent, configure, elements, entrySet, forEach, get, getInfo, getName, getOrDefault, getProperty, getService, getServices, getVersion, getVersionStr, isConfigured, keys, keySet, load, merge, put, putAll, putIfAbsent, putService, remove, remove, removeService, replace, replace, replaceAll, toString, values

    • 构造方法详细信息

      • AuthProvider

        @Deprecated(since="9")
protected AuthProvider​(String name,
                       double version,
                       String info)
        已过时。 改用AuthProvider(String, String, String) 。
        构造具有指定名称，版本号和信息的提供程序。
        参数
        name - 提供商名称。
        version - 提供者版本号。
        info - 提供商及其服务的描述。

      • AuthProvider

        protected AuthProvider​(String name,
                       String versionStr,
                       String info)
        构造具有指定名称，版本字符串和信息的提供程序。
        参数
        name - 提供商名称。
        versionStr - 提供者版本字符串。
        info - 提供商及其服务的描述。
        从以下版本开始：
        9

    • 方法详细信息

      • login

        public abstract void login​(Subject subject,
                           CallbackHandler handler)
                    throws LoginException
        登录此提供商。

        提供商依靠CallbackHandler从呼叫者获取认证信息（例如PIN）。 如果调用者将一个null处理程序传递给此方法，则提供程序将使用setCallbackHandler方法中设置的处理程序。 如果该方法中没有设置任何处理程序，则提供程序将查询默认处理程序实现的完全限定类名的auth.login.defaultCallbackHandler安全属性。 如果未设置安全属性，则假定提供者具有用于获得认证信息的替代方式。

        参数
        subject - 可能包含用于身份验证的主体/凭据的Subject ，或者在成功认证完成后可能会使用其他主体/凭证填充。 该参数可以是null 。
        handler - 该 CallbackHandler使用的 CallbackHandler从呼叫者获取认证信息，可能是 null
        异常
        IllegalStateException - 如果提供商需要配置，并且尚未调用 Provider.configure(java.lang.String)
        LoginException - 如果登录操作失败
        SecurityException - 如果呼叫者没有通过 SecurityPermission("authProvider.name")的安全检查，其中 name是该提供商的 getName方法返回的值

      • logout

        public abstract void logout​()
                     throws LoginException
        从此提供商注销。
        异常
        IllegalStateException - 如果提供商需要配置，并且尚未调用 Provider.configure(java.lang.String)
        LoginException - 如果注销操作失败
        SecurityException - 如果呼叫者没有通过 SecurityPermission("authProvider.name")的安全检查，其中 name是该提供商的 getName方法返回的值

      • setCallbackHandler

        public abstract void setCallbackHandler​(CallbackHandler handler)
        设置一个CallbackHandler 。

        如果没有传递给login方法，则提供程序将使用此处理程序。 提供者也使用这个处理程序，如果它代表呼叫者调用login 。 在任一情况下，如果未通过此方法设置处理程序，则提供程序将查询默认处理程序实现的完全限定类名的auth.login.defaultCallbackHandler安全属性。 如果未设置安全属性，则假定提供者具有用于获得认证信息的替代方式。

        参数
        handler - 用于获得认证信息的 CallbackHandler ，其可以是 null
        异常
        IllegalStateException - 如果提供商需要配置，并且尚未调用 Provider.configure(java.lang.String)
        SecurityException - 如果呼叫者没有通过 SecurityPermission("authProvider.name")的安全检查，其中 name是该提供商的 getName方法返回的值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class BasicPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
  • All Implemented Interfaces:
    Serializable ， Guard
    已知直接子类：
    AttachPermission ， AudioPermission ， AuthPermission ， AWTPermission ， DelegationPermission ， FXPermission ， InquireSecContextPermission ， JAXBPermission ， JDIPermission ， LinkPermission ， LoggingPermission ， ManagementPermission ， MBeanServerPermission ， MBeanTrustPermission ， NetPermission ， NetworkPermission ， PropertyPermission ， ReflectPermission ， RuntimePermission ， SecurityPermission ， SerializablePermission ， SQLPermission ， SSLPermission ， SubjectDelegationPermission ， WebServicePermission

    public abstract class BasicPermission
extends Permission
implements Serializable
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。

    BasicPermission的名称是给定权限的名称（例如“exit”，“setFactory”，“print.queueJob”等））。 命名约定遵循层次化属性命名约定。 星号可以自己出现，或者如果紧接着是“。”。 可能出现在名称的末尾，表示通配符匹配。 例如，“*”和“java。*”表示通配符匹配，而“* java”，“a * b”和“java *”则不表示。

    操作字符串（从Permission继承）未使用。 因此，BasicPermission通常用作“命名”权限的基类（包含名称但不包含操作列表的基类）;如果需要，子类可以在BasicPermission之上实现操作。

    从以下版本开始：
    1.2
    另请参见：
    Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BasicPermission​(String name)
      用指定的名称创建一个新的BasicPermission。
      BasicPermission​(String name, String actions)
      创建一个具有指定名称的新BasicPermission对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查两个BasicPermission对象是否相等。
      String getActions​()
      返回动作的规范字符串表示形式，它当前是空字符串“”，因为BasicPermission没有任何操作。
      int hashCode​()
      返回此对象的哈希码值。
      boolean implies​(Permission p)
      检查指定的权限是否被该对象“隐含”。
      PermissionCollection newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储BasicPermission对象。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • BasicPermission

        public BasicPermission​(String name)
        用指定的名称创建一个新的BasicPermission。 名称是权限的符号名称，如“setFactory”，“print.queueJob”或“topLevelWindow”等。
        参数
        name - name的名称。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。

      • BasicPermission

        public BasicPermission​(String name,
                       String actions)
        创建一个具有指定名称的新BasicPermission对象。 该名称是BasicPermission的符号名称，并且操作String当前未使用。
        参数
        name - name的名称。
        actions - 忽略。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。

    • 方法详细信息

      • implies

        public boolean implies​(Permission p)
        检查指定的权限是否被该对象“隐含”。

        更具体地说，这个方法返回true：

        • p的类和这个对象的类是一样的
        • p的名称等于或（在通配符的情况下）由该对象的名称隐含。 例如，“ab *”表示“abc”。
        Specified by:
        implies在类 Permission
        参数
        p - 允许检查。
        结果
        如果通过的权限等于或暗示此权限，则为true，否则为false。

      • equals

        public boolean equals​(Object obj)
        检查两个BasicPermission对象是否相等。 检查obj的类与该对象的类相同，并具有与该对象相同的名称。
        Specified by:
        equals在 Permission
        参数
        obj - 我们正在测试与此对象相等的对象。
        结果
        如果 obj的类与此对象的类相同，并且与此BasicPermission对象具有相同的名称，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此对象的哈希码值。 使用的哈希代码是名称的哈希码，即getName().hashCode() ，其中getName来自Permission超类。
        Specified by:
        hashCode在 Permission
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getActions

        public String getActions​()
        返回动作的规范字符串表示形式，它当前是空字符串“”，因为BasicPermission没有任何操作。
        Specified by:
        getActions在类 Permission
        结果
        空字符串“”。

      • newPermissionCollection

        public PermissionCollection newPermissionCollection​()
        返回一个新的PermissionCollection对象，用于存储BasicPermission对象。

        BasicPermission对象必须以允许以任何顺序插入的方式进行存储，但这也允许以有效（一致的）方式实现PermissionCollection implies方法。

        重写：
        newPermissionCollection在类 Permission
        结果
        适用于存储BasicPermissions的新PermissionCollection对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Certificate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface Certificate

  • 已过时。
    Java平台中创建了一个新的证书处理包。 此证书界面已完全弃用，并在此允许平滑过渡到新软件包。

    @Deprecated(since="1.2")
public interface Certificate

    这是管理各种身份证书的抽象方法的接口。 身份证明书是公证人的担保，公钥是另一位校长的公钥。 （主体代表一个实体，如个人用户，一个团体或一个公司）。

    特别地，该接口旨在成为具有不同格式但重要常见用途的构造的常见抽象。 例如，不同类型的证书（如X.509证书和PGP证书）共享一般证书功能（需要对证书进行编码和解码）以及某些类型的信息，例如公钥，其密钥的主体，担保人保证公钥是指定的本金。 因此，X.509证书的实现和PGP证书的实现都可以使用证书接口，即使它们的格式和其他类型和数量的信息存储不同。

    重要提示 ：此接口对于共享某些常见用途的对象进行编目和分组很有用。 它没有自己的任何语义。 特别地，证书对象不会对绑定的有效性做任何声明。 执行该接口的应用程序有责任验证证书并确认其有效性。

    从以下版本开始：
    1.1
    另请参见：
    Certificate

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      void decode​(InputStream stream)
      已过时。
      从输入流解码证书。
      void encode​(OutputStream stream)
      已过时。
      将证书编码为可通过 decode方法解码的格式的输出流。
      String getFormat​()
      已过时。
      返回编码格式的名称。
      Principal getGuarantor​()
      已过时。
      返回证书的担保人，即与该证书相关联的公钥与该证书相关联的主体的主体。
      Principal getPrincipal​()
      已过时。
      返回担保人担保的主 - 对对的本金。
      PublicKey getPublicKey​()
      已过时。
      返回担保人保证的主 - 关键对的关键字。
      String toString​(boolean detailed)
      已过时。
      返回一个表示证书内容的字符串。

    • 方法详细信息

      • getGuarantor

        Principal getGuarantor​()
        已过时。
        返回证书的担保人，即与该证书相关联的公钥与该证书相关联的主体的主体。 对于X.509证书，担保人通常将是认证机构（如美国邮政局或Verisign，Inc.）。
        结果
        担保人担保主键绑定。

      • getPrincipal

        Principal getPrincipal​()
        已过时。
        返回担保人担保的主 - 对对的本金。
        结果
        该证书的主体是绑定的。

      • getPublicKey

        PublicKey getPublicKey​()
        已过时。
        返回担保人保证的主 - 关键对的关键字。
        结果
        该证书认证的公钥属于特定的主体。

      • encode

        void encode​(OutputStream stream)
     throws KeyException,
            IOException
        已过时。
        将证书编码为可通过 decode方法解码的格式的输出流。
        参数
        stream - 用于对证书进行编码的输出流。
        异常
        KeyException - 如果证书未正确初始化或数据丢失等
        IOException - 如果在尝试将编码的证书输出到输出流时发生流异常。
        另请参见：
        decode(java.io.InputStream) ， getFormat()

      • decode

        void decode​(InputStream stream)
     throws KeyException,
            IOException
        已过时。
        从输入流解码证书。 格式应该是由归国getFormat和生产encode 。
        参数
        stream - 从中获取要解码的数据的输入流。
        异常
        KeyException - 如果证书未正确初始化或数据丢失等
        IOException - 如果尝试从输入流输入编码的证书时发生异常。
        另请参见：
        encode(java.io.OutputStream) ， getFormat()

      • getFormat

        String getFormat​()
        已过时。
        返回编码格式的名称。 这被用作一个提示来找到一个适当的解析器。 它可以是“X.509”，“PGP”等。这是encode和decode方法制作和理解的格式。
        结果
        编码格式的名称。

      • toString

        String toString​(boolean detailed)
        已过时。
        返回一个表示证书内容的字符串。
        参数
        detailed - 是否提供有关证书的详细信息
        结果
        表示证书内容的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CodeSigner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class CodeSigner

  • java.lang.Object
    • java.security.CodeSigner
  • All Implemented Interfaces:
    Serializable

    public final class CodeSigner
extends Object
implements Serializable
    该类封装了有关代码签名者的信息。 这是不可变的
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CodeSigner​(CertPath signerCertPath, Timestamp timestamp)
      构造一个CodeSigner对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      测试指定对象与此代码签名者之间的相等性。
      CertPath getSignerCertPath​()
      返回签名者的证书路径。
      Timestamp getTimestamp​()
      返回签名时间戳。
      int hashCode​()
      返回此代码签名者的哈希码值。
      String toString​()
      返回描述此代码签名者的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CodeSigner

        public CodeSigner​(CertPath signerCertPath,
                  Timestamp timestamp)
        构造一个CodeSigner对象。
        参数
        signerCertPath - 签名人的证书路径。 它不能是null 。
        timestamp - 签名时间戳。 如果是null则不会为签名生成时间戳。
        异常
        NullPointerException - 如果 signerCertPath是 null 。

    • 方法详细信息

      • getSignerCertPath

        public CertPath getSignerCertPath​()
        返回签名者的证书路径。
        结果
        证书路径。

      • getTimestamp

        public Timestamp getTimestamp​()
        返回签名时间戳。
        结果
        时间戳或 null如果没有）。

      • hashCode

        public int hashCode​()
        返回此代码签名者的哈希码值。 使用签名者的证书路径和时间戳（如果存在）生成哈希码。
        重写：
        hashCode在 Object
        结果
        此代码签名者的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        测试指定对象与此代码签名者之间的相等性。 如果两个签名者签名者的签名路径相等，并且如果它们的时间戳相同，则两个签名者被认为是相等的。
        重写：
        equals在 Object
        参数
        obj - 要测试与此对象相等的对象。
        结果
        如果对象被视为相等，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回描述此代码签名者的字符串。
        重写：
        toString中的 Object
        结果
        包含签名者证书和时间戳的字符串（如果存在）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CodeSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class CodeSource

  • java.lang.Object
    • java.security.CodeSource
  • All Implemented Interfaces:
    Serializable

    public class CodeSource
extends Object
implements Serializable

    该类扩展了代码库的概念，不仅封装了位置（URL），还封装了用于验证源自该位置的签名代码的证书链。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CodeSource​(URL url, Certificate[] certs)
      构造一个CodeSource并将其与指定的位置和证书集合相关联。
      CodeSource​(URL url, CodeSigner[] signers)
      构造CodeSource并将其与指定的位置和代码签名者集合相关联。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      测试指定对象和此对象之间的相等性。
      Certificate[] getCertificates​()
      返回与此CodeSource相关联的证书。
      CodeSigner[] getCodeSigners​()
      返回与此CodeSource相关联的代码签名者。
      URL getLocation​()
      返回与此CodeSource关联的位置。
      int hashCode​()
      返回此对象的哈希码值。
      boolean implies​(CodeSource codesource)
      如果此CodeSource对象“暗示”指定的CodeSource，则返回true。
      String toString​()
      返回描述此CodeSource的字符串，告知其URL和证书。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CodeSource

        public CodeSource​(URL url,
                  Certificate[] certs)
        构造一个CodeSource并将其与指定的位置和证书集合相关联。
        参数
        url - 位置（URL）。 它可能是null 。
        certs - 证书。 它可能是null 。 复制数组的内容以防止后续修改。

      • CodeSource

        public CodeSource​(URL url,
                  CodeSigner[] signers)
        构造CodeSource并将其与指定的位置和代码签名者集合相关联。
        参数
        url - 位置（URL）。 它可能是null 。
        signers - 代码签名者。 它可能是null 。 复制数组的内容以防止后续修改。
        从以下版本开始：
        1.5

    • 方法详细信息

      • hashCode

        public int hashCode​()
        返回此对象的哈希码值。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        测试指定对象和此对象之间的相等性。 如果两个CodeSource对象的位置具有相同的值，并且其签名者证书链的值是相同的，则认为它们是相等的。 不要求证书链的顺序相同。
        重写：
        equals在 Object
        参数
        obj - 要测试与此对象相等的对象。
        结果
        如果对象被视为相等，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • getLocation

        public final URL getLocation​()
        返回与此CodeSource关联的位置。
        结果
        位置（URL），或 null如果在施工期间没有提供URL）。

      • getCertificates

        public final Certificate[] getCertificates​()
        返回与此CodeSource相关联的证书。

        如果此CodeSource对象是使用CodeSource(URL url, CodeSigner[] signers)构造函数创建的，那么它的证书链将被提取并用于创建一个证书对象数组。 每个签名者证书后面都有其支持证书链（可能为空）。 每个签名者证书及其支持证书链从底部到顶部订购（即，首先签名者证书和（根）证书颁发机构的最后）。

        结果
        证书阵列的副本，如果没有， null 。

      • getCodeSigners

        public final CodeSigner[] getCodeSigners​()
        返回与此CodeSource相关联的代码签名者。

        如果此CodeSource对象是使用CodeSource(URL url, java.security.cert.Certificate[] certs)构造函数创建的，那么它的证书链将被提取并用于创建一个CodeSigner对象数组。 请注意，只检查X.509证书 - 所有其他证书类型都将被忽略。

        结果
        代码签名者数组的副本，如果没有， null 。
        从以下版本开始：
        1.5

      • implies

        public boolean implies​(CodeSource codesource)
        如果此CodeSource对象“暗示”指定的CodeSource，则返回true。

        更具体地说，该方法进行以下检查。 如果有任何失败，则返回false。 如果他们都成功，它将返回真实。

        • 代码不能为空。
        • 如果此对象的证书不为空，那么所有这些对象的证书必须都存在于codesource的证书。
        • 如果此对象的位置（的getLocation（））不为空，然后进行以下检查针对此对象的位置和codesource的的制作：
          • codeource的位置不能为空。
          • 如果此对象的位置等于codeource的位置，则返回true。
          • 这个对象的协议（getLocation（）。getProtocol（））必须等于codeource的协议，忽略大小写。
          • 如果此对象的主机（getLocation（）。getHost（））不为空，则使用此对象的主机构建的SocketPermission必须意味着使用codesource主机构建的SocketPermission。
          • 如果此对象的端口（getLocation（）。getPort（））不等于-1（即，如果指定了端口），则它必须等于codeource的端口或默认端口（codesource.getLocation（）。getDefaultPort（） ）。
          • 如果此对象的文件（的getLocation（）的GetFile（））不等于codesource的的文件，然后进行以下检查：如果此对象的文件以‘/ - ’结尾，则codesource的文件必须使用此对象的开始文件（尾随“ - ”）。 如果此对象的文件以“/ *”，则codesource的文件必须使用此对象的文件开始结束，不能再有‘/’分隔符。 如果此对象的文件不以“/”，则codesource结束/‘附加的文件必须此对象的文件以匹配’。
          • 如果这个对象的引用（getLocation（）。getRef（））不为null，它必须等于codeource的引用。

        例如，具有以下位置的代码源对象和空证书都表示代码源位置为“http://java.sun.com/classes/foo.jar”和空证书：

          http:
     http://*.sun.com/classes/*
     http://java.sun.com/classes/-
     http://java.sun.com/classes/foo.jar
        请注意，如果此CodeSource具有空位置和空证书链，则它意味着每个其他CodeSource。
        参数
        codesource - CodeSource进行比较。
        结果
        如果代码源隐含指定的代码源，则为true，否则为false。

      • toString

        public String toString​()
        返回描述此CodeSource的字符串，告知其URL和证书。
        重写：
        toString在 Object
        结果
        有关此CodeSource的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CryptoPrimitive (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.security

Enum CryptoPrimitive

  • java.lang.Object
    • java.lang.Enum<CryptoPrimitive>
      • java.security.CryptoPrimitive
  • All Implemented Interfaces:
    Serializable ， Comparable<CryptoPrimitive>

    public enum CryptoPrimitive
extends Enum<CryptoPrimitive>
    加密原语的枚举。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BLOCK_CIPHER
      对称原语：块密码
      KEY_AGREEMENT
      非对称原语：密钥协商和密钥分发
      KEY_ENCAPSULATION
      不对称原语：密钥封装机制
      KEY_WRAP
      对称原语：键包装
      MAC
      对称原语：消息认证码
      MESSAGE_DIGEST
      散列函数
      PUBLIC_KEY_ENCRYPTION
      不对称原语：公钥加密
      SECURE_RANDOM
      加密随机数发生器
      SIGNATURE
      不对称原语：签名方案
      STREAM_CIPHER
      对称原语：流密码

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static CryptoPrimitive valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CryptoPrimitive[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MESSAGE_DIGEST

        public static final CryptoPrimitive MESSAGE_DIGEST
        散列函数

      • SECURE_RANDOM

        public static final CryptoPrimitive SECURE_RANDOM
        加密随机数发生器

      • BLOCK_CIPHER

        public static final CryptoPrimitive BLOCK_CIPHER
        对称原语：块密码

      • STREAM_CIPHER

        public static final CryptoPrimitive STREAM_CIPHER
        对称原语：流密码

      • MAC

        public static final CryptoPrimitive MAC
        对称原语：消息认证码

      • KEY_WRAP

        public static final CryptoPrimitive KEY_WRAP
        对称原语：键包装

      • PUBLIC_KEY_ENCRYPTION

        public static final CryptoPrimitive PUBLIC_KEY_ENCRYPTION
        不对称原语：公钥加密

      • SIGNATURE

        public static final CryptoPrimitive SIGNATURE
        不对称原语：签名方案

      • KEY_ENCAPSULATION

        public static final CryptoPrimitive KEY_ENCAPSULATION
        不对称原语：密钥封装机制

      • KEY_AGREEMENT

        public static final CryptoPrimitive KEY_AGREEMENT
        非对称原语：密钥协商和密钥分发

    • 方法详细信息

      • values

        public static CryptoPrimitive[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (CryptoPrimitive c : CryptoPrimitive.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static CryptoPrimitive valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


DigestException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class DigestException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.DigestException
  • All Implemented Interfaces:
    Serializable

    public class DigestException
extends GeneralSecurityException
    这是通用的消息摘要异常。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DigestException​()
      构造一个没有详细消息的DigestException。
      DigestException​(String msg)
      构造具有指定详细消息的DigestException。
      DigestException​(String message, Throwable cause)
      创建一个具有指定的详细信息和原因的 DigestException 。
      DigestException​(Throwable cause)
      创建 DigestException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • DigestException

        public DigestException​()
        构造一个没有详细消息的DigestException。 （详细信息是描述此特定异常的字符串。）

      • DigestException

        public DigestException​(String msg)
        构造具有指定详细消息的DigestException。 （详细信息是描述此特定异常的字符串。）
        参数
        msg - 详细信息。

      • DigestException

        public DigestException​(String message,
                       Throwable cause)
        创建一个具有指定的详细信息和原因的 DigestException 。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • DigestException

        public DigestException​(Throwable cause)
        创建 DigestException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （A null允许值，表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DigestInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class DigestInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.security.DigestInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class DigestInputStream
extends FilterInputStream
    透明流，使用通过流的位更新关联的消息摘要。

    要完成消息摘要计算，请在调用此摘要输入流的一个digest方法之后，在相关消息摘要上调用其中一个digest方法。

    可以打开或关闭此流（参见on ）。 当它打开时，对其中一个read方法的调用会导致消息摘要的更新。 但是当它关闭时，消息摘要不会更新。 默认值为流启用。

    请注意，摘要对象只能计算一个摘要（参见MessageDigest ），以便为了计算中间摘要，调用者应该将句柄保留在摘要对象上，并将其克隆到每个要进行计算的摘要，使原始摘要保持不变。

    从以下版本开始：
    1.2
    另请参见：
    MessageDigest ， DigestOutputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected MessageDigest digest
      与此流相关联的消息摘要。

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      构造方法
      Constructor 描述
      DigestInputStream​(InputStream stream, MessageDigest digest)
      使用指定的输入流和消息摘要创建摘要输入流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MessageDigest getMessageDigest​()
      返回与此流相关联的消息摘要。
      void on​(boolean on)
      打开或关闭摘要功能。
      int read​()
      读取一个字节，并更新消息摘要（如果摘要功能打开）。
      int read​(byte[] b, int off, int len)
      读取一个字节数组，并更新消息摘要（如果摘要功能打开）。
      void setMessageDigest​(MessageDigest digest)
      将指定的消息摘要与此流相关联。
      String toString​()
      打印此摘要输入流及其相关消息摘要对象的字符串表示形式。

      • Methods inherited from class java.io.FilterInputStream

        available, close, mark, markSupported, read, reset, skip

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • digest

        protected MessageDigest digest
        与此流相关联的消息摘要。

    • 构造方法详细信息

      • DigestInputStream

        public DigestInputStream​(InputStream stream,
                         MessageDigest digest)
        使用指定的输入流和消息摘要创建摘要输入流。
        参数
        stream - 输入流。
        digest - 要与此流关联的消息摘要。

    • 方法详细信息

      • getMessageDigest

        public MessageDigest getMessageDigest​()
        返回与此流相关联的消息摘要。
        结果
        与此流相关联的消息摘要。
        另请参见：
        setMessageDigest(java.security.MessageDigest)

      • setMessageDigest

        public void setMessageDigest​(MessageDigest digest)
        将指定的消息摘要与此流相关联。
        参数
        digest - 要与此流关联的消息摘要。
        另请参见：
        getMessageDigest()

      • read

        public int read​()
         throws IOException
        读取一个字节，并更新消息摘要（如果摘要功能打开）。 也就是说，该方法从输入流读取一个字节，阻塞直到字节被实际读取。 如果摘要功能打开（见on ），则此方法将调用update与此流相关联的消息摘要，将其读取字节。
        重写：
        read在 FilterInputStream
        结果
        字节读取。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        MessageDigest.update(byte)

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        读取一个字节数组，并更新消息摘要（如果摘要功能打开）。 也就是说，此方法从输入流读取len个字节到阵列b ，从偏移off开始。 该方法阻塞，直到数据被实际读取。 如果摘要功能打开（见on ），则此方法将调用update与此流相关联的消息摘要，传递数据。
        重写：
        read在 FilterInputStream
        参数
        b - 读取数据的数组。
        off - 应该放置数据的起始偏移量为 b 。
        len - 要从输入流读取到b中的最大字节数，从偏移 off开始。
        结果
        实际读取的字节数。 这是小于len如果之前读取已到达流的末尾len字节。 如果没有读取字节，则返回-1，因为在调用时已经到达流的结尾。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        MessageDigest.update(byte[], int, int)

      • on

        public void on​(boolean on)
        打开或关闭摘要功能。 默认值为开。 当它打开时，对其中一个read方法的调用会导致消息摘要的更新。 但是当它关闭时，消息摘要不会更新。
        参数
        on - true打开摘要功能，false将其关闭。

      • toString

        public String toString​()
        打印此摘要输入流及其相关消息摘要对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DigestOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class DigestOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.security.DigestOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class DigestOutputStream
extends FilterOutputStream
    透明流，使用通过流的位更新关联的消息摘要。

    要完成消息摘要计算，则需要调用一个digest方法对相关消息的调用此摘要输出流的一个消化后write种方法。

    可以打开或关闭此流（参见on ）。 当它打开时，对其中一个write方法的调用会导致消息摘要的更新。 但是当它关闭时，消息摘要不会更新。 默认值为流启用。

    从以下版本开始：
    1.2
    另请参见：
    MessageDigest ， DigestInputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected MessageDigest digest
      与此流相关联的消息摘要。

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Constructor 描述
      DigestOutputStream​(OutputStream stream, MessageDigest digest)
      使用指定的输出流和消息摘要创建摘要输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MessageDigest getMessageDigest​()
      返回与此流相关联的消息摘要。
      void on​(boolean on)
      打开或关闭摘要功能。
      void setMessageDigest​(MessageDigest digest)
      将指定的消息摘要与此流相关联。
      String toString​()
      打印此摘要输出流及其相关消息摘要对象的字符串表示形式。
      void write​(byte[] b, int off, int len)
      使用指定的子阵列更新消息摘要（如果摘要功能打开），并且无论如何将子阵列写入输出流。
      void write​(int b)
      使用指定的字节更新消息摘要（如果摘要功能打开），并且无论如何将该字节写入输出流。

      • Methods inherited from class java.io.FilterOutputStream

        close, flush, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • digest

        protected MessageDigest digest
        与此流相关联的消息摘要。

    • 构造方法详细信息

      • DigestOutputStream

        public DigestOutputStream​(OutputStream stream,
                          MessageDigest digest)
        使用指定的输出流和消息摘要创建摘要输出流。
        参数
        stream - 输出流。
        digest - 要与此流关联的消息摘要。

    • 方法详细信息

      • getMessageDigest

        public MessageDigest getMessageDigest​()
        返回与此流相关联的消息摘要。
        结果
        与此流相关联的消息摘要。
        另请参见：
        setMessageDigest(java.security.MessageDigest)

      • setMessageDigest

        public void setMessageDigest​(MessageDigest digest)
        将指定的消息摘要与此流相关联。
        参数
        digest - 要与此流关联的消息摘要。
        另请参见：
        getMessageDigest()

      • write

        public void write​(int b)
           throws IOException
        使用指定的字节更新消息摘要（如果摘要功能打开），并且无论如何将该字节写入输出流。 也就是说，如果摘要功能打开（见on ），则该方法调用update与该流相关联的消息摘要，传递字节b 。 该方法然后将字节写入输出流，阻塞直到字节实际写入。
        重写：
        write在 FilterOutputStream
        参数
        b - 要用于更新和写入输出流的字节。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        MessageDigest.update(byte)

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        使用指定的子阵列更新消息摘要（如果摘要功能打开），并且无论如何将子阵列写入输出流。 也就是说，如果摘要功能打开（见on ），此方法将调用update与此流相关联的消息摘要，传递其子阵列规范。 然后，该方法将子阵列字节写入输出流，阻塞直到字节实际写入。
        重写：
        write在 FilterOutputStream
        参数
        b - 包含用于更新和写入输出流的子阵列的数组。
        off - 要更新和写入的第一个字节的偏移量为 b 。
        len - 要从 b更新和写入的数据的字节数，从偏移 off开始。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        MessageDigest.update(byte[], int, int)

      • on

        public void on​(boolean on)
        打开或关闭摘要功能。 默认值为开。 当它打开时，对其中一个write方法的调用会导致消息摘要的更新。 但是当它关闭时，消息摘要不会更新。
        参数
        on - true打开摘要功能，false将其关闭。

      • toString

        public String toString​()
        打印此摘要输出流及其相关消息摘要对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DomainCombiner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface DomainCombiner

  • 所有已知实现类：
    SubjectDomainCombiner

    public interface DomainCombiner
    A DomainCombiner提供了一种手段来动态更新与当前AccessControlContext相关联的ProtectionDomains。

    A DomainCombiner作为参数传递给适用于AccessControlContext构造AccessControlContext 。 然后将新构建的上下文传递给AccessController.doPrivileged(..., context)方法以将提供的上下文（和关联的DomainCombiner ）与当前执行线程进行绑定。 随后致电AccessController.getContext或AccessController.checkPermission导致DomainCombiner.combine被调用。

    组合方法有两个参数。 第一个参数表示当前执行Thread中ProtectionDomains的数组，因为最近调用了AccessController.doPrivileged 。 如果没有调用doPrivileged，那么第一个参数将包含当前执行线程中的所有ProtectionDomains。 第二个参数表示一个继承的ProtectionDomains数组，可以是null 。 ProtectionDomains可以从父线程或从特权上下文继承。 如果没有调用doPrivileged，那么第二个参数将包含从父线程继承的ProtectionDomains。 如果对doPrivileged进行了一个或多个调用，并且最近的调用是doPrivileged（action，context），则第二个参数将包含来自特权上下文的ProtectionDomains。 如果最近的电话是doPrivileged（action），那么没有特权上下文，第二个参数将是null 。

    combine方法调查ProtectionDomains的两个输入数组，并返回包含更新的ProtectionDomains的单个数组。 在最简单的情况下， combine方法将两个堆栈合并为一个。 在更复杂的情况下， combine方法返回一个修改的ProtectionDomains堆栈。 修改可能已添加新的ProtectionDomains，删除某些ProtectionDomains，或者只是更新现有的ProtectionDomains。 还允许对ProtectionDomains进行重新排序和其他优化。 通常， combine方法将其更新封装在DomainCombiner的信息上。

    在AccessController.getContext方法从AccessController.getContext收到ProtectionDomains的组合堆栈DomainCombiner ，它返回一个新的AccessControlContext，它们具有组合的ProtectionDomain以及DomainCombiner 。

    从以下版本开始：
    1.3
    另请参见：
    AccessController ， AccessControlContext

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ProtectionDomain[] combine​(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
      修改或更新提供的ProtectionDomains。

    • 方法详细信息

      • combine

        ProtectionDomain[] combine​(ProtectionDomain[] currentDomains,
                           ProtectionDomain[] assignedDomains)
        修改或更新提供的ProtectionDomains。 ProtectionDomains可能会被添加到给定的ProtectionDomains或从其中删除。 ProtectionDomains可能会重新排序。 可以修改个人ProtectionDomains（例如，使用一组新的权限）。
        参数
        currentDomains - 与当前执行线程相关联的ProtectionDomains，最高权限为ProtectionDomain 。 ProtectionDomains按执行顺序列出，最近执行的ProtectionDomain驻留在阵列的开头。 如果当前执行的线程没有关联的ProtectionDomains，则此参数可能为null 。
        assignedDomains - 一个继承的ProtectionDomains数组。 ProtectionDomains可以从父线程继承，或从特权AccessControlContext 。 如果没有继承的ProtectionDomains，此参数可能为null 。
        结果
        由更新的ProtectionDomains组成的新阵列，或 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DomainLoadStoreParameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class DomainLoadStoreParameter

  • java.lang.Object
    • java.security.DomainLoadStoreParameter
  • All Implemented Interfaces:
    KeyStore.LoadStoreParameter

    public final class DomainLoadStoreParameter
extends Object
implements KeyStore.LoadStoreParameter
    指定密钥库中密钥库的配置数据。 密钥库域是作为单个逻辑密钥库呈现的密钥库的集合。 配置数据用于KeyStore load和store操作。

    配置数据支持以下语法：

       domain <domainName> [<property> ...] { keystore <keystoreName> [<property> ...] ; ... }; ...
    其中domainName和keystoreName是标识符，而property是密钥/值配对。 键和值由“equals”符号分隔，该值用双引号括起来。 属性值可以是可打印字符串或十六进制数字的冒号分隔对的二进制字符串。 多值属性用逗号分隔的值表示，用方括号括起来。 见Arrays.toString(java.lang.Object[]) 。

    为了确保密钥库条目被唯一标识，每个条目的别名是由它的前缀keystoreName其次条目名称隔膜与各keystoreName必须在其领域内是唯一的。 存储密钥库时，省略条目名前缀。

    属性是上下文相关的：适用于域中所有密钥库的属性位于域子句中，仅适用于特定密钥库的属性位于该密钥库子句中。 除非另有说明，否则密钥库子句中的属性将覆盖域子句中相同名称的属性。 所有属性名都不区分大小写。 支持以下属性：

    keystoreType="<type>"
    密钥库类型。
    keystoreURI="<url>"
    密钥库位置。
    keystoreProviderName="<name>"
    密钥库的JCE提供程序的名称。
    keystorePasswordEnv="<environment-variable>"
    存储密钥库密码的环境变量。 或者，密码可以在Map<String, ProtectionParameter>提供给构造方法。
    entryNameSeparator="<separator>"
    密钥库名称前缀和条目名称之间的分隔符。 指定时，它适用于域中的所有条目。 它的默认值是一个空格。

    例如，包含三个密钥库的简单密钥库域的配置数据如下所示：

      domain app1 {
     keystore app1-truststore
         keystoreURI="file:///app1/etc/truststore.jks";

     keystore system-truststore
         keystoreURI="${java.home}/lib/security/cacerts";

     keystore app1-keystore
         keystoreType="PKCS12"
         keystoreURI="file:///app1/etc/keystore.p12";
 };
    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      DomainLoadStoreParameter​(URI configuration, Map<String,KeyStore.ProtectionParameter> protectionParams)
      使用用于保护密钥库数据的参数构建密钥库域的DomainLoadStoreParameter。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      URI getConfiguration​()
      获取域配置数据的标识符。
      KeyStore.ProtectionParameter getProtectionParameter​()
      获取此域的密钥库保护参数。
      Map<String,KeyStore.ProtectionParameter> getProtectionParams​()
      获取此域中密钥库的密钥库保护参数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DomainLoadStoreParameter

        public DomainLoadStoreParameter​(URI configuration,
                                Map<String,KeyStore.ProtectionParameter> protectionParams)
        使用用于保护密钥库数据的参数构建密钥库域的DomainLoadStoreParameter。
        参数
        configuration - 域配置数据的标识符。 当需要在同一位置区分多个域配置时，应在java.net.URI片段组件中指定目标域的名称。
        protectionParams - 从密钥库名称到用于保护密钥库数据的参数的映射。 当不需要保护参数或通过域配置数据中的属性指定保护参数时，应使用A java.util.Collections.EMPTY_MAP 。 克隆以防止后续修改。
        异常
        NullPointerException - 如果 configuration或 protectionParams是 null

    • 方法详细信息

      • getConfiguration

        public URI getConfiguration​()
        获取域配置数据的标识符。
        结果
        配置数据的标识符

      • getProtectionParams

        public Map<String,KeyStore.ProtectionParameter> getProtectionParams​()
        获取此域中密钥库的密钥库保护参数。
        结果
        一个不可修改的密钥库名称映射到保护参数

      • getProtectionParameter

        public KeyStore.ProtectionParameter getProtectionParameter​()
        获取此域的密钥库保护参数。 密钥库域不支持保护参数。
        Specified by:
        getProtectionParameter在接口 KeyStore.LoadStoreParameter
        结果
        总是返回 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DrbgParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class DrbgParameters

  • java.lang.Object
    • java.security.DrbgParameters

  • public class DrbgParameters
extends Object
    该类指定DRBG（确定性随机位发生器）使用的参数。

    根据NIST Special Publication 800-90A Revision 1, Recommendation for Random Number Generation Using Deterministic Random Bit Generators （800-90Ar1），

    A DRBG is based on a DRBG mechanism as specified in this Recommendation and includes a source of randomness. A DRBG mechanism uses an algorithm (i.e., a DRBG algorithm) that produces a sequence of bits from an initial value that is determined by a seed that is determined from the output of the randomness source."

    800-90Ar1规范允许各种DRBG实现选择，如：

    • 熵源，
    • DRBG机制（例如，Hash_DRBG），
    • 一个DRBG算法（例如，用于Hash_DRBG的SHA-256和CTR_DRBG的AES-256。请注意，这不是SecureRandom.getInstance(java.lang.String)中使用的算法，下面我们称之为SecureRandom算法 ）
    • 可选功能，包括预测电阻和再接种支持，
    • 最高的安全实力。

    这些选择是在每个实现中设置的，不是由SecureRandom API直接管理。 检查您的DRBG提供商的文档，以找到适合的情况实现。

    另一方面，800-90Ar1规范确实有一些可配置的选项，如：

    • 要求安全实力，
    • 如果需要预测电阻，
    • 个性化字符串和附加输入。

    可以使用DrbgParameters.Instantiation对象和其他信息（例如，不由此API管理的随机数）的参数来实例化DRBG实例。 这映射到Instantiate_function在NIST SP 800-90Ar1定义。

    可以使用DrbgParameters.Reseed对象的参数重新设置DRBG实例。 这映射到Reseed_function在NIST SP 800-90Ar1定义。 主叫SecureRandom.reseed()等效于调用SecureRandom.reseed(SecureRandomParameters)与有效实例化的预测性标记（如通过返回SecureRandom.getParameters() ），没有附加的输入。

    DRBG实例使用DrbgParameters.NextBytes对象的附加参数生成数据。 这映射到Generate_function在NIST SP 800-90Ar1定义。 主叫SecureRandom.nextBytes(byte[])等效于调用SecureRandom.nextBytes(byte[], SecureRandomParameters)与有效实例化的强度和预测性标志（如通过返回SecureRandom.getParameters() ），没有附加的输入。

    DRBG应作为SecureRandomSpi的子类实现 。 建议实现包含一个DrbgParameters.Instantiation参数的1-arg constructor 。 如果这样实现，这个实现可以通过任何SecureRandom.getInstance()方法来选择。 如果由具有SecureRandomParameters参数的SecureRandom.getInstance()选择，则将该参数传递到此构造函数中。 如果由SecureRandom.getInstance()选择了SecureRandomParameters参数，则构造函数将使用一个null参数调用，并且实现应选择其自己的参数。 其SecureRandom.getParameters()必须始终返回一个非空有效的DrbgParameters.Instantiation对象，反映DRBG实际上如何实例化。 呼叫者可以使用此信息来确定SecureRandom对象是否是DRBG，以及它支持哪些功能。 请注意，返回的值不一定等于传递到SecureRandom.getInstance()调用的DrbgParameters.Instantiation对象。 例如，所请求的能力可以是DrbgParameters.Capability.NONE，但是如果实现支持重新加载，则有效值可以是DrbgParameters.Capability.RESEED_ONLY 。 实施必须实现DrbgParameters.NextBytes参数的SecureRandomSpi.engineNextBytes(byte[], SecureRandomParameters)方法。 除非结果SecureRandom.getParameters()有其capability为NONE ，它必须实现SecureRandomSpi.engineReseed(SecureRandomParameters) ，这需要DrbgParameters.Reseed参数。

    另一方面，如果DRBG实现不包含具有DrbgParameters.Instantiation参数（不推荐）的DrbgParameters.Instantiation函数，则只能由SecureRandom.getInstance()选择而不具有SecureRandomParameters参数，但如果具有SecureRandomParameters参数的getInstance方法，则不会选择该参数叫做。 如果这样实现，其SecureRandom.getParameters()必须返回null ，不需要实现SecureRandomSpi.engineNextBytes(byte[], SecureRandomParameters)或SecureRandomSpi.engineReseed(SecureRandomParameters) 。

    如果种子期大于由DRBG机制定义的最大种子寿命，DRBG可能会自动重新植入。

    DRBG实现应通过保留配置和有效参数来支持序列化和反序列化，但内部状态不能被序列化，反序列化对象必须重新启动。

    例子：

     SecureRandom drbg;
 byte[] buffer = new byte[32];

 // Any DRBG is OK
 drbg = SecureRandom.getInstance("DRBG");
 drbg.nextBytes(buffer);

 SecureRandomParameters params = drbg.getParameters();
 if (params instanceof DrbgParameters.Instantiation) {
     DrbgParameters.Instantiation ins = (DrbgParameters.Instantiation) params;
     if (ins.getCapability().supportsReseeding()) {
         drbg.reseed();
     }
 }

 // The following call requests a weak DRBG instance. It is only
 // guaranteed to support 112 bits of security strength.
 drbg = SecureRandom.getInstance("DRBG",
         DrbgParameters.instantiation(112, NONE, null));

 // Both the next two calls will likely fail, because drbg could be
 // instantiated with a smaller strength with no prediction resistance
 // support.
 drbg.nextBytes(buffer,
         DrbgParameters.nextBytes(256, false, "more".getBytes()));
 drbg.nextBytes(buffer,
         DrbgParameters.nextBytes(112, true, "more".getBytes()));

 // The following call requests a strong DRBG instance, with a
 // personalization string. If it successfully returns an instance,
 // that instance is guaranteed to support 256 bits of security strength
 // with prediction resistance available.
 drbg = SecureRandom.getInstance("DRBG", DrbgParameters.instantiation(
         256, PR_AND_RESEED, "hello".getBytes()));

 // Prediction resistance is not requested in this single call,
 // but an additional input is used.
 drbg.nextBytes(buffer,
         DrbgParameters.nextBytes(-1, false, "more".getBytes()));

 // Same for this call.
 drbg.reseed(DrbgParameters.reseed(false, "extra".getBytes()));
    实现要求：
    按照惯例，提供商应使用 standard SecureRandom algorithm name “DRBG”命名其主要DRBG实现。
    Implementation Note:
    以下注释适用于JDK参考实现的SUN提供程序中的“DRBG”实现。

    该实现支持具有DRBG算法SHA-224，SHA-512/224，SHA-256，SHA-512/256，SHA-384和SHA-512的Hash_DRBG和HMAC_DRBG机制以及CTR_DRBG（均使用推导函数而不使用派生功能）与DRBG算法AES-128，AES-192和AES-256。

    机制名称和DRBG算法名称由security property securerandom.drbg.config确定。 默认选项是具有SHA-256的Hash_DRBG。

    对于每个组合，可以从112请求到其支持的最高强度的安全强度。 支持反馈和预测电阻。

    通过DrbgParameters.Instantiation类支持个性化字符串，通过DrbgParameters.NextBytes和DrbgParameters.Reseed类支持额外的输入。

    如果DRBG未被明确地用DrbgParameters.Instantiation对象实例化，则该实现将以128位的默认请求强度，无预测阻力请求，无个性化字符串实例化。 这些默认实例化参数也可以使用securerandom.drbg.config安全属性进行自定义。

    该实现从由安全属性securerandom.source确定的系统默认熵源读取新鲜熵。

    调用SecureRandom.generateSeed(int)将直接从该系统读取默认熵源。

    此实施已通过20151104版本的The DRBG Test Vectors中包含的所有测试。

    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  DrbgParameters.Capability
      DRBG的可重新预测和预测抵抗能力。
      static class  DrbgParameters.Instantiation
      用于实例化的DRBG参数。
      static class  DrbgParameters.NextBytes
      用于随机位生成的DRBG参数。
      static class  DrbgParameters.Reseed
      重新植入的DRBG参数。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static DrbgParameters.Instantiation instantiation​(int strength, DrbgParameters.Capability capability, byte[] personalizationString)
      生成一个DrbgParameters.Instantiation对象。
      static DrbgParameters.NextBytes nextBytes​(int strength, boolean predictionResistance, byte[] additionalInput)
      生成一个DrbgParameters.NextBytes对象。
      static DrbgParameters.Reseed reseed​(boolean predictionResistance, byte[] additionalInput)
      生成一个DrbgParameters.Reseed对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • instantiation

        public static DrbgParameters.Instantiation instantiation​(int strength,
                                                         DrbgParameters.Capability capability,
                                                         byte[] personalizationString)
        生成一个DrbgParameters.Instantiation对象。
        参数
        strength - 安全强度（以位为单位），-1表示默认强度，如果在 getInstance 。
        capability - 能力
        personalizationString - 个性化字符串作为字节数组，可以是null 。 该字节数组的内容将被复制。
        结果
        一个新的 Instantiation对象
        异常
        NullPointerException - 如果 capability是 null
        IllegalArgumentException - 如果 strength小于-1

      • nextBytes

        public static DrbgParameters.NextBytes nextBytes​(int strength,
                                                 boolean predictionResistance,
                                                 byte[] additionalInput)
        生成一个DrbgParameters.NextBytes对象。
        参数
        strength - 请求安全强度。 如果设置为-1，则将使用有效强度。
        predictionResistance - 要求预测电阻
        additionalInput - 附加输入，可以是null 。 该字节数组的内容将被复制。
        结果
        一个新的 NextBytes对象
        异常
        IllegalArgumentException - 如果 strength小于-1

      • reseed

        public static DrbgParameters.Reseed reseed​(boolean predictionResistance,
                                           byte[] additionalInput)
        生成一个DrbgParameters.Reseed对象。
        参数
        predictionResistance - 要求预测电阻
        additionalInput - 附加输入，可以是null 。 该字节数组的内容将被复制。
        结果
        一个新的 Reseed对象
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DrbgParameters.Capability (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.security

Enum DrbgParameters.Capability

  • java.lang.Object
    • java.lang.Enum<DrbgParameters.Capability>
      • java.security.DrbgParameters.Capability
  • All Implemented Interfaces:
    Serializable ， Comparable<DrbgParameters.Capability>
    Enclosing class:
    DrbgParameters

    public static enum DrbgParameters.Capability
extends Enum<DrbgParameters.Capability>
    DRBG的可重新预测和预测抵抗能力。

    当该对象传递到SecureRandom.getInstance()调用时，它是所请求的最小功能。 当从SecureRandom.getParameters()返回时，这是有效的功能。

    请注意，虽然NIST SP Instantiate_function定义的Instantiate_function仅包含prediction_resistance_flag参数，但Capability类型包含额外值RESEED_ONLY，因为重新进给是可选功能。 如果NONE在Instantiation对象中用于调用SecureRandom.getInstance方法，则返回的DRBG实例不能保证支持重新进入。 如果使用RESEED_ONLY或PR_AND_RESEED ，则该实例必须支持重新进入。

    下表列出了如果要求某种能力的可能的有效值，即

     Capability requested = ...;
 SecureRandom s = SecureRandom.getInstance("DRBG",
         DrbgParameters(-1, requested, null));
 Capability effective = ((DrbgParametes.Initiate) s.getParameters())
         .getCapability();
    requested and effective capabilities Requested Value Possible Effective Values NONE NONE, RESEED_ONLY, PR_AND_RESEED RESEED_ONLY RESEED_ONLY, PR_AND_RESEED PR_AND_RESEED PR_AND_RESEED

    支持预测抵抗的DRBG实施也必须支持重新种植。

    从以下版本开始：
    9

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NONE
      既不预测抵抗也不抵消。
      PR_AND_RESEED
      预测抵抗和重新种植。
      RESEED_ONLY
      重新设计，但没有预测阻力。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean supportsPredictionResistance​()
      返回此功能是否支持预测阻力。
      boolean supportsReseeding​()
      返回此功能是否支持重新加载。
      String toString​()
      返回声明中包含的此枚举常量的名称。
      static DrbgParameters.Capability valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DrbgParameters.Capability[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PR_AND_RESEED

        public static final DrbgParameters.Capability PR_AND_RESEED
        预测抵抗和重新种植。

      • RESEED_ONLY

        public static final DrbgParameters.Capability RESEED_ONLY
        重新设计，但没有预测阻力。

      • NONE

        public static final DrbgParameters.Capability NONE
        既不预测抵抗也不抵消。

    • 方法详细信息

      • values

        public static DrbgParameters.Capability[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (DrbgParameters.Capability c : DrbgParameters.Capability.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static DrbgParameters.Capability valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • toString

        public String toString​()
        说明从类别复制： Enum
        返回声明中包含的此枚举常量的名称。 该方法可以被覆盖，尽管它通常不是必需或不可取的。 当一个更“程序员友好”的字符串形式存在时，枚举类型应该覆盖此方法。
        重写：
        toString在 Enum<DrbgParameters.Capability>
        结果
        这个枚举常数的名称

      • supportsReseeding

        public boolean supportsReseeding​()
        返回此功能是否支持重新加载。
        结果
        true为 PR_AND_RESEED和 RESEED_ONLY和 false为 NONE

      • supportsPredictionResistance

        public boolean supportsPredictionResistance​()
        返回此功能是否支持预测阻力。
        结果
        true为 PR_AND_RESEED和 false为 RESEED_ONLY和 NONE
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


DrbgParameters.Instantiation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class DrbgParameters.Instantiation

  • java.lang.Object
    • java.security.DrbgParameters.Instantiation
  • All Implemented Interfaces:
    SecureRandomParameters
    Enclosing class:
    DrbgParameters

    public static final class DrbgParameters.Instantiation
extends Object
implements SecureRandomParameters
    用于实例化的DRBG参数。

    当用于SecureRandom.getInstance(String, SecureRandomParameters)或其他类似的getInstance调用中的一个采用SecureRandomParameters参数时，表示新创建的SecureRandom对象必须最小化支持的请求实例参数。 当用作SecureRandom.getParameters()方法的返回值时，表示SecureRandom对象的有效实例参数。

    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DrbgParameters.Capability getCapability​()
      返回能力。
      byte[] getPersonalizationString​()
      返回个性化字符串作为字节数组。
      int getStrength​()
      以比特返回安全强度。
      String toString​()
      返回此 Instantiation的人类可读字符串表示 Instantiation 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getStrength

        public int getStrength​()
        以比特返回安全强度。
        结果
        如果在getInstance ，则返回所请求的最小强度，如果没有强度的特定请求，则返回-1。 如果在getParameters ，返回有效强度。 有效强度必须大于或等于所要求的最小强度。

      • getCapability

        public DrbgParameters.Capability getCapability​()
        返回能力。
        结果
        如果在getInstance ，则返回所需的最小能力。 如果在getParameters ，则返回有关有效预测阻力标志的信息以及是否支持重新进给。

      • getPersonalizationString

        public byte[] getPersonalizationString​()
        返回个性化字符串作为字节数组。
        结果
        如果在getInstance使用， getInstance所请求的个性化字符串作为新分配的数组返回，如果未请求个性化字符串，则返回null 。 相同的字符串应该返回getParameters作为一个新的副本，或者null如果没有个性化的字符串在请求getInstance 。

      • toString

        public String toString​()
        返回此 Instantiation的人类可读字符串表示 Instantiation 。
        重写：
        toString在类 Object
        结果
        字符串表示
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DrbgParameters.NextBytes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class DrbgParameters.NextBytes

  • java.lang.Object
    • java.security.DrbgParameters.NextBytes
  • All Implemented Interfaces:
    SecureRandomParameters
    Enclosing class:
    DrbgParameters

    public static final class DrbgParameters.NextBytes
extends Object
implements SecureRandomParameters
    用于随机位生成的DRBG参数。 它用于SecureRandom.nextBytes(byte[], SecureRandomParameters) 。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getAdditionalInput​()
      返回请求的附加输入。
      boolean getPredictionResistance​()
      返回是否请求预测电阻。
      int getStrength​()
      返回以位为单位的安全强度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getStrength

        public int getStrength​()
        返回以位为单位的安全强度。
        结果
        要求强度，如果有效强度应该使用-1。

      • getPredictionResistance

        public boolean getPredictionResistance​()
        返回是否请求预测电阻。
        结果
        是否要求预测电阻

      • getAdditionalInput

        public byte[] getAdditionalInput​()
        返回请求的附加输入。
        结果
        the requested additional input, null if not requested. A new byte array is returned each time this method is called.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DrbgParameters.Reseed (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class DrbgParameters.Reseed

  • java.lang.Object
    • java.security.DrbgParameters.Reseed
  • All Implemented Interfaces:
    SecureRandomParameters
    Enclosing class:
    DrbgParameters

    public static final class DrbgParameters.Reseed
extends Object
implements SecureRandomParameters
    重新植入的DRBG参数。 它用于SecureRandom.reseed(SecureRandomParameters) 。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getAdditionalInput​()
      返回请求的附加输入。
      boolean getPredictionResistance​()
      返回是否请求预测电阻。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getPredictionResistance

        public boolean getPredictionResistance​()
        返回是否请求预测电阻。
        结果
        是否要求预测电阻

      • getAdditionalInput

        public byte[] getAdditionalInput​()
        返回请求的附加输入。
        结果
        请求的附加输入，如果没有请求， null 。 每次调用此方法时都会返回一个新的字节数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GeneralSecurityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class GeneralSecurityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    BadPaddingException ， CertificateException ， CertPathBuilderException ， CertPathValidatorException ， CertStoreException ， CRLException ， DigestException ， ExemptionMechanismException ， IllegalBlockSizeException ， InvalidAlgorithmParameterException ， InvalidKeySpecException ， InvalidParameterSpecException ， KeyException ， KeyStoreException ， LoginException ， NoSuchAlgorithmException ， NoSuchPaddingException ， NoSuchProviderException ， ShortBufferException ， SignatureException ， UnrecoverableEntryException

    public class GeneralSecurityException
extends 异常
    GeneralSecurityException类是一种通用安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      GeneralSecurityException​()
      构造一个没有详细消息的GeneralSecurityException。
      GeneralSecurityException​(String msg)
      构造具有指定详细消息的GeneralSecurityException。
      GeneralSecurityException​(String message, Throwable cause)
      创建一个 GeneralSecurityException与指定的详细信息和原因。
      GeneralSecurityException​(Throwable cause)
      创建 GeneralSecurityException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • GeneralSecurityException

        public GeneralSecurityException​()
        构造一个没有详细消息的GeneralSecurityException。

      • GeneralSecurityException

        public GeneralSecurityException​(String msg)
        构造具有指定详细消息的GeneralSecurityException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。

      • GeneralSecurityException

        public GeneralSecurityException​(String message,
                                Throwable cause)
        创建一个 GeneralSecurityException与指定的详细信息和原因。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法后续检索）。 （允许A null值，表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • GeneralSecurityException

        public GeneralSecurityException​(Throwable cause)
        创建 GeneralSecurityException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （A null允许值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Guard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface Guard

  • 所有已知实现类：
    AllPermission ， AttachPermission ， AudioPermission ， AuthPermission ， AWTPermission ， BasicPermission ， CardPermission ， DelegationPermission ， FilePermission ， FXPermission ， InquireSecContextPermission ， JAXBPermission ， JDIPermission ， LinkPermission ， LoggingPermission ， ManagementPermission ， MBeanPermission ， MBeanServerPermission ， MBeanTrustPermission ， NetPermission ， NetworkPermission ， Permission ， PrivateCredentialPermission ， PropertyPermission ， ReflectPermission ， RuntimePermission ， SecurityPermission ， SerializablePermission ， ServicePermission ， SocketPermission ， SQLPermission ， SSLPermission ， SubjectDelegationPermission ， UnresolvedPermission ， URLPermission ， WebServicePermission

    public interface Guard

    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。

    此接口包含一个单一的方法， checkGuard ，带有一个object参数。 checkGuard被调用（由GuardedObject getObject方法）来确定是否允许访问该对象。

    从以下版本开始：
    1.2
    另请参见：
    GuardedObject

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void checkGuard​(Object object)
      确定是否允许访问被保护对象 object 。

    • 方法详细信息

      • checkGuard

        void checkGuard​(Object object)
         throws SecurityException
        确定是否允许访问被保护对象object 。 如果允许访问，则默认返回。 否则，抛出SecurityException。
        参数
        object - 被守卫保护的对象。
        异常
        SecurityException - 如果访问被拒绝。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GuardedObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class GuardedObject

  • java.lang.Object
    • java.security.GuardedObject
  • All Implemented Interfaces:
    Serializable

    public class GuardedObject
extends Object
implements Serializable
    GuardedObject是一个用于保护对另一个对象的访问的对象。

    GuardedObject封装了一个目标对象和一个Guard对象，使得只有在Guard对象允许的情况下才能访问目标对象。 一旦对象被GuardedObject封装，对该对象的访问由getObject方法控制，该方法在Guard对象上调用checkGuard方法来保护访问。 如果不允许访问，则抛出异常。

    从以下版本开始：
    1.2
    另请参见：
    Guard ， Permission ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      GuardedObject​(Object object, Guard guard)
      使用指定的对象和守卫构造一个GuardedObject。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getObject​()
      检索被保护的对象，或者如果对守卫对象的访问被守卫拒绝，则抛出异常。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GuardedObject

        public GuardedObject​(Object object,
                     Guard guard)
        使用指定的对象和守卫构造一个GuardedObject。 如果Guard对象为空，那么对于谁可以访问对象就不会有任何限制。
        参数
        object - 要保护的对象。
        guard - 保护对象访问对象的Guard对象。

    • 方法详细信息

      • getObject

        public Object getObject​()
                 throws SecurityException
        检索被保护的对象，或者如果对守卫对象的访问被守卫拒绝，则抛出异常。
        结果
        守卫的对象。
        异常
        SecurityException - 如果对被保护对象的访问被拒绝。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Identity (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Identity

  • java.lang.Object
    • java.security.Identity
  • All Implemented Interfaces:
    Serializable ， Principal
    已知直接子类：
    IdentityScope ， Signer
    已过时。
    此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。

    @Deprecated(since="1.2")
public abstract class Identity
extends Object
implements Principal, Serializable

    该类表示身份：真实世界的对象，例如人，公司或组织，其身份可以使用其公钥进行身份验证。 身份也可能是更抽象（或具体）的构造，例如守护进程线程或智能卡。

    所有Identity对象都有一个名称和一个公钥。 名字是不可变的 身份也可以是范围。 也就是说，如果一个身份被指定为具有一个特定的范围，则该身份的名称和公钥在该范围内是唯一的。

    身份证件还有一套证书（都证明自己的公钥）。 这些证书中指定的主体名称不一定相同，只是键。

    身份可以被子类化，包括邮政地址和电子邮件地址，电话号码，面孔和徽标的图像等等。

    从以下版本开始：
    1.1
    另请参见：
    IdentityScope ， Signer ， Principal ， Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Identity​()
      已过时。
      仅用于序列化的构造方法。
        Identity​(String name)
      已过时。
      构造一个具有指定名称的标识符，而不指定范围。
        Identity​(String name, IdentityScope scope)
      已过时。
      构造具有指定名称和范围的身份。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addCertificate​(Certificate certificate)
      已过时。
      为此身份添加证书。
      Certificate[] certificates​()
      已过时。
      返回此身份的所有证书的副本。
      boolean equals​(Object identity)
      已过时。
      测试指定对象与此身份之间的相等性。
      String getInfo​()
      已过时。
      返回先前为此标识指定的一般信息。
      String getName​()
      已过时。
      返回此身份的名称。
      PublicKey getPublicKey​()
      已过时。
      返回此身份的公钥。
      IdentityScope getScope​()
      已过时。
      返回此身份的范围。
      int hashCode​()
      已过时。
      返回此标识的哈希码。
      protected boolean identityEquals​(Identity identity)
      已过时。
      测试指定身份与此身份之间的相等性。
      void removeCertificate​(Certificate certificate)
      已过时。
      从此身份中删除证书。
      void setInfo​(String info)
      已过时。
      指定此标识的常规信息字符串。
      void setPublicKey​(PublicKey key)
      已过时。
      设置此身份的公钥。
      String toString​()
      已过时。
      返回一个描述此身份的短字符串，告诉其名称及其范围（如果有）。
      String toString​(boolean detailed)
      已过时。
      返回此标识的字符串表示形式，可选择更多的细节，不包括没有任何参数的 toString方法提供的详细信息。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • Identity

        protected Identity​()
        已过时。
        仅用于序列化的构造方法。

      • Identity

        public Identity​(String name,
                IdentityScope scope)
         throws KeyManagementException
        已过时。
        构造具有指定名称和范围的身份。
        参数
        name - 身份名称。
        scope - 身份的范围。
        异常
        KeyManagementException - 如果在作用 KeyManagementException已经存在同名的身份。

      • Identity

        public Identity​(String name)
        已过时。
        构造一个具有指定名称的标识符，而不指定范围。
        参数
        name - 身份名称。

    • 方法详细信息

      • getName

        public final String getName​()
        已过时。
        返回此身份的名称。
        Specified by:
        getName在接口 Principal
        结果
        这个身份的名字。

      • getScope

        public final IdentityScope getScope​()
        已过时。
        返回此身份的范围。
        结果
        这个身份的范围。

      • getPublicKey

        public PublicKey getPublicKey​()
        已过时。
        返回此身份的公钥。
        结果
        这个身份的公钥。
        另请参见：
        setPublicKey(java.security.PublicKey)

      • setPublicKey

        public void setPublicKey​(PublicKey key)
                  throws KeyManagementException
        已过时。
        设置此身份的公钥。 旧密钥和所有这些身份的证书将通过此操作删除。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法是以"setIdentityPublicKey"作为参数来调用，以查看是否可以设置公钥。

        参数
        key - 这个身份的公钥。
        异常
        KeyManagementException - 如果身份范围中的另一个身份具有相同的公钥，或者是否发生另一个异常。
        SecurityException - 如果存在安全管理员，并且其 checkSecurityAccess方法不允许设置公钥。
        另请参见：
        getPublicKey() ， SecurityManager.checkSecurityAccess(java.lang.String)

      • setInfo

        public void setInfo​(String info)
        已过时。
        指定此标识的常规信息字符串。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法被调用，其中"setIdentityInfo"作为参数来查看是否可以指定信息字符串。

        参数
        info - 信息字符串。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkSecurityAccess方法不允许设置信息字符串。
        另请参见：
        getInfo() ， SecurityManager.checkSecurityAccess(java.lang.String)

      • getInfo

        public String getInfo​()
        已过时。
        返回先前为此标识指定的一般信息。
        结果
        关于这个身份的一般信息。
        另请参见：
        setInfo(java.lang.String)

      • addCertificate

        public void addCertificate​(Certificate certificate)
                    throws KeyManagementException
        已过时。
        为此身份添加证书。 如果身份具有公钥，证书中的公钥必须相同，如果身份不具有公钥，则该身份的公钥设置为证书中指定的公钥。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法将以"addIdentityCertificate"作为参数来调用，以查看是否可以添加一个证书。

        参数
        certificate - 要添加的证书。
        异常
        KeyManagementException - 如果证书无效，则添加的证书中的公钥与此标识的公钥冲突，或者是否发生另一个异常。
        SecurityException - 如果存在安全管理员，并且其 checkSecurityAccess方法不允许添加证书。
        另请参见：
        SecurityManager.checkSecurityAccess(java.lang.String)

      • removeCertificate

        public void removeCertificate​(Certificate certificate)
                       throws KeyManagementException
        已过时。
        从此身份中删除证书。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法将以"removeIdentityCertificate"作为参数来调用，以查看是否可以删除证书。

        参数
        certificate - 要删除的证书。
        异常
        KeyManagementException - 如果证书丢失，或者是否发生另一个异常。
        SecurityException - 如果存在安全管理员，并且其 checkSecurityAccess方法不允许删除证书。
        另请参见：
        SecurityManager.checkSecurityAccess(java.lang.String)

      • certificates

        public Certificate[] certificates​()
        已过时。
        返回此身份的所有证书的副本。
        结果
        该身份的所有证书的副本。

      • equals

        public final boolean equals​(Object identity)
        已过时。
        测试指定对象与此身份之间的相等性。 这首先测试一下实体是否实际引用同一个对象，在这种情况下，它返回true。 接下来，它检查实体是否具有相同的名称和相同的范围。 如果这样做，该方法返回true。 否则，它调用identityEquals ，哪些子类应该覆盖。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        identity - 测试与此身份相等的对象。
        结果
        如果对象被视为相等，则为true，否则为false。
        另请参见：
        identityEquals(java.security.Identity)

      • identityEquals

        protected boolean identityEquals​(Identity identity)
        已过时。
        测试指定身份与此身份之间的相等性。 这个方法应该被子类覆盖以测试相等性。 如果名称和公钥相等，则默认行为为true。
        参数
        identity - 用于测试与此身份相等的身份。
        结果
        如果身份认为相等，则为真，否则为false。
        另请参见：
        equals(java.lang.Object)

      • toString

        public String toString​()
        已过时。
        返回一个描述此身份的短字符串，告诉其名称及其范围（如果有）。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法将以"printIdentity"作为参数来调用，以查看是否可以返回该字符串。

        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        有关此身份的信息，例如其名称及其范围的名称（如果有）。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkSecurityAccess方法不允许返回描述此身份的字符串。
        另请参见：
        SecurityManager.checkSecurityAccess(java.lang.String)

      • toString

        public String toString​(boolean detailed)
        已过时。
        返回此标识的字符串表示形式，可选择更多的细节，不包括没有任何参数的toString方法。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法将以"printIdentity"作为参数来调用，以查看是否可以返回该字符串。

        参数
        detailed - 是否提供详细信息。
        结果
        关于这个身份的信息。 如果detailed为true，则该方法返回的信息多于toString方法提供的信息，而不包含任何参数。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkSecurityAccess方法不允许返回描述此身份的字符串。
        另请参见：
        toString() ， SecurityManager.checkSecurityAccess(java.lang.String)

      • hashCode

        public int hashCode​()
        已过时。
        返回此标识的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个身份的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IdentityScope (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class IdentityScope

  • java.lang.Object
    • java.security.Identity
      • java.security.IdentityScope
  • All Implemented Interfaces:
    Serializable ， Principal
    已过时。
    此类不再使用。 其功能已被java.security.KeyStore替代， java.security.cert包，以及java.security.Principal 。

    @Deprecated(since="1.2")
public abstract class IdentityScope
extends Identity

    这个类代表身份的范围。 它是一个身份本身，因此有一个名字，可以有一个范围。 它还可以选择具有公钥和相关证书。

    IdentityScope可以包含各种身份对象，包括签名者。 可以使用相同的方法检索，添加和删除所有类型的Identity对象。 请注意，实际上可以预期，不同类型的身份范围将针对各种类型的身份对其各种操作应用不同的策略。

    密钥和身份之间存在一对一的映射，每个范围只能有一个密钥副本。 例如，假设Acme Software，Inc是用户已知的软件发行商。 假设它是一个身份，也就是它有一个公钥和一组关联的证书。 它在范围中使用名称“Acme Software”命名。 范围中没有其他命名的身份具有相同的公钥。 当然，没有一个也有同样的名字。

    从以下版本开始：
    1.1
    另请参见：
    Identity ， Signer ， Principal ， Key ， Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected IdentityScope​()
      已过时。
      此构造函数仅用于序列化，不应由子类使用。
        IdentityScope​(String name)
      已过时。
      构造具有指定名称的新的身份范围。
        IdentityScope​(String name, IdentityScope scope)
      已过时。
      构造具有指定名称和范围的新的身份范围。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      abstract void addIdentity​(Identity identity)
      已过时。
      向此身份范围添加身份。
      abstract Identity getIdentity​(String name)
      已过时。
      以指定的名称（如果有）返回此范围中的身份。
      Identity getIdentity​(Principal principal)
      已过时。
      检索其名称与指定的主体相同的身份。
      abstract Identity getIdentity​(PublicKey key)
      已过时。
      使用指定的公钥检索身份。
      static IdentityScope getSystemScope​()
      已过时。
      返回系统的身份范围。
      abstract Enumeration<Identity> identities​()
      已过时。
      返回此身份范围内所有身份的枚举。
      abstract void removeIdentity​(Identity identity)
      已过时。
      从此身份范围中删除身份。
      protected static void setSystemScope​(IdentityScope scope)
      已过时。
      设置系统的身份范围。
      abstract int size​()
      已过时。
      返回此身份范围内的身份数。
      String toString​()
      已过时。
      返回此标识范围的字符串表示形式，包括其名称，其范围名称和此身份范围中的身份数。

      • Methods inherited from class java.security.Identity

        addCertificate, certificates, equals, getInfo, getName, getPublicKey, getScope, hashCode, identityEquals, removeCertificate, setInfo, setPublicKey, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • IdentityScope

        protected IdentityScope​()
        已过时。
        此构造函数仅用于序列化，不应由子类使用。

      • IdentityScope

        public IdentityScope​(String name)
        已过时。
        构造具有指定名称的新的身份范围。
        参数
        name - 范围名称。

      • IdentityScope

        public IdentityScope​(String name,
                     IdentityScope scope)
              throws KeyManagementException
        已过时。
        构造具有指定名称和范围的新的身份范围。
        参数
        name - 范围名称。
        scope - 新身份范围的范围。
        异常
        KeyManagementException - 如果范围中已经存在同名的身份。

    • 方法详细信息

      • getSystemScope

        public static IdentityScope getSystemScope​()
        已过时。
        返回系统的身份范围。
        结果
        系统的身份范围，如果没有设置， null 。
        另请参见：
        setSystemScope(java.security.IdentityScope)

      • setSystemScope

        protected static void setSystemScope​(IdentityScope scope)
        已过时。
        设置系统的身份范围。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法将以"setSystemScope"作为参数来调用，以确定是否可以设置身份范围。

        参数
        scope - 设置的范围。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkSecurityAccess方法不允许设置身份范围。
        另请参见：
        getSystemScope() ， SecurityManager.checkSecurityAccess(java.lang.String)

      • size

        public abstract int size​()
        已过时。
        返回此身份范围内的身份数。
        结果
        该身份范围内的身份数量。

      • getIdentity

        public abstract Identity getIdentity​(String name)
        已过时。
        以指定的名称（如果有）返回此范围中的身份。
        参数
        name - 要检索的身份的名称。
        结果
        名称为 name的身份，如果此范围中没有名为 name的身份， name null。

      • getIdentity

        public Identity getIdentity​(Principal principal)
        已过时。
        检索其名称与指定的主体相同的身份。 （注：身份实现主体。）
        参数
        principal - 与要检索的身份相对应的主体。
        结果
        名称与委托人名称相同的身份，如果在此范围内没有同名的身份，则为null。

      • getIdentity

        public abstract Identity getIdentity​(PublicKey key)
        已过时。
        使用指定的公钥检索身份。
        参数
        key - 要返回的身份的公钥。
        结果
        使用给定键的身份，如果此范围中没有该密钥的身份，则为null。

      • addIdentity

        public abstract void addIdentity​(Identity identity)
                          throws KeyManagementException
        已过时。
        向此身份范围添加身份。
        参数
        identity - 要添加的身份。
        异常
        KeyManagementException - 如果身份无效，则会发生名称冲突，另一个身份具有与添加的身份相同的公钥，或发生另一个异常。

      • removeIdentity

        public abstract void removeIdentity​(Identity identity)
                             throws KeyManagementException
        已过时。
        从此身份范围中删除身份。
        参数
        identity - 要删除的身份
        异常
        KeyManagementException - 如果身份丢失或发生另一个异常。

      • identities

        public abstract Enumeration<Identity> identities​()
        已过时。
        返回此身份范围内所有身份的枚举。
        结果
        在此身份范围内列举所有身份。

      • toString

        public String toString​()
        已过时。
        返回此标识范围的字符串表示形式，包括其名称，其范围名称和此身份范围中的身份数。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Identity
        结果
        这个身份范围的字符串表示形式。
        另请参见：
        SecurityManager.checkSecurityAccess(java.lang.String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidAlgorithmParameterException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class InvalidAlgorithmParameterException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.InvalidAlgorithmParameterException
  • All Implemented Interfaces:
    Serializable

    public class InvalidAlgorithmParameterException
extends GeneralSecurityException
    这是无效或不合适的算法参数的例外。
    从以下版本开始：
    1.2
    另请参见：
    AlgorithmParameters ， AlgorithmParameterSpec ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidAlgorithmParameterException​()
      构造一个InvalidAlgorithmParameterException，没有详细信息。
      InvalidAlgorithmParameterException​(String msg)
      使用指定的详细消息构造InvalidAlgorithmParameterException。
      InvalidAlgorithmParameterException​(String message, Throwable cause)
      创建一个具有指定的详细信息和原因的 InvalidAlgorithmParameterException 。
      InvalidAlgorithmParameterException​(Throwable cause)
      创建一个 InvalidAlgorithmParameterException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidAlgorithmParameterException

        public InvalidAlgorithmParameterException​()
        构造一个InvalidAlgorithmParameterException，没有详细信息。 详细消息是描述此特定异常的字符串。

      • InvalidAlgorithmParameterException

        public InvalidAlgorithmParameterException​(String msg)
        使用指定的详细消息构造InvalidAlgorithmParameterException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。

      • InvalidAlgorithmParameterException

        public InvalidAlgorithmParameterException​(String message,
                                          Throwable cause)
        创建一个 InvalidAlgorithmParameterException具有指定的详细信息和原因。
        参数
        message - 详细信息（由 Throwable.getMessage()方法保存供以后检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • InvalidAlgorithmParameterException

        public InvalidAlgorithmParameterException​(Throwable cause)
        创建一个 InvalidAlgorithmParameterException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（保存以供以后通过Throwable.getCause()方法检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidKeyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class InvalidKeyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.KeyException
            • java.security.InvalidKeyException
  • All Implemented Interfaces:
    Serializable

    public class InvalidKeyException
extends KeyException
    这是无效键（无效编码，长度错误，未初始化等）的例外。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidKeyException​()
      构造一个InvalidKeyException，没有详细信息。
      InvalidKeyException​(String msg)
      构造具有指定详细消息的InvalidKeyException。
      InvalidKeyException​(String message, Throwable cause)
      创建一个 InvalidKeyException与指定的详细信息和原因。
      InvalidKeyException​(Throwable cause)
      创建一个 InvalidKeyException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidKeyException

        public InvalidKeyException​()
        构造一个InvalidKeyException，没有详细信息。 详细消息是描述此特定异常的字符串。

      • InvalidKeyException

        public InvalidKeyException​(String msg)
        构造具有指定详细消息的InvalidKeyException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。

      • InvalidKeyException

        public InvalidKeyException​(String message,
                           Throwable cause)
        创建一个 InvalidKeyException具有指定的详细信息和原因。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （A null允许值，表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • InvalidKeyException

        public InvalidKeyException​(Throwable cause)
        创建一个 InvalidKeyException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidParameterException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class InvalidParameterException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.security.InvalidParameterException
  • All Implemented Interfaces:
    Serializable

    public class InvalidParameterException
extends IllegalArgumentException
    当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidParameterException​()
      构造一个无详细消息的InvalidParameterException。
      InvalidParameterException​(String msg)
      构造具有指定详细消息的InvalidParameterException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidParameterException

        public InvalidParameterException​()
        构造一个无详细消息的InvalidParameterException。 详细消息是描述此特定异常的字符串。

      • InvalidParameterException

        public InvalidParameterException​(String msg)
        构造具有指定详细消息的InvalidParameterException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.security (Java SE 9 & JDK 9 )

java.security

Interfaces

  • AlgorithmConstraints
  • Certificate
  • DomainCombiner
  • Guard
  • Key
  • KeyStore.Entry
  • KeyStore.Entry.Attribute
  • KeyStore.LoadStoreParameter
  • KeyStore.ProtectionParameter
  • Policy.Parameters
  • Principal
  • PrivateKey
  • PrivilegedAction
  • PrivilegedExceptionAction
  • PublicKey
  • SecureRandomParameters

Classes

  • AccessControlContext
  • AccessController
  • AlgorithmParameterGenerator
  • AlgorithmParameterGeneratorSpi
  • AlgorithmParameters
  • AlgorithmParametersSpi
  • AllPermission
  • AuthProvider
  • BasicPermission
  • CodeSigner
  • CodeSource
  • DigestInputStream
  • DigestOutputStream
  • DomainLoadStoreParameter
  • DrbgParameters
  • DrbgParameters.Instantiation
  • DrbgParameters.NextBytes
  • DrbgParameters.Reseed
  • GuardedObject
  • Identity
  • IdentityScope
  • KeyFactory
  • KeyFactorySpi
  • KeyPair
  • KeyPairGenerator
  • KeyPairGeneratorSpi
  • KeyRep
  • KeyStore
  • KeyStore.Builder
  • KeyStore.CallbackHandlerProtection
  • KeyStore.PasswordProtection
  • KeyStore.PrivateKeyEntry
  • KeyStore.SecretKeyEntry
  • KeyStore.TrustedCertificateEntry
  • KeyStoreSpi
  • MessageDigest
  • MessageDigestSpi
  • Permission
  • PermissionCollection
  • Permissions
  • PKCS12Attribute
  • Policy
  • PolicySpi
  • ProtectionDomain
  • Provider
  • Provider.Service
  • SecureClassLoader
  • SecureRandom
  • SecureRandomSpi
  • Security
  • SecurityPermission
  • Signature
  • SignatureSpi
  • SignedObject
  • Signer
  • Timestamp
  • UnresolvedPermission
  • URIParameter

Enums

  • CryptoPrimitive
  • DrbgParameters.Capability
  • KeyRep.Type

Exceptions

  • AccessControlException
  • DigestException
  • GeneralSecurityException
  • InvalidAlgorithmParameterException
  • InvalidKeyException
  • InvalidParameterException
  • KeyException
  • KeyManagementException
  • KeyStoreException
  • NoSuchAlgorithmException
  • NoSuchProviderException
  • PrivilegedActionException
  • ProviderException
  • SignatureException
  • UnrecoverableEntryException
  • UnrecoverableKeyException


java.security (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.security

提供安全框架的类和接口。 这包括实现易于配置，细粒度访问控制安全架构的类。 该软件包还支持加密公钥对的生成和存储，以及许多可导出的加密操作，包括用于消息摘要和签名生成的加密操作。 最后，该包提供支持签名/保护对象并安全随机数生成的类。 该包中提供的许多类（特别是加密和安全随机数生成器类）是基于提供者的。 类本身定义了应用程序可以编写的编程接口。 然后，实现本身可以由独立的第三方供应商编写，并根据需要无缝地插入。 因此，应用程序开发人员可以利用任何数量的基于提供者的实现，而无需添加或重写代码。

包装规格

  • Java Cryptography Architecture (JCA) Reference Guide
  • PKCS＃8：私钥信息语法标准版本1.2，1993年11月
  • Java Security Standard Algorithm Names Specification

相关文档

有关进一步的文档，请参阅：
  • Java Security Overview
  • How to Implement a Provider in the Java Cryptography Architecture
  • Default Policy Implementation and Policy File Syntax
  • Permissions in the Java Development Kit (JDK)
  • Summary of Tools for Java Platform Security （例如keytool和jarsigner ），
从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    AlgorithmConstraints
    该接口指定加密算法，密钥（密钥大小）和其他算法参数的约束。
    Certificate Deprecated.
    Java平台中创建了一个新的证书处理包。
    DomainCombiner
    A DomainCombiner提供了一种手段来动态更新与当前 AccessControlContext相关联的ProtectionDomains。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Key
    Key界面是所有键的顶级界面。
    KeyStore.Entry
    KeyStore条目类型的标记界面。
    KeyStore.Entry.Attribute
    与密钥库条目关联的属性。
    KeyStore.LoadStoreParameter
    KeyStore load和 store参数的标记界面。
    KeyStore.ProtectionParameter
    用于密钥库保护参数的标记界面。
    Policy.Parameters
    这表示Policy参数的标记界面。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
    PrivateKey
    私钥。
    PrivilegedAction<T>
    要启用权限执行的计算。
    PrivilegedExceptionAction<T>
    要启用权限执行的计算，会抛出一个或多个已检查的异常。
    PublicKey
    公钥
    SecureRandomParameters
    用于各种 SecureRandom方法中使用的参数的标记界面。
  • 类摘要
    Class 描述
    AccessControlContext
    AccessControlContext用于根据其封装的上下文来进行系统资源访问决策。
    AccessController
    AccessController类用于访问控制操作和决策。
    AlgorithmParameterGenerator
    AlgorithmParameterGenerator类用于生成一组要用于某种算法的参数。
    AlgorithmParameterGeneratorSpi
    该类定义了 AlgorithmParameterGenerator类的 （ SPI ），用于生成一组要与特定算法一起使用的参数。
    AlgorithmParameters
    此类用作加密参数的不透明表示。
    AlgorithmParametersSpi
    该类为 AlgorithmParameters类定义了 （ SPI ），用于管理算法参数。
    AllPermission
    AllPermission是一个隐含所有其他权限的权限。
    AuthProvider
    此类为提供程序定义登录和注销方法。
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    CodeSigner
    该类封装了有关代码签名者的信息。
    CodeSource
    该类扩展了代码库的概念，不仅封装了位置（URL），还封装了用于验证源自该位置的签名代码的证书链。
    DigestInputStream
    透明流，使用通过流的位更新关联的消息摘要。
    DigestOutputStream
    透明流，使用通过流的位更新关联的消息摘要。
    DomainLoadStoreParameter
    指定密钥库中密钥库的配置数据。
    DrbgParameters
    该类指定DRBG（确定性随机位发生器）使用的参数。
    DrbgParameters.Instantiation
    用于实例化的DRBG参数。
    DrbgParameters.NextBytes
    用于随机位生成的DRBG参数。
    DrbgParameters.Reseed
    重新植入的DRBG参数。
    GuardedObject
    GuardedObject是一个用于保护对另一个对象的访问的对象。
    Identity Deprecated.
    此类不再使用。
    IdentityScope Deprecated.
    此类不再使用。
    KeyFactory
    主要工厂用于将 键 （ Key型的不透明加密密钥）转换为 密钥规范 （基础密钥材料的透明表示），反之亦然。
    KeyFactorySpi
    该类定义了 KeyFactory类的 （ SPI ）。
    KeyPair
    这个类是密钥对（一个公钥和一个私钥）的简单持有者。
    KeyPairGenerator
    KeyPairGenerator类用于生成公钥和私钥对。
    KeyPairGeneratorSpi
    该类定义了 KeyPairGenerator类的 （ SPI ），用于生成公钥和私钥对。
    KeyRep
    序列化关键对象的标准化表示。
    KeyStore
    该类代表加密密钥和证书的存储设备。
    KeyStore.Builder
    要实例化的KeyStore对象的描述。
    KeyStore.CallbackHandlerProtection
    一个封装CallbackHandler的ProtectionParameter。
    KeyStore.PasswordProtection
    基于密码的实现 ProtectionParameter 。
    KeyStore.PrivateKeyEntry
    一个 KeyStore条目，其中包含一个 PrivateKey和相应的证书链。
    KeyStore.SecretKeyEntry
    A KeyStore条目，其中包含一个 SecretKey 。
    KeyStore.TrustedCertificateEntry
    A KeyStore条目，其中包含受信任的 Certificate 。
    KeyStoreSpi
    该类定义了 KeyStore类的 （ SPI ）。
    MessageDigest
    该MessageDigest类为应用程序提供消息摘要算法的功能，如SHA-1或SHA-256。
    MessageDigestSpi
    该类定义了 MessageDigest类的 （ SPI ），它提供消息摘要算法（如MD5或SHA）的功能。
    Permission
    用于表示访问系统资源的抽象类。
    PermissionCollection
    代表Permission对象集合的抽象类。
    Permissions
    此类表示许多权限的异构集合。
    PKCS12Attribute
    与PKCS12密钥库条目关联的属性。
    Policy
    Policy对象负责确定在Java运行时环境中执行的代码是否具有执行安全敏感操作的权限。
    PolicySpi
    该类定义了 Policy类的 （ SPI ）。
    ProtectionDomain
    ProtectionDomain类封装了一个域的特性，该域包含一组类，当代表一组给定的主体执行时，该类的实例被授予一组权限。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
    Provider.Service
    安全服务的描述。
    SecureClassLoader
    此类扩展了ClassLoader，其额外支持用于定义具有相关代码源和权限的类，默认情况下系统策略将检索该类。
    SecureRandom
    这个类提供了一个密码强的随机数生成器（RNG）。
    SecureRandomSpi
    该类定义了SecureRandom类的 （ SPI ）。
    Security
    此类集中所有安全属性和常见的安全方法。
    SecurityPermission
    此类用于安全权限。
    Signature
    Signature类用于向应用程序提供数字签名算法的功能。
    SignatureSpi
    该类定义了 Signature类的 （ SPI ），用于提供数字签名算法的功能。
    SignedObject
    SignedObject是一个类，用于创建可靠的运行时对象，其完整性不会受到威胁，而不会被检测到。
    Signer Deprecated.
    此类不再使用。
    Timestamp
    此类封装了有关已签名时间戳的信息。
    UnresolvedPermission
    UnresolvedPermission类用于保存初始化策略时“未解决”的权限。
    URIParameter
    包含指向PolicySpi或ConfigurationSpi实现的数据的URI的参数。
  • 枚举摘要
    Enum 描述
    CryptoPrimitive
    加密原语的枚举。
    DrbgParameters.Capability
    DRBG的可重新预测和预测抵抗能力。
    KeyRep.Type
    钥匙类型
  • 异常摘要
    异常 描述
    AccessControlException
    AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。
    DigestException
    这是通用的消息摘要异常。
    GeneralSecurityException
    GeneralSecurityException类是一种通用安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。
    InvalidAlgorithmParameterException
    这是无效或不合适的算法参数的例外。
    InvalidKeyException
    这是无效键（无效编码，长度错误，未初始化等）的例外。
    InvalidParameterException
    当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。
    KeyException
    这是基本的关键例外。
    KeyManagementException
    这是处理密钥管理的所有操作的一般密钥管理例外。
    KeyStoreException
    这是通用的KeyStore异常。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    PrivilegedActionException
    这个异常是由 doPrivileged(PrivilegedExceptionAction)和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context)引发的，表示正在执行的操作会抛出一个被检查的异常。
    ProviderException
    提供者异常的运行时异常（例如错误配置错误或不可恢复的内部错误），它们可能由提供程序子类化以抛出专门的提供者特定的运行时错误。
    SignatureException
    这是一般的签名异常。
    UnrecoverableEntryException
    如果密钥库中的条目无法恢复，则抛出此异常。
    UnrecoverableKeyException
    如果密钥存储库中的密钥无法恢复，则抛出此异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.security Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.security

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.security.AccessControlContext
    • java.security.AccessController
    • java.security.AlgorithmParameterGenerator
    • java.security.AlgorithmParameterGeneratorSpi
    • java.security.AlgorithmParameters
    • java.security.AlgorithmParametersSpi
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
    • java.security.CodeSigner (implements java.io.Serializable)
    • java.security.CodeSource (implements java.io.Serializable)
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • java.security.Provider
            • java.security.AuthProvider
    • java.security.DomainLoadStoreParameter (implements java.security.KeyStore.LoadStoreParameter)
    • java.security.DrbgParameters
    • java.security.DrbgParameters.Instantiation (implements java.security.SecureRandomParameters)
    • java.security.DrbgParameters.NextBytes (implements java.security.SecureRandomParameters)
    • java.security.DrbgParameters.Reseed (implements java.security.SecureRandomParameters)
    • java.security.GuardedObject (implements java.io.Serializable)
    • java.security.Identity (implements java.security.Principal, java.io.Serializable)
      • java.security.IdentityScope
      • java.security.Signer
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • java.security.DigestInputStream
    • java.security.KeyFactory
    • java.security.KeyFactorySpi
    • java.security.KeyPair (implements java.io.Serializable)
    • java.security.KeyPairGeneratorSpi
      • java.security.KeyPairGenerator
    • java.security.KeyRep (implements java.io.Serializable)
    • java.security.KeyStore
    • java.security.KeyStore.Builder
    • java.security.KeyStore.CallbackHandlerProtection (implements java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PasswordProtection (implements javax.security.auth.Destroyable, java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PrivateKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.SecretKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.TrustedCertificateEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStoreSpi
    • java.security.MessageDigestSpi
      • java.security.MessageDigest
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • java.security.DigestOutputStream
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.AllPermission
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.security.SecurityPermission
      • java.security.UnresolvedPermission (implements java.io.Serializable)
    • java.security.PermissionCollection (implements java.io.Serializable)
      • java.security.Permissions (implements java.io.Serializable)
    • java.security.PKCS12Attribute (implements java.security.KeyStore.Entry.Attribute)
    • java.security.Policy
    • java.security.PolicySpi
    • java.security.ProtectionDomain
    • java.security.Provider.Service
    • java.util.Random (implements java.io.Serializable)
      • java.security.SecureRandom
    • java.security.SecureRandomSpi (implements java.io.Serializable)
    • java.security.Security
    • java.security.SignatureSpi
      • java.security.Signature
    • java.security.SignedObject (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.security.GeneralSecurityException
          • java.security.DigestException
          • java.security.InvalidAlgorithmParameterException
          • java.security.KeyException
            • java.security.InvalidKeyException
            • java.security.KeyManagementException
          • java.security.KeyStoreException
          • java.security.NoSuchAlgorithmException
          • java.security.NoSuchProviderException
          • java.security.SignatureException
          • java.security.UnrecoverableEntryException
            • java.security.UnrecoverableKeyException
        • java.security.PrivilegedActionException
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.security.InvalidParameterException
          • java.security.ProviderException
          • java.lang.SecurityException
            • java.security.AccessControlException
    • java.security.Timestamp (implements java.io.Serializable)
    • java.security.URIParameter (implements javax.security.auth.login.Configuration.Parameters, java.security.Policy.Parameters)

Interface Hierarchy

  • java.security.AlgorithmConstraints
  • java.security.Certificate
  • javax.security.auth.Destroyable
    • java.security.PrivateKey (also extends java.security.Key)
  • java.security.DomainCombiner
  • java.security.Guard
  • java.security.KeyStore.Entry
  • java.security.KeyStore.Entry.Attribute
  • java.security.KeyStore.LoadStoreParameter
  • java.security.KeyStore.ProtectionParameter
  • java.security.Policy.Parameters
  • java.security.Principal
  • java.security.PrivilegedAction<T>
  • java.security.PrivilegedExceptionAction<T>
  • java.security.SecureRandomParameters
  • java.io.Serializable
    • java.security.Key
      • java.security.PrivateKey (also extends javax.security.auth.Destroyable)
      • java.security.PublicKey

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.security.CryptoPrimitive
      • java.security.DrbgParameters.Capability
      • java.security.KeyRep.Type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Key (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface Key

  • All Superinterfaces:
    Serializable
    All Known Subinterfaces:
    DHPrivateKey ， DHPublicKey ， DSAPrivateKey ， DSAPublicKey ， ECPrivateKey ， ECPublicKey ， PBEKey ， PrivateKey ， PublicKey ， RSAMultiPrimePrivateCrtKey ， RSAPrivateCrtKey ， RSAPrivateKey ， RSAPublicKey ， SecretKey
    所有已知实现类：
    EncryptionKey ， KerberosKey ， SecretKeySpec

    public interface Key
extends Serializable
    Key界面是所有键的顶级界面。 它定义了所有关键对象共享的功能。 所有键有三个特点：
    • 算法

      这是该键的关键算法。 关键算法通常是加密或非对称运算算法（如DSA或RSA），可以与这些算法和相关算法（如RSA，RSA，RSA，MDA，Raw DSA等）相结合。使用getAlgorithm方法获得密钥算法。

    • 编码形式

      这是当在Java虚拟机之外需要密钥的标准表示时使用的密钥的外部编码形式，就像将密钥发送给其他方一样。 密钥根据标准格式（如X.509 SubjectPublicKeyInfo或PKCS＃8）进行编码，并使用getEncoded方法返回。 注意：ASN.1类型SubjectPublicKeyInfo的语法定义如下：

        SubjectPublicKeyInfo ::= SEQUENCE {
   algorithm AlgorithmIdentifier,
   subjectPublicKey BIT STRING }

 AlgorithmIdentifier ::= SEQUENCE {
   algorithm OBJECT IDENTIFIER,
   parameters ANY DEFINED BY algorithm OPTIONAL }
      有关详细信息，请参阅RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile 。
    • A格式

      这是编码密钥格式的名称。 它由getFormat方法返回。

    密钥通常通过密钥生成器，证书或用于管理密钥的各种身份类获得。 密钥也可以通过使用关键工厂从关键规范（基础密钥材料的透明表示）获得（参见KeyFactory ）。

    Key应该使用KeyRep作为其序列化表示。 请注意，序列化的密钥可能包含不应在不受信任的环境中暴露的敏感信息。 有关详细信息，请参阅序列化规范的Security Appendix 。

    从以下版本开始：
    1.1
    另请参见：
    PublicKey ， PrivateKey ， KeyPair ， KeyPairGenerator ， KeyFactory ， KeyRep ， KeySpec ， Identity ， Signer

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      类指纹被设置为指示与以前版本的类的序列化兼容性。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getAlgorithm​()
      返回此键的标准算法名称。
      byte[] getEncoded​()
      返回其主要编码格式的密钥，如果此密钥不支持编码，则返回null。
      String getFormat​()
      返回此键的主编码格式的名称，如果此键不支持编码，则返回null。

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        类指纹被设置为指示与以前版本的类的序列化兼容性。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getAlgorithm

        String getAlgorithm​()
        返回此键的标准算法名称。 例如，“DSA”将表示该密钥是DSA密钥。 有关详细信息，请参阅Java Security Standard Algorithm Names文档。
        结果
        与该密钥相关联的算法的名称。

      • getFormat

        String getFormat​()
        返回此键的主编码格式的名称，如果此键不支持编码，则返回null。 如果存在该密钥的ASN.1规范，主编码格式将以适当的ASN.1数据格式命名。 例如，公钥的ASN.1数据格式的名称为SubjectPublicKeyInfo ，由X.509标准定义; 在这种情况下，返回的格式为"X.509" 。 类似地，私钥的ASN.1数据格式的名称是由PKCS＃8标准定义的PrivateKeyInfo ; 在这种情况下，返回的格式为"PKCS#8" 。
        结果
        键的主要编码格式。

      • getEncoded

        byte[] getEncoded​()
        返回其主要编码格式的密钥，如果此密钥不支持编码，则返回null。
        结果
        编码密钥，如果密钥不支持编码，则为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


KeyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.KeyException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    InvalidKeyException ， KeyManagementException

    public class KeyException
extends GeneralSecurityException
    这是基本的关键例外。
    从以下版本开始：
    1.1
    另请参见：
    Key ， InvalidKeyException ， KeyManagementException ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyException​()
      构造一个没有详细消息的KeyException。
      KeyException​(String msg)
      构造具有指定详细消息的KeyException。
      KeyException​(String message, Throwable cause)
      创建一个 KeyException与指定的详细信息和原因。
      KeyException​(Throwable cause)
      创建 KeyException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • KeyException

        public KeyException​()
        构造一个没有详细消息的KeyException。 详细消息是描述此特定异常的字符串。

      • KeyException

        public KeyException​(String msg)
        构造具有指定详细消息的KeyException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。

      • KeyException

        public KeyException​(String message,
                    Throwable cause)
        新新新新 KeyException
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • KeyException

        public KeyException​(Throwable cause)
        创建 KeyException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （允许A null值，表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyFactory

  • java.lang.Object
    • java.security.KeyFactory

  • public class KeyFactory
extends Object
    主要工厂用于将键 （ Key型的不透明加密密钥）转换为密钥规范 （基础密钥材料的透明表示），反之亦然。

    主要工厂是双向的。 也就是说，它们允许您从给定的密钥规范（密钥材料）构建一个不透明的密钥对象，或以合适的格式检索密钥对象的基础密钥材料。

    同一个密钥可能存在多个兼容的密钥规范。 例如，可以使用DSAPublicKeySpec或X509EncodedKeySpec指定DSA公钥。 一个关键的工厂可用于在兼容的密钥规范之间进行转换。

    以下是如何使用密钥工厂以从其编码实例化DSA公钥的示例。 假设爱丽丝收到了鲍勃的数字签名。 鲍勃也把她的公开密钥（编码格式）发给他，以验证他的签名。 Alice然后执行以下操作：

      X509EncodedKeySpec bobPubKeySpec = new X509EncodedKeySpec(bobEncodedPubKey);
 KeyFactory keyFactory = KeyFactory.getInstance("DSA");
 PublicKey bobPubKey = keyFactory.generatePublic(bobPubKeySpec);
 Signature sig = Signature.getInstance("DSA");
 sig.initVerify(bobPubKey);
 sig.update(data);
 sig.verify(signature);

    Java平台的每个实现都需要支持以下标准的KeyFactory算法：

    • DiffieHellman
    • DSA
    • RSA
    这些算法在Java Security Standard算法名称规范的KeyFactory section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.2
    另请参见：
    Key ， PublicKey ， PrivateKey ， KeySpec ， DSAPublicKeySpec ， X509EncodedKeySpec

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected KeyFactory​(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
      创建一个KeyFactory对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PrivateKey generatePrivate​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成私钥对象。
      PublicKey generatePublic​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成公钥对象。
      String getAlgorithm​()
      获取与此 KeyFactory相关联的算法的名称。
      static KeyFactory getInstance​(String algorithm)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      static KeyFactory getInstance​(String algorithm, String provider)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      static KeyFactory getInstance​(String algorithm, Provider provider)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      <T extends KeySpec>
      T             		getKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。
      Provider getProvider​()
      返回此关键工厂对象的提供者。
      Key translateKey​(Key key)
      将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyFactory

        protected KeyFactory​(KeyFactorySpi keyFacSpi,
                     Provider provider,
                     String algorithm)
        创建一个KeyFactory对象。
        参数
        keyFacSpi - 代表
        provider - 提供商
        algorithm - 与此 KeyFactory关联的算法的名称

    • 方法详细信息

      • getInstance

        public static KeyFactory getInstance​(String algorithm)
                              throws NoSuchAlgorithmException
        返回一个KeyFactory对象，它转换指定算法的公钥/私钥。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装KeyFactorySpi实现的新KeyFactory对象。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 所请求密钥算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyFactory部分。
        结果
        新的 KeyFactory对象
        异常
        NoSuchAlgorithmException - 如果否 Provider支持指定算法的 KeyFactorySpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static KeyFactory getInstance​(String algorithm,
                                     String provider)
                              throws NoSuchAlgorithmException,
                                     NoSuchProviderException
        返回一个KeyFactory对象，它转换指定算法的公钥/私钥。

        返回从指定提供程序封装KeyFactorySpi实现的新KeyFactory对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        algorithm - 所请求密钥算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyFactory部分。
        provider - 提供商的名称。
        结果
        新的 KeyFactory对象
        异常
        IllegalArgumentException - 如果提供者名称为 null或为空
        NoSuchAlgorithmException - 如果指定算法的 KeyFactorySpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static KeyFactory getInstance​(String algorithm,
                                     Provider provider)
                              throws NoSuchAlgorithmException
        返回一个KeyFactory对象，它转换指定算法的公钥/私钥。

        返回从指定的Provider对象封装KeyFactorySpi实现的新KeyFactory对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 所请求密钥算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyFactory部分。
        provider - 提供商。
        结果
        新的 KeyFactory对象
        异常
        IllegalArgumentException - 如果指定的提供者是 null
        NoSuchAlgorithmException - 如果指定的算法的 KeyFactorySpi实现不能从指定的 Provider对象获得
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        1.4
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此关键工厂对象的提供者。
        结果
        这个关键工厂对象的提供者

      • getAlgorithm

        public final String getAlgorithm​()
        获取与此 KeyFactory相关联的算法的名称。
        结果
        与该 KeyFactory相关联的算法的名称

      • generatePublic

        public final PublicKey generatePublic​(KeySpec keySpec)
                               throws InvalidKeySpecException
        从提供的密钥规范（密钥材料）生成公钥对象。
        参数
        keySpec - 公钥的规范（密钥材料）。
        结果
        公钥。
        异常
        InvalidKeySpecException - 如果给定的密钥规范不适合该密钥工厂生成公钥。

      • generatePrivate

        public final PrivateKey generatePrivate​(KeySpec keySpec)
                                 throws InvalidKeySpecException
        从提供的密钥规范（密钥材料）生成私钥对象。
        参数
        keySpec - keySpec的规范（密钥材料）。
        结果
        私钥。
        异常
        InvalidKeySpecException - 如果给定的密钥规范不适合该密钥工厂生成私钥。

      • getKeySpec

        public final <T extends KeySpec> T getKeySpec​(Key key,
                                              Class<T> keySpec)
                                       throws InvalidKeySpecException
        返回给定键对象的规范（关键材料）。 keySpec标识应该返回密钥材料的规范类。 例如，它可以是DSAPublicKeySpec.class ，以表明在DSAPublicKeySpec类的实例中应该返回密钥材料。
        参数类型
        T - 要返回的密钥规范的类型
        参数
        key - 关键。
        keySpec - 应该返回密钥材料的规范类。
        结果
        在所请求的规范类的实例中的基础密钥规范（密钥材料）。
        异常
        InvalidKeySpecException - 如果所请求的密钥规范不适用于给定的密钥，或给定的密钥不能被处理（例如，给定的密钥具有无法识别的算法或格式）。

      • translateKey

        public final Key translateKey​(Key key)
                       throws InvalidKeyException
        将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。
        参数
        key - 提供者未知或不信任的关键。
        结果
        翻译密钥。
        异常
        InvalidKeyException - 如果该密钥工厂无法处理给定的密钥。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyFactorySpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyFactorySpi

  • java.lang.Object
    • java.security.KeyFactorySpi

  • public abstract class KeyFactorySpi
extends Object
    该类定义了KeyFactory类的 （ SPI ）。 该类中的所有抽象方法必须由希望提供特定算法的关键工厂的实现的每个加密服务提供商来实现。

    主要工厂用于将键 （ Key型的不透明加密密钥）转换为关键规范 （基础密钥材料的透明表示），反之亦然。

    主要工厂是双向的。 也就是说，它们允许您从给定的密钥规范（密钥材料）构建一个不透明的密钥对象，或以合适的格式检索密钥对象的基础密钥材料。

    同一个密钥可能存在多个兼容的密钥规范。 例如，可以使用DSAPublicKeySpec或X509EncodedKeySpec指定DSA公钥。 一个关键的工厂可用于在兼容的密钥规范之间进行转换。

    供应商应记录其关键工厂支持的所有关键规格。

    从以下版本开始：
    1.2
    另请参见：
    KeyFactory ， Key ， PublicKey ， PrivateKey ， KeySpec ， DSAPublicKeySpec ， X509EncodedKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyFactorySpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      protected abstract PrivateKey engineGeneratePrivate​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成私钥对象。
      protected abstract PublicKey engineGeneratePublic​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成公钥对象。
      protected abstract <T extends KeySpec>
      T             		engineGetKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。
      protected abstract Key engineTranslateKey​(Key key)
      将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyFactorySpi

        public KeyFactorySpi​()

    • 方法详细信息

      • engineGeneratePublic

        protected abstract PublicKey engineGeneratePublic​(KeySpec keySpec)
                                           throws InvalidKeySpecException
        从提供的密钥规范（密钥材料）生成公钥对象。
        参数
        keySpec - 公钥的规范（密钥材料）。
        结果
        公钥。
        异常
        InvalidKeySpecException - 如果给定的密钥规范不适合该密钥工厂生成公钥。

      • engineGeneratePrivate

        protected abstract PrivateKey engineGeneratePrivate​(KeySpec keySpec)
                                             throws InvalidKeySpecException
        从提供的密钥规范（密钥材料）生成私钥对象。
        参数
        keySpec - keySpec的规范（密钥材料）。
        结果
        私钥。
        异常
        InvalidKeySpecException - 如果给定的密钥规范不适合该密钥工厂生成私钥。

      • engineGetKeySpec

        protected abstract <T extends KeySpec> T engineGetKeySpec​(Key key,
                                                          Class<T> keySpec)
                                                   throws InvalidKeySpecException
        返回给定键对象的规范（关键材料）。 keySpec标识应该返回密钥材料的规范类。 例如，它可以是DSAPublicKeySpec.class ，以表明应该在DSAPublicKeySpec类的实例中返回密钥材料。
        参数类型
        T - 要返回的密钥规范的类型
        参数
        key - 关键。
        keySpec - 应该返回密钥材料的规范类。
        结果
        在所请求的规范类的实例中的基础密钥规范（密钥材料）。
        异常
        InvalidKeySpecException - 如果请求的密钥规范不适用于给定的密钥，或给定的密钥不能被处理（例如，给定的密钥具有无法识别的格式）。

      • engineTranslateKey

        protected abstract Key engineTranslateKey​(Key key)
                                   throws InvalidKeyException
        将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。
        参数
        key - 提供者未知或不信任的密钥。
        结果
        翻译密钥。
        异常
        InvalidKeyException - if the given key cannot be processed by this key factory.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyManagementException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyManagementException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.KeyException
            • java.security.KeyManagementException
  • All Implemented Interfaces:
    Serializable

    public class KeyManagementException
extends KeyException
    这是处理密钥管理的所有操作的一般密钥管理例外。 开发人员可能为更详细的信息创建的KeyManagementException子类的示例可能包括：
    • KeyIDConflictException
    • KeyAuthorizationFailureException
    • ExpiredKeyException
    从以下版本开始：
    1.1
    另请参见：
    Key ， KeyException ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyManagementException​()
      构造一个没有详细消息的KeyManagementException。
      KeyManagementException​(String msg)
      构造具有指定详细消息的KeyManagementException。
      KeyManagementException​(String message, Throwable cause)
      创建一个具有指定的详细信息和原因的 KeyManagementException 。
      KeyManagementException​(Throwable cause)
      创建 KeyManagementException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • KeyManagementException

        public KeyManagementException​()
        构造一个没有详细消息的KeyManagementException。 详细消息是描述此特定异常的字符串。

      • KeyManagementException

        public KeyManagementException​(String msg)
        构造具有指定详细消息的KeyManagementException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。

      • KeyManagementException

        public KeyManagementException​(String message,
                              Throwable cause)
        创建一个 KeyManagementException具有指定的详细信息和原因。
        参数
        message - 详细信息（保存以供以后通过 Throwable.getMessage()方法检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • KeyManagementException

        public KeyManagementException​(Throwable cause)
        创建 KeyManagementException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （A null允许值，表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyPair (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyPair

  • java.lang.Object
    • java.security.KeyPair
  • All Implemented Interfaces:
    Serializable

    public final class KeyPair
extends Object
implements Serializable
    这个类是密钥对（一个公钥和一个私钥）的简单持有者。 它不强制执行任何安全性，并且在初始化时应该像PrivateKey那样对待。
    从以下版本开始：
    1.1
    另请参见：
    PublicKey ， PrivateKey ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyPair​(PublicKey publicKey, PrivateKey privateKey)
      从给定的公钥和私钥构造一个密钥对。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PrivateKey getPrivate​()
      返回对此密钥对的私钥组件的引用。
      PublicKey getPublic​()
      返回对此密钥对的公钥组件的引用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyPair

        public KeyPair​(PublicKey publicKey,
               PrivateKey privateKey)
        从给定的公钥和私钥构造一个密钥对。

        请注意，此构造函数仅存储对生成的密钥对中的公钥和私钥组件的引用。 这是安全的，因为Key对象是不可变的。

        参数
        publicKey - 公钥。
        privateKey - 私钥。

    • 方法详细信息

      • getPublic

        public PublicKey getPublic​()
        返回对此密钥对的公钥组件的引用。
        结果
        引用公钥。

      • getPrivate

        public PrivateKey getPrivate​()
        返回对此密钥对的私钥组件的引用。
        结果
        引用私钥。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyPairGenerator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyPairGenerator

  • java.lang.Object
    • java.security.KeyPairGeneratorSpi
      • java.security.KeyPairGenerator

  • public abstract class KeyPairGenerator
extends KeyPairGeneratorSpi
    KeyPairGenerator类用于生成公钥和私钥对。 密钥对生成器使用getInstance工厂方法（返回给定类的实例的静态方法）构造。

    用于特定算法的密钥对生成器创建可以与该算法一起使用的公钥/私钥对。 它还将算法特定的参数与生成的每个密钥相关联。

    生成密钥对的方式有两种：以算法无关的方式，并以算法特定的方式。 两者之间的唯一区别是对象的初始化：

    • 独立于算法的初始化

      所有密钥对生成器共享密钥大小和随机源的概念。 对于不同的算法来说，keyize被不同地解释（例如，在DSA算法的情况下，keysize对应于模数的长度）。 这个KeyPairGenerator类中有一个initialize方法，它接受这两个普遍共享的参数类型。 还有一个只需要一个keysize参数，并使用最高优先级的安装提供程序的SecureRandom实现作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，则使用系统提供的随机源。）

      由于在调用上述与算法无关的initialize方法时没有指定其他参数，因此提供者如何处理与每个密钥相关联的特定于算法的参数（如果有的话）。

      如果算法是DSA算法，并且keysize（模数大小）是p或2048，那么Sun提供商使用一组预计算值作为q和g参数。 如果模数大小不是上述值之一， Sun提供商将创建一组新的参数。 其他提供商可能具有超过上述模数大小的预计算参数集。 还有一些可能没有预先计算的参数的列表，而不是总是创建新的参数集。

    • 特定于算法的初始化

      对于已经存在一组特定于算法的参数（例如，DSA中所谓的社区参数 ）的情况，有两个initialize方法具有AlgorithmParameterSpec参数。 一个也有一个SecureRandom参数，而另一个使用最高优先级安装的提供者的SecureRandom实现作为随机的来源。 （如果没有一个已安装的提供商提供SecureRandom的实现，则使用系统提供的随机源。）

    如果客户端没有显式初始化KeyPairGenerator（通过调用initialize方法），则每个提供程序都必须提供（并记录）默认的初始化。 有关JDK提供程序使用的KeyPairGenerator默认值的信息，请参阅JDK Providers文档的Keysize Restriction部分。 不过，请注意，不同提供商的默认值可能会有所不同。 此外，提供者的默认值可能会在将来的版本中更改。 因此，建议明确地初始化KeyPairGenerator，而不是依赖于提供者特定的默认值。

    注意，这个类是抽象的，由于历史原因而从KeyPairGeneratorSpi扩展。 应用程序开发人员只应注意KeyPairGenerator类中定义的方法; 超类中的所有方法都适用于希望提供自己的密钥对生成器实现的加密服务提供商。

    Java平台的每个实现都需要支持以下标准的KeyPairGenerator算法，并在括号中键入：

    • DiffieHellman （ DiffieHellman ）
    • DSA （ DSA ）
    • RSA （ RSA ）
    这些算法在Java Security Standard算法名称规范的KeyPairGenerator section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.1
    另请参见：
    AlgorithmParameterSpec

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected KeyPairGenerator​(String algorithm)
      为指定的算法创建一个KeyPairGenerator对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      KeyPair generateKeyPair​()
      生成一个密钥对。
      KeyPair genKeyPair​()
      生成一个密钥对。
      String getAlgorithm​()
      返回此密钥对生成器的算法的标准名称。
      static KeyPairGenerator getInstance​(String algorithm)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      static KeyPairGenerator getInstance​(String algorithm, String provider)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      static KeyPairGenerator getInstance​(String algorithm, Provider provider)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      Provider getProvider​()
      返回此密钥对生成器对象的提供者。
      void initialize​(int keysize)
      使用默认参数集和最高优先级安装的提供程序的 SecureRandom实现来初始化密钥对生成器作为随机源。
      void initialize​(int keysize, SecureRandom random)
      使用给定的随机源（和默认参数集）初始化特定密钥大小的密钥对生成器。
      void initialize​(AlgorithmParameterSpec params)
      使用指定的参数集和最优先安装的提供程序的 SecureRandom实现来初始化密钥对生成器作为随机源。
      void initialize​(AlgorithmParameterSpec params, SecureRandom random)
      使用给定的参数集和随机源初始化密钥对生成器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyPairGenerator

        protected KeyPairGenerator​(String algorithm)
        为指定的算法创建一个KeyPairGenerator对象。
        参数
        algorithm - 算法的标准字符串名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyPairGenerator部分。

    • 方法详细信息

      • getAlgorithm

        public String getAlgorithm​()
        返回此密钥对生成器的算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyPairGenerator部分。
        结果
        算法的标准字符串名称。

      • getInstance

        public static KeyPairGenerator getInstance​(String algorithm)
                                    throws NoSuchAlgorithmException
        返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装KeyPairGeneratorSpi实现的新KeyPairGenerator对象。

        注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 算法的标准字符串名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyPairGenerator部分。
        结果
        新的 KeyPairGenerator对象
        异常
        NoSuchAlgorithmException - 如果没有 Provider支持指定算法的 KeyPairGeneratorSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static KeyPairGenerator getInstance​(String algorithm,
                                           String provider)
                                    throws NoSuchAlgorithmException,
                                           NoSuchProviderException
        返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。

        返回从指定提供程序封装KeyPairGeneratorSpi实现的新KeyPairGenerator对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        参数
        algorithm - 算法的标准字符串名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyPairGenerator部分。
        provider - 提供程序的字符串名称。
        结果
        新的 KeyPairGenerator对象
        异常
        IllegalArgumentException - 如果提供商名称为 null或为空
        NoSuchAlgorithmException - 如果指定算法的 KeyPairGeneratorSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static KeyPairGenerator getInstance​(String algorithm,
                                           Provider provider)
                                    throws NoSuchAlgorithmException
        返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。

        返回从指定的Provider对象封装KeyPairGeneratorSpi实现的新KeyPairGenerator对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 算法的标准字符串名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyPairGenerator部分。
        provider - 提供商。
        结果
        新的 KeyPairGenerator对象
        异常
        IllegalArgumentException - 如果指定的提供者是 null
        NoSuchAlgorithmException - 如果指定的算法的 KeyPairGeneratorSpi实现不能从指定的 Provider对象获得
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        1.4
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此密钥对生成器对象的提供者。
        结果
        这个密钥对生成器对象的提供者

      • initialize

        public void initialize​(int keysize)
        使用默认参数集和最高优先级安装提供程序的SecureRandom实现作为随机源，初始化某个密钥大小的密钥对生成器。 （如果没有一个已安装的提供商提供了一个SecureRandom的实现，则使用系统提供的随机源。）
        参数
        keysize - keysize 。 这是一种算法特定的度量，例如以位数指定的模数长度。
        异常
        InvalidParameterException - 如果此KeyPairGenerator对象不支持 keysize 。

      • initialize

        public void initialize​(int keysize,
                       SecureRandom random)
        使用给定的随机源（和默认参数集）初始化特定密钥大小的密钥对生成器。
        Specified by:
        initialize在 KeyPairGeneratorSpi
        参数
        keysize - keysize 。 这是一种算法特定的度量，例如以位数指定的模数长度。
        random - 随机的来源。
        异常
        InvalidParameterException - 如果此KeyPairGenerator对象不支持 keysize 。
        从以下版本开始：
        1.2

      • initialize

        public void initialize​(AlgorithmParameterSpec params)
                throws InvalidAlgorithmParameterException
        使用指定的参数集和最高优先级的安装提供程序的SecureRandom实现来初始化密钥对生成器作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，则使用系统提供的随机源。）

        这个具体的方法已经添加到这个以前定义的抽象类中。 该方法调用KeyPairGeneratorSpi initialize方法，传递它params和随机源（从最高优先级安装的提供程序或系统获得，如果没有一个已安装的提供程序提供一个）。 如果提供程序没有覆盖该initialize方法，则始终会抛出UnsupportedOperationException异常。

        参数
        params - 用于生成密钥的参数集。
        异常
        InvalidAlgorithmParameterException - 如果给定的参数不适合此密钥对生成器。
        从以下版本开始：
        1.2

      • initialize

        public void initialize​(AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidAlgorithmParameterException
        使用给定的参数集和随机源初始化密钥对生成器。

        这个具体的方法已经添加到这个以前定义的抽象类中。 此方法调用KeyPairGeneratorSpi initialize方法，传递给它params和random 。 那个initialize方法总是会抛出UnsupportedOperationException，如果它不被提供程序覆盖。

        重写：
        initialize在 KeyPairGeneratorSpi
        参数
        params - 用于生成密钥的参数集。
        random - 随机的来源。
        异常
        InvalidAlgorithmParameterException - 如果给定的参数不适合该密钥对生成器。
        从以下版本开始：
        1.2

      • genKeyPair

        public final KeyPair genKeyPair​()
        生成一个密钥对。

        如果此KeyPairGenerator尚未被显式初始化，则提供者特定的默认值将用于生成的密钥的大小和其他（算法特定）值。

        这将在每次调用时生成一个新的密钥对。

        此方法在功能上等同于generateKeyPair 。

        结果
        生成的密钥对
        从以下版本开始：
        1.2

      • generateKeyPair

        public KeyPair generateKeyPair​()
        生成一个密钥对。

        如果此KeyPairGenerator尚未被显式初始化，则提供者特定的默认值将用于生成的密钥的大小和其他（算法特定）值。

        这将在每次调用时生成一个新的密钥对。

        此方法在功能上相当于genKeyPair 。

        Specified by:
        generateKeyPair在 KeyPairGeneratorSpi
        结果
        生成的密钥对
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyPairGeneratorSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyPairGeneratorSpi

  • java.lang.Object
    • java.security.KeyPairGeneratorSpi
  • 已知直接子类：
    KeyPairGenerator

    public abstract class KeyPairGeneratorSpi
extends Object

    该类定义了KeyPairGenerator类的 （ SPI ），用于生成公钥和私钥对。

    该类中的所有抽象方法必须由希望提供特定算法的密钥对生成器的实现的每个加密服务提供商来实现。

    如果客户端没有显式初始化KeyPairGenerator（通过调用initialize方法），则每个提供程序都必须提供（并记录）默认的初始化。 有关JDK提供程序使用的KeyPairGenerator默认值的信息，请参阅JDK Providers文档的Keysize Restriction部分。 不过，请注意，不同提供商的默认值可能会有所不同。 此外，提供者的默认值可能会在将来的版本中更改。 因此，建议明确地初始化KeyPairGenerator，而不是依赖于提供者特定的默认值。

    从以下版本开始：
    1.2
    另请参见：
    KeyPairGenerator ， AlgorithmParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyPairGeneratorSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract KeyPair generateKeyPair​()
      生成一个密钥对。
      abstract void initialize​(int keysize, SecureRandom random)
      使用默认参数集初始化某个密钥对的密钥对生成器。
      void initialize​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化密钥对生成器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyPairGeneratorSpi

        public KeyPairGeneratorSpi​()

    • 方法详细信息

      • initialize

        public abstract void initialize​(int keysize,
                                SecureRandom random)
        使用默认参数集初始化某个密钥对的密钥对生成器。
        参数
        keysize - keysize 。 这是一种算法特定的度量，例如以位数指定的模数长度。
        random - 该发生器的随机性来源。
        异常
        InvalidParameterException - 如果此KeyPairGeneratorSpi对象不支持 keysize 。

      • initialize

        public void initialize​(AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidAlgorithmParameterException
        使用指定的参数集和用户提供的随机源初始化密钥对生成器。

        这个具体的方法已经添加到这个以前定义的抽象类中。 （为了向后兼容，它不能是抽象的。）提供者可以覆盖它来初始化密钥对生成器。 如果一个参数不适合这个密钥对生成器，这样的覆盖应该会抛出一个InvalidAlgorithmParameterException。 如果此方法未被覆盖，则会始终抛出UnsupportedOperationException异常。

        参数
        params - 用于生成密钥的参数集。
        random - 这个发电机的随机性来源。
        异常
        InvalidAlgorithmParameterException - 如果给定的参数不适合该密钥对生成器。
        从以下版本开始：
        1.2

      • generateKeyPair

        public abstract KeyPair generateKeyPair​()
        生成一个密钥对。 除非使用KeyPairGenerator接口调用初始化方法，否则将使用特定于算法的默认值。 这将在每次调用时生成一个新的密钥对。
        结果
        新生成的 KeyPair
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyRep (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyRep

  • java.lang.Object
    • java.security.KeyRep
  • All Implemented Interfaces:
    Serializable

    public class KeyRep
extends Object
implements Serializable
    序列化关键对象的标准化表示。

    请注意，序列化的密钥可能包含不应在不受信任的环境中暴露的敏感信息。 有关详细信息，请参阅序列化规范的Security Appendix 。

    从以下版本开始：
    1.5
    另请参见：
    Key ， KeyFactory ， SecretKeySpec ， X509EncodedKeySpec ， PKCS8EncodedKeySpec ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  KeyRep.Type
      钥匙类型

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyRep​(KeyRep.Type type, String algorithm, String format, byte[] encoded)
      构造备用Key类。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Object readResolve​()
      解决Key对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyRep

        public KeyRep​(KeyRep.Type type,
              String algorithm,
              String format,
              byte[] encoded)
        构造备用Key类。
        参数
        type - Type.SECRET，Type.PUBLIC或Type.PRIVATE
        algorithm - 从 Key.getAlgorithm()返回的算法
        format - 从 Key.getFormat()返回的编码格式
        encoded - 从 Key.getEncoded()返回的编码字节
        异常
        NullPointerException - 如果类型为 null ，如果算法为 null ，如果格式为 null ，或者编码为 null

    • 方法详细信息

      • readResolve

        protected Object readResolve​()
                      throws ObjectStreamException
        解决Key对象。

        此方法支持三种类型/格式组合：

        • Type.SECRET /“RAW” - 返回使用编码的关键字节和算法构造的SecretKeySpec对象
        • Type.PUBLIC /“X.509” - 获取密钥算法的KeyFactory实例，用编码的密钥字节构建一个X509EncodedKeySpec，并从规范中生成一个公钥
        • Type.PRIVATE /“PKCS＃8” - 获取密钥算法的KeyFactory实例，使用编码的密钥字节构建PKCS8EncodedKeySpec，并从规范中生成私钥
        结果
        解析的Key对象
        异常
        ObjectStreamException - 如果类型/格式组合无法识别，如果算法，密钥格式或编码密钥字节无法识别/无效，则如果密钥的分辨率由于任何原因失败
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyRep.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.security

Enum KeyRep.Type

  • java.lang.Object
    • java.lang.Enum<KeyRep.Type>
      • java.security.KeyRep.Type
  • All Implemented Interfaces:
    Serializable ， Comparable<KeyRep.Type>
    Enclosing class:
    KeyRep

    public static enum KeyRep.Type
extends Enum<KeyRep.Type>
    钥匙类型
    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      PRIVATE
      键入私钥。
      PUBLIC
      输入公钥。
      SECRET
      键入密钥。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static KeyRep.Type valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static KeyRep.Type[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SECRET

        public static final KeyRep.Type SECRET
        键入密钥。

      • PUBLIC

        public static final KeyRep.Type PUBLIC
        输入公钥。

      • PRIVATE

        public static final KeyRep.Type PRIVATE
        键入私钥。

    • 方法详细信息

      • values

        public static KeyRep.Type[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (KeyRep.Type c : KeyRep.Type.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static KeyRep.Type valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


KeyStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyStore

  • java.lang.Object
    • java.security.KeyStore

  • public class KeyStore
extends Object
    该类代表加密密钥和证书的存储设备。

    A KeyStore管理不同类型的条目。 每种类型的条目实现KeyStore.Entry接口。 提供了三个基本的KeyStore.Entry实现：

    • KeyStore.PrivateKeyEntry

      这种类型的条目保存加密PrivateKey ，其可选地以受保护的格式存储以防止未经授权的访问。 还附有相应公钥的证书链。

      私钥和证书链由给定实体用于自身认证。 用于此认证的应用程序包括在发布和/或许可软件时签署JAR文件的软件分发机构。

    • KeyStore.SecretKeyEntry

      这种类型的条目保存加密SecretKey ，其可选地以受保护的格式存储以防止未经授权的访问。

    • KeyStore.TrustedCertificateEntry

      这种类型的条目包含属于另一方的单个公钥Certificate 。 它被称为可信证书，因为密钥库所有者信任证书中的公钥确实属于由证书的主体 （所有者）标识的身份。

      这种类型的条目可用于验证其他方。

    密钥库中的每个条目都由“别名”字符串标识。 在私钥及其关联的证书链的情况下，这些字符串区分实体可以自己认证的不同方式。 例如，实体可以使用不同的证书颁发机构或使用不同的公钥算法对其进行身份验证。

    别名区分大小写是否依赖于实现。 为了避免出现问题，建议不要在KeyStore中使用只有不同的别名。

    密钥库是否是持久的，如果密钥库是持久的，则使用密钥库的机制，这里没有指定。 这允许使用各种技术来保护敏感（例如，私人或秘密）密钥。 智能卡或其他集成的加密引擎（SafeKeyper）是一种选择，也可以使用诸如文件的更简单的机制（以各种格式）。

    请求KeyStore对象的典型方法包括指定现有密钥库文件，依赖于默认类型并提供特定的密钥库类型。

    • 指定现有密钥库文件：
        // get keystore password
    char[] password = getPassword();

    // probe the keystore file and load the keystore entries
    KeyStore ks = KeyStore.getInstance(new File("keyStoreName"), password);
      系统将探测指定的文件以确定其密钥库类型，并返回其加载条目的密钥库实现。 当使用这种方法时，不需要调用密钥库的load方法。
    • 要依靠默认类型：
        KeyStore ks = KeyStore.getInstance(KeyStore.getDefaultType());
      系统将返回默认类型的密钥库实现。
    • 提供特定的密钥库类型：
        KeyStore ks = KeyStore.getInstance("JKS");
      系统将返回在环境中可用的指定密钥库类型的最优选实现。

    在可以访问密钥库之前，它必须是loaded （除非在实例化期间已经加载）。

      KeyStore ks = KeyStore.getInstance(KeyStore.getDefaultType());

    // get user password and file input stream
    char[] password = getPassword();

    try (FileInputStream fis = new FileInputStream("keyStoreName")) {
        ks.load(fis, password);
    }
    要使用上述load方法创建一个空密钥库，请通过null作为InputStream参数。

    一旦加载了密钥库，就可以从密钥库中读取现有条目，或者将新条目写入密钥库中：

      KeyStore.ProtectionParameter protParam =
        new KeyStore.PasswordProtection(password);

    // get my private key
    KeyStore.PrivateKeyEntry pkEntry = (KeyStore.PrivateKeyEntry)
        ks.getEntry("privateKeyAlias", protParam);
    PrivateKey myPrivateKey = pkEntry.getPrivateKey();

    // save my secret key
    javax.crypto.SecretKey mySecretKey;
    KeyStore.SecretKeyEntry skEntry =
        new KeyStore.SecretKeyEntry(mySecretKey);
    ks.setEntry("secretKeyAlias", skEntry, protParam);

    // store away the keystore
    try (FileOutputStream fos = new FileOutputStream("newKeyStoreName")) {
        ks.store(fos, password);
    }
    请注意，虽然可以使用相同的密码来加载密钥库，以保护私钥条目，保护密钥条目，并存储密钥库（如上面的示例代码所示），不同的密码或其他保护参数也可以使用。

    Java平台的每个实现都需要支持以下标准KeyStore类型：

    • PKCS12
    这种类型在Java安全标准算法名称规范的KeyStore section中进行了描述。 请参阅发行说明文件以了解是否支持其他类型。
    从以下版本开始：
    1.2
    另请参见：
    PrivateKey ， SecretKey ， Certificate

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  KeyStore.Builder
      要实例化的KeyStore对象的描述。
      static class  KeyStore.CallbackHandlerProtection
      一个封装CallbackHandler的ProtectionParameter。
      static interface  KeyStore.Entry
      KeyStore条目类型的标记界面。
      static interface  KeyStore.LoadStoreParameter
      KeyStore load和 store参数的标记界面。
      static class  KeyStore.PasswordProtection
      基于密码的实现 ProtectionParameter 。
      static class  KeyStore.PrivateKeyEntry
      一个 KeyStore条目，其中包含一个 PrivateKey和相应的证书链。
      static interface  KeyStore.ProtectionParameter
      用于密钥库保护参数的标记界面。
      static class  KeyStore.SecretKeyEntry
      A KeyStore条目，其中包含一个 SecretKey 。
      static class  KeyStore.TrustedCertificateEntry
      A KeyStore条目，其中包含受信任的 Certificate 。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected KeyStore​(KeyStoreSpi keyStoreSpi, Provider provider, String type)
      创建给定类型的KeyStore对象，并封装给定的提供者实现（SPI对象）。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Enumeration<String> aliases​()
      列出此密钥库的所有别名。
      boolean containsAlias​(String alias)
      检查此密钥库中是否存在给定的别名。
      void deleteEntry​(String alias)
      从此密钥库中删除由给定别名标识的条目。
      boolean entryInstanceOf​(String alias, Class<? extends KeyStore.Entry> entryClass)
      确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
      Certificate getCertificate​(String alias)
      返回与给定别名相关联的证书。
      String getCertificateAlias​(Certificate cert)
      返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。
      Certificate[] getCertificateChain​(String alias)
      返回与给定别名关联的证书链。
      Date getCreationDate​(String alias)
      返回由给定别名标识的条目的创建日期。
      static String getDefaultType​()
      返回由 keystore.type安全属性指定的默认密钥库类型，或者如果没有这样的属性，则返回字符串“jks”（“Java密钥库”的缩写）。
      KeyStore.Entry getEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的密钥库 Entry 。
      static KeyStore getInstance​(File file, char[] password)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore getInstance​(File file, KeyStore.LoadStoreParameter param)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore getInstance​(String type)
      返回指定类型的密钥库对象。
      static KeyStore getInstance​(String type, String provider)
      返回指定类型的密钥库对象。
      static KeyStore getInstance​(String type, Provider provider)
      返回指定类型的密钥库对象。
      Key getKey​(String alias, char[] password)
      返回与给定别名相关联的密钥，使用给定的密码恢复它。
      Provider getProvider​()
      返回此密钥库的提供者。
      String getType​()
      返回此密钥库的类型。
      boolean isCertificateEntry​(String alias)
      如果给定别名标识的条目是通过调用 setCertificateEntry创建的，或者通过调用 setEntry与 TrustedCertificateEntry创建的条目，则返回true。
      boolean isKeyEntry​(String alias)
      如果给定别名标识的条目是通过调用创建返回true setKeyEntry ，或者创建通过调用 setEntry与 PrivateKeyEntry或者 SecretKeyEntry 。
      void load​(InputStream stream, char[] password)
      从给定的输入流加载此KeyStore。
      void load​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter加载此密钥库。
      void setCertificateEntry​(String alias, Certificate cert)
      将给定的可信证书分配给给定的别名。
      void setEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
      在指定的别名下保存密钥库 Entry 。
      void setKeyEntry​(String alias, byte[] key, Certificate[] chain)
      将给定的密钥（已经被保护）分配给给定的别名。
      void setKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)
      将给定的密钥分配给给定的别名，并使用给定的密码进行保护。
      int size​()
      检索此密钥库中的条目数。
      void store​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void store​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter存储此密钥库。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyStore

        protected KeyStore​(KeyStoreSpi keyStoreSpi,
                   Provider provider,
                   String type)
        创建给定类型的KeyStore对象，并封装给定的提供者实现（SPI对象）。
        参数
        keyStoreSpi - 提供者实现。
        provider - 提供商。
        type - 密钥库类型。

    • 方法详细信息

      • getInstance

        public static KeyStore getInstance​(String type)
                            throws KeyStoreException
        返回指定类型的密钥库对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定类型的第一个Provider中封装KeyStoreSpi实现的新KeyStore对象。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        type - 密钥库的类型。 有关标准密钥库类型的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyStore部分。
        结果
        指定类型的密钥库对象
        异常
        KeyStoreException - 如果否 Provider支持指定类型的 KeyStoreSpi实现
        NullPointerException - 如果 type是 null
        另请参见：
        Provider

      • getInstance

        public static KeyStore getInstance​(String type,
                                   String provider)
                            throws KeyStoreException,
                                   NoSuchProviderException
        返回指定类型的密钥库对象。

        返回从指定提供程序封装KeyStoreSpi实现的新KeyStore对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        参数
        type - 密钥库的类型。 有关标准密钥库类型的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyStore部分。
        provider - 提供者的名称。
        结果
        指定类型的密钥库对象
        异常
        IllegalArgumentException - 如果提供商名称为 null或为空
        KeyStoreException - 如果指定类型的 KeyStoreSpi实现不能从指定的提供者
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException -如果 type为 null
        另请参见：
        Provider

      • getInstance

        public static KeyStore getInstance​(String type,
                                   Provider provider)
                            throws KeyStoreException
        返回指定类型的密钥库对象。

        返回从指定的Provider对象封装KeyStoreSpi实现的新KeyStore对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        type - 密钥库的类型。 有关标准密钥库类型的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyStore部分。
        provider - 提供商。
        结果
        指定类型的密钥库对象
        异常
        IllegalArgumentException - 如果指定的提供者是 null
        KeyStoreException - 如果指定类型的 KeyStoreSpi实现从指定的 Provider对象不可用
        NullPointerException - 如果 type是 null
        从以下版本开始：
        1.4
        另请参见：
        Provider

      • getDefaultType

        public static final String getDefaultType​()
        返回由keystore.type security属性指定的默认密钥库类型，或者如果没有这样的属性，则返回字符串“jks”（“Java keystore”的缩写）。

        默认密钥库类型可以由不想使用硬编码密钥库类型的应用程序使用，当调用其中一个getInstance方法时，如果用户未指定自己的密钥库类型，则希望提供默认的密钥库类型。

        通过将keystore.type安全属性的值设置为所需的密钥库类型，可以更改默认密钥库类型。

        结果
        由 keystore.type安全属性指定的默认密钥仓库类型，如果没有此类属性，则为字符串“jks”。
        另请参见：
        security properties

      • getProvider

        public final Provider getProvider​()
        返回此密钥库的提供者。
        结果
        这个密钥库的提供者。

      • getType

        public final String getType​()
        返回此密钥库的类型。
        结果
        这个密钥库的类型。

      • getKey

        public final Key getKey​(String alias,
                        char[] password)
                 throws KeyStoreException,
                        NoSuchAlgorithmException,
                        UnrecoverableKeyException
        返回与给定别名相关联的密钥，使用给定的密码恢复它。 密钥必须已经通过调用别名关联到setKeyEntry ，或者通过将呼叫setEntry与PrivateKeyEntry或者SecretKeyEntry 。
        参数
        alias - 别名
        password - 恢复密钥的密码
        结果
        请求的密钥，如果给定的别名不存在或不标识与密钥相关的条目，则为null。
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。
        NoSuchAlgorithmException - 如果无法找到恢复密钥的算法
        UnrecoverableKeyException - 如果密钥无法恢复（例如，给定的密码错误）。

      • getCertificateChain

        public final Certificate[] getCertificateChain​(String alias)
                                        throws KeyStoreException
        返回与给定别名关联的证书链。 证书链必须已经通过调用setKeyEntry与别名相关联，或通过调用setEntry与PrivateKeyEntry 。
        参数
        alias - 别名
        结果
        证书链（以用户的证书首先跟随着零个或多个证书颁发机构排序），如果给定的别名不存在或不包含证书链，则为null
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。

      • getCertificate

        public final Certificate getCertificate​(String alias)
                                 throws KeyStoreException
        返回与给定别名相关联的证书。

        如果给定的别名标识了通过调用setCertificateEntry创建的条目，或通过调用setEntry与TrustedCertificateEntry创建的条目，则返回该条目中包含的受信任证书。

        如果给定的别名标识由setKeyEntry的调用创建的条目，或通过调用setEntry与PrivateKeyEntry创建的条目，则返回该条目中证书链的第一个元素。

        参数
        alias - 别名
        结果
        证书，如果给定的别名不存在或不包含证书，则为null。
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。

      • getCreationDate

        public final Date getCreationDate​(String alias)
                           throws KeyStoreException
        返回由给定别名标识的条目的创建日期。
        参数
        alias - 别名
        结果
        此条目的创建日期，如果给定的别名不存在，则为null
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。

      • setKeyEntry

        public final void setKeyEntry​(String alias,
                              Key key,
                              char[] password,
                              Certificate[] chain)
                       throws KeyStoreException
        将给定的密钥分配给给定的别名，并使用给定的密码进行保护。

        如果给定的密钥是类型为java.security.PrivateKey ，则必须附有一个证书链，证明相应的公钥。

        如果给定的别名已经存在，与它相关联的密钥库信息将被给定的密钥（也可能是证书链）覆盖。

        参数
        alias - 别名
        key - 与别名关联的关键
        password - 密码保护密钥
        chain - 相应公钥的证书链（仅当给定键为 java.security.PrivateKey类型 java.security.PrivateKey ）。
        异常
        KeyStoreException - 如果密钥存储库尚未初始化（加载），则给定的密钥不能被保护，或者由于其他原因导致该操作失败

      • setKeyEntry

        public final void setKeyEntry​(String alias,
                              byte[] key,
                              Certificate[] chain)
                       throws KeyStoreException
        将给定的密钥（已经被保护）分配给给定的别名。

        如果受保护的密钥是java.security.PrivateKey型，则必须附有一个证书链，证明相应的公钥。 如果基础密钥库实现类型为jks ，则key必须编码为PKCS＃8标准中定义的EncryptedPrivateKeyInfo 。

        如果给定的别名已经存在，与它相关联的密钥库信息将被给定的密钥（也可能是证书链）覆盖。

        参数
        alias - 别名
        key - 与别名关联的密钥（以受保护的格式）
        chain - 相应公钥的证书链（仅当受保护的密钥为 java.security.PrivateKey类型时才有用）。
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载），或者由于其他原因导致此操作失败。

      • setCertificateEntry

        public final void setCertificateEntry​(String alias,
                                      Certificate cert)
                               throws KeyStoreException
        将给定的可信证书分配给给定的别名。

        如果给定的别名标识通过调用创建现有条目setCertificateEntry ，或者创建通过调用setEntry与TrustedCertificateEntry ，在现有条目中的可信证书被给定证书重写。

        参数
        alias - 别名
        cert - 证书
        异常
        KeyStoreException - 如果密钥库尚未初始化，或者给定的别名已经存在，并且不标识包含受信任证书的条目，否则此操作由于某些其他原因而失败。

      • deleteEntry

        public final void deleteEntry​(String alias)
                       throws KeyStoreException
        从此密钥库中删除由给定别名标识的条目。
        参数
        alias - 别名
        异常
        KeyStoreException - 如果密钥库尚未初始化，或者条目无法删除。

      • aliases

        public final Enumeration<String> aliases​()
                                  throws KeyStoreException
        列出此密钥库的所有别名。
        结果
        枚举别名
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。

      • containsAlias

        public final boolean containsAlias​(String alias)
                            throws KeyStoreException
        检查此密钥库中是否存在给定的别名。
        参数
        alias - 别名
        结果
        如果别名存在则为true，否则为false
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。

      • size

        public final int size​()
               throws KeyStoreException
        检索此密钥库中的条目数。
        结果
        此密钥库中的条目数
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。

      • isKeyEntry

        public final boolean isKeyEntry​(String alias)
                         throws KeyStoreException
        如果由给定别名标识的条目是通过调用 setKeyEntry创建的，或通过调用 setEntry与 PrivateKeyEntry或 SecretKeyEntry创建的条目，则返回true。
        参数
        alias - 要检查的密钥库条目的别名
        结果
        如果给定别名标识的条目是与密钥相关的条目，则为true，否则为false。
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。

      • isCertificateEntry

        public final boolean isCertificateEntry​(String alias)
                                 throws KeyStoreException
        如果给定别名标识的条目是通过调用 setCertificateEntry创建的，或者通过调用 setEntry与 TrustedCertificateEntry创建的条目，则返回true。
        参数
        alias - 要检查密钥库条目的别名
        结果
        如果给定别名标识的条目包含受信任的证书，则为true，否则为false。
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。

      • getCertificateAlias

        public final String getCertificateAlias​(Certificate cert)
                                 throws KeyStoreException
        返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。

        此方法尝试将给定证书与每个密钥库条目相匹配。 如果考虑的条目是通过调用setCertificateEntry创建的，或者通过调用setEntry与TrustedCertificateEntry ，则将给定的证书与该条目的证书进行比较。

        如果考虑的条目是通过调用setKeyEntry创建的，或者通过调用setEntry与PrivateKeyEntry ，则将给定的证书与该条目的证书链的第一个元素进行比较。

        参数
        cert - 证书匹配。
        结果
        具有匹配证书的第一个条目的别名，如果此密钥库中没有此类条目，则为null。
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。

      • store

        public final void store​(OutputStream stream,
                        char[] password)
                 throws KeyStoreException,
                        IOException,
                        NoSuchAlgorithmException,
                        CertificateException
        将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
        参数
        stream - 写入此密钥库的输出流。
        password - 生成密钥库完整性检查的密码
        异常
        KeyStoreException - 如果密钥库尚未初始化（加载）。
        IOException - 如果数据有I / O问题
        NoSuchAlgorithmException - 如果 NoSuchAlgorithmException适当的数据完整性算法
        CertificateException - 如果密钥库数据中包含的任何证书无法存储

      • store

        public final void store​(KeyStore.LoadStoreParameter param)
                 throws KeyStoreException,
                        IOException,
                        NoSuchAlgorithmException,
                        CertificateException
        使用给定的 LoadStoreParameter存储此密钥库。
        参数
        param -在 LoadStoreParameter指定如何存储密钥库，这可能是 null
        异常
        IllegalArgumentException - 如果给定的 LoadStoreParameter输入未被识别
        KeyStoreException - 如果密钥存储库尚未初始化（加载）
        IOException - 如果数据存在I / O问题
        NoSuchAlgorithmException - 如果 NoSuchAlgorithmException适当的数据完整性算法
        CertificateException - 如果密钥库数据中包含的任何证书无法存储
        从以下版本开始：
        1.5

      • load

        public final void load​(InputStream stream,
                       char[] password)
                throws IOException,
                       NoSuchAlgorithmException,
                       CertificateException
        从给定的输入流加载此KeyStore。

        可以提供密码来解锁密钥库（例如，密钥库驻留在硬件令牌设备上），或者检查密钥库数据的完整性。 如果没有为完整性检查提供密码，则不执行完整性检查。

        为了创建一个空的密钥库，或者如果密钥库不能从流初始化，请传递null作为stream参数。

        请注意，如果此密钥库已经加载，则会从给定的输入流重新初始化并加载该密钥库。

        参数
        stream - 加载密钥库的输入流，或 null
        password - 用于检查密钥库完整性的密码，用于解锁密钥仓库的密码，或 null
        异常
        IOException - 如果密钥库数据存在I / O或格式问题，如果需要密码但未提供密码，或者给定的密码不正确。 如果错误是由于错误的密码， IOException的IOException应该是一个UnrecoverableKeyException
        NoSuchAlgorithmException - 如果用于检查密钥库完整性的算法无法找到
        CertificateException - 如果密钥库中的任何证书无法加载

      • load

        public final void load​(KeyStore.LoadStoreParameter param)
                throws IOException,
                       NoSuchAlgorithmException,
                       CertificateException
        使用给定的LoadStoreParameter加载此密钥库。

        请注意，如果此KeyStore已经加载，它将从给定的参数重新初始化并重新加载。

        参数
        param -所述 LoadStoreParameter指定如何加载密钥库，其可以是 null
        异常
        IllegalArgumentException - 如果给定的 LoadStoreParameter输入未被识别
        IOException - 如果存在密钥库数据的I / O或格式问题。 如果错误是由于不正确的ProtectionParameter （如密码错误）的cause的的IOException应该是UnrecoverableKeyException
        NoSuchAlgorithmException - 如果用于检查密钥库的完整性的算法无法找到
        CertificateException - 如果密钥库中的任何证书无法加载
        从以下版本开始：
        1.5

      • getEntry

        public final KeyStore.Entry getEntry​(String alias,
                                     KeyStore.ProtectionParameter protParam)
                              throws NoSuchAlgorithmException,
                                     UnrecoverableEntryException,
                                     KeyStoreException
        使用指定的保护参数获取指定别名的密钥库 Entry 。
        参数
        alias - 获取此别名的密钥库 Entry
        protParam - ProtectionParameter用于保护 Entry ，可能是 null
        结果
        Entry为指定的别名，或 null如果没有这样的条目
        异常
        NullPointerException - 如果 alias是 null
        NoSuchAlgorithmException - 如果 NoSuchAlgorithmException用于恢复条目的算法
        UnrecoverableEntryException - 如果指定的 protParam不足或无效
        UnrecoverableKeyException - 如果条目是 PrivateKeyEntry或 SecretKeyEntry ，并且指定的 protParam不包含恢复密钥所需的信息（例如错误的密码）
        KeyStoreException - 如果密钥库尚未初始化（加载）。
        从以下版本开始：
        1.5
        另请参见：
        setEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter)

      • setEntry

        public final void setEntry​(String alias,
                           KeyStore.Entry entry,
                           KeyStore.ProtectionParameter protParam)
                    throws KeyStoreException
        在指定的别名下保存密钥库Entry 。 保护参数用于保护Entry 。

        如果指定别名的条目已存在，则会被覆盖。

        参数
        alias - 将密钥库 Entry在此别名下的 Entry
        entry - 要保存的 Entry
        protParam - ProtectionParameter用于保护 Entry ，其中可能是 null
        异常
        NullPointerException - 如果是 alias或 entry是 null
        KeyStoreException - 如果密钥库尚未初始化（加载），或者由于其他原因导致此操作失败
        从以下版本开始：
        1.5
        另请参见：
        getEntry(String, KeyStore.ProtectionParameter)

      • entryInstanceOf

        public final boolean entryInstanceOf​(String alias,
                                     Class<? extends KeyStore.Entry> entryClass)
                              throws KeyStoreException
        确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
        参数
        alias - 别名
        entryClass - 入门课
        结果
        如果指定的 alias的密钥库 Entry是指定的 alias的实例或子类， entryClass true，否则为false
        异常
        NullPointerException - 如果 alias或 entryClass是 null
        KeyStoreException - 如果密钥库尚未初始化（加载）
        从以下版本开始：
        1.5

      • getInstance

        public static final KeyStore getInstance​(File file,
                                         char[] password)
                                  throws KeyStoreException,
                                         IOException,
                                         NoSuchAlgorithmException,
                                         CertificateException
        返回相应密钥库类型的加载密钥库对象。 首先，通过探测指定的文件确定密钥库类型。 然后使用该文件中的数据实例化和加载密钥库对象。

        可以提供密码来解锁密钥库（例如，密钥库驻留在硬件令牌设备上），或者检查密钥库数据的完整性。 如果没有为完整性检查提供密码，则不执行完整性检查。

        此方法遍历已注册的安全性列表providers ，从最优选的提供程序开始。 对于由Provider提供的每个KeyStoreSpi实现，它将调用engineProbe方法来确定它是否支持指定的密钥库。 返回一个新的KeyStore对象，它从支持指定文件的第一个Provider中封装KeyStoreSpi实现。

        注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        参数
        file - 密钥库文件
        password - 密钥库密码，可能是 null
        结果
        加载了密钥库数据的密钥库对象
        异常
        KeyStoreException - 如果没有提供者支持指定密钥库文件的KeyStoreSpi实现。
        IOException - 如果密钥库数据存在I / O或格式问题，如果需要密码但未提供密码，或者给定的密码不正确。 如果错误是由于错误的密码， cause的IOException应为UnrecoverableKeyException 。
        NoSuchAlgorithmException - 如果用于检查密钥库的完整性的算法无法找到。
        CertificateException - 如果密钥库中的任何证书无法加载。
        IllegalArgumentException - 如果文件不存在或不引用正常文件。
        NullPointerException - 如果文件是 null 。
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(java.io.FileDescriptor)方法拒绝对指定文件的读取访问。
        从以下版本开始：
        9
        另请参见：
        Provider

      • getInstance

        public static final KeyStore getInstance​(File file,
                                         KeyStore.LoadStoreParameter param)
                                  throws KeyStoreException,
                                         IOException,
                                         NoSuchAlgorithmException,
                                         CertificateException
        返回相应密钥库类型的加载密钥库对象。 首先，通过探测指定的文件确定密钥库类型。 然后使用该文件中的数据实例化和加载密钥库对象。 可以提供A LoadStoreParameter ，其指定如何解锁密钥仓库数据或执行完整性检查。

        该方法从最优先的提供程序开始，遍历注册安全性列表providers 。 对于由Provider提供的每个KeyStoreSpi实现，它将调用engineProbe方法来确定它是否支持指定的密钥库。 返回一个新的KeyStore对象，它从支持指定文件的第一个Provider中封装KeyStoreSpi实现。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        参数
        file - 密钥库文件
        param -所述 LoadStoreParameter指定如何加载密钥库，其可以是 null
        结果
        加载了密钥库数据的密钥库对象
        异常
        KeyStoreException - 如果没有提供程序支持指定密钥库文件的KeyStoreSpi实现。
        IOException - 如果存在密钥库数据的I / O或格式问题。 如果错误是由于ProtectionParameter （例如错误的密码） 造成的， IOException应为UnrecoverableKeyException 。
        NoSuchAlgorithmException - 如果用于检查密钥库的完整性的算法无法找到。
        CertificateException - 如果密钥库中的任何证书无法加载。
        IllegalArgumentException - 如果文件不存在或不引用正常文件，或者如果无法识别参数。
        NullPointerException - 如果文件是 null 。
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkRead(java.io.FileDescriptor)方法拒绝对指定文件的读取访问。
        从以下版本开始：
        9
        另请参见：
        Provider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyStore.Builder

  • java.lang.Object
    • java.security.KeyStore.Builder
  • Enclosing class:
    KeyStore

    public abstract static class KeyStore.Builder
extends Object
    要实例化的KeyStore对象的描述。

    此类的实例封装了实例化和初始化KeyStore对象所需的信息。 当调用getKeyStore()方法时，会触发该进程。

    这使得可以将配置从KeyStore对象创建中解耦，例如延迟密码提示直到需要。

    从以下版本开始：
    1.5
    另请参见：
    KeyStore ， KeyStoreBuilderParameters

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Builder​()
      构建新的Builder。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract KeyStore getKeyStore​()
      返回此对象描述的KeyStore。
      abstract KeyStore.ProtectionParameter getProtectionParameter​(String alias)
      返回应用于获取给定别名的Entry的ProtectionParameters。
      static KeyStore.Builder newInstance​(File file, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder newInstance​(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder newInstance​(String type, Provider provider, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder newInstance​(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter)
      返回封装给定KeyStore的新Builder。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Builder

        protected Builder​()
        构建新的Builder。

    • 方法详细信息

      • getKeyStore

        public abstract KeyStore getKeyStore​()
                              throws KeyStoreException
        返回此对象描述的KeyStore。
        结果
        这个对象描述的 KeyStore
        异常
        KeyStoreException - 如果在操作期间发生错误，例如，如果KeyStore无法实例化或加载

      • getProtectionParameter

        public abstract KeyStore.ProtectionParameter getProtectionParameter​(String alias)
                                                             throws KeyStoreException
        返回应用于获取给定别名的Entry的ProtectionParameters。 在调用此方法之前，必须调用getKeyStore方法。
        参数
        alias - KeyStore条目的别名
        结果
        应使用ProtectionParameters获取给定别名的Entry 。
        异常
        NullPointerException - 如果别名为空
        KeyStoreException - 操作过程中是否发生错误
        IllegalStateException - 如果在调用此方法之前尚未调用getKeyStore方法

      • newInstance

        public static KeyStore.Builder newInstance​(KeyStore keyStore,
                                           KeyStore.ProtectionParameter protectionParameter)
        返回封装给定KeyStore的新Builder。 该getKeyStore()返回对象的方法将返回keyStore ，该getProtectionParameter()方法将返回protectionParameters 。

        如果现有的KeyStore对象需要与基于Builder的API一起使用，这将非常有用。

        参数
        keyStore - 要封装的KeyStore
        protectionParameter - 用于保护KeyStore条目的ProtectionParameter
        结果
        一个新的Builder对象
        异常
        NullPointerException - 如果keyStore或protectParameters为空
        IllegalArgumentException - 如果keyStore尚未初始化

      • newInstance

        public static KeyStore.Builder newInstance​(String type,
                                           Provider provider,
                                           File file,
                                           KeyStore.ProtectionParameter protection)
        返回一个新的Builder对象。

        在返回的构建器上首次调用getKeyStore()方法将创建一个类型为type的KeyStore，并调用其load()方法。 inputStream参数是由file 。 如果protection是PasswordProtection ，则通过调用getPassword方法获得密码。 否则，如果protection为CallbackHandlerProtection ，则通过调用CallbackHandler获取密码。

        后续调用getKeyStore()返回与初始调用相同的对象。 如果初始调用失败并带有KeyStoreException，后续调用也会引发KeyStoreException。

        KeyStore如果非空，则从provider实例化。 否则，将搜索所有安装的提供程序。

        调用getProtectionParameter()将返回一个封装用于调用load方法的密码的PasswordProtection对象。

        请注意 ， getKeyStore()方法是在调用此方法的代码的AccessControlContext内执行的。

        参数
        type - 要构建的KeyStore的类型
        provider - 要从中将实例化KeyStore的提供者（或null）
        file - 包含KeyStore数据的文件
        protection - 保护KeyStore数据的ProtectionParameter
        结果
        一个新的Builder对象
        异常
        NullPointerException - 如果类型，文件或保护为空
        IllegalArgumentException - 如果保护不是PasswordProtection或CallbackHandlerProtection的实例; 或者如果文件不存在或不引用普通文件

      • newInstance

        public static KeyStore.Builder newInstance​(File file,
                                           KeyStore.ProtectionParameter protection)
        返回一个新的Builder对象。

        在返回的构建器上首次调用getKeyStore()方法将使用file创建一个KeyStore，以检测密钥库类型，然后调用其load()方法。 它使用相同的算法来确定密钥库类型，如KeyStore.getInstance(File, LoadStoreParameter)中所述 。 inputStream参数是由file 。 如果protection是PasswordProtection ，密码是通过调用getPassword方法获得的。 否则，如果protection为CallbackHandlerProtection ，则通过调用CallbackHandler获取密码。

        后续调用getKeyStore()返回与初始调用相同的对象。 如果初始调用失败并带有KeyStoreException，后续调用也会引发KeyStoreException。

        调用getProtectionParameter()将返回一个封装用于调用load方法的密码的PasswordProtection对象。

        请注意 ， getKeyStore()方法是在调用此方法的代码的AccessControlContext内执行的。

        参数
        file - 包含KeyStore数据的文件
        protection - 保护KeyStore数据的ProtectionParameter
        结果
        一个新的Builder对象
        异常
        NullPointerException - 如果文件或保护为空
        IllegalArgumentException - 如果保护不是PasswordProtection或CallbackHandlerProtection的实例; 或者如果文件不存在或不引用普通文件
        从以下版本开始：
        9

      • newInstance

        public static KeyStore.Builder newInstance​(String type,
                                           Provider provider,
                                           KeyStore.ProtectionParameter protection)
        返回一个新的Builder对象。

        每次调用返回的构建器上的getKeyStore()方法将返回一个新的KeyStore对象，类型为type 。 其load()方法使用封装protection的LoadStoreParameter调用。

        如果非空，KeyStore从provider实例化。 否则，将搜索所有安装的提供程序。

        致电getProtectionParameter()将返回protection 。

        请注意 ， getKeyStore()方法在调用此方法的代码的AccessControlContext内执行。

        参数
        type - 要构建的KeyStore的类型
        provider - 要从其中实例化KeyStore的提供者（或为空）
        protection - 保护密钥库的ProtectionParameter
        结果
        一个新的Builder对象
        异常
        NullPointerException - 如果类型或保护为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.CallbackHandlerProtection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyStore.CallbackHandlerProtection

  • java.lang.Object
    • java.security.KeyStore.CallbackHandlerProtection
  • All Implemented Interfaces:
    KeyStore.ProtectionParameter
    Enclosing class:
    KeyStore

    public static class KeyStore.CallbackHandlerProtection
extends Object
implements KeyStore.ProtectionParameter
    一个封装CallbackHandler的ProtectionParameter。
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      CallbackHandlerProtection​(CallbackHandler handler)
      从CallbackHandler构造一个新的CallbackHandlerProtection。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CallbackHandler getCallbackHandler​()
      返回CallbackHandler。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CallbackHandlerProtection

        public CallbackHandlerProtection​(CallbackHandler handler)
        从CallbackHandler构造一个新的CallbackHandlerProtection。
        参数
        handler - CallbackHandler
        异常
        NullPointerException - 如果处理程序为空

    • 方法详细信息

      • getCallbackHandler

        public CallbackHandler getCallbackHandler​()
        返回CallbackHandler。
        结果
        CallbackHandler。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.Entry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface KeyStore.Entry

  • 所有已知实现类：
    KeyStore.PrivateKeyEntry ， KeyStore.SecretKeyEntry ， KeyStore.TrustedCertificateEntry
    Enclosing class:
    KeyStore

    public static interface KeyStore.Entry
    KeyStore条目类型的标记界面。
    从以下版本开始：
    1.5

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  KeyStore.Entry.Attribute
      与密钥库条目关联的属性。

    • 方法摘要

      所有方法 接口方法 Default Methods
      Modifier and Type 方法 描述
      default Set<KeyStore.Entry.Attribute> getAttributes​()
      检索与条目关联的属性。

    • 方法详细信息

      • getAttributes

        default Set<KeyStore.Entry.Attribute> getAttributes​()
        检索与条目关联的属性。
        实现要求：
        默认实现返回一个空的 Set 。
        结果
        一个不可修改的属性 Set ，可能是空的
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.Entry.Attribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface KeyStore.Entry.Attribute

  • 所有已知实现类：
    PKCS12Attribute
    Enclosing interface:
    KeyStore.Entry

    public static interface KeyStore.Entry.Attribute
    与密钥库条目关联的属性。 它包含一个名称和一个或多个值。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getName​()
      返回属性的名称。
      String getValue​()
      返回属性的值。

    • 方法详细信息

      • getName

        String getName​()
        返回属性的名称。
        结果
        属性名称

      • getValue

        String getValue​()
        返回属性的值。 多值属性将其值作为单个字符串进行编码。
        结果
        属性值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.LoadStoreParameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface KeyStore.LoadStoreParameter

  • 所有已知实现类：
    DomainLoadStoreParameter
    Enclosing class:
    KeyStore

    public static interface KeyStore.LoadStoreParameter
    KeyStore load和 store参数的标记接口。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      KeyStore.ProtectionParameter getProtectionParameter​()
      获取用于保护密钥库数据的参数。

    • 方法详细信息

      • getProtectionParameter

        KeyStore.ProtectionParameter getProtectionParameter​()
        获取用于保护密钥库数据的参数。
        结果
        the parameter used to protect keystore data, or null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.PasswordProtection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyStore.PasswordProtection

  • java.lang.Object
    • java.security.KeyStore.PasswordProtection
  • All Implemented Interfaces:
    KeyStore.ProtectionParameter ， Destroyable
    Enclosing class:
    KeyStore

    public static class KeyStore.PasswordProtection
extends Object
implements KeyStore.ProtectionParameter, Destroyable
    基于密码的实现为 ProtectionParameter 。
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      PasswordProtection​(char[] password)
      创建一个密码参数。
      PasswordProtection​(char[] password, String protectionAlgorithm, AlgorithmParameterSpec protectionParameters)
      创建密码参数，并指定在加密密钥库条目时使用的保护算法和相关参数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void destroy​()
      清除密码。
      char[] getPassword​()
      获取密码。
      String getProtectionAlgorithm​()
      获取保护算法的名称。
      AlgorithmParameterSpec getProtectionParameters​()
      获取为保护算法提供的参数。
      boolean isDestroyed​()
      确定密码是否已被清除。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PasswordProtection

        public PasswordProtection​(char[] password)
        创建一个密码参数。

        指定的password在存储在新的PasswordProtection对象之前被克隆。

        参数
        password - 密码，可能是 null

      • PasswordProtection

        public PasswordProtection​(char[] password,
                          String protectionAlgorithm,
                          AlgorithmParameterSpec protectionParameters)
        创建密码参数，并指定在加密密钥库条目时使用的保护算法和相关参数。

        指定的password在存储在新的PasswordProtection对象之前被克隆。

        参数
        password - 密码，可能是 null
        protectionAlgorithm - 加密算法名称，例如PBEWithHmacSHA256AndAES_256 。 有关标准加密算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的密码部分。
        protectionParameters - 加密算法参数规范，可以是 null
        异常
        NullPointerException - 如果 protectionAlgorithm是 null
        从以下版本开始：
        1.8

    • 方法详细信息

      • getProtectionAlgorithm

        public String getProtectionAlgorithm​()
        获取保护算法的名称。 如果没有设置，则密钥库提供程序将使用其默认保护算法。 使用'keystore.<type>.keyProtectionAlgorithm'安全属性设置给定密钥库类型的默认保护算法的名称。 例如， keystore.PKCS12.keyProtectionAlgorithm属性存储用于PKCS12密钥库的默认密钥保护算法的名称。 如果未设置security属性，将使用实现特定的算法。
        结果
        算法名称，如果没有设置， null
        从以下版本开始：
        1.8

      • getProtectionParameters

        public AlgorithmParameterSpec getProtectionParameters​()
        获取为保护算法提供的参数。
        结果
        算法参数规范，或 null ，如果没有设置
        从以下版本开始：
        1.8

      • getPassword

        public char[] getPassword​()
        获取密码。

        请注意，此方法返回对密码的引用。 如果创建了数组的克隆，则呼叫者有责任在不再需要密码信息后将其清除。

        结果
        密码，可能是 null
        异常
        IllegalStateException - 如果密码已被清除（销毁）
        另请参见：
        destroy()

      • destroy

        public void destroy​()
             throws DestroyFailedException
        清除密码。
        Specified by:
        destroy在接口 Destroyable
        异常
        DestroyFailedException - 如果此方法无法清除密码

      • isDestroyed

        public boolean isDestroyed​()
        确定密码是否已被清除。
        Specified by:
        isDestroyed在接口 Destroyable
        结果
        如果密码已被清除，则为true，否则为false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.PrivateKeyEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyStore.PrivateKeyEntry

  • java.lang.Object
    • java.security.KeyStore.PrivateKeyEntry
  • All Implemented Interfaces:
    KeyStore.Entry
    Enclosing class:
    KeyStore

    public static final class KeyStore.PrivateKeyEntry
extends Object
implements KeyStore.Entry
    一个 KeyStore条目，其中包含一个 PrivateKey和相应的证书链。
    从以下版本开始：
    1.5

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.security.KeyStore.Entry

        KeyStore.Entry.Attribute

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrivateKeyEntry​(PrivateKey privateKey, Certificate[] chain)
      构建一个 PrivateKeyEntry与 PrivateKey及相应的证书链。
      PrivateKeyEntry​(PrivateKey privateKey, Certificate[] chain, Set<KeyStore.Entry.Attribute> attributes)
      构造一个具有 PrivateKeyEntry的 PrivateKey和相应的证书链和相关联的条目属性。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Set<KeyStore.Entry.Attribute> getAttributes​()
      检索与条目关联的属性。
      Certificate getCertificate​()
      从此条目中的证书链中获取终端实体 Certificate 。
      Certificate[] getCertificateChain​()
      从此条目获取 Certificate链。
      PrivateKey getPrivateKey​()
      从此条目获取 PrivateKey 。
      String toString​()
      返回此PrivateKeyEntry的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrivateKeyEntry

        public PrivateKeyEntry​(PrivateKey privateKey,
                       Certificate[] chain)
        构建一个PrivateKeyEntry与PrivateKey及相应的证书链。

        指定的chain在存储在新的PrivateKeyEntry对象之前被克隆。

        参数
        privateKey - PrivateKey
        chain - 表示证书链的Certificate s的数组。 必须对该链进行排序，并在索引0处包含与Certificate对应的Certificate 。
        异常
        NullPointerException - 如果是 privateKey或 chain是 null
        IllegalArgumentException -如果指定的链具有的长度为0，如果指定的链不包含 Certificate S中的相同的类型，或者如果 PrivateKey算法不所述的算法匹配 PublicKey到底实体 Certificate （索引0）

      • PrivateKeyEntry

        public PrivateKeyEntry​(PrivateKey privateKey,
                       Certificate[] chain,
                       Set<KeyStore.Entry.Attribute> attributes)
        构造一个具有PrivateKeyEntry的PrivateKey以及相应的证书链和相关的条目属性。

        指定的chain和attributes在存储在新的PrivateKeyEntry对象之前被克隆。

        参数
        privateKey - PrivateKey
        chain - 表示证书链的Certificate的数组。 必须对该链进行排序，并在索引0处包含与Certificate对应的Certificate 。
        attributes - 属性
        异常
        NullPointerException -如果 privateKey ， chain或者 attributes为 null
        IllegalArgumentException -如果指定的链具有的长度为0，如果指定的链不包含 Certificate S中的相同的类型，或者如果 PrivateKey算法不所述的算法匹配 PublicKey到底实体 Certificate （索引0）
        从以下版本开始：
        1.8

    • 方法详细信息

      • getPrivateKey

        public PrivateKey getPrivateKey​()
        从此条目获取 PrivateKey 。
        结果
        PrivateKey目的 PrivateKey

      • getCertificateChain

        public Certificate[] getCertificateChain​()
        从此条目获取Certificate链。

        存储链在被返回之前被克隆。

        结果
        一组Certificate对应于该公钥的证书链。 如果证书的类型为X.509，则返回的数组的运行时类型为X509Certificate[] 。

      • getCertificate

        public Certificate getCertificate​()
        从此条目中的证书链中获取终端实体 Certificate 。
        结果
        来自该条目中的证书链的终端实体Certificate （在索引0处）。 如果证书类型为X.509，则返回的证书的运行时类型为X509Certificate 。

      • getAttributes

        public Set<KeyStore.Entry.Attribute> getAttributes​()
        检索与条目关联的属性。
        Specified by:
        getAttributes在接口 KeyStore.Entry
        结果
        一个不可修改的属性 Set可能是空的
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回此PrivateKeyEntry的字符串表示形式。
        重写：
        toString在类 Object
        结果
        此PrivateKeyEntry的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.ProtectionParameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface KeyStore.ProtectionParameter

  • 所有已知实现类：
    KeyStore.CallbackHandlerProtection ， KeyStore.PasswordProtection
    Enclosing class:
    KeyStore

    public static interface KeyStore.ProtectionParameter
    用于密钥库保护参数的标记界面。

    存储在ProtectionParameter对象中的信息保护密钥库的内容。 例如，保护参数可用于检查密钥库数据的完整性，或保护敏感密钥库数据的机密性（例如PrivateKey ）。

    从以下版本开始：
    1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.SecretKeyEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyStore.SecretKeyEntry

  • java.lang.Object
    • java.security.KeyStore.SecretKeyEntry
  • All Implemented Interfaces:
    KeyStore.Entry
    Enclosing class:
    KeyStore

    public static final class KeyStore.SecretKeyEntry
extends Object
implements KeyStore.Entry
    A KeyStore条目，其中包含一个 SecretKey 。
    从以下版本开始：
    1.5

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.security.KeyStore.Entry

        KeyStore.Entry.Attribute

    • 构造方法摘要

      构造方法
      Constructor 描述
      SecretKeyEntry​(SecretKey secretKey)
      构造一个 SecretKeyEntry与 SecretKey 。
      SecretKeyEntry​(SecretKey secretKey, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 SecretKeyEntry与一个 SecretKey和相关联的条目属性。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Set<KeyStore.Entry.Attribute> getAttributes​()
      检索与条目关联的属性。
      SecretKey getSecretKey​()
      从此条目获取 SecretKey 。
      String toString​()
      返回此SecretKeyEntry的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SecretKeyEntry

        public SecretKeyEntry​(SecretKey secretKey)
        构造一个 SecretKeyEntry与一个 SecretKey 。
        参数
        secretKey - SecretKey
        异常
        NullPointerException - 如果 secretKey是 null

      • SecretKeyEntry

        public SecretKeyEntry​(SecretKey secretKey,
                      Set<KeyStore.Entry.Attribute> attributes)
        构造一个SecretKeyEntry与SecretKey及相关条目中的属性。

        指定的attributes在存储在新的SecretKeyEntry对象之前被克隆。

        参数
        secretKey - SecretKey
        attributes - 属性
        异常
        NullPointerException - 如果是 secretKey或 attributes是 null
        从以下版本开始：
        1.8

    • 方法详细信息

      • getSecretKey

        public SecretKey getSecretKey​()
        从此条目获取 SecretKey 。
        结果
        SecretKey目的 SecretKey

      • getAttributes

        public Set<KeyStore.Entry.Attribute> getAttributes​()
        检索与条目关联的属性。
        Specified by:
        getAttributes在接口 KeyStore.Entry
        结果
        一个不可修改的属性 Set ，可能是空的
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回此SecretKeyEntry的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个SecretKeyEntry的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStore.TrustedCertificateEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyStore.TrustedCertificateEntry

  • java.lang.Object
    • java.security.KeyStore.TrustedCertificateEntry
  • All Implemented Interfaces:
    KeyStore.Entry
    Enclosing class:
    KeyStore

    public static final class KeyStore.TrustedCertificateEntry
extends Object
implements KeyStore.Entry
    A KeyStore条目，其中包含受信任的 Certificate 。
    从以下版本开始：
    1.5

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.security.KeyStore.Entry

        KeyStore.Entry.Attribute

    • 构造方法摘要

      构造方法
      Constructor 描述
      TrustedCertificateEntry​(Certificate trustedCert)
      构造一个 TrustedCertificateEntry与一个值得信赖的 Certificate 。
      TrustedCertificateEntry​(Certificate trustedCert, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 TrustedCertificateEntry具有可信赖的 Certificate和相关联的条目属性。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Set<KeyStore.Entry.Attribute> getAttributes​()
      检索与条目关联的属性。
      Certificate getTrustedCertificate​()
      从此条目获取信任的 Certficate 。
      String toString​()
      返回此TrustedCertificateEntry的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TrustedCertificateEntry

        public TrustedCertificateEntry​(Certificate trustedCert)
        构造一个 TrustedCertificateEntry与一个值得信赖的 Certificate 。
        参数
        trustedCert - 信任的 Certificate
        异常
        NullPointerException - 如果 trustedCert是 null

      • TrustedCertificateEntry

        public TrustedCertificateEntry​(Certificate trustedCert,
                               Set<KeyStore.Entry.Attribute> attributes)
        构造一个TrustedCertificateEntry具有可信赖的Certificate和相关联的条目属性。

        指定的attributes在存储在新的TrustedCertificateEntry对象之前被克隆。

        参数
        trustedCert - 信任的 Certificate
        attributes - 属性
        异常
        NullPointerException - 如果是 trustedCert或 attributes是 null
        从以下版本开始：
        1.8

    • 方法详细信息

      • getTrustedCertificate

        public Certificate getTrustedCertificate​()
        从此条目获取信任的 Certficate 。
        结果
        来自此条目的值得信赖的 Certificate

      • getAttributes

        public Set<KeyStore.Entry.Attribute> getAttributes​()
        检索与条目关联的属性。
        Specified by:
        getAttributes在接口 KeyStore.Entry
        结果
        一个不可修改的属性 Set ，可能是空的
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回此TrustedCertificateEntry的字符串表示形式。
        重写：
        toString在 Object
        结果
        该TrustedCertificateEntry的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStoreException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyStoreException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.KeyStoreException
  • All Implemented Interfaces:
    Serializable

    public class KeyStoreException
extends GeneralSecurityException
    这是通用的KeyStore异常。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyStoreException​()
      构造一个没有详细消息的KeyStoreException。
      KeyStoreException​(String msg)
      构造具有指定详细消息的KeyStoreException。
      KeyStoreException​(String message, Throwable cause)
      创建一个 KeyStoreException与指定的详细信息和原因。
      KeyStoreException​(Throwable cause)
      创建 KeyStoreException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • KeyStoreException

        public KeyStoreException​()
        构造一个没有详细消息的KeyStoreException。 （详细信息是描述此特定异常的字符串。）

      • KeyStoreException

        public KeyStoreException​(String msg)
        构造具有指定详细消息的KeyStoreException。 （详细信息是描述此特定异常的字符串。）
        参数
        msg - 详细信息。

      • KeyStoreException

        public KeyStoreException​(String message,
                         Throwable cause)
        创建一个 KeyStoreException与指定的详细信息和原因。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法后续检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • KeyStoreException

        public KeyStoreException​(Throwable cause)
        创建 KeyStoreException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyStoreSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class KeyStoreSpi

  • java.lang.Object
    • java.security.KeyStoreSpi

  • public abstract class KeyStoreSpi
extends Object
    该类定义了KeyStore类的 （ SPI ）。 该类中的所有抽象方法必须由希望提供特定密钥库类型的密钥库的实现的每个加密服务提供商来实现。
    从以下版本开始：
    1.2
    另请参见：
    KeyStore

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyStoreSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Enumeration<String> engineAliases​()
      列出此密钥库的所有别名。
      abstract boolean engineContainsAlias​(String alias)
      检查此密钥库中是否存在给定的别名。
      abstract void engineDeleteEntry​(String alias)
      从此密钥库中删除由给定别名标识的条目。
      boolean engineEntryInstanceOf​(String alias, Class<? extends KeyStore.Entry> entryClass)
      确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
      abstract Certificate engineGetCertificate​(String alias)
      返回与给定别名相关联的证书。
      abstract String engineGetCertificateAlias​(Certificate cert)
      返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。
      abstract Certificate[] engineGetCertificateChain​(String alias)
      返回与给定别名关联的证书链。
      abstract Date engineGetCreationDate​(String alias)
      返回由给定别名标识的条目的创建日期。
      KeyStore.Entry engineGetEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的 KeyStore.Entry 。
      abstract Key engineGetKey​(String alias, char[] password)
      返回与给定别名相关联的密钥，使用给定的密码恢复它。
      abstract boolean engineIsCertificateEntry​(String alias)
      如果由给定别名标识的条目是通过调用 setCertificateEntry创建的，或者通过调用 setEntry与 TrustedCertificateEntry创建的条目，则返回true。
      abstract boolean engineIsKeyEntry​(String alias)
      如果由给定别名标识的条目是通过调用 setKeyEntry创建的，或者通过调用 setEntry （ PrivateKeyEntry或 SecretKeyEntry ）创建的条目，则返回true。
      abstract void engineLoad​(InputStream stream, char[] password)
      从给定的输入流加载密钥库。
      void engineLoad​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParameter加载密钥库。
      boolean engineProbe​(InputStream stream)
      探测指定的输入流以确定它是否包含此实现支持的密钥库。
      abstract void engineSetCertificateEntry​(String alias, Certificate cert)
      将给定的证书分配给给定的别名。
      void engineSetEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
      在指定的别名下保存 KeyStore.Entry 。
      abstract void engineSetKeyEntry​(String alias, byte[] key, Certificate[] chain)
      将给定的密钥（已经被保护）分配给给定的别名。
      abstract void engineSetKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)
      将给定的密钥分配给给定的别名，并使用给定的密码进行保护。
      abstract int engineSize​()
      检索此密钥库中的条目数。
      abstract void engineStore​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void engineStore​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParmeter存储此密钥库。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyStoreSpi

        public KeyStoreSpi​()

    • 方法详细信息

      • engineGetKey

        public abstract Key engineGetKey​(String alias,
                                 char[] password)
                          throws NoSuchAlgorithmException,
                                 UnrecoverableKeyException
        返回与给定别名相关联的密钥，使用给定的密码恢复它。 密钥必须已通过呼叫setKeyEntry与该别名相关联，或通过致电setEntry与PrivateKeyEntry或SecretKeyEntry 。
        参数
        alias - 别名
        password - 恢复密钥的密码
        结果
        请求的密钥，如果给定的别名不存在或不标识与密钥相关的条目，则为null。
        异常
        NoSuchAlgorithmException - 如果无法找到恢复密钥的算法
        UnrecoverableKeyException - 如果密钥无法恢复（例如，给定的密码错误）。

      • engineGetCertificateChain

        public abstract Certificate[] engineGetCertificateChain​(String alias)
        返回与给定别名关联的证书链。 证书链必须已经通过调用setKeyEntry与别名关联，或通过调用setEntry与PrivateKeyEntry 。
        参数
        alias - 别名
        结果
        证书链（先以用户的证书和最后的根证书颁发机构排序），如果给定的别名不存在或不包含证书链，则为null

      • engineGetCertificate

        public abstract Certificate engineGetCertificate​(String alias)
        返回与给定别名相关联的证书。

        如果给定的别名标识了通过调用setCertificateEntry创建的条目，或通过调用setEntry与TrustedCertificateEntry创建的条目，则返回该条目中包含的受信任证书。

        如果给定的别名标识了通过调用setKeyEntry创建的条目，或通过调用setEntry （具有PrivateKeyEntry创建的PrivateKeyEntry ，则返回该条目中的证书链的第一个元素（如果存在链）。

        参数
        alias - 别名
        结果
        证书，如果给定的别名不存在或不包含证书，则为null。

      • engineGetCreationDate

        public abstract Date engineGetCreationDate​(String alias)
        返回由给定别名标识的条目的创建日期。
        参数
        alias - 别名
        结果
        此条目的创建日期，如果给定的别名不存在，则为null

      • engineSetKeyEntry

        public abstract void engineSetKeyEntry​(String alias,
                                       Key key,
                                       char[] password,
                                       Certificate[] chain)
                                throws KeyStoreException
        将给定的密钥分配给给定的别名，并使用给定的密码进行保护。

        如果给定的密钥是类型为java.security.PrivateKey ，它必须附有一个证书链，证明相应的公钥。

        如果给定的别名已经存在，与它相关联的密钥库信息将被给定的密钥（也可能是证书链）覆盖。

        参数
        alias - 别名
        key - 与别名关联的关键
        password - 密码保护密钥
        chain - 相应公钥的证书链（仅当给定键为 java.security.PrivateKey类型 java.security.PrivateKey ）。
        异常
        KeyStoreException - 如果给定的密钥不能被保护，或者由于某些其他原因导致该操作失败

      • engineSetKeyEntry

        public abstract void engineSetKeyEntry​(String alias,
                                       byte[] key,
                                       Certificate[] chain)
                                throws KeyStoreException
        将给定的密钥（已经被保护）分配给给定的别名。

        如果受保护的密钥是java.security.PrivateKey型，则必须附有一个证书链，证明相应的公钥。

        如果给定的别名已经存在，与它相关联的密钥库信息将被给定的密钥（也可能是证书链）覆盖。

        参数
        alias - 别名
        key - 与别名关联的密钥（以受保护的格式）
        chain - 相应公钥的证书链（仅当受保护的密钥为 java.security.PrivateKey类型时才有用）。
        异常
        KeyStoreException - 如果此操作失败。

      • engineSetCertificateEntry

        public abstract void engineSetCertificateEntry​(String alias,
                                               Certificate cert)
                                        throws KeyStoreException
        将给定的证书分配给给定的别名。

        如果给定的别名标识了通过调用setCertificateEntry创建的现有条目，或通过调用setEntry与TrustedCertificateEntry ，则现有条目中的受信任证书将被给定的证书覆盖。

        参数
        alias - 别名
        cert - 证书
        异常
        KeyStoreException - 如果给定的别名已经存在，并且不标识包含受信任证书的条目，或者由于其他原因导致此操作失败。

      • engineDeleteEntry

        public abstract void engineDeleteEntry​(String alias)
                                throws KeyStoreException
        从此密钥库中删除由给定别名标识的条目。
        参数
        alias - 别名
        异常
        KeyStoreException - 如果条目无法删除。

      • engineAliases

        public abstract Enumeration<String> engineAliases​()
        列出此密钥库的所有别名。
        结果
        枚举别名

      • engineContainsAlias

        public abstract boolean engineContainsAlias​(String alias)
        检查此密钥库中是否存在给定的别名。
        参数
        alias - 别名
        结果
        如果别名存在则为true，否则为false

      • engineSize

        public abstract int engineSize​()
        检索此密钥库中的条目数。
        结果
        此密钥库中的条目数

      • engineIsKeyEntry

        public abstract boolean engineIsKeyEntry​(String alias)
        如果由给定别名标识的条目是通过调用 setKeyEntry创建的，或者通过调用 setEntry与 PrivateKeyEntry或 SecretKeyEntry创建的条目，则返回true。
        参数
        alias - 要检查的密钥库条目的别名
        结果
        如果给定别名标识的条目是密钥相关的，则为true，否则为false。

      • engineIsCertificateEntry

        public abstract boolean engineIsCertificateEntry​(String alias)
        如果给定别名标识的条目是通过调用创建返回true setCertificateEntry ，或者创建通过调用 setEntry用 TrustedCertificateEntry 。
        参数
        alias - 要检查的密钥库条目的别名
        结果
        如果给定别名标识的条目包含受信任的证书，则为true，否则为false。

      • engineGetCertificateAlias

        public abstract String engineGetCertificateAlias​(Certificate cert)
        返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。

        此方法尝试将给定证书与每个密钥库条目相匹配。 如果正在考虑的条目是通过调用setCertificateEntry创建的，或通过调用setEntry与TrustedCertificateEntry ，则将给定的证书与该条目的证书进行比较。

        如果正在考虑的条目是通过调用setKeyEntry创建的，或通过调用setEntry与PrivateKeyEntry ，则将给定的证书与该条目的证书链的第一个元素进行比较。

        参数
        cert - 证书匹配。
        结果
        具有匹配证书的第一个条目的别名，如果此密钥库中没有此类条目，则为null。

      • engineStore

        public abstract void engineStore​(OutputStream stream,
                                 char[] password)
                          throws IOException,
                                 NoSuchAlgorithmException,
                                 CertificateException
        将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
        参数
        stream - 写入此密钥库的输出流。
        password - 生成密钥库完整性检查的密码
        异常
        IOException - 如果数据存在I / O问题
        NoSuchAlgorithmException - 如果 NoSuchAlgorithmException适当的数据完整性算法
        CertificateException - 如果密钥库数据中包含的任何证书无法存储

      • engineStore

        public void engineStore​(KeyStore.LoadStoreParameter param)
                 throws IOException,
                        NoSuchAlgorithmException,
                        CertificateException
        使用给定的 KeyStore.LoadStoreParmeter存储此密钥库。
        参数
        param -在 KeyStore.LoadStoreParmeter指定如何存储密钥库，这可能是 null
        异常
        IllegalArgumentException - 如果给定的 KeyStore.LoadStoreParmeter输入未被识别
        IOException - 如果数据存在I / O问题
        NoSuchAlgorithmException - 如果 NoSuchAlgorithmException适当的数据完整性算法
        CertificateException - 如果密钥库数据中包含的任何证书无法存储
        从以下版本开始：
        1.5

      • engineLoad

        public abstract void engineLoad​(InputStream stream,
                                char[] password)
                         throws IOException,
                                NoSuchAlgorithmException,
                                CertificateException
        从给定的输入流加载密钥库。

        可以提供密码来解锁密钥库（例如，密钥库驻留在硬件令牌设备上），或者检查密钥库数据的完整性。 如果没有为完整性检查提供密码，则不执行完整性检查。

        参数
        stream - 加载密钥库的输入流，或 null
        password - 用于检查密钥库完整性的密码，用于解锁密钥库的密码，或 null
        异常
        IOException - 如果密钥库数据存在I / O或格式问题，如果需要密码但未提供密码，或者给定的密码不正确。 如果错误是由于密码错误， IOException的IOException应为UnrecoverableKeyException
        NoSuchAlgorithmException - 如果用于检查密钥库完整性的算法无法找到
        CertificateException - 如果密钥库中的任何证书无法加载

      • engineLoad

        public void engineLoad​(KeyStore.LoadStoreParameter param)
                throws IOException,
                       NoSuchAlgorithmException,
                       CertificateException
        使用给定的KeyStore.LoadStoreParameter加载密钥库。

        请注意，如果此KeyStore已经加载，它将从给定的参数重新初始化并重新加载。

        实现要求：
        默认实现检查KeyStore.LoadStoreParameter以提取其密码，并将其传递给engineLoad(InputStream, char[])以及null InputStream 。

        如果KeyStore.LoadStoreParameter为null则密码参数也null 。 否则KeyStore.ProtectionParameter的KeyStore.LoadStoreParameter必须是KeyStore.PasswordProtection或支持PasswordCallback的KeyStore.CallbackHandlerProtection ，以便可以提取密码参数。 如果KeyStore.ProtectionParameter既不是那些类，那么抛出一个NoSuchAlgorithmException 。

        参数
        param -所述 KeyStore.LoadStoreParameter指定如何加载密钥库，其可以是 null
        异常
        IllegalArgumentException - 如果给定的 KeyStore.LoadStoreParameter输入未被识别
        IOException - 如果存在密钥库数据的I / O或格式问题。 如果错误是由于错误的ProtectionParameter （例如错误的密码）， IOException的IOException应为UnrecoverableKeyException
        NoSuchAlgorithmException - 如果用于检查密钥库的完整性的算法无法找到
        CertificateException - 如果密钥库中的任何证书无法加载
        从以下版本开始：
        1.5

      • engineGetEntry

        public KeyStore.Entry engineGetEntry​(String alias,
                                     KeyStore.ProtectionParameter protParam)
                              throws KeyStoreException,
                                     NoSuchAlgorithmException,
                                     UnrecoverableEntryException
        获取具有指定保护参数的指定别名的 KeyStore.Entry 。
        参数
        alias - 获取 KeyStore.Entry的这个别名
        protParam - ProtectionParameter用于保护 Entry ，其中可能是 null
        结果
        该 KeyStore.Entry指定别名，或 null如果没有这样的条目
        异常
        KeyStoreException - 如果操作失败
        NoSuchAlgorithmException - 如果 NoSuchAlgorithmException用于恢复条目的算法
        UnrecoverableEntryException - 如果指定的 protParam不足或无效
        UnrecoverableKeyException - 如果条目是 PrivateKeyEntry或 SecretKeyEntry ，并且指定的 protParam不包含恢复密钥所需的信息（例如错误的密码）
        从以下版本开始：
        1.5

      • engineSetEntry

        public void engineSetEntry​(String alias,
                           KeyStore.Entry entry,
                           KeyStore.ProtectionParameter protParam)
                    throws KeyStoreException
        在指定的别名下保存一个KeyStore.Entry 。 指定的保护参数用于保护Entry 。

        如果指定别名的条目已存在，则会被覆盖。

        参数
        alias - 保存在这个别名下的 KeyStore.Entry
        entry - 要保存的 Entry
        protParam - ProtectionParameter用于保护 Entry ，可能是 null
        异常
        KeyStoreException - 如果此操作失败
        从以下版本开始：
        1.5

      • engineEntryInstanceOf

        public boolean engineEntryInstanceOf​(String alias,
                                     Class<? extends KeyStore.Entry> entryClass)
        确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
        参数
        alias - 别名
        entryClass - 入门课
        结果
        如果指定的 alias的密钥库 Entry是指定的 alias的实例或子类， entryClass true，否则为false
        从以下版本开始：
        1.5

      • engineProbe

        public boolean engineProbe​(InputStream stream)
                    throws IOException
        探测指定的输入流以确定它是否包含此实现支持的密钥库。
        实现要求：
        此方法默认返回false。 密钥库实现应该覆盖此方法直接窥视数据流或使用其他内容检测机制。
        参数
        stream - 要探测的密钥库数据
        结果
        如果密钥库数据被支持，则为true，否则为false
        异常
        IOException - 如果密钥库数据存在I / O问题。
        NullPointerException - 如果流是 null 。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MessageDigest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class MessageDigest

  • java.lang.Object
    • java.security.MessageDigestSpi
      • java.security.MessageDigest

  • public abstract class MessageDigest
extends MessageDigestSpi
    该MessageDigest类为应用程序提供消息摘要算法的功能，如SHA-1或SHA-256。 消息摘要是采用任意大小的数据并输出固定长度散列值的安全单向散列函数。

    MessageDigest对象开始初始化。 使用update方法通过它处理数据。 在任何时候可以调用reset来重置摘要。 一旦要更新的所有数据都被更新，应该调用digest方法之一来完成哈希计算。

    对于给定数量的更新，可以调用digest方法一次。 在digest之后，将MessageDigest对象重置为初始化状态。

    实现可以实现Cloneable接口。 客户端应用程序可以通过尝试克隆和捕获CloneNotSupportedException来测试可克隆性：

       MessageDigest md = MessageDigest.getInstance("SHA"); try { md.update(toChapter1); MessageDigest tc1 = md.clone(); byte[] toChapter1Digest = tc1.digest(); md.update(toChapter2); ...etc. } catch (CloneNotSupportedException cnse) { throw new DigestException("couldn't make digest of partial content"); }

    请注意，如果给定的实现不可克隆，则如果预先知道摘要的数量，仍然可以通过实例化几个实例来计算中间摘要。

    注意，这个类是抽象的，由于历史原因而从MessageDigestSpi延伸。 应用程序开发人员只应注意本MessageDigest课程中定义的方法; 超类中的所有方法都适用于希望提供自己的消息摘要算法实现的加密服务提供商。

    Java平台的每个实现都需要支持以下标准的MessageDigest算法：

    • MD5
    • SHA-1
    • SHA-256
    这些算法在Java Security Standard算法名称规范的MessageDigest section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.1
    另请参见：
    DigestInputStream ， DigestOutputStream

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected MessageDigest​(String algorithm)
      使用指定的算法名称创建消息摘要。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      如果实现是可克隆的，则返回克隆。
      byte[] digest​()
      通过执行最后的操作（如填充）来完成哈希计算。
      byte[] digest​(byte[] input)
      使用指定的字节数组对摘要执行最终更新，然后完成摘要计算。
      int digest​(byte[] buf, int offset, int len)
      通过执行最后的操作（如填充）来完成哈希计算。
      String getAlgorithm​()
      返回一个标识算法的字符串，与实现细节无关。
      int getDigestLength​()
      以字节为单位返回摘要的长度，如果提供程序不支持此操作，并且实现不可克隆，则返回0。
      static MessageDigest getInstance​(String algorithm)
      返回实现指定摘要算法的MessageDigest对象。
      static MessageDigest getInstance​(String algorithm, String provider)
      返回实现指定摘要算法的MessageDigest对象。
      static MessageDigest getInstance​(String algorithm, Provider provider)
      返回实现指定摘要算法的MessageDigest对象。
      Provider getProvider​()
      返回此消息摘要对象的提供者。
      static boolean isEqual​(byte[] digesta, byte[] digestb)
      比较两个平等的消息。
      void reset​()
      重置摘要以供进一步使用。
      String toString​()
      返回此消息摘要对象的字符串表示形式。
      void update​(byte input)
      使用指定的字节更新摘要。
      void update​(byte[] input)
      使用指定的字节数组更新摘要。
      void update​(byte[] input, int offset, int len)
      使用指定的字节数组从指定的偏移量开始更新摘要。
      void update​(ByteBuffer input)
      使用指定的ByteBuffer更新摘要。

      • Methods inherited from class java.security.MessageDigestSpi

        engineDigest, engineDigest, engineGetDigestLength, engineReset, engineUpdate, engineUpdate, engineUpdate

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MessageDigest

        protected MessageDigest​(String algorithm)
        使用指定的算法名称创建消息摘要。
        参数
        algorithm - 摘要算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的MessageDigest部分。

    • 方法详细信息

      • getInstance

        public static MessageDigest getInstance​(String algorithm)
                                 throws NoSuchAlgorithmException
        返回实现指定摘要算法的MessageDigest对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装MessageDigestSpi实现的新MessageDigest对象。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 请求的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的MessageDigest部分。
        结果
        一个实现指定算法的 MessageDigest对象
        异常
        NoSuchAlgorithmException - 如果没有 Provider支持指定算法的 MessageDigestSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static MessageDigest getInstance​(String algorithm,
                                        String provider)
                                 throws NoSuchAlgorithmException,
                                        NoSuchProviderException
        返回实现指定摘要算法的MessageDigest对象。

        返回从指定提供程序封装MessageDigestSpi实现的新MessageDigest对象。 指定的提供者必须在安全提供程序列表中注册。

        注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        参数
        algorithm - 请求的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的MessageDigest部分。
        provider - 提供商的名称。
        结果
        一个实现指定算法的 MessageDigest对象
        异常
        IllegalArgumentException - 如果提供商名称为 null或为空
        NoSuchAlgorithmException - 如果指定算法的 MessageDigestSpi实现不能从指定的提供者
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static MessageDigest getInstance​(String algorithm,
                                        Provider provider)
                                 throws NoSuchAlgorithmException
        返回实现指定摘要算法的MessageDigest对象。

        返回从指定的Provider对象封装MessageDigestSpi实现的新MessageDigest对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 请求的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的MessageDigest部分。
        provider - 提供商。
        结果
        一个实现指定算法的 MessageDigest对象
        异常
        IllegalArgumentException - 如果指定的提供者是 null
        NoSuchAlgorithmException - 如果指定的算法的 MessageDigestSpi实现不能从指定的 Provider对象获得
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        1.4
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此消息摘要对象的提供者。
        结果
        该消息摘要对象的提供者

      • update

        public void update​(byte input)
        使用指定的字节更新摘要。
        参数
        input - 用于更新摘要的字节。

      • update

        public void update​(byte[] input,
                   int offset,
                   int len)
        使用指定的字节数组从指定的偏移量开始更新摘要。
        参数
        input - 字节数组。
        offset - 从字节数组开始的偏移量。
        len - 要使用的字节数，从 offset开始。

      • update

        public void update​(byte[] input)
        使用指定的字节数组更新摘要。
        参数
        input - 字节数组。

      • update

        public final void update​(ByteBuffer input)
        使用指定的ByteBuffer更新摘要。 摘要采用更新的input.remaining()起始字节input.position() 。 返回时，缓冲区的位置将等于其限制; 其限制将不会改变。
        参数
        input - ByteBuffer
        从以下版本开始：
        1.5

      • digest

        public byte[] digest​()
        通过执行最后的操作（如填充）来完成哈希计算。 此通话完成后，摘要将重置。
        结果
        用于生成的哈希值的字节数组。

      • digest

        public int digest​(byte[] buf,
                  int offset,
                  int len)
           throws DigestException
        通过执行最后的操作（如填充）来完成哈希计算。 此通话完成后，摘要将重置。
        参数
        buf - 计算摘要的输出缓冲区
        offset - 偏移到输出缓冲区开始存储摘要
        len - 为摘要分配的buf内的字节数
        结果
        将字节数放入 buf
        异常
        DigestException - 如果发生错误。

      • digest

        public byte[] digest​(byte[] input)
        使用指定的字节数组对摘要执行最终更新，然后完成摘要计算。 也就是说，这种方法首先调用update(input) ，将输入数组传递到update方法，然后调用digest() 。
        参数
        input - 摘要完成之前要更新的输入。
        结果
        用于生成的哈希值的字节数组。

      • toString

        public String toString​()
        返回此消息摘要对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • isEqual

        public static boolean isEqual​(byte[] digesta,
                              byte[] digestb)
        比较两个平等的消息。 如果两个摘要具有相同的长度，并且相应位置的所有字节相等，则两个摘要相等。
        Implementation Note:
        如果摘要长度相同，则会检查所有字节以确定相等。
        参数
        digesta - 一个比较的摘要。
        digestb - 其他摘要比较。
        结果
        如果摘要相等，则为true，否则为false。

      • reset

        public void reset​()
        重置摘要以供进一步使用。

      • getAlgorithm

        public final String getAlgorithm​()
        返回一个标识算法的字符串，与实现细节无关。 该名称应该是标准的Java安全名称（如“SHA”，“MD5”等）。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的MessageDigest部分。
        结果
        算法的名称

      • getDigestLength

        public final int getDigestLength​()
        以字节为单位返回摘要的长度，如果提供程序不支持此操作，并且实现不可克隆，则返回0。
        结果
        摘要长度（以字节为单位），如果此操作不受提供程序支持，则执行不可克隆。
        从以下版本开始：
        1.2

      • clone

        public Object clone​()
             throws CloneNotSupportedException
        如果实现是可克隆的，则返回克隆。
        重写：
        clone在 MessageDigestSpi
        结果
        一个克隆，如果实现是可克隆的。
        异常
        CloneNotSupportedException - 如果在不支持 Cloneable的实现上调用此方法。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MessageDigestSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class MessageDigestSpi

  • java.lang.Object
    • java.security.MessageDigestSpi
  • 已知直接子类：
    MessageDigest

    public abstract class MessageDigestSpi
extends Object
    该类为MessageDigest类定义了 （ SPI ），它提供消息摘要算法（如MD5或SHA）的功能。 消息摘要是采用任意大小的数据并输出固定长度散列值的安全单向散列函数。

    该类中的所有抽象方法必须由希望提供特定消息摘要算法的实现的加密服务提供者来实现。

    实现可以实现Cloneable接口。

    从以下版本开始：
    1.2
    另请参见：
    MessageDigest

    • 构造方法摘要

      构造方法
      Constructor 描述
      MessageDigestSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      如果实现是可克隆的，则返回克隆。
      protected abstract byte[] engineDigest​()
      通过执行最后的操作（如填充）来完成哈希计算。
      protected int engineDigest​(byte[] buf, int offset, int len)
      通过执行最后的操作（如填充）来完成哈希计算。
      protected int engineGetDigestLength​()
      以字节为单位返回摘要长度。
      protected abstract void engineReset​()
      重置摘要以供进一步使用。
      protected abstract void engineUpdate​(byte input)
      使用指定的字节更新摘要。
      protected abstract void engineUpdate​(byte[] input, int offset, int len)
      使用指定的字节数组从指定的偏移量开始更新摘要。
      protected void engineUpdate​(ByteBuffer input)
      使用指定的ByteBuffer更新摘要。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MessageDigestSpi

        public MessageDigestSpi​()

    • 方法详细信息

      • engineGetDigestLength

        protected int engineGetDigestLength​()
        以字节为单位返回摘要长度。

        这个具体的方法已经添加到这个以前定义的抽象类中。 （为了向后兼容，它不能是抽象的。）

        默认行为是返回0。

        该方法可能被提供者覆盖以返回摘要长度。

        结果
        摘要长度以字节为单位。
        从以下版本开始：
        1.2

      • engineUpdate

        protected abstract void engineUpdate​(byte input)
        使用指定的字节更新摘要。
        参数
        input - 用于更新的字节。

      • engineUpdate

        protected abstract void engineUpdate​(byte[] input,
                                     int offset,
                                     int len)
        使用指定的字节数组从指定的偏移量开始更新摘要。
        参数
        input - 用于更新的字节数组。
        offset - 从字节数组开始的偏移量。
        len - 要使用的字节数，从 offset开始。

      • engineUpdate

        protected void engineUpdate​(ByteBuffer input)
        使用指定的ByteBuffer更新摘要。 摘要采用更新的input.remaining()起始字节input.position() 。 返回时，缓冲区的位置将等于其限制; 其限制将不会改变。
        参数
        input - ByteBuffer
        从以下版本开始：
        1.5

      • engineDigest

        protected abstract byte[] engineDigest​()
        通过执行最后的操作（如填充）来完成哈希计算。 一旦engineDigest ，引擎应该被复位（见engineReset ）。 重置是引擎执行者的责任。
        结果
        用于生成的哈希值的字节数组。

      • engineDigest

        protected int engineDigest​(byte[] buf,
                           int offset,
                           int len)
                    throws DigestException
        通过执行最后的操作（如填充）来完成哈希计算。 一旦engineDigest ，引擎应该被复位（见engineReset ）。 重置是引擎执行者的责任。 这种方法应该是抽象的，但是我们留下具体的二进制兼容性。 有知识的提供者应该覆盖这种方法。
        参数
        buf - 存储摘要的输出缓冲区
        offset - 从输出缓冲区中启动的偏移量
        len - 为摘要分配的buf内的字节数。 这个默认实现和SUN提供者都不返回部分摘要。 这个参数的存在仅仅是为了我们的API的一致性。 如果该参数的值小于实际的摘要长度，该方法将抛出一个DigestException。 如果该值大于或等于实际摘要长度，则忽略此参数。
        结果
        摘要存储在输出缓冲区中的长度。
        异常
        DigestException - 如果发生错误。
        从以下版本开始：
        1.2

      • engineReset

        protected abstract void engineReset​()
        重置摘要以供进一步使用。

      • clone

        public Object clone​()
             throws CloneNotSupportedException
        如果实现是可克隆的，则返回克隆。
        重写：
        clone在 Object
        结果
        一个克隆，如果实现是可克隆的。
        异常
        CloneNotSupportedException - 如果这是在不支持 Cloneable的实现上 Cloneable 。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NoSuchAlgorithmException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class NoSuchAlgorithmException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.NoSuchAlgorithmException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchAlgorithmException
extends GeneralSecurityException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchAlgorithmException​()
      构造一个没有详细消息的NoSuchAlgorithmException。
      NoSuchAlgorithmException​(String msg)
      构造具有指定详细消息的NoSuchAlgorithmException。
      NoSuchAlgorithmException​(String message, Throwable cause)
      创建一个 NoSuchAlgorithmException与指定的详细信息和原因。
      NoSuchAlgorithmException​(Throwable cause)
      创建 NoSuchAlgorithmException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchAlgorithmException

        public NoSuchAlgorithmException​()
        构造一个没有详细消息的NoSuchAlgorithmException。 详细消息是描述此特定异常的字符串。

      • NoSuchAlgorithmException

        public NoSuchAlgorithmException​(String msg)
        构造具有指定详细消息的NoSuchAlgorithmException。 详细消息是描述此特定异常的字符串，可能例如指定哪种算法不可用。
        参数
        msg - 详细信息。

      • NoSuchAlgorithmException

        public NoSuchAlgorithmException​(String message,
                                Throwable cause)
        创建一个具有指定的详细消息和原因的 NoSuchAlgorithmException 。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （A null值被允许，并且表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • NoSuchAlgorithmException

        public NoSuchAlgorithmException​(Throwable cause)
        创建 NoSuchAlgorithmException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null允许值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NoSuchProviderException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class NoSuchProviderException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.NoSuchProviderException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchProviderException
extends GeneralSecurityException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchProviderException​()
      构造一个没有详细信息的NoSuchProviderException。
      NoSuchProviderException​(String msg)
      构造具有指定详细消息的NoSuchProviderException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchProviderException

        public NoSuchProviderException​()
        构造一个没有详细信息的NoSuchProviderException。 详细消息是描述此特定异常的字符串。

      • NoSuchProviderException

        public NoSuchProviderException​(String msg)
        构造具有指定详细消息的NoSuchProviderException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Permission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Permission

  • java.lang.Object
    • java.security.Permission
  • All Implemented Interfaces:
    Serializable ， Guard
    已知直接子类：
    AllPermission ， BasicPermission ， CardPermission ， FilePermission ， MBeanPermission ， PrivateCredentialPermission ， ServicePermission ， SocketPermission ， UnresolvedPermission ， URLPermission

    public abstract class Permission
extends Object
implements Guard, Serializable
    用于表示访问系统资源的抽象类。 所有权限都有一个名称（其解释取决于子类），以及用于定义特定Permission子类的语义的抽象函数。

    大多数权限对象还包括一个“操作”列表，用于告知对象允许的操作。 例如，对于java.io.FilePermission对象，权限名称是文件（或目录）的路径名，操作列表（例如“读取，写入”）指定为指定的文件授予哪些操作（或者为指定目录）。 对于不需要这样的列表的权限对象（如java.lang.RuntimePermission ，操作列表是可选的; 您具有命名权限（例如“system.exit”），或者您没有。

    每个子类必须实现的一个重要方法是比较权限的implies方法。 基本上，“权限p1意味着许可p2”表示如果被授予权限p1，则自然会授予权限p2。 因此，这不是一个等式测试，而是一个子集测试。

    权限对象与String对象类似，因为它们在创建后是不可变的。 子类不能提供可以在创建权限后更改权限状态的方法。

    从以下版本开始：
    1.2
    另请参见：
    Permissions ， PermissionCollection ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Permission​(String name)
      构造具有指定名称的权限。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void checkGuard​(Object object)
      实施保护接口以获得许可。
      abstract boolean equals​(Object obj)
      检查两个Permission对象的相等性。
      abstract String getActions​()
      以String形式返回操作。
      String getName​()
      返回此权限的名称。
      abstract int hashCode​()
      返回此Permission对象的哈希码值。
      abstract boolean implies​(Permission permission)
      检查指定权限的操作是否由此对象的操作“隐含”。
      PermissionCollection newPermissionCollection​()
      为给定的Permission对象返回一个空的PermissionCollection，如果未定义，则返回null。
      String toString​()
      返回描述此权限的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Permission

        public Permission​(String name)
        构造具有指定名称的权限。
        参数
        name - 正在创建的权限对象的名称。

    • 方法详细信息

      • checkGuard

        public void checkGuard​(Object object)
                throws SecurityException
        实施保护接口以获得许可。 调用SecurityManager.checkPermission方法，将此权限对象作为权限进行检查。 如果访问被授予，则默认返回。 否则，抛出SecurityException。
        Specified by:
        checkGuard在接口 Guard
        参数
        object - 被保护的对象（当前被忽略）。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许访问。
        另请参见：
        Guard ， GuardedObject ， SecurityManager.checkPermission(java.security.Permission)

      • implies

        public abstract boolean implies​(Permission permission)
        检查指定权限的操作是否由此对象的操作“隐含”。

        这必须由Permission的子类实现，因为它们是唯一可以在Permission对象上强加语义的。

        AccessController使用implies方法来确定所请求的权限是否被已知在当前执行上下文中有效的另一权限暗示。

        参数
        permission - 允许检查。
        结果
        如果此对象隐含指定的权限，则为true，否则为false。

      • equals

        public abstract boolean equals​(Object obj)
        检查两个Permission对象的相等性。

        不要使用equals方法进行访问控制决策; 使用implies方法。

        重写：
        equals中的 Object
        参数
        obj - 我们正在测试与该对象相等的对象。
        结果
        如果两个Permission对象都是等效的，则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public abstract int hashCode​()
        返回此Permission对象的哈希码值。

        权限对象所需的hashCode行为如下：

        • 无论何时在执行Java应用程序时多次在同一个Permission对象上调用该函数，那么hashCode方法必须始终返回相同的整数。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个Permission对象根据equals方法相等，则在两个Permission对象中的每一个上调用hashCode方法必须产生相同的整数结果。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getName

        public final String getName​()
        返回此权限的名称。 例如，在java.io.FilePermission的情况下，该名称将是一个路径名。
        结果
        该权限的名称。

      • getActions

        public abstract String getActions​()
        以String形式返回操作。 这是抽象的，所以子类可以延迟创建一个String表示，直到需要。 子类应该总是以他们认为是他们的规范形式返回动作。 例如，通过以下方式创建的两个FilePermission对象：
          perm1 = new FilePermission(p1,"read,write");
   perm2 = new FilePermission(p2,"write,read");
        当调用getActions方法时，都返回“读，写”。
        结果
        这个权限的动作。

      • newPermissionCollection

        public PermissionCollection newPermissionCollection​()
        为给定的Permission对象返回一个空的PermissionCollection，如果未定义，则返回null。 类Permission的子类应该重写这个，如果他们需要将其权限存储在特定的PermissionCollection对象中，以便在调用PermissionCollection.implies方法时提供正确的语义。 如果返回null，那么此方法的调用者可以自由地在其选择的任何PermissionCollection中存储此类型的权限（使用Hashtable，使用Vector等）。
        结果
        一个新的PermissionCollection类型的PermissionCollection对象，如果没有定义，则返回null。

      • toString

        public String toString​()
        返回描述此权限的字符串。 约定是以以下格式指定类名，权限名和操作：'（“ClassName”“name”“actions”）'或'（“ClassName”“name”）'如果操作列表是空或空。
        重写：
        toString在 Object
        结果
        有关此权限的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PermissionCollection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class PermissionCollection

  • java.lang.Object
    • java.security.PermissionCollection
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    Permissions

    public abstract class PermissionCollection
extends Object
implements Serializable
    代表Permission对象集合的抽象类。

    使用PermissionCollection，您可以：

    • 使用add方法添加收藏的权限。
    • 使用implies方法检查收集中是否暗示了特定权限。
    • 枚举所有权限，使用elements方法。

    当希望将许多相同类型的Permission对象组合在一起时，应首先调用该特定类型的Permission对象上的newPermissionCollection方法。 默认行为（从Permission类）只是返回null。 如果PermissionsCollection对象需要存储其权限，以便在调用PermissionCollection.implies方法时提供正确的语义，则类Permission的子类将重写该方法。 如果返回非空值，则必须使用PermissionCollection。 如果返回null，那么newPermissionCollection的调用者可以自由地存储他们选择的任何PermissionCollection中的给定类型的权限（一个使用Hashtable，一个使用Vector等）。

    由Permission.newPermissionCollection方法返回的PermissionCollection是一个同构的集合，它仅存储给定权限类型的权限对象。 PermissionCollection也可能是异构的。 例如，Permissions是PermissionCollection子类，它表示PermissionCollections的集合。 也就是说，它的成员都是均匀的PermissionCollection。 例如，Permissions对象可能具有所有FilePermission对象的FilePermissionCollection，所有SocketPermission对象的SocketPermissionCollection等等。 其add方法为相应的集合添加了一个权限。

    每当将权限添加到异构PermissionCollection（如权限）中时，PermissionCollection还不包含指定权限类型的PermissionCollection，PermissionCollection应该在权限类上调用newPermissionCollection方法，以查看是否需要特殊的PermissionCollection。 如果newPermissionCollection返回null，PermissionCollection可以将权限存储在任何所需的PermissionCollection类型中（一个使用Hashtable，一个使用Vector等）。 例如，Permissions对象使用在Hashtable中存储权限对象的默认PermissionCollection实现。

    PermissionCollection的子类实现应该假定它们可以从多个线程同时调用，因此应该被正确同步。 此外，通过elements方法返回的枚举不是故障快速的 。 在枚举集合时不应执行对集合的修改。

    从以下版本开始：
    1.2
    另请参见：
    Permission ， Permissions ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PermissionCollection​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void add​(Permission permission)
      将权限对象添加到当前权限对象集合。
      abstract Enumeration<Permission> elements​()
      返回集合中所有Permission对象的枚举。
      Stream<Permission> elementsAsStream​()
      返回集合中所有权限对象的流。
      abstract boolean implies​(Permission permission)
      检查此PermissionCollection中持有的Permission对象的集合是否暗示了指定的权限。
      boolean isReadOnly​()
      如果此PermissionCollection对象被标记为只读方式，则返回true。
      void setReadOnly​()
      将此PermissionCollection对象标记为“只读”。
      String toString​()
      返回描述此PermissionCollection对象的字符串，提供有关其所包含的所有权限的信息。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PermissionCollection

        public PermissionCollection​()

    • 方法详细信息

      • add

        public abstract void add​(Permission permission)
        将权限对象添加到当前权限对象集合。
        参数
        permission - 要添加的权限对象。
        异常
        SecurityException - - 如果此PermissionCollection对象已被标记为只读
        IllegalArgumentException - - 如果此PermissionCollection对象是均匀集合，并且权限不是正确的类型。

      • implies

        public abstract boolean implies​(Permission permission)
        检查此PermissionCollection中持有的Permission对象的集合是否暗示了指定的权限。
        参数
        permission - 要比较的权限对象。
        结果
        如果集合中的权限暗示“权限”，则为true，否则为false。

      • elements

        public abstract Enumeration<Permission> elements​()
        返回集合中所有Permission对象的枚举。
        结果
        列举所有权限。
        另请参见：
        elementsAsStream()

      • elementsAsStream

        public Stream<Permission> elementsAsStream​()
        返回集合中所有权限对象的流。

        在执行终端流操作期间，不应修改集合（见add(java.security.Permission) ）。 否则，终端流操作的结果未定义。

        实现要求：
        默认实现创建一个流，其源是从调用返回的枚举派生到 elements() 。
        结果
        所有权限的流。
        从以下版本开始：
        9

      • setReadOnly

        public void setReadOnly​()
        将此PermissionCollection对象标记为“只读”。 PermissionCollection对象被标记为只读方式后，不能使用add添加新的权限对象。

      • isReadOnly

        public boolean isReadOnly​()
        如果此PermissionCollection对象被标记为只读方式，则返回true。 如果是只读方式，则不能使用add添加新的权限对象。

        默认情况下，对象不是只读的。 它可以通过调用setReadOnly设置为只读。

        结果
        如果此PermissionCollection对象被标记为只读，则为true，否则为false。

      • toString

        public String toString​()
        返回描述此PermissionCollection对象的字符串，提供有关其所包含的所有权限的信息。 格式为：
          super.toString() (
   // enumerate all the Permission
   // objects and call toString() on them,
   // one per line..
 )
        super.toString是一个调用这个对象的超类的这个toString方法，它是Object。 结果是这个PermissionCollection的类型名称后跟这个对象的哈希码，因此使客户端区分不同的PermissionCollections对象，即使它们包含相同的权限。
        重写：
        toString在 Object
        结果
        有关此PermissionCollection对象的信息，如上所述。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Permissions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Permissions

  • java.lang.Object
    • java.security.PermissionCollection
      • java.security.Permissions
  • All Implemented Interfaces:
    Serializable

    public final class Permissions
extends PermissionCollection
implements Serializable
    此类表示许多权限的异构集合。 也就是说，它包含不同类型的Permission对象，它们被组织成PermissionCollections。 例如，如果任何java.io.FilePermission对象添加到此类的实例，它们都将存储在单个PermissionCollection中。 它是通过调用FilePermission类中的newPermissionCollection方法返回的PermissionCollection。 类似地，任何java.lang.RuntimePermission对象都存储在调用RuntimePermission类中的newPermissionCollection方法返回的PermissionCollection中。 因此，此类表示PermissionCollections的集合。

    当调用add方法添加权限时，权限将存储在适当的PermissionCollection中。 如果尚未存在此类集合，则会确定Permission对象的类，并在newPermissionCollection上调用newPermissionCollection方法来创建PermissionCollection并将其添加到Permissions对象。 如果newPermissionCollection返回null，则将创建并使用使用散列表的默认PermissionCollection。 每个散列表条目都将Permission对象存储为键和值。

    通过elements方法返回的枚举不是故障快速的 。 在枚举集合时不应执行对集合的修改。

    从以下版本开始：
    1.2
    另请参见：
    Permission ， PermissionCollection ， AllPermission

    • 构造方法摘要

      构造方法
      Constructor 描述
      Permissions​()
      创建一个不包含PermissionCollections的新Permissions对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(Permission permission)
      将权限对象添加到权限所属的类的PermissionCollection。
      Enumeration<Permission> elements​()
      返回此Permissions对象中所有PermissionCollections中所有Permission对象的枚举。
      boolean implies​(Permission permission)
      检查此对象的PermissionCollection是否具有指定权限类的权限，这意味着在 权限对象中表达的 权限 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.PermissionCollection

        elementsAsStream, isReadOnly, setReadOnly, toString

    • 构造方法详细信息

      • Permissions

        public Permissions​()
        创建一个不包含PermissionCollections的新Permissions对象。

    • 方法详细信息

      • add

        public void add​(Permission permission)
        将权限对象添加到权限所属的类的PermissionCollection。 例如，如果权限是FilePermission，则将其添加到此Permissions对象中存储的FilePermissionCollection中。 此方法创建一个新的PermissionCollection对象（并向其添加权限）如果一个适当的集合尚不存在。
        Specified by:
        add PermissionCollection
        参数
        permission - 要添加的权限对象。
        异常
        SecurityException - 如果此Permissions对象被标记为只读方式。
        另请参见：
        PermissionCollection.isReadOnly()

      • implies

        public boolean implies​(Permission permission)
        检查此对象的PermissionCollection是否具有指定权限类的权限，这意味着在权限对象中表达的权限 。 如果适当的PermissionCollection（例如，FilePermission的FilePermissionCollection）中的权限组合在一起意味着指定的权限，则返回true。

        例如，假设此Permissions对象中有一个FilePermissionCollection，并且它包含一个FilePermission，它为“/ tmp”目录的所有子目录中的所有文件指定了“读取”访问权限，另一个为所有文件指定“写入”访问权限的FilePermission在“/ tmp / scratch / foo”目录中。 然后，如果以“/ tmp / scratch / foo”目录中的文件同时指定了“读取”和“写入”权限来调用implies方法，则返回true 。

        此外，如果此PermissionCollection包含AllPermission，此方法将始终返回true。

        Specified by:
        implies在 PermissionCollection
        参数
        permission - 要检查的权限对象。
        结果
        如果PermissionCollection中的权限隐含“权限”，则为true，否则为false。

      • elements

        public Enumeration<Permission> elements​()
        返回此Permissions对象中所有PermissionCollections中所有Permission对象的枚举。
        Specified by:
        elements在 PermissionCollection
        结果
        列举所有权限。
        另请参见：
        PermissionCollection.elementsAsStream()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PKCS12Attribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class PKCS12Attribute

  • java.lang.Object
    • java.security.PKCS12Attribute
  • All Implemented Interfaces:
    KeyStore.Entry.Attribute

    public final class PKCS12Attribute
extends Object
implements KeyStore.Entry.Attribute
    与PKCS12密钥库条目关联的属性。 属性名称是ASN.1对象标识符，属性值是一组ASN.1类型。
    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      PKCS12Attribute​(byte[] encoded)
      从其ASN.1 DER编码构造PKCS12属性。
      PKCS12Attribute​(String name, String value)
      从其名称和值构造PKCS12属性。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      比较这个 PKCS12Attribute和一个指定的对象的相等性。
      byte[] getEncoded​()
      返回属性的ASN.1 DER编码。
      String getName​()
      返回表示为点分隔整数列表的属性的ASN.1对象标识符。
      String getValue​()
      返回属性的ASN.1 DER编码值作为字符串。
      int hashCode​()
      返回此 PKCS12Attribute的哈希 PKCS12Attribute 。
      String toString​()
      返回此 PKCS12Attribute的字符串表示 PKCS12Attribute 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PKCS12Attribute

        public PKCS12Attribute​(String name,
                       String value)
        从其名称和值构造PKCS12属性。 该名称是表示为点分隔整数列表的ASN.1对象标识符。 字符串值表示为字符串本身。 二进制值表示为冒号分隔的十六进制数字对的字符串。 多值属性用逗号分隔的值列表表示，方括号括起来。 见Arrays.toString(java.lang.Object[]) 。

        字符串值将作为ASN.1 UTF8String进行DER编码，二进制值将作为ASN.1八位字节字符串进行DER编码。

        参数
        name - 属性的标识符
        value - 属性的值
        异常
        NullPointerException - 如果是 name或 value是 null
        IllegalArgumentException - 如果 name或 value格式不正确

      • PKCS12Attribute

        public PKCS12Attribute​(byte[] encoded)
        从其ASN.1 DER编码构造PKCS12属性。 DER编码由以下ASN.1定义指定：
          Attribute ::= SEQUENCE {
     type   AttributeType,
     values SET OF AttributeValue
 }
 AttributeType ::= OBJECT IDENTIFIER
 AttributeValue ::= ANY defined by type
        参数
        encoded - 属性的ASN.1 DER编码。 克隆以防止随后的修改。
        异常
        NullPointerException - 如果 encoded是 null
        IllegalArgumentException - 如果 encoded格式不正确

    • 方法详细信息

      • getName

        public String getName​()
        返回表示为点分隔整数列表的属性的ASN.1对象标识符。
        Specified by:
        getName在接口 KeyStore.Entry.Attribute
        结果
        属性的标识符

      • getValue

        public String getValue​()
        返回属性的ASN.1 DER编码值作为字符串。 ASN.1 DER编码值返回以下String格式之一：
        • 具有自然字符串表示形式的基本ASN.1类型的DER编码作为字符串本身返回。 此类型目前仅限于BOOLEAN，INTEGER，OBJECT IDENTIFIER，UTCTime，GeneralizedTime和以下六种ASN.1字符串类型：UTF8String，PrintableString，T61String，IA5String，BMPString和GeneralString。
        • 任何其他ASN.1类型的DER编码未被解码，而是以冒号分隔的十六进制数字的二进制字符串的形式返回。
        多值属性用逗号分隔的值列表表示，方括号括起来。 见Arrays.toString(java.lang.Object[]) 。
        Specified by:
        getValue在接口 KeyStore.Entry.Attribute
        结果
        属性值的字符串编码

      • getEncoded

        public byte[] getEncoded​()
        返回属性的ASN.1 DER编码。
        结果
        属性的DER编码的克隆

      • equals

        public boolean equals​(Object obj)
        比较这个 PKCS12Attribute和一个指定的对象进行相等。
        重写：
        equals在 Object
        参数
        obj - 比较对象
        结果
        如果 obj是一个 PKCS12Attribute并且它们的DER编码相等， PKCS12Attribute true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此PKCS12Attribute的哈希PKCS12Attribute 。 哈希码是根据其DER编码计算的。
        重写：
        hashCode Object
        结果
        哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此 PKCS12Attribute的字符串表示 PKCS12Attribute 。
        重写：
        toString在 Object
        结果
        一个由“等于”符号分隔的名称/值对
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Policy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Policy

  • java.lang.Object
    • java.security.Policy

  • public abstract class Policy
extends Object
    Policy对象负责确定在Java运行时环境中执行的代码是否具有执行安全敏感操作的权限。

    在任何给定时间，运行时只安装一个策略对象。 可以通过调用setPolicy方法来安装Policy对象。 可以通过调用getPolicy方法获得安装的Policy对象。

    如果运行时中没有安装Policy对象，则调用getPolicy将安装默认Policy实现（该抽象类的默认子类实现）的实例。 可以通过将policy.provider安全属性的值设置为所需策略子类实现的完全限定名称来更改默认策略实现。 系统类加载器用于加载此类。

    应用程序代码可以直接子类化Policy来提供自定义的实现。 另外，可以通过使用标准类型调用getInstance工厂方法之一来构建Policy对象的实例。 默认策略类型为“JavaPolicy”。

    一旦安装了Policy实例（默认情况下，或通过调用setPolicy ），Java运行时需要确定执行代码（封装在ProtectionDomain中）是否可以执行SecurityManager保护的操作时，会调用其implies方法。 Policy对象检索其策略数据取决于策略实现本身。 策略数据可以例如存储在平面ASCII文件中，在Policy类的序列化二进制文件中，或者存储在数据库中。

    refresh方法会导致策略对象刷新/重新加载其数据。 这个操作是依赖于实现的。 例如，如果策略对象将其数据存储在配置文件中，则调用refresh会使其重新读取配置策略文件。 如果不支持刷新操作，则此方法不执行任何操作。 请注意，刷新的策略可能不会对特定ProtectionDomain中的类产生影响。 这取决于策略提供商的implies方法及其PermissionCollection缓存策略的实现。

    从以下版本开始：
    1.2
    另请参见：
    Provider ， ProtectionDomain ， Permission ， security properties

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static interface  Policy.Parameters
      这表示Policy参数的标记界面。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PermissionCollection UNSUPPORTED_EMPTY_COLLECTION
      只读空PermissionCollection实例。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Policy​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static Policy getInstance​(String type, Policy.Parameters params)
      返回指定类型的Policy对象。
      static Policy getInstance​(String type, Policy.Parameters params, String provider)
      返回指定类型的Policy对象。
      static Policy getInstance​(String type, Policy.Parameters params, Provider provider)
      返回指定类型的Policy对象。
      Policy.Parameters getParameters​()
      退货政策参数。
      PermissionCollection getPermissions​(CodeSource codesource)
      返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。
      PermissionCollection getPermissions​(ProtectionDomain domain)
      返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。
      static Policy getPolicy​()
      返回已安装的Policy对象。
      Provider getProvider​()
      返回本政策的提供者。
      String getType​()
      返回此策略的类型。
      boolean implies​(ProtectionDomain domain, Permission permission)
      评估授予ProtectionDomain的权限的全局策略，并测试是否授予权限。
      void refresh​()
      刷新/重新加载策略配置。
      static void setPolicy​(Policy p)
      设置系统范围的Policy对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • UNSUPPORTED_EMPTY_COLLECTION

        public static final PermissionCollection UNSUPPORTED_EMPTY_COLLECTION
        只读空PermissionCollection实例。
        从以下版本开始：
        1.6

    • 构造方法详细信息

      • Policy

        public Policy​()

    • 方法详细信息

      • getPolicy

        public static Policy getPolicy​()
        返回已安装的Policy对象。 该值不应该缓存，因为它可以通过调用setPolicy 。 此方法首先调用SecurityManager.checkPermission具有SecurityPermission("getPolicy")权限，以确保获取Policy对象。
        结果
        已安装的策略。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许获取Policy对象。
        另请参见：
        SecurityManager.checkPermission(Permission) ， setPolicy(java.security.Policy)

      • setPolicy

        public static void setPolicy​(Policy p)
        设置系统范围的Policy对象。 该方法首先调用SecurityManager.checkPermission具有SecurityPermission("setPolicy")权限，以确保设置策略是SecurityPermission("setPolicy")的。
        参数
        p - 新的系统策略对象。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许设置策略。
        另请参见：
        SecurityManager.checkPermission(Permission) ， getPolicy()

      • getInstance

        public static Policy getInstance​(String type,
                                 Policy.Parameters params)
                          throws NoSuchAlgorithmException
        返回指定类型的Policy对象。

        此方法遍历已注册的安全提供程序列表，从最为首选的提供程序开始。 返回从支持指定类型的第一个Provider中封装PolicySpi实现的新策略对象。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        type - 指定的策略类型。 有关标准策略类型的列表，请参阅Java Security Standard Algorithm Names Specification中的“策略”部分。
        params - 策略的参数，可能为null。
        结果
        新的 Policy对象
        异常
        IllegalArgumentException - 如果指定的参数不能被 PolicySpi实现从所选 Provider
        NoSuchAlgorithmException - 如果没有 Provider支持指定类型的 PolicySpi实现
        NullPointerException - 如果 type是 null
        SecurityException - 如果调用者没有获取指定类型的 Policy实例的权限。
        从以下版本开始：
        1.6
        另请参见：
        Provider

      • getInstance

        public static Policy getInstance​(String type,
                                 Policy.Parameters params,
                                 String provider)
                          throws NoSuchProviderException,
                                 NoSuchAlgorithmException
        返回指定类型的Policy对象。

        返回从指定提供程序封装PolicySpi实现的新策略对象。 指定的提供者必须在提供者列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        type - 指定的策略类型。 有关标准策略类型的列表，请参阅Java Security Standard Algorithm Names Specification中的“策略”部分。
        params - 策略的参数，可以为null。
        provider - 提供商。
        结果
        新的 Policy对象
        异常
        IllegalArgumentException - 如果指定的提供者是 null或为空，或指定的参数不能被指定的提供者的 PolicySpi实现所理解
        NoSuchAlgorithmException - 如果指定的提供程序不支持指定类型的 PolicySpi实现
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException -如果 type为 null
        SecurityException - 如果主叫方没有获得指定类型的 Policy实例的权限
        从以下版本开始：
        1.6
        另请参见：
        Provider

      • getInstance

        public static Policy getInstance​(String type,
                                 Policy.Parameters params,
                                 Provider provider)
                          throws NoSuchAlgorithmException
        返回指定类型的Policy对象。

        返回从指定的Provider对象封装PolicySpi实现的新策略对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        type - 指定的策略类型。 有关标准策略类型的列表，请参阅Java Security Standard Algorithm Names Specification中的策略部分。
        params - 策略的参数，可以为null。
        provider - 提供者。
        结果
        新的 Policy对象
        异常
        IllegalArgumentException - 如果指定的 Provider是 null ，或者指定的参数不能被指定的 PolicySpi实现从 Provider
        NoSuchAlgorithmException - 如果指定的 Provider不支持指定类型的 PolicySpi实现
        NullPointerException - 如果 type是 null
        SecurityException - 如果调用者没有获得指定类型的 Policy实例的权限
        从以下版本开始：
        1.6
        另请参见：
        Provider

      • getProvider

        public Provider getProvider​()
        返回本政策的提供者。

        如果通过调用Policy.getInstance获取该策略实例，则只有一个提供者。 否则，此方法返回null。

        结果
        该策略的提供者，或null。
        从以下版本开始：
        1.6

      • getType

        public String getType​()
        返回此策略的类型。

        此策略实例只有通过调用Policy.getInstance获取的类型。 否则，此方法返回null。

        结果
        此策略的类型，或null。
        从以下版本开始：
        1.6

      • getParameters

        public Policy.Parameters getParameters​()
        退货政策参数。

        此策略实例只有通过调用Policy.getInstance获取参数。 否则，此方法返回null。

        结果
        策略参数，或null。
        从以下版本开始：
        1.6

      • getPermissions

        public PermissionCollection getPermissions​(CodeSource codesource)
        返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。

        不鼓励应用程序调用此方法，因为所有策略实现可能不支持该操作。 应用程序应完全依靠implies方法执行策略检查。 如果应用程序绝对必须调用getPermissions方法，那么它应该调用getPermissions(ProtectionDomain) 。

        此方法的默认实现返回Policy.UNSUPPORTED_EMPTY_COLLECTION。 如果策略实现可以返回授予CodeSource的一组权限，则可以覆盖此方法。

        参数
        codesource - 已向其授予返回的PermissionCollection的CodeSource。
        结果
        一组授予给指定CodeSource的权限。 如果支持此操作，则返回的权限集必须是新的可变实例，并且必须支持异构许可类型。 如果不支持此操作，则返回Policy.UNSUPPORTED_EMPTY_COLLECTION。

      • getPermissions

        public PermissionCollection getPermissions​(ProtectionDomain domain)
        返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。

        不鼓励应用程序调用此方法，因为所有策略实现可能不支持该操作。 应用程序应依靠implies方法执行策略检查。

        此方法的默认实现首先检索通过getPermissions(CodeSource)返回的权限（CodeSource取自指定的ProtectionDomain）以及位于指定的ProtectionDomain内的权限。 然后将所有这些权限组合并返回到新的PermissionCollection对象中。 如果getPermissions(CodeSource)返回Policy.UNSUPPORTED_EMPTY_COLLECTION，则此方法返回新的PermissionCollection对象中指定的ProtectionDomain中包含的权限。

        如果策略实现支持返回授予ProtectionDomain的一组权限，则可以覆盖此方法。

        参数
        domain - 已授予返回的PermissionCollection的ProtectionDomain。
        结果
        授予指定的ProtectionDomain的一组权限。 如果支持此操作，则返回的权限集必须是新的可变实例，并且必须支持异构许可类型。 如果不支持此操作，则返回Policy.UNSUPPORTED_EMPTY_COLLECTION。
        从以下版本开始：
        1.4

      • implies

        public boolean implies​(ProtectionDomain domain,
                       Permission permission)
        评估授予ProtectionDomain的权限的全局策略，并测试是否授予权限。
        参数
        domain - 要保护域要测试
        permission - 要测试的Permission对象的含义。
        结果
        如果“权限”是授予此ProtectionDomain的权限的适当子集，则为true。
        从以下版本开始：
        1.4
        另请参见：
        ProtectionDomain

      • refresh

        public void refresh​()
        刷新/重新加载策略配置。 该方法的行为取决于实现。 例如，对基于文件的策略调用refresh将导致重新读取该文件。

        这种方法的默认实现什么都不做。 如果策略实现支持刷新操作，则该方法应该被覆盖。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Policy.Parameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface Policy.Parameters

  • 所有已知实现类：
    URIParameter
    Enclosing class:
    Policy

    public static interface Policy.Parameters
    这表示Policy参数的标记界面。
    从以下版本开始：
    1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PolicySpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class PolicySpi

  • java.lang.Object
    • java.security.PolicySpi

  • public abstract class PolicySpi
extends Object
    该类定义了Policy类的 （ SPI ）。 此类中的所有抽象方法必须由希望提供Policy实施的每个服务提供商实现。

    此抽象类的子类实现必须提供一个公共构造函数，它将一个Policy.Parameters对象作为输入参数。 如果不了解Policy.Parameters输入，这个构造函数也必须抛出一个IllegalArgumentException。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      PolicySpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected PermissionCollection engineGetPermissions​(CodeSource codesource)
      返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。
      protected PermissionCollection engineGetPermissions​(ProtectionDomain domain)
      返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。
      protected abstract boolean engineImplies​(ProtectionDomain domain, Permission permission)
      检查策略是否授予了ProtectionDomain的权限。
      protected void engineRefresh​()
      刷新/重新加载策略配置。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PolicySpi

        public PolicySpi​()

    • 方法详细信息

      • engineImplies

        protected abstract boolean engineImplies​(ProtectionDomain domain,
                                         Permission permission)
        检查策略是否授予了ProtectionDomain的权限。
        参数
        domain - 要检查的ProtectionDomain。
        permission - 检查是否将此权限授予给指定的域。
        结果
        boolean如果权限授予域，则为true。

      • engineRefresh

        protected void engineRefresh​()
        刷新/重新加载策略配置。 该方法的行为取决于实现。 例如，对基于文件的策略调用refresh将导致重新读取该文件。

        这种方法的默认实现什么都不做。 如果策略实现支持刷新操作，则该方法应该被覆盖。

      • engineGetPermissions

        protected PermissionCollection engineGetPermissions​(CodeSource codesource)
        返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。

        此方法的默认实现返回Policy.UNSUPPORTED_EMPTY_COLLECTION对象。 如果策略实现可以返回授予CodeSource的一组权限，则可以覆盖此方法。

        参数
        codesource - 已授予返回的PermissionCollection的CodeSource。
        结果
        一组授予给指定CodeSource的权限。 如果支持此操作，则返回的权限集必须是新的可变实例，并且必须支持异构许可类型。 如果不支持此操作，则返回Policy.UNSUPPORTED_EMPTY_COLLECTION。

      • engineGetPermissions

        protected PermissionCollection engineGetPermissions​(ProtectionDomain domain)
        返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。

        此方法的默认实现返回Policy.UNSUPPORTED_EMPTY_COLLECTION对象。 如果策略实现可以返回授予ProtectionDomain的一组权限，则可以覆盖此方法。

        参数
        domain - 已授予返回的PermissionCollection的ProtectionDomain。
        结果
        授予指定的ProtectionDomain的一组权限。 如果支持此操作，则返回的权限集必须是新的可变实例，并且必须支持异构许可类型。 如果不支持此操作，则返回Policy.UNSUPPORTED_EMPTY_COLLECTION。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Principal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface Principal

  • All Known Subinterfaces:
    Group ， GroupPrincipal ， UserPrincipal
    所有已知实现类：
    HttpPrincipal ， Identity ， IdentityScope ， JMXPrincipal ， KerberosPrincipal ， LdapPrincipal ， NTDomainPrincipal ， NTSid ， NTSidDomainPrincipal ， NTSidGroupPrincipal ， NTSidPrimaryGroupPrincipal ， NTSidUserPrincipal ， NTUserPrincipal ， Signer ， SolarisNumericGroupPrincipal ， SolarisNumericUserPrincipal ， SolarisPrincipal ， UnixNumericGroupPrincipal ， UnixNumericUserPrincipal ， UnixPrincipal ， UserPrincipal ， X500Principal ， X500Principal

    public interface Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
    从以下版本开始：
    1.1
    另请参见：
    X509Certificate

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean equals​(Object another)
      将此主体与指定对象进行比较。
      String getName​()
      返回此主体的名称。
      int hashCode​()
      返回此主体的哈希码。
      default boolean implies​(Subject subject)
      如果该主体隐含指定的主题，则返回true。
      String toString​()
      返回此主体的字符串表示形式。

    • 方法详细信息

      • equals

        boolean equals​(Object another)
        将此主体与指定对象进行比较。 如果传入的对象匹配由此接口的实现表示的主体，则返回true。
        重写：
        equals在 Object
        参数
        another - 与...相比较。
        结果
        如果所传递的主体与该主体封装的主体相同，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        String toString​()
        返回此主体的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个主体的字符串表示。

      • hashCode

        int hashCode​()
        返回此主体的哈希码。
        重写：
        hashCode在 Object
        结果
        这个主体的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getName

        String getName​()
        返回此主体的名称。
        结果
        这个委托人的名字。

      • implies

        default boolean implies​(Subject subject)
        如果该主体隐含指定的主题，则返回true。
        实现要求：
        如果subject非空，则此方法的默认实现将返回true，并且至少包含一个等于此主体的主体。

        如果需要，子类可以用不同的实现覆盖它。

        参数
        subject - Subject
        结果
        如果 subject是非空的，并且由该主体暗示，则为true，否则为false。
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface PrivateKey

  • All Superinterfaces:
    Destroyable ， Key ， Serializable
    All Known Subinterfaces:
    DHPrivateKey ， DSAPrivateKey ， ECPrivateKey ， RSAMultiPrimePrivateCrtKey ， RSAPrivateCrtKey ， RSAPrivateKey

    public interface PrivateKey
extends Key, Destroyable
    私钥。 该接口的目的是为所有私钥接口分组（并提供类型安全性）。

    注意：专用私钥接口扩展了这个接口。 参见，例如， DSAPrivateKey接口在java.security.interfaces中 。

    实现应该覆盖来自Destroyable接口的默认destroy和isDestroyed方法，以使敏感密钥信息被销毁，清除，或者在这些信息是不可变的，未被引用的情况下。 最后，由于PrivateKey是Serializable ，实现也应该覆盖ObjectOutputStream.writeObject(java.lang.Object)，以防止被破坏的密钥被序列化。

    从以下版本开始：
    1.1
    另请参见：
    Key ， PublicKey ， Certificate ， Signature.initVerify(java.security.PublicKey) ， DSAPrivateKey ， RSAPrivateKey ， RSAPrivateCrtKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      类指纹被设置为指示与以前版本的类的序列化兼容性。

    • 方法摘要

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        类指纹被设置为指示与以前版本的类的序列化兼容性。
        另请参见：
        Constant Field Values
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PrivilegedAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface PrivilegedAction<T>

  • public interface PrivilegedAction<T>
    要启用权限执行的计算。 通过在PrivilegedAction对象上调用AccessController.doPrivileged来执行计算。 此接口仅用于不抛出检查异常的计算; 抛出检查的异常的计算必须使用PrivilegedExceptionAction 。
    从以下版本开始：
    1.2
    另请参见：
    AccessController ， AccessController.doPrivileged(PrivilegedAction) ， PrivilegedExceptionAction

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      T run​()
      执行计算。

    • 方法详细信息

      • run

        T run​()
        执行计算。 此方法将在启用权限后由AccessController.doPrivileged调用。
        结果
        可以表示计算结果的类依赖值。 实现PrivilegedAction每个类应该记录这个值代表什么（如果有的话）。
        另请参见：
        AccessController.doPrivileged(PrivilegedAction), AccessController.doPrivileged(PrivilegedAction, AccessControlContext)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrivilegedActionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class PrivilegedActionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.PrivilegedActionException
  • All Implemented Interfaces:
    Serializable

    public class PrivilegedActionException
extends 异常
    这个异常是由doPrivileged(PrivilegedExceptionAction)和doPrivileged(PrivilegedExceptionAction, AccessControlContext context)引发的，表示正在执行的操作会抛出一个被检查的异常。 可以通过调用getException方法获取动作抛出的异常。 实际上， PrivilegedActionException是特权操作抛出的异常的“包装器”。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 在建造时提供的“通过特权计算抛出的异常”是通过getException()方法访问的，现在被称为原因 ，并且可以通过Throwable.getCause()方法以及上述“传统方法”来访问。

    从以下版本开始：
    1.2
    另请参见：
    PrivilegedExceptionAction ， AccessController.doPrivileged(PrivilegedExceptionAction) ， AccessController.doPrivileged(PrivilegedExceptionAction,AccessControlContext) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrivilegedActionException​(异常 exception)
      构造一个新的PrivilegedActionException“包装”特定的异常。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回此异常的原因（导致此 PrivilegedActionException的特权计算抛出的异常）。
      异常 getException​()
      返回导致此 PrivilegedActionException的特权计算抛出的异常。
      String toString​()
      返回此可抛出的简短描述。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

    • 构造方法详细信息

      • PrivilegedActionException

        public PrivilegedActionException​(异常 exception)
        构造一个新的PrivilegedActionException“包装”特定的异常。
        参数
        exception - 抛出的异常

    • 方法详细信息

      • getException

        public 异常 getException​()
        返回导致此PrivilegedActionException的特权计算抛出的异常。

        这种方法早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

        结果
        特权计算引发的异常导致了这个 PrivilegedActionException 。
        另请参见：
        PrivilegedExceptionAction ， AccessController.doPrivileged(PrivilegedExceptionAction) ， AccessController.doPrivileged(PrivilegedExceptionAction, AccessControlContext)

      • getCause

        public Throwable getCause​()
        返回此异常的原因（导致此 PrivilegedActionException的特权计算抛出的异常）。
        重写：
        getCause在 Throwable
        结果
        这个例外的原因。
        从以下版本开始：
        1.4

      • toString

        public String toString​()
        描述从类别复制Throwable
        返回此可抛出的简短描述。 结果是：
        • 这个对象的类的name
        • “：”（一个冒号和一个空格）
        • 调用该对象的Throwable.getLocalizedMessage()方法的结果
        如果getLocalizedMessage返回null ，那么只返回类名。
        重写：
        toString在 Throwable
        结果
        这个throwable的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrivilegedExceptionAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface PrivilegedExceptionAction<T>

  • public interface PrivilegedExceptionAction<T>
    要启用权限执行的计算，会抛出一个或多个已检查的异常。 通过在PrivilegedExceptionAction对象上调用AccessController.doPrivileged来执行计算。 此接口仅用于抛出已检查异常的计算; 不抛出检查异常的计算应该使用PrivilegedAction 。
    从以下版本开始：
    1.2
    另请参见：
    AccessController ， AccessController.doPrivileged(PrivilegedExceptionAction) ， AccessController.doPrivileged(PrivilegedExceptionAction, AccessControlContext) ， PrivilegedAction

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      T run​()
      执行计算。

    • 方法详细信息

      • run

        T run​()
throws 异常
        执行计算。 此方法将在启用权限后由AccessController.doPrivileged调用。
        结果
        可以表示计算结果的类依赖值。 实现PrivilegedExceptionAction每个类应该记录这个值代表什么（如果有的话）。
        异常
        异常 - 发生了特殊情况。 实现PrivilegedExceptionAction每个类应该记录其运行方法可以抛出的异常。
        另请参见：
        AccessController.doPrivileged(PrivilegedExceptionAction) ， AccessController.doPrivileged(PrivilegedExceptionAction,AccessControlContext)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProtectionDomain (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class ProtectionDomain

  • java.lang.Object
    • java.security.ProtectionDomain

  • public class ProtectionDomain
extends Object
    ProtectionDomain类封装了一个域的特性，该域包含一组类，当代表一组给定的主体执行时，该类的实例被授予一组权限。

    一个静态权限集可以在构建时绑定到一个ProtectionDomain; 不管有效的政策如何，这种权限都被授予域。 但是，为了支持动态安全策略，还可以构建一个ProtectionDomain，使得当检查权限时，它将被动态映射到当前策略的一组权限。

    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProtectionDomain​(CodeSource codesource, PermissionCollection permissions)
      使用给定的CodeSource和权限创建一个新的ProtectionDomain。
      ProtectionDomain​(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
      创建一个由给定的CodeSource，Permissions，ClassLoader和Principals数组限定的新的ProtectionDomain。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ClassLoader getClassLoader​()
      返回此域的ClassLoader。
      CodeSource getCodeSource​()
      返回此域的CodeSource。
      PermissionCollection getPermissions​()
      返回授予此域的静态权限。
      Principal[] getPrincipals​()
      返回此域的主体数组。
      boolean implies​(Permission perm)
      检查并看看ProtectionDomain是否隐含在Permission对象中表达的权限。
      boolean staticPermissionsOnly​()
      如果此域只包含静态权限，并且在许可检查时不检查当前的 Policy ，则返回true。
      String toString​()
      将ProtectionDomain转换为字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ProtectionDomain

        public ProtectionDomain​(CodeSource codesource,
                        PermissionCollection permissions)
        使用给定的CodeSource和权限创建一个新的ProtectionDomain。 如果权限对象不为空，那么将在传入的Permissions对象中调用setReadOnly() 。

        授予此域的权限是静态的，即调用staticPermissionsOnly()方法返回true。 它们只包含传递给此构造函数的那些，并且不会查询当前的“策略”。

        参数
        codesource - 与该域相关联的代码源
        permissions - 授予此域的权限

      • ProtectionDomain

        public ProtectionDomain​(CodeSource codesource,
                        PermissionCollection permissions,
                        ClassLoader classloader,
                        Principal[] principals)
        创建一个由给定的CodeSource，Permissions，ClassLoader和Principals数组限定的新的ProtectionDomain。 如果权限对象不为空，那么将在传入的Permissions对象中调用setReadOnly() 。

        授予此域的权限是动态的，即调用staticPermissionsOnly()方法返回false。 它们包括传递给此构造函数的静态权限以及当前策略在选中权限时授予此域的任何权限。

        此构造函数通常由ClassLoaders和DomainCombiners使用， 代理到Policy以主动关联授予此域的权限。 此构造函数为策略提供者提供了增加提供的PermissionCollection以反映策略更改的机会。

        参数
        codesource - 与此域相关联的CodeSource
        permissions - 授予此域的权限
        classloader - 与此域相关联的ClassLoader
        principals - 与此域相关联的主体数组。 复制数组的内容以防止后续修改。
        从以下版本开始：
        1.4
        另请参见：
        Policy.refresh() ， Policy.getPermissions(ProtectionDomain)

    • 方法详细信息

      • getCodeSource

        public final CodeSource getCodeSource​()
        返回此域的CodeSource。
        结果
        该域的CodeSource可能为null。
        从以下版本开始：
        1.2

      • getClassLoader

        public final ClassLoader getClassLoader​()
        返回此域的ClassLoader。
        结果
        该域的ClassLoader可以为null。
        从以下版本开始：
        1.4

      • getPrincipals

        public final Principal[] getPrincipals​()
        返回此域的主体数组。
        结果
        此域的一个非空数组的主体。 每次调用此方法时都会返回一个新数组。
        从以下版本开始：
        1.4

      • getPermissions

        public final PermissionCollection getPermissions​()
        返回授予此域的静态权限。
        结果
        该域的静态权限集可能为null。
        另请参见：
        Policy.refresh() ， Policy.getPermissions(ProtectionDomain)

      • staticPermissionsOnly

        public final boolean staticPermissionsOnly​()
        如果此域仅包含静态权限，并且在许可检查时不检查当前的 Policy ，则返回true。
        结果
        如果此域仅包含静态权限，则为true。
        从以下版本开始：
        9

      • implies

        public boolean implies​(Permission perm)
        检查并看看ProtectionDomain是否隐含在Permission对象中表达的权限。

        所评估的权限集是ProtectionDomain是否由静态权限组构建的功能，或者绑定到一组动态映射的权限集。

        如果staticPermissionsOnly()方法返回true，那么只能根据构造中提供的PermissionCollection进行权限检查。

        否则，将根据构建中提供的PermissionCollection和当前的Policy绑定来组合权限。

        参数
        perm - 要检查的权限对象。
        结果
        如果此ProtectionDomain隐含有 perm则为true。

      • toString

        public String toString​()
        将ProtectionDomain转换为字符串。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Provider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Provider

  • java.lang.Object
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<Object,Object>
        • java.util.Properties
          • java.security.Provider
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Map<Object,Object>
    已知直接子类：
    AuthProvider

    public abstract class Provider
extends Properties
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。 提供商可能实施的服务包括：
    • 算法（如DSA，RSA或SHA-256）。
    • 密钥生成，转换和管理功能（如针对特定于算法的密钥）。

    一些提供者实现在其操作期间可能会遇到不可恢复的内部错误，例如无法与安全令牌进行通信。 A ProviderException应用于指示此类错误。

    请注意，可以使用提供程序来实现Java中的任何安全服务，该安全服务使用可插拔架构，并可选择适合的实现。

    服务类型Provider保留供安全框架使用。 这种类型的服务不能被应用程序添加，删除或修改。 以下属性将自动放置在每个Provider对象中：

    Attributes Automatically Placed in a Provider Object Name Value Provider.id name String.valueOf(provider.getName()) Provider.id version String.valueOf(provider.getVersionStr()) Provider.id info String.valueOf(provider.getInfo()) Provider.id className provider.getClass().getName()

    每个提供者都有一个名称和一个版本字符串。 提供者通常在资源目录META-INF/services标识一个名为java.security.Provider的文件。 安全提供商通过ServiceLoader机制查询，使用application class loader 。

    提供商可以被配置为使得它们在运行时通过Security.getProviders()方法被自动安装并使其可用。 配置和安装安全提供程序的机制是实现特定的。

    Implementation Note:
    JDK实现支持通过Java安装目录中的conf/security/java.security文件静态注册安全提供程序。 JDK运行时自动安装这些提供程序，请参阅“Java加密体系结构（JCA）参考指南”中的The Provider Class ，了解有关特定类型的提供程序，加密服务提供程序的工作原理和安装方式的信息。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Provider.Service
      安全服务的描述。

    • Field Summary

      • Fields inherited from class java.util.Properties

        defaults

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Provider​(String name, double version, String info)
      已过时。
      改用Provider(String, String, String) 。
      protected Provider​(String name, String versionStr, String info)
      构造具有指定名称，版本字符串和信息的提供程序。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void clear​()
      清除此提供程序，使其不再包含用于查找由提供程序实施的设施的属性。
      Object compute​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      Object computeIfAbsent​(Object key, Function<? super Object,? extends Object> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      Object computeIfPresent​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      Provider configure​(String configArg)
      将提供的配置参数应用于此提供程序实例并返回配置的提供程序。
      Enumeration<Object> elements​()
      返回此散列表中值的枚举。
      Set<Map.Entry<Object,Object>> entrySet​()
      返回此提供程序中包含的属性条目的不可修改的Set视图。
      void forEach​(BiConsumer<? super Object,? super Object> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      Object get​(Object key)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。
      String getInfo​()
      返回提供商及其服务的可读描述。
      String getName​()
      返回此提供程序的名称。
      Object getOrDefault​(Object key, Object defaultValue)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。
      String getProperty​(String key)
      使用此属性列表中指定的键搜索属性。
      Provider.Service getService​(String type, String algorithm)
      获取描述此提供程序实现该算法或别名的指定类型的服务。
      Set<Provider.Service> getServices​()
      获取不可修改的此提供程序支持的所有服务的集合。
      double getVersion​()
      已过时。
      请改用getVersionStr() 。
      String getVersionStr​()
      返回此提供程序的版本字符串。
      boolean isConfigured​()
      检查此提供程序实例是否已配置。
      Enumeration<Object> keys​()
      返回此散列表中键的枚举。
      Set<Object> keySet​()
      返回此提供程序中包含的属性键的不可修改的Set视图。
      void load​(InputStream inStream)
      从输入流读取属性列表（键和元素对）。
      Object merge​(Object key, Object value, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)
      如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。
      Object put​(Object key, Object value)
      将 key属性设置为具有指定的 value 。
      void putAll​(Map<?,?> t)
      将指定地图中的所有映射复制到此提供程序。
      Object putIfAbsent​(Object key, Object value)
      如果指定的键尚未与值相关联（或映射到 null ）将其与给定值相关联并返回 null ，否则返回当前值。
      protected void putService​(Provider.Service s)
      添加服务。
      Object remove​(Object key)
      删除 key属性（及其对应的 value ）。
      boolean remove​(Object key, Object value)
      仅当指定的密钥当前映射到指定的值时删除该条目。
      protected void removeService​(Provider.Service s)
      删除以前使用 putService()添加的服务。
      Object replace​(Object key, Object value)
      只有当目标映射到某个值时，才能替换指定键的条目。
      boolean replace​(Object key, Object oldValue, Object newValue)
      仅当当前映射到指定的值时，才能替换指定键的条目。
      void replaceAll​(BiFunction<? super Object,? super Object,? extends Object> function)
      用条目集迭代器返回的顺序，直到所有的条目都被处理或函数抛出一个异常，替换每个条目的值，结果是对该条目调用给定的函数。
      String toString​()
      返回一个带有该提供者的名称和版本字符串的字符串。
      Collection<Object> values​()
      返回此提供程序中包含的属性值的不可修改的集合视图。

      • Methods inherited from interface java.util.Map

        entry, of, of, of, of, of, of, of, of, of, of, of, ofEntries

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.util.Properties

        clone, contains, containsKey, containsValue, equals, getProperty, hashCode, isEmpty, list, list, load, loadFromXML, propertyNames, rehash, save, setProperty, size, store, store, storeToXML, storeToXML, stringPropertyNames

    • 构造方法详细信息

      • Provider

        @Deprecated(since="9")
protected Provider​(String name,
                   double version,
                   String info)
        已过时。 改用Provider(String, String, String) 。
        构造具有指定名称，版本号和信息的提供程序。 调用此构造方法等效于调用Provider(String, String, String)与name名称， Double.toString(version) ，并info 。
        参数
        name - 提供商名称。
        version - 提供者版本号。
        info - 提供商及其服务的描述。

      • Provider

        protected Provider​(String name,
                   String versionStr,
                   String info)
        构造具有指定名称，版本字符串和信息的提供程序。

        版本字符串包含版本号，可选地后跟其他信息由“+”，“ - ”之一分隔。 版本号的格式为：

             ^[0-9]+(\.[0-9]+)*

        为了以双倍的形式返回版本号，当有两个以上的组件（如上所述由'。'分隔开）时，只保留前两个组件。 结果字符串然后传递给Double.valueOf(String)生成版本号，即getVersion() 。

        如果转换失败，将使用值0。

        参数
        name - 提供商名称。
        versionStr - 提供者版本字符串。
        info - 提供商及其服务的描述。
        从以下版本开始：
        9

    • 方法详细信息

      • configure

        public Provider configure​(String configArg)
        将提供的配置参数应用于此提供程序实例并返回配置的提供程序。 请注意，如果此提供程序无法在现场配置，则将创建并返回新的提供程序。 因此，呼叫者应始终使用返回的提供者。
        实现要求：
        默认实现抛出UnsupportedOperationException 。 仅当支持配置参数时，子类才应该覆盖此方法。
        参数
        configArg - 配置此提供程序的配置信息。
        结果
        提供者配置提供的配置参数。
        异常
        UnsupportedOperationException - 如果不支持配置参数。
        NullPointerException - 如果提供的配置参数为空。
        InvalidParameterException - 如果提供的配置参数无效。
        从以下版本开始：
        9

      • isConfigured

        public boolean isConfigured​()
        检查此提供程序实例是否已配置。
        实现要求：
        默认实现返回true。 如果提供者实例在构造后需要显式的configure调用，则子类应该覆盖此方法。
        结果
        如果不需要进一步配置，则为true，否则为false。
        从以下版本开始：
        9

      • getName

        public String getName​()
        返回此提供程序的名称。
        结果
        该提供商的名称。

      • getVersion

        @Deprecated(since="9")
public double getVersion​()
        已过时。 改用getVersionStr() 。
        返回此提供商的版本号。
        结果
        该提供商的版本号。

      • getVersionStr

        public String getVersionStr​()
        返回此提供程序的版本字符串。
        结果
        该提供商的版本字符串。
        从以下版本开始：
        9

      • getInfo

        public String getInfo​()
        返回提供商及其服务的可读描述。 这可能会返回一个带有相关链接的HTML页面。
        结果
        提供者及其服务的描述。

      • toString

        public String toString​()
        返回一个带有该提供者的名称和版本字符串的字符串。
        重写：
        toString在 Properties
        结果
        该字符串具有此提供程序的名称和版本字符串。

      • clear

        public void clear​()
        清除此提供程序，使其不再包含用于查找由提供程序实施的设施的属性。

        如果启用安全管理器，则其checkSecurityAccess方法将使用字符串"clearProviderProperties."+name （其中， name是提供程序名称）来调用，以查看是否可以清除此提供程序。

        Specified by:
        clear在接口 Map<Object,Object>
        重写：
        clear在 Properties
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝访问以清除此提供程序
        从以下版本开始：
        1.2

      • load

        public void load​(InputStream inStream)
          throws IOException
        从输入流读取属性列表（键和元素对）。
        重写：
        load在 Properties
        参数
        inStream - 输入流。
        异常
        IOException - 从输入流读取时发生错误。
        另请参见：
        Properties.load(java.io.Reader)

      • putAll

        public void putAll​(Map<?,?> t)
        将指定地图中的所有映射复制到此提供程序。 这些映射将替换此提供者对当前指定的Map中的任何键的任何属性。
        Specified by:
        putAll在接口 Map<Object,Object>
        重写：
        putAll在 Properties
        参数
        t - 要存储在此地图中的映射
        从以下版本开始：
        1.2

      • entrySet

        public Set<Map.Entry<Object,Object>> entrySet​()
        返回此提供程序中包含的属性条目的不可修改的Set视图。
        Specified by:
        entrySet在接口 Map<Object,Object>
        重写：
        entrySet在 Properties
        结果
        该地图中包含的映射的集合视图
        从以下版本开始：
        1.2
        另请参见：
        Map.Entry

      • keySet

        public Set<Object> keySet​()
        返回此提供程序中包含的属性键的不可修改的Set视图。
        Specified by:
        keySet在接口 Map<Object,Object>
        重写：
        keySet在 Properties
        结果
        该地图中包含的键的集合视图
        从以下版本开始：
        1.2

      • values

        public Collection<Object> values​()
        返回此提供程序中包含的属性值的不可修改的集合视图。
        Specified by:
        values在接口 Map<Object,Object>
        重写：
        values中的 Properties
        结果
        该地图中包含的值的集合视图
        从以下版本开始：
        1.2

      • put

        public Object put​(Object key,
                  Object value)
        将key属性设置为具有指定的value 。

        如果启用了安全管理器，则其checkSecurityAccess方法将使用字符串"putProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以设置此提供程序的属性值。

        Specified by:
        put在接口 Map<Object,Object>
        重写：
        put在 Properties
        参数
        key - 哈希表键
        value - 值
        结果
        该哈希表中指定键的上一个值，如果没有， null
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝对设置属性值的访问。
        从以下版本开始：
        1.2
        另请参见：
        Object.equals(Object) ， Hashtable.get(Object)

      • putIfAbsent

        public Object putIfAbsent​(Object key,
                          Object value)
        如果指定的键尚未与某个值相关联（或映射到null ）将其与给定值相关联并返回null ，否则返回当前值。

        如果安全管理器已启用，则其checkSecurityAccess方法将使用字符串"putProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以设置此提供程序的属性值。

        Specified by:
        putIfAbsent在接口 Map<Object,Object>
        重写：
        putIfAbsent在 Properties
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示该映射以前关联的是null的关键字，如果实现支持空值）。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝对设置属性值的访问。
        从以下版本开始：
        1.8

      • remove

        public Object remove​(Object key)
        删除key属性（及其对应的value ）。

        如果启用了安全管理器，则其checkSecurityAccess方法将使用字符串"removeProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以删除此提供程序的属性。

        Specified by:
        remove在接口 Map<Object,Object>
        重写：
        remove在 Properties
        参数
        key - 需要删除的关键
        结果
        密钥映射到此散列表中的值，如果密钥没有映射， null
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝访问以删除此提供程序的属性。
        从以下版本开始：
        1.2

      • remove

        public boolean remove​(Object key,
                      Object value)
        仅当指定的密钥当前映射到指定的值时删除该条目。

        如果启用了安全管理器，则其checkSecurityAccess方法将使用字符串"removeProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以删除此提供程序的属性。

        Specified by:
        remove在接口 Map<Object,Object>
        重写：
        remove在 Properties
        参数
        key - 与指定值相关联的键
        value - 预期与指定键相关联的值
        结果
        true如果该值被删除
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝访问以删除此提供程序的属性。
        从以下版本开始：
        1.8

      • replace

        public boolean replace​(Object key,
                       Object oldValue,
                       Object newValue)
        仅当当前映射到指定的值时，才能替换指定键的条目。

        如果安全管理器已启用，则其checkSecurityAccess方法将使用字符串"putProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以设置此提供程序的属性值。

        Specified by:
        replace在接口 Map<Object,Object>
        重写：
        replace在 Properties
        参数
        key - 与指定值相关联的键
        oldValue - 预期与指定键相关联的值
        newValue - 要与指定键相关联的值
        结果
        true如果该值被替换
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝对设置属性值的访问。
        从以下版本开始：
        1.8

      • replace

        public Object replace​(Object key,
                      Object value)
        只有当目标映射到某个值时，才能替换指定键的条目。

        如果启用安全管理器，则其checkSecurityAccess方法将使用字符串"putProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以设置此提供程序的属性值。

        Specified by:
        replace在接口 Map<Object,Object>
        重写：
        replace在 Properties
        参数
        key - 与指定值相关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以表示该地图以前关联的是null的关键字，如果实现支持空值）。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝对设置属性值的访问。
        从以下版本开始：
        1.8

      • replaceAll

        public void replaceAll​(BiFunction<? super Object,? super Object,? extends Object> function)
        用条目集迭代器返回的顺序，直到所有的条目都被处理或函数抛出一个异常，替换每个条目的值，结果是对该条目调用给定的函数。

        如果启用安全管理器，则其checkSecurityAccess方法将使用字符串"putProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以设置此提供程序的属性值。

        Specified by:
        replaceAll在接口 Map<Object,Object>
        重写：
        replaceAll在 Properties
        参数
        function - 应用于每个条目的功能
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝对设置属性值的访问。
        从以下版本开始：
        1.8

      • compute

        public Object compute​(Object key,
                      BiFunction<? super Object,? super Object,? extends Object> remappingFunction)
        尝试计算指定键的映射及其当前映射值（如果没有当前映射，则null ）。

        如果启用安全管理器，则其checkSecurityAccess方法将使用字符串"putProviderProperty."+name和"removeProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以设置此提供程序的属性值并删除此提供程序的属性。

        Specified by:
        compute在接口 Map<Object,Object>
        重写：
        compute在 Properties
        参数
        key - 指定值与之关联的键
        remappingFunction - 计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝对设置属性值的访问或删除属性。
        从以下版本开始：
        1.8

      • computeIfAbsent

        public Object computeIfAbsent​(Object key,
                              Function<? super Object,? extends Object> mappingFunction)
        如果指定的键尚未与值相关联（或映射到null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是null 。

        如果安全管理器已启用，则其checkSecurityAccess方法将使用字符串"putProviderProperty."+name和"removeProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以设置此提供程序的属性值并删除此提供程序的属性。

        Specified by:
        computeIfAbsent在接口 Map<Object,Object>
        重写：
        computeIfAbsent在 Properties
        参数
        key - 要与其关联的指定值的键
        mappingFunction - 计算值的映射函数
        结果
        与指定键相关联的当前（现有或计算）值，如果计算值为空，则为null
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝对设置属性值的访问并删除属性。
        从以下版本开始：
        1.8

      • computeIfPresent

        public Object computeIfPresent​(Object key,
                               BiFunction<? super Object,? super Object,? extends Object> remappingFunction)
        如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

        如果启用安全管理器，则其checkSecurityAccess方法将使用字符串"putProviderProperty."+name和"removeProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以设置此提供程序的属性值并删除此提供程序的属性。

        Specified by:
        computeIfPresent在接口 Map<Object,Object>
        重写：
        computeIfPresent在 Properties
        参数
        key - 指定值与之关联的键
        remappingFunction - 计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝对设置属性值的访问或删除属性。
        从以下版本开始：
        1.8

      • merge

        public Object merge​(Object key,
                    Object value,
                    BiFunction<? super Object,? super Object,? extends Object> remappingFunction)
        如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。 否则，将该值替换为给定重映射函数的结果，如果结果为空，则将其移除。 当组合键的多个映射值时，该方法可能是有用的。

        如果启用了安全管理器，则其checkSecurityAccess方法将使用字符串"putProviderProperty."+name和"removeProviderProperty."+name （其中name是提供程序名称）进行name ，以查看是否可以设置此提供程序的属性值并删除此提供程序的属性。

        Specified by:
        merge在接口 Map<Object,Object>
        重写：
        merge在 Properties
        参数
        key - 结合值与之关联的键
        value - 要与与密钥相关联的现有值合并的非空值，或者如果没有现有值或空值与密钥相关联，则与密钥相关联
        remappingFunction - 如果存在重新计算值的重映射功能
        结果
        与指定键相关联的新值，如果没有值与该键相关联，则返回null
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝访问设置属性值或删除属性。
        从以下版本开始：
        1.8

      • get

        public Object get​(Object key)
        描述从类别复制： Hashtable
        返回指定键映射到的值，如果此映射不包含键的映射，则返回null 。

        更正式地，如果这个地图包含一个k键到一个值v的映射，这样(key.equals(k)) ，那么这个方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        Specified by:
        get在接口 Map<Object,Object>
        重写：
        get在 Properties
        参数
        key - 要返回其关联值的键
        结果
        映射指定键的值，如果此映射不包含该键的映射， null
        另请参见：
        Hashtable.put(Object, Object)

      • getOrDefault

        public Object getOrDefault​(Object key,
                           Object defaultValue)
        说明从接口Map复制
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。
        Specified by:
        getOrDefault在接口 Map<Object,Object>
        重写：
        getOrDefault中的 Properties
        参数
        key - 要返回其关联值的键
        defaultValue - 键的默认映射
        结果
        映射指定键的值，如果此映射不包含该键的映射， defaultValue
        从以下版本开始：
        1.8

      • forEach

        public void forEach​(BiConsumer<? super Object,? super Object> action)
        说明从界面Map复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach在接口 Map<Object,Object>
        重写：
        forEach在 Properties
        参数
        action - 为每个条目执行的操作
        从以下版本开始：
        1.8

      • keys

        public Enumeration<Object> keys​()
        描述从类别复制： Hashtable
        返回此散列表中键的枚举。 对返回的对象使用枚举方法按顺序获取键。 如果哈希表在结构上被修改，同时枚举了键，则枚举的结果是未定义的。
        重写：
        keys在 Properties
        结果
        这个哈希表中的键的枚举。
        另请参见：
        Enumeration ， Hashtable.elements() ， Hashtable.keySet() ， Map

      • elements

        public Enumeration<Object> elements​()
        描述从类别复制： Hashtable
        返回此散列表中值的枚举。 对返回的对象使用枚举方法来顺序获取元素。 如果哈希表在结构上被修改，同时枚举了值，则枚举的结果是未定义的。
        重写：
        elements在 Properties
        结果
        列出这个散列表中的值。
        另请参见：
        Enumeration ， Hashtable.keys() ， Hashtable.values() ， Map

      • getProperty

        public String getProperty​(String key)
        描述从类复制： Properties
        使用此属性列表中指定的键搜索属性。 如果在此属性列表中找不到该键，则会默认属性列表及其默认值递归。 如果找不到属性，该方法返回null 。
        重写：
        getProperty在 Properties
        参数
        key - 属性键。
        结果
        该属性列表中具有指定键值的值。
        另请参见：
        Properties.setProperty(java.lang.String, java.lang.String) ， Properties.defaults

      • getService

        public Provider.Service getService​(String type,
                                   String algorithm)
        获取描述此提供程序实现该算法或别名的指定类型的服务。 如果没有这样的实现，这个方法返回null。 如果有两个匹配的服务，一个添加到这个提供商使用putService()和一个通过put()添加，通过putService()添加的服务被返回。
        参数
        type - 请求的类型service （例如， MessageDigest ）
        algorithm - 请求的服务的不区分大小写的算法名称（或替代别名）（例如， SHA-1 ）
        结果
        描述此提供商的匹配服务的服务，如果不存在此类服务，则为null
        异常
        NullPointerException - 如果类型或算法为空
        从以下版本开始：
        1.5

      • getServices

        public Set<Provider.Service> getServices​()
        获取不可修改的此提供程序支持的所有服务的集合。
        结果
        该提供商支持的所有服务的一个不可修改的集合
        从以下版本开始：
        1.5

      • putService

        protected void putService​(Provider.Service s)
        添加服务。 如果存在具有相同算法名称的相同类型的服务，并使用putService()添加，则将被新服务替换。 此方法还会以Java Cryptography Architecture (JCA) Reference Guide中描述的格式将关于此服务的信息放在提供商的Hashtable值中。

        另外，如果有一个安全管理器，它的checkSecurityAccess方法被调用与字符串"putProviderProperty."+name ，其中name是提供者名称，看看是否可以设置此提供程序的属性值。 如果使用默认实现checkSecurityAccess （即，该方法不被覆盖），则这将导致对安全管理器的checkPermission方法的checkPermission ，具有SecurityPermission("putProviderProperty."+name)权限。

        参数
        s - 要添加的服务
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝对设置属性值的访问。
        NullPointerException - 如果s为空
        从以下版本开始：
        1.5

      • removeService

        protected void removeService​(Provider.Service s)
        删除以前使用putService()添加的服务。 指定的服务将从此提供程序中删除。 它将不再由getService()返回，其信息将从此提供商的Hashtable中删除。

        另外，如果有一个安全管理器，它的checkSecurityAccess方法被调用与字符串"removeProviderProperty."+name ，其中name是提供者名称，看看是否可以删除此提供程序的属性。 如果使用默认实现checkSecurityAccess （即，该方法不被覆盖），则这将导致对安全管理器的checkPermission方法的checkPermission ，具有SecurityPermission("removeProviderProperty."+name)权限。

        参数
        s - 要删除的服务
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝访问以删除此提供程序的属性。
        NullPointerException - 如果s为空
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Provider.Service (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Provider.Service

  • java.lang.Object
    • java.security.Provider.Service
  • Enclosing class:
    Provider

    public static class Provider.Service
extends Object
    安全服务的描述。 它封装了一个服务的属性，并且包含一个工厂方法来获取此服务的新实现实例。

    每个服务都有一个提供服务的提供者，一个类型，算法名称和实现该服务的类的名称。 可选地，它还包括此服务（别名）和属性的替代算法名称列表，它们是（名称，值）字符串对的映射。

    该类定义了Java安全框架在搜索合适的服务并实例化时使用的方法supportsParameter()和newInstance() 。 这些方法的有效参数取决于服务的类型。 有关Java SE中定义的服务类型，请参阅Java Cryptography Architecture (JCA) Reference Guide有效值。 请注意，Java SE之外的组件可以定义其他类型的服务及其行为。

    这个类的实例是不可变的。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      Service​(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
      构建新服务

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getAlgorithm​()
      返回此服务的算法的名称。
      String getAttribute​(String name)
      返回指定属性的值，如果未为此服务设置此属性，则返回null。
      String getClassName​()
      返回实现此服务的类的名称。
      Provider getProvider​()
      返回此服务的提供者。
      String getType​()
      获取此服务的类型。
      Object newInstance​(Object constructorParameter)
      返回此服务描述的实现的新实例。
      boolean supportsParameter​(Object parameter)
      测试此服务是否可以使用指定的参数。
      String toString​()
      返回此服务的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Service

        public Service​(Provider provider,
               String type,
               String algorithm,
               String className,
               List<String> aliases,
               Map<String,String> attributes)
        构建新服务
        参数
        provider - 提供此服务的提供商
        type - 此服务的类型
        algorithm - 算法名称
        className - 实现此服务的类的名称
        aliases - 如果算法没有别名，则别名列表或null
        attributes - 属性的映射，如果此实现没有属性，则为null
        异常
        NullPointerException - 如果提供程序，类型，算法或className为空

    • 方法详细信息

      • getType

        public final String getType​()
        获取此服务的类型。 例如， MessageDigest 。
        结果
        这种服务的类型

      • getAlgorithm

        public final String getAlgorithm​()
        返回此服务的算法的名称。 例如， SHA-1 。
        结果
        该服务的算法

      • getProvider

        public final Provider getProvider​()
        返回此服务的提供者。
        结果
        该服务的提供者

      • getClassName

        public final String getClassName​()
        返回实现此服务的类的名称。
        结果
        实施此服务的类的名称

      • getAttribute

        public final String getAttribute​(String name)
        返回指定属性的值，如果未为此服务设置此属性，则返回null。
        参数
        name - 所请求属性的名称
        结果
        指定属性的值，如果属性不存在，则为null
        异常
        NullPointerException - 如果name为null

      • newInstance

        public Object newInstance​(Object constructorParameter)
                   throws NoSuchAlgorithmException
        返回此服务描述的实现的新实例。 安全提供程序框架使用此方法构建实现。 应用程序通常不需要调用它。

        默认实现使用反射来调用此类服务的标准构造函数。 安全提供者可以重写此方法以不同的方式实现实例化。 有关对各种类型服务有效的constructorParameter的详细信息和值，请参见Java Cryptography Architecture (JCA) Reference Guide 。

        参数
        constructorParameter - 传递给构造函数的值，如果此类型的服务不使用constructorParameter，则为null。
        结果
        这项服务的新实施
        异常
        InvalidParameterException - 如果此类型的服务的constructorParameter的值无效。
        NoSuchAlgorithmException - 如果由于任何其他原因实例化失败。

      • supportsParameter

        public boolean supportsParameter​(Object parameter)
        测试此服务是否可以使用指定的参数。 如果此服务无法使用该参数，则返回false。 如果此服务可以使用参数，如果快速测试不可行或状态未知，则返回true。

        安全提供程序框架使用这种方法与某些类型的服务来快速排除不匹配的实现以供考虑。 应用程序通常不需要调用它。

        有关各种类型服务的详细信息和参数值参见本类的顶部和Java Cryptography Architecture (JCA) Reference Guide 。 安全提供商可以覆盖它来实现自己的测试。

        参数
        parameter - 要测试的参数
        结果
        如果此服务不能使用指定的参数，则为false; 如果可以使用参数，则为true
        异常
        InvalidParameterException - 如果参数的值对于此类型的服务无效，或者该方法不能与此类型的服务一起使用

      • toString

        public String toString​()
        返回此服务的字符串表示形式。
        重写：
        toString在 Object
        结果
        此服务的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProviderException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class ProviderException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.security.ProviderException
  • All Implemented Interfaces:
    Serializable

    public class ProviderException
extends RuntimeException
    提供者异常的运行时异常（例如错误配置错误或不可恢复的内部错误），它们可能由提供程序子类化以抛出专门的提供者特定的运行时错误。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProviderException​()
      构造一个没有详细消息的ProviderException。
      ProviderException​(String s)
      构造具有指定详细消息的ProviderException。
      ProviderException​(String message, Throwable cause)
      创建一个具有指定的详细信息和原因的 ProviderException 。
      ProviderException​(Throwable cause)
      创建 ProviderException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ProviderException

        public ProviderException​()
        构造一个没有详细消息的ProviderException。 详细消息是描述此特定异常的字符串。

      • ProviderException

        public ProviderException​(String s)
        构造具有指定详细消息的ProviderException。 详细消息是描述此特定异常的字符串。
        参数
        s - 详细信息。

      • ProviderException

        public ProviderException​(String message,
                         Throwable cause)
        创建一个具有指定的详细信息和原因的 ProviderException 。
        参数
        message - 详细信息（由 Throwable.getMessage()方法保存供以后检索）。
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • ProviderException

        public ProviderException​(Throwable cause)
        创建 ProviderException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface PublicKey

  • All Superinterfaces:
    Key ， Serializable
    All Known Subinterfaces:
    DHPublicKey ， DSAPublicKey ， ECPublicKey ， RSAPublicKey

    public interface PublicKey
extends Key

    公钥 此接口不包含方法或常量。 它仅用于对所有公钥接口进行分组（并提供类型安全性）。 注意：专用公钥接口扩展了这个接口。 例如，参见java.security.interfaces的DSAPublicKey界面。

    从以下版本开始：
    1.1
    另请参见：
    Key ， PrivateKey ， Certificate ， Signature.initVerify(java.security.PublicKey) ， DSAPublicKey ， RSAPublicKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      类指纹被设置为指示与以前版本的类的序列化兼容性。

    • 方法摘要

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        类指纹被设置为指示与以前版本的类的序列化兼容性。
        另请参见：
        Constant Field Values
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


SecureClassLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class SecureClassLoader

  • java.lang.Object
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
  • 已知直接子类：
    URLClassLoader

    public class SecureClassLoader
extends ClassLoader
    此类扩展了ClassLoader，其额外支持用于定义具有相关代码源和权限的类，默认情况下系统策略将检索该类。
    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SecureClassLoader​()
      使用默认的父类加载器创建一个新的SecureClassLoader进行委派。
      protected SecureClassLoader​(ClassLoader parent)
      使用指定的父类加载器创建新的SecureClassLoader进行委派。
      protected SecureClassLoader​(String name, ClassLoader parent)
      创建指定名称的新的 SecureClassLoader并使用指定的父类加载器进行委派。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Class<?> defineClass​(String name, byte[] b, int off, int len, CodeSource cs)
      将字节数组转换为类Class的实例，并具有可选的CodeSource。
      protected Class<?> defineClass​(String name, ByteBuffer b, CodeSource cs)
      一个转换ByteBuffer成类的实例Class ，使用可选的CodeSource。
      protected PermissionCollection getPermissions​(CodeSource codesource)
      返回给定CodeSource对象的权限。

      • Methods inherited from class java.lang.ClassLoader

        clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findClass, findClass, findLibrary, findLoadedClass, findResource, findResource, findResources, findSystemClass, getClassLoadingLock, getDefinedPackage, getDefinedPackages, getName, getPackage, getPackages, getParent, getPlatformClassLoader, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, getUnnamedModule, isRegisteredAsParallelCapable, loadClass, loadClass, registerAsParallelCapable, resolveClass, resources, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SecureClassLoader

        protected SecureClassLoader​(ClassLoader parent)
        使用指定的父类加载器创建新的SecureClassLoader进行委派。

        如果有安全管理员，这种方法首先调用安全管理员的checkCreateClassLoader方法，以确保允许创建一个类加载器。

        参数
        parent - 父类加载器
        异常
        SecurityException - 如果存在安全管理员，并且其 checkCreateClassLoader方法不允许创建类加载器。
        另请参见：
        SecurityManager.checkCreateClassLoader()

      • SecureClassLoader

        protected SecureClassLoader​()
        使用默认的父类加载器创建一个新的SecureClassLoader进行委派。

        如果有一个安全管理器，这个方法首先调用安全管理器的checkCreateClassLoader方法来确保允许创建一个类加载器。

        异常
        SecurityException - 如果安全管理器存在，并且其 checkCreateClassLoader方法不允许创建类加载器。
        另请参见：
        SecurityManager.checkCreateClassLoader()

      • SecureClassLoader

        protected SecureClassLoader​(String name,
                            ClassLoader parent)
        创建指定名称的新的 SecureClassLoader并使用指定的父类加载器进行委派。
        参数
        name - 类加载器名称; 或者如果没有命名， null
        parent - 父类加载器
        异常
        IllegalArgumentException - 如果给定的名称为空。
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkCreateClassLoader()方法不允许创建类加载器。
        从以下版本开始：
        9

    • 方法详细信息

      • defineClass

        protected final Class<?> defineClass​(String name,
                                     byte[] b,
                                     int off,
                                     int len,
                                     CodeSource cs)
        将字节数组转换为类Class的实例，并具有可选的CodeSource。 在课堂可以使用之前，必须解决。

        如果提供非空CodeSource，则构造ProtectionDomain并与正在定义的类相关联。

        参数
        name - 类的预期名称，或null如果不知道，使用'。' 而不是'/'作为分隔符，没有尾随的“.class”后缀。
        b - 构成类数据的字节。 位置off至off+len-1的字节应具有由The Java™ Virtual Machine Specification定义的有效类文件的格式。
        off - 类数据中的起始偏移量为 b
        len - 类数据的长度
        cs - 相关的CodeSource，如果没有， null
        结果
        从数据创建的 Class对象，以及可选的CodeSource。
        异常
        ClassFormatError - 如果数据不包含有效的类
        IndexOutOfBoundsException - 如果 off或 len为负数，或者如果 off+len大于 b.length 。
        SecurityException - 如果尝试将此类添加到包含由不同于该类的不同证书集签名的类的包中，或者类名以“java”开头。

      • defineClass

        protected final Class<?> defineClass​(String name,
                                     ByteBuffer b,
                                     CodeSource cs)
        一个转换ByteBuffer成类的实例Class ，使用可选的CodeSource。 在课堂可以使用之前，必须解决。

        如果提供非空CodeSource，则构造ProtectionDomain并与正在定义的类相关联。

        参数
        name - 类的预期名称，如果不知道， null ，使用'。' 而不是'/'作为分隔符，没有尾随的“.class”后缀。
        b - 构成类数据的字节。 位置b.position()至b.position() + b.limit() -1的字节应具有由The Java™ Virtual Machine Specification定义的有效类文件的格式。
        cs - 相关的CodeSource，如果没有， null
        结果
        从数据创建的 Class对象，以及可选的CodeSource。
        异常
        ClassFormatError - 如果数据不包含有效的类
        SecurityException - 如果尝试将此类添加到包含由不同于该类的不同证书集签名的类的包中，或者类名以“java”开头。
        从以下版本开始：
        1.5

      • getPermissions

        protected PermissionCollection getPermissions​(CodeSource codesource)
        返回给定CodeSource对象的权限。

        该方法由defineClass方法调用，该方法在为正在定义的类构造ProtectionDomain时，将CodeSource作为参数。

        参数
        codesource - 代码源。
        结果
        the permissions granted to the codesource.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SecureRandom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class SecureRandom

  • java.lang.Object
    • java.util.Random
      • java.security.SecureRandom
  • All Implemented Interfaces:
    Serializable

    public class SecureRandom
extends Random
    这个类提供了一个密码强的随机数生成器（RNG）。

    密码强的随机数最低限度符合FIPS 140-2, Security Requirements for Cryptographic Modules第4.9.1节中规定的统计随机数发生器测试。 此外， SecureRandom必须产生非确定性输出。 因此，传递给SecureRandom对象的任何种子材料必须是不可预测的，并且所有SecureRandom输出序列必须加密强度，如RFC 4086: Randomness Requirements for Security中所述 。

    许多SecureRandom实现是伪随机数生成器（PRNG，也称为确定性随机位生成器或DRBG）的形式，这意味着它们使用确定性算法从随机种子产生伪随机序列。 其他实现可以产生真正的随机数，而其他实现可以使用两种技术的组合。

    调用者通过无参数构造函数或getInstance方法之一获取SecureRandom实例。 例如：

     SecureRandom r1 = new SecureRandom();
 SecureRandom r2 = SecureRandom.getInstance("NativePRNG");
 SecureRandom r3 = SecureRandom.getInstance("DRBG",
         DrbgParameters.instantiation(128, RESEED_ONLY, null));

    上述第三个语句返回支持特定实例参数的特定算法的一个SecureRandom对象。 实现的有效实例参数必须与此最小请求匹配，但不一定相同。 例如，即使请求不需要某个功能，实际的实例化也可以提供该功能。 实现可能会延迟实例化一个SecureRandom直到它被实际使用，但有效的实例参数必须在创建之后立即确定，并且getParameters()应始终返回相同的结果。

    典型的呼叫者SecureRandom调用以下方法来检索随机字节：

     SecureRandom random = new SecureRandom();
 byte[] bytes = new byte[20];
 random.nextBytes(bytes);

    呼叫者还可以调用generateSeed(int)方法来生成给定数量的种子字节（例如，种子其他随机数生成器）：

     byte[] seed = random.generateSeed(20);

    新创建的PRNG SecureRandom对象未被种子（除非由SecureRandom(byte[])创建）。 第一个呼叫nextBytes将迫使它从一个实现特定的熵源进行种子化。 如果以前打过setSeed ，这种自播不会发生。

    A SecureRandom可以随时通过调用reseed或setSeed方法重新进入。 reseed方法从熵源读取熵输入以重新设定自身。 setSeed方法要求调用者提供种子。

    请注意： reseed可能不是所有支持SecureRandom实现。

    一些SecureRandom实现可以在其nextBytes(byte[], SecureRandomParameters)和reseed(SecureRandomParameters)方法中接受SecureRandomParameters参数，以进一步控制方法的行为。

    注意：根据实施， generateSeed ， reseed和nextBytes方法可阻止作为熵被收集，例如，如果源熵是/ dev /上的各种类Unix操作系统随机的。

    线程安全

    SecureRandom对象可以安全地被多个并发线程使用。
    实现要求：
    A SecureRandom服务提供商可以通过在注册提供程序时将service provider attribute “ThreadSafe”设置为“true”来宣传其是线程安全的。 否则，此类将同步访问SecureRandomSpi实现的以下方法：
    • SecureRandomSpi.engineSetSeed(byte[])
    • SecureRandomSpi.engineNextBytes(byte[])
    • SecureRandomSpi.engineNextBytes(byte[], SecureRandomParameters)
    • SecureRandomSpi.engineGenerateSeed(int)
    • SecureRandomSpi.engineReseed(SecureRandomParameters)
    从以下版本开始：
    1.1
    另请参见：
    SecureRandomSpi ， Random ， Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        SecureRandom​()
      构造一个实现默认随机数算法的安全随机数生成器（RNG）。
        SecureRandom​(byte[] seed)
      构造一个实现默认随机数算法的安全随机数生成器（RNG）。
      protected SecureRandom​(SecureRandomSpi secureRandomSpi, Provider provider)
      创建一个 SecureRandom对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] generateSeed​(int numBytes)
      返回给定数量的种子字节，使用该类用于种子本身的种子生成算法计算。
      String getAlgorithm​()
      返回由该 SecureRandom对象实现的算法的名称。
      static SecureRandom getInstance​(String algorithm)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom getInstance​(String algorithm, String provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom getInstance​(String algorithm, Provider provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom getInstance​(String algorithm, SecureRandomParameters params)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom getInstance​(String algorithm, SecureRandomParameters params, String provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom getInstance​(String algorithm, SecureRandomParameters params, Provider provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom getInstanceStrong​()
      返回通过使用securerandom.strongAlgorithms Security属性中指定的算法/提供程序选择的SecureRandom对象。
      SecureRandomParameters getParameters​()
      返回此SecureRandom实例的有效SecureRandomParameters 。
      Provider getProvider​()
      返回此 SecureRandom对象的提供者。
      static byte[] getSeed​(int numBytes)
      返回给定数量的种子字节，使用该类用于种子本身的种子生成算法计算。
      protected int next​(int numBits)
      生成一个包含用户指定数量的伪随机位的整数（右对齐，带前导零）。
      void nextBytes​(byte[] bytes)
      生成用户指定的随机字节数。
      void nextBytes​(byte[] bytes, SecureRandomParameters params)
      使用附加参数生成用户指定的随机字节数。
      void reseed​()
      使用从其熵源读取的熵输入来确定此 SecureRandom 。
      void reseed​(SecureRandomParameters params)
      用这个 SecureRandom的熵输入从其熵源读取附加参数。
      void setSeed​(byte[] seed)
      用给定的种子重新设定这个随机对象。
      void setSeed​(long seed)
      使用给定的 long seed包含的八个字节重新设置此随机对象。
      String toString​()
      返回此 SecureRandom的人类可读字符串表示 SecureRandom 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.util.Random

        doubles, doubles, doubles, doubles, ints, ints, ints, ints, longs, longs, longs, longs, nextBoolean, nextDouble, nextFloat, nextGaussian, nextInt, nextInt, nextLong

    • 构造方法详细信息

      • SecureRandom

        public SecureRandom​()
        构造一个实现默认随机数算法的安全随机数生成器（RNG）。

        此构造函数遍历注册的安全提供程序列表，从最优选的提供程序开始。 SecureRandomSpi从支持SecureRandom （RNG）算法的第一个提供程序封装SecureRandomSpi实现的新的SecureRandom对象。 如果没有提供者支持RNG算法，则返回实现特定的默认值。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        见SecureRandom的部分Java Security Standard Algorithm Names Specification有关标准RNG算法名称的信息。

      • SecureRandom

        public SecureRandom​(byte[] seed)
        构造一个实现默认随机数算法的安全随机数生成器（RNG）。 SecureRandom实例用指定的种子字节种子。

        此构造函数遍历注册的安全提供程序列表，从最优选的提供程序开始。 SecureRandomSpi从支持SecureRandom （RNG）算法的第一个提供程序封装SecureRandomSpi实现的新的SecureRandom对象。 如果没有提供者支持RNG算法，则返回实现特定的默认值。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        见SecureRandom的部分Java Security Standard Algorithm Names Specification有关标准RNG算法名称的信息。

        参数
        seed - 种子。

      • SecureRandom

        protected SecureRandom​(SecureRandomSpi secureRandomSpi,
                       Provider provider)
        创建一个 SecureRandom对象。
        参数
        secureRandomSpi - SecureRandom实现。
        provider - 提供商。

    • 方法详细信息

      • getInstance

        public static SecureRandom getInstance​(String algorithm)
                                throws NoSuchAlgorithmException
        返回实现指定的随机数生成器（RNG）算法的SecureRandom对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 SecureRandomSpi从支持指定算法的第一个提供者封装SecureRandomSpi实现的新的SecureRandom对象。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - RNG算法的名称。 见SecureRandom的部分Java Security Standard Algorithm Names Specification有关标准RNG算法名称的信息。
        结果
        新的 SecureRandom对象
        异常
        NoSuchAlgorithmException - 如果没有 Provider支持指定算法的 SecureRandomSpi实现
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        1.2
        另请参见：
        Provider

      • getInstance

        public static SecureRandom getInstance​(String algorithm,
                                       String provider)
                                throws NoSuchAlgorithmException,
                                       NoSuchProviderException
        返回实现指定的随机数生成器（RNG）算法的SecureRandom对象。

        返回从指定的提供程序封装SecureRandomSpi实现的新的SecureRandom对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        参数
        algorithm - RNG算法的名称。 见SecureRandom的部分Java Security Standard Algorithm Names Specification有关标准RNG算法名称的信息。
        provider - 提供商的名称。
        结果
        新的 SecureRandom对象
        异常
        IllegalArgumentException - 如果提供商名称为 null或为空
        NoSuchAlgorithmException - 如果指定算法的 SecureRandomSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        1.2
        另请参见：
        Provider

      • getInstance

        public static SecureRandom getInstance​(String algorithm,
                                       Provider provider)
                                throws NoSuchAlgorithmException
        返回实现指定的随机数生成器（RNG）算法的SecureRandom对象。

        新SecureRandom对象封装SecureRandomSpi从指定执行Provider返回对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - RNG算法的名称。 见SecureRandom的部分Java Security Standard Algorithm Names Specification有关标准RNG算法名称的信息。
        provider - 提供商。
        结果
        新的 SecureRandom对象
        异常
        IllegalArgumentException - 如果指定的提供者是 null
        NoSuchAlgorithmException - 如果指定的算法的 SecureRandomSpi实现不能从指定的 Provider对象获得
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        1.4
        另请参见：
        Provider

      • getInstance

        public static SecureRandom getInstance​(String algorithm,
                                       SecureRandomParameters params)
                                throws NoSuchAlgorithmException
        返回实现指定的随机数生成器（RNG）算法的SecureRandom对象，并支持指定的SecureRandomParameters请求。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回一个新的SecureRandom对象，该对象封装了来自第一个提供程序的SecureRandomSpi实现，该提供程序支持指定的算法和指定的SecureRandomParameters 。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - RNG算法的名称。 见SecureRandom的部分Java Security Standard Algorithm Names Specification有关标准RNG算法名称的信息。
        params -在 SecureRandomParameters新创建 SecureRandom对象必须支持。
        结果
        新的 SecureRandom对象
        异常
        IllegalArgumentException - 如果指定的参数是 null
        NoSuchAlgorithmException - 如果没有提供程序支持指定算法和参数的 SecureRandomSpi实现
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        9
        另请参见：
        Provider

      • getInstance

        public static SecureRandom getInstance​(String algorithm,
                                       SecureRandomParameters params,
                                       String provider)
                                throws NoSuchAlgorithmException,
                                       NoSuchProviderException
        返回实现指定的随机数生成器（RNG）算法的SecureRandom对象，并支持指定的SecureRandomParameters请求。

        返回从指定提供程序封装SecureRandomSpi实现的新的SecureRandom对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        algorithm - RNG算法的名称。 见SecureRandom的部分Java Security Standard Algorithm Names Specification有关标准RNG算法名称的信息。
        params - SecureRandomParameters新建 SecureRandom对象必须支持。
        provider - 提供商的名称。
        结果
        新的 SecureRandom对象
        异常
        IllegalArgumentException - 如果提供商名称为 null或为空，或params为 null
        NoSuchAlgorithmException - 如果指定的提供程序不支持针对指定算法和参数的 SecureRandomSpi实现
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        9
        另请参见：
        Provider

      • getInstance

        public static SecureRandom getInstance​(String algorithm,
                                       SecureRandomParameters params,
                                       Provider provider)
                                throws NoSuchAlgorithmException
        返回实现指定的随机数生成器（RNG）算法的SecureRandom对象，并支持指定的SecureRandomParameters请求。

        新SecureRandom对象封装SecureRandomSpi从指定执行Provider返回对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - RNG算法的名称。 见SecureRandom的部分Java Security Standard Algorithm Names Specification有关标准RNG算法名称的信息。
        params -在 SecureRandomParameters新创建 SecureRandom对象必须支持。
        provider - 提供商。
        结果
        新的 SecureRandom对象
        异常
        IllegalArgumentException - 如果指定的提供者或参数是 null
        NoSuchAlgorithmException - 如果指定的提供程序不支持针对指定算法和参数的 SecureRandomSpi实现
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        9
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此 SecureRandom对象的提供者。
        结果
        这个 SecureRandom对象的提供者。

      • getAlgorithm

        public String getAlgorithm​()
        返回由该 SecureRandom对象实现的算法的名称。
        结果
        如果算法名称无法确定，则算法的名称为 unknown 。
        从以下版本开始：
        1.5

      • toString

        public String toString​()
        返回此 SecureRandom的人类可读字符串表示 SecureRandom 。
        重写：
        toString在 Object
        结果
        字符串表示

      • getParameters

        public SecureRandomParameters getParameters​()
        返回此SecureRandom实例的有效SecureRandomParameters 。

        返回的值可能与传递给getInstance方法的SecureRandomParameters对象不同，但在此SecureRandom对象的生命周期内不能更改。

        一个调用者可以使用返回的值来找出这个SecureRandom支持哪些特性。

        结果
        有效的SecureRandomParameters参数，如果没有使用参数， null 。
        从以下版本开始：
        9
        另请参见：
        SecureRandomSpi

      • setSeed

        public void setSeed​(byte[] seed)
        用给定的种子重新设定这个随机对象。 种子补充，而不是替代现有的种子。 因此，重复的呼叫保证不会减少随机性。

        一个PRNG SecureRandom如果不会自动种子本身setSeed之前任何所谓nextBytes或者reseed电话。 调用者应该确保seed参数包含足够的熵来确保这个SecureRandom的安全性。

        参数
        seed - 种子。
        另请参见：
        getSeed(int)

      • setSeed

        public void setSeed​(long seed)
        使用给定的long seed包含的八个字节重新设置此随机对象。 给定的种子补充，而不是替代现有的种子。 因此，重复的呼叫保证不会减少随机性。

        此方法的定义是与java.util.Random兼容性。

        重写：
        setSeed在 Random
        参数
        seed - 种子。
        另请参见：
        getSeed(int)

      • nextBytes

        public void nextBytes​(byte[] bytes)
        生成用户指定的随机字节数。
        重写：
        nextBytes在 Random
        参数
        bytes - 要用随机字节填充的数组。

      • nextBytes

        public void nextBytes​(byte[] bytes,
                      SecureRandomParameters params)
        使用附加参数生成用户指定的随机字节数。
        参数
        bytes - 要用随机字节填充的数组
        params - 附加参数
        异常
        NullPointerException - 如果 bytes为空
        UnsupportedOperationException - 如果底层提供者实现没有覆盖此方法
        IllegalArgumentException - 如果 params是 null ，非法或不支持此 SecureRandom
        从以下版本开始：
        9

      • next

        protected final int next​(int numBits)
        生成一个包含用户指定数量的伪随机位的整数（右对齐，带前导零）。 此方法重写一个java.util.Random方法，以及用于提供随机比特的源到所有的从类继承的方法（例如， nextInt ， nextLong ，和nextFloat ）。
        重写：
        next在 Random
        参数
        numBits - 要生成的伪随机比特数，其中 0 <= numBits <= 32 。
        结果
        一个 int包含用户指定的伪随机位数（右对齐，带前导零）。

      • getSeed

        public static byte[] getSeed​(int numBytes)
        返回给定数量的种子字节，使用该类用于种子本身的种子生成算法计算。 该呼叫可以用于种子其他随机数发生器。

        此方法仅用于向后兼容。 鼓励呼叫者使用另一种getInstance方法来获取一个SecureRandom对象，然后调用generateSeed方法从该对象获取种子字节。

        参数
        numBytes - 要生成的种子字节数。
        结果
        种子字节。
        异常
        IllegalArgumentException - 如果 numBytes为负数
        另请参见：
        setSeed(byte[])

      • generateSeed

        public byte[] generateSeed​(int numBytes)
        返回给定数量的种子字节，使用该类用于种子本身的种子生成算法计算。 该呼叫可以用于种子其他随机数发生器。
        参数
        numBytes - 要生成的种子字节数。
        结果
        种子字节。
        异常
        IllegalArgumentException - 如果 numBytes为负数

      • getInstanceStrong

        public static SecureRandom getInstanceStrong​()
                                      throws NoSuchAlgorithmException
        返回通过使用securerandom.strongAlgorithms Security属性中指定的算法/提供程序选择的一个SecureRandom对象。

        某些情况需要强大的随机值，例如创建高价值/长寿命秘密（如RSA公钥/私钥）时。 为了帮助指导应用程序选择合适的强大的SecureRandom实现，Java发行版包括securerandom.strongAlgorithms Security属性中已知的强大的SecureRandom实现列表。

        Java平台的每个实现都需要至少支持一个强大的SecureRandom实现。

        结果
        一个强大的 SecureRandom实施，如 securerandom.strongAlgorithms Security Properties所示
        异常
        NoSuchAlgorithmException - 如果没有算法可用
        从以下版本开始：
        1.8
        另请参见：
        Security.getProperty(String)

      • reseed

        public void reseed​()
        使用从其熵源读取的熵输入来确定此 SecureRandom 。
        异常
        UnsupportedOperationException - 如果底层提供者实现没有覆盖此方法。
        从以下版本开始：
        9

      • reseed

        public void reseed​(SecureRandomParameters params)
        重新设计这个SecureRandom其中熵输入从其熵源读取附加参数。

        注意，熵是从熵源获得的。 虽然params一些数据可能包含熵，但其主要用途是提供多样性。

        参数
        params - 额外的参数
        异常
        UnsupportedOperationException - 如果底层提供者实现没有覆盖此方法。
        IllegalArgumentException - 如果 params是 null ，非法或不支持此 SecureRandom
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SecureRandomParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Interface SecureRandomParameters

  • 所有已知实现类：
    DrbgParameters.Instantiation ， DrbgParameters.NextBytes ， DrbgParameters.Reseed

    public interface SecureRandomParameters
    用于各种SecureRandom方法的参数的标记界面。

    大约SecureRandom实现可能需要额外的操作参数。 实现此接口的类的对象可以传递给支持它们的那些实现。

    从以下版本开始：
    9
    另请参见：
    DrbgParameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SecureRandomSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class SecureRandomSpi

  • java.lang.Object
    • java.security.SecureRandomSpi
  • All Implemented Interfaces:
    Serializable

    public abstract class SecureRandomSpi
extends Object
implements Serializable
    该类定义了SecureRandom类的 （ SPI ）。

    该类中的所有抽象方法必须由希望提供加密强伪随机数生成器的实现的每个服务提供者来实现。

    实现要求：
    如果SecureRandomSpi(SecureRandomParameters)构造函数在实现中被覆盖，那么当实例化一个SecureRandom时，它总是被调用。 准确地说，如果对象是用一个实例SecureRandom的getInstance方法没有 SecureRandomParameters参数，构造函数会被一个叫null论证和实施负责创建自己的SecureRandomParameters使用参数时engineGetParameters()被调用。 如果使用 SecureRandomParameters参数的SecureRandom的getInstance方法中的一个实例化对象，则将使用该参数调用构造函数。 engineGetParameters()方法不能返回null 。

    否则，如果SecureRandomSpi(SecureRandomParameters)构造未实现覆盖，在SecureRandomSpi()构造函数必须重写，如果某个对象是使用的一个实例它会被称为SecureRandom的getInstance方法没有 SecureRandomParameters的说法。 使用 SecureRandomParameters参数调用SecureRandom的getInstance方法SecureRandomParameters将永远不会返回此实现的实例。 engineGetParameters()方法必须返回null 。

    有关线程安全性的更多详细信息，请参阅SecureRandom 。 默认情况下， SecureRandomSpi实现被认为对多个并发线程使用是不安全的，并且SecureRandom将同步对每个适用引擎方法的访问（有关方法列表，请参阅SecureRandom ）。 但是，如果一个SecureRandomSpi实现是线程安全的，则service provider attribute “ThreadSafe”在其注册期间应设置为“true”，如下所示：

     put("SecureRandom.AlgName ThreadSafe", "true");
    要么
     putService(new Service(this, "SecureRandom", "AlgName", className,
          null, Map.of("ThreadSafe", "true")));
    SecureRandom将无需任何同步即可调用适用的引擎方法。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        SecureRandomSpi​()
      没有参数的构造函数。
      protected SecureRandomSpi​(SecureRandomParameters params)
      具有参数的构造方法

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract byte[] engineGenerateSeed​(int numBytes)
      返回给定的种子字节数。
      protected SecureRandomParameters engineGetParameters​()
      返回此SecureRandom实例的有效SecureRandomParameters 。
      protected abstract void engineNextBytes​(byte[] bytes)
      生成用户指定的随机字节数。
      protected void engineNextBytes​(byte[] bytes, SecureRandomParameters params)
      使用附加参数生成用户指定的随机字节数。
      protected void engineReseed​(SecureRandomParameters params)
      使用附加参数从熵源读取熵输入来重新获得该随机对象。
      protected abstract void engineSetSeed​(byte[] seed)
      用给定的种子重新设定这个随机对象。
      String toString​()
      返回此 SecureRandom的人类可读字符串表示 SecureRandom 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SecureRandomSpi

        public SecureRandomSpi​()
        没有参数的构造函数。

      • SecureRandomSpi

        protected SecureRandomSpi​(SecureRandomParameters params)
        具有参数的构造方法
        参数
        params - SecureRandomParameters对象。 这个参数可以是null 。
        异常
        IllegalArgumentException - 如果 params无法识别或不支持此 SecureRandom
        从以下版本开始：
        9

    • 方法详细信息

      • engineSetSeed

        protected abstract void engineSetSeed​(byte[] seed)
        用给定的种子重新设定这个随机对象。 种子补充，而不是替代现有的种子。 因此，重复的呼叫保证不会减少随机性。
        参数
        seed - 种子。

      • engineNextBytes

        protected abstract void engineNextBytes​(byte[] bytes)
        生成用户指定的随机字节数。

        一些随机数生成器只能生成有限量的每个调用的随机字节。 如果bytes的大小大于此限制，则实现应该在从该方法返回之前多次调用其生成过程以完全填充缓冲区。

        参数
        bytes - 要用随机字节填充的数组。

      • engineNextBytes

        protected void engineNextBytes​(byte[] bytes,
                               SecureRandomParameters params)
        使用附加参数生成用户指定的随机字节数。

        一些随机数生成器只能生成有限量的每个调用的随机字节。 如果bytes的大小大于此限制，则实现应该在从此方法返回之前多次调用其生成过程以完全填充缓冲区。

        实现要求：
        默认实现会抛出一个UnsupportedOperationException 。
        参数
        bytes - 要用随机字节填充的数组
        params - 附加参数
        异常
        UnsupportedOperationException - 如果实现没有覆盖此方法
        IllegalArgumentException - 如果 params是 null ，非法或不支持此 SecureRandom
        从以下版本开始：
        9

      • engineGenerateSeed

        protected abstract byte[] engineGenerateSeed​(int numBytes)
        返回给定的种子字节数。 该呼叫可以用于种子其他随机数发生器。
        参数
        numBytes - 要生成的种子字节数。
        结果
        种子字节。

      • engineReseed

        protected void engineReseed​(SecureRandomParameters params)
        使用附加参数从熵源读取熵输入来重新获得该随机对象。

        如果这个方法由SecureRandom.reseed()调用 ，则params将为null 。

        如果实现不支持重新进入，请勿覆盖此方法。

        实现要求：
        默认实现会抛出一个UnsupportedOperationException 。
        参数
        params - 额外的参数，可以是 null 。
        异常
        UnsupportedOperationException - 如果实现没有覆盖此方法
        IllegalArgumentException - 如果 params是非法的或不支持此 SecureRandom
        从以下版本开始：
        9

      • engineGetParameters

        protected SecureRandomParameters engineGetParameters​()
        返回此SecureRandom实例的有效SecureRandomParameters 。
        实现要求：
        默认实现返回 null 。
        结果
        有效的SecureRandomParameters参数，如果没有使用参数， null 。
        从以下版本开始：
        9

      • toString

        public String toString​()
        返回此 SecureRandom的人类可读字符串表示 SecureRandom 。
        重写：
        toString中的 Object
        结果
        字符串表示
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Security (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Security

  • java.lang.Object
    • java.security.Security

  • public final class Security
extends Object

    此类集中所有安全属性和常见的安全方法。 其主要用途之一是管理提供商。

    安全属性的默认值从实现特定的位置读取，该位置通常是Java安装目录中的属性文件conf/security/java.security 。

    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static int addProvider​(Provider provider)
      将供应商添加到下一个可用位置。
      static String getAlgorithmProperty​(String algName, String propName)
      已过时。
      此方法用于返回“SUN”加密服务提供程序的主文件中的专有属性的值，以确定如何解析特定于算法的参数。 AlgorithmParameters使用新的基于提供者的和算法无关的AlgorithmParameters和KeyFactory引擎类（在J2SE版本1.2平台中引入）。
      static Set<String> getAlgorithms​(String serviceName)
      返回一组字符串，其中包含指定Java加密服务的所有可用算法或类型的名称（例如Signature，MessageDigest，Cipher，Mac，KeyStore）。
      static String getProperty​(String key)
      获取安全属性值。
      static Provider getProvider​(String name)
      返回以指定名称安装的提供程序（如果有）。
      static Provider[] getProviders​()
      返回包含所有已安装提供程序的数组。
      static Provider[] getProviders​(String filter)
      返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。
      static Provider[] getProviders​(Map<String,String> filter)
      返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。
      static int insertProviderAt​(Provider provider, int position)
      在指定的位置添加一个新的提供者。
      static void removeProvider​(String name)
      删除具有指定名称的提供程序。
      static void setProperty​(String key, String datum)
      设置安全属性值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getAlgorithmProperty

        @Deprecated
public static String getAlgorithmProperty​(String algName,
                                          String propName)
        已过时。 此方法用于返回“SUN”加密服务提供程序的主文件中的专有属性的值，以确定如何解析特定于算法的参数。 AlgorithmParameters使用新的基于提供者和算法的AlgorithmParameters和KeyFactory引擎类（在J2SE版本1.2平台中引入）。
        获取算法的指定属性。 算法名称应为标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification 。 一种可能的用途是通过专门的算法解析器，它可以将类映射到他们所理解的算法（非常像键解析器）。
        参数
        algName - 算法名称。
        propName - 要获取的属性的名称。
        结果
        指定属性的值。

      • insertProviderAt

        public static int insertProviderAt​(Provider provider,
                                   int position)
        在指定的位置添加一个新的提供者。 位置是提供者搜索请求的算法的首选顺序。 位置是1，即1是最优选的，其次是2，依此类推。

        如果给定的提供商安装在请求的位置，那么以前位于该位置的提供商以及位置大于position所有提供者position向上移动一个位置（朝向已安装提供程序列表的末尾）。

        如果已经安装了提供程序，则无法添加。

        如果有安全管理器，则使用"insertProvider"权限目标名称调用SecurityManager.checkSecurityAccess(java.lang.String)方法，以查看是否可以添加新的提供程序。 如果此权限检查被拒绝，则checkSecurityAccess被再次调用，具有"insertProvider."+provider.getName()权限目标名称。 如果两个检查都被拒绝，则抛出一个SecurityException 。

        参数
        provider - 要添加的提供者。
        position - 呼叫者对此提供商的偏好位置。
        结果
        添加提供者的实际偏好位置，如果未安装提供程序，则为-1。
        异常
        NullPointerException - 如果提供程序为空
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝访问以添加新提供程序
        另请参见：
        getProvider(java.lang.String) ， removeProvider(java.lang.String) ， SecurityPermission

      • addProvider

        public static int addProvider​(Provider provider)
        将供应商添加到下一个可用位置。

        如果有安全管理器，则使用"insertProvider"权限目标名称调用SecurityManager.checkSecurityAccess(java.lang.String)方法，以查看是否可以添加新的提供程序。 如果此权限检查被拒绝， checkSecurityAccess使用"insertProvider."+provider.getName()权限目标名称再次调用"insertProvider."+provider.getName() 。 如果两个检查都被拒绝，则抛出一个SecurityException 。

        参数
        provider - 要添加的提供者。
        结果
        添加提供程序的首选位置，如果未安装提供程序，则为-1。
        异常
        NullPointerException - 如果提供者为null
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝访问以添加新提供程序
        另请参见：
        getProvider(java.lang.String) ， removeProvider(java.lang.String) ， SecurityPermission

      • removeProvider

        public static void removeProvider​(String name)
        删除具有指定名称的提供程序。

        当指定的提供程序被删除时，位于大于指定提供程序的位置的所有提供程序都向下移动一个位置（朝向已安装提供程序列表的头部）。

        如果提供程序未安装或名称为空，此方法将静默返回。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法被调用与字符串"removeProvider."+name看看是否可以删除提供程序。 如果使用默认实现checkSecurityAccess （即，该方法不被覆盖），那么这将导致使用SecurityPermission("removeProvider."+name)权限调用安全管理器的checkPermission方法。

        参数
        name - 要删除的提供商的名称。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkSecurityAccess(java.lang.String)方法拒绝访问以删除提供程序
        另请参见：
        getProvider(java.lang.String) ， addProvider(java.security.Provider)

      • getProviders

        public static Provider[] getProviders​()
        返回包含所有已安装提供程序的数组。 数组中提供者的顺序是它们的优先顺序。
        结果
        所有安装的提供程序的阵列。

      • getProvider

        public static Provider getProvider​(String name)
        返回以指定名称安装的提供程序（如果有）。 如果没有安装指定名称的提供者，或者如果name为null，则返回null。
        参数
        name - 要获取的提供商的名称。
        结果
        指定名称的提供者。
        另请参见：
        removeProvider(java.lang.String) ， addProvider(java.security.Provider)

      • getProviders

        public static Provider[] getProviders​(String filter)
        返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。 返回的提供商根据他们的preference order进行订购。

        密码服务始终与特定的算法或类型相关联。 例如，数字签名服务始终与特定算法（例如，DSA）相关联，并且CertificateFactory服务始终与特定证书类型相关联（例如，X.509）。

        选择标准必须用以下两种格式之一来指定：

        • <crypto_service> <algorithm_or_type>

          加密服务名称不能包含任何点。

          如果提供者实现指定的加密服务的指定算法或类型，则提供者满足指定的选择标准。

          例如，对于X.509证书提供CertificateFactory实现的任何提供者都将满足“CertificateFactory.X.509”。

        • <crypto_service>。<algorithm_or_type> <attribute_name>：<attribute_value>

          加密服务名称不能包含任何点。 <algorithm_or_type>和<attribute_name>之间必须有一个或多个空格。

          如果提供者实现指定的加密服务的指定算法或类型，并且其实现满足指定的属性名/值对表示的约束，则提供者满足该选择标准。

          例如，任何实施SHA1withDSA签名算法的提供者的密钥大小为1024（或更大）的“Signature.SHA1withDSA KeySize：1024”将被满足。

        有关标准加密服务名称，标准算法名称和标准属性名称的信息，请参阅Java Security Standard Algorithm Names Specification 。

        参数
        filter - 选择提供者的标准。 过滤器不区分大小写。
        结果
        所有安装的提供者满足选择标准，如果没有安装这样的提供者，则为null。
        异常
        InvalidParameterException - 如果过滤器不是所需的格式
        NullPointerException - 如果过滤器为空
        从以下版本开始：
        1.3
        另请参见：
        getProviders(java.util.Map)

      • getProviders

        public static Provider[] getProviders​(Map<String,String> filter)
        返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。 返回的提供商根据他们的preference order订购 。

        选择标准由地图表示。 每个地图条目表示选择标准。 如果满足所有选择标准，则选择提供者。 此类地图中任何条目的关键字必须为以下两种格式之一：

        • <crypto_service> <algorithm_or_type>

          加密服务名称不能包含任何点。

          与键相关联的值必须是空字符串。

          如果提供者实现指定的加密服务的指定算法或类型，则提供者满足该选择标准。

        • <crypto_service>。 <algorithm_or_type> <attribute_name>

          加密服务名称不能包含任何点。 <algorithm_or_type>和<attribute_name>之间必须有一个或多个空格。

          与键相关联的值必须是非空字符串。 如果提供者实现指定的加密服务的指定算法或类型，并且其实现满足指定的属性名/值对表示的约束，则提供者满足该选择标准。

        有关标准加密服务名称，标准算法名称和标准属性名称的信息，请参阅Java Security Standard Algorithm Names Specification 。

        参数
        filter - 选择提供者的标准。 过滤器不区分大小写。
        结果
        满足选择标准的所有已安装的提供程序，如果没有安装此类提供程序，则为null。
        异常
        InvalidParameterException - 如果过滤器不是所需的格式
        NullPointerException - 如果过滤器为空
        从以下版本开始：
        1.3
        另请参见：
        getProviders(java.lang.String)

      • getProperty

        public static String getProperty​(String key)
        获取安全属性值。

        首先，如果有一个安全管理器，它的checkPermission方法被调用一个java.security.SecurityPermission("getProperty."+key)权限来查看是否可以检索指定的安全属性值。

        参数
        key - 正在检索的财产的关键。
        结果
        对应密钥的安全属性的值。
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkPermission(java.security.Permission)方法拒绝访问以检索指定的安全属性值
        NullPointerException - 是key为null
        另请参见：
        setProperty(java.lang.String, java.lang.String) ， SecurityPermission

      • setProperty

        public static void setProperty​(String key,
                               String datum)
        设置安全属性值。

        首先，如果有一个安全管理器，它的checkPermission方法被调用一个java.security.SecurityPermission("setProperty."+key)权限来查看是否可以设置指定的安全属性值。

        参数
        key - 要设置的属性的名称。
        datum - 要设置的属性的值。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkPermission(java.security.Permission)方法拒绝访问以设置指定的安全属性值
        NullPointerException - 如果键或原点为空
        另请参见：
        getProperty(java.lang.String) ， SecurityPermission

      • getAlgorithms

        public static Set<String> getAlgorithms​(String serviceName)
        返回一组字符串，其中包含指定Java加密服务的所有可用算法或类型的名称（例如Signature，MessageDigest，Cipher，Mac，KeyStore）。 如果没有支持指定服务的提供程序，或者serviceName为空，则返回一个空的Set。 有关Java加密服务的完整列表，请参阅Java Cryptography Architecture (JCA) Reference Guide 。 注意：返回的集是不可变的。
        参数
        serviceName - Java加密服务的名称（例如，Signature，MessageDigest，Cipher，Mac，KeyStore）。 注意：此参数不区分大小写。
        结果
        一组字符串，其中包含指定Java加密服务的所有可用算法或类型的名称，如果没有提供程序支持指定的服务，则包含空集。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SecurityPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class SecurityPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.security.SecurityPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class SecurityPermission
extends BasicPermission
    此类用于安全权限。 A SecurityPermission包含一个名称（也称为“目标名称”），但没有操作列表; 你有指定的权限，或者你没有。

    目标名称是安全配置参数的名称（见下文）。 目前SecurityPermission对象用于保护访问AccessControlContext ， Policy ， Provider ， Security ， Signer ，并Identity对象。

    下表列出了标准的SecurityPermission目标名称，并为每个目标名称提供了许可允许的描述，并讨论授予代码授权的风险。

    target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission authProvider.{provider name} Allow the named provider to be an AuthProvider for login and logout operations. This allows the named provider to perform login and logout operations. The named provider must extend AuthProvider and care must be taken to grant to a trusted provider since login operations involve sensitive authentication information such as PINs and passwords. createAccessControlContext Creation of an AccessControlContext This allows someone to instantiate an AccessControlContext with a DomainCombiner. Extreme care must be taken when granting this permission. Malicious code could create a DomainCombiner that augments the set of permissions granted to code, and even grant the code AllPermission. getDomainCombiner Retrieval of an AccessControlContext's DomainCombiner This allows someone to retrieve an AccessControlContext's DomainCombiner. Since DomainCombiners may contain sensitive information, this could potentially lead to a privacy leak. getPolicy Retrieval of the system-wide security policy (specifically, of the currently-installed Policy object) This allows someone to query the policy via the getPermissions call, which discloses which permissions would be granted to a given CodeSource. While revealing the policy does not compromise the security of the system, it does provide malicious code with additional information which it may use to better aim an attack. It is wise not to divulge more information than necessary. setPolicy Setting of the system-wide security policy (specifically, the Policy object) Granting this permission is extremely dangerous, as malicious code may grant itself all the necessary permissions it needs to successfully mount an attack on the system. createPolicy.{policy type} Getting an instance of a Policy implementation from a provider Granting this permission enables code to obtain a Policy object. Malicious code may query the Policy object to determine what permissions have been granted to code other than itself. getProperty.{key} Retrieval of the security property with the specified key Depending on the particular key for which access has been granted, the code may have access to the list of security providers, as well as the location of the system-wide and user security policies. while revealing this information does not compromise the security of the system, it does provide malicious code with additional information which it may use to better aim an attack. setProperty.{key} Setting of the security property with the specified key This could include setting a security provider or defining the location of the system-wide security policy. Malicious code that has permission to set a new security provider may set a rogue provider that steals confidential information such as cryptographic private keys. In addition, malicious code with permission to set the location of the system-wide security policy may point it to a security policy that grants the attacker all the necessary permissions it requires to successfully mount an attack on the system. insertProvider Addition of a new provider This would allow somebody to introduce a possibly malicious provider (e.g., one that discloses the private keys passed to it) as the highest-priority provider. This would be possible because the Security object (which manages the installed providers) currently does not check the integrity or authenticity of a provider before attaching it. The "insertProvider" permission subsumes the "insertProvider.{provider name}" permission (see the section below for more information). removeProvider.{provider name} Removal of the specified provider This may change the behavior or disable execution of other parts of the program. If a provider subsequently requested by the program has been removed, execution may fail. Also, if the removed provider is not explicitly requested by the rest of the program, but it would normally be the provider chosen when a cryptography service is requested (due to its previous order in the list of providers), a different provider will be chosen instead, or no suitable provider will be found, thereby resulting in program failure. clearProviderProperties.{provider name} "Clearing" of a Provider so that it no longer contains the properties used to look up services implemented by the provider This disables the lookup of services implemented by the provider. This may thus change the behavior or disable execution of other parts of the program that would normally utilize the Provider, as described under the "removeProvider.{provider name}" permission. putProviderProperty.{provider name} Setting of properties for the specified Provider The provider properties each specify the name and location of a particular service implemented by the provider. By granting this permission, you let code replace the service specification with another one, thereby specifying a different implementation. removeProviderProperty.{provider name} Removal of properties from the specified Provider This disables the lookup of services implemented by the provider. They are no longer accessible due to removal of the properties specifying their names and locations. This may change the behavior or disable execution of other parts of the program that would normally utilize the Provider, as described under the "removeProvider.{provider name}" permission.

    以下权限已经被新版的权限取代或与已过时的类相关： Identity ， IdentityScope ， Signer 。 不鼓励使用它们。 有关详细信息，请参阅适用的课程。

    target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission insertProvider.{provider name} Addition of a new provider, with the specified name Use of this permission is discouraged from further use because it is possible to circumvent the name restrictions by overriding the Provider.getName() method. Also, there is an equivalent level of risk associated with granting code permission to insert a provider with a specific name, or any name it chooses. Users should use the "insertProvider" permission instead.

    This would allow somebody to introduce a possibly malicious provider (e.g., one that discloses the private keys passed to it) as the highest-priority provider. This would be possible because the Security object (which manages the installed providers) currently does not check the integrity or authenticity of a provider before attaching it.

    setSystemScope Setting of the system identity scope This would allow an attacker to configure the system identity scope with certificates that should not be trusted, thereby granting applet or application code signed with those certificates privileges that would have been denied by the system's original identity scope. setIdentityPublicKey Setting of the public key for an Identity If the identity is marked as "trusted", this allows an attacker to introduce a different public key (e.g., its own) that is not trusted by the system's identity scope, thereby granting applet or application code signed with that public key privileges that would have been denied otherwise. setIdentityInfo Setting of a general information string for an Identity This allows attackers to set the general description for an identity. This may trick applications into using a different identity than intended or may prevent applications from finding a particular identity. addIdentityCertificate Addition of a certificate for an Identity This allows attackers to set a certificate for an identity's public key. This is dangerous because it affects the trust relationship across the system. This public key suddenly becomes trusted to a wider audience than it otherwise would be. removeIdentityCertificate Removal of a certificate for an Identity This allows attackers to remove a certificate for an identity's public key. This is dangerous because it affects the trust relationship across the system. This public key suddenly becomes considered less trustworthy than it otherwise would be. printIdentity Viewing the name of a principal and optionally the scope in which it is used, and whether or not it is considered "trusted" in that scope The scope that is printed out may be a filename, in which case it may convey local system information. For example, here's a sample printout of an identity named "carol", who is marked not trusted in the user's identity database:
    carol[/home/luehe/identitydb.obj][not trusted] getSignerPrivateKey Retrieval of a Signer's private key It is very dangerous to allow access to a private key; private keys are supposed to be kept secret. Otherwise, code can use the private key to sign various files and claim the signature came from the Signer. setSignerKeyPair Setting of the key pair (public key and private key) for a Signer This would allow an attacker to replace somebody else's (the "target's") keypair with a possibly weaker keypair (e.g., a keypair of a smaller keysize). This also would allow the attacker to listen in on encrypted communication between the target and its peers. The target's peers might wrap an encryption session key under the target's "new" public key, which would allow the attacker (who possesses the corresponding private key) to unwrap the session key and decipher the communication data encrypted under that session key.
    Implementation Note:
    实现可能会定义其他目标名称，但应使用命名约定（如反向域名符号）来避免名称冲突。
    从以下版本开始：
    1.2
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SecurityPermission​(String name)
      创建一个新的具有指定名称的SecurityPermission。
      SecurityPermission​(String name, String actions)
      创建一个新的具有指定名称的SecurityPermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • SecurityPermission

        public SecurityPermission​(String name)
        创建一个新的具有指定名称的SecurityPermission。 该名称是SecurityPermission的符号名称。 名称后面可能会出现一个星号，后跟“。”，或本身表示通配符匹配。
        参数
        name - SecurityPermission的名称
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。

      • SecurityPermission

        public SecurityPermission​(String name,
                          String actions)
        创建一个新的具有指定名称的SecurityPermission对象。 该名称是SecurityPermission的符号名称，并且操作String当前未使用，应为null。
        参数
        name - SecurityPermission的名称
        actions - 应为null。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Signature (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Signature

  • java.lang.Object
    • java.security.SignatureSpi
      • java.security.Signature

  • public abstract class Signature
extends SignatureSpi
    Signature类用于向应用程序提供数字签名算法的功能。 数字签名用于数字数据的认证和完整性保证。

    签名算法可以是NIST标准DSA，使用DSA和SHA-1。 使用SHA-1消息摘要算法的DSA算法可以指定为SHA1withDSA 。 在RSA的情况下，存在对消息多个选择摘要算法，所以签名算法可被指定为，例如， MD2withRSA ， MD5withRSA ，或SHA1withRSA 。 必须指定算法名称，因为没有默认值。

    Signature对象可用于生成和验证数字签名。

    Signature对象用于签名数据或验证签名有三个阶段：

    1. 初始化，或者
      • 一个公钥，用于初始化签名以进行验证（见initVerify ）或
      • 私钥（和可选的安全随机数生成器），用于初始化签名签名（见initSign(PrivateKey)和initSign(PrivateKey, SecureRandom) ）。
    2. 更新

      根据初始化的类型，这将更新要签名或验证的字节。 请参阅update方法。

    3. 在所有更新的字节上签名或验证签名。 参见sign方法和verify方法。

    注意，这个类是抽象的，由于历史原因而从SignatureSpi延伸。 应用程序开发人员只应注意本Signature课程中定义的方法; 超类中的所有方法都适用于希望提供自己的数字签名算法实现的加密服务提供商。

    Java平台的每个实现都需要支持以下标准的Signature算法：

    • SHA1withDSA
    • SHA256withDSA
    • SHA1withRSA
    • SHA256withRSA
    这些算法在Java安全标准算法名称规范的Signature section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected static int SIGN
      可能的值为 state ，表示此签名对象已初始化以进行签名。
      protected int state
      此签名对象的当前状态。
      protected static int UNINITIALIZED
      可能的值为 state ，表示此签名对象尚未初始化。
      protected static int VERIFY
      可能的值为 state ，表示此签名对象已初始化以进行验证。

      • Fields inherited from class java.security.SignatureSpi

        appRandom

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Signature​(String algorithm)
      为指定的算法创建一个Signature对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Object clone​()
      如果实现是可克隆的，则返回克隆。
      String getAlgorithm​()
      返回此签名对象的算法名称。
      static Signature getInstance​(String algorithm)
      返回实现指定签名算法的Signature对象。
      static Signature getInstance​(String algorithm, String provider)
      返回实现指定签名算法的Signature对象。
      static Signature getInstance​(String algorithm, Provider provider)
      返回实现指定签名算法的Signature对象。
      Object getParameter​(String param)
      已过时。
      AlgorithmParameters getParameters​()
      返回与此签名对象一起使用的参数。
      Provider getProvider​()
      返回此签名对象的提供者。
      void initSign​(PrivateKey privateKey)
      初始化此对象进行签名。
      void initSign​(PrivateKey privateKey, SecureRandom random)
      初始化此对象进行签名。
      void initVerify​(Certificate certificate)
      使用给定证书中的公钥初始化此对象进行验证。
      void initVerify​(PublicKey publicKey)
      初始化此对象进行验证。
      void setParameter​(String param, Object value)
      已过时。
      使用setParameter 。
      void setParameter​(AlgorithmParameterSpec params)
      使用指定的参数集初始化此签名引擎。
      byte[] sign​()
      返回所有更新的数据的签名字节。
      int sign​(byte[] outbuf, int offset, int len)
      完成签名操作并将生成的签名字节存储在提供的缓冲区 outbuf ，从 offset开始。
      String toString​()
      返回此签名对象的字符串表示形式，提供包含对象状态和所使用算法名称的信息。
      void update​(byte b)
      更新要由一个字节签名或验证的数据。
      void update​(byte[] data)
      使用指定的字节数组更新要签名或验证的数据。
      void update​(byte[] data, int off, int len)
      使用指定的字节数组从指定的偏移量更新要签名或验证的数据。
      void update​(ByteBuffer data)
      使用指定的ByteBuffer更新要签名或验证的数据。
      boolean verify​(byte[] signature)
      验证传入签名。
      boolean verify​(byte[] signature, int offset, int length)
      以指定的偏移量开始，以指定的字节数组验证传入签名。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.SignatureSpi

        engineGetParameter, engineGetParameters, engineInitSign, engineInitSign, engineInitVerify, engineSetParameter, engineSetParameter, engineSign, engineSign, engineUpdate, engineUpdate, engineUpdate, engineVerify, engineVerify

    • 字段详细信息

      • UNINITIALIZED

        protected static final int UNINITIALIZED
        可能的值为 state ，表示此签名对象尚未初始化。
        另请参见：
        Constant Field Values

      • SIGN

        protected static final int SIGN
        可能的值为 state ，表示此签名对象已初始化以进行签名。
        另请参见：
        Constant Field Values

      • VERIFY

        protected static final int VERIFY
        可能的值为 state ，表示此签名对象已初始化以进行验证。
        另请参见：
        Constant Field Values

      • state

        protected int state
        此签名对象的当前状态。

    • 构造方法详细信息

      • Signature

        protected Signature​(String algorithm)
        为指定的算法创建一个Signature对象。
        参数
        algorithm - 算法的标准字符串名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的“签名”部分。

    • 方法详细信息

      • getInstance

        public static Signature getInstance​(String algorithm)
                             throws NoSuchAlgorithmException
        返回实现指定签名算法的Signature对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装SignatureSpi实现的新Signature对象。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 请求的算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的“签名”部分。
        结果
        新的 Signature对象
        异常
        NoSuchAlgorithmException - 如果否 Provider支持指定算法的 Signature实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static Signature getInstance​(String algorithm,
                                    String provider)
                             throws NoSuchAlgorithmException,
                                    NoSuchProviderException
        返回实现指定签名算法的Signature对象。

        返回从指定提供程序封装SignatureSpi实现的新Signature对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        algorithm - 请求的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的“签名”部分。
        provider - 提供商的名称。
        结果
        新的 Signature对象
        异常
        IllegalArgumentException - 如果提供商名称为 null或为空
        NoSuchAlgorithmException - 如果指定算法的 SignatureSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static Signature getInstance​(String algorithm,
                                    Provider provider)
                             throws NoSuchAlgorithmException
        返回实现指定签名算法的Signature对象。

        返回从指定的Provider对象封装SignatureSpi实现的新Signature对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 请求的算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的“签名”部分。
        provider - 提供商。
        结果
        新的 Signature对象
        异常
        IllegalArgumentException - 如果提供者是 null
        NoSuchAlgorithmException - 如果指定的算法的 SignatureSpi实现不能从指定的 Provider对象获得
        NullPointerException - 如果 algorithm是 null
        从以下版本开始：
        1.4
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此签名对象的提供者。
        结果
        这个签名对象的提供者

      • initVerify

        public final void initVerify​(PublicKey publicKey)
                      throws InvalidKeyException
        初始化此对象进行验证。 如果再次使用不同的参数调用此方法，则会消除此调用的影响。
        参数
        publicKey - 签名将被验证的身份的公钥。
        异常
        InvalidKeyException - 如果密钥无效。

      • initVerify

        public final void initVerify​(Certificate certificate)
                      throws InvalidKeyException
        使用给定证书中的公钥初始化此对象进行验证。

        如果证书是类型X.509，并且密钥使用扩展字段标记为关键，并且密钥使用扩展字段的值意味着证书中的公钥及其相应的私钥不应该用于数字签名，一个InvalidKeyException被抛出。

        参数
        certificate - 签名将被验证的身份证明。
        异常
        InvalidKeyException - 如果证书中的公钥未正确编码或不包括所需的参数信息或不能用于数字签名。
        从以下版本开始：
        1.3

      • initSign

        public final void initSign​(PrivateKey privateKey)
                    throws InvalidKeyException
        初始化此对象进行签名。 如果再次使用不同的参数调用此方法，则会消除此调用的影响。
        参数
        privateKey - 将要生成其签名的身份的私钥。
        异常
        InvalidKeyException - 如果密钥无效。

      • initSign

        public final void initSign​(PrivateKey privateKey,
                           SecureRandom random)
                    throws InvalidKeyException
        初始化此对象进行签名。 如果再次使用不同的参数调用此方法，则会消除此调用的影响。
        参数
        privateKey - 将要生成签名的身份的私钥。
        random - 此签名的随机来源。
        异常
        InvalidKeyException - 如果密钥无效。

      • sign

        public final byte[] sign​()
                  throws SignatureException
        返回所有更新的数据的签名字节。 签名的格式取决于底层签名方案。

        调用此方法将此签名对象重置为先前初始化以通过调用initSign(PrivateKey)进行签名的initSign(PrivateKey) 。 也就是说，如果需要，通过对update和sign新呼叫，对象被重置并可用于从相同的签名者生成另一个签名。

        结果
        签名操作结果的签名字节。
        异常
        SignatureException - 如果此签名对象未正确初始化，或者该签名算法是否无法处理提供的输入数据。

      • sign

        public final int sign​(byte[] outbuf,
                      int offset,
                      int len)
               throws SignatureException
        完成签名操作并将生成的签名字节存储在提供的缓冲器outbuf ，从offset开始。 签名的格式取决于底层签名方案。

        该签名对象被重置为其初始状态（在调用initSign方法之一之后的状态），并且可以重用以使用相同的私钥生成进一步的签名。

        参数
        outbuf - 签名结果的缓冲区。
        offset - 偏移到 outbuf ，其中存储签名。
        len - 分配给签名的 outbuf内的字节数。
        结果
        放入 outbuf的字节数。
        异常
        SignatureException - 如果此签名对象未正确初始化，则该签名算法无法处理提供的输入数据，或者如果 len小于实际签名长度。
        IllegalArgumentException -如果 outbuf是 null ，或 offset或 len小于0，或总和 offset和 len比的长度大 outbuf 。
        从以下版本开始：
        1.2

      • verify

        public final boolean verify​(byte[] signature)
                     throws SignatureException
        验证传入签名。

        调用此方法将此签名对象重置为先前初始化以通过调用initVerify(PublicKey)进行验证的initVerify(PublicKey) 。 也就是说，对象被重置并且可用于验证来自在initVerify的调用中指定了公钥的身份的另一个签名。

        参数
        signature - 要验证的签名字节。
        结果
        如果签名被验证，则为真，否则为false。
        异常
        SignatureException - 如果此签名对象未正确初始化，则传入的签名不正确编码或错误类型，如果此签名算法无法处理提供的输入数据等。

      • verify

        public final boolean verify​(byte[] signature,
                            int offset,
                            int length)
                     throws SignatureException
        以指定的偏移量开始，以指定的字节数组验证传入签名。

        调用此方法将此签名对象重置为先前初始化以通过调用initVerify(PublicKey)进行验证的initVerify(PublicKey) 。 也就是说，对象被重置并且可用于从在initVerify的调用中指定了公钥的身份验证另一个签名。

        参数
        signature - 要验证的签名字节。
        offset - 从字节数组开始的偏移量。
        length - 从偏移开始使用的字节数。
        结果
        如果签名被验证，则为真，否则为false。
        异常
        SignatureException - 如果该签名对象未被正确初始化，则如果该签名算法无法处理提供的输入数据，则传入的签名被错误地编码或错误的类型。
        IllegalArgumentException - 如果 signature字节数组为空，或者 offset或 length小于0，或者 offset和 length的总和大于 signature字节数组的长度。
        从以下版本开始：
        1.4

      • update

        public final void update​(byte b)
                  throws SignatureException
        更新要由一个字节签名或验证的数据。
        参数
        b - 用于更新的字节。
        异常
        SignatureException - 如果此签名对象未正确初始化。

      • update

        public final void update​(byte[] data)
                  throws SignatureException
        使用指定的字节数组更新要签名或验证的数据。
        参数
        data - 用于更新的字节数组。
        异常
        SignatureException - 如果此签名对象未正确初始化。

      • update

        public final void update​(byte[] data,
                         int off,
                         int len)
                  throws SignatureException
        使用指定的字节数组从指定的偏移量更新要签名或验证的数据。
        参数
        data - 字节数组。
        off - 从字节数组开始的偏移量。
        len - 从偏移开始使用的字节数。
        异常
        SignatureException - 如果此签名对象未正确初始化。
        IllegalArgumentException -如果 data是 null ，或 off或 len小于0，或总和 off和 len比的长度大 data 。

      • update

        public final void update​(ByteBuffer data)
                  throws SignatureException
        使用指定的ByteBuffer更新要签名或验证的数据。 处理data.remaining()起始字节data.position() 。 返回时，缓冲区的位置将等于其限制; 其限制将不会改变。
        参数
        data - ByteBuffer
        异常
        SignatureException - 如果此签名对象未正确初始化。
        从以下版本开始：
        1.5

      • getAlgorithm

        public final String getAlgorithm​()
        返回此签名对象的算法名称。
        结果
        该签名对象的算法名称。

      • toString

        public String toString​()
        返回此签名对象的字符串表示形式，提供包含对象状态和所使用算法名称的信息。
        重写：
        toString在 Object
        结果
        该签名对象的字符串表示形式。

      • setParameter

        @Deprecated
public final void setParameter​(String param,
                               Object value)
                        throws InvalidParameterException
        已过时。 使用setParameter 。
        将指定的算法参数设置为指定的值。 该方法提供通用机制，通过该机制可以设置该对象的各种参数。 参数可以是算法的任何可设置参数，诸如参数大小，或用于签名生成的随机比特来源（如果适用）），或者是否执行特定但可选择的计算的指示。 每个参数的均匀算法特定命名方案是可取的，但在此时未指定。
        参数
        param - 参数的字符串标识符。
        value - 参数值。
        异常
        InvalidParameterException - 如果 param是此签名算法引擎的无效参数，则该参数已设置，不能再次设置，发生安全异常等。
        另请参见：
        getParameter(java.lang.String)

      • setParameter

        public final void setParameter​(AlgorithmParameterSpec params)
                        throws InvalidAlgorithmParameterException
        使用指定的参数集初始化此签名引擎。
        参数
        params - 参数
        异常
        InvalidAlgorithmParameterException - 如果给定的参数不适合此签名引擎
        另请参见：
        getParameters()

      • getParameters

        public final AlgorithmParameters getParameters​()
        返回与此签名对象一起使用的参数。

        返回的参数可能与用于初始化该签名的参数相同，或者如果该签名需要算法参数但未被任何初始化，则可能包含由底层签名实现使用的默认和随机生成的参数值的组合。

        结果
        与此签名一起使用的参数，如果此签名不使用任何参数，则为null。
        从以下版本开始：
        1.4
        另请参见：
        setParameter(AlgorithmParameterSpec)

      • getParameter

        @Deprecated
public final Object getParameter​(String param)
                          throws InvalidParameterException
        已过时。
        获取指定算法参数的值。 该方法提供通用机制，通过该机制可以获得该对象的各种参数。 参数可以是算法的任何可设置参数，诸如参数大小，或用于签名生成的随机比特来源（如果适用）），或者是否执行特定但可选择的计算的指示。 每个参数的均匀算法特定命名方案是可取的，但在此时未指定。
        参数
        param - 参数的字符串名称。
        结果
        表示参数值的对象，如果没有，则为null。
        异常
        InvalidParameterException - 如果 param是此引擎的无效参数，或尝试获取此参数时发生另一个异常。
        另请参见：
        setParameter(String, Object)

      • clone

        public Object clone​()
             throws CloneNotSupportedException
        如果实现是可克隆的，则返回克隆。
        重写：
        clone在 SignatureSpi
        结果
        一个克隆，如果实现是可克隆的。
        异常
        CloneNotSupportedException - 如果在不支持 Cloneable的实现上调用此方法。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


SignatureException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class SignatureException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.SignatureException
  • All Implemented Interfaces:
    Serializable

    public class SignatureException
extends GeneralSecurityException
    这是一般的签名异常。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SignatureException​()
      构造一个没有详细消息的SignatureException。
      SignatureException​(String msg)
      构造具有指定详细消息的SignatureException。
      SignatureException​(String message, Throwable cause)
      创建一个具有指定的详细信息和原因的 SignatureException 。
      SignatureException​(Throwable cause)
      创建 SignatureException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SignatureException

        public SignatureException​()
        构造一个没有详细消息的SignatureException。 详细消息是描述此特定异常的字符串。

      • SignatureException

        public SignatureException​(String msg)
        构造具有指定详细消息的SignatureException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。

      • SignatureException

        public SignatureException​(String message,
                          Throwable cause)
        创建一个 SignatureException与指定的详细信息和原因。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • SignatureException

        public SignatureException​(Throwable cause)
        创建 SignatureException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许值为null ，表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SignatureSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class SignatureSpi

  • java.lang.Object
    • java.security.SignatureSpi
  • 已知直接子类：
    Signature

    public abstract class SignatureSpi
extends Object
    该类定义了Signature类的 （ SPI ），用于提供数字签名算法的功能。 数字签名用于数字数据的认证和完整性保证。

    该类中的所有抽象方法必须由希望提供特定签名算法的实现的每个加密服务提供商来实现。

    从以下版本开始：
    1.2
    另请参见：
    Signature

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected SecureRandom appRandom
      应用指定的随机源。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SignatureSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Object clone​()
      如果实现是可克隆的，则返回克隆。
      protected abstract Object engineGetParameter​(String param)
      已过时。
      protected AlgorithmParameters engineGetParameters​()
      提供者覆盖此方法以返回与此签名引擎一起使用的参数，如果此签名引擎不使用任何参数，则返回null。
      protected abstract void engineInitSign​(PrivateKey privateKey)
      使用指定的私钥初始化此签名对象进行签名操作。
      protected void engineInitSign​(PrivateKey privateKey, SecureRandom random)
      使用指定的私钥和签名操作的随机源初始化此签名对象。
      protected abstract void engineInitVerify​(PublicKey publicKey)
      使用指定的公钥初始化此签名对象进行验证操作。
      protected abstract void engineSetParameter​(String param, Object value)
      已过时。
      由engineSetParameter取代 。
      protected void engineSetParameter​(AlgorithmParameterSpec params)
      提供者将覆盖此方法以使用指定的参数集来初始化此签名引擎。
      protected abstract byte[] engineSign​()
      返回到目前为止更新的所有数据的签名字节。
      protected int engineSign​(byte[] outbuf, int offset, int len)
      完成此签名操作，并将生成的签名字节存储在提供的缓冲区 outbuf ，从 offset开始。
      protected abstract void engineUpdate​(byte b)
      使用指定的字节更新要签名或验证的数据。
      protected abstract void engineUpdate​(byte[] b, int off, int len)
      使用指定的字节数组从指定的偏移量更新要签名或验证的数据。
      protected void engineUpdate​(ByteBuffer input)
      使用指定的ByteBuffer更新要签名或验证的数据。
      protected abstract boolean engineVerify​(byte[] sigBytes)
      验证传入签名。
      protected boolean engineVerify​(byte[] sigBytes, int offset, int length)
      以指定的偏移量开始，以指定的字节数组验证传入签名。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • appRandom

        protected SecureRandom appRandom
        应用指定的随机源。

    • 构造方法详细信息

      • SignatureSpi

        public SignatureSpi​()

    • 方法详细信息

      • engineInitVerify

        protected abstract void engineInitVerify​(PublicKey publicKey)
                                  throws InvalidKeyException
        使用指定的公钥初始化此签名对象进行验证操作。
        参数
        publicKey - 签名将被验证的身份的公钥。
        异常
        InvalidKeyException - 如果密钥编码不正确，则丢失参数，依此类推。

      • engineInitSign

        protected abstract void engineInitSign​(PrivateKey privateKey)
                                throws InvalidKeyException
        使用指定的私钥初始化此签名对象进行签名操作。
        参数
        privateKey - 将生成签名的身份的私钥。
        异常
        InvalidKeyException - 如果密钥编码不正确，则丢失参数，依此类推。

      • engineInitSign

        protected void engineInitSign​(PrivateKey privateKey,
                              SecureRandom random)
                       throws InvalidKeyException
        使用指定的私钥和签名操作的随机源初始化此签名对象。

        这个具体的方法已经添加到这个以前定义的抽象类中。 （为了向后兼容，它不能是抽象的。）

        参数
        privateKey - 将生成签名的身份的私钥。
        random - 随机的来源
        异常
        InvalidKeyException - 如果密钥编码不正确，则丢失参数，依此类推。

      • engineUpdate

        protected abstract void engineUpdate​(byte b)
                              throws SignatureException
        使用指定的字节更新要签名或验证的数据。
        参数
        b - 用于更新的字节。
        异常
        SignatureException - 如果引擎未正确初始化

      • engineUpdate

        protected abstract void engineUpdate​(byte[] b,
                                     int off,
                                     int len)
                              throws SignatureException
        使用指定的字节数组从指定的偏移量更新要签名或验证的数据。
        参数
        b - 字节数组
        off - 从字节数组开始的偏移量
        len - 从偏移开始使用的字节数
        异常
        SignatureException - 如果引擎未正确初始化

      • engineUpdate

        protected void engineUpdate​(ByteBuffer input)
        使用指定的ByteBuffer更新要签名或验证的数据。 处理data.remaining()起始字节data.position() 。 返回时，缓冲区的位置将等于其限制; 其限制将不会改变。
        参数
        input - ByteBuffer
        从以下版本开始：
        1.5

      • engineSign

        protected abstract byte[] engineSign​()
                              throws SignatureException
        返回到目前为止更新的所有数据的签名字节。 签名的格式取决于底层签名方案。
        结果
        签名操作结果的签名字节。
        异常
        SignatureException - 如果引擎未正确初始化，或者该签名算法是否无法处理提供的输入数据。

      • engineSign

        protected int engineSign​(byte[] outbuf,
                         int offset,
                         int len)
                  throws SignatureException
        完成此签名操作，并将生成的签名字节存储在提供的缓冲区outbuf ，从offset开始。 签名的格式取决于底层签名方案。

        签名实现被重置为其初始状态（在调用engineInitSign方法之一后的engineInitSign ），并且可以重用以使用相同的私钥生成进一步的签名。 这种方法应该是抽象的，但是我们留下具体的二进制兼容性。 有知识的提供者应该覆盖这种方法。

        参数
        outbuf - 签名结果的缓冲区。
        offset - 偏移到 outbuf ，其中存储签名。
        len - 分配给签名的outbuf内的字节数。 这个默认实现和SUN提供者都不返回部分摘要。 如果此参数的值小于实际签名长度，则此方法将抛出一个SignatureException。 如果该值大于或等于实际签名长度，则忽略此参数。
        结果
        字节数放入 outbuf
        异常
        SignatureException - 如果引擎未正确初始化，如果此签名算法无法处理提供的输入数据，或者如果 len小于实际签名长度。
        从以下版本开始：
        1.2

      • engineVerify

        protected abstract boolean engineVerify​(byte[] sigBytes)
                                 throws SignatureException
        验证传入签名。
        参数
        sigBytes - 要验证的签名字节。
        结果
        如果签名被验证，则为真，否则为false。
        异常
        SignatureException - 如果引擎未正确初始化，则传入的签名被错误地编码或错误的类型，如果该签名算法不能处理提供的输入数据等。

      • engineVerify

        protected boolean engineVerify​(byte[] sigBytes,
                               int offset,
                               int length)
                        throws SignatureException
        以指定的偏移量开始，以指定的字节数组验证传入签名。

        注意：子类应该覆盖默认实现。

        参数
        sigBytes - 要验证的签名字节。
        offset - 从字节数组开始的偏移量。
        length - 从偏移开始使用的字节数。
        结果
        如果签名被验证，则为真，否则为false。
        异常
        SignatureException - 如果引擎未正确初始化，则传入的签名被错误地编码或错误的类型，如果该签名算法无法处理提供的输入数据等。
        从以下版本开始：
        1.4

      • engineSetParameter

        @Deprecated
protected abstract void engineSetParameter​(String param,
                                           Object value)
                                    throws InvalidParameterException
        已过时。 替换为engineSetParameter 。
        将指定的算法参数设置为指定的值。 该方法提供通用机制，通过该机制可以设置该对象的各种参数。 参数可以是算法的任何可设置参数，诸如参数大小，或用于签名生成的随机比特来源（如果适用）），或者是否执行特定但可选择的计算的指示。 每个参数的均匀算法特定命名方案是可取的，但在此时未指定。
        参数
        param - 参数的字符串标识符。
        value - 参数值。
        异常
        InvalidParameterException - 如果 param是该签名算法引擎的无效参数，则该参数已设置，不能再次设置，发生安全异常等。

      • engineSetParameter

        protected void engineSetParameter​(AlgorithmParameterSpec params)
                           throws InvalidAlgorithmParameterException

        提供者将覆盖此方法以使用指定的参数集来初始化此签名引擎。

        参数
        params - 参数
        异常
        UnsupportedOperationException - 如果此方法不被提供程序覆盖
        InvalidAlgorithmParameterException - 如果此方法被提供程序覆盖，并且给定的参数不适合此签名引擎

      • engineGetParameters

        protected AlgorithmParameters engineGetParameters​()

        提供者覆盖此方法以返回与此签名引擎一起使用的参数，如果此签名引擎不使用任何参数，则返回null。

        返回的参数可能与用于初始化此签名引擎的参数相同，或者如果该签名引擎需要算法参数但未被任何一个初始化，则可能包含底层签名实现使用的默认和随机生成的参数值的组合。

        结果
        与此签名引擎一起使用的参数，如果此签名引擎不使用任何参数，则为null
        异常
        UnsupportedOperationException - 如果此方法不被提供程序覆盖
        从以下版本开始：
        1.4

      • engineGetParameter

        @Deprecated
protected abstract Object engineGetParameter​(String param)
                                      throws InvalidParameterException
        已过时。
        获取指定算法参数的值。 该方法提供通用机制，通过该机制可以获得该对象的各种参数。 参数可以是算法的任何可设置参数，诸如参数大小，或用于签名生成的随机比特来源（如果适用）），或者是否执行特定但可选择的计算的指示。 每个参数的均匀算法特定命名方案是可取的，但在此时未指定。
        参数
        param - 参数的字符串名称。
        结果
        表示参数值的对象，如果没有，则为null。
        异常
        InvalidParameterException - 如果 param是此引擎的无效参数，或尝试获取此参数时发生另一个异常。

      • clone

        public Object clone​()
             throws CloneNotSupportedException
        如果实现是可克隆的，则返回克隆。
        重写：
        clone在 Object
        结果
        一个克隆，如果实现是可克隆的。
        异常
        CloneNotSupportedException - 如果在不支持 Cloneable的实现上调用此方法。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


SignedObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class SignedObject

  • java.lang.Object
    • java.security.SignedObject
  • All Implemented Interfaces:
    Serializable

    public final class SignedObject
extends Object
implements Serializable

    SignedObject是一个类，用于创建可靠的运行时对象，其完整性不会受到威胁，而不会被检测到。

    更具体地说，SignedObject包含另一个Serializable对象，即（待签名）对象及其签名。

    签名对象是原始对象的“深层副本”（以序列化形式）。 一旦复制完成，对原始对象的进一步操纵对副本没有副作用。

    底层签名算法由传递给构造函数的签名对象和verify方法指定。 用于签名的典型用法如下：

       Signature signingEngine = Signature.getInstance(algorithm, provider); SignedObject so = new SignedObject(myobject, signingKey, signingEngine);

    验证的典型用法如下（已收到SignedObject so ）：

       Signature verificationEngine = Signature.getInstance(algorithm, provider); if (so.verify(publickey, verificationEngine)) try { Object myobj = so.getObject(); } catch (java.lang.ClassNotFoundException e) {};

    值得注意的几点。 首先，不需要初始化签名或验证引擎，因为它将在构造函数和verify方法中重新初始化。 其次，为了验证成功，指定的公钥必须是与用于生成SignedObject的私钥对应的公钥。

    更重要的是，出于灵活性原因，构造函数和verify方法允许定制的签名引擎，其可以实现未正式安装作为加密提供者的一部分的签名算法。 然而，编写验证码的程序员至关重要的是要知道使用什么是Signature引擎，因为它自己的verify方法的实现被调用来验证签名。 换句话说，恶意的Signature可能会选择在验证时始终返回true，以试图绕过安全检查。

    签名算法可以是NIST标准DSA，使用DSA和SHA-1。 该算法使用与签名相同的约定来指定。 使用SHA-1消息摘要算法的DSA算法可以被指定为例如“SHA / DSA”或“SHA-1 / DSA”（它们是等效的）。 在RSA的情况下，消息摘要算法有多种选择，因此签名算法可以被指定为例如“MD2 / RSA”，“MD5 / RSA”或“SHA-1 / RSA”。 必须指定算法名称，因为没有默认值。

    Cryptography Package Provider的名称也由构造函数的Signature参数和verify方法指定。 如果未指定提供程序，则使用默认提供程序。 默认情况下，每个安装都可以配置为使用特定的提供者。

    SignedObject的潜在应用包括：

    • 它可以在内部使用任何Java运行时作为一个不可伪造的授权令牌 - 可以传递的令牌，而不用担心令牌可能被恶意修改而不被检测到。
    • 它可以用于在Java运行时间之外对数据/对象进行签名和序列化（例如，将重要的访问控制数据存储在磁盘上）。
    • 嵌套SignedObject可用于构建类似于授权和授权链的签名的逻辑序列。
    从以下版本开始：
    1.2
    另请参见：
    Signature ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SignedObject​(Serializable object, PrivateKey signingKey, Signature signingEngine)
      从任何可序列化对象构造一个SignedObject。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getAlgorithm​()
      检索签名算法的名称。
      Object getObject​()
      检索封装对象。
      byte[] getSignature​()
      以一个字节数组的形式检索签名对象上的签名。
      boolean verify​(PublicKey verificationKey, Signature verificationEngine)
      验证此SignedObject中的签名是使用指定的验证引擎使用给定的验证密钥存储在其中的对象的有效签名。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SignedObject

        public SignedObject​(Serializable object,
                    PrivateKey signingKey,
                    Signature signingEngine)
             throws IOException,
                    InvalidKeyException,
                    SignatureException
        从任何可序列化对象构造一个SignedObject。 给定的对象使用指定的签名引擎签名。
        参数
        object - 要签名的对象。
        signingKey - 用于签名的私钥。
        signingEngine - 签名签名引擎。
        异常
        IOException - 如果在序列化期间发生错误
        InvalidKeyException - 如果密钥无效。
        SignatureException - 如果签名失败。

    • 方法详细信息

      • getObject

        public Object getObject​()
                 throws IOException,
                        ClassNotFoundException
        检索封装对象。 封装的对象在返回之前被解除序列化。
        结果
        封装对象。
        异常
        IOException - 如果在反序列化期间发生错误
        ClassNotFoundException - 如果在反序列化期间发生错误

      • getSignature

        public byte[] getSignature​()
        以一个字节数组的形式检索签名对象上的签名。
        结果
        签名。 每次调用此方法时都会返回一个新数组。

      • getAlgorithm

        public String getAlgorithm​()
        检索签名算法的名称。
        结果
        签名算法名称。

      • verify

        public boolean verify​(PublicKey verificationKey,
                      Signature verificationEngine)
               throws InvalidKeyException,
                      SignatureException
        验证此SignedObject中的签名是使用指定的验证引擎使用给定的验证密钥存储在其中的对象的有效签名。
        参数
        verificationKey - 验证公钥。
        verificationEngine - 签名验证引擎。
        结果
        true如果签名是有效的， false否则
        异常
        SignatureException - 如果签名验证失败（异常阻止签名验证引擎正常完成）。
        InvalidKeyException - 验证键是否无效。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Signer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Signer

  • java.lang.Object
    • java.security.Identity
      • java.security.Signer
  • All Implemented Interfaces:
    Serializable ， Principal
    已过时。
    此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。

    @Deprecated(since="1.2")
public abstract class Signer
extends Identity
    此类用于表示也可以对数据进行数字签名的身份。

    签名人私钥的管理是一个重要且敏感的问题，应由子类根据其预期用途进行处理。

    从以下版本开始：
    1.1
    另请参见：
    Identity ， Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Signer​()
      已过时。
      创建一个签名者
        Signer​(String name)
      已过时。
      创建具有指定身份名称的签名者。
        Signer​(String name, IdentityScope scope)
      已过时。
      创建具有指定身份名称和范围的签名者。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      PrivateKey getPrivateKey​()
      已过时。
      返回此签名者的私钥。
      void setKeyPair​(KeyPair pair)
      已过时。
      设置此签名者的密钥对（公钥和私钥）。
      String toString​()
      已过时。
      返回一个关于签名者的信息字符串。

      • Methods inherited from class java.security.Identity

        addCertificate, certificates, equals, getInfo, getName, getPublicKey, getScope, hashCode, identityEquals, removeCertificate, setInfo, setPublicKey, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • Signer

        protected Signer​()
        已过时。
        创建一个签名者 该构造函数只能用于序列化。

      • Signer

        public Signer​(String name)
        已过时。
        创建具有指定身份名称的签名者。
        参数
        name - 身份名称。

      • Signer

        public Signer​(String name,
              IdentityScope scope)
       throws KeyManagementException
        已过时。
        创建具有指定身份名称和范围的签名者。
        参数
        name - 身份名称。
        scope - 身份的范围。
        异常
        KeyManagementException - 如果在作用 KeyManagementException已经存在同名的身份。

    • 方法详细信息

      • getPrivateKey

        public PrivateKey getPrivateKey​()
        已过时。
        返回此签名者的私钥。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法将以"getSignerPrivateKey"作为参数来调用，以查看是否可以返回私钥。

        结果
        此签名者的私钥，如果私钥尚未设置，则为null。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkSecurityAccess方法不允许返回私钥。
        另请参见：
        SecurityManager.checkSecurityAccess(java.lang.String)

      • setKeyPair

        public final void setKeyPair​(KeyPair pair)
                      throws InvalidParameterException,
                             KeyException
        已过时。
        设置此签名者的密钥对（公钥和私钥）。

        首先，如果有一个安全管理器，它的checkSecurityAccess方法被调用，以"setSignerKeyPair"作为参数来查看是否可以设置密钥对。

        参数
        pair - 一个初始化的密钥对。
        异常
        InvalidParameterException - 如果密钥对未正确初始化。
        KeyException - 如果由于任何其他原因无法设置密钥对。
        SecurityException - 如果存在安全管理员，并且其 checkSecurityAccess方法不允许设置密钥对。
        另请参见：
        SecurityManager.checkSecurityAccess(java.lang.String)

      • toString

        public String toString​()
        已过时。
        返回一个关于签名者的信息字符串。
        Specified by:
        toString在接口 Principal
        重写：
        toString在类 Identity
        结果
        一系列关于签名者的信息。
        另请参见：
        SecurityManager.checkSecurityAccess(java.lang.String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Timestamp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class Timestamp

  • java.lang.Object
    • java.security.Timestamp
  • All Implemented Interfaces:
    Serializable

    public final class Timestamp
extends Object
implements Serializable
    此类封装了有关已签名时间戳的信息。 这是不可变的 它包括时间戳的日期和时间以及生成和签署时间戳的时间戳权限（TSA）的信息。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Timestamp​(Date timestamp, CertPath signerCertPath)
      构建时间戳

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      测试指定对象与此时间戳之间的相等性。
      CertPath getSignerCertPath​()
      返回时间戳权限的证书路径。
      Date getTimestamp​()
      返回生成时间戳的日期和时间。
      int hashCode​()
      返回此时间戳的哈希码值。
      String toString​()
      返回描述此时间戳的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Timestamp

        public Timestamp​(Date timestamp,
                 CertPath signerCertPath)
        构建时间戳
        参数
        timestamp - 是时间戳的日期和时间。 它不能为空。
        signerCertPath - 是TSA的证书路径。 它不能为空。
        异常
        NullPointerException - 如果timestamp或signerCertPath为null。

    • 方法详细信息

      • getTimestamp

        public Date getTimestamp​()
        返回生成时间戳的日期和时间。
        结果
        时间戳的日期和时间。

      • getSignerCertPath

        public CertPath getSignerCertPath​()
        返回时间戳权限的证书路径。
        结果
        TSA的证书路径。

      • hashCode

        public int hashCode​()
        返回此时间戳的哈希码值。 使用时间戳和TSA证书路径的日期和时间生成哈希码。
        重写：
        hashCode在 Object
        结果
        此时间戳的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        测试指定对象与此时间戳之间的相等性。 如果其时间戳及其签名者的证书路径的日期和时间相等，则两个时间戳被认为是相等的。
        重写：
        equals在 Object
        参数
        obj - 测试与此时间戳记相等的对象。
        结果
        如果时间戳被认为是相等的，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回描述此时间戳的字符串。
        重写：
        toString在 Object
        结果
        包含时间戳的日期和时间及其签名者证书的字符串。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnrecoverableEntryException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class UnrecoverableEntryException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.UnrecoverableEntryException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    UnrecoverableKeyException

    public class UnrecoverableEntryException
extends GeneralSecurityException
    如果密钥库中的条目无法恢复，则抛出此异常。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnrecoverableEntryException​()
      构造一个不可恢复的EntryException，没有详细的消息。
      UnrecoverableEntryException​(String msg)
      构造具有指定的详细消息的UnrecoverableEntryException，它提供了有关为什么抛出此异常的更多信息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnrecoverableEntryException

        public UnrecoverableEntryException​()
        构造一个不可恢复的EntryException，没有详细的消息。

      • UnrecoverableEntryException

        public UnrecoverableEntryException​(String msg)
        构造具有指定的详细消息的UnrecoverableEntryException，它提供了有关为什么抛出此异常的更多信息。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnrecoverableKeyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class UnrecoverableKeyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.UnrecoverableEntryException
            • java.security.UnrecoverableKeyException
  • All Implemented Interfaces:
    Serializable

    public class UnrecoverableKeyException
extends UnrecoverableEntryException
    如果密钥存储库中的密钥无法恢复，则抛出此异常。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnrecoverableKeyException​()
      构造不可恢复的KeyException，没有详细消息。
      UnrecoverableKeyException​(String msg)
      构造一个具有指定的详细信息的UnrecoverableKeyException，它提供了有关为什么抛出此异常的更多信息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnrecoverableKeyException

        public UnrecoverableKeyException​()
        构造不可恢复的KeyException，没有详细消息。

      • UnrecoverableKeyException

        public UnrecoverableKeyException​(String msg)
        构造一个具有指定的详细信息的UnrecoverableKeyException，它提供了有关为什么抛出此异常的更多信息。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnresolvedPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class UnresolvedPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.UnresolvedPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class UnresolvedPermission
extends Permission
implements Serializable
    UnresolvedPermission类用于保存初始化策略时“未解决”的权限。 未解决的权限是在策略初始化时实际的Permission类不存在的权限（见下文）。

    Java运行时的策略（指定哪些权限可用于各种主体的代码）由Policy对象表示。 无论何时初始化或刷新策略，都会为策略允许的所有权限创建适当类的权限对象。

    策略配置引用的许多权限类类型是本地存在的（即CLASSPATH中可以找到的类型）。 可以在策略初始化期间实例化此类权限的对象。 例如，始终可以实例化一个java.io.FilePermission，因为在CLASSPATH上找到FilePermission类。

    在策略初始化期间，其他权限类可能不存在。 例如，引用的权限类可能在稍后加载的JAR文件中。 对于每个这样的类，一个UnresolvedPermission被实例化。 因此，UnresolvedPermission本质上是一个包含有关权限信息的“占位符”。

    之后，当代码调用AccessController.checkPermission的类型以前未被解析，但其类已被加载的先前未被解析的类型的权限被“解决”。 也就是说，对于每个这样的UnresolvedPermission，基于UnresolvedPermission中的信息，实例化了适当类类型的新对象。

    为了实例化新类，UnresolvedPermission假定该类提供一个零，一个和/或两个参数的构造函数。 零参数构造函数将用于实例化没有名称而没有操作的权限。 假设一个arg构造函数以一个String名字作为输入，并且假设一个双参数构造函数采用一个String名字和String动作作为输入。 UnresolvedPermission可以调用具有null名称和/或操作的构造函数。 如果适当的权限构造函数不可用，则UnresolvedPermission将被忽略，并且相关权限将不会被授予执行代码。

    新创建的权限对象将替换被删除的UnresolvedPermission。

    需要注意的是getName方法为UnresolvedPermission返回type （类名称）尚未解析的基础权限。

    从以下版本开始：
    1.2
    另请参见：
    Permission ， Permissions ， PermissionCollection ， Policy ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnresolvedPermission​(String type, String name, String actions, Certificate[] certs)
      创建一个新的UnresolvedPermission，当权限解决时，包含稍后实际创建指定类的权限所需的权限信息。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查两个UnresolvedPermission对象是否相等。
      String getActions​()
      返回动作的规范字符串表示形式，它当前是空字符串“”，因为UnresolvedPermission没有任何操作。
      String getUnresolvedActions​()
      获取尚未解决的基础权限的操作。
      Certificate[] getUnresolvedCerts​()
      获取尚未解决的底层权限的签名者证书（无任何支持链）。
      String getUnresolvedName​()
      获取尚未解决的基础权限的目标名称。
      String getUnresolvedType​()
      获取尚未解决的基础权限的类型（类名）。
      int hashCode​()
      返回此对象的哈希码值。
      boolean implies​(Permission p)
      对于未解决的权限，此方法总是返回false。
      PermissionCollection newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储UnresolvedPermission对象。
      String toString​()
      返回描述此UnresolvedPermission的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName

    • 构造方法详细信息

      • UnresolvedPermission

        public UnresolvedPermission​(String type,
                            String name,
                            String actions,
                            Certificate[] certs)
        创建一个新的UnresolvedPermission，当权限解决时，包含稍后实际创建指定类的权限所需的权限信息。
        参数
        type - 解析此未解决权限时将创建的Permission类的类名。
        name - 权限的名称。
        actions - 权限的动作。
        certs - 许可类的签名证书。 这是证书链的列表，其中每个链由签名者证书和可选的其支持证书链组成。 每个链从底到顶排序（即，首先签名者证书和最后的（根）证书颁发机构）。 签名者证书是从数组复制的。 对数组的后续更改不会影响此UnsolvedPermission。

    • 方法详细信息

      • implies

        public boolean implies​(Permission p)
        对于未解决的权限，此方法总是返回false。 也就是说，UnresolvedPermission从不被认为意味着另一个权限。
        Specified by:
        implies在 Permission
        参数
        p - 允许检查。
        结果
        假。

      • equals

        public boolean equals​(Object obj)
        检查两个UnresolvedPermission对象是否相等。 检查obj是UnresolvedPermission，并且具有与此对象相同的类型（类）名称，权限名称，操作和证书。

        要确定证书的相等性，此方法仅比较实际的签名者证书。 该方法不考虑支持证书链。

        Specified by:
        equals在 Permission
        参数
        obj - 我们正在测试与此对象相等的对象。
        结果
        如果obj是UnresolvedPermission，则为true，并且具有与此对象相同的类型（类）名称，权限名称，操作和证书。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此对象的哈希码值。
        Specified by:
        hashCode在 Permission
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getActions

        public String getActions​()
        返回动作的规范字符串表示形式，它当前是空字符串“”，因为UnresolvedPermission没有任何操作。 也就是说，当解决此UnresolvedPermission时将创建的权限的操作可能不为空，但UnresolvedPermission本身永远不会被视为具有任何操作。
        Specified by:
        getActions在 Permission
        结果
        空字符串“”。

      • getUnresolvedType

        public String getUnresolvedType​()
        获取尚未解决的基础权限的类型（类名）。
        结果
        未解析的底层权限的类型（类名）
        从以下版本开始：
        1.5

      • getUnresolvedName

        public String getUnresolvedName​()
        获取尚未解决的基础权限的目标名称。
        结果
        尚未解决的底层权限的目标名称，如果没有目标名称，则为 null
        从以下版本开始：
        1.5

      • getUnresolvedActions

        public String getUnresolvedActions​()
        获取尚未解决的基础权限的操作。
        结果
        尚未解决的底层权限的操作，如果没有操作， null
        从以下版本开始：
        1.5

      • getUnresolvedCerts

        public Certificate[] getUnresolvedCerts​()
        获取尚未解决的底层权限的签名者证书（无任何支持链）。
        结果
        未经解决的底层许可的签名者证书，如果没有签署者证书，则为null。 每次调用此方法时都会返回一个新数组。
        从以下版本开始：
        1.5

      • toString

        public String toString​()
        返回描述此UnresolvedPermission的字符串。 约定是以以下格式指定类名称，权限名称和操作：'（未解决的“ClassName”“name”“actions”）'。
        重写：
        toString在 Permission
        结果
        关于这个UnresolvedPermission的信息。

      • newPermissionCollection

        public PermissionCollection newPermissionCollection​()
        返回一个新的PermissionCollection对象，用于存储UnresolvedPermission对象。
        重写：
        newPermissionCollection在 Permission
        结果
        适用于存储UnresolvedPermissions的新PermissionCollection对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


URIParameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security

Class URIParameter

  • java.lang.Object
    • java.security.URIParameter
  • All Implemented Interfaces:
    Policy.Parameters ， Configuration.Parameters

    public class URIParameter
extends Object
implements Policy.Parameters, Configuration.Parameters
    包含指向PolicySpi或ConfigurationSpi实现的数据的URI的参数。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      URIParameter​(URI uri)
      构造URIParameter，URI指向用于SPI实现的数据。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      URI getURI​()
      返回URI。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • URIParameter

        public URIParameter​(URI uri)
        构造URIParameter，URI指向用于SPI实现的数据。
        参数
        uri - 指向数据的URI。
        异常
        NullPointerException - 如果指定的URI为空。

    • 方法详细信息

      • getURI

        public URI getURI​()
        返回URI。
        结果
        uri的URI。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.security (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.security

  • Packages that use java.security
    软件包 描述
    com.sun.jarsigner
    此包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.security.auth
    提供Principal的实现。
    com.sun.security.jgss
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    javafx.util
    包含各种实用程序和助手类。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    javax.security.cert
    提供公钥证书类。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.crypto.dsig.dom
    DOM专用类为 javax.xml.crypto.dsig包。
    javax.xml.crypto.dsig.keyinfo
    用于解析和处理KeyInfo元素和结构的类。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    jdk.net
    适用于 java.net和 java.nio.channels套接字类的平台特定套接字选项。
    jdk.security.jarsigner
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
  • Classes in java.security used by com.sun.jarsigner
    Class 描述
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
  • Classes in java.security used by com.sun.jdi
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by com.sun.net.httpserver
    Class 描述
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
  • Classes in java.security used by com.sun.security.auth
    Class 描述
    CodeSource
    该类扩展了代码库的概念，不仅封装了位置（URL），还封装了用于验证源自该位置的签名代码的证书链。
    PermissionCollection
    代表Permission对象集合的抽象类。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
  • Classes in java.security used by com.sun.security.jgss
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by com.sun.tools.attach
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by java.awt
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by java.io
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
    PermissionCollection
    代表Permission对象集合的抽象类。
  • Classes in java.security used by java.lang
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
    ProtectionDomain
    ProtectionDomain类封装了一个域的特性，该域包含一组类，当代表一组给定的主体执行时，该类的实例被授予一组权限。
  • Classes in java.security used by java.lang.instrument
    Class 描述
    ProtectionDomain
    ProtectionDomain类封装了一个域的特性，该域包含一组类，当代表一组给定的主体执行时，该类的实例被授予一组权限。
  • Classes in java.security used by java.lang.management
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by java.lang.reflect
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by java.net
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    CodeSource
    该类扩展了代码库的概念，不仅封装了位置（URL），还封装了用于验证源自该位置的签名代码的证书链。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
    PermissionCollection
    代表Permission对象集合的抽象类。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
    SecureClassLoader
    此类扩展了ClassLoader，其额外支持用于定义具有相关代码源和权限的类，默认情况下系统策略将检索该类。
  • Classes in java.security used by java.nio.file
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by java.nio.file.attribute
    Class 描述
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
  • Classes in java.security used by java.security
    Class 描述
    AccessControlContext
    AccessControlContext用于根据其封装的上下文来进行系统资源访问决策。
    AccessControlException
    AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。
    AlgorithmParameterGenerator
    AlgorithmParameterGenerator类用于生成一组要用于某种算法的参数。
    AlgorithmParameterGeneratorSpi
    该类定义了 AlgorithmParameterGenerator类的 （ SPI ），用于生成一组要与特定算法一起使用的参数。
    AlgorithmParameters
    此类用作加密参数的不透明表示。
    AlgorithmParametersSpi
    该类为 AlgorithmParameters类定义了 （ SPI ），用于管理算法参数。
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Certificate
    已过时。
    Java平台中创建了一个新的证书处理包。 此证书界面已完全弃用，并在此允许平滑过渡到新软件包。
    CodeSigner
    该类封装了有关代码签名者的信息。
    CodeSource
    该类扩展了代码库的概念，不仅封装了位置（URL），还封装了用于验证源自该位置的签名代码的证书链。
    CryptoPrimitive
    加密原语的枚举。
    DigestException
    这是通用的消息摘要异常。
    DomainCombiner
    A DomainCombiner提供了一种动态更新与当前 AccessControlContext相关联的ProtectionDomains的 AccessControlContext 。
    DrbgParameters.Capability
    DRBG的可重新预测和预测抵抗能力。
    DrbgParameters.Instantiation
    用于实例化的DRBG参数。
    DrbgParameters.NextBytes
    用于随机位生成的DRBG参数。
    DrbgParameters.Reseed
    重新植入的DRBG参数。
    GeneralSecurityException
    GeneralSecurityException类是一种通用安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Identity
    已过时。
    此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
    IdentityScope
    已过时。
    此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
    InvalidAlgorithmParameterException
    这是无效或不合适的算法参数的例外。
    InvalidKeyException
    这是无效键（无效编码，长度错误，未初始化等）的例外。
    InvalidParameterException
    当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。
    Key
    Key界面是所有键的顶级界面。
    KeyException
    这是基本的关键例外。
    KeyFactory
    主要工厂用于将 键 （ Key型的不透明加密密钥）转换成 关键规范 （基础密钥材料的透明表示），反之亦然。
    KeyFactorySpi
    该类定义了 KeyFactory类的 （ SPI ）。
    KeyManagementException
    这是处理密钥管理的所有操作的一般密钥管理例外。
    KeyPair
    这个类是密钥对（一个公钥和一个私钥）的简单持有者。
    KeyPairGenerator
    KeyPairGenerator类用于生成公钥和私钥对。
    KeyPairGeneratorSpi
    该类定义了 KeyPairGenerator类的 （ SPI ），用于生成公钥和私钥对。
    KeyRep.Type
    钥匙类型
    KeyStore
    该类代表加密密钥和证书的存储设备。
    KeyStore.Builder
    要实例化的KeyStore对象的描述。
    KeyStore.Entry
    KeyStore条目类型的标记界面。
    KeyStore.Entry.Attribute
    与密钥库条目关联的属性。
    KeyStore.LoadStoreParameter
    KeyStore load和 store参数的标记界面。
    KeyStore.ProtectionParameter
    用于密钥库保护参数的标记界面。
    KeyStoreException
    这是通用的KeyStore异常。
    KeyStoreSpi
    该类为 KeyStore类定义了 （ SPI ）。
    MessageDigest
    该MessageDigest类为应用程序提供消息摘要算法的功能，如SHA-1或SHA-256。
    MessageDigestSpi
    该类定义了 MessageDigest类的 （ SPI ），它提供消息摘要算法（如MD5或SHA）的功能。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    Permission
    用于表示访问系统资源的抽象类。
    PermissionCollection
    代表Permission对象集合的抽象类。
    Policy
    Policy对象负责确定在Java运行时环境中执行的代码是否具有执行安全敏感操作的权限。
    Policy.Parameters
    这表示Policy参数的标记界面。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
    PrivateKey
    私钥。
    PrivilegedAction
    要启用权限执行的计算。
    PrivilegedActionException
    doPrivileged(PrivilegedExceptionAction)和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context)抛出此异常，表示正在执行的操作会抛出一个已检查的异常。
    PrivilegedExceptionAction
    要启用权限执行的计算，会抛出一个或多个已检查的异常。
    ProtectionDomain
    ProtectionDomain类封装了一个域的特性，该域包含一组类，当代表一组给定的主体执行时，该类的实例被授予一组权限。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
    Provider.Service
    安全服务的描述。
    PublicKey
    公钥
    SecureRandom
    这个类提供了一个密码强的随机数生成器（RNG）。
    SecureRandomParameters
    用于各种 SecureRandom方法的参数的标记界面。
    SecureRandomSpi
    该类定义了SecureRandom类的 （ SPI ）。
    Signature
    Signature类用于向应用程序提供数字签名算法的功能。
    SignatureException
    这是一般的签名异常。
    SignatureSpi
    该类定义了 Signature类的 （ SPI ），用于提供数字签名算法的功能。
    Timestamp
    此类封装了有关已签名时间戳的信息。
    UnrecoverableEntryException
    如果密钥库中的条目无法恢复，则抛出此异常。
    UnrecoverableKeyException
    如果密钥存储库中的密钥无法恢复，则抛出此异常。
  • Classes in java.security used by java.security.acl
    Class 描述
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
  • Classes in java.security used by java.security.cert
    Class 描述
    GeneralSecurityException
    GeneralSecurityException类是一种通用的安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。
    InvalidAlgorithmParameterException
    这是无效或不合适的算法参数的例外。
    InvalidKeyException
    这是无效键（无效编码，长度错误，未初始化等）的例外。
    KeyStore
    该类代表加密密钥和证书的存储设备。
    KeyStoreException
    这是通用的KeyStore异常。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
    PublicKey
    公钥
    SignatureException
    这是一般的签名异常。
  • Classes in java.security used by java.security.interfaces
    Class 描述
    InvalidParameterException
    当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。
    Key
    Key界面是所有键的顶级界面。
    PrivateKey
    私钥。
    PublicKey
    公钥
    SecureRandom
    这个类提供了一个密码强的随机数生成器（RNG）。
  • Classes in java.security used by java.security.spec
    Class 描述
    GeneralSecurityException
    GeneralSecurityException类是一种通用的安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。
  • Classes in java.security used by java.sql
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by java.util
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
    PermissionCollection
    代表Permission对象集合的抽象类。
  • Classes in java.security used by java.util.concurrent
    Class 描述
    PrivilegedAction
    要启用权限执行的计算。
    PrivilegedExceptionAction
    要启用权限执行的计算，会抛出一个或多个已检查的异常。
  • Classes in java.security used by java.util.jar
    Class 描述
    CodeSigner
    该类封装了有关代码签名者的信息。
  • Classes in java.security used by java.util.logging
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by javafx.util
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by javax.crypto
    Class 描述
    AlgorithmParameters
    此类用作加密参数的不透明表示。
    GeneralSecurityException
    GeneralSecurityException类是一种通用的安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。
    InvalidAlgorithmParameterException
    这是无效或不合适的算法参数的例外。
    InvalidKeyException
    这是无效键（无效编码，长度错误，未初始化等）的例外。
    Key
    Key界面是所有键的顶级界面。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
    SecureRandom
    这个类提供了一个密码强的随机数生成器（RNG）。
  • Classes in java.security used by javax.crypto.interfaces
    Class 描述
    Key
    Key界面是所有键的顶级界面。
    PrivateKey
    私钥。
    PublicKey
    公钥
  • Classes in java.security used by javax.crypto.spec
    Class 描述
    InvalidKeyException
    这是无效键（无效编码，长度错误，未初始化等）的例外。
    Key
    Key界面是所有键的顶级界面。
  • Classes in java.security used by javax.management
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
    PermissionCollection
    代表Permission对象集合的抽象类。
  • Classes in java.security used by javax.management.loading
    Class 描述
    SecureClassLoader
    此类扩展了ClassLoader，其额外支持用于定义具有相关代码源和权限的类，默认情况下系统策略将检索该类。
  • Classes in java.security used by javax.management.remote
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
  • Classes in java.security used by javax.net.ssl
    Class 描述
    AlgorithmConstraints
    该接口指定加密算法，密钥（密钥大小）和其他算法参数的约束。
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    InvalidAlgorithmParameterException
    这是无效或不合适的算法参数的例外。
    KeyManagementException
    这是处理密钥管理的所有操作的一般密钥管理例外。
    KeyStore
    该类代表加密密钥和证书的存储设备。
    KeyStore.Builder
    要实例化的KeyStore对象的描述。
    KeyStoreException
    这是通用的KeyStore异常。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    Permission
    用于表示访问系统资源的抽象类。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
    PrivateKey
    私钥。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
    SecureRandom
    这个类提供了一个密码强的随机数生成器（RNG）。
    UnrecoverableKeyException
    如果密钥存储库中的密钥无法恢复，则抛出此异常。
  • Classes in java.security used by javax.security.auth
    Class 描述
    AccessControlContext
    AccessControlContext用于根据其封装的上下文来进行系统资源访问决策。
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    CodeSource
    该类扩展了代码库的概念，不仅封装了位置（URL），还封装了用于验证源自该位置的签名代码的证书链。
    DomainCombiner
    A DomainCombiner提供了一种手段来动态更新与当前 AccessControlContext相关联的ProtectionDomains。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
    PermissionCollection
    代表Permission对象集合的抽象类。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
    PrivilegedAction
    要启用权限执行的计算。
    PrivilegedActionException
    这个异常是由 doPrivileged(PrivilegedExceptionAction)和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context)抛出的，表示正在执行的操作会抛出一个被检查的异常。
    PrivilegedExceptionAction
    要启用权限执行的计算，会抛出一个或多个已检查的异常。
    ProtectionDomain
    ProtectionDomain类封装了一个域的特性，该域包含一组类，当代表一组给定的主体执行时，该类的实例被授予一组权限。
  • Classes in java.security used by javax.security.auth.kerberos
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Key
    Key界面是所有键的顶级界面。
    Permission
    用于表示访问系统资源的抽象类。
    PermissionCollection
    代表Permission对象集合的抽象类。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
  • Classes in java.security used by javax.security.auth.login
    Class 描述
    GeneralSecurityException
    GeneralSecurityException类是一种通用的安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
  • Classes in java.security used by javax.security.auth.x500
    Class 描述
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
    PrivateKey
    私钥。
  • Classes in java.security used by javax.security.cert
    Class 描述
    InvalidKeyException
    这是无效键（无效编码，长度错误，未初始化等）的例外。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
    PublicKey
    公钥
    SignatureException
    这是一般的签名异常。
  • Classes in java.security used by javax.smartcardio
    Class 描述
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    Permission
    用于表示访问系统资源的抽象类。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
  • Classes in java.security used by javax.sound.sampled
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by javax.xml.bind
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by javax.xml.crypto
    Class 描述
    Key
    Key界面是所有键的顶级界面。
  • Classes in java.security used by javax.xml.crypto.dsig
    Class 描述
    InvalidAlgorithmParameterException
    这是无效或不合适的算法参数的例外。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
  • Classes in java.security used by javax.xml.crypto.dsig.dom
    Class 描述
    Key
    Key界面是所有键的顶级界面。
  • Classes in java.security used by javax.xml.crypto.dsig.keyinfo
    Class 描述
    KeyException
    这是基本的关键例外。
    NoSuchProviderException
    当特定安全提供程序被请求但在环境中不可用时抛出此异常。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
    PublicKey
    公钥
  • Classes in java.security used by javax.xml.ws
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
  • Classes in java.security used by javax.xml.ws.spi.http
    Class 描述
    Principal
    该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
  • Classes in java.security used by jdk.net
    Class 描述
    BasicPermission
    BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
    Guard
    该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。
    Permission
    用于表示访问系统资源的抽象类。
  • Classes in java.security used by jdk.security.jarsigner
    Class 描述
    KeyStore.PrivateKeyEntry
    A KeyStore条目，其中包含一个 PrivateKey和相应的证书链。
    NoSuchAlgorithmException
    当请求特定的加密算法但在环境中不可用时抛出此异常。
    PrivateKey
    私钥。
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
  • Classes in java.security used by org.ietf.jgss
    Class 描述
    Provider
    该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Acl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.acl

Interface Acl

  • All Superinterfaces:
    Owner
    已过时。
    自1.2版本以来，该软件包已被java.security.Policy和相关类替代。

    @Deprecated(since="9")
public interface Acl
extends Owner
    接口表示访问控制列表（ACL）。 访问控制列表是用于保护对资源的访问的数据结构。

    ACL可以被认为是具有多个ACL条目的数据结构。 接口类型为AclEntry的每个ACL条目包含与特定主体相关联的一组权限。 （主体代表单个用户或组的实体）。 另外，每个ACL条目被指定为正或负。 如果为正，将授予相关委托人的权限。 如果是否定的，那么权限将被拒绝。

    每个ACL中的ACL条目遵循以下规则：

    • 每个主体最多可以有一个正的ACL条目和一个负条目; 也就是说，对于任何主体，不允许使用多个正或负的ACL条目。 每个条目指定要授予（如果为正）或拒绝（如果为否定）的一组权限。
    • 如果没有特定主体的条目，则认为主体具有空（空）权限集。
    • 如果有一个肯定的条目授予一个委托人一个特定的权限，而一个拒绝主体相同的权限的否定条目，结果就好像这个权限从未被授予或被拒绝。
    • 个人权限总是覆盖个人所属的组的权限。 也就是说，个人的否定权限（特定拒绝权限）会覆盖组的正面权限。 个人积极的权限会覆盖组的负权限。
    java.security.acl包提供了ACL和相关数据结构（ACL条目，组，权限等）的接口。

    java.security.acl.Acl接口扩展了java.security.acl.Owner接口。 所有者界面用于维护每个ACL的所有者列表。 只允许所有者修改ACL。 例如，只有拥有者可以调用ACL的addEntry方法向ACL添加新的ACL条目。

    从以下版本开始：
    1.1
    另请参见：
    AclEntry ， Owner ， getPermissions(java.security.Principal)

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      boolean addEntry​(Principal caller, AclEntry entry)
      已过时。
      向此ACL添加ACL条目。
      boolean checkPermission​(Principal principal, Permission permission)
      已过时。
      检查指定的委托人是否具有指定的权限。
      Enumeration<AclEntry> entries​()
      已过时。
      返回此ACL中条目的枚举。
      String getName​()
      已过时。
      返回此ACL的名称。
      Enumeration<Permission> getPermissions​(Principal user)
      已过时。
      返回指定主体的一组允许权限的枚举（表示一个实体，如个人或组）。
      boolean removeEntry​(Principal caller, AclEntry entry)
      已过时。
      从此ACL中删除ACL条目。
      void setName​(Principal caller, String name)
      已过时。
      设置此ACL的名称。
      String toString​()
      已过时。
      返回ACL内容的字符串表示形式。

      • Methods inherited from interface java.security.acl.Owner

        addOwner, deleteOwner, isOwner

    • 方法详细信息

      • setName

        void setName​(Principal caller,
             String name)
      throws NotOwnerException
        已过时。
        设置此ACL的名称。
        参数
        caller - 调用此方法的主体。 它必须是此ACL的所有者。
        name - 要提供给此ACL的名称。
        异常
        NotOwnerException - 如果调用者主体不是此ACL的所有者。
        另请参见：
        getName()

      • getName

        String getName​()
        已过时。
        返回此ACL的名称。
        结果
        该ACL的名称。
        另请参见：
        setName(java.security.Principal, java.lang.String)

      • addEntry

        boolean addEntry​(Principal caller,
                 AclEntry entry)
          throws NotOwnerException
        已过时。
        向此ACL添加ACL条目。 条目将主体（例如，个人或组）与一组权限相关联。 每个主体最多可以有一个正的ACL条目（指定授予主体的权限）和一个否定的ACL条目（指定要拒绝的权限）。 如果ACL中已经存在相同类型（负或正）的ACL条目，则返回false。
        参数
        caller - 调用此方法的主体。 它必须是此ACL的所有者。
        entry - 要添加到此ACL的ACL条目。
        结果
        在成功时为true，如果同一主体的相同类型（正或负）的条目已经存在于此ACL中，则为false。
        异常
        NotOwnerException - 如果调用者主体不是此ACL的所有者。

      • removeEntry

        boolean removeEntry​(Principal caller,
                    AclEntry entry)
             throws NotOwnerException
        已过时。
        从此ACL中删除ACL条目。
        参数
        caller - 调用此方法的主体。 它必须是此ACL的所有者。
        entry - 要从此ACL删除的ACL条目。
        结果
        成功时为true，如果条目不属于此ACL，则为false。
        异常
        NotOwnerException - 如果调用者主体不是此Acl的所有者。

      • getPermissions

        Enumeration<Permission> getPermissions​(Principal user)
        已过时。
        返回指定主体的一组允许权限的枚举（表示一个实体，如个人或组）。 这组允许的权限计算如下：
        • 如果此访问控制列表中没有指定主体的条目，则返回空的权限集。
        • 否则，确定主体的组权限集。 （主体可以属于一个或多个组，其中组是由组接口表示的一组主体。）组正面权限集合是主体所属的每个组的所有正面权限的并集。 组负权限集是主体所属的每个组的所有负权限的并集。 如果在正面的权限集和负权限集都有一个特定的权限，它将从两者中移除。

          也确定了个人的正面和负面的权限集。 正面的权限集包含主体的正面ACL条目（如果有）中指定的权限。 同样，负权限集包含在主体的负ACL条目（如果有）中指定的权限。 如果此ACL中的主体不存在正（负）ACL条目，那么单个正（或否）权限集将被视为null。

          然后，使用简单规则计算授予主体的权限集，即单个权限始终覆盖组权限。 也就是说，委托人的个人否定权限集（特定拒绝权限）将覆盖组正面权限集，并且主体的单个正面权限集覆盖组负权限集。

        参数
        user - 其权限集将被归还的主体。
        结果
        权限集指定允许主体的权限。

      • entries

        Enumeration<AclEntry> entries​()
        已过时。
        返回此ACL中条目的枚举。 枚举中的每个元素都是AclEntry类型。
        结果
        枚举此ACL中的条目。

      • checkPermission

        boolean checkPermission​(Principal principal,
                        Permission permission)
        已过时。
        检查指定的委托人是否具有指定的权限。 如果是，则返回true，否则返回false。 更具体地说，该方法检查所传递的许可是否是指定主体的允许权限集的成员。 允许权限集由与getPermissions方法使用的算法相同的算法确定。
        参数
        principal - 被认为是有效的认证委托人。
        permission - 有待检查的权限。
        结果
        如果主体具有指定的权限，则为true，否则为false。
        另请参见：
        getPermissions(java.security.Principal)

      • toString

        String toString​()
        已过时。
        返回ACL内容的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of the ACL contents.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AclEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.acl

Interface AclEntry

  • All Superinterfaces:
    Cloneable
    已过时。
    自1.2以来，该软件包已被java.security.Policy及相关课程所取代。

    @Deprecated(since="9")
public interface AclEntry
extends Cloneable
    这是用于表示访问控制列表（ACL）中的一个条目的接口。

    ACL可以被认为是具有多个ACL条目对象的数据结构。 每个ACL条目对象包含与特定主体相关联的一组权限。 （主体代表单个用户或组的实体）。 另外，每个ACL条目被指定为正或负。 如果为正，将授予相关委托人的权限。 如果是否定的，那么权限将被拒绝。 每个主体最多可以有一个正的ACL条目和一个负条目; 也就是说，对于任何主体，不允许使用多个正或负的ACL条目。 注意：ACL条目默认为正。 仅当调用setNegativePermissions方法时，条目才成为否定条目。

    从以下版本开始：
    1.1
    另请参见：
    Acl

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      boolean addPermission​(Permission permission)
      已过时。
      将指定的权限添加到此ACL条目。
      boolean checkPermission​(Permission permission)
      已过时。
      检查指定的权限是否是此条目中权限集的一部分。
      Object clone​()
      已过时。
      克隆此ACL条目。
      Principal getPrincipal​()
      已过时。
      返回此ACL条目授予或拒绝权限的主体。
      boolean isNegative​()
      已过时。
      如果这是一个否定的ACL条目（一个拒绝相关主体的条目中的权限集），则返回true，否则返回false。
      Enumeration<Permission> permissions​()
      已过时。
      返回此ACL条目中权限的枚举。
      boolean removePermission​(Permission permission)
      已过时。
      从此ACL条目中删除指定的权限。
      void setNegativePermissions​()
      已过时。
      将此ACL条目设置为负数。
      boolean setPrincipal​(Principal user)
      已过时。
      指定此ACL条目授予或拒绝权限的主体。
      String toString​()
      已过时。
      返回此ACL条目内容的字符串表示形式。

    • 方法详细信息

      • setPrincipal

        boolean setPrincipal​(Principal user)
        已过时。
        指定此ACL条目授予或拒绝权限的主体。 如果已经为此ACL条目设置了一个主体，则返回false，否则返回true。
        参数
        user - 为此条目设置的主体。
        结果
        如果主体设置为true，则为true，如果已经为此条目设置了一个主体集，则为false。
        另请参见：
        getPrincipal()

      • getPrincipal

        Principal getPrincipal​()
        已过时。
        返回此ACL条目授予或拒绝权限的主体。 如果此条目没有主体集，则返回null。
        结果
        与此条目相关联的主体。
        另请参见：
        setPrincipal(java.security.Principal)

      • setNegativePermissions

        void setNegativePermissions​()
        已过时。
        将此ACL条目设置为负数。 也就是说，关联的主体（例如，用户或组）将被拒绝在条目中指定的权限集。 注意：ACL条目默认为正。 只有在调用此setNegativePermissions方法时，条目才成为否定条目。

      • isNegative

        boolean isNegative​()
        已过时。
        如果这是一个否定的ACL条目（一个拒绝相关主体的条目中的权限集），则返回true，否则返回false。
        结果
        如果这是一个负的ACL条目，则为true，否则为false。

      • addPermission

        boolean addPermission​(Permission permission)
        已过时。
        将指定的权限添加到此ACL条目。 注意：条目可以有多个权限。
        参数
        permission - 与本条目中的主体相关联的权限。
        结果
        如果添加了权限，则为true，如果权限已经是此条目的权限集的一部分，则为false。

      • removePermission

        boolean removePermission​(Permission permission)
        已过时。
        从此ACL条目中删除指定的权限。
        参数
        permission - 从此条目中删除的权限。
        结果
        如果权限被删除，则为true，如果权限不是此条目的权限集的一部分，则为false。

      • checkPermission

        boolean checkPermission​(Permission permission)
        已过时。
        检查指定的权限是否是此条目中权限集的一部分。
        参数
        permission - 有待检查的权限。
        结果
        如果权限是此条目中设置的权限的一部分，则为true，否则为false。

      • permissions

        Enumeration<Permission> permissions​()
        已过时。
        返回此ACL条目中权限的枚举。
        结果
        枚举此ACL条目中的权限。

      • toString

        String toString​()
        已过时。
        返回此ACL条目内容的字符串表示形式。
        重写：
        toString在 Object
        结果
        内容的字符串表示形式。

      • clone

        Object clone​()
        已过时。
        克隆此ACL条目。
        结果
        此ACL条目的克隆。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AclNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.acl

Class AclNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.acl.AclNotFoundException
  • All Implemented Interfaces:
    Serializable
    已过时。
    自1.2版本以来，该软件包已被java.security.Policy和相关课程所取代。

    @Deprecated(since="9")
public class AclNotFoundException
extends 异常
    这是在引用不存在的ACL（访问控制列表）时抛出的异常。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AclNotFoundException​()
      已过时。
      构造一个AclNotFoundException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AclNotFoundException

        public AclNotFoundException​()
        已过时。
        构造一个AclNotFoundException。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Group (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.acl

Interface Group

  • All Superinterfaces:
    Principal
    已过时。
    自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。

    @Deprecated(since="9")
public interface Group
extends Principal
    该界面用于表示一组主体。 （主体代表一个实体，如个人用户或公司）。

    请注意，Group扩展了Principal。 因此，可以将Principal或Group作为参数传递给包含Principal参数的方法。 例如，您可以通过调用对象的addMember方法将其传递给Principal或Group，将Principal或Group添加到Group对象。

    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      boolean addMember​(Principal user)
      已过时。
      将指定的成员添加到组中。
      boolean isMember​(Principal member)
      已过时。
      如果传递的主体是组的成员，则返回true。
      Enumeration<? extends Principal> members​()
      已过时。
      返回组中成员的枚举。
      boolean removeMember​(Principal user)
      已过时。
      从组中删除指定的成员。

      • Methods inherited from interface java.security.Principal

        equals, getName, hashCode, implies, toString

    • 方法详细信息

      • addMember

        boolean addMember​(Principal user)
        已过时。
        将指定的成员添加到组中。
        参数
        user - 添加到此组的主体。
        结果
        如果成员成功添加，则为true，如果委托人已经是会员，则为false。

      • removeMember

        boolean removeMember​(Principal user)
        已过时。
        从组中删除指定的成员。
        参数
        user - 从该组移除的主体。
        结果
        如果委托人被移除，则为真，如果委托人不是会员，则为假。

      • isMember

        boolean isMember​(Principal member)
        已过时。
        如果传递的主体是组的成员，则返回true。 此方法执行递归搜索，因此如果主体属于属于此组成员的组，则返回true。
        参数
        member - 其会员资格将被检查的校长。
        结果
        如果主体是该组的成员，则为true，否则为false。

      • members

        Enumeration<? extends Principal> members​()
        已过时。
        返回组中成员的枚举。 返回的对象可以是Principal或Group（它是Principal的子类）的实例。
        结果
        集团成员的列举。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.security.acl (Java SE 9 & JDK 9 )

java.security.acl

Interfaces

  • Acl
  • AclEntry
  • Group
  • Owner
  • Permission

Exceptions

  • AclNotFoundException
  • LastOwnerException
  • NotOwnerException


java.security.acl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.security.acl

此包中的类和接口已被弃用。 新的类不应该添加到这个包中。 java.security包含合适的替代品。 详见Policy及相关课程。
从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    Acl Deprecated.
    自1.2以来，该软件包已被java.security.Policy及相关课程所取代。
    AclEntry Deprecated.
    自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。
    Group Deprecated.
    自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。
    Owner Deprecated.
    这个包自java.security.Policy以来被替换为java.security.Policy和相关类。
    Permission Deprecated.
    自1.2以来，该软件包已被java.security.Policy及相关课程所取代。
  • 异常摘要
    异常 描述
    AclNotFoundException Deprecated.
    自1.2以来，该软件包已被java.security.Policy及相关类替代。
    LastOwnerException Deprecated.
    自1.2版本以来，该软件包已被java.security.Policy和相关类替代。
    NotOwnerException Deprecated.
    自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.security.acl Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.security.acl

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.security.acl.AclNotFoundException
        • java.security.acl.LastOwnerException
        • java.security.acl.NotOwnerException

Interface Hierarchy

  • java.lang.Cloneable
    • java.security.acl.AclEntry
  • java.security.acl.Owner
    • java.security.acl.Acl
  • java.security.acl.Permission
  • java.security.Principal
    • java.security.acl.Group
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LastOwnerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.acl

Class LastOwnerException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.acl.LastOwnerException
  • All Implemented Interfaces:
    Serializable
    已过时。
    自1.2版本以来，该软件包已被java.security.Policy和相关类替代。

    @Deprecated(since="9")
public class LastOwnerException
extends 异常
    这是在尝试删除访问控制列表的最后一个所有者时抛出的异常。
    从以下版本开始：
    1.1
    另请参见：
    Owner.deleteOwner(java.security.Principal, java.security.Principal) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LastOwnerException​()
      已过时。
      构造一个LastOwnerException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • LastOwnerException

        public LastOwnerException​()
        已过时。
        构造一个LastOwnerException。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NotOwnerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.acl

Class NotOwnerException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.acl.NotOwnerException
  • All Implemented Interfaces:
    Serializable
    已过时。
    自1.2版本以来，该软件包已被java.security.Policy和相关类替代。

    @Deprecated(since="9")
public class NotOwnerException
extends 异常
    这是一个异常，只要对象（如访问控制列表）的修改只允许由对象的所有者完成，但是尝试修改的Principal不是所有者。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NotOwnerException​()
      已过时。
      构造一个NotOwnerException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NotOwnerException

        public NotOwnerException​()
        已过时。
        构造一个NotOwnerException。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Owner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.acl

Interface Owner

  • All Known Subinterfaces:
    Acl
    已过时。
    自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。

    @Deprecated(since="9")
public interface Owner
    用于管理访问控制列表（ACL）或ACL配置的所有者的界面。 （请注意， java.security.acl包中的Acl接口扩展了该Owner接口。）应将初始所有者Principal指定为实现此接口的类的构造函数的参数。
    从以下版本开始：
    1.1
    另请参见：
    Acl

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      boolean addOwner​(Principal caller, Principal owner)
      已过时。
      添加所有者。
      boolean deleteOwner​(Principal caller, Principal owner)
      已过时。
      删除所有者。
      boolean isOwner​(Principal owner)
      已过时。
      如果给定的主体是ACL的所有者，则返回true。

    • 方法详细信息

      • addOwner

        boolean addOwner​(Principal caller,
                 Principal owner)
          throws NotOwnerException
        已过时。
        添加所有者。 只有所有者可以修改ACL内容。 调用主体必须是ACL的所有者才能调用此方法。 也就是说，只有拥有者才能添加其他所有者。 初始所有者在ACL构建时配置。
        参数
        caller - 调用此方法的主体。 它必须是ACL的所有者。
        owner - 应该添加到所有者列表的所有者。
        结果
        如果成功，则为true，如果拥有者已经是所有者，则为false
        异常
        NotOwnerException - 如果调用者主体不是ACL的所有者。

      • deleteOwner

        boolean deleteOwner​(Principal caller,
                    Principal owner)
             throws NotOwnerException,
                    LastOwnerException
        已过时。
        删除所有者。 如果这是ACL中的最后一个所有者，则会引发异常。

        调用主体必须是ACL的所有者才能调用此方法。

        参数
        caller - 调用此方法的主体。 它必须是ACL的所有者。
        owner - 要从所有者列表中删除的所有者。
        结果
        如果所有者被删除，则为真，如果所有者不是所有者列表的一部分，则为false。
        异常
        NotOwnerException - 如果调用者主体不是ACL的所有者。
        LastOwnerException - 如果只有一个所有者，那么deleteOwner将离开ACL拥有者。

      • isOwner

        boolean isOwner​(Principal owner)
        已过时。
        如果给定的主体是ACL的所有者，则返回true。
        参数
        owner - 要检查的主体以确定其是否为所有者。
        结果
        如果通过的委托人在所有者名单中，则为真，否则为false。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Permission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.acl

Interface Permission

  • 已过时。
    自1.2以来，这个软件包已经被java.security.Policy和相关的类替代了。

    @Deprecated(since="9")
public interface Permission
    此接口表示一个权限，例如用于授予对资源的特定类型访问权限的权限。
    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(Object another)
      已过时。
      如果传递的对象匹配此接口中表示的权限，则返回true。
      String toString​()
      已过时。
      打印此权限的字符串表示形式。

    • 方法详细信息

      • equals

        boolean equals​(Object another)
        已过时。
        如果传递的对象匹配此接口中表示的权限，则返回true。
        重写：
        equals在 Object
        参数
        another - 与...进行比较的权限对象。
        结果
        如果Permission对象相等则为true，否则为false
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        String toString​()
        已过时。
        打印此权限的字符串表示形式。
        重写：
        toString在 Object
        结果
        字符串表示的权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.security.acl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.security.acl

  • Packages that use java.security.acl
    软件包 描述
    java.security.acl
    此包中的类和接口已被弃用。
  • Classes in java.security.acl used by java.security.acl
    Class 描述
    AclEntry
    已过时。
    自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。
    LastOwnerException
    已过时。
    自1.2以来，该软件包已被java.security.Policy和相关类替代。
    NotOwnerException
    已过时。
    自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。
    Owner
    已过时。
    自1.2版本以来，该软件包已被java.security.Policy和相关类替代。
    Permission
    已过时。
    自1.2以来，这个软件包已经被java.security.Policy和相关的类替代了。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.acl.AclNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.acl.AclNotFoundException

No usage of java.security.acl.AclNotFoundException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.acl.LastOwnerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.acl.LastOwnerException

  • Packages that use LastOwnerException
    软件包 描述
    java.security.acl
    此包中的类和接口已被弃用。

    • Uses of LastOwnerException in java.security.acl

      Methods in java.security.acl that throw LastOwnerException
      Modifier and Type 方法 描述
      boolean Owner.deleteOwner​(Principal caller, Principal owner)
      已过时。
      删除所有者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.acl.NotOwnerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.acl.NotOwnerException

  • Packages that use NotOwnerException
    软件包 描述
    java.security.acl
    此包中的类和接口已被弃用。

    • Uses of NotOwnerException in java.security.acl

      Methods in java.security.acl that throw NotOwnerException
      Modifier and Type 方法 描述
      boolean Acl.addEntry​(Principal caller, AclEntry entry)
      已过时。
      向此ACL添加ACL条目。
      boolean Owner.addOwner​(Principal caller, Principal owner)
      已过时。
      添加所有者。
      boolean Owner.deleteOwner​(Principal caller, Principal owner)
      已过时。
      删除所有者。
      boolean Acl.removeEntry​(Principal caller, AclEntry entry)
      已过时。
      从此ACL中删除ACL条目。
      void Acl.setName​(Principal caller, String name)
      已过时。
      设置此ACL的名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.acl.Acl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.acl.Acl

No usage of java.security.acl.Acl
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.acl.AclEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.acl.AclEntry

  • Packages that use AclEntry
    软件包 描述
    java.security.acl
    此包中的类和接口已被弃用。

    • Uses of AclEntry in java.security.acl

      Methods in java.security.acl that return types with arguments of type AclEntry
      Modifier and Type 方法 描述
      Enumeration<AclEntry> Acl.entries​()
      已过时。
      返回此ACL中条目的枚举。
      Methods in java.security.acl with parameters of type AclEntry
      Modifier and Type 方法 描述
      boolean Acl.addEntry​(Principal caller, AclEntry entry)
      已过时。
      向此ACL添加ACL条目。
      boolean Acl.removeEntry​(Principal caller, AclEntry entry)
      已过时。
      Removes an ACL entry from this ACL.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.acl.Group (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.acl.Group

No usage of java.security.acl.Group
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.acl.Owner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.acl.Owner

  • Packages that use Owner
    软件包 描述
    java.security.acl
    此包中的类和接口已被弃用。

    • Uses of Owner in java.security.acl

      Subinterfaces of Owner in java.security.acl
      Modifier and Type 接口 描述
      interface  Acl
      已过时。
      自1.2以来，该软件包已被java.security.Policy及相关课程所取代。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.acl.Permission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.acl.Permission

  • Packages that use Permission
    软件包 描述
    java.security.acl
    此包中的类和接口已被弃用。

    • Uses of Permission in java.security.acl

      Methods in java.security.acl that return types with arguments of type Permission
      Modifier and Type 方法 描述
      Enumeration<Permission> Acl.getPermissions​(Principal user)
      已过时。
      返回指定主体的一组允许权限的枚举（表示一个实体，如个人或组）。
      Enumeration<Permission> AclEntry.permissions​()
      已过时。
      返回此ACL条目中权限的枚举。
      Methods in java.security.acl with parameters of type Permission
      Modifier and Type 方法 描述
      boolean AclEntry.addPermission​(Permission permission)
      已过时。
      将指定的权限添加到此ACL条目。
      boolean Acl.checkPermission​(Principal principal, Permission permission)
      已过时。
      检查指定的委托人是否具有指定的权限。
      boolean AclEntry.checkPermission​(Permission permission)
      已过时。
      检查指定的权限是否是此条目中权限集的一部分。
      boolean AclEntry.removePermission​(Permission permission)
      已过时。
      Removes the specified permission from this ACL entry.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Certificate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class Certificate

  • java.lang.Object
    • java.security.cert.Certificate
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    X509Certificate

    public abstract class Certificate
extends Object
implements Serializable

    用于管理各种身份证件的抽象类。 身份证明书是一个委托人与另一个委托人提供的公钥的绑定。 （主体代表一个实体，如个人用户，一个团体或一个公司）。

    该类是具有不同格式但重要常见用途的证书的抽象。 例如，不同类型的证书（如X.509和PGP）共享一般证书功能（如编码和验证）以及某些类型的信息（如公钥）。

    X.509，PGP和SDSI证书都可以通过对证书类进行子类化来实现，即使它们包含不同的信息集，并且以不同的方式存储和检索信息。

    从以下版本开始：
    1.2
    另请参见：
    X509Certificate ， CertificateFactory ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected static class  Certificate.CertificateRep
      用于序列化的替代证书类。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Certificate​(String type)
      创建指定类型的证书。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object other)
      将此证书与指定的对象进行比较。
      abstract byte[] getEncoded​()
      返回此证书的编码形式。
      abstract PublicKey getPublicKey​()
      从此证书获取公钥。
      String getType​()
      返回此证书的类型。
      int hashCode​()
      从其编码形式返回此证书的哈希码值。
      abstract String toString​()
      返回此证书的字符串表示形式。
      abstract void verify​(PublicKey key)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void verify​(PublicKey key, String sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      protected Object writeReplace​()
      更换要序列化的证书。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Certificate

        protected Certificate​(String type)
        创建指定类型的证书。
        参数
        type - 证书类型的标准名称。 有关标准证书类型的信息，请参阅Java Security Standard Algorithm Names Specification中的CertificateFactory部分。

    • 方法详细信息

      • getType

        public final String getType​()
        返回此证书的类型。
        结果
        该证书的类型。

      • equals

        public boolean equals​(Object other)
        将此证书与指定的对象进行比较。 如果other对象是instanceof Certificate ，则其编码形式将被检索并与该证书的编码形式进行比较。
        重写：
        equals在 Object
        参数
        other - 要与此证书相等的对象。
        结果
        如果两个证书的编码形式匹配，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        从其编码形式返回此证书的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getEncoded

        public abstract byte[] getEncoded​()
                           throws CertificateEncodingException
        返回此证书的编码形式。 假设每个证书类型将只有一种形式的编码; 例如，X.509证书将被编码为ASN.1 DER。
        结果
        该证书的编码形式
        异常
        CertificateEncodingException - 如果发生编码错误。

      • verify

        public abstract void verify​(PublicKey key)
                     throws CertificateException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
        使用与指定公钥对应的私钥验证此证书是否已经签名。
        参数
        key - 用于执行验证的PublicKey。
        异常
        NoSuchAlgorithmException - 不支持的签名算法。
        InvalidKeyException - 键错误。
        NoSuchProviderException - 如果没有默认提供程序。
        SignatureException - 签名错误。
        CertificateException - 编码错误。

      • verify

        public abstract void verify​(PublicKey key,
                            String sigProvider)
                     throws CertificateException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
        使用与指定公钥对应的私钥验证此证书是否已经签名。 此方法使用指定提供商提供的签名验证引擎。
        参数
        key - 用于执行验证的PublicKey。
        sigProvider - 签名提供者的名称。
        异常
        NoSuchAlgorithmException - 关于不支持的签名算法。
        InvalidKeyException - 键错误。
        NoSuchProviderException - 不正确的提供者。
        SignatureException - 签名错误。
        CertificateException - 关于编码错误。

      • verify

        public void verify​(PublicKey key,
                   Provider sigProvider)
            throws CertificateException,
                   NoSuchAlgorithmException,
                   InvalidKeyException,
                   SignatureException
        使用与指定公钥对应的私钥验证此证书是否已经签名。 此方法使用指定提供商提供的签名验证引擎。 请注意，指定的Provider对象不必在提供者列表中注册。

        该方法被添加到Java Platform Standard Edition的1.8版本。 为了保持与现有服务提供商的向后兼容性，此方法不能为abstract ，默认情况下会抛出一个UnsupportedOperationException 。

        参数
        key - 用于执行验证的PublicKey。
        sigProvider - 签名提供者。
        异常
        NoSuchAlgorithmException - 不支持的签名算法。
        InvalidKeyException - 键错误。
        SignatureException - 签名错误。
        CertificateException - 编码错误。
        UnsupportedOperationException - 如果不支持该方法
        从以下版本开始：
        1.8

      • toString

        public abstract String toString​()
        返回此证书的字符串表示形式。
        重写：
        toString在类 Object
        结果
        此证书的字符串表示形式。

      • getPublicKey

        public abstract PublicKey getPublicKey​()
        从此证书获取公钥。
        结果
        公钥。

      • writeReplace

        protected Object writeReplace​()
                       throws ObjectStreamException
        更换要序列化的证书。
        结果
        要序列化的备用证书对象
        异常
        ObjectStreamException - 如果无法创建表示此证书的新对象
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Certificate.CertificateRep (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class Certificate.CertificateRep

  • java.lang.Object
    • java.security.cert.Certificate.CertificateRep
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    Certificate

    protected static class Certificate.CertificateRep
extends Object
implements Serializable
    用于序列化的替代证书类。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CertificateRep​(String type, byte[] data)
      使用证书类型和证书编码字节构造备用证书类。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Object readResolve​()
      解决证书对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertificateRep

        protected CertificateRep​(String type,
                         byte[] data)
        使用证书类型和证书编码字节构造备用证书类。
        参数
        type - 证书类型的标准名称。
        data - 证书资料。

    • 方法详细信息

      • readResolve

        protected Object readResolve​()
                      throws ObjectStreamException
        解决证书对象。
        结果
        已解决的证书对象
        异常
        ObjectStreamException - if the Certificate could not be resolved
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertificateEncodingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertificateEncodingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateEncodingException
  • All Implemented Interfaces:
    Serializable

    public class CertificateEncodingException
extends CertificateException
    证书编码异常。 当尝试对证书进行编码时发生错误时，将抛出此错误。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertificateEncodingException​()
      构造一个没有详细消息的CertificateEncodingException。
      CertificateEncodingException​(String message)
      构造具有指定详细消息的CertificateEncodingException。
      CertificateEncodingException​(String message, Throwable cause)
      创建一个 CertificateEncodingException与指定的详细信息和原因。
      CertificateEncodingException​(Throwable cause)
      创建 CertificateEncodingException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CertificateEncodingException

        public CertificateEncodingException​()
        构造一个没有详细消息的CertificateEncodingException。 详细消息是描述此特定异常的字符串。

      • CertificateEncodingException

        public CertificateEncodingException​(String message)
        构造具有指定详细消息的CertificateEncodingException。 详细消息是描述此特定异常的字符串。
        参数
        message - 详细信息。

      • CertificateEncodingException

        public CertificateEncodingException​(String message,
                                    Throwable cause)
        创建一个 CertificateEncodingException具有指定的详细信息和原因。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null允许值，表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • CertificateEncodingException

        public CertificateEncodingException​(Throwable cause)
        创建 CertificateEncodingException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertificateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertificateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertificateException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    CertificateEncodingException ， CertificateExpiredException ， CertificateNotYetValidException ， CertificateParsingException ， CertificateRevokedException

    public class CertificateException
extends GeneralSecurityException
    此异常表示各种证书问题之一。
    从以下版本开始：
    1.2
    另请参见：
    Certificate ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertificateException​()
      构造一个没有详细消息的证书异常。
      CertificateException​(String msg)
      使用给定的详细消息构造证书异常。
      CertificateException​(String message, Throwable cause)
      创建一个 CertificateException与指定的详细信息和原因。
      CertificateException​(Throwable cause)
      创建 CertificateException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CertificateException

        public CertificateException​()
        构造一个没有详细消息的证书异常。 详细消息是描述此特定异常的字符串。

      • CertificateException

        public CertificateException​(String msg)
        使用给定的详细消息构造证书异常。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。

      • CertificateException

        public CertificateException​(String message,
                            Throwable cause)
        创建一个 CertificateException与指定的详细信息和原因。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • CertificateException

        public CertificateException​(Throwable cause)
        创建 CertificateException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （允许A null值，表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertificateExpiredException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertificateExpiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateExpiredException
  • All Implemented Interfaces:
    Serializable

    public class CertificateExpiredException
extends CertificateException
    证书过期例外 只要当前的Date或指定的Date是在证书的有效期内指定的notAfter日期/时间之后notAfter的。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertificateExpiredException​()
      构造一个没有详细消息的CertificateExpiredException。
      CertificateExpiredException​(String message)
      构造具有指定详细消息的CertificateExpiredException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CertificateExpiredException

        public CertificateExpiredException​()
        构造一个没有详细消息的CertificateExpiredException。 详细消息是描述此特定异常的字符串。

      • CertificateExpiredException

        public CertificateExpiredException​(String message)
        构造具有指定详细消息的CertificateExpiredException。 详细消息是描述此特定异常的字符串。
        参数
        message - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertificateFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertificateFactory

  • java.lang.Object
    • java.security.cert.CertificateFactory

  • public class CertificateFactory
extends Object
    该类定义了证书工厂的功能，用于从其编码生成证书，认证路径（ CertPath ）和证书吊销列表（CRL）对象。

    对于由多个证书组成的编码，当您要解析可能不相关证书的集合时，请使用generateCertificates 。 否则，使用generateCertPath当你想生成CertPath （证书链）并随后与验证它CertPathValidator 。

    对于X.509证书工厂必须返回是一个实例证明java.security.cert.X509Certificate这是一个实例，和CRL java.security.cert.X509CRL 。

    以下示例读取具有Base64编码证书的文件，每个文件的开头由----- BEGIN CERTIFICATE -----限制，最后由----- END CERTIFICATE ----- 。 我们将FileInputStream （不支持mark和reset ）转换为BufferedInputStream （支持这些方法），因此每次调用generateCertificate仅消耗一个证书，并且输入流的读取位置位于下一个证书中文件：

       FileInputStream fis = new FileInputStream(filename); BufferedInputStream bis = new BufferedInputStream(fis); CertificateFactory cf = CertificateFactory.getInstance("X.509"); while (bis.available() > 0) { Certificate cert = cf.generateCertificate(bis); System.out.println(cert.toString()); }

    以下示例解析存储在文件中的PKCS＃7格式的证书答复，并从中提取所有证书：

      FileInputStream fis = new FileInputStream(filename);
 CertificateFactory cf = CertificateFactory.getInstance("X.509");
 Collection c = cf.generateCertificates(fis);
 Iterator i = c.iterator();
 while (i.hasNext()) {
    Certificate cert = (Certificate)i.next();
    System.out.println(cert);
 }

    Java平台的每个实现都需要支持以下标准CertificateFactory类型：

    • X.509
    和以下标准CertPath编码：
    • PKCS7
    • PkiPath
    类型和编码在Java安全标准算法名称规范的CertificateFactory section和CertPath Encodings section中进行了描述。 请参阅实施的发行文档，以查看是否支持其他类型或编码。
    从以下版本开始：
    1.2
    另请参见：
    Certificate ， X509Certificate ， CertPath ， CRL ， X509CRL

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CertificateFactory​(CertificateFactorySpi certFacSpi, Provider provider, String type)
      创建给定类型的CertificateFactory对象，并将给定的提供者实现（SPI对象）封装在其中。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Certificate generateCertificate​(InputStream inStream)
      生成证书对象，并使用从输入流 inStream读取的数据进行初始化。
      Collection<? extends Certificate> generateCertificates​(InputStream inStream)
      返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
      CertPath generateCertPath​(InputStream inStream)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath generateCertPath​(InputStream inStream, String encoding)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath generateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并使用 List的 Certificate初始化它。
      CRL generateCRL​(InputStream inStream)
      生成证书吊销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。
      Collection<? extends CRL> generateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。
      Iterator<String> getCertPathEncodings​()
      返回此证书工厂支持的 CertPath编码的迭代，首先使用默认编码。
      static CertificateFactory getInstance​(String type)
      返回实现指定证书类型的证书工厂对象。
      static CertificateFactory getInstance​(String type, String provider)
      返回指定证书类型的证书工厂对象。
      static CertificateFactory getInstance​(String type, Provider provider)
      返回指定证书类型的证书工厂对象。
      Provider getProvider​()
      返回此证书工厂的提供者。
      String getType​()
      返回与该证书工厂相关联的证书类型的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertificateFactory

        protected CertificateFactory​(CertificateFactorySpi certFacSpi,
                             Provider provider,
                             String type)
        创建给定类型的CertificateFactory对象，并将给定的提供者实现（SPI对象）封装在其中。
        参数
        certFacSpi - 提供商实现。
        provider - 提供商。
        type - 证书类型。

    • 方法详细信息

      • getInstance

        public static final CertificateFactory getInstance​(String type)
                                            throws CertificateException
        返回实现指定证书类型的证书工厂对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定类型的第一个Provider中封装CertificateFactorySpi实现的新CertificateFactory对象。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        type - 请求的证书类型的名称。 有关标准证书类型的信息，请参阅Java Security Standard Algorithm Names Specification中的CertificateFactory部分。
        结果
        指定类型的证书工厂对象
        异常
        CertificateException - 如果否 Provider支持指定类型的 CertificateFactorySpi实现
        NullPointerException - 如果 type是 null
        另请参见：
        Provider

      • getInstance

        public static final CertificateFactory getInstance​(String type,
                                                   String provider)
                                            throws CertificateException,
                                                   NoSuchProviderException
        返回指定证书类型的证书工厂对象。

        返回从指定提供程序封装CertificateFactorySpi实现的新CertificateFactory对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        参数
        type - 证书类型。 有关标准证书类型的信息，请参阅Java Security Standard Algorithm Names Specification中的CertificateFactory部分。
        provider - 提供商的名称。
        结果
        指定类型的证书工厂对象
        异常
        CertificateException - 如果指定算法的 CertificateFactorySpi实现不能从指定的提供者获得
        IllegalArgumentException - 如果提供商名称为 null或为空
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 type是 null
        另请参见：
        Provider

      • getInstance

        public static final CertificateFactory getInstance​(String type,
                                                   Provider provider)
                                            throws CertificateException
        返回指定证书类型的证书工厂对象。

        返回从指定的Provider对象封装CertificateFactorySpi实现的新CertificateFactory对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        type - 证书类型。 有关标准证书类型的信息，请参阅Java Security Standard Algorithm Names Specification中的CertificateFactory部分。
        provider - 提供商。
        结果
        指定类型的证书工厂对象
        异常
        CertificateException - 如果指定的算法的 CertificateFactorySpi实现不能从指定的 Provider对象获得
        IllegalArgumentException - 如果 provider是 null
        NullPointerException - 如果 type是 null
        从以下版本开始：
        1.4
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此证书工厂的提供者。
        结果
        该证书工厂的提供者。

      • getType

        public final String getType​()
        返回与该证书工厂相关联的证书类型的名称。
        结果
        与此证书工厂关联的证书类型的名称。

      • generateCertificate

        public final Certificate generateCertificate​(InputStream inStream)
                                      throws CertificateException
        生成证书对象，并使用从输入流inStream读取的数据进行初始化。

        为了利用此证书工厂支持的特殊证书格式，返回的证书对象可以类型转换为相应的证书类。 例如，如果此证书工厂实施X.509证书，则返回的证书对象可以类型转换为X509Certificate类。

        在X.509证书的证书工厂的情况下， inStream提供的证书必须是DER编码的，并且可以以二进制或可打印（Base64）编码提供。 如果证书是以Base64编码方式提供的，则必须以----- BEGIN CERTIFICATE -----开头为边界，并且必须在----- END CERTIFICATE ----- 。

        请注意，如果给定的输入流不支持mark和reset ，则此方法将消耗整个输入流。 否则，对该方法的每次调用都会消耗一个证书，并且输入流的读取位置位于固有的证书结束标记之后的下一个可用字节。 如果输入流中的数据不包含固有的证书结束标记（EOF除外），并且在证书解析后存在尾随数据，则抛出CertificateException 。

        参数
        inStream - 具有证书数据的输入流。
        结果
        用来自输入流的数据初始化的证书对象。
        异常
        CertificateException - 解析错误。

      • getCertPathEncodings

        public final Iterator<String> getCertPathEncodings​()
        返回此证书工厂支持的CertPath编码的迭代，首先使用默认编码。 有关标准编码名称及其格式的信息，请参阅Java Security Standard Algorithm Names Specification中的CertPath编码部分。

        尝试通过其remove方法修改返回的Iterator导致一个UnsupportedOperationException 。

        结果
        一个 Iterator的支持的 CertPath编码的名称（作为 String ）
        从以下版本开始：
        1.4

      • generateCertPath

        public final CertPath generateCertPath​(InputStream inStream)
                                throws CertificateException
        生成一个CertPath对象，并使用从InputStream inStream读取的数据进行初始化。 数据假定为默认编码。 默认编码的名称是的第一个元素Iterator由返回getCertPathEncodings方法。
        参数
        inStream - 包含数据的 InputStream
        结果
        一个 CertPath从与所述数据初始化 InputStream
        异常
        CertificateException - 解码时是否发生异常
        从以下版本开始：
        1.4

      • generateCertPath

        public final CertPath generateCertPath​(InputStream inStream,
                                       String encoding)
                                throws CertificateException
        生成一个CertPath对象，并使用从InputStream inStream读取的数据进行初始化。 数据假定为指定的编码。 有关标准编码名称及其格式的信息，请参阅Java Security Standard Algorithm Names Specification中的CertPath编码部分。
        参数
        inStream - 包含数据的 InputStream
        encoding - 用于数据的编码
        结果
        一个 CertPath初始化的数据来自 InputStream
        异常
        CertificateException - 如果在解码或请求的编码不支持时发生异常
        从以下版本开始：
        1.4

      • generateCertPath

        public final CertPath generateCertPath​(List<? extends Certificate> certificates)
                                throws CertificateException
        生成一个CertPath对象，并使用List的Certificate初始化它。

        提供的证书必须是CertificateFactory支持的类型。 他们将被拷贝出来的List对象。

        参数
        certificates - a List of Certificate s
        结果
        一个 CertPath用提供的证书列表初始化
        异常
        CertificateException - 如果发生异常
        从以下版本开始：
        1.4

      • generateCertificates

        public final Collection<? extends Certificate> generateCertificates​(InputStream inStream)
                                                             throws CertificateException
        返回从给定输入流inStream读取的证书的（可能为空的）集合视图。

        为了利用此证书工厂支持的特殊证书格式，返回的集合视图中的每个元素都可以类型转换为相应的证书类。 例如，如果此证书工厂实施X.509证书，则返回的集合中的元素可以类型转换为X509Certificate类。

        在X.509证书的证书工厂的情况下， inStream可能包含以generateCertificate描述的格式的DER编码证书序列。 另外， inStream可能包含PKCS＃7证书链。 这是一个PKCS＃7 SignedData对象，唯一有效的字段是证书 。 特别地，签名和内容被忽略。 此格式允许一次下载多个证书。 如果没有证书，则返回空集合。

        请注意，如果给定的输入流不支持mark和reset ，则此方法将消耗整个输入流。

        参数
        inStream - 具有证书的输入流。
        结果
        使用来自输入流的数据初始化的java.security.cert.Certificate对象的（可能为空的）集合视图。
        异常
        CertificateException - 解析错误。

      • generateCRL

        public final CRL generateCRL​(InputStream inStream)
                      throws CRLException
        生成证书吊销列表（CRL）对象，并使用从输入流inStream读取的数据进行初始化。

        为了利用此证书工厂支持的专用CRL格式，返回的CRL对象可以类型转换为相应的CRL类。 例如，如果此证书工厂实现X.509 CRL，则返回的CRL对象可以类型转换为X509CRL类。

        请注意，如果给定的输入流不支持mark和reset ，则此方法将消耗整个输入流。 否则，对该方法的每次调用都会消耗一个CRL，并且输入流的读取位置位于固有的CRL结束标记之后的下一个可用字节。 如果输入流中的数据不包含固有的CRL结束标记（EOF除外），并且在解析CRL之后存在尾随数据，则抛出CRLException 。

        参数
        inStream - 具有CRL数据的输入流。
        结果
        用输入流中的数据初始化一个CRL对象。
        异常
        CRLException - 解析错误。

      • generateCRLs

        public final Collection<? extends CRL> generateCRLs​(InputStream inStream)
                                             throws CRLException
        返回从给定输入流inStream读取的CRL的（可能为空的）集合视图。

        为了利用此证书工厂支持的专用CRL格式，返回的集合视图中的每个元素都可以类型转换为相应的CRL类。 例如，如果此证书工厂实现X.509 CRL，则返回的集合中的元素可以类型为X509CRL类。

        在X.509 CRL的证书工厂的情况下， inStream可能包含一系列DER编码的CRL。 另外， inStream可能包含PKCS＃7 CRL集。 这是一个PKCS＃7 SignedData对象，唯一有效的字段是crls 。 特别地，签名和内容被忽略。 此格式允许一次下载多个CRL。 如果没有CRL，则返回一个空的集合。

        请注意，如果给定的输入流不支持mark和reset ，则此方法将消耗整个输入流。

        参数
        inStream - 具有CRL的输入流。
        结果
        使用来自输入流的数据初始化的java.security.cert.CRL对象的（可能为空的）集合视图。
        异常
        CRLException - on parsing errors.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertificateFactorySpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertificateFactorySpi

  • java.lang.Object
    • java.security.cert.CertificateFactorySpi

  • public abstract class CertificateFactorySpi
extends Object
    该类定义了CertificateFactory类的 （ SPI ）。 该类中的所有抽象方法必须由希望为特定证书类型（例如X.509）提供证书工厂的实现的每个加密服务提供商实现。

    证书工厂用于从其编码生成证书，认证路径（ CertPath ）和证书撤销列表（CRL）对象。

    对于X.509证书工厂必须返回是一个实例证明java.security.cert.X509Certificate这是一个实例，和CRL java.security.cert.X509CRL 。

    从以下版本开始：
    1.2
    另请参见：
    CertificateFactory ， Certificate ， X509Certificate ， CertPath ， CRL ， X509CRL

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertificateFactorySpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Certificate engineGenerateCertificate​(InputStream inStream)
      生成证书对象，并使用从输入流 inStream读取的数据进行初始化。
      abstract Collection<? extends Certificate> engineGenerateCertificates​(InputStream inStream)
      返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
      CertPath engineGenerateCertPath​(InputStream inStream)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath engineGenerateCertPath​(InputStream inStream, String encoding)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath engineGenerateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并使用 List的 Certificate初始化它。
      abstract CRL engineGenerateCRL​(InputStream inStream)
      生成证书吊销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。
      abstract Collection<? extends CRL> engineGenerateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。
      Iterator<String> engineGetCertPathEncodings​()
      返回此证书工厂支持的 CertPath编码的迭代，首先使用默认编码。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertificateFactorySpi

        public CertificateFactorySpi​()

    • 方法详细信息

      • engineGenerateCertificate

        public abstract Certificate engineGenerateCertificate​(InputStream inStream)
                                               throws CertificateException
        生成证书对象，并使用从输入流inStream读取的数据进行初始化。

        为了利用此证书工厂支持的特殊证书格式，返回的证书对象可以类型转换为相应的证书类。 例如，如果此证书工厂实现X.509证书，则返回的证书对象可以类型转换为X509Certificate类。

        在X.509证书的证书工厂的情况下， inStream提供的证书必须是DER编码的，并且可以以二进制或可打印（Base64）编码方式提供。 如果证书是以Base64编码方式提供的，则必须以----- BEGIN CERTIFICATE -----开头为边界，并且必须在----- END CERTIFICATE ----- 。

        请注意，如果给定的输入流不支持mark和reset ，则此方法将消耗整个输入流。 否则，对该方法的每次调用都会消耗一个证书，并且输入流的读取位置位于固有的证书结束标记之后的下一个可用字节。 如果输入流中的数据不包含固有的证书结束标记（EOF除外），并且在证书被解析后存在尾随数据，则抛出一个CertificateException 。

        参数
        inStream - 具有证书数据的输入流。
        结果
        用来自输入流的数据初始化的证书对象。
        异常
        CertificateException - 解析错误。

      • engineGenerateCertPath

        public CertPath engineGenerateCertPath​(InputStream inStream)
                                throws CertificateException
        生成一个CertPath对象，并使用从InputStream inStream读取的数据进行初始化。 数据假定为默认编码。

        该方法被添加到Java 2平台标准版的1.4版本。 为了保持与现有服务提供商的向后兼容性，此方法不能为abstract ，默认情况下会抛出UnsupportedOperationException 。

        参数
        inStream - 包含数据的 InputStream
        结果
        一个 CertPath初始化的数据来自 InputStream
        异常
        CertificateException - 解码时是否发生异常
        UnsupportedOperationException - 如果不支持该方法
        从以下版本开始：
        1.4

      • engineGenerateCertPath

        public CertPath engineGenerateCertPath​(InputStream inStream,
                                       String encoding)
                                throws CertificateException
        生成一个CertPath对象，并使用从InputStream inStream读取的数据进行初始化。 数据假定为指定的编码。

        该方法被添加到Java 2平台标准版的1.4版本。 为了保持与现有服务提供商的向后兼容性，此方法不能为abstract ，默认情况下会抛出一个UnsupportedOperationException 。

        参数
        inStream - 包含数据的 InputStream
        encoding - 用于数据的编码
        结果
        一个 CertPath从与所述数据初始化 InputStream
        异常
        CertificateException - 如果在解码或请求的编码不支持时发生异常
        UnsupportedOperationException - 如果不支持该方法
        从以下版本开始：
        1.4

      • engineGenerateCertPath

        public CertPath engineGenerateCertPath​(List<? extends Certificate> certificates)
                                throws CertificateException
        生成一个CertPath对象，并使用List的Certificate初始化。

        提供的证书必须是CertificateFactory支持的类型。 他们将被复制出来的List对象。

        该方法被添加到Java 2平台标准版的1.4版本。 为了保持与现有服务提供商的向后兼容性，此方法不能为abstract ，默认情况下会抛出一个UnsupportedOperationException 。

        参数
        certificates - a List的 Certificate s
        结果
        一个 CertPath用提供的证书列表初始化
        异常
        CertificateException - 如果发生异常
        UnsupportedOperationException - 如果不支持该方法
        从以下版本开始：
        1.4

      • engineGetCertPathEncodings

        public Iterator<String> engineGetCertPathEncodings​()
        返回此证书工厂支持的CertPath编码的迭代，首先使用默认编码。 有关标准编码名称的信息，请参阅Java Security Standard Algorithm Names Specification中的CertPath编码部分。

        尝试通过其remove方法修改返回的Iterator产生一个UnsupportedOperationException 。

        该方法被添加到Java 2平台标准版的1.4版本。 为了保持与现有服务提供商的向后兼容性，此方法不能为abstract ，默认情况下会抛出一个UnsupportedOperationException 。

        结果
        一个 Iterator的支持的 CertPath编码的名称（如 String ）
        异常
        UnsupportedOperationException - 如果不支持该方法
        从以下版本开始：
        1.4

      • engineGenerateCertificates

        public abstract Collection<? extends Certificate> engineGenerateCertificates​(InputStream inStream)
                                                                      throws CertificateException
        返回从给定输入流inStream读取的证书的（可能为空的）集合视图。

        为了利用此证书工厂支持的特殊证书格式，返回的集合视图中的每个元素都可以类型转换为相应的证书类。 例如，如果此证书工厂实施X.509证书，则返回的集合中的元素可以类型转换为X509Certificate类。

        在X.509证书的证书工厂的情况下， inStream可能包含以generateCertificate描述的格式的单个DER编码证书。 另外， inStream可能包含PKCS＃7证书链。 这是一个PKCS＃7 SignedData对象，唯一有效的字段是证书 。 特别地，签名和内容被忽略。 此格式允许一次下载多个证书。 如果没有证书，则返回空集合。

        请注意，如果给定的输入流不支持mark和reset ，则此方法将消耗整个输入流。

        参数
        inStream - 具有证书的输入流。
        结果
        使用来自输入流的数据初始化的java.security.cert.Certificate对象的（可能为空的）集合视图。
        异常
        CertificateException - 解析错误。

      • engineGenerateCRL

        public abstract CRL engineGenerateCRL​(InputStream inStream)
                               throws CRLException
        生成证书吊销列表（CRL）对象，并使用从输入流inStream读取的数据进行初始化。

        为了利用此证书工厂支持的专用CRL格式，返回的CRL对象可以类型转换为相应的CRL类。 例如，如果此证书工厂实现X.509 CRL，则返回的CRL对象可以类型转换为X509CRL类。

        请注意，如果给定的输入流不支持mark和reset ，则此方法将消耗整个输入流。 否则，对该方法的每次调用都会消耗一个CRL，并且输入流的读取位置位于固有的CRL结束标记之后的下一个可用字节。 如果输入流中的数据不包含固有的CRL结束标记（EOF除外），并且在解析CRL后存在尾随数据，则抛出CRLException 。

        参数
        inStream - 具有CRL数据的输入流。
        结果
        用输入流中的数据初始化一个CRL对象。
        异常
        CRLException - 解析错误。

      • engineGenerateCRLs

        public abstract Collection<? extends CRL> engineGenerateCRLs​(InputStream inStream)
                                                      throws CRLException
        返回从给定输入流inStream读取的CRL的（可能为空的）集合视图。

        为了利用此证书工厂支持的专用CRL格式，返回的集合视图中的每个元素都可以类型转换为相应的CRL类。 例如，如果此证书工厂实现X.509 CRL，则返回集合中的元素可以类型转换为X509CRL类。

        在X.509 CRL的证书工厂的情况下， inStream可能包含单个DER编码的CRL。 另外， inStream可能包含PKCS＃7 CRL集。 这是一个PKCS＃7 SignedData对象，唯一有效的字段是crls 。 特别地，签名和内容被忽略。 此格式允许一次下载多个CRL。 如果没有CRL，则返回一个空的集合。

        请注意，如果给定的输入流不支持mark和reset ，则此方法将消耗整个输入流。

        参数
        inStream - 具有CRL的输入流。
        结果
        使用来自输入流的数据初始化的java.security.cert.CRL对象的（可能为空的）集合视图。
        异常
        CRLException - 解析错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertificateNotYetValidException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertificateNotYetValidException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateNotYetValidException
  • All Implemented Interfaces:
    Serializable

    public class CertificateNotYetValidException
extends CertificateException
    证书还没有有效的例外。 每当当前的Date或指定的Date在证书有效期内的notBefore日期/时间之前，这是抛出的。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertificateNotYetValidException​()
      构造一个没有详细消息的CertificateNotYetValidException。
      CertificateNotYetValidException​(String message)
      构造具有指定详细消息的CertificateNotYetValidException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CertificateNotYetValidException

        public CertificateNotYetValidException​()
        构造一个没有详细消息的CertificateNotYetValidException。 详细消息是描述此特定异常的字符串。

      • CertificateNotYetValidException

        public CertificateNotYetValidException​(String message)
        构造具有指定详细消息的CertificateNotYetValidException。 详细消息是描述此特定异常的字符串。
        参数
        message - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertificateParsingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertificateParsingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateParsingException
  • All Implemented Interfaces:
    Serializable

    public class CertificateParsingException
extends CertificateException
    证书解析异常。 每当无效的DER编码证书被解析或不受支持时，都会抛出此错误。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertificateParsingException​()
      构造一个没有详细消息的CertificateParsingException。
      CertificateParsingException​(String message)
      构造具有指定详细消息的CertificateParsingException。
      CertificateParsingException​(String message, Throwable cause)
      创建一个具有指定的详细信息和原因的 CertificateParsingException 。
      CertificateParsingException​(Throwable cause)
      创建 CertificateParsingException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CertificateParsingException

        public CertificateParsingException​()
        构造一个没有详细消息的CertificateParsingException。 详细消息是描述此特定异常的字符串。

      • CertificateParsingException

        public CertificateParsingException​(String message)
        构造具有指定详细消息的CertificateParsingException。 详细消息是描述此特定异常的字符串。
        参数
        message - 详细信息。

      • CertificateParsingException

        public CertificateParsingException​(String message,
                                   Throwable cause)
        创建一个 CertificateParsingException与指定的详细信息和原因。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （A null允许值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • CertificateParsingException

        public CertificateParsingException​(Throwable cause)
        创建 CertificateParsingException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （A null允许值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertificateRevokedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertificateRevokedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateRevokedException
  • All Implemented Interfaces:
    Serializable

    public class CertificateRevokedException
extends CertificateException
    表示X.509证书的异常被撤销。 A CertificateRevokedException包含有关撤销的证书的其他信息，例如证书被撤销的日期及其被撤销的原因。
    从以下版本开始：
    1.7
    另请参见：
    CertPathValidatorException ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertificateRevokedException​(Date revocationDate, CRLReason reason, X500Principal authority, Map<String,Extension> extensions)
      构造具有指定撤销日期，原因代码，权限名称和扩展名映射的 CertificateRevokedException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      X500Principal getAuthorityName​()
      返回签署证书撤销状态信息的权限的名称。
      Map<String,Extension> getExtensions​()
      返回X.509扩展名的地图，其中包含有关撤销证书的附加信息，例如无效日期扩展。
      Date getInvalidityDate​()
      返回此 CertificateRevokedException的无效日期扩展名中指定的无效日期。
      String getMessage​()
      返回此throwable的详细消息字符串。
      Date getRevocationDate​()
      返回证书被撤销的日期。
      CRLReason getRevocationReason​()
      返回证书被撤销的原因。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CertificateRevokedException

        public CertificateRevokedException​(Date revocationDate,
                                   CRLReason reason,
                                   X500Principal authority,
                                   Map<String,Extension> extensions)
        构造具有指定撤销日期，原因代码，权限名称和扩展名映射的 CertificateRevokedException 。
        参数
        revocationDate - 证书被撤销的日期。 复制日期以防止后续修改。
        reason - 撤销原因
        extensions - X.509扩展的地图。 每个键都是一个OID字符串，映射到相应的扩展。 复制地图以防止后续修改。
        authority - 表示签署证书撤销状态信息的权限的名称的 X500Principal
        异常
        NullPointerException -如果 revocationDate ， reason ， authority ，或 extensions为 null
        ClassCastException - 如果 extensions包含错误键入的键或值

    • 方法详细信息

      • getRevocationDate

        public Date getRevocationDate​()
        返回证书被撤销的日期。 每次调用该方法时都会返回一个新副本，以防止后续修改。
        结果
        撤销日期

      • getRevocationReason

        public CRLReason getRevocationReason​()
        返回证书被撤销的原因。
        结果
        撤销原因

      • getAuthorityName

        public X500Principal getAuthorityName​()
        返回签署证书撤销状态信息的权限的名称。
        结果
        表示签署证书撤销状态信息的权限的名称的 X500Principal

      • getInvalidityDate

        public Date getInvalidityDate​()
        返回此CertificateRevokedException的无效日期扩展名中指定的无效日期。 无效日期是已知或怀疑私钥遭到入侵的日期或证书否则无效。 此实施方法调用getExtensions()并检查返回的映射，以获取无效日期扩展名OID（“2.5.29.24”）的条目。 如果找到，它将在扩展名中返回无效日期; 否则为空。 每次调用该方法时都会返回一个新的Date对象，以防止后续修改。
        结果
        无效日期，或 null如果未指定

      • getExtensions

        public Map<String,Extension> getExtensions​()
        返回X.509扩展名的地图，其中包含有关撤销证书的附加信息，例如无效日期扩展。 每个键都是一个OID字符串，映射到相应的扩展。
        结果
        一个不可修改的X.509扩展名的地图，如果没有扩展名，则是空的地图

      • getMessage

        public String getMessage​()
        描述从类别复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertPath

  • java.lang.Object
    • java.security.cert.CertPath
  • All Implemented Interfaces:
    Serializable

    public abstract class CertPath
extends Object
implements Serializable
    证书的不可变序列（认证路径）。

    这是一个抽象类，它定义了所有CertPath的共同方法。 子类可以处理不同类型的证书（X.509，PGP等）。

    所有CertPath对象都有一个类型，一个Certificate s的列表，以及一个或多个支持的编码。 因为CertPath类是不可变的，所以在CertPath ， CertPath不能以任何外部可见的方式改变。 这个规定适用于这个类的所有公共领域和方法，以及任何由子类添加或覆盖的规则。

    类型是String标识的类型Certificate S IN的证书路径。 对于每个证书cert证书路径certPath ， cert.getType().equals(certPath.getType())必须是true 。

    Certificate的列表是List的零或多个Certificate的有序List 。 这个List和Certificate包含的所有List都必须是不可变的。

    每个CertPath对象必须支持一个或多个编码，以便将对象转换为字节数组以存储或传输给其他方。 优选地，这些编码应该是有良好记录的标准（例如PKCS＃7）。 CertPath支持的编码CertPath被认为是默认编码。 如果没有显式请求编码，则使用此编码（例如，对于getEncoded()方法）。

    全部CertPath对象也是Serializable 。 CertPath对象在序列化期间被解析为备用的CertPathRep对象。 这允许将CertPath对象序列化为等效表示，而不管其底层实现。

    可以使用CertificateFactory创建CertPath对象，或者可以由其他类返回，如CertPathBuilder 。

    按照惯例，X.509 CertPath S（由X509Certificate S），是有序开头的目标，证书和与信任锚颁发的证书结束。 也就是说，一个证书的颁发者是下面的一个证书的主题。 代表TrustAnchor的证书不应包含在认证路径中。 未验证X.509 CertPath可能不遵循这些约定。 PKIX CertPathValidator将检测到这些约定的任何偏离，导致认证路径无效并抛出一个CertPathValidatorException 。

    Java平台的每个实现都需要支持以下标准CertPath编码：

    • PKCS7
    • PkiPath
    这些编码在Java安全标准算法名称规范的CertPath Encodings section中进行了描述。 请参阅实现的发行文档，以查看是否支持其他编码。

    并发访问

    所有CertPath对象必须是线程安全的。 也就是说，多个线程可以在单个CertPath对象（或多个）上同时调用此类中定义的方法，而不会产生不良影响。 对于List返回的CertPath.getCertificates也是如此。

    要求CertPath对象是不可变的和线程安全的，可以让它们传递到各种代码，而不用担心协调访问。 提供这种线程安全性通常并不困难，因为所CertPath和List对象是不可变的。

    从以下版本开始：
    1.4
    另请参见：
    CertificateFactory ， CertPathBuilder ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected static class  CertPath.CertPathRep
      替代 CertPath类用于序列化。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CertPath​(String type)
      创建一个指定类型的 CertPath 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object other)
      将此认证路径与指定的对象进行比较。
      abstract List<? extends Certificate> getCertificates​()
      返回此认证路径中的证书列表。
      abstract byte[] getEncoded​()
      使用默认编码返回此认证路径的编码形式。
      abstract byte[] getEncoded​(String encoding)
      使用指定的编码返回此认证路径的编码形式。
      abstract Iterator<String> getEncodings​()
      返回此认证路径支持的编码的迭代，并使用默认编码。
      String getType​()
      返回此认证路径中的 Certificate的类型。
      int hashCode​()
      返回此认证路径的哈希码。
      String toString​()
      返回此认证路径的字符串表示形式。
      protected Object writeReplace​()
      替换 CertPath以使用 CertPathRep对象进行序列化。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CertPath

        protected CertPath​(String type)
        创建指定类型的CertPath 。

        此构造函数受到保护，因为大多数用户应使用CertificateFactory创建CertPath 。

        参数
        type - 此路径中 Certificate的类型的标准名称

    • 方法详细信息

      • getType

        public String getType​()
        返回此认证路径中的Certificate的类型。 这是cert.getType()对于认证路径中所有Certificate都将返回的字符串。
        结果
        该认证路径中的类型为 Certificate （从不为null）

      • getEncodings

        public abstract Iterator<String> getEncodings​()
        返回此认证路径支持的编码的迭代，并使用默认编码。 尝试通过其remove方法修改返回的Iterator产生一个UnsupportedOperationException 。
        结果
        一个 Iterator的支持编码的名称（作为字符串）

      • equals

        public boolean equals​(Object other)
        将此认证路径与指定的对象进行比较。 两个CertPath在相同的情况下是相等的，如果他们的类型相同，并且他们的证书List （并且暗示Certificate的List ）相等。 A CertPath从不等于不是CertPath的对象。

        该算法由该方法实现。 如果被覆盖，则必须维护此处指定的行为。

        重写：
        equals在 Object
        参数
        other - 要与此认证路径相等的对象
        结果
        如果指定的对象等于此认证路径，则为true，否则为false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此认证路径的哈希码。 认证路径的哈希码被定义为以下计算的结果：
           hashCode = path.getType().hashCode(); hashCode = 31*hashCode + path.getCertificates().hashCode();
        这确保path1.equals(path2)意味着path1.hashCode()==path2.hashCode()的任何两个认证路径， path1和path2 ，根据path2的一般合同Object.hashCode 。
        重写：
        hashCode在类 Object
        结果
        该认证路径的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此认证路径的字符串表示形式。 这将调用toString在每个方法Certificate S IN的路径。
        重写：
        toString在 Object
        结果
        该认证路径的字符串表示形式

      • getEncoded

        public abstract byte[] getEncoded​()
                           throws CertificateEncodingException
        使用默认编码返回此认证路径的编码形式。
        结果
        编码字节
        异常
        CertificateEncodingException - 如果发生编码错误

      • getEncoded

        public abstract byte[] getEncoded​(String encoding)
                           throws CertificateEncodingException
        使用指定的编码返回此认证路径的编码形式。
        参数
        encoding - 要使用的编码的名称
        结果
        编码字节
        异常
        CertificateEncodingException - 如果发生编码错误或不支持请求的编码

      • getCertificates

        public abstract List<? extends Certificate> getCertificates​()
        返回此认证路径中的证书列表。 返回的List必须是不可变的和线程安全的。
        结果
        一个不可变的 List的 Certificate s（可能为空，但不为null）

      • writeReplace

        protected Object writeReplace​()
                       throws ObjectStreamException
        将 CertPath替换为 CertPathRep对象进行序列化。
        结果
        CertPathRep要序列化
        异常
        ObjectStreamException - 如果无法创建表示此认证路径的对象 CertPathRep
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPath.CertPathRep (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertPath.CertPathRep

  • java.lang.Object
    • java.security.cert.CertPath.CertPathRep
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    CertPath

    protected static class CertPath.CertPathRep
extends Object
implements Serializable
    替代 CertPath类用于序列化。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CertPathRep​(String type, byte[] data)
      创建具有指定类型和认证路径的编码形式的 CertPathRep 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Object readResolve​()
      返回从类型和数据构造的 CertPath 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertPathRep

        protected CertPathRep​(String type,
                      byte[] data)
        创建具有指定类型和编码形式的认证路径的 CertPathRep 。
        参数
        type - CertPath类型的标准名称
        data - 认证路径的编码形式

    • 方法详细信息

      • readResolve

        protected Object readResolve​()
                      throws ObjectStreamException
        返回从类型和数据构造的 CertPath 。
        结果
        解决了 CertPath对象
        异常
        ObjectStreamException - if a CertPath could not be constructed
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertPathBuilder

  • java.lang.Object
    • java.security.cert.CertPathBuilder

  • public class CertPathBuilder
extends Object
    建立认证路径（也称为证书链）的课程。

    这个类使用基于提供者的架构。 要创建一个CertPathBuilder ，请调用静态的getInstance方法之一，传递所需的算法名称为CertPathBuilder并可选地提供所需的提供者的名称。

    一旦创建了一个CertPathBuilder对象，就可以通过调用build方法并传递一个算法特定的参数集来构造认证路径。 如果成功的话，结果（包括CertPath一个建）在实现一个对象返回CertPathBuilderResult接口。

    该getRevocationChecker()方法允许应用程序指定用于由附加特定算法的参数和选项CertPathBuilder检查证书的撤销状态时。 下面是一个演示如何使用PKIX算法的例子：

      CertPathBuilder cpb = CertPathBuilder.getInstance("PKIX");
 PKIXRevocationChecker rc = (PKIXRevocationChecker)cpb.getRevocationChecker();
 rc.setOptions(EnumSet.of(Option.PREFER_CRLS));
 params.addCertPathChecker(rc);
 CertPathBuilderResult cpbr = cpb.build(params);

    Java平台的每个实现都需要支持以下标准CertPathBuilder算法：

    • PKIX
    该算法在Java安全标准算法名称规范的CertPathBuilder section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。

    并发访问

    该类的静态方法保证线程安全。 多个线程可以同时调用此类中定义的静态方法，而不会产生不良影响。

    但是，对于此类定义的非静态方法，这不是真的。 除非特定提供者另有说明，否则需要同时访问单个CertPathBuilder实例的线程应在CertPathBuilder同步并提供必要的锁定。 多个线程每个操作不同的CertPathBuilder实例不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertPath

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CertPathBuilder​(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
      创建给定算法的 CertPathBuilder对象，并将给定的提供者实现（SPI对象）封装在其中。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CertPathBuilderResult build​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
      String getAlgorithm​()
      返回此 CertPathBuilder算法的 CertPathBuilder 。
      static String getDefaultType​()
      返回由 certpathbuilder.type安全属性指定的默认 CertPathBuilder类型，如果不存在此属性，则返回字符串“PKIX”。
      static CertPathBuilder getInstance​(String algorithm)
      返回实现指定算法的 CertPathBuilder对象。
      static CertPathBuilder getInstance​(String algorithm, String provider)
      返回实现指定算法的 CertPathBuilder对象。
      static CertPathBuilder getInstance​(String algorithm, Provider provider)
      返回实现指定算法的 CertPathBuilder对象。
      Provider getProvider​()
      返回此 CertPathBuilder的提供者。
      CertPathChecker getRevocationChecker​()
      返回 CertPathChecker封装的 CertPathBuilderSpi实现用于检查证书的撤销状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertPathBuilder

        protected CertPathBuilder​(CertPathBuilderSpi builderSpi,
                          Provider provider,
                          String algorithm)
        创建给定算法的 CertPathBuilder对象，并将给定的提供者实现（SPI对象）封装在其中。
        参数
        builderSpi - 提供者实现
        provider - 提供商
        algorithm - 算法名称

    • 方法详细信息

      • getInstance

        public static CertPathBuilder getInstance​(String algorithm)
                                   throws NoSuchAlgorithmException
        返回实现指定算法的CertPathBuilder对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装CertPathBuilderSpi实现的新CertPathBuilder对象。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 所请求的CertPathBuilder算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的CertPathBuilder部分。
        结果
        一个实现指定算法的 CertPathBuilder对象
        异常
        NoSuchAlgorithmException - 如果没有 Provider支持指定算法的 CertPathBuilderSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static CertPathBuilder getInstance​(String algorithm,
                                          String provider)
                                   throws NoSuchAlgorithmException,
                                          NoSuchProviderException
        返回实现指定算法的CertPathBuilder对象。

        返回从指定提供程序封装CertPathBuilderSpi实现的新CertPathBuilder对象。 指定的提供者必须在安全提供程序列表中注册。

        注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        参数
        algorithm - 请求的名称CertPathBuilder算法。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的CertPathBuilder部分。
        provider - 提供商的名称。
        结果
        一个实现指定算法的 CertPathBuilder对象
        异常
        IllegalArgumentException - 如果 provider是 null或空
        NoSuchAlgorithmException - 如果指定算法的 CertPathBuilderSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static CertPathBuilder getInstance​(String algorithm,
                                          Provider provider)
                                   throws NoSuchAlgorithmException
        返回实现指定算法的CertPathBuilder对象。

        返回从指定的Provider对象封装CertPathBuilderSpi实现的新的CertPathBuilder对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 请求的名称CertPathBuilder算法。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的CertPathBuilder部分。
        provider - 提供商。
        结果
        一个实现指定算法的 CertPathBuilder对象
        异常
        IllegalArgumentException - 如果 provider是 null
        NoSuchAlgorithmException - 如果指定的算法的 CertPathBuilderSpi实现从指定的 Provider对象不可用
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此 CertPathBuilder的提供者。
        结果
        这个 CertPathBuilder的提供者

      • getAlgorithm

        public final String getAlgorithm​()
        返回此 CertPathBuilder算法的 CertPathBuilder 。
        结果
        这个 CertPathBuilder的算法的 CertPathBuilder

      • build

        public final CertPathBuilderResult build​(CertPathParameters params)
                                  throws CertPathBuilderException,
                                         InvalidAlgorithmParameterException
        尝试使用指定的算法参数集构建认证路径。
        参数
        params - 算法参数
        结果
        构建算法的结果
        异常
        CertPathBuilderException - 如果构建器不能构造满足指定参数的认证路径
        InvalidAlgorithmParameterException - 如果指定的参数不适合此 CertPathBuilder

      • getDefaultType

        public static final String getDefaultType​()
        返回由certpathbuilder.type安全属性指定的默认CertPathBuilder类型，如果不存在此属性，则返回字符串“PKIX”。

        默认的CertPathBuilder类型可以由不想使用硬编码类型的应用程序使用，当调用getInstance方法之一时，并希望提供默认类型，以防用户没有指定自己的类型。

        通过将certpathbuilder.type安全属性的值设置为CertPathBuilder类型，可以更改默认值certpathbuilder.type类型。

        结果
        默认的 CertPathBuilder类型由 certpathbuilder.type指定的安全属性，或字符串“PKIX”，如果没有这样的属性存在。
        另请参见：
        security properties

      • getRevocationChecker

        public final CertPathChecker getRevocationChecker​()
        返回CertPathChecker封装的CertPathBuilderSpi实现用于检查证书的撤销状态。 PKIX实现返回PKIXRevocationChecker类型的PKIXRevocationChecker 。 此方法的每次调用返回一个新的实例CertPathChecker 。

        此方法的主要目的是允许调用者指定额外的输入参数和特定于撤销检查的选项。 参见课程说明一个例子。

        结果
        一个 CertPathChecker
        异常
        UnsupportedOperationException - 如果服务提供商不支持此方法
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathBuilderException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertPathBuilderException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertPathBuilderException
  • All Implemented Interfaces:
    Serializable

    public class CertPathBuilderException
extends GeneralSecurityException
    一个例外，指出使用CertPathBuilder构建认证路径时遇到的各种问题CertPathBuilder 。

    A CertPathBuilderException提供对包装异常的支持。 getCause方法返回引发此异常抛出的throwable（如果有）。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertPathBuilder ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertPathBuilderException​()
      创建 CertPathBuilderException与 null作为其详细消息。
      CertPathBuilderException​(String msg)
      创建一个 CertPathBuilderException与给定的详细信息。
      CertPathBuilderException​(String msg, Throwable cause)
      创建一个具有指定的详细消息和原因的 CertPathBuilderException 。
      CertPathBuilderException​(Throwable cause)
      创建一个包含指定的throwable的 CertPathBuilderException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CertPathBuilderException

        public CertPathBuilderException​()
        创建 CertPathBuilderException与 null作为其详细消息。

      • CertPathBuilderException

        public CertPathBuilderException​(String msg)
        使用给定的详细信息创建一个CertPathBuilderException 。 详细信息是一个String ，它更详细地描述了这个特殊的异常。
        参数
        msg - 详细信息

      • CertPathBuilderException

        public CertPathBuilderException​(Throwable cause)
        创建一个CertPathBuilderException ，它包装指定的throwable。 这允许将任何异常转换为CertPathBuilderException ，同时保留关于包装异常的信息，这可能对调试有用。 详细消息设置为（ cause==null ? null : cause.toString() ）（通常包含原因的类和详细消息）。
        参数
        cause - 原因（由getCause()方法保存供以后检索）。 （允许A null值，并表示原因不存在或未知。）

      • CertPathBuilderException

        public CertPathBuilderException​(String msg,
                                Throwable cause)
        创建一个 CertPathBuilderException具有指定的详细信息和原因。
        参数
        msg - 详细信息
        cause - 原因（由getCause()方法保存供以后检索）。 （A null值是允许的，表示原因不存在或未知。）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathBuilderResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface CertPathBuilderResult

  • All Superinterfaces:
    Cloneable
    所有已知实现类：
    PKIXCertPathBuilderResult

    public interface CertPathBuilderResult
extends Cloneable
    认证路径构建器算法的结果的规范。 CertPathBuilder.build方法返回的所有结果都必须实现此接口。

    至少，一个CertPathBuilderResult包含CertPath通过内置CertPathBuilder实例。 该接口的实现可以添加返回实现或算法特定信息的方法，例如调试信息或认证路径验证结果。

    并发访问

    除非另有说明，否则此界面中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertPathBuilder

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object clone​()
      复制一份这个 CertPathBuilderResult 。
      CertPath getCertPath​()
      返回建立的认证路径。

    • 方法详细信息

      • getCertPath

        CertPath getCertPath​()
        返回建立的认证路径。
        结果
        认证路径（从不 null ）

      • clone

        Object clone​()
        复制这份CertPathBuilderResult 。 副本的更改不会影响原始文件，反之亦然。
        结果
        这个 CertPathBuilderResult的副本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathBuilderSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertPathBuilderSpi

  • java.lang.Object
    • java.security.cert.CertPathBuilderSpi

  • public abstract class CertPathBuilderSpi
extends Object
    （ SPI ）为CertPathBuilder类。 所有CertPathBuilder实现必须包括一个扩展此类（ CertPathBuilderSpi ）并实现其所有方法的类（SPI类）。 一般来说，此类的实例只能通过CertPathBuilder类访问。 有关详细信息，请参阅Java加密体系结构。

    并发访问

    不需要保护此类的实例，防止来自多个线程的并发访问。 需要同时访问单个CertPathBuilderSpi实例的线程应在其之间同步并在调用包装CertPathBuilder对象之前提供必要的锁定。

    然而， CertPathBuilderSpi实现可能仍然会遇到并发问题，因为每个操作不同的CertPathBuilderSpi实例的多个线程不需要同步。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertPathBuilderSpi​()
      默认构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract CertPathBuilderResult engineBuild​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
      CertPathChecker engineGetRevocationChecker​()
      返回此实现用于检查证书的吊销状态的 CertPathChecker 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertPathBuilderSpi

        public CertPathBuilderSpi​()
        默认构造函数。

    • 方法详细信息

      • engineBuild

        public abstract CertPathBuilderResult engineBuild​(CertPathParameters params)
                                           throws CertPathBuilderException,
                                                  InvalidAlgorithmParameterException
        尝试使用指定的算法参数集构建认证路径。
        参数
        params - 算法参数
        结果
        构建算法的结果
        异常
        CertPathBuilderException - 如果构建器不能构造满足指定参数的认证路径
        InvalidAlgorithmParameterException - 如果指定的参数不适合此 CertPathBuilder

      • engineGetRevocationChecker

        public CertPathChecker engineGetRevocationChecker​()
        返回此实现用于检查证书的撤销状态的CertPathChecker 。 PKIX实现返回PKIXRevocationChecker类型的PKIXRevocationChecker 。

        此方法的主要目的是允许调用者指定额外的输入参数和特定于撤销检查的选项。 参见CertPathBuilder的类描述。

        该方法被添加到Java Platform Standard Edition的1.8版本。 为了保持与现有服务提供商的向后兼容性，此方法不能是抽象的，默认情况下会抛出一个UnsupportedOperationException 。

        结果
        一个 CertPathChecker ，该实现用于检查证书的撤销状态
        异常
        UnsupportedOperationException - 如果不支持此方法
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathChecker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface CertPathChecker

  • 所有已知实现类：
    PKIXCertPathChecker ， PKIXRevocationChecker

    public interface CertPathChecker

    对Certificate的CertPath执行一个或多个检查。

    通常创建CertPathChecker实现来扩展认证路径验证算法。 例如，实现可以检查和处理认证路径中每个证书的关键私人扩展。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void check​(Certificate cert)
      使用其内部状态对指定的证书执行检查。
      void init​(boolean forward)
      初始化这个 CertPathChecker的内部状态。
      boolean isForwardCheckingSupported​()
      指示是否支持转发检查。

    • 方法详细信息

      • init

        void init​(boolean forward)
   throws CertPathValidatorException
        初始化这个CertPathChecker的内部状态。

        forward标志指定证书将传递给check方法（正向或反向）的顺序。

        参数
        forward - 证书颁发给check方法的check 。 如果true ，证书从目标提供给信任锚（转发）; 如果false ，从信任锚到目标（反向）。
        异常
        CertPathValidatorException - 如果这个 CertPathChecker无法以指定的顺序检查证书

      • isForwardCheckingSupported

        boolean isForwardCheckingSupported​()
        指示是否支持转发检查。 正向检查指的能力CertPathChecker时证书被呈现给执行其检查check方法在向前方向（从靶信任锚）。
        结果
        true如果正向检查支持， false否则

      • check

        void check​(Certificate cert)
    throws CertPathValidatorException
        使用其内部状态对指定的证书执行检查。 证书按init方法指定的顺序init 。
        参数
        cert - 要检查的 Certificate
        异常
        CertPathValidatorException - 如果指定的证书没有通过支票
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface CertPathParameters

  • All Superinterfaces:
    Cloneable
    所有已知实现类：
    PKIXBuilderParameters ， PKIXParameters

    public interface CertPathParameters
extends Cloneable
    认证路径算法参数的规范。 该接口的目的是为所有CertPath参数规范分组（并提供类型安全性）。 所有CertPath参数规范必须实现此接口。
    从以下版本开始：
    1.4
    另请参见：
    CertPathValidator.validate(CertPath, CertPathParameters) ， CertPathBuilder.build(CertPathParameters)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object clone​()
      复制这份 CertPathParameters 。

    • 方法详细信息

      • clone

        Object clone​()
        复制这份CertPathParameters 。 副本的更改不会影响原始文件，反之亦然。
        结果
        这个 CertPathParameters的副本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathValidator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertPathValidator

  • java.lang.Object
    • java.security.cert.CertPathValidator

  • public class CertPathValidator
extends Object
    用于验证认证路径（也称为证书链）的类。

    这个类使用基于提供者的架构。 要创建一个CertPathValidator ，调用静态一个getInstance方法，传递的算法名称CertPathValidator所需和可选要求的供应商的名称。

    一旦创建了一个CertPathValidator对象，它可以用于通过调用validate方法来验证认证路径，并将其CertPath给要验证的CertPath和特定于算法的参数集。 如果成功，则会在实现CertPathValidatorResult接口的对象中返回结果。

    该getRevocationChecker()方法允许应用程序指定用于由附加特定算法的参数和选项CertPathValidator检查证书的撤销状态时。 下面是一个演示如何使用PKIX算法的例子：

      CertPathValidator cpv = CertPathValidator.getInstance("PKIX");
 PKIXRevocationChecker rc = (PKIXRevocationChecker)cpv.getRevocationChecker();
 rc.setOptions(EnumSet.of(Option.SOFT_FAIL));
 params.addCertPathChecker(rc);
 CertPathValidatorResult cpvr = cpv.validate(path, params);

    Java平台的每个实现都需要支持以下标准的CertPathValidator算法：

    • PKIX
    该算法在Java安全标准算法名称规范的CertPathValidator section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。

    并发访问

    该类的静态方法保证线程安全。 多个线程可以同时调用此类中定义的静态方法，而不会产生不良影响。

    但是，对于此类定义的非静态方法，这不是真的。 除非特定提供者另有说明，否则需要同时访问单个CertPathValidator实例的线程应在CertPathValidator同步并提供必要的锁定。 多个线程每个操作不同的CertPathValidator实例不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertPath

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CertPathValidator​(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
      创建给定算法的 CertPathValidator对象，并将给定的提供者实现（SPI对象）封装在其中。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getAlgorithm​()
      返回此 CertPathValidator的算法名称。
      static String getDefaultType​()
      返回由 certpathvalidator.type安全属性指定的默认 CertPathValidator类型，如果不存在此属性，则返回字符串“PKIX”。
      static CertPathValidator getInstance​(String algorithm)
      返回实现指定算法的 CertPathValidator对象。
      static CertPathValidator getInstance​(String algorithm, String provider)
      返回实现指定算法的 CertPathValidator对象。
      static CertPathValidator getInstance​(String algorithm, Provider provider)
      返回实现指定算法的 CertPathValidator对象。
      Provider getProvider​()
      返回 Provider的 CertPathValidator 。
      CertPathChecker getRevocationChecker​()
      返回 CertPathChecker封装的 CertPathValidatorSpi实现用于检查证书的撤销状态。
      CertPathValidatorResult validate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertPathValidator

        protected CertPathValidator​(CertPathValidatorSpi validatorSpi,
                            Provider provider,
                            String algorithm)
        创建给定算法的 CertPathValidator对象，并将给定的提供者实现（SPI对象）封装在其中。
        参数
        validatorSpi - 提供商实现
        provider - 提供商
        algorithm - 算法名称

    • 方法详细信息

      • getInstance

        public static CertPathValidator getInstance​(String algorithm)
                                     throws NoSuchAlgorithmException
        返回实现指定算法的CertPathValidator对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装CertPathValidatorSpi实现的新CertPathValidator对象。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与由Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 请求的名称CertPathValidator算法。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的CertPathValidator部分。
        结果
        一个实现指定算法的 CertPathValidator对象
        异常
        NoSuchAlgorithmException - 如果没有 Provider支持指定算法的 CertPathValidatorSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static CertPathValidator getInstance​(String algorithm,
                                            String provider)
                                     throws NoSuchAlgorithmException,
                                            NoSuchProviderException
        返回实现指定算法的CertPathValidator对象。

        返回从指定提供程序封装CertPathValidatorSpi实现的新CertPathValidator对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        algorithm - 请求的名称CertPathValidator算法。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的CertPathValidator部分。
        provider - 提供商的名称。
        结果
        一个实现指定算法的 CertPathValidator对象
        异常
        IllegalArgumentException - 如果 provider是 null或空
        NoSuchAlgorithmException - 如果指定算法的 CertPathValidatorSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static CertPathValidator getInstance​(String algorithm,
                                            Provider provider)
                                     throws NoSuchAlgorithmException
        返回实现指定算法的CertPathValidator对象。

        返回从指定的Provider对象封装CertPathValidatorSpi实现的新CertPathValidator对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 请求的名称CertPathValidator算法。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的CertPathValidator部分。
        provider - 提供商。
        结果
        一个实现指定算法的 CertPathValidator对象
        异常
        IllegalArgumentException - 如果 provider是 null
        NoSuchAlgorithmException - 如果指定的算法的一个 CertPathValidatorSpi实现从指定的Provider对象不可用
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此 Provider的 CertPathValidator 。
        结果
        这个 Provider的 CertPathValidator

      • getAlgorithm

        public final String getAlgorithm​()
        返回此 CertPathValidator的算法名称。
        结果
        该算法名称为 CertPathValidator

      • validate

        public final CertPathValidatorResult validate​(CertPath certPath,
                                              CertPathParameters params)
                                       throws CertPathValidatorException,
                                              InvalidAlgorithmParameterException
        使用指定的算法参数集验证指定的认证路径。

        指定的CertPath必须是验证算法支持的类型，否则将抛出InvalidAlgorithmParameterException 。 例如， CertPathValidator实现该算法PKIX验证CertPath类型X.509的对象。

        参数
        certPath - 要验证的 CertPath
        params - 算法参数
        结果
        验证算法的结果
        异常
        CertPathValidatorException - 如果 CertPath没有验证
        InvalidAlgorithmParameterException - 如果指定的参数或指定的类型 CertPath不适合此 CertPathValidator

      • getDefaultType

        public static final String getDefaultType​()
        返回由certpathvalidator.type安全属性指定的默认CertPathValidator类型，如果不存在此属性，则返回字符串“PKIX”。

        默认的CertPathValidator类型可以由不想使用硬编码类型的应用程序使用，当调用getInstance方法之一时，并且希望提供默认类型，以防用户没有指定自己的类型。

        通过将certpathvalidator.type安全属性的值设置为CertPathValidator类型，可以更改默认值certpathvalidator.type类型。

        结果
        默认的 CertPathValidator类型由 certpathvalidator.type指定的安全属性，或字符串“PKIX”，如果没有这样的属性存在。
        另请参见：
        security properties

      • getRevocationChecker

        public final CertPathChecker getRevocationChecker​()
        返回CertPathChecker ，该封装CertPathValidatorSpi实现使用检查证书的吊销状态。 PKIX实现返回PKIXRevocationChecker类型的PKIXRevocationChecker 。 此方法的每次调用将返回一个新的实例CertPathChecker 。

        此方法的主要目的是允许调用者指定额外的输入参数和特定于撤销检查的选项。 参见课程说明一个例子。

        结果
        一个 CertPathChecker
        异常
        UnsupportedOperationException - 如果服务提供商不支持此方法
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathValidatorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertPathValidatorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertPathValidatorException
  • All Implemented Interfaces:
    Serializable

    public class CertPathValidatorException
extends GeneralSecurityException
    表示验证认证路径时遇到的各种问题之一的异常。

    A CertPathValidatorException提供对包装异常的支持。 getCause方法返回引发此异常抛出的throwable（如果有）。

    A CertPathValidatorException还可以包括在抛出异常时验证的认证路径，导致异常引发的认证路径中的证书的索引以及导致失败的原因。 使用getCertPath ， getIndex ，并getReason方法来获取这些信息。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertPathValidator ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  CertPathValidatorException.BasicReason
      BasicReason列举了任何类型的认证路径可能无效的潜在原因。
      static interface  CertPathValidatorException.Reason
      验证算法失败的原因。

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertPathValidatorException​()
      创建一个 CertPathValidatorException没有详细消息。
      CertPathValidatorException​(String msg)
      使用给定的详细信息创建一个 CertPathValidatorException 。
      CertPathValidatorException​(String msg, Throwable cause)
      创建一个 CertPathValidatorException与指定的详细信息和原因。
      CertPathValidatorException​(String msg, Throwable cause, CertPath certPath, int index)
      创建具有指定的详细消息，原因，认证路径和索引的 CertPathValidatorException 。
      CertPathValidatorException​(String msg, Throwable cause, CertPath certPath, int index, CertPathValidatorException.Reason reason)
      创建具有指定的详细消息，原因，认证路径，索引和原因的 CertPathValidatorException 。
      CertPathValidatorException​(Throwable cause)
      创建一个 CertPathValidatorException ，它包装指定的throwable。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CertPath getCertPath​()
      返回在抛出异常时验证的认证路径。
      int getIndex​()
      返回导致异常抛出的证书路径中的证书的索引。
      CertPathValidatorException.Reason getReason​()
      返回验证失败的原因。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CertPathValidatorException

        public CertPathValidatorException​()
        创建一个 CertPathValidatorException没有详细消息。

      • CertPathValidatorException

        public CertPathValidatorException​(String msg)
        使用给定的详细信息创建一个CertPathValidatorException 。 详细信息是描述这个特殊异常的String 。
        参数
        msg - 详细信息

      • CertPathValidatorException

        public CertPathValidatorException​(Throwable cause)
        创建一个CertPathValidatorException ，它包装指定的throwable。 这允许将任何异常转换为CertPathValidatorException ，同时保留关于包装异常的信息，这可能对调试很有用。 详细消息设置为（ cause==null ? null : cause.toString() ）（其通常包含原因的类和详细消息）。
        参数
        cause - 原因（保存以供getCause()方法稍后检索）。 （A null值是允许的，并且表示原因不存在或未知。）

      • CertPathValidatorException

        public CertPathValidatorException​(String msg,
                                  Throwable cause)
        创建一个 CertPathValidatorException具有指定的详细信息和原因。
        参数
        msg - 详细信息
        cause - 原因（保存以供getCause()方法后续检索）。 （允许A null值，并表示原因不存在或未知。）

      • CertPathValidatorException

        public CertPathValidatorException​(String msg,
                                  Throwable cause,
                                  CertPath certPath,
                                  int index)
        使用指定的详细消息，原因，认证路径和索引创建 CertPathValidatorException 。
        参数
        msg - 详细信息（或 null如果没有）
        cause - 原因（或 null如果没有）
        certPath - 遇到错误时验证路径
        index - 导致错误的认证路径中的证书索引（如果不适用，则为-1）。 请注意， CertPath中的证书列表为零。
        异常
        IndexOutOfBoundsException - 如果索引超出范围 (index < -1 || (certPath != null && index >= certPath.getCertificates().size())
        IllegalArgumentException - 如果 certPath是 null和 index不是-1

      • CertPathValidatorException

        public CertPathValidatorException​(String msg,
                                  Throwable cause,
                                  CertPath certPath,
                                  int index,
                                  CertPathValidatorException.Reason reason)
        使用指定的详细信息，原因，认证路径，索引和原因创建 CertPathValidatorException 。
        参数
        msg - 详细信息（或 null如果没有）
        cause - 原因（或 null如果没有）
        certPath - 当遇到错误时正在验证的认证路径
        index - 导致错误的认证路径中的证书索引（或-1（如果不适用））。 请注意， CertPath中的证书列表为零。
        reason - 验证失败的原因
        异常
        IndexOutOfBoundsException - 如果索引超出范围 (index < -1 || (certPath != null && index >= certPath.getCertificates().size())
        IllegalArgumentException - 如果 certPath是 null和 index不是-1
        NullPointerException - 如果 reason是 null
        从以下版本开始：
        1.7

    • 方法详细信息

      • getCertPath

        public CertPath getCertPath​()
        返回在抛出异常时验证的认证路径。
        结果
        的 CertPath （或当抛出异常正被验证的 null如果未指定）

      • getIndex

        public int getIndex​()
        返回导致异常抛出的证书路径中的证书的索引。 请注意， CertPath中的证书列表为零。 如果没有设置索引，则返回-1。
        结果
        已设置的索引，如果没有设置则为-1

      • getReason

        public CertPathValidatorException.Reason getReason​()
        返回验证失败的原因。 原因与getIndex()返回证书的索引有关。
        结果
        验证失败的原因，或 BasicReason.UNSPECIFIED如果没有指定原因
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathValidatorException.BasicReason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.security.cert

Enum CertPathValidatorException.BasicReason

  • java.lang.Object
    • java.lang.Enum<CertPathValidatorException.BasicReason>
      • java.security.cert.CertPathValidatorException.BasicReason
  • All Implemented Interfaces:
    Serializable ， Comparable<CertPathValidatorException.BasicReason> ， CertPathValidatorException.Reason
    Enclosing class:
    CertPathValidatorException

    public static enum CertPathValidatorException.BasicReason
extends Enum<CertPathValidatorException.BasicReason>
implements CertPathValidatorException.Reason
    BasicReason列举了任何类型的认证路径可能无效的潜在原因。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALGORITHM_CONSTRAINED
      公钥或签名算法已被约束。
      EXPIRED
      证书已过期。
      INVALID_SIGNATURE
      签名无效。
      NOT_YET_VALID
      证书尚未生效。
      REVOKED
      证书被撤销。
      UNDETERMINED_REVOCATION_STATUS
      证书的撤销状态无法确定。
      UNSPECIFIED
      不明原因

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static CertPathValidatorException.BasicReason valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CertPathValidatorException.BasicReason[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNSPECIFIED

        public static final CertPathValidatorException.BasicReason UNSPECIFIED
        不明原因

      • EXPIRED

        public static final CertPathValidatorException.BasicReason EXPIRED
        证书已过期。

      • NOT_YET_VALID

        public static final CertPathValidatorException.BasicReason NOT_YET_VALID
        证书尚未生效。

      • REVOKED

        public static final CertPathValidatorException.BasicReason REVOKED
        证书被撤销。

      • UNDETERMINED_REVOCATION_STATUS

        public static final CertPathValidatorException.BasicReason UNDETERMINED_REVOCATION_STATUS
        证书的撤销状态无法确定。

      • INVALID_SIGNATURE

        public static final CertPathValidatorException.BasicReason INVALID_SIGNATURE
        签名无效。

      • ALGORITHM_CONSTRAINED

        public static final CertPathValidatorException.BasicReason ALGORITHM_CONSTRAINED
        公钥或签名算法已被约束。

    • 方法详细信息

      • values

        public static CertPathValidatorException.BasicReason[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (CertPathValidatorException.BasicReason c : CertPathValidatorException.BasicReason.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static CertPathValidatorException.BasicReason valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


CertPathValidatorException.Reason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface CertPathValidatorException.Reason

  • All Superinterfaces:
    Serializable
    所有已知实现类：
    CertPathValidatorException.BasicReason ， PKIXReason
    Enclosing class:
    CertPathValidatorException

    public static interface CertPathValidatorException.Reason
extends Serializable
    验证算法失败的原因。
    从以下版本开始：
    1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathValidatorResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface CertPathValidatorResult

  • All Superinterfaces:
    Cloneable
    所有已知实现类：
    PKIXCertPathBuilderResult ， PKIXCertPathValidatorResult

    public interface CertPathValidatorResult
extends Cloneable
    认证路径验证器算法的结果的规范。

    该接口的目的是为所有认证路径验证器结果分组（并提供类型安全性）。 CertPathValidator.validate方法返回的所有结果都必须实现此接口。

    从以下版本开始：
    1.4
    另请参见：
    CertPathValidator

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object clone​()
      复制一份这个 CertPathValidatorResult 。

    • 方法详细信息

      • clone

        Object clone​()
        复制一份这个CertPathValidatorResult 。 副本的更改不会影响原始文件，反之亦然。
        结果
        这个 CertPathValidatorResult的副本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertPathValidatorSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertPathValidatorSpi

  • java.lang.Object
    • java.security.cert.CertPathValidatorSpi

  • public abstract class CertPathValidatorSpi
extends Object
    （ SPI ）为CertPathValidator类。 所有CertPathValidator实现都必须包括一个扩展此类（ CertPathValidatorSpi ）并实现其所有方法的类（SPI类）。 通常，这个类的实例只能通过CertPathValidator类访问。 有关详细信息，请参阅Java加密体系结构。

    并发访问

    不需要保护此类的实例，防止来自多个线程的并发访问。 需要同时访问一个CertPathValidatorSpi实例的线程之间应同步，并在调用包装CertPathValidator对象之前提供必要的锁定。

    然而， CertPathValidatorSpi实现可能仍然会遇到并发问题，因为每个操作不同的CertPathValidatorSpi实例的多个线程不需要同步。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertPathValidatorSpi​()
      默认构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      CertPathChecker engineGetRevocationChecker​()
      返回此实现用于检查证书的撤销状态的 CertPathChecker 。
      abstract CertPathValidatorResult engineValidate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertPathValidatorSpi

        public CertPathValidatorSpi​()
        默认构造函数。

    • 方法详细信息

      • engineValidate

        public abstract CertPathValidatorResult engineValidate​(CertPath certPath,
                                                       CertPathParameters params)
                                                throws CertPathValidatorException,
                                                       InvalidAlgorithmParameterException
        使用指定的算法参数集验证指定的认证路径。

        指定的CertPath必须是验证算法支持的类型，否则将抛出一个InvalidAlgorithmParameterException 。 例如， CertPathValidator实现该算法PKIX验证CertPath类型X.509的对象。

        参数
        certPath - 要验证的 CertPath
        params - 算法参数
        结果
        验证算法的结果
        异常
        CertPathValidatorException - 如果 CertPath没有验证
        InvalidAlgorithmParameterException - 如果指定的参数或指定的类型 CertPath不适合此 CertPathValidator

      • engineGetRevocationChecker

        public CertPathChecker engineGetRevocationChecker​()
        返回此实现用于检查证书的吊销状态的CertPathChecker 。 PKIX实现返回PKIXRevocationChecker类型的PKIXRevocationChecker 。

        此方法的主要目的是允许调用者指定额外的输入参数和特定于撤销检查的选项。 参见CertPathValidator的类描述。

        该方法被添加到Java Platform Standard Edition的1.8版本。 为了保持与现有服务提供商的向后兼容性，此方法不能是抽象的，默认情况下会抛出一个UnsupportedOperationException 。

        结果
        一个 CertPathChecker ，该实现用于检查证书的撤销状态
        异常
        UnsupportedOperationException - 如果不支持此方法
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface CertSelector

  • All Superinterfaces:
    Cloneable
    所有已知实现类：
    X509CertSelector

    public interface CertSelector
extends Cloneable
    一个选择器，用于定义一组选择Certificate的标准。 实现此接口的类通常用于指定Certificate检索CertStore 。

    并发访问

    除非另有说明，否则此界面中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    Certificate ， CertStore ， CertStore.getCertificates(java.security.cert.CertSelector)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object clone​()
      CertSelector这个 CertSelector 。
      boolean match​(Certificate cert)
      决定是否选择 Certificate 。

    • 方法详细信息

      • match

        boolean match​(Certificate cert)
        决定是否选择 Certificate 。
        参数
        cert - 要检查的 Certificate
        结果
        true如果 Certificate应选择， false否则

      • clone

        Object clone​()
        CertSelector这个CertSelector 。 副本的更改不会影响原始文件，反之亦然。
        结果
        这个 CertSelector的副本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertStore

  • java.lang.Object
    • java.security.cert.CertStore

  • public class CertStore
extends Object
    从存储库检索Certificate s和CRL s的类。

    这个类使用基于提供者的架构。 要创建一个CertStore ，请调用静态的getInstance方法之一，传递所需的类型为CertStore ，任何适用的初始化参数和可选的所需提供商的名称。

    一旦CertStore被创建，它可以被用来获取Certificate S和CRL通过调用以S getCertificates种getCRLs方法。

    与提供对私钥和受信任证书的缓存的访问的KeyStore不同， CertStore旨在提供对潜在的广泛的不受信任证书和CRL存储库的访问。 例如， CertStore的LDAP实现使用LDAP协议和RFC服务属性中定义的模式提供对存储在一个或多个目录中的证书和CRL的访问。

    Java平台的每个实现都需要支持以下标准CertStore类型：

    • Collection
    这种类型在Java安全标准算法名称规范的CertStore section中进行了描述。 请参阅发行说明文件以了解是否支持其他类型。

    并发访问

    CertStore对象的所有公共方法必须是线程安全的。 也就是说，多个线程可以在单个CertStore对象（或多个）上同时调用这些方法，而不会产生不良影响。 例如，这允许CertPathBuilder搜索CRL，同时搜索其他证书。

    该类的静态方法也保证线程安全。 多个线程可以同时调用此类中定义的静态方法，而不会产生不良影响。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CertStore​(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
      创建给定类型的 CertStore对象，并将给定的提供者实现（SPI对象）封装在其中。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Collection<? extends Certificate> getCertificates​(CertSelector selector)
      返回匹配指定选择器的 Collection的 Certificate 。
      CertStoreParameters getCertStoreParameters​()
      返回用于初始化 CertStore的参数。
      Collection<? extends CRL> getCRLs​(CRLSelector selector)
      返回匹配指定选择器的 Collection的 CRL 。
      static String getDefaultType​()
      返回 certstore.type安全属性指定的默认 CertStore类型，如果不存在此属性，则返回字符串“LDAP”。
      static CertStore getInstance​(String type, CertStoreParameters params)
      返回实现指定的 CertStore类型的 CertStore对象，并使用指定的参数进行初始化。
      static CertStore getInstance​(String type, CertStoreParameters params, String provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      static CertStore getInstance​(String type, CertStoreParameters params, Provider provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      Provider getProvider​()
      返回此 CertStore的提供者。
      String getType​()
      返回此 CertStore的类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertStore

        protected CertStore​(CertStoreSpi storeSpi,
                    Provider provider,
                    String type,
                    CertStoreParameters params)
        创建给定类型的 CertStore对象，并将给定的提供程序实现（SPI对象）封装在其中。
        参数
        storeSpi - 提供者实现
        provider - 提供商
        type - 类型
        params - 初始化参数（可能是 null ）

    • 方法详细信息

      • getCertificates

        public final Collection<? extends Certificate> getCertificates​(CertSelector selector)
                                                        throws CertStoreException
        返回匹配指定选择器的Collection的Certificate 。 如果Certificate与选择器匹配，则将返回一个空的Collection 。

        对于一些CertStore类型，结果Collection可能不包含与选择器匹配的所有 Certificate 。 例如，LDAP CertStore可能不会搜索目录中的所有条目。 相反，它可能只是搜索可能包含它正在寻找的Certificate的条目。

        一些CertStore实现（特别是LDAP CertStore ）可能会抛出一个CertStoreException除非提供了一个包含可用于查找证书的特定标准的非空CertSelector 。 发行人和/或主题名称是特别有用的标准。

        参数
        selector - A CertSelector用于选择应该返回哪些Certificate 。 指定null返回所有Certificate s（如果支持）。
        结果
        A Collection的 Certificate s匹配指定的选择器（从不 null ）
        异常
        CertStoreException - 如果发生异常

      • getCRLs

        public final Collection<? extends CRL> getCRLs​(CRLSelector selector)
                                        throws CertStoreException
        返回匹配指定选择器的Collection的CRL 。 如果没有CRL匹配选择器，将返回一个空的Collection 。

        对于一些CertStore类型，结果Collection可能不包含与选择器匹配的所有 CRL 。 例如，LDAP CertStore可能不搜索目录中的所有条目。 相反，它可能只是搜索可能包含它正在寻找的CRL的条目。

        一些CertStore实现（特别是LDAP CertStore ）可能会抛出一个CertStoreException除非提供了一个包含可用于查找CRL的特定标准的非空CRLSelector 。 发行人名称和/或要检查的证书特别有用。

        参数
        selector - A CRLSelector用于选择应该返回哪些CRL 。 指定null以返回所有CRL s（如果支持）。
        结果
        A Collection的 CRL s匹配指定的选择器（从不 null ）
        异常
        CertStoreException - 如果发生异常

      • getInstance

        public static CertStore getInstance​(String type,
                                    CertStoreParameters params)
                             throws InvalidAlgorithmParameterException,
                                    NoSuchAlgorithmException
        返回实现指定的CertStore类型的CertStore对象，并使用指定的参数进行初始化。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定类型的第一个Provider中封装CertStoreSpi实现的新CertStore对象。

        注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        返回的CertStore将使用指定的CertStoreParameters初始化。 所需参数的类型可能因不同类型的CertStore s而异。 请注意，指定的CertStoreParameters对象被克隆。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        type - 请求的名称CertStore类型。 有关标准类型的信息，请参阅Java Security Standard Algorithm Names Specification中的CertStore部分。
        params - 初始化参数（可以是 null ）。
        结果
        一个实现指定的 CertStore类型的 CertStore对象
        异常
        InvalidAlgorithmParameterException - 如果指定的初始化参数不适用于此 CertStore
        NoSuchAlgorithmException - 如果否 Provider支持指定类型的 CertStoreSpi实现
        NullPointerException - 如果 type是 null
        另请参见：
        Provider

      • getInstance

        public static CertStore getInstance​(String type,
                                    CertStoreParameters params,
                                    String provider)
                             throws InvalidAlgorithmParameterException,
                                    NoSuchAlgorithmException,
                                    NoSuchProviderException
        返回实现指定的CertStore类型的CertStore对象。

        返回从指定提供程序封装CertStoreSpi实现的新CertStore对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        返回的CertStore将使用指定的CertStoreParameters初始化。 所需参数的类型可能因不同类型的CertStore而异。 请注意，指定的CertStoreParameters对象被克隆。

        参数
        type - 请求的CertStore类型。 有关标准类型的信息，请参阅Java Security Standard Algorithm Names Specification中的CertStore部分。
        params - 初始化参数（可能为 null ）。
        provider - 提供商的名称。
        结果
        一个 CertStore实现指定类型的对象
        异常
        IllegalArgumentException - 如果 provider是 null或空
        InvalidAlgorithmParameterException - 如果指定的初始化参数不适用于此 CertStore
        NoSuchAlgorithmException - 如果指定类型的 CertStoreSpi实现不能从指定的提供者
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 type是 null
        另请参见：
        Provider

      • getInstance

        public static CertStore getInstance​(String type,
                                    CertStoreParameters params,
                                    Provider provider)
                             throws NoSuchAlgorithmException,
                                    InvalidAlgorithmParameterException
        返回实现指定的CertStore类型的CertStore对象。

        返回从指定的Provider对象封装CertStoreSpi实现的新CertStore对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        返回的CertStore将使用指定的CertStoreParameters初始化。 所需参数的类型可能因不同类型的CertStore而异。 请注意，指定的CertStoreParameters对象被克隆。

        参数
        type - 请求的CertStore类型。 有关标准类型的信息，请参阅Java Security Standard Algorithm Names Specification中的CertStore部分。
        params - 初始化参数（可能是 null ）。
        provider - 提供商。
        结果
        一个实现指定类型的 CertStore对象
        异常
        IllegalArgumentException - 如果 provider为空
        InvalidAlgorithmParameterException - 如果指定的初始化参数不适用于此 CertStore
        NoSuchAlgorithmException - 如果指定类型的一个 CertStoreSpi实现从指定的Provider对象不可用
        NullPointerException - 如果 type是 null
        另请参见：
        Provider

      • getCertStoreParameters

        public final CertStoreParameters getCertStoreParameters​()
        返回用于初始化CertStore的参数。 请注意， CertStoreParameters对象在返回之前被克隆。
        结果
        用于初始化这个 CertStore的参数（可能是 null ）

      • getType

        public final String getType​()
        返回此 CertStore的类型。
        结果
        这种类型的 CertStore

      • getProvider

        public final Provider getProvider​()
        返回此 CertStore的提供者。
        结果
        这个 CertStore的提供者

      • getDefaultType

        public static final String getDefaultType​()
        返回由certstore.type安全属性指定的默认CertStore类型，如果没有此类属性，则返回字符串“LDAP”。

        默认的CertStore类型可以由不想在使用getInstance方法时使用硬编码类型的应用程序使用，并且要提供默认的CertStore类型，以防用户未指定自己的。

        通过将certstore.type安全属性的值设置为CertStore类型，可以更改默认值certstore.type类型。

        结果
        由 certstore.type安全属性指定的默认 CertStore类型，如果没有此类属性，则为字符串“LDAP”。
        另请参见：
        security properties
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertStoreException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertStoreException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertStoreException
  • All Implemented Interfaces:
    Serializable

    public class CertStoreException
extends GeneralSecurityException
    一个例外，指出从CertStore检索证书和CRL的各种问题CertStore 。

    A CertStoreException提供对包装异常的支持。 getCause方法返回引发此异常抛出的throwable（如果有）。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertStore ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertStoreException​()
      创建 CertStoreException与 null作为其详细消息。
      CertStoreException​(String msg)
      使用给定的详细信息创建一个 CertStoreException 。
      CertStoreException​(String msg, Throwable cause)
      创建一个 CertStoreException与指定的详细信息和原因。
      CertStoreException​(Throwable cause)
      创建一个包裹指定的throwable的 CertStoreException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CertStoreException

        public CertStoreException​()
        创建一个 CertStoreException作为其详细信息 null 。

      • CertStoreException

        public CertStoreException​(String msg)
        使用给定的详细信息创建一个CertStoreException 。 详细信息是描述这个特殊异常的String 。
        参数
        msg - 详细信息

      • CertStoreException

        public CertStoreException​(Throwable cause)
        创建一个包裹指定的throwable的CertStoreException 。 这允许将任何异常转换为CertStoreException ，同时保留有关原因的信息，这可能对调试有用。 详细消息设置为（ cause==null ? null : cause.toString() ）（其通常包含原因的类和详细消息）。
        参数
        cause - 原因（保存以供getCause()方法稍后检索）。 （允许A null值，并表示原因不存在或未知。）

      • CertStoreException

        public CertStoreException​(String msg,
                          Throwable cause)
        创建一个 CertStoreException具有指定的详细信息和原因。
        参数
        msg - 详细信息
        cause - 原因（由getCause()方法保存供以后检索）。 （允许值为null ，表示原因不存在或未知。）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertStoreParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface CertStoreParameters

  • All Superinterfaces:
    Cloneable
    所有已知实现类：
    CollectionCertStoreParameters ， LDAPCertStoreParameters ， URICertStoreParameters

    public interface CertStoreParameters
extends Cloneable
    一个规格为CertStore参数。

    该接口的目的是为所有CertStore参数规范进行分组（并提供类型安全性）。 所有CertStore参数规范都必须实现这个接口。

    通常，将CertStoreParameters对象作为参数传递给CertStore.getInstance方法之一。 getInstance方法返回一个CertStore ，用于检索Certificate s和CRL s。 返回的CertStore将使用指定的参数进行初始化。 所需的参数类型可能因不同类型的CertStore而异。

    从以下版本开始：
    1.4
    另请参见：
    CertStore.getInstance(java.lang.String, java.security.cert.CertStoreParameters)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object clone​()
      复制这份 CertStoreParameters 。

    • 方法详细信息

      • clone

        Object clone​()
        做一个这个CertStoreParameters的副本。

        “复制”的确切含义可能取决于CertStoreParameters对象的类别。 一个典型的实现执行这个对象的“深层复制”，但这不是绝对的要求。 一些实现可以执行该对象的一些或所有字段的“浅拷贝”。

        请注意， CertStore.getInstance方法制作了指定的CertStoreParameters的副本。 clone深层拷贝实现更安全，更健壮，因为它阻止了呼叫者通过随后修改其初始化参数的内容来破坏共享的CertStore 。 然而， clone的浅拷贝实现更适合于需要保存对包含在CertStoreParameters的参数的CertStoreParameters 。 例如，浅拷贝克隆允许应用程序立即释放特定CertStore初始化参数的资源，而不是等待垃圾回收机制。 这应该非常小心，因为CertStore可能仍然被其他线程使用。

        每个子类应该说明这种方法的确切行为，以便用户和开发人员知道预期。

        结果
        这个 CertStoreParameters的副本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CertStoreSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CertStoreSpi

  • java.lang.Object
    • java.security.cert.CertStoreSpi

  • public abstract class CertStoreSpi
extends Object
    （ SPI ）为CertStore类。 所有CertStore实现都必须包含扩展此类（ CertStoreSpi ）的类（SPI类），为具有类型为CertStoreParameters的单个参数提供构造函数，并实现其所有方法。 一般来说，这个类的实例只能通过CertStore类访问。 有关详细信息，请参阅Java加密体系结构。

    并发访问

    所有CertStoreSpi对象的公共方法必须是线程安全的。 也就是说，多个线程可以在单个CertStoreSpi对象（或多个）上同时调用这些方法，而不会产生不良影响。 例如，这允许CertPathBuilder搜索CRL同时搜索其他证书。

    简单的CertStoreSpi实现可能会通过向其engineGetCertificates和engineGetCRLs方法添加一个synchronized关键字来确保线程安全。 更复杂的可能允许真正的并发访问。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      CertStoreSpi​(CertStoreParameters params)
      唯一的建设者。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Collection<? extends Certificate> engineGetCertificates​(CertSelector selector)
      返回匹配指定选择器的 Collection的 Certificate 。
      abstract Collection<? extends CRL> engineGetCRLs​(CRLSelector selector)
      返回匹配指定选择器的 Collection的 CRL 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertStoreSpi

        public CertStoreSpi​(CertStoreParameters params)
             throws InvalidAlgorithmParameterException
        唯一的建设者。
        参数
        params - 初始化参数（可以是 null ）
        异常
        InvalidAlgorithmParameterException - 如果初始化参数不适合这个 CertStoreSpi

    • 方法详细信息

      • engineGetCertificates

        public abstract Collection<? extends Certificate> engineGetCertificates​(CertSelector selector)
                                                                 throws CertStoreException
        返回匹配指定选择器的Collection的Certificate 。 如果没有Certificate匹配选择器，将返回一个空的Collection 。

        对于大约CertStore类型，产生的Collection可能不包含与选择器匹配的所有 Certificate 。 例如，LDAP CertStore可能不会搜索目录中的所有条目。 相反，它可能只是搜索可能包含它正在寻找的Certificate的条目。

        一些CertStore实现（特别是LDAP CertStore ）可以抛出CertStoreException除非提供了包括可用于查找证书的特定标准的非空CertSelector 。 发行人和/或主题名称是特别有用的标准。

        参数
        selector - A CertSelector用于选择应该返回哪些Certificate 。 指定null以返回所有Certificate （如果支持）。
        结果
        A Collection的 Certificate s匹配指定的选择器（从不 null ）
        异常
        CertStoreException - 如果发生异常

      • engineGetCRLs

        public abstract Collection<? extends CRL> engineGetCRLs​(CRLSelector selector)
                                                 throws CertStoreException
        返回匹配指定选择器的Collection的CRL 。 如果CRL与选择器匹配，则将返回一个空的Collection 。

        对于大约CertStore类型，结果Collection可能不包含与选择器匹配的所有 CRL 。 例如，LDAP CertStore可能不会搜索目录中的所有条目。 相反，它可能只是搜索可能包含它正在寻找的CRL的条目。

        一些CertStore实现（特别是LDAP CertStore ）可以抛出CertStoreException除非提供了包括可用于查找CRL的特定标准的非空CRLSelector 。 发行人名称和/或要检查的证书特别有用。

        参数
        selector - A CRLSelector用于选择应该返回哪些CRL 。 指定null返回所有CRL s（如果支持）。
        结果
        A Collection的 CRL s匹配指定的选择器（从不 null ）
        异常
        CertStoreException - 如果发生异常
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CollectionCertStoreParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CollectionCertStoreParameters

  • java.lang.Object
    • java.security.cert.CollectionCertStoreParameters
  • All Implemented Interfaces:
    Cloneable ， CertStoreParameters

    public class CollectionCertStoreParameters
extends Object
implements CertStoreParameters
    参数用作集合CertStore算法的输入。

    该类用于为集合CertStore算法的实现提供必要的配置参数。 此类包含的唯一参数是Collection ，其中CertStore将从中检索证书和CRL。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    Collection ， CertStore

    • 构造方法摘要

      构造方法
      Constructor 描述
      CollectionCertStoreParameters​()
      使用默认参数值创建一个 CollectionCertStoreParameters的实例（一个空 Collection ）。
      CollectionCertStoreParameters​(Collection<?> collection)
      创建一个 CollectionCertStoreParameters的实例，这将允许从指定的 Collection检索证书和CRL。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      返回此对象的副本。
      Collection<?> getCollection​()
      返回 Collection ， Certificate检索到 Certificate s和 CRL 。
      String toString​()
      返回描述参数的格式化字符串。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CollectionCertStoreParameters

        public CollectionCertStoreParameters​(Collection<?> collection)
        创建一个CollectionCertStoreParameters的实例，这将允许从指定的Collection检索证书和CRL。 如果指定的Collection包含不是Certificate或CRL的对象，则该对象将被集合CertStore忽略。

        Collection 未被复制。 相反，使用引用。 这允许调用方随后添加或删除Certificates或者CRL从S Collection ，从而改变了一套Certificates或者CRL可供系列S CertStore 。 收集CertStore不会修改的内容Collection 。

        如果Collection将被一个线程修改，而另一个线程正在调用已使用该Collection初始化的集合CertStore的方法，那么Collection必须具有故障快速迭代器。

        参数
        collection - a Collection的 Certificate s和 CRL s
        异常
        NullPointerException - 如果 collection是 null

      • CollectionCertStoreParameters

        public CollectionCertStoreParameters​()
        使用默认参数值创建一个 CollectionCertStoreParameters的实例（一个空 Collection ）。

    • 方法详细信息

      • getCollection

        public Collection<?> getCollection​()
        返回Collection ， Certificate检索到Certificate s和CRL 。 这不是 Collection的副本，它是一个参考。 这允许调用方随后添加或删除Certificates或者CRL从S Collection 。
        结果
        Collection （从不null）

      • clone

        public Object clone​()
        返回此对象的副本。 请注意，仅对Collection的引用进行复制，而不是内容。
        Specified by:
        clone在接口 CertStoreParameters
        重写：
        clone在 Object
        结果
        副本
        另请参见：
        Cloneable

      • toString

        public String toString​()
        返回描述参数的格式化字符串。
        重写：
        toString在 Object
        结果
        描述参数的格式化字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CRL (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CRL

  • java.lang.Object
    • java.security.cert.CRL
  • 已知直接子类：
    X509CRL

    public abstract class CRL
extends Object
    该类是具有不同格式但重要常见用途的证书吊销列表（CRL）的抽象。 例如，所有CRL共享列出撤销证书的功能，可以查询是否列出给定的证书。

    专门的CRL类型可以通过对这个抽象类进行子类化来定义。

    从以下版本开始：
    1.2
    另请参见：
    X509CRL ， CertificateFactory

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CRL​(String type)
      创建指定类型的CRL。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      String getType​()
      返回此CRL的类型。
      abstract boolean isRevoked​(Certificate cert)
      检查给定的证书是否在此CRL上。
      abstract String toString​()
      返回此CRL的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CRL

        protected CRL​(String type)
        创建指定类型的CRL。
        参数
        type - CRL类型的标准名称。 有关标准CRL类型的信息，请参阅Java Security Standard Algorithm Names文档。

    • 方法详细信息

      • getType

        public final String getType​()
        返回此CRL的类型。
        结果
        这种CRL的类型。

      • toString

        public abstract String toString​()
        返回此CRL的字符串表示形式。
        重写：
        toString在 Object
        结果
        此CRL的字符串表示形式。

      • isRevoked

        public abstract boolean isRevoked​(Certificate cert)
        检查给定的证书是否在此CRL上。
        参数
        cert - 检查证书。
        结果
        如果给定的证书在此CRL上，则为true，否则为false。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CRLException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class CRLException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CRLException
  • All Implemented Interfaces:
    Serializable

    public class CRLException
extends GeneralSecurityException
    CRL（证书撤销列表）异常。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CRLException​()
      构造一个没有详细消息的CRLException。
      CRLException​(String message)
      构造具有指定详细消息的CRLException。
      CRLException​(String message, Throwable cause)
      创建一个 CRLException与指定的详细信息和原因。
      CRLException​(Throwable cause)
      创建 CRLException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CRLException

        public CRLException​()
        构造一个没有详细消息的CRLException。 详细消息是描述此特定异常的字符串。

      • CRLException

        public CRLException​(String message)
        构造具有指定详细消息的CRLException。 详细消息是描述此特定异常的字符串。
        参数
        message - 详细信息。

      • CRLException

        public CRLException​(String message,
                    Throwable cause)
        创建一个 CRLException具有指定的详细信息和原因。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法后续检索）。 （A null允许值，表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • CRLException

        public CRLException​(Throwable cause)
        创建 CRLException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null允许值，表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CRLReason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.security.cert

Enum CRLReason

  • java.lang.Object
    • java.lang.Enum<CRLReason>
      • java.security.cert.CRLReason
  • All Implemented Interfaces:
    Serializable ， Comparable<CRLReason>

    public enum CRLReason
extends Enum<CRLReason>
    CRLReason枚举指定证书被撤销的原因，如 RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile中所定义。
    从以下版本开始：
    1.7
    另请参见：
    X509CRLEntry.getRevocationReason() ， CertificateRevokedException.getRevocationReason()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      AA_COMPROMISE
      这个原因表明已知或怀疑证书对象的私钥已经被泄密。
      AFFILIATION_CHANGED
      这个原因表明主题的名称或其他信息已经改变。
      CA_COMPROMISE
      这个原因表明已知或怀疑证书对象的私钥已经被泄密。
      CERTIFICATE_HOLD
      这个原因表明证书已被搁置。
      CESSATION_OF_OPERATION
      这个原因表明证书不再需要了。
      KEY_COMPROMISE
      这个原因表明已知或怀疑证书对象的私钥已经被泄密。
      PRIVILEGE_WITHDRAWN
      这个原因表明授予证书主体的特权已被撤回。
      REMOVE_FROM_CRL
      这个原因表明证书以前被暂停，应该从CRL中删除。
      SUPERSEDED
      这个原因表明证书已被取代。
      UNSPECIFIED
      这个原因表明，为什么证书被撤销是不明确的。
      UNUSED
      没用的原因

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static CRLReason valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CRLReason[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNSPECIFIED

        public static final CRLReason UNSPECIFIED
        这个原因表明，为什么证书被撤销是不明确的。

      • KEY_COMPROMISE

        public static final CRLReason KEY_COMPROMISE
        这个原因表明已知或怀疑证书对象的私钥已经被泄密。 它仅适用于最终实体证书。

      • CA_COMPROMISE

        public static final CRLReason CA_COMPROMISE
        这个原因表明已知或怀疑证书对象的私钥已经被泄密。 它仅适用于证书颁发机构（CA）证书。

      • AFFILIATION_CHANGED

        public static final CRLReason AFFILIATION_CHANGED
        这个原因表明主题的名称或其他信息已经改变。

      • SUPERSEDED

        public static final CRLReason SUPERSEDED
        这个原因表明证书已被取代。

      • CESSATION_OF_OPERATION

        public static final CRLReason CESSATION_OF_OPERATION
        这个原因表明证书不再需要了。

      • CERTIFICATE_HOLD

        public static final CRLReason CERTIFICATE_HOLD
        这个原因表明证书已被搁置。

      • UNUSED

        public static final CRLReason UNUSED
        没用的原因

      • REMOVE_FROM_CRL

        public static final CRLReason REMOVE_FROM_CRL
        这个原因表明证书以前被暂停，应该从CRL中删除。 它用于delta CRL。

      • PRIVILEGE_WITHDRAWN

        public static final CRLReason PRIVILEGE_WITHDRAWN
        这个原因表明授予证书主体的特权已被撤回。

      • AA_COMPROMISE

        public static final CRLReason AA_COMPROMISE
        这个原因表明已知或怀疑证书对象的私钥已经被泄密。 它仅适用于权限属性（AA）证书。

    • 方法详细信息

      • values

        public static CRLReason[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (CRLReason c : CRLReason.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static CRLReason valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


CRLSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface CRLSelector

  • All Superinterfaces:
    Cloneable
    所有已知实现类：
    X509CRLSelector

    public interface CRLSelector
extends Cloneable
    一个选择器，用于定义一组选择CRL的标准。 实现此接口的类通常用于指定CRL检索CertStore 。

    并发访问

    除非另有说明，否则此界面中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CRL ， CertStore ， CertStore.getCRLs(java.security.cert.CRLSelector)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object clone​()
      复制一份这个 CRLSelector 。
      boolean match​(CRL crl)
      决定是否选择 CRL 。

    • 方法详细信息

      • match

        boolean match​(CRL crl)
        决定是否选择 CRL 。
        参数
        crl - 要检查的 CRL
        结果
        true如果 CRL应选择， false否则

      • clone

        Object clone​()
        复制一份这个CRLSelector 。 副本的更改不会影响原始文件，反之亦然。
        结果
        这个 CRLSelector的副本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Extension (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface Extension

  • public interface Extension
    此接口表示X.509扩展。

    扩展提供了一种将附加属性与用户或公钥相关联并用于管理认证层次结构的方法。 扩展格式还允许社区定义私人扩展以携带这些社区独有的信息。

    每个扩展包含对象标识符，指示其是关键还是非关键扩展的临界性设置，以及ASN.1 DER编码值。 其ASN.1的定义是：

      Extension ::= SEQUENCE {
         extnId        OBJECT IDENTIFIER,
         critical      BOOLEAN DEFAULT FALSE,
         extnValue     OCTET STRING
                 -- contains a DER encoding of a value
                 -- of the type registered for use with
                 -- the extnId object identifier value
     }

    该接口旨在提供对单个扩展的访问，而不像X509Extension更适合访问一组扩展。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void encode​(OutputStream out)
      生成扩展的DER编码，并将其写入输出流。
      String getId​()
      获取扩展的对象标识符。
      byte[] getValue​()
      获取扩展程序的DER编码值。
      boolean isCritical​()
      获取扩展的临界值设置。

    • 方法详细信息

      • getId

        String getId​()
        获取扩展的对象标识符。
        结果
        对象标识符作为字符串

      • isCritical

        boolean isCritical​()
        获取扩展的临界值设置。
        结果
        如果这是一个关键的扩展，则为true。

      • getValue

        byte[] getValue​()
        获取扩展程序的DER编码值。 注意，这是编码为OCTET STRING的字节。 它不包括OCTET STRING标签和长度。
        结果
        扩展值的副本，如果没有扩展值， null 。

      • encode

        void encode​(OutputStream out)
     throws IOException
        生成扩展的DER编码，并将其写入输出流。
        参数
        out - 输出流
        异常
        IOException - 编码或输出错误。
        NullPointerException - 如果 out是 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.security.cert (Java SE 9 & JDK 9 )

java.security.cert

Interfaces

  • CertPathBuilderResult
  • CertPathChecker
  • CertPathParameters
  • CertPathValidatorException.Reason
  • CertPathValidatorResult
  • CertSelector
  • CertStoreParameters
  • CRLSelector
  • Extension
  • PolicyNode
  • X509Extension

Classes

  • Certificate
  • Certificate.CertificateRep
  • CertificateFactory
  • CertificateFactorySpi
  • CertPath
  • CertPath.CertPathRep
  • CertPathBuilder
  • CertPathBuilderSpi
  • CertPathValidator
  • CertPathValidatorSpi
  • CertStore
  • CertStoreSpi
  • CollectionCertStoreParameters
  • CRL
  • LDAPCertStoreParameters
  • PKIXBuilderParameters
  • PKIXCertPathBuilderResult
  • PKIXCertPathChecker
  • PKIXCertPathValidatorResult
  • PKIXParameters
  • PKIXRevocationChecker
  • PolicyQualifierInfo
  • TrustAnchor
  • URICertStoreParameters
  • X509Certificate
  • X509CertSelector
  • X509CRL
  • X509CRLEntry
  • X509CRLSelector

Enums

  • CertPathValidatorException.BasicReason
  • CRLReason
  • PKIXReason
  • PKIXRevocationChecker.Option

Exceptions

  • CertificateEncodingException
  • CertificateException
  • CertificateExpiredException
  • CertificateNotYetValidException
  • CertificateParsingException
  • CertificateRevokedException
  • CertPathBuilderException
  • CertPathValidatorException
  • CertStoreException
  • CRLException


java.security.cert (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.security.cert

提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。 它包含对X.509 v3证书和X.509 v2 CRL的支持。

包装规格

  • Java Cryptography Architecture (JCA) Reference Guide
  • RFC 5280：Internet X.509公共密钥基础设施证书和证书吊销列表（CRL）配置文件
  • RFC 2560：X.509 Internet公钥基础设施在线证书状态协议 - OCSP
  • Java Security Standard Algorithm Names Specification

相关文档

有关X.509证书和CRL的信息，请参阅：
  • http://www.ietf.org/rfc/rfc5280.txt
  • Java PKI Programmer's Guide
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    CertPathBuilderResult
    认证路径构建器算法的结果的规范。
    CertPathChecker
    对每个 Certificate执行一个或多个检查 CertPath 。
    CertPathParameters
    认证路径算法参数的规范。
    CertPathValidatorException.Reason
    验证算法失败的原因。
    CertPathValidatorResult
    认证路径验证器算法的结果的规范。
    CertSelector
    一个选择器，定义了一组选择 Certificate的标准。
    CertStoreParameters
    规格参数 CertStore 。
    CRLSelector
    一个选择器，用于定义一组选择 CRL的标准。
    Extension
    此接口表示X.509扩展。
    PolicyNode
    由PKIX认证路径验证算法定义的不可变的有效策略树节点。
    X509Extension
    X509扩展接口。
  • 类摘要
    Class 描述
    Certificate
    用于管理各种身份证件的抽象类。
    Certificate.CertificateRep
    用于序列化的替代证书类。
    CertificateFactory
    该类定义了证书工厂的功能，用于从其编码生成证书，认证路径（ CertPath ）和证书吊销列表（CRL）对象。
    CertificateFactorySpi
    该类定义了 CertificateFactory类的 （ SPI ）。
    CertPath
    证书的不可变序列（认证路径）。
    CertPath.CertPathRep
    候补 CertPath类用于序列化。
    CertPathBuilder
    建立认证路径（也称为证书链）的课程。
    CertPathBuilderSpi
    （ SPI ）为CertPathBuilder类。
    CertPathValidator
    用于验证认证路径（也称为证书链）的类。
    CertPathValidatorSpi
    （ SPI ）为CertPathValidator类。
    CertStore
    从存储库检索 Certificate s和 CRL s的类。
    CertStoreSpi
    （ SPI ）为CertStore类。
    CollectionCertStoreParameters
    参数用作集合 CertStore算法的输入。
    CRL
    该类是具有不同格式但重要常见用途的证书吊销列表（CRL）的抽象。
    LDAPCertStoreParameters
    参数用作LDAP CertStore算法的输入。
    PKIXBuilderParameters
    参数用作PKIX CertPathBuilder算法的输入。
    PKIXCertPathBuilderResult
    此类表示PKIX认证路径构建器算法的成功结果。
    PKIXCertPathChecker
    对 X509Certificate执行一个或多个检查的抽象类。
    PKIXCertPathValidatorResult
    该类代表PKIX认证路径验证算法的成功结果。
    PKIXParameters
    参数用作PKIX CertPathValidator算法的输入。
    PKIXRevocationChecker
    A PKIXCertPathChecker用于使用PKIX算法检查证书的撤销状态。
    PolicyQualifierInfo
    由ASN.1 PolicyQualifierInfo结构表示的不可变策略限定符。
    TrustAnchor
    信任锚或最受信任的证书颁发机构（CA）。
    URICertStoreParameters
    用作 CertStore算法的输入的参数，其使用URI中包含的信息来检索证书和CRL。
    X509Certificate
    X.509证书的抽象类。
    X509CertSelector
    A CertSelector选择符合所有指定条件的 X509Certificates 。
    X509CRL
    X.509证书撤销列表（CRL）的抽象类。
    X509CRLEntry
    CRL（证书撤销列表）中撤销证书的抽象类。
    X509CRLSelector
    A CRLSelector选择符合所有指定条件的 X509CRLs 。
  • 枚举摘要
    Enum 描述
    CertPathValidatorException.BasicReason
    BasicReason列举了任何类型的认证路径可能无效的潜在原因。
    CRLReason
    CRLReason枚举指定了撤销证书的原因，如 RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile中所定义。
    PKIXReason
    PKIXReason列举了根据PKIX（RFC 5280）标准，X.509认证路径可能无效的潜在PKIX特定原因。
    PKIXRevocationChecker.Option
    可以为吊销检查机制指定的各种撤销选项。
  • 异常摘要
    异常 描述
    CertificateEncodingException
    证书编码异常。
    CertificateException
    此异常表示各种证书问题之一。
    CertificateExpiredException
    证书过期例外
    CertificateNotYetValidException
    证书还没有有效的例外。
    CertificateParsingException
    证书解析异常。
    CertificateRevokedException
    表示X.509证书的异常被撤销。
    CertPathBuilderException
    一个例外，指出使用 CertPathBuilder构建认证路径时遇到的各种问题 CertPathBuilder 。
    CertPathValidatorException
    表示验证认证路径时遇到的各种问题之一的异常。
    CertStoreException
    一个例外，指出从 CertStore检索证书和CRL的各种问题 CertStore 。
    CRLException
    CRL (Certificate Revocation List) Exception.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.security.cert Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.security.cert

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.security.cert.Certificate (implements java.io.Serializable)
      • java.security.cert.X509Certificate (implements java.security.cert.X509Extension)
    • java.security.cert.Certificate.CertificateRep (implements java.io.Serializable)
    • java.security.cert.CertificateFactory
    • java.security.cert.CertificateFactorySpi
    • java.security.cert.CertPath (implements java.io.Serializable)
    • java.security.cert.CertPath.CertPathRep (implements java.io.Serializable)
    • java.security.cert.CertPathBuilder
    • java.security.cert.CertPathBuilderSpi
    • java.security.cert.CertPathValidator
    • java.security.cert.CertPathValidatorSpi
    • java.security.cert.CertStore
    • java.security.cert.CertStoreSpi
    • java.security.cert.CollectionCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • java.security.cert.CRL
      • java.security.cert.X509CRL (implements java.security.cert.X509Extension)
    • java.security.cert.LDAPCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • java.security.cert.PKIXCertPathChecker (implements java.security.cert.CertPathChecker, java.lang.Cloneable)
      • java.security.cert.PKIXRevocationChecker
    • java.security.cert.PKIXCertPathValidatorResult (implements java.security.cert.CertPathValidatorResult)
      • java.security.cert.PKIXCertPathBuilderResult (implements java.security.cert.CertPathBuilderResult)
    • java.security.cert.PKIXParameters (implements java.security.cert.CertPathParameters)
      • java.security.cert.PKIXBuilderParameters
    • java.security.cert.PolicyQualifierInfo
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.security.GeneralSecurityException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateEncodingException
            • java.security.cert.CertificateExpiredException
            • java.security.cert.CertificateNotYetValidException
            • java.security.cert.CertificateParsingException
            • java.security.cert.CertificateRevokedException
          • java.security.cert.CertPathBuilderException
          • java.security.cert.CertPathValidatorException
          • java.security.cert.CertStoreException
          • java.security.cert.CRLException
    • java.security.cert.TrustAnchor
    • java.security.cert.URICertStoreParameters (implements java.security.cert.CertStoreParameters)
    • java.security.cert.X509CertSelector (implements java.security.cert.CertSelector)
    • java.security.cert.X509CRLEntry (implements java.security.cert.X509Extension)
    • java.security.cert.X509CRLSelector (implements java.security.cert.CRLSelector)

Interface Hierarchy

  • java.security.cert.CertPathChecker
  • java.lang.Cloneable
    • java.security.cert.CertPathBuilderResult
    • java.security.cert.CertPathParameters
    • java.security.cert.CertPathValidatorResult
    • java.security.cert.CertSelector
    • java.security.cert.CertStoreParameters
    • java.security.cert.CRLSelector
  • java.security.cert.Extension
  • java.security.cert.PolicyNode
  • java.io.Serializable
    • java.security.cert.CertPathValidatorException.Reason
  • java.security.cert.X509Extension

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.security.cert.CertPathValidatorException.BasicReason (implements java.security.cert.CertPathValidatorException.Reason)
      • java.security.cert.CRLReason
      • java.security.cert.PKIXReason (implements java.security.cert.CertPathValidatorException.Reason)
      • java.security.cert.PKIXRevocationChecker.Option
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LDAPCertStoreParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class LDAPCertStoreParameters

  • java.lang.Object
    • java.security.cert.LDAPCertStoreParameters
  • All Implemented Interfaces:
    Cloneable ， CertStoreParameters

    public class LDAPCertStoreParameters
extends Object
implements CertStoreParameters
    参数用作LDAP CertStore算法的输入。

    此类用于为LDAP CertStore算法的实现提供必要的配置参数（服务器名称和端口号）。 但是，如果要从RFC 5280指定的ldap URI中检索证书或CRL，请使用URICertStoreParameters，因为URI可能包含其他信息，例如可识别名称，这将有助于LDAP CertStore查找特定的证书和CRL。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertStore

    • 构造方法摘要

      构造方法
      Constructor 描述
      LDAPCertStoreParameters​()
      使用默认参数值（服务器名“localhost”，端口389）创建一个 LDAPCertStoreParameters的实例。
      LDAPCertStoreParameters​(String serverName)
      使用指定的服务器名称创建一个 LDAPCertStoreParameters的实例，默认端口为389。
      LDAPCertStoreParameters​(String serverName, int port)
      使用指定的参数值创建一个 LDAPCertStoreParameters的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      返回此对象的副本。
      int getPort​()
      返回LDAP服务器的端口号。
      String getServerName​()
      返回LDAP服务器的DNS名称。
      String toString​()
      返回描述参数的格式化字符串。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LDAPCertStoreParameters

        public LDAPCertStoreParameters​(String serverName,
                               int port)
        使用指定的参数值创建一个 LDAPCertStoreParameters的实例。
        参数
        serverName - LDAP服务器的DNS名称
        port - LDAP服务器的端口号
        异常
        NullPointerException - 如果 serverName是 null

      • LDAPCertStoreParameters

        public LDAPCertStoreParameters​(String serverName)
        使用指定的服务器名称创建一个 LDAPCertStoreParameters的实例，默认端口为389。
        参数
        serverName - LDAP服务器的DNS名称
        异常
        NullPointerException - 如果 serverName是 null

      • LDAPCertStoreParameters

        public LDAPCertStoreParameters​()
        使用默认参数值（服务器名“localhost”，端口389）创建 LDAPCertStoreParameters的实例。

    • 方法详细信息

      • getServerName

        public String getServerName​()
        返回LDAP服务器的DNS名称。
        结果
        的名字（不是 null ）

      • getPort

        public int getPort​()
        返回LDAP服务器的端口号。
        结果
        端口号

      • clone

        public Object clone​()
        返回此对象的副本。 副本的更改不会影响原始文件，反之亦然。

        注意：此方法目前执行对象的浅拷贝（简单地调用Object.clone() ）。 如果添加了不应该共享的新参数，这可能会在将来的版本中更改，以执行深层复制。

        Specified by:
        clone在接口 CertStoreParameters
        重写：
        clone在类 Object
        结果
        副本
        另请参见：
        Cloneable

      • toString

        public String toString​()
        返回描述参数的格式化字符串。
        重写：
        toString在 Object
        结果
        a formatted string describing the parameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PKIXBuilderParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class PKIXBuilderParameters

  • java.lang.Object
    • java.security.cert.PKIXParameters
      • java.security.cert.PKIXBuilderParameters
  • All Implemented Interfaces:
    Cloneable ， CertPathParameters

    public class PKIXBuilderParameters
extends PKIXParameters
    参数用作PKIX CertPathBuilder算法的输入。

    一个PKIX CertPathBuilder使用这些参数到build一个CertPath ，已经根据PKIX认证路径验证算法进行了验证。

    要实例化一个PKIXBuilderParameters对象，应用程序必须指定由PKIX认证路径验证算法定义的一个或多个最受信任的CA。 最可靠的CA可以使用两个构造函数之一来指定。 一个应用程序可以调用PKIXBuilderParameters(Set, CertSelector) ，指定一个Set的TrustAnchor对象，每个对象都标识最受信任的CA。 或者，应用程序可以调用PKIXBuilderParameters(KeyStore, CertSelector) ，指定包含可信证书条目的KeyStore实例，每个实例将被视为最受信任的CA。

    另外，应用程序必须指定CertPathBuilder将尝试构建路径的目标证书的约束。 约束被指定为CertSelector对象。 这些约束应提供CertPathBuilder足够的搜索条件来查找目标证书。 X509Certificate最小标准通常包括主题名称和/或一个或多个主题替代名称。 如果没有指定足够的条件，那么CertPathBuilder可能会抛出一个CertPathBuilderException 。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertPathBuilder

    • 构造方法摘要

      构造方法
      Constructor 描述
      PKIXBuilderParameters​(KeyStore keystore, CertSelector targetConstraints)
      创建一个 PKIXBuilderParameters的实例，它从指定的 KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。
      PKIXBuilderParameters​(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
      使用指定的 Set最受信任的CA创建 PKIXBuilderParameters的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getMaxPathLength​()
      返回证书路径中可能存在的中间非自颁发证书的最大数量的值。
      void setMaxPathLength​(int maxPathLength)
      设置认证路径中可能存在的非自发中间证书的最大数量的值。
      String toString​()
      返回描述参数的格式化字符串。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.cert.PKIXParameters

        addCertPathChecker, addCertStore, clone, getCertPathCheckers, getCertStores, getDate, getInitialPolicies, getPolicyQualifiersRejected, getSigProvider, getTargetCertConstraints, getTrustAnchors, isAnyPolicyInhibited, isExplicitPolicyRequired, isPolicyMappingInhibited, isRevocationEnabled, setAnyPolicyInhibited, setCertPathCheckers, setCertStores, setDate, setExplicitPolicyRequired, setInitialPolicies, setPolicyMappingInhibited, setPolicyQualifiersRejected, setRevocationEnabled, setSigProvider, setTargetCertConstraints, setTrustAnchors

    • 构造方法详细信息

      • PKIXBuilderParameters

        public PKIXBuilderParameters​(Set<TrustAnchor> trustAnchors,
                             CertSelector targetConstraints)
                      throws InvalidAlgorithmParameterException
        使用指定的Set最受信任的CA创建PKIXBuilderParameters的实例。 该集合的每个元素是一个TrustAnchor 。

        请注意， Set被复制以防止后续修改。

        参数
        trustAnchors - a Set of TrustAnchor s
        targetConstraints - 一个 CertSelector指定目标证书上的约束
        异常
        InvalidAlgorithmParameterException - 如果 trustAnchors为空 (trustAnchors.isEmpty() == true)
        NullPointerException - 如果 trustAnchors是 null
        ClassCastException -如果任何的元件的 trustAnchors类型不是 java.security.cert.TrustAnchor

      • PKIXBuilderParameters

        public PKIXBuilderParameters​(KeyStore keystore,
                             CertSelector targetConstraints)
                      throws KeyStoreException,
                             InvalidAlgorithmParameterException
        创建一个PKIXBuilderParameters的实例，它从指定的KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。 只考虑包含受信任的X509Certificate的密钥库条目; 所有其他证书类型将被忽略。
        参数
        keystore - 一个 KeyStore ，从中可以填充最可靠的CA集
        targetConstraints - 一个 CertSelector指定目标证书的约束
        异常
        KeyStoreException - 如果 keystore尚未初始化
        InvalidAlgorithmParameterException - 如果 keystore不包含至少一个可信证书条目
        NullPointerException - 如果 keystore是 null

    • 方法详细信息

      • setMaxPathLength

        public void setMaxPathLength​(int maxPathLength)
        设置认证路径中可能存在的非自发中间证书的最大数量的值。 如果主体和发行者字段中出现的DN相同且不为空，则证书是自发证的。 请注意，认证路径中的最后一个证书不是中间证书，不包括在此限制内。 通常最后一个证书是终端实体证书，但它可以是CA证书。 PKIX CertPathBuilder实例不能构建比指定长度更长的路径。

        值为0表示路径只能包含单个证书。 值-1表示路径长度是无约束的（即没有最大值）。 默认最大路径长度（如果未指定）为5.设置小于-1的值将导致抛出异常。

        如果任何CA证书包含BasicConstraintsExtension ，则只要结果是较小长度的认证路径，扩展名的pathLenConstraint字段的值将覆盖最大路径长度参数。

        参数
        maxPathLength - 认证路径中可能存在的非自发中间证书的最大数量
        异常
        InvalidParameterException - 如果 maxPathLength设置为小于-1的值
        另请参见：
        getMaxPathLength()

      • getMaxPathLength

        public int getMaxPathLength​()
        返回证书路径中可能存在的中间非自颁发证书的最大数量的值。 有关详细信息，请参阅setMaxPathLength(int)方法。
        结果
        认证路径中可能存在的非自发中间证书的最大数量，如果没有限制，则为-1
        另请参见：
        setMaxPathLength(int)

      • toString

        public String toString​()
        返回描述参数的格式化字符串。
        重写：
        toString在 PKIXParameters
        结果
        a formatted string describing the parameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PKIXCertPathBuilderResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class PKIXCertPathBuilderResult

  • java.lang.Object
    • java.security.cert.PKIXCertPathValidatorResult
      • java.security.cert.PKIXCertPathBuilderResult
  • All Implemented Interfaces:
    Cloneable ， CertPathBuilderResult ， CertPathValidatorResult

    public class PKIXCertPathBuilderResult
extends PKIXCertPathValidatorResult
implements CertPathBuilderResult
    此类表示PKIX认证路径构建器算法的成功结果。 使用此算法构建和返回的所有认证路径也将根据PKIX认证路径验证算法进行验证。

    PKIXCertPathBuilderResult实例由实现PKIX算法的CertPathBuilder对象的build方法返回。

    所有PKIXCertPathBuilderResult对象都包含由构建算法构建的认证路径，由构建算法产生的有效策略树和主题公钥，以及TrustAnchor描述作为认证路径的信任锚点的证书颁发机构（CA）。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertPathBuilderResult

    • 构造方法摘要

      构造方法
      Constructor 描述
      PKIXCertPathBuilderResult​(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
      创建包含指定参数的 PKIXCertPathBuilderResult实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CertPath getCertPath​()
      返回建立和验证的认证路径。
      String toString​()
      返回此 PKIXCertPathBuilderResult的可打印的表示。

      • Methods inherited from interface java.security.cert.CertPathBuilderResult

        clone

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.cert.PKIXCertPathValidatorResult

        clone, getPolicyTree, getPublicKey, getTrustAnchor

    • 构造方法详细信息

      • PKIXCertPathBuilderResult

        public PKIXCertPathBuilderResult​(CertPath certPath,
                                 TrustAnchor trustAnchor,
                                 PolicyNode policyTree,
                                 PublicKey subjectPublicKey)
        创建包含指定参数的 PKIXCertPathBuilderResult实例。
        参数
        certPath - 经过验证的 CertPath
        trustAnchor - 描述作为证书路径的信任锚点的CA的 TrustAnchor
        policyTree - 不可变的有效策略树，如果没有有效的策略， null
        subjectPublicKey - 主题的公钥
        异常
        NullPointerException -如果 certPath ， trustAnchor或者 subjectPublicKey参数为 null

    • 方法详细信息

      • getCertPath

        public CertPath getCertPath​()
        返回建立和验证的认证路径。 CertPath对象不包括信任锚点。 相反，请使用getTrustAnchor()方法获取作为认证路径的信任锚点的TrustAnchor 。
        Specified by:
        getCertPath在接口 CertPathBuilderResult
        结果
        内置和验证 CertPath （从不 null ）

      • toString

        public String toString​()
        返回此 PKIXCertPathBuilderResult的可打印表示。
        重写：
        toString在 PKIXCertPathValidatorResult
        结果
        a String describing the contents of this PKIXCertPathBuilderResult
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PKIXCertPathChecker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class PKIXCertPathChecker

  • java.lang.Object
    • java.security.cert.PKIXCertPathChecker
  • All Implemented Interfaces:
    Cloneable ， CertPathChecker
    已知直接子类：
    PKIXRevocationChecker

    public abstract class PKIXCertPathChecker
extends Object
implements CertPathChecker, Cloneable
    对X509Certificate执行一个或多个检查的抽象类。

    可以创建PKIXCertPathChecker类的具体实现来扩展PKIX认证路径验证算法。 例如，实现可以检查和处理认证路径中每个证书的关键私人扩展。

    PKIXCertPathChecker实例使用PKIXParameters和PKIXBuilderParameters类的setCertPathCheckers或addCertPathChecker方法作为参数传递。 将针对由PKIX CertPathValidator或CertPathBuilder实现的每个证书调用PKIXCertPathChecker的check方法。

    A PKIXCertPathChecker可以在认证路径中的连续证书上多次调用。 预期具体子类将维护可能需要检查连续证书的任何内部状态。 init方法用于初始化检查器的内部状态，以便可以检查新的认证路径的证书。 必要时，有状态的实现必须覆盖clone方法，以便允许PKIX CertPathBuilder有效地回溯并尝试其他路径。 在这些情况下， CertPathBuilder能够通过恢复克隆的PKIXCertPathChecker s恢复先前的路径验证状态。

    证书提交给PKIXCertPathChecker可能是向前（从目标到最受信任的CA）或反向（从最受信任的CA到目标）。 一个PKIXCertPathChecker实现必须支持反向检查（当相反方向呈现证书时执行检查的能力），并且可以支持前向检查（当向前方向呈现证书时执行检查的能力）。 isForwardCheckingSupported方法指示是否支持前向检查。

    执行检查所需的附加输入参数可以通过此类的具体实现的构造函数来指定。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    PKIXParameters ， PKIXBuilderParameters

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected PKIXCertPathChecker​()
      默认构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void check​(Certificate cert)
      使用其内部状态对指定的证书执行检查。
      abstract void check​(Certificate cert, Collection<String> unresolvedCritExts)
      使用其内部状态对指定证书执行检查，并从指定的OID字符串集合中删除其处理的任何关键扩展，这些扩展代表未解决的关键扩展。
      Object clone​()
      返回此对象的克隆。
      abstract Set<String> getSupportedExtensions​()
      返回 PKIXCertPathChecker支持（即识别，能够处理）的X.509证书扩展的不可变 Set ，如果不支持扩展名，则 null 。
      abstract void init​(boolean forward)
      初始化这个 PKIXCertPathChecker的内部状态。
      abstract boolean isForwardCheckingSupported​()
      指示是否支持转发检查。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PKIXCertPathChecker

        protected PKIXCertPathChecker​()
        默认构造函数。

    • 方法详细信息

      • init

        public abstract void init​(boolean forward)
                   throws CertPathValidatorException
        初始化这个PKIXCertPathChecker的内部状态。

        forward标志指定证书将传递给check方法（正向或反向）的顺序。 A PKIXCertPathChecker 必须支持反向检查，并且可以支持前向检查。

        Specified by:
        init在接口 CertPathChecker
        参数
        forward - 证书颁发给check方法的check 。 如果true ，证书将从目标提供给最受信任的CA（转发）; 如果是false ，从最信任的CA到目标（反向）。
        异常
        CertPathValidatorException - 如果这个PKIXCertPathChecker无法以指定的顺序检查证书; 如果forward标志为false，则不应该抛出，因为必须支持反向检查

      • isForwardCheckingSupported

        public abstract boolean isForwardCheckingSupported​()
        指示是否支持转发检查。 正向检查指的能力PKIXCertPathChecker时证书被呈现给执行其检查check方法在向前方向（从靶到最信任的CA）。
        Specified by:
        isForwardCheckingSupported在接口 CertPathChecker
        结果
        true如果支持前向检查，否则为 false

      • getSupportedExtensions

        public abstract Set<String> getSupportedExtensions​()
        返回PKIXCertPathChecker支持（即识别，能够处理）的X.509证书扩展的不可变Set ，如果不支持扩展名，则null 。

        集合的每个元素是表示支持的X.509扩展的对象标识符（OID）的String 。 OID由一组以句点分隔的非负整数表示。

        一个PKIXCertPathChecker可能能够处理的所有X.509证书扩展应该包含在该集合中。

        结果
        一个不可变 Set X.509扩展的OID（在 String此支持的格式） PKIXCertPathChecker ，或 null ，如果没有附加信息被支撑

      • check

        public abstract void check​(Certificate cert,
                           Collection<String> unresolvedCritExts)
                    throws CertPathValidatorException
        使用其内部状态对指定证书执行检查，并从指定的OID字符串集合中删除其处理的任何关键扩展，这些扩展代表未解决的关键扩展。 证书按照init方法规定的顺序init 。
        参数
        cert - 要检查的 Certificate
        unresolvedCritExts - 一个 Collection的OID字符串，表示当前的一组未解决的关键扩展
        异常
        CertPathValidatorException - 如果指定的证书没有通过支票

      • check

        public void check​(Certificate cert)
           throws CertPathValidatorException
        使用其内部状态对指定的证书执行检查。 证书按照init方法规定的顺序init 。

        此实现调用check(cert, java.util.Collections.<String>emptySet()) 。

        Specified by:
        check在接口 CertPathChecker
        参数
        cert - 要检查的 Certificate
        异常
        CertPathValidatorException - 如果指定的证书没有通过支票

      • clone

        public Object clone​()
        返回此对象的克隆。 调用Object.clone()方法。 维护状态的所有子类必须支持并覆盖此方法。
        重写：
        clone在 Object
        结果
        这个 PKIXCertPathChecker的副本
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PKIXCertPathValidatorResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class PKIXCertPathValidatorResult

  • java.lang.Object
    • java.security.cert.PKIXCertPathValidatorResult
  • All Implemented Interfaces:
    Cloneable ， CertPathValidatorResult
    已知直接子类：
    PKIXCertPathBuilderResult

    public class PKIXCertPathValidatorResult
extends Object
implements CertPathValidatorResult
    该类代表PKIX认证路径验证算法的成功结果。

    PKIXCertPathValidatorResult实例由实现PKIX算法的CertPathValidator对象的validate方法返回。

    所有PKIXCertPathValidatorResult对象都包含由验证算法产生的有效策略树和主题公钥，以及描述作为证书路径的信任锚的证书颁发机构（CA）的TrustAnchor 。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertPathValidatorResult

    • 构造方法摘要

      构造方法
      Constructor 描述
      PKIXCertPathValidatorResult​(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
      创建包含指定参数的 PKIXCertPathValidatorResult实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      返回此对象的副本。
      PolicyNode getPolicyTree​()
      返回PKIX认证路径验证算法产生的有效策略树的根节点。
      PublicKey getPublicKey​()
      返回认证路径的主题（目标）的公钥，包括任何继承的公钥参数（如果适用）。
      TrustAnchor getTrustAnchor​()
      返回描述作为证书路径的信任锚点的CA的 TrustAnchor 。
      String toString​()
      返回此 PKIXCertPathValidatorResult的可打印的表示。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PKIXCertPathValidatorResult

        public PKIXCertPathValidatorResult​(TrustAnchor trustAnchor,
                                   PolicyNode policyTree,
                                   PublicKey subjectPublicKey)
        创建包含指定参数的 PKIXCertPathValidatorResult实例。
        参数
        trustAnchor - 描述作为认证路径的信任锚点的CA的 TrustAnchor
        policyTree - 不可变的有效策略树，如果没有有效的策略， null
        subjectPublicKey - 该主题的公钥
        异常
        NullPointerException - 如果 subjectPublicKey或 trustAnchor参数是 null

    • 方法详细信息

      • getTrustAnchor

        public TrustAnchor getTrustAnchor​()
        返回描述作为认证路径的信任锚点的CA的 TrustAnchor 。
        结果
        TrustAnchor （从不 null ）

      • getPolicyTree

        public PolicyNode getPolicyTree​()
        返回PKIX认证路径验证算法产生的有效策略树的根节点。 返回的PolicyNode对象和通过公共方法返回的任何对象是不可变的。

        大多数应用程序不需要检查有效的策略树。 他们可以通过在PKIXParameters设置策略相关参数来实现其策略处理目标。 然而，更复杂的应用程序，特别是处理策略限定符的应用程序可能需要使用PolicyNode.getParent和PolicyNode.getChildren方法遍历有效的策略树。

        结果
        有效策略树的 null如果没有有效策略， null

      • getPublicKey

        public PublicKey getPublicKey​()
        返回认证路径的主题（目标）的公钥，包括任何继承的公钥参数（如果适用）。
        结果
        主题的公钥（永远不是 null ）

      • clone

        public Object clone​()
        返回此对象的副本。
        Specified by:
        clone在接口 CertPathValidatorResult
        重写：
        clone在类 Object
        结果
        副本
        另请参见：
        Cloneable

      • toString

        public String toString​()
        返回此 PKIXCertPathValidatorResult的可打印 PKIXCertPathValidatorResult 。
        重写：
        toString在 Object
        结果
        一个 String此的描述内容 PKIXCertPathValidatorResult
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PKIXParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class PKIXParameters

  • java.lang.Object
    • java.security.cert.PKIXParameters
  • All Implemented Interfaces:
    Cloneable ， CertPathParameters
    已知直接子类：
    PKIXBuilderParameters

    public class PKIXParameters
extends Object
implements CertPathParameters
    参数用作PKIX CertPathValidator算法的输入。

    PKIX CertPathValidator使用这些参数根据PKIX认证路径验证算法来验证CertPath 。

    要实例化一个PKIXParameters对象，应用程序必须指定由PKIX认证路径验证算法定义的一个或多个最受信任的CA。 最可靠的CA可以使用两个构造函数之一进行指定。 应用程序可以调用PKIXParameters(Set) ，指定Set的TrustAnchor对象，每个对象的识别最信任的CA. 或者，应用程序可以调用PKIXParameters(KeyStore) ，指定包含可信证书条目的KeyStore实例，每个实例将被视为最受信任的CA。

    一旦创建了一个PKIXParameters对象，可以指定其他参数（例如通过调用setInitialPolicies或setDate ），然后PKIXParameters与CertPath一起传递，以验证为CertPathValidator.validate 。

    任何未设置的参数（或设置为null ）将被设置为该参数的默认值。 date参数的默认值为null ，表示路径验证当前的时间。 剩余参数的默认值最小限制。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertPathValidator

    • 构造方法摘要

      构造方法
      Constructor 描述
      PKIXParameters​(KeyStore keystore)
      创建 PKIXParameters的实例，该实例从指定的 KeyStore包含的受信任的证书条目填充最受信任的CA KeyStore 。
      PKIXParameters​(Set<TrustAnchor> trustAnchors)
      使用指定的 Set最受信任的CA创建一个 PKIXParameters的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addCertPathChecker​(PKIXCertPathChecker checker)
      在认证路径检查列表中添加一个 PKIXCertPathChecker 。
      void addCertStore​(CertStore store)
      在查找证书和CRL中使用的 CertStore列表末尾添加一个 CertStore 。
      Object clone​()
      复制这个 PKIXParameters对象。
      List<PKIXCertPathChecker> getCertPathCheckers​()
      返回认证路径检查器的 List 。
      List<CertStore> getCertStores​()
      返回用于查找证书和CRL的不可变 List的 CertStore 。
      Date getDate​()
      返回确定认证路径有效性的时间。
      Set<String> getInitialPolicies​()
      返回一个不可变的初始策略标识符（OID字符串）的 Set ，表明这些策略中的任何一个对证书用户来说都是可接受的，用于认证路径处理。
      boolean getPolicyQualifiersRejected​()
      获取PolicyQualifiersRejected标志。
      String getSigProvider​()
      返回签名提供者的名称，如果未设置，则返回 null 。
      CertSelector getTargetCertConstraints​()
      返回目标证书所需的约束。
      Set<TrustAnchor> getTrustAnchors​()
      返回一个不可变的 Set最受信任的CA。
      boolean isAnyPolicyInhibited​()
      检查是否应将任何策略OID包含在证书中进行处理。
      boolean isExplicitPolicyRequired​()
      检查是否需要明确的策略。
      boolean isPolicyMappingInhibited​()
      检查策略映射是否被禁止。
      boolean isRevocationEnabled​()
      检查RevocationEnabled标志。
      void setAnyPolicyInhibited​(boolean val)
      设置状态以确定是否应将任何策略OID包含在证书中进行处理。
      void setCertPathCheckers​(List<PKIXCertPathChecker> checkers)
      设置一个额外的认证路径检查器 List 。
      void setCertStores​(List<CertStore> stores)
      设置用于查找证书和CRL的 CertStore的列表。
      void setDate​(Date date)
      设置认证路径的有效性应该被确定的时间。
      void setExplicitPolicyRequired​(boolean val)
      设置ExplicitPolicyRequired标志。
      void setInitialPolicies​(Set<String> initialPolicies)
      设置初始策略标识符（OID字符串）的 Set ，指示证书用户为了认证路径处理的目的而可以接受这些策略中的任何一个。
      void setPolicyMappingInhibited​(boolean val)
      设置PolicyMappingInhibited标志。
      void setPolicyQualifiersRejected​(boolean qualifiersRejected)
      设置PolicyQualifiersRejected标志。
      void setRevocationEnabled​(boolean val)
      设置RevocationEnabled标志。
      void setSigProvider​(String sigProvider)
      设置签名提供者的名称。
      void setTargetCertConstraints​(CertSelector selector)
      设置目标证书所需的约束。
      void setTrustAnchors​(Set<TrustAnchor> trustAnchors)
      设置 Set最受信任的CA。
      String toString​()
      返回描述参数的格式化字符串。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PKIXParameters

        public PKIXParameters​(Set<TrustAnchor> trustAnchors)
               throws InvalidAlgorithmParameterException
        创建一个PKIXParameters的实例，其中指定了Set的最受信任的CA。 该集合的每个元素是一个TrustAnchor 。

        请注意， Set被复制以防止后续修改。

        参数
        trustAnchors - a Set of TrustAnchor s
        异常
        InvalidAlgorithmParameterException - 如果指定的 Set为空 (trustAnchors.isEmpty() == true)
        NullPointerException - 如果指定的 Set是 null
        ClassCastException -如果任何在元素 Set类型不是 java.security.cert.TrustAnchor

      • PKIXParameters

        public PKIXParameters​(KeyStore keystore)
               throws KeyStoreException,
                      InvalidAlgorithmParameterException
        创建一个PKIXParameters的实例，它从指定的KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。 仅考虑包含受信任的X509Certificates密钥库条目; 所有其他证书类型将被忽略。
        参数
        keystore - 一个 KeyStore ，从中可以填充最可靠的CA集
        异常
        KeyStoreException - 如果密钥库尚未初始化
        InvalidAlgorithmParameterException - 如果密钥库不包含至少一个可信证书条目
        NullPointerException - 如果密钥库是 null

    • 方法详细信息

      • getTrustAnchors

        public Set<TrustAnchor> getTrustAnchors​()
        返回一个不可变的 Set最受信任的CA。
        结果
        一个不变的 Set的 TrustAnchor s（从不 null ）
        另请参见：
        setTrustAnchors(java.util.Set<java.security.cert.TrustAnchor>)

      • setTrustAnchors

        public void setTrustAnchors​(Set<TrustAnchor> trustAnchors)
                     throws InvalidAlgorithmParameterException
        设置Set最受信任的CA。

        请注意， Set被复制以防止后续修改。

        参数
        trustAnchors - a Set of TrustAnchor s
        异常
        InvalidAlgorithmParameterException - 如果指定的 Set为空 (trustAnchors.isEmpty() == true)
        NullPointerException - 如果指定的 Set是 null
        ClassCastException - 如果集合中的任何元素不是类型 java.security.cert.TrustAnchor
        另请参见：
        getTrustAnchors()

      • getInitialPolicies

        public Set<String> getInitialPolicies​()
        返回不可变的初始策略标识符（OID字符串） Set ，表明证书用户为了认证路径处理的目的可以接受这些策略中的任何一个。 默认返回值是一个空的Set ，这被解释为任何策略都是可以接受的。
        结果
        String格式的初始策略OID不可变的Set ，或空的Set （意味着任何策略都可以接受）。 永远不会返回null 。
        另请参见：
        setInitialPolicies(java.util.Set<java.lang.String>)

      • setInitialPolicies

        public void setInitialPolicies​(Set<String> initialPolicies)
        设置初始策略标识符（OID字符串）的Set ，指示证书用户为了认证路径处理的目的而可以接受这些策略中的任何一个。 默认情况下，任何策略都是可接受的（即所有策略），所以希望允许任何策略可以接受的用户不需要调用此方法，也可以使用空的Set （或null ）进行调用。

        请注意， Set被复制以防止后续修改。

        参数
        initialPolicies - Set的 String格式的初始策略OID（或 null ）
        异常
        ClassCastException - 如果集合中的任何元素不是类型 String
        另请参见：
        getInitialPolicies()

      • setCertStores

        public void setCertStores​(List<CertStore> stores)
        设置用于查找证书和CRL的CertStore的列表。 可能是null ，在这种情况下不会使用CertStore 。 列表中的第一个CertStore可能优于稍后出现的那些。

        请注意， List被复制以防止后续修改。

        参数
        stores - a List of CertStore s（or null ）
        异常
        ClassCastException - 如果列表中的任何元素不是类型 java.security.cert.CertStore
        另请参见：
        getCertStores()

      • addCertStore

        public void addCertStore​(CertStore store)
        在查找证书和CRL中使用的 CertStore列表末尾添加一个 CertStore 。
        参数
        store - 要添加的CertStore 。 如果null ，该商店被忽略（未添加到列表）。

      • getCertStores

        public List<CertStore> getCertStores​()
        返回用于查找证书和CRL的不可变 List （ CertStore 。
        结果
        一个不可变的 List的 CertStore s（可能是空的，但从不 null ）
        另请参见：
        setCertStores(java.util.List<java.security.cert.CertStore>)

      • setRevocationEnabled

        public void setRevocationEnabled​(boolean val)
        设置RevocationEnabled标志。 如果此标志为真，将使用基础PKIX服务提供程序的默认撤销检查机制。 如果该标志为false，则默认的撤销检查机制将被禁用（未使用）。

        当创建一个PKIXParameters对象时，该标志设置为true。 此设置反映了检查撤销的最常见策略，因为每个服务提供商必须支持撤销检查以符合PKIX。 如果使用PKIX服务提供商的默认撤销检查机制或替代撤销检查机制（也称为addCertPathChecker或setCertPathCheckers方法）不实用时，复杂的应用程序应将此标志设置为false。

        参数
        val - RevocationEnabled标志的新值

      • isRevocationEnabled

        public boolean isRevocationEnabled​()
        检查RevocationEnabled标志。 如果此标志为真，将使用基础PKIX服务提供程序的默认撤销检查机制。 如果该标志为false，则默认的撤销检查机制将被禁用（未使用）。 有关设置此标志值的更多详细信息，请参阅setRevocationEnabled方法。
        结果
        RevocationEnabled标志的当前值

      • setExplicitPolicyRequired

        public void setExplicitPolicyRequired​(boolean val)
        设置ExplicitPolicyRequired标志。 如果此标志为真，则每个证书中都需要明确标识可接受的策略。 默认情况下，ExplicitPolicyRequired标志为false。
        参数
        val - true如果需要明确的政策，否则为 false

      • isExplicitPolicyRequired

        public boolean isExplicitPolicyRequired​()
        检查是否需要明确的策略。 如果此标志为真，则每个证书中都需要明确标识可接受的策略。 默认情况下，ExplicitPolicyRequired标志为false。
        结果
        true是否需要明确的政策， false否则

      • setPolicyMappingInhibited

        public void setPolicyMappingInhibited​(boolean val)
        设置PolicyMappingInhibited标志。 如果该标志为真，则禁止策略映射。 缺省情况下，策略映射不被禁止（标志为false）。
        参数
        val - true如果禁止策略映射，否则为 false

      • isPolicyMappingInhibited

        public boolean isPolicyMappingInhibited​()
        检查策略映射是否被禁止。 如果该标志为真，则禁止策略映射。 缺省情况下，策略映射不被禁止（标志为false）。
        结果
        如果禁止策略映射，则为true，否则为false

      • setAnyPolicyInhibited

        public void setAnyPolicyInhibited​(boolean val)
        设置状态以确定是否应将任何策略OID包含在证书中进行处理。 默认情况下，任何策略OID不被禁止（ isAnyPolicyInhibited()返回false ）。
        参数
        val - true如果任何策略OID被禁止，否则为 false

      • isAnyPolicyInhibited

        public boolean isAnyPolicyInhibited​()
        检查是否应将任何策略OID包含在证书中进行处理。
        结果
        true如果任何策略OID被禁止，否则为 false

      • setPolicyQualifiersRejected

        public void setPolicyQualifiersRejected​(boolean qualifiersRejected)
        设置PolicyQualifiersRejected标志。 如果此标志为真，那么在证书策略扩展中包含策略限定符的证书将被拒绝。 如果该标志为假，则证书不会在此基础上被拒绝。

        当创建一个PKIXParameters对象时，该标志设置为true。 此设置反映了处理策略限定词的最常用（最简单）策略。 希望使用更复杂的策略的应用程序必须将此标志设置为false。

        请注意，PKIX认证路径验证算法指定必须处理和验证证书策略扩展中标记为关键的任何策略限定符。 否则认证路径必须被拒绝。 如果policyQualifiersRejected标志设置为false，则应用程序以此方式验证所有策略限定符，以便符合PKIX标准。

        参数
        qualifiersRejected - PolicyQualifiersRejected标志的新值
        另请参见：
        getPolicyQualifiersRejected() ， PolicyQualifierInfo

      • getPolicyQualifiersRejected

        public boolean getPolicyQualifiersRejected​()
        获取PolicyQualifiersRejected标志。 如果此标志为真，那么在证书策略扩展中包含策略限定符的证书将被拒绝。 如果该标志为假，则证书不会在此基础上被拒绝。

        当创建一个PKIXParameters对象时，该标志设置为true。 此设置反映了处理策略限定词的最常用（最简单）策略。 希望使用更复杂的策略的应用程序必须将此标志设置为false。

        结果
        PolicyQualifiersRejected标志的当前值
        另请参见：
        setPolicyQualifiersRejected(boolean)

      • getDate

        public Date getDate​()
        返回确定认证路径有效性的时间。 如果是null ，则使用当前时间。

        请注意，返回的Date被复制以防止后续修改。

        结果
        Date或 null如果没有设置
        另请参见：
        setDate(java.util.Date)

      • setDate

        public void setDate​(Date date)
        设置认证路径的有效性应该被确定的时间。 如果是null ，则使用当前时间。

        请注意， Date提供的Date复制以防止后续修改。

        参数
        date - Date或 null当前时间
        另请参见：
        getDate()

      • setCertPathCheckers

        public void setCertPathCheckers​(List<PKIXCertPathChecker> checkers)
        设置一个额外的认证路径检查器List 。 如果指定List包含一个对象，它是不是一个PKIXCertPathChecker ，它将被忽略。

        每个PKIXCertPathChecker指定的实现对证书的附加检查。 通常，这些是处理和验证证书中包含的私有扩展的检查。 应使用执行检查所需的任何初始化参数来实例化每个PKIXCertPathChecker 。

        该方法允许复杂的应用程序扩展PKIX CertPathValidator或CertPathBuilder 。 每个指定的PKIXCertPathChecker的每个将被处理或验证的每个证书的PKIX CertPathValidator或CertPathBuilder 。

        无论这些额外的PKIXCertPathChecker是否设置，PKIX CertPathValidator或CertPathBuilder必须对每个证书执行所有必需的PKIX检查。 此规则的一个例外是如果RevocationEnabled标志设置为false（参见setRevocationEnabled方法）。

        请注意， List提供的List被复制，并且克隆了列表中的每个PKIXCertPathChecker以防止后续修改。

        参数
        checkers - a List of PKIXCertPathChecker s。 可能是null ，在这种情况下不会使用额外的检查。
        异常
        ClassCastException - 如果列表中的任何元素不是类型 java.security.cert.PKIXCertPathChecker
        另请参见：
        getCertPathCheckers()

      • getCertPathCheckers

        public List<PKIXCertPathChecker> getCertPathCheckers​()
        返回认证路径检查程序的List 。 返回List是不可改变的，而且每个PKIXCertPathChecker在List被克隆，以防止后续修改。
        结果
        一个不可变的 List的 PKIXCertPathChecker s（可能是空的，但不是 null ）
        另请参见：
        setCertPathCheckers(java.util.List<java.security.cert.PKIXCertPathChecker>)

      • addCertPathChecker

        public void addCertPathChecker​(PKIXCertPathChecker checker)
        在认证路径检查列表中添加一个PKIXCertPathChecker 。 有关详细信息，请参阅setCertPathCheckers方法。

        请注意， PKIXCertPathChecker被克隆以防止后续修改。

        参数
        checker - 一个PKIXCertPathChecker添加到支票列表。 如果null ，检查器将被忽略（未添加到列表中）。

      • getSigProvider

        public String getSigProvider​()
        返回签名提供者的名称，如果未设置，则返回 null 。
        结果
        签名提供者的名称（或 null ）
        另请参见：
        setSigProvider(java.lang.String)

      • setSigProvider

        public void setSigProvider​(String sigProvider)
        设置签名提供者的名称。 创建Signature对象时，指定的提供程序将是首选。 如果null或未设置，则将使用支持该算法的第一供应商。
        参数
        sigProvider - 签名提供者的名字（或 null ）
        另请参见：
        getSigProvider()

      • getTargetCertConstraints

        public CertSelector getTargetCertConstraints​()
        返回目标证书所需的约束。 约束作为CertSelector一个实例返回。 如果是null ，那么没有限制。

        请注意，返回的CertSelector被克隆以防止后续修改。

        结果
        一个 CertSelector指定目标证书的约束（或 null ）
        另请参见：
        setTargetCertConstraints(java.security.cert.CertSelector)

      • setTargetCertConstraints

        public void setTargetCertConstraints​(CertSelector selector)
        设置目标证书所需的约束。 约束被指定为CertSelector一个实例。 如果是null ，那么没有限制。

        请注意，指定的CertSelector被克隆以防止后续修改。

        参数
        selector -一个 CertSelector指定目标证书的约束（或 null ）
        另请参见：
        getTargetCertConstraints()

      • clone

        public Object clone​()
        PKIXParameters这个PKIXParameters对象。 副本的更改不会影响原始文件，反之亦然。
        Specified by:
        clone在接口 CertPathParameters
        重写：
        clone在 Object
        结果
        这个 PKIXParameters对象的副本
        另请参见：
        Cloneable

      • toString

        public String toString​()
        返回描述参数的格式化字符串。
        重写：
        toString在 Object
        结果
        a formatted string describing the parameters.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PKIXReason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.security.cert

Enum PKIXReason

  • java.lang.Object
    • java.lang.Enum<PKIXReason>
      • java.security.cert.PKIXReason
  • All Implemented Interfaces:
    Serializable ， Comparable<PKIXReason> ， CertPathValidatorException.Reason

    public enum PKIXReason
extends Enum<PKIXReason>
implements CertPathValidatorException.Reason
    PKIXReason列举了PKIX特有的原因，即根据PKIX（RFC 5280）标准，X.509认证路径可能无效。 这些原因除了CertPathValidatorException.BasicReason枚举之外。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      INVALID_KEY_USAGE
      证书的密钥使用无效。
      INVALID_NAME
      名称限制已被违反。
      INVALID_POLICY
      政策制约因素受到侵犯。
      NAME_CHAINING
      证书链不正确。
      NO_TRUST_ANCHOR
      找不到可接受的信托锚点。
      NOT_CA_CERT
      证书不是CA证书。
      PATH_TOO_LONG
      路径长度约束已被违反。
      UNRECOGNIZED_CRIT_EXT
      证书包含一个或多个无法识别的关键扩展。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PKIXReason valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PKIXReason[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NAME_CHAINING

        public static final PKIXReason NAME_CHAINING
        证书链不正确。

      • INVALID_KEY_USAGE

        public static final PKIXReason INVALID_KEY_USAGE
        证书的密钥使用无效。

      • INVALID_POLICY

        public static final PKIXReason INVALID_POLICY
        政策制约因素受到侵犯。

      • NO_TRUST_ANCHOR

        public static final PKIXReason NO_TRUST_ANCHOR
        找不到可接受的信托锚点。

      • UNRECOGNIZED_CRIT_EXT

        public static final PKIXReason UNRECOGNIZED_CRIT_EXT
        证书包含一个或多个无法识别的关键扩展。

      • NOT_CA_CERT

        public static final PKIXReason NOT_CA_CERT
        证书不是CA证书。

      • PATH_TOO_LONG

        public static final PKIXReason PATH_TOO_LONG
        路径长度约束已被违反。

      • INVALID_NAME

        public static final PKIXReason INVALID_NAME
        名称限制已被违反。

    • 方法详细信息

      • values

        public static PKIXReason[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PKIXReason c : PKIXReason.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PKIXReason valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PKIXRevocationChecker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class PKIXRevocationChecker

  • java.lang.Object
    • java.security.cert.PKIXCertPathChecker
      • java.security.cert.PKIXRevocationChecker
  • All Implemented Interfaces:
    Cloneable ， CertPathChecker

    public abstract class PKIXRevocationChecker
extends PKIXCertPathChecker
    A PKIXCertPathChecker用于使用PKIX算法检查证书的撤销状态。

    A PKIXRevocationChecker使用在线证书状态协议（OCSP）或证书吊销列表（CRL）检查证书的撤销状态。 OCSP在RFC 2560中描述，并且是用于确定证书状态的网络协议。 CRL是标识撤销证书的时间戳列表，RFC 5280描述了一种使用CRL确定证书撤销状态的算法。

    每个PKIXRevocationChecker必须能够使用OCSP和CRL来检查证书的撤销状态。 默认情况下，OCSP是检查撤销状态的首选机制，CRL作为备用机制。 但是，可以使用PREFER_CRLS选项将此首选项切换到CRL。 此外，可以使用NO_FALLBACK选项禁用回退机制。

    A PKIXRevocationChecker是通过调用PKIX CertPathValidator的getRevocationChecker方法获得的。 可以设置特定于吊销的其他参数和选项（例如通过调用setOcspResponder方法）。 所述PKIXRevocationChecker加入到PKIXParameters使用对象addCertPathChecker或setCertPathCheckers方法，然后将PKIXParameters与一起传递CertPath进行验证到validate一个PKIX的方法CertPathValidator 。 当以这种方式提供撤销检查器时，将用于检查撤销，而不管RevocationEnabled标志的设置。 类似地，可以将PKIXRevocationChecker添加到用于PKIX CertPathBuilder的PKIXBuilderParameters对象中。

    注意，当一个PKIXRevocationChecker被添加到PKIXParameters ，它克隆了PKIXRevocationChecker ; 因此任何对PKIXRevocationChecker后续修改都没有效果。

    任何未设置的参数（或设置为null ）将被设置为该参数的默认值。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.8
    另请参见：
    RFC 2560: X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSP ，
    RFC 5280: Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  PKIXRevocationChecker.Option
      可以为吊销检查机制指定的各种撤销选项。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected PKIXRevocationChecker​()
      默认构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      PKIXRevocationChecker clone​()
      返回此对象的克隆。
      List<Extension> getOcspExtensions​()
      获取可选的OCSP请求扩展。
      URI getOcspResponder​()
      获取标识OCSP响应器位置的URI。
      X509Certificate getOcspResponderCert​()
      获取OCSP响应者的证书。
      Map<X509Certificate,byte[]> getOcspResponses​()
      获得OCSP响应。
      Set<PKIXRevocationChecker.Option> getOptions​()
      获取吊销选项。
      abstract List<CertPathValidatorException> getSoftFailExceptions​()
      返回一个列表，其中包含当设置了 SOFT_FAIL选项时撤销检查器忽略的异常。
      void setOcspExtensions​(List<Extension> extensions)
      设置可选的OCSP请求扩展。
      void setOcspResponder​(URI uri)
      设置标识OCSP响应器位置的URI。
      void setOcspResponderCert​(X509Certificate cert)
      设置OCSP响应者的证书。
      void setOcspResponses​(Map<X509Certificate,byte[]> responses)
      设置OCSP响应。
      void setOptions​(Set<PKIXRevocationChecker.Option> options)
      设置撤销选项。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.security.cert.PKIXCertPathChecker

        check, check, getSupportedExtensions, init, isForwardCheckingSupported

    • 构造方法详细信息

      • PKIXRevocationChecker

        protected PKIXRevocationChecker​()
        默认构造函数。

    • 方法详细信息

      • setOcspResponder

        public void setOcspResponder​(URI uri)
        设置标识OCSP响应器位置的URI。 这将覆盖ocsp.responderURL安全属性以及在证书授权信息访问扩展中指定的任何响应者，如RFC 5280中所定义。
        参数
        uri - 响应者URI

      • getOcspResponder

        public URI getOcspResponder​()
        获取标识OCSP响应器位置的URI。 这覆盖了ocsp.responderURL安全属性。 如果此参数或ocsp.responderURL属性未设置，则该位置由RFC 5280中定义的证书的权限信息访问扩展确定。
        结果
        响应者URI，如果没有设置， null

      • setOcspResponderCert

        public void setOcspResponderCert​(X509Certificate cert)
        设置OCSP响应者的证书。 这将覆盖ocsp.responderCertSubjectName ， ocsp.responderCertIssuerName ，并ocsp.responderCertSerialNumber安全属性。
        参数
        cert - 答复者的证书

      • getOcspResponderCert

        public X509Certificate getOcspResponderCert​()
        获取OCSP响应者的证书。 这将覆盖ocsp.responderCertSubjectName ， ocsp.responderCertIssuerName ，并ocsp.responderCertSerialNumber安全属性。 如果此参数或上述属性未设置，则响应者的证书按照RFC 2560中的规定确定。
        结果
        应答者的证书，或 null如果没有设置

      • setOcspExtensions

        public void setOcspExtensions​(List<Extension> extensions)
        设置可选的OCSP请求扩展。
        参数
        extensions - 扩展名单。 该列表被复制以防止后续修改。

      • getOcspExtensions

        public List<Extension> getOcspExtensions​()
        获取可选的OCSP请求扩展。
        结果
        一个不可修改的扩展名单。 如果没有指定扩展名，列表为空。

      • setOcspResponses

        public void setOcspResponses​(Map<X509Certificate,byte[]> responses)
        设置OCSP响应。 当使用OCSP时，这些响应用于确定指定证书的吊销状态。
        参数
        responses - OCSP响应图。 每个密钥是一个X509Certificate ，映射到该证书的相应的DER编码的OCSP响应。 执行地图的深层副本以防止后续修改。

      • getOcspResponses

        public Map<X509Certificate,byte[]> getOcspResponses​()
        获得OCSP响应。 当使用OCSP时，这些响应用于确定指定证书的吊销状态。
        结果
        OCSP响应图。 每个密钥是一个X509Certificate ，映射到该证书的相应的DER编码的OCSP响应。 返回地图的深层副本以防止后续修改。 如果未指定任何响应，则返回空的地图。

      • setOptions

        public void setOptions​(Set<PKIXRevocationChecker.Option> options)
        设置撤销选项。
        参数
        options - 一组撤销选项。 该集合被复制以防止后续修改。

      • getOptions

        public Set<PKIXRevocationChecker.Option> getOptions​()
        获取吊销选项。
        结果
        一套不可修改的撤销选择。 如果未指定任何选项，则该集合为空。

      • getSoftFailExceptions

        public abstract List<CertPathValidatorException> getSoftFailExceptions​()
        返回一个列表，其中包含当设置了SOFT_FAIL选项时撤销检查器忽略的异常。 每次调用init清单。 列表按照每个条目的getIndex方法返回的证书索引按升序排列。

        PKIXRevocationChecker的实现负责将忽略的例外添加到列表中。

        结果
        一个包含被忽略的异常的不可修改的列表。 如果没有忽略异常，列表为空。

      • clone

        public PKIXRevocationChecker clone​()
        描述从类别复制： PKIXCertPathChecker
        返回此对象的克隆。 调用Object.clone()方法。 维护状态的所有子类必须支持并覆盖此方法。
        重写：
        clone在 PKIXCertPathChecker
        结果
        这个 PKIXCertPathChecker的副本
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PKIXRevocationChecker.Option (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.security.cert

Enum PKIXRevocationChecker.Option

  • java.lang.Object
    • java.lang.Enum<PKIXRevocationChecker.Option>
      • java.security.cert.PKIXRevocationChecker.Option
  • All Implemented Interfaces:
    Serializable ， Comparable<PKIXRevocationChecker.Option>
    Enclosing class:
    PKIXRevocationChecker

    public static enum PKIXRevocationChecker.Option
extends Enum<PKIXRevocationChecker.Option>
    可以为吊销检查机制指定的各种撤销选项。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NO_FALLBACK
      禁用后备机制。
      ONLY_END_ENTITY
      仅检查终端实体证书的撤销状态。
      PREFER_CRLS
      喜欢CRCP到OSCP。
      SOFT_FAIL
      如果由于以下原因之一而无法确定吊销状态，允许撤销检查成功：由于网络错误，无法获取CRL或OCSP响应。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PKIXRevocationChecker.Option valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PKIXRevocationChecker.Option[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ONLY_END_ENTITY

        public static final PKIXRevocationChecker.Option ONLY_END_ENTITY
        仅检查终端实体证书的撤销状态。

      • PREFER_CRLS

        public static final PKIXRevocationChecker.Option PREFER_CRLS
        喜欢CRCP到OSCP。 默认行为是更喜欢OCSP。 每个PKIX实施应该记录他们具体的偏好规则和后备策略的进一步细节。

      • NO_FALLBACK

        public static final PKIXRevocationChecker.Option NO_FALLBACK
        禁用后备机制。

      • SOFT_FAIL

        public static final PKIXRevocationChecker.Option SOFT_FAIL
        如果撤销状态由于以下原因之一而无法确定，允许撤销检查成功：
        • 由于网络错误，无法获取CRL或OCSP响应。
        • OCSP响应者返回RFC 2560第2.3节中指定的以下错误之一：internalError或tryLater。

        请注意，这些条件适用于OCSP和CRL，除非设置了NO_FALLBACK选项，否则撤销检查只有在两个机制在上述条件之一失败时才能成功。 导致网络错误的异常被忽略，但可以稍后通过调用getSoftFailExceptions方法检索。

    • 方法详细信息

      • values

        public static PKIXRevocationChecker.Option[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PKIXRevocationChecker.Option c : PKIXRevocationChecker.Option.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PKIXRevocationChecker.Option valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PolicyNode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface PolicyNode

  • public interface PolicyNode
    由PKIX认证路径验证算法定义的不可变的有效策略树节点。

    PKIX认证路径验证算法的输出之一是有效的策略树，其中包括被确定为有效的策略，如何确定此策略以及遇到的任何策略限定符。 此树的深度为n ，其中n为已验证的认证路径的长度。

    大多数应用程序不需要检查有效的策略树。 他们可以通过设置PKIXParameters的策略相关参数来实现其策略处理目标。 然而，有效的策略树可用于更复杂的应用程序，特别是那些处理策略限定符的应用程序。

    PKIXCertPathValidatorResult.getPolicyTree返回有效策略树的根节点。 可以使用getChildren和getParent方法遍历树。 可以使用PolicyNode其他方法检索关于特定节点的数据。

    并发访问

    所有PolicyNode对象必须是不可变的和线程安全的。 多个线程可以同时在单个PolicyNode对象（或多个）上调用此类中定义的方法，而不会产生不良影响。 这个规定适用于这个类的所有公共领域和方法，以及任何由子类添加或覆盖的规则。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Iterator<? extends PolicyNode> getChildren​()
      返回该节点的子节点的迭代器。
      int getDepth​()
      返回此节点在有效策略树中的深度。
      Set<String> getExpectedPolicies​()
      返回在待处理的下一个证书中满足此节点有效策略的一组预期策略。
      PolicyNode getParent​()
      返回此节点的父节点，如果这是根节点，则返回 null 。
      Set<? extends PolicyQualifierInfo> getPolicyQualifiers​()
      返回与此节点所表示的有效策略相关联的策略限定符集。
      String getValidPolicy​()
      返回此节点所表示的有效策略。
      boolean isCritical​()
      返回最近处理的证书中的证书策略扩展的关键指标。

    • 方法详细信息

      • getParent

        PolicyNode getParent​()
        返回此节点的父节点，如果这是根节点，则返回 null 。
        结果
        该节点的父节点，如果这是根节点， null

      • getChildren

        Iterator<? extends PolicyNode> getChildren​()
        返回该节点的子节点的迭代器。 任何尝试通过Iterator的删除方法修改此节点的子节点都必须抛出一个UnsupportedOperationException 。
        结果
        这个节点的孩子的迭代器

      • getDepth

        int getDepth​()
        返回此节点在有效策略树中的深度。
        结果
        该节点的深度（根节点为0，其子节点为1，等等）

      • getValidPolicy

        String getValidPolicy​()
        返回此节点所表示的有效策略。
        结果
        该节点代表的有效策略的String OID。 对于根节点，此方法始终返回特殊的anyPolicy OID：“2.5.29.32.0”。

      • getPolicyQualifiers

        Set<? extends PolicyQualifierInfo> getPolicyQualifiers​()
        返回与此节点所表示的有效策略相关联的策略限定符集。
        结果
        一个不变的Set的PolicyQualifierInfo 。 对于根节点，这总是一个空的Set 。

      • getExpectedPolicies

        Set<String> getExpectedPolicies​()
        返回在待处理的下一个证书中满足此节点有效策略的一组预期策略。
        结果
        一个不可改变的Set预期政策String OID。 对于根节点，此方法总是返回一个Set的一个元素，特殊的anyPolicy OID：“2.5.29.32.0”。

      • isCritical

        boolean isCritical​()
        返回最近处理的证书中的证书策略扩展的关键指标。
        结果
        true如果扩展标记为关键，否则为false 。 对于根节点，总是返回false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PolicyQualifierInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class PolicyQualifierInfo

  • java.lang.Object
    • java.security.cert.PolicyQualifierInfo

  • public class PolicyQualifierInfo
extends Object
    由ASN.1 PolicyQualifierInfo结构表示的不可变策略限定符。

    ASN.1的定义如下：

      PolicyQualifierInfo ::= SEQUENCE {
        policyQualifierId       PolicyQualifierId,
        qualifier               ANY DEFINED BY policyQualifierId }

    证书策略扩展（如果存在于X.509版本3证书中）包含一个或多个策略信息项的序列，每个条件由对象标识符（OID）和可选的限定符组成。 在终端实体证书中，这些策略信息术语表示证书颁发的政策以及可以使用证书的目的。 在CA证书中，这些策略信息术语限制了包含此证书的认证路径的策略集。

    Set的PolicyQualifierInfo对象由PolicyNode.getPolicyQualifiers方法返回。 这允许具有特定策略要求的应用程序来处理和验证每个策略限定符。 在验证认证路径之前，需要处理策略限定符的应用程序应将policyQualifiersRejected标志显式设置为false（通过调用PKIXParameters.setPolicyQualifiersRejected方法）。

    请注意，PKIX认证路径验证算法指定必须处理和验证证书策略扩展中标记为关键的任何策略限定符。 否则认证路径必须被拒绝。 如果policyQualifiersRejected标志设置为false，则应用程序以此方式验证所有策略限定符，以便符合PKIX标准。

    并发访问

    所有PolicyQualifierInfo对象必须是不可变的和线程安全的。 也就是说，多个线程可以同时在单个PolicyQualifierInfo对象（或多个）上调用此类中定义的方法，而不会产生不良影响。 要求PolicyQualifierInfo对象是不可变的和线程安全的，可以将它们传递给各种代码，而不用担心协调访问。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      PolicyQualifierInfo​(byte[] encoded)
      从编码字节创建一个 PolicyQualifierInfo的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getEncoded​()
      返回此 PolicyQualifierInfo的ASN.1 DER编码形式。
      byte[] getPolicyQualifier​()
      返回此 PolicyQualifierInfo的 qualifier字段的ASN.1 DER编码形式。
      String getPolicyQualifierId​()
      返回 policyQualifierId这个领域 PolicyQualifierInfo 。
      String toString​()
      返回此可打印的表示 PolicyQualifierInfo 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PolicyQualifierInfo

        public PolicyQualifierInfo​(byte[] encoded)
                    throws IOException
        从编码字节创建一个PolicyQualifierInfo的实例。 编码字节数组在构造时被复制。
        参数
        encoded - 一个包含DER编码限定符的字节数组
        异常
        IOException - 如果字节数组不表示有效和可解析的策略限定符，则抛出

    • 方法详细信息

      • getPolicyQualifierId

        public final String getPolicyQualifierId​()
        返回policyQualifierId这个领域PolicyQualifierInfo 。 policyQualifierId是由句点分隔的一组非负整数表示的对象标识符（OID）。
        结果
        OID（从不 null ）

      • getEncoded

        public final byte[] getEncoded​()
        返回此 PolicyQualifierInfo的ASN.1 DER编码形式。
        结果
        ASN.1 DER编码字节（从不null ）。 请注意，将返回副本，因此每次调用此方法时都会克隆数据。

      • getPolicyQualifier

        public final byte[] getPolicyQualifier​()
        返回此 PolicyQualifierInfo的 qualifier字段的ASN.1 DER编码形式。
        结果
        ASN.1 DER编码的字节为qualifier字段。 请注意，将返回副本，因此每次调用此方法时都会克隆数据。

      • toString

        public String toString​()
        返回此 PolicyQualifierInfo的可打印 PolicyQualifierInfo 。
        重写：
        toString在 Object
        结果
        a String describing the contents of this PolicyQualifierInfo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TrustAnchor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class TrustAnchor

  • java.lang.Object
    • java.security.cert.TrustAnchor

  • public class TrustAnchor
extends Object
    信任锚或最受信任的证书颁发机构（CA）。

    该类表示一个“最受信任的CA”，它被用作验证X.509认证路径的信任锚点。 最受信任的CA包括CA的公钥，CA的名称以及可以使用该密钥验证的路径集合上的任何限制。 这些参数可以以可信X509Certificate或独立参数的形式指定。

    并发访问

    所有TrustAnchor对象必须是不可变的和线程安全的。 也就是说，多个线程可以同时在单个TrustAnchor对象（或多个）上调用此类中定义的方法，而不会产生不良影响。 要求TrustAnchor对象是不可变的和线程安全的，可以将它们传递到各种代码段，而不用担心协调访问。 这个规定适用于这个类的所有公共领域和方法，以及任何由子类添加或覆盖的规则。

    从以下版本开始：
    1.4
    另请参见：
    PKIXParameters(Set) ， PKIXBuilderParameters(Set, CertSelector)

    • 构造方法摘要

      构造方法
      Constructor 描述
      TrustAnchor​(String caName, PublicKey pubKey, byte[] nameConstraints)
      创建一个 TrustAnchor的实例，其中最受信任的CA被指定为可分辨名称和公钥。
      TrustAnchor​(X509Certificate trustedCert, byte[] nameConstraints)
      创建具有指定的 X509Certificate和可选名称约束的 TrustAnchor实例，这些约束用于在验证X.509认证路径时用作其他约束。
      TrustAnchor​(X500Principal caPrincipal, PublicKey pubKey, byte[] nameConstraints)
      创建一个 TrustAnchor的实例，其中最受信任的CA被指定为X500Principal和公钥。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      X500Principal getCA​()
      返回最受信任的CA作为X500Principal的名称。
      String getCAName​()
      返回RFC 2253 String格式中最受信任的CA的名称。
      PublicKey getCAPublicKey​()
      返回最受信任的CA的公钥。
      byte[] getNameConstraints​()
      返回名称约束参数。
      X509Certificate getTrustedCert​()
      返回最受信任的CA证书。
      String toString​()
      返回描述 TrustAnchor的格式化字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TrustAnchor

        public TrustAnchor​(X509Certificate trustedCert,
                   byte[] nameConstraints)
        创建具有指定的X509Certificate和可选名称约束的TrustAnchor实例，这些约束用于在验证X.509认证路径时用作其他约束。

        名称约束被指定为字节数组。 该字节数组应包含名称约束的DER编码形式，因为它们将出现在RFC 5280和X.509中定义的NameConstraints结构中。 此结构的ASN.1定义如下。

           NameConstraints ::= SEQUENCE { permittedSubtrees [0] GeneralSubtrees OPTIONAL, excludedSubtrees [1] GeneralSubtrees OPTIONAL } GeneralSubtrees ::= SEQUENCE SIZE (1..MAX) OF GeneralSubtree GeneralSubtree ::= SEQUENCE { base GeneralName, minimum [0] BaseDistance DEFAULT 0, maximum [1] BaseDistance OPTIONAL } BaseDistance ::= INTEGER (0..MAX) GeneralName ::= CHOICE { otherName [0] OtherName, rfc822Name [1] IA5String, dNSName [2] IA5String, x400Address [3] ORAddress, directoryName [4] Name, ediPartyName [5] EDIPartyName, uniformResourceIdentifier [6] IA5String, iPAddress [7] OCTET STRING, registeredID [8] OBJECT IDENTIFIER}

        请注意，提供的名称约束字节数组被克隆以防止后续修改。

        参数
        trustedCert - 信任的 X509Certificate
        nameConstraints - 包含用于检查名称约束的NameConstraints扩展的ASN.1 DER编码的字节数组。 只包括扩展的值，而不是OID或临界标志。 指定null以省略参数。
        异常
        IllegalArgumentException - 如果名称约束无法解码
        NullPointerException - 如果指定的 X509Certificate是 null

      • TrustAnchor

        public TrustAnchor​(X500Principal caPrincipal,
                   PublicKey pubKey,
                   byte[] nameConstraints)
        创建一个TrustAnchor的实例，其中最受信任的CA被指定为X500Principal和公钥。 名称约束是可选参数，并且在验证X.509认证路径时被用作额外的约束。

        名称约束被指定为字节数组。 该字节数组包含名称约束的DER编码形式，因为它们将出现在RFC 5280和X.509中定义的NameConstraints结构中。 该结构的ASN.1符号在TrustAnchor(X509Certificate trustedCert, byte[] nameConstraints) 的文档中提供。

        请注意，此处提供的名称约束字节数组被克隆以防止后续修改。

        参数
        caPrincipal - 最受信任的CA作为 caPrincipal的名称
        pubKey - 最受信任的CA的公钥
        nameConstraints - 包含用于检查名称约束的NameConstraints扩展的ASN.1 DER编码的字节数组。 只包括扩展的值，而不是OID或临界标志。 指定null省略参数。
        异常
        NullPointerException - 如果指定的 caPrincipal或 pubKey参数为 null
        从以下版本开始：
        1.5

      • TrustAnchor

        public TrustAnchor​(String caName,
                   PublicKey pubKey,
                   byte[] nameConstraints)
        创建一个TrustAnchor的实例，其中最受信任的CA被指定为可分辨名称和公钥。 名称约束是可选参数，并且在验证X.509认证路径时被用作额外的约束。

        名称约束被指定为字节数组。 该字节数组包含名称约束的DER编码形式，因为它们将出现在RFC 5280和X.509中定义的NameConstraints结构中。 该结构的ASN.1符号在TrustAnchor(X509Certificate trustedCert, byte[] nameConstraints) 的文档中提供。

        请注意，此处提供的名称约束字节数组被克隆以防止后续修改。

        参数
        caName - 最受信任的CA的X.500专有名称 RFC 2253 String格式
        pubKey - 最受信任的CA的公钥
        nameConstraints - 包含用于检查名称约束的NameConstraints扩展的ASN.1 DER编码的字节数组。 只包括扩展的值，而不是OID或临界标志。 指定null省略参数。
        异常
        IllegalArgumentException - 如果指定的 caName参数为空 (caName.length() == 0)或格式不正确或名称约束无法解码
        NullPointerException - 如果指定的 caName或 pubKey参数为 null

    • 方法详细信息

      • getTrustedCert

        public final X509Certificate getTrustedCert​()
        返回最受信任的CA证书。
        结果
        如果信任锚点未指定为受信任的证书，那么可信任的 X509Certificate或 null

      • getCA

        public final X500Principal getCA​()
        返回最受信任的CA作为X500Principal的名称。
        结果
        最信任的CA的X.500可分辨名称，或者如果信任锚点未指定为可信公用密钥和名称或X500Principal对， null
        从以下版本开始：
        1.5

      • getCAName

        public final String getCAName​()
        返回RFC 2253 String格式中最受信任的CA的名称。
        结果
        最信任的CA的X.500可分辨名称，或者如果信任锚没有被指定为可信公钥和名称或X500Principal对， null

      • getCAPublicKey

        public final PublicKey getCAPublicKey​()
        返回最受信任的CA的公钥。
        结果
        最信任的CA的公钥，或者如果信任锚没有被指定为可信公钥和名称或X500Principal对， null

      • getNameConstraints

        public final byte[] getNameConstraints​()
        返回名称约束参数。 指定的名称约束与此信任锚相关联，并且在验证X.509认证路径时旨在用作其他约束。

        名称约束作为字节数组返回。 该字节数组包含名称约束的DER编码形式，因为它们将出现在RFC 5280和X.509中定义的NameConstraints结构中。 该结构的ASN.1符号在TrustAnchor(X509Certificate trustedCert, byte[] nameConstraints) 的文档中提供。

        请注意，返回的字节数组被克隆以防止后续修改。

        结果
        一个包含用于检查名称约束的NameConstraints扩展的ASN.1 DER编码的字节数组，如果未设置 null 。

      • toString

        public String toString​()
        返回描述 TrustAnchor的格式化字符串。
        重写：
        toString在 Object
        结果
        a formatted string describing the TrustAnchor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


URICertStoreParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class URICertStoreParameters

  • java.lang.Object
    • java.security.cert.URICertStoreParameters
  • All Implemented Interfaces:
    Cloneable ， CertStoreParameters

    public final class URICertStoreParameters
extends Object
implements CertStoreParameters
    用作CertStore算法的参数的参数，其使用URI中包含的信息来检索证书和CRL。

    该类用于通过RFC 5280中定义的URI提供必要的配置参数，以实现CertStore算法。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    9
    另请参见：
    CertStore ， URI

    • 构造方法摘要

      构造方法
      Constructor 描述
      URICertStoreParameters​(URI uri)
      使用指定的URI创建一个 URICertStoreParameters的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      URICertStoreParameters clone​()
      返回此对象的副本。
      boolean equals​(Object p)
      将指定的对象与此参数对象进行比较以获得相等性。
      URI getURI​()
      返回用于构建此 URICertStoreParameters对象的URI。
      int hashCode​()
      返回此参数对象的哈希码值。
      String toString​()
      返回描述包含用于构造此对象的URI的参数的格式化字符串。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • URICertStoreParameters

        public URICertStoreParameters​(URI uri)
        使用指定的URI创建一个 URICertStoreParameters的实例。
        参数
        uri - 包含配置信息的URI。
        异常
        NullPointerException - 如果 uri为空

    • 方法详细信息

      • getURI

        public URI getURI​()
        返回用于构建此 URICertStoreParameters对象的URI。
        结果
        URI。

      • clone

        public URICertStoreParameters clone​()
        返回此对象的副本。 副本的更改不会影响原始文件，反之亦然。
        Specified by:
        clone在接口 CertStoreParameters
        重写：
        clone在 Object
        结果
        副本
        另请参见：
        Cloneable

      • hashCode

        public int hashCode​()
        返回此参数对象的哈希码值。 哈希码是使用构建中提供的URI生成的。
        重写：
        hashCode在 Object
        结果
        这个参数的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object p)
        将指定的对象与此参数对象进行比较以获得相等性。 如果用于构造它们的URI相等，则两个URICertStoreParameters被认为是相等的。
        重写：
        equals在 Object
        参数
        p - 测试与此参数相等的对象。
        结果
        如果指定的对象等于此参数对象，则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回描述包含用于构造此对象的URI的参数的格式化字符串。
        重写：
        toString在 Object
        结果
        描述参数的格式化字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.security.cert (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.security.cert

  • Packages that use java.security.cert
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    java.net
    提供实现网络应用程序的类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    javax.crypto
    提供加密操作的类和接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    jdk.security.jarsigner
  • Classes in java.security.cert used by com.sun.jarsigner
    Class 描述
    CertificateException
    此异常表示各种证书问题之一。
    X509Certificate
    X.509证书的抽象类。
  • Classes in java.security.cert used by java.net
    Class 描述
    Certificate
    用于管理各种身份证件的抽象类。
  • Classes in java.security.cert used by java.security
    Class 描述
    Certificate
    用于管理各种身份证件的抽象类。
    CertificateException
    此异常表示各种证书问题之一。
    CertPath
    证书的不可变序列（认证路径）。
  • Classes in java.security.cert used by java.security.cert
    Class 描述
    Certificate
    用于管理各种身份证件的抽象类。
    CertificateEncodingException
    证书编码异常。
    CertificateException
    此异常表示各种证书问题之一。
    CertificateExpiredException
    证书过期例外
    CertificateFactory
    该类定义了证书工厂的功能，用于从其编码生成证书，认证路径（ CertPath ）和证书吊销列表（CRL）对象。
    CertificateFactorySpi
    该类定义了 CertificateFactory类的 （ SPI ）。
    CertificateNotYetValidException
    证书还没有有效的例外。
    CertificateParsingException
    证书解析异常。
    CertPath
    证书的不可变序列（认证路径）。
    CertPathBuilder
    建立认证路径（也称为证书链）的课程。
    CertPathBuilderException
    一个例外，指出使用 CertPathBuilder构建认证路径时遇到的各种问题 CertPathBuilder 。
    CertPathBuilderResult
    认证路径构建器算法的结果的规范。
    CertPathBuilderSpi
    （ SPI ）为CertPathBuilder类。
    CertPathChecker
    对每个的一个或多个检查 Certificate一个的 CertPath 。
    CertPathParameters
    认证路径算法参数的规范。
    CertPathValidator
    用于验证认证路径（也称为证书链）的类。
    CertPathValidatorException
    表示验证认证路径时遇到的各种问题之一的异常。
    CertPathValidatorException.BasicReason
    BasicReason列举了任何类型的认证路径可能无效的潜在原因。
    CertPathValidatorException.Reason
    验证算法失败的原因。
    CertPathValidatorResult
    认证路径验证器算法的结果的规范。
    CertPathValidatorSpi
    （ SPI ）为CertPathValidator类。
    CertSelector
    一个选择器，定义了一组选择 Certificate的标准。
    CertStore
    从存储库检索 Certificate s和 CRL s的类。
    CertStoreException
    一个例外，指出从 CertStore检索证书和CRL的各种问题 CertStore 。
    CertStoreParameters
    规格参数 CertStore 。
    CertStoreSpi
    （ SPI ）为CertStore类。
    CRL
    该类是具有不同格式但重要常见用途的证书吊销列表（CRL）的抽象。
    CRLException
    CRL（证书撤销列表）异常。
    CRLReason
    CRLReason枚举指定证书被撤销的原因，如 RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile中所定义。
    CRLSelector
    一个选择器，定义一组选择 CRL的标准。
    Extension
    此接口表示X.509扩展。
    PKIXCertPathChecker
    对 X509Certificate执行一次或多次检查的抽象类。
    PKIXCertPathValidatorResult
    该类代表PKIX认证路径验证算法的成功结果。
    PKIXParameters
    参数用作PKIX CertPathValidator算法的输入。
    PKIXReason
    PKIXReason列举了根据PKIX（RFC 5280）标准，X.509认证路径可能无效的潜在PKIX特定原因。
    PKIXRevocationChecker
    A PKIXCertPathChecker用于使用PKIX算法检查证书的撤销状态。
    PKIXRevocationChecker.Option
    可以为吊销检查机制指定的各种撤销选项。
    PolicyNode
    由PKIX认证路径验证算法定义的不可变的有效策略树节点。
    PolicyQualifierInfo
    由ASN.1 PolicyQualifierInfo结构表示的不可变策略限定符。
    TrustAnchor
    信任锚或最受信任的证书颁发机构（CA）。
    URICertStoreParameters
    用作 CertStore算法的参数的参数，其使用URI中包含的信息来检索证书和CRL。
    X509Certificate
    X.509证书的抽象类。
    X509CRLEntry
    CRL（证书撤销列表）中撤销证书的抽象类。
    X509Extension
    X509扩展接口。
  • Classes in java.security.cert used by java.util.jar
    Class 描述
    Certificate
    用于管理各种身份证件的抽象类。
  • Classes in java.security.cert used by javax.crypto
    Class 描述
    Certificate
    用于管理各种身份证件的抽象类。
  • Classes in java.security.cert used by javax.net.ssl
    Class 描述
    Certificate
    用于管理各种身份证件的抽象类。
    CertificateException
    此异常表示各种证书问题之一。
    CertPathParameters
    认证路径算法参数的规范。
    X509Certificate
    X.509证书的抽象类。
  • Classes in java.security.cert used by javax.security.auth.x500
    Class 描述
    X509Certificate
    X.509证书的抽象类。
  • Classes in java.security.cert used by jdk.security.jarsigner
    Class 描述
    CertPath
    证书的不可变序列（认证路径）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


X509Certificate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class X509Certificate

  • java.lang.Object
    • java.security.cert.Certificate
      • java.security.cert.X509Certificate
  • All Implemented Interfaces:
    Serializable ， X509Extension

    public abstract class X509Certificate
extends Certificate
implements X509Extension

    X.509证书的抽象类。 这提供了访问X.509证书的所有属性的标准方法。

    1996年6月，基本的X.509 v3格式由ISO / IEC和ANSI X9完成，下文将在ASN.1中进行说明：

      Certificate  ::=  SEQUENCE  {
     tbsCertificate       TBSCertificate,
     signatureAlgorithm   AlgorithmIdentifier,
     signature            BIT STRING  }

    这些证书被广泛用于支持Internet安全系统中的身份验证和其他功能。 通用应用包括隐私增强邮件（PEM），传输层安全性（SSL），可靠软件分发的代码签名和安全电子交易（SET）。

    这些证书由证书颁发机构 （CA）进行管理和验证 。 CA是通过以X.509标准格式放置数据然后对数据进行数字签名来创建证书的服务。 CA作为可信赖的第三方，引导彼此之间没有直接了解的校长之间。 CA证书是由他们自己签名的，或由其他CA（如“root”）CA签名的。

    更多信息，请参见RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile 。

    tbsCertificate的ASN.1定义是：

      TBSCertificate  ::=  SEQUENCE  {
     version         [0]  EXPLICIT Version DEFAULT v1,
     serialNumber         CertificateSerialNumber,
     signature            AlgorithmIdentifier,
     issuer               Name,
     validity             Validity,
     subject              Name,
     subjectPublicKeyInfo SubjectPublicKeyInfo,
     issuerUniqueID  [1]  IMPLICIT UniqueIdentifier OPTIONAL,
                          -- If present, version must be v2 or v3
     subjectUniqueID [2]  IMPLICIT UniqueIdentifier OPTIONAL,
                          -- If present, version must be v2 or v3
     extensions      [3]  EXPLICIT Extensions OPTIONAL
                          -- If present, version must be v3
     }

    证书使用证书工厂实例化。 以下是如何实例化X.509证书的示例：

      try (InputStream inStream = new FileInputStream("fileName-of-cert")) {
     CertificateFactory cf = CertificateFactory.getInstance("X.509");
     X509Certificate cert = (X509Certificate)cf.generateCertificate(inStream);
 }
    从以下版本开始：
    1.2
    另请参见：
    Certificate ， CertificateFactory ， X509Extension ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.security.cert.Certificate

        Certificate.CertificateRep

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected X509Certificate​()
      X.509证书的构造方法。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void checkValidity​()
      检查证书当前是否有效。
      abstract void checkValidity​(Date date)
      检查给定日期是否在证书的有效期内。
      abstract int getBasicConstraints​()
      从关键的 BasicConstraints扩展名（OID = 2.5.29.19）获取证书约束路径长度。
      List<String> getExtendedKeyUsage​()
      获取表示扩展密钥使用扩展（OID = 2.5.29.37）的 ExtKeyUsageSyntax字段的OBJECT IDENTIFIER的字符串的不可修改列表。
      Collection<List<?>> getIssuerAlternativeNames​()
      从 IssuerAltName扩展名（OID = 2.5.29.18）获取不可变的发行人替代名称集合。
      abstract Principal getIssuerDN​()
      诋毁 ，取而代之的是 getIssuerX500Principal() 。
      abstract boolean[] getIssuerUniqueID​()
      从证书获取 issuerUniqueID价值。
      X500Principal getIssuerX500Principal​()
      从证书中返回发行人（发行人可分辨名称）值为 X500Principal 。
      abstract boolean[] getKeyUsage​()
      获取表示 KeyUsage扩展名（OID = 2.5.29.15）的位的布尔数组。
      abstract Date getNotAfter​()
      从证书的有效期获取 notAfter日期。
      abstract Date getNotBefore​()
      从证书的有效期获取 notBefore日期。
      abstract BigInteger getSerialNumber​()
      获取证书中的 serialNumber值。
      abstract String getSigAlgName​()
      获取证书签名算法的签名算法名称。
      abstract String getSigAlgOID​()
      从证书获取签名算法OID字符串。
      abstract byte[] getSigAlgParams​()
      从该证书的签名算法获取DER编码的签名算法参数。
      abstract byte[] getSignature​()
      获取 signature中的 signature值（原始签名位）。
      Collection<List<?>> getSubjectAlternativeNames​()
      从 SubjectAltName扩展名（OID = 2.5.29.17）获取不可变的主题替代名称集合。
      abstract Principal getSubjectDN​()
      诋毁 ，取而代之的是 getSubjectX500Principal() 。
      abstract boolean[] getSubjectUniqueID​()
      从证书获取 subjectUniqueID价值。
      X500Principal getSubjectX500Principal​()
      从证书返回主题（主体可分辨名称）值作为 X500Principal 。
      abstract byte[] getTBSCertificate​()
      从该证书获取DER编码的证书信息， tbsCertificate 。
      abstract int getVersion​()
      从证书获取 version （版本号）值。
      void verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。

      • Methods inherited from class java.security.cert.Certificate

        equals, getEncoded, getPublicKey, getType, hashCode, toString, verify, verify, writeReplace

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.cert.X509Extension

        getCriticalExtensionOIDs, getExtensionValue, getNonCriticalExtensionOIDs, hasUnsupportedCriticalExtension

    • 构造方法详细信息

      • X509Certificate

        protected X509Certificate​()
        X.509证书的构造方法。

    • 方法详细信息

      • checkValidity

        public abstract void checkValidity​()
                            throws CertificateExpiredException,
                                   CertificateNotYetValidException
        检查证书当前是否有效。 如果当前日期和时间在证书中给出的有效期内。

        有效期由两个日期/时间值组成：证书有效的第一个和最后一个日期（和时间）。 它在ASN.1中定义为：

          validity             Validity

 Validity ::= SEQUENCE {
     notBefore      CertificateValidityDate,
     notAfter       CertificateValidityDate }

 CertificateValidityDate ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }
        异常
        CertificateExpiredException - 如果证书已过期。
        CertificateNotYetValidException - 如果证书尚未生效。

      • checkValidity

        public abstract void checkValidity​(Date date)
                            throws CertificateExpiredException,
                                   CertificateNotYetValidException
        检查给定日期是否在证书的有效期内。 换句话说，这决定了证书在给定的日期/时间是否有效。
        参数
        date - 在该日期/时间检查此证书是否有效的日期。
        异常
        CertificateExpiredException - 如果证书已经到期提供的 date 。
        CertificateNotYetValidException - 如果证书尚未对所提供的 date有效。
        另请参见：
        checkValidity()

      • getVersion

        public abstract int getVersion​()
        获取证书中的version （版本号）值。 ASN.1的定义是：
          version  [0] EXPLICIT Version DEFAULT v1

 Version ::=  INTEGER  {  v1(0), v2(1), v3(2)  }
        结果
        版本号，即1或2。

      • getSerialNumber

        public abstract BigInteger getSerialNumber​()
        从证书中获取serialNumber值。 序列号是由证书颁发机构分配给每个证书的整数。 对于由给定CA颁发的每个证书（即，发行者名称和序列号标识唯一证书），它必须是唯一的。 ASN.1的定义是：
          serialNumber     CertificateSerialNumber

 CertificateSerialNumber  ::=  INTEGER
        结果
        序列号。

      • getIssuerDN

        public abstract Principal getIssuerDN​()
        诋毁 ，取而代之的是getIssuerX500Principal() 。 该方法返回issuer作为实现特定的Principal对象，不应该由便携式代码依赖。

        从证书获取issuer （发行人可分辨名称）值。 发行人名称标识签发（并签发）证书的实体。

        发行人名称字段包含X.500可分辨名称（DN）。 ASN.1的定义是：

          issuer    Name

 Name ::= CHOICE { RDNSequence }
 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName
 RelativeDistinguishedName ::=
     SET OF AttributeValueAssertion

 AttributeValueAssertion ::= SEQUENCE {
                               AttributeType,
                               AttributeValue }
 AttributeType ::= OBJECT IDENTIFIER
 AttributeValue ::= ANY
        Name描述了由属性组成的分层名称，例如国家名称和相应的值，例如US。 的类型的AttributeValue分量由确定AttributeType ; 一般来说将会是一个directoryString 。 甲directoryString通常之一PrintableString ， TeletexString或UniversalString 。
        结果
        一位姓名为发行人名称的校长。

      • getIssuerX500Principal

        public X500Principal getIssuerX500Principal​()
        从证书中返回发行人（发行人可分辨名称）值作为X500Principal 。

        建议子类覆盖此方法。

        结果
        一个 X500Principal代表发行人的可分辨名称
        从以下版本开始：
        1.4

      • getSubjectDN

        public abstract Principal getSubjectDN​()
        诋毁 ，取而代之的是getSubjectX500Principal() 。 该方法返回subject作为实现特定的Principal对象，不应该由便携式代码依赖。

        从证书中获取subject （主题可分辨名称）值。 如果subject值为空，则返回的Principal对象的getName()方法返回一个空字符串（“”）。

        ASN.1的定义是：

          subject    Name

        参见getIssuerDN和Name等相关定义。

        结果
        名称为主题名称的校长。

      • getSubjectX500Principal

        public X500Principal getSubjectX500Principal​()
        从证书中返回主题（主体可分辨名称）值作为X500Principal 。 如果主题值为空，则返回的X500Principal对象的getName()方法返回一个空字符串（“”）。

        建议子类覆盖此方法。

        结果
        一个 X500Principal代表主题的专有名称
        从以下版本开始：
        1.4

      • getNotBefore

        public abstract Date getNotBefore​()
        从证书的有效期获取notBefore日期。 相关的ASN.1定义是：
          validity             Validity

 Validity ::= SEQUENCE {
     notBefore      CertificateValidityDate,
     notAfter       CertificateValidityDate }

 CertificateValidityDate ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }
        结果
        有效期的开始日期。
        另请参见：
        checkValidity()

      • getNotAfter

        public abstract Date getNotAfter​()
        从证书的有效期获取notAfter日期。 有关ASN.1定义，请参见getNotBefore 。
        结果
        有效期结束日期。
        另请参见：
        checkValidity()

      • getTBSCertificate

        public abstract byte[] getTBSCertificate​()
                                  throws CertificateEncodingException
        从该证书获取DER编码的证书信息， tbsCertificate 。 这可以独立地用于验证签名。
        结果
        DER编码的证书信息。
        异常
        CertificateEncodingException - 如果发生编码错误。

      • getSignature

        public abstract byte[] getSignature​()
        从证书获取signature值（原始签名位）。 ASN.1的定义是：
          signature     BIT STRING
        结果
        签名。

      • getSigAlgName

        public abstract String getSigAlgName​()
        获取证书签名算法的签名算法名称。 一个例子是字符串“SHA256withRSA”。 ASN.1的定义是：
          signatureAlgorithm   AlgorithmIdentifier

 AlgorithmIdentifier  ::=  SEQUENCE  {
     algorithm               OBJECT IDENTIFIER,
     parameters              ANY DEFINED BY algorithm OPTIONAL  }
                             -- contains a value of the type
                             -- registered for use with the
                             -- algorithm object identifier value

        算法名称由algorithm OID字符串确定。

        结果
        签名算法名称。

      • getSigAlgOID

        public abstract String getSigAlgOID​()
        从证书获取签名算法OID字符串。 OID由一组由周期分隔的非负整数表示。 例如，字符串“1.2.840.10040.4.3”标识了在RFC 3279: Algorithms and Identifiers for the Internet X.509 Public Key Infrastructure Certificate and CRL Profile中定义的具有DSA签名算法的SHA-1。

        有关ASN.1定义，请参见getSigAlgName 。

        结果
        签名算法OID字符串。

      • getSigAlgParams

        public abstract byte[] getSigAlgParams​()
        从该证书的签名算法获取DER编码的签名算法参数。 在大多数情况下，签名算法参数为null; 参数通常随附证书的公钥一起提供。 如果需要访问个别参数值，则使用AlgorithmParameters与返回的名称进行实例化getSigAlgName 。

        有关ASN.1定义，请参阅getSigAlgName 。

        结果
        DER编码的签名算法参数，如果没有参数，则为null。

      • getIssuerUniqueID

        public abstract boolean[] getIssuerUniqueID​()
        从证书中获取issuerUniqueID值。 颁发者唯一标识符存在于证书中以处理随时间重用发行者名称的可能性。 RFC 5280建议不再重复使用名称，并且符合规范的证书不会使用唯一的标识符。 符合该配置文件的应用程序应能够解析唯一标识符并进行比较。

        ASN.1的定义是：

          issuerUniqueID  [1]  IMPLICIT UniqueIdentifier OPTIONAL

 UniqueIdentifier  ::=  BIT STRING
        结果
        颁发者唯一标识符，如果证书中不存在则为null。

      • getSubjectUniqueID

        public abstract boolean[] getSubjectUniqueID​()
        从证书获取subjectUniqueID值。

        ASN.1的定义是：

          subjectUniqueID  [2]  IMPLICIT UniqueIdentifier OPTIONAL

 UniqueIdentifier  ::=  BIT STRING
        结果
        主题唯一标识符，如果证书中不存在则为null。

      • getKeyUsage

        public abstract boolean[] getKeyUsage​()
        获取表示KeyUsage扩展名（OID = 2.5.29.15）的位的布尔数组。 密钥使用扩展定义了证书中包含的密钥的目的（例如，加密，签名，证书签名）。 ASN.1的定义是：
          KeyUsage ::= BIT STRING {
     digitalSignature        (0),
     nonRepudiation          (1),
     keyEncipherment         (2),
     dataEncipherment        (3),
     keyAgreement            (4),
     keyCertSign             (5),
     cRLSign                 (6),
     encipherOnly            (7),
     decipherOnly            (8) }
        RFC 5280建议在使用时将其标记为关键扩展。
        结果
        该证书的KeyUsage扩展名，表示为一组布尔值。 阵列中KeyUsage值的顺序与上述ASN.1定义相同。 该数组将包含上面定义的每个KeyUsage的值。 如果证书中编码的KeyUsage列表长于上述列表，则不会被截断。 如果此证书不包含KeyUsage扩展名，则返回null。

      • getExtendedKeyUsage

        public List<String> getExtendedKeyUsage​()
                                 throws CertificateParsingException
        获取表示扩展密钥使用扩展的ExtKeyUsageSyntax字段的对象标识符（OID = 2.5.29.37）的字符串的不可修改列表。 它指示除了或代替密钥使用扩展字段中指示的基本目的之外，还可以使用认证公钥的一个或多个目的。 ASN.1的定义是：
          ExtKeyUsageSyntax ::= SEQUENCE SIZE (1..MAX) OF KeyPurposeId

 KeyPurposeId ::= OBJECT IDENTIFIER
        任何有需要的组织都可以定义关键用途。 用于识别关键用途的对象标识符应根据IANA或ITU-T Rec。 X.660 | ISO / IEC / ITU 9834-1。

        该方法被添加到Java 2平台标准版的1.4版本。 为了保持与现有服务提供商的向后兼容性，此方法不是abstract ，它提供了默认的实现。 子类应该使用正确的实现来覆盖此方法。

        结果
        该证书的ExtendedKeyUsage扩展名作为表示为字符串的对象标识符的不可修改列表。 如果此证书不包含ExtendedKeyUsage扩展名，则返回null。
        异常
        CertificateParsingException - 如果扩展名无法解码
        从以下版本开始：
        1.4

      • getBasicConstraints

        public abstract int getBasicConstraints​()
        从关键的BasicConstraints扩展名（OID = 2.5.29.19）获取证书约束路径长度。

        基本约束扩展标识证书的主体是证书颁发机构（CA），以及证书路径可能通过该CA可能存在多深。 pathLenConstraint字段（见下文）只有在cA设置为TRUE时才有意义。 在这种情况下，它会给出证书路径中可能遵循此证书的CA证书的最大数量。 值为零表示只有终端实体证书可能在路径中。

        ASN.1的定义是：

          BasicConstraints ::= SEQUENCE {
     cA                  BOOLEAN DEFAULT FALSE,
     pathLenConstraint   INTEGER (0..MAX) OPTIONAL }
        结果
        如果BasicConstraints扩展存在于证书中，则该值为pathLenConstraint ，并且证书的主题是CA，否则为-1。 如果该证书的主体是CA和pathLenConstraint没有出现， Integer.MAX_VALUE返回，表明没有限制的认证路径的允许长度。

      • getSubjectAlternativeNames

        public Collection<List<?>> getSubjectAlternativeNames​()
                                               throws CertificateParsingException
        从SubjectAltName扩展名（OID = 2.5.29.17）获取不可变的主题替代名称集合。

        SubjectAltName扩展的ASN.1定义是：

          SubjectAltName ::= GeneralNames

 GeneralNames :: = SEQUENCE SIZE (1..MAX) OF GeneralName

 GeneralName ::= CHOICE {
      otherName                       [0]     OtherName,
      rfc822Name                      [1]     IA5String,
      dNSName                         [2]     IA5String,
      x400Address                     [3]     ORAddress,
      directoryName                   [4]     Name,
      ediPartyName                    [5]     EDIPartyName,
      uniformResourceIdentifier       [6]     IA5String,
      iPAddress                       [7]     OCTET STRING,
      registeredID                    [8]     OBJECT IDENTIFIER}

        如果此证书不包含SubjectAltName扩展名，则返回null 。 否则， Collection返回与表示每个条目GeneralName包含在扩展。 每个条目是List其第一个条目是Integer （名称类型，0-8），第二个条目是String或字节数组（名称，分别为字符串或ASN.1 DER编码形式）。

        RFC 822 ，DNS和URI名称返回为String s，使用完善的字符串格式为这些类型（受到包含在RFC 5280中的限制）。 IPv4地址名称使用虚线四舍五入方法返回。 IPv6地址名称以“a1：a2：...：a8”的形式返回，其中a1-a8是十六进制值，表示地址的8位16位。 OID名称返回为String表示为以句点分隔的一系列非负整数。 并且目录名称（可分辨名称）以RFC 2253字符串格式返回。 没有为其他名称，X.400名称，EDI方名称或任何其他类型的名称定义标准字符串格式。 它们作为包含名称的ASN.1 DER编码形式的字节数组返回。

        请注意，返回的Collection可能包含多个相同类型的名称。 另外，请注意，返回的Collection是不可变的，并且克隆任何包含字节数组的条目以防止后续修改。

        该方法被添加到Java 2平台标准版的1.4版本。 为了保持与现有服务提供商的向后兼容性，此方法不是abstract ，它提供了默认的实现。 子类应该使用正确的实现来覆盖此方法。

        结果
        不可变的 Collection主题备选名称（或 null ）
        异常
        CertificateParsingException - 如果扩展名无法解码
        从以下版本开始：
        1.4

      • getIssuerAlternativeNames

        public Collection<List<?>> getIssuerAlternativeNames​()
                                              throws CertificateParsingException
        从IssuerAltName扩展名（OID = 2.5.29.18）获取不可变的发行人替代名称集合。

        IssuerAltName扩展的ASN.1定义是：

          IssuerAltName ::= GeneralNames
        的ASN.1定义GeneralNames中定义getSubjectAlternativeNames 。

        如果此证书不包含IssuerAltName扩展名，则返回null 。 否则， Collection返回与表示每个条目GeneralName包含在扩展。 每个条目是一个List其第一个条目是Integer （名称类型，0-8），其第二个条目是String或字节数组（名称，分别为字符串或ASN.1 DER编码形式）。 有关每种名称类型使用的格式的详细信息，请参阅getSubjectAlternativeNames方法。

        请注意，返回的Collection可能包含多个相同类型的名称。 另外，请注意，返回的Collection是不可变的，并且克隆了包含字节数组的任何条目以防止后续修改。

        该方法被添加到Java 2平台标准版的1.4版本。 为了保持与现有服务提供商的向后兼容性，此方法不是abstract ，它提供了默认的实现。 子类应该使用正确的实现来覆盖此方法。

        结果
        发行人替代名称不可变 Collection （或 null ）
        异常
        CertificateParsingException - 如果扩展名无法解码
        从以下版本开始：
        1.4

      • verify

        public void verify​(PublicKey key,
                   Provider sigProvider)
            throws CertificateException,
                   NoSuchAlgorithmException,
                   InvalidKeyException,
                   SignatureException
        使用与指定公钥对应的私钥验证此证书是否已经签名。 此方法使用指定提供商提供的签名验证引擎。 请注意，指定的Provider对象不必在提供者列表中注册。 该方法被添加到Java Platform Standard Edition的1.8版本。 为了保持与现有服务提供商的向后兼容性，此方法不是abstract ，它提供了默认的实现。
        重写：
        verify在 Certificate
        参数
        key - 用于执行验证的PublicKey。
        sigProvider - 签名提供者。
        异常
        NoSuchAlgorithmException - 不支持的签名算法。
        InvalidKeyException - 键错误。
        SignatureException - 签名错误。
        CertificateException - 编码错误。
        UnsupportedOperationException - 如果不支持该方法
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


X509CertSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class X509CertSelector

  • java.lang.Object
    • java.security.cert.X509CertSelector
  • All Implemented Interfaces:
    Cloneable ， CertSelector

    public class X509CertSelector
extends Object
implements CertSelector
    A CertSelector ，选择符合所有指定条件的X509Certificates 。 当从CertStore选择证书以构建符合PKIX的认证路径时，此类特别有用。

    当第一次构造中， X509CertSelector启用没有标准，并且每个所述get方法返回默认值（ null ，或-1为getBasicConstraints方法）。 因此， match方法将返回true任何X509Certificate 。 通常，启用了几个条件（例如通过调用setIssuer或setKeyUsage ），然后将X509CertSelector传递给CertStore.getCertificates或一些类似的方法。

    可以启用几个标准（例如，通过调用setIssuer和setSerialNumber ），使得match方法通常唯一匹配单个X509Certificate 。 我们通常说，因为两个发行CA可能具有相同的可分辨名称，并且每个发出具有相同序列号的证书。 其他独特组合包括发行人，主题，subjectKeyIdentifier和/或subjectPublicKey标准。

    有关下列X.509证书扩展的定义，请参阅RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile 。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CertSelector ， X509Certificate

    • 构造方法摘要

      构造方法
      Constructor 描述
      X509CertSelector​()
      创建一个 X509CertSelector 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addPathToName​(int type, byte[] name)
      在pathToNames条件中添加一个名称。
      void addPathToName​(int type, String name)
      在pathToNames条件中添加一个名称。
      void addSubjectAlternativeName​(int type, byte[] name)
      在subjectAlternativeNames条件中添加一个名称。
      void addSubjectAlternativeName​(int type, String name)
      在subjectAlternativeNames条件中添加一个名称。
      Object clone​()
      返回此对象的副本。
      byte[] getAuthorityKeyIdentifier​()
      返回authorityKeyIdentifier标准。
      int getBasicConstraints​()
      返回基本约束约束。
      X509Certificate getCertificate​()
      返回certificateEquals标准。
      Date getCertificateValid​()
      返回certificateValid条件。
      Set<String> getExtendedKeyUsage​()
      返回extendedKeyUsage标准。
      X500Principal getIssuer​()
      作为 X500Principal返回发行人标准。
      byte[] getIssuerAsBytes​()
      作为字节数组返回发行方标准。
      String getIssuerAsString​()
      诋毁 ，使用 getIssuer()或者 getIssuerAsBytes()代替。
      boolean[] getKeyUsage​()
      返回keyUsage标准。
      boolean getMatchAllSubjectAltNames​()
      指示 X509Certificate必须包含 setSubjectAlternativeNames或 addSubjectAlternativeName方法中指定的所有或至少一个 subjectAlternativeNames 。
      byte[] getNameConstraints​()
      返回名称约束条件。
      Collection<List<?>> getPathToNames​()
      返回pathToNames条件的副本。
      Set<String> getPolicy​()
      返回策略标准。
      Date getPrivateKeyValid​()
      返回privateKeyValid条件。
      BigInteger getSerialNumber​()
      返回serialNumber标准。
      X500Principal getSubject​()
      返回主题标准为 X500Principal 。
      Collection<List<?>> getSubjectAlternativeNames​()
      返回subjectAlternativeNames条件的副本。
      byte[] getSubjectAsBytes​()
      以字节数组形式返回主题标准。
      String getSubjectAsString​()
      诋毁 ，使用 getSubject()或者 getSubjectAsBytes()代替。
      byte[] getSubjectKeyIdentifier​()
      返回subjectKeyIdentifier标准。
      PublicKey getSubjectPublicKey​()
      返回subjectPublicKey标准。
      String getSubjectPublicKeyAlgID​()
      返回subjectPublicKeyAlgID条件。
      boolean match​(Certificate cert)
      决定是否选择 Certificate 。
      void setAuthorityKeyIdentifier​(byte[] authorityKeyID)
      设置authorityKeyIdentifier标准。
      void setBasicConstraints​(int minMaxPathLen)
      设置基本约束约束。
      void setCertificate​(X509Certificate cert)
      设置certificateEquals标准。
      void setCertificateValid​(Date certValid)
      设置certificateValid标准。
      void setExtendedKeyUsage​(Set<String> keyPurposeSet)
      设置extendedKeyUsage标准。
      void setIssuer​(byte[] issuerDN)
      设定发行人标准。
      void setIssuer​(String issuerDN)
      诋毁 ，使用 setIssuer(X500Principal)或者 setIssuer(byte[])代替。
      void setIssuer​(X500Principal issuer)
      设定发行人标准。
      void setKeyUsage​(boolean[] keyUsage)
      设置keyUsage标准。
      void setMatchAllSubjectAltNames​(boolean matchAllNames)
      启用/禁用匹配 setSubjectAlternativeNames或 addSubjectAlternativeName方法中指定的所有 subjectAlternativeNames 。
      void setNameConstraints​(byte[] bytes)
      设置名称约束条件。
      void setPathToNames​(Collection<List<?>> names)
      设置pathToNames条件。
      void setPolicy​(Set<String> certPolicySet)
      设置策略约束。
      void setPrivateKeyValid​(Date privateKeyValid)
      设置privateKeyValid条件。
      void setSerialNumber​(BigInteger serial)
      设置serialNumber标准。
      void setSubject​(byte[] subjectDN)
      设置主题标准。
      void setSubject​(String subjectDN)
      诋毁 ，使用 setSubject(X500Principal)或者 setSubject(byte[])代替。
      void setSubject​(X500Principal subject)
      设置主题标准。
      void setSubjectAlternativeNames​(Collection<List<?>> names)
      设置subjectAlternativeNames标准。
      void setSubjectKeyIdentifier​(byte[] subjectKeyID)
      设置subjectKeyIdentifier标准。
      void setSubjectPublicKey​(byte[] key)
      设置subjectPublicKey标准。
      void setSubjectPublicKey​(PublicKey key)
      设置subjectPublicKey标准。
      void setSubjectPublicKeyAlgID​(String oid)
      设置subjectPublicKeyAlgID标准。
      String toString​()
      返回 CertSelector的可打印表示。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • X509CertSelector

        public X509CertSelector​()
        创建一个X509CertSelector 。 最初，没有任何标准设置，所以任何X509Certificate将匹配。

    • 方法详细信息

      • setCertificate

        public void setCertificate​(X509Certificate cert)
        设置certificateEquals标准。 指定的X509Certificate必须等于X509Certificate传递给match方法。 如果是null ，那么这个检查是不适用的。

        当需要匹配单个证书时，此方法特别有用。 虽然可以与certificateEquals标准一起指定其他标准，但通常不实际或必要。

        参数
        cert - 要匹配的 X509Certificate （或 null ）
        另请参见：
        getCertificate()

      • setSerialNumber

        public void setSerialNumber​(BigInteger serial)
        设置serialNumber标准。 指定的序列号必须与X509Certificate中的证书序列号X509Certificate 。 如果是null ，任何证书序列号都可以。
        参数
        serial - 要匹配的证书序列号（或 null ）
        另请参见：
        getSerialNumber()

      • setIssuer

        public void setIssuer​(X500Principal issuer)
        设定发行人标准。 指定的可分辨名称必须与X509Certificate中的发行人可分辨名称相匹配。 如果是null ，任何发行人的辨别名都可以。
        参数
        issuer - 专有名称为 null （或 null ）
        从以下版本开始：
        1.5

      • setIssuer

        public void setIssuer​(String issuerDN)
               throws IOException
        诋毁 ，使用setIssuer(X500Principal)或者setIssuer(byte[])代替。 不应该依赖此方法，因为由于某些可分辨名称的RFC 2253字符串形式中的编码信息丢失，它可能无法匹配某些证书。

        设定发行人标准。 指定的可分辨名称必须与X509Certificate中的发行人可分辨名称相匹配。 如果是null ，任何发行人的辨别名都可以。

        如果issuerDN不是null ，它应该包含一个可分辨的名称，以RFC 2253格式。

        参数
        issuerDN - RFC 2253格式的专有名称（或 null ）
        异常
        IOException - 如果发生解析错误（DN的表单不正确）

      • setIssuer

        public void setIssuer​(byte[] issuerDN)
               throws IOException
        设定发行人标准。 指定的可分辨名称必须与X509Certificate中的发行人可分辨名称相匹配。 如果指定了null ，则发行人标准被禁用，任何发行人的可分辨名称都可以。

        如果issuerDN不是null ，它应该包含单个DER编码的可分辨名称，如X.501中所定义。 该结构的ASN.1符号如下。

           Name ::= CHOICE { RDNSequence } RDNSequence ::= SEQUENCE OF RelativeDistinguishedName RelativeDistinguishedName ::= SET SIZE (1 .. MAX) OF AttributeTypeAndValue AttributeTypeAndValue ::= SEQUENCE { type AttributeType, value AttributeValue } AttributeType ::= OBJECT IDENTIFIER AttributeValue ::= ANY DEFINED BY AttributeType .... DirectoryString ::= CHOICE { teletexString TeletexString (SIZE (1..MAX)), printableString PrintableString (SIZE (1..MAX)), universalString UniversalString (SIZE (1..MAX)), utf8String UTF8String (SIZE (1.. MAX)), bmpString BMPString (SIZE (1..MAX)) }

        请注意，此处指定的字节数组被克隆以防止后续修改。

        参数
        issuerDN - 包含ASN.1 DER编码格式（或 null ）中的可分辨名称的字节数组
        异常
        IOException - 如果出现编码错误（DN格式不正确）

      • setSubject

        public void setSubject​(X500Principal subject)
        设置主题标准。 指定的可分辨名称必须与X509Certificate中的主题识别名称相X509Certificate 。 如果是null ，任何主题的专有名称都会做。
        参数
        subject - 作为 subject的专有名称（或 null ）
        从以下版本开始：
        1.5

      • setSubject

        public void setSubject​(String subjectDN)
                throws IOException
        诋毁 ，使用setSubject(X500Principal)或者setSubject(byte[])代替。 不应该依赖此方法，因为由于某些特定名称的RFC 2253字符串形式的编码信息丢失，因为它可能无法匹配某些证书。

        设置主题标准。 指定的可分辨名称必须与X509Certificate中的主题可分辨名称相匹配。 如果是null ，任何主题的专有名称都会做。

        如果subjectDN不是null ，它应该包含一个可分辨的名称，以RFC 2253格式。

        参数
        subjectDN - RFC 2253格式的专有名称（或 null ）
        异常
        IOException - 如果发生解析错误（DN的表单不正确）

      • setSubject

        public void setSubject​(byte[] subjectDN)
                throws IOException
        设置主题标准。 指定的可分辨名称必须与X509Certificate中的主题可分辨名称相匹配。 如果是null ，任何主题的专有名称都会做。

        如果subjectDN不是null ，它应该包含单个DER编码的可分辨名称，如X.501中所定义。 对于该结构的ASN.1符号，请参阅setIssuer(byte [] issuerDN) 。

        参数
        subjectDN - 包含ASN.1 DER格式（或 null ）中的可分辨名称的字节数组
        异常
        IOException - 如果出现编码错误（DN格式不正确）

      • setSubjectKeyIdentifier

        public void setSubjectKeyIdentifier​(byte[] subjectKeyID)
        设置subjectKeyIdentifier标准。 X509Certificate必须包含一个SubjectKeyIdentifier扩展名，扩展名的内容与指定的标准值匹配。 如果标准值为null ，则不会对subjectKeyIdentifier进行检查。

        如果subjectKeyID不是null ，它应该包含与SubjectKeyIdentifier扩展名的扩展值（不包括对象标识符，关键性设置和封装OCTET STRING）的内容相对应的单个DER编码值。 以下是ASN.1符号。

           SubjectKeyIdentifier ::= KeyIdentifier KeyIdentifier ::= OCTET STRING

        由于主题标识符的格式不受任何标准的约束，因此主题标识符不会被X509CertSelector解析。 相反，使用逐字节比较来比较值。

        请注意，此处提供的字节数组被克隆以防止后续修改。

        参数
        subjectKeyID - 主题标识符（或 null ）
        另请参见：
        getSubjectKeyIdentifier()

      • setAuthorityKeyIdentifier

        public void setAuthorityKeyIdentifier​(byte[] authorityKeyID)
        设置authorityKeyIdentifier标准。 X509Certificate必须包含一个AuthorityKeyIdentifier扩展名，扩展名的内容与指定的标准值匹配。 如果标准值为null ， null不会执行authorityKeyIdentifier权限检查。

        如果authorityKeyID不是null ，它应该包含一个对应于AuthorityKeyIdentifier扩展的扩展值（不包括对象标识符，关键性设置和封装OCTET STRING）的内容的单个DER编码值。 以下是ASN.1符号。

           AuthorityKeyIdentifier ::= SEQUENCE { keyIdentifier [0] KeyIdentifier OPTIONAL, authorityCertIssuer [1] GeneralNames OPTIONAL, authorityCertSerialNumber [2] CertificateSerialNumber OPTIONAL } KeyIdentifier ::= OCTET STRING

        权限密钥标识符不由X509CertSelector解析。 相反，使用逐字节比较来比较值。

        当keyIdentifier领域AuthorityKeyIdentifier填充，该值通常取自SubjectKeyIdentifier延长发行人的证书中。 但是，请注意，发行人证书上的X509Certificate.getExtensionValue(<SubjectKeyIdentifier Object Identifier>)的结果可能不能直接用作setAuthorityKeyIdentifier的输入。 这是因为SubjectKeyIdentifier只包含一个KeyIdentifier OCTET STRING，而不包含KeyIdentifier，GeneralNames和CertificateSerialNumber的SEQUENCE。 为了使用发卡行证书的SubjectKeyIdentifier扩展名的扩展值，必须提取嵌入式KeyIdentifier OCTET STRING的值，然后将该OCTET STRING的编码为SEQUENCE。 有关SubjectKeyIdentifier的更多详细信息，请参阅setSubjectKeyIdentifier(byte[] subjectKeyID) 。

        还要注意，此处提供的字节数组被克隆以防止后续修改。

        参数
        authorityKeyID - 权限密钥标识符（或 null ）
        另请参见：
        getAuthorityKeyIdentifier()

      • setCertificateValid

        public void setCertificateValid​(Date certValid)
        设置certificateValid标准。 指定的日期必须在X509Certificate的证书有效期内。 如果是null ，则不会进行certificateValid检查。

        请注意， Date提供的Date被克隆以防止后续修改。

        参数
        certValid - 要查询的 Date （或 null ）
        另请参见：
        getCertificateValid()

      • setPrivateKeyValid

        public void setPrivateKeyValid​(Date privateKeyValid)
        设置privateKeyValid条件。 指定的日期必须在X509Certificate的私钥有效期内。 如果是null ，则不进行privateKeyValid检查。

        请注意， Date提供的Date被克隆以防止后续修改。

        参数
        privateKeyValid - 要查询的 Date （或 null ）
        另请参见：
        getPrivateKeyValid()

      • setSubjectPublicKeyAlgID

        public void setSubjectPublicKeyAlgID​(String oid)
                              throws IOException
        设置subjectPublicKeyAlgID标准。 X509Certificate必须包含具有指定算法的主题公钥。 如果是null ，则不会对subjectPublicKeyAlgID进行检查。
        参数
        oid - 要检查的算法的对象标识符（OID）（或null ）。 OID由以句点分隔的一组非负整数表示。
        异常
        IOException - 如果OID无效，例如第一个组件不是0,1或2或第二个组件大于39。
        另请参见：
        getSubjectPublicKeyAlgID()

      • setSubjectPublicKey

        public void setSubjectPublicKey​(PublicKey key)
        设置subjectPublicKey标准。 X509Certificate必须包含指定的主题公钥。 如果是null ，则不会对subjectPublicKey进行检查。
        参数
        key - 要查询的主题公钥（或 null ）
        另请参见：
        getSubjectPublicKey()

      • setSubjectPublicKey

        public void setSubjectPublicKey​(byte[] key)
                         throws IOException
        设置subjectPublicKey标准。 X509Certificate必须包含指定的主题公钥。 如果是null ，则不会对subjectPublicKey进行检查。

        因为这个方法允许将公钥指定为一个字节数组，它可以用于未知的密钥类型。

        如果key不是null ，它应该包含一个DER编码的SubjectPublicKeyInfo结构，如X.509中定义的。 该结构的ASN.1符号如下。

           SubjectPublicKeyInfo ::= SEQUENCE { algorithm AlgorithmIdentifier, subjectPublicKey BIT STRING } AlgorithmIdentifier ::= SEQUENCE { algorithm OBJECT IDENTIFIER, parameters ANY DEFINED BY algorithm OPTIONAL } -- contains a value of the type -- registered for use with the -- algorithm object identifier value

        请注意，此处提供的字节数组被克隆以防止后续修改。

        参数
        key - 包含ASN.1 DER表单中的主题公钥的字节数组（或 null ）
        异常
        IOException - 如果发生编码错误（主题公钥的表单不正确）
        另请参见：
        getSubjectPublicKey()

      • setKeyUsage

        public void setKeyUsage​(boolean[] keyUsage)
        设置keyUsage标准。 X509Certificate必须允许指定的keyUsage值。 如果是null ，则不需要使用keyUsage检查。 请注意，没有keyUsage扩展的X509Certificate隐式允许所有keyUsage值。

        请注意，此处提供的布尔数组被克隆以防止后续修改。

        参数
        keyUsage - 与X509Certificate.getKeyUsage()返回的布尔数组相同格式的布尔数组。 或null 。
        另请参见：
        getKeyUsage()

      • setExtendedKeyUsage

        public void setExtendedKeyUsage​(Set<String> keyPurposeSet)
                         throws IOException
        设置extendedKeyUsage标准。 X509Certificate必须在扩展密钥使用扩展中允许指定的密钥用途。 如果keyPurposeSet为空或null ，则不会对扩展的null检查。 请注意，没有extendedKeyUsage扩展的X509Certificate隐式允许所有关键用途。

        请注意， Set被克隆以防止后续修改。

        参数
        keyPurposeSet - 一个Set的字符串格式的主要目的OID（或null ）。 每个OID由一组以句点分隔的非负整数表示。
        异常
        IOException - 如果OID无效，例如第一个组件不是0,1或2或第二个组件大于39。
        另请参见：
        getExtendedKeyUsage()

      • setMatchAllSubjectAltNames

        public void setMatchAllSubjectAltNames​(boolean matchAllNames)
        启用/禁用匹配setSubjectAlternativeNames或addSubjectAlternativeName方法中指定的所有subjectAlternativeNames 。 如果启用，则X509Certificate必须包含所有指定的主题备用名称。 如果禁用，则X509Certificate必须至少包含一个指定的主题替代名称。

        matchAllNames标志默认为true 。

        参数
        matchAllNames - 如果是true ，则启用该标志; 如果是false ，则该标志被禁用。
        另请参见：
        getMatchAllSubjectAltNames()

      • setSubjectAlternativeNames

        public void setSubjectAlternativeNames​(Collection<List<?>> names)
                                throws IOException
        设置subjectAlternativeNames标准。 X509Certificate必须包含所有或至少一个指定的subjectAlternativeNames，具体取决于matchAllNames标志的值（请参阅setMatchAllSubjectAltNames ）。

        该方法允许调用者使用单个方法调用来指定subjectAlternativeNames标准的完整主题备用名称集。 指定的值替换subjectAlternativeNames条件的上一个值。

        names参数（如果不是null ）是一个Collection ，每个名称的一个条目将包含在主题备用名称标准中。 每个条目是一个List其第一个条目是Integer （名称类型，0-8），其第二个条目是String或字节数组（名称，分别为字符串或ASN.1 DER编码形式）。 可以有多个相同类型的名称。 如果提供了null作为此参数的值，则不会执行subjectAlternativeNames检查。

        Collection中的每个主题备用名称可以指定为String或ASN.1编码字节数组。 有关所使用格式的更多详细信息，请参阅addSubjectAlternativeName(int type, String name)和addSubjectAlternativeName(int type, byte [] name) 。

        注意：对于可分辨名称，请指定字节数组形式而不是字符串形式。 有关详细信息，请参阅addSubjectAlternativeName(int, String)中的注释。

        需要注意的是names参数可以包含重复的名称（相同的名称和名称类型），但他们可以从被删除Collection由返回的名字getSubjectAlternativeNames方法。

        请注意，在Collection上执行深度拷贝以防止后续修改。

        参数
        names - 一个 Collection的名字（或 null ）
        异常
        IOException - 如果发生解析错误
        另请参见：
        getSubjectAlternativeNames()

      • addSubjectAlternativeName

        public void addSubjectAlternativeName​(int type,
                                      String name)
                               throws IOException
        在subjectAlternativeNames条件中添加一个名称。 X509Certificate必须包含所有或至少一个指定的subjectAlternativeNames，具体取决于matchAllNames标志的值（请参阅setMatchAllSubjectAltNames ）。

        此方法允许调用者向一组主题替代名称添加一个名称。 指定的名称将添加到subjectAlternativeNames条件的任何先前值。 如果指定的名称是重复的，则可能会被忽略。

        该名称以字符串格式提供。 RFC 822 ，DNS和URI名称对于这些类型使用完善的字符串格式（受RFC 5280中包含的限制）。 IPv4地址名称使用虚线四边形符号提供。 OID地址名称表示为以句点分隔的一系列非负整数。 目录名称（专有名称）以RFC 2253格式提供。 没有为其他名称，X.400名称，EDI方名称，IPv6地址名称或任何其他类型的名称定义标准字符串格式。 应使用addSubjectAlternativeName(int type, byte [] name)方法指定。

        注意：对于可分辨名称，请改用addSubjectAlternativeName(int, byte[]) 。 不应该依赖此方法，因为由于某些特定名称的RFC 2253字符串形式的编码信息丢失，因为它可能无法匹配某些证书。

        参数
        type - 名称类型（0-8，如RFC 5280第4.2.1.6节中所述）
        name - 字符串形式的名称（不是 null ）
        异常
        IOException - 如果发生解析错误

      • addSubjectAlternativeName

        public void addSubjectAlternativeName​(int type,
                                      byte[] name)
                               throws IOException
        在subjectAlternativeNames条件中添加一个名称。 X509Certificate必须包含所有或至少一个指定的subjectAlternativeNames，具体取决于matchAllNames标志的值（参见setMatchAllSubjectAltNames ）。

        此方法允许调用者向一组主题替代名称添加一个名称。 指定的名称将添加到subjectAlternativeNames条件的任何先前值。 如果指定的名称是重复的，则可能会被忽略。

        该名称作为字节数组提供。 该字节数组应包含DER编码的名称，因为它将出现在RFC 5280和X.509中定义的GeneralName结构中。 编码字节数组应该只包含名称的编码值，并且不应该包含与GeneralName结构中名称相关联的标签。 此结构的ASN.1定义如下。

           GeneralName ::= CHOICE { otherName [0] OtherName, rfc822Name [1] IA5String, dNSName [2] IA5String, x400Address [3] ORAddress, directoryName [4] Name, ediPartyName [5] EDIPartyName, uniformResourceIdentifier [6] IA5String, iPAddress [7] OCTET STRING, registeredID [8] OBJECT IDENTIFIER}

        请注意，此处提供的字节数组被克隆以防止后续修改。

        参数
        type - 名称类型（0-8，如上所列）
        name - 包含ASN.1 DER编码形式的名称的字节数组
        异常
        IOException - 如果发生解析错误

      • setNameConstraints

        public void setNameConstraints​(byte[] bytes)
                        throws IOException
        设置名称约束条件。 X509Certificate必须具有符合指定名称限制的主题和主题备用名称。

        名称约束被指定为字节数组。 该字节数组应包含名称约束的DER编码形式，因为它们将出现在RFC 5280和X.509中定义的NameConstraints结构中。 此结构的ASN.1定义如下。

           NameConstraints ::= SEQUENCE { permittedSubtrees [0] GeneralSubtrees OPTIONAL, excludedSubtrees [1] GeneralSubtrees OPTIONAL } GeneralSubtrees ::= SEQUENCE SIZE (1..MAX) OF GeneralSubtree GeneralSubtree ::= SEQUENCE { base GeneralName, minimum [0] BaseDistance DEFAULT 0, maximum [1] BaseDistance OPTIONAL } BaseDistance ::= INTEGER (0..MAX) GeneralName ::= CHOICE { otherName [0] OtherName, rfc822Name [1] IA5String, dNSName [2] IA5String, x400Address [3] ORAddress, directoryName [4] Name, ediPartyName [5] EDIPartyName, uniformResourceIdentifier [6] IA5String, iPAddress [7] OCTET STRING, registeredID [8] OBJECT IDENTIFIER}

        请注意，此处提供的字节数组被克隆以防止后续修改。

        参数
        bytes - 一个包含用于检查名称约束的NameConstraints扩展的ASN.1 DER编码的字节数组。 只包括扩展的值，而不是OID或临界标志。 可以是null ，在这种情况下不会执行名称约束检查。
        异常
        IOException - 如果发生解析错误
        另请参见：
        getNameConstraints()

      • setBasicConstraints

        public void setBasicConstraints​(int minMaxPathLen)
        设置基本约束约束。 如果值大于或等于零，则X509Certificates必须包含一个至少具有此值的pathLen的basicConstraints扩展。 如果值为-2，则只接受终端实体证书。 如果值为-1，则不进行检查。

        当建立认证路径（从目标到信任锚点）建立认证路径时，此约束是有用的。如果构建了部分路径，任何候选证书的maxPathLen值必须大于或等于部分路径中的证书数量。

        参数
        minMaxPathLen - 基本约束约束的值
        异常
        IllegalArgumentException - 如果值小于-2
        另请参见：
        getBasicConstraints()

      • setPolicy

        public void setPolicy​(Set<String> certPolicySet)
               throws IOException
        设置策略约束。 X509Certificate必须在其证书策略扩展中至少包括一个指定的策略。 如果certPolicySet为空，则X509Certificate必须在证书策略扩展中至少包含一些指定的策略。 如果certPolicySet为null ，则不进行任何策略检查。

        请注意， Set被克隆以防止后续修改。

        参数
        certPolicySet - 一个Set的字符串格式的证书策略OID（或null ）。 每个OID由一组以句点分隔的非负整数表示。
        异常
        IOException - 如果OID上发生解析错误，例如第一个组件不是0,1或2或第二个组件大于39。
        另请参见：
        getPolicy()

      • setPathToNames

        public void setPathToNames​(Collection<List<?>> names)
                    throws IOException
        设置pathToNames条件。 X509Certificate不能包含禁止构建指定名称路径的名称约束。

        该方法允许调用者使用单个方法调用来指定X509Certificates的名称约束必须允许的完整名称集合。 指定的值替换pathToNames条件的上一个值。

        当建立认证路径（从目标到信任锚点）时，此约束是有用的。如果构建了部分路径，则任何候选证书不得包含禁止构建路径到部分路径中的任何名称的名称约束。

        names参数（如果不是null ）是一个Collection ，每个名称的一个条目将包含在pathToNames条件中。 每个条目是一个List其第一个条目是Integer （名称类型，0-8），其第二个条目是String或字节数组（名称，分别为字符串或ASN.1 DER编码形式）。 可以有多个相同类型的名称。 如果提供null作为此参数的值，则不执行pathToNames检查。

        Collection中的每个名称可以指定为String或ASN.1编码字节数组。 有关所使用格式的更多详细信息，请参阅addPathToName(int type, String name)和addPathToName(int type, byte [] name) 。

        注意：对于可分辨名称，请指定字节数组形式而不是字符串形式。 有关详细信息，请参阅addPathToName(int, String)中的注释。

        需要注意的是names参数可以包含重复的名称（相同的名称和名称类型），但他们可以从被删除Collection由返回的名字getPathToNames方法。

        请注意，对Collection执行深度拷贝以防止后续修改。

        参数
        names - 一个 Collection ，每个名称有一个条目（或 null ）
        异常
        IOException - 如果发生解析错误
        另请参见：
        getPathToNames()

      • addPathToName

        public void addPathToName​(int type,
                          String name)
                   throws IOException
        在pathToNames条件中添加一个名称。 X509Certificate不能包含禁止构建指定名称路径的名称约束。

        此方法允许调用者向X509Certificates的名称约束必须允许的一组名称添加一个名称。 指定的名称将添加到pathToNames条件的任何先前值。 如果名称重复，则可能会被忽略。

        该名称以字符串格式提供。 RFC 822，DNS和URI名称对于这些类型使用完善的字符串格式（受到RFC 5280中的限制）。 IPv4地址名称使用虚线四边形符号提供。 OID地址名称表示为以句点分隔的一系列非负整数。 目录名称（专有名称）以RFC 2253格式提供。 没有为其他名称，X.400名称，EDI方名称，IPv6地址名称或任何其他类型的名称定义标准字符串格式。 应使用addPathToName(int type, byte [] name)方法指定。

        注意：对于可分辨名称，请改用addPathToName(int, byte[]) 。 不应该依赖此方法，因为由于某些特定名称的RFC 2253字符串形式的编码信息丢失，因为它可能无法匹配某些证书。

        参数
        type - 名称类型（0-8，如RFC 5280第4.2.1.6节中所述）
        name - 字符串形式的名称
        异常
        IOException - 如果发生解析错误

      • addPathToName

        public void addPathToName​(int type,
                          byte[] name)
                   throws IOException
        在pathToNames条件中添加一个名称。 X509Certificate不能包括禁止构建指定名称的路径的名称约束。

        这种方法允许调用者在X509Certificates的名称约束必须允许的名称集中添加一个名称。 指定的名称将添加到pathToNames条件的任何先前值。 如果名称重复，则可能会被忽略。

        该名称作为字节数组提供。 该字节数组应包含DER编码的名称，因为它将出现在RFC 5280和X.509中定义的GeneralName结构中。 该结构的ASN.1定义见addSubjectAlternativeName(int type, byte [] name)的文档。

        请注意，此处提供的字节数组被克隆以防止后续修改。

        参数
        type - 名称类型（0-8，如RFC 5280第4.2.1.6节中所述）
        name - 包含ASN.1 DER编码形式的名称的字节数组
        异常
        IOException - 如果发生解析错误

      • getCertificate

        public X509Certificate getCertificate​()
        返回certificateEquals标准。 指定的X509Certificate必须等于X509Certificate传递给match方法。 如果是null ， null此检查。
        结果
        匹配的 X509Certificate （或 null ）
        另请参见：
        setCertificate(java.security.cert.X509Certificate)

      • getSerialNumber

        public BigInteger getSerialNumber​()
        返回serialNumber标准。 指定的序列号必须与X509Certificate中的证书序列号X509Certificate 。 如果是null ，任何证书序列号都可以。
        结果
        证书序列号匹配（或 null ）
        另请参见：
        setSerialNumber(java.math.BigInteger)

      • getIssuer

        public X500Principal getIssuer​()
        作为X500Principal返回发行人标准。 该名称必须与X509Certificate中的发行人可分辨名称相匹配。 如果是null ，发行人标准被禁用，任何发行人的辨别名都可以。
        结果
        所需发行人的识别名称为 null （或 null ）
        从以下版本开始：
        1.5

      • getIssuerAsString

        public String getIssuerAsString​()
        诋毁 ，使用getIssuer()或者getIssuerAsBytes()代替。 不应该依赖此方法，因为由于某些特定名称的RFC 2253字符串形式的编码信息丢失，因为它可能无法匹配某些证书。

        作为String返回发行人标准。 该名称必须与X509Certificate中的发行人可分辨名称相匹配。 如果null ，发行人标准被禁用，任何发行人的辨别名称都可以。

        如果返回的值不是null ，则它是一种可分辨的名称，以RFC 2253格式。

        结果
        RFC 2253格式（或 null ）所需的发行人可分辨名称

      • getIssuerAsBytes

        public byte[] getIssuerAsBytes​()
                        throws IOException
        作为字节数组返回发行方标准。 该名称必须与X509Certificate中的发行人可分辨名称相匹配。 如果是null ，则发行人标准被禁用，任何发行人的辨别名都可以。

        如果返回的值不是null ，则它是一个包含单个DER编码的可分辨名称的字节数组，如X.501中所定义。 该结构的ASN.1符号在setIssuer(byte [] issuerDN)的文档中提供。

        请注意，返回的字节数组被克隆以防止后续修改。

        结果
        包含ASN.1 DER格式（或 null ）中所需颁发者可分辨名称的字节数组
        异常
        IOException - 如果发生编码错误

      • getSubject

        public X500Principal getSubject​()
        返回主题标准为X500Principal 。 该专有名称必须与X509Certificate中的主题识别名称相匹配。 如果null ，主题标准被禁用，任何主题辨别名称都可以。
        结果
        所需主题识别名称为 null （或 null ）
        从以下版本开始：
        1.5

      • getSubjectAsString

        public String getSubjectAsString​()
        诋毁 ，使用getSubject()或者getSubjectAsBytes()代替。 不应该依赖此方法，因为由于某些特定名称的RFC 2253字符串形式的编码信息丢失，因为它可能无法匹配某些证书。

        返回主题标准为String 。 该名称必须与X509Certificate中的主题识别名称相匹配。 如果null ，主题标准被禁用，并且任何主题可分辨名称都可以。

        如果返回的值不是null ，则它是一种可分辨的名称，以RFC 2253格式。

        结果
        RFC 2253格式（或 null ）所需的主题标识名称

      • getSubjectAsBytes

        public byte[] getSubjectAsBytes​()
                         throws IOException
        以字节数组形式返回主题标准。 该名称必须与X509Certificate中的主题识别名称相匹配。 如果是null ，主题标准被禁用，任何主题的专有名称都会这样做。

        如果返回的值不是null ，则它是一个包含单个DER编码的可分辨名称的字节数组，如X.501中所定义。 该结构的ASN.1符号在setSubject(byte [] subjectDN)的文档中提供。

        请注意，返回的字节数组被克隆以防止后续修改。

        结果
        包含ASN.1 DER格式（或 null ）中所需主题标识名的字节数组
        异常
        IOException - 如果发生编码错误

      • getSubjectKeyIdentifier

        public byte[] getSubjectKeyIdentifier​()
        返回subjectKeyIdentifier标准。 X509Certificate必须包含带有指定值的SubjectKeyIdentifier扩展名。 如果是null ，则不会对subjectKeyIdentifier进行检查。

        请注意，返回的字节数组被克隆以防止后续修改。

        结果
        密钥标识符（或 null ）
        另请参见：
        setSubjectKeyIdentifier(byte[])

      • getAuthorityKeyIdentifier

        public byte[] getAuthorityKeyIdentifier​()
        返回authorityKeyIdentifier标准。 X509Certificate必须包含具有指定值的AuthorityKeyIdentifier扩展。 如果是null ，那么没有权限的null检查就会完成。

        请注意，返回的字节数组被克隆以防止后续修改。

        结果
        密钥标识符（或 null ）
        另请参见：
        setAuthorityKeyIdentifier(byte[])

      • getCertificateValid

        public Date getCertificateValid​()
        返回certificateValid条件。 指定的日期必须在X509Certificate的证书有效期内。 如果是null ，则不会执行certificateValid检查。

        请注意，返回的Date被克隆以防止后续修改。

        结果
        Date检查（或 null ）
        另请参见：
        setCertificateValid(java.util.Date)

      • getPrivateKeyValid

        public Date getPrivateKeyValid​()
        返回privateKeyValid条件。 指定的日期必须在X509Certificate的私钥有效期内。 如果是null ，则不进行privateKeyValid检查。

        请注意，返回的Date是克隆的，以防止后续修改。

        结果
        Date检查（或 null ）
        另请参见：
        setPrivateKeyValid(java.util.Date)

      • getSubjectPublicKeyAlgID

        public String getSubjectPublicKeyAlgID​()
        返回subjectPublicKeyAlgID条件。 X509Certificate必须包含具有指定算法的主题公钥。 如果是null ，则不会对subjectPublicKeyAlgID进行检查。
        结果
        要检查的签名算法的对象标识符（OID）（或null ）。 OID由以句点分隔的一组非负整数表示。
        另请参见：
        setSubjectPublicKeyAlgID(java.lang.String)

      • getSubjectPublicKey

        public PublicKey getSubjectPublicKey​()
        返回subjectPublicKey标准。 X509Certificate必须包含指定的主题公钥。 如果是null ，则不会对subjectPublicKey进行检查。
        结果
        要查询的主题公钥（或 null ）
        另请参见：
        setSubjectPublicKey(java.security.PublicKey)

      • getKeyUsage

        public boolean[] getKeyUsage​()
        返回keyUsage标准。 X509Certificate必须允许指定的keyUsage值。 如果为空，则不进行keyUsage检查。

        请注意，返回的布尔数组被克隆以防止后续修改。

        结果
        一个与X509Certificate.getKeyUsage()返回的布尔数组相同格式的布尔数组。 或null 。
        另请参见：
        setKeyUsage(boolean[])

      • getExtendedKeyUsage

        public Set<String> getExtendedKeyUsage​()
        返回extendedKeyUsage标准。 X509Certificate必须允许其扩展密钥使用扩展中指定的密钥目的。 如果返回的keyPurposeSet为空或者是null ，则不会进行extendedKeyUsage检查。 请注意，没有extendedKeyUsage扩展的X509Certificate隐式允许所有关键用途。
        结果
        字符串格式的主要目的OID（或 null ）的不可变 Set
        另请参见：
        setExtendedKeyUsage(java.util.Set<java.lang.String>)

      • getMatchAllSubjectAltNames

        public boolean getMatchAllSubjectAltNames​()
        指示X509Certificate必须包含setSubjectAlternativeNames或addSubjectAlternativeName方法中指定的所有或至少一个subjectAlternativeNames 。 如果是true ，那么X509Certificate必须包含所有指定的主题替代名称。 如果是false ，那么X509Certificate必须包含至少一个指定的主题替代名称。
        结果
        true如果标志被使能; 如果标志被禁用， false 。 标志默认为true 。
        另请参见：
        setMatchAllSubjectAltNames(boolean)

      • getSubjectAlternativeNames

        public Collection<List<?>> getSubjectAlternativeNames​()
        返回subjectAlternativeNames条件的副本。 X509Certificate必须包含所有或至少一个指定的subjectAlternativeNames，具体取决于matchAllNames标志的值（参见getMatchAllSubjectAltNames ）。 如果返回值为null ，则不执行subjectAlternativeNames检查。

        如果返回的值不是null ，则它是一个Collection ，每个名称的一个条目将包含在主题备用名称标准中。 每个条目是List其第一个条目是Integer （名称类型，0-8），第二个条目是String或字节数组（名称，分别为字符串或ASN.1 DER编码形式）。 可以有多个相同类型的名称。 请注意，返回的Collection可能包含重复的名称（相同的名称和名称类型）。

        Collection中的每个主题备用名称可以指定为String或ASN.1编码字节数组。 有关所使用格式的更多详细信息，请参阅addSubjectAlternativeName(int type, String name)和addSubjectAlternativeName(int type, byte [] name) 。

        请注意，在Collection上执行深度拷贝以防止后续修改。

        结果
        一个 Collection的名字（或 null ）
        另请参见：
        setSubjectAlternativeNames(java.util.Collection<java.util.List<?>>)

      • getNameConstraints

        public byte[] getNameConstraints​()
        返回名称约束条件。 X509Certificate必须具有符合指定名称限制的主题和主题备用名称。

        名称约束作为字节数组返回。 该字节数组包含名称约束的DER编码形式，因为它们将出现在RFC 5280和X.509中定义的NameConstraints结构中。 该结构的ASN.1符号在setNameConstraints(byte [] bytes)的文档中提供。

        请注意，返回的字节数组被克隆以防止后续修改。

        结果
        一个包含用于检查名称约束的NameConstraints扩展的ASN.1 DER编码的字节数组。 null如果不执行名称约束检查。
        另请参见：
        setNameConstraints(byte[])

      • getBasicConstraints

        public int getBasicConstraints​()
        返回基本约束约束。 如果值大于或等于零，则X509Certificates必须包含一个至少具有此值的pathLen的basicConstraints扩展。 如果值为-2，则只接受终端实体证书。 如果值为-1，则不会执行basicConstraints检查。
        结果
        基本约束约束的值
        另请参见：
        setBasicConstraints(int)

      • getPolicy

        public Set<String> getPolicy​()
        返回策略标准。 X509Certificate必须在其证书策略扩展中至少包括一个指定的策略。 如果返回的Set为空，那么X509Certificate必须在其证书策略扩展中至少包含一些指定的策略。 如果Set返回的是null ，则不进行任何策略检查。
        结果
        一个不可变的 Set证书策略OID字符串格式（或 null ）
        另请参见：
        setPolicy(java.util.Set<java.lang.String>)

      • getPathToNames

        public Collection<List<?>> getPathToNames​()
        返回pathToNames条件的副本。 X509Certificate不能包含禁止构建指定名称路径的名称约束。 如果返回的值为null ，则不会执行pathToNames检查。

        如果返回的值不是null ，则它是一个Collection ，每个名称的一个条目将包含在pathToNames条件中。 每个条目是一个List其第一个条目是Integer （名称类型，0-8），第二个条目是String或字节数组（名称，分别为字符串或ASN.1 DER编码形式）。 可以有多个相同类型的名称。 请注意，返回的Collection可能包含重复的名称（相同的名称和名称类型）。

        可以将Collection中的每个名称指定为String或ASN.1编码字节数组。 有关所使用格式的详细信息，请参阅addPathToName(int type, String name)和addPathToName(int type, byte [] name) 。

        请注意，在Collection上执行深度拷贝以防止后续修改。

        结果
        一个 Collection的名字（或 null ）
        另请参见：
        setPathToNames(java.util.Collection<java.util.List<?>>)

      • toString

        public String toString​()
        返回 CertSelector的可打印的表示。
        重写：
        toString在 Object
        结果
        一个描述 String的内容的 CertSelector

      • match

        public boolean match​(Certificate cert)
        决定是否选择 Certificate 。
        Specified by:
        match在接口 CertSelector
        参数
        cert - 要检查的 Certificate
        结果
        true如果 Certificate应选择， false否则

      • clone

        public Object clone​()
        返回此对象的副本。
        Specified by:
        clone接口 CertSelector
        重写：
        clone在 Object
        结果
        副本
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


X509CRL (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class X509CRL

  • java.lang.Object
    • java.security.cert.CRL
      • java.security.cert.X509CRL
  • All Implemented Interfaces:
    X509Extension

    public abstract class X509CRL
extends CRL
implements X509Extension

    X.509证书撤销列表（CRL）的抽象类。 CRL是标识已撤销证书的时间戳列表。 它由证书颁发机构（CA）签署，并在公共存储库中免费提供。

    每个撤销的证书都由其证书序列号在CRL中标识。 当证书使用系统使用证书（例如，用于验证远程用户的数字签名）时，该系统不仅可以检查证书签名和有效性，还可以获取适当最近的CRL，并检查证书序列号是否不在CRL。 “适当近期”的含义可能随当地政策而有所不同，但通常意味着最近发布的CRL。 CA定期定期发布新的CRL（例如，每小时，每天或每周）。 作为撤销，条目将添加到CRL中，并且在达到证书到期日期时可能会删除条目。

    下面在ASN.1中介绍X.509 v2 CRL格式：

      CertificateList  ::=  SEQUENCE  {
     tbsCertList          TBSCertList,
     signatureAlgorithm   AlgorithmIdentifier,
     signature            BIT STRING  }

    更多信息，请参见RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile 。

    tbsCertList的ASN.1定义是：

      TBSCertList  ::=  SEQUENCE  {
     version                 Version OPTIONAL,
                             -- if present, must be v2
     signature               AlgorithmIdentifier,
     issuer                  Name,
     thisUpdate              ChoiceOfTime,
     nextUpdate              ChoiceOfTime OPTIONAL,
     revokedCertificates     SEQUENCE OF SEQUENCE  {
         userCertificate         CertificateSerialNumber,
         revocationDate          ChoiceOfTime,
         crlEntryExtensions      Extensions OPTIONAL
                                 -- if present, must be v2
         }  OPTIONAL,
     crlExtensions           [0]  EXPLICIT Extensions OPTIONAL
                                  -- if present, must be v2
     }

    CRL使用证书工厂进行实例化。 以下是如何实例化X.509 CRL的示例：

       try (InputStream inStream = new FileInputStream("fileName-of-crl")) { CertificateFactory cf = CertificateFactory.getInstance("X.509"); X509CRL crl = (X509CRL)cf.generateCRL(inStream); }
    从以下版本开始：
    1.2
    另请参见：
    CRL ， CertificateFactory ， X509Extension

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected X509CRL​()
      X.509 CRL的构造方法。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object other)
      将此CRL与给定对象进行比较。
      abstract byte[] getEncoded​()
      返回此CRL的ASN.1 DER编码形式。
      abstract Principal getIssuerDN​()
      诋毁 ，取而代之的是 getIssuerX500Principal() 。
      X500Principal getIssuerX500Principal​()
      从CRL返回发行人（发行人可分辨名称）值为 X500Principal 。
      abstract Date getNextUpdate​()
      从CRL获取 nextUpdate日期。
      abstract X509CRLEntry getRevokedCertificate​(BigInteger serialNumber)
      获取给定证书serialNumber的CRL条目（如果有）。
      X509CRLEntry getRevokedCertificate​(X509Certificate certificate)
      获取给定证书的CRL条目（如果有）。
      abstract Set<? extends X509CRLEntry> getRevokedCertificates​()
      获取此CRL中的所有条目。
      abstract String getSigAlgName​()
      获取CRL签名算法的签名算法名称。
      abstract String getSigAlgOID​()
      从CRL获取签名算法OID字符串。
      abstract byte[] getSigAlgParams​()
      从该CRL的签名算法获取DER编码的签名算法参数。
      abstract byte[] getSignature​()
      从CRL获取 signature值（原始签名位）。
      abstract byte[] getTBSCertList​()
      获取DER编码的CRL信息，来自此CRL的 tbsCertList 。
      abstract Date getThisUpdate​()
      从CRL获取 thisUpdate日期。
      abstract int getVersion​()
      从CRL获取 version （版本号）值。
      int hashCode​()
      从其编码形式返回此CRL的哈希码值。
      abstract void verify​(PublicKey key)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      abstract void verify​(PublicKey key, String sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      void verify​(PublicKey key, Provider sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。

      • Methods inherited from class java.security.cert.CRL

        getType, isRevoked, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.cert.X509Extension

        getCriticalExtensionOIDs, getExtensionValue, getNonCriticalExtensionOIDs, hasUnsupportedCriticalExtension

    • 构造方法详细信息

      • X509CRL

        protected X509CRL​()
        X.509 CRL的构造方法。

    • 方法详细信息

      • equals

        public boolean equals​(Object other)
        将此CRL与给定对象进行比较。 如果other对象是instanceof X509CRL ，则其编码形式被检索并与该CRL的编码形式进行比较。
        重写：
        equals在 Object
        参数
        other - 测试与此CRL相等的对象。
        结果
        如果两个CRL的编码形式匹配，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        从其编码形式返回此CRL的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getEncoded

        public abstract byte[] getEncoded​()
                           throws CRLException
        返回此CRL的ASN.1 DER编码形式。
        结果
        该证书的编码形式
        异常
        CRLException - 如果发生编码错误。

      • verify

        public abstract void verify​(PublicKey key)
                     throws CRLException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
        验证此CRL是否使用与给定公钥对应的私钥进行签名。
        参数
        key - 用于执行验证的PublicKey。
        异常
        NoSuchAlgorithmException - 不支持的签名算法。
        InvalidKeyException - 键错误。
        NoSuchProviderException - 如果没有默认提供程序。
        SignatureException - 签名错误。
        CRLException - 编码错误。

      • verify

        public abstract void verify​(PublicKey key,
                            String sigProvider)
                     throws CRLException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
        验证此CRL是否使用与给定公钥对应的私钥进行签名。 此方法使用给定提供商提供的签名验证引擎。
        参数
        key - 用于执行验证的PublicKey。
        sigProvider - 签名提供者的名称。
        异常
        NoSuchAlgorithmException - 不支持的签名算法。
        InvalidKeyException - 键错误。
        NoSuchProviderException - 错误提供者。
        SignatureException - 签名错误。
        CRLException - 编码错误。

      • verify

        public void verify​(PublicKey key,
                   Provider sigProvider)
            throws CRLException,
                   NoSuchAlgorithmException,
                   InvalidKeyException,
                   SignatureException
        验证此CRL是否使用与给定公钥对应的私钥进行签名。 此方法使用给定提供商提供的签名验证引擎。 请注意，指定的Provider对象不必在提供者列表中注册。 该方法被添加到Java Platform Standard Edition的1.8版本。 为了保持与现有服务提供商的向后兼容性，此方法不是abstract ，它提供了默认的实现。
        参数
        key - 用于执行验证的PublicKey。
        sigProvider - 签名提供者。
        异常
        NoSuchAlgorithmException - 不支持的签名算法。
        InvalidKeyException - 键错误。
        SignatureException - 签名错误。
        CRLException - 编码错误。
        从以下版本开始：
        1.8

      • getVersion

        public abstract int getVersion​()
        从CRL获取version （版本号）值。 ASN.1的定义是：
          version    Version OPTIONAL,
             -- if present, must be v2

 Version  ::=  INTEGER  {  v1(0), v2(1), v3(2)  }
             -- v3 does not apply to CRLs but appears for consistency
             -- with definition of Version for certs
        结果
        版本号，即1或2。

      • getIssuerDN

        public abstract Principal getIssuerDN​()
        诋毁 ，取而代之的是getIssuerX500Principal() 。 该方法返回issuer作为实现特定的Principal对象，不应该由便携式代码依赖。

        从CRL获取issuer （发行人可分辨名称）值。 发行人名称标识签署（并发行）CRL的实体。

        发行人名称字段包含X.500可分辨名称（DN）。 ASN.1的定义是：

          issuer    Name

 Name ::= CHOICE { RDNSequence }
 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName
 RelativeDistinguishedName ::=
     SET OF AttributeValueAssertion

 AttributeValueAssertion ::= SEQUENCE {
                               AttributeType,
                               AttributeValue }
 AttributeType ::= OBJECT IDENTIFIER
 AttributeValue ::= ANY
        Name描述了由属性组成的分层名称，例如国家名称和相应的值，例如US。 的类型的AttributeValue分量由确定AttributeType ; 一般来说将会是一个directoryString 。 甲directoryString通常之一PrintableString ， TeletexString或UniversalString 。
        结果
        一位姓名为发行人名称的校长。

      • getIssuerX500Principal

        public X500Principal getIssuerX500Principal​()
        从CRL返回发行人（发行人可分辨名称）值作为X500Principal 。

        建议子类覆盖此方法。

        结果
        代表发行人的名称为 X500Principal
        从以下版本开始：
        1.4

      • getThisUpdate

        public abstract Date getThisUpdate​()
        从CRL获取thisUpdate日期。 ASN.1的定义是：
          thisUpdate   ChoiceOfTime
 ChoiceOfTime ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }
        结果
        来自CRL的 thisUpdate日期。

      • getNextUpdate

        public abstract Date getNextUpdate​()
        从CRL获取 nextUpdate日期。
        结果
        来自CRL的 nextUpdate日期，如果不存在，则为null。

      • getRevokedCertificate

        public abstract X509CRLEntry getRevokedCertificate​(BigInteger serialNumber)
        获取给定证书serialNumber的CRL条目（如果有）。
        参数
        serialNumber - 要查找CRL条目的证书的序列号
        结果
        具有给定序列号的条目，如果此CRL中不存在此类条目，则为null。
        另请参见：
        X509CRLEntry

      • getRevokedCertificate

        public X509CRLEntry getRevokedCertificate​(X509Certificate certificate)
        获取给定证书的CRL条目（如果有）。

        此方法可用于查找间接CRL中的CRL条目，这意味着CRL包含CRL颁发者以外的发行人的条目。 默认实现只会返回由CRL颁发者颁发的证书的条目。 希望支持间接CRL的子类应该覆盖此方法。

        参数
        certificate - 要查找CRL条目的证书
        结果
        给定证书的条目，如果此CRL中不存在此类条目，则为null。
        异常
        NullPointerException - 如果证书为空
        从以下版本开始：
        1.5

      • getRevokedCertificates

        public abstract Set<? extends X509CRLEntry> getRevokedCertificates​()
        获取此CRL中的所有条目。 这将返回一组X509CRLEntry对象。
        结果
        所有条目，如果没有，则为null。
        另请参见：
        X509CRLEntry

      • getTBSCertList

        public abstract byte[] getTBSCertList​()
                               throws CRLException
        获取DER编码的CRL信息，来自此CRL的tbsCertList 。 这可以独立地用于验证签名。
        结果
        DER编码的CRL信息。
        异常
        CRLException - 如果发生编码错误。

      • getSignature

        public abstract byte[] getSignature​()
        获取CRL中的signature值（原始签名位）。 ASN.1的定义是：
          signature     BIT STRING
        结果
        签名。

      • getSigAlgName

        public abstract String getSigAlgName​()
        获取CRL签名算法的签名算法名称。 一个例子是字符串“SHA256withRSA”。 ASN.1的定义是：
          signatureAlgorithm   AlgorithmIdentifier

 AlgorithmIdentifier  ::=  SEQUENCE  {
     algorithm               OBJECT IDENTIFIER,
     parameters              ANY DEFINED BY algorithm OPTIONAL  }
                             -- contains a value of the type
                             -- registered for use with the
                             -- algorithm object identifier value

        算法名称由algorithm OID字符串确定。

        结果
        签名算法名称。

      • getSigAlgOID

        public abstract String getSigAlgOID​()
        从CRL获取签名算法OID字符串。 OID由一组由周期分隔的非负整数表示。 例如，字符串“1.2.840.10040.4.3”标识了在RFC 3279: Algorithms and Identifiers for the Internet X.509 Public Key Infrastructure Certificate and CRL Profile中定义的具有DSA签名算法的SHA-1。

        有关ASN.1定义，请参见getSigAlgName 。

        结果
        签名算法OID字符串。

      • getSigAlgParams

        public abstract byte[] getSigAlgParams​()
        从该CRL的签名算法获取DER编码的签名算法参数。 在大多数情况下，签名算法参数为null; 这些参数通常随公钥提供。 如果需要访问个别参数值，则使用AlgorithmParameters与返回的名称进行实例化getSigAlgName 。

        有关ASN.1定义，请参见getSigAlgName 。

        结果
        DER编码的签名算法参数，如果没有参数，则为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


X509CRLEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class X509CRLEntry

  • java.lang.Object
    • java.security.cert.X509CRLEntry
  • All Implemented Interfaces:
    X509Extension

    public abstract class X509CRLEntry
extends Object
implements X509Extension

    CRL（证书撤销列表）中撤销证书的抽象类。 revokedCertificates的ASN.1定义是：

      revokedCertificates    SEQUENCE OF SEQUENCE  {
     userCertificate    CertificateSerialNumber,
     revocationDate     ChoiceOfTime,
     crlEntryExtensions Extensions OPTIONAL
                        -- if present, must be v2
 }  OPTIONAL

 CertificateSerialNumber  ::=  INTEGER

 Extensions  ::=  SEQUENCE SIZE (1..MAX) OF Extension

 Extension  ::=  SEQUENCE  {
     extnId        OBJECT IDENTIFIER,
     critical      BOOLEAN DEFAULT FALSE,
     extnValue     OCTET STRING
                   -- contains a DER encoding of a value
                   -- of the type registered for use with
                   -- the extnId object identifier value
 }
    从以下版本开始：
    1.2
    另请参见：
    X509CRL ， X509Extension

    • 构造方法摘要

      构造方法
      Constructor 描述
      X509CRLEntry​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object other)
      将此CRL条目与给定对象进行比较。
      X500Principal getCertificateIssuer​()
      获取此条目描述的X509证书颁发者。
      abstract byte[] getEncoded​()
      返回此CRL条目的ASN.1 DER编码形式，即内部SEQUENCE。
      abstract Date getRevocationDate​()
      从此X509CRLEntry（ revocationDate）获取撤销日期。
      CRLReason getRevocationReason​()
      返回证书被撤销的原因，如CRL条目的“原因码”扩展中所指定。
      abstract BigInteger getSerialNumber​()
      从这个X509CRLEntry， userCertificate获取序列号。
      abstract boolean hasExtensions​()
      如果此CRL条目具有扩展名，则返回true。
      int hashCode​()
      从其编码形式返回此CRL条目的哈希码值。
      abstract String toString​()
      返回此CRL条目的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.cert.X509Extension

        getCriticalExtensionOIDs, getExtensionValue, getNonCriticalExtensionOIDs, hasUnsupportedCriticalExtension

    • 构造方法详细信息

      • X509CRLEntry

        public X509CRLEntry​()

    • 方法详细信息

      • equals

        public boolean equals​(Object other)
        将此CRL条目与给定对象进行比较。 如果other对象是instanceof X509CRLEntry ，则将其编码形式（内部SEQUENCE）检索并与此CRL条目的编码形式进行比较。
        重写：
        equals在 Object
        参数
        other - 要测试与此CRL条目相等的对象。
        结果
        如果两个CRL条目的编码形式匹配，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        从其编码形式返回此CRL条目的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getEncoded

        public abstract byte[] getEncoded​()
                           throws CRLException
        返回此CRL条目的ASN.1 DER编码形式，即内部SEQUENCE。
        结果
        该证书的编码形式
        异常
        CRLException - 如果发生编码错误。

      • getSerialNumber

        public abstract BigInteger getSerialNumber​()
        从这个X509CRLEntry， userCertificate获取序列号。
        结果
        序列号。

      • getCertificateIssuer

        public X500Principal getCertificateIssuer​()
        获取此条目描述的X509证书颁发者。 如果证书颁发者也是CRL颁发者，则此方法返回null。

        此方法与间接CRL一起使用。 默认实现始终返回null。 希望支持间接CRL的子类应该覆盖它。

        结果
        由本条款描述的X509证书的发行人，如果由CRL发行人发行，则为null。
        从以下版本开始：
        1.5

      • getRevocationDate

        public abstract Date getRevocationDate​()
        从此X509CRLEntry（ revocationDate）获取撤销日期。
        结果
        撤销日期。

      • hasExtensions

        public abstract boolean hasExtensions​()
        如果此CRL条目具有扩展名，则返回true。
        结果
        如果此条目有扩展名，则为true，否则为false。

      • toString

        public abstract String toString​()
        返回此CRL条目的字符串表示形式。
        重写：
        toString在 Object
        结果
        此CRL条目的字符串表示形式。

      • getRevocationReason

        public CRLReason getRevocationReason​()
        返回证书被撤销的原因，如CRL条目的“原因码”扩展中所指定。
        结果
        证书已被吊销的原因，或 null如果此CRL条目没有原因码扩展名
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


X509CRLSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Class X509CRLSelector

  • java.lang.Object
    • java.security.cert.X509CRLSelector
  • All Implemented Interfaces:
    Cloneable ， CRLSelector

    public class X509CRLSelector
extends Object
implements CRLSelector
    A CRLSelector选择符合所有指定条件的X509CRLs 。 当从CertStore选择CRL以检查特定证书的撤销状态时， CertStore特别有用。

    首次构建时， X509CRLSelector没有启用条件，并且每个get方法都返回默认值（ null ）。 因此， match方法将返回true任何X509CRL 。 通常，启用了几个条件（例如通过调用setIssuers或setDateAndTime ），然后将X509CRLSelector传递给CertStore.getCRLs或一些类似的方法。

    有关下列X.509 CRL字段和扩展名的定义，请参阅RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile 。

    并发访问

    除非另有说明，否则此类中定义的方法不是线程安全的。 需要同时访问单个对象的多个线程应在其间同步并提供必要的锁定。 每个操作单独对象的多个线程不需要同步。

    从以下版本开始：
    1.4
    另请参见：
    CRLSelector ， X509CRL

    • 构造方法摘要

      构造方法
      Constructor 描述
      X509CRLSelector​()
      创建一个 X509CRLSelector 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addIssuer​(X500Principal issuer)
      向issuerNames条件添加一个名称。
      void addIssuerName​(byte[] name)
      向issuerNames条件添加一个名称。
      void addIssuerName​(String name)
      诋毁 ，使用 addIssuer(X500Principal)或者 addIssuerName(byte[])代替。
      Object clone​()
      返回此对象的副本。
      X509Certificate getCertificateChecking​()
      返回正在检查的证书。
      Date getDateAndTime​()
      返回dateAndTime条件。
      Collection<Object> getIssuerNames​()
      返回issuerNames条件的副本。
      Collection<X500Principal> getIssuers​()
      返回issuerNames条件。
      BigInteger getMaxCRL​()
      返回maxCRLNumber标准。
      BigInteger getMinCRL​()
      返回minCRLNumber标准。
      boolean match​(CRL crl)
      决定是否选择 CRL 。
      void setCertificateChecking​(X509Certificate cert)
      设置正在检查的证书。
      void setDateAndTime​(Date dateAndTime)
      设置dateAndTime标准。
      void setIssuerNames​(Collection<?> names)
      注意：使用 setIssuers(Collection)或仅在使用此方法时指定专有名称的字节数组形式。
      void setIssuers​(Collection<X500Principal> issuers)
      设置issuerNames条件。
      void setMaxCRLNumber​(BigInteger maxCRL)
      设置maxCRLNumber标准。
      void setMinCRLNumber​(BigInteger minCRL)
      设置minCRLNumber标准。
      String toString​()
      返回 X509CRLSelector的可打印表示。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • X509CRLSelector

        public X509CRLSelector​()
        创建一个X509CRLSelector 。 最初没有设置任何条件，所以X509CRL将匹配。

    • 方法详细信息

      • setIssuers

        public void setIssuers​(Collection<X500Principal> issuers)
        设置issuerNames条件。 X509CRL的发行人识别名称必须至少与一个指定的可分辨名称相匹配。 如果是null ，任何发行人的辨别名都可以。

        该方法允许调用者使用单个方法调用来指定X509CRLs可能包含的完整的发行者名称X509CRLs 。 指定的值替换issuerNames条件的上一个值。

        names参数（如果不是null ）是Collection的X500Principal 。

        需要注意的是names参数可以包含重复的专有名称，但他们可以从被删除Collection由返回的名字getIssuers方法。

        请注意，在Collection上执行副本以防止后续修改。

        参数
        issuers - 一个 Collection （或 null ）
        从以下版本开始：
        1.5
        另请参见：
        getIssuers()

      • setIssuerNames

        public void setIssuerNames​(Collection<?> names)
                    throws IOException
        注意：使用setIssuers(Collection)或使用此方法时，仅指定可分辨名称的字节数组形式。 有关详细信息，请参阅addIssuerName(String) 。

        设置issuerNames条件。 X509CRL的颁发者可分辨名称必须至少与一个指定的可分辨名称相匹配。 如果是null ，任何发行人的名字都可以。

        该方法允许调用者使用单个方法调用来指定X509CRLs可能包含的完整的发行者名称X509CRLs 。 指定的值替换issuerNames条件的上一个值。

        names参数（如果不是null ）是一个Collection的名字。 每个名称是一个String或一个表示可分辨名称的字节数组（分别为RFC 2253或ASN.1 DER编码形式）。 如果提供null作为此参数的值，则不执行issuerNames检查。

        需要注意的是names参数可以包含重复的专有名称，但他们可以从被删除Collection由返回的名字getIssuerNames方法。

        如果一个名称被指定为一个字节数组，它应包含一个DER编码的唯一名称，如X.501所定义。 该结构的ASN.1符号如下。

           Name ::= CHOICE { RDNSequence } RDNSequence ::= SEQUENCE OF RelativeDistinguishedName RelativeDistinguishedName ::= SET SIZE (1 .. MAX) OF AttributeTypeAndValue AttributeTypeAndValue ::= SEQUENCE { type AttributeType, value AttributeValue } AttributeType ::= OBJECT IDENTIFIER AttributeValue ::= ANY DEFINED BY AttributeType .... DirectoryString ::= CHOICE { teletexString TeletexString (SIZE (1..MAX)), printableString PrintableString (SIZE (1..MAX)), universalString UniversalString (SIZE (1..MAX)), utf8String UTF8String (SIZE (1.. MAX)), bmpString BMPString (SIZE (1..MAX)) }

        请注意，对Collection执行深度拷贝以防止后续修改。

        参数
        names - 一个 Collection的名称（或 null ）
        异常
        IOException - 如果发生解析错误
        另请参见：
        getIssuerNames()

      • addIssuer

        public void addIssuer​(X500Principal issuer)
        向issuerNames条件添加一个名称。 X509CRL的发行人识别名称必须至少与一个指定的可分辨名称相匹配。

        此方法允许调用者向X509CRLs可能包含的发行者名称集添加名称。 指定的名称将添加到issuerNames条件的任何先前值。 如果指定的名称是重复的，则可能会被忽略。

        参数
        issuer - 发行人为 issuer
        从以下版本开始：
        1.5

      • addIssuerName

        public void addIssuerName​(String name)
                   throws IOException
        诋毁 ，使用addIssuer(X500Principal)或者addIssuerName(byte[])代替。 不应该依赖此方法，因为由于某些专有名称的RFC 2253字符串形式的编码信息丢失，因此可能无法匹配某些CRL。

        向issuerNames条件添加一个名称。 X509CRL的发行人识别名必须与至少一个指定的可分辨名称相匹配。

        此方法允许调用者向X509CRLs可能包含的发行者名称集合添加一个名称。 指定的名称将添加到issuerNames条件的任何先前值。 如果指定的名称是重复的，则可能会被忽略。

        参数
        name - RFC 2253形式的名称
        异常
        IOException - 如果发生解析错误

      • addIssuerName

        public void addIssuerName​(byte[] name)
                   throws IOException
        向issuerNames条件添加一个名称。 X509CRL的发行人可分辨名称必须至少与一个指定的可分辨名称相匹配。

        此方法允许调用者向X509CRLs可能包含的发行者名称集合添加名称。 指定的名称将添加到issuerNames条件的任何先前值。 如果指定的名称是重复的，则可能会被忽略。 如果一个名称被指定为一个字节数组，它应包含一个DER编码的唯一名称，如X.501所定义。 该结构的ASN.1符号如下。

        该名称作为字节数组提供。 该字节数组应包含单个DER编码的可分辨名称，如X.501中所定义。 此结构的ASN.1符号显示在setIssuerNames(Collection names)的文档中。

        请注意，此处提供的字节数组被克隆以防止后续修改。

        参数
        name - 包含ASN.1 DER编码形式的名称的字节数组
        异常
        IOException - 如果发生解析错误

      • setMinCRLNumber

        public void setMinCRLNumber​(BigInteger minCRL)
        设置minCRLNumber标准。 X509CRL必须具有值大于或等于指定值的CRL号码扩展名。 如果是null ，则不进行minCRLNumber检查。
        参数
        minCRL - 接受的最低CRL号码（或 null ）

      • setMaxCRLNumber

        public void setMaxCRLNumber​(BigInteger maxCRL)
        设置maxCRLNumber标准。 X509CRL必须具有值小于或等于指定值的CRL号码扩展名。 如果是null ，则不会进行maxCRLNumber检查。
        参数
        maxCRL - 接受的最大CRL号码（或 null ）

      • setDateAndTime

        public void setDateAndTime​(Date dateAndTime)
        设置dateAndTime标准。 指定的日期必须等于或晚于X509CRL的thisUpdate组件的值，并且早于nextUpdate组件的值。 如果X509CRL不包含nextUpdate组件，则不匹配。 如果是null ，则不会对dateAndTime进行检查。

        请注意， Date提供的Date被克隆以防止后续修改。

        参数
        dateAndTime - 匹配的 Date （或 null ）
        另请参见：
        getDateAndTime()

      • setCertificateChecking

        public void setCertificateChecking​(X509Certificate cert)
        设置正在检查的证书。 这不是一个标准。 相反，它是可选的信息，可以帮助CertStore查找与检查指定证书的撤销相关的CRL。 如果指定了null ，则不提供此类可选信息。
        参数
        cert - 正在检查的 X509Certificate （或 null ）
        另请参见：
        getCertificateChecking()

      • getIssuers

        public Collection<X500Principal> getIssuers​()
        返回issuerNames条件。 X509CRL的发行人识别名必须至少与一个指定的可分辨名称相匹配。 如果返回的值为null ，则任何发行人的可分辨名称都可以。

        如果返回的值不是null ，则是Collection的不可修改的X500Principal 。

        结果
        一个不可修改的 Collection的名称（或 null ）
        从以下版本开始：
        1.5
        另请参见：
        setIssuers(java.util.Collection<javax.security.auth.x500.X500Principal>)

      • getIssuerNames

        public Collection<Object> getIssuerNames​()
        返回issuerNames条件的副本。 X509CRL的发行人可分辨名称必须至少与一个指定的可分辨名称相匹配。 如果返回的值为null ，则任何发行人的可分辨名称都可以。

        如果返回的值不是null ，那么它的名字是Collection 。 每个名称都是String或表示可分辨名称的字节数组（分别为RFC 2253或ASN.1 DER编码形式）。 请注意，返回的Collection可能包含重复的名称。

        如果一个名称被指定为一个字节数组，它应包含一个DER编码的唯一名称，如X.501所定义。 该结构的ASN.1符号在setIssuerNames(Collection names)的文档中给出 。

        请注意，对Collection执行深层复制以防止后续修改。

        结果
        一个 Collection的名字（或 null ）
        另请参见：
        setIssuerNames(java.util.Collection<?>)

      • getMinCRL

        public BigInteger getMinCRL​()
        返回minCRLNumber标准。 X509CRL必须具有值大于或等于指定值的CRL号码扩展名。 如果是null ，则不会进行minCRLNumber检查。
        结果
        接受的最小CRL号码（或 null ）

      • getMaxCRL

        public BigInteger getMaxCRL​()
        返回maxCRLNumber标准。 X509CRL必须具有值小于或等于指定值的CRL号码扩展名。 如果是null ，则不会进行maxCRLNumber检查。
        结果
        接受的最大CRL号码（或 null ）

      • getDateAndTime

        public Date getDateAndTime​()
        返回dateAndTime条件。 指定的日期必须等于或晚于X509CRL的thisUpdate组件的值，并且早于nextUpdate组件的值。 如果X509CRL不包含nextUpdate组件，则不匹配。 如果是null ，则不会对dateAndTime进行检查。

        请注意，返回的Date被克隆以防止后续修改。

        结果
        Date匹配（或 null ）
        另请参见：
        setDateAndTime(java.util.Date)

      • getCertificateChecking

        public X509Certificate getCertificateChecking​()
        返回正在检查的证书。 这不是一个标准。 相反，它是可选的信息，可以帮助CertStore查找与检查指定证书的撤销相关的CRL。 如果返回的值为null ，则不提供此类可选信息。
        结果
        正在检查的证书（或 null ）
        另请参见：
        setCertificateChecking(java.security.cert.X509Certificate)

      • toString

        public String toString​()
        返回 X509CRLSelector的可打印表示。
        重写：
        toString在 Object
        结果
        一个描述 String的内容的 X509CRLSelector 。

      • match

        public boolean match​(CRL crl)
        决定是否选择 CRL 。
        Specified by:
        match在接口 CRLSelector
        参数
        crl - 要检查的 CRL
        结果
        true如果 CRL应选择， false否则

      • clone

        public Object clone​()
        返回此对象的副本。
        Specified by:
        clone接口 CRLSelector
        重写：
        clone在 Object
        结果
        副本
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


X509Extension (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.cert

Interface X509Extension

  • 所有已知实现类：
    X509Certificate ， X509CRL ， X509CRLEntry

    public interface X509Extension
    X509扩展接口。

    为X.509 v3 Certificates和v2 CRLs （证书吊销列表）定义的扩展提供了用于将附加属性与用户或公钥相关联的方法，用于管理认证层次结构以及管理CRL分发。 X.509扩展格式还允许社区定义私有扩展以携带这些社区独有的信息。

    证书/ CRL中的每个扩展名可能被指定为关键或非关键。 证书/ CRL使用系统（验证证书/ CRL的应用程序）如果遇到无法识别的关键扩展名，则必须拒绝证书/ CRL。 如果无法识别非关键扩展名，则可能会被忽略。

    ASN.1的定义是：

      Extensions  ::=  SEQUENCE SIZE (1..MAX) OF Extension

 Extension  ::=  SEQUENCE  {
     extnId        OBJECT IDENTIFIER,
     critical      BOOLEAN DEFAULT FALSE,
     extnValue     OCTET STRING
                   -- contains a DER encoding of a value
                   -- of the type registered for use with
                   -- the extnId object identifier value
 }
    由于并非所有分机都是已知的，因此getExtensionValue方法返回扩展值的DER编码OCTET STRING（即extnValue ）。 然后可以由理解扩展名的类来处理。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Set<String> getCriticalExtensionOIDs​()
      获取由实现此接口的对象管理的证书/ CRL中标记为“CRITICAL”的扩展名的OID字符串集。
      byte[] getExtensionValue​(String oid)
      获取由传入的 oid字符串标识的扩展值（ extnValue ）的DER编码的OCTET字符串。
      Set<String> getNonCriticalExtensionOIDs​()
      获取由实现此接口的对象管理的证书/ CRL中标记为“非关键性”的扩展名的OID字符串集。
      boolean hasUnsupportedCriticalExtension​()
      检查是否有不支持的关键扩展。

    • 方法详细信息

      • hasUnsupportedCriticalExtension

        boolean hasUnsupportedCriticalExtension​()
        检查是否有不支持的关键扩展。
        结果
        true如果发现不支持的关键扩展，否则为 false 。

      • getCriticalExtensionOIDs

        Set<String> getCriticalExtensionOIDs​()
        获取由实现此接口的对象管理的证书/ CRL中标记为“CRITICAL”的扩展名的OID字符串集。 以下是从X509Certificate获取一组关键扩展的示例代码，并打印OID：
           X509Certificate cert = null; try (InputStream inStrm = new FileInputStream("DER-encoded-Cert")) { CertificateFactory cf = CertificateFactory.getInstance("X.509"); cert = (X509Certificate)cf.generateCertificate(inStrm); } Set<String> critSet = cert.getCriticalExtensionOIDs(); if (critSet != null && !critSet.isEmpty()) { System.out.println("Set of critical extensions:"); for (String oid : critSet) { System.out.println(oid); } }
        结果
        扩展名OID字符串的标识为关键的扩展名的集合（或空集（如果没有标记为关键））。 如果根本没有扩展名，那么这个方法返回null。

      • getNonCriticalExtensionOIDs

        Set<String> getNonCriticalExtensionOIDs​()
        获取由实现此接口的对象管理的证书/ CRL中标记为“非关键性”的扩展名的OID字符串集。 以下是从X509CRL撤销的证书条目获取一组非关键扩展的示例代码，并打印OID：
           CertificateFactory cf = null; X509CRL crl = null; try (InputStream inStrm = new FileInputStream("DER-encoded-CRL")) { cf = CertificateFactory.getInstance("X.509"); crl = (X509CRL)cf.generateCRL(inStrm); } byte[] certData = <DER-encoded certificate data> ByteArrayInputStream bais = new ByteArrayInputStream(certData); X509Certificate cert = (X509Certificate)cf.generateCertificate(bais); X509CRLEntry badCert = crl.getRevokedCertificate(cert.getSerialNumber()); if (badCert != null) { Set<String> nonCritSet = badCert.getNonCriticalExtensionOIDs(); if (nonCritSet != null) for (String oid : nonCritSet) { System.out.println(oid); } }
        结果
        扩展名为非关键扩展名的扩展名OID字符串的集合（或空的集合，如果没有标记为非关键的）。 如果根本没有扩展名，那么这个方法返回null。

      • getExtensionValue

        byte[] getExtensionValue​(String oid)
        获取由传入的oid字符串标识的扩展值（ extnValue ）的DER编码的OCTET字符串。 oid字符串由一组以句点分隔的非负整数表示。

        例如：

        Examples of OIDs and extension names OID (Object Identifier) Extension Name 2.5.29.14 SubjectKeyIdentifier 2.5.29.15 KeyUsage 2.5.29.16 PrivateKeyUsage 2.5.29.17 SubjectAlternativeName 2.5.29.18 IssuerAlternativeName 2.5.29.19 BasicConstraints 2.5.29.30 NameConstraints 2.5.29.33 PolicyMappings 2.5.29.35 AuthorityKeyIdentifier 2.5.29.36 PolicyConstraints
        参数
        oid - 扩展名的对象标识符值。
        结果
        扩展值的DER编码八位字节串，如果不存在，则为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class java.security.cert.Certificate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.Certificate

  • Packages that use Certificate
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    javax.crypto
    提供加密操作的类和接口。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of Certificate in java.net

      Methods in java.net that return Certificate
      Modifier and Type 方法 描述
      Certificate[] JarURLConnection.getCertificates​()
      如果它的URL指向JAR文件条目，则返回此连接的证书对象，否则返回null。
      Methods in java.net that return types with arguments of type Certificate
      Modifier and Type 方法 描述
      abstract List<Certificate> SecureCacheResponse.getLocalCertificateChain​()
      返回在握手检索网络资源的原始连接期间发送到服务器的证书链。
      abstract List<Certificate> SecureCacheResponse.getServerCertificateChain​()
      返回服务器的证书链，它是作为在检索网络资源的原始连接中从缓存定义会话的一部分而建立的。

    • Uses of Certificate in java.security

      Methods in java.security that return Certificate
      Modifier and Type 方法 描述
      abstract Certificate KeyStoreSpi.engineGetCertificate​(String alias)
      返回与给定别名相关联的证书。
      abstract Certificate[] KeyStoreSpi.engineGetCertificateChain​(String alias)
      返回与给定别名关联的证书链。
      Certificate KeyStore.getCertificate​(String alias)
      返回与给定别名相关联的证书。
      Certificate KeyStore.PrivateKeyEntry.getCertificate​()
      从该条目中的证书链中获取终端实体 Certificate 。
      Certificate[] KeyStore.getCertificateChain​(String alias)
      返回与给定别名关联的证书链。
      Certificate[] KeyStore.PrivateKeyEntry.getCertificateChain​()
      从此条目获取 Certificate链。
      Certificate[] CodeSource.getCertificates​()
      返回与此CodeSource相关联的证书。
      Certificate KeyStore.TrustedCertificateEntry.getTrustedCertificate​()
      从此条目获取值得信赖的 Certficate 。
      Certificate[] UnresolvedPermission.getUnresolvedCerts​()
      获取尚未解决的底层权限的签名者证书（无任何支持链）。
      Methods in java.security with parameters of type Certificate
      Modifier and Type 方法 描述
      abstract String KeyStoreSpi.engineGetCertificateAlias​(Certificate cert)
      返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。
      abstract void KeyStoreSpi.engineSetCertificateEntry​(String alias, Certificate cert)
      将给定的证书分配给给定的别名。
      abstract void KeyStoreSpi.engineSetKeyEntry​(String alias, byte[] key, Certificate[] chain)
      将给定的密钥（已经被保护）分配给给定的别名。
      abstract void KeyStoreSpi.engineSetKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)
      将给定的密钥分配给给定的别名，并使用给定的密码进行保护。
      String KeyStore.getCertificateAlias​(Certificate cert)
      返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。
      void Signature.initVerify​(Certificate certificate)
      使用给定证书中的公钥初始化此对象进行验证。
      void KeyStore.setCertificateEntry​(String alias, Certificate cert)
      将给定的可信证书分配给给定的别名。
      void KeyStore.setKeyEntry​(String alias, byte[] key, Certificate[] chain)
      将给定的密钥（已经被保护）分配给给定的别名。
      void KeyStore.setKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)
      将给定的密钥分配给给定的别名，并使用给定的密码进行保护。
      Constructors in java.security with parameters of type Certificate
      Constructor 描述
      CodeSource​(URL url, Certificate[] certs)
      构造一个CodeSource并将其与指定的位置和证书集合相关联。
      PrivateKeyEntry​(PrivateKey privateKey, Certificate[] chain)
      构造一个 PrivateKeyEntry与 PrivateKey和相应的证书链。
      PrivateKeyEntry​(PrivateKey privateKey, Certificate[] chain, Set<KeyStore.Entry.Attribute> attributes)
      构造一个具有 PrivateKeyEntry的 PrivateKey和相应的证书链和相关的条目属性。
      TrustedCertificateEntry​(Certificate trustedCert)
      构造一个 TrustedCertificateEntry与一个值得信赖的 Certificate 。
      TrustedCertificateEntry​(Certificate trustedCert, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 TrustedCertificateEntry具有可信任的 Certificate和相关联的条目属性。
      UnresolvedPermission​(String type, String name, String actions, Certificate[] certs)
      创建一个新的UnresolvedPermission，当权限解决时，包含稍后实际创建指定类的权限所需的权限信息。

    • Uses of Certificate in java.security.cert

      Subclasses of Certificate in java.security.cert
      Modifier and Type Class 描述
      class  X509Certificate
      X.509证书的抽象类。
      Methods in java.security.cert that return Certificate
      Modifier and Type 方法 描述
      abstract Certificate CertificateFactorySpi.engineGenerateCertificate​(InputStream inStream)
      生成证书对象并使用从输入流 inStream读取的数据进行初始化。
      Certificate CertificateFactory.generateCertificate​(InputStream inStream)
      生成证书对象并使用从输入流 inStream读取的数据进行初始化。
      Methods in java.security.cert that return types with arguments of type Certificate
      Modifier and Type 方法 描述
      abstract Collection<? extends Certificate> CertificateFactorySpi.engineGenerateCertificates​(InputStream inStream)
      返回从给定的输入流 inStream读取的证书的（可能为空的）集合视图。
      abstract Collection<? extends Certificate> CertStoreSpi.engineGetCertificates​(CertSelector selector)
      返回与指定选择器匹配的 Collection的 Certificate 。
      Collection<? extends Certificate> CertificateFactory.generateCertificates​(InputStream inStream)
      返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
      abstract List<? extends Certificate> CertPath.getCertificates​()
      返回此认证路径中的证书列表。
      Collection<? extends Certificate> CertStore.getCertificates​(CertSelector selector)
      返回匹配指定选择器的 Collection的 Certificate 。
      Methods in java.security.cert with parameters of type Certificate
      Modifier and Type 方法 描述
      void CertPathChecker.check​(Certificate cert)
      使用其内部状态对指定的证书执行检查。
      void PKIXCertPathChecker.check​(Certificate cert)
      使用其内部状态对指定的证书执行检查。
      abstract void PKIXCertPathChecker.check​(Certificate cert, Collection<String> unresolvedCritExts)
      使用其内部状态对指定证书执行检查，并从指定的OID字符串集合中删除其处理的任何关键扩展，这些扩展代表未解决的关键扩展。
      abstract boolean CRL.isRevoked​(Certificate cert)
      检查给定的证书是否在此CRL上。
      boolean CertSelector.match​(Certificate cert)
      决定是否选择 Certificate 。
      boolean X509CertSelector.match​(Certificate cert)
      决定是否选择 Certificate 。
      Method parameters in java.security.cert with type arguments of type Certificate
      Modifier and Type 方法 描述
      CertPath CertificateFactorySpi.engineGenerateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并用 List的 Certificate s进行初始化。
      CertPath CertificateFactory.generateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并使用 List的 Certificate初始化。

    • Uses of Certificate in java.util.jar

      Methods in java.util.jar that return Certificate
      Modifier and Type 方法 描述
      Certificate[] JarEntry.getCertificates​()
      返回 Certificate对象此条，或 null如果没有。

    • Uses of Certificate in javax.crypto

      Methods in javax.crypto with parameters of type Certificate
      Modifier and Type 方法 描述
      void Cipher.init​(int opmode, Certificate certificate)
      使用给定证书中的公钥初始化此密码。
      void Cipher.init​(int opmode, Certificate certificate, SecureRandom random)
      使用给定证书中的公钥和随机源初始化此密码。

    • Uses of Certificate in javax.net.ssl

      Methods in javax.net.ssl that return Certificate
      Modifier and Type 方法 描述
      Certificate[] HandshakeCompletedEvent.getLocalCertificates​()
      返回在握手期间发送给对等体的证书。
      abstract Certificate[] HttpsURLConnection.getLocalCertificates​()
      返回在握手期间发送到服务器的证书。
      Certificate[] SSLSession.getLocalCertificates​()
      返回在握手期间发送给对等体的证书。
      Certificate[] HandshakeCompletedEvent.getPeerCertificates​()
      返回作为定义会话的一部分而建立的对等体的身份。
      Certificate[] SSLSession.getPeerCertificates​()
      返回作为定义会话的一部分而建立的对等体的身份。
      abstract Certificate[] HttpsURLConnection.getServerCertificates​()
      返回作为定义会话的一部分而建立的服务器的证书链。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.Certificate.CertificateRep (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.Certificate.CertificateRep

No usage of java.security.cert.Certificate.CertificateRep
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertificateEncodingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertificateEncodingException

  • Packages that use CertificateEncodingException
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertificateEncodingException in java.security.cert

      Methods in java.security.cert that throw CertificateEncodingException
      Modifier and Type 方法 描述
      abstract byte[] Certificate.getEncoded​()
      返回此证书的编码形式。
      abstract byte[] CertPath.getEncoded​()
      使用默认编码返回此认证路径的编码形式。
      abstract byte[] CertPath.getEncoded​(String encoding)
      使用指定的编码返回此认证路径的编码形式。
      abstract byte[] X509Certificate.getTBSCertificate​()
      从该证书获取DER编码的证书信息， tbsCertificate 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertificateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertificateException

  • Packages that use CertificateException
    软件包 描述
    com.sun.jarsigner
    该包包括用于定义 jarsigner工具使用的签名机制的接口和类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of CertificateException in com.sun.jarsigner

      Methods in com.sun.jarsigner that throw CertificateException
      Modifier and Type 方法 描述
      abstract byte[] ContentSigner.generateSignedData​(ContentSignerParameters parameters, boolean omitContent, boolean applyTimestamp)
      已过时。
      生成PKCS＃7签名的数据消息。

    • Uses of CertificateException in java.security

      Methods in java.security that throw CertificateException
      Modifier and Type 方法 描述
      abstract void KeyStoreSpi.engineLoad​(InputStream stream, char[] password)
      从给定的输入流加载密钥库。
      void KeyStoreSpi.engineLoad​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParameter加载密钥库。
      abstract void KeyStoreSpi.engineStore​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void KeyStoreSpi.engineStore​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParmeter存储此密钥库。
      static KeyStore KeyStore.getInstance​(File file, char[] password)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore KeyStore.getInstance​(File file, KeyStore.LoadStoreParameter param)
      返回相应密钥库类型的加载密钥库对象。
      void KeyStore.load​(InputStream stream, char[] password)
      从给定的输入流加载此KeyStore。
      void KeyStore.load​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter加载此密钥库。
      void KeyStore.store​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void KeyStore.store​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter存储此密钥库。

    • Uses of CertificateException in java.security.cert

      Subclasses of CertificateException in java.security.cert
      Modifier and Type Class 描述
      class  CertificateEncodingException
      证书编码异常。
      class  CertificateExpiredException
      证书过期例外
      class  CertificateNotYetValidException
      证书还没有有效的例外。
      class  CertificateParsingException
      证书解析异常。
      class  CertificateRevokedException
      表示X.509证书的异常被撤销。
      Methods in java.security.cert that throw CertificateException
      Modifier and Type 方法 描述
      abstract Certificate CertificateFactorySpi.engineGenerateCertificate​(InputStream inStream)
      生成证书对象，并使用从输入流 inStream读取的数据进行初始化。
      abstract Collection<? extends Certificate> CertificateFactorySpi.engineGenerateCertificates​(InputStream inStream)
      返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
      CertPath CertificateFactorySpi.engineGenerateCertPath​(InputStream inStream)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactorySpi.engineGenerateCertPath​(InputStream inStream, String encoding)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactorySpi.engineGenerateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并使用 List的 Certificate初始化。
      Certificate CertificateFactory.generateCertificate​(InputStream inStream)
      生成证书对象，并使用从输入流 inStream读取的数据进行初始化。
      Collection<? extends Certificate> CertificateFactory.generateCertificates​(InputStream inStream)
      返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
      CertPath CertificateFactory.generateCertPath​(InputStream inStream)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactory.generateCertPath​(InputStream inStream, String encoding)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactory.generateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并使用 List的 Certificate初始化它。
      static CertificateFactory CertificateFactory.getInstance​(String type)
      返回实现指定证书类型的证书工厂对象。
      static CertificateFactory CertificateFactory.getInstance​(String type, String provider)
      返回指定证书类型的证书工厂对象。
      static CertificateFactory CertificateFactory.getInstance​(String type, Provider provider)
      返回指定证书类型的证书工厂对象。
      abstract void Certificate.verify​(PublicKey key)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void X509Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。

    • Uses of CertificateException in javax.net.ssl

      Methods in javax.net.ssl that throw CertificateException
      Modifier and Type 方法 描述
      abstract void X509ExtendedTrustManager.checkClientTrusted​(X509Certificate[] chain, String authType, Socket socket)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      abstract void X509ExtendedTrustManager.checkClientTrusted​(X509Certificate[] chain, String authType, SSLEngine engine)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      void X509TrustManager.checkClientTrusted​(X509Certificate[] chain, String authType)
      给定由对等体提供的部分或完整的证书链，构建证书路径到受信任的根，并返回，如果它可以被验证，并且基于认证类型对客户端SSL认证信任。
      abstract void X509ExtendedTrustManager.checkServerTrusted​(X509Certificate[] chain, String authType, Socket socket)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      abstract void X509ExtendedTrustManager.checkServerTrusted​(X509Certificate[] chain, String authType, SSLEngine engine)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      void X509TrustManager.checkServerTrusted​(X509Certificate[] chain, String authType)
      给定对等体提供的部分或完整的证书链，构建一个证书路径到一个受信任的根，并返回，如果它可以被验证，并且信任基于认证类型的服务器SSL认证。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertificateExpiredException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertificateExpiredException

  • Packages that use CertificateExpiredException
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertificateExpiredException in java.security.cert

      Methods in java.security.cert that throw CertificateExpiredException
      Modifier and Type 方法 描述
      abstract void X509Certificate.checkValidity​()
      检查证书当前是否有效。
      abstract void X509Certificate.checkValidity​(Date date)
      检查给定日期是否在证书的有效期内。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertificateFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertificateFactory

  • Packages that use CertificateFactory
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertificateFactory in java.security.cert

      Methods in java.security.cert that return CertificateFactory
      Modifier and Type 方法 描述
      static CertificateFactory CertificateFactory.getInstance​(String type)
      返回实现指定证书类型的证书工厂对象。
      static CertificateFactory CertificateFactory.getInstance​(String type, String provider)
      返回指定证书类型的证书工厂对象。
      static CertificateFactory CertificateFactory.getInstance​(String type, Provider provider)
      返回指定证书类型的证书工厂对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertificateFactorySpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertificateFactorySpi

  • Packages that use CertificateFactorySpi
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertificateFactorySpi in java.security.cert

      Constructors in java.security.cert with parameters of type CertificateFactorySpi
      Constructor 描述
      CertificateFactory​(CertificateFactorySpi certFacSpi, Provider provider, String type)
      创建给定类型的CertificateFactory对象，并将给定的提供者实现（SPI对象）封装在其中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertificateNotYetValidException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertificateNotYetValidException

  • Packages that use CertificateNotYetValidException
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertificateNotYetValidException in java.security.cert

      Methods in java.security.cert that throw CertificateNotYetValidException
      Modifier and Type 方法 描述
      abstract void X509Certificate.checkValidity​()
      检查证书当前是否有效。
      abstract void X509Certificate.checkValidity​(Date date)
      检查给定日期是否在证书的有效期内。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertificateParsingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertificateParsingException

  • Packages that use CertificateParsingException
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertificateParsingException in java.security.cert

      Methods in java.security.cert that throw CertificateParsingException
      Modifier and Type 方法 描述
      List<String> X509Certificate.getExtendedKeyUsage​()
      获取表示扩展密钥使用扩展（OID = 2.5.29.37）的 ExtKeyUsageSyntax字段的OBJECT标识符的字符串的不可修改列表。
      Collection<List<?>> X509Certificate.getIssuerAlternativeNames​()
      从 IssuerAltName扩展名（OID = 2.5.29.18）获取不可变的发行人替代名称集合。
      Collection<List<?>> X509Certificate.getSubjectAlternativeNames​()
      从 SubjectAltName扩展名（OID = 2.5.29.17）获取不可变的主题备用名称集合。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertificateRevokedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertificateRevokedException

No usage of java.security.cert.CertificateRevokedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertPath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertPath

  • Packages that use CertPath
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    jdk.security.jarsigner

    • Uses of CertPath in java.security

      Methods in java.security that return CertPath
      Modifier and Type 方法 描述
      CertPath CodeSigner.getSignerCertPath​()
      返回签名者的证书路径。
      CertPath Timestamp.getSignerCertPath​()
      返回时间戳权限的证书路径。
      Constructors in java.security with parameters of type CertPath
      Constructor 描述
      CodeSigner​(CertPath signerCertPath, Timestamp timestamp)
      构造一个CodeSigner对象。
      Timestamp​(Date timestamp, CertPath signerCertPath)
      构建时间戳

    • Uses of CertPath in java.security.cert

      Methods in java.security.cert that return CertPath
      Modifier and Type 方法 描述
      CertPath CertificateFactorySpi.engineGenerateCertPath​(InputStream inStream)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactorySpi.engineGenerateCertPath​(InputStream inStream, String encoding)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactorySpi.engineGenerateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并用 List的 Certificate初始化。
      CertPath CertificateFactory.generateCertPath​(InputStream inStream)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactory.generateCertPath​(InputStream inStream, String encoding)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactory.generateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并使用 List的 Certificate初始化。
      CertPath CertPathBuilderResult.getCertPath​()
      返回建立的认证路径。
      CertPath CertPathValidatorException.getCertPath​()
      返回在抛出异常时验证的认证路径。
      CertPath PKIXCertPathBuilderResult.getCertPath​()
      返回建立和验证的认证路径。
      Methods in java.security.cert with parameters of type CertPath
      Modifier and Type 方法 描述
      abstract CertPathValidatorResult CertPathValidatorSpi.engineValidate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。
      CertPathValidatorResult CertPathValidator.validate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。
      Constructors in java.security.cert with parameters of type CertPath
      Constructor 描述
      CertPathValidatorException​(String msg, Throwable cause, CertPath certPath, int index)
      创建具有指定的详细消息，原因，认证路径和索引的 CertPathValidatorException 。
      CertPathValidatorException​(String msg, Throwable cause, CertPath certPath, int index, CertPathValidatorException.Reason reason)
      创建一个具有指定的详细消息，原因，认证路径，索引和原因的 CertPathValidatorException 。
      PKIXCertPathBuilderResult​(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
      创建包含指定参数的 PKIXCertPathBuilderResult实例。

    • Uses of CertPath in jdk.security.jarsigner

      Constructors in jdk.security.jarsigner with parameters of type CertPath
      Constructor 描述
      Builder​(PrivateKey privateKey, CertPath certPath)
      使用私钥和认证路径创建一个 JarSigner.Builder对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertPath.CertPathRep (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertPath.CertPathRep

No usage of java.security.cert.CertPath.CertPathRep
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertPathBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertPathBuilder

  • Packages that use CertPathBuilder
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathBuilder in java.security.cert

      Methods in java.security.cert that return CertPathBuilder
      Modifier and Type 方法 描述
      static CertPathBuilder CertPathBuilder.getInstance​(String algorithm)
      返回实现指定算法的 CertPathBuilder对象。
      static CertPathBuilder CertPathBuilder.getInstance​(String algorithm, String provider)
      返回实现指定算法的 CertPathBuilder对象。
      static CertPathBuilder CertPathBuilder.getInstance​(String algorithm, Provider provider)
      返回实现指定算法的 CertPathBuilder对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertPathBuilderException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertPathBuilderException

  • Packages that use CertPathBuilderException
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathBuilderException in java.security.cert

      Methods in java.security.cert that throw CertPathBuilderException
      Modifier and Type 方法 描述
      CertPathBuilderResult CertPathBuilder.build​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
      abstract CertPathBuilderResult CertPathBuilderSpi.engineBuild​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertPathBuilderSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertPathBuilderSpi

  • Packages that use CertPathBuilderSpi
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathBuilderSpi in java.security.cert

      Constructors in java.security.cert with parameters of type CertPathBuilderSpi
      Constructor 描述
      CertPathBuilder​(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
      创建给定算法的 CertPathBuilder对象，并将给定的提供者实现（SPI对象）封装在其中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertPathValidator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertPathValidator

  • Packages that use CertPathValidator
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathValidator in java.security.cert

      Methods in java.security.cert that return CertPathValidator
      Modifier and Type 方法 描述
      static CertPathValidator CertPathValidator.getInstance​(String algorithm)
      返回实现指定算法的 CertPathValidator对象。
      static CertPathValidator CertPathValidator.getInstance​(String algorithm, String provider)
      返回实现指定算法的 CertPathValidator对象。
      static CertPathValidator CertPathValidator.getInstance​(String algorithm, Provider provider)
      返回实现指定算法的 CertPathValidator对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertPathValidatorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertPathValidatorException

  • Packages that use CertPathValidatorException
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathValidatorException in java.security.cert

      Methods in java.security.cert that return types with arguments of type CertPathValidatorException
      Modifier and Type 方法 描述
      abstract List<CertPathValidatorException> PKIXRevocationChecker.getSoftFailExceptions​()
      返回一个列表，其中包含当设置了 SOFT_FAIL选项时撤销检查器忽略的异常。
      Methods in java.security.cert that throw CertPathValidatorException
      Modifier and Type 方法 描述
      void CertPathChecker.check​(Certificate cert)
      使用其内部状态对指定的证书执行检查。
      void PKIXCertPathChecker.check​(Certificate cert)
      使用其内部状态对指定的证书执行检查。
      abstract void PKIXCertPathChecker.check​(Certificate cert, Collection<String> unresolvedCritExts)
      使用其内部状态对指定证书执行检查，并从指定的OID字符串集合中删除其处理的任何关键扩展，这些扩展代表未解决的关键扩展。
      abstract CertPathValidatorResult CertPathValidatorSpi.engineValidate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。
      void CertPathChecker.init​(boolean forward)
      初始化此 CertPathChecker的内部状态。
      abstract void PKIXCertPathChecker.init​(boolean forward)
      初始化这个 PKIXCertPathChecker的内部状态。
      CertPathValidatorResult CertPathValidator.validate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertPathValidatorException.BasicReason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertPathValidatorException.BasicReason

  • Packages that use CertPathValidatorException.BasicReason
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathValidatorException.BasicReason in java.security.cert

      Methods in java.security.cert that return CertPathValidatorException.BasicReason
      Modifier and Type 方法 描述
      static CertPathValidatorException.BasicReason CertPathValidatorException.BasicReason.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CertPathValidatorException.BasicReason[] CertPathValidatorException.BasicReason.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertPathValidatorSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertPathValidatorSpi

  • Packages that use CertPathValidatorSpi
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathValidatorSpi in java.security.cert

      Constructors in java.security.cert with parameters of type CertPathValidatorSpi
      Constructor 描述
      CertPathValidator​(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
      创建给定算法的 CertPathValidator对象，并将给定的提供者实现（SPI对象）封装在其中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertStore

  • Packages that use CertStore
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertStore in java.security.cert

      Methods in java.security.cert that return CertStore
      Modifier and Type 方法 描述
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params)
      返回实现指定的 CertStore类型的 CertStore对象，并使用指定的参数进行初始化。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, String provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, Provider provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      Methods in java.security.cert that return types with arguments of type CertStore
      Modifier and Type 方法 描述
      List<CertStore> PKIXParameters.getCertStores​()
      返回用于查找证书和CRL的不可变 List的 CertStore 。
      Methods in java.security.cert with parameters of type CertStore
      Modifier and Type 方法 描述
      void PKIXParameters.addCertStore​(CertStore store)
      在查找证书和CRL中使用的 CertStore列表的末尾添加一个 CertStore 。
      Method parameters in java.security.cert with type arguments of type CertStore
      Modifier and Type 方法 描述
      void PKIXParameters.setCertStores​(List<CertStore> stores)
      Sets the list of CertStores to be used in finding certificates and CRLs.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertStoreException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertStoreException

  • Packages that use CertStoreException
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertStoreException in java.security.cert

      Methods in java.security.cert that throw CertStoreException
      Modifier and Type 方法 描述
      abstract Collection<? extends Certificate> CertStoreSpi.engineGetCertificates​(CertSelector selector)
      返回匹配指定选择器的 Collection的 Certificate 。
      abstract Collection<? extends CRL> CertStoreSpi.engineGetCRLs​(CRLSelector selector)
      返回与指定的选择器匹配的 Collection的 CRL 。
      Collection<? extends Certificate> CertStore.getCertificates​(CertSelector selector)
      返回匹配指定选择器的 Collection的 Certificate 。
      Collection<? extends CRL> CertStore.getCRLs​(CRLSelector selector)
      返回匹配指定选择器的 Collection的 CRL 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CertStoreSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CertStoreSpi

  • Packages that use CertStoreSpi
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertStoreSpi in java.security.cert

      Constructors in java.security.cert with parameters of type CertStoreSpi
      Constructor 描述
      CertStore​(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
      创建给定类型的 CertStore对象，并将给定的提供者实现（SPI对象）封装在其中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CollectionCertStoreParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CollectionCertStoreParameters

No usage of java.security.cert.CollectionCertStoreParameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CRL (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CRL

  • Packages that use CRL
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CRL in java.security.cert

      Subclasses of CRL in java.security.cert
      Modifier and Type Class 描述
      class  X509CRL
      X.509证书撤销列表（CRL）的抽象类。
      Methods in java.security.cert that return CRL
      Modifier and Type 方法 描述
      abstract CRL CertificateFactorySpi.engineGenerateCRL​(InputStream inStream)
      生成证书吊销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。
      CRL CertificateFactory.generateCRL​(InputStream inStream)
      生成证书吊销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。
      Methods in java.security.cert that return types with arguments of type CRL
      Modifier and Type 方法 描述
      abstract Collection<? extends CRL> CertificateFactorySpi.engineGenerateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。
      abstract Collection<? extends CRL> CertStoreSpi.engineGetCRLs​(CRLSelector selector)
      返回匹配指定选择器的 Collection的 CRL 。
      Collection<? extends CRL> CertificateFactory.generateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。
      Collection<? extends CRL> CertStore.getCRLs​(CRLSelector selector)
      返回匹配指定选择器的 Collection的 CRL 。
      Methods in java.security.cert with parameters of type CRL
      Modifier and Type 方法 描述
      boolean CRLSelector.match​(CRL crl)
      决定是否选择 CRL 。
      boolean X509CRLSelector.match​(CRL crl)
      决定是否选择 CRL 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CRLException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CRLException

  • Packages that use CRLException
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CRLException in java.security.cert

      Methods in java.security.cert that throw CRLException
      Modifier and Type 方法 描述
      abstract CRL CertificateFactorySpi.engineGenerateCRL​(InputStream inStream)
      生成证书吊销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。
      abstract Collection<? extends CRL> CertificateFactorySpi.engineGenerateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。
      CRL CertificateFactory.generateCRL​(InputStream inStream)
      生成证书吊销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。
      Collection<? extends CRL> CertificateFactory.generateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。
      abstract byte[] X509CRL.getEncoded​()
      返回此CRL的ASN.1 DER编码形式。
      abstract byte[] X509CRLEntry.getEncoded​()
      返回此CRL条目的ASN.1 DER编码形式，即内部SEQUENCE。
      abstract byte[] X509CRL.getTBSCertList​()
      获取DER编码的CRL信息，来自此CRL的 tbsCertList 。
      abstract void X509CRL.verify​(PublicKey key)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      abstract void X509CRL.verify​(PublicKey key, String sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      void X509CRL.verify​(PublicKey key, Provider sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.CRLReason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.CRLReason

  • Packages that use CRLReason
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CRLReason in java.security.cert

      Methods in java.security.cert that return CRLReason
      Modifier and Type 方法 描述
      CRLReason CertificateRevokedException.getRevocationReason​()
      返回证书被撤销的原因。
      CRLReason X509CRLEntry.getRevocationReason​()
      返回证书被撤销的原因，如CRL条目的“原因码”扩展中所指定。
      static CRLReason CRLReason.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CRLReason[] CRLReason.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in java.security.cert with parameters of type CRLReason
      Constructor 描述
      CertificateRevokedException​(Date revocationDate, CRLReason reason, X500Principal authority, Map<String,Extension> extensions)
      构造具有指定撤销日期，原因代码，权限名称和扩展名映射的 CertificateRevokedException 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.LDAPCertStoreParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.LDAPCertStoreParameters

No usage of java.security.cert.LDAPCertStoreParameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.PKIXBuilderParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.PKIXBuilderParameters

No usage of java.security.cert.PKIXBuilderParameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.PKIXCertPathBuilderResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.PKIXCertPathBuilderResult

No usage of java.security.cert.PKIXCertPathBuilderResult
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.PKIXCertPathChecker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.PKIXCertPathChecker

  • Packages that use PKIXCertPathChecker
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of PKIXCertPathChecker in java.security.cert

      Subclasses of PKIXCertPathChecker in java.security.cert
      Modifier and Type Class 描述
      class  PKIXRevocationChecker
      A PKIXCertPathChecker用于使用PKIX算法检查证书的撤销状态。
      Methods in java.security.cert that return types with arguments of type PKIXCertPathChecker
      Modifier and Type 方法 描述
      List<PKIXCertPathChecker> PKIXParameters.getCertPathCheckers​()
      返回认证路径检查器的 List 。
      Methods in java.security.cert with parameters of type PKIXCertPathChecker
      Modifier and Type 方法 描述
      void PKIXParameters.addCertPathChecker​(PKIXCertPathChecker checker)
      在认证路径检查列表中添加一个 PKIXCertPathChecker 。
      Method parameters in java.security.cert with type arguments of type PKIXCertPathChecker
      Modifier and Type 方法 描述
      void PKIXParameters.setCertPathCheckers​(List<PKIXCertPathChecker> checkers)
      设置一个额外的认证路径检查器 List 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.PKIXCertPathValidatorResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.PKIXCertPathValidatorResult

  • Packages that use PKIXCertPathValidatorResult
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of PKIXCertPathValidatorResult in java.security.cert

      Subclasses of PKIXCertPathValidatorResult in java.security.cert
      Modifier and Type Class 描述
      class  PKIXCertPathBuilderResult
      此类表示PKIX认证路径构建器算法的成功结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.PKIXParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.PKIXParameters

  • Packages that use PKIXParameters
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of PKIXParameters in java.security.cert

      Subclasses of PKIXParameters in java.security.cert
      Modifier and Type Class 描述
      class  PKIXBuilderParameters
      参数用作PKIX CertPathBuilder算法的输入。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.PKIXReason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.PKIXReason

  • Packages that use PKIXReason
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of PKIXReason in java.security.cert

      Methods in java.security.cert that return PKIXReason
      Modifier and Type 方法 描述
      static PKIXReason PKIXReason.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PKIXReason[] PKIXReason.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.PKIXRevocationChecker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.PKIXRevocationChecker

  • Packages that use PKIXRevocationChecker
    软件包 描述
    java.security.cert
    Provides classes and interfaces for parsing and managing certificates, certificate revocation lists (CRLs), and certification paths.

    • Uses of PKIXRevocationChecker in java.security.cert

      Methods in java.security.cert that return PKIXRevocationChecker
      Modifier and Type | 方法 | 描述
      PKIXRevocationChecker | PKIXRevocationChecker.clone​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.PKIXRevocationChecker.Option (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.PKIXRevocationChecker.Option

  • Packages that use PKIXRevocationChecker.Option
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of PKIXRevocationChecker.Option in java.security.cert

      Methods in java.security.cert that return PKIXRevocationChecker.Option
      Modifier and Type 方法 描述
      static PKIXRevocationChecker.Option PKIXRevocationChecker.Option.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PKIXRevocationChecker.Option[] PKIXRevocationChecker.Option.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.security.cert that return types with arguments of type PKIXRevocationChecker.Option
      Modifier and Type 方法 描述
      Set<PKIXRevocationChecker.Option> PKIXRevocationChecker.getOptions​()
      获取吊销选项。
      Method parameters in java.security.cert with type arguments of type PKIXRevocationChecker.Option
      Modifier and Type 方法 描述
      void PKIXRevocationChecker.setOptions​(Set<PKIXRevocationChecker.Option> options)
      设置撤销选项。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.PolicyQualifierInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.PolicyQualifierInfo

  • Packages that use PolicyQualifierInfo
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of PolicyQualifierInfo in java.security.cert

      Methods in java.security.cert that return types with arguments of type PolicyQualifierInfo
      Modifier and Type 方法 描述
      Set<? extends PolicyQualifierInfo> PolicyNode.getPolicyQualifiers​()
      返回与此节点所表示的有效策略相关联的策略限定符集。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.TrustAnchor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.TrustAnchor

  • Packages that use TrustAnchor
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of TrustAnchor in java.security.cert

      Methods in java.security.cert that return TrustAnchor
      Modifier and Type 方法 描述
      TrustAnchor PKIXCertPathValidatorResult.getTrustAnchor​()
      返回描述作为证书路径的信任锚点的CA的 TrustAnchor 。
      Methods in java.security.cert that return types with arguments of type TrustAnchor
      Modifier and Type 方法 描述
      Set<TrustAnchor> PKIXParameters.getTrustAnchors​()
      返回不可变的 Set最受信任的CA。
      Method parameters in java.security.cert with type arguments of type TrustAnchor
      Modifier and Type 方法 描述
      void PKIXParameters.setTrustAnchors​(Set<TrustAnchor> trustAnchors)
      设置 Set最受信任的CA。
      Constructors in java.security.cert with parameters of type TrustAnchor
      Constructor 描述
      PKIXCertPathBuilderResult​(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
      创建包含指定参数的 PKIXCertPathBuilderResult实例。
      PKIXCertPathValidatorResult​(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
      创建包含指定参数的 PKIXCertPathValidatorResult实例。
      Constructor parameters in java.security.cert with type arguments of type TrustAnchor
      Constructor 描述
      PKIXBuilderParameters​(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
      使用指定的 Set最受信任的CA创建一个 PKIXBuilderParameters的实例。
      PKIXParameters​(Set<TrustAnchor> trustAnchors)
      使用指定的 Set最受信任的CA创建一个 PKIXParameters的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.URICertStoreParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.URICertStoreParameters

  • Packages that use URICertStoreParameters
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of URICertStoreParameters in java.security.cert

      Methods in java.security.cert that return URICertStoreParameters
      Modifier and Type 方法 描述
      URICertStoreParameters URICertStoreParameters.clone​()
      返回此对象的副本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.X509Certificate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.X509Certificate

  • Packages that use X509Certificate
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。

    • Uses of X509Certificate in com.sun.jarsigner

      Methods in com.sun.jarsigner that return X509Certificate
      Modifier and Type 方法 描述
      X509Certificate[] ContentSignerParameters.getSignerCertificateChain​()
      已过时。
      检索签名人的X.509证书链。
      X509Certificate ContentSignerParameters.getTimestampingAuthorityCertificate​()
      已过时。
      检索时间戳管理局（TSA）的证书。

    • Uses of X509Certificate in java.security.cert

      Methods in java.security.cert that return X509Certificate
      Modifier and Type 方法 描述
      X509Certificate X509CertSelector.getCertificate​()
      返回certificateEquals标准。
      X509Certificate X509CRLSelector.getCertificateChecking​()
      返回正在检查的证书。
      X509Certificate PKIXRevocationChecker.getOcspResponderCert​()
      获取OCSP响应者的证书。
      X509Certificate TrustAnchor.getTrustedCert​()
      返回最受信任的CA证书。
      Methods in java.security.cert that return types with arguments of type X509Certificate
      Modifier and Type 方法 描述
      Map<X509Certificate,byte[]> PKIXRevocationChecker.getOcspResponses​()
      获得OCSP响应。
      Methods in java.security.cert with parameters of type X509Certificate
      Modifier and Type 方法 描述
      X509CRLEntry X509CRL.getRevokedCertificate​(X509Certificate certificate)
      获取给定证书的CRL条目（如果有）。
      void X509CertSelector.setCertificate​(X509Certificate cert)
      设置certificateEquals标准。
      void X509CRLSelector.setCertificateChecking​(X509Certificate cert)
      设置正在检查的证书。
      void PKIXRevocationChecker.setOcspResponderCert​(X509Certificate cert)
      设置OCSP响应者的证书。
      Method parameters in java.security.cert with type arguments of type X509Certificate
      Modifier and Type 方法 描述
      void PKIXRevocationChecker.setOcspResponses​(Map<X509Certificate,byte[]> responses)
      设置OCSP响应。
      Constructors in java.security.cert with parameters of type X509Certificate
      Constructor 描述
      TrustAnchor​(X509Certificate trustedCert, byte[] nameConstraints)
      创建具有指定的 X509Certificate和可选名称约束的 TrustAnchor实例，这些约束用于在验证X.509认证路径时用作其他约束。

    • Uses of X509Certificate in javax.net.ssl

      Methods in javax.net.ssl that return X509Certificate
      Modifier and Type 方法 描述
      X509Certificate[] X509TrustManager.getAcceptedIssuers​()
      返回一个可信任验证对等体的证书颁发机构证书数组。
      X509Certificate[] X509KeyManager.getCertificateChain​(String alias)
      返回与给定别名关联的证书链。
      Methods in javax.net.ssl with parameters of type X509Certificate
      Modifier and Type 方法 描述
      abstract void X509ExtendedTrustManager.checkClientTrusted​(X509Certificate[] chain, String authType, Socket socket)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      abstract void X509ExtendedTrustManager.checkClientTrusted​(X509Certificate[] chain, String authType, SSLEngine engine)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      void X509TrustManager.checkClientTrusted​(X509Certificate[] chain, String authType)
      给定由对等体提供的部分或完整的证书链，构建证书路径到受信任的根，并返回，如果它可以被验证，并且基于认证类型对客户端SSL认证信任。
      abstract void X509ExtendedTrustManager.checkServerTrusted​(X509Certificate[] chain, String authType, Socket socket)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      abstract void X509ExtendedTrustManager.checkServerTrusted​(X509Certificate[] chain, String authType, SSLEngine engine)
      给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。
      void X509TrustManager.checkServerTrusted​(X509Certificate[] chain, String authType)
      给定对等体提供的部分或完整的证书链，构建一个证书路径到一个受信任的根，并返回，如果它可以被验证，并且信任基于认证类型的服务器SSL认证。

    • Uses of X509Certificate in javax.security.auth.x500

      Methods in javax.security.auth.x500 that return X509Certificate
      Modifier and Type 方法 描述
      X509Certificate X500PrivateCredential.getCertificate​()
      返回X.509证书。
      Constructors in javax.security.auth.x500 with parameters of type X509Certificate
      Constructor 描述
      X500PrivateCredential​(X509Certificate cert, PrivateKey key)
      创建X500PrivateCredential，它将X.509证书，私钥和KeyStore别名相关联。
      X500PrivateCredential​(X509Certificate cert, PrivateKey key, String alias)
      创建X500PrivateCredential，它将X.509证书，私钥和KeyStore别名相关联。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.X509CertSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.X509CertSelector

No usage of java.security.cert.X509CertSelector
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.X509CRL (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.X509CRL

No usage of java.security.cert.X509CRL
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.X509CRLEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.X509CRLEntry

  • Packages that use X509CRLEntry
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of X509CRLEntry in java.security.cert

      Methods in java.security.cert that return X509CRLEntry
      Modifier and Type 方法 描述
      abstract X509CRLEntry X509CRL.getRevokedCertificate​(BigInteger serialNumber)
      获取给定证书serialNumber的CRL条目（如果有）。
      X509CRLEntry X509CRL.getRevokedCertificate​(X509Certificate certificate)
      获取给定证书的CRL条目（如果有）。
      Methods in java.security.cert that return types with arguments of type X509CRLEntry
      Modifier and Type 方法 描述
      abstract Set<? extends X509CRLEntry> X509CRL.getRevokedCertificates​()
      获取此CRL中的所有条目。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.cert.X509CRLSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.cert.X509CRLSelector

No usage of java.security.cert.X509CRLSelector
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.CertPathBuilderResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.CertPathBuilderResult

  • Packages that use CertPathBuilderResult
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathBuilderResult in java.security.cert

      Classes in java.security.cert that implement CertPathBuilderResult
      Modifier and Type Class 描述
      class  PKIXCertPathBuilderResult
      此类表示PKIX认证路径构建器算法的成功结果。
      Methods in java.security.cert that return CertPathBuilderResult
      Modifier and Type 方法 描述
      CertPathBuilderResult CertPathBuilder.build​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
      abstract CertPathBuilderResult CertPathBuilderSpi.engineBuild​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.CertPathChecker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.CertPathChecker

  • Packages that use CertPathChecker
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathChecker in java.security.cert

      Classes in java.security.cert that implement CertPathChecker
      Modifier and Type Class 描述
      class  PKIXCertPathChecker
      对 X509Certificate执行一个或多个检查的抽象类。
      class  PKIXRevocationChecker
      A PKIXCertPathChecker用于使用PKIX算法检查证书的撤销状态。
      Methods in java.security.cert that return CertPathChecker
      Modifier and Type 方法 描述
      CertPathChecker CertPathBuilderSpi.engineGetRevocationChecker​()
      返回此实现用于检查证书的撤销状态的 CertPathChecker 。
      CertPathChecker CertPathValidatorSpi.engineGetRevocationChecker​()
      返回此实现用于检查证书的吊销状态的 CertPathChecker 。
      CertPathChecker CertPathBuilder.getRevocationChecker​()
      返回 CertPathChecker封装的 CertPathBuilderSpi实现用于检查证书的撤销状态。
      CertPathChecker CertPathValidator.getRevocationChecker​()
      Returns a CertPathChecker that the encapsulated CertPathValidatorSpi implementation uses to check the revocation status of certificates.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.CertPathParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.CertPathParameters

  • Packages that use CertPathParameters
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of CertPathParameters in java.security.cert

      Classes in java.security.cert that implement CertPathParameters
      Modifier and Type Class 描述
      class  PKIXBuilderParameters
      参数用作PKIX CertPathBuilder算法的输入。
      class  PKIXParameters
      参数用作PKIX CertPathValidator算法的输入。
      Methods in java.security.cert with parameters of type CertPathParameters
      Modifier and Type 方法 描述
      CertPathBuilderResult CertPathBuilder.build​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
      abstract CertPathBuilderResult CertPathBuilderSpi.engineBuild​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
      abstract CertPathValidatorResult CertPathValidatorSpi.engineValidate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。
      CertPathValidatorResult CertPathValidator.validate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。

    • Uses of CertPathParameters in javax.net.ssl

      Methods in javax.net.ssl that return CertPathParameters
      Modifier and Type 方法 描述
      CertPathParameters CertPathTrustManagerParameters.getParameters​()
      返回此类封装的CertPathParameters的克隆。
      Constructors in javax.net.ssl with parameters of type CertPathParameters
      Constructor 描述
      CertPathTrustManagerParameters​(CertPathParameters parameters)
      从指定的参数构造新的CertPathTrustManagerParameters。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.CertPathValidatorException.Reason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.CertPathValidatorException.Reason

  • Packages that use CertPathValidatorException.Reason
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathValidatorException.Reason in java.security.cert

      Classes in java.security.cert that implement CertPathValidatorException.Reason
      Modifier and Type Class 描述
      static class  CertPathValidatorException.BasicReason
      BasicReason列举了任何类型的认证路径可能无效的潜在原因。
      class  PKIXReason
      该 PKIXReason列举了PKIX特有的原因，因为根据PKIX（RFC 5280）标准，X.509认证路径可能无效。
      Methods in java.security.cert that return CertPathValidatorException.Reason
      Modifier and Type 方法 描述
      CertPathValidatorException.Reason CertPathValidatorException.getReason​()
      返回验证失败的原因。
      Constructors in java.security.cert with parameters of type CertPathValidatorException.Reason
      Constructor 描述
      CertPathValidatorException​(String msg, Throwable cause, CertPath certPath, int index, CertPathValidatorException.Reason reason)
      创建具有指定的详细消息，原因，认证路径，索引和原因的 CertPathValidatorException 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.CertPathValidatorResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.CertPathValidatorResult

  • Packages that use CertPathValidatorResult
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertPathValidatorResult in java.security.cert

      Classes in java.security.cert that implement CertPathValidatorResult
      Modifier and Type Class 描述
      class  PKIXCertPathBuilderResult
      此类表示PKIX认证路径构建器算法的成功结果。
      class  PKIXCertPathValidatorResult
      该类代表PKIX认证路径验证算法的成功结果。
      Methods in java.security.cert that return CertPathValidatorResult
      Modifier and Type 方法 描述
      abstract CertPathValidatorResult CertPathValidatorSpi.engineValidate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。
      CertPathValidatorResult CertPathValidator.validate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.CertSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.CertSelector

  • Packages that use CertSelector
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertSelector in java.security.cert

      Classes in java.security.cert that implement CertSelector
      Modifier and Type Class 描述
      class  X509CertSelector
      A CertSelector选择符合所有指定条件的 X509Certificates 。
      Methods in java.security.cert that return CertSelector
      Modifier and Type 方法 描述
      CertSelector PKIXParameters.getTargetCertConstraints​()
      返回目标证书所需的约束。
      Methods in java.security.cert with parameters of type CertSelector
      Modifier and Type 方法 描述
      abstract Collection<? extends Certificate> CertStoreSpi.engineGetCertificates​(CertSelector selector)
      返回与指定的选择器匹配的 Collection的 Certificate 。
      Collection<? extends Certificate> CertStore.getCertificates​(CertSelector selector)
      返回匹配指定选择器的 Collection的 Certificate 。
      void PKIXParameters.setTargetCertConstraints​(CertSelector selector)
      设置目标证书所需的约束。
      Constructors in java.security.cert with parameters of type CertSelector
      Constructor 描述
      PKIXBuilderParameters​(KeyStore keystore, CertSelector targetConstraints)
      创建 PKIXBuilderParameters的实例，它从指定的 KeyStore包含的受信任的证书条目填充最受信任的CA KeyStore 。
      PKIXBuilderParameters​(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
      创建具有指定的 Set最受信任的CA的 PKIXBuilderParameters实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.CertStoreParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.CertStoreParameters

  • Packages that use CertStoreParameters
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CertStoreParameters in java.security.cert

      Classes in java.security.cert that implement CertStoreParameters
      Modifier and Type Class 描述
      class  CollectionCertStoreParameters
      参数用作集合 CertStore算法的输入。
      class  LDAPCertStoreParameters
      参数用作LDAP CertStore算法的输入。
      class  URICertStoreParameters
      用作 CertStore算法的参数的参数，其使用URI中包含的信息来检索证书和CRL。
      Methods in java.security.cert that return CertStoreParameters
      Modifier and Type 方法 描述
      CertStoreParameters CertStore.getCertStoreParameters​()
      返回用于初始化 CertStore的参数。
      Methods in java.security.cert with parameters of type CertStoreParameters
      Modifier and Type 方法 描述
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params)
      返回实现指定的 CertStore类型的 CertStore对象，并使用指定的参数进行初始化。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, String provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, Provider provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      Constructors in java.security.cert with parameters of type CertStoreParameters
      Constructor 描述
      CertStore​(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
      创建给定类型的 CertStore对象，并将给定的提供者实现（SPI对象）封装在其中。
      CertStoreSpi​(CertStoreParameters params)
      唯一的建设者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.CRLSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.CRLSelector

  • Packages that use CRLSelector
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of CRLSelector in java.security.cert

      Classes in java.security.cert that implement CRLSelector
      Modifier and Type Class 描述
      class  X509CRLSelector
      A CRLSelector ，其选择符合所有指定条件的 X509CRLs 。
      Methods in java.security.cert with parameters of type CRLSelector
      Modifier and Type 方法 描述
      abstract Collection<? extends CRL> CertStoreSpi.engineGetCRLs​(CRLSelector selector)
      返回匹配指定选择器的 Collection的 CRL 。
      Collection<? extends CRL> CertStore.getCRLs​(CRLSelector selector)
      返回 Collection的 CRL指定选择器匹配秒。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.Extension (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.Extension

  • Packages that use Extension
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of Extension in java.security.cert

      Methods in java.security.cert that return types with arguments of type Extension
      Modifier and Type 方法 描述
      Map<String,Extension> CertificateRevokedException.getExtensions​()
      返回X.509扩展名的地图，其中包含有关撤销证书的附加信息，例如无效日期扩展。
      List<Extension> PKIXRevocationChecker.getOcspExtensions​()
      获取可选的OCSP请求扩展。
      Method parameters in java.security.cert with type arguments of type Extension
      Modifier and Type 方法 描述
      void PKIXRevocationChecker.setOcspExtensions​(List<Extension> extensions)
      设置可选的OCSP请求扩展。
      Constructor parameters in java.security.cert with type arguments of type Extension
      Constructor 描述
      CertificateRevokedException​(Date revocationDate, CRLReason reason, X500Principal authority, Map<String,Extension> extensions)
      构造具有指定撤销日期，原因代码，权限名称和扩展名映射的 CertificateRevokedException 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.PolicyNode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.PolicyNode

  • Packages that use PolicyNode
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of PolicyNode in java.security.cert

      Methods in java.security.cert that return PolicyNode
      Modifier and Type 方法 描述
      PolicyNode PolicyNode.getParent​()
      返回此节点的父节点，如果这是根节点，则返回 null 。
      PolicyNode PKIXCertPathValidatorResult.getPolicyTree​()
      返回PKIX认证路径验证算法产生的有效策略树的根节点。
      Methods in java.security.cert that return types with arguments of type PolicyNode
      Modifier and Type 方法 描述
      Iterator<? extends PolicyNode> PolicyNode.getChildren​()
      返回该节点的子节点的迭代器。
      Constructors in java.security.cert with parameters of type PolicyNode
      Constructor 描述
      PKIXCertPathBuilderResult​(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
      创建包含指定参数的 PKIXCertPathBuilderResult实例。
      PKIXCertPathValidatorResult​(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
      创建包含指定参数的 PKIXCertPathValidatorResult实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.cert.X509Extension (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.cert.X509Extension

  • Packages that use X509Extension
    软件包 描述
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

    • Uses of X509Extension in java.security.cert

      Classes in java.security.cert that implement X509Extension
      Modifier and Type Class 描述
      class  X509Certificate
      X.509证书的抽象类。
      class  X509CRL
      X.509证书撤销列表（CRL）的抽象类。
      class  X509CRLEntry
      CRL（证书撤销列表）中撤销证书的抽象类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.AccessControlContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.AccessControlContext

  • Packages that use AccessControlContext
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.security.auth
    此软件包提供了认证和授权的框架。

    • Uses of AccessControlContext in java.security

      Methods in java.security that return AccessControlContext
      Modifier and Type 方法 描述
      static AccessControlContext AccessController.getContext​()
      此方法将获取当前调用上下文的“快照”，其中包括当前Thread的继承的AccessControlContext和任何有限权限范围，并将其放置在AccessControlContext对象中。
      Methods in java.security with parameters of type AccessControlContext
      Modifier and Type 方法 描述
      static <T> T AccessController.doPrivileged​(PrivilegedAction<T> action, AccessControlContext context)
      执行指定的 PrivilegedAction ，启用并受指定的 AccessControlContext限制。
      static <T> T AccessController.doPrivileged​(PrivilegedAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedAction具有启用并受指定的 AccessControlContext限制的特权，特权范围受指定的 Permission参数限制。
      static <T> T AccessController.doPrivileged​(PrivilegedExceptionAction<T> action, AccessControlContext context)
      执行指定 PrivilegedExceptionAction由指定的启用和限制特权 AccessControlContext 。
      static <T> T AccessController.doPrivileged​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction ，启用并受限于特定的 AccessControlContext ，并且特权范围受指定的 Permission参数限制。
      Constructors in java.security with parameters of type AccessControlContext
      Constructor 描述
      AccessControlContext​(AccessControlContext acc, DomainCombiner combiner)
      创建一个新的 AccessControlContext与给定的 AccessControlContext和 DomainCombiner 。

    • Uses of AccessControlContext in javax.security.auth

      Methods in javax.security.auth with parameters of type AccessControlContext
      Modifier and Type 方法 描述
      static <T> T Subject.doAsPrivileged​(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
      作为一个特殊的 Subject执行特权工作。
      static <T> T Subject.doAsPrivileged​(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
      作为特定的 Subject执行特权工作。
      static Subject Subject.getSubject​(AccessControlContext acc)
      Get the Subject associated with the provided AccessControlContext.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.AccessControlException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.AccessControlException

  • Packages that use AccessControlException
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of AccessControlException in java.security

      Methods in java.security that throw AccessControlException
      Modifier and Type 方法 描述
      void AccessControlContext.checkPermission​(Permission perm)
      根据当前有效的安全策略以及此对象中的上下文确定是否允许或拒绝由指定权限指定的访问请求。
      static void AccessController.checkPermission​(Permission perm)
      根据当前的AccessControlContext和安全策略确定是否允许或拒绝由指定的权限指定的访问请求。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.AccessController (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.AccessController

No usage of java.security.AccessController
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.AlgorithmParameterGenerator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.AlgorithmParameterGenerator

  • Packages that use AlgorithmParameterGenerator
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of AlgorithmParameterGenerator in java.security

      Methods in java.security that return AlgorithmParameterGenerator
      Modifier and Type 方法 描述
      static AlgorithmParameterGenerator AlgorithmParameterGenerator.getInstance​(String algorithm)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      static AlgorithmParameterGenerator AlgorithmParameterGenerator.getInstance​(String algorithm, String provider)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      static AlgorithmParameterGenerator AlgorithmParameterGenerator.getInstance​(String algorithm, Provider provider)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.AlgorithmParameterGeneratorSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.AlgorithmParameterGeneratorSpi

  • Packages that use AlgorithmParameterGeneratorSpi
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of AlgorithmParameterGeneratorSpi in java.security

      Constructors in java.security with parameters of type AlgorithmParameterGeneratorSpi
      Constructor 描述
      AlgorithmParameterGenerator​(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
      创建一个AlgorithmParameterGenerator对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.AlgorithmParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.AlgorithmParameters

  • Packages that use AlgorithmParameters
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.crypto
    提供加密操作的类和接口。

    • Uses of AlgorithmParameters in java.security

      Methods in java.security that return AlgorithmParameters
      Modifier and Type 方法 描述
      protected abstract AlgorithmParameters AlgorithmParameterGeneratorSpi.engineGenerateParameters​()
      生成参数。
      protected AlgorithmParameters SignatureSpi.engineGetParameters​()
      提供者覆盖此方法以返回与此签名引擎一起使用的参数，如果此签名引擎不使用任何参数，则返回null。
      AlgorithmParameters AlgorithmParameterGenerator.generateParameters​()
      生成参数。
      static AlgorithmParameters AlgorithmParameters.getInstance​(String algorithm)
      返回指定算法的参数对象。
      static AlgorithmParameters AlgorithmParameters.getInstance​(String algorithm, String provider)
      返回指定算法的参数对象。
      static AlgorithmParameters AlgorithmParameters.getInstance​(String algorithm, Provider provider)
      返回指定算法的参数对象。
      AlgorithmParameters Signature.getParameters​()
      返回与此签名对象一起使用的参数。
      Methods in java.security with parameters of type AlgorithmParameters
      Modifier and Type 方法 描述
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, String algorithm, AlgorithmParameters parameters)
      确定是否为算法授予了指定的加密原语的权限。
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, String algorithm, Key key, AlgorithmParameters parameters)
      确定算法和相应的密钥是否被授予对指定的加密原语的许可。

    • Uses of AlgorithmParameters in javax.crypto

      Methods in javax.crypto that return AlgorithmParameters
      Modifier and Type 方法 描述
      protected abstract AlgorithmParameters CipherSpi.engineGetParameters​()
      返回与此密码一起使用的参数。
      AlgorithmParameters EncryptedPrivateKeyInfo.getAlgParameters​()
      返回加密算法使用的算法参数。
      AlgorithmParameters Cipher.getParameters​()
      返回与此密码一起使用的参数。
      Methods in javax.crypto with parameters of type AlgorithmParameters
      Modifier and Type 方法 描述
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      void Cipher.init​(int opmode, Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void ExemptionMechanism.init​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      Constructors in javax.crypto with parameters of type AlgorithmParameters
      Constructor 描述
      EncryptedPrivateKeyInfo​(AlgorithmParameters algParams, byte[] encryptedData)
      根据加密算法参数和加密数据构建一个 EncryptedPrivateKeyInfo 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.AlgorithmParametersSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.AlgorithmParametersSpi

  • Packages that use AlgorithmParametersSpi
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of AlgorithmParametersSpi in java.security

      Constructors in java.security with parameters of type AlgorithmParametersSpi
      Constructor 描述
      AlgorithmParameters​(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
      创建一个AlgorithmParameters对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.AllPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.AllPermission

No usage of java.security.AllPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.AuthProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.AuthProvider

No usage of java.security.AuthProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.BasicPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.BasicPermission

  • Packages that use BasicPermission
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.security.jgss
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.security
    提供安全框架的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    javafx.util
    包含各种实用程序和助手类。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    jdk.net
    适用于 java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of BasicPermission in com.sun.jdi

      Subclasses of BasicPermission in com.sun.jdi
      Modifier and Type Class 描述
      class  JDIPermission
      JDIPermission类代表访问权限 VirtualMachineManager 。

    • Uses of BasicPermission in com.sun.security.jgss

      Subclasses of BasicPermission in com.sun.security.jgss
      Modifier and Type Class 描述
      class  InquireSecContextPermission
      该类用于保护可以使用 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)方法访问的已建立GSS安全上下文的各种属性。

    • Uses of BasicPermission in com.sun.tools.attach

      Subclasses of BasicPermission in com.sun.tools.attach
      Modifier and Type Class 描述
      class  AttachPermission
      当一个SecurityManager集合，这是当代码调用VirtalMachine.attach附加到目标虚拟机时将被检查的权限。

    • Uses of BasicPermission in java.awt

      Subclasses of BasicPermission in java.awt
      Modifier and Type Class 描述
      class  AWTPermission
      此类用于AWT权限。

    • Uses of BasicPermission in java.io

      Subclasses of BasicPermission in java.io
      Modifier and Type Class 描述
      class  SerializablePermission
      这个类用于Serializable权限。

    • Uses of BasicPermission in java.lang

      Subclasses of BasicPermission in java.lang
      Modifier and Type Class 描述
      class  RuntimePermission
      此类用于运行时权限。

    • Uses of BasicPermission in java.lang.management

      Subclasses of BasicPermission in java.lang.management
      Modifier and Type Class 描述
      class  ManagementPermission
      当SecurityManager运行的代码调用在Java平台的管理界面中定义的方法时，SecurityManager将检查的权限。

    • Uses of BasicPermission in java.lang.reflect

      Subclasses of BasicPermission in java.lang.reflect
      Modifier and Type Class 描述
      class  ReflectPermission
      反思操作的权限类。

    • Uses of BasicPermission in java.net

      Subclasses of BasicPermission in java.net
      Modifier and Type Class 描述
      class  NetPermission
      此类用于各种网络权限。

    • Uses of BasicPermission in java.nio.file

      Subclasses of BasicPermission in java.nio.file
      Modifier and Type Class 描述
      class  LinkPermission
      Permission类链接创建操作。

    • Uses of BasicPermission in java.security

      Subclasses of BasicPermission in java.security
      Modifier and Type Class 描述
      class  SecurityPermission
      此类用于安全权限。

    • Uses of BasicPermission in java.sql

      Subclasses of BasicPermission in java.sql
      Modifier and Type Class 描述
      class  SQLPermission
      SecurityManager将在运行启用了 SecurityManager的应用程序的代码时检查的权限，调用 DriverManager.deregisterDriver方法， DriverManager.setLogWriter方法， DriverManager.setLogStream （弃用）方法， SyncFactory.setJNDIContext方法， SyncFactory.setLogger方法， Connection.setNetworkTimeout方法或 Connection.abort方法。

    • Uses of BasicPermission in java.util

      Subclasses of BasicPermission in java.util
      Modifier and Type Class 描述
      class  PropertyPermission
      此类用于属性权限。

    • Uses of BasicPermission in java.util.logging

      Subclasses of BasicPermission in java.util.logging
      Modifier and Type Class 描述
      class  LoggingPermission
      当SecurityManager运行的代码调用其中一个日志控件方法（如Logger.setLevel）时，SecurityManager将检查该权限。

    • Uses of BasicPermission in javafx.util

      Subclasses of BasicPermission in javafx.util
      Modifier and Type Class 描述
      class  FXPermission
      此类用于JavaFX权限。

    • Uses of BasicPermission in javax.management

      Subclasses of BasicPermission in javax.management
      Modifier and Type Class 描述
      class  MBeanServerPermission
      A执行与MBeanServers有关的操作的权限。
      class  MBeanTrustPermission
      此权限在签名者或代码库中表示“信任”。

    • Uses of BasicPermission in javax.management.remote

      Subclasses of BasicPermission in javax.management.remote
      Modifier and Type Class 描述
      class  SubjectDelegationPermission
      认证身份所需的权限代表授权身份执行操作。

    • Uses of BasicPermission in javax.net.ssl

      Subclasses of BasicPermission in javax.net.ssl
      Modifier and Type Class 描述
      class  SSLPermission
      此类用于各种网络权限。

    • Uses of BasicPermission in javax.security.auth

      Subclasses of BasicPermission in javax.security.auth
      Modifier and Type Class 描述
      class  AuthPermission
      此类用于验证权限。

    • Uses of BasicPermission in javax.security.auth.kerberos

      Subclasses of BasicPermission in javax.security.auth.kerberos
      Modifier and Type Class 描述
      class  DelegationPermission
      此类用于限制Kerberos授权模型的使用，即：可转发和可预售的机票。

    • Uses of BasicPermission in javax.sound.sampled

      Subclasses of BasicPermission in javax.sound.sampled
      Modifier and Type Class 描述
      class  AudioPermission
      AudioPermission类表示对音频系统资源的访问权限。

    • Uses of BasicPermission in javax.xml.bind

      Subclasses of BasicPermission in javax.xml.bind
      Modifier and Type Class 描述
      class  JAXBPermission
      此类用于JAXB权限。

    • Uses of BasicPermission in javax.xml.ws

      Subclasses of BasicPermission in javax.xml.ws
      Modifier and Type Class 描述
      class  WebServicePermission
      此类定义Web服务权限。

    • Uses of BasicPermission in jdk.net

      Subclasses of BasicPermission in jdk.net
      Modifier and Type Class 描述
      class  NetworkPermission
      表示访问jdk.net包中定义的扩展网络功能的权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.CodeSigner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.CodeSigner

  • Packages that use CodeSigner
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of CodeSigner in java.security

      Methods in java.security that return CodeSigner
      Modifier and Type 方法 描述
      CodeSigner[] CodeSource.getCodeSigners​()
      返回与此CodeSource相关联的代码签名者。
      Constructors in java.security with parameters of type CodeSigner
      Constructor 描述
      CodeSource​(URL url, CodeSigner[] signers)
      构造CodeSource并将其与指定的位置和代码签名者集合相关联。

    • Uses of CodeSigner in java.util.jar

      Methods in java.util.jar that return CodeSigner
      Modifier and Type 方法 描述
      CodeSigner[] JarEntry.getCodeSigners​()
      返回 CodeSigner对象此条，或 null如果没有。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.CodeSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.CodeSource

  • Packages that use CodeSource
    软件包 描述
    com.sun.security.auth
    提供Principal的实现。
    java.net
    提供实现网络应用程序的类。
    java.security
    提供安全框架的类和接口。
    javax.security.auth
    此软件包提供了认证和授权的框架。

    • Uses of CodeSource in com.sun.security.auth

      Methods in com.sun.security.auth with parameters of type CodeSource
      Modifier and Type 方法 描述
      PermissionCollection PolicyFile.getPermissions​(Subject subject, CodeSource codesource)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      检查此 Policy并返回授予给指定的 Subject和 CodeSource的权限。

    • Uses of CodeSource in java.net

      Methods in java.net with parameters of type CodeSource
      Modifier and Type 方法 描述
      protected PermissionCollection URLClassLoader.getPermissions​(CodeSource codesource)
      返回给定的代码源对象的权限。

    • Uses of CodeSource in java.security

      Methods in java.security that return CodeSource
      Modifier and Type 方法 描述
      CodeSource ProtectionDomain.getCodeSource​()
      返回此域的CodeSource。
      Methods in java.security with parameters of type CodeSource
      Modifier and Type 方法 描述
      protected Class<?> SecureClassLoader.defineClass​(String name, byte[] b, int off, int len, CodeSource cs)
      将字节数组转换为类Class的实例，并具有可选的CodeSource。
      protected Class<?> SecureClassLoader.defineClass​(String name, ByteBuffer b, CodeSource cs)
      一个转换ByteBuffer成类的实例Class ，使用可选的CodeSource。
      protected PermissionCollection PolicySpi.engineGetPermissions​(CodeSource codesource)
      返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。
      PermissionCollection Policy.getPermissions​(CodeSource codesource)
      返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。
      protected PermissionCollection SecureClassLoader.getPermissions​(CodeSource codesource)
      返回给定CodeSource对象的权限。
      boolean CodeSource.implies​(CodeSource codesource)
      如果此CodeSource对象“暗示”指定的CodeSource，则返回true。
      Constructors in java.security with parameters of type CodeSource
      Constructor 描述
      ProtectionDomain​(CodeSource codesource, PermissionCollection permissions)
      使用给定的CodeSource和权限创建一个新的ProtectionDomain。
      ProtectionDomain​(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
      创建一个由给定的CodeSource，Permissions，ClassLoader和Principals数组限定的新的ProtectionDomain。

    • Uses of CodeSource in javax.security.auth

      Methods in javax.security.auth with parameters of type CodeSource
      Modifier and Type 方法 描述
      abstract PermissionCollection Policy.getPermissions​(Subject subject, CodeSource cs)
      已过时。
      检索授予与指定的 CodeSource相关的校长的权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.CryptoPrimitive (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.CryptoPrimitive

  • Packages that use CryptoPrimitive
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of CryptoPrimitive in java.security

      Methods in java.security that return CryptoPrimitive
      Modifier and Type 方法 描述
      static CryptoPrimitive CryptoPrimitive.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CryptoPrimitive[] CryptoPrimitive.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Method parameters in java.security with type arguments of type CryptoPrimitive
      Modifier and Type 方法 描述
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, String algorithm, AlgorithmParameters parameters)
      确定是否为算法授予了指定的加密原语的权限。
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, String algorithm, Key key, AlgorithmParameters parameters)
      确定算法和相应的密钥是否被授予对指定的加密原语的许可。
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, Key key)
      确定一个密钥是否被授予了指定的加密原语的权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.DigestException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.DigestException

  • Packages that use DigestException
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of DigestException in java.security

      Methods in java.security that throw DigestException
      Modifier and Type 方法 描述
      int MessageDigest.digest​(byte[] buf, int offset, int len)
      通过执行最后的操作（如填充）来完成哈希计算。
      protected int MessageDigestSpi.engineDigest​(byte[] buf, int offset, int len)
      通过执行最后的操作（如填充）来完成哈希计算。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.DigestInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.DigestInputStream

No usage of java.security.DigestInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.DigestOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.DigestOutputStream

No usage of java.security.DigestOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.DomainLoadStoreParameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.DomainLoadStoreParameter

No usage of java.security.DomainLoadStoreParameter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.DrbgParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.DrbgParameters

No usage of java.security.DrbgParameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.DrbgParameters.Capability (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.DrbgParameters.Capability

  • Packages that use DrbgParameters.Capability
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of DrbgParameters.Capability in java.security

      Methods in java.security that return DrbgParameters.Capability
      Modifier and Type 方法 描述
      DrbgParameters.Capability DrbgParameters.Instantiation.getCapability​()
      返回能力。
      static DrbgParameters.Capability DrbgParameters.Capability.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DrbgParameters.Capability[] DrbgParameters.Capability.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.security with parameters of type DrbgParameters.Capability
      Modifier and Type 方法 描述
      static DrbgParameters.Instantiation DrbgParameters.instantiation​(int strength, DrbgParameters.Capability capability, byte[] personalizationString)
      生成一个DrbgParameters.Instantiation对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.DrbgParameters.Instantiation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.DrbgParameters.Instantiation

  • Packages that use DrbgParameters.Instantiation
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of DrbgParameters.Instantiation in java.security

      Methods in java.security that return DrbgParameters.Instantiation
      Modifier and Type 方法 描述
      static DrbgParameters.Instantiation DrbgParameters.instantiation​(int strength, DrbgParameters.Capability capability, byte[] personalizationString)
      生成一个DrbgParameters.Instantiation对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.DrbgParameters.NextBytes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.DrbgParameters.NextBytes

  • Packages that use DrbgParameters.NextBytes
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of DrbgParameters.NextBytes in java.security

      Methods in java.security that return DrbgParameters.NextBytes
      Modifier and Type 方法 描述
      static DrbgParameters.NextBytes DrbgParameters.nextBytes​(int strength, boolean predictionResistance, byte[] additionalInput)
      生成一个DrbgParameters.NextBytes对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.DrbgParameters.Reseed (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.DrbgParameters.Reseed

  • Packages that use DrbgParameters.Reseed
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of DrbgParameters.Reseed in java.security

      Methods in java.security that return DrbgParameters.Reseed
      Modifier and Type 方法 描述
      static DrbgParameters.Reseed DrbgParameters.reseed​(boolean predictionResistance, byte[] additionalInput)
      生成一个DrbgParameters.Reseed对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.GeneralSecurityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.GeneralSecurityException

  • Packages that use GeneralSecurityException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。

    • Uses of GeneralSecurityException in java.security

      Subclasses of GeneralSecurityException in java.security
      Modifier and Type Class 描述
      class  DigestException
      这是通用的消息摘要异常。
      class  InvalidAlgorithmParameterException
      这是无效或不合适的算法参数的例外。
      class  InvalidKeyException
      这是无效键（无效编码，长度错误，未初始化等）的例外。
      class  KeyException
      这是基本的关键例外。
      class  KeyManagementException
      这是处理密钥管理的所有操作的一般密钥管理例外。
      class  KeyStoreException
      这是通用的KeyStore异常。
      class  NoSuchAlgorithmException
      当请求特定的加密算法但在环境中不可用时抛出此异常。
      class  NoSuchProviderException
      当特定安全提供程序被请求但在环境中不可用时抛出此异常。
      class  SignatureException
      这是一般的签名异常。
      class  UnrecoverableEntryException
      如果密钥库中的条目无法恢复，则抛出此异常。
      class  UnrecoverableKeyException
      如果密钥存储库中的密钥无法恢复，则抛出此异常。

    • Uses of GeneralSecurityException in java.security.cert

      Subclasses of GeneralSecurityException in java.security.cert
      Modifier and Type Class 描述
      class  CertificateEncodingException
      证书编码异常。
      class  CertificateException
      此异常表示各种证书问题之一。
      class  CertificateExpiredException
      证书过期例外
      class  CertificateNotYetValidException
      证书还没有有效的例外。
      class  CertificateParsingException
      证书解析异常。
      class  CertificateRevokedException
      表示X.509证书的异常被撤销。
      class  CertPathBuilderException
      一个例外，指出使用 CertPathBuilder构建认证路径时遇到的各种问题 CertPathBuilder 。
      class  CertPathValidatorException
      表示验证认证路径时遇到的各种问题之一的异常。
      class  CertStoreException
      一个例外，指出从 CertStore检索证书和CRL的各种问题 CertStore 。
      class  CRLException
      CRL（证书撤销列表）异常。

    • Uses of GeneralSecurityException in java.security.spec

      Subclasses of GeneralSecurityException in java.security.spec
      Modifier and Type Class 描述
      class  InvalidKeySpecException
      这是无效密钥规范的例外。
      class  InvalidParameterSpecException
      这是无效参数规范的例外。

    • Uses of GeneralSecurityException in javax.crypto

      Subclasses of GeneralSecurityException in javax.crypto
      Modifier and Type Class 描述
      class  AEADBadTagException
      当以AEAD模式运行的Cipher （如GCM / CCM）无法验证提供的认证标签时，会抛出此异常。
      class  BadPaddingException
      当期望输入数据的特定填充机制但数据未正确填充时，会抛出此异常。
      class  ExemptionMechanismException
      这是通用的ExemptionMechanism异常。
      class  IllegalBlockSizeException
      当提供给块密码的数据长度不正确时，抛出此异常，即与密码的块大小不匹配。
      class  NoSuchPaddingException
      当请求特定的填充机制但在环境中不可用时抛出此异常。
      class  ShortBufferException
      当用户提供的输出缓冲区太短而不能保存操作结果时，抛出此异常。

    • Uses of GeneralSecurityException in javax.security.auth.login

      Subclasses of GeneralSecurityException in javax.security.auth.login
      Modifier and Type Class 描述
      class  AccountException
      通用帐户异常。
      class  AccountExpiredException
      表示用户帐户已过期。
      class  AccountLockedException
      指示帐户被锁定。
      class  AccountNotFoundException
      表示找不到帐户。
      class  CredentialException
      通用凭证异常。
      class  CredentialExpiredException
      表示 Credential已过期。
      class  CredentialNotFoundException
      表示没有找到凭据。
      class  FailedLoginException
      表示用户身份验证失败。
      class  LoginException
      This is the basic login exception.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.GuardedObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.GuardedObject

No usage of java.security.GuardedObject
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Identity (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Identity

  • Packages that use Identity
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of Identity in java.security

      Subclasses of Identity in java.security
      Modifier and Type Class 描述
      class  IdentityScope
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      class  Signer
      已过时。
      此类不再使用。 其功能已被java.security.KeyStore替代， java.security.cert包，以及java.security.Principal 。
      Methods in java.security that return Identity
      Modifier and Type 方法 描述
      abstract Identity IdentityScope.getIdentity​(String name)
      已过时。
      以指定的名称（如果有）返回此范围中的身份。
      Identity IdentityScope.getIdentity​(Principal principal)
      已过时。
      检索其名称与指定的主体相同的身份。
      abstract Identity IdentityScope.getIdentity​(PublicKey key)
      已过时。
      使用指定的公钥检索身份。
      Methods in java.security that return types with arguments of type Identity
      Modifier and Type 方法 描述
      abstract Enumeration<Identity> IdentityScope.identities​()
      已过时。
      返回此身份范围内所有身份的枚举。
      Methods in java.security with parameters of type Identity
      Modifier and Type 方法 描述
      abstract void IdentityScope.addIdentity​(Identity identity)
      已过时。
      向此身份范围添加身份。
      protected boolean Identity.identityEquals​(Identity identity)
      已过时。
      测试指定身份与此身份之间的相等性。
      abstract void IdentityScope.removeIdentity​(Identity identity)
      已过时。
      Removes an identity from this identity scope.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.IdentityScope (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.IdentityScope

  • Packages that use IdentityScope
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of IdentityScope in java.security

      Methods in java.security that return IdentityScope
      Modifier and Type 方法 描述
      IdentityScope Identity.getScope​()
      已过时。
      返回此身份的范围。
      static IdentityScope IdentityScope.getSystemScope​()
      已过时。
      返回系统的身份范围。
      Methods in java.security with parameters of type IdentityScope
      Modifier and Type 方法 描述
      protected static void IdentityScope.setSystemScope​(IdentityScope scope)
      已过时。
      设置系统的身份范围。
      Constructors in java.security with parameters of type IdentityScope
      Constructor 描述
      Identity​(String name, IdentityScope scope)
      已过时。
      构造具有指定名称和范围的身份。
      IdentityScope​(String name, IdentityScope scope)
      已过时。
      构造具有指定名称和范围的新的身份范围。
      Signer​(String name, IdentityScope scope)
      已过时。
      Creates a signer with the specified identity name and scope.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.InvalidAlgorithmParameterException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.InvalidAlgorithmParameterException

  • Packages that use InvalidAlgorithmParameterException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。

    • Uses of InvalidAlgorithmParameterException in java.security

      Methods in java.security that throw InvalidAlgorithmParameterException
      Modifier and Type 方法 描述
      protected abstract void AlgorithmParameterGeneratorSpi.engineInit​(AlgorithmParameterSpec genParamSpec, SecureRandom random)
      使用一组特定于算法的参数生成值初始化此参数生成器。
      protected void SignatureSpi.engineSetParameter​(AlgorithmParameterSpec params)
      提供者将覆盖此方法以使用指定的参数集来初始化此签名引擎。
      void AlgorithmParameterGenerator.init​(AlgorithmParameterSpec genParamSpec)
      使用一组特定于算法的参数生成值初始化此参数生成器。
      void AlgorithmParameterGenerator.init​(AlgorithmParameterSpec genParamSpec, SecureRandom random)
      使用一组特定于算法的参数生成值初始化此参数生成器。
      void KeyPairGenerator.initialize​(AlgorithmParameterSpec params)
      使用指定的参数集初始化密钥对生成器，并将最高优先级的安装提供程序的 SecureRandom实现作为随机源。
      void KeyPairGenerator.initialize​(AlgorithmParameterSpec params, SecureRandom random)
      使用给定的参数集和随机源初始化密钥对生成器。
      void KeyPairGeneratorSpi.initialize​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化密钥对生成器。
      void Signature.setParameter​(AlgorithmParameterSpec params)
      使用指定的参数集初始化此签名引擎。

    • Uses of InvalidAlgorithmParameterException in java.security.cert

      Methods in java.security.cert that throw InvalidAlgorithmParameterException
      Modifier and Type 方法 描述
      CertPathBuilderResult CertPathBuilder.build​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
      abstract CertPathBuilderResult CertPathBuilderSpi.engineBuild​(CertPathParameters params)
      尝试使用指定的算法参数集构建认证路径。
      abstract CertPathValidatorResult CertPathValidatorSpi.engineValidate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params)
      返回实现指定的 CertStore类型的 CertStore对象，并使用指定的参数进行初始化。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, String provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, Provider provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      void PKIXParameters.setTrustAnchors​(Set<TrustAnchor> trustAnchors)
      设置 Set最受信任的CA。
      CertPathValidatorResult CertPathValidator.validate​(CertPath certPath, CertPathParameters params)
      使用指定的算法参数集验证指定的认证路径。
      Constructors in java.security.cert that throw InvalidAlgorithmParameterException
      Constructor 描述
      CertStoreSpi​(CertStoreParameters params)
      唯一的建设者。
      PKIXBuilderParameters​(KeyStore keystore, CertSelector targetConstraints)
      创建一个 PKIXBuilderParameters的实例，它从指定的 KeyStore包含的受信任证书条目中填充最受信任的CA KeyStore 。
      PKIXBuilderParameters​(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
      使用指定的 Set最受信任的CA创建一个 PKIXBuilderParameters的实例。
      PKIXParameters​(KeyStore keystore)
      创建一个 PKIXParameters的实例，它从指定的 KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。
      PKIXParameters​(Set<TrustAnchor> trustAnchors)
      使用指定的 Set最受信任的CA创建一个 PKIXParameters的实例。

    • Uses of InvalidAlgorithmParameterException in javax.crypto

      Methods in javax.crypto that throw InvalidAlgorithmParameterException
      Modifier and Type 方法 描述
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      protected abstract void KeyAgreementSpi.engineInit​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      protected abstract void KeyGeneratorSpi.engineInit​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化密钥生成器。
      protected abstract void MacSpi.engineInit​(Key key, AlgorithmParameterSpec params)
      用给定（秘密）密钥和算法参数初始化MAC。
      void Cipher.init​(int opmode, Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void ExemptionMechanism.init​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      void ExemptionMechanism.init​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      void KeyAgreement.init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数集初始化此密钥协议。
      void KeyAgreement.init​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      void KeyGenerator.init​(AlgorithmParameterSpec params)
      使用指定的参数集初始化此密钥生成器。
      void KeyGenerator.init​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化此密钥生成器。
      void Mac.init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数初始化此 Mac对象。

    • Uses of InvalidAlgorithmParameterException in javax.net.ssl

      Methods in javax.net.ssl that throw InvalidAlgorithmParameterException
      Modifier and Type 方法 描述
      protected abstract void KeyManagerFactorySpi.engineInit​(ManagerFactoryParameters spec)
      使用关键材料来源初始化该工厂。
      protected abstract void TrustManagerFactorySpi.engineInit​(ManagerFactoryParameters spec)
      使用提供商特定的密钥材料来源初始化该工厂。
      void KeyManagerFactory.init​(ManagerFactoryParameters spec)
      使用提供商特定的密钥材料来源初始化该工厂。
      void TrustManagerFactory.init​(ManagerFactoryParameters spec)
      使用提供商特定的信任资料来源初始化该工厂。

    • Uses of InvalidAlgorithmParameterException in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that throw InvalidAlgorithmParameterException
      Modifier and Type 方法 描述
      abstract void TransformService.init​(TransformParameterSpec params)
      使用指定的参数初始化此 TransformService 。
      abstract void TransformService.init​(XMLStructure parent, XMLCryptoContext context)
      使用指定的参数和文档上下文初始化此 TransformService 。
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod​(String algorithm, C14NMethodParameterSpec params)
      为指定的算法URI和参数创建一个 CanonicalizationMethod 。
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod​(String algorithm, XMLStructure params)
      为指定的算法URI和参数创建一个 CanonicalizationMethod 。
      abstract DigestMethod XMLSignatureFactory.newDigestMethod​(String algorithm, DigestMethodParameterSpec params)
      为指定的算法URI和参数创建一个 DigestMethod 。
      abstract SignatureMethod XMLSignatureFactory.newSignatureMethod​(String algorithm, SignatureMethodParameterSpec params)
      为指定的算法URI和参数创建一个 SignatureMethod 。
      abstract Transform XMLSignatureFactory.newTransform​(String algorithm, TransformParameterSpec params)
      为指定的算法URI和参数创建一个 Transform 。
      abstract Transform XMLSignatureFactory.newTransform​(String algorithm, XMLStructure params)
      为指定的算法URI和参数创建一个 Transform 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.InvalidKeyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.InvalidKeyException

  • Packages that use InvalidKeyException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.security.cert
    提供公钥证书类。

    • Uses of InvalidKeyException in java.security

      Methods in java.security that throw InvalidKeyException
      Modifier and Type 方法 描述
      protected abstract void SignatureSpi.engineInitSign​(PrivateKey privateKey)
      使用指定的私钥初始化此签名对象进行签名操作。
      protected void SignatureSpi.engineInitSign​(PrivateKey privateKey, SecureRandom random)
      使用指定的私钥和签名操作的随机源初始化此签名对象。
      protected abstract void SignatureSpi.engineInitVerify​(PublicKey publicKey)
      使用指定的公钥初始化此签名对象进行验证操作。
      protected abstract Key KeyFactorySpi.engineTranslateKey​(Key key)
      将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。
      void Signature.initSign​(PrivateKey privateKey)
      初始化此对象进行签名。
      void Signature.initSign​(PrivateKey privateKey, SecureRandom random)
      初始化此对象进行签名。
      void Signature.initVerify​(Certificate certificate)
      使用给定证书中的公钥初始化此对象进行验证。
      void Signature.initVerify​(PublicKey publicKey)
      初始化此对象进行验证。
      Key KeyFactory.translateKey​(Key key)
      将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。
      boolean SignedObject.verify​(PublicKey verificationKey, Signature verificationEngine)
      验证此SignedObject中的签名是使用指定的验证引擎使用给定的验证密钥存储在其中的对象的有效签名。
      Constructors in java.security that throw InvalidKeyException
      Constructor 描述
      SignedObject​(Serializable object, PrivateKey signingKey, Signature signingEngine)
      从任何可序列化对象构造一个SignedObject。

    • Uses of InvalidKeyException in java.security.cert

      Methods in java.security.cert that throw InvalidKeyException
      Modifier and Type 方法 描述
      abstract void Certificate.verify​(PublicKey key)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void X509Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void X509CRL.verify​(PublicKey key)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      abstract void X509CRL.verify​(PublicKey key, String sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      void X509CRL.verify​(PublicKey key, Provider sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。

    • Uses of InvalidKeyException in javax.crypto

      Methods in javax.crypto that throw InvalidKeyException
      Modifier and Type 方法 描述
      Key KeyAgreement.doPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      protected abstract Key KeyAgreementSpi.engineDoPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      protected abstract SecretKey KeyAgreementSpi.engineGenerateSecret​(String algorithm)
      创建共享密钥，并将其作为请求的算法类型的秘密密钥对象返回。
      protected int CipherSpi.engineGetKeySize​(Key key)
      以位为单位返回给定键对象的键大小。
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, SecureRandom random)
      用密钥和随机源初始化此密码。
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key)
      使用密钥初始化此豁免机制。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      protected abstract void KeyAgreementSpi.engineInit​(Key key, SecureRandom random)
      用给定的密钥和随机源初始化这个密钥协商。
      protected abstract void KeyAgreementSpi.engineInit​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      protected abstract void MacSpi.engineInit​(Key key, AlgorithmParameterSpec params)
      用给定（秘密）密钥和算法参数初始化MAC。
      protected abstract SecretKey SecretKeyFactorySpi.engineTranslateKey​(SecretKey key)
      将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。
      protected Key CipherSpi.engineUnwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
      打开以前包装的钥匙。
      protected byte[] CipherSpi.engineWrap​(Key key)
      包裹钥匙
      SecretKey KeyAgreement.generateSecret​(String algorithm)
      创建共享密钥，并将其作为指定算法的一个 SecretKey对象返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, String providerName)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, Provider provider)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      Object SealedObject.getObject​(Key key)
      检索原始（封装）对象。
      Object SealedObject.getObject​(Key key, String provider)
      检索原始（封装）对象。
      void Cipher.init​(int opmode, Certificate certificate)
      使用给定证书中的公钥初始化此密码。
      void Cipher.init​(int opmode, Certificate certificate, SecureRandom random)
      使用给定证书中的公钥和随机源初始化此密码。
      void Cipher.init​(int opmode, Key key)
      用密钥初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void Cipher.init​(int opmode, Key key, SecureRandom random)
      用密钥和随机源初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void ExemptionMechanism.init​(Key key)
      使用密钥初始化此豁免机制。
      void ExemptionMechanism.init​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      void ExemptionMechanism.init​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      void KeyAgreement.init​(Key key)
      使用给定的密钥初始化此密钥协议，该密钥需要包含此密钥协议所需的所有算法参数。
      void KeyAgreement.init​(Key key, SecureRandom random)
      用给定的密钥和随机源初始化这个密钥协商。
      void KeyAgreement.init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数集初始化此密钥协议。
      void KeyAgreement.init​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      void Mac.init​(Key key)
      使用给定的键初始化此 Mac对象。
      void Mac.init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数初始化此 Mac对象。
      SecretKey SecretKeyFactory.translateKey​(SecretKey key)
      将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。
      Key Cipher.unwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
      打开以前包装的钥匙。
      byte[] Cipher.wrap​(Key key)
      包裹钥匙

    • Uses of InvalidKeyException in javax.crypto.spec

      Methods in javax.crypto.spec that throw InvalidKeyException
      Modifier and Type 方法 描述
      static boolean DESedeKeySpec.isParityAdjusted​(byte[] key, int offset)
      检查给定的DES-EDE密钥是否从 offset开始进行奇偶校验。
      static boolean DESKeySpec.isParityAdjusted​(byte[] key, int offset)
      检查给定的DES密钥材料，从 offset开始，是奇偶校验调整的。
      static boolean DESKeySpec.isWeak​(byte[] key, int offset)
      检查给定的DES密钥材料是弱还是弱弱。
      Constructors in javax.crypto.spec that throw InvalidKeyException
      Constructor 描述
      DESedeKeySpec​(byte[] key)
      创建使用前24个字节在一个DESedeKeySpec对象， key作为DES-EDE密钥的密钥材料。
      DESedeKeySpec​(byte[] key, int offset)
      创建使用前24个字节在一个DESedeKeySpec对象， key ，在开始 offset以下，作为DES-EDE密钥的密钥材料。
      DESKeySpec​(byte[] key)
      创建使用前8个字节中一个DESKeySpec对象， key作为DES密钥的密钥材料。
      DESKeySpec​(byte[] key, int offset)
      创建使用前8个字节中一个DESKeySpec对象， key ，在开始 offset以下，作为DES密钥的密钥材料。

    • Uses of InvalidKeyException in javax.security.cert

      Methods in javax.security.cert that throw InvalidKeyException
      Modifier and Type 方法 描述
      abstract void Certificate.verify​(PublicKey key)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.InvalidParameterException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.InvalidParameterException

  • Packages that use InvalidParameterException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。

    • Uses of InvalidParameterException in java.security

      Methods in java.security that throw InvalidParameterException
      Modifier and Type 方法 描述
      protected abstract Object SignatureSpi.engineGetParameter​(String param)
      已过时。
      protected abstract void SignatureSpi.engineSetParameter​(String param, Object value)
      已过时。
      由engineSetParameter替代 。
      Object Signature.getParameter​(String param)
      已过时。
      void Signer.setKeyPair​(KeyPair pair)
      已过时。
      设置此签名者的密钥对（公钥和私钥）。
      void Signature.setParameter​(String param, Object value)
      已过时。
      使用setParameter 。

    • Uses of InvalidParameterException in java.security.interfaces

      Methods in java.security.interfaces that throw InvalidParameterException
      Modifier and Type 方法 描述
      void DSAKeyPairGenerator.initialize​(int modlen, boolean genParams, SecureRandom random)
      为给定的模数长度（而不是参数）初始化密钥对生成器以及可选的SecureRandom位源。
      void DSAKeyPairGenerator.initialize​(DSAParams params, SecureRandom random)
      使用DSA系列参数（p，q和g）和可选的SecureRandom位源初始化密钥对生成器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyException

  • Packages that use KeyException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.xml.crypto.dsig.keyinfo
    类用于解析和处理KeyInfo个元件和结构。

    • Uses of KeyException in java.security

      Subclasses of KeyException in java.security
      Modifier and Type Class 描述
      class  InvalidKeyException
      这是无效键（无效编码，长度错误，未初始化等）的例外。
      class  KeyManagementException
      这是处理密钥管理的所有操作的一般密钥管理例外。
      Methods in java.security that throw KeyException
      Modifier and Type 方法 描述
      void Certificate.decode​(InputStream stream)
      已过时。
      从输入流解码证书。
      void Certificate.encode​(OutputStream stream)
      已过时。
      将证书编码为可以通过 decode方法解码的格式的输出流。
      void Signer.setKeyPair​(KeyPair pair)
      已过时。
      设置此签名者的密钥对（公钥和私钥）。

    • Uses of KeyException in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that throw KeyException
      Modifier and Type 方法 描述
      PublicKey KeyValue.getPublicKey​()
      返回此 KeyValue 。
      abstract KeyValue KeyInfoFactory.newKeyValue​(PublicKey key)
      从指定的公钥中创建一个 KeyValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyFactory

  • Packages that use KeyFactory
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyFactory in java.security

      Methods in java.security that return KeyFactory
      Modifier and Type 方法 描述
      static KeyFactory KeyFactory.getInstance​(String algorithm)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      static KeyFactory KeyFactory.getInstance​(String algorithm, String provider)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      static KeyFactory KeyFactory.getInstance​(String algorithm, Provider provider)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyFactorySpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyFactorySpi

  • Packages that use KeyFactorySpi
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyFactorySpi in java.security

      Constructors in java.security with parameters of type KeyFactorySpi
      Constructor 描述
      KeyFactory​(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
      创建一个KeyFactory对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyManagementException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyManagementException

  • Packages that use KeyManagementException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of KeyManagementException in java.security

      Methods in java.security that throw KeyManagementException
      Modifier and Type 方法 描述
      void Identity.addCertificate​(Certificate certificate)
      已过时。
      为此身份添加证书。
      abstract void IdentityScope.addIdentity​(Identity identity)
      已过时。
      向此身份范围添加身份。
      void Identity.removeCertificate​(Certificate certificate)
      已过时。
      从此身份中删除证书。
      abstract void IdentityScope.removeIdentity​(Identity identity)
      已过时。
      从此身份范围中删除身份。
      void Identity.setPublicKey​(PublicKey key)
      已过时。
      设置此身份的公钥。
      Constructors in java.security that throw KeyManagementException
      Constructor 描述
      Identity​(String name, IdentityScope scope)
      已过时。
      构造具有指定名称和范围的身份。
      IdentityScope​(String name, IdentityScope scope)
      已过时。
      构造具有指定名称和范围的新的身份范围。
      Signer​(String name, IdentityScope scope)
      已过时。
      创建具有指定身份名称和范围的签名者。

    • Uses of KeyManagementException in javax.net.ssl

      Methods in javax.net.ssl that throw KeyManagementException
      Modifier and Type 方法 描述
      protected abstract void SSLContextSpi.engineInit​(KeyManager[] km, TrustManager[] tm, SecureRandom sr)
      初始化此上下文。
      void SSLContext.init​(KeyManager[] km, TrustManager[] tm, SecureRandom random)
      初始化此上下文。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyPair (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyPair

  • Packages that use KeyPair
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyPair in java.security

      Methods in java.security that return KeyPair
      Modifier and Type 方法 描述
      KeyPair KeyPairGenerator.generateKeyPair​()
      生成一个密钥对。
      abstract KeyPair KeyPairGeneratorSpi.generateKeyPair​()
      生成一个密钥对。
      KeyPair KeyPairGenerator.genKeyPair​()
      生成一个密钥对。
      Methods in java.security with parameters of type KeyPair
      Modifier and Type 方法 描述
      void Signer.setKeyPair​(KeyPair pair)
      已过时。
      设置此签名者的密钥对（公钥和私钥）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyPairGenerator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyPairGenerator

  • Packages that use KeyPairGenerator
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyPairGenerator in java.security

      Methods in java.security that return KeyPairGenerator
      Modifier and Type 方法 描述
      static KeyPairGenerator KeyPairGenerator.getInstance​(String algorithm)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      static KeyPairGenerator KeyPairGenerator.getInstance​(String algorithm, String provider)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      static KeyPairGenerator KeyPairGenerator.getInstance​(String algorithm, Provider provider)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyPairGeneratorSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyPairGeneratorSpi

  • Packages that use KeyPairGeneratorSpi
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyPairGeneratorSpi in java.security

      Subclasses of KeyPairGeneratorSpi in java.security
      Modifier and Type Class 描述
      class  KeyPairGenerator
      KeyPairGenerator类用于生成公钥和私钥对。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyRep (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyRep

No usage of java.security.KeyRep
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyRep.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyRep.Type

  • Packages that use KeyRep.Type
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyRep.Type in java.security

      Methods in java.security that return KeyRep.Type
      Modifier and Type 方法 描述
      static KeyRep.Type KeyRep.Type.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static KeyRep.Type[] KeyRep.Type.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in java.security with parameters of type KeyRep.Type
      Constructor 描述
      KeyRep​(KeyRep.Type type, String algorithm, String format, byte[] encoded)
      构造备用Key类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyStore

  • Packages that use KeyStore
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of KeyStore in java.security

      Methods in java.security that return KeyStore
      Modifier and Type 方法 描述
      static KeyStore KeyStore.getInstance​(File file, char[] password)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore KeyStore.getInstance​(File file, KeyStore.LoadStoreParameter param)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore KeyStore.getInstance​(String type)
      返回指定类型的密钥库对象。
      static KeyStore KeyStore.getInstance​(String type, String provider)
      返回指定类型的密钥库对象。
      static KeyStore KeyStore.getInstance​(String type, Provider provider)
      返回指定类型的密钥库对象。
      abstract KeyStore KeyStore.Builder.getKeyStore​()
      返回此对象描述的KeyStore。
      Methods in java.security with parameters of type KeyStore
      Modifier and Type 方法 描述
      static KeyStore.Builder KeyStore.Builder.newInstance​(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter)
      返回封装给定KeyStore的新Builder。

    • Uses of KeyStore in java.security.cert

      Constructors in java.security.cert with parameters of type KeyStore
      Constructor 描述
      PKIXBuilderParameters​(KeyStore keystore, CertSelector targetConstraints)
      创建一个 PKIXBuilderParameters的实例，它从指定的 KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。
      PKIXParameters​(KeyStore keystore)
      创建一个 PKIXParameters的实例，它从指定的 KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。

    • Uses of KeyStore in javax.net.ssl

      Methods in javax.net.ssl with parameters of type KeyStore
      Modifier and Type 方法 描述
      protected abstract void KeyManagerFactorySpi.engineInit​(KeyStore ks, char[] password)
      使用关键材料来源初始化该工厂。
      protected abstract void TrustManagerFactorySpi.engineInit​(KeyStore ks)
      使用证书颁发机构和相关信托资料来源初始化该工厂。
      void KeyManagerFactory.init​(KeyStore ks, char[] password)
      使用关键材料来源初始化该工厂。
      void TrustManagerFactory.init​(KeyStore ks)
      使用证书颁发机构和相关信托资料来源初始化该工厂。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyStore.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyStore.Builder

  • Packages that use KeyStore.Builder
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of KeyStore.Builder in java.security

      Methods in java.security that return KeyStore.Builder
      Modifier and Type 方法 描述
      static KeyStore.Builder KeyStore.Builder.newInstance​(File file, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder KeyStore.Builder.newInstance​(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder KeyStore.Builder.newInstance​(String type, Provider provider, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder KeyStore.Builder.newInstance​(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter)
      返回封装给定KeyStore的新Builder。

    • Uses of KeyStore.Builder in javax.net.ssl

      Methods in javax.net.ssl that return types with arguments of type KeyStore.Builder
      Modifier and Type 方法 描述
      List<KeyStore.Builder> KeyStoreBuilderParameters.getParameters​()
      返回此对象封装的KeyStore.Builder的不可修改列表。
      Constructors in javax.net.ssl with parameters of type KeyStore.Builder
      Constructor 描述
      KeyStoreBuilderParameters​(KeyStore.Builder builder)
      从指定的KeyStore.Builder构造新的KeyStoreBuilderParameters。
      Constructor parameters in javax.net.ssl with type arguments of type KeyStore.Builder
      Constructor 描述
      KeyStoreBuilderParameters​(List<KeyStore.Builder> parameters)
      从KeyStore.Builder的列表中构造新的KeyStoreBuilderParameters。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyStore.CallbackHandlerProtection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyStore.CallbackHandlerProtection

No usage of java.security.KeyStore.CallbackHandlerProtection
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyStore.PasswordProtection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyStore.PasswordProtection

No usage of java.security.KeyStore.PasswordProtection
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyStore.PrivateKeyEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyStore.PrivateKeyEntry

  • Packages that use KeyStore.PrivateKeyEntry
    软件包 描述
    jdk.security.jarsigner

    • Uses of KeyStore.PrivateKeyEntry in jdk.security.jarsigner

      Constructors in jdk.security.jarsigner with parameters of type KeyStore.PrivateKeyEntry
      Constructor 描述
      Builder​(KeyStore.PrivateKeyEntry entry)
      Creates a JarSigner.Builder object with a KeyStore.PrivateKeyEntry object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyStore.SecretKeyEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyStore.SecretKeyEntry

No usage of java.security.KeyStore.SecretKeyEntry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyStore.TrustedCertificateEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyStore.TrustedCertificateEntry

No usage of java.security.KeyStore.TrustedCertificateEntry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyStoreException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyStoreException

  • Packages that use KeyStoreException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of KeyStoreException in java.security

      Methods in java.security that throw KeyStoreException
      Modifier and Type 方法 描述
      Enumeration<String> KeyStore.aliases​()
      列出此密钥库的所有别名。
      boolean KeyStore.containsAlias​(String alias)
      检查此密钥库中是否存在给定的别名。
      void KeyStore.deleteEntry​(String alias)
      从此密钥库中删除由给定别名标识的条目。
      abstract void KeyStoreSpi.engineDeleteEntry​(String alias)
      从此密钥库中删除由给定别名标识的条目。
      KeyStore.Entry KeyStoreSpi.engineGetEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的 KeyStore.Entry 。
      abstract void KeyStoreSpi.engineSetCertificateEntry​(String alias, Certificate cert)
      将给定的证书分配给给定的别名。
      void KeyStoreSpi.engineSetEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
      在指定的别名下保存一个 KeyStore.Entry 。
      abstract void KeyStoreSpi.engineSetKeyEntry​(String alias, byte[] key, Certificate[] chain)
      将给定的密钥（已经被保护）分配给给定的别名。
      abstract void KeyStoreSpi.engineSetKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)
      将给定的密钥分配给给定的别名，并使用给定的密码进行保护。
      boolean KeyStore.entryInstanceOf​(String alias, Class<? extends KeyStore.Entry> entryClass)
      确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
      Certificate KeyStore.getCertificate​(String alias)
      返回与给定别名相关联的证书。
      String KeyStore.getCertificateAlias​(Certificate cert)
      返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。
      Certificate[] KeyStore.getCertificateChain​(String alias)
      返回与给定别名关联的证书链。
      Date KeyStore.getCreationDate​(String alias)
      返回由给定别名标识的条目的创建日期。
      KeyStore.Entry KeyStore.getEntry​(String alias, KeyStore.ProtectionParameter protParam)
      使用指定的保护参数获取指定别名的密钥库 Entry 。
      static KeyStore KeyStore.getInstance​(File file, char[] password)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore KeyStore.getInstance​(File file, KeyStore.LoadStoreParameter param)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore KeyStore.getInstance​(String type)
      返回指定类型的密钥库对象。
      static KeyStore KeyStore.getInstance​(String type, String provider)
      返回指定类型的密钥库对象。
      static KeyStore KeyStore.getInstance​(String type, Provider provider)
      返回指定类型的密钥库对象。
      Key KeyStore.getKey​(String alias, char[] password)
      返回与给定别名相关联的密钥，使用给定的密码恢复它。
      abstract KeyStore KeyStore.Builder.getKeyStore​()
      返回此对象描述的KeyStore。
      abstract KeyStore.ProtectionParameter KeyStore.Builder.getProtectionParameter​(String alias)
      返回应用于获取给定别名的Entry的ProtectionParameters。
      boolean KeyStore.isCertificateEntry​(String alias)
      如果由给定别名标识的条目是通过调用 setCertificateEntry创建的，或者通过调用 setEntry与 TrustedCertificateEntry创建的条目，则返回true。
      boolean KeyStore.isKeyEntry​(String alias)
      如果给定别名标识的条目是通过调用 setKeyEntry创建的，或者通过调用 setEntry与 PrivateKeyEntry或 SecretKeyEntry创建的条目，则返回true。
      void KeyStore.setCertificateEntry​(String alias, Certificate cert)
      将给定的可信证书分配给给定的别名。
      void KeyStore.setEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
      在指定的别名下保存密钥库 Entry 。
      void KeyStore.setKeyEntry​(String alias, byte[] key, Certificate[] chain)
      将给定的密钥（已经被保护）分配给给定的别名。
      void KeyStore.setKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)
      将给定的密钥分配给给定的别名，并使用给定的密码进行保护。
      int KeyStore.size​()
      检索此密钥库中的条目数。
      void KeyStore.store​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void KeyStore.store​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter存储此密钥库。

    • Uses of KeyStoreException in java.security.cert

      Constructors in java.security.cert that throw KeyStoreException
      Constructor 描述
      PKIXBuilderParameters​(KeyStore keystore, CertSelector targetConstraints)
      创建一个 PKIXBuilderParameters的实例，它从指定的 KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。
      PKIXParameters​(KeyStore keystore)
      创建一个 PKIXParameters的实例，它从指定的 KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。

    • Uses of KeyStoreException in javax.net.ssl

      Methods in javax.net.ssl that throw KeyStoreException
      Modifier and Type 方法 描述
      protected abstract void KeyManagerFactorySpi.engineInit​(KeyStore ks, char[] password)
      使用关键材料来源初始化该工厂。
      protected abstract void TrustManagerFactorySpi.engineInit​(KeyStore ks)
      使用证书颁发机构和相关信托资料来源初始化该工厂。
      void KeyManagerFactory.init​(KeyStore ks, char[] password)
      使用关键材料来源初始化该工厂。
      void TrustManagerFactory.init​(KeyStore ks)
      使用证书颁发机构和相关信托资料来源初始化该工厂。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.KeyStoreSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.KeyStoreSpi

  • Packages that use KeyStoreSpi
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyStoreSpi in java.security

      Constructors in java.security with parameters of type KeyStoreSpi
      Constructor 描述
      KeyStore​(KeyStoreSpi keyStoreSpi, Provider provider, String type)
      创建给定类型的KeyStore对象，并封装给定的提供者实现（SPI对象）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.MessageDigest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.MessageDigest

  • Packages that use MessageDigest
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of MessageDigest in java.security

      Fields in java.security declared as MessageDigest
      Modifier and Type Field 描述
      protected MessageDigest DigestInputStream.digest
      与此流相关联的消息摘要。
      protected MessageDigest DigestOutputStream.digest
      与此流相关联的消息摘要。
      Methods in java.security that return MessageDigest
      Modifier and Type 方法 描述
      static MessageDigest MessageDigest.getInstance​(String algorithm)
      返回实现指定摘要算法的MessageDigest对象。
      static MessageDigest MessageDigest.getInstance​(String algorithm, String provider)
      返回实现指定摘要算法的MessageDigest对象。
      static MessageDigest MessageDigest.getInstance​(String algorithm, Provider provider)
      返回实现指定摘要算法的MessageDigest对象。
      MessageDigest DigestInputStream.getMessageDigest​()
      返回与此流相关联的消息摘要。
      MessageDigest DigestOutputStream.getMessageDigest​()
      返回与此流相关联的消息摘要。
      Methods in java.security with parameters of type MessageDigest
      Modifier and Type 方法 描述
      void DigestInputStream.setMessageDigest​(MessageDigest digest)
      将指定的消息摘要与此流相关联。
      void DigestOutputStream.setMessageDigest​(MessageDigest digest)
      将指定的消息摘要与此流相关联。
      Constructors in java.security with parameters of type MessageDigest
      Constructor 描述
      DigestInputStream​(InputStream stream, MessageDigest digest)
      使用指定的输入流和消息摘要创建摘要输入流。
      DigestOutputStream​(OutputStream stream, MessageDigest digest)
      使用指定的输出流和消息摘要创建摘要输出流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.MessageDigestSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.MessageDigestSpi

  • Packages that use MessageDigestSpi
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of MessageDigestSpi in java.security

      Subclasses of MessageDigestSpi in java.security
      Modifier and Type Class 描述
      class  MessageDigest
      该MessageDigest类为应用程序提供消息摘要算法的功能，如SHA-1或SHA-256。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.NoSuchAlgorithmException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.NoSuchAlgorithmException

  • Packages that use NoSuchAlgorithmException
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.cert
    提供公钥证书类。
    javax.smartcardio
    Java™智能卡I / O API
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    jdk.security.jarsigner

    • Uses of NoSuchAlgorithmException in com.sun.jarsigner

      Methods in com.sun.jarsigner that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      abstract byte[] ContentSigner.generateSignedData​(ContentSignerParameters parameters, boolean omitContent, boolean applyTimestamp)
      已过时。
      生成PKCS＃7签名的数据消息。

    • Uses of NoSuchAlgorithmException in java.security

      Methods in java.security that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      KeyStore.Entry KeyStoreSpi.engineGetEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的 KeyStore.Entry 。
      abstract Key KeyStoreSpi.engineGetKey​(String alias, char[] password)
      返回与给定别名相关联的密钥，使用给定的密码恢复它。
      abstract void KeyStoreSpi.engineLoad​(InputStream stream, char[] password)
      从给定的输入流加载密钥库。
      void KeyStoreSpi.engineLoad​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParameter加载密钥库。
      abstract void KeyStoreSpi.engineStore​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void KeyStoreSpi.engineStore​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParmeter存储此密钥库。
      KeyStore.Entry KeyStore.getEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的密钥库 Entry 。
      static AlgorithmParameterGenerator AlgorithmParameterGenerator.getInstance​(String algorithm)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      static AlgorithmParameterGenerator AlgorithmParameterGenerator.getInstance​(String algorithm, String provider)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      static AlgorithmParameterGenerator AlgorithmParameterGenerator.getInstance​(String algorithm, Provider provider)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      static AlgorithmParameters AlgorithmParameters.getInstance​(String algorithm)
      返回指定算法的参数对象。
      static AlgorithmParameters AlgorithmParameters.getInstance​(String algorithm, String provider)
      返回指定算法的参数对象。
      static AlgorithmParameters AlgorithmParameters.getInstance​(String algorithm, Provider provider)
      返回指定算法的参数对象。
      static KeyFactory KeyFactory.getInstance​(String algorithm)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      static KeyFactory KeyFactory.getInstance​(String algorithm, String provider)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      static KeyFactory KeyFactory.getInstance​(String algorithm, Provider provider)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      static KeyPairGenerator KeyPairGenerator.getInstance​(String algorithm)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      static KeyPairGenerator KeyPairGenerator.getInstance​(String algorithm, String provider)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      static KeyPairGenerator KeyPairGenerator.getInstance​(String algorithm, Provider provider)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      static KeyStore KeyStore.getInstance​(File file, char[] password)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore KeyStore.getInstance​(File file, KeyStore.LoadStoreParameter param)
      返回相应密钥库类型的加载密钥库对象。
      static MessageDigest MessageDigest.getInstance​(String algorithm)
      返回实现指定摘要算法的MessageDigest对象。
      static MessageDigest MessageDigest.getInstance​(String algorithm, String provider)
      返回实现指定摘要算法的MessageDigest对象。
      static MessageDigest MessageDigest.getInstance​(String algorithm, Provider provider)
      返回实现指定摘要算法的MessageDigest对象。
      static Policy Policy.getInstance​(String type, Policy.Parameters params)
      返回指定类型的Policy对象。
      static Policy Policy.getInstance​(String type, Policy.Parameters params, String provider)
      返回指定类型的Policy对象。
      static Policy Policy.getInstance​(String type, Policy.Parameters params, Provider provider)
      返回指定类型的Policy对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, String provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, Provider provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, String provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, Provider provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static Signature Signature.getInstance​(String algorithm)
      返回实现指定签名算法的Signature对象。
      static Signature Signature.getInstance​(String algorithm, String provider)
      返回实现指定签名算法的Signature对象。
      static Signature Signature.getInstance​(String algorithm, Provider provider)
      返回实现指定签名算法的Signature对象。
      static SecureRandom SecureRandom.getInstanceStrong​()
      返回通过使用securerandom.strongAlgorithms Security属性中指定的算法/提供程序选择的SecureRandom对象。
      Key KeyStore.getKey​(String alias, char[] password)
      返回与给定别名相关联的密钥，使用给定的密码恢复它。
      void KeyStore.load​(InputStream stream, char[] password)
      从给定的输入流加载此KeyStore。
      void KeyStore.load​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter加载此密钥库。
      Object Provider.Service.newInstance​(Object constructorParameter)
      返回此服务描述的实现的新实例。
      void KeyStore.store​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void KeyStore.store​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter存储此密钥库。

    • Uses of NoSuchAlgorithmException in java.security.cert

      Methods in java.security.cert that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      static CertPathBuilder CertPathBuilder.getInstance​(String algorithm)
      返回实现指定算法的 CertPathBuilder对象。
      static CertPathBuilder CertPathBuilder.getInstance​(String algorithm, String provider)
      返回实现指定算法的 CertPathBuilder对象。
      static CertPathBuilder CertPathBuilder.getInstance​(String algorithm, Provider provider)
      返回实现指定算法的 CertPathBuilder对象。
      static CertPathValidator CertPathValidator.getInstance​(String algorithm)
      返回实现指定算法的 CertPathValidator对象。
      static CertPathValidator CertPathValidator.getInstance​(String algorithm, String provider)
      返回实现指定算法的 CertPathValidator对象。
      static CertPathValidator CertPathValidator.getInstance​(String algorithm, Provider provider)
      返回实现指定算法的 CertPathValidator对象。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params)
      返回实现指定的 CertStore类型的 CertStore对象，并使用指定的参数进行初始化。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, String provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, Provider provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      abstract void Certificate.verify​(PublicKey key)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void X509Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void X509CRL.verify​(PublicKey key)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      abstract void X509CRL.verify​(PublicKey key, String sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      void X509CRL.verify​(PublicKey key, Provider sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。

    • Uses of NoSuchAlgorithmException in javax.crypto

      Methods in javax.crypto that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      protected abstract SecretKey KeyAgreementSpi.engineGenerateSecret​(String algorithm)
      创建共享密钥，并将其作为请求的算法类型的秘密密钥对象返回。
      protected abstract void CipherSpi.engineSetMode​(String mode)
      设置此密码的模式。
      protected Key CipherSpi.engineUnwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
      打开以前包装的钥匙。
      SecretKey KeyAgreement.generateSecret​(String algorithm)
      创建共享密钥，并将其作为指定算法的 SecretKey对象返回。
      static Cipher Cipher.getInstance​(String transformation)
      返回实现指定转换的 Cipher对象。
      static Cipher Cipher.getInstance​(String transformation, String provider)
      返回实现指定转换的 Cipher对象。
      static Cipher Cipher.getInstance​(String transformation, Provider provider)
      返回实现指定转换的 Cipher对象。
      static ExemptionMechanism ExemptionMechanism.getInstance​(String algorithm)
      返回实现指定的免除机制算法的 ExemptionMechanism对象。
      static ExemptionMechanism ExemptionMechanism.getInstance​(String algorithm, String provider)
      返回实现指定的免除机制算法的 ExemptionMechanism对象。
      static ExemptionMechanism ExemptionMechanism.getInstance​(String algorithm, Provider provider)
      返回实现指定的免除机制算法的 ExemptionMechanism对象。
      static KeyAgreement KeyAgreement.getInstance​(String algorithm)
      返回实现指定的密钥协商算法的 KeyAgreement对象。
      static KeyAgreement KeyAgreement.getInstance​(String algorithm, String provider)
      返回一个 KeyAgreement对象，实现指定的密钥协商算法。
      static KeyAgreement KeyAgreement.getInstance​(String algorithm, Provider provider)
      返回实现指定的密钥协商算法的 KeyAgreement对象。
      static KeyGenerator KeyGenerator.getInstance​(String algorithm)
      返回一个产生指定算法的密钥的 KeyGenerator对象。
      static KeyGenerator KeyGenerator.getInstance​(String algorithm, String provider)
      返回产生指定算法的密钥的 KeyGenerator对象。
      static KeyGenerator KeyGenerator.getInstance​(String algorithm, Provider provider)
      返回一个产生指定算法的密钥的 KeyGenerator对象。
      static Mac Mac.getInstance​(String algorithm)
      返回实现指定MAC算法的 Mac对象。
      static Mac Mac.getInstance​(String algorithm, String provider)
      返回实现指定的MAC算法的 Mac对象。
      static Mac Mac.getInstance​(String algorithm, Provider provider)
      返回实现指定MAC算法的 Mac对象。
      static SecretKeyFactory SecretKeyFactory.getInstance​(String algorithm)
      返回一个转换指定算法的密钥的 SecretKeyFactory对象。
      static SecretKeyFactory SecretKeyFactory.getInstance​(String algorithm, String provider)
      返回一个转换指定算法的密钥的 SecretKeyFactory对象。
      static SecretKeyFactory SecretKeyFactory.getInstance​(String algorithm, Provider provider)
      返回一个转换指定算法的密钥的 SecretKeyFactory对象。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, String providerName)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, Provider provider)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      static int Cipher.getMaxAllowedKeyLength​(String transformation)
      根据已安装的JCE管辖区策略文件，返回指定转换的最大密钥长度。
      static AlgorithmParameterSpec Cipher.getMaxAllowedParameterSpec​(String transformation)
      返回一个AlgorithmParameterSpec对象，该对象包含根据管辖区策略文件的最大密码参数值。
      Object SealedObject.getObject​(Key key)
      检索原始（封装）对象。
      Object SealedObject.getObject​(Key key, String provider)
      检索原始（封装）对象。
      Key Cipher.unwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
      打开以前包装的钥匙。
      Constructors in javax.crypto that throw NoSuchAlgorithmException
      Constructor 描述
      EncryptedPrivateKeyInfo​(String algName, byte[] encryptedData)
      从加密算法名称和加密数据构造一个 EncryptedPrivateKeyInfo 。
      EncryptedPrivateKeyInfo​(AlgorithmParameters algParams, byte[] encryptedData)
      从加密算法参数和加密数据构建一个 EncryptedPrivateKeyInfo 。

    • Uses of NoSuchAlgorithmException in javax.net.ssl

      Methods in javax.net.ssl that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      protected abstract void KeyManagerFactorySpi.engineInit​(KeyStore ks, char[] password)
      使用关键材料来源初始化该工厂。
      static SSLContext SSLContext.getDefault​()
      返回默认的SSL上下文。
      static KeyManagerFactory KeyManagerFactory.getInstance​(String algorithm)
      返回一个 KeyManagerFactory对象，作为主要管理员的工厂。
      static KeyManagerFactory KeyManagerFactory.getInstance​(String algorithm, String provider)
      返回一个 KeyManagerFactory对象，作为主要管理员的工厂。
      static KeyManagerFactory KeyManagerFactory.getInstance​(String algorithm, Provider provider)
      返回一个 KeyManagerFactory对象，作为关键经理的工厂。
      static SSLContext SSLContext.getInstance​(String protocol)
      返回实现指定安全套接字协议的 SSLContext对象。
      static SSLContext SSLContext.getInstance​(String protocol, String provider)
      返回实现指定安全套接字协议的 SSLContext对象。
      static SSLContext SSLContext.getInstance​(String protocol, Provider provider)
      返回实现指定安全套接字协议的 SSLContext对象。
      static TrustManagerFactory TrustManagerFactory.getInstance​(String algorithm)
      返回一个作为信任管理器的工厂的 TrustManagerFactory对象。
      static TrustManagerFactory TrustManagerFactory.getInstance​(String algorithm, String provider)
      返回一个 TrustManagerFactory对象，作为信任管理器的工厂。
      static TrustManagerFactory TrustManagerFactory.getInstance​(String algorithm, Provider provider)
      返回一个作为信任管理器的工厂的 TrustManagerFactory对象。
      void KeyManagerFactory.init​(KeyStore ks, char[] password)
      使用关键材料来源初始化该工厂。

    • Uses of NoSuchAlgorithmException in javax.security.auth.login

      Methods in javax.security.auth.login that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      static Configuration Configuration.getInstance​(String type, Configuration.Parameters params)
      返回指定类型的Configuration对象。
      static Configuration Configuration.getInstance​(String type, Configuration.Parameters params, String provider)
      返回指定类型的Configuration对象。
      static Configuration Configuration.getInstance​(String type, Configuration.Parameters params, Provider provider)
      返回指定类型的Configuration对象。

    • Uses of NoSuchAlgorithmException in javax.security.cert

      Methods in javax.security.cert that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      abstract void Certificate.verify​(PublicKey key)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。

    • Uses of NoSuchAlgorithmException in javax.smartcardio

      Methods in javax.smartcardio that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      static TerminalFactory TerminalFactory.getInstance​(String type, Object params)
      返回使用指定参数初始化的指定类型的TerminalFactory。
      static TerminalFactory TerminalFactory.getInstance​(String type, Object params, String provider)
      返回使用指定参数初始化的指定类型的TerminalFactory。
      static TerminalFactory TerminalFactory.getInstance​(String type, Object params, Provider provider)
      返回使用指定参数初始化的指定类型的TerminalFactory。

    • Uses of NoSuchAlgorithmException in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      static TransformService TransformService.getInstance​(String algorithm, String mechanismType)
      返回一个 TransformService支持指定算法URI（例如： Transform.XPATH2 ）和机制类型（比如：DOM）。
      static TransformService TransformService.getInstance​(String algorithm, String mechanismType, String provider)
      返回一个 TransformService ，它支持由指定的提供者提供的指定的算法URI（例如： Transform.XPATH2 ）和机制类型（例如：DOM）。
      static TransformService TransformService.getInstance​(String algorithm, String mechanismType, Provider provider)
      返回一个 TransformService ，它支持指定的 TransformService程序提供的指定的算法URI（例如： Transform.XPATH2 ）和机制类型（例如：DOM）。
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod​(String algorithm, C14NMethodParameterSpec params)
      为指定的算法URI和参数创建一个 CanonicalizationMethod 。
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod​(String algorithm, XMLStructure params)
      为指定的算法URI和参数创建一个 CanonicalizationMethod 。
      abstract DigestMethod XMLSignatureFactory.newDigestMethod​(String algorithm, DigestMethodParameterSpec params)
      为指定的算法URI和参数创建一个 DigestMethod 。
      abstract SignatureMethod XMLSignatureFactory.newSignatureMethod​(String algorithm, SignatureMethodParameterSpec params)
      为指定的算法URI和参数创建一个 SignatureMethod 。
      abstract Transform XMLSignatureFactory.newTransform​(String algorithm, TransformParameterSpec params)
      为指定的算法URI和参数创建一个 Transform 。
      abstract Transform XMLSignatureFactory.newTransform​(String algorithm, XMLStructure params)
      为指定的算法URI和参数创建一个 Transform 。

    • Uses of NoSuchAlgorithmException in jdk.security.jarsigner

      Methods in jdk.security.jarsigner that throw NoSuchAlgorithmException
      Modifier and Type 方法 描述
      JarSigner.Builder JarSigner.Builder.digestAlgorithm​(String algorithm)
      设置摘要算法。
      JarSigner.Builder JarSigner.Builder.digestAlgorithm​(String algorithm, Provider provider)
      从指定的提供者设置摘要算法。
      JarSigner.Builder JarSigner.Builder.signatureAlgorithm​(String algorithm)
      设置签名算法。
      JarSigner.Builder JarSigner.Builder.signatureAlgorithm​(String algorithm, Provider provider)
      从指定的提供者设置签名算法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.NoSuchProviderException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.NoSuchProviderException

  • Packages that use NoSuchProviderException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.cert
    提供公钥证书类。
    javax.smartcardio
    Java™智能卡I / O API
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.crypto.dsig.keyinfo
    用于解析和处理KeyInfo元素和结构的类。

    • Uses of NoSuchProviderException in java.security

      Methods in java.security that throw NoSuchProviderException
      Modifier and Type 方法 描述
      static AlgorithmParameterGenerator AlgorithmParameterGenerator.getInstance​(String algorithm, String provider)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      static AlgorithmParameters AlgorithmParameters.getInstance​(String algorithm, String provider)
      返回指定算法的参数对象。
      static KeyFactory KeyFactory.getInstance​(String algorithm, String provider)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      static KeyPairGenerator KeyPairGenerator.getInstance​(String algorithm, String provider)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      static KeyStore KeyStore.getInstance​(String type, String provider)
      返回指定类型的密钥库对象。
      static MessageDigest MessageDigest.getInstance​(String algorithm, String provider)
      返回实现指定摘要算法的MessageDigest对象。
      static Policy Policy.getInstance​(String type, Policy.Parameters params, String provider)
      返回指定类型的Policy对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, String provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, String provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static Signature Signature.getInstance​(String algorithm, String provider)
      返回实现指定签名算法的Signature对象。

    • Uses of NoSuchProviderException in java.security.cert

      Methods in java.security.cert that throw NoSuchProviderException
      Modifier and Type 方法 描述
      static CertificateFactory CertificateFactory.getInstance​(String type, String provider)
      返回指定证书类型的证书工厂对象。
      static CertPathBuilder CertPathBuilder.getInstance​(String algorithm, String provider)
      返回实现指定算法的 CertPathBuilder对象。
      static CertPathValidator CertPathValidator.getInstance​(String algorithm, String provider)
      返回实现指定算法的 CertPathValidator对象。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, String provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      abstract void Certificate.verify​(PublicKey key)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void X509CRL.verify​(PublicKey key)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      abstract void X509CRL.verify​(PublicKey key, String sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。

    • Uses of NoSuchProviderException in javax.crypto

      Methods in javax.crypto that throw NoSuchProviderException
      Modifier and Type 方法 描述
      static Cipher Cipher.getInstance​(String transformation, String provider)
      返回实现指定转换的 Cipher对象。
      static ExemptionMechanism ExemptionMechanism.getInstance​(String algorithm, String provider)
      返回一个实现指定的免除机制算法的 ExemptionMechanism对象。
      static KeyAgreement KeyAgreement.getInstance​(String algorithm, String provider)
      返回实现指定的密钥协商算法的一个 KeyAgreement对象。
      static KeyGenerator KeyGenerator.getInstance​(String algorithm, String provider)
      返回一个产生指定算法的密钥的 KeyGenerator对象。
      static Mac Mac.getInstance​(String algorithm, String provider)
      返回实现指定MAC算法的 Mac对象。
      static SecretKeyFactory SecretKeyFactory.getInstance​(String algorithm, String provider)
      返回一个转换指定算法的密钥的 SecretKeyFactory对象。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, String providerName)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      Object SealedObject.getObject​(Key key, String provider)
      检索原始（封装）对象。

    • Uses of NoSuchProviderException in javax.net.ssl

      Methods in javax.net.ssl that throw NoSuchProviderException
      Modifier and Type 方法 描述
      static KeyManagerFactory KeyManagerFactory.getInstance​(String algorithm, String provider)
      返回一个 KeyManagerFactory对象，作为主要管理员的工厂。
      static SSLContext SSLContext.getInstance​(String protocol, String provider)
      返回实现指定的安全套接字协议的 SSLContext对象。
      static TrustManagerFactory TrustManagerFactory.getInstance​(String algorithm, String provider)
      返回一个作为信任管理器的工厂的 TrustManagerFactory对象。

    • Uses of NoSuchProviderException in javax.security.auth.login

      Methods in javax.security.auth.login that throw NoSuchProviderException
      Modifier and Type 方法 描述
      static Configuration Configuration.getInstance​(String type, Configuration.Parameters params, String provider)
      返回指定类型的Configuration对象。

    • Uses of NoSuchProviderException in javax.security.cert

      Methods in javax.security.cert that throw NoSuchProviderException
      Modifier and Type 方法 描述
      abstract void Certificate.verify​(PublicKey key)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。

    • Uses of NoSuchProviderException in javax.smartcardio

      Methods in javax.smartcardio that throw NoSuchProviderException
      Modifier and Type 方法 描述
      static TerminalFactory TerminalFactory.getInstance​(String type, Object params, String provider)
      返回使用指定参数初始化的指定类型的TerminalFactory。

    • Uses of NoSuchProviderException in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that throw NoSuchProviderException
      Modifier and Type 方法 描述
      static TransformService TransformService.getInstance​(String algorithm, String mechanismType, String provider)
      返回一个 TransformService支持指定算法URI（例如： Transform.XPATH2 ）和机制类型：由指定的提供者提供（例如，DOM）。
      static XMLSignatureFactory XMLSignatureFactory.getInstance​(String mechanismType, String provider)
      返回一个 XMLSignatureFactory ，它支持由指定的提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

    • Uses of NoSuchProviderException in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that throw NoSuchProviderException
      Modifier and Type 方法 描述
      static KeyInfoFactory KeyInfoFactory.getInstance​(String mechanismType, String provider)
      返回一个 KeyInfoFactory ，它支持由指定的提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Permission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Permission

  • Packages that use Permission
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.security.jgss
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.security
    提供安全框架的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    javafx.util
    包含各种实用程序和助手类。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of Permission in com.sun.jdi

      Subclasses of Permission in com.sun.jdi
      Modifier and Type Class 描述
      class  JDIPermission
      JDIPermission类代表对 VirtualMachineManager访问权限。

    • Uses of Permission in com.sun.security.jgss

      Subclasses of Permission in com.sun.security.jgss
      Modifier and Type Class 描述
      class  InquireSecContextPermission
      该类用于保护可以使用 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)方法访问的已建立的GSS安全上下文的各种属性。

    • Uses of Permission in com.sun.tools.attach

      Subclasses of Permission in com.sun.tools.attach
      Modifier and Type Class 描述
      class  AttachPermission
      当一个SecurityManager设置时，这是当代码调用VirtalMachine.attach附加到目标虚拟机时将被检查的权限。

    • Uses of Permission in java.awt

      Subclasses of Permission in java.awt
      Modifier and Type Class 描述
      class  AWTPermission
      此类用于AWT权限。

    • Uses of Permission in java.io

      Subclasses of Permission in java.io
      Modifier and Type Class 描述
      class  FilePermission
      此类表示访问文件或目录。
      class  SerializablePermission
      这个类用于Serializable权限。
      Methods in java.io with parameters of type Permission
      Modifier and Type 方法 描述
      boolean FilePermission.implies​(Permission p)
      检查此FilePermission对象是否“暗示”指定的权限。

    • Uses of Permission in java.lang

      Subclasses of Permission in java.lang
      Modifier and Type Class 描述
      class  RuntimePermission
      此类用于运行时权限。
      Methods in java.lang with parameters of type Permission
      Modifier and Type 方法 描述
      void SecurityManager.checkPermission​(Permission perm)
      如果根据当前有效的安全策略不允许指定的权限指定的请求访问，则抛出一个 SecurityException 。
      void SecurityManager.checkPermission​(Permission perm, Object context)
      如果指定的安全上下文被拒绝访问由给定权限指定的资源，则抛出一个 SecurityException 。

    • Uses of Permission in java.lang.management

      Subclasses of Permission in java.lang.management
      Modifier and Type Class 描述
      class  ManagementPermission
      当SecurityManager运行的代码调用在Java平台的管理界面中定义的方法时，SecurityManager将检查的权限。

    • Uses of Permission in java.lang.reflect

      Subclasses of Permission in java.lang.reflect
      Modifier and Type Class 描述
      class  ReflectPermission
      反思操作的权限类。

    • Uses of Permission in java.net

      Subclasses of Permission in java.net
      Modifier and Type Class 描述
      class  NetPermission
      此类用于各种网络权限。
      class  SocketPermission
      此类表示通过套接字访问网络。
      class  URLPermission
      表示访问由给定网址定义的资源或资源集的权限，以及给定的一组用户可设置的请求方法和请求标头。
      Methods in java.net that return Permission
      Modifier and Type 方法 描述
      Permission HttpURLConnection.getPermission​()
      返回表示连接到目标主机和端口所需的权限的SocketPermission对象。
      Permission URLConnection.getPermission​()
      返回一个权限对象，该对象表示创建此对象所表示的连接所需的权限。
      Methods in java.net with parameters of type Permission
      Modifier and Type 方法 描述
      boolean SocketPermission.implies​(Permission p)
      检查此套接字许可对象是否“暗示”指定的权限。
      boolean URLPermission.implies​(Permission p)
      检查此URLPermission是否意味着给定的权限。

    • Uses of Permission in java.nio.file

      Subclasses of Permission in java.nio.file
      Modifier and Type Class 描述
      class  LinkPermission
      Permission类的链接创建操作。

    • Uses of Permission in java.security

      Subclasses of Permission in java.security
      Modifier and Type Class 描述
      class  AllPermission
      AllPermission是一个隐含所有其他权限的权限。
      class  BasicPermission
      BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
      class  SecurityPermission
      此类用于安全权限。
      class  UnresolvedPermission
      UnresolvedPermission类用于保存初始化策略时“未解决”的权限。
      Methods in java.security that return Permission
      Modifier and Type 方法 描述
      Permission AccessControlException.getPermission​()
      获取与此异常关联的Permission对象，如果没有相应的Permission对象，则为null。
      Methods in java.security that return types with arguments of type Permission
      Modifier and Type 方法 描述
      abstract Enumeration<Permission> PermissionCollection.elements​()
      返回集合中所有Permission对象的枚举。
      Enumeration<Permission> Permissions.elements​()
      返回此Permissions对象中所有PermissionCollections中所有Permission对象的枚举。
      Stream<Permission> PermissionCollection.elementsAsStream​()
      返回集合中所有权限对象的流。
      Methods in java.security with parameters of type Permission
      Modifier and Type 方法 描述
      abstract void PermissionCollection.add​(Permission permission)
      将权限对象添加到当前权限对象集合。
      void Permissions.add​(Permission permission)
      将权限对象添加到权限所属的类的PermissionCollection。
      void AccessControlContext.checkPermission​(Permission perm)
      根据当前有效的安全策略以及此对象中的上下文确定是否允许或拒绝由指定权限指定的访问请求。
      static void AccessController.checkPermission​(Permission perm)
      根据当前的AccessControlContext和安全策略确定是否允许或拒绝由指定的权限指定的访问请求。
      static <T> T AccessController.doPrivileged​(PrivilegedAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedAction ，其特权被启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
      static <T> T AccessController.doPrivileged​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction具有启用并受指定的 AccessControlContext限制的权限，特权范围受指定的 Permission参数限制。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedAction具有启用并受指定的 AccessControlContext限制的特权，并且特权范围受指定的 Permission参数限制。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
      protected abstract boolean PolicySpi.engineImplies​(ProtectionDomain domain, Permission permission)
      检查策略是否授予了ProtectionDomain的权限。
      boolean AllPermission.implies​(Permission p)
      检查指定的权限是否被该对象“隐含”。
      boolean BasicPermission.implies​(Permission p)
      检查指定的权限是否被该对象“隐含”。
      abstract boolean Permission.implies​(Permission permission)
      检查指定权限的操作是否由此对象的操作“隐含”。
      abstract boolean PermissionCollection.implies​(Permission permission)
      检查此PermissionCollection中持有的Permission对象的集合是否暗示了指定的权限。
      boolean Permissions.implies​(Permission permission)
      检查此对象的PermissionCollection是否具有指定权限类的权限，这意味着在 权限对象中表达的 权限 。
      boolean Policy.implies​(ProtectionDomain domain, Permission permission)
      评估授予ProtectionDomain的权限的全局策略，并测试是否授予权限。
      boolean ProtectionDomain.implies​(Permission perm)
      检查并看看ProtectionDomain是否隐含在Permission对象中表达的权限。
      boolean UnresolvedPermission.implies​(Permission p)
      对于未解决的权限，此方法总是返回false。
      Constructors in java.security with parameters of type Permission
      Constructor 描述
      AccessControlException​(String s, Permission p)
      构造具有指定的详细消息的 AccessControlException以及引起异常的请求权限。

    • Uses of Permission in java.sql

      Subclasses of Permission in java.sql
      Modifier and Type Class 描述
      class  SQLPermission
      的量，许可 SecurityManager将检查当运行用的应用程序代码 SecurityManager启用，调用 DriverManager.deregisterDriver方法， DriverManager.setLogWriter方法， DriverManager.setLogStream （不建议使用）方法， SyncFactory.setJNDIContext方法， SyncFactory.setLogger方法， Connection.setNetworkTimeout方法或 Connection.abort方法。

    • Uses of Permission in java.util

      Subclasses of Permission in java.util
      Modifier and Type Class 描述
      class  PropertyPermission
      此类用于属性权限。
      Methods in java.util with parameters of type Permission
      Modifier and Type 方法 描述
      boolean PropertyPermission.implies​(Permission p)
      检查此PropertyPermission对象是否“暗示”指定的权限。

    • Uses of Permission in java.util.logging

      Subclasses of Permission in java.util.logging
      Modifier and Type Class 描述
      class  LoggingPermission
      当SecurityManager运行的代码调用其中一个日志控件方法（如Logger.setLevel）时，SecurityManager将检查该权限。

    • Uses of Permission in javafx.util

      Subclasses of Permission in javafx.util
      Modifier and Type Class 描述
      class  FXPermission
      此类用于JavaFX权限。

    • Uses of Permission in javax.management

      Subclasses of Permission in javax.management
      Modifier and Type Class 描述
      class  MBeanPermission
      控制访问MBeanServer操作的权限。
      class  MBeanServerPermission
      A执行与MBeanServers有关的操作的权限。
      class  MBeanTrustPermission
      此权限在签名者或代码库中表示“信任”。
      Methods in javax.management with parameters of type Permission
      Modifier and Type 方法 描述
      boolean MBeanPermission.implies​(Permission p)
      检查这个MBeanPermission对象是否“暗示”指定的权限。
      boolean MBeanServerPermission.implies​(Permission p)
      检查此MBeanServerPermission对象是否“暗示”指定的权限。

    • Uses of Permission in javax.management.remote

      Subclasses of Permission in javax.management.remote
      Modifier and Type Class 描述
      class  SubjectDelegationPermission
      认证身份所需的权限代表授权身份执行操作。

    • Uses of Permission in javax.net.ssl

      Subclasses of Permission in javax.net.ssl
      Modifier and Type Class 描述
      class  SSLPermission
      此类用于各种网络权限。

    • Uses of Permission in javax.security.auth

      Subclasses of Permission in javax.security.auth
      Modifier and Type Class 描述
      class  AuthPermission
      此类用于验证权限。
      class  PrivateCredentialPermission
      此类用于保护对属于特定 Subject私有凭据的访问。
      Methods in javax.security.auth with parameters of type Permission
      Modifier and Type 方法 描述
      boolean PrivateCredentialPermission.implies​(Permission p)
      检查这个 PrivateCredentialPermission意味着指定的 Permission 。

    • Uses of Permission in javax.security.auth.kerberos

      Subclasses of Permission in javax.security.auth.kerberos
      Modifier and Type Class 描述
      class  DelegationPermission
      此类用于限制Kerberos授权模型的使用，即：可转发和可预售的机票。
      class  ServicePermission
      此类用于保护Kerberos服务和访问这些服务所必需的凭据。
      Methods in javax.security.auth.kerberos with parameters of type Permission
      Modifier and Type 方法 描述
      boolean DelegationPermission.implies​(Permission p)
      检查此Kerberos委托许可对象是否“暗示”指定的权限。
      boolean ServicePermission.implies​(Permission p)
      检查此Kerberos服务权限对象是否“暗示”指定的权限。

    • Uses of Permission in javax.smartcardio

      Subclasses of Permission in javax.smartcardio
      Modifier and Type Class 描述
      class  CardPermission
      智能卡操作的许可。
      Methods in javax.smartcardio with parameters of type Permission
      Modifier and Type 方法 描述
      boolean CardPermission.implies​(Permission permission)
      检查此CardPermission对象是否意味着指定的权限。

    • Uses of Permission in javax.sound.sampled

      Subclasses of Permission in javax.sound.sampled
      Modifier and Type Class 描述
      class  AudioPermission
      AudioPermission类代表对音频系统资源的访问权限。

    • Uses of Permission in javax.xml.bind

      Subclasses of Permission in javax.xml.bind
      Modifier and Type Class 描述
      class  JAXBPermission
      此类用于JAXB权限。

    • Uses of Permission in javax.xml.ws

      Subclasses of Permission in javax.xml.ws
      Modifier and Type Class 描述
      class  WebServicePermission
      此类定义Web服务权限。

    • Uses of Permission in jdk.net

      Subclasses of Permission in jdk.net
      Modifier and Type Class 描述
      class  NetworkPermission
      表示访问jdk.net包中定义的扩展网络功能的权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.PermissionCollection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.PermissionCollection

  • Packages that use PermissionCollection
    软件包 描述
    com.sun.security.auth
    提供Principal的实现。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.net
    提供实现网络应用程序的类。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.management
    提供Java管理扩展的核心类。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。

    • Uses of PermissionCollection in com.sun.security.auth

      Methods in com.sun.security.auth that return PermissionCollection
      Modifier and Type 方法 描述
      PermissionCollection PolicyFile.getPermissions​(Subject subject, CodeSource codesource)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      检查此 Policy并返回授予指定的 Subject和 CodeSource的权限。

    • Uses of PermissionCollection in java.io

      Methods in java.io that return PermissionCollection
      Modifier and Type 方法 描述
      PermissionCollection FilePermission.newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储FilePermission对象。

    • Uses of PermissionCollection in java.net

      Methods in java.net that return PermissionCollection
      Modifier and Type 方法 描述
      protected PermissionCollection URLClassLoader.getPermissions​(CodeSource codesource)
      返回给定的代码源对象的权限。
      PermissionCollection SocketPermission.newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储SocketPermission对象。

    • Uses of PermissionCollection in java.security

      Subclasses of PermissionCollection in java.security
      Modifier and Type Class 描述
      class  Permissions
      此类表示许多权限的异构集合。
      Fields in java.security declared as PermissionCollection
      Modifier and Type Field 描述
      static PermissionCollection Policy.UNSUPPORTED_EMPTY_COLLECTION
      只读空PermissionCollection实例。
      Methods in java.security that return PermissionCollection
      Modifier and Type 方法 描述
      protected PermissionCollection PolicySpi.engineGetPermissions​(CodeSource codesource)
      返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。
      protected PermissionCollection PolicySpi.engineGetPermissions​(ProtectionDomain domain)
      返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。
      PermissionCollection Policy.getPermissions​(CodeSource codesource)
      返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。
      PermissionCollection Policy.getPermissions​(ProtectionDomain domain)
      返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。
      PermissionCollection ProtectionDomain.getPermissions​()
      返回授予此域的静态权限。
      protected PermissionCollection SecureClassLoader.getPermissions​(CodeSource codesource)
      返回给定CodeSource对象的权限。
      PermissionCollection AllPermission.newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储AllPermission对象。
      PermissionCollection BasicPermission.newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储BasicPermission对象。
      PermissionCollection Permission.newPermissionCollection​()
      为给定的Permission对象返回一个空的PermissionCollection，如果未定义，则返回null。
      PermissionCollection UnresolvedPermission.newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储UnresolvedPermission对象。
      Constructors in java.security with parameters of type PermissionCollection
      Constructor 描述
      ProtectionDomain​(CodeSource codesource, PermissionCollection permissions)
      使用给定的CodeSource和权限创建一个新的ProtectionDomain。
      ProtectionDomain​(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
      创建一个由给定的CodeSource，Permissions，ClassLoader和Principals数组限定的新的ProtectionDomain。

    • Uses of PermissionCollection in java.util

      Methods in java.util that return PermissionCollection
      Modifier and Type 方法 描述
      PermissionCollection PropertyPermission.newPermissionCollection​()
      返回一个用于存储PropertyPermission对象的新的PermissionCollection对象。

    • Uses of PermissionCollection in javax.management

      Methods in javax.management that return PermissionCollection
      Modifier and Type | 方法 | 描述
      PermissionCollection | MBeanServerPermission.newPermissionCollection​()

    • Uses of PermissionCollection in javax.security.auth

      Methods in javax.security.auth that return PermissionCollection
      Modifier and Type 方法 描述
      abstract PermissionCollection Policy.getPermissions​(Subject subject, CodeSource cs)
      已过时。
      检索授予与指定的 CodeSource相关的校长的权限。
      PermissionCollection PrivateCredentialPermission.newPermissionCollection​()
      返回PrivateCredentialPermissions的同类集合在 PermissionCollection 。

    • Uses of PermissionCollection in javax.security.auth.kerberos

      Methods in javax.security.auth.kerberos that return PermissionCollection
      Modifier and Type 方法 描述
      PermissionCollection DelegationPermission.newPermissionCollection​()
      返回一个PermissionCollection对象，用于存储DelegationPermission对象。
      PermissionCollection ServicePermission.newPermissionCollection​()
      返回一个用于存储ServicePermission对象的PermissionCollection对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Permissions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Permissions

No usage of java.security.Permissions
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.PKCS12Attribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.PKCS12Attribute

No usage of java.security.PKCS12Attribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Policy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Policy

  • Packages that use Policy
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of Policy in java.security

      Methods in java.security that return Policy
      Modifier and Type 方法 描述
      static Policy Policy.getInstance​(String type, Policy.Parameters params)
      返回指定类型的Policy对象。
      static Policy Policy.getInstance​(String type, Policy.Parameters params, String provider)
      返回指定类型的Policy对象。
      static Policy Policy.getInstance​(String type, Policy.Parameters params, Provider provider)
      返回指定类型的Policy对象。
      static Policy Policy.getPolicy​()
      返回已安装的Policy对象。
      Methods in java.security with parameters of type Policy
      Modifier and Type 方法 描述
      static void Policy.setPolicy​(Policy p)
      设置系统范围的Policy对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.PolicySpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.PolicySpi

No usage of java.security.PolicySpi
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.PrivilegedActionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.PrivilegedActionException

  • Packages that use PrivilegedActionException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.security.auth
    此软件包提供了认证和授权的框架。

    • Uses of PrivilegedActionException in java.security

      Methods in java.security that throw PrivilegedActionException
      Modifier and Type 方法 描述
      static <T> T AccessController.doPrivileged​(PrivilegedExceptionAction<T> action)
      执行指定的 PrivilegedExceptionAction启用特权。
      static <T> T AccessController.doPrivileged​(PrivilegedExceptionAction<T> action, AccessControlContext context)
      执行指定的 PrivilegedExceptionAction其中启用并受指定的 AccessControlContext限制。
      static <T> T AccessController.doPrivileged​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action)
      执行指定的 PrivilegedExceptionAction启用特权。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。

    • Uses of PrivilegedActionException in javax.security.auth

      Methods in javax.security.auth that throw PrivilegedActionException
      Modifier and Type 方法 描述
      static <T> T Subject.doAs​(Subject subject, PrivilegedExceptionAction<T> action)
      执行工作作为一个特定的 Subject 。
      static <T> T Subject.doAsPrivileged​(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
      作为特定的 Subject执行特权工作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.ProtectionDomain (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.ProtectionDomain

  • Packages that use ProtectionDomain
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.security
    提供安全框架的类和接口。
    javax.security.auth
    此软件包提供了认证和授权的框架。

    • Uses of ProtectionDomain in java.lang

      Methods in java.lang that return ProtectionDomain
      Modifier and Type 方法 描述
      ProtectionDomain Class.getProtectionDomain​()
      返回 ProtectionDomain 。
      Methods in java.lang with parameters of type ProtectionDomain
      Modifier and Type 方法 描述
      protected Class<?> ClassLoader.defineClass​(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
      将一个字节数组转换为类别 Class的实例，给定的是 ProtectionDomain 。
      protected Class<?> ClassLoader.defineClass​(String name, ByteBuffer b, ProtectionDomain protectionDomain)
      一个转换ByteBuffer成类的实例Class ，与给定ProtectionDomain 。

    • Uses of ProtectionDomain in java.lang.instrument

      Methods in java.lang.instrument with parameters of type ProtectionDomain
      Modifier and Type 方法 描述
      default byte[] ClassFileTransformer.transform​(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。
      default byte[] ClassFileTransformer.transform​(Module module, ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。

    • Uses of ProtectionDomain in java.security

      Methods in java.security that return ProtectionDomain
      Modifier and Type 方法 描述
      ProtectionDomain[] DomainCombiner.combine​(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
      修改或更新提供的ProtectionDomains。
      Methods in java.security with parameters of type ProtectionDomain
      Modifier and Type 方法 描述
      ProtectionDomain[] DomainCombiner.combine​(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
      修改或更新提供的ProtectionDomains。
      protected PermissionCollection PolicySpi.engineGetPermissions​(ProtectionDomain domain)
      返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。
      protected abstract boolean PolicySpi.engineImplies​(ProtectionDomain domain, Permission permission)
      检查策略是否授予了ProtectionDomain的权限。
      PermissionCollection Policy.getPermissions​(ProtectionDomain domain)
      返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。
      boolean Policy.implies​(ProtectionDomain domain, Permission permission)
      评估授予ProtectionDomain的权限的全局策略，并测试是否授予权限。
      Constructors in java.security with parameters of type ProtectionDomain
      Constructor 描述
      AccessControlContext​(ProtectionDomain[] context)
      使用给定的ProtectionDomains数组创建一个AccessControlContext。

    • Uses of ProtectionDomain in javax.security.auth

      Methods in javax.security.auth that return ProtectionDomain
      Modifier and Type 方法 描述
      ProtectionDomain[] SubjectDomainCombiner.combine​(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
      更新从校长有关的ProtectionDomains Subject与此相关 SubjectDomainCombiner 。
      Methods in javax.security.auth with parameters of type ProtectionDomain
      Modifier and Type 方法 描述
      ProtectionDomain[] SubjectDomainCombiner.combine​(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
      更新从校长有关的ProtectionDomains Subject与此相关 SubjectDomainCombiner 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Provider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Provider

  • Packages that use Provider
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.smartcardio
    Java™智能卡I / O API
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.crypto.dsig.keyinfo
    类用于解析和处理KeyInfo个元件和结构。
    jdk.security.jarsigner
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。

    • Uses of Provider in java.security

      Subclasses of Provider in java.security
      Modifier and Type Class 描述
      class  AuthProvider
      此类为提供程序定义登录和注销方法。
      Methods in java.security that return Provider
      Modifier and Type 方法 描述
      Provider Provider.configure​(String configArg)
      将提供的配置参数应用于此提供程序实例并返回配置的提供程序。
      Provider AlgorithmParameterGenerator.getProvider​()
      返回此算法参数生成器对象的提供者。
      Provider AlgorithmParameters.getProvider​()
      返回此参数对象的提供者。
      Provider KeyFactory.getProvider​()
      返回此关键工厂对象的提供者。
      Provider KeyPairGenerator.getProvider​()
      返回此密钥对生成器对象的提供者。
      Provider KeyStore.getProvider​()
      返回此密钥库的提供者。
      Provider MessageDigest.getProvider​()
      返回此消息摘要对象的提供者。
      Provider Policy.getProvider​()
      返回本政策的提供者。
      Provider Provider.Service.getProvider​()
      返回此服务的提供者。
      Provider SecureRandom.getProvider​()
      返回此 SecureRandom对象的提供者。
      static Provider Security.getProvider​(String name)
      返回以指定名称安装的提供程序（如果有）。
      Provider Signature.getProvider​()
      返回此签名对象的提供者。
      static Provider[] Security.getProviders​()
      返回包含所有已安装提供程序的数组。
      static Provider[] Security.getProviders​(String filter)
      返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。
      static Provider[] Security.getProviders​(Map<String,String> filter)
      返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。
      Methods in java.security with parameters of type Provider
      Modifier and Type 方法 描述
      static int Security.addProvider​(Provider provider)
      将供应商添加到下一个可用位置。
      static AlgorithmParameterGenerator AlgorithmParameterGenerator.getInstance​(String algorithm, Provider provider)
      返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。
      static AlgorithmParameters AlgorithmParameters.getInstance​(String algorithm, Provider provider)
      返回指定算法的参数对象。
      static KeyFactory KeyFactory.getInstance​(String algorithm, Provider provider)
      返回一个KeyFactory对象，它转换指定算法的公钥/私钥。
      static KeyPairGenerator KeyPairGenerator.getInstance​(String algorithm, Provider provider)
      返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。
      static KeyStore KeyStore.getInstance​(String type, Provider provider)
      返回指定类型的密钥库对象。
      static MessageDigest MessageDigest.getInstance​(String algorithm, Provider provider)
      返回实现指定摘要算法的MessageDigest对象。
      static Policy Policy.getInstance​(String type, Policy.Parameters params, Provider provider)
      返回指定类型的Policy对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, Provider provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, Provider provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static Signature Signature.getInstance​(String algorithm, Provider provider)
      返回实现指定签名算法的Signature对象。
      static int Security.insertProviderAt​(Provider provider, int position)
      在指定的位置添加一个新的提供者。
      static KeyStore.Builder KeyStore.Builder.newInstance​(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder KeyStore.Builder.newInstance​(String type, Provider provider, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      Constructors in java.security with parameters of type Provider
      Constructor 描述
      AlgorithmParameterGenerator​(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
      创建一个AlgorithmParameterGenerator对象。
      AlgorithmParameters​(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
      创建一个AlgorithmParameters对象。
      KeyFactory​(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
      创建一个KeyFactory对象。
      KeyStore​(KeyStoreSpi keyStoreSpi, Provider provider, String type)
      创建给定类型的KeyStore对象，并封装给定的提供者实现（SPI对象）。
      SecureRandom​(SecureRandomSpi secureRandomSpi, Provider provider)
      创建一个 SecureRandom对象。
      Service​(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
      构建新服务

    • Uses of Provider in java.security.cert

      Methods in java.security.cert that return Provider
      Modifier and Type 方法 描述
      Provider CertificateFactory.getProvider​()
      返回此证书工厂的提供者。
      Provider CertPathBuilder.getProvider​()
      返回此 CertPathBuilder的提供者。
      Provider CertPathValidator.getProvider​()
      返回此 Provider的 CertPathValidator 。
      Provider CertStore.getProvider​()
      返回此 CertStore的提供者。
      Methods in java.security.cert with parameters of type Provider
      Modifier and Type 方法 描述
      static CertificateFactory CertificateFactory.getInstance​(String type, Provider provider)
      返回指定证书类型的证书工厂对象。
      static CertPathBuilder CertPathBuilder.getInstance​(String algorithm, Provider provider)
      返回实现指定算法的 CertPathBuilder对象。
      static CertPathValidator CertPathValidator.getInstance​(String algorithm, Provider provider)
      返回实现指定算法的 CertPathValidator对象。
      static CertStore CertStore.getInstance​(String type, CertStoreParameters params, Provider provider)
      返回实现指定的 CertStore类型的 CertStore对象。
      void Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void X509Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void X509CRL.verify​(PublicKey key, Provider sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      Constructors in java.security.cert with parameters of type Provider
      Constructor 描述
      CertificateFactory​(CertificateFactorySpi certFacSpi, Provider provider, String type)
      创建给定类型的CertificateFactory对象，并将给定的提供者实现（SPI对象）封装在其中。
      CertPathBuilder​(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
      创建给定算法的 CertPathBuilder对象，并将给定的提供者实现（SPI对象）封装在其中。
      CertPathValidator​(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
      创建给定算法的 CertPathValidator对象，并将给定的提供者实现（SPI对象）封装在其中。
      CertStore​(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
      创建给定类型的 CertStore对象，并将给定的提供者实现（SPI对象）封装在其中。

    • Uses of Provider in javax.crypto

      Methods in javax.crypto that return Provider
      Modifier and Type 方法 描述
      Provider Cipher.getProvider​()
      返回此 Cipher对象的提供者。
      Provider ExemptionMechanism.getProvider​()
      返回此 ExemptionMechanism对象的提供者。
      Provider KeyAgreement.getProvider​()
      返回此 KeyAgreement对象的提供者。
      Provider KeyGenerator.getProvider​()
      返回此 KeyGenerator对象的提供者。
      Provider Mac.getProvider​()
      返回此 Mac对象的提供者。
      Provider SecretKeyFactory.getProvider​()
      返回此 SecretKeyFactory对象的提供者。
      Methods in javax.crypto with parameters of type Provider
      Modifier and Type 方法 描述
      static Cipher Cipher.getInstance​(String transformation, Provider provider)
      返回实现指定转换的 Cipher对象。
      static ExemptionMechanism ExemptionMechanism.getInstance​(String algorithm, Provider provider)
      返回一个实现指定的免除机制算法的 ExemptionMechanism对象。
      static KeyAgreement KeyAgreement.getInstance​(String algorithm, Provider provider)
      返回实现指定的密钥协商算法的 KeyAgreement对象。
      static KeyGenerator KeyGenerator.getInstance​(String algorithm, Provider provider)
      返回一个产生指定算法的密钥的 KeyGenerator对象。
      static Mac Mac.getInstance​(String algorithm, Provider provider)
      返回实现指定MAC算法的 Mac对象。
      static SecretKeyFactory SecretKeyFactory.getInstance​(String algorithm, Provider provider)
      返回一个转换指定算法的密钥的 SecretKeyFactory对象。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, Provider provider)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      Constructors in javax.crypto with parameters of type Provider
      Constructor 描述
      Cipher​(CipherSpi cipherSpi, Provider provider, String transformation)
      创建一个Cipher对象。
      ExemptionMechanism​(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
      创建一个ExemptionMechanism对象。
      KeyAgreement​(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
      创建一个KeyAgreement对象。
      KeyGenerator​(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
      创建一个KeyGenerator对象。
      Mac​(MacSpi macSpi, Provider provider, String algorithm)
      创建MAC对象。
      SecretKeyFactory​(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
      创建一个SecretKeyFactory对象。

    • Uses of Provider in javax.net.ssl

      Methods in javax.net.ssl that return Provider
      Modifier and Type 方法 描述
      Provider KeyManagerFactory.getProvider​()
      返回此 KeyManagerFactory对象的提供者。
      Provider SSLContext.getProvider​()
      返回此 SSLContext对象的提供者。
      Provider TrustManagerFactory.getProvider​()
      返回此 TrustManagerFactory对象的提供者。
      Methods in javax.net.ssl with parameters of type Provider
      Modifier and Type 方法 描述
      static KeyManagerFactory KeyManagerFactory.getInstance​(String algorithm, Provider provider)
      返回一个 KeyManagerFactory对象，作为关键经理的工厂。
      static SSLContext SSLContext.getInstance​(String protocol, Provider provider)
      返回实现指定安全套接字协议的 SSLContext对象。
      static TrustManagerFactory TrustManagerFactory.getInstance​(String algorithm, Provider provider)
      返回一个 TrustManagerFactory对象，作为信任管理器的工厂。
      Constructors in javax.net.ssl with parameters of type Provider
      Constructor 描述
      KeyManagerFactory​(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
      创建一个KeyManagerFactory对象。
      SSLContext​(SSLContextSpi contextSpi, Provider provider, String protocol)
      创建一个SSLContext对象。
      TrustManagerFactory​(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
      创建一个TrustManagerFactory对象。

    • Uses of Provider in javax.security.auth.login

      Methods in javax.security.auth.login that return Provider
      Modifier and Type 方法 描述
      Provider Configuration.getProvider​()
      返回此配置的提供程序。
      Methods in javax.security.auth.login with parameters of type Provider
      Modifier and Type 方法 描述
      static Configuration Configuration.getInstance​(String type, Configuration.Parameters params, Provider provider)
      返回指定类型的Configuration对象。

    • Uses of Provider in javax.smartcardio

      Methods in javax.smartcardio that return Provider
      Modifier and Type 方法 描述
      Provider TerminalFactory.getProvider​()
      返回此TerminalFactory的提供者。
      Methods in javax.smartcardio with parameters of type Provider
      Modifier and Type 方法 描述
      static TerminalFactory TerminalFactory.getInstance​(String type, Object params, Provider provider)
      返回使用指定参数初始化的指定类型的TerminalFactory。

    • Uses of Provider in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return Provider
      Modifier and Type 方法 描述
      Provider TransformService.getProvider​()
      返回此 TransformService的提供者。
      Provider XMLSignatureFactory.getProvider​()
      返回此 XMLSignatureFactory的提供者。
      Methods in javax.xml.crypto.dsig with parameters of type Provider
      Modifier and Type 方法 描述
      static TransformService TransformService.getInstance​(String algorithm, String mechanismType, Provider provider)
      返回一个 TransformService ，它支持指定的 TransformService程序提供的指定算法URI（例如： Transform.XPATH2 ）和机制类型（例如：DOM）。
      static XMLSignatureFactory XMLSignatureFactory.getInstance​(String mechanismType, Provider provider)
      返回一个 XMLSignatureFactory ，它支持由指定的提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

    • Uses of Provider in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return Provider
      Modifier and Type 方法 描述
      Provider KeyInfoFactory.getProvider​()
      返回此 KeyInfoFactory的提供者。
      Methods in javax.xml.crypto.dsig.keyinfo with parameters of type Provider
      Modifier and Type 方法 描述
      static KeyInfoFactory KeyInfoFactory.getInstance​(String mechanismType, Provider provider)
      返回一个 KeyInfoFactory ，它支持由指定的提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

    • Uses of Provider in jdk.security.jarsigner

      Methods in jdk.security.jarsigner with parameters of type Provider
      Modifier and Type 方法 描述
      JarSigner.Builder JarSigner.Builder.digestAlgorithm​(String algorithm, Provider provider)
      从指定的提供者设置摘要算法。
      JarSigner.Builder JarSigner.Builder.signatureAlgorithm​(String algorithm, Provider provider)
      从指定的提供者设置签名算法。

    • Uses of Provider in org.ietf.jgss

      Methods in org.ietf.jgss with parameters of type Provider
      Modifier and Type 方法 描述
      abstract void GSSManager.addProviderAtEnd​(Provider p, Oid mech)
      该方法用于向GSSManager指示，如果没有找到支持给定机制的其他提供程序，应用程序将希望使用特定的提供程序。
      abstract void GSSManager.addProviderAtFront​(Provider p, Oid mech)
      该方法用于向GSSManager指示当给定机制需要支持时，应用程序希望在所有其他提供程序之前使用特定的提供程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Provider.Service (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Provider.Service

  • Packages that use Provider.Service
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of Provider.Service in java.security

      Methods in java.security that return Provider.Service
      Modifier and Type 方法 描述
      Provider.Service Provider.getService​(String type, String algorithm)
      获取描述此提供程序实现该算法或别名的指定类型的服务。
      Methods in java.security that return types with arguments of type Provider.Service
      Modifier and Type 方法 描述
      Set<Provider.Service> Provider.getServices​()
      获取不可修改的此提供程序支持的所有服务的集合。
      Methods in java.security with parameters of type Provider.Service
      Modifier and Type 方法 描述
      protected void Provider.putService​(Provider.Service s)
      添加服务。
      protected void Provider.removeService​(Provider.Service s)
      删除以前使用 putService()添加的服务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.ProviderException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.ProviderException

No usage of java.security.ProviderException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.SecureClassLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.SecureClassLoader

  • Packages that use SecureClassLoader
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    javax.management.loading
    提供实现高级动态加载的类。

    • Uses of SecureClassLoader in java.net

      Subclasses of SecureClassLoader in java.net
      Modifier and Type Class 描述
      class  URLClassLoader
      此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。

    • Uses of SecureClassLoader in javax.management.loading

      Subclasses of SecureClassLoader in javax.management.loading
      Modifier and Type Class 描述
      class  MLet
      允许您在来自远程URL的MBean服务器中实例化和注册一个或多个MBean。
      class  PrivateMLet
      未添加到ClassLoaderRepository的MLet。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.SecureRandom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.SecureRandom

  • Packages that use SecureRandom
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of SecureRandom in java.security

      Fields in java.security declared as SecureRandom
      Modifier and Type Field 描述
      protected SecureRandom SignatureSpi.appRandom
      应用指定的随机源。
      Methods in java.security that return SecureRandom
      Modifier and Type 方法 描述
      static SecureRandom SecureRandom.getInstance​(String algorithm)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, String provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, Provider provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, String provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, Provider provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom SecureRandom.getInstanceStrong​()
      返回通过使用securerandom.strongAlgorithms Security属性中指定的算法/提供程序选择的SecureRandom对象。
      Methods in java.security with parameters of type SecureRandom
      Modifier and Type 方法 描述
      protected abstract void AlgorithmParameterGeneratorSpi.engineInit​(int size, SecureRandom random)
      初始化此参数生成器以获得一定的大小和随机源。
      protected abstract void AlgorithmParameterGeneratorSpi.engineInit​(AlgorithmParameterSpec genParamSpec, SecureRandom random)
      使用一组特定于算法的参数生成值初始化此参数生成器。
      protected void SignatureSpi.engineInitSign​(PrivateKey privateKey, SecureRandom random)
      使用指定的私钥和签名操作的随机源初始化此签名对象。
      void AlgorithmParameterGenerator.init​(int size, SecureRandom random)
      初始化此参数生成器以获得一定的大小和随机源。
      void AlgorithmParameterGenerator.init​(AlgorithmParameterSpec genParamSpec, SecureRandom random)
      使用一组特定于算法的参数生成值初始化此参数生成器。
      void KeyPairGenerator.initialize​(int keysize, SecureRandom random)
      使用给定的随机源（和默认参数集）初始化特定密钥大小的密钥对生成器。
      void KeyPairGenerator.initialize​(AlgorithmParameterSpec params, SecureRandom random)
      使用给定的参数集和随机源初始化密钥对生成器。
      abstract void KeyPairGeneratorSpi.initialize​(int keysize, SecureRandom random)
      使用默认参数集初始化某个密钥对的密钥对生成器。
      void KeyPairGeneratorSpi.initialize​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化密钥对生成器。
      void Signature.initSign​(PrivateKey privateKey, SecureRandom random)
      初始化此对象进行签名。

    • Uses of SecureRandom in java.security.interfaces

      Methods in java.security.interfaces with parameters of type SecureRandom
      Modifier and Type 方法 描述
      void DSAKeyPairGenerator.initialize​(int modlen, boolean genParams, SecureRandom random)
      为给定的模数长度（而不是参数）初始化密钥对生成器以及可选的SecureRandom位源。
      void DSAKeyPairGenerator.initialize​(DSAParams params, SecureRandom random)
      使用DSA系列参数（p，q和g）和可选的SecureRandom位源初始化密钥对生成器。

    • Uses of SecureRandom in javax.crypto

      Methods in javax.crypto with parameters of type SecureRandom
      Modifier and Type 方法 描述
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, SecureRandom random)
      用密钥和随机源初始化此密码。
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void KeyAgreementSpi.engineInit​(Key key, SecureRandom random)
      用给定的密钥和随机源初始化这个密钥协商。
      protected abstract void KeyAgreementSpi.engineInit​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      protected abstract void KeyGeneratorSpi.engineInit​(int keysize, SecureRandom random)
      使用给定的随机源初始化该密钥生成器以进行某些密钥化。
      protected abstract void KeyGeneratorSpi.engineInit​(SecureRandom random)
      初始化密钥生成器。
      protected abstract void KeyGeneratorSpi.engineInit​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化密钥生成器。
      void Cipher.init​(int opmode, Certificate certificate, SecureRandom random)
      使用给定证书中的公钥和随机源初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void Cipher.init​(int opmode, Key key, SecureRandom random)
      用密钥和随机源初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void KeyAgreement.init​(Key key, SecureRandom random)
      用给定的密钥和随机源初始化这个密钥协商。
      void KeyAgreement.init​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      void KeyGenerator.init​(int keysize, SecureRandom random)
      使用用户提供的随机源，初始化该密钥生成器以进行某些密钥化。
      void KeyGenerator.init​(SecureRandom random)
      初始化此密钥生成器。
      void KeyGenerator.init​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化此密钥生成器。

    • Uses of SecureRandom in javax.net.ssl

      Methods in javax.net.ssl with parameters of type SecureRandom
      Modifier and Type 方法 描述
      protected abstract void SSLContextSpi.engineInit​(KeyManager[] km, TrustManager[] tm, SecureRandom sr)
      初始化此上下文。
      void SSLContext.init​(KeyManager[] km, TrustManager[] tm, SecureRandom random)
      Initializes this context.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.SecureRandomSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.SecureRandomSpi

  • Packages that use SecureRandomSpi
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of SecureRandomSpi in java.security

      Constructors in java.security with parameters of type SecureRandomSpi
      Constructor 描述
      SecureRandom​(SecureRandomSpi secureRandomSpi, Provider provider)
      创建一个 SecureRandom对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Security (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Security

No usage of java.security.Security
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.SecurityPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.SecurityPermission

No usage of java.security.SecurityPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Signature (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Signature

  • Packages that use Signature
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of Signature in java.security

      Methods in java.security that return Signature
      Modifier and Type 方法 描述
      static Signature Signature.getInstance​(String algorithm)
      返回实现指定签名算法的Signature对象。
      static Signature Signature.getInstance​(String algorithm, String provider)
      返回实现指定签名算法的Signature对象。
      static Signature Signature.getInstance​(String algorithm, Provider provider)
      返回实现指定签名算法的Signature对象。
      Methods in java.security with parameters of type Signature
      Modifier and Type 方法 描述
      boolean SignedObject.verify​(PublicKey verificationKey, Signature verificationEngine)
      验证此SignedObject中的签名是使用指定的验证引擎使用给定的验证密钥存储在其中的对象的有效签名。
      Constructors in java.security with parameters of type Signature
      Constructor 描述
      SignedObject​(Serializable object, PrivateKey signingKey, Signature signingEngine)
      从任何可序列化对象构造一个SignedObject。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.SignatureException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.SignatureException

  • Packages that use SignatureException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.security.cert
    提供公钥证书类。

    • Uses of SignatureException in java.security

      Methods in java.security that throw SignatureException
      Modifier and Type 方法 描述
      protected abstract byte[] SignatureSpi.engineSign​()
      返回到目前为止更新的所有数据的签名字节。
      protected int SignatureSpi.engineSign​(byte[] outbuf, int offset, int len)
      完成此签名操作，并将生成的签名字节存储在提供的缓冲区 outbuf ，从 offset开始。
      protected abstract void SignatureSpi.engineUpdate​(byte b)
      使用指定的字节更新要签名或验证的数据。
      protected abstract void SignatureSpi.engineUpdate​(byte[] b, int off, int len)
      使用指定的字节数组从指定的偏移量更新要签名或验证的数据。
      protected abstract boolean SignatureSpi.engineVerify​(byte[] sigBytes)
      验证传入签名。
      protected boolean SignatureSpi.engineVerify​(byte[] sigBytes, int offset, int length)
      以指定的偏移量开始，以指定的字节数组验证传入签名。
      byte[] Signature.sign​()
      返回所有更新的数据的签名字节。
      int Signature.sign​(byte[] outbuf, int offset, int len)
      完成签名操作，并将生成的签名字节存储在提供的缓冲区 outbuf ，从 offset开始。
      void Signature.update​(byte b)
      更新要由一个字节签名或验证的数据。
      void Signature.update​(byte[] data)
      使用指定的字节数组更新要签名或验证的数据。
      void Signature.update​(byte[] data, int off, int len)
      使用指定的字节数组从指定的偏移量更新要签名或验证的数据。
      void Signature.update​(ByteBuffer data)
      使用指定的ByteBuffer更新要签名或验证的数据。
      boolean Signature.verify​(byte[] signature)
      验证传入签名。
      boolean Signature.verify​(byte[] signature, int offset, int length)
      以指定的偏移量开始，以指定的字节数组验证传入签名。
      boolean SignedObject.verify​(PublicKey verificationKey, Signature verificationEngine)
      验证此SignedObject中的签名是使用指定的验证引擎使用给定的验证密钥存储在其中的对象的有效签名。
      Constructors in java.security that throw SignatureException
      Constructor 描述
      SignedObject​(Serializable object, PrivateKey signingKey, Signature signingEngine)
      从任何可序列化对象构造一个SignedObject。

    • Uses of SignatureException in java.security.cert

      Methods in java.security.cert that throw SignatureException
      Modifier and Type 方法 描述
      abstract void Certificate.verify​(PublicKey key)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void X509Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void X509CRL.verify​(PublicKey key)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      abstract void X509CRL.verify​(PublicKey key, String sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      void X509CRL.verify​(PublicKey key, Provider sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。

    • Uses of SignatureException in javax.security.cert

      Methods in javax.security.cert that throw SignatureException
      Modifier and Type 方法 描述
      abstract void Certificate.verify​(PublicKey key)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.SignatureSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.SignatureSpi

  • Packages that use SignatureSpi
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of SignatureSpi in java.security

      Subclasses of SignatureSpi in java.security
      Modifier and Type Class 描述
      class  Signature
      Signature类用于向应用程序提供数字签名算法的功能。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.SignedObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.SignedObject

No usage of java.security.SignedObject
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Signer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Signer

No usage of java.security.Signer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.Timestamp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.Timestamp

  • Packages that use Timestamp
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of Timestamp in java.security

      Methods in java.security that return Timestamp
      Modifier and Type 方法 描述
      Timestamp CodeSigner.getTimestamp​()
      返回签名时间戳。
      Constructors in java.security with parameters of type Timestamp
      Constructor 描述
      CodeSigner​(CertPath signerCertPath, Timestamp timestamp)
      构造一个CodeSigner对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.UnrecoverableEntryException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.UnrecoverableEntryException

  • Packages that use UnrecoverableEntryException
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of UnrecoverableEntryException in java.security

      Subclasses of UnrecoverableEntryException in java.security
      Modifier and Type Class 描述
      class  UnrecoverableKeyException
      如果密钥存储库中的密钥无法恢复，则抛出此异常。
      Methods in java.security that throw UnrecoverableEntryException
      Modifier and Type 方法 描述
      KeyStore.Entry KeyStoreSpi.engineGetEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的 KeyStore.Entry 。
      KeyStore.Entry KeyStore.getEntry​(String alias, KeyStore.ProtectionParameter protParam)
      使用指定的保护参数获取指定别名的密钥库 Entry 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.UnrecoverableKeyException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.UnrecoverableKeyException

  • Packages that use UnrecoverableKeyException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of UnrecoverableKeyException in java.security

      Methods in java.security that throw UnrecoverableKeyException
      Modifier and Type 方法 描述
      abstract Key KeyStoreSpi.engineGetKey​(String alias, char[] password)
      返回与给定别名相关联的密钥，使用给定的密码恢复它。
      Key KeyStore.getKey​(String alias, char[] password)
      返回与给定别名相关联的密钥，使用给定的密码恢复它。

    • Uses of UnrecoverableKeyException in javax.net.ssl

      Methods in javax.net.ssl that throw UnrecoverableKeyException
      Modifier and Type 方法 描述
      protected abstract void KeyManagerFactorySpi.engineInit​(KeyStore ks, char[] password)
      使用关键材料来源初始化该工厂。
      void KeyManagerFactory.init​(KeyStore ks, char[] password)
      使用关键材料来源初始化该工厂。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.UnresolvedPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.UnresolvedPermission

No usage of java.security.UnresolvedPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.URIParameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.URIParameter

No usage of java.security.URIParameter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.AlgorithmConstraints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.AlgorithmConstraints

  • Packages that use AlgorithmConstraints
    软件包 描述
    javax.net.ssl
    为安全套接字包提供类。

    • Uses of AlgorithmConstraints in javax.net.ssl

      Methods in javax.net.ssl that return AlgorithmConstraints
      Modifier and Type 方法 描述
      AlgorithmConstraints SSLParameters.getAlgorithmConstraints​()
      返回加密算法约束。
      Methods in javax.net.ssl with parameters of type AlgorithmConstraints
      Modifier and Type 方法 描述
      void SSLParameters.setAlgorithmConstraints​(AlgorithmConstraints constraints)
      设置加密算法约束，除了由运行时环境配置的任何约束之外，它将被使用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.Certificate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.Certificate

  • Packages that use Certificate
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of Certificate in java.security

      Methods in java.security that return Certificate
      Modifier and Type 方法 描述
      Certificate[] Identity.certificates​()
      已过时。
      返回此身份的所有证书的副本。
      Methods in java.security with parameters of type Certificate
      Modifier and Type 方法 描述
      void Identity.addCertificate​(Certificate certificate)
      已过时。
      为此身份添加证书。
      void Identity.removeCertificate​(Certificate certificate)
      已过时。
      Removes a certificate from this identity.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.DomainCombiner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.DomainCombiner

  • Packages that use DomainCombiner
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.security.auth
    此软件包提供了认证和授权的框架。

    • Uses of DomainCombiner in java.security

      Methods in java.security that return DomainCombiner
      Modifier and Type 方法 描述
      DomainCombiner AccessControlContext.getDomainCombiner​()
      获取 DomainCombiner与此 AccessControlContext相关联。
      Constructors in java.security with parameters of type DomainCombiner
      Constructor 描述
      AccessControlContext​(AccessControlContext acc, DomainCombiner combiner)
      创建一个新的 AccessControlContext与给定的 AccessControlContext和 DomainCombiner 。

    • Uses of DomainCombiner in javax.security.auth

      Classes in javax.security.auth that implement DomainCombiner
      Modifier and Type Class 描述
      class  SubjectDomainCombiner
      一个 SubjectDomainCombiner与校长更新的ProtectionDomains从 Subject与此相关 SubjectDomainCombiner 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.Guard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.Guard

  • Packages that use Guard
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.security.jgss
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.security
    提供安全框架的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    javafx.util
    包含各种实用程序和助手类。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of Guard in com.sun.jdi

      Classes in com.sun.jdi that implement Guard
      Modifier and Type Class 描述
      class  JDIPermission
      JDIPermission类表示访问权限 VirtualMachineManager 。

    • Uses of Guard in com.sun.security.jgss

      Classes in com.sun.security.jgss that implement Guard
      Modifier and Type Class 描述
      class  InquireSecContextPermission
      此类用于保护可以使用 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)方法访问的已建立GSS安全上下文的各种属性。

    • Uses of Guard in com.sun.tools.attach

      Classes in com.sun.tools.attach that implement Guard
      Modifier and Type Class 描述
      class  AttachPermission
      当一个SecurityManager集合，这是当代码调用VirtalMachine.attach附加到目标虚拟机时将被检查的权限。

    • Uses of Guard in java.awt

      Classes in java.awt that implement Guard
      Modifier and Type Class 描述
      class  AWTPermission
      此类用于AWT权限。

    • Uses of Guard in java.io

      Classes in java.io that implement Guard
      Modifier and Type Class 描述
      class  FilePermission
      此类表示访问文件或目录。
      class  SerializablePermission
      这个类用于Serializable权限。

    • Uses of Guard in java.lang

      Classes in java.lang that implement Guard
      Modifier and Type Class 描述
      class  RuntimePermission
      此类用于运行时权限。

    • Uses of Guard in java.lang.management

      Classes in java.lang.management that implement Guard
      Modifier and Type Class 描述
      class  ManagementPermission
      当SecurityManager运行的代码调用在Java平台的管理界面中定义的方法时，SecurityManager将检查的权限。

    • Uses of Guard in java.lang.reflect

      Classes in java.lang.reflect that implement Guard
      Modifier and Type Class 描述
      class  ReflectPermission
      反思操作的权限类。

    • Uses of Guard in java.net

      Classes in java.net that implement Guard
      Modifier and Type Class 描述
      class  NetPermission
      此类用于各种网络权限。
      class  SocketPermission
      此类表示通过套接字访问网络。
      class  URLPermission
      表示访问由给定网址定义的资源或资源集的权限，以及给定的一组用户可设置的请求方法和请求标头。

    • Uses of Guard in java.nio.file

      Classes in java.nio.file that implement Guard
      Modifier and Type Class 描述
      class  LinkPermission
      Permission类链接创建操作。

    • Uses of Guard in java.security

      Classes in java.security that implement Guard
      Modifier and Type Class 描述
      class  AllPermission
      AllPermission是一个隐含所有其他权限的权限。
      class  BasicPermission
      BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
      class  Permission
      用于表示访问系统资源的抽象类。
      class  SecurityPermission
      此类用于安全权限。
      class  UnresolvedPermission
      UnresolvedPermission类用于保存初始化策略时“未解决”的权限。
      Constructors in java.security with parameters of type Guard
      Constructor 描述
      GuardedObject​(Object object, Guard guard)
      使用指定的对象和守卫构造一个GuardedObject。

    • Uses of Guard in java.sql

      Classes in java.sql that implement Guard
      Modifier and Type Class 描述
      class  SQLPermission
      SecurityManager将在运行启用了 SecurityManager的应用程序的代码时检查的权限，调用 DriverManager.deregisterDriver方法， DriverManager.setLogWriter方法， DriverManager.setLogStream （弃用）方法， SyncFactory.setJNDIContext方法， SyncFactory.setLogger方法， Connection.setNetworkTimeout方法或 Connection.abort方法。

    • Uses of Guard in java.util

      Classes in java.util that implement Guard
      Modifier and Type Class 描述
      class  PropertyPermission
      此类用于属性权限。

    • Uses of Guard in java.util.logging

      Classes in java.util.logging that implement Guard
      Modifier and Type Class 描述
      class  LoggingPermission
      当SecurityManager运行的代码调用其中一个日志控件方法（如Logger.setLevel）时，SecurityManager将检查该权限。

    • Uses of Guard in javafx.util

      Classes in javafx.util that implement Guard
      Modifier and Type Class 描述
      class  FXPermission
      此类用于JavaFX权限。

    • Uses of Guard in javax.management

      Classes in javax.management that implement Guard
      Modifier and Type Class 描述
      class  MBeanPermission
      控制访问MBeanServer操作的权限。
      class  MBeanServerPermission
      A执行与MBeanServers有关的操作的权限。
      class  MBeanTrustPermission
      此权限在签名者或代码库中表示“信任”。

    • Uses of Guard in javax.management.remote

      Classes in javax.management.remote that implement Guard
      Modifier and Type Class 描述
      class  SubjectDelegationPermission
      认证身份所需的权限代表授权身份执行操作。

    • Uses of Guard in javax.net.ssl

      Classes in javax.net.ssl that implement Guard
      Modifier and Type Class 描述
      class  SSLPermission
      此类用于各种网络权限。

    • Uses of Guard in javax.security.auth

      Classes in javax.security.auth that implement Guard
      Modifier and Type Class 描述
      class  AuthPermission
      此类用于验证权限。
      class  PrivateCredentialPermission
      此类用于保护对属于特定 Subject私有凭据的访问。

    • Uses of Guard in javax.security.auth.kerberos

      Classes in javax.security.auth.kerberos that implement Guard
      Modifier and Type Class 描述
      class  DelegationPermission
      此类用于限制Kerberos授权模型的使用，即：可转发和可预售的机票。
      class  ServicePermission
      此类用于保护Kerberos服务和访问这些服务所必需的凭据。

    • Uses of Guard in javax.smartcardio

      Classes in javax.smartcardio that implement Guard
      Modifier and Type Class 描述
      class  CardPermission
      智能卡操作的许可。

    • Uses of Guard in javax.sound.sampled

      Classes in javax.sound.sampled that implement Guard
      Modifier and Type Class 描述
      class  AudioPermission
      AudioPermission类代表对音频系统资源的访问权限。

    • Uses of Guard in javax.xml.bind

      Classes in javax.xml.bind that implement Guard
      Modifier and Type Class 描述
      class  JAXBPermission
      此类用于JAXB权限。

    • Uses of Guard in javax.xml.ws

      Classes in javax.xml.ws that implement Guard
      Modifier and Type Class 描述
      class  WebServicePermission
      此类定义Web服务权限。

    • Uses of Guard in jdk.net

      Classes in jdk.net that implement Guard
      Modifier and Type Class 描述
      class  NetworkPermission
      Represents permission to access the extended networking capabilities defined in the jdk.net package.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.Key (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.Key

  • Packages that use Key
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig.dom
    DOM特定的类为 javax.xml.crypto.dsig包。

    • Uses of Key in java.security

      Subinterfaces of Key in java.security
      Modifier and Type 接口 描述
      interface  PrivateKey
      私钥。
      interface  PublicKey
      公钥
      Methods in java.security that return Key
      Modifier and Type 方法 描述
      abstract Key KeyStoreSpi.engineGetKey​(String alias, char[] password)
      返回与给定别名相关联的密钥，使用给定的密码恢复它。
      protected abstract Key KeyFactorySpi.engineTranslateKey​(Key key)
      将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。
      Key KeyStore.getKey​(String alias, char[] password)
      返回与给定别名相关联的密钥，使用给定的密码恢复它。
      Key KeyFactory.translateKey​(Key key)
      将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。
      Methods in java.security with parameters of type Key
      Modifier and Type 方法 描述
      protected abstract <T extends KeySpec>
      T             		KeyFactorySpi.engineGetKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。
      abstract void KeyStoreSpi.engineSetKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)
      将给定的密钥分配给给定的别名，并使用给定的密码进行保护。
      protected abstract Key KeyFactorySpi.engineTranslateKey​(Key key)
      将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。
      <T extends KeySpec>
      T             		KeyFactory.getKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, String algorithm, Key key, AlgorithmParameters parameters)
      确定算法和相应的密钥是否被授予对指定的加密原语的许可。
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, Key key)
      确定一个密钥是否被授予了指定的加密原语的权限。
      void KeyStore.setKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)
      将给定的密钥分配给给定的别名，并使用给定的密码进行保护。
      Key KeyFactory.translateKey​(Key key)
      将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。

    • Uses of Key in java.security.interfaces

      Subinterfaces of Key in java.security.interfaces
      Modifier and Type 接口 描述
      interface  DSAPrivateKey
      DSA私钥的标准接口。
      interface  DSAPublicKey
      DSA公钥的接口。
      interface  ECPrivateKey
      椭圆曲线（EC）私钥的界面。
      interface  ECPublicKey
      椭圆曲线（EC）公钥的界面。
      interface  RSAMultiPrimePrivateCrtKey
      与PKCS＃1 v2.1中定义的使用 中国剩余定理 （CRT）信息值的RSA多权限私钥的接口。
      interface  RSAPrivateCrtKey
      使用 中国剩余定理 （CRT）信息值的PKCS＃1标准中定义的RSA私钥的接口。
      interface  RSAPrivateKey
      RSA私钥的接口。
      interface  RSAPublicKey
      与RSA公钥的接口。

    • Uses of Key in javax.crypto

      Subinterfaces of Key in javax.crypto
      Modifier and Type 接口 描述
      interface  SecretKey
      一个秘密（对称）键。
      Methods in javax.crypto that return Key
      Modifier and Type 方法 描述
      Key KeyAgreement.doPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      protected abstract Key KeyAgreementSpi.engineDoPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      protected Key CipherSpi.engineUnwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
      打开以前包装的钥匙。
      Key Cipher.unwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
      打开以前包装的钥匙。
      Methods in javax.crypto with parameters of type Key
      Modifier and Type 方法 描述
      Key KeyAgreement.doPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      protected abstract Key KeyAgreementSpi.engineDoPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      protected int CipherSpi.engineGetKeySize​(Key key)
      以位为单位返回给定键对象的键大小。
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, SecureRandom random)
      用密钥和随机源初始化此密码。
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key)
      使用密钥初始化此豁免机制。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      protected abstract void KeyAgreementSpi.engineInit​(Key key, SecureRandom random)
      用给定的密钥和随机源初始化这个密钥协商。
      protected abstract void KeyAgreementSpi.engineInit​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      protected abstract void MacSpi.engineInit​(Key key, AlgorithmParameterSpec params)
      用给定（秘密）密钥和算法参数初始化MAC。
      protected byte[] CipherSpi.engineWrap​(Key key)
      包裹钥匙
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, String providerName)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, Provider provider)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      Object SealedObject.getObject​(Key key)
      检索原始（封装）对象。
      Object SealedObject.getObject​(Key key, String provider)
      检索原始（封装）对象。
      void Cipher.init​(int opmode, Key key)
      用密钥初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void Cipher.init​(int opmode, Key key, SecureRandom random)
      用密钥和随机源初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void ExemptionMechanism.init​(Key key)
      使用密钥初始化此豁免机制。
      void ExemptionMechanism.init​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      void ExemptionMechanism.init​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      void KeyAgreement.init​(Key key)
      使用给定的密钥初始化此密钥协议，该密钥需要包含此密钥协议所需的所有算法参数。
      void KeyAgreement.init​(Key key, SecureRandom random)
      用给定的密钥和随机源初始化这个密钥协商。
      void KeyAgreement.init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数集初始化此密钥协议。
      void KeyAgreement.init​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      void Mac.init​(Key key)
      使用给定的键初始化此 Mac对象。
      void Mac.init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数初始化此 Mac对象。
      boolean ExemptionMechanism.isCryptoAllowed​(Key key)
      返回此豁免机制是否已成功生成结果blob。
      byte[] Cipher.wrap​(Key key)
      包裹钥匙

    • Uses of Key in javax.crypto.interfaces

      Subinterfaces of Key in javax.crypto.interfaces
      Modifier and Type 接口 描述
      interface  DHPrivateKey
      与Diffie-Hellman私钥的接口。
      interface  DHPublicKey
      与Diffie-Hellman公钥的接口。
      interface  PBEKey
      与PBE密钥的接口。

    • Uses of Key in javax.crypto.spec

      Classes in javax.crypto.spec that implement Key
      Modifier and Type Class 描述
      class  SecretKeySpec
      该类以独立于提供商的方式指定密钥。

    • Uses of Key in javax.security.auth.kerberos

      Classes in javax.security.auth.kerberos that implement Key
      Modifier and Type Class 描述
      class  EncryptionKey
      此类封装了Kerberos中使用的EncryptionKey。
      class  KerberosKey
      该类封装了Kerberos主体的长期密钥。

    • Uses of Key in javax.xml.crypto

      Methods in javax.xml.crypto that return Key
      Modifier and Type 方法 描述
      Key KeySelectorResult.getKey​()
      返回所选的键。
      Methods in javax.xml.crypto with parameters of type Key
      Modifier and Type 方法 描述
      static KeySelector KeySelector.singletonKeySelector​(Key key)
      返回 KeySelector总是选择指定密钥，不管的 KeyInfo传递给它。

    • Uses of Key in javax.xml.crypto.dsig.dom

      Constructors in javax.xml.crypto.dsig.dom with parameters of type Key
      Constructor 描述
      DOMSignContext​(Key signingKey, Node parent)
      使用指定的签名密钥和父节点创建一个 DOMSignContext 。
      DOMSignContext​(Key signingKey, Node parent, Node nextSibling)
      使用指定的签名密钥，父节点和下一个兄弟节点创建一个 DOMSignContext 。
      DOMValidateContext​(Key validatingKey, Node node)
      创建一个包含指定的键和节点的 DOMValidateContext 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.KeyStore.Entry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.KeyStore.Entry

  • Packages that use KeyStore.Entry
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyStore.Entry in java.security

      Classes in java.security that implement KeyStore.Entry
      Modifier and Type Class 描述
      static class  KeyStore.PrivateKeyEntry
      A KeyStore条目，其中包含一个 PrivateKey和相应的证书链。
      static class  KeyStore.SecretKeyEntry
      A KeyStore条目，其中包含一个 SecretKey 。
      static class  KeyStore.TrustedCertificateEntry
      A KeyStore条目，其中包含受信任的 Certificate 。
      Methods in java.security that return KeyStore.Entry
      Modifier and Type 方法 描述
      KeyStore.Entry KeyStoreSpi.engineGetEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的 KeyStore.Entry 。
      KeyStore.Entry KeyStore.getEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的密钥库 Entry 。
      Methods in java.security with parameters of type KeyStore.Entry
      Modifier and Type 方法 描述
      void KeyStoreSpi.engineSetEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
      在指定的别名下保存一个 KeyStore.Entry 。
      void KeyStore.setEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
      保存指定别名下的密钥库 Entry 。
      Method parameters in java.security with type arguments of type KeyStore.Entry
      Modifier and Type 方法 描述
      boolean KeyStoreSpi.engineEntryInstanceOf​(String alias, Class<? extends KeyStore.Entry> entryClass)
      确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
      boolean KeyStore.entryInstanceOf​(String alias, Class<? extends KeyStore.Entry> entryClass)
      确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.KeyStore.Entry.Attribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.KeyStore.Entry.Attribute

  • Packages that use KeyStore.Entry.Attribute
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyStore.Entry.Attribute in java.security

      Classes in java.security that implement KeyStore.Entry.Attribute
      Modifier and Type Class 描述
      class  PKCS12Attribute
      与PKCS12密钥库条目关联的属性。
      Methods in java.security that return types with arguments of type KeyStore.Entry.Attribute
      Modifier and Type 方法 描述
      default Set<KeyStore.Entry.Attribute> KeyStore.Entry.getAttributes​()
      检索与条目关联的属性。
      Set<KeyStore.Entry.Attribute> KeyStore.PrivateKeyEntry.getAttributes​()
      检索与条目关联的属性。
      Set<KeyStore.Entry.Attribute> KeyStore.SecretKeyEntry.getAttributes​()
      检索与条目关联的属性。
      Set<KeyStore.Entry.Attribute> KeyStore.TrustedCertificateEntry.getAttributes​()
      检索与条目关联的属性。
      Constructor parameters in java.security with type arguments of type KeyStore.Entry.Attribute
      Constructor 描述
      PrivateKeyEntry​(PrivateKey privateKey, Certificate[] chain, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 PrivateKeyEntry与一个 PrivateKey和相应的证书链和相关的条目属性。
      SecretKeyEntry​(SecretKey secretKey, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 SecretKeyEntry ，具有 SecretKey和相关联的条目属性。
      TrustedCertificateEntry​(Certificate trustedCert, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 TrustedCertificateEntry与可信 Certificate及相关条目中的属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.KeyStore.LoadStoreParameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.KeyStore.LoadStoreParameter

  • Packages that use KeyStore.LoadStoreParameter
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyStore.LoadStoreParameter in java.security

      Classes in java.security that implement KeyStore.LoadStoreParameter
      Modifier and Type Class 描述
      class  DomainLoadStoreParameter
      指定密钥库中密钥库的配置数据。
      Methods in java.security with parameters of type KeyStore.LoadStoreParameter
      Modifier and Type 方法 描述
      void KeyStoreSpi.engineLoad​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParameter加载密钥库。
      void KeyStoreSpi.engineStore​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParmeter存储此密钥库。
      static KeyStore KeyStore.getInstance​(File file, KeyStore.LoadStoreParameter param)
      返回相应密钥库类型的加载密钥库对象。
      void KeyStore.load​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter加载此密钥库。
      void KeyStore.store​(KeyStore.LoadStoreParameter param)
      Stores this keystore using the given LoadStoreParameter.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.KeyStore.ProtectionParameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.KeyStore.ProtectionParameter

  • Packages that use KeyStore.ProtectionParameter
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of KeyStore.ProtectionParameter in java.security

      Classes in java.security that implement KeyStore.ProtectionParameter
      Modifier and Type Class 描述
      static class  KeyStore.CallbackHandlerProtection
      一个封装CallbackHandler的ProtectionParameter。
      static class  KeyStore.PasswordProtection
      基于密码的实现 ProtectionParameter 。
      Methods in java.security that return KeyStore.ProtectionParameter
      Modifier and Type 方法 描述
      KeyStore.ProtectionParameter DomainLoadStoreParameter.getProtectionParameter​()
      获取此域的密钥库保护参数。
      abstract KeyStore.ProtectionParameter KeyStore.Builder.getProtectionParameter​(String alias)
      返回应用于获取给定别名的Entry的ProtectionParameters。
      KeyStore.ProtectionParameter KeyStore.LoadStoreParameter.getProtectionParameter​()
      获取用于保护密钥库数据的参数。
      Methods in java.security that return types with arguments of type KeyStore.ProtectionParameter
      Modifier and Type 方法 描述
      Map<String,KeyStore.ProtectionParameter> DomainLoadStoreParameter.getProtectionParams​()
      获取此域中密钥库的密钥库保护参数。
      Methods in java.security with parameters of type KeyStore.ProtectionParameter
      Modifier and Type 方法 描述
      KeyStore.Entry KeyStoreSpi.engineGetEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的 KeyStore.Entry 。
      void KeyStoreSpi.engineSetEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
      在指定的别名下保存一个 KeyStore.Entry 。
      KeyStore.Entry KeyStore.getEntry​(String alias, KeyStore.ProtectionParameter protParam)
      获取具有指定保护参数的指定别名的密钥库 Entry 。
      static KeyStore.Builder KeyStore.Builder.newInstance​(File file, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder KeyStore.Builder.newInstance​(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder KeyStore.Builder.newInstance​(String type, Provider provider, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder KeyStore.Builder.newInstance​(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter)
      返回封装给定KeyStore的新Builder。
      void KeyStore.setEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
      在指定的别名下保存密钥库 Entry 。
      Constructor parameters in java.security with type arguments of type KeyStore.ProtectionParameter
      Constructor 描述
      DomainLoadStoreParameter​(URI configuration, Map<String,KeyStore.ProtectionParameter> protectionParams)
      使用用于保护密钥库数据的参数构建密钥库域的DomainLoadStoreParameter。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.Policy.Parameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.Policy.Parameters

  • Packages that use Policy.Parameters
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of Policy.Parameters in java.security

      Classes in java.security that implement Policy.Parameters
      Modifier and Type Class 描述
      class  URIParameter
      包含指向PolicySpi或ConfigurationSpi实现的数据的URI的参数。
      Methods in java.security that return Policy.Parameters
      Modifier and Type 方法 描述
      Policy.Parameters Policy.getParameters​()
      退货政策参数。
      Methods in java.security with parameters of type Policy.Parameters
      Modifier and Type 方法 描述
      static Policy Policy.getInstance​(String type, Policy.Parameters params)
      返回指定类型的Policy对象。
      static Policy Policy.getInstance​(String type, Policy.Parameters params, String provider)
      返回指定类型的Policy对象。
      static Policy Policy.getInstance​(String type, Policy.Parameters params, Provider provider)
      返回指定类型的Policy对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.Principal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.Principal

  • Packages that use Principal
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.security.auth
    提供Principal的实现。
    java.net
    提供实现网络应用程序的类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    javax.security.cert
    提供公钥证书类。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。

    • Uses of Principal in com.sun.net.httpserver

      Classes in com.sun.net.httpserver that implement Principal
      Modifier and Type Class 描述
      class  HttpPrincipal
      表示通过HTTP Basic或Digest身份验证身份验证的用户。

    • Uses of Principal in com.sun.security.auth

      Classes in com.sun.security.auth that implement Principal
      Modifier and Type Class 描述
      class  LdapPrincipal
      由 RFC 2253指定的专有名称确定的 主体 。
      class  NTDomainPrincipal
      该类实现了 Principal接口，并表示用户认证的Windows NT域的名称。
      class  NTSid
      此类实现 Principal接口，并表示有关Windows NT用户，组或领域的信息。
      class  NTSidDomainPrincipal
      此类扩展为 NTSid ，表示Windows NT用户的域SID。
      class  NTSidGroupPrincipal
      该类扩展了 NTSid ，代表Windows NT用户所属的组之一。
      class  NTSidPrimaryGroupPrincipal
      此类扩展为 NTSid ，表示Windows NT用户的主组SID。
      class  NTSidUserPrincipal
      此类扩展为 NTSid ，表示Windows NT用户的SID。
      class  NTUserPrincipal
      该类实现了 Principal接口，代表了Windows NT用户。
      class  SolarisNumericGroupPrincipal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由UnixNumericGroupPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  SolarisNumericUserPrincipal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由UnixNumericUserPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  SolarisPrincipal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由UnixPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  UnixNumericGroupPrincipal
      该类实现 Principal接口，代表用户的Unix组标识号（GID）。
      class  UnixNumericUserPrincipal
      该类实现 Principal接口，代表用户的Unix标识号（UID）。
      class  UnixPrincipal
      该类实现了 Principal接口，代表了Unix用户。
      class  UserPrincipal
      由用户名或帐户名称标识的用户主体。
      class  X500Principal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      Java平台中提供了一个新的X500Principal类。 这个X500Principal类完全被弃用，这里允许平滑过渡到新类。 此类可能在将来的Java SE版本中被删除。

    • Uses of Principal in java.net

      Methods in java.net that return Principal
      Modifier and Type 方法 描述
      abstract Principal SecureCacheResponse.getLocalPrincipal​()
      返回在检索网络资源的原始连接中握手期间发送到服务器的主体。
      abstract Principal SecureCacheResponse.getPeerPrincipal​()
      返回作为在检索网络资源的原始连接期间定义会话的一部分而建立的服务器的主体。

    • Uses of Principal in java.nio.file.attribute

      Subinterfaces of Principal in java.nio.file.attribute
      Modifier and Type 接口 描述
      interface  GroupPrincipal
      A UserPrincipal表示 组身份 ，用于确定文件系统中对象的访问权限。
      interface  UserPrincipal
      A Principal表示用于确定文件系统中对象的访问权限的身份。

    • Uses of Principal in java.security

      Classes in java.security that implement Principal
      Modifier and Type Class 描述
      class  Identity
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      class  IdentityScope
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      class  Signer
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      Methods in java.security that return Principal
      Modifier and Type 方法 描述
      Principal Certificate.getGuarantor​()
      已过时。
      返回证书的担保人，即与该证书相关联的公钥与该证书相关联的主体的主体。
      Principal Certificate.getPrincipal​()
      已过时。
      返回担保人担保的主 - 对对的本金。
      Principal[] ProtectionDomain.getPrincipals​()
      返回此域的主体数组。
      Methods in java.security with parameters of type Principal
      Modifier and Type 方法 描述
      Identity IdentityScope.getIdentity​(Principal principal)
      已过时。
      检索其名称与指定的主体相同的身份。
      Constructors in java.security with parameters of type Principal
      Constructor 描述
      ProtectionDomain​(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
      创建一个由给定的CodeSource，Permissions，ClassLoader和Principals数组限定的新的ProtectionDomain。

    • Uses of Principal in java.security.acl

      Subinterfaces of Principal in java.security.acl
      Modifier and Type 接口 描述
      interface  Group
      已过时。
      自1.2版起，该软件包已被java.security.Policy及相关课程所取代。
      Methods in java.security.acl that return Principal
      Modifier and Type 方法 描述
      Principal AclEntry.getPrincipal​()
      已过时。
      返回此ACL条目授予或拒绝权限的主体。
      Methods in java.security.acl that return types with arguments of type Principal
      Modifier and Type 方法 描述
      Enumeration<? extends Principal> Group.members​()
      已过时。
      返回组中成员的枚举。
      Methods in java.security.acl with parameters of type Principal
      Modifier and Type 方法 描述
      boolean Acl.addEntry​(Principal caller, AclEntry entry)
      已过时。
      向此ACL添加ACL条目。
      boolean Group.addMember​(Principal user)
      已过时。
      将指定的成员添加到组中。
      boolean Owner.addOwner​(Principal caller, Principal owner)
      已过时。
      添加所有者。
      boolean Acl.checkPermission​(Principal principal, Permission permission)
      已过时。
      检查指定的委托人是否具有指定的权限。
      boolean Owner.deleteOwner​(Principal caller, Principal owner)
      已过时。
      删除所有者。
      Enumeration<Permission> Acl.getPermissions​(Principal user)
      已过时。
      返回指定主体的一组允许权限的枚举（表示一个实体，如个人或组）。
      boolean Group.isMember​(Principal member)
      已过时。
      如果传递的主体是组的成员，则返回true。
      boolean Owner.isOwner​(Principal owner)
      已过时。
      如果给定的主体是ACL的所有者，则返回true。
      boolean Acl.removeEntry​(Principal caller, AclEntry entry)
      已过时。
      从此ACL中删除ACL条目。
      boolean Group.removeMember​(Principal user)
      已过时。
      从组中删除指定的成员。
      void Acl.setName​(Principal caller, String name)
      已过时。
      设置此ACL的名称。
      boolean AclEntry.setPrincipal​(Principal user)
      已过时。
      指定此ACL条目授予或拒绝权限的主体。

    • Uses of Principal in java.security.cert

      Methods in java.security.cert that return Principal
      Modifier and Type 方法 描述
      abstract Principal X509Certificate.getIssuerDN​()
      诋毁 ，取而代之的是 X509Certificate.getIssuerX500Principal() 。
      abstract Principal X509CRL.getIssuerDN​()
      诋毁 ，取而代之的是 X509CRL.getIssuerX500Principal() 。
      abstract Principal X509Certificate.getSubjectDN​()
      诋毁 ，取而代之的是 X509Certificate.getSubjectX500Principal() 。

    • Uses of Principal in javax.management.remote

      Classes in javax.management.remote that implement Principal
      Modifier and Type Class 描述
      class  JMXPrincipal
      JMX Remote API的远程客户端的身份。

    • Uses of Principal in javax.net.ssl

      Methods in javax.net.ssl that return Principal
      Modifier and Type 方法 描述
      Principal HandshakeCompletedEvent.getLocalPrincipal​()
      返回在握手期间发送给对等体的主体。
      Principal HttpsURLConnection.getLocalPrincipal​()
      返回在握手期间发送到服务器的主体。
      Principal SSLSession.getLocalPrincipal​()
      返回在握手期间发送给对等体的主体。
      Principal HandshakeCompletedEvent.getPeerPrincipal​()
      返回作为定义会话的一部分而建立的对等体的身份。
      Principal HttpsURLConnection.getPeerPrincipal​()
      返回作为定义会话的一部分而建立的服务器的主体。
      Principal SSLSession.getPeerPrincipal​()
      返回作为定义会话的一部分而建立的对等体的身份。
      Methods in javax.net.ssl with parameters of type Principal
      Modifier and Type 方法 描述
      String X509KeyManager.chooseClientAlias​(String[] keyType, Principal[] issuers, Socket socket)
      选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，来认证安全套接字的客户端。
      String X509ExtendedKeyManager.chooseEngineClientAlias​(String[] keyType, Principal[] issuers, SSLEngine engine)
      选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表，鉴定 SSLEngine连接的客户端。
      String X509ExtendedKeyManager.chooseEngineServerAlias​(String keyType, Principal[] issuers, SSLEngine engine)
      选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，鉴定 SSLEngine连接的服务器端。
      String X509KeyManager.chooseServerAlias​(String keyType, Principal[] issuers, Socket socket)
      选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，对安全套接字的服务器端进行身份验证。
      String[] X509KeyManager.getClientAliases​(String keyType, Principal[] issuers)
      获取匹配的别名，用于鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表的身份验证安全套接字的客户端。
      String[] X509KeyManager.getServerAliases​(String keyType, Principal[] issuers)
      获取匹配的别名，用于鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表的身份验证安全套接字的服务器端。

    • Uses of Principal in javax.security.auth

      Methods in javax.security.auth with type parameters of type Principal
      Modifier and Type 方法 描述
      <T extends Principal>
      Set<T>             		Subject.getPrincipals​(Class<T> c)
      返回 Set与此关联的Principal Subject是实例或指定的子类 Class 。
      Methods in javax.security.auth that return types with arguments of type Principal
      Modifier and Type 方法 描述
      Set<Principal> Subject.getPrincipals​()
      返回 Set与此相关的校长 Subject 。
      Constructor parameters in javax.security.auth with type arguments of type Principal
      Constructor 描述
      Subject​(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
      使用主体和凭据创建一个 Subject的实例。

    • Uses of Principal in javax.security.auth.kerberos

      Classes in javax.security.auth.kerberos that implement Principal
      Modifier and Type Class 描述
      class  KerberosPrincipal
      这个类封装了一个Kerberos主体。

    • Uses of Principal in javax.security.auth.x500

      Classes in javax.security.auth.x500 that implement Principal
      Modifier and Type Class 描述
      class  X500Principal
      这个类代表X.500 Principal 。

    • Uses of Principal in javax.security.cert

      Methods in javax.security.cert that return Principal
      Modifier and Type 方法 描述
      abstract Principal X509Certificate.getIssuerDN​()
      已过时。
      从证书中获取 issuer （发行人可分辨名称）值。
      abstract Principal X509Certificate.getSubjectDN​()
      已过时。
      从证书中获取 subject （主题可分辨名称）值。

    • Uses of Principal in javax.xml.ws

      Methods in javax.xml.ws that return Principal
      Modifier and Type 方法 描述
      Principal WebServiceContext.getUserPrincipal​()
      返回标识当前正在处理的请求的发件人的Principal。

    • Uses of Principal in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return Principal
      Modifier and Type 方法 描述
      abstract Principal HttpExchange.getUserPrincipal​()
      返回Principal ，表示此身份验证的用户HttpExchange 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.PrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.PrivateKey

  • Packages that use PrivateKey
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    jdk.security.jarsigner

    • Uses of PrivateKey in java.security

      Methods in java.security that return PrivateKey
      Modifier and Type 方法 描述
      protected abstract PrivateKey KeyFactorySpi.engineGeneratePrivate​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成私钥对象。
      PrivateKey KeyFactory.generatePrivate​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成私钥对象。
      PrivateKey KeyPair.getPrivate​()
      返回对此密钥对的私钥组件的引用。
      PrivateKey KeyStore.PrivateKeyEntry.getPrivateKey​()
      从此条目获取 PrivateKey 。
      PrivateKey Signer.getPrivateKey​()
      已过时。
      返回此签名者的私钥。
      Methods in java.security with parameters of type PrivateKey
      Modifier and Type 方法 描述
      protected abstract void SignatureSpi.engineInitSign​(PrivateKey privateKey)
      使用指定的私钥初始化此签名对象进行签名操作。
      protected void SignatureSpi.engineInitSign​(PrivateKey privateKey, SecureRandom random)
      使用指定的私钥和签名操作的随机源初始化此签名对象。
      void Signature.initSign​(PrivateKey privateKey)
      初始化此对象进行签名。
      void Signature.initSign​(PrivateKey privateKey, SecureRandom random)
      初始化此对象进行签名。
      Constructors in java.security with parameters of type PrivateKey
      Constructor 描述
      KeyPair​(PublicKey publicKey, PrivateKey privateKey)
      从给定的公钥和私钥构造一个密钥对。
      PrivateKeyEntry​(PrivateKey privateKey, Certificate[] chain)
      构建一个 PrivateKeyEntry与 PrivateKey及相应的证书链。
      PrivateKeyEntry​(PrivateKey privateKey, Certificate[] chain, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 PrivateKeyEntry其中包含 PrivateKey及相应的证书链和相关的条目属性。
      SignedObject​(Serializable object, PrivateKey signingKey, Signature signingEngine)
      从任何可序列化对象构造一个SignedObject。

    • Uses of PrivateKey in java.security.interfaces

      Subinterfaces of PrivateKey in java.security.interfaces
      Modifier and Type 接口 描述
      interface  DSAPrivateKey
      DSA私钥的标准接口。
      interface  ECPrivateKey
      椭圆曲线（EC）私钥的界面。
      interface  RSAMultiPrimePrivateCrtKey
      与PKCS＃1 v2.1中定义的使用 中国剩余定理 （CRT）信息值的RSA多权限私钥的接口。
      interface  RSAPrivateCrtKey
      使用 中国剩余定理 （CRT）信息值的PKCS＃1标准中定义的RSA私钥的接口。
      interface  RSAPrivateKey
      RSA私钥的接口。

    • Uses of PrivateKey in javax.crypto.interfaces

      Subinterfaces of PrivateKey in javax.crypto.interfaces
      Modifier and Type 接口 描述
      interface  DHPrivateKey
      与Diffie-Hellman私钥的接口。

    • Uses of PrivateKey in javax.net.ssl

      Methods in javax.net.ssl that return PrivateKey
      Modifier and Type 方法 描述
      PrivateKey X509KeyManager.getPrivateKey​(String alias)
      返回与给定别名相关联的键。

    • Uses of PrivateKey in javax.security.auth.x500

      Methods in javax.security.auth.x500 that return PrivateKey
      Modifier and Type 方法 描述
      PrivateKey X500PrivateCredential.getPrivateKey​()
      返回PrivateKey。
      Constructors in javax.security.auth.x500 with parameters of type PrivateKey
      Constructor 描述
      X500PrivateCredential​(X509Certificate cert, PrivateKey key)
      创建X500PrivateCredential，它将X.509证书，私钥和KeyStore别名相关联。
      X500PrivateCredential​(X509Certificate cert, PrivateKey key, String alias)
      创建X500PrivateCredential，它将X.509证书，私钥和KeyStore别名相关联。

    • Uses of PrivateKey in jdk.security.jarsigner

      Methods in jdk.security.jarsigner with parameters of type PrivateKey
      Modifier and Type 方法 描述
      static String JarSigner.Builder.getDefaultSignatureAlgorithm​(PrivateKey key)
      获取私钥的默认签名算法。
      Constructors in jdk.security.jarsigner with parameters of type PrivateKey
      Constructor 描述
      Builder​(PrivateKey privateKey, CertPath certPath)
      Creates a JarSigner.Builder object with a private key and a certification path.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.PrivilegedAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.PrivilegedAction

  • Packages that use PrivilegedAction
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javax.security.auth
    此软件包提供了认证和授权的框架。

    • Uses of PrivilegedAction in java.security

      Methods in java.security with parameters of type PrivilegedAction
      Modifier and Type 方法 描述
      static <T> T AccessController.doPrivileged​(PrivilegedAction<T> action)
      执行指定的 PrivilegedAction启用特权。
      static <T> T AccessController.doPrivileged​(PrivilegedAction<T> action, AccessControlContext context)
      执行指定的 PrivilegedAction ，其特权被启用并受指定的 AccessControlContext限制。
      static <T> T AccessController.doPrivileged​(PrivilegedAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedAction<T> action)
      执行指定的 PrivilegedAction启用特权。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受限于指定的 Permission参数。

    • Uses of PrivilegedAction in java.util.concurrent

      Methods in java.util.concurrent with parameters of type PrivilegedAction
      Modifier and Type 方法 描述
      static Callable<Object> Executors.callable​(PrivilegedAction<?> action)
      返回一个Callable对象，该对象在被调用时运行给定的特权操作并返回其结果。

    • Uses of PrivilegedAction in javax.security.auth

      Methods in javax.security.auth with parameters of type PrivilegedAction
      Modifier and Type 方法 描述
      static <T> T Subject.doAs​(Subject subject, PrivilegedAction<T> action)
      执行工作作为一个特定的 Subject 。
      static <T> T Subject.doAsPrivileged​(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
      作为一个特定的 Subject执行特权工作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.PrivilegedExceptionAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.PrivilegedExceptionAction

  • Packages that use PrivilegedExceptionAction
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javax.security.auth
    此软件包提供了认证和授权的框架。

    • Uses of PrivilegedExceptionAction in java.security

      Methods in java.security with parameters of type PrivilegedExceptionAction
      Modifier and Type 方法 描述
      static <T> T AccessController.doPrivileged​(PrivilegedExceptionAction<T> action)
      执行指定的 PrivilegedExceptionAction启用特权。
      static <T> T AccessController.doPrivileged​(PrivilegedExceptionAction<T> action, AccessControlContext context)
      执行指定的 PrivilegedExceptionAction具有启用并受指定的 AccessControlContext限制的特权。
      static <T> T AccessController.doPrivileged​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action)
      执行指定的 PrivilegedExceptionAction启用特权。
      static <T> T AccessController.doPrivilegedWithCombiner​(PrivilegedExceptionAction<T> action, AccessControlContext context, Permission... perms)
      执行指定的 PrivilegedExceptionAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。

    • Uses of PrivilegedExceptionAction in java.util.concurrent

      Methods in java.util.concurrent with parameters of type PrivilegedExceptionAction
      Modifier and Type 方法 描述
      static Callable<Object> Executors.callable​(PrivilegedExceptionAction<?> action)
      返回一个Callable对象，当被调用时，它运行给定的特权异常操作并返回其结果。

    • Uses of PrivilegedExceptionAction in javax.security.auth

      Methods in javax.security.auth with parameters of type PrivilegedExceptionAction
      Modifier and Type 方法 描述
      static <T> T Subject.doAs​(Subject subject, PrivilegedExceptionAction<T> action)
      执行工作作为一个特定的 Subject 。
      static <T> T Subject.doAsPrivileged​(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
      作为一个特殊的 Subject执行特权工作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.PublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.PublicKey

  • Packages that use PublicKey
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.security.cert
    提供公钥证书类。
    javax.xml.crypto.dsig.keyinfo
    用于解析和处理KeyInfo元素和结构的类。

    • Uses of PublicKey in java.security

      Methods in java.security that return PublicKey
      Modifier and Type 方法 描述
      protected abstract PublicKey KeyFactorySpi.engineGeneratePublic​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成公钥对象。
      PublicKey KeyFactory.generatePublic​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成公钥对象。
      PublicKey KeyPair.getPublic​()
      返回对此密钥对的公钥组件的引用。
      PublicKey Certificate.getPublicKey​()
      已过时。
      返回担保人保证的主 - 关键对的关键字。
      PublicKey Identity.getPublicKey​()
      已过时。
      返回此身份的公钥。
      Methods in java.security with parameters of type PublicKey
      Modifier and Type 方法 描述
      protected abstract void SignatureSpi.engineInitVerify​(PublicKey publicKey)
      使用指定的公钥初始化此签名对象进行验证操作。
      abstract Identity IdentityScope.getIdentity​(PublicKey key)
      已过时。
      使用指定的公钥检索身份。
      void Signature.initVerify​(PublicKey publicKey)
      初始化此对象进行验证。
      void Identity.setPublicKey​(PublicKey key)
      已过时。
      设置此身份的公钥。
      boolean SignedObject.verify​(PublicKey verificationKey, Signature verificationEngine)
      验证此SignedObject中的签名是使用指定的验证引擎使用给定的验证密钥存储在其中的对象的有效签名。
      Constructors in java.security with parameters of type PublicKey
      Constructor 描述
      KeyPair​(PublicKey publicKey, PrivateKey privateKey)
      从给定的公钥和私钥构造一个密钥对。

    • Uses of PublicKey in java.security.cert

      Methods in java.security.cert that return PublicKey
      Modifier and Type 方法 描述
      PublicKey TrustAnchor.getCAPublicKey​()
      返回最受信任的CA的公钥。
      abstract PublicKey Certificate.getPublicKey​()
      从此证书获取公钥。
      PublicKey PKIXCertPathValidatorResult.getPublicKey​()
      返回认证路径的主题（目标）的公钥，包括任何继承的公钥参数（如果适用）。
      PublicKey X509CertSelector.getSubjectPublicKey​()
      返回subjectPublicKey标准。
      Methods in java.security.cert with parameters of type PublicKey
      Modifier and Type 方法 描述
      void X509CertSelector.setSubjectPublicKey​(PublicKey key)
      设置subjectPublicKey标准。
      abstract void Certificate.verify​(PublicKey key)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      void X509Certificate.verify​(PublicKey key, Provider sigProvider)
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void X509CRL.verify​(PublicKey key)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      abstract void X509CRL.verify​(PublicKey key, String sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      void X509CRL.verify​(PublicKey key, Provider sigProvider)
      验证此CRL是否使用与给定公钥对应的私钥进行签名。
      Constructors in java.security.cert with parameters of type PublicKey
      Constructor 描述
      PKIXCertPathBuilderResult​(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
      创建包含指定参数的 PKIXCertPathBuilderResult实例。
      PKIXCertPathValidatorResult​(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
      创建包含指定参数的 PKIXCertPathValidatorResult实例。
      TrustAnchor​(String caName, PublicKey pubKey, byte[] nameConstraints)
      创建一个 TrustAnchor的实例，其中最受信任的CA被指定为可分辨名称和公钥。
      TrustAnchor​(X500Principal caPrincipal, PublicKey pubKey, byte[] nameConstraints)
      创建一个 TrustAnchor的实例，其中最受信任的CA被指定为X500Principal和公钥。

    • Uses of PublicKey in java.security.interfaces

      Subinterfaces of PublicKey in java.security.interfaces
      Modifier and Type 接口 描述
      interface  DSAPublicKey
      DSA公钥的接口。
      interface  ECPublicKey
      椭圆曲线（EC）公钥的界面。
      interface  RSAPublicKey
      与RSA公钥的接口。

    • Uses of PublicKey in javax.crypto.interfaces

      Subinterfaces of PublicKey in javax.crypto.interfaces
      Modifier and Type 接口 描述
      interface  DHPublicKey
      与Diffie-Hellman公钥的接口。

    • Uses of PublicKey in javax.security.cert

      Methods in javax.security.cert that return PublicKey
      Modifier and Type 方法 描述
      abstract PublicKey Certificate.getPublicKey​()
      已过时。
      从此证书获取公钥。
      Methods in javax.security.cert with parameters of type PublicKey
      Modifier and Type 方法 描述
      abstract void Certificate.verify​(PublicKey key)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。
      abstract void Certificate.verify​(PublicKey key, String sigProvider)
      已过时。
      使用与指定公钥对应的私钥验证此证书是否已经签名。

    • Uses of PublicKey in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return PublicKey
      Modifier and Type 方法 描述
      PublicKey KeyValue.getPublicKey​()
      返回此 KeyValue 。
      Methods in javax.xml.crypto.dsig.keyinfo with parameters of type PublicKey
      Modifier and Type 方法 描述
      abstract KeyValue KeyInfoFactory.newKeyValue​(PublicKey key)
      Creates a KeyValue from the specified public key.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.SecureRandomParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.SecureRandomParameters

  • Packages that use SecureRandomParameters
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of SecureRandomParameters in java.security

      Classes in java.security that implement SecureRandomParameters
      Modifier and Type Class 描述
      static class  DrbgParameters.Instantiation
      用于实例化的DRBG参数。
      static class  DrbgParameters.NextBytes
      用于随机位生成的DRBG参数。
      static class  DrbgParameters.Reseed
      重新植入的DRBG参数。
      Methods in java.security that return SecureRandomParameters
      Modifier and Type 方法 描述
      protected SecureRandomParameters SecureRandomSpi.engineGetParameters​()
      返回此SecureRandom实例的有效SecureRandomParameters 。
      SecureRandomParameters SecureRandom.getParameters​()
      返回此SecureRandom实例的有效SecureRandomParameters 。
      Methods in java.security with parameters of type SecureRandomParameters
      Modifier and Type 方法 描述
      protected void SecureRandomSpi.engineNextBytes​(byte[] bytes, SecureRandomParameters params)
      使用附加参数生成用户指定的随机字节数。
      protected void SecureRandomSpi.engineReseed​(SecureRandomParameters params)
      使用附加参数从熵源读取熵输入来重新获得该随机对象。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, String provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      static SecureRandom SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, Provider provider)
      返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。
      void SecureRandom.nextBytes​(byte[] bytes, SecureRandomParameters params)
      使用附加参数生成用户指定的随机字节数。
      void SecureRandom.reseed​(SecureRandomParameters params)
      使用其附加参数从其熵源中读取熵输入来获得此 SecureRandom 。
      Constructors in java.security with parameters of type SecureRandomParameters
      Constructor 描述
      SecureRandomSpi​(SecureRandomParameters params)
      具有参数的构造方法
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


DSAKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface DSAKey

  • All Known Subinterfaces:
    DSAPrivateKey ， DSAPublicKey

    public interface DSAKey
    DSA公钥或私钥的接口。 DSA（数字签名算法）在NIST的FIPS-186中定义。
    从以下版本开始：
    1.1
    另请参见：
    DSAParams ， Key ， Signature

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      DSAParams getParams​()
      返回特定于DSA的关键参数。

    • 方法详细信息

      • getParams

        DSAParams getParams​()
        返回特定于DSA的关键参数。 这些参数绝对不是秘密的。
        结果
        DSA特定的关键参数。
        另请参见：
        DSAParams
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DSAKeyPairGenerator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface DSAKeyPairGenerator

  • public interface DSAKeyPairGenerator
    与能够生成DSA密钥对的对象的接口。

    initialize方法可以分别被称为任意次数。 如果在DSAKeyPairGenerator上没有initialize方法，则默认使用预先计算的p，q和g参数以及SecureRandom的实例作为随机位源来生成1024位密钥。

    用户希望指定特定于DSA的参数，并生成适用于DSA算法的密钥对

    1. 通过调用具有“DSA”作为参数的KeyPairGenerator getInstance方法，获取DSA算法的密钥对生成器。
    2. 通过将结果转换为DSAKeyPairGenerator并从该DSAKeyPairGenerator接口调用initialize方法之一来初始化生成器。
    3. 通过从KeyPairGenerator类调用generateKeyPair方法生成密钥对。

    注意：并不总是需要为DSA密钥对生成器执行特定于算法的初始化。 也就是说，在此界面中并不总是需要调用initialize方法。 当您接受特定于算法的参数的默认值时，使用KeyPairGenerator接口中的initialize方法进行无算法独立初始化。

    注意：此接口的一些早期实现可能不支持较大尺寸的DSA参数，例如2048和3072位。

    从以下版本开始：
    1.1
    另请参见：
    KeyPairGenerator

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void initialize​(int modlen, boolean genParams, SecureRandom random)
      为给定的模数长度（而不是参数）初始化密钥对生成器以及可选的SecureRandom位源。
      void initialize​(DSAParams params, SecureRandom random)
      使用DSA系列参数（p，q和g）和可选的SecureRandom位源初始化密钥对生成器。

    • 方法详细信息

      • initialize

        void initialize​(DSAParams params,
                SecureRandom random)
         throws InvalidParameterException
        使用DSA系列参数（p，q和g）和可选的SecureRandom位源初始化密钥对生成器。 如果需要SecureRandom位源，但不提供，即为null，则将使用默认的SecureRandom实例。
        参数
        params - 用于生成密钥的参数。
        random - 用于生成密钥位的随机位源; 可以为空。
        异常
        InvalidParameterException - 如果 params值无效，为空或不受支持。

      • initialize

        void initialize​(int modlen,
                boolean genParams,
                SecureRandom random)
         throws InvalidParameterException
        为给定的模数长度（而不是参数）初始化密钥对生成器以及可选的SecureRandom位源。 如果需要SecureRandom位源，但不提供，即为null，则将使用默认的SecureRandom实例。

        如果genParams为真，则该方法生成新的p，q和g参数。 如果为假，则该方法使用预计算参数作为所要求的模数长度。 如果该模数长度没有预先计算的参数，将抛出异常。 保证模数长度为512和1024位的默认参数始终保持不变。

        参数
        modlen - 模数长度（以位为单位）。 有效值是512到1024之间，包括2048和3072之间的64的任何倍数。
        random - 用于生成密钥位的随机位源; 可以为空。
        genParams - 是否为所要求的模数长度生成新参数。
        异常
        InvalidParameterException - 如果 modlen无效或不受支持，或者如果 genParams为假，并且所请求的模数长度没有预先计算的参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DSAParams (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface DSAParams

  • 所有已知实现类：
    DSAParameterSpec

    public interface DSAParams
    与DSA特定的关键参数集的接口，定义了DSA 密钥族 。 DSA（数字签名算法）在NIST的FIPS-186中定义。
    从以下版本开始：
    1.1
    另请参见：
    DSAKey ， Key ， Signature

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getG​()
      返回基数 g 。
      BigInteger getP​()
      返回素数， p 。
      BigInteger getQ​()
      返回次贷， q 。

    • 方法详细信息

      • getP

        BigInteger getP​()
        返回素数， p 。
        结果
        主要， p 。

      • getQ

        BigInteger getQ​()
        返回次贷， q 。
        结果
        次贷 q 。

      • getG

        BigInteger getG​()
        返回底座， g 。
        结果
        the base, g.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DSAPrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface DSAPrivateKey

  • All Superinterfaces:
    Destroyable ， DSAKey ， Key ， PrivateKey ， Serializable

    public interface DSAPrivateKey
extends DSAKey, PrivateKey
    DSA私钥的标准接口。 DSA（数字签名算法）在NIST的FIPS-186中定义。
    从以下版本开始：
    1.1
    另请参见：
    Key ， Signature ， DSAKey ， DSAPublicKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      类指纹被设置为指示与以前版本的类的序列化兼容性。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getX​()
      返回私钥的值， x 。

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from interface java.security.interfaces.DSAKey

        getParams

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        类指纹被设置为指示与以前版本的类的序列化兼容性。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getX

        BigInteger getX​()
        返回私钥的值， x 。
        结果
        私钥的值， x 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DSAPublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface DSAPublicKey

  • All Superinterfaces:
    DSAKey ， Key ， PublicKey ， Serializable

    public interface DSAPublicKey
extends DSAKey, PublicKey
    DSA公钥的接口。 DSA（数字签名算法）在NIST的FIPS-186中定义。
    从以下版本开始：
    1.1
    另请参见：
    Key ， Signature ， DSAKey ， DSAPrivateKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      类指纹被设置为指示与以前版本的类的序列化兼容性。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getY​()
      返回公钥的值， y 。

      • Methods inherited from interface java.security.interfaces.DSAKey

        getParams

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        类指纹被设置为指示与以前版本的类的序列化兼容性。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getY

        BigInteger getY​()
        返回公钥的值， y 。
        结果
        公钥的值， y 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ECKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface ECKey

  • All Known Subinterfaces:
    ECPrivateKey ， ECPublicKey

    public interface ECKey
    椭圆曲线（EC）键的界面。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ECParameterSpec getParams​()
      返回与此关键字关联的域参数。

    • 方法详细信息

      • getParams

        ECParameterSpec getParams​()
        返回与此关键字关联的域参数。 域参数是在密钥生成过程中明确指定或隐式创建的。
        结果
        相关联的域参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ECPrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface ECPrivateKey

  • All Superinterfaces:
    Destroyable ， ECKey ， Key ， PrivateKey ， Serializable

    public interface ECPrivateKey
extends PrivateKey, ECKey
    椭圆曲线（EC）私钥的界面。
    从以下版本开始：
    1.5
    另请参见：
    PrivateKey ， ECKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      设置为指示序列化兼容性的类指纹。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getS​()
      返回私有值S.

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from interface java.security.interfaces.ECKey

        getParams

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        设置为指示序列化兼容性的类指纹。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getS

        BigInteger getS​()
        返回私有值S.
        结果
        私人价值S.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ECPublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface ECPublicKey

  • All Superinterfaces:
    ECKey ， Key ， PublicKey ， Serializable

    public interface ECPublicKey
extends PublicKey, ECKey
    椭圆曲线（EC）公钥的界面。
    从以下版本开始：
    1.5
    另请参见：
    PublicKey ， ECKey ， ECPoint

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      设置为指示序列化兼容性的类指纹。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ECPoint getW​()
      返回公共点W.

      • Methods inherited from interface java.security.interfaces.ECKey

        getParams

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        设置为指示序列化兼容性的类指纹。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getW

        ECPoint getW​()
        返回公共点W.
        结果
        公共点W.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


java.security.interfaces (Java SE 9 & JDK 9 )

java.security.interfaces

Interfaces

  • DSAKey
  • DSAKeyPairGenerator
  • DSAParams
  • DSAPrivateKey
  • DSAPublicKey
  • ECKey
  • ECPrivateKey
  • ECPublicKey
  • RSAKey
  • RSAMultiPrimePrivateCrtKey
  • RSAPrivateCrtKey
  • RSAPrivateKey
  • RSAPublicKey


java.security.interfaces (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.security.interfaces

提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。

请注意，这些接口仅适用于密钥实现，其密钥资料可访问和可用。 这些接口不适用于其密钥材料驻留在不可访问的受保护存储（如硬件设备）中的密钥实现。

有关如何使用这些界面的更多开发者信息，包括有关如何为硬件设备设计Key类的信息，请参阅这些加密提供程序开发人员指南：

  • How to Implement a Provider in the Java Cryptography Architecture

包装规格

  • PKCS＃1：RSA加密标准版本1.5，1993年11月
  • 联邦信息处理标准出版物（FIPS PUB）186：数字签名标准（DSS）

相关文档

有关进一步的文档，请参阅：
  • {extLink security_guide_jca Java加密体系结构参考指南}
从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    DSAKey
    DSA公钥或私钥的接口。
    DSAKeyPairGenerator
    与能够生成DSA密钥对的对象的接口。
    DSAParams
    与DSA特定的关键参数集的接口，定义了DSA 密钥族 。
    DSAPrivateKey
    DSA私钥的标准接口。
    DSAPublicKey
    DSA公钥的接口。
    ECKey
    椭圆曲线（EC）键的界面。
    ECPrivateKey
    椭圆曲线（EC）私钥的界面。
    ECPublicKey
    椭圆曲线（EC）公钥的界面。
    RSAKey
    与RSA公钥或私钥的接口。
    RSAMultiPrimePrivateCrtKey
    与PKCS＃1 v2.1中定义的使用 中国剩余定理 （CRT）信息值的RSA多权限私钥的接口。
    RSAPrivateCrtKey
    使用 中国剩余定理 （CRT）信息值的PKCS＃1标准中定义的RSA私钥的接口。
    RSAPrivateKey
    RSA私钥的接口。
    RSAPublicKey
    与RSA公钥的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.security.interfaces Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.security.interfaces

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.security.auth.Destroyable
    • java.security.PrivateKey (also extends java.security.Key)
      • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey)
      • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey)
      • java.security.interfaces.RSAPrivateKey (also extends java.security.interfaces.RSAKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
  • java.security.interfaces.DSAKey
    • java.security.interfaces.DSAPrivateKey (also extends java.security.PrivateKey)
    • java.security.interfaces.DSAPublicKey (also extends java.security.PublicKey)
  • java.security.interfaces.DSAKeyPairGenerator
  • java.security.interfaces.DSAParams
  • java.security.interfaces.ECKey
    • java.security.interfaces.ECPrivateKey (also extends java.security.PrivateKey)
    • java.security.interfaces.ECPublicKey (also extends java.security.PublicKey)
  • java.security.interfaces.RSAKey
    • java.security.interfaces.RSAPrivateKey (also extends java.security.PrivateKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPublicKey (also extends java.security.PublicKey)
  • java.io.Serializable
    • java.security.Key
      • java.security.PrivateKey (also extends javax.security.auth.Destroyable)
        • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAPrivateKey (also extends java.security.interfaces.RSAKey)
          • java.security.interfaces.RSAMultiPrimePrivateCrtKey
          • java.security.interfaces.RSAPrivateCrtKey
      • java.security.PublicKey
        • java.security.interfaces.DSAPublicKey (also extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPublicKey (also extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAPublicKey (also extends java.security.interfaces.RSAKey)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


RSAKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface RSAKey

  • All Known Subinterfaces:
    RSAMultiPrimePrivateCrtKey ， RSAPrivateCrtKey ， RSAPrivateKey ， RSAPublicKey

    public interface RSAKey
    与RSA公钥或私钥的接口。
    从以下版本开始：
    1.3
    另请参见：
    RSAPublicKey ， RSAPrivateKey

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getModulus​()
      返回模数。

    • 方法详细信息

      • getModulus

        BigInteger getModulus​()
        返回模数。
        结果
        the modulus
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RSAMultiPrimePrivateCrtKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface RSAMultiPrimePrivateCrtKey

  • All Superinterfaces:
    Destroyable ， Key ， PrivateKey ， RSAKey ， RSAPrivateKey ， Serializable

    public interface RSAMultiPrimePrivateCrtKey
extends RSAPrivateKey
    与PKCS＃1 v2.1中定义的使用 中国剩余定理 （CRT）信息值的RSA多权限私钥的接口。
    从以下版本开始：
    1.4
    另请参见：
    RSAPrivateKeySpec ， RSAMultiPrimePrivateCrtKeySpec ， RSAPrivateKey ， RSAPrivateCrtKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      类型指纹被设置为指示与以前版本的类型的序列化兼容性。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getCrtCoefficient​()
      返回crtCoefficient。
      RSAOtherPrimeInfo[] getOtherPrimeInfo​()
      如果只有两个素因子（p和q），则返回otherPrimeInfo或null。
      BigInteger getPrimeExponentP​()
      返回primeExponentP。
      BigInteger getPrimeExponentQ​()
      返回primeExponentQ。
      BigInteger getPrimeP​()
      返回primeP。
      BigInteger getPrimeQ​()
      返回primeQ。
      BigInteger getPublicExponent​()
      返回公共指数。

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

      • Methods inherited from interface java.security.interfaces.RSAKey

        getModulus

      • Methods inherited from interface java.security.interfaces.RSAPrivateKey

        getPrivateExponent

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        类型指纹被设置为指示与以前版本的类型的序列化兼容性。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getPublicExponent

        BigInteger getPublicExponent​()
        返回公共指数。
        结果
        公众指数。

      • getPrimeP

        BigInteger getPrimeP​()
        返回primeP。
        结果
        黄金。

      • getPrimeQ

        BigInteger getPrimeQ​()
        返回primeQ。
        结果
        最好的。

      • getPrimeExponentP

        BigInteger getPrimeExponentP​()
        返回primeExponentP。
        结果
        primeExponentP。

      • getPrimeExponentQ

        BigInteger getPrimeExponentQ​()
        返回primeExponentQ。
        结果
        primeExponentQ。

      • getCrtCoefficient

        BigInteger getCrtCoefficient​()
        返回crtCoefficient。
        结果
        crt系数。

      • getOtherPrimeInfo

        RSAOtherPrimeInfo[] getOtherPrimeInfo​()
        如果只有两个素因子（p和q），则返回otherPrimeInfo或null。
        结果
        otherPrimeInfo。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RSAPrivateCrtKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface RSAPrivateCrtKey

  • All Superinterfaces:
    Destroyable ， Key ， PrivateKey ， RSAKey ， RSAPrivateKey ， Serializable

    public interface RSAPrivateCrtKey
extends RSAPrivateKey
    使用 中国剩余定理 （CRT）信息值的PKCS＃1标准中定义的RSA私钥的接口。
    从以下版本开始：
    1.2
    另请参见：
    RSAPrivateKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      类型指纹被设置为指示与以前版本的类型的序列化兼容性。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getCrtCoefficient​()
      返回crtCoefficient。
      BigInteger getPrimeExponentP​()
      返回primeExponentP。
      BigInteger getPrimeExponentQ​()
      返回primeExponentQ。
      BigInteger getPrimeP​()
      返回primeP。
      BigInteger getPrimeQ​()
      返回primeQ。
      BigInteger getPublicExponent​()
      返回公共指数。

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

      • Methods inherited from interface java.security.interfaces.RSAKey

        getModulus

      • Methods inherited from interface java.security.interfaces.RSAPrivateKey

        getPrivateExponent

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        类型指纹被设置为指示与以前版本的类型的序列化兼容性。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getPublicExponent

        BigInteger getPublicExponent​()
        返回公共指数。
        结果
        公众指数

      • getPrimeP

        BigInteger getPrimeP​()
        返回primeP。
        结果
        黄金

      • getPrimeQ

        BigInteger getPrimeQ​()
        返回primeQ。
        结果
        最好的

      • getPrimeExponentP

        BigInteger getPrimeExponentP​()
        返回primeExponentP。
        结果
        primeExponentP

      • getPrimeExponentQ

        BigInteger getPrimeExponentQ​()
        返回primeExponentQ。
        结果
        primeExponentQ

      • getCrtCoefficient

        BigInteger getCrtCoefficient​()
        返回crtCoefficient。
        结果
        the crtCoefficient
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RSAPrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface RSAPrivateKey

  • All Superinterfaces:
    Destroyable ， Key ， PrivateKey ， RSAKey ， Serializable
    All Known Subinterfaces:
    RSAMultiPrimePrivateCrtKey ， RSAPrivateCrtKey

    public interface RSAPrivateKey
extends PrivateKey, RSAKey
    RSA私钥的接口。
    从以下版本开始：
    1.2
    另请参见：
    RSAPrivateCrtKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      类型指纹被设置为指示与以前版本的类型的序列化兼容性。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getPrivateExponent​()
      返回私有指数。

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

      • Methods inherited from interface java.security.interfaces.RSAKey

        getModulus

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        类型指纹被设置为指示与以前版本的类型的序列化兼容性。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getPrivateExponent

        BigInteger getPrivateExponent​()
        返回私有指数。
        结果
        私人指数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RSAPublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.interfaces

Interface RSAPublicKey

  • All Superinterfaces:
    Key ， PublicKey ， RSAKey ， Serializable

    public interface RSAPublicKey
extends PublicKey, RSAKey
    与RSA公钥的接口。
    从以下版本开始：
    1.2

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      类型指纹被设置为指示与以前版本的类型的序列化兼容性。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getPublicExponent​()
      返回公共指数。

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

      • Methods inherited from interface java.security.interfaces.RSAKey

        getModulus

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        类型指纹被设置为指示与以前版本的类型的序列化兼容性。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getPublicExponent

        BigInteger getPublicExponent​()
        返回公共指数。
        结果
        公众指数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Package java.security.interfaces (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.security.interfaces

  • Packages that use java.security.interfaces
    软件包 描述
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
  • Classes in java.security.interfaces used by java.security.interfaces
    Class 描述
    DSAKey
    DSA公钥或私钥的接口。
    DSAParams
    与DSA特定的关键参数集的接口，定义了DSA 密钥族 。
    ECKey
    椭圆曲线（EC）键的界面。
    RSAKey
    与RSA公钥或私钥的接口。
    RSAPrivateKey
    RSA私钥的接口。
  • Classes in java.security.interfaces used by java.security.spec
    Class 描述
    DSAParams
    与DSA特定的关键参数集的接口，定义了DSA 密钥族 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.DSAKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.DSAKey

  • Packages that use DSAKey
    软件包 描述
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。

    • Uses of DSAKey in java.security.interfaces

      Subinterfaces of DSAKey in java.security.interfaces
      Modifier and Type 接口 描述
      interface  DSAPrivateKey
      DSA私钥的标准接口。
      interface  DSAPublicKey
      DSA公钥的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.DSAKeyPairGenerator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.DSAKeyPairGenerator

No usage of java.security.interfaces.DSAKeyPairGenerator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.DSAParams (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.DSAParams

  • Packages that use DSAParams
    软件包 描述
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of DSAParams in java.security.interfaces

      Methods in java.security.interfaces that return DSAParams
      Modifier and Type 方法 描述
      DSAParams DSAKey.getParams​()
      返回特定于DSA的关键参数。
      Methods in java.security.interfaces with parameters of type DSAParams
      Modifier and Type 方法 描述
      void DSAKeyPairGenerator.initialize​(DSAParams params, SecureRandom random)
      使用DSA系列参数（p，q和g）和可选的SecureRandom位源初始化密钥对生成器。

    • Uses of DSAParams in java.security.spec

      Classes in java.security.spec that implement DSAParams
      Modifier and Type Class 描述
      class  DSAParameterSpec
      该类指定与DSA算法一起使用的参数集。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.DSAPrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.DSAPrivateKey

No usage of java.security.interfaces.DSAPrivateKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.DSAPublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.DSAPublicKey

No usage of java.security.interfaces.DSAPublicKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.ECKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.ECKey

  • Packages that use ECKey
    软件包 描述
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。

    • Uses of ECKey in java.security.interfaces

      Subinterfaces of ECKey in java.security.interfaces
      Modifier and Type 接口 描述
      interface  ECPrivateKey
      椭圆曲线（EC）私钥的界面。
      interface  ECPublicKey
      椭圆曲线（EC）公钥的界面。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.ECPrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.ECPrivateKey

No usage of java.security.interfaces.ECPrivateKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.ECPublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.ECPublicKey

No usage of java.security.interfaces.ECPublicKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.RSAKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.RSAKey

  • Packages that use RSAKey
    软件包 描述
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。

    • Uses of RSAKey in java.security.interfaces

      Subinterfaces of RSAKey in java.security.interfaces
      Modifier and Type 接口 描述
      interface  RSAMultiPrimePrivateCrtKey
      与PKCS＃1 v2.1中定义的使用 中国剩余定理 （CRT）信息值的RSA多权限私钥的接口。
      interface  RSAPrivateCrtKey
      使用 中国剩余定理 （CRT）信息值的PKCS＃1标准中定义的RSA私钥的接口。
      interface  RSAPrivateKey
      RSA私钥的接口。
      interface  RSAPublicKey
      与RSA公钥的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.RSAMultiPrimePrivateCrtKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.RSAMultiPrimePrivateCrtKey

No usage of java.security.interfaces.RSAMultiPrimePrivateCrtKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.RSAPrivateCrtKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.RSAPrivateCrtKey

No usage of java.security.interfaces.RSAPrivateCrtKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.RSAPrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.RSAPrivateKey

  • Packages that use RSAPrivateKey
    软件包 描述
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。

    • Uses of RSAPrivateKey in java.security.interfaces

      Subinterfaces of RSAPrivateKey in java.security.interfaces
      Modifier and Type 接口 描述
      interface  RSAMultiPrimePrivateCrtKey
      与PKCS＃1 v2.1中定义的使用 中国剩余定理 （CRT）信息值的RSA多权限私钥的接口。
      interface  RSAPrivateCrtKey
      使用 中国剩余定理 （CRT）信息值的PKCS＃1标准中定义的RSA私钥的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.interfaces.RSAPublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.interfaces.RSAPublicKey

No usage of java.security.interfaces.RSAPublicKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AlgorithmParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Interface AlgorithmParameterSpec

  • All Known Subinterfaces:
    C14NMethodParameterSpec ， DigestMethodParameterSpec ， SignatureMethodParameterSpec ， TransformParameterSpec
    所有已知实现类：
    DHGenParameterSpec ， DHParameterSpec ， DSAGenParameterSpec ， DSAParameterSpec ， ECGenParameterSpec ， ECParameterSpec ， ExcC14NParameterSpec ， GCMParameterSpec ， HMACParameterSpec ， IvParameterSpec ， MGF1ParameterSpec ， OAEPParameterSpec ， PBEParameterSpec ， PSSParameterSpec ， RC2ParameterSpec ， RC5ParameterSpec ， RSAKeyGenParameterSpec ， XPathFilter2ParameterSpec ， XPathFilterParameterSpec ， XSLTTransformParameterSpec

    public interface AlgorithmParameterSpec
    密码参数的（透明）规范。

    此接口不包含方法或常量。 其唯一的目的是为所有参数规格分组（并提供类型安全性）。 所有参数规范必须实现此接口。

    从以下版本开始：
    1.2
    另请参见：
    AlgorithmParameters ， DSAParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DSAGenParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class DSAGenParameterSpec

  • java.lang.Object
    • java.security.spec.DSAGenParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public final class DSAGenParameterSpec
extends Object
implements AlgorithmParameterSpec
    这个不可变类指定了用于生成如 FIPS 186-3 Digital Signature Standard (DSS)中规定的DSA参数的参数 集 。
    从以下版本开始：
    1.8
    另请参见：
    AlgorithmParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      DSAGenParameterSpec​(int primePLen, int subprimeQLen)
      使用 primePLen和 subprimeQLen创建DSA参数生成的域参数规范。
      DSAGenParameterSpec​(int primePLen, int subprimeQLen, int seedLen)
      创建用于使用DSA参数生成一个域参数规范 primePLen ， subprimeQLen ，和 seedLen 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getPrimePLength​()
      以位为单位返回要生成的DSA域参数的素数P的期望长度。
      int getSeedLength​()
      以比特返回域参数种子的所需长度。
      int getSubprimeQLength​()
      以位为单位返回要生成的DSA域参数的子素数Q的期望长度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DSAGenParameterSpec

        public DSAGenParameterSpec​(int primePLen,
                           int subprimeQLen)
        使用primePLen和subprimeQLen创建DSA参数生成的域参数规范。 subprimeQLen的值也用作域参数种子的默认长度（以位为单位）。
        参数
        primePLen - 素数P的所需长度，以位为单位。
        subprimeQLen - 子素数Q的所需长度（以位为单位）。
        异常
        IllegalArgumentException - 如果 primePLen或 subprimeQLen根据FIPS 186-3的规范是非法的。

      • DSAGenParameterSpec

        public DSAGenParameterSpec​(int primePLen,
                           int subprimeQLen,
                           int seedLen)
        创建用于使用DSA参数生成一个域参数规范 primePLen ， subprimeQLen ，和 seedLen 。
        参数
        primePLen - 素数P的所需长度（以位为单位）。
        subprimeQLen - 子素数Q的所需长度（以位为单位）。
        seedLen - 以域为单位的域参数种子的期望长度应等于或大于 subprimeQLen 。
        异常
        IllegalArgumentException -如果 primePLenLen ， subprimeQLen ，或 seedLen每FIPS 186-3的规格是非法的。

    • 方法详细信息

      • getPrimePLength

        public int getPrimePLength​()
        以位为单位返回要生成的DSA域参数的素数P的期望长度。
        结果
        素数的长度

      • getSubprimeQLength

        public int getSubprimeQLength​()
        以位为单位返回要生成的DSA域参数的子素数Q的期望长度。
        结果
        子素数Q的长度。

      • getSeedLength

        public int getSeedLength​()
        以比特返回域参数种子的所需长度。
        结果
        域参数种子的长度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DSAParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class DSAParameterSpec

  • java.lang.Object
    • java.security.spec.DSAParameterSpec
  • All Implemented Interfaces:
    DSAParams ， AlgorithmParameterSpec

    public class DSAParameterSpec
extends Object
implements AlgorithmParameterSpec, DSAParams
    该类指定与DSA算法一起使用的参数集。
    从以下版本开始：
    1.2
    另请参见：
    AlgorithmParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      DSAParameterSpec​(BigInteger p, BigInteger q, BigInteger g)
      使用指定的参数值创建新的DSAParameterSpec。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getG​()
      返回底座 g 。
      BigInteger getP​()
      退货 p 。
      BigInteger getQ​()
      返回次级 q 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DSAParameterSpec

        public DSAParameterSpec​(BigInteger p,
                        BigInteger q,
                        BigInteger g)
        使用指定的参数值创建新的DSAParameterSpec。
        参数
        p - 黄金。
        q - 次级。
        g - 基地。

    • 方法详细信息

      • getP

        public BigInteger getP​()
        退货 p 。
        Specified by:
        getP在接口 DSAParams
        结果
        主要 p 。

      • getQ

        public BigInteger getQ​()
        返回次级 q 。
        Specified by:
        getQ在接口 DSAParams
        结果
        次级 q 。

      • getG

        public BigInteger getG​()
        返回底座 g 。
        Specified by:
        getG在接口 DSAParams
        结果
        基地 g 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DSAPrivateKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class DSAPrivateKeySpec

  • java.lang.Object
    • java.security.spec.DSAPrivateKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class DSAPrivateKeySpec
extends Object
implements KeySpec
    此类指定具有相关参数的DSA私钥。
    从以下版本开始：
    1.2
    另请参见：
    Key ， KeyFactory ， KeySpec ， DSAPublicKeySpec ， PKCS8EncodedKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      DSAPrivateKeySpec​(BigInteger x, BigInteger p, BigInteger q, BigInteger g)
      用指定的参数值创建一个新的DSAPrivateKeySpec。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getG​()
      返回底座 g 。
      BigInteger getP​()
      退货 p 。
      BigInteger getQ​()
      返回次级 q 。
      BigInteger getX​()
      返回私钥 x 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DSAPrivateKeySpec

        public DSAPrivateKeySpec​(BigInteger x,
                         BigInteger p,
                         BigInteger q,
                         BigInteger g)
        用指定的参数值创建一个新的DSAPrivateKeySpec。
        参数
        x - 私钥。
        p - 黄金。
        q - 次级。
        g - 基地。

    • 方法详细信息

      • getX

        public BigInteger getX​()
        返回私钥 x 。
        结果
        私钥 x 。

      • getP

        public BigInteger getP​()
        退货 p 。
        结果
        主要 p 。

      • getQ

        public BigInteger getQ​()
        返回次级 q 。
        结果
        次级 q 。

      • getG

        public BigInteger getG​()
        返回底座 g 。
        结果
        基地 g 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DSAPublicKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class DSAPublicKeySpec

  • java.lang.Object
    • java.security.spec.DSAPublicKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class DSAPublicKeySpec
extends Object
implements KeySpec
    该类指定具有相关参数的DSA公钥。
    从以下版本开始：
    1.2
    另请参见：
    Key ， KeyFactory ， KeySpec ， DSAPrivateKeySpec ， X509EncodedKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      DSAPublicKeySpec​(BigInteger y, BigInteger p, BigInteger q, BigInteger g)
      用指定的参数值创建一个新的DSAPublicKeySpec。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getG​()
      返回底座 g 。
      BigInteger getP​()
      退货 p 。
      BigInteger getQ​()
      返回次级 q 。
      BigInteger getY​()
      返回公钥 y 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DSAPublicKeySpec

        public DSAPublicKeySpec​(BigInteger y,
                        BigInteger p,
                        BigInteger q,
                        BigInteger g)
        用指定的参数值创建一个新的DSAPublicKeySpec。
        参数
        y - 公钥。
        p - 黄金。
        q - 次级。
        g - 基地。

    • 方法详细信息

      • getY

        public BigInteger getY​()
        返回公钥 y 。
        结果
        公钥 y 。

      • getP

        public BigInteger getP​()
        退货 p 。
        结果
        主要的 p 。

      • getQ

        public BigInteger getQ​()
        返回次级 q 。
        结果
        次级 q 。

      • getG

        public BigInteger getG​()
        返回底座 g 。
        结果
        基地 g 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ECField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Interface ECField

  • 所有已知实现类：
    ECFieldF2m ， ECFieldFp

    public interface ECField
    该接口表示椭圆曲线（EC）有限域。 所有专门的EC字段必须实现此接口。
    从以下版本开始：
    1.5
    另请参见：
    ECFieldFp ， ECFieldF2m

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getFieldSize​()
      返回字段大小（以位为单位）。

    • 方法详细信息

      • getFieldSize

        int getFieldSize​()
        返回字段大小（以位为单位）。 注意：对于主有限域ECFieldFp，返回以位为单位的素数p的大小。 对于特征2有限域ECFieldF2m，返回m。
        结果
        the field size in bits.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ECFieldF2m (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class ECFieldF2m

  • java.lang.Object
    • java.security.spec.ECFieldF2m
  • All Implemented Interfaces:
    ECField

    public class ECFieldF2m
extends Object
implements ECField
    这个不可变类定义了椭圆曲线（EC）特征2有限域。
    从以下版本开始：
    1.5
    另请参见：
    ECField

    • 构造方法摘要

      构造方法
      Constructor 描述
      ECFieldF2m​(int m)
      创建椭圆曲线特征2有限域，其具有正常基础的2 ^ m元素。
      ECFieldF2m​(int m, int[] ks)
      创建椭圆曲线特征2有限域，其具有多项式基础的2 ^ m元素。
      ECFieldF2m​(int m, BigInteger rp)
      创建椭圆曲线特征2有限域，其具有多项式基础的2 ^ m元素。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此有限域作为与指定对象相等的比较。
      int getFieldSize​()
      返回该特征2有限域的字段大小（以比特为 m 。
      int getM​()
      返回该特征2有限域的值 m 。
      int[] getMidTermsOfReductionPolynomial​()
      返回一个整数数组，其中包含多项式基础的缩减多项式的中间项的顺序，或者为正常的基数返回null。
      BigInteger getReductionPolynomial​()
      返回一个BigInteger，其第i个位对应于多项式基础的缩小多项式的第i个系数，或者为正常值，返回null。
      int hashCode​()
      返回此特征2有限域的哈希码值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ECFieldF2m

        public ECFieldF2m​(int m)
        创建椭圆曲线特征2有限域，其具有正常基础的2 ^ m元素。
        参数
        m - 2 ^ m是元素的数量。
        异常
        IllegalArgumentException - 如果 m 。

      • ECFieldF2m

        public ECFieldF2m​(int m,
                  BigInteger rp)
        创建椭圆曲线特征2有限域，其具有多项式基础的2 ^ m元素。 该字段的缩小多项式基于其第i位对应于缩小多项式的第i个系数的rp 。

        注意：有效的简化多项式是三项式（X ^ m + X ^ k + 1， m k > = 1）或五项式（X ^ m + X ^ k3 + X ^ k2 + X ^ k1 + 1与m > k3 > k2 > k1 > = 1）。

        参数
        m - 2 ^ m是元素的数量。
        rp - 其第i位对应于缩小多项式的第i个系数的BigInteger。
        异常
        NullPointerException - 如果 rp为空。
        IllegalArgumentException - 如果 m不为正，或者 rp不表示有效的缩减多项式。

      • ECFieldF2m

        public ECFieldF2m​(int m,
                  int[] ks)
        创建椭圆曲线特征2有限域，其具有多项式基础的2 ^ m元素。 该字段的缩小多项式基于ks其内容包含缩减多项式的中间项的顺序。 注意：有效的简化多项式是三项式（X ^ m + X ^ k + 1，其中m > k > = 1）或五项式（X ^ m + X ^ k3 + X ^ k2 + X ^ k1 + 1与m > k3 > k2 > k1 > = 1），所以ks应该具有长度1或3。
        参数
        m - 2 ^ m是元素的数量。
        ks - 缩减多项式中期的顺序。 复制该数组的内容以防止后续修改。
        异常
        NullPointerException - 如果 ks为空。
        IllegalArgumentException - 如果 m不为正，或者 ks的长度既不是1也不是3，或者 ks中的值不在 m -1和1（含）之间，并且按降序排列。

    • 方法详细信息

      • getFieldSize

        public int getFieldSize​()
        返回该特征2有限域的字段大小，位数为 m 。
        Specified by:
        getFieldSize在接口 ECField
        结果
        字段大小以位为单位。

      • getM

        public int getM​()
        返回该特征2有限域的值 m 。
        结果
        m与2 ^ m是元素的数量。

      • getReductionPolynomial

        public BigInteger getReductionPolynomial​()
        返回一个BigInteger，其第i个位对应于多项式基础的缩小多项式的第i个系数，或者为正常值，返回null。
        结果
        一个BigInteger，其第i个位对应于用于多项式基础的缩小多项式的第i个系数，或者对应于正常的基础的null。

      • getMidTermsOfReductionPolynomial

        public int[] getMidTermsOfReductionPolynomial​()
        返回一个整数数组，其中包含多项式基础的缩减多项式的中间项的顺序，或者为正常的基数返回null。
        结果
        一个整数数组，它包含多项式基础的缩减多项式的中间项的顺序，或者是正常的基础的null。 每次调用此方法时，都会返回一个新数组。

      • equals

        public boolean equals​(Object obj)
        将此有限域作为与指定对象相等的比较。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        如果 obj是 obj的实例，并且 m和缩减多项式匹配， m true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此特征2有限域的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ECFieldFp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class ECFieldFp

  • java.lang.Object
    • java.security.spec.ECFieldFp
  • All Implemented Interfaces:
    ECField

    public class ECFieldFp
extends Object
implements ECField
    这个不可变类定义了椭圆曲线（EC）素数有限域。
    从以下版本开始：
    1.5
    另请参见：
    ECField

    • 构造方法摘要

      构造方法
      Constructor 描述
      ECFieldFp​(BigInteger p)
      创建椭圆曲线初始有限域与指定的素数 p 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此主要有限域与等同与指定对象进行比较。
      int getFieldSize​()
      返回这个主要有限域的素数p的大小的字段大小。
      BigInteger getP​()
      返回这个主要有限域的素数 p 。
      int hashCode​()
      返回此主要有限域的哈希码值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ECFieldFp

        public ECFieldFp​(BigInteger p)
        创建具有指定素数的椭圆曲线初始有限域 p 。
        参数
        p - 黄金。
        异常
        NullPointerException - 如果 p为空。
        IllegalArgumentException - 如果 p 。

    • 方法详细信息

      • getFieldSize

        public int getFieldSize​()
        返回这个主要有限域的素数p的大小的字段大小。
        Specified by:
        getFieldSize在接口 ECField
        结果
        字段大小以位为单位。

      • getP

        public BigInteger getP​()
        返回这个主要有限域的素数 p 。
        结果
        主要。

      • equals

        public boolean equals​(Object obj)
        将此主要有限域与等同与指定对象进行比较。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        如果 obj是 obj的实例并且素数匹配，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此主要有限域的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ECGenParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class ECGenParameterSpec

  • java.lang.Object
    • java.security.spec.ECGenParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class ECGenParameterSpec
extends Object
implements AlgorithmParameterSpec
    这个不可变类指定用于生成椭圆曲线（EC）域参数的参数集。
    从以下版本开始：
    1.5
    另请参见：
    AlgorithmParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      ECGenParameterSpec​(String stdName)
      使用标准（或预定义）名称 stdName创建EC参数生成的参数规范，以生成相应的（预计算）椭圆曲线域参数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getName​()
      返回要生成的EC域参数的标准或预定义名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ECGenParameterSpec

        public ECGenParameterSpec​(String stdName)
        使用标准（或预定义）名称stdName创建EC参数生成的参数规范，以生成相应的（预计算）椭圆曲线域参数。 有关支持名称的列表，请参阅将使用实施的提供商的文档。
        参数
        stdName - 要生成的EC域参数的标准名称。
        异常
        NullPointerException - 如果 stdName为空。

    • 方法详细信息

      • getName

        public String getName​()
        返回要生成的EC域参数的标准或预定义名称。
        结果
        标准或预定义名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ECParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class ECParameterSpec

  • java.lang.Object
    • java.security.spec.ECParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class ECParameterSpec
extends Object
implements AlgorithmParameterSpec
    这个不可变类指定了使用椭圆曲线加密（ECC）的一组域参数。
    从以下版本开始：
    1.5
    另请参见：
    AlgorithmParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      ECParameterSpec​(EllipticCurve curve, ECPoint g, BigInteger n, int h)
      根据指定的值创建椭圆曲线域参数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getCofactor​()
      返回辅助因子。
      EllipticCurve getCurve​()
      返回此参数定义的椭圆曲线。
      ECPoint getGenerator​()
      返回也称为基点的生成器。
      BigInteger getOrder​()
      返回发生器的顺序。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ECParameterSpec

        public ECParameterSpec​(EllipticCurve curve,
                       ECPoint g,
                       BigInteger n,
                       int h)
        根据指定的值创建椭圆曲线域参数。
        参数
        curve - 该参数定义的椭圆曲线。
        g - 也称为 g的发电机。
        n - 发电机的顺序 g 。
        h - 辅因子。
        异常
        NullPointerException -如果 curve ， g ，或 n为null。
        IllegalArgumentException - 如果 n或 h 。

    • 方法详细信息

      • getCurve

        public EllipticCurve getCurve​()
        返回此参数定义的椭圆曲线。
        结果
        该参数定义的椭圆曲线。

      • getGenerator

        public ECPoint getGenerator​()
        返回也称为基点的生成器。
        结果
        也称为基点的发电机。

      • getOrder

        public BigInteger getOrder​()
        返回发生器的顺序。
        结果
        发电机的顺序。

      • getCofactor

        public int getCofactor​()
        返回辅助因子。
        结果
        辅因子。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ECPoint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class ECPoint

  • java.lang.Object
    • java.security.spec.ECPoint

  • public class ECPoint
extends Object
    这个不可变的类表示仿射坐标中的椭圆曲线（EC）上的点。 其他坐标系可以扩展这个类以在其他坐标中表示这一点。
    从以下版本开始：
    1.5

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static ECPoint POINT_INFINITY
      这定义了无限远的点。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ECPoint​(BigInteger x, BigInteger y)
      从指定的仿射x坐标 x和仿射y坐标 y创建一个 y 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此椭圆曲线点与指定对象进行比较。
      BigInteger getAffineX​()
      返回仿射x坐标 x 。
      BigInteger getAffineY​()
      返回仿射y坐标 y 。
      int hashCode​()
      返回此椭圆曲线点的哈希码值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • POINT_INFINITY

        public static final ECPoint POINT_INFINITY
        这定义了无限远的点。

    • 构造方法详细信息

      • ECPoint

        public ECPoint​(BigInteger x,
               BigInteger y)
        从指定的仿射x坐标 x和仿射y坐标 y创建一个 y 。
        参数
        x - 仿射x坐标。
        y - 仿射y坐标。
        异常
        NullPointerException - 如果 x或 y为空。

    • 方法详细信息

      • getAffineX

        public BigInteger getAffineX​()
        返回仿射x坐标x 。 注意：POINT_INFINITY有一个零仿射x坐标。
        结果
        仿射x坐标。

      • getAffineY

        public BigInteger getAffineY​()
        返回仿射y坐标y 。 注意：POINT_INFINITY具有无效的仿射y坐标。
        结果
        仿射y坐标。

      • equals

        public boolean equals​(Object obj)
        将此椭圆曲线点与指定对象进行比较。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        如果 obj是 obj的实例，并且仿射坐标匹配，则为true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此椭圆曲线点的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ECPrivateKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class ECPrivateKeySpec

  • java.lang.Object
    • java.security.spec.ECPrivateKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class ECPrivateKeySpec
extends Object
implements KeySpec
    这个不可变类指定一个带有关联参数的椭圆曲线私钥。
    从以下版本开始：
    1.5
    另请参见：
    KeySpec ， ECParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      ECPrivateKeySpec​(BigInteger s, ECParameterSpec params)
      用指定的参数值创建一个新的ECPrivateKeySpec。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ECParameterSpec getParams​()
      返回相关的椭圆曲线域参数。
      BigInteger getS​()
      返回私有值S.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ECPrivateKeySpec

        public ECPrivateKeySpec​(BigInteger s,
                        ECParameterSpec params)
        用指定的参数值创建一个新的ECPrivateKeySpec。
        参数
        s - 私有价值。
        params - 相关的椭圆曲线域参数。
        异常
        NullPointerException - 如果 s或 params为空。

    • 方法详细信息

      • getS

        public BigInteger getS​()
        返回私有值S.
        结果
        私人价值S.

      • getParams

        public ECParameterSpec getParams​()
        返回相关的椭圆曲线域参数。
        结果
        EC域参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ECPublicKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class ECPublicKeySpec

  • java.lang.Object
    • java.security.spec.ECPublicKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class ECPublicKeySpec
extends Object
implements KeySpec
    这个不可变类指定了一个带有关联参数的椭圆曲线公钥。
    从以下版本开始：
    1.5
    另请参见：
    KeySpec ， ECPoint ， ECParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      ECPublicKeySpec​(ECPoint w, ECParameterSpec params)
      用指定的参数值创建一个新的ECPublicKeySpec。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ECParameterSpec getParams​()
      返回相关的椭圆曲线域参数。
      ECPoint getW​()
      返回公共点W.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ECPublicKeySpec

        public ECPublicKeySpec​(ECPoint w,
                       ECParameterSpec params)
        用指定的参数值创建一个新的ECPublicKeySpec。
        参数
        w - 公众点。
        params - 相关的椭圆曲线域参数。
        异常
        NullPointerException - 如果 w或 params为空。
        IllegalArgumentException - 如果 w指向无限远，即ECPoint.POINT_INFINITY

    • 方法详细信息

      • getW

        public ECPoint getW​()
        返回公共点W.
        结果
        公共点W.

      • getParams

        public ECParameterSpec getParams​()
        返回相关的椭圆曲线域参数。
        结果
        EC域参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EllipticCurve (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class EllipticCurve

  • java.lang.Object
    • java.security.spec.EllipticCurve

  • public class EllipticCurve
extends Object
    这个不变的类保存代表椭圆曲线所需的必要值。
    从以下版本开始：
    1.5
    另请参见：
    ECField ， ECFieldFp ， ECFieldF2m

    • 构造方法摘要

      构造方法
      Constructor 描述
      EllipticCurve​(ECField field, BigInteger a, BigInteger b)
      创建具有指定的椭圆字段 field和系数 a和 b的椭圆曲线。
      EllipticCurve​(ECField field, BigInteger a, BigInteger b, byte[] seed)
      创建具有指定的椭圆场 field ，系数 a和 b以及用于曲线生成的 seed的椭圆曲线。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此椭圆曲线与指定对象进行比较。
      BigInteger getA​()
      返回椭圆曲线的第一个系数 a 。
      BigInteger getB​()
      返回椭圆曲线的第二个系数 b 。
      ECField getField​()
      返回椭圆曲线结束的有限域 field 。
      byte[] getSeed​()
      返回在曲线生成期间使用的种子字节 seed 。
      int hashCode​()
      返回此椭圆曲线的哈希码值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EllipticCurve

        public EllipticCurve​(ECField field,
                     BigInteger a,
                     BigInteger b)
        创建具有指定的椭圆场 field和系数 a和 b的椭圆曲线。
        参数
        field - 这个椭圆曲线结束的有限域。
        a - 这个椭圆曲线的第一个系数。
        b - 这个椭圆曲线的第二个系数。
        异常
        NullPointerException -如果 field ， a ，或 b为null。
        IllegalArgumentException - 如果 a或 b不为空且不在 field 。

      • EllipticCurve

        public EllipticCurve​(ECField field,
                     BigInteger a,
                     BigInteger b,
                     byte[] seed)
        创建具有指定的椭圆场 field ，系数 a和 b以及用于曲线生成的 seed的椭圆曲线。
        参数
        field - 这个椭圆曲线结束的有限域。
        a - 这个椭圆曲线的第一个系数。
        b - 这个椭圆曲线的第二个系数。
        seed - 用于稍后验证的曲线生成期间使用的字节。 复制该数组的内容以防止后续修改。
        异常
        NullPointerException -如果 field ， a ，或 b为null。
        IllegalArgumentException - 如果 a或 b不为空，而不在 field 。

    • 方法详细信息

      • getField

        public ECField getField​()
        返回这个椭圆曲线结束的有限域 field 。
        结果
        该曲线结束的字段为 field 。

      • getA

        public BigInteger getA​()
        返回椭圆曲线的第一个系数 a 。
        结果
        第一个系数 a 。

      • getB

        public BigInteger getB​()
        返回椭圆曲线的第二个系数 b 。
        结果
        第二个系数 b 。

      • getSeed

        public byte[] getSeed​()
        返回在曲线生成期间使用的播种字节seed 。 如果未指定，可能为null。
        结果
        播种字节seed 。 每次调用此方法时，都会返回一个新数组。

      • equals

        public boolean equals​(Object obj)
        将此椭圆曲线与指定对象进行比较。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        如果 obj是EllipticCurve的实例，并且字段A和B匹配， obj true，否则为false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此椭圆曲线的哈希码值。
        重写：
        hashCode在 Object
        结果
        从字段A和B的哈希码计算的哈希码值如下：
           (field.hashCode() << 6) + (a.hashCode() << 4) + (b.hashCode() << 2)
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EncodedKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class EncodedKeySpec

  • java.lang.Object
    • java.security.spec.EncodedKeySpec
  • All Implemented Interfaces:
    KeySpec
    已知直接子类：
    PKCS8EncodedKeySpec ， X509EncodedKeySpec

    public abstract class EncodedKeySpec
extends Object
implements KeySpec
    该类表示编码格式的公钥或私钥。
    从以下版本开始：
    1.2
    另请参见：
    Key ， KeyFactory ， KeySpec ， X509EncodedKeySpec ， PKCS8EncodedKeySpec

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        EncodedKeySpec​(byte[] encodedKey)
      使用给定的编码密钥创建一个新的 EncodedKeySpec 。
      protected EncodedKeySpec​(byte[] encodedKey, String algorithm)
      使用给定的编码密钥创建一个新的 EncodedKeySpec 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      String getAlgorithm​()
      返回编码密钥算法的名称。
      byte[] getEncoded​()
      返回编码的密钥。
      abstract String getFormat​()
      返回与此密钥规范相关联的编码格式的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EncodedKeySpec

        public EncodedKeySpec​(byte[] encodedKey)
        使用给定的编码密钥创建一个新的 EncodedKeySpec 。
        参数
        encodedKey - 编码密钥。 复制数组的内容以防止后续修改。
        异常
        NullPointerException - 如果 encodedKey为空。

      • EncodedKeySpec

        protected EncodedKeySpec​(byte[] encodedKey,
                         String algorithm)
        使用给定的编码密钥创建一个新的EncodedKeySpec 。 这个构造函数在EncodedKeySpec对象的后续调用者可能不知道密钥算法时很有用。
        参数
        encodedKey - 编码密钥。 复制数组的内容以防止后续修改。
        algorithm - 编码密钥的算法名称有关标准算法名称的信息，请参阅 Java Security Standard Algorithm Names Specification中的KeyFactory部分。
        异常
        NullPointerException - 如果 encodedKey或 algorithm为空。
        IllegalArgumentException - 如果 algorithm是空字符串 ""
        从以下版本开始：
        9

    • 方法详细信息

      • getAlgorithm

        public String getAlgorithm​()
        返回编码密钥算法的名称。
        结果
        算法的名称，如果未指定则为null
        从以下版本开始：
        9

      • getEncoded

        public byte[] getEncoded​()
        返回编码的密钥。
        结果
        编码密钥。 每次调用此方法时都会返回一个新数组。

      • getFormat

        public abstract String getFormat​()
        返回与此密钥规范相关联的编码格式的名称。

        如果密钥的不透明表示（见Key ）可以转换（参见KeyFactory ）到此密钥规范（或其子类）中， getFormat在不透明密钥上调用的getFormat将返回与此密钥规范的getFormat方法相同的值。

        结果
        编码格式的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidKeySpecException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class InvalidKeySpecException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.spec.InvalidKeySpecException
  • All Implemented Interfaces:
    Serializable

    public class InvalidKeySpecException
extends GeneralSecurityException
    这是无效密钥规范的例外。
    从以下版本开始：
    1.2
    另请参见：
    KeySpec ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidKeySpecException​()
      构造一个InvalidKeySpecException，没有详细消息。
      InvalidKeySpecException​(String msg)
      使用指定的详细消息构造InvalidKeySpecException。
      InvalidKeySpecException​(String message, Throwable cause)
      创建一个具有指定的详细信息和原因的 InvalidKeySpecException 。
      InvalidKeySpecException​(Throwable cause)
      创建一个 InvalidKeySpecException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidKeySpecException

        public InvalidKeySpecException​()
        构造一个InvalidKeySpecException，没有详细消息。 详细消息是描述此特定异常的字符串。

      • InvalidKeySpecException

        public InvalidKeySpecException​(String msg)
        使用指定的详细消息构造InvalidKeySpecException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。

      • InvalidKeySpecException

        public InvalidKeySpecException​(String message,
                               Throwable cause)
        创建一个具有指定的详细信息和原因的 InvalidKeySpecException 。
        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法后续检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • InvalidKeySpecException

        public InvalidKeySpecException​(Throwable cause)
        创建一个 InvalidKeySpecException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidParameterSpecException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class InvalidParameterSpecException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.spec.InvalidParameterSpecException
  • All Implemented Interfaces:
    Serializable

    public class InvalidParameterSpecException
extends GeneralSecurityException
    这是无效参数规范的例外。
    从以下版本开始：
    1.2
    另请参见：
    AlgorithmParameters ， AlgorithmParameterSpec ， DSAParameterSpec ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidParameterSpecException​()
      构造一个没有详细信息的InvalidParameterSpecException。
      InvalidParameterSpecException​(String msg)
      使用指定的详细消息构造InvalidParameterSpecException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidParameterSpecException

        public InvalidParameterSpecException​()
        构造一个没有详细信息的InvalidParameterSpecException。 详细消息是描述此特定异常的字符串。

      • InvalidParameterSpecException

        public InvalidParameterSpecException​(String msg)
        使用指定的详细消息构造InvalidParameterSpecException。 详细消息是描述此特定异常的字符串。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.security.spec (Java SE 9 & JDK 9 )

java.security.spec

Interfaces

  • AlgorithmParameterSpec
  • ECField
  • KeySpec

Classes

  • DSAGenParameterSpec
  • DSAParameterSpec
  • DSAPrivateKeySpec
  • DSAPublicKeySpec
  • ECFieldF2m
  • ECFieldFp
  • ECGenParameterSpec
  • ECParameterSpec
  • ECPoint
  • ECPrivateKeySpec
  • ECPublicKeySpec
  • EllipticCurve
  • EncodedKeySpec
  • MGF1ParameterSpec
  • PKCS8EncodedKeySpec
  • PSSParameterSpec
  • RSAKeyGenParameterSpec
  • RSAMultiPrimePrivateCrtKeySpec
  • RSAOtherPrimeInfo
  • RSAPrivateCrtKeySpec
  • RSAPrivateKeySpec
  • RSAPublicKeySpec
  • X509EncodedKeySpec

Exceptions

  • InvalidKeySpecException
  • InvalidParameterSpecException


java.security.spec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.security.spec

提供关键规范和算法参数规范的类和接口。

关键规范是构成关键材料的透明表示。 密钥可以以特定于算法的方式或与算法无关的编码格式（例如ASN.1）来指定。 此包包含DSA公钥和私钥，RSA公钥和私钥，DER编码格式的PKCS＃8私钥和DER编码格式的X.509公钥和私钥的密钥规范。

算法参数规范是与算法一起使用的参数集合的透明表示。 该包包含与DSA算法一起使用的参数的算法参数规范。

包装规格

  • PKCS＃1：RSA加密标准版本1.5，1993年11月
  • PKCS＃8：私钥信息语法标准版本1.2，1993年11月
  • 联邦信息处理标准出版物（FIPS PUB）186：数字签名标准（DSS）

相关文档

有关算法参数和关键规格信息的文档，请参阅：
  • Java Cryptography Architecture (JCA) Reference Guide
  • How to Implement a Provider in the Java Cryptography Architecture
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    AlgorithmParameterSpec
    密码参数的（透明）规范。
    ECField
    该接口表示椭圆曲线（EC）有限域。
    KeySpec
    构成加密密钥的密钥材料的（透明）规范。
  • 类摘要
    Class 描述
    DSAGenParameterSpec
    这个不可变类指定了用于生成如 FIPS 186-3 Digital Signature Standard (DSS)中指定的DSA参数的参数 集 。
    DSAParameterSpec
    该类指定与DSA算法一起使用的参数集。
    DSAPrivateKeySpec
    此类指定具有相关参数的DSA私钥。
    DSAPublicKeySpec
    该类指定具有相关参数的DSA公钥。
    ECFieldF2m
    这个不可变类定义了椭圆曲线（EC）特征2有限域。
    ECFieldFp
    这个不可变类定义了椭圆曲线（EC）素数有限域。
    ECGenParameterSpec
    这个不可变类指定用于生成椭圆曲线（EC）域参数的参数集。
    ECParameterSpec
    这个不可变类指定了使用椭圆曲线加密（ECC）的一组域参数。
    ECPoint
    这个不可变的类表示仿射坐标中的椭圆曲线（EC）上的点。
    ECPrivateKeySpec
    这个不可变类指定一个带有关联参数的椭圆曲线私钥。
    ECPublicKeySpec
    这个不可变类指定了一个带有关联参数的椭圆曲线公钥。
    EllipticCurve
    这个不变的类保存代表椭圆曲线所需的必要值。
    EncodedKeySpec
    该类表示编码格式的公钥或私钥。
    MGF1ParameterSpec
    该类指定了在 PKCS #1 v2.1标准中定义的OAEP填充和RSA-PSS签名方案中与掩码生成函数MGF1一起使用的参数集合。
    PKCS8EncodedKeySpec
    该类代表私有密钥的ASN.1编码，根据ASN.1类型 PrivateKeyInfo编码。
    PSSParameterSpec
    该类指定了 PKCS#1 v2.1标准中定义的RSA-PSS签名方案的参数规范。
    RSAKeyGenParameterSpec
    此类指定用于生成RSA密钥对的参数集。
    RSAMultiPrimePrivateCrtKeySpec
    该类指定PKCS＃1 v2.1中定义的RSA多权限私钥，使用中文余数定理（CRT）信息值进行效率。
    RSAOtherPrimeInfo
    该类表示RSA的OtherPrimeInfo结构中的三元组（素数，指数和系数），如PKCS＃1 v2.1中定义的。
    RSAPrivateCrtKeySpec
    该类指定PKCS＃1标准中定义的RSA私钥，使用中文余数定理（CRT）信息值进行效率。
    RSAPrivateKeySpec
    此类指定一个RSA私钥。
    RSAPublicKeySpec
    此类指定一个RSA公钥。
    X509EncodedKeySpec
    该类表示公钥的ASN.1编码，根据ASN.1类型 SubjectPublicKeyInfo编码。
  • 异常摘要
    异常 描述
    InvalidKeySpecException
    这是无效密钥规范的例外。
    InvalidParameterSpecException
    这是无效参数规范的例外。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.security.spec Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.security.spec

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.security.spec.DSAGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.DSAParameterSpec (implements java.security.spec.AlgorithmParameterSpec, java.security.interfaces.DSAParams)
    • java.security.spec.DSAPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.DSAPublicKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.ECFieldF2m (implements java.security.spec.ECField)
    • java.security.spec.ECFieldFp (implements java.security.spec.ECField)
    • java.security.spec.ECGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECPoint
    • java.security.spec.ECPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.ECPublicKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.EllipticCurve
    • java.security.spec.EncodedKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.PKCS8EncodedKeySpec
      • java.security.spec.X509EncodedKeySpec
    • java.security.spec.MGF1ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.PSSParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.RSAKeyGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.RSAOtherPrimeInfo
    • java.security.spec.RSAPrivateKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.RSAMultiPrimePrivateCrtKeySpec
      • java.security.spec.RSAPrivateCrtKeySpec
    • java.security.spec.RSAPublicKeySpec (implements java.security.spec.KeySpec)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.security.GeneralSecurityException
          • java.security.spec.InvalidKeySpecException
          • java.security.spec.InvalidParameterSpecException

Interface Hierarchy

  • java.security.spec.AlgorithmParameterSpec
  • java.security.spec.ECField
  • java.security.spec.KeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


KeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Interface KeySpec

  • 所有已知实现类：
    DESedeKeySpec ， DESKeySpec ， DHPrivateKeySpec ， DHPublicKeySpec ， DSAPrivateKeySpec ， DSAPublicKeySpec ， ECPrivateKeySpec ， ECPublicKeySpec ， EncodedKeySpec ， PBEKeySpec ， PKCS8EncodedKeySpec ， RSAMultiPrimePrivateCrtKeySpec ， RSAPrivateCrtKeySpec ， RSAPrivateKeySpec ， RSAPublicKeySpec ， SecretKeySpec ， X509EncodedKeySpec

    public interface KeySpec
    构成加密密钥的密钥材料的（透明）规范。

    如果密钥存储在硬件设备上，则其规范可能包含有助于识别设备上的密钥的信息。

    密钥可以以特定于算法的方式或与算法无关的编码格式（例如ASN.1）来指定。 例如，DSA私钥可以通过它的组件指定x ， p ， q ，和g （参见DSAPrivateKeySpec ），或者它可使用其DER编码（见指定PKCS8EncodedKeySpec ）。

    此接口不包含方法或常量。 其唯一的目的是为所有关键规格分组（并提供类型安全）。 所有关键规格必须实现此接口。

    从以下版本开始：
    1.2
    另请参见：
    Key ， KeyFactory ， EncodedKeySpec ， X509EncodedKeySpec ， PKCS8EncodedKeySpec ， DSAPrivateKeySpec ， DSAPublicKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MGF1ParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class MGF1ParameterSpec

  • java.lang.Object
    • java.security.spec.MGF1ParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class MGF1ParameterSpec
extends Object
implements AlgorithmParameterSpec
    该类指定了在PKCS #1 v2.1标准中定义的OAEP填充和RSA-PSS签名方案中与掩码生成函数MGF1一起使用的参数集。

    其PKCS＃1标准中的ASN.1定义如下：

      MGF1Parameters ::= OAEP-PSSDigestAlgorthms
    哪里
      OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-sha1 PARAMETERS NULL   }|
   { OID id-sha224 PARAMETERS NULL   }|
   { OID id-sha256 PARAMETERS NULL }|
   { OID id-sha384 PARAMETERS NULL }|
   { OID id-sha512 PARAMETERS NULL },
   ...  -- Allows for future expansion --
 }
    从以下版本开始：
    1.5
    另请参见：
    PSSParameterSpec ， OAEPParameterSpec

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static MGF1ParameterSpec SHA1
      使用“SHA-1”消息摘要的MGF1ParameterSpec。
      static MGF1ParameterSpec SHA224
      使用“SHA-224”消息摘要的MGF1ParameterSpec。
      static MGF1ParameterSpec SHA256
      使用“SHA-256”消息摘要的MGF1ParameterSpec。
      static MGF1ParameterSpec SHA384
      使用“SHA-384”消息摘要的MGF1ParameterSpec。
      static MGF1ParameterSpec SHA512
      使用SHA-512消息摘要的MGF1ParameterSpec。

    • 构造方法摘要

      构造方法
      Constructor 描述
      MGF1ParameterSpec​(String mdName)
      为PKCS＃1标准中定义的掩码生成函数MGF1构造一个参数集。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getDigestAlgorithm​()
      返回掩码生成函数使用的消息摘要的算法名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • SHA1

        public static final MGF1ParameterSpec SHA1
        使用“SHA-1”消息摘要的MGF1ParameterSpec。

      • SHA224

        public static final MGF1ParameterSpec SHA224
        使用“SHA-224”消息摘要的MGF1ParameterSpec。

      • SHA256

        public static final MGF1ParameterSpec SHA256
        使用“SHA-256”消息摘要的MGF1ParameterSpec。

      • SHA384

        public static final MGF1ParameterSpec SHA384
        使用“SHA-384”消息摘要的MGF1ParameterSpec。

      • SHA512

        public static final MGF1ParameterSpec SHA512
        使用SHA-512消息摘要的MGF1ParameterSpec。

    • 构造方法详细信息

      • MGF1ParameterSpec

        public MGF1ParameterSpec​(String mdName)
        为PKCS＃1标准中定义的掩码生成函数MGF1构造一个参数集。
        参数
        mdName - 在该掩码生成函数MGF1中使用的消息摘要的算法名称。
        异常
        NullPointerException - 如果 mdName为空。

    • 方法详细信息

      • getDigestAlgorithm

        public String getDigestAlgorithm​()
        返回掩码生成函数使用的消息摘要的算法名称。
        结果
        消息摘要的算法名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PKCS8EncodedKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class PKCS8EncodedKeySpec

  • java.lang.Object
    • java.security.spec.EncodedKeySpec
      • java.security.spec.PKCS8EncodedKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class PKCS8EncodedKeySpec
extends EncodedKeySpec
    该类代表私有密钥的ASN.1编码，根据ASN.1类型PrivateKeyInfo编码。 PrivateKeyInfo语法在PKCS＃8标准中定义如下：
      PrivateKeyInfo ::= SEQUENCE {
   version Version,
   privateKeyAlgorithm PrivateKeyAlgorithmIdentifier,
   privateKey PrivateKey,
   attributes [0] IMPLICIT Attributes OPTIONAL }

 Version ::= INTEGER

 PrivateKeyAlgorithmIdentifier ::= AlgorithmIdentifier

 PrivateKey ::= OCTET STRING

 Attributes ::= SET OF Attribute
    从以下版本开始：
    1.2
    另请参见：
    Key ， KeyFactory ， KeySpec ， EncodedKeySpec ， X509EncodedKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      PKCS8EncodedKeySpec​(byte[] encodedKey)
      使用给定的编码密钥创建一个新的 PKCS8EncodedKeySpec 。
      PKCS8EncodedKeySpec​(byte[] encodedKey, String algorithm)
      使用给定的编码密钥和算法创建一个新的 PKCS8EncodedKeySpec 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getEncoded​()
      返回按照PKCS＃8标准编码的关键字节。
      String getFormat​()
      返回与此密钥规范相关联的编码格式的名称。

      • Methods inherited from class java.security.spec.EncodedKeySpec

        getAlgorithm

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PKCS8EncodedKeySpec

        public PKCS8EncodedKeySpec​(byte[] encodedKey)
        使用给定的编码密钥创建一个新的 PKCS8EncodedKeySpec 。
        参数
        encodedKey - 该密钥，假设根据PKCS＃8标准进行编码。 复制数组的内容以防止后续修改。
        异常
        NullPointerException - 如果 encodedKey为空。

      • PKCS8EncodedKeySpec

        public PKCS8EncodedKeySpec​(byte[] encodedKey,
                           String algorithm)
        使用给定的编码密钥和算法创建一个新的PKCS8EncodedKeySpec 。 当PKCS8EncodedKeySpec对象的后续调用者可能不知道私钥的算法时，此构造函数很有用。
        参数
        encodedKey - 假定根据PKCS＃8标准编码的密钥。 复制数组的内容以防止后续修改。
        algorithm - 编码私钥的算法名称有关标准算法名称的信息，请参阅 Java Security Standard Algorithm Names Specification中的KeyFactory部分。
        异常
        NullPointerException - 如果 encodedKey或 algorithm为空。
        IllegalArgumentException - 如果 algorithm是空字符串 ""
        从以下版本开始：
        9

    • 方法详细信息

      • getEncoded

        public byte[] getEncoded​()
        返回按照PKCS＃8标准编码的关键字节。
        重写：
        getEncoded在 EncodedKeySpec
        结果
        密钥的PKCS＃8编码。 每次调用此方法时都会返回一个新数组。

      • getFormat

        public final String getFormat​()
        返回与此密钥规范相关联的编码格式的名称。
        Specified by:
        getFormat在 EncodedKeySpec
        结果
        字符串 "PKCS#8" 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PSSParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class PSSParameterSpec

  • java.lang.Object
    • java.security.spec.PSSParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class PSSParameterSpec
extends Object
implements AlgorithmParameterSpec
    该类指定了PKCS#1 v2.1标准中定义的RSA-PSS签名方案的参数规范。

    其PKCS＃1标准中的ASN.1定义如下：

      RSASSA-PSS-params ::= SEQUENCE {
   hashAlgorithm      [0] OAEP-PSSDigestAlgorithms  DEFAULT sha1,
   maskGenAlgorithm   [1] PKCS1MGFAlgorithms  DEFAULT mgf1SHA1,
   saltLength         [2] INTEGER  DEFAULT 20,
   trailerField       [3] INTEGER  DEFAULT 1
 }
    哪里
      OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-sha1 PARAMETERS NULL   }|
   { OID id-sha224 PARAMETERS NULL   }|
   { OID id-sha256 PARAMETERS NULL }|
   { OID id-sha384 PARAMETERS NULL }|
   { OID id-sha512 PARAMETERS NULL },
   ...  -- Allows for future expansion --
 }

 PKCS1MGFAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-mgf1 PARAMETERS OAEP-PSSDigestAlgorithms },
   ...  -- Allows for future expansion --
 }

    注意：PSSParameterSpec.DEFAULT使用以下内容：消息摘要 - “SHA-1”掩码生成函数（mgf） - mgf - MGF1ParameterSpec.SHA1的“MGF1”参数SaltLength - 20 TrailerField - 1

    从以下版本开始：
    1.4
    另请参见：
    MGF1ParameterSpec ， AlgorithmParameterSpec ， Signature

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PSSParameterSpec DEFAULT
      PSS参数设置为所有默认值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PSSParameterSpec​(int saltLen)
      使用指定的盐长度和PKCS＃1中定义的其他默认值创建一个新的 PSSParameterSpec 。
      PSSParameterSpec​(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, int saltLen, int trailerField)
      使用指定的消息摘要，掩码生成功能，掩码生成功能参数，盐长度和尾部字段值创建PKCS＃1标准中定义的新的 PSSParameterSpec 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getDigestAlgorithm​()
      返回消息摘要算法名称。
      String getMGFAlgorithm​()
      返回掩码生成函数算法名称。
      AlgorithmParameterSpec getMGFParameters​()
      返回掩码生成函数的参数。
      int getSaltLength​()
      返回盐长度（以位为单位）。
      int getTrailerField​()
      返回预告片字段的值，即PKCS＃1 v2.1中的bc。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT

        public static final PSSParameterSpec DEFAULT
        PSS参数设置为所有默认值。
        从以下版本开始：
        1.5

    • 构造方法详细信息

      • PSSParameterSpec

        public PSSParameterSpec​(String mdName,
                        String mgfName,
                        AlgorithmParameterSpec mgfSpec,
                        int saltLen,
                        int trailerField)
        使用指定的消息摘要，掩码生成功能，掩码生成功能参数，盐长度和尾部字段值创建PKCS＃1标准中定义的新的 PSSParameterSpec 。
        参数
        mdName - 哈希函数的算法名称。
        mgfName - 掩码生成函数的算法名称。
        mgfSpec - 掩码生成功能的参数。 如果指定为null，则由getMGFParameters（）返回null。
        saltLen - 盐的长度。
        trailerField - 预告片字段的值。
        异常
        NullPointerException - 如果是 mdName或 mgfName为空。
        IllegalArgumentException - 如果 saltLen或 trailerField小于0。
        从以下版本开始：
        1.5

      • PSSParameterSpec

        public PSSParameterSpec​(int saltLen)
        使用指定的盐长度和PKCS＃1中定义的其他默认值创建一个新的 PSSParameterSpec 。
        参数
        saltLen - 要在PKCS＃1 PSS编码中使用的盐的长度。
        异常
        IllegalArgumentException - 如果 saltLen小于0。

    • 方法详细信息

      • getDigestAlgorithm

        public String getDigestAlgorithm​()
        返回消息摘要算法名称。
        结果
        消息摘要算法名称。
        从以下版本开始：
        1.5

      • getMGFAlgorithm

        public String getMGFAlgorithm​()
        返回掩码生成函数算法名称。
        结果
        面具生成函数算法名称。
        从以下版本开始：
        1.5

      • getMGFParameters

        public AlgorithmParameterSpec getMGFParameters​()
        返回掩码生成函数的参数。
        结果
        掩膜生成功能的参数。
        从以下版本开始：
        1.5

      • getSaltLength

        public int getSaltLength​()
        返回盐长度（以位为单位）。
        结果
        盐长度。

      • getTrailerField

        public int getTrailerField​()
        返回预告片字段的值，即PKCS＃1 v2.1中的bc。
        结果
        预告片段的值，即PKCS＃1 v2.1中的bc。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RSAKeyGenParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class RSAKeyGenParameterSpec

  • java.lang.Object
    • java.security.spec.RSAKeyGenParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class RSAKeyGenParameterSpec
extends Object
implements AlgorithmParameterSpec
    此类指定用于生成RSA密钥对的参数集。
    从以下版本开始：
    1.3
    另请参见：
    KeyPairGenerator.initialize(java.security.spec.AlgorithmParameterSpec)

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static BigInteger F0
      公众指数值F0 = 3。
      static BigInteger F4
      公共指数值F4 = 65537。

    • 构造方法摘要

      构造方法
      Constructor 描述
      RSAKeyGenParameterSpec​(int keysize, BigInteger publicExponent)
      从给定的keysize和public-exponent值构造一个新的 RSAParameterSpec对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getKeysize​()
      返回keysize。
      BigInteger getPublicExponent​()
      返回public-exponent值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • F0

        public static final BigInteger F0
        公众指数值F0 = 3。

      • F4

        public static final BigInteger F4
        公共指数值F4 = 65537。

    • 构造方法详细信息

      • RSAKeyGenParameterSpec

        public RSAKeyGenParameterSpec​(int keysize,
                              BigInteger publicExponent)
        从给定的keysize和public-exponent值构造一个新的 RSAParameterSpec对象。
        参数
        keysize - 模数大小（以位数表示）
        publicExponent - 公众指数

    • 方法详细信息

      • getKeysize

        public int getKeysize​()
        返回keysize。
        结果
        键盘。

      • getPublicExponent

        public BigInteger getPublicExponent​()
        返回public-exponent值。
        结果
        公众指数值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RSAMultiPrimePrivateCrtKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class RSAMultiPrimePrivateCrtKeySpec

  • java.lang.Object
    • java.security.spec.RSAPrivateKeySpec
      • java.security.spec.RSAMultiPrimePrivateCrtKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class RSAMultiPrimePrivateCrtKeySpec
extends RSAPrivateKeySpec
    该类指定PKCS＃1 v2.1中定义的RSA多权限私钥，使用中文余数定理（CRT）信息值进行效率。
    从以下版本开始：
    1.4
    另请参见：
    Key ， KeyFactory ， KeySpec ， PKCS8EncodedKeySpec ， RSAPrivateKeySpec ， RSAPublicKeySpec ， RSAOtherPrimeInfo

    • 构造方法摘要

      构造方法
      Constructor 描述
      RSAMultiPrimePrivateCrtKeySpec​(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient, RSAOtherPrimeInfo[] otherPrimeInfo)
      根据PKCS＃1 v2.1中定义的模数，publicExponent，privateExponent，primeP，primeQ，primeExponentP，primeExponentQ，crtCoefficient和otherPrimeInfo，创建一个新的 RSAMultiPrimePrivateCrtKeySpec 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getCrtCoefficient​()
      返回crtCoefficient。
      RSAOtherPrimeInfo[] getOtherPrimeInfo​()
      如果只有两个素因子（p和q），则返回otherPrimeInfo的副本或null。
      BigInteger getPrimeExponentP​()
      返回primeExponentP。
      BigInteger getPrimeExponentQ​()
      返回primeExponentQ。
      BigInteger getPrimeP​()
      返回primeP。
      BigInteger getPrimeQ​()
      返回primeQ。
      BigInteger getPublicExponent​()
      返回公共指数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.security.spec.RSAPrivateKeySpec

        getModulus, getPrivateExponent

    • 构造方法详细信息

      • RSAMultiPrimePrivateCrtKeySpec

        public RSAMultiPrimePrivateCrtKeySpec​(BigInteger modulus,
                                      BigInteger publicExponent,
                                      BigInteger privateExponent,
                                      BigInteger primeP,
                                      BigInteger primeQ,
                                      BigInteger primeExponentP,
                                      BigInteger primeExponentQ,
                                      BigInteger crtCoefficient,
                                      RSAOtherPrimeInfo[] otherPrimeInfo)
        创建一个新的RSAMultiPrimePrivateCrtKeySpec给定在PKCS＃1 v2.1中定义的模数，publicExponent，privateExponent，primeP，primeQ，primeExponentP，primeExponentQ，crtCoefficient和otherPrimeInfo。

        请注意，复制otherPrimeInfo的内容以防止在构建此对象时进行后续修改。

        参数
        modulus - 模数n。
        publicExponent - 公众指数e。
        privateExponent - 私有指数d。
        primeP - n的素因子p。
        primeQ - n的素因子q。
        primeExponentP - 这是d mod（p-1）。
        primeExponentQ - 这是d mod（q-1）。
        crtCoefficient - 中国剩余定理系数q-1 mod p。
        otherPrimeInfo - 如果只有两个素因子（p和q），则可以指定其余素数的三元组。
        异常
        NullPointerException -如果任何一个参数，即 modulus ， publicExponent ， privateExponent ， primeP ， primeQ ， primeExponentP ， primeExponentQ ， crtCoefficient ，为空。
        IllegalArgumentException - 如果指定一个空的，即0长度， otherPrimeInfo 。

    • 方法详细信息

      • getPublicExponent

        public BigInteger getPublicExponent​()
        返回公共指数。
        结果
        公众指数。

      • getPrimeP

        public BigInteger getPrimeP​()
        返回primeP。
        结果
        黄金。

      • getPrimeQ

        public BigInteger getPrimeQ​()
        返回primeQ。
        结果
        最好的。

      • getPrimeExponentP

        public BigInteger getPrimeExponentP​()
        返回primeExponentP。
        结果
        primeExponentP。

      • getPrimeExponentQ

        public BigInteger getPrimeExponentQ​()
        返回primeExponentQ。
        结果
        primeExponentQ。

      • getCrtCoefficient

        public BigInteger getCrtCoefficient​()
        返回crtCoefficient。
        结果
        crt系数。

      • getOtherPrimeInfo

        public RSAOtherPrimeInfo[] getOtherPrimeInfo​()
        如果只有两个素因子（p和q），则返回otherPrimeInfo的副本或null。
        结果
        otherPrimeInfo。 每次调用此方法时都会返回一个新数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RSAOtherPrimeInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class RSAOtherPrimeInfo

  • java.lang.Object
    • java.security.spec.RSAOtherPrimeInfo

  • public class RSAOtherPrimeInfo
extends Object
    该类表示RSA的OtherPrimeInfo结构中的三元组（素数，指数和系数），如PKCS＃1 v2.1中定义的。 RSA的OtherPrimeInfo的ASN.1语法如下：
      OtherPrimeInfo ::= SEQUENCE {
   prime INTEGER,
   exponent INTEGER,
   coefficient INTEGER
   }
    从以下版本开始：
    1.4
    另请参见：
    RSAPrivateCrtKeySpec ， RSAMultiPrimePrivateCrtKey

    • 构造方法摘要

      构造方法
      Constructor 描述
      RSAOtherPrimeInfo​(BigInteger prime, BigInteger primeExponent, BigInteger crtCoefficient)
      创建一个新的 RSAOtherPrimeInfo给定了PKCS＃1中定义的素数，素数和crtCoefficient。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getCrtCoefficient​()
      返回素数的crtCoefficient。
      BigInteger getExponent​()
      返回素数的指数。
      BigInteger getPrime​()
      返回素数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RSAOtherPrimeInfo

        public RSAOtherPrimeInfo​(BigInteger prime,
                         BigInteger primeExponent,
                         BigInteger crtCoefficient)
        创建一个新的 RSAOtherPrimeInfo给定了在PKCS＃1中定义的素数，素数，和crtCoefficient。
        参数
        prime - n的主要因素。
        primeExponent - 指数。
        crtCoefficient - 中国剩余定理系数。
        异常
        NullPointerException -如果任何一个参数，即 prime ， primeExponent ， crtCoefficient ，为空。

    • 方法详细信息

      • getPrime

        public final BigInteger getPrime​()
        返回素数。
        结果
        主要。

      • getExponent

        public final BigInteger getExponent​()
        返回素数的指数。
        结果
        主要成分。

      • getCrtCoefficient

        public final BigInteger getCrtCoefficient​()
        返回素数的crtCoefficient。
        结果
        crt系数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RSAPrivateCrtKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class RSAPrivateCrtKeySpec

  • java.lang.Object
    • java.security.spec.RSAPrivateKeySpec
      • java.security.spec.RSAPrivateCrtKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class RSAPrivateCrtKeySpec
extends RSAPrivateKeySpec
    该类指定PKCS＃1标准中定义的RSA私钥，使用中文余数定理（CRT）信息值进行效率。
    从以下版本开始：
    1.2
    另请参见：
    Key ， KeyFactory ， KeySpec ， PKCS8EncodedKeySpec ， RSAPrivateKeySpec ， RSAPublicKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      RSAPrivateCrtKeySpec​(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient)
      创建一个新的 RSAPrivateCrtKeySpec给定在PKCS＃1中定义的模数，publicExponent，privateExponent，primeP，primeQ，primeExponentP，primeExponentQ和crtCoefficient。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getCrtCoefficient​()
      返回crtCoefficient。
      BigInteger getPrimeExponentP​()
      返回primeExponentP。
      BigInteger getPrimeExponentQ​()
      返回primeExponentQ。
      BigInteger getPrimeP​()
      返回primeP。
      BigInteger getPrimeQ​()
      返回primeQ。
      BigInteger getPublicExponent​()
      返回公共指数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.security.spec.RSAPrivateKeySpec

        getModulus, getPrivateExponent

    • 构造方法详细信息

      • RSAPrivateCrtKeySpec

        public RSAPrivateCrtKeySpec​(BigInteger modulus,
                            BigInteger publicExponent,
                            BigInteger privateExponent,
                            BigInteger primeP,
                            BigInteger primeQ,
                            BigInteger primeExponentP,
                            BigInteger primeExponentQ,
                            BigInteger crtCoefficient)
        给定新的 RSAPrivateCrtKeySpec给定在PKCS＃1中定义的模数，publicExponent，privateExponent，primeP，primeQ，primeExponentP，primeExponentQ和crtCoefficient。
        参数
        modulus - 模数n
        publicExponent - 公众指数e
        privateExponent - 私人指数d
        primeP - n的素因子p
        primeQ - n的素因子q
        primeExponentP - 这是d mod（p-1）
        primeExponentQ - 这是d mod（q-1）
        crtCoefficient - 中国剩余定理系数q-1 mod p

    • 方法详细信息

      • getPublicExponent

        public BigInteger getPublicExponent​()
        返回公共指数。
        结果
        公众指数

      • getPrimeP

        public BigInteger getPrimeP​()
        返回primeP。
        结果
        黄金

      • getPrimeQ

        public BigInteger getPrimeQ​()
        返回primeQ。
        结果
        最好的

      • getPrimeExponentP

        public BigInteger getPrimeExponentP​()
        返回primeExponentP。
        结果
        primeExponentP

      • getPrimeExponentQ

        public BigInteger getPrimeExponentQ​()
        返回primeExponentQ。
        结果
        primeExponentQ

      • getCrtCoefficient

        public BigInteger getCrtCoefficient​()
        返回crtCoefficient。
        结果
        crt系数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RSAPrivateKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class RSAPrivateKeySpec

  • java.lang.Object
    • java.security.spec.RSAPrivateKeySpec
  • All Implemented Interfaces:
    KeySpec
    已知直接子类：
    RSAMultiPrimePrivateCrtKeySpec ， RSAPrivateCrtKeySpec

    public class RSAPrivateKeySpec
extends Object
implements KeySpec
    此类指定一个RSA私钥。
    从以下版本开始：
    1.2
    另请参见：
    Key ， KeyFactory ， KeySpec ， PKCS8EncodedKeySpec ， RSAPublicKeySpec ， RSAPrivateCrtKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      RSAPrivateKeySpec​(BigInteger modulus, BigInteger privateExponent)
      创建一个新的RSAPrivateKeySpec。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getModulus​()
      返回模数。
      BigInteger getPrivateExponent​()
      返回私有指数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RSAPrivateKeySpec

        public RSAPrivateKeySpec​(BigInteger modulus,
                         BigInteger privateExponent)
        创建一个新的RSAPrivateKeySpec。
        参数
        modulus - 模数
        privateExponent - 私人指数

    • 方法详细信息

      • getModulus

        public BigInteger getModulus​()
        返回模数。
        结果
        模数

      • getPrivateExponent

        public BigInteger getPrivateExponent​()
        返回私有指数。
        结果
        私人指数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RSAPublicKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class RSAPublicKeySpec

  • java.lang.Object
    • java.security.spec.RSAPublicKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class RSAPublicKeySpec
extends Object
implements KeySpec
    此类指定一个RSA公钥。
    从以下版本开始：
    1.2
    另请参见：
    Key ， KeyFactory ， KeySpec ， X509EncodedKeySpec ， RSAPrivateKeySpec ， RSAPrivateCrtKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      RSAPublicKeySpec​(BigInteger modulus, BigInteger publicExponent)
      创建一个新的RSAPublicKeySpec。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getModulus​()
      返回模数。
      BigInteger getPublicExponent​()
      返回公共指数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RSAPublicKeySpec

        public RSAPublicKeySpec​(BigInteger modulus,
                        BigInteger publicExponent)
        创建一个新的RSAPublicKeySpec。
        参数
        modulus - 模数
        publicExponent - 公众指数

    • 方法详细信息

      • getModulus

        public BigInteger getModulus​()
        返回模数。
        结果
        模数

      • getPublicExponent

        public BigInteger getPublicExponent​()
        返回公共指数。
        结果
        公众指数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.security.spec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.security.spec

  • Packages that use java.security.spec
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.crypto.dsig.spec
    XML数字签名的参数类。
  • Classes in java.security.spec used by java.security
    Class 描述
    AlgorithmParameterSpec
    密码参数的（透明）规范。
    InvalidKeySpecException
    这是无效密钥规范的例外。
    InvalidParameterSpecException
    这是无效参数规范的例外。
    KeySpec
    构成加密密钥的密钥材料的（透明）规范。
  • Classes in java.security.spec used by java.security.interfaces
    Class 描述
    ECParameterSpec
    这个不可变类指定了使用椭圆曲线加密（ECC）的一组域参数。
    ECPoint
    这个不可变的类表示仿射坐标中的椭圆曲线（EC）上的点。
    RSAOtherPrimeInfo
    该类表示RSA的OtherPrimeInfo结构中的三元组（素数，指数和系数），如PKCS＃1 v2.1中定义的。
  • Classes in java.security.spec used by java.security.spec
    Class 描述
    AlgorithmParameterSpec
    密码参数的（透明）规范。
    ECField
    该接口表示椭圆曲线（EC）有限域。
    ECParameterSpec
    这个不可变类指定了使用椭圆曲线加密（ECC）的一组域参数。
    ECPoint
    这个不可变的类表示仿射坐标中的椭圆曲线（EC）上的点。
    EllipticCurve
    这个不变的类保存代表椭圆曲线所需的必要值。
    EncodedKeySpec
    该类表示编码格式的公钥或私钥。
    KeySpec
    构成加密密钥的密钥材料的（透明）规范。
    MGF1ParameterSpec
    该类指定了在 PKCS #1 v2.1标准中定义的OAEP填充和RSA-PSS签名方案中与掩码生成函数MGF1一起使用的参数集合。
    PSSParameterSpec
    该类指定了 27058892336522标准中定义的RSA-PSS签名方案的参数规范。
    RSAOtherPrimeInfo
    该类表示RSA的OtherPrimeInfo结构中的三元组（素数，指数和系数），如PKCS＃1 v2.1中定义的。
    RSAPrivateKeySpec
    此类指定一个RSA私钥。
  • Classes in java.security.spec used by javax.crypto
    Class 描述
    AlgorithmParameterSpec
    密码参数的（透明）规范。
    InvalidKeySpecException
    这是无效密钥规范的例外。
    KeySpec
    构成加密密钥的密钥材料的（透明）规范。
    PKCS8EncodedKeySpec
    该类代表私有密钥的ASN.1编码，根据ASN.1类型 PrivateKeyInfo编码。
  • Classes in java.security.spec used by javax.crypto.spec
    Class 描述
    AlgorithmParameterSpec
    密码参数的（透明）规范。
    KeySpec
    构成加密密钥的密钥材料的（透明）规范。
  • Classes in java.security.spec used by javax.xml.crypto
    Class 描述
    AlgorithmParameterSpec
    密码参数的（透明）规范。
  • Classes in java.security.spec used by javax.xml.crypto.dsig
    Class 描述
    AlgorithmParameterSpec
    密码参数的（透明）规范。
  • Classes in java.security.spec used by javax.xml.crypto.dsig.spec
    Class 描述
    AlgorithmParameterSpec
    密码参数的（透明）规范。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


X509EncodedKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.security.spec

Class X509EncodedKeySpec

  • java.lang.Object
    • java.security.spec.EncodedKeySpec
      • java.security.spec.X509EncodedKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class X509EncodedKeySpec
extends EncodedKeySpec
    该类表示公钥的ASN.1编码，根据ASN.1类型SubjectPublicKeyInfo编码。 SubjectPublicKeyInfo语法在X.509标准中定义如下：
      SubjectPublicKeyInfo ::= SEQUENCE {
   algorithm AlgorithmIdentifier,
   subjectPublicKey BIT STRING }
    从以下版本开始：
    1.2
    另请参见：
    Key ， KeyFactory ， KeySpec ， EncodedKeySpec ， PKCS8EncodedKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      X509EncodedKeySpec​(byte[] encodedKey)
      使用给定的编码密钥创建一个新的 X509EncodedKeySpec 。
      X509EncodedKeySpec​(byte[] encodedKey, String algorithm)
      使用给定的编码密钥创建一个新的 X509EncodedKeySpec 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getEncoded​()
      返回按照X.509标准编码的关键字节。
      String getFormat​()
      返回与此密钥规范相关联的编码格式的名称。

      • Methods inherited from class java.security.spec.EncodedKeySpec

        getAlgorithm

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • X509EncodedKeySpec

        public X509EncodedKeySpec​(byte[] encodedKey)
        使用给定的编码密钥创建一个新的 X509EncodedKeySpec 。
        参数
        encodedKey - 该密钥，假定是根据X.509标准进行编码的。 复制数组的内容以防止后续修改。
        异常
        NullPointerException - 如果 encodedKey为空。

      • X509EncodedKeySpec

        public X509EncodedKeySpec​(byte[] encodedKey,
                          String algorithm)
        使用给定的编码密钥创建一个新的X509EncodedKeySpec 。 当X509EncodedKeySpec对象的后续调用者可能不知道密钥的算法时，此构造函数很有用。
        参数
        encodedKey - 假定根据X.509标准编码的密钥。 复制数组的内容以防止后续修改。
        algorithm - 编码公钥的算法名称有关标准算法名称的信息，请参阅 Java Security Standard Algorithm Names Specification中的KeyFactory部分。
        异常
        NullPointerException - 如果 encodedKey或 algorithm为空。
        IllegalArgumentException - 如果 algorithm是空字符串 ""
        从以下版本开始：
        9

    • 方法详细信息

      • getEncoded

        public byte[] getEncoded​()
        返回按照X.509标准编码的关键字节。
        重写：
        getEncoded在 EncodedKeySpec
        结果
        密钥的X.509编码。 每次调用此方法时都会返回一个新数组。

      • getFormat

        public final String getFormat​()
        返回与此密钥规范相关联的编码格式的名称。
        Specified by:
        getFormat在 EncodedKeySpec
        结果
        字符串 "X.509" 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class java.security.spec.DSAGenParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.DSAGenParameterSpec

No usage of java.security.spec.DSAGenParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.DSAParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.DSAParameterSpec

No usage of java.security.spec.DSAParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.DSAPrivateKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.DSAPrivateKeySpec

No usage of java.security.spec.DSAPrivateKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.DSAPublicKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.DSAPublicKeySpec

No usage of java.security.spec.DSAPublicKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.ECFieldF2m (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.ECFieldF2m

No usage of java.security.spec.ECFieldF2m
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.ECFieldFp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.ECFieldFp

No usage of java.security.spec.ECFieldFp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.ECGenParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.ECGenParameterSpec

No usage of java.security.spec.ECGenParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.ECParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.ECParameterSpec

  • Packages that use ECParameterSpec
    软件包 描述
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of ECParameterSpec in java.security.interfaces

      Methods in java.security.interfaces that return ECParameterSpec
      Modifier and Type 方法 描述
      ECParameterSpec ECKey.getParams​()
      返回与此关键字关联的域参数。

    • Uses of ECParameterSpec in java.security.spec

      Methods in java.security.spec that return ECParameterSpec
      Modifier and Type 方法 描述
      ECParameterSpec ECPrivateKeySpec.getParams​()
      返回相关的椭圆曲线域参数。
      ECParameterSpec ECPublicKeySpec.getParams​()
      返回相关的椭圆曲线域参数。
      Constructors in java.security.spec with parameters of type ECParameterSpec
      Constructor 描述
      ECPrivateKeySpec​(BigInteger s, ECParameterSpec params)
      用指定的参数值创建一个新的ECPrivateKeySpec。
      ECPublicKeySpec​(ECPoint w, ECParameterSpec params)
      Creates a new ECPublicKeySpec with the specified parameter values.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.ECPoint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.ECPoint

  • Packages that use ECPoint
    软件包 描述
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of ECPoint in java.security.interfaces

      Methods in java.security.interfaces that return ECPoint
      Modifier and Type 方法 描述
      ECPoint ECPublicKey.getW​()
      返回公共点W.

    • Uses of ECPoint in java.security.spec

      Fields in java.security.spec declared as ECPoint
      Modifier and Type Field 描述
      static ECPoint ECPoint.POINT_INFINITY
      这定义了无限远的点。
      Methods in java.security.spec that return ECPoint
      Modifier and Type 方法 描述
      ECPoint ECParameterSpec.getGenerator​()
      返回也称为基点的生成器。
      ECPoint ECPublicKeySpec.getW​()
      返回公共点W.
      Constructors in java.security.spec with parameters of type ECPoint
      Constructor 描述
      ECParameterSpec​(EllipticCurve curve, ECPoint g, BigInteger n, int h)
      根据指定的值创建椭圆曲线域参数。
      ECPublicKeySpec​(ECPoint w, ECParameterSpec params)
      用指定的参数值创建一个新的ECPublicKeySpec。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.ECPrivateKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.ECPrivateKeySpec

No usage of java.security.spec.ECPrivateKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.ECPublicKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.ECPublicKeySpec

No usage of java.security.spec.ECPublicKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.EllipticCurve (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.EllipticCurve

  • Packages that use EllipticCurve
    软件包 描述
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of EllipticCurve in java.security.spec

      Methods in java.security.spec that return EllipticCurve
      Modifier and Type 方法 描述
      EllipticCurve ECParameterSpec.getCurve​()
      返回此参数定义的椭圆曲线。
      Constructors in java.security.spec with parameters of type EllipticCurve
      Constructor 描述
      ECParameterSpec​(EllipticCurve curve, ECPoint g, BigInteger n, int h)
      根据指定的值创建椭圆曲线域参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.EncodedKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.EncodedKeySpec

  • Packages that use EncodedKeySpec
    软件包 描述
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of EncodedKeySpec in java.security.spec

      Subclasses of EncodedKeySpec in java.security.spec
      Modifier and Type Class 描述
      class  PKCS8EncodedKeySpec
      该类表示ASN.1编码的私钥，根据ASN.1类型编码 PrivateKeyInfo 。
      class  X509EncodedKeySpec
      该类表示公钥的ASN.1编码，根据ASN.1类型 SubjectPublicKeyInfo编码。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.InvalidKeySpecException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.InvalidKeySpecException

  • Packages that use InvalidKeySpecException
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.crypto
    提供加密操作的类和接口。

    • Uses of InvalidKeySpecException in java.security

      Methods in java.security that throw InvalidKeySpecException
      Modifier and Type 方法 描述
      protected abstract PrivateKey KeyFactorySpi.engineGeneratePrivate​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成私钥对象。
      protected abstract PublicKey KeyFactorySpi.engineGeneratePublic​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成公钥对象。
      protected abstract <T extends KeySpec>
      T             		KeyFactorySpi.engineGetKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。
      PrivateKey KeyFactory.generatePrivate​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成私钥对象。
      PublicKey KeyFactory.generatePublic​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成公钥对象。
      <T extends KeySpec>
      T             		KeyFactory.getKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。

    • Uses of InvalidKeySpecException in javax.crypto

      Methods in javax.crypto that throw InvalidKeySpecException
      Modifier and Type 方法 描述
      protected abstract SecretKey SecretKeyFactorySpi.engineGenerateSecret​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成一个 SecretKey对象。
      protected abstract KeySpec SecretKeyFactorySpi.engineGetKeySpec​(SecretKey key, Class<?> keySpec)
      以请求的格式返回给定键对象的规范（关键材料）。
      SecretKey SecretKeyFactory.generateSecret​(KeySpec keySpec)
      根据提供的密钥规范（密钥材料）生成一个 SecretKey对象。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Cipher cipher)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      KeySpec SecretKeyFactory.getKeySpec​(SecretKey key, Class<?> keySpec)
      Returns a specification (key material) of the given key object in the requested format.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.InvalidParameterSpecException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.InvalidParameterSpecException

  • Packages that use InvalidParameterSpecException
    软件包 描述
    java.security
    提供安全框架的类和接口。

    • Uses of InvalidParameterSpecException in java.security

      Methods in java.security that throw InvalidParameterSpecException
      Modifier and Type 方法 描述
      protected abstract <T extends AlgorithmParameterSpec>
      T             		AlgorithmParametersSpi.engineGetParameterSpec​(Class<T> paramSpec)
      返回此参数对象的（透明）规范。
      protected abstract void AlgorithmParametersSpi.engineInit​(AlgorithmParameterSpec paramSpec)
      使用 paramSpec指定的参数初始化此参数对象。
      <T extends AlgorithmParameterSpec>
      T             		AlgorithmParameters.getParameterSpec​(Class<T> paramSpec)
      返回此参数对象的（透明）规范。
      void AlgorithmParameters.init​(AlgorithmParameterSpec paramSpec)
      使用 paramSpec指定的参数初始化此参数对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.MGF1ParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.MGF1ParameterSpec

  • Packages that use MGF1ParameterSpec
    软件包 描述
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of MGF1ParameterSpec in java.security.spec

      Fields in java.security.spec declared as MGF1ParameterSpec
      Modifier and Type Field 描述
      static MGF1ParameterSpec MGF1ParameterSpec.SHA1
      使用“SHA-1”消息摘要的MGF1ParameterSpec。
      static MGF1ParameterSpec MGF1ParameterSpec.SHA224
      使用“SHA-224”消息摘要的MGF1ParameterSpec。
      static MGF1ParameterSpec MGF1ParameterSpec.SHA256
      使用“SHA-256”消息摘要的MGF1ParameterSpec。
      static MGF1ParameterSpec MGF1ParameterSpec.SHA384
      使用“SHA-384”消息摘要的MGF1ParameterSpec。
      static MGF1ParameterSpec MGF1ParameterSpec.SHA512
      使用SHA-512消息摘要的MGF1ParameterSpec。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.PKCS8EncodedKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.PKCS8EncodedKeySpec

  • Packages that use PKCS8EncodedKeySpec
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of PKCS8EncodedKeySpec in javax.crypto

      Methods in javax.crypto that return PKCS8EncodedKeySpec
      Modifier and Type 方法 描述
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, String providerName)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, Provider provider)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Cipher cipher)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.PSSParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.PSSParameterSpec

  • Packages that use PSSParameterSpec
    软件包 描述
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of PSSParameterSpec in java.security.spec

      Fields in java.security.spec declared as PSSParameterSpec
      Modifier and Type Field 描述
      static PSSParameterSpec PSSParameterSpec.DEFAULT
      PSS参数设置为所有默认值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.RSAKeyGenParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.RSAKeyGenParameterSpec

No usage of java.security.spec.RSAKeyGenParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.RSAMultiPrimePrivateCrtKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.RSAMultiPrimePrivateCrtKeySpec

No usage of java.security.spec.RSAMultiPrimePrivateCrtKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.RSAOtherPrimeInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.RSAOtherPrimeInfo

  • Packages that use RSAOtherPrimeInfo
    软件包 描述
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of RSAOtherPrimeInfo in java.security.interfaces

      Methods in java.security.interfaces that return RSAOtherPrimeInfo
      Modifier and Type 方法 描述
      RSAOtherPrimeInfo[] RSAMultiPrimePrivateCrtKey.getOtherPrimeInfo​()
      如果只有两个素因子（p和q），则返回otherPrimeInfo或null。

    • Uses of RSAOtherPrimeInfo in java.security.spec

      Methods in java.security.spec that return RSAOtherPrimeInfo
      Modifier and Type 方法 描述
      RSAOtherPrimeInfo[] RSAMultiPrimePrivateCrtKeySpec.getOtherPrimeInfo​()
      如果只有两个素因子（p和q），则返回otherPrimeInfo的副本或null。
      Constructors in java.security.spec with parameters of type RSAOtherPrimeInfo
      Constructor 描述
      RSAMultiPrimePrivateCrtKeySpec​(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient, RSAOtherPrimeInfo[] otherPrimeInfo)
      创建一个新的 RSAMultiPrimePrivateCrtKeySpec给定在PKCS＃1 v2.1中定义的modulus，publicExponent，privateExponent，primeP，primeQ，primeExponentP，primeExponentQ，crtCoefficient和otherPrimeInfo。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.RSAPrivateCrtKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.RSAPrivateCrtKeySpec

No usage of java.security.spec.RSAPrivateCrtKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.RSAPrivateKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.RSAPrivateKeySpec

  • Packages that use RSAPrivateKeySpec
    软件包 描述
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of RSAPrivateKeySpec in java.security.spec

      Subclasses of RSAPrivateKeySpec in java.security.spec
      Modifier and Type Class 描述
      class  RSAMultiPrimePrivateCrtKeySpec
      该类指定PKCS＃1 v2.1中定义的RSA多权限私钥，使用中文余数定理（CRT）信息值进行效率。
      class  RSAPrivateCrtKeySpec
      该类指定PKCS＃1标准中定义的RSA私钥，使用中文余数定理（CRT）信息值进行效率。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.RSAPublicKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.RSAPublicKeySpec

No usage of java.security.spec.RSAPublicKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.security.spec.X509EncodedKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.security.spec.X509EncodedKeySpec

No usage of java.security.spec.X509EncodedKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.spec.AlgorithmParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.spec.AlgorithmParameterSpec

  • Packages that use AlgorithmParameterSpec
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.crypto.dsig.spec
    XML数字签名的参数类。

    • Uses of AlgorithmParameterSpec in java.security

      Methods in java.security with type parameters of type AlgorithmParameterSpec
      Modifier and Type 方法 描述
      protected abstract <T extends AlgorithmParameterSpec>
      T             		AlgorithmParametersSpi.engineGetParameterSpec​(Class<T> paramSpec)
      返回此参数对象的（透明）规范。
      <T extends AlgorithmParameterSpec>
      T             		AlgorithmParameters.getParameterSpec​(Class<T> paramSpec)
      返回此参数对象的（透明）规范。
      Methods in java.security that return AlgorithmParameterSpec
      Modifier and Type 方法 描述
      AlgorithmParameterSpec KeyStore.PasswordProtection.getProtectionParameters​()
      获取为保护算法提供的参数。
      Methods in java.security with parameters of type AlgorithmParameterSpec
      Modifier and Type 方法 描述
      protected abstract void AlgorithmParameterGeneratorSpi.engineInit​(AlgorithmParameterSpec genParamSpec, SecureRandom random)
      使用一组特定于算法的参数生成值初始化此参数生成器。
      protected abstract void AlgorithmParametersSpi.engineInit​(AlgorithmParameterSpec paramSpec)
      使用 paramSpec指定的参数初始化此参数对象。
      protected void SignatureSpi.engineSetParameter​(AlgorithmParameterSpec params)
      提供者将覆盖此方法以使用指定的参数集来初始化此签名引擎。
      void AlgorithmParameterGenerator.init​(AlgorithmParameterSpec genParamSpec)
      使用一组特定于算法的参数生成值初始化此参数生成器。
      void AlgorithmParameterGenerator.init​(AlgorithmParameterSpec genParamSpec, SecureRandom random)
      使用一组特定于算法的参数生成值初始化此参数生成器。
      void AlgorithmParameters.init​(AlgorithmParameterSpec paramSpec)
      使用 paramSpec指定的参数初始化此参数对象。
      void KeyPairGenerator.initialize​(AlgorithmParameterSpec params)
      使用指定的参数集和最高优先级的安装提供程序的 SecureRandom实现来初始化密钥对生成器作为随机源。
      void KeyPairGenerator.initialize​(AlgorithmParameterSpec params, SecureRandom random)
      使用给定的参数集和随机源初始化密钥对生成器。
      void KeyPairGeneratorSpi.initialize​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化密钥对生成器。
      void Signature.setParameter​(AlgorithmParameterSpec params)
      使用指定的参数集初始化此签名引擎。
      Constructors in java.security with parameters of type AlgorithmParameterSpec
      Constructor 描述
      PasswordProtection​(char[] password, String protectionAlgorithm, AlgorithmParameterSpec protectionParameters)
      创建密码参数，并指定在加密密钥库条目时使用的保护算法和相关参数。

    • Uses of AlgorithmParameterSpec in java.security.spec

      Classes in java.security.spec that implement AlgorithmParameterSpec
      Modifier and Type Class 描述
      class  DSAGenParameterSpec
      这个不可变类指定了用于生成如 FIPS 186-3 Digital Signature Standard (DSS)中指定的DSA参数的参数 集 。
      class  DSAParameterSpec
      该类指定与DSA算法一起使用的参数集。
      class  ECGenParameterSpec
      这个不可变类指定用于生成椭圆曲线（EC）域参数的参数集。
      class  ECParameterSpec
      这个不可变类指定了使用椭圆曲线加密（ECC）的一组域参数。
      class  MGF1ParameterSpec
      该类别规定了在 PKCS #1 v2.1标准中定义的OAEP填充和RSA-PSS签名方案中与掩码生成函数MGF1一起使用的参数集合。
      class  PSSParameterSpec
      该类指定了 PKCS#1 v2.1标准中定义的RSA-PSS签名方案的参数规范。
      class  RSAKeyGenParameterSpec
      此类指定用于生成RSA密钥对的参数集。
      Methods in java.security.spec that return AlgorithmParameterSpec
      Modifier and Type 方法 描述
      AlgorithmParameterSpec PSSParameterSpec.getMGFParameters​()
      返回掩码生成函数的参数。
      Constructors in java.security.spec with parameters of type AlgorithmParameterSpec
      Constructor 描述
      PSSParameterSpec​(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, int saltLen, int trailerField)
      使用指定的消息摘要，掩码生成功能，掩码生成函数的参数，盐长度和尾部字段值创建PKCS＃1标准中定义的新的 PSSParameterSpec 。

    • Uses of AlgorithmParameterSpec in javax.crypto

      Methods in javax.crypto that return AlgorithmParameterSpec
      Modifier and Type 方法 描述
      static AlgorithmParameterSpec Cipher.getMaxAllowedParameterSpec​(String transformation)
      返回一个AlgorithmParameterSpec对象，该对象包含根据管辖区策略文件的最大密码参数值。
      Methods in javax.crypto with parameters of type AlgorithmParameterSpec
      Modifier and Type 方法 描述
      protected abstract void CipherSpi.engineInit​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      protected abstract void KeyAgreementSpi.engineInit​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      protected abstract void KeyGeneratorSpi.engineInit​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化密钥生成器。
      protected abstract void MacSpi.engineInit​(Key key, AlgorithmParameterSpec params)
      用给定（秘密）密钥和算法参数初始化MAC。
      void Cipher.init​(int opmode, Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此密码。
      void Cipher.init​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void ExemptionMechanism.init​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      void KeyAgreement.init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数集初始化此密钥协议。
      void KeyAgreement.init​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
      void KeyGenerator.init​(AlgorithmParameterSpec params)
      使用指定的参数集初始化此密钥生成器。
      void KeyGenerator.init​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化此密钥生成器。
      void Mac.init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数初始化此 Mac对象。

    • Uses of AlgorithmParameterSpec in javax.crypto.spec

      Classes in javax.crypto.spec that implement AlgorithmParameterSpec
      Modifier and Type Class 描述
      class  DHGenParameterSpec
      此类指定用于生成Diffie-Hellman密钥协议中使用的Diffie-Hellman（系统）参数的参数集。
      class  DHParameterSpec
      该类指定与PKCS＃3： Diffie-Hellman密钥协商标准中指定的Diffie-Hellman算法一起使用的参数集合。
      class  GCMParameterSpec
      指定Cipher使用伽罗瓦/计数器模式（GCM）模式所需的一组参数。
      class  IvParameterSpec
      该类指定 初始化向量 （IV）。
      class  OAEPParameterSpec
      该类指定与OAEP填充一起使用的参数集，如 PKCS #1标准中所定义。
      class  PBEParameterSpec
      该类指定了基于密码的加密（PBE）使用的参数集，如 PKCS #5标准中所定义。
      class  RC2ParameterSpec
      该类指定与 RC2算法一起使用的参数。
      class  RC5ParameterSpec
      该类指定与 RC5算法一起使用的参数。
      Methods in javax.crypto.spec that return AlgorithmParameterSpec
      Modifier and Type 方法 描述
      AlgorithmParameterSpec OAEPParameterSpec.getMGFParameters​()
      返回掩码生成函数的参数。
      AlgorithmParameterSpec PBEParameterSpec.getParameterSpec​()
      返回密码算法参数规范。
      Constructors in javax.crypto.spec with parameters of type AlgorithmParameterSpec
      Constructor 描述
      OAEPParameterSpec​(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
      构造为使用指定的消息摘要算法在PKCS＃1标准中定义的OAEP冗余参数集 mdName ，掩码生成函数算法 mgfName ，掩码生成函数参数 mgfSpec编码输入P的，和源 pSrc 。
      PBEParameterSpec​(byte[] salt, int iterationCount, AlgorithmParameterSpec paramSpec)
      构建PKCS＃5标准中定义的基于密码的加密参数集。

    • Uses of AlgorithmParameterSpec in javax.xml.crypto

      Methods in javax.xml.crypto that return AlgorithmParameterSpec
      Modifier and Type 方法 描述
      AlgorithmParameterSpec AlgorithmMethod.getParameterSpec​()
      返回此 AlgorithmMethod的算法参数。

    • Uses of AlgorithmParameterSpec in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return AlgorithmParameterSpec
      Modifier and Type 方法 描述
      AlgorithmParameterSpec CanonicalizationMethod.getParameterSpec​()
      返回与该 CanonicalizationMethod相关联的特定于算法的输入参数。
      AlgorithmParameterSpec DigestMethod.getParameterSpec​()
      返回与该 DigestMethod相关联的特定于算法的输入参数。
      AlgorithmParameterSpec SignatureMethod.getParameterSpec​()
      返回该算法特定的输入参数 SignatureMethod 。
      AlgorithmParameterSpec Transform.getParameterSpec​()
      返回与此 Transform相关的特定于算法的输入参数。

    • Uses of AlgorithmParameterSpec in javax.xml.crypto.dsig.spec

      Subinterfaces of AlgorithmParameterSpec in javax.xml.crypto.dsig.spec
      Modifier and Type 接口 描述
      interface  C14NMethodParameterSpec
      一个CanonicalizationMethod算法的算法参数的规范 。
      interface  DigestMethodParameterSpec
      一个DigestMethod算法的算法参数说明 。
      interface  SignatureMethodParameterSpec
      XML SignatureMethod算法的算法参数说明 。
      interface  TransformParameterSpec
      一个Transform算法的算法参数说明 。
      Classes in javax.xml.crypto.dsig.spec that implement AlgorithmParameterSpec
      Modifier and Type Class 描述
      class  ExcC14NParameterSpec
      W3C推荐参数： Exclusive XML Canonicalization (C14N) algorithm 。
      class  HMACParameterSpec
      参数为 XML Signature HMAC Algorithm 。
      class  XPathFilter2ParameterSpec
      参考W3C推荐 XPath Filter 2.0 Transform Algorithm 。
      class  XPathFilterParameterSpec
      参数为 XPath Filtering Transform Algorithm 。
      class  XSLTTransformParameterSpec
      参数为 XSLT Transform Algorithm 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.spec.ECField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.spec.ECField

  • Packages that use ECField
    软件包 描述
    java.security.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of ECField in java.security.spec

      Classes in java.security.spec that implement ECField
      Modifier and Type Class 描述
      class  ECFieldF2m
      这个不可变类定义了椭圆曲线（EC）特征2有限域。
      class  ECFieldFp
      这个不可变类定义了椭圆曲线（EC）素数有限域。
      Methods in java.security.spec that return ECField
      Modifier and Type 方法 描述
      ECField EllipticCurve.getField​()
      返回这个椭圆曲线结束的有限域 field 。
      Constructors in java.security.spec with parameters of type ECField
      Constructor 描述
      EllipticCurve​(ECField field, BigInteger a, BigInteger b)
      创建具有指定的椭圆场 field和系数 a和 b的椭圆曲线。
      EllipticCurve​(ECField field, BigInteger a, BigInteger b, byte[] seed)
      创建具有指定的椭圆字段 field ，系数 a和 b以及用于曲线生成的 seed的椭圆曲线。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.security.spec.KeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.security.spec.KeySpec

  • Packages that use KeySpec
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of KeySpec in java.security

      Methods in java.security with type parameters of type KeySpec
      Modifier and Type 方法 描述
      protected abstract <T extends KeySpec>
      T             		KeyFactorySpi.engineGetKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。
      <T extends KeySpec>
      T             		KeyFactory.getKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。
      Methods in java.security with parameters of type KeySpec
      Modifier and Type 方法 描述
      protected abstract PrivateKey KeyFactorySpi.engineGeneratePrivate​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成私钥对象。
      protected abstract PublicKey KeyFactorySpi.engineGeneratePublic​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成公钥对象。
      PrivateKey KeyFactory.generatePrivate​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成私钥对象。
      PublicKey KeyFactory.generatePublic​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成公钥对象。

    • Uses of KeySpec in java.security.spec

      Classes in java.security.spec that implement KeySpec
      Modifier and Type Class 描述
      class  DSAPrivateKeySpec
      此类指定具有相关参数的DSA私钥。
      class  DSAPublicKeySpec
      该类指定具有相关参数的DSA公钥。
      class  ECPrivateKeySpec
      这个不可变类指定一个带有关联参数的椭圆曲线私钥。
      class  ECPublicKeySpec
      这个不可变类指定了一个带有关联参数的椭圆曲线公钥。
      class  EncodedKeySpec
      该类表示编码格式的公钥或私钥。
      class  PKCS8EncodedKeySpec
      该类代表私有密钥的ASN.1编码，根据ASN.1类型 PrivateKeyInfo编码。
      class  RSAMultiPrimePrivateCrtKeySpec
      该类指定PKCS＃1 v2.1中定义的RSA多权限私钥，使用中文余数定理（CRT）信息值进行效率。
      class  RSAPrivateCrtKeySpec
      该类指定PKCS＃1标准中定义的RSA私钥，使用中文余数定理（CRT）信息值进行效率。
      class  RSAPrivateKeySpec
      此类指定一个RSA私钥。
      class  RSAPublicKeySpec
      此类指定一个RSA公钥。
      class  X509EncodedKeySpec
      该类表示公钥的ASN.1编码，根据ASN.1类型 SubjectPublicKeyInfo编码。

    • Uses of KeySpec in javax.crypto

      Methods in javax.crypto that return KeySpec
      Modifier and Type 方法 描述
      protected abstract KeySpec SecretKeyFactorySpi.engineGetKeySpec​(SecretKey key, Class<?> keySpec)
      以请求的格式返回给定键对象的规范（关键材料）。
      KeySpec SecretKeyFactory.getKeySpec​(SecretKey key, Class<?> keySpec)
      以请求的格式返回给定键对象的规范（关键材料）。
      Methods in javax.crypto with parameters of type KeySpec
      Modifier and Type 方法 描述
      protected abstract SecretKey SecretKeyFactorySpi.engineGenerateSecret​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成一个 SecretKey对象。
      SecretKey SecretKeyFactory.generateSecret​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成一个 SecretKey对象。

    • Uses of KeySpec in javax.crypto.spec

      Classes in javax.crypto.spec that implement KeySpec
      Modifier and Type Class 描述
      class  DESedeKeySpec
      该类指定DES-EDE（“triple-DES”）键。
      class  DESKeySpec
      该类指定一个DES密钥。
      class  DHPrivateKeySpec
      该类指定具有相关参数的Diffie-Hellman私钥。
      class  DHPublicKeySpec
      该类指定具有相关参数的Diffie-Hellman公钥。
      class  PBEKeySpec
      用户选择的密码，可用于基于密码的加密（ PBE ）。
      class  SecretKeySpec
      This class specifies a secret key in a provider-independent fashion.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Array (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Array

  • 所有已知实现类：
    SerialArray

    public interface Array
    用于SQL编程语言的映射类型为ARRAY 。 默认情况下， Array值是对SQL ARRAY值的事务持续时间引用。 默认情况下，使用内部的SQL LOCATOR（数组）实现一个Array对象，这意味着一个Array对象包含一个逻辑指针，指向SQL ARRAY值中的数据，而不是包含ARRAY值的数据。

    Array接口提供了将SQL ARRAY值的数据作为数组或ResultSet对象提供给客户端的ResultSet 。 如果SQL ARRAY的元素是UDT，则它们可能是自定义映射的。 要创建自定义映射，程序员必须做两件事情：

    • 创建一个实现SQLData接口的类，以便UDT进行自定义映射。
    • 在包含的类型映射中创建一个条目
      • UDT的完全限定的SQL类型名称
      • Class对象为类实现SQLData

    当具有基本类型的条目的类型映射被提供给方法getArray和getResultSet ，其包含的映射将用于映射ARRAY值的元素。 如果没有提供类型图，通常情况下，默认情况下将使用连接的类型映射。 如果连接的类型映射或提供给方法的类型映射没有基本类型的条目，则会根据标准映射映射元素。

    如果JDBC驱动程序支持数据类型，则必须完全实现Array接口上的所有方法。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void free​()
      该方法释放 Array对象并释放其所拥有的资源。
      Object getArray​()
      以Java编程语言的形式获取此 Array对象指定的SQL ARRAY值的内容。
      Object getArray​(long index, int count)
      检索由该 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。
      Object getArray​(long index, int count, Map<String,Class<?>> map)
      检索由该 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。
      Object getArray​(Map<String,Class<?>> map)
      检索此 Array对象指定的SQL ARRAY值的内容。
      int getBaseType​()
      检索此 Array对象指定的数组中的元素的JDBC类型。
      String getBaseTypeName​()
      检索此 Array对象指定的数组中的元素的SQL类型名称。
      ResultSet getResultSet​()
      检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。
      ResultSet getResultSet​(long index, int count)
      检索一个结果集，该结果集包含从索引 index开始的子阵列的元素，并包含最多 count连续元素。
      ResultSet getResultSet​(long index, int count, Map<String,Class<?>> map)
      检索一个结果集，该结果集包含从索引 index开始的子阵列的元素，并包含最多 count连续元素。
      ResultSet getResultSet​(Map<String,Class<?>> map)
      检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。

    • 方法详细信息

      • getBaseTypeName

        String getBaseTypeName​()
                throws SQLException
        检索此Array对象指定的数组中的元素的SQL类型名称。 如果元素是内置类型，则返回元素的特定于数据库的类型名称。 如果元素是用户定义类型（UDT），则此方法返回完全限定的SQL类型名称。
        结果
        一个String ，它是内置基类型的数据库特定名称; 或作为UDT的基本类型的完全限定的SQL类型名称
        异常
        SQLException - 如果尝试访问类型名称时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getBaseType

        int getBaseType​()
         throws SQLException
        检索此 Array对象指定的数组中的元素的JDBC类型。
        结果
        一个常数来自类Types ，它是由Array对象指定的数组中的元素的类型代码
        异常
        SQLException - 如果尝试访问基本类型时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getArray

        Object getArray​()
         throws SQLException
        以Java编程语言的形式Array由该Array对象指定的SQL ARRAY值的内容。 方法getArray此版本使用与连接相关联的类型映射来自定义类型映射。

        注意：当使用getArray实现映射到原始数据类型的基本类型时，实现定义是否返回的数组是该基元数据类型的数组或Object的数组。

        结果
        Java编程语言中的数组，其中包含由此 Array对象指定的SQL ARRAY的有序元素
        异常
        SQLException - 如果尝试访问阵列时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getArray

        Object getArray​(Map<String,Class<?>> map)
         throws SQLException
        检索此Array对象指定的SQL ARRAY值的内容。 此方法使用指定的map进行类型映射自定义，除非数组的基本类型与map中的用户定义类型不匹配，在这种情况下，它将使用标准映射。 该方法getArray使用给定类型映射或标准映射; 它从不使用与连接相关联的类型映射。

        注意：当使用getArray实现映射到基本数据类型的基类型时，实现定义是否返回的数组是该基元数据类型的数组或Object的数组。

        参数
        map - 一个 java.util.Map对象，其中包含SQL类型名称与Java编程语言中的类的映射
        结果
        Java编程语言中的数组，其中包含由该对象指定的SQL数组的有序元素
        异常
        SQLException - 如果尝试访问阵列时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getArray

        Object getArray​(long index,
                int count)
         throws SQLException
        检索由该Array对象指定的SQL ARRAY值，从指定的index开始，并包含最多count个SQL数组的连续元素。 此方法使用与连接相关联的类型映射来定制类型映射。

        注意：当使用getArray实现映射到原始数据类型的基类型时，实现定义是否返回的数组是该基元数据类型的数组或Object的数组。

        参数
        index - 要检索的第一个元素的数组索引; 第一个元素是索引1
        count - 要检索的连续SQL数组元素的数量
        结果
        一个包含最多 count个数组的数组，以元素 index
        异常
        SQLException - 如果尝试访问阵列时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getArray

        Object getArray​(long index,
                int count,
                Map<String,Class<?>> map)
         throws SQLException
        检索由该Array对象指定的SQL ARRAY值，从指定的index开始，并包含最多count个SQL数组的连续元素。

        此方法使用指定的map进行类型映射自定义，除非数组的基本类型与map中的用户定义类型不匹配，在这种情况下，它将使用标准映射。 该方法getArray使用给定类型映射或标准映射; 它从不使用与连接相关联的类型映射。

        注意：当使用getArray实现映射到原始数据类型的基本类型时，实现定义是否返回的数组是该基元数据类型的数组或Object的数组。

        参数
        index - 要检索的第一个元素的数组索引; 第一个元素是索引1
        count - 要检索的连续SQL数组元素的数量
        map - 一个 java.util.Map对象，其中包含SQL类型名称及其映射到的Java编程语言中的类
        结果
        一个包含最多 count个连续元素的数组，由 Array对象指定的SQL ARRAY值，以元素 index
        异常
        SQLException - 如果尝试访问阵列时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getResultSet

        ResultSet getResultSet​()
                throws SQLException
        检索包含此Array对象指定的SQL ARRAY值的元素的结果集。 如果适当，使用连接的类型映射映射数组的元素; 否则，使用标准映射。

        结果集包含每个数组元素的一行，每行中有两列。 第二列存储元素值; 第一列将索引存储到该元素的数组中（第一个数组元素处于索引1）。 这些行按照索引顺序的升序排列。

        结果
        一个ResultSet对象，该对象包含由该Array对象指定的数组中的每个元素的Array ，其中行按升序排列。
        异常
        SQLException - 如果在尝试访问阵列时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getResultSet

        ResultSet getResultSet​(Map<String,Class<?>> map)
                throws SQLException
        检索包含此Array对象指定的SQL ARRAY值的元素的结果集。 此方法使用指定的map进行类型映射自定义，除非数组的基本类型与map中的用户定义类型不匹配，在这种情况下，它将使用标准映射。 该方法getResultSet使用给定类型映射或标准映射; 它从不使用与连接相关联的类型映射。

        结果集包含每个数组元素的一行，每行中有两列。 第二列存储元素值; 第一列将索引存储到该元素的数组中（第一个数组元素处于索引1）。 这些行按照索引顺序的升序排列。

        参数
        map - 包含SQL用户定义类型与Java编程语言中的类的映射
        结果
        一个 ResultSet对象，该对象包含由该 Array对象指定的数组中的每个元素的一行，基于索引按行升序。
        异常
        SQLException - 如果尝试访问阵列时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getResultSet

        ResultSet getResultSet​(long index,
                       int count)
                throws SQLException
        检索一个结果集，其中包含以索引index开头的子阵列的元素，并包含最多count连续元素。 如果地图包含基本类型的条目，则此方法使用连接的类型映射来映射数组的元素。 否则，使用标准映射。

        结果集对于此对象指定的SQL数组的每个元素都有一行，第一行包含索引号为index的元素。 基于指数，结果集可以按升序排列高达count行。 每行有两列：第二列存储元素值; 第一列将索引存储到该元素的数组中。

        参数
        index - 要检索的第一个元素的数组索引; 第一个元素是索引1
        count - 要检索的连续SQL数组元素的数量
        结果
        一个 ResultSet对象包含最多 count个连续元素的SQL数组，由该 Array对象指定，从索引 index开始。
        异常
        SQLException - 如果尝试访问阵列时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getResultSet

        ResultSet getResultSet​(long index,
                       int count,
                       Map<String,Class<?>> map)
                throws SQLException
        检索一个结果集，其中包含以索引index开始的子阵列的元素，并包含最多count连续元素。 此方法使用指定的map进行类型映射自定义，除非阵列的基本类型与map中的用户定义类型不匹配，在这种情况下，它将使用标准映射。 该方法getResultSet使用给定类型映射或标准映射; 它从不使用与连接相关联的类型映射。

        结果集对于此对象指定的SQL数组的每个元素都有一行，第一行包含索引号为index的元素。 基于指数，结果集的升序最多为count行。 每行有两列：第二列存储元素值; 第一列将索引存储到该元素的数组中。

        参数
        index - 要检索的第一个元素的数组索引; 第一个元素是索引1
        count - 要检索的连续SQL数组元素的数量
        map - 包含SQL类型名称与Java（tm）编程语言中的类映射的 Map对象
        结果
        一个 ResultSet对象，包含由 Array对象指定的SQL数组的最多 count个连续元素，从索引 index开始。
        异常
        SQLException - 如果尝试访问阵列时发生错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • free

        void free​()
   throws SQLException
        该方法可以释放Array对象并释放它所拥有的资源。 调用free方法后，该对象无效。

        在free之后，任何调用free以外的方法的尝试将导致抛出SQLException 。 如果free被多次调用，在后续调用free被视为无操作。

        异常
        SQLException - 如果发生错误，将释放Array的资源
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BatchUpdateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class BatchUpdateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.BatchUpdateException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class BatchUpdateException
extends SQLException
    在批量更新操作期间发生错误时，抛出SQLException的子类。 除了BatchUpdateException提供的信息之外 ， BatchUpdateException还提供了在批量更新期间成功执行的所有命令的更新计数，即在发生错误之前执行的所有命令。 更新计数数组中元素的顺序对应于将命令添加到批次的顺序。

    批处理更新中的命令无法正常执行并抛出一个BatchUpdateException ，驱动程序可能会继续处理剩余的命令，也可能不会继续处理。 如果驱动程序在失败后继续处理，方法BatchUpdateException.getUpdateCounts返回的数组将为批处理中的每个命令都有一个元素，而不仅仅是在错误之前成功执行的命令的元素。 在驱动程序继续处理命令的情况下，任何失败命令的数组元素为Statement.EXECUTE_FAILED 。

    JDBC驱动程序实现应该使用构造函数BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause)而不是使用构建BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause)来获取int[]的更新计数，以避免溢出的可能性。

    如果调用Statement.executeLargeBatch方法，建议您调用getLargeUpdateCounts而不是getUpdateCounts ，以避免整数更新计数的可能溢出。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BatchUpdateException​()
      构造一个 BatchUpdateException对象。
      BatchUpdateException​(int[] updateCounts)
      构造一个 BatchUpdateException对象，使用给定的 updateCounts初始化。
      BatchUpdateException​(int[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException对象，初始化为给定的 cause和 updateCounts 。
      BatchUpdateException​(String reason, int[] updateCounts)
      构造一个由给定的 reason和 updateCounts初始化的 BatchUpdateException对象。
      BatchUpdateException​(String reason, int[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， cause和 updateCounts 。
      BatchUpdateException​(String reason, String SQLState, int[] updateCounts)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState和 updateCounts 。
      BatchUpdateException​(String reason, String SQLState, int[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， cause ，和 updateCounts 。
      BatchUpdateException​(String reason, String SQLState, int vendorCode, int[] updateCounts)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode和 updateCounts 。
      BatchUpdateException​(String reason, String SQLState, int vendorCode, int[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode cause和 updateCounts 。
      BatchUpdateException​(String reason, String SQLState, int vendorCode, long[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode cause和 updateCounts 。
      BatchUpdateException​(Throwable cause)
      构造一个 BatchUpdateException对象，初始化为给定的 cause 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      long[] getLargeUpdateCounts​()
      检索在发生此异常之前成功执行的批量更新中每个更新语句的更新计数。
      int[] getUpdateCounts​()
      检索在发生此异常之前成功执行的批量更新中每个更新语句的更新计数。

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • BatchUpdateException

        public BatchUpdateException​(String reason,
                            String SQLState,
                            int vendorCode,
                            int[] updateCounts)
        构造一个BatchUpdateException与给定的初始化的对象reason ， SQLState ， vendorCode和updateCounts 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。

        注意：没有验证updateCounts溢出，因此，建议您使用构造函数BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause) 。

        参数
        reason - 错误的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 特定数据库供应商使用的异常代码
        updateCounts -的阵列int ，其每个元素指示的更新计数， Statement.SUCCESS_NO_INFO或Statement.EXECUTE_FAILED在批次JDBC驱动程序继续命令失败后处理中的每个SQL命令; 在命令失败后停止处理的JDBC驱动程序发生故障之前，批处理中的每个SQL命令的更新计数或Statement.SUCCESS_NO_INFO
        从以下版本开始：
        1.2
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​(String reason,
                            String SQLState,
                            int[] updateCounts)
        构造一个BatchUpdateException与给定的初始化的对象reason ， SQLState和updateCounts 。 cause未初始化，并可能随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。

        注意：没有验证updateCounts的溢出，因此，建议您使用构造函数BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause) 。

        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        updateCounts -的阵列int ，其每个元素指示的更新计数， Statement.SUCCESS_NO_INFO或Statement.EXECUTE_FAILED在批次JDBC驱动程序继续命令失败后处理中的每个SQL命令; 在命令失败后停止处理的JDBC驱动程序发生故障之前，批处理中的每个SQL命令的更新计数或Statement.SUCCESS_NO_INFO
        从以下版本开始：
        1.2
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​(String reason,
                            int[] updateCounts)
        构造一个BatchUpdateException对象，该对象使用给定的reason和updateCounts初始化。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 SQLState初始化为null ，供应商代码初始化为0。

        注意：没有验证updateCounts的溢出，因此，建议您使用构造函数BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause) 。

        参数
        reason - 异常的描述
        updateCounts -的阵列int ，其每个元素指示的更新计数， Statement.SUCCESS_NO_INFO或Statement.EXECUTE_FAILED在批次JDBC驱动程序继续命令失败后处理中的每个SQL命令; 在命令失败后停止处理的JDBC驱动程序发生故障之前，批处理中的每个SQL命令的更新计数或Statement.SUCCESS_NO_INFO
        从以下版本开始：
        1.2
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​(int[] updateCounts)
        构造一个BatchUpdateException对象，初始化为给定的updateCounts 。 通过调用Throwable.initCause(java.lang.Throwable)方法初始化。 reason和SQLState初始化为null，供应商代码初始化为0。

        注意：没有验证updateCounts的溢出，因此，建议您使用构造函数BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause) 。

        参数
        updateCounts -的阵列int ，其每个元素指示的更新计数， Statement.SUCCESS_NO_INFO或Statement.EXECUTE_FAILED在批次JDBC驱动程序继续命令失败后处理中的每个SQL命令; 在命令失败后停止处理的JDBC驱动程序发生故障之前，批处理中的每个SQL命令的更新计数或Statement.SUCCESS_NO_INFO
        从以下版本开始：
        1.2
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​()
        构造一个BatchUpdateException对象。 的reason ， SQLState和updateCounts被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.2
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​(Throwable cause)
        构造一个BatchUpdateException对象，使用给定的cause初始化。 的SQLState和updateCounts被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​(int[] updateCounts,
                            Throwable cause)
        构造一个BatchUpdateException对象，该对象使用给定的cause和updateCounts初始化。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。

        注意：没有验证updateCounts溢出，因此，建议您使用构造函数BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause) 。

        参数
        updateCounts -的阵列int ，其每个元素指示的更新计数， Statement.SUCCESS_NO_INFO或Statement.EXECUTE_FAILED在批次JDBC驱动程序继续命令失败后处理中的每个SQL命令; 在命令失败后停止处理的JDBC驱动程序发生故障之前，批处理中的每个SQL命令的更新计数或Statement.SUCCESS_NO_INFO
        cause - 这个SQLException的基本原因（由getCause()方法保存以供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​(String reason,
                            int[] updateCounts,
                            Throwable cause)
        构造一个BatchUpdateException与给定的初始化的对象reason ， cause和updateCounts 。 SQLState初始化为null ，供应商代码初始化为0。

        注意：没有验证updateCounts溢出，因此，建议您使用构造函数BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause) 。

        参数
        reason - 异常的描述
        updateCounts -的阵列int ，其每个元素指示的更新计数， Statement.SUCCESS_NO_INFO或Statement.EXECUTE_FAILED在批次JDBC驱动程序继续命令失败后处理中的每个SQL命令; 在命令失败后停止处理的JDBC驱动程序发生故障之前，批处理中的每个SQL命令的更新计数或Statement.SUCCESS_NO_INFO
        cause - 这个SQLException的基本原因（由getCause()方法保存供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​(String reason,
                            String SQLState,
                            int[] updateCounts,
                            Throwable cause)
        构造一个BatchUpdateException与给定的初始化的对象reason ， SQLState ， cause ，和updateCounts 。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        updateCounts -的阵列int ，其每个元素指示的更新计数， Statement.SUCCESS_NO_INFO或Statement.EXECUTE_FAILED在批次JDBC驱动程序继续命令失败后处理中的每个SQL命令; 在命令失败后停止处理的JDBC驱动程序发生故障之前，批处理中的每个SQL命令的更新计数或Statement.SUCCESS_NO_INFO

        注意：没有验证updateCounts的溢出，因此，建议您使用构造函数BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause) 。

        cause - 这个SQLException的基本原因（由getCause()方法保存供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​(String reason,
                            String SQLState,
                            int vendorCode,
                            int[] updateCounts,
                            Throwable cause)
        构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode cause和 updateCounts 。
        参数
        reason - 错误的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 特定数据库供应商使用的异常代码
        updateCounts -的阵列int ，其每个元素指示的更新计数， Statement.SUCCESS_NO_INFO或Statement.EXECUTE_FAILED在批次JDBC驱动程序继续命令失败后处理中的每个SQL命令; 在命令失败后停止处理的JDBC驱动程序发生故障之前，批处理中的每个SQL命令的更新计数或Statement.SUCCESS_NO_INFO

        注意：没有验证updateCounts的溢出，因此，建议您使用构造函数BatchUpdateException(String reason, String SQLState, int vendorCode, long []updateCounts,Throwable cause) 。

        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
        另请参见：
        BatchUpdateException(java.lang.String, java.lang.String, int, long[], java.lang.Throwable)

      • BatchUpdateException

        public BatchUpdateException​(String reason,
                            String SQLState,
                            int vendorCode,
                            long[] updateCounts,
                            Throwable cause)
        构造一个BatchUpdateException与给定的初始化的对象reason ， SQLState ， vendorCode cause和updateCounts 。

        当返回的更新计数可能超过Integer.MAX_VALUE时，应使用此构造函数。

        参数
        reason - 错误的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 特定数据库供应商使用的异常代码
        updateCounts -的阵列long ，其每个元素指示的更新计数， Statement.SUCCESS_NO_INFO或Statement.EXECUTE_FAILED在批次JDBC驱动程序继续命令失败后处理中的每个SQL命令; 在命令失败后停止处理的JDBC驱动程序发生故障之前，批处理中的每个SQL命令的更新计数或Statement.SUCCESS_NO_INFO
        cause - 这个SQLException的基本原因（由getCause()方法保存供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.8

    • 方法详细信息

      • getUpdateCounts

        public int[] getUpdateCounts​()
        检索在发生此异常之前成功执行的批量更新中每个更新语句的更新计数。 当其中一个命令无法正常执行时，实现批量更新的驱动程序可能会或可能不会继续处理其他命令。 如果驱动程序继续处理命令，则此方法返回的数组将具有与批处理中的命令一样多的元素; 否则，它将包含在抛出BatchUpdateException之前成功执行的每个命令的更新计数。

        针对Java 2 SDK（Standard Edition，版本1.3）修改了此方法的可能返回值。 这是为了适应在抛出BatchUpdateException对象之后在批量更新中继续处理命令的新选项。

        结果
        一个int的数组，包含在发生错误之前成功执行的更新的更新计数。 或者，如果驱动程序在错误后继续处理命令，则批处理中的每个命令都将执行以下操作之一：
        1. 更新计数
        2. Statement.SUCCESS_NO_INFO表示命令执行成功但受影响的行数未知
        3. Statement.EXECUTE_FAILED表示命令无法成功执行
        从以下版本开始：
        1.3
        另请参见：
        getLargeUpdateCounts()

      • getLargeUpdateCounts

        public long[] getLargeUpdateCounts​()
        检索在发生此异常之前成功执行的批量更新中每个更新语句的更新计数。 当其中一个命令无法正常执行时，实现批量更新的驱动程序可能会或可能不会继续处理其他命令。 如果驱动程序继续处理命令，则此方法返回的数组将具有与批处理中的命令一样多的元素; 否则，它将包含在抛出BatchUpdateException之前成功执行的每个命令的更新计数。

        当调用Statement.executeLargeBatch时，应使用此方法，并且返回的更新计数可能超过Integer.MAX_VALUE 。

        结果
        一个long的数组包含在此错误发生之前成功执行的更新的更新计数。 或者，如果驱动程序在错误后继续处理命令，则批处理中的每个命令都将执行以下操作之一：
        1. 更新计数
        2. Statement.SUCCESS_NO_INFO表示该命令执行成功，但受影响的行数未知
        3. Statement.EXECUTE_FAILED表示命令无法成功执行
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Blob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Blob

  • 所有已知实现类：
    SerialBlob

    public interface Blob
    表示（映射）在Java编程语言中的一个SQL BLOB值。 SQL BLOB是一种内置类型，它将二进制大对象作为列值存储在数据库表的一行中。 默认情况下，驱动程序使用SQL locator(BLOB)实现Blob ，这意味着一个Blob对象包含一个指向SQL BLOB数据而不是数据本身的逻辑指针。 A Blob对象在创建事务的持续时间内有效。

    方法在接口ResultSet ， CallableStatement ，并PreparedStatement ，如getBlob和setBlob允许编程人员访问SQL BLOB值。 Blob接口提供了获取SQL BLOB （二进制大对象）值的长度的方法，用于在客户端上实现BLOB值，并确定BLOB值中字节模式的位置。 此外，该界面还具有更新BLOB值的方法。

    如果JDBC驱动程序支持数据类型，则必须完全实现Blob接口上的所有方法。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void free​()
      该方法可以释放 Blob对象并释放它所拥有的资源。
      InputStream getBinaryStream​()
      检索由该 Blob实例指定的 BLOB值作为流。
      InputStream getBinaryStream​(long pos, long length)
      返回一个包含部分 Blob值的 InputStream对象，从pos指定的字节开始，长度为字节长度。
      byte[] getBytes​(long pos, int length)
      检索 Blob对象所代表的 BLOB全部或部分值，作为字节数组。
      long length​()
      返回此 Blob对象指定的 BLOB值中的字节数。
      long position​(byte[] pattern, long start)
      检索指定字节数组 pattern在 Blob对象表示的 BLOB值内开始的字节位置。
      long position​(Blob pattern, long start)
      检索在该字节位置 BLOB通过该指定值 Blob对象在该 pattern开始。
      OutputStream setBinaryStream​(long pos)
      检索可用于写入此 Blob对象所代表的 BLOB值的流。
      int setBytes​(long pos, byte[] bytes)
      将给定的字节数组写入 Blob对象所表示的 BLOB值，从位置 pos开始，并返回写入的字节数。
      int setBytes​(long pos, byte[] bytes, int offset, int len)
      将给定的全部或部分 byte阵列到 BLOB ，该值 Blob对象表示，并返回写入的字节数。
      void truncate​(long len)
      截断 BLOB值，这 Blob对象表示为 len字节长度。

    • 方法详细信息

      • length

        long length​()
     throws SQLException
        返回由 Blob对象指定的 BLOB值中的字节数。
        结果
        长度为 BLOB ，字节数
        异常
        SQLException - 如果访问 BLOB的长度有错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getBytes

        byte[] getBytes​(long pos,
                int length)
         throws SQLException
        检索Blob对象表示的BLOB全部或部分值，作为字节数组。 此byte阵列包含多到length开始位置连续字节pos 。
        参数
        pos - 要提取的BLOB值中第一个字节的顺序位置; 第一个字节在位置1
        length - 要复制的连续字节数; 长度的值必须为0或更大
        结果
        从 Blob对象指定的 BLOB值中最多包含 length个连续字节的字节数组，从位置 pos的字节开始
        异常
        SQLException - 访问BLOB值时是否有错误; 如果pos小于1或长度小于0
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        setBytes(long, byte[])

      • getBinaryStream

        InputStream getBinaryStream​()
                     throws SQLException
        检索由 Blob实例指定的 BLOB值作为流。
        结果
        一个包含 BLOB数据的流
        异常
        SQLException - 如果访问 BLOB值时出错
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        setBinaryStream(long)

      • position

        long position​(byte[] pattern,
              long start)
       throws SQLException
        检索指定的字节数组pattern在Blob对象表示的BLOB值内开始的字节位置。 对于搜索pattern的位置开始start 。
        参数
        pattern - 要搜索的字节数组
        start - 开始搜索的位置; 第一名是1
        结果
        模式出现的位置，否则为-1
        异常
        SQLException - 如果访问 BLOB有错误或者启动小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • position

        long position​(Blob pattern,
              long start)
       throws SQLException
        检索由pattern开始的Blob对象指定的BLOB值中的字节位置。 搜索从位置start开始。
        参数
        pattern - Blob对象指定要搜索的 BLOB值
        start - 在开始搜索的BLOB值的位置; 第一名是1
        结果
        模式开始的位置，否则为-1
        异常
        SQLException - 如果在访问 BLOB值时出现错误，或者如果起始小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • setBytes

        int setBytes​(long pos,
             byte[] bytes)
      throws SQLException
        将给定的字节数组写入Blob对象表示的BLOB值，从位置pos开始，并返回写入的字节数。 字节阵列将覆盖在现有的字节Blob对象开始在位置pos 。 如果在编写字节数组时达到Blob值的结尾，那么将增加Blob值的长度以适应额外的字节。

        注意：如果为pos指定的值大于BLOB值的长度+ 1，那么行为是未定义的。 某些JDBC驱动程序可能会抛出一个SQLException而其他驱动程序可能会支持此操作。

        参数
        pos - 在BLOB对象中的位置开始写入; 第一名是1
        bytes - 要写入此 Blob对象的 BLOB值的字节数组
        结果
        写入的字节数
        异常
        SQLException - 如果存在访问 BLOB值或pos小于1的错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getBytes(long, int)

      • setBytes

        int setBytes​(long pos,
             byte[] bytes,
             int offset,
             int len)
      throws SQLException
        将给定的全部或部分byte阵列到BLOB ，该值Blob对象表示，并返回写入的字节数。 写作起始于pos的BLOB ; len给定字节数组的len字节。 字节阵列将覆盖在现有的字节Blob对象开始在位置pos 。 如果在写入字节数组时达到了Blob值，那么Blob值将被增加以适应额外的字节。

        注意：如果为pos指定的值大于BLOB值的长度+ 1，那么行为是未定义的。 某些JDBC驱动程序可能会抛出一个SQLException而其他驱动程序可能会支持此操作。

        参数
        pos - 在BLOB对象开始写入的位置; 第一名是1
        bytes - 要写入此 BLOB对象的字节数组
        offset - 要开始读取要设置的字节的阵列 bytes的偏移量
        len - 要从字节数组 BLOB写入的字节数 bytes
        结果
        写入的字节数
        异常
        SQLException - 如果存在访问 BLOB值的错误或者pos小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getBytes(long, int)

      • setBinaryStream

        OutputStream setBinaryStream​(long pos)
                      throws SQLException
        检索可用于写入Blob对象表示的值的BLOB值的流。 流从位置pos开始。 写入流的字节将覆盖从位置pos开始的Blob对象中的现有字节。 如果在写入流时达到Blob值的结尾，那么Blob值将被增加以适应额外的字节。

        注意：如果为pos指定的值大于BLOB值的长度+ 1，那么行为是未定义的。 某些JDBC驱动程序可能会抛出一个SQLException而其他驱动程序可能会支持此操作。

        参数
        pos - 在开始写作的BLOB值的位置; 第一名是1
        结果
        可以写入数据的 java.io.OutputStream对象
        异常
        SQLException - 如果在访问 BLOB值时出现错误，或者pos小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getBinaryStream()

      • truncate

        void truncate​(long len)
       throws SQLException
        截断该Blob对象表示的长度为len个字节的BLOB值。

        注意：如果为pos指定的值大于BLOB值的长度+ 1，那么行为是未定义的。 一些JDBC驱动程序可能会抛出一个SQLException而其他驱动程序可能会支持此操作。

        参数
        len - 这个 Blob对象所表示的 BLOB值的长度（以字节为单位）应该被截断
        异常
        SQLException - 如果存在访问 BLOB的错误或者如果len小于0
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • free

        void free​()
   throws SQLException
        该方法可以释放Blob对象并释放它所拥有的资源。 一旦调用了free方法，该对象就无效。

        在free之后，任何调用free以外的方法的尝试将导致抛出SQLException 。 如果free被多次调用，在后续调用free被视为无操作。

        异常
        SQLException - 如果发布错误发生Blob的资源
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getBinaryStream

        InputStream getBinaryStream​(long pos,
                            long length)
                     throws SQLException
        返回一个包含部分 Blob值的 InputStream对象，从pos指定的字节开始，长度为长度字节。
        参数
        pos - 要检索的部分值的第一个字节的偏移量。 Blob的第一个字节在位置1。
        length - 要检索的部分值的字节长度
        结果
        InputStream ，可以读取部分 Blob值。
        异常
        SQLException - 如果pos小于1，或者如果pos大于 Blob的字节数，或者如果pos +长度大于 Blob的字节数
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CallableStatement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface CallableStatement

  • All Superinterfaces:
    AutoCloseable ， PreparedStatement ， Statement ， Wrapper

    public interface CallableStatement
extends PreparedStatement
    用于执行SQL存储过程的界面。 JDBC API提供了存储过程SQL转义语法，允许以标准方式为所有RDBMS调用存储过程。 此转义语法包含一个结果参数和不包含结果参数的表单。 如果使用，结果参数必须注册为OUT参数。 其他参数可用于输入，输出或两者。 参数按顺序依次引用，第一个参数为1。
      {?= call <procedure-name>[(<arg1>,<arg2>, ...)]}
   {call <procedure-name>[(<arg1>,<arg2>, ...)]}

    IN参数值使用继承自PreparedStatement的set方法设置。 所有OUT参数的类型必须在执行存储过程之前进行注册; 它们的值通过这里提供的get方法在执行后被检索。

    A CallableStatement可以返回一个ResultSet对象或多个ResultSet对象。 多个ResultSet对象使用继承自Statement的操作来处理。

    为了最大的可移植性，调用的ResultSet对象和更新计数应该在获得输出参数的值进行处理。

    从以下版本开始：
    1.1
    另请参见：
    Connection.prepareCall(java.lang.String) ， ResultSet

    • Field Summary

      • Fields inherited from interface java.sql.Statement

        CLOSE_ALL_RESULTS, CLOSE_CURRENT_RESULT, EXECUTE_FAILED, KEEP_CURRENT_RESULT, NO_GENERATED_KEYS, RETURN_GENERATED_KEYS, SUCCESS_NO_INFO

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods 弃用的方法
      Modifier and Type 方法 描述
      Array getArray​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC ARRAY参数的值作为Array对象。
      Array getArray​(String parameterName)
      以Java编程语言中的Array对象的形式获取 JDBC ARRAY参数的值。
      BigDecimal getBigDecimal​(int parameterIndex)
      将指定的JDBC NUMERIC参数的值作为 java.math.BigDecimal对象检索，该对象的值包含小数点右侧的数字。
      BigDecimal getBigDecimal​(int parameterIndex, int scale)
      已过时。
      使用getBigDecimal(int parameterIndex)或getBigDecimal(String parameterName)
      BigDecimal getBigDecimal​(String parameterName)
      以 java.math.BigDecimal对象的形式 java.math.BigDecimal JDBC NUMERIC参数的值，该对象的值包含小数点右侧的数字。
      Blob getBlob​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC BLOB参数的值作为Blob对象。
      Blob getBlob​(String parameterName)
      以Java编程语言中的Blob对象的形式获取 JDBC BLOB参数的值。
      boolean getBoolean​(int parameterIndex)
      获取指定的JDBC的价值 BIT或者 BOOLEAN作为参数 boolean Java编程语言。
      boolean getBoolean​(String parameterName)
      以Java编程语言中的 boolean JDBC BIT或 BOOLEAN参数的值。
      byte getByte​(int parameterIndex)
      以Java编程语言中的 byte指定的JDBC TINYINT参数的值。
      byte getByte​(String parameterName)
      以Java编程语言中的 byte JDBC TINYINT参数的值。
      byte[] getBytes​(int parameterIndex)
      将指定的JDBC BINARY或 VARBINARY参数的值作为Java编程语言中的 byte值的数组 byte 。
      byte[] getBytes​(String parameterName)
      检索JDBC BINARY或 VARBINARY参数的值，作为Java编程语言中的 byte值。
      Reader getCharacterStream​(int parameterIndex)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      Reader getCharacterStream​(String parameterName)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      Clob getClob​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC CLOB参数的值作为 java.sql.Clob对象。
      Clob getClob​(String parameterName)
      以Java编程语言中的 java.sql.Clob对象获取JDBC CLOB参数的值。
      Date getDate​(int parameterIndex)
      以 java.sql.Date对象的形式获取指定的JDBC DATE参数的值。
      Date getDate​(int parameterIndex, Calendar cal)
      检索指定的JDBC DATE参数的值作为 java.sql.Date对象，使用给定的 Calendar对象构造日期。
      Date getDate​(String parameterName)
      检索作为 java.sql.Date对象的JDBC DATE参数的值。
      Date getDate​(String parameterName, Calendar cal)
      检索JDBC DATE参数的值作为 java.sql.Date对象，使用给定的 Calendar对象构造日期。
      double getDouble​(int parameterIndex)
      以Java编程语言中的 double指定的JDBC DOUBLE参数的值。
      double getDouble​(String parameterName)
      以Java编程语言中的 double JDBC DOUBLE参数的值。
      float getFloat​(int parameterIndex)
      以Java编程语言中的 float指定的JDBC FLOAT参数的值。
      float getFloat​(String parameterName)
      以Java编程语言中的 float JDBC FLOAT参数的值。
      int getInt​(int parameterIndex)
      以Java编程语言中的 int指定的JDBC INTEGER参数的值。
      int getInt​(String parameterName)
      以Java编程语言中的 int JDBC INTEGER参数的值。
      long getLong​(int parameterIndex)
      以Java编程语言中的 long指定的JDBC BIGINT参数的值。
      long getLong​(String parameterName)
      以Java编程语言中的 long JDBC BIGINT参数的值。
      Reader getNCharacterStream​(int parameterIndex)
      以Java编程语言中的 java.io.Reader对象获取指定参数的值。
      Reader getNCharacterStream​(String parameterName)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      NClob getNClob​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC NCLOB参数的值作为 java.sql.NClob对象。
      NClob getNClob​(String parameterName)
      以Java编程语言作为 java.sql.NClob对象检索JDBC NCLOB参数的值。
      String getNString​(int parameterIndex)
      检索指定的值 NCHAR ， NVARCHAR或者 LONGNVARCHAR参数为 String的Java编程语言。
      String getNString​(String parameterName)
      检索指定的值 NCHAR ， NVARCHAR或者 LONGNVARCHAR参数为 String的Java编程语言。
      Object getObject​(int parameterIndex)
      以Java编程语言中的 Object指定参数的值。
      <T> T getObject​(int parameterIndex, Class<T> type)
      返回表示OUT参数 parameterIndex的值的对象，并将转换为参数的SQL类型到所请求的Java数据类型，如果支持转换。
      Object getObject​(int parameterIndex, Map<String,Class<?>> map)
      返回表示OUT参数 parameterIndex的值的对象，并使用 map作为参数值的自定义映射。
      Object getObject​(String parameterName)
      以Java编程语言中的 Object参数的值。
      <T> T getObject​(String parameterName, Class<T> type)
      返回表示OUT参数值 parameterName的值的对象，如果支持转换，则将从参数的SQL类型转换为请求的Java数据类型。
      Object getObject​(String parameterName, Map<String,Class<?>> map)
      返回表示OUT参数 parameterName的值的对象，并使用 map作为参数值的自定义映射。
      Ref getRef​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC REF(<structured-type>)参数的值作为Ref对象。
      Ref getRef​(String parameterName)
      以Java编程语言的形式获取 JDBC REF(<structured-type>)参数的值作为Ref对象。
      RowId getRowId​(int parameterIndex)
      以 java.sql.RowId对象的形式获取指定的JDBC ROWID参数的值。
      RowId getRowId​(String parameterName)
      以 java.sql.RowId对象的形式获取指定的JDBC ROWID参数的值。
      short getShort​(int parameterIndex)
      以Java编程语言中的 short指定的JDBC SMALLINT参数的值。
      short getShort​(String parameterName)
      以Java编程语言 short JDBC SMALLINT参数的值作为 short 。
      SQLXML getSQLXML​(int parameterIndex)
      以Java编程语言中的 java.sql.SQLXML对象获取指定的 SQL XML参数的值。
      SQLXML getSQLXML​(String parameterName)
      以Java编程语言作为 java.sql.SQLXML对象检索指定的 SQL XML参数的值。
      String getString​(int parameterIndex)
      以Java编程语言中的 CHAR VARCHAR指定的JDBC CHAR或 LONGVARCHAR参数的 String 。
      String getString​(String parameterName)
      检索JDBC的价值 CHAR ， VARCHAR ，或 LONGVARCHAR参数为 String的Java编程语言。
      Time getTime​(int parameterIndex)
      以 java.sql.Time对象的形式获取指定的JDBC TIME参数的值。
      Time getTime​(int parameterIndex, Calendar cal)
      检索指定的JDBC的 TIME参数为 java.sql.Time对象，使用给定的 Calendar对象构建时间。
      Time getTime​(String parameterName)
      检索作为 java.sql.Time对象的JDBC TIME参数的值。
      Time getTime​(String parameterName, Calendar cal)
      检索JDBC TIME参数的值作为 java.sql.Time对象，使用给定的 Calendar对象构造时间。
      Timestamp getTimestamp​(int parameterIndex)
      以 java.sql.Timestamp对象的形式获取指定的JDBC TIMESTAMP参数的值。
      Timestamp getTimestamp​(int parameterIndex, Calendar cal)
      将指定的JDBC TIMESTAMP参数的值作为 java.sql.Timestamp对象 java.sql.Timestamp ，使用给定的 Calendar对象构造 Timestamp对象。
      Timestamp getTimestamp​(String parameterName)
      检索作为 java.sql.Timestamp对象的JDBC TIMESTAMP参数的值。
      Timestamp getTimestamp​(String parameterName, Calendar cal)
      检索JDBC TIMESTAMP参数的值作为 java.sql.Timestamp对象，使用给定的 Calendar对象来构造 Timestamp对象。
      URL getURL​(int parameterIndex)
      将指定的JDBC DATALINK参数的值检索为 java.net.URL对象。
      URL getURL​(String parameterName)
      检索作为 java.net.URL对象的JDBC DATALINK参数的值。
      void registerOutParameter​(int parameterIndex, int sqlType)
      将序号 parameterIndex的OUT参数注册到JDBC类型 sqlType 。
      void registerOutParameter​(int parameterIndex, int sqlType, int scale)
      将序号 parameterIndex的参数注册为JDBC类型 sqlType 。
      void registerOutParameter​(int parameterIndex, int sqlType, String typeName)
      注册指定的输出参数。
      default void registerOutParameter​(int parameterIndex, SQLType sqlType)
      将序号 parameterIndex的OUT参数注册到JDBC类型 sqlType 。
      default void registerOutParameter​(int parameterIndex, SQLType sqlType, int scale)
      将序号 parameterIndex的参数注册为JDBC类型 sqlType 。
      default void registerOutParameter​(int parameterIndex, SQLType sqlType, String typeName)
      注册指定的输出参数。
      void registerOutParameter​(String parameterName, int sqlType)
      将名为 parameterName的OUT参数注册到JDBC类型 sqlType 。
      void registerOutParameter​(String parameterName, int sqlType, int scale)
      将名为 parameterName的参数注册为JDBC类型 sqlType 。
      void registerOutParameter​(String parameterName, int sqlType, String typeName)
      注册指定的输出参数。
      default void registerOutParameter​(String parameterName, SQLType sqlType)
      将名为 parameterName的OUT参数注册到JDBC类型 sqlType 。
      default void registerOutParameter​(String parameterName, SQLType sqlType, int scale)
      将名为 parameterName的参数注册为JDBC类型 sqlType 。
      default void registerOutParameter​(String parameterName, SQLType sqlType, String typeName)
      注册指定的输出参数。
      void setAsciiStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void setAsciiStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void setAsciiStream​(String parameterName, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void setBigDecimal​(String parameterName, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。
      void setBinaryStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void setBinaryStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void setBinaryStream​(String parameterName, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void setBlob​(String parameterName, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void setBlob​(String parameterName, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void setBlob​(String parameterName, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。
      void setBoolean​(String parameterName, boolean x)
      将指定的参数设置为给定的Java boolean值。
      void setByte​(String parameterName, byte x)
      将指定的参数设置为给定的Java byte值。
      void setBytes​(String parameterName, byte[] x)
      将指定的参数设置为给定的Java字节数组。
      void setCharacterStream​(String parameterName, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void setCharacterStream​(String parameterName, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void setCharacterStream​(String parameterName, Reader reader, long length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void setClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void setClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void setClob​(String parameterName, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。
      void setDate​(String parameterName, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void setDate​(String parameterName, Date x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Date值，使用给定的 Calendar对象。
      void setDouble​(String parameterName, double x)
      将指定的参数设置为给定的Java double值。
      void setFloat​(String parameterName, float x)
      将指定的参数设置为给定的Java float值。
      void setInt​(String parameterName, int x)
      将指定的参数设置为给定的Java int值。
      void setLong​(String parameterName, long x)
      将指定的参数设置为给定的Java long值。
      void setNCharacterStream​(String parameterName, Reader value)
      将指定的参数设置为 Reader对象。
      void setNCharacterStream​(String parameterName, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void setNClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void setNClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void setNClob​(String parameterName, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void setNString​(String parameterName, String value)
      将指定的参数设置为给定的 String对象。
      void setNull​(String parameterName, int sqlType)
      将指定的参数设置为SQL NULL 。
      void setNull​(String parameterName, int sqlType, String typeName)
      将指定的参数设置为SQL NULL 。
      void setObject​(String parameterName, Object x)
      使用给定对象设置指定参数的值。
      void setObject​(String parameterName, Object x, int targetSqlType)
      使用给定对象设置指定参数的值。
      void setObject​(String parameterName, Object x, int targetSqlType, int scale)
      使用给定对象设置指定参数的值。
      default void setObject​(String parameterName, Object x, SQLType targetSqlType)
      使用给定对象设置指定参数的值。
      default void setObject​(String parameterName, Object x, SQLType targetSqlType, int scaleOrLength)
      使用给定对象设置指定参数的值。
      void setRowId​(String parameterName, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void setShort​(String parameterName, short x)
      将指定的参数设置为给定的Java short值。
      void setSQLXML​(String parameterName, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void setString​(String parameterName, String x)
      将指定的参数设置为给定的Java String值。
      void setTime​(String parameterName, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void setTime​(String parameterName, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void setTimestamp​(String parameterName, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。
      void setURL​(String parameterName, URL val)
      将指定的参数设置为给定的 java.net.URL对象。
      boolean wasNull​()
      检索读取的最后一个OUT参数的值是否为SQL NULL 。

      • Methods inherited from interface java.sql.PreparedStatement

        addBatch, clearParameters, execute, executeLargeUpdate, executeQuery, executeUpdate, getMetaData, getParameterMetaData, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBoolean, setByte, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setDate, setDate, setDouble, setFloat, setInt, setLong, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNString, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setRef, setRowId, setShort, setSQLXML, setString, setTime, setTime, setTimestamp, setTimestamp, setUnicodeStream, setURL

      • Methods inherited from interface java.sql.Statement

        addBatch, cancel, clearBatch, clearWarnings, close, closeOnCompletion, enquoteIdentifier, enquoteLiteral, enquoteNCharLiteral, execute, execute, execute, execute, executeBatch, executeLargeBatch, executeLargeUpdate, executeLargeUpdate, executeLargeUpdate, executeLargeUpdate, executeQuery, executeUpdate, executeUpdate, executeUpdate, executeUpdate, getConnection, getFetchDirection, getFetchSize, getGeneratedKeys, getLargeMaxRows, getLargeUpdateCount, getMaxFieldSize, getMaxRows, getMoreResults, getMoreResults, getQueryTimeout, getResultSet, getResultSetConcurrency, getResultSetHoldability, getResultSetType, getUpdateCount, getWarnings, isClosed, isCloseOnCompletion, isPoolable, isSimpleIdentifier, setCursorName, setEscapeProcessing, setFetchDirection, setFetchSize, setLargeMaxRows, setMaxFieldSize, setMaxRows, setPoolable, setQueryTimeout

      • Methods inherited from interface java.sql.Wrapper

        isWrapperFor, unwrap

    • 方法详细信息

      • registerOutParameter

        void registerOutParameter​(int parameterIndex,
                          int sqlType)
                   throws SQLException
        将序号parameterIndex的OUT参数注册到JDBC类型sqlType 。 所有OUT参数必须在执行存储过程之前进行注册。

        对于OUT参数，由sqlType指定的JDBC类型确定了在get方法中必须使用的Java类型，以读取该参数的值。

        如果期望返回此输出参数的JDBC类型是特定于该特定数据库的，则sqlType应为java.sql.Types.OTHER 。 方法getObject(int)检索该值。

        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        sqlType - 由java.sql.Types定义的JDBC类型代码。 如果参数为JDBC类型NUMERIC或DECIMAL ，则应使用接受比例值的registerOutParameter版本。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException -如果 sqlType是 ARRAY ， BLOB ， CLOB ， DATALINK ， JAVA_OBJECT ， NCHAR ， NCLOB ， NVARCHAR ， LONGNVARCHAR ， REF ， ROWID ， SQLXML或 STRUCT数据类型和JDBC驱动程序不支持此数据类型
        另请参见：
        Types

      • registerOutParameter

        void registerOutParameter​(int parameterIndex,
                          int sqlType,
                          int scale)
                   throws SQLException
        将序号parameterIndex的参数注册为JDBC类型sqlType 。 所有OUT参数必须在执行存储过程之前进行注册。

        对于OUT参数，由sqlType指定的JDBC类型决定了在get方法中必须使用的Java类型，以读取该参数的值。

        这个版本registerOutParameter当参数是JDBC类型应使用NUMERIC或DECIMAL 。

        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        sqlType - 由 java.sql.Types定义的SQL类型代码。
        scale - 小数点右侧所需的数字位数。 它必须大于或等于零。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException -如果 sqlType是 ARRAY ， BLOB ， CLOB ， DATALINK ， JAVA_OBJECT ， NCHAR ， NCLOB ， NVARCHAR ， LONGNVARCHAR ， REF ， ROWID ， SQLXML或 STRUCT数据类型和JDBC驱动程序不支持此数据类型
        另请参见：
        Types

      • wasNull

        boolean wasNull​()
         throws SQLException
        检索读取的最后一个OUT参数的值是否为SQL NULL 。 请注意，此方法只能在调用getter方法后调用; 否则，在确定是否为null没有null 。
        结果
        true如果最后一个参数读取为SQL NULL ; 否则为false
        异常
        SQLException - 如果发生数据库访问错误或此方法在关闭的 CallableStatement调用 CallableStatement

      • getString

        String getString​(int parameterIndex)
          throws SQLException
        获取指定的JDBC的价值CHAR ， VARCHAR ，或LONGVARCHAR参数为String的Java编程语言。

        对于固定长度类型的JDBC CHAR ，返回的String对象与数据库中的SQL CHAR值具有完全相同的值，包括数据库添加的任何填充。

        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setString(java.lang.String, java.lang.String)

      • getBoolean

        boolean getBoolean​(int parameterIndex)
            throws SQLException
        以Java编程语言的形式获取指定的JDBC BIT或 BOOLEAN参数的值作为 boolean 。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为false 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setBoolean(java.lang.String, boolean)

      • getByte

        byte getByte​(int parameterIndex)
      throws SQLException
        以Java编程语言中的 byte指定的JDBC TINYINT参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setByte(java.lang.String, byte)

      • getShort

        short getShort​(int parameterIndex)
        throws SQLException
        以Java编程语言中的 short指定的JDBC SMALLINT参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setShort(java.lang.String, short)

      • getInt

        int getInt​(int parameterIndex)
    throws SQLException
        以Java编程语言中的 int指定的JDBC INTEGER参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setInt(java.lang.String, int)

      • getLong

        long getLong​(int parameterIndex)
      throws SQLException
        以Java编程语言中的 long指定的JDBC BIGINT参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setLong(java.lang.String, long)

      • getFloat

        float getFloat​(int parameterIndex)
        throws SQLException
        以Java编程语言中的 float指定的JDBC FLOAT参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setFloat(java.lang.String, float)

      • getDouble

        double getDouble​(int parameterIndex)
          throws SQLException
        以Java编程语言中的 double指定的JDBC DOUBLE参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setDouble(java.lang.String, double)

      • getBigDecimal

        @Deprecated(since="1.2")
BigDecimal getBigDecimal​(int parameterIndex,
                         int scale)
                  throws SQLException
        已过时。 使用getBigDecimal(int parameterIndex)或getBigDecimal(String parameterName)
        将指定的JDBC NUMERIC参数的值作为 java.math.BigDecimal对象的小数点右侧的 比例数字检索。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        scale - 小数点右侧的位数
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        另请参见：
        setBigDecimal(java.lang.String, java.math.BigDecimal)

      • getBytes

        byte[] getBytes​(int parameterIndex)
         throws SQLException
        以Java编程语言中的 byte数组的形式 byte指定的JDBC BINARY或 VARBINARY参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setBytes(java.lang.String, byte[])

      • getDate

        Date getDate​(int parameterIndex)
      throws SQLException
        以 java.sql.Date对象的形式获取指定的JDBC DATE参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setDate(java.lang.String, java.sql.Date)

      • getTime

        Time getTime​(int parameterIndex)
      throws SQLException
        以 java.sql.Time对象的形式获取指定的JDBC TIME参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setTime(java.lang.String, java.sql.Time)

      • getTimestamp

        Timestamp getTimestamp​(int parameterIndex)
                throws SQLException
        以 java.sql.Timestamp对象的形式获取指定的JDBC TIMESTAMP参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        setTimestamp(java.lang.String, java.sql.Timestamp)

      • getObject

        Object getObject​(int parameterIndex)
          throws SQLException
        以Java编程语言中的Object指定参数的值。 如果值为SQL NULL ，则驱动程序返回一个Java null 。

        此方法返回一个Java对象，其类型对应于使用方法registerOutParameter为此参数注册的JDBC类型。 通过将目标JDBC类型注册为java.sql.Types.OTHER ，此方法可用于读取特定于数据库的抽象数据类型。

        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        A java.lang.Object保存OUT参数值
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        另请参见：
        Types ， setObject(java.lang.String, java.lang.Object, int, int)

      • getBigDecimal

        BigDecimal getBigDecimal​(int parameterIndex)
                  throws SQLException
        将指定的JDBC NUMERIC参数的值作为 java.math.BigDecimal对象 NUMERIC ，该对象的值包含小数点右侧的数字。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值全精度。 如果值为SQL NULL ，结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        从以下版本开始：
        1.2
        另请参见：
        setBigDecimal(java.lang.String, java.math.BigDecimal)

      • getObject

        Object getObject​(int parameterIndex,
                 Map<String,Class<?>> map)
          throws SQLException
        返回表示OUT参数值parameterIndex的对象，并使用map作为参数值的自定义映射。

        此方法返回一个Java对象，其类型对应于使用方法registerOutParameter为该参数注册的JDBC类型。 通过将目标JDBC类型注册为java.sql.Types.OTHER ，此方法可用于读取数据库特定的抽象数据类型。

        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        map - 从SQL类型名称到Java类的映射
        结果
        一个 java.lang.Object保存OUT参数值
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        setObject(java.lang.String, java.lang.Object, int, int)

      • getRef

        Ref getRef​(int parameterIndex)
    throws SQLException
        以Java编程语言的形式获取指定的JDBC REF(<structured-type>)参数的值作为Ref对象。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值为Java编程语言中的一个Ref对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getBlob

        Blob getBlob​(int parameterIndex)
      throws SQLException
        以Java编程语言的形式获取指定的JDBC BLOB参数的值作为Blob对象。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值为Java编程语言中的一个Blob对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getClob

        Clob getClob​(int parameterIndex)
      throws SQLException
        以Java编程语言 java.sql.Clob指定的JDBC CLOB参数的值作为 java.sql.Clob对象。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        Clob 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getArray

        Array getArray​(int parameterIndex)
        throws SQLException
        以Java编程语言的形式获取指定的JDBC ARRAY参数的值作为2705898377907对象。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        参数值为Java编程语言中的一个Array对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getDate

        Date getDate​(int parameterIndex,
             Calendar cal)
      throws SQLException
        将指定的JDBC DATE参数的值作为java.sql.Date对象java.sql.Date ，使用给定的Calendar对象构造日期。 使用Calendar对象，驱动程序可以计算考虑到自定义时区和区域设置的日期。 如果没有指定Calendar对象，则驱动程序使用默认的时区和区域设置。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        cal - 驱动程序将用于构建日期的 Calendar对象
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        从以下版本开始：
        1.2
        另请参见：
        setDate(java.lang.String, java.sql.Date)

      • getTime

        Time getTime​(int parameterIndex,
             Calendar cal)
      throws SQLException
        检索指定的JDBC TIME参数的值作为java.sql.Time对象，使用给定的Calendar对象来构建时间。 使用Calendar对象，驱动程序可以计算考虑到自定义时区和区域设置的时间。 如果没有指定Calendar对象，驱动程序将使用默认的时区和区域设置。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        cal - 驱动程序将用于构建时间的 Calendar对象
        结果
        参数值 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        从以下版本开始：
        1.2
        另请参见：
        setTime(java.lang.String, java.sql.Time)

      • getTimestamp

        Timestamp getTimestamp​(int parameterIndex,
                       Calendar cal)
                throws SQLException
        将指定的JDBC TIMESTAMP参数的值作为java.sql.Timestamp对象java.sql.Timestamp ，使用给定的Calendar对象构造Timestamp对象。 使用Calendar对象，驱动程序可以计算考虑到自定义时区和区域设置的时间戳。 如果未指定Calendar对象，则驱动程序将使用默认的时区和区域设置。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        cal - 驱动程序将用于构建时间戳的 Calendar对象
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        从以下版本开始：
        1.2
        另请参见：
        setTimestamp(java.lang.String, java.sql.Timestamp)

      • registerOutParameter

        void registerOutParameter​(int parameterIndex,
                          int sqlType,
                          String typeName)
                   throws SQLException
        注册指定的输出参数。 此版本的方法registerOutParameter应用于用户定义或REF输出参数。 的用户定义类型的实例包括： STRUCT ， DISTINCT ， JAVA_OBJECT ，和指定数组类型。

        所有OUT参数必须在执行存储过程之前进行注册。

        对于用户定义的参数，还应该给出参数的完全限定的SQL类型名称，而REF参数要求给出引用类型的完全限定类型名称。 不需要类型代码和类型名称信息的JDBC驱动程序可能会忽略它。 然而，为了便于携带，应用程序应始终为用户定义和REF参数提供这些值。 虽然是为用户定义的和REF参数，该方法可以被用于注册任何JDBC类型的参数。 如果该参数不具有用户定义或REF类型，则typeName参数将被忽略。

        注意：读取out参数的值时，必须使用Java类型对应于参数的注册SQL类型的getter方法。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        sqlType - 一个值从Types
        typeName - SQL结构化类型的全限定名称
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException -如果 sqlType是 ARRAY ， BLOB ， CLOB ， DATALINK ， JAVA_OBJECT ， NCHAR ， NCLOB ， NVARCHAR ， LONGNVARCHAR ， REF ， ROWID ， SQLXML或 STRUCT数据类型和JDBC驱动程序不支持此数据类型
        从以下版本开始：
        1.2
        另请参见：
        Types

      • registerOutParameter

        void registerOutParameter​(String parameterName,
                          int sqlType)
                   throws SQLException
        将名为parameterName的OUT参数注册到JDBC类型sqlType 。 所有OUT参数必须在执行存储过程之前进行注册。

        对于OUT参数，由sqlType指定的JDBC类型决定了在get方法中必须使用的Java类型，以读取该参数的值。

        如果希望返回到此输出参数的JDBC类型特定于该特定数据库，则sqlType应为java.sql.Types.OTHER 。 方法getObject(int)检索该值。

        参数
        parameterName - 参数的名称
        sqlType - 由java.sql.Types定义的JDBC类型代码。 如果参数为JDBC类型NUMERIC或DECIMAL ，则应使用接受比例值的registerOutParameter版本。
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException -如果 sqlType是 ARRAY ， BLOB ， CLOB ， DATALINK ， JAVA_OBJECT ， NCHAR ， NCLOB ， NVARCHAR ， LONGNVARCHAR ， REF ， ROWID ， SQLXML或 STRUCT数据类型和JDBC驱动程序不支持此数据类型，或者JDBC驱动程序不支持这种方法
        从以下版本开始：
        1.4
        另请参见：
        Types

      • registerOutParameter

        void registerOutParameter​(String parameterName,
                          int sqlType,
                          int scale)
                   throws SQLException
        将名为parameterName的参数注册为JDBC类型sqlType 。 所有OUT参数必须在执行存储过程之前进行注册。

        对于OUT参数，由sqlType指定的JDBC类型决定了在get方法中必须使用的Java类型，以读取该参数的值。

        这个版本registerOutParameter当参数是JDBC类型应使用NUMERIC或DECIMAL 。

        参数
        parameterName - 参数的名称
        sqlType - 由 java.sql.Types定义的SQL类型代码。
        scale - 小数点右侧所需的数字位数。 它必须大于或等于零。
        异常
        SQLException 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException -如果 sqlType是 ARRAY ， BLOB ， CLOB ， DATALINK ， JAVA_OBJECT ， NCHAR ， NCLOB ， NVARCHAR ， LONGNVARCHAR ， REF ， ROWID ， SQLXML或 STRUCT数据类型和JDBC驱动程序不支持此数据类型，或者JDBC驱动程序不支持这种方法
        从以下版本开始：
        1.4
        另请参见：
        Types

      • registerOutParameter

        void registerOutParameter​(String parameterName,
                          int sqlType,
                          String typeName)
                   throws SQLException
        注册指定的输出参数。 此版本的方法registerOutParameter应用于用户名或REF输出参数。 用户命名类型的示例包括：STRUCT，DISTINCT，JAVA_OBJECT和命名的数组类型。

        所有OUT参数必须在执行存储过程之前进行注册。

        对于用户命名的参数，还应该给出参数的完全限定的SQL类型名称，而REF参数要求给定引用类型的完全限定类型名称。 不需要类型代码和类型名称信息的JDBC驱动程序可能会忽略它。 然而，为了便于携带，应用程序应始终为用户命名和REF参数提供这些值。 尽管它是用于用户命名的和REF参数的，但是该方法可以用于注册任何JDBC类型的参数。 如果该参数不具有用户名或REF类型，则将忽略typeName参数。

        注意：读取out参数的值时，必须使用Java类型XXX对应于参数的注册SQL类型的getXXX方法。

        参数
        parameterName - 参数的名称
        sqlType - 一个值从Types
        typeName - SQL结构化类型的全限定名称
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException -如果 sqlType是 ARRAY ， BLOB ， CLOB ， DATALINK ， JAVA_OBJECT ， NCHAR ， NCLOB ， NVARCHAR ， LONGNVARCHAR ， REF ， ROWID ， SQLXML或 STRUCT数据类型和JDBC驱动程序不支持此数据类型，或者JDBC驱动程序不支持这种方法
        从以下版本开始：
        1.4
        另请参见：
        Types

      • getURL

        URL getURL​(int parameterIndex)
    throws SQLException
        以 java.net.URL对象的形式获取指定的JDBC DATALINK参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        结果
        一个 java.net.URL对象，表示用作指定参数的JDBC DATALINK值
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误，则在关闭的CallableStatement上调用此方法，或者如果返回的URL不是Java平台上的有效URL
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setURL(java.lang.String, java.net.URL)

      • setURL

        void setURL​(String parameterName,
            URL val)
     throws SQLException
        将指定的参数设置为给定的java.net.URL对象。 当驱动程序将其发送到数据库时将其转换为SQL DATALINK值。
        参数
        parameterName - 参数的名称
        val - 参数值
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误; 此方法在关闭的CallableStatement或网址格式CallableStatement调用
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getURL(int)

      • setNull

        void setNull​(String parameterName,
             int sqlType)
      throws SQLException
        将指定的参数设置为SQL NULL 。

        注意：您必须指定参数的SQL类型。

        参数
        parameterName - 参数的名称
        sqlType - 在 java.sql.Types定义的SQL类型代码
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • setBoolean

        void setBoolean​(String parameterName,
                boolean x)
         throws SQLException
        将指定的参数设置为给定的Java boolean值。 当驱动程序将其发送到数据库时将其转换为SQL BIT或BOOLEAN值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getBoolean(int)

      • setByte

        void setByte​(String parameterName,
             byte x)
      throws SQLException
        将指定的参数设置为给定的Java byte值。 当驱动程序将其发送到数据库时，将其转换为SQL TINYINT值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getByte(int)

      • setShort

        void setShort​(String parameterName,
              short x)
       throws SQLException
        将指定的参数设置为给定的Java short值。 当驱动程序将其发送到数据库时，将其转换为SQL SMALLINT值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于一个命名的参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getShort(int)

      • setInt

        void setInt​(String parameterName,
            int x)
     throws SQLException
        将指定的参数设置为给定的Java int值。 当驱动程序将其发送到数据库时将其转换为SQL INTEGER值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getInt(int)

      • setLong

        void setLong​(String parameterName,
             long x)
      throws SQLException
        将指定的参数设置为给定的Java long值。 当驱动程序将其发送到数据库时，将其转换为SQL BIGINT值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getLong(int)

      • setFloat

        void setFloat​(String parameterName,
              float x)
       throws SQLException
        将指定的参数设置为给定的Java float值。 当驱动程序将其发送到数据库时将其转换为SQL FLOAT值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getFloat(int)

      • setDouble

        void setDouble​(String parameterName,
               double x)
        throws SQLException
        将指定的参数设置为给定的Java double值。 当驱动程序将其发送到数据库时，将其转换为SQL DOUBLE值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getDouble(int)

      • setBigDecimal

        void setBigDecimal​(String parameterName,
                   BigDecimal x)
            throws SQLException
        将指定的参数设置为给定的java.math.BigDecimal值。 当驱动程序将其发送到数据库时，将其转换为SQL NUMERIC值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getBigDecimal(int, int)

      • setString

        void setString​(String parameterName,
               String x)
        throws SQLException
        将指定的参数设置为给定的Java String值。 驱动程序将其转换为SQL VARCHAR或LONGVARCHAR值（取决于相对于驱动程序对VARCHAR的限制的参数的大小），当它发送到数据库时。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getString(int)

      • setBytes

        void setBytes​(String parameterName,
              byte[] x)
       throws SQLException
        将指定的参数设置为给定的Java字节数组。 驱动程序将其转换为SQL VARBINARY或LONGVARBINARY （取决于相对于驱动程序对VARBINARY值的限制的参数的大小），当它发送到数据库时。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于一个命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getBytes(int)

      • setDate

        void setDate​(String parameterName,
             Date x)
      throws SQLException
        使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的java.sql.Date值。 当驱动程序将其发送到数据库时，将其转换为SQL DATE值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getDate(int)

      • setTime

        void setTime​(String parameterName,
             Time x)
      throws SQLException
        将指定的参数设置为给定的java.sql.Time值。 当驱动程序将其发送到数据库时，将其转换为SQL TIME值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getTime(int)

      • setTimestamp

        void setTimestamp​(String parameterName,
                  Timestamp x)
           throws SQLException
        将指定的参数设置为给定的java.sql.Timestamp值。 当驱动程序将其发送到数据库时，将其转换为SQL TIMESTAMP值。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getTimestamp(int)

      • setAsciiStream

        void setAsciiStream​(String parameterName,
                    InputStream x,
                    int length)
             throws SQLException
        将指定的参数设置为给定的输入流，它将具有指定的字节数。 当输入非常大的ASCII值到LONGVARCHAR参数时，通过java.io.InputStream发送它可能更实用。 将根据需要从流中读取数据，直到达到文件结尾。 JDBC驱动程序将从ASCII到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterName - 参数的名称
        x - 包含ASCII参数值的Java输入流
        length - 流中的字节数
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • setBinaryStream

        void setBinaryStream​(String parameterName,
                     InputStream x,
                     int length)
              throws SQLException
        将指定的参数设置为给定的输入流，它将具有指定的字节数。 当一个非常大的二进制值输入到一个LONGVARBINARY参数时，通过一个java.io.InputStream对象发送它可能更实用。 数据将从流中读取，直到达到文件结尾。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterName - 参数的名称
        x - 包含二进制参数值的java输入流
        length - 流中的字节数
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • setObject

        void setObject​(String parameterName,
               Object x,
               int targetSqlType,
               int scale)
        throws SQLException
        使用给定对象设置指定参数的值。

        在发送给数据库之前，给定的Java对象将被转换为给定的targetSqlType。 如果对象具有自定义映射（实现接口SQLData的类），则JDBC驱动程序应调用方法SQLData.writeSQL将其写入SQL数据流。 如果，在另一方面，对象是实现一类Ref ， Blob ， Clob ， NClob ， Struct ， java.net.URL ，或Array ，驾驶员应把它传递给数据库作为相应SQL类型的值。

        请注意，此方法可能用于传递特定于数据库的抽象数据类型。

        参数
        parameterName - 参数的名称
        x - 包含输入参数值的对象
        targetSqlType - 要发送到数据库的SQL类型（在java.sql.Types中定义）。 比例参数可能进一步限定此类型。
        scale - 对于java.sql.Types.DECIMAL或java.sql.Types.NUMERIC类型，这是小数点后的位数。 对于所有其他类型，此值将被忽略。
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.4
        另请参见：
        Types ， getObject(int)

      • setObject

        void setObject​(String parameterName,
               Object x,
               int targetSqlType)
        throws SQLException
        使用给定对象设置指定参数的值。 该方法类似于setObject(String parameterName, Object x, int targetSqlType, int scaleOrLength) ，除了它假定为零。
        参数
        parameterName - 参数的名称
        x - 包含输入参数值的对象
        targetSqlType - 要发送到数据库的SQL类型（在java.sql.Types中定义）
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.4
        另请参见：
        getObject(int)

      • setObject

        void setObject​(String parameterName,
               Object x)
        throws SQLException
        使用给定对象设置指定参数的值。

        JDBC规范规定了从Java Object类型到SQL类型的标准映射。 在发送给数据库之前，给定的参数将被转换为相应的SQL类型。

        请注意，该方法可以用于通过使用特定于驱动程序的Java类型来传递特定于数据库的抽象数据类型。 如果对象是实现接口SQLData的类，则JDBC驱动程序应该调用方法SQLData.writeSQL将其写入SQL数据流。 如果，在另一方面，对象是实现一类Ref ， Blob ， Clob ， NClob ， Struct ， java.net.URL ，或Array ，驾驶员应把它传递给数据库作为相应SQL类型的值。

        如果存在歧义，则此方法会引发异常，例如，如果对象是实现多个以上命名的接口的类。

        注意：并非所有数据库都允许将非类型的Null发送到后端。 为了最大可移植性，应使用setNull或setObject(String parameterName, Object x, int sqlType)方法，而不是setObject(String parameterName, Object x) 。

        参数
        parameterName - 参数的名称
        x - 包含输入参数值的对象
        异常
        SQLException - 如果parameterName不对应于一个命名参数; 如果发生数据库访问错误，此方法在关闭的CallableStatement上调用，或者如果给定的Object参数不明确
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getObject(int)

      • setCharacterStream

        void setCharacterStream​(String parameterName,
                        Reader reader,
                        int length)
                 throws SQLException
        将指定的参数设置为给定的Reader对象，这是给定的长度的字符数。 当将非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更实用。 数据将从流中读取，直到达到文件结尾。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterName - 参数的名称
        reader - 包含用作指定参数的UNICODE数据的 java.io.Reader对象
        length - 流中的字符数
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • setDate

        void setDate​(String parameterName,
             Date x,
             Calendar cal)
      throws SQLException
        使用给定的Calendar对象将指定的参数设置为给定的java.sql.Date值。 驱动程序使用Calendar对象来构造一个SQL DATE值，然后驱动程序将其发送到数据库。 使用aa Calendar对象，驱动程序可以计算考虑到自定义时区的日期。 如果未指定Calendar对象，则驱动程序将使用默认时区，即运行应用程序的虚拟机的时区。
        参数
        parameterName - 参数的名称
        x - 参数值
        cal - 驱动程序将用于构建日期的 Calendar对象
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getDate(int)

      • setTime

        void setTime​(String parameterName,
             Time x,
             Calendar cal)
      throws SQLException
        使用给定的Calendar对象将指定的参数设置为给定的java.sql.Time值。 驱动程序使用Calendar对象来构造一个SQL TIME值，然后驱动程序将其发送到数据库。 使用aa Calendar对象，驱动程序可以计算考虑到自定义时区的时间。 如果没有指定Calendar对象，则驱动程序使用默认时区，即运行应用程序的虚拟机的时区。
        参数
        parameterName - 参数的名称
        x - 参数值
        cal - 驱动程序将用于构建时间的 Calendar对象
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getTime(int)

      • setTimestamp

        void setTimestamp​(String parameterName,
                  Timestamp x,
                  Calendar cal)
           throws SQLException
        使用给定的Calendar对象将指定的参数设置为给定的java.sql.Timestamp值。 驱动程序使用Calendar对象来构造一个SQL TIMESTAMP值，然后驱动程序将其发送到数据库。 使用aa Calendar对象，驱动程序可以计算考虑到自定义时区的时间戳。 如果未指定Calendar对象，则驱动程序使用默认时区，即运行应用程序的虚拟机的时区。
        参数
        parameterName - 参数的名称
        x - 参数值
        cal - 驱动程序将用于构建时间戳的 Calendar对象
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getTimestamp(int)

      • setNull

        void setNull​(String parameterName,
             int sqlType,
             String typeName)
      throws SQLException
        将指定的参数设置为SQL NULL 。 此版本的方法setNull应用于用户定义的类型和REF类型参数。 用户定义类型的示例包括：STRUCT，DISTINCT，JAVA_OBJECT和命名的数组类型。

        注意：为了便于携带，当指定NULL用户定义或REF参数时，应用程序必须给出SQL类型代码和完全限定的SQL类型名称。 在用户定义类型的情况下，名称是参数本身的类型名称。 对于REF参数，名称是引用类型的类型名称。

        尽管它是用于用户定义的和参数的参数，但是该方法可以用于设置任何JDBC类型的空值参数。 如果参数没有用户定义或REF类型，则给定的typeName将被忽略。

        参数
        parameterName - 参数的名称
        sqlType - 一个值从 java.sql.Types
        typeName - SQL用户定义类型的全限定名称; 如果参数不是用户定义的类型或SQL REF值，则忽略该值
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • getString

        String getString​(String parameterName)
          throws SQLException
        检索JDBC的价值CHAR ， VARCHAR ，或LONGVARCHAR参数为String的Java编程语言。

        对于固定长度类型的JDBC CHAR ，返回的String对象具有与数据库中SQL CHAR值相同的值，包括数据库添加的任何填充。

        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setString(java.lang.String, java.lang.String)

      • getBoolean

        boolean getBoolean​(String parameterName)
            throws SQLException
        以Java编程语言中的 boolean JDBC BIT或 BOOLEAN参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为false 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setBoolean(java.lang.String, boolean)

      • getByte

        byte getByte​(String parameterName)
      throws SQLException
        以Java编程语言中的 byte JDBC TINYINT参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setByte(java.lang.String, byte)

      • getShort

        short getShort​(String parameterName)
        throws SQLException
        以Java编程语言中的 short JDBC SMALLINT参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setShort(java.lang.String, short)

      • getInt

        int getInt​(String parameterName)
    throws SQLException
        以Java编程语言中的 int JDBC INTEGER参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setInt(java.lang.String, int)

      • getLong

        long getLong​(String parameterName)
      throws SQLException
        以Java编程语言中的 long JDBC BIGINT参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setLong(java.lang.String, long)

      • getFloat

        float getFloat​(String parameterName)
        throws SQLException
        以Java编程语言中的 float JDBC FLOAT参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterName不对应于一个命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setFloat(java.lang.String, float)

      • getDouble

        double getDouble​(String parameterName)
          throws SQLException
        以Java编程语言中的 double JDBC DOUBLE参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为0 。
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setDouble(java.lang.String, double)

      • getBytes

        byte[] getBytes​(String parameterName)
         throws SQLException
        以Java编程语言中的 byte数组的形式 byte JDBC BINARY或 VARBINARY参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setBytes(java.lang.String, byte[])

      • getDate

        Date getDate​(String parameterName)
      throws SQLException
        检索作为 java.sql.Date对象的JDBC DATE参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterName与命名参数不对应， 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setDate(java.lang.String, java.sql.Date)

      • getTime

        Time getTime​(String parameterName)
      throws SQLException
        检索作为 java.sql.Time对象的JDBC TIME参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setTime(java.lang.String, java.sql.Time)

      • getTimestamp

        Timestamp getTimestamp​(String parameterName)
                throws SQLException
        检索作为 java.sql.Timestamp对象的JDBC TIMESTAMP参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setTimestamp(java.lang.String, java.sql.Timestamp)

      • getObject

        Object getObject​(String parameterName)
          throws SQLException
        以Java编程语言中的Object参数的值。 如果该值为SQL NULL ，则驱动程序返回一个Java null 。

        此方法返回一个Java对象，其类型对应于使用方法registerOutParameter为该参数注册的JDBC类型。 通过将目标JDBC类型注册为java.sql.Types.OTHER ，此方法可用于读取数据库特定的抽象数据类型。

        参数
        parameterName - 参数的名称
        结果
        A java.lang.Object保存OUT参数值。
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        Types ， setObject(java.lang.String, java.lang.Object, int, int)

      • getBigDecimal

        BigDecimal getBigDecimal​(String parameterName)
                  throws SQLException
        检索JDBC NUMERIC参数的值作为 java.math.BigDecimal对象，该值与小数点右边的数字一样多。
        参数
        parameterName - 参数的名称
        结果
        参数值全精度。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setBigDecimal(java.lang.String, java.math.BigDecimal)

      • getObject

        Object getObject​(String parameterName,
                 Map<String,Class<?>> map)
          throws SQLException
        返回表示OUT参数值parameterName的对象，并使用map作为参数值的自定义映射。

        此方法返回一个Java对象，其类型对应于使用方法registerOutParameter为该参数注册的JDBC类型。 通过将目标JDBC类型注册为java.sql.Types.OTHER ，此方法可用于读取数据库特定的抽象数据类型。

        参数
        parameterName - 参数的名称
        map - 从SQL类型名称到Java类的映射
        结果
        一个 java.lang.Object持有OUT参数值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setObject(java.lang.String, java.lang.Object, int, int)

      • getRef

        Ref getRef​(String parameterName)
    throws SQLException
        以Java编程语言中的一个Ref对象获取JDBC REF(<structured-type>)参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值为Java编程语言中的一个Ref对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • getBlob

        Blob getBlob​(String parameterName)
      throws SQLException
        以Java编程语言的形式获取 JDBC BLOB参数的值作为Blob对象。
        参数
        parameterName - 参数的名称
        结果
        参数值为Java编程语言中的一个Blob对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • getClob

        Clob getClob​(String parameterName)
      throws SQLException
        以Java编程语言中的 java.sql.Clob对象获取JDBC CLOB参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值为Java编程语言中的一个Clob对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • getArray

        Array getArray​(String parameterName)
        throws SQLException
        以Java编程语言中的Array对象获取JDBC ARRAY参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值为Java编程语言中的一个Array对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • getDate

        Date getDate​(String parameterName,
             Calendar cal)
      throws SQLException
        检索JDBC DATE参数的值作为java.sql.Date对象，使用给定的Calendar对象构造日期。 使用Calendar对象，驱动程序可以计算考虑到自定义时区和区域设置的日期。 如果未指定Calendar对象，则驱动程序将使用默认的时区和区域设置。
        参数
        parameterName - 参数的名称
        cal - 驱动程序将用于构建日期的 Calendar对象
        结果
        参数值。 如果值为SQL NULL ，结果为null 。
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setDate(java.lang.String, java.sql.Date)

      • getTime

        Time getTime​(String parameterName,
             Calendar cal)
      throws SQLException
        检索JDBC TIME参数的值作为java.sql.Time对象，使用给定的Calendar对象构建时间。 使用Calendar对象，驱动程序可以计算考虑到自定义时区和区域设置的时间。 如果未指定Calendar对象，则驱动程序将使用默认的时区和区域设置。
        参数
        parameterName - 参数的名称
        cal - 驱动程序将用于构建时间的 Calendar对象
        结果
        参数值 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setTime(java.lang.String, java.sql.Time)

      • getTimestamp

        Timestamp getTimestamp​(String parameterName,
                       Calendar cal)
                throws SQLException
        检索JDBC TIMESTAMP参数的值作为java.sql.Timestamp对象，使用给定的Calendar对象构造Timestamp对象。 使用Calendar对象，驱动程序可以计算考虑到自定义时区和区域设置的时间戳。 如果未指定Calendar对象，则驱动程序将使用默认的时区和区域设置。
        参数
        parameterName - 参数的名称
        cal - 驱动程序将用于构建时间戳的 Calendar对象
        结果
        参数值。 如果值为SQL NULL ，则结果为null 。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setTimestamp(java.lang.String, java.sql.Timestamp)

      • getURL

        URL getURL​(String parameterName)
    throws SQLException
        以 java.net.URL对象的形式 java.net.URL JDBC DATALINK参数的值。
        参数
        parameterName - 参数的名称
        结果
        参数值为Java编程语言中的一个java.net.URL对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误，此方法在关闭的CallableStatement上CallableStatement ，或者如果URL出现问题
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setURL(java.lang.String, java.net.URL)

      • getRowId

        RowId getRowId​(int parameterIndex)
        throws SQLException
        以 java.sql.RowId对象的形式获取指定的JDBC ROWID参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        结果
        将表示JDBC ROWID值的RowId对象用作指定参数。 如果参数包含SQL NULL ，则返回一个null值。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getRowId

        RowId getRowId​(String parameterName)
        throws SQLException
        以 java.sql.RowId对象的形式获取指定的JDBC ROWID参数的值。
        参数
        parameterName - 参数的名称
        结果
        将表示JDBC ROWID值的RowId对象用作指定参数。 如果参数包含SQL NULL ，则返回一个null值。
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setRowId

        void setRowId​(String parameterName,
              RowId x)
       throws SQLException
        将指定的参数设置为给定的java.sql.RowId对象。 当驱动程序将其发送到数据库时，将其转换为SQL ROWID 。
        参数
        parameterName - 参数的名称
        x - 参数值
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNString

        void setNString​(String parameterName,
                String value)
         throws SQLException
        将指定的参数设置为给定的String对象。 驱动程序将其转换为SQL NCHAR或NVARCHAR或LONGNVARCHAR
        参数
        parameterName - 要设置的参数的名称
        value - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNCharacterStream

        void setNCharacterStream​(String parameterName,
                         Reader value,
                         long length)
                  throws SQLException
        将指定的参数设置为Reader对象。 Reader读取数据，直到达到文件结尾。 驱动程序必须从Java字符格式转换为数据库中的国家字符集。
        参数
        parameterName - 要设置的参数的名称
        value - 参数值
        length - 参数数据中的字符数。
        异常
        SQLException - 如果parameterName不对应于named参数;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNClob

        void setNClob​(String parameterName,
              NClob value)
       throws SQLException
        将指定的参数设置为java.sql.NClob对象。 该对象实现了java.sql.NClob接口。 这个NClob对象映射到一个SQL NCLOB 。
        参数
        parameterName - 要设置的参数的名称
        value - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setClob

        void setClob​(String parameterName,
             Reader reader,
             long length)
      throws SQLException
        将指定的参数设置为Reader对象。 reader必须包含由长度指定的字符数，否则在执行SQLException将生成CallableStatement 。 该方法与setCharacterStream (int, Reader, int)方法不同，因为它通知驱动程序参数值应该作为CLOB发送到服务器。 当使用setCharacterStream方法时，驱动程序可能需要额外的工作才能确定参数数据是否应作为LONGVARCHAR或CLOB发送到服务器
        参数
        parameterName - 要设置的参数的名称
        reader - 包含用于设置参数值的数据的对象。
        length - 参数数据中的字符数。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果指定的长度小于零; 发生数据库访问错误，或者在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setBlob

        void setBlob​(String parameterName,
             InputStream inputStream,
             long length)
      throws SQLException
        将指定的参数设置为InputStream对象。 Inputstream必须包含由长度指定的字符数，否则当执行SQLException将生成CallableStatement 。 该方法与setBinaryStream (int, InputStream, int)方法不同，因为它通知驱动程序参数值应作为BLOB发送到服务器。 当使用setBinaryStream方法时，驱动程序可能需要执行额外的工作才能确定是否应将参数数据作为LONGVARBINARY或BLOB发送到服务器
        参数
        parameterName - 要设置的参数的名称是2，...
        inputStream - 包含用于设置参数值的数据的对象。
        length - 参数数据中的字节数。
        异常
        SQLException - 如果parameterName与命名参数不对应;
如果指定的长度小于零;
如果InputStream中的字节数与指定长度不匹配;
如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNClob

        void setNClob​(String parameterName,
              Reader reader,
              long length)
       throws SQLException
        将指定的参数设置为Reader对象。 reader必须包含由长度指定的字符数，否则当执行SQLException将生成CallableStatement 。 该方法与setCharacterStream (int, Reader, int)方法不同，因为它通知驱动程序参数值应作为NCLOB发送到服务器。 当使用setCharacterStream方法时，驱动程序可能需要额外的工作才能确定参数数据是否应作为LONGNVARCHAR或NCLOB发送到服务器
        参数
        parameterName - 要设置的参数的名称
        reader - 包含用于设置参数值的数据的对象。
        length - 参数数据中的字符数。
        异常
        SQLException - 如果parameterName与命名参数不对应;
如果指定的长度小于零;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNClob

        NClob getNClob​(int parameterIndex)
        throws SQLException
        以Java编程语言的形式获取指定的JDBC NCLOB参数的值作为 java.sql.NClob对象。
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        结果
        该参数值作为Java编程语言中的一个NClob对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterIndex无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNClob

        NClob getNClob​(String parameterName)
        throws SQLException
        以Java编程语言的形式 java.sql.NClob JDBC NCLOB参数的值作为 java.sql.NClob对象。
        参数
        parameterName - 参数的名称
        结果
        参数值为Java编程语言中的一个NClob对象。 如果值为SQL NULL ，则返回值null 。
        异常
        SQLException - 如果parameterName不对应于named参数;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setSQLXML

        void setSQLXML​(String parameterName,
               SQLXML xmlObject)
        throws SQLException
        将指定的参数设置为给定的java.sql.SQLXML对象。 当驱动程序将其发送到数据库时，将其转换为SQL XML值。
        参数
        parameterName - 参数的名称
        xmlObject - 一个 SQLXML对象，绘制一个 SQL XML值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误; 这个方法被称为在关闭CallableStatement或java.xml.transform.Result ， Writer或OutputStream为尚未关闭SQLXML对象
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getSQLXML

        SQLXML getSQLXML​(int parameterIndex)
          throws SQLException
        以Java编程语言中的 java.sql.SQLXML对象获取指定的 SQL XML参数的值。
        参数
        parameterIndex - 第一个参数的索引为1，第二个为2，...
        结果
        一个映射 SQL XML值的 SQLXML对象
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getSQLXML

        SQLXML getSQLXML​(String parameterName)
          throws SQLException
        以Java编程语言中的 java.sql.SQLXML对象的形式获取指定的 SQL XML参数的值。
        参数
        parameterName - 参数的名称
        结果
        一个映射 SQL XML值的 SQLXML对象
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNString

        String getNString​(int parameterIndex)
           throws SQLException
        检索指定的值NCHAR ， NVARCHAR或者LONGNVARCHAR参数为String的Java编程语言。

        对于固定长度类型的JDBC NCHAR ，返回的String对象与数据库中的SQL NCHAR值完全相同，包括数据库添加的任何填充。

        参数
        parameterIndex - 第一个参数的索引为1，第二个为2，...
        结果
        一个 String对象映射的 NCHAR ， NVARCHAR或 LONGNVARCHAR值
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6
        另请参见：
        setNString(java.lang.String, java.lang.String)

      • getNString

        String getNString​(String parameterName)
           throws SQLException
        检索指定的值NCHAR ， NVARCHAR或者LONGNVARCHAR参数为String的Java编程语言。

        对于固定长度类型的JDBC NCHAR ，返回的String对象具有与数据库中具有的SQL NCHAR值完全相同的值，包括数据库添加的任何填充。

        参数
        parameterName - 参数的名称
        结果
        一个 String对象映射的 NCHAR ， NVARCHAR或 LONGNVARCHAR值
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6
        另请参见：
        setNString(java.lang.String, java.lang.String)

      • getNCharacterStream

        Reader getNCharacterStream​(int parameterIndex)
                    throws SQLException
        以Java编程语言的形式获取指定参数的值作为java.io.Reader对象。 访问时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR参数。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        结果
        一个包含参数值的java.io.Reader对象; 如果值为SQL NULL ，则返回的值为Java编程语言中的null 。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNCharacterStream

        Reader getNCharacterStream​(String parameterName)
                    throws SQLException
        以Java编程语言的形式获取指定参数的值作为java.io.Reader对象。 访问时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR参数。
        参数
        parameterName - 参数的名称
        结果
        一个包含参数值的java.io.Reader对象; 如果值为SQL NULL ，则返回的值为null ，在Java编程语言
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getCharacterStream

        Reader getCharacterStream​(int parameterIndex)
                   throws SQLException
        以Java编程语言中的 java.io.Reader对象获取指定参数的值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        结果
        一个包含参数值的java.io.Reader对象; 如果值为SQL NULL ，则返回的值为null （在Java编程语言中）。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        从以下版本开始：
        1.6

      • getCharacterStream

        Reader getCharacterStream​(String parameterName)
                   throws SQLException
        以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
        参数
        parameterName - 参数的名称
        结果
        一个包含参数值的java.io.Reader对象; 如果值为SQL NULL ，则返回的值为Java编程语言中的null
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setBlob

        void setBlob​(String parameterName,
             Blob x)
      throws SQLException
        将指定的参数设置为给定的java.sql.Blob对象。 当驱动程序将其发送到数据库时，将其转换为SQL BLOB值。
        参数
        parameterName - 参数的名称
        x - 一个 Blob对象，映射SQL BLOB值
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setClob

        void setClob​(String parameterName,
             Clob x)
      throws SQLException
        将指定的参数设置为给定的java.sql.Clob对象。 当驱动程序将其发送到数据库时，将其转换为SQL CLOB值。
        参数
        parameterName - 参数的名称
        x - 一个映射SQL CLOB值的 Clob对象
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setAsciiStream

        void setAsciiStream​(String parameterName,
                    InputStream x,
                    long length)
             throws SQLException
        将指定的参数设置为给定的输入流，它将具有指定的字节数。 当输入非常大的ASCII值到LONGVARCHAR参数时，通过java.io.InputStream发送它可能更实用。 将根据需要从流中读取数据，直到达到文件结尾。 JDBC驱动程序将从ASCII到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterName - 参数的名称
        x - 包含ASCII参数值的Java输入流
        length - 流中的字节数
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setBinaryStream

        void setBinaryStream​(String parameterName,
                     InputStream x,
                     long length)
              throws SQLException
        将指定的参数设置为给定的输入流，它将具有指定的字节数。 当一个非常大的二进制值输入到一个LONGVARBINARY参数时，通过一个java.io.InputStream对象发送它可能比较实用。 数据将从流中读取，直到达到文件结尾。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterName - 参数的名称
        x - 包含二进制参数值的java输入流
        length - 流中的字节数
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setCharacterStream

        void setCharacterStream​(String parameterName,
                        Reader reader,
                        long length)
                 throws SQLException
        将指定的参数设置为给定的Reader对象，这是给定的长度的字符数。 当将非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更实用。 数据将从流中读取，直到达到文件结尾。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterName - 参数的名称
        reader - 包含用作指定参数的UNICODE数据的 java.io.Reader对象
        length - 流中的字符数
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setAsciiStream

        void setAsciiStream​(String parameterName,
                    InputStream x)
             throws SQLException
        将指定的参数设置为给定的输入流。 当输入非常大的ASCII值到LONGVARCHAR参数时，通过java.io.InputStream发送它可能更实用。 将根据需要从流中读取数据，直到达到文件结尾。 JDBC驱动程序将从ASCII到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的setAsciiStream是否更有效。

        参数
        parameterName - 参数的名称
        x - 包含ASCII参数值的Java输入流
        异常
        SQLException - 如果parameterName不对应于命名参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setBinaryStream

        void setBinaryStream​(String parameterName,
                     InputStream x)
              throws SQLException
        将指定的参数设置为给定的输入流。 当一个非常大的二进制值输入到一个LONGVARBINARY参数时，通过一个java.io.InputStream对象发送它可能会比较实用。 数据将从流中读取，直到达到文件结尾。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的setBinaryStream是否更有效。

        参数
        parameterName - 参数的名称
        x - 包含二进制参数值的java输入流
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setCharacterStream

        void setCharacterStream​(String parameterName,
                        Reader reader)
                 throws SQLException
        将指定的参数设置为给定的Reader对象。 当将非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更实用。 数据将从流中读取，直到达到文件结尾。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的setCharacterStream可能会更有效。

        参数
        parameterName - 参数的名称
        reader - 包含Unicode数据的 java.io.Reader对象
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNCharacterStream

        void setNCharacterStream​(String parameterName,
                         Reader value)
                  throws SQLException
        将指定的参数设置为Reader对象。 Reader读取数据，直到达到文件结尾。 驱动程序必须从Java字符格式转换为数据库中的国家字符集。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的setNCharacterStream可能会更有效。

        参数
        parameterName - 参数的名称
        value - 参数值
        异常
        SQLException - 如果parameterName不对应于named参数;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误;
或者这个方法在关闭的CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setClob

        void setClob​(String parameterName,
             Reader reader)
      throws SQLException
        将指定的参数设置为Reader对象。 该方法与setCharacterStream (int, Reader)方法不同，因为它通知驱动程序参数值应作为CLOB发送到服务器。 当使用setCharacterStream方法时，驱动程序可能需要额外的工作才能确定参数数据是否应作为LONGVARCHAR或CLOB发送到服务器

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的setClob可能会更有效。

        参数
        parameterName - 参数的名称
        reader - 包含将参数值设置为的数据的对象。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setBlob

        void setBlob​(String parameterName,
             InputStream inputStream)
      throws SQLException
        将指定的参数设置为InputStream对象。 该方法与setBinaryStream (int, InputStream)方法不同，因为它通知驱动程序参数值应作为BLOB发送到服务器。 当使用setBinaryStream方法时，驱动程序可能需要进行额外的工作来确定参数数据是否应作为LONGVARBINARY或BLOB发送到服务器

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的setBlob可能会更有效。

        参数
        parameterName - 参数的名称
        inputStream - 包含要将参数值设置为的数据的对象。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNClob

        void setNClob​(String parameterName,
              Reader reader)
       throws SQLException
        将指定的参数设置为Reader对象。 该方法与setCharacterStream (int, Reader)方法不同，因为它通知驱动程序参数值应作为NCLOB发送到服务器。 当使用setCharacterStream方法时，驱动程序可能需要额外的工作才能确定参数数据是否应作为LONGNVARCHAR或NCLOB发送到服务器

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的setNClob可能会更有效。

        参数
        parameterName - 参数的名称
        reader - 包含用于设置参数值的数据的对象。
        异常
        SQLException - 如果parameterName不对应于命名参数;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getObject

        <T> T getObject​(int parameterIndex,
                Class<T> type)
         throws SQLException
        返回一个表示OUT参数值parameterIndex的对象，并且如果支持转换，则将从参数的SQL类型转换为所请求的Java数据类型。 如果不支持转换或为类型指定为null，则抛出SQLException 。

        至少，实现必须支持附录B表B-3中定义的转换，并将适当的用户定义的SQL类型转换为实现SQLData或Struct的Java类型。 可以支持额外的转换，并定义供应商。

        参数类型
        T - 由此Class对象建模的类的类型
        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        type - 表示将指定参数转换为的Java数据类型的类。
        结果
        一个持有OUT参数值的 type的实例
        异常
        SQLException - 如果不支持转换，type为null或发生另一个错误。 异常的getCause（）方法可能会提供更详细的异常，例如，如果发生转换错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.7

      • getObject

        <T> T getObject​(String parameterName,
                Class<T> type)
         throws SQLException
        返回表示OUT参数parameterName的值的对象，并将转换为参数的SQL类型为所需的Java数据类型，如果支持转换。 如果转换不受支持或为该类型指定为空，则抛出SQLException 。

        至少，实现必须支持附录B表B-3中定义的转换，并将适当的用户定义的SQL类型转换为实现SQLData或Struct的Java类型。 可以支持额外的转换，并定义供应商。

        参数类型
        T - 由此Class对象建模的类的类型
        参数
        parameterName - 参数的名称
        type - 表示将指定参数转换为的Java数据类型的类。
        结果
        一个持有OUT参数值的 type的实例
        异常
        SQLException - 如果不支持转换，type为null或发生另一个错误。 异常的getCause（）方法可能会提供更详细的异常，例如，如果发生转换错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.7

      • setObject

        default void setObject​(String parameterName,
                       Object x,
                       SQLType targetSqlType,
                       int scaleOrLength)
                throws SQLException
        使用给定对象设置指定参数的值。 如果第二个参数是一个InputStream则流必须包含scaleOrLength指定的字节数。 如果第二个参数是Reader那么读者必须包含scaleOrLength指定的字符数。 如果这些条件不正确，驱动程序将在执行准备好的语句时生成SQLException 。

        在发送给数据库之前，给定的Java对象将被转换为给定的targetSqlType。 如果对象具有自定义映射（实现接口SQLData的类），则JDBC驱动程序应调用方法SQLData.writeSQL将其写入SQL数据流。 如果，在另一方面，对象是实现一类Ref ， Blob ， Clob ， NClob ， Struct ， java.net.URL ，或Array ，驾驶员应把它传递给数据库作为相应SQL类型的值。

        请注意，此方法可能用于传递特定于数据库的抽象数据类型。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterName - 参数的名称
        x - 包含输入参数值的对象
        targetSqlType - 要发送到数据库的SQL类型。 比例参数可能进一步限定此类型。
        scaleOrLength - 对于java.sql.JDBCType.DECIMAL或java.sql.JDBCType.NUMERIC types ，这是小数点后的位数。 对于Java对象类型InputStream和Reader ，这是流或读取器中数据的长度。 对于所有其他类型，此值将被忽略。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法，或者如果x指定的Java对象是InputStream或Reader对象，并且scale参数的值小于零
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • setObject

        default void setObject​(String parameterName,
                       Object x,
                       SQLType targetSqlType)
                throws SQLException
        使用给定对象设置指定参数的值。 该方法类似于setObject(String parameterName, Object x, SQLType targetSqlType, int scaleOrLength) ，除了它假定为零。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterName - 参数的名称
        x - 包含输入参数值的对象
        targetSqlType - 要发送到数据库的SQL类型
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • registerOutParameter

        default void registerOutParameter​(int parameterIndex,
                                  SQLType sqlType)
                           throws SQLException
        将序号parameterIndex的OUT参数注册到JDBC类型sqlType 。 所有OUT参数必须在执行存储过程之前进行注册。

        对于OUT参数，由sqlType指定的JDBC类型决定了在get方法中必须使用的Java类型，以读取该参数的值。

        如果希望返回到此输出参数的JDBC类型是特定于该特定数据库的，则sqlType可能为JDBCType.OTHER或JDBC驱动程序支持的SQLType 。 方法getObject(int)检索该值。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        sqlType - 由SQLType定义的JDBC类型代码用于注册OUT参数。 如果参数为JDBC类型JDBCType.NUMERIC或JDBCType.DECIMAL ，则应使用接受比例值的registerOutParameter版本。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的sqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • registerOutParameter

        default void registerOutParameter​(int parameterIndex,
                                  SQLType sqlType,
                                  int scale)
                           throws SQLException
        将序号parameterIndex的参数注册为JDBC类型sqlType 。 所有OUT参数必须在执行存储过程之前进行注册。

        对于OUT参数，由sqlType指定的JDBC类型决定了在get方法中必须使用的Java类型，以读取该参数的值。

        这个版本registerOutParameter当参数是JDBC类型应使用JDBCType.NUMERIC或JDBCType.DECIMAL 。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterIndex - 第一个参数是1，第二个是2，依此类推
        sqlType - 由 SQLType定义的JDBC类型代码用于注册OUT参数。
        scale - 小数点右侧所需的数字位数。 它必须大于或等于零。
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的sqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • registerOutParameter

        default void registerOutParameter​(int parameterIndex,
                                  SQLType sqlType,
                                  String typeName)
                           throws SQLException
        注册指定的输出参数。 此版本的方法registerOutParameter应用于用户定义或REF输出参数。 的用户定义类型的实例包括： STRUCT ， DISTINCT ， JAVA_OBJECT ，和指定数组类型。

        所有OUT参数必须在执行存储过程之前进行注册。

        对于用户定义的参数，还应该给出参数的完全限定的SQL类型名称，而REF参数要求给出引用类型的完全限定类型名称。 不需要类型代码和类型名称信息的JDBC驱动程序可能会忽略它。 然而，为了便于携带，应用程序应始终为用户定义的参数和REF参数提供这些值。 虽然它是用于用户定义和REF参数，但此方法可用于注册任何JDBC类型的参数。 如果该参数不具有用户定义或类型为REF ，则typeName参数将被忽略。

        注意：读取out参数的值时，必须使用Java类型对应于参数的注册SQL类型的getter方法。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        sqlType - 由 SQLType定义的JDBC类型代码用于注册OUT参数。
        typeName - SQL结构化类型的全限定名称
        异常
        SQLException - 如果parameterIndex无效; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的sqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • registerOutParameter

        default void registerOutParameter​(String parameterName,
                                  SQLType sqlType)
                           throws SQLException
        将名为parameterName的OUT参数注册到JDBC类型sqlType 。 所有OUT参数必须在执行存储过程之前进行注册。

        对于OUT参数，由sqlType指定的JDBC类型确定在get方法中必须使用的Java类型来读取该参数的值。

        如果预期要返回给此输出参数的JDBC类型是特定于该特定的数据库， sqlType应该是JDBCType.OTHER或SQLType由该JDBC驱动程序支持..方法getObject(int)检索值。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterName - 参数的名称
        sqlType - 由SQLType定义的JDBC类型代码用于注册OUT参数。 如果参数为JDBC类型JDBCType.NUMERIC或JDBCType.DECIMAL ，则应使用接受比例值的registerOutParameter版本。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的sqlType或JDBC驱动程序不支持此方法
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • registerOutParameter

        default void registerOutParameter​(String parameterName,
                                  SQLType sqlType,
                                  int scale)
                           throws SQLException
        将名为parameterName的参数注册为JDBC类型sqlType 。 所有OUT参数必须在执行存储过程之前进行注册。

        对于OUT参数，由sqlType指定的JDBC类型决定了在get方法中必须使用的Java类型，以读取该参数的值。

        这个版本registerOutParameter当参数是JDBC类型应使用JDBCType.NUMERIC或JDBCType.DECIMAL 。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterName - 参数的名称
        sqlType - 由 SQLType定义的JDBC类型代码用于注册OUT参数。
        scale - 小数点右侧所需的数字位数。 它必须大于或等于零。
        异常
        SQLException - 如果parameterName不对应于named参数; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的sqlType或JDBC驱动程序不支持此方法
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • registerOutParameter

        default void registerOutParameter​(String parameterName,
                                  SQLType sqlType,
                                  String typeName)
                           throws SQLException
        注册指定的输出参数。 此版本的方法registerOutParameter应用于用户名或REF输出参数。 用户命名类型的示例包括：STRUCT，DISTINCT，JAVA_OBJECT和命名的数组类型。

        所有OUT参数必须在执行存储过程之前进行注册。

        对于用户命名的参数，还应该给出参数的完全限定的SQL类型名称，而REF参数要求给定引用类型的完全限定类型名称。 不需要类型代码和类型名称信息的JDBC驱动程序可能会忽略它。 然而，为了便于携带，应用程序应始终为用户命名和REF参数提供这些值。 尽管它是用于用户命名的和REF参数的，但是该方法可以用于注册任何JDBC类型的参数。 如果该参数不具有用户名或REF类型，则将忽略typeName参数。

        注意：读取out参数的值时，必须使用Java类型XXX对应于参数的注册SQL类型的getXXX方法。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterName - 参数的名称
        sqlType - 由 SQLType定义的JDBC类型代码用于注册OUT参数。
        typeName - SQL结构化类型的全限定名称
        异常
        SQLException - 如果parameterName与命名参数不对应; 如果发生数据库访问错误或在关闭的CallableStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的sqlType或JDBC驱动程序不支持此方法
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClientInfoStatus (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.sql
软件包 java.sql

Enum ClientInfoStatus

  • java.lang.Object
    • java.lang.Enum<ClientInfoStatus>
      • java.sql.ClientInfoStatus
  • All Implemented Interfaces:
    Serializable ， Comparable<ClientInfoStatus>

    public enum ClientInfoStatus
extends Enum<ClientInfoStatus>
    通过拨打 Connection.setClientInfo无法设置属性的状态的枚举
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      REASON_UNKNOWN
      由于某些未知原因，客户端信息属性无法设置
      REASON_UNKNOWN_PROPERTY
      指定的客户端信息属性名称不是公认的属性名称。
      REASON_VALUE_INVALID
      为客户端info属性指定的值无效。
      REASON_VALUE_TRUNCATED
      为客户端信息属性指定的值太大。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ClientInfoStatus valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ClientInfoStatus[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • REASON_UNKNOWN

        public static final ClientInfoStatus REASON_UNKNOWN
        由于某些未知原因，客户端信息属性无法设置
        从以下版本开始：
        1.6

      • REASON_UNKNOWN_PROPERTY

        public static final ClientInfoStatus REASON_UNKNOWN_PROPERTY
        指定的客户端信息属性名称不是公认的属性名称。
        从以下版本开始：
        1.6

      • REASON_VALUE_INVALID

        public static final ClientInfoStatus REASON_VALUE_INVALID
        为客户端info属性指定的值无效。
        从以下版本开始：
        1.6

      • REASON_VALUE_TRUNCATED

        public static final ClientInfoStatus REASON_VALUE_TRUNCATED
        为客户端信息属性指定的值太大。
        从以下版本开始：
        1.6

    • 方法详细信息

      • values

        public static ClientInfoStatus[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ClientInfoStatus c : ClientInfoStatus.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ClientInfoStatus valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Clob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Clob

  • All Known Subinterfaces:
    NClob
    所有已知实现类：
    SerialClob

    public interface Clob
    在Java的编程语言中映射为SQL CLOB类型。 SQL CLOB是一种内置类型，将字符大对象作为列值存储在数据库表的行中。 默认情况下，驱动程序使用SQL locator(CLOB)实现Clob对象，这意味着Clob对象包含指向SQL CLOB数据而不是数据本身的逻辑指针。 Clob对象在其创建的事务的持续时间内有效。

    Clob接口提供了获取SQL CLOB （字符大对象）值的长度的方法，用于在客户端上实现CLOB值，以及在CLOB值内搜索子字符串或CLOB对象。 方法在接口ResultSet ， CallableStatement ，并PreparedStatement ，如getClob和setClob允许编程人员访问SQL CLOB值。 此外，该界面还具有更新CLOB值的方法。

    如果JDBC驱动程序支持数据类型，则必须完全实现Clob接口上的所有方法。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void free​()
      此方法释放 Clob对象所持有的资源。
      InputStream getAsciiStream​()
      检索由该 Clob对象指定的 CLOB值作为ascii流。
      Reader getCharacterStream​()
      检索 Clob对象作为 java.io.Reader对象（或作为字符流）指定的 CLOB值。
      Reader getCharacterStream​(long pos, long length)
      返回一个包含部分 Clob值的 Reader对象，以pos指定的字符开头，长度字符为长度。
      String getSubString​(long pos, int length)
      检索由该 Clob对象指定的 CLOB值中指定的子字符串的副本。
      long length​()
      检索由 Clob对象指定的 CLOB值中的字符数。
      long position​(String searchstr, long start)
      检索由 Clob对象表示的SQL CLOB指定的子字符串 searchstr出现的字符位置。
      long position​(Clob searchstr, long start)
      检索此 Clob对象中指定的 Clob对象 searchstr的字符位置。
      OutputStream setAsciiStream​(long pos)
      检索流用于写入ASCII字符的 CLOB值，这 Clob对象表示，起始于位置 pos 。
      Writer setCharacterStream​(long pos)
      检索流用于写入的Unicode字符流的 CLOB值，这 Clob对象表示，在位置 pos 。
      int setString​(long pos, String str)
      写入给定的Java String到 CLOB值，这 Clob对象表示在该位置 pos 。
      int setString​(long pos, String str, int offset, int len)
      写入 len字符的 str ，从字符 offset开始，以 Clob表示的 CLOB值。
      void truncate​(long len)
      截断这个 Clob指定的长度为 len字符的 CLOB值。

    • 方法详细信息

      • length

        long length​()
     throws SQLException
        检索由 Clob对象指定的 CLOB值中的字符数。
        结果
        长度为 CLOB的字符
        异常
        SQLException - 访问 CLOB值的长度是否存在错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getSubString

        String getSubString​(long pos,
                    int length)
             throws SQLException
        在Clob对象指定的CLOB值中检索指定子字符串的副本。 子pos始于位置pos ，最多可连续length个字符。
        参数
        pos - 要提取的子字符串的第一个字符。 第一个字符在位置1。
        length - 要复制的连续字符数; 长度的值必须为0或更大
        结果
        一个 String是 Clob对象中指定的 CLOB值中指定的子字符串
        异常
        SQLException - 访问CLOB值是否有错误; 如果pos小于1或长度小于0
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getCharacterStream

        Reader getCharacterStream​()
                   throws SQLException
        检索 Clob对象作为 java.io.Reader对象（或作为字符流）指定的 CLOB值。
        结果
        一个包含 CLOB数据的 java.io.Reader对象
        异常
        SQLException - 访问 CLOB值是否有错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        setCharacterStream(long)

      • getAsciiStream

        InputStream getAsciiStream​()
                    throws SQLException
        检索由该 Clob对象指定的 CLOB值作为ASCII码流。
        结果
        一个 java.io.InputStream对象包含 CLOB数据
        异常
        SQLException - 访问 CLOB值是否有错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        setAsciiStream(long)

      • position

        long position​(String searchstr,
              long start)
       throws SQLException
        检索由该Clob对象表示的SQL CLOB指定的子字符串searchstr出现的字符位置。 搜索从位置start开始。
        参数
        searchstr - 要搜索的子字符串
        start - 开始搜索的位置; 第一名是1
        结果
        子字符串出现的位置，如果不存在则为-1。 第一名是1
        异常
        SQLException - 如果存在访问 CLOB值的错误或者pos小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • position

        long position​(Clob searchstr,
              long start)
       throws SQLException
        检索此Clob对象中指定的Clob对象searchstr的字符位置。 搜索从位置start开始。
        参数
        searchstr - 要搜索的 Clob对象
        start - 开始搜索的位置; 第一名是1
        结果
        Clob对象出现的位置，如果不存在则为-1。 第一名是1
        异常
        SQLException - 如果存在访问 CLOB值的错误，或者如果启动小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • setString

        int setString​(long pos,
              String str)
       throws SQLException
        写入给定的Java String到CLOB值，这Clob对象表示在该位置pos 。 字符串将覆盖在现有的字符Clob在位置对象起始pos 。 如果在写入给定的字符串时达到Clob值的结尾，那么Clob值将被增加以容纳额外的字符。

        注意：如果为pos指定的值大于CLOB值的长度+ 1，那么行为是未定义的。 某些JDBC驱动程序可能会抛出一个SQLException而其他驱动程序可能会支持此操作。

        参数
        pos - 开始写入Clob对象所代表的CLOB值的位置; 第一名是1。
        str - 要写入 Clob指定的 CLOB值的字符串
        结果
        写入的字符数
        异常
        SQLException - 如果存在访问 CLOB值的错误或者pos小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • setString

        int setString​(long pos,
              String str,
              int offset,
              int len)
       throws SQLException
        写入len字符的str ，从字符offset开始，以Clob表示的CLOB值。 字符串将覆盖从位置pos开始的Clob对象中的现有字符。 如果在写入给定的字符串时达到了Clob值的结尾，那么Clob值将被增加以容纳额外的字符。

        注意：如果为pos指定的值大于CLOB值的长度+ 1，那么行为是未定义的。 一些JDBC驱动程序可能会抛出一个SQLException而其他驱动程序可能会支持此操作。

        参数
        pos - 开始写入这个CLOB对象的位置; 第一名是1
        str - 要写入这个 Clob对象的值的 CLOB值的字符串
        offset - 偏移到 str开始读取要写入的字符
        len - 要写入的字符数
        结果
        写入的字符数
        异常
        SQLException - 如果存在访问 CLOB值的错误或者pos小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • setAsciiStream

        OutputStream setAsciiStream​(long pos)
                     throws SQLException
        检索流用于写入ASCII字符的CLOB值，这Clob对象表示，起始于位置pos 。 写入流的字符将覆盖Clob对象中从位置pos开始的现有字符。 如果的端Clob而写入字符到流达到的值，则长度Clob值将增加以容纳额外的字符。

        注意：如果为pos指定的值大于CLOB值的长度+ 1，那么行为是未定义的。 某些JDBC驱动程序可能会抛出一个SQLException而其他驱动程序可能会支持此操作。

        参数
        pos - 开始写入这个CLOB对象的位置 第一名是1
        结果
        可以写入ASCII编码字符的流
        异常
        SQLException - 如果存在访问 CLOB值的错误或者pos小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getAsciiStream()

      • setCharacterStream

        Writer setCharacterStream​(long pos)
                   throws SQLException
        检索流用于写入的Unicode字符流的CLOB值，这Clob对象表示，在位置pos 。 写入流的字符将覆盖Clob对象中从位置pos开始的现有字符。 如果在将字符写入流时达到了Clob值，那么Clob值将被增加以容纳额外的字符。

        注意：如果为pos指定的值大于CLOB值的长度+ 1，那么行为是未定义的。 某些JDBC驱动程序可能会抛出一个SQLException而其他驱动程序可能会支持此操作。

        参数
        pos - 开始写入CLOB值的位置; 第一名是1
        结果
        可编写Unicode编码字符的流
        异常
        SQLException - 如果访问 CLOB值出现错误或者pos小于1
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getCharacterStream()

      • truncate

        void truncate​(long len)
       throws SQLException
        截断Clob指定的长度为len字符的CLOB值。

        注意：如果为pos指定的值大于CLOB值的长度+ 1，那么行为是未定义的。 某些JDBC驱动程序可能会抛出一个SQLException而其他驱动程序可能会支持此操作。

        参数
        len - 要截断 CLOB值的长度（以字符为 CLOB
        异常
        SQLException - 如果存在访问 CLOB值的错误或者如果len小于0
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • free

        void free​()
   throws SQLException
        此方法释放Clob对象所占据的资源。 调用free方法后，该对象无效。

        在free之后，任何调用free以外的方法的尝试将导致抛出SQLException 。 如果free被多次调用，在后续调用free被视为无操作。

        异常
        SQLException - 如果发生错误，释放Clob的资源
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getCharacterStream

        Reader getCharacterStream​(long pos,
                          long length)
                   throws SQLException
        返回一个包含部分 Clob值的 Reader对象，以pos指定的字符开头，长度为长度字符。
        参数
        pos - 要检索的部分值的第一个字符的偏移量。 Clob中的第一个字符在位置1。
        length - 要检索的部分值的字符长度。
        结果
        Reader通过其可以读取部分 Clob值。
        异常
        SQLException - 如果pos小于1; 或者如果pos大于Clob的字符数; 或者如果pos +长度大于Clob的字符数
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Connection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Connection

  • All Superinterfaces:
    AutoCloseable ， Wrapper

    public interface Connection
extends Wrapper, AutoCloseable

    与特定数据库的连接（会话）。 执行SQL语句并在连接的上下文中返回结果。

    Connection对象的数据库能够提供描述其表，其支持的SQL语法，其存储过程，此连接的功能等的信息。 该信息是通过getMetaData方法获得的。

    注意：配置Connection ，JDBC应用程序应使用适当的Connection方法，如setAutoCommit或setTransactionIsolation 。 当有JDBC方法可用时，应用程序不应直接调用SQL命令来更改连接的配置。 默认情况下，一个Connection对象处于自动提交模式，这意味着它在执行每个语句后自动提交更改。 如果自动提交模式已被禁用，则必须显式调用方法commit才能提交更改; 否则数据库更改将不会被保存。

    使用JDBC 2.1核心API创建的新的Connection对象具有与之关联的最初为空的类型映射。 用户可以在此类型地图中输入UDT的自定义映射。 当使用方法ResultSet.getObject从数据源检索UDT时， getObject方法将检查连接的类型映射，以查看是否存在该UDT的条目。 如果是这样，那么getObject方法会将UDT映射到指定的类。 如果没有条目，将使用标准映射映射UDT。

    用户可以创建一个新的类型映射，它是一个java.util.Map对象，在其中创建一个条目，并将其传递给可以执行自定义映射的java.sql方法。 在这种情况下，该方法将使用给定的类型映射，而不是与该连接关联的映射。

    例如，以下代码片段指定SQL类型ATHLETES将映射到Java编程语言中的类别Athletes 。 代码片段检索Connection对象con的类型映射，将条目插入其中，然后将新条目的类型映射设置为连接的类型映射。

      java.util.Map map = con.getTypeMap();
      map.put("mySchemaName.ATHLETES", Class.forName("Athletes"));
      con.setTypeMap(map);
    从以下版本开始：
    1.1
    另请参见：
    DriverManager.getConnection(java.lang.String, java.util.Properties) ， Statement ， ResultSet ， DatabaseMetaData

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TRANSACTION_NONE
      指示不支持事务的常量。
      static int TRANSACTION_READ_COMMITTED
      一个常数表示防止脏读; 可能会发生不可重复的读取和幻像读取。
      static int TRANSACTION_READ_UNCOMMITTED
      一个常量表示可能会发生脏读，不可重复读和幻读。
      static int TRANSACTION_REPEATABLE_READ
      一个常量表示防止了脏读和不可重复读; 可以发生幻影读取。
      static int TRANSACTION_SERIALIZABLE
      一个常数表示防止脏读，不可重复读和幻影读。

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void abort​(Executor executor)
      终止打开的连接。
      default void beginRequest​()
      向司机提示，一个请求，一个独立的工作单位，正在开始这个连接。
      void clearWarnings​()
      清除此 Connection对象报告的所有警告。
      void close​()
      立即释放此 Connection对象的数据库和JDBC资源，而不是等待它们自动释放。
      void commit​()
      使上次提交/回滚之后所做的所有更改都将永久性，并释放此 Connection对象当前持有的任何数据库锁。
      Array createArrayOf​(String typeName, Object[] elements)
      用于创建Array对象的Factory方法。
      Blob createBlob​()
      构造一个实现 Blob接口的对象。
      Clob createClob​()
      构造一个实现 Clob接口的对象。
      NClob createNClob​()
      构造一个实现 NClob接口的对象。
      SQLXML createSQLXML​()
      构造一个实现 SQLXML接口的对象。
      Statement createStatement​()
      创建一个 Statement对象，用于将SQL语句发送到数据库。
      Statement createStatement​(int resultSetType, int resultSetConcurrency)
      创建一个 Statement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
      Statement createStatement​(int resultSetType, int resultSetConcurrency, int resultSetHoldability)
      创建一个 Statement对象，该对象将生成具有给定类型，并发和 ResultSet对象。
      Struct createStruct​(String typeName, Object[] attributes)
      用于创建Struct对象的工厂方法。
      default void endRequest​()
      向司机提示，要求，独立工作单位已经完成。
      boolean getAutoCommit​()
      检索此 Connection对象的当前自动提交模式。
      String getCatalog​()
      检索此 Connection对象的当前目录名称。
      Properties getClientInfo​()
      返回包含驱动程序支持的每个客户端信息属性的名称和当前值的列表。
      String getClientInfo​(String name)
      返回由name指定的客户端信息属性的值。
      int getHoldability​()
      检索使用此 Connection对象创建的 ResultSet对象的当前可 Connection 。
      DatabaseMetaData getMetaData​()
      检索一个 DatabaseMetaData对象，其中包含有关此 Connection对象表示连接的数据库的元数据。
      int getNetworkTimeout​()
      检索驱动程序等待数据库请求完成的毫秒数。
      String getSchema​()
      检索此 Connection对象的当前模式名称。
      int getTransactionIsolation​()
      检索此 Connection对象的当前事务隔离级别。
      Map<String,Class<?>> getTypeMap​()
      检索与该 Map对象关联的 Connection对象。
      SQLWarning getWarnings​()
      检索此 Connection对象上的通话报告的第一个警告。
      boolean isClosed​()
      检索此 Connection对象是否已关闭。
      boolean isReadOnly​()
      检索此 Connection对象是否处于只读模式。
      boolean isValid​(int timeout)
      如果连接尚未关闭并且仍然有效，则返回true。
      String nativeSQL​(String sql)
      将给定的SQL语句转换为系统的本机SQL语法。
      CallableStatement prepareCall​(String sql)
      创建一个 CallableStatement对象来调用数据库存储过程。
      CallableStatement prepareCall​(String sql, int resultSetType, int resultSetConcurrency)
      创建一个 CallableStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
      CallableStatement prepareCall​(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
      创建一个 CallableStatement对象，它将生成具有给定类型和并发性的 ResultSet对象。
      PreparedStatement prepareStatement​(String sql)
      创建一个 PreparedStatement对象，用于将参数化的SQL语句发送到数据库。
      PreparedStatement prepareStatement​(String sql, int autoGeneratedKeys)
      创建一个默认的 PreparedStatement对象，该对象具有检索自动生成的密钥的能力。
      PreparedStatement prepareStatement​(String sql, int[] columnIndexes)
      创建一个默认的 PreparedStatement对象，能够返回由给定数组指定的自动生成的键。
      PreparedStatement prepareStatement​(String sql, int resultSetType, int resultSetConcurrency)
      创建一个 PreparedStatement对象，该对象将使用给定类型和并发性生成 ResultSet对象。
      PreparedStatement prepareStatement​(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
      创建一个 PreparedStatement对象，该对象将生成具有给定类型，并发和 ResultSet对象。
      PreparedStatement prepareStatement​(String sql, String[] columnNames)
      创建一个默认的 PreparedStatement对象，能够返回给定数组指定的自动生成的键。
      void releaseSavepoint​(Savepoint savepoint)
      从当前事务中删除指定的 Savepoint和后续的 Savepoint对象。
      void rollback​()
      撤消在当前事务中所做的所有更改，并释放此 Connection对象当前持有的任何数据库锁。
      void rollback​(Savepoint savepoint)
      撤消在给定的 Savepoint对象设置后进行的所有更改。
      void setAutoCommit​(boolean autoCommit)
      将此连接的自动提交模式设置为给定状态。
      void setCatalog​(String catalog)
      设置给定的目录名称，以便选择要在其中工作的 Connection对象的数据库的子空间。
      void setClientInfo​(String name, String value)
      将由name指定的客户端信息属性的值设置为由值指定的值。
      void setClientInfo​(Properties properties)
      设置连接的客户端信息属性的值。
      void setHoldability​(int holdability)
      将使用此 Connection对象创建的对象的默认 ResultSet更改为给定的可保存性。
      void setNetworkTimeout​(Executor executor, int milliseconds)
      设置 Connection的最大周期或从 Connection创建的 Connection将等待数据库回复任何一个请求。
      void setReadOnly​(boolean readOnly)
      将此连接设置为只读模式，作为驱动程序的提示以启用数据库优化。
      Savepoint setSavepoint​()
      在当前事务中创建一个未命名的保存点，并返回表示它的新的 Savepoint对象。
      Savepoint setSavepoint​(String name)
      在当前事务中创建具有给定名称的保存点，并返回表示它的新的 Savepoint对象。
      void setSchema​(String schema)
      设置要访问的给定模式名称。
      default void setShardingKey​(ShardingKey shardingKey)
      指定与此Connection一起使用的shardingKey
      default void setShardingKey​(ShardingKey shardingKey, ShardingKey superShardingKey)
      指定与此连接一起使用的shardingKey和superShardingKey
      default boolean setShardingKeyIfValid​(ShardingKey shardingKey, int timeout)
      设置并验证此连接的分片密钥。
      default boolean setShardingKeyIfValid​(ShardingKey shardingKey, ShardingKey superShardingKey, int timeout)
      设置并验证此连接的分片密钥。
      void setTransactionIsolation​(int level)
      尝试将此 Connection对象的事务隔离级别更改为给定的对象。
      void setTypeMap​(Map<String,Class<?>> map)
      安装给定 TypeMap对象的类型映射此 Connection对象。

      • Methods inherited from interface java.sql.Wrapper

        isWrapperFor, unwrap

    • 字段详细信息

      • TRANSACTION_NONE

        static final int TRANSACTION_NONE
        指示不支持事务的常量。
        另请参见：
        Constant Field Values

      • TRANSACTION_READ_UNCOMMITTED

        static final int TRANSACTION_READ_UNCOMMITTED
        一个常量表示可能会发生脏读，不可重复读和幻读。 此级别允许在该行的任何更改被提交之前，一个事务更改的行被另一个事务读取（“脏读”）。 如果任何更改被回滚，则第二个事务将检索到无效的行。
        另请参见：
        Constant Field Values

      • TRANSACTION_READ_COMMITTED

        static final int TRANSACTION_READ_COMMITTED
        一个常数表示防止脏读; 可能会发生不可重复的读取和幻像读取。 此级别仅禁止一个事务读取其中未提交的更改的行。
        另请参见：
        Constant Field Values

      • TRANSACTION_REPEATABLE_READ

        static final int TRANSACTION_REPEATABLE_READ
        一个常量表示防止了脏读和不可重复读; 可以发生幻影读取。 该级别禁止事务读取其中未提交的更改的行，并且还禁止一个事务读取行的情况，第二事务更改行，并且第一个事务重新读取该行，第二次获取不同的值（ “不可重复读”）。
        另请参见：
        Constant Field Values

      • TRANSACTION_SERIALIZABLE

        static final int TRANSACTION_SERIALIZABLE
        一个常数表示防止脏读，不可重复读和幻影读。 此级别包括在禁止TRANSACTION_REPEATABLE_READ ，并进一步禁止在那里一个事务读取满足所有行的情况WHERE条件，第二个事务插入一行满足该WHERE条件，和第一个事务重新读取为相同的条件下，检索附加的“幻影“行在第二读。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • createStatement

        Statement createStatement​()
                   throws SQLException
        创建一个Statement对象，用于将SQL语句发送到数据库。 无参数的SQL语句通常使用Statement对象执行。 如果相同的SQL语句执行了很多次，则使用PreparedStatement对象可能会更有效。

        使用返回的Statement对象创建的结果集将默认为TYPE_FORWARD_ONLY ，并发级别为CONCUR_READ_ONLY 。 创建的结果集的可保持性可以通过调用getHoldability()来确定。

        结果
        一个新的默认 Statement对象
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法

      • prepareStatement

        PreparedStatement prepareStatement​(String sql)
                            throws SQLException
        创建一个PreparedStatement对象，用于将参数化的SQL语句发送到数据库。

        具有或不具有IN参数的SQL语句可以预编译并存储在一个PreparedStatement对象中。 然后可以使用该对象多次有效地执行此语句。

        注意：此方法针对从预编译中受益的参数化SQL语句进行了优化。 如果驱动程序支持预编译，则方法prepareStatement将将该语句发送到数据库进行预编译。 有些驱动程序可能不支持预编译。 在这种情况下，在执行PreparedStatement对象之前，该语句可能不会发送到数据库。 这对用户没有直接影响; 然而，它确实影响了哪些方法抛出一些SQLException对象。

        使用返回的PreparedStatement对象创建的结果集将默认为TYPE_FORWARD_ONLY型，并发级别为CONCUR_READ_ONLY 。 创建的结果集的可保持性可以通过调用getHoldability()来确定。

        参数
        sql - 可能包含一个或多个“？”的SQL语句 IN参数占位符
        结果
        一个新的默认的 PreparedStatement对象包含预编译的SQL语句
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法

      • prepareCall

        CallableStatement prepareCall​(String sql)
                       throws SQLException
        创建一个CallableStatement对象来调用数据库存储过程。 CallableStatement对象提供了设置其IN和OUT参数的方法以及执行对存储过程的调用的方法。

        注意：此方法针对处理存储过程调用语句进行了优化。 当完成方法prepareCall时，一些驱动程序可以将呼叫声明发送到数据库; 其他人可能会等到CallableStatement对象执行。 这对用户没有直接影响; 但是，它确实会影响哪个方法抛出某些SQLExceptions。

        使用返回的CallableStatement对象创建的结果集将默认为TYPE_FORWARD_ONLY ，并发级别为CONCUR_READ_ONLY 。 创建的结果集的可保持性可以通过调用getHoldability()来确定。

        参数
        sql - 可能包含一个或多个“？”的SQL语句 参数占位符 通常使用JDBC调用转义语法指定此语句。
        结果
        一个新的默认的 CallableStatement对象包含预编译的SQL语句
        异常
        SQLException - 如果发生数据库访问错误或在关闭的连接上调用此方法

      • nativeSQL

        String nativeSQL​(String sql)
          throws SQLException
        将给定的SQL语句转换为系统的本机SQL语法。 驱动程序可以将JDBC SQL语法转换为系统的本机SQL语法，然后再发送。 此方法返回驱动程序将发送的语句的本机形式。
        参数
        sql - 可能包含一个或多个“？”的SQL语句 参数占位符
        结果
        本声明的本机形式
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法

      • setAutoCommit

        void setAutoCommit​(boolean autoCommit)
            throws SQLException
        将此连接的自动提交模式设置为给定状态。 如果连接处于自动提交模式，则其所有SQL语句将作为单个事务执行并提交。 否则，其SQL语句被分组为通过调用方法commit或方法rollback终止的事务。 默认情况下，新连接处于自动提交模式。

        当语句完成时，发生提交。 语句完成的时间取决于SQL语句的类型：

        • 对于DML语句（如插入，更新或删除）和DDL语句，语句在执行完成后立即完成。
        • 对于Select语句，当关联的结果集关闭时，该语句将完成。
        • 对于CallableStatement对象或返回多个结果的语句，当所有关联的结果集都已关闭，并且已检索到所有更新计数和输出参数时，该语句将完成。

        注意：如果在事务中调用此方法并更改了自动提交模式，则事务将被提交。 如果调用了setAutoCommit ，并且自动提交模式未更改，则调用是无操作的。

        参数
        autoCommit - true启用自动提交模式; false禁用它
        异常
        SQLException - 如果发生数据库访问错误，则在参与分布式事务时调用setAutoCommit（true），或者在闭合连接上调用此方法
        另请参见：
        getAutoCommit()

      • getAutoCommit

        boolean getAutoCommit​()
               throws SQLException
        检索此 Connection对象的当前自动提交模式。
        结果
        这个 Connection对象的自动提交模式的当前状态
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法
        另请参见：
        setAutoCommit(boolean)

      • commit

        void commit​()
     throws SQLException
        使之前进行的所有更改都是永久性的，并释放此Connection对象当前持有的任何数据库锁。 只有当自动提交模式被禁用时，才应该使用此方法。
        异常
        SQLException -如果发生数据库访问错误，这种方法在参与分布式事务的同时调用，如果这种方法被称为关闭的连接上或本 Connection对象处于自动提交模式
        另请参见：
        setAutoCommit(boolean)

      • rollback

        void rollback​()
       throws SQLException
        撤消在当前事务中所做的所有更改，并释放此Connection对象当前持有的任何数据库锁。 只有当自动提交模式被禁用时，才应该使用此方法。
        异常
        SQLException -如果发生数据库访问错误，这种方法在参与分布式事务的同时调用，调用此方法关闭的连接上或本 Connection对象处于自动提交模式
        另请参见：
        setAutoCommit(boolean)

      • close

        void close​()
    throws SQLException
        立即释放此Connection对象的数据库和JDBC资源，而不是等待它们自动释放。

        调用已关闭的Connection对象上的方法close是无操作的。

        强烈建议在调用close方法之前，应用程序显式地提交或回滚活动事务。 如果调用了close方法，并且有一个活动的事务，则结果是实现定义的。

        Specified by:
        close在接口 AutoCloseable
        异常
        SQLException - 如果发生数据库访问错误

      • isClosed

        boolean isClosed​()
          throws SQLException
        检索此Connection对象是否已关闭。 如果方法close已被调用或者发生某些致命错误，则连接被关闭。 这种方法只有在方法Connection.close被调用之后被调用才能保证返回true 。

        通常无法调用此方法来确定与数据库的连接是有效还是无效。 典型的客户端可以通过捕获尝试尝试时可能抛出的任何异常来确定连接无效。

        结果
        true如果这个Connection对象是关闭的; false如果它仍然是开放的
        异常
        SQLException - 如果发生数据库访问错误

      • getMetaData

        DatabaseMetaData getMetaData​()
                      throws SQLException
        检索DatabaseMetaData对象，其中包含此Connection对象表示连接的数据库的元数据。 元数据包括有关数据库表，其支持的SQL语法，其存储过程，此连接的功能等的信息。
        结果
        一个 DatabaseMetaData对象为这个 Connection对象
        异常
        SQLException - 如果发生数据库访问错误或在已关闭连接上调用此方法

      • setReadOnly

        void setReadOnly​(boolean readOnly)
          throws SQLException
        将此连接设置为只读模式，作为驱动程序的提示以启用数据库优化。

        注意：在事务中无法调用此方法。

        参数
        readOnly - true启用只读模式; false禁用它
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者在事务期间调用此方法

      • isReadOnly

        boolean isReadOnly​()
            throws SQLException
        检索此 Connection对象是否处于只读模式。
        结果
        true如果这个Connection对象是只读的; 否则为false
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法

      • setCatalog

        void setCatalog​(String catalog)
         throws SQLException
        设置给定的目录名称，以便选择要在其中工作的Connection对象的数据库的子空间。

        如果驱动程序不支持目录，它将默认忽略此请求。

        调用setCatalog对先前创建或准备没有影响Statement对象。 当Connection方法prepareStatement或prepareCall被调用时，是否定义DBMS准备操作是否立即进行实现。 为了获得最大的可移植性， setCatalog应该在之前被称为Statement创建或准备。

        参数
        catalog - 要在其中工作的目录（此 Connection对象的数据库中的子空间）的名称
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法
        另请参见：
        getCatalog()

      • getCatalog

        String getCatalog​()
           throws SQLException
        检索此 Connection对象的当前目录名称。
        结果
        当前目录名称或 null如果没有
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法
        另请参见：
        setCatalog(java.lang.String)

      • setTransactionIsolation

        void setTransactionIsolation​(int level)
                      throws SQLException
        尝试将此Connection对象的事务隔离级别更改为给定的对象。 界面Connection中定义的常量是可能的事务隔离级别。

        注意：如果在一个事务中调用这个方法，结果就是实现定义的。

        参数
        level -下列之一的Connection常量： Connection.TRANSACTION_READ_UNCOMMITTED ， Connection.TRANSACTION_READ_COMMITTED ， Connection.TRANSACTION_REPEATABLE_READ ，或Connection.TRANSACTION_SERIALIZABLE 。 （请注意，无法使用Connection.TRANSACTION_NONE因为它指定不支持事务。）
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者给定参数不是 Connection常量之一
        另请参见：
        DatabaseMetaData.supportsTransactionIsolationLevel(int) ， getTransactionIsolation()

      • getTransactionIsolation

        int getTransactionIsolation​()
                     throws SQLException
        检索此 Connection对象的当前事务隔离级别。
        结果
        当前事务隔离级别，这将是以下常量之一： Connection.TRANSACTION_READ_UNCOMMITTED ， Connection.TRANSACTION_READ_COMMITTED ， Connection.TRANSACTION_REPEATABLE_READ ， Connection.TRANSACTION_SERIALIZABLE ，或 Connection.TRANSACTION_NONE 。
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法
        另请参见：
        setTransactionIsolation(int)

      • getWarnings

        SQLWarning getWarnings​()
                throws SQLException
        检索此Connection对象上的呼叫报告的第一个警告。 如果有多个警告，则后续的警告将被链接到第一个警告，并且可以通过调用先前检索的警告的方法SQLWarning.getNextWarning来检索。

        这种方法可能不会在封闭的连接上被调用; 这样做会造成一个SQLException被抛出。

        注意：随后的警告将链接到此SQLWarning。

        结果
        第一个 SQLWarning对象或 null如果没有
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法
        另请参见：
        SQLWarning

      • clearWarnings

        void clearWarnings​()
            throws SQLException
        清除为该Connection对象报告的所有警告。 在调用此方法后，方法getWarnings返回null直到为该Connection对象报告新的警告。
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法

      • createStatement

        Statement createStatement​(int resultSetType,
                          int resultSetConcurrency)
                   throws SQLException
        创建一个Statement对象，该对象将生成具有给定类型和并发性的ResultSet对象。 该方法与上述createStatement方法相同，但允许覆盖默认的结果集类型和并发性。 创建的结果集的可保持性可以通过调用getHoldability()来确定。
        参数
        resultSetType - 结果集类型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        resultSetConcurrency - 并发类型; 一个ResultSet.CONCUR_READ_ONLY或ResultSet.CONCUR_UPDATABLE
        结果
        一个新的 Statement对象，将生成具有给定类型和并发的 ResultSet对象
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者给定参数不是 ResultSet表示类型和并发的常量
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法，或者该方法不支持指定的结果集类型和结果集并发。
        从以下版本开始：
        1.2

      • prepareStatement

        PreparedStatement prepareStatement​(String sql,
                                   int resultSetType,
                                   int resultSetConcurrency)
                            throws SQLException
        创建一个PreparedStatement对象，该对象将生成具有给定类型和并发性的ResultSet对象。 该方法与上述prepareStatement方法相同，但允许覆盖默认的结果集类型和并发性。 创建的结果集的可保留性可以通过调用getHoldability()来确定。
        参数
        sql - 一个String对象，即要发送到数据库的SQL语句; 可能包含一个或多个'？' IN参数
        resultSetType - 结果集类型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        resultSetConcurrency - 并发类型; ResultSet.CONCUR_READ_ONLY或ResultSet.CONCUR_UPDATABLE
        结果
        一个新的PreparedStatement对象，其中包含预编译的SQL语句，该语句将产生具有给定类型和并发性的 ResultSet对象
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者给定的参数不是表示类型和并发的常量 ResultSet
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法，或者该方法不支持指定的结果集类型和结果集并发。
        从以下版本开始：
        1.2

      • prepareCall

        CallableStatement prepareCall​(String sql,
                              int resultSetType,
                              int resultSetConcurrency)
                       throws SQLException
        创建一个CallableStatement对象，该对象将生成具有给定类型和并发性的ResultSet对象。 此方法与上述prepareCall方法相同，但允许覆盖默认的结果集类型和并发性。 创建的结果集的可保持性可以通过调用getHoldability()来确定。
        参数
        sql - 一个String对象，即要发送到数据库的SQL语句; 可能包含或多于'？' 参数
        resultSetType - 结果集类型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        resultSetConcurrency - 并发类型; ResultSet.CONCUR_READ_ONLY或ResultSet.CONCUR_UPDATABLE
        结果
        包含预编译的SQL语句的新的 CallableStatement对象将产生具有给定类型和并发的 ResultSet对象
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者给定参数不是表示类型和并发的常量 ResultSet
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法，或者该方法不支持指定的结果集类型和结果集并发。
        从以下版本开始：
        1.2

      • getTypeMap

        Map<String,Class<?>> getTypeMap​()
                         throws SQLException
        检索Map与此相关联的对象Connection对象。 除非应用程序已添加条目，否则返回的类型映射将为空。

        在对从getTypeMap返回的Map对象进行更改后，您必须调用setTypeMap ，因为JDBC驱动程序可能会创建传递给setTypeMap的Map对象的内部副本：

          Map<String,Class<?>> myMap = con.getTypeMap();
      myMap.put("mySchemaName.ATHLETES", Athletes.class);
      con.setTypeMap(myMap);
        结果
        与该 java.util.Map对象关联的 Connection对象
        异常
        SQLException - 如果发生数据库访问错误或在关闭的连接上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        setTypeMap(java.util.Map<java.lang.String, java.lang.Class<?>>)

      • setTypeMap

        void setTypeMap​(Map<String,Class<?>> map)
         throws SQLException
        将给定的TypeMap对象作为TypeMap对象的类型映射表Connection 。 类型映射将用于SQL结构化类型和不同类型的自定义映射。

        你必须设置的值TypeMap到callng前setMap为JDBC驱动程序可以创建的内部副本TypeMap ：

          Map myMap<String,Class<?>> = new HashMap<String,Class<?>>();
      myMap.put("mySchemaName.ATHLETES", Athletes.class);
      con.setTypeMap(myMap);
        参数
        map - 要安装的 java.util.Map对象作为此 Connection对象的默认类型映射的替代
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者给定参数不是 java.util.Map对象
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        getTypeMap()

      • setHoldability

        void setHoldability​(int holdability)
             throws SQLException
        将使用此Connection对象创建的对象的默认ResultSet更改为给定的可保存性。 ResultSet对象的默认可保持性可以通过调用DatabaseMetaData.getResultSetHoldability()来确定。
        参数
        holdability - 一个ResultSet保持常数; 一个ResultSet.HOLD_CURSORS_OVER_COMMIT或ResultSet.CLOSE_CURSORS_AT_COMMIT
        异常
        SQLException - 如果发生数据库访问，则在闭合连接上调用此方法，或者给定参数不是表示 ResultSet保持性的常量 ResultSet
        SQLFeatureNotSupportedException - 如果不支持给定的可保持性
        从以下版本开始：
        1.4
        另请参见：
        getHoldability() ， DatabaseMetaData.getResultSetHoldability() ， ResultSet

      • getHoldability

        int getHoldability​()
            throws SQLException
        检索使用此 Connection对象创建的 ResultSet对象的当前可 Connection 。
        结果
        ResultSet.HOLD_CURSORS_OVER_COMMIT ， ResultSet.HOLD_CURSORS_OVER_COMMIT或 ResultSet.CLOSE_CURSORS_AT_COMMIT
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法
        从以下版本开始：
        1.4
        另请参见：
        setHoldability(int) ， DatabaseMetaData.getResultSetHoldability() ， ResultSet

      • setSavepoint

        Savepoint setSavepoint​()
                throws SQLException
        在当前事务中创建一个未命名的保存点，并返回代表它的新的Savepoint对象。

        如果setSavepoint在活动事务之外被调用，那么将在这个新创建的保存点处启动一个事务。

        结果
        新的 Savepoint对象
        异常
        SQLException - 如果发生数据库访问错误，则在参与分布式事务时调用此方法，此方法在闭合连接上调用，或此 Connection对象当前处于自动提交模式
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        Savepoint

      • setSavepoint

        Savepoint setSavepoint​(String name)
                throws SQLException
        在当前事务中创建具有给定名称的保存点，并返回表示它的新的Savepoint对象。

        如果setSavepoint在活动事务之外被调用，那么将在这个新创建的保存点处启动一个事务。

        参数
        name - 一个 String其中包含保存点的名称
        结果
        新的 Savepoint对象
        异常
        SQLException -如果发生数据库访问错误，这种方法是在参与分布式事务，这种方法被称为关闭的连接上或本叫 Connection对象当前处于自动提交模式
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        Savepoint

      • rollback

        void rollback​(Savepoint savepoint)
       throws SQLException
        撤消在给定的Savepoint对象设置后进行的所有更改。

        只有当自动提交被禁用时，才应该使用此方法。

        参数
        savepoint - Savepoint对象回滚到
        异常
        SQLException - 如果发生数据库访问错误，则在参与分布式事务时调用此方法，此方法在闭合连接上被调用， Savepoint对象不再有效，或者此 Connection对象当前处于自动提交模式
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        Savepoint ， rollback()

      • releaseSavepoint

        void releaseSavepoint​(Savepoint savepoint)
               throws SQLException
        从当前事务中删除指定的Savepoint和后续的Savepoint对象。 对删除保存点的任何引用将导致抛出SQLException 。
        参数
        savepoint - 要删除的 Savepoint对象
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者给定的 Savepoint对象在当前事务中不是有效的保存点
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • createStatement

        Statement createStatement​(int resultSetType,
                          int resultSetConcurrency,
                          int resultSetHoldability)
                   throws SQLException
        创建一个Statement对象，该对象将生成具有给定类型，并发和ResultSet对象。 该方法与上述的createStatement方法相同，但允许覆盖默认的结果集类型，并发性和可容忍性。
        参数
        resultSetType -下列操作之一 ResultSet常量： ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或 ResultSet.TYPE_SCROLL_SENSITIVE
        resultSetConcurrency - 以下 ResultSet常量之一： ResultSet.CONCUR_READ_ONLY或 ResultSet.CONCUR_UPDATABLE
        resultSetHoldability - 以下 ResultSet常量之一： ResultSet.HOLD_CURSORS_OVER_COMMIT或 ResultSet.CLOSE_CURSORS_AT_COMMIT
        结果
        一个新的 Statement对象，将生成具有给定类型，并发和可 ResultSet对象
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者给定参数不是指示类型，并发性和可 ResultSet常量 ResultSet
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法，或者该方法不支持指定的结果集类型，则结果集可持续性和结果集并发。
        从以下版本开始：
        1.4
        另请参见：
        ResultSet

      • prepareStatement

        PreparedStatement prepareStatement​(String sql,
                                   int resultSetType,
                                   int resultSetConcurrency,
                                   int resultSetHoldability)
                            throws SQLException
        创建一个PreparedStatement对象，该对象将生成具有给定类型，并发和ResultSet对象。

        此方法与上述prepareStatement方法相同，但允许覆盖默认的结果集类型，并发性和可容纳性。

        参数
        sql - 一个String对象，即要发送到数据库的SQL语句; 可能包含一个或多个'？' IN参数
        resultSetType -下列操作之一 ResultSet常量： ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或 ResultSet.TYPE_SCROLL_SENSITIVE
        resultSetConcurrency - 以下 ResultSet常量之一： ResultSet.CONCUR_READ_ONLY或 ResultSet.CONCUR_UPDATABLE
        resultSetHoldability - 以下 ResultSet常量之一： ResultSet.HOLD_CURSORS_OVER_COMMIT或 ResultSet.CLOSE_CURSORS_AT_COMMIT
        结果
        一个新的 PreparedStatement对象，包含预编译的SQL语句，将生成具有给定类型，并发性和可 ResultSet对象
        异常
        SQLException - 如果发生数据库访问错误，此方法在闭合连接上调用，或者给定参数不是 ResultSet常量，指示类型，并发性和可容忍性
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法，或者该方法不支持指定的结果集类型，则结果集可持续性和结果集并发。
        从以下版本开始：
        1.4
        另请参见：
        ResultSet

      • prepareCall

        CallableStatement prepareCall​(String sql,
                              int resultSetType,
                              int resultSetConcurrency,
                              int resultSetHoldability)
                       throws SQLException
        创建一个CallableStatement对象，该对象将使用给定类型和并发性生成ResultSet对象。 此方法与上述prepareCall方法相同，但它允许默认结果集类型，结果集并发类型和可保持性被覆盖。
        参数
        sql - 一个String对象，即要发送到数据库的SQL语句; 可能包含或多于'？' 参数
        resultSetType -下列操作之一 ResultSet常量： ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或 ResultSet.TYPE_SCROLL_SENSITIVE
        resultSetConcurrency - 以下 ResultSet常数之一： ResultSet.CONCUR_READ_ONLY或 ResultSet.CONCUR_UPDATABLE
        resultSetHoldability - 以下 ResultSet常数之一： ResultSet.HOLD_CURSORS_OVER_COMMIT或 ResultSet.CLOSE_CURSORS_AT_COMMIT
        结果
        新 CallableStatement对象，包含预编译的SQL语句，将产生 ResultSet对象具有给定类型，并发性和可保存
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者给定参数不是表示类型，并发性和可 ResultSet常量 ResultSet
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法，或者该方法不支持指定的结果集类型，则结果集可持续性和结果集并发。
        从以下版本开始：
        1.4
        另请参见：
        ResultSet

      • prepareStatement

        PreparedStatement prepareStatement​(String sql,
                                   int autoGeneratedKeys)
                            throws SQLException
        创建一个默认的PreparedStatement对象，该对象具有检索自动生成的密钥的能力。 给定的常量告诉驱动程序是否应该使自动生成的密钥可用于检索。 如果SQL语句不是INSERT语句，或SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），则忽略此参数。

        注意：此方法针对从预编译中受益的参数化SQL语句进行了优化。 如果驱动程序支持预编译，方法prepareStatement将将该语句发送到数据库进行预编译。 有些驱动程序可能不支持预编译。 在这种情况下，在执行PreparedStatement对象之前，该语句可能不会发送到数据库。 这对用户没有直接影响; 然而，它确实影响了哪些方法抛出某些SQLExceptions。

        使用返回的PreparedStatement对象创建的结果集将默认为TYPE_FORWARD_ONLY ，并发级别为CONCUR_READ_ONLY 。 创建的结果集的可保持性可以通过调用getHoldability()来确定。

        参数
        sql - 可能包含一个或多个“？”的SQL语句 IN参数占位符
        autoGeneratedKeys - 表示是否应返回自动生成的键的标志; 一个Statement.RETURN_GENERATED_KEYS或Statement.NO_GENERATED_KEYS
        结果
        一个新的 PreparedStatement对象，包含预编译的SQL语句，将具有返回自动生成的键的功能
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法，或者给定参数不是 Statement常量，指示是否应返回自动生成的密钥
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法与常量Statement.RETURN_GENERATED_KEYS
        从以下版本开始：
        1.4

      • prepareStatement

        PreparedStatement prepareStatement​(String sql,
                                   int[] columnIndexes)
                            throws SQLException
        创建一个默认的PreparedStatement对象，能够返回给定数组指定的自动生成的键。 该数组包含目标表中包含应该可用的自动生成的键的列的索引。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该数组。

        具有或不具有IN参数的SQL语句可以预编译并存储在一个PreparedStatement对象中。 然后可以使用该对象多次有效地执行此语句。

        注意：此方法针对从预编译中受益的参数化SQL语句进行了优化。 如果驱动程序支持预编译，则方法prepareStatement将将该语句发送到数据库进行预编译。 有些驱动程序可能不支持预编译。 在这种情况下，在执行PreparedStatement对象之前，该语句可能不会发送到数据库。 这对用户没有直接影响; 然而，它确实影响了哪些方法抛出某些SQLExceptions。

        使用返回的PreparedStatement对象创建的结果集将默认为TYPE_FORWARD_ONLY ，并发级别为CONCUR_READ_ONLY 。 创建的结果集的可保持性可以通过调用getHoldability()来确定。

        参数
        sql - 可能包含一个或多个“？”的SQL语句 IN参数占位符
        columnIndexes - 列索引数组，指示应该从插入的行或行中返回的列
        结果
        一个新的 PreparedStatement对象，包含预编译语句，它能够返回由给定的列索引数组指定的自动生成的键
        异常
        SQLException - 如果发生数据库访问错误或在已关闭连接上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • prepareStatement

        PreparedStatement prepareStatement​(String sql,
                                   String[] columnNames)
                            throws SQLException
        创建一个默认的PreparedStatement对象，能够返回给定数组指定的自动生成的键。 该数组包含目标表中包含应该返回的自动生成的键的列的名称。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该数组。

        具有或不具有IN参数的SQL语句可以预编译并存储在一个PreparedStatement对象中。 然后可以使用该对象多次有效地执行此语句。

        注意：此方法针对从预编译中受益的参数化SQL语句进行了优化。 如果驱动程序支持预编译，则方法prepareStatement将将该语句发送到数据库进行预编译。 有些驱动程序可能不支持预编译。 在这种情况下，在执行PreparedStatement对象之前，该语句可能不会发送到数据库。 这对用户没有直接影响; 然而，它确实影响了哪些方法抛出某些SQLExceptions。

        使用返回的PreparedStatement对象创建的结果集将默认为TYPE_FORWARD_ONLY型，并发级别为CONCUR_READ_ONLY 。 创建的结果集的可保留性可以通过调用getHoldability()来确定。

        参数
        sql - 可能包含一个或多个“？”的SQL语句 IN参数占位符
        columnNames - 一列列名称，指示应该从插入的行或行中返回的列
        结果
        一个新的 PreparedStatement对象，包含预编译的语句，它能够返回由给定的列名数组指定的自动生成的键
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • createClob

        Clob createClob​()
         throws SQLException
        构造实现Clob接口的对象。 最初返回的对象不包含任何数据。 的setAsciiStream ， setCharacterStream和setString所述的方法Clob接口可用于将数据添加到所述Clob 。
        结果
        一个实现 Clob接口的对象
        异常
        SQLException - 如果无法构建实现 Clob接口的对象， Clob在闭合连接上调用此方法或发生数据库访问错误。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此数据类型
        从以下版本开始：
        1.6

      • createBlob

        Blob createBlob​()
         throws SQLException
        构造实现Blob接口的对象。 最初返回的对象不包含任何数据。 setBinaryStream和setBytes方法的Blob接口可用于向Blob添加数据。
        结果
        一个实现 Blob接口的对象
        异常
        SQLException - 如果无法构建实现 Blob接口的对象，则在闭合连接上调用此方法或发生数据库访问错误。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此数据类型
        从以下版本开始：
        1.6

      • createNClob

        NClob createNClob​()
           throws SQLException
        构造实现NClob接口的对象。 最初返回的对象不包含任何数据。 的setAsciiStream ， setCharacterStream和setString所述的方法NClob接口可用于将数据添加到所述NClob 。
        结果
        一个实现 NClob接口的对象
        异常
        SQLException - 如果无法构建实现 NClob接口的对象，则在闭合连接上调用此方法或发生数据库访问错误。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此数据类型
        从以下版本开始：
        1.6

      • createSQLXML

        SQLXML createSQLXML​()
             throws SQLException
        构造实现SQLXML接口的对象。 最初返回的对象不包含任何数据。 的createXmlStreamWriter对象和setString所述的方法SQLXML接口可用于将数据添加到所述SQLXML对象。
        结果
        一个实现 SQLXML接口的对象
        异常
        SQLException - 如果无法构建实现 SQLXML接口的对象，则在闭合连接上调用此方法或发生数据库访问错误。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此数据类型
        从以下版本开始：
        1.6

      • isValid

        boolean isValid​(int timeout)
         throws SQLException
        如果连接尚未关闭并且仍然有效，则返回true。 驱动程序应该提交关于连接的查询或者使用一些其他机制，当调用此方法时，肯定验证连接仍然有效。

        驱动程序提交的验证连接的查询应在当前事务的上下文中执行。

        参数
        timeout - - 等待数据库操作用于验证连接完成的时间（秒）。 如果超时时间在操作完成之前到期，则此方法返回false。 值为0表示超时未应用于数据库操作。
        结果
        如果连接有效，则为true，否则为false
        异常
        SQLException - 如果为 timeout提供的值小于0
        从以下版本开始：
        1.6
        另请参见：
        DatabaseMetaData.getClientInfoProperties()

      • setClientInfo

        void setClientInfo​(String name,
                   String value)
            throws SQLClientInfoException
        将由name指定的客户端信息属性的值设置为由值指定的值。

        应用程序可以使用DatabaseMetaData.getClientInfoProperties方法来确定驱动程序支持的客户端信息属性以及可能为每个属性指定的最大长度。

        驱动程序将指定的值存储在数据库中的合适位置。 例如在特殊寄存器，会话参数或系统表列中。 为了提高效率，驱动程序可能推迟在数据库中设置值，直到下一次执行或准备语句。 除了将客户端信息存储在数据库中的适当位置之外，这些方法不得改变连接的行为。 提供给这些方法的值仅用于记帐，诊断和调试目的。

        如果指定的客户端信息名称不被驱动程序识别，驱动程序将产生警告。

        如果为此方法指定的值大于该属性的最大长度，则驱动程序可能会截断该值并生成警告或生成一个SQLClientInfoException 。 如果驱动程序生成SQLClientInfoException ，则指定的值未在连接上设置。

        以下是标准的客户端信息属性。 驱动程序不需要支持这些属性，但是如果驱动程序支持可以由其中一个标准属性描述的客户端信息属性，则应使用标准属性名称。

        • ApplicationName - 当前正在使用连接的应用程序的名称
        • ClientUser - 使用连接的应用程序正在执行的用户的名称。 这可能与建立连接时使用的用户名不同。
        • ClientHostname - 使用连接的应用程序正在运行的计算机的主机名。
        参数
        name - 要设置的客户端信息属性的名称
        value - 将客户端信息属性设置为的值。 如果值为null，则指定属性的当前值将被清除。
        异常
        SQLClientInfoException - 如果数据库服务器在设置数据库服务器上的客户端信息值时返回错误，或者在闭合连接上调用此方法
        从以下版本开始：
        1.6

      • setClientInfo

        void setClientInfo​(Properties properties)
            throws SQLClientInfoException
        设置连接的客户端信息属性的值。 Properties对象包含要设置的客户端信息属性的名称和值。 属性列表中包含的客户端信息属性集将替换当前连接上的客户端信息属性集。 如果连接上当前设置的属性不存在于属性列表中，则该属性将被清除。 指定空属性列表将清除连接上的所有属性。 有关详细信息，请参阅setClientInfo (String, String) 。

        如果在设置任何客户端信息属性时发生错误，则抛出SQLClientInfoException 。 SQLClientInfoException包含指示哪些客户端信息属性未设置的信息。 客户端信息的状态是未知的，因为某些数据库不允许以原子方式设置多个客户端信息属性。 对于这些数据库，可能在错误发生之前设置了一个或多个属性。

        参数
        properties - 要设置的客户端信息属性的列表
        异常
        SQLClientInfoException - 如果数据库服务器在数据库服务器上设置clientInfo值时返回错误，或者在闭合连接上调用此方法
        从以下版本开始：
        1.6
        另请参见：
        setClientInfo(String, String)

      • getClientInfo

        String getClientInfo​(String name)
              throws SQLException
        返回由name指定的客户端信息属性的值。 如果指定的客户端信息属性尚未设置且没有默认值，则此方法可能返回null。 如果驱动程序不支持指定的客户端信息属性名称，此方法也将返回null。

        应用程序可以使用DatabaseMetaData.getClientInfoProperties方法来确定驱动程序支持的客户端信息属性。

        参数
        name - 要检索的客户端信息属性的名称
        结果
        指定的客户端信息属性的值
        异常
        SQLException - 如果数据库服务器在从数据库获取客户机信息值时返回错误，或者在闭合连接上调用此方法
        从以下版本开始：
        1.6
        另请参见：
        DatabaseMetaData.getClientInfoProperties()

      • getClientInfo

        Properties getClientInfo​()
                  throws SQLException
        返回包含驱动程序支持的每个客户端信息属性的名称和当前值的列表。 如果属性未设置且没有默认值，则客户端信息属性的值可能为null。
        结果
        一个 Properties对象，其中包含驱动程序支持的每个客户端信息属性的名称和当前值。
        异常
        SQLException - 如果数据库服务器在从数据库中获取客户端信息值时返回错误，或者在闭合连接上调用此方法
        从以下版本开始：
        1.6

      • createArrayOf

        Array createArrayOf​(String typeName,
                    Object[] elements)
             throws SQLException
        用于创建Array对象的Factory方法。

        注意：当使用createArrayOf创建映射到原始数据类型的数组对象时，实现定义Array对象是否是该基元数据类型的数组或Object的数组。

        注意： JDBC驱动程序负责将元素Object数组映射到给定类别为Object java.sql.Types中定义的默认JDBC SQL类型。 默认映射在JDBC规范的附录B中指定。 如果生成的JDBC类型不是给定typeName的适当类型，那么它将被实现定义是抛出一个SQLException还是驱动程序支持所得到的转换。

        参数
        typeName - 数组的元素的类型的SQL名称映射到。 typeName是一个特定于数据库的名称，可能是该数据库支持的内置类型，用户定义类型或标准SQL类型的名称。 这是Array.getBaseTypeName返回的值
        elements - 填充返回对象的元素
        结果
        一个Array对象，其元素映射到指定的SQL类型
        异常
        SQLException - 如果发生数据库错误，则JDBC类型不适用于typeName，并且不支持转换，typeName为null或在闭合连接上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此数据类型
        从以下版本开始：
        1.6

      • createStruct

        Struct createStruct​(String typeName,
                    Object[] attributes)
             throws SQLException
        用于创建Struct对象的工厂方法。
        参数
        typeName - 此Struct对象映射到的SQL结构化类型的SQL类型名称。 typeName是为此数据库定义的用户定义类型的名称。 这是Struct.getSQLTypeName返回的值。
        attributes - 填充返回对象的属性
        结果
        一个映射到给定SQL类型并使用给定属性填充的Struct对象
        异常
        SQLException - 如果发生数据库错误，typeName为空，或者在闭合连接上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此数据类型
        从以下版本开始：
        1.6

      • setSchema

        void setSchema​(String schema)
        throws SQLException
        设置要访问的给定模式名称。

        如果驱动程序不支持模式，它将默认忽略此请求。

        调用setSchema对以前创建或准备的Statement对象没有影响。 当Connection方法prepareStatement或prepareCall被调用时，定义是否立即执行DBMS准备操作。 为了获得最大的可移植性， setSchema应该在之前被称为Statement创建或准备。

        参数
        schema - 要工作的模式的名称
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法
        从以下版本开始：
        1.7
        另请参见：
        getSchema()

      • getSchema

        String getSchema​()
          throws SQLException
        检索此 Connection对象的当前模式名称。
        结果
        当前的模式名称或 null如果没有
        异常
        SQLException - 如果发生数据库访问错误或在闭合连接上调用此方法
        从以下版本开始：
        1.7
        另请参见：
        setSchema(java.lang.String)

      • abort

        void abort​(Executor executor)
    throws SQLException
        终止打开的连接。 致电abort导致：
        • 连接标记为关闭
        • 关闭与数据库的任何物理连接
        • 释放连接使用的资源
        • 确保当前正在访问连接的任何线程将进行完成或抛出一个SQLException 。

        调用abort标记连接已关闭并释放任何资源。 关闭连接时调用abort是无操作的。

        可能的是，连接所持有的资源的中止和释放可能需要较长的时间。 当abort方法返回时，连接将被标记为已关闭，作为中止参数传递的Executor可能仍在执行任务以释放资源。

        该方法检查在允许该方法继续之前有一个SQLPermission对象。 如果一个SecurityManager存在，其checkPermission方法拒绝调用abort ，此方法将抛出一个java.lang.SecurityException 。

        参数
        executor - Executor使用的 abort 。
        异常
        SQLException - 如果发生数据库访问错误或 executor是 null ，
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法拒绝调用 abort
        从以下版本开始：
        1.7
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， Executor

      • setNetworkTimeout

        void setNetworkTimeout​(Executor executor,
                       int milliseconds)
                throws SQLException
        设置Connection的最大周期或从Connection创建的Connection将等待数据库回复任何一个请求。 如果任何请求仍未得到答复，等待方法将返回SQLException ，而Connection或从Connection创建的Connection将被标记为关闭。 任何后续使用的对象，随着外close ， isClosed或者Connection.isValid方法，将导致SQLException 。

        注意 ：此方法旨在解决一个罕见但严重的情况，其中网络分区可能导致线程发出JDBC调用在套接字读取中不间断挂起，直到OS TCP-TIMEOUT（通常为10分钟）。 该方法与abort() 方法有关，该方法为管理员线程提供一种在管理员线程可访问JDBC连接的情况下释放任何此类线程的方法。 setNetworkTimeout方法将覆盖没有管理员线程的情况，或者无法访问连接。 这种方法在效果上是严重的，应该给出足够高的值，所以在任何更正常的超时之前，如事务超时，它永远不会被触发。

        JDBC驱动程序实现也可以在不存在网络的环境中选择支持setNetworkTimeout方法对数据库响应时间施加限制。

        驱动程序可以通过多个内部驱动程序 - 数据库传输来内部实现其部分或全部API调用，并由驱动程序实现确定是否将始终对API调用的响应进行限制，也可以应用于任何单个请求在API调用期间。

        可以多次调用此方法，例如为JDBC代码区域设置限制，并在此区域退出时重置为默认值。 调用此方法对已有未完成的请求没有影响。

        Statement.setQueryTimeout()超时值与setNetworkTimeout指定的超时值setNetworkTimeout 。 如果查询超时在网络超时之前超时，则语句执行将被取消。 如果网络仍然处于活动状态，则结果将是语句和连接都可以使用。 但是，如果网络超时在查询超时之前超时或由于网络问题而导致语句超时失败，则连接将被标记为已关闭，连接所持有的任何资源将被释放，并且连接和语句都将不可用。

        当驱动程序确定setNetworkTimeout超时值已过期时，JDBC驱动程序将连接关闭，并释放连接所持有的任何资源。

        在允许该方法继续之前，此方法将检查是否有一个SQLPermission对象。 如果一个SecurityManager存在，其checkPermission方法拒绝调用setNetworkTimeout ，则此方法将抛出一个java.lang.SecurityException 。

        参数
        executor - Executor使用的 setNetworkTimeout 。
        milliseconds - 等待数据库操作完成的时间（以毫秒为单位）。 如果JDBC驱动程序不支持毫秒数，则JDBC驱动程序会将值舍入到最接近的秒。 如果在操作完成之前超时时间到期，将抛出一个SQLException。 值为0表示数据库操作没有超时。
        异常
        SQLException - 如果发生数据库访问错误，则在闭合连接上调用此方法， executor为 null ，或为 seconds指定的值小于0。
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法拒绝调用 setNetworkTimeout 。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.7
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， Statement.setQueryTimeout(int) ， getNetworkTimeout() ， abort(java.util.concurrent.Executor) ， Executor

      • getNetworkTimeout

        int getNetworkTimeout​()
               throws SQLException
        检索驱动程序等待数据库请求完成的毫秒数。 如果超出限制，则抛出SQLException 。
        结果
        当前超时限制（以毫秒为单位） 零意味着没有限制
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Connection调用此方法 Connection
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.7
        另请参见：
        setNetworkTimeout(java.util.concurrent.Executor, int)

      • beginRequest

        default void beginRequest​()
                   throws SQLException
        向司机提示，一个请求，一个独立的工作单位，正在开始这个连接。 每个请求与客户端或服务器上连接的本地状态相关的所有其他请求都是独立的。 工作之间做beginRequest ， endRequest对不会依赖于连接上进行任何其他工作，如任何要求的其他请求或外部的一部分。 请求可以包括多个事务。 可能依赖于已提交的数据库状态，因为它不是本地连接。

        本地状态被定义为与客户端或数据库中不可透明再现的当前连接本地连接的任何状态。

        致电beginRequest和endRequest未嵌套。 对beginRequest多次呼叫，无endRequest呼叫endRequest不是错误。 第一个beginRequest调用标记为请求的开始，后续调用被视为无操作

        使用beginRequest和endRequest是可选的，供应商特定的，并且应该在很大程度上是透明的。 特别地，实现可以检测指示对诸如开放事务之类的其他工作的依赖的条件。 建议尽管不需要，如果有一个活动的事务和beginRequest被调用，这个实现会抛出一个SQLException 。 使用这些方法可以提高性能或提供其他好处。 有关其他信息，请咨询供应商文档。

        建议在beginRequest对中包含每个工作单元， endRequest在请求的开始或结束时没有打开的事务，并且不依赖跨越请求边界的本地状态。 提交的数据库状态不是本地的。

        API Note:
        Connection方法由Connection pooling管理器使用。

        在返回到呼叫者的连接之前，池管理器应该在基础连接上调用beginRequest 。

        池管理器不需要调用beginRequest如果：

        • 连接池缓存PooledConnection对象
        • 当应用程序调用getConnection时，返回逻辑连接句柄
        • 逻辑Connection通过调用关闭Connection.close久违的前PooledConnection到缓存。
        实现要求：
        默认的实现是无操作的。

        异常
        SQLException - 如果发生错误
        从以下版本开始：
        9
        另请参见：
        endRequest() ， PooledConnection

      • endRequest

        default void endRequest​()
                 throws SQLException
        向司机提示，要求，独立工作单位已经完成。 拨打beginRequest和endRequest都不嵌套。 对endRequest多次呼叫，无需beginRequest呼叫beginRequest不是错误。 第一个endRequest调用标记请求完成，后续调用被视为无操作。 如果endRequest被调用，而不是初始调用beginRequest是一个no-op。

        该方法的具体行为是供应商特定的。 特别地，实现可以检测指示对诸如开放事务之类的其他工作的依赖的条件。 建议尽管不需要，如果有一个活动的事务和endRequest被调用，这个实现会抛出一个SQLException 。

        API Note:
        Connection方法由Connection pooling管理器使用。

        当应用程序将连接返回到连接池时，池管理器应调用底层连接上的endRequest 。

        如果以下情况，池管理器不需要调用endRequest ：

        • 连接池缓存PooledConnection对象
        • 当应用程序调用getConnection时返回逻辑连接句柄
        • 逻辑Connection通过调用关闭Connection.close久违的前PooledConnection到缓存。
        实现要求：
        默认的实现是无操作的。
        异常
        SQLException - 如果发生错误
        从以下版本开始：
        9
        另请参见：
        beginRequest() ， PooledConnection

      • setShardingKeyIfValid

        default boolean setShardingKeyIfValid​(ShardingKey shardingKey,
                                      ShardingKey superShardingKey,
                                      int timeout)
                               throws SQLException
        设置并验证此连接的分片密钥。 可以为分片键指定null值。 null分片密钥的有效性是供应商特定的。 有关其他信息，请咨询供应商的文档。
        API Note:
        此方法验证分片键是否适用于Connection 。 超时值指示Connection在setShardingKeyIfValid返回false之前等待Connection验证分片密钥有效的时间。
        实现要求：
        默认实现将抛出一个 SQLFeatureNotSupportedException 。
        参数
        shardingKey - 要对此连接进行验证的分片密钥。 分片键可能是null
        superShardingKey - 要对此连接进行验证的超级分片密钥。 超级分片键可以是null 。
        timeout - 预计在完成验证过程之前的几秒钟内的时间，否则验证过程将中止。 值为0表示验证过程不会超时。
        结果
        如果连接有效并且分片键在此连接上有效并设置，则为true; 如果分片键无效或超时期限在操作完成之前到期，则为false。
        异常
        SQLException - 执行此验证时是否发生错误;
一个superSharedingKey指定没有一个shardingKey ;
这个方法叫做一个封闭的connection ;
或timeout值为负数。
        SQLFeatureNotSupportedException - 如果驱动程序不支持分片
        从以下版本开始：
        9
        另请参见：
        ShardingKey ， ShardingKeyBuilder

      • setShardingKeyIfValid

        default boolean setShardingKeyIfValid​(ShardingKey shardingKey,
                                      int timeout)
                               throws SQLException
        设置并验证此连接的分片密钥。 可以为分片键指定null值。 null分片密钥的有效性是供应商特定的。 有关其他信息，请咨询供应商的文档。
        API Note:
        此方法验证分片密钥对Connection有效。 超时值指示在setShardingKeyIfValid返回false之前，驱动程序应等待Connection验证分片密钥有效的时间。
        实现要求：
        默认实现将抛出一个 SQLFeatureNotSupportedException 。
        参数
        shardingKey - 要对此连接进行验证的分片密钥。 分片键可以是null
        timeout - 预计在完成验证过程之前的几秒钟内，否则验证过程将中止。 值为0表示验证过程不会超时。
        结果
        如果连接有效并且分片键在此连接上有效，则为true; 如果分片密钥无效或超时期限在操作完成之前到期，则为false。
        异常
        SQLException - 执行此验证时是否有错误; 这个方法是在关闭的connection调用的connection ; 或timeout值为负数。
        SQLFeatureNotSupportedException - 如果驱动程序不支持分片
        从以下版本开始：
        9
        另请参见：
        ShardingKey ， ShardingKeyBuilder

      • setShardingKey

        default void setShardingKey​(ShardingKey shardingKey,
                            ShardingKey superShardingKey)
                     throws SQLException
        指定与此连接一起使用的shardingKey和superShardingKey
        API Note:
        此方法设置指定的分片键，但不需要往返数据库，以验证分片键是否适用于 Connection 。
        实现要求：
        默认实现将抛出一个 SQLFeatureNotSupportedException 。
        参数
        shardingKey - 在此连接上设置的分片密钥。 分片键可以是null
        superShardingKey - 在此连接上设置的超级分片密钥。 超级分片键可以是null
        异常
        SQLException - 如果设置分片键出现错误; 这个方法被调用在一个封闭的connection ; 或superSharedingKey而不指定shardingKey
        SQLFeatureNotSupportedException - 如果驱动程序不支持分片
        从以下版本开始：
        9
        另请参见：
        ShardingKey ， ShardingKeyBuilder

      • setShardingKey

        default void setShardingKey​(ShardingKey shardingKey)
                     throws SQLException
        指定与此Connection一起使用的shardingKey
        API Note:
        此方法设置指定的分片密钥，但不需要往返数据库，以验证分片密钥对 Connection有效。
        实现要求：
        默认实现将抛出一个 SQLFeatureNotSupportedException 。
        参数
        shardingKey - 在此连接上设置的分片密钥。 分片键可以是null
        异常
        SQLException - 如果发生错误设置分片键; 或者这个方法在关闭的connection
        SQLFeatureNotSupportedException - 如果驱动程序不支持分片
        从以下版本开始：
        9
        另请参见：
        ShardingKey, ShardingKeyBuilder
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ConnectionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface ConnectionBuilder

  • public interface ConnectionBuilder
    从DataSource对象创建的构建器，用于建立与data source对象所表示的数据库的连接。 用于中指定的连接属性data source被用作由所述默认值ConnectionBuilder 。

    以下示例说明如何使用ConnectionBuilder创建Connection ：

       DataSource ds = new MyDataSource(); ShardingKey superShardingKey = ds.createShardingKeyBuilder() .subkey("EASTERN_REGION", JDBCType.VARCHAR) .build(); ShardingKey shardingKey = ds.createShardingKeyBuilder() .subkey("PITTSBURGH_BRANCH", JDBCType.VARCHAR) .build(); Connection con = ds.createConnectionBuilder() .user("rafa") .password("tennis") .setShardingKey(shardingKey) .setSuperShardingKey(superShardingKey) .build();
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Connection build​()
      返回由此构建器定义的对象的实例。
      ConnectionBuilder password​(String password)
      指定创建连接时要使用的密码
      ConnectionBuilder shardingKey​(ShardingKey shardingKey)
      指定在创建连接时使用的 shardingKey
      ConnectionBuilder superShardingKey​(ShardingKey superShardingKey)
      指定在创建连接时使用的 superShardingKey
      ConnectionBuilder user​(String username)
      指定创建连接时要使用的用户名

    • 方法详细信息

      • user

        ConnectionBuilder user​(String username)
        指定创建连接时要使用的用户名
        参数
        username - 代表连接的数据库用户
        结果
        相同的 ConnectionBuilder实例

      • password

        ConnectionBuilder password​(String password)
        指定创建连接时要使用的密码
        参数
        password - 用于此连接的密码。 可能是null
        结果
        相同的 ConnectionBuilder实例

      • shardingKey

        ConnectionBuilder shardingKey​(ShardingKey shardingKey)
        指定创建连接时要使用的 shardingKey
        参数
        shardingKey - ShardingKey。 可能是null
        结果
        相同的 ConnectionBuilder实例
        另请参见：
        ShardingKey ， ShardingKeyBuilder

      • superShardingKey

        ConnectionBuilder superShardingKey​(ShardingKey superShardingKey)
        指定创建连接时要使用的 superShardingKey
        参数
        superShardingKey - SuperShardingKey。 可能是null
        结果
        相同的 ConnectionBuilder实例
        另请参见：
        ShardingKey ， ShardingKeyBuilder

      • build

        Connection build​()
          throws SQLException
        返回由此构建器定义的对象的实例。
        结果
        内置对象
        异常
        SQLException - 如果构建对象发生错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DatabaseMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface DatabaseMetaData

  • All Superinterfaces:
    Wrapper

    public interface DatabaseMetaData
extends Wrapper
    关于整个数据库的综合信息。

    此接口由驱动程序供应商实现，以便用户根据与其一起使用的JDBC技术（“JDBC驱动程序”）结合驱动程序知道数据库管理系统（DBMS）的功能。 不同的关系DBMS通常支持不同的功能，以不同的方式实现功能，并使用不同的数据类型。 此外，驱动程序可以在DBMS提供的功能之上实现一个功能。 此界面中方法返回的信息适用于特定驱动程序和特定DBMS协同工作的功能。 请注意，如本文档所使用的，术语“数据库”通常用于指代驱动程序和DBMS。

    此接口的用户通常是需要发现如何处理基础DBMS的工具。 对于旨在与多个DBMS一起使用的应用程序尤其如此。 例如，一个工具可能会使用方法getTypeInfo来查找可以在CREATE TABLE语句中使用哪些数据类型。 或者用户可能会调用方法supportsCorrelatedSubqueries查看是否可以使用相关的子查询或supportsBatchUpdates查看是否可以使用批量更新。

    一些DatabaseMetaData方法以ResultSet对象的形式返回信息列表。 常规的ResultSet方法，如getString和getInt ，可用于从这些ResultSet对象中检索数据。 如果一个给定的元数据形式不可用，将返回一个空的ResultSet 。 由给定方法的ResultSet对象定义的列之外的其他列可以由JDBC驱动程序供应商定义，并且必须由其列标签访问。

    一些DatabaseMetaData方法使用String模式的参数。 这些参数都有名称，如fooPattern。 在模式字符串中，“％”表示匹配0个或更多字符的任何子字符串，“_”表示匹配任何一个字符。 只返回与搜索模式匹配的元数据条目。 如果搜索模式参数设置为null ，则该参数的标准将从搜索中删除。

    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static short attributeNoNulls
      表示可能不允许 NULL值。
      static short attributeNullable
      表示绝对允许 NULL值。
      static short attributeNullableUnknown
      表示是否允许 NULL值是未知的。
      static int bestRowNotPseudo
      表示最佳行标识符不是伪列。
      static int bestRowPseudo
      表示最佳行标识符是伪列。
      static int bestRowSession
      表示最佳行标识符的范围是当前会话的剩余部分。
      static int bestRowTemporary
      表示最佳行标识符的范围是非常临时的，只在该行被使用时持久。
      static int bestRowTransaction
      表示最佳行标识符的范围是当前事务的剩余部分。
      static int bestRowUnknown
      表示最佳行标识符可能是伪列，也可能不是伪列。
      static int columnNoNulls
      表示该列可能不允许 NULL值。
      static int columnNullable
      表示该列绝对允许 NULL值。
      static int columnNullableUnknown
      表示列的无效性是未知的。
      static int functionColumnIn
      表示参数或列是IN参数。
      static int functionColumnInOut
      表示参数或列是INOUT参数。
      static int functionColumnOut
      表示参数或列是OUT参数。
      static int functionColumnResult
      表示参数或列是结果集中的列。
      static int functionColumnUnknown
      表示参数或列的类型未知。
      static int functionNoNulls
      表示不允许 NULL值。
      static int functionNoTable
      表示该函数不返回表。
      static int functionNullable
      表示允许 NULL值。
      static int functionNullableUnknown
      表示是否允许 NULL值是未知的。
      static int functionResultUnknown
      表示不知道函数是返回结果还是表。
      static int functionReturn
      表示参数或列是返回值。
      static int functionReturnsTable
      表示该函数返回一个表。
      static int importedKeyCascade
      对于列 UPDATE_RULE ，表示当主键更新时，外键（导入的键）被更改以与其一致。
      static int importedKeyInitiallyDeferred
      表示延迟。
      static int importedKeyInitiallyImmediate
      表示延迟。
      static int importedKeyNoAction
      对于列 UPDATE_RULE和 DELETE_RULE ，表示如果主键已导入，则不能更新或删除。
      static int importedKeyNotDeferrable
      表示延迟。
      static int importedKeyRestrict
      对于列 UPDATE_RULE ，指示如果主键已被另一个表作为外键导入，则可能不更新主键。
      static int importedKeySetDefault
      对于列 UPDATE_RULE和 DELETE_RULE ，表示如果主键被更新或删除，则外键（导入的键）被设置为默认值。
      static int importedKeySetNull
      对于列 UPDATE_RULE和 DELETE_RULE ，表示当主键被更新或删除时，外键（导入的键）被改变为 NULL 。
      static int procedureColumnIn
      表示列存储IN参数。
      static int procedureColumnInOut
      表示列存储INOUT参数。
      static int procedureColumnOut
      表示列存储OUT参数。
      static int procedureColumnResult
      表示列存储结果。
      static int procedureColumnReturn
      表示列存储返回值。
      static int procedureColumnUnknown
      表示列的类型未知。
      static int procedureNoNulls
      表示不允许 NULL值。
      static int procedureNoResult
      表示该过程不返回结果。
      static int procedureNullable
      表示允许 NULL值。
      static int procedureNullableUnknown
      表示是否允许 NULL值是未知数。
      static int procedureResultUnknown
      表示不知道过程是否返回结果。
      static int procedureReturnsResult
      表示该过程返回结果。
      static int sqlStateSQL
      用于指示方法 DatabaseMetaData.getSQLStateType返回的值是否为SQLSTATE值的方法 SQLException.getSQLState的可能返回值。
      static int sqlStateSQL99
      该方法一个可能的返回值 DatabaseMetaData.getSQLStateType这是用来指示由方法返回的值是否 SQLException.getSQLState是一个SQL99 SQLSTATE值。
      static int sqlStateXOpen
      该方法一个可能的返回值 DatabaseMetaData.getSQLStateType这是用来指示由方法返回的值是否 SQLException.getSQLState是X /打开（现在知道的公开组）SQL CLI SQLSTATE值。
      static short tableIndexClustered
      表示此表索引是聚簇索引。
      static short tableIndexHashed
      表示此索引是散列索引。
      static short tableIndexOther
      表示此表索引不是聚簇索引，散列索引或表统计信息; 这是其他的东西。
      static short tableIndexStatistic
      表示此列包含与表的索引描述一起返回的表统计信息。
      static int typeNoNulls
      表示此数据类型不允许使用 NULL值。
      static int typeNullable
      表示允许此数据类型的值为 NULL 。
      static int typeNullableUnknown
      表示不知道该数据类型是否允许 NULL值。
      static int typePredBasic
      表示数据类型只能在不使用 LIKE谓词的 WHERE搜索条款中使用。
      static int typePredChar
      表示数据类型只能在 WHERE使用 LIKE谓词的搜索条款中使用。
      static int typePredNone
      表示此类型不支持 WHERE搜索子句。
      static int typeSearchable
      表示所有 WHERE搜索子句都可以基于此类型。
      static int versionColumnNotPseudo
      表示此版本列不是伪列。
      static int versionColumnPseudo
      表示此版本列是伪列。
      static int versionColumnUnknown
      表示此版本列可能是也可能不是伪列。

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean allProceduresAreCallable​()
      检索当前用户是否可以调用方法返回的所有过程 getProcedures 。
      boolean allTablesAreSelectable​()
      检索当前用户是否可以使用 SELECT语句中方法 getTables返回的所有表。
      boolean autoCommitFailureClosesAllResultSets​()
      检索autoCommit中是否为 SQLException是否为 true表示所有打开的ResultSet都被关闭，即使是可保留的。
      boolean dataDefinitionCausesTransactionCommit​()
      检索事务中的数据定义语句是否强制事务提交。
      boolean dataDefinitionIgnoredInTransactions​()
      检索此数据库是否忽略事务中的数据定义语句。
      boolean deletesAreDetected​(int type)
      检索是否可以通过调用方法 ResultSet.rowDeleted检测到可见行删除。
      boolean doesMaxRowSizeIncludeBlobs​()
      检索方法 getMaxRowSize的返回值是否包含SQL数据类型 LONGVARCHAR和 LONGVARBINARY 。
      boolean generatedKeyAlwaysReturned​()
      检索如果为自动生成的密钥列指定的列名称或索引有效并且语句成功，将始终返回生成的密钥。
      ResultSet getAttributes​(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern)
      检索给定模式和目录中可用的用户定义类型（UDT）给定类型的给定属性的描述。
      ResultSet getBestRowIdentifier​(String catalog, String schema, String table, int scope, boolean nullable)
      检索表的唯一标识行的最佳列集描述。
      ResultSet getCatalogs​()
      检索此数据库中可用的目录名称。
      String getCatalogSeparator​()
      检索此数据库用作目录和表名之间的分隔符的 String 。
      String getCatalogTerm​()
      检索“目录”的数据库供应商的首选项。
      ResultSet getClientInfoProperties​()
      检索驱动程序支持的客户端信息属性的列表。
      ResultSet getColumnPrivileges​(String catalog, String schema, String table, String columnNamePattern)
      检索表的列的访问权限的描述。
      ResultSet getColumns​(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
      检索指定目录中可用的表列的描述。
      Connection getConnection​()
      检索生成此元数据对象的连接。
      ResultSet getCrossReference​(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable)
      检索引用主键的给定外键表中的外键列的描述，或表示父表的唯一约束的列（可以是相同或不同的表）。
      int getDatabaseMajorVersion​()
      检索底层数据库的主版本号。
      int getDatabaseMinorVersion​()
      检索底层数据库的次要版本号。
      String getDatabaseProductName​()
      检索此数据库产品的名称。
      String getDatabaseProductVersion​()
      检索此数据库产品的版本号。
      int getDefaultTransactionIsolation​()
      检索此数据库的默认事务隔离级别。
      int getDriverMajorVersion​()
      检索此JDBC驱动程序的主要版本号。
      int getDriverMinorVersion​()
      检索此JDBC驱动程序的次要版本号。
      String getDriverName​()
      检索此JDBC驱动程序的名称。
      String getDriverVersion​()
      以 String检索此JDBC驱动程序的版本号。
      ResultSet getExportedKeys​(String catalog, String schema, String table)
      检索引用给定表的主键列（由表导出的外键）的外键列的描述。
      String getExtraNameCharacters​()
      检索可用于未引号的标识符名称（超出az，AZ，0-9和_）的所有“额外”字符。
      ResultSet getFunctionColumns​(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern)
      检索给定目录的系统或用户功能参数和返回类型的描述。
      ResultSet getFunctions​(String catalog, String schemaPattern, String functionNamePattern)
      检索给定目录中可用的系统和用户功能的描述。
      String getIdentifierQuoteString​()
      检索用于引用SQL标识符的字符串。
      ResultSet getImportedKeys​(String catalog, String schema, String table)
      检索给定表的外键列（由表导入的主键）引用的主键列的描述。
      ResultSet getIndexInfo​(String catalog, String schema, String table, boolean unique, boolean approximate)
      检索给定表的索引和统计信息的描述。
      int getJDBCMajorVersion​()
      检索此驱动程序的主要JDBC版本号。
      int getJDBCMinorVersion​()
      检索此驱动程序的次要JDBC版本号。
      int getMaxBinaryLiteralLength​()
      检索数据库允许的内联二进制文字的最大十六进制数。
      int getMaxCatalogNameLength​()
      检索此数据库在目录名称中允许的最大字符数。
      int getMaxCharLiteralLength​()
      检索此数据库允许使用字符文字的最大字符数。
      int getMaxColumnNameLength​()
      检索此数据库允许列名称的最大字符数。
      int getMaxColumnsInGroupBy​()
      检索 GROUP BY子句中数据库允许的最大列数。
      int getMaxColumnsInIndex​()
      检索数据库在索引中允许的最大列数。
      int getMaxColumnsInOrderBy​()
      检索 ORDER BY子句中数据库允许的最大列数。
      int getMaxColumnsInSelect​()
      检索 SELECT列表中数据库允许的最大列数。
      int getMaxColumnsInTable​()
      检索数据库在表中允许的最大列数。
      int getMaxConnections​()
      检索可能的此数据库的最大并发连接数。
      int getMaxCursorNameLength​()
      检索该数据库在游标名称中允许的最大字符数。
      int getMaxIndexLength​()
      检索数据库允许索引的最大字节数，包括索引的所有部分。
      default long getMaxLogicalLobSize​()
      检索此数据库允许 LOB逻辑大小的最大字节数。
      int getMaxProcedureNameLength​()
      检索此数据库在过程名称中允许的最大字符数。
      int getMaxRowSize​()
      检索数据库在单行中允许的最大字节数。
      int getMaxSchemaNameLength​()
      检索此数据库在模式名称中允许的最大字符数。
      int getMaxStatementLength​()
      检索数据库在SQL语句中允许的最大字符数。
      int getMaxStatements​()
      检索可以同时打开的此数据库的活动语句的最大数量。
      int getMaxTableNameLength​()
      检索数据库在表名中允许的最大字符数。
      int getMaxTablesInSelect​()
      检索 SELECT语句中数据库允许的最大表数。
      int getMaxUserNameLength​()
      检索数据库在用户名中允许的最大字符数。
      String getNumericFunctions​()
      检索此数据库可用的逗号分隔的数学函数列表。
      ResultSet getPrimaryKeys​(String catalog, String schema, String table)
      检索给定表的主键列的描述。
      ResultSet getProcedureColumns​(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern)
      检索给定目录的存储过程参数和结果列的描述。
      ResultSet getProcedures​(String catalog, String schemaPattern, String procedureNamePattern)
      200的X- 200 200 X- 200 200 X- 200 200：
      String getProcedureTerm​()
      检索“程序”的数据库供应商的首选项。
      ResultSet getPseudoColumns​(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
      检索指定目录和模式中给定表中可用的伪列或隐藏列的描述。
      int getResultSetHoldability​()
      检索此数据库对于 ResultSet对象的默认保持 ResultSet 。
      RowIdLifetime getRowIdLifetime​()
      指示此数据源是否支持SQL ROWID类型，以及RowId对象保持有效的生命周期。
      ResultSet getSchemas​()
      检索此数据库中可用的模式名称。
      ResultSet getSchemas​(String catalog, String schemaPattern)
      检索此数据库中可用的模式名称。
      String getSchemaTerm​()
      检索“模式”的数据库供应商的首选项。
      String getSearchStringEscape​()
      检索可用于转义通配符的字符串。
      String getSQLKeywords​()
      检索所有这些数据库的SQL关键字的逗号分隔列表，这些关键字也不是SQL：2003关键字。
      int getSQLStateType​()
      指示 SQLException.getSQLState返回的SQLSTATE是X / Open（现在称为Open Group）SQL CLI或SQL：2003。
      String getStringFunctions​()
      检索此数据库可用的逗号分隔的字符串函数列表。
      ResultSet getSuperTables​(String catalog, String schemaPattern, String tableNamePattern)
      检索此数据库中特定模式中定义的表层次结构的描述。
      ResultSet getSuperTypes​(String catalog, String schemaPattern, String typeNamePattern)
      检索此数据库中特定模式中定义的用户定义类型（UDT）层次结构的描述。
      String getSystemFunctions​()
      检索此数据库可用的系统函数的逗号分隔列表。
      ResultSet getTablePrivileges​(String catalog, String schemaPattern, String tableNamePattern)
      检索目录中可用的每个表的访问权限的描述。
      ResultSet getTables​(String catalog, String schemaPattern, String tableNamePattern, String[] types)
      检索给定目录中可用表的描述。
      ResultSet getTableTypes​()
      检索此数据库中可用的表类型。
      String getTimeDateFunctions​()
      检索此数据库可用的时间和日期函数的逗号分隔列表。
      ResultSet getTypeInfo​()
      检索此数据库支持的所有数据类型的描述。
      ResultSet getUDTs​(String catalog, String schemaPattern, String typeNamePattern, int[] types)
      检索在特定模式中定义的用户定义类型（UDT）的描述。
      String getURL​()
      检索此DBMS的URL。
      String getUserName​()
      检索此数据库已知的用户名。
      ResultSet getVersionColumns​(String catalog, String schema, String table)
      检索表中更新行中任何值时自动更新的表的列的说明。
      boolean insertsAreDetected​(int type)
      检索是否可以通过调用方法 ResultSet.rowInserted检测到可见行插入。
      boolean isCatalogAtStart​()
      检索目录是否在完全限定的表名开始时显示。
      boolean isReadOnly​()
      检索该数据库是否处于只读模式。
      boolean locatorsUpdateCopy​()
      指示对LOB进行的更新是在副本上还是直接进行到LOB。
      boolean nullPlusNonNullIsNull​()
      检索此数据库是否支持 NULL和 NULL之间的连接值为 NULL 。
      boolean nullsAreSortedAtEnd​()
      检索最终是否排序 NULL值，无论排序顺序如何。
      boolean nullsAreSortedAtStart​()
      检索 NULL值是否在开始排序，无论排序顺序如何。
      boolean nullsAreSortedHigh​()
      检索 NULL值是否排序高。
      boolean nullsAreSortedLow​()
      检索 NULL值是否排序低。
      boolean othersDeletesAreVisible​(int type)
      检索他人删除是否可见。
      boolean othersInsertsAreVisible​(int type)
      检索他人所做的插入是否可见。
      boolean othersUpdatesAreVisible​(int type)
      检索其他人所做的更新是否可见。
      boolean ownDeletesAreVisible​(int type)
      检索结果集自身的删除是否可见。
      boolean ownInsertsAreVisible​(int type)
      检索结果集是否可以看到自己的插入。
      boolean ownUpdatesAreVisible​(int type)
      检索是否为给定类型的 ResultSet对象，结果集的自己的更新是可见的。
      boolean storesLowerCaseIdentifiers​()
      检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并将其存储为小写。
      boolean storesLowerCaseQuotedIdentifiers​()
      检索此数据库是否将混合大小写的SQL标识符视为不区分大小写，并以小写形式存储。
      boolean storesMixedCaseIdentifiers​()
      检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并以混合大小写存储。
      boolean storesMixedCaseQuotedIdentifiers​()
      检索此数据库是否将混合大小写的SQL标识符视为不区分大小写，并以混合大小写存储。
      boolean storesUpperCaseIdentifiers​()
      检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并以大写形式存储。
      boolean storesUpperCaseQuotedIdentifiers​()
      检索此数据库是否将混合大小写引用的SQL标识符视为不区分大小写，并以大写形式存储。
      boolean supportsAlterTableWithAddColumn​()
      检索此数据库是否支持带有添加列的 ALTER TABLE 。
      boolean supportsAlterTableWithDropColumn​()
      检索此数据库是否支持带有删除列的 ALTER TABLE 。
      boolean supportsANSI92EntryLevelSQL​()
      检索此数据库是否支持ANSI92入门级SQL语法。
      boolean supportsANSI92FullSQL​()
      检索此数据库是否支持支持的ANSI92完整SQL语法。
      boolean supportsANSI92IntermediateSQL​()
      检索该数据库是否支持ANSI92中间SQL语法。
      boolean supportsBatchUpdates​()
      检索此数据库是否支持批量更新。
      boolean supportsCatalogsInDataManipulation​()
      检索数据操作语句中是否可以使用目录名称。
      boolean supportsCatalogsInIndexDefinitions​()
      检索是否可以在索引定义语句中使用目录名称。
      boolean supportsCatalogsInPrivilegeDefinitions​()
      检索是否可以在特权定义语句中使用目录名称。
      boolean supportsCatalogsInProcedureCalls​()
      检索是否可以在过程调用语句中使用目录名称。
      boolean supportsCatalogsInTableDefinitions​()
      检索表定义语句中是否可以使用目录名称。
      boolean supportsColumnAliasing​()
      检索此数据库是否支持列别名。
      boolean supportsConvert​()
      检索此数据库是否支持JDBC标量函数 CONVERT用于将一种JDBC类型转换为另一种JDBC类型。
      boolean supportsConvert​(int fromType, int toType)
      检索此数据库是否支持JDBC标量函数 CONVERT用于JDBC类型 fromType和 toType之间的转换。
      boolean supportsCoreSQLGrammar​()
      检索此数据库是否支持ODBC Core SQL语法。
      boolean supportsCorrelatedSubqueries​()
      检索此数据库是否支持相关的子查询。
      boolean supportsDataDefinitionAndDataManipulationTransactions​()
      检索此数据库是否支持事务中的数据定义和数据操作语句。
      boolean supportsDataManipulationTransactionsOnly​()
      检索此数据库是否仅支持事务中的数据操作语句。
      boolean supportsDifferentTableCorrelationNames​()
      检索是否支持表相关名称，它们被限制为与表的名称不同。
      boolean supportsExpressionsInOrderBy​()
      检索此数据库是否支持 ORDER BY列表中的表达式。
      boolean supportsExtendedSQLGrammar​()
      检索此数据库是否支持ODBC扩展SQL语法。
      boolean supportsFullOuterJoins​()
      检索此数据库是否支持完全嵌套的外连接。
      boolean supportsGetGeneratedKeys​()
      检索在执行语句后是否可以检索自动生成的键
      boolean supportsGroupBy​()
      检索此数据库是否支持某种形式的 GROUP BY子句。
      boolean supportsGroupByBeyondSelect​()
      获取此数据库是否支持使用不包含在列 SELECT在一份声明中 GROUP BY条款规定，所有在列 SELECT声明都包含在在 GROUP BY条款。
      boolean supportsGroupByUnrelated​()
      检索此数据库是否支持在 GROUP BY子句中使用 GROUP BY SELECT语句中的 GROUP BY 。
      boolean supportsIntegrityEnhancementFacility​()
      检索此数据库是否支持SQL完整性增强工具。
      boolean supportsLikeEscapeClause​()
      检索此数据库是否支持指定一个 LIKE转义子句。
      boolean supportsLimitedOuterJoins​()
      检索此数据库是否为外连接提供有限的支持。
      boolean supportsMinimumSQLGrammar​()
      检索此数据库是否支持ODBC最低SQL语法。
      boolean supportsMixedCaseIdentifiers​()
      检索此数据库是否将混合大小写不引用的SQL标识符视为区分大小写，并将结果存储在混合大小写中。
      boolean supportsMixedCaseQuotedIdentifiers​()
      检索此数据库是否将混合大小写的SQL标识符视为区分大小写，并将结果存储在混合大小写中。
      boolean supportsMultipleOpenResults​()
      检索是否有可能具有多个 ResultSet从返回的对象 CallableStatement对象同时进行。
      boolean supportsMultipleResultSets​()
      检索该数据库是否支持从方法 execute的单一调用中获取多个 ResultSet对象。
      boolean supportsMultipleTransactions​()
      检索此数据库是否允许同时打开多个事务（在不同的连接上）。
      boolean supportsNamedParameters​()
      检索此数据库是否支持可调用语句的命名参数。
      boolean supportsNonNullableColumns​()
      检索此数据库中的列是否可以被定义为不可为空。
      boolean supportsOpenCursorsAcrossCommit​()
      检索此数据库是否支持保持游标在提交之间打开。
      boolean supportsOpenCursorsAcrossRollback​()
      检索此数据库是否支持在回滚之间保持光标打开。
      boolean supportsOpenStatementsAcrossCommit​()
      检索此数据库是否支持在提交之间保留语句。
      boolean supportsOpenStatementsAcrossRollback​()
      检索此数据库是否支持在回滚期间保持语句打开。
      boolean supportsOrderByUnrelated​()
      检索此数据库是否支持在 ORDER BY子句中使用 ORDER BY SELECT语句中的 ORDER BY 。
      boolean supportsOuterJoins​()
      检索此数据库是否支持某种形式的外连接。
      boolean supportsPositionedDelete​()
      检索此数据库是否支持定位 DELETE语句。
      boolean supportsPositionedUpdate​()
      检索此数据库是否支持定位 UPDATE语句。
      default boolean supportsRefCursors​()
      检索此数据库是否支持REF CURSOR。
      boolean supportsResultSetConcurrency​(int type, int concurrency)
      检索此数据库是否支持给定的并发类型与给定的结果集类型的组合。
      boolean supportsResultSetHoldability​(int holdability)
      检索此数据库是否支持给定的结果集保持性。
      boolean supportsResultSetType​(int type)
      检索此数据库是否支持给定的结果集类型。
      boolean supportsSavepoints​()
      检索此数据库是否支持保存点。
      boolean supportsSchemasInDataManipulation​()
      检索是否可以在数据操作语句中使用模式名称。
      boolean supportsSchemasInIndexDefinitions​()
      检索是否可以在索引定义语句中使用模式名称。
      boolean supportsSchemasInPrivilegeDefinitions​()
      检索是否可以在特权定义语句中使用模式名称。
      boolean supportsSchemasInProcedureCalls​()
      检索是否可以在过程调用语句中使用模式名称。
      boolean supportsSchemasInTableDefinitions​()
      检索表定义语句中是否可以使用模式名称。
      boolean supportsSelectForUpdate​()
      检索此数据库是否支持 SELECT FOR UPDATE语句。
      default boolean supportsSharding​()
      检索此数据库是否支持分片。
      boolean supportsStatementPooling​()
      检索此数据库是否支持语句池。
      boolean supportsStoredFunctionsUsingCallSyntax​()
      检索此数据库是否支持使用存储过程转义语法调用用户定义或供应商功能。
      boolean supportsStoredProcedures​()
      检索此数据库是否支持使用存储过程转义语法的存储过程调用。
      boolean supportsSubqueriesInComparisons​()
      检索此数据库是否支持比较表达式中的子查询。
      boolean supportsSubqueriesInExists​()
      检索此数据库是否支持 EXISTS表达式中的子查询。
      boolean supportsSubqueriesInIns​()
      检索此数据库是否支持 IN表达式中的子查询。
      boolean supportsSubqueriesInQuantifieds​()
      检索此数据库是否支持量化表达式中的子查询。
      boolean supportsTableCorrelationNames​()
      检索此数据库是否支持表相关名称。
      boolean supportsTransactionIsolationLevel​(int level)
      检索此数据库是否支持给定的事务隔离级别。
      boolean supportsTransactions​()
      检索此数据库是否支持事务。
      boolean supportsUnion​()
      检索此数据库是否支持SQL UNION 。
      boolean supportsUnionAll​()
      检索此数据库是否支持SQL UNION ALL 。
      boolean updatesAreDetected​(int type)
      检索是否通过调用方法 ResultSet.rowUpdated检测到可见行更新。
      boolean usesLocalFilePerTable​()
      检索此数据库是否为每个表使用一个文件。
      boolean usesLocalFiles​()
      检索此数据库是否将表存储在本地文件中。

      • Methods inherited from interface java.sql.Wrapper

        isWrapperFor, unwrap

    • 字段详细信息

      • procedureResultUnknown

        static final int procedureResultUnknown
        表示不知道过程是否返回结果。

        由方法getProcedures返回的ResultSet对象中的列PROCEDURE_TYPE可能值。

        另请参见：
        Constant Field Values

      • procedureNoResult

        static final int procedureNoResult
        表示该过程不返回结果。

        由方法getProcedures返回的ResultSet对象中的列PROCEDURE_TYPE可能值。

        另请参见：
        Constant Field Values

      • procedureReturnsResult

        static final int procedureReturnsResult
        表示该过程返回结果。

        由方法getProcedures返回的ResultSet对象中的列PROCEDURE_TYPE可能值。

        另请参见：
        Constant Field Values

      • procedureColumnUnknown

        static final int procedureColumnUnknown
        表示列的类型未知。

        COLUMN_TYPE中ResultSet的列可能的值由方法getProcedureColumns返回。

        另请参见：
        Constant Field Values

      • procedureColumnIn

        static final int procedureColumnIn
        表示列存储IN参数。

        该列的可能值COLUMN_TYPE在ResultSet该方法返回getProcedureColumns 。

        另请参见：
        Constant Field Values

      • procedureColumnInOut

        static final int procedureColumnInOut
        表示列存储INOUT参数。

        该列的可能值COLUMN_TYPE在ResultSet该方法返回getProcedureColumns 。

        另请参见：
        Constant Field Values

      • procedureColumnOut

        static final int procedureColumnOut
        表示列存储OUT参数。

        COLUMN_TYPE中ResultSet的列可能的值由方法getProcedureColumns返回。

        另请参见：
        Constant Field Values

      • procedureColumnReturn

        static final int procedureColumnReturn
        表示列存储返回值。

        该列的可能值COLUMN_TYPE在ResultSet该方法返回getProcedureColumns 。

        另请参见：
        Constant Field Values

      • procedureColumnResult

        static final int procedureColumnResult
        表示列存储结果。

        COLUMN_TYPE中ResultSet列中可能的值由方法getProcedureColumns返回。

        另请参见：
        Constant Field Values

      • procedureNoNulls

        static final int procedureNoNulls
        表示不允许NULL值。

        由方法getProcedureColumns返回的ResultSet对象中的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • procedureNullable

        static final int procedureNullable
        表示允许NULL值。

        由方法getProcedureColumns返回的ResultSet对象中的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • procedureNullableUnknown

        static final int procedureNullableUnknown
        表示是否允许NULL值是未知的。

        由方法getProcedureColumns返回的ResultSet对象中的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • columnNoNulls

        static final int columnNoNulls
        表示列可能不允许NULL值。

        在ResultSet通过方法getColumns返回的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • columnNullable

        static final int columnNullable
        表示该列绝对允许NULL值。

        该列的可能值NULLABLE在ResultSet该方法返回getColumns 。

        另请参见：
        Constant Field Values

      • columnNullableUnknown

        static final int columnNullableUnknown
        表示列的无效性是未知的。

        NULLABLE中ResultSet列可能的值由方法getColumns返回。

        另请参见：
        Constant Field Values

      • bestRowTemporary

        static final int bestRowTemporary
        表示最佳行标识符的范围是非常临时的，只在该行被使用时持久。

        由方法getBestRowIdentifier返回的ResultSet对象中的列SCOPE可能值。

        另请参见：
        Constant Field Values

      • bestRowTransaction

        static final int bestRowTransaction
        表示最佳行标识符的范围是当前事务的剩余部分。

        由方法getBestRowIdentifier返回的ResultSet对象中的列SCOPE可能值。

        另请参见：
        Constant Field Values

      • bestRowSession

        static final int bestRowSession
        表示最佳行标识符的范围是当前会话的剩余部分。

        由方法getBestRowIdentifier返回的ResultSet对象中的列SCOPE可能值。

        另请参见：
        Constant Field Values

      • bestRowUnknown

        static final int bestRowUnknown
        表示最佳行标识符可能是伪列，也可能不是伪列。

        由方法getBestRowIdentifier返回的ResultSet对象中的列PSEUDO_COLUMN可能值。

        另请参见：
        Constant Field Values

      • bestRowNotPseudo

        static final int bestRowNotPseudo
        表示最佳行标识符不是伪列。

        由方法getBestRowIdentifier返回的ResultSet对象中的列PSEUDO_COLUMN可能值。

        另请参见：
        Constant Field Values

      • bestRowPseudo

        static final int bestRowPseudo
        表示最佳行标识符是伪列。

        由方法getBestRowIdentifier返回的ResultSet对象中的列PSEUDO_COLUMN可能值。

        另请参见：
        Constant Field Values

      • versionColumnUnknown

        static final int versionColumnUnknown
        表示此版本列可能是也可能不是伪列。

        由方法getVersionColumns返回的ResultSet对象中的列PSEUDO_COLUMN可能值。

        另请参见：
        Constant Field Values

      • versionColumnNotPseudo

        static final int versionColumnNotPseudo
        表示此版本列不是伪列。

        由方法getVersionColumns返回的ResultSet对象中的列PSEUDO_COLUMN可能值。

        另请参见：
        Constant Field Values

      • versionColumnPseudo

        static final int versionColumnPseudo
        表示此版本列是伪列。

        由方法getVersionColumns返回的ResultSet对象中的列PSEUDO_COLUMN可能值。

        另请参见：
        Constant Field Values

      • importedKeyCascade

        static final int importedKeyCascade
        对于列UPDATE_RULE ，表示当主键更新时，外键（导入的键）被更改以与其一致。 对于列DELETE_RULE ，它表示当主键被删除时，导入该键的行被删除。

        对于各列的可能值UPDATE_RULE和DELETE_RULE在ResultSet通过所述方法返回的对象getImportedKeys ， getExportedKeys ，和getCrossReference 。

        另请参见：
        Constant Field Values

      • importedKeyRestrict

        static final int importedKeyRestrict
        对于列UPDATE_RULE ，表示主键可能不被更新，如果它已被其他表导入为外键。 对于列DELETE_RULE ，表示如果主键已被其他表作为外键导入，则可能不删除主键。

        对于各列的可能值UPDATE_RULE和DELETE_RULE在ResultSet通过所述方法返回的对象getImportedKeys ， getExportedKeys ，和getCrossReference 。

        另请参见：
        Constant Field Values

      • importedKeySetNull

        static final int importedKeySetNull
        对于列UPDATE_RULE和DELETE_RULE ，表示当主键被更新或删除时，外键（导入的键）被更改为NULL 。

        对于各列的可能值UPDATE_RULE和DELETE_RULE在ResultSet通过所述方法返回的对象getImportedKeys ， getExportedKeys ，和getCrossReference 。

        另请参见：
        Constant Field Values

      • importedKeyNoAction

        static final int importedKeyNoAction
        对于列UPDATE_RULE和DELETE_RULE ，表示如果主键已导入，则不能更新或删除。

        对于各列的可能值UPDATE_RULE和DELETE_RULE在ResultSet通过所述方法返回的对象getImportedKeys ， getExportedKeys ，和getCrossReference 。

        另请参见：
        Constant Field Values

      • importedKeySetDefault

        static final int importedKeySetDefault
        对于列UPDATE_RULE和DELETE_RULE ，表示如果主键被更新或删除，则外键（导入的键）被设置为默认值。

        对于各列的可能值UPDATE_RULE和DELETE_RULE在ResultSet通过所述方法返回的对象getImportedKeys ， getExportedKeys ，和getCrossReference 。

        另请参见：
        Constant Field Values

      • importedKeyInitiallyDeferred

        static final int importedKeyInitiallyDeferred
        表示延迟。 有关定义，请参见SQL-92。

        该列的可能值DEFERRABILITY在ResultSet通过所述方法返回的对象getImportedKeys ， getExportedKeys ，和getCrossReference 。

        另请参见：
        Constant Field Values

      • importedKeyInitiallyImmediate

        static final int importedKeyInitiallyImmediate
        表示延迟。 有关定义，请参见SQL-92。

        该列的可能值DEFERRABILITY在ResultSet通过所述方法返回的对象getImportedKeys ， getExportedKeys ，和getCrossReference 。

        另请参见：
        Constant Field Values

      • importedKeyNotDeferrable

        static final int importedKeyNotDeferrable
        表示延迟。 有关定义，请参见SQL-92。

        该列的可能值DEFERRABILITY在ResultSet通过所述方法返回的对象getImportedKeys ， getExportedKeys ，和getCrossReference 。

        另请参见：
        Constant Field Values

      • typeNoNulls

        static final int typeNoNulls
        表示该数据类型不允许使用NULL值。

        由方法getTypeInfo返回的ResultSet对象中的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • typeNullable

        static final int typeNullable
        表示允许此数据类型的值为NULL 。

        由方法getTypeInfo返回的ResultSet对象中的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • typeNullableUnknown

        static final int typeNullableUnknown
        表示不知道该数据类型是否允许NULL值。

        由方法getTypeInfo返回的ResultSet对象中的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • typePredNone

        static final int typePredNone
        表示此类型不支持搜索条件WHERE 。

        由方法getTypeInfo返回的ResultSet对象中的列SEARCHABLE可能值。

        另请参见：
        Constant Field Values

      • typePredChar

        static final int typePredChar
        表示数据类型只能在使用LIKE谓词的WHERE搜索子句中使用。

        ResultSet对象中的列SEARCHABLE可能的值由方法getTypeInfo返回。

        另请参见：
        Constant Field Values

      • typePredBasic

        static final int typePredBasic
        表示数据类型只能在不使用LIKE谓词的WHERE搜索条款中使用。

        由方法getTypeInfo返回的ResultSet对象中的列SEARCHABLE可能值。

        另请参见：
        Constant Field Values

      • typeSearchable

        static final int typeSearchable
        表示所有WHERE搜索子句都可以基于此类型。

        由方法getTypeInfo返回的ResultSet对象中的列SEARCHABLE可能值。

        另请参见：
        Constant Field Values

      • tableIndexStatistic

        static final short tableIndexStatistic
        表示此列包含与表的索引描述一起返回的表统计信息。

        由方法getIndexInfo返回的ResultSet对象中的列TYPE可能值。

        另请参见：
        Constant Field Values

      • tableIndexClustered

        static final short tableIndexClustered
        表示此表索引是聚簇索引。

        由方法getIndexInfo返回的ResultSet对象中的列TYPE可能值。

        另请参见：
        Constant Field Values

      • tableIndexHashed

        static final short tableIndexHashed
        表示此索引是散列索引。

        由方法getIndexInfo返回的ResultSet对象中的列TYPE可能值。

        另请参见：
        Constant Field Values

      • tableIndexOther

        static final short tableIndexOther
        表示此表索引不是聚簇索引，散列索引或表统计信息; 这是其他的东西。

        由方法getIndexInfo返回的ResultSet对象中的列TYPE可能值。

        另请参见：
        Constant Field Values

      • attributeNoNulls

        static final short attributeNoNulls
        表示可能不允许NULL值。

        由方法getAttributes返回的ResultSet对象中的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • attributeNullable

        static final short attributeNullable
        表示绝对允许NULL值。

        由方法getAttributes返回的ResultSet对象中的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • attributeNullableUnknown

        static final short attributeNullableUnknown
        表示是否允许NULL值是未知的。

        由方法getAttributes返回的ResultSet对象中的列NULLABLE可能值。

        另请参见：
        Constant Field Values

      • sqlStateXOpen

        static final int sqlStateXOpen
        该方法一个可能的返回值 DatabaseMetaData.getSQLStateType这是用来指示由方法返回的值是否 SQLException.getSQLState是X /打开（现在知道的公开组）SQL CLI SQLSTATE值。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • sqlStateSQL

        static final int sqlStateSQL
        用于指示方法 DatabaseMetaData.getSQLStateType返回的值是否为SQLSTATE值的方法 SQLException.getSQLState的可能返回值。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • sqlStateSQL99

        static final int sqlStateSQL99
        该方法一个可能的返回值DatabaseMetaData.getSQLStateType这是用来指示由方法返回的值是否SQLException.getSQLState是一个SQL99 SQLSTATE值。

        注意：这个常数只是出于兼容性原因。 开发人员应该使用常数sqlStateSQL代替。

        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • functionColumnUnknown

        static final int functionColumnUnknown
        表示参数或列的类型未知。

        该列的可能值COLUMN_TYPE在ResultSet该方法返回getFunctionColumns 。

        另请参见：
        Constant Field Values

      • functionColumnIn

        static final int functionColumnIn
        表示参数或列是IN参数。

        COLUMN_TYPE的ResultSet列可能的值由方法getFunctionColumns返回。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionColumnInOut

        static final int functionColumnInOut
        表示参数或列是INOUT参数。

        该列的可能值COLUMN_TYPE在ResultSet该方法返回getFunctionColumns 。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionColumnOut

        static final int functionColumnOut
        表示参数或列是OUT参数。

        COLUMN_TYPE中ResultSet列可能的值由方法getFunctionColumns返回。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionReturn

        static final int functionReturn
        表示参数或列是返回值。

        该列的可能值COLUMN_TYPE在ResultSet该方法返回getFunctionColumns 。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionColumnResult

        static final int functionColumnResult
        表示参数或列是结果集中的列。

        该列的可能值COLUMN_TYPE在ResultSet该方法返回getFunctionColumns 。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionNoNulls

        static final int functionNoNulls
        表示不允许NULL值。

        由方法getFunctionColumns返回的ResultSet对象中的列NULLABLE可能值。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionNullable

        static final int functionNullable
        表示允许NULL值。

        由方法getFunctionColumns返回的ResultSet对象中的列NULLABLE可能值。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionNullableUnknown

        static final int functionNullableUnknown
        表示是否允许NULL值是未知的。

        由方法getFunctionColumns返回的ResultSet对象中的列NULLABLE可能值。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionResultUnknown

        static final int functionResultUnknown
        表示不知道函数是返回结果还是表。

        由方法getFunctions返回的ResultSet对象中的列FUNCTION_TYPE可能值。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionNoTable

        static final int functionNoTable
        表示该函数不返回表。

        由方法getFunctions返回的ResultSet对象中的列FUNCTION_TYPE可能值。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • functionReturnsTable

        static final int functionReturnsTable
        表示该函数返回一个表。

        由方法getFunctions返回的ResultSet对象中的列FUNCTION_TYPE可能值。

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

    • 方法详细信息

      • allProceduresAreCallable

        boolean allProceduresAreCallable​()
                          throws SQLException
        检索当前用户是否可以调用方法返回的所有过程 getProcedures 。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • allTablesAreSelectable

        boolean allTablesAreSelectable​()
                        throws SQLException
        检索当前用户是否可以使用 SELECT语句中方法 getTables返回的所有表。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • getURL

        String getURL​()
       throws SQLException
        检索此DBMS的URL。
        结果
        该DBMS的URL或 null如果无法生成
        异常
        SQLException - 如果发生数据库访问错误

      • getUserName

        String getUserName​()
            throws SQLException
        检索此数据库已知的用户名。
        结果
        数据库用户名
        异常
        SQLException - 如果发生数据库访问错误

      • isReadOnly

        boolean isReadOnly​()
            throws SQLException
        检索该数据库是否处于只读模式。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • nullsAreSortedHigh

        boolean nullsAreSortedHigh​()
                    throws SQLException
        检索NULL值是否排序高。 排序高意味着NULL值排序高于域中的任何其他值。 按升序排列，如果此方法返回true ，则NULL将出现NULL值。 相比之下，方法nullsAreSortedAtEnd指示是否在末尾对NULL值进行排序，而不管排序顺序如何。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • nullsAreSortedLow

        boolean nullsAreSortedLow​()
                   throws SQLException
        检索NULL值是否排序低。 Sorted low表示NULL值比域中的任何其他值都低。 按升序排列，如果此方法返回true ，则开始时将出现NULL值。 相比之下，方法nullsAreSortedAtStart指示是否在开始排序NULL值，而不管排序顺序如何。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • nullsAreSortedAtStart

        boolean nullsAreSortedAtStart​()
                       throws SQLException
        检索 NULL值是否在开始排序，无论排序顺序如何。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • nullsAreSortedAtEnd

        boolean nullsAreSortedAtEnd​()
                     throws SQLException
        检索最终是否排序 NULL值，而不管排序顺序如何。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • getDatabaseProductName

        String getDatabaseProductName​()
                       throws SQLException
        检索此数据库产品的名称。
        结果
        数据库产品名称
        异常
        SQLException - 如果发生数据库访问错误

      • getDatabaseProductVersion

        String getDatabaseProductVersion​()
                          throws SQLException
        检索此数据库产品的版本号。
        结果
        数据库版本号
        异常
        SQLException - 如果发生数据库访问错误

      • getDriverName

        String getDriverName​()
              throws SQLException
        检索此JDBC驱动程序的名称。
        结果
        JDBC驱动程序名称
        异常
        SQLException - 如果发生数据库访问错误

      • getDriverVersion

        String getDriverVersion​()
                 throws SQLException
        以 String检索此JDBC驱动程序的版本号。
        结果
        JDBC驱动程序版本
        异常
        SQLException - 如果发生数据库访问错误

      • getDriverMajorVersion

        int getDriverMajorVersion​()
        检索此JDBC驱动程序的主要版本号。
        结果
        JDBC驱动主要版本

      • getDriverMinorVersion

        int getDriverMinorVersion​()
        检索此JDBC驱动程序的次要版本号。
        结果
        JDBC驱动程序次要版本号

      • usesLocalFiles

        boolean usesLocalFiles​()
                throws SQLException
        检索此数据库是否将表存储在本地文件中。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • usesLocalFilePerTable

        boolean usesLocalFilePerTable​()
                       throws SQLException
        检索此数据库是否为每个表使用一个文件。
        结果
        true如果此数据库为每个表使用本地文件; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • supportsMixedCaseIdentifiers

        boolean supportsMixedCaseIdentifiers​()
                              throws SQLException
        检索此数据库是否将混合大小写不引用的SQL标识符视为区分大小写，并将结果存储在混合大小写中。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • storesUpperCaseIdentifiers

        boolean storesUpperCaseIdentifiers​()
                            throws SQLException
        检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并以大写形式存储。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • storesLowerCaseIdentifiers

        boolean storesLowerCaseIdentifiers​()
                            throws SQLException
        检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并将其存储为小写。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • storesMixedCaseIdentifiers

        boolean storesMixedCaseIdentifiers​()
                            throws SQLException
        检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并以混合大小写存储。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsMixedCaseQuotedIdentifiers

        boolean supportsMixedCaseQuotedIdentifiers​()
                                    throws SQLException
        检索此数据库是否将混合大小写的SQL标识符视为区分大小写，并将结果存储在混合大小写中。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • storesUpperCaseQuotedIdentifiers

        boolean storesUpperCaseQuotedIdentifiers​()
                                  throws SQLException
        检索此数据库是否将混合大小写引用的SQL标识符视为不区分大小写，并以大写形式存储。
        结果
        true如果是这样的话 false否则
        异常
        SQLException - 如果发生数据库访问错误

      • storesLowerCaseQuotedIdentifiers

        boolean storesLowerCaseQuotedIdentifiers​()
                                  throws SQLException
        检索此数据库是否将混合大小写的SQL标识符视为不区分大小写，并以小写形式存储。
        结果
        true如果是这样的话 false否则
        异常
        SQLException - 如果发生数据库访问错误

      • storesMixedCaseQuotedIdentifiers

        boolean storesMixedCaseQuotedIdentifiers​()
                                  throws SQLException
        检索此数据库是否将混合大小写的SQL标识符视为不区分大小写，并以混合大小写存储。
        结果
        true如果是的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • getIdentifierQuoteString

        String getIdentifierQuoteString​()
                         throws SQLException
        检索用于引用SQL标识符的字符串。 如果不支持标识符引用，则此方法返回空格“”。
        结果
        引用字符串或空格如果引用不受支持
        异常
        SQLException - 如果发生数据库访问错误

      • getSQLKeywords

        String getSQLKeywords​()
               throws SQLException
        检索所有这些数据库的SQL关键字的逗号分隔列表，这些关键字也不是SQL：2003关键字。
        结果
        该数据库关键字的列表也不是SQL：2003关键字
        异常
        SQLException - 如果发生数据库访问错误

      • getNumericFunctions

        String getNumericFunctions​()
                    throws SQLException
        检索此数据库可用的逗号分隔的数学函数列表。 这些是JDBC函数escape子句中使用的Open / Open CLI数学函数名称。
        结果
        该数据库支持的数学函数列表
        异常
        SQLException - 如果发生数据库访问错误

      • getStringFunctions

        String getStringFunctions​()
                   throws SQLException
        检索此数据库可用的逗号分隔的字符串函数列表。 这些是JDBC函数escape子句中使用的Open Group CLI字符串函数名。
        结果
        此数据库支持的字符串函数的列表
        异常
        SQLException - 如果发生数据库访问错误

      • getSystemFunctions

        String getSystemFunctions​()
                   throws SQLException
        检索此数据库可用的系统函数的逗号分隔列表。 这些是JDBC函数escape子句中使用的Open Group CLI系统函数名。
        结果
        该数据库支持的系统功能列表
        异常
        SQLException - 如果发生数据库访问错误

      • getTimeDateFunctions

        String getTimeDateFunctions​()
                     throws SQLException
        检索此数据库可用的时间和日期函数的逗号分隔列表。
        结果
        该数据库支持的时间和日期功能的列表
        异常
        SQLException - 如果发生数据库访问错误

      • getSearchStringEscape

        String getSearchStringEscape​()
                      throws SQLException
        检索可用于转义通配符的字符串。 这是可用于在作为模式的目录搜索参数中转义“_”或“％”的字符串（因此使用其中一个通配符）。

        '_'字符代表任何单个字符; '％'字符表示零个或多个字符的任何序列。

        结果
        用于转义通配符的字符串
        异常
        SQLException - 如果发生数据库访问错误

      • getExtraNameCharacters

        String getExtraNameCharacters​()
                       throws SQLException
        检索可用于未引号的标识符名称（超出az，AZ，0-9和_）的所有“额外”字符。
        结果
        该字符串包含额外的字符
        异常
        SQLException - 如果发生数据库访问错误

      • supportsAlterTableWithAddColumn

        boolean supportsAlterTableWithAddColumn​()
                                 throws SQLException
        检索此数据库是否支持 ALTER TABLE添加列。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsAlterTableWithDropColumn

        boolean supportsAlterTableWithDropColumn​()
                                  throws SQLException
        检索此数据库是否支持带有删除列的 ALTER TABLE 。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsColumnAliasing

        boolean supportsColumnAliasing​()
                        throws SQLException
        检索此数据库是否支持列别名。

        如果是这样，可以使用SQL AS子句为计算列提供名称，或者根据需要为列提供别名。

        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • nullPlusNonNullIsNull

        boolean nullPlusNonNullIsNull​()
                       throws SQLException
        检索此数据库是否支持 NULL和 NULL之间的连接值为 NULL 。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsConvert

        boolean supportsConvert​()
                 throws SQLException
        检索此数据库是否支持JDBC标量函数CONVERT用于将一种JDBC类型转换为另一种JDBC类型。 JDBC类型是在java.sql.Types定义的通用SQL数据类型。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsConvert

        boolean supportsConvert​(int fromType,
                        int toType)
                 throws SQLException
        检索此数据库是否支持JDBC标量函数CONVERT用于JDBC类型fromType和toType之间的转换。 JDBC类型是在java.sql.Types定义的通用SQL数据类型。
        参数
        fromType - 转换的类型; 来自类别java.sql.Types的类型代码java.sql.Types
        toType - 要转换的类型; 来自类别java.sql.Types的类型代码java.sql.Types
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        Types

      • supportsTableCorrelationNames

        boolean supportsTableCorrelationNames​()
                               throws SQLException
        检索此数据库是否支持表相关名称。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsDifferentTableCorrelationNames

        boolean supportsDifferentTableCorrelationNames​()
                                        throws SQLException
        检索是否支持表相关名称，它们被限制为与表的名称不同。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsExpressionsInOrderBy

        boolean supportsExpressionsInOrderBy​()
                              throws SQLException
        检索此数据库是否支持 ORDER BY列表中的表达式。
        结果
        true如果是的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsOrderByUnrelated

        boolean supportsOrderByUnrelated​()
                          throws SQLException
        检索此数据库是否支持使用 ORDER BY子句中不在 SELECT语句中的 ORDER BY 。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsGroupBy

        boolean supportsGroupBy​()
                 throws SQLException
        检索此数据库是否支持某种形式的 GROUP BY子句。
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsGroupByUnrelated

        boolean supportsGroupByUnrelated​()
                          throws SQLException
        检索此数据库是否支持在 GROUP BY子句中使用 GROUP BY SELECT语句中的 GROUP BY 。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsGroupByBeyondSelect

        boolean supportsGroupByBeyondSelect​()
                             throws SQLException
        获取此数据库是否支持使用不包含在列 SELECT在一份声明中 GROUP BY条款规定，所有在列 SELECT声明都包含在在 GROUP BY条款。
        结果
        true如果是的话 false否则
        异常
        SQLException - 如果发生数据库访问错误

      • supportsLikeEscapeClause

        boolean supportsLikeEscapeClause​()
                          throws SQLException
        检索此数据库是否支持指定一个 LIKE转义子句。
        结果
        true如果是的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsMultipleResultSets

        boolean supportsMultipleResultSets​()
                            throws SQLException
        检索此数据库是否支持从方法 execute的单一调用中获取多个 ResultSet对象。
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsMultipleTransactions

        boolean supportsMultipleTransactions​()
                              throws SQLException
        检索此数据库是否允许同时打开多个事务（在不同的连接上）。
        结果
        true如果是的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsNonNullableColumns

        boolean supportsNonNullableColumns​()
                            throws SQLException
        检索此数据库中的列是否可以被定义为不可为空。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsMinimumSQLGrammar

        boolean supportsMinimumSQLGrammar​()
                           throws SQLException
        检索此数据库是否支持ODBC最低SQL语法。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsCoreSQLGrammar

        boolean supportsCoreSQLGrammar​()
                        throws SQLException
        检索此数据库是否支持ODBC Core SQL语法。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsExtendedSQLGrammar

        boolean supportsExtendedSQLGrammar​()
                            throws SQLException
        检索此数据库是否支持ODBC扩展SQL语法。
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsANSI92EntryLevelSQL

        boolean supportsANSI92EntryLevelSQL​()
                             throws SQLException
        检索此数据库是否支持ANSI92入门级SQL语法。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsANSI92IntermediateSQL

        boolean supportsANSI92IntermediateSQL​()
                               throws SQLException
        检索该数据库是否支持ANSI92中间SQL语法。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsANSI92FullSQL

        boolean supportsANSI92FullSQL​()
                       throws SQLException
        检索此数据库是否支持支持的ANSI92完整SQL语法。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsIntegrityEnhancementFacility

        boolean supportsIntegrityEnhancementFacility​()
                                      throws SQLException
        检索此数据库是否支持SQL完整性增强工具。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • supportsOuterJoins

        boolean supportsOuterJoins​()
                    throws SQLException
        检索此数据库是否支持某种形式的外连接。
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsFullOuterJoins

        boolean supportsFullOuterJoins​()
                        throws SQLException
        检索此数据库是否支持完全嵌套的外连接。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsLimitedOuterJoins

        boolean supportsLimitedOuterJoins​()
                           throws SQLException
        检索此数据库是否为外连接提供有限的支持。 （这将是true ，如果该方法supportsFullOuterJoins返回true ）。
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • getSchemaTerm

        String getSchemaTerm​()
              throws SQLException
        检索“模式”的数据库供应商的首选项。
        结果
        “模式”的供应商术语
        异常
        SQLException - 如果发生数据库访问错误

      • getProcedureTerm

        String getProcedureTerm​()
                 throws SQLException
        检索“程序”的数据库供应商的首选项。
        结果
        “程序”的供应商术语
        异常
        SQLException - 如果发生数据库访问错误

      • getCatalogTerm

        String getCatalogTerm​()
               throws SQLException
        检索“目录”的数据库供应商的首选项。
        结果
        “目录”的供应商术语
        异常
        SQLException - 如果发生数据库访问错误

      • isCatalogAtStart

        boolean isCatalogAtStart​()
                  throws SQLException
        检索目录是否在完全限定的表名开始时显示。 如果没有，目录出现在最后。
        结果
        true如果目录名出现在完全限定表名的开头; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • getCatalogSeparator

        String getCatalogSeparator​()
                    throws SQLException
        检索此数据库用作目录和表名之间的分隔符的 String 。
        结果
        分隔符串
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSchemasInDataManipulation

        boolean supportsSchemasInDataManipulation​()
                                   throws SQLException
        检索是否可以在数据操作语句中使用模式名称。
        结果
        true如果是的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSchemasInProcedureCalls

        boolean supportsSchemasInProcedureCalls​()
                                 throws SQLException
        检索是否可以在过程调用语句中使用模式名称。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSchemasInTableDefinitions

        boolean supportsSchemasInTableDefinitions​()
                                   throws SQLException
        检索表定义语句中是否可以使用模式名称。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSchemasInIndexDefinitions

        boolean supportsSchemasInIndexDefinitions​()
                                   throws SQLException
        检索是否可以在索引定义语句中使用模式名称。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSchemasInPrivilegeDefinitions

        boolean supportsSchemasInPrivilegeDefinitions​()
                                       throws SQLException
        检索是否可以在特权定义语句中使用模式名称。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • supportsCatalogsInDataManipulation

        boolean supportsCatalogsInDataManipulation​()
                                    throws SQLException
        检索数据操作语句中是否可以使用目录名称。
        结果
        true如果是的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsCatalogsInProcedureCalls

        boolean supportsCatalogsInProcedureCalls​()
                                  throws SQLException
        检索是否可以在过程调用语句中使用目录名称。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • supportsCatalogsInTableDefinitions

        boolean supportsCatalogsInTableDefinitions​()
                                    throws SQLException
        检索表定义语句中是否可以使用目录名称。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsCatalogsInIndexDefinitions

        boolean supportsCatalogsInIndexDefinitions​()
                                    throws SQLException
        检索是否可以在索引定义语句中使用目录名称。
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsCatalogsInPrivilegeDefinitions

        boolean supportsCatalogsInPrivilegeDefinitions​()
                                        throws SQLException
        检索是否可以在特权定义语句中使用目录名称。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsPositionedDelete

        boolean supportsPositionedDelete​()
                          throws SQLException
        检索此数据库是否支持定位 DELETE语句。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsPositionedUpdate

        boolean supportsPositionedUpdate​()
                          throws SQLException
        检索此数据库是否支持定位 UPDATE语句。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSelectForUpdate

        boolean supportsSelectForUpdate​()
                         throws SQLException
        检索此数据库是否支持 SELECT FOR UPDATE语句。
        结果
        true如果是的话; false否则
        异常
        SQLException - 如果发生数据库访问错误

      • supportsStoredProcedures

        boolean supportsStoredProcedures​()
                          throws SQLException
        检索此数据库是否支持使用存储过程转义语法的存储过程调用。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSubqueriesInComparisons

        boolean supportsSubqueriesInComparisons​()
                                 throws SQLException
        检索此数据库是否支持比较表达式中的子查询。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSubqueriesInExists

        boolean supportsSubqueriesInExists​()
                            throws SQLException
        检索此数据库是否支持 EXISTS表达式中的子查询。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSubqueriesInIns

        boolean supportsSubqueriesInIns​()
                         throws SQLException
        检索此数据库是否支持 IN表达式中的子查询。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsSubqueriesInQuantifieds

        boolean supportsSubqueriesInQuantifieds​()
                                 throws SQLException
        检索此数据库是否支持量化表达式中的子查询。
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsCorrelatedSubqueries

        boolean supportsCorrelatedSubqueries​()
                              throws SQLException
        检索此数据库是否支持相关的子查询。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsUnion

        boolean supportsUnion​()
               throws SQLException
        检索此数据库是否支持SQL UNION 。
        结果
        true如果是的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsUnionAll

        boolean supportsUnionAll​()
                  throws SQLException
        检索此数据库是否支持SQL UNION ALL 。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsOpenCursorsAcrossCommit

        boolean supportsOpenCursorsAcrossCommit​()
                                 throws SQLException
        检索此数据库是否支持保持游标在提交之间打开。
        结果
        true如果游标始终保持打开状态; false如果他们可能不会保持开放
        异常
        SQLException - 如果发生数据库访问错误

      • supportsOpenCursorsAcrossRollback

        boolean supportsOpenCursorsAcrossRollback​()
                                   throws SQLException
        检索此数据库是否支持在回滚之间保持光标打开。
        结果
        true如果游标始终保持打开状态; false如果他们可能不会保持开放
        异常
        SQLException - 如果发生数据库访问错误

      • supportsOpenStatementsAcrossCommit

        boolean supportsOpenStatementsAcrossCommit​()
                                    throws SQLException
        检索此数据库是否支持在提交之间保留语句。
        结果
        true if语句总是保持开放; false如果他们可能不会保持开放
        异常
        SQLException - 如果发生数据库访问错误

      • supportsOpenStatementsAcrossRollback

        boolean supportsOpenStatementsAcrossRollback​()
                                      throws SQLException
        检索此数据库是否支持在回滚期间保持语句打开。
        结果
        true if语句始终保持打开状态; false如果他们可能不会保持打开
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxBinaryLiteralLength

        int getMaxBinaryLiteralLength​()
                       throws SQLException
        检索数据库允许的内联二进制文字的最大十六进制数。
        结果
        最大二进制文字的最大长度（十六进制字符）; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxCharLiteralLength

        int getMaxCharLiteralLength​()
                     throws SQLException
        检索此数据库允许使用字符文字的最大字符数。
        结果
        字符文字允许的最大字符数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxColumnNameLength

        int getMaxColumnNameLength​()
                    throws SQLException
        检索此数据库允许列名称的最大字符数。
        结果
        列名允许的最大字符数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxColumnsInGroupBy

        int getMaxColumnsInGroupBy​()
                    throws SQLException
        检索 GROUP BY子句中数据库允许的最大列数。
        结果
        允许的最大列数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxColumnsInIndex

        int getMaxColumnsInIndex​()
                  throws SQLException
        检索数据库在索引中允许的最大列数。
        结果
        允许的最大列数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxColumnsInOrderBy

        int getMaxColumnsInOrderBy​()
                    throws SQLException
        检索 ORDER BY子句中数据库允许的最大列数。
        结果
        允许的最大列数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxColumnsInSelect

        int getMaxColumnsInSelect​()
                   throws SQLException
        检索 SELECT列表中数据库允许的最大列数。
        结果
        允许的最大列数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxColumnsInTable

        int getMaxColumnsInTable​()
                  throws SQLException
        检索数据库在表中允许的最大列数。
        结果
        允许的最大列数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxConnections

        int getMaxConnections​()
               throws SQLException
        检索可能的此数据库的最大并发连接数。
        结果
        一次可能的最大有效连接数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxCursorNameLength

        int getMaxCursorNameLength​()
                    throws SQLException
        检索该数据库在游标名称中允许的最大字符数。
        结果
        游标名称允许的最大字符数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxIndexLength

        int getMaxIndexLength​()
               throws SQLException
        检索数据库允许索引的最大字节数，包括索引的所有部分。
        结果
        允许的最大字节数; 这个限制包括索引的所有组成部分的复合; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxSchemaNameLength

        int getMaxSchemaNameLength​()
                    throws SQLException
        检索此数据库在模式名称中允许的最大字符数。
        结果
        模式名称中允许的最大字符数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxProcedureNameLength

        int getMaxProcedureNameLength​()
                       throws SQLException
        检索此数据库在过程名称中允许的最大字符数。
        结果
        过程名称中允许的最大字符数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxCatalogNameLength

        int getMaxCatalogNameLength​()
                     throws SQLException
        检索此数据库在目录名称中允许的最大字符数。
        结果
        目录名称中允许的最大字符数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxRowSize

        int getMaxRowSize​()
           throws SQLException
        检索数据库在单行中允许的最大字节数。
        结果
        一行允许的最大字节数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • doesMaxRowSizeIncludeBlobs

        boolean doesMaxRowSizeIncludeBlobs​()
                            throws SQLException
        检索方法 getMaxRowSize的返回值是否包含SQL数据类型 LONGVARCHAR和 LONGVARBINARY 。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxStatementLength

        int getMaxStatementLength​()
                   throws SQLException
        检索数据库在SQL语句中允许的最大字符数。
        结果
        SQL语句允许的最大字符数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxStatements

        int getMaxStatements​()
              throws SQLException
        检索可以同时打开的此数据库的活动语句的最大数量。
        结果
        一次可以打开的最大语句数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxTableNameLength

        int getMaxTableNameLength​()
                   throws SQLException
        检索数据库在表名中允许的最大字符数。
        结果
        表名允许的最大字符数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxTablesInSelect

        int getMaxTablesInSelect​()
                  throws SQLException
        检索 SELECT语句中数据库允许的最大表数。
        结果
        SELECT语句允许的最大表数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxUserNameLength

        int getMaxUserNameLength​()
                  throws SQLException
        检索数据库在用户名中允许的最大字符数。
        结果
        用户名允许的最大字符数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误

      • getDefaultTransactionIsolation

        int getDefaultTransactionIsolation​()
                            throws SQLException
        检索此数据库的默认事务隔离级别。 可能的值在java.sql.Connection中定义。
        结果
        默认隔离级别
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        Connection

      • supportsTransactions

        boolean supportsTransactions​()
                      throws SQLException
        检索此数据库是否支持事务。 如果没有，则调用方法commit是noop，隔离级别为TRANSACTION_NONE 。
        结果
        true如果支持交易; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • supportsTransactionIsolationLevel

        boolean supportsTransactionIsolationLevel​(int level)
                                   throws SQLException
        检索此数据库是否支持给定的事务隔离级别。
        参数
        level - java.sql.Connection定义的事务隔离级别 java.sql.Connection
        结果
        true如果是这样的话 false否则
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        Connection

      • supportsDataDefinitionAndDataManipulationTransactions

        boolean supportsDataDefinitionAndDataManipulationTransactions​()
                                                       throws SQLException
        检索此数据库是否支持事务中的数据定义和数据操作语句。
        结果
        true如果是这样的话 false否则
        异常
        SQLException - 如果发生数据库访问错误

      • supportsDataManipulationTransactionsOnly

        boolean supportsDataManipulationTransactionsOnly​()
                                          throws SQLException
        检索此数据库是否仅支持事务中的数据操作语句。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • dataDefinitionCausesTransactionCommit

        boolean dataDefinitionCausesTransactionCommit​()
                                       throws SQLException
        检索事务中的数据定义语句是否强制事务提交。
        结果
        true如果是这样的话 false否则
        异常
        SQLException - 如果发生数据库访问错误

      • dataDefinitionIgnoredInTransactions

        boolean dataDefinitionIgnoredInTransactions​()
                                     throws SQLException
        检索此数据库是否忽略事务中的数据定义语句。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • getProcedures

        ResultSet getProcedures​(String catalog,
                        String schemaPattern,
                        String procedureNamePattern)
                 throws SQLException
        200的X- 200 200 X- 200 200 X- 200 200：

        仅返回与模式和过程名称标准相匹配的过程描述。 他们被下令PROCEDURE_CAT ， PROCEDURE_SCHEM ， PROCEDURE_NAME和SPECIFIC_ NAME 。

        每个过程描述都有以下列：

        1. PROCEDURE_CAT字符串=>程序目录（可能为null ）
        2. PROCEDURE_SCHEM字符串=>过程模式（可能为null ）
        3. PROCEDURE_NAME字符串=>过程名称
        4. 保留供将来使用
        5. 保留供将来使用
        6. 保留供将来使用
        7. 备注字符串=>对程序的解释性评论
        8. PROCEDURE_TYPE短=>种程序：
          • procedureResultUnknown - 无法确定是否返回值
          • procedureNoResult - 不返回返回值
          • procedureReturnsResult - 返回一个返回值
        9. SPECIFIC_NAME字符串=>在其模式中唯一标识此过程的名称。

        用户可能没有执行getProcedures返回的任何过程的getProcedures

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式名称模式;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        procedureNamePattern - 过程名称模式; 必须与存储在数据库中的过程名称相匹配
        结果
        ResultSet - 每一行都是一个过程描述
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        getSearchStringEscape()

      • getProcedureColumns

        ResultSet getProcedureColumns​(String catalog,
                              String schemaPattern,
                              String procedureNamePattern,
                              String columnNamePattern)
                       throws SQLException
        检索给定目录的存储过程参数和结果列的描述。

        仅返回与模式，过程和参数名称标准相匹配的描述。 它们由PROCEDURE_CAT，PROCEDURE_SCHEM，PROCEDURE_NAME和SPECIFIC_NAME命令。 在这里，返回值（如果有的话）是第一个。 接下来是呼叫顺序中的参数说明。 列描述按照列号顺序。

        ResultSet中的每一行都是具有以下字段的参数描述或列描述：

        1. PROCEDURE_CAT字符串=>过程目录（可能为null ）
        2. PROCEDURE_SCHEM字符串=>过程模式（可能为null ）
        3. PROCEDURE_NAME字符串=>过程名称
        4. COLUMN_NAME字符串=>列/参数名称
        5. COLUMN_TYPE Short =>列/参数：
          • procedureColumnUnknown - 没有人知道
          • procedureColumnIn - IN参数
          • procedureColumnInOut - INOUT参数
          • procedureColumnOut - OUT参数
          • procedureColumnReturn - 过程返回值
          • procedureColumnResult - 结果列在ResultSet
        6. DATA_TYPE int => java.sql.Types中的SQL类型
        7. TYPE_NAME字符串=> SQL类型名称，对于UDT类型，类型名称是完全限定的
        8. PRECISION int =>精度
        9. LENGTH int =>以字节为单位的数据长度
        10. SCALE short => scale - 对于SCALE不适用的数据类型返回null。
        11. RADIX短=>基数
        12. NULLABLE short =>可以包含NULL。
          • procedureNoNulls - 不允许NULL值
          • procedureNullable - 允许NULL值
          • procedureNullableUnknown - 可空性未知
        13. 备注字符串=>注释描述参数/列
        14. COLUMN_DEF字符串=>列的默认值，当值以单引号括起时，应将其解释为字符串（可能为null ）
          • 字符串NULL（不包含在引号中） - 如果将NULL指定为默认值
          • TRUNCATE（不用引号括起来） - 如果指定的默认值不能被表示而不被截断
          • NULL - 如果未指定默认值
        15. SQL_DATA_TYPE int =>保留供将来使用
        16. SQL_DATETIME_SUB int =>保留供将来使用
        17. CHAR_OCTET_LENGTH int =>基于二进制和字符的列的最大长度。 对于任何其他数据类型，返回的值为NULL
        18. ORDINAL_POSITION int =>从1开始的顺序位置，用于过程的输入和输出参数。 如果此行描述过程的返回值，则返回值0。 对于结果集列，它是从1开始的结果集中的列的顺序位置。如果有多个结果集，则列序号位置是实现定义的。
        19. IS_NULLABLE字符串=> ISO规则用于确定列的可空性。
          • YES ---如果列可以包含NULL
          • 否---如果列不能包含NULL
          • 空字符串---如果列的可空性是未知的
        20. SPECIFIC_NAME字符串=>在其模式中唯一标识此过程的名称。

        注意：某些数据库可能不返回过程的列描述。

        PRECISION列表示给定列的指定列大小。 对于数值数据，这是最大精度。 对于字符数据，这是字符长度。 对于datetime数据类型，这是String表示形式的长度（假定分数秒分量的最大允许精度）。 对于二进制数据，这是以字节为单位的长度。 对于ROWID数据类型，这是以字节为单位的长度。 对于列大小不适用的数据类型，返回空值。

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式名称模式;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null表示不应该使用模式名称来缩小搜索范围
        procedureNamePattern - 过程名称模式; 必须与存储在数据库中的过程名称相匹配
        columnNamePattern - 列名称模式; 必须匹配存储在数据库中的列名称
        结果
        ResultSet - 每行描述一个存储过程参数或列
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        getSearchStringEscape()

      • getTables

        ResultSet getTables​(String catalog,
                    String schemaPattern,
                    String tableNamePattern,
                    String[] types)
             throws SQLException
        检索给定目录中可用表的描述。 仅返回与目录，模式，表名和类型条件匹配的表描述。 他们被下令TABLE_TYPE ， TABLE_CAT ， TABLE_SCHEM和TABLE_NAME 。

        每个表格描述包含以下列：

        1. TABLE_CAT字符串=>表目录（可能为null ）
        2. TABLE_SCHEM字符串=>表模式（可以是null ）
        3. TABLE_NAME字符串=>表名
        4. TABLE_TYPE字符串=>表类型。 典型的类型是“TABLE”，“VIEW”，“SYSTEM TABLE”，“GLOBAL TEMPORARY”，“LOCAL TEMPORARY”，“ALIAS”，“SYNONYM”。
        5. 备注字符串=>表上的解释性注释（可能为null ）
        6. TYPE_CAT字符串=>类型目录（可能为null ）
        7. TYPE_SCHEM字符串=>类型模式（可能是null ）
        8. TYPE_NAME字符串=>类型名称（可能为null ）
        9. SELF_REFERENCING_COL_NAME字符串=>打字表的指定“标识符”列的名称（可能为null ）
        10. REF_GENERATION字符串=>指定如何创建SELF_REFERENCING_COL_NAME中的值。 值为“SYSTEM”，“USER”，“DERIVED”。 （可以是null ）

        注意：某些数据库可能不会返回所有表的信息。

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式名称模式;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        tableNamePattern - 表名称模式; 必须匹配存储在数据库中的表名称
        types - 表格类型的列表，它们必须来自于从getTableTypes()返回的表格类型列表; null返回所有类型
        结果
        ResultSet - 每一行都是表的描述
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        getSearchStringEscape()

      • getSchemas

        ResultSet getSchemas​()
              throws SQLException
        检索此数据库中可用的模式名称。 结果由TABLE_CATALOG和TABLE_SCHEM 。

        模式列为：

        1. TABLE_SCHEM字符串=>模式名称
        2. TABLE_CATALOG字符串=>目录名称（可能为null ）
        结果
        一个 ResultSet对象，其中每行是模式描述
        异常
        SQLException - 如果发生数据库访问错误

      • getCatalogs

        ResultSet getCatalogs​()
               throws SQLException
        检索此数据库中可用的目录名称。 结果按目录名称排序。

        目录栏是：

        1. TABLE_CAT字符串=>目录名称
        结果
        一个 ResultSet对象，其中每行具有作为目录名称的单个 String列
        异常
        SQLException - 如果发生数据库访问错误

      • getTableTypes

        ResultSet getTableTypes​()
                 throws SQLException
        检索此数据库中可用的表类型。 结果按表类型排序。

        表格类型是：

        1. TABLE_TYPE字符串=>表类型。 典型的类型是“TABLE”，“VIEW”，“SYSTEM TABLE”，“GLOBAL TEMPORARY”，“LOCAL TEMPORARY”，“ALIAS”，“SYNONYM”。
        结果
        一个 ResultSet对象，其中每行具有单个 String列，即表类型
        异常
        SQLException - 如果发生数据库访问错误

      • getColumns

        ResultSet getColumns​(String catalog,
                     String schemaPattern,
                     String tableNamePattern,
                     String columnNamePattern)
              throws SQLException
        检索指定目录中可用的表列的描述。

        仅返回与目录，模式，表和列名称标准相匹配的列描述。 他们被下令TABLE_CAT ， TABLE_SCHEM ， TABLE_NAME ，并ORDINAL_POSITION 。

        每列描述具有以下列：

        1. TABLE_CAT字符串=>表目录（可能为null ）
        2. TABLE_SCHEM字符串=>表模式（可以是null ）
        3. TABLE_NAME字符串=>表名
        4. COLUMN_NAME字符串=>列名称
        5. DATA_TYPE int => java.sql.Types中的SQL类型
        6. TYPE_NAME字符串=>数据源相关类型名称，对于UDT，类型名称是完全限定的
        7. COLUMN_SIZE int =>列大小。
        8. 不使用BUFFER_LENGTH 。
        9. DECIMAL_DIGITS int =>小数位数。 对于DECIMAL_DIGITS不适用的数据类型，返回空值。
        10. NUM_PREC_RADIX int =>基数（通常为10或2）
        11. NULLABLE int =>允许NULL。
          • columnNoNulls - 可能不允许NULL值
          • columnNullable - 绝对允许NULL值
          • columnNullableUnknown - 可空性未知
        12. 备注字符串=>注释描述列（可能为null ）
        13. COLUMN_DEF字符串=>列的默认值，当该值以单引号括起时，应将其解释为字符串（可能为null ）
        14. 未使用SQL_DATA_TYPE int =>
        15. SQL_DATETIME_SUB int =>未使用
        16. CHAR_OCTET_LENGTH int =>用于char类型列中最大字节数
        17. ORDINAL_POSITION int =>表中的列索引（从1开始）
        18. IS_NULLABLE字符串=> ISO规则用于确定列的可空性。
          • YES ---如果列可以包含NULL
          • 否---如果列不能包含NULL
          • 空字符串---如果列的可空性是未知的
        19. SCOPE_CATALOG字符串=>作为引用属性范围的表的目录（如果DATA_TYPE不是REF， null ）
        20. SCOPE_SCHEMA字符串=>作为参考属性范围的表的模式（如果DATA_TYPE不是REF， null ）
        21. SCOPE_TABLE字符串=>表名称，这个参考属性的范围（如果DATA_TYPE不是REF， null ）
        22. SOURCE_DATA_TYPE short =>不同类型或用户生成的引用类型的源类型，java.sql.Types中的SQL类型（如果DATA_TYPE不是DISTINCT或用户生成的REF， null ）
        23. IS_AUTOINCREMENT字符串=>指示此列是否自动递增
          • YES ---如果列自动递增
          • 否---如果列不自动递增
          • 空字符串---如果无法确定列是否自动递增
        24. IS_GENERATEDCOLUMN字符串=>指示这是否是生成的列
          • 是---如果这是一个生成的列
          • 否---如果这不是一个生成的列
          • 空字符串---如果无法确定这是否是生成的列

        COLUMN_SIZE列指定给定列的列大小。 对于数值数据，这是最大精度。 对于字符数据，这是字符长度。 对于datetime数据类型，这是String表示形式的长度（假定分数秒分量的最大允许精度）。 对于二进制数据，这是以字节为单位的长度。 对于ROWID数据类型，这是以字节为单位的长度。 对于列大小不适用的数据类型，返回空值。

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式名称模式;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        tableNamePattern - 表名称模式; 必须匹配存储在数据库中的表名称
        columnNamePattern - 列名称模式; 必须匹配存储在数据库中的列名称
        结果
        ResultSet - 每行都是列描述
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        getSearchStringEscape()

      • getColumnPrivileges

        ResultSet getColumnPrivileges​(String catalog,
                              String schema,
                              String table,
                              String columnNamePattern)
                       throws SQLException
        检索表的列的访问权限的描述。

        只返回匹配列名称条件的权限。 它们由COLUMN_NAME和PRIVILEGE命令。

        每个权限描述都具有以下列：

        1. TABLE_CAT字符串=>表目录（可能为null ）
        2. TABLE_SCHEM字符串=>表模式（可以是null ）
        3. TABLE_NAME字符串=>表名
        4. COLUMN_NAME字符串=>列名称
        5. GRANTOR字符串=>设保人（可能为null ）
        6. GRANTEE字符串=>授权人
        7. PRIVILEGE字符串=>访问名称（SELECT，INSERT，UPDATE，REFERENCES，...）
        8. IS_GRANTABLE字符串=> “是”如果受让人被允许授予他人; “否”如果没有; null如果未知
        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schema - 模式名称;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        table - 表名; 必须匹配存储在数据库中的表名称
        columnNamePattern - 列名称模式; 必须匹配存储在数据库中的列名称
        结果
        ResultSet - 每一行都是列特权描述
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        getSearchStringEscape()

      • getTablePrivileges

        ResultSet getTablePrivileges​(String catalog,
                             String schemaPattern,
                             String tableNamePattern)
                      throws SQLException
        检索目录中可用的每个表的访问权限的描述。 请注意，表权限适用于表中的一个或多个列。 假设此权限适用于所有列（这对某些系统可能是真实的但对所有列都不正确）将是错误的。）

        只返回匹配模式和表名称条件的权限。 他们被下令TABLE_CAT ， TABLE_SCHEM ， TABLE_NAME ，并PRIVILEGE 。

        每个权限描述都具有以下列：

        1. TABLE_CAT字符串=>表目录（可能为null ）
        2. TABLE_SCHEM字符串=>表模式（可以是null ）
        3. TABLE_NAME字符串=>表名
        4. GRANTOR字符串=>设保人访问（可能为null ）
        5. GRANTEE字符串=>访问=>人
        6. PRIVILEGE字符串=>访问名称（SELECT，INSERT，UPDATE，REFERENCES，...）
        7. IS_GRANTABLE字符串=> “是”如果受让人被允许授予他人; “否”如果没有; null如果未知
        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式名称模式;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        tableNamePattern - 表名模式; 必须匹配存储在数据库中的表名称
        结果
        ResultSet - 每一行都是表特权描述
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        getSearchStringEscape()

      • getBestRowIdentifier

        ResultSet getBestRowIdentifier​(String catalog,
                               String schema,
                               String table,
                               int scope,
                               boolean nullable)
                        throws SQLException
        检索表的唯一标识行的最佳列集描述。 它们由SCOPE命令。

        每列描述具有以下列：

        1. 范围短=>实际结果范围
          • bestRowTemporary - 非常临时，同时使用行
          • bestRowTransaction - 对当前事务的剩余部分有效
          • bestRowSession - 对当前会话剩余部分有效
        2. COLUMN_NAME字符串=>列名称
        3. DATA_TYPE int => java.sql.Types中的SQL数据类型
        4. TYPE_NAME字符串=>数据源相关类型名称，对于UDT，类型名称是完全限定的
        5. COLUMN_SIZE int =>精度
        6. BUFFER_LENGTH int =>未使用
        7. DECIMAL_DIGITS short => scale - 对于DECIMAL_DIGITS不适用的数据类型，返回空值。
        8. PSEUDO_COLUMN short =>这是一个像Oracle ROWID这样的伪列
          • bestRowUnknown - 可能是也可能不是伪列
          • bestRowNotPseudo - 不是伪列
          • bestRowPseudo - 是一个伪列

        COLUMN_SIZE列表示给定列的指定列大小。 对于数值数据，这是最大精度。 对于字符数据，这是字符长度。 对于datetime数据类型，这是String表示形式的长度（假定分数秒分量的最大允许精度）。 对于二进制数据，这是以字节为单位的长度。 对于ROWID数据类型，这是以字节为单位的长度。 对于列大小不适用的数据类型，返回空值。

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schema - 模式名称;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null表示不应该使用模式名称来缩小搜索范围
        table - 表名; 必须匹配存储在数据库中的表名称
        scope - 感兴趣的范围; 使用与SCOPE相同的值
        nullable - 包含可空的列。
        结果
        ResultSet - 每行都是列描述
        异常
        SQLException - 如果发生数据库访问错误

      • getVersionColumns

        ResultSet getVersionColumns​(String catalog,
                            String schema,
                            String table)
                     throws SQLException
        检索表中更新行中任何值时自动更新的表的列的说明。 他们是无序的

        每列描述具有以下列：

        1. SCOPE短=>未使用
        2. COLUMN_NAME字符串=>列名
        3. DATA_TYPE int => SQL数据类型，从java.sql.Types
        4. TYPE_NAME字符串=>数据源相关的类型名称
        5. COLUMN_SIZE int =>精度
        6. BUFFER_LENGTH int =>列值的长度（以字节为单位）
        7. DECIMAL_DIGITS short => scale - 对于DECIMAL_DIGITS不适用的数据类型，返回空值。
        8. PSEUDO_COLUMN short =>这是伪列如Oracle ROWID
          • versionColumnUnknown - 可能是也可能不是伪列
          • versionColumnNotPseudo - 不是伪列
          • versionColumnPseudo - 是一个伪列

        COLUMN_SIZE列表示给定列的指定列大小。 对于数值数据，这是最大精度。 对于字符数据，这是字符长度。 对于datetime数据类型，这是String表示形式的长度（假定分数秒分量的最大允许精度）。 对于二进制数据，这是以字节为单位的长度。 对于ROWID数据类型，这是以字节为单位的长度。 对于列大小不适用的数据类型，返回空值。

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schema - 模式名称;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        table - 表名; 必须匹配存储在数据库中的表名称
        结果
        一个 ResultSet对象，其中每行都是列描述
        异常
        SQLException - 如果发生数据库访问错误

      • getPrimaryKeys

        ResultSet getPrimaryKeys​(String catalog,
                         String schema,
                         String table)
                  throws SQLException
        检索给定表的主键列的描述。 它们由COLUMN_NAME命令。

        每个主键列描述具有以下列：

        1. TABLE_CAT字符串=>表目录（可能为null ）
        2. TABLE_SCHEM字符串=>表模式（可以是null ）
        3. TABLE_NAME字符串=>表名
        4. COLUMN_NAME字符串=>列名
        5. KEY_SEQ短=>序列号内的主键（值1表示主密钥中的第一列，值2将代表主键中的第二列）。
        6. PK_NAME字符串=>主键名称（可能为null ）
        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schema - 模式名称;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null表示不应该使用模式名称来缩小搜索范围
        table - 表名; 必须匹配存储在数据库中的表名称
        结果
        ResultSet - 每行是主键列描述
        异常
        SQLException - 如果发生数据库访问错误

      • getImportedKeys

        ResultSet getImportedKeys​(String catalog,
                          String schema,
                          String table)
                   throws SQLException
        检索给定表的外键列（由表导入的主键）引用的主键列的描述。 它们由PKTABLE_CAT，PKTABLE_SCHEM，PKTABLE_NAME和KEY_SEQ排序。

        每个主键列描述具有以下列：

        1. PKTABLE_CAT字符串=>正在导入的主键表目录（可能为null ）
        2. PKTABLE_SCHEM字符串=>正在导入的主键表模式（可能为null ）
        3. =>主键表名称的PKTABLE_NAME字符串=>
        4. PKCOLUMN_NAME字符串=>正在导入的主键列名称
        5. FKTABLE_CAT字符串=>外键表目录（可能为null ）
        6. FKTABLE_SCHEM字符串=>外键表null （可以是null ）
        7. FKTABLE_NAME字符串=>外键表名
        8. FKCOLUMN_NAME字符串=>外键列名
        9. KEY_SEQ短=>外键内的序列号（值1表示外键的第一列中，值2将代表外键内的第二列）。
        10. UPDATE_RULE short =>当主键更新时，外键会发生什么：
          • importedNoAction - 如果导入了主键，则不允许更新主键
          • importedKeyCascade - 更改导入的密钥以同意主密钥更新
          • importedKeySetNull - 如果主键已更新， NULL导入的键更改为NULL
          • importedKeySetDefault - 如果其主键已更新，则将导入的键更改为默认值
          • importedKeyRestrict - 与importedKeyNoAction相同（适用于ODBC 2.x兼容性）
        11. DELETE_RULE short =>当删除主键时，外键会发生什么。
          • importedKeyNoAction - 如果导入了主键，则不允许删除主键
          • importedKeyCascade - 删除导入已删除密钥的行
          • importedKeySetNull - 如果主键已被删除，则将导入的键更改为NULL
          • importedKeyRestrict - 与importedKeyNoAction相同（适用于ODBC 2.x兼容性）
          • importedKeySetDefault - 如果主键已被删除，则将导入的键更改为默认值
        12. FK_NAME字符串=>外键名称（可能为null ）
        13. PK_NAME字符串=>主键名称（可能为null ）
        14. DEFERRABILITY short =>可以将外键约束的评估推迟到提交之前
          • importedKeyInitiallyDeferred - 请参见SQL92的定义
          • importedKeyInitiallyImmediate - 请参见SQL92的定义
          • importedKeyNotDeferrable - 请参见SQL92的定义
        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schema - 模式名称;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null表示不应该使用模式名称来缩小搜索范围
        table - 表名; 必须匹配存储在数据库中的表名称
        结果
        ResultSet - 每行是主键列描述
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        getExportedKeys(java.lang.String, java.lang.String, java.lang.String)

      • getExportedKeys

        ResultSet getExportedKeys​(String catalog,
                          String schema,
                          String table)
                   throws SQLException
        检索引用给定表的主键列（由表导出的外键）的外键列的描述。 它们由FKTABLE_CAT，FKTABLE_SCHEM，FKTABLE_NAME和KEY_SEQ排序。

        每个外键列描述具有以下列：

        1. PKTABLE_CAT字符串=>主键表目录（可能为null ）
        2. PKTABLE_SCHEM字符串=>主键表模式（可能为null ）
        3. PKTABLE_NAME字符串=>主键表名
        4. PKCOLUMN_NAME字符串=>主键列名称
        5. FKTABLE_CAT字符串=>外键表目录（可能为null ）（可能为null ）
        6. FKTABLE_SCHEM字符串=>正在导出的外键表模式（可能为null ）（可能为null ）
        7. FKTABLE_NAME字符串=>正在导出的外键表名
        8. FKCOLUMN_NAME字符串=>正在导出的外键列名
        9. KEY_SEQ短=>序列号内的外键（值1表示外键的第一列中，值2将代表外键内的第二列）。
        10. UPDATE_RULE short =>主更新时外键会发生什么：
          • importedNoAction - 如果导入了主键，则不允许更新主键
          • importedKeyCascade - 更改导入的密钥以同意主密钥更新
          • importedKeySetNull - 如果其主键已更新， NULL导入的键更改为NULL
          • importedKeySetDefault - 如果其主键已更新，则将导入的键更改为默认值
          • importedKeyRestrict - 与importedKeyNoAction相同（适用于ODBC 2.x兼容性）
        11. DELETE_RULE short =>当删除主键时，外键会发生什么。
          • importedKeyNoAction - 如果导入了主键，则不允许删除主键
          • importedKeyCascade - 删除导入已删除密钥的行
          • importedKeySetNull - 如果主键已被删除， NULL导入的键更改为NULL
          • importedKeyRestrict - 与importedKeyNoAction相同（适用于ODBC 2.x兼容性）
          • importedKeySetDefault - 如果主键已被删除，则将导入的键更改为默认值
        12. FK_NAME字符串=>外键名称（可能为null ）
        13. PK_NAME字符串=>主键名称（可能为null ）
        14. DEFERRABILITY短=>可能的外键约束的评估延迟到提交
          • importedKeyInitiallyDeferred - 请参见SQL92的定义
          • importedKeyInitiallyImmediate - 请参见SQL92的定义
          • importedKeyNotDeferrable - 请参见SQL92的定义
        参数
        catalog - 目录名称;
必须匹配存储在此数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schema - 模式名称;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        table - 表名; 必须匹配存储在此数据库中的表名称
        结果
        一个 ResultSet对象，其中每行是外键列描述
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        getImportedKeys(java.lang.String, java.lang.String, java.lang.String)

      • getCrossReference

        ResultSet getCrossReference​(String parentCatalog,
                            String parentSchema,
                            String parentTable,
                            String foreignCatalog,
                            String foreignSchema,
                            String foreignTable)
                     throws SQLException
        检索引用主键的给定外键表中的外键列的描述，或表示父表的唯一约束的列（可以是相同或不同的表）。 从父表返回的列数必须与组成外键的列数匹配。 它们由FKTABLE_CAT，FKTABLE_SCHEM，FKTABLE_NAME和KEY_SEQ排序。

        每个外键列描述具有以下列：

        1. PKTABLE_CAT字符串=>父键表目录（可能为null ）
        2. PKTABLE_SCHEM字符串=>父密钥表模式（可以是null ）
        3. PKTABLE_NAME字符串=>父键表名
        4. PKCOLUMN_NAME字符串=>父键列名
        5. FKTABLE_CAT字符串=>正在导出的外键表目录（可能为null ）（可能为null ）
        6. FKTABLE_SCHEM字符串=>正在导出的外键表模式（可能为null ）（可能为null ）
        7. FKTABLE_NAME字符串=>正在导出的外键表名称
        8. FKCOLUMN_NAME字符串=>正在导出的外键列名
        9. KEY_SEQ短=>序列号内的外键（值1表示外键的第一列中，值2将代表外键内的第二列）。
        10. UPDATE_RULE short =>父键更新时外键会发生什么：
          • importedNoAction - 如果已导入，则不允许更新父键
          • importedKeyCascade - 更改导入的密钥以同意父密钥更新
          • importedKeySetNull - 如果其父键已更新， NULL导入的键更改为NULL
          • importedKeySetDefault - 如果父键被更新，则将导入的键更改为默认值
          • importedKeyRestrict - 与importedKeyNoAction相同（适用于ODBC 2.x兼容性）
        11. DELETE_RULE short =>当父键被删除时，外键会发生什么。
          • importedKeyNoAction - 如果已经导入，则不允许删除父键
          • importedKeyCascade - 删除导入已删除密钥的行
          • importedKeySetNull - 如果主键已被删除， NULL导入的键更改为NULL
          • importedKeyRestrict - 与importedKeyNoAction相同（适用于ODBC 2.x兼容性）
          • importedKeySetDefault - 如果其父键已被删除，则将导入的键更改为默认值
        12. FK_NAME字符串=>外键名称（可能为null ）
        13. PK_NAME字符串=>父密钥名称（可能为null ）
        14. DEFERRABILITY short =>可以将外键约束的评估推迟到提交之前
          • importedKeyInitiallyDeferred - 请参见SQL92的定义
          • importedKeyInitiallyImmediate - 请参见SQL92的定义
          • importedKeyNotDeferrable - 请参见SQL92的定义
        参数
        parentCatalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示从选择条件中删除目录名称
        parentSchema - 模式名称;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null表示从选择条件中删除模式名称
        parentTable - 导出密钥的表的名称; 必须匹配存储在数据库中的表名称
        foreignCatalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示从选择标准中删除目录名称
        foreignSchema - 模式名称;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null表示从选择条件中删除模式名称
        foreignTable - 导入密钥的表的名称; 必须匹配存储在数据库中的表名称
        结果
        ResultSet - 每行是外键列描述
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        getImportedKeys(java.lang.String, java.lang.String, java.lang.String)

      • getTypeInfo

        ResultSet getTypeInfo​()
               throws SQLException
        检索此数据库支持的所有数据类型的描述。 它们由DATA_TYPE排序，然后数据类型映射到相应的JDBC SQL类型。

        如果数据库支持SQL distinct类型，那么getTypeInfo（）将返回一行具有DISTINCT的TYPE_NAME和Types.DISTINCT的DATA_TYPE。 如果数据库支持SQL结构化类型，那么getTypeInfo（）将返回一个TYPE_NAME为STRUCT和DATA_TYPE为Types.STRUCT的单行。

        如果支持SQL不同或结构化类型，则可以从getUDTs（）方法获取有关各个类型的信息。

        每个类型的描述都有以下列：

        1. TYPE_NAME字符串=>类型名称
        2. DATA_TYPE int => java.sql.Types中的SQL数据类型
        3. PRECISION int =>最大精度
        4. LITERAL_PREFIX字符串=>用于引用文字的前缀（可以是null ）
        5. LITERAL_SUFFIX字符串=>用于引用文字的后缀（可能是null ）
        6. CREATE_PARAMS字符串=>用于创建类型的参数（可能为null ）
        7. NULLABLE short =>可以为此类型使用NULL。
          • typeNoNulls - 不允许NULL值
          • typeNullable - 允许NULL值
          • typeNullableUnknown - 可空性未知
        8. CASE_SENSITIVE boolean =>是区分大小写的。
        9. SEARCHABLE short =>可以使用基于此类型的“WHERE”：
          • typePredNone - 不支持
          • typePredChar - 仅支持WHERE .. LIKE
          • typePredBasic - 支持除了WHERE .. LIKE
          • typeSearchable - 支持所有WHERE ..
        10. UNSIGNED_ATTRIBUTE boolean =>是无符号的。
        11. FIXED_PREC_SCALE boolean =>可以是一个货币值。
        12. AUTO_INCREMENT boolean =>可以用于自动递增值。
        13. LOCAL_TYPE_NAME字符串=>本地化版本的类型名称（可能为null ）
        14. MINIMUM_SCALE短=>支持最小比例
        15. 最大尺寸MAXIMUM_SCALE =>
        16. 未使用SQL_DATA_TYPE int =>
        17. SQL_DATETIME_SUB int =>未使用
        18. NUM_PREC_RADIX int =>通常为2或10

        PRECISION列表示服务器为给定数据类型支持的最大列大小。 对于数值数据，这是最大精度。 对于字符数据，这是字符长度。 对于datetime数据类型，这是String表示形式的长度（假定分数秒分量的最大允许精度）。 对于二进制数据，这是以字节为单位的长度。 对于ROWID数据类型，这是以字节为单位的长度。 对于列大小不适用的数据类型，返回空值。

        结果
        一个 ResultSet对象，其中每行都是SQL类型描述
        异常
        SQLException - 如果发生数据库访问错误

      • getIndexInfo

        ResultSet getIndexInfo​(String catalog,
                       String schema,
                       String table,
                       boolean unique,
                       boolean approximate)
                throws SQLException
        检索给定表的索引和统计信息的描述。 它们由NON_UNIQUE，TYPE，INDEX_NAME和ORDINAL_POSITION命令。

        每个索引列描述具有以下列：

        1. TABLE_CAT字符串=>表目录（可能为null ）
        2. TABLE_SCHEM字符串=>表模式（可以是null ）
        3. TABLE_NAME字符串=>表名
        4. NON_UNIQUE boolean =>索引值不唯一。 TYPE为tableIndexStatistic时为false
        5. INDEX_QUALIFIER字符串=>索引目录（可能为null ）; 当TYPE为tableIndexStatistic时，为null
        6. INDEX_NAME字符串=>索引名称; 当TYPE为tableIndexStatistic时，为null
        7. TYPE short =>索引类型：
          • tableIndexStatistic - 这将标识与表索引描述一起返回的表统计信息
          • tableIndexClustered - 这是一个聚簇索引
          • tableIndexHashed - 这是一个散列索引
          • tableIndexOther - 这是其他风格的索引
        8. ORDINAL_POSITION短=>索引中的列序列号; TYPE为tableIndexStatistic时为零
        9. COLUMN_NAME字符串=>列名称; 当TYPE为tableIndexStatistic时，为null
        10. ASC_OR_DESC字符串=>列排序序列，“A” =>升序，“D” =>降序，如果不支持排序顺序，可以是null ; 当TYPE为tableIndexStatistic时，为null
        11. CARDINALITY long =>当TYPE是tableIndexStatistic时，这是表中的行数; 否则，它是索引中唯一值的数量。
        12. PAGES long =>当TYPE是tableIndexStatistic时，这是用于表的页数，否则是当前索引使用的页数。
        13. FILTER_CONDITION字符串=>过滤条件（如果有）。 （可以是null ）
        参数
        catalog - 目录名称;
必须匹配存储在此数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schema - 模式名称;
必须与存储在此数据库中的模式名称相匹配;
“”检索没有模式的那些;
null表示不应该使用模式名称来缩小搜索范围
        table - 表名; 必须匹配存储在此数据库中的表名称
        unique - 如果为true，则只返回唯一值的索引; 当假，返回指数，不管是否唯一
        approximate - 如果为true，则允许结果反映近似值或数据值; 如果虚假，请求结果准确
        结果
        ResultSet - 每行是索引列描述
        异常
        SQLException - 如果发生数据库访问错误

      • supportsResultSetType

        boolean supportsResultSetType​(int type)
                       throws SQLException
        检索此数据库是否支持给定的结果集类型。
        参数
        type - 在 java.sql.ResultSet定义
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2
        另请参见：
        Connection

      • supportsResultSetConcurrency

        boolean supportsResultSetConcurrency​(int type,
                                     int concurrency)
                              throws SQLException
        检索此数据库是否支持给定的并发类型与给定的结果集类型的组合。
        参数
        type - 在 java.sql.ResultSet定义
        concurrency - 在 java.sql.ResultSet定义的 java.sql.ResultSet
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2
        另请参见：
        Connection

      • ownUpdatesAreVisible

        boolean ownUpdatesAreVisible​(int type)
                      throws SQLException
        检索是否为给定类型的 ResultSet对象，结果集的自己的更新是可见的。
        参数
        type - ResultSet型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        结果
        true如果给定结果集类型的更新可见; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • ownDeletesAreVisible

        boolean ownDeletesAreVisible​(int type)
                      throws SQLException
        检索结果集自身的删除是否可见。
        参数
        type - ResultSet型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        结果
        true如果删除对于给定的结果集类型可见; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • ownInsertsAreVisible

        boolean ownInsertsAreVisible​(int type)
                      throws SQLException
        检索结果集是否可以看到自己的插入。
        参数
        type - ResultSet型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        结果
        true如果给定的结果集类型的插入是可见的; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • othersUpdatesAreVisible

        boolean othersUpdatesAreVisible​(int type)
                         throws SQLException
        检索其他人所做的更新是否可见。
        参数
        type - ResultSet型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        结果
        true如果其他人所做的更新对于给定的结果集类型可见; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • othersDeletesAreVisible

        boolean othersDeletesAreVisible​(int type)
                         throws SQLException
        检索他人删除是否可见。
        参数
        type - ResultSet类型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        结果
        true如果其他人所做的删除对于给定的结果集类型可见; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • othersInsertsAreVisible

        boolean othersInsertsAreVisible​(int type)
                         throws SQLException
        检索他人所做的插入是否可见。
        参数
        type - ResultSet型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        结果
        true如果其他人所做的插入对于给定的结果集类型可见; false否则
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • updatesAreDetected

        boolean updatesAreDetected​(int type)
                    throws SQLException
        检索是否可以通过调用方法 ResultSet.rowUpdated检测到可见行更新。
        参数
        type - ResultSet型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        结果
        true如果结果集类型检测到更改; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • deletesAreDetected

        boolean deletesAreDetected​(int type)
                    throws SQLException
        检索是否可以通过调用方法ResultSet.rowDeleted检测到可见行删除。 如果方法deletesAreDetected返回false ，则意味着删除的行将从结果集中删除。
        参数
        type - ResultSet类型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        结果
        true如果由给定的结果集类型检测到删除; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • insertsAreDetected

        boolean insertsAreDetected​(int type)
                    throws SQLException
        检索是否通过调用方法 ResultSet.rowInserted检测到可见行插入。
        参数
        type - ResultSet型; 之一ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或ResultSet.TYPE_SCROLL_SENSITIVE
        结果
        true如果由指定的结果集类型检测到更改; false否则
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • supportsBatchUpdates

        boolean supportsBatchUpdates​()
                      throws SQLException
        检索此数据库是否支持批量更新。
        结果
        true如果此数据库支持批量更新; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • getUDTs

        ResultSet getUDTs​(String catalog,
                  String schemaPattern,
                  String typeNamePattern,
                  int[] types)
           throws SQLException
        检索在特定模式中定义的用户定义类型（UDT）的描述。 架构特定的UDT可具有型JAVA_OBJECT ， STRUCT ，或DISTINCT 。

        只返回匹配目录，模式，类型名称和类型条件的类型。 他们被下令DATA_TYPE ， TYPE_CAT ， TYPE_SCHEM和TYPE_NAME 。 type name参数可能是一个完全限定名称。 在这种情况下，目录和schemaPattern参数将被忽略。

        每个类型的描述都有以下列：

        1. TYPE_CAT字符串=>该类型的目录（可能是null ）
        2. TYPE_SCHEM字符串=>类型的模式（可以是null ）
        3. TYPE_NAME字符串=>类型名称
        4. CLASS_NAME String => Java类名
        5. DATA_TYPE int => java.sql.Types中定义的类型值。 JAVA_OBJECT，STRUCT或DISTINCT之一
        6. 备注字符串=>对类型的解释性注释
        7. BASE_TYPE short => DISTINCT类型的源类型的类型代码或实现java.sql.Types中定义的结构化类型的SELF_REFERENCING_COLUMN的用户生成的引用类型的类型（ null如果DATA_TYPE不是DISTINCT或不是STRUCT与null REFERENCE_GENERATION = USER_DEFINED）

        注意：如果驱动程序不支持UDT，则返回空结果集。

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式模式名称;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        typeNamePattern - 类型名称模式; 必须匹配存储在数据库中的类型名称; 可能是一个完全合格的名称
        types - 要包含的用户定义类型（JAVA_OBJECT，STRUCT或DISTINCT）的列表; null返回所有类型
        结果
        ResultSet对象，其中每行描述一个UDT
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2
        另请参见：
        getSearchStringEscape()

      • getConnection

        Connection getConnection​()
                  throws SQLException
        检索生成此元数据对象的连接。
        结果
        生成此元数据对象的连接
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2

      • supportsSavepoints

        boolean supportsSavepoints​()
                    throws SQLException
        检索此数据库是否支持保存点。
        结果
        true如果保存点被支持; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • supportsNamedParameters

        boolean supportsNamedParameters​()
                         throws SQLException
        检索此数据库是否支持可调用语句的命名参数。
        结果
        true如果命名参数被支持; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • supportsMultipleOpenResults

        boolean supportsMultipleOpenResults​()
                             throws SQLException
        检索是否有可能具有多个 ResultSet从返回的对象 CallableStatement对象同时进行。
        结果
        true如果一个CallableStatement对象可以同时返回多个ResultSet对象; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • supportsGetGeneratedKeys

        boolean supportsGetGeneratedKeys​()
                          throws SQLException
        检索在执行语句后是否可以检索自动生成的键
        结果
        true如果在执行语句后可以检索自动生成的键; 否则为false

        如果返回true ，则JDBC驱动程序必须支持至少返回SQL INSERT语句的自动生成的密钥

        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getSuperTypes

        ResultSet getSuperTypes​(String catalog,
                        String schemaPattern,
                        String typeNamePattern)
                 throws SQLException
        检索此数据库中特定模式中定义的用户定义类型（UDT）层次结构的描述。 只有立即超类型/子类型关系被建模。

        仅返回与目录，模式和类型名称匹配的UDT的超类型信息。 type name参数可能是一个完全限定名称。 当提供的UDT名称是完全限定名称时，将忽略catalog和schemaPattern参数。

        如果UDT没有直接超类型，那么它不在这里列出。 该方法返回的一行ResultSet对象描述了指定的UDT和一个直接超类型。 一行有以下列：

        1. TYPE_CAT字符串=> UDT的目录（可能是null ）
        2. TYPE_SCHEM字符串=> UDT的模式（可以是null ）
        3. TYPE_NAME字符串=> UDT的类型名称
        4. SUPERTYPE_CAT字符串=>直接超类型的目录（可能是null ）
        5. SUPERTYPE_SCHEM字符串=>直接超类型的模式（可能是null ）
        6. SUPERTYPE_NAME字符串=>直接超类型的名称

        注意：如果驱动程序不支持类型层次结构，则返回空结果集。

        参数
        catalog - 目录名称; “”检索没有目录的那些; null表示从选择标准中删除目录名称
        schemaPattern - 模式名称模式; “”检索没有模式的那些
        typeNamePattern - 一个UDT名称模式; 可能是一个完全合格的名称
        结果
        一个 ResultSet对象，其中一行提供有关指定UDT的信息
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4
        另请参见：
        getSearchStringEscape()

      • getSuperTables

        ResultSet getSuperTables​(String catalog,
                         String schemaPattern,
                         String tableNamePattern)
                  throws SQLException
        检索此数据库中特定模式中定义的表层次结构的描述。

        仅返回与目录，模式和表名称匹配的表的超级信息。 表名称参数可能是完全限定名称，在这种情况下，将忽略catalog和schemaPattern参数。 如果表没有超级表，则不在此处列出。 必须在与子表相同的目录和模式中定义超级。 因此，该类型描述不需要包含该信息为supertable。

        每个类型的描述都有以下列：

        1. TABLE_CAT字符串=>该类型的目录（可能是null ）
        2. TABLE_SCHEM字符串=>类型的模式（可为null ）
        3. TABLE_NAME字符串=>类型名称
        4. SUPERTABLE_NAME字符串=>的直接超类型的名称

        注意：如果驱动程序不支持类型层次结构，则返回空结果集。

        参数
        catalog - 目录名称; “”检索没有目录的那些; null表示从选择条件中删除目录名称
        schemaPattern - 模式名称模式; “”检索没有模式的那些
        tableNamePattern - 表名称模式; 可能是一个完全合格的名称
        结果
        一个 ResultSet对象，其中每行是一个类型描述
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4
        另请参见：
        getSearchStringEscape()

      • getAttributes

        ResultSet getAttributes​(String catalog,
                        String schemaPattern,
                        String typeNamePattern,
                        String attributeNamePattern)
                 throws SQLException
        检索给定模式和目录中可用的用户定义类型（UDT）给定类型的给定属性的描述。

        仅针对与目录，模式，类型和属性名称标准匹配的UDT的属性返回说明。 他们被下令TYPE_CAT ， TYPE_SCHEM ， TYPE_NAME和ORDINAL_POSITION 。 此描述不包含继承的属性。

        返回的ResultSet对象具有以下列：

        1. TYPE_CAT字符串=>类型目录（可能为null ）
        2. TYPE_SCHEM字符串=>类型模式（可以是null ）
        3. TYPE_NAME字符串=>类型名称
        4. ATTR_NAME字符串=>属性名称
        5. DATA_TYPE int =>属性类型来自java.sql.Types的SQL类型
        6. ATTR_TYPE_NAME字符串=>数据源相关类型名称。 对于UDT，类型名称是完全限定的。 对于REF，类型名称是完全限定的，并且表示引用类型的目标类型。
        7. ATTR_SIZE int =>列大小。 对于char或date类型，这是最大字符数; 对于数字或十进制类型，这是精度。
        8. DECIMAL_DIGITS int =>小数位数。 对于DECIMAL_DIGITS不适用的数据类型，返回空值。
        9. NUM_PREC_RADIX int =>基数（通常为10或2）
        10. NULLABLE int =>是否允许NULL
          • attributeNoNulls - 可能不允许NULL值
          • attributeNullable - 绝对允许NULL值
          • attributeNullableUnknown - 可空性未知
        11. 备注字符串=>注释描述列（可能为null ）
        12. ATTR_DEF字符串=>默认值（可能为null ）
        13. 未使用SQL_DATA_TYPE int =>
        14. SQL_DATETIME_SUB int =>未使用
        15. CHAR_OCTET_LENGTH int =>用于char类型列中最大字节数
        16. ORDINAL_POSITION int => UDT属性的索引（从1开始）
        17. IS_NULLABLE字符串=> ISO规则用于确定属性的可空性。
          • YES ---如果属性可以包含NULL
          • 否---如果属性不能包含NULL
          • 空字符串---如果属性的可空性是未知的
        18. SCOPE_CATALOG字符串=>作为参考属性范围的表目录（如果DATA_TYPE不是REF， null ）
        19. SCOPE_SCHEMA字符串=>作为参考属性范围的表的模式（如果DATA_TYPE不是REF， null ）
        20. SCOPE_TABLE字符串=>作为参考属性范围的表名（如果DATA_TYPE不是REF， null ）
        21. SOURCE_DATA_TYPE short =>不同类型或用户生成的引用类型的源类型，java.sql.Types中的SQL类型（如果DATA_TYPE不是DISTINCT或用户生成的REF， null ）
        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式名称模式;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        typeNamePattern - 类型名称模式; 必须匹配存储在数据库中的类型名称
        attributeNamePattern - 属性名称模式; 必须匹配在数据库中声明的属性名称
        结果
        一个 ResultSet对象，其中每行是属性描述
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4
        另请参见：
        getSearchStringEscape()

      • supportsResultSetHoldability

        boolean supportsResultSetHoldability​(int holdability)
                              throws SQLException
        检索此数据库是否支持给定的结果集保持性。
        参数
        holdability - 以下常数之一： ResultSet.HOLD_CURSORS_OVER_COMMIT或 ResultSet.CLOSE_CURSORS_AT_COMMIT
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4
        另请参见：
        Connection

      • getResultSetHoldability

        int getResultSetHoldability​()
                     throws SQLException
        检索 ResultSet对象的数据库的默认保持 ResultSet 。
        结果
        默认保持性; ResultSet.HOLD_CURSORS_OVER_COMMIT或ResultSet.CLOSE_CURSORS_AT_COMMIT
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getDatabaseMajorVersion

        int getDatabaseMajorVersion​()
                     throws SQLException
        检索底层数据库的主版本号。
        结果
        底层数据库的主要版本
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getDatabaseMinorVersion

        int getDatabaseMinorVersion​()
                     throws SQLException
        检索底层数据库的次要版本号。
        结果
        底层数据库的次要版本
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getJDBCMajorVersion

        int getJDBCMajorVersion​()
                 throws SQLException
        检索此驱动程序的主要JDBC版本号。
        结果
        JDBC版主要号码
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getJDBCMinorVersion

        int getJDBCMinorVersion​()
                 throws SQLException
        检索此驱动程序的次要JDBC版本号。
        结果
        JDBC版本次要号码
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getSQLStateType

        int getSQLStateType​()
             throws SQLException
        指示 SQLException.getSQLState返回的SQLSTATE是X / Open（现在称为Open Group）SQL CLI或SQL：2003。
        结果
        SQLSTATE的类型; 其中之一：sqlStateXOpen或sqlStateSQL
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • locatorsUpdateCopy

        boolean locatorsUpdateCopy​()
                    throws SQLException
        指示对LOB进行的更新是在副本上还是直接进行到LOB。
        结果
        如果对LOB的副本进行更新， true ; false如果更新直接进行了LOB
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • supportsStatementPooling

        boolean supportsStatementPooling​()
                          throws SQLException
        检索此数据库是否支持语句池。
        结果
        true如果是的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getRowIdLifetime

        RowIdLifetime getRowIdLifetime​()
                        throws SQLException
        指示此数据源是否支持SQL ROWID类型，以及RowId对象保持有效的生命周期。
        结果
        表示生命的状态为 RowId
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.6

      • getSchemas

        ResultSet getSchemas​(String catalog,
                     String schemaPattern)
              throws SQLException
        检索此数据库中可用的模式名称。 结果按TABLE_CATALOG和TABLE_SCHEM 。

        模式列为：

        1. TABLE_SCHEM字符串=>模式名称
        2. TABLE_CATALOG字符串=>目录名称（可能为null ）
        参数
        catalog - 目录名称; 必须匹配存储在数据库中的目录名称;“”检索没有目录的目录; null表示目录名称不应用于缩小搜索范围。
        schemaPattern - 模式名称; 必须匹配存储在数据库中的模式名称; null表示模式名称不应用于缩小搜索范围。
        结果
        一个 ResultSet对象，其中每一行都是模式描述
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.6
        另请参见：
        getSearchStringEscape()

      • supportsStoredFunctionsUsingCallSyntax

        boolean supportsStoredFunctionsUsingCallSyntax​()
                                        throws SQLException
        检索此数据库是否支持使用存储过程转义语法调用用户定义或供应商功能。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.6

      • autoCommitFailureClosesAllResultSets

        boolean autoCommitFailureClosesAllResultSets​()
                                      throws SQLException
        检索一个SQLException而autoCommit是true表示所有打开的ResultSet是关闭的，即使是可保留的。 当自动提交为SQLException时出现true ，由供应商决定，JDBC驱动程序是否使用提交操作，回滚操作或既不执行提交也不回滚。 这种差异的潜在结果是可否保存的ResultSet是否关闭。
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.6

      • getClientInfoProperties

        ResultSet getClientInfoProperties​()
                           throws SQLException
        检索驱动程序支持的客户端信息属性的列表。 结果集包含以下列
        1. NAME字符串=>客户端信息属性的名称
        2. MAX_LEN int =>属性值的最大长度
        3. DEFAULT_VALUE字符串=>属性的默认值
        4. DESCRIPTION字符串=>属性的描述。 这通常包含有关数据库中存储该属性的信息。

        ResultSet按NAME列排序

        结果
        一个ResultSet对象; 每行都是支持的客户端信息属性
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.6

      • getFunctions

        ResultSet getFunctions​(String catalog,
                       String schemaPattern,
                       String functionNamePattern)
                throws SQLException
        检索给定目录中可用的系统和用户功能的描述。

        只返回与模式和函数名称标准相匹配的系统和用户函数说明。 他们被下令FUNCTION_CAT ， FUNCTION_SCHEM ， FUNCTION_NAME和SPECIFIC_ NAME 。

        每个功能描述都有以下列：

        1. FUNCTION_CAT字符串=>功能目录（可能为null ）
        2. FUNCTION_SCHEM字符串=>函数模式（可能是null ）
        3. FUNCTION_NAME字符串=>函数名。 这是用于调用该函数的名称
        4. 备注字符串=>对功能的解释性注释
        5. FUNCTION_TYPE短=>种功能：
          • functionResultUnknown - 无法确定是否返回值或表
          • functionNoTable - 不返回表
          • functionReturnsTable - 返回一个表
        6. SPECIFIC_NAME字符串=>在其模式中唯一标识此函数的名称。 这是一个用户指定的，或DBMS生成的名称，可能与FUNCTION_NAME不同，例如具有过载功能

        用户可能没有执行getFunctions返回的任何功能的getFunctions

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式名称模式;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null表示不应该使用模式名称来缩小搜索范围
        functionNamePattern - 函数名称模式; 必须匹配存储在数据库中的函数名称
        结果
        ResultSet - 每行是一个函数描述
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.6
        另请参见：
        getSearchStringEscape()

      • getFunctionColumns

        ResultSet getFunctionColumns​(String catalog,
                             String schemaPattern,
                             String functionNamePattern,
                             String columnNamePattern)
                      throws SQLException
        检索给定目录的系统或用户功能参数和返回类型的描述。

        仅返回与模式，函数和参数名称标准相匹配的描述。 他们被下令FUNCTION_CAT ， FUNCTION_SCHEM ， FUNCTION_NAME和SPECIFIC_ NAME 。 在这里，返回值（如果有的话）是第一个。 接下来是呼叫顺序中的参数说明。 列描述按照列号顺序。

        ResultSet中的每一行是一个参数描述，列描述或返回类型描述，具有以下字段：

        1. FUNCTION_CAT字符串=>功能目录（可能为null ）
        2. FUNCTION_SCHEM字符串=>函数模式（可以是null ）
        3. FUNCTION_NAME字符串=>函数名。 这是用于调用该函数的名称
        4. COLUMN_NAME字符串=>列/参数名称
        5. COLUMN_TYPE Short =>种列/参数：
          • functionColumnUnknown - 没人知道
          • functionColumnIn - IN参数
          • functionColumnInOut - INOUT参数
          • functionColumnOut - OUT参数
          • functionColumnReturn - 函数返回值
          • functionColumnResult - 表示参数或列是ResultSet的列
        6. DATA_TYPE int => java.sql.Types中的SQL类型
        7. TYPE_NAME字符串=> SQL类型名称，对于UDT类型，类型名称是完全限定的
        8. PRECISION int =>精度
        9. LENGTH int =>以字节为单位的数据长度
        10. SCALE short => scale - 对于SCALE不适用的数据类型，返回null。
        11. RADIX短=>基数
        12. NULLABLE short =>可以包含NULL。
          • functionNoNulls - 不允许NULL值
          • functionNullable - 允许NULL值
          • functionNullableUnknown - 可空性未知
        13. 备注字符串=>注释描述列/参数
        14. CHAR_OCTET_LENGTH int =>二进制和基于字符的参数或列的最大长度。 对于任何其他数据类型，返回的值为NULL
        15. ORDINAL_POSITION int =>序数位置，从1开始，用于输入和输出参数。 如果此行描述函数的返回值，则返回值为0。 对于结果集列，它是从1开始的结果集中的列的顺序位置。
        16. IS_NULLABLE字符串=> ISO规则用于确定参数或列的可空性。
          • YES ---如果参数或列可以包含NULL
          • 否---如果参数或列不能包含NULL
          • 空字符串---如果参数或列的可空性是未知的
        17. SPECIFIC_NAME字符串=>在其模式中唯一标识此函数的名称。 这是一个用户指定的或DBMS生成的名称，可能与FUNCTION_NAME不同，例如具有过载功能

        PRECISION列表示给定参数或列的指定列大小。 对于数值数据，这是最大精度。 对于字符数据，这是字符长度。 对于datetime数据类型，这是String表示形式的长度（假定分数秒分量的最大允许精度）。 对于二进制数据，这是以字节为单位的长度。 对于ROWID数据类型，这是以字节为单位的长度。 对于列大小不适用的数据类型，返回空值。

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式名称模式;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        functionNamePattern - 过程名称模式; 必须匹配存储在数据库中的函数名称
        columnNamePattern - 参数名称模式; 必须匹配存储在数据库中的参数或列名称
        结果
        ResultSet - 每行描述用户函数参数，列或返回类型
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.6
        另请参见：
        getSearchStringEscape()

      • getPseudoColumns

        ResultSet getPseudoColumns​(String catalog,
                           String schemaPattern,
                           String tableNamePattern,
                           String columnNamePattern)
                    throws SQLException
        检索指定目录和模式中给定表中可用的伪列或隐藏列的描述。 伪列或隐藏列可能不总是存储在表中，并且在ResultSet中不可见，除非它们在查询的最外面的SELECT列表中指定。 伪列或隐藏列可能不一定能够被修改。 如果没有伪列或隐藏列，则返回一个空的ResultSet。

        仅返回与目录，模式，表和列名称标准相匹配的列描述。 他们被下令TABLE_CAT ， TABLE_SCHEM ， TABLE_NAME和COLUMN_NAME 。

        每列描述具有以下列：

        1. TABLE_CAT字符串=>表目录（可能为null ）
        2. TABLE_SCHEM字符串=>表模式（可以是null ）
        3. TABLE_NAME字符串=>表名
        4. COLUMN_NAME字符串=>列名称
        5. DATA_TYPE int => java.sql.Types中的SQL类型
        6. COLUMN_SIZE int =>列大小。
        7. DECIMAL_DIGITS int =>小数位数。 对于DECIMAL_DIGITS不适用的数据类型，返回空值。
        8. NUM_PREC_RADIX int =>基数（通常为10或2）
        9. COLUMN_USAGE字符串=>列的允许使用。 返回的值将对应于由PseudoColumnUsage.name()返回的枚举名称
        10. 备注字符串=>注释描述列（可以是null ）
        11. CHAR_OCTET_LENGTH int =>用于char类型列中最大字节数
        12. IS_NULLABLE字符串=> ISO规则用于确定列的可空性。
          • YES ---如果列可以包含NULL
          • 否---如果列不能包含NULL
          • 空字符串---如果列的可空性是未知的

        COLUMN_SIZE列指定给定列的列大小。 对于数值数据，这是最大精度。 对于字符数据，这是字符长度。 对于datetime数据类型，这是String表示形式的长度（假定分数秒分量的最大允许精度）。 对于二进制数据，这是以字节为单位的长度。 对于ROWID数据类型，这是以字节为单位的长度。 对于列大小不适用的数据类型，返回空值。

        参数
        catalog - 目录名称;
必须匹配存储在数据库中的目录名称;
“”检索没有目录的那些;
null表示目录名称不应用于缩小搜索范围
        schemaPattern - 模式名称模式;
必须匹配存储在数据库中的模式名称;
“”检索没有模式的那些;
null意味着不应该使用模式名称来缩小搜索范围
        tableNamePattern - 表名模式; 必须匹配存储在数据库中的表名称
        columnNamePattern - 列名称模式; 必须匹配存储在数据库中的列名称
        结果
        ResultSet - 每行都是列描述
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.7
        另请参见：
        PseudoColumnUsage

      • generatedKeyAlwaysReturned

        boolean generatedKeyAlwaysReturned​()
                            throws SQLException
        检索如果为自动生成的密钥列指定的列名称或索引有效并且语句成功，将始终返回生成的密钥。 返回的密钥可能基于或不基于自动生成的密钥的列。 有关其他详细信息，请参阅JDBC驱动程序文档
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.7

      • getMaxLogicalLobSize

        default long getMaxLogicalLobSize​()
                           throws SQLException
        检索此数据库允许LOB的逻辑大小的最大字节数。

        默认实现将返回0

        结果
        允许的最大字节数; 零的结果意味着没有限制或限制是不知道的
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.8

      • supportsRefCursors

        default boolean supportsRefCursors​()
                            throws SQLException
        检索此数据库是否支持REF CURSOR。

        默认实现将返回false

        结果
        true如果这个数据库支持REF CURSOR; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.8

      • supportsSharding

        default boolean supportsSharding​()
                          throws SQLException
        检索此数据库是否支持分片。
        实现要求：
        默认实现将返回 false
        结果
        true如果这个数据库支持分片; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DataTruncation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class DataTruncation

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLWarning
            • java.sql.DataTruncation
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class DataTruncation
extends SQLWarning
    由于其超出MaxFieldSize原因，数据值意外截断时，异常抛出DataTruncation异常（写入）或报告为DataTruncation警告（读取时）。

    读取期间的DataTruncation的DataTruncation为01004 。

    写入期间的DataTruncation的DataTruncation为22001 。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataTruncation​(int index, boolean parameter, boolean read, int dataSize, int transferSize)
      创建 DataTruncation与初始化为01004时的SQLState对象 read设定为 true时和22001 read设定为 false ，设置为“数据截断”，供应商代码设置为0的原因，而其他字段被设置为给定值。
      DataTruncation​(int index, boolean parameter, boolean read, int dataSize, int transferSize, Throwable cause)
      创建 DataTruncation与初始化为01004时的SQLState对象 read设定为 true时和22001 read设定为 false ，设置为“数据截断”，供应商代码设置为0的原因，而其他字段被设置为给定值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getDataSize​()
      获取应该传输的数据的字节数。
      int getIndex​()
      检索被截断的列或参数的索引。
      boolean getParameter​()
      指示truncated的值是参数值还是列值。
      boolean getRead​()
      指示值是否在读取时被截断。
      int getTransferSize​()
      获取实际传输的数据的字节数。

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.sql.SQLWarning

        getNextWarning, setNextWarning

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • DataTruncation

        public DataTruncation​(int index,
                      boolean parameter,
                      boolean read,
                      int dataSize,
                      int transferSize)
        创建DataTruncation与初始化为01004时的SQLState对象read设定为true时和22001 read设定为false ，设置为“数据截断”，供应商代码设置为0的原因，而其他字段被设置为给定值。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        index - 参数或列值的索引
        parameter - 如果参数值被截断， parameter true
        read - 如果读取被截断， read true
        dataSize - 数据的原始大小
        transferSize - 截断后的大小

      • DataTruncation

        public DataTruncation​(int index,
                      boolean parameter,
                      boolean read,
                      int dataSize,
                      int transferSize,
                      Throwable cause)
        创建 DataTruncation与初始化为01004时的SQLState对象 read设定为 true时和22001 read设定为 false ，设置为“数据截断”，供应商代码设置为0的原因，而其他字段被设置为给定值。
        参数
        index - 参数或列值的索引
        parameter - 如果参数值被截断， parameter true
        read - 如果读取被截断， read true
        dataSize - 数据的原始大小
        transferSize - 截断后的大小
        cause - DataTruncation （其保存以供getCause()方法稍后检索）的根本原因; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

    • 方法详细信息

      • getIndex

        public int getIndex​()
        检索被截断的列或参数的索引。

        如果列或参数索引未知，则可能为-1，在这种情况下，应忽略parameter和read字段。

        结果
        截断的参数或列值的索引

      • getParameter

        public boolean getParameter​()
        指示truncated的值是参数值还是列值。
        结果
        true如果truncated的值是一个参数; false如果它是列值

      • getRead

        public boolean getRead​()
        指示值是否在读取时被截断。
        结果
        true如果从数据库读取值被截断; false如果数据在写入时被截断

      • getDataSize

        public int getDataSize​()
        获取应该传输的数据的字节数。 如果正在执行数据转换，此数字可能是近似值。 如果大小未知，则该值可能为-1 。
        结果
        应该传输的数据的字节数

      • getTransferSize

        public int getTransferSize​()
        获取实际传输的数据的字节数。 如果大小未知，则该值可能为-1 。
        结果
        实际传输的数据的字节数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Date (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class Date

  • java.lang.Object
    • java.util.Date
      • java.sql.Date
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Comparable<Date>

    public class Date
extends Date

    大约一毫秒值的薄包装，允许JDBC将其标识为SQL DATE值。 毫秒值表示1970年1月1日00：00：00.000 GMT之后的毫秒数。

    为了符合SQL DATE的定义，由java.sql.Date实例包装的毫秒值必须通过将实例关联的特定时区中的小时，分钟，秒和毫秒设置为零来进行“归一化”。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Date​(int year, int month, int day)
      已过时。
      而是使用构造函数Date(long date)
      Date​(long date)
      使用给定的毫秒时间值构造一个 Date对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int getHours​()
      已过时。
      int getMinutes​()
      已过时。
      int getSeconds​()
      已过时。
      void setHours​(int i)
      已过时。
      void setMinutes​(int i)
      已过时。
      void setSeconds​(int i)
      已过时。
      void setTime​(long date)
      使用给定的毫秒时间值设置现有的 Date对象。
      Instant toInstant​()
      此方法总是引发UnsupportedOperationException，因为SQL Date值没有时间组件，因此不应该使用此方法。
      LocalDate toLocalDate​()
      使用这个 Date对象的年，月和日创建一个 LocalDate实例。
      String toString​()
      格式化日期转义格式yyyy-mm-dd。
      static Date valueOf​(String s)
      将JDBC日期转义格式的字符串转换为 Date值。
      static Date valueOf​(LocalDate date)
      从LocalDate对象获取一个Date的实例，具有与给定的LocalDate相同的年，月和日的值。

      • Methods inherited from class java.util.Date

        after, before, clone, compareTo, equals, from, getDate, getDay, getMonth, getTime, getTimezoneOffset, getYear, hashCode, parse, setDate, setMonth, setYear, toGMTString, toLocaleString, UTC

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Date

        @Deprecated(since="1.2")
public Date​(int year,
            int month,
            int day)
        已过时。 而是使用构造函数Date(long date)
        构造一个以给定的年，月和日初始化的Date对象。

        如果给定的参数超出界限，结果是未定义的。

        参数
        year - 年减1900; 必须是0到8099.（注意8099是9999减1900。）
        month - 0至11
        day - 1至31

      • Date

        public Date​(long date)
        使用给定的毫秒时间值构造一个Date对象。 如果给定的毫秒值包含时间信息，则驱动程序将将时间组件设置为对应于零GMT的默认时区（运行应用程序的Java虚拟机的时区）。
        参数
        date - 1970年1月1日以来的毫秒数，00:00:00 GMT不超过8099年的毫秒表示。负数表示1970年1月1日00:00:00 GMT之前的毫秒数。

    • 方法详细信息

      • setTime

        public void setTime​(long date)
        使用给定的毫秒时间值设置现有的Date对象。 如果给定的毫秒值包含时间信息，则驱动程序将将时间组件设置为对应于零GMT的默认时区（运行应用程序的Java虚拟机的时区）。
        重写：
        setTime在类 Date
        参数
        date - 1970年1月1日以来的毫秒数，00:00:00 GMT不超过8099年的毫秒表示。负数表示1970年1月1日00:00:00 GMT之前的毫秒数。

      • valueOf

        public static Date valueOf​(String s)
        将JDBC日期转义格式的字符串转换为 Date值。
        参数
        s - 表示格式为“yyyy- [m] m- [d] d”的日期的String对象。 也可以省略mm和dd的前导零。
        结果
        表示给定日期的 java.sql.Date对象
        异常
        IllegalArgumentException - 如果给定的日期不在JDBC日期转义格式（yyyy- [m] m- [d] d）

      • toString

        public String toString​()
        格式化日期转义格式yyyy-mm-dd。
        重写：
        toString在 Date
        结果
        一个以yyyy-mm-dd格式的字符串
        另请参见：
        Date.toLocaleString() ， Date.toGMTString()

      • getHours

        @Deprecated(since="1.2")
public int getHours​()
        已过时。
        X- 20045 X-
        重写：
        getHours在类 Date
        结果
        这个日期代表的时间。
        异常
        IllegalArgumentException - 如果调用此方法
        另请参见：
        setHours(int)

      • getMinutes

        @Deprecated(since="1.2")
public int getMinutes​()
        已过时。
        X- 20045 X-
        重写：
        getMinutes在 Date
        结果
        由该日期表示的小时数。
        异常
        IllegalArgumentException - 如果这个方法被调用
        另请参见：
        setMinutes(int)

      • getSeconds

        @Deprecated(since="1.2")
public int getSeconds​()
        已过时。
        X- 20045 X-
        重写：
        getSeconds在 Date
        结果
        由此日期表示的分钟秒数。
        异常
        IllegalArgumentException - 如果这个方法被调用
        另请参见：
        setSeconds(int)

      • setHours

        @Deprecated(since="1.2")
public void setHours​(int i)
        已过时。
        X- 20045 X-
        重写：
        setHours在 Date
        参数
        i - 小时值。
        异常
        IllegalArgumentException - 如果调用此方法
        另请参见：
        getHours()

      • setMinutes

        @Deprecated(since="1.2")
public void setMinutes​(int i)
        已过时。
        X- 20045 X-
        重写：
        setMinutes在类 Date
        参数
        i - 分钟的值。
        异常
        IllegalArgumentException - 如果调用此方法
        另请参见：
        getMinutes()

      • setSeconds

        @Deprecated(since="1.2")
public void setSeconds​(int i)
        已过时。
        X- 20045 X-
        重写：
        setSeconds在 Date
        参数
        i - 秒值。
        异常
        IllegalArgumentException - 如果调用此方法
        另请参见：
        getSeconds()

      • valueOf

        public static Date valueOf​(LocalDate date)
        从LocalDate对象获取一个Date的实例，具有与给定的LocalDate相同的年，月和日的值。

        提供的LocalDate被解释为本地时区的本地日期。

        参数
        date - a转换 LocalDate
        结果
        一个 Date对象
        异常
        NullPointerException - 如果 date为空
        从以下版本开始：
        1.8

      • toLocalDate

        public LocalDate toLocalDate​()
        使用这个 Date对象的年，月和日创建一个 LocalDate实例。
        结果
        表示相同日期值的 LocalDate对象
        从以下版本开始：
        1.8

      • toInstant

        public Instant toInstant​()
        此方法总是引发UnsupportedOperationException，因为SQL Date值没有时间组件，因此不应该使用此方法。
        重写：
        toInstant在类 Date
        结果
        表示与 Date对象在时间线上相同点的瞬间
        异常
        UnsupportedOperationException - if this method is invoked
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Driver (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Driver

  • public interface Driver
    每个驱动程序类必须实现的接口。

    Java SQL框架允许多个数据库驱动程序。

    每个驱动程序都应该提供一个实现Driver接口的类。

    DriverManager将尝试加载尽可能多的驱动程序，然后对于任何给定的连接请求，它会依次要求每个驱动程序尝试连接到目标URL。

    强烈建议每个Driver类应该是小型且独立的，以便可以加载和查询Driver类，而不需要大量的支持代码。

    当加载一个Driver类时，它应该创建一个自己的实例，并用DriverManager注册它。 这意味着用户可以通过调用以下方式加载和注册驱动程序：

    Class.forName("foo.bah.Driver")

    JDBC驱动程序可以创建DriverAction实现，以便在调用DriverManager.deregisterDriver(java.sql.Driver)时接收通知。

    从以下版本开始：
    1.1
    另请参见：
    DriverManager ， Connection ， DriverAction

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean acceptsURL​(String url)
      检索驱动程序是否认为可以打开与给定URL的连接。
      Connection connect​(String url, Properties info)
      尝试使数据库连接到给定的URL。
      int getMajorVersion​()
      检索司机的主要版本号。
      int getMinorVersion​()
      获取驱动程序的次要版本号。
      Logger getParentLogger​()
      返回此驱动程序使用的所有日志记录器的父记录器。
      DriverPropertyInfo[] getPropertyInfo​(String url, Properties info)
      获取有关此驱动程序可能属性的信息。
      boolean jdbcCompliant​()
      报告此驱动程序是否是一个真正的JDBC兼容驱动程序。

    • 方法详细信息

      • connect

        Connection connect​(String url,
                   Properties info)
            throws SQLException
        尝试使数据库连接到给定的URL。 如果驱动程序意识到连接到给定的URL是错误的驱动程序，驱动程序应该返回“null”。 这将是常见的，因为当JDBC驱动程序管理器被要求连接到给定的URL时，它会依次将URL传递给每个加载的驱动程序。

        如果驱动程序是正确的驱动程序连接到给定的URL，但连接到数据库时，驱动程序应该抛出一个SQLException 。

        Properties参数可用于传递任意字符串标签/值对作为连接参数。 通常， Properties对象中至少应包含“用户”和“密码”属性。

        注意：如果将属性指定为url一部分，并且还在Properties对象中指定，那么Properties哪个值优先执行定义。 为了最大可移植性，应用程序应仅指定一次属性。

        参数
        url - 要连接到的数据库的URL
        info - 作为连接参数的任意字符串标签/值对的列表。 通常至少应包含“用户”和“密码”属性。
        结果
        一个 Connection对象，表示与URL的连接
        异常
        SQLException - 如果发生数据库访问错误或URL为 null

      • acceptsURL

        boolean acceptsURL​(String url)
            throws SQLException
        检索驱动程序是否认为可以打开与给定URL的连接。 通常，驱动程序将返回true如果他们了解在URL中指定的子协议和false ，如果他们不这样做。
        参数
        url - 数据库的URL
        结果
        true如果此驱动程序了解给定的URL; 否则为false
        异常
        SQLException - 如果发生数据库访问错误或url是 null

      • getPropertyInfo

        DriverPropertyInfo[] getPropertyInfo​(String url,
                                     Properties info)
                              throws SQLException
        获取有关此驱动程序可能属性的信息。

        getPropertyInfo方法旨在允许通用GUI工具发现应该提示人们为了获取足够的信息连接到数据库的属性。 请注意，根据人类迄今为止提供的值，可能需要额外的值，因此可能需要对getPropertyInfo方法进行多次调用。

        参数
        url - 要连接到的数据库的URL
        info - 建议的连接打开时发送的标签/值对列表
        结果
        描述可能属性的DriverPropertyInfo对象的数组。 如果不需要属性，该数组可能是一个空数组。
        异常
        SQLException - 如果发生数据库访问错误

      • getMajorVersion

        int getMajorVersion​()
        检索司机的主要版本号。 最初这应该是1。
        结果
        这个司机的主要版本号

      • getMinorVersion

        int getMinorVersion​()
        获取驱动程序的次要版本号。 最初这应该是0。
        结果
        这个司机的次版本号

      • jdbcCompliant

        boolean jdbcCompliant​()
        报告此驱动程序是否是一个真正的JDBC兼容驱动程序。 如果驱动程序通过了JDBC兼容性测试， true这里只能报告true ; 否则需要返回false 。

        JDBC兼容性要求完全支持JDBC API并完全支持SQL 92入门级。 预计JDBC兼容的驱动程序将可用于所有主要的商业数据库。

        这种方法并不旨在鼓励开发非JDBC兼容驱动程序，而是认识到一些供应商有兴趣为不支持完整数据库功能的轻量级数据库或特殊数据库使用JDBC API和框架例如文档信息检索，其中SQL实现可能不可行。

        结果
        true如果这个驱动程序是符合JDBC的; 否则为false

      • getParentLogger

        Logger getParentLogger​()
                throws SQLFeatureNotSupportedException
        返回此驱动程序使用的所有日志记录器的父记录器。 这应该是距离根记录器最远的记录器，该记录器仍然是此驱动程序使用的所有记录器的祖先。 配置此记录器将影响驱动程序生成的所有日志消息。 在最坏的情况下，这可能是根记录器。
        结果
        该驱动程序的父记录器
        异常
        SQLFeatureNotSupportedException - 如果驱动程序不使用 java.util.logging 。
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DriverAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface DriverAction

  • public interface DriverAction
    当Driver想要通过DriverManager通知时必须实现的接口。

    A DriverAction实现不是直接由应用程序使用。 JDBC驱动程序可以选择在私有类中创建其DriverAction实现，以避免直接调用它。

    JDBC驱动程序的静态初始化块必须调用DriverManager.registerDriver(java.sql.Driver, java.sql.DriverAction)才能通知DriverManager哪个DriverAction实现在JDBC驱动程序被注销时调用。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void deregister​()
      方法由 DriverManager.deregisterDriver(Driver)调用，通知JDBC驱动程序它已被注销。

    • 方法详细信息

      • deregister

        void deregister​()
        由DriverManager.deregisterDriver(Driver)调用的方法通知JDBC驱动程序它已被注销。

        deregister方法仅供JDBC驱动程序使用，而不是由应用程序使用。 推荐JDBC驱动程序在公共类中不实现DriverAction 。 如果在调用deregister方法时存在与数据库的活动连接，那么该连接是关闭还是被允许继续进行的具体实现。 一旦这个方法被调用，它的实现特定于驱动程序是否可能限制创建与数据库的新连接的能力，调用其他Driver方法或抛出一个SQLException 。 有关其行为的其他信息，请参阅JDBC驱动程序文档。

        从以下版本开始：
        1.8
        另请参见：
        DriverManager.registerDriver(java.sql.Driver, java.sql.DriverAction) ， DriverManager.deregisterDriver(Driver)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DriverManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class DriverManager

  • java.lang.Object
    • java.sql.DriverManager

  • public class DriverManager
extends Object
    用于管理一组JDBC驱动程序的基本服务。

    注意： DataSource接口提供了连接数据源的另一种方法。 使用DataSource对象是连接到数据源的首选方法。

    作为其初始化的一部分， DriverManager类将尝试通过使用以下方式加载可用的JDBC驱动程序：

    • jdbc.drivers系统属性，其中包含一个冒号分隔的JDBC驱动程序完全限定类名的列表。 每个驱动程序使用system class loader加载：
      • jdbc.drivers=foo.bah.Driver:wombat.sql.Driver:bad.taste.ourDriver
    • java.sql.Driver类的服务提供商，通过service-provider loading机制加载。

    Implementation Note:
    DriverManager初始化完成懒惰，并使用线程上下文类加载器查找服务提供程序。 加载并可用于应用程序的驱动程序将取决于通过DriverManager触发驱动程序初始化的线程的线程上下文类加载器。

    当调用方法getConnection ， DriverManager将尝试从初始化中加载的驱动程序中找到合适的驱动程序，并使用与当前应用程序相同的类加载器明确加载驱动程序。

    从以下版本开始：
    1.1
    另请参见：
    Driver ， Connection

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static void deregisterDriver​(Driver driver)
      从 DriverManager的注册驱动程序列表中删除指定的驱动程序。
      static Stream<Driver> drivers​()
      使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索流。
      static Connection getConnection​(String url)
      尝试建立与给定数据库URL的连接。
      static Connection getConnection​(String url, String user, String password)
      尝试建立与给定数据库URL的连接。
      static Connection getConnection​(String url, Properties info)
      尝试建立与给定数据库URL的连接。
      static Driver getDriver​(String url)
      尝试查找了解给定URL的驱动程序。
      static Enumeration<Driver> getDrivers​()
      使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索枚举。
      static int getLoginTimeout​()
      获取尝试登录数据库时驱动程序可以等待的最长时间（秒）。
      static PrintStream getLogStream​()
      已过时。
      使用getLogWriter
      static PrintWriter getLogWriter​()
      检索日志记录器。
      static void println​(String message)
      打印到当前JDBC日志流的消息。
      static void registerDriver​(Driver driver)
      使用 DriverManager注册给定的驱动程序。
      static void registerDriver​(Driver driver, DriverAction da)
      使用 DriverManager注册给定的驱动程序。
      static void setLoginTimeout​(int seconds)
      设置驱动程序在识别驱动程序后尝试连接到数据库时等待的最长时间（秒）。
      static void setLogStream​(PrintStream out)
      已过时。
      使用setLogWriter
      static void setLogWriter​(PrintWriter out)
      设置 DriverManager和所有驱动程序使用的记录/跟踪 PrintWriter对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getLogWriter

        public static PrintWriter getLogWriter​()
        检索日志记录器。 应使用getLogWriter和setLogWriter方法，而不是get/setlogStream方法，这些方法已被弃用。
        结果
        一个 java.io.PrintWriter对象
        从以下版本开始：
        1.2
        另请参见：
        setLogWriter(java.io.PrintWriter)

      • setLogWriter

        public static void setLogWriter​(PrintWriter out)
        设置DriverManager和所有驱动程序使用的日志/跟踪PrintWriter对象。

        如果一个安全管理器存在，它的checkPermission方法首先被调用一个SQLPermission("setLog")权限，以检查主叫方是否允许调用setLogWriter 。

        参数
        out - 新的记录/跟踪PrintStream对象; null禁用日志记录和跟踪
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法拒绝设置日志记录器的权限。
        从以下版本开始：
        1.2
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， getLogWriter()

      • getConnection

        public static Connection getConnection​(String url,
                                       Properties info)
                                throws SQLException
        尝试建立与给定数据库URL的连接。 DriverManager尝试从一组已注册的JDBC驱动程序中选择适当的驱动程序。

        注意：如果将属性指定为url一部分，并且也在Properties对象中指定，那么Properties实现方式定义哪个值优先。 为了最大可移植性，应用程序应仅指定一次属性。

        参数
        url - 表单 jdbc:subprotocol:subname的数据库URL
        info - 任意字符串标签/值对作为连接参数的列表; 通常至少应包含“用户”和“密码”属性
        结果
        连接到URL
        异常
        SQLException - 如果发生数据库访问错误或URL为 null
        SQLTimeoutException - 当驱动程序确定已经超过了 setLoginTimeout方法指定的超时值，并且至少尝试取消当前的数据库连接尝试

      • getConnection

        public static Connection getConnection​(String url,
                                       String user,
                                       String password)
                                throws SQLException
        尝试建立与给定数据库URL的连接。 DriverManager尝试从一组已注册的JDBC驱动程序中选择适当的驱动程序。

        注意：如果user或password属性也被指定为url一部分，则实现定义哪个值优先。 为了最大可移植性，应用程序应仅指定一次属性。

        参数
        url - 表单 jdbc:subprotocol:subname的数据库URL
        user - 正在进行连接的数据库用户
        password - 用户密码
        结果
        与URL的连接
        异常
        SQLException - 如果发生数据库访问错误或url是 null
        SQLTimeoutException - 当驱动程序确定已经超过了 setLoginTimeout方法指定的超时值，并且至少尝试取消当前数据库连接尝试

      • getConnection

        public static Connection getConnection​(String url)
                                throws SQLException
        尝试建立与给定数据库URL的连接。 DriverManager尝试从一组已注册的JDBC驱动程序中选择适当的驱动程序。
        参数
        url - 表单 jdbc:subprotocol:subname的数据库URL
        结果
        与URL的连接
        异常
        SQLException - 如果发生数据库访问错误或url是 null
        SQLTimeoutException - 当驱动程序确定已经超过 setLoginTimeout方法指定的超时值并且至少尝试取消当前数据库连接尝试

      • getDriver

        public static Driver getDriver​(String url)
                        throws SQLException
        尝试查找了解给定URL的驱动程序。 DriverManager尝试从一组已注册的JDBC驱动程序中选择适当的驱动程序。
        参数
        url - 表单 jdbc:subprotocol:subname的数据库URL
        结果
        表示可以连接到给定URL的驱动程序的 Driver对象
        异常
        SQLException - 如果发生数据库访问错误

      • registerDriver

        public static void registerDriver​(Driver driver)
                           throws SQLException
        使用DriverManager注册给定的驱动程序。 新加载的驱动程序类应该调用方法registerDriver使其自己已知DriverManager 。 如果司机目前已注册，则不采取任何行动。
        参数
        driver - DriverManager注册的新JDBC驱动程序
        异常
        SQLException - 如果发生数据库访问错误
        NullPointerException - 如果 driver为空

      • registerDriver

        public static void registerDriver​(Driver driver,
                                  DriverAction da)
                           throws SQLException
        使用DriverManager注册给定的驱动程序。 新加载的驱动程序类应该调用方法registerDriver使其自己已知DriverManager 。 如果司机目前已注册，则不采取任何行动。
        参数
        driver - 要在 DriverManager注册的新JDBC驱动程序
        da - 当 DriverManager#deregisterDriver被调用时要使用的 DriverAction实现
        异常
        SQLException - 如果发生数据库访问错误
        NullPointerException - 如果 driver为空
        从以下版本开始：
        1.8

      • deregisterDriver

        public static void deregisterDriver​(Driver driver)
                             throws SQLException
        从DriverManager的注册驱动程序列表中删除指定的驱动程序。

        如果为要删除的驱动程序指定了null值，则不执行任何操作。

        如果一个安全管理器存在，它的checkPermission方法首先被调用一个SQLPermission("deregisterDriver")权限来检查调用者是否被允许注销一个JDBC驱动程序。

        如果在注册驱动程序列表中找不到指定的驱动程序，则不执行任何操作。 如果司机被发现，将从注册的驱动程序列表中删除。

        如果在JDBC驱动程序注册时指定了一个DriverAction实例，则在从注册驱动程序列表中删除驱动程序之前，将会调用其注销方法。

        参数
        driver - 要删除的JDBC驱动程序
        异常
        SQLException - 如果发生数据库访问错误
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法拒绝注销驱动程序的权限。
        另请参见：
        SecurityManager.checkPermission(java.security.Permission)

      • getDrivers

        public static Enumeration<Driver> getDrivers​()
        使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索枚举。

        注意：可以使用d.getClass().getName()找到驱动程序的类d.getClass().getName()

        结果
        由调用者的类加载器加载的JDBC驱动程序列表
        另请参见：
        drivers()

      • drivers

        public static Stream<Driver> drivers​()
        使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索流。
        结果
        由调用者的类加载器加载的JDBC驱动程序流
        从以下版本开始：
        9

      • setLoginTimeout

        public static void setLoginTimeout​(int seconds)
        设置驱动程序在识别驱动程序后尝试连接到数据库时等待的最长时间（秒）。
        参数
        seconds - 以秒为单位的登录时间限制; 零意味着没有限制
        另请参见：
        getLoginTimeout()

      • getLoginTimeout

        public static int getLoginTimeout​()
        获取尝试登录数据库时驱动程序可以等待的最长时间（秒）。
        结果
        司机登录时间限制以秒为单位
        另请参见：
        setLoginTimeout(int)

      • setLogStream

        @Deprecated(since="1.2")
public static void setLogStream​(PrintStream out)
        已过时。 使用setLogWriter
        设置DriverManager和所有驱动程序使用的日志记录/跟踪PrintStream。

        如果一个安全管理器存在，它的checkPermission方法首先被调用一个SQLPermission("setLog")权限，以检查主叫方是否可以调用setLogStream 。

        参数
        out - 新的记录/跟踪PrintStream; 禁用，设置为null
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法拒绝设置日志流的权限。
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， getLogStream()

      • getLogStream

        @Deprecated(since="1.2")
public static PrintStream getLogStream​()
        已过时。 使用getLogWriter
        检索 DriverManager和所有驱动程序使用的日志记录/跟踪PrintStream。
        结果
        记录/跟踪PrintStream; 如果禁用，是null
        另请参见：
        setLogStream(java.io.PrintStream)

      • println

        public static void println​(String message)
        打印到当前JDBC日志流的消息。
        参数
        message - a log or tracing message
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DriverPropertyInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class DriverPropertyInfo

  • java.lang.Object
    • java.sql.DriverPropertyInfo

  • public class DriverPropertyInfo
extends Object

    用于进行连接的驱动程序属性。 DriverPropertyInfo课程仅对需要通过getDriverProperties方法与驱动程序进行getDriverProperties以发现和提供连接属性的高级程序员感兴趣。

    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      String[] choices
      如果可以从一组特定值中选择字段值DriverPropertyInfo.value ，则可能的值的数组; 否则为空。
      String description
      属性的简要说明，可能为null。
      String name
      物业的名称。
      boolean required
      如果在 Driver.connect和 false必须为此属性提供值，则 required字段为 true 。
      String value
      value字段基于提供给方法 getPropertyInfo ，Java环境和驱动程序提供的默认值的信息的组合，指定属性的当前值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DriverPropertyInfo​(String name, String value)
      构造具有给定名称和值的 DriverPropertyInfo对象。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • name

        public String name
        物业的名称。

      • description

        public String description
        属性的简要说明，可能为null。

      • required

        public boolean required
        如果在 Driver.connect和 false必须为此属性提供值，则 required字段为 true 。

      • value

        public String value
        value字段基于提供给方法getPropertyInfo的信息，Java环境和驱动程序提供的默认值的组合来指定属性的当前值。 如果没有值，则该字段可以为null。

      • choices

        public String[] choices
        如果可以从一组特定值中选择字段DriverPropertyInfo.value的值，则可能的值的数组; 否则为空。

    • 构造方法详细信息

      • DriverPropertyInfo

        public DriverPropertyInfo​(String name,
                          String value)
        构造具有给定名称和值的DriverPropertyInfo对象。 description和choices初始化为null而required初始化为false 。
        参数
        name - 属性的名称
        value - 当前值，可以为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


java.sql (Java SE 9 & JDK 9 )

java.sql

Interfaces

  • Array
  • Blob
  • CallableStatement
  • Clob
  • Connection
  • ConnectionBuilder
  • DatabaseMetaData
  • Driver
  • DriverAction
  • NClob
  • ParameterMetaData
  • PreparedStatement
  • Ref
  • ResultSet
  • ResultSetMetaData
  • RowId
  • Savepoint
  • ShardingKey
  • ShardingKeyBuilder
  • SQLData
  • SQLInput
  • SQLOutput
  • SQLType
  • SQLXML
  • Statement
  • Struct
  • Wrapper

Classes

  • Date
  • DriverManager
  • DriverPropertyInfo
  • SQLPermission
  • Time
  • Timestamp
  • Types

Enums

  • ClientInfoStatus
  • JDBCType
  • PseudoColumnUsage
  • RowIdLifetime

Exceptions

  • BatchUpdateException
  • DataTruncation
  • SQLClientInfoException
  • SQLDataException
  • SQLException
  • SQLFeatureNotSupportedException
  • SQLIntegrityConstraintViolationException
  • SQLInvalidAuthorizationSpecException
  • SQLNonTransientConnectionException
  • SQLNonTransientException
  • SQLRecoverableException
  • SQLSyntaxErrorException
  • SQLTimeoutException
  • SQLTransactionRollbackException
  • SQLTransientConnectionException
  • SQLTransientException
  • SQLWarning


java.sql (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.sql

Package java.sql

提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。 该API包括一个框架，可以动态地安装不同的驱动程序来访问不同的数据源。 虽然JDBC API主要面向将SQL语句传递到数据库，但它提供了从表格格式的任何数据源读取和写入数据。 可以通过javax.sql.RowSet接口组提供读写器设备，以便使用和更新数据表，平面文件或任何其他表格数据源中的数据。

什么是JDBC¢4.3 API包含

所述JDBCâ“¢4.3 API既包括java.sql包中，被称为JDBC核心API和javax.sql包，被称为JDBC可选包API。 这个完整的JDBC API包含在Java标准版（Java SE）中，第7版javax.sql包将JDBC API的功能从客户端API扩展到服务器端的API，它是一个Java企业版（Java EE？）技术的重要组成部分。

版本

JDBC 4.3 API包含以前的所有JDBC API版本：
  • JDBC 4.2 API
  • JDBC 4.1 API
  • JDBC 4.0 API
  • JDBC 3.0 API
  • JDBC 2.1核心API
  • JDBC 2.0可选软件包API
    （请注意，JDBC 2.1核心API和JDBC 2.0可选软件包API一起被称为JDBC 2.0 API。）
  • JDBC 1.2 API
  • JDBC 1.0 API

类，接口，方法，字段，构造函数和异常具有以下“since”标记，用于指示何时被引入Java平台。 当这些“since”标签用于Javadoc对JDBC API的注释时，它们表示如下：

  • 由于9 - 新的JDBC 4.3 API和部分Java SE平台9版本
  • 自从1.8 - 新的JDBC 4.2 API和Java SE平台的一部分，版本8
  • 自从1.7 - 新的JDBC 4.1 API和Java SE平台的一部分，版本7
  • 由于1.6 - 新增的JDBC 4.0 API和部分Java SE平台版本6
  • 自1.4版本以来，JDBC 3.0 API和J2SE平台的一部分版本为1.4版本
  • 自从1.2 - 新的JDBC 2.0 API和J2SE平台的1.2版本
  • 由于1.1或没有“自”标签 - 在原来的JDBC 1.0 API和JDK的“¢”1.1版的一部分

注意：许多新功能是可选的; 因此，司机和他们支持的功能有一些变化。 在尝试使用驱动程序的文档之前，请务必查看驱动程序的文档是否支持该功能。

注： SQLPermission类已添加到Java¢2 SDK，Standard Edition，1.3版本中。 此类用于防止未经授权的访问与DriverManager相关联的日志记录流，其可能包含诸如表名，列数据等信息。

什么是java.sql包含

java.sql包包含以下API：
  • 通过DriverManager工具与数据库建立连接
    • DriverManager类 - 与驱动程序建立连接
    • SQLPermission类 - 在安全管理器（如小程序）中运行的代码尝试通过DriverManager设置日志记录流时提供DriverManager
    • Driver接口 - 提供了基于JDBC技术（“JDBC驱动程序”）注册和连接驱动程序的API; 一般只能用于DriverManager类
    • DriverPropertyInfo类 - 为JDBC驱动程序提供属性; 不被普通用户使用
  • 发送SQL语句到数据库
    • Statement - 用于发送基本SQL语句
    • PreparedStatement - 用于发送准备语句或基本SQL语句（派生自Statement ）
    • CallableStatement - 用于调用数据库存储过程（派生自PreparedStatement ）
    • Connection接口 - 提供创建语句和管理连接及其属性的方法
    • Savepoint - 在事务中提供保存点
  • 检索和更新查询的结果
    • ResultSet接口
  • SQL类型到Java编程语言中的类和接口的标准映射
    • Array接口 - SQL ARRAY映射
    • Blob接口 - SQL BLOB映射
    • Clob接口 - SQL CLOB映射
    • Date类 - 映射为SQL DATE
    • NClob接口 - 映射为SQL NCLOB
    • Ref接口 - 映射为SQL REF
    • RowId接口 - SQL ROWID映射
    • Struct接口 - SQL STRUCT映射
    • SQLXML接口 - 映射为SQL XML
    • Time类映射为SQL TIME
    • Timestamp类 - 映射为SQL TIMESTAMP
    • Types类 - 为SQL类型提供常量
  • 自定义将SQL用户定义类型（UDT）映射到Java编程语言中的类
    • SQLData interface - 指定UDT与此类的实例的映射
    • SQLInput接口 - 提供从流中读取UDT属性的方法
    • SQLOutput接口 - 提供将UDT属性写回流的方法
  • 元数据
    • DatabaseMetaData接口 - 提供有关数据库的信息
    • ResultSetMetaData接口 - 提供有关ResultSet对象的列的信息
    • ParameterMetaData接口 - 提供有关PreparedStatement命令的参数信息
  • 例外
    • SQLException - 由于其他原因存在访问数据时遇到问题和某些方法，大多数方法抛出
    • SQLWarning - 抛出以指示警告
    • DataTruncation - 抛出以指示数据可能已被截断
    • BatchUpdateException - 抛出以表示批处理更新中的所有命令都不会成功执行

java.sql和javax.sql在JDBC 4.3 API中javax.sql功能

  • 添加Sharding支持
  • 增强Connection能够向驾驶员提供一个请求，一个独立的工作单位开始或结束的提示
  • 增强型DatabaseMetaData以确定是否支持Sharding
  • 将方法drivers添加到DriverManager以返回当前加载和可用的JDBC驱动程序的Stream
  • 增加对Statement支持，以引用文字和简单标识符
  • 澄清Java SE版本的方法已被弃用

java.sql和javax.sql JDBC 4.2 API中介绍的功能

  • 增加了JDBCType枚举和SQLType界面
  • 支持REF CURSORS在CallableStatement
  • DatabaseMetaData返回最大逻辑LOB大小的方法，如果支持参考光标
  • 增加了对大型更新计数的支持

java.sql和javax.sql在JDBC 4.1 API中javax.sql功能

  • 允许Connection ， ResultSet和Statement与尝试，与资源语句中使用对象
  • 支持添加到CallableStatement和ResultSet以指定通过getObject方法转换为Java类型
  • DatabaseMetaData返回PseudoColumns的方法以及是否始终返回生成的密钥
  • 增加了对Connection支持，以指定数据库模式，中止和超时物理连接。
  • 添加了关闭Statement对象的支持，当对象的Statement对象被关闭时
  • 获得父记录器的支持Driver ， DataSource ， ConnectionPoolDataSource和XADataSource

java.sql和javax.sql在JDBC 4.0 API中javax.sql功能

  • auto java.sql.Driver discovery - 不再需要通过Class.forName加载java.sql.Driver课程
  • 添加了国家字符集支持
  • 为SQL：2003 XML数据类型添加了支持
  • SQLException增强功能 - 增加了原因链接的支持; 为常见的SQLState类值代码添加了新的SQLExceptions
  • 增强的Blob / Clob功能 - 为创建和释放Blob / Clob实例提供的支持以及为改善可访问性而添加的其他方法
  • 支持添加用于访问SQL ROWID
  • 添加的支持允许JDBC应用程序访问由供应商（通常在应用程序服务器或连接池环境中）包装的JDBC资源的实例。
  • 当被通知可用性PreparedStatement ，其与相关联的PooledConnection已被关闭或驱动程序确定是无效

java.sql和javax.sql在JDBC 3.0 API中javax.sql功能

  • 池化语句 - 重用与池化连接相关联的语句
  • 保存点 - 允许将事务回滚到指定的保存点
  • 为ConnectionPoolDataSource定义的ConnectionPoolDataSource - 指定如何合并连接
  • PreparedStatement对象参数的元数据
  • 能够从自动生成的列中检索值
  • 能够拥有多个ResultSet对象从返回CallableStatement对象在同一时间开
  • 能够通过名称和索引来识别参数到CallableStatement对象
  • ResultSet可保持性 - 指定游标在事务结束时是否应该保持打开或关闭的能力
  • 能够检索和更新Ref对象引用的SQL结构化类型实例
  • 能够编程方式更新BLOB ， CLOB ， ARRAY ，并REF值。
  • 添加java.sql.Types.DATALINK数据类型 - 允许JDBC驱动程序访问存储在数据源外部的对象
  • 添加用于检索SQL类型层次结构的元数据

java.sql特性介绍在JDBC 2.1 Core API中

  • 可滚动的结果集 - 使用允许将光标移动到特定行或相对于其当前位置的位置的ResultSet接口中的新方法
  • 批量更新
  • 程序更新 - 使用ResultSet更新程序
  • 新数据类型 - 映射SQL3数据类型的接口
  • 用户定义类型（UDT）的自定义映射
  • 其他功能，包括性能提示，字符流的使用， java.math.BigDecimal完整精度值，额外的安全性以及对日期，时间和时间戳值中时区的支持。

javax.sql在JDBC 2.0可选软件包API中javax.sql功能

  • DataSource接口作为连接的一种手段。 Java命名和目录接口（JNDI）用于注册具有命名服务的DataSource对象，并用于检索它。
  • 池连接 - 允许连接被使用和重复使用
  • 分布式事务 - 允许事务跨越不同的DBMS服务器
  • RowSet技术 - 提供处理和传递数据的便利手段

UDT的自定义映射

在SQL中定义的用户定义类型（UDT）可以映射到Java编程语言中的类。 SQL结构类型或SQL DISTINCT类型是可以自定义映射的UDT。 以下三个步骤设置了一个自定义映射：
  1. 在SQL中定义SQL结构类型或DISTINCT类型
  2. 定义要将SQL UDT映射到的Java编程语言中的类。 这个类必须实现SQLData界面。
  3. 在Connection对象的类型映射中Connection一个条目，其中包含两件事情：
    • UDT的完全限定的SQL名称
    • 用于实现SQLData接口的类的Class对象

当这些功能适用于UDT时，调用该UDT上的方法ResultSet.getObject或CallableStatement.getObject将自动检索其自定义映射。 此外， PreparedStatement.setObject方法将自动将对象重新映射到其SQL类型，以将其存储在数据源中。

包装规格

  • JDBC 4.3 Specification

相关文档

  • Lesson:JDBC Basics(The Javaxx Tutorials > JDBC™ Database Access)
  • JDBC™ API Tutorial and Reference, Third Edition
  • 接口摘要
    接口 描述
    Array
    在Java编程语言中映射的SQL类型为 ARRAY 。
    Blob
    表示（映射）在Java编程语言中的一个SQL BLOB值。
    CallableStatement
    用于执行SQL存储过程的界面。
    Clob
    Java的编程语言映射为SQL CLOB类型。
    Connection
    与特定数据库的连接（会话）。
    ConnectionBuilder
    从 DataSource对象创建的构建器，用于建立与 data source对象所表示的数据库的连接。
    DatabaseMetaData
    关于整个数据库的综合信息。
    Driver
    每个驱动程序类必须实现的接口。
    DriverAction
    当Driver希望通过DriverManager通知时必须实现的接口。
    NClob
    Java的编程语言映射为SQL NCLOB类型。
    ParameterMetaData
    可用于获取有关 PreparedStatement对象中每个参数标记的类型和属性的 PreparedStatement对象。
    PreparedStatement
    表示预编译的SQL语句的对象。
    Ref
    SQL编程语言中的映射SQL REF值，它是对数据库中SQL结构化类型值的引用。
    ResultSet
    表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
    ResultSetMetaData
    可用于获取有关 ResultSet对象中列的类型和属性的信息的对象。
    RowId
    SQL编程语言中的表示（映射）SQL ROWID值。
    Savepoint
    一个保存点的表示，这是当前事务中可以从 Connection.rollback方法引用的一个点。
    ShardingKey
    用于指示此对象表示Sharding键的接口。
    ShardingKeyBuilder
    从DataSource或XADataSource对象创建的构建器，用于创建具有支持的数据类型的子键的ShardingKey 。
    SQLData
    用于将SQL用户定义类型（UDT）自定义映射到Java编程语言中的类的接口。
    SQLInput
    包含表示SQL结构化类型或SQL不同类型实例的值的流的输入流。
    SQLOutput
    用于将用户定义类型的属性写入数据库的输出流。
    SQLType
    用于标识通用SQL类型（称为JDBC类型或供应商特定数据类型）的对象。
    SQLXML
    用于SQL XML类型的JavaTM编程语言中的映射。
    Statement
    用于执行静态SQL语句并返回其生成的结果的对象。
    Struct
    用于SQL结构化类型的Java编程语言中的标准映射。
    Wrapper
    提供在有问题的实例实际上是一个代理类时能够检索委托实例的JDBC类的接口。
  • 类摘要
    Class 描述
    Date
    一个薄的包装器，大约有一个毫秒值，允许JDBC将其识别为SQL DATE值。
    DriverManager
    用于管理一组JDBC驱动程序的基本服务。
    DriverPropertyInfo
    用于进行连接的驱动程序属性。
    SQLPermission
    SecurityManager将在启用运行具有 SecurityManager的应用程序的代码时检查的权限，调用 DriverManager.deregisterDriver方法， DriverManager.setLogWriter方法， DriverManager.setLogStream （已弃用）方法， SyncFactory.setJNDIContext方法， SyncFactory.setLogger方法， Connection.setNetworkTimeout方法或 Connection.abort方法。
    Time
    围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。
    Timestamp
    一个围绕 java.util.Date的薄包装，允许JDBC API将其标识为SQL TIMESTAMP值。
    Types
    定义用于标识通用SQL类型的常量的类，称为JDBC类型。
  • 枚举摘要
    Enum 描述
    ClientInfoStatus
    通过拨打 Connection.setClientInfo不能设置属性的状态的枚举
    JDBCType
    定义用于标识通用SQL类型（称为JDBC类型）的常量。
    PseudoColumnUsage
    伪/隐藏列使用枚举。
    RowIdLifetime
    RowId寿命值的枚举。
  • 异常摘要
    异常 描述
    BatchUpdateException
    在批量更新操作期间发生错误时，抛出SQLException的子类。
    DataTruncation
    由于其超出 MaxFieldSize原因，数据值意外截断时，异常抛出 DataTruncation异常（写入）或报告为 DataTruncation警告（读取时）。
    SQLClientInfoException
    当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。
    SQLDataException
    当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。
    SQLException
    提供有关数据库访问错误或其他错误的信息的异常。
    SQLFeatureNotSupportedException
    当SQLState类的值为' 0A '（值为'零'A）时，抛出SQLException的子类。
    SQLIntegrityConstraintViolationException
    当SQLState类的值为“ 23 ”时，或在供应商指定的条件下抛出SQLException的子类。
    SQLInvalidAuthorizationSpecException
    当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出SQLException的子类。
    SQLNonTransientConnectionException
    抛出SQLState类值为“ 08 ”的SQLException子类，或者在供应商指定的条件下。
    SQLNonTransientException
    当同一操作的重试的实例将失败的情况下抛出SQLException的子类，除非更正SQLException的原因。
    SQLRecoverableException
    如果应用程序执行某些恢复步骤并重试整个事务，或者在分布式事务（即事务分支）的情况下，先前发生故障的操作可能会成功的子集SQLException 。
    SQLSyntaxErrorException
    当SQLState类值为“ 42 ”时，或在供应商指定的条件下，抛出SQLException的子类。
    SQLTimeoutException
    的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。
    SQLTransactionRollbackException
    当SQLState类值为“ 40 ”时，或在供应商指定的条件下，抛出SQLException的子类。
    SQLTransientConnectionException
    SQLState类值为“ 08 ”的SQLException的子类，或供应商指定的条件。
    SQLTransientException
    SQLException的子类在以前失败的操作可能能够在没有应用程序级功能的任何干预的情况下重试操作时能够成功的情况下抛出。
    SQLWarning
    提供有关数据库访问警告的信息的异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.sql Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.sql

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.Date (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.sql.Date
      • java.sql.Time
      • java.sql.Timestamp
    • java.sql.DriverManager
    • java.sql.DriverPropertyInfo
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.sql.SQLPermission
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • java.sql.BatchUpdateException
          • java.sql.SQLClientInfoException
          • java.sql.SQLNonTransientException
            • java.sql.SQLDataException
            • java.sql.SQLFeatureNotSupportedException
            • java.sql.SQLIntegrityConstraintViolationException
            • java.sql.SQLInvalidAuthorizationSpecException
            • java.sql.SQLNonTransientConnectionException
            • java.sql.SQLSyntaxErrorException
          • java.sql.SQLRecoverableException
          • java.sql.SQLTransientException
            • java.sql.SQLTimeoutException
            • java.sql.SQLTransactionRollbackException
            • java.sql.SQLTransientConnectionException
          • java.sql.SQLWarning
            • java.sql.DataTruncation
    • java.sql.Types

Interface Hierarchy

  • java.sql.Array
  • java.lang.AutoCloseable
    • java.sql.Connection (also extends java.sql.Wrapper)
    • java.sql.ResultSet (also extends java.sql.Wrapper)
    • java.sql.Statement (also extends java.sql.Wrapper)
      • java.sql.PreparedStatement
        • java.sql.CallableStatement
  • java.sql.Blob
  • java.sql.Clob
    • java.sql.NClob
  • java.sql.ConnectionBuilder
  • java.sql.Driver
  • java.sql.DriverAction
  • java.sql.Ref
  • java.sql.RowId
  • java.sql.Savepoint
  • java.sql.ShardingKey
  • java.sql.ShardingKeyBuilder
  • java.sql.SQLData
  • java.sql.SQLInput
  • java.sql.SQLOutput
  • java.sql.SQLType
  • java.sql.SQLXML
  • java.sql.Struct
  • java.sql.Wrapper
    • java.sql.Connection (also extends java.lang.AutoCloseable)
    • java.sql.DatabaseMetaData
    • java.sql.ParameterMetaData
    • java.sql.ResultSet (also extends java.lang.AutoCloseable)
    • java.sql.ResultSetMetaData
    • java.sql.Statement (also extends java.lang.AutoCloseable)
      • java.sql.PreparedStatement
        • java.sql.CallableStatement

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.sql.ClientInfoStatus
      • java.sql.JDBCType (implements java.sql.SQLType)
      • java.sql.PseudoColumnUsage
      • java.sql.RowIdLifetime
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


JDBCType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.sql
软件包 java.sql

Enum JDBCType

  • java.lang.Object
    • java.lang.Enum<JDBCType>
      • java.sql.JDBCType
  • All Implemented Interfaces:
    Serializable ， Comparable<JDBCType> ， SQLType

    public enum JDBCType
extends Enum<JDBCType>
implements SQLType

    定义用于标识通用SQL类型（称为JDBC类型）的常量。

    从以下版本开始：
    1.8
    另请参见：
    SQLType

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ARRAY
      标识通用SQL类型 ARRAY 。
      BIGINT
      标识通用SQL类型 BIGINT 。
      BINARY
      标识通用SQL类型 BINARY 。
      BIT
      标识通用SQL类型 BIT 。
      BLOB
      标识通用SQL类型 BLOB 。
      BOOLEAN
      标识通用SQL类型 BOOLEAN 。
      CHAR
      标识通用SQL类型 CHAR 。
      CLOB
      标识通用SQL类型 CLOB 。
      DATALINK
      标识通用SQL类型 DATALINK 。
      DATE
      标识通用SQL类型 DATE 。
      DECIMAL
      标识通用SQL类型 DECIMAL 。
      DISTINCT
      标识通用SQL类型 DISTINCT 。
      DOUBLE
      标识通用SQL类型 DOUBLE 。
      FLOAT
      标识通用SQL类型 FLOAT 。
      INTEGER
      标识通用SQL类型 INTEGER 。
      JAVA_OBJECT
      表示SQL类型是特定于数据库的，并且映射到可以通过getObject和setObject方法访问的Java对象。
      LONGNVARCHAR
      标识通用SQL类型 LONGNVARCHAR 。
      LONGVARBINARY
      标识通用SQL类型 LONGVARBINARY 。
      LONGVARCHAR
      标识通用SQL类型 LONGVARCHAR 。
      NCHAR
      标识通用SQL类型 NCHAR 。
      NCLOB
      标识通用SQL类型 NCLOB 。
      NULL
      标识通用SQL值 NULL 。
      NUMERIC
      标识通用SQL类型 NUMERIC 。
      NVARCHAR
      标识通用SQL类型 NVARCHAR 。
      OTHER
      表示SQL类型是特定于数据库的，并且映射到可以通过getObject和setObject方法访问的Java对象。
      REAL
      标识通用SQL类型 REAL 。
      REF
      标识通用SQL类型 REF 。
      REF_CURSOR
      标识通用SQL类型 REF_CURSOR 。
      ROWID
      标识SQL类型 ROWID 。
      SMALLINT
      标识通用SQL类型 SMALLINT 。
      SQLXML
      标识通用SQL类型 SQLXML 。
      STRUCT
      标识通用SQL类型 STRUCT 。
      TIME
      标识通用SQL类型 TIME 。
      TIME_WITH_TIMEZONE
      标识通用SQL类型 TIME_WITH_TIMEZONE 。
      TIMESTAMP
      标识通用SQL类型 TIMESTAMP 。
      TIMESTAMP_WITH_TIMEZONE
      标识通用SQL类型 TIMESTAMP_WITH_TIMEZONE 。
      TINYINT
      标识通用SQL类型 TINYINT 。
      VARBINARY
      标识通用SQL类型 VARBINARY 。
      VARCHAR
      标识通用SQL类型 VARCHAR 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getName​()
      返回表示SQL数据类型的 SQLType名称。
      String getVendor​()
      返回支持此数据类型的供应商的名称。
      Integer getVendorTypeNumber​()
      返回数据类型的供应商特定类型编号。
      static JDBCType valueOf​(int type)
      返回 JDBCType对应于指定 Types值
      static JDBCType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static JDBCType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BIT

        public static final JDBCType BIT
        标识通用SQL类型 BIT 。

      • TINYINT

        public static final JDBCType TINYINT
        标识通用SQL类型 TINYINT 。

      • SMALLINT

        public static final JDBCType SMALLINT
        标识通用SQL类型 SMALLINT 。

      • INTEGER

        public static final JDBCType INTEGER
        标识通用SQL类型 INTEGER 。

      • BIGINT

        public static final JDBCType BIGINT
        标识通用SQL类型 BIGINT 。

      • FLOAT

        public static final JDBCType FLOAT
        标识通用SQL类型 FLOAT 。

      • REAL

        public static final JDBCType REAL
        标识通用SQL类型 REAL 。

      • DOUBLE

        public static final JDBCType DOUBLE
        标识通用SQL类型 DOUBLE 。

      • NUMERIC

        public static final JDBCType NUMERIC
        标识通用SQL类型 NUMERIC 。

      • DECIMAL

        public static final JDBCType DECIMAL
        标识通用SQL类型 DECIMAL 。

      • CHAR

        public static final JDBCType CHAR
        标识通用SQL类型 CHAR 。

      • VARCHAR

        public static final JDBCType VARCHAR
        标识通用SQL类型 VARCHAR 。

      • LONGVARCHAR

        public static final JDBCType LONGVARCHAR
        标识通用SQL类型 LONGVARCHAR 。

      • DATE

        public static final JDBCType DATE
        标识通用SQL类型 DATE 。

      • TIME

        public static final JDBCType TIME
        标识通用SQL类型 TIME 。

      • TIMESTAMP

        public static final JDBCType TIMESTAMP
        标识通用SQL类型 TIMESTAMP 。

      • BINARY

        public static final JDBCType BINARY
        标识通用SQL类型 BINARY 。

      • VARBINARY

        public static final JDBCType VARBINARY
        标识通用SQL类型 VARBINARY 。

      • LONGVARBINARY

        public static final JDBCType LONGVARBINARY
        标识通用SQL类型 LONGVARBINARY 。

      • NULL

        public static final JDBCType NULL
        标识通用SQL值 NULL 。

      • OTHER

        public static final JDBCType OTHER
        表示SQL类型是特定于数据库的，并且映射到可以通过getObject和setObject方法访问的Java对象。

      • JAVA_OBJECT

        public static final JDBCType JAVA_OBJECT
        表示SQL类型是特定于数据库的，并且映射到可以通过getObject和setObject方法访问的Java对象。

      • DISTINCT

        public static final JDBCType DISTINCT
        标识通用SQL类型 DISTINCT 。

      • STRUCT

        public static final JDBCType STRUCT
        标识通用SQL类型 STRUCT 。

      • ARRAY

        public static final JDBCType ARRAY
        标识通用SQL类型 ARRAY 。

      • BLOB

        public static final JDBCType BLOB
        标识通用SQL类型 BLOB 。

      • CLOB

        public static final JDBCType CLOB
        标识通用SQL类型 CLOB 。

      • REF

        public static final JDBCType REF
        标识通用SQL类型 REF 。

      • DATALINK

        public static final JDBCType DATALINK
        标识通用SQL类型 DATALINK 。

      • BOOLEAN

        public static final JDBCType BOOLEAN
        标识通用SQL类型 BOOLEAN 。

      • ROWID

        public static final JDBCType ROWID
        标识SQL类型 ROWID 。

      • NCHAR

        public static final JDBCType NCHAR
        标识通用SQL类型 NCHAR 。

      • NVARCHAR

        public static final JDBCType NVARCHAR
        标识通用SQL类型 NVARCHAR 。

      • LONGNVARCHAR

        public static final JDBCType LONGNVARCHAR
        标识通用SQL类型 LONGNVARCHAR 。

      • NCLOB

        public static final JDBCType NCLOB
        标识通用SQL类型 NCLOB 。

      • SQLXML

        public static final JDBCType SQLXML
        标识通用SQL类型 SQLXML 。

      • REF_CURSOR

        public static final JDBCType REF_CURSOR
        标识通用SQL类型 REF_CURSOR 。

      • TIME_WITH_TIMEZONE

        public static final JDBCType TIME_WITH_TIMEZONE
        标识通用SQL类型 TIME_WITH_TIMEZONE 。

      • TIMESTAMP_WITH_TIMEZONE

        public static final JDBCType TIMESTAMP_WITH_TIMEZONE
        标识通用SQL类型 TIMESTAMP_WITH_TIMEZONE 。

    • 方法详细信息

      • values

        public static JDBCType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (JDBCType c : JDBCType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static JDBCType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • getName

        public String getName​()
        返回表示SQL数据类型的 SQLType名称。
        Specified by:
        getName在接口 SQLType
        结果
        这个名字 SQLType 。

      • getVendor

        public String getVendor​()
        返回支持此数据类型的供应商的名称。
        Specified by:
        getVendor在接口 SQLType
        结果
        该数据类型的供应商的名称是JDBCType的java.sql。

      • getVendorTypeNumber

        public Integer getVendorTypeNumber​()
        返回数据类型的供应商特定类型编号。
        Specified by:
        getVendorTypeNumber在接口 SQLType
        结果
        表示数据类型的整数。 为JDBCType ，该值将是相同的值作为Types为数据类型。

      • valueOf

        public static JDBCType valueOf​(int type)
        返回 JDBCType对应于指定 Types值
        参数
        type - Types价值
        结果
        JDBCType常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定值为 Types常量
        另请参见：
        Types
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


NClob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface NClob

  • All Superinterfaces:
    Clob

    public interface NClob
extends Clob
    在Java的编程语言中映射SQL NCLOB类型。 SQL NCLOB是一种内置类型，它使用国家字符集作为数据库表行中的列值存储字符大对象。

    NClob接口扩展了Clob接口，该接口提供了获取SQL NCLOB值的长度的方法，用于在客户端上实现NCLOB值，并在NCLOB值内搜索子串或NCLOB对象。 一个NClob对象，就像一个Clob对象，在创建它的事务的持续时间内是有效的。 方法在接口ResultSet ， CallableStatement ，并PreparedStatement ，如getNClob和setNClob允许编程人员访问SQL NCLOB值。 此外，该接口还具有更新NCLOB值的方法。

    如果JDBC驱动程序支持数据类型，则必须完全实现NClob接口上的所有方法。

    从以下版本开始：
    1.6

    • 方法摘要

      • Methods inherited from interface java.sql.Clob

        free, getAsciiStream, getCharacterStream, getCharacterStream, getSubString, length, position, position, setAsciiStream, setCharacterStream, setString, setString, truncate
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ParameterMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface ParameterMetaData

  • All Superinterfaces:
    Wrapper

    public interface ParameterMetaData
extends Wrapper
    可用于获取有关PreparedStatement对象中每个参数标记的类型和属性的PreparedStatement对象。 对于某些查询和驱动程序实现， ParameterMetaData对象返回的数据在执行PreparedStatement之前可能不可用。

    某些驱动程序实现可能无法提供有关CallableStatement对象中每个参数标记的类型和属性的信息。

    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int parameterModeIn
      常数表示参数的模式为IN。
      static int parameterModeInOut
      常数表示参数的模式为INOUT。
      static int parameterModeOut
      常数表示参数的模式为OUT。
      static int parameterModeUnknown
      常数表示参数的模式未知。
      static int parameterNoNulls
      该常量指示一个参数将不允许 NULL值。
      static int parameterNullable
      该常量指示一个参数将允许 NULL值。
      static int parameterNullableUnknown
      指示参数的无效性的常数未知。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getParameterClassName​(int param)
      检索其实例应传递给方法 PreparedStatement.setObject的Java类的完全限定名称。
      int getParameterCount​()
      获取的参数中的数 PreparedStatement对象指此 ParameterMetaData对象包含的信息。
      int getParameterMode​(int param)
      检索指定参数的模式。
      int getParameterType​(int param)
      检索指定参数的SQL类型。
      String getParameterTypeName​(int param)
      检索指定参数的数据库特定类型名称。
      int getPrecision​(int param)
      检索指定参数的指定列大小。
      int getScale​(int param)
      检索小数点右侧指定参数的位数。 对于不适用比例的数据类型，返回0。
      int isNullable​(int param)
      检索指定参数中是否允许空值。
      boolean isSigned​(int param)
      检索指定参数的值是否可以是符号数。

      • Methods inherited from interface java.sql.Wrapper

        isWrapperFor, unwrap

    • 字段详细信息

      • parameterNoNulls

        static final int parameterNoNulls
        该常量指示参数不允许 NULL值。
        另请参见：
        Constant Field Values

      • parameterNullable

        static final int parameterNullable
        该常量指示一个参数将允许 NULL值。
        另请参见：
        Constant Field Values

      • parameterNullableUnknown

        static final int parameterNullableUnknown
        指示参数的无效性的常数未知。
        另请参见：
        Constant Field Values

      • parameterModeUnknown

        static final int parameterModeUnknown
        常数表示参数的模式未知。
        另请参见：
        Constant Field Values

      • parameterModeIn

        static final int parameterModeIn
        常数表示参数的模式为IN。
        另请参见：
        Constant Field Values

      • parameterModeInOut

        static final int parameterModeInOut
        常数表示参数的模式为INOUT。
        另请参见：
        Constant Field Values

      • parameterModeOut

        static final int parameterModeOut
        常数表示参数的模式为OUT。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getParameterCount

        int getParameterCount​()
               throws SQLException
        获取的参数中的数 PreparedStatement对象指此 ParameterMetaData对象包含的信息。
        结果
        参数数量
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • isNullable

        int isNullable​(int param)
        throws SQLException
        检索指定参数中是否允许空值。
        参数
        param - 第一个参数是1，第二个是2，...
        结果
        给定参数的可空性状态; 之一ParameterMetaData.parameterNoNulls ， ParameterMetaData.parameterNullable ，或ParameterMetaData.parameterNullableUnknown
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • isSigned

        boolean isSigned​(int param)
          throws SQLException
        检索指定参数的值是否可以是符号数。
        参数
        param - 第一个参数是1，第二个是2，...
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getPrecision

        int getPrecision​(int param)
          throws SQLException
        检索指定参数的指定列大小。

        返回的值表示给定参数的最大列大小。 对于数值数据，这是最大精度。 对于字符数据，这是字符长度。 对于datetime数据类型，这是String表示形式的长度（假定分数秒分量的最大允许精度）。 对于二进制数据，这是以字节为单位的长度。 对于ROWID数据类型，这是以字节为单位的长度。 对于列大小不适用的数据类型返回0。

        参数
        param - 第一个参数是1，第二个是2，...
        结果
        精确
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getScale

        int getScale​(int param)
      throws SQLException
        检索小数点右侧指定参数的位数。 对于不适用比例的数据类型，返回0。
        参数
        param - 第一个参数是1，第二个是2，...
        结果
        规模
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getParameterType

        int getParameterType​(int param)
              throws SQLException
        检索指定参数的SQL类型。
        参数
        param - 第一个参数是1，第二个是2，...
        结果
        SQL类型从 java.sql.Types
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4
        另请参见：
        Types

      • getParameterTypeName

        String getParameterTypeName​(int param)
                     throws SQLException
        检索指定参数的数据库特定类型名称。
        参数
        param - 第一个参数是1，第二个是2，...
        结果
        键入数据库使用的名称。 如果参数类型是用户定义的类型，则返回完全限定类型的名称。
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getParameterClassName

        String getParameterClassName​(int param)
                      throws SQLException
        检索要将实例应传递给方法 PreparedStatement.setObject的Java类的完全限定名称。
        参数
        param - 第一个参数是1，第二个是2，...
        结果
        Java编程语言中将由方法PreparedStatement.setObject用于设置指定参数中的值的完全限定名称。 这是用于自定义映射的类名。
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4

      • getParameterMode

        int getParameterMode​(int param)
              throws SQLException
        检索指定参数的模式。
        参数
        param - 第一个参数是1，第二个是2，...
        结果
        模式的参数; 之一ParameterMetaData.parameterModeIn ， ParameterMetaData.parameterModeOut ，或ParameterMetaData.parameterModeInOut ParameterMetaData.parameterModeUnknown 。
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PreparedStatement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface PreparedStatement

  • All Superinterfaces:
    AutoCloseable ， Statement ， Wrapper
    All Known Subinterfaces:
    CallableStatement

    public interface PreparedStatement
extends Statement
    表示预编译的SQL语句的对象。

    SQL语句已预编译并存储在一个PreparedStatement对象中。 然后可以使用该对象多次有效地执行此语句。

    注意：setter方法（ setShort ， setString用于设置IN参数值必须指定与所定义的SQL类型的输入参数的兼容的类型，等等）。 例如，如果IN参数具有SQL类型INTEGER ，则应使用方法setInt 。

    如果需要任意参数类型转换，方法setObject应与目标SQL类型一起使用。

    在以下设置参数的示例中， con表示活动连接：

      PreparedStatement pstmt = con.prepareStatement("UPDATE EMPLOYEES
                                     SET SALARY = ? WHERE ID = ?");
   pstmt.setBigDecimal(1, 153833.00)
   pstmt.setInt(2, 110592)
    从以下版本开始：
    1.1
    另请参见：
    Connection.prepareStatement(java.lang.String) ， ResultSet

    • Field Summary

      • Fields inherited from interface java.sql.Statement

        CLOSE_ALL_RESULTS, CLOSE_CURRENT_RESULT, EXECUTE_FAILED, KEEP_CURRENT_RESULT, NO_GENERATED_KEYS, RETURN_GENERATED_KEYS, SUCCESS_NO_INFO

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods 弃用的方法
      Modifier and Type 方法 描述
      void addBatch​()
      向这个 PreparedStatement对象的一批命令添加一组参数。
      void clearParameters​()
      立即清除当前参数值。
      boolean execute​()
      执行此 PreparedStatement对象中的SQL语句，可能是任何类型的SQL语句。
      default long executeLargeUpdate​()
      执行在该SQL语句PreparedStatement对象，它必须是一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
      ResultSet executeQuery​()
      执行此 PreparedStatement对象中的SQL查询，并返回查询生成的 ResultSet对象。
      int executeUpdate​()
      执行在该SQL语句PreparedStatement对象，它必须是一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
      ResultSetMetaData getMetaData​()
      检索 ResultSetMetaData对象，该对象包含有关执行此 PreparedStatement对象时将返回的 ResultSet对象的列的信息。
      ParameterMetaData getParameterMetaData​()
      检索此 PreparedStatement对象的参数的数量，类型和属性。
      void setArray​(int parameterIndex, Array x)
      将指定的参数设置为给定的 java.sql.Array对象。
      void setAsciiStream​(int parameterIndex, InputStream x)
      将指定的参数设置为给定的输入流。
      void setAsciiStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void setAsciiStream​(int parameterIndex, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void setBigDecimal​(int parameterIndex, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。
      void setBinaryStream​(int parameterIndex, InputStream x)
      将指定的参数设置为给定的输入流。
      void setBinaryStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void setBinaryStream​(int parameterIndex, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void setBlob​(int parameterIndex, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void setBlob​(int parameterIndex, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void setBlob​(int parameterIndex, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。
      void setBoolean​(int parameterIndex, boolean x)
      将指定的参数设置为给定的Java boolean值。
      void setByte​(int parameterIndex, byte x)
      将指定的参数设置为给定的Java byte值。
      void setBytes​(int parameterIndex, byte[] x)
      将指定的参数设置为给定的Java字节数组。
      void setCharacterStream​(int parameterIndex, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void setCharacterStream​(int parameterIndex, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void setCharacterStream​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void setClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void setClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void setClob​(int parameterIndex, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。
      void setDate​(int parameterIndex, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void setDate​(int parameterIndex, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void setDouble​(int parameterIndex, double x)
      将指定的参数设置为给定的Java double值。
      void setFloat​(int parameterIndex, float x)
      将指定的参数设置为给定的Java float值。
      void setInt​(int parameterIndex, int x)
      将指定的参数设置为给定的Java int值。
      void setLong​(int parameterIndex, long x)
      将指定的参数设置为给定的Java long值。
      void setNCharacterStream​(int parameterIndex, Reader value)
      将指定的参数设置为 Reader对象。
      void setNCharacterStream​(int parameterIndex, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void setNClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void setNClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void setNClob​(int parameterIndex, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void setNString​(int parameterIndex, String value)
      将指定的参数设置为给定的 String对象。
      void setNull​(int parameterIndex, int sqlType)
      将指定的参数设置为SQL NULL 。
      void setNull​(int parameterIndex, int sqlType, String typeName)
      将指定的参数设置为SQL NULL 。
      void setObject​(int parameterIndex, Object x)
      使用给定对象设置指定参数的值。
      void setObject​(int parameterIndex, Object x, int targetSqlType)
      使用给定对象设置指定参数的值。
      void setObject​(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
      使用给定对象设置指定参数的值。
      default void setObject​(int parameterIndex, Object x, SQLType targetSqlType)
      使用给定对象设置指定参数的值。
      default void setObject​(int parameterIndex, Object x, SQLType targetSqlType, int scaleOrLength)
      使用给定对象设置指定参数的值。
      void setRef​(int parameterIndex, Ref x)
      将指定的参数设置为给定的 REF(<structured-type>)值。
      void setRowId​(int parameterIndex, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void setShort​(int parameterIndex, short x)
      将指定的参数设置为给定的Java short值。
      void setSQLXML​(int parameterIndex, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void setString​(int parameterIndex, String x)
      将指定的参数设置为给定的Java String值。
      void setTime​(int parameterIndex, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void setTime​(int parameterIndex, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void setTimestamp​(int parameterIndex, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。
      void setUnicodeStream​(int parameterIndex, InputStream x, int length)
      已过时。
      使用setCharacterStream
      void setURL​(int parameterIndex, URL x)
      将指定的参数设置为给定的 java.net.URL值。

      • Methods inherited from interface java.sql.Statement

        addBatch, cancel, clearBatch, clearWarnings, close, closeOnCompletion, enquoteIdentifier, enquoteLiteral, enquoteNCharLiteral, execute, execute, execute, execute, executeBatch, executeLargeBatch, executeLargeUpdate, executeLargeUpdate, executeLargeUpdate, executeLargeUpdate, executeQuery, executeUpdate, executeUpdate, executeUpdate, executeUpdate, getConnection, getFetchDirection, getFetchSize, getGeneratedKeys, getLargeMaxRows, getLargeUpdateCount, getMaxFieldSize, getMaxRows, getMoreResults, getMoreResults, getQueryTimeout, getResultSet, getResultSetConcurrency, getResultSetHoldability, getResultSetType, getUpdateCount, getWarnings, isClosed, isCloseOnCompletion, isPoolable, isSimpleIdentifier, setCursorName, setEscapeProcessing, setFetchDirection, setFetchSize, setLargeMaxRows, setMaxFieldSize, setMaxRows, setPoolable, setQueryTimeout

      • Methods inherited from interface java.sql.Wrapper

        isWrapperFor, unwrap

    • 方法详细信息

      • executeQuery

        ResultSet executeQuery​()
                throws SQLException
        执行此 PreparedStatement对象中的SQL查询，并返回查询生成的 ResultSet对象。
        结果
        一个ResultSet对象，其中包含查询产生的数据; 从不null
        异常
        SQLException - 如果发生数据库访问错误; 这个方法在一个封闭的PreparedStatement上被调用，或者SQL语句不返回一个ResultSet对象
        SQLTimeoutException - 当驱动程序确定已经超过了 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement

      • executeUpdate

        int executeUpdate​()
           throws SQLException
        执行在该SQL语句PreparedStatement对象，它必须是一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
        结果
        （1）SQL数据操作语言（DML）语句的行计数或（2）0不返回的SQL语句
        异常
        SQLException - 如果发生数据库访问错误; 这个方法在一个封闭的PreparedStatement上被调用，或者SQL语句返回一个ResultSet对象
        SQLTimeoutException - 当驱动程序确定已超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement

      • setNull

        void setNull​(int parameterIndex,
             int sqlType)
      throws SQLException
        将指定的参数设置为SQL NULL 。

        注意：您必须指定参数的SQL类型。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        sqlType - 在 java.sql.Types定义的SQL类型代码
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException -如果 sqlType是 ARRAY ， BLOB ， CLOB ， DATALINK ， JAVA_OBJECT ， NCHAR ， NCLOB ， NVARCHAR ， LONGNVARCHAR ， REF ， ROWID ， SQLXML或 STRUCT数据类型和JDBC驱动程序不支持此数据类型

      • setBoolean

        void setBoolean​(int parameterIndex,
                boolean x)
         throws SQLException
        将指定的参数设置为给定的Java boolean值。 当驱动程序将其发送到数据库时，将其转换为SQL BIT或BOOLEAN值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setByte

        void setByte​(int parameterIndex,
             byte x)
      throws SQLException
        将指定的参数设置为给定的Java byte值。 当驱动程序将其发送到数据库时，将其转换为SQL TINYINT值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setShort

        void setShort​(int parameterIndex,
              short x)
       throws SQLException
        将指定的参数设置为给定的Java short值。 当驱动程序将其发送到数据库时，将其转换为SQL SMALLINT值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setInt

        void setInt​(int parameterIndex,
            int x)
     throws SQLException
        将指定的参数设置为给定的Java int值。 当驱动程序将其发送到数据库时，将其转换为SQL INTEGER值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setLong

        void setLong​(int parameterIndex,
             long x)
      throws SQLException
        将指定的参数设置为给定的Java long值。 当驱动程序将其发送到数据库时，将其转换为SQL BIGINT值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setFloat

        void setFloat​(int parameterIndex,
              float x)
       throws SQLException
        将指定的参数设置为给定的Java float值。 当驱动程序将其发送到数据库时，将其转换为SQL REAL值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setDouble

        void setDouble​(int parameterIndex,
               double x)
        throws SQLException
        将指定的参数设置为给定的Java double值。 当驱动程序将其发送到数据库时，将其转换为SQL DOUBLE值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setBigDecimal

        void setBigDecimal​(int parameterIndex,
                   BigDecimal x)
            throws SQLException
        将指定的参数设置为给定的java.math.BigDecimal值。 当驱动程序将其发送到数据库时，将其转换为SQL NUMERIC值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setString

        void setString​(int parameterIndex,
               String x)
        throws SQLException
        将指定的参数设置为给定的Java String值。 当驱动程序将其发送到数据库时，将其转换为SQL VARCHAR或LONGVARCHAR值（取决于参数相对于驱动程序对VARCHAR的限制的大小）的大小。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setBytes

        void setBytes​(int parameterIndex,
              byte[] x)
       throws SQLException
        将指定的参数设置为给定的Java字节数组。 驱动程序将其转换为SQL VARBINARY或LONGVARBINARY （取决于参数相对于驱动程序对VARBINARY值的限制的大小），当它发送到数据库时。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setDate

        void setDate​(int parameterIndex,
             Date x)
      throws SQLException
        使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的java.sql.Date值。 当驱动程序将其发送到数据库时，将其转换为SQL DATE值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setTime

        void setTime​(int parameterIndex,
             Time x)
      throws SQLException
        将指定的参数设置为给定的java.sql.Time值。 当驱动程序将其发送到数据库时，将其转换为SQL TIME值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setTimestamp

        void setTimestamp​(int parameterIndex,
                  Timestamp x)
           throws SQLException
        将指定的参数设置为给定的java.sql.Timestamp值。 当驱动程序将其发送到数据库时，将其转换为SQL TIMESTAMP值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setAsciiStream

        void setAsciiStream​(int parameterIndex,
                    InputStream x,
                    int length)
             throws SQLException
        将指定的参数设置为给定的输入流，它将具有指定的字节数。 当输入非常大的ASCII值到LONGVARCHAR参数时，通过java.io.InputStream发送它可能更实用。 将根据需要从流中读取数据，直到达到文件结尾。 JDBC驱动程序将从ASCII到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含ASCII参数值的Java输入流
        length - 流中的字节数
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • setUnicodeStream

        @Deprecated(since="1.2")
void setUnicodeStream​(int parameterIndex,
                      InputStream x,
                      int length)
               throws SQLException
        已过时。 使用setCharacterStream
        将指定的参数设置为给定的输入流，它将具有指定的字节数。 当一个非常大的Unicode值输入到LONGVARCHAR参数时，通过java.io.InputStream对象发送它可能更实用。 数据将从流中读取，直到达到文件结尾。 JDBC驱动程序将从Unicode到数据库字符格式进行任何必要的转换。 Unicode流的字节格式必须是Java虚拟机规范中定义的Java UTF-8。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含Unicode参数值的 java.io.InputStream对象
        length - 流中的字节数
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法

      • setBinaryStream

        void setBinaryStream​(int parameterIndex,
                     InputStream x,
                     int length)
              throws SQLException
        将指定的参数设置为给定的输入流，它将具有指定的字节数。 当一个非常大的二进制值输入到一个LONGVARBINARY参数时，通过java.io.InputStream对象发送它可能更实用。 数据将从流中读取，直到达到文件结尾。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含二进制参数值的java输入流
        length - 流中的字节数
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法

      • clearParameters

        void clearParameters​()
              throws SQLException
        立即清除当前参数值。

        一般来说，参数值仍然有效用于重复使用语句。 设置参数值将自动清除其以前的值。 然而，在某些情况下，立即释放当前参数值使用的资源是有用的; 这可以通过调用方法clearParameters来完成。

        异常
        SQLException - 如果发生数据库访问错误或此方法在已关闭的 PreparedStatement

      • setObject

        void setObject​(int parameterIndex,
               Object x,
               int targetSqlType)
        throws SQLException
        使用给定对象设置指定参数的值。 该方法类似于setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength) ，除了它假定为零。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含输入参数值的对象
        targetSqlType - 要发送到数据库的SQL类型（在java.sql.Types中定义）
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的targetSqlType
        另请参见：
        Types

      • setObject

        void setObject​(int parameterIndex,
               Object x)
        throws SQLException

        使用给定对象设置指定参数的值。

        JDBC规范规定了从Java Object类型到SQL类型的标准映射。 在发送给数据库之前，给定的参数将被转换为相应的SQL类型。

        请注意，该方法可以用于通过使用特定于驱动程序的Java类型来传递特定于数据库的抽象数据类型。 如果对象是实现接口SQLData的类，则JDBC驱动程序应调用方法SQLData.writeSQL将其写入SQL数据流。 如果，在另一方面，对象是实现一类Ref ， Blob ， Clob ， NClob ， Struct ， java.net.URL ， RowId ， SQLXML或Array ，驾驶员应把它传递给数据库作为相应SQL类型的值。

        注意：并非所有数据库都允许将非类型的Null发送到后端。 为了最大可移植性，应使用setNull或setObject(int parameterIndex, Object x, int sqlType)方法代替setObject(int parameterIndex, Object x) 。

        注意：如果存在歧义，则此方法会引发异常，例如，如果对象是实现多个上述接口的类。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含输入参数值的对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误; 这个方法在一个封闭的PreparedStatement上被调用，或给定对象的类型是不明确的

      • execute

        boolean execute​()
         throws SQLException
        执行此PreparedStatement对象中的SQL语句，可能是任何类型的SQL语句。 一些准备的语句返回多个结果; execute方法处理这些复杂语句以及由方法executeQuery和executeUpdate处理的更简单的语句形式。

        execute方法返回一个boolean以指示第一个结果的形式。 您必须调用方法getResultSet或getUpdateCount来检索结果; 您必须致电getMoreResults才能转到任何后续结果。

        结果
        true如果第一个结果是一个ResultSet对象; false如果第一个结果是更新计数或没有结果
        异常
        SQLException - 如果发生数据库访问错误; 这个方法在一个关闭的PreparedStatement上调用，或者这个方法提供一个参数
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        另请参见：
        Statement.execute(java.lang.String) ，
Statement.getResultSet() ，
Statement.getUpdateCount() ，
Statement.getMoreResults()

      • addBatch

        void addBatch​()
       throws SQLException
        向这个 PreparedStatement对象的一批命令添加一组参数。
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement调用此方法 PreparedStatement
        从以下版本开始：
        1.2
        另请参见：
        Statement.addBatch(java.lang.String)

      • setCharacterStream

        void setCharacterStream​(int parameterIndex,
                        Reader reader,
                        int length)
                 throws SQLException
        将指定的参数设置为给定的Reader对象，这是给定的长度的字符数。 当将非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更实用。 数据将从流中读取，直到达到文件结尾。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        reader - 包含Unicode数据的 java.io.Reader对象
        length - 流中的字符数
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        从以下版本开始：
        1.2

      • setRef

        void setRef​(int parameterIndex,
            Ref x)
     throws SQLException
        将指定的参数设置为给定的REF(<structured-type>)值。 当驱动程序将其发送到数据库时，将其转换为SQL REF值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 一个SQL REF值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • setBlob

        void setBlob​(int parameterIndex,
             Blob x)
      throws SQLException
        将指定的参数设置为给定的java.sql.Blob对象。 当驱动程序将其发送到数据库时，将其转换为SQL BLOB值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 映射SQL BLOB值的 Blob对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • setClob

        void setClob​(int parameterIndex,
             Clob x)
      throws SQLException
        将指定的参数设置为给定的java.sql.Clob对象。 当驱动程序将其发送到数据库时，将其转换为SQL CLOB值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 映射SQL CLOB值的 Clob对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • setArray

        void setArray​(int parameterIndex,
              Array x)
       throws SQLException
        将指定的参数设置为给定的java.sql.Array对象。 当驱动程序将其发送到数据库时，将其转换为SQL ARRAY值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 映射SQL ARRAY值的 Array对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getMetaData

        ResultSetMetaData getMetaData​()
                       throws SQLException
        检索ResultSetMetaData对象，该对象包含有关执行此PreparedStatement对象时将返回的ResultSet对象的列的信息。

        由于PreparedStatement对象是预编译的，就可以了解ResultSet对象将返回，而不必执行它。 因此，有可能调用的方法getMetaData一个上PreparedStatement对象，而不是等待执行它，然后调用ResultSet.getMetaData的上方法ResultSet返回的对象。

        注意：由于缺少底层DBMS支持，因此对某些驱动程序而言，使用此方法可能是昂贵的。

        结果
        对 ResultSet对象的列或 null的描述，如果驱动程序不能返回一个 ResultSetMetaData对象
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 PreparedStatement调用此方法 PreparedStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • setDate

        void setDate​(int parameterIndex,
             Date x,
             Calendar cal)
      throws SQLException
        使用给定的Calendar对象将指定的参数设置为给定的java.sql.Date值。 驱动程序使用Calendar对象来构造一个SQL DATE值，然后驱动程序将其发送到数据库。 使用Calendar对象，驱动程序可以计算考虑到自定义时区的日期。 如果未指定Calendar对象，驱动程序将使用默认时区，即运行应用程序的虚拟机的时区。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        cal - 驱动程序将用于构建日期的 Calendar对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        从以下版本开始：
        1.2

      • setTime

        void setTime​(int parameterIndex,
             Time x,
             Calendar cal)
      throws SQLException
        使用给定的Calendar对象将指定的参数设置为给定的java.sql.Time值。 驱动程序使用Calendar对象来构造一个SQL TIME值，然后驱动程序将其发送到数据库。 使用Calendar对象，驱动程序可以计算考虑到自定义时区的时间。 如果未指定Calendar对象，则驱动程序使用默认时区，即运行应用程序的虚拟机的时区。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        cal - 驱动程序将用于构建时间的 Calendar对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        从以下版本开始：
        1.2

      • setTimestamp

        void setTimestamp​(int parameterIndex,
                  Timestamp x,
                  Calendar cal)
           throws SQLException
        使用给定的Calendar对象将指定的参数设置为给定的java.sql.Timestamp值。 驱动程序使用Calendar对象来构造一个SQL TIMESTAMP值，然后驱动程序将其发送到数据库。 使用Calendar对象，驱动程序可以计算考虑到自定义时区的时间戳。 如果未指定Calendar对象，则驱动程序将使用默认时区，即运行应用程序的虚拟机的时区。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        cal - 驱动程序将用于构建时间戳的 Calendar对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        从以下版本开始：
        1.2

      • setNull

        void setNull​(int parameterIndex,
             int sqlType,
             String typeName)
      throws SQLException
        将指定的参数设置为SQL NULL 。 此版本的方法setNull应用于用户定义的类型和REF类型参数。 用户定义类型的示例包括：STRUCT，DISTINCT，JAVA_OBJECT和命名的数组类型。

        注意：为了便于携带，当指定NULL用户定义或REF参数时，应用程序必须给出SQL类型代码和完全限定的SQL类型名称。 在用户定义类型的情况下，名称是参数本身的类型名称。 对于REF参数，名称是引用类型的类型名称。 如果JDBC驱动程序不需要类型代码或类型名称信息，它可能会忽略它。 尽管它是用于用户定义的和参数的参数，但是该方法可以用于设置任何JDBC类型的空值参数。 如果参数没有用户定义或REF类型，则给定的typeName将被忽略。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        sqlType - 一个来自 java.sql.Types的值
        typeName - SQL用户定义类型的全限定名称; 如果参数不是用户定义的类型或REF，则将被忽略
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException -如果 sqlType是 ARRAY ， BLOB ， CLOB ， DATALINK ， JAVA_OBJECT ， NCHAR ， NCLOB ， NVARCHAR ， LONGNVARCHAR ， REF ， ROWID ， SQLXML或 STRUCT数据类型和JDBC驱动程序不支持此数据类型，或者JDBC驱动程序不支持这种方法
        从以下版本开始：
        1.2

      • setURL

        void setURL​(int parameterIndex,
            URL x)
     throws SQLException
        将指定的参数设置为给定的java.net.URL值。 当驱动程序将其发送到数据库时，将其转换为SQL DATALINK值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 要设置的 java.net.URL对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • getParameterMetaData

        ParameterMetaData getParameterMetaData​()
                                throws SQLException
        检索 PreparedStatement对象参数的数量，类型和属性。
        结果
        一个 ParameterMetaData对象，其中包含有关此 PreparedStatement对象的每个参数标记的数量，类型和属性的信息
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement调用此方法 PreparedStatement
        从以下版本开始：
        1.4
        另请参见：
        ParameterMetaData

      • setRowId

        void setRowId​(int parameterIndex,
              RowId x)
       throws SQLException
        将指定的参数设置为给定的java.sql.RowId对象。 当驱动程序将其发送到数据库时，将其转换为SQL ROWID值
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在封闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNString

        void setNString​(int parameterIndex,
                String value)
         throws SQLException
        将指定的参数设置为给定的String对象。 当驱动程序将其发送到数据库时，将其转换为SQL NCHAR或NVARCHAR或LONGNVARCHAR值（取决于参数相对于驱动程序对NVARCHAR的限制的大小）的大小。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        value - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误;
或者这个方法在关闭的PreparedStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNCharacterStream

        void setNCharacterStream​(int parameterIndex,
                         Reader value,
                         long length)
                  throws SQLException
        将指定的参数设置为Reader对象。 Reader读取数据，直到达到文件结尾。 驱动程序必须从Java字符格式转换为数据库中的国家字符集。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        value - 参数值
        length - 参数数据中的字符数。
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误;
或者这个方法在一个封闭的PreparedStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNClob

        void setNClob​(int parameterIndex,
              NClob value)
       throws SQLException
        将指定的参数设置为java.sql.NClob对象。 当驱动程序将其发送到数据库时，将其转换为SQL NCLOB值。
        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        value - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误;
或者这个方法在关闭的PreparedStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setClob

        void setClob​(int parameterIndex,
             Reader reader,
             long length)
      throws SQLException
        将指定的参数设置为Reader对象。 读者必须包含由长度指定的字符数，否则在执行SQLException会产生PreparedStatement 。 该方法与setCharacterStream (int, Reader, int)方法不同，因为它通知驱动程序参数值应作为CLOB发送到服务器。 当使用setCharacterStream方法时，驱动程序可能必须进行额外的工作，以确定是否应将参数数据作为LONGVARCHAR或CLOB发送到服务器
        参数
        parameterIndex - 第一个参数的索引为1，第二个为2，...
        reader - 包含将参数值设置为的数据的对象。
        length - 参数数据中的字符数。
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误; 该方法在关闭的PreparedStatement上调用，或者如果指定的长度小于零。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setBlob

        void setBlob​(int parameterIndex,
             InputStream inputStream,
             long length)
      throws SQLException
        将指定的参数设置为InputStream对象。 Inputstream必须包含由长度指定的字符数，否则在执行SQLException将生成PreparedStatement 。 该方法与setBinaryStream (int, InputStream, int)方法不同，因为它通知驱动程序参数值应作为BLOB发送到服务器。 当使用setBinaryStream方法时，驱动程序可能需要进行额外的工作才能确定是否应将参数数据作为LONGVARBINARY或BLOB发送到服务器
        参数
        parameterIndex - 第一个参数的索引为1，第二个为2，...
        inputStream - 包含将参数值设置为的数据的对象。
        length - 参数数据中的字节数。
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记;
如果发生数据库访问错误;
这个方法是在封闭的PreparedStatement上PreparedStatement ;
如果指定的长度小于零，或者InputStream中的字节数与指定长度不匹配。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNClob

        void setNClob​(int parameterIndex,
              Reader reader,
              long length)
       throws SQLException
        将指定的参数设置为Reader对象。 读者必须包含由长度指定的字符数，否则当执行SQLException将生成PreparedStatement 。 该方法与setCharacterStream (int, Reader, int)方法不同，因为它通知驱动程序参数值应作为NCLOB发送到服务器。 当使用setCharacterStream方法时，驱动程序可能必须进行额外的工作来确定是否应将参数数据作为LONGNVARCHAR或NCLOB发送到服务器
        参数
        parameterIndex - 第一个参数的索引为1，第二个为2，...
        reader - 包含将参数值设置为的数据的对象。
        length - 参数数据中的字符数。
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记;
如果指定的长度小于零;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setSQLXML

        void setSQLXML​(int parameterIndex,
               SQLXML xmlObject)
        throws SQLException
        将指定的参数设置为给定的java.sql.SQLXML对象。 当驱动程序将其发送到数据库时，将其转换为SQL XML值。
        参数
        parameterIndex - 第一个参数的索引为1，第二个为2，...
        xmlObject - 映射SQL XML值的 SQLXML对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误; 这个方法被称为在关闭PreparedStatement或java.xml.transform.Result ， Writer或OutputStream为尚未关闭SQLXML对象
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setObject

        void setObject​(int parameterIndex,
               Object x,
               int targetSqlType,
               int scaleOrLength)
        throws SQLException

        使用给定对象设置指定参数的值。 如果第二个参数是一个InputStream则流必须包含由scaleOrLength指定的字节数。 如果第二个参数为Reader则读取器必须包含scaleOrLength指定的字符数。 如果这些条件不正确，驱动程序将在执行准备好的语句时生成SQLException 。

        在发送给数据库之前，给定的Java对象将被转换为给定的targetSqlType。 如果对象具有自定义映射（是实现接口SQLData的类），则JDBC驱动程序应调用方法SQLData.writeSQL将其写入SQL数据流。 如果，在另一方面，对象是实现一类Ref ， Blob ， Clob ， NClob ， Struct ， java.net.URL ，或Array ，驾驶员应把它传递给数据库作为相应SQL类型的值。

        请注意，此方法可能用于传递特定于数据库的抽象数据类型。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含输入参数值的对象
        targetSqlType - 要发送到数据库的SQL类型（定义在java.sql.Types中）。 比例参数可能进一步限定此类型。
        scaleOrLength - 对于java.sql.Types.DECIMAL或java.sql.Types.NUMERIC types ，这是小数点后的数字位数。 对于Java对象类型InputStream和Reader ，这是流或读取器中数据的长度。 对于所有其他类型，此值将被忽略。
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误; 该方法在关闭的PreparedStatement上调用，或者如果由x指定的Java对象是InputStream或Reader对象，并且scale参数的值小于零
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的targetSqlType
        另请参见：
        Types

      • setAsciiStream

        void setAsciiStream​(int parameterIndex,
                    InputStream x,
                    long length)
             throws SQLException
        将指定的参数设置为给定的输入流，它将具有指定的字节数。 当输入非常大的ASCII值到LONGVARCHAR参数时，通过java.io.InputStream发送它可能更实用。 将根据需要从流中读取数据，直到达到文件结尾。 JDBC驱动程序将从ASCII到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含ASCII参数值的Java输入流
        length - 流中的字节数
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        从以下版本开始：
        1.6

      • setBinaryStream

        void setBinaryStream​(int parameterIndex,
                     InputStream x,
                     long length)
              throws SQLException
        将指定的参数设置为给定的输入流，它将具有指定的字节数。 当一个非常大的二进制值输入到一个LONGVARBINARY参数时，通过一个java.io.InputStream对象发送它可能比较实用。 数据将从流中读取，直到达到文件结尾。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含二进制参数值的java输入流
        length - 流中的字节数
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        从以下版本开始：
        1.6

      • setCharacterStream

        void setCharacterStream​(int parameterIndex,
                        Reader reader,
                        long length)
                 throws SQLException
        将指定的参数设置为给定的Reader对象，这是给定的长度的字符数。 当将非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更实用。 数据将从流中读取，直到达到文件结尾。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        reader - 包含Unicode数据的 java.io.Reader对象
        length - 流中的字符数
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        从以下版本开始：
        1.6

      • setAsciiStream

        void setAsciiStream​(int parameterIndex,
                    InputStream x)
             throws SQLException
        将指定的参数设置为给定的输入流。 当一个非常大的ASCII值输入到LONGVARCHAR参数时，通过java.io.InputStream发送它可能更实用。 将根据需要从流中读取数据，直到达到文件结尾。 JDBC驱动程序将从ASCII到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的setAsciiStream带有长度参数。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含ASCII参数值的Java输入流
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setBinaryStream

        void setBinaryStream​(int parameterIndex,
                     InputStream x)
              throws SQLException
        将指定的参数设置为给定的输入流。 当一个非常大的二进制值输入到一个LONGVARBINARY参数时，通过一个java.io.InputStream对象发送它可能比较实际。 数据将从流中读取，直到达到文件结尾。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的setBinaryStream带有长度参数。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含二进制参数值的java输入流
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setCharacterStream

        void setCharacterStream​(int parameterIndex,
                        Reader reader)
                 throws SQLException
        将指定的参数设置为给定的Reader对象。 当将非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更实用。 数据将从流中读取，直到达到文件结尾。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的setCharacterStream带有长度参数。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        reader - 包含Unicode数据的 java.io.Reader对象
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNCharacterStream

        void setNCharacterStream​(int parameterIndex,
                         Reader value)
                  throws SQLException
        将指定的参数设置为Reader对象。 Reader读取数据，直到达到文件结尾。 驱动程序必须从Java字符格式转换为数据库中的国家字符集。

        注意：此流对象可以是标准Java流对象，也可以是实现标准接口的自己的子类。

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的setNCharacterStream带有长度参数。

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        value - 参数值
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误;
或者这个方法在一个封闭的PreparedStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setClob

        void setClob​(int parameterIndex,
             Reader reader)
      throws SQLException
        将指定的参数设置为Reader对象。 该方法与setCharacterStream (int, Reader)方法不同，因为它通知驱动程序参数值应作为CLOB发送到服务器。 当使用setCharacterStream方法时，驱动程序可能需要进行额外的工作才能确定是否应将参数数据作为LONGVARCHAR或CLOB发送到服务器

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的setClob带有长度参数。

        参数
        parameterIndex - 第一个参数的索引为1，第二个为2，...
        reader - 包含将参数值设置为的数据的对象。
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误; 该方法在关闭的PreparedStatement上调用，或者如果parameterIndex与SQL语句中的参数标记不对应
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setBlob

        void setBlob​(int parameterIndex,
             InputStream inputStream)
      throws SQLException
        将指定的参数设置为InputStream对象。 该方法与setBinaryStream (int, InputStream)方法不同，因为它通知驱动程序参数值应作为BLOB发送到服务器。 当使用setBinaryStream方法时，驱动程序可能需要进行额外的工作才能确定参数数据是否应作为LONGVARBINARY或BLOB发送到服务器

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的setBlob带有长度参数。

        参数
        parameterIndex - 第一个参数的索引为1，第二个为2，...
        inputStream - 包含用于设置参数值的数据的对象。
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误; 这个方法在关闭的PreparedStatement上调用，或者如果parameterIndex与SQL语句中的参数标记不对应，
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setNClob

        void setNClob​(int parameterIndex,
              Reader reader)
       throws SQLException
        将指定的参数设置为Reader对象。 该方法与setCharacterStream (int, Reader)方法不同，因为它通知驱动程序参数值应作为NCLOB发送到服务器。 当使用setCharacterStream方法时，驱动程序可能需要进行额外的工作才能确定是否应将参数数据作为LONGNVARCHAR或NCLOB发送到服务器

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本setNClob可能会更有效。

        参数
        parameterIndex - 第一个参数的索引为1，第二个为2，...
        reader - 包含将参数值设置为的数据的对象。
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setObject

        default void setObject​(int parameterIndex,
                       Object x,
                       SQLType targetSqlType,
                       int scaleOrLength)
                throws SQLException

        使用给定对象设置指定参数的值。 如果第二个参数是一个InputStream则流必须包含scaleOrLength指定的字节数。 如果第二个参数是Reader则读者必须包含由scaleOrLength指定的字符数。 如果这些条件不正确，驱动程序将在执行准备好的语句时生成一个SQLException 。

        在发送给数据库之前，给定的Java对象将被转换为给定的targetSqlType。 如果对象具有自定义映射（实现接口SQLData的类），则JDBC驱动程序应调用方法SQLData.writeSQL将其写入SQL数据流。 如果，在另一方面，对象是实现一类Ref ， Blob ， Clob ， NClob ， Struct ， java.net.URL ，或Array ，驾驶员应把它传递给数据库作为相应SQL类型的值。

        请注意，此方法可能用于传递特定于数据库的抽象数据类型。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含输入参数值的对象
        targetSqlType - 要发送到数据库的SQL类型。 比例参数可能进一步限定此类型。
        scaleOrLength - 对于java.sql.JDBCType.DECIMAL或java.sql.JDBCType.NUMERIC types ，这是小数点后的位数。 对于Java对象类型InputStream和Reader ，这是流或读取器中数据的长度。 对于所有其他类型，此值将被忽略。
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法，或者如果x指定的Java对象是InputStream或Reader对象，并且scale参数的值小于零
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • setObject

        default void setObject​(int parameterIndex,
                       Object x,
                       SQLType targetSqlType)
                throws SQLException
        使用给定对象设置指定参数的值。 该方法类似于setObject(int parameterIndex, Object x, SQLType targetSqlType, int scaleOrLength) ，除了它假定为零。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        parameterIndex - 第一个参数是1，第二个是2，...
        x - 包含输入参数值的对象
        targetSqlType - 要发送到数据库的SQL类型
        异常
        SQLException - 如果parameterIndex不对应于SQL语句中的参数标记; 如果发生数据库访问错误或在关闭的PreparedStatement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • executeLargeUpdate

        default long executeLargeUpdate​()
                         throws SQLException
        执行在该SQL语句PreparedStatement对象，它必须是一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。

        当返回的行数可能超过Integer.MAX_VALUE时，应使用此方法。

        默认实现将抛出UnsupportedOperationException

        结果
        （1）SQL数据操作语言（DML）语句的行计数或（2）0不返回的SQL语句
        异常
        SQLException - 如果发生数据库访问错误; 此方法在关闭的PreparedStatement上调用，或者SQL语句返回一个ResultSet对象
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PseudoColumnUsage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.sql
软件包 java.sql

Enum PseudoColumnUsage

  • java.lang.Object
    • java.lang.Enum<PseudoColumnUsage>
      • java.sql.PseudoColumnUsage
  • All Implemented Interfaces:
    Serializable ， Comparable<PseudoColumnUsage>

    public enum PseudoColumnUsage
extends Enum<PseudoColumnUsage>
    伪/隐藏列使用枚举。
    从以下版本开始：
    1.7
    另请参见：
    DatabaseMetaData.getPseudoColumns(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NO_USAGE_RESTRICTIONS
      伪/隐藏列的使用没有限制。
      SELECT_LIST_ONLY
      伪/隐藏列只能在SELECT列表中使用。
      USAGE_UNKNOWN
      伪/隐藏列的使用无法确定。
      WHERE_CLAUSE_ONLY
      伪/隐藏列只能在WHERE子句中使用。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PseudoColumnUsage valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PseudoColumnUsage[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SELECT_LIST_ONLY

        public static final PseudoColumnUsage SELECT_LIST_ONLY
        伪/隐藏列只能在SELECT列表中使用。

      • WHERE_CLAUSE_ONLY

        public static final PseudoColumnUsage WHERE_CLAUSE_ONLY
        伪/隐藏列只能在WHERE子句中使用。

      • NO_USAGE_RESTRICTIONS

        public static final PseudoColumnUsage NO_USAGE_RESTRICTIONS
        伪/隐藏列的使用没有限制。

      • USAGE_UNKNOWN

        public static final PseudoColumnUsage USAGE_UNKNOWN
        伪/隐藏列的使用无法确定。

    • 方法详细信息

      • values

        public static PseudoColumnUsage[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PseudoColumnUsage c : PseudoColumnUsage.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PseudoColumnUsage valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Ref (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Ref

  • 所有已知实现类：
    SerialRef

    public interface Ref
    SQL编程语言中的映射SQL REF值，它是对数据库中SQL结构化类型值的引用。

    SQL REF值存储在一个包含可引用SQL结构类型的实例的表，并且每个REF值是在该表中一个实例的唯一标识符。 可以使用SQL REF值代替其引用的SQL结构化类型，作为表中的列值或结构化类型中的属性值。

    因为SQL REF值是指向SQL结构类型的逻辑指针，所以默认情况下， Ref对象也是一个逻辑指针。 因此，作为Ref对象检索SQL REF值并未实现客户端上的结构化类型的属性。

    一个Ref对象可以使用PreparedStatement.setRef方法存储在数据库中。

    如果JDBC驱动程序支持数据类型，则必须完全实现Ref接口上的所有方法。

    从以下版本开始：
    1.2
    另请参见：
    Struct

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getBaseTypeName​()
      检索此 Ref对象引用的SQL结构类型的完全限定SQL名称。
      Object getObject​()
      检索此 Ref对象引用的SQL结构类型实例。
      Object getObject​(Map<String,Class<?>> map)
      检索引用的对象，并使用给定的类型映射将其映射到Java类型。
      void setObject​(Object value)
      将此 Ref对象引用的给定实例的结构化类型值设置为 Object 。

    • 方法详细信息

      • getBaseTypeName

        String getBaseTypeName​()
                throws SQLException
        检索此 Ref对象引用的SQL结构类型的全限定SQL名称。
        结果
        引用的SQL结构化类型的全限定SQL名称
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getObject

        Object getObject​(Map<String,Class<?>> map)
          throws SQLException
        检索引用的对象，并使用给定的类型映射将其映射到Java类型。
        参数
        map - 一个 java.util.Map对象，其中包含要使用的映射（被引用的SQL结构化类型的完全限定名称，以及将被映射到SQL结构类型的 SQLData实现的类对象）
        结果
        一个Java Object ，这是这个 Ref对象引用的SQL结构类型的自定义映射
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setObject(java.lang.Object)

      • getObject

        Object getObject​()
          throws SQLException
        检索此Ref对象引用的SQL结构类型实例。 如果连接的类型映射具有结构化类型的条目，则实例将被自定义映射到类型映射中指示的Java类。 否则，结构化类型实例将映射到一个Struct对象。
        结果
        一个Java Object ，这是该 Ref对象引用的SQL结构类型的映射
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        setObject(java.lang.Object)

      • setObject

        void setObject​(Object value)
        throws SQLException
        将此Ref对象引用的给定实例的结构化类型值设置为Object 。 当驱动程序将其发送到数据库时，将其转换为SQL结构类型。
        参数
        value -一个 Object表示SQL结构类型实例，这 Ref对象将引用
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4
        另请参见：
        getObject() ， getObject(Map) ， PreparedStatement.setObject(int, Object) ， CallableStatement.setObject(String, Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ResultSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface ResultSet

  • All Superinterfaces:
    AutoCloseable ， Wrapper
    All Known Subinterfaces:
    CachedRowSet ， FilteredRowSet ， JdbcRowSet ， JoinRowSet ， RowSet ， SyncResolver ， WebRowSet

    public interface ResultSet
extends Wrapper, AutoCloseable
    表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。

    A ResultSet对象维护指向其当前数据行的光标。 最初，光标位于第一行之前。 next方法将光标移动到下一行，并且因为在ResultSet对象中没有更多行时返回false ，因此可以在while循环中使用循环来遍历结果集。

    默认的ResultSet对象不可更新，并且只有一个向前移动的光标。 因此，您只能从第一行到最后一行迭代一次。 可以生成ResultSet可滚动和/或可更新的对象。 以下代码片段（其中con是有效的Connection对象）说明了如何使其可以滚动并对其他人的更新不敏感的结果集，这是可更新的。 请参阅ResultSet其他选项的字段。

      Statement stmt = con.createStatement(
                                      ResultSet.TYPE_SCROLL_INSENSITIVE,
                                      ResultSet.CONCUR_UPDATABLE);
       ResultSet rs = stmt.executeQuery("SELECT a, b FROM TABLE2");
       // rs will be scrollable, will not show changes made by others,
       // and will be updatable
    所述ResultSet接口提供getter方法（ getBoolean ， getLong用于从当前行检索列值，等等）。 可以使用列的索引号或列的名称来检索值。 一般来说，使用列索引将更有效率。 列从1编号。为了最大可移植性，每行中的结果集列应以从左到右的顺序读取，每列应只读一次。

    对于getter方法，JDBC驱动程序尝试将底层数据转换为getter方法中指定的Java类型，并返回合适的Java值。 JDBC规范有一个表格，显示了可从ResultSet getter方法使用的SQL类型到Java类型的允许映射。

    用作getter方法输入的列名不区分大小写。 当使用列名称调用getter方法时，多个列具有相同的名称，将返回第一个匹配列的值。 列名称选项用于在生成结果集的SQL查询中使用列名时使用。 对于在查询中未明确命名的列，最好使用列号。 如果使用列名称，程序员应该小心保证它们唯一地引用预期的列，这可以通过SQL AS子句来确保。

    JDBC 2.0 API（Java¢2 SDK，Standard Edition，1.2版）中的此接口添加了一组更新方法。 关于getter方法参数的注释也适用于updater方法的参数。

    更新方法可以以两种方式使用：

    1. 更新当前行中的列值。 在可滚动的ResultSet对象中，光标可以向后和向前移动到绝对位置或相对于当前行的位置。 下面的代码段更新NAME所述的第五行中列ResultSet对象rs ，然后使用方法updateRow来更新该数据的源表rs推导。
        rs.absolute(5); // moves the cursor to the fifth row of rs
       rs.updateString("NAME", "AINSWORTH"); // updates the
          // NAME column of row 5 to be AINSWORTH
       rs.updateRow(); // updates the row in the data source
    2. 将列值插入到插入行中。 可更新的ResultSet对象具有与其相关联的特殊行，其用作构建要插入的行的暂存区域。 以下代码片段将光标移动到插入行，构建一个三列的行，并将其插入到rs并进入使用该方法将数据源表insertRow 。
        rs.moveToInsertRow(); // moves cursor to the insert row
       rs.updateString(1, "AINSWORTH"); // updates the
          // first column of the insert row to be AINSWORTH
       rs.updateInt(2,35); // updates the second column to be 35
       rs.updateBoolean(3, true); // updates the third column to true
       rs.insertRow();
       rs.moveToCurrentRow();

    当生成它的Statement对象被关闭，重新执行或用于从多个结果序列中检索下一个结果时，一个ResultSet对象将自动关闭。

    ResultSet对象列的数量，类型和属性由ResultSet.getMetaData方法返回的ResultSetMetaData对象提供。

    从以下版本开始：
    1.1
    另请参见：
    Statement.executeQuery(java.lang.String) ， Statement.getResultSet() ， ResultSetMetaData

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CLOSE_CURSORS_AT_COMMIT
      指示当前事务提交时，表示具有此 ResultSet对象的常量将被关闭。
      static int CONCUR_READ_ONLY
      该常量指示可能无法更新的 ResultSet对象的并发模式。
      static int CONCUR_UPDATABLE
      该常量指示可能更新的 ResultSet对象的并发模式。
      static int FETCH_FORWARD
      指示结果集中的行将在向前方向处理的常数; 第一个到最后。
      static int FETCH_REVERSE
      指示结果集中的行将以相反方向处理的常数; 最后到第一位。
      static int FETCH_UNKNOWN
      指示结果集中的行将被处理的顺序的常量是未知的。
      static int HOLD_CURSORS_OVER_COMMIT
      这表明开放的不断 ResultSet当前事务时承诺的对象具有此可保存性将继续开放。
      static int TYPE_FORWARD_ONLY
      指示其光标可以向前移动的 ResultSet对象的类型的常量。
      static int TYPE_SCROLL_INSENSITIVE
      该常量指示 ResultSet对象的类型，该对象是可滚动的，但对 ResultSet的数据更改通常不敏感。
      static int TYPE_SCROLL_SENSITIVE
      该常量指示 ResultSet对象的类型，该对象是可滚动的，并且对 ResultSet基础数据的更改通常很敏感。

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods 弃用的方法
      Modifier and Type 方法 描述
      boolean absolute​(int row)
      将光标移动到此 ResultSet对象中的给定行号。
      void afterLast​()
      将光标移动到 ResultSet对象的末尾，就在最后一行之后。
      void beforeFirst​()
      将光标移动到 ResultSet对象的正面，就在第一行之前。
      void cancelRowUpdates​()
      取消对此 ResultSet对象中当前行的更新。
      void clearWarnings​()
      清除此 ResultSet对象上报告的所有警告。
      void close​()
      立即释放此 ResultSet对象的数据库和JDBC资源，而不是等待其自动关闭时发生。
      void deleteRow​()
      从此 ResultSet对象和底层数据库中删除当前行。
      int findColumn​(String columnLabel)
      将给定的 ResultSet列标签映射到其 ResultSet列索引。
      boolean first​()
      将光标移动到此 ResultSet对象中的第一行。
      Array getArray​(int columnIndex)
      以Java编程语言中的 ResultSet对象的形式 Array此 ResultSet对象的当前行中指定列的值。
      Array getArray​(String columnLabel)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 Array对象。
      InputStream getAsciiStream​(int columnIndex)
      将此 ResultSet对象的当前行中指定列的值作为ASCII字符流 ResultSet 。
      InputStream getAsciiStream​(String columnLabel)
      将此 ResultSet对象的当前行中指定列的值作为ASCII字符流 ResultSet 。
      BigDecimal getBigDecimal​(int columnIndex)
      在 ResultSet对象的当前行中的指定列的值作为 java.math.BigDecimal完全精确 java.math.BigDecimal 。
      BigDecimal getBigDecimal​(int columnIndex, int scale)
      已过时。
      使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
      BigDecimal getBigDecimal​(String columnLabel)
      在 ResultSet对象的当前行中的指定列的值作为 java.math.BigDecimal完全精确 java.math.BigDecimal 。
      BigDecimal getBigDecimal​(String columnLabel, int scale)
      已过时。
      使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
      InputStream getBinaryStream​(int columnIndex)
      将此 ResultSet对象的当前行中指定列的值作为未解释的字节流 ResultSet 。
      InputStream getBinaryStream​(String columnLabel)
      检索该 ResultSet对象的当前行中指定列的值，作为未解释的流 byte s。
      Blob getBlob​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Blob对象。
      Blob getBlob​(String columnLabel)
      以Java编程语言中的 ResultSet对象的形式 Blob此 ResultSet对象的当前行中指定列的值。
      boolean getBoolean​(int columnIndex)
      检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 boolean 。
      boolean getBoolean​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 boolean 。
      byte getByte​(int columnIndex)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 byte 。
      byte getByte​(String columnLabel)
      以Java编程语言中的 byte此 ResultSet对象的当前行中指定列的值。
      byte[] getBytes​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 byte数组。
      byte[] getBytes​(String columnLabel)
      以Java编程语言中的 byte数组来检索此 ResultSet对象的当前行中指定列的值。
      Reader getCharacterStream​(int columnIndex)
      以 ResultSet对象的形式 java.io.Reader此 ResultSet对象的当前行中指定列的值。
      Reader getCharacterStream​(String columnLabel)
      以 ResultSet对象的形式 java.io.Reader此 ResultSet对象的当前行中指定列的值。
      Clob getClob​(int columnIndex)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 Clob对象。
      Clob getClob​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Clob对象。
      int getConcurrency​()
      检索此 ResultSet对象的并发模式。
      String getCursorName​()
      检索此 ResultSet对象使用的SQL游标的名称。
      Date getDate​(int columnIndex)
      这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Date的Java编程语言对象。
      Date getDate​(int columnIndex, Calendar cal)
      检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Date对象。
      Date getDate​(String columnLabel)
      以Java编程语言中的 java.sql.Date对象获取此 ResultSet对象的当前行中指定列的值。
      Date getDate​(String columnLabel, Calendar cal)
      以Java编程语言中的 java.sql.Date对象获取此 ResultSet对象的当前行中指定列的值。
      double getDouble​(int columnIndex)
      以Java编程语言中的 double此 ResultSet对象的当前行中指定列的值。
      double getDouble​(String columnLabel)
      以Java编程语言中的 double此 ResultSet对象的当前行中指定列的值。
      int getFetchDirection​()
      检索此 ResultSet对象的抓取方向。
      int getFetchSize​()
      检索此 ResultSet对象的提取大小。
      float getFloat​(int columnIndex)
      检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 float 。
      float getFloat​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 float 。
      int getHoldability​()
      检索此 ResultSet对象的 ResultSet
      int getInt​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 int 。
      int getInt​(String columnLabel)
      以Java编程语言中的 int此 ResultSet对象的当前行中指定列的值。
      long getLong​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 long 。
      long getLong​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 long 。
      ResultSetMetaData getMetaData​()
      检索此 ResultSet对象列的数量，类型和属性。
      Reader getNCharacterStream​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值作为 java.io.Reader对象。
      Reader getNCharacterStream​(String columnLabel)
      以 ResultSet对象的形式 java.io.Reader此 ResultSet对象的当前行中指定列的值。
      NClob getNClob​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 NClob对象。
      NClob getNClob​(String columnLabel)
      这个检索的当前行中指定列的值 ResultSet对象为 NClob的Java编程语言对象。
      String getNString​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 String 。
      String getNString​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 String 。
      Object getObject​(int columnIndex)
      获取此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Object 。
      <T> T getObject​(int columnIndex, Class<T> type)
      检索此 ResultSet对象的当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。
      Object getObject​(int columnIndex, Map<String,Class<?>> map)
      以Java编程语言中的 Object此 ResultSet对象的当前行中指定列的值。
      Object getObject​(String columnLabel)
      获取此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Object 。
      <T> T getObject​(String columnLabel, Class<T> type)
      检索此 ResultSet对象的当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。
      Object getObject​(String columnLabel, Map<String,Class<?>> map)
      以Java编程语言中的 Object此 ResultSet对象的当前行中指定列的值。
      Ref getRef​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Ref对象。
      Ref getRef​(String columnLabel)
      以Java编程语言中的 Ref对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      int getRow​()
      检索当前行号。
      RowId getRowId​(int columnIndex)
      以该Java编程语言中的 java.sql.RowId对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      RowId getRowId​(String columnLabel)
      以Java编程语言中的 java.sql.RowId对象获取此 ResultSet对象的当前行中指定列的值。
      short getShort​(int columnIndex)
      以Java编程语言中的 short此 ResultSet对象的当前行中指定列的值。
      short getShort​(String columnLabel)
      以Java编程语言中的 short此 ResultSet对象的当前行中指定列的值。
      SQLXML getSQLXML​(int columnIndex)
      检索此 ResultSet的当前行中指定列的值为Java编程语言中的 java.sql.SQLXML对象。
      SQLXML getSQLXML​(String columnLabel)
      以Java编程语言中的 java.sql.SQLXML对象的形式获取此 ResultSet的当前行中指定列的值。
      Statement getStatement​()
      检索 Statement生成此对象 ResultSet对象。
      String getString​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 String 。
      String getString​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 String 。
      Time getTime​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
      Time getTime​(int columnIndex, Calendar cal)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
      Time getTime​(String columnLabel)
      以Java编程语言的 ResultSet对象的形式 java.sql.Time此 ResultSet对象的当前行中指定列的值。
      Time getTime​(String columnLabel, Calendar cal)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
      Timestamp getTimestamp​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Timestamp对象。
      Timestamp getTimestamp​(int columnIndex, Calendar cal)
      以Java编程语言的 java.sql.Timestamp对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      Timestamp getTimestamp​(String columnLabel)
      以Java编程语言的 ResultSet对象的形式 java.sql.Timestamp此 ResultSet对象的当前行中指定列的值。
      Timestamp getTimestamp​(String columnLabel, Calendar cal)
      以Java编程语言中的 ResultSet对象的形式 java.sql.Timestamp此 ResultSet对象的当前行中指定列的值。
      int getType​()
      检索此 ResultSet对象的类型。
      InputStream getUnicodeStream​(int columnIndex)
      已过时。
      使用getCharacterStream代替getUnicodeStream
      InputStream getUnicodeStream​(String columnLabel)
      已过时。
      改用getCharacterStream
      URL getURL​(int columnIndex)
      以Java编程语言的 java.net.URL对象的形式， ResultSet对象的当前行中指定列的值。
      URL getURL​(String columnLabel)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.net.URL对象。
      SQLWarning getWarnings​()
      检索该 ResultSet对象上的通话报告的第一个警告。
      void insertRow​()
      将插入行的内容插入到此 ResultSet对象中并进入数据库。
      boolean isAfterLast​()
      检索光标是否在此 ResultSet对象的最后一行之后。
      boolean isBeforeFirst​()
      检索光标是否在此 ResultSet对象中的第一行之前。
      boolean isClosed​()
      检索此 ResultSet对象是否已关闭。
      boolean isFirst​()
      检索光标是否在 ResultSet对象的第一行。
      boolean isLast​()
      检索光标是否在 ResultSet对象的最后一行。
      boolean last​()
      将光标移动到此 ResultSet对象中的最后一行。
      void moveToCurrentRow​()
      将光标移动到记住的光标位置，通常是当前行。
      void moveToInsertRow​()
      将光标移动到插入行。
      boolean next​()
      将光标从当前位置向前移动一行。
      boolean previous​()
      将光标移动到此 ResultSet对象中的上一行。
      void refreshRow​()
      用数据库中最新的值刷新当前行。
      boolean relative​(int rows)
      将光标移动到正或负的相对行数。
      boolean rowDeleted​()
      检索行是否被删除。
      boolean rowInserted​()
      检索当前行是否有插入。
      boolean rowUpdated​()
      检索当前行是否已更新。
      void setFetchDirection​(int direction)
      给出这个 ResultSet对象中的行将被处理的方向的提示。
      void setFetchSize​(int rows)
      给JDBC驱动程序提供一个关于应该从数据库中获取的行数，这个更多的行需要 ResultSet对象。
      void updateArray​(int columnIndex, Array x)
      使用 java.sql.Array值更新指定的列。
      void updateArray​(String columnLabel, Array x)
      使用 java.sql.Array值更新指定的列。
      void updateAsciiStream​(int columnIndex, InputStream x)
      使用ascii流值更新指定的列。
      void updateAsciiStream​(int columnIndex, InputStream x, int length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void updateAsciiStream​(int columnIndex, InputStream x, long length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void updateAsciiStream​(String columnLabel, InputStream x)
      使用ascii流值更新指定的列。
      void updateAsciiStream​(String columnLabel, InputStream x, int length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void updateAsciiStream​(String columnLabel, InputStream x, long length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void updateBigDecimal​(int columnIndex, BigDecimal x)
      使用 java.math.BigDecimal值更新指定的列。
      void updateBigDecimal​(String columnLabel, BigDecimal x)
      使用 java.sql.BigDecimal值更新指定的列。
      void updateBinaryStream​(int columnIndex, InputStream x)
      使用二进制流值更新指定的列。
      void updateBinaryStream​(int columnIndex, InputStream x, int length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void updateBinaryStream​(int columnIndex, InputStream x, long length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void updateBinaryStream​(String columnLabel, InputStream x)
      使用二进制流值更新指定的列。
      void updateBinaryStream​(String columnLabel, InputStream x, int length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void updateBinaryStream​(String columnLabel, InputStream x, long length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void updateBlob​(int columnIndex, InputStream inputStream)
      使用给定的输入流更新指定的列。
      void updateBlob​(int columnIndex, InputStream inputStream, long length)
      使用给定的输入流更新指定列，该输入流将具有指定的字节数。
      void updateBlob​(int columnIndex, Blob x)
      使用 java.sql.Blob值更新指定的列。
      void updateBlob​(String columnLabel, InputStream inputStream)
      使用给定的输入流更新指定的列。
      void updateBlob​(String columnLabel, InputStream inputStream, long length)
      使用给定的输入流更新指定列，该输入流将具有指定的字节数。
      void updateBlob​(String columnLabel, Blob x)
      使用 java.sql.Blob值更新指定的列。
      void updateBoolean​(int columnIndex, boolean x)
      使用 boolean值更新指定的列。
      void updateBoolean​(String columnLabel, boolean x)
      使用 boolean值更新指定的列。
      void updateByte​(int columnIndex, byte x)
      使用 byte值更新指定的列。
      void updateByte​(String columnLabel, byte x)
      使用 byte值更新指定的列。
      void updateBytes​(int columnIndex, byte[] x)
      使用 byte数组值更新指定的列。
      void updateBytes​(String columnLabel, byte[] x)
      使用字节数组值更新指定的列。
      void updateCharacterStream​(int columnIndex, Reader x)
      使用字符流值更新指定的列。
      void updateCharacterStream​(int columnIndex, Reader x, int length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void updateCharacterStream​(int columnIndex, Reader x, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void updateCharacterStream​(String columnLabel, Reader reader)
      使用字符流值更新指定的列。
      void updateCharacterStream​(String columnLabel, Reader reader, int length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void updateCharacterStream​(String columnLabel, Reader reader, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void updateClob​(int columnIndex, Reader reader)
      使用给定的 Reader对象更新指定的列。
      void updateClob​(int columnIndex, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的字符数。
      void updateClob​(int columnIndex, Clob x)
      使用 java.sql.Clob值更新指定的列。
      void updateClob​(String columnLabel, Reader reader)
      使用给定的 Reader对象更新指定的列。
      void updateClob​(String columnLabel, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的字符数。
      void updateClob​(String columnLabel, Clob x)
      使用 java.sql.Clob值更新指定的列。
      void updateDate​(int columnIndex, Date x)
      使用 java.sql.Date值更新指定的列。
      void updateDate​(String columnLabel, Date x)
      使用 java.sql.Date值更新指定的列。
      void updateDouble​(int columnIndex, double x)
      使用 double值更新指定的列。
      void updateDouble​(String columnLabel, double x)
      使用 double值更新指定的列。
      void updateFloat​(int columnIndex, float x)
      使用 float值更新指定的列。
      void updateFloat​(String columnLabel, float x)
      使用 float值更新指定的列。
      void updateInt​(int columnIndex, int x)
      使用 int值更新指定的列。
      void updateInt​(String columnLabel, int x)
      使用 int值更新指定的列。
      void updateLong​(int columnIndex, long x)
      使用 long值更新指定的列。
      void updateLong​(String columnLabel, long x)
      使用 long值更新指定的列。
      void updateNCharacterStream​(int columnIndex, Reader x)
      使用字符流值更新指定的列。
      void updateNCharacterStream​(int columnIndex, Reader x, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void updateNCharacterStream​(String columnLabel, Reader reader)
      使用字符流值更新指定的列。
      void updateNCharacterStream​(String columnLabel, Reader reader, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void updateNClob​(int columnIndex, Reader reader)
      使用给定的 Reader更新指定的列。根据需要，将从流中读取数据，直到达到流出端。
      void updateNClob​(int columnIndex, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的字符长度。
      void updateNClob​(int columnIndex, NClob nClob)
      使用 java.sql.NClob值更新指定的列。
      void updateNClob​(String columnLabel, Reader reader)
      使用给定的 Reader对象更新指定的列。
      void updateNClob​(String columnLabel, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的字符数。
      void updateNClob​(String columnLabel, NClob nClob)
      使用 java.sql.NClob值更新指定的列。
      void updateNString​(int columnIndex, String nString)
      使用 String值更新指定的列。
      void updateNString​(String columnLabel, String nString)
      使用 String值更新指定的列。
      void updateNull​(int columnIndex)
      使用 null值更新指定的列。
      void updateNull​(String columnLabel)
      使用 null值更新指定的列。
      void updateObject​(int columnIndex, Object x)
      使用 Object值更新指定的列。
      void updateObject​(int columnIndex, Object x, int scaleOrLength)
      使用 Object值更新指定的列。
      default void updateObject​(int columnIndex, Object x, SQLType targetSqlType)
      使用 Object值更新指定的列。
      default void updateObject​(int columnIndex, Object x, SQLType targetSqlType, int scaleOrLength)
      使用 Object值更新指定的列。
      void updateObject​(String columnLabel, Object x)
      使用 Object值更新指定的列。
      void updateObject​(String columnLabel, Object x, int scaleOrLength)
      使用 Object值更新指定的列。
      default void updateObject​(String columnLabel, Object x, SQLType targetSqlType)
      使用 Object值更新指定的列。
      default void updateObject​(String columnLabel, Object x, SQLType targetSqlType, int scaleOrLength)
      使用 Object值更新指定的列。
      void updateRef​(int columnIndex, Ref x)
      使用 java.sql.Ref值更新指定的列。
      void updateRef​(String columnLabel, Ref x)
      使用 java.sql.Ref值更新指定的列。
      void updateRow​()
      使用此 ResultSet对象的当前行的新内容更新底层数据库。
      void updateRowId​(int columnIndex, RowId x)
      使用 RowId值更新指定的列。
      void updateRowId​(String columnLabel, RowId x)
      使用 RowId值更新指定的列。
      void updateShort​(int columnIndex, short x)
      使用 short值更新指定的列。
      void updateShort​(String columnLabel, short x)
      使用 short值更新指定的列。
      void updateSQLXML​(int columnIndex, SQLXML xmlObject)
      使用 java.sql.SQLXML值更新指定的列。
      void updateSQLXML​(String columnLabel, SQLXML xmlObject)
      使用 java.sql.SQLXML值更新指定的列。
      void updateString​(int columnIndex, String x)
      使用 String值更新指定的列。
      void updateString​(String columnLabel, String x)
      使用 String值更新指定的列。
      void updateTime​(int columnIndex, Time x)
      使用 java.sql.Time值更新指定的列。
      void updateTime​(String columnLabel, Time x)
      使用 java.sql.Time值更新指定的列。
      void updateTimestamp​(int columnIndex, Timestamp x)
      使用 java.sql.Timestamp值更新指定的列。
      void updateTimestamp​(String columnLabel, Timestamp x)
      使用 java.sql.Timestamp值更新指定的列。
      boolean wasNull​()
      报告最后一列读取的值是否为 NULL 。

      • Methods inherited from interface java.sql.Wrapper

        isWrapperFor, unwrap

    • 字段详细信息

      • FETCH_FORWARD

        static final int FETCH_FORWARD
        指示结果集中的行将在向前方向处理的常数; 第一个到最后。 该常数由方法setFetchDirection用作驱动程序的提示，驱动程序可以忽略该常量。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • FETCH_REVERSE

        static final int FETCH_REVERSE
        指示结果集中的行将以相反方向处理的常数; 最后到第一位。 该常数由方法setFetchDirection用作驱动程序的提示，驱动程序可以忽略该常量。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • FETCH_UNKNOWN

        static final int FETCH_UNKNOWN
        指示结果集中的行将被处理的顺序的常量是未知的。 该常数由方法setFetchDirection用作驱动程序的提示，驱动程序可以忽略该常量。
        另请参见：
        Constant Field Values

      • TYPE_FORWARD_ONLY

        static final int TYPE_FORWARD_ONLY
        指示其光标可以向前移动的 ResultSet对象的类型的常量。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • TYPE_SCROLL_INSENSITIVE

        static final int TYPE_SCROLL_INSENSITIVE
        该常量指示 ResultSet对象的类型，该对象是可滚动的，但对 ResultSet的数据更改通常不敏感。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • TYPE_SCROLL_SENSITIVE

        static final int TYPE_SCROLL_SENSITIVE
        该常量指示一个类型 ResultSet对象是可滚动的，并改变构成了这一数据一般敏感 ResultSet 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • CONCUR_READ_ONLY

        static final int CONCUR_READ_ONLY
        该常量指示可能不会更新的 ResultSet对象的并发模式。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • CONCUR_UPDATABLE

        static final int CONCUR_UPDATABLE
        该常量指示可能更新的 ResultSet对象的并发模式。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • HOLD_CURSORS_OVER_COMMIT

        static final int HOLD_CURSORS_OVER_COMMIT
        指示打开 ResultSet具有此可保持性的对象的常量将在当前事务提交时保持打开。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • CLOSE_CURSORS_AT_COMMIT

        static final int CLOSE_CURSORS_AT_COMMIT
        指示当前事务提交时，表示打开 ResultSet具有此可保持性的对象的常量将被关闭。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

    • 方法详细信息

      • next

        boolean next​()
      throws SQLException
        将光标从当前位置向前移动一行。 一个ResultSet游标最初位于第一行之前; 方法next的第一个调用使第一行成为当前行; 第二个调用使第二行成为当前行，依此类推。

        当对next方法的调用返回false ，光标位于最后一行之后。 任何调用需要当前行的ResultSet方法将导致抛出SQLException 。 如果结果集类型为TYPE_FORWARD_ONLY ，它是指定的JDBC驱动程序实现是否会返回供应商false或抛出SQLException上的后续调用next 。

        如果当前行的输入流已打开，则对方法next的调用将隐式关闭它。 读取新行时，将清除ResultSet对象的警告链。

        结果
        true如果新的当前行有效; false如果没有更多的行
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • close

        void close​()
    throws SQLException
        立即释放此ResultSet对象的数据库和JDBC资源，而不是等待其自动关闭时发生。

        一个的闭合ResultSet对象不关闭Blob ， Clob或NClob由创建的对象ResultSet 。 Blob ， Clob或NClob对象在它们被创建的，除非他们的交易的至少持续时间保持有效free方法被调用。

        当ResultSet被关闭，任何ResultSetMetaData通过调用中创建的实例getMetaData方法仍然可以访问。

        注意： ResultSet目的是通过自动关闭Statement生成它时该对象Statement对象被关闭时，重新执行，或用于检索从多个结果的序列中的下一结果。

        调用已关闭的ResultSet对象上的方法close是无操作的。

        Specified by:
        close在接口 AutoCloseable
        异常
        SQLException - 如果发生数据库访问错误

      • wasNull

        boolean wasNull​()
         throws SQLException
        报告最后一列读取的值是否为NULL 。 请注意，您必须先在列上调用其中一个getter方法来尝试读取其值，然后调用方法wasNull以查看读取的值是否为SQL NULL 。
        结果
        true如果读取的最后一个列值为SQL NULL ，否则为 false
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getString

        String getString​(int columnIndex)
          throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 String 。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getBoolean

        boolean getBoolean​(int columnIndex)
            throws SQLException
        以Java编程语言中的boolean此ResultSet对象的当前行中指定列的值。

        如果指定列的数据类型为CHAR或VARCHAR，并且包含“0”或数据类型为BIT，TINYINT，SMALLINT，INTEGER或BIGINT，并且包含0，则返回值为false 。 如果指定列的数据类型为CHAR或VARCHAR，并且包含“1”或数据类型为BIT，TINYINT，SMALLINT，INTEGER或BIGINT，并且包含1，则返回值为true 。

        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为false
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getByte

        byte getByte​(int columnIndex)
      throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 byte 。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，返回值为0
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getShort

        short getShort​(int columnIndex)
        throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 short 。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getInt

        int getInt​(int columnIndex)
    throws SQLException
        以Java编程语言中的 int此 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getLong

        long getLong​(int columnIndex)
      throws SQLException
        以Java编程语言中的 long此 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getFloat

        float getFloat​(int columnIndex)
        throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 float 。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getDouble

        double getDouble​(int columnIndex)
          throws SQLException
        以Java编程语言中的 double此 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getBigDecimal

        @Deprecated(since="1.2")
BigDecimal getBigDecimal​(int columnIndex,
                         int scale)
                  throws SQLException
        已过时。 使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
        以Java编程语言中的 java.sql.BigDecimal此 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        scale - 小数点右侧的位数
        结果
        列值; 如果值为SQL NULL ，返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法

      • getBytes

        byte[] getBytes​(int columnIndex)
         throws SQLException
        以Java编程语言的byte数组的形式byte此ResultSet对象的当前行中指定列的值。 字节表示驱动程序返回的原始值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getDate

        Date getDate​(int columnIndex)
      throws SQLException
        检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Date对象。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getTime

        Time getTime​(int columnIndex)
      throws SQLException
        以该Java编程语言中的 java.sql.Time对象的形式，检索该 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getTimestamp

        Timestamp getTimestamp​(int columnIndex)
                throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Timestamp对象。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getAsciiStream

        InputStream getAsciiStream​(int columnIndex)
                    throws SQLException
        将此ResultSet对象的当前行中指定列的值作为ASCII字符流ResultSet 。 然后可以从流中读取大小写的值。 该方法特别适用于检索大量的LONGVARCHAR值。 JDBC驱动程序将从数据库格式进行任何必要的转换为ASCII。

        注意：返回流中的所有数据必须在获取任何其他列的值之前读取。 下一次调用getter方法会隐式关闭流。 此外，当调用方法InputStream.available是否有数据可用时，流可以返回0 。

        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        Java输入流，将数据库列值作为一个字节的ASCII字符流传递; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getUnicodeStream

        @Deprecated(since="1.2")
InputStream getUnicodeStream​(int columnIndex)
                      throws SQLException
        已过时。 使用getCharacterStream代替getUnicodeStream
        检索此ResultSet对象的当前行中指定列的值，以及两字节3个字符的流。 第一个字节是高字节; 第二个字节是低字节。 然后可以从流中读取大小写的值。 该方法特别适用于获取大LONGVARCHAR值。 JDBC驱动程序将从数据库格式进行任何必要的转换为Unicode。

        注意：返回流中的所有数据必须在获取任何其他列的值之前读取。 下一次调用getter方法会隐式关闭流。 此外，一个流可以返回0当方法InputStream.available被调用时，是否有数据可用。

        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        Java输入流，将数据库列值作为两字节Unicode字符流传递; 如果值为SQL NULL ，返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法

      • getBinaryStream

        InputStream getBinaryStream​(int columnIndex)
                     throws SQLException
        检索此ResultSet对象的当前行中指定列的值作为未解释字节流。 然后可以从流中读取大小写的值。 这种方法特别适用于检索大型的LONGVARBINARY值。

        注意：返回流中的所有数据必须在获取任何其他列的值之前读取。 下一次调用getter方法会隐式关闭流。 此外，当方法InputStream.available被调用是否存在可用数据时，流可以返回0 。

        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        将输入数据库列值作为未解释字节流的Java输入流; 如果值为SQL NULL ，返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getString

        String getString​(String columnLabel)
          throws SQLException
        以Java编程语言中的 String此 ResultSet对象当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，返回值为null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getBoolean

        boolean getBoolean​(String columnLabel)
            throws SQLException
        检索此ResultSet对象当前行中指定列的值为Java编程语言中的boolean 。

        如果指定列的数据类型为CHAR或VARCHAR，并且包含“0”或数据类型为BIT，TINYINT，SMALLINT，INTEGER或BIGINT，并且包含0，则返回值为false 。 如果指定列的数据类型为CHAR或VARCHAR，并且包含“1”或数据类型为BIT，TINYINT，SMALLINT，INTEGER或BIGINT，并且包含1，则返回值为true 。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为false
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getByte

        byte getByte​(String columnLabel)
      throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 byte 。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getShort

        short getShort​(String columnLabel)
        throws SQLException
        以Java编程语言中的 short此 ResultSet对象的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getInt

        int getInt​(String columnLabel)
    throws SQLException
        以Java编程语言中的 int此 ResultSet对象的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getLong

        long getLong​(String columnLabel)
      throws SQLException
        以Java编程语言中的 long此 ResultSet对象的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getFloat

        float getFloat​(String columnLabel)
        throws SQLException
        以Java编程语言中的 float此 ResultSet对象当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为0
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getDouble

        double getDouble​(String columnLabel)
          throws SQLException
        以Java编程语言中的 double此 ResultSet对象的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，返回值为0
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getBigDecimal

        @Deprecated(since="1.2")
BigDecimal getBigDecimal​(String columnLabel,
                         int scale)
                  throws SQLException
        已过时。 使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.math.BigDecimal 。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        scale - 小数点右侧的位数
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法

      • getBytes

        byte[] getBytes​(String columnLabel)
         throws SQLException
        以该Java编程语言的byte数组的形式，获取该ResultSet对象的当前行中指定列的值。 字节表示驱动程序返回的原始值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，返回值为null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getDate

        Date getDate​(String columnLabel)
      throws SQLException
        以Java编程语言中的 ResultSet对象的形式 java.sql.Date此 ResultSet对象的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getTime

        Time getTime​(String columnLabel)
      throws SQLException
        检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getTimestamp

        Timestamp getTimestamp​(String columnLabel)
                throws SQLException
        以Java编程语言中的 ResultSet对象的形式 java.sql.Timestamp此 ResultSet对象的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getAsciiStream

        InputStream getAsciiStream​(String columnLabel)
                    throws SQLException
        将此ResultSet对象的当前行中指定列的值作为ASCII字符流ResultSet 。 然后可以从流中读取大小写的值。 这种方法特别适用于检索大量的LONGVARCHAR值。 JDBC驱动程序将从数据库格式进行任何必要的转换为ASCII。

        注意：返回流中的所有数据必须在获取任何其他列的值之前读取。 下一次调用getter方法会隐式关闭流。 此外，当调用方法available是否有数据可用时，流可以返回0 。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个Java输入流，将数据库列值作为一个字节的ASCII字符流传递。 如果值为SQL NULL ，返回值为null 。
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getUnicodeStream

        @Deprecated(since="1.2")
InputStream getUnicodeStream​(String columnLabel)
                      throws SQLException
        已过时。 使用getCharacterStream代替
        检索此ResultSet对象的当前行中指定列的值作为两字节Unicode字符流。 第一个字节是高字节; 第二个字节是低字节。 然后可以从流中读取大小写的值。 该方法特别适用于检索大量的LONGVARCHAR值。 启用JDBC技术的驱动程序将从数据库格式进行任何必要的转换为Unicode。

        注意：返回流中的所有数据必须在获取任何其他列的值之前读取。 下一次调用getter方法会隐式关闭流。 此外，一个流可以返回0当方法InputStream.available被调用时，是否有数据可用。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个Java输入流，将数据库列值作为两字节Unicode字符流传递。 如果值为SQL NULL ，返回值为null 。
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法

      • getBinaryStream

        InputStream getBinaryStream​(String columnLabel)
                     throws SQLException
        将此ResultSet对象的当前行中的指定列的值作为未解释的byte s的流byte 。 然后可以从流中读取大小写的值。 该方法特别适用于获取大LONGVARBINARY值。

        注意：返回流中的所有数据必须在获取任何其他列的值之前读取。 下一次调用getter方法会隐式关闭流。 此外，当调用方法available是否有数据可用时，流可以返回0 。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        将输入数据库列值作为未解释字节流的Java输入流; 如果值为SQL NULL ，则结果为null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getWarnings

        SQLWarning getWarnings​()
                throws SQLException
        检索通过此ResultSet对象的呼叫报告的第一个警告。 此ResultSet对象的后续警告将链接到此方法返回的SQLWarning对象。

        每次阅读新行时，警告链都会自动清除。 此方法可能不会在已关闭的ResultSet对象上调用; 这样做会导致一个SQLException被抛出。

        注意：此警告链只包含由ResultSet方法引起的警告。 由Statement方法（如读取OUT参数）引起的任何警告都将链接到Statement对象。

        结果
        第一个 SQLWarning对象报告或 null如果没有
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • clearWarnings

        void clearWarnings​()
            throws SQLException
        清除此ResultSet对象上报告的所有警告。 调用此方法后，方法getWarnings返回null直到为该ResultSet对象报告新的警告。
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getCursorName

        String getCursorName​()
              throws SQLException
        检索此ResultSet对象使用的SQL游标的名称。

        在SQL中，通过命名的游标检索结果表。 可以使用引用游标名称的定位更新/删除语句来更新或删除结果集的当前行。 为确保光标具有适当的隔离级别以支持更新，光标的SELECT语句应为SELECT FOR UPDATE 。 如果省略FOR UPDATE ，定位更新可能会失败。

        JDBC API通过提供ResultSet对象使用的SQL游标的名称来支持此SQL功能。 ResultSet对象的当前行也是此SQL游标的当前行。

        结果
        这个 ResultSet对象的游标的SQL名称
        异常
        SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法

      • getMetaData

        ResultSetMetaData getMetaData​()
                       throws SQLException
        检索此 ResultSet对象列的数量，类型和属性。
        结果
        这个 ResultSet对象的列的描述
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getObject

        Object getObject​(int columnIndex)
          throws SQLException

        获取此ResultSet对象的当前行中指定列的值为Java编程语言中的Object 。

        此方法将以Java对象的形式返回给定列的值。 Java对象的类型将是与列的SQL类型相对应的默认Java对象类型，遵循JDBC规范中指定的内置类型的映射。 如果值为SQL NULL ，则驱动程序返回一个Java null 。

        此方法也可用于读取数据库特定的抽象数据类型。 在JDBC 2.0 API中，方法getObject的行为被扩展为实现SQL用户定义类型的数据。

        如果Connection.getTypeMap没有抛出一个SQLFeatureNotSupportedException ，那么当一列包含一个结构化或不同的值时，该方法的行为就好像是调用： getObject(columnIndex, this.getStatement().getConnection().getTypeMap()) 。 如果Connection.getTypeMap抛出一个SQLFeatureNotSupportedException ，那么不支持结构化值，并且将不同的值映射到由DISTINCT类型的底层SQL类型确定的默认Java类。

        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        一个 java.lang.Object持有列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • getObject

        Object getObject​(String columnLabel)
          throws SQLException

        获取此ResultSet对象的当前行中指定列的值为Java编程语言中的Object 。

        此方法将以Java对象的形式返回给定列的值。 Java对象的类型将是与列的SQL类型相对应的默认Java对象类型，遵循JDBC规范中指定的内置类型的映射。 如果值为SQL NULL ，则驱动程序返回一个Java null 。

        此方法也可用于读取数据库特定的抽象数据类型。

        在JDBC 2.0 API中，方法getObject的行为被扩展为实现SQL用户定义类型的数据。 当列包含结构化或不同的值时，此方法的行为就像调用： getObject(columnIndex, this.getStatement().getConnection().getTypeMap()) 。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个 java.lang.Object保存列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法

      • findColumn

        int findColumn​(String columnLabel)
        throws SQLException
        将给定的 ResultSet列标签映射到其 ResultSet列索引。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        给定列名称的列索引
        异常
        SQLException - 如果 ResultSet对象不包含标记为 columnLabel的列，则会发生数据库访问错误，或者在关闭结果集上调用此方法

      • getCharacterStream

        Reader getCharacterStream​(int columnIndex)
                   throws SQLException
        以 ResultSet对象的形式 java.io.Reader此 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        包含列值的java.io.Reader对象; 如果值为SQL NULL ，则返回的值为Java编程语言中的null 。
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getCharacterStream

        Reader getCharacterStream​(String columnLabel)
                   throws SQLException
        检索此 ResultSet对象当前行中指定列的值作为 java.io.Reader对象。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个包含列值的java.io.Reader对象; 如果值为SQL NULL ，返回值为Java编程语言中的null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getBigDecimal

        BigDecimal getBigDecimal​(int columnIndex)
                  throws SQLException
        在 ResultSet对象的当前行中指定列的值作为 java.math.BigDecimal以完全精确的方式获取。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值（全精度）; 如果值为SQL NULL ，则返回的值为null （在Java编程语言中）。
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getBigDecimal

        BigDecimal getBigDecimal​(String columnLabel)
                  throws SQLException
        以 java.math.BigDecimal的形式全面精确地 ResultSet对象的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值（全精度）; 如果值为SQL NULL ，则返回的值为null （在Java编程语言中）。
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • isBeforeFirst

        boolean isBeforeFirst​()
               throws SQLException
        检索光标是否在此ResultSet对象的第一行之前。

        注意：对于ResultSet s，支持isBeforeFirst方法是可选的，结果集类型为TYPE_FORWARD_ONLY

        结果
        如果光标位于第一行之前， true ; false如果光标在任何其他位置，或者结果集不包含任何行
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • isAfterLast

        boolean isAfterLast​()
             throws SQLException
        检索光标是否在ResultSet对象的最后一行之后。

        注意：对于ResultSet s，支持isAfterLast方法是可选的，结果集类型为TYPE_FORWARD_ONLY

        结果
        如果光标位于最后一行之后， true ; false如果光标在任何其他位置或结果集不包含任何行
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • isFirst

        boolean isFirst​()
         throws SQLException
        检索光标是否位于该ResultSet对象的第一行。

        注意：对于ResultSet s，支持isFirst方法是可选的，结果集类型为TYPE_FORWARD_ONLY

        结果
        如果光标位于第一行， true ; false否则
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • isLast

        boolean isLast​()
        throws SQLException
        检索光标是否在ResultSet对象的最后一行。 注意：调用方法isLast可能是昂贵的，因为JDBC驱动程序可能需要提前一行才能确定当前行是否是结果集中的最后一行。

        注意：对于ResultSet s，支持isLast方法是可选的，结果集类型为TYPE_FORWARD_ONLY

        结果
        true如果光标在最后一行; 否则为false
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • beforeFirst

        void beforeFirst​()
          throws SQLException
        将光标移动到ResultSet对象的正面，就在第一行之前。 如果结果集不包含行，则此方法不起作用。
        异常
        SQLException - 如果发生数据库访问错误; 该方法在闭合结果集上调用或结果集类型为TYPE_FORWARD_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • afterLast

        void afterLast​()
        throws SQLException
        将光标移动到ResultSet对象的末尾，就在最后一行之后。 如果结果集不包含行，则此方法不起作用。
        异常
        SQLException - 如果发生数据库访问错误; 该方法在闭合结果集上调用，或者结果集类型为TYPE_FORWARD_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • first

        boolean first​()
       throws SQLException
        将光标移动到此 ResultSet对象中的第一行。
        结果
        true如果光标在有效的行上; 如果结果集中没有行， false
        异常
        SQLException - 如果发生数据库访问错误; 该方法在闭合结果集上调用，或者结果集类型为TYPE_FORWARD_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • last

        boolean last​()
      throws SQLException
        将光标移动到此 ResultSet对象中的最后一行。
        结果
        如果游标在有效的行上， true ; 如果结果集中没有行， false
        异常
        SQLException - 如果发生数据库访问错误; 该方法在闭合结果集上调用，或者结果集类型为TYPE_FORWARD_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getRow

        int getRow​()
    throws SQLException
        检索当前行号。 第一行是第1行，第2行等等。

        注意：对于ResultSet s，支持getRow方法是可选的，结果集类型为TYPE_FORWARD_ONLY

        结果
        当前行号; 0如果没有当前行
        异常
        SQLException - 如果发生数据库访问错误，或者在关闭结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • absolute

        boolean absolute​(int row)
          throws SQLException
        将光标移动到此ResultSet对象中的给定行号。

        如果行号为正，则光标相对于结果集的开头移动到给定的行号。 第一行是第1行，第二行是第2行，依此类推。

        如果给定行号为负，光标将移动到相对于结果集结尾的绝对行位置。 例如，调用方法absolute(-1)将光标定位在最后一行; 调用方法absolute(-2)将光标移动到下一行到最后一行，依此类推。

        如果指定的行号为零，则光标移动到第一行之前。

        将光标定位在结果集中的第一行/最后一行之外的尝试将光标留在第一行之前或最后一行之后。

        注意：呼叫absolute(1)与拨打first()相同。 拨打absolute(-1)与拨打last()相同。

        参数
        row - 光标应该移动的行的编号。 值为零表示光标将位于第一行之前; 正数表示从结果集开始计数的行号; 负号表示从结果集的结尾开始计数的行号
        结果
        true如果光标移动到这个ResultSet对象的位置; 如果光标位于第一行之前或最后一行之后， false
        异常
        SQLException - 如果发生数据库访问错误; 该方法在闭合结果集上调用，或者结果集类型为TYPE_FORWARD_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • relative

        boolean relative​(int rows)
          throws SQLException
        将光标移动到正或负的相对行数。 尝试超出结果集中的第一行/最后一行将光标置于第一行/最后一行之前/之后。 调用relative(0)是有效的，但不会更改光标位置。

        注：调用方法relative(1)是相同的调用方法next()并调用方法relative(-1)是相同的调用方法previous() 。

        参数
        rows - 一个int指定从当前行移动的行数; 正数将光标向前移动; 负号将光标向后移动
        结果
        true如果光标在一行上; 否则为false
        异常
        SQLException - 如果发生数据库访问错误; 该方法在闭合结果集上调用，或者结果集类型为TYPE_FORWARD_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • previous

        boolean previous​()
          throws SQLException
        将光标移动到此ResultSet对象中的上一行。

        当对previous方法的调用返回false ，光标位于第一行之前。 任何调用需要当前行的ResultSet方法将导致抛出SQLException 。

        如果当前行的输入流打开，则对方法previous的调用将隐式关闭它。 读取新行时，将清除ResultSet对象的警告更改。

        结果
        true如果光标现在位于有效的行上; 如果光标位于第一行之前， false
        异常
        SQLException - 如果发生数据库访问错误; 该方法在闭合结果集上调用，或者结果集类型为TYPE_FORWARD_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • setFetchDirection

        void setFetchDirection​(int direction)
                throws SQLException
        对此ResultSet对象中的行将被处理的方向提示。 初始值由产生此ResultSet对象的Statement对象确定。 抓取方向可随时更改。
        参数
        direction - 一个int指定建议的提取方向; 之一ResultSet.FETCH_FORWARD ， ResultSet.FETCH_REVERSE ，或ResultSet.FETCH_UNKNOWN
        异常
        SQLException - 如果发生数据库访问错误; 该方法在闭合结果集上调用，或者结果集类型为TYPE_FORWARD_ONLY ，并且获取方向不是FETCH_FORWARD
        从以下版本开始：
        1.2
        另请参见：
        Statement.setFetchDirection(int) ， getFetchDirection()

      • getFetchDirection

        int getFetchDirection​()
               throws SQLException
        检索此 ResultSet对象的抓取方向。
        结果
        当前抓取方向为这个 ResultSet对象
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2
        另请参见：
        setFetchDirection(int)

      • setFetchSize

        void setFetchSize​(int rows)
           throws SQLException
        给JDBC驱动程序提供一个关于应该从数据库中获取的行数，这个更多的行需要ResultSet对象。 如果指定的获取大小为零，则JDBC驱动程序将忽略该值，并且可以自由地对获取大小应该做出最佳猜测。 默认值由创建结果集的Statement对象设置。 抓取大小可随时更改。
        参数
        rows - 要获取的行数
        异常
        SQLException - 如果发生数据库访问错误; 该方法在闭合结果集上调用或条件rows >= 0不满足
        从以下版本开始：
        1.2
        另请参见：
        getFetchSize()

      • getFetchSize

        int getFetchSize​()
          throws SQLException
        检索此 ResultSet对象的抓取大小。
        结果
        当前抓取的大小为这个 ResultSet对象
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2
        另请参见：
        setFetchSize(int)

      • getType

        int getType​()
     throws SQLException
        检索此ResultSet对象的类型。 该类型由创建结果集的Statement对象确定。
        结果
        ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或 ResultSet.TYPE_SCROLL_SENSITIVE
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getConcurrency

        int getConcurrency​()
            throws SQLException
        检索此ResultSet对象的并发模式。 所使用的并发性由创建结果集的Statement对象确定。
        结果
        并发类型为 ResultSet.CONCUR_READ_ONLY或 ResultSet.CONCUR_UPDATABLE
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • rowUpdated

        boolean rowUpdated​()
            throws SQLException
        检索当前行是否已更新。 返回的值取决于结果集是否可以检测到更新。

        注意：支持rowUpdated方法是可选的，结果集并发性为CONCUR_READ_ONLY

        结果
        true如果检测到当前行已被所有者或另一个明显更新; 否则为false
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        DatabaseMetaData.updatesAreDetected(int)

      • rowInserted

        boolean rowInserted​()
             throws SQLException
        检索当前行是否有插入。 返回的值取决于此ResultSet对象是否可以检测到可见的插入。

        注意：支持rowInserted方法是可选的，结果集并发性为CONCUR_READ_ONLY

        结果
        true如果检测到当前行被插入; false否则
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        DatabaseMetaData.insertsAreDetected(int)

      • rowDeleted

        boolean rowDeleted​()
            throws SQLException
        检索行是否被删除。 删除的行可能在结果集中留下可见的“孔”。 该方法可用于检测结果集中的孔。 返回的值取决于此ResultSet对象是否可以检测到删除。

        注意：支持rowDeleted方法是可选的，结果集并发性为CONCUR_READ_ONLY

        结果
        true如果检测到当前行被所有者或另一个删除; 否则为false
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        DatabaseMetaData.deletesAreDetected(int)

      • updateNull

        void updateNull​(int columnIndex)
         throws SQLException
        使用null值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateBoolean

        void updateBoolean​(int columnIndex,
                   boolean x)
            throws SQLException
        使用boolean值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateByte

        void updateByte​(int columnIndex,
                byte x)
         throws SQLException
        使用byte值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateShort

        void updateShort​(int columnIndex,
                 short x)
          throws SQLException
        使用short值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者这个方法在一个封闭的结果集上被调用
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateInt

        void updateInt​(int columnIndex,
               int x)
        throws SQLException
        使用int值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateLong

        void updateLong​(int columnIndex,
                long x)
         throws SQLException
        使用long值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateFloat

        void updateFloat​(int columnIndex,
                 float x)
          throws SQLException
        使用float值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateDouble

        void updateDouble​(int columnIndex,
                  double x)
           throws SQLException
        使用double值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateBigDecimal

        void updateBigDecimal​(int columnIndex,
                      BigDecimal x)
               throws SQLException
        使用java.math.BigDecimal值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateString

        void updateString​(int columnIndex,
                  String x)
           throws SQLException
        使用String值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateBytes

        void updateBytes​(int columnIndex,
                 byte[] x)
          throws SQLException
        使用byte数组值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateDate

        void updateDate​(int columnIndex,
                Date x)
         throws SQLException
        使用java.sql.Date值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateTime

        void updateTime​(int columnIndex,
                Time x)
         throws SQLException
        使用java.sql.Time值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateTimestamp

        void updateTimestamp​(int columnIndex,
                     Timestamp x)
              throws SQLException
        使用java.sql.Timestamp值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateAsciiStream

        void updateAsciiStream​(int columnIndex,
                       InputStream x,
                       int length)
                throws SQLException
        使用ascii流值更新指定的列，该值将具有指定的字节数。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateBinaryStream

        void updateBinaryStream​(int columnIndex,
                        InputStream x,
                        int length)
                 throws SQLException
        使用二进制流值更新指定的列，该值将具有指定的字节数。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateCharacterStream

        void updateCharacterStream​(int columnIndex,
                           Reader x,
                           int length)
                    throws SQLException
        使用字符流值更新指定的列，该值将具有指定的字节数。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者这个方法在一个封闭的结果集上被调用
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateObject

        void updateObject​(int columnIndex,
                  Object x,
                  int scaleOrLength)
           throws SQLException
        使用Object值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        如果第二个参数是一个InputStream则流必须包含由scaleOrLength指定的字节数。 如果第二个参数是一个Reader那么读者必须包含由scaleOrLength指定的字符数。 如果这些条件不正确，则执行该语句时，驱动程序将生成一个SQLException 。

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        scaleOrLength -为的目的java.math.BigDecimal ，这是数字的小数点后的位数。 对于Java对象类型InputStream和Reader ，这是流或读取器中数据的长度。 对于所有其他类型，此值将被忽略。
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateObject

        void updateObject​(int columnIndex,
                  Object x)
           throws SQLException
        使用Object值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateNull

        void updateNull​(String columnLabel)
         throws SQLException
        使用null值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateBoolean

        void updateBoolean​(String columnLabel,
                   boolean x)
            throws SQLException
        使用boolean值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateByte

        void updateByte​(String columnLabel,
                byte x)
         throws SQLException
        使用byte值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateShort

        void updateShort​(String columnLabel,
                 short x)
          throws SQLException
        使用short值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在封闭结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateInt

        void updateInt​(String columnLabel,
               int x)
        throws SQLException
        使用int值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateLong

        void updateLong​(String columnLabel,
                long x)
         throws SQLException
        使用long值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateFloat

        void updateFloat​(String columnLabel,
                 float x)
          throws SQLException
        使用float值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateDouble

        void updateDouble​(String columnLabel,
                  double x)
           throws SQLException
        使用double值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateBigDecimal

        void updateBigDecimal​(String columnLabel,
                      BigDecimal x)
               throws SQLException
        使用java.sql.BigDecimal值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateString

        void updateString​(String columnLabel,
                  String x)
           throws SQLException
        使用String值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateBytes

        void updateBytes​(String columnLabel,
                 byte[] x)
          throws SQLException
        使用字节数组值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateDate

        void updateDate​(String columnLabel,
                Date x)
         throws SQLException
        使用java.sql.Date值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateTime

        void updateTime​(String columnLabel,
                Time x)
         throws SQLException
        使用java.sql.Time值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateTimestamp

        void updateTimestamp​(String columnLabel,
                     Timestamp x)
              throws SQLException
        使用java.sql.Timestamp值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateAsciiStream

        void updateAsciiStream​(String columnLabel,
                       InputStream x,
                       int length)
                throws SQLException
        使用ascii流值更新指定的列，该值将具有指定的字节数。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateBinaryStream

        void updateBinaryStream​(String columnLabel,
                        InputStream x,
                        int length)
                 throws SQLException
        使用二进制流值更新指定的列，该值将具有指定的字节数。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者这个方法在一个封闭的结果集上被调用
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateCharacterStream

        void updateCharacterStream​(String columnLabel,
                           Reader reader,
                           int length)
                    throws SQLException
        使用字符流值更新指定的列，该值将具有指定的字节数。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        reader - 包含新列值的 java.io.Reader对象
        length - 流的长度
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateObject

        void updateObject​(String columnLabel,
                  Object x,
                  int scaleOrLength)
           throws SQLException
        使用Object值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        如果第二个参数是一个InputStream则流必须包含由scaleOrLength指定的字节数。 如果第二个参数是一个Reader那么读者必须包含由scaleOrLength指定的字符数。 如果这些条件不正确，则执行该语句时，驱动程序将生成一个SQLException 。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        scaleOrLength -为的目的java.math.BigDecimal ，这是数字的小数点后的位数。 对于Java对象类型InputStream和Reader ，这是流或读取器中数据的长度。 对于所有其他类型，此值将被忽略。
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateObject

        void updateObject​(String columnLabel,
                  Object x)
           throws SQLException
        使用Object值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • insertRow

        void insertRow​()
        throws SQLException
        将插入行的内容插入到此ResultSet对象中并进入数据库。 当调用此方法时，游标必须位于插入行上。
        异常
        SQLException - 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY ，该方法在闭合结果集上调用，如果当游标不在插入行上时调用此方法，或者插入行中的所有不可为空的列都已被赋予非 - 空值
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • updateRow

        void updateRow​()
        throws SQLException
        使用此ResultSet对象的当前行的新内容更新底层数据库。 当光标在插入行上时，无法调用此方法。
        异常
        SQLException - 如果发生数据库访问错误; 结果集并发是CONCUR_READ_ONLY ; 这个方法在一个封闭的结果集上被调用，或者当光标在插入行上时调用这个方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • deleteRow

        void deleteRow​()
        throws SQLException
        从此ResultSet对象和底层数据库中删除当前行。 当光标在插入行上时，无法调用此方法。
        异常
        SQLException - 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY ; 这个方法在一个封闭的结果集上被调用，或者当光标在插入行上时调用这个方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • refreshRow

        void refreshRow​()
         throws SQLException
        用数据库中最新的值刷新当前行。 当光标在插入行上时，无法调用此方法。

        refreshRow方法为应用程序提供了一种明确告知JDBC驱动程序从数据库中提取行的方法。 当JDBC驱动程序执行缓存或预取时，应用程序可能希望调用refreshRow以从数据库中获取行的最新值。 如果抓取大小大于1，JDBC驱动程序可能会一次刷新多个行。

        根据事务隔离级别和光标灵敏度，所有值都被刷新。 如果在调用updater方法后调用了refreshRow ，但是在调用方法updateRow之前调用，那么对行的更新就会丢失。 通常调用方法refreshRow可能会降低性能。

        异常
        SQLException - 如果发生数据库访问错误; 这个方法在一个封闭的结果集上被调用; 结果集类型为TYPE_FORWARD_ONLY或者当光标位于插入行上时调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法，或者该方法不支持指定的结果集类型和结果集并发。
        从以下版本开始：
        1.2

      • cancelRowUpdates

        void cancelRowUpdates​()
               throws SQLException
        取消对此ResultSet对象中当前行的更新。 在调用更新方法之后，并且在调用方法updateRow之前可以调用此方法来回滚对行进行的更新。 如果没有更新，或者已经调用了updateRow ，则此方法无效。
        异常
        SQLException - 如果发生数据库访问错误; 这个方法在一个封闭的结果集上被调用; 结果集并发性为CONCUR_READ_ONLY或者当光标位于插入行上时调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • moveToInsertRow

        void moveToInsertRow​()
              throws SQLException
        将光标移动到插入行。 当光标位于插入行上时，将记住当前的光标位置。 插入行是与可更新结果集相关联的特殊行。 它本质上是一个缓冲区，其中可以通过在将行插入结果集之前调用updater方法来构造新行。 当游标在插入行上时，只能调用updater，getter和insertRow方法。 在调用insertRow之前，每次调用此方法时，必须为结果集中的所有列赋予一个值。 必须先调用updater方法，然后才能对列值调用getter方法。
        异常
        SQLException - 如果发生数据库访问错误; 这个方法在一个封闭的结果集上被调用，或者结果集并发是CONCUR_READ_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • moveToCurrentRow

        void moveToCurrentRow​()
               throws SQLException
        将光标移动到记住的光标位置，通常是当前行。 如果光标不在插入行上，则此方法不起作用。
        异常
        SQLException - 如果发生数据库访问错误; 这个方法在一个封闭的结果集上被调用，或者结果集并发是CONCUR_READ_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getStatement

        Statement getStatement​()
                throws SQLException
        检索Statement生成此对象ResultSet对象。 如果结果集是以某种其他方式生成的，例如通过DatabaseMetaData方法生成，则此方法可能会返回null 。
        结果
        所述 Statement生成此对象 ResultSet对象或 null如果结果集制作一些其他的方式
        异常
        SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getObject

        Object getObject​(int columnIndex,
                 Map<String,Class<?>> map)
          throws SQLException
        以Java编程语言中的Object此ResultSet对象当前行中指定列的值。 如果该值为SQL NULL ，则驱动程序返回一个Java null 。 此方法使用给定的Map对象进行正在检索的SQL结构化或不同类型的自定义映射。
        参数
        columnIndex - 第一列是1，第二列是2，...
        map - 一个 java.util.Map对象，其中包含从SQL类型名称到Java编程语言中的类的映射
        结果
        一个代表SQL值的Java编程语言中的一个 Object
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getRef

        Ref getRef​(int columnIndex)
    throws SQLException
        以Java编程语言中的 ResultSet对象的形式 Ref此 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        一个表示SQL REF值的 Ref对象
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getBlob

        Blob getBlob​(int columnIndex)
      throws SQLException
        以Java编程语言中的 Blob对象获取此 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        一个 Blob对象，表示指定列中的SQL BLOB值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getClob

        Clob getClob​(int columnIndex)
      throws SQLException
        以Java编程语言的 ResultSet对象的形式 Clob该 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        一个 Clob对象，表示指定列中的SQL CLOB值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getArray

        Array getArray​(int columnIndex)
        throws SQLException
        以Java编程语言中的 Array对象获取此 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        一个 Array对象，表示指定列中的SQL ARRAY值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getObject

        Object getObject​(String columnLabel,
                 Map<String,Class<?>> map)
          throws SQLException
        以Java编程语言中的Object此ResultSet对象的当前行中指定列的值。 如果值为SQL NULL ，则驱动程序返回一个Java null 。 如果适用，此方法使用指定的Map对象进行自定义映射。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        map - 一个 java.util.Map对象，其中包含从SQL类型名称到Java编程语言中的类的映射
        结果
        一个 Object表示指定列中的SQL值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getRef

        Ref getRef​(String columnLabel)
    throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Ref对象。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个 Ref对象，表示指定列中的SQL REF值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getBlob

        Blob getBlob​(String columnLabel)
      throws SQLException
        以Java编程语言中的 Blob对象的形式，检索此 ResultSet对象的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        表示指定列中的SQL BLOB值的 Blob对象
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getClob

        Clob getClob​(String columnLabel)
      throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Clob对象。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个 Clob对象，表示指定列中的SQL CLOB值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getArray

        Array getArray​(String columnLabel)
        throws SQLException
        检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 Array对象。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个 Array对象，表示指定列中的SQL ARRAY值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getDate

        Date getDate​(int columnIndex,
             Calendar cal)
      throws SQLException
        以Java编程语言中的ResultSet对象的形式java.sql.Date此ResultSet对象的当前行中指定列的值。 如果基础数据库不存储时区信息，则此方法使用给定的日历为日期构造适当的毫秒值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        cal - 用于构建日期的 java.util.Calendar对象
        结果
        列值为java.sql.Date对象; 如果值为SQL NULL ，则返回的值为Java编程语言中的null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getDate

        Date getDate​(String columnLabel,
             Calendar cal)
      throws SQLException
        检索此ResultSet对象的当前行中指定列的值为Java编程语言中的java.sql.Date对象。 如果基础数据库不存储时区信息，则此方法使用给定的日历为日期构造适当的毫秒值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        cal - 用于构建日期的 java.util.Calendar对象
        结果
        列值为java.sql.Date对象; 如果值为SQL NULL ，则返回的值为Java编程语言中的null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getTime

        Time getTime​(int columnIndex,
             Calendar cal)
      throws SQLException
        检索此ResultSet对象的当前行中指定列的值为Java编程语言中的java.sql.Time对象。 如果基础数据库不存储时区信息，则此方法使用给定的日历来构建适当的毫秒值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        cal - 用于构建时间的 java.util.Calendar对象
        结果
        列值为java.sql.Time对象; 如果值为SQL NULL ，返回的值为null ，在Java编程语言
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getTime

        Time getTime​(String columnLabel,
             Calendar cal)
      throws SQLException
        检索此ResultSet对象的当前行中指定列的值为Java编程语言中的java.sql.Time对象。 如果基础数据库不存储时区信息，则此方法使用给定的日历来构建适当的毫秒值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        cal - 用于构建时间的 java.util.Calendar对象
        结果
        列值为java.sql.Time对象; 如果值为SQL NULL ，则返回的值为Java编程语言中的null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getTimestamp

        Timestamp getTimestamp​(int columnIndex,
                       Calendar cal)
                throws SQLException
        以Java编程语言中的java.sql.Timestamp对象的形式，检索此ResultSet对象的当前行中指定列的值。 如果基础数据库不存储时区信息，则此方法使用给定的日历为时间戳创建适当的毫秒值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        cal - 用于构建时间戳的 java.util.Calendar对象
        结果
        列值为java.sql.Timestamp对象; 如果值为SQL NULL ，返回的值为null ，在Java编程语言
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getTimestamp

        Timestamp getTimestamp​(String columnLabel,
                       Calendar cal)
                throws SQLException
        以Java编程语言中的ResultSet对象的形式java.sql.Timestamp此ResultSet对象的当前行中指定列的值。 如果基础数据库不存储时区信息，则此方法使用给定的日历为时间戳创建适当的毫秒值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        cal - 用于构建日期的 java.util.Calendar对象
        结果
        列值为java.sql.Timestamp对象; 如果值为SQL NULL ，返回的值为null ，在Java编程语言
        异常
        SQLException - 如果columnLabel无效或者发生数据库访问错误或在关闭的结果集上调用此方法
        从以下版本开始：
        1.2

      • getURL

        URL getURL​(int columnIndex)
    throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.net.URL对象。
        参数
        columnIndex - 列1的索引是第一个，第二个是第二个，...
        结果
        列值为java.net.URL对象; 如果值为SQL NULL ，则返回的值为Java编程语言中的null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 这个方法在一个封闭的结果集上被调用，或者一个URL是格式错误的
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • getURL

        URL getURL​(String columnLabel)
    throws SQLException
        以Java编程语言中的 ResultSet对象的形式 java.net.URL此 ResultSet对象的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值为java.net.URL对象; 如果值为SQL NULL ，则返回的值为null ，在Java编程语言
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 这个方法在一个封闭的结果集上被调用，或者一个URL是格式错误的
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • updateRef

        void updateRef​(int columnIndex,
               Ref x)
        throws SQLException
        使用java.sql.Ref值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • updateRef

        void updateRef​(String columnLabel,
               Ref x)
        throws SQLException
        使用java.sql.Ref值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者在一个封闭的结果集上调用这个方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • updateBlob

        void updateBlob​(int columnIndex,
                Blob x)
         throws SQLException
        使用java.sql.Blob值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • updateBlob

        void updateBlob​(String columnLabel,
                Blob x)
         throws SQLException
        使用java.sql.Blob值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • updateClob

        void updateClob​(int columnIndex,
                Clob x)
         throws SQLException
        使用java.sql.Clob值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • updateClob

        void updateClob​(String columnLabel,
                Clob x)
         throws SQLException
        使用java.sql.Clob值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者在一个封闭的结果集上调用这个方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • updateArray

        void updateArray​(int columnIndex,
                 Array x)
          throws SQLException
        使用java.sql.Array值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • updateArray

        void updateArray​(String columnLabel,
                 Array x)
          throws SQLException
        使用java.sql.Array值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者在一个封闭的结果集上调用这个方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • getRowId

        RowId getRowId​(int columnIndex)
        throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.RowId对象。
        参数
        columnIndex - 第一列是1，第二列2，...
        结果
        列值; 如果值为SQL NULL ，返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getRowId

        RowId getRowId​(String columnLabel)
        throws SQLException
        检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.RowId对象。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，返回值为null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateRowId

        void updateRowId​(int columnIndex,
                 RowId x)
          throws SQLException
        使用RowId值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列2，...
        x - 列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateRowId

        void updateRowId​(String columnLabel,
                 RowId x)
          throws SQLException
        使用RowId值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者这个方法在一个封闭的结果集上被调用
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getHoldability

        int getHoldability​()
            throws SQLException
        检索此 ResultSet对象的 ResultSet
        结果
        ResultSet.HOLD_CURSORS_OVER_COMMIT或 ResultSet.CLOSE_CURSORS_AT_COMMIT
        异常
        SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
        从以下版本开始：
        1.6

      • isClosed

        boolean isClosed​()
          throws SQLException
        检索此ResultSet对象是否已关闭。 如果方法关闭已被调用或自动关闭，则关闭ResultSet 。
        结果
        如果这个ResultSet对象关闭， ResultSet true; 如果它仍然开放，则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.6

      • updateNString

        void updateNString​(int columnIndex,
                   String nString)
            throws SQLException
        使用String值更新指定的列。 更新时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列2，...
        nString - 要更新的列的值
        异常
        SQLException - 如果columnIndex无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
这个方法在一个封闭的结果集上被调用;
结果集并发性为CONCUR_READ_ONLY或发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNString

        void updateNString​(String columnLabel,
                   String nString)
            throws SQLException
        使用String值更新指定的列。 更新时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        nString - 要更新的列的值
        异常
        SQLException - 如果columnLabel无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
这个方法在一个封闭的结果集上被调用;
结果集并发性为CONCUR_READ_ONLY或者发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNClob

        void updateNClob​(int columnIndex,
                 NClob nClob)
          throws SQLException
        使用java.sql.NClob值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列2，...
        nClob - 要更新的列的值
        异常
        SQLException - 如果columnIndex无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
这个方法在一个封闭的结果集上被调用;
如果发生数据库访问错误或结果集并发性为CONCUR_READ_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNClob

        void updateNClob​(String columnLabel,
                 NClob nClob)
          throws SQLException
        使用java.sql.NClob值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        nClob - 要更新的列的值
        异常
        SQLException - 如果columnLabel无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
这个方法在一个封闭的结果集上被调用;
如果发生数据库访问错误或结果集并发性为CONCUR_READ_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNClob

        NClob getNClob​(int columnIndex)
        throws SQLException
        以Java编程语言中的 NClob对象获取该 ResultSet对象的当前行中指定列的值。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        表示指定列中的SQL NCLOB值的 NClob对象
        异常
        SQLException - 如果columnIndex无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
这个方法在一个封闭的结果集上被调用，或者发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNClob

        NClob getNClob​(String columnLabel)
        throws SQLException
        检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 NClob对象。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个表示指定列中的SQL NCLOB值的 NClob对象
        异常
        SQLException - 如果columnLabel无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
这个方法在一个封闭的结果集上被调用，或者发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getSQLXML

        SQLXML getSQLXML​(int columnIndex)
          throws SQLException
        这个检索的当前行中指定列的值 ResultSet为 java.sql.SQLXML的Java编程语言对象。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        一个映射 SQL XML值的 SQLXML对象
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getSQLXML

        SQLXML getSQLXML​(String columnLabel)
          throws SQLException
        以Java编程语言的 java.sql.SQLXML对象的形式获取此 ResultSet的当前行中指定列的值。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个映射 SQL XML值的 SQLXML对象
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateSQLXML

        void updateSQLXML​(int columnIndex,
                  SQLXML xmlObject)
           throws SQLException
        使用java.sql.SQLXML值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnIndex - 第一列是1，第二列2，...
        xmlObject - 要更新的列的值
        异常
        SQLException - 如果columnIndex无效;
如果发生数据库访问错误;
这个方法在一个封闭的结果集上被调用;
的java.xml.transform.Result ， Writer或OutputStream尚未收为SQLXML对象;
如果处理XML值或结果集中存在错误并发性是CONCUR_READ_ONLY 。
异常的getCause方法可能会提供更详细的异常，例如，如果流不包含有效的XML。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateSQLXML

        void updateSQLXML​(String columnLabel,
                  SQLXML xmlObject)
           throws SQLException
        使用java.sql.SQLXML值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        xmlObject - 列值
        异常
        SQLException - 如果columnLabel无效;
如果发生数据库访问错误;
这个方法在一个封闭的结果集上被调用;
的java.xml.transform.Result ， Writer或OutputStream尚未收为SQLXML对象;
如果处理XML值或结果集中的错误并发性为CONCUR_READ_ONLY 。
异常的getCause方法可能会提供更详细的异常，例如，如果流不包含有效的XML。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNString

        String getNString​(int columnIndex)
           throws SQLException
        检索此ResultSet对象的当前行中指定列的值为Java编程语言中的String 。 访问时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        列值; 如果值为SQL NULL ，返回值为null
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNString

        String getNString​(String columnLabel)
           throws SQLException
        检索此ResultSet对象的当前行中指定列的值为Java编程语言中的String 。 访问时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        列值; 如果值为SQL NULL ，则返回值为null
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNCharacterStream

        Reader getNCharacterStream​(int columnIndex)
                    throws SQLException
        以ResultSet对象的形式java.io.Reader此ResultSet对象的当前行中指定列的值。 访问时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。
        参数
        columnIndex - 第一列是1，第二列是2，...
        结果
        一个包含列值的java.io.Reader对象; 如果值为SQL NULL ，则返回的值为Java编程语言中的null 。
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getNCharacterStream

        Reader getNCharacterStream​(String columnLabel)
                    throws SQLException
        检索此ResultSet对象的当前行中指定列的值作为java.io.Reader对象。 访问时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        结果
        一个包含列值的java.io.Reader对象; 如果值为SQL NULL ，则返回的值为null ，在Java编程语言
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误或在关闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNCharacterStream

        void updateNCharacterStream​(int columnIndex,
                            Reader x,
                            long length)
                     throws SQLException
        使用字符流值更新指定的列，该值将具有指定的字节数。 驱动程序必须从Java字符格式转换为数据库中的国家字符集。 更新时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNCharacterStream

        void updateNCharacterStream​(String columnLabel,
                            Reader reader,
                            long length)
                     throws SQLException
        使用字符流值更新指定的列，该值将具有指定的字节数。 驱动程序必须从Java字符格式转换为数据库中的国家字符集。 更新时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        reader - 包含新列值的 java.io.Reader对象
        length - 流的长度
        异常
        SQLException 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者这个方法在一个封闭的结果集上被调用
        SQLFeatureNotSupportedException ：
        从以下版本开始：
        1.6

      • updateAsciiStream

        void updateAsciiStream​(int columnIndex,
                       InputStream x,
                       long length)
                throws SQLException
        使用ascii流值更新指定的列，该值将具有指定的字节数。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateBinaryStream

        void updateBinaryStream​(int columnIndex,
                        InputStream x,
                        long length)
                 throws SQLException
        使用二进制流值更新指定的列，该值将具有指定的字节数。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateCharacterStream

        void updateCharacterStream​(int columnIndex,
                           Reader x,
                           long length)
                    throws SQLException
        使用字符流值更新指定的列，该值将具有指定的字节数。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateAsciiStream

        void updateAsciiStream​(String columnLabel,
                       InputStream x,
                       long length)
                throws SQLException
        使用ascii流值更新指定的列，该值将具有指定的字节数。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者这种方法在一个封闭的结果集上被调用
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateBinaryStream

        void updateBinaryStream​(String columnLabel,
                        InputStream x,
                        long length)
                 throws SQLException
        使用二进制流值更新指定的列，该值将具有指定的字节数。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        length - 流的长度
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者这个方法在一个封闭的结果集上被调用
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateCharacterStream

        void updateCharacterStream​(String columnLabel,
                           Reader reader,
                           long length)
                    throws SQLException
        使用字符流值更新指定的列，该值将具有指定的字节数。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        reader - 包含新列值的 java.io.Reader对象
        length - 流的长度
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateBlob

        void updateBlob​(int columnIndex,
                InputStream inputStream,
                long length)
         throws SQLException
        使用给定的输入流更新指定列，该输入流将具有指定的字节数。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnIndex - 第一列是1，第二列是2，...
        inputStream - 包含用于设置参数值的数据的对象。
        length - 参数数据中的字节数。
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateBlob

        void updateBlob​(String columnLabel,
                InputStream inputStream,
                long length)
         throws SQLException
        使用给定的输入流更新指定列，该输入流将具有指定的字节数。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        inputStream - 包含用于将参数值设置为的数据的对象。
        length - 参数数据中的字节数。
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateClob

        void updateClob​(int columnIndex,
                Reader reader,
                long length)
         throws SQLException
        使用给定的Reader对象更新指定的列，这是给定的字符数。 当非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更实用。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnIndex - 第一列是1，第二列是2，...
        reader - 包含用于设置参数值的数据的对象。
        length - 参数数据中的字符数。
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者在一个封闭的结果集上调用这个方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateClob

        void updateClob​(String columnLabel,
                Reader reader,
                long length)
         throws SQLException
        使用给定的Reader对象更新指定的列，这是给定的长度的字符数。 当将非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更实用。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        reader - 包含用于设置参数值的数据的对象。
        length - 参数数据中的字符数。
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者在一个封闭的结果集上调用这个方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNClob

        void updateNClob​(int columnIndex,
                 Reader reader,
                 long length)
          throws SQLException
        使用给定的Reader对象更新指定的列，这是给定的字符数。 当将非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更实用。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnIndex - 第一列是1，第二列2，...
        reader - 包含用于设置参数值的数据的对象。
        length - 参数数据中的字符数。
        异常
        SQLException - 如果columnIndex无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或结果集并发性为CONCUR_READ_ONLY ，则此方法在关闭的结果集上CONCUR_READ_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNClob

        void updateNClob​(String columnLabel,
                 Reader reader,
                 long length)
          throws SQLException
        使用给定的Reader对象更新指定的列，这是给定的字符数。 当非常大的UNICODE值输入到LONGVARCHAR参数时，通过java.io.Reader对象发送它可能更为实用。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        reader - 包含将参数值设置为的数据的对象。
        length - 参数数据中的字符数。
        异常
        SQLException - 如果columnLabel无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
这个方法在一个封闭的结果集上被调用;
如果发生数据库访问错误或结果集并发性为CONCUR_READ_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNCharacterStream

        void updateNCharacterStream​(int columnIndex,
                            Reader x)
                     throws SQLException
        使用字符流值更新指定的列。 数据将根据需要从流中读取，直到达到流出端。 驱动程序必须从Java字符格式转换为数据库中的国家字符集。 更新时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注意：请参阅您的JDBC驱动程序文档，以确定使用一个长度参数的版本的updateNCharacterStream可能会更有效。

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNCharacterStream

        void updateNCharacterStream​(String columnLabel,
                            Reader reader)
                     throws SQLException
        使用字符流值更新指定的列。 数据将根据需要从流中读取，直到达到流出端。 驱动程序必须从Java字符格式转换为数据库中的国家字符集。 更新时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的updateNCharacterStream是否更有效。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        reader - 包含新列值的 java.io.Reader对象
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateAsciiStream

        void updateAsciiStream​(int columnIndex,
                       InputStream x)
                throws SQLException
        使用ascii流值更新指定的列。 数据将根据需要从流中读取，直到达到流出端。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的updateAsciiStream可能会更有效。

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateBinaryStream

        void updateBinaryStream​(int columnIndex,
                        InputStream x)
                 throws SQLException
        使用二进制流值更新指定的列。 数据将根据需要从流中读取，直到达到流出端。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的updateBinaryStream带有长度参数。

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateCharacterStream

        void updateCharacterStream​(int columnIndex,
                           Reader x)
                    throws SQLException
        使用字符流值更新指定的列。 数据将根据需要从流中读取，直到达到流出端。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的updateCharacterStream带有长度参数。

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateAsciiStream

        void updateAsciiStream​(String columnLabel,
                       InputStream x)
                throws SQLException
        使用ascii流值更新指定的列。 数据将根据需要从流中读取，直到达到流出端。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的updateAsciiStream可能会更有效。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateBinaryStream

        void updateBinaryStream​(String columnLabel,
                        InputStream x)
                 throws SQLException
        使用二进制流值更新指定的列。 数据将根据需要从流中读取，直到达到流出端。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的updateBinaryStream带有长度参数。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateCharacterStream

        void updateCharacterStream​(String columnLabel,
                           Reader reader)
                    throws SQLException
        使用字符流值更新指定的列。 数据将根据需要从流中读取，直到达到流出端。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的updateCharacterStream带有长度参数。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        reader - 包含新列值的 java.io.Reader对象
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateBlob

        void updateBlob​(int columnIndex,
                InputStream inputStream)
         throws SQLException
        使用给定的输入流更新指定的列。 数据将根据需要从流中读取，直到达到流出端。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的updateBlob可能会更有效。

        参数
        columnIndex - 第一列是1，第二列是2，...
        inputStream - 包含用于设置参数值的数据的对象。
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在闭合结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateBlob

        void updateBlob​(String columnLabel,
                InputStream inputStream)
         throws SQLException
        使用给定的输入流更新指定的列。 数据将根据需要从流中读取，直到达到流出端。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本updateBlob可能会更有效。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        inputStream - 包含用于设置参数值的数据的对象。
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateClob

        void updateClob​(int columnIndex,
                Reader reader)
         throws SQLException
        使用给定的Reader对象更新指定的列。 数据将根据需要从流中读取，直到达到流出端。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本的updateClob可能会更有效。

        参数
        columnIndex - 第一列是1，第二列是2，...
        reader - 包含用于设置参数值的数据的对象。
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateClob

        void updateClob​(String columnLabel,
                Reader reader)
         throws SQLException
        使用给定的Reader对象更新指定的列。 数据将根据需要从流中读取，直到达到流出端。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注：请参考JDBC驱动程序文档，以确定它可能是更有效地使用一个版本的updateClob带有长度参数。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        reader - 包含用于设置参数值的数据的对象。
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在封闭结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNClob

        void updateNClob​(int columnIndex,
                 Reader reader)
          throws SQLException
        使用给定的Reader更新指定的列。根据需要从数据流中读取数据，直到达到目标流。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本updateNClob是否更有效。

        参数
        columnIndex - 第一列是1，第二列2，...
        reader - 包含用于设置参数值的数据的对象。
        异常
        SQLException - 如果columnIndex无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
如果发生数据库访问错误或结果集并发性为CONCUR_READ_ONLY ，则此方法在关闭的结果集上CONCUR_READ_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • updateNClob

        void updateNClob​(String columnLabel,
                 Reader reader)
          throws SQLException
        使用给定的Reader对象更新指定的列。 数据将根据需要从流中读取，直到达到流出端。 JDBC驱动程序将从UNICODE到数据库字符格式进行任何必要的转换。

        更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        注意：请参阅您的JDBC驱动程序文档，以确定使用需要长度参数的版本updateNClob可能会更有效。

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        reader - 包含将参数值设置为的数据的对象。
        异常
        SQLException - 如果columnLabel无效;
如果司机不支持国家字符集;
如果驱动程序可以检测到可能发生数据转换错误;
这个方法在一个封闭的结果集上被调用;
如果发生数据库访问错误或结果集并发性为CONCUR_READ_ONLY
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getObject

        <T> T getObject​(int columnIndex,
                Class<T> type)
         throws SQLException

        检索此ResultSet对象的当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。 如果不支持转换或为该类型指定了null，则抛出SQLException 。

        至少，实现必须支持附录B表B-3中定义的转换，并将适当的用户定义的SQL类型转换为实现SQLData或Struct的Java类型。 可以支持额外的转换，并定义供应商。

        参数类型
        T - 由此Class对象建模的类的类型
        参数
        columnIndex - 第一列是1，第二列是2，...
        type - 表示将指定列转换为的Java数据类型的类。
        结果
        一个持有列值的 type的实例
        异常
        SQLException - 如果不支持转换，则type为null或发生其他错误。 异常的getCause（）方法可能会提供更详细的异常，例如，如果发生转换错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.7

      • getObject

        <T> T getObject​(String columnLabel,
                Class<T> type)
         throws SQLException

        检索此ResultSet对象的当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。 如果不支持转换或为该类型指定了null，则抛出SQLException 。

        至少，实现必须支持附录B表B-3中定义的转换，并将适当的用户定义的SQL类型转换为实现SQLData或Struct的Java类型。 可以支持额外的转换，并定义供应商。

        参数类型
        T - 由此Class对象建模的类的类型
        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        type - 表示将指定列转换为的Java数据类型的类。
        结果
        一个持有列值的 type的实例
        异常
        SQLException - 如果不支持转换，则type为null或发生其他错误。 异常的getCause（）方法可能会提供更详细的异常，例如，如果发生转换错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.7

      • updateObject

        default void updateObject​(int columnIndex,
                          Object x,
                          SQLType targetSqlType,
                          int scaleOrLength)
                   throws SQLException
        使用Object值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        如果第二个参数是一个InputStream则流必须包含由scaleOrLength指定的字节数。 如果第二个参数是一个Reader那么读者必须包含由scaleOrLength指定的字符数。 如果这些条件不正确，则执行该语句时，驱动程序将生成一个SQLException 。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        targetSqlType - 要发送到数据库的SQL类型
        scaleOrLength -为的目的java.math.BigDecimal ，这是数字的小数点后的位数。 对于Java对象类型InputStream和Reader ，这是流或读取器中数据的长度。 对于所有其他类型，此值将被忽略。
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者在一个封闭的结果集上调用这个方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法; 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • updateObject

        default void updateObject​(String columnLabel,
                          Object x,
                          SQLType targetSqlType,
                          int scaleOrLength)
                   throws SQLException
        使用Object值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        如果第二个参数是一个InputStream则流必须包含scaleOrLength指定的字节数。 如果第二个参数是一个Reader那么读者必须包含由scaleOrLength指定的字符数。 如果这些条件不正确，则执行该语句时，驱动程序将生成一个SQLException 。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        targetSqlType - 要发送到数据库的SQL类型
        scaleOrLength -为的目的java.math.BigDecimal ，这是数字的小数点后的位数。 对于Java对象类型InputStream和Reader ，这是流或读取器中数据的长度。 对于所有其他类型，此值将被忽略。
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性是CONCUR_READ_ONLY或者在一个封闭的结果集上调用这个方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法; 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • updateObject

        default void updateObject​(int columnIndex,
                          Object x,
                          SQLType targetSqlType)
                   throws SQLException
        使用Object值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        columnIndex - 第一列是1，第二列是2，...
        x - 新的列值
        targetSqlType - 要发送到数据库的SQL类型
        异常
        SQLException - 如果columnIndex无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法; 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType

      • updateObject

        default void updateObject​(String columnLabel,
                          Object x,
                          SQLType targetSqlType)
                   throws SQLException
        使用Object值更新指定的列。 更新器方法用于更新当前行或插入行中的列值。 updater方法不更新底层数据库; 而是updateRow或insertRow方法来更新数据库。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        columnLabel - 使用SQL AS子句指定的列的标签。 如果未指定SQL AS子句，则该标签是列的名称
        x - 新的列值
        targetSqlType - 要发送到数据库的SQL类型
        异常
        SQLException - 如果columnLabel无效; 如果发生数据库访问错误; 结果集并发性为CONCUR_READ_ONLY或者在一个封闭的结果集上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法; 如果JDBC驱动程序不支持指定的targetSqlType
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ResultSetMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface ResultSetMetaData

  • All Superinterfaces:
    Wrapper
    All Known Subinterfaces:
    RowSetMetaData
    所有已知实现类：
    RowSetMetaDataImpl

    public interface ResultSetMetaData
extends Wrapper
    可用于获取有关ResultSet对象中列的类型和属性的信息的对象。 以下代码段创建ResultSet对象rs，创建ResultSetMetaData对象rsmd，并使用rsmd来查找rs中有多少列，以及是否可以在WHERE子句中使用rs中的第一列。
      ResultSet rs = stmt.executeQuery("SELECT a, b, c FROM TABLE2");
     ResultSetMetaData rsmd = rs.getMetaData();
     int numberOfColumns = rsmd.getColumnCount();
     boolean b = rsmd.isSearchable(1);
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int columnNoNulls
      常量表示列不允许 NULL值。
      static int columnNullable
      常数表示列允许 NULL 。
      static int columnNullableUnknown
      常数表示列的值的可空性是未知的。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getCatalogName​(int column)
      获取指定列的表的目录名称。
      String getColumnClassName​(int column)
      如果调用方法 ResultSet.getObject以从列中检索值，则返回其实例生成的Java类的完全限定名称。
      int getColumnCount​()
      返回此 ResultSet对象中的列数。
      int getColumnDisplaySize​(int column)
      指定指定列的正常最大宽度（以字符为单位）。
      String getColumnLabel​(int column)
      获取指定列的建议标题用于打印输出和显示。
      String getColumnName​(int column)
      获取指定列的名称。
      int getColumnType​(int column)
      检索指定列的SQL类型。
      String getColumnTypeName​(int column)
      检索指定列的数据库特定类型名称。
      int getPrecision​(int column)
      获取指定列的指定列大小。
      int getScale​(int column)
      获取小数点右侧的指定列的位数。 对于不适用比例的数据类型，返回0。
      String getSchemaName​(int column)
      获取指定列的表的模式。
      String getTableName​(int column)
      获取指定列的表名称。
      boolean isAutoIncrement​(int column)
      指示指定列是否自动编号。
      boolean isCaseSensitive​(int column)
      指示列的大小写是否重要。
      boolean isCurrency​(int column)
      指示指定的列是现金值。
      boolean isDefinitelyWritable​(int column)
      指示指定列上的写入是否会成功。
      int isNullable​(int column)
      表示指定列中的值的无效性。
      boolean isReadOnly​(int column)
      指示指定列是否绝对不可写。
      boolean isSearchable​(int column)
      指示指定的列是否可以在where子句中使用。
      boolean isSigned​(int column)
      指示指定列中的值是否为有符号数。
      boolean isWritable​(int column)
      指示指定列上的写入是否成功。

      • Methods inherited from interface java.sql.Wrapper

        isWrapperFor, unwrap

    • 字段详细信息

      • columnNoNulls

        static final int columnNoNulls
        常数表示列不允许 NULL值。
        另请参见：
        Constant Field Values

      • columnNullable

        static final int columnNullable
        常数表示列允许 NULL 。
        另请参见：
        Constant Field Values

      • columnNullableUnknown

        static final int columnNullableUnknown
        常数表示列的值的可空性是未知的。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getColumnCount

        int getColumnCount​()
            throws SQLException
        返回此 ResultSet对象中的列数。
        结果
        列数
        异常
        SQLException - 如果发生数据库访问错误

      • isAutoIncrement

        boolean isAutoIncrement​(int column)
                 throws SQLException
        指示指定列是否自动编号。
        参数
        column - 第一列是1，第二列是2，...
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • isCaseSensitive

        boolean isCaseSensitive​(int column)
                 throws SQLException
        指示列的大小写是否重要。
        参数
        column - 第一列是1，第二列是2，...
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • isSearchable

        boolean isSearchable​(int column)
              throws SQLException
        指示指定的列是否可以在where子句中使用。
        参数
        column - 第一列是1，第二列是2，...
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • isCurrency

        boolean isCurrency​(int column)
            throws SQLException
        指示指定的列是现金值。
        参数
        column - 第一列是1，第二列是2，...
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • isNullable

        int isNullable​(int column)
        throws SQLException
        表示指定列中的值的无效性。
        参数
        column - 第一列是1，第二列是2，...
        结果
        给定列的可空性状态; 之一columnNoNulls ， columnNullable或columnNullableUnknown
        异常
        SQLException - 如果发生数据库访问错误

      • isSigned

        boolean isSigned​(int column)
          throws SQLException
        指示指定列中的值是否为有符号数。
        参数
        column - 第一列是1，第二列是2，...
        结果
        true如果是这样的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • getColumnDisplaySize

        int getColumnDisplaySize​(int column)
                  throws SQLException
        指定指定列的正常最大宽度（以字符为单位）。
        参数
        column - 第一列是1，第二列是2，...
        结果
        允许的正常最大字符数作为指定列的宽度
        异常
        SQLException - 如果发生数据库访问错误

      • getColumnLabel

        String getColumnLabel​(int column)
               throws SQLException
        获取指定列的建议标题用于打印输出和显示。 建议的标题通常由SQL AS子句指定。 如果未指定SQL AS ，则从getColumnLabel返回的值将与getColumnName方法返回的值相同。
        参数
        column - 第一列是1，第二列是2，...
        结果
        建议列标题
        异常
        SQLException - 如果发生数据库访问错误

      • getColumnName

        String getColumnName​(int column)
              throws SQLException
        获取指定列的名称。
        参数
        column - 第一列是1，第二列是2，...
        结果
        栏名
        异常
        SQLException - 如果发生数据库访问错误

      • getSchemaName

        String getSchemaName​(int column)
              throws SQLException
        获取指定列的表的模式。
        参数
        column - 第一列是1，第二列是2，...
        结果
        模式名称或“”，如果不适用
        异常
        SQLException - 如果发生数据库访问错误

      • getPrecision

        int getPrecision​(int column)
          throws SQLException
        获取指定列的指定列大小。 对于数值数据，这是最大精度。 对于字符数据，这是字符长度。 对于datetime数据类型，这是String表示形式的长度（假定分数秒分量的最大允许精度）。 对于二进制数据，这是以字节为单位的长度。 对于ROWID数据类型，这是以字节为单位的长度。 对于列大小不适用的数据类型返回0。
        参数
        column - 第一列是1，第二列是2，...
        结果
        精确
        异常
        SQLException - 如果发生数据库访问错误

      • getScale

        int getScale​(int column)
      throws SQLException
        获取小数点右侧的指定列的位数。 对于不适用比例的数据类型，返回0。
        参数
        column - 第一列是1，第二列是2，...
        结果
        规模
        异常
        SQLException - 如果发生数据库访问错误

      • getTableName

        String getTableName​(int column)
             throws SQLException
        获取指定列的表名称。
        参数
        column - 第一列是1，第二列是2，...
        结果
        表名或“”，如果不适用
        异常
        SQLException - 如果发生数据库访问错误

      • getCatalogName

        String getCatalogName​(int column)
               throws SQLException
        获取指定列的表的目录名称。
        参数
        column - 第一列是1，第二列是2，...
        结果
        指定列出现的表的目录的名称或“”，如果不适用
        异常
        SQLException - 如果发生数据库访问错误

      • getColumnType

        int getColumnType​(int column)
           throws SQLException
        检索指定列的SQL类型。
        参数
        column - 第一列是1，第二列是2，...
        结果
        来自java.sql.Types的SQL类型
        异常
        SQLException - 如果发生数据库访问错误
        另请参见：
        Types

      • getColumnTypeName

        String getColumnTypeName​(int column)
                  throws SQLException
        检索指定列的数据库特定类型名称。
        参数
        column - 第一列是1，第二列是2，...
        结果
        数据库使用的类型名称。 如果列类型是用户定义的类型，则返回完全限定类型的名称。
        异常
        SQLException - 如果发生数据库访问错误

      • isReadOnly

        boolean isReadOnly​(int column)
            throws SQLException
        指示指定列是否绝对不可写。
        参数
        column - 第一列是1，第二列是2，...
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • isWritable

        boolean isWritable​(int column)
            throws SQLException
        指示指定列上的写入是否成功。
        参数
        column - 第一列是1，第二列是2，...
        结果
        true如果是的话 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • isDefinitelyWritable

        boolean isDefinitelyWritable​(int column)
                      throws SQLException
        指示指定列上的写入是否会成功。
        参数
        column - 第一列是1，第二列是2，...
        结果
        true如果是的话; 否则为false
        异常
        SQLException - 如果发生数据库访问错误

      • getColumnClassName

        String getColumnClassName​(int column)
                   throws SQLException

        如果调用方法ResultSet.getObject以从列中检索值，则返回其实例生成的Java类的完全限定名称。 ResultSet.getObject可能会返回此方法返回的类的子类。

        参数
        column - 第一列是1，第二列是2，...
        结果
        Java编程语言中的类的完全限定名称，方法ResultSet.getObject将用于检索指定列中的值。 这是用于自定义映射的类名。
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RowId (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface RowId

  • public interface RowId
    SQL编程语言中的表示（映射）SQL ROWID值。 SQL ROWID是一种内置类型，其值可以被认为是数据库表中其标识行的地址。 该地址是否是逻辑的，或在任何方面，物理是由其始发数据源确定的。

    方法在接口ResultSet ， CallableStatement ，并PreparedStatement ，如getRowId和setRowId允许程序员访问SQL ROWID值。 RowId接口提供了一种用于将ROWID的值表示为字节数组或String 。

    该方法getRowIdLifetime在界面DatabaseMetaData ，可以用于确定是否RowId对象保持有效，其中，该交易的持续时间RowId创建，其中，所述会话的持续时间RowId ，被创建，或者，有效地用于如只要其识别的行不被删除。 除了指定其原始数据源之外的其有效寿命的持续时间， getRowIdLifetime指定的持续时间ROWID值的有效寿命其原始数据源内。 在这方面，它与一个大的对象不同，因为它的始发数据源中的大对象的有效寿命没有限制。

    如果JDBC驱动程序支持数据类型，则必须完全实现RowId接口上的所有方法。

    从以下版本开始：
    1.6
    另请参见：
    DatabaseMetaData

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此 RowId与指定对象进行比较。
      byte[] getBytes​()
      返回一个字节数组，表示该 java.sql.RowId对象指定的SQL ROWID的值。
      int hashCode​()
      返回此 RowId对象的哈希码值。
      String toString​()
      返回一个表示此 java.sql.RowId对象指定的SQL ROWID值的字符串。

    • 方法详细信息

      • equals

        boolean equals​(Object obj)
        将此RowId与指定对象进行比较。 结果是true当且仅当参数不为null，并且是与此对象表示相同的ROWID的RowId对象时。

        考虑RowId的起源和有效期限与其他RowId进行比较时，这一点很重要。 如果两者都是有效的，并且两者都来自相同数据源上的同一个表，那么如果它们相同，则它们标识相同的行; 如果一个或多个不再被保证是有效的，或者如果它们源于不同的数据源或相同数据源上的不同的表，那么它们可能相等，但是仍然不能识别相同的行。

        重写：
        equals在 Object
        参数
        obj - 该 Object比较这 RowId对象。
        结果
        如果RowId s相等RowId true; 否则为假
        从以下版本开始：
        1.6
        另请参见：
        Object.hashCode() ， HashMap

      • getBytes

        byte[] getBytes​()
        返回一个字节数组，表示该 java.sql.RowId对象指定的SQL ROWID的值。
        结果
        字节数组，其长度由提供连接的驱动程序确定，表示由此java.sql.RowId对象指定的ROWID的值。

      • toString

        String toString​()
        返回一个表示由此java.sql.RowId对象指定的SQL ROWID值的字符串。

        像java.sql.Date.toString()一样，将DATE的内容作为String “2004-03-17”而不是SQL中的DATE字面值（这将是String DATE“2004-03-17”）返回，toString（）返回其内容ROWID以特定于驱动程序提供连接的形式，可能不是一个ROWID文字。

        重写：
        toString在 Object
        结果
        一个字符串，其格式是由驾驶员提供的连接，表示所述的值确定 ROWID由该指定 java.sql.RowId对象。

      • hashCode

        int hashCode​()
        返回此 RowId对象的哈希码值。
        重写：
        hashCode在 Object
        结果
        一个哈希码为 RowId
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RowIdLifetime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.sql
软件包 java.sql

Enum RowIdLifetime

  • java.lang.Object
    • java.lang.Enum<RowIdLifetime>
      • java.sql.RowIdLifetime
  • All Implemented Interfaces:
    Serializable ， Comparable<RowIdLifetime>

    public enum RowIdLifetime
extends Enum<RowIdLifetime>
    RowId寿命值的枚举。
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ROWID_UNSUPPORTED
      表示此数据源不支持ROWID类型。
      ROWID_VALID_FOREVER
      表示来自该数据源的RowId的生存期实际上是无限制的。
      ROWID_VALID_OTHER
      表示来自此数据源的RowId的生命周期是不确定的; 但不是ROWID_VALID_TRANSACTION，ROWID_VALID_SESSION或ROWID_VALID_FOREVER之一。
      ROWID_VALID_SESSION
      表示来自此数据源的RowId的生命周期至少为包含会话。
      ROWID_VALID_TRANSACTION
      表示来自此数据源的RowId的生命周期至少为包含事务。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static RowIdLifetime valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static RowIdLifetime[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ROWID_UNSUPPORTED

        public static final RowIdLifetime ROWID_UNSUPPORTED
        表示此数据源不支持ROWID类型。

      • ROWID_VALID_OTHER

        public static final RowIdLifetime ROWID_VALID_OTHER
        表示来自此数据源的RowId的生命周期是不确定的; 但不是ROWID_VALID_TRANSACTION，ROWID_VALID_SESSION或ROWID_VALID_FOREVER之一。

      • ROWID_VALID_SESSION

        public static final RowIdLifetime ROWID_VALID_SESSION
        表示来自此数据源的RowId的生命周期至少为包含会话。

      • ROWID_VALID_TRANSACTION

        public static final RowIdLifetime ROWID_VALID_TRANSACTION
        表示来自此数据源的RowId的生命周期至少为包含事务。

      • ROWID_VALID_FOREVER

        public static final RowIdLifetime ROWID_VALID_FOREVER
        表示来自该数据源的RowId的生存期实际上是无限制的。

    • 方法详细信息

      • values

        public static RowIdLifetime[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (RowIdLifetime c : RowIdLifetime.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static RowIdLifetime valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Savepoint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Savepoint

  • public interface Savepoint
    一个保存点的表示，这是当前事务中可以从Connection.rollback方法引用的一个点。 当事务回滚到保存点时，保存点之后所做的所有更改都将被撤销。

    保存点可以是命名的或未命名的。 未命名的保存点由基础数据源生成的ID标识。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getSavepointId​()
      检索 Savepoint对象所代表的保存点的生成ID。
      String getSavepointName​()
      检索 Savepoint对象所代表的保存点的名称。

    • 方法详细信息

      • getSavepointId

        int getSavepointId​()
            throws SQLException
        检索 Savepoint对象所代表的保存点的生成ID。
        结果
        该保存点的数字ID
        异常
        SQLException - 如果这是一个命名的保存点
        从以下版本开始：
        1.4

      • getSavepointName

        String getSavepointName​()
                 throws SQLException
        检索此 Savepoint对象所代表的保存点的名称。
        结果
        该保存点的名称
        异常
        SQLException - 如果这是一个未命名的保存点
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ShardingKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface ShardingKey

  • public interface ShardingKey
    用于指示此对象表示Sharding键的接口。 一个ShardingKey实例只能保证与源自它的数据源实例兼容。 A ShardingKey使用ShardingKeyBuilder创建。

    以下示例说明如何使用ShardingKeyBuilder创建一个ShardingKey ：

       DataSource ds = new MyDataSource(); ShardingKey shardingKey = ds.createShardingKeyBuilder() .subkey("abc", JDBCType.VARCHAR) .subkey(94002, JDBCType.INTEGER) .build();

    A ShardingKey也可用于指定superShardingKey 。 支持复合分片的数据库可能会使用superShardingKey在分superShardingKey指定额外的分区级别。

    下面的例子说明了如何使用ShardingKeyBuilder创建superShardingKey为东部地区与ShardingKey为匹兹堡分公司指定的：

       DataSource ds = new MyDataSource(); ShardingKey superShardingKey = ds.createShardingKeyBuilder() .subkey("EASTERN_REGION", JDBCType.VARCHAR) .build(); ShardingKey shardingKey = ds.createShardingKeyBuilder() .subkey("PITTSBURGH_BRANCH", JDBCType.VARCHAR) .build(); Connection con = ds.createConnectionBuilder() .superShardingKey(superShardingKey) .shardingKey(shardingKey) .build();
    从以下版本开始：
    9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ShardingKeyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface ShardingKeyBuilder

  • public interface ShardingKeyBuilder
    从DataSource或XADataSource对象创建的构建器，用于使用支持的数据类型的子键创建一个ShardingKey 。 实现必须支持JDBCType.VARCHAR，并且还可以支持其他数据类型。

    以下示例说明如何使用ShardingKeyBuilder创建一个ShardingKey ：

       DataSource ds = new MyDataSource(); ShardingKey shardingKey = ds.createShardingKeyBuilder() .subkey("abc", JDBCType.VARCHAR) .subkey(94002, JDBCType.INTEGER) .build();
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ShardingKey build​()
      返回由此构建器定义的对象的实例。
      ShardingKeyBuilder subkey​(Object subkey, SQLType subkeyType)
      将调用此方法将子项添加到正在构建的Sharding Key对象中。

    • 方法详细信息

      • subkey

        ShardingKeyBuilder subkey​(Object subkey,
                          SQLType subkeyType)
        将调用此方法将子项添加到正在构建的Sharding Key对象中。 子密钥方法的调用顺序很重要，因为它表示子密钥在分片密钥中的放置顺序。
        参数
        subkey - 包含需要作为分 subkey键一部分的对象
        subkeyType - 类型为java.sql.SQLType的子密钥数据类型
        结果
        这个构建器对象

      • build

        ShardingKey build​()
           throws SQLException
        返回由此构建器定义的对象的实例。
        结果
        内置对象
        异常
        SQLException - 如果构建对象发生错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLClientInfoException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLClientInfoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLClientInfoException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLClientInfoException
extends SQLException
    当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。 除了SQLClientInfoException提供的信息SQLException ， SQLClientInfoException还提供了未设置的客户端信息属性列表。 某些数据库不允许以原子方式设置多个客户端信息属性。 对于这些数据库，尽管Connection.setClientInfo方法抛出异常，但有可能某些客户端信息属性已设置。 应用程序可以使用getFailedProperties方法检索未设置的客户端信息属性列表。 通过将Map<String,ClientInfoStatus>传递给适当的SQLClientInfoException构造函数来标识属性。
    从以下版本开始：
    1.6
    另请参见：
    ClientInfoStatus ， Connection.setClientInfo(java.lang.String, java.lang.String) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLClientInfoException​()
      构造一个 SQLClientInfoException对象。
      SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， vendorCode和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause ， vendorCode和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause和 failedProperties 。
      SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException对象，其初始化为给定的 reason和 failedProperties 。
      SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， cause和 failedProperties 。
      SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException对象，初始化为给定的 failedProperties 。
      SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException对象，初始化为给定的 cause和 failedProperties 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Map<String,ClientInfoStatus> getFailedProperties​()
      返回无法设置的客户端信息属性列表。

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLClientInfoException

        public SQLClientInfoException​()
        构造一个SQLClientInfoException对象。 的reason ， SQLState ，和failedProperties列表被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLClientInfoException

        public SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties)
        构造一个SQLClientInfoException对象，使用给定的failedProperties初始化。 reason和SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法初始化。
        参数
        failedProperties - 包含无法设置的属性值的地图。 地图中的键包含无法设置的客户端信息属性的名称，值包含ClientInfoStatus定义的原因代码ClientInfoStatus
        从以下版本开始：
        1.6

      • SQLClientInfoException

        public SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties,
                              Throwable cause)
        构造一个SQLClientInfoException对象，该对象使用给定的cause和failedProperties初始化。 所述reason被初始化为null如果cause==null或cause.toString()如果cause!=null ，供应商代码被初始化为0。
        参数
        failedProperties - 包含无法设置的属性值的地图。 地图中的键包含无法设置的客户端信息属性的名称，值包含ClientInfoStatus定义的原因码ClientInfoStatus
        cause - （保存以供以后通过getCause()方法检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLClientInfoException

        public SQLClientInfoException​(String reason,
                              Map<String,ClientInfoStatus> failedProperties)
        构造一个SQLClientInfoException对象，初始化为给定的reason和failedProperties 。 SQLState被初始化为null ，供应商代码被初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法初始化。
        参数
        reason - 异常的描述
        failedProperties - 包含无法设置的属性值的地图。 地图中的键包含无法设置的客户端信息属性的名称，值包含ClientInfoStatus定义的原因码ClientInfoStatus
        从以下版本开始：
        1.6

      • SQLClientInfoException

        public SQLClientInfoException​(String reason,
                              Map<String,ClientInfoStatus> failedProperties,
                              Throwable cause)
        构造一个SQLClientInfoException与给定的初始化的对象reason ， cause和failedProperties 。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述
        failedProperties - 包含无法设置的属性值的地图。 地图中的键包含无法设置的客户端信息属性的名称，值包含ClientInfoStatus定义的原因码ClientInfoStatus
        cause - 这个SQLException的基本原因（其保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLClientInfoException

        public SQLClientInfoException​(String reason,
                              String SQLState,
                              Map<String,ClientInfoStatus> failedProperties)
        构造一个SQLClientInfoException与给定的初始化的对象reason ， SQLState和failedProperties 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        failedProperties - 包含无法设置的属性值的地图。 地图中的键包含无法设置的客户端信息属性的名称，值包含ClientInfoStatus定义的原因码ClientInfoStatus
        从以下版本开始：
        1.6

      • SQLClientInfoException

        public SQLClientInfoException​(String reason,
                              String SQLState,
                              Map<String,ClientInfoStatus> failedProperties,
                              Throwable cause)
        构造一个SQLClientInfoException与给定的初始化的对象reason ， SQLState ， cause和failedProperties 。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        failedProperties - 包含无法设置的属性值的地图。 地图中的键包含无法设置的客户端信息属性的名称，值包含ClientInfoStatus定义的原因码ClientInfoStatus
        cause - 这个SQLException的基本原因（其保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLClientInfoException

        public SQLClientInfoException​(String reason,
                              String SQLState,
                              int vendorCode,
                              Map<String,ClientInfoStatus> failedProperties)
        构造一个SQLClientInfoException与给定的初始化的对象reason ， SQLState ， vendorCode和failedProperties 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        failedProperties - 包含无法设置的属性值的地图。 地图中的键包含无法设置的客户端信息属性的名称，值包含ClientInfoStatus定义的原因码ClientInfoStatus
        从以下版本开始：
        1.6

      • SQLClientInfoException

        public SQLClientInfoException​(String reason,
                              String SQLState,
                              int vendorCode,
                              Map<String,ClientInfoStatus> failedProperties,
                              Throwable cause)
        构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause ， vendorCode和 failedProperties 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        failedProperties - 包含无法设置的属性值的地图。 地图中的键包含无法设置的客户端信息属性的名称，值包含ClientInfoStatus定义的原因代码ClientInfoStatus
        cause - 这个SQLException的基本原因（由getCause()方法保存以供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

    • 方法详细信息

      • getFailedProperties

        public Map<String,ClientInfoStatus> getFailedProperties​()
        返回无法设置的客户端信息属性列表。 地图中的键包含无法设置的客户端信息属性的名称，值包含ClientInfoStatus定义的原因码ClientInfoStatus
        结果
        包含无法设置的客户端信息属性的地图列表
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface SQLData

  • public interface SQLData
    用于将SQL用户定义类型（UDT）自定义映射到Java编程语言中的类的接口。 实现SQLData接口的类的类对象将被输入到相应的Connection对象的类型映射以及作为自定义映射的UDT的SQL名称。

    通常， SQLData实现将为SQL结构化类型的每个属性或SQL DISTINCT类型的单个字段定义一个字段。 当使用ResultSet.getObject方法从数据源检索UDT时，它将被映射为此类的实例。 程序员可以像Java编程语言中的任何其他对象一样对该类实例进行操作，然后通过调用PreparedStatement.setObject方法存储对其进行的任何更改，将其映射到SQL类型。

    预期自定义映射的类的实现将由一个工具完成。 在典型的实现中，程序员将简单地提供SQL UDT的名称，它被映射到的类的名称以及要映射UDT的每个属性的字段的名称。 该工具将使用此信息来实现SQLData.readSQL和SQLData.writeSQL方法。 readSQL方法调用适当的SQLInput方法从SQLInput对象读取每个属性， writeSQL方法调用SQLOutput方法通过SQLOutput对象将每个属性写回数据源。

    应用程序员通常不会直接调用SQLData方法，而SQLInput和SQLOutput方法在内部由SQLData方法调用，而不是应用程序代码。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getSQLTypeName​()
      返回此对象表示的SQL用户定义类型的完全限定名称。
      void readSQL​(SQLInput stream, String typeName)
      使用从数据库读取的数据填充此对象。
      void writeSQL​(SQLOutput stream)
      将此对象写入给定的SQL数据流，将其转换回数据源中的SQL值。

    • 方法详细信息

      • getSQLTypeName

        String getSQLTypeName​()
               throws SQLException
        返回此对象表示的SQL用户定义类型的完全限定名称。 此方法由JDBC驱动程序调用，以获取映射到此实例为SQLData的UDT实例的名称。
        结果
        在构建和填充此对象时传递给方法 readSQL的类型名称
        异常
        SQLException - 如果有数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readSQL

        void readSQL​(SQLInput stream,
             String typeName)
      throws SQLException
        使用从数据库读取的数据填充此对象。 该方法的实现必须遵循以下协议：
        • 它必须从给定的输入流中读取SQL类型的每个属性或元素。 这是通过调用输入流的方法来读取每个项目，按照它们在类型的SQL定义中显示的顺序完成。
        • 方法readSQL然后将数据分配给适当的字段或这些或其他对象的元素。 具体而言，它必须调用相应的读取器方法（ SQLInput.readString ， SQLInput.readBigDecimal ，等等）方法（S）执行以下操作：针对不同类型，读取其单个数据元素; 对于结构化类型，读取SQL类型的每个属性的值。
        JDBC驱动程序在调用此方法之前使用类型映射程序初始化输入流，由SQLInput中适当的SQLInput读取器方法使用。
        参数
        stream - 要从中读取正在自定义映射的值的数据的 SQLInput对象
        typeName - 数据流上的值的SQL类型名称
        异常
        SQLException - 如果有数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        SQLInput

      • writeSQL

        void writeSQL​(SQLOutput stream)
       throws SQLException
        将此对象写入给定的SQL数据流，将其转换回数据源中的SQL值。 该方法的实现必须遵循以下协议：
        它必须将SQL类型的每个属性写入给定的输出流。 这是通过调用输出流的方法来编写每个项，按照它们在类型的SQL定义中出现的顺序来完成。 具体而言，它必须调用适当SQLOutput作家方法（一个或多个）（ writeInt ， writeString ，等等），以执行以下操作：对的独特的类型，写入其单个数据元素; 对于结构类型，为SQL类型的每个属性写入一个值。
        参数
        stream - 要为自定义映射的值写入数据的 SQLOutput对象
        异常
        SQLException - 如果有数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
        另请参见：
        SQLOutput
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLDataException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLDataException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLNonTransientException
            • java.sql.SQLDataException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLDataException
extends SQLNonTransientException
    当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。 这表示各种数据错误，包括但不限于数据转换错误，除以0，以及函数的无效参数。

    请参阅您的驱动程序供应商文档， 异常可能抛出此异常的供应商指定的条件。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLDataException​()
      构造一个 SQLDataException对象。
      SQLDataException​(String reason)
      使用给定的 reason构造一个 SQLDataException对象。
      SQLDataException​(String reason, String SQLState)
      使用给定的 reason和 SQLState构造一个 SQLDataException对象。
      SQLDataException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLDataException与给定对象 reason ， SQLState和 vendorCode 。
      SQLDataException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLDataException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLDataException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLDataException与给定对象 reason ， SQLState和 cause 。
      SQLDataException​(String reason, Throwable cause)
      构造一个 SQLDataException对象，给定的 reason和 cause 。
      SQLDataException​(Throwable cause)
      构造一个 SQLDataException对象与一个给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLDataException

        public SQLDataException​()
        构造一个SQLDataException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过调用被初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLDataException

        public SQLDataException​(String reason)
        构造一个SQLDataException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLDataException

        public SQLDataException​(String reason,
                        String SQLState)
        构造一个SQLDataException对象，给定的reason和SQLState 。 供应商代码初始化为0. cause未初始化，随后可以通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLDataException

        public SQLDataException​(String reason,
                        String SQLState,
                        int vendorCode)
        构造一个SQLDataException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLDataException

        public SQLDataException​(Throwable cause)
        构造一个SQLDataException对象与一个给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLDataException

        public SQLDataException​(String reason,
                        Throwable cause)
        使用给定的reason和cause构造一个SQLDataException对象。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLDataException

        public SQLDataException​(String reason,
                        String SQLState,
                        Throwable cause)
        构造一个SQLDataException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLDataException

        public SQLDataException​(String reason,
                        String SQLState,
                        int vendorCode,
                        Throwable cause)
        构造一个 SQLDataException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>
    已知直接子类：
    BatchUpdateException ， RowSetWarning ， SerialException ， SQLClientInfoException ， SQLNonTransientException ， SQLRecoverableException ， SQLTransientException ， SQLWarning ， SyncFactoryException ， SyncProviderException

    public class SQLException
extends 异常
implements Iterable<Throwable>

    提供有关数据库访问错误或其他错误的信息的异常。

    每个SQLException提供了几种信息：

    • 描述错误的字符串。 这被用作通过方法getMessage可用的Java异常消息。
    • 一个“SQLstate”字符串，它遵循XOPEN SQLstate约定或SQL：2003约定。 SQLState字符串的值在相应的规范中描述。 可以使用DatabaseMetaData方法getSQLStateType来发现驱动程序是否返回XOPEN类型或SQL：2003类型。
    • 一个特定于每个供应商的整数错误代码。 通常这将是底层数据库返回的实际错误代码。
    • 连锁到下一个例外。 这可以用于提供其他错误信息。
    • 因果关系，如果有的话这个SQLException 。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLException​()
      构造一个 SQLException对象。
      SQLException​(String reason)
      使用给定的 reason构造一个 SQLException对象。
      SQLException​(String reason, String SQLState)
      构造一个 SQLException对象，给定的 reason和 SQLState 。
      SQLException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLException与给定对象 reason ， SQLState和 vendorCode 。
      SQLException​(String reason, String sqlState, int vendorCode, Throwable cause)
      构造一个 SQLException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLException​(String reason, String sqlState, Throwable cause)
      构造一个 SQLException与给定对象 reason ， SQLState和 cause 。
      SQLException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLException对象。
      SQLException​(Throwable cause)
      构造一个 SQLException对象与给定的 cause 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getErrorCode​()
      检索此 SQLException对象的供应商特定异常代码。
      SQLException getNextException​()
      通过setNextException（SQLException ex）获取链接到此 SQLException对象的异常。
      String getSQLState​()
      检索此 SQLException对象的SQLState。
      Iterator<Throwable> iterator​()
      返回链接的SQLExceptions的迭代器。
      void setNextException​(SQLException ex)
      将 SQLException对象添加到链的末尾。

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLException

        public SQLException​(String reason,
                    String SQLState,
                    int vendorCode)
        构造一个SQLException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码

      • SQLException

        public SQLException​(String reason,
                    String SQLState)
        使用给定的reason和SQLState构造一个SQLException对象。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码

      • SQLException

        public SQLException​(String reason)
        构造一个SQLException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法初始化。
        参数
        reason - 异常的描述

      • SQLException

        public SQLException​()
        构造一个SQLException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。

      • SQLException

        public SQLException​(Throwable cause)
        构造一个SQLException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLException

        public SQLException​(String reason,
                    Throwable cause)
        使用给定的reason和cause构造一个SQLException对象。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLException

        public SQLException​(String reason,
                    String sqlState,
                    Throwable cause)
        构造一个SQLException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        sqlState - 标识异常的XOPEN或SQL：2003代码
        cause - 这个SQLException原因（其保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLException

        public SQLException​(String reason,
                    String sqlState,
                    int vendorCode,
                    Throwable cause)
        构造一个 SQLException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        sqlState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause - 这是SQLException （其保存以供getCause()方法稍后检索）的根本原因; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

    • 方法详细信息

      • getSQLState

        public String getSQLState​()
        检索此 SQLException对象的SQLState。
        结果
        SQLState值

      • getErrorCode

        public int getErrorCode​()
        检索此 SQLException对象的供应商特定异常代码。
        结果
        供应商的错误代码

      • getNextException

        public SQLException getNextException​()
        通过setNextException（SQLException ex）检索链接到此 SQLException对象的异常。
        结果
        链中的下一个SQLException对象; null如果没有
        另请参见：
        setNextException(java.sql.SQLException)

      • setNextException

        public void setNextException​(SQLException ex)
        在对象的末尾添加一个 SQLException对象。
        参数
        ex - 将添加到 SQLException链结尾的新异常
        另请参见：
        getNextException()

      • iterator

        public Iterator<Throwable> iterator​()
        返回链接的SQLExceptions的迭代器。 迭代器将用于遍历每个SQLException及其基本原因（如果有的话）。
        Specified by:
        iterator在接口 Iterable<Throwable>
        结果
        在链接的SQLExceptions和原因按正确顺序的迭代器
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLFeatureNotSupportedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLFeatureNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLNonTransientException
            • java.sql.SQLFeatureNotSupportedException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLFeatureNotSupportedException
extends SQLNonTransientException
    当SQLState类的值为' 0A '（值为'零'A）时，抛出SQLException的子类。 这表明JDBC驱动程序不支持可选的JDBC功能。 可选的JDBC功能可以归入休闲类别：
    • 不支持可选功能
    • 不支持可选的重载方法
    • 不支持方法的可选模式。 方法的模式是基于作为方法的参数值传递的常数确定的
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLFeatureNotSupportedException​()
      构造一个 SQLFeatureNotSupportedException对象。
      SQLFeatureNotSupportedException​(String reason)
      构造一个 SQLFeatureNotSupportedException对象与一个给定的 reason 。
      SQLFeatureNotSupportedException​(String reason, String SQLState)
      构造一个 SQLFeatureNotSupportedException对象，给定的 reason和 SQLState 。
      SQLFeatureNotSupportedException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState和 vendorCode 。
      SQLFeatureNotSupportedException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLFeatureNotSupportedException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState和 cause 。
      SQLFeatureNotSupportedException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLFeatureNotSupportedException对象。
      SQLFeatureNotSupportedException​(Throwable cause)
      构造一个 SQLFeatureNotSupportedException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLFeatureNotSupportedException

        public SQLFeatureNotSupportedException​()
        构造一个SQLFeatureNotSupportedException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLFeatureNotSupportedException

        public SQLFeatureNotSupportedException​(String reason)
        使用给定的reason构造一个SQLFeatureNotSupportedException对象。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLFeatureNotSupportedException

        public SQLFeatureNotSupportedException​(String reason,
                                       String SQLState)
        构造一个SQLFeatureNotSupportedException对象与给定的reason和SQLState 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLFeatureNotSupportedException

        public SQLFeatureNotSupportedException​(String reason,
                                       String SQLState,
                                       int vendorCode)
        构造一个SQLFeatureNotSupportedException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLFeatureNotSupportedException

        public SQLFeatureNotSupportedException​(Throwable cause)
        构造一个SQLFeatureNotSupportedException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLFeatureNotSupportedException

        public SQLFeatureNotSupportedException​(String reason,
                                       Throwable cause)
        使用给定的reason和cause构造一个SQLFeatureNotSupportedException对象。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause - 这个SQLException的基本原因（由getCause()方法保存供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLFeatureNotSupportedException

        public SQLFeatureNotSupportedException​(String reason,
                                       String SQLState,
                                       Throwable cause)
        构造一个SQLFeatureNotSupportedException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause - （通过getCause()方法保存供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLFeatureNotSupportedException

        public SQLFeatureNotSupportedException​(String reason,
                                       String SQLState,
                                       int vendorCode,
                                       Throwable cause)
        构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface SQLInput

  • 所有已知实现类：
    SQLInputImpl

    public interface SQLInput
    包含表示SQL结构化类型或SQL不同类型实例的值的流的输入流。 该界面仅用于自定义映射，由驱动程序在幕后使用，程序员从不直接调用SQLInput方法。 读取器的方法（ readLong ， readBytes ，等等）为的实现提供了一种方法SQLData接口以读取值SQLInput对象。 并且如SQLData ，必须按照它们对应的属性出现在类型的SQL定义中的顺序进行对reader方法的调用。 方法wasNull用于确定最后读取的值是否为SQL NULL 。

    当方法getObject与实现接口SQLData的类的对象SQLData调用时，JDBC驱动程序调用方法SQLData.getSQLType来确定自定义映射的用户定义类型（UDT）的SQL类型。 驱动程序创建一个SQLInput的实例，并使用UDT的属性进行填充。 然后，驱动程序将输入流传SQLData.readSQL方法SQLData.readSQL ，方法SQLData.readSQL又在其实现中调用SQLInput读取器方法来从输入流读取属性。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      Array readArray​()
      从流中读取SQL ARRAY值，并将其作为Java编程语言中的 Array对象返回。
      InputStream readAsciiStream​()
      读取流中的下一个属性并将其作为ASCII字符流返回。
      BigDecimal readBigDecimal​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 java.math.BigDecimal对象返回。
      InputStream readBinaryStream​()
      读取流中的下一个属性并将其作为未解释的字节流返回。
      Blob readBlob​()
      从流中读取SQL BLOB值，并将其作为Java编程语言中的 Blob对象返回。
      boolean readBoolean​()
      读取流中的下一个属性，并将其作为Java编程语言中的 boolean返回。
      byte readByte​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 byte返回。
      byte[] readBytes​()
      读取流中的下一个属性，并将其作为Java编程语言中的字节数组返回。
      Reader readCharacterStream​()
      读取流中的下一个属性，并将其作为Unicode字符流返回。
      Clob readClob​()
      从流中读取SQL CLOB值，并将其作为Java编程语言中的 Clob对象返回。
      Date readDate​()
      读取流中的下一个属性并将其作为 java.sql.Date对象返回。
      double readDouble​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 double返回。
      float readFloat​()
      读取流中的下一个属性，并将其作为Java编程语言中的 float返回。
      int readInt​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 int返回。
      long readLong​()
      读取流中的下一个属性，并将其作为Java编程语言中的 long返回。
      NClob readNClob​()
      从流中读取SQL NCLOB值，并将其作为Java编程语言中的 NClob对象返回。
      String readNString​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 String返回。
      Object readObject​()
      读取流的头部的数据，并将其作为Java编程语言中的一个 Object返回。
      default <T> T readObject​(Class<T> type)
      读取流中的下一个属性，并将其作为Java编程语言中的一个 Object返回。
      Ref readRef​()
      从流中读取SQL REF值，并将其作为Java编程语言中的 Ref对象返回。
      RowId readRowId​()
      从流中读取SQL ROWID值，并将其作为Java编程语言中的 RowId对象返回。
      short readShort​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 short返回。
      SQLXML readSQLXML​()
      从流中读取SQL XML值，并将其作为Java编程语言中的 SQLXML对象返回。
      String readString​()
      读取流中的下一个属性，并将其作为Java编程语言中的 String返回。
      Time readTime​()
      读取流中的下一个属性，并将其作为 java.sql.Time对象返回。
      Timestamp readTimestamp​()
      读取流中的下一个属性，并将其作为 java.sql.Timestamp对象返回。
      URL readURL​()
      从流中读取SQL DATALINK值，并将其作为Java编程语言中的 java.net.URL对象返回。
      boolean wasNull​()
      检索最后读取的值是否为SQL NULL 。

    • 方法详细信息

      • readString

        String readString​()
           throws SQLException
        String
        结果
        属性; NULL null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readBoolean

        boolean readBoolean​()
             throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的一个 boolean返回。
        结果
        属性; 如果值为SQL NULL ，则返回false
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readByte

        byte readByte​()
       throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的一个 byte返回。
        结果
        属性; 如果值为SQL NULL ，则返回0
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readShort

        short readShort​()
         throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的 short返回。
        结果
        属性; 如果值为SQL NULL ，则返回0
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readInt

        int readInt​()
     throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的一个 int返回。
        结果
        属性; 如果值为SQL NULL ，则返回0
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readLong

        long readLong​()
       throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的 long返回。
        结果
        属性; 如果值为SQL NULL ，则返回0
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readFloat

        float readFloat​()
         throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的一个 float返回。
        结果
        属性; 如果值为SQL NULL ，则返回0
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readDouble

        double readDouble​()
           throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的一个 double返回。
        结果
        属性; 如果值为SQL NULL ，则返回0
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readBigDecimal

        BigDecimal readBigDecimal​()
                   throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的一个 java.math.BigDecimal对象返回。
        结果
        属性; 如果值为SQL NULL ，则返回null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readBytes

        byte[] readBytes​()
          throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的字节数组返回。
        结果
        属性; 如果值为SQL NULL ，则返回null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readDate

        Date readDate​()
       throws SQLException
        读取流中的下一个属性，并将其作为 java.sql.Date对象返回。
        结果
        属性; 如果值为SQL NULL ，则返回null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readTime

        Time readTime​()
       throws SQLException
        读取流中的下一个属性，并将其作为 java.sql.Time对象返回。
        结果
        属性; 如果值为SQL NULL ，则返回null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readTimestamp

        Timestamp readTimestamp​()
                 throws SQLException
        读取流中的下一个属性，并将其作为 java.sql.Timestamp对象返回。
        结果
        属性; 如果值为SQL NULL ，则返回null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readCharacterStream

        Reader readCharacterStream​()
                    throws SQLException
        读取流中的下一个属性，并将其作为Unicode字符流返回。
        结果
        属性; 如果值为SQL NULL ，则返回null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readAsciiStream

        InputStream readAsciiStream​()
                     throws SQLException
        读取流中的下一个属性并将其作为ASCII字符流返回。
        结果
        属性; 如果值为SQL NULL ，则返回null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readBinaryStream

        InputStream readBinaryStream​()
                      throws SQLException
        读取流中的下一个属性并将其作为未解释的字节流返回。
        结果
        属性; 如果值为SQL NULL ，则返回null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readObject

        Object readObject​()
           throws SQLException
        读取流头的数据，并以Java编程语言中的Object返回。 返回的对象的实际类型由默认类型映射以及此流的类型映射中存在的任何自定义项确定。

        流式传输到应用程序之前，JDBC驱动程序会向流中注册类型映射。

        当流的头部的数据是SQL NULL ，该方法返回null 。 如果基准是SQL结构或不同类型，则它确定流头上的基准的SQL类型。 如果流的类型映射具有该SQL类型的条目，则驱动程序构造适当类的对象，并调用该对象上的方法SQLData.readSQL ，该对象使用该方法描述的协议从流中读取附加数据。

        结果
        流头的数据作为Java编程语言中的一个Object ; null如果基准是SQL NULL
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readRef

        Ref readRef​()
     throws SQLException
        从流中读取SQL REF值，并将其作为Java编程语言中的 Ref对象返回。
        结果
        一个Ref对象，表示流头部的SQL REF值; null如果读取的值是SQL NULL
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readBlob

        Blob readBlob​()
       throws SQLException
        从流中读取SQL BLOB值，并将其作为Java编程语言中的 Blob对象返回。
        结果
        一个Blob对象，表示流头部的SQL BLOB值的数据; null如果读取的值是SQL NULL
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readClob

        Clob readClob​()
       throws SQLException
        从流中读取SQL CLOB值，并将其作为Java编程语言中的 Clob对象返回。
        结果
        一个Clob对象，表示流头上的SQL CLOB值的数据; null如果读取的值为SQL NULL
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readArray

        Array readArray​()
         throws SQLException
        从流中读取SQL ARRAY值，并将其作为Java编程语言中的 Array对象返回。
        结果
        一个Array对象，表示流头部的SQL ARRAY值的数据; null如果读取的值是SQL NULL
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • wasNull

        boolean wasNull​()
         throws SQLException
        检索最后读取的值是否为SQL NULL 。
        结果
        true如果最近读取的SQL值是SQL NULL ; 否则为false
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • readURL

        URL readURL​()
     throws SQLException
        从流中读取SQL DATALINK值，并将其作为Java编程语言中的 java.net.URL对象返回。
        结果
        一个 java.net.URL对象。
        异常
        SQLException - 如果发生数据库访问错误，或者网址格式错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • readNClob

        NClob readNClob​()
         throws SQLException
        从流中读取SQL NCLOB值，并将其作为Java编程语言中的一个 NClob对象返回。
        结果
        一个NClob对象，表示流头部的SQL NCLOB值的数据; null如果读取的值是SQL NULL
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • readNString

        String readNString​()
            throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的String返回。 访问时，它适用于使用NCHAR ， NVARCHAR和LONGNVARCHAR列。
        结果
        属性; 如果值为SQL NULL ，则返回null
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • readSQLXML

        SQLXML readSQLXML​()
           throws SQLException
        从流中读取SQL XML值，并将其作为Java编程语言中的 SQLXML对象返回。
        结果
        一个表示数据头的SQL XML值的数据的SQLXML对象; null如果读取的值是SQL NULL
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • readRowId

        RowId readRowId​()
         throws SQLException
        从流中读取SQL ROWID值，并将其作为Java编程语言中的 RowId对象返回。
        结果
        一个表示数据头的SQL ROWID值的数据的RowId对象; null如果读取的值是SQL NULL
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • readObject

        default <T> T readObject​(Class<T> type)
                  throws SQLException
        读取流中的下一个属性，并将其作为Java编程语言中的一个Object返回。 返回的对象的实际类型由指定的Java数据类型以及此流的类型映射中存在的任何自定义项确定。

        流式传输到应用程序之前，JDBC驱动程序会向流中注册类型映射。

        当流的头部的属性是SQL NULL该方法返回null 。 如果该属性是SQL结构化或不同类型，则它将确定流头上属性的SQL类型。 如果流的类型映射具有该SQL类型的条目，则驱动程序将构建适当类的对象，并调用该对象上的方法SQLData.readSQL ，该方法使用该方法描述的协议从流中读取附加数据。

        默认实现将抛出SQLFeatureNotSupportedException

        参数类型
        T - 由此Class对象建模的类的类型
        参数
        type - 表示将属性转换为Java数据类型的类。
        结果
        流的头部属性为Java编程语言中的一个Object ; null如果属性是SQL NULL
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLIntegrityConstraintViolationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLIntegrityConstraintViolationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLNonTransientException
            • java.sql.SQLIntegrityConstraintViolationException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLIntegrityConstraintViolationException
extends SQLNonTransientException
    当SQLState类的值为“ 23 ”时，或在供应商指定的条件下，抛出SQLException的子类。 这表示违反完整性约束（外键，主键或唯一键）。

    请咨询您的驱动程序供应商文档， 异常可能抛出此异常的供应商指定的条件。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLIntegrityConstraintViolationException​()
      构造一个 SQLIntegrityConstraintViolationException对象。
      SQLIntegrityConstraintViolationException​(String reason)
      构造一个 SQLIntegrityConstraintViolationException与给定的 reason 。
      SQLIntegrityConstraintViolationException​(String reason, String SQLState)
      使用给定的 reason和 SQLState构造一个 SQLIntegrityConstraintViolationException对象。
      SQLIntegrityConstraintViolationException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState和 vendorCode 。
      SQLIntegrityConstraintViolationException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLIntegrityConstraintViolationException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState和 cause 。
      SQLIntegrityConstraintViolationException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLIntegrityConstraintViolationException对象。
      SQLIntegrityConstraintViolationException​(Throwable cause)
      构造一个 SQLIntegrityConstraintViolationException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLIntegrityConstraintViolationException

        public SQLIntegrityConstraintViolationException​()
        构造一个SQLIntegrityConstraintViolationException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLIntegrityConstraintViolationException

        public SQLIntegrityConstraintViolationException​(String reason)
        构造一个SQLIntegrityConstraintViolationException与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，随后可以通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLIntegrityConstraintViolationException

        public SQLIntegrityConstraintViolationException​(String reason,
                                                String SQLState)
        使用给定的reason和SQLState构造一个SQLIntegrityConstraintViolationException对象。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLIntegrityConstraintViolationException

        public SQLIntegrityConstraintViolationException​(String reason,
                                                String SQLState,
                                                int vendorCode)
        构造一个SQLIntegrityConstraintViolationException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLIntegrityConstraintViolationException

        public SQLIntegrityConstraintViolationException​(Throwable cause)
        构造一个SQLIntegrityConstraintViolationException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLIntegrityConstraintViolationException

        public SQLIntegrityConstraintViolationException​(String reason,
                                                Throwable cause)
        使用给定的reason和cause构造一个SQLIntegrityConstraintViolationException对象。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause - （由getCause()方法保存供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLIntegrityConstraintViolationException

        public SQLIntegrityConstraintViolationException​(String reason,
                                                String SQLState,
                                                Throwable cause)
        构造一个SQLIntegrityConstraintViolationException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLIntegrityConstraintViolationException

        public SQLIntegrityConstraintViolationException​(String reason,
                                                String SQLState,
                                                int vendorCode,
                                                Throwable cause)
        构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause - （保存为getCause()方法后续检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLInvalidAuthorizationSpecException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLInvalidAuthorizationSpecException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLNonTransientException
            • java.sql.SQLInvalidAuthorizationSpecException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLInvalidAuthorizationSpecException
extends SQLNonTransientException
    当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出SQLException的子类。 这表示在连接建立期间呈现的授权凭证无效。

    请参阅您的驱动程序供应商文档， 异常可能抛出此异常的供应商指定的条件。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLInvalidAuthorizationSpecException​()
      构造一个 SQLInvalidAuthorizationSpecException对象。
      SQLInvalidAuthorizationSpecException​(String reason)
      构造一个 SQLInvalidAuthorizationSpecException对象与给定的 reason 。
      SQLInvalidAuthorizationSpecException​(String reason, String SQLState)
      构造一个 SQLInvalidAuthorizationSpecException对象与给定的 reason和 SQLState 。
      SQLInvalidAuthorizationSpecException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState和 vendorCode 。
      SQLInvalidAuthorizationSpecException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLInvalidAuthorizationSpecException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState和 cause 。
      SQLInvalidAuthorizationSpecException​(String reason, Throwable cause)
      构造一个 SQLInvalidAuthorizationSpecException对象与一个给定的 reason和 cause 。
      SQLInvalidAuthorizationSpecException​(Throwable cause)
      构造一个 SQLInvalidAuthorizationSpecException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLInvalidAuthorizationSpecException

        public SQLInvalidAuthorizationSpecException​()
        构造一个SQLInvalidAuthorizationSpecException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLInvalidAuthorizationSpecException

        public SQLInvalidAuthorizationSpecException​(String reason)
        构造一个SQLInvalidAuthorizationSpecException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLInvalidAuthorizationSpecException

        public SQLInvalidAuthorizationSpecException​(String reason,
                                            String SQLState)
        构造一个SQLInvalidAuthorizationSpecException对象与给定的reason和SQLState 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLInvalidAuthorizationSpecException

        public SQLInvalidAuthorizationSpecException​(String reason,
                                            String SQLState,
                                            int vendorCode)
        构造一个SQLInvalidAuthorizationSpecException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLInvalidAuthorizationSpecException

        public SQLInvalidAuthorizationSpecException​(Throwable cause)
        构造一个SQLInvalidAuthorizationSpecException对象与给定的cause 。 SQLState被初始化为null ，供应商代码初始化为0. null如果为reason则初始化为cause==null或cause.toString()如果为cause!=null 。
        参数
        cause - 这是SQLException （其保存以供getCause()方法稍后检索）的根本原因; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLInvalidAuthorizationSpecException

        public SQLInvalidAuthorizationSpecException​(String reason,
                                            Throwable cause)
        构造一个SQLInvalidAuthorizationSpecException对象与一个给定的reason和cause 。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLInvalidAuthorizationSpecException

        public SQLInvalidAuthorizationSpecException​(String reason,
                                            String SQLState,
                                            Throwable cause)
        构造一个SQLInvalidAuthorizationSpecException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLInvalidAuthorizationSpecException

        public SQLInvalidAuthorizationSpecException​(String reason,
                                            String SQLState,
                                            int vendorCode,
                                            Throwable cause)
        构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause - 这个SQLException的基本原因（由getCause()方法保存以备以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLNonTransientConnectionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLNonTransientConnectionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLNonTransientException
            • java.sql.SQLNonTransientConnectionException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLNonTransientConnectionException
extends SQLNonTransientException
    抛出SQLState类值为“ 08 ”的SQLException子类，或者在供应商指定的条件下。 这表示如果重新尝试操作失败的连接操作将不会成功，而不会导致故障被更正。

    请咨询您的驱动程序供应商文档， 异常可能抛出此异常的供应商指定的条件。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLNonTransientConnectionException​()
      构造一个 SQLNonTransientConnectionException对象。
      SQLNonTransientConnectionException​(String reason)
      构造一个 SQLNonTransientConnectionException对象与给定的 reason 。
      SQLNonTransientConnectionException​(String reason, String SQLState)
      使用给定的 reason和 SQLState构造一个 SQLNonTransientConnectionException对象。
      SQLNonTransientConnectionException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState和 vendorCode 。
      SQLNonTransientConnectionException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLNonTransientConnectionException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState和 cause 。
      SQLNonTransientConnectionException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLTransientException对象。
      SQLNonTransientConnectionException​(Throwable cause)
      构造一个 SQLNonTransientConnectionException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLNonTransientConnectionException

        public SQLNonTransientConnectionException​()
        构造一个SQLNonTransientConnectionException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLNonTransientConnectionException

        public SQLNonTransientConnectionException​(String reason)
        构造一个SQLNonTransientConnectionException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，随后可以通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLNonTransientConnectionException

        public SQLNonTransientConnectionException​(String reason,
                                          String SQLState)
        构造一个SQLNonTransientConnectionException对象，给定的reason和SQLState 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLNonTransientConnectionException

        public SQLNonTransientConnectionException​(String reason,
                                          String SQLState,
                                          int vendorCode)
        构造一个SQLNonTransientConnectionException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLNonTransientConnectionException

        public SQLNonTransientConnectionException​(Throwable cause)
        构造一个SQLNonTransientConnectionException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause - 这个SQLException原因（其保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLNonTransientConnectionException

        public SQLNonTransientConnectionException​(String reason,
                                          Throwable cause)
        使用给定的reason和cause构造一个SQLTransientException对象。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLNonTransientConnectionException

        public SQLNonTransientConnectionException​(String reason,
                                          String SQLState,
                                          Throwable cause)
        构造一个SQLNonTransientConnectionException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause - （由getCause()方法保存供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLNonTransientConnectionException

        public SQLNonTransientConnectionException​(String reason,
                                          String SQLState,
                                          int vendorCode,
                                          Throwable cause)
        构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLNonTransientException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLNonTransientException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLNonTransientException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>
    已知直接子类：
    SQLDataException ， SQLFeatureNotSupportedException ， SQLIntegrityConstraintViolationException ， SQLInvalidAuthorizationSpecException ， SQLNonTransientConnectionException ， SQLSyntaxErrorException

    public class SQLNonTransientException
extends SQLException
    当一个重试相同操作的实例将失败的情况下抛出SQLException的子类，除非修正了SQLException的原因。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLNonTransientException​()
      构造一个 SQLNonTransientException对象。
      SQLNonTransientException​(String reason)
      构造一个 SQLNonTransientException对象与给定的 reason 。
      SQLNonTransientException​(String reason, String SQLState)
      使用给定的 reason和 SQLState构造一个 SQLNonTransientException对象。
      SQLNonTransientException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLNonTransientException与给定对象 reason ， SQLState和 vendorCode 。
      SQLNonTransientException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLNonTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLNonTransientException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLNonTransientException与给定对象 reason ， SQLState和 cause 。
      SQLNonTransientException​(String reason, Throwable cause)
      构造一个 SQLTransientException对象与给定的 reason和 cause 。
      SQLNonTransientException​(Throwable cause)
      构造一个 SQLNonTransientException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLNonTransientException

        public SQLNonTransientException​()
        构造一个SQLNonTransientException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLNonTransientException

        public SQLNonTransientException​(String reason)
        构造一个SQLNonTransientException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLNonTransientException

        public SQLNonTransientException​(String reason,
                                String SQLState)
        构造一个SQLNonTransientException对象与给定的reason和SQLState 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLNonTransientException

        public SQLNonTransientException​(String reason,
                                String SQLState,
                                int vendorCode)
        构造一个SQLNonTransientException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLNonTransientException

        public SQLNonTransientException​(Throwable cause)
        构造一个SQLNonTransientException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLNonTransientException

        public SQLNonTransientException​(String reason,
                                Throwable cause)
        构造一个SQLTransientException对象与给定的reason和cause 。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLNonTransientException

        public SQLNonTransientException​(String reason,
                                String SQLState,
                                Throwable cause)
        构造一个SQLNonTransientException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLNonTransientException

        public SQLNonTransientException​(String reason,
                                String SQLState,
                                int vendorCode,
                                Throwable cause)
        构造一个 SQLNonTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLOutput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface SQLOutput

  • 所有已知实现类：
    SQLOutputImpl

    public interface SQLOutput
    用于将用户定义类型的属性写入数据库的输出流。 此接口仅用于自定义映射，由驱动程序使用，其方法从不直接由程序员调用。

    当实现接口SQLData的类的对象作为参数传递给SQL语句时，JDBC驱动程序将调用方法SQLData.getSQLType来确定传递给数据库的SQL数据的种类。 然后，驱动程序创建一个SQLOutput的实例，并将其传递给方法SQLData.writeSQL 。 该方法writeSQL依次调用适当SQLOutput 作家方法writeBoolean ， writeCharacterStream ，等等），以写入从数据SQLData对象到SQLOutput输出流作为SQL用户定义类型的表示。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void writeArray​(Array x)
      向流写入一个SQL ARRAY值。
      void writeAsciiStream​(InputStream x)
      将下一个属性作为ASCII字符串写入流。
      void writeBigDecimal​(BigDecimal x)
      将下一个属性作为java.math.BigDecimal对象写入流。
      void writeBinaryStream​(InputStream x)
      将下一个属性写入流作为未解释字节流。
      void writeBlob​(Blob x)
      向流写入一个SQL BLOB值。
      void writeBoolean​(boolean x)
      将下一个属性作为Java布尔值写入流。
      void writeByte​(byte x)
      将下一个属性作为Java字节写入流。
      void writeBytes​(byte[] x)
      将下一个属性写入流作为字节数组。
      void writeCharacterStream​(Reader x)
      将下一个属性作为Unicode字符流写入流。
      void writeClob​(Clob x)
      将SQL CLOB值写入流。
      void writeDate​(Date x)
      将下一个属性作为java.sql.Date对象写入流。
      void writeDouble​(double x)
      将下一个属性作为Java double写入流。
      void writeFloat​(float x)
      将下一个属性作为Java float写入流。
      void writeInt​(int x)
      将下一个属性作为Java int写入流。
      void writeLong​(long x)
      将下一个属性作为Java写入流。
      void writeNClob​(NClob x)
      将SQL NCLOB值写入流。
      void writeNString​(String x)
      将下一个属性作为Java编程语言中的 String写入流。
      default void writeObject​(Object x, SQLType targetSqlType)
      将包含在给定对象中的数据写入流。
      void writeObject​(SQLData x)
      向流中写入包含在给定的 SQLData对象中的数据。
      void writeRef​(Ref x)
      向流中写入一个SQL REF值。
      void writeRowId​(RowId x)
      将SQL ROWID值写入流。
      void writeShort​(short x)
      将下一个属性写入流作为Java短。
      void writeSQLXML​(SQLXML x)
      将SQL XML值写入流。
      void writeString​(String x)
      将下一个属性写入流中，作为Java编程语言中的一个 String 。
      void writeStruct​(Struct x)
      将SQL结构化类型值写入流。
      void writeTime​(Time x)
      将下一个属性作为java.sql.Time对象写入流。
      void writeTimestamp​(Timestamp x)
      将下一个属性作为java.sql.Timestamp对象写入流。
      void writeURL​(URL x)
      将SQL DATALINK值写入流。

    • 方法详细信息

      • writeString

        void writeString​(String x)
          throws SQLException
        将下一个属性写入流中，作为Java编程语言中的 String 。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeBoolean

        void writeBoolean​(boolean x)
           throws SQLException
        将下一个属性作为Java布尔值写入流。 将下一个属性写入流中，作为Java编程语言中的一个String 。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeByte

        void writeByte​(byte x)
        throws SQLException
        将下一个属性作为Java字节写入流。 将下一个属性写入流，作为Java编程语言中的一个String 。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeShort

        void writeShort​(short x)
         throws SQLException
        将下一个属性写入流作为Java短。 将下一个属性作为Java编程语言中的String写入流。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeInt

        void writeInt​(int x)
       throws SQLException
        将下一个属性作为Java int写入流。 将下一个属性作为Java编程语言中的一个String写入流。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeLong

        void writeLong​(long x)
        throws SQLException
        将下一个属性作为Java写入流。 将下一个属性写入流，作为Java编程语言中的一个String 。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeFloat

        void writeFloat​(float x)
         throws SQLException
        将下一个属性作为Java float写入流。 将下一个属性写入流，作为Java编程语言中的一个String 。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeDouble

        void writeDouble​(double x)
          throws SQLException
        将下一个属性作为Java double写入流。 将下一个属性写入流中，作为Java编程语言中的一个String 。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeBigDecimal

        void writeBigDecimal​(BigDecimal x)
              throws SQLException
        将下一个属性作为java.math.BigDecimal对象写入流。 将下一个属性写入流中，作为Java编程语言中的一个String 。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeBytes

        void writeBytes​(byte[] x)
         throws SQLException
        将下一个属性写入流作为字节数组。 将下一个属性写入流中，作为Java编程语言中的一个String 。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeDate

        void writeDate​(Date x)
        throws SQLException
        将下一个属性作为java.sql.Date对象写入流。 将下一个属性作为Java编程语言中的一个java.sql.Date对象写入流。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeTime

        void writeTime​(Time x)
        throws SQLException
        将下一个属性作为java.sql.Time对象写入流。 将下一个属性作为Java编程语言中的java.sql.Date对象写入流。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeTimestamp

        void writeTimestamp​(Timestamp x)
             throws SQLException
        将下一个属性作为java.sql.Timestamp对象写入流。 将下一个属性写入流中，作为Java编程语言中的一个java.sql.Date对象。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeCharacterStream

        void writeCharacterStream​(Reader x)
                   throws SQLException
        将下一个属性作为Unicode字符流写入流。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeAsciiStream

        void writeAsciiStream​(InputStream x)
               throws SQLException
        将下一个属性作为ASCII字符串写入流。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeBinaryStream

        void writeBinaryStream​(InputStream x)
                throws SQLException
        将下一个属性写入流作为未解释字节流。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeObject

        void writeObject​(SQLData x)
          throws SQLException
        向流中写入包含在给定的SQLData对象中的数据。 当SQLData对象为null ，此方法将SQL NULL写入流。 否则，它调用给定对象的SQLData.writeSQL方法，该方法将对象的属性写入流。 方法SQLData.writeSQL的实现调用适当的SQLOutput写入器方法来按顺序写入每个对象的属性。 属性必须从SQLInput输入流中读取，并以与用户定义类型的SQL定义相同的顺序写入SQLOutput输出流。
        参数
        x - 表示SQL结构化或不同类型数据的对象
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeRef

        void writeRef​(Ref x)
       throws SQLException
        新新新新 REF
        参数
        x - 表示SQL REF值的数据的 Ref对象
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeBlob

        void writeBlob​(Blob x)
        throws SQLException
        将SQL BLOB值写入流。
        参数
        x - 表示SQL BLOB值的数据的 Blob对象
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeClob

        void writeClob​(Clob x)
        throws SQLException
        将SQL CLOB值写入流。
        参数
        x - 表示SQL CLOB值的数据的 Clob对象
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeStruct

        void writeStruct​(Struct x)
          throws SQLException
        将SQL结构化类型值写入流。
        参数
        x - 表示SQL结构类型数据的 Struct对象
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeArray

        void writeArray​(Array x)
         throws SQLException
        将SQL ARRAY值写入流。
        参数
        x - 表示SQL ARRAY类型的数据的 Array对象
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • writeURL

        void writeURL​(URL x)
       throws SQLException
        将SQL DATALINK值写入流。
        参数
        x - 表示SQL DATALINK类型数据的 java.net.URL对象
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • writeNString

        void writeNString​(String x)
           throws SQLException
        将下一个属性写入流中，作为Java编程语言中的一个String 。 驱动程序将其转换为SQL NCHAR或NVARCHAR或LONGNVARCHAR值（取决于参数相对于驱动程序对NVARCHAR值的限制的大小），将其发送到流。
        参数
        x - 传递给数据库的值
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • writeNClob

        void writeNClob​(NClob x)
         throws SQLException
        将SQL NCLOB值写入流。
        参数
        x - 表示SQL NCLOB值的数据的 NClob对象
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • writeRowId

        void writeRowId​(RowId x)
         throws SQLException
        写入一个SQL ROWID值到流。
        参数
        x - 表示SQL ROWID值的数据的 RowId对象
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • writeSQLXML

        void writeSQLXML​(SQLXML x)
          throws SQLException
        将SQL XML值写入流。
        参数
        x - 表示SQL XML值的数据的 SQLXML对象
        异常
        SQLException -如果发生数据库访问错误， java.xml.transform.Result ， Writer或OutputStream尚未收为SQLXML对象或者如果存在一个错误处理XML值。 异常的getCause方法可能会提供更详细的异常，例如，如果流不包含有效的XML。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • writeObject

        default void writeObject​(Object x,
                         SQLType targetSqlType)
                  throws SQLException
        将包含在给定对象中的数据写入流。 在发送到流之前，该对象将转换为指定的targetSqlType。

        当object是null ，此方法将SQL NULL写入流。

        如果对象具有自定义映射（实现接口SQLData的类），则JDBC驱动程序应调用方法SQLData.writeSQL将其写入SQL数据流。 如果，在另一方面，对象是实现一类Ref ， Blob ， Clob ， NClob ， Struct ， java.net.URL ，或Array ，驾驶员应把它传递给数据库作为相应SQL类型的值。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        x - 包含输入参数值的对象
        targetSqlType - 要发送到数据库的SQL类型。
        异常
        SQLException - 如果发生数据库访问错误，或者x指定的Java对象是InputStream或Reader对象，并且scale参数的值小于零
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此数据类型
        从以下版本开始：
        1.8
        另请参见：
        JDBCType ， SQLType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.sql.SQLPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class SQLPermission
extends BasicPermission
    在启用SecurityManager的应用程序的代码的情况下， SecurityManager将检查的权限，调用DriverManager.deregisterDriver方法， DriverManager.setLogWriter方法， DriverManager.setLogStream （弃用）方法， SyncFactory.setJNDIContext方法， SyncFactory.setLogger方法， Connection.setNetworkTimeout方法或Connection.abort方法。 如果没有SQLPermission对象，这些方法会抛出一个java.lang.SecurityException作为运行时异常。

    一个SQLPermission对象包含一个名称（也称为“目标名称”），但没有动作列表; 有一个命名的权限或没有。 目标名称是权限的名称（见下文）。 命名约定遵循层次化属性命名约定。 另外，星号可能会出现在名称的末尾，遵循“。”或本身表示通配符匹配。 例如： loadLibrary.*和*表示通配符匹配，而*loadLibrary和a*b不。

    下表列出了所有可能的SQLPermission目标名称。 该表给出了许可允许的描述以及授权许可的风险的讨论。

    permission target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission setLog Setting of the logging stream This is a dangerous permission to grant. The contents of the log may contain usernames and passwords, SQL statements, and SQL data. callAbort Allows the invocation of the Connection method abort Permits an application to terminate a physical connection to a database. setSyncFactory Allows the invocation of the SyncFactory methods setJNDIContext and setLogger Permits an application to specify the JNDI context from which the SyncProvider implementations can be retrieved from and the logging object to be used by the SyncProvider implementation. setNetworkTimeout Allows the invocation of the Connection method setNetworkTimeout Permits an application to specify the maximum period a Connection or objects created from the Connection will wait for the database to reply to any one request. deregisterDriver Allows the invocation of the DriverManager method deregisterDriver Permits an application to remove a JDBC driver from the list of registered Drivers and release its resources.
    从以下版本开始：
    1.3
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLPermission​(String name)
      使用指定的名称创建一个新的 SQLPermission对象。
      SQLPermission​(String name, String actions)
      使用指定的名称创建一个新的 SQLPermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • SQLPermission

        public SQLPermission​(String name)
        创建一个新的指定名称的SQLPermission对象。 名称是SQLPermission的符号名称。
        参数
        name -此的名称 SQLPermission对象，它必须是 setLog ， callAbort ， setSyncFactory ， deregisterDriver ，或 setNetworkTimeout
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。

      • SQLPermission

        public SQLPermission​(String name,
                     String actions)
        使用指定的名称创建一个新的SQLPermission对象。 名称是SQLPermission的象征名称; 操作String当前未使用，应为null 。
        参数
        name -此的名称 SQLPermission对象，它必须是 setLog ， callAbort ， setSyncFactory ， deregisterDriver ，或 setNetworkTimeout
        actions - 应为 null
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLRecoverableException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLRecoverableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLRecoverableException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLRecoverableException
extends SQLException
    如果应用程序执行某些恢复步骤并重试整个事务，或者在分布式事务（即事务分支）的情况下，先前发生故障的操作可能会成功的子类抛出SQLException 。 至少，恢复操作必须包括关闭当前连接并获取新的连接。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLRecoverableException​()
      构造一个 SQLRecoverableException对象。
      SQLRecoverableException​(String reason)
      构造一个 SQLRecoverableException对象与给定的 reason 。
      SQLRecoverableException​(String reason, String SQLState)
      构造一个 SQLRecoverableException对象，给定的 reason和 SQLState 。
      SQLRecoverableException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLRecoverableException与给定对象 reason ， SQLState和 vendorCode 。
      SQLRecoverableException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLRecoverableException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLRecoverableException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLRecoverableException与给定对象 reason ， SQLState和 cause 。
      SQLRecoverableException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLRecoverableException对象。
      SQLRecoverableException​(Throwable cause)
      构造一个 SQLRecoverableException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLRecoverableException

        public SQLRecoverableException​()
        构造一个SQLRecoverableException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLRecoverableException

        public SQLRecoverableException​(String reason)
        构造一个SQLRecoverableException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLRecoverableException

        public SQLRecoverableException​(String reason,
                               String SQLState)
        使用给定的reason和SQLState构造一个SQLRecoverableException对象。 cause未初始化，可以通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLRecoverableException

        public SQLRecoverableException​(String reason,
                               String SQLState,
                               int vendorCode)
        构造一个SQLRecoverableException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLRecoverableException

        public SQLRecoverableException​(Throwable cause)
        构造一个SQLRecoverableException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLRecoverableException

        public SQLRecoverableException​(String reason,
                               Throwable cause)
        构造一个SQLRecoverableException对象与一个给定的reason和cause 。 SQLState被初始化为null ，供应商代码被初始化为0。
        参数
        reason - 异常的描述。
        cause - SQLException （其保存以供getCause()方法稍后检索）的根本原因; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLRecoverableException

        public SQLRecoverableException​(String reason,
                               String SQLState,
                               Throwable cause)
        构造一个SQLRecoverableException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause - 这个SQLException的基本原因（其保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLRecoverableException

        public SQLRecoverableException​(String reason,
                               String SQLState,
                               int vendorCode,
                               Throwable cause)
        构造一个 SQLRecoverableException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLSyntaxErrorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLSyntaxErrorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLNonTransientException
            • java.sql.SQLSyntaxErrorException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLSyntaxErrorException
extends SQLNonTransientException
    当SQLState类值为“ 42 ”时，或者在供应商指定的条件下，抛出SQLException的子类。 这表示正在进行的查询违反了SQL语法规则。

    请参阅您的驱动程序供应商文档， 异常可能抛出此异常的供应商指定的条件。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLSyntaxErrorException​()
      构造一个 SQLSyntaxErrorException对象。
      SQLSyntaxErrorException​(String reason)
      构造一个 SQLSyntaxErrorException对象与给定的 reason 。
      SQLSyntaxErrorException​(String reason, String SQLState)
      使用给定的 reason和 SQLState构造一个 SQLSyntaxErrorException对象。
      SQLSyntaxErrorException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState和 vendorCode 。
      SQLSyntaxErrorException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLSyntaxErrorException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState和 cause 。
      SQLSyntaxErrorException​(String reason, Throwable cause)
      构造一个 SQLSyntaxErrorException对象，给定的 reason和 cause 。
      SQLSyntaxErrorException​(Throwable cause)
      构造一个 SQLSyntaxErrorException对象与一个给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLSyntaxErrorException

        public SQLSyntaxErrorException​()
        构造一个SQLSyntaxErrorException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLSyntaxErrorException

        public SQLSyntaxErrorException​(String reason)
        构造一个SQLSyntaxErrorException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLSyntaxErrorException

        public SQLSyntaxErrorException​(String reason,
                               String SQLState)
        构造一个SQLSyntaxErrorException对象，给定的reason和SQLState 。 cause未初始化，随后可以通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLSyntaxErrorException

        public SQLSyntaxErrorException​(String reason,
                               String SQLState,
                               int vendorCode)
        构造一个SQLSyntaxErrorException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，然后可以通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLSyntaxErrorException

        public SQLSyntaxErrorException​(Throwable cause)
        构造一个SQLSyntaxErrorException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLSyntaxErrorException

        public SQLSyntaxErrorException​(String reason,
                               Throwable cause)
        构造一个SQLSyntaxErrorException对象，给定的reason和cause 。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLSyntaxErrorException

        public SQLSyntaxErrorException​(String reason,
                               String SQLState,
                               Throwable cause)
        构造一个SQLSyntaxErrorException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause - （由getCause()方法保存供以后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLSyntaxErrorException

        public SQLSyntaxErrorException​(String reason,
                               String SQLState,
                               int vendorCode,
                               Throwable cause)
        构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLTimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLTimeoutException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLTransientException
            • java.sql.SQLTimeoutException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLTimeoutException
extends SQLTransientException

    的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。

    此异常与标准SQLState不对应。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLTimeoutException​()
      构造一个 SQLTimeoutException对象。
      SQLTimeoutException​(String reason)
      构造一个 SQLTimeoutException对象与给定的 reason 。
      SQLTimeoutException​(String reason, String SQLState)
      构造一个 SQLTimeoutException对象，给定的 reason和 SQLState 。
      SQLTimeoutException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLTimeoutException对象，其中给定的 reason SQLState和 vendorCode 。
      SQLTimeoutException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLTimeoutException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLTimeoutException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLTimeoutException与给定对象 reason ， SQLState和 cause 。
      SQLTimeoutException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLTimeoutException对象。
      SQLTimeoutException​(Throwable cause)
      构造一个 SQLTimeoutException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLTimeoutException

        public SQLTimeoutException​()
        构造一个SQLTimeoutException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLTimeoutException

        public SQLTimeoutException​(String reason)
        构造一个SQLTimeoutException对象与给定的reason 。 SQLState被初始化为null ，供应商代码被初始化为0. cause未初始化，随后可以通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLTimeoutException

        public SQLTimeoutException​(String reason,
                           String SQLState)
        使用给定的reason和SQLState构造一个SQLTimeoutException对象。 cause未初始化，并可能随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLTimeoutException

        public SQLTimeoutException​(String reason,
                           String SQLState,
                           int vendorCode)
        构造一个SQLTimeoutException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLTimeoutException

        public SQLTimeoutException​(Throwable cause)
        构造一个SQLTimeoutException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTimeoutException

        public SQLTimeoutException​(String reason,
                           Throwable cause)
        构造一个SQLTimeoutException对象，给定的reason和cause 。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTimeoutException

        public SQLTimeoutException​(String reason,
                           String SQLState,
                           Throwable cause)
        构造一个SQLTimeoutException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTimeoutException

        public SQLTimeoutException​(String reason,
                           String SQLState,
                           int vendorCode,
                           Throwable cause)
        构造一个 SQLTimeoutException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause - 这个SQLException （其保存以供getCause()方法稍后检索）的根本原因; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLTransactionRollbackException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLTransactionRollbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLTransientException
            • java.sql.SQLTransactionRollbackException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLTransactionRollbackException
extends SQLTransientException
    当SQLState类值为“ 40 ”时，或者在供应商指定的条件下，抛出SQLException的子类。 这表示由于死锁或其他事务序列化故障，当前语句被数据库自动回滚。

    请咨询您的驱动程序供应商文档， 异常可能抛出此异常的供应商指定的条件。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLTransactionRollbackException​()
      构造一个 SQLTransactionRollbackException对象。
      SQLTransactionRollbackException​(String reason)
      构造一个 SQLTransactionRollbackException对象与给定的 reason 。
      SQLTransactionRollbackException​(String reason, String SQLState)
      构造一个 SQLTransactionRollbackException对象，给定的 reason和 SQLState 。
      SQLTransactionRollbackException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState和 vendorCode 。
      SQLTransactionRollbackException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLTransactionRollbackException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState和 cause 。
      SQLTransactionRollbackException​(String reason, Throwable cause)
      构造一个 SQLTransactionRollbackException对象，给定的 reason和 cause 。
      SQLTransactionRollbackException​(Throwable cause)
      构造一个 SQLTransactionRollbackException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLTransactionRollbackException

        public SQLTransactionRollbackException​()
        构造一个SQLTransactionRollbackException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLTransactionRollbackException

        public SQLTransactionRollbackException​(String reason)
        构造一个SQLTransactionRollbackException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLTransactionRollbackException

        public SQLTransactionRollbackException​(String reason,
                                       String SQLState)
        构造一个SQLTransactionRollbackException对象，给定的reason和SQLState 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLTransactionRollbackException

        public SQLTransactionRollbackException​(String reason,
                                       String SQLState,
                                       int vendorCode)
        构造一个SQLTransactionRollbackException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLTransactionRollbackException

        public SQLTransactionRollbackException​(Throwable cause)
        构造一个SQLTransactionRollbackException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTransactionRollbackException

        public SQLTransactionRollbackException​(String reason,
                                       Throwable cause)
        构造一个SQLTransactionRollbackException对象与给定的reason和cause 。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTransactionRollbackException

        public SQLTransactionRollbackException​(String reason,
                                       String SQLState,
                                       Throwable cause)
        构造一个SQLTransactionRollbackException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTransactionRollbackException

        public SQLTransactionRollbackException​(String reason,
                                       String SQLState,
                                       int vendorCode,
                                       Throwable cause)
        构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause - 这是SQLException （其保存以供getCause()方法稍后检索）的根本原因; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLTransientConnectionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLTransientConnectionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLTransientException
            • java.sql.SQLTransientConnectionException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>

    public class SQLTransientConnectionException
extends SQLTransientException
    SQLState类值为“ 08 ”的SQLException的子类，或供应商指定的条件。 这表示如果在没有任何应用程序级更改的情况下重试操作，则失败的连接操作可能会成功。

    请参阅您的驱动程序供应商文档， 异常可能抛出此异常的供应商指定的条件。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLTransientConnectionException​()
      构造一个 SQLTransientConnectionException对象。
      SQLTransientConnectionException​(String reason)
      构造一个 SQLTransientConnectionException对象与给定的 reason 。
      SQLTransientConnectionException​(String reason, String SQLState)
      构造一个 SQLTransientConnectionException对象与给定的 reason和 SQLState 。
      SQLTransientConnectionException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState和 vendorCode 。
      SQLTransientConnectionException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLTransientConnectionException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState和 cause 。
      SQLTransientConnectionException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLTransientConnectionException对象。
      SQLTransientConnectionException​(Throwable cause)
      构造一个 SQLTransientConnectionException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLTransientConnectionException

        public SQLTransientConnectionException​()
        构造一个SQLTransientConnectionException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLTransientConnectionException

        public SQLTransientConnectionException​(String reason)
        构造一个SQLTransientConnectionException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLTransientConnectionException

        public SQLTransientConnectionException​(String reason,
                                       String SQLState)
        使用给定的reason和SQLState构造一个SQLTransientConnectionException对象。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLTransientConnectionException

        public SQLTransientConnectionException​(String reason,
                                       String SQLState,
                                       int vendorCode)
        构造一个SQLTransientConnectionException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLTransientConnectionException

        public SQLTransientConnectionException​(Throwable cause)
        构造一个SQLTransientConnectionException对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTransientConnectionException

        public SQLTransientConnectionException​(String reason,
                                       Throwable cause)
        构造一个SQLTransientConnectionException对象与一个给定的reason和cause 。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 异常的描述。
        cause -底层原因SQLException （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTransientConnectionException

        public SQLTransientConnectionException​(String reason,
                                       String SQLState,
                                       Throwable cause)
        构造一个SQLTransientConnectionException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause - 这个SQLException的基本原因（其保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTransientConnectionException

        public SQLTransientConnectionException​(String reason,
                                       String SQLState,
                                       int vendorCode,
                                       Throwable cause)
        构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause - 这是SQLException （其保存以供getCause()方法稍后检索）的根本原因; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLTransientException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLTransientException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLTransientException
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>
    已知直接子类：
    SQLTimeoutException ， SQLTransactionRollbackException ， SQLTransientConnectionException

    public class SQLTransientException
extends SQLException
    SQLException的子类被抛出在以前失败的操作可能能够成功的情况下，当操作被重试而没有任何干预的应用程序级功能。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLTransientException​()
      构造一个 SQLTransientException对象。
      SQLTransientException​(String reason)
      构造一个 SQLTransientException对象与给定的 reason 。
      SQLTransientException​(String reason, String SQLState)
      使用给定的 reason和 SQLState构造一个 SQLTransientException对象。
      SQLTransientException​(String reason, String SQLState, int vendorCode)
      构造一个 SQLTransientException与给定对象 reason ， SQLState和 vendorCode 。
      SQLTransientException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLTransientException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLTransientException与给定对象 reason ， SQLState和 cause 。
      SQLTransientException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLTransientException对象。
      SQLTransientException​(Throwable cause)
      构造一个 SQLTransientException对象与给定的 cause 。

    • 方法摘要

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLTransientException

        public SQLTransientException​()
        构造一个SQLTransientException对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。
        从以下版本开始：
        1.6

      • SQLTransientException

        public SQLTransientException​(String reason)
        构造一个SQLTransientException对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        从以下版本开始：
        1.6

      • SQLTransientException

        public SQLTransientException​(String reason,
                             String SQLState)
        使用给定的reason和SQLState构造一个SQLTransientException对象。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        从以下版本开始：
        1.6

      • SQLTransientException

        public SQLTransientException​(String reason,
                             String SQLState,
                             int vendorCode)
        构造一个SQLTransientException与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        从以下版本开始：
        1.6

      • SQLTransientException

        public SQLTransientException​(Throwable cause)
        构造一个SQLTransientException对象与给定的cause 。 SQLState初始化为null ，供应商代码初始化为0. null如果为reason则初始化为cause==null或cause.toString()如果为cause!=null 。
        参数
        cause - 这个SQLException的基本原因（其保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTransientException

        public SQLTransientException​(String reason,
                             Throwable cause)
        构造一个SQLTransientException对象与给定的reason和cause 。 SQLState被初始化为null ，供应商代码被初始化为0。
        参数
        reason - 异常的描述。
        cause - 这是SQLException （其保存以供getCause()方法稍后检索）的根本原因; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTransientException

        public SQLTransientException​(String reason,
                             String SQLState,
                             Throwable cause)
        构造一个SQLTransientException与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 异常的描述。
        SQLState - 标识异常的XOPEN或SQL：2003代码
        cause - 这个SQLException （其保存以供getCause()方法稍后检索）的根本原因; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6

      • SQLTransientException

        public SQLTransientException​(String reason,
                             String SQLState,
                             int vendorCode,
                             Throwable cause)
        构造一个 SQLTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 异常的描述
        SQLState - 标识异常的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的异常代码
        cause - 这个SQLException的基本原因（保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface SQLType

  • 所有已知实现类：
    JDBCType

    public interface SQLType
    用于标识通用SQL类型（称为JDBC类型或供应商特定数据类型）的对象。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getName​()
      返回表示SQL数据类型的 SQLType名称。
      String getVendor​()
      返回支持此数据类型的供应商的名称。
      Integer getVendorTypeNumber​()
      返回数据类型的供应商特定类型编号。

    • 方法详细信息

      • getName

        String getName​()
        返回表示SQL数据类型的 SQLType名称。
        结果
        这个名字 SQLType 。

      • getVendor

        String getVendor​()
        返回支持此数据类型的供应商的名称。 返回的值通常是此供应商的包名称。
        结果
        该数据类型的供应商的名称

      • getVendorTypeNumber

        Integer getVendorTypeNumber​()
        返回数据类型的供应商特定类型编号。
        结果
        表示供应商特定数据类型的整数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLWarning (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class SQLWarning

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • java.sql.SQLWarning
  • All Implemented Interfaces:
    Serializable ， Iterable<Throwable>
    已知直接子类：
    DataTruncation

    public class SQLWarning
extends SQLException

    提供有关数据库访问警告的信息的异常。 警告被静默链接到方法导致其报告的对象。

    警告可以从被检索Connection ， Statement ，和ResultSet对象。 尝试在连接关闭之后检索警告将导致抛出异常。 类似地，尝试在关闭语句或在结果集合关闭后在语句上检索警告将导致抛出异常。 请注意，关闭语句也会关闭它可能产生的结果集。

    从以下版本开始：
    1.1
    另请参见：
    Connection.getWarnings() ，
Statement.getWarnings() ，
ResultSet.getWarnings() ，
Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SQLWarning​()
      构造一个 SQLWarning对象。
      SQLWarning​(String reason)
      使用给定的 reason构造一个 SQLWarning对象。
      SQLWarning​(String reason, String SQLState)
      使用给定的 reason和 SQLState构造一个 SQLWarning对象。
      SQLWarning​(String reason, String SQLState, int vendorCode)
      构造一个 SQLWarning与给定对象 reason ， SQLState和 vendorCode 。
      SQLWarning​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLWarning与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLWarning​(String reason, String SQLState, Throwable cause)
      构造一个 SQLWarning与给定对象 reason ， SQLState和 cause 。
      SQLWarning​(String reason, Throwable cause)
      构造一个 SQLWarning对象，给定的 reason和 cause 。
      SQLWarning​(Throwable cause)
      构造一个 SQLWarning对象与给定的 cause 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SQLWarning getNextWarning​()
      通过 setNextWarning检索此 SQLWarning对象链接的警告。
      void setNextWarning​(SQLWarning w)
      将 SQLWarning对象添加到链的末尾。

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SQLWarning

        public SQLWarning​(String reason,
                  String SQLState,
                  int vendorCode)
        构造一个SQLWarning与给定对象reason ， SQLState和vendorCode 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 警告的说明
        SQLState - 标识警告的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的警告代码

      • SQLWarning

        public SQLWarning​(String reason,
                  String SQLState)
        构造一个SQLWarning对象，给定的reason和SQLState 。 cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。 供应商代码初始化为0。
        参数
        reason - 警告的说明
        SQLState - 标识警告的XOPEN或SQL：2003代码

      • SQLWarning

        public SQLWarning​(String reason)
        构造一个SQLWarning对象与给定的reason 。 SQLState初始化为null ，供应商代码初始化为0. cause未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)方法进行初始化。
        参数
        reason - 警告的说明

      • SQLWarning

        public SQLWarning​()
        构造一个SQLWarning对象。 的reason ， SQLState被初始化为null和供应商代码被初始化为0。 cause没有初始化，随后可以通过向一个呼叫进行初始化Throwable.initCause(java.lang.Throwable)方法。

      • SQLWarning

        public SQLWarning​(Throwable cause)
        构造一个SQLWarning对象与给定的cause 。 该SQLState被初始化为null和供应商代码被初始化为0。 reason被初始化为null如果cause==null或cause.toString()如果cause!=null 。
        参数
        cause -底层原因SQLWarning （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。

      • SQLWarning

        public SQLWarning​(String reason,
                  Throwable cause)
        构造一个SQLWarning对象与给定的reason和cause 。 SQLState初始化为null ，供应商代码初始化为0。
        参数
        reason - 警告的说明
        cause -底层原因SQLWarning （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。

      • SQLWarning

        public SQLWarning​(String reason,
                  String SQLState,
                  Throwable cause)
        构造一个SQLWarning与给定对象reason ， SQLState和cause 。 供应商代码初始化为0。
        参数
        reason - 警告的说明
        SQLState - 标识警告的XOPEN或SQL：2003代码
        cause -底层原因SQLWarning （保存用于由稍后检索getCause()方法）; 可能为空，表示原因不存在或未知。

      • SQLWarning

        public SQLWarning​(String reason,
                  String SQLState,
                  int vendorCode,
                  Throwable cause)
        构造一个 SQLWarning与给定对象 reason ， SQLState ， vendorCode和 cause 。
        参数
        reason - 警告的说明
        SQLState - 标识警告的XOPEN或SQL：2003代码
        vendorCode - 数据库供应商特定的警告代码
        cause - 这个SQLWarning的基本原因（其保存以供getCause()方法稍后检索）; 可能为空，表示原因不存在或未知。

    • 方法详细信息

      • getNextWarning

        public SQLWarning getNextWarning​()
        检索由 setNextWarning链接到该 SQLWarning对象的 setNextWarning 。
        结果
        下一个SQLException在连锁店; null如果没有
        另请参见：
        setNextWarning(java.sql.SQLWarning)

      • setNextWarning

        public void setNextWarning​(SQLWarning w)
        将 SQLWarning对象添加到链的末尾。
        参数
        w - 新一轮的 SQLException链
        另请参见：
        getNextWarning()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLXML (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface SQLXML

  • public interface SQLXML
    用于SQL XML类型的JavaTM编程语言中的映射。 XML是一种内置类型，它将XML值作为列值存储在数据库表的一行中。 默认情况下，驱动程序实现SQLXML对象作为XML数据的逻辑指针，而不是数据本身。 SQLXML对象在创建事务的持续时间内是有效的。

    SQLXML接口提供了以String，Reader或Writer或Stream的形式访问XML值的方法。 XML值也可以通过源访问或设置为结果，它们与XML解析器API（如DOM，SAX和StAX）一起使用，以及XSLT转换和XPath评估。

    接口ResultSet，CallableStatement和PreparedStatement中的方法（如getSQLXML）允许程序员访问XML值。 此外，该界面还具有更新XML值的方法。

    可以使用BinaryStream获取SQLXML实例的XML值

      SQLXML sqlxml = resultSet.getSQLXML(column);
   InputStream binaryStream = sqlxml.getBinaryStream();
    例如，使用DOM解析器解析XML值：
      DocumentBuilder parser = DocumentBuilderFactory.newInstance().newDocumentBuilder();
   Document result = parser.parse(binaryStream);
    或使用SAX解析器解析XML值到您的处理程序：
      SAXParser parser = SAXParserFactory.newInstance().newSAXParser();
   parser.parse(binaryStream, myHandler);
    或使用StAX解析器解析XML值：
      XMLInputFactory factory = XMLInputFactory.newInstance();
   XMLStreamReader streamReader = factory.createXMLStreamReader(binaryStream);

    因为数据库可能会使用XML的优化表示，通过getSource（）和setResult（）访问该值可以提高处理性能，而不需要序列化到流表示和解析XML。

    例如，要获取DOM文档节点：

      DOMSource domSource = sqlxml.getSource(DOMSource.class);
   Document document = (Document) domSource.getNode();
    或将值设置为DOM文档节点到myNode：
      DOMResult domResult = sqlxml.setResult(DOMResult.class);
   domResult.setNode(myNode);
    或者，将SAX事件发送到您的处理程序：
      SAXSource saxSource = sqlxml.getSource(SAXSource.class);
   XMLReader xmlReader = saxSource.getXMLReader();
   xmlReader.setContentHandler(myHandler);
   xmlReader.parse(saxSource.getInputSource());
    或者，从SAX事件设置结果值：
      SAXResult saxResult = sqlxml.setResult(SAXResult.class);
   ContentHandler contentHandler = saxResult.getHandler();
   contentHandler.startDocument();
   // set the XML elements and attributes into the result
   contentHandler.endDocument();
    或者，要获得StAX事件：
      StAXSource staxSource = sqlxml.getSource(StAXSource.class);
   XMLStreamReader streamReader = staxSource.getXMLStreamReader();
    或者，从StAX事件设置结果值：
      StAXResult staxResult = sqlxml.setResult(StAXResult.class);
   XMLStreamWriter streamWriter = staxResult.getXMLStreamWriter();
    或者，使用xsltFile输出中的XSLT将XML值执行XSLT转换为文件resultFile：
      File xsltFile = new File("a.xslt");
   File myFile = new File("result.xml");
   Transformer xslt = TransformerFactory.newInstance().newTransformer(new StreamSource(xsltFile));
   Source source = sqlxml.getSource(null);
   Result result = new StreamResult(myFile);
   xslt.transform(source, result);
    或者，评估XML值上的XPath表达式：
      XPath xpath = XPathFactory.newInstance().newXPath();
   DOMSource domSource = sqlxml.getSource(DOMSource.class);
   Document document = (Document) domSource.getNode();
   String expression = "/foo/@bar";
   String barValue = xpath.evaluate(expression, document);
    要将XML值设置为XSLT转换的结果：
      File sourceFile = new File("source.xml");
   Transformer xslt = TransformerFactory.newInstance().newTransformer(new StreamSource(xsltFile));
   Source streamSource = new StreamSource(sourceFile);
   Result result = sqlxml.setResult(null);
   xslt.transform(streamSource, result);
    可以使用调用newTransformer（）指定的标识变换将任何源转换为Result：
      Transformer identity = TransformerFactory.newInstance().newTransformer();
   Source source = sqlxml.getSource(null);
   File myFile = new File("result.xml");
   Result result = new StreamResult(myFile);
   identity.transform(source, result);
    要将Source的内容写入标准输出：
      Transformer identity = TransformerFactory.newInstance().newTransformer();
   Source source = sqlxml.getSource(null);
   Result result = new StreamResult(System.out);
   identity.transform(source, result);
    从DOMResult创建DOMSource：
      DOMSource domSource = new DOMSource(domResult.getNode());

    不完整或无效的XML值在设置时可能导致SQLException，或者在执行execute（）时可能会发生异常。 在执行execute（）之前必须关闭所有流，否则将抛出SQLException。

    读取和写入SQLXML对象的XML值最多可以发生一次。 可读和不可读的概念状态确定读取API中的一个是否将返回值或抛出异常。 可写和不可写的概念状态确定一个写入API是否将设置值或抛出异常。

    free（）或任何读取API被调用时，状态从可读到不可读：getBinaryStream（），getCharacterStream（），getSource（）和getString（）。 当这种情况发生时，实现也可能会将状态更改为不可写。

    一旦free（）或任何一个编写的API被调用，状态从可写到不可写：setBinaryStream（），setCharacterStream（），setResult（）和setString（）。 当这种情况发生时，实现也可能会将状态更改为不可读。

    如果JDBC驱动程序支持数据类型，则必须完全实现SQLXML接口上的所有方法。

    从以下版本开始：
    1.6
    另请参见：
    javax.xml.parsers ， javax.xml.stream ， javax.xml.transform ， javax.xml.xpath

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void free​()
      此方法关闭此对象并释放其持有的资源。
      InputStream getBinaryStream​()
      检索此SQLXML实例指定的XML值作为流。
      Reader getCharacterStream​()
      将此SQLXML实例指定的XML值作为java.io.Reader对象检索。
      <T extends Source>
      T             		getSource​(Class<T> sourceClass)
      返回一个用于读取此SQLXML实例指定的XML值的源。
      String getString​()
      返回此SQLXML实例指定的XML值的字符串表示形式。
      OutputStream setBinaryStream​()
      检索可用于编写此SQLXML实例所代表的XML值的流。
      Writer setCharacterStream​()
      检索要用于写入此SQLXML实例所代表的XML值的流。
      <T extends Result>
      T             		setResult​(Class<T> resultClass)
      返回一个用于设置此SQLXML实例指定的XML值的结果。
      void setString​(String value)
      将此SQLXML实例指定的XML值设置为给定的String表示形式。

    • 方法详细信息

      • free

        void free​()
   throws SQLException
        此方法关闭此对象并释放其持有的资源。 当调用此方法时，SQL XML对象变得无效，既不可读写。 在free之后，任何调用free以外的方法的尝试free将导致抛出SQLException 。 如果free被多次调用，在后续调用free被视为无操作。
        异常
        SQLException - 如果存在释放XML值的错误。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getBinaryStream

        InputStream getBinaryStream​()
                     throws SQLException
        检索此SQLXML实例指定的XML值作为流。 输入流的字节根据XML 1.0规范的附录F进行解释。 当ResultSet的指定列具有SQLXML类型java.sql.Types时，此方法的行为与ResultSet.getBinaryStream（）相同。

        当调用此方法时，SQL XML对象变得不可读，并且根据实现可能不会写入。

        结果
        包含XML数据的流。
        异常
        SQLException - 如果处理XML值时出错。 如果状态不可读，则抛出异常。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setBinaryStream

        OutputStream setBinaryStream​()
                      throws SQLException
        检索可用于编写此SQLXML实例所代表的XML值的流。 流从位置0开始。流的字节根据XML 1.0规范的附录F进行解释当ResultSet的指定列具有类型java.sql时，此方法的行为与ResultSet.updateBinaryStream（）相同。 SQLXML的类型。

        当调用此方法时，SQL XML对象变得不可写入，并且根据实现情况也可能变得不可读取。

        结果
        可以写入数据的流。
        异常
        SQLException - 如果在处理XML值时出错。 如果状态不可写，则抛出异常。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getCharacterStream

        Reader getCharacterStream​()
                   throws SQLException
        将此SQLXML实例指定的XML值作为java.io.Reader对象检索。 此流的格式由org.xml.sax.InputSource定义，根据XML 1.0规范的第2节和附录B，流中的字符表示XML的unicode代码点。 虽然可能存在unicode以外的编码声明，但是流的编码是unicode。 当ResultSet的指定列具有SQLXML类型java.sql.Types时，此方法的行为与ResultSet.getCharacterStream（）相同。

        当调用此方法时，SQL XML对象变得不可读，并且根据实现可能不会写入。

        结果
        包含XML数据的流。
        异常
        SQLException - 如果处理XML值时出错。 异常的getCause（）方法可能会提供更详细的异常，例如，如果流不包含有效字符。 如果状态不可读，则抛出异常。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setCharacterStream

        Writer setCharacterStream​()
                   throws SQLException
        检索要用于写入此SQLXML实例所代表的XML值的流。 此流的格式由org.xml.sax.InputSource定义，根据XML 1.0规范的第2节和附录B，流中的字符表示XML的unicode代码点。 虽然可能存在unicode以外的编码声明，但是流的编码是unicode。 当ResultSet的指定列具有SQLXML类型java.sql.Types时，此方法的行为与ResultSet.updateCharacterStream（）相同。

        当调用此方法时，SQL XML对象变得不可写入，并且根据实现情况也可能变得不可读取。

        结果
        可以写入数据的流。
        异常
        SQLException - 如果处理XML值时出错。 异常的getCause（）方法可能会提供更详细的异常，例如，如果流不包含有效字符。 如果状态不可写，则抛出异常。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getString

        String getString​()
          throws SQLException
        返回此SQLXML实例指定的XML值的字符串表示形式。 此字符串的格式由org.xml.sax.InputSource定义，根据XML 1.0规范的第2节和附录B，流中的字符表示XML的unicode代码点。 虽然可能存在unicode以外的编码声明，但String的编码是unicode。 当ResultSet的指定列具有SQLXML类型java.sql.Types时，此方法的行为与ResultSet.getString（）相同。

        当调用此方法时，SQL XML对象变得不可读，并且根据实现可能不会写入。

        结果
        由此SQLXML实例指定的XML值的字符串表示形式。
        异常
        SQLException - 如果处理XML值时出错。 异常的getCause（）方法可能会提供更详细的异常，例如，如果流不包含有效字符。 如果状态不可读，则抛出异常。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setString

        void setString​(String value)
        throws SQLException
        将此SQLXML实例指定的XML值设置为给定的String表示形式。 此字符串的格式由org.xml.sax.InputSource定义，根据XML 1.0规范的第2节和附录B，流中的字符表示XML的unicode代码点。 虽然可能存在unicode以外的编码声明，但String的编码是unicode。 当ResultSet的指定列具有SQLXML类型java.sql.Types时，此方法的行为与ResultSet.updateString（）相同。

        当调用此方法时，SQL XML对象变得不可写入，并且根据实现情况也可能变得不可读取。

        参数
        value - XML值
        异常
        SQLException - 如果在处理XML值时出错。 异常的getCause（）方法可能会提供更详细的异常，例如，如果流不包含有效字符。 如果状态不可写，则抛出异常。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • getSource

        <T extends Source> T getSource​(Class<T> sourceClass)
                        throws SQLException
        返回一个用于读取此SQLXML实例指定的XML值的源。 来源用作XML解析器和XSLT变换器的输入。

        默认情况下，XML解析器的源将进行命名空间处理。 Source的systemID是依赖于实现的。

        当调用此方法时，SQL XML对象变得不可读，并且根据实现可能不会写入。

        请注意，SAX是一个回调架构，因此，返回的SAXSource应该被设置为一个内容处理程序，它将从解析中接收SAX事件。 内容处理程序将基于XML的内容接收回调。

          SAXSource saxSource = sqlxml.getSource(SAXSource.class);
   XMLReader xmlReader = saxSource.getXMLReader();
   xmlReader.setContentHandler(myHandler);
   xmlReader.parse(saxSource.getInputSource());
        参数类型
        T - 由此Class对象建模的类的类型
        参数
        sourceClass - 源的类，或null。 如果该类为null，则将返回供应商特定的Source实现。 至少支持以下类别：
          javax.xml.transform.dom.DOMSource - returns a DOMSource
   javax.xml.transform.sax.SAXSource - returns a SAXSource
   javax.xml.transform.stax.StAXSource - returns a StAXSource
   javax.xml.transform.stream.StreamSource - returns a StreamSource
        结果
        用于读取XML值的源。
        异常
        SQLException - 如果在处理XML值时出错，或者不支持此功能。 异常的getCause（）方法可能会提供更详细的异常，例如，如果发生XML解析器异常。 如果状态不可读，则抛出异常。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6

      • setResult

        <T extends Result> T setResult​(Class<T> resultClass)
                        throws SQLException
        返回一个用于设置此SQLXML实例指定的XML值的结果。

        结果的systemID依赖于实现。

        当调用此方法时，SQL XML对象变得不可写入，并且根据实现情况也可能变得不可读取。

        请注意，SAX是一个回调架构，返回的SAXResult具有分配的内容处理程序，它将基于XML的内容接收SAX事件。 使用XML文档的内容调用内容处理程序来分配值。

          SAXResult saxResult = sqlxml.setResult(SAXResult.class);
   ContentHandler contentHandler = saxResult.getXMLReader().getContentHandler();
   contentHandler.startDocument();
   // set the XML elements and attributes into the result
   contentHandler.endDocument();
        参数类型
        T - 由此Class对象建模的类的类型
        参数
        resultClass - 结果的类，或null。 如果resultClass为null，将返回一个供应商特定的Result实现。 至少支持以下类别：
          javax.xml.transform.dom.DOMResult - returns a DOMResult
   javax.xml.transform.sax.SAXResult - returns a SAXResult
   javax.xml.transform.stax.StAXResult - returns a StAXResult
   javax.xml.transform.stream.StreamResult - returns a StreamResult
        结果
        返回设置XML值的结果。
        异常
        SQLException - 如果处理XML值时出错，或者不支持此功能。 异常的getCause（）方法可能会提供更详细的异常，例如，如果发生XML解析器异常。 如果状态不可写，则抛出异常。
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Statement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Statement

  • All Superinterfaces:
    AutoCloseable ， Wrapper
    All Known Subinterfaces:
    CallableStatement ， PreparedStatement

    public interface Statement
extends Wrapper, AutoCloseable

    用于执行静态SQL语句并返回其生成的结果的对象。

    默认情况下，每个Statement对象只能有一个ResultSet对象同时打开。 因此，如果一个ResultSet对象的读取与另一个对象的读取交错，则每个对象必须由不同的Statement对象生成。 Statement接口中的所有执行方法会隐式关闭语句的当前ResultSet对象，如果存在该对象。

    从以下版本开始：
    1.1
    另请参见：
    Connection.createStatement() ， ResultSet

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CLOSE_ALL_RESULTS
      常数表示，当调用 getMoreResults时，所有已保留打开的 ResultSet对象都应关闭。
      static int CLOSE_CURRENT_RESULT
      该常量表示当调用 getMoreResults时，应关闭当前的 ResultSet对象。
      static int EXECUTE_FAILED
      指示执行批处理语句时发生错误的常量。
      static int KEEP_CURRENT_RESULT
      该常量表示当调用 getMoreResults时不应关闭当前的 ResultSet对象。
      static int NO_GENERATED_KEYS
      常数表示生成的密钥不应该可用于检索。
      static int RETURN_GENERATED_KEYS
      常数表示生成的密钥应该可用于检索。
      static int SUCCESS_NO_INFO
      指示批处理语句执行成功但不影响其行数的常量可用的常量。

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void addBatch​(String sql)
      将给定的SQL命令添加到此 Statement对象的当前命令列表中。
      void cancel​()
      如果DBMS和驱动程序都支持中止SQL语句，则取消此 Statement对象。
      void clearBatch​()
      清空这个 Statement对象当前的SQL命令列表。
      void clearWarnings​()
      清除所有在这个 Statement对象上报告的警告。
      void close​()
      立即释放此 Statement对象的数据库和JDBC资源，而不是等待它自动关闭时发生。
      void closeOnCompletion​()
      指定当其所有相关结果集都关闭时，此 Statement将关闭。
      default String enquoteIdentifier​(String identifier, boolean alwaysQuote)
      返回一个SQL标识符。
      default String enquoteLiteral​(String val)
      返回一个包含在单引号中的 String 。
      default String enquoteNCharLiteral​(String val)
      返回一个 String表示一个用单引号括起来的前缀为大写字母N的国家字符集文字。
      boolean execute​(String sql)
      执行给定的SQL语句，这可能会返回多个结果。
      boolean execute​(String sql, int autoGeneratedKeys)
      执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出任何自动生成的密钥应该可用于检索。
      boolean execute​(String sql, int[] columnIndexes)
      执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      boolean execute​(String sql, String[] columnNames)
      执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      int[] executeBatch​()
      将一批命令提交到数据库以执行，并且所有命令都执行成功，返回一个更新计数的数组。
      default long[] executeLargeBatch​()
      将一批命令提交到数据库以执行，并且所有命令都执行成功，返回一个更新计数的数组。
      default long executeLargeUpdate​(String sql)
      执行给定的SQL语句，这可能是 INSERT ， UPDATE ，或 DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。
      default long executeLargeUpdate​(String sql, int autoGeneratedKeys)
      执行给定的SQL语句，并用给定的标志来向驱动程序发出信号，指出这个 Statement对象生成的自动生成的密钥是否应该可用于检索。
      default long executeLargeUpdate​(String sql, int[] columnIndexes)
      执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      default long executeLargeUpdate​(String sql, String[] columnNames)
      执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      ResultSet executeQuery​(String sql)
      执行给定的SQL语句，返回一个 ResultSet对象。
      int executeUpdate​(String sql)
      执行给定的SQL语句，这可能是 INSERT ， UPDATE ，或 DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。
      int executeUpdate​(String sql, int autoGeneratedKeys)
      执行给定的SQL语句，并用给定的标志来向驱动程序发出信号，指出这个 Statement对象产生的自动生成的密钥是否应该可用于检索。
      int executeUpdate​(String sql, int[] columnIndexes)
      执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      int executeUpdate​(String sql, String[] columnNames)
      执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      Connection getConnection​()
      检索 Connection生成此对象 Statement对象。
      int getFetchDirection​()
      检索从数据库表中获取行的方向，这是从此 Statement对象生成的结果集的默认值。
      int getFetchSize​()
      检索结果集合的行数是默认为获取大小 ResultSet从该生成的对象 Statement对象。
      ResultSet getGeneratedKeys​()
      检索作为执行此 Statement对象的结果创建的任何自动生成的密钥。
      default long getLargeMaxRows​()
      检索一个的最大行数 ResultSet由此产生对象 Statement对象可以包含。
      default long getLargeUpdateCount​()
      将当前结果作为更新计数检索; 如果结果是一个ResultSet对象或没有更多结果，则返回-1。
      int getMaxFieldSize​()
      检索可以在被返回字符和二进制列值的最大字节数 ResultSet由此产生对象 Statement对象。
      int getMaxRows​()
      检索一个的最大行数 ResultSet由此产生对象 Statement对象可以包含。
      boolean getMoreResults​()
      移动到此 Statement对象的下一个结果，如果它是一个 ResultSet对象，则返回 true ，并隐式关闭使用方法 getResultSet获取的任何当前的 ResultSet对象。
      boolean getMoreResults​(int current)
      移动到此 Statement对象的下一个结果，根据给定标志指定的指令处理任何当前的 ResultSet对象，如果下一个结果是一个 ResultSet对象，则返回 true 。
      int getQueryTimeout​()
      检索驱动程序等待执行 Statement对象的 Statement 。
      ResultSet getResultSet​()
      以 ResultSet对象获取当前结果。
      int getResultSetConcurrency​()
      检索由 ResultSet对象生成的 Statement对象的结果集并发。
      int getResultSetHoldability​()
      检索 ResultSet对象生成的对象的结果集 Statement 。
      int getResultSetType​()
      检索 ResultSet对象生成的 Statement对象的结果集类型。
      int getUpdateCount​()
      将当前结果作为更新计数检索; 如果结果是一个ResultSet对象或没有更多结果，则返回-1。
      SQLWarning getWarnings​()
      检索通过此 Statement对象的呼叫报告的第一个警告。
      boolean isClosed​()
      检索此 Statement对象是否已关闭。
      boolean isCloseOnCompletion​()
      返回一个值，指示当其所有相关结果集都关闭时，此 Statement是否关闭。
      boolean isPoolable​()
      返回一个值，指示 Statement是否可 Statement 。
      default boolean isSimpleIdentifier​(String identifier)
      检索 identifier是否是一个简单的SQL标识符。
      void setCursorName​(String name)
      将SQL游标名称设置为给定的 String ，这将由后续的 Statement对象 execute方法使用。
      void setEscapeProcessing​(boolean enable)
      设置逃脱处理打开或关闭。
      void setFetchDirection​(int direction)
      给出驱动程序一个关于使用这个 Statement对象创建的 ResultSet对象中处理行的方向的提示。
      void setFetchSize​(int rows)
      给JDBC驱动程序提供一个关于应该从数据库中获取的行数，提供 ResultSet由 Statement生成的对象的更多行。
      default void setLargeMaxRows​(long max)
      设置的任何行的最大数目的极限 ResultSet由此生成的对象 Statement对象可以包含给定数目。
      void setMaxFieldSize​(int max)
      设置由 ResultSet对象产生的 Statement对象中的字符和二进制列值可以返回的最大字节数限制。
      void setMaxRows​(int max)
      设置的任何行的最大数目的极限 ResultSet由此生成的对象 Statement对象可以包含给定数目。
      void setPoolable​(boolean poolable)
      请求汇集或不汇集 Statement 。
      void setQueryTimeout​(int seconds)
      设置驱动程序等待 Statement对象执行到给定秒数的秒数。

      • Methods inherited from interface java.sql.Wrapper

        isWrapperFor, unwrap

    • 字段详细信息

      • CLOSE_CURRENT_RESULT

        static final int CLOSE_CURRENT_RESULT
        常量表示当调用 getMoreResults时，当前的 ResultSet对象应关闭。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • KEEP_CURRENT_RESULT

        static final int KEEP_CURRENT_RESULT
        该常量表示当调用 getMoreResults时不应关闭当前的 ResultSet对象。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • CLOSE_ALL_RESULTS

        static final int CLOSE_ALL_RESULTS
        该常量指示所有 ResultSet以前已经保持开放对象应该调用时关闭 getMoreResults 。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • SUCCESS_NO_INFO

        static final int SUCCESS_NO_INFO
        指示批处理语句执行成功但不影响其行数的常量可用的常量。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • EXECUTE_FAILED

        static final int EXECUTE_FAILED
        指示执行批处理语句时发生错误的常量。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • RETURN_GENERATED_KEYS

        static final int RETURN_GENERATED_KEYS
        常数表示生成的密钥应该可用于检索。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • NO_GENERATED_KEYS

        static final int NO_GENERATED_KEYS
        常数表示生成的密钥不应该可用于检索。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

    • 方法详细信息

      • executeQuery

        ResultSet executeQuery​(String sql)
                throws SQLException
        执行给定的SQL语句，返回一个ResultSet对象。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        参数
        sql - 要发送到数据库的SQL语句，通常为静态SQL SELECT语句
        结果
        一个ResultSet对象，其中包含由给定查询生成的数据; 从不null
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，给定的SQL语句产生除单个 ResultSet对象之外的任何内容，该方法在 PreparedStatement或 CallableStatement
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement

      • executeUpdate

        int executeUpdate​(String sql)
           throws SQLException
        执行给定的SQL语句，这可能是INSERT ， UPDATE ，或DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        参数
        sql -一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
        结果
        （1）SQL数据操作语言（DML）语句的行计数或（2）0不返回的SQL语句
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，给定的SQL语句生成一个 ResultSet对象，该方法在 PreparedStatement或 CallableStatement
        SQLTimeoutException - 当驱动程序确定已超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement

      • close

        void close​()
    throws SQLException
        立即释放此Statement对象的数据库和JDBC资源，而不是等待其自动关闭时发生。 一旦你完成它们，一般来说，尽快释放资源，以避免捆绑数据库资源。

        在已关闭的Statement对象上调用方法close不起作用。

        注意：当一个Statement对象关闭时，其当前的ResultSet对象（如果存在）也被关闭。

        Specified by:
        close在接口 AutoCloseable
        异常
        SQLException - 如果发生数据库访问错误

      • getMaxFieldSize

        int getMaxFieldSize​()
             throws SQLException
        检索可以在被返回字符和二进制列值的最大字节数ResultSet由此产生对象Statement对象。 此限制仅适用于BINARY ， VARBINARY ， LONGVARBINARY ， CHAR ， VARCHAR ， NCHAR ， NVARCHAR ， LONGNVARCHAR个LONGVARCHAR列。 如果超出限制，则会忽略多余的数据。
        结果
        存储字符和二进制值的列的当前列大小限制; 零意味着没有限制
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement调用此方法 Statement
        另请参见：
        setMaxFieldSize(int)

      • setMaxFieldSize

        void setMaxFieldSize​(int max)
              throws SQLException
        设置由ResultSet对象生成的Statement对象中的字符和二进制列值可以返回的最大字节数的限制。 此限制仅适用于BINARY ， VARBINARY ， LONGVARBINARY ， CHAR ， VARCHAR ， NCHAR ， NVARCHAR ， LONGNVARCHAR个LONGVARCHAR领域。 如果超出限制，则会忽略多余的数据。 为了最大可移植性，请使用大于256的值。
        参数
        max - 以字节为单位的新列大小限制; 零意味着没有限制
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement或条件 max >= 0不满足
        另请参见：
        getMaxFieldSize()

      • getMaxRows

        int getMaxRows​()
        throws SQLException
        检索一个的最大行数ResultSet由此产生对象Statement对象可以包含。 如果超出此限制，多余的行将被静默地删除。
        结果
        行了的当前最大数目ResultSet由此产生对象Statement对象; 零意味着没有限制
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 Statement调用此方法 Statement
        另请参见：
        setMaxRows(int)

      • setMaxRows

        void setMaxRows​(int max)
         throws SQLException
        设置的任何行的最大数目的极限ResultSet由此生成的对象Statement对象可以包含给定数目。 如果超出限制，则多余的行将被静默地丢弃。
        参数
        max - 新的最大行限制; 零意味着没有限制
        异常
        SQLException - 如果发生数据库访问错误，此方法将在封闭的 Statement上 Statement或条件 max >= 0不满足
        另请参见：
        getMaxRows()

      • setEscapeProcessing

        void setEscapeProcessing​(boolean enable)
                  throws SQLException
        设置逃脱处理打开或关闭。 如果启用了远程扫描（默认值），驱动程序将在将SQL语句发送到数据库之前进行转义替换。

        Connection和DataSource属性escapeProcessing可用于更改默认的转义处理行为。 值为true（默认值）启用对所有Statement对象的转义处理。 false值将禁用所有Statement对象的转义处理。 setEscapeProcessing方法可用于指定个人Statement对象的转义处理行为。

        注意：由于准备好的语句通常在进行此呼叫之前已被解析，所以禁用PreparedStatements对象的转义处理将不起作用。

        参数
        enable - true以实现逃脱处理; false禁用它
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 Statement调用此方法 Statement

      • getQueryTimeout

        int getQueryTimeout​()
             throws SQLException
        检索驱动程序等待Statement对象执行的Statement 。 如果超出限制，则抛出SQLException 。
        结果
        当前查询超时限制（以秒为单位） 零意味着没有限制
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement调用此方法 Statement
        另请参见：
        setQueryTimeout(int)

      • setQueryTimeout

        void setQueryTimeout​(int seconds)
              throws SQLException
        设置驱动程序等待Statement对象执行到给定秒数的秒数。 默认情况下，运行语句完成时间允许的时间没有限制。 如果超出限制，则抛出SQLTimeoutException 。 JDBC驱动程序必须将此限制到execute ， executeQuery和executeUpdate方法。

        注意： JDBC驱动程序实现也可以将此限制应用于ResultSet方法（有关详细信息，请参阅驱动程序供应商文档）。

        注意：在的情况下Statement配料，它被执行定义为超时是否被施加到经由所添加的单个SQL命令addBatch方法或通过调用SQL命令的整批executeBatch方法（请与驱动程序供应商的文档详情）。

        参数
        seconds - 新的查询超时限制（以秒为单位） 零意味着没有限制
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement或条件 seconds >= 0不满足
        另请参见：
        getQueryTimeout()

      • cancel

        void cancel​()
     throws SQLException
        如果DBMS和驱动程序都支持中止SQL语句，则取消此Statement对象。 一个线程可以使用此方法来取消正在由另一个线程执行的语句。
        异常
        SQLException - 如果发生数据库访问错误或在封闭的 Statement上调用此方法
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法

      • getWarnings

        SQLWarning getWarnings​()
                throws SQLException
        检索该Statement对象上的呼叫报告的第一个警告。 随后Statement对象警告将链接到此SQLWarning对象。

        每次执行语句时，警告链都会自动清除。 该方法可能不会在封闭的Statement对象上调用; 这样做会造成一个SQLException被抛出。

        注意：如果你正在处理ResultSet对象关联的任何警告，在读ResultSet对象将在其上，而不是在链接Statement产生它的对象。

        结果
        第一个 SQLWarning对象或 null如果没有警告
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement上调用此方法

      • clearWarnings

        void clearWarnings​()
            throws SQLException
        清除此Statement对象上报告的所有警告。 调用此方法后，方法getWarnings将返回null直到此Statement对象报告新的警告。
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 Statement调用此方法 Statement

      • setCursorName

        void setCursorName​(String name)
            throws SQLException
        将SQL游标名称设置为给定的String ，这将由后续的Statement对象execute方法使用。 然后可以将此名称用于SQL定位的更新或删除语句，以标识此语句生成的ResultSet对象中的当前行。 如果数据库不支持定位更新/删除，则此方法是noop。 为了确保光标具有适当的隔离级别以支持更新，游标的SELECT语句应具有表单SELECT FOR UPDATE 。 如果不存在FOR UPDATE ，定位更新可能会失败。

        注意：根据定义，位置更新和删除的执行必须由不同来完成Statement比生成的所述一个对象ResultSet被用于定位对象。 此外，游标名称在连接中必须是唯一的。

        参数
        name - 新的游标名称，在连接中必须是唯一的
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement调用此方法 Statement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法

      • execute

        boolean execute​(String sql)
         throws SQLException
        执行给定的SQL语句，这可能会返回多个结果。 在某些（不常见）情况下，单个SQL语句可能会返回多个结果集和/或更新计数。 通常你可以忽略这一点，除非你是（1）执行你知道可能返回多个结果的存储过程，或者（2）你正在动态地执行一个未知的SQL字符串。

        execute方法执行SQL语句并指示第一个结果的形式。 那么您必须使用方法getResultSet或getUpdateCount来检索结果，并且getMoreResults移动到任何后续的结果。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        参数
        sql - 任何SQL语句
        结果
        true如果第一个结果是一个ResultSet对象; false如果是更新计数或没有结果
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，该方法在 PreparedStatement或 CallableStatement
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        另请参见：
        getResultSet() ，
getUpdateCount() ，
getMoreResults()

      • getResultSet

        ResultSet getResultSet​()
                throws SQLException
        以ResultSet对象的形式获取当前结果。 每个结果应该只调用一次这个方法。
        结果
        当前结果为 ResultSet对象或 null如果结果是更新计数或没有更多的结果
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement调用此方法 Statement
        另请参见：
        execute(java.lang.String)

      • getUpdateCount

        int getUpdateCount​()
            throws SQLException
        将当前结果作为更新计数检索; 如果结果是一个ResultSet对象或没有更多结果，则返回-1。 每个结果应该只调用一次这个方法。
        结果
        当前结果作为更新计数; -1如果当前结果是一个ResultSet对象或没有更多的结果
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement调用此方法 Statement
        另请参见：
        execute(java.lang.String)

      • getMoreResults

        boolean getMoreResults​()
                throws SQLException
        移动到此Statement对象的下一个结果，如果它是一个ResultSet对象，则返回true ，并隐式关闭使用方法getResultSet获取的任何当前的ResultSet对象。

        以下是没有更多的结果：

           // stmt is a Statement object ((stmt.getMoreResults() == false) && (stmt.getUpdateCount() == -1))
        结果
        true如果下一个结果是一个ResultSet对象; false如果是更新计数或没有更多的结果
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement调用此方法 Statement
        另请参见：
        execute(java.lang.String)

      • setFetchDirection

        void setFetchDirection​(int direction)
                throws SQLException
        给司机的提示，在哪些行中的处理方向ResultSet使用该创建的对象Statement对象。 默认值为ResultSet.FETCH_FORWARD 。

        请注意，此方法设置由此Statement对象生成的结果集的默认提取方向。 每个结果集都有自己的获取和设置自己的提取方向的方法。

        参数
        direction - 处理行的初始方向
        异常
        SQLException -如果发生数据库访问错误，该方法被称为在关闭 Statement或者给定方向不是之一 ResultSet.FETCH_FORWARD ， ResultSet.FETCH_REVERSE ，或 ResultSet.FETCH_UNKNOWN
        从以下版本开始：
        1.2
        另请参见：
        getFetchDirection()

      • getFetchDirection

        int getFetchDirection​()
               throws SQLException
        检索从数据库表中获取行的方向，这是从此Statement对象生成的结果集的默认值。 如果此Statement对象尚未通过调用方法setFetchDirection设置获取方向，则返回值是实现特定的。
        结果
        从此 Statement对象生成的结果集的默认提取方向
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 Statement调用此方法 Statement
        从以下版本开始：
        1.2
        另请参见：
        setFetchDirection(int)

      • setFetchSize

        void setFetchSize​(int rows)
           throws SQLException
        给JDBC驱动程序一个提示，当ResultSet生成的ResultSet对象需要更多行时，应该从数据库中提取的行Statement 。 如果指定的值为零，则提示将被忽略。 默认值为零。
        参数
        rows - 要获取的行数
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement或条件 rows >= 0不被满足。
        从以下版本开始：
        1.2
        另请参见：
        getFetchSize()

      • getFetchSize

        int getFetchSize​()
          throws SQLException
        检索结果集合的行数是默认为获取大小ResultSet从该生成的对象Statement对象。 如果此Statement对象尚未通过调用方法setFetchSize设置获取大小，则返回值是实现特定的。
        结果
        从此 Statement对象生成的结果集的默认提取大小
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement上调用此方法
        从以下版本开始：
        1.2
        另请参见：
        setFetchSize(int)

      • getResultSetConcurrency

        int getResultSetConcurrency​()
                     throws SQLException
        检索由此 ResultSet对象生成的 Statement对象的结果集并发。
        结果
        ResultSet.CONCUR_READ_ONLY或 ResultSet.CONCUR_UPDATABLE
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 Statement调用此方法 Statement
        从以下版本开始：
        1.2

      • getResultSetType

        int getResultSetType​()
              throws SQLException
        检索由此 ResultSet对象生成的 Statement对象的结果集类型。
        结果
        之一 ResultSet.TYPE_FORWARD_ONLY ， ResultSet.TYPE_SCROLL_INSENSITIVE ，或 ResultSet.TYPE_SCROLL_SENSITIVE
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement上调用此方法
        从以下版本开始：
        1.2

      • addBatch

        void addBatch​(String sql)
       throws SQLException
        将给定的SQL命令添加到此Statement对象的当前命令列表中。 该列表中的命令可以通过调用方法executeBatch作为批处理执行。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        参数
        sql - 通常这是一个SQL INSERT或 UPDATE语句
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，驱动程序不支持批量更新，该方法在 PreparedStatement或 CallableStatement
        从以下版本开始：
        1.2
        另请参见：
        executeBatch() ， DatabaseMetaData.supportsBatchUpdates()

      • clearBatch

        void clearBatch​()
         throws SQLException
        清空此 Statement对象的当前SQL命令列表。
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement或驱动程序不支持批量更新
        从以下版本开始：
        1.2
        另请参见：
        addBatch(java.lang.String) ， DatabaseMetaData.supportsBatchUpdates()

      • executeBatch

        int[] executeBatch​()
            throws SQLException
        将一批命令提交到数据库以执行，并且所有命令都执行成功，返回一个更新计数的数组。 返回的阵列的int元素被排序以对应于批次中的命令，这些命令根据它们添加到批处理的顺序进行排序。 由方法executeBatch返回的数组中的元素可以是以下之一：
        1. 大于或等于零的数字表示该命令已成功处理，并且是一个更新计数，表示数据库中受命令执行影响的行数
        2. 值为SUCCESS_NO_INFO - 表示该命令已成功处理，但受影响的行数未知

          如果批量更新中的其中一个命令无法正常执行，则此方法将抛出一个BatchUpdateException ，并且JDBC驱动程序可能会继续处理或不继续处理批处理中的剩余命令。 但是，驱动程序的行为必须与特定的DBMS保持一致，或者始终继续处理命令或者从不继续处理命令。 如果驱动程序在故障后继续处理，方法BatchUpdateException.getUpdateCounts返回的数组将包含与批处理中的命令一样多的元素，并且至少有一个元素将如下所示：

        3. 值为EXECUTE_FAILED - 表示命令无法成功执行，并且仅在驱动程序在命令失败后继续处理命令时才会发生

        可能的实现和返回值已在Java 2 SDK，Standard Edition，版本1.3中进行了修改，以适应在抛出BatchUpdateException对象后，批量更新中继续处理命令的选项。

        结果
        一组更新计数，包含批处理中每个命令的一个元素。 数组的元素根据命令添加到批处理的顺序进行排序。
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的Statement上调用，或者驱动程序不支持批处理语句。 抛出BatchUpdateException （的一个子类SQLException ）如果发送到数据库的命令之一无法正确执行或者尝试返回的结果集。
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.2
        另请参见：
        addBatch(java.lang.String) ， DatabaseMetaData.supportsBatchUpdates()

      • getConnection

        Connection getConnection​()
                  throws SQLException
        检索 Connection生成此对象 Statement对象。
        结果
        产生此语句的连接
        异常
        SQLException - 如果发生数据库访问错误或在关闭的 Statement上调用此方法
        从以下版本开始：
        1.2

      • getMoreResults

        boolean getMoreResults​(int current)
                throws SQLException
        移动到这个Statement对象的下一个结果，根据给定标志指定的指令处理任何当前的ResultSet对象，如果下一个结果是一个ResultSet对象，则返回true 。

        以下是没有更多的结果：

           // stmt is a Statement object ((stmt.getMoreResults(current) == false) && (stmt.getUpdateCount() == -1))
        参数
        current -下列之一的 Statement常数指示应该发生什么样的当前 ResultSet获取的对象使用该方法 getResultSet ： Statement.CLOSE_CURRENT_RESULT ， Statement.KEEP_CURRENT_RESULT ，或 Statement.CLOSE_ALL_RESULTS
        结果
        true如果下一个结果是一个ResultSet对象; false如果它是更新计数或没有更多的结果
        异常
        SQLException -如果发生数据库访问错误，该方法被称为在关闭 Statement或提供的参数不是以下之一： Statement.CLOSE_CURRENT_RESULT ， Statement.KEEP_CURRENT_RESULT或 Statement.CLOSE_ALL_RESULTS
        SQLFeatureNotSupportedException -如果 DatabaseMetaData.supportsMultipleOpenResults返回 false ，要么 Statement.KEEP_CURRENT_RESULT或 Statement.CLOSE_ALL_RESULTS被作为参数提供。
        从以下版本开始：
        1.4
        另请参见：
        execute(java.lang.String)

      • getGeneratedKeys

        ResultSet getGeneratedKeys​()
                    throws SQLException
        检索由于执行此Statement对象而创建的任何自动生成的密钥。 如果此Statement对象未生成任何键，则返回一个空的ResultSet对象。

        注意：如果未指定表示自动生成的键的列，则JDBC驱动程序实现将确定最能代表自动生成的键的列。

        结果
        一个 ResultSet包含由该的执行而生成的自动生成的密钥（或多个）对象 Statement对象
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 Statement调用此方法 Statement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.4

      • executeUpdate

        int executeUpdate​(String sql,
                  int autoGeneratedKeys)
           throws SQLException
        执行给定的SQL语句，并用给定的标志来向驱动程序发出信号，说明该Statement对象产生的自动生成的密钥是否应该可用于检索。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该标志。

        注意：无法在PreparedStatement或CallableStatement上调用此方法。

        参数
        sql -一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
        autoGeneratedKeys - 表示是否应自动生成的密钥可用于检索的标志; 以下常数之一： Statement.RETURN_GENERATED_KEYS Statement.NO_GENERATED_KEYS
        结果
        （1）SQL数据操作语言（DML）语句的行计数或（2）0不返回的SQL语句
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，给定的SQL语句返回一个 ResultSet对象，给定的常量不是允许的一个，该方法在 PreparedStatement或 CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法与Statement.RETURN_GENERATED_KEYS的常量
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.4

      • executeUpdate

        int executeUpdate​(String sql,
                  int[] columnIndexes)
           throws SQLException
        执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。 该数组包含目标表中包含应该可用的自动生成的键的列的索引。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该数组。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        参数
        sql -一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
        columnIndexes - 一列列索引数组，指示应该从插入的行返回的列
        结果
        （1）SQL数据操作语言（DML）语句的行计数或（2）0不返回的SQL语句
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，SQL语句返回一个 ResultSet对象，提供给此方法的第二个参数不是一个 int数组，其元素是有效的列索引，该方法被调用一个 PreparedStatement或 CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.4

      • executeUpdate

        int executeUpdate​(String sql,
                  String[] columnNames)
           throws SQLException
        执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。 该数组包含目标表中包含应该可用的自动生成的键的列的名称。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该数组。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        参数
        sql -一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
        columnNames - 应该从插入的行返回的列的名称数组
        结果
        无论是行数 INSERT ， UPDATE ，或 DELETE语句，或者为0，SQL语句不返回任何内容
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，SQL语句返回一个 ResultSet对象，提供给此方法的第二个参数不是其元素为有效列名的 String数组，该方法被调用一个 PreparedStatement或 CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.4

      • execute

        boolean execute​(String sql,
                int autoGeneratedKeys)
         throws SQLException
        执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出任何自动生成的密钥应该可用于检索。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略此信号。

        在某些（不常见）情况下，单个SQL语句可能会返回多个结果集和/或更新计数。 通常你可以忽略这一点，除非你是（1）执行你知道可能返回多个结果的存储过程，或者（2）你正在动态地执行一个未知的SQL字符串。

        execute方法执行SQL语句并指示第一个结果的形式。 然后，您必须使用方法getResultSet或getUpdateCount来检索结果，然后getMoreResults移动到任何后续结果。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        参数
        sql - 任何SQL语句
        autoGeneratedKeys - 表示使用方法getGeneratedKeys是否应使自动生成的密钥可用于检索的getGeneratedKeys ; 以下常数之一： Statement.RETURN_GENERATED_KEYS或Statement.NO_GENERATED_KEYS
        结果
        true如果第一个结果是一个ResultSet对象; false如果是更新计数或没有结果
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上调用，此方法提供的第二个参数不是 Statement.RETURN_GENERATED_KEYS或 Statement.NO_GENERATED_KEYS ，该方法在 PreparedStatement或 CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法与常量Statement.RETURN_GENERATED_KEYS
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.4
        另请参见：
        getResultSet() ，
getUpdateCount() ，
getMoreResults() ，
getGeneratedKeys()

      • execute

        boolean execute​(String sql,
                int[] columnIndexes)
         throws SQLException
        执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。 该数组包含目标表中包含应该可用的自动生成的键的列的索引。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该数组。

        在某些（不常见）情况下，单个SQL语句可能会返回多个结果集和/或更新计数。 通常你可以忽略这一点，除非你是（1）执行你知道可能返回多个结果的存储过程，或者（2）你正在动态地执行一个未知的SQL字符串。

        execute方法执行SQL语句并指示第一个结果的形式。 然后，您必须使用方法getResultSet或getUpdateCount来检索结果，然后getMoreResults移动到任何后续结果。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        参数
        sql - 任何SQL语句
        columnIndexes - 插入行中列的索引数组，应该可用于通过调用方法进行检索 getGeneratedKeys
        结果
        true如果第一个结果是一个ResultSet对象; false如果是更新计数或没有结果
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，传递给此方法的 int数组中的元素不是有效的列索引，该方法在 PreparedStatement或 CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.4
        另请参见：
        getResultSet() ，
getUpdateCount() ，
getMoreResults()

      • execute

        boolean execute​(String sql,
                String[] columnNames)
         throws SQLException
        执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。 该数组包含目标表中包含应该可用的自动生成的键的列的名称。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该数组。

        在某些（不常见）情况下，单个SQL语句可能会返回多个结果集和/或更新计数。 通常你可以忽略这一点，除非你是（1）执行你知道可能返回多个结果的存储过程，或者（2）你正在动态地执行一个未知的SQL字符串。

        execute方法执行SQL语句并指示第一个结果的形式。 然后，您必须使用方法getResultSet或getUpdateCount来检索结果，然后getMoreResults移动到任何后续结果。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        参数
        sql - 任何SQL语句
        columnNames - 插入行中列的名称数组，应该可以通过调用方法进行检索 getGeneratedKeys
        结果
        true如果下一个结果是一个ResultSet对象; false如果它是更新计数或没有更多的结果
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，传递给此方法的 String数组的元素不是有效的列名，该方法在 PreparedStatement或 CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.4
        另请参见：
        getResultSet() ，
getUpdateCount() ，
getMoreResults() ，
getGeneratedKeys()

      • getResultSetHoldability

        int getResultSetHoldability​()
                     throws SQLException
        检索由此 ResultSet对象生成的 Statement对象的结果集 Statement 。
        结果
        ResultSet.HOLD_CURSORS_OVER_COMMIT或 ResultSet.CLOSE_CURSORS_AT_COMMIT
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 Statement调用此方法 Statement
        从以下版本开始：
        1.4

      • isClosed

        boolean isClosed​()
          throws SQLException
        检索此Statement对象是否已关闭。 如果方法关闭已被调用或自动关闭，则关闭Statement 。
        结果
        如果这个Statement对象被关闭， Statement true; 如果它仍然开放，则为false
        异常
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        1.6

      • setPoolable

        void setPoolable​(boolean poolable)
          throws SQLException
        要求汇集或不汇集Statement 。 指定的值是对语句池实现的一个提示，指示应用程序是否希望汇总语句。 语句池管理器是否使用提示。

        语句的可池值适用于由驱动程序实现的内部语句高速缓存和应用程序服务器和其他应用程序实现的外部语句高速缓存。

        默认情况下， Statement在创建时不可Statement ，并且在创建时可以PreparedStatement和CallableStatement 。

        参数
        poolable - 请求将该语句合并，如果为true，并且该语句未被汇总（如果为false）
        异常
        SQLException - 如果此方法在关闭的 Statement
        从以下版本开始：
        1.6

      • isPoolable

        boolean isPoolable​()
            throws SQLException
        返回一个值，指示 Statement是否可 Statement 。
        结果
        true如果Statement是可Statement的; false否则
        异常
        SQLException - 如果这个方法在关闭的 Statement
        从以下版本开始：
        1.6
        另请参见：
        setPoolable(boolean)

      • closeOnCompletion

        void closeOnCompletion​()
                throws SQLException
        指定当其所有相关结果集都关闭时，此Statement将关闭。 如果执行Statement不生成任何结果集，则此方法无效。

        注意：多次呼叫closeOnCompletion不要切换对这个Statement的影响。 但是，调用closeOnCompletion确实会影响后续的语句执行，以及当前具有开放依赖结果集的语句。

        异常
        SQLException - 如果此方法在关闭的 Statement
        从以下版本开始：
        1.7

      • isCloseOnCompletion

        boolean isCloseOnCompletion​()
                     throws SQLException
        返回一个值，指示当其所有相关结果集都关闭时，此 Statement是否关闭。
        结果
        true如果Statement在其所有相关结果集都关闭时将关闭; false否则
        异常
        SQLException - 如果此方法在关闭的 Statement
        从以下版本开始：
        1.7

      • getLargeUpdateCount

        default long getLargeUpdateCount​()
                          throws SQLException
        将当前结果作为更新计数检索; 如果结果是一个ResultSet对象或没有更多结果，则返回-1。 每个结果应该只调用一次这个方法。

        当返回的行数可能超过Integer.MAX_VALUE时，应使用此方法。

        默认实现将抛出UnsupportedOperationException

        结果
        当前结果作为更新计数; -1如果当前结果是一个ResultSet对象或没有更多的结果
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 Statement调用此方法 Statement
        从以下版本开始：
        1.8
        另请参见：
        execute(java.lang.String)

      • setLargeMaxRows

        default void setLargeMaxRows​(long max)
                      throws SQLException
        设置由此ResultSet对象生成的Statement对象可以包含给给定数量的最大行数的限制。 如果超出限制，则多余的行将被静默地丢弃。

        当行限可能超过Integer.MAX_VALUE时，应使用此方法。

        默认实现将抛出UnsupportedOperationException

        参数
        max - 新的最大行限制; 零意味着没有限制
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement或条件 max >= 0不满足
        从以下版本开始：
        1.8
        另请参见：
        getMaxRows()

      • getLargeMaxRows

        default long getLargeMaxRows​()
                      throws SQLException
        检索一个的最大行数ResultSet由此产生对象Statement对象可以包含。 如果超出此限制，多余的行将被静默地删除。

        当返回行限制可能超过Integer.MAX_VALUE时，应使用此方法。

        默认实现将返回0

        结果
        行了的当前最大数目ResultSet由此产生对象Statement对象; 零意味着没有限制
        异常
        SQLException - 如果发生数据库访问错误或者在关闭的 Statement调用此方法 Statement
        从以下版本开始：
        1.8
        另请参见：
        setMaxRows(int)

      • executeLargeBatch

        default long[] executeLargeBatch​()
                          throws SQLException
        将一批命令提交到数据库以执行，并且所有命令都执行成功，返回一个更新计数的数组。 返回的数组的long元素被排序以对应于批次中的命令，这些命令根据它们添加到批处理的顺序进行排序。 方法executeLargeBatch返回的数组中的元素可能是以下之一：
        1. 大于或等于零的数字表示该命令已成功处理，并且是一个更新计数，表示数据库中受命令执行影响的行数
        2. 值为SUCCESS_NO_INFO - 表示该命令已成功处理，但受影响的行数未知

          如果批量更新中的其中一个命令无法正常执行，则此方法将抛出一个BatchUpdateException ，并且JDBC驱动程序可能会继续处理或不继续处理批处理中的其余命令。 但是，驱动程序的行为必须与特定的DBMS保持一致，或者始终继续处理命令或者从不继续处理命令。 如果驱动程序在故障后继续处理，方法BatchUpdateException.getLargeUpdateCounts返回的数组将包含与批处理中的命令一样多的元素，并且至少有一个元素将包含以下内容：

        3. 值为EXECUTE_FAILED - 表示命令无法成功执行，并且仅在驱动程序在命令失败后继续处理命令时才会发生

        当返回的行数可能超过Integer.MAX_VALUE时，应使用此方法。

        默认实现将抛出UnsupportedOperationException

        结果
        一组更新计数，包含批处理中每个命令的一个元素。 数组的元素根据命令添加到批处理的顺序进行排序。
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的Statement上Statement或驱动程序不支持批处理语句。 抛出BatchUpdateException （的一个子类SQLException ）如果发送到数据库的命令之一无法正确执行或者尝试返回的结果集。
        SQLTimeoutException - 当驱动程序确定已超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.8
        另请参见：
        addBatch(java.lang.String) ， DatabaseMetaData.supportsBatchUpdates()

      • executeLargeUpdate

        default long executeLargeUpdate​(String sql)
                         throws SQLException
        执行给定的SQL语句，这可能是INSERT ， UPDATE ，或DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。

        当返回的行数可能超过Integer.MAX_VALUE时，应使用此方法。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        默认实现将抛出UnsupportedOperationException

        参数
        sql -一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
        结果
        （1）SQL数据操作语言（DML）语句的行计数或（2）0不返回的SQL语句
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，给定的SQL语句生成一个 ResultSet对象，该方法在 PreparedStatement或 CallableStatement
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.8

      • executeLargeUpdate

        default long executeLargeUpdate​(String sql,
                                int autoGeneratedKeys)
                         throws SQLException
        执行给定的SQL语句，并用给定的标志来向驱动程序发出信号，指出这个Statement对象产生的自动生成的密钥是否应该可用于检索。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该标志。

        当返回的行数可能超过Integer.MAX_VALUE时，应使用此方法。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        sql -一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
        autoGeneratedKeys - 指示自动生成的密钥是否可用于检索的标志; 以下常数之一： Statement.RETURN_GENERATED_KEYS Statement.NO_GENERATED_KEYS
        结果
        （1）SQL数据操作语言（DML）语句的行计数或（2）0不返回的SQL语句
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，给定的SQL语句返回一个 ResultSet对象，给定常量不是允许的一个，该方法在 PreparedStatement或 CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法与常量Statement.RETURN_GENERATED_KEYS
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.8

      • executeLargeUpdate

        default long executeLargeUpdate​(String sql,
                                int[] columnIndexes)
                         throws SQLException
        执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。 该数组包含目标表中包含应该可用的自动生成的键的列的索引。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该数组。

        当返回的行数可能超过Integer.MAX_VALUE时，应使用此方法。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        sql -一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
        columnIndexes - 一列列索引，指示应从插入的行返回的列
        结果
        （1）SQL数据操作语言（DML）语句的行计数或（2）0不返回的SQL语句
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，SQL语句返回一个 ResultSet对象，提供给此方法的第二个参数不是其元素为有效列索引的 int数组，该方法被调用一个 PreparedStatement或 CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.8

      • executeLargeUpdate

        default long executeLargeUpdate​(String sql,
                                String[] columnNames)
                         throws SQLException
        执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。 该数组包含目标表中包含应该可用的自动生成的键的列的名称。 如果SQL语句不是INSERT语句，或者SQL语句能够返回自动生成的键（此类语句的列表是供应商特定的），驱动程序将忽略该数组。

        当返回的行数可能超过Integer.MAX_VALUE时，应使用此方法。

        注意：此方法无法在PreparedStatement或CallableStatement 。

        默认实现将抛出SQLFeatureNotSupportedException

        参数
        sql -一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
        columnNames - 应该从插入的行返回的列的名称数组
        结果
        无论是行数 INSERT ， UPDATE ，或 DELETE语句，或者为0，SQL语句不返回任何内容
        异常
        SQLException - 如果发生数据库访问错误，此方法在关闭的 Statement上 Statement ，SQL语句返回一个 ResultSet对象，提供给此方法的第二个参数不是一个 String数组，其元素是有效的列名，该方法被调用一个 PreparedStatement或 CallableStatement
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        SQLTimeoutException - 当驱动程序确定已经超过 setQueryTimeout方法指定的超时值，并且至少尝试取消当前正在运行的 Statement
        从以下版本开始：
        1.8

      • enquoteLiteral

        default String enquoteLiteral​(String val)
                       throws SQLException
        返回一个包含在单引号中的String 。 字符串中单引号的任何出现将被两个单引号替换。
        Examples of the conversion:
        Value | Result
        Hello | 'Hello'
        G'Day | 'G''Day'
        'G''Day' | '''G''''Day'''
        I'''M | 'I''''''M'
        Implementation Note:
        JDBC驱动程序实现可能需要提供自己的此方法的实现，以满足底层数据源的要求。
        参数
        val - 一个字符串
        结果
        用单引号括起来的每个单引号转换为两个单引号的字符串
        异常
        NullPointerException - 如果val是 null
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        9

      • enquoteIdentifier

        default String enquoteIdentifier​(String identifier,
                                 boolean alwaysQuote)
                          throws SQLException
        返回一个SQL标识符。 如果identifier是一个简单的SQL标识符：
        • 如果alwaysQuote为false则返回原始值
        • 如果alwaysQuote为true返回分隔true
        如果identifier不是简单的SQL标识符，则identifier将被包含在双引号中（如果尚未存在）。 如果数据源不支持分隔标识符的双引号，则标识符应由从DatabaseMetaData.getIdentifierQuoteString()返回的字符串括起来。 如果数据源不支持分隔标识符，则应抛出一个SQLFeatureNotSupportedException 。

        甲SQLException如果将被抛出identifier包含在分隔标识符无效的任何字符或标识符长度为数据源无效。

        实现要求：
        默认实现使用以下标准来确定有效的简单SQL标识符：
        • 字符串未用双引号括起来
        • 第一个字符是从a到z或从A到Z的字母字符
        • 该名称仅包含字母数字字符或字符“_”
        默认实现将抛出一个SQLException如果：
        • identifier包含一个null字符或双引号，不是一个简单的SQL标识符。
        • identifier的长度小于1或大于128个字符
        Examples of the conversion:
        identifier | alwaysQuote | Result
        Hello | false | Hello
        Hello | true | "Hello"
        G'Day | false | "G'Day"
        "Bruce Wayne" | false | "Bruce Wayne"
        "Bruce Wayne" | true | "Bruce Wayne"
        GoodDay$ | false | "GoodDay$"
        Hello"World | false | SQLException
        "Hello"World" | false | SQLException
        Implementation Note:
        JDBC驱动程序实现可能需要提供自己的此方法的实现，以满足底层数据源的要求。
        参数
        identifier - 一个SQL标识符
        alwaysQuote - 指示是否应将简单的SQL标识符作为引用的标识符返回
        结果
        简单的SQL标识符或分隔的标识符
        异常
        SQLException - 如果标识符不是有效的标识符
        SQLFeatureNotSupportedException - 如果数据源不支持分隔标识符
        NullPointerException - 如果标识符是 null
        从以下版本开始：
        9

      • isSimpleIdentifier

        default boolean isSimpleIdentifier​(String identifier)
                            throws SQLException
        检索 identifier是否是一个简单的SQL标识符。
        实现要求：
        默认实现使用以下标准来确定有效的简单SQL标识符：
        • 字符串未用双引号括起来
        • 第一个字符是从a到z或从A到Z的字母字符
        • 字符串只包含字母数字字符或字符“_”
        • 字符串长度在1到128个字符之间
        Examples of the conversion:
        identifier | Simple Identifier
        Hello | true
        G'Day | false
        "Bruce Wayne" | false
        GoodDay$ | false
        Hello"World | false
        "Hello"World" | false
        Implementation Note:
        JDBC驱动程序实现可能需要提供自己的此方法的实现，以满足底层数据源的要求。
        参数
        identifier - 一个SQL标识符
        结果
        如果一个简单的SQL标识符为true，否则为false
        异常
        NullPointerException - 如果标识符是 null
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        9

      • enquoteNCharLiteral

        default String enquoteNCharLiteral​(String val)
                            throws SQLException
        返回一个String表示一个国家字符集文字，用单引号括起来，并以大写字母N作为前缀。字符串中任何单引号的出现将被两个单引号替代。
        Examples of the conversion:
        Value | Result
        Hello | N'Hello'
        G'Day | N'G''Day'
        'G''Day' | N'''G''''Day'''
        I'''M | N'I''''''M'
        N'Hello' | N'N''Hello'''
        Implementation Note:
        JDBC驱动程序实现可能需要提供自己的此方法的实现，以满足底层数据源的要求。 enquoteNCharLiteral的一个实现可以接受一个不同于由同一个驱动程序实现enquoteLiteral所接受的字符。
        参数
        val - 一个字符串
        结果
        将参数中的每个单引号字符替换为两个单引号字符的结果，其中整个结果以“N”为前缀。
        异常
        NullPointerException - 如果val为 null
        SQLException - 如果发生数据库访问错误
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Struct (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Struct

  • 所有已知实现类：
    SerialStruct

    public interface Struct

    用于SQL结构化类型的Java编程语言中的标准映射。 Struct对象包含其表示的SQL结构化类型的每个属性的值。 默认情况下，一个Struct的实例是有效的，只要应用程序有一个引用。

    如果JDBC驱动程序支持数据类型，则必须完全实现Struct接口上的所有方法。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object[] getAttributes​()
      生成此 Struct对象所代表的SQL结构化类型的属性的有序值。
      Object[] getAttributes​(Map<String,Class<?>> map)
      生成此 Struct对象所代表的SQL结构化类型的属性的有序值。
      String getSQLTypeName​()
      检索此 Struct对象所代表的SQL结构类型的SQL类型名称。

    • 方法详细信息

      • getSQLTypeName

        String getSQLTypeName​()
               throws SQLException
        检索此 Struct对象所代表的SQL结构类型的SQL类型名称。
        结果
        这个 Struct对象是通用表示形式的SQL结构化类型的完全限定类型名称
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getAttributes

        Object[] getAttributes​()
                throws SQLException
        生成此Struct对象所代表的SQL结构化类型的属性的有序值。 处理各个属性时，此方法使用与连接相关联的类型映射来进行类型映射的自定义。 如果连接的类型映射中没有匹配属性表示的结构化类型的条目，则驱动程序将使用标准映射。

        从概念上讲，该方法调用结构化类型的每个属性的方法getObject ，并返回一个包含结果的Java数组。

        结果
        一个包含有序属性值的数组
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2

      • getAttributes

        Object[] getAttributes​(Map<String,Class<?>> map)
                throws SQLException
        生成此Struct对象表示的SQL结构化类型的属性的有序值。 处理各个属性时，此方法使用给定的类型映射来进行类型映射的自定义。 如果给定类型映射中没有与属性表示的结构化类型匹配的条目，则驱动程序将使用标准映射。 此方法从不使用与连接相关联的类型映射。

        从概念上讲，该方法调用结构化类型的每个属性的方法getObject ，并返回一个包含结果的Java数组。

        参数
        map - SQL类型名称与Java类的映射
        结果
        一个包含有序属性值的数组
        异常
        SQLException - 如果发生数据库访问错误
        SQLFeatureNotSupportedException - 如果JDBC驱动程序不支持此方法
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Time (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class Time

  • java.lang.Object
    • java.util.Date
      • java.sql.Time
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Comparable<Date>

    public class Time
extends Date

    围绕java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。 Time类添加了格式化和解析操作，以支持时间值的JDBC转义语法。

    日期组件应设置为1970年1月1日的“零纪元”值，不应被访问。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Time​(int hour, int minute, int second)
      已过时。
      使用构造函数，该构造函数需要一个毫秒值来代替此构造函数
      Time​(long time)
      使用毫秒时间值构建一个 Time对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int getDate​()
      已过时。
      int getDay​()
      已过时。
      int getMonth​()
      已过时。
      int getYear​()
      已过时。
      void setDate​(int i)
      已过时。
      void setMonth​(int i)
      已过时。
      void setTime​(long time)
      使用毫秒时间值设置 Time对象。
      void setYear​(int i)
      已过时。
      Instant toInstant​()
      此方法总是引发UnsupportedOperationException，因为SQL Time值没有日期组件，因此不应该使用此方法。
      LocalTime toLocalTime​()
      将此 Time对象转换为 LocalTime 。
      String toString​()
      以JDBC时间转义格式格式化。
      static Time valueOf​(String s)
      将JDBC时间转义格式的字符串转换为 Time值。
      static Time valueOf​(LocalTime time)
      从LocalTime对象获取Time的实例，具有与给定的LocalTime相同的小时，分钟和第二时间值。

      • Methods inherited from class java.util.Date

        after, before, clone, compareTo, equals, from, getHours, getMinutes, getSeconds, getTime, getTimezoneOffset, hashCode, parse, setHours, setMinutes, setSeconds, toGMTString, toLocaleString, UTC

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Time

        @Deprecated(since="1.2")
public Time​(int hour,
            int minute,
            int second)
        已过时。 使用构造函数，该构造函数需要一个毫秒值来代替此构造函数
        构造一个Time对象，该对象使用给定的小时，分钟和秒值进行初始化。 驱动程序将日期组件设置为1970年1月1日。尝试访问Time对象的日期组件的任何方法将抛出一个java.lang.IllegalArgumentException 。

        如果给定的参数超出界限，结果是未定义的。

        参数
        hour - 0至23
        minute - 0至59
        second - 0至59

      • Time

        public Time​(long time)
        使用毫秒时间值构造一个 Time对象。
        参数
        time - 1970年1月1日00:00:00 GMT以来的毫秒数 负数是1970年1月1日00:00:00 GMT之前的毫秒

    • 方法详细信息

      • setTime

        public void setTime​(long time)
        使用毫秒时间值设置 Time对象。
        重写：
        setTime在 Date
        参数
        time - 1970年1月1日00:00:00 GMT以来的毫秒 负数是1970年1月1日00:00:00 GMT之前的毫秒

      • valueOf

        public static Time valueOf​(String s)
        将JDBC时间转义格式的字符串转换为 Time值。
        参数
        s - 时间格式“hh：mm：ss”
        结果
        一个对应的 Time对象

      • toString

        public String toString​()
        以JDBC时间转义格式格式化。
        重写：
        toString在 Date
        结果
        一个 String在hh：mm：ss格式
        另请参见：
        Date.toLocaleString() ， Date.toGMTString()

      • getYear

        @Deprecated(since="1.2")
public int getYear​()
        已过时。
        此方法已被弃用，不应使用，因为SQL TIME值不具有年份组件。
        重写：
        getYear在 Date
        结果
        这个日期代表的年份，减去1900年。
        异常
        IllegalArgumentException - 如果调用此方法
        另请参见：
        setYear(int)

      • getMonth

        @Deprecated(since="1.2")
public int getMonth​()
        已过时。
        此方法已弃用，不应使用，因为SQL TIME值不具有月份组件。
        重写：
        getMonth在 Date
        结果
        该日期的代表月份。
        异常
        IllegalArgumentException - 如果这个方法被调用
        另请参见：
        setMonth(int)

      • getDay

        @Deprecated(since="1.2")
public int getDay​()
        已过时。
        此方法已被弃用，不应使用，因为SQL TIME值不包含日组件。
        重写：
        getDay在 Date
        结果
        这个日期的星期几。
        异常
        IllegalArgumentException - 如果这个方法被调用
        另请参见：
        Calendar

      • getDate

        @Deprecated(since="1.2")
public int getDate​()
        已过时。
        此方法已被弃用，不应使用，因为SQL TIME值没有日期组件。
        重写：
        getDate在 Date
        结果
        这个日期的一个月的日子。
        异常
        IllegalArgumentException - 如果该方法被调用
        另请参见：
        setDate(int)

      • setYear

        @Deprecated(since="1.2")
public void setYear​(int i)
        已过时。
        此方法已被弃用，不应使用，因为SQL TIME值不具有年份组件。
        重写：
        setYear在 Date
        参数
        i - 年值。
        异常
        IllegalArgumentException - 如果调用此方法
        另请参见：
        getYear()

      • setMonth

        @Deprecated(since="1.2")
public void setMonth​(int i)
        已过时。
        此方法已被弃用，不应使用，因为SQL TIME值不具有月份组件。
        重写：
        setMonth中的 Date
        参数
        i - 0-11之间的月份值。
        异常
        IllegalArgumentException - 如果这个方法被调用
        另请参见：
        getMonth()

      • setDate

        @Deprecated(since="1.2")
public void setDate​(int i)
        已过时。
        此方法已被弃用，不应使用，因为SQL TIME值没有日期组件。
        重写：
        setDate在 Date
        参数
        i - 月中的日期值在1-31之间。
        异常
        IllegalArgumentException - 如果调用此方法
        另请参见：
        getDate()

      • valueOf

        public static Time valueOf​(LocalTime time)
        从LocalTime对象获取Time的实例，具有与给定的LocalTime相同的小时，分钟和秒值。 来自LocalTime字段不是新创建的Time对象的一部分。
        参数
        time - a转换 LocalTime
        结果
        一个 Time对象
        异常
        NullPointerException - 如果 time为空
        从以下版本开始：
        1.8

      • toLocalTime

        public LocalTime toLocalTime​()
        将此Time对象转换为LocalTime 。

        该转换创建一个LocalTime ，表示与此Time相同的小时，分钟和秒值。 纳秒LocalTime字段将被设置为零。

        结果
        一个表示相同时间值的 LocalTime对象
        从以下版本开始：
        1.8

      • toInstant

        public Instant toInstant​()
        此方法总是引发UnsupportedOperationException，因为SQL Time值不具有日期组件，因此不应该使用它。
        重写：
        toInstant在 Date
        结果
        即时表示在这个 Date对象的时间线上的相同点
        异常
        UnsupportedOperationException - if this method is invoked
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Timestamp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class Timestamp

  • java.lang.Object
    • java.util.Date
      • java.sql.Timestamp
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Comparable<Date>

    public class Timestamp
extends Date

    一个围绕java.util.Date的薄型封装，允许JDBC API将其标识为SQL TIMESTAMP值。 它通过允许将秒数的规定精确到纳秒来增加保持SQL TIMESTAMP分秒数值的能力。 时间戳记还提供格式化和解析操作，以支持时间戳值的JDBC转义语法。

    Timestamp对象的精度计算为：

    • 19 ，这是yyyy-mm-dd hh中的字符数：mm：ss
    • 20 + s ，它是yyyy-mm-dd hh中的字符数：mm：ss。[fff ...]和s表示给定时间戳的缩放，分数秒精度。

    注意：此类型是java.util.Date和单独的纳秒值的复合值。 只有整数秒存储在java.util.Date组件中。 分数秒 - 纳米 - 是分开的。 Timestamp.equals(Object)方法在传递不是java.sql.Timestamp的实例的对象时不会返回true ，因为日期的nanos组件是未知的。 其结果是，该Timestamp.equals(Object)方法不相对于所述对称java.util.Date.equals(Object)方法。 此外， hashCode方法使用底层的java.util.Date实现，因此在其计算中不包括nanos。

    由于之间的差异Timestamp类和java.util.Date上述类，建议代码不能查看Timestamp一般值的一个实例java.util.Date 。 Timestamp和java.util.Date之间的继承关系真的表示实现继承，而不是类型继承。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Timestamp​(int year, int month, int date, int hour, int minute, int second, int nano)
      已过时。
      而是使用构造函数Timestamp(long millis)
      Timestamp​(long time)
      使用毫秒时间值构造一个 Timestamp对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean after​(Timestamp ts)
      指示此 Timestamp对象是否晚于给定的 Timestamp对象。
      boolean before​(Timestamp ts)
      指示此 Timestamp对象是否早于给定的 Timestamp对象。
      int compareTo​(Timestamp ts)
      将此 Timestamp对象与给定的 Timestamp对象进行比较。
      int compareTo​(Date o)
      将此 Timestamp对象与给定的 Date对象进行比较。
      boolean equals​(Object ts)
      测试这个 Timestamp对象是否等于给定的对象。
      boolean equals​(Timestamp ts)
      测试看看这个 Timestamp对象是否等于给定的 Timestamp对象。
      static Timestamp from​(Instant instant)
      从Instant对象获取一个Timestamp的实例。
      int getNanos​()
      获取此 Timestamp对象的 nanos值。
      long getTime​()
      返回自1970年1月1日以来，由 Timestamp对象表示的00:00:00 GMT的毫秒数。
      int hashCode​()
      返回此对象的哈希码值。
      void setNanos​(int n)
      将此 Timestamp对象的 nanos字段设置为给定值。
      void setTime​(long time)
      将此 Timestamp对象设置为表示1970年1月1日00:00:00 GMT后的 time毫秒的时间点。
      Instant toInstant​()
      将此 Timestamp对象转换为 Instant 。
      LocalDateTime toLocalDateTime​()
      将此 Timestamp对象转换为 LocalDateTime 。
      String toString​()
      以JDBC时间戳转义格式格式化时间戳。
      static Timestamp valueOf​(String s)
      将 String对象以JDBC时间戳转换格式转换为 Timestamp值。
      static Timestamp valueOf​(LocalDateTime dateTime)
      获取的实例 Timestamp从 LocalDateTime对象，以相同的年，月，月日，时，分，秒和毫微秒日期时间值作为提供 LocalDateTime 。

      • Methods inherited from class java.util.Date

        after, before, clone, getDate, getDay, getHours, getMinutes, getMonth, getSeconds, getTimezoneOffset, getYear, parse, setDate, setHours, setMinutes, setMonth, setSeconds, setYear, toGMTString, toLocaleString, UTC

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Timestamp

        @Deprecated(since="1.2")
public Timestamp​(int year,
                 int month,
                 int date,
                 int hour,
                 int minute,
                 int second,
                 int nano)
        已过时。 而是使用构造函数Timestamp(long millis)
        构造一个使用给定值初始化的 Timestamp对象。
        参数
        year - 年减1900
        month - 0至11
        date - 1至31
        hour - 0至23
        minute - 0至59
        second - 0至59
        nano - 0至999,999,999
        异常
        IllegalArgumentException - 如果纳米参数超出范围

      • Timestamp

        public Timestamp​(long time)
        使用毫秒时间值构造一个Timestamp对象。 积分秒存储在基础日期值中; 小数秒将存储在Timestamp对象的nanos字段中。
        参数
        time - 自1970年1月1日00:00:00 GMT以来的毫秒。 负数是1970年1月1日00:00:00 GMT之前的毫秒数。
        另请参见：
        Calendar

    • 方法详细信息

      • setTime

        public void setTime​(long time)
        将此 Timestamp对象设置为1970年1月1日00:00:00 GMT后的 time毫秒的时间点。
        重写：
        setTime在 Date
        参数
        time - 毫秒数。
        另请参见：
        getTime() ， Timestamp(long time) ， Calendar

      • getTime

        public long getTime​()
        返回自1970年1月1日以来，由 Timestamp对象表示的00:00:00 GMT的毫秒数。
        重写：
        getTime在 Date
        结果
        自1970年1月1日起，以此日期为准的00:00:00 GMT的毫秒数。
        另请参见：
        setTime(long)

      • valueOf

        public static Timestamp valueOf​(String s)
        将JDBC时间戳转换格式中的一个 String对象转换为 Timestamp值。
        参数
        s - 时间戳，格式为yyyy-[m]m-[d]d hh:mm:ss[.f...] 。 分数秒可以省略。 也可以省略mm和dd的前导零。
        结果
        相应的 Timestamp值
        异常
        IllegalArgumentException - 如果给定的参数不具有格式 yyyy-[m]m-[d]d hh:mm:ss[.f...]

      • toString

        public String toString​()
        以JDBC时间戳转义格式格式化时间戳。 yyyy-mm-dd hh:mm:ss.fffffffff ，其中fffffffff表示纳秒。
        重写：
        toString在 Date
        结果
        一个 String对象在 yyyy-mm-dd hh:mm:ss.fffffffff格式
        另请参见：
        Date.toLocaleString() ， Date.toGMTString()

      • getNanos

        public int getNanos​()
        获取此 Timestamp对象的 nanos值。
        结果
        这个 Timestamp对象的小数秒组件
        另请参见：
        setNanos(int)

      • setNanos

        public void setNanos​(int n)
        将此 Timestamp对象的 nanos字段设置为给定值。
        参数
        n - 新的分数秒分量
        异常
        IllegalArgumentException - 如果给定的参数大于999999999或小于0
        另请参见：
        getNanos()

      • equals

        public boolean equals​(Timestamp ts)
        测试这个 Timestamp对象是否等于给定的 Timestamp对象。
        参数
        ts - 与 Timestamp值进行比较
        结果
        true如果给定的Timestamp对象等于这个Timestamp对象; false否则

      • equals

        public boolean equals​(Object ts)
        测试这个Timestamp对象是否等于给定对象。 此版本的方法equals已被添加以修复Timestamp.equals(Timestamp)的不正确签名，并保留与现有类文件的向后兼容性。 注意：该方法与基类中的equals(Object)方法不对称。
        重写：
        equals在 Date
        参数
        ts - 与 Object值进行比较
        结果
        true如果给定Object是一个实例Timestamp等于这个Timestamp对象; 否则为false
        另请参见：
        Date.getTime()

      • before

        public boolean before​(Timestamp ts)
        指示此 Timestamp对象是否早于给定的 Timestamp对象。
        参数
        ts - 要与 Timestamp值进行比较
        结果
        true如果这个Timestamp对象较早; 否则为false

      • after

        public boolean after​(Timestamp ts)
        指示此 Timestamp对象是否晚于给定的 Timestamp对象。
        参数
        ts - 与 Timestamp值进行比较
        结果
        true如果这个Timestamp对象是后来的; false否则

      • compareTo

        public int compareTo​(Timestamp ts)
        将此 Timestamp对象与给定的 Timestamp对象进行比较。
        参数
        ts - 要与 Timestamp对象进行比较的 Timestamp对象
        结果
        值0如果两个Timestamp对象相等; 一个值小于0如果这个Timestamp对象是在给定的参数之前; 并且如果此Timestamp对象在给定参数之后，则值大于0 。
        从以下版本开始：
        1.4

      • compareTo

        public int compareTo​(Date o)
        将此 Timestamp对象与给定的 Date对象进行比较。
        Specified by:
        compareTo在接口 Comparable<Date>
        重写：
        compareTo在 Date
        参数
        o -的 Date被比作此 Timestamp对象
        结果
        值0如果这个Timestamp对象和给定对象是相等的; 一个值小于0如果这个Timestamp对象是在给定的参数之前; 并且如果此Timestamp对象在给定参数之后，该值大于0 。
        从以下版本开始：
        1.5

      • hashCode

        public int hashCode​()
        返回此对象的哈希码值。 结果是由Date.getTime()方法返回的原始long值的两半的异或。 也就是说，哈希码是表达式的值：

 (int)(this.getTime()^(this.getTime() >>> 32))
        hashCode方法使用底层的java.util.Date实现，因此在其计算中不包括java.util.Date 。
        重写：
        hashCode在 Date
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • valueOf

        public static Timestamp valueOf​(LocalDateTime dateTime)
        获取的实例Timestamp从LocalDateTime对象，以相同的年，月，月日，时，分，秒和毫微秒日期时间值作为提供LocalDateTime 。

        提供的LocalDateTime被解释为本地时区的本地日期时间。

        参数
        dateTime - a转换 LocalDateTime
        结果
        一个 Timestamp对象
        异常
        NullPointerException - 如果 dateTime为空。
        从以下版本开始：
        1.8

      • toLocalDateTime

        public LocalDateTime toLocalDateTime​()
        将此Timestamp对象转换为LocalDateTime 。

        该转换将创建一个LocalDateTime ，表示当地时区Timestamp的同一年，月，日，月，日，时间和Timestamp日期时间值。

        结果
        表示相同日期时间值的 LocalDateTime对象
        从以下版本开始：
        1.8

      • from

        public static Timestamp from​(Instant instant)
        从Instant对象获取Timestamp的实例。

        Instant可以在未来更进一步的时间点上存储积分，并且在过去比Date进一步。 在这种情况下，此方法将抛出异常。

        参数
        instant - 即时转换
        结果
        一个 Timestamp代表在提供的时刻的时间线上的相同点
        异常
        NullPointerException - 如果 instant为空。
        IllegalArgumentException - 如果瞬间太大，无法表示为 Timestamp
        从以下版本开始：
        1.8

      • toInstant

        public Instant toInstant​()
        将此Timestamp对象转换为Instant 。

        该转换创建一个Instant ，代表与此Timestamp的时间线上的相同点。

        重写：
        toInstant在 Date
        结果
        即时表示时间线上的同一点
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Types (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Class Types

  • java.lang.Object
    • java.sql.Types

  • public class Types
extends Object

    定义用于标识通用SQL类型的常量的类，称为JDBC类型。

    这个类永远不会被实例化。

    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ARRAY
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 ARRAY 。
      static int BIGINT
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BIGINT 。
      static int BINARY
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BINARY 。
      static int BIT
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BIT 。
      static int BLOB
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BLOB 。
      static int BOOLEAN
      Java编程语言中的常量（有时称为类型代码），用于标识通用SQL类型 BOOLEAN 。
      static int CHAR
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 CHAR 。
      static int CLOB
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 CLOB 。
      static int DATALINK
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DATALINK 。
      static int DATE
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DATE 。
      static int DECIMAL
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DECIMAL 。
      static int DISTINCT
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DISTINCT 。
      static int DOUBLE
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DOUBLE 。
      static int FLOAT
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 FLOAT 。
      static int INTEGER
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 INTEGER 。
      static int JAVA_OBJECT
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 JAVA_OBJECT 。
      static int LONGNVARCHAR
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 LONGNVARCHAR 。
      static int LONGVARBINARY
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 LONGVARBINARY 。
      static int LONGVARCHAR
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 LONGVARCHAR 。
      static int NCHAR
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NCHAR
      static int NCLOB
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NCLOB 。
      static int NULL
      Java编程语言中的常量，用于标识通用SQL值 NULL 。
      static int NUMERIC
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NUMERIC 。
      static int NVARCHAR
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NVARCHAR 。
      static int OTHER
      Java编程语言中的常量表示SQL类型是特定于数据库的，并且映射到可以通过方法 getObject和 setObject访问的Java对象。
      static int REAL
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 REAL 。
      static int REF
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 REF 。
      static int REF_CURSOR
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 REF CURSOR 。
      static int ROWID
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 ROWID
      static int SMALLINT
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 SMALLINT 。
      static int SQLXML
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 XML 。
      static int STRUCT
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 STRUCT 。
      static int TIME
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIME 。
      static int TIME_WITH_TIMEZONE
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIME WITH TIMEZONE 。
      static int TIMESTAMP
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIMESTAMP 。
      static int TIMESTAMP_WITH_TIMEZONE
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIMESTAMP WITH TIMEZONE 。
      static int TINYINT
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TINYINT 。
      static int VARBINARY
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 VARBINARY 。
      static int VARCHAR
      Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 VARCHAR 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • BIT

        public static final int BIT

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型BIT 。

        另请参见：
        Constant Field Values

      • TINYINT

        public static final int TINYINT

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型TINYINT 。

        另请参见：
        Constant Field Values

      • SMALLINT

        public static final int SMALLINT

        Java编程语言中的常量（有时称为类型代码），用于标识通用SQL类型SMALLINT 。

        另请参见：
        Constant Field Values

      • INTEGER

        public static final int INTEGER

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型INTEGER 。

        另请参见：
        Constant Field Values

      • BIGINT

        public static final int BIGINT

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型BIGINT 。

        另请参见：
        Constant Field Values

      • FLOAT

        public static final int FLOAT

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型FLOAT 。

        另请参见：
        Constant Field Values

      • REAL

        public static final int REAL

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型REAL 。

        另请参见：
        Constant Field Values

      • DOUBLE

        public static final int DOUBLE

        Java编程语言中的常量（有时称为类型代码），用于标识通用SQL类型DOUBLE 。

        另请参见：
        Constant Field Values

      • NUMERIC

        public static final int NUMERIC

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型NUMERIC 。

        另请参见：
        Constant Field Values

      • DECIMAL

        public static final int DECIMAL

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型DECIMAL 。

        另请参见：
        Constant Field Values

      • CHAR

        public static final int CHAR

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型CHAR 。

        另请参见：
        Constant Field Values

      • VARCHAR

        public static final int VARCHAR

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型VARCHAR 。

        另请参见：
        Constant Field Values

      • LONGVARCHAR

        public static final int LONGVARCHAR

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型LONGVARCHAR 。

        另请参见：
        Constant Field Values

      • DATE

        public static final int DATE

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型DATE 。

        另请参见：
        Constant Field Values

      • TIME

        public static final int TIME

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型TIME 。

        另请参见：
        Constant Field Values

      • TIMESTAMP

        public static final int TIMESTAMP

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型TIMESTAMP 。

        另请参见：
        Constant Field Values

      • BINARY

        public static final int BINARY

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型BINARY 。

        另请参见：
        Constant Field Values

      • VARBINARY

        public static final int VARBINARY

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型VARBINARY 。

        另请参见：
        Constant Field Values

      • LONGVARBINARY

        public static final int LONGVARBINARY

        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型LONGVARBINARY 。

        另请参见：
        Constant Field Values

      • NULL

        public static final int NULL

        Java编程语言中的常量，用于标识通用SQL值NULL 。

        另请参见：
        Constant Field Values

      • OTHER

        public static final int OTHER
        Java编程语言中的常量表示SQL类型是特定于数据库的，并被映射到可通过方法 getObject和 setObject访问的Java对象。
        另请参见：
        Constant Field Values

      • JAVA_OBJECT

        public static final int JAVA_OBJECT
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 JAVA_OBJECT 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • DISTINCT

        public static final int DISTINCT
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DISTINCT 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • STRUCT

        public static final int STRUCT
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 STRUCT 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • ARRAY

        public static final int ARRAY
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 ARRAY 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • BLOB

        public static final int BLOB
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BLOB 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • CLOB

        public static final int CLOB
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 CLOB 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • REF

        public static final int REF
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 REF 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • DATALINK

        public static final int DATALINK
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DATALINK 。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • BOOLEAN

        public static final int BOOLEAN
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BOOLEAN 。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • ROWID

        public static final int ROWID
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 ROWID
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • NCHAR

        public static final int NCHAR
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NCHAR
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • NVARCHAR

        public static final int NVARCHAR
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NVARCHAR 。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • LONGNVARCHAR

        public static final int LONGNVARCHAR
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 LONGNVARCHAR 。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • NCLOB

        public static final int NCLOB
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NCLOB 。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • SQLXML

        public static final int SQLXML
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 XML 。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • REF_CURSOR

        public static final int REF_CURSOR
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 REF CURSOR 。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values

      • TIME_WITH_TIMEZONE

        public static final int TIME_WITH_TIMEZONE
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIME WITH TIMEZONE 。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values

      • TIMESTAMP_WITH_TIMEZONE

        public static final int TIMESTAMP_WITH_TIMEZONE
        Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIMESTAMP WITH TIMEZONE 。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Package java.sql (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.sql

  • Packages that use java.sql
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
  • Classes in java.sql used by java.sql
    Class 描述
    Array
    Java编程语言中的映射为SQL类型 ARRAY 。
    Blob
    表示（映射）在Java编程语言中的一个SQL BLOB值。
    CallableStatement
    用于执行SQL存储过程的界面。
    ClientInfoStatus
    枚举财产无法通过拨打 Connection.setClientInfo设置的 Connection.setClientInfo
    Clob
    在Java的编程语言中映射为SQL CLOB类型。
    Connection
    与特定数据库的连接（会话）。
    ConnectionBuilder
    从 DataSource对象创建的构建器，用于建立与 data source对象所表示的数据库的连接。
    DatabaseMetaData
    关于整个数据库的综合信息。
    Date
    一个大约一毫秒值的薄包装，允许JDBC将其标识为SQL DATE值。
    Driver
    每个驱动程序类必须实现的接口。
    DriverAction
    当Driver想要通知DriverManager时必须实现的接口。
    DriverPropertyInfo
    用于进行连接的驱动程序属性。
    JDBCType
    定义用于标识通用SQL类型（称为JDBC类型）的常量。
    NClob
    在Java的编程语言中映射为SQL NCLOB类型。
    ParameterMetaData
    可用于获取有关 PreparedStatement对象中每个参数标记的类型和属性的 PreparedStatement对象。
    PreparedStatement
    表示预编译的SQL语句的对象。
    PseudoColumnUsage
    伪/隐藏列使用枚举。
    Ref
    SQL编程语言中的映射SQL REF值，它是对数据库中SQL结构化类型值的引用。
    ResultSet
    表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
    ResultSetMetaData
    可用于获取有关 ResultSet对象中列的类型和属性的信息的对象。
    RowId
    SQL编程语言中的表示（映射）SQL ROWID值。
    RowIdLifetime
    RowId寿命值的枚举。
    Savepoint
    一个保存点的表示，它是当前事务中可以从 Connection.rollback方法引用的一个点。
    ShardingKey
    用于指示此对象表示Sharding键的接口。
    ShardingKeyBuilder
    从DataSource或XADataSource对象创建的构建器，用于使用支持的数据类型的子键创建一个ShardingKey 。
    SQLClientInfoException
    当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。
    SQLData
    用于将SQL用户定义类型（UDT）自定义映射到Java编程语言中的类的接口。
    SQLException
    提供有关数据库访问错误或其他错误的信息的异常。
    SQLFeatureNotSupportedException
    当SQLState类的值为' 0A '（值为'零'A）时，抛出SQLException的子类。
    SQLInput
    包含表示SQL结构化类型或SQL不同类型实例的值的流的输入流。
    SQLNonTransientException
    当一个重试相同操作的实例将失败的情况下，抛出SQLException的子类，除非修正了原因SQLException 。
    SQLOutput
    用于将用户定义类型的属性写入数据库的输出流。
    SQLTransientException
    SQLException的子类在以前失败的操作可能能够在没有应用程序级功能的任何干预的情况下重试操作时能够成功的情况下抛出。
    SQLType
    用于标识通用SQL类型（称为JDBC类型或供应商特定数据类型）的对象。
    SQLWarning
    提供有关数据库访问警告的信息的异常。
    SQLXML
    用于SQL XML类型的JavaTM编程语言中的映射。
    Statement
    用于执行静态SQL语句并返回其生成的结果的对象。
    Struct
    用于SQL结构化类型的Java编程语言中的标准映射。
    Time
    一个围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。
    Timestamp
    一个围绕 java.util.Date的薄包装，允许JDBC API将其标识为SQL TIMESTAMP值。
    Wrapper
    提供在有问题的实例实际上是一个代理类时能够检索委托实例的JDBC类的接口。
  • Classes in java.sql used by javax.sql
    Class 描述
    Array
    在Java编程语言中映射的SQL类型为 ARRAY 。
    Blob
    表示（映射）在Java编程语言中的一个SQL BLOB值。
    Clob
    在Java的编程语言中映射为SQL CLOB类型。
    Connection
    与特定数据库的连接（会话）。
    ConnectionBuilder
    从 DataSource对象创建的构建器，用于建立与 data source对象所表示的数据库的连接。
    Date
    一个薄的包装器，大约一毫秒的值，允许JDBC将其标识为SQL DATE值。
    NClob
    在Java的编程语言中映射为SQL NCLOB类型。
    PreparedStatement
    表示预编译的SQL语句的对象。
    Ref
    SQL编程语言中的映射SQL REF ，它是对数据库中SQL结构化类型值的引用。
    ResultSet
    表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
    ResultSetMetaData
    可用于获取有关 ResultSet对象中列的类型和属性的信息的对象。
    RowId
    SQL编程语言中的表示（映射）SQL ROWID值。
    ShardingKey
    用于指示此对象表示Sharding键的接口。
    ShardingKeyBuilder
    从DataSource或XADataSource对象创建的构建器，用于使用支持的数据类型的子键创建ShardingKey 。
    SQLException
    提供有关数据库访问错误或其他错误的信息的异常。
    SQLFeatureNotSupportedException
    当SQLState类值为' 0A '（值为'零'A）时，抛出SQLException的子类。
    SQLXML
    用于SQL XML类型的JavaTM编程语言中的映射。
    Time
    围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。
    Timestamp
    一个围绕 java.util.Date的薄包装，允许JDBC API将其标识为SQL TIMESTAMP值。
    Wrapper
    提供在有问题的实例实际上是一个代理类时能够检索委托实例的JDBC类的接口。
  • Classes in java.sql used by javax.sql.rowset
    Class 描述
    Array
    在Java编程语言中映射的SQL类型为 ARRAY 。
    Blob
    表示（映射）在Java编程语言中的一个SQL BLOB值。
    Clob
    在Java的编程语言中映射为SQL CLOB类型。
    Connection
    与特定数据库的连接（会话）。
    Date
    一个薄的包装器绕着一个毫秒值，允许JDBC将其识别为SQL DATE值。
    NClob
    在Java的编程语言中映射为SQL NCLOB类型。
    Ref
    SQL编程语言中的映射SQL REF值，它是对数据库中SQL结构化类型值的引用。
    ResultSet
    表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
    ResultSetMetaData
    可用于获取有关 ResultSet对象中列的类型和属性的信息的对象。
    RowId
    SQL编程语言中的表示（映射）SQL ROWID值。
    Savepoint
    一个保存点的表示，它是当前事务中可以从 Connection.rollback方法引用的一个点。
    SQLException
    提供有关数据库访问错误或其他错误的信息的异常。
    SQLXML
    用于SQL XML类型的JavaTM编程语言中的映射。
    Time
    围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。
    Timestamp
    java.util.Date附近的薄型封装，允许JDBC API将其标识为SQL TIMESTAMP值。
    Wrapper
    提供在有问题的实例实际上是一个代理类时能够检索委托实例的JDBC类的接口。
  • Classes in java.sql used by javax.sql.rowset.serial
    Class 描述
    Array
    在Java编程语言中映射的SQL类型为 ARRAY 。
    Blob
    表示（映射）在Java编程语言中的一个SQL BLOB值。
    Clob
    在Java的编程语言中映射为SQL CLOB类型。
    Date
    一个薄的包装器绕着一个毫秒值，允许JDBC将其识别为SQL DATE值。
    NClob
    在Java的编程语言中映射为SQL NCLOB类型。
    Ref
    SQL编程语言中的映射SQL REF值，它是对数据库中SQL结构化类型值的引用。
    ResultSet
    表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
    RowId
    SQL编程语言中的表示（映射）SQL ROWID值。
    SQLData
    用于将SQL用户定义类型（UDT）自定义映射到Java编程语言中的类的接口。
    SQLException
    提供有关数据库访问错误或其他错误的信息的异常。
    SQLInput
    包含表示SQL结构化类型或SQL不同类型实例的值的流的输入流。
    SQLOutput
    用于将用户定义类型的属性写入数据库的输出流。
    SQLXML
    用于SQL XML类型的JavaTM编程语言中的映射。
    Struct
    用于SQL结构化类型的Java编程语言中的标准映射。
    Time
    围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。
    Timestamp
    一个围绕 java.util.Date的薄包装，允许JDBC API将其标识为SQL TIMESTAMP值。
  • Classes in java.sql used by javax.sql.rowset.spi
    Class 描述
    ResultSet
    表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
    Savepoint
    一个保存点的表示，这是当前事务中可以从 Connection.rollback方法引用的一个点。
    SQLException
    提供有关数据库访问错误或其他错误的信息的异常。
    Wrapper
    提供在有问题的实例实际上是一个代理类时能够检索委托实例的JDBC类的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Wrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.sql
软件包 java.sql

Interface Wrapper

  • All Known Subinterfaces:
    CachedRowSet ， CallableStatement ， Connection ， DatabaseMetaData ， DataSource ， FilteredRowSet ， JdbcRowSet ， JoinRowSet ， ParameterMetaData ， PreparedStatement ， ResultSet ， ResultSetMetaData ， RowSet ， RowSetMetaData ， Statement ， SyncResolver ， WebRowSet
    所有已知实现类：
    RowSetMetaDataImpl

    public interface Wrapper
    提供在有问题的实例实际上是一个代理类时能够检索委托实例的JDBC类的接口。

    许多JDBC驱动程序实现使用包装器模式来提供超出传统JDBC API的扩展，这些扩展是特定于数据源的。 开发人员可能希望获得这些被包装的资源（代理）作为代表实际资源的代理类实例。 此接口描述了访问由其代理表示的这些包装资源的标准机制，以允许直接访问资源委托。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean isWrapperFor​(Class<?> iface)
      如果这实现了接口参数，或者直接或间接地为一个对象的包装器返回true。
      <T> T unwrap​(Class<T> iface)
      返回一个实现给定接口以允许访问非标准方法的对象，或代理不公开的标准方法。

    • 方法详细信息

      • unwrap

        <T> T unwrap​(Class<T> iface)
      throws SQLException
        返回一个实现给定接口以允许访问非标准方法的对象，或代理不公开的标准方法。 如果接收器实现接口，则结果是接收机或接收机的代理。 如果接收者是一个包装器，并且被包装的对象实现了接口，那么结果就是被包装对象或被包装对象的代理。 否则返回在包装对象或该结果的代理上递归调用unwrap结果。 如果接收者不是包装器，并且不实现接口，则抛出一个SQLException 。
        参数类型
        T - 由此Class对象建模的类的类型
        参数
        iface - 定义结果必须实现的接口的类。
        结果
        一个实现接口的对象。 可能是实际实现对象的代理。
        异常
        SQLException - 如果没有找到实现接口的对象
        从以下版本开始：
        1.6

      • isWrapperFor

        boolean isWrapperFor​(Class<?> iface)
              throws SQLException
        如果这实现了接口参数，或者直接或间接地为一个对象的包装器返回true。 否则返回false。 如果这实现了接口，那么返回true，否则如果这是一个包装器，那么返回在包装对象上递归调用isWrapperFor的结果。 如果这不实现接口并且不是包装器，则返回false。 与unwrap相比，此方法应作为低成本操作实现，以便呼叫者可以使用此方法来避免可能会失败的昂贵的unwrap调用。 如果此方法返回true，则使用相同参数调用unwrap应该会成功。
        参数
        iface - 定义接口的类。
        结果
        如果这实现了接口，或者直接或间接地包装一个对象，则为true。
        异常
        SQLException - 如果在确定是否是具有给定接口的对象的包装器时发生错误。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class java.sql.BatchUpdateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.BatchUpdateException

No usage of java.sql.BatchUpdateException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.ClientInfoStatus (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.ClientInfoStatus

  • Packages that use ClientInfoStatus
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of ClientInfoStatus in java.sql

      Methods in java.sql that return ClientInfoStatus
      Modifier and Type 方法 描述
      static ClientInfoStatus ClientInfoStatus.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ClientInfoStatus[] ClientInfoStatus.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.sql that return types with arguments of type ClientInfoStatus
      Modifier and Type 方法 描述
      Map<String,ClientInfoStatus> SQLClientInfoException.getFailedProperties​()
      返回无法设置的客户端信息属性列表。
      Constructor parameters in java.sql with type arguments of type ClientInfoStatus
      Constructor 描述
      SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， vendorCode和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause ， vendorCode和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause和 failedProperties 。
      SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException对象，初始化为给定的 reason和 failedProperties 。
      SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， cause和 failedProperties 。
      SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException对象，初始化为给定的 failedProperties 。
      SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException对象，初始化为给定的 cause和 failedProperties 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.DataTruncation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.DataTruncation

No usage of java.sql.DataTruncation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.Date (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.Date

  • Packages that use Date
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of Date in java.sql

      Methods in java.sql that return Date
      Modifier and Type 方法 描述
      Date CallableStatement.getDate​(int parameterIndex)
      以 java.sql.Date对象的形式获取指定的JDBC DATE参数的值。
      Date CallableStatement.getDate​(int parameterIndex, Calendar cal)
      以 java.sql.Date对象的形式获取指定的JDBC DATE参数的值，使用给定的 Calendar对象构造日期。
      Date CallableStatement.getDate​(String parameterName)
      以 java.sql.Date对象的形式检索JDBC DATE参数的值。
      Date CallableStatement.getDate​(String parameterName, Calendar cal)
      检索JDBC DATE参数的值作为 java.sql.Date对象，使用给定的 Calendar对象构造日期。
      Date ResultSet.getDate​(int columnIndex)
      这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Date的Java编程语言对象。
      Date ResultSet.getDate​(int columnIndex, Calendar cal)
      这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Date的Java编程语言对象。
      Date ResultSet.getDate​(String columnLabel)
      以Java编程语言中的 java.sql.Date对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      Date ResultSet.getDate​(String columnLabel, Calendar cal)
      这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Date的Java编程语言对象。
      Date SQLInput.readDate​()
      读取流中的下一个属性，并将其作为 java.sql.Date对象返回。
      static Date Date.valueOf​(String s)
      将JDBC日期转义格式的字符串转换为 Date值。
      static Date Date.valueOf​(LocalDate date)
      从一个LocalDate对象获取一个Date的实例，具有与给定的LocalDate相同的年，月和日的值。
      Methods in java.sql with parameters of type Date
      Modifier and Type 方法 描述
      void CallableStatement.setDate​(String parameterName, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void CallableStatement.setDate​(String parameterName, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void PreparedStatement.setDate​(int parameterIndex, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void PreparedStatement.setDate​(int parameterIndex, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void ResultSet.updateDate​(int columnIndex, Date x)
      使用 java.sql.Date值更新指定的列。
      void ResultSet.updateDate​(String columnLabel, Date x)
      使用 java.sql.Date值更新指定的列。
      void SQLOutput.writeDate​(Date x)
      将下一个属性作为java.sql.Date对象写入流。

    • Uses of Date in javax.sql

      Methods in javax.sql with parameters of type Date
      Modifier and Type 方法 描述
      void RowSet.setDate​(int parameterIndex, Date x)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.sql.Date值。
      void RowSet.setDate​(int parameterIndex, Date x, Calendar cal)
      使用给定的 java.sql.Date值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setDate​(String parameterName, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void RowSet.setDate​(String parameterName, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。

    • Uses of Date in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Date
      Modifier and Type 方法 描述
      void BaseRowSet.setDate​(int parameterIndex, Date x)
      将指定的参数设置为给定的 java.sql.Date值。
      void BaseRowSet.setDate​(int parameterIndex, Date x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Date对象。
      void BaseRowSet.setDate​(String parameterName, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void BaseRowSet.setDate​(String parameterName, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。

    • Uses of Date in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return Date
      Modifier and Type 方法 描述
      Date SQLInputImpl.readDate​()
      检索此 SQLInputImpl的下一个属性为 java.sql.Date对象。
      Methods in javax.sql.rowset.serial with parameters of type Date
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeDate​(Date x)
      将Java编程语言中的一个 java.sql.Date对象写入此 SQLOutputImpl对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.DriverManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.DriverManager

No usage of java.sql.DriverManager
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.DriverPropertyInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.DriverPropertyInfo

  • Packages that use DriverPropertyInfo
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of DriverPropertyInfo in java.sql

      Methods in java.sql that return DriverPropertyInfo
      Modifier and Type 方法 描述
      DriverPropertyInfo[] Driver.getPropertyInfo​(String url, Properties info)
      获取有关此驱动程序可能属性的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.JDBCType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.JDBCType

  • Packages that use JDBCType
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of JDBCType in java.sql

      Methods in java.sql that return JDBCType
      Modifier and Type 方法 描述
      static JDBCType JDBCType.valueOf​(int type)
      返回 JDBCType对应于指定 Types值
      static JDBCType JDBCType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static JDBCType[] JDBCType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.PseudoColumnUsage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.PseudoColumnUsage

  • Packages that use PseudoColumnUsage
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of PseudoColumnUsage in java.sql

      Methods in java.sql that return PseudoColumnUsage
      Modifier and Type 方法 描述
      static PseudoColumnUsage PseudoColumnUsage.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PseudoColumnUsage[] PseudoColumnUsage.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.RowIdLifetime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.RowIdLifetime

  • Packages that use RowIdLifetime
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of RowIdLifetime in java.sql

      Methods in java.sql that return RowIdLifetime
      Modifier and Type 方法 描述
      RowIdLifetime DatabaseMetaData.getRowIdLifetime​()
      指示此数据源是否支持SQL ROWID类型，以及RowId对象保持有效的生命周期。
      static RowIdLifetime RowIdLifetime.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static RowIdLifetime[] RowIdLifetime.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLClientInfoException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLClientInfoException

  • Packages that use SQLClientInfoException
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of SQLClientInfoException in java.sql

      Methods in java.sql that throw SQLClientInfoException
      Modifier and Type 方法 描述
      void Connection.setClientInfo​(String name, String value)
      将由name指定的客户端信息属性的值设置为由值指定的值。
      void Connection.setClientInfo​(Properties properties)
      设置连接的客户端信息属性的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLDataException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLDataException

No usage of java.sql.SQLDataException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLException

  • Packages that use SQLException
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。

    • Uses of SQLException in java.sql

      Subclasses of SQLException in java.sql
      Modifier and Type Class 描述
      class  BatchUpdateException
      在批量更新操作期间发生错误时抛出的SQLException的子类。
      class  DataTruncation
      由于其超出 MaxFieldSize原因而导致数据值意外截断时，异常抛出 DataTruncation异常（写入）或报告为 DataTruncation警告（读取时）。
      class  SQLClientInfoException
      当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。
      class  SQLDataException
      当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLFeatureNotSupportedException
      当SQLState类的值为' 0A '（值为'零'A）时，抛出SQLException的子类。
      class  SQLIntegrityConstraintViolationException
      当SQLState类值为“ 23 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLInvalidAuthorizationSpecException
      当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLNonTransientConnectionException
      针对SQLState类值“ 08 ”或在供应商指定的条件下抛出的子类为SQLException 。
      class  SQLNonTransientException
      当一个重试相同操作的实例将失败的情况下抛出SQLException的子类，除非修正了原因SQLException 。
      class  SQLRecoverableException
      如果应用程序执行某些恢复步骤并重试整个事务，或者在分布式事务（即事务分支）的情况下，先前发生故障的操作可能能够成功的子类抛出SQLException 。
      class  SQLSyntaxErrorException
      当SQLState类值为“ 42 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTimeoutException
      的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。
      class  SQLTransactionRollbackException
      当SQLState类值为“ 40 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTransientConnectionException
      SQLState类值为“ 08 ”的SQLException的子类，或供应商指定的条件。
      class  SQLTransientException
      SQLException的子类被抛出在以前失败的操作可能能够成功的情况下，当操作被重试而没有任何干预的应用程序级功能。
      class  SQLWarning
      提供有关数据库访问警告的信息的异常。
      Methods in java.sql that return SQLException
      Modifier and Type 方法 描述
      SQLException SQLException.getNextException​()
      通过setNextException（SQLException ex）获取链接到此 SQLException对象的异常。
      Methods in java.sql with parameters of type SQLException
      Modifier and Type 方法 描述
      void SQLException.setNextException​(SQLException ex)
      将一个 SQLException对象添加到链的末尾。
      Methods in java.sql that throw SQLException
      Modifier and Type 方法 描述
      void Connection.abort​(Executor executor)
      终止打开的连接。
      boolean ResultSet.absolute​(int row)
      将光标移动到此 ResultSet对象中的给定行号。
      boolean Driver.acceptsURL​(String url)
      检索驱动程序是否认为可以打开与给定URL的连接。
      void PreparedStatement.addBatch​()
      向这个 PreparedStatement对象的一批命令添加一组参数。
      void Statement.addBatch​(String sql)
      将给定的SQL命令添加到此 Statement对象的当前命令列表中。
      void ResultSet.afterLast​()
      将光标移动到此 ResultSet对象的末尾，就在最后一行之后。
      boolean DatabaseMetaData.allProceduresAreCallable​()
      检索当前用户是否可以调用方法返回的所有过程 getProcedures 。
      boolean DatabaseMetaData.allTablesAreSelectable​()
      检索当前用户是否可以使用方法 getTables在 SELECT语句中返回的所有表。
      boolean DatabaseMetaData.autoCommitFailureClosesAllResultSets​()
      检索一个 SQLException而autoCommit是 true表示所有打开的ResultSet都是关闭的，即使是可保存的。
      void ResultSet.beforeFirst​()
      将光标移动到此 ResultSet对象的正面，就在第一行之前。
      default void Connection.beginRequest​()
      向司机提示，一个请求，一个独立的工作单位，正在开始这个连接。
      Connection ConnectionBuilder.build​()
      返回由此构建器定义的对象的实例。
      ShardingKey ShardingKeyBuilder.build​()
      返回由此构建器定义的对象的实例。
      void Statement.cancel​()
      如果DBMS和驱动程序都支持中止SQL语句，则取消此 Statement对象。
      void ResultSet.cancelRowUpdates​()
      取消对此 ResultSet对象中当前行所做的更新。
      void Statement.clearBatch​()
      清空此 Statement对象的当前SQL命令列表。
      void PreparedStatement.clearParameters​()
      立即清除当前参数值。
      void Connection.clearWarnings​()
      清除为此 Connection对象报告的所有警告。
      void ResultSet.clearWarnings​()
      清除此 ResultSet对象上报告的所有警告。
      void Statement.clearWarnings​()
      清除在此 Statement对象上报告的所有警告。
      void Connection.close​()
      立即释放此 Connection对象的数据库和JDBC资源，而不是等待它们自动释放。
      void ResultSet.close​()
      立即释放此 ResultSet对象的数据库和JDBC资源，而不是等待其自动关闭时发生。
      void Statement.close​()
      立即释放此 Statement对象的数据库和JDBC资源，而不是等待其自动关闭时发生。
      void Statement.closeOnCompletion​()
      指定当其所有相关结果集都关闭时，此 Statement将关闭。
      void Connection.commit​()
      使之前进行的所有更改都是永久性的，并释放此 Connection对象当前持有的数据库锁。
      Connection Driver.connect​(String url, Properties info)
      尝试使数据库连接到给定的URL。
      Array Connection.createArrayOf​(String typeName, Object[] elements)
      用于创建Array对象的Factory方法。
      Blob Connection.createBlob​()
      构造实现 Blob接口的对象。
      Clob Connection.createClob​()
      构造一个实现 Clob接口的对象。
      NClob Connection.createNClob​()
      构造一个实现 NClob接口的对象。
      SQLXML Connection.createSQLXML​()
      构造一个实现 SQLXML接口的对象。
      Statement Connection.createStatement​()
      创建一个 Statement对象，用于将SQL语句发送到数据库。
      Statement Connection.createStatement​(int resultSetType, int resultSetConcurrency)
      创建一个 Statement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
      Statement Connection.createStatement​(int resultSetType, int resultSetConcurrency, int resultSetHoldability)
      创建一个 Statement对象，该对象将生成具有给定类型，并发和 ResultSet对象。
      Struct Connection.createStruct​(String typeName, Object[] attributes)
      用于创建Struct对象的工厂方法。
      boolean DatabaseMetaData.dataDefinitionCausesTransactionCommit​()
      检索事务中的数据定义语句是否强制事务提交。
      boolean DatabaseMetaData.dataDefinitionIgnoredInTransactions​()
      检索此数据库是否忽略事务中的数据定义语句。
      void ResultSet.deleteRow​()
      从此 ResultSet对象和底层数据库中删除当前行。
      boolean DatabaseMetaData.deletesAreDetected​(int type)
      检索是否通过调用方法 ResultSet.rowDeleted检测到可见行删除。
      static void DriverManager.deregisterDriver​(Driver driver)
      从 DriverManager的注册驱动程序列表中删除指定的驱动程序。
      boolean DatabaseMetaData.doesMaxRowSizeIncludeBlobs​()
      检索方法 getMaxRowSize的返回值是否包含SQL数据类型 LONGVARCHAR和 LONGVARBINARY 。
      default void Connection.endRequest​()
      向司机提示，要求，独立工作单位已经完成。
      default String Statement.enquoteIdentifier​(String identifier, boolean alwaysQuote)
      返回一个SQL标识符。
      default String Statement.enquoteLiteral​(String val)
      返回一个用引号括起来的 String 。
      default String Statement.enquoteNCharLiteral​(String val)
      返回一个 String代表一个用单引号括起来的前缀为大写字母N的国家字符集文字。
      boolean PreparedStatement.execute​()
      执行此 PreparedStatement对象中的SQL语句，可能是任何类型的SQL语句。
      boolean Statement.execute​(String sql)
      执行给定的SQL语句，这可能会返回多个结果。
      boolean Statement.execute​(String sql, int autoGeneratedKeys)
      执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出任何自动生成的密钥应该可用于检索。
      boolean Statement.execute​(String sql, int[] columnIndexes)
      执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      boolean Statement.execute​(String sql, String[] columnNames)
      执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      int[] Statement.executeBatch​()
      将一批命令提交到数据库以执行，并且所有命令都执行成功，返回一个更新计数的数组。
      default long[] Statement.executeLargeBatch​()
      将一批命令提交到数据库以执行，并且所有命令都执行成功，返回一个更新计数的数组。
      default long PreparedStatement.executeLargeUpdate​()
      执行在该SQL语句PreparedStatement对象，它必须是一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
      default long Statement.executeLargeUpdate​(String sql)
      执行给定的SQL语句，这可能是 INSERT ， UPDATE ，或 DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。
      default long Statement.executeLargeUpdate​(String sql, int autoGeneratedKeys)
      执行给定的SQL语句，并用给定的标志来向驱动程序发出信号，指出这个 Statement对象产生的自动生成的密钥是否应该可用于检索。
      default long Statement.executeLargeUpdate​(String sql, int[] columnIndexes)
      执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      default long Statement.executeLargeUpdate​(String sql, String[] columnNames)
      执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      ResultSet PreparedStatement.executeQuery​()
      执行此 PreparedStatement对象中的SQL查询，并返回查询生成的 ResultSet对象。
      ResultSet Statement.executeQuery​(String sql)
      执行给定的SQL语句，返回一个 ResultSet对象。
      int PreparedStatement.executeUpdate​()
      执行在该SQL语句PreparedStatement对象，它必须是一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
      int Statement.executeUpdate​(String sql)
      执行给定的SQL语句，这可能是 INSERT ， UPDATE ，或 DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。
      int Statement.executeUpdate​(String sql, int autoGeneratedKeys)
      执行给定的SQL语句并用给定的标志来向驱动程序发出信号，指出这个 Statement对象产生的自动生成的密钥是否应该可用于检索。
      int Statement.executeUpdate​(String sql, int[] columnIndexes)
      执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      int Statement.executeUpdate​(String sql, String[] columnNames)
      执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
      int ResultSet.findColumn​(String columnLabel)
      将给定的 ResultSet列标签映射到其 ResultSet列索引。
      boolean ResultSet.first​()
      将光标移动到此 ResultSet对象中的第一行。
      void Array.free​()
      该方法可以释放 Array对象并释放它所拥有的资源。
      void Blob.free​()
      该方法可以释放 Blob对象并释放它所拥有的资源。
      void Clob.free​()
      此方法释放 Clob对象所持有的资源。
      void SQLXML.free​()
      此方法关闭此对象并释放其持有的资源。
      boolean DatabaseMetaData.generatedKeyAlwaysReturned​()
      检索如果为自动生成的密钥列指定的列名称或索引有效并且语句成功，将始终返回生成的密钥。
      Object Array.getArray​()
      以Java编程语言的形式 Array由该 Array对象指定的SQL ARRAY值的内容。
      Object Array.getArray​(long index, int count)
      检索由该 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。
      Object Array.getArray​(long index, int count, Map<String,Class<?>> map)
      检索由该 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。
      Object Array.getArray​(Map<String,Class<?>> map)
      检索此 Array对象指定的SQL ARRAY值的内容。
      Array CallableStatement.getArray​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC ARRAY参数的值作为Array对象。
      Array CallableStatement.getArray​(String parameterName)
      以Java编程语言作为Array对象检索JDBC ARRAY参数的值。
      Array ResultSet.getArray​(int columnIndex)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 Array对象。
      Array ResultSet.getArray​(String columnLabel)
      以Java编程语言中的 ResultSet对象的形式， Array此 ResultSet对象的当前行中指定列的值。
      InputStream Clob.getAsciiStream​()
      检索由该 Clob对象指定的 CLOB值作为ascii流。
      InputStream ResultSet.getAsciiStream​(int columnIndex)
      将此 ResultSet对象的当前行中指定列的值作为ASCII字符流 ResultSet 。
      InputStream ResultSet.getAsciiStream​(String columnLabel)
      将此 ResultSet对象的当前行中指定列的值作为ASCII字符流 ResultSet 。
      ResultSet DatabaseMetaData.getAttributes​(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern)
      检索给定模式和目录中可用的用户定义类型（UDT）给定类型的给定属性的描述。
      Object[] Struct.getAttributes​()
      生成此 Struct对象表示的SQL结构化类型的属性的有序值。
      Object[] Struct.getAttributes​(Map<String,Class<?>> map)
      生成此 Struct对象表示的SQL结构化类型的属性的有序值。
      boolean Connection.getAutoCommit​()
      检索此 Connection对象的当前自动提交模式。
      int Array.getBaseType​()
      检索由该 Array对象指定的数组中的元素的JDBC类型。
      String Array.getBaseTypeName​()
      检索此 Array对象指定的数组中的元素的SQL类型名称。
      String Ref.getBaseTypeName​()
      检索此 Ref对象引用的SQL结构化类型的全限定SQL名称。
      ResultSet DatabaseMetaData.getBestRowIdentifier​(String catalog, String schema, String table, int scope, boolean nullable)
      检索表的唯一标识行的最佳列集描述。
      BigDecimal CallableStatement.getBigDecimal​(int parameterIndex)
      将指定的JDBC NUMERIC参数的值作为 java.math.BigDecimal对象检索，该对象的值包含小数点右侧的数字。
      BigDecimal CallableStatement.getBigDecimal​(int parameterIndex, int scale)
      已过时。
      请使用getBigDecimal(int parameterIndex)或getBigDecimal(String parameterName)
      BigDecimal CallableStatement.getBigDecimal​(String parameterName)
      检索JDBC NUMERIC参数的值作为 java.math.BigDecimal对象，其值包含小数点右侧的数字。
      BigDecimal ResultSet.getBigDecimal​(int columnIndex)
      以 ResultSet作为 java.math.BigDecimal全面精确检索此 ResultSet对象当前行中指定列的值。
      BigDecimal ResultSet.getBigDecimal​(int columnIndex, int scale)
      已过时。
      使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
      BigDecimal ResultSet.getBigDecimal​(String columnLabel)
      以 ResultSet对象的当前行中的指定列的值 java.math.BigDecimal完整的精度。
      BigDecimal ResultSet.getBigDecimal​(String columnLabel, int scale)
      已过时。
      使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
      InputStream Blob.getBinaryStream​()
      检索由该 Blob实例指定的 BLOB值作为流。
      InputStream Blob.getBinaryStream​(long pos, long length)
      返回一个包含部分 Blob值的 InputStream对象，从pos指定的字节开始，长度为长度字节。
      InputStream ResultSet.getBinaryStream​(int columnIndex)
      将此 ResultSet对象的当前行中的指定列的值作为未解释的字节流 ResultSet 。
      InputStream ResultSet.getBinaryStream​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值，作为未解释的流 byte s。
      InputStream SQLXML.getBinaryStream​()
      检索此SQLXML实例指定的XML值作为流。
      Blob CallableStatement.getBlob​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC BLOB参数的值作为Blob对象。
      Blob CallableStatement.getBlob​(String parameterName)
      以Java编程语言中的Blob对象的形式获取 JDBC BLOB参数的值。
      Blob ResultSet.getBlob​(int columnIndex)
      以Java编程语言中的 ResultSet对象的形式 Blob此 ResultSet对象的当前行中指定列的值。
      Blob ResultSet.getBlob​(String columnLabel)
      以Java编程语言中的 ResultSet对象的形式 Blob此 ResultSet对象当前行中指定列的值。
      boolean CallableStatement.getBoolean​(int parameterIndex)
      获取指定的JDBC的价值 BIT或者 BOOLEAN作为参数 boolean Java编程语言。
      boolean CallableStatement.getBoolean​(String parameterName)
      以Java编程语言中的 boolean JDBC BIT或 BOOLEAN参数的值。
      boolean ResultSet.getBoolean​(int columnIndex)
      以Java编程语言中的 boolean此 ResultSet对象的当前行中指定列的值。
      boolean ResultSet.getBoolean​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 boolean 。
      byte CallableStatement.getByte​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC TINYINT参数的值作为 byte 。
      byte CallableStatement.getByte​(String parameterName)
      以Java编程语言中的 byte JDBC TINYINT参数的值。
      byte ResultSet.getByte​(int columnIndex)
      以Java编程语言中的 byte该 ResultSet对象的当前行中指定列的值。
      byte ResultSet.getByte​(String columnLabel)
      以Java编程语言中的 byte该 ResultSet对象的当前行中指定列的值。
      byte[] Blob.getBytes​(long pos, int length)
      检索该 Blob对象所代表的 BLOB全部或部分值，作为字节数组。
      byte[] CallableStatement.getBytes​(int parameterIndex)
      以Java编程语言中的 byte数组的形式 byte指定的JDBC BINARY或 VARBINARY参数的值。
      byte[] CallableStatement.getBytes​(String parameterName)
      检索JDBC BINARY或 VARBINARY参数的值，作为Java编程语言中的 byte数组。
      byte[] ResultSet.getBytes​(int columnIndex)
      以该Java编程语言的 byte数组的形式，将此 ResultSet对象的当前行中的指定列的值检索。
      byte[] ResultSet.getBytes​(String columnLabel)
      以该Java编程语言的 byte数组的形式，检索此 ResultSet对象的当前行中指定列的值。
      String Connection.getCatalog​()
      检索此 Connection对象的当前目录名称。
      String ResultSetMetaData.getCatalogName​(int column)
      获取指定列的表的目录名称。
      ResultSet DatabaseMetaData.getCatalogs​()
      检索此数据库中可用的目录名称。
      String DatabaseMetaData.getCatalogSeparator​()
      检索此数据库用作目录和表名之间的分隔符的 String 。
      String DatabaseMetaData.getCatalogTerm​()
      检索“目录”的数据库供应商的首选项。
      Reader CallableStatement.getCharacterStream​(int parameterIndex)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      Reader CallableStatement.getCharacterStream​(String parameterName)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      Reader Clob.getCharacterStream​()
      检索由 Clob对象指定的 java.io.Reader对象（或作为字符流）的 CLOB值。
      Reader Clob.getCharacterStream​(long pos, long length)
      返回一个包含部分 Clob值的 Reader对象，以pos指定的字符开头，长度为长度字符。
      Reader ResultSet.getCharacterStream​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值作为 java.io.Reader对象。
      Reader ResultSet.getCharacterStream​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值作为 java.io.Reader对象。
      Reader SQLXML.getCharacterStream​()
      将此SQLXML实例指定的XML值作为java.io.Reader对象检索。
      Properties Connection.getClientInfo​()
      返回包含驱动程序支持的每个客户端信息属性的名称和当前值的列表。
      String Connection.getClientInfo​(String name)
      返回由name指定的客户端信息属性的值。
      ResultSet DatabaseMetaData.getClientInfoProperties​()
      检索驱动程序支持的客户端信息属性的列表。
      Clob CallableStatement.getClob​(int parameterIndex)
      以Java编程语言 java.sql.Clob指定的JDBC CLOB参数的值作为 java.sql.Clob对象。
      Clob CallableStatement.getClob​(String parameterName)
      以Java编程语言中的一个 java.sql.Clob对象获取JDBC CLOB参数的值。
      Clob ResultSet.getClob​(int columnIndex)
      以Java编程语言中的 Clob对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      Clob ResultSet.getClob​(String columnLabel)
      这个检索的当前行中指定列的值 ResultSet对象为 Clob的Java编程语言对象。
      String ResultSetMetaData.getColumnClassName​(int column)
      如果调用方法 ResultSet.getObject以从列中检索值，则返回其实例生成的Java类的完全限定名称。
      int ResultSetMetaData.getColumnCount​()
      返回此 ResultSet对象中的列数。
      int ResultSetMetaData.getColumnDisplaySize​(int column)
      指定指定列的正常最大宽度（以字符为单位）。
      String ResultSetMetaData.getColumnLabel​(int column)
      获取指定列的建议标题用于打印输出和显示。
      String ResultSetMetaData.getColumnName​(int column)
      获取指定列的名称。
      ResultSet DatabaseMetaData.getColumnPrivileges​(String catalog, String schema, String table, String columnNamePattern)
      检索表的列的访问权限的描述。
      ResultSet DatabaseMetaData.getColumns​(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
      检索指定目录中可用的表列的描述。
      int ResultSetMetaData.getColumnType​(int column)
      检索指定列的SQL类型。
      String ResultSetMetaData.getColumnTypeName​(int column)
      检索指定列的数据库特定类型名称。
      int ResultSet.getConcurrency​()
      检索此 ResultSet对象的并发模式。
      Connection DatabaseMetaData.getConnection​()
      检索生成此元数据对象的连接。
      static Connection DriverManager.getConnection​(String url)
      尝试建立与给定数据库URL的连接。
      static Connection DriverManager.getConnection​(String url, String user, String password)
      尝试建立与给定数据库URL的连接。
      static Connection DriverManager.getConnection​(String url, Properties info)
      尝试建立与给定数据库URL的连接。
      Connection Statement.getConnection​()
      检索 Connection生成此对象 Statement对象。
      ResultSet DatabaseMetaData.getCrossReference​(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable)
      检索引用主键的给定外键表中的外键列的描述，或表示父表的唯一约束的列（可以是相同或不同的表）。
      String ResultSet.getCursorName​()
      检索此 ResultSet对象使用的SQL游标的名称。
      int DatabaseMetaData.getDatabaseMajorVersion​()
      检索底层数据库的主版本号。
      int DatabaseMetaData.getDatabaseMinorVersion​()
      检索底层数据库的次要版本号。
      String DatabaseMetaData.getDatabaseProductName​()
      检索此数据库产品的名称。
      String DatabaseMetaData.getDatabaseProductVersion​()
      检索此数据库产品的版本号。
      Date CallableStatement.getDate​(int parameterIndex)
      以 java.sql.Date对象的形式获取指定的JDBC DATE参数的值。
      Date CallableStatement.getDate​(int parameterIndex, Calendar cal)
      检索指定的JDBC DATE参数的值作为 java.sql.Date对象，使用给定的 Calendar对象构造日期。
      Date CallableStatement.getDate​(String parameterName)
      以 java.sql.Date对象的形式 java.sql.Date JDBC DATE参数的值。
      Date CallableStatement.getDate​(String parameterName, Calendar cal)
      使用给定的 Calendar对象来构造日期，将JDBC DATE参数的值检索为 java.sql.Date对象。
      Date ResultSet.getDate​(int columnIndex)
      检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Date对象。
      Date ResultSet.getDate​(int columnIndex, Calendar cal)
      以Java编程语言中的 java.sql.Date对象获取此 ResultSet对象的当前行中指定列的值。
      Date ResultSet.getDate​(String columnLabel)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Date对象。
      Date ResultSet.getDate​(String columnLabel, Calendar cal)
      以Java编程语言中的 ResultSet对象的形式 java.sql.Date该 ResultSet对象的当前行中指定列的值。
      int DatabaseMetaData.getDefaultTransactionIsolation​()
      检索此数据库的默认事务隔离级别。
      double CallableStatement.getDouble​(int parameterIndex)
      以Java编程语言中的 double指定的JDBC DOUBLE参数的值。
      double CallableStatement.getDouble​(String parameterName)
      以Java编程语言中的 double JDBC DOUBLE参数的值。
      double ResultSet.getDouble​(int columnIndex)
      检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 double 。
      double ResultSet.getDouble​(String columnLabel)
      以Java编程语言中的 double此 ResultSet对象的当前行中指定列的值。
      static Driver DriverManager.getDriver​(String url)
      尝试查找了解给定URL的驱动程序。
      String DatabaseMetaData.getDriverName​()
      检索此JDBC驱动程序的名称。
      String DatabaseMetaData.getDriverVersion​()
      以 String检索此JDBC驱动程序的版本号。
      ResultSet DatabaseMetaData.getExportedKeys​(String catalog, String schema, String table)
      检索引用给定表的主键列（由表导出的外键）的外键列的描述。
      String DatabaseMetaData.getExtraNameCharacters​()
      检索可用于未引号的标识符名称（超出az，AZ，0-9和_）的所有“额外”字符。
      int ResultSet.getFetchDirection​()
      检索此 ResultSet对象的抓取方向。
      int Statement.getFetchDirection​()
      检索从数据库表中获取行的方向，这是从此 Statement对象生成的结果集的默认值。
      int ResultSet.getFetchSize​()
      检索此 ResultSet对象的提取大小。
      int Statement.getFetchSize​()
      检索结果集合的行数是默认为获取大小 ResultSet从该生成的对象 Statement对象。
      float CallableStatement.getFloat​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC FLOAT参数的值作为 float 。
      float CallableStatement.getFloat​(String parameterName)
      以Java编程语言中的 float JDBC FLOAT参数的值。
      float ResultSet.getFloat​(int columnIndex)
      以Java编程语言中的 float该 ResultSet对象的当前行中指定列的值。
      float ResultSet.getFloat​(String columnLabel)
      以Java编程语言中的 float此 ResultSet对象的当前行中指定列的值。
      ResultSet DatabaseMetaData.getFunctionColumns​(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern)
      检索给定目录的系统或用户功能参数和返回类型的描述。
      ResultSet DatabaseMetaData.getFunctions​(String catalog, String schemaPattern, String functionNamePattern)
      检索给定目录中可用的系统和用户功能的描述。
      ResultSet Statement.getGeneratedKeys​()
      检索由执行此 Statement对象而创建的任何自动生成的密钥。
      int Connection.getHoldability​()
      检索使用此 Connection对象创建的 ResultSet对象的当前可 Connection 。
      int ResultSet.getHoldability​()
      检索此 ResultSet对象的 ResultSet
      String DatabaseMetaData.getIdentifierQuoteString​()
      检索用于引用SQL标识符的字符串。
      ResultSet DatabaseMetaData.getImportedKeys​(String catalog, String schema, String table)
      检索给定表的外键列（由表导入的主键）引用的主键列的描述。
      ResultSet DatabaseMetaData.getIndexInfo​(String catalog, String schema, String table, boolean unique, boolean approximate)
      检索给定表的索引和统计信息的描述。
      int CallableStatement.getInt​(int parameterIndex)
      以Java编程语言的形式 int指定的JDBC INTEGER参数的值作为 int 。
      int CallableStatement.getInt​(String parameterName)
      以Java编程语言中的 int JDBC INTEGER参数的值。
      int ResultSet.getInt​(int columnIndex)
      以Java编程语言中的 int此 ResultSet对象当前行中指定列的值。
      int ResultSet.getInt​(String columnLabel)
      以Java编程语言中的 int此 ResultSet对象的当前行中指定列的值。
      int DatabaseMetaData.getJDBCMajorVersion​()
      检索此驱动程序的主要JDBC版本号。
      int DatabaseMetaData.getJDBCMinorVersion​()
      检索此驱动程序的次要JDBC版本号。
      default long Statement.getLargeMaxRows​()
      检索一个的最大行数 ResultSet由此产生对象 Statement对象可以包含。
      default long Statement.getLargeUpdateCount​()
      将当前结果作为更新计数检索; 如果结果是一个ResultSet对象或没有更多结果，则返回-1。
      long CallableStatement.getLong​(int parameterIndex)
      以Java编程语言中的 long指定的JDBC BIGINT参数的值。
      long CallableStatement.getLong​(String parameterName)
      以Java编程语言中的 long JDBC BIGINT参数的值。
      long ResultSet.getLong​(int columnIndex)
      以Java编程语言中的 long此 ResultSet对象的当前行中指定列的值。
      long ResultSet.getLong​(String columnLabel)
      以Java编程语言中的 long此 ResultSet对象当前行中指定列的值。
      int DatabaseMetaData.getMaxBinaryLiteralLength​()
      检索数据库允许的内联二进制文字的最大十六进制数。
      int DatabaseMetaData.getMaxCatalogNameLength​()
      检索此数据库在目录名称中允许的最大字符数。
      int DatabaseMetaData.getMaxCharLiteralLength​()
      检索此数据库允许使用字符文字的最大字符数。
      int DatabaseMetaData.getMaxColumnNameLength​()
      检索此数据库允许列名称的最大字符数。
      int DatabaseMetaData.getMaxColumnsInGroupBy​()
      检索 GROUP BY子句中数据库允许的最大列数。
      int DatabaseMetaData.getMaxColumnsInIndex​()
      检索数据库在索引中允许的最大列数。
      int DatabaseMetaData.getMaxColumnsInOrderBy​()
      检索 ORDER BY子句中数据库允许的最大列数。
      int DatabaseMetaData.getMaxColumnsInSelect​()
      检索 SELECT列表中数据库允许的最大列数。
      int DatabaseMetaData.getMaxColumnsInTable​()
      检索数据库在表中允许的最大列数。
      int DatabaseMetaData.getMaxConnections​()
      检索可能的此数据库的最大并发连接数。
      int DatabaseMetaData.getMaxCursorNameLength​()
      检索该数据库在游标名称中允许的最大字符数。
      int Statement.getMaxFieldSize​()
      检索由 ResultSet对象生成的 Statement对象中的字符和二进制列值可以返回的最大字节数。
      int DatabaseMetaData.getMaxIndexLength​()
      检索数据库允许索引的最大字节数，包括索引的所有部分。
      default long DatabaseMetaData.getMaxLogicalLobSize​()
      检索数据库允许 LOB的逻辑大小的最大字节数。
      int DatabaseMetaData.getMaxProcedureNameLength​()
      检索此数据库在过程名称中允许的最大字符数。
      int Statement.getMaxRows​()
      检索一个的最大行数 ResultSet由此产生对象 Statement对象可以包含。
      int DatabaseMetaData.getMaxRowSize​()
      检索数据库在单行中允许的最大字节数。
      int DatabaseMetaData.getMaxSchemaNameLength​()
      检索此数据库在模式名称中允许的最大字符数。
      int DatabaseMetaData.getMaxStatementLength​()
      检索数据库在SQL语句中允许的最大字符数。
      int DatabaseMetaData.getMaxStatements​()
      检索可以同时打开的此数据库的活动语句的最大数量。
      int DatabaseMetaData.getMaxTableNameLength​()
      检索数据库在表名中允许的最大字符数。
      int DatabaseMetaData.getMaxTablesInSelect​()
      在 SELECT语句中检索此数据库允许的最大表数。
      int DatabaseMetaData.getMaxUserNameLength​()
      检索数据库在用户名中允许的最大字符数。
      DatabaseMetaData Connection.getMetaData​()
      检索 DatabaseMetaData对象，该对象包含此 Connection对象表示连接的数据库的元数据。
      ResultSetMetaData PreparedStatement.getMetaData​()
      检索 ResultSetMetaData对象，其中包含有关执行此 PreparedStatement对象时将返回的 ResultSet对象的列的信息。
      ResultSetMetaData ResultSet.getMetaData​()
      检索此 ResultSet对象列的数量，类型和属性。
      boolean Statement.getMoreResults​()
      移动到这个 Statement对象的下一个结果，如果它是一个 ResultSet对象，返回 true ，并隐式关闭使用方法 getResultSet获取的任何当前的 ResultSet对象。
      boolean Statement.getMoreResults​(int current)
      移动到此 Statement对象的下一个结果，根据给定标志指定的指令处理任何当前的 ResultSet对象，如果下一个结果是一个 ResultSet对象，则返回 true 。
      Reader CallableStatement.getNCharacterStream​(int parameterIndex)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      Reader CallableStatement.getNCharacterStream​(String parameterName)
      以Java编程语言中的 java.io.Reader对象获取指定参数的值。
      Reader ResultSet.getNCharacterStream​(int columnIndex)
      检索 ResultSet对象的当前行中指定列的值作为 java.io.Reader对象。
      Reader ResultSet.getNCharacterStream​(String columnLabel)
      检索 ResultSet对象的当前行中指定列的值作为 java.io.Reader对象。
      NClob CallableStatement.getNClob​(int parameterIndex)
      以Java编程语言 java.sql.NClob指定的JDBC NCLOB参数的值作为 java.sql.NClob对象。
      NClob CallableStatement.getNClob​(String parameterName)
      以Java编程语言作为 java.sql.NClob对象检索JDBC NCLOB参数的值。
      NClob ResultSet.getNClob​(int columnIndex)
      以Java编程语言中的 NClob对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      NClob ResultSet.getNClob​(String columnLabel)
      这个检索的当前行中指定列的值 ResultSet对象为 NClob的Java编程语言对象。
      int Connection.getNetworkTimeout​()
      检索驱动程序等待数据库请求完成的毫秒数。
      String CallableStatement.getNString​(int parameterIndex)
      检索指定的值 NCHAR ， NVARCHAR或者 LONGNVARCHAR参数为 String的Java编程语言。
      String CallableStatement.getNString​(String parameterName)
      检索指定的值 NCHAR ， NVARCHAR或者 LONGNVARCHAR参数为 String的Java编程语言。
      String ResultSet.getNString​(int columnIndex)
      以Java编程语言中的 String此 ResultSet对象的当前行中指定列的值。
      String ResultSet.getNString​(String columnLabel)
      以Java编程语言中的 String此 ResultSet对象当前行中指定列的值。
      String DatabaseMetaData.getNumericFunctions​()
      检索此数据库可用的逗号分隔的数学函数列表。
      Object CallableStatement.getObject​(int parameterIndex)
      以Java编程语言中的 Object指定参数的值。
      <T> T CallableStatement.getObject​(int parameterIndex, Class<T> type)
      返回表示OUT参数 parameterIndex的值的对象，并将转换为参数的SQL类型到所请求的Java数据类型，如果支持转换。
      Object CallableStatement.getObject​(int parameterIndex, Map<String,Class<?>> map)
      返回表示OUT参数 parameterIndex的值的对象，并使用参数值的自定义映射 map 。
      Object CallableStatement.getObject​(String parameterName)
      以Java编程语言中的 Object参数的值。
      <T> T CallableStatement.getObject​(String parameterName, Class<T> type)
      返回表示OUT参数 parameterName的值的对象，并将转换为参数的SQL类型到所请求的Java数据类型，如果支持转换。
      Object CallableStatement.getObject​(String parameterName, Map<String,Class<?>> map)
      返回表示OUT参数 parameterName的值的对象，并使用 map作为参数值的自定义映射。
      Object Ref.getObject​()
      检索此 Ref对象引用的SQL结构类型实例。
      Object Ref.getObject​(Map<String,Class<?>> map)
      检索引用的对象，并使用给定的类型映射将其映射到Java类型。
      Object ResultSet.getObject​(int columnIndex)
      获取此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Object 。
      <T> T ResultSet.getObject​(int columnIndex, Class<T> type)
      检索此 ResultSet对象当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。
      Object ResultSet.getObject​(int columnIndex, Map<String,Class<?>> map)
      以Java编程语言中的 Object此 ResultSet对象当前行中指定列的值。
      Object ResultSet.getObject​(String columnLabel)
      获取此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Object 。
      <T> T ResultSet.getObject​(String columnLabel, Class<T> type)
      检索此 ResultSet对象当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。
      Object ResultSet.getObject​(String columnLabel, Map<String,Class<?>> map)
      以Java编程语言中的 Object此 ResultSet对象的当前行中指定列的值。
      String ParameterMetaData.getParameterClassName​(int param)
      检索要将其实例传递给方法的Java类的完全限定名称 PreparedStatement.setObject 。
      int ParameterMetaData.getParameterCount​()
      检索此 ParameterMetaData对象包含信息的 PreparedStatement对象中的参数数。
      ParameterMetaData PreparedStatement.getParameterMetaData​()
      检索此 PreparedStatement对象参数的数量，类型和属性。
      int ParameterMetaData.getParameterMode​(int param)
      检索指定参数的模式。
      int ParameterMetaData.getParameterType​(int param)
      检索指定参数的SQL类型。
      String ParameterMetaData.getParameterTypeName​(int param)
      检索指定参数的数据库特定类型名称。
      int ParameterMetaData.getPrecision​(int param)
      检索指定参数的指定列大小。
      int ResultSetMetaData.getPrecision​(int column)
      获取指定列的指定列大小。
      ResultSet DatabaseMetaData.getPrimaryKeys​(String catalog, String schema, String table)
      检索给定表的主键列的描述。
      ResultSet DatabaseMetaData.getProcedureColumns​(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern)
      检索给定目录的存储过程参数和结果列的描述。
      ResultSet DatabaseMetaData.getProcedures​(String catalog, String schemaPattern, String procedureNamePattern)
      200的X- 200 200 X- 200 200 X- 200 200：
      String DatabaseMetaData.getProcedureTerm​()
      检索“程序”的数据库供应商的首选项。
      DriverPropertyInfo[] Driver.getPropertyInfo​(String url, Properties info)
      获取有关此驱动程序可能属性的信息。
      ResultSet DatabaseMetaData.getPseudoColumns​(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
      检索指定目录和模式中给定表中可用的伪列或隐藏列的描述。
      int Statement.getQueryTimeout​()
      检索驱动程序等待执行 Statement对象的 Statement 。
      Ref CallableStatement.getRef​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC REF(<structured-type>)参数的值作为Ref对象。
      Ref CallableStatement.getRef​(String parameterName)
      以Java编程语言的形式获取 JDBC REF(<structured-type>)参数的值作为Ref对象。
      Ref ResultSet.getRef​(int columnIndex)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 Ref对象。
      Ref ResultSet.getRef​(String columnLabel)
      以Java编程语言中的 Ref对象获取此 ResultSet对象的当前行中指定列的值。
      ResultSet Array.getResultSet​()
      检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。
      ResultSet Array.getResultSet​(long index, int count)
      检索一个结果集，该结果集包含从索引号为 index开始的子阵列的元素，并包含最多 count连续元素。
      ResultSet Array.getResultSet​(long index, int count, Map<String,Class<?>> map)
      检索一个结果集，该结果集包含从索引 index开始的子阵列的元素，并包含最多 count连续元素。
      ResultSet Array.getResultSet​(Map<String,Class<?>> map)
      检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。
      ResultSet Statement.getResultSet​()
      以 ResultSet对象的形式获取当前结果。
      int Statement.getResultSetConcurrency​()
      检索由 ResultSet对象生成的 Statement对象的结果集并发。
      int DatabaseMetaData.getResultSetHoldability​()
      检索此数据库对于 ResultSet对象的默认保持 ResultSet 。
      int Statement.getResultSetHoldability​()
      检索 ResultSet对象生成的对象的结果集 Statement 。
      int Statement.getResultSetType​()
      检索结果集类型 ResultSet由此生成的对象 Statement对象。
      int ResultSet.getRow​()
      检索当前行号。
      RowId CallableStatement.getRowId​(int parameterIndex)
      以 java.sql.RowId对象的形式获取指定的JDBC ROWID参数的值。
      RowId CallableStatement.getRowId​(String parameterName)
      以 java.sql.RowId对象的形式获取指定的JDBC ROWID参数的值。
      RowId ResultSet.getRowId​(int columnIndex)
      以Java编程语言的 java.sql.RowId对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      RowId ResultSet.getRowId​(String columnLabel)
      以Java编程语言中的 java.sql.RowId对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      RowIdLifetime DatabaseMetaData.getRowIdLifetime​()
      指示此数据源是否支持SQL ROWID类型，以及RowId对象保持有效的生命周期。
      int Savepoint.getSavepointId​()
      检索此 Savepoint对象所代表的保存点的生成ID。
      String Savepoint.getSavepointName​()
      检索此 Savepoint对象所代表的保存点的名称。
      int ParameterMetaData.getScale​(int param)
      检索小数点右侧指定参数的位数。 对于不适用比例的数据类型，返回0。
      int ResultSetMetaData.getScale​(int column)
      获取小数点右侧的指定列的位数。 对于不适用比例的数据类型，返回0。
      String Connection.getSchema​()
      检索此 Connection对象的当前模式名称。
      String ResultSetMetaData.getSchemaName​(int column)
      获取指定列的表的模式。
      ResultSet DatabaseMetaData.getSchemas​()
      检索此数据库中可用的模式名称。
      ResultSet DatabaseMetaData.getSchemas​(String catalog, String schemaPattern)
      检索此数据库中可用的模式名称。
      String DatabaseMetaData.getSchemaTerm​()
      检索“模式”的数据库供应商的首选项。
      String DatabaseMetaData.getSearchStringEscape​()
      检索可用于转义通配符的字符串。
      short CallableStatement.getShort​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC SMALLINT参数的值作为 short 。
      short CallableStatement.getShort​(String parameterName)
      以Java编程语言中的 short JDBC SMALLINT参数的值。
      short ResultSet.getShort​(int columnIndex)
      以Java编程语言中的 short此 ResultSet对象当前行中指定列的值。
      short ResultSet.getShort​(String columnLabel)
      以Java编程语言中的 short该 ResultSet对象的当前行中指定列的值。
      <T extends Source>
      T             		SQLXML.getSource​(Class<T> sourceClass)
      返回一个用于读取此SQLXML实例指定的XML值的源。
      String DatabaseMetaData.getSQLKeywords​()
      检索所有这些数据库的SQL关键字的逗号分隔列表，这些关键字也不是SQL：2003关键字。
      int DatabaseMetaData.getSQLStateType​()
      指示 SQLException.getSQLState返回的SQLSTATE是X / Open（现在称为Open Group）SQL CLI或SQL：2003。
      String SQLData.getSQLTypeName​()
      返回此对象表示的SQL用户定义类型的完全限定名称。
      String Struct.getSQLTypeName​()
      检索此 Struct对象所代表的SQL结构类型的SQL类型名称。
      SQLXML CallableStatement.getSQLXML​(int parameterIndex)
      以Java编程语言中的 java.sql.SQLXML对象获取指定的 SQL XML参数的值。
      SQLXML CallableStatement.getSQLXML​(String parameterName)
      以Java编程语言作为 java.sql.SQLXML对象检索指定的 SQL XML参数的值。
      SQLXML ResultSet.getSQLXML​(int columnIndex)
      以Java编程语言中的 java.sql.SQLXML对象的形式，检索此 ResultSet的当前行中指定列的值。
      SQLXML ResultSet.getSQLXML​(String columnLabel)
      以Java编程语言的 java.sql.SQLXML对象的形式获取此 ResultSet的当前行中指定列的值。
      Statement ResultSet.getStatement​()
      检索 Statement生成此对象 ResultSet对象。
      String CallableStatement.getString​(int parameterIndex)
      以Java编程语言中的 CHAR VARCHAR指定的JDBC CHAR或 LONGVARCHAR参数的 String 。
      String CallableStatement.getString​(String parameterName)
      检索JDBC的价值 CHAR ， VARCHAR ，或 LONGVARCHAR参数为 String的Java编程语言。
      String ResultSet.getString​(int columnIndex)
      以Java编程语言中的 String该 ResultSet对象的当前行中指定列的值。
      String ResultSet.getString​(String columnLabel)
      以Java编程语言中的 String该 ResultSet对象的当前行中指定列的值。
      String SQLXML.getString​()
      返回此SQLXML实例指定的XML值的字符串表示形式。
      String DatabaseMetaData.getStringFunctions​()
      检索此数据库可用的逗号分隔的字符串函数列表。
      String Clob.getSubString​(long pos, int length)
      在 Clob对象指定的 CLOB值中检索指定子字符串的副本。
      ResultSet DatabaseMetaData.getSuperTables​(String catalog, String schemaPattern, String tableNamePattern)
      检索此数据库中特定模式中定义的表层次结构的描述。
      ResultSet DatabaseMetaData.getSuperTypes​(String catalog, String schemaPattern, String typeNamePattern)
      检索此数据库中特定模式中定义的用户定义类型（UDT）层次结构的描述。
      String DatabaseMetaData.getSystemFunctions​()
      检索此数据库可用的系统函数的逗号分隔列表。
      String ResultSetMetaData.getTableName​(int column)
      获取指定列的表名称。
      ResultSet DatabaseMetaData.getTablePrivileges​(String catalog, String schemaPattern, String tableNamePattern)
      检索目录中可用的每个表的访问权限的描述。
      ResultSet DatabaseMetaData.getTables​(String catalog, String schemaPattern, String tableNamePattern, String[] types)
      检索给定目录中可用表的描述。
      ResultSet DatabaseMetaData.getTableTypes​()
      检索此数据库中可用的表类型。
      Time CallableStatement.getTime​(int parameterIndex)
      将指定的JDBC TIME参数的值检索为 java.sql.Time对象。
      Time CallableStatement.getTime​(int parameterIndex, Calendar cal)
      检索指定的JDBC TIME参数的值作为 java.sql.Time对象，使用给定的 Calendar对象构建时间。
      Time CallableStatement.getTime​(String parameterName)
      检索作为 java.sql.Time对象的JDBC TIME参数的值。
      Time CallableStatement.getTime​(String parameterName, Calendar cal)
      检索JDBC TIME参数的值作为 java.sql.Time对象，使用给定的 Calendar对象构建时间。
      Time ResultSet.getTime​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
      Time ResultSet.getTime​(int columnIndex, Calendar cal)
      这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Time的Java编程语言对象。
      Time ResultSet.getTime​(String columnLabel)
      以Java编程语言中的 ResultSet对象的形式 java.sql.Time此 ResultSet对象的当前行中指定列的值。
      Time ResultSet.getTime​(String columnLabel, Calendar cal)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
      String DatabaseMetaData.getTimeDateFunctions​()
      检索此数据库可用的时间和日期函数的逗号分隔列表。
      Timestamp CallableStatement.getTimestamp​(int parameterIndex)
      以 java.sql.Timestamp对象的形式获取指定的JDBC TIMESTAMP参数的值。
      Timestamp CallableStatement.getTimestamp​(int parameterIndex, Calendar cal)
      以 java.sql.Timestamp对象的形式获取指定的JDBC TIMESTAMP参数的值，使用给定的 Calendar对象来构造 Timestamp对象。
      Timestamp CallableStatement.getTimestamp​(String parameterName)
      检索作为 java.sql.Timestamp对象的JDBC TIMESTAMP参数的值。
      Timestamp CallableStatement.getTimestamp​(String parameterName, Calendar cal)
      检索JDBC的值 TIMESTAMP参数作为 java.sql.Timestamp对象，使用给定 Calendar对象构造 Timestamp对象。
      Timestamp ResultSet.getTimestamp​(int columnIndex)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Timestamp对象。
      Timestamp ResultSet.getTimestamp​(int columnIndex, Calendar cal)
      以Java编程语言中的 java.sql.Timestamp对象获取此 ResultSet对象的当前行中指定列的值。
      Timestamp ResultSet.getTimestamp​(String columnLabel)
      以Java编程语言的 java.sql.Timestamp对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      Timestamp ResultSet.getTimestamp​(String columnLabel, Calendar cal)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Timestamp对象。
      int Connection.getTransactionIsolation​()
      检索此 Connection对象的当前事务隔离级别。
      int ResultSet.getType​()
      检索此 ResultSet对象的类型。
      ResultSet DatabaseMetaData.getTypeInfo​()
      检索此数据库支持的所有数据类型的描述。
      Map<String,Class<?>> Connection.getTypeMap​()
      检索 Map与此相关联的对象 Connection对象。
      ResultSet DatabaseMetaData.getUDTs​(String catalog, String schemaPattern, String typeNamePattern, int[] types)
      检索在特定模式中定义的用户定义类型（UDT）的描述。
      InputStream ResultSet.getUnicodeStream​(int columnIndex)
      已过时。
      使用getCharacterStream代替getUnicodeStream
      InputStream ResultSet.getUnicodeStream​(String columnLabel)
      已过时。
      使用getCharacterStream代替
      int Statement.getUpdateCount​()
      将当前结果作为更新计数检索; 如果结果是一个ResultSet对象或没有更多结果，则返回-1。
      URL CallableStatement.getURL​(int parameterIndex)
      以 java.net.URL对象的形式获取指定的JDBC DATALINK参数的值。
      URL CallableStatement.getURL​(String parameterName)
      以 java.net.URL对象的形式 java.net.URL JDBC DATALINK参数的值。
      String DatabaseMetaData.getURL​()
      检索此DBMS的URL。
      URL ResultSet.getURL​(int columnIndex)
      以Java编程语言中的 ResultSet对象的形式 java.net.URL此 ResultSet对象的当前行中指定列的值。
      URL ResultSet.getURL​(String columnLabel)
      以Java编程语言中的 java.net.URL对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      String DatabaseMetaData.getUserName​()
      检索此数据库已知的用户名。
      ResultSet DatabaseMetaData.getVersionColumns​(String catalog, String schema, String table)
      检索表中更新行中任何值时自动更新的表的列的说明。
      SQLWarning Connection.getWarnings​()
      检索通过此 Connection对象的呼叫报告的第一个警告。
      SQLWarning ResultSet.getWarnings​()
      检索通过此 ResultSet对象的呼叫报告的第一个警告。
      SQLWarning Statement.getWarnings​()
      检索通过此 Statement对象的呼叫报告的第一个警告。
      void ResultSet.insertRow​()
      将插入行的内容插入到此 ResultSet对象中并进入数据库。
      boolean DatabaseMetaData.insertsAreDetected​(int type)
      检索是否可以通过调用方法 ResultSet.rowInserted检测到可见的行插入。
      boolean ResultSet.isAfterLast​()
      检索光标是否在此 ResultSet对象中的最后一行之后。
      boolean ResultSetMetaData.isAutoIncrement​(int column)
      指示指定列是否自动编号。
      boolean ResultSet.isBeforeFirst​()
      检索光标是否在此 ResultSet对象的第一行之前。
      boolean ResultSetMetaData.isCaseSensitive​(int column)
      指示列的大小写是否重要。
      boolean DatabaseMetaData.isCatalogAtStart​()
      检索目录是否在完全限定的表名开始时显示。
      boolean Connection.isClosed​()
      检索此 Connection对象是否已关闭。
      boolean ResultSet.isClosed​()
      检索此 ResultSet对象是否已关闭。
      boolean Statement.isClosed​()
      检索此 Statement对象是否已关闭。
      boolean Statement.isCloseOnCompletion​()
      返回一个值，指示当所有其相关结果集都关闭时，是否关闭此 Statement 。
      boolean ResultSetMetaData.isCurrency​(int column)
      指示指定的列是现金值。
      boolean ResultSetMetaData.isDefinitelyWritable​(int column)
      指示指定列上的写入是否会成功。
      boolean ResultSet.isFirst​()
      检索光标是否在此 ResultSet对象的第一行。
      boolean ResultSet.isLast​()
      检索光标是否在该 ResultSet对象的最后一行。
      int ParameterMetaData.isNullable​(int param)
      检索指定参数中是否允许空值。
      int ResultSetMetaData.isNullable​(int column)
      表示指定列中的值的无效性。
      boolean Statement.isPoolable​()
      返回一个值，指示 Statement是否可 Statement 。
      boolean Connection.isReadOnly​()
      检索此 Connection对象是否处于只读模式。
      boolean DatabaseMetaData.isReadOnly​()
      检索该数据库是否处于只读模式。
      boolean ResultSetMetaData.isReadOnly​(int column)
      指示指定列是否绝对不可写。
      boolean ResultSetMetaData.isSearchable​(int column)
      指示指定的列是否可以在where子句中使用。
      boolean ParameterMetaData.isSigned​(int param)
      检索指定参数的值是否可以是符号数。
      boolean ResultSetMetaData.isSigned​(int column)
      指示指定列中的值是否为有符号数。
      default boolean Statement.isSimpleIdentifier​(String identifier)
      检索 identifier是否是一个简单的SQL标识符。
      boolean Connection.isValid​(int timeout)
      如果连接尚未关闭并且仍然有效，则返回true。
      boolean Wrapper.isWrapperFor​(Class<?> iface)
      如果这实现了接口参数，或者直接或间接地为一个对象的包装器返回true。
      boolean ResultSetMetaData.isWritable​(int column)
      指示指定列上的写入是否成功。
      boolean ResultSet.last​()
      将光标移动到此 ResultSet对象中的最后一行。
      long Blob.length​()
      返回此 Blob对象指定的 BLOB值中的字节数。
      long Clob.length​()
      检索 Clob对象指定的 CLOB值中的字符数。
      boolean DatabaseMetaData.locatorsUpdateCopy​()
      指示对LOB进行的更新是在副本上还是直接进行到LOB。
      void ResultSet.moveToCurrentRow​()
      将光标移动到记住的光标位置，通常是当前行。
      void ResultSet.moveToInsertRow​()
      将光标移动到插入行。
      String Connection.nativeSQL​(String sql)
      将给定的SQL语句转换为系统的本机SQL语法。
      boolean ResultSet.next​()
      将光标从当前位置向前移动一行。
      boolean DatabaseMetaData.nullPlusNonNullIsNull​()
      检索此数据库是否支持 NULL和非 NULL之间的连接值为 NULL 。
      boolean DatabaseMetaData.nullsAreSortedAtEnd​()
      检索最终是否排序 NULL ，无论排序顺序如何。
      boolean DatabaseMetaData.nullsAreSortedAtStart​()
      检索 NULL值是否在开始排序，无论排序顺序如何。
      boolean DatabaseMetaData.nullsAreSortedHigh​()
      检索 NULL值是否排序高。
      boolean DatabaseMetaData.nullsAreSortedLow​()
      检索 NULL值是否排序低。
      boolean DatabaseMetaData.othersDeletesAreVisible​(int type)
      检索他人删除是否可见。
      boolean DatabaseMetaData.othersInsertsAreVisible​(int type)
      检索他人所做的插入是否可见。
      boolean DatabaseMetaData.othersUpdatesAreVisible​(int type)
      检索其他人所做的更新是否可见。
      boolean DatabaseMetaData.ownDeletesAreVisible​(int type)
      检索结果集自身的删除是否可见。
      boolean DatabaseMetaData.ownInsertsAreVisible​(int type)
      检索结果集是否可以看到自己的插入。
      boolean DatabaseMetaData.ownUpdatesAreVisible​(int type)
      检索对于给定类型的 ResultSet对象，结果集的自己的更新是可见的。
      long Blob.position​(byte[] pattern, long start)
      检索指定字节数组 pattern在 Blob对象表示的 BLOB值内开始的字节位置。
      long Blob.position​(Blob pattern, long start)
      检索在该字节位置 BLOB通过该指定值 Blob对象在该 pattern开始。
      long Clob.position​(String searchstr, long start)
      检索由 Clob对象表示的SQL CLOB指定的子字符串 searchstr出现的字符位置。
      long Clob.position​(Clob searchstr, long start)
      检索指定的 Clob对象 searchstr在此 Clob对象中出现的字符位置。
      CallableStatement Connection.prepareCall​(String sql)
      创建一个用于调用数据库存储过程的 CallableStatement对象。
      CallableStatement Connection.prepareCall​(String sql, int resultSetType, int resultSetConcurrency)
      创建一个 CallableStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
      CallableStatement Connection.prepareCall​(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
      创建一个 CallableStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
      PreparedStatement Connection.prepareStatement​(String sql)
      创建一个 PreparedStatement对象，用于将参数化的SQL语句发送到数据库。
      PreparedStatement Connection.prepareStatement​(String sql, int autoGeneratedKeys)
      创建一个默认的 PreparedStatement对象，该对象具有检索自动生成的键的能力。
      PreparedStatement Connection.prepareStatement​(String sql, int[] columnIndexes)
      创建一个默认的 PreparedStatement对象，能够返回由给定数组指定的自动生成的键。
      PreparedStatement Connection.prepareStatement​(String sql, int resultSetType, int resultSetConcurrency)
      创建一个 PreparedStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
      PreparedStatement Connection.prepareStatement​(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
      创建一个 PreparedStatement对象，该对象将生成具有给定类型，并发和 ResultSet对象。
      PreparedStatement Connection.prepareStatement​(String sql, String[] columnNames)
      创建一个默认的 PreparedStatement对象，能够返回给定数组指定的自动生成的键。
      boolean ResultSet.previous​()
      将光标移动到此 ResultSet对象中的上一行。
      Array SQLInput.readArray​()
      从流中读取SQL ARRAY值，并将其作为Java编程语言中的 Array对象返回。
      InputStream SQLInput.readAsciiStream​()
      读取流中的下一个属性并将其作为ASCII字符流返回。
      BigDecimal SQLInput.readBigDecimal​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 java.math.BigDecimal对象返回。
      InputStream SQLInput.readBinaryStream​()
      读取流中的下一个属性并将其作为未解释的字节流返回。
      Blob SQLInput.readBlob​()
      从流中读取SQL BLOB值，并将其作为Java编程语言中的 Blob对象返回。
      boolean SQLInput.readBoolean​()
      读取流中的下一个属性，并将其作为Java编程语言中的 boolean返回。
      byte SQLInput.readByte​()
      读取流中的下一个属性，并将其作为Java编程语言中的 byte返回。
      byte[] SQLInput.readBytes​()
      读取流中的下一个属性，并将其作为Java编程语言中的字节数组返回。
      Reader SQLInput.readCharacterStream​()
      读取流中的下一个属性，并将其作为Unicode字符流返回。
      Clob SQLInput.readClob​()
      从流中读取SQL CLOB值，并将其作为Java编程语言中的 Clob对象返回。
      Date SQLInput.readDate​()
      读取流中的下一个属性，并将其作为 java.sql.Date对象返回。
      double SQLInput.readDouble​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 double返回。
      float SQLInput.readFloat​()
      读取流中的下一个属性，并将其作为Java编程语言中的 float返回。
      int SQLInput.readInt​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 int返回。
      long SQLInput.readLong​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 long返回。
      NClob SQLInput.readNClob​()
      从流中读取SQL NCLOB值，并将其作为Java编程语言中的 NClob对象返回。
      String SQLInput.readNString​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 String返回。
      Object SQLInput.readObject​()
      读取流头的数据，并以Java编程语言中的 Object返回。
      default <T> T SQLInput.readObject​(Class<T> type)
      读取流中的下一个属性，并将其作为Java编程语言中的 Object返回。
      Ref SQLInput.readRef​()
      从流中读取SQL REF值，并将其作为Java编程语言中的 Ref对象返回。
      RowId SQLInput.readRowId​()
      从流中读取SQL ROWID值，并将其作为Java编程语言中的 RowId对象返回。
      short SQLInput.readShort​()
      读取流中的下一个属性，并将其作为Java编程语言中的 short返回。
      void SQLData.readSQL​(SQLInput stream, String typeName)
      使用从数据库读取的数据填充此对象。
      SQLXML SQLInput.readSQLXML​()
      从流中读取SQL XML值，并将其作为Java编程语言中的 SQLXML对象返回。
      String SQLInput.readString​()
      读取流中的下一个属性，并将其作为Java编程语言中的 String返回。
      Time SQLInput.readTime​()
      读取流中的下一个属性，并将其作为 java.sql.Time对象返回。
      Timestamp SQLInput.readTimestamp​()
      读取流中的下一个属性，并将其作为 java.sql.Timestamp对象返回。
      URL SQLInput.readURL​()
      从流中读取SQL DATALINK值，并将其作为Java编程语言中的 java.net.URL对象返回。
      void ResultSet.refreshRow​()
      用数据库中最新的值刷新当前行。
      static void DriverManager.registerDriver​(Driver driver)
      注册给定的驱动程序与 DriverManager 。
      static void DriverManager.registerDriver​(Driver driver, DriverAction da)
      使用 DriverManager注册给定的驱动程序。
      void CallableStatement.registerOutParameter​(int parameterIndex, int sqlType)
      将序号 parameterIndex的OUT参数注册到JDBC类型 sqlType 。
      void CallableStatement.registerOutParameter​(int parameterIndex, int sqlType, int scale)
      将序号 parameterIndex的参数注册为JDBC类型 sqlType 。
      void CallableStatement.registerOutParameter​(int parameterIndex, int sqlType, String typeName)
      注册指定的输出参数。
      default void CallableStatement.registerOutParameter​(int parameterIndex, SQLType sqlType)
      将序号 parameterIndex的OUT参数注册到JDBC类型 sqlType 。
      default void CallableStatement.registerOutParameter​(int parameterIndex, SQLType sqlType, int scale)
      将序号 parameterIndex的参数注册为JDBC类型 sqlType 。
      default void CallableStatement.registerOutParameter​(int parameterIndex, SQLType sqlType, String typeName)
      注册指定的输出参数。
      void CallableStatement.registerOutParameter​(String parameterName, int sqlType)
      将名为 parameterName的OUT参数注册到JDBC类型 sqlType 。
      void CallableStatement.registerOutParameter​(String parameterName, int sqlType, int scale)
      将名称为 parameterName的参数注册为JDBC类型 sqlType 。
      void CallableStatement.registerOutParameter​(String parameterName, int sqlType, String typeName)
      注册指定的输出参数。
      default void CallableStatement.registerOutParameter​(String parameterName, SQLType sqlType)
      将名为 parameterName的OUT参数注册到JDBC类型 sqlType 。
      default void CallableStatement.registerOutParameter​(String parameterName, SQLType sqlType, int scale)
      将名为 parameterName的参数注册为JDBC类型 sqlType 。
      default void CallableStatement.registerOutParameter​(String parameterName, SQLType sqlType, String typeName)
      注册指定的输出参数。
      boolean ResultSet.relative​(int rows)
      将光标移动到正或负的相对行数。
      void Connection.releaseSavepoint​(Savepoint savepoint)
      从当前事务中删除指定的 Savepoint和后续的 Savepoint对象。
      void Connection.rollback​()
      撤消在当前事务中所做的所有更改，并释放此 Connection对象当前持有的任何数据库锁。
      void Connection.rollback​(Savepoint savepoint)
      撤消在给定的 Savepoint对象设置后进行的所有更改。
      boolean ResultSet.rowDeleted​()
      检索行是否被删除。
      boolean ResultSet.rowInserted​()
      检索当前行是否有插入。
      boolean ResultSet.rowUpdated​()
      检索当前行是否已更新。
      void PreparedStatement.setArray​(int parameterIndex, Array x)
      将指定的参数设置为给定的 java.sql.Array对象。
      void CallableStatement.setAsciiStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void CallableStatement.setAsciiStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void CallableStatement.setAsciiStream​(String parameterName, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      OutputStream Clob.setAsciiStream​(long pos)
      检索要用于将Ascii字符写入 Clob对象表示的 CLOB值的流，从位置 pos开始。
      void PreparedStatement.setAsciiStream​(int parameterIndex, InputStream x)
      将指定的参数设置为给定的输入流。
      void PreparedStatement.setAsciiStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void PreparedStatement.setAsciiStream​(int parameterIndex, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void Connection.setAutoCommit​(boolean autoCommit)
      将此连接的自动提交模式设置为给定状态。
      void CallableStatement.setBigDecimal​(String parameterName, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。
      void PreparedStatement.setBigDecimal​(int parameterIndex, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。
      OutputStream Blob.setBinaryStream​(long pos)
      检索可用于写入此 Blob对象所代表的值的 BLOB的流。
      void CallableStatement.setBinaryStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void CallableStatement.setBinaryStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void CallableStatement.setBinaryStream​(String parameterName, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void PreparedStatement.setBinaryStream​(int parameterIndex, InputStream x)
      将指定的参数设置为给定的输入流。
      void PreparedStatement.setBinaryStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void PreparedStatement.setBinaryStream​(int parameterIndex, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      OutputStream SQLXML.setBinaryStream​()
      检索可用于编写此SQLXML实例所代表的XML值的流。
      void CallableStatement.setBlob​(String parameterName, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void CallableStatement.setBlob​(String parameterName, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void CallableStatement.setBlob​(String parameterName, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。
      void PreparedStatement.setBlob​(int parameterIndex, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void PreparedStatement.setBlob​(int parameterIndex, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void PreparedStatement.setBlob​(int parameterIndex, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。
      void CallableStatement.setBoolean​(String parameterName, boolean x)
      将指定的参数设置为给定的Java boolean值。
      void PreparedStatement.setBoolean​(int parameterIndex, boolean x)
      将指定的参数设置为给定的Java boolean值。
      void CallableStatement.setByte​(String parameterName, byte x)
      将指定的参数设置为给定的Java byte值。
      void PreparedStatement.setByte​(int parameterIndex, byte x)
      将指定的参数设置为给定的Java byte值。
      int Blob.setBytes​(long pos, byte[] bytes)
      将给定的字节数组写入 Blob对象所表示的 BLOB值，从位置 pos开始，并返回写入的字节数。
      int Blob.setBytes​(long pos, byte[] bytes, int offset, int len)
      将所有或部分给定的 byte数组写入 Blob对象表示的 BLOB值，并返回写入的字节数。
      void CallableStatement.setBytes​(String parameterName, byte[] x)
      将指定的参数设置为给定的Java字节数组。
      void PreparedStatement.setBytes​(int parameterIndex, byte[] x)
      将指定的参数设置为给定的Java字节数组。
      void Connection.setCatalog​(String catalog)
      为了选择这个的子空间设置给定目录名称 Connection对象在其中工作的数据库。
      void CallableStatement.setCharacterStream​(String parameterName, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void CallableStatement.setCharacterStream​(String parameterName, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void CallableStatement.setCharacterStream​(String parameterName, Reader reader, long length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      Writer Clob.setCharacterStream​(long pos)
      检索流用于写入的Unicode字符流的 CLOB值，这 Clob对象表示，在位置 pos 。
      void PreparedStatement.setCharacterStream​(int parameterIndex, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void PreparedStatement.setCharacterStream​(int parameterIndex, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void PreparedStatement.setCharacterStream​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      Writer SQLXML.setCharacterStream​()
      检索要用于写入此SQLXML实例所代表的XML值的流。
      void CallableStatement.setClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setClob​(String parameterName, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。
      void PreparedStatement.setClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setClob​(int parameterIndex, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。
      void Statement.setCursorName​(String name)
      将SQL游标名称设置为给定的 String ，这将由后续的 Statement对象使用 execute方法。
      void CallableStatement.setDate​(String parameterName, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void CallableStatement.setDate​(String parameterName, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void PreparedStatement.setDate​(int parameterIndex, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void PreparedStatement.setDate​(int parameterIndex, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void CallableStatement.setDouble​(String parameterName, double x)
      将指定的参数设置为给定的Java double值。
      void PreparedStatement.setDouble​(int parameterIndex, double x)
      将指定的参数设置为给定的Java double值。
      void Statement.setEscapeProcessing​(boolean enable)
      设置逃脱处理打开或关闭。
      void ResultSet.setFetchDirection​(int direction)
      给出这个 ResultSet对象中的行将被处理的方向的提示。
      void Statement.setFetchDirection​(int direction)
      向驱动程序提供关于使用此 Statement对象创建的对象中的 ResultSet在 ResultSet处理的方向的提示。
      void ResultSet.setFetchSize​(int rows)
      给JDBC驱动程序一个提示，当这个 ResultSet对象需要更多行时，应该从数据库中获取的行数。
      void Statement.setFetchSize​(int rows)
      给JDBC驱动程序一个提示，当 ResultSet生成的 ResultSet对象需要更多行时，应从数据库中获取的行 Statement 。
      void CallableStatement.setFloat​(String parameterName, float x)
      将指定的参数设置为给定的Java float值。
      void PreparedStatement.setFloat​(int parameterIndex, float x)
      将指定的参数设置为给定的Java float值。
      void Connection.setHoldability​(int holdability)
      将使用此 Connection对象创建的 ResultSet对象的默认可 ResultSet更改为给定的可保存性。
      void CallableStatement.setInt​(String parameterName, int x)
      将指定的参数设置为给定的Java int值。
      void PreparedStatement.setInt​(int parameterIndex, int x)
      将指定的参数设置为给定的Java int值。
      default void Statement.setLargeMaxRows​(long max)
      设置的任何行的最大数目的极限 ResultSet由此生成的对象 Statement对象可以包含给定数目。
      void CallableStatement.setLong​(String parameterName, long x)
      将指定的参数设置为给定的Java long值。
      void PreparedStatement.setLong​(int parameterIndex, long x)
      将指定的参数设置为给定的Java long值。
      void Statement.setMaxFieldSize​(int max)
      设置由 ResultSet对象生成的 Statement对象中的字符和二进制列值可以返回的最大字节数的限制。
      void Statement.setMaxRows​(int max)
      设置由此 ResultSet对象生成的 Statement对象可以包含给给定数量的最大行数的限制。
      void CallableStatement.setNCharacterStream​(String parameterName, Reader value)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setNCharacterStream​(String parameterName, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setNCharacterStream​(int parameterIndex, Reader value)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setNCharacterStream​(int parameterIndex, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setNClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setNClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setNClob​(String parameterName, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void PreparedStatement.setNClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setNClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setNClob​(int parameterIndex, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void Connection.setNetworkTimeout​(Executor executor, int milliseconds)
      设置 Connection的最大周期或从 Connection创建的 Connection将等待数据库回复任何一个请求。
      void CallableStatement.setNString​(String parameterName, String value)
      将指定的参数设置为给定的 String对象。
      void PreparedStatement.setNString​(int parameterIndex, String value)
      将指定的参数设置为给定的 String对象。
      void CallableStatement.setNull​(String parameterName, int sqlType)
      将指定的参数设置为SQL NULL 。
      void CallableStatement.setNull​(String parameterName, int sqlType, String typeName)
      将指定的参数设置为SQL NULL 。
      void PreparedStatement.setNull​(int parameterIndex, int sqlType)
      将指定的参数设置为SQL NULL 。
      void PreparedStatement.setNull​(int parameterIndex, int sqlType, String typeName)
      将指定的参数设置为SQL NULL 。
      void CallableStatement.setObject​(String parameterName, Object x)
      使用给定对象设置指定参数的值。
      void CallableStatement.setObject​(String parameterName, Object x, int targetSqlType)
      使用给定对象设置指定参数的值。
      void CallableStatement.setObject​(String parameterName, Object x, int targetSqlType, int scale)
      使用给定对象设置指定参数的值。
      default void CallableStatement.setObject​(String parameterName, Object x, SQLType targetSqlType)
      使用给定对象设置指定参数的值。
      default void CallableStatement.setObject​(String parameterName, Object x, SQLType targetSqlType, int scaleOrLength)
      使用给定对象设置指定参数的值。
      void PreparedStatement.setObject​(int parameterIndex, Object x)
      使用给定对象设置指定参数的值。
      void PreparedStatement.setObject​(int parameterIndex, Object x, int targetSqlType)
      使用给定对象设置指定参数的值。
      void PreparedStatement.setObject​(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
      使用给定对象设置指定参数的值。
      default void PreparedStatement.setObject​(int parameterIndex, Object x, SQLType targetSqlType)
      使用给定对象设置指定参数的值。
      default void PreparedStatement.setObject​(int parameterIndex, Object x, SQLType targetSqlType, int scaleOrLength)
      使用给定对象设置指定参数的值。
      void Ref.setObject​(Object value)
      将此 Ref对象引用到给定实例的结构化类型值设置为 Object 。
      void Statement.setPoolable​(boolean poolable)
      要求汇集或不汇集 Statement 。
      void Statement.setQueryTimeout​(int seconds)
      设置驱动程序等待 Statement对象执行到给定秒数的秒数。
      void Connection.setReadOnly​(boolean readOnly)
      将此连接设置为只读模式，作为驱动程序的提示以启用数据库优化。
      void PreparedStatement.setRef​(int parameterIndex, Ref x)
      将指定的参数设置为给定的 REF(<structured-type>)值。
      <T extends Result>
      T             		SQLXML.setResult​(Class<T> resultClass)
      返回一个用于设置此SQLXML实例指定的XML值的结果。
      void CallableStatement.setRowId​(String parameterName, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void PreparedStatement.setRowId​(int parameterIndex, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      Savepoint Connection.setSavepoint​()
      在当前事务中创建一个未命名的保存点，并返回代表它的新的 Savepoint对象。
      Savepoint Connection.setSavepoint​(String name)
      在当前事务中创建具有给定名称的保存点，并返回表示它的新的 Savepoint对象。
      void Connection.setSchema​(String schema)
      设置要访问的给定模式名称。
      default void Connection.setShardingKey​(ShardingKey shardingKey)
      指定与此Connection一起使用的shardingKey
      default void Connection.setShardingKey​(ShardingKey shardingKey, ShardingKey superShardingKey)
      指定与此连接一起使用的shardingKey和superShardingKey
      default boolean Connection.setShardingKeyIfValid​(ShardingKey shardingKey, int timeout)
      设置并验证此连接的分片密钥。
      default boolean Connection.setShardingKeyIfValid​(ShardingKey shardingKey, ShardingKey superShardingKey, int timeout)
      设置并验证此连接的分片密钥。
      void CallableStatement.setShort​(String parameterName, short x)
      将指定的参数设置为给定的Java short值。
      void PreparedStatement.setShort​(int parameterIndex, short x)
      将指定的参数设置为给定的Java short值。
      void CallableStatement.setSQLXML​(String parameterName, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void PreparedStatement.setSQLXML​(int parameterIndex, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void CallableStatement.setString​(String parameterName, String x)
      将指定的参数设置为给定的Java String值。
      int Clob.setString​(long pos, String str)
      写入给定的Java String到 CLOB值，这 Clob对象表示在该位置 pos 。
      int Clob.setString​(long pos, String str, int offset, int len)
      写 len字符的 str ，从字符 offset开始，以 Clob表示的 CLOB值。
      void PreparedStatement.setString​(int parameterIndex, String x)
      将指定的参数设置为给定的Java String值。
      void SQLXML.setString​(String value)
      将此SQLXML实例指定的XML值设置为给定的String表示形式。
      void CallableStatement.setTime​(String parameterName, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void CallableStatement.setTime​(String parameterName, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void PreparedStatement.setTime​(int parameterIndex, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void PreparedStatement.setTime​(int parameterIndex, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void CallableStatement.setTimestamp​(String parameterName, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void CallableStatement.setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。
      void PreparedStatement.setTimestamp​(int parameterIndex, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void PreparedStatement.setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。
      void Connection.setTransactionIsolation​(int level)
      尝试将此 Connection对象的事务隔离级别更改为给定的对象。
      void Connection.setTypeMap​(Map<String,Class<?>> map)
      安装给定 TypeMap对象的类型映射此 Connection对象。
      void PreparedStatement.setUnicodeStream​(int parameterIndex, InputStream x, int length)
      已过时。
      使用setCharacterStream
      void CallableStatement.setURL​(String parameterName, URL val)
      将指定的参数设置为给定的 java.net.URL对象。
      void PreparedStatement.setURL​(int parameterIndex, URL x)
      将指定的参数设置为给定的 java.net.URL值。
      boolean DatabaseMetaData.storesLowerCaseIdentifiers​()
      检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并将其存储为小写。
      boolean DatabaseMetaData.storesLowerCaseQuotedIdentifiers​()
      检索此数据库是否将混合大小写的SQL标识符视为不区分大小写，并以小写形式存储。
      boolean DatabaseMetaData.storesMixedCaseIdentifiers​()
      检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并以混合大小写存储。
      boolean DatabaseMetaData.storesMixedCaseQuotedIdentifiers​()
      检索此数据库是否将混合大小写的SQL标识符视为不区分大小写，并以混合大小写存储。
      boolean DatabaseMetaData.storesUpperCaseIdentifiers​()
      检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并以大写形式存储。
      boolean DatabaseMetaData.storesUpperCaseQuotedIdentifiers​()
      检索此数据库是否将混合大小写引用的SQL标识符视为不区分大小写，并以大写形式存储。
      boolean DatabaseMetaData.supportsAlterTableWithAddColumn​()
      检索此数据库是否支持 ALTER TABLE添加列。
      boolean DatabaseMetaData.supportsAlterTableWithDropColumn​()
      检索此数据库是否支持具有删除列的 ALTER TABLE 。
      boolean DatabaseMetaData.supportsANSI92EntryLevelSQL​()
      检索此数据库是否支持ANSI92入门级SQL语法。
      boolean DatabaseMetaData.supportsANSI92FullSQL​()
      检索此数据库是否支持支持的ANSI92完整SQL语法。
      boolean DatabaseMetaData.supportsANSI92IntermediateSQL​()
      检索该数据库是否支持ANSI92中间SQL语法。
      boolean DatabaseMetaData.supportsBatchUpdates​()
      检索此数据库是否支持批量更新。
      boolean DatabaseMetaData.supportsCatalogsInDataManipulation​()
      检索数据操作语句中是否可以使用目录名称。
      boolean DatabaseMetaData.supportsCatalogsInIndexDefinitions​()
      检索是否可以在索引定义语句中使用目录名称。
      boolean DatabaseMetaData.supportsCatalogsInPrivilegeDefinitions​()
      检索是否可以在特权定义语句中使用目录名称。
      boolean DatabaseMetaData.supportsCatalogsInProcedureCalls​()
      检索是否可以在过程调用语句中使用目录名称。
      boolean DatabaseMetaData.supportsCatalogsInTableDefinitions​()
      检索表定义语句中是否可以使用目录名称。
      boolean DatabaseMetaData.supportsColumnAliasing​()
      检索此数据库是否支持列别名。
      boolean DatabaseMetaData.supportsConvert​()
      检索此数据库是否支持JDBC标量函数 CONVERT以将一种JDBC类型转换为另一种JDBC类型。
      boolean DatabaseMetaData.supportsConvert​(int fromType, int toType)
      检索此数据库是否支持JDBC标量函数 CONVERT用于JDBC类型 fromType和 toType之间的转换。
      boolean DatabaseMetaData.supportsCoreSQLGrammar​()
      检索此数据库是否支持ODBC Core SQL语法。
      boolean DatabaseMetaData.supportsCorrelatedSubqueries​()
      检索此数据库是否支持相关的子查询。
      boolean DatabaseMetaData.supportsDataDefinitionAndDataManipulationTransactions​()
      检索此数据库是否支持事务中的数据定义和数据操作语句。
      boolean DatabaseMetaData.supportsDataManipulationTransactionsOnly​()
      检索此数据库是否仅支持事务中的数据操作语句。
      boolean DatabaseMetaData.supportsDifferentTableCorrelationNames​()
      检索是否支持表相关名称，它们被限制为与表的名称不同。
      boolean DatabaseMetaData.supportsExpressionsInOrderBy​()
      检索此数据库是否支持 ORDER BY列表中的表达式。
      boolean DatabaseMetaData.supportsExtendedSQLGrammar​()
      检索此数据库是否支持ODBC扩展SQL语法。
      boolean DatabaseMetaData.supportsFullOuterJoins​()
      检索此数据库是否支持完全嵌套的外连接。
      boolean DatabaseMetaData.supportsGetGeneratedKeys​()
      检索在执行语句后是否可以检索自动生成的键
      boolean DatabaseMetaData.supportsGroupBy​()
      检索此数据库是否支持某种形式的 GROUP BY子句。
      boolean DatabaseMetaData.supportsGroupByBeyondSelect​()
      获取此数据库是否支持使用不包含在列 SELECT在一份声明中 GROUP BY条款规定，所有在列 SELECT声明都包含在在 GROUP BY条款。
      boolean DatabaseMetaData.supportsGroupByUnrelated​()
      检索此数据库是否支持在 GROUP BY子句中使用 GROUP BY SELECT语句中的 GROUP BY 。
      boolean DatabaseMetaData.supportsIntegrityEnhancementFacility​()
      检索此数据库是否支持SQL完整性增强工具。
      boolean DatabaseMetaData.supportsLikeEscapeClause​()
      检索此数据库是否支持指定一个 LIKE转义子句。
      boolean DatabaseMetaData.supportsLimitedOuterJoins​()
      检索此数据库是否为外连接提供有限的支持。
      boolean DatabaseMetaData.supportsMinimumSQLGrammar​()
      检索此数据库是否支持ODBC最低SQL语法。
      boolean DatabaseMetaData.supportsMixedCaseIdentifiers​()
      检索此数据库是否将混合大小写不引用的SQL标识符视为区分大小写，并将结果存储在混合大小写中。
      boolean DatabaseMetaData.supportsMixedCaseQuotedIdentifiers​()
      检索此数据库是否将混合大小写的SQL标识符视为区分大小写，并将结果存储在混合大小写中。
      boolean DatabaseMetaData.supportsMultipleOpenResults​()
      检索是否有可能具有多个 ResultSet从返回的对象 CallableStatement对象同时进行。
      boolean DatabaseMetaData.supportsMultipleResultSets​()
      检索该数据库是否支持从方法 execute的单一调用中获取多个 ResultSet对象。
      boolean DatabaseMetaData.supportsMultipleTransactions​()
      检索此数据库是否允许同时打开多个事务（在不同的连接上）。
      boolean DatabaseMetaData.supportsNamedParameters​()
      检索此数据库是否支持可调用语句的命名参数。
      boolean DatabaseMetaData.supportsNonNullableColumns​()
      检索此数据库中的列是否可以被定义为不可为空。
      boolean DatabaseMetaData.supportsOpenCursorsAcrossCommit​()
      检索此数据库是否支持保持游标在提交之间打开。
      boolean DatabaseMetaData.supportsOpenCursorsAcrossRollback​()
      检索此数据库是否支持在回滚之间保持光标打开。
      boolean DatabaseMetaData.supportsOpenStatementsAcrossCommit​()
      检索此数据库是否支持在提交之间保留语句。
      boolean DatabaseMetaData.supportsOpenStatementsAcrossRollback​()
      检索此数据库是否支持在回滚期间保持语句打开。
      boolean DatabaseMetaData.supportsOrderByUnrelated​()
      检索此数据库是否支持在 ORDER BY子句中使用 ORDER BY SELECT语句中的 ORDER BY 。
      boolean DatabaseMetaData.supportsOuterJoins​()
      检索此数据库是否支持某种形式的外连接。
      boolean DatabaseMetaData.supportsPositionedDelete​()
      检索此数据库是否支持定位 DELETE语句。
      boolean DatabaseMetaData.supportsPositionedUpdate​()
      检索此数据库是否支持定位 UPDATE语句。
      default boolean DatabaseMetaData.supportsRefCursors​()
      检索此数据库是否支持REF CURSOR。
      boolean DatabaseMetaData.supportsResultSetConcurrency​(int type, int concurrency)
      检索此数据库是否支持给定的并发类型与给定的结果集类型的组合。
      boolean DatabaseMetaData.supportsResultSetHoldability​(int holdability)
      检索此数据库是否支持给定的结果集保持性。
      boolean DatabaseMetaData.supportsResultSetType​(int type)
      检索此数据库是否支持给定的结果集类型。
      boolean DatabaseMetaData.supportsSavepoints​()
      检索此数据库是否支持保存点。
      boolean DatabaseMetaData.supportsSchemasInDataManipulation​()
      检索是否可以在数据操作语句中使用模式名称。
      boolean DatabaseMetaData.supportsSchemasInIndexDefinitions​()
      检索是否可以在索引定义语句中使用模式名称。
      boolean DatabaseMetaData.supportsSchemasInPrivilegeDefinitions​()
      检索是否可以在特权定义语句中使用模式名称。
      boolean DatabaseMetaData.supportsSchemasInProcedureCalls​()
      检索是否可以在过程调用语句中使用模式名称。
      boolean DatabaseMetaData.supportsSchemasInTableDefinitions​()
      检索表定义语句中是否可以使用模式名称。
      boolean DatabaseMetaData.supportsSelectForUpdate​()
      检索此数据库是否支持 SELECT FOR UPDATE语句。
      default boolean DatabaseMetaData.supportsSharding​()
      检索此数据库是否支持分片。
      boolean DatabaseMetaData.supportsStatementPooling​()
      检索此数据库是否支持语句池。
      boolean DatabaseMetaData.supportsStoredFunctionsUsingCallSyntax​()
      检索此数据库是否支持使用存储过程转义语法调用用户定义或供应商功能。
      boolean DatabaseMetaData.supportsStoredProcedures​()
      检索此数据库是否支持使用存储过程转义语法的存储过程调用。
      boolean DatabaseMetaData.supportsSubqueriesInComparisons​()
      检索此数据库是否支持比较表达式中的子查询。
      boolean DatabaseMetaData.supportsSubqueriesInExists​()
      检索此数据库是否支持 EXISTS表达式中的子查询。
      boolean DatabaseMetaData.supportsSubqueriesInIns​()
      检索此数据库是否支持 IN表达式中的子查询。
      boolean DatabaseMetaData.supportsSubqueriesInQuantifieds​()
      检索此数据库是否支持量化表达式中的子查询。
      boolean DatabaseMetaData.supportsTableCorrelationNames​()
      检索此数据库是否支持表相关名称。
      boolean DatabaseMetaData.supportsTransactionIsolationLevel​(int level)
      检索此数据库是否支持给定的事务隔离级别。
      boolean DatabaseMetaData.supportsTransactions​()
      检索此数据库是否支持事务。
      boolean DatabaseMetaData.supportsUnion​()
      检索此数据库是否支持SQL UNION 。
      boolean DatabaseMetaData.supportsUnionAll​()
      检索此数据库是否支持SQL UNION ALL 。
      void Blob.truncate​(long len)
      截断 BLOB值，这 Blob对象表示为 len字节长度。
      void Clob.truncate​(long len)
      截断该 Clob指定的长度为 len字符的 CLOB值。
      <T> T Wrapper.unwrap​(Class<T> iface)
      返回一个实现给定接口以允许访问非标准方法的对象，或代理不公开的标准方法。
      void ResultSet.updateArray​(int columnIndex, Array x)
      使用 java.sql.Array值更新指定的列。
      void ResultSet.updateArray​(String columnLabel, Array x)
      使用 java.sql.Array值更新指定的列。
      void ResultSet.updateAsciiStream​(int columnIndex, InputStream x)
      使用ascii流值更新指定的列。
      void ResultSet.updateAsciiStream​(int columnIndex, InputStream x, int length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateAsciiStream​(int columnIndex, InputStream x, long length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateAsciiStream​(String columnLabel, InputStream x)
      使用ascii流值更新指定的列。
      void ResultSet.updateAsciiStream​(String columnLabel, InputStream x, int length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateAsciiStream​(String columnLabel, InputStream x, long length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBigDecimal​(int columnIndex, BigDecimal x)
      使用 java.math.BigDecimal值更新指定的列。
      void ResultSet.updateBigDecimal​(String columnLabel, BigDecimal x)
      使用 java.sql.BigDecimal值更新指定的列。
      void ResultSet.updateBinaryStream​(int columnIndex, InputStream x)
      使用二进制流值更新指定的列。
      void ResultSet.updateBinaryStream​(int columnIndex, InputStream x, int length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBinaryStream​(int columnIndex, InputStream x, long length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBinaryStream​(String columnLabel, InputStream x)
      使用二进制流值更新指定的列。
      void ResultSet.updateBinaryStream​(String columnLabel, InputStream x, int length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBinaryStream​(String columnLabel, InputStream x, long length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBlob​(int columnIndex, InputStream inputStream)
      使用给定的输入流更新指定的列。
      void ResultSet.updateBlob​(int columnIndex, InputStream inputStream, long length)
      使用给定的输入流更新指定列，该输入流将具有指定的字节数。
      void ResultSet.updateBlob​(int columnIndex, Blob x)
      使用 java.sql.Blob值更新指定的列。
      void ResultSet.updateBlob​(String columnLabel, InputStream inputStream)
      使用给定的输入流更新指定的列。
      void ResultSet.updateBlob​(String columnLabel, InputStream inputStream, long length)
      使用给定的输入流更新指定列，该输入流将具有指定的字节数。
      void ResultSet.updateBlob​(String columnLabel, Blob x)
      使用 java.sql.Blob值更新指定的列。
      void ResultSet.updateBoolean​(int columnIndex, boolean x)
      使用 boolean值更新指定的列。
      void ResultSet.updateBoolean​(String columnLabel, boolean x)
      使用 boolean值更新指定的列。
      void ResultSet.updateByte​(int columnIndex, byte x)
      使用 byte值更新指定的列。
      void ResultSet.updateByte​(String columnLabel, byte x)
      使用 byte值更新指定的列。
      void ResultSet.updateBytes​(int columnIndex, byte[] x)
      使用 byte数组值更新指定的列。
      void ResultSet.updateBytes​(String columnLabel, byte[] x)
      使用字节数组值更新指定的列。
      void ResultSet.updateCharacterStream​(int columnIndex, Reader x)
      使用字符流值更新指定的列。
      void ResultSet.updateCharacterStream​(int columnIndex, Reader x, int length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateCharacterStream​(int columnIndex, Reader x, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateCharacterStream​(String columnLabel, Reader reader)
      使用字符流值更新指定的列。
      void ResultSet.updateCharacterStream​(String columnLabel, Reader reader, int length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateCharacterStream​(String columnLabel, Reader reader, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateClob​(int columnIndex, Reader reader)
      使用给定的 Reader对象更新指定的列。
      void ResultSet.updateClob​(int columnIndex, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的字符数长。
      void ResultSet.updateClob​(int columnIndex, Clob x)
      使用 java.sql.Clob值更新指定的列。
      void ResultSet.updateClob​(String columnLabel, Reader reader)
      使用给定的 Reader对象更新指定的列。
      void ResultSet.updateClob​(String columnLabel, Reader reader, long length)
      使用给定的 Reader对象来更新指定的列，这是给定的长度的字符数。
      void ResultSet.updateClob​(String columnLabel, Clob x)
      使用 java.sql.Clob值更新指定的列。
      void ResultSet.updateDate​(int columnIndex, Date x)
      使用 java.sql.Date值更新指定的列。
      void ResultSet.updateDate​(String columnLabel, Date x)
      使用 java.sql.Date值更新指定的列。
      void ResultSet.updateDouble​(int columnIndex, double x)
      使用 double值更新指定的列。
      void ResultSet.updateDouble​(String columnLabel, double x)
      使用 double值更新指定的列。
      void ResultSet.updateFloat​(int columnIndex, float x)
      使用 float值更新指定的列。
      void ResultSet.updateFloat​(String columnLabel, float x)
      使用 float值更新指定的列。
      void ResultSet.updateInt​(int columnIndex, int x)
      使用 int值更新指定的列。
      void ResultSet.updateInt​(String columnLabel, int x)
      使用 int值更新指定的列。
      void ResultSet.updateLong​(int columnIndex, long x)
      使用 long值更新指定的列。
      void ResultSet.updateLong​(String columnLabel, long x)
      使用 long值更新指定的列。
      void ResultSet.updateNCharacterStream​(int columnIndex, Reader x)
      使用字符流值更新指定的列。
      void ResultSet.updateNCharacterStream​(int columnIndex, Reader x, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateNCharacterStream​(String columnLabel, Reader reader)
      使用字符流值更新指定的列。
      void ResultSet.updateNCharacterStream​(String columnLabel, Reader reader, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateNClob​(int columnIndex, Reader reader)
      使用给定的 Reader更新指定列。根据需要将从数据流中读取数据，直到达到流到目标。
      void ResultSet.updateNClob​(int columnIndex, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的字符数。
      void ResultSet.updateNClob​(int columnIndex, NClob nClob)
      使用 java.sql.NClob值更新指定的列。
      void ResultSet.updateNClob​(String columnLabel, Reader reader)
      使用给定的 Reader对象更新指定的列。
      void ResultSet.updateNClob​(String columnLabel, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的长度的字符数。
      void ResultSet.updateNClob​(String columnLabel, NClob nClob)
      使用 java.sql.NClob值更新指定的列。
      void ResultSet.updateNString​(int columnIndex, String nString)
      使用 String值更新指定的列。
      void ResultSet.updateNString​(String columnLabel, String nString)
      使用 String值更新指定的列。
      void ResultSet.updateNull​(int columnIndex)
      使用 null值更新指定的列。
      void ResultSet.updateNull​(String columnLabel)
      使用 null值更新指定的列。
      void ResultSet.updateObject​(int columnIndex, Object x)
      使用 Object值更新指定的列。
      void ResultSet.updateObject​(int columnIndex, Object x, int scaleOrLength)
      使用 Object值更新指定的列。
      default void ResultSet.updateObject​(int columnIndex, Object x, SQLType targetSqlType)
      使用 Object值更新指定的列。
      default void ResultSet.updateObject​(int columnIndex, Object x, SQLType targetSqlType, int scaleOrLength)
      使用 Object值更新指定的列。
      void ResultSet.updateObject​(String columnLabel, Object x)
      使用 Object值更新指定的列。
      void ResultSet.updateObject​(String columnLabel, Object x, int scaleOrLength)
      使用 Object值更新指定的列。
      default void ResultSet.updateObject​(String columnLabel, Object x, SQLType targetSqlType)
      使用 Object值更新指定的列。
      default void ResultSet.updateObject​(String columnLabel, Object x, SQLType targetSqlType, int scaleOrLength)
      使用 Object值更新指定的列。
      void ResultSet.updateRef​(int columnIndex, Ref x)
      使用 java.sql.Ref值更新指定的列。
      void ResultSet.updateRef​(String columnLabel, Ref x)
      使用 java.sql.Ref值更新指定的列。
      void ResultSet.updateRow​()
      使用此 ResultSet对象的当前行的新内容更新底层数据库。
      void ResultSet.updateRowId​(int columnIndex, RowId x)
      使用 RowId值更新指定的列。
      void ResultSet.updateRowId​(String columnLabel, RowId x)
      使用 RowId值更新指定的列。
      boolean DatabaseMetaData.updatesAreDetected​(int type)
      检索是否可以通过调用方法 ResultSet.rowUpdated检测到可见行更新。
      void ResultSet.updateShort​(int columnIndex, short x)
      使用 short值更新指定的列。
      void ResultSet.updateShort​(String columnLabel, short x)
      使用 short值更新指定的列。
      void ResultSet.updateSQLXML​(int columnIndex, SQLXML xmlObject)
      使用 java.sql.SQLXML值更新指定的列。
      void ResultSet.updateSQLXML​(String columnLabel, SQLXML xmlObject)
      使用 java.sql.SQLXML值更新指定的列。
      void ResultSet.updateString​(int columnIndex, String x)
      使用 String值更新指定的列。
      void ResultSet.updateString​(String columnLabel, String x)
      使用 String值更新指定的列。
      void ResultSet.updateTime​(int columnIndex, Time x)
      使用 java.sql.Time值更新指定的列。
      void ResultSet.updateTime​(String columnLabel, Time x)
      使用 java.sql.Time值更新指定的列。
      void ResultSet.updateTimestamp​(int columnIndex, Timestamp x)
      使用 java.sql.Timestamp值更新指定的列。
      void ResultSet.updateTimestamp​(String columnLabel, Timestamp x)
      使用 java.sql.Timestamp值更新指定的列。
      boolean DatabaseMetaData.usesLocalFilePerTable​()
      检索此数据库是否为每个表使用一个文件。
      boolean DatabaseMetaData.usesLocalFiles​()
      检索此数据库是否将表存储在本地文件中。
      boolean CallableStatement.wasNull​()
      检索读取的最后一个OUT参数的值是否为SQL NULL 。
      boolean ResultSet.wasNull​()
      报告最后一列读取的值是否为SQL NULL 。
      boolean SQLInput.wasNull​()
      检索最后读取的值是否为SQL NULL 。
      void SQLOutput.writeArray​(Array x)
      将SQL ARRAY值写入流。
      void SQLOutput.writeAsciiStream​(InputStream x)
      将下一个属性作为ASCII字符串写入流。
      void SQLOutput.writeBigDecimal​(BigDecimal x)
      将下一个属性作为java.math.BigDecimal对象写入流。
      void SQLOutput.writeBinaryStream​(InputStream x)
      将下一个属性写入流作为未解释字节流。
      void SQLOutput.writeBlob​(Blob x)
      将SQL BLOB值写入流。
      void SQLOutput.writeBoolean​(boolean x)
      将下一个属性作为Java布尔值写入流。
      void SQLOutput.writeByte​(byte x)
      将下一个属性作为Java字节写入流。
      void SQLOutput.writeBytes​(byte[] x)
      将下一个属性写入流作为字节数组。
      void SQLOutput.writeCharacterStream​(Reader x)
      将下一个属性作为Unicode字符流写入流。
      void SQLOutput.writeClob​(Clob x)
      将SQL CLOB值写入流。
      void SQLOutput.writeDate​(Date x)
      将下一个属性作为java.sql.Date对象写入流。
      void SQLOutput.writeDouble​(double x)
      将下一个属性作为Java double写入流。
      void SQLOutput.writeFloat​(float x)
      将下一个属性作为Java float写入流。
      void SQLOutput.writeInt​(int x)
      将下一个属性作为Java int写入流。
      void SQLOutput.writeLong​(long x)
      将下一个属性作为Java写入流。
      void SQLOutput.writeNClob​(NClob x)
      将SQL NCLOB值写入流。
      void SQLOutput.writeNString​(String x)
      将下一个属性作为Java编程语言中的一个 String写入流。
      default void SQLOutput.writeObject​(Object x, SQLType targetSqlType)
      将包含在给定对象中的数据写入流。
      void SQLOutput.writeObject​(SQLData x)
      向流中写入包含在给定的 SQLData对象中的数据。
      void SQLOutput.writeRef​(Ref x)
      将SQL REF值写入流。
      void SQLOutput.writeRowId​(RowId x)
      将SQL ROWID值写入流。
      void SQLOutput.writeShort​(short x)
      将下一个属性写入流作为Java短。
      void SQLData.writeSQL​(SQLOutput stream)
      将此对象写入给定的SQL数据流，将其转换回数据源中的SQL值。
      void SQLOutput.writeSQLXML​(SQLXML x)
      将SQL XML值写入流。
      void SQLOutput.writeString​(String x)
      将下一个属性作为Java编程语言中的 String写入流。
      void SQLOutput.writeStruct​(Struct x)
      将SQL结构化类型值写入流。
      void SQLOutput.writeTime​(Time x)
      将下一个属性作为java.sql.Time对象写入流。
      void SQLOutput.writeTimestamp​(Timestamp x)
      将下一个属性作为java.sql.Timestamp对象写入流。
      void SQLOutput.writeURL​(URL x)
      将SQL DATALINK值写入流。

    • Uses of SQLException in javax.sql

      Methods in javax.sql that return SQLException
      Modifier and Type 方法 描述
      SQLException ConnectionEvent.getSQLException​()
      检索 SQLException此 ConnectionEvent对象。
      SQLException StatementEvent.getSQLException​()
      返回驱动程序即将抛出的 SQLException
      Methods in javax.sql that throw SQLException
      Modifier and Type 方法 描述
      PooledConnection PooledConnectionBuilder.build​()
      返回由此构建器定义的对象的实例。
      XAConnection XAConnectionBuilder.build​()
      返回由此构建器定义的对象的实例。
      void RowSet.clearParameters​()
      清除为此 RowSet对象的命令设置的参数。
      void PooledConnection.close​()
      关闭此 PooledConnection对象所代表的物理连接。
      default ConnectionBuilder DataSource.createConnectionBuilder​()
      创建一个新的 ConnectionBuilder实例
      default PooledConnectionBuilder ConnectionPoolDataSource.createPooledConnectionBuilder​()
      创建一个新的 PooledConnectionBuilder实例
      default ShardingKeyBuilder CommonDataSource.createShardingKeyBuilder​()
      创建一个新的 ShardingKeyBuilder实例
      default XAConnectionBuilder XADataSource.createXAConnectionBuilder​()
      创建一个新的 XAConnectionBuilder实例
      void RowSet.execute​()
      RowSet这个 RowSet对象的数据。
      Connection DataSource.getConnection​()
      尝试建立与这个 DataSource对象所代表的数据源的连接。
      Connection DataSource.getConnection​(String username, String password)
      尝试建立与此 DataSource对象所代表的数据源的连接。
      Connection PooledConnection.getConnection​()
      创建并返回一个 Connection对象，该对象是此 PooledConnection对象所代表的物理连接的句柄。
      Connection RowSetInternal.getConnection​()
      检索 Connection传递给该对象 RowSet对象。
      boolean RowSet.getEscapeProcessing​()
      检索是否为此 RowSet对象启用了转义处理。
      int CommonDataSource.getLoginTimeout​()
      获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。
      int ConnectionPoolDataSource.getLoginTimeout​()
      获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。
      int DataSource.getLoginTimeout​()
      获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。
      int XADataSource.getLoginTimeout​()
      获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。
      PrintWriter CommonDataSource.getLogWriter​()
      检索此 DataSource对象的日志记录器。
      PrintWriter ConnectionPoolDataSource.getLogWriter​()
      检索此 DataSource对象的日志记录器。
      PrintWriter DataSource.getLogWriter​()
      检索此 DataSource对象的日志记录器。
      PrintWriter XADataSource.getLogWriter​()
      检索 DataSource对象的日志记录器。
      int RowSet.getMaxFieldSize​()
      检索某些列值可能返回的最大字节数。
      int RowSet.getMaxRows​()
      检索此 RowSet对象可以包含的最大行数。
      ResultSet RowSetInternal.getOriginal​()
      检索 ResultSet含有该原始值对象 RowSet对象。
      ResultSet RowSetInternal.getOriginalRow​()
      检索包含当前行的原始值的 ResultSet对象。
      Object[] RowSetInternal.getParams​()
      检索为此 RowSet对象的命令设置的参数。
      PooledConnection ConnectionPoolDataSource.getPooledConnection​()
      尝试建立可用作池连接的物理数据库连接。
      PooledConnection ConnectionPoolDataSource.getPooledConnection​(String user, String password)
      尝试建立可用作池连接的物理数据库连接。
      int RowSet.getQueryTimeout​()
      检索驱动程序等待语句执行的最大秒数。
      Map<String,Class<?>> RowSet.getTypeMap​()
      检索与此 Map对象关联的 RowSet对象，该对象指定SQL用户定义类型（如果有）的自定义映射。
      String RowSet.getUrl​()
      检索url属性这个 RowSet对象将用于创建连接，如果它使用 DriverManager代替的 DataSource对象建立连接。
      XAConnection XADataSource.getXAConnection​()
      尝试建立可在分布式事务中使用的物理数据库连接。
      XAConnection XADataSource.getXAConnection​(String user, String password)
      尝试使用给定的用户名和密码建立物理数据库连接。
      XAResource XAConnection.getXAResource​()
      检索一个 XAResource对象，事务管理器将使用管理这个 XAConnection分布式事务对象的参与。
      void RowSetReader.readData​(RowSetInternal caller)
      读取调用 RowSet对象的新内容。
      void RowSet.setArray​(int i, Array x)
      使用给定的 Array值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setAsciiStream​(int parameterIndex, InputStream x)
      将此 RowSet对象的命令中的指定参数设置为给定的输入流。
      void RowSet.setAsciiStream​(int parameterIndex, InputStream x, int length)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.io.InputStream值。
      void RowSet.setAsciiStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void RowSet.setAsciiStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void RowSetMetaData.setAutoIncrement​(int columnIndex, boolean property)
      设置指定列是否自动编号，默认值为 RowSet对象的列不会自动编号。
      void RowSet.setBigDecimal​(int parameterIndex, BigDecimal x)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.math.BigDecimal值。
      void RowSet.setBigDecimal​(String parameterName, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。
      void RowSet.setBinaryStream​(int parameterIndex, InputStream x)
      将此 RowSet对象的命令中的指定参数设置为给定的输入流。
      void RowSet.setBinaryStream​(int parameterIndex, InputStream x, int length)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.io.InputStream值。
      void RowSet.setBinaryStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void RowSet.setBinaryStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void RowSet.setBlob​(int parameterIndex, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void RowSet.setBlob​(int parameterIndex, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void RowSet.setBlob​(int i, Blob x)
      使用给定的 Blob值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setBlob​(String parameterName, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void RowSet.setBlob​(String parameterName, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void RowSet.setBlob​(String parameterName, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。
      void RowSet.setBoolean​(int parameterIndex, boolean x)
      将此 RowSet对象的命令中的指定参数设置为给定的Java boolean值。
      void RowSet.setBoolean​(String parameterName, boolean x)
      将指定的参数设置为给定的Java boolean值。
      void RowSet.setByte​(int parameterIndex, byte x)
      将此 RowSet对象的命令中的指定参数设置为给定的Java byte值。
      void RowSet.setByte​(String parameterName, byte x)
      将指定的参数设置为给定的Java byte值。
      void RowSet.setBytes​(int parameterIndex, byte[] x)
      将此 RowSet对象的命令中的指定参数设置为给定的 byte Java数组。
      void RowSet.setBytes​(String parameterName, byte[] x)
      将指定的参数设置为给定的Java字节数组。
      void RowSetMetaData.setCaseSensitive​(int columnIndex, boolean property)
      设置指定列是否区分大小写。
      void RowSetMetaData.setCatalogName​(int columnIndex, String catalogName)
      将指定列的表的目录名称（如果有的话）设置为给定的 String 。
      void RowSet.setCharacterStream​(int parameterIndex, Reader reader)
      将此 RowSet对象的命令中的指定参数设置为给定的 Reader对象。
      void RowSet.setCharacterStream​(int parameterIndex, Reader reader, int length)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.io.Reader值。
      void RowSet.setCharacterStream​(String parameterName, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void RowSet.setCharacterStream​(String parameterName, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void RowSet.setClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void RowSet.setClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setClob​(int i, Clob x)
      使用给定的 Clob值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void RowSet.setClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setClob​(String parameterName, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。
      void RowSetMetaData.setColumnCount​(int columnCount)
      将 RowSet对象中的列数设置为给定的数字。
      void RowSetMetaData.setColumnDisplaySize​(int columnIndex, int size)
      将指定列的正常最大宽度设置为给定的 int 。
      void RowSetMetaData.setColumnLabel​(int columnIndex, String label)
      设置用于打印输出的建议列标题，并显示给给定的 String （如果有）。
      void RowSetMetaData.setColumnName​(int columnIndex, String columnName)
      将指定列的名称设置为给定的 String 。
      void RowSetMetaData.setColumnType​(int columnIndex, int SQLType)
      将指定列的SQL类型设置为给定的列。
      void RowSetMetaData.setColumnTypeName​(int columnIndex, String typeName)
      将指定列的类型名称（如果有的话）设置为给定的 String 。
      void RowSet.setCommand​(String cmd)
      将此 RowSet对象的命令属性设置为给定的SQL查询。
      void RowSet.setConcurrency​(int concurrency)
      将此 RowSet对象的并发设置为给定的并发级别。
      void RowSetMetaData.setCurrency​(int columnIndex, boolean property)
      设置指定列是否为现金值。
      void RowSet.setDataSourceName​(String name)
      将此 RowSet对象的数据源名称属性设置为给定的 String 。
      void RowSet.setDate​(int parameterIndex, Date x)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.sql.Date值。
      void RowSet.setDate​(int parameterIndex, Date x, Calendar cal)
      使用给定的 java.sql.Date值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setDate​(String parameterName, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void RowSet.setDate​(String parameterName, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void RowSet.setDouble​(int parameterIndex, double x)
      将此 RowSet对象的命令中的指定参数设置为给定的Java double值。
      void RowSet.setDouble​(String parameterName, double x)
      将指定的参数设置为给定的Java double值。
      void RowSet.setEscapeProcessing​(boolean enable)
      设置此 RowSet对象的转义处理开启或关闭。
      void RowSet.setFloat​(int parameterIndex, float x)
      将此 RowSet对象的命令中的指定参数设置为给定的Java float值。
      void RowSet.setFloat​(String parameterName, float x)
      将指定的参数设置为给定的Java float值。
      void RowSet.setInt​(int parameterIndex, int x)
      将此 RowSet对象的命令中的指定参数设置为给定的Java int值。
      void RowSet.setInt​(String parameterName, int x)
      将指定的参数设置为给定的Java int值。
      void CommonDataSource.setLoginTimeout​(int seconds)
      设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。
      void ConnectionPoolDataSource.setLoginTimeout​(int seconds)
      设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。
      void DataSource.setLoginTimeout​(int seconds)
      设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。
      void XADataSource.setLoginTimeout​(int seconds)
      设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。
      void CommonDataSource.setLogWriter​(PrintWriter out)
      将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。
      void ConnectionPoolDataSource.setLogWriter​(PrintWriter out)
      将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。
      void DataSource.setLogWriter​(PrintWriter out)
      将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。
      void XADataSource.setLogWriter​(PrintWriter out)
      将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。
      void RowSet.setLong​(int parameterIndex, long x)
      将此 RowSet对象的命令中的指定参数设置为给定的Java long值。
      void RowSet.setLong​(String parameterName, long x)
      将指定的参数设置为给定的Java long值。
      void RowSet.setMaxFieldSize​(int max)
      将列值返回的最大字节数设置为给定的字节数。
      void RowSet.setMaxRows​(int max)
      将此 RowSet对象的最大行数设置为指定的数字。
      void RowSetInternal.setMetaData​(RowSetMetaData md)
      将给定的 RowSetMetaData对象设置为 RowSetMetaData对象的 RowSet对象。
      void RowSet.setNCharacterStream​(int parameterIndex, Reader value)
      将此 RowSet对象的命令中的指定参数设置为 Reader对象。
      void RowSet.setNCharacterStream​(int parameterIndex, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setNCharacterStream​(String parameterName, Reader value)
      将指定的参数设置为 Reader对象。
      void RowSet.setNCharacterStream​(String parameterName, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setNClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void RowSet.setNClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setNClob​(int parameterIndex, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void RowSet.setNClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void RowSet.setNClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setNClob​(String parameterName, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void RowSet.setNString​(int parameterIndex, String value)
      将指定的参数设置为给定的 String对象。
      void RowSet.setNString​(String parameterName, String value)
      将指定的参数设置为给定的 String对象。
      void RowSet.setNull​(int parameterIndex, int sqlType)
      将此 RowSet对象的SQL命令中的指定参数设置为SQL NULL 。
      void RowSet.setNull​(int paramIndex, int sqlType, String typeName)
      将此 RowSet对象的SQL命令中的指定参数设置为SQL NULL 。
      void RowSet.setNull​(String parameterName, int sqlType)
      将指定的参数设置为SQL NULL 。
      void RowSet.setNull​(String parameterName, int sqlType, String typeName)
      将指定的参数设置为SQL NULL 。
      void RowSetMetaData.setNullable​(int columnIndex, int property)
      设置指定列的值是否可以设置为 NULL 。
      void RowSet.setObject​(int parameterIndex, Object x)
      使用Java Object在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setObject​(int parameterIndex, Object x, int targetSqlType)
      使用Java Object在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setObject​(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
      使用给定的Java Object在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setObject​(String parameterName, Object x)
      使用给定对象设置指定参数的值。
      void RowSet.setObject​(String parameterName, Object x, int targetSqlType)
      使用给定对象设置指定参数的值。
      void RowSet.setObject​(String parameterName, Object x, int targetSqlType, int scale)
      使用给定对象设置指定参数的值。
      void RowSet.setPassword​(String password)
      将此 RowSet对象的数据库密码设置为给定的 String 。
      void RowSetMetaData.setPrecision​(int columnIndex, int precision)
      将指定列的十进制数字数设置为给定的 int 。
      void RowSet.setQueryTimeout​(int seconds)
      设置驱动程序等待语句执行到给定秒数的最长时间。
      void RowSet.setReadOnly​(boolean value)
      设置此 RowSet对象是否为只读到给定的 boolean 。
      void RowSet.setRef​(int i, Ref x)
      使用给定的 Ref值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setRowId​(int parameterIndex, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void RowSet.setRowId​(String parameterName, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void RowSetMetaData.setScale​(int columnIndex, int scale)
      将指定列的小数点右侧的位数设置为给定的 int 。
      void RowSetMetaData.setSchemaName​(int columnIndex, String schemaName)
      将指定列的表的模式（如果有）的名称设置为给定的 String 。
      void RowSetMetaData.setSearchable​(int columnIndex, boolean property)
      设置指定的列是否可以在where子句中使用。
      void RowSet.setShort​(int parameterIndex, short x)
      将此 RowSet对象的命令中的指定参数设置为给定的Java short值。
      void RowSet.setShort​(String parameterName, short x)
      将指定的参数设置为给定的Java short值。
      void RowSetMetaData.setSigned​(int columnIndex, boolean property)
      设置指定的列是否是有符号的数字。
      void RowSet.setSQLXML​(int parameterIndex, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void RowSet.setSQLXML​(String parameterName, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void RowSet.setString​(int parameterIndex, String x)
      将此 RowSet对象的命令中的指定参数设置为给定的Java String值。
      void RowSet.setString​(String parameterName, String x)
      将指定的参数设置为给定的Java String值。
      void RowSetMetaData.setTableName​(int columnIndex, String tableName)
      将指定列的表名称（如果有）设置为给定的 String 。
      void RowSet.setTime​(int parameterIndex, Time x)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.sql.Time值。
      void RowSet.setTime​(int parameterIndex, Time x, Calendar cal)
      使用给定的 java.sql.Time值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setTime​(String parameterName, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void RowSet.setTime​(String parameterName, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void RowSet.setTimestamp​(int parameterIndex, Timestamp x)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.sql.Timestamp值。
      void RowSet.setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      使用给定的 java.sql.Timestamp值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setTimestamp​(String parameterName, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void RowSet.setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。
      void RowSet.setTransactionIsolation​(int level)
      设置此 RowSet对象的事务隔离级别。
      void RowSet.setType​(int type)
      将此 RowSet对象的类型设置为给定类型。
      void RowSet.setTypeMap​(Map<String,Class<?>> map)
      安装给定 java.util.Map对象的默认类型映射此 RowSet对象。
      void RowSet.setUrl​(String url)
      设置 RowSet对象在使用 DriverManager创建连接时将使用的URL。
      void RowSet.setURL​(int parameterIndex, URL x)
      将指定的参数设置为给定的 java.net.URL值。
      void RowSet.setUsername​(String name)
      将此 RowSet对象的用户名属性设置为给定的 String 。
      boolean RowSetWriter.writeData​(RowSetInternal caller)
      将此 RowSetWriter对象的行 RowSetWriter的更改写回数据源，从中获取其数据。
      Constructors in javax.sql with parameters of type SQLException
      Constructor 描述
      ConnectionEvent​(PooledConnection con, SQLException ex)
      构造一个 ConnectionEvent对象，该对象使用给定的 PooledConnection对象和 SQLException对象进行初始化。
      StatementEvent​(PooledConnection con, PreparedStatement statement, SQLException exception)
      构造一个 StatementEvent具有指定 PooledConnection ， PreparedStatement和 SQLException

    • Uses of SQLException in javax.sql.rowset

      Subclasses of SQLException in javax.sql.rowset
      Modifier and Type Class 描述
      class  RowSetWarning
      扩展名为 SQLException ，其中提供了有关在 RowSet对象上设置的数据库警告的信息。
      Methods in javax.sql.rowset that throw SQLException
      Modifier and Type 方法 描述
      void JoinRowSet.addRowSet​(Joinable rowset)
      将给定的 RowSet对象添加到此 JoinRowSet对象。
      void JoinRowSet.addRowSet​(RowSet[] rowset, int[] columnIdx)
      将一个或多个 RowSet包含的给定阵列中的对象 RowSet对象此 JoinRowSet对象，并为每一个的匹配列 RowSet对象列索引的给定阵列中的匹配列。
      void JoinRowSet.addRowSet​(RowSet[] rowset, String[] columnName)
      将包含在给定的 RowSet对象数组中的一个或多个 RowSet对象添加到此 JoinRowSet对象，并将每个 RowSet对象的匹配列设置为给定列名称数组中的匹配列。
      void JoinRowSet.addRowSet​(RowSet rowset, int columnIdx)
      将给定的 RowSet对象添加到此 JoinRowSet对象，并将指定的列设置为 RowSet对象的匹配列。
      void JoinRowSet.addRowSet​(RowSet rowset, String columnName)
      将 rowset添加到此 JoinRowSet对象，并将指定列设置为匹配列。
      void BaseRowSet.clearParameters​()
      清除此 RowSet对象在执行此 RowSet对象的命令时要设置的参数的内部表示形式中的所有当前参数值。
      boolean CachedRowSet.columnUpdated​(int idx)
      指示此 CachedRowSet对象的当前行中的指定列是否已更新。
      boolean CachedRowSet.columnUpdated​(String columnName)
      指示此 CachedRowSet对象的当前行中的指定列是否已更新。
      void CachedRowSet.commit​()
      每个 CachedRowSet对象的 SyncProvider包含一个 Connection对象，从 ResultSet或JDBC属性传递给它的构造函数。
      void JdbcRowSet.commit​()
      每个 JdbcRowSet包含一个 Connection对象，从 ResultSet或JDBC属性传递给它的构造函数。
      CachedRowSet RowSetFactory.createCachedRowSet​()
      创建一个新的CachedRowSet实例。
      CachedRowSet CachedRowSet.createCopy​()
      创建 RowSet对象，该对象是此 CachedRowSet对象中的数据的深层副本。
      CachedRowSet CachedRowSet.createCopyNoConstraints​()
      创建一个 CachedRowSet对象，它是该 CachedRowSet对象的数据的深层副本，但是 CachedRowSet无关。
      CachedRowSet CachedRowSet.createCopySchema​()
      创建一个 CachedRowSet对象，该对象为该 CachedRowSet对象的空白副本。
      FilteredRowSet RowSetFactory.createFilteredRowSet​()
      创建一个新的FilteredRowSet实例。
      JdbcRowSet RowSetFactory.createJdbcRowSet​()
      创建一个新的JdbcRowSet实例。
      JoinRowSet RowSetFactory.createJoinRowSet​()
      创建一个JoinRowSet的新实例。
      RowSet CachedRowSet.createShared​()
      返回一个新 RowSet由相同的数据与此的支持对象 CachedRowSet对象。
      WebRowSet RowSetFactory.createWebRowSet​()
      创建一个WebRowSet的新实例。
      boolean Predicate.evaluate​(Object value, int column)
      该方法由 FilteredRowSet对象调用，以检查值是否位于使用 setFilter()方法设置的过滤条件（或存在多个约束的条件） setFilter() 。
      boolean Predicate.evaluate​(Object value, String columnName)
      该方法由 FilteredRowSet对象调用，以检查该值是否在使用setFilter方法设置的过滤条件之间。
      void CachedRowSet.execute​(Connection conn)
      使用数据填充此 CachedRowSet对象，使用给定的连接生成将从中读取数据的结果集。
      boolean JdbcRowSet.getAutoCommit​()
      每个 JdbcRowSet包含一个 Connection对象，从原来的 ResultSet或JDBC属性传递给它。
      String RowSetMetaDataImpl.getCatalogName​(int columnIndex)
      检索从中导出指定列中的值的表的目录名称。
      String RowSetMetaDataImpl.getColumnClassName​(int columnIndex)
      以指定列中的值映射到的Java编程语言中的类的全限定名称。
      int RowSetMetaDataImpl.getColumnCount​()
      检索创建此 RowSetMetaDataImpl对象的 RowSet对象中的列数。
      int RowSetMetaDataImpl.getColumnDisplaySize​(int columnIndex)
      检索指定列的字符的正常最大宽度。
      String RowSetMetaDataImpl.getColumnLabel​(int columnIndex)
      检索指定列的建议列标题，以用于打印输出和显示。
      String RowSetMetaDataImpl.getColumnName​(int columnIndex)
      检索指定列的名称。
      int RowSetMetaDataImpl.getColumnType​(int columnIndex)
      检索存储在指定列中的SQL类型的类型代码（ java.sql.Types常量之一）。
      String RowSetMetaDataImpl.getColumnTypeName​(int columnIndex)
      检索存储在指定列中的值的DBMS特定类型名称。
      int BaseRowSet.getConcurrency​()
      返回此 RowSet对象的并发性。
      boolean BaseRowSet.getEscapeProcessing​()
      确定是否启用此 RowSet对象的转义处理。
      int BaseRowSet.getFetchDirection​()
      检索此 RowSet对象的当前提取方向设置。
      int BaseRowSet.getFetchSize​()
      返回此 RowSet对象的提取大小。
      int JoinRowSet.getJoinType​()
      返回描述管理此JoinRowSet实例的集合SQL JOIN一个 int 。
      int[] CachedRowSet.getKeyColumns​()
      返回一个包含一个或多个列号的数组，该列数表示形成唯一标识此 CachedRowSet对象行的键。
      int[] Joinable.getMatchColumnIndexes​()
      使用方法 setMatchColumn(int[] columnIdxes)检索为此 RowSet对象设置的匹配列的索引。
      String[] Joinable.getMatchColumnNames​()
      检索使用方法 setMatchColumn(String [] columnNames)为此 RowSet对象设置的匹配列的名称。
      int BaseRowSet.getMaxFieldSize​()
      检索此 RowSet对象中可用于列值的最大字节数。
      int BaseRowSet.getMaxRows​()
      检索此 RowSet对象可能包含的最大行数。
      ResultSet CachedRowSet.getOriginal​()
      返回一个 ResultSet包含该原始值对象 CachedRowSet对象。
      ResultSet CachedRowSet.getOriginalRow​()
      返回一个 ResultSet对象，其中仅包含此 CachedRowSet对象的当前行的原始值。
      Object[] BaseRowSet.getParams​()
      检索一个数组，其中包含已为此 RowSet对象的命令设置的参数值（对象和基元），如果尚未设置所有参数，则抛出一个 SQLException对象。
      int RowSetMetaDataImpl.getPrecision​(int columnIndex)
      检索存储在指定列中的值的总位数。
      int BaseRowSet.getQueryTimeout​()
      检索驱动程序等待查询执行的最大秒数。
      String[] JoinRowSet.getRowSetNames​()
      返回一个 String数组，其中包含添加到此 JoinRowSet对象的 RowSet对象的名称。
      Collection<?> JoinRowSet.getRowSets​()
      返回 Collection包含对象 RowSet已经添加到该物体 JoinRowSet对象。
      RowSetWarning CachedRowSet.getRowSetWarnings​()
      检索通过此 RowSet对象的呼叫报告的第一个警告。
      RowSetWarning JdbcRowSet.getRowSetWarnings​()
      检索通过此 JdbcRowSet对象的呼叫报告的第一个警告。
      int RowSetMetaDataImpl.getScale​(int columnIndex)
      检索存储在指定列中的值的小数点右边的位数。
      String RowSetMetaDataImpl.getSchemaName​(int columnIndex)
      检索从中导出指定列中的值的表的模式名称。
      boolean BaseRowSet.getShowDeleted​()
      检索 boolean指示标记为删除的行是否显示在当前行的集合中。
      boolean CachedRowSet.getShowDeleted​()
      检索 boolean指示标记为删除的行是否显示在当前行的集合中。
      boolean JdbcRowSet.getShowDeleted​()
      检索 boolean指示标记为删除的行是否显示在当前行的集合中。
      SyncProvider CachedRowSet.getSyncProvider​()
      检索 CachedRowSet对象的 SyncProvider实现。
      String CachedRowSet.getTableName​()
      返回用于创建此 CachedRowSet对象的对象（表）的标识符。
      String RowSetMetaDataImpl.getTableName​(int columnIndex)
      检索从中导出指定列中的值的表的名称。
      int BaseRowSet.getType​()
      返回此 RowSet对象的类型。
      String BaseRowSet.getUrl​()
      检索此 RowSet对象的 javax.sql.Reader对象用于使用启用JDBC技术的驱动程序与关系数据库建立连接的JDBC URL。
      String JoinRowSet.getWhereClause​()
      返回在JoinRowSet对象中使用的WHERE子句的类似SQL的描述。
      boolean RowSetMetaDataImpl.isAutoIncrement​(int columnIndex)
      检索存储在指定列中的值是否自动编号，因此是唯读的。
      boolean RowSetMetaDataImpl.isCaseSensitive​(int columnIndex)
      指示指定列的名称是否重要。
      boolean RowSetMetaDataImpl.isCurrency​(int columnIndex)
      指示存储在指定列中的值是否为现金值。
      boolean RowSetMetaDataImpl.isDefinitelyWritable​(int columnIndex)
      指示指定列上的写操作是否一定会成功。
      int RowSetMetaDataImpl.isNullable​(int columnIndex)
      检索一个常量，指示是否可以在指定列中存储 NULL值。
      boolean RowSetMetaDataImpl.isReadOnly​(int columnIndex)
      指示指定的列是否绝对不可写，因此只读。
      boolean RowSetMetaDataImpl.isSearchable​(int columnIndex)
      指示存储在指定列中的值是否可以在 WHERE子句中使用。
      boolean RowSetMetaDataImpl.isSigned​(int columnIndex)
      指示存储在指定列中的值是否为有符号数。
      boolean RowSetMetaDataImpl.isWrapperFor​(Class<?> interfaces)
      如果这实现了接口参数，或者直接或间接地为一个对象的包装器返回true。
      boolean RowSetMetaDataImpl.isWritable​(int columnIndex)
      指示指定列上的写操作是否可以成功。
      static RowSetFactory RowSetProvider.newFactory​()
      创建一个 RowSetFactory实现的新实例。
      static RowSetFactory RowSetProvider.newFactory​(String factoryClassName, ClassLoader cl)
      从指定的工厂类名称创建一个新的实例 RowSetFactory 。
      boolean CachedRowSet.nextPage​()
      增加当前页面的 CachedRowSet 。
      protected void BaseRowSet.notifyCursorMoved​()
      通知所有注册到这个 RowSet对象的听众，其游标已经移动。
      protected void BaseRowSet.notifyRowChanged​()
      通知所有在 RowSet对象注册的听众，其中一行已更改。
      protected void BaseRowSet.notifyRowSetChanged​()
      通知所有注册此 RowSet对象的听众，其全部内容已更改。
      void CachedRowSet.populate​(ResultSet data)
      填充此 CachedRowSet从给定数据对象 ResultSet对象。
      void CachedRowSet.populate​(ResultSet rs, int startRow)
      填充此 CachedRowSet从给定数据对象 ResultSet对象。
      boolean CachedRowSet.previousPage​()
      减少当前页面的 CachedRowSet 。
      void WebRowSet.readXml​(InputStream iStream)
      读取基于流的XML输入来填充此 WebRowSet对象。
      void WebRowSet.readXml​(Reader reader)
      读取 WebRowSet在从给定的XML格式对象 Reader对象。
      void CachedRowSet.release​()
      发布此 CachedRowSet对象的当前内容，并向所有注册的监听器发送一个 rowSetChanged事件。
      void CachedRowSet.restoreOriginal​()
      将此 CachedRowSet对象恢复为其原始值，即其最后一组更改前的值。
      void CachedRowSet.rollback​()
      每个 CachedRowSet对象的 SyncProvider包含一个 Connection对象，从原始的 ResultSet或JDBC属性传递给它。
      void CachedRowSet.rollback​(Savepoint s)
      每个 CachedRowSet对象的 SyncProvider包含一个 Connection对象，从原来的 ResultSet或JDBC属性传递给它。
      void JdbcRowSet.rollback​()
      每个 JdbcRowSet包含一个 Connection对象，从原来的 ResultSet或JDBC属性传递给它。
      void JdbcRowSet.rollback​(Savepoint s)
      每个 JdbcRowSet包含一个 Connection对象，从原来的 ResultSet或传递给它的JDBC属性。
      void CachedRowSet.rowSetPopulated​(RowSetEvent event, int numRows)
      通知已注册的侦听器给定的RowSetEvent对象中的RowSet对象已经填充了许多其他行。
      void BaseRowSet.setArray​(int parameterIndex, Array array)
      将指定的参数设置为Java编程语言中的一个 Array对象。
      void BaseRowSet.setAsciiStream​(int parameterIndex, InputStream x)
      将此 RowSet对象的命令中的指定参数设置为给定的输入流。
      void BaseRowSet.setAsciiStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的 java.io.InputStream对象，该对象将具有指定的字节数。
      void BaseRowSet.setAsciiStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void BaseRowSet.setAsciiStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void JdbcRowSet.setAutoCommit​(boolean autoCommit)
      每个 JdbcRowSet包含一个 Connection对象，从原来的 ResultSet或JDBC属性传递给它。
      void RowSetMetaDataImpl.setAutoIncrement​(int columnIndex, boolean property)
      设置指定的列是否自动编号，因此只读为给定的 boolean值。
      void BaseRowSet.setBigDecimal​(int parameterIndex, BigDecimal x)
      将指定的参数设置为给定的 java.lang.BigDecimal值。
      void BaseRowSet.setBigDecimal​(String parameterName, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。
      void BaseRowSet.setBinaryStream​(int parameterIndex, InputStream x)
      将此 RowSet对象的命令中的指定参数设置为给定的输入流。
      void BaseRowSet.setBinaryStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的 java.io.InputStream对象，该对象将具有指定的字节数。
      void BaseRowSet.setBinaryStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void BaseRowSet.setBinaryStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void BaseRowSet.setBlob​(int parameterIndex, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void BaseRowSet.setBlob​(int parameterIndex, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void BaseRowSet.setBlob​(int parameterIndex, Blob x)
      将指定的参数设置为Java编程语言中给定的 Blob对象。
      void BaseRowSet.setBlob​(String parameterName, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void BaseRowSet.setBlob​(String parameterName, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void BaseRowSet.setBlob​(String parameterName, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。
      void BaseRowSet.setBoolean​(int parameterIndex, boolean x)
      将指定的参数设置为Java编程语言中给定的 boolean 。
      void BaseRowSet.setBoolean​(String parameterName, boolean x)
      将指定的参数设置为给定的Java boolean值。
      void BaseRowSet.setByte​(int parameterIndex, byte x)
      将指定的参数设置为Java编程语言中给定的 byte 。
      void BaseRowSet.setByte​(String parameterName, byte x)
      将指定的参数设置为给定的Java byte值。
      void BaseRowSet.setBytes​(int parameterIndex, byte[] x)
      将指定的参数设置为给定的字节数组。
      void BaseRowSet.setBytes​(String parameterName, byte[] x)
      将指定的参数设置为给定的Java字节数组。
      void RowSetMetaDataImpl.setCaseSensitive​(int columnIndex, boolean property)
      设置指定列的名称是否对给定的 boolean区分大小写。
      void RowSetMetaDataImpl.setCatalogName​(int columnIndex, String catalogName)
      将派生指定列的表的目录名称设置为 catalogName 。
      void BaseRowSet.setCharacterStream​(int parameterIndex, Reader reader)
      将此 RowSet对象的命令中的指定参数设置为给定的 Reader对象。
      void BaseRowSet.setCharacterStream​(int parameterIndex, Reader reader, int length)
      将指定的参数设置为给定的 java.io.Reader对象，该对象将具有指定的字符数。
      void BaseRowSet.setCharacterStream​(String parameterName, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void BaseRowSet.setCharacterStream​(String parameterName, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void BaseRowSet.setClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setClob​(int parameterIndex, Clob x)
      将指定的参数设置为Java编程语言中给定的 Clob对象。
      void BaseRowSet.setClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setClob​(String parameterName, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。
      void RowSetMetaDataImpl.setColumnCount​(int columnCount)
      将该 RowSetMetaDataImpl对象的对象创建为 RowSet对象的列数设置为给定的数字。
      void RowSetMetaDataImpl.setColumnDisplaySize​(int columnIndex, int size)
      将指定列中正常的最大字符数设置为给定的数字。
      void RowSetMetaDataImpl.setColumnLabel​(int columnIndex, String label)
      设置建议的列标签，用于打印输出和显示（如果有） 标签 。
      void RowSetMetaDataImpl.setColumnName​(int columnIndex, String columnName)
      将指定列的列名称设置为给定的名称。
      void RowSetMetaDataImpl.setColumnType​(int columnIndex, int SQLType)
      将存储在指定列中的值的SQL类型代码从类 java.sql.Types设置为给定类型代码。
      void RowSetMetaDataImpl.setColumnTypeName​(int columnIndex, String typeName)
      将存储在指定列中的值的数据源使用的类型名称设置为给定的类型名称。
      void BaseRowSet.setCommand​(String cmd)
      将此 RowSet对象的 command属性设置为给定的 String对象，并清除为先前命令设置的参数（如果有）。
      void BaseRowSet.setConcurrency​(int concurrency)
      将此 RowSet对象的并发设置为指定的并发。
      void RowSetMetaDataImpl.setCurrency​(int columnIndex, boolean property)
      设置存储在指定列中的值是否为给定的 boolean的现金值。
      void BaseRowSet.setDataSourceName​(String name)
      将此 RowSet对象的 DataSource名称属性设置为给定的逻辑名称，并将此 RowSet对象的Url属性设置为 null 。
      void BaseRowSet.setDate​(int parameterIndex, Date x)
      将指定的参数设置为给定的 java.sql.Date值。
      void BaseRowSet.setDate​(int parameterIndex, Date x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Date对象。
      void BaseRowSet.setDate​(String parameterName, Date x)
      使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。
      void BaseRowSet.setDate​(String parameterName, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void BaseRowSet.setDouble​(int parameterIndex, double x)
      将指定的参数设置为Java编程语言中给定的 double 。
      void BaseRowSet.setDouble​(String parameterName, double x)
      将指定的参数设置为给定的Java double值。
      void BaseRowSet.setEscapeProcessing​(boolean enable)
      设置给给定的 boolean驱动程序是否将扫描转义语法，并在将SQL语句发送到数据库之前执行转义替换。
      void BaseRowSet.setFetchDirection​(int direction)
      向驱动程序提供关于将处理此 RowSet对象中的行的方向的性能提示。
      void BaseRowSet.setFetchSize​(int rows)
      将此 RowSet对象的提取大小设置为给定的行数。
      void FilteredRowSet.setFilter​(Predicate p)
      将给定的 Predicate对象应用于此 FilteredRowSet对象。
      void BaseRowSet.setFloat​(int parameterIndex, float x)
      将指定的参数设置为Java编程语言中给定的 float 。
      void BaseRowSet.setFloat​(String parameterName, float x)
      将指定的参数设置为给定的Java float值。
      void BaseRowSet.setInt​(int parameterIndex, int x)
      将指定的参数设置为Java编程语言中的一个 int 。
      void BaseRowSet.setInt​(String parameterName, int x)
      将指定的参数设置为给定的Java int值。
      void JoinRowSet.setJoinType​(int joinType)
      允许应用程序调整JoinRowSet对象实例中包含的表所强制的类型 JOIN 。
      void CachedRowSet.setKeyColumns​(int[] keys)
      将这个 CachedRowSet对象的 keyCols字段设置为给定的列号数组，这样形成一个用于唯一标识这个 CachedRowSet对象的行的键。
      void BaseRowSet.setLong​(int parameterIndex, long x)
      将指定的参数设置为Java编程语言中给定的 long 。
      void BaseRowSet.setLong​(String parameterName, long x)
      将指定的参数设置为给定的Java long值。
      void Joinable.setMatchColumn​(int columnIdx)
      将指定列设置为此 RowSet对象的匹配列。
      void Joinable.setMatchColumn​(int[] columnIdxes)
      将指定的列设置为此 RowSet对象的匹配列。
      void Joinable.setMatchColumn​(String columnName)
      将指定列设置为此 RowSet对象的匹配列。
      void Joinable.setMatchColumn​(String[] columnNames)
      将指定的列设置为此 RowSet对象的匹配列。
      void BaseRowSet.setMaxFieldSize​(int max)
      将此 RowSet对象中的列值的最大字节数设置为给定的数字。
      void BaseRowSet.setMaxRows​(int max)
      将此 RowSet对象的最大行数设置为给定的数字。
      void CachedRowSet.setMetaData​(RowSetMetaData md)
      使用给定的 RowSetMetaData对象设置此 CachedRowSet对象的元数据。
      void BaseRowSet.setNCharacterStream​(int parameterIndex, Reader value)
      将此 RowSet对象的命令中的指定参数设置为 Reader对象。
      void BaseRowSet.setNCharacterStream​(int parameterIndex, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNCharacterStream​(String parameterName, Reader value)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNCharacterStream​(String parameterName, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNClob​(int parameterIndex, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void BaseRowSet.setNClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNClob​(String parameterName, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void BaseRowSet.setNString​(int parameterIndex, String value)
      将指定的参数设置为给定的 String对象。
      void BaseRowSet.setNString​(String parameterName, String value)
      将指定的参数设置为给定的 String对象。
      void BaseRowSet.setNull​(int parameterIndex, int sqlType)
      将指定的参数设置为SQL NULL 。
      void BaseRowSet.setNull​(int parameterIndex, int sqlType, String typeName)
      将指定的参数设置为SQL NULL 。
      void BaseRowSet.setNull​(String parameterName, int sqlType)
      将指定的参数设置为SQL NULL 。
      void BaseRowSet.setNull​(String parameterName, int sqlType, String typeName)
      将指定的参数设置为SQL NULL 。
      void RowSetMetaDataImpl.setNullable​(int columnIndex, int property)
      设置是否存储在指定列中的值可以被设置为 NULL从界面到给定的常量 ResultSetMetaData 。
      void BaseRowSet.setObject​(int parameterIndex, Object x)
      将指定的参数设置为Java编程语言中的一个 Object 。
      void BaseRowSet.setObject​(int parameterIndex, Object x, int targetSqlType)
      使用给定的 Object值设置指定参数的值。
      void BaseRowSet.setObject​(int parameterIndex, Object x, int targetSqlType, int scale)
      将指定的参数设置为Java编程语言中的一个 Object 。
      void BaseRowSet.setObject​(String parameterName, Object x)
      使用给定对象设置指定参数的值。
      void BaseRowSet.setObject​(String parameterName, Object x, int targetSqlType)
      使用给定对象设置指定参数的值。
      void BaseRowSet.setObject​(String parameterName, Object x, int targetSqlType, int scale)
      使用给定对象设置指定参数的值。
      void CachedRowSet.setOriginalRow​()
      将此 CachedRowSet对象中的当前行设置为原始行。
      void CachedRowSet.setPageSize​(int size)
      设置 CachedRowSet对象的页面大小。
      void RowSetMetaDataImpl.setPrecision​(int columnIndex, int precision)
      将存储在指定列中的值中的十进制数字的总数设置为给定的数字。
      void BaseRowSet.setQueryTimeout​(int seconds)
      将给定的数字设置为驱动程序等待查询执行的最大秒数。
      void BaseRowSet.setRef​(int parameterIndex, Ref ref)
      将指定的参数设置为Java编程语言中给定的 Ref对象。
      void BaseRowSet.setRowId​(int parameterIndex, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void BaseRowSet.setRowId​(String parameterName, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void RowSetMetaDataImpl.setScale​(int columnIndex, int scale)
      将存储在指定列中的值中的小数点右边的位数设置为给定的数字。
      void RowSetMetaDataImpl.setSchemaName​(int columnIndex, String schemaName)
      将指定列的表的模式名称（如果有）设置为 schemaName 。
      void RowSetMetaDataImpl.setSearchable​(int columnIndex, boolean property)
      设置在给定的 boolean值的 WHERE子句中是否可以使用存储在指定列中的值。
      void BaseRowSet.setShort​(int parameterIndex, short x)
      将指定的参数设置为Java编程语言中给定的 short 。
      void BaseRowSet.setShort​(String parameterName, short x)
      将指定的参数设置为给定的Java short值。
      void BaseRowSet.setShowDeleted​(boolean value)
      将属性 showDeleted设置为给定的 boolean值，该值确定标记为删除的行是否显示在当前行的集合中。
      void CachedRowSet.setShowDeleted​(boolean b)
      将属性 showDeleted设置为给定的 boolean值，该值确定标记为删除的行是否显示在当前行的集合中。
      void JdbcRowSet.setShowDeleted​(boolean b)
      将属性 showDeleted设置为给定的 boolean值。
      void RowSetMetaDataImpl.setSigned​(int columnIndex, boolean property)
      设置存储在指定列中的值是否为给定的 boolean 。
      void BaseRowSet.setSQLXML​(int parameterIndex, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void BaseRowSet.setSQLXML​(String parameterName, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void BaseRowSet.setString​(int parameterIndex, String x)
      将指定的参数设置为给定的 String值。
      void BaseRowSet.setString​(String parameterName, String x)
      将指定的参数设置为给定的Java String值。
      void CachedRowSet.setSyncProvider​(String provider)
      设置 SyncProvider此对象 CachedRowSet对象到指定的一个。
      void CachedRowSet.setTableName​(String tabName)
      将此派生的 CachedRowSet对象的表的标识符设置为给定的表名。
      void RowSetMetaDataImpl.setTableName​(int columnIndex, String tableName)
      将派生指定列的表的名称设置为给定的表名。
      void BaseRowSet.setTime​(int parameterIndex, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void BaseRowSet.setTime​(int parameterIndex, Time x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Time对象。
      void BaseRowSet.setTime​(String parameterName, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void BaseRowSet.setTime​(String parameterName, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void BaseRowSet.setTimestamp​(int parameterIndex, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void BaseRowSet.setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Timestamp对象。
      void BaseRowSet.setTimestamp​(String parameterName, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void BaseRowSet.setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。
      void BaseRowSet.setTransactionIsolation​(int level)
      将此JDBC RowSet对象的事务隔离属性设置为给定的常量。
      void BaseRowSet.setType​(int type)
      将此 RowSet对象的类型设置为指定的类型。
      void BaseRowSet.setUnicodeStream​(int parameterIndex, InputStream x, int length)
      已过时。
      getCharacterStream应该用于它的位置
      void BaseRowSet.setUrl​(String url)
      将此 RowSet对象的Url属性设置为给定的 String对象，并将dataSource名称属性设置为 null 。
      void BaseRowSet.setURL​(int parameterIndex, URL x)
      将指定的参数设置为给定的 java.net.URL值。
      CachedRowSet JoinRowSet.toCachedRowSet​()
      创建一个新的 CachedRowSet包含此数据对象 JoinRowSet对象，它可以保存到使用数据源 SyncProvider对象为 CachedRowSet对象。
      Collection<?> CachedRowSet.toCollection​()
      这个转换 CachedRowSet对象为 Collection包含所有这一切的目的 CachedRowSet对象的数据。
      Collection<?> CachedRowSet.toCollection​(int column)
      将此 CachedRowSet对象中的指定列转换为 Collection对象。
      Collection<?> CachedRowSet.toCollection​(String column)
      将此 CachedRowSet对象中的指定列转换为 Collection对象。
      void CachedRowSet.undoDelete​()
      取消删除当前行并通知侦听器行已更改。
      void CachedRowSet.undoInsert​()
      如果已经插入了该行，则立即将该行从 CachedRowSet对象中删除，并通知侦听器行已更改。
      void CachedRowSet.undoUpdate​()
      如果该行已被修改，立即反转最后一次更新操作。
      void Joinable.unsetMatchColumn​(int columnIdx)
      将指定的列 RowSet为该 RowSet对象的匹配列。
      void Joinable.unsetMatchColumn​(int[] columnIdxes)
      将指定的列 RowSet为该 RowSet对象的匹配列。
      void Joinable.unsetMatchColumn​(String columnName)
      将指定的列 RowSet为该 RowSet对象的匹配列。
      void Joinable.unsetMatchColumn​(String[] columnName)
      将指定的列 RowSet为该 RowSet对象的匹配列。
      <T> T RowSetMetaDataImpl.unwrap​(Class<T> iface)
      返回一个实现给定接口以允许访问非标准方法的对象，或代理不公开的标准方法。
      void WebRowSet.writeXml​(OutputStream oStream)
      将此 WebRowSet对象的数据，属性和元数据以XML格式写入给定的 OutputStream对象。
      void WebRowSet.writeXml​(Writer writer)
      将此 WebRowSet对象的数据，属性和元数据以XML格式写入给定的 Writer对象。
      void WebRowSet.writeXml​(ResultSet rs, OutputStream oStream)
      使用给定的 ResultSet对象的内容填充此 WebRowSet对象，并将其数据，属性和元数据以XML格式写入给定的 OutputStream对象。
      void WebRowSet.writeXml​(ResultSet rs, Writer writer)
      使用给定的 ResultSet对象的内容填充此 WebRowSet对象，并将其数据，属性和元数据以XML格式写入给定的 Writer对象。

    • Uses of SQLException in javax.sql.rowset.serial

      Subclasses of SQLException in javax.sql.rowset.serial
      Modifier and Type Class 描述
      class  SerialException
      指示和错误，序列化或 BLOB, CLOB, STRUCT or ARRAY序列化的SQL类型，如 BLOB, CLOB, STRUCT or ARRAY除了SQL类型，如 DATALINK and JAVAOBJECT
      Methods in javax.sql.rowset.serial that throw SQLException
      Modifier and Type 方法 描述
      void SerialArray.free​()
      该方法可以释放 SerialArray对象并释放它所拥有的资源。
      void SerialBlob.free​()
      该方法可以释放 SerialBlob对象并释放其拥有的资源。
      void SerialClob.free​()
      该方法可以释放 SerialClob对象并释放它所拥有的资源。
      InputStream SerialClob.getAsciiStream​()
      检索由 SerialClob对象指定的 CLOB值作为ascii流。
      InputStream SerialBlob.getBinaryStream​(long pos, long length)
      返回一个包含部分 Blob值的 InputStream对象，从pos指定的字节开始，长度为长度字节。
      Reader SerialClob.getCharacterStream​(long pos, long length)
      返回一个包含部分 SerialClob值的 Reader对象，以pos指定的字符开头，长度为长度字符。
      long SerialBlob.position​(byte[] pattern, long start)
      返回此 SerialBlob对象中给定字节模式开始的位置，在指定位置开始搜索。
      long SerialBlob.position​(Blob pattern, long start)
      返回此 SerialBlob对象中的位置，其中给定的 Blob对象开始，开始在指定位置的搜索。
      long SerialClob.position​(String searchStr, long start)
      返回此 SerialClob对象中的位置，给定的 String对象开始，开始在指定位置的搜索。
      long SerialClob.position​(Clob searchStr, long start)
      返回此 SerialClob对象中的位置，其中给定的 Clob签名开始，开始在指定位置的搜索。
      Array SQLInputImpl.readArray​()
      从流中读取SQL ARRAY值，并将其作为Java编程语言中的 Array对象返回。
      InputStream SQLInputImpl.readAsciiStream​()
      将此 SQLInputImpl对象中的下一个属性作为ASCII字符流返回。
      BigDecimal SQLInputImpl.readBigDecimal​()
      检索此 SQLInputImpl对象中的下一个属性为 java.math.BigDecimal 。
      InputStream SQLInputImpl.readBinaryStream​()
      将此 SQLInputImpl对象中的下一个属性作为未解释的字节流返回。
      Blob SQLInputImpl.readBlob​()
      在 SQLInputImpl对象的头部检索 BLOB值作为Java编程语言中的一个 Blob对象。
      boolean SQLInputImpl.readBoolean​()
      获取此的下一个属性 SQLInputImpl对象为 boolean的Java编程语言。
      byte SQLInputImpl.readByte​()
      获取此的下一个属性 SQLInputImpl对象为 byte的Java编程语言。
      byte[] SQLInputImpl.readBytes​()
      将此 SQLInputImpl对象中的下一个属性作为字节数组检索。
      Reader SQLInputImpl.readCharacterStream​()
      将此 SQLInputImpl对象中的下一个属性作为Unicode字符流检索。
      Clob SQLInputImpl.readClob​()
      以 SQLInputImpl对象作为 Clob对象的Java编程语言 CLOB值。
      Date SQLInputImpl.readDate​()
      将此 SQLInputImpl的下一个属性作为 java.sql.Date对象获取。
      double SQLInputImpl.readDouble​()
      检索此 SQLInputImpl对象中的下一个属性为Java编程语言中的 double 。
      float SQLInputImpl.readFloat​()
      将这个 SQLInputImpl对象中的下一个属性作为Java编程语言中的一个 float 。
      int SQLInputImpl.readInt​()
      检索此 SQLInputImpl对象中的下一个属性为Java编程语言中的 int 。
      long SQLInputImpl.readLong​()
      将这个 SQLInputImpl对象中的下一个属性作为Java编程语言中的一个 long检索。
      NClob SQLInputImpl.readNClob​()
      从流中读取SQL NCLOB值，并将其作为Java编程语言中的 Clob对象返回。
      String SQLInputImpl.readNString​()
      读取流中的下一个属性，并将其作为Java编程语言中的 String返回。
      Object SQLInputImpl.readObject​()
      获取该 SQLInputImpl对象头部的值作为Java编程语言中的 Object 。
      Ref SQLInputImpl.readRef​()
      将该 SQLInputImpl对象的头部的值作为Java编程语言中的 Ref对象检索。
      RowId SQLInputImpl.readRowId​()
      从流中读取SQL ROWID值，并将其作为Java编程语言中的 RowId对象返回。
      short SQLInputImpl.readShort​()
      将此 SQLInputImpl对象中的下一个属性作为Java编程语言中的 short 。
      SQLXML SQLInputImpl.readSQLXML​()
      从流中读取SQL XML值，并将其作为Java编程语言中的 SQLXML对象返回。
      String SQLInputImpl.readString​()
      获取此的下一个属性 SQLInputImpl对象为 String的Java编程语言。
      Time SQLInputImpl.readTime​()
      将此 SQLInputImpl对象中的下一个属性检索为 java.sql.Time对象。
      Timestamp SQLInputImpl.readTimestamp​()
      将此 SQLInputImpl对象中的下一个属性检索为 java.sql.Timestamp对象。
      URL SQLInputImpl.readURL​()
      从流中读取SQL DATALINK值，并将其作为Java编程语言中的 URL对象返回。
      OutputStream SerialClob.setAsciiStream​(long pos)
      检索流用于写入ASCII字符的 CLOB值，这 SerialClob对象表示，起始于位置 pos 。
      OutputStream SerialBlob.setBinaryStream​(long pos)
      检索可用于写入 Blob对象所代表的值的 BLOB的流。
      int SerialBlob.setBytes​(long pos, byte[] bytes)
      将给定的字节数组写入 Blob对象表示的 BLOB值，从位置 pos开始，并返回写入的字节数。
      int SerialBlob.setBytes​(long pos, byte[] bytes, int offset, int length)
      将所有或部分给定的 byte阵列写入 Blob对象表示的 BLOB值，并返回写入的字节数。
      Writer SerialClob.setCharacterStream​(long pos)
      检索流用于写入的Unicode字符流的 CLOB值，这 SerialClob对象表示，在位置 pos 。
      boolean SQLInputImpl.wasNull​()
      确定从此 SQLInputImpl对象读取的最后一个值是否为 null 。
      void SQLOutputImpl.writeArray​(Array x)
      将Java编程语言中的一个 Array对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeAsciiStream​(InputStream x)
      向这个 SQLOutputImpl对象写入一串ASCII字符。
      void SQLOutputImpl.writeBigDecimal​(BigDecimal x)
      将Java编程语言中的一个 java.math.BigDecimal对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeBinaryStream​(InputStream x)
      将一串未解释的字节写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeBlob​(Blob x)
      将Java编程语言中的 Blob对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeBoolean​(boolean x)
      将Java编程语言中的一个 boolean写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeByte​(byte x)
      将Java编程语言中的 byte写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeBytes​(byte[] x)
      将 bytes的Java编程语言的数组写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeCharacterStream​(Reader x)
      将Unicode字符串写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeClob​(Clob x)
      将Java编程语言中的一个 Clob对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeDate​(Date x)
      将Java编程语言中的一个 java.sql.Date对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeDouble​(double x)
      将Java编程语言中的 double写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeFloat​(float x)
      将Java编程语言中的 float写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeInt​(int x)
      将Java编程语言中的 int写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeLong​(long x)
      将Java编程语言中的 long写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeNClob​(NClob x)
      将SQL NCLOB值写入流。
      void SQLOutputImpl.writeNString​(String x)
      将下一个属性作为Java编程语言中的 String写入流。
      void SQLOutputImpl.writeObject​(SQLData x)
      向流中写入包含在给定的 SQLData对象中的数据。
      void SQLOutputImpl.writeRef​(Ref x)
      将Java编程语言中的一个 Ref对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeRowId​(RowId x)
      将SQL ROWID值写入流。
      void SQLOutputImpl.writeShort​(short x)
      将Java编程语言中的 short写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeSQLXML​(SQLXML x)
      将SQL XML值写入流。
      void SQLOutputImpl.writeString​(String x)
      将Java编程语言中的 String写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeStruct​(Struct x)
      将Java编程语言中的一个 Struct对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeTime​(Time x)
      将Java编程语言中的一个 java.sql.Time对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeTimestamp​(Timestamp x)
      将Java编程语言中的 java.sql.Timestamp对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeURL​(URL url)
      将Java编程语言中的一个 java.sql.Type.DATALINK对象写入此 SQLOutputImpl对象。
      Constructors in javax.sql.rowset.serial that throw SQLException
      Constructor 描述
      SerialArray​(Array array)
      构造一个新 SerialArray从给定对象 Array对象。
      SerialArray​(Array array, Map<String,Class<?>> map)
      从给定的 Array对象构造一个新的 SerialArray对象，当元素为SQL UDT时，使用给定的类型映射来定位每个元素的映射。
      SerialBlob​(byte[] b)
      构造一个 SerialBlob对象，它是给定的 byte数组的序列化版本。
      SerialBlob​(Blob blob)
      构造一个 SerialBlob对象，它是给定的 Blob对象的序列化版本。
      SerialClob​(char[] ch)
      构造一个 SerialClob对象，它是给定的 char数组的序列化版本。
      SerialClob​(Clob clob)
      构造一个 SerialClob对象，它是给定的 Clob对象的序列化版本。
      SerialRef​(Ref ref)
      构造一个 SerialRef从给定对象 Ref对象。
      SQLInputImpl​(Object[] attributes, Map<String,Class<?>> map)
      创建一个 SQLInputImpl对象，该对象使用给定的属性数组和给定的类型映射进行初始化。
      SQLOutputImpl​(Vector<?> attributes, Map<String,?> map)
      创建一个新的 SQLOutputImpl对象，使用给定的属性向量初始化并输入map。

    • Uses of SQLException in javax.sql.rowset.spi

      Subclasses of SQLException in javax.sql.rowset.spi
      Modifier and Type Class 描述
      class  SyncFactoryException
      表示 SyncFactory机制出错。
      class  SyncProviderException
      表示 SyncProvider机制出现错误。
      Methods in javax.sql.rowset.spi that throw SQLException
      Modifier and Type 方法 描述
      void TransactionalWriter.commit​()
      自从最后一次调用 commit或 rollback方法以来，永久性地执行了 acceptChanges方法的所有更改。
      Object SyncResolver.getConflictValue​(int index)
      检索此 SyncResolver对象的当前行中指定列中的值，该值是导致冲突的数据源中的值。
      Object SyncResolver.getConflictValue​(String columnName)
      检索此 SyncResolver对象的当前行中指定列中的值，该值是导致冲突的数据源中的值。
      boolean SyncResolver.nextConflict​()
      将光标从当前位置向下移动到包含冲突值的下一行。
      boolean SyncResolver.previousConflict​()
      将光标从当前位置向上移动到此 SyncResolver对象中的上一个冲突行。
      void XmlReader.readXML​(WebRowSet caller, Reader reader)
      从XML格式的给定输入流中读取和解析给定的 WebRowSet对象。
      void TransactionalWriter.rollback​()
      撤消在当前事务中所做的所有更改。
      void TransactionalWriter.rollback​(Savepoint s)
      撤消在给定的 Savepoint对象之前进行的当前交易中所做的所有更改。
      void SyncResolver.setResolvedValue​(int index, Object obj)
      将 obj设置为正在同步的 RowSet对象的当前行中的列 索引中的值。
      void SyncResolver.setResolvedValue​(String columnName, Object obj)
      将 obj设置为正在同步的 RowSet对象的当前行中的列 columnName中的值。
      void XmlWriter.writeXML​(WebRowSet caller, Writer writer)
      将给定的 WebRowSet对象写入指定的 java.io.Writer输出流作为XML文档。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLFeatureNotSupportedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLFeatureNotSupportedException

  • Packages that use SQLFeatureNotSupportedException
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。

    • Uses of SQLFeatureNotSupportedException in java.sql

      Methods in java.sql that throw SQLFeatureNotSupportedException
      Modifier and Type 方法 描述
      Logger Driver.getParentLogger​()
      返回此驱动程序使用的所有日志记录器的父记录器。

    • Uses of SQLFeatureNotSupportedException in javax.sql

      Methods in javax.sql that throw SQLFeatureNotSupportedException
      Modifier and Type 方法 描述
      Logger CommonDataSource.getParentLogger​()
      返回此数据源使用的所有日志记录器的父记录器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLIntegrityConstraintViolationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLIntegrityConstraintViolationException

No usage of java.sql.SQLIntegrityConstraintViolationException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLInvalidAuthorizationSpecException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLInvalidAuthorizationSpecException

No usage of java.sql.SQLInvalidAuthorizationSpecException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLNonTransientConnectionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLNonTransientConnectionException

No usage of java.sql.SQLNonTransientConnectionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLNonTransientException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLNonTransientException

  • Packages that use SQLNonTransientException
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of SQLNonTransientException in java.sql

      Subclasses of SQLNonTransientException in java.sql
      Modifier and Type Class 描述
      class  SQLDataException
      当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLFeatureNotSupportedException
      当SQLState类值为' 0A '（值为'零'A）时抛出的子类为SQLException 。
      class  SQLIntegrityConstraintViolationException
      当SQLState类值为“ 23 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLInvalidAuthorizationSpecException
      当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLNonTransientConnectionException
      的亚类SQLException抛出的SQLState类值“08”，或供应商指定的条件下进行。
      class  SQLSyntaxErrorException
      The subclass of SQLException thrown when the SQLState class value is ' 42', or under vendor-specified conditions.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLPermission

No usage of java.sql.SQLPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLRecoverableException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLRecoverableException

No usage of java.sql.SQLRecoverableException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLSyntaxErrorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLSyntaxErrorException

No usage of java.sql.SQLSyntaxErrorException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLTimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLTimeoutException

No usage of java.sql.SQLTimeoutException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLTransactionRollbackException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLTransactionRollbackException

No usage of java.sql.SQLTransactionRollbackException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLTransientConnectionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLTransientConnectionException

No usage of java.sql.SQLTransientConnectionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLTransientException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLTransientException

  • Packages that use SQLTransientException
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of SQLTransientException in java.sql

      Subclasses of SQLTransientException in java.sql
      Modifier and Type Class 描述
      class  SQLTimeoutException
      的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。
      class  SQLTransactionRollbackException
      当SQLState类值为“ 40 ”时，或者在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTransientConnectionException
      用于SQLState类值为“ 08 ”的SQLException的子类，或者在供应商指定的条件下。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.SQLWarning (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.SQLWarning

  • Packages that use SQLWarning
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of SQLWarning in java.sql

      Subclasses of SQLWarning in java.sql
      Modifier and Type Class 描述
      class  DataTruncation
      由于 DataTruncation异常超出 MaxFieldSize原因而导致数据值意外截断时，异常抛出 DataTruncation异常（写入）或报告为 DataTruncation警告（读取时）。
      Methods in java.sql that return SQLWarning
      Modifier and Type 方法 描述
      SQLWarning SQLWarning.getNextWarning​()
      检索 SQLWarning对象由 setNextWarning链接的警告。
      SQLWarning Connection.getWarnings​()
      检索通过此 Connection对象的呼叫报告的第一个警告。
      SQLWarning ResultSet.getWarnings​()
      检索通过此 ResultSet对象的呼叫报告的第一个警告。
      SQLWarning Statement.getWarnings​()
      检索此 Statement对象上的呼叫报告的第一个警告。
      Methods in java.sql with parameters of type SQLWarning
      Modifier and Type 方法 描述
      void SQLWarning.setNextWarning​(SQLWarning w)
      Adds a SQLWarning object to the end of the chain.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.Time (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.Time

  • Packages that use Time
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of Time in java.sql

      Methods in java.sql that return Time
      Modifier and Type 方法 描述
      Time CallableStatement.getTime​(int parameterIndex)
      以 java.sql.Time对象的形式获取指定的JDBC TIME参数的值。
      Time CallableStatement.getTime​(int parameterIndex, Calendar cal)
      将指定的JDBC TIME参数的值作为 java.sql.Time对象 java.sql.Time ，使用给定的 Calendar对象构建时间。
      Time CallableStatement.getTime​(String parameterName)
      以 java.sql.Time对象的形式检索JDBC TIME参数的值。
      Time CallableStatement.getTime​(String parameterName, Calendar cal)
      检索JDBC TIME参数的值作为 java.sql.Time对象，使用给定的 Calendar对象构建时间。
      Time ResultSet.getTime​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
      Time ResultSet.getTime​(int columnIndex, Calendar cal)
      以Java编程语言中的 ResultSet对象的形式 java.sql.Time此 ResultSet对象的当前行中指定列的值。
      Time ResultSet.getTime​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
      Time ResultSet.getTime​(String columnLabel, Calendar cal)
      这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Time的Java编程语言对象。
      Time SQLInput.readTime​()
      读取流中的下一个属性，并将其作为 java.sql.Time对象返回。
      static Time Time.valueOf​(String s)
      将JDBC时间转义格式的字符串转换为 Time值。
      static Time Time.valueOf​(LocalTime time)
      从LocalTime对象获取Time的实例，具有与给定的LocalTime相同的小时，分钟和第二时间值。
      Methods in java.sql with parameters of type Time
      Modifier and Type 方法 描述
      void CallableStatement.setTime​(String parameterName, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void CallableStatement.setTime​(String parameterName, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void PreparedStatement.setTime​(int parameterIndex, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void PreparedStatement.setTime​(int parameterIndex, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void ResultSet.updateTime​(int columnIndex, Time x)
      使用 java.sql.Time值更新指定的列。
      void ResultSet.updateTime​(String columnLabel, Time x)
      使用 java.sql.Time值更新指定的列。
      void SQLOutput.writeTime​(Time x)
      将下一个属性作为java.sql.Time对象写入流。

    • Uses of Time in javax.sql

      Methods in javax.sql with parameters of type Time
      Modifier and Type 方法 描述
      void RowSet.setTime​(int parameterIndex, Time x)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.sql.Time值。
      void RowSet.setTime​(int parameterIndex, Time x, Calendar cal)
      使用给定的 java.sql.Time值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setTime​(String parameterName, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void RowSet.setTime​(String parameterName, Time x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Time值，使用给定的 Calendar对象。

    • Uses of Time in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Time
      Modifier and Type 方法 描述
      void BaseRowSet.setTime​(int parameterIndex, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void BaseRowSet.setTime​(int parameterIndex, Time x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Time对象。
      void BaseRowSet.setTime​(String parameterName, Time x)
      将指定的参数设置为给定的 java.sql.Time值。
      void BaseRowSet.setTime​(String parameterName, Time x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Time值，使用给定的 Calendar对象。

    • Uses of Time in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return Time
      Modifier and Type 方法 描述
      Time SQLInputImpl.readTime​()
      将此 SQLInputImpl对象中的下一个属性检索为 java.sql.Time对象。
      Methods in javax.sql.rowset.serial with parameters of type Time
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeTime​(Time x)
      将Java编程语言中的一个 java.sql.Time对象写入此 SQLOutputImpl对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.Timestamp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.Timestamp

  • Packages that use Timestamp
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of Timestamp in java.sql

      Methods in java.sql that return Timestamp
      Modifier and Type 方法 描述
      static Timestamp Timestamp.from​(Instant instant)
      从Instant对象获取一个Timestamp的实例。
      Timestamp CallableStatement.getTimestamp​(int parameterIndex)
      将指定的JDBC TIMESTAMP参数的值作为 java.sql.Timestamp对象 java.sql.Timestamp 。
      Timestamp CallableStatement.getTimestamp​(int parameterIndex, Calendar cal)
      将指定的JDBC TIMESTAMP参数的值作为 java.sql.Timestamp对象 java.sql.Timestamp ，使用给定的 Calendar对象构造 Timestamp对象。
      Timestamp CallableStatement.getTimestamp​(String parameterName)
      以 java.sql.Timestamp对象的形式 java.sql.Timestamp JDBC TIMESTAMP参数的值。
      Timestamp CallableStatement.getTimestamp​(String parameterName, Calendar cal)
      检索JDBC TIMESTAMP参数的值作为 java.sql.Timestamp对象，使用给定的 Calendar对象来构造 Timestamp对象。
      Timestamp ResultSet.getTimestamp​(int columnIndex)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Timestamp对象。
      Timestamp ResultSet.getTimestamp​(int columnIndex, Calendar cal)
      这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Timestamp的Java编程语言对象。
      Timestamp ResultSet.getTimestamp​(String columnLabel)
      以Java编程语言中的 java.sql.Timestamp对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      Timestamp ResultSet.getTimestamp​(String columnLabel, Calendar cal)
      以Java编程语言中的 ResultSet对象的形式 java.sql.Timestamp此 ResultSet对象的当前行中指定列的值。
      Timestamp SQLInput.readTimestamp​()
      读取流中的下一个属性，并将其作为 java.sql.Timestamp对象返回。
      static Timestamp Timestamp.valueOf​(String s)
      将JDBC时间戳转换格式的 String对象转换为 Timestamp值。
      static Timestamp Timestamp.valueOf​(LocalDateTime dateTime)
      获取的实例 Timestamp从 LocalDateTime对象，以相同的年，月，月日，时，分，秒和毫微秒日期时间值作为提供 LocalDateTime 。
      Methods in java.sql with parameters of type Timestamp
      Modifier and Type 方法 描述
      boolean Timestamp.after​(Timestamp ts)
      指示此 Timestamp对象是否晚于给定的 Timestamp对象。
      boolean Timestamp.before​(Timestamp ts)
      指示此 Timestamp对象是否早于给定的 Timestamp对象。
      int Timestamp.compareTo​(Timestamp ts)
      将此 Timestamp对象与给定的 Timestamp对象进行比较。
      boolean Timestamp.equals​(Timestamp ts)
      测试这个 Timestamp对象是否等于给定的 Timestamp对象。
      void CallableStatement.setTimestamp​(String parameterName, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void CallableStatement.setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。
      void PreparedStatement.setTimestamp​(int parameterIndex, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void PreparedStatement.setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。
      void ResultSet.updateTimestamp​(int columnIndex, Timestamp x)
      使用 java.sql.Timestamp值更新指定的列。
      void ResultSet.updateTimestamp​(String columnLabel, Timestamp x)
      使用 java.sql.Timestamp值更新指定的列。
      void SQLOutput.writeTimestamp​(Timestamp x)
      将下一个属性作为java.sql.Timestamp对象写入流。

    • Uses of Timestamp in javax.sql

      Methods in javax.sql with parameters of type Timestamp
      Modifier and Type 方法 描述
      void RowSet.setTimestamp​(int parameterIndex, Timestamp x)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.sql.Timestamp值。
      void RowSet.setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      使用给定的 java.sql.Timestamp值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setTimestamp​(String parameterName, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void RowSet.setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

    • Uses of Timestamp in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Timestamp
      Modifier and Type 方法 描述
      void BaseRowSet.setTimestamp​(int parameterIndex, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void BaseRowSet.setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Timestamp对象。
      void BaseRowSet.setTimestamp​(String parameterName, Timestamp x)
      将指定的参数设置为给定的 java.sql.Timestamp值。
      void BaseRowSet.setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

    • Uses of Timestamp in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return Timestamp
      Modifier and Type 方法 描述
      Timestamp SQLInputImpl.readTimestamp​()
      将此 SQLInputImpl对象中的下一个属性检索为 java.sql.Timestamp对象。
      Methods in javax.sql.rowset.serial with parameters of type Timestamp
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeTimestamp​(Timestamp x)
      Writes a java.sql.Timestamp object in the Java programming language to this SQLOutputImpl object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.sql.Types (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.sql.Types

No usage of java.sql.Types
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Array (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Array

  • Packages that use Array
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of Array in java.sql

      Methods in java.sql that return Array
      Modifier and Type 方法 描述
      Array Connection.createArrayOf​(String typeName, Object[] elements)
      用于创建Array对象的Factory方法。
      Array CallableStatement.getArray​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC ARRAY参数的值作为Array对象。
      Array CallableStatement.getArray​(String parameterName)
      以Java编程语言中的Array对象获取JDBC ARRAY参数的值。
      Array ResultSet.getArray​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Array对象。
      Array ResultSet.getArray​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Array对象。
      Array SQLInput.readArray​()
      从流中读取SQL ARRAY值，并将其作为Java编程语言中的 Array对象返回。
      Methods in java.sql with parameters of type Array
      Modifier and Type 方法 描述
      void PreparedStatement.setArray​(int parameterIndex, Array x)
      将指定的参数设置为给定的 java.sql.Array对象。
      void ResultSet.updateArray​(int columnIndex, Array x)
      使用 java.sql.Array值更新指定的列。
      void ResultSet.updateArray​(String columnLabel, Array x)
      使用 java.sql.Array值更新指定的列。
      void SQLOutput.writeArray​(Array x)
      写入一个SQL ARRAY值到流。

    • Uses of Array in javax.sql

      Methods in javax.sql with parameters of type Array
      Modifier and Type 方法 描述
      void RowSet.setArray​(int i, Array x)
      使用给定的 Array值在此 RowSet对象的命令中设置指定的参数。

    • Uses of Array in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Array
      Modifier and Type 方法 描述
      void BaseRowSet.setArray​(int parameterIndex, Array array)
      将指定的参数设置为Java编程语言中的一个 Array对象。

    • Uses of Array in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement Array
      Modifier and Type Class 描述
      class  SerialArray
      一个 Array对象的序列化版本，它是Java编程语言中的一个SQL ARRAY值的映射。
      Methods in javax.sql.rowset.serial that return Array
      Modifier and Type 方法 描述
      Array SQLInputImpl.readArray​()
      从流中读取SQL ARRAY值，并将其作为Java编程语言中的 Array对象返回。
      Methods in javax.sql.rowset.serial with parameters of type Array
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeArray​(Array x)
      将Java编程语言中的一个 Array对象写入此 SQLOutputImpl对象。
      Constructors in javax.sql.rowset.serial with parameters of type Array
      Constructor 描述
      SerialArray​(Array array)
      构造一个新 SerialArray从给定对象 Array对象。
      SerialArray​(Array array, Map<String,Class<?>> map)
      从给定的 Array对象构造一个新的 SerialArray对象，当元素是SQL UDT时，使用给定的类型映射来为每个元素的自定义映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Blob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Blob

  • Packages that use Blob
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of Blob in java.sql

      Methods in java.sql that return Blob
      Modifier and Type 方法 描述
      Blob Connection.createBlob​()
      构造一个实现 Blob接口的对象。
      Blob CallableStatement.getBlob​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC BLOB参数的值作为Blob对象。
      Blob CallableStatement.getBlob​(String parameterName)
      将JDBC BLOB参数的值作为Java编程语言中的Blob对象检索。
      Blob ResultSet.getBlob​(int columnIndex)
      检索该 ResultSet对象当前行中指定列的值为Java编程语言中的 Blob对象。
      Blob ResultSet.getBlob​(String columnLabel)
      以Java编程语言中的 Blob对象的形式，检索此 ResultSet对象的当前行中指定列的值。
      Blob SQLInput.readBlob​()
      从流中读取SQL BLOB值，并将其作为Java编程语言中的 Blob对象返回。
      Methods in java.sql with parameters of type Blob
      Modifier and Type 方法 描述
      long Blob.position​(Blob pattern, long start)
      检索在该字节位置 BLOB通过该指定值 Blob对象在该 pattern开始。
      void CallableStatement.setBlob​(String parameterName, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。
      void PreparedStatement.setBlob​(int parameterIndex, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。
      void ResultSet.updateBlob​(int columnIndex, Blob x)
      使用 java.sql.Blob值更新指定的列。
      void ResultSet.updateBlob​(String columnLabel, Blob x)
      使用 java.sql.Blob值更新指定的列。
      void SQLOutput.writeBlob​(Blob x)
      写入SQL BLOB值。

    • Uses of Blob in javax.sql

      Methods in javax.sql with parameters of type Blob
      Modifier and Type 方法 描述
      void RowSet.setBlob​(int i, Blob x)
      使用给定的 Blob值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setBlob​(String parameterName, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。

    • Uses of Blob in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Blob
      Modifier and Type 方法 描述
      void BaseRowSet.setBlob​(int parameterIndex, Blob x)
      将指定的参数设置为Java编程语言中给定的 Blob对象。
      void BaseRowSet.setBlob​(String parameterName, Blob x)
      将指定的参数设置为给定的 java.sql.Blob对象。

    • Uses of Blob in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement Blob
      Modifier and Type Class 描述
      class  SerialBlob
      一个序列化的映射在Java编程语言中的一个SQL BLOB值。
      Methods in javax.sql.rowset.serial that return Blob
      Modifier and Type 方法 描述
      Blob SQLInputImpl.readBlob​()
      在 SQLInputImpl对象的头部 BLOB值作为Java编程语言中的 Blob对象。
      Methods in javax.sql.rowset.serial with parameters of type Blob
      Modifier and Type 方法 描述
      long SerialBlob.position​(Blob pattern, long start)
      返回此 SerialBlob对象中的位置，给定的 Blob对象开始，开始在指定位置的搜索。
      void SQLOutputImpl.writeBlob​(Blob x)
      将Java编程语言中的一个 Blob对象写入此 SQLOutputImpl对象。
      Constructors in javax.sql.rowset.serial with parameters of type Blob
      Constructor 描述
      SerialBlob​(Blob blob)
      Constructs a SerialBlob object that is a serialized version of the given Blob object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.CallableStatement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.CallableStatement

  • Packages that use CallableStatement
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of CallableStatement in java.sql

      Methods in java.sql that return CallableStatement
      Modifier and Type 方法 描述
      CallableStatement Connection.prepareCall​(String sql)
      创建一个用于调用数据库存储过程的 CallableStatement对象。
      CallableStatement Connection.prepareCall​(String sql, int resultSetType, int resultSetConcurrency)
      创建一个 CallableStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
      CallableStatement Connection.prepareCall​(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
      创建一个 CallableStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Clob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Clob

  • Packages that use Clob
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of Clob in java.sql

      Subinterfaces of Clob in java.sql
      Modifier and Type 接口 描述
      interface  NClob
      在Java的编程语言中映射为SQL NCLOB类型。
      Methods in java.sql that return Clob
      Modifier and Type 方法 描述
      Clob Connection.createClob​()
      构造一个实现 Clob接口的对象。
      Clob CallableStatement.getClob​(int parameterIndex)
      以Java编程语言的形式获取指定的JDBC CLOB参数的值作为 java.sql.Clob对象。
      Clob CallableStatement.getClob​(String parameterName)
      CLOB java.sql.Clob
      Clob ResultSet.getClob​(int columnIndex)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Clob对象。
      Clob ResultSet.getClob​(String columnLabel)
      这个检索的当前行中指定列的值 ResultSet对象为 Clob的Java编程语言对象。
      Clob SQLInput.readClob​()
      从流中读取SQL CLOB值，并将其作为Java编程语言中的 Clob对象返回。
      Methods in java.sql with parameters of type Clob
      Modifier and Type 方法 描述
      long Clob.position​(Clob searchstr, long start)
      检索此 Clob对象中指定的 Clob对象 searchstr的字符位置。
      void CallableStatement.setClob​(String parameterName, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。
      void PreparedStatement.setClob​(int parameterIndex, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。
      void ResultSet.updateClob​(int columnIndex, Clob x)
      使用 java.sql.Clob值更新指定的列。
      void ResultSet.updateClob​(String columnLabel, Clob x)
      使用 java.sql.Clob值更新指定的列。
      void SQLOutput.writeClob​(Clob x)
      将SQL CLOB值写入流。

    • Uses of Clob in javax.sql

      Methods in javax.sql with parameters of type Clob
      Modifier and Type 方法 描述
      void RowSet.setClob​(int i, Clob x)
      使用给定的 Clob值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setClob​(String parameterName, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。

    • Uses of Clob in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Clob
      Modifier and Type 方法 描述
      void BaseRowSet.setClob​(int parameterIndex, Clob x)
      将指定的参数设置为Java编程语言中给定的 Clob对象。
      void BaseRowSet.setClob​(String parameterName, Clob x)
      将指定的参数设置为给定的 java.sql.Clob对象。

    • Uses of Clob in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement Clob
      Modifier and Type Class 描述
      class  SerialClob
      一个序列化映射的Java编程语言中的一个SQL CLOB值。
      Methods in javax.sql.rowset.serial that return Clob
      Modifier and Type 方法 描述
      Clob SQLInputImpl.readClob​()
      以 SQLInputImpl对象的形式 Clob该 SQLInputImpl对象的头像中的 CLOB值。
      Methods in javax.sql.rowset.serial with parameters of type Clob
      Modifier and Type 方法 描述
      long SerialClob.position​(Clob searchStr, long start)
      返回此 SerialClob对象中的位置，其中给定的 Clob签名开始，在指定位置开始搜索。
      void SQLOutputImpl.writeClob​(Clob x)
      将Java编程语言中的一个 Clob对象写入此 SQLOutputImpl对象。
      Constructors in javax.sql.rowset.serial with parameters of type Clob
      Constructor 描述
      SerialClob​(Clob clob)
      构造一个 SerialClob对象，该对象是给定的 Clob对象的序列化版本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Connection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Connection

  • Packages that use Connection
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。

    • Uses of Connection in java.sql

      Methods in java.sql that return Connection
      Modifier and Type 方法 描述
      Connection ConnectionBuilder.build​()
      返回由此构建器定义的对象的实例。
      Connection Driver.connect​(String url, Properties info)
      尝试使数据库连接到给定的URL。
      Connection DatabaseMetaData.getConnection​()
      检索生成此元数据对象的连接。
      static Connection DriverManager.getConnection​(String url)
      尝试建立与给定数据库URL的连接。
      static Connection DriverManager.getConnection​(String url, String user, String password)
      尝试建立与给定数据库URL的连接。
      static Connection DriverManager.getConnection​(String url, Properties info)
      尝试建立与给定数据库URL的连接。
      Connection Statement.getConnection​()
      检索 Connection生成此对象 Statement对象。

    • Uses of Connection in javax.sql

      Methods in javax.sql that return Connection
      Modifier and Type 方法 描述
      Connection DataSource.getConnection​()
      尝试建立与此 DataSource对象所代表的数据源的连接。
      Connection DataSource.getConnection​(String username, String password)
      尝试与此 DataSource对象所代表的数据源建立连接。
      Connection PooledConnection.getConnection​()
      创建并返回一个 Connection对象，该对象是该 PooledConnection对象表示的物理连接的句柄。
      Connection RowSetInternal.getConnection​()
      检索 Connection传递给该对象 RowSet对象。

    • Uses of Connection in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Connection
      Modifier and Type 方法 描述
      void CachedRowSet.acceptChanges​(Connection con)
      使用指定的 Connection对象传播所有行更新，插入和删除对此 CachedRowSet对象的数据源的更改，以建立与数据源的连接。
      void CachedRowSet.execute​(Connection conn)
      用数据填充这个 CachedRowSet对象，使用给定的连接生成将从中读取数据的结果集。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.ConnectionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.ConnectionBuilder

  • Packages that use ConnectionBuilder
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。

    • Uses of ConnectionBuilder in java.sql

      Methods in java.sql that return ConnectionBuilder
      Modifier and Type 方法 描述
      ConnectionBuilder ConnectionBuilder.password​(String password)
      指定创建连接时要使用的密码
      ConnectionBuilder ConnectionBuilder.shardingKey​(ShardingKey shardingKey)
      指定创建连接时要使用的 shardingKey
      ConnectionBuilder ConnectionBuilder.superShardingKey​(ShardingKey superShardingKey)
      指定在创建连接时使用的 superShardingKey
      ConnectionBuilder ConnectionBuilder.user​(String username)
      指定创建连接时要使用的用户名

    • Uses of ConnectionBuilder in javax.sql

      Methods in javax.sql that return ConnectionBuilder
      Modifier and Type 方法 描述
      default ConnectionBuilder DataSource.createConnectionBuilder​()
      Create a new ConnectionBuilder instance
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.DatabaseMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.DatabaseMetaData

  • Packages that use DatabaseMetaData
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of DatabaseMetaData in java.sql

      Methods in java.sql that return DatabaseMetaData
      Modifier and Type 方法 描述
      DatabaseMetaData Connection.getMetaData​()
      检索 DatabaseMetaData对象包含有关哪个这个数据库的元数据 Connection对象表示的连接。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Driver (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Driver

  • Packages that use Driver
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of Driver in java.sql

      Methods in java.sql that return Driver
      Modifier and Type 方法 描述
      static Driver DriverManager.getDriver​(String url)
      尝试查找了解给定URL的驱动程序。
      Methods in java.sql that return types with arguments of type Driver
      Modifier and Type 方法 描述
      static Stream<Driver> DriverManager.drivers​()
      使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索流。
      static Enumeration<Driver> DriverManager.getDrivers​()
      使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索枚举。
      Methods in java.sql with parameters of type Driver
      Modifier and Type 方法 描述
      static void DriverManager.deregisterDriver​(Driver driver)
      从 DriverManager的注册驱动程序列表中删除指定的驱动程序。
      static void DriverManager.registerDriver​(Driver driver)
      使用 DriverManager注册给定的驱动程序。
      static void DriverManager.registerDriver​(Driver driver, DriverAction da)
      Registers the given driver with the DriverManager.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.DriverAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.DriverAction

  • Packages that use DriverAction
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of DriverAction in java.sql

      Methods in java.sql with parameters of type DriverAction
      Modifier and Type 方法 描述
      static void DriverManager.registerDriver​(Driver driver, DriverAction da)
      使用 DriverManager注册给定的驱动程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.NClob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.NClob

  • Packages that use NClob
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of NClob in java.sql

      Methods in java.sql that return NClob
      Modifier and Type 方法 描述
      NClob Connection.createNClob​()
      构造一个实现 NClob接口的对象。
      NClob CallableStatement.getNClob​(int parameterIndex)
      以Java编程语言作为 java.sql.NClob对象检索指定的JDBC NCLOB参数的值。
      NClob CallableStatement.getNClob​(String parameterName)
      以Java编程语言作为 java.sql.NClob对象检索JDBC NCLOB参数的值。
      NClob ResultSet.getNClob​(int columnIndex)
      这个检索的当前行中指定列的值 ResultSet对象为 NClob的Java编程语言对象。
      NClob ResultSet.getNClob​(String columnLabel)
      这个检索的当前行中指定列的值 ResultSet对象为 NClob的Java编程语言对象。
      NClob SQLInput.readNClob​()
      从流中读取SQL NCLOB值，并将其作为Java编程语言中的 NClob对象返回。
      Methods in java.sql with parameters of type NClob
      Modifier and Type 方法 描述
      void CallableStatement.setNClob​(String parameterName, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void PreparedStatement.setNClob​(int parameterIndex, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void ResultSet.updateNClob​(int columnIndex, NClob nClob)
      使用 java.sql.NClob值更新指定的列。
      void ResultSet.updateNClob​(String columnLabel, NClob nClob)
      使用 java.sql.NClob值更新指定的列。
      void SQLOutput.writeNClob​(NClob x)
      将SQL NCLOB值写入流。

    • Uses of NClob in javax.sql

      Methods in javax.sql with parameters of type NClob
      Modifier and Type 方法 描述
      void RowSet.setNClob​(int parameterIndex, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void RowSet.setNClob​(String parameterName, NClob value)
      将指定的参数设置为 java.sql.NClob对象。

    • Uses of NClob in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type NClob
      Modifier and Type 方法 描述
      void BaseRowSet.setNClob​(int parameterIndex, NClob value)
      将指定的参数设置为 java.sql.NClob对象。
      void BaseRowSet.setNClob​(String parameterName, NClob value)
      将指定的参数设置为 java.sql.NClob对象。

    • Uses of NClob in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return NClob
      Modifier and Type 方法 描述
      NClob SQLInputImpl.readNClob​()
      从流中读取SQL NCLOB值，并将其作为Java编程语言中的 Clob对象返回。
      Methods in javax.sql.rowset.serial with parameters of type NClob
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeNClob​(NClob x)
      将SQL NCLOB值写入流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.ParameterMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.ParameterMetaData

  • Packages that use ParameterMetaData
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of ParameterMetaData in java.sql

      Methods in java.sql that return ParameterMetaData
      Modifier and Type 方法 描述
      ParameterMetaData PreparedStatement.getParameterMetaData​()
      检索此 PreparedStatement对象的参数的数量，类型和属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.PreparedStatement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.PreparedStatement

  • Packages that use PreparedStatement
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。

    • Uses of PreparedStatement in java.sql

      Subinterfaces of PreparedStatement in java.sql
      Modifier and Type 接口 描述
      interface  CallableStatement
      用于执行SQL存储过程的界面。
      Methods in java.sql that return PreparedStatement
      Modifier and Type 方法 描述
      PreparedStatement Connection.prepareStatement​(String sql)
      创建一个 PreparedStatement对象，用于将参数化的SQL语句发送到数据库。
      PreparedStatement Connection.prepareStatement​(String sql, int autoGeneratedKeys)
      创建一个默认的 PreparedStatement对象，该对象可以检索自动生成的密钥。
      PreparedStatement Connection.prepareStatement​(String sql, int[] columnIndexes)
      创建一个默认的 PreparedStatement对象，能够返回给定数组指定的自动生成的键。
      PreparedStatement Connection.prepareStatement​(String sql, int resultSetType, int resultSetConcurrency)
      创建一个 PreparedStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
      PreparedStatement Connection.prepareStatement​(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
      创建一个 PreparedStatement对象，该对象将生成具有给定类型，并发和 ResultSet对象。
      PreparedStatement Connection.prepareStatement​(String sql, String[] columnNames)
      创建一个默认的 PreparedStatement对象，能够返回给定数组指定的自动生成的键。

    • Uses of PreparedStatement in javax.sql

      Methods in javax.sql that return PreparedStatement
      Modifier and Type 方法 描述
      PreparedStatement StatementEvent.getStatement​()
      返回正在关闭或无效的 PreparedStatement
      Constructors in javax.sql with parameters of type PreparedStatement
      Constructor 描述
      StatementEvent​(PooledConnection con, PreparedStatement statement)
      构造一个 StatementEvent与指定的 PooledConnection和 PreparedStatement 。
      StatementEvent​(PooledConnection con, PreparedStatement statement, SQLException exception)
      构造一个 StatementEvent具有指定 PooledConnection ， PreparedStatement和 SQLException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Ref (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Ref

  • Packages that use Ref
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of Ref in java.sql

      Methods in java.sql that return Ref
      Modifier and Type 方法 描述
      Ref CallableStatement.getRef​(int parameterIndex)
      以Java编程语言作为Ref对象检索指定的JDBC REF(<structured-type>)参数的值。
      Ref CallableStatement.getRef​(String parameterName)
      以Java编程语言作为Ref对象检索JDBC REF(<structured-type>)参数的值。
      Ref ResultSet.getRef​(int columnIndex)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 Ref对象。
      Ref ResultSet.getRef​(String columnLabel)
      以Java编程语言中的 ResultSet对象的形式 Ref此 ResultSet对象的当前行中指定列的值。
      Ref SQLInput.readRef​()
      从流中读取SQL REF值，并将其作为Java编程语言中的 Ref对象返回。
      Methods in java.sql with parameters of type Ref
      Modifier and Type 方法 描述
      void PreparedStatement.setRef​(int parameterIndex, Ref x)
      将指定的参数设置为给定的 REF(<structured-type>)值。
      void ResultSet.updateRef​(int columnIndex, Ref x)
      使用 java.sql.Ref值更新指定的列。
      void ResultSet.updateRef​(String columnLabel, Ref x)
      使用 java.sql.Ref值更新指定的列。
      void SQLOutput.writeRef​(Ref x)
      将SQL REF值写入流。

    • Uses of Ref in javax.sql

      Methods in javax.sql with parameters of type Ref
      Modifier and Type 方法 描述
      void RowSet.setRef​(int i, Ref x)
      使用给定的 Ref值在此 RowSet对象的命令中设置指定的参数。

    • Uses of Ref in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Ref
      Modifier and Type 方法 描述
      void BaseRowSet.setRef​(int parameterIndex, Ref ref)
      将指定的参数设置为Java编程语言中给定的 Ref对象。

    • Uses of Ref in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement Ref
      Modifier and Type Class 描述
      class  SerialRef
      一个 Ref对象的序列化映射，它是Java编程语言中的一个SQL REF值的映射。
      Methods in javax.sql.rowset.serial that return Ref
      Modifier and Type 方法 描述
      Ref SQLInputImpl.readRef​()
      以该Java编程语言中的 SQLInputImpl对象的形式 Ref该 SQLInputImpl对象的头部的值。
      Methods in javax.sql.rowset.serial with parameters of type Ref
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeRef​(Ref x)
      将Java编程语言中的一个 Ref对象写入此 SQLOutputImpl对象。
      Constructors in javax.sql.rowset.serial with parameters of type Ref
      Constructor 描述
      SerialRef​(Ref ref)
      Constructs a SerialRef object from the given Ref object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.ResultSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.ResultSet

  • Packages that use ResultSet
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。

    • Uses of ResultSet in java.sql

      Methods in java.sql that return ResultSet
      Modifier and Type 方法 描述
      ResultSet PreparedStatement.executeQuery​()
      执行此 PreparedStatement对象中的SQL查询，并返回查询生成的 ResultSet对象。
      ResultSet Statement.executeQuery​(String sql)
      执行给定的SQL语句，返回一个 ResultSet对象。
      ResultSet DatabaseMetaData.getAttributes​(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern)
      检索给定模式和目录中可用的用户定义类型（UDT）给定类型的给定属性的描述。
      ResultSet DatabaseMetaData.getBestRowIdentifier​(String catalog, String schema, String table, int scope, boolean nullable)
      检索表的唯一标识行的最佳列集描述。
      ResultSet DatabaseMetaData.getCatalogs​()
      检索此数据库中可用的目录名称。
      ResultSet DatabaseMetaData.getClientInfoProperties​()
      检索驱动程序支持的客户端信息属性的列表。
      ResultSet DatabaseMetaData.getColumnPrivileges​(String catalog, String schema, String table, String columnNamePattern)
      检索表的列的访问权限的描述。
      ResultSet DatabaseMetaData.getColumns​(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
      检索指定目录中可用的表列的描述。
      ResultSet DatabaseMetaData.getCrossReference​(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable)
      检索引用主键的给定外键表中的外键列的描述，或表示父表的唯一约束的列（可以是相同或不同的表）。
      ResultSet DatabaseMetaData.getExportedKeys​(String catalog, String schema, String table)
      检索引用给定表的主键列（由表导出的外键）的外键列的描述。
      ResultSet DatabaseMetaData.getFunctionColumns​(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern)
      检索给定目录的系统或用户功能参数和返回类型的描述。
      ResultSet DatabaseMetaData.getFunctions​(String catalog, String schemaPattern, String functionNamePattern)
      检索给定目录中可用的系统和用户功能的描述。
      ResultSet Statement.getGeneratedKeys​()
      检索由于执行此 Statement对象而创建的任何自动生成的密钥。
      ResultSet DatabaseMetaData.getImportedKeys​(String catalog, String schema, String table)
      检索给定表的外键列（由表导入的主键）引用的主键列的描述。
      ResultSet DatabaseMetaData.getIndexInfo​(String catalog, String schema, String table, boolean unique, boolean approximate)
      检索给定表的索引和统计信息的描述。
      ResultSet DatabaseMetaData.getPrimaryKeys​(String catalog, String schema, String table)
      检索给定表的主键列的描述。
      ResultSet DatabaseMetaData.getProcedureColumns​(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern)
      检索给定目录的存储过程参数和结果列的描述。
      ResultSet DatabaseMetaData.getProcedures​(String catalog, String schemaPattern, String procedureNamePattern)
      200的X- 200 200 X- 200 200 X- 200 200：
      ResultSet DatabaseMetaData.getPseudoColumns​(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
      检索指定目录和模式中给定表中可用的伪列或隐藏列的描述。
      ResultSet Array.getResultSet​()
      检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。
      ResultSet Array.getResultSet​(long index, int count)
      检索一个结果集，该结果集包含从索引 index开始的子阵列的元素，并包含多达 count连续元素。
      ResultSet Array.getResultSet​(long index, int count, Map<String,Class<?>> map)
      检索一个结果集，该结果集保存从索引 index开始的子阵列的元素，并包含最多 count连续元素。
      ResultSet Array.getResultSet​(Map<String,Class<?>> map)
      检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。
      ResultSet Statement.getResultSet​()
      以 ResultSet对象的形式获取当前结果。
      ResultSet DatabaseMetaData.getSchemas​()
      检索此数据库中可用的模式名称。
      ResultSet DatabaseMetaData.getSchemas​(String catalog, String schemaPattern)
      检索此数据库中可用的模式名称。
      ResultSet DatabaseMetaData.getSuperTables​(String catalog, String schemaPattern, String tableNamePattern)
      检索此数据库中特定模式中定义的表层次结构的描述。
      ResultSet DatabaseMetaData.getSuperTypes​(String catalog, String schemaPattern, String typeNamePattern)
      检索此数据库中特定模式中定义的用户定义类型（UDT）层次结构的描述。
      ResultSet DatabaseMetaData.getTablePrivileges​(String catalog, String schemaPattern, String tableNamePattern)
      检索目录中可用的每个表的访问权限的描述。
      ResultSet DatabaseMetaData.getTables​(String catalog, String schemaPattern, String tableNamePattern, String[] types)
      检索给定目录中可用表的描述。
      ResultSet DatabaseMetaData.getTableTypes​()
      检索此数据库中可用的表类型。
      ResultSet DatabaseMetaData.getTypeInfo​()
      检索此数据库支持的所有数据类型的描述。
      ResultSet DatabaseMetaData.getUDTs​(String catalog, String schemaPattern, String typeNamePattern, int[] types)
      检索在特定模式中定义的用户定义类型（UDT）的描述。
      ResultSet DatabaseMetaData.getVersionColumns​(String catalog, String schema, String table)
      检索表中更新行中任何值时自动更新的表的列的说明。

    • Uses of ResultSet in javax.sql

      Subinterfaces of ResultSet in javax.sql
      Modifier and Type 接口 描述
      interface  RowSet
      该接口为JavaBeans组件模型的JDBC API添加了支持。
      Methods in javax.sql that return ResultSet
      Modifier and Type 方法 描述
      ResultSet RowSetInternal.getOriginal​()
      检索 ResultSet含有该原始值对象 RowSet对象。
      ResultSet RowSetInternal.getOriginalRow​()
      检索包含当前行的原始值的 ResultSet对象。

    • Uses of ResultSet in javax.sql.rowset

      Subinterfaces of ResultSet in javax.sql.rowset
      Modifier and Type 接口 描述
      interface  CachedRowSet
      CachedRowSet所有标准实现必须实现的接口。
      interface  FilteredRowSet
      FilteredRowSet所有标准实现必须实现的标准接口。
      interface  JdbcRowSet
      JdbcRowSet所有标准实现必须实现的标准接口。
      interface  JoinRowSet
      JoinRowSet接口提供了将不同 RowSet对象的相关数据组合成一个 JoinRowSet对象的机制，该对象表示SQL JOIN 。
      interface  WebRowSet
      WebRowSet必须实现的所有实现的标准接口。
      Methods in javax.sql.rowset that return ResultSet
      Modifier and Type 方法 描述
      ResultSet CachedRowSet.getOriginal​()
      返回一个 ResultSet包含该原始值对象 CachedRowSet对象。
      ResultSet CachedRowSet.getOriginalRow​()
      返回一个 ResultSet对象，该对象包含仅此 CachedRowSet对象的当前行的原始值。
      Methods in javax.sql.rowset with parameters of type ResultSet
      Modifier and Type 方法 描述
      void CachedRowSet.populate​(ResultSet data)
      填充此 CachedRowSet从给定数据对象 ResultSet对象。
      void CachedRowSet.populate​(ResultSet rs, int startRow)
      填充此 CachedRowSet从给定数据对象 ResultSet对象。
      void WebRowSet.writeXml​(ResultSet rs, OutputStream oStream)
      使用给定的 ResultSet对象的内容填充此 WebRowSet对象，并将其数据，属性和元数据以XML格式写入给定的 OutputStream对象。
      void WebRowSet.writeXml​(ResultSet rs, Writer writer)
      使用给定的 ResultSet对象的内容填充此 WebRowSet对象，并将其数据，属性和元数据以XML格式写入给定的 Writer对象。

    • Uses of ResultSet in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return ResultSet
      Modifier and Type 方法 描述
      ResultSet SerialArray.getResultSet​()
      检索 ResultSet对象，其中包含 SerialArray对象表示的 ARRAY值中的所有元素。
      ResultSet SerialArray.getResultSet​(long index, int count)
      检索一个 ResultSet对象，保存从索引 索引开始的子阵列的元素，并包含最多 计数连续的元素。
      ResultSet SerialArray.getResultSet​(long index, int count, Map<String,Class<?>> map)
      检索设置保持其开始于检索所述子阵列的元素的结果 ResultSet对象，其中包含在该元件的子阵列 SerialArray对象，开始于索引 指数和包含 count个连续元素。
      ResultSet SerialArray.getResultSet​(Map<String,Class<?>> map)
      检索包含 ResultSet对象所表示的SQL ARRAY值的所有元素的 SerialArray对象。

    • Uses of ResultSet in javax.sql.rowset.spi

      Subinterfaces of ResultSet in javax.sql.rowset.spi
      Modifier and Type 接口 描述
      interface  SyncResolver
      定义一个框架，允许应用程序使用手动决策树来决定在发生同步冲突时应该做什么。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.ResultSetMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.ResultSetMetaData

  • Packages that use ResultSetMetaData
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。

    • Uses of ResultSetMetaData in java.sql

      Methods in java.sql that return ResultSetMetaData
      Modifier and Type 方法 描述
      ResultSetMetaData PreparedStatement.getMetaData​()
      检索 ResultSetMetaData对象，其中包含有关执行此 PreparedStatement对象时将返回的 ResultSet对象的列的信息。
      ResultSetMetaData ResultSet.getMetaData​()
      检索此 ResultSet对象列的数量，类型和属性。

    • Uses of ResultSetMetaData in javax.sql

      Subinterfaces of ResultSetMetaData in javax.sql
      Modifier and Type 接口 描述
      interface  RowSetMetaData
      包含有关 RowSet对象中的列的 RowSet对象。

    • Uses of ResultSetMetaData in javax.sql.rowset

      Classes in javax.sql.rowset that implement ResultSetMetaData
      Modifier and Type Class 描述
      class  RowSetMetaDataImpl
      Provides implementations for the methods that set and get metadata information about a RowSet object's columns.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.RowId (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.RowId

  • Packages that use RowId
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of RowId in java.sql

      Methods in java.sql that return RowId
      Modifier and Type 方法 描述
      RowId CallableStatement.getRowId​(int parameterIndex)
      检索指定的JDBC ROWID参数的值作为 java.sql.RowId对象。
      RowId CallableStatement.getRowId​(String parameterName)
      检索指定的JDBC ROWID参数的值作为 java.sql.RowId对象。
      RowId ResultSet.getRowId​(int columnIndex)
      以Java编程语言的 ResultSet对象的形式 java.sql.RowId该 ResultSet对象的当前行中指定列的值。
      RowId ResultSet.getRowId​(String columnLabel)
      以Java编程语言中的 java.sql.RowId对象获取该 ResultSet对象的当前行中指定列的值。
      RowId SQLInput.readRowId​()
      从流中读取SQL ROWID值，并将其作为Java编程语言中的 RowId对象返回。
      Methods in java.sql with parameters of type RowId
      Modifier and Type 方法 描述
      void CallableStatement.setRowId​(String parameterName, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void PreparedStatement.setRowId​(int parameterIndex, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void ResultSet.updateRowId​(int columnIndex, RowId x)
      使用 RowId值更新指定的列。
      void ResultSet.updateRowId​(String columnLabel, RowId x)
      使用 RowId值更新指定的列。
      void SQLOutput.writeRowId​(RowId x)
      将SQL ROWID值写入流。

    • Uses of RowId in javax.sql

      Methods in javax.sql with parameters of type RowId
      Modifier and Type 方法 描述
      void RowSet.setRowId​(int parameterIndex, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void RowSet.setRowId​(String parameterName, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。

    • Uses of RowId in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type RowId
      Modifier and Type 方法 描述
      void BaseRowSet.setRowId​(int parameterIndex, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。
      void BaseRowSet.setRowId​(String parameterName, RowId x)
      将指定的参数设置为给定的 java.sql.RowId对象。

    • Uses of RowId in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return RowId
      Modifier and Type 方法 描述
      RowId SQLInputImpl.readRowId​()
      从流中读取SQL ROWID值，并将其作为Java编程语言中的 RowId对象返回。
      Methods in javax.sql.rowset.serial with parameters of type RowId
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeRowId​(RowId x)
      写入SQL ROWID值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Savepoint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Savepoint

  • Packages that use Savepoint
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。

    • Uses of Savepoint in java.sql

      Methods in java.sql that return Savepoint
      Modifier and Type 方法 描述
      Savepoint Connection.setSavepoint​()
      在当前事务中创建一个未命名的保存点，并返回代表它的新的 Savepoint对象。
      Savepoint Connection.setSavepoint​(String name)
      在当前事务中创建具有给定名称的保存点，并返回表示它的新的 Savepoint对象。
      Methods in java.sql with parameters of type Savepoint
      Modifier and Type 方法 描述
      void Connection.releaseSavepoint​(Savepoint savepoint)
      从当前事务中删除指定的 Savepoint和后续的 Savepoint对象。
      void Connection.rollback​(Savepoint savepoint)
      撤消在给定的 Savepoint对象设置后进行的所有更改。

    • Uses of Savepoint in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Savepoint
      Modifier and Type 方法 描述
      void CachedRowSet.rollback​(Savepoint s)
      每个 CachedRowSet对象的 SyncProvider包含一个 Connection对象，从原来的 ResultSet或JDBC属性传递给它。
      void JdbcRowSet.rollback​(Savepoint s)
      每个 JdbcRowSet包含一个 Connection对象，从原来的 ResultSet或JDBC属性传递给它。

    • Uses of Savepoint in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi with parameters of type Savepoint
      Modifier and Type 方法 描述
      void TransactionalWriter.rollback​(Savepoint s)
      Savepoint在给定的 Savepoint对象之前进行的当前交易中所做的所有更改。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.ShardingKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.ShardingKey

  • Packages that use ShardingKey
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。

    • Uses of ShardingKey in java.sql

      Methods in java.sql that return ShardingKey
      Modifier and Type 方法 描述
      ShardingKey ShardingKeyBuilder.build​()
      返回由此构建器定义的对象的实例。
      Methods in java.sql with parameters of type ShardingKey
      Modifier and Type 方法 描述
      default void Connection.setShardingKey​(ShardingKey shardingKey)
      指定与此Connection一起使用的shardingKey
      default void Connection.setShardingKey​(ShardingKey shardingKey, ShardingKey superShardingKey)
      指定与此连接一起使用的shardingKey和superShardingKey
      default boolean Connection.setShardingKeyIfValid​(ShardingKey shardingKey, int timeout)
      设置并验证此连接的分片密钥。
      default boolean Connection.setShardingKeyIfValid​(ShardingKey shardingKey, ShardingKey superShardingKey, int timeout)
      设置并验证此连接的分片密钥。
      ConnectionBuilder ConnectionBuilder.shardingKey​(ShardingKey shardingKey)
      指定在创建连接时使用的 shardingKey
      ConnectionBuilder ConnectionBuilder.superShardingKey​(ShardingKey superShardingKey)
      指定在创建连接时使用的 superShardingKey

    • Uses of ShardingKey in javax.sql

      Methods in javax.sql with parameters of type ShardingKey
      Modifier and Type 方法 描述
      PooledConnectionBuilder PooledConnectionBuilder.shardingKey​(ShardingKey shardingKey)
      指定在创建连接时使用的 shardingKey
      XAConnectionBuilder XAConnectionBuilder.shardingKey​(ShardingKey shardingKey)
      指定在创建连接时使用的 shardingKey
      PooledConnectionBuilder PooledConnectionBuilder.superShardingKey​(ShardingKey superShardingKey)
      指定在创建连接时使用的 superShardingKey
      XAConnectionBuilder XAConnectionBuilder.superShardingKey​(ShardingKey superShardingKey)
      Specifies a superShardingKey to be used when creating a connection
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.ShardingKeyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.ShardingKeyBuilder

  • Packages that use ShardingKeyBuilder
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。

    • Uses of ShardingKeyBuilder in java.sql

      Methods in java.sql that return ShardingKeyBuilder
      Modifier and Type 方法 描述
      ShardingKeyBuilder ShardingKeyBuilder.subkey​(Object subkey, SQLType subkeyType)
      将调用此方法将子项添加到正在构建的Sharding Key对象中。

    • Uses of ShardingKeyBuilder in javax.sql

      Methods in javax.sql that return ShardingKeyBuilder
      Modifier and Type 方法 描述
      default ShardingKeyBuilder CommonDataSource.createShardingKeyBuilder​()
      创建一个新的 ShardingKeyBuilder实例
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.SQLData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.SQLData

  • Packages that use SQLData
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of SQLData in java.sql

      Methods in java.sql with parameters of type SQLData
      Modifier and Type 方法 描述
      void SQLOutput.writeObject​(SQLData x)
      向流中写入包含在给定的 SQLData对象中的数据。

    • Uses of SQLData in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial with parameters of type SQLData
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeObject​(SQLData x)
      向流中写入包含在给定的 SQLData对象中的数据。
      Constructors in javax.sql.rowset.serial with parameters of type SQLData
      Constructor 描述
      SerialStruct​(SQLData in, Map<String,Class<?>> map)
      从给定的 SQLData对象构造一个 SerialStruct对象，使用给定的类型映射将其自定义映射到Java编程语言中的类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.SQLInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.SQLInput

  • Packages that use SQLInput
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of SQLInput in java.sql

      Methods in java.sql with parameters of type SQLInput
      Modifier and Type 方法 描述
      void SQLData.readSQL​(SQLInput stream, String typeName)
      使用从数据库读取的数据填充此对象。

    • Uses of SQLInput in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement SQLInput
      Modifier and Type Class 描述
      class  SQLInputImpl
      用于自定义映射用户定义类型（UDT）的输入流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.SQLOutput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.SQLOutput

  • Packages that use SQLOutput
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of SQLOutput in java.sql

      Methods in java.sql with parameters of type SQLOutput
      Modifier and Type 方法 描述
      void SQLData.writeSQL​(SQLOutput stream)
      将此对象写入给定的SQL数据流，将其转换回数据源中的SQL值。

    • Uses of SQLOutput in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement SQLOutput
      Modifier and Type Class 描述
      class  SQLOutputImpl
      用于将自定义映射的用户定义类型（UDT）的属性写入数据库的输出流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.SQLType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.SQLType

  • Packages that use SQLType
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of SQLType in java.sql

      Classes in java.sql that implement SQLType
      Modifier and Type Class 描述
      class  JDBCType
      定义用于标识通用SQL类型（称为JDBC类型）的常量。
      Methods in java.sql with parameters of type SQLType
      Modifier and Type 方法 描述
      default void CallableStatement.registerOutParameter​(int parameterIndex, SQLType sqlType)
      将序号 parameterIndex的OUT参数注册到JDBC类型 sqlType 。
      default void CallableStatement.registerOutParameter​(int parameterIndex, SQLType sqlType, int scale)
      将序号 parameterIndex的参数注册为JDBC类型 sqlType 。
      default void CallableStatement.registerOutParameter​(int parameterIndex, SQLType sqlType, String typeName)
      注册指定的输出参数。
      default void CallableStatement.registerOutParameter​(String parameterName, SQLType sqlType)
      将名为 parameterName的OUT参数注册到JDBC类型 sqlType 。
      default void CallableStatement.registerOutParameter​(String parameterName, SQLType sqlType, int scale)
      将名为 parameterName的参数注册为JDBC类型 sqlType 。
      default void CallableStatement.registerOutParameter​(String parameterName, SQLType sqlType, String typeName)
      注册指定的输出参数。
      default void CallableStatement.setObject​(String parameterName, Object x, SQLType targetSqlType)
      使用给定对象设置指定参数的值。
      default void CallableStatement.setObject​(String parameterName, Object x, SQLType targetSqlType, int scaleOrLength)
      使用给定对象设置指定参数的值。
      default void PreparedStatement.setObject​(int parameterIndex, Object x, SQLType targetSqlType)
      使用给定对象设置指定参数的值。
      default void PreparedStatement.setObject​(int parameterIndex, Object x, SQLType targetSqlType, int scaleOrLength)
      使用给定对象设置指定参数的值。
      ShardingKeyBuilder ShardingKeyBuilder.subkey​(Object subkey, SQLType subkeyType)
      将调用此方法将子项添加到正在构建的Sharding Key对象中。
      default void ResultSet.updateObject​(int columnIndex, Object x, SQLType targetSqlType)
      使用 Object值更新指定的列。
      default void ResultSet.updateObject​(int columnIndex, Object x, SQLType targetSqlType, int scaleOrLength)
      使用 Object值更新指定的列。
      default void ResultSet.updateObject​(String columnLabel, Object x, SQLType targetSqlType)
      使用 Object值更新指定的列。
      default void ResultSet.updateObject​(String columnLabel, Object x, SQLType targetSqlType, int scaleOrLength)
      使用 Object值更新指定的列。
      default void SQLOutput.writeObject​(Object x, SQLType targetSqlType)
      将包含在给定对象中的数据写入流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.SQLXML (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.SQLXML

  • Packages that use SQLXML
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of SQLXML in java.sql

      Methods in java.sql that return SQLXML
      Modifier and Type 方法 描述
      SQLXML Connection.createSQLXML​()
      构造一个实现 SQLXML接口的对象。
      SQLXML CallableStatement.getSQLXML​(int parameterIndex)
      以Java编程语言中的 java.sql.SQLXML对象获取指定的 SQL XML参数的值。
      SQLXML CallableStatement.getSQLXML​(String parameterName)
      以Java编程语言作为 java.sql.SQLXML对象检索指定的 SQL XML参数的值。
      SQLXML ResultSet.getSQLXML​(int columnIndex)
      以Java编程语言的 java.sql.SQLXML对象的形式，将此 ResultSet的当前行中的指定列的值检索。
      SQLXML ResultSet.getSQLXML​(String columnLabel)
      以Java编程语言的 java.sql.SQLXML对象的形式 java.sql.SQLXML此 ResultSet的当前行中指定列的值。
      SQLXML SQLInput.readSQLXML​()
      从流中读取SQL XML值，并将其作为Java编程语言中的 SQLXML对象返回。
      Methods in java.sql with parameters of type SQLXML
      Modifier and Type 方法 描述
      void CallableStatement.setSQLXML​(String parameterName, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void PreparedStatement.setSQLXML​(int parameterIndex, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void ResultSet.updateSQLXML​(int columnIndex, SQLXML xmlObject)
      使用 java.sql.SQLXML值更新指定的列。
      void ResultSet.updateSQLXML​(String columnLabel, SQLXML xmlObject)
      使用 java.sql.SQLXML值更新指定的列。
      void SQLOutput.writeSQLXML​(SQLXML x)
      将SQL XML值写入流。

    • Uses of SQLXML in javax.sql

      Methods in javax.sql with parameters of type SQLXML
      Modifier and Type 方法 描述
      void RowSet.setSQLXML​(int parameterIndex, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void RowSet.setSQLXML​(String parameterName, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。

    • Uses of SQLXML in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type SQLXML
      Modifier and Type 方法 描述
      void BaseRowSet.setSQLXML​(int parameterIndex, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。
      void BaseRowSet.setSQLXML​(String parameterName, SQLXML xmlObject)
      将指定的参数设置为给定的 java.sql.SQLXML对象。

    • Uses of SQLXML in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return SQLXML
      Modifier and Type 方法 描述
      SQLXML SQLInputImpl.readSQLXML​()
      从流中读取SQL XML值，并将其作为Java编程语言中的 SQLXML对象返回。
      Methods in javax.sql.rowset.serial with parameters of type SQLXML
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeSQLXML​(SQLXML x)
      写入一个SQL XML值到流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Statement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Statement

  • Packages that use Statement
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

    • Uses of Statement in java.sql

      Subinterfaces of Statement in java.sql
      Modifier and Type 接口 描述
      interface  CallableStatement
      用于执行SQL存储过程的界面。
      interface  PreparedStatement
      表示预编译的SQL语句的对象。
      Methods in java.sql that return Statement
      Modifier and Type 方法 描述
      Statement Connection.createStatement​()
      创建一个 Statement对象，用于将SQL语句发送到数据库。
      Statement Connection.createStatement​(int resultSetType, int resultSetConcurrency)
      创建一个 Statement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
      Statement Connection.createStatement​(int resultSetType, int resultSetConcurrency, int resultSetHoldability)
      创建一个 Statement对象，该对象将生成具有给定类型，并发和 ResultSet对象。
      Statement ResultSet.getStatement​()
      Retrieves the Statement object that produced this ResultSet object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Struct (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Struct

  • Packages that use Struct
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

    • Uses of Struct in java.sql

      Methods in java.sql that return Struct
      Modifier and Type 方法 描述
      Struct Connection.createStruct​(String typeName, Object[] attributes)
      用于创建Struct对象的工厂方法。
      Methods in java.sql with parameters of type Struct
      Modifier and Type 方法 描述
      void SQLOutput.writeStruct​(Struct x)
      将SQL结构化类型值写入流。

    • Uses of Struct in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement Struct
      Modifier and Type Class 描述
      class  SerialStruct
      SQL编程语言中的SQL结构化类型的序列化映射。
      Methods in javax.sql.rowset.serial with parameters of type Struct
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeStruct​(Struct x)
      将Java编程语言中的一个 Struct对象写入此 SQLOutputImpl对象。
      Constructors in javax.sql.rowset.serial with parameters of type Struct
      Constructor 描述
      SerialStruct​(Struct in, Map<String,Class<?>> map)
      Constructs a SerialStruct object from the given Struct object, using the given java.util.Map object for custom mapping the SQL structured type or any of its attributes that are SQL structured types.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.sql.Wrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.sql.Wrapper

  • Packages that use Wrapper
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。

    • Uses of Wrapper in java.sql

      Subinterfaces of Wrapper in java.sql
      Modifier and Type 接口 描述
      interface  CallableStatement
      用于执行SQL存储过程的界面。
      interface  Connection
      与特定数据库的连接（会话）。
      interface  DatabaseMetaData
      关于整个数据库的综合信息。
      interface  ParameterMetaData
      可用于获取有关 PreparedStatement对象中每个参数标记的类型和属性的 PreparedStatement对象。
      interface  PreparedStatement
      表示预编译的SQL语句的对象。
      interface  ResultSet
      表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
      interface  ResultSetMetaData
      可用于获取有关 ResultSet对象中列的类型和属性的信息的对象。
      interface  Statement
      用于执行静态SQL语句并返回其生成的结果的对象。

    • Uses of Wrapper in javax.sql

      Subinterfaces of Wrapper in javax.sql
      Modifier and Type 接口 描述
      interface  DataSource
      一个连接到这个 DataSource对象所代表的物理数据源的工厂。
      interface  RowSet
      该接口为JavaBeans组件模型的JDBC API添加了支持。
      interface  RowSetMetaData
      包含有关 RowSet对象中的列的 RowSet对象。

    • Uses of Wrapper in javax.sql.rowset

      Subinterfaces of Wrapper in javax.sql.rowset
      Modifier and Type 接口 描述
      interface  CachedRowSet
      CachedRowSet所有标准实现必须实现的接口。
      interface  FilteredRowSet
      FilteredRowSet所有标准实现必须实现的标准接口。
      interface  JdbcRowSet
      JdbcRowSet所有标准实现必须实现的标准接口。
      interface  JoinRowSet
      JoinRowSet接口提供了将来自不同 RowSet对象的相关数据组合到一个 JoinRowSet对象中的机制，该对象表示SQL JOIN 。
      interface  WebRowSet
      WebRowSet所有实现必须实现的标准接口。
      Classes in javax.sql.rowset that implement Wrapper
      Modifier and Type Class 描述
      class  RowSetMetaDataImpl
      提供有关设置和获取关于 RowSet对象列的元数据信息的方法的实现。

    • Uses of Wrapper in javax.sql.rowset.spi

      Subinterfaces of Wrapper in javax.sql.rowset.spi
      Modifier and Type 接口 描述
      interface  SyncResolver
      定义一个框架，允许应用程序使用手动决策树来决定在发生同步冲突时应该做什么。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Annotation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class Annotation

  • java.lang.Object
    • java.text.Annotation

  • public class Annotation
extends Object
    如果属性具有注释特征，则Annotation对象用作文本属性值的包装器。 这些特点是：
    • 应用属性的文本范围对范围的语义是至关重要的。 这意味着，该属性不能应用于其适用的文本范围的子范围，如果两个相邻的文本范围对于此属性具有相同的值，则该属性仍然不能应用于具有此值的整体的组合范围。
    • 如果基础文本被更改，则该属性或其值通常不再适用。
    一个例子是附在句子上的语法信息：对于上一句，你可以说“一个例子”是主题，但你不能对“一个”，“示例”或“考试”说同样的话。 当文本被改变时，语法信息通常变得无效。 另一个例子是日本的阅读信息（yomi）。

    将属性值包装到注释对象中，即使属性值相等，也不会合并相邻文本，并且如果底层文本被修改，则会向文本容器指示属性应该被丢弃。

    从以下版本开始：
    1.2
    另请参见：
    AttributedCharacterIterator

    • 构造方法摘要

      构造方法
      Constructor 描述
      Annotation​(Object value)
      构造具有给定值的注释记录，可以为null。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getValue​()
      返回属性的值，可以为null。
      String toString​()
      返回此注释的String表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Annotation

        public Annotation​(Object value)
        构造具有给定值的注释记录，可以为null。
        参数
        value - 属性的值

    • 方法详细信息

      • getValue

        public Object getValue​()
        返回属性的值，可以为null。
        结果
        属性的值

      • toString

        public String toString​()
        返回此注释的String表示形式。
        重写：
        toString在 Object
        结果
        the String representation of this Annotation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AttributedCharacterIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Interface AttributedCharacterIterator

  • All Superinterfaces:
    CharacterIterator ， Cloneable

    public interface AttributedCharacterIterator
extends CharacterIterator
    一个AttributedCharacterIterator允许通过文本和相关的属性信息进行迭代。

    属性是由键标识的键/值对。 给定字符上没有两个属性可以具有相同的键。

    属性的值是不可变的，不能被客户机或存储设备突变。 它们总是通过引用传递，而不是被克隆。

    关于属性的运行是一个最大文本范围：

    • 该属性未定义，或null为整个范围，或
    • 属性值被定义，并且对于整个范围具有相同的非null值。

    相对于一组属性的运行是每个成员属性满足此条件的最大文本范围。

    当获得没有指定明确属性的运行（即调用getRunStart()和getRunLimit() ）时，具有相同属性（相同属性/值对集合）的任何连续文本段被视为单独的运行，如果属性已被赋予这些文本段分开。

    返回的索引仅限于迭代器的范围。

    返回的属性信息仅限于包含当前字符的运行。

    属性键是AttributedCharacterIterator.Attribute及其子类的实例，例如TextAttribute 。

    从以下版本开始：
    1.2
    另请参见：
    AttributedCharacterIterator.Attribute ， TextAttribute ， AttributedString ， Annotation

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  AttributedCharacterIterator.Attribute
      定义用于标识文本属性的属性键。

    • Field Summary

      • Fields inherited from interface java.text.CharacterIterator

        DONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Set<AttributedCharacterIterator.Attribute> getAllAttributeKeys​()
      返回在迭代器的文本范围上定义的所有属性的关键字。
      Object getAttribute​(AttributedCharacterIterator.Attribute attribute)
      返回当前字符的名称为 attribute的值。
      Map<AttributedCharacterIterator.Attribute,Object> getAttributes​()
      返回当前字符中定义的属性的地图。
      int getRunLimit​()
      相对于包含当前字符的所有属性返回运行后第一个字符的索引。
      int getRunLimit​(AttributedCharacterIterator.Attribute attribute)
      返回运行后相对于包含当前字符的给定 attribute的第一个字符的索引。
      int getRunLimit​(Set<? extends AttributedCharacterIterator.Attribute> attributes)
      相对于包含当前字符的给定的 attributes返回运行后的第一个字符的索引。
      int getRunStart​()
      相对于包含当前字符的所有属性返回运行的第一个字符的索引。
      int getRunStart​(AttributedCharacterIterator.Attribute attribute)
      返回相对于包含当前字符的给定的 attribute的运行的第一个字符的索引。
      int getRunStart​(Set<? extends AttributedCharacterIterator.Attribute> attributes)
      相对于包含当前字符的给定的 attributes返回运行的第一个字符的索引。

      • Methods inherited from interface java.text.CharacterIterator

        clone, current, first, getBeginIndex, getEndIndex, getIndex, last, next, previous, setIndex

    • 方法详细信息

      • getRunStart

        int getRunStart​()
        相对于包含当前字符的所有属性返回运行的第一个字符的索引。

        如果已将属性分别提供给这些文本段，则具有相同属性（相同的属性/值对集合）的任何连续文本段被视为单独的运行。

        结果
        运行的第一个字符的索引

      • getRunStart

        int getRunStart​(AttributedCharacterIterator.Attribute attribute)
        相对于包含当前字符的给定 attribute返回运行的第一个字符的索引。
        参数
        attribute - 所需属性。
        结果
        运行的第一个字符的索引

      • getRunStart

        int getRunStart​(Set<? extends AttributedCharacterIterator.Attribute> attributes)
        相对于包含当前字符的给定的 attributes返回运行的第一个字符的索引。
        参数
        attributes - 一组所需属性。
        结果
        运行的第一个字符的索引

      • getRunLimit

        int getRunLimit​()
        相对于包含当前字符的所有属性返回运行后第一个字符的索引。

        如果已将属性分别提供给这些文本段，则具有相同属性（相同的属性/值对集合）的任何连续文本段被视为单独的运行。

        结果
        运行后的第一个字符的索引

      • getRunLimit

        int getRunLimit​(AttributedCharacterIterator.Attribute attribute)
        相对于包含当前字符的给定的 attribute返回运行后的第一个字符的索引。
        参数
        attribute - 所需属性
        结果
        运行后的第一个字符的索引

      • getRunLimit

        int getRunLimit​(Set<? extends AttributedCharacterIterator.Attribute> attributes)
        返回运行后相对于包含当前字符的给定 attributes的第一个字符的索引。
        参数
        attributes - 一组所需属性
        结果
        运行后的第一个字符的索引

      • getAttributes

        Map<AttributedCharacterIterator.Attribute,Object> getAttributes​()
        返回当前字符中定义的属性的地图。
        结果
        具有当前字符定义的属性的地图

      • getAttribute

        Object getAttribute​(AttributedCharacterIterator.Attribute attribute)
        返回当前字符的名称为attribute的值。 如果attribute则返回null 。
        参数
        attribute - 所需属性
        结果
        名称为 attribute或 null的值

      • getAllAttributeKeys

        Set<AttributedCharacterIterator.Attribute> getAllAttributeKeys​()
        返回在迭代器的文本范围上定义的所有属性的关键字。 如果没有定义属性，则该集合为空。
        结果
        the keys of all attributes
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AttributedCharacterIterator.Attribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class AttributedCharacterIterator.Attribute

  • java.lang.Object
    • java.text.AttributedCharacterIterator.Attribute
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    Format.Field ， TextAttribute
    Enclosing interface:
    AttributedCharacterIterator

    public static class AttributedCharacterIterator.Attribute
extends Object
implements Serializable
    定义用于标识文本属性的属性键。 这些键用于AttributedCharacterIterator和AttributedString 。
    从以下版本开始：
    1.2
    另请参见：
    AttributedCharacterIterator ， AttributedString ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static AttributedCharacterIterator.Attribute INPUT_METHOD_SEGMENT
      输入方法段的属性键。
      static AttributedCharacterIterator.Attribute LANGUAGE
      一些文本的语言的属性键。
      static AttributedCharacterIterator.Attribute READING
      用于阅读某些文本的属性键。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Attribute​(String name)
      构造具有给定名称的 Attribute 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      比较两个对象的平等。
      protected String getName​()
      返回属性的名称。
      int hashCode​()
      返回对象的哈希码值。
      protected Object readResolve​()
      解析反序列化为预定义常量的实例。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • LANGUAGE

        public static final AttributedCharacterIterator.Attribute LANGUAGE
        一些文本的语言的属性键。

        值为Locale的实例。

        另请参见：
        Locale

      • READING

        public static final AttributedCharacterIterator.Attribute READING
        用于阅读某些文本的属性键。 在一个单词的书写形式和发音只是松散相关的语言（如日语）中，通常需要将书写（发音）与书面形式一起存储。

        值是实例Annotation种的召开情况String 。

        另请参见：
        Annotation ， String

      • INPUT_METHOD_SEGMENT

        public static final AttributedCharacterIterator.Attribute INPUT_METHOD_SEGMENT
        输入方法段的属性键。 输入法通常将文本分解成段，通常对应于单词。

        值是Annotation持有一个null参考的实例。

        另请参见：
        Annotation

    • 构造方法详细信息

      • Attribute

        protected Attribute​(String name)
        构造具有给定名称的 Attribute 。
        参数
        name - 名称 Attribute

    • 方法详细信息

      • equals

        public final boolean equals​(Object obj)
        比较两个对象的平等。 如果x和y引用了同一个对象，则此版本仅对于x.equals(y)返回true，并保证所有子类。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public final int hashCode​()
        返回对象的哈希码值。 此版本与Object版本相同，但也是最终版本。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回对象的字符串表示形式。 此版本返回类名称的连接， "(" ，标识属性的名称和")" 。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • getName

        protected String getName​()
        返回属性的名称。
        结果
        名称为 Attribute

      • readResolve

        protected Object readResolve​()
                      throws InvalidObjectException
        解析反序列化为预定义常量的实例。
        结果
        解决了 Attribute对象
        异常
        InvalidObjectException - 如果要解析的对象不是 Attribute的实例
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AttributedString (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class AttributedString

  • java.lang.Object
    • java.text.AttributedString

  • public class AttributedString
extends Object
    AttributedString保存文本和相关属性信息。 在某些情况下，文本读取器想要通过AttributedCharacterIterator接口访问属性文本，可以将其用作实际的数据存储。

    属性是由键标识的键/值对。 给定字符上没有两个属性可以具有相同的键。

    属性的值是不可变的，不能被客户机或存储设备突变。 它们总是通过引用传递，而不是被克隆。

    从以下版本开始：
    1.2
    另请参见：
    AttributedCharacterIterator ， Annotation

    • 构造方法摘要

      构造方法
      Constructor 描述
      AttributedString​(String text)
      使用给定的文本构造一个AttributedString实例。
      AttributedString​(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      使用给定的文本和属性构造一个AttributedString实例。
      AttributedString​(AttributedCharacterIterator text)
      使用AttributedCharacterIterator表示的给定归因文本构造一个AttributedString实例。
      AttributedString​(AttributedCharacterIterator text, int beginIndex, int endIndex)
      使用AttributedCharacterIterator表示的给定归因文本的子范围构造一个AttributedString实例。
      AttributedString​(AttributedCharacterIterator text, int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
      使用AttributedCharacterIterator表示的给定归因文本的子范围构造一个AttributedString实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addAttribute​(AttributedCharacterIterator.Attribute attribute, Object value)
      在整个字符串中添加一个属性。
      void addAttribute​(AttributedCharacterIterator.Attribute attribute, Object value, int beginIndex, int endIndex)
      将一个属性添加到字符串的子范围。
      void addAttributes​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes, int beginIndex, int endIndex)
      将一组属性添加到字符串的子范围。
      AttributedCharacterIterator getIterator​()
      创建一个AttributedCharacterIterator实例，该实例提供对该字符串的整个内容的访问。
      AttributedCharacterIterator getIterator​(AttributedCharacterIterator.Attribute[] attributes)
      创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。
      AttributedCharacterIterator getIterator​(AttributedCharacterIterator.Attribute[] attributes, int beginIndex, int endIndex)
      创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AttributedString

        public AttributedString​(String text)
        使用给定的文本构造一个AttributedString实例。
        参数
        text - 此归因字符串的文本。
        异常
        NullPointerException - 如果 text为空。

      • AttributedString

        public AttributedString​(String text,
                        Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
        使用给定的文本和属性构造一个AttributedString实例。
        参数
        text - 此归因字符串的文本。
        attributes - 适用于整个字符串的属性。
        异常
        NullPointerException - 如果 text或 attributes为空。
        IllegalArgumentException - 如果文本长度为0，并且attributes参数不是空的Map（属性不能应用于0长度范围）。

      • AttributedString

        public AttributedString​(AttributedCharacterIterator text)
        使用AttributedCharacterIterator表示的给定归因文本构造一个AttributedString实例。
        参数
        text - 此归因字符串的文本。
        异常
        NullPointerException - 如果 text为空。

      • AttributedString

        public AttributedString​(AttributedCharacterIterator text,
                        int beginIndex,
                        int endIndex)
        使用AttributedCharacterIterator表示的给定归因文本的子范围构造一个AttributedString实例。 如果给定范围产生一个空文本，则所有属性将被丢弃。 请注意，由原始属性范围的子范围丢弃由注释对象包装的任何属性。
        参数
        text - 此归因字符串的文本。
        beginIndex - 范围的第一个字符的索引。
        endIndex - 范围的最后一个字符后面的字符的索引。
        异常
        NullPointerException - 如果 text为空。
        IllegalArgumentException - 如果由beginIndex和endIndex给出的子范围超出了文本范围。
        另请参见：
        Annotation

      • AttributedString

        public AttributedString​(AttributedCharacterIterator text,
                        int beginIndex,
                        int endIndex,
                        AttributedCharacterIterator.Attribute[] attributes)
        使用AttributedCharacterIterator表示的给定归因文本的子范围构造一个AttributedString实例。 只有与给定属性相匹配的属性将被并入到实例中。 如果给定范围产生一个空文本，则所有属性将被丢弃。 请注意，由原始属性范围的子范围丢弃由注释对象包装的任何属性。
        参数
        text - 此归因字符串的文本。
        beginIndex - 范围的第一个字符的索引。
        endIndex - 范围的最后一个字符后面的字符的索引。
        attributes - 指定要从文本中提取的属性。 如果指定为null，将使用所有可用的属性。
        异常
        NullPointerException - 如果 text为空。
        IllegalArgumentException - 如果由beginIndex和endIndex给出的子范围超出了文本范围。
        另请参见：
        Annotation

    • 方法详细信息

      • addAttribute

        public void addAttribute​(AttributedCharacterIterator.Attribute attribute,
                         Object value)
        在整个字符串中添加一个属性。
        参数
        attribute - 属性键
        value - 属性的值; 可能为null
        异常
        NullPointerException - 如果 attribute为空。
        IllegalArgumentException - 如果AttributedString的长度为0（属性不能应用于0长度范围）。

      • addAttribute

        public void addAttribute​(AttributedCharacterIterator.Attribute attribute,
                         Object value,
                         int beginIndex,
                         int endIndex)
        将一个属性添加到字符串的子范围。
        参数
        attribute - 属性键
        value - 属性的值。 可能为null。
        beginIndex - 范围的第一个字符的索引。
        endIndex - 范围的最后一个字符后面的字符的索引。
        异常
        NullPointerException - 如果 attribute为空。
        IllegalArgumentException - 如果beginIndex小于0，则endIndex大于字符串的长度，或者beginIndex和endIndex一起不定义字符串的非空子列。

      • addAttributes

        public void addAttributes​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes,
                          int beginIndex,
                          int endIndex)
        将一组属性添加到字符串的子范围。
        参数
        attributes - 要添加到字符串的属性。
        beginIndex - 范围的第一个字符的索引。
        endIndex - 范围的最后一个字符后面的字符的索引。
        异常
        NullPointerException - 如果 attributes为空。
        IllegalArgumentException - 如果beginIndex小于0，则endIndex大于字符串的长度，或者beginIndex和endIndex一起不定义字符串的非空子范围，并且attributes参数不是空的Map。

      • getIterator

        public AttributedCharacterIterator getIterator​()
        创建一个AttributedCharacterIterator实例，该实例提供对该字符串的整个内容的访问。
        结果
        提供对文本及其属性的访问的迭代器。

      • getIterator

        public AttributedCharacterIterator getIterator​(AttributedCharacterIterator.Attribute[] attributes)
        创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。 关于属性中没有列出的属性的信息，实现者可能不需要通过迭代器访问。 如果列表为空，则所有可用属性信息都应该可访问。
        参数
        attributes - 客户端感兴趣的属性列表
        结果
        提供对整个文本及其所选属性的访问的迭代器

      • getIterator

        public AttributedCharacterIterator getIterator​(AttributedCharacterIterator.Attribute[] attributes,
                                               int beginIndex,
                                               int endIndex)
        创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。 关于属性中没有列出的属性的信息，实现者可能不需要通过迭代器访问。 如果列表为空，则所有可用属性信息都应该可访问。
        参数
        attributes - 客户端感兴趣的属性列表
        beginIndex - 第一个字符的索引
        endIndex - 最后一个字符后面的字符的索引
        结果
        提供对文本及其属性的访问的迭代器
        异常
        IllegalArgumentException - 如果beginIndex小于0，则endIndex大于字符串的长度，或beginIndex大于endIndex。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Bidi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class Bidi

  • java.lang.Object
    • java.text.Bidi

  • public final class Bidi
extends Object
    该类实现了Unicode双向算法。

    Bidi对象提供有关用于创建它的文本的双向重新排序的信息。 这是必需的，例如，正确显示阿拉伯语或希伯来语文本。 这些语言本质上是混合的方式，因为它们从左到右订购数字，而从右到左排序大多数其他文本。

    一旦创建，可以查询一个Bidi对象，看看它代表的文本是从左到右还是从右到左。 这样的对象非常轻巧，这个文本比较容易处理。

    如果有多个文本运行，则可以通过索引访问有关运行的信息，以获取运行的开始，限制和级别。 该级别表示方向运行的方向和“嵌套级别”。 奇数级别是从右到左，而平均级别是从左到右。 因此，例如级别0表示从左到右的文本，而级别1表示从右到左的文本，级别2表示嵌入在从右到左的运行中的从左到右的文本。

    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DIRECTION_DEFAULT_LEFT_TO_RIGHT
      常数表示基本方向取决于文本中根据Unicode双向算法的第一个强定向字符。
      static int DIRECTION_DEFAULT_RIGHT_TO_LEFT
      常数表示基本方向取决于文本中根据Unicode双向算法的第一个强定向字符。
      static int DIRECTION_LEFT_TO_RIGHT
      常数表示基地方向是从左到右。
      static int DIRECTION_RIGHT_TO_LEFT
      恒定指示基准方向是从右到左。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Bidi​(char[] text, int textStart, byte[] embeddings, int embStart, int paragraphLength, int flags)
      从给定的文本，嵌入和方向信息创建Bidi。
      Bidi​(String paragraph, int flags)
      从文本和基本方向的给定段落创建Bidi。
      Bidi​(AttributedCharacterIterator paragraph)
      从文本的给定段落创建Bidi。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean baseIsLeftToRight​()
      如果基本方向是从左到右，则返回true。
      Bidi createLineBidi​(int lineStart, int lineLimit)
      创建一个Bidi对象，该对象表示由当前Bidi表示的段落内的一行文本上的双目标信息。
      int getBaseLevel​()
      返回基本级别（如果从左到右为0，如果从右到左，则返回1）。
      int getLength​()
      返回行中的文本长度。
      int getLevelAt​(int offset)
      返回已解决的偏移角色级别。
      int getRunCount​()
      返回级别运行次数。
      int getRunLevel​(int run)
      返回此行中第n个逻辑运行的级别。
      int getRunLimit​(int run)
      返回该行的第n个逻辑运行结束之后的索引，作为与行开头的偏移量。
      int getRunStart​(int run)
      返回此行中第n个逻辑运行开始处的字符索引，作为与行开头的偏移量。
      boolean isLeftToRight​()
      如果行是从左到右的文本，并且基本方向是从左到右，返回true。
      boolean isMixed​()
      如果行不是从左到右还是从右到左，返回true。
      boolean isRightToLeft​()
      如果行是从右到左文本，并且基本方向是从右到左，返回true。
      static void reorderVisually​(byte[] levels, int levelStart, Object[] objects, int objectStart, int count)
      将数组中的对象根据其级别重新排序为可视化顺序。
      static boolean requiresBidi​(char[] text, int start, int limit)
      如果指定的文本需要双向分析，则返回true。
      String toString​()
      显示调试中使用的双向内部状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DIRECTION_LEFT_TO_RIGHT

        public static final int DIRECTION_LEFT_TO_RIGHT
        常数表示基地方向是从左到右。
        另请参见：
        Constant Field Values

      • DIRECTION_RIGHT_TO_LEFT

        public static final int DIRECTION_RIGHT_TO_LEFT
        恒定指示基准方向是从右到左。
        另请参见：
        Constant Field Values

      • DIRECTION_DEFAULT_LEFT_TO_RIGHT

        public static final int DIRECTION_DEFAULT_LEFT_TO_RIGHT
        常数表示基本方向取决于文本中根据Unicode双向算法的第一个强定向字符。 如果不存在强定向角色，则基本方向是从左到右。
        另请参见：
        Constant Field Values

      • DIRECTION_DEFAULT_RIGHT_TO_LEFT

        public static final int DIRECTION_DEFAULT_RIGHT_TO_LEFT
        常数表示基本方向取决于文本中根据Unicode双向算法的第一个强定向字符。 如果不存在强定向角色，则基本方向是从右到左。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Bidi

        public Bidi​(String paragraph,
            int flags)
        从文本和基本方向的给定段落创建Bidi。
        参数
        paragraph - 一段文字
        flags - 控制算法的标志集合。 该算法了解标志DIRECTION_LEFT_TO_RIGHT，DIRECTION_RIGHT_TO_LEFT，DIRECTION_DEFAULT_LEFT_TO_RIGHT和DIRECTION_DEFAULT_RIGHT_TO_LEFT。 其他值被保留。

      • Bidi

        public Bidi​(AttributedCharacterIterator paragraph)
        从文本的给定段落创建Bidi。

        文本中的RUN_DIRECTION属性（如果存在）确定基本方向（从左到右或从右到左）。 如果不存在，则使用Unicode双向算法计算基本方向，如果文本中没有强有力的方向性字符，则默认为从左到右。 该属性（如果存在）必须应用于段落中的所有文本。

        文本中的BIDI_EMBEDDING属性（如果存在）表示嵌入级别信息。 -1到-62的负值表示在级别的绝对值上的覆盖。 1到62的正值表示嵌入。 在值为零或未定义的情况下，假定由基准方向确定的基本嵌入级别。

        文本中的NUMERIC_SHAPING属性（如果存在）在运行bidi算法之前将欧洲数字转换为其他十进制数字。 该属性（如果存在）必须应用于段落中的所有文本。

        参数
        paragraph - 具有可选字符和段落属性信息的文本段落
        另请参见：
        TextAttribute.BIDI_EMBEDDING ， TextAttribute.NUMERIC_SHAPING ， TextAttribute.RUN_DIRECTION

      • Bidi

        public Bidi​(char[] text,
            int textStart,
            byte[] embeddings,
            int embStart,
            int paragraphLength,
            int flags)
        从给定的文本，嵌入和方向信息创建Bidi。 embeddings数组可能为null。 如果存在，则这些值表示嵌入级别信息。 -1到-61的负值表示在该级别的绝对值上的覆盖。 1到61的正值表示嵌入。 在值为零的情况下，假定由基准方向确定的基本嵌入级别。
        参数
        text - 一个包含要处理的文本段落的数组。
        textStart - 将段落的开头的文本数组的索引。
        embeddings - 包含段落中每个字符的嵌入值的数组。 这可以是null，在这种情况下，假设没有外部嵌入信息。
        embStart - 索引到嵌入数组的开始段落。
        paragraphLength - 文本和嵌入数组中段落的长度。
        flags - 控制算法的标志集合。 该算法了解标志DIRECTION_LEFT_TO_RIGHT，DIRECTION_RIGHT_TO_LEFT，DIRECTION_DEFAULT_LEFT_TO_RIGHT和DIRECTION_DEFAULT_RIGHT_TO_LEFT。 其他值被保留。

    • 方法详细信息

      • createLineBidi

        public Bidi createLineBidi​(int lineStart,
                           int lineLimit)
        创建一个Bidi对象，该对象表示由当前Bidi表示的段落内的一行文本上的双目标信息。 如果整个段落适合一行，则不需要此呼叫。
        参数
        lineStart - 从段落开始到行开始的偏移量。
        lineLimit - 从段落开始到行限制的偏移量。
        结果
        一个 Bidi对象

      • isMixed

        public boolean isMixed​()
        如果行不是从左到右还是从右到左，返回true。 这意味着它有从左到右和从右到左的文本的混合运行，或者基本方向与文本的唯一运行的方向不同。
        结果
        如果行不是从左到右或从右到左，则为true。

      • isLeftToRight

        public boolean isLeftToRight​()
        如果行是从左到右的文本，并且基本方向是从左到右，返回true。
        结果
        如果行全部是从左到右的文本，并且基本方向是从左到右，则为true

      • isRightToLeft

        public boolean isRightToLeft​()
        如果行是从右到左文本，并且基本方向是从右到左，返回true。
        结果
        如果行全部是从右到左的文本，并且基本方向是从右到左，则为true

      • getLength

        public int getLength​()
        返回行中的文本长度。
        结果
        文字的长度在行中

      • baseIsLeftToRight

        public boolean baseIsLeftToRight​()
        如果基本方向是从左到右，则返回true。
        结果
        如果基本方向是从左到右，则为真

      • getBaseLevel

        public int getBaseLevel​()
        返回基本级别（如果从左到右为0，如果从右到左，则返回1）。
        结果
        基础水平

      • getLevelAt

        public int getLevelAt​(int offset)
        返回已解决的偏移角色级别。 如果偏移量为<0或≥该行的长度，则返回基准方向。
        参数
        offset - 返回级别的字符的索引
        结果
        已解决的角色偏移量

      • getRunCount

        public int getRunCount​()
        返回级别运行次数。
        结果
        级别运行次数

      • getRunLevel

        public int getRunLevel​(int run)
        返回此行中第n个逻辑运行的级别。
        参数
        run - 运行的索引，介于0和 getRunCount()之间
        结果
        运行的水平

      • getRunStart

        public int getRunStart​(int run)
        返回此行中第n个逻辑运行开始处的字符索引，作为与行开头的偏移量。
        参数
        run - 运行的索引，介于0和 getRunCount()之间
        结果
        开始运行

      • getRunLimit

        public int getRunLimit​(int run)
        返回该行的第n个逻辑运行结束之后的索引，作为与行开头的偏移量。 例如，这将返回上一行在行上的行长度。
        参数
        run - 运行的索引，介于0和 getRunCount()之间
        结果
        限制运行的极限

      • requiresBidi

        public static boolean requiresBidi​(char[] text,
                                   int start,
                                   int limit)
        如果指定的文本需要双向分析，则返回true。 如果这返回false，文本将从左到右显示。 客户可以避免构建一个Bidi对象。 假定Unicode的阿拉伯语表示形式区域中的文本已经被形状化并且被排序显示，因此不会导致该函数返回true。
        参数
        text - 包含要测试的字符的文本
        start - 要测试的字符范围的开始
        limit - 要测试的字符范围的限制
        结果
        如果字符范围需要双向分析，则为真

      • reorderVisually

        public static void reorderVisually​(byte[] levels,
                                   int levelStart,
                                   Object[] objects,
                                   int objectStart,
                                   int count)
        将数组中的对象根据其级别重新排序为可视化顺序。 当您具有以逻辑顺序表示文本运行的对象集合时，这是一个实用功能，每个运行都包含单个级别的文本。 假设每个文本的运行都具有由数组中的相应元素指示的级别（ index - objectStart + levelStart ），则对象数组中的index从objectStart到objectStart + count的元素将被重新排序为可视顺序。
        参数
        levels - 表示每个对象的双向级别的数组
        levelStart - 级别数组中的起始位置
        objects - 要重新排序为可视化顺序的对象数组
        objectStart - 对象数组中的起始位置
        count - 要重新排序的对象数

      • toString

        public String toString​()
        显示调试中使用的双向内部状态。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


BreakIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class BreakIterator

  • java.lang.Object
    • java.text.BreakIterator
  • All Implemented Interfaces:
    Cloneable

    public abstract class BreakIterator
extends Object
implements Cloneable
    BreakIterator类实现了在文本中查找边界位置的方法。 BreakIterator实例保持当前位置并扫描返回边界发生的字符索引的文本。 在内部， BreakIterator扫描文本使用CharacterIterator ，并且因此能够扫描通过实现协议的任何对象保存文本。 A StringCharacterIterator用于扫描传递给setText String对象。

    您可以使用此类提供的工厂方法来创建各种类型的中断迭代器的实例。 尤其是，使用getWordInstance ， getLineInstance ， getSentenceInstance ，并getCharacterInstance创造BreakIterator s表示分别执行字，行，句子和字符边界分析。 单个BreakIterator只能在一个单位（单词，行，句子等）上工作。 对于您希望执行的每个单位边界分析，必须使用不同的迭代器。

    行边界分析确定在换行时文本字符串可以被打破的位置。 该机制正确处理标点符号和连字符。 实际断线需要考虑可用线宽，并由更高级别的软件处理。

    句子边界分析允许选择正确解释数字和缩写中的句点，以及尾随的标点符号，如引号和括号。

    Word边界分析由搜索和替换功能以及文本编辑应用程序使用，允许用户双击选择单词。 词选择提供正确解释单词内和之后的标点符号。 不是单词的一部分的字符，如符号或标点符号，双方都有单词。

    字符边界分析允许用户与字符进行交互，例如，当将光标移动到文本字符串时。 字符边界分析提供了通过字符串的正确导航，而不管字符的存储方式如何。 返回的边界可以是补充字符，组合字符序列或连字符集的边界。 例如，重音字符可能存储为基本字符和变音标记。 用户认为是一个字符的用户可能因语言而异。

    由本类工厂方法返回的BreakIterator实例仅适用于自然语言，而不适用于编程语言文本。 然而，可以定义标记编程语言的子类。

    示例 ：

    创建和使用文本边界：

     public static void main(String args[]) {
      if (args.length == 1) {
          String stringToExamine = args[0];
          //print each word in order
          BreakIterator boundary = BreakIterator.getWordInstance();
          boundary.setText(stringToExamine);
          printEachForward(boundary, stringToExamine);
          //print each sentence in reverse order
          boundary = BreakIterator.getSentenceInstance(Locale.US);
          boundary.setText(stringToExamine);
          printEachBackward(boundary, stringToExamine);
          printFirst(boundary, stringToExamine);
          printLast(boundary, stringToExamine);
      }
 }
    按顺序打印每个元素：
     public static void printEachForward(BreakIterator boundary, String source) {
     int start = boundary.first();
     for (int end = boundary.next();
          end != BreakIterator.DONE;
          start = end, end = boundary.next()) {
          System.out.println(source.substring(start,end));
     }
 }
    以相反的顺序打印每个元素：
     public static void printEachBackward(BreakIterator boundary, String source) {
     int end = boundary.last();
     for (int start = boundary.previous();
          start != BreakIterator.DONE;
          end = start, start = boundary.previous()) {
         System.out.println(source.substring(start,end));
     }
 }
    打印第一个元素：
     public static void printFirst(BreakIterator boundary, String source) {
     int start = boundary.first();
     int end = boundary.next();
     System.out.println(source.substring(start,end));
 }
    打印最后一个元素
     public static void printLast(BreakIterator boundary, String source) {
     int end = boundary.last();
     int start = boundary.previous();
     System.out.println(source.substring(start,end));
 }
    在指定位置打印元素：
     public static void printAt(BreakIterator boundary, int pos, String source) {
     int end = boundary.following(pos);
     int start = boundary.previous();
     System.out.println(source.substring(start,end));
 }
    找到下一个字：

 public static int nextWordStartAfter(int pos, String text) {
     BreakIterator wb = BreakIterator.getWordInstance();
     wb.setText(text);
     int last = wb.following(pos);
     int current = wb.next();
     while (current != BreakIterator.DONE) {
         for (int p = last; p < current; p++) {
             if (Character.isLetter(text.codePointAt(p)))
                 return last;
         }
         last = current;
         current = wb.next();
     }
     return BreakIterator.DONE;
 }
    (The iterator returned by BreakIterator.getWordInstance() is unique in that the break positions it returns don't represent both the start and end of the thing being iterated over. That is, a sentence-break iterator returns breaks that each represent the end of one sentence and the beginning of the next. With the word-break iterator, the characters between two boundaries might be a word, or they might be the punctuation or whitespace between two words. The above code uses a simple heuristic to determine which boundary is the beginning of a word: If the characters between this boundary and the next boundary include at least one letter (this can be an alphabetical letter, a CJK ideograph, a Hangul syllable, a Kana character, etc.), then the text between this boundary and the next is a word; otherwise, it's the material between words.)
    从以下版本开始：
    1.1
    另请参见：
    CharacterIterator

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DONE
      当达到第一个或最后一个文本边界时，DONE将返回previous（），next（），next（int），previous（int）和after（int）。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected BreakIterator​()
      构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建一个这个迭代器的副本
      abstract int current​()
      返回最近由next（），next（int），previous（），first（），last（），following（int）或previous（int）返回的文本边界的字符索引。
      abstract int first​()
      返回第一个边界。
      abstract int following​(int offset)
      返回指定字符偏移后的第一个边界。
      static Locale[] getAvailableLocales​()
      返回所有语言环境的数组， get*Instance方法可以返回本地化实例。
      static BreakIterator getCharacterInstance​()
      对于 default locale为 character breaks返回一个新的 BreakIterator实例。
      static BreakIterator getCharacterInstance​(Locale locale)
      为给定的区域设置返回一个新的 BreakIterator实例 character breaks 。
      static BreakIterator getLineInstance​()
      为 default locale返回一个新的 BreakIterator实例 line breaks 。
      static BreakIterator getLineInstance​(Locale locale)
      为给定的区域设置返回一个新的 BreakIterator实例 line breaks 。
      static BreakIterator getSentenceInstance​()
      返回一个新 BreakIterator例如 sentence breaks为 default locale 。
      static BreakIterator getSentenceInstance​(Locale locale)
      为给定的区域设置返回一个新的 BreakIterator实例 sentence breaks 。
      abstract CharacterIterator getText​()
      获取正在扫描的文本
      static BreakIterator getWordInstance​()
      为 default locale返回一个新的 BreakIterator实例 word breaks 。
      static BreakIterator getWordInstance​(Locale locale)
      为给定的区域设置返回一个新的 BreakIterator实例 word breaks 。
      boolean isBoundary​(int offset)
      如果指定的字符偏移量是文本边界，则返回true。
      abstract int last​()
      返回最后一个边界。
      abstract int next​()
      返回当前边界之后的边界。
      abstract int next​(int n)
      从当前边界返回第n个边界。
      int preceding​(int offset)
      返回指定字符偏移量之前的最后一个边界。
      abstract int previous​()
      返回当前边界之前的边界。
      void setText​(String newText)
      设置要扫描的新文本字符串。
      abstract void setText​(CharacterIterator newText)
      设置一个新文本进行扫描。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DONE

        public static final int DONE
        当达到第一个或最后一个文本边界时，DONE将返回previous（），next（），next（int），previous（int）和after（int）。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • BreakIterator

        protected BreakIterator​()
        构造函数。 BreakIterator是无状态的，没有默认行为。

    • 方法详细信息

      • clone

        public Object clone​()
        创建一个这个迭代器的副本
        重写：
        clone在 Object
        结果
        这个的副本
        另请参见：
        Cloneable

      • first

        public abstract int first​()
        返回第一个边界。 迭代器的当前位置被设置为第一个文本边界。
        结果
        第一个文本边界的字符索引。

      • last

        public abstract int last​()
        返回最后一个边界。 迭代器的当前位置设置为最后一个文本边界。
        结果
        最后一个文本边界的字符索引。

      • next

        public abstract int next​(int n)
        从当前边界返回第n个边界。 如果达到了第一个或最后一个文本边界，它将返回BreakIterator.DONE并且根据到达哪一个文本边界将当前位置设置为第一个或最后一个文本边界。 否则，迭代器的当前位置被设置为新的边界。 例如，如果迭代器的当前位置是第m个文本边界，并且从当前边界到最后一个文本边界存在三个边界，则下一个（2）调用将返回m + 2。新的文本位置设置为（m + 2）个文本边界。 下一个（4）调用将返回BreakIterator.DONE ，最后一个文本边界将成为新的文本位置。
        参数
        n - 要返回的边界。 0值不起作用。 负值移动到上一个边界，正值移动到稍后的边界。
        结果
        从当前位置起第n个边界的字符索引，如果达到了第一个或最后一个文本边界， BreakIterator.DONE 。

      • next

        public abstract int next​()
        返回当前边界之后的边界。 如果当前边界是最后一个文本边界，则返回BreakIterator.DONE ，迭代器的当前位置不变。 否则，迭代器的当前位置被设置为当前边界之后的边界。
        结果
        如果当前边界是最后一个文本边界，则下一个文本边界的字符索引为BreakIterator.DONE 。 相当于下一（1）。
        另请参见：
        next(int)

      • previous

        public abstract int previous​()
        返回当前边界之前的边界。 如果当前边界是第一个文本边界，则返回BreakIterator.DONE ，迭代器的当前位置不变。 否则，迭代器的当前位置被设置为当前边界之前的边界。
        结果
        前一个文本边界的字符索引，如果当前边界是第一个文本边界， BreakIterator.DONE 。

      • following

        public abstract int following​(int offset)
        返回指定字符偏移后的第一个边界。 如果指定的偏移量等于最后一个文本边界，则返回BreakIterator.DONE ，迭代器的当前位置不变。 否则，迭代器的当前位置被设置为返回的边界。 返回的值始终大于offset或值BreakIterator.DONE 。
        参数
        offset - 开始扫描的字符偏移量。
        结果
        指定偏移后的第一个边界，如果最后一个文本边界作为偏移传递， BreakIterator.DONE 。
        异常
        IllegalArgumentException - 如果指定的偏移小于第一个文本边界或大于最后一个文本边界。

      • preceding

        public int preceding​(int offset)
        返回指定字符偏移量之前的最后一个边界。 如果指定的偏移量等于第一个文本边界，则返回BreakIterator.DONE ，迭代器的当前位置不变。 否则，迭代器的当前位置被设置为返回的边界。 返回的值始终小于偏移值或值BreakIterator.DONE 。
        参数
        offset - 开始扫描的字符偏移量。
        结果
        指定偏移前的最后一个边界，如果第一个文本边界作为偏移传递， BreakIterator.DONE 。
        异常
        IllegalArgumentException - 如果指定的偏移量小于第一个文本边界或大于最后一个文本边界。
        从以下版本开始：
        1.2

      • isBoundary

        public boolean isBoundary​(int offset)
        如果指定的字符偏移量是文本边界，则返回true。
        参数
        offset - 要检查的字符偏移量。
        结果
        true如果“偏移”是边界位置，否则为 false 。
        异常
        IllegalArgumentException - 如果指定的偏移小于第一个文本边界或大于最后一个文本边界。
        从以下版本开始：
        1.2

      • current

        public abstract int current​()
        返回最近由next（），next（int），previous（），first（），last（），following（int）或previous（int）返回的文本边界的字符索引。 如果这些方法中的任何一个返回BreakIterator.DONE因为已经达到了第一个或最后一个文本边界，则返回第一个或最后一个文本边界，具体取决于到达哪一个。
        结果
        从上述方法返回的文本边界，第一个或最后一个文本边界。
        另请参见：
        next() ，
next(int) ，
previous() ，
first() ，
last() ，
following(int) ，
preceding(int)

      • getText

        public abstract CharacterIterator getText​()
        获取正在扫描的文本
        结果
        正在扫描的文字

      • setText

        public void setText​(String newText)
        设置要扫描的新文本字符串。 当前的扫描位置被重置为first（）。
        参数
        newText - 要扫描的新文本。

      • setText

        public abstract void setText​(CharacterIterator newText)
        设置一个新文本进行扫描。 当前的扫描位置被重置为first（）。
        参数
        newText - 要扫描的新文本。

      • getWordInstance

        public static BreakIterator getWordInstance​()
        为 default locale返回一个新的 BreakIterator实例 word breaks 。
        结果
        一个用于单词的中断迭代器

      • getWordInstance

        public static BreakIterator getWordInstance​(Locale locale)
        为给定的区域设置返回一个新的 BreakIterator实例 word breaks 。
        参数
        locale - 所需的语言环境
        结果
        一个用于单词的中断迭代器
        异常
        NullPointerException - 如果 locale为空

      • getLineInstance

        public static BreakIterator getLineInstance​()
        返回一个新 BreakIterator例如 line breaks为 default locale 。
        结果
        换行符用于换行符

      • getLineInstance

        public static BreakIterator getLineInstance​(Locale locale)
        返回一个新 BreakIterator例如 line breaks给定语言环境。
        参数
        locale - 所需的语言环境
        结果
        换行符用于换行符
        异常
        NullPointerException - 如果 locale为空

      • getCharacterInstance

        public static BreakIterator getCharacterInstance​()
        为 default locale返回一个新的 BreakIterator实例 character breaks 。
        结果
        用于字符中断的中断迭代器

      • getCharacterInstance

        public static BreakIterator getCharacterInstance​(Locale locale)
        为给定的语言环境返回一个新的 BreakIterator实例，用于 character breaks 。
        参数
        locale - 所需的语言环境
        结果
        用于字符中断的中断迭代器
        异常
        NullPointerException - 如果 locale为空

      • getSentenceInstance

        public static BreakIterator getSentenceInstance​()
        为 default locale返回一个新的 BreakIterator实例 sentence breaks 。
        结果
        休假的休息迭代器

      • getSentenceInstance

        public static BreakIterator getSentenceInstance​(Locale locale)
        为给定的语言环境返回一个新的 BreakIterator实例，用于 sentence breaks 。
        参数
        locale - 所需的语言环境
        结果
        休假的休息迭代器
        异常
        NullPointerException - 如果 locale为空

      • getAvailableLocales

        public static Locale[] getAvailableLocales​()
        返回一个所有语言环境的数组， get*Instance方法可以返回本地化实例。 返回的数组表示由Java运行时支持的语言环境和已安装的BreakIteratorProvider实现的联合。 它必须至少包含Locale实例等于Locale.US 。
        结果
        本地化的数组，可用于本地化的 BreakIterator实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


CharacterIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Interface CharacterIterator

  • All Superinterfaces:
    Cloneable
    All Known Subinterfaces:
    AttributedCharacterIterator
    所有已知实现类：
    Segment ， StringCharacterIterator

    public interface CharacterIterator
extends Cloneable
    该接口定义了一种用于文本双向迭代的协议。 迭代器遍历有界的字符序列。 字符的索引值以getBeginIndex（）返回的值开始，并继续执行getEndIndex（） - 1返回的值。

    迭代器保持当前的字符索引，其有效范围是从getBeginIndex（）到getEndIndex（）; 包含值getEndIndex（）以允许处理零长度的文本范围以及出于历史原因。 可以通过调用getIndex（）并通过调用setIndex（），first（）和last（）直接设置当前索引。

    方法previous（）和next（）用于迭代。 如果他们移动到从getBeginIndex（）到getEndIndex（）-1的范围之外，他们返回DONE，表示迭代器已经到达序列的末尾。 DONE也由其他方法返回，以指示当前索引超出此范围。

    例子：

    从头到尾遍历文字

       public void traverseForward(CharacterIterator iter) { for(char c = iter.first(); c != CharacterIterator.DONE; c = iter.next()) { processChar(c); } }
    从头到尾横向移动文字
       public void traverseBackward(CharacterIterator iter) { for(char c = iter.last(); c != CharacterIterator.DONE; c = iter.previous()) { processChar(c); } }
    从文本中的给定位置向前和向后移动。 此示例中对notBoundary（）的调用表示一些其他停止条件。
       public void traverseOut(CharacterIterator iter, int pos) { for (char c = iter.setIndex(pos); c != CharacterIterator.DONE && notBoundary(c); c = iter.next()) { } int end = iter.getIndex(); for (char c = iter.setIndex(pos); c != CharacterIterator.DONE && notBoundary(c); c = iter.previous()) { } int start = iter.getIndex(); processSection(start, end); }
    从以下版本开始：
    1.1
    另请参见：
    StringCharacterIterator ， AttributedCharacterIterator

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static char DONE
      当迭代器到达文本的结尾或开始时返回的常量。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object clone​()
      创建一个这个迭代器的副本
      char current​()
      获取当前位置的字符（由getIndex（）返回）。
      char first​()
      将位置设置为getBeginIndex（），并返回该位置的字符。
      int getBeginIndex​()
      返回文本的起始索引。
      int getEndIndex​()
      返回文本的结束索引。
      int getIndex​()
      返回当前索引。
      char last​()
      将位置设置为getEndIndex（） - 1（如果文本为空，则为getEndIndex（）），并返回该位置处的字符。
      char next​()
      将迭代器的索引增加1，并返回新索引处的字符。
      char previous​()
      将迭代器的索引减1，并返回新索引处的字符。
      char setIndex​(int position)
      将位置设置为文本中的指定位置，并返回该字符。

    • 字段详细信息

      • DONE

        static final char DONE
        当迭代器到达文本的结尾或开始时返回的常量。 值为'\\ uFFFF'，不应该在任何有效的Unicode字符串中出现的“不是字符”值。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • first

        char first​()
        将位置设置为getBeginIndex（），并返回该位置的字符。
        结果
        文本中的第一个字符，如果文本为空，则为DONE
        另请参见：
        getBeginIndex()

      • last

        char last​()
        将位置设置为getEndIndex（） - 1（如果文本为空，则为getEndIndex（）），并返回该位置处的字符。
        结果
        文本中的最后一个字符，如果文本为空，则为DONE
        另请参见：
        getEndIndex()

      • current

        char current​()
        获取当前位置的字符（由getIndex（）返回）。
        结果
        当前位置的字符，如果当前位置离开文本末尾，则为DONE。
        另请参见：
        getIndex()

      • next

        char next​()
        将迭代器的索引增加1，并返回新索引处的字符。 如果生成的索引大于或等于getEndIndex（），则当前索引将重置为getEndIndex（），并返回DONE值。
        结果
        新位置的角色，如果新的位置在文本范围的结尾，则为DONE。

      • previous

        char previous​()
        将迭代器的索引减1，并返回新索引处的字符。 如果当前索引是getBeginIndex（），索引将保留在getBeginIndex（）中，并返回DONE值。
        结果
        当前位置等于getBeginIndex（）时，新位置的角色为DONE。

      • setIndex

        char setIndex​(int position)
        将位置设置为文本中的指定位置，并返回该字符。
        参数
        position - 文本中的位置。 有效值的范围从getBeginIndex（）到getEndIndex（）。 如果提供了无效值，则会抛出IllegalArgumentException异常。
        结果
        指定位置的字符或DONE，如果指定的位置等于getEndIndex（）

      • getBeginIndex

        int getBeginIndex​()
        返回文本的起始索引。
        结果
        文本开始的索引。

      • getEndIndex

        int getEndIndex​()
        返回文本的结束索引。 该索引是文本结束后第一个字符的索引。
        结果
        文本中最后一个字符后的索引

      • getIndex

        int getIndex​()
        返回当前索引。
        结果
        当前指数。

      • clone

        Object clone​()
        创建一个这个迭代器的副本
        结果
        A copy of this
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ChoiceFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class ChoiceFormat

  • java.lang.Object
    • java.text.Format
      • java.text.NumberFormat
        • java.text.ChoiceFormat
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class ChoiceFormat
extends NumberFormat
    A ChoiceFormat允许您将格式附加到一系列数字。 它通常用于处理复数的MessageFormat中。 该选项用升序列表双精度指定，其中每个项目指定直到下一个项目的半开间隔：
     X matches j if and only if limit[j] ≤ X < limit[j+1]
    如果没有匹配，则使用第一个或最后一个索引，这取决于数字（X）是否太低或太高。 如果限制数组不是按升序排列，格式化结果将不正确。 ChoiceFormat也接受\u221E等效于无限远（INF）。

    注意： ChoiceFormat与其他Format类别不同之处在于您使用构造函数（不是使用getInstance样式工厂方法）创建一个ChoiceFormat对象。 工厂方法不是必需的，因为ChoiceFormat不需要为给定的区域设置任何复杂的设置。 实际上， ChoiceFormat没有实现任何区域设置的具体行为。

    创建ChoiceFormat ，必须指定格式数组和限制数组。 这些数组的长度必须相同。 例如，

    • 极限 = {1,2,3,4,5,6,7}
      格式 = {“太阳”，“星期一”，“星期二”，“星期三”，“星期三”，“星期五”，“星期六”
    • limits = {0，1，ChoiceFormat.nextDouble（1）}
      formats = {“no files”，“one file”，“many files”}
      （ nextDouble可以用来获得下一个更高的双倍，使半开间隔。）

    以下是一个简单的示例，显示格式和解析：

 double[] limits = {1,2,3,4,5,6,7};
 String[] dayOfWeekNames = {"Sun","Mon","Tue","Wed","Thur","Fri","Sat"};
 ChoiceFormat form = new ChoiceFormat(limits, dayOfWeekNames);
 ParsePosition status = new ParsePosition(0);
 for (double i = 0.0; i <= 8.0; ++i) {
     status.setIndex(0);
     System.out.println(i + " -> " + form.format(i) + " -> "
                              + form.parse(form.format(i),status));
 }
    这是一个更复杂的例子，具有格式格式：

 double[] filelimits = {0,1,2};
 String[] filepart = {"are no files","is one file","are {2} files"};
 ChoiceFormat fileform = new ChoiceFormat(filelimits, filepart);
 Format[] testFormats = {fileform, null, NumberFormat.getInstance()};
 MessageFormat pattform = new MessageFormat("There {0} on {1}");
 pattform.setFormats(testFormats);
 Object[] testArgs = {null, "ADisk", null};
 for (int i = 0; i < 4; ++i) {
     testArgs[0] = new Integer(i);
     testArgs[2] = testArgs[0];
     System.out.println(pattform.format(testArgs));
 }

    为ChoiceFormat对象指定模式是相当简单的。 例如：

 ChoiceFormat fmt = new ChoiceFormat(
      "-1#is negative| 0#is zero or fraction | 1#is one |1.0<is 1+ |2#is two |2<is more than 2.");
 System.out.println("Formatter Pattern : " + fmt.toPattern());

 System.out.println("Format with -INF : " + fmt.format(Double.NEGATIVE_INFINITY));
 System.out.println("Format with -1.0 : " + fmt.format(-1.0));
 System.out.println("Format with 0 : " + fmt.format(0));
 System.out.println("Format with 0.9 : " + fmt.format(0.9));
 System.out.println("Format with 1.0 : " + fmt.format(1));
 System.out.println("Format with 1.5 : " + fmt.format(1.5));
 System.out.println("Format with 2 : " + fmt.format(2));
 System.out.println("Format with 2.1 : " + fmt.format(2.1));
 System.out.println("Format with NaN : " + fmt.format(Double.NaN));
 System.out.println("Format with +INF : " + fmt.format(Double.POSITIVE_INFINITY));
    输出结果如下：

 Format with -INF : is negative
 Format with -1.0 : is negative
 Format with 0 : is zero or fraction
 Format with 0.9 : is zero or fraction
 Format with 1.0 : is one
 Format with 1.5 : is 1+
 Format with 2 : is two
 Format with 2.1 : is more than 2.
 Format with NaN : is negative
 Format with +INF : is more than 2.

    Synchronization

    选择格式不同步。 建议为每个线程创建单独的格式实例。 如果多个线程同时访问格式，则必须在外部进行同步。

    从以下版本开始：
    1.1
    另请参见：
    DecimalFormat ， MessageFormat ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.text.NumberFormat

        NumberFormat.Field

    • Field Summary

      • Fields inherited from class java.text.NumberFormat

        FRACTION_FIELD, INTEGER_FIELD

    • 构造方法摘要

      构造方法
      Constructor 描述
      ChoiceFormat​(double[] limits, String[] formats)
      具有限制和相应格式的构造。
      ChoiceFormat​(String newPattern)
      基于模式的限制和相应格式的构造。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyPattern​(String newPattern)
      设置模式。
      Object clone​()
      覆盖可克隆
      boolean equals​(Object obj)
      两者之间的平等比较
      StringBuffer format​(double number, StringBuffer toAppendTo, FieldPosition status)
      返回格式为double的模式。
      StringBuffer format​(long number, StringBuffer toAppendTo, FieldPosition status)
      专业化格式。
      Object[] getFormats​()
      获取在构造函数中传递的格式。
      double[] getLimits​()
      获取构造函数中传递的限制。
      int hashCode​()
      生成消息格式对象的哈希码。
      static double nextDouble​(double d)
      找到的 d大于 d 。
      static double nextDouble​(double d, boolean positive)
      发现最小双数大于 d （如果 positive为 true ），或最大双倍小于 d （如果 positive为 false ）。
      Number parse​(String text, ParsePosition status)
      从输入文本中解析一个数字。
      static double previousDouble​(double d)
      发现最大的双倍小于 d 。
      void setChoices​(double[] limits, String[] formats)
      设置要在格式化中使用的选项。
      String toPattern​()
      获得模式。

      • Methods inherited from class java.text.Format

        format, formatToCharacterIterator, parseObject

      • Methods inherited from class java.text.NumberFormat

        format, format, format, getAvailableLocales, getCurrency, getCurrencyInstance, getCurrencyInstance, getInstance, getInstance, getIntegerInstance, getIntegerInstance, getMaximumFractionDigits, getMaximumIntegerDigits, getMinimumFractionDigits, getMinimumIntegerDigits, getNumberInstance, getNumberInstance, getPercentInstance, getPercentInstance, getRoundingMode, isGroupingUsed, isParseIntegerOnly, parse, parseObject, setCurrency, setGroupingUsed, setMaximumFractionDigits, setMaximumIntegerDigits, setMinimumFractionDigits, setMinimumIntegerDigits, setParseIntegerOnly, setRoundingMode

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ChoiceFormat

        public ChoiceFormat​(String newPattern)
        基于模式的限制和相应格式的构造。
        参数
        newPattern - 新的模式字符串
        异常
        NullPointerExcpetion - 如果 newPattern是 null
        另请参见：
        applyPattern(java.lang.String)

      • ChoiceFormat

        public ChoiceFormat​(double[] limits,
                    String[] formats)
        具有限制和相应格式的构造。
        参数
        limits - 升序限制
        formats - 相应的格式字符串
        异常
        NullPointerException -如果 limits或者 formats为 null
        另请参见：
        setChoices(double[], java.lang.String[])

    • 方法详细信息

      • applyPattern

        public void applyPattern​(String newPattern)
        设置模式。
        参数
        newPattern - 查看课程说明。
        异常
        NullPointerException - 如果 newPattern是 null

      • toPattern

        public String toPattern​()
        获得模式。
        结果
        模式字符串

      • setChoices

        public void setChoices​(double[] limits,
                       String[] formats)
        设置要在格式化中使用的选项。
        参数
        limits - 包含您要使用该格式解析的顶级值，并应按升序排序。 当格式化X时，选择将是i，其中limit [i]¤X <limit [i + 1]。 如果限制数组不是按升序排列，格式化结果将不正确。
        formats - 是您要为每个限制使用的格式。 它们可以是格式对象或字符串。 当使用对象Y进行格式化时，如果对象是NumberFormat，则调用（（NumberFormat）Y）.format（X）。 否则调用Y.toString（）。
        异常
        NullPointerException - 如果是 limits或 formats是 null

      • getLimits

        public double[] getLimits​()
        获取构造函数中传递的限制。
        结果
        极限。

      • getFormats

        public Object[] getFormats​()
        获取在构造函数中传递的格式。
        结果
        格式。

      • format

        public StringBuffer format​(long number,
                           StringBuffer toAppendTo,
                           FieldPosition status)
        专业化格式。 该方法真的调用format(double, StringBuffer, FieldPosition)因此所支持的longs的范围只等于可以通过double存储的范围。 这绝对不是实际的限制。
        Specified by:
        format中的 NumberFormat
        参数
        number - 长数字格式
        toAppendTo - 要附加格式化文本的StringBuffer
        status - 字段位置
        结果
        格式化的StringBuffer
        另请参见：
        Format.format(java.lang.Object)

      • format

        public StringBuffer format​(double number,
                           StringBuffer toAppendTo,
                           FieldPosition status)
        返回格式为double的模式。
        Specified by:
        format在 NumberFormat
        参数
        number - 要格式化和替换的数字。
        toAppendTo - 附加文本。
        status - 忽略没有返回有用的状态。
        结果
        格式化的StringBuffer
        异常
        NullPointerException - 如果 toAppendTo是 null
        另请参见：
        Format.format(java.lang.Object)

      • parse

        public Number parse​(String text,
                    ParsePosition status)
        从输入文本中解析一个数字。
        Specified by:
        parse在 NumberFormat
        参数
        text - 源文本。
        status - 输入 - 输出参数。 在输入上，status.index字段指示应解析的源文本的第一个字符。 退出时，如果没有发生错误，则将status.index设置为源文本中的第一个未解析的字符。 退出时，如果发生错误，则status.index不变，并将status.errorIndex设置为导致解析失败的字符的第一个索引。
        结果
        一个表示解析数值的数字。
        异常
        NullPointerException - 如果 status为 null或 text为 null ，选择字符串列表不为空。
        另请参见：
        NumberFormat.isParseIntegerOnly() ， Format.parseObject(java.lang.String, java.text.ParsePosition)

      • nextDouble

        public static final double nextDouble​(double d)
        找到的最小双数大于d 。 如果是NaN ，返回相同的值。

        用于制作半开间隔。

        参数
        d - 参考值
        结果
        最小双重值超过 d
        另请参见：
        previousDouble(double)

      • previousDouble

        public static final double previousDouble​(double d)
        发现最大的双倍小于d 。 如果是NaN ，返回相同的值。
        参数
        d - 参考值
        结果
        最大双倍值小于 d
        另请参见：
        nextDouble(double)

      • clone

        public Object clone​()
        覆盖可克隆
        重写：
        clone在 NumberFormat
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • hashCode

        public int hashCode​()
        生成消息格式对象的哈希码。
        重写：
        hashCode在 NumberFormat
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        两者之间的平等比较
        重写：
        equals在类 NumberFormat
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • nextDouble

        public static double nextDouble​(double d,
                                boolean positive)
        发现最少的双倍大于d （如果positive是true ），或最大的双倍小于d （如果positive是false ）。 如果是NaN ，返回相同的值。 不影响浮点标志，只要这些成员函数不会：Double.longBitsToDouble（long）Double.doubleToLongBits（double）Double.isNaN（double）
        参数
        d - 参考值
        positive - true如果需要最小双倍; 否则为false
        结果
        最小或更大的双重值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CollationElementIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class CollationElementIterator

  • java.lang.Object
    • java.text.CollationElementIterator

  • public final class CollationElementIterator
extends Object
    CollationElementIterator类用作遍历国际字符串的每个字符的迭代器。 使用迭代器返回定位字符的排序优先级。 字符的排序优先级，我们将其称为键，定义了字符在给定的排序规则对象中的整理方式。

    例如，考虑以下西班牙语：

     "ca" → the first key is key('c') and second key is key('a').
 "cha" → the first key is key('ch') and second key is key('a').
    在德国，
     "�b" → the first key is key('a'), the second key is key('e'), and
 the third key is key('b').
    一个字符的键是一个整数，由一个小阶（short），二次（byte）和三阶（byte）组成。 Java严格定义了其原始数据类型的大小和签名。 因此，静态函数primaryOrder ， secondaryOrder ，并tertiaryOrder回报int ， short ，并short分别以确保密钥值的正确性。

    迭代器使用示例，

  String testString = "This is a test";
  Collator col = Collator.getInstance();
  if (col instanceof RuleBasedCollator) {
      RuleBasedCollator ruleBasedCollator = (RuleBasedCollator)col;
      CollationElementIterator collationElementIterator = ruleBasedCollator.getCollationElementIterator(testString);
      int primaryOrder = CollationElementIterator.primaryOrder(collationElementIterator.next());
          :
  }

    CollationElementIterator.next返回下一个字符的排序规则顺序。 整理订单由一级订单，二级订单和三级订单组成。 归类顺序的数据类型为int 。 排序顺序的前16位是其主要顺序; 接下来的8位是次级，最后8位是第三级。

    注意： CollationElementIterator是RuleBasedCollator实现的一部分。 它仅适用于RuleBasedCollator实例。

    从以下版本开始：
    1.1
    另请参见：
    Collator ， RuleBasedCollator

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int NULLORDER
      指示字符串结束的空白顺序由光标到达。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getMaxExpansion​(int order)
      返回以指定的比较顺序结束的任何扩展序列的最大长度。
      int getOffset​()
      返回与下一个排序规则元素对应的原始文本中的字符偏移量。
      int next​()
      获取字符串中的下一个排序规则元素。
      int previous​()
      获取字符串中的以前的排序规则元素。
      static int primaryOrder​(int order)
      返回排序规则元素的主要组件。
      void reset​()
      将光标重置为字符串的开头。
      static short secondaryOrder​(int order)
      返回排序规则元素的次要组件。
      void setOffset​(int newOffset)
      将迭代器设置为指向与指定字符对应的排序规则元素（参数是原始字符串中的CHARACTER偏移量，而不是其对应的排序规则元素序列中的偏移量）。
      void setText​(String source)
      设置要迭代的新字符串。
      void setText​(CharacterIterator source)
      设置要迭代的新字符串。
      static short tertiaryOrder​(int order)
      返回排序规则元素的三级分量。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NULLORDER

        public static final int NULLORDER
        指示字符串结束的空白顺序由光标到达。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • reset

        public void reset​()
        将光标重置为字符串的开头。 next（）的下一个调用将返回字符串中的第一个排序规则元素。

      • next

        public int next​()
        获取字符串中的下一个排序规则元素。

        该迭代器遍历从字符串构建的一系列排序规则元素。 因为没有必要从字符到排序规则元素的一对一映射，这并不意味着与“返回字符串中下一个字符的排序规则元素[或排序优先级]”相同。

        此函数返回迭代器当前指向的排序规则元素，然后更新内部指针以指向下一个元素。 previous（）首先更新指针，然后返回该元素。 这意味着当您在迭代时更改方向（即，调用next（），然后调用previous（）或调用previous（）然后调用next（）），您将返回相同的元素两次。

        结果
        下一个排序规则元素

      • previous

        public int previous​()
        获取字符串中的以前的排序规则元素。

        该迭代器遍历从字符串构建的一系列排序规则元素。 因为没有必要从字符到排序规则元素的一对一映射，这并不意味着与“返回字符串中前一个字符的排序规则元素[或排序优先级]”相同。

        此函数将迭代器的内部指针更新为指向当前指向的collation元素，然后返回该元素，而next（）返回当前元素，然后更新指针。 这意味着当您在迭代时更改方向（即，调用next（），然后调用previous（）或调用previous（）然后调用next（）），您将返回相同的元素两次。

        结果
        以前的排序规则元素
        从以下版本开始：
        1.2

      • primaryOrder

        public static final int primaryOrder​(int order)
        返回排序规则元素的主要组件。
        参数
        order - 排序规则元素
        结果
        元素的主要组成部分

      • secondaryOrder

        public static final short secondaryOrder​(int order)
        返回排序规则元素的次要组件。
        参数
        order - 排序规则元素
        结果
        元素的次要组件

      • tertiaryOrder

        public static final short tertiaryOrder​(int order)
        返回排序规则元素的三级分量。
        参数
        order - 排序规则元素
        结果
        元素的第三部分

      • setOffset

        public void setOffset​(int newOffset)
        将迭代器设置为指向与指定字符对应的排序规则元素（参数是原始字符串中的CHARACTER偏移量，而不是其对应的排序规则元素序列中的偏移量）。 下一次调用next（）返回的值将是对应于文本中指定位置的排序规则元素。 如果该位置在合约字符序列的中间，下一次调用next（）的结果是该序列的排序规则元素。 这意味着getOffset（）不能保证返回与传递给setOffset（）的前一个调用相同的值。
        参数
        newOffset - 新的字符偏移到原始文本。
        从以下版本开始：
        1.2

      • getOffset

        public int getOffset​()
        返回与下一个排序规则元素对应的原始文本中的字符偏移量。 （也就是说，getOffset（）返回与下一次调用next（）返回的排序规则元素对应的文本中的位置）。该值将始终是对应于排序规则元素的第一个字符的索引（a当两个或更多个字符都对应于相同的排序规则元素时，收缩字符序列）。 这意味着如果您立即通过getOffset（）执行setOffset（x），getOffset（）将不一定返回x。
        结果
        对应于下一次调用next（）返回的排序规则元素的原始文本中的字符偏移量。
        从以下版本开始：
        1.2

      • getMaxExpansion

        public int getMaxExpansion​(int order)
        返回以指定的比较顺序结束的任何扩展序列的最大长度。
        参数
        order - 上一个或下一个返回的归类顺序。
        结果
        以指定顺序结束的任何扩展序列的最大长度。
        从以下版本开始：
        1.2

      • setText

        public void setText​(String source)
        设置要迭代的新字符串。
        参数
        source - 新的源文本
        从以下版本开始：
        1.2

      • setText

        public void setText​(CharacterIterator source)
        设置要迭代的新字符串。
        参数
        source - 新的源文本。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


CollationKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class CollationKey

  • java.lang.Object
    • java.text.CollationKey
  • All Implemented Interfaces:
    Comparable<CollationKey>

    public abstract class CollationKey
extends Object
implements Comparable<CollationKey>
    A CollationKey代表一个String根据一个特定的Collator对象的规则。 比较两个CollationKey s返回其代表的String的相对顺序。 使用CollationKey比较String s通常比使用Collator.compare快。 因此，当String必须多次比较时，例如当排序String的列表时。 使用CollationKey s更有效率。

    您不能直接创建CollationKey 。 而是通过调用Collator.getCollationKey生成它们。 只能比较CollationKey来自同一生成S- Collator对象。

    为CollationKey生成String涉及检查整个String并将其转换为可以按位比较的一系列位。 一旦生成密钥，就可以快速比较。 在String需要进行多次比较时，生成键的成本将以较快的比较进行String 。 另一方面，比较的结果通常由每个String的前几个字符String 。 Collator.compare只检查所需的字符数量，使其在进行单次比较时更快。

    以下示例显示如何使用CollationKey来对String的列表进行排序。

 // Create an array of CollationKeys for the Strings to be sorted.
 Collator myCollator = Collator.getInstance();
 CollationKey[] keys = new CollationKey[3];
 keys[0] = myCollator.getCollationKey("Tom");
 keys[1] = myCollator.getCollationKey("Dick");
 keys[2] = myCollator.getCollationKey("Harry");
 sort(keys);

 //...

 // Inside body of sort routine, compare keys this way
 if (keys[i].compareTo(keys[j]) > 0)
    // swap keys[i] and keys[j]

 //...

 // Finally, when we've returned from sort.
 System.out.println(keys[0].getSourceString());
 System.out.println(keys[1].getSourceString());
 System.out.println(keys[2].getSourceString());
    从以下版本开始：
    1.1
    另请参见：
    Collator ， RuleBasedCollator

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CollationKey​(String source)
      CollationKey构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract int compareTo​(CollationKey target)
      将此CollationKey与目标CollationKey进行比较。
      String getSourceString​()
      返回此CollationKey表示的String。
      abstract byte[] toByteArray​()
      将CollationKey转换为位序列。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CollationKey

        protected CollationKey​(String source)
        CollationKey构造函数。
        参数
        source - 源字符串
        异常
        NullPointerException - 如果 source为空
        从以下版本开始：
        1.6

    • 方法详细信息

      • compareTo

        public abstract int compareTo​(CollationKey target)
        将此CollationKey与目标CollationKey进行比较。 应用了创建这些键的Collator对象的排序规则。 注意：由不同Collator创建的CollationKeys无法比较。
        Specified by:
        compareTo在接口 Comparable<CollationKey>
        参数
        target - 目标CollationKey
        结果
        返回一个整数值。 如果该值小于目标值，则该值小于零，如果此值和目标值相等，则值为零，如果该值大于目标值，则值大于零。
        另请参见：
        Collator.compare(java.lang.String, java.lang.String)

      • getSourceString

        public String getSourceString​()
        返回此CollationKey表示的String。
        结果
        这个CollationKey的源字符串

      • toByteArray

        public abstract byte[] toByteArray​()
        将CollationKey转换为位序列。 如果两个CollationKey可以合法比较，那么可以比较每个这些密钥的字节数组，以获得相同的结果。 字节数组首先被组织成最高有效字节。
        结果
        CollationKey的字节数组表示
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Collator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class Collator

  • java.lang.Object
    • java.text.Collator
  • All Implemented Interfaces:
    Cloneable ， Comparator<Object>
    已知直接子类：
    RuleBasedCollator

    public abstract class Collator
extends Object
implements Comparator<Object>, Cloneable
    Collator类执行区域设置敏感String比较。 您使用此类来构建自然语言文本的搜索和排序例程。

    Collator是一个抽象的基类。 子类实现特定的整理策略。 一个子类， RuleBasedCollator ，目前提供了Java平台，适用于广泛的语言。 可以创建其他子类来处理更专门的需求。

    像其他语言环境敏感类，你可以使用静态工厂方法， getInstance ，以获得适当Collator对象为给定的语言环境。 您只需要查看Collator的子类，如果您需要了解特定整理策略的详细信息，或者您需要修改该策略。

    以下示例显示了如何使用默认语言环境的Collator来比较两个字符串。

 // Compare two strings in the default locale
 Collator myCollator = Collator.getInstance();
 if( myCollator.compare("abc", "ABC") < 0 )
     System.out.println("abc is less than ABC");
 else
     System.out.println("abc is greater than or equal to ABC");

    您可以设置一个Collator的强度属性来确定在比较中被认为是重要的差异水平。 提供四个优势： PRIMARY ， SECONDARY ， TERTIARY ，并IDENTICAL 。 对语言特征的优势的确切分配取决于区域设置。 例如，在捷克语中，“e”和“f”被认为是主要差异，而“e”和“Ä”是次要差异，“e”和“E”是三级差异，“e”和“e”相同。 以下显示了美国英语的情况和口音如何被忽略。

     //Get the Collator for US English and set its strength to PRIMARY
 Collator usCollator = Collator.getInstance(Locale.US);
 usCollator.setStrength(Collator.PRIMARY);
 if( usCollator.compare("abc", "ABC") == 0 ) {
     System.out.println("Strings are equivalent");
 }

    为了比较String一次， compare方法提供最佳性能。 然而，当排序String的列表时，通常需要多次比较每个String 。 在这种情况下， CollationKey提供更好的性能。 所述CollationKey类转换String到一系列可以按位与其他进行比较的比特CollationKey秒。 A CollationKey由Collator对象为给定的String 。
    注意： CollationKey从不同的Collator s不能比较。 请参阅类描述CollationKey用于使用例如CollationKey秒。

    从以下版本开始：
    1.1
    另请参见：
    RuleBasedCollator ， CollationKey ， CollationElementIterator ， Locale

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CANONICAL_DECOMPOSITION
      分解模式值。
      static int FULL_DECOMPOSITION
      分解模式值。
      static int IDENTICAL
      整理器强度值。
      static int NO_DECOMPOSITION
      分解模式值。
      static int PRIMARY
      整理器强度值。
      static int SECONDARY
      整理器强度值。
      static int TERTIARY
      整理器强度值。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Collator​()
      默认构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      覆盖可克隆
      int compare​(Object o1, Object o2)
      比较其两个参数的顺序。
      abstract int compare​(String source, String target)
      根据此Collator的排序规则将源字符串与目标字符串进行比较。
      boolean equals​(Object that)
      比较两个Collator的平等。
      boolean equals​(String source, String target)
      基于此Collator的排序规则比较两个字符串的相等性的便利方法。
      static Locale[] getAvailableLocales​()
      返回一个所有语言环境的数组，该类的 getInstance方法可以返回本地化实例。
      abstract CollationKey getCollationKey​(String source)
      将String转换成可以与其他CollationKeys进行比较的一系列位。
      int getDecomposition​()
      获取此Collator的分解模式。
      static Collator getInstance​()
      获取当前默认语言环境的Collator。
      static Collator getInstance​(Locale desiredLocale)
      获取所需语言环境的Collator。
      int getStrength​()
      返回此Collator的强度属性。
      abstract int hashCode​()
      生成此Collator的哈希码。
      void setDecomposition​(int decompositionMode)
      设置此Collator的分解模式。
      void setStrength​(int newStrength)
      设置此Collator的强度属性。

      • Methods inherited from interface java.util.Comparator

        comparing, comparing, comparingDouble, comparingInt, comparingLong, naturalOrder, nullsFirst, nullsLast, reversed, reverseOrder, thenComparing, thenComparing, thenComparing, thenComparingDouble, thenComparingInt, thenComparingLong

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • PRIMARY

        public static final int PRIMARY
        整理器强度值。 当设定时，在比较期间只有PRIMARY差异被认为是重要的。 对语言特征的优势分配取决于区域设置。 一个常见的例子是将不同的基本字母（“a”对“b”）视为主要差异。
        另请参见：
        setStrength(int) ， getStrength() ， Constant Field Values

      • SECONDARY

        public static final int SECONDARY
        整理器强度值。 当设定时，在比较期间只有第二和以上的差异被认为是重要的。 对语言特征的优势分配取决于区域设置。 一个常见的例子是同一个基本字母（“a”vs“ï”）的不同重音形式被认为是第二个差异。
        另请参见：
        setStrength(int) ， getStrength() ， Constant Field Values

      • TERTIARY

        public static final int TERTIARY
        整理器强度值。 设定时，在比较期间，只有TERTIARY及以上差异被认为是重要的。 对语言特征的优势分配取决于区域设置。 一个常见的例子是病例差异（“a”vs“A”）被认为是TERTIARY差异。
        另请参见：
        setStrength(int) ， getStrength() ， Constant Field Values

      • IDENTICAL

        public static final int IDENTICAL
        整理器强度值。 设定时，所有差异在比较期间都被认为是显着的。 对语言特征的优势分配取决于区域设置。 一个常见的例子是控制字符（“\ u0001”vs“\ u0002”）在PRIMARY，SECONDARY和TERTIARY级别被认为是相等的，但在IDENTICAL级别不同。 此外，如果分解设置为NO_DECOMPOSITION，则在“ENC”（A-grave）和“A \ u0300”（A，combine-grave）之间的预先组合的重音符之间的区别将在IDENTICAL级别被认为是重要的。
        另请参见：
        Constant Field Values

      • NO_DECOMPOSITION

        public static final int NO_DECOMPOSITION
        分解模式值。 设置NO_DECOMPOSITION时，重音字符不会被分解以进行归类。 这是默认设置，并提供最快的排序规则，但只会为不使用重音的语言产生正确的结果。
        另请参见：
        getDecomposition() ， setDecomposition(int) ， Constant Field Values

      • CANONICAL_DECOMPOSITION

        public static final int CANONICAL_DECOMPOSITION
        分解模式值。 使用CANONICAL_DECOMPOSITION设置，根据Unicode标准的规范变体的字符将被分解以进行归类。 这应该被用来获得正确的重音符号排序。

        CANONICAL_DECOMPOSITION对应于标准化形式D，如Unicode Technical Report #15所述 。

        另请参见：
        getDecomposition() ， setDecomposition(int) ， Constant Field Values

      • FULL_DECOMPOSITION

        public static final int FULL_DECOMPOSITION
        分解模式值。 使用FULL_DECOMPOSITION设置，Unicode规范变体和Unicode兼容性变体将被分解以进行归类。 这不仅引起重音字符的整理，而且还会使具有特殊格式的字符与其正常形式进行整理。 例如，半宽和全角ASCII和片假名字符然后整理在一起。 FULL_DECOMPOSITION是最完整的，因此是最慢的分解模式。

        FULL_DECOMPOSITION对应于规范化形式KD，如Unicode Technical Report #15所述 。

        另请参见：
        getDecomposition() ， setDecomposition(int) ， Constant Field Values

    • 构造方法详细信息

      • Collator

        protected Collator​()
        默认构造函数。 这个构造函数是受保护的，所以子类可以访问它。 用户通常通过调用出厂方法getInstance来创建一个Collator子类。
        另请参见：
        getInstance()

    • 方法详细信息

      • getInstance

        public static Collator getInstance​()
        获取当前默认语言环境的Collator。 默认语言环境由java.util.Locale.getDefault确定。
        结果
        默认语言环境的Collator（例如en_US）
        另请参见：
        Locale.getDefault()

      • getInstance

        public static Collator getInstance​(Locale desiredLocale)
        获取所需语言环境的Collator。
        参数
        desiredLocale - 所需的语言环境。
        结果
        对于所需语言环境的Collator。
        另请参见：
        Locale ， ResourceBundle

      • compare

        public abstract int compare​(String source,
                            String target)
        根据此Collator的排序规则将源字符串与目标字符串进行比较。 根据源字符串是否小于等于或大于目标字符串，返回小于等于或大于零的整数。 有关使用示例，请参阅Collator类描述。

        对于一次比较，该方法具有最佳性能。 如果给定的String参与多个比较，CollationKey.compareTo具有最佳性能。 有关使用CollationKeys的示例，请参阅Collator类描述。

        参数
        source - 源字符串。
        target - 目标字符串。
        结果
        返回一个整数值。 如果源小于目标值，则值小于零，如果源和目标相等，则值为零，如果源大于目标值，则值大于零。
        另请参见：
        CollationKey ， getCollationKey(java.lang.String)

      • compare

        public int compare​(Object o1,
                   Object o2)
        比较其两个参数的顺序。 返回负整数，零或正整数，因为第一个参数小于，等于或大于第二个参数。

        此实现只返回compare((String)o1, (String)o2) 。

        Specified by:
        compare在接口 Comparator<Object>
        参数
        o1 - 要比较的第一个对象。
        o2 - 要比较的第二个对象。
        结果
        第一个参数的负整数，零或正整数小于等于或大于第二个参数。
        异常
        ClassCastException - 参数不能转换为字符串。
        从以下版本开始：
        1.2
        另请参见：
        Comparator

      • getCollationKey

        public abstract CollationKey getCollationKey​(String source)
        将String转换成可以与其他CollationKeys进行比较的一系列位。 当Strings涉及多个比较时，CollationKeys提供比Collator.compare更好的性能。 有关使用CollationKeys的示例，请参阅Collator类描述。
        参数
        source - 要转换为归类密钥的字符串。
        结果
        基于此Collator的排序规则的给定String的CollationKey。 如果源String为null，则返回一个空CollationKey。
        另请参见：
        CollationKey ， compare(java.lang.String, java.lang.String)

      • equals

        public boolean equals​(String source,
                      String target)
        基于此Collator的排序规则比较两个字符串的相等性的便利方法。
        参数
        source - 要比较的源字符串。
        target - 要比较的目标字符串。
        结果
        如果字符串根据排序规则规则相等，则为true。 假，否则。
        另请参见：
        compare(java.lang.String, java.lang.String)

      • getStrength

        public int getStrength​()
        返回此Collator的强度属性。 强度属性确定在比较期间被认为是显着的最小差异水平。 有关使用示例，请参阅Collator类描述。
        结果
        此Collator目前的实力财产。
        另请参见：
        setStrength(int) ， PRIMARY ， SECONDARY ， TERTIARY ， IDENTICAL

      • setStrength

        public void setStrength​(int newStrength)
        设置此Collator的强度属性。 强度属性确定在比较期间被认为是显着的最小差异水平。 有关使用示例，请参阅Collator类描述。
        参数
        newStrength - 新的实力值。
        异常
        IllegalArgumentException - 如果新的实力值不是PRIMARY，SECONDARY，TERTIARY或IDENTICAL之一。
        另请参见：
        getStrength() ， PRIMARY ， SECONDARY ， TERTIARY ， IDENTICAL

      • getDecomposition

        public int getDecomposition​()
        获取此Collator的分解模式。 分解模式决定如何处理Unicode组合字符。 调整分解模式允许用户在更快更完整的排序规则行为之间进行选择。

        分解模式的三个值为：

        • NO_DECOMPOSITION，
        • CANONICAL_DECOMPOSITION
        • FULL_DECOMPOSITION。
        有关这些三个常数的说明，请参阅文档。
        结果
        分解模式
        另请参见：
        setDecomposition(int) ， NO_DECOMPOSITION ， CANONICAL_DECOMPOSITION ， FULL_DECOMPOSITION

      • setDecomposition

        public void setDecomposition​(int decompositionMode)
        设置此Collator的分解模式。 有关分解模式的描述，请参阅getDecomposition。
        参数
        decompositionMode - 新的分解模式。
        异常
        IllegalArgumentException - 如果给定的值不是有效的分解模式。
        另请参见：
        getDecomposition() ， NO_DECOMPOSITION ， CANONICAL_DECOMPOSITION ， FULL_DECOMPOSITION

      • getAvailableLocales

        public static Locale[] getAvailableLocales​()
        返回所有语言环境的数组， getInstance方法可以返回本地化实例。 返回的数组表示由Java运行时支持的语言环境和已安装的CollatorProvider实现的联合。 它必须至少包含一个等于Locale.US的Locale实例。
        结果
        一组本地化的本地化的 Collator实例可用。

      • clone

        public Object clone​()
        覆盖可克隆
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • equals

        public boolean equals​(Object that)
        比较两个Collator的平等。
        Specified by:
        equals在接口 Comparator<Object>
        重写：
        equals中的 Object
        参数
        that - 与此进行比较的Collator。
        结果
        如果此Collator与Collator相同，则为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public abstract int hashCode​()
        生成此Collator的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DateFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class DateFormat

  • java.lang.Object
    • java.text.Format
      • java.text.DateFormat
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    SimpleDateFormat

    public abstract class DateFormat
extends Format
    DateFormat是一个用于日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。 日期/时间格式化子类（如SimpleDateFormat ）允许格式化（即日期文本），解析（文本日期）和归一化。 该日期表示为Date对象，或自1970年1月1日00:00:00 GMT以来的毫秒。

    DateFormat提供了许多类方法，用于根据默认或给定的区域设置和多个格式化样式获取默认的日期/时间格式化程序。 格式化风格包括FULL ， LONG ， MEDIUM ，并SHORT 。 方法说明中提供了更多细节和使用这些样式的示例。

    DateFormat可以帮助您格式化和解析任何区域设置的日期。 您的代码可以完全独立于几个月，几个星期甚至日历格式的区域设置约定：月球与太阳能。

    要格式化当前区域设置的日期，请使用静态工厂方法之一：

 myString = DateFormat.getDateInstance().format(myDate);

    如果要格式化多个日期，更多的是获取格式并多次使用它，以便系统不必多次获取有关本地语言和国家/地区约定的信息。

 DateFormat df = DateFormat.getDateInstance();
 for (int i = 0; i < myDate.length; ++i) {
     output.println(df.format(myDate[i]) + "; ");
 }

    要格式化不同语言环境的日期，请在调用getDateInstance()中指定。

 DateFormat df = DateFormat.getDateInstance(DateFormat.LONG, Locale.FRANCE);

    您也可以使用DateFormat进行解析。

 myDate = df.parse(myString);

    使用getDateInstance获取该国家的正常日期格式。 还有其他静态工厂方法可用。 使用getTimeInstance获取该国家的时间格式。 使用getDateTimeInstance获取日期和时间格式。 您可以将不同的选项传递给这些工厂方法来控制结果的长度; 从SHORT到MEDIUM到LONG到FULL 。 确切的结果取决于语言环境，但通常是：

    • SHORT是完全数字的，如12.13.52或3:30pm
    • MEDIUM较长，如Jan 12, 1952
    • LONG较长，如January 12, 1952或3:30:32pm
    • FULL是完全指定的，如Tuesday, April 12, 1952 AD or 3:30:42pm PST 。

    您也可以根据需要设置格式的时区。 如果你想在格式或分析更精确的控制，（或者希望给用户更多的控制），可以尝试铸造DateFormat你从工厂方法到获得SimpleDateFormat 。 这将适用于大多数国家; 只要记住把它放在一个try块，以防万一遇到一个不寻常的块。

    您也可以使用ParsePosition和FieldPosition的解析和格式方法表单 ，让您

    • 逐渐解析一串字符串。
    • 对齐任何特定的字段，或找出它在屏幕上的选择。

    Synchronization

    日期格式不同步。 建议为每个线程创建单独的格式实例。 如果多个线程同时访问格式，则必须在外部进行同步。

    实现要求：
    • format(Date, StringBuffer, FieldPosition)和parse(String, ParsePosition)方法可能会抛出NullPointerException ，如果其参数是null 。 子类可以提供自己的实现和规范约NullPointerException 。
    • 该setCalendar(Calendar) ， setNumberFormat(NumberFormat)和setTimeZone(TimeZone)方法不抛出NullPointerException当他们的参数是null ，但在相同的情况下任何后续操作可以抛出NullPointerException 。
    • 的getCalendar() ， getNumberFormat()和getTimeZone()方法可以返回null ，如果此实例的相应值被设定为null通过相应的设置方法。 例如： getTimeZone()可能会返回null ，如果这个实例的TimeZone值设置为setTimeZone(null) 。
    从以下版本开始：
    1.1
    另请参见：
    Format ， NumberFormat ， SimpleDateFormat ， Calendar ， GregorianCalendar ， TimeZone ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  DateFormat.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 DateFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int AM_PM_FIELD
      AM_PM字段对齐的常用常数。
      protected Calendar calendar
      Calendar用于计算日期时间字段和时间的实例。
      static int DATE_FIELD
      DATE字段对齐的常用常数。
      static int DAY_OF_WEEK_FIELD
      DAY_OF_WEEK字段对齐的常用常数。
      static int DAY_OF_WEEK_IN_MONTH_FIELD
      DAY_OF_WEEK_IN_MONTH字段对齐的常用常数。
      static int DAY_OF_YEAR_FIELD
      DAY_OF_YEAR字段对齐的常用常数。
      static int DEFAULT
      常数为默认样式模式。
      static int ERA_FIELD
      ERA场对齐的有用常数。
      static int FULL
      恒定的全风格图案。
      static int HOUR_OF_DAY0_FIELD
      基于零的HOUR_OF_DAY字段对齐的常用常数。
      static int HOUR_OF_DAY1_FIELD
      基于一个HOUR_OF_DAY字段对齐的常用常数。
      static int HOUR0_FIELD
      基于零的HOUR场对齐的有用常数。
      static int HOUR1_FIELD
      基于一个HOUR字段对齐的常用常数。
      static int LONG
      恒久的长款式。
      static int MEDIUM
      中等风格图案的常数。
      static int MILLISECOND_FIELD
      MILLISECOND字段对齐的常用常数。
      static int MINUTE_FIELD
      MINUTE字段对齐的常用常数。
      static int MONTH_FIELD
      MONTH字段对齐的常用常数。
      protected NumberFormat numberFormat
      DateFormat用于在日期和时间格式化数字的数字格式化程序。
      static int SECOND_FIELD
      有用的常数用于SECOND场对齐。
      static int SHORT
      恒定的短款式。
      static int TIMEZONE_FIELD
      TIMEZONE字段对齐的常用常数。
      static int WEEK_OF_MONTH_FIELD
      WEEK_OF_MONTH字段对齐的常用常数。
      static int WEEK_OF_YEAR_FIELD
      WEEK_OF_YEAR字段对齐的常用常数。
      static int YEAR_FIELD
      YEAR场对齐的常用常数。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected DateFormat​()
      创建一个新的日期格式。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      覆盖可克隆
      boolean equals​(Object obj)
      覆盖等于
      StringBuffer format​(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition)
      覆盖格式。
      String format​(Date date)
      将日期格式化成日期/时间字符串。
      abstract StringBuffer format​(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition)
      将日期格式化成日期/时间字符串。
      static Locale[] getAvailableLocales​()
      返回一个所有语言环境的数组，该类的 get*Instance方法可以返回本地化实例。
      Calendar getCalendar​()
      获取与此日期/时间格式化程序关联的日历。
      static DateFormat getDateInstance​()
      获取缺省格式化样式的默认 FORMAT区域设置的日期格式化程序。
      static DateFormat getDateInstance​(int style)
      获取默认的 FORMAT区域设置的给定格式化样式的日期格式化程序。
      static DateFormat getDateInstance​(int style, Locale aLocale)
      获取给定区域设置的给定格式化样式的日期格式化程序。
      static DateFormat getDateTimeInstance​()
      获取日期/时间格式化程序，默认格式设置为默认的 FORMAT区域设置。
      static DateFormat getDateTimeInstance​(int dateStyle, int timeStyle)
      获取默认的 FORMAT区域设置的给定日期和时间格式化样式的日期/时间格式化程序。
      static DateFormat getDateTimeInstance​(int dateStyle, int timeStyle, Locale aLocale)
      获取给定区域设置的给定格式样式的日期/时间格式化程序。
      static DateFormat getInstance​()
      获取在日期和时间上使用SHORT样式的默认日期/时间格式化程序。
      NumberFormat getNumberFormat​()
      获取此日期/时间格式化程序用于格式化和解析时间的数字格式化程序。
      static DateFormat getTimeInstance​()
      获取默认格式化样式为默认的 FORMAT区域设置的时间格式化程序。
      static DateFormat getTimeInstance​(int style)
      获取默认的 FORMAT区域设置的给定格式化样式的时间格式化程序。
      static DateFormat getTimeInstance​(int style, Locale aLocale)
      获取给定区域设置的给定格式化样式的时间格式化程序。
      TimeZone getTimeZone​()
      获取时区。
      int hashCode​()
      覆盖hashCode
      boolean isLenient​()
      告诉日期/时间解析是否宽松。
      Date parse​(String source)
      从给定字符串的开始解析文本以生成日期。
      abstract Date parse​(String source, ParsePosition pos)
      根据给定的解析位置解析日期/时间字符串。
      Object parseObject​(String source, ParsePosition pos)
      从字符串中解析文本，产生一个 Date 。
      void setCalendar​(Calendar newCalendar)
      将日历设置为使用此日期格式。
      void setLenient​(boolean lenient)
      指定日期/时间解析是否宽松。
      void setNumberFormat​(NumberFormat newNumberFormat)
      允许您设置数字格式化程序。
      void setTimeZone​(TimeZone zone)
      设置 DateFormat对象日历的时区。

      • Methods inherited from class java.text.Format

        format, formatToCharacterIterator, parseObject

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • calendar

        protected Calendar calendar
        Calendar用于计算日期时间字段和时间的实例。 此字段用于格式化和解析。

        子类应此字段初始化为Calendar适合于Locale与此相关DateFormat 。

      • numberFormat

        protected NumberFormat numberFormat
        DateFormat用于在日期和时间格式化数字的数字格式化程序。 子类应将其初始化为适合与此DateFormat相关联的区域设置的数字格式。

      • ERA_FIELD

        public static final int ERA_FIELD
        ERA场对齐的有用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • YEAR_FIELD

        public static final int YEAR_FIELD
        YEAR场对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • MONTH_FIELD

        public static final int MONTH_FIELD
        MONTH字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • DATE_FIELD

        public static final int DATE_FIELD
        DATE字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • HOUR_OF_DAY1_FIELD

        public static final int HOUR_OF_DAY1_FIELD
        基于一个HOUR_OF_DAY字段对齐的常用常数。 用于FieldPosition的日期/时间格式。 HOUR_OF_DAY1_FIELD用于单一24小时制。 例如，23:59 + 01:00结果是24:59。
        另请参见：
        Constant Field Values

      • HOUR_OF_DAY0_FIELD

        public static final int HOUR_OF_DAY0_FIELD
        基于零的HOUR_OF_DAY字段对齐的常用常数。 用于FieldPosition的日期/时间格式。 HOUR_OF_DAY0_FIELD用于零基24小时制。 例如，23:59 + 01:00结果是00:59。
        另请参见：
        Constant Field Values

      • MINUTE_FIELD

        public static final int MINUTE_FIELD
        MINUTE字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • SECOND_FIELD

        public static final int SECOND_FIELD
        有用的常数用于SECOND场对齐。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • MILLISECOND_FIELD

        public static final int MILLISECOND_FIELD
        MILLISECOND字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • DAY_OF_WEEK_FIELD

        public static final int DAY_OF_WEEK_FIELD
        DAY_OF_WEEK字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • DAY_OF_YEAR_FIELD

        public static final int DAY_OF_YEAR_FIELD
        DAY_OF_YEAR字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • DAY_OF_WEEK_IN_MONTH_FIELD

        public static final int DAY_OF_WEEK_IN_MONTH_FIELD
        DAY_OF_WEEK_IN_MONTH字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • WEEK_OF_YEAR_FIELD

        public static final int WEEK_OF_YEAR_FIELD
        WEEK_OF_YEAR字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • WEEK_OF_MONTH_FIELD

        public static final int WEEK_OF_MONTH_FIELD
        WEEK_OF_MONTH字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • AM_PM_FIELD

        public static final int AM_PM_FIELD
        AM_PM字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • HOUR1_FIELD

        public static final int HOUR1_FIELD
        基于一个HOUR字段对齐的常用常数。 用于FieldPosition的日期/时间格式。 HOUR1_FIELD用于基于1个12小时制的时钟。 例如，11:30 PM + 1小时结果在12:30 AM。
        另请参见：
        Constant Field Values

      • HOUR0_FIELD

        public static final int HOUR0_FIELD
        基于零的HOUR场对齐的有用常数。 用于FieldPosition的日期/时间格式。 HOUR0_FIELD用于零基12小时制。 例如，上午11:30 PM + 1小时结果是00:30 AM。
        另请参见：
        Constant Field Values

      • TIMEZONE_FIELD

        public static final int TIMEZONE_FIELD
        TIMEZONE字段对齐的常用常数。 用于FieldPosition的日期/时间格式。
        另请参见：
        Constant Field Values

      • FULL

        public static final int FULL
        恒定的全风格图案。
        另请参见：
        Constant Field Values

      • LONG

        public static final int LONG
        恒久的长款式。
        另请参见：
        Constant Field Values

      • MEDIUM

        public static final int MEDIUM
        中等风格图案的常数。
        另请参见：
        Constant Field Values

      • SHORT

        public static final int SHORT
        恒定的短款式。
        另请参见：
        Constant Field Values

      • DEFAULT

        public static final int DEFAULT
        常数为默认样式模式。 其值为MEDIUM。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DateFormat

        protected DateFormat​()
        创建一个新的日期格式。

    • 方法详细信息

      • format

        public final StringBuffer format​(Object obj,
                                 StringBuffer toAppendTo,
                                 FieldPosition fieldPosition)
        覆盖格式。 将时间对象格式化成时间字符串。 时间对象的示例是以毫秒为单位的时间值和Date对象。
        Specified by:
        format在 Format
        参数
        obj - 必须是数字或日期。
        toAppendTo - 返回时间字符串的字符串缓冲区。
        fieldPosition - 跟踪返回字符串中字段的位置。 在输入：对齐字段，如果需要。 输出：对齐字段的偏移量。 例如，给定时间文本“1996.07.10 AD在15:08:56 PDT”，如果给定的fieldPosition为DateFormat.YEAR_FIELD，则fieldPosition的起始索引和结束索引将分别设置为0和4。 请注意，如果相同的时间字段在模式中出现多次，则fieldPosition将被设置为该时间字段的第一个出现。 例如，使用模式“haz（zzzz）”和对齐字段DateFormat.TIMEZONE_FIELD将日期格式化为时间字符串“1 PM PDT（太平洋夏令时）”，fieldPosition的起始索引和结束索引将设置为5和8，分别是时区模式字符“z”的第一次出现。
        结果
        字符串缓冲区以forAppendTo传递，并附加了格式化的文本。
        异常
        IllegalArgumentException - 如果 Format无法格式化给定的 obj 。
        另请参见：
        Format

      • format

        public abstract StringBuffer format​(Date date,
                                    StringBuffer toAppendTo,
                                    FieldPosition fieldPosition)
        将日期格式化成日期/时间字符串。
        参数
        date - 要格式化为日期/时间字符串的日期。
        toAppendTo - 返回日期/时间字符串的字符串缓冲区。
        fieldPosition - 跟踪返回字符串中字段的位置。 在输入：对齐字段，如果需要。 输出：对齐字段的偏移量。 例如，给定时间文本“1996.07.10 AD在15:08:56 PDT”，如果给定的fieldPosition为DateFormat.YEAR_FIELD，则fieldPosition的起始索引和结束索引将分别设置为0和4。 请注意，如果相同的时间字段在模式中出现多次，则fieldPosition将被设置为该时间字段的第一个出现。 例如，使用模式“haz（zzzz）”和对齐字段DateFormat.TIMEZONE_FIELD将日期格式化为时间字符串“1 PM PDT（太平洋夏令时）”，fieldPosition的起始索引和结束索引将设置为5和8，分别是时区模式字符“z”的第一次出现。
        结果
        字符串缓冲区以forAppendTo传递，并附加了格式化的文本。

      • format

        public final String format​(Date date)
        将日期格式化成日期/时间字符串。
        参数
        date - 要格式化为时间字符串的时间值。
        结果
        格式化的时间字符串。

      • parse

        public Date parse​(String source)
           throws ParseException
        从给定字符串的开始解析文本以生成日期。 该方法可能不会使用给定字符串的整个文本。

        有关日期解析的更多信息，请参阅parse(String, ParsePosition)方法。

        参数
        source - A String其开头应该被解析。
        结果
        A Date从字符串中解析。
        异常
        ParseException - 如果指定字符串的开头不能被解析。

      • parse

        public abstract Date parse​(String source,
                           ParsePosition pos)
        根据给定的解析位置解析日期/时间字符串。 例如，时间文本"07/10/96 4:5 PM, PDT"将被解析为Date ，相当于Date(837039900000L) 。

        默认情况下，解析是宽松的：如果输入不是此对象的格式方法使用的形式，但仍可以解析为日期，则解析成功。 客户可能会通过致电setLenient(false)坚持严格遵守格式。

        此解析操作使用calendar生成Date 。 因此， calendar的日期时间字段和TimeZone值可能已被覆盖，这取决于子类实现。 以前通过调用setTimeZone设置的任何TimeZone值可能需要恢复进一步操作。

        参数
        source - 要解析的日期/时间字符串
        pos - 输入时，开始解析的位置; 输出，解析终止的位置，或解析失败时的起始位置。
        结果
        A Date或 null如果输入无法解析

      • parseObject

        public Object parseObject​(String source,
                          ParsePosition pos)
        从字符串中解析文本，产生一个Date 。

        该方法尝试从pos给出的索引开始解析文本。 如果解析成功，则pos的索引将更新为使用最后一个字符后的索引（解析不一定使用字符串末尾的所有字符），并返回解析的日期。 更新的pos可用于指示下一次调用此方法的起始点。 如果发生错误，则pos的索引未更改，将错误索引pos设置为发生错误的字符的索引，返回null。

        有关日期解析的更多信息，请参阅parse(String, ParsePosition)方法。

        Specified by:
        parseObject在类 Format
        参数
        source - A String ，其中的一部分应该被解析。
        pos -A ParsePosition具有如上所述的索引和错误索引信息的对象。
        结果
        A Date从字符串中解析。 万一出错，返回null。
        异常
        NullPointerException - 如果 source或 pos为空。

      • getTimeInstance

        public static final DateFormat getTimeInstance​()
        获取缺省格式化样式的默认FORMAT语言环境的时间格式化程序。

        这相当于调用getTimeInstance(DEFAULT, Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        时间格式化
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getTimeInstance

        public static final DateFormat getTimeInstance​(int style)
        获取默认的FORMAT区域设置的给定格式化样式的时间格式化程序。

        这相当于调用getTimeInstance(style, Locale.getDefault(Locale.Category.FORMAT)) 。

        参数
        style - 给定的格式化样式。 例如，美国地区的“h：mm a”的短路。
        结果
        时间格式化
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getTimeInstance

        public static final DateFormat getTimeInstance​(int style,
                                               Locale aLocale)
        获取给定区域设置的给定格式化样式的时间格式化程序。
        参数
        style - 给定的格式化样式。 例如，美国地区的“h：mm a”的短路。
        aLocale - 给定的区域设置。
        结果
        时间格式化

      • getDateInstance

        public static final DateFormat getDateInstance​()
        获取缺省格式化样式的日期格式化程序，默认为FORMAT区域设置。

        这相当于调用getDateInstance(DEFAULT, Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        一个日期格式化程序
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getDateInstance

        public static final DateFormat getDateInstance​(int style)
        获取默认的FORMAT区域设置的给定格式化样式的日期格式化程序。

        这相当于调用getDateInstance(style, Locale.getDefault(Locale.Category.FORMAT)) 。

        参数
        style - 给定的格式化样式。 例如，美国地区的“M / d / yy”短路。
        结果
        一个日期格式化程序
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getDateInstance

        public static final DateFormat getDateInstance​(int style,
                                               Locale aLocale)
        获取给定区域设置的给定格式化样式的日期格式化程序。
        参数
        style - 给定的格式化样式。 例如，美国地区的“M / d / yy”短路。
        aLocale - 给定的地区。
        结果
        一个日期格式化程序

      • getDateTimeInstance

        public static final DateFormat getDateTimeInstance​()
        获取日期/时间格式化程序，其默认格式化样式为默认的FORMAT区域设置。

        这相当于调用getDateTimeInstance(DEFAULT, DEFAULT, Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        日期/时间格式化。
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getDateTimeInstance

        public static final DateFormat getDateTimeInstance​(int dateStyle,
                                                   int timeStyle)
        获取默认的FORMAT语言环境的给定日期和时间格式化样式的日期/时间格式化程序。

        这相当于调用getDateTimeInstance(dateStyle, timeStyle, Locale.getDefault(Locale.Category.FORMAT)) 。

        参数
        dateStyle - 给定的日期格式化样式。 例如，美国地区的“M / d / yy”短路。
        timeStyle - 给定的时间格式化样式。 例如，美国地区的“h：mm a”的短路。
        结果
        日期/时间格式化。
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getDateTimeInstance

        public static final DateFormat getDateTimeInstance​(int dateStyle,
                                                   int timeStyle,
                                                   Locale aLocale)
        获取给定区域设置的给定格式样式的日期/时间格式化程序。
        参数
        dateStyle - 给定的日期格式化样式。
        timeStyle - 给定的时间格式化样式。
        aLocale - 给定的区域设置。
        结果
        日期/时间格式化。

      • getInstance

        public static final DateFormat getInstance​()
        获取在日期和时间上使用SHORT样式的默认日期/时间格式化程序。
        结果
        日期/时间格式化

      • getAvailableLocales

        public static Locale[] getAvailableLocales​()
        返回所有语言环境的数组，该类的get*Instance方法可以返回本地化实例。 返回的数组表示由Java运行时支持的语言环境和已安装的DateFormatProvider实现的联合。 它必须至少包含Locale实例等于Locale.US 。
        结果
        一组可用于本地化的本地化的区域设置 DateFormat 。

      • setCalendar

        public void setCalendar​(Calendar newCalendar)
        将日历设置为使用此日期格式。 最初，使用指定或默认语言环境的默认日历。

        以前设置的任何TimeZone和leniency值将被newCalendar的值覆盖。

        参数
        newCalendar - 新的 Calendar被日期格式使用

      • getCalendar

        public Calendar getCalendar​()
        获取与此日期/时间格式化程序关联的日历。
        结果
        与该日期/时间格式化程序相关联的日历。

      • setNumberFormat

        public void setNumberFormat​(NumberFormat newNumberFormat)
        允许您设置数字格式化程序。
        参数
        newNumberFormat - 给定的新的NumberFormat。

      • getNumberFormat

        public NumberFormat getNumberFormat​()
        获取此日期/时间格式化程序用于格式化和解析时间的数字格式化程序。
        结果
        这个日期/时间格式化程序使用的数字格式化程序。

      • setTimeZone

        public void setTimeZone​(TimeZone zone)
        设置DateFormat对象的日历的时区。 此方法等同于以下调用。

 getCalendar().setTimeZone(zone)

        这个方法设置的TimeZone被一个setCalendar调用所覆盖。

        由此方法设置的TimeZone可能会由于调用parse方法而被覆盖。

        参数
        zone - 给定的新时区。

      • getTimeZone

        public TimeZone getTimeZone​()
        获取时区。 此方法等同于以下调用。

 getCalendar().getTimeZone()
        结果
        与DateFormat日历相关联的时区。

      • setLenient

        public void setLenient​(boolean lenient)
        指定日期/时间解析是否宽松。 通过宽泛的解析，解析器可以使用启发式来解释不精确匹配该对象格式的输入。 通过严格的解析，输入必须与此对象的格式相匹配。

        此方法等同于以下调用。

 getCalendar().setLenient(lenient)

        这个宽大值被调用setCalendar()覆盖。

        参数
        lenient - 当 true ，解析是宽松的
        另请参见：
        Calendar.setLenient(boolean)

      • isLenient

        public boolean isLenient​()
        告诉日期/时间解析是否宽松。 此方法等同于以下调用。

 getCalendar().isLenient()
        结果
        true如果calendar是宽松的; 否则为false 。
        另请参见：
        Calendar.isLenient()

      • hashCode

        public int hashCode​()
        覆盖hashCode
        重写：
        hashCode在类 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        覆盖等于
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • clone

        public Object clone​()
        覆盖可克隆
        重写：
        clone在 Format
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DateFormat.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class DateFormat.Field

  • java.lang.Object
    • java.text.AttributedCharacterIterator.Attribute
      • java.text.Format.Field
        • java.text.DateFormat.Field
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    DateFormat

    public static class DateFormat.Field
extends Format.Field
    定义了用于作为属性键常数AttributedCharacterIterator从返回DateFormat.formatToCharacterIterator和字段标识符在FieldPosition 。

    该类还提供了两种方法来映射其常量和相应的日历常量。

    从以下版本开始：
    1.4
    另请参见：
    Calendar ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static DateFormat.Field AM_PM
      常数识别时间指示符（例如
      static DateFormat.Field DAY_OF_MONTH
      不断识别月的字段。
      static DateFormat.Field DAY_OF_WEEK
      不断识别星期几的字段。
      static DateFormat.Field DAY_OF_WEEK_IN_MONTH
      不断识别星期几的字段。
      static DateFormat.Field DAY_OF_YEAR
      常年识别日期字段。
      static DateFormat.Field ERA
      不断识别时代领域。
      static DateFormat.Field HOUR_OF_DAY0
      常数确定小时的字段，其中合法值为0到23。
      static DateFormat.Field HOUR_OF_DAY1
      常数确定时间字段，法定值为1到24。
      static DateFormat.Field HOUR0
      常数标识小时字段，合法值为0到11。
      static DateFormat.Field HOUR1
      常数标识小时字段，合法值为1到12。
      static DateFormat.Field MILLISECOND
      常量标识毫秒字段。
      static DateFormat.Field MINUTE
      常数识别分钟字段。
      static DateFormat.Field MONTH
      不断识别月份字段。
      static DateFormat.Field SECOND
      常数识别第二个字段。
      static DateFormat.Field TIME_ZONE
      不断识别时区字段。
      static DateFormat.Field WEEK_OF_MONTH
      不断识别月份字段。
      static DateFormat.Field WEEK_OF_YEAR
      常年识别一周的字段。
      static DateFormat.Field YEAR
      不断识别年份字段。

      • Fields inherited from class java.text.AttributedCharacterIterator.Attribute

        INPUT_METHOD_SEGMENT, LANGUAGE, READING

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Field​(String name, int calendarField)
      创建一个 Field 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getCalendarField​()
      返回与此属性相关联的 Calendar字段。
      static DateFormat.Field ofCalendarField​(int calendarField)
      返回 Field常数，对应于 Calendar常数 calendarField 。
      protected Object readResolve​()
      解析反序列化为预定义常量的实例。

      • Methods inherited from class java.text.AttributedCharacterIterator.Attribute

        equals, getName, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ERA

        public static final DateFormat.Field ERA
        不断识别时代领域。

      • YEAR

        public static final DateFormat.Field YEAR
        不断识别年份字段。

      • MONTH

        public static final DateFormat.Field MONTH
        不断识别月份字段。

      • DAY_OF_MONTH

        public static final DateFormat.Field DAY_OF_MONTH
        不断识别月的字段。

      • HOUR_OF_DAY1

        public static final DateFormat.Field HOUR_OF_DAY1
        常数确定时间字段，法定值为1到24。

      • HOUR_OF_DAY0

        public static final DateFormat.Field HOUR_OF_DAY0
        常数确定小时的字段，其中合法值为0到23。

      • MINUTE

        public static final DateFormat.Field MINUTE
        常数识别分钟字段。

      • SECOND

        public static final DateFormat.Field SECOND
        常数识别第二个字段。

      • MILLISECOND

        public static final DateFormat.Field MILLISECOND
        常量标识毫秒字段。

      • DAY_OF_WEEK

        public static final DateFormat.Field DAY_OF_WEEK
        不断识别星期几的字段。

      • DAY_OF_YEAR

        public static final DateFormat.Field DAY_OF_YEAR
        常年识别日期字段。

      • DAY_OF_WEEK_IN_MONTH

        public static final DateFormat.Field DAY_OF_WEEK_IN_MONTH
        不断识别星期几的字段。

      • WEEK_OF_YEAR

        public static final DateFormat.Field WEEK_OF_YEAR
        常年识别一周的字段。

      • WEEK_OF_MONTH

        public static final DateFormat.Field WEEK_OF_MONTH
        不断识别月份字段。

      • AM_PM

        public static final DateFormat.Field AM_PM
        不断识别时间指示符（例如“am”或“pm”）字段。

      • HOUR1

        public static final DateFormat.Field HOUR1
        常数标识小时字段，合法值为1到12。

      • HOUR0

        public static final DateFormat.Field HOUR0
        常数标识小时字段，合法值为0到11。

      • TIME_ZONE

        public static final DateFormat.Field TIME_ZONE
        不断识别时区字段。

    • 构造方法详细信息

      • Field

        protected Field​(String name,
                int calendarField)
        创建一个 Field 。
        参数
        name - 名称 Field
        calendarField - Calendar常数这个Field对应; 任何价值，即使一个超出合法范围的Calendar值也可以使用，但是-1应该被用于不符合法定Calendar值

    • 方法详细信息

      • ofCalendarField

        public static DateFormat.Field ofCalendarField​(int calendarField)
        返回Field常数，对应于Calendar常量calendarField 。 如果Calendar常量和Field之间没有直接映射，则返回null。
        参数
        calendarField - 日历字段常量
        结果
        表示calendarField的字段实例。
        异常
        IllegalArgumentException - 如果 calendarField不是一个 Calendar字段常量的值。
        另请参见：
        Calendar

      • getCalendarField

        public int getCalendarField​()
        返回与此属性相关联的Calendar字段。 例如，如果这表示Calendar的小时字段，则会返回Calendar.HOUR 。 如果没有相应的Calendar常数，则返回-1。
        结果
        该字段的日历常数
        另请参见：
        Calendar

      • readResolve

        protected Object readResolve​()
                      throws InvalidObjectException
        解析反序列化为预定义常量的实例。
        重写：
        readResolve在 AttributedCharacterIterator.Attribute
        结果
        解析DateFormat.Field常量
        异常
        InvalidObjectException - 如果常数无法解决。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DateFormatSymbols (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class DateFormatSymbols

  • java.lang.Object
    • java.text.DateFormatSymbols
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class DateFormatSymbols
extends Object
implements Serializable, Cloneable
    DateFormatSymbols是用于封装可本地化的日期时间格式化数据的公共类，例如月份的名称，星期几的名称和时区数据。 SimpleDateFormat使用DateFormatSymbols封装此信息。

    通常你不应该直接使用DateFormatSymbols 。 相反，我们鼓励你创建一个日期-时间格式化DateFormat类的工厂方法： getTimeInstance ， getDateInstance ，或getDateTimeInstance 。 这些方法会自动为格式化程序创建一个DateFormatSymbols ，以便您不必。 格式化程序创建后，您可以使用setPattern方法修改其格式模式。 有关使用DateFormat的工厂方法创建格式化程序的更多信息，请参阅DateFormat 。

    如果您决定为特定区域设置创建具有特定格式模式的日期时间格式化程序，则可以使用以下命令：

     new SimpleDateFormat(aPattern, DateFormatSymbols.getInstance(aLocale)).

    DateFormatSymbols对象是可DateFormatSymbols 。 当您获得DateFormatSymbols对象时，请随时修改日期时间格式化数据。 例如，您可以将本地化的日期时间格式模式字符替换为您感到容易记住的字符。 或者您可以将代表城市更改为您最喜爱的城市。

    可以添加新的DateFormatSymbols子类以支持SimpleDateFormat用于其他语言环境的日期时间格式。

    从以下版本开始：
    1.1
    另请参见：
    DateFormat ， SimpleDateFormat ， SimpleTimeZone ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DateFormatSymbols​()
      通过从默认的 FORMAT区域设置的资源中加载格式数据构造一个DateFormatSymbols对象。
      DateFormatSymbols​(Locale locale)
      通过从给定语言环境的资源加载格式数据构造DateFormatSymbols对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      覆盖可克隆
      boolean equals​(Object obj)
      覆盖等于
      String[] getAmPmStrings​()
      获取ampm字符串。
      static Locale[] getAvailableLocales​()
      返回一个所有语言环境的数组，为此类可以返回本地化实例的 getInstance方法。
      String[] getEras​()
      获取时代字符串。
      static DateFormatSymbols getInstance​()
      获取默认语言环境的 DateFormatSymbols实例。
      static DateFormatSymbols getInstance​(Locale locale)
      获取指定区域设置的 DateFormatSymbols实例。
      String getLocalPatternChars​()
      获取本地化的日期时间模式字符。
      String[] getMonths​()
      获取月份字符串。
      String[] getShortMonths​()
      获得短的月份字符串。
      String[] getShortWeekdays​()
      获得短周日字符串。
      String[] getWeekdays​()
      获得平日字符串。
      String[][] getZoneStrings​()
      获取时区字符串。
      int hashCode​()
      覆盖hashCode。
      void setAmPmStrings​(String[] newAmpms)
      设置ampm字符串。
      void setEras​(String[] newEras)
      设置时代字符串。
      void setLocalPatternChars​(String newLocalPatternChars)
      设置本地化的日期时间模式字符。
      void setMonths​(String[] newMonths)
      设置月份字符串。
      void setShortMonths​(String[] newShortMonths)
      设置短的月份字符串。
      void setShortWeekdays​(String[] newShortWeekdays)
      设置短周日字符串。
      void setWeekdays​(String[] newWeekdays)
      设置工作日字符串
      void setZoneStrings​(String[][] newZoneStrings)
      设置时区字符串。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DateFormatSymbols

        public DateFormatSymbols​()
        通过从默认的FORMAT区域设置的资源中加载格式数据构造一个DateFormatSymbols对象。 此构造函数只能为Java运行时环境支持的语言环境构建实例，而不是由已安装的DateFormatSymbolsProvider实现支持的语言环境。 对于完整的区域覆盖，请使用getInstance方法。

        这相当于调用DateFormatSymbols(Locale.getDefault(Locale.Category.FORMAT)) 。

        异常
        MissingResourceException - 如果无法找到或无法加载默认语言环境的资源。
        另请参见：
        getInstance() ， Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • DateFormatSymbols

        public DateFormatSymbols​(Locale locale)
        通过从给定语言环境的资源加载格式数据构造DateFormatSymbols对象。 此构造函数只能为Java运行时环境支持的语言环境构建实例，而不是由已安装的DateFormatSymbolsProvider实现支持的语言环境。 对于完整的区域覆盖，请使用getInstance方法。
        参数
        locale - 所需的语言环境
        异常
        MissingResourceException - 如果指定的区域设置的资源无法找到或无法加载。
        另请参见：
        getInstance(Locale)

    • 方法详细信息

      • getAvailableLocales

        public static Locale[] getAvailableLocales​()
        返回一个所有语言环境的数组，该类的getInstance方法可以返回本地化实例。 返回的数组表示由Java运行时支持的语言环境和已安装的DateFormatSymbolsProvider实现的联合。 它必须至少包含Locale实例等于Locale.US 。
        结果
        语言环境的数组，它局部 DateFormatSymbols实例可用。
        从以下版本开始：
        1.6

      • getInstance

        public static final DateFormatSymbols getInstance​()
        获取默认语言环境的DateFormatSymbols实例。 此方法可访问由Java运行时本身支持的区域设置的DateFormatSymbols实例以及已安装的DateFormatSymbolsProvider实现所支持的实例 。

        这相当于调用getInstance(Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        一个 DateFormatSymbols实例。
        从以下版本开始：
        1.6
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getInstance

        public static final DateFormatSymbols getInstance​(Locale locale)
        获取指定区域设置的DateFormatSymbols实例。 此方法可访问由Java运行时本身支持的语言环境的DateFormatSymbols实例以及已安装的DateFormatSymbolsProvider实现所支持的实例 。
        参数
        locale - 给定的区域设置。
        结果
        一个 DateFormatSymbols例子。
        异常
        NullPointerException - 如果 locale为空
        从以下版本开始：
        1.6

      • getEras

        public String[] getEras​()
        获取时代字符串。 例如：“AD”和“BC”。
        结果
        时代弦。

      • setEras

        public void setEras​(String[] newEras)
        设置时代字符串。 例如：“AD”和“BC”。
        参数
        newEras - 新时代的弦。

      • getMonths

        public String[] getMonths​()
        获取月份字符串。 例如：“1月”，“2月”等

        如果语言需要格式化和独立使用的不同格式，则此方法将以格式化形式返回月份名称。 例如，在捷克语言一月的首选月份名称是在格式化形式ledna，而它在单机形式LEDEN。 这种方法返回"ledna" 。 有关详细信息，请参阅Calendar Elements in the Unicode Locale Data Markup Language (LDML) specification 。

        结果
        月份字符串。 使用Calendar.JANUARY ， Calendar.FEBRUARY等，以索引的结果阵列。

      • setMonths

        public void setMonths​(String[] newMonths)
        设置月份字符串。 例如：“1月”，“2月”等
        参数
        newMonths - 新的月份字符串。 阵列应被索引Calendar.JANUARY ， Calendar.FEBRUARY等

      • getShortMonths

        public String[] getShortMonths​()
        获得短的月份字符串。 例如：“Jan”，“Feb”等

        如果语言需要格式化和独立用法的不同格式，则此方法将以格式化形式返回较短的月份名称。 例如，加泰罗尼亚语中1月份的首选缩写是de gen。 在格式化形式，而它是gen。 在独立的形式。 在这种情况下，此方法返回"de gen." 。 有关详细信息，请参阅Calendar Elements in the Unicode Locale Data Markup Language (LDML) specification 。

        结果
        短的月份字符串。 使用Calendar.JANUARY ， Calendar.FEBRUARY等，以索引的结果阵列。

      • setShortMonths

        public void setShortMonths​(String[] newShortMonths)
        设置短的月份字符串。 例如：“Jan”，“Feb”等
        参数
        newShortMonths - 新的短的月份字符串。 阵列应被索引Calendar.JANUARY ， Calendar.FEBRUARY等

      • getWeekdays

        public String[] getWeekdays​()
        获得平日字符串。 例如：“星期日”，“星期一”等
        结果
        工作日的字符串。 使用Calendar.SUNDAY ， Calendar.MONDAY等，以索引的结果阵列。

      • setWeekdays

        public void setWeekdays​(String[] newWeekdays)
        设置工作日字符串 例如：“星期日”，“星期一”等
        参数
        newWeekdays - 新的工作日字符串。 阵列应被索引Calendar.SUNDAY ， Calendar.MONDAY等

      • getShortWeekdays

        public String[] getShortWeekdays​()
        获得短周日字符串。 例如：“太阳”，“星期一”等
        结果
        短周日字符串。 使用Calendar.SUNDAY ， Calendar.MONDAY等，以索引的结果阵列。

      • setShortWeekdays

        public void setShortWeekdays​(String[] newShortWeekdays)
        设置短周日字符串。 例如：“太阳”，“星期一”等
        参数
        newShortWeekdays - 新的短周日字符串。 阵列应被索引Calendar.SUNDAY ， Calendar.MONDAY等

      • getAmPmStrings

        public String[] getAmPmStrings​()
        获取ampm字符串。 例如：“AM”和“PM”。
        结果
        ampm字符串。

      • setAmPmStrings

        public void setAmPmStrings​(String[] newAmpms)
        设置ampm字符串。 例如：“AM”和“PM”。
        参数
        newAmpms - 新的ampm字符串。

      • getZoneStrings

        public String[][] getZoneStrings​()
        获取时区字符串。 不鼓励使用这种方法; 改用TimeZone.getDisplayName() 。

        返回的值是大小为n的m的二维数组，其中m为至少5.每行n是包含单个TimeZone的本地化名称的条目。 每行包含（ i范围从0 .. n -1）：

        • zoneStrings[i][0] - 时区ID
        • zoneStrings[i][1] - 标准时间的长名称
        • zoneStrings[i][2] - 标准时间区域的短名称
        • zoneStrings[i][3] - 夏令时区域的长名称
        • zoneStrings[i][4] - 夏令时区域的简称
        区域ID 未本地化; 它是TimeZone类的有效ID，不是custom IDs 。 所有其他条目都是本地化名称。 如果某个区域未实现夏令时，则不应使用夏令时名称。

        如果setZoneStrings一直呼吁这个DateFormatSymbols实例，然后通过调用提供的字符串返回。 否则，返回的数组包含由Java运行时提供的名称和安装的TimeZoneNameProvider实现。

        结果
        时区字符串。
        另请参见：
        setZoneStrings(String[][])

      • setZoneStrings

        public void setZoneStrings​(String[][] newZoneStrings)
        设置时区字符串。 该参数必须是m，其中m是至少为5。每个n行的是包含本地化的名称为单一的条目大小为n的串的二维阵列TimeZone 。 每行包含（ i范围从0 .. n -1）：
        • zoneStrings[i][0] - 时区ID
        • zoneStrings[i][1] - 标准时间的长名称
        • zoneStrings[i][2] - 标准时间的短名称
        • zoneStrings[i][3] - 夏令时区域的长名称
        • zoneStrings[i][4] - 夏令时区域的短名称
        区域ID 未本地化; 它是TimeZone类的有效ID，不是custom IDs 。 所有其他条目都是本地化名称。
        参数
        newZoneStrings - 新的时区字符串。
        异常
        IllegalArgumentException -如果在任何行的长度 newZoneStrings小于5
        NullPointerException - 如果 newZoneStrings为空
        另请参见：
        getZoneStrings()

      • getLocalPatternChars

        public String getLocalPatternChars​()
        获取本地化的日期时间模式字符。 例如：'你'，'t'等
        结果
        本地化的日期时间模式字符。

      • setLocalPatternChars

        public void setLocalPatternChars​(String newLocalPatternChars)
        设置本地化的日期时间模式字符。 例如：'你'，'t'等
        参数
        newLocalPatternChars - 新的本地化日期时间模式字符。

      • clone

        public Object clone​()
        覆盖可克隆
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • hashCode

        public int hashCode​()
        覆盖hashCode。 为DateFormatSymbols对象生成哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        覆盖等于
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DecimalFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class DecimalFormat

  • java.lang.Object
    • java.text.Format
      • java.text.NumberFormat
        • java.text.DecimalFormat
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class DecimalFormat
extends NumberFormat
    DecimalFormat是格式为十进制数的NumberFormat的具体子类。 它具有各种功能，旨在使任何地区的数字解析和格式化，包括支持西方，阿拉伯语和印度数字。 它还支持不同类型的数字，包括整数（123），定点数（123.4），科学记数法（1.23E4），百分比（12％）和货币金额（123美元）。 所有这些都可以进行本地化。

    要获取特定区域设置的NumberFormat （包括默认语言环境），请致电NumberFormat的工厂方法之一，例如getInstance() 。 一般来说，不要直接调用DecimalFormat构造函数，因为NumberFormat工厂方法可能会返回DecimalFormat以外的子类。 如果您需要自定义格式对象，请执行以下操作：

     NumberFormat f = NumberFormat.getInstance(loc);
 if (f instanceof DecimalFormat) {
     ((DecimalFormat) f).setDecimalSeparatorAlwaysShown(true);
 }

    A DecimalFormat包括图案和一组符号 。 可以使用applyPattern()或间接使用API方法直接设置模式。 符号存储在一个DecimalFormatSymbols对象中。 当使用NumberFormat工厂方法时，模式和符号从本地化的ResourceBundle读取。

    模式

    DecimalFormat模式具有以下语法：
     Pattern:
         PositivePattern
         PositivePattern ; NegativePattern
 PositivePattern:
         Prefixopt Number Suffixopt
 NegativePattern:
         Prefixopt Number Suffixopt
 Prefix:
         any Unicode characters except \uFFFE, \uFFFF, and special characters
 Suffix:
         any Unicode characters except \uFFFE, \uFFFF, and special characters
 Number:
         Integer Exponentopt
         Integer . Fraction Exponentopt
 Integer:
         MinimumInteger
         #
         # Integer
         # , Integer
 MinimumInteger:
         0
         0 MinimumInteger
         0 , MinimumInteger
 Fraction:
         MinimumFractionopt OptionalFractionopt
 MinimumFraction:
         0 MinimumFractionopt
 OptionalFraction:
         # OptionalFractionopt
 Exponent:
         E MinimumExponent
 MinimumExponent:
         0 MinimumExponentopt

    A DecimalFormat模式包含正和负子模式，例如"#,##0.00;(#,##0.00)" 。 每个子模式都有一个前缀，数字部分和后缀。 负子模式是可选的; 如果不存在，则使用以局部减号（ '-'在大多数语言环境中）前缀的正子模式作为负子模式。 也就是说， "0.00"独自相当于"0.00;-0.00" 。 如果存在显式的负子模式，则仅用于指定负前缀和后缀; 位数，最小数字和其他特征与正图案完全相同。 这意味着"#,##0.0#;(#)"产生与"#,##0.0#;(#,##0.0#)"完全相同的行为。

    用于无穷大，数字，数千个分隔符，十进制分隔符等的前缀，后缀和各种符号可以设置为任意值，并且在格式化期间它们将正确显示。 但是，必须注意符号和字符串不冲突，否则解析将不可靠。 例如，对于DecimalFormat.parse() ，正负号前缀或后缀必须是不同的，以便能够区分正值和负值。 （如果它们相同，那么DecimalFormat将表现为没有指定负子模式。）另一个例子是，小数分隔符和千位分隔符应该是不同的字符，否则解析将是不可能的。

    分组分隔符通常用于数千个，但在一些国家，它分隔成万。 分组大小是分组字符之间的常数数字，例如3个为100,000,000或4为1,0000,0000。 如果您提供具有多个分组字符的模式，则最后一个和整数结束之间的间隔是使用的模式。 所以"#,##,###,####" == "######,####" == "##,####,####" 。

    特殊图案字符

    一个模式中的许多人物都是字面上的; 在格式化期间，它们在解析期间匹配，输出不变。 另一方面，特殊字符代表其他字符，字符串或字符类。 除非另有说明，否则必须引用它们，如果它们以字面值的形式出现在前缀或后缀中。

    这里列出的字符用于非本地化模式。 本地化模式使用从该格式化程序的DecimalFormatSymbols对象中取得的相应字符，而这些字符将失去其特殊状态。 货币符号和报价两个例外都不是本地化的。

    Chart showing symbol, location, localized, and meaning.
    Symbol | Location | Localized? | Meaning
    0 | Number | Yes | Digit
    # Number Yes Digit, zero shows as absent
    . Number Yes Decimal separator or monetary decimal separator
    - Number Yes Minus sign
    , Number Yes Grouping separator
    E | Number | Yes | Separates mantissa and exponent in scientific notation. Need not be quoted in prefix or suffix.
    ; Subpattern boundary Yes Separates positive and negative subpatterns
    % Prefix or suffix Yes Multiply by 100 and show as percentage
    \u2030 | Prefix or suffix | Yes | Multiply by 1000 and show as per mille value
    ¤ (\u00A4) | Prefix or suffix | No | Currency sign, replaced by currency symbol. If doubled, replaced by international currency symbol. If present in a pattern, the monetary decimal separator is used instead of the decimal separator.
    ' Prefix or suffix No Used to quote special characters in a prefix or suffix, for example, "'#'#" formats 123 to "#123". To create a single quote itself, use two in a row: "# o''clock".

    科学计数法

    科学符号中的数字表示为尾数和幂的乘积，例如，1234可以表示为1.234×10 ^ 3。 尾数通常在1.0‰x <10.0的范围内，但不一定是。 可以指示DecimalFormat格式化和分析科学符号， 只能通过模式 ; 目前没有工厂方法创建科学的符号格式。 在一个模式中，紧随着一个或多个数字字符的指数字符表示科学符号。 示例： "0.###E0"将号码1234格式化为"1.234E3" 。

    • 指数字符后的数字字符数给出最小指数数字计数。 没有最大值。 负指数使用局部减号进行格式化， 而不是模式的前缀和后缀。 这允许模式如"0.###E0 m/s" 。
    • 整数数字的最小和最大数字一起解释：
      • 如果整数数字的最大数目大于其最小数目并大于1，则强制指数为整数数字的最大数目的倍数，而将最小数字解释为1。最常见的使用这个是生成工程符号 ，其中指数是三的倍数，例如"##0.#####E0" 。 使用此模式，数字12345格式为"12.345E3" ，而123456格式为"123.456E3" 。
      • 否则，通过调整指数来实现最小数字的整数。 示例：0.00123格式化为"00.###E0"产生"12.3E-4" 。
    • 尾数中的有效位数是最小整数和最大小数位数之和，不受最大整数数字的影响。 例如，使用"##0.##E0"格式化的12345是"12.3E3" 。 要显示所有数字，将有效数字计数设置为零。 有效数字的数量不会影响解析。
    • 指数图案可能不包含分组分隔符。

    四舍五入

    DecimalFormat提供RoundingMode中格式化定义的舍入模式。 默认情况下，它使用RoundingMode.HALF_EVEN 。

    数字

    对于格式化， DecimalFormat使用从DecimalFormatSymbols对象中定义的本地化零位开始的十个连续字符作为数字。 对于解析，这些数字以及由Character.digit定义的所有Unicode十进制数字都被识别。

    特殊价值观

    NaN格式化为字符串，通常具有单个字符\uFFFD 。 该字符串由DecimalFormatSymbols对象确定。 这是唯一未使用前缀和后缀的值。

    Infinity格式化为字符串，通常具有单个字符\u221E ，其中应用了正或负的前缀和后缀。 无穷大字符串由DecimalFormatSymbols对象确定。

    负零（ "-0" ）解析

    • BigDecimal(0)如果isParseBigDecimal()是真的，
    • Long(0)如果isParseBigDecimal()是假的，并isParseIntegerOnly()是真的，
    • Double(-0.0)如果两个isParseBigDecimal()和isParseIntegerOnly()都是假的。

    Synchronization

    十进制格式通常不同步。 建议为每个线程创建单独的格式实例。 如果多个线程同时访问格式，则必须在外部进行同步。

    例

 <strong>// Print out a number using the localized number, integer, currency,
 // and percent format for each locale</strong>
 Locale[] locales = NumberFormat.getAvailableLocales();
 double myNumber = -1234.56;
 NumberFormat form;
 for (int j = 0; j < 4; ++j) {
     System.out.println("FORMAT");
     for (int i = 0; i < locales.length; ++i) {
         if (locales[i].getCountry().length() == 0) {
            continue; // Skip language-only locales
         }
         System.out.print(locales[i].getDisplayName());
         switch (j) {
         case 0:
             form = NumberFormat.getInstance(locales[i]); break;
         case 1:
             form = NumberFormat.getIntegerInstance(locales[i]); break;
         case 2:
             form = NumberFormat.getCurrencyInstance(locales[i]); break;
         default:
             form = NumberFormat.getPercentInstance(locales[i]); break;
         }
         if (form instanceof DecimalFormat) {
             System.out.print(": " + ((DecimalFormat) form).toPattern());
         }
         System.out.print(" -> " + form.format(myNumber));
         try {
             System.out.println(" -> " + form.parse(form.format(myNumber)));
         } catch (ParseException e) {}
     }
 }
    从以下版本开始：
    1.1
    另请参见：
    Java Tutorial ， NumberFormat ， DecimalFormatSymbols ， ParsePosition ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.text.NumberFormat

        NumberFormat.Field

    • Field Summary

      • Fields inherited from class java.text.NumberFormat

        FRACTION_FIELD, INTEGER_FIELD

    • 构造方法摘要

      构造方法
      Constructor 描述
      DecimalFormat​()
      使用缺省模式和符号创建默认的 FORMAT区域设置的DecimalFormat。
      DecimalFormat​(String pattern)
      使用给定的模式和默认的 FORMAT区域设置的符号创建一个DecimalFormat。
      DecimalFormat​(String pattern, DecimalFormatSymbols symbols)
      使用给定的模式和符号创建一个DecimalFormat。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyLocalizedPattern​(String pattern)
      将给定的模式应用于此Format对象。
      void applyPattern​(String pattern)
      将给定的模式应用于此Format对象。
      Object clone​()
      标准覆盖 语义不变。
      boolean equals​(Object obj)
      覆盖等于
      StringBuffer format​(double number, StringBuffer result, FieldPosition fieldPosition)
      格式化为一个字符串。
      StringBuffer format​(long number, StringBuffer result, FieldPosition fieldPosition)
      格式化一个长的字符串。
      StringBuffer format​(Object number, StringBuffer toAppendTo, FieldPosition pos)
      格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
      AttributedCharacterIterator formatToCharacterIterator​(Object obj)
      格式化产生一个 AttributedCharacterIterator的对象。
      Currency getCurrency​()
      在格式化货币值时获取此十进制格式使用的货币。
      DecimalFormatSymbols getDecimalFormatSymbols​()
      返回十进制格式符号的副本，通常程序员或用户不会更改它们。
      int getGroupingSize​()
      返回分组大小。
      int getMaximumFractionDigits​()
      获取数字小数部分中允许的最大位数。
      int getMaximumIntegerDigits​()
      获取数字的整数部分允许的最大位数。
      int getMinimumFractionDigits​()
      获取数字小数部分中允许的最小位数。
      int getMinimumIntegerDigits​()
      获取数字整数部分允许的最小位数。
      int getMultiplier​()
      以百分比，每mille和类似格式获取乘数。
      String getNegativePrefix​()
      获取负前缀。
      String getNegativeSuffix​()
      得到负的后缀。
      String getPositivePrefix​()
      获取正面前缀。
      String getPositiveSuffix​()
      获得积极的后缀。
      RoundingMode getRoundingMode​()
      获取此DecimalFormat中使用的RoundingMode 。
      int hashCode​()
      覆盖hashCode
      boolean isDecimalSeparatorAlwaysShown​()
      允许您使用整数获取小数分隔符的行为。
      boolean isParseBigDecimal​()
      返回 parse(java.lang.String, java.text.ParsePosition)方法是否返回 BigDecimal 。
      Number parse​(String text, ParsePosition pos)
      Number
      void setCurrency​(Currency currency)
      设置格式化货币值时此数字格式使用的货币。
      void setDecimalFormatSymbols​(DecimalFormatSymbols newSymbols)
      设置十进制格式符号，通常程序员或用户不会更改。
      void setDecimalSeparatorAlwaysShown​(boolean newValue)
      允许您使用整数设置小数分隔符的行为。
      void setGroupingSize​(int newValue)
      设置分组大小。
      void setGroupingUsed​(boolean newValue)
      设置是否以此格式使用分组。
      void setMaximumFractionDigits​(int newValue)
      设置数字小数部分允许的最大位数。
      void setMaximumIntegerDigits​(int newValue)
      设置数字的整数部分允许的最大位数。
      void setMinimumFractionDigits​(int newValue)
      设置数字小数部分允许的最小位数。
      void setMinimumIntegerDigits​(int newValue)
      设置数字的整数部分允许的最小位数。
      void setMultiplier​(int newValue)
      设置以百分比，每mille和类似格式使用的乘数。
      void setNegativePrefix​(String newValue)
      设置负前缀。
      void setNegativeSuffix​(String newValue)
      设置负后缀。
      void setParseBigDecimal​(boolean newValue)
      设置 parse(java.lang.String, java.text.ParsePosition)方法是否返回 BigDecimal 。
      void setPositivePrefix​(String newValue)
      设置正前缀。
      void setPositiveSuffix​(String newValue)
      设置正后缀。
      void setRoundingMode​(RoundingMode roundingMode)
      设置此DecimalFormat中使用的RoundingMode 。
      String toLocalizedPattern​()
      合成表示此Format对象的当前状态的本地化模式字符串。
      String toPattern​()
      合成表示此Format对象的当前状态的模式字符串。

      • Methods inherited from class java.text.Format

        format, parseObject

      • Methods inherited from class java.text.NumberFormat

        format, format, getAvailableLocales, getCurrencyInstance, getCurrencyInstance, getInstance, getInstance, getIntegerInstance, getIntegerInstance, getNumberInstance, getNumberInstance, getPercentInstance, getPercentInstance, isGroupingUsed, isParseIntegerOnly, parse, parseObject, setParseIntegerOnly

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DecimalFormat

        public DecimalFormat​()
        使用默认模式和默认的FORMAT区域设置的符号创建一个DecimalFormat。 当国际化不是主要关注点时，这是获取一个十进制格式的方便方法。

        要获得给定语言环境的标准格式，请使用NumberFormat上的工厂方法，例如getNumberInstance。 这些工厂将为给定的区域设置返回最合适的NumberFormat子类。

        另请参见：
        NumberFormat.getInstance() ，
NumberFormat.getNumberInstance() ，
NumberFormat.getCurrencyInstance() ，
NumberFormat.getPercentInstance()

      • DecimalFormat

        public DecimalFormat​(String pattern)
        使用给定的模式和默认的FORMAT语言环境的符号创建一个DecimalFormat。 当国际化不是主要关注点时，这是获取一个十进制格式的方便方法。

        要获得给定语言环境的标准格式，请使用NumberFormat上的工厂方法，例如getNumberInstance。 这些工厂将为给定的区域设置返回最合适的NumberFormat子类。

        参数
        pattern - 非本地化模式字符串。
        异常
        NullPointerException - 如果 pattern为空
        IllegalArgumentException - 如果给定的模式无效。
        另请参见：
        NumberFormat.getInstance() ，
NumberFormat.getNumberInstance() ，
NumberFormat.getCurrencyInstance() ，
NumberFormat.getPercentInstance()

      • DecimalFormat

        public DecimalFormat​(String pattern,
                     DecimalFormatSymbols symbols)
        使用给定的模式和符号创建一个DecimalFormat。 当您需要完全自定义格式的行为时，请使用此构造函数。

        要获取给定语言环境的标准格式，请使用NumberFormat上的工厂方法，例如getInstance或getCurrencyInstance。 如果您只需要对标准格式进行微调，您可以修改NumberFormat工厂方法返回的格式。

        参数
        pattern - 非本地化模式字符串
        symbols - 要使用的符号集合
        异常
        NullPointerException - 如果任何给定的参数为空
        IllegalArgumentException - 如果给定的模式无效
        另请参见：
        NumberFormat.getInstance() ， NumberFormat.getNumberInstance() ， NumberFormat.getCurrencyInstance() ， NumberFormat.getPercentInstance() ， DecimalFormatSymbols

    • 方法详细信息

      • format

        public final StringBuffer format​(Object number,
                                 StringBuffer toAppendTo,
                                 FieldPosition pos)
        格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。 该号码可以是Number的任何子类。

        此实现使用允许的最大精度。

        重写：
        format在 NumberFormat
        参数
        number - 要格式化的数字
        toAppendTo - 要附加格式化文本的 StringBuffer
        pos - 在输入：一个对齐字段，如果需要。 输出：对齐字段的偏移量。
        结果
        该值传递为 toAppendTo
        异常
        IllegalArgumentException - 如果 number为null或不是 Number的实例。
        NullPointerException - 如果 toAppendTo或 pos为空
        ArithmeticException - 如果舍入模式设置为RoundingMode.UNNECESSARY，则需要舍入
        另请参见：
        FieldPosition

      • format

        public StringBuffer format​(double number,
                           StringBuffer result,
                           FieldPosition fieldPosition)
        格式化为一个字符串。
        Specified by:
        format在 NumberFormat
        参数
        number - 双格式
        result - 要附加文本
        fieldPosition - 输入：如果需要，对齐字段。 输出：对齐字段的偏移量。
        结果
        格式化的数字字符串
        异常
        NullPointerException - 如果 result或 fieldPosition是 null
        ArithmeticException - 如果舍入模式设置为RoundingMode.UNNECESSARY，则需要舍入
        另请参见：
        FieldPosition

      • format

        public StringBuffer format​(long number,
                           StringBuffer result,
                           FieldPosition fieldPosition)
        格式化一个长的字符串。
        Specified by:
        format在 NumberFormat
        参数
        number - 长格式
        result - 要附加文本
        fieldPosition - 在输入端：一个对齐字段，如果需要的话。 输出：对齐字段的偏移量。
        结果
        格式化的数字字符串
        异常
        NullPointerException - 如果 result或 fieldPosition是 null
        ArithmeticException - 如果舍入方式设置为RoundingMode.UNNECESSARY，则需要舍入
        另请参见：
        FieldPosition

      • formatToCharacterIterator

        public AttributedCharacterIterator formatToCharacterIterator​(Object obj)
        格式化一个对象，生成一个AttributedCharacterIterator 。 您可以使用返回的AttributedCharacterIterator构建生成的字符串，以及确定有关生成的字符串的信息。

        AttributedCharacterIterator的每个属性键将为类型NumberFormat.Field ，属性值与属性键相同。

        重写：
        formatToCharacterIterator在 Format
        参数
        obj - 要格式化的对象
        结果
        AttributedCharacterIterator描述格式化的值。
        异常
        NullPointerException - 如果obj为空。
        IllegalArgumentException - 格式化格式化给定对象时。
        ArithmeticException - 如果舍入模式设置为RoundingMode.UNNECESSARY，则需要舍入
        从以下版本开始：
        1.4

      • parse

        public Number parse​(String text,
                    ParsePosition pos)
        从字符串中解析文本，生成一个Number 。

        该方法尝试从pos给出的索引开始解析文本。 如果解析成功，那么pos的索引将在使用最后一个字符后更新为索引（解析不一定使用字符串末尾的所有字符），并返回解析的数字。 更新的pos可用于指示下一次调用此方法的起始点。 如果发生错误，则指数pos没有改变，误差指数pos被设置为发生错误的字符的索引，并返回null。

        返回的子类取决于isParseBigDecimal()的值以及要解析的字符串。

        • 如果isParseBigDecimal()为false（默认值），大多数整数值将返回为Long对象，无论如何写入： "17"和"17.000"都解析为Long(17) 。 不能适应Long的值返回为Double s。 这包括具有小数部分，无限值， NaN和值-0.0的值。 DecimalFormat 没有决定是否返回Double或者Long基于小数点分隔符的源字符串中的存在。 这样做可以防止溢出"-9,223,372,036,854,775,808.00"尾数的整数（如"-9,223,372,036,854,775,808.00" ）被准确解析。

          呼叫者可以使用Number方法doubleValue ， longValue ，等等，以获得他们想要的类型。

        • 如果isParseBigDecimal()为true，则返回BigDecimal对象。 这些值由BigDecimal(String)构成，用于与区域设置无关的格式的相应字符串。 特殊情况为负，正无穷大和NaN返回为Double实例，保持对应的Double常数值。

        DecimalFormat解析代表十进制数字的所有Unicode字符，由Character.digit()定义。 此外， DecimalFormat还可以识别为以DecimalFormatSymbols对象中定义的本地化零位开始的十个连续字符的数字。

        Specified by:
        parse在类 NumberFormat
        参数
        text - 要解析的字符串
        pos - 具有 ParsePosition索引和错误索引信息的 ParsePosition对象。
        结果
        解析的值，或 null如果解析失败
        异常
        NullPointerException - 如果 text或 pos为空。
        另请参见：
        NumberFormat.isParseIntegerOnly() ， Format.parseObject(java.lang.String, java.text.ParsePosition)

      • getDecimalFormatSymbols

        public DecimalFormatSymbols getDecimalFormatSymbols​()
        返回十进制格式符号的副本，通常程序员或用户不会更改它们。
        结果
        所需的DecimalFormatSymbols的副本
        另请参见：
        DecimalFormatSymbols

      • setDecimalFormatSymbols

        public void setDecimalFormatSymbols​(DecimalFormatSymbols newSymbols)
        设置十进制格式符号，通常程序员或用户不会更改。
        参数
        newSymbols - 所需的DecimalFormatSymbols
        另请参见：
        DecimalFormatSymbols

      • getPositivePrefix

        public String getPositivePrefix​()
        获取正面前缀。

        示例：+123，$ 123，sFr123

        结果
        正面前缀

      • setPositivePrefix

        public void setPositivePrefix​(String newValue)
        设置正前缀。

        示例：+123，$ 123，sFr123

        参数
        newValue - 新的正面前缀

      • getNegativePrefix

        public String getNegativePrefix​()
        获取负前缀。

        示例：-123，（$ 123）（带负号后缀），sFr-123

        结果
        负前缀

      • setNegativePrefix

        public void setNegativePrefix​(String newValue)
        设置负前缀。

        示例：-123，（$ 123）（带负号后缀），sFr-123

        参数
        newValue - 新的负面前缀

      • getPositiveSuffix

        public String getPositiveSuffix​()
        获得积极的后缀。

        示例：123％

        结果
        正后缀

      • setPositiveSuffix

        public void setPositiveSuffix​(String newValue)
        设置正后缀。

        示例：123％

        参数
        newValue - 新的正后缀

      • getNegativeSuffix

        public String getNegativeSuffix​()
        得到负的后缀。

        示例：-123％，（$ 123）（带正后缀）

        结果
        负后缀

      • setNegativeSuffix

        public void setNegativeSuffix​(String newValue)
        设置负后缀。

        示例：123％

        参数
        newValue - 新的负后缀

      • getMultiplier

        public int getMultiplier​()
        以百分比，每mille和类似格式获取乘数。
        结果
        乘数
        另请参见：
        setMultiplier(int)

      • setMultiplier

        public void setMultiplier​(int newValue)
        设置以百分比，每mille和类似格式使用的乘数。 对于百分比格式，将乘数设置为100，后缀为'％'（对于阿拉伯语，使用阿拉伯数字符号）。 对于每格式，将乘数设置为1000，后缀为'\ u2030'。

        示例：乘法器100,1.23被格式化为“123”，“123”被解析为1.23。

        参数
        newValue - 新的乘数
        另请参见：
        getMultiplier()

      • setGroupingUsed

        public void setGroupingUsed​(boolean newValue)
        设置是否以此格式使用分组。
        重写：
        setGroupingUsed在类 NumberFormat
        参数
        newValue - true如果使用分组; false否则
        另请参见：
        NumberFormat.isGroupingUsed()

      • getGroupingSize

        public int getGroupingSize​()
        返回分组大小。 分组大小是数字整数部分中分组分隔符之间的位数。 例如，在号码“123,456.78”中，分组大小为3。
        结果
        分组大小
        另请参见：
        setGroupingSize(int) ， NumberFormat.isGroupingUsed() ， DecimalFormatSymbols.getGroupingSeparator()

      • setGroupingSize

        public void setGroupingSize​(int newValue)
        设置分组大小。 分组大小是数字整数部分中分组分隔符之间的位数。 例如，在号码“123,456.78”中，分组大小为3。
        传入的值被转换为一个字节，这可能会丢失信息。
        参数
        newValue - 新的分组大小
        另请参见：
        getGroupingSize() ，
NumberFormat.setGroupingUsed(boolean) ，
DecimalFormatSymbols.setGroupingSeparator(char)

      • isDecimalSeparatorAlwaysShown

        public boolean isDecimalSeparatorAlwaysShown​()
        允许您使用整数获取小数分隔符的行为。 （小数分隔符将始终显示为小数。）

        示例：十进制ON：12345â'12345。 OFF：12345†'12345

        结果
        如果总是显示小数分隔符，则为true ; 否则为false

      • setDecimalSeparatorAlwaysShown

        public void setDecimalSeparatorAlwaysShown​(boolean newValue)
        允许您使用整数设置小数分隔符的行为。 （小数分隔符将始终显示为小数。）

        示例：十进制ON：12345â'12345。 OFF：12345†'12345

        参数
        newValue - true如果始终显示小数分隔符; false否则

      • isParseBigDecimal

        public boolean isParseBigDecimal​()
        返回parse(java.lang.String, java.text.ParsePosition)方法是否返回BigDecimal 。 默认值为false。
        结果
        true如果解析方法返回BigDecimal; 否则为false
        从以下版本开始：
        1.5
        另请参见：
        setParseBigDecimal(boolean)

      • setParseBigDecimal

        public void setParseBigDecimal​(boolean newValue)
        设置 parse(java.lang.String, java.text.ParsePosition)方法是否返回 BigDecimal 。
        参数
        newValue - true如果解析方法返回BigDecimal; 否则为false
        从以下版本开始：
        1.5
        另请参见：
        isParseBigDecimal()

      • clone

        public Object clone​()
        标准覆盖 语义不变。
        重写：
        clone在 NumberFormat
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • equals

        public boolean equals​(Object obj)
        覆盖等于
        重写：
        equals在 NumberFormat
        参数
        obj - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        覆盖hashCode
        重写：
        hashCode在 NumberFormat
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toPattern

        public String toPattern​()
        合成表示此Format对象的当前状态的模式字符串。
        结果
        一个模式字符串
        另请参见：
        applyPattern(java.lang.String)

      • toLocalizedPattern

        public String toLocalizedPattern​()
        合成表示此Format对象的当前状态的本地化模式字符串。
        结果
        本地化模式字符串
        另请参见：
        applyPattern(java.lang.String)

      • applyPattern

        public void applyPattern​(String pattern)
        将给定的模式应用于此Format对象。 模式是各种格式化属性的简短说明。 这些属性也可以通过各种设置方法单独更改。

        这个例程设置的整数数字没有限制，因为这是典型的最终用户期望; 如果要设置实际值，请使用setMaximumInteger。 对于负数，使用第二个模式，用分号分隔

        示例"#,#00.0#"

        这意味着至少2个整数数字，1个分数，最多2个小数位数。

        示例： "#,#00.0#;(#,#00.0#)"用于括号中的负数。

        在负模式中，忽略最小和最大计数; 这些被假定设置为正模式。

        参数
        pattern - 一个新的模式
        异常
        NullPointerException - 如果 pattern为空
        IllegalArgumentException - 如果给定的模式无效。

      • applyLocalizedPattern

        public void applyLocalizedPattern​(String pattern)
        将给定的模式应用于此Format对象。 该模式被假定为局部符号。 模式是各种格式化属性的简短说明。 这些属性也可以通过各种设置方法单独更改。

        这个例程设置的整数数字没有限制，因为这是典型的最终用户期望; 如果要设置实际值，请使用setMaximumInteger。 对于负数，使用第二个模式，用分号分隔

        示例"#,#00.0#" '1,234.56

        这意味着至少2个整数数字，1个分数，最多2个小数位数。

        示例： "#,#00.0#;(#,#00.0#)"用于括号中的否定。

        在负模式中，忽略最小和最大计数; 这些被假定设置为正模式。

        参数
        pattern - 一种新的模式
        异常
        NullPointerException - 如果 pattern为空
        IllegalArgumentException - 如果给定的模式无效。

      • setMaximumIntegerDigits

        public void setMaximumIntegerDigits​(int newValue)
        设置数字的整数部分允许的最大位数。 对于BigInteger和BigDecimal对象之外的格式化数字，使用newValue和309的较低者。 负输入值被替换为0。
        重写：
        setMaximumIntegerDigits在 NumberFormat
        参数
        newValue - 要显示的最大整数位数; 如果小于零，则使用零。 具体的子类可能会强制适用于正在格式化的数字类型的此值的上限。
        另请参见：
        NumberFormat.setMaximumIntegerDigits(int)

      • setMinimumIntegerDigits

        public void setMinimumIntegerDigits​(int newValue)
        设置数字的整数部分允许的最小位数。 对于BigInteger和BigDecimal对象以外的格式化数字，使用newValue和309的较低者。 负输入值被替换为0。
        重写：
        setMinimumIntegerDigits在 NumberFormat
        参数
        newValue - 要显示的最小整数位数; 如果小于零，则使用零。 具体的子类可能会强制适用于正在格式化的数字类型的此值的上限。
        另请参见：
        NumberFormat.setMinimumIntegerDigits(int)

      • setMaximumFractionDigits

        public void setMaximumFractionDigits​(int newValue)
        设置数字小数部分允许的最大位数。 对于BigInteger和BigDecimal对象之外的格式化数字，使用newValue和340的较低者。 负输入值被替换为0。
        重写：
        setMaximumFractionDigits在 NumberFormat
        参数
        newValue - 要显示的最小数字数字; 如果小于零，则使用零。 具体的子类可能会强制适用于正在格式化的数字类型的此值的上限。
        另请参见：
        NumberFormat.setMaximumFractionDigits(int)

      • setMinimumFractionDigits

        public void setMinimumFractionDigits​(int newValue)
        设置数字小数部分允许的最小位数。 对于BigInteger和BigDecimal对象之外的格式化数字，使用newValue和340的较低者。 负输入值被替换为0。
        重写：
        setMinimumFractionDigits在 NumberFormat
        参数
        newValue - 要显示的最小数字数字; 如果小于零，则使用零。 具体的子类可能会强制适用于正在格式化的数字类型的此值的上限。
        另请参见：
        NumberFormat.setMinimumFractionDigits(int)

      • getMaximumIntegerDigits

        public int getMaximumIntegerDigits​()
        获取数字的整数部分允许的最大位数。 对于BigInteger和BigDecimal对象之外的格式化数字，使用返回值的下限和309。
        重写：
        getMaximumIntegerDigits在 NumberFormat
        结果
        最大位数
        另请参见：
        setMaximumIntegerDigits(int)

      • getMinimumIntegerDigits

        public int getMinimumIntegerDigits​()
        获取数字整数部分允许的最小位数。 对于BigInteger和BigDecimal对象之外的格式化数字，使用返回值和309的较低者。
        重写：
        getMinimumIntegerDigits在 NumberFormat
        结果
        最小位数
        另请参见：
        setMinimumIntegerDigits(int)

      • getMaximumFractionDigits

        public int getMaximumFractionDigits​()
        获取数字小数部分中允许的最大位数。 对于BigInteger和BigDecimal对象之外的格式化数字，使用返回值和340的较低者。
        重写：
        getMaximumFractionDigits在 NumberFormat
        结果
        最大位数。
        另请参见：
        setMaximumFractionDigits(int)

      • getMinimumFractionDigits

        public int getMinimumFractionDigits​()
        获取数字小数部分中允许的最小位数。 对于BigInteger和BigDecimal对象之外的格式化数字，使用返回值和340的较低者。
        重写：
        getMinimumFractionDigits在 NumberFormat
        结果
        最小位数
        另请参见：
        setMinimumFractionDigits(int)

      • getCurrency

        public Currency getCurrency​()
        在格式化货币值时获取此十进制格式使用的货币。 货币是通过调用DecimalFormatSymbols.getCurrency这个数字格式的符号获得的。
        重写：
        getCurrency在 NumberFormat
        结果
        该十进制格式使用的货币，或 null
        从以下版本开始：
        1.4

      • setCurrency

        public void setCurrency​(Currency currency)
        设置格式化货币值时此数字格式使用的货币。 这不会更新数字格式使用的小数位数的最小或最大数量。 货币是通过调用DecimalFormatSymbols.setCurrency这个数字格式的符号设置的。
        重写：
        setCurrency在 NumberFormat
        参数
        currency - 这种十进制格式使用的新货币
        异常
        NullPointerException - 如果 currency为空
        从以下版本开始：
        1.4

      • getRoundingMode

        public RoundingMode getRoundingMode​()
        获取此DecimalFormat中使用的RoundingMode 。
        重写：
        getRoundingMode在 NumberFormat
        结果
        RoundingMode用于此DecimalFormat。
        从以下版本开始：
        1.6
        另请参见：
        setRoundingMode(RoundingMode)

      • setRoundingMode

        public void setRoundingMode​(RoundingMode roundingMode)
        设置此DecimalFormat中使用的RoundingMode 。
        重写：
        setRoundingMode在 NumberFormat
        参数
        roundingMode - 要使用的 RoundingMode
        异常
        NullPointerException - 如果 roundingMode为空。
        从以下版本开始：
        1.6
        另请参见：
        getRoundingMode()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DecimalFormatSymbols (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class DecimalFormatSymbols

  • java.lang.Object
    • java.text.DecimalFormatSymbols
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class DecimalFormatSymbols
extends Object
implements Cloneable, Serializable
    此类表示DecimalFormat格式化数字所需的符号集（如小数分隔符，分组分隔符等）。 DecimalFormat为其本身创建一个DecimalFormatSymbols的实例从其区域设置数据。 如果需要更改任何这些符号，可以从DecimalFormat获取DecimalFormatSymbols对象并对其进行修改。
    从以下版本开始：
    1.1
    另请参见：
    Locale ， DecimalFormat ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DecimalFormatSymbols​()
      为默认的 FORMAT区域设置创建一个DecimalFormatSymbols对象。
      DecimalFormatSymbols​(Locale locale)
      为给定的区域设置创建一个DecimalFormatSymbols对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      标准覆盖。
      boolean equals​(Object obj)
      覆盖等于。
      static Locale[] getAvailableLocales​()
      返回一个所有语言环境的数组，该类的 getInstance方法可以返回本地化实例。
      Currency getCurrency​()
      获取这些DecimalFormatSymbols的货币。
      String getCurrencySymbol​()
      返回其区域设置中这些DecimalFormatSymbols的货币的货币符号。
      char getDecimalSeparator​()
      获取用于十进制符号的字符。
      char getDigit​()
      获取用于图案中数字的字符。
      String getExponentSeparator​()
      返回用于将尾数与指数分隔开的字符串。
      char getGroupingSeparator​()
      获取用于千位分隔符的字符。
      String getInfinity​()
      获取用于表示无穷大的字符串。
      static DecimalFormatSymbols getInstance​()
      获取默认语言环境的 DecimalFormatSymbols实例。
      static DecimalFormatSymbols getInstance​(Locale locale)
      获取指定区域设置的 DecimalFormatSymbols实例。
      String getInternationalCurrencySymbol​()
      返回这些DecimalFormatSymbols的货币的ISO 4217货币代码。
      char getMinusSign​()
      获取用于表示减号的字符。
      char getMonetaryDecimalSeparator​()
      返回货币小数分隔符。
      String getNaN​()
      获取用于表示“不是数字”的字符串。
      char getPatternSeparator​()
      获取用于在模式中分离正和负子模式的字符。
      char getPercent​()
      获取用于百分号的字符。
      char getPerMill​()
      获取每个mille标志使用的字符。
      char getZeroDigit​()
      获取用于零的字符。
      int hashCode​()
      覆盖hashCode。
      void setCurrency​(Currency currency)
      设置这些DecimalFormatSymbols的货币。
      void setCurrencySymbol​(String currency)
      在其区域设置中设置这些DecimalFormatSymbols的货币的货币符号。
      void setDecimalSeparator​(char decimalSeparator)
      设置用于十进制符号的字符。
      void setDigit​(char digit)
      设置模式中用于数字的字符。
      void setExponentSeparator​(String exp)
      设置用于将尾数与指数分开的字符串。
      void setGroupingSeparator​(char groupingSeparator)
      设置用于千位分隔符的字符。
      void setInfinity​(String infinity)
      设置用于表示无穷大的字符串。
      void setInternationalCurrencySymbol​(String currencyCode)
      设置这些DecimalFormatSymbols的货币的ISO 4217货币代码。
      void setMinusSign​(char minusSign)
      设置用于表示减号的字符。
      void setMonetaryDecimalSeparator​(char sep)
      设置货币十进制分隔符。
      void setNaN​(String NaN)
      设置用于表示“不是数字”的字符串。
      void setPatternSeparator​(char patternSeparator)
      设置用于在模式中分离正和负子模式的字符。
      void setPercent​(char percent)
      设置用于百分号的字符。
      void setPerMill​(char perMill)
      设置每个mille标志使用的字符。
      void setZeroDigit​(char zeroDigit)
      设置用于零的字符。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DecimalFormatSymbols

        public DecimalFormatSymbols​()
        为默认的FORMAT语言环境创建一个DecimalFormatSymbols对象。 此构造函数只能为Java运行时环境支持的语言环境构建实例，而不是由已安装的27059640152828实现支持的语言环境。 对于完整的区域覆盖，请使用getInstance方法。

        这相当于调用DecimalFormatSymbols(Locale.getDefault(Locale.Category.FORMAT)) 。

        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • DecimalFormatSymbols

        public DecimalFormatSymbols​(Locale locale)
        为给定的区域设置创建一个DecimalFormatSymbols对象。 此构造函数只能为Java运行时环境支持的语言环境构建实例，而不是由已安装的DecimalFormatSymbolsProvider实现支持的语言环境。 对于完整的区域覆盖，请使用getInstance方法。 如果指定的区域设置包含编号系统的Locale.UNICODE_LOCALE_EXTENSION ，则如果JRE实现支持该实例，则使用指定的编号系统初始化该实例。 例如，
          NumberFormat.getNumberInstance(Locale.forLanguageTag("th-TH-u-nu-thai"))
        这可能会返回一个NumberFormat实例与泰国编号系统，而不是拉丁语编号系统。
        参数
        locale - 所需的语言环境
        异常
        NullPointerException - 如果 locale为空

    • 方法详细信息

      • getAvailableLocales

        public static Locale[] getAvailableLocales​()
        返回一个所有语言环境的数组，该类的getInstance方法可以返回本地化实例。 返回的数组表示由Java运行时支持的语言环境和安装的DecimalFormatSymbolsProvider实现的联合。 它必须至少包含Locale实例等于Locale.US 。
        结果
        一组本地化的本地化 DecimalFormatSymbols实例可用。
        从以下版本开始：
        1.6

      • getInstance

        public static final DecimalFormatSymbols getInstance​()
        获取默认语言环境的DecimalFormatSymbols实例。 此方法可以访问由Java运行时本身支持的语言环境的DecimalFormatSymbols实例以及已安装的DecimalFormatSymbolsProvider实现所支持的实例 。

        这相当于调用getInstance(Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        一个 DecimalFormatSymbols实例。
        从以下版本开始：
        1.6
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getInstance

        public static final DecimalFormatSymbols getInstance​(Locale locale)
        获取指定语言环境的DecimalFormatSymbols实例。 此方法提供对Java运行时本身支持的语言环境的DecimalFormatSymbols实例以及已安装的DecimalFormatSymbolsProvider实现支持的实例的访问。 如果指定的区域设置包含编号系统的Locale.UNICODE_LOCALE_EXTENSION ，则如果JRE实现支持该实例，则使用指定的编号系统初始化该实例。 例如，
          NumberFormat.getNumberInstance(Locale.forLanguageTag("th-TH-u-nu-thai"))
        这可能会返回一个NumberFormat实例与泰国编号系统，而不是拉丁语编号系统。
        参数
        locale - 所需的语言环境。
        结果
        一个 DecimalFormatSymbols实例。
        异常
        NullPointerException - 如果 locale为空
        从以下版本开始：
        1.6

      • getZeroDigit

        public char getZeroDigit​()
        获取用于零的字符。 不同于阿拉伯语等
        结果
        字符用于零

      • setZeroDigit

        public void setZeroDigit​(char zeroDigit)
        设置用于零的字符。 不同于阿拉伯语等
        参数
        zeroDigit - 用于零的字符

      • getGroupingSeparator

        public char getGroupingSeparator​()
        获取用于千位分隔符的字符。 不同于法语等
        结果
        分组分隔符

      • setGroupingSeparator

        public void setGroupingSeparator​(char groupingSeparator)
        设置用于千位分隔符的字符。 不同于法语等
        参数
        groupingSeparator - 分组分隔符

      • getDecimalSeparator

        public char getDecimalSeparator​()
        获取用于十进制符号的字符。 不同于法语等
        结果
        用于十进制符号的字符

      • setDecimalSeparator

        public void setDecimalSeparator​(char decimalSeparator)
        设置用于十进制符号的字符。 不同于法语等
        参数
        decimalSeparator - 用于小数符号的字符

      • getPerMill

        public char getPerMill​()
        获取每个mille标志使用的字符。 不同于阿拉伯语等
        结果
        用于每个mille标志的字符

      • setPerMill

        public void setPerMill​(char perMill)
        设置每个mille标志使用的字符。 不同于阿拉伯语等
        参数
        perMill - 用于每个mille标志的字符

      • getPercent

        public char getPercent​()
        获取用于百分号的字符。 不同于阿拉伯语等
        结果
        用于百分号的字符

      • setPercent

        public void setPercent​(char percent)
        设置用于百分号的字符。 不同于阿拉伯语等
        参数
        percent - 用于百分号的字符

      • getDigit

        public char getDigit​()
        获取用于图案中数字的字符。
        结果
        用于图案中数字的字符

      • setDigit

        public void setDigit​(char digit)
        设置模式中用于数字的字符。
        参数
        digit - 用于图案中数字的字符

      • getPatternSeparator

        public char getPatternSeparator​()
        获取用于在模式中分离正和负子模式的字符。
        结果
        模式分隔符

      • setPatternSeparator

        public void setPatternSeparator​(char patternSeparator)
        设置用于在模式中分离正和负子模式的字符。
        参数
        patternSeparator - 模式分隔符

      • getInfinity

        public String getInfinity​()
        获取用于表示无穷大的字符串。 几乎总是保持不变。
        结果
        字符串代表无穷大

      • setInfinity

        public void setInfinity​(String infinity)
        设置用于表示无穷大的字符串。 几乎总是保持不变。
        参数
        infinity - 表示无穷大的字符串

      • getNaN

        public String getNaN​()
        获取用于表示“不是数字”的字符串。 几乎总是保持不变。
        结果
        代表“不是数字”的字符串

      • setNaN

        public void setNaN​(String NaN)
        设置用于表示“不是数字”的字符串。 几乎总是保持不变。
        参数
        NaN - 表示“不是数字”的字符串

      • getMinusSign

        public char getMinusSign​()
        获取用于表示减号的字符。 如果没有指定明确的负格式，则通过将minusSign前缀为正形式形成。
        结果
        字符代表减号

      • setMinusSign

        public void setMinusSign​(char minusSign)
        设置用于表示减号的字符。 如果没有指定明确的负格式，则通过将minusSign前缀为正形式形成。
        参数
        minusSign - 代表减号的字符

      • getCurrencySymbol

        public String getCurrencySymbol​()
        返回其区域设置中这些DecimalFormatSymbols的货币的货币符号。
        结果
        货币符号
        从以下版本开始：
        1.2

      • setCurrencySymbol

        public void setCurrencySymbol​(String currency)
        在其区域设置中设置这些DecimalFormatSymbols的货币的货币符号。
        参数
        currency - 货币符号
        从以下版本开始：
        1.2

      • getInternationalCurrencySymbol

        public String getInternationalCurrencySymbol​()
        返回这些DecimalFormatSymbols的货币的ISO 4217货币代码。
        结果
        货币代码
        从以下版本开始：
        1.2

      • setInternationalCurrencySymbol

        public void setInternationalCurrencySymbol​(String currencyCode)
        设置这些DecimalFormatSymbols的货币的ISO 4217货币代码。 如果货币代码有效（如Currency.getInstance所定义），则还将Currency属性设置为相应的Currency实例，并将货币符号属性设置为DecimalFormatSymbols的区域设置中的货币符号。 如果货币代码无效，则currency属性设置为null，并且不修改货币符号属性。
        参数
        currencyCode - 货币代码
        从以下版本开始：
        1.2
        另请参见：
        setCurrency(java.util.Currency) ， setCurrencySymbol(java.lang.String)

      • getCurrency

        public Currency getCurrency​()
        获取这些DecimalFormatSymbols的货币。 如果货币符号属性先前设置为不是有效的ISO 4217货币代码的值，则可以为null。
        结果
        使用的货币，或空值
        从以下版本开始：
        1.4

      • setCurrency

        public void setCurrency​(Currency currency)
        设置这些DecimalFormatSymbols的货币。 这也将货币符号属性设置为DecimalFormatSymbols'区域设置中的货币符号，并将货币符号属性设置为货币的ISO 4217货币代码。
        参数
        currency - 要使用的新货币
        异常
        NullPointerException - 如果 currency为空
        从以下版本开始：
        1.4
        另请参见：
        setCurrencySymbol(java.lang.String) ， setInternationalCurrencySymbol(java.lang.String)

      • getMonetaryDecimalSeparator

        public char getMonetaryDecimalSeparator​()
        返回货币小数分隔符。
        结果
        货币小数分隔符
        从以下版本开始：
        1.2

      • setMonetaryDecimalSeparator

        public void setMonetaryDecimalSeparator​(char sep)
        设置货币十进制分隔符。
        参数
        sep - 货币十进制分隔符
        从以下版本开始：
        1.2

      • getExponentSeparator

        public String getExponentSeparator​()
        返回用于将尾数与指数分隔开的字符串。 示例：1.23×10 ^ 4的“x10 ^”，1.23E4的“E”。
        结果
        指数分隔符串
        从以下版本开始：
        1.6
        另请参见：
        setExponentSeparator(java.lang.String)

      • setExponentSeparator

        public void setExponentSeparator​(String exp)
        设置用于将尾数与指数分开的字符串。 示例：1.23×10 ^ 4的“x10 ^”，1.23E4的“E”。
        参数
        exp - 指数分隔符字符串
        异常
        NullPointerException - 如果 exp为空
        从以下版本开始：
        1.6
        另请参见：
        getExponentSeparator()

      • clone

        public Object clone​()
        标准覆盖。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • equals

        public boolean equals​(Object obj)
        覆盖等于。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        覆盖hashCode。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FieldPosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class FieldPosition

  • java.lang.Object
    • java.text.FieldPosition

  • public class FieldPosition
extends Object
    FieldPosition是由Format及其子类使用的简单类，用于标识格式化输出中的字段。 可以通过两种方式识别字段：
    • 一个整数常数，其名称通常以_FIELD 。 这些常数在Format的各个子类中Format 。
    • 以Format.Field常数，见ERA_FIELD及其朋友在DateFormat为例。

    FieldPosition使用两个索引来跟踪格式化输出中的字段的位置：字段的第一个字符的索引和字段的最后一个字符的索引。

    在各种Format类中的一个版本的format方法需要一个FieldPosition对象作为参数。 您可以使用此format方法执行部分格式化或获取有关格式化输出的信息（例如字段的位置）。

    如果您对格式化字符串中所有属性的位置感兴趣，请使用Format方法formatToCharacterIterator 。

    从以下版本开始：
    1.1
    另请参见：
    Format

    • 构造方法摘要

      构造方法
      Constructor 描述
      FieldPosition​(int field)
      为给定字段创建一个FieldPosition对象。
      FieldPosition​(Format.Field attribute)
      为给定的字段常量创建一个FieldPosition对象。
      FieldPosition​(Format.Field attribute, int fieldID)
      为给定字段创建一个 FieldPosition对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      覆盖等于
      int getBeginIndex​()
      检索请求字段中第一个字符的索引。
      int getEndIndex​()
      检索请求字段中最后一个字符后的字符索引。
      int getField​()
      检索字段标识符。
      Format.Field getFieldAttribute​()
      从 Field子类之一返回字段标识符作为属性常量。
      int hashCode​()
      返回此FieldPosition的哈希码。
      void setBeginIndex​(int bi)
      设置开始索引。
      void setEndIndex​(int ei)
      设置结束索引。
      String toString​()
      返回此FieldPosition的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FieldPosition

        public FieldPosition​(int field)
        为给定字段创建一个FieldPosition对象。 字段由常量来标识，其名称通常以_FIELD结尾，格式的各种子类中。
        参数
        field - 字段标识符
        另请参见：
        NumberFormat.INTEGER_FIELD ， NumberFormat.FRACTION_FIELD ， DateFormat.YEAR_FIELD ， DateFormat.MONTH_FIELD

      • FieldPosition

        public FieldPosition​(Format.Field attribute)
        为给定的字段常量创建一个FieldPosition对象。 字段由各种Format子类中定义的常量来标识。 这相当于拨打new FieldPosition(attribute, -1) 。
        参数
        attribute - Format.Field常量标识字段
        从以下版本开始：
        1.4

      • FieldPosition

        public FieldPosition​(Format.Field attribute,
                     int fieldID)
        为给定字段创建一个FieldPosition对象。 该字段由Field子类之一的属性常量以及由Format子类定义的整数字段ID标识。 Format子类都知道Field应该要优先attribute而忽略fieldID如果attribute不为空。 但是，较旧的Format子类可能不知道Field并依赖于fieldID 。 如果该字段没有相应的整数常数，则fieldID应为-1。
        参数
        attribute - Format.Field常量标识字段
        fieldID - 标识字段的整数常量
        从以下版本开始：
        1.4

    • 方法详细信息

      • getFieldAttribute

        public Format.Field getFieldAttribute​()
        从Field子类之一返回字段标识符作为属性常量。 如果字段仅由整数字段ID指定，则可能返回null。
        结果
        字段的标识符
        从以下版本开始：
        1.4

      • getField

        public int getField​()
        检索字段标识符。
        结果
        字段标识符

      • getBeginIndex

        public int getBeginIndex​()
        检索请求字段中第一个字符的索引。
        结果
        开始索引

      • getEndIndex

        public int getEndIndex​()
        检索请求字段中最后一个字符后的字符索引。
        结果
        最终索引

      • setBeginIndex

        public void setBeginIndex​(int bi)
        设置开始索引。 供格式的子类使用。
        参数
        bi - 开始索引
        从以下版本开始：
        1.2

      • setEndIndex

        public void setEndIndex​(int ei)
        设置结束索引。 供格式的子类使用。
        参数
        ei - 结束索引
        从以下版本开始：
        1.2

      • equals

        public boolean equals​(Object obj)
        覆盖等于
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此FieldPosition的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此FieldPosition的字符串表示形式。
        重写：
        toString在 Object
        结果
        该对象的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Format (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class Format

  • java.lang.Object
    • java.text.Format
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    DateFormat ， MessageFormat ， NumberFormat

    public abstract class Format
extends Object
implements Serializable, Cloneable
    Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。

    Format定义编程接口，用于格式化语言环境敏感的对象到String秒（ format法），用于解析String背部进入对象（ parseObject方法）。

    通常，格式的parseObject方法必须能够解析其format方法格式化的任何字符串。 但是，这是不可能的例外情况。 例如，一个format方法可能创建两个相邻的整数，其间没有分隔符，在这种情况下， parseObject无法确定哪个数字属于哪个数字。

    子类

    Java平台提供的三个专业小类Format - DateFormat ， MessageFormat ，并NumberFormat分别──为格式化日期，消息和数字，。

    具体的子类必须实现三种方法：

    1. format(Object obj, StringBuffer toAppendTo, FieldPosition pos)
    2. formatToCharacterIterator(Object obj)
    3. parseObject(String source, ParsePosition pos)
    这些一般方法允许对象进行多态解析和格式化，例如使用MessageFormat 。 子类通常还为特定输入类型提供额外的format方法以及特定结果类型的parse方法。 任何不使用ParsePosition参数的parse方法应该在输入文本开头没有任何文本的情况下抛出ParseException 。

    大多数子类也将实现以下工厂方法：

    1. getInstance获取适合当前语言环境的有用的格式对象
    2. getInstance(Locale)获取适用于指定语言环境的有用的格式对象
    另外，一些子类也可以实现其他getXxxxInstance方法来进行更专门的控制。 例如， NumberFormat类提供getPercentInstance和getCurrencyInstance方法来获取专门的数字格式化程序。

    Format子类允许程序员为语言环境创建对象（例如使用getInstance(Locale) ）还必须实现以下类方法：

     public static Locale[] getAvailableLocales()

    最后，子类可以定义一组常量来标识格式化输出中的各种字段。 这些常量用于创建一个FieldPosition对象，它识别字段中包含的信息及其在格式化结果中的位置。 这些常数应该命名为item_FIELD ，其中item标识字段。 有关这些常量的例子，请参阅ERA_FIELD及其朋友在DateFormat 。

    Synchronization

    格式通常不同步。 建议为每个线程创建单独的格式实例。 如果多个线程同时访问格式，则必须在外部进行同步。

    从以下版本开始：
    1.1
    另请参见：
    ParsePosition ， FieldPosition ， NumberFormat ， DateFormat ， MessageFormat ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Format.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 Format.formatToCharacterIterator和字段标识符在 FieldPosition 。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Format​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建并返回此对象的副本。
      String format​(Object obj)
      格式化一个对象来生成一个字符串。
      abstract StringBuffer format​(Object obj, StringBuffer toAppendTo, FieldPosition pos)
      格式化对象并将生成的文本附加到给定的字符串缓冲区。
      AttributedCharacterIterator formatToCharacterIterator​(Object obj)
      格式化一个对象，生成一个 AttributedCharacterIterator 。
      Object parseObject​(String source)
      从给定字符串的开头解析文本以产生一个对象。
      abstract Object parseObject​(String source, ParsePosition pos)
      从字符串中解析文本以生成对象。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Format

        protected Format​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • format

        public final String format​(Object obj)
        格式化一个对象来生成一个字符串。 这相当于
        format (obj, new StringBuffer(), new FieldPosition(0)).toString();
        参数
        obj - 要格式化的对象
        结果
        格式化的字符串。
        异常
        IllegalArgumentException - 如果格式化不能格式化给定的对象

      • format

        public abstract StringBuffer format​(Object obj,
                                    StringBuffer toAppendTo,
                                    FieldPosition pos)
        格式化对象并将生成的文本附加到给定的字符串缓冲区。 如果pos参数标识格式使用的字段，则其索引将设置为遇到的第一个此类字段的开头和结尾。
        参数
        obj - 要格式化的对象
        toAppendTo - 要附加文本的位置
        pos - 标识格式化文本中的字段的 FieldPosition
        结果
        字符串缓冲区作为 toAppendTo ，附带格式化的文本
        异常
        NullPointerException - 如果 toAppendTo或 pos为空
        IllegalArgumentException - 如果格式化不能格式化给定的对象

      • formatToCharacterIterator

        public AttributedCharacterIterator formatToCharacterIterator​(Object obj)
        格式化产生一个AttributedCharacterIterator的对象。 您可以使用返回的AttributedCharacterIterator构建生成的字符串，以及确定有关生成的字符串的信息。

        AttributedCharacterIterator的每个属性键将为Field类型。 它是由每Format实现定义什么合法的值是在每个属性AttributedCharacterIterator ，但通常属性键也用作属性值。

        默认实现创建一个没有属性的AttributedCharacterIterator 。 支持字段的子类应该覆盖此，并创建一个具有有意义属性的AttributedCharacterIterator 。

        参数
        obj - 要格式化的对象
        结果
        AttributedCharacterIterator描述格式化的值。
        异常
        NullPointerException - 如果obj为空。
        IllegalArgumentException - 格式化格式化给定对象时。
        从以下版本开始：
        1.4

      • parseObject

        public abstract Object parseObject​(String source,
                                   ParsePosition pos)
        从字符串中解析文本以生成对象。

        该方法尝试从pos给出的索引开始解析文本。 如果解析成功，则pos的索引将更新为使用最后一个字符后的索引（解析不一定使用字符串末尾的所有字符），并返回已解析的对象。 更新的pos可用于指示下一次调用此方法的起始点。 如果发生错误，则pos的索引不会更改，错误索引pos设置为发生错误的字符的索引，返回null。

        参数
        source - A String ，其中的一部分应该被解析。
        pos - 具有 ParsePosition索引和错误索引信息的 ParsePosition对象。
        结果
        一个Object从字符串解析。 万一出错，返回null。
        异常
        NullPointerException - 如果 source或 pos为空。

      • parseObject

        public Object parseObject​(String source)
                   throws ParseException
        从给定字符串的开头解析文本以产生一个对象。 该方法可能不会使用给定字符串的整个文本。
        参数
        source - A String其开头应该被解析。
        结果
        一个 Object从字符串中解析出来。
        异常
        ParseException - 如果指定字符串的开头不能被解析。
        NullPointerException - 如果 source为空。

      • clone

        public Object clone​()
        创建并返回此对象的副本。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Format.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class Format.Field

  • java.lang.Object
    • java.text.AttributedCharacterIterator.Attribute
      • java.text.Format.Field
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    DateFormat.Field ， MessageFormat.Field ， NumberFormat.Field
    Enclosing class:
    Format

    public static class Format.Field
extends AttributedCharacterIterator.Attribute
    定义了用于作为属性键常数 AttributedCharacterIterator从返回 Format.formatToCharacterIterator和字段标识符在 FieldPosition 。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.text.AttributedCharacterIterator.Attribute

        INPUT_METHOD_SEGMENT, LANGUAGE, READING

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Field​(String name)
      用指定的名称创建一个字段。

    • 方法摘要

      • Methods inherited from class java.text.AttributedCharacterIterator.Attribute

        equals, getName, hashCode, readResolve, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Field

        protected Field​(String name)
        用指定的名称创建一个字段。
        参数
        name - 属性名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.text (Java SE 9 & JDK 9 )

java.text

Interfaces

  • AttributedCharacterIterator
  • CharacterIterator

Classes

  • Annotation
  • AttributedCharacterIterator.Attribute
  • AttributedString
  • Bidi
  • BreakIterator
  • ChoiceFormat
  • CollationElementIterator
  • CollationKey
  • Collator
  • DateFormat
  • DateFormat.Field
  • DateFormatSymbols
  • DecimalFormat
  • DecimalFormatSymbols
  • FieldPosition
  • Format
  • Format.Field
  • MessageFormat
  • MessageFormat.Field
  • Normalizer
  • NumberFormat
  • NumberFormat.Field
  • ParsePosition
  • RuleBasedCollator
  • SimpleDateFormat
  • StringCharacterIterator

Enums

  • Normalizer.Form

Exceptions

  • ParseException


java.text (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.text

提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。 这意味着您的主要应用程序或小程序可以写成与语言无关的，并且它可以依赖于单独的，动态链接的本地化资源。 这允许在任何时候为新的本地化添加本地化的灵活性。

这些类能够格式化日期，数字和消息，解析; 搜索和排序字符串; 并对字符，单词，句子和换行符进行迭代。 该包包含三个主要的类和接口组：

  • 用于文本迭代的类
  • 用于格式化和解析的类
  • 字符串归类的类
从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    AttributedCharacterIterator
    一个 AttributedCharacterIterator允许通过文本和相关的属性信息进行迭代。
    CharacterIterator
    该接口定义了一种用于文本双向迭代的协议。
  • 类摘要
    Class 描述
    Annotation
    如果属性具有注释特征，则Annotation对象用作文本属性值的包装器。
    AttributedCharacterIterator.Attribute
    定义用于标识文本属性的属性键。
    AttributedString
    AttributedString保存文本和相关属性信息。
    Bidi
    该类实现了Unicode双向算法。
    BreakIterator
    BreakIterator类实现了在文本中查找边界位置的方法。
    ChoiceFormat
    A ChoiceFormat允许您将格式附加到数字范围。
    CollationElementIterator
    CollationElementIterator类用作迭代器来遍历国际字符串的每个字符。
    CollationKey
    A CollationKey代表一个 String根据一个特定的 Collator对象的规则。
    Collator
    Collator类执行区域设置敏感的 String比较。
    DateFormat
    DateFormat是日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。
    DateFormat.Field
    定义了用于作为属性键常数 AttributedCharacterIterator从返回 DateFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
    DateFormatSymbols
    DateFormatSymbols是用于封装可本地化的日期时间格式化数据的公共类，例如月份的名称，星期几的名称和时区数据。
    DecimalFormat
    DecimalFormat是格式为十进制数的 NumberFormat的具体子类。
    DecimalFormatSymbols
    此类表示 DecimalFormat格式化数字所需的符号集（如小数分隔符，分组分隔符等）。
    FieldPosition
    FieldPosition是由 Format及其子类使用的简单类，用于标识格式化输出中的字段。
    Format
    Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
    Format.Field
    定义了用于作为属性键常数 AttributedCharacterIterator从返回 Format.formatToCharacterIterator和字段标识符在 FieldPosition 。
    MessageFormat
    MessageFormat提供了一种以语言中立的方式产生级联消息的方法。
    MessageFormat.Field
    定义从 MessageFormat.formatToCharacterIterator返回的 AttributedCharacterIterator中用作属性键的 MessageFormat.formatToCharacterIterator 。
    Normalizer
    该类提供了方法 normalize ，它将Unicode文本转换为等效的组合或分解形式，从而更容易对文本进行排序和搜索。
    NumberFormat
    NumberFormat是所有数字格式的抽象基类。
    NumberFormat.Field
    定义了用于作为属性键常数 AttributedCharacterIterator从返回 NumberFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
    ParsePosition
    ParsePosition是一个简单的类，由 Format及其子类使用，用于在解析过程中跟踪当前位置。
    RuleBasedCollator
    所述 RuleBasedCollator类是的具体子类 Collator ，提供了一个简单的，数据驱动的表collator。
    SimpleDateFormat
    SimpleDateFormat是一种具体的类，用于以区域设置敏感的方式格式化和解析日期。
    StringCharacterIterator
    StringCharacterIterator实现 CharacterIterator协议为 String 。
  • 枚举摘要
    Enum 描述
    Normalizer.Form
    此枚举提供了 Unicode Standard Annex #15 — Unicode Normalization Forms中描述的四个Unicode规范化表单的常量，以及访问它们的两种方法。
  • 异常摘要
    异常 描述
    ParseException
    Signals that an error has been reached unexpectedly while parsing.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.text Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.text

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.text.Annotation
    • java.text.AttributedCharacterIterator.Attribute (implements java.io.Serializable)
      • java.text.Format.Field
        • java.text.DateFormat.Field
        • java.text.MessageFormat.Field
        • java.text.NumberFormat.Field
    • java.text.AttributedString
    • java.text.Bidi
    • java.text.BreakIterator (implements java.lang.Cloneable)
    • java.text.CollationElementIterator
    • java.text.CollationKey (implements java.lang.Comparable<T>)
    • java.text.Collator (implements java.lang.Cloneable, java.util.Comparator<T>)
      • java.text.RuleBasedCollator
    • java.text.DateFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • java.text.DecimalFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • java.text.FieldPosition
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
      • java.text.MessageFormat
      • java.text.NumberFormat
        • java.text.ChoiceFormat
        • java.text.DecimalFormat
    • java.text.Normalizer
    • java.text.ParsePosition
    • java.text.StringCharacterIterator (implements java.text.CharacterIterator)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.text.ParseException

Interface Hierarchy

  • java.lang.Cloneable
    • java.text.CharacterIterator
      • java.text.AttributedCharacterIterator

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.text.Normalizer.Form
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


MessageFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class MessageFormat

  • java.lang.Object
    • java.text.Format
      • java.text.MessageFormat
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class MessageFormat
extends Format
    MessageFormat提供了一种以语言中立的方式产生级联消息的方法。 使用它来构建为最终用户显示的消息。

    MessageFormat采取一组对象，对它们进行格式化，然后将格式化的字符串插入到适当位置的模式中。

    注意： MessageFormat与其他Format类别不同之处在于，您创建一个MessageFormat对象，其中一个构造函数（不是使用getInstance样式工厂方法）。 工厂方法不是必需的，因为MessageFormat本身不实现区域设置特定的行为。 任何特定于语言环境的行为都由您提供的模式以及用于插入参数的子格式定义。

    Patterns and Their Interpretation

    MessageFormat使用以下形式的模式：
     MessageFormatPattern:
         String
         MessageFormatPattern FormatElement String

 FormatElement:
         { ArgumentIndex }
         { ArgumentIndex , FormatType }
         { ArgumentIndex , FormatType , FormatStyle }

 FormatType: one of
         number date time choice

 FormatStyle:
         short
         medium
         long
         full
         integer
         currency
         percent
         SubformatPattern

    在字符串中 ，可以使用一对单引号来引用除单引号以外的任何字符。 例如，模式字符串"'{0}'"表示字符串"{0}"而不是FormatElement 。 单引号本身必须用整个字符串中的双引号''表示。 例如，模式字符串"'{''}'"被解释为序列'{ （起始引号和左大括号）， '' （单引号）和}' （右括号括号和引号结尾）， 而不是 '{'和'}' （引用左右大括号）：代表字符串"{'}" ， 而不是 "{}" 。

    SubformatPattern由其对应的子格式解释，并且子格式依赖模式规则适用。 例如，模式字符串"{1,number,$'#',##}" （SubformatPattern用下划线）会产生与井号的数字格式引述，具有结果如： "$#31,45" 。 有关详细信息，请参阅每个Format子类文档。

    任何不匹配的报价在给定模式结束时被视为关闭。 例如，图案字符串"'{0}"被视为图案"'{0}'" 。

    任何不引用花样的花括号必须平衡。 例如， "ab {0} de"和"ab '}' de"是有效的模式，但"ab {0'}' de" ， "ab } de"和"''{''"都没有。

    警告：
    不幸的是，消息格式模式中使用引号的规则显得有些混乱。 特别是，地方主义者并不总是明确单引号是否需要加倍。 确保通知本地化程序有关规则，并告知他们（例如，通过使用资源包源文件中的注释） MessageFormat处理哪些字符串。 请注意，本地化程序可能需要在原始版本没有转换的字符串中使用单引号。

    ArgumentIndex值是使用数字'0'至'9'写入的非负整数，并表示传递给format方法的arguments数组的索引或由parse方法返回的结果数组。

    FormatType和FormatStyle值用于为format元素创建一个Format实例。 下表显示了值映射到Format实例。 表中未显示的组合是非法的。 SubformatPattern必须是使用的Format子类的有效模式字符串。

    Shows how FormatType and FormatStyle values map to Format instances FormatType FormatStyle Subformat Created (none) (none) null number (none) NumberFormat.getInstance (getLocale()) integer NumberFormat.getIntegerInstance (getLocale()) currency NumberFormat.getCurrencyInstance (getLocale()) percent NumberFormat.getPercentInstance (getLocale()) SubformatPattern new DecimalFormat (subformatPattern, DecimalFormatSymbols.getInstance (getLocale())) date (none) DateFormat.getDateInstance ( DateFormat.DEFAULT , getLocale()) short DateFormat.getDateInstance ( DateFormat.SHORT , getLocale()) medium DateFormat.getDateInstance ( DateFormat.DEFAULT , getLocale()) long DateFormat.getDateInstance ( DateFormat.LONG , getLocale()) full DateFormat.getDateInstance ( DateFormat.FULL , getLocale()) SubformatPattern new SimpleDateFormat (subformatPattern, getLocale()) time (none) DateFormat.getTimeInstance ( DateFormat.DEFAULT , getLocale()) short DateFormat.getTimeInstance ( DateFormat.SHORT , getLocale()) medium DateFormat.getTimeInstance ( DateFormat.DEFAULT , getLocale()) long DateFormat.getTimeInstance ( DateFormat.LONG , getLocale()) full DateFormat.getTimeInstance ( DateFormat.FULL , getLocale()) SubformatPattern new SimpleDateFormat (subformatPattern, getLocale()) choice SubformatPattern new ChoiceFormat (subformatPattern)

    使用信息

    以下是一些使用示例。 在真正的国际化程序中，消息格式模式和其他静态字符串当然将从资源束中获取。 其他参数将在运行时动态确定。

    第一个例子使用静态方法MessageFormat.format ，内部创建一个MessageFormat一次性使用：

     int planet = 7;
 String event = "a disturbance in the Force";

 String result = MessageFormat.format(
     "At {1,time} on {1,date}, there was {2} on planet {0,number,integer}.",
     planet, new Date(), event);
    输出为：
     At 12:30 PM on Jul 3, 2053, there was a disturbance in the Force on planet 7.

    以下示例创建可重复使用的MessageFormat实例：

     int fileCount = 1273;
 String diskName = "MyDisk";
 Object[] testArgs = {new Long(fileCount), diskName};

 MessageFormat form = new MessageFormat(
     "The disk \"{1}\" contains {0} file(s).");

 System.out.println(form.format(testArgs));
    fileCount不同值的输出：
     The disk "MyDisk" contains 0 file(s).
 The disk "MyDisk" contains 1 file(s).
 The disk "MyDisk" contains 1,273 file(s).

    对于更复杂的模式，您可以使用ChoiceFormat为单数和复数生成正确的形式：

     MessageFormat form = new MessageFormat("The disk \"{1}\" contains {0}.");
 double[] filelimits = {0,1,2};
 String[] filepart = {"no files","one file","{0,number} files"};
 ChoiceFormat fileform = new ChoiceFormat(filelimits, filepart);
 form.setFormatByArgumentIndex(0, fileform);

 int fileCount = 1273;
 String diskName = "MyDisk";
 Object[] testArgs = {new Long(fileCount), diskName};

 System.out.println(form.format(testArgs));
    输出值与fileCount不同：
     The disk "MyDisk" contains no files.
 The disk "MyDisk" contains one file.
 The disk "MyDisk" contains 1,273 files.

    您可以通过编程方式创建ChoiceFormat ，如上例所示，或使用模式。 有关详细信息，请参阅ChoiceFormat 。

 form.applyPattern(
    "There {0,choice,0#are no files|1#is one file|1<are {0,number,integer} files}.");

    注意：如上所述，由ChoiceFormat中的MessageFormat生成的字符串被视为特殊MessageFormat ; “{”的出现用于表示子格式，并导致递归。 如果您以编程方式创建MessageFormat和ChoiceFormat （而不是使用字符串模式），那么请注意不要产生自身递归的格式，这将导致无限循环。

    当单个参数在字符串中被多次解析时，最后一个匹配将是解析的最终结果。 例如，

     MessageFormat mf = new MessageFormat("{0,number,#.##}, {0,number,#.#}");
 Object[] objs = {new Double(3.1415)};
 String result = mf.format( objs );
 // result now equals "3.14, 3.1"
 objs = null;
 objs = mf.parse(result, new ParsePosition(0));
 // objs now equals {new Double(3.1)}

    同样，使用包含多个相同参数的模式的对象使用MessageFormat对象进行解析将返回最后一个匹配项。 例如，

     MessageFormat mf = new MessageFormat("{0}, {0}, {0}");
 String forParsing = "x, y, z";
 Object[] objs = mf.parse(forParsing, new ParsePosition(0));
 // result now equals {new String("z")}

    Synchronization

    消息格式不同步。 建议为每个线程创建单独的格式实例。 如果多个线程同时访问格式，则必须在外部进行同步。

    从以下版本开始：
    1.1
    另请参见：
    Locale ， Format ， NumberFormat ， DecimalFormat ， DecimalFormatSymbols ， ChoiceFormat ， DateFormat ， SimpleDateFormat ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  MessageFormat.Field
      定义从 MessageFormat.formatToCharacterIterator返回的 AttributedCharacterIterator中用作属性键的 MessageFormat.formatToCharacterIterator 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      MessageFormat​(String pattern)
      为默认的 FORMAT区域设置和指定的模式构造一个MessageFormat。
      MessageFormat​(String pattern, Locale locale)
      为指定的区域设置和模式构造一个MessageFormat。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyPattern​(String pattern)
      设置此消息格式使用的模式。
      Object clone​()
      创建并返回此对象的副本。
      boolean equals​(Object obj)
      两个消息格式对象之间的平等比较
      StringBuffer format​(Object[] arguments, StringBuffer result, FieldPosition pos)
      格式化一个对象数组，并将 MessageFormat的格式（格式化元素替换为格式化对象） StringBuffer到所提供的 StringBuffer 。
      StringBuffer format​(Object arguments, StringBuffer result, FieldPosition pos)
      格式化一组对象，并将 MessageFormat的格式（格式化元素替换为格式化对象） StringBuffer到所提供的 StringBuffer 。
      static String format​(String pattern, Object... arguments)
      使用给定的模式创建一个MessageFormat，并使用它来格式化给定的参数。
      AttributedCharacterIterator formatToCharacterIterator​(Object arguments)
      格式化一组对象，并将它们插入到 MessageFormat的模式中，生成一个 AttributedCharacterIterator 。
      Format[] getFormats​()
      获取用于先前设置的模式字符串中的格式元素的格式。
      Format[] getFormatsByArgumentIndex​()
      获取用于传递到 format方法中的值的格式或从 parse方法返回的 parse 。
      Locale getLocale​()
      获取创建或比较子格式时使用的区域设置。
      int hashCode​()
      生成消息格式对象的哈希码。
      Object[] parse​(String source)
      从给定字符串的开头解析文本以产生一个对象数组。
      Object[] parse​(String source, ParsePosition pos)
      解析字符串。
      Object parseObject​(String source, ParsePosition pos)
      从字符串中解析文本以生成对象数组。
      void setFormat​(int formatElementIndex, Format newFormat)
      设置在先前设置的模式字符串中使用具有给定格式元素索引的格式元素的格式。
      void setFormatByArgumentIndex​(int argumentIndex, Format newFormat)
      设置使用给定参数索引的先前设置的模式字符串中的格式元素的格式。
      void setFormats​(Format[] newFormats)
      设置用于先前设置的模式字符串中的格式元素的格式。
      void setFormatsByArgumentIndex​(Format[] newFormats)
      设置用于传递给 format方法或从 parse方法返回的值的格式。
      void setLocale​(Locale locale)
      设置创建或比较子格式时要使用的区域设置。
      String toPattern​()
      返回表示消息格式的当前状态的模式。

      • Methods inherited from class java.text.Format

        format, parseObject

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MessageFormat

        public MessageFormat​(String pattern)
        为默认的FORMAT区域设置和指定的模式构造一个MessageFormat。 构造函数首先设置区域设置，然后解析模式，并为其中包含的格式元素创建一个子格式列表。 模式及其解释在class description中规定。
        参数
        pattern - 此消息格式的模式
        异常
        IllegalArgumentException - 如果模式无效
        NullPointerException - 如果 pattern是 null

      • MessageFormat

        public MessageFormat​(String pattern,
                     Locale locale)
        为指定的区域设置和模式构造一个MessageFormat。 构造函数首先设置区域设置，然后解析模式，并为其中包含的格式元素创建一个子格式列表。 模式及其解释在class description中规定。
        参数
        pattern - 此消息格式的模式
        locale - 此消息格式的区域设置
        异常
        IllegalArgumentException - 如果模式无效
        NullPointerException - 如果 pattern是 null
        从以下版本开始：
        1.4

    • 方法详细信息

      • setLocale

        public void setLocale​(Locale locale)
        设置创建或比较子格式时要使用的区域设置。 这将影响后续呼叫
        • 到applyPattern和toPattern方法，如果格式元素指定格式类型，因此具有在applyPattern方法中创建的子格式，以及
        • 到format和formatToCharacterIterator方法，如果格式元素不指定格式类型，因此在格式化方法中创建子格式。
        已创建的子格式不受影响。
        参数
        locale - 创建或比较子格式时要使用的区域设置

      • getLocale

        public Locale getLocale​()
        获取创建或比较子格式时使用的区域设置。
        结果
        创建或比较子格式时使用的区域设置

      • applyPattern

        public void applyPattern​(String pattern)
        设置此消息格式使用的模式。 该方法解析模式，并为其中包含的格式元素创建一个子格式列表。 模式及其解释在class description中规定。
        参数
        pattern - 此消息格式的模式
        异常
        IllegalArgumentException - 如果模式无效
        NullPointerException - 如果 pattern是 null

      • toPattern

        public String toPattern​()
        返回表示消息格式的当前状态的模式。 该字符串由内部信息构成，因此不一定等于之前应用的模式。
        结果
        表示消息格式的当前状态的模式

      • setFormatsByArgumentIndex

        public void setFormatsByArgumentIndex​(Format[] newFormats)
        设置用于传递给format方法或从parse方法返回的值的格式。 newFormats中元素的newFormats对应于在先前设置的模式字符串中使用的参数索引。 的格式中的顺序newFormats因此对应于在元素的顺序arguments阵列传递给format方法或由所述返回的结果阵列parse方法。

        如果一个参数索引用于模式字符串中的多个格式元素，则相应的新格式将用于所有这些格式元素。 如果模式字符串中的任何格式元素都不使用参数索引，则忽略相应的新格式。 如果提供的格式比所需的格式少，那么仅替换小于newFormats.length参数索引的格式被替换。

        参数
        newFormats - 要使用的新格式
        异常
        NullPointerException - 如果 newFormats为空
        从以下版本开始：
        1.4

      • setFormats

        public void setFormats​(Format[] newFormats)
        设置用于先前设置的模式字符串中的格式元素的格式。 newFormats中格式的newFormats对应于模式字符串中的格式元素的顺序。

        如果模式字符串所需的格式多于其他格式，则忽略其余格式。 如果提供的格式少于所需的格式，则仅替换第一个newFormats.length格式。

        由于模式字符串中的格式元素的顺序通常在本地化期间发生变化，因此通常最好使用setFormatsByArgumentIndex方法，该方法假定与arguments数组中的元素的顺序相对应的格式顺序传递给format方法或结果数组由parse方法归还。

        参数
        newFormats - 要使用的新格式
        异常
        NullPointerException - 如果 newFormats为空

      • setFormatByArgumentIndex

        public void setFormatByArgumentIndex​(int argumentIndex,
                                     Format newFormat)
        设置使用给定参数索引的先前设置的模式字符串中的格式元素的格式。 参数索引是格式元素定义的一部分，并且表示传递给format方法的arguments数组的索引或由parse方法返回的结果数组。

        如果参数索引用于模式字符串中的多个格式元素，则新格式将用于所有此类格式元素。 如果参数索引不用于模式字符串中的任何格式元素，则将忽略新格式。

        参数
        argumentIndex - 要使用新格式的参数索引
        newFormat - 使用的新格式
        从以下版本开始：
        1.4

      • setFormat

        public void setFormat​(int formatElementIndex,
                      Format newFormat)
        设置在先前设置的模式字符串中使用具有给定格式元素索引的格式元素的格式。 格式元素索引是从模式字符串开始计数的格式元素的从零开始的数字。

        由于模式字符串中的格式元素的顺序通常在本地化期间发生变化，所以通常最好使用setFormatByArgumentIndex方法，该方法根据它们指定的参数索引来访问格式元素。

        参数
        formatElementIndex - 模式中格式元素的索引
        newFormat - 用于指定格式元素的格式
        异常
        ArrayIndexOutOfBoundsException - 如果 formatElementIndex等于或大于模式字符串中格式元素的数量

      • getFormatsByArgumentIndex

        public Format[] getFormatsByArgumentIndex​()
        获取用于传递给format方法的值或从parse方法返回的parse 。 返回数组中元素的索引对应于先前设置的模式字符串中使用的参数索引。 的返回的数组中的格式的顺序因此对应于在元素的顺序arguments阵列传递给format方法或由所述返回的结果阵列parse方法。

        如果模式字符串中的多个格式元素使用参数索引，则在数组中返回用于最后一个格式元素的格式。 如果模式字符串中的任何格式元素都不使用参数索引，则在数组中返回null。

        结果
        用于模式中参数的格式
        从以下版本开始：
        1.4

      • getFormats

        public Format[] getFormats​()
        获取用于先前设置的模式字符串中的格式元素的格式。 返回数组中格式的顺序对应于模式字符串中格式元素的顺序。

        由于模式字符串中的格式元素的顺序通常在本地化期间发生变化，所以通常最好使用getFormatsByArgumentIndex方法，该方法假定与arguments数组中的元素的顺序相对应的格式顺序传递给format方法或返回的结果数组通过parse方法。

        结果
        用于格式元素格式的格式

      • format

        public final StringBuffer format​(Object[] arguments,
                                 StringBuffer result,
                                 FieldPosition pos)
        格式化一个对象数组，并将MessageFormat的格式附加到格式化对象的格式元素到所提供的StringBuffer 。

        代替各个格式元素的文本是从格式元素的当前子格式和格式元素参数索引处的arguments元素派生的，如下表第一个匹配行所示。 如果arguments为null或少于argumentIndex + 1元素，则参数不可用 。

        Examples of subformat,argument,and formatted text Subformat Argument Formatted Text any unavailable "{" + argumentIndex + "}" any null "null" instanceof ChoiceFormat any subformat.format(argument).indexOf('{') >= 0 ?
        (new MessageFormat(subformat.format(argument), getLocale())).format(argument) : subformat.format(argument)         != null any subformat.format(argument) null instanceof Number NumberFormat.getInstance(getLocale()).format(argument) null instanceof Date DateFormat.getDateTimeInstance(DateFormat.SHORT, DateFormat.SHORT, getLocale()).format(argument) null instanceof String argument null any argument.toString()

        如果pos为非空，并且参考Field.ARGUMENT ，将返回第一个格式化字符串的位置。

        参数
        arguments - 要格式化和替换的对象数组。
        result - 附加文本。
        pos - 输入：如果需要，对齐字段。 输出：对齐字段的偏移量。
        结果
        字符串缓冲区作为 result ，附带格式化的文本
        异常
        IllegalArgumentException - 如果 arguments数组中的参数不是使用它的格式元素所期望的类型。
        NullPointerException - 如果 result是 null

      • format

        public static String format​(String pattern,
                            Object... arguments)
        使用给定的模式创建一个MessageFormat，并使用它来格式化给定的参数。 这相当于
        (new MessageFormat(pattern)).format(arguments, new StringBuffer(), null).toString()
        参数
        pattern - 模式字符串
        arguments - 要格式化的对象
        结果
        格式化的字符串
        异常
        IllegalArgumentException - 如果模式无效，或者 arguments数组中的参数不是使用格式化元素所期望的类型。
        NullPointerException - 如果 pattern是 null

      • format

        public final StringBuffer format​(Object arguments,
                                 StringBuffer result,
                                 FieldPosition pos)
        格式化一组对象，并将MessageFormat的格式附加到已提供的StringBuffer的格式化对象的格式元素中。 这相当于
        format((Object[]) arguments, result, pos)
        Specified by:
        format在 Format
        参数
        arguments - 要格式化和替换的对象数组。
        result - 附加文本。
        pos - 输入：如果需要，对齐字段。 输出：对齐字段的偏移量。
        结果
        字符串缓冲区作为 toAppendTo ，附带格式化的文本
        异常
        IllegalArgumentException - 如果 arguments数组中的参数不是使用它的格式元素所期望的类型。
        NullPointerException - 如果 result是 null

      • formatToCharacterIterator

        public AttributedCharacterIterator formatToCharacterIterator​(Object arguments)
        格式化一组对象并将其插入到MessageFormat的模式中，产生一个AttributedCharacterIterator 。 您可以使用返回的AttributedCharacterIterator构建生成的字符串，以及确定有关生成的字符串的信息。

        返回的AttributedCharacterIterator的文本与返回的文本相同

        format(arguments, new StringBuffer(), null).toString()

        此外， AttributedCharacterIterator至少包含属性，指示从arguments数组中的参数生成文本的arguments 。 这些属性的键的类型为MessageFormat.Field ，它们的值为Integer对象，指示生成文本的参数的arguments数组中的索引。

        从底层的属性/值Format实例即MessageFormat用途也将被放置在所得AttributedCharacterIterator 。 这样，您不仅可以在生成的字符串中找到参数的位置，还可以找到它所包含的字段。

        重写：
        formatToCharacterIterator在 Format
        参数
        arguments - 要格式化和替换的对象数组。
        结果
        AttributedCharacterIterator描述格式化的值。
        异常
        NullPointerException - 如果 arguments为空。
        IllegalArgumentException - 如果 arguments数组中的参数不是使用它的格式元素所期望的类型。
        从以下版本开始：
        1.4

      • parse

        public Object[] parse​(String source,
                      ParsePosition pos)
        解析字符串。

        警告：在许多情况下，解析可能会失败。 例如：

        • 如果其中一个参数不发生在模式中。
        • 如果参数的格式丢失信息，例如使用大量格式化为“许多”的选择格式。
        • 还没有处理递归（其中替换的字符串包含{n}个引用）。
        • 如果解析的某些部分含糊不清，则不会总是找到匹配（或正确的匹配）。 例如，如果模式“{1}，{2}”与字符串参数{“a，b”，“c”}一起使用，则它将格式化为“a，b，c”。 当结果被解析时，它将返回{“a”，“b，c”}。
        • 如果单个参数在字符串中被多次解析，则后来的解析获胜。
        解析失败时，请使用ParsePosition.getErrorIndex（）来查找字符串中解析失败的位置。 返回的错误索引是字符串与之进行比较的子模式的起始偏移量。 例如，如果解析字符串“AAA {0} BBB”与模式“AAD {0} BBB”进行比较，则错误索引为0.当发生错误时，对该方法的调用将返回null。 如果源为null，则返回一个空数组。
        参数
        source - 要解析的字符串
        pos - 解析位置
        结果
        一组解析的对象
        异常
        NullPointerException - 如果 pos是 null为非空 source字符串。

      • parse

        public Object[] parse​(String source)
               throws ParseException
        从给定字符串的开头解析文本以产生一个对象数组。 该方法可能不会使用给定字符串的整个文本。

        有关消息解析的更多信息，请参阅parse(String, ParsePosition)方法。

        参数
        source - A String其开头应该被解析。
        结果
        从字符串中解析出一个 Object数组。
        异常
        ParseException - 如果无法解析指定字符串的开头。

      • parseObject

        public Object parseObject​(String source,
                          ParsePosition pos)
        从字符串中解析文本以生成对象数组。

        该方法尝试从pos给出的索引开始解析文本。 如果解析成功，则pos的索引将更新为使用最后一个字符后的索引（解析不一定使用字符串末尾的所有字符），并返回已解析的对象数组。 更新的pos可用于指示下一次调用此方法的起始点。 如果发生错误，则pos的索引未更改，错误索引pos设置为发生错误的字符的索引，返回null。

        有关消息解析的更多信息，请参阅parse(String, ParsePosition)方法。

        Specified by:
        parseObject在 Format
        参数
        source - A String ，其中一部分应该被解析。
        pos - 具有 ParsePosition索引和错误索引信息的 ParsePosition对象。
        结果
        从字符串中解析一个Object数组。 万一出错，返回null。
        异常
        NullPointerException - 如果 pos为空。

      • clone

        public Object clone​()
        创建并返回此对象的副本。
        重写：
        clone在 Format
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • equals

        public boolean equals​(Object obj)
        两个消息格式对象之间的平等比较
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        生成消息格式对象的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MessageFormat.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class MessageFormat.Field

  • java.lang.Object
    • java.text.AttributedCharacterIterator.Attribute
      • java.text.Format.Field
        • java.text.MessageFormat.Field
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    MessageFormat

    public static class MessageFormat.Field
extends Format.Field
    定义从 MessageFormat.formatToCharacterIterator返回的 AttributedCharacterIterator中用作属性键的 MessageFormat.formatToCharacterIterator 。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static MessageFormat.Field ARGUMENT
      常量标识从传入 formatToCharacterIterator的参数生成的消息的一部分。

      • Fields inherited from class java.text.AttributedCharacterIterator.Attribute

        INPUT_METHOD_SEGMENT, LANGUAGE, READING

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Field​(String name)
      用指定的名称创建一个字段。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Object readResolve​()
      解析反序列化为预定义常量的实例。

      • Methods inherited from class java.text.AttributedCharacterIterator.Attribute

        equals, getName, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ARGUMENT

        public static final MessageFormat.Field ARGUMENT
        常量标识从传入formatToCharacterIterator的参数生成的消息的一部分。 与该密钥相关联的值将是一个Integer表示arguments数组中生成文本的参数的索引。

    • 构造方法详细信息

      • Field

        protected Field​(String name)
        用指定的名称创建一个字段。
        参数
        name - 属性名称

    • 方法详细信息

      • readResolve

        protected Object readResolve​()
                      throws InvalidObjectException
        解析反序列化为预定义常量的实例。
        重写：
        readResolve在 AttributedCharacterIterator.Attribute
        结果
        解决MessageFormat.Field常量
        异常
        InvalidObjectException - 如果常数无法解决。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Normalizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class Normalizer

  • java.lang.Object
    • java.text.Normalizer

  • public final class Normalizer
extends Object
    该类提供了将Unicode文本转换为等效的组合或分解形式的方法normalize ，从而更容易地对文本进行排序和搜索。 normalize方法支持Unicode Standard Annex #15 — Unicode Normalization Forms中描述的标准规范化形式。

    具有重音或其他装饰的字符可以以多种不同的方式以Unicode编码。 例如，以字母A-acute。 在Unicode中，可以将其编码为单个字符（“组合”形式）：

      U+00C1    LATIN CAPITAL LETTER A WITH ACUTE
    或作为两个单独的字符（“分解”形式）：
      U+0041    LATIN CAPITAL LETTER A
      U+0301    COMBINING ACUTE ACCENT
    然而，对于您的程序的用户，这两个序列应被视为相同的“用户级”字符“A与尖锐的口音”。 当您搜索或比较文本时，您必须确保这两个序列被视为等同的。 另外，您必须处理多个口音的字符。 有时，字符组合口音的顺序是重要的，而在其他情况下，不同顺序的重音序列确实是相当的。

    类似地，字符串“ffi”可以被编码为三个单独的字母：

      U+0066    LATIN SMALL LETTER F
      U+0066    LATIN SMALL LETTER F
      U+0069    LATIN SMALL LETTER I
    或作为单个字符
      U+FB03    LATIN SMALL LIGATURE FFI
    ffi连字不是一个独特的语义字符，严格来说，它不应该在Unicode中，而是包含在与已经提供的字符集的兼容性上。 Unicode标准通过将“兼容性”分解给相应的语义字符来标识这些字符。 排序和搜索时，您通常会使用这些映射。

    normalize方法有助于通过将文本转换为规范组合和分解形式来解决这些问题，如上面的第一个例子所示。 此外，您可以使其执行兼容性分解，以便可以将兼容性字符与其等同物相同。 最后， normalize方法normalize口音重新排列成正确的规范，让您不用担心自己的口音重排。

    W3C通常建议在NFC中交换文本。 还要注意，大多数遗留字符编码仅使用预先形式的形式，并且通常不会自己对任何组合标记进行编码。 要转换为这样的字符编码，Unicode文本需要归一化到NFC。 有关更多使用示例，请参阅Unicode标准附件。

    从以下版本开始：
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Normalizer.Form
      此枚举提供了 Unicode Standard Annex #15 — Unicode Normalization Forms中描述的四种Unicode归一化表单的常量，以及访问它们的两种方法。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static boolean isNormalized​(CharSequence src, Normalizer.Form form)
      确定给定的char值序列是否被归一化。
      static String normalize​(CharSequence src, Normalizer.Form form)
      归一化一个char值序列。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • normalize

        public static String normalize​(CharSequence src,
                               Normalizer.Form form)
        归一化一个char值序列。 序列将根据指定的规范化进行归一化。
        参数
        src - 要归一化的char值的序列。
        form - 规范化形式; 一个Normalizer.Form.NFC ， Normalizer.Form.NFD ， Normalizer.Form.NFKC ， Normalizer.Form.NFKD
        结果
        标准化字符串
        异常
        NullPointerException - 如果 src或 form为空。

      • isNormalized

        public static boolean isNormalized​(CharSequence src,
                                   Normalizer.Form form)
        确定给定的char值序列是否被归一化。
        参数
        src - 要检查的char值的序列。
        form - 规范化形式; 一个Normalizer.Form.NFC ， Normalizer.Form.NFD ， Normalizer.Form.NFKC ， Normalizer.Form.NFKD
        结果
        如果char值的序列被归一化则为true; 否则为假。
        异常
        NullPointerException - 如果 src或 form为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Normalizer.Form (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.text

Enum Normalizer.Form

  • java.lang.Object
    • java.lang.Enum<Normalizer.Form>
      • java.text.Normalizer.Form
  • All Implemented Interfaces:
    Serializable ， Comparable<Normalizer.Form>
    Enclosing class:
    Normalizer

    public static enum Normalizer.Form
extends Enum<Normalizer.Form>
    此枚举提供了 Unicode Standard Annex #15 — Unicode Normalization Forms中描述的四个Unicode归一化表单的常量，以及访问它们的两种方法。
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NFC
      经典分解，其次是规范组成。
      NFD
      规范分解。
      NFKC
      兼容性分解，其次是规范组成。
      NFKD
      兼容性分解

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Normalizer.Form valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Normalizer.Form[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NFD

        public static final Normalizer.Form NFD
        规范分解。

      • NFC

        public static final Normalizer.Form NFC
        经典分解，其次是规范组成。

      • NFKD

        public static final Normalizer.Form NFKD
        兼容性分解

      • NFKC

        public static final Normalizer.Form NFKC
        兼容性分解，其次是规范组成。

    • 方法详细信息

      • values

        public static Normalizer.Form[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Normalizer.Form c : Normalizer.Form.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Normalizer.Form valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


NumberFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class NumberFormat

  • java.lang.Object
    • java.text.Format
      • java.text.NumberFormat
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    ChoiceFormat ， DecimalFormat

    public abstract class NumberFormat
extends Format
    NumberFormat是所有数字格式的抽象基类。 该类提供格式化和解析数字的接口。 NumberFormat还提供了确定哪些区域设置具有数字格式以及它们的名称的方法。

    NumberFormat可帮助您格式化和解析任何区域设置的数字。 您的代码可以完全独立于小数点，数千分隔符或甚至使用的特定十进制数字的区域设置约定，或者数字格式是否为偶数十进制。

    要格式化当前语言环境的数字，请使用其中一种工厂类方法：

 myString = NumberFormat.getInstance().format(myNumber);
    如果要格式化多个数字，更多的是获取格式并多次使用它，以便系统不必多次获取有关本地语言和国家/地区约定的信息。

 NumberFormat nf = NumberFormat.getInstance();
 for (int i = 0; i < myNumber.length; ++i) {
     output.println(nf.format(myNumber[i]) + "; ");
 }
    要格式化不同语言环境的数字，请在调用getInstance指定它。

 NumberFormat nf = NumberFormat.getInstance(Locale.FRENCH);
    您也可以使用NumberFormat来解析数字：

 myNumber = nf.parse(myString);
    使用getInstance或getNumberInstance获取正常数字格式。 使用getIntegerInstance获取整数格式。 使用getCurrencyInstance获取货币编号格式。 并使用getPercentInstance获取显示百分比的格式。 使用这种格式，0.53的分数显示为53％。

    您还可以使用setMinimumFractionDigits等方法控制数字的显示。 如果你想在格式或对其进行解析更大的控制权，或者希望给用户更多的控制，你可以尝试铸造NumberFormat你从工厂方法到获得DecimalFormat 。 这对绝大多数地方都有用; 只要记住把它放在一个try块中，以防万一遇到不寻常的一个。

    NumberFormat和DecimalFormat被设计为使得某些控件可以用于格式化，而其他控件可用于解析。 以下是每种这些控制方法的详细说明，

    setParseIntegerOnly：仅影响解析，例如如果为true，则为“3456.78”→3456（并且在索引6之后留下解析位置）如果为false，则为“3456.78”→3456.78（并且在索引8之后留下解析位置）是独立的格式化。 如果您不想显示小数点后可能没有数字的小数点，请使用setDecimalSeparatorAlwaysShown。

    setDecimalSeparatorAlwaysShown：仅影响格式化，只有在小数点之后可能没有数字的地方，例如像“＃，## 0。##”这样的模式，例如，如果为true，则为3456.00†“”3,456“。 如果是false，3456.00â†“”3456“这是独立于解析。 如果要解析在小数点停止，请使用setParseIntegerOnly。

    您还可以使用parse和format方法的形式，其中包含ParsePosition和FieldPosition以允许您：

    • 逐渐解析一串字符串
    • 对齐小数点和其他区域
    例如，您可以通过两种方式对齐数字：
    1. 如果您使用的间距排列等宽字体，你可以通过FieldPosition在您的格式的呼叫，与field = INTEGER_FIELD 。 在输出时， getEndIndex将被设置为整数的最后一个字符与小数点之间的偏移量。 在字符串前面添加（desiredSpaceCount - getEndIndex）空格。
    2. 如果您使用比例字体，而不是使用空格填充，请测量从起始到getEndIndex的字符串宽度（以像素为getEndIndex 。 然后在绘制文本之前将笔移动（desiredPixelWidth - widthToAlignmentPoint）。 它也可以在没有十进制的情况下工作，但最后可能有其他字符，例如括号为负数：“（12）”表示-12。

    Synchronization

    数字格式通常不同步。 建议为每个线程创建单独的格式实例。 如果多个线程同时访问格式，则必须在外部进行同步。

    实现要求：
    该format(double, StringBuffer, FieldPosition) ， format(long, StringBuffer, FieldPosition)和parse(String, ParsePosition)方法可能抛出NullPointerException ，如果他们的任何参数为null 。 子类可以提供自己的实现和规范约NullPointerException 。
    从以下版本开始：
    1.1
    另请参见：
    DecimalFormat ， ChoiceFormat ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  NumberFormat.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 NumberFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int FRACTION_FIELD
      用于构造FieldPosition对象的字段常量。
      static int INTEGER_FIELD
      用于构造FieldPosition对象的字段常量。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected NumberFormat​()
      唯一的构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      覆盖可克隆。
      boolean equals​(Object obj)
      覆盖等于。
      String format​(double number)
      专业化格式。
      abstract StringBuffer format​(double number, StringBuffer toAppendTo, FieldPosition pos)
      专业化格式。
      String format​(long number)
      专业化格式。
      abstract StringBuffer format​(long number, StringBuffer toAppendTo, FieldPosition pos)
      专业化格式。
      StringBuffer format​(Object number, StringBuffer toAppendTo, FieldPosition pos)
      格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
      static Locale[] getAvailableLocales​()
      返回所有语言环境的数组，该类的 get*Instance方法可以返回本地化实例。
      Currency getCurrency​()
      在格式化货币值时，获取此数字格式使用的货币。
      static NumberFormat getCurrencyInstance​()
      返回当前默认值 FORMAT区域设置的货币格式。
      static NumberFormat getCurrencyInstance​(Locale inLocale)
      返回指定区域设置的货币格式。
      static NumberFormat getInstance​()
      返回当前默认 值为FORMAT的通用数字格式。
      static NumberFormat getInstance​(Locale inLocale)
      返回指定区域设置的通用数字格式。
      static NumberFormat getIntegerInstance​()
      返回当前默认 FORMAT区域设置的整数格式。
      static NumberFormat getIntegerInstance​(Locale inLocale)
      返回指定区域设置的整数格式。
      int getMaximumFractionDigits​()
      返回数字小数部分允许的最大位数。
      int getMaximumIntegerDigits​()
      返回数字整数部分允许的最大位数。
      int getMinimumFractionDigits​()
      返回数字小数部分允许的最小位数。
      int getMinimumIntegerDigits​()
      返回数字整数部分允许的最小位数。
      static NumberFormat getNumberInstance​()
      返回当前默认 FORMAT区域设置的通用数字格式。
      static NumberFormat getNumberInstance​(Locale inLocale)
      返回指定区域设置的通用数字格式。
      static NumberFormat getPercentInstance​()
      返回当前默认 值为FORMAT的区域设置的百分比格式。
      static NumberFormat getPercentInstance​(Locale inLocale)
      返回指定区域设置的百分比格式。
      RoundingMode getRoundingMode​()
      获取此NumberFormat中使用的RoundingMode 。
      int hashCode​()
      覆盖hashCode。
      boolean isGroupingUsed​()
      新新新旗新新新新旗新新旗新新旗新新旗旗新新旗新新旗旗新新旗新旗旗
      boolean isParseIntegerOnly​()
      如果此格式将仅将数字解析为整数，则返回true。
      Number parse​(String source)
      从给定字符串的开头解析文本以产生一个数字。
      abstract Number parse​(String source, ParsePosition parsePosition)
      如果可能，返回长（例如，在[Long.MIN_VALUE，Long.MAX_VALUE]范围内，无小数），否则为Double。
      Object parseObject​(String source, ParsePosition pos)
      从字符串中解析文本，生成一个 Number 。
      void setCurrency​(Currency currency)
      设置格式化货币值时此数字格式使用的货币。
      void setGroupingUsed​(boolean newValue)
      设置是否以此格式使用分组。
      void setMaximumFractionDigits​(int newValue)
      设置数字小数部分允许的最大位数。 maximumFractionDigits必须为〜最小FractionDigits。
      void setMaximumIntegerDigits​(int newValue)
      设置数字的整数部分允许的最大位数。 maximumIntegerDigits必须为≤最小值。
      void setMinimumFractionDigits​(int newValue)
      设置数字小数部分允许的最小位数。 minimumFractionDigits必须是最大值。
      void setMinimumIntegerDigits​(int newValue)
      设置数字的整数部分允许的最小位数。 minimumIntegerDigits必须是最大值。
      void setParseIntegerOnly​(boolean value)
      设置是否仅将数字解析为整数。
      void setRoundingMode​(RoundingMode roundingMode)
      设置此NumberFormat中使用的RoundingMode 。

      • Methods inherited from class java.text.Format

        format, formatToCharacterIterator, parseObject

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • INTEGER_FIELD

        public static final int INTEGER_FIELD
        用于构造FieldPosition对象的字段常量。 表示应该返回格式化数字的整数部分的位置。
        另请参见：
        FieldPosition ， Constant Field Values

      • FRACTION_FIELD

        public static final int FRACTION_FIELD
        用于构造FieldPosition对象的字段常量。 表示应该返回格式化数字的分数部分的位置。
        另请参见：
        FieldPosition ， Constant Field Values

    • 构造方法详细信息

      • NumberFormat

        protected NumberFormat​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • format

        public StringBuffer format​(Object number,
                           StringBuffer toAppendTo,
                           FieldPosition pos)
        格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。 该数字可以是Number的任何子类。

        该实现使用Number.longValue()为所有可转换为long而不丢失信息的整数型值提取数字值，包括BigInteger值为bit length ，小于64，Number.doubleValue()为所有其他类型。 然后拨打format(long,java.lang.StringBuffer,java.text.FieldPosition)或format(double,java.lang.StringBuffer,java.text.FieldPosition) 。 这可能导致BigInteger和BigDecimal值的信息和精度损失。

        Specified by:
        format在类 Format
        参数
        number - 要格式化的号码
        toAppendTo - 要附加格式化文本的 StringBuffer
        pos - 输入：如果需要，对齐字段。 输出：对齐字段的偏移量。
        结果
        该值传递为 toAppendTo
        异常
        IllegalArgumentException - 如果 number为空， Number的实例。
        NullPointerException - 如果 toAppendTo或 pos为空
        ArithmeticException - 如果舍入模式设置为RoundingMode.UNNESSESSARY，则需要舍入
        另请参见：
        FieldPosition

      • parseObject

        public final Object parseObject​(String source,
                                ParsePosition pos)
        从字符串中解析文本，产生一个Number 。

        该方法尝试从pos给出的索引开始解析文本。 如果解析成功，那么pos的索引将在使用最后一个字符后更新为索引（解析不一定使用字符串末尾的所有字符），并返回解析的数字。 更新的pos可用于指示下一次调用此方法的起始点。 如果发生错误，则pos的索引不改变，则将错误索引pos设置为发生错误的字符的索引，返回null。

        有关数字解析的更多信息，请参阅parse(String, ParsePosition)方法。

        Specified by:
        parseObject在类 Format
        参数
        source - A String ，其中的一部分应该被解析。
        pos索引和错误索引信息的 pos - A ParsePosition对象。
        结果
        A Number从字符串解析。 万一出错，返回null。
        异常
        NullPointerException - 如果 source或 pos为空。

      • format

        public final String format​(double number)
        专业化格式。
        参数
        number - 双数格式
        结果
        格式化的字符串
        异常
        ArithmeticException - 如果舍入模式设置为RoundingMode.UNNECESSARY，则需要舍入
        另请参见：
        Format.format(java.lang.Object)

      • format

        public final String format​(long number)
        专业化格式。
        参数
        number - 长编号格式
        结果
        格式化的字符串
        异常
        ArithmeticException - 如果舍入方式设置为RoundingMode.UNNECESSARY，则需要舍入
        另请参见：
        Format.format(java.lang.Object)

      • format

        public abstract StringBuffer format​(double number,
                                    StringBuffer toAppendTo,
                                    FieldPosition pos)
        专业化格式。
        参数
        number - 双数格式
        toAppendTo - 要附加格式化文本的StringBuffer
        pos - 字段位置
        结果
        格式化的StringBuffer
        异常
        ArithmeticException - 如果舍入方式设置为RoundingMode.UNNECESSARY，则需要舍入
        另请参见：
        Format.format(java.lang.Object)

      • format

        public abstract StringBuffer format​(long number,
                                    StringBuffer toAppendTo,
                                    FieldPosition pos)
        专业化格式。
        参数
        number - 长数字格式
        toAppendTo - 要附加格式化文本的StringBuffer
        pos - 字段位置
        结果
        格式化的StringBuffer
        异常
        ArithmeticException - 如果舍入模式设置为RoundingMode.UNNECESSARY，则需要舍入
        另请参见：
        Format.format(java.lang.Object)

      • parse

        public abstract Number parse​(String source,
                             ParsePosition parsePosition)
        如果可能，返回长（例如，在[Long.MIN_VALUE，Long.MAX_VALUE]范围内，无小数），否则为Double。 如果IntegerOnly被设置，将在小数点（或等效的位置）停止;例如，对于有理数字“1 2/3”，将在1）之后停止。 不抛出异常; 如果没有对象可以解析，索引没有变化！
        参数
        source - 要解析的字符串
        parsePosition - 解析位置
        结果
        被解析的价值
        另请参见：
        isParseIntegerOnly() ， Format.parseObject(java.lang.String, java.text.ParsePosition)

      • parse

        public Number parse​(String source)
             throws ParseException
        从给定字符串的开头解析文本以产生一个数字。 该方法可能不会使用给定字符串的整个文本。

        有关数字解析的更多信息，请参阅parse(String, ParsePosition)方法。

        参数
        source - A String其开头应该被解析。
        结果
        A Number从字符串中解析。
        异常
        ParseException - 如果指定字符串的开头不能被解析。

      • isParseIntegerOnly

        public boolean isParseIntegerOnly​()
        如果此格式将仅将数字解析为整数，则返回true。 例如在英语语言环境中，使用ParseIntegerOnly true，字符串“1234”。 将被解析为整数值1234，解析将停止在“”。 字符。 当然，解析操作接受的确切格式是区域设置依赖，并由NumberFormat的子类决定。
        结果
        true如果数字只能解析为整数; 否则为false

      • setParseIntegerOnly

        public void setParseIntegerOnly​(boolean value)
        设置是否仅将数字解析为整数。
        参数
        value - true如果数字只能解析为整数; 否则为false
        另请参见：
        isParseIntegerOnly()

      • getInstance

        public static final NumberFormat getInstance​()
        返回当前默认的FORMAT区域设置的通用数字格式。 这与拨打getNumberInstance()相同。
        结果
        用于通用数字格式化的 NumberFormat实例

      • getInstance

        public static NumberFormat getInstance​(Locale inLocale)
        返回指定区域设置的通用数字格式。 这与调用getNumberInstance(inLocale)相同。
        参数
        inLocale - 所需的语言环境
        结果
        用于通用数字格式化的 NumberFormat实例

      • getNumberInstance

        public static final NumberFormat getNumberInstance​()
        返回当前默认的FORMAT区域设置的通用数字格式。

        这相当于调用getNumberInstance(Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        用于通用数字格式化的 NumberFormat实例
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getNumberInstance

        public static NumberFormat getNumberInstance​(Locale inLocale)
        返回指定区域设置的通用数字格式。
        参数
        inLocale - 所需的语言环境
        结果
        用于通用数字格式化的 NumberFormat实例

      • getIntegerInstance

        public static final NumberFormat getIntegerInstance​()
        返回当前默认FORMAT区域设置的整数格式。 返回的数字格式被配置成使用半甚至舍入圆浮点数到最接近的整数（参见RoundingMode.HALF_EVEN ）进行格式化，并且解析仅一个输入字符串的整数部分（参见isParseIntegerOnly ）。

        这相当于调用getIntegerInstance(Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        整数值的数字格式
        从以下版本开始：
        1.4
        另请参见：
        getRoundingMode() ， Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getIntegerInstance

        public static NumberFormat getIntegerInstance​(Locale inLocale)
        返回指定区域设置的整数格式。 返回的数字格式被配置成使用半甚至舍入圆浮点数到最接近的整数（参见RoundingMode.HALF_EVEN ）进行格式化，并且解析仅一个输入字符串的整数部分（参见isParseIntegerOnly ）。
        参数
        inLocale - 所需的语言环境
        结果
        整数值的数字格式
        从以下版本开始：
        1.4
        另请参见：
        getRoundingMode()

      • getCurrencyInstance

        public static final NumberFormat getCurrencyInstance​()
        返回当前默认的货币格式FORMAT区域设置。

        这相当于调用getCurrencyInstance(Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        货币格式化的 NumberFormat实例
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getCurrencyInstance

        public static NumberFormat getCurrencyInstance​(Locale inLocale)
        返回指定区域设置的货币格式。
        参数
        inLocale - 所需的语言环境
        结果
        货币格式化的 NumberFormat实例

      • getPercentInstance

        public static final NumberFormat getPercentInstance​()
        返回当前默认值为FORMAT的区域设置的百分比格式。

        这相当于调用getPercentInstance(Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        用于百分比格式化的 NumberFormat实例
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • getPercentInstance

        public static NumberFormat getPercentInstance​(Locale inLocale)
        返回指定区域设置的百分比格式。
        参数
        inLocale - 所需的语言环境
        结果
        用于百分比格式化的 NumberFormat实例

      • getAvailableLocales

        public static Locale[] getAvailableLocales​()
        返回一个所有语言环境的数组，该类的get*Instance方法可以返回本地化实例。 返回的数组表示由Java运行时支持的语言环境和已安装的NumberFormatProvider实现的联合。 它必须包含至少一个Locale实例，等于Locale.US 。
        结果
        一组可用于本地化的本地化的区域设置 NumberFormat 。

      • hashCode

        public int hashCode​()
        覆盖hashCode。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        覆盖等于。
        重写：
        equals在类 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • clone

        public Object clone​()
        覆盖可克隆。
        重写：
        clone在类 Format
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • isGroupingUsed

        public boolean isGroupingUsed​()
        新新新旗新新新新旗新新旗新新旗新新旗旗新新旗新新旗旗新新旗新旗旗 例如，在英文区域设置中，通过分组，数字1234567可能被格式化为“1,234,567”。 分组分隔符以及每个组的大小取决于区域设置，并由NumberFormat的子类决定。
        结果
        true如果使用分组; false否则
        另请参见：
        setGroupingUsed(boolean)

      • setGroupingUsed

        public void setGroupingUsed​(boolean newValue)
        设置是否以此格式使用分组。
        参数
        newValue - true如果使用分组; 否则为false
        另请参见：
        isGroupingUsed()

      • getMaximumIntegerDigits

        public int getMaximumIntegerDigits​()
        返回数字整数部分允许的最大位数。
        结果
        最大位数
        另请参见：
        setMaximumIntegerDigits(int)

      • setMaximumIntegerDigits

        public void setMaximumIntegerDigits​(int newValue)
        设置数字的整数部分允许的最大位数。 maximumIntegerDigits必须为≤最小值。 如果maximumIntegerDigits的新值小于minimumIntegerDigits的当前值，那么minimumIntegerDigits也将被设置为新值。
        参数
        newValue - 要显示的最大整数位数; 如果小于零，则使用零。 具体的子类可能会强制适用于正在格式化的数字类型的此值的上限。
        另请参见：
        getMaximumIntegerDigits()

      • getMinimumIntegerDigits

        public int getMinimumIntegerDigits​()
        返回数字整数部分允许的最小位数。
        结果
        最小位数
        另请参见：
        setMinimumIntegerDigits(int)

      • setMinimumIntegerDigits

        public void setMinimumIntegerDigits​(int newValue)
        设置数字的整数部分允许的最小位数。 minimumIntegerDigits必须是最大值。 如果minimumIntegerDigits的新值超过当前的maximumIntegerDigits值，那么maximumIntegerDigits也将被设置为新的值
        参数
        newValue - 要显示的最小整数数字; 如果小于零，则使用零。 具体的子类可能会强制适用于正在格式化的数字类型的此值的上限。
        另请参见：
        getMinimumIntegerDigits()

      • getMaximumFractionDigits

        public int getMaximumFractionDigits​()
        返回数字小数部分允许的最大位数。
        结果
        最大位数。
        另请参见：
        setMaximumFractionDigits(int)

      • setMaximumFractionDigits

        public void setMaximumFractionDigits​(int newValue)
        设置数字小数部分允许的最大位数。 maximumFractionDigits必须为〜最小FractionDigits。 如果maximumFractionDigits的新值小于minimumFractionDigits的当前值，那么minimumFractionDigits也将被设置为新值。
        参数
        newValue - 要显示的最小数字位数; 如果小于零，则使用零。 具体的子类可能会强制适用于正在格式化的数字类型的此值的上限。
        另请参见：
        getMaximumFractionDigits()

      • getMinimumFractionDigits

        public int getMinimumFractionDigits​()
        返回数字小数部分允许的最小位数。
        结果
        最小位数
        另请参见：
        setMinimumFractionDigits(int)

      • setMinimumFractionDigits

        public void setMinimumFractionDigits​(int newValue)
        设置数字小数部分允许的最小位数。 minimumFractionDigits必须是最大值。 如果minimumFractionDigits的新值超过了currentFractionDigits的当前值，那么maximumIntegerDigits也将被设置为新的值
        参数
        newValue - 要显示的最小数字数字; 如果小于零，则使用零。 具体的子类可能会强制适用于正在格式化的数字类型的此值的上限。
        另请参见：
        getMinimumFractionDigits()

      • getCurrency

        public Currency getCurrency​()
        在格式化货币值时，获取此数字格式使用的货币。 初始值以区域设置依赖的方式导出。 如果无法确定有效货币，并且使用setCurrency未设定货币，则返回值可能为null。

        默认实现抛出UnsupportedOperationException 。

        结果
        该数字格式使用的货币，或 null
        异常
        UnsupportedOperationException - 如果数字格式类不实现货币格式
        从以下版本开始：
        1.4

      • setCurrency

        public void setCurrency​(Currency currency)
        设置格式化货币值时此数字格式使用的货币。 这不会更新数字格式使用的小数位数的最小或最大数量。

        默认实现抛出UnsupportedOperationException 。

        参数
        currency - 此数字格式使用的新货币
        异常
        UnsupportedOperationException - 如果数字格式类不实现货币格式化
        NullPointerException - 如果 currency为空
        从以下版本开始：
        1.4

      • getRoundingMode

        public RoundingMode getRoundingMode​()
        获取此NumberFormat中使用的RoundingMode 。 NumberFormat中此方法的默认实现总是抛出UnsupportedOperationException 。 处理不同舍入模式的子类应该覆盖此方法。
        结果
        用于此NumberFormat的 RoundingMode 。
        异常
        UnsupportedOperationException - 默认实现总是引发这个异常
        从以下版本开始：
        1.6
        另请参见：
        setRoundingMode(RoundingMode)

      • setRoundingMode

        public void setRoundingMode​(RoundingMode roundingMode)
        设置此NumberFormat中使用的RoundingMode 。 NumberFormat中此方法的默认实现总是抛出UnsupportedOperationException 。 处理不同舍入模式的子类应该覆盖此方法。
        参数
        roundingMode - 要使用的 RoundingMode
        异常
        UnsupportedOperationException - 默认实现总是引发这个异常
        NullPointerException - 如果 roundingMode为空
        从以下版本开始：
        1.6
        另请参见：
        getRoundingMode()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


NumberFormat.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class NumberFormat.Field

  • java.lang.Object
    • java.text.AttributedCharacterIterator.Attribute
      • java.text.Format.Field
        • java.text.NumberFormat.Field
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    NumberFormat

    public static class NumberFormat.Field
extends Format.Field
    定义了用于作为属性键常数 AttributedCharacterIterator从返回 NumberFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static NumberFormat.Field CURRENCY
      不断识别货币字段。
      static NumberFormat.Field DECIMAL_SEPARATOR
      常数标识小数分隔符字段。
      static NumberFormat.Field EXPONENT
      常数识别指数字段。
      static NumberFormat.Field EXPONENT_SIGN
      常数识别指数符号字段。
      static NumberFormat.Field EXPONENT_SYMBOL
      常数识别指数符号字段。
      static NumberFormat.Field FRACTION
      常数识别分数字段。
      static NumberFormat.Field GROUPING_SEPARATOR
      常数标识分组分隔符字段。
      static NumberFormat.Field INTEGER
      常量识别整数字段。
      static NumberFormat.Field PERCENT
      不断识别百分比字段。
      static NumberFormat.Field PERMILLE
      常数识别容错字段。
      static NumberFormat.Field SIGN
      常量识别符号字段。

      • Fields inherited from class java.text.AttributedCharacterIterator.Attribute

        INPUT_METHOD_SEGMENT, LANGUAGE, READING

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Field​(String name)
      创建具有指定名称的Field实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Object readResolve​()
      解析反序列化为预定义常量的实例。

      • Methods inherited from class java.text.AttributedCharacterIterator.Attribute

        equals, getName, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INTEGER

        public static final NumberFormat.Field INTEGER
        常量识别整数字段。

      • FRACTION

        public static final NumberFormat.Field FRACTION
        常数识别分数字段。

      • EXPONENT

        public static final NumberFormat.Field EXPONENT
        常数识别指数字段。

      • DECIMAL_SEPARATOR

        public static final NumberFormat.Field DECIMAL_SEPARATOR
        常数标识小数分隔符字段。

      • SIGN

        public static final NumberFormat.Field SIGN
        常量识别符号字段。

      • GROUPING_SEPARATOR

        public static final NumberFormat.Field GROUPING_SEPARATOR
        常数标识分组分隔符字段。

      • EXPONENT_SYMBOL

        public static final NumberFormat.Field EXPONENT_SYMBOL
        常数识别指数符号字段。

      • PERCENT

        public static final NumberFormat.Field PERCENT
        不断识别百分比字段。

      • PERMILLE

        public static final NumberFormat.Field PERMILLE
        常数识别容错字段。

      • CURRENCY

        public static final NumberFormat.Field CURRENCY
        不断识别货币字段。

      • EXPONENT_SIGN

        public static final NumberFormat.Field EXPONENT_SIGN
        常数识别指数符号字段。

    • 构造方法详细信息

      • Field

        protected Field​(String name)
        创建具有指定名称的Field实例。
        参数
        name - 属性名称

    • 方法详细信息

      • readResolve

        protected Object readResolve​()
                      throws InvalidObjectException
        解析反序列化为预定义常量的实例。
        重写：
        readResolve在 AttributedCharacterIterator.Attribute
        结果
        解决了NumberFormat.Field常量
        异常
        InvalidObjectException - 如果常数无法解决。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ParseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class ParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.text.ParseException
  • All Implemented Interfaces:
    Serializable

    public class ParseException
extends 异常
    表示解析时意外出现错误。
    从以下版本开始：
    1.1
    另请参见：
    异常 ， Format ， FieldPosition ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ParseException​(String s, int errorOffset)
      构造具有指定的详细消息和偏移量的ParseException。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getErrorOffset​()
      返回发现错误的位置。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ParseException

        public ParseException​(String s,
                      int errorOffset)
        构造具有指定的详细消息和偏移量的ParseException。 详细消息是描述此特定异常的字符串。
        参数
        s - 详细信息
        errorOffset - 解析时发现错误的位置。

    • 方法详细信息

      • getErrorOffset

        public int getErrorOffset​()
        返回发现错误的位置。
        结果
        发现错误的位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ParsePosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class ParsePosition

  • java.lang.Object
    • java.text.ParsePosition

  • public class ParsePosition
extends Object
    ParsePosition是由Format及其子类使用的简单类，用于在解析过程中跟踪当前位置。 各种Format类中的parseObject方法需要一个ParsePosition对象作为参数。

    通过设计，当您通过不同格式的字符串进行解析时，可以使用相同的ParsePosition ，因为索引参数记录当前位置。

    从以下版本开始：
    1.1
    另请参见：
    Format

    • 构造方法摘要

      构造方法
      Constructor 描述
      ParsePosition​(int index)
      使用给定的初始索引创建一个新的ParsePosition。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      覆盖等于
      int getErrorIndex​()
      检索发生错误的索引，如果未设置错误索引，则返回-1。
      int getIndex​()
      检索当前的解析位置。
      int hashCode​()
      返回此ParsePosition的哈希码。
      void setErrorIndex​(int ei)
      设置发生解析错误的索引。
      void setIndex​(int index)
      设置当前解析位置。
      String toString​()
      返回此ParsePosition的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ParsePosition

        public ParsePosition​(int index)
        使用给定的初始索引创建一个新的ParsePosition。
        参数
        index - 初始索引

    • 方法详细信息

      • getIndex

        public int getIndex​()
        检索当前的解析位置。 在输入解析方法时，这是解析将开始的字符的索引; 在输出上，它是最后一个字符解析后的字符的索引。
        结果
        当前解析位置

      • setIndex

        public void setIndex​(int index)
        设置当前解析位置。
        参数
        index - 当前解析位置

      • setErrorIndex

        public void setErrorIndex​(int ei)
        设置发生解析错误的索引。 在从parseObject方法返回错误代码之前，格式化应该设置此值。 如果未设置，默认值为-1。
        参数
        ei - 发生错误的索引
        从以下版本开始：
        1.2

      • getErrorIndex

        public int getErrorIndex​()
        检索发生错误的索引，如果未设置错误索引，则返回-1。
        结果
        发生错误的索引
        从以下版本开始：
        1.2

      • equals

        public boolean equals​(Object obj)
        覆盖等于
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此ParsePosition的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此ParsePosition的字符串表示形式。
        重写：
        toString在 Object
        结果
        该对象的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RuleBasedCollator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class RuleBasedCollator

  • java.lang.Object
    • java.text.Collator
      • java.text.RuleBasedCollator
  • All Implemented Interfaces:
    Cloneable ， Comparator<Object>

    public class RuleBasedCollator
extends Collator
    所述RuleBasedCollator类是的具体子类Collator ，提供了一个简单的，数据驱动的表collator。 使用这个类可以创建一个自定义的基于表的Collator 。 RuleBasedCollator将字符映射到排序键。

    RuleBasedCollator对效率有以下限制（其他子类可用于更复杂的语言）：

    1. 如果指定了由<modifier>控制的特殊排序规则，则它将应用于整个整理器对象。
    2. 所有未提及的字符都在排序规则顺序的末尾。

    排序规则表由排序规则列表组成，其中每个规则是三种形式之一：

      <modifier>
    <relation> <text-argument>
    <reset> <text-argument>
    规则要素的定义如下：
    • 文本参数 ：文本参数是任何字符序列，不包括特殊字符（即常见的空格字符[0009-000D，0020]和规则语法字符[0021-002F，003A-0040，005B-0060，007B- 007E]）。 如果需要这些字符，您可以将它们放在单引号中（例如，＆amp;＆gt;'＆'）。 请注意，未引用的空白字符将被忽略; 例如b c被视为bc 。
    • 修饰符 ：目前有两个修改器启用特殊的排序规则。
      • '@'：开启反向排序口音（次要差异），如法文。
      • '！' ：打开泰国/老挝元音辅音交换。 如果这个规则是有效的，当范围为\ U0E401- \ U0E2E的范围为\ U0E01- \ U0E2E的泰国辅音之前的某个泰语元音或者范围为\ U0EC0- \ U0EC4的老元音位于范围\ U0E81- \ U0EAE然后元音放在辅音之后进行排序。

      '@'：表示口音向后排序，如法语。

    • 关系 ：关系如下：
      • '<'：大，作为信差（主）
      • ';' ：大，作为重音差（次要）
      • '，'：大于病例差异（大专）
      • '='：等于
    • 重置 ：有一个单独的重置，主要用于收缩和扩展，但也可以用于在一组规则的末尾添加修改。

      '＆'：表示下一个规则遵循重置文本参数进行排序的位置。

    这听起来比实际上更复杂。 例如，以下是表达相同内容的等效方法：

     a < b < c
 a < b & b < c
 a < c & a < b
    请注意，顺序很重要，因为随后的项目会在text-argument之后立即进行。 以下不等效：
     a < b & a < c
 a < c & a < b
    text-argument必须已经存在于序列中，或者text-argument的一些初始子字符串必须存在。 （例如“a <b＆ae <e”是有效的，因为在“ae”被重置之前的序列中存在“a”）。 在后一种情况下，“ae”不输入并视为单个字符; 相反，“e”按照扩展为两个字符进行排序：“a”后跟“e”。 这种差异出现在自然语言中：在传统的西班牙语“ch”被视为一个单一的字符（表示为“c <ch <d”），而在传统的德语a-umlaut被看作是扩展到两个字符（表示为“a，A <b，B ...＆ae; \ u00e3＆AE; \ u00c3”）。 [\ u00e3和\ u00c3当然是a-umlaut的转义序列。]

    不可思议的人物

    对于可忽略的角色，第一条规则必须从一个关系开始（我们上面使用的例子是真正的片段;“a <b”应该是“<a <b”）。 但是，如果第一个关系不是“<”，则所有直到第一个“<”的文本参数都是可忽略的。 例如，“， - <a <b”使“ - ”成为一个可忽略的字符，正如我们前面在“黑鸟”一词中所看到的那样。 在不同语言的样本中，您会发现大多数口音都是可忽略的。

    规范化和口音

    RuleBasedCollator自动处理其规则表以包括RuleBasedCollator字符和组合字符版本的重音字符。 即使所提供的规则字符串仅包含基本字符和单独组合重音字符，则将在表中输入与规则字符串中的所有规范字符组合匹配的预先组合的重音字符。

    这使您可以使用RuleBasedCollator来比较重音字符串，即使将整理器设置为NO_DECOMPOSITION。 但是有两个注意事项。 首先，如果要整理的字符串包含可能不符合规范的组合序列，则应将归一化器设置为CANONICAL_DECOMPOSITION或FULL_DECOMPOSITION以启用对组合序列的排序。 第二，如果字符串包含具有兼容性分解的字符（例如全宽和半角形式），则必须使用FULL_DECOMPOSITION，因为规则表仅包括规范映射。

    错误

    以下是错误：

    • 文本参数包含未引用的标点符号（例如“a <bc <d”）。
    • 关系或重置字符不在文本参数后面（例如“a <，b”）。
    • 文本参数（或文本参数的初始子字符串）不在序列中的重置。 （例如“a <b＆e <f”）
    如果你产生这些错误之一，一个RuleBasedCollator会抛出一个ParseException 。

    例子

    简单：“<a <b <c <d”

    挪威语：“<a，A <b，B <c，C <d，D <e，E <f，F <g，G <h，H <i，I <j，J <k，K < L <m，M <n，N <o，O <p，P <q，Q <r，R <s，S <t，T <u，U <v，V <w，W <x， y，Y <z，Z <\ u00E6，\ u00C6 <\ u00F8，\ u00D8 <\ u00E5 = a \ u030A，\ u00C5 = A \ u030A; aa，AA“

    要创建一个RuleBasedCollator有适合您的需要的专门规则对象，在构造RuleBasedCollator与包含在规则String对象。 例如：

     String simple = "< a< b< c< d";
 RuleBasedCollator mySimple = new RuleBasedCollator(simple);
    要么：
     String Norwegian = "< a, A < b, B < c, C < d, D < e, E < f, F < g, G < h, H < i, I" +
                    "< j, J < k, K < l, L < m, M < n, N < o, O < p, P < q, Q < r, R" +
                    "< s, S < t, T < u, U < v, V < w, W < x, X < y, Y < z, Z" +
                    "< \u00E6, \u00C6" +     // Latin letter ae & AE
                    "< \u00F8, \u00D8" +     // Latin letter o & O with stroke
                    "< \u00E5 = a\u030A," +  // Latin letter a with ring above
                    "  \u00C5 = A\u030A;" +  // Latin letter A with ring above
                    "  aa, AA";
 RuleBasedCollator myNorwegian = new RuleBasedCollator(Norwegian);

    可以通过连接规则字符串来创建新的归类规则字符串。 例如，由getRules()返回的规则可以连接以组合多个RuleBasedCollator s。

    以下示例演示如何更改非间距重音符的顺序，

     // old rule
 String oldRules = "=\u0301;\u0300;\u0302;\u0308"    // main accents
                 + ";\u0327;\u0303;\u0304;\u0305"    // main accents
                 + ";\u0306;\u0307;\u0309;\u030A"    // main accents
                 + ";\u030B;\u030C;\u030D;\u030E"    // main accents
                 + ";\u030F;\u0310;\u0311;\u0312"    // main accents
                 + "< a , A ; ae, AE ; \u00e6 , \u00c6"
                 + "< b , B < c, C < e, E & C < d, D";
 // change the order of accent characters
 String addOn = "& \u0300 ; \u0308 ; \u0302";
 RuleBasedCollator myCollator = new RuleBasedCollator(oldRules + addOn);
    从以下版本开始：
    1.1
    另请参见：
    Collator ， CollationElementIterator

    • Field Summary

      • Fields inherited from class java.text.Collator

        CANONICAL_DECOMPOSITION, FULL_DECOMPOSITION, IDENTICAL, NO_DECOMPOSITION, PRIMARY, SECONDARY, TERTIARY

    • 构造方法摘要

      构造方法
      Constructor 描述
      RuleBasedCollator​(String rules)
      RuleBasedCollator构造函数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      标准覆盖 语义不变。
      int compare​(String source, String target)
      基于归类规则比较存储在两个不同字符串中的字符数据。
      boolean equals​(Object obj)
      比较两个对照对象的相等性。
      CollationElementIterator getCollationElementIterator​(String source)
      返回给定String的CollationElementIterator。
      CollationElementIterator getCollationElementIterator​(CharacterIterator source)
      返回给定CharacterIterator的CollationElementIterator。
      CollationKey getCollationKey​(String source)
      将字符串转换成可以与CollationKey.compareTo进行比较的一系列字符。
      String getRules​()
      获取排序规则对象的基于表的规则。
      int hashCode​()
      生成基于表的归类对象的哈希码

      • Methods inherited from class java.text.Collator

        compare, equals, getAvailableLocales, getDecomposition, getInstance, getInstance, getStrength, setDecomposition, setStrength

      • Methods inherited from interface java.util.Comparator

        comparing, comparing, comparingDouble, comparingInt, comparingLong, naturalOrder, nullsFirst, nullsLast, reversed, reverseOrder, thenComparing, thenComparing, thenComparing, thenComparingDouble, thenComparingInt, thenComparingLong

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RuleBasedCollator

        public RuleBasedCollator​(String rules)
                  throws ParseException
        RuleBasedCollator构造函数。 这需要表规则并构建一个排序规则表。 有关归类规则语法的更多详细信息，请参阅RuleBasedCollator类描述。
        参数
        rules - 用于构建排序规则表的排序规则。
        异常
        ParseException - 如果规则的构建过程失败，将抛出格式异常。 例如，构建规则“a <？<d”将导致构造函数抛出ParseException，因为'？' 没有引用。
        另请参见：
        Locale

    • 方法详细信息

      • getRules

        public String getRules​()
        获取排序规则对象的基于表的规则。
        结果
        返回从排序规则对象创建的排序规则。

      • getCollationElementIterator

        public CollationElementIterator getCollationElementIterator​(String source)
        返回给定String的CollationElementIterator。
        参数
        source - 要整理的字符串
        结果
        一个 CollationElementIterator对象
        另请参见：
        CollationElementIterator

      • getCollationElementIterator

        public CollationElementIterator getCollationElementIterator​(CharacterIterator source)
        返回给定CharacterIterator的CollationElementIterator。
        参数
        source - 要整理的字符迭代器
        结果
        一个 CollationElementIterator对象
        从以下版本开始：
        1.2
        另请参见：
        CollationElementIterator

      • compare

        public int compare​(String source,
                   String target)
        基于归类规则比较存储在两个不同字符串中的字符数据。 返回有关字符串是否小于，大于或等于语言中另一个字符串的信息。 这可以在子类中覆盖。
        Specified by:
        compare在类 Collator
        参数
        source - 源字符串。
        target - 目标字符串。
        结果
        返回一个整数值。 如果源小于目标值，则值小于零，如果源和目标相等，则值为零，如果源大于目标值，则值大于零。
        异常
        NullPointerException - 如果 source或 target为空。
        另请参见：
        CollationKey ， Collator.getCollationKey(java.lang.String)

      • getCollationKey

        public CollationKey getCollationKey​(String source)
        将字符串转换成可以与CollationKey.compareTo进行比较的一系列字符。 这将覆盖java.text.Collator.getCollationKey。 它可以在一个子类中被覆盖。
        Specified by:
        getCollationKey在 Collator
        参数
        source - 要转换为归类密钥的字符串。
        结果
        基于此Collator的排序规则的给定String的CollationKey。 如果源String为null，则返回一个空CollationKey。
        另请参见：
        CollationKey ， Collator.compare(java.lang.String, java.lang.String)

      • clone

        public Object clone​()
        标准覆盖 语义不变。
        重写：
        clone在 Collator
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • equals

        public boolean equals​(Object obj)
        比较两个对照对象的相等性。
        Specified by:
        equals在接口 Comparator<Object>
        重写：
        equals在 Collator
        参数
        obj - 要与之进行比较的基于表的归类对象。
        结果
        如果当前基于表的归类对象与基于表的归类对象obj相同，则为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        生成基于表的归类对象的哈希码
        Specified by:
        hashCode在 Collator
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleDateFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class SimpleDateFormat

  • java.lang.Object
    • java.text.Format
      • java.text.DateFormat
        • java.text.SimpleDateFormat
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class SimpleDateFormat
extends DateFormat
    SimpleDateFormat是一个具体的类，用于以区域设置敏感的方式格式化和解析日期。 它允许格式化（日期文本），解析（文本日期）和规范化。

    SimpleDateFormat允许您从选择日期时间格式化的任何用户定义的模式开始。 不过，建议您创建一个日期-时间格式有两种getTimeInstance ， getDateInstance ，或getDateTimeInstance在DateFormat 。 这些类方法中的每一个都可以返回使用默认格式模式初始化的日期/时间格式化程序。 您可以根据需要使用applyPattern方法修改格式模式。 有关使用这些方法的更多信息，请参阅DateFormat 。

    日期和时间模式

    日期和时间格式由日期和时间模式字符串指定。 在日期和时间模式字符串中，从'A'到'Z'以及从'a'到'z'引号的字母被解释为表示日期或时间字符串的组件的模式字母。 可以使用单引号（ ' ）引用文本，以避免解释。 "''"代表单引号。 所有其他字符不被解释; 在格式化过程中，它们只是复制到输出字符串中，或者在解析过程中与输入字符串匹配。

    定义了以下图案字母（所有其他字符从'A'到'Z'和从'a'到'z'被保留）：

    Chart shows pattern letters, date/time component, presentation, and examples.
    Letter | Date or Time Component | Presentation | Examples
    G | Era designator | Text | AD
    y | Year | Year | 1996; 96
    Y | Week year | Year | 2009; 09
    M | Month in year (context sensitive) | Month | July; Jul; 07
    L | Month in year (standalone form) | Month | July; Jul; 07
    w | Week in year | Number | 27
    W | Week in month | Number | 2
    D | Day in year | Number | 189
    d | Day in month | Number | 10
    F | Day of week in month | Number | 2
    E | Day name in week | Text | Tuesday; Tue
    u | Day number of week (1 = Monday, ..., 7 = Sunday) | Number | 1
    a | Am/pm marker | Text | PM
    H | Hour in day (0-23) | Number | 0
    k | Hour in day (1-24) | Number | 24
    K | Hour in am/pm (0-11) | Number | 0
    h | Hour in am/pm (1-12) | Number | 12
    m | Minute in hour | Number | 30
    s | Second in minute | Number | 55
    S | Millisecond | Number | 978
    z | Time zone | General time zone | Pacific Standard Time; PST; GMT-08:00
    Z | Time zone | RFC 822 time zone | -0800
    X | Time zone | ISO 8601 time zone | -08; -0800; -08:00
    模式字母通常重复，因为它们的数字确定了准确的表示：
    • Text:对于格式化，如果模式字母数为4以上，则使用完整形式; 否则，如果有的话，使用简短或缩写形式。 对于解析，两种形式都是接受的，与模式字母的数量无关。

    • Number:对于格式化，模式字母的数量是最小位数，较短的数字被填充到该数量。 对于解析，模式字母的数量将被忽略，除非需要分隔两个相邻的字段。

    • Year:如果格式化程序的Calendar是公历，则应用以下规则。
      • 对于格式化，如果模式字母数为2，那么年份将被截断为2位数; 否则解释为number 。
      • 对于解析，如果模式字母的数量大于2，则年份将按字面解释，而不管数字的数量。 所以使用模式“MM / dd / yyyy”，“01/11/12”解析为公元12年1月11日
      • 要使用缩写年份模式（“y”或“yy”）进行解析， SimpleDateFormat必须解释相对于某个世纪的缩写年份。 这样做是通过将日期调整为在创建SimpleDateFormat实例之后的80年之前和20年之后。 例如，使用1997年1月1日创建的“MM / dd / yy”和SimpleDateFormat实例的模式，字符串“01/11/12”将被解释为2012年1月11日，而字符串“05/04 / 64“将被解释为1964年5月4日。在解析期间，只有由Character.isDigit(char)定义的两个数字组成的字符串将被解析为默认世纪。 任何其他数字字符串，例如一位数字字符串，三位或三位以上数字字符串，或两位数字字符串（全部不是全部数字）（例如“-1”），均按字面解释。 所以“01/02/3”或“01/02/003”的解析方式与公元3年1月2日相同。 同样，“01/02 / -3”在公元前4年1月2日被解析。
      否则，将应用日历系统特定的表单。 对于格式化和解析两者，如果模式字母数为4以上，则使用特定日历long form的日历。 否则，使用特定于日历的日历short or abbreviated form 。

      如果本周年'Y'了规定，并且calendar不支持任何week years ，历年（ 'y' ）来代替。 可以通过致电getCalendar()测试一周的支持。 isWeekDateSupported() 。

    • Month:如果模式字母数为3以上，则该月份被解释为text ; 否则，它被解释为number 。
      • 字母M产生上下文相关的月份名称，例如嵌入的名称形式。 字母M是上下文敏感的，因为当它在独立模式中使用时，例如“MMMM”，它给出了一个月份名称的独立形式，并且当它在包含其他字段的模式中使用时，例如，“d MMMM”，它给出了一个月份名称的格式。 例如，加泰罗尼亚语的1月是格式形式的“de gener”，而它们是独立形式的“gener”。 在这种情况下，“MMMM”会产生“一般”，“d MMMM”的月份将产生“通用”。 如果已经使用构造函数SimpleDateFormat(String,DateFormatSymbols)或方法setDateFormatSymbols(DateFormatSymbols)明确设置了一个DateFormatSymbols ，则使用由DateFormatSymbols给出的月份名称。
      • L字母生成独立形式的月份名称。

    • General time zone:如果他们有姓名，时区将被解释为text 。 对于表示GMT偏移值的时区，使用以下语法：
        GMTOffsetTimeZone:
             GMT Sign Hours : Minutes
     Sign: one of
             + -
     Hours:
             Digit
             Digit Digit
     Minutes:
             Digit Digit
     Digit: one of
             0 1 2 3 4 5 6 7 8 9
      小时数必须在0到23之间， 分钟必须介于00和59之间。格式与区域设置无关，数字必须取自Unicode标准的基本拉丁方块。

      对于解析， RFC 822 time zones也被接受。

    • RFC 822 time zone:格式化时，使用RFC 822 4位数时区格式：
        RFC822TimeZone:
             Sign TwoDigitHours Minutes
     TwoDigitHours:
             Digit Digit
      TwoDigitHours必须介于00和23之间。其他定义与general time zones相同 。

      对于解析， general time zones也被接受。

    • ISO 8601 Time zone:模式字母的数量指定格式和解析的格式如下：
        ISO8601TimeZone:
             OneLetterISO8601TimeZone
             TwoLetterISO8601TimeZone
             ThreeLetterISO8601TimeZone
     OneLetterISO8601TimeZone:
             Sign TwoDigitHours
             Z
     TwoLetterISO8601TimeZone:
             Sign TwoDigitHours Minutes
             Z
     ThreeLetterISO8601TimeZone:
             Sign TwoDigitHours : Minutes
             Z
      其他定义与general time zones或RFC 822 time zones相同 。

      对于格式化，如果GMT的偏移值为0，则产生"Z" 。 如果模式字母的数量为1，则忽略小时数。 例如，如果模式是"X" ，而时区是"GMT+05:30" ，则产生"+05" 。

      对于解析， "Z"被解析为UTC时区指示符。 General time zones 不被接受。

      如果模式字母的数目是4或更多， IllegalArgumentException被构建时抛出SimpleDateFormat或applying a pattern 。

    SimpleDateFormat还支持本地化的日期和时间模式字符串。 在这些字符串中，上述的图案字母可以被替换为其他与区域相关的图案字母。 SimpleDateFormat不处理除了图案字母之外的文本的本地化; 这取决于课堂的客户。

    例子

    以下示例显示如何在美国地区中解释日期和时间模式。 给定的日期和时间是2001-07-04 12:08:56当地时间在美国太平洋时间时区。
    Examples of date and time patterns interpreted in the U.S. locale
    Date and Time Pattern | Result
    "yyyy.MM.dd G 'at' HH:mm:ss z" | 2001.07.04 AD at 12:08:56 PDT
    "EEE, MMM d, ''yy" | Wed, Jul 4, '01
    "h:mm a" | 12:08 PM
    "hh 'o''clock' a, zzzz" | 12 o'clock PM, Pacific Daylight Time
    "K:mm a, z" | 0:08 PM, PDT
    "yyyyy.MMMMM.dd GGG hh:mm aaa" | 02001.July.04 AD 12:08 PM
    "EEE, d MMM yyyy HH:mm:ss Z" | Wed, 4 Jul 2001 12:08:56 -0700
    "yyMMddHHmmssZ" | 010704120856-0700
    "yyyy-MM-dd'T'HH:mm:ss.SSSZ" | 2001-07-04T12:08:56.235-0700
    "yyyy-MM-dd'T'HH:mm:ss.SSSXXX" | 2001-07-04T12:08:56.235-07:00
    "YYYY-'W'ww-u" | 2001-W27-3

    Synchronization

    日期格式不同步。 建议为每个线程创建单独的格式实例。 如果多个线程同时访问格式，则必须在外部进行同步。

    从以下版本开始：
    1.1
    另请参见：
    Java Tutorial ， Calendar ， TimeZone ， DateFormat ， DateFormatSymbols ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.text.DateFormat

        DateFormat.Field

    • Field Summary

      • Fields inherited from class java.text.DateFormat

        AM_PM_FIELD, calendar, DATE_FIELD, DAY_OF_WEEK_FIELD, DAY_OF_WEEK_IN_MONTH_FIELD, DAY_OF_YEAR_FIELD, DEFAULT, ERA_FIELD, FULL, HOUR_OF_DAY0_FIELD, HOUR_OF_DAY1_FIELD, HOUR0_FIELD, HOUR1_FIELD, LONG, MEDIUM, MILLISECOND_FIELD, MINUTE_FIELD, MONTH_FIELD, numberFormat, SECOND_FIELD, SHORT, TIMEZONE_FIELD, WEEK_OF_MONTH_FIELD, WEEK_OF_YEAR_FIELD, YEAR_FIELD

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleDateFormat​()
      构造一个 SimpleDateFormat使用默认模式和日期格式符号为默认的 FORMAT区域设置。
      SimpleDateFormat​(String pattern)
      使用给定模式构建一个 SimpleDateFormat ，默认日期格式符号为默认的 FORMAT区域设置。
      SimpleDateFormat​(String pattern, DateFormatSymbols formatSymbols)
      使用给定的模式和日期格式符号构造一个 SimpleDateFormat 。
      SimpleDateFormat​(String pattern, Locale locale)
      使用给定的模式构建一个 SimpleDateFormat ，并为给定的区域设置默认的日期格式符号。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyLocalizedPattern​(String pattern)
      将给定的本地化模式字符串应用于此日期格式。
      void applyPattern​(String pattern)
      将给定的模式字符串应用于此日期格式。
      Object clone​()
      创建一个这个 SimpleDateFormat的副本。
      boolean equals​(Object obj)
      将给定对象与此 SimpleDateFormat进行比较以获得相等性。
      StringBuffer format​(Date date, StringBuffer toAppendTo, FieldPosition pos)
      将给定的 Date为日期/时间字符串，并将结果追加到给定的 StringBuffer 。
      AttributedCharacterIterator formatToCharacterIterator​(Object obj)
      格式化产生一个 AttributedCharacterIterator的对象。
      Date get2DigitYearStart​()
      返回100年期间的开始日期，2位数年份被解释为在内。
      DateFormatSymbols getDateFormatSymbols​()
      获取此日期格式的日期和时间格式符号的副本。
      int hashCode​()
      返回此 SimpleDateFormat对象的哈希码值。
      Date parse​(String text, ParsePosition pos)
      从字符串中解析文本以产生一个 Date 。
      void set2DigitYearStart​(Date startDate)
      设置100年期间，两位数年份将被解释为在用户指定的日期开始。
      void setDateFormatSymbols​(DateFormatSymbols newFormatSymbols)
      设置此日期格式的日期和时间格式符号。
      String toLocalizedPattern​()
      返回描述此日期格式的本地化模式字符串。
      String toPattern​()
      返回描述此日期格式的模式字符串。

      • Methods inherited from class java.text.DateFormat

        format, format, getAvailableLocales, getCalendar, getDateInstance, getDateInstance, getDateInstance, getDateTimeInstance, getDateTimeInstance, getDateTimeInstance, getInstance, getNumberFormat, getTimeInstance, getTimeInstance, getTimeInstance, getTimeZone, isLenient, parse, parseObject, setCalendar, setLenient, setNumberFormat, setTimeZone

      • Methods inherited from class java.text.Format

        format, parseObject

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SimpleDateFormat

        public SimpleDateFormat​()
        构造一个SimpleDateFormat使用默认模式和日期格式符号进行默认的FORMAT语言环境。 注意：此构造函数可能不支持所有区域设置。 要全面覆盖，请使用DateFormat类中的工厂方法。

      • SimpleDateFormat

        public SimpleDateFormat​(String pattern)
        构造一个SimpleDateFormat使用给定的模式和默认的日期格式符号为默认的FORMAT区域设置。 注意：此构造函数可能不支持所有区域设置。 要完整覆盖，请使用DateFormat类中的工厂方法。

        这相当于调用SimpleDateFormat(pattern, Locale.getDefault(Locale.Category.FORMAT)) 。

        参数
        pattern - 描述日期和时间格式的模式
        异常
        NullPointerException - 如果给定的模式为空
        IllegalArgumentException - 如果给定的模式无效
        另请参见：
        Locale.getDefault(java.util.Locale.Category) ， Locale.Category.FORMAT

      • SimpleDateFormat

        public SimpleDateFormat​(String pattern,
                        Locale locale)
        构造一个SimpleDateFormat使用给定的模式和给定语言环境的默认日期格式符号。 注意：此构造函数可能不支持所有区域设置。 要完整覆盖，请使用DateFormat类中的工厂方法。
        参数
        pattern - 描述日期和时间格式的模式
        locale - 应使用日期格式符号的区域设置
        异常
        NullPointerException - 如果给定的模式或区域设置为空
        IllegalArgumentException - 如果给定的模式无效

      • SimpleDateFormat

        public SimpleDateFormat​(String pattern,
                        DateFormatSymbols formatSymbols)
        使用给定的模式和日期格式符号构造一个 SimpleDateFormat 。
        参数
        pattern - 描述日期和时间格式的模式
        formatSymbols - 要用于格式化的日期格式符号
        异常
        NullPointerException - 如果给定的模式或formatSymbols为空
        IllegalArgumentException - 如果给定的模式无效

    • 方法详细信息

      • set2DigitYearStart

        public void set2DigitYearStart​(Date startDate)
        设置100年期间，两位数年份将被解释为在用户指定的日期开始。
        参数
        startDate - 在解析期间，两位数年份将放置在 startDate到 startDate + 100 years的范围内。
        异常
        NullPointerException - 如果 startDate是 null 。
        从以下版本开始：
        1.2
        另请参见：
        get2DigitYearStart()

      • get2DigitYearStart

        public Date get2DigitYearStart​()
        返回100年期间的开始日期，2位数年份被解释为在内。
        结果
        开始解读两位数年的100年期间
        从以下版本开始：
        1.2
        另请参见：
        set2DigitYearStart(java.util.Date)

      • format

        public StringBuffer format​(Date date,
                           StringBuffer toAppendTo,
                           FieldPosition pos)
        将给定的 Date成日期/时间字符串，并将结果追加到给定的 StringBuffer 。
        Specified by:
        format在 DateFormat
        参数
        date - 要格式化为日期时间字符串的日期时间值。
        toAppendTo - 要附加新的日期时间文本。
        pos - 格式化位置。 在输入：对齐字段，如果需要。 输出：对齐字段的偏移量。
        结果
        格式化的日期时间字符串。
        异常
        NullPointerException - 如果任何参数是 null 。

      • formatToCharacterIterator

        public AttributedCharacterIterator formatToCharacterIterator​(Object obj)
        格式化一个对象，生成一个AttributedCharacterIterator 。 您可以使用返回的AttributedCharacterIterator构建生成的String，以及确定有关生成的String的信息。

        AttributedCharacterIterator的每个属性键将是类型为DateFormat.Field ，对应的属性值与属性键相同。

        重写：
        formatToCharacterIterator在 Format
        参数
        obj - 要格式化的对象
        结果
        AttributedCharacterIterator描述格式化的值。
        异常
        NullPointerException - 如果obj为空。
        IllegalArgumentException - 如果格式不能格式化给定的对象，或格式的模式字符串无效。
        从以下版本开始：
        1.4

      • parse

        public Date parse​(String text,
                  ParsePosition pos)
        从字符串中解析文本，产生一个Date 。

        该方法尝试从pos给出的索引开始解析文本。 如果解析成功，则pos的索引将更新为使用最后一个字符后的索引（解析不一定使用字符串末尾的所有字符），并返回解析的日期。 更新的pos可用于指示下一次调用此方法的起始点。 如果发生错误，则pos的索引不改变，则将错误索引pos设置为发生错误的字符的索引，返回null。

        此解析操作使用calendar生成Date 。 所有的calendar的日期时间字段cleared解析之前，与calendar “被用于任何丢失的日期时间信息S日期时间字段的默认值。 例如，如果解析操作没有给出年值，则解析的Date的年值为1970，为GregorianCalendar 。 TimeZone值可能会被覆盖，这取决于给定的模式和时区值在text 。 以前通过调用setTimeZone设置的任何TimeZone值都可能需要恢复进一步操作。

        Specified by:
        parse在 DateFormat
        参数
        text - A String ，其中一部分应该被解析。
        pos - 具有上述索引和错误索引信息的 ParsePosition对象。
        结果
        A Date从字符串中解析。 万一出错，返回null。
        异常
        NullPointerException - 如果 text或 pos为空。

      • toPattern

        public String toPattern​()
        返回描述此日期格式的模式字符串。
        结果
        描述此日期格式的模式字符串。

      • toLocalizedPattern

        public String toLocalizedPattern​()
        返回描述此日期格式的本地化模式字符串。
        结果
        描述此日期格式的本地化模式字符串。

      • applyPattern

        public void applyPattern​(String pattern)
        将给定的模式字符串应用于此日期格式。
        参数
        pattern - 此日期格式的新日期和时间模式
        异常
        NullPointerException - 如果给定的模式为空
        IllegalArgumentException - 如果给定的模式无效

      • applyLocalizedPattern

        public void applyLocalizedPattern​(String pattern)
        将给定的本地化模式字符串应用于此日期格式。
        参数
        pattern - 要映射到此格式的新日期和时间格式模式的字符串
        异常
        NullPointerException - 如果给定的模式为空
        IllegalArgumentException - 如果给定的模式无效

      • getDateFormatSymbols

        public DateFormatSymbols getDateFormatSymbols​()
        获取此日期格式的日期和时间格式符号的副本。
        结果
        该日期格式的日期和时间格式符号
        另请参见：
        setDateFormatSymbols(java.text.DateFormatSymbols)

      • setDateFormatSymbols

        public void setDateFormatSymbols​(DateFormatSymbols newFormatSymbols)
        设置此日期格式的日期和时间格式符号。
        参数
        newFormatSymbols - 新的日期和时间格式符号
        异常
        NullPointerException - 如果给定的newFormatSymbols为空
        另请参见：
        getDateFormatSymbols()

      • clone

        public Object clone​()
        创建一个这个SimpleDateFormat的副本。 这也克隆了格式的日期格式符号。
        重写：
        clone在 DateFormat
        结果
        这个 SimpleDateFormat的克隆
        另请参见：
        Cloneable

      • hashCode

        public int hashCode​()
        返回此 SimpleDateFormat对象的哈希码值。
        重写：
        hashCode在 DateFormat
        结果
        这个 SimpleDateFormat对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将给定对象与此 SimpleDateFormat进行比较以获得相等性。
        重写：
        equals在 DateFormat
        参数
        obj - 与之比较的参考对象。
        结果
        如果给定的对象等于这个 SimpleDateFormat
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringCharacterIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text

Class StringCharacterIterator

  • java.lang.Object
    • java.text.StringCharacterIterator
  • All Implemented Interfaces:
    Cloneable ， CharacterIterator

    public final class StringCharacterIterator
extends Object
implements CharacterIterator
    StringCharacterIterator实现CharacterIterator协议为String 。 StringCharacterIterator类遍历整个String 。
    从以下版本开始：
    1.1
    另请参见：
    CharacterIterator

    • Field Summary

      • Fields inherited from interface java.text.CharacterIterator

        DONE

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringCharacterIterator​(String text)
      构造一个初始索引为0的迭代器。
      StringCharacterIterator​(String text, int pos)
      构造具有指定初始索引的迭代器。
      StringCharacterIterator​(String text, int begin, int end, int pos)
      在给定字符串的给定范围内构造迭代器，索引设置在指定的位置。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建此迭代器的副本。
      char current​()
      为String执行CharacterIterator.current（）。
      boolean equals​(Object obj)
      比较两个StringCharacterIterator对象的相等性。
      char first​()
      为String实现CharacterIterator.first（）。
      int getBeginIndex​()
      为String实现CharacterIterator.getBeginIndex（）。
      int getEndIndex​()
      为String执行CharacterIterator.getEndIndex（）。
      int getIndex​()
      为String实现CharacterIterator.getIndex（）。
      int hashCode​()
      计算此迭代器的哈希码。
      char last​()
      为String实现CharacterIterator.last（）。
      char next​()
      为String执行CharacterIterator.next（）。
      char previous​()
      为String实现CharacterIterator.previous（）。
      char setIndex​(int p)
      为String实现CharacterIterator.setIndex（）。
      void setText​(String text)
      重置这个迭代器以指向一个新的字符串。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StringCharacterIterator

        public StringCharacterIterator​(String text)
        构造一个初始索引为0的迭代器。
        参数
        text - 要迭代的 String

      • StringCharacterIterator

        public StringCharacterIterator​(String text,
                               int pos)
        构造具有指定初始索引的迭代器。
        参数
        text - 要迭代的字符串
        pos - 初始迭代器位置

      • StringCharacterIterator

        public StringCharacterIterator​(String text,
                               int begin,
                               int end,
                               int pos)
        在给定字符串的给定范围内构造迭代器，索引设置在指定的位置。
        参数
        text - 要迭代的字符串
        begin - 第一个字符的索引
        end - 最后一个字符后面的字符的索引
        pos - 初始迭代器位置

    • 方法详细信息

      • setText

        public void setText​(String text)
        重置这个迭代器以指向一个新的字符串。 这个package-visible方法被其他java.text类使用，希望在每次调用setText方法时避免分配新的StringCharacterIterator对象。
        参数
        text - 要迭代的字符串
        从以下版本开始：
        1.2

      • first

        public char first​()
        为String实现CharacterIterator.first（）。
        Specified by:
        first在接口 CharacterIterator
        结果
        文本中的第一个字符，如果文本为空，则为DONE
        另请参见：
        CharacterIterator.first()

      • last

        public char last​()
        为String实现CharacterIterator.last（）。
        Specified by:
        last在接口 CharacterIterator
        结果
        文本中的最后一个字符，如果文本为空，则为DONE
        另请参见：
        CharacterIterator.last()

      • setIndex

        public char setIndex​(int p)
        为String实现CharacterIterator.setIndex（）。
        Specified by:
        setIndex在接口 CharacterIterator
        参数
        p - 文本中的位置。 有效值的范围从getBeginIndex（）到getEndIndex（）。 如果提供了无效值，则会抛出IllegalArgumentException异常。
        结果
        指定位置的字符或DONE，如果指定的位置等于getEndIndex（）
        另请参见：
        CharacterIterator.setIndex(int)

      • current

        public char current​()
        为String执行CharacterIterator.current（）。
        Specified by:
        current在接口 CharacterIterator
        结果
        当前位置的字符，如果当前位置离开文本末尾，则为DONE。
        另请参见：
        CharacterIterator.current()

      • next

        public char next​()
        为String执行CharacterIterator.next（）。
        Specified by:
        next在接口 CharacterIterator
        结果
        新位置的角色，如果新的位置在文本范围的结尾，则为DONE。
        另请参见：
        CharacterIterator.next()

      • previous

        public char previous​()
        为String实现CharacterIterator.previous（）。
        Specified by:
        previous在接口 CharacterIterator
        结果
        当前位置等于getBeginIndex（）时，新位置的角色为DONE。
        另请参见：
        CharacterIterator.previous()

      • getBeginIndex

        public int getBeginIndex​()
        为String实现CharacterIterator.getBeginIndex（）。
        Specified by:
        getBeginIndex在接口 CharacterIterator
        结果
        文本开始的索引。
        另请参见：
        CharacterIterator.getBeginIndex()

      • getEndIndex

        public int getEndIndex​()
        为String执行CharacterIterator.getEndIndex（）。
        Specified by:
        getEndIndex在接口 CharacterIterator
        结果
        文本中最后一个字符后的索引
        另请参见：
        CharacterIterator.getEndIndex()

      • getIndex

        public int getIndex​()
        为String实现CharacterIterator.getIndex（）。
        Specified by:
        getIndex在接口 CharacterIterator
        结果
        当前指数。
        另请参见：
        CharacterIterator.getIndex()

      • equals

        public boolean equals​(Object obj)
        比较两个StringCharacterIterator对象的相等性。
        重写：
        equals类 Object
        参数
        obj - 要与之比较的StringCharacterIterator对象。
        结果
        如果给定的obj与此StringCharacterIterator对象相同，则为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算此迭代器的哈希码。
        重写：
        hashCode在 Object
        结果
        哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • clone

        public Object clone​()
        创建此迭代器的副本。
        Specified by:
        clone在接口 CharacterIterator
        重写：
        clone在 Object
        结果
        这个的副本
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.text (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.text

  • Packages that use java.text
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。
    java.time.format
    提供打印和解析日期和时间的类。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
  • Classes in java.text used by com.sun.source.util
    Class 描述
    BreakIterator
    BreakIterator类实现了查找文本中边界位置的方法。
  • Classes in java.text used by java.awt
    Class 描述
    AttributedCharacterIterator
    AttributedCharacterIterator允许通过文本和相关属性信息进行迭代。
    AttributedCharacterIterator.Attribute
    定义用于标识文本属性的属性键。
    CharacterIterator
    该接口定义了一种用于文本双向迭代的协议。
  • Classes in java.text used by java.awt.event
    Class 描述
    AttributedCharacterIterator
    一个 AttributedCharacterIterator允许通过文本和相关的属性信息进行迭代。
  • Classes in java.text used by java.awt.font
    Class 描述
    AttributedCharacterIterator
    一个 AttributedCharacterIterator允许通过文本和相关的属性信息进行迭代。
    AttributedCharacterIterator.Attribute
    定义用于标识文本属性的属性键。
    BreakIterator
    BreakIterator类实现了在文本中查找边界位置的方法。
  • Classes in java.text used by java.awt.im
    Class 描述
    AttributedCharacterIterator
    一个 AttributedCharacterIterator允许通过文本和相关的属性信息进行迭代。
    AttributedCharacterIterator.Attribute
    定义用于标识文本属性的属性键。
  • Classes in java.text used by java.awt.im.spi
    Class 描述
    AttributedCharacterIterator
    一个 AttributedCharacterIterator允许通过文本和相关的属性信息进行迭代。
  • Classes in java.text used by java.text
    Class 描述
    AttributedCharacterIterator
    一个 AttributedCharacterIterator允许通过文本和相关的属性信息进行迭代。
    AttributedCharacterIterator.Attribute
    定义用于标识文本属性的属性键。
    Bidi
    该类实现了Unicode双向算法。
    BreakIterator
    BreakIterator类实现了在文本中查找边界位置的方法。
    CharacterIterator
    该接口定义了一种用于文本双向迭代的协议。
    CollationElementIterator
    CollationElementIterator类用作遍历国际字符串的每个字符的迭代器。
    CollationKey
    A CollationKey表示一个 String的规则下的一个特定的 Collator对象。
    Collator
    Collator类执行区域设置敏感 String比较。
    DateFormat
    DateFormat是日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。
    DateFormat.Field
    定义了用于作为属性键常数 AttributedCharacterIterator从返回 DateFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
    DateFormatSymbols
    DateFormatSymbols是用于封装可本地化的日期时间格式化数据的公共类，例如月份的名称，星期几的名称和时区数据。
    DecimalFormatSymbols
    此类表示 DecimalFormat格式化数字所需的符号集（如小数分隔符，分组分隔符等）。
    FieldPosition
    FieldPosition是由 Format及其子类使用的简单类，用于标识格式化输出中的字段。
    Format
    Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
    Format.Field
    定义了用于作为属性键常数 AttributedCharacterIterator从返回 Format.formatToCharacterIterator和字段标识符在 FieldPosition 。
    MessageFormat.Field
    定义从 MessageFormat.formatToCharacterIterator返回的 AttributedCharacterIterator中用作属性键的 MessageFormat.formatToCharacterIterator 。
    Normalizer.Form
    此枚举提供了 Unicode Standard Annex #15 — Unicode Normalization Forms中描述的四个Unicode归一化表单的常量，以及访问它们的两种方法。
    NumberFormat
    NumberFormat是所有数字格式的抽象基类。
    NumberFormat.Field
    定义了用于作为属性键常数 AttributedCharacterIterator从返回 NumberFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
    ParseException
    表示解析时意外出现错误。
    ParsePosition
    ParsePosition是由 Format及其子类使用的简单类，用于在解析期间跟踪当前位置。
  • Classes in java.text used by java.text.spi
    Class 描述
    BreakIterator
    BreakIterator类实现了在文本中查找边界位置的方法。
    Collator
    Collator类执行区域设置敏感 String比较。
    DateFormat
    DateFormat是一种用于日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。
    DateFormatSymbols
    DateFormatSymbols是用于封装可本地化的日期时间格式化数据的公共类，例如月份的名称，星期几的名称和时区数据。
    DecimalFormatSymbols
    此类表示 DecimalFormat格式化数字所需的符号集（如小数分隔符，分组分隔符等）。
    NumberFormat
    NumberFormat是所有数字格式的抽象基类。
  • Classes in java.text used by java.time.format
    Class 描述
    Format
    Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
    ParsePosition
    ParsePosition是一个使用的简单类，由 Format及其子类用于在解析过程中跟踪当前位置。
  • Classes in java.text used by javafx.beans.binding
    Class 描述
    Format
    Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
  • Classes in java.text used by javafx.beans.property
    Class 描述
    Format
    Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
  • Classes in java.text used by javafx.util.converter
    Class 描述
    DateFormat
    DateFormat是一种用于日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。
    Format
    Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
    NumberFormat
    NumberFormat是所有数字格式的抽象基类。
  • Classes in java.text used by javax.swing
    Class 描述
    AttributedCharacterIterator
    一个 AttributedCharacterIterator允许通过文本和相关的属性信息进行迭代。
    DecimalFormat
    DecimalFormat是格式为十进制数的 NumberFormat的具体子类。
    Format
    Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
    MessageFormat
    MessageFormat提供了一种以语言中立的方式产生级联消息的方法。
    ParseException
    表示解析时意外出现错误。
    SimpleDateFormat
    SimpleDateFormat是一个具体的类，用于以区域设置敏感的方式格式化和解析日期。
  • Classes in java.text used by javax.swing.plaf.synth
    Class 描述
    ParseException
    表示解析时意外出现错误。
  • Classes in java.text used by javax.swing.text
    Class 描述
    CharacterIterator
    该接口定义了一种用于文本双向迭代的协议。
    DateFormat
    DateFormat是日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。
    Format
    Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
    Format.Field
    定义了用于作为属性键常数 AttributedCharacterIterator从返回 Format.formatToCharacterIterator和字段标识符在 FieldPosition 。
    MessageFormat
    MessageFormat提供了一种以语言中立的方式产生级联消息的方法。
    NumberFormat
    NumberFormat是所有数字格式的抽象基类。
    ParseException
    表示解析时意外出现错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.Annotation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.Annotation

No usage of java.text.Annotation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.AttributedCharacterIterator.Attribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.AttributedCharacterIterator.Attribute

  • Packages that use AttributedCharacterIterator.Attribute
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.im
    提供输入法框架的类和接口。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of AttributedCharacterIterator.Attribute in java.awt

      Methods in java.awt that return AttributedCharacterIterator.Attribute
      Modifier and Type 方法 描述
      AttributedCharacterIterator.Attribute[] Font.getAvailableAttributes​()
      返回此 Font支持的所有属性的 Font 。
      Method parameters in java.awt with type arguments of type AttributedCharacterIterator.Attribute
      Modifier and Type 方法 描述
      Font Font.deriveFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      通过复制当前的 Font对象并应用一组新的字体属性来创建一个新的 Font对象。
      static Font Font.getFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      返回一个适合于属性的 Font 。
      Constructor parameters in java.awt with type arguments of type AttributedCharacterIterator.Attribute
      Constructor 描述
      Font​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      创建具有指定属性的新的 Font 。

    • Uses of AttributedCharacterIterator.Attribute in java.awt.font

      Subclasses of AttributedCharacterIterator.Attribute in java.awt.font
      Modifier and Type Class 描述
      class  TextAttribute
      TextAttribute类定义用于文本呈现的属性键和属性值。
      Constructor parameters in java.awt.font with type arguments of type AttributedCharacterIterator.Attribute
      Constructor 描述
      TextLayout​(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
      从一个 String构造一个 TextLayout和一个属性集。

    • Uses of AttributedCharacterIterator.Attribute in java.awt.im

      Methods in java.awt.im with parameters of type AttributedCharacterIterator.Attribute
      Modifier and Type 方法 描述
      AttributedCharacterIterator InputMethodRequests.cancelLatestCommittedText​(AttributedCharacterIterator.Attribute[] attributes)
      从文本编辑组件获取最新提交的文本，并将其从组件的文本正文中删除。
      AttributedCharacterIterator InputMethodRequests.getCommittedText​(int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
      获取一个迭代器，提供对文本编辑组件中包含的整个文本和属性的访问，除了未提交的文本。
      AttributedCharacterIterator InputMethodRequests.getSelectedText​(AttributedCharacterIterator.Attribute[] attributes)
      从文本编辑组件获取当前选定的文本。

    • Uses of AttributedCharacterIterator.Attribute in java.text

      Subclasses of AttributedCharacterIterator.Attribute in java.text
      Modifier and Type Class 描述
      static class  DateFormat.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 DateFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
      static class  Format.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 Format.formatToCharacterIterator和字段标识符在 FieldPosition 。
      static class  MessageFormat.Field
      定义从 MessageFormat.formatToCharacterIterator返回的 AttributedCharacterIterator中用作属性键的 MessageFormat.formatToCharacterIterator 。
      static class  NumberFormat.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 NumberFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
      Fields in java.text declared as AttributedCharacterIterator.Attribute
      Modifier and Type Field 描述
      static AttributedCharacterIterator.Attribute AttributedCharacterIterator.Attribute.INPUT_METHOD_SEGMENT
      输入方法段的属性键。
      static AttributedCharacterIterator.Attribute AttributedCharacterIterator.Attribute.LANGUAGE
      一些文本的语言的属性键。
      static AttributedCharacterIterator.Attribute AttributedCharacterIterator.Attribute.READING
      用于阅读某些文本的属性键。
      Methods in java.text that return types with arguments of type AttributedCharacterIterator.Attribute
      Modifier and Type 方法 描述
      Set<AttributedCharacterIterator.Attribute> AttributedCharacterIterator.getAllAttributeKeys​()
      返回在迭代器的文本范围上定义的所有属性的关键字。
      Map<AttributedCharacterIterator.Attribute,Object> AttributedCharacterIterator.getAttributes​()
      返回当前字符中定义的属性的地图。
      Methods in java.text with parameters of type AttributedCharacterIterator.Attribute
      Modifier and Type 方法 描述
      void AttributedString.addAttribute​(AttributedCharacterIterator.Attribute attribute, Object value)
      在整个字符串中添加一个属性。
      void AttributedString.addAttribute​(AttributedCharacterIterator.Attribute attribute, Object value, int beginIndex, int endIndex)
      将一个属性添加到字符串的子范围。
      Object AttributedCharacterIterator.getAttribute​(AttributedCharacterIterator.Attribute attribute)
      返回当前字符的名称为 attribute的值。
      AttributedCharacterIterator AttributedString.getIterator​(AttributedCharacterIterator.Attribute[] attributes)
      创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。
      AttributedCharacterIterator AttributedString.getIterator​(AttributedCharacterIterator.Attribute[] attributes, int beginIndex, int endIndex)
      创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。
      int AttributedCharacterIterator.getRunLimit​(AttributedCharacterIterator.Attribute attribute)
      返回运行后相对于包含当前字符的给定的 attribute的第一个字符的索引。
      int AttributedCharacterIterator.getRunStart​(AttributedCharacterIterator.Attribute attribute)
      相对于包含当前字符的给定的 attribute ，返回运行的第一个字符的索引。
      Method parameters in java.text with type arguments of type AttributedCharacterIterator.Attribute
      Modifier and Type 方法 描述
      void AttributedString.addAttributes​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes, int beginIndex, int endIndex)
      将一组属性添加到字符串的子范围。
      int AttributedCharacterIterator.getRunLimit​(Set<? extends AttributedCharacterIterator.Attribute> attributes)
      相对于包含当前字符的给定的 attributes返回运行后的第一个字符的索引。
      int AttributedCharacterIterator.getRunStart​(Set<? extends AttributedCharacterIterator.Attribute> attributes)
      相对于包含当前字符的给定的 attributes ，返回运行的第一个字符的索引。
      Constructors in java.text with parameters of type AttributedCharacterIterator.Attribute
      Constructor 描述
      AttributedString​(AttributedCharacterIterator text, int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
      使用AttributedCharacterIterator表示的给定归因文本的子范围构造一个AttributedString实例。
      Constructor parameters in java.text with type arguments of type AttributedCharacterIterator.Attribute
      Constructor 描述
      AttributedString​(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      使用给定的文本和属性构造一个AttributedString实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.AttributedString (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.AttributedString

No usage of java.text.AttributedString
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.Bidi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.Bidi

  • Packages that use Bidi
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of Bidi in java.text

      Methods in java.text that return Bidi
      Modifier and Type 方法 描述
      Bidi Bidi.createLineBidi​(int lineStart, int lineLimit)
      创建一个Bidi对象，该对象表示由当前Bidi表示的段落内的一行文本上的双目标信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.BreakIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.BreakIterator

  • Packages that use BreakIterator
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    java.awt.font
    提供与字体相关的类和界面。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。

    • Uses of BreakIterator in com.sun.source.util

      Methods in com.sun.source.util that return BreakIterator
      Modifier and Type 方法 描述
      abstract BreakIterator DocTrees.getBreakIterator​()
      返回用于计算文档注释第一句的break迭代器。
      Methods in com.sun.source.util with parameters of type BreakIterator
      Modifier and Type 方法 描述
      abstract void DocTrees.setBreakIterator​(BreakIterator breakiterator)
      设置break迭代器来计算文档注释的第一个句子。

    • Uses of BreakIterator in java.awt.font

      Constructors in java.awt.font with parameters of type BreakIterator
      Constructor 描述
      LineBreakMeasurer​(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
      为指定的文本构造一个 LineBreakMeasurer 。

    • Uses of BreakIterator in java.text

      Methods in java.text that return BreakIterator
      Modifier and Type 方法 描述
      static BreakIterator BreakIterator.getCharacterInstance​()
      返回一个新 BreakIterator例如 character breaks为 default locale 。
      static BreakIterator BreakIterator.getCharacterInstance​(Locale locale)
      返回一个新 BreakIterator例如 character breaks给定语言环境。
      static BreakIterator BreakIterator.getLineInstance​()
      返回一个新 BreakIterator例如 line breaks为 default locale 。
      static BreakIterator BreakIterator.getLineInstance​(Locale locale)
      为给定的区域设置返回一个新的 BreakIterator实例 line breaks 。
      static BreakIterator BreakIterator.getSentenceInstance​()
      返回一个新 BreakIterator例如 sentence breaks为 default locale 。
      static BreakIterator BreakIterator.getSentenceInstance​(Locale locale)
      为给定的语言环境返回一个新的 BreakIterator实例 sentence breaks 。
      static BreakIterator BreakIterator.getWordInstance​()
      返回一个新 BreakIterator例如 word breaks为 default locale 。
      static BreakIterator BreakIterator.getWordInstance​(Locale locale)
      返回一个新 BreakIterator例如 word breaks给定语言环境。

    • Uses of BreakIterator in java.text.spi

      Methods in java.text.spi that return BreakIterator
      Modifier and Type 方法 描述
      abstract BreakIterator BreakIteratorProvider.getCharacterInstance​(Locale locale)
      为给定的语言环境返回一个新的 BreakIterator实例 character breaks 。
      abstract BreakIterator BreakIteratorProvider.getLineInstance​(Locale locale)
      返回一个新 BreakIterator例如 line breaks给定语言环境。
      abstract BreakIterator BreakIteratorProvider.getSentenceInstance​(Locale locale)
      返回一个新 BreakIterator例如 sentence breaks给定语言环境。
      abstract BreakIterator BreakIteratorProvider.getWordInstance​(Locale locale)
      Returns a new BreakIterator instance for word breaks for the given locale.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.ChoiceFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.ChoiceFormat

No usage of java.text.ChoiceFormat
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.CollationElementIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.CollationElementIterator

  • Packages that use CollationElementIterator
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of CollationElementIterator in java.text

      Methods in java.text that return CollationElementIterator
      Modifier and Type 方法 描述
      CollationElementIterator RuleBasedCollator.getCollationElementIterator​(String source)
      返回给定String的CollationElementIterator。
      CollationElementIterator RuleBasedCollator.getCollationElementIterator​(CharacterIterator source)
      返回给定CharacterIterator的CollationElementIterator。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.CollationKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.CollationKey

  • Packages that use CollationKey
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of CollationKey in java.text

      Methods in java.text that return CollationKey
      Modifier and Type 方法 描述
      abstract CollationKey Collator.getCollationKey​(String source)
      将String转换成可以与其他CollationKeys进行比较的一系列位。
      CollationKey RuleBasedCollator.getCollationKey​(String source)
      将字符串转换成可以与CollationKey.compareTo进行比较的一系列字符。
      Methods in java.text with parameters of type CollationKey
      Modifier and Type 方法 描述
      abstract int CollationKey.compareTo​(CollationKey target)
      将此CollationKey与目标CollationKey进行比较。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.Collator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.Collator

  • Packages that use Collator
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。

    • Uses of Collator in java.text

      Subclasses of Collator in java.text
      Modifier and Type Class 描述
      class  RuleBasedCollator
      所述 RuleBasedCollator类是的具体子类 Collator ，提供了一个简单的，数据驱动的表collator。
      Methods in java.text that return Collator
      Modifier and Type 方法 描述
      static Collator Collator.getInstance​()
      获取当前默认语言环境的Collator。
      static Collator Collator.getInstance​(Locale desiredLocale)
      获取所需语言环境的Collator。

    • Uses of Collator in java.text.spi

      Methods in java.text.spi that return Collator
      Modifier and Type 方法 描述
      abstract Collator CollatorProvider.getInstance​(Locale locale)
      返回指定区域设置的新的 Collator实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.DateFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.DateFormat

  • Packages that use DateFormat
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of DateFormat in java.text

      Subclasses of DateFormat in java.text
      Modifier and Type Class 描述
      class  SimpleDateFormat
      SimpleDateFormat是一个具体的类，用于以区域设置敏感的方式格式化和解析日期。
      Methods in java.text that return DateFormat
      Modifier and Type 方法 描述
      static DateFormat DateFormat.getDateInstance​()
      获取默认格式化样式为默认的 FORMAT语言环境的日期格式化程序。
      static DateFormat DateFormat.getDateInstance​(int style)
      获取默认的 FORMAT区域设置的给定格式化样式的日期格式化程序。
      static DateFormat DateFormat.getDateInstance​(int style, Locale aLocale)
      获取给定区域设置的给定格式化样式的日期格式化程序。
      static DateFormat DateFormat.getDateTimeInstance​()
      获取日期/时间格式化程序的默认格式化样式为默认的 FORMAT区域设置。
      static DateFormat DateFormat.getDateTimeInstance​(int dateStyle, int timeStyle)
      获取默认的 FORMAT语言环境的给定日期和时间格式化样式的日期/时间格式化程序。
      static DateFormat DateFormat.getDateTimeInstance​(int dateStyle, int timeStyle, Locale aLocale)
      获取给定区域设置的给定格式样式的日期/时间格式化程序。
      static DateFormat DateFormat.getInstance​()
      获取在日期和时间上使用SHORT样式的默认日期/时间格式化程序。
      static DateFormat DateFormat.getTimeInstance​()
      获取默认格式化样式为默认的 FORMAT区域设置的时间格式化程序。
      static DateFormat DateFormat.getTimeInstance​(int style)
      获取默认的 FORMAT区域设置的给定格式化样式的时间格式化程序。
      static DateFormat DateFormat.getTimeInstance​(int style, Locale aLocale)
      获取给定区域设置的给定格式化样式的时间格式化程序。

    • Uses of DateFormat in java.text.spi

      Methods in java.text.spi that return DateFormat
      Modifier and Type 方法 描述
      abstract DateFormat DateFormatProvider.getDateInstance​(int style, Locale locale)
      返回一个新的 DateFormat实例，其格式为指定区域设置的给定格式化样式的日期。
      abstract DateFormat DateFormatProvider.getDateTimeInstance​(int dateStyle, int timeStyle, Locale locale)
      返回一个新的 DateFormat实例，它使用给定的格式化样式格式化日期和时间。
      abstract DateFormat DateFormatProvider.getTimeInstance​(int style, Locale locale)
      返回一个新的 DateFormat实例，该实例使用指定区域设置的给定格式化样式格式化时间。

    • Uses of DateFormat in javafx.util.converter

      Fields in javafx.util.converter declared as DateFormat
      Modifier and Type | Field | 描述
      protected DateFormat | DateTimeStringConverter.dateFormat
      Methods in javafx.util.converter that return DateFormat
      Modifier and Type 方法 描述
      protected DateFormat DateStringConverter.getDateFormat​()
      返回一个DateFormat实例，用于格式化和解析StringConverter 。
      protected DateFormat DateTimeStringConverter.getDateFormat​()
      返回一个DateFormat实例，用于在此StringConverter中进行格式化和解析。
      protected DateFormat TimeStringConverter.getDateFormat​()
      返回一个DateFormat实例，用于在此StringConverter中进行格式化和解析。
      Constructors in javafx.util.converter with parameters of type DateFormat
      Constructor 描述
      DateStringConverter​(DateFormat dateFormat)
      使用指定的DateFormat格式化程序为Date创建一个StringConverter值。
      DateTimeStringConverter​(DateFormat dateFormat)
      使用指定的DateFormat格式化程序为Date创建一个StringConverter值。
      TimeStringConverter​(DateFormat dateFormat)
      创建StringConverter为Date值，使用指定的DateFormat格式。

    • Uses of DateFormat in javax.swing.text

      Methods in javax.swing.text with parameters of type DateFormat
      Modifier and Type 方法 描述
      void DateFormatter.setFormat​(DateFormat format)
      设置指定可编辑和显示的合法值的格式。
      Constructors in javax.swing.text with parameters of type DateFormat
      Constructor 描述
      DateFormatter​(DateFormat format)
      返回配置了指定的 Format实例的DateFormatter。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.DateFormat.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.DateFormat.Field

  • Packages that use DateFormat.Field
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of DateFormat.Field in java.text

      Fields in java.text declared as DateFormat.Field
      Modifier and Type Field 描述
      static DateFormat.Field DateFormat.Field.AM_PM
      常数识别时间指示符（例如
      static DateFormat.Field DateFormat.Field.DAY_OF_MONTH
      不断识别月的字段。
      static DateFormat.Field DateFormat.Field.DAY_OF_WEEK
      不断识别星期几的字段。
      static DateFormat.Field DateFormat.Field.DAY_OF_WEEK_IN_MONTH
      不断识别星期几的字段。
      static DateFormat.Field DateFormat.Field.DAY_OF_YEAR
      常年识别日期字段。
      static DateFormat.Field DateFormat.Field.ERA
      不断识别时代领域。
      static DateFormat.Field DateFormat.Field.HOUR_OF_DAY0
      常数确定小时的字段，其中合法值为0到23。
      static DateFormat.Field DateFormat.Field.HOUR_OF_DAY1
      常数确定时间字段，法定值为1到24。
      static DateFormat.Field DateFormat.Field.HOUR0
      常数标识小时字段，合法值为0到11。
      static DateFormat.Field DateFormat.Field.HOUR1
      常数标识小时字段，合法值为1到12。
      static DateFormat.Field DateFormat.Field.MILLISECOND
      常量标识毫秒字段。
      static DateFormat.Field DateFormat.Field.MINUTE
      常数识别分钟字段。
      static DateFormat.Field DateFormat.Field.MONTH
      不断识别月份字段。
      static DateFormat.Field DateFormat.Field.SECOND
      常数识别第二个字段。
      static DateFormat.Field DateFormat.Field.TIME_ZONE
      不断识别时区字段。
      static DateFormat.Field DateFormat.Field.WEEK_OF_MONTH
      不断识别月份字段。
      static DateFormat.Field DateFormat.Field.WEEK_OF_YEAR
      常年识别一周的字段。
      static DateFormat.Field DateFormat.Field.YEAR
      不断识别年份字段。
      Methods in java.text that return DateFormat.Field
      Modifier and Type 方法 描述
      static DateFormat.Field DateFormat.Field.ofCalendarField​(int calendarField)
      返回 Field常数，对应于 Calendar常量 calendarField 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.DateFormatSymbols (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.DateFormatSymbols

  • Packages that use DateFormatSymbols
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。

    • Uses of DateFormatSymbols in java.text

      Methods in java.text that return DateFormatSymbols
      Modifier and Type 方法 描述
      DateFormatSymbols SimpleDateFormat.getDateFormatSymbols​()
      获取此日期格式的日期和时间格式符号的副本。
      static DateFormatSymbols DateFormatSymbols.getInstance​()
      获取默认语言环境的 DateFormatSymbols实例。
      static DateFormatSymbols DateFormatSymbols.getInstance​(Locale locale)
      获取指定区域设置的 DateFormatSymbols实例。
      Methods in java.text with parameters of type DateFormatSymbols
      Modifier and Type 方法 描述
      void SimpleDateFormat.setDateFormatSymbols​(DateFormatSymbols newFormatSymbols)
      设置此日期格式的日期和时间格式符号。
      Constructors in java.text with parameters of type DateFormatSymbols
      Constructor 描述
      SimpleDateFormat​(String pattern, DateFormatSymbols formatSymbols)
      使用给定的模式和日期格式符号构造一个 SimpleDateFormat 。

    • Uses of DateFormatSymbols in java.text.spi

      Methods in java.text.spi that return DateFormatSymbols
      Modifier and Type 方法 描述
      abstract DateFormatSymbols DateFormatSymbolsProvider.getInstance​(Locale locale)
      返回指定区域设置的新的 DateFormatSymbols实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.DecimalFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.DecimalFormat

  • Packages that use DecimalFormat
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of DecimalFormat in javax.swing

      Methods in javax.swing that return DecimalFormat
      Modifier and Type 方法 描述
      DecimalFormat JSpinner.NumberEditor.getFormat​()
      返回 java.text.DecimalFormat对象 JFormattedTextField用来分析和格式化数字。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.DecimalFormatSymbols (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.DecimalFormatSymbols

  • Packages that use DecimalFormatSymbols
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。

    • Uses of DecimalFormatSymbols in java.text

      Methods in java.text that return DecimalFormatSymbols
      Modifier and Type 方法 描述
      DecimalFormatSymbols DecimalFormat.getDecimalFormatSymbols​()
      返回十进制格式符号的副本，通常程序员或用户不会更改它们。
      static DecimalFormatSymbols DecimalFormatSymbols.getInstance​()
      获取默认语言环境的 DecimalFormatSymbols实例。
      static DecimalFormatSymbols DecimalFormatSymbols.getInstance​(Locale locale)
      获取指定语言环境的 DecimalFormatSymbols实例。
      Methods in java.text with parameters of type DecimalFormatSymbols
      Modifier and Type 方法 描述
      void DecimalFormat.setDecimalFormatSymbols​(DecimalFormatSymbols newSymbols)
      设置十进制格式符号，通常程序员或用户不会更改。
      Constructors in java.text with parameters of type DecimalFormatSymbols
      Constructor 描述
      DecimalFormat​(String pattern, DecimalFormatSymbols symbols)
      使用给定的模式和符号创建一个DecimalFormat。

    • Uses of DecimalFormatSymbols in java.text.spi

      Methods in java.text.spi that return DecimalFormatSymbols
      Modifier and Type 方法 描述
      abstract DecimalFormatSymbols DecimalFormatSymbolsProvider.getInstance​(Locale locale)
      返回指定区域设置的新的 DecimalFormatSymbols实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.FieldPosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.FieldPosition

  • Packages that use FieldPosition
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of FieldPosition in java.text

      Methods in java.text with parameters of type FieldPosition
      Modifier and Type 方法 描述
      StringBuffer ChoiceFormat.format​(double number, StringBuffer toAppendTo, FieldPosition status)
      返回格式为double的模式。
      StringBuffer ChoiceFormat.format​(long number, StringBuffer toAppendTo, FieldPosition status)
      专业化格式。
      StringBuffer DateFormat.format​(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition)
      覆盖格式。
      abstract StringBuffer DateFormat.format​(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition)
      将日期格式化成日期/时间字符串。
      StringBuffer DecimalFormat.format​(double number, StringBuffer result, FieldPosition fieldPosition)
      格式化为一个字符串。
      StringBuffer DecimalFormat.format​(long number, StringBuffer result, FieldPosition fieldPosition)
      格式化一个长的字符串。
      StringBuffer DecimalFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)
      格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
      abstract StringBuffer Format.format​(Object obj, StringBuffer toAppendTo, FieldPosition pos)
      格式化对象并将生成的文本附加到给定的字符串缓冲区。
      StringBuffer MessageFormat.format​(Object[] arguments, StringBuffer result, FieldPosition pos)
      格式化一组对象，并将 MessageFormat的格式（格式化元素替换为格式化对象） StringBuffer到所提供的 StringBuffer 。
      StringBuffer MessageFormat.format​(Object arguments, StringBuffer result, FieldPosition pos)
      格式化一个对象数组，并将 MessageFormat的格式（格式化元素替换为格式化对象） StringBuffer到所提供的 StringBuffer 。
      abstract StringBuffer NumberFormat.format​(double number, StringBuffer toAppendTo, FieldPosition pos)
      专业化格式。
      abstract StringBuffer NumberFormat.format​(long number, StringBuffer toAppendTo, FieldPosition pos)
      专业化格式。
      StringBuffer NumberFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)
      格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
      StringBuffer SimpleDateFormat.format​(Date date, StringBuffer toAppendTo, FieldPosition pos)
      将给定的 Date为日期/时间字符串，并将结果追加到给定的 StringBuffer 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.Format (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.Format

  • Packages that use Format
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time.format
    提供打印和解析日期和时间的类。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Format in java.text

      Subclasses of Format in java.text
      Modifier and Type Class 描述
      class  ChoiceFormat
      A ChoiceFormat允许您将格式附加到一系列数字。
      class  DateFormat
      DateFormat是一种用于日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。
      class  DecimalFormat
      DecimalFormat是格式为十进制数的 NumberFormat的具体子类。
      class  MessageFormat
      MessageFormat提供了一种以语言中立的方式产生连接消息的方法。
      class  NumberFormat
      NumberFormat是所有数字格式的抽象基类。
      class  SimpleDateFormat
      SimpleDateFormat是一个具体的类，用于以区域设置敏感的方式格式化和解析日期。
      Methods in java.text that return Format
      Modifier and Type 方法 描述
      Format[] MessageFormat.getFormats​()
      获取用于先前设置的模式字符串中的格式元素的格式。
      Format[] MessageFormat.getFormatsByArgumentIndex​()
      获取用于传递到 format方法中的值的格式或从 parse方法返回的 parse 。
      Methods in java.text with parameters of type Format
      Modifier and Type 方法 描述
      void MessageFormat.setFormat​(int formatElementIndex, Format newFormat)
      设置在先前设置的模式字符串中使用具有给定格式元素索引的格式元素的格式。
      void MessageFormat.setFormatByArgumentIndex​(int argumentIndex, Format newFormat)
      设置使用给定参数索引的先前设置的模式字符串中的格式元素的格式。
      void MessageFormat.setFormats​(Format[] newFormats)
      设置用于先前设置的模式字符串中的格式元素的格式。
      void MessageFormat.setFormatsByArgumentIndex​(Format[] newFormats)
      设置用于传递给 format方法的值或从 parse方法返回的 parse 。

    • Uses of Format in java.time.format

      Methods in java.time.format that return Format
      Modifier and Type 方法 描述
      Format DateTimeFormatter.toFormat​()
      将此格式化程序作为 java.text.Format实例返回。
      Format DateTimeFormatter.toFormat​(TemporalQuery<?> parseQuery)
      将此格式化程序作为 java.text.Format实例返回，使用指定的查询进行解析。

    • Uses of Format in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type Format
      Modifier and Type 方法 描述
      static void Bindings.bindBidirectional​(Property<String> stringProperty, Property<?> otherProperty, Format format)
      在String - Property和另一个Property使用指定的Format生成双向绑定（或“反向绑定”）进行转换。

    • Uses of Format in javafx.beans.property

      Methods in javafx.beans.property with parameters of type Format
      Modifier and Type 方法 描述
      void StringProperty.bindBidirectional​(Property<?> other, Format format)
      在这个 StringProperty和另一个任意属性之间创建双向绑定。

    • Uses of Format in javafx.util.converter

      Methods in javafx.util.converter that return Format
      Modifier and Type 方法 描述
      protected Format FormatStringConverter.getFormat​()
      返回一个Format实例，用于在此StringConverter中进行格式化和解析。
      Constructors in javafx.util.converter with parameters of type Format
      Constructor 描述
      FormatStringConverter​(Format format)

    • Uses of Format in javax.swing

      Constructors in javax.swing with parameters of type Format
      Constructor 描述
      JFormattedTextField​(Format format)
      创建一个 JFormattedTextField 。

    • Uses of Format in javax.swing.text

      Methods in javax.swing.text that return Format
      Modifier and Type 方法 描述
      Format InternationalFormatter.getFormat​()
      返回指定可编辑和显示的合法值的格式。
      Methods in javax.swing.text with parameters of type Format
      Modifier and Type 方法 描述
      void InternationalFormatter.setFormat​(Format format)
      设置指定可编辑和显示的合法值的格式。
      void NumberFormatter.setFormat​(Format format)
      设置指定可编辑和显示的合法值的格式。
      Constructors in javax.swing.text with parameters of type Format
      Constructor 描述
      InternationalFormatter​(Format format)
      创建一个 InternationalFormatter使用指定 Format实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.Format.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.Format.Field

  • Packages that use Format.Field
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Format.Field in java.text

      Subclasses of Format.Field in java.text
      Modifier and Type Class 描述
      static class  DateFormat.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 DateFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
      static class  MessageFormat.Field
      定义从 MessageFormat.formatToCharacterIterator返回的 AttributedCharacterIterator中用作属性键的 MessageFormat.formatToCharacterIterator 。
      static class  NumberFormat.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 NumberFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
      Methods in java.text that return Format.Field
      Modifier and Type 方法 描述
      Format.Field FieldPosition.getFieldAttribute​()
      从一个 Field子类返回字段标识符作为属性常量。
      Constructors in java.text with parameters of type Format.Field
      Constructor 描述
      FieldPosition​(Format.Field attribute)
      为给定的字段常量创建一个FieldPosition对象。
      FieldPosition​(Format.Field attribute, int fieldID)
      为给定字段创建一个 FieldPosition对象。

    • Uses of Format.Field in javax.swing.text

      Methods in javax.swing.text that return Format.Field
      Modifier and Type 方法 描述
      Format.Field[] InternationalFormatter.getFields​(int offset)
      返回与文本 offset相关联的 Format.Field常量。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.MessageFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.MessageFormat

  • Packages that use MessageFormat
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of MessageFormat in javax.swing

      Methods in javax.swing with parameters of type MessageFormat
      Modifier and Type 方法 描述
      Printable JTable.getPrintable​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
      返回一个用于打印此JTable的 Printable 。
      boolean JTable.print​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
      显示打印对话框的便捷方法，然后以给定的打印模式打印此 JTable ，并使用指定的页眉和页脚文本。
      boolean JTable.print​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive)
      按照功能全面的 print方法指定打印此表，默认打印机指定为打印服务。
      boolean JTable.print​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service)
      打印这个 JTable 。

    • Uses of MessageFormat in javax.swing.text

      Methods in javax.swing.text with parameters of type MessageFormat
      Modifier and Type 方法 描述
      Printable JTextComponent.getPrintable​(MessageFormat headerFormat, MessageFormat footerFormat)
      返回 Printable用于打印此 JTextComponent的内容。
      boolean JTextComponent.print​(MessageFormat headerFormat, MessageFormat footerFormat)
      显示打印对话框的便捷打印方法，然后以指定的页眉和页脚文本的 交互模式打印此 JTextComponent 。
      boolean JTextComponent.print​(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive)
      打印 JTextComponent的内容。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.MessageFormat.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.MessageFormat.Field

  • Packages that use MessageFormat.Field
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of MessageFormat.Field in java.text

      Fields in java.text declared as MessageFormat.Field
      Modifier and Type Field 描述
      static MessageFormat.Field MessageFormat.Field.ARGUMENT
      常量标识从传入 formatToCharacterIterator的参数生成的消息的一部分。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.Normalizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.Normalizer

No usage of java.text.Normalizer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.Normalizer.Form (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.Normalizer.Form

  • Packages that use Normalizer.Form
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of Normalizer.Form in java.text

      Methods in java.text that return Normalizer.Form
      Modifier and Type 方法 描述
      static Normalizer.Form Normalizer.Form.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Normalizer.Form[] Normalizer.Form.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.text with parameters of type Normalizer.Form
      Modifier and Type 方法 描述
      static boolean Normalizer.isNormalized​(CharSequence src, Normalizer.Form form)
      确定给定的char值序列是否被归一化。
      static String Normalizer.normalize​(CharSequence src, Normalizer.Form form)
      归一化一个char值序列。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.NumberFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.NumberFormat

  • Packages that use NumberFormat
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of NumberFormat in java.text

      Subclasses of NumberFormat in java.text
      Modifier and Type Class 描述
      class  ChoiceFormat
      A ChoiceFormat允许您将格式附加到一系列数字。
      class  DecimalFormat
      DecimalFormat是的具体子类 NumberFormat格式化十进制数字。
      Fields in java.text declared as NumberFormat
      Modifier and Type Field 描述
      protected NumberFormat DateFormat.numberFormat
      DateFormat用于在日期和时间格式化数字的数字格式化程序。
      Methods in java.text that return NumberFormat
      Modifier and Type 方法 描述
      static NumberFormat NumberFormat.getCurrencyInstance​()
      返回当前默认 FORMAT区域设置的货币格式。
      static NumberFormat NumberFormat.getCurrencyInstance​(Locale inLocale)
      返回指定区域设置的货币格式。
      static NumberFormat NumberFormat.getInstance​()
      返回当前默认 FORMAT区域设置的通用数字格式。
      static NumberFormat NumberFormat.getInstance​(Locale inLocale)
      返回指定区域设置的通用数字格式。
      static NumberFormat NumberFormat.getIntegerInstance​()
      返回当前默认 FORMAT区域设置的整数格式。
      static NumberFormat NumberFormat.getIntegerInstance​(Locale inLocale)
      返回指定区域设置的整数格式。
      NumberFormat DateFormat.getNumberFormat​()
      获取此日期/时间格式化程序用于格式化和解析时间的数字格式化程序。
      static NumberFormat NumberFormat.getNumberInstance​()
      返回当前默认 FORMAT区域设置的通用数字格式。
      static NumberFormat NumberFormat.getNumberInstance​(Locale inLocale)
      返回指定区域设置的通用数字格式。
      static NumberFormat NumberFormat.getPercentInstance​()
      返回当前默认 值为FORMAT的区域设置的百分比格式。
      static NumberFormat NumberFormat.getPercentInstance​(Locale inLocale)
      返回指定区域设置的百分比格式。
      Methods in java.text with parameters of type NumberFormat
      Modifier and Type 方法 描述
      void DateFormat.setNumberFormat​(NumberFormat newNumberFormat)
      允许您设置数字格式化程序。

    • Uses of NumberFormat in java.text.spi

      Methods in java.text.spi that return NumberFormat
      Modifier and Type 方法 描述
      abstract NumberFormat NumberFormatProvider.getCurrencyInstance​(Locale locale)
      返回一个新的 NumberFormat实例，它为指定的区域设置格式化货币值。
      abstract NumberFormat NumberFormatProvider.getIntegerInstance​(Locale locale)
      返回一个新的 NumberFormat实例，它为指定的区域设置格式化整数值。
      abstract NumberFormat NumberFormatProvider.getNumberInstance​(Locale locale)
      返回指定区域设置的新通用 NumberFormat实例。
      abstract NumberFormat NumberFormatProvider.getPercentInstance​(Locale locale)
      返回一个新的 NumberFormat实例，该实例格式化指定区域设置的百分比值。

    • Uses of NumberFormat in javafx.util.converter

      Methods in javafx.util.converter that return NumberFormat
      Modifier and Type 方法 描述
      protected NumberFormat CurrencyStringConverter.getNumberFormat​()
      返回一个NumberFormat实例，用于在此StringConverter中进行格式化和解析。
      protected NumberFormat NumberStringConverter.getNumberFormat​()
      返回一个NumberFormat实例，用于在此StringConverter中进行格式化和解析。
      NumberFormat PercentageStringConverter.getNumberFormat​()
      返回一个NumberFormat实例，用于在此StringConverter中进行格式化和解析。
      Constructors in javafx.util.converter with parameters of type NumberFormat
      Constructor 描述
      CurrencyStringConverter​(NumberFormat numberFormat)
      NumberStringConverter​(NumberFormat numberFormat)
      PercentageStringConverter​(NumberFormat numberFormat)

    • Uses of NumberFormat in javax.swing.text

      Constructors in javax.swing.text with parameters of type NumberFormat
      Constructor 描述
      NumberFormatter​(NumberFormat format)
      使用指定的Format实例创建NumberFormatter。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.NumberFormat.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.NumberFormat.Field

  • Packages that use NumberFormat.Field
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of NumberFormat.Field in java.text

      Fields in java.text declared as NumberFormat.Field
      Modifier and Type Field 描述
      static NumberFormat.Field NumberFormat.Field.CURRENCY
      不断识别货币字段。
      static NumberFormat.Field NumberFormat.Field.DECIMAL_SEPARATOR
      常数标识小数分隔符字段。
      static NumberFormat.Field NumberFormat.Field.EXPONENT
      常数识别指数字段。
      static NumberFormat.Field NumberFormat.Field.EXPONENT_SIGN
      常数识别指数符号字段。
      static NumberFormat.Field NumberFormat.Field.EXPONENT_SYMBOL
      常数识别指数符号字段。
      static NumberFormat.Field NumberFormat.Field.FRACTION
      常数识别分数字段。
      static NumberFormat.Field NumberFormat.Field.GROUPING_SEPARATOR
      常数标识分组分隔符字段。
      static NumberFormat.Field NumberFormat.Field.INTEGER
      常量识别整数字段。
      static NumberFormat.Field NumberFormat.Field.PERCENT
      不断识别百分比字段。
      static NumberFormat.Field NumberFormat.Field.PERMILLE
      常数识别容错字段。
      static NumberFormat.Field NumberFormat.Field.SIGN
      常量识别符号字段。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.ParseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.ParseException

  • Packages that use ParseException
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of ParseException in java.text

      Methods in java.text that throw ParseException
      Modifier and Type 方法 描述
      Date DateFormat.parse​(String source)
      从给定字符串的开始解析文本以生成日期。
      Object[] MessageFormat.parse​(String source)
      从给定字符串的开头解析文本以产生一个对象数组。
      Number NumberFormat.parse​(String source)
      从给定字符串的开头解析文本以产生一个数字。
      Object Format.parseObject​(String source)
      从给定字符串的开头解析文本以产生一个对象。
      Constructors in java.text that throw ParseException
      Constructor 描述
      RuleBasedCollator​(String rules)
      RuleBasedCollator构造函数。

    • Uses of ParseException in javax.swing

      Methods in javax.swing that throw ParseException
      Modifier and Type 方法 描述
      void JFormattedTextField.commitEdit​()
      强制从 AbstractFormatter的当前值并设置为当前值。
      void JSpinner.commitEdit​()
      将当前编辑的值提交到 SpinnerModel 。
      void JSpinner.DefaultEditor.commitEdit​()
      将当前编辑的值推送到 SpinnerModel 。
      abstract Object JFormattedTextField.AbstractFormatter.stringToValue​(String text)
      解析 text返回任意的对象。
      abstract String JFormattedTextField.AbstractFormatter.valueToString​(Object value)
      返回要显示 value的字符串值。

    • Uses of ParseException in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that throw ParseException
      Modifier and Type 方法 描述
      void SynthLookAndFeel.load​(InputStream input, Class<?> resourceBase)
      加载 SynthStyle s将由此 SynthLookAndFeel使用的 SynthLookAndFeel 。
      void SynthLookAndFeel.load​(URL url)
      加载组 SynthStyle将由本使用的S SynthLookAndFeel 。

    • Uses of ParseException in javax.swing.text

      Methods in javax.swing.text that throw ParseException
      Modifier and Type 方法 描述
      void MaskFormatter.setMask​(String mask)
      设置掩码规定合法字符。
      Object DefaultFormatter.stringToValue​(String string)
      通过使用String参数的构造函数将String中的传递转换为 getValueClass的实例。
      Object InternationalFormatter.stringToValue​(String text)
      返回 Object的表示 String text 。
      Object MaskFormatter.stringToValue​(String value)
      解析文本，返回字符串 value的相应对象表示 value 。
      String DefaultFormatter.valueToString​(Object value)
      通过 toString方法将Object中传入的对象转换为字符串。
      String InternationalFormatter.valueToString​(Object value)
      返回对象 value的字符串表示 value 。
      String MaskFormatter.valueToString​(Object value)
      基于掩码返回对象 value的字符串表示形式。
      Constructors in javax.swing.text that throw ParseException
      Constructor 描述
      MaskFormatter​(String mask)
      使用指定的掩码创建一个 MaskFormatter 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.ParsePosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.ParsePosition

  • Packages that use ParsePosition
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time.format
    提供打印和解析日期和时间的类。

    • Uses of ParsePosition in java.text

      Methods in java.text with parameters of type ParsePosition
      Modifier and Type 方法 描述
      Number ChoiceFormat.parse​(String text, ParsePosition status)
      从输入文本中解析一个数字。
      abstract Date DateFormat.parse​(String source, ParsePosition pos)
      根据给定的解析位置解析日期/时间字符串。
      Number DecimalFormat.parse​(String text, ParsePosition pos)
      从字符串中解析文本，产生一个 Number 。
      Object[] MessageFormat.parse​(String source, ParsePosition pos)
      解析字符串。
      abstract Number NumberFormat.parse​(String source, ParsePosition parsePosition)
      如果可能，返回长（例如，在[Long.MIN_VALUE，Long.MAX_VALUE]范围内，无小数），否则为Double。
      Date SimpleDateFormat.parse​(String text, ParsePosition pos)
      从字符串中解析文本以产生一个 Date 。
      Object DateFormat.parseObject​(String source, ParsePosition pos)
      从字符串中解析文本以产生一个 Date 。
      abstract Object Format.parseObject​(String source, ParsePosition pos)
      从字符串中解析文本以生成对象。
      Object MessageFormat.parseObject​(String source, ParsePosition pos)
      从字符串中解析文本以生成对象数组。
      Object NumberFormat.parseObject​(String source, ParsePosition pos)
      从字符串中解析文本以产生一个 Number 。

    • Uses of ParsePosition in java.time.format

      Methods in java.time.format with parameters of type ParsePosition
      Modifier and Type 方法 描述
      TemporalAccessor DateTimeFormatter.parse​(CharSequence text, ParsePosition position)
      使用此格式化器解析文本，提供对文本位置的控制。
      TemporalAccessor DateTimeFormatter.parseUnresolved​(CharSequence text, ParsePosition position)
      使用此格式化程序解析文本，而无需解析结果，用于高级用例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.RuleBasedCollator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.RuleBasedCollator

No usage of java.text.RuleBasedCollator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.SimpleDateFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.SimpleDateFormat

  • Packages that use SimpleDateFormat
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of SimpleDateFormat in javax.swing

      Methods in javax.swing that return SimpleDateFormat
      Modifier and Type 方法 描述
      SimpleDateFormat JSpinner.DateEditor.getFormat​()
      java.text.SimpleDateFormat新 JFormattedTextField
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.StringCharacterIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.StringCharacterIterator

No usage of java.text.StringCharacterIterator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.text.AttributedCharacterIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.text.AttributedCharacterIterator

  • Packages that use AttributedCharacterIterator
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AttributedCharacterIterator in java.awt

      Methods in java.awt with parameters of type AttributedCharacterIterator
      Modifier and Type 方法 描述
      abstract void Graphics.drawString​(AttributedCharacterIterator iterator, int x, int y)
      根据TextAttribute类的规范，渲染指定迭代器的文本应用其属性。
      abstract void Graphics2D.drawString​(AttributedCharacterIterator iterator, float x, float y)
      根据TextAttribute类的规范，渲染指定迭代器的文本应用其属性。
      abstract void Graphics2D.drawString​(AttributedCharacterIterator iterator, int x, int y)
      根据TextAttribute类的规范，渲染指定迭代器的文本应用其属性。

    • Uses of AttributedCharacterIterator in java.awt.event

      Methods in java.awt.event that return AttributedCharacterIterator
      Modifier and Type 方法 描述
      AttributedCharacterIterator InputMethodEvent.getText​()
      获取组合的承诺和合成文本。
      Constructors in java.awt.event with parameters of type AttributedCharacterIterator
      Constructor 描述
      InputMethodEvent​(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      构造具有指定源组件，类型，时间，文本，插入符号和 InputMethodEvent 。
      InputMethodEvent​(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      构造具有指定的源组件，类型，文本，插入符号和 InputMethodEvent 。

    • Uses of AttributedCharacterIterator in java.awt.font

      Methods in java.awt.font with parameters of type AttributedCharacterIterator
      Modifier and Type 方法 描述
      void LineBreakMeasurer.deleteChar​(AttributedCharacterIterator newParagraph, int deletePos)
      从文本中删除单个字符后更新 LineBreakMeasurer ，并将当前位置设置为段落的开头。
      void TextMeasurer.deleteChar​(AttributedCharacterIterator newParagraph, int deletePos)
      在 TextMeasurer当前表示的段落中删除单个字符后，更新 TextMeasurer 。
      void LineBreakMeasurer.insertChar​(AttributedCharacterIterator newParagraph, int insertPos)
      在将单个字符插入到文本中后，更新 LineBreakMeasurer ，并将当前位置设置为段落的开头。
      void TextMeasurer.insertChar​(AttributedCharacterIterator newParagraph, int insertPos)
      更新 TextMeasurer单个字符已经被插入到当前这个表示的段落后 TextMeasurer 。
      Constructors in java.awt.font with parameters of type AttributedCharacterIterator
      Constructor 描述
      LineBreakMeasurer​(AttributedCharacterIterator text, FontRenderContext frc)
      为指定的文本构造一个 LineBreakMeasurer 。
      LineBreakMeasurer​(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
      为指定的文本构造一个 LineBreakMeasurer 。
      TextLayout​(AttributedCharacterIterator text, FontRenderContext frc)
      从迭代器构造一个 TextLayout超过样式文本。
      TextMeasurer​(AttributedCharacterIterator text, FontRenderContext frc)
      从源文本构造一个 TextMeasurer 。

    • Uses of AttributedCharacterIterator in java.awt.im

      Methods in java.awt.im that return AttributedCharacterIterator
      Modifier and Type 方法 描述
      AttributedCharacterIterator InputMethodRequests.cancelLatestCommittedText​(AttributedCharacterIterator.Attribute[] attributes)
      从文本编辑组件获取最新提交的文本，并将其从组件的文本正文中删除。
      AttributedCharacterIterator InputMethodRequests.getCommittedText​(int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
      获取一个迭代器，提供对文本编辑组件中包含的整个文本和属性的访问，除了未提交的文本。
      AttributedCharacterIterator InputMethodRequests.getSelectedText​(AttributedCharacterIterator.Attribute[] attributes)
      从文本编辑组件获取当前选定的文本。

    • Uses of AttributedCharacterIterator in java.awt.im.spi

      Methods in java.awt.im.spi with parameters of type AttributedCharacterIterator
      Modifier and Type 方法 描述
      void InputMethodContext.dispatchInputMethodEvent​(int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      从给定的参数创建输入法事件并将其分派到客户端组件。

    • Uses of AttributedCharacterIterator in java.text

      Methods in java.text that return AttributedCharacterIterator
      Modifier and Type 方法 描述
      AttributedCharacterIterator DecimalFormat.formatToCharacterIterator​(Object obj)
      格式化一个对象，生成一个 AttributedCharacterIterator 。
      AttributedCharacterIterator Format.formatToCharacterIterator​(Object obj)
      格式化产生一个 AttributedCharacterIterator的对象。
      AttributedCharacterIterator MessageFormat.formatToCharacterIterator​(Object arguments)
      格式化一系列对象，并将其插入到 MessageFormat的模式中，产生一个 AttributedCharacterIterator 。
      AttributedCharacterIterator SimpleDateFormat.formatToCharacterIterator​(Object obj)
      格式化产生一个 AttributedCharacterIterator的对象。
      AttributedCharacterIterator AttributedString.getIterator​()
      创建一个AttributedCharacterIterator实例，该实例提供对该字符串的整个内容的访问。
      AttributedCharacterIterator AttributedString.getIterator​(AttributedCharacterIterator.Attribute[] attributes)
      创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。
      AttributedCharacterIterator AttributedString.getIterator​(AttributedCharacterIterator.Attribute[] attributes, int beginIndex, int endIndex)
      创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。
      Constructors in java.text with parameters of type AttributedCharacterIterator
      Constructor 描述
      AttributedString​(AttributedCharacterIterator text)
      使用AttributedCharacterIterator表示的给定归因文本构造一个AttributedString实例。
      AttributedString​(AttributedCharacterIterator text, int beginIndex, int endIndex)
      使用AttributedCharacterIterator表示的给定归因文本的子范围构造一个AttributedString实例。
      AttributedString​(AttributedCharacterIterator text, int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
      使用AttributedCharacterIterator表示的给定归因文本的子范围构造一个AttributedString实例。
      Bidi​(AttributedCharacterIterator paragraph)
      从文本的给定段落创建Bidi。

    • Uses of AttributedCharacterIterator in javax.swing

      Methods in javax.swing with parameters of type AttributedCharacterIterator
      Modifier and Type 方法 描述
      void DebugGraphics.drawString​(AttributedCharacterIterator iterator, int x, int y)
      Overrides Graphics.drawString.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.text.CharacterIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.text.CharacterIterator

  • Packages that use CharacterIterator
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of CharacterIterator in java.awt

      Methods in java.awt with parameters of type CharacterIterator
      Modifier and Type 方法 描述
      int Font.canDisplayUpTo​(CharacterIterator iter, int start, int limit)
      表示此 Font是否可以显示 iter从 iter开始并以 start结尾的 limit 。
      GlyphVector Font.createGlyphVector​(FontRenderContext frc, CharacterIterator ci)
      创建GlyphVector由指定的字符映射到字形的一对一的基础上在此的Unicode cmap Font 。
      LineMetrics Font.getLineMetrics​(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定的参数创建的一个 LineMetrics对象。
      LineMetrics FontMetrics.getLineMetrics​(CharacterIterator ci, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定的CharacterIterator的LineMetrics对象。
      Rectangle2D Font.getStringBounds​(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc)
      返回指定索引的字符的逻辑边界CharacterIterator指定FontRenderContext 。
      Rectangle2D FontMetrics.getStringBounds​(CharacterIterator ci, int beginIndex, int limit, Graphics context)
      返回在指定的 Graphics上下文中指定的 CharacterIterator中索引的字符的边界。

    • Uses of CharacterIterator in java.text

      Subinterfaces of CharacterIterator in java.text
      Modifier and Type 接口 描述
      interface  AttributedCharacterIterator
      AttributedCharacterIterator允许通过文本和相关属性信息进行迭代。
      Classes in java.text that implement CharacterIterator
      Modifier and Type Class 描述
      class  StringCharacterIterator
      StringCharacterIterator实现 CharacterIterator协议为 String 。
      Methods in java.text that return CharacterIterator
      Modifier and Type 方法 描述
      abstract CharacterIterator BreakIterator.getText​()
      获取正在扫描的文本
      Methods in java.text with parameters of type CharacterIterator
      Modifier and Type 方法 描述
      CollationElementIterator RuleBasedCollator.getCollationElementIterator​(CharacterIterator source)
      返回给定CharacterIterator的CollationElementIterator。
      abstract void BreakIterator.setText​(CharacterIterator newText)
      设置一个新文本进行扫描。
      void CollationElementIterator.setText​(CharacterIterator source)
      设置要迭代的新字符串。

    • Uses of CharacterIterator in javax.swing.text

      Classes in javax.swing.text that implement CharacterIterator
      Modifier and Type Class 描述
      class  Segment
      表示文本片段的字符数组的段。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


BreakIteratorProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text.spi

Class BreakIteratorProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.BreakIteratorProvider

  • public abstract class BreakIteratorProvider
extends LocaleServiceProvider
    提供BreakIterator类的具体实现的服务提供者的抽象类。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected BreakIteratorProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract BreakIterator getCharacterInstance​(Locale locale)
      为给定的语言环境返回一个新的 BreakIterator实例 character breaks 。
      abstract BreakIterator getLineInstance​(Locale locale)
      为给定的区域设置返回一个新的 BreakIterator实例 line breaks 。
      abstract BreakIterator getSentenceInstance​(Locale locale)
      返回一个新 BreakIterator例如 sentence breaks给定语言环境。
      abstract BreakIterator getWordInstance​(Locale locale)
      返回一个新 BreakIterator例如 word breaks给定语言环境。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BreakIteratorProvider

        protected BreakIteratorProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getWordInstance

        public abstract BreakIterator getWordInstance​(Locale locale)
        返回一个新 BreakIterator例如 word breaks给定语言环境。
        参数
        locale - 所需的语言环境
        结果
        一个用于单词的中断迭代器
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        BreakIterator.getWordInstance(java.util.Locale)

      • getLineInstance

        public abstract BreakIterator getLineInstance​(Locale locale)
        为给定的区域设置返回一个新的 BreakIterator实例 line breaks 。
        参数
        locale - 所需的语言环境
        结果
        换行符用于换行符
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        BreakIterator.getLineInstance(java.util.Locale)

      • getCharacterInstance

        public abstract BreakIterator getCharacterInstance​(Locale locale)
        返回一个新 BreakIterator例如 character breaks给定语言环境。
        参数
        locale - 所需的语言环境
        结果
        用于字符中断的中断迭代器
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        BreakIterator.getCharacterInstance(java.util.Locale)

      • getSentenceInstance

        public abstract BreakIterator getSentenceInstance​(Locale locale)
        为给定的区域设置返回一个新的 BreakIterator实例 sentence breaks 。
        参数
        locale - 所需的语言环境
        结果
        休假的休息迭代器
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        BreakIterator.getSentenceInstance(java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CollatorProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text.spi

Class CollatorProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.CollatorProvider

  • public abstract class CollatorProvider
extends LocaleServiceProvider
    提供Collator类的具体实现的服务提供者的抽象类。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CollatorProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Collator getInstance​(Locale locale)
      返回指定区域设置的新的 Collator实例。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CollatorProvider

        protected CollatorProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getInstance

        public abstract Collator getInstance​(Locale locale)
        返回指定区域设置的新的 Collator实例。
        参数
        locale - 所需的语言环境。
        结果
        Collator为所需的语言环境。
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的地区 之一 。
        另请参见：
        Collator.getInstance(java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DateFormatProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text.spi

Class DateFormatProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.DateFormatProvider

  • public abstract class DateFormatProvider
extends LocaleServiceProvider
    提供DateFormat类的具体实现的服务提供者的抽象类。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected DateFormatProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract DateFormat getDateInstance​(int style, Locale locale)
      返回一个新的 DateFormat实例，其格式为指定区域设置的给定格式化样式的日期。
      abstract DateFormat getDateTimeInstance​(int dateStyle, int timeStyle, Locale locale)
      返回一个新的 DateFormat实例，它使用指定区域设置的给定格式化样式格式化日期和时间。
      abstract DateFormat getTimeInstance​(int style, Locale locale)
      返回一个新的 DateFormat实例，用于为指定的区域设置格式化给定的格式化样式。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DateFormatProvider

        protected DateFormatProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getTimeInstance

        public abstract DateFormat getTimeInstance​(int style,
                                           Locale locale)
        返回一个新的 DateFormat实例，它为指定的区域设置使用给定格式化样式格式化时间。
        参数
        style - 给定的格式化样式。 中的任一个DateFormat.SHORT ， DateFormat.MEDIUM ， DateFormat.LONG ，或DateFormat.FULL 。
        locale - 所需的语言环境。
        结果
        时间格式化
        异常
        IllegalArgumentException - 如果 style无效，或者如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        NullPointerException - 如果 locale为空
        另请参见：
        DateFormat.getTimeInstance(int, java.util.Locale)

      • getDateInstance

        public abstract DateFormat getDateInstance​(int style,
                                           Locale locale)
        返回一个新的 DateFormat实例，其格式为指定区域设置的给定格式化样式的日期。
        参数
        style - 给定的格式化样式。 中的任一个DateFormat.SHORT ， DateFormat.MEDIUM ， DateFormat.LONG ，或DateFormat.FULL 。
        locale - 所需的语言环境。
        结果
        一个日期格式化程序
        异常
        IllegalArgumentException - 如果 style无效，或者如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        NullPointerException - 如果 locale为空
        另请参见：
        DateFormat.getDateInstance(int, java.util.Locale)

      • getDateTimeInstance

        public abstract DateFormat getDateTimeInstance​(int dateStyle,
                                               int timeStyle,
                                               Locale locale)
        返回一个新的 DateFormat实例，该实例使用指定区域设置的给定格式化样式格式化日期和时间。
        参数
        dateStyle - 给定的日期格式化样式。 中的任一个DateFormat.SHORT ， DateFormat.MEDIUM ， DateFormat.LONG ，或DateFormat.FULL 。
        timeStyle - 给定的时间格式化样式。 中的任一个DateFormat.SHORT ， DateFormat.MEDIUM ， DateFormat.LONG ，或DateFormat.FULL 。
        locale - 所需的语言环境。
        结果
        日期/时间格式化。
        异常
        IllegalArgumentException - 如果 dateStyle或 timeStyle无效，或者如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        NullPointerException - 如果 locale为空
        另请参见：
        DateFormat.getDateTimeInstance(int, int, java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DateFormatSymbolsProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text.spi

Class DateFormatSymbolsProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.DateFormatSymbolsProvider

  • public abstract class DateFormatSymbolsProvider
extends LocaleServiceProvider
    提供DateFormatSymbols类的实例的服务提供者的抽象类。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected DateFormatSymbolsProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract DateFormatSymbols getInstance​(Locale locale)
      返回指定区域设置的新的 DateFormatSymbols实例。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DateFormatSymbolsProvider

        protected DateFormatSymbolsProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getInstance

        public abstract DateFormatSymbols getInstance​(Locale locale)
        返回指定区域设置的新的 DateFormatSymbols实例。
        参数
        locale - 所需的语言环境
        结果
        一个 DateFormatSymbols例子。
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        DateFormatSymbols.getInstance(java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DecimalFormatSymbolsProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text.spi

Class DecimalFormatSymbolsProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.DecimalFormatSymbolsProvider

  • public abstract class DecimalFormatSymbolsProvider
extends LocaleServiceProvider
    提供DecimalFormatSymbols类的实例的服务提供者的抽象类。

    请求的Locale可能包含一个extension，用于指定所需的编号系统。 例如， "ar-u-nu-arab" （在BCP 47语言标签表单中）用阿拉伯语 - 印度数字和符号指定阿拉伯语，而"ar-u-nu-latn"用拉丁字母和符号表示阿拉伯语。 请参阅编号系统的Unicode语言环境数据标记语言（LDML）规范。

    从以下版本开始：
    1.6
    另请参见：
    Locale.forLanguageTag(String) ， Locale.getExtension(char)

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected DecimalFormatSymbolsProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract DecimalFormatSymbols getInstance​(Locale locale)
      返回指定区域设置的新的 DecimalFormatSymbols实例。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DecimalFormatSymbolsProvider

        protected DecimalFormatSymbolsProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getInstance

        public abstract DecimalFormatSymbols getInstance​(Locale locale)
        返回指定区域设置的新的 DecimalFormatSymbols实例。
        参数
        locale - 所需的语言环境
        结果
        一个 DecimalFormatSymbols实例。
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        DecimalFormatSymbols.getInstance(java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.text.spi (Java SE 9 & JDK 9 )

java.text.spi

Classes

  • BreakIteratorProvider
  • CollatorProvider
  • DateFormatProvider
  • DateFormatSymbolsProvider
  • DecimalFormatSymbolsProvider
  • NumberFormatProvider


java.text.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.text.spi

java.text包中类的服务提供者类。
从以下版本开始：
1.6
  • 类摘要
    Class 描述
    BreakIteratorProvider
    提供BreakIterator类的具体实现的服务提供者的抽象类。
    CollatorProvider
    提供Collator类的具体实现的服务提供者的抽象类。
    DateFormatProvider
    提供DateFormat类的具体实现的服务提供者的抽象类。
    DateFormatSymbolsProvider
    提供DateFormatSymbols类的实例的服务提供者的抽象类。
    DecimalFormatSymbolsProvider
    提供DecimalFormatSymbols类的实例的服务提供者的抽象类。
    NumberFormatProvider
    An abstract class for service providers that provide concrete implementations of the NumberFormat class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.text.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.text.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.BreakIteratorProvider
      • java.text.spi.CollatorProvider
      • java.text.spi.DateFormatProvider
      • java.text.spi.DateFormatSymbolsProvider
      • java.text.spi.DecimalFormatSymbolsProvider
      • java.text.spi.NumberFormatProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


NumberFormatProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.text.spi

Class NumberFormatProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.NumberFormatProvider

  • public abstract class NumberFormatProvider
extends LocaleServiceProvider
    提供NumberFormat类的具体实现的服务提供者的抽象类。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected NumberFormatProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract NumberFormat getCurrencyInstance​(Locale locale)
      返回一个新的 NumberFormat实例，它为指定的区域设置格式化货币值。
      abstract NumberFormat getIntegerInstance​(Locale locale)
      返回一个新的 NumberFormat实例，它为指定的区域设置格式化整数值。
      abstract NumberFormat getNumberInstance​(Locale locale)
      返回指定区域设置的新通用 NumberFormat实例。
      abstract NumberFormat getPercentInstance​(Locale locale)
      返回一个新的 NumberFormat实例，用于格式化指定区域设置的百分比值。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NumberFormatProvider

        protected NumberFormatProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getCurrencyInstance

        public abstract NumberFormat getCurrencyInstance​(Locale locale)
        返回一个新的 NumberFormat实例，它为指定的区域设置格式化货币值。
        参数
        locale - 所需的语言环境。
        结果
        货币格式化
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        NumberFormat.getCurrencyInstance(java.util.Locale)

      • getIntegerInstance

        public abstract NumberFormat getIntegerInstance​(Locale locale)
        返回一个新的NumberFormat实例，它为指定的区域设置格式化整数值。 返回的数字格式被配置成使用半甚至舍入圆浮点数到最接近的整数（参见HALF_EVEN ）进行格式化，并且解析仅一个输入字符串的整数部分（参见isParseIntegerOnly ）。
        参数
        locale - 所需的语言环境
        结果
        整数值的数字格式
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        NumberFormat.getIntegerInstance(java.util.Locale)

      • getNumberInstance

        public abstract NumberFormat getNumberInstance​(Locale locale)
        返回指定区域设置的新通用 NumberFormat实例。
        参数
        locale - 所需的语言环境
        结果
        通用数字格式化程序
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        NumberFormat.getNumberInstance(java.util.Locale)

      • getPercentInstance

        public abstract NumberFormat getPercentInstance​(Locale locale)
        返回一个新的 NumberFormat实例，它为指定的区域设置格式化百分比值。
        参数
        locale - 所需的语言环境
        结果
        百分比格式化
        异常
        NullPointerException - 如果 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        NumberFormat.getPercentInstance(java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.text.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.text.spi

No usage of java.text.spi
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.spi.BreakIteratorProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.spi.BreakIteratorProvider

No usage of java.text.spi.BreakIteratorProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.spi.CollatorProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.spi.CollatorProvider

No usage of java.text.spi.CollatorProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.spi.DateFormatProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.spi.DateFormatProvider

No usage of java.text.spi.DateFormatProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.spi.DateFormatSymbolsProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.spi.DateFormatSymbolsProvider

No usage of java.text.spi.DateFormatSymbolsProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.spi.DecimalFormatSymbolsProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.spi.DecimalFormatSymbolsProvider

No usage of java.text.spi.DecimalFormatSymbolsProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.text.spi.NumberFormatProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.text.spi.NumberFormatProvider

No usage of java.text.spi.NumberFormatProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Clock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class Clock

  • java.lang.Object
    • java.time.Clock

  • public abstract class Clock
extends Object
    使用时区提供对当前即时，日期和时间的访问的时钟。

    该类的实例用于查找当前时刻，可以使用存储的时区来解释当前时刻，以查找当前日期和时间。 因此，可以使用时钟来代替System.currentTimeMillis()和TimeZone.getDefault() 。

    使用Clock是可选的。 所有关键的日期时间类也有一个now()工厂方法，它使用默认时区中的系统时钟。 这种抽象的主要目的是允许在需要时插入备用时钟。 应用程序使用对象获取当前时间，而不是静态方法。 这可以简化测试。

    应用程序的最佳做法是将Clock传递给需要当前即时的任何方法。 依赖注入框架是实现此目的的一种方法：

      public class MyBean {
    private Clock clock;  // dependency inject
    ...
    public void process(LocalDate eventDate) {
      if (eventDate.isBefore(LocalDate.now(clock)) {
        ...
      }
    }
  }
    这种方法允许在测试期间使用替代时钟，例如fixed或offset 。

    system工厂方法基于最佳可用系统时钟提供时钟这可能使用System.currentTimeMillis()或更高分辨率的时钟（如果有）。

    实现要求：
    这个抽象类必须小心实现，以确保其他类正确运行。 可以实例化的所有实现必须是最终的，不可变的和线程安全的。

    主要方法被定义为允许抛出异常。 在正常使用中，不会抛出任何异常，但是一个可能的实现是从中央时间服务器通过网络获取时间。 显然，在这种情况下，查找可能会失败，因此允许该方法抛出异常。

    从返回的时刻Clock上的时间尺度工作忽略闰秒，如在描述Instant 。 如果实现包装了提供闰秒信息的源，那么应该使用一个机制来“平滑”闰秒。 Java时间尺度要求使用UTC-SLS，但是只要记录它们的工作原理，时钟实现可以选择它们与时间尺度的准确度。 因此实际上不需要实际执行UTC-SLS转换，否则不需要知道闰秒。

    实施应尽可能实施Serializable并且必须记录它们是否支持序列化。

    Implementation Note:
    这里提供的时钟实现基于与System.currentTimeMillis()相同的底层时钟，但是如果可用，则可能具有比毫秒更精细的精度。 然而，关于基础时钟的准确性几乎没有保证。 需要更精确时钟的应用程序必须使用不同的外部时钟（如NTP服务器）实现此抽象类。
    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Clock​()
      子类可访问的构造方法。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查这个时钟是否等于另一个时钟。
      static Clock fixed​(Instant fixedInstant, ZoneId zone)
      获得始终返回相同时刻的时钟。
      abstract ZoneId getZone​()
      获取用于创建日期和时间的时区。
      int hashCode​()
      这个时钟的哈希码。
      abstract Instant instant​()
      获取当前的时钟瞬间。
      long millis​()
      获取时钟的当前毫秒时间。
      static Clock offset​(Clock baseClock, Duration offsetDuration)
      获取一个时钟，从指定的时钟周期返回时钟，并添加指定的时间
      static Clock system​(ZoneId zone)
      获取使用最佳可用系统时钟返回当前即时的时钟。
      static Clock systemDefaultZone​()
      获取使用最佳可用系统时钟返回当前即时的时钟，使用默认时区转换为日期和时间。
      static Clock systemUTC​()
      获取使用最佳可用系统时钟返回当前即时的时钟，使用UTC时区转换为日期和时间。
      static Clock tick​(Clock baseClock, Duration tickDuration)
      获取时钟，将时钟从指定的时钟截断返回到指定持续时间的最近出现。
      static Clock tickMillis​(ZoneId zone)
      获取时钟，使用最佳可用系统时钟返回当前瞬间滴答整数毫秒。
      static Clock tickMinutes​(ZoneId zone)
      获取时钟，使用最佳可用系统时钟在一分钟内返回当前瞬间滴答。
      static Clock tickSeconds​(ZoneId zone)
      获取时钟，使用最佳可用系统时钟在一秒钟内返回当前瞬间滴答作响。
      abstract Clock withZone​(ZoneId zone)
      以不同的时区返回此时钟的副本。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Clock

        protected Clock​()
        子类可访问的构造方法。

    • 方法详细信息

      • systemUTC

        public static Clock systemUTC​()
        获取使用最佳可用系统时钟返回当前即时的时钟，使用UTC时区转换为日期和时间。

        这个时钟，而不是systemDefaultZone() ，当你需要当前时刻没有日期或时间时，应该使用。

        该时钟基于最佳可用系统时钟。 这可能使用System.currentTimeMillis()或更高分辨率的时钟（如果有）。

        从即时到日期或时间的转换使用UTC time-zone 。

        返回的实现是不可变的，线程安全的和Serializable 。 相当于system(ZoneOffset.UTC) 。

        结果
        在UTC区域使用最佳可用系统时钟的时钟不为空

      • systemDefaultZone

        public static Clock systemDefaultZone​()
        获取使用最佳可用系统时钟返回当前即时的时钟，使用默认时区转换为日期和时间。

        该时钟基于最佳可用系统时钟。 这可能使用System.currentTimeMillis()或更高分辨率的时钟（如果有）。

        使用这种方法硬编码对应用程序的默认时区的依赖。 建议避免这种情况，并尽可能使用特定的时区。 当您需要当前即时的时间，而不用日期或时间，则应使用UTC clock 。

        返回的实现是不可变的，线程安全的和Serializable 。 相当于system(ZoneId.systemDefault()) 。

        结果
        在默认区域中使用最佳可用系统时钟的时钟，不为空
        另请参见：
        ZoneId.systemDefault()

      • system

        public static Clock system​(ZoneId zone)
        获取使用最佳可用系统时钟返回当前即时的时钟。

        该时钟基于最佳可用系统时钟。 这可能使用System.currentTimeMillis() ，或者更高分辨率的时钟（如果有）。

        从即时到日期或时间的转换使用指定的时区。

        返回的实现是不可变的，线程安全的和Serializable 。

        参数
        zone - 用于将即时转换为日期时间的时区，不为空
        结果
        在指定区域中使用最佳可用系统时钟的时钟，不为空

      • tickMillis

        public static Clock tickMillis​(ZoneId zone)
        获取时钟，使用最佳可用系统时钟返回当前瞬间滴答整数毫秒。

        这个时钟将始终将纳秒的字段截断为毫秒。 这可以确保可见的时间在整个毫秒内打勾。 底层时钟是最佳可用系统时钟，相当于使用system(ZoneId) 。

        出于性能原因，实施可能会使用缓存策略。 因此，可能通过该时钟观察到的毫秒的开始将晚于通过底层时钟直接观察到的毫秒的开始。

        返回的实现是不可变的，线程安全的和Serializable 。 相当于tick(system(zone), Duration.ofMillis(1)) 。

        参数
        zone - 用于将即时转换为日期时间的时区，不为空
        结果
        一个使用指定区域，以毫秒为单位的时钟，不为空
        从以下版本开始：
        9

      • tickSeconds

        public static Clock tickSeconds​(ZoneId zone)
        获取时钟，使用最佳可用系统时钟在一秒钟内返回当前瞬间滴答作响。

        该时钟将始终将纳秒的字段设置为零。 这可以确保可见的时间在整个秒钟内打勾。 底层时钟是最好的可用系统时钟，相当于使用system(ZoneId) 。

        出于性能原因，实施可能会使用缓存策略。 因此，可能通过该时钟观察的第二秒的开始将晚于直接通过下面的时钟观察到的。

        返回的实现是不可变的，线程安全的和Serializable 。 相当于tick(system(zone), Duration.ofSeconds(1)) 。

        参数
        zone - 用于将即时转换为日期时间的时区，不为空
        结果
        一个使用指定区域在整个秒钟内刻录的时钟，不为空

      • tickMinutes

        public static Clock tickMinutes​(ZoneId zone)
        获取时钟，使用最佳可用系统时钟在一分钟内返回当前瞬间滴答。

        该时钟将始终将纳秒二分之一和二分之一字段设置为零。 这确保了可见的时间在整个分钟内打勾。 底层时钟是最好的可用系统时钟，相当于使用system(ZoneId) 。

        出于性能原因，实施可能会使用缓存策略。 因此，可能通过该时钟观察到的分钟的开始将晚于直接通过底层时钟观察到的分钟的开始。

        返回的实现是不可变的，线程安全的和Serializable 。 相当于tick(system(zone), Duration.ofMinutes(1)) 。

        参数
        zone - 用于将即时转换为日期时间的时区，不为空
        结果
        一个使用指定区域在整个分钟内刻录的时钟，不为空

      • tick

        public static Clock tick​(Clock baseClock,
                         Duration tickDuration)
        获取时钟，将时钟从指定的时钟截断返回到指定持续时间的最近出现。

        该时钟将仅按照指定的持续时间进行选择。 因此，如果持续时间是半秒钟，则时钟将使时间截断为半秒钟。

        刻度持续时间必须为正。 如果它的一部分小于一毫秒，则整个持续时间必须分成一秒而不留余数。 所有正常的刻度持续时间将与这些标准匹配，包括小时，分钟，秒和毫秒的任意倍数，以及敏感的纳秒持续时间，如20ns，250,000ns和500,000ns。

        零或一纳秒的持续时间将没有截断效应。 传递其中的一个将返回底层时钟。

        出于性能原因，实施可能会使用缓存策略。 因此，可能通过该时钟观察到的所请求持续时间的开始将晚于直接通过底层时钟观察到的持续时间。

        返回的实现是不可变的，线程安全的， Serializable提供基本时钟。

        参数
        baseClock - 基准时钟打开滴答时钟，不为空
        tickDuration - 每个可见tick的持续时间，而不是负数，不为null
        结果
        一个以整个单位记录的时钟，不为零
        异常
        IllegalArgumentException - 如果持续时间为负，或者具有小于整个毫秒的部分，使得整个持续时间不能被整除为一秒
        ArithmeticException - 如果持续时间太大而无法表示为纳米

      • fixed

        public static Clock fixed​(Instant fixedInstant,
                          ZoneId zone)
        获得始终返回相同时刻的时钟。

        这个时钟只需返回指定的时刻。 因此，它不是常规意义上的时钟。 主要用例是测试，固定时钟确保测试不依赖于当前时钟。

        返回的实现是不可变的，线程安全的和Serializable 。

        参数
        fixedInstant - 即时使用时钟，不为空
        zone - 用于将即时转换为日期时间的时区，不为空
        结果
        一个总是返回相同时刻的时钟，而不是null

      • offset

        public static Clock offset​(Clock baseClock,
                           Duration offsetDuration)
        获取一个时钟，从指定的时钟周期返回时钟，并添加指定的时间

        这个时钟包裹另一个时钟，返回稍后指定持续时间的时刻。 如果持续时间为负，则时间将早于当前日期和时间。 这个的主要用例是模拟未来或过去的运行。

        零的持续时间将没有抵消效果。 传递零将返回底层时钟。

        返回的实现是不可变的，线程安全的， Serializable提供基本时钟。

        参数
        baseClock - 基本时钟添加持续时间，不为null
        offsetDuration - 添加的持续时间，不为null
        结果
        基于基本时钟的时钟，持续时间加上，不为空

      • getZone

        public abstract ZoneId getZone​()
        获取用于创建日期和时间的时区。

        时钟通常将获得当前时刻，然后使用时区将其转换为日期或时间。 此方法返回使用的时区。

        结果
        用于解释时刻的时区，不为空

      • withZone

        public abstract Clock withZone​(ZoneId zone)
        以不同的时区返回此时钟的副本。

        时钟通常将获得当前时刻，然后使用时区将其转换为日期或时间。 此方法返回具有相似属性但使用不同时区的时钟。

        参数
        zone - 时区改为，不为空
        结果
        基于此时钟的时钟具有指定的时区，不为空

      • millis

        public long millis​()
        获取时钟的当前毫秒时间。

        这将返回从1970-01-01T00：00Z（UTC）测量的基于毫秒的时刻。 这相当于System.currentTimeMillis()的定义。

        大多数应用程序应避免使用此方法，并使用Instant来表示时间线上的即时，而不是原始毫秒值。 提供这种方法以允许在高性能使用情况下使用时钟，其中创建对象将是不可接受的。

        目前的默认实现方式是拨打instant() 。

        结果
        从这个时钟的当前毫秒时刻，从1970-01-01T00：00Z（UTC）的Java时代测量，不为零
        异常
        DateTimeException - 如果无法获取该时间，则不会被大多数实现抛出

      • instant

        public abstract Instant instant​()
        获取当前的时钟瞬间。

        这将返回表示由时钟定义的当前时刻的瞬间。

        结果
        从这个时钟的当前瞬间，不为空
        异常
        DateTimeException - 如果无法获取该时刻，则不会被大多数实现抛出

      • equals

        public boolean equals​(Object obj)
        检查这个时钟是否等于另一个时钟。

        时钟应该覆盖此方法，以根据其状态比较平等，并符合Object.equals(java.lang.Object)的合同。 如果不覆盖，行为由Object.equals(java.lang.Object)定义

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他时钟，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个时钟的哈希码。

        时钟应根据其状态来覆盖此方法，并符合Object.hashCode()的合同。 如果不覆盖，行为由Object.hashCode()定义

        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DateTimeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class DateTimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.time.DateTimeException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    DateTimeParseException ， UnsupportedTemporalTypeException ， ZoneRulesException

    public class DateTimeException
extends RuntimeException
    用于在计算日期时间时指示问题的异常。

    此异常用于指示创建，查询和操作日期时间对象的问题。

    实现要求：
    该类旨在用于单个线程。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DateTimeException​(String message)
      使用指定的消息构造新的日期时间异常。
      DateTimeException​(String message, Throwable cause)
      构造一个新的日期时间异常与指定的消息和原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • DateTimeException

        public DateTimeException​(String message)
        使用指定的消息构造新的日期时间异常。
        参数
        message - 用于此异常的消息可能为null

      • DateTimeException

        public DateTimeException​(String message,
                         Throwable cause)
        构造一个新的日期时间异常与指定的消息和原因。
        参数
        message - 用于此异常的消息可能为null
        cause - the cause of the exception, may be null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DayOfWeek (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time

Enum DayOfWeek

  • java.lang.Object
    • java.lang.Enum<DayOfWeek>
      • java.time.DayOfWeek
  • All Implemented Interfaces:
    Serializable ， Comparable<DayOfWeek> ， TemporalAccessor ， TemporalAdjuster

    public enum DayOfWeek
extends Enum<DayOfWeek>
implements TemporalAccessor, TemporalAdjuster
    星期几，如“星期二”。

    DayOfWeek是一个表示星期一，星期二，星期三，星期四，星期五，星期六和星期日的星期几的星期几的枚举。

    除了文字枚举名称外，每个星期几都有一个int值。 int价格遵循ISO-8601标准，从1（星期一）到7（星期日）。 建议应用程序使用枚举而不是int值来确保代码清晰。

    该枚举提供访问星期几本地化的文本形式。 某些区域设置也会为日期分配不同的数值，并将星号表示为值1，但此类不提供此参数。 请参阅WeekFields本地化周编号。

    不要使用ordinal()获得的数字表示DayOfWeek 。 改用getValue() 。

    该枚举代表了许多日历系统中发现的常见概念。 因此，该枚举可以被任何具有与ISO日历系统完全相同的星期概念定义的日历系统使用。

    实现要求：
    这是一个不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      FRIDAY
      星期五的单日例子。
      MONDAY
      星期一星期几的单身人士例子。
      SATURDAY
      星期六的单日例子。
      SUNDAY
      星期天的星期几的单身人士例子。
      THURSDAY
      星期四的单日例子。
      TUESDAY
      星期二星期几的单身人士例子。
      WEDNESDAY
      星期三的星期几的单身人士例子。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      将指定的时间对象调整为具有这一天的日期。
      static DayOfWeek from​(TemporalAccessor temporal)
      从时间对象获取 DayOfWeek的实例。
      int get​(TemporalField field)
      从这个星期几获取指定字段的值作为 int 。
      String getDisplayName​(TextStyle style, Locale locale)
      获取文本表示，如“星期一”或“星期五”。
      long getLong​(TemporalField field)
      从这个星期几获取指定字段的值作为 long 。
      int getValue​()
      获得 int价值。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      DayOfWeek minus​(long days)
      返回指定天数之前的星期几。
      static DayOfWeek of​(int dayOfWeek)
      从 int获取 DayOfWeek的实例。
      DayOfWeek plus​(long days)
      返回这一天后指定天数的星期几。
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此星期几。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      static DayOfWeek valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DayOfWeek[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MONDAY

        public static final DayOfWeek MONDAY
        星期一星期几的单身人士例子。 其数值为1 。

      • TUESDAY

        public static final DayOfWeek TUESDAY
        星期二星期几的单身人士例子。 它的数值为2 。

      • WEDNESDAY

        public static final DayOfWeek WEDNESDAY
        星期三的星期几的单身人士例子。 这个数值为3 。

      • THURSDAY

        public static final DayOfWeek THURSDAY
        星期四的单日例子。 这个数值为4 。

      • FRIDAY

        public static final DayOfWeek FRIDAY
        星期五的单日例子。 这个数值为5 。

      • SATURDAY

        public static final DayOfWeek SATURDAY
        星期六的单日例子。 这个数值为6 。

      • SUNDAY

        public static final DayOfWeek SUNDAY
        星期天的星期几的单身人士例子。 这个数值为7 。

    • 方法详细信息

      • values

        public static DayOfWeek[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (DayOfWeek c : DayOfWeek.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static DayOfWeek valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • of

        public static DayOfWeek of​(int dayOfWeek)
        从int获取DayOfWeek的实例。

        DayOfWeek是一个代表本周7天的枚举。 该工厂允许从int获取枚举。 int价格遵循ISO-8601标准，从1（星期一）到7（星期日）。

        参数
        dayOfWeek - 代表从1（星期一）到7（星期日）的星期几
        结果
        一天的单身人士，不为零
        异常
        DateTimeException - 如果星期几无效

      • from

        public static DayOfWeek from​(TemporalAccessor temporal)
        从时间对象获取一个DayOfWeek的实例。

        这取决于指定时间的星期几。 A TemporalAccessor表示任意一组日期和时间信息，该工厂将转换为DayOfWeek一个实例。

        该转换提取了DAY_OF_WEEK字段。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考DayOfWeek::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        星期几不为零
        异常
        DateTimeException - 如果无法转换为 DayOfWeek

      • getValue

        public int getValue​()
        获得周二int价值。

        这些值按照ISO-8601标准编号，从1（星期一）到7（星期日）。 有关本地化的星期编号，请参阅WeekFields.dayOfWeek() 。

        结果
        从星期一到星期日从星期一到星期日的星期几

      • getDisplayName

        public String getDisplayName​(TextStyle style,
                             Locale locale)
        获取文本表示，如“星期一”或“星期五”。

        这将返回用于标识星期几的文字名称，适合向用户呈现。 参数控制返回的文本和区域设置的样式。

        如果没有发现文本映射，则返回numeric value 。

        参数
        style - 所需文本的长度，不为空
        locale - 要使用的语言环境，不为空
        结果
        星期几的文本值不为null

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的星期几。 如果是false，那么调用range和get方法会抛出异常。

        如果该字段为DAY_OF_WEEK，则此方法返回true。 所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果在这个星期几支持该字段，则为true，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 这个星期几用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果字段是DAY_OF_WEEK，那么将返回从1到7的星期几的范围。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持

      • get

        public int get​(TemporalField field)
        从这个星期几获取指定字段的值作为int 。

        这将查询指定字段的值的星期几。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果字段是DAY_OF_WEEK，那么将返回从1到7的星期几的值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值在值的有效范围内
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从这个星期几获取指定字段的值作为long 。

        这将查询指定字段的值的星期几。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果字段是DAY_OF_WEEK，那么将返回从1到7的星期几的值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取该字段的值
        UnsupportedTemporalTypeException - 如果不支持该字段
        ArithmeticException - 如果发生数字溢出

      • plus

        public DayOfWeek plus​(long days)
        返回这一天后指定天数的星期几。

        周末到周一，周末的计算结束。 指定期间可能为负。

        此实例是不可变的，不受此方法调用的影响。

        参数
        days - 添加的日子，正面或者负面
        结果
        由此产生的星期几不为零

      • minus

        public DayOfWeek minus​(long days)
        返回指定天数之前的星期几。

        计算周一至周日从年初开始计算。 指定期间可能为负。

        此实例是不可变的，不受此方法调用的影响。

        参数
        days - 减去正数或负数的日期
        结果
        由此产生的星期几不为零

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此星期几。

        这使用指定的查询策略对象来查询这个星期几。 TemporalQuery对象定义要用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在指定的查询this作为参数调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        将指定的时间对象调整为具有这一天的日期。

        这返回与周日的输入相同的可观察类型的时间对象与此相同。

        该调整是相当于使用Temporal.with(TemporalField, long)通过ChronoField.DAY_OF_WEEK作为字段。 请注意，这将在星期一至星期日周前向前或向后进行调整。 有关本周的开始日期，请参阅WeekFields.dayOfWeek() 。 有关更多控制的其他调整器，请参见TemporalAdjuster ，如next(MONDAY) 。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisDayOfWeek.adjustInto(temporal);
   temporal = temporal.with(thisDayOfWeek);

        例如，给定一个星期三的日期，输出以下内容：

          dateOnWed.with(MONDAY);     // two days earlier
   dateOnWed.with(TUESDAY);    // one day earlier
   dateOnWed.with(WEDNESDAY);  // same date
   dateOnWed.with(THURSDAY);   // one day later
   dateOnWed.with(FRIDAY);     // two days later
   dateOnWed.with(SATURDAY);   // three days later
   dateOnWed.with(SUNDAY);     // four days later

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果无法进行调整
        ArithmeticException - 如果发生数字溢出
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Duration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class Duration

  • java.lang.Object
    • java.time.Duration
  • All Implemented Interfaces:
    Serializable ， Comparable<Duration> ， TemporalAmount

    public final class Duration
extends Object
implements TemporalAmount, Comparable<Duration>, Serializable
    基于时间的时间量，如'34.5秒'。

    该类以秒和纳秒为单位建立数量或时间量。 它可以使用其他基于持续时间的单位进行访问，例如分钟和小时。 此外， DAYS单位可以使用，被视为完全等于24小时，因此忽略了夏令时效应。 请参阅Period以获取与此类别相等的日期。

    身体持续时间可能无限长。 为了实用性，持续时间存储有类似于Instant的约束。 持续时间使用纳秒分辨率，最大值可以保持在long 。 这大于当前估计的宇宙年龄。

    持续时间的范围需要存储大于long 。 为了达到这个目的，该类存储一个long代表秒，一个int代表二分之一秒，总共在0到999,999,999之间。 该模型具有定向持续时间，意味着持续时间可能为负。

    持续时间以秒为单位测量，但这些不一定与基于原子钟的科学“SI秒”定义相同。 这种差异仅影响闰秒附近测量的持续时间，不应影响大多数应用。 关于第二个和时间尺度的含义的讨论，见Instant 。

    这是一个value-based课; 对Duration实例使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Duration ZERO
      持续时间为零的常数。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Duration abs​()
      以正长度返回此持续时间的副本。
      Temporal addTo​(Temporal temporal)
      将此持续时间添加到指定的时间对象。
      static Duration between​(Temporal startInclusive, Temporal endExclusive)
      获取表示两个时间对象之间的持续时间的 Duration 。
      int compareTo​(Duration otherDuration)
      将此持续时间与指定的 Duration 。
      Duration dividedBy​(long divisor)
      返回此持续时间的副本除以指定的值。
      long dividedBy​(Duration divisor)
      在此持续时间内返回指定持续时间的整数倍数。
      boolean equals​(Object otherDuration)
      检查此持续时间是否等于指定的 Duration 。
      static Duration from​(TemporalAmount amount)
      从时间量获取 Duration的实例。
      long get​(TemporalUnit unit)
      获取所请求单元的值。
      int getNano​()
      在此持续时间内获得第二秒内的纳秒数。
      long getSeconds​()
      获取此持续时间内的秒数。
      List<TemporalUnit> getUnits​()
      获取此持续时间支持的单位集。
      int hashCode​()
      这个持续时间的哈希码。
      boolean isNegative​()
      检查此持续时间是否为负，不包括零。
      boolean isZero​()
      检查此持续时间是否为零长度。
      Duration minus​(long amountToSubtract, TemporalUnit unit)
      返回指定持续时间的副本减去。
      Duration minus​(Duration duration)
      返回指定持续时间的副本减去。
      Duration minusDays​(long daysToSubtract)
      在标准的24小时内减去指定的持续时间，返回此持续时间的副本。
      Duration minusHours​(long hoursToSubtract)
      以缩小的小时返回指定持续时间的此持续时间的副本。
      Duration minusMillis​(long millisToSubtract)
      以指定的持续时间返回此持续时间的副本，以毫秒为单位。
      Duration minusMinutes​(long minutesToSubtract)
      以指定的持续时间返回此持续时间的副本，以分钟为单位。
      Duration minusNanos​(long nanosToSubtract)
      以指定的持续时间返回此持续时间的副本，减去纳秒。
      Duration minusSeconds​(long secondsToSubtract)
      以指定的持续时间返回此持续时间的副本，以秒为单位。
      Duration multipliedBy​(long multiplicand)
      返回此持续时间的副本乘以标量。
      Duration negated​()
      返回长度为否定的此持续时间的副本。
      static Duration of​(long amount, TemporalUnit unit)
      获得 Duration表示指定单位的金额。
      static Duration ofDays​(long days)
      获得 Duration代表标准的24小时的天数。
      static Duration ofHours​(long hours)
      获得 Duration代表标准小时数。
      static Duration ofMillis​(long millis)
      获取 Duration表示毫秒数。
      static Duration ofMinutes​(long minutes)
      获得 Duration代表标准分钟数。
      static Duration ofNanos​(long nanos)
      获得一个 Duration代表一个纳秒。
      static Duration ofSeconds​(long seconds)
      获得 Duration秒数。
      static Duration ofSeconds​(long seconds, long nanoAdjustment)
      获得 Duration表示秒数和纳秒的调整。
      static Duration parse​(CharSequence text)
      获得 Duration从文本字符串，如 PnDTnHnMn.nS 。
      Duration plus​(long amountToAdd, TemporalUnit unit)
      返回此持续时间的副本，并添加指定的持续时间。
      Duration plus​(Duration duration)
      返回此持续时间的副本，并添加指定的持续时间。
      Duration plusDays​(long daysToAdd)
      在标准的24小时内添加指定的持续时间返回此持续时间的副本。
      Duration plusHours​(long hoursToAdd)
      以指定的持续时间返回此持续时间的副本，小时数。
      Duration plusMillis​(long millisToAdd)
      以指定的持续时间（以毫秒为单位）返回此持续时间的副本。
      Duration plusMinutes​(long minutesToAdd)
      以指定的持续时间（以分钟为单位）返回此持续时间的副本。
      Duration plusNanos​(long nanosToAdd)
      以指定的持续时间返回此持续时间的副本，以纳秒为单位。
      Duration plusSeconds​(long secondsToAdd)
      以指定的持续时间（以秒为单位）返回此持续时间的副本。
      Temporal subtractFrom​(Temporal temporal)
      从指定的时间对象中减去此持续时间。
      long toDays​()
      获取此持续时间的天数。
      long toDaysPart​()
      提取持续时间的天数。
      long toHours​()
      获取此持续时间内的小时数。
      int toHoursPart​()
      提取持续时间部分的小时数。
      long toMillis​()
      将此持续时间转换为总长度（以毫秒为单位）。
      int toMillisPart​()
      提取持续时间部分的毫秒数。
      long toMinutes​()
      获取此持续时间的分钟数。
      int toMinutesPart​()
      提取持续时间部分的分钟数。
      long toNanos​()
      将此持续时间转换为以 long表示的总长度，表示为 long 。
      int toNanosPart​()
      在持续时间的几秒钟内获取纳秒部分。
      long toSeconds​()
      获取此持续时间内的秒数。
      int toSecondsPart​()
      提取持续时间中的秒数。
      String toString​()
      使用ISO-8601秒表示形式显示此持续时间的字符串表示，如 PT8H6M12.345S 。
      Duration truncatedTo​(TemporalUnit unit)
      将此 Duration的副本返回给指定的单位。
      Duration withNanos​(int nanoOfSecond)
      以指定的纳秒为单位返回此持续时间的副本。
      Duration withSeconds​(long seconds)
      以指定的秒数返回此持续时间的副本。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ZERO

        public static final Duration ZERO
        持续时间为零的常数。

    • 方法详细信息

      • ofDays

        public static Duration ofDays​(long days)
        获得Duration代表一些标准的24小时的日子。

        秒是根据一天的标准清晰度计算的，每天的天数为86400秒，这意味着24小时的一天。 第二场的纳秒设置为零。

        参数
        days - 正数或负数的天数
        结果
        一个 Duration ，不为null
        异常
        ArithmeticException - 输入天数是否超过 Duration的容量

      • ofHours

        public static Duration ofHours​(long hours)
        获得Duration代表多个标准时数。

        秒是根据一小时的标准清晰度计算的，每小时3600秒。 第二场的纳秒设置为零。

        参数
        hours - 小时数，正数或负数
        结果
        一个 Duration ，不为null
        异常
        ArithmeticException - 如果输入时间超过 Duration的容量

      • ofMinutes

        public static Duration ofMinutes​(long minutes)
        获得Duration代表标准分钟数。

        秒是根据分钟的标准清晰度计算的，每分钟为60秒。 第二场的纳秒设置为零。

        参数
        minutes - 分数，正数或负数
        结果
        一个 Duration ，不为null
        异常
        ArithmeticException - 输入的分钟是否超过 Duration的容量

      • ofSeconds

        public static Duration ofSeconds​(long seconds)
        获得Duration表示秒数。

        第二场的纳秒设置为零。

        参数
        seconds - 秒数，正数或负数
        结果
        一个 Duration ，不为null

      • ofSeconds

        public static Duration ofSeconds​(long seconds,
                                 long nanoAdjustment)
        获得Duration表示秒数和纳秒的调整。

        该方法允许通过任意数量的纳秒。工厂将改变第二和纳秒的值，以确保存储的纳秒在0至999,999,999的范围内。 例如，以下将导致完全相同的持续时间：

          Duration.ofSeconds(3, 1);
  Duration.ofSeconds(4, -999_999_999);
  Duration.ofSeconds(2, 1000_000_001);
        参数
        seconds - 秒数，正数或负数
        nanoAdjustment - 纳秒秒调整为正数或负数
        结果
        一个 Duration ，不为null
        异常
        ArithmeticException - 如果调整导致秒数超过 Duration的容量

      • ofMillis

        public static Duration ofMillis​(long millis)
        获得Duration表示毫秒数。

        从指定的毫秒中提取秒和纳秒。

        参数
        millis - 毫秒数，正或负数
        结果
        一个 Duration ，不为null

      • ofNanos

        public static Duration ofNanos​(long nanos)
        获得代表数纳秒的Duration 。

        从指定的纳秒提取秒和纳秒。

        参数
        nanos - 纳秒数，正或负数
        结果
        一个 Duration ，不为null

      • of

        public static Duration of​(long amount,
                          TemporalUnit unit)
        获得Duration表示指定单位的金额。

        这些参数代表短语的两个部分，如“6小时”。 例如：

          Duration.of(3, SECONDS);
  Duration.of(465, HOURS);
        这种方法只接受一个单位的子集。 该单位必须有exact duration或ChronoUnit.DAYS ，被视为24小时。 其他单位抛出异常。
        参数
        amount - 持续时间的量，以单位为单位，以正或负为单位
        unit - 测量持续时间的单位必须具有精确的持续时间，而不是空值
        结果
        一个 Duration ，不为null
        异常
        DateTimeException - 如果周期单位具有估计的持续时间
        ArithmeticException - 如果发生数字溢出

      • from

        public static Duration from​(TemporalAmount amount)
        从时间量获取Duration的实例。

        这取决于指定量的持续时间。 A TemporalAmount表示这个工厂在一段时间内提取的时间量，可以是基于日期的或基于时间的。

        这些转换围绕该单位的数量循环，并使用该单位的duration来计算总计Duration 。 这种方法只接受一个单位的子集。 该单位必须有exact duration或ChronoUnit.DAYS ，被视为24小时。 如果找到任何其他单位，则会抛出异常。

        参数
        amount - 转换的时间量，不为空
        结果
        等效持续时间，不为空
        异常
        DateTimeException - 如果无法转换为 Duration
        ArithmeticException - 如果发生数字溢出

      • parse

        public static Duration parse​(CharSequence text)
        获得Duration从文本字符串，如PnDTnHnMn.nS 。

        这将解析持续时间的文本表示，包括由toString()生成的字符串。 接受的格式基于ISO-8601持续时间格式PnDTnHnMn.nS其中几天被认为是24小时。

        字符串以可选符号开头，由ASCII负号或正号表示。 如果是负面的，整个时期都是否定的。 ASCII字母“P”接下来是大写或小写。 然后有四个部分，每个部分由数字和后缀组成。 这些部分的日期，小时，分钟和秒的ASCII码为“D”，“H”，“M”和“S”，大写或小写。 后缀必须按顺序排列。 ASCII字母“T”必须在小时，分钟或第二段的第一次出现之前（如果有的话）出现。 必须存在四个部分中的至少一个，如果存在“T”，则在“T”之后必须至少有一个部分。 每个部分的编号部分必须由一个或多个ASCII数字组成。 该数字可能以ASCII正或负号为前缀。 天数，小时和分钟数必须解析为long 。 秒数必须解析为具有可选分数的long 。 小数点可以是点或逗号。 小数部分可能具有从零到九位数。

        其他单位的前加/减号和负值不属于ISO-8601标准。

        例子：

          "PT20.345S" -- parses as "20.345 seconds"
    "PT15M"     -- parses as "15 minutes" (where a minute is 60 seconds)
    "PT10H"     -- parses as "10 hours" (where an hour is 3600 seconds)
    "P2D"       -- parses as "2 days" (where a day is 24 hours or 86400 seconds)
    "P2DT3H4M"  -- parses as "2 days, 3 hours and 4 minutes"
    "PT-6H3M"    -- parses as "-6 hours and +3 minutes"
    "-PT6H3M"    -- parses as "-6 hours and -3 minutes"
    "-PT-6H+3M"  -- parses as "+6 hours and -3 minutes"
        参数
        text - 要解析的文本，不为空
        结果
        解析的持续时间，不为null
        异常
        DateTimeParseException - 如果文本无法解析为持续时间

      • between

        public static Duration between​(Temporal startInclusive,
                               Temporal endExclusive)
        获取表示两个时间对象之间的持续时间的Duration 。

        这计算两个时间对象之间的持续时间。 如果对象的类型不同，则根据第一个对象的类型计算持续时间。 例如，如果第一个参数是LocalTime则第二个参数将转换为LocalTime 。

        指定的时间对象必须支持SECONDS单元。 对于完全准确性，应支持NANOS单元或NANO_OF_SECOND字段。

        如果结束在开始之前，该方法的结果可以是负期。 要保证获得一个积极的期限，请拨打abs()的结果。

        参数
        startInclusive - 开始即时，包含，不为空
        endExclusive - 结束时刻，排他，不为空
        结果
        一个 Duration ，不为null
        异常
        DateTimeException - 如果无法获得时间之间的秒数
        ArithmeticException - 如果计算超过容量 Duration

      • get

        public long get​(TemporalUnit unit)
        获取所请求单元的值。

        这将为两个支持的单元SECONDS和NANOS中的每一个返回一个值。 所有其他单位抛出异常。

        Specified by:
        get在接口 TemporalAmount
        参数
        unit - TemporalUnit返回值的 TemporalUnit
        结果
        单位的长期价值
        异常
        DateTimeException - 如果不支持本机
        UnsupportedTemporalTypeException - 如果不支持本机

      • getUnits

        public List<TemporalUnit> getUnits​()
        获取此持续时间支持的单位集。

        支持的单位为SECONDS和NANOS 。 它们按照秒，nanos的顺序返回。

        该组可以与get(TemporalUnit)一起使用以访问整个持续时间的状态。

        Specified by:
        getUnits在接口 TemporalAmount
        结果
        包含秒和纳米单位的列表，不为空

      • isZero

        public boolean isZero​()
        检查此持续时间是否为零长度。

        A Duration表示时间线上两点之间的有向距离，因此可以为正，零或负。 该方法检查长度是否为零。

        结果
        如果此持续时间的总长度等于零，则为真

      • isNegative

        public boolean isNegative​()
        检查此持续时间是否为负，不包括零。

        A Duration表示时间线上两点之间的有向距离，因此可以为正，零或负。 此方法检查长度是否小于零。

        结果
        如果此持续时间的总长度小于零，则为真

      • getSeconds

        public long getSeconds​()
        获取此持续时间内的秒数。

        使用两个字段（秒和纳秒）存储持续时间的长度。 纳秒部分是从0到999,999,999的值，它是以秒为单位的长度的调整。 总持续时间通过调用此方法和getNano()来定义。

        A Duration表示时间线上两点之间的有向距离。 负数持续时间由秒部分的负号表示。 -1纳秒的持续时间存储为-1秒加上999,999,999纳秒。

        结果
        整个秒的长度部分持续时间为正或负

      • getNano

        public int getNano​()
        在此持续时间内获得第二秒内的纳秒数。

        使用两个字段（秒和纳秒）存储持续时间的长度。 纳秒部分是从0到999,999,999的值，它是以秒为单位的长度的调整。 总持续时间通过调用此方法和getSeconds()来定义。

        A Duration表示时间线上两点之间的有向距离。 负数持续时间由秒部分的负号表示。 -1纳秒的持续时间存储为-1秒加上999,999,999纳秒。

        结果
        第二部分的纳秒长度为0到999,999,999

      • withSeconds

        public Duration withSeconds​(long seconds)
        以指定的秒数返回此持续时间的副本。

        这将返回指定秒数的持续时间，保留此持续时间的纳秒的部分。

        此实例是不可变的，不受此方法调用的影响。

        参数
        seconds - 表示秒可以是负数
        结果
        一个 Duration基于此期间与请求的秒，不为null

      • withNanos

        public Duration withNanos​(int nanoOfSecond)
        以指定的纳秒为单位返回此持续时间的副本。

        这将返回具有指定的纳秒的持续时间，保留此持续时间的秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanoOfSecond - 表示从0到999,999,999的纳秒
        结果
        一个 Duration基于这个时期与请求的纳秒，不为null
        异常
        DateTimeException - 如果纳秒是无效的

      • plus

        public Duration plus​(Duration duration)
        返回此持续时间的副本，并添加指定的持续时间。

        此实例是不可变的，不受此方法调用的影响。

        参数
        duration - 添加的持续时间，正或负，不为空
        结果
        一个 Duration基于这个持续时间，指定的持续时间加上，不为空
        异常
        ArithmeticException - 如果发生数字溢出

      • plus

        public Duration plus​(long amountToAdd,
                     TemporalUnit unit)
        返回此持续时间的副本，并添加指定的持续时间。

        持续时间量以指定单位计量。 这种方法只接受一个单位的子集。 单位必须有exact duration或ChronoUnit.DAYS ，被视为24小时。 其他单位抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        amountToAdd - 添加量，以单位计，正数或负数
        unit - 测量金额的单位必须具有精确的持续时间，而不是空值
        结果
        一个 Duration基于此持续时间，指定的持续时间加上，不为null
        异常
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusDays

        public Duration plusDays​(long daysToAdd)
        在标准的24小时内添加指定的持续时间返回此持续时间的副本。

        天数乘以86400，以获得要添加的秒数。 这是基于一天24小时的标准清晰度。

        此实例是不可变的，不受此方法调用的影响。

        参数
        daysToAdd - 正或负的日子
        结果
        一个 Duration基于这个持续时间，加上指定的天数，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • plusHours

        public Duration plusHours​(long hoursToAdd)
        以指定的持续时间返回此持续时间的副本，小时数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hoursToAdd - 正或负的时间
        结果
        一个 Duration基于这个持续时间，加上指定的小时数，不为空
        异常
        ArithmeticException - 如果发生数字溢出

      • plusMinutes

        public Duration plusMinutes​(long minutesToAdd)
        以指定的持续时间（以分钟为单位）返回此持续时间的副本。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutesToAdd - 要添加的分数，正数或负数
        结果
        一个 Duration基于这个持续时间加上指定的分钟，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • plusSeconds

        public Duration plusSeconds​(long secondsToAdd)
        以指定的持续时间（以秒为单位）返回此持续时间的副本。

        此实例是不可变的，不受此方法调用的影响。

        参数
        secondsToAdd - 要添加的秒数，正数或负数
        结果
        一个 Duration基于这个持续时间，加上指定的秒数，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • plusMillis

        public Duration plusMillis​(long millisToAdd)
        以指定的持续时间（以毫秒为单位）返回此持续时间的副本。

        此实例是不可变的，不受此方法调用的影响。

        参数
        millisToAdd - 要添加的毫秒数，正数或负数
        结果
        一个 Duration基于此持续时间，指定的毫秒加上，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • plusNanos

        public Duration plusNanos​(long nanosToAdd)
        以指定的持续时间返回此持续时间的副本，以纳秒为单位。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanosToAdd - 添加的纳秒，正或负
        结果
        一个 Duration基于这个持续时间加上指定的纳秒，不为空
        异常
        ArithmeticException - 如果发生数字溢出

      • minus

        public Duration minus​(Duration duration)
        返回指定持续时间的副本减去。

        此实例是不可变的，不受此方法调用的影响。

        参数
        duration - 减去正或负的持续时间，不为空
        结果
        一个 Duration基于此持续时间减去指定的持续时间，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • minus

        public Duration minus​(long amountToSubtract,
                      TemporalUnit unit)
        返回指定持续时间的副本减去。

        持续时间量以指定单位计量。 这种方法只接受一个单位的子集。 单位必须有exact duration或ChronoUnit.DAYS ，被视为24小时。 其他单位抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        amountToSubtract - 以单位为单位，以正或负值来衡量的量
        unit - 测量金额的单位必须具有精确的持续时间，而不是空值
        结果
        一个 Duration基于此持续时间减去指定的持续时间，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • minusDays

        public Duration minusDays​(long daysToSubtract)
        在标准的24小时内减去指定的持续时间，返回此持续时间的副本。

        天数乘以86400，以获得要减去的秒数。 这是基于一天24小时的标准清晰度。

        此实例是不可变的，不受此方法调用的影响。

        参数
        daysToSubtract - 减去正数或负数的日期
        结果
        一个 Duration基于此持续时间减去指定的日期，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • minusHours

        public Duration minusHours​(long hoursToSubtract)
        以缩小的小时返回指定持续时间的此持续时间的副本。

        小时数乘以3600，以获得要减去的秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hoursToSubtract - 减去正数或负数的小时数
        结果
        一个 Duration基于此持续时间减去指定的小时，不为空
        异常
        ArithmeticException - 如果发生数字溢出

      • minusMinutes

        public Duration minusMinutes​(long minutesToSubtract)
        以指定的持续时间返回此持续时间的副本，以分钟为单位。

        小时数乘以60，以获得要减去的秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutesToSubtract - 减去正数或负数的分数
        结果
        一个 Duration基于此持续时间减去指定的分钟，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • minusSeconds

        public Duration minusSeconds​(long secondsToSubtract)
        以指定的持续时间返回此持续时间的副本，以秒为单位。

        此实例是不可变的，不受此方法调用的影响。

        参数
        secondsToSubtract - 减去正数或负数的秒数
        结果
        一个 Duration基于此持续时间减去指定的秒数，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • minusMillis

        public Duration minusMillis​(long millisToSubtract)
        以指定的持续时间返回此持续时间的副本，以毫秒为单位。

        此实例是不可变的，不受此方法调用的影响。

        参数
        millisToSubtract - 减去正数或负数的毫秒数
        结果
        一个 Duration基于此持续时间减去指定的毫秒，不为空
        异常
        ArithmeticException - 如果发生数字溢出

      • minusNanos

        public Duration minusNanos​(long nanosToSubtract)
        以指定的持续时间返回此持续时间的副本，减去纳秒。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanosToSubtract - 减去正数或负数的纳秒
        结果
        一个 Duration基于此持续时间减去指定的纳秒，不为空
        异常
        ArithmeticException - 如果发生数字溢出

      • multipliedBy

        public Duration multipliedBy​(long multiplicand)
        返回此持续时间的副本乘以标量。

        此实例是不可变的，不受此方法调用的影响。

        参数
        multiplicand - 将持续时间乘以正值或负值的值
        结果
        一个 Duration基于此持续时间乘以指定的标量，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • dividedBy

        public Duration dividedBy​(long divisor)
        返回此持续时间的副本除以指定的值。

        此实例是不可变的，不受此方法调用的影响。

        参数
        divisor - 将持续时间除以正或负的值不为零的值
        结果
        一个 Duration基于此持续时间除以指定的除数，不为null
        异常
        ArithmeticException - 如果除数为零或数字溢出发生

      • dividedBy

        public long dividedBy​(Duration divisor)
        在此持续时间内返回指定持续时间的整数倍数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        divisor - 将持续时间除以正或负的值不为null
        结果
        整数次，向零舍入，在此持续时间内发生指定的 Duration ，可能为负数
        异常
        ArithmeticException - 如果除数为零，或者数字溢出发生
        从以下版本开始：
        9

      • negated

        public Duration negated​()
        返回长度为否定的此持续时间的副本。

        此方法交换此持续时间的总长度的符号。 例如， PT1.3S将作为PT-1.3S返回。

        此实例是不可变的，不受此方法调用的影响。

        结果
        一个 Duration基于这个持续时间的数量被否定，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • abs

        public Duration abs​()
        以正长度返回此持续时间的副本。

        该方法通过有效地从任何负的总长度去除符号来返回正的持续时间。 例如， PT-1.3S将作为PT1.3S返回。

        此实例是不可变的，不受此方法调用的影响。

        结果
        一个 Duration基于这个持续时间，绝对长度，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • addTo

        public Temporal addTo​(Temporal temporal)
        将此持续时间添加到指定的时间对象。

        这返回与添加了此持续时间的输入相同的可观察类型的时间对象。

        在大多数情况下，通过使用Temporal.plus(TemporalAmount)来更正呼叫模式。

          // these two lines are equivalent, but the second approach is recommended
   dateTime = thisDuration.addTo(dateTime);
   dateTime = dateTime.plus(thisDuration);

        计算将添加秒，然后添加纳秒。 只会增加非零金额。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        addTo在接口 TemporalAmount
        参数
        temporal - 要调整的时间对象，不为空
        结果
        与调整相同类型的对象，不为空
        异常
        DateTimeException - 如果无法添加
        ArithmeticException - 如果发生数字溢出

      • subtractFrom

        public Temporal subtractFrom​(Temporal temporal)
        从指定的时间对象中减去此持续时间。

        这返回与具有该持续时间的输入相同的可观察类型的时间对象。

        在大多数情况下，使用Temporal.minus(TemporalAmount)来更正呼叫模式。

          // these two lines are equivalent, but the second approach is recommended
   dateTime = thisDuration.subtractFrom(dateTime);
   dateTime = dateTime.minus(thisDuration);

        计算将减去秒，然后减去纳秒。 只会增加非零金额。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        subtractFrom在接口 TemporalAmount
        参数
        temporal - 要调整的时间对象，不为null
        结果
        与调整相同类型的对象，不为空
        异常
        DateTimeException - 如果不能减去
        ArithmeticException - 如果发生数字溢出

      • toDays

        public long toDays​()
        获取此持续时间的天数。

        这通过将秒数除以86400来返回持续时间的总天数。这是基于24小时的一天的标准清晰度。

        此实例是不可变的，不受此方法调用的影响。

        结果
        持续时间的天数可能为负数

      • toHours

        public long toHours​()
        获取此持续时间内的小时数。

        这通过将秒数除以3600来返回持续时间的总小时数。

        此实例是不可变的，不受此方法调用的影响。

        结果
        持续时间的小时数可能为负数

      • toMinutes

        public long toMinutes​()
        获取此持续时间的分钟数。

        这将通过将秒数除以60来返回持续时间内的总分钟数。

        此实例是不可变的，不受此方法调用的影响。

        结果
        持续时间内的分钟数可能为负数

      • toSeconds

        public long toSeconds​()
        获取此持续时间内的秒数。

        这将返回持续时间内的总秒数。

        此实例是不可变的，不受此方法调用的影响。

        结果
        整个秒的长度部分持续时间为正或负
        从以下版本开始：
        9

      • toMillis

        public long toMillis​()
        将此持续时间转换为总长度（以毫秒为单位）。

        如果此持续时间太大，无法适应long毫秒，则会抛出异常。

        如果此持续时间大于毫秒精度，则转换将丢弃任何超量精度信息，犹如纳秒的数值为百分之一百分之一。

        结果
        持续时间的总长度（以毫秒为单位）
        异常
        ArithmeticException - 如果发生数字溢出

      • toNanos

        public long toNanos​()
        将此持续时间转换为总长度，单位为纳秒，表示为long 。

        如果此持续时间太大，无法适应long纳秒，则会抛出异常。

        结果
        持续时间的总长度以纳秒为单位
        异常
        ArithmeticException - 如果发生数字溢出

      • toDaysPart

        public long toDaysPart​()
        提取持续时间的天数。

        这通过将秒数除以86400来返回持续时间的总天数。这是基于24小时的一天的标准清晰度。

        此实例是不可变的，不受此方法调用的影响。

        结果
        持续时间的天数可能为负数
        从以下版本开始：
        9

      • toHoursPart

        public int toHoursPart​()
        提取持续时间部分的小时数。

        这将返回一天中划分toHours()小时的剩余小时数。 这是基于一天24小时的标准清晰度。

        此实例是不可变的，不受此方法调用的影响。

        结果
        持续时间部分的小时数可能为负数
        从以下版本开始：
        9

      • toMinutesPart

        public int toMinutesPart​()
        提取持续时间部分的分钟数。

        这返回在一小时内分割toMinutes()分钟的剩余分钟数。 这是基于一小时的标准清晰度为60分钟。

        此实例是不可变的，不受此方法调用的影响。

        结果
        持续时间内的分钟数可能为负数
        从以下版本开始：
        9

      • toSecondsPart

        public int toSecondsPart​()
        提取持续时间中的秒数。

        这将在一分钟内将toSeconds()分秒秒钟返回剩余的秒数。 这是基于一分钟的标准清晰度为60秒。

        此实例是不可变的，不受此方法调用的影响。

        结果
        持续时间内的秒数部分可能为负数
        从以下版本开始：
        9

      • toMillisPart

        public int toMillisPart​()
        提取持续时间部分的毫秒数。

        这通过将纳秒数除以1,000,000来返回毫秒部分。 使用两个字段（秒和纳秒）存储持续时间的长度。 纳秒部分是从0到999,999,999的值，它是以秒为单位的长度的调整。 总持续时间通过调用getNano()和getSeconds()来定义。

        此实例是不可变的，不受此方法调用的影响。

        结果
        毫秒数的一部分持续时间。
        从以下版本开始：
        9

      • toNanosPart

        public int toNanosPart​()
        在持续时间的几秒钟内获取纳秒部分。

        使用两个字段（秒和纳秒）存储持续时间的长度。 纳秒部分是从0到999,999,999的值，它是以秒为单位的长度的调整。 总持续时间通过调用getNano()和getSeconds()来定义。

        此实例是不可变的，不受此方法调用的影响。

        结果
        第二部分的纳秒长度为0到999,999,999
        从以下版本开始：
        9

      • truncatedTo

        public Duration truncatedTo​(TemporalUnit unit)
        返回此Duration的副本截断到指定的单位。

        截断持续时间返回原始的副本，其概念字段小于设置为零的指定单位。 例如，使用MINUTES单位截断将舍入到最近的分钟，将秒和纳秒设置为零。

        该单位必须有一个duration ，分为标准日期的长度，不含余量。 这包括所有提供的时间单位ChronoUnit和DAYS 。 其他ChronoUnits会抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        unit - 截断到的单位，不为null
        结果
        一个 Duration基于此持续时间截断，不为null
        异常
        DateTimeException - 如果单位无效截断
        UnsupportedTemporalTypeException - 如果不支持本机
        从以下版本开始：
        9

      • compareTo

        public int compareTo​(Duration otherDuration)
        将此持续时间与指定的Duration 。

        比较是基于持续时间的总长度。 它与“等于”一致，如Comparable所定义。

        Specified by:
        compareTo在接口 Comparable<Duration>
        参数
        otherDuration - 其他持续时间来比较，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • equals

        public boolean equals​(Object otherDuration)
        检查此持续时间是否等于指定的Duration 。

        比较是基于持续时间的总长度。

        重写：
        equals在 Object
        参数
        otherDuration - 其他持续时间，null返回false
        结果
        如果其他持续时间等于这一个则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个持续时间的哈希码。
        重写：
        hashCode在类 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        使用ISO-8601秒表示形式的字符串表示形式，如PT8H6M12.345S 。

        返回的字符串的格式为PTnHnMnS ，其中n是持续时间的相关小时数，分钟或秒。 任何小数秒将放置在秒部分中的小数点后面。 如果一个部分的值为零，则省略。 小时，分钟和秒将都有相同的标志。

        例子：

          "20.345 seconds"                 -- "PT20.345S
    "15 minutes" (15 * 60 seconds)   -- "PT15M"
    "10 hours" (10 * 3600 seconds)   -- "PT10H"
    "2 days" (2 * 86400 seconds)     -- "PT48H"
        请注意，24小时的倍数不会输出为天数，以避免与Period混淆。
        重写：
        toString在 Object
        结果
        该持续时间的ISO-8601表示，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Instant (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class Instant

  • java.lang.Object
    • java.time.Instant
  • All Implemented Interfaces:
    Serializable ， Comparable<Instant> ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class Instant
extends Object
implements Temporal, TemporalAdjuster, Comparable<Instant>, Serializable
    在时间线上的瞬间点。

    该类在时间线上建立单个瞬时点。 这可能用于在应用程序中记录事件时间戳。

    瞬间的范围需要存储大于long 。 为了实现这一点，该类存储一个long代表时代秒， int表示纳秒秒，它将始终在0和999,999,999之间。 时标是从标准的Java时代1970-01-01T00:00:00Z测量的，其中时期之后的时刻具有正值，较早的时刻具有负值。 对于时代第二和纳秒部分，时间线上的值越大越小。

    时间尺度

    太阳日的长度是人类测量时间的标准方式。 这传统上被分为60秒60小时的24小时，形成了86400秒。

    现代计时是基于相对于铯原子的跃迁精确定义SI秒的原子钟。 SI秒的长度定义为非常接近一天的第86400分。

    不幸的是，随着地球的旋转，一天的长短变化。 此外，随着时间的推移，一天的平均长度随着地球的减速而变得越来越长。 因此，2012年太阳日的长度稍长于86400 SI秒。 任何一天的实际长度以及地球减速的数量都是不可预知的，只能通过测量来确定。 UT1时间尺度捕获一天中的准确时间，但在一天之后的一段时间内才可用。

    UTC时间刻度是将UT1的所有额外分数从UT1捆绑到整秒钟的标准方法，称为闰秒 。 根据地球的旋转变化，可以添加或删除闰秒。 因此，为了保持日子与太阳对齐，UTC允许一天有86399 SI秒或86401 SI秒。

    现代UTC时间尺度于1972年引入，引入了整个飞跃的概念。 在1958年和1972年之间，UTC的定义是复杂的，次要的次秒级和对名义第二的长度的改变。 截至2012年，正在进行讨论，以再次更改UTC的定义，有可能删除闰秒或引入其他更改。

    鉴于上述精确计时的复杂性，该Java API定义了自己的时间尺度Java时间尺度 。

    Java时间刻度将每个日历日划分为86400个细分，称为秒。 这些秒可能与SI秒不同。 它与事实上的国际民事时间尺度非常吻合，不时定义哪些变化。

    Java时间尺度对时间线的不同部分的定义略有不同，每个时间尺度基于用作民事时间基础的一致性国际时间尺度。 每当修改或替换国际商定的时间尺度时，必须为其定义新的Java Time-Scale部分。 每个细分必须符合以下要求：

    • Java时间尺度应与国际民用时间尺度相匹配;
    • Java时间尺度应每天中午完全符合国际民用时间尺度;
    • Java时间尺度应与国际民用时间尺度有明确的关系。
    目前，截至2013年，Java时间尺度中有两个部分。

    对于从1972-11-03（截面如下所述的准确边界）的细分，直到另行通知，国际时间尺度是UTC（具有闰秒）。 在此段中，Java时间刻度与UTC-SLS相同。 这与UTC没有闰秒的天数相同。 在有闰秒的日子里，闰秒在一天的最后1000秒内平均分布，保持每天86400秒的出现。

    对于1972-11-03之前的部分，任意延伸回来，国际统一时间尺度被定义为UT1，应用于光学上，这相当于主要子午线（格林威治）的（平均）太阳时间。 在这一部分，Java时间尺度与国际时间标准一致。 两段之间的确切边界是1972-11-03T00：00和1972-11-04T12：00之间的UT1 = UTC的时刻。

    使用JSR-310 API的Java时间尺度的实现不需要提供任何次秒级准确的或者单调或平滑地进行的时钟。 因此实际上不需要实际执行UTC-SLS转换，否则不需要知道闰秒。 然而，JSR-310确实要求在定义表示当前时刻的时钟时，实现必须记录它们使用的方法。 有关可用时钟的详细信息，请参阅Clock 。

    Java时间标度用于所有日期时间类。 这包括Instant ， LocalDate ， LocalTime ， OffsetDateTime ， ZonedDateTime和Duration 。

    这是一个value-based课; 在Instant实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Instant EPOCH
      常数为1970-01-01T00：00：00Z时代瞬间。
      static Instant MAX
      最大支持 Instant ，'1000000000-12-31T23：59：59.999999999Z'。
      static Instant MIN
      最低支持 Instant ，'-1000000000-01-01T00：00Z'。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象具有这个瞬间。
      OffsetDateTime atOffset​(ZoneOffset offset)
      将此瞬间与偏移组合，创建一个 OffsetDateTime 。
      ZonedDateTime atZone​(ZoneId zone)
      将此瞬间与时区相结合，创建一个 ZonedDateTime 。
      int compareTo​(Instant otherInstant)
      将此瞬间与指定的时刻进行比较。
      boolean equals​(Object otherInstant)
      检查这个瞬间是否等于指定的时刻。
      static Instant from​(TemporalAccessor temporal)
      从时间对象获取 Instant的实例。
      int get​(TemporalField field)
      从该时刻获取指定字段的值作为 int 。
      long getEpochSecond​()
      从1970-01-01T00：00：00Z的Java时代获取秒数。
      long getLong​(TemporalField field)
      从该时刻获取指定字段的值作为 long 。
      int getNano​()
      从第二个开始就从时间线获得纳秒的数量。
      int hashCode​()
      返回此时刻的哈希码。
      boolean isAfter​(Instant otherInstant)
      检查这个瞬间是否在指定的时刻之后。
      boolean isBefore​(Instant otherInstant)
      检查这个时刻是否在指定的时刻之前。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      Instant minus​(long amountToSubtract, TemporalUnit unit)
      返回此时刻的副本，减去指定的金额。
      Instant minus​(TemporalAmount amountToSubtract)
      返回此时刻的副本，减去指定的金额。
      Instant minusMillis​(long millisToSubtract)
      以毫秒为单位的指定持续时间返回此瞬间的副本。
      Instant minusNanos​(long nanosToSubtract)
      以纳秒为单位返回指定持续时间的此瞬间的副本。
      Instant minusSeconds​(long secondsToSubtract)
      以秒为单位返回指定持续时间的此瞬间的副本。
      static Instant now​()
      从系统时钟获取当前瞬间。
      static Instant now​(Clock clock)
      从指定的时钟获取当前时刻。
      static Instant ofEpochMilli​(long epochMilli)
      从1970-01-01T00：00：00Z的时期获取使用毫秒的 Instant的实例。
      static Instant ofEpochSecond​(long epochSecond)
      使用从1970-01-01T00：00：00Z的时代开始的秒数获得 Instant的实例。
      static Instant ofEpochSecond​(long epochSecond, long nanoAdjustment)
      使用从1970-01-01T00：00：00Z的时期开始的秒数获得 Instant的实例和秒的纳秒分数。
      static Instant parse​(CharSequence text)
      从 2007-12-03T10:15:30.00Z等文本字符串获取 Instant的实例。
      Instant plus​(long amountToAdd, TemporalUnit unit)
      返回添加指定数量的此瞬间的副本。
      Instant plus​(TemporalAmount amountToAdd)
      返回添加指定数量的此瞬间的副本。
      Instant plusMillis​(long millisToAdd)
      以毫秒为单位的指定持续时间返回此瞬间的副本。
      Instant plusNanos​(long nanosToAdd)
      以指定的持续时间返回此瞬间的副本，以纳秒为单位。
      Instant plusSeconds​(long secondsToAdd)
      以指定的持续时间返回此瞬间的副本，以秒为单位。
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此即时。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      long toEpochMilli​()
      将此瞬间转换为1970-01-01T00：00：00Z的时期的毫秒数。
      String toString​()
      此瞬间使用ISO-8601表示形式的字符串表示形式。
      Instant truncatedTo​(TemporalUnit unit)
      将此 Instant的副本返回给指定的单位。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定单位计算直到另一瞬间的时间量。
      Instant with​(TemporalAdjuster adjuster)
      返回此瞬间的调整副本。
      Instant with​(TemporalField field, long newValue)
      将指定的字段设置为新值返回此瞬间的副本。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • EPOCH

        public static final Instant EPOCH
        常数为1970-01-01T00：00：00Z时代瞬间。

      • MIN

        public static final Instant MIN
        最低支持Instant ，'-1000000000-01-01T00：00Z'。 这可以被应用程序用作“过去”的瞬间。

        这比最低LocalDateTime提前一年。 这提供了足够的值来处理除了本地日期时间之外影响瞬间的ZoneOffset的范围。 该值也被选择为使得该年度的值符合int 。

      • MAX

        public static final Instant MAX
        最大支持Instant ，'1000000000-12-31T23：59：59.999999999Z'。 这可以被应用程序用作“远未来”的瞬间。

        这比最高LocalDateTime晚了LocalDateTime 。 这提供足够的值来处理除了本地日期时间之外影响瞬间的ZoneOffset的范围。 该值也被选择为使得该年度的值适合int 。

    • 方法详细信息

      • now

        public static Instant now​()
        从系统时钟获取当前瞬间。

        这将查询system UTC clock获取当前即时。

        使用此方法将阻止使用备用时间源进行测试的能力，因为时钟被有效地硬编码。

        结果
        当前即时使用系统时钟，不为空

      • now

        public static Instant now​(Clock clock)
        从指定的时钟获取当前时刻。

        这将查询指定的时钟以获取当前时间。

        使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前即时，不为空

      • ofEpochSecond

        public static Instant ofEpochSecond​(long epochSecond)
        使用从1970-01-01T00：00：00Z的时代开始的秒数获得一个Instant的实例。

        纳秒场被设置为零。

        参数
        epochSecond - 从1970-01-01T00：00：00Z的秒数
        结果
        一瞬间，不为零
        异常
        DateTimeException - 如果瞬间超过最大或最小瞬间

      • ofEpochSecond

        public static Instant ofEpochSecond​(long epochSecond,
                                    long nanoAdjustment)
        使用从1970-01-01T00：00：00Z的时期开始的秒数获得Instant的实例， Instant获得秒的纳秒分数。

        该方法允许通过任意数量的纳秒。工厂将改变第二和纳秒的值，以确保存储的纳秒在0至999,999,999的范围内。 例如，以下将导致完全相同的时刻：

          Instant.ofEpochSecond(3, 1);
  Instant.ofEpochSecond(4, -999_999_999);
  Instant.ofEpochSecond(2, 1000_000_001);
        参数
        epochSecond - 从1970-01-01T00：00：00Z的秒数
        nanoAdjustment - 纳秒秒调整为正数或负数
        结果
        一瞬间，不为零
        异常
        DateTimeException - 如果瞬间超过最大或最小瞬间
        ArithmeticException - 如果发生数字溢出

      • ofEpochMilli

        public static Instant ofEpochMilli​(long epochMilli)
        从1970-01-01T00：00：00Z的时期获取使用毫秒的Instant的实例。

        从指定的毫秒中提取秒和纳秒。

        参数
        epochMilli - 从1970-01-01T00：00：00Z的毫秒数
        结果
        一瞬间，不为零
        异常
        DateTimeException - 如果瞬间超过最大或最小瞬间

      • from

        public static Instant from​(TemporalAccessor temporal)
        从时间对象获取Instant的实例。

        这将根据指定的时间获得一个瞬间。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为Instant的实例。

        该转换提取了INSTANT_SECONDS和NANO_OF_SECOND字段。

        该方法匹配功能界面TemporalQuery的签名，允许它通过方法参考Instant::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        即时，不为空
        异常
        DateTimeException - 如果无法转换为 Instant

      • parse

        public static Instant parse​(CharSequence text)
        从2007-12-03T10:15:30.00Z等文本字符串获取Instant的实例。

        该字符串必须表示UTC的有效时间，并使用DateTimeFormatter.ISO_INSTANT进行解析。

        参数
        text - 要解析的文本，不为空
        结果
        解析的瞬间，不为空
        异常
        DateTimeParseException - 如果文本无法解析

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的此即时。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 支持的字段有：

        • NANO_OF_SECOND
        • MICRO_OF_SECOND
        • MILLI_OF_SECOND
        • INSTANT_SECONDS
        所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果该字段在此瞬间被支持，则为true，否则为false

      • isSupported

        public boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定的单位是否可以添加到该日期时间或从该日期时间中减去。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        如果单位是ChronoUnit，那么查询是在这里实现的。 支持的单位是：

        • NANOS
        • MICROS
        • MILLIS
        • SECONDS
        • MINUTES
        • HOURS
        • HALF_DAYS
        • DAYS
        所有其他ChronoUnit实例将返回false。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 此瞬间用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持

      • get

        public int get​(TemporalField field)
        从该时刻获取指定字段的值作为int 。

        这将查询指定字段的值。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将根据此日期时间返回有效值，但INSTANT_SECONDS用于int并抛出DateTimeException 。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从该时刻获取指定字段的值作为long 。

        这将查询指定字段的值。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将根据此日期时间返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • getEpochSecond

        public long getEpochSecond​()
        从1970-01-01T00：00：00Z的Java时代获取秒数。

        时代秒计数是第二个0是1970-01-01T00：00：00Z的秒的简单递增计数。 一天的纳秒部分由getNano()返回。

        结果
        从1970-01-01T00：00：00Z的时代开始的秒数

      • getNano

        public int getNano​()
        从第二个开始就从时间线获得纳秒的数量。

        第二纳秒值测量从第二个返回的getEpochSecond()的纳秒的总数 。

        结果
        秒内的纳秒总是正数，从不超过999,999,999

      • with

        public Instant with​(TemporalAdjuster adjuster)
        返回此瞬间的调整副本。

        这将返回一个Instant ，基于此，即时调整。 调整使用指定的调整器策略对象进行。 阅读调整器的文档，了解将进行什么调整。

        该方法的结果是通过调用TemporalAdjuster.adjustInto(Temporal)方法获得的指定调整器通过this作为参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        一个 Instant基于 this进行了调整，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        public Instant with​(TemporalField field,
                    long newValue)
        将指定的字段设置为新值返回此瞬间的副本。

        这将返回一个Instant ，基于此，更改指定字段的值。 如果不可能设置该值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，则在此处执行调整。 支持的字段的行为如下：

        • NANO_OF_SECOND - 返回一个Instant具有指定的纳秒。 第二纪将不变。
        • MICRO_OF_SECOND - 返回一个Instant ， Instant秒替换为指定的微秒乘以1,000。 第二纪将不变。
        • MILLI_OF_SECOND - 返回Instant ，以秒为单位，以秒为单位替换为指定的毫秒数乘以1,000,000。 第二纪将不变。
        • INSTANT_SECONDS - 返回具有指定时代的Instant 。 纳秒将不变。

        在所有情况下，如果新值超出该字段值的有效范围，那么将抛出一个DateTimeException 。

        所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.adjustInto(Temporal, long)传递this作为参数。 在这种情况下，该字段决定是否以及如何调整即时。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        一个 Instant基于 this指定的字段设置，不为null
        异常
        DateTimeException - 如果字段无法设置
        UnsupportedTemporalTypeException - 如果不支持该字段
        ArithmeticException - 如果发生数字溢出

      • truncatedTo

        public Instant truncatedTo​(TemporalUnit unit)
        将此Instant的副本截回到指定的单位。

        截断该瞬间返回原始数据的副本，该字段小于设置为零的指定单位。 这些字段是基于使用UTC偏移量计算的，如toString 。 例如，使用MINUTES单位截断将舍入到最近的分钟，将秒和纳秒设置为零。

        该单位必须有一个duration ，划分为标准日期的长度， 无余数。 这包括所有提供的时间单位在ChronoUnit和DAYS 。 其他单位抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        unit - 截断到的单位，不为null
        结果
        一个 Instant基于这个瞬间截断时间，不为null
        异常
        DateTimeException - 如果单位无效截断
        UnsupportedTemporalTypeException - 如果不支持本机

      • plus

        public Instant plus​(TemporalAmount amountToAdd)
        返回添加指定数量的此瞬间的副本。

        这将返回一个Instant ，基于此，添加了指定的数量。 金额通常为Duration，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.addTo(Temporal)将计算委托给金额对象。 金额实施可以以任何愿望的方式实现添加，但通常可以回调到plus(long, TemporalUnit) 。 请参阅金额执行的文档，以确定是否可以成功添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 Instant基于这个瞬间与添加，而不是null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        public Instant plus​(long amountToAdd,
                    TemporalUnit unit)
        返回添加指定数量的此瞬间的副本。

        这将返回一个Instant ，基于这一个，增加的单位数额。 如果不可能添加金额，因为单位不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoUnit，那么在这里实现添加。 支持的字段的行为如下：

        • NANOS - 返回一个Instant ，其中添加了指定的纳秒数。 这相当于plusNanos(long) 。
        • MICROS - 返回一个Instant ，其中添加了指定的微秒数。 这相当于plusNanos(long) ，数量乘以1,000。
        • MILLIS - 返回指定的毫秒数的Instant 。 这相当于plusNanos(long) ，数额乘以1,000,000。
        • SECONDS - 返回一个Instant ，加上指定的秒数。 这相当于plusSeconds(long) 。
        • MINUTES - 返回指定分钟数的Instant 。 这相当于plusSeconds(long) ，数量乘以60。
        • HOURS - 返回指定加入小时数的Instant 。 这相当于plusSeconds(long) ，金额乘以3600。
        • HALF_DAYS - 返回一个Instant ，加上指定的半天。 相当于plusSeconds(long) ，金额乘以43.00 （12小时）。
        • DAYS - 返回指定加入天数的Instant 。 这相当于plusSeconds(long) ，数额乘以86,400（24小时）。

        所有其他ChronoUnit实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为参数。 在这种情况下，单元确定是否以及如何执行添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 添加到结果中的单位数量可能为负数
        unit - 要添加的单位，不为null
        结果
        一个 Instant基于这个瞬间与指定的量添加，不为null
        异常
        DateTimeException - 如果不能添加
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusSeconds

        public Instant plusSeconds​(long secondsToAdd)
        以指定的持续时间返回此瞬间的副本，以秒为单位。

        此实例是不可变的，不受此方法调用的影响。

        参数
        secondsToAdd - 要添加的秒数，正数或负数
        结果
        一个 Instant基于这个瞬间添加了指定的秒，不为null
        异常
        DateTimeException - 如果结果超过最大或最小时刻
        ArithmeticException - 如果发生数字溢出

      • plusMillis

        public Instant plusMillis​(long millisToAdd)
        以毫秒为单位的指定持续时间返回此瞬间的副本。

        此实例是不可变的，不受此方法调用的影响。

        参数
        millisToAdd - 要添加的毫秒数，正数或负数
        结果
        一个 Instant基于这个瞬间添加了指定的毫秒，不为null
        异常
        DateTimeException - 如果结果超过最大或最小时间
        ArithmeticException - 如果发生数字溢出

      • plusNanos

        public Instant plusNanos​(long nanosToAdd)
        以指定的持续时间返回此瞬间的副本，以纳秒为单位。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanosToAdd - nanosToAdd秒，正或负
        结果
        一个 Instant基于这个瞬间添加了指定的纳秒，不为null
        异常
        DateTimeException - 如果结果超过最大或最小速度
        ArithmeticException - 如果发生数字溢出

      • minus

        public Instant minus​(TemporalAmount amountToSubtract)
        返回此时刻的副本，减去指定的金额。

        这将返回一个Instant ，基于此，减去指定的数量。 金额通常为Duration，但可能是实现TemporalAmount界面的任何其他类型。

        通过调用TemporalAmount.subtractFrom(Temporal)将计算委托给金额对象。 数量执行可以以任何希望的方式实现减法，但通常可以回调到minus(long, TemporalUnit) 。 请参阅数量执行的文档，以确定是否可以成功减去它们。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去量，不为空
        结果
        一个 Instant基于这个瞬间与减法而不是null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        public Instant minus​(long amountToSubtract,
                     TemporalUnit unit)
        返回此时刻的副本，减去指定的金额。

        这将返回一个Instant ，基于这一个，减去的单位数量。 如果不可能减去金额，因为该单位不受支持或出于某种其他原因，则会抛出异常。

        这个方法相当于plus(long, TemporalUnit) ，这个数量是否定的。 请参阅该方法，以了解如何添加，从而减去运算。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 从结果中减去的单位数量可能为负数
        unit - 减去量的单位，不为空
        结果
        一个 Instant基于此瞬间指定的数量减去，不为null
        异常
        DateTimeException - 如果不能进行减法
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minusSeconds

        public Instant minusSeconds​(long secondsToSubtract)
        以秒为单位返回指定持续时间的此瞬间的副本。

        此实例是不可变的，不受此方法调用的影响。

        参数
        secondsToSubtract - 减去正数或负数的秒数
        结果
        一个 Instant基于此瞬间减去指定的秒数，不为空
        异常
        DateTimeException - 如果结果超过最大或最小瞬间
        ArithmeticException - 如果发生数字溢出

      • minusMillis

        public Instant minusMillis​(long millisToSubtract)
        以毫秒为单位的指定持续时间返回此瞬间的副本。

        此实例是不可变的，不受此方法调用的影响。

        参数
        millisToSubtract - 减去正数或负数的毫秒数
        结果
        一个 Instant基于此瞬间减去指定的毫秒，不为null
        异常
        DateTimeException - 如果结果超过最大或最小瞬间
        ArithmeticException - 如果发生数字溢出

      • minusNanos

        public Instant minusNanos​(long nanosToSubtract)
        以纳秒为单位返回指定持续时间的此瞬间的副本。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanosToSubtract - 减去正数或负数的纳秒
        结果
        一个 Instant基于此瞬间减去指定的纳秒，不为空
        异常
        DateTimeException - 如果结果超过最大或最小瞬间
        ArithmeticException - 如果发生数字溢出

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此即时。

        这使用指定的查询策略对象来查询这一瞬间。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的指定查询通过this作为参数。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象具有这个瞬间。

        这将返回与输入相同的可观察类型的时间对象，其瞬间改变为与此相同。

        调整相当于使用Temporal.with(TemporalField, long)两次，通过ChronoField.INSTANT_SECONDS和ChronoField.NANO_OF_SECOND作为字段。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正调用模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisInstant.adjustInto(temporal);
   temporal = temporal.with(thisInstant);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        根据指定单位计算直到另一瞬间的时间量。

        这可以计算一个Instant对象之间的时间量，单个TemporalUnit 。 起点和终点是this和指定的时刻。 如果结束在开始之前，结果将为负数。 计算返回一个整数，表示两个时刻之间完整单位的数量。 所述Temporal传递给此方法被转换为Instant使用from(TemporalAccessor) 。 例如，可以使用startInstant.until(endInstant, SECONDS)计算两个日期之间的startInstant.until(endInstant, SECONDS) 。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, SECONDS);
   amount = SECONDS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        这个计算方法在ChronoUnit中实现 。 单位NANOS ， MICROS ， MILLIS ， SECONDS ， MINUTES ， HOURS ， HALF_DAYS和DAYS的支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，转换为 Instant ，不为空
        unit - 衡量金额的单位，不为空
        结果
        这个瞬间和结束时刻之间的时间量
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 Instant
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • atOffset

        public OffsetDateTime atOffset​(ZoneOffset offset)
        将此瞬间与偏移量组合起来创建一个OffsetDateTime 。

        这将从UTC /格林威治指定的偏移量从此时刻返回OffsetDateTime 。 如果瞬间太大而无法适应偏移日期时间，将抛出异常。

        这个方法相当于OffsetDateTime.ofInstant(this, offset) 。

        参数
        offset - 要组合的偏移量，不为空
        结果
        从该时刻形成的偏移日期时间和指定的偏移量，不为空
        异常
        DateTimeException - 如果结果超出了支持的范围

      • atZone

        public ZonedDateTime atZone​(ZoneId zone)
        将此瞬间与时区相结合，创建一个ZonedDateTime 。

        这将返回一个ZonedDateTime ，从这个时刻在指定的时区形成。 如果瞬间太大，无法进入划定的日期时间，将会抛出异常。

        此方法相当于ZonedDateTime.ofInstant(this, zone) 。

        参数
        zone - 要组合的区域，不为空
        结果
        从这个时刻和指定的区域形成的划分的日期时间，不为null
        异常
        DateTimeException - 如果结果超出支持范围

      • toEpochMilli

        public long toEpochMilli​()
        将此瞬间转换为1970-01-01T00：00：00Z的时期的毫秒数。

        如果这个时刻在时间线上表示一个太远的距离或过去，以适应long毫秒，那么抛出异常。

        如果这个瞬间具有大于毫秒的精度，则转换将丢弃任何超量精度信息，就好像以毫秒为单位的整数除以一百万。

        结果
        自1970-01-01T00：00：00Z以来的毫秒数
        异常
        ArithmeticException - 如果发生数字溢出

      • compareTo

        public int compareTo​(Instant otherInstant)
        将此瞬间与指定的时刻进行比较。

        比较是基于时刻的时间位置。 它与“等于”一致，如Comparable所定义。

        Specified by:
        compareTo在接口 Comparable<Instant>
        参数
        otherInstant - 另一个即时比较，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正
        异常
        NullPointerException - 如果otherInstant为空

      • isAfter

        public boolean isAfter​(Instant otherInstant)
        检查这个瞬间是否在指定的时刻之后。

        比较是基于时刻的时间位置。

        参数
        otherInstant - 另一个即时比较，不为null
        结果
        如果这个瞬间是在指定的时刻之后，则为真
        异常
        NullPointerException - 如果otherInstant为空

      • isBefore

        public boolean isBefore​(Instant otherInstant)
        检查这个时刻是否在指定的时刻之前。

        比较是基于时刻的时间位置。

        参数
        otherInstant - 另一个即时比较，不为null
        结果
        如果这个时刻在指定的时刻之前，则为true
        异常
        NullPointerException - 如果otherInstant为空

      • equals

        public boolean equals​(Object otherInstant)
        检查这个瞬间是否等于指定的时刻。

        比较是基于时刻的时间位置。

        重写：
        equals在 Object
        参数
        otherInstant - 另一个即时，null返回false
        结果
        如果另一个时刻等于这个时刻，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此时刻的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        此瞬间使用ISO-8601表示形式的字符串表示形式。

        所使用的格式与DateTimeFormatter.ISO_INSTANT相同。

        重写：
        toString在 Object
        结果
        此瞬间的ISO-8601表示，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


java.time (Java SE 9 & JDK 9 )

java.time

Classes

  • Clock
  • Duration
  • Instant
  • LocalDate
  • LocalDateTime
  • LocalTime
  • MonthDay
  • OffsetDateTime
  • OffsetTime
  • Period
  • Year
  • YearMonth
  • ZonedDateTime
  • ZoneId
  • ZoneOffset

Enums

  • DayOfWeek
  • Month

Exceptions

  • DateTimeException


java.time (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.time

日期，时间，瞬间和持续时间的主要API。

这里定义的类代表主要的日期时间概念，包括时刻，持续时间，日期，时间，时区和时段。 它们基于ISO日历系统，这是遵循激进的格里高利规则的事实上的世界日历。 所有的类都是不可变的，线程安全的。

每个日期时间实例由API方便地提供的字段组成。 对于较低级别的访问，请参阅java.time.temporal软件包。 每个类都支持打印和解析各种日期和时间。 有关自定义选项，请参阅java.time.format包。

该java.time.chrono包包含日历中立API ChronoLocalDate ， ChronoLocalDateTime ， ChronoZonedDateTime和Era 。 这适用于需要使用本地化日历的应用程序。 建议应用程序在系统边界使用ISO-8601日期和时间类，例如数据库或跨网络。 日历中性API应保留用于与用户的交互。

日期和时间

Instant本质上是一个数字时间戳。 当前Instant可以从Clock检索。 这对于一个时间点的记录和持久性是有用的，并且在过去已经与从System.currentTimeMillis()存储结果相关联。

LocalDate存储一个没有时间的日期。 它存储一个像“2010-12-03”这样的日期，可以用来存储一个生日。

LocalTime存储没有日期的时间。 这样可以储存一个像“11：30”这样的时间，可以用来存储一个开或关的时间。

LocalDateTime存储日期和时间。 这样可以存储像2010-12-03T11：30这样的日期。

ZonedDateTime存储具有时区的日期和时间。 如果您想要考虑到ZoneId （如“欧洲/巴黎”）的日期和时间进行准确计算，这很有用。 在可能的情况下，建议在没有时区的情况下使用更简单的类。 时区的广泛使用往往会增加应用程序的相当大的复杂性。

期限和期限

除了日期和时间之外，API还允许存储期间和持续时间。 A Duration是以纳秒为单位的时间线的简单测量。 A Period以对人类有意义的单位（例如年数或日期）表示一段时间。

附加价值类型

Month自己存储一个月。 这个单独的一个月是独立的，比如“十二月”。

DayOfWeek自己存储一周的一天。 这样就可以隔离一个星期，例如“TUESDAY”。

Year自己存储一年。 这个单独的一年是独立的，比如“2010”。

YearMonth存储一年没有一天或一个时间的年份和月份。 这可以存储一年和一个月，如“2010-12”，可用于信用卡到期。

MonthDay存储一个月，一天没有一年或一个时间。 这可以存储一个月和一个月的日期，例如“ - 12-03”，可以用来存储年度事件，如生日，而不存储年份。

OffsetTime存储与UTC没有日期的时间和偏移量。 这样可以存储像'11：30 + 01：00'的日期。 ZoneOffset的形式是“+01：00”。

OffsetDateTime存储与UTC的日期和时间和偏移量。 这样可以存储像2010-12-03T11：30 + 01：00这样的日期。 这有时在XML消息和其他形式的持久性中找到，但是包含的信息少于全时区。

包装规格

除非另有说明，否则在此包中的任何类或接口中将null参数传递给构造函数或方法将导致抛出NullPointerException 。 Javadoc“@param”定义用于总结空行为。 “ @throws NullPointerException ”没有在每个方法中明确记录。

所有计算应检查数字溢出并抛出ArithmeticException或DateTimeException 。

设计说明（非规范性）

API已被设计为提前拒绝null并清除此行为。 一个关键的例外是任何接受对象并返回布尔值的方法，为了检查或验证，通常会为null返回false。

该API旨在在主要高级API中合理的情况下是类型安全的。 因此，对于日期，时间和日期时间的不同概念，还有偏移和时区的变体，都有单独的类。 这似乎是很多类，但大多数应用程序只能开始五个日期/时间类型。

  • Instant - 时间戳
  • LocalDate - 没有时间的日期，或任何对偏移或时区的引用
  • LocalTime - 没有日期的时间，或任何对偏移量或时区的引用
  • LocalDateTime - 结合日期和时间，但仍没有任何偏移或时区
  • ZonedDateTime - 一个“完整”的日期时间与时区和解决偏离UTC /格林威治

Instant是最接近相当于java.util.Date类。 ZonedDateTime是最接近的等价类java.util.GregorianCalendar 。

如果可能的话，应用程序应该使用LocalDate ， LocalTime和LocalDateTime ，以更好的模型域。 例如，生日应该存储在代码LocalDate 。 请记住，任何使用time-zone （例如“欧洲/巴黎”）的计算增加了相当大的复杂性。 许多应用程序只能使用被写入LocalDate ， LocalTime和Instant ，与在用户界面（UI）层添加的时区。

基于偏移的日期时间类型OffsetTime和OffsetDateTime主要用于网络协议和数据库访问。 例如，大多数数据库不能自动存储像“欧洲/巴黎”这样的时区，但是它们可以存储像“+02：00”这样的偏移量。

还提供了一个迄今为止最重要的子部分，包括类Month ， DayOfWeek ， Year ， YearMonth和MonthDay 。 这些可用于建模更复杂的日期时间概念。 例如， YearMonth可用于表示信用卡到期。

请注意，虽然有大量代表日期不同方面的课程，但在时间的不同方面处理相对较少。 根据类型安全性，其逻辑结论将导致小时，小时 - 秒和小时 - 秒 - 二秒的课程。 虽然在逻辑上是纯粹的，但这不是一个实际的选择，因为日期和时间的组合，课程的数量几乎增加了两倍。 因此， LocalTime用于所有时间精度，零被用于暗示较低的精度。

在完全类型安全性的最终结论之后，也可能会争论在日期时间中每个字段的单独类，例如HourOfDay的类和DayOfMonth的另一个类。 这种方法被尝试，但是在Java语言中过于复杂，缺乏可用性。 周期也会出现类似的问题。 每个期间单位都有一个单独的课程，例如“年”和“分钟”类型。 但是，这会产生很多类和类型转换的问题。 因此，提供的日期 - 时间类型是纯度和实用性之间的妥协。

API方法的表面面积相对较大。 这是通过使用一致的方法前缀来管理的。

  • of - 静态工厂方法
  • parse - 静态工厂方法集中于解析
  • get - 获取某物的价值
  • is - 检查是否有事情
  • with - 不可变的相当于一个设定者
  • plus - 向对象添加金额
  • minus - 从对象中减去金额
  • to - 将此对象转换为另一种类型
  • at - 将此对象与另一个对象组合，如date.atTime(time)

多个日历系统是设计挑战的难题。 第一个原则是大多数用户想要标准的ISO日历系统。 因此，主要类别只有ISO。 第二个原则是，大多数希望使用非ISO日历系统的用户需要用户交互，因此它是一个UI本地化问题。 因此，日期和时间对象应该作为ISO对象在数据模型和永久存储中保存，只能转换为和从本地日历进行显示。 日历系统将分别存储在用户偏好中。

然而，有一些有限的用例，用户认为他们需要在整个应用程序中的任意日历系统中存储和使用日期。 这是由ChronoLocalDate支持，但是在使用该界面的Javadoc之前，请阅读所有相关警告至关重要。 总而言之，需要在多个日历系统之间进行通用互操作的应用程序通常需要以与使用ISO日历的方式完全不同的方式编写，因此大多数应用程序应仅使用ISO并避免使用ChronoLocalDate 。

API也是为了用户可扩展性设计的，因为有很多计算时间的方法。 该field和unit API，通过访问TemporalAccessor和Temporal提供了很大的灵活应用。 此外， TemporalQuery和TemporalAdjuster接口提供日常功能，允许代码阅读接近业务需求：

  LocalDate customerBirthday = customer.loadBirthdayFromDatabase();
   LocalDate today = LocalDate.now();
   if (customerBirthday.equals(today)) {
     LocalDate specialOfferExpiryDate = today.plusWeeks(2).with(next(FRIDAY));
     customer.sendBirthdaySpecialOffer(specialOfferExpiryDate);
   }
从以下版本开始：
1.8
  • 类摘要
    Class 描述
    Clock
    使用时区提供对当前即时，日期和时间的访问的时钟。
    Duration
    基于时间的时间量，如'34.5秒'。
    Instant
    在时间线上的瞬间点。
    LocalDate
    在ISO- 2007-12-03 ，如 2007-12-03 。
    LocalDateTime
    在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
    LocalTime
    在ISO- 10:15:30 ，如 10:15:30 。
    MonthDay
    ISO- --12-03 ，如 --12-03 。
    OffsetDateTime
    在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如 2007-12-03T10:15:30+01:00 。
    OffsetTime
    在ISO- 10:15:30+01:00 UTC /格林威治的时间，如 10:15:30+01:00 。
    Period
    ISO-8601日历系统中的日期时间，例如“2年3个月4天”。
    Year
    一年在ISO- 2007 ，如 2007 。
    YearMonth
    ISO- 2007-12 ，如 2007-12 。
    ZonedDateTime
    ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。
    ZoneId
    一个时区ID，如 Europe/Paris 。
    ZoneOffset
    与格林威治/ UTC的时区偏移量，如 +02:00 。
  • 枚举摘要
    Enum 描述
    DayOfWeek
    星期几，如“星期二”。
    Month
    一个月，如“七月”。
  • 异常摘要
    异常 描述
    DateTimeException
    Exception used to indicate a problem while calculating a date-time.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.time Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.time

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.time.Clock
    • java.time.Duration (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.TemporalAmount)
    • java.time.Instant (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.LocalDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.LocalDateTime (implements java.time.chrono.ChronoLocalDateTime<D>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.LocalTime (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.MonthDay (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.TemporalAccessor, java.time.temporal.TemporalAdjuster)
    • java.time.OffsetDateTime (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.OffsetTime (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.Period (implements java.time.chrono.ChronoPeriod, java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.time.DateTimeException
    • java.time.Year (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.YearMonth (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.ZonedDateTime (implements java.time.chrono.ChronoZonedDateTime<D>, java.io.Serializable, java.time.temporal.Temporal)
    • java.time.ZoneId (implements java.io.Serializable)
      • java.time.ZoneOffset (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.TemporalAccessor, java.time.temporal.TemporalAdjuster)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.time.DayOfWeek (implements java.time.temporal.TemporalAccessor, java.time.temporal.TemporalAdjuster)
      • java.time.Month (implements java.time.temporal.TemporalAccessor, java.time.temporal.TemporalAdjuster)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LocalDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class LocalDate

  • java.lang.Object
    • java.time.LocalDate
  • All Implemented Interfaces:
    Serializable ， Comparable<ChronoLocalDate> ， ChronoLocalDate ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class LocalDate
extends Object
implements Temporal, TemporalAdjuster, ChronoLocalDate, Serializable
    在ISO- 2007-12-03 ，如2007-12-03 。

    LocalDate是一个不可变的日期时间对象，表示日期，通常被视为年月日。 也可以访问其他日期字段，例如日期，星期几和星期。 例如，值“2007年10月2日”可以存储在LocalDate 。

    该类不存储或表示时间或时区。 相反，它是日期的描述，用于生日。 它不能表示时间线上的瞬时，没有附加信息，如偏移或时区。

    ISO-8601日历系统是当今世界绝大多数的现代民用日历系统。 它相当于今天的闰年规则一直适用于日常生活的公历日历系统。 对于今天写的大多数应用，ISO-8601规则是完全合适的。 然而，任何利用历史日期并要求它们准确的应用程序都将发现ISO-8601方法不合适。

    这是一个value-based类; 对LocalDate实例使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预知的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static LocalDate EPOCH
      时代年份 LocalDate ，'1970-01-01'。
      static LocalDate MAX
      最大支持 LocalDate ，'+ 999999999-12-31'。
      static LocalDate MIN
      最低支持 LocalDate ，'- LocalDate '。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象的日期相同。
      LocalDateTime atStartOfDay​()
      将此日期与午夜时间结合 LocalDateTime ，在此日期开始时创建一个 LocalDateTime 。
      ZonedDateTime atStartOfDay​(ZoneId zone)
      根据时区中的规则，在最早的有效时间内从此日期返回划分的日期时间。
      LocalDateTime atTime​(int hour, int minute)
      结合此日期与时间创建一个 LocalDateTime 。
      LocalDateTime atTime​(int hour, int minute, int second)
      结合这个日期与时间创建一个 LocalDateTime 。
      LocalDateTime atTime​(int hour, int minute, int second, int nanoOfSecond)
      结合此日期与时间创建一个 LocalDateTime 。
      LocalDateTime atTime​(LocalTime time)
      结合此日期与时间创建一个 LocalDateTime 。
      OffsetDateTime atTime​(OffsetTime time)
      将此日期与偏移时间相结合以创建 OffsetDateTime 。
      int compareTo​(ChronoLocalDate other)
      将此日期与另一个日期进行比较。
      Stream<LocalDate> datesUntil​(LocalDate endExclusive)
      返回顺序排列的日期流。
      Stream<LocalDate> datesUntil​(LocalDate endExclusive, Period step)
      通过给定的增量步骤返回日期的顺序排序流。
      boolean equals​(Object obj)
      检查这个日期是否等于另一个日期。
      String format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期。
      static LocalDate from​(TemporalAccessor temporal)
      从时间对象获取一个 LocalDate的实例。
      int get​(TemporalField field)
      从此日期获取指定字段的值作为 int 。
      IsoChronology getChronology​()
      获取这个日期的时间顺序，即ISO日历系统。
      int getDayOfMonth​()
      获取月份字段。
      DayOfWeek getDayOfWeek​()
      获取星期几字段，这是一个枚举 DayOfWeek 。
      int getDayOfYear​()
      获得日期字段。
      IsoEra getEra​()
      获得这个时代适用的时代。
      long getLong​(TemporalField field)
      从此日期获取指定字段的值作为 long 。
      Month getMonth​()
      使用 Month枚举获取月份字段。
      int getMonthValue​()
      将月份字段从1到12。
      int getYear​()
      获取年份字段。
      int hashCode​()
      这个日期的哈希码。
      boolean isAfter​(ChronoLocalDate other)
      检查此日期是否在指定日期之后。
      boolean isBefore​(ChronoLocalDate other)
      检查此日期是否在指定日期之前。
      boolean isEqual​(ChronoLocalDate other)
      检查此日期是否等于指定的日期。
      boolean isLeapYear​()
      根据ISO培训日历系统规则，检查年份是否是闰年。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      int lengthOfMonth​()
      返回由此日期表示的月份的长度。
      int lengthOfYear​()
      返回由此日期表示的年份的长度。
      LocalDate minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期的副本，减去指定的金额。
      LocalDate minus​(TemporalAmount amountToSubtract)
      返回此日期的副本，减去指定的金额。
      LocalDate minusDays​(long daysToSubtract)
      返回此 LocalDate的副本，并减去指定的天数。
      LocalDate minusMonths​(long monthsToSubtract)
      返回此 LocalDate的副本，并减去指定的月数。
      LocalDate minusWeeks​(long weeksToSubtract)
      返回此 LocalDate的副本，并 LocalDate指定的周数。
      LocalDate minusYears​(long yearsToSubtract)
      返回此 LocalDate的副本，并减去指定的年数。
      static LocalDate now​()
      从默认时区的系统时钟获取当前日期。
      static LocalDate now​(Clock clock)
      从指定的时钟获取当前日期。
      static LocalDate now​(ZoneId zone)
      从指定时区的系统时钟获取当前日期。
      static LocalDate of​(int year, int month, int dayOfMonth)
      从一年，一个月和一天获得一个 LocalDate的实例。
      static LocalDate of​(int year, Month month, int dayOfMonth)
      从一年，一个月和一天获取 LocalDate的实例。
      static LocalDate ofEpochDay​(long epochDay)
      从纪元日数获得 LocalDate的实例。
      static LocalDate ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalDate的实例。
      static LocalDate ofYearDay​(int year, int dayOfYear)
      从一年和一年的一年中获得 LocalDate的实例。
      static LocalDate parse​(CharSequence text)
      从 2007-12-03等文本字符串获取 LocalDate的实例。
      static LocalDate parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 LocalDate的实例。
      LocalDate plus​(long amountToAdd, TemporalUnit unit)
      返回此日期的副本，并添加指定的金额。
      LocalDate plus​(TemporalAmount amountToAdd)
      返回此日期的副本，并添加指定的金额。
      LocalDate plusDays​(long daysToAdd)
      返回添加了指定天数的 LocalDate的副本。
      LocalDate plusMonths​(long monthsToAdd)
      返回此 LocalDate的副本，并附加指定的月数。
      LocalDate plusWeeks​(long weeksToAdd)
      以指定的周数返回此 LocalDate的副本。
      LocalDate plusYears​(long yearsToAdd)
      以指定的年数返回此 LocalDate的副本。
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此日期。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      long toEpochDay​()
      将此日期转换为大纪元日。
      long toEpochSecond​(LocalTime time, ZoneOffset offset)
      将此 LocalDate转换为从1970-01-01T00：00：00Z开始的秒数。
      String toString​()
      将此日期输出为 String ，如 2007-12-03 。
      Period until​(ChronoLocalDate endDateExclusive)
      将此日期和其他日期之间的期间计算为 Period 。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。
      LocalDate with​(TemporalAdjuster adjuster)
      返回此日期的调整副本。
      LocalDate with​(TemporalField field, long newValue)
      返回此日期的副本，并将指定的字段设置为新值。
      LocalDate withDayOfMonth​(int dayOfMonth)
      返回这个 LocalDate的副本，并更改日期。
      LocalDate withDayOfYear​(int dayOfYear)
      返回此 LocalDate更改的 LocalDate的副本。
      LocalDate withMonth​(int month)
      返回这个 LocalDate的副本，并更改月份。
      LocalDate withYear​(int year)
      返回该 LocalDate的副本。

      • Methods inherited from interface java.time.chrono.ChronoLocalDate

        timeLineOrder

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN

        public static final LocalDate MIN
        最低支持LocalDate '。 应用程序可以将其用作“过去”的日期。

      • MAX

        public static final LocalDate MAX
        最大支持LocalDate ，'+ 999999999-12-31'。 应用程序可以将其用作“远未来”的日期。

      • EPOCH

        public static final LocalDate EPOCH
        时代年份 LocalDate ，'1970-01-01'。

    • 方法详细信息

      • now

        public static LocalDate now​()
        从默认时区的系统时钟获取当前日期。

        这将查询默认时区中的system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前日期使用系统时钟和默认时区，不为空

      • now

        public static LocalDate now​(ZoneId zone)
        从指定时区的系统时钟获取当前日期。

        这将查询system clock以获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前日期使用系统时钟，不为空

      • now

        public static LocalDate now​(Clock clock)
        从指定的时钟获取当前日期。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 备用时钟可能使用dependency injection引入。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前日期，不为null

      • of

        public static LocalDate of​(int year,
                           Month month,
                           int dayOfMonth)
        从一年，一个月和一天获得LocalDate的实例。

        这将返回一个LocalDate与指定的年，月和日。 该日期必须在年和月中有效，否则将抛出异常。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 代表的月份，不为null
        dayOfMonth - 代表从1到31的月份
        结果
        本地日期，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者月的日期对于月份无效

      • of

        public static LocalDate of​(int year,
                           int month,
                           int dayOfMonth)
        从一年，一月和一天获得LocalDate的实例。

        这将返回一个LocalDate与指定的年，月和日。 该日期必须在年和月中有效，否则将抛出异常。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 从1月1日至12日（12月）的月份，
        dayOfMonth - 代表从1到31的月份
        结果
        本地日期，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者月中的日期对于月份无效

      • ofYearDay

        public static LocalDate ofYearDay​(int year,
                                  int dayOfYear)
        从一年和一年的一年中获得LocalDate的实例。

        这将返回具有指定年份和日期的LocalDate 。 年份必须在一年中有效，否则将被抛出异常。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        dayOfYear - 代表从1到366的日期
        结果
        本地日期，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者如果当年的日期无效

      • ofInstant

        public static LocalDate ofInstant​(Instant instant,
                                  ZoneId zone)
        从Instant和区域ID获取LocalDate的实例。

        这将根据指定的时间创建本地日期。 首先，使用区域ID和时刻获取UTC /格林威治的偏移量，这很简单，因为每个时刻只有一个有效的偏移量。 然后，使用即时和偏移量来计算本地日期。

        参数
        instant - 即时创建日期，不为null
        zone - 时区，可能是偏移，不为空
        结果
        本地日期，不为空
        异常
        DateTimeException - 如果结果超出了支持的范围
        从以下版本开始：
        9

      • ofEpochDay

        public static LocalDate ofEpochDay​(long epochDay)
        从纪元日数获取LocalDate的实例。

        这将返回一个LocalDate与指定的时代。 EPOCH_DAY是第0天为1970-01-01的简单递增计数。 负数表示较早的日子。

        参数
        epochDay - 根据时代1970-01-01转换的大纪元日
        结果
        本地日期，不为空
        异常
        DateTimeException - 如果纪元日超过支持的日期范围

      • from

        public static LocalDate from​(TemporalAccessor temporal)
        从时间对象获取LocalDate的实例。

        这将基于指定的时间获取本地日期。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为LocalDate的实例。

        转换使用TemporalQueries.localDate()查询，它依赖于提取EPOCH_DAY字段。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考LocalDate::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        本地日期，不为空
        异常
        DateTimeException - 如果无法转换为 LocalDate
        另请参见：
        Chronology.date(TemporalAccessor)

      • parse

        public static LocalDate parse​(CharSequence text)
        从2007-12-03等文本字符串获取LocalDate的实例。

        字符串必须表示有效的日期，并使用DateTimeFormatter.ISO_LOCAL_DATE进行解析。

        参数
        text - 要解析的文本，如“2007-12-03”，不为空
        结果
        解析的本地日期，不为null
        异常
        DateTimeParseException - 如果文本无法解析

      • parse

        public static LocalDate parse​(CharSequence text,
                              DateTimeFormatter formatter)
        使用特定的格式化程序从文本字符串获取LocalDate的实例。

        使用格式化程序解析文本，返回日期。

        参数
        text - 要解析的文本，不为空
        formatter - 要使用的格式化程序，不为空
        结果
        解析的本地日期，不为null
        异常
        DateTimeParseException - 如果文本无法解析

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的日期。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 支持的字段有：

        • DAY_OF_WEEK
        • ALIGNED_DAY_OF_WEEK_IN_MONTH
        • ALIGNED_DAY_OF_WEEK_IN_YEAR
        • DAY_OF_MONTH
        • DAY_OF_YEAR
        • EPOCH_DAY
        • ALIGNED_WEEK_OF_MONTH
        • ALIGNED_WEEK_OF_YEAR
        • MONTH_OF_YEAR
        • PROLEPTIC_MONTH
        • YEAR_OF_ERA
        • YEAR
        • ERA
        所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 ChronoLocalDate
        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果在此日期支持该字段，则为true，否则为false

      • isSupported

        public boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定单位是否可以添加到该日期或从该日期减去。 如果是false，那么调用plus(long, TemporalUnit)和minus方法就会抛出异常。

        如果单位是ChronoUnit，那么查询是在这里实现的。 支持的单位是：

        • DAYS
        • WEEKS
        • MONTHS
        • YEARS
        • DECADES
        • CENTURIES
        • MILLENNIA
        • ERAS
        所有其他ChronoUnit实例将返回false。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 ChronoLocalDate
        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 此日期用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例都将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持

      • get

        public int get​(TemporalField field)
        从此日期获取指定字段的值作为int 。

        此日期查询指定字段的值。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回基于此日期的有效值，除了EPOCH_DAY和PROLEPTIC_MONTH ，这些值太大，不符合int并抛出UnsupportedTemporalTypeException 。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从此日期获取指定字段的值作为long 。

        此日期查询指定字段的值。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，那么在这里实现查询。 supported fields将根据此日期返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • getChronology

        public IsoChronology getChronology​()
        获取这个日期的时间顺序，即ISO日历系统。

        Chronology代表正在使用的日历系统。 ISO-8601日历系统是当今世界绝大多数的现代民用日历系统。 它相当于今天的闰年规则一直适用于日常生活的公历日历系统。

        Specified by:
        getChronology在接口 ChronoLocalDate
        结果
        ISO年表，不为空

      • getEra

        public IsoEra getEra​()
        获得这个时代适用的时代。

        官方的ISO-8601标准没有定义时间，但是IsoChronology没有。 它从一年前开始定义了两个时代的“CE”，从零开始定义了“公元前”。 由于Julian-Gregorian割接之前的日期与历史不一致，“BCE”和“CE”之间的切换也不与通常使用“BC”和“AD”的常用的时间对齐。

        该类的用户通常应该忽略此方法，因为它主要是为了履行需要支持日文日历系统的ChronoLocalDate合同。

        Specified by:
        getEra在接口 ChronoLocalDate
        结果
        此日期适用的IsoEra不为空

      • getYear

        public int getYear​()
        获取年份字段。

        此方法返回一年的原始值int 。

        通过这种方法返回的年份是按照get(YEAR) 。 要获得年代，请使用get(YEAR_OF_ERA) 。

        结果
        年，从MIN_YEAR到MAX_YEAR

      • getMonthValue

        public int getMonthValue​()
        将月份字段从1到12。

        此方法将一个月作为int从1到12返回。如果通过调用getMonth()使用枚举Month，应用程序代码通常会更加清晰。

        结果
        从1到12年的月份
        另请参见：
        getMonth()

      • getMonth

        public Month getMonth​()
        使用Month枚举获取月份字段。

        此方法返回本月的枚举Month 。 这避免了int值意味着什么的混乱。 如果您需要访问原始的int值，那么枚举将提供int value 。

        结果
        月份，不为零
        另请参见：
        getMonthValue()

      • getDayOfMonth

        public int getDayOfMonth​()
        获取月份字段。

        此方法返回int的原始值int值。

        结果
        从1到31日

      • getDayOfYear

        public int getDayOfYear​()
        获得日期字段。

        该方法返回原始值int值。

        结果
        一年中，从1到365，或闰年366

      • getDayOfWeek

        public DayOfWeek getDayOfWeek​()
        获取星期几字段，这是一个枚举DayOfWeek 。

        此方法返回星期几的枚举DayOfWeek 。 这避免了int值意味着什么的混乱。 如果您需要访问原始的int值，则枚举将提供int value 。

        附加信息可以从DayOfWeek获得。 这包括值的文本名称。

        结果
        星期几不为零

      • isLeapYear

        public boolean isLeapYear​()
        根据ISO培训日历系统规则，检查年份是否是闰年。

        这种方法在整个时间线上应用目前的闰年规则。 一般来说，一年是一个闰年，如果没有余数可以被四分割。 但是，除了100岁之外，年份可以被分割为100岁，除了年龄可以被400除外。

        例如，1904年是一个闰年，可以被4整除。1900年不是一个闰年，因为它可以被100整除，然而2000年是一个闰年，因为它可以被400除数。

        计算是应激的 - 将相同的规则应用到远未来很远的地方。 这在历史上是不准确的，但对于ISO-8601标准是正确的。

        Specified by:
        isLeapYear在接口 ChronoLocalDate
        结果
        如果一年是飞跃，否则为假

      • lengthOfMonth

        public int lengthOfMonth​()
        返回由此日期表示的月份的长度。

        这将以天为单位返回月份的长度。 例如，1月份的日期将返回31。

        Specified by:
        lengthOfMonth在接口 ChronoLocalDate
        结果
        月的长度以天为单位

      • lengthOfYear

        public int lengthOfYear​()
        返回由此日期表示的年份的长度。

        这将返回年份的长度，以天数为365或366。

        Specified by:
        lengthOfYear在接口 ChronoLocalDate
        结果
        366如果一年是飞跃，否则为365

      • with

        public LocalDate with​(TemporalAdjuster adjuster)
        返回此日期的调整副本。

        这将返回一个LocalDate ，基于这一个，调整日期。 调整使用指定的调整器策略对象进行。 阅读调整器的文档，了解将进行什么调整。

        一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。

        TemporalAdjusters提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 关键的日期时间课程还实现了TemporalAdjuster界面，如Month和MonthDay 。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        例如这个代码在7月的最后一天返回一个日期：

          import static java.time.Month.*;
  import static java.time.temporal.TemporalAdjusters.*;

  result = localDate.with(JULY).with(lastDayOfMonth());

        该方法的结果是通过调用TemporalAdjuster.adjustInto(Temporal)方法，通过this作为参数的指定调整器。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        一个 LocalDate基于 this进行了调整，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        public LocalDate with​(TemporalField field,
                      long newValue)
        返回此日期的副本，并将指定的字段设置为新值。

        这将返回一个LocalDate ，基于此，更改指定字段的值。 这可以用于更改任何支持的字段，例如年，月或月。 如果不可能设置该值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        在某些情况下，更改指定字段可能会导致生成日期无效，例如将月份从1月31日更改为2月将导致日期无效。 在这种情况下，该领域负责解决日期。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        如果该字段是ChronoField，则在此处执行调整。 支持的字段的行为如下：

        • DAY_OF_WEEK - 返回一个LocalDate与指定的星期几。 日期在周一至周日的边界内向前或向后调整至6天。
        • ALIGNED_DAY_OF_WEEK_IN_MONTH - 返回一个LocalDate与指定对齐的星期几。 日期被调整为指定的基于月份的对齐日 - 每周。 统计周数将被计算在一个月的第一个星期从该月的第一天开始。 这可能导致日期在下个月被移动到6天。
        • ALIGNED_DAY_OF_WEEK_IN_YEAR - 返回一个LocalDate与指定的对齐日 - 星期。 日期被调整到指定的基于年的对齐的星期几。 统计周数，使得某一年的第一周从那一年的第一天开始。 这可能导致日期在第二年被移动到6天。
        • DAY_OF_MONTH - 返回指定日期的LocalDate 。 月和年将不变。 如果每月的日期无效，则会抛出DateTimeException 。
        • DAY_OF_YEAR - 返回指定日期的LocalDate 。 年将不变。 如果一年中的日期无效，则抛出一个DateTimeException 。
        • EPOCH_DAY - 返回一个LocalDate与指定的时代。 这完全取代了日期，相当于ofEpochDay(long) 。
        • ALIGNED_WEEK_OF_MONTH - 返回指定对齐的月份的LocalDate 。 统计周数将被计算在一个月的第一个星期从该月的第一天开始。 此调整将整周的日期移动到与指定周相匹配。 结果将与此日期相同。 这可能导致日期被移动到下个月。
        • ALIGNED_WEEK_OF_YEAR - 返回一个LocalDate与指定的对齐的一周中的一年。 统计周数，使得某一年的第一周从那一年的第一天开始。 此调整将整周的日期移动到与指定周相匹配。 结果将与此日期相同。 这可能导致日期移至下一年。
        • MONTH_OF_YEAR - 返回指定月份的LocalDate 。 年将不变。 除非新的月份和年份都无效，否则日期也将保持不变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。
        • PROLEPTIC_MONTH - 返回一个LocalDate与指定的LocalDate 。 除非新月和年份无效，否则日期不变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。
        • YEAR_OF_ERA - 返回具有特定年龄的LocalDate 。 时代和月份将保持不变。 除非新的月份和年份都无效，否则日期也将保持不变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。
        • YEAR - 返回指定年份的LocalDate 。 这个月不变。 除非新的月份和年份都无效，否则日期也将保持不变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。
        • ERA - 返回指定时代的LocalDate 。 年份和月份将保持不变。 除非新的月份和年份都无效，否则日期也将保持不变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。

        在所有情况下，如果新值超出该字段值的有效范围，那么将抛出一个DateTimeException 。

        所有其他ChronoField实例都会抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.adjustInto(Temporal, long)传递this作为参数。 在这种情况下，该字段决定是否以及如何调整即时。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        一个 LocalDate基于 this与指定的字段集，不为null
        异常
        DateTimeException - 如果该字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • withYear

        public LocalDate withYear​(int year)
        返回该LocalDate的副本。

        如果一年中的日期无效，它将被更改为该月的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        year - 设置结果的年份，从MIN_YEAR到MAX_YEAR
        结果
        一个 LocalDate基于这个日期与请求的年份，不为null
        异常
        DateTimeException - 如果年值无效

      • withMonth

        public LocalDate withMonth​(int month)
        返回该LocalDate的副本。

        如果一年中的日期无效，它将被更改为该月的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        month - 从1月（1月）到12月（12月）的结果中，
        结果
        一个 LocalDate基于这个日期与请求的月份，不为null
        异常
        DateTimeException - 如果月份值无效

      • withDayOfMonth

        public LocalDate withDayOfMonth​(int dayOfMonth)
        返回此LocalDate的副本，并更改日期。

        如果生成的日期无效，则抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        dayOfMonth - 在结果中设置的月份，从1到28-31
        结果
        一个 LocalDate基于此日期与请求的日期，不为null
        异常
        DateTimeException - 如果月日的价值无效，或者月的月日无效的月份

      • withDayOfYear

        public LocalDate withDayOfYear​(int dayOfYear)
        返回此LocalDate更改的LocalDate的副本。

        如果生成的日期无效，则抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        dayOfYear - 设定结果的日期，从1到365-366
        结果
        一个 LocalDate基于这个日期与请求的一天，不为null
        异常
        DateTimeException - 如果日期年值无效，或者如果当年的日期无效

      • plus

        public LocalDate plus​(TemporalAmount amountToAdd)
        返回此日期的副本，并添加指定的金额。

        这将返回一个LocalDate ，基于此，添加指定的数量。 金额通常为Period，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.addTo(Temporal)将计算委托给金额对象。 数量执行可以以任何方式实现添加，但是它通常会回调到plus(long, TemporalUnit) 。 请参阅金额执行的文档，以确定是否可以成功添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 LocalDate基于这个日期与添加，而不是null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        public LocalDate plus​(long amountToAdd,
                      TemporalUnit unit)
        返回此日期的副本，并添加指定的金额。

        这将返回一个LocalDate ，基于此，以添加的单位数量。 如果不可能添加金额，因为单位不受支持或出于某种其他原因，则抛出异常。

        在某些情况下，添加金额会导致结果日期无效。 例如，在1月31日之前添加一个月将导致2月31日。 在这种情况下，单位负责解决日期。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        如果该字段是ChronoUnit，那么在这里实现添加。 支持的字段的行为如下：

        • DAYS - 返回指定加入天数的LocalDate 。 这相当于plusDays(long) 。
        • WEEKS - 返回一个LocalDate ，添加了指定的周数。 这相当于plusWeeks(long)，并使用了7天的一周。
        • MONTHS - 返回一个LocalDate ，加上指定的月数。 这相当于plusMonths(long) 。 除非新月和年份无效，否则月份将不会改变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。
        • YEARS - 返回一个LocalDate了指定年数的LocalDate 。 这相当于plusYears(long) 。 除非新月和年份无效，否则月份将不会改变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。
        • DECADES - 返回一个LocalDate ，加上指定的几十年。 这相当于拨打plusYears(long) ，金额乘以10.除非新月和年份无效，否则日期将不变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。
        • CENTURIES - 返回一个LocalDate ，附加了几百年的指定数量。 这相当于拨打plusYears(long) ，金额乘以100.除非新月和年份无效，否则日期将不变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。
        • MILLENNIA - 返回一个LocalDate ，加上指定的几千年。 这相当于拨打plusYears(long) ，数量乘以1,000。 除非新月和年份无效，否则月份将不会改变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。
        • ERAS - 返回一个LocalDate ，其中添加了指定的时间。 只支持两个时间，所以数量必须是1，零或者减1。 如果金额不是零，那么这个年份就会改变，使得年龄不变。 除非新月和年份无效，否则月份将不会改变。 在这种情况下，每月的月份将被调整为新的月份和年份的最大有效值。

        所有其他ChronoUnit实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为参数。 在这种情况下，单元确定是否以及如何执行添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 添加到结果中的单位数量可能为负数
        unit - 要添加的单位，不为null
        结果
        一个 LocalDate基于此日期与指定的数量添加，不为null
        异常
        DateTimeException - 如果不能添加
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusYears

        public LocalDate plusYears​(long yearsToAdd)
        返回添加了指定年数的LocalDate的副本。

        该方法通过三个步骤将指定的数量添加到年份字段：

        1. 将输入年份添加到年份字段
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2008-02-29（闰年）加上一年将导致无效日期2009-02-29（标准年）。 而不是返回无效结果，而是选择2009-02-28的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        yearsToAdd - 多年来补充，可能是负数
        结果
        一个 LocalDate基于这个日期与添加的年份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusMonths

        public LocalDate plusMonths​(long monthsToAdd)
        返回此LocalDate的副本，并附加指定的月数。

        此方法通过三个步骤将指定的数量添加到月份字段：

        1. 将输入的月份添加到月份字段
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2007-03-31加上一个月将导致无效日期2007-04-31。 而不是返回无效结果，而是选择2007-04-30的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        monthsToAdd - 要添加的月份，可能为负数
        结果
        一个 LocalDate基于这个日期与添加的月份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusWeeks

        public LocalDate plusWeeks​(long weeksToAdd)
        返回此LocalDate的副本，并附加指定的星期数。

        该方法将指定的数量以周为单位，根据需要增加月份和年份字段的日期字段，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2008-12-31加上一周将导致2009-01-07。

        此实例是不可变的，不受此方法调用的影响。

        参数
        weeksToAdd - 要添加的星期可能为负数
        结果
        一个 LocalDate基于这个日期与周添加，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusDays

        public LocalDate plusDays​(long daysToAdd)
        以指定的天数返回此LocalDate的副本。

        此方法将指定的金额添加到天数字段中，根据需要增加月份和年份字段，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2008-12-31加上一天会导致2009-01-01。

        此实例是不可变的，不受此方法调用的影响。

        参数
        daysToAdd - 添加的日子可能为负数
        结果
        一个 LocalDate基于这个日期与添加的日子，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minus

        public LocalDate minus​(TemporalAmount amountToSubtract)
        返回此日期的副本，减去指定的金额。

        这将返回一个LocalDate ，基于此，减去指定的数量。 金额通常为Period，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.subtractFrom(Temporal)将计算委托给金额对象。 数量执行可以任何方式自由地执行减法，但是它通常会回调到minus(long, TemporalUnit) 。 请参阅数量执行的文档，以确定是否可以成功减去它们。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去量，不为空
        结果
        一个 LocalDate基于这个日期与减法而不是null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        public LocalDate minus​(long amountToSubtract,
                       TemporalUnit unit)
        返回此日期的副本，减去指定的金额。

        这将返回一个LocalDate ，基于这一个，以减少的单位数量。 如果不可能减去金额，因为该单位不受支持或出于某种其他原因，则会抛出异常。

        该方法相当于plus(long, TemporalUnit) ，数量被否定。 请参阅该方法，以了解如何添加，从而减去运算。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract
        unit - 减去量的单位，不为空
        结果
        一个 LocalDate基于此日期减去指定的数量，不为null
        异常
        DateTimeException - 如果不能进行减法
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minusYears

        public LocalDate minusYears​(long yearsToSubtract)
        返回此LocalDate的副本，并减去指定的年数。

        该方法从三个步骤中减去指定的数量：

        1. 从年度字段减去输入年数
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2008-02-29（闰年）减去一年将导致无效日期2007-02-29（标准年）。 而不是返回无效结果，而是选择2007-02-28的该月份的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        yearsToSubtract - 减去年份，可能为负数
        结果
        一个 LocalDate基于这个日期减去，不是null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusMonths

        public LocalDate minusMonths​(long monthsToSubtract)
        返回此LocalDate的副本，并减去指定的月数。

        该方法从以下三个步骤中减去月份字段中指定的数量：

        1. 从月份字段减去输入月份
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2007-03-31减去一个月将导致无效日期2007-02-31。 而不是返回无效结果，而是选择2007-02-28的该月份的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        monthsToSubtract - 减去的月份可能为负数
        结果
        一个 LocalDate基于此日期与减去的月份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusWeeks

        public LocalDate minusWeeks​(long weeksToSubtract)
        返回此LocalDate的副本，并减去指定的周数。

        该方法从必要的日期字段减去月和年字段中减去指定的数量，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2009-01-07减去一周将导致2008-12-31。

        此实例是不可变的，不受此方法调用的影响。

        参数
        weeksToSubtract - 减去的星期可能为负数
        结果
        一个 LocalDate基于这个日期与减去的星期，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusDays

        public LocalDate minusDays​(long daysToSubtract)
        返回此LocalDate的副本，并减去指定的天数。

        该方法根据需要减去月份和年份字段的日期字段减去指定的金额，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2009-01-01减去一天会导致2008-12-31。

        此实例是不可变的，不受此方法调用的影响。

        参数
        daysToSubtract - 减去的日子可能是负数
        结果
        一个 LocalDate基于这个日期减去，而不是null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此日期。

        这使用指定的查询策略对象查询此日期。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的指定查询通过this作为参数。

        Specified by:
        query在接口 ChronoLocalDate
        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象与此对象的日期相同。

        这返回与日期改变为与之相同的输入的相同可观察类型的时间对象。

        该调整是相当于使用Temporal.with(TemporalField, long)通过ChronoField.EPOCH_DAY作为字段。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisLocalDate.adjustInto(temporal);
   temporal = temporal.with(thisLocalDate);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 ChronoLocalDate
        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        根据指定的单位计算直到另一个日期的时间量。

        这将计算一个LocalDate对象之间的时间量，单个TemporalUnit 。 起点和终点为this和指定日期。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为LocalDate使用from(TemporalAccessor) 。 例如，可以使用startDate.until(endDate, DAYS)计算两个日期之间的天startDate.until(endDate, DAYS) 。

        计算返回一个整数，表示两个日期之间的完整单位数。 例如，2012-06-15至2012-08-14之间的月数将只有一个月，因为是两个月的一天。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        该方法的计算用于ChronoUnit 。 单位DAYS ， WEEKS ， MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS的支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 ChronoLocalDate
        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，转换为 LocalDate ，不为空
        unit - 衡量金额的单位，不为空
        结果
        此日期与结束日期之间的时间
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 LocalDate
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • until

        public Period until​(ChronoLocalDate endDateExclusive)
        将此日期和另一个日期之间的期间计算为Period 。

        这将计算两个日期之间的年份，月份和日期之间的期间。 起点和终点是this和指定的日期。 如果结束在开始之前，结果将为负数。 每年，每月的负号将相同。

        使用ISO日历系统进行计算。 如有必要，输入日期将转换为ISO。

        包含开始日期，但结束日期不是。 通过删除完整的月份计算该期间，然后计算剩余天数，进行调整，以确保两者都具有相同的符号。 然后根据12个月的时间将月数标准化为数年和数月。 如果结束日期的月份大于或等于开始的日期，则一个月被认为是完整的。 例如，从2010-01-15到2011-03-18是“1年，2个月和3天”。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用Period.between(LocalDate, LocalDate) ：

          // these two lines are equivalent
   period = start.until(end);
   period = Period.between(start, end);
        应该根据这种做法进行选择，使代码更易读。
        Specified by:
        until在接口 ChronoLocalDate
        参数
        endDateExclusive - 结束日期，排他，可能在任何年代，不为空
        结果
        此日期与结束日期之间的期间不为空

      • datesUntil

        public Stream<LocalDate> datesUntil​(LocalDate endExclusive)
        返回顺序排列的日期流。 返回的流从此日期开始（包括），并以1天的增量步长进入endExclusive （排他）。

        此方法相当于datesUntil(endExclusive, Period.ofDays(1)) 。

        参数
        endExclusive - 结束日期，排他，不为空
        结果
        一个序列 Stream的范围为 LocalDate值
        异常
        IllegalArgumentException - 如果结束日期在此日期之前
        从以下版本开始：
        9

      • datesUntil

        public Stream<LocalDate> datesUntil​(LocalDate endExclusive,
                                    Period step)
        通过给定的增量步骤返回日期的顺序排序流。 返回的流从此日期开始（包括），并转到endExclusive （排他）。

        流中出现的第n个日期等于this.plus(step.multipliedBy(n)) （但步进乘法的结果永远不会溢出）。 例如，如果这个日期是2015-01-31 ，结束日期是2015-05-01和步骤为1个月，然后流包含2015-01-31 ， 2015-02-28 ， 2015-03-31 ，和2015-04-30 。

        参数
        endExclusive - 结束日期，排他，不为null
        step - 代表步骤的非零，非负 Period 。
        结果
        一个序列 Stream的范围为 LocalDate值
        异常
        IllegalArgumentException - 如果步数为零，或 step.getDays()和 step.toTotalMonths()具有相反的符号，或结束日期在此日期之前，步骤为正，或结束日期为此日期之后，步骤为负
        从以下版本开始：
        9

      • format

        public String format​(DateTimeFormatter formatter)
        使用指定的格式化程序格式化此日期。

        此日期将传递给格式化程序以生成一个字符串。

        Specified by:
        format在接口 ChronoLocalDate
        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的日期字符串，不为null
        异常
        DateTimeException - 打印过程中是否发生错误

      • atTime

        public LocalDateTime atTime​(LocalTime time)
        结合这个日期与时间创建一个LocalDateTime 。

        这将在指定的时间返回从此日期形成的LocalDateTime 。 日期和时间的所有可能的组合都是有效的。

        Specified by:
        atTime在接口 ChronoLocalDate
        参数
        time - 结合的时间，不为null
        结果
        从该日期到指定时间形成的本地日期时间，不为空

      • atTime

        public LocalDateTime atTime​(int hour,
                            int minute)
        结合这个日期与时间创建一个LocalDateTime 。

        这将返回一个从这个日期形成的LocalDateTime在指定的小时和分钟。 秒和纳秒场将被设置为零。 单个时间字段必须在其有效范围内。 日期和时间的所有可能的组合都是有效的。

        参数
        hour - 从0到23的使用时间
        minute - 从0到59使用的小时
        结果
        从该日期到指定时间形成的本地日期时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围

      • atTime

        public LocalDateTime atTime​(int hour,
                            int minute,
                            int second)
        结合此日期与时间创建一个LocalDateTime 。

        这将返回一个LocalDateTime从这个日期形成的指定的小时，分钟和秒。 纳秒场将被设置为零。 单个时间字段必须在其有效范围内。 日期和时间的所有可能的组合都是有效的。

        参数
        hour - 从0到23使用的小时
        minute - 从0到59使用的小时
        second - 从0到59的秒表示
        结果
        从该日期到指定时间形成的本地日期时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围

      • atTime

        public LocalDateTime atTime​(int hour,
                            int minute,
                            int second,
                            int nanoOfSecond)
        结合此日期与时间创建一个LocalDateTime 。

        这将返回一个从这个日期形成的LocalDateTime指定的小时，分钟，秒和纳秒。 单个时间字段必须在其有效范围内。 日期和时间的所有可能的组合都是有效的。

        参数
        hour - 从0到23的使用小时
        minute - 使用小时，从0到59
        second - 从0到59的秒表示
        nanoOfSecond - 表示从0到999,999,999的纳秒
        结果
        从该日期到指定时间形成的本地日期时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围

      • atTime

        public OffsetDateTime atTime​(OffsetTime time)
        将此日期与偏移时间相结合以创建OffsetDateTime 。

        这将在指定的时间返回从此日期形成的OffsetDateTime 。 日期和时间的所有可能的组合都是有效的。

        参数
        time - 结合的时间，不为null
        结果
        从该日期和指定时间形成的偏移日期时间，不为空

      • atStartOfDay

        public LocalDateTime atStartOfDay​()
        将此日期与午夜时间相结合，以便在此日期开始时创建一个LocalDateTime 。

        这将在此日期开始之前的午夜00:00之间返回一个LocalDateTime 。

        结果
        本日期开始的午夜的当地日期时间不为空

      • atStartOfDay

        public ZonedDateTime atStartOfDay​(ZoneId zone)
        根据时区中的规则，在最早的有效时间内从此日期返回划分的日期时间。

        时区规则（如夏令时）意味着不是每个本地日期时间对指定的区域都有效，因此本地日期时间可能不是午夜。

        在大多数情况下，本地日期时间只有一个有效的偏移量。 在重叠的情况下，存在两个有效的偏移量，并且使用较早的一个，对应于该日期的午夜的第一次出现。 在差距的情况下，分区的日期时间将代表差距之后的时刻。

        如果区域ID为ZoneOffset ，则结果总是有一个午夜时间。

        要在给定的时区内转换特定时间，请拨打atTime(LocalTime)，后跟LocalDateTime.atZone(ZoneId) 。

        参数
        zone - 要使用的区域ID，不为空
        结果
        从该日期形成的划区日期时间和区域的最早有效时间，不为空

      • toEpochDay

        public long toEpochDay​()
        描述从接口ChronoLocalDate复制
        将此日期转换为大纪元日。

        Epoch Day count是第0天为1970-01-01（ISO）的简单递增计数。 这个定义对于所有的年表都是一样的，可以进行转换。

        此默认实现查询EPOCH_DAY字段。

        Specified by:
        toEpochDay在接口 ChronoLocalDate
        结果
        大纪元日等于这个日期

      • toEpochSecond

        public long toEpochSecond​(LocalTime time,
                          ZoneOffset offset)
        将此LocalDate转换为1970-01-01T00：00：00Z的时代以来的秒数。

        这将此本地日期与指定的时间和偏移量相结合，以计算从1970-01-01T00：00：00Z开始的秒数。 时代之后的时代的实体是积极的，较早的是负的。

        参数
        time - 当地时间，不为空
        offset - 区域偏移，不为空
        结果
        从1970-01-01T00：00：00Z开始的秒数可能为负数
        从以下版本开始：
        9

      • compareTo

        public int compareTo​(ChronoLocalDate other)
        将此日期与另一个日期进行比较。

        比较主要是从最早到最晚的日期。 它与“等于”一致，如Comparable所定义。

        如果所有被比较的日期都是LocalDate实例，则比较将完全基于日期。 如果一些比较的日期是不同的年表，那么年龄也被考虑，见ChronoLocalDate.compareTo(java.time.chrono.ChronoLocalDate) 。

        Specified by:
        compareTo在接口 ChronoLocalDate
        Specified by:
        compareTo在接口 Comparable<ChronoLocalDate>
        参数
        other - 与之比较的其他日期，不为空
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        public boolean isAfter​(ChronoLocalDate other)
        检查此日期是否在指定日期之后。

        这将检查这个日期是否表示在另一个日期之后的本地时间线上的一个点。

          LocalDate a = LocalDate.of(2012, 6, 30);
   LocalDate b = LocalDate.of(2012, 7, 1);
   a.isAfter(b) == false
   a.isAfter(a) == false
   b.isAfter(a) == true

        此方法仅考虑两个日期在本地时间线上的位置。 它不考虑年表或日历系统。 这与compareTo(ChronoLocalDate)中的比较不同，但是与ChronoLocalDate.timeLineOrder()相同。

        Specified by:
        isAfter在接口 ChronoLocalDate
        参数
        other - 与之比较的其他日期，不为null
        结果
        如果此日期在指定日期之后，则为真

      • isBefore

        public boolean isBefore​(ChronoLocalDate other)
        检查此日期是否在指定日期之前。

        这将检查该日期是否表示在另一个日期之前的本地时间线上的一个点。

          LocalDate a = LocalDate.of(2012, 6, 30);
   LocalDate b = LocalDate.of(2012, 7, 1);
   a.isBefore(b) == true
   a.isBefore(a) == false
   b.isBefore(a) == false

        此方法仅考虑两个日期在本地时间线上的位置。 它不考虑年表或日历系统。 这与compareTo(ChronoLocalDate)中的比较不同，但是与ChronoLocalDate.timeLineOrder()相同。

        Specified by:
        isBefore在接口 ChronoLocalDate
        参数
        other - 要比较的其他日期，不为null
        结果
        如果此日期在指定日期之前，则为真

      • isEqual

        public boolean isEqual​(ChronoLocalDate other)
        检查此日期是否等于指定的日期。

        这将检查该日期是否表示与其他日期在当地时间线上的相同点。

          LocalDate a = LocalDate.of(2012, 6, 30);
   LocalDate b = LocalDate.of(2012, 7, 1);
   a.isEqual(b) == false
   a.isEqual(a) == true
   b.isEqual(a) == false

        此方法仅考虑两个日期在本地时间线上的位置。 它不考虑年表或日历系统。 这是在比较不同compareTo(ChronoLocalDate) ，但是同样的方法为ChronoLocalDate.timeLineOrder() 。

        Specified by:
        isEqual在接口 ChronoLocalDate
        参数
        other - 要比较的其他日期，不为空
        结果
        如果此日期等于指定日期，则为真

      • equals

        public boolean equals​(Object obj)
        检查这个日期是否等于另一个日期。

        比较这个LocalDate与另一个确保日期是一样的。

        只对LocalDate类型的LocalDate进行比较，其他类型返回false。 要比较两个TemporalAccessor实例的日期，包括两个不同年表中的日期，请使用ChronoField.EPOCH_DAY作为比较。

        Specified by:
        equals在接口 ChronoLocalDate
        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个日期的哈希码。
        Specified by:
        hashCode在接口 ChronoLocalDate
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        将此日期输出为String ，如2007-12-03 。

        输出将采用ISO-8601格式uuuu-MM-dd 。

        Specified by:
        toString在接口 ChronoLocalDate
        重写：
        toString在 Object
        结果
        此日期的字符串表示形式，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


LocalDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class LocalDateTime

  • java.lang.Object
    • java.time.LocalDateTime
  • All Implemented Interfaces:
    Serializable ， Comparable<LocalDate> ， ChronoLocalDateTime<LocalDate> ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class LocalDateTime
extends Object
implements Temporal, TemporalAdjuster, ChronoLocalDateTime<LocalDate>, Serializable
    在ISO- 2007-12-03T10:15:30 ，如2007-12-03T10:15:30 。

    LocalDateTime是一个不变的日期时间对象，代表日期时间，通常被视为年 - 月 - 日 - 小时 - 秒。 也可以访问其他日期和时间字段，例如日期，星期几和星期。 时间表示为纳秒精度。 例如，值“2007年10月2日在13：45.30.123456789”可以存储在LocalDateTime 。

    该类不存储或表示时区。 相反，它是一个日期的描述，用于生日，结合当地时间在挂钟上看到。 它不能表示时间线上的瞬时，没有附加信息，如偏移或时区。

    ISO-8601日历系统是当今世界绝大多数的现代民用日历系统。 它相当于今天的闰年规则一直适用于日常生活的公历日历系统。 对于今天写的大多数应用，ISO-8601规则是完全合适的。 然而，任何利用历史日期并要求它们准确的应用程序都将发现ISO-8601方法不合适。

    这是一个value-based类; 在LocalDateTime实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static LocalDateTime MAX
      最大支持 LocalDateTime ，'+ 999999999-12-31T23：59：59.999999999'。
      static LocalDateTime MIN
      最低支持 LocalDateTime ：00：00'。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的日期和时间。
      OffsetDateTime atOffset​(ZoneOffset offset)
      将此日期时间与偏移量相结合可创建 OffsetDateTime 。
      ZonedDateTime atZone​(ZoneId zone)
      将此日期时间与时区组合起来创建一个 ZonedDateTime 。
      int compareTo​(ChronoLocalDateTime<?> other)
      将此日期时间与其他日期时间进行比较。
      boolean equals​(Object obj)
      检查此日期时间是否等于另一个日期时间。
      String format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。
      static LocalDateTime from​(TemporalAccessor temporal)
      LocalDateTime
      int get​(TemporalField field)
      从此日期时间获取指定字段的值作为 int 。
      int getDayOfMonth​()
      获取月份字段。
      DayOfWeek getDayOfWeek​()
      获取星期几字段，这是一个枚举 DayOfWeek 。
      int getDayOfYear​()
      获得日期字段。
      int getHour​()
      获取时间字段。
      long getLong​(TemporalField field)
      从此日期时间获取指定字段的值作为 long 。
      int getMinute​()
      获取小时字段。
      Month getMonth​()
      使用 Month枚举获取月份字段。
      int getMonthValue​()
      将月份字段从1到12。
      int getNano​()
      获得纳秒第二场。
      int getSecond​()
      获得第二分钟的字段。
      int getYear​()
      获取年份字段。
      int hashCode​()
      这个日期时间的哈希码。
      boolean isAfter​(ChronoLocalDateTime<?> other)
      检查这个日期时间是否在指定的日期之后。
      boolean isBefore​(ChronoLocalDateTime<?> other)
      检查此日期时间是否在指定的日期时间之前。
      boolean isEqual​(ChronoLocalDateTime<?> other)
      检查此日期时间是否等于指定的日期时间。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      LocalDateTime minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期时间的副本，并减去指定的金额。
      LocalDateTime minus​(TemporalAmount amountToSubtract)
      返回此日期时间的副本，并减去指定的金额。
      LocalDateTime minusDays​(long days)
      返回此 LocalDateTime的副本，并减去指定的天数。
      LocalDateTime minusHours​(long hours)
      返回此 LocalDateTime的副本，并减去指定的小时数。
      LocalDateTime minusMinutes​(long minutes)
      返回此 LocalDateTime的副本，并减去指定的分钟数。
      LocalDateTime minusMonths​(long months)
      返回此 LocalDateTime的副本，并减去指定的月数。
      LocalDateTime minusNanos​(long nanos)
      返回此 LocalDateTime的副本，并减去指定的纳秒数。
      LocalDateTime minusSeconds​(long seconds)
      返回此 LocalDateTime的副本，并减去指定的秒数。
      LocalDateTime minusWeeks​(long weeks)
      返回此 LocalDateTime的副本，并减去指定的周数。
      LocalDateTime minusYears​(long years)
      返回此 LocalDateTime的副本，并减去指定的年数。
      static LocalDateTime now​()
      从默认时区的系统时钟获取当前的日期时间。
      static LocalDateTime now​(Clock clock)
      从指定的时钟获取当前的日期时间。
      static LocalDateTime now​(ZoneId zone)
      从指定时区的系统时钟获取当前的日期时间。
      static LocalDateTime of​(int year, int month, int dayOfMonth, int hour, int minute)
      从年，月，日，小时和分钟获得 LocalDateTime的实例，将第二和纳秒设置为零。
      static LocalDateTime of​(int year, int month, int dayOfMonth, int hour, int minute, int second)
      从年，月，日，小时，分钟和秒获得 LocalDateTime的实例，将纳秒设置为零。
      static LocalDateTime of​(int year, int month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond)
      从年，月，日，时，分，秒，纳秒获得 LocalDateTime的实例。
      static LocalDateTime of​(int year, Month month, int dayOfMonth, int hour, int minute)
      从年，月，日，小时和分钟获得 LocalDateTime的实例，将第二和纳秒设置为零。
      static LocalDateTime of​(int year, Month month, int dayOfMonth, int hour, int minute, int second)
      从年，月，日，小时，分钟和秒获得 LocalDateTime的实例，将纳秒设置为零。
      static LocalDateTime of​(int year, Month month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond)
      从年，月，日，时，分，秒，纳秒获得 LocalDateTime的实例。
      static LocalDateTime of​(LocalDate date, LocalTime time)
      从日期和时间获取 LocalDateTime的实例。
      static LocalDateTime ofEpochSecond​(long epochSecond, int nanoOfSecond, ZoneOffset offset)
      使用从1970-01-01T00：00：00Z的时代开始的秒数获得一个 LocalDateTime的实例。
      static LocalDateTime ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalDateTime的实例。
      static LocalDateTime parse​(CharSequence text)
      从 2007-12-03T10:15:30等文本字符串获取 LocalDateTime的实例。
      static LocalDateTime parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 LocalDateTime的实例。
      LocalDateTime plus​(long amountToAdd, TemporalUnit unit)
      返回此日期时间的副本，并添加指定的数量。
      LocalDateTime plus​(TemporalAmount amountToAdd)
      返回此日期时间的副本，并添加指定的数量。
      LocalDateTime plusDays​(long days)
      以指定的天数返回此 LocalDateTime的副本。
      LocalDateTime plusHours​(long hours)
      返回此 LocalDateTime的副本，并附加指定的小时数。
      LocalDateTime plusMinutes​(long minutes)
      返回此 LocalDateTime的副本，并附加指定的分钟数。
      LocalDateTime plusMonths​(long months)
      返回此 LocalDateTime的副本，并附加指定的月数。
      LocalDateTime plusNanos​(long nanos)
      返回此 LocalDateTime的副本， LocalDateTime添加了指定的纳秒数。
      LocalDateTime plusSeconds​(long seconds)
      返回此 LocalDateTime的副本，并添加指定的秒数。
      LocalDateTime plusWeeks​(long weeks)
      返回此 LocalDateTime的副本，并附加指定的周数。
      LocalDateTime plusYears​(long years)
      以指定的年数返回此 LocalDateTime的副本。
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      LocalDate toLocalDate​()
      获得这个日期时间的 LocalDate部分。
      LocalTime toLocalTime​()
      获取此日期时间的 LocalTime部分。
      String toString​()
      将此日期时间输出为 String ，如 2007-12-03T10:15:30 。
      LocalDateTime truncatedTo​(TemporalUnit unit)
      返回此 LocalDateTime的副本，截断时间。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算到另一个日期时间的时间量。
      LocalDateTime with​(TemporalAdjuster adjuster)
      返回此日期时间的调整副本。
      LocalDateTime with​(TemporalField field, long newValue)
      返回此日期时间的副本，并将指定的字段设置为新值。
      LocalDateTime withDayOfMonth​(int dayOfMonth)
      返回 LocalDateTime的副本，并更改日期。
      LocalDateTime withDayOfYear​(int dayOfYear)
      返回此 LocalDateTime的副本，并更改日期。
      LocalDateTime withHour​(int hour)
      返回此 LocalDateTime的副本，并更改日期。
      LocalDateTime withMinute​(int minute)
      返回此 LocalDateTime的副本，小时改变。
      LocalDateTime withMonth​(int month)
      返回此 LocalDateTime的副本，并更改月份。
      LocalDateTime withNano​(int nanoOfSecond)
      返回这个 LocalDateTime的副本， LocalDateTime改变了。
      LocalDateTime withSecond​(int second)
      返回此 LocalDateTime的副本，其中第二分钟更改。
      LocalDateTime withYear​(int year)
      返回这个 LocalDateTime的副本，年份被更改。

      • Methods inherited from interface java.time.chrono.ChronoLocalDateTime

        getChronology, timeLineOrder, toEpochSecond, toInstant

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN

        public static final LocalDateTime MIN
        最低支持LocalDateTime ，'- LocalDateTime ：00：00'。 这是最短日期开始时午夜的当地日期。 这结合了LocalDate.MIN和LocalTime.MIN 。 这可以被应用程序用作“过去”的日期。

      • MAX

        public static final LocalDateTime MAX
        最大支持LocalDateTime ，'+ 999999999-12-31T23：59：59.999999999'。 这是在最大日期结束之前的午夜之前的当地日期。 这结合了LocalDate.MAX和LocalTime.MAX 。 这个应用程序可以作为“远未来”的日期时间使用。

    • 方法详细信息

      • now

        public static LocalDateTime now​()
        从默认时区的系统时钟获取当前的日期时间。

        这将在默认时区查询system clock以获取当前的日期时间。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前日期时间使用系统时钟和默认时区，不为空

      • now

        public static LocalDateTime now​(ZoneId zone)
        从指定时区的系统时钟获取当前的日期时间。

        这将查询system clock以获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前日期时间使用系统时钟，不为空

      • now

        public static LocalDateTime now​(Clock clock)
        从指定的时钟获取当前的日期时间。

        这将查询指定的时钟以获取当前的日期时间。 使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前日期时间，不为null

      • of

        public static LocalDateTime of​(int year,
                               Month month,
                               int dayOfMonth,
                               int hour,
                               int minute)
        从年，月，日，小时和分钟获得LocalDateTime的实例，将第二和纳秒设置为零。

        这将返回一个LocalDateTime与指定的年，月，日，月，小时和分钟。 该日期必须在年和月中有效，否则将抛出异常。 第二和第十二个字段将被设置为零。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 代表的月份，不为null
        dayOfMonth - 代表从1到31的月份
        hour - 代表从0到23的小时
        minute - 从0到59表示的小时
        结果
        本地日期时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者如果月的日期对于月份无效

      • of

        public static LocalDateTime of​(int year,
                               Month month,
                               int dayOfMonth,
                               int hour,
                               int minute,
                               int second)
        从年，月，日，小时，分钟和秒获得LocalDateTime的实例，将纳秒设置为零。

        这将返回一个LocalDateTime与指定的年，月，日，月，小时，分钟和秒。 该日期必须在年和月中有效，否则将抛出异常。 纳秒场将被设置为零。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 代表的月份，不为null
        dayOfMonth - 代表从1到31的月份
        hour - 代表从0到23的小时
        minute - 从0到59表示的小时
        second - 从0到59的秒表示
        结果
        本地日期时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者如果月的日期对于月份无效

      • of

        public static LocalDateTime of​(int year,
                               Month month,
                               int dayOfMonth,
                               int hour,
                               int minute,
                               int second,
                               int nanoOfSecond)
        从年，月，日，时，分，秒，纳秒获得LocalDateTime的实例。

        这将返回一个LocalDateTime与指定的年，月，日，月，小时，分，秒和纳秒。 该日期必须在年和月中有效，否则将抛出异常。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 代表的月份，不为null
        dayOfMonth - 代表从1到31的月份
        hour - 代表从0到23的小时
        minute - 表示从0到59的小时
        second - 从0到59的秒表示
        nanoOfSecond - 表示从0到999,999,999的纳秒
        结果
        本地日期时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者月的日期对于月份无效

      • of

        public static LocalDateTime of​(int year,
                               int month,
                               int dayOfMonth,
                               int hour,
                               int minute)
        从年，月，日，小时和分钟获得LocalDateTime的实例，将第二和纳秒设置为零。

        这将返回一个LocalDateTime与指定的年，月，日，月，小时和分钟。 该日期必须在年和月中有效，否则将抛出异常。 第二和第十二个字段将被设置为零。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 从1月1日至12日（12月）的月份，
        dayOfMonth - 代表从1到31的月份
        hour - 代表从0到23的小时
        minute - 从0到59表示的小时
        结果
        本地日期时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者如果月的日期对于月份无效

      • of

        public static LocalDateTime of​(int year,
                               int month,
                               int dayOfMonth,
                               int hour,
                               int minute,
                               int second)
        从年，月，日，小时，分钟和秒获得LocalDateTime的实例，将纳秒设置为零。

        这将返回一个LocalDateTime与指定的年，月，日，月，时，分和秒。 该日期必须在年和月中有效，否则将抛出异常。 纳秒场将被设置为零。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 从1月1日至12日（12月）的月份，
        dayOfMonth - 代表从1到31的月份
        hour - 代表从0到23的小时
        minute - 表示从0到59的小时
        second - 从0到59的秒表示
        结果
        本地日期时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者如果月的日期对于月份无效

      • of

        public static LocalDateTime of​(int year,
                               int month,
                               int dayOfMonth,
                               int hour,
                               int minute,
                               int second,
                               int nanoOfSecond)
        从年，月，日，时，分，秒，纳秒获得LocalDateTime的实例。

        这将返回一个LocalDateTime与指定的年，月，日，月，小时，分，秒和纳秒。 该日期必须在年和月中有效，否则将抛出异常。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 从1月1日至12日（12月）的月份，
        dayOfMonth - 代表从1到31的月份
        hour - 代表从0到23的小时
        minute - 表示从0到59的小时
        second - 从0到59的秒表示
        nanoOfSecond - 表示从0到999,999,999的纳秒
        结果
        本地日期时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者如果月的日期对于月份无效

      • of

        public static LocalDateTime of​(LocalDate date,
                               LocalTime time)
        从日期和时间获取 LocalDateTime的实例。
        参数
        date - 本地日期，不为空
        time - 当地时间，不为空
        结果
        本地日期时间，不为空

      • ofInstant

        public static LocalDateTime ofInstant​(Instant instant,
                                      ZoneId zone)
        从Instant和区域ID获取LocalDateTime的实例。

        这将根据指定的时间创建本地日期时间。 首先，使用区域ID和时刻获取UTC /格林威治的偏移量，这很简单，因为每个时刻只有一个有效的偏移量。 然后，使用即时和偏移量来计算本地日期时间。

        参数
        instant - 即时创建日期时间，不为null
        zone - 可能是偏移的时区，不为空
        结果
        本地日期时间，不为空
        异常
        DateTimeException - 如果结果超出了支持的范围

      • ofEpochSecond

        public static LocalDateTime ofEpochSecond​(long epochSecond,
                                          int nanoOfSecond,
                                          ZoneOffset offset)
        从1970-01-01T00：00：00Z的时代获得使用秒数的LocalDateTime的实例。

        这允许将epoch-second字段转换为本地日期时间。 这主要用于低级转换，而不是一般的应用程序使用。

        参数
        epochSecond - 从1970-01-01T00：00：00Z的时代开始的秒数
        nanoOfSecond - 秒内的纳秒，从0到999,999,999
        offset - 区域偏移，不为空
        结果
        本地日期时间，不为空
        异常
        DateTimeException - 如果结果超出了支持的范围，或者纳秒是无效的

      • from

        public static LocalDateTime from​(TemporalAccessor temporal)
        从时间对象获取一个LocalDateTime的实例。

        这可以基于指定的时间获取本地日期时间。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为LocalDateTime一个实例。

        该转换从时间对象中提取并组合了LocalDate和LocalTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考LocalDateTime::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        本地日期时间，不为空
        异常
        DateTimeException - 如果无法转换为 LocalDateTime
        另请参见：
        Chronology.localDateTime(TemporalAccessor)

      • parse

        public static LocalDateTime parse​(CharSequence text)
        从2007-12-03T10:15:30等文本字符串获取LocalDateTime的实例。

        字符串必须表示有效的日期时间，并使用DateTimeFormatter.ISO_LOCAL_DATE_TIME进行解析。

        参数
        text - 要解析的文本，如“2007-12-03T10：15：30”，不为空
        结果
        解析的本地日期时间，不为null
        异常
        DateTimeParseException - 如果文本无法解析

      • parse

        public static LocalDateTime parse​(CharSequence text,
                                  DateTimeFormatter formatter)
        使用特定的格式化程序从文本字符串获取LocalDateTime的实例。

        使用格式化程序解析文本，返回日期时间。

        参数
        text - 要解析的文本，不为空
        formatter - 使用的格式化程序，不为空
        结果
        解析的本地日期时间，不为null
        异常
        DateTimeParseException - 如果文本无法解析

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的日期时间。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 支持的字段有：

        • NANO_OF_SECOND
        • NANO_OF_DAY
        • MICRO_OF_SECOND
        • MICRO_OF_DAY
        • MILLI_OF_SECOND
        • MILLI_OF_DAY
        • SECOND_OF_MINUTE
        • SECOND_OF_DAY
        • MINUTE_OF_HOUR
        • MINUTE_OF_DAY
        • HOUR_OF_AMPM
        • CLOCK_HOUR_OF_AMPM
        • HOUR_OF_DAY
        • CLOCK_HOUR_OF_DAY
        • AMPM_OF_DAY
        • DAY_OF_WEEK
        • ALIGNED_DAY_OF_WEEK_IN_MONTH
        • ALIGNED_DAY_OF_WEEK_IN_YEAR
        • DAY_OF_MONTH
        • DAY_OF_YEAR
        • EPOCH_DAY
        • ALIGNED_WEEK_OF_MONTH
        • ALIGNED_WEEK_OF_YEAR
        • MONTH_OF_YEAR
        • PROLEPTIC_MONTH
        • YEAR_OF_ERA
        • YEAR
        • ERA
        所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果在此日期时间内支持该字段，则为true，否则为false

      • isSupported

        public boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定的单位是否可以添加到该日期时间或从该日期时间中减去。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        如果单位是ChronoUnit，那么查询是在这里实现的。 支持的单位是：

        • NANOS
        • MICROS
        • MILLIS
        • SECONDS
        • MINUTES
        • HOURS
        • HALF_DAYS
        • DAYS
        • WEEKS
        • MONTHS
        • YEARS
        • DECADES
        • CENTURIES
        • MILLENNIA
        • ERAS
        所有其他ChronoUnit实例将返回false。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 此日期时间用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为空
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果不能获得该字段的范围
        UnsupportedTemporalTypeException - 如果不支持该字段

      • get

        public int get​(TemporalField field)
        从此日期时间获取指定字段的值作为int 。

        这将查询指定字段的值的此日期时间。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 该supported fields将返回基于此日期时间有效值，除了NANO_OF_DAY ， MICRO_OF_DAY ， EPOCH_DAY和PROLEPTIC_MONTH这是太大，无法在int并抛出UnsupportedTemporalTypeException 。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从此日期时间获取指定字段的值作为long 。

        这将查询指定字段的值的此日期时间。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将根据此日期时间返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • toLocalDate

        public LocalDate toLocalDate​()
        获取LocalDate这个日期时间的一部分。

        这将返回一个与此日期时间相同的年份，月份和日期的LocalDate 。

        Specified by:
        toLocalDate在接口 ChronoLocalDateTime<LocalDate>
        结果
        此日期时间的日期部分不为null

      • getYear

        public int getYear​()
        获取年份字段。

        此方法返回一年的原始值int 。

        通过这种方法返回的年份是按照get(YEAR) 。 要获得年龄，请使用get(YEAR_OF_ERA) 。

        结果
        年，从MIN_YEAR到MAX_YEAR

      • getMonthValue

        public int getMonthValue​()
        将月份字段从1到12。

        此方法将一个月从int从1到12返回。如果通过调用getMonth()使用枚举Month，应用程序代码通常更清晰。

        结果
        从1到12年的月份
        另请参见：
        getMonth()

      • getMonth

        public Month getMonth​()
        使用Month枚举获取月份字段。

        此方法返回本月的枚举Month 。 这样可以避免混淆int值的含义。 如果您需要访问原始的int值，则枚举将提供int value 。

        结果
        月份，不为零
        另请参见：
        getMonthValue()

      • getDayOfMonth

        public int getDayOfMonth​()
        获取月份字段。

        此方法返回int值。

        结果
        从1到31日

      • getDayOfYear

        public int getDayOfYear​()
        获得日期字段。

        此方法返回int的原始值int值。

        结果
        一年中，从1到365，或闰年366

      • getDayOfWeek

        public DayOfWeek getDayOfWeek​()
        获取星期几字段，这是一个枚举DayOfWeek 。

        此方法返回星期几的枚举DayOfWeek 。 这样可以避免混淆int值的含义。 如果您需要访问原始的int值，则枚举将提供int value 。

        附加信息可以从DayOfWeek获得。 这包括值的文本名称。

        结果
        星期几不为零

      • toLocalTime

        public LocalTime toLocalTime​()
        获取此日期时间的LocalTime部分。

        这将返回一个LocalTime与这个日期时间相同的小时，分，秒和纳秒。

        Specified by:
        toLocalTime在接口 ChronoLocalDateTime<LocalDate>
        结果
        这个日期时间的一部分，不是null

      • getHour

        public int getHour​()
        获取时间字段。
        结果
        时间从0到23

      • getMinute

        public int getMinute​()
        获取小时字段。
        结果
        分钟，从0到59

      • getSecond

        public int getSecond​()
        获得第二分钟的字段。
        结果
        第二分钟，从0到59

      • getNano

        public int getNano​()
        获得纳秒第二场。
        结果
        纳秒，从0到999,999,999

      • with

        public LocalDateTime with​(TemporalAdjuster adjuster)
        返回此日期时间的调整副本。

        这将返回一个LocalDateTime ，基于这一个，日期时间被调整。 调整使用指定的调整器策略对象进行。 阅读调整器的文档，了解将进行什么调整。

        一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。

        TemporalAdjusters中提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 关键的日期时间类也实现了TemporalAdjuster接口，如Month和MonthDay 。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        例如这个代码在7月的最后一天返回一个日期：

          import static java.time.Month.*;
  import static java.time.temporal.TemporalAdjusters.*;

  result = localDateTime.with(JULY).with(lastDayOfMonth());

        LocalDate和LocalTime课程实现TemporalAdjuster ，因此这种方法可用于更改日期，时间或偏移量：

          result = localDateTime.with(date);
  result = localDateTime.with(time);

        该方法的结果是通过在通过this作为参数的指定调整器上调用TemporalAdjuster.adjustInto(Temporal)方法获得的。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        一个 LocalDateTime基于 this进行了调整，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        public LocalDateTime with​(TemporalField field,
                          long newValue)
        返回此日期时间的副本，并将指定的字段设置为新值。

        这将返回一个LocalDateTime ，基于此，更改指定字段的值。 这可以用于更改任何支持的字段，例如年，月或月。 如果不可能设置该值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        在某些情况下，更改指定的字段可能会导致生成的日期时间无效，例如将月份从1月31日更改为2月将导致日期无效。 在这种情况下，该领域负责解决日期。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        如果该字段是ChronoField，则在此处实现调整。 supported fields将按照LocalDate或LocalTime的匹配方法进行操作 。 所有其他ChronoField实例都会抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.adjustInto(Temporal, long)传递this作为参数。 在这种情况下，该字段决定是否以及如何调整即时。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        一个 LocalDateTime基于 this与指定的字段集，不为null
        异常
        DateTimeException - 如果该字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • withYear

        public LocalDateTime withYear​(int year)
        返回该LocalDateTime的副本。

        时间不影响计算，结果将相同。 如果一年中的日期无效，它将被更改为该月的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        year - 设置结果的年份，从MIN_YEAR到MAX_YEAR
        结果
        一个 LocalDateTime基于这个日期时间与请求的一年，不为null
        异常
        DateTimeException - 如果年值无效

      • withMonth

        public LocalDateTime withMonth​(int month)
        返回此LocalDateTime的副本，并更改月份。

        时间不影响计算，结果将相同。 如果一年中的日期无效，它将被更改为该月的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        month - 从1月（1月）到12月（12月），确定结果的月份
        结果
        一个 LocalDateTime基于这个日期时间与请求的月份，不为null
        异常
        DateTimeException - 如果月份值无效

      • withDayOfMonth

        public LocalDateTime withDayOfMonth​(int dayOfMonth)
        返回LocalDateTime的副本，并更改日期。

        如果生成的日期时间无效，则抛出异常。 时间不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        dayOfMonth - 在结果中设置的月份，从1到28-31
        结果
        一个 LocalDateTime基于这个日期时间与请求的一天，不为null
        异常
        DateTimeException - 如果月日的价值无效，或者月的月日无效月月

      • withDayOfYear

        public LocalDateTime withDayOfYear​(int dayOfYear)
        返回此LocalDateTime更改的LocalDateTime的副本。

        如果生成的日期时间无效，则抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        dayOfYear - 设定结果的日期，从1到365-366
        结果
        一个 LocalDateTime基于这个日期与请求的一天，不为null
        异常
        DateTimeException - 如果日期年值无效，或者如果当年的日期无效

      • withHour

        public LocalDateTime withHour​(int hour)
        返回此LocalDateTime的副本，并更改日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hour - 设置结果的时间从0到23
        结果
        一个 LocalDateTime基于这个日期时间与请求的小时，不为null
        异常
        DateTimeException - 如果小时值无效

      • withMinute

        public LocalDateTime withMinute​(int minute)
        返回此LocalDateTime的副本，小时改变。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minute - 结果中设置的小时从0到59
        结果
        一个 LocalDateTime基于这个日期时间与请求的分钟，不为null
        异常
        DateTimeException - 如果分钟值无效

      • withSecond

        public LocalDateTime withSecond​(int second)
        返回此LocalDateTime的副本，其中第二分钟更改。

        此实例是不可变的，不受此方法调用的影响。

        参数
        second - 设置结果的 second ，从0到59
        结果
        一个 LocalDateTime基于这个日期时间与请求的第二个，不为null
        异常
        DateTimeException - 如果第二个值无效

      • withNano

        public LocalDateTime withNano​(int nanoOfSecond)
        返回此LocalDateTime的副本，其中纳秒修改。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanoOfSecond - 纳秒在结果中设置，从0到999,999,999
        结果
        一个 LocalDateTime基于这个日期时间与请求的纳秒，不为null
        异常
        DateTimeException - 如果纳米值无效

      • truncatedTo

        public LocalDateTime truncatedTo​(TemporalUnit unit)
        返回此LocalDateTime的副本，截断时间。

        截断返回原始日期时间的副本，其中小于指定单位的字段设置为零。 例如，使用minutes单位截断会将第二分钟和纳秒的字段设置为零。

        该单位必须有一个duration ，分为标准日期的长度，不含余数。 这包括所有提供的时间单位ChronoUnit和DAYS 。 其他单位抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        unit - 截断到的单位，不为null
        结果
        一个 LocalDateTime基于此日期时间截断，不为null
        异常
        DateTimeException - 如果无法截断
        UnsupportedTemporalTypeException - 如果不支持本机

      • plus

        public LocalDateTime plus​(TemporalAmount amountToAdd)
        返回此日期时间的副本，并添加指定的数量。

        这将返回一个LocalDateTime ，基于此，添加了指定的数量。 金额通常为Period或Duration，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.addTo(Temporal)将计算委托给金额对象。 数量执行可以以任何方式实现添加，但是它通常会回调到plus(long, TemporalUnit) 。 请参阅金额执行的文档，以确定是否可以成功添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 LocalDateTime基于这个日期时间与添加，而不是null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        public LocalDateTime plus​(long amountToAdd,
                          TemporalUnit unit)
        返回此日期时间的副本，并添加指定的数量。

        这将返回一个LocalDateTime ，基于这一个，以添加的单位数量。 如果不可能添加金额，因为单位不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoUnit，那么添加在这里实现。 日期单位按LocalDate.plus(long, TemporalUnit)添加。 时间单位按LocalTime.plus(long, TemporalUnit)加入，相当于使用plusDays(long)的天数增加。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为参数。 在这种情况下，单元确定是否以及如何执行添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加到结果中的单位数量可能为负数
        unit - 要添加的单位，不为null
        结果
        一个 LocalDateTime基于这个日期时间加上指定的数量，不为null
        异常
        DateTimeException - 如果不能添加
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusYears

        public LocalDateTime plusYears​(long years)
        返回此LocalDateTime的副本，并附加指定的年数。

        该方法通过三个步骤将指定的数量添加到年份字段：

        1. 将输入年份添加到年份字段
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2008-02-29（闰年）加上一年将导致无效日期2009-02-29（标准年）。 而不是返回无效结果，而是选择2009-02-28的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        years - 多年来补充，可能是负数
        结果
        一个 LocalDateTime基于这个日期时间与添加的年份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusMonths

        public LocalDateTime plusMonths​(long months)
        返回此LocalDateTime的副本，并附加指定的月数。

        此方法通过三个步骤将指定的数量添加到月份字段：

        1. 将输入的月份添加到月份字段
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2007-03-31加上一个月将导致无效日期2007-04-31。 而不是返回无效结果，而是选择2007-04-30的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        months - 添加的月份可能为负数
        结果
        一个 LocalDateTime基于这个日期时间与添加的月份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusWeeks

        public LocalDateTime plusWeeks​(long weeks)
        返回此LocalDateTime的副本，并添加指定的周数。

        该方法将指定的数量以周为单位，根据需要增加月份和年份字段的日期字段，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2008-12-31加上一周将导致2009-01-07。

        此实例是不可变的，不受此方法调用的影响。

        参数
        weeks - 要添加的周数可能为负数
        结果
        一个 LocalDateTime基于这个日期时间与周添加，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusDays

        public LocalDateTime plusDays​(long days)
        返回此LocalDateTime的副本，并附加指定的天数。

        此方法将指定的金额添加到天数字段中，根据需要增加月份和年份字段，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2008-12-31加上一天会导致2009-01-01。

        此实例是不可变的，不受此方法调用的影响。

        参数
        days - 添加的日子可能为负数
        结果
        一个 LocalDateTime基于这个日期时间与添加的天数，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusHours

        public LocalDateTime plusHours​(long hours)
        返回此LocalDateTime的副本，并附加指定的小时数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hours - 要添加的时间可能为负数
        结果
        一个 LocalDateTime基于这个日期时间加上小时，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusMinutes

        public LocalDateTime plusMinutes​(long minutes)
        返回此LocalDateTime的副本，并附加指定的分钟数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutes - 要添加的分钟，可能为负数
        结果
        一个 LocalDateTime基于这个日期时间添加分钟，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusSeconds

        public LocalDateTime plusSeconds​(long seconds)
        返回此LocalDateTime的副本，并添加指定的秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        seconds - 添加的秒数可能为负数
        结果
        一个 LocalDateTime基于这个日期时间添加的秒，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusNanos

        public LocalDateTime plusNanos​(long nanos)
        返回此LocalDateTime的副本， LocalDateTime添加了指定的纳秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanos - nanos添加，可能为负数
        结果
        一个 LocalDateTime基于这个日期时间加上纳秒，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • minus

        public LocalDateTime minus​(TemporalAmount amountToSubtract)
        返回此日期时间的副本，并减去指定的金额。

        这将返回一个LocalDateTime ，基于此，减去指定的数量。 金额通常为Period或Duration，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.subtractFrom(Temporal)将计算委托给金额对象。 数量执行可以以任何方式实现减法，但是它通常会回调到minus(long, TemporalUnit) 。 请参阅数量执行的文档，以确定是否可以成功减去它们。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去量，不为null
        结果
        一个 LocalDateTime基于这个日期时间与减法而不是null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        public LocalDateTime minus​(long amountToSubtract,
                           TemporalUnit unit)
        返回此日期时间的副本，并减去指定的金额。

        这将返回一个LocalDateTime ，基于这一个，减去的单位数量。 如果不可能减去金额，因为该单位不受支持或出于某种其他原因，则会抛出异常。

        这个方法相当于plus(long, TemporalUnit) ，这个数量是否定的。 请参阅该方法，以了解如何添加，从而减去运算。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 从结果中减去的单位数量可能为负数
        unit - 减去量的单位，不为空
        结果
        一个 LocalDateTime基于此日期时间减去指定的数量，不为null
        异常
        DateTimeException - 如果不能进行减法
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minusYears

        public LocalDateTime minusYears​(long years)
        返回此LocalDateTime的副本，减去指定的年数。

        该方法从三个步骤中减去指定的数量：

        1. 从年度字段减去输入年数
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2008-02-29（闰年）减去一年将导致无效日期2007-02-29（标准年）。 而不是返回无效结果，而是选择2007-02-28的该月份的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        years - 减去年份，可能为负数
        结果
        一个 LocalDateTime基于这个日期时间与减去的年份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusMonths

        public LocalDateTime minusMonths​(long months)
        返回此LocalDateTime的副本，并减去指定的月数。

        该方法从以下三个步骤中减去月份字段中指定的数量：

        1. 从月份字段减去输入月份
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2007-03-31减去一个月将导致无效日期2007-02-31。 而不是返回无效结果，而是选择2007-02-28的该月份的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        months - 减去数月，可能为负数
        结果
        一个 LocalDateTime基于这个日期时间与减去的月份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusWeeks

        public LocalDateTime minusWeeks​(long weeks)
        返回此LocalDateTime的副本，并LocalDateTime指定的周数。

        该方法从必要的日期字段减去月和年字段中减去指定的数量，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2009-01-07减去一周将导致2008-12-31。

        此实例是不可变的，不受此方法调用的影响。

        参数
        weeks - 减去星期，可能为负数
        结果
        一个 LocalDateTime基于这个日期时间与减去的星期，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • minusDays

        public LocalDateTime minusDays​(long days)
        返回此LocalDateTime的副本，并减去指定的天数。

        该方法根据需要减去月份和年份字段的日期字段减去指定的金额，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2009-01-01减去一天会导致2008-12-31。

        此实例是不可变的，不受此方法调用的影响。

        参数
        days - 减去的日子，可能是负数
        结果
        一个 LocalDateTime基于这个日期时间减去的日期，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusHours

        public LocalDateTime minusHours​(long hours)
        返回此LocalDateTime的副本，并减去指定的小时数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hours - 减去的时间可能为负数
        结果
        一个 LocalDateTime基于这个日期时间减去小时，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusMinutes

        public LocalDateTime minusMinutes​(long minutes)
        返回此LocalDateTime的副本，并减去指定的分钟数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutes - 减去的分数可能为负数
        结果
        一个 LocalDateTime基于这个日期时间减去分钟，而不是null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusSeconds

        public LocalDateTime minusSeconds​(long seconds)
        返回此LocalDateTime的副本，并减去指定的秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        seconds - 减去的秒数可能为负数
        结果
        一个 LocalDateTime基于此日期时间减去秒，不为空
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusNanos

        public LocalDateTime minusNanos​(long nanos)
        返回此LocalDateTime的副本，并减去指定的纳秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanos - nanos减去，可能是负的
        结果
        一个 LocalDateTime基于这个日期时间减去纳秒，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此日期时间。

        这将使用指定的查询策略对象查询此日期时间。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在指定的查询this作为参数调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象与此对象具有相同的日期和时间。

        这将返回与输入相同的可观察类型的时间对象，日期和时间更改为与此相同。

        调整相当于使用Temporal.with(TemporalField, long)两次，通过ChronoField.EPOCH_DAY和ChronoField.NANO_OF_DAY作为字段。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisLocalDateTime.adjustInto(temporal);
   temporal = temporal.with(thisLocalDateTime);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        根据指定的单位计算到另一个日期时间的时间量。

        这可以计算一个LocalDateTime对象之间的时间量，单个TemporalUnit 。 起点和终点是this和指定的日期时间。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为LocalDateTime使用from(TemporalAccessor) 。 例如，可以使用startDateTime.until(endDateTime, DAYS)计算两个日期时间之间的天startDateTime.until(endDateTime, DAYS) 。

        计算返回一个整数，表示两个日期时间之间的完整单位数。 例如，2012-06-15T00：00和2012-08-14T23：59之间的月数将只有一个月，因为是两个月不到一分钟。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        该方法的计算用于ChronoUnit 。 单位NANOS ， MICROS ， MILLIS ， SECONDS ， MINUTES ， HOURS和HALF_DAYS ， DAYS ， WEEKS ， MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS的支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，转换为 LocalDateTime ，不为空
        unit - 测量金额的单位，不为空
        结果
        在此日期和结束日期时间之间的时间量
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 LocalDateTime
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • format

        public String format​(DateTimeFormatter formatter)
        使用指定的格式化程序格式化此日期时间。

        这个日期时间将传递给格式化程序以生成一个字符串。

        Specified by:
        format在接口 ChronoLocalDateTime<LocalDate>
        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的日期时间字符串，不为空
        异常
        DateTimeException - 打印时是否发生错误

      • atOffset

        public OffsetDateTime atOffset​(ZoneOffset offset)
        将此日期时间与偏移量相结合以创建OffsetDateTime 。

        这将从指定的偏移量从此日期时间返回一个OffsetDateTime 。 日期时间和偏移量的所有可能的组合都是有效的。

        参数
        offset - 要组合的偏移量，不为空
        结果
        从此日期时间形成的偏移日期时间和指定的偏移量，不为空

      • atZone

        public ZonedDateTime atZone​(ZoneId zone)
        将此日期时间与时区组合起来创建一个ZonedDateTime 。

        这将从指定时区的此日期时间返回一个ZonedDateTime 。 结果将尽可能接近日期时间。 时区规则（如夏令时）意味着并非每个本地日期时间对指定的区域都有效，因此可能会调整本地日期时间。

        本地日期时间在时间线上解析为单个时刻。 这是通过从区域ID的rules定义的本地日期时间中找到UTC /格林威治的有效偏移量来实现的。

        在大多数情况下，本地日期时间只有一个有效的偏移量。 在重叠的情况下，时钟被设置回来，有两个有效的偏移量。 该方法使用通常对应于“summer”的较早的偏移量。

        在间隙向前跳跃的情况下，没有有效的偏移。 相反，本地日期时间被调整为稍后间隔的长度。 对于典型的1小时夏令时更改，本地日期时间将在一小时后移动到通常对应于“夏季”的偏移量。

        要在重叠期间获得稍后的偏移量，请致电ZonedDateTime.withLaterOffsetAtOverlap()对此方法的结果。 当有间隙或重叠时抛出异常，请使用ZonedDateTime.ofStrict(LocalDateTime, ZoneOffset, ZoneId) 。

        Specified by:
        atZone在接口 ChronoLocalDateTime<LocalDate>
        参数
        zone - 使用的时区，不为空
        结果
        从这个日期时间形成的划分的日期时间，不为null

      • compareTo

        public int compareTo​(ChronoLocalDateTime<?> other)
        将此日期时间与其他日期时间进行比较。

        比较主要是从最早到最晚的日期时间。 它与“等于”一致，如Comparable所定义。

        如果所有被比较的日期时间是LocalDateTime实例，则比较将完全基于日期时间。 如果一些被比较的日期是不同的年表，那么年龄也被考虑，见ChronoLocalDateTime.compareTo(java.time.chrono.ChronoLocalDateTime<?>) 。

        Specified by:
        compareTo在接口 ChronoLocalDateTime<LocalDate>
        Specified by:
        compareTo在接口 Comparable<LocalDate>
        参数
        other - 其他日期时间来比较，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        public boolean isAfter​(ChronoLocalDateTime<?> other)
        检查这个日期时间是否在指定的日期之后。

        这将检查这个日期时间是否表示在另一个日期时间之后的本地时间线上的一个点。

          LocalDate a = LocalDateTime.of(2012, 6, 30, 12, 00);
   LocalDate b = LocalDateTime.of(2012, 7, 1, 12, 00);
   a.isAfter(b) == false
   a.isAfter(a) == false
   b.isAfter(a) == true

        此方法仅考虑本地时间线上两个日期时间的位置。 它不考虑年表或日历系统。 这与compareTo(ChronoLocalDateTime)中的比较不同，但是与ChronoLocalDateTime.timeLineOrder()相同。

        Specified by:
        isAfter在接口 ChronoLocalDateTime<LocalDate>
        参数
        other - 其他日期时间来比较，不为null
        结果
        如果此日期时间在指定的日期时间后，则为true

      • isBefore

        public boolean isBefore​(ChronoLocalDateTime<?> other)
        检查此日期时间是否在指定的日期时间之前。

        这将检查这个日期时间是否表示在另一个日期时间之前的本地时间线上的一个点。

          LocalDate a = LocalDateTime.of(2012, 6, 30, 12, 00);
   LocalDate b = LocalDateTime.of(2012, 7, 1, 12, 00);
   a.isBefore(b) == true
   a.isBefore(a) == false
   b.isBefore(a) == false

        此方法仅考虑本地时间线上两个日期时间的位置。 它不考虑年表或日历系统。 这与compareTo(ChronoLocalDateTime)中的比较不同，但与ChronoLocalDateTime.timeLineOrder()相同。

        Specified by:
        isBefore在接口 ChronoLocalDateTime<LocalDate>
        参数
        other - 其他日期时间来比较，不为null
        结果
        如果此日期时间在指定的日期时间之前，则为true

      • isEqual

        public boolean isEqual​(ChronoLocalDateTime<?> other)
        检查此日期时间是否等于指定的日期时间。

        这将检查这个日期时间是否与其他日期时间在本地时间线上表示相同的点。

          LocalDate a = LocalDateTime.of(2012, 6, 30, 12, 00);
   LocalDate b = LocalDateTime.of(2012, 7, 1, 12, 00);
   a.isEqual(b) == false
   a.isEqual(a) == true
   b.isEqual(a) == false

        此方法仅考虑本地时间线上两个日期时间的位置。 它不考虑年表或日历系统。 这与compareTo(ChronoLocalDateTime)的比较不同，但是与ChronoLocalDateTime.timeLineOrder()相同。

        Specified by:
        isEqual在接口 ChronoLocalDateTime<LocalDate>
        参数
        other - 其他日期时间来比较，不为null
        结果
        如果此日期时间等于指定的日期时间，则为true

      • equals

        public boolean equals​(Object obj)
        检查此日期时间是否等于另一个日期时间。

        将此LocalDateTime与另一个进行比较，确保日期时间相同。 只对LocalDateTime类型的LocalDateTime进行比较，其他类型返回false。

        Specified by:
        equals在接口 ChronoLocalDateTime<LocalDate>
        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期时间，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个日期时间的哈希码。
        Specified by:
        hashCode在接口 ChronoLocalDateTime<LocalDate>
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        输出这个日期时间为String ，如2007-12-03T10:15:30 。

        输出将是以下ISO-8601格式之一：

        • uuuu-MM-dd'T'HH:mm
        • uuuu-MM-dd'T'HH:mm:ss
        • uuuu-MM-dd'T'HH:mm:ss.SSS
        • uuuu-MM-dd'T'HH:mm:ss.SSSSSS
        • uuuu-MM-dd'T'HH:mm:ss.SSSSSSSSS
        所使用的格式将是将省略部分隐含为零的时间的全部值输出的最短。
        Specified by:
        toString在接口 ChronoLocalDateTime<LocalDate>
        重写：
        toString在 Object
        结果
        此日期时间的字符串表示形式，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


LocalTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class LocalTime

  • java.lang.Object
    • java.time.LocalTime
  • All Implemented Interfaces:
    Serializable ， Comparable<LocalTime> ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class LocalTime
extends Object
implements Temporal, TemporalAdjuster, Comparable<LocalTime>, Serializable
    在ISO- 10:15:30 ，如10:15:30 。

    LocalTime是一个不可变的日期时间对象，代表一个时间，通常被视为小时 - 秒。 时间表示为纳秒精度。 例如，值“13：45.30.123456789”可以存储在LocalTime 。

    该类不存储或表示日期或时区。 相反，它是当地时间的描述，如在挂钟上看到的。 它不能表示时间线上的瞬时，没有附加信息，如偏移或时区。

    ISO-8601日历系统是当今世界绝大多数的现代民用日历系统。 该API假定所有日历系统在时间上使用相同的表示，这个类。

    这是一个value-based课; 对LocalTime实例使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static LocalTime MAX
      最大支持 LocalTime ，'23：59：59.999999999'。
      static LocalTime MIDNIGHT
      午夜开始的时候，'00：00'。
      static LocalTime MIN
      最低支持 LocalTime ：00'。
      static LocalTime NOON
      中午的时候，“12：00”。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的时间。
      LocalDateTime atDate​(LocalDate date)
      结合这个时间与一个日期来创建一个 LocalDateTime 。
      OffsetTime atOffset​(ZoneOffset offset)
      结合这个时间与偏移创建一个 OffsetTime 。
      int compareTo​(LocalTime other)
      比较这个时间到另一个时间。
      boolean equals​(Object obj)
      检查这次是否等于另一次。
      String format​(DateTimeFormatter formatter)
      此时使用指定的格式化程序格式化。
      static LocalTime from​(TemporalAccessor temporal)
      从时间对象获取 LocalTime的实例。
      int get​(TemporalField field)
      从此时间获取指定字段的值作为 int 。
      int getHour​()
      获取时间字段。
      long getLong​(TemporalField field)
      从此时间获取指定字段的值作为 long 。
      int getMinute​()
      获取小时字段。
      int getNano​()
      获得纳秒第二场。
      int getSecond​()
      获得第二分钟的字段。
      int hashCode​()
      这个时候的哈希码。
      boolean isAfter​(LocalTime other)
      检查此时间是否在指定时间后。
      boolean isBefore​(LocalTime other)
      检查此时间是否在指定时间之前。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      LocalTime minus​(long amountToSubtract, TemporalUnit unit)
      返回此次的副本，减去指定的金额。
      LocalTime minus​(TemporalAmount amountToSubtract)
      返回此次的副本，减去指定的金额。
      LocalTime minusHours​(long hoursToSubtract)
      返回此 LocalTime的副本，并减去指定的小时数。
      LocalTime minusMinutes​(long minutesToSubtract)
      返回此 LocalTime的副本，并减去指定的分钟数。
      LocalTime minusNanos​(long nanosToSubtract)
      返回此 LocalTime的副本，减去指定的纳秒数。
      LocalTime minusSeconds​(long secondsToSubtract)
      返回此 LocalTime的副本，并减去指定的秒数。
      static LocalTime now​()
      从默认时区的系统时钟获取当前时间。
      static LocalTime now​(Clock clock)
      从指定的时钟获取当前时间。
      static LocalTime now​(ZoneId zone)
      从指定时区的系统时钟获取当前时间。
      static LocalTime of​(int hour, int minute)
      从一分钟内获得 LocalTime的实例。
      static LocalTime of​(int hour, int minute, int second)
      从一小时，一分钟和秒钟获得 LocalTime的实例。
      static LocalTime of​(int hour, int minute, int second, int nanoOfSecond)
      从一小时，分钟，秒和纳秒获取 LocalTime的实例。
      static LocalTime ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalTime的实例。
      static LocalTime ofNanoOfDay​(long nanoOfDay)
      从 LocalTime价值获取 LocalTime的实例。
      static LocalTime ofSecondOfDay​(long secondOfDay)
      从第二天的价值获得一个 LocalTime的实例。
      static LocalTime parse​(CharSequence text)
      从 10:15等文本字符串获取 LocalTime的实例。
      static LocalTime parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 LocalTime的实例。
      LocalTime plus​(long amountToAdd, TemporalUnit unit)
      返回此时添加了指定数量的副本。
      LocalTime plus​(TemporalAmount amountToAdd)
      返回此时添加了指定数量的副本。
      LocalTime plusHours​(long hoursToAdd)
      返回此 LocalTime的副本，并添加指定的小时数。
      LocalTime plusMinutes​(long minutesToAdd)
      返回此 LocalTime的副本，并附加指定的分钟数。
      LocalTime plusNanos​(long nanosToAdd)
      返回此 LocalTime的副本， LocalTime添加了指定的纳秒数。
      LocalTime plusSeconds​(long secondstoAdd)
      返回此 LocalTime的副本，并添加指定的秒数。
      <R> R query​(TemporalQuery<R> query)
      此时使用指定的查询进行查询。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      long toEpochSecond​(LocalDate date, ZoneOffset offset)
      将此 LocalTime转换为自1970-01-01T00：00：00Z的时代以来的秒数。
      long toNanoOfDay​()
      提取时间为天数，从 0到 24 * 60 * 60 * 1,000,000,000 - 1 。
      int toSecondOfDay​()
      提取时间为每天的秒数，从 0到 24 * 60 * 60 - 1 。
      String toString​()
      此时输出为 String ，如 10:15 。
      LocalTime truncatedTo​(TemporalUnit unit)
      返回此 LocalTime的副本，截断时间。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一次的时间量。
      LocalTime with​(TemporalAdjuster adjuster)
      返回此次调整后的副本。
      LocalTime with​(TemporalField field, long newValue)
      返回此时间的副本，并将指定的字段设置为新值。
      LocalTime withHour​(int hour)
      返回 LocalTime的副本，并更改日期。
      LocalTime withMinute​(int minute)
      返回此 LocalTime的副本，小时更改。
      LocalTime withNano​(int nanoOfSecond)
      返回这个 LocalTime的副本， LocalTime改变了。
      LocalTime withSecond​(int second)
      返回此 LocalTime的副本，并更改了第二分钟。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN

        public static final LocalTime MIN
        最低支持LocalTime ：00'。 这是一天开始的午夜时间。

      • MAX

        public static final LocalTime MAX
        最大支持LocalTime ，'23：59：59.999999999'。 这是在一天结束之前的午夜之前的时间。

      • MIDNIGHT

        public static final LocalTime MIDNIGHT
        午夜开始的时候，'00：00'。

      • NOON

        public static final LocalTime NOON
        中午的时候，“12：00”。

    • 方法详细信息

      • now

        public static LocalTime now​()
        从默认时区的系统时钟获取当前时间。

        这将在默认时区查询system clock以获取当前时间。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前时间使用系统时钟和默认时区，不为空

      • now

        public static LocalTime now​(ZoneId zone)
        从指定时区的系统时钟获取当前时间。

        这将查询system clock获取当前时间。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前时间使用系统时钟，不为空

      • now

        public static LocalTime now​(Clock clock)
        从指定的时钟获取当前时间。

        这将查询指定的时钟以获取当前时间。 使用此方法可以使用备用时钟进行测试。 备用时钟可以使用dependency injection引入。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前时间，不为null

      • of

        public static LocalTime of​(int hour,
                           int minute)
        从一小时分钟获得LocalTime的实例。

        这LocalTime指定的小时和分钟返回LocalTime 。 第二和第十二个字段将被设置为零。

        参数
        hour - 代表从0到23的小时
        minute - 从0到59表示的小时
        结果
        当地时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围

      • of

        public static LocalTime of​(int hour,
                           int minute,
                           int second)
        从一小时，分钟和秒钟获取LocalTime的实例。

        这将返回一个LocalTime与指定的小时，分钟和秒。 纳秒场将被设置为零。

        参数
        hour - 代表从0到23的小时
        minute - 从0到59表示的小时
        second - 从0到59的秒表示
        结果
        当地时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围

      • of

        public static LocalTime of​(int hour,
                           int minute,
                           int second,
                           int nanoOfSecond)
        从一小时，分钟，秒和纳秒获取LocalTime的实例。

        这将返回一个LocalTime指定的小时，分钟，秒和纳秒。

        参数
        hour - 代表从0到23的小时
        minute - 从0到59表示的小时
        second - 从0到59的秒表示
        nanoOfSecond - 表示从0到999,999,999的纳秒
        结果
        当地时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围

      • ofInstant

        public static LocalTime ofInstant​(Instant instant,
                                  ZoneId zone)
        从Instant和区域ID获取LocalTime的实例。

        这将根据指定的时间创建本地时间。 首先，使用区域ID和时刻获取UTC /格林威治的偏移量，这很简单，因为每个时刻只有一个有效的偏移量。 然后，使用瞬时和偏移来计算当地时间。

        参数
        instant - 即时创建时间，不为null
        zone - 时区，可能是偏移，不为空
        结果
        当地时间，不为空
        从以下版本开始：
        9

      • ofSecondOfDay

        public static LocalTime ofSecondOfDay​(long secondOfDay)
        从第二天的价值获取一个LocalTime的实例。

        这将返回一个LocalTime与指定的第二天。 纳秒场将被设置为零。

        参数
        secondOfDay - 第二天，从 0到 24 * 60 * 60 - 1
        结果
        当地时间，不为空
        异常
        DateTimeException - 如果第二天的值无效

      • ofNanoOfDay

        public static LocalTime ofNanoOfDay​(long nanoOfDay)
        从LocalTime价值获取LocalTime的实例。

        这将返回一个LocalTime与指定的纳秒。

        参数
        nanoOfDay - nanoOfDay日，从 0到 24 * 60 * 60 * 1,000,000,000 - 1
        结果
        当地时间，不为空
        异常
        DateTimeException - 如果天数的 DateTimeException无效

      • from

        public static LocalTime from​(TemporalAccessor temporal)
        从时间对象获取一个LocalTime的实例。

        这取决于指定时间的本地时间。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为LocalTime一个实例。

        转换使用TemporalQueries.localTime()查询，它依赖于提取NANO_OF_DAY字段。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考LocalTime::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        当地时间，不为空
        异常
        DateTimeException - 如果无法转换为 LocalTime

      • parse

        public static LocalTime parse​(CharSequence text)
        从10:15等文本字符串获取LocalTime的实例。

        字符串必须表示有效时间，并使用DateTimeFormatter.ISO_LOCAL_TIME进行解析。

        参数
        text - 要解析的文本，如“10:15:30”，不为空
        结果
        解析当地时间，不为空
        异常
        DateTimeParseException - 如果文本无法解析

      • parse

        public static LocalTime parse​(CharSequence text,
                              DateTimeFormatter formatter)
        使用特定的格式化程序从文本字符串获取LocalTime的实例。

        使用格式化程序解析文本，返回一个时间。

        参数
        text - 要解析的文本，不为空
        formatter - 要使用的格式化程序，不为null
        结果
        解析当地时间，不为空
        异常
        DateTimeParseException - 如果文本无法解析

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查此时间是否可以查询指定的字段。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 支持的字段有：

        • NANO_OF_SECOND
        • NANO_OF_DAY
        • MICRO_OF_SECOND
        • MICRO_OF_DAY
        • MILLI_OF_SECOND
        • MILLI_OF_DAY
        • SECOND_OF_MINUTE
        • SECOND_OF_DAY
        • MINUTE_OF_HOUR
        • MINUTE_OF_DAY
        • HOUR_OF_AMPM
        • CLOCK_HOUR_OF_AMPM
        • HOUR_OF_DAY
        • CLOCK_HOUR_OF_DAY
        • AMPM_OF_DAY
        所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果此时支持该字段，则为true，否则为false

      • isSupported

        public boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定的单位是否可以被添加到这个时间或从这个时间减去。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        如果单位是ChronoUnit，那么查询是在这里实现的。 支持的单位是：

        • NANOS
        • MICROS
        • MILLIS
        • SECONDS
        • MINUTES
        • HOURS
        • HALF_DAYS
        所有其他ChronoUnit实例将返回false。

        如果单位不是ChronoUnit ，则通过调用TemporalUnit.isSupportedBy(Temporal)通过this作为参数获得该方法的结果。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 这次用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果不能获得字段的范围
        UnsupportedTemporalTypeException - 如果不支持该字段

      • get

        public int get​(TemporalField field)
        从此时间获取指定字段的值作为int 。

        此时会查询指定字段的值。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回基于此时间的有效值，除了NANO_OF_DAY和MICRO_OF_DAY ，这些值太大，无法适应int并抛出UnsupportedTemporalTypeException 。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从此时间获取指定字段的值为long 。

        此时会查询指定字段的值。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回基于此时间的有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取该字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • getHour

        public int getHour​()
        获取时间字段。
        结果
        时间从0到23

      • getMinute

        public int getMinute​()
        获取小时字段。
        结果
        分钟，从0到59

      • getSecond

        public int getSecond​()
        获得第二分钟的字段。
        结果
        第二分钟，从0到59

      • getNano

        public int getNano​()
        获得纳秒第二场。
        结果
        纳秒，从0到999,999,999

      • with

        public LocalTime with​(TemporalAdjuster adjuster)
        返回此次调整后的副本。

        这返回一个LocalTime ，基于这一个，随着时间的推移。 调整使用指定的调整器策略对象进行。 阅读调整器的文档，了解将进行什么调整。

        一个简单的调整器可以简单地设置一个字段，如小时字段。 更复杂的调整器可能会将时间设置为一天中的最后一个小时。

        该方法的结果是通过调用270602882841991方法，通过this作为参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        一个 LocalTime基于 this进行了调整，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        public LocalTime with​(TemporalField field,
                      long newValue)
        返回此时间的副本，并将指定的字段设置为新值。

        这将返回一个LocalTime ，基于此，更改指定字段的值。 这可以用于更改任何支持的字段，如小时，分钟或秒。 如果不可能设置该值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，则在此处执行调整。 支持的字段的行为如下：

        • NANO_OF_SECOND - 返回一个LocalTime具有指定的纳秒。 小时，分和秒将保持不变。
        • NANO_OF_DAY - 返回指定纳秒的LocalTime 。 这完全取代了时间，相当于ofNanoOfDay(long) 。
        • MICRO_OF_SECOND - 返回一个LocalTime ，以秒为单位的LocalTime数乘以指定的微秒乘以1,000。 小时，分和秒将保持不变。
        • MICRO_OF_DAY - 返回一个LocalTime与指定的微型日。 这完全取代了时间，相当于使用ofNanoOfDay(long)与微日相乘1,000。
        • MILLI_OF_SECOND - 返回LocalTime ，以秒为单位，以秒为单位替换为1,000,000。 小时，分和秒将保持不变。
        • MILLI_OF_DAY - 返回指定毫米的LocalTime 。 这完全取代了时间，相当于使用ofNanoOfDay(long)毫秒的日子乘以1,000,000。
        • SECOND_OF_MINUTE - 返回指定秒钟的LocalTime 。 小时，分钟和毫秒都不变。
        • SECOND_OF_DAY - 返回指定的第二天的LocalTime 。 纳秒将不变。
        • MINUTE_OF_HOUR - 返回一个LocalTime与指定的分钟小时。 小时，秒钟和纳秒将保持不变。
        • MINUTE_OF_DAY - 返回指定分钟的LocalTime 。 二分之一秒和二分之一秒将不变。
        • HOUR_OF_AMPM - 返回一个LocalTime与指定的上午pm。 AM / PM，分钟小时，秒钟和纳秒将不变。
        • CLOCK_HOUR_OF_AMPM - 返回一个LocalTime与指定的时钟上午pm。 AM / PM，分钟小时，秒钟和纳秒将不变。
        • HOUR_OF_DAY - 返回一个LocalTime与指定的小时。 分钟小时，秒钟和纳秒将保持不变。
        • CLOCK_HOUR_OF_DAY - 返回一个LocalTime具有指定的时钟 - 时间。 分钟小时，秒钟和纳秒将保持不变。
        • AMPM_OF_DAY - 返回具有指定AM / PM的LocalTime 。 上午的小时，分钟，小时和二分之一秒将不变。

        在所有情况下，如果新值超出了字段值的有效范围，则抛出DateTimeException 。

        所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.adjustInto(Temporal, long)传递this作为参数。 在这种情况下，该字段决定是否以及如何调整即时。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        一个 LocalTime基于 this与指定的字段集，不为null
        异常
        DateTimeException - 如果该字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • withHour

        public LocalTime withHour​(int hour)
        返回此LocalTime的副本，并更改日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hour - 设置结果的小时数，从0到23
        结果
        一个 LocalTime基于这个时间与请求的小时，不为null
        异常
        DateTimeException - 如果小时值无效

      • withMinute

        public LocalTime withMinute​(int minute)
        返回此LocalTime的副本，小时改变。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minute - 在0到59之间设置的小时
        结果
        一个 LocalTime基于此时间与请求的分钟，不为null
        异常
        DateTimeException - 如果分钟值无效

      • withSecond

        public LocalTime withSecond​(int second)
        返回此LocalTime的副本，第二分钟更改。

        此实例是不可变的，不受此方法调用的影响。

        参数
        second - 在0到59之间设置结果的 second
        结果
        一个 LocalTime基于此时与请求的第二个，不为null
        异常
        DateTimeException - 如果第二个值无效

      • withNano

        public LocalTime withNano​(int nanoOfSecond)
        返回这个LocalTime的副本，并修改了纳秒。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanoOfSecond - 纳秒在结果中设置，从0到999,999,999
        结果
        一个 LocalTime基于这个时间与请求的纳秒，不为null
        异常
        DateTimeException - 如果 DateTimeException值无效

      • truncatedTo

        public LocalTime truncatedTo​(TemporalUnit unit)
        返回此LocalTime的副本，截断时间。

        截断返回原始时间的副本，其中小于指定单位的字段设置为零。 例如，使用minutes单元截断将将第二分钟和纳秒的字段设置为零。

        该单位必须有一个duration ，分为标准日期的长度， 无余数。 这包括所有提供的时间单位ChronoUnit和DAYS 。 其他单位抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        unit - 截断到的单位，不为null
        结果
        一个 LocalTime基于此时间截断，不为null
        异常
        DateTimeException - 如果不能截断
        UnsupportedTemporalTypeException - 如果不支持本机

      • plus

        public LocalTime plus​(TemporalAmount amountToAdd)
        返回此时添加了指定数量的副本。

        这将返回一个LocalTime ，基于此，添加指定的数量。 金额通常为Duration，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.addTo(Temporal)将计算委托给金额对象。 数量执行可以以任何愿望的方式实现添加，但通常可以回调到plus(long, TemporalUnit) 。 请参阅金额执行的文档，以确定是否可以成功添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 LocalTime基于这个时间加上，而不是null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        public LocalTime plus​(long amountToAdd,
                      TemporalUnit unit)
        返回此时添加了指定数量的副本。

        这将返回一个LocalTime ，基于这一个，以添加的单位数量。 如果不可能添加金额，因为单位不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoUnit，那么添加在这里实现。 支持的字段的行为如下：

        • NANOS - 返回一个LocalTime ，加上指定的纳秒数。 这相当于plusNanos(long) 。
        • MICROS - 返回一个LocalTime ，加上指定的微秒数。 这相当于plusNanos(long) ，数量乘以1,000。
        • MILLIS - 返回指定的毫秒数的LocalTime 。 相当于plusNanos(long) ，金额乘以1,000,000。
        • SECONDS - 返回一个LocalTime ，加上指定的秒数。 这相当于plusSeconds(long) 。
        • MINUTES - 返回一个LocalTime ，加上指定的分钟数。 这相当于plusMinutes(long) 。
        • HOURS - 返回一个LocalTime ，加上指定的小时数。 这相当于plusHours(long) 。
        • HALF_DAYS - 返回一个LocalTime ，加上指定的半天。 这相当于plusHours(long) ，数量乘以12。

        所有其他ChronoUnit实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为参数。 在这种情况下，单元确定是否以及如何执行添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 添加到结果中的单位数量可能为负数
        unit - 要添加的单位，不为null
        结果
        一个 LocalTime基于这个时间与指定的数量添加，不为null
        异常
        DateTimeException - 如果不能添加
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusHours

        public LocalTime plusHours​(long hoursToAdd)
        返回此LocalTime的副本，并附加指定的小时数。

        这样就增加了指定的小时数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hoursToAdd - 添加的时间可能为负数
        结果
        一个 LocalTime基于这个时间加上的时间，不是null

      • plusMinutes

        public LocalTime plusMinutes​(long minutesToAdd)
        以指定的分钟数返回此LocalTime的副本。

        这样就添加了指定的分钟数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutesToAdd - 要添加的分钟，可能为负数
        结果
        一个 LocalTime基于这个时间加上分钟，不为null

      • plusSeconds

        public LocalTime plusSeconds​(long secondstoAdd)
        返回此LocalTime的副本，并添加指定的秒数。

        这样就增加了指定的秒数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        secondstoAdd - 要添加的秒数，可能为负数
        结果
        一个 LocalTime基于这个时间与秒添加，不为null

      • plusNanos

        public LocalTime plusNanos​(long nanosToAdd)
        返回此LocalTime的副本， LocalTime添加了指定的纳秒数。

        这样就增加了指定的纳秒数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanosToAdd - nanosToAdd添加，可能是负的
        结果
        一个 LocalTime基于这个时间加上纳秒，不是null

      • minus

        public LocalTime minus​(TemporalAmount amountToSubtract)
        返回此次的副本，减去指定的金额。

        这将返回一个LocalTime ，基于此，减去指定的数量。 金额通常为Duration，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.subtractFrom(Temporal)将计算委托给金额对象。 数量执行可以任何方式自由实现减法，但是它通常会回调到minus(long, TemporalUnit) 。 请参阅数量执行的文档，以确定是否可以成功减去它们。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去量，不为空
        结果
        一个 LocalTime基于这个时间与减法而不是null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        public LocalTime minus​(long amountToSubtract,
                       TemporalUnit unit)
        返回此次的副本，减去指定的金额。

        这将返回一个LocalTime ，基于这一个，减去的单位数量。 如果不可能减去金额，因为该单位不受支持或出于某种其他原因，则会抛出异常。

        该方法相当于plus(long, TemporalUnit) ，数量被否定。 请参阅该方法，以了解如何添加，从而减去运算。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 从结果中减去的单位数量可能为负数
        unit - 减去量的单位，不为空
        结果
        一个 LocalTime基于此时间减去指定的数量，不为null
        异常
        DateTimeException - 如果不能进行减法
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minusHours

        public LocalTime minusHours​(long hoursToSubtract)
        返回此LocalTime的副本，并减去指定的小时数。

        这样从这个时间减去指定的小时数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hoursToSubtract - 减去的时间可能为负数
        结果
        一个 LocalTime基于这个时间减去了小时，不为null

      • minusMinutes

        public LocalTime minusMinutes​(long minutesToSubtract)
        返回此LocalTime的副本，并减去指定的分钟数。

        这将从此时间减去指定的分钟数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutesToSubtract - 减去的分数可能为负数
        结果
        一个 LocalTime基于此时间减去分钟，不为空

      • minusSeconds

        public LocalTime minusSeconds​(long secondsToSubtract)
        返回此LocalTime的副本，并减去指定的秒数。

        从此时间减去指定的秒数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        secondsToSubtract - 减去的秒数可能为负数
        结果
        一个 LocalTime基于此时间减去秒，不为空

      • minusNanos

        public LocalTime minusNanos​(long nanosToSubtract)
        返回此LocalTime的副本，减去指定的纳秒数。

        从这个时间减去指定的纳秒数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanosToSubtract - nanosToSubtract减去，可能是负数
        结果
        一个 LocalTime基于这个时间减去纳秒，不为null

      • query

        public <R> R query​(TemporalQuery<R> query)
        此时使用指定的查询进行查询。

        这样可以使用指定的查询策略对象查询此时间。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在指定的查询this作为参数调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象与此对象具有相同的时间。

        这返回与时间变化相同的输入的相同可观察类型的时间对象。

        调整相当于通过ChronoField.NANO_OF_DAY作为字段使用Temporal.with(TemporalField, long) 。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisLocalTime.adjustInto(temporal);
   temporal = temporal.with(thisLocalTime);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        根据指定的单位计算直到另一次的时间量。

        这可以计算一个LocalTime对象之间的时间量，单个TemporalUnit 。 起点和终点为this和指定时间。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为LocalTime使用from(TemporalAccessor) 。 例如，可以使用startTime.until(endTime, HOURS)计算两次之间的小时startTime.until(endTime, HOURS) 。

        计算返回一个整数，表示两次之间的完整单位数。 例如，从11:30到13:29之间的小时数将只有一个小时，因为它是两分钟不到两分钟。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MINUTES);
   amount = MINUTES.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        该方法的计算用于ChronoUnit 。 单位NANOS ， MICROS ， MILLIS ， SECONDS ， MINUTES ， HOURS和HALF_DAYS的支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束时间，排他，转换为 LocalTime ，不为空
        unit - 衡量金额的单位，不为空
        结果
        这段时间与结束时间之间的时间量
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 LocalTime
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • format

        public String format​(DateTimeFormatter formatter)
        此时使用指定的格式化程序格式化。

        这一次将被传递给格式化程序来生成一个字符串。

        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的时间字符串，不为null
        异常
        DateTimeException - 打印时是否发生错误

      • atDate

        public LocalDateTime atDate​(LocalDate date)
        结合这个时间与日期来创建一个LocalDateTime 。

        这将返回一个LocalDateTime形成从这个时间在指定的日期。 日期和时间的所有可能的组合都是有效的。

        参数
        date - 要结合的日期，不为null
        结果
        从这个时间和指定的日期形成的本地日期时间，不为null

      • atOffset

        public OffsetTime atOffset​(ZoneOffset offset)
        结合这个时间与偏移量创建一个OffsetTime 。

        这将返回一个OffsetTime ，从此时间以指定的偏移量形成。 所有可能的时间和偏移的组合都是有效的。

        参数
        offset - 要组合的偏移量，不为空
        结果
        从此时间形成的偏移时间和指定的偏移量，不为空

      • toSecondOfDay

        public int toSecondOfDay​()
        提取时间为一天的秒数，从 0到 24 * 60 * 60 - 1 。
        结果
        第二天相当于这个时候

      • toNanoOfDay

        public long toNanoOfDay​()
        提取时间为天数，从 0到 24 * 60 * 60 * 1,000,000,000 - 1 。
        结果
        那天的纳米相当于这个时间

      • toEpochSecond

        public long toEpochSecond​(LocalDate date,
                          ZoneOffset offset)
        将此LocalTime转换为从1970-01-01T00：00：00Z开始的秒数。

        这将本地时间与指定的日期和偏移量相结合，以计算从1970-01-01T00：00：00Z开始的秒数的时代秒值。 时代之后的时代的实体是积极的，较早的是负的。

        参数
        date - 本地日期，不为null
        offset - 区域偏移，不为空
        结果
        从1970-01-01T00：00：00Z开始的秒数可能为负数
        从以下版本开始：
        9

      • compareTo

        public int compareTo​(LocalTime other)
        比较这个时间到另一个时间。

        比较是基于一天内当地时间的时间位置。 它与“等于”一致，如Comparable所定义。

        Specified by:
        compareTo在接口 Comparable<LocalTime>
        参数
        other - 其他时间比较，不是null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        public boolean isAfter​(LocalTime other)
        检查此时间是否在指定时间后。

        比较是基于一天内时间的时间位置。

        参数
        other - 其他时间比较，不为null
        结果
        如果这是在指定的时间之后，则为true

      • isBefore

        public boolean isBefore​(LocalTime other)
        检查此时间是否在指定时间之前。

        比较是基于一天内时间的时间位置。

        参数
        other - 其他时间比较，不为null
        结果
        如果这一点在指定时间之前，则为true

      • equals

        public boolean equals​(Object obj)
        检查这次是否等于另一次。

        比较是基于一天内时间的时间位置。

        只有LocalTime类型的LocalTime被比较，其他类型返回false。 要比较两个TemporalAccessor实例的日期，请使用ChronoField.NANO_OF_DAY作为比较器。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他时间，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个时候的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        此时输出为String ，如10:15 。

        输出将是以下ISO-8601格式之一：

        • HH:mm
        • HH:mm:ss
        • HH:mm:ss.SSS
        • HH:mm:ss.SSSSSS
        • HH:mm:ss.SSSSSSSSS
        所使用的格式将是将省略部分隐含为零的时间的全部值输出的最短。
        重写：
        toString在 Object
        结果
        这个时间的字符串表示，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Month (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time

Enum Month

  • java.lang.Object
    • java.lang.Enum<Month>
      • java.time.Month
  • All Implemented Interfaces:
    Serializable ， Comparable<Month> ， TemporalAccessor ， TemporalAdjuster

    public enum Month
extends Enum<Month>
implements TemporalAccessor, TemporalAdjuster
    一个月，如“七月”。

    Month是代表今年12月，1月，2月，3月，4月，5月，6月，7月，8月，9月，10月，11月和12月的枚举。

    除了文字枚举名称外，每个月都有一个int值。 int价值遵循正常使用和ISO-8601标准，从1月1日至12日（12月）。 建议应用程序使用枚举而不是int值来确保代码清晰。

    不要使用ordinal()获得的数字表示Month 。 改用getValue() 。

    该枚举代表了许多日历系统中发现的常见概念。 因此，该枚举可能被任何具有与ISO-8601日历系统完全相同的年度概念的日历系统使用。

    实现要求：
    这是一个不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APRIL
      4月份的单身实例，30天。
      AUGUST
      8月份的单身人士31天。
      DECEMBER
      12月份的单身人士31天。
      FEBRUARY
      二月份的单身人士28天，或闰年29人。
      JANUARY
      1月份的单身实例31天。
      JULY
      7月份的单身人士31天。
      JUNE
      6月份的单身人士30天。
      MARCH
      3月份的单身人士31天。
      MAY
      5月份的单身人士31天。
      NOVEMBER
      11月份的单身人士30天。
      OCTOBER
      10月份的单身人士31天。
      SEPTEMBER
      9月份的单身实例，30天。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      将指定的时间对象调整为具有这个月的年份。
      int firstDayOfYear​(boolean leapYear)
      获得与本月第一天对应的日期。
      Month firstMonthOfQuarter​()
      获得与本季度第一个月相对应的月份。
      static Month from​(TemporalAccessor temporal)
      从时间对象获取一个 Month的实例。
      int get​(TemporalField field)
      从这个月份获取指定字段的值作为 int 。
      String getDisplayName​(TextStyle style, Locale locale)
      获取文本表示，如“1月”或“12月”。
      long getLong​(TemporalField field)
      从这个月份获取指定字段的值作为 long 。
      int getValue​()
      获得年度 int价值。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      int length​(boolean leapYear)
      以天为单位获得本月的长度。
      int maxLength​()
      以天为单位获得本月的最大长度。
      int minLength​()
      以天为单位获得本月的最小长度。
      Month minus​(long months)
      返回指定月份之前的月份。
      static Month of​(int month)
      从 int获得 Month的实例。
      Month plus​(long months)
      返回指定月份之后的月份。
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此月份的一年。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      static Month valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Month[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • JANUARY

        public static final Month JANUARY
        1月份的单身实例31天。 这个数值为1 。

      • FEBRUARY

        public static final Month FEBRUARY
        二月份的单身人士28天，或闰年29人。 这个数值为2 。

      • MARCH

        public static final Month MARCH
        3月份的单身人士31天。 它的数值为3 。

      • APRIL

        public static final Month APRIL
        4月份的单身实例，30天。 这个数值为4 。

      • MAY

        public static final Month MAY
        5月份的单身人士31天。 它的数值为5 。

      • JUNE

        public static final Month JUNE
        6月份的单身人士30天。 其数值为6 。

      • JULY

        public static final Month JULY
        7月份的单身人士31天。 这个数值为7 。

      • AUGUST

        public static final Month AUGUST
        8月份的单身人士31天。 这个数值为8 。

      • SEPTEMBER

        public static final Month SEPTEMBER
        9月份的单身实例，30天。 这个数值是9 。

      • OCTOBER

        public static final Month OCTOBER
        10月份的单身人士31天。 这个数值为10 。

      • NOVEMBER

        public static final Month NOVEMBER
        11月份的单身人士30天。 这个数值为11 。

      • DECEMBER

        public static final Month DECEMBER
        12月份的单身人士31天。 这个数值为12 。

    • 方法详细信息

      • values

        public static Month[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Month c : Month.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Month valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • of

        public static Month of​(int month)
        从int获取Month的实例。

        Month是一年的12个月的枚举。 该工厂允许从int获取枚举。 int价格遵循ISO-8601标准，从1月1日至12日（12月）。

        参数
        month - 从1月1日至12日（12月）的月份，
        结果
        月份，不为零
        异常
        DateTimeException - 如果月份无效

      • from

        public static Month from​(TemporalAccessor temporal)
        从时间对象获取Month的实例。

        这取决于指定时间的一个月。 A TemporalAccessor代表日期和时间信息的任意集合，该工厂转换为Month的实例。

        该转换提取了MONTH_OF_YEAR字段。 只有当时间对象具有ISO年表，或者可以转换为LocalDate ，才允许提取。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考Month::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        月份，不为零
        异常
        DateTimeException - 如果无法转换为 Month

      • getValue

        public int getValue​()
        获得年度int价值。

        这些值按照ISO-8601标准编号，从1（1月）到12（12月）。

        结果
        从1月（1月）到12月12日的月份

      • getDisplayName

        public String getDisplayName​(TextStyle style,
                             Locale locale)
        获取文本表示，如“1月”或“12月”。

        这将返回用于标识年月的文本名称，适合向用户呈现。 参数控制返回的文本和区域设置的样式。

        如果没有发现文本映射，则返回numeric value 。

        参数
        style - 所需文本的长度，不为空
        locale - 要使用的语言环境，不为空
        结果
        月份的文本值不为空

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的年月日。 如果是false，那么调用range和get方法会抛出异常。

        如果该字段为MONTH_OF_YEAR，则此方法返回true。 所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果在这个月份的时候支持该字段，则为true，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 本月用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果字段是MONTH_OF_YEAR，那么将返回从1到12的月份的范围。 所有其他ChronoField实例会抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持

      • get

        public int get​(TemporalField field)
        从这个月份获取指定字段的值作为int 。

        这个月查询指定字段的值。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果字段是MONTH_OF_YEAR，那么将返回从1到12的月份的值。 所有其他ChronoField实例会抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值在值的有效范围内
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从这个月份获取指定字段的值作为long 。

        这个月查询指定字段的值。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果字段是MONTH_OF_YEAR ，则将返回从1到12的月份的值。 所有其他ChronoField实例会抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • plus

        public Month plus​(long months)
        返回指定月份之后的月份。

        计算从12月到1月左右。 指定期间可能为负。

        此实例是不可变的，不受此方法调用的影响。

        参数
        months - 要添加的月份，正面或负面
        结果
        结果月份，不为空

      • minus

        public Month minus​(long months)
        返回指定月份之前的月份。

        计算从1月到12月的年初。 指定期间可能为负。

        此实例是不可变的，不受此方法调用的影响。

        参数
        months - 减数，正或负的月数
        结果
        结果月份，不为空

      • length

        public int length​(boolean leapYear)
        以天为单位获得本月的长度。

        这需要一个标志来确定是否返回闰年的长度。

        二月份在标准年份有28天，闰年有29天。 4月，6月，9月和11月有30天。 所有其他月份都有31天。

        参数
        leapYear - 如果闰年需要长度，则为true
        结果
        本月的天数为28天至31天

      • minLength

        public int minLength​()
        以天为单位获得本月的最小长度。

        二月最短28天。 4月，6月，9月和11月有30天。 所有其他月份都有31天。

        结果
        这个月的最小长度为天数，从28到31

      • maxLength

        public int maxLength​()
        以天为单位获得本月的最大长度。

        二月最长可达29天。 4月，6月，9月和11月有30天。 所有其他月份都有31天。

        结果
        这个月的最大长度为天，从29到31

      • firstDayOfYear

        public int firstDayOfYear​(boolean leapYear)
        获得与本月第一天对应的日期。

        这将返回本月开始的日期，使用闰年标志来确定2月的长度。

        参数
        leapYear - 如果闰年需要长度，则为true
        结果
        相当于本月第一天的一年中的一天，从1到336

      • firstMonthOfQuarter

        public Month firstMonthOfQuarter​()
        获得与本季度第一个月相对应的月份。

        年份可分为四个季度。 此方法返回基准月份的季度的第一个月。 1月，2月和3月返回1月。 四月，五月和六月返回四月。 七月，八月和九月返回七月。 十月，十一月和十二月返回十月。

        结果
        本月第一个月对应本月，不为零

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此月份的一年。

        这使用指定的查询策略对象查询这个月份。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在指定的查询this作为参数调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        将指定的时间对象调整为具有这个月的年份。

        这返回与年月日的输入相同的可观察类型的时间对象与此相同。

        该调整是相当于使用Temporal.with(TemporalField, long)通过ChronoField.MONTH_OF_YEAR作为字段。 如果指定的时间对象不使用ISO日历系统，则抛出DateTimeException 。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisMonth.adjustInto(temporal);
   temporal = temporal.with(thisMonth);

        例如，在5月份的日期中，输出以下内容：

          dateInMay.with(JANUARY);    // four months earlier
   dateInMay.with(APRIL);      // one months earlier
   dateInMay.with(MAY);        // same date
   dateInMay.with(JUNE);       // one month later
   dateInMay.with(DECEMBER);   // seven months later

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


MonthDay (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class MonthDay

  • java.lang.Object
    • java.time.MonthDay
  • All Implemented Interfaces:
    Serializable ， Comparable<MonthDay> ， TemporalAccessor ， TemporalAdjuster

    public final class MonthDay
extends Object
implements TemporalAccessor, TemporalAdjuster, Comparable<MonthDay>, Serializable
    ISO- --12-03 ，如--12-03 。

    MonthDay是一个不可变的日期时间对象，代表一个月和一个月的组合。 可以获得可以从月和日派生的任何字段，例如四分之一年份。

    该类不存储或代表一年，一个或多个时区。 例如，值“12月3日”可以存储在MonthDay 。

    由于MonthDay不具有一年，所以2月29日的闰天被认为是有效的。

    该类实现TemporalAccessor而不是Temporal 。 这是因为无法定义2月29日是否有效，没有外部信息，阻止执行加/减。 与此相关， MonthDay仅提供对查询的访问权限，并设置字段MONTH_OF_YEAR和DAY_OF_MONTH 。

    ISO-8601日历系统是当今世界绝大多数的现代民用日历系统。 它相当于今天的闰年规则一直适用于日常生活的公历日历系统。 对于今天写的大多数应用，ISO-8601规则是完全合适的。 然而，任何利用历史日期并要求它们准确的应用程序都将发现ISO-8601方法不合适。

    这是一个value-based课; 对MonthDay实例的使用身份敏感操作（包括引用等式（ == ），身份哈希代码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      将指定的时间对象调整为具有这个月日。
      LocalDate atYear​(int year)
      结合这一个月与一年创造 LocalDate 。
      int compareTo​(MonthDay other)
      比较这个月份到另一个月的日子。
      boolean equals​(Object obj)
      检查这个月日是否等于另一个月 - 日。
      String format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化本月。
      static MonthDay from​(TemporalAccessor temporal)
      从时间对象获取一个 MonthDay的实例。
      int get​(TemporalField field)
      从这个月日获取指定字段的值作为 int 。
      int getDayOfMonth​()
      获取月份字段。
      long getLong​(TemporalField field)
      从这个月份获取指定字段的值作为 long 。
      Month getMonth​()
      使用 Month枚举获取月份字段。
      int getMonthValue​()
      将月份字段从1到12。
      int hashCode​()
      这个月的哈希码。
      boolean isAfter​(MonthDay other)
      检查这个月日是否在指定的月日之后。
      boolean isBefore​(MonthDay other)
      检查这个月日是否在指定的月日之前。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isValidYear​(int year)
      检查年份是否适用于本月。
      static MonthDay now​()
      从默认时区的系统时钟获取当前月日。
      static MonthDay now​(Clock clock)
      从指定的时钟获取当前的月日。
      static MonthDay now​(ZoneId zone)
      从指定时区的系统时钟获取当前的月日。
      static MonthDay of​(int month, int dayOfMonth)
      获得 MonthDay的实例。
      static MonthDay of​(Month month, int dayOfMonth)
      获得 MonthDay的实例。
      static MonthDay parse​(CharSequence text)
      从文本字符串（例如 --12-03获取 MonthDay的实例。
      static MonthDay parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 MonthDay的实例。
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此月日。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      String toString​()
      本月的产量为 String ，如 --12-03 。
      MonthDay with​(Month month)
      返回这个 MonthDay的副本，并更改月份。
      MonthDay withDayOfMonth​(int dayOfMonth)
      返回此 MonthDay的副本，并更改日期。
      MonthDay withMonth​(int month)
      返回这个 MonthDay的副本， MonthDay更改月份。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • now

        public static MonthDay now​()
        从默认时区的系统时钟获取当前月日。

        这将查询默认时区中的system clock以获取当前的月日。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前月日使用系统时钟和默认时区，不为空

      • now

        public static MonthDay now​(ZoneId zone)
        从指定时区的系统时钟获取当前的月日。

        这将查询system clock获取当前的月日。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前月日使用系统时钟，不为空

      • now

        public static MonthDay now​(Clock clock)
        从指定的时钟获取当前的月日。

        这将查询指定的时钟以获取当前的月日。 使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前月日，不为空

      • of

        public static MonthDay of​(Month month,
                          int dayOfMonth)
        获得MonthDay的实例。

        闰年内的月份必须有效。 因此，二月二十九日是有效的。

        例如，四月和第三十一日的通行将会引起例外，因为在任何一年都不可能有4月31日。 相比之下，允许在二月二十九日过境，因为这个月日有时是有效的。

        参数
        month - 代表的月份，不为null
        dayOfMonth - 代表从1到31的月份
        结果
        月日，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者月的日期对于该月无效

      • of

        public static MonthDay of​(int month,
                          int dayOfMonth)
        获得MonthDay的实例。

        闰年内的月份必须有效。 因此，在第2月（2月），第29天有效。

        例如，在4月（4月）和第31天通过将会发生例外，因为任何一年都不可能是4月31日。 相比之下，允许在二月二十九日过境，因为这个月日有时是有效的。

        参数
        month - 从1月1日至12日（12月）的月份，
        dayOfMonth - 代表从1到31的月份
        结果
        月日，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者月的日期对于该月无效

      • from

        public static MonthDay from​(TemporalAccessor temporal)
        从时间对象获取一个MonthDay的实例。

        这将基于指定的时间获得一个月日。 A TemporalAccessor表示任意的日期和时间信息集，该工厂转换为MonthDay一个实例。

        该转换提取了MONTH_OF_YEAR和DAY_OF_MONTH字段。 只有当时间对象具有ISO年表，或者可以转换为LocalDate ，才允许提取。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考MonthDay::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        月日，不为空
        异常
        DateTimeException - 如果无法转换为 MonthDay

      • parse

        public static MonthDay parse​(CharSequence text)
        从文本字符串（例如--12-03获取MonthDay的实例。

        字符串必须表示有效的日期。 格式为--MM-dd 。

        参数
        text - 要解析的文本，例如“--12-03”，不为null
        结果
        解析的月日，不为空
        异常
        DateTimeParseException - 如果文本无法解析

      • parse

        public static MonthDay parse​(CharSequence text,
                             DateTimeFormatter formatter)
        使用特定的格式化程序从文本字符串获取MonthDay的实例。

        使用格式化程序解析文本，返回一个月的日子。

        参数
        text - 要解析的文本，不为空
        formatter - 要使用的格式化程序，不为null
        结果
        解析的月日，不为空
        异常
        DateTimeParseException - 如果文本无法解析

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的这个月日。 如果是false，那么调用range和get方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 支持的字段有：

        • MONTH_OF_YEAR
        • YEAR
        所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果在这个月的日子里支持该字段，则为true，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 这个月份用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获得该字段的范围
        UnsupportedTemporalTypeException - 如果不支持该字段

      • get

        public int get​(TemporalField field)
        从这个月份获取指定字段的值作为int 。

        这个月的日子会查询指定字段的值。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将根据本月日返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从这个月份的日期获取指定字段的值作为long 。

        这个月的日子会查询指定字段的值。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将根据本月日返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取该字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • getMonthValue

        public int getMonthValue​()
        将月份字段从1到12。

        此方法将一个月从int从1到12返回。如果通过调用getMonth()使用枚举Month，应用程序代码通常更清晰。

        结果
        从1到12年的月份
        另请参见：
        getMonth()

      • getMonth

        public Month getMonth​()
        使用Month枚举获取月份字段。

        此方法返回本月的枚举Month 。 这避免了int值意味着什么的混乱。 如果您需要访问原始的int值，则枚举将提供int value 。

        结果
        月份，不为零
        另请参见：
        getMonthValue()

      • getDayOfMonth

        public int getDayOfMonth​()
        获取月份字段。

        此方法返回int值。

        结果
        从1到31日

      • isValidYear

        public boolean isValidYear​(int year)
        检查年份是否适用于本月。

        此方法检查此月和日以及输入年份是否形成有效日期。 这只能在二月二十九日返回假。

        参数
        year - 验证年份
        结果
        如果该年份适用于本月的日期，则为真
        另请参见：
        Year.isValidMonthDay(MonthDay)

      • withMonth

        public MonthDay withMonth​(int month)
        返回这个MonthDay的副本， MonthDay更改月。

        这将返回指定月份的一个月日。 如果指定月份的日期无效，则日期将被调整到最后一个有效的日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        month - 从1月（1月）至12月（12月）返回的月日设定的月份
        结果
        一个 MonthDay基于这个月份与请求的月份，不为null
        异常
        DateTimeException - 如果月份值无效

      • with

        public MonthDay with​(Month month)
        返回这个MonthDay的副本，并更改月份。

        这将返回指定月份的一个月日。 如果指定月份的日期无效，则日期将被调整到最后一个有效的日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        month - 在返回的月日设置的月份，不为null
        结果
        一个 MonthDay基于这个月份与请求的月份，不为null

      • withDayOfMonth

        public MonthDay withDayOfMonth​(int dayOfMonth)
        返回此MonthDay的副本，并更改日期。

        这将返回具有指定日期的月日。 如果当月的日期无效，则抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        dayOfMonth - 返回月日，从1到31的月份
        结果
        一个 MonthDay基于这个月日的请求日，不为null
        异常
        DateTimeException - 如果月日的价值无效，或者月的日期对于该月无效

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此月日。

        这使用指定的查询策略对象查询本月。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过对通过this作为参数的指定查询调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        将指定的时间对象调整为具有这个月日。

        这将返回与月份和日期的输入相同的可观察类型的时间对象，与之相同。

        调整相当于使用Temporal.with(TemporalField, long)两次，通过ChronoField.MONTH_OF_YEAR和ChronoField.DAY_OF_MONTH作为字段。 如果指定的时间对象不使用ISO日历系统，则抛出DateTimeException 。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisMonthDay.adjustInto(temporal);
   temporal = temporal.with(thisMonthDay);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • format

        public String format​(DateTimeFormatter formatter)
        使用指定的格式化程序格式化本月。

        这个月的日子将传递给格式化程序来生成一个字符串。

        参数
        formatter - 使用的格式化程序，不为null
        结果
        格式化的日期字符串，不为空
        异常
        DateTimeException - 打印时是否发生错误

      • atYear

        public LocalDate atYear​(int year)
        结合本月与一年创造LocalDate 。

        这将返回一个LocalDate形成从这个月 - 日和指定年份。

        如果这一年不是闰年，那么2月29日的一个月的日子将会调整到2月28日。

        此实例是不可变的，不受此方法调用的影响。

        参数
        year - 从MIN_YEAR到MAX_YEAR的使用年数
        结果
        从本月和指定年份形成的当地日期，不为空
        异常
        DateTimeException - 如果年度在有效范围之外

      • compareTo

        public int compareTo​(MonthDay other)
        比较这个月份到另一个月的日子。

        比较首先是基于月份的价值，然后是当天的价值。 它与“等于”一致，如Comparable所定义。

        Specified by:
        compareTo在接口 Comparable<MonthDay>
        参数
        other - 与其他月相比，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        public boolean isAfter​(MonthDay other)
        检查这个月日是否在指定的月日之后。
        参数
        other - 与其他月相比，不为空
        结果
        如果这是在指定的月日之后，则为真

      • isBefore

        public boolean isBefore​(MonthDay other)
        检查这个月日是否在指定的月日之前。
        参数
        other - 与其他月相比，不为空
        结果
        如果这一点在指定的月日之前，则为true

      • equals

        public boolean equals​(Object obj)
        检查这个月日是否等于另一个月 - 日。

        比较是基于一年内的月日的时间位置。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他月日，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个月的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        以String输出这个月的日子，如--12-03 。

        输出格式为--MM-dd ：

        重写：
        toString在 Object
        结果
        这个月份的字符串表示，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OffsetDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class OffsetDateTime

  • java.lang.Object
    • java.time.OffsetDateTime
  • All Implemented Interfaces:
    Serializable ， Comparable<OffsetDateTime> ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class OffsetDateTime
extends Object
implements Temporal, TemporalAdjuster, Comparable<OffsetDateTime>, Serializable
    在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如2007-12-03T10:15:30+01:00 。

    OffsetDateTime是具有偏移量的日期时间的不可变表示。 该类存储所有日期和时间字段，精度为纳秒，以及与UTC /格林威治的偏移量。 例如，值“2007年10月2日13：45.30.123456789 +02：00”可以存储在OffsetDateTime 。

    OffsetDateTime ， ZonedDateTime和Instant所有存储在时间线瞬间纳秒的精度。 Instant是最简单的，只是代表瞬间。 OffsetDateTime添加到UTC /格林威治的偏移量，这样可以获得当地的日期时间。 ZonedDateTime添加全时区规则。

    目的在于使用ZonedDateTime或Instant在较简单的应用中对数据进行建模。 当更详细地建模日期时间概念时，或者当与数据库或网络协议进行通信时，可以使用此类。

    这是一个value-based课; 对OffsetDateTime实例使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static OffsetDateTime MAX
      最大支持 OffsetDateTime ，'+ 999999999-12-31T23：59：59.999999999-18：00'。
      static OffsetDateTime MIN
      最低支持 OffsetDateTime ：00：00 + 18：00'。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的偏移量，日期和时间。
      ZonedDateTime atZoneSameInstant​(ZoneId zone)
      将此日期时间与时区组合，以创建一个 ZonedDateTime确保结果具有相同的时刻。
      ZonedDateTime atZoneSimilarLocal​(ZoneId zone)
      将此日期时间与时区组合，以创建一个 ZonedDateTime尝试保持相同的本地日期和时间。
      int compareTo​(OffsetDateTime other)
      将此日期时间与其他日期时间进行比较。
      boolean equals​(Object obj)
      检查此日期时间是否等于另一个日期时间。
      String format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。
      static OffsetDateTime from​(TemporalAccessor temporal)
      从时间对象获取 OffsetDateTime的实例。
      int get​(TemporalField field)
      从此日期时间获取指定字段的值作为 int 。
      int getDayOfMonth​()
      获取月份字段。
      DayOfWeek getDayOfWeek​()
      获取星期几字段，这是一个枚举 DayOfWeek 。
      int getDayOfYear​()
      获得日期字段。
      int getHour​()
      获取时间字段。
      long getLong​(TemporalField field)
      从此日期时间获取指定字段的值作为 long 。
      int getMinute​()
      获取小时字段。
      Month getMonth​()
      使用 Month枚举获取月份字段。
      int getMonthValue​()
      将月份字段从1到12。
      int getNano​()
      获得纳秒第二场。
      ZoneOffset getOffset​()
      获取区域偏移量，例如“+01：00”。
      int getSecond​()
      获得第二分钟的字段。
      int getYear​()
      获取年份字段。
      int hashCode​()
      这个日期时间的哈希码。
      boolean isAfter​(OffsetDateTime other)
      检查此日期时间是否在指定的日期时间之后。
      boolean isBefore​(OffsetDateTime other)
      检查此日期时间是否在指定的日期时间之前。
      boolean isEqual​(OffsetDateTime other)
      检查此日期时间的时间是否等于指定的日期时间。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      OffsetDateTime minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期时间的副本，并减去指定的金额。
      OffsetDateTime minus​(TemporalAmount amountToSubtract)
      返回此日期时间的副本，并减去指定的金额。
      OffsetDateTime minusDays​(long days)
      返回此 OffsetDateTime的副本，并减去指定的天数。
      OffsetDateTime minusHours​(long hours)
      返回此 OffsetDateTime的副本，并减去指定的小时数。
      OffsetDateTime minusMinutes​(long minutes)
      返回此 OffsetDateTime的副本，并减去指定的分钟数。
      OffsetDateTime minusMonths​(long months)
      返回此 OffsetDateTime的副本，并减去指定的月数。
      OffsetDateTime minusNanos​(long nanos)
      返回此 OffsetDateTime的副本，并减去指定的纳秒数。
      OffsetDateTime minusSeconds​(long seconds)
      返回此 OffsetDateTime的副本，并减去指定的秒数。
      OffsetDateTime minusWeeks​(long weeks)
      返回此 OffsetDateTime的副本，并 OffsetDateTime指定的周数。
      OffsetDateTime minusYears​(long years)
      返回此 OffsetDateTime的副本，并减去指定的年数。
      static OffsetDateTime now​()
      从默认时区的系统时钟获取当前的日期时间。
      static OffsetDateTime now​(Clock clock)
      从指定的时钟获取当前的日期时间。
      static OffsetDateTime now​(ZoneId zone)
      从指定时区的系统时钟获取当前的日期时间。
      static OffsetDateTime of​(int year, int month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond, ZoneOffset offset)
      从年，月，日，小时，分，秒，纳秒和偏移中获取 OffsetDateTime的实例。
      static OffsetDateTime of​(LocalDate date, LocalTime time, ZoneOffset offset)
      从日期，时间和偏移量获取 OffsetDateTime的实例。
      static OffsetDateTime of​(LocalDateTime dateTime, ZoneOffset offset)
      从日期时间和偏移量获取 OffsetDateTime的实例。
      static OffsetDateTime ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 OffsetDateTime的实例。
      static OffsetDateTime parse​(CharSequence text)
      从 2007-12-03T10:15:30+01:00等文本字符串获取 OffsetDateTime的实例。
      static OffsetDateTime parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 OffsetDateTime的实例。
      OffsetDateTime plus​(long amountToAdd, TemporalUnit unit)
      返回此日期时间的副本，并添加指定的数量。
      OffsetDateTime plus​(TemporalAmount amountToAdd)
      返回此日期时间的副本，并添加指定的数量。
      OffsetDateTime plusDays​(long days)
      以指定的天数返回此OffsetDateTime的副本。
      OffsetDateTime plusHours​(long hours)
      返回此 OffsetDateTime的副本，并附加指定的小时数。
      OffsetDateTime plusMinutes​(long minutes)
      以指定的分钟数返回此 OffsetDateTime的副本。
      OffsetDateTime plusMonths​(long months)
      返回此 OffsetDateTime的副本，并附加指定的月数。
      OffsetDateTime plusNanos​(long nanos)
      返回此 OffsetDateTime的副本， OffsetDateTime添加了指定的纳秒数。
      OffsetDateTime plusSeconds​(long seconds)
      返回此 OffsetDateTime的副本，并添加指定的秒数。
      OffsetDateTime plusWeeks​(long weeks)
      返回添加了指定周数的此OffsetDateTime的副本。
      OffsetDateTime plusYears​(long years)
      返回此 OffsetDateTime的副本，并附加指定的年数。
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      static Comparator<OffsetDateTime> timeLineOrder​()
      获得一个比较器，只比较两个 OffsetDateTime实例。
      long toEpochSecond​()
      将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。
      Instant toInstant​()
      将此日期时间转换为 Instant 。
      LocalDate toLocalDate​()
      获取此日期时间的 LocalDate部分。
      LocalDateTime toLocalDateTime​()
      获取此日期时间的 LocalDateTime部分。
      LocalTime toLocalTime​()
      获取此日期时间的 LocalTime部分。
      OffsetTime toOffsetTime​()
      将此日期时间转换为 OffsetTime 。
      String toString​()
      将此日期时间输出为 String ，如 2007-12-03T10:15:30+01:00 。
      ZonedDateTime toZonedDateTime​()
      将此日期时间转换为 ZonedDateTime使用偏移量作为区域ID。
      OffsetDateTime truncatedTo​(TemporalUnit unit)
      返回此 OffsetDateTime的副本，截断时间。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算到另一个日期时间的时间量。
      OffsetDateTime with​(TemporalAdjuster adjuster)
      返回此日期时间的调整副本。
      OffsetDateTime with​(TemporalField field, long newValue)
      返回此日期时间的副本，并将指定的字段设置为新值。
      OffsetDateTime withDayOfMonth​(int dayOfMonth)
      返回 OffsetDateTime的副本，并更改日期。
      OffsetDateTime withDayOfYear​(int dayOfYear)
      返回这个 OffsetDateTime的副本， OffsetDateTime更改日期。
      OffsetDateTime withHour​(int hour)
      返回此 OffsetDateTime的副本，并更改日期。
      OffsetDateTime withMinute​(int minute)
      返回此 OffsetDateTime的副本，小时改变。
      OffsetDateTime withMonth​(int month)
      返回该 OffsetDateTime的副本。
      OffsetDateTime withNano​(int nanoOfSecond)
      返回这个 OffsetDateTime的副本， OffsetDateTime改变了。
      OffsetDateTime withOffsetSameInstant​(ZoneOffset offset)
      以指定的偏移量返回此 OffsetDateTime的副本，确保结果处于同一时刻。
      OffsetDateTime withOffsetSameLocal​(ZoneOffset offset)
      返回具有指定偏移量的 OffsetDateTime的副本，确保结果具有相同的本地日期时间。
      OffsetDateTime withSecond​(int second)
      返回此 OffsetDateTime的副本，其中第二分钟更改。
      OffsetDateTime withYear​(int year)
      返回这个 OffsetDateTime的副本，年份被更改。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN

        public static final OffsetDateTime MIN
        最低支持OffsetDateTime ：00：00 + 18：00'。 这是在最大偏移量的最小日期开始的午夜的当地日期时间（更大的偏移在时间线上较早）。 这结合了LocalDateTime.MIN和ZoneOffset.MAX 。 这可以被应用程序用作“过去”的日期。

      • MAX

        public static final OffsetDateTime MAX
        最大支持OffsetDateTime ，'+ 999999999-12-31T23：59：59.999999999-18：00'。 这是在最小偏移量的最大日期结束之前的午夜之前的当地日期时间（较大的负偏移量稍后在时间线上）。 这结合了LocalDateTime.MAX和ZoneOffset.MIN 。 这个应用程序可以作为“远未来”的日期时间使用。

    • 方法详细信息

      • timeLineOrder

        public static Comparator<OffsetDateTime> timeLineOrder​()
        获得一个比较器，只比较两个OffsetDateTime实例。

        这种方法与compareTo(java.time.OffsetDateTime)中的比较不同之处在于它只比较了潜在的时刻。

        结果
        比较器可以按时间顺序进行比较
        另请参见：
        isAfter(java.time.OffsetDateTime) ，
isBefore(java.time.OffsetDateTime) ，
isEqual(java.time.OffsetDateTime)

      • now

        public static OffsetDateTime now​()
        从默认时区的系统时钟获取当前的日期时间。

        这将在默认时区中查询system clock以获取当前的日期时间。 偏移量将从时钟的时区计算。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前日期时间使用系统时钟，不为空

      • now

        public static OffsetDateTime now​(ZoneId zone)
        从指定时区的系统时钟获取当前的日期时间。

        这将查询system clock以获取当前日期。 指定时区可以避免对默认时区的依赖。 偏移量将从指定的时区计算。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前日期时间使用系统时钟，不为空

      • now

        public static OffsetDateTime now​(Clock clock)
        从指定的时钟获取当前的日期时间。

        这将查询指定的时钟以获取当前的日期时间。 偏移量将从时钟的时区计算。

        使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前日期时间，不为null

      • of

        public static OffsetDateTime of​(LocalDate date,
                                LocalTime time,
                                ZoneOffset offset)
        从日期，时间和偏移量获取OffsetDateTime的实例。

        这将创建具有指定的本地日期，时间和偏移量的偏移日期时间。

        参数
        date - 本地日期，不为空
        time - 当地时间，不为空
        offset - 区域偏移，不为空
        结果
        偏移日期时间，不为null

      • of

        public static OffsetDateTime of​(LocalDateTime dateTime,
                                ZoneOffset offset)
        从日期时间和偏移量获取OffsetDateTime的实例。

        这将创建具有指定的本地日期时间和偏移量的偏移日期时间。

        参数
        dateTime - 本地日期时间，不为空
        offset - 区域偏移，不为空
        结果
        偏移日期时间，不为null

      • of

        public static OffsetDateTime of​(int year,
                                int month,
                                int dayOfMonth,
                                int hour,
                                int minute,
                                int second,
                                int nanoOfSecond,
                                ZoneOffset offset)
        从年，月，日，时，分，秒，纳秒和偏移中获取OffsetDateTime的实例。

        这将创建与七个指定字段的偏移日期时间。

        该方法主要用于编写测试用例。 非测试代码通常会使用其他方法来创建一个偏移时间。 LocalDateTime具有五个额外的方便的变体，相当的工厂方法采用较少的参数。 在这里不提供它们来减少API的占用空间。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 从1月1日至12日（12月）的月份，
        dayOfMonth - 代表从1到31的月份
        hour - 代表从0到23的小时
        minute - 表示从0到59的小时
        second - 从0到59的秒表示
        nanoOfSecond - 表示从0到999,999,999的纳秒
        offset - 区域偏移，不为空
        结果
        偏移日期时间，不为null
        异常
        DateTimeException - 如果任何字段的值超出范围，或者如果月的日期对于月份无效

      • ofInstant

        public static OffsetDateTime ofInstant​(Instant instant,
                                       ZoneId zone)
        从Instant和区域ID获取OffsetDateTime的实例。

        这将创建与指定的相同时间的偏移日期时间。 找到UTC /格林威治的偏移量很简单，因为每个瞬间只有一个有效的偏移量。

        参数
        instant - 即时创建日期时间，不为null
        zone - 可能是偏移的时区，不为空
        结果
        偏移日期时间，不为null
        异常
        DateTimeException - 如果结果超出了支持范围

      • from

        public static OffsetDateTime from​(TemporalAccessor temporal)
        从时间对象获取一个OffsetDateTime的实例。

        这将基于指定的时间获得偏移日期时间。 A TemporalAccessor代表日期和时间信息的任意集合，该工厂转换为OffsetDateTime一个实例。

        转换将首先从时间对象获取一个ZoneOffset 。 然后会尝试获得一个LocalDateTime ，如果需要的话可以回到Instant 。 结果将是ZoneOffset与LocalDateTime或Instant 。 允许实现执行优化，例如访问与相关对象相当的那些字段。

        该方法匹配功能界面TemporalQuery的签名，允许它通过方法参考OffsetDateTime::from作为查询使用。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        偏移日期时间，不为null
        异常
        DateTimeException - 如果无法转换为 OffsetDateTime

      • parse

        public static OffsetDateTime parse​(CharSequence text)
        从2007-12-03T10:15:30+01:00等文本字符串获取OffsetDateTime的实例。

        字符串必须表示有效的日期时间，并使用DateTimeFormatter.ISO_OFFSET_DATE_TIME进行解析。

        参数
        text - 要解析的文本，如“2007-12-03T10：15：30 + 01：00”，不为空
        结果
        解析的偏移日期时间，不为null
        异常
        DateTimeParseException - 如果文本无法解析

      • parse

        public static OffsetDateTime parse​(CharSequence text,
                                   DateTimeFormatter formatter)
        使用特定的格式化OffsetDateTime从文本字符串获取OffsetDateTime的实例。

        使用格式化程序解析文本，返回日期时间。

        参数
        text - 要解析的文本，不为空
        formatter - 要使用的格式化程序，不为null
        结果
        解析的偏移日期时间，不为null
        异常
        DateTimeParseException - 如果文本无法解析

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的日期时间。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        如果该字段是ChronoField，那么查询是在这里实现的。 支持的字段有：

        • NANO_OF_SECOND
        • NANO_OF_DAY
        • MICRO_OF_SECOND
        • MICRO_OF_DAY
        • MILLI_OF_SECOND
        • MILLI_OF_DAY
        • SECOND_OF_MINUTE
        • SECOND_OF_DAY
        • MINUTE_OF_HOUR
        • MINUTE_OF_DAY
        • HOUR_OF_AMPM
        • CLOCK_HOUR_OF_AMPM
        • HOUR_OF_DAY
        • CLOCK_HOUR_OF_DAY
        • AMPM_OF_DAY
        • DAY_OF_WEEK
        • ALIGNED_DAY_OF_WEEK_IN_MONTH
        • ALIGNED_DAY_OF_WEEK_IN_YEAR
        • DAY_OF_MONTH
        • DAY_OF_YEAR
        • EPOCH_DAY
        • ALIGNED_WEEK_OF_MONTH
        • ALIGNED_WEEK_OF_YEAR
        • MONTH_OF_YEAR
        • PROLEPTIC_MONTH
        • YEAR_OF_ERA
        • YEAR
        • ERA
        • INSTANT_SECONDS
        • OFFSET_SECONDS
        所有其他ChronoField实例都将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果在此日期时间内支持该字段，则为true，否则为false

      • isSupported

        public boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定的单位是否可以添加到该日期时间或从该日期时间中减去。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        如果单位是ChronoUnit，那么查询是在这里实现的。 支持的单位是：

        • NANOS
        • MICROS
        • MILLIS
        • SECONDS
        • MINUTES
        • HOURS
        • HALF_DAYS
        • DAYS
        • WEEKS
        • MONTHS
        • YEARS
        • DECADES
        • CENTURIES
        • MILLENNIA
        • ERAS
        所有其他ChronoUnit实例将返回false。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 此日期时间用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果不能获得该字段的范围
        UnsupportedTemporalTypeException - 如果不支持该字段

      • get

        public int get​(TemporalField field)
        从此日期时间获取指定字段的值为int 。

        这将查询指定字段的值的此日期时间。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，那么查询是在这里实现的。 该supported fields将返回基于此日期时间有效值，除了NANO_OF_DAY ， MICRO_OF_DAY ， EPOCH_DAY ， PROLEPTIC_MONTH和INSTANT_SECONDS这是太大，无法在int并抛出UnsupportedTemporalTypeException 。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段不是ChronoField ，则通过调用TemporalField.getFrom(TemporalAccessor)通过this作为参数获得此方法的结果。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为空
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从此日期时间获取指定字段的值为long 。

        这将查询指定字段的值的此日期时间。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果字段是ChronoField，那么查询是在这里实现的。 supported fields将根据此日期时间返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获得该字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • getOffset

        public ZoneOffset getOffset​()
        获取区域偏移量，例如“+01：00”。

        这是当地时间与UTC /格林威治的抵消。

        结果
        区域偏移，不为空

      • withOffsetSameLocal

        public OffsetDateTime withOffsetSameLocal​(ZoneOffset offset)
        返回具有指定偏移量的OffsetDateTime的副本，确保结果具有相同的本地日期时间。

        此方法返回一个具有相同的对象LocalDateTime和指定的ZoneOffset 。 不需要或执行计算。 例如，如果此时间表示2007-12-03T10:30+02:00并且指定的偏移量为+03:00 ，则此方法将返回2007-12-03T10:30+03:00 。

        要考虑到偏移量之间的差异，并调整时间字段，请使用withOffsetSameInstant(java.time.ZoneOffset) 。

        此实例是不可变的，不受此方法调用的影响。

        参数
        offset - 要更改的区域偏移量，不为空
        结果
        一个 OffsetDateTime基于这个日期时间与请求的偏移量，不为null

      • withOffsetSameInstant

        public OffsetDateTime withOffsetSameInstant​(ZoneOffset offset)
        返回具有指定偏移量的OffsetDateTime的副本，确保结果处于同一时刻。

        此方法返回一个具有指定的对象ZoneOffset和一个LocalDateTime由两个偏移之间的差异进行调整。 这将导致旧的和新的对象代表相同的时刻。 这对于在不同的偏移量中找到本地时间是有用的。 例如，如果此时间表示2007-12-03T10:30+02:00并且指定的偏移量为+03:00 ，则此方法将返回2007-12-03T11:30+03:00 。

        要在不调整本地时间的情况下更改偏移量，请使用withOffsetSameLocal(java.time.ZoneOffset) 。

        此实例是不可变的，不受此方法调用的影响。

        参数
        offset - 要更改的区域偏移量，不为空
        结果
        一个 OffsetDateTime基于此日期时间与请求的偏移量，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • toLocalDateTime

        public LocalDateTime toLocalDateTime​()
        获取此日期时间的LocalDateTime部分。

        这将返回一个LocalDateTime与这个日期时间相同的年，月，日和时间。

        结果
        这个日期时间的本地日期时间部分，不为空

      • toLocalDate

        public LocalDate toLocalDate​()
        获得这个日期时间的LocalDate一部分。

        这将返回一个LocalDate与同一年，月和日在这个日期时间。

        结果
        此日期时间的日期部分不为null

      • getYear

        public int getYear​()
        获取年份字段。

        此方法返回一年的原始值int 。

        通过这种方法返回的年份是根据get(YEAR)是灵巧的。 要获得年龄，请使用get(YEAR_OF_ERA) 。

        结果
        年，从MIN_YEAR到MAX_YEAR

      • getMonthValue

        public int getMonthValue​()
        将月份字段从1到12。

        该方法将一月份从1到12返回为int如果通过调用getMonth()使用枚举Month，则应用代码通常更清晰。

        结果
        从1到12年的月份
        另请参见：
        getMonth()

      • getMonth

        public Month getMonth​()
        使用Month枚举获取月份字段。

        此方法返回本月的枚举Month 。 这避免了int值意味着什么的混乱。 如果您需要访问原始的int值，则枚举将提供int value 。

        结果
        月份，不为零
        另请参见：
        getMonthValue()

      • getDayOfMonth

        public int getDayOfMonth​()
        获取月份字段。

        此方法返回int的原始值int值。

        结果
        从1到31日

      • getDayOfYear

        public int getDayOfYear​()
        获得日期字段。

        此方法返回int的原始值int值。

        结果
        一年中，从1到365，或闰年366

      • getDayOfWeek

        public DayOfWeek getDayOfWeek​()
        获取星期几字段，这是一个枚举DayOfWeek 。

        此方法返回星期几的枚举DayOfWeek 。 这避免了int值意味着什么的混乱。 如果您需要访问原始的int值，则枚举将提供int value 。

        更多信息可以从DayOfWeek获得。 这包括值的文本名称。

        结果
        星期几不为零

      • toLocalTime

        public LocalTime toLocalTime​()
        获得这个日期时间的LocalTime部分。

        这将返回一个LocalTime与这个日期时间相同的小时，分钟，秒和纳秒。

        结果
        这个日期时间的一部分，不是null

      • getHour

        public int getHour​()
        获取时间字段。
        结果
        时间从0到23

      • getMinute

        public int getMinute​()
        获取小时字段。
        结果
        分钟，从0到59

      • getSecond

        public int getSecond​()
        获得第二分钟的字段。
        结果
        第二分钟，从0到59

      • getNano

        public int getNano​()
        获得纳秒第二场。
        结果
        纳秒，从0到999,999,999

      • with

        public OffsetDateTime with​(TemporalAdjuster adjuster)
        返回此日期时间的调整副本。

        这将返回一个OffsetDateTime ，基于此，调整日期时间。 调整使用指定的调整器策略对象进行。 阅读调整器的文档，了解将进行什么调整。

        一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 在TemporalAdjusters中提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 关键的日期时间课程还实现了TemporalAdjuster界面，如Month和MonthDay 。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        例如这个代码在7月的最后一天返回一个日期：

          import static java.time.Month.*;
  import static java.time.temporal.TemporalAdjusters.*;

  result = offsetDateTime.with(JULY).with(lastDayOfMonth());

        类LocalDate ， LocalTime和ZoneOffset实施TemporalAdjuster ，从而可以用这种方法来改变日期，时间或偏移：

          result = offsetDateTime.with(date);
  result = offsetDateTime.with(time);
  result = offsetDateTime.with(offset);

        该方法的结果是通过调用TemporalAdjuster.adjustInto(Temporal)方法在指定的调整器上通过this作为参数获得的。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        一个 OffsetDateTime基于 this进行了调整，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        public OffsetDateTime with​(TemporalField field,
                           long newValue)
        返回此日期时间的副本，并将指定的字段设置为新值。

        这将返回一个OffsetDateTime ，基于此，更改指定字段的值。 这可以用于更改任何支持的字段，例如年，月或月。 如果不可能设置该值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        在某些情况下，更改指定的字段可能会导致生成的日期时间无效，例如将月份从1月31日更改为2月将导致日期无效。 在这种情况下，该领域负责解决日期。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        如果现场是ChronoField，那么在这里实现调整。

        INSTANT_SECONDS字段将返回指定时间的日期时间。 偏移和纳秒不变。 如果新的即时值超出有效范围，则将抛出DateTimeException 。

        OFFSET_SECONDS字段将返回指定偏移量的日期时间。 当地的日期时间是不变的。 如果新的偏移值超出有效范围，则将抛出DateTimeException 。

        其他supported fields将按照LocalDateTime的匹配方法进行操作 。 在这种情况下，偏移不是计算的一部分，将不会改变。

        所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段不是ChronoField ，则通过调用TemporalField.adjustInto(Temporal, long)通过this作为参数获得该方法的结果。 在这种情况下，该字段决定是否以及如何调整即时。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        一个 OffsetDateTime基于 this与指定的字段集，不为null
        异常
        DateTimeException - 如果字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • withYear

        public OffsetDateTime withYear​(int year)
        返回这个OffsetDateTime的副本，年份被更改。

        时间和偏移量不影响计算，结果将相同。 如果一年中的日期无效，它将被更改为该月的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        year - 从MIN_YEAR到MAX_YEAR的结果年份
        结果
        一个 OffsetDateTime基于这个日期时间与所请求的一年，不为null
        异常
        DateTimeException - 如果年值无效

      • withMonth

        public OffsetDateTime withMonth​(int month)
        返回这个OffsetDateTime的副本，并更改月份。

        时间和偏移量不影响计算，结果将相同。 如果一年中的日期无效，它将被更改为该月的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        month - 从1月（1月）到12月（12月）的结果中，
        结果
        一个 OffsetDateTime基于这个日期时间与请求的月份，不为null
        异常
        DateTimeException - 如果月份值无效

      • withDayOfMonth

        public OffsetDateTime withDayOfMonth​(int dayOfMonth)
        返回此OffsetDateTime的副本，并更改日期。

        如果生成的OffsetDateTime无效，则会抛出异常。 时间和偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        dayOfMonth - 设定结果的月份，从1到28-31
        结果
        一个 OffsetDateTime基于这个日期时间与请求的一天，不为null
        异常
        DateTimeException - 如果月日的价值无效，或者月的日期对于月份无效

      • withDayOfYear

        public OffsetDateTime withDayOfYear​(int dayOfYear)
        返回此OffsetDateTime更改的OffsetDateTime的副本。

        时间和偏移量不影响计算，结果将相同。 如果生成的OffsetDateTime无效，则会抛出异常。

        此实例是不可变的，不受此方法调用的影响。

        参数
        dayOfYear - 设定结果的日期，从1到365-366
        结果
        一个 OffsetDateTime基于这个日期与请求的一天，不为null
        异常
        DateTimeException - 如果日期年值无效，或者如果当年的日期无效

      • withHour

        public OffsetDateTime withHour​(int hour)
        返回OffsetDateTime的副本，并更改日期。

        日期和偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hour - 设置结果的时间从0到23
        结果
        一个 OffsetDateTime基于这个日期时间与请求的小时，不为null
        异常
        DateTimeException - 如果小时值无效

      • withMinute

        public OffsetDateTime withMinute​(int minute)
        返回此OffsetDateTime的副本，小时更改。

        日期和偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minute - 在0到59之间设置结果的小时
        结果
        一个 OffsetDateTime基于这个日期时间与请求的分钟，不为null
        异常
        DateTimeException - 如果分钟值无效

      • withSecond

        public OffsetDateTime withSecond​(int second)
        返回此OffsetDateTime的副本，其中第二分钟更改。

        日期和偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        second - 在0到59之间设置结果的 second
        结果
        一个 OffsetDateTime基于这个日期时间与请求的秒，不为null
        异常
        DateTimeException - 如果第二个值无效

      • withNano

        public OffsetDateTime withNano​(int nanoOfSecond)
        返回此OffsetDateTime的副本，其中纳秒修改。

        日期和偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanoOfSecond - 纳秒在设置结果中，从0到999,999,999
        结果
        一个 OffsetDateTime基于这个日期时间与请求的纳秒，不为null
        异常
        DateTimeException - 如果纳米值无效

      • truncatedTo

        public OffsetDateTime truncatedTo​(TemporalUnit unit)
        返回此OffsetDateTime的副本，截断时间。

        截断返回原始日期时间的副本，其中小于指定单位的字段设置为零。 例如，使用minutes单位进行截断将将第二分钟和第二纳秒字段设置为零。

        该单位必须有一个duration ，分为标准日期的长度， 无余数。 这包括所有提供的时间单位ChronoUnit和DAYS 。 其他单位抛出异常。

        偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        unit - 截断到的单位，不为null
        结果
        一个 OffsetDateTime基于这个日期时间截断，不为null
        异常
        DateTimeException - 如果无法截断
        UnsupportedTemporalTypeException - 如果不支持本机

      • plus

        public OffsetDateTime plus​(TemporalAmount amountToAdd)
        返回此日期时间的副本，并添加指定的数量。

        这将返回一个OffsetDateTime ，基于此，添加指定的数量。 金额通常为Period或Duration，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.addTo(Temporal)将计算委托给金额对象。 金额实施可以以任何方式实现添加，但是它通常会回调到plus(long, TemporalUnit) 。 请参阅金额执行的文档，以确定是否可以成功添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 OffsetDateTime基于这个日期时间与添加，而不是null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        public OffsetDateTime plus​(long amountToAdd,
                           TemporalUnit unit)
        返回此日期时间的副本，并添加指定的数量。

        这将返回一个OffsetDateTime ，基于这一个，以添加的单位数量。 如果不可能添加金额，因为单位不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoUnit，则添加由LocalDateTime.plus(long, TemporalUnit)实现。 偏移量不是计算的一部分，结果将不变。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为参数。 在这种情况下，单元确定是否以及如何执行添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 添加到结果中的单位数量可能为负数
        unit - 要添加的单位，不为null
        结果
        一个 OffsetDateTime基于这个日期时间加上指定的数量，不为null
        异常
        DateTimeException - 如果不能添加
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusYears

        public OffsetDateTime plusYears​(long years)
        以指定的年数返回此OffsetDateTime的副本。

        该方法通过三个步骤将指定的数量添加到年份字段：

        1. 将输入年份添加到年份字段
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2008-02-29（闰年）加上一年将导致无效日期2009-02-29（标准年）。 而不是返回无效结果，而是选择2009-02-28的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        years - 增加的年份，可能是负数
        结果
        一个 OffsetDateTime基于这个日期时间与添加的年份，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • plusMonths

        public OffsetDateTime plusMonths​(long months)
        返回此OffsetDateTime的副本，并附加指定的月数。

        此方法通过三个步骤将指定的数量添加到月份字段：

        1. 将输入的月份添加到月份字段
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2007-03-31加上一个月将导致无效日期2007-04-31。 而不是返回无效结果，而是选择2007-04-30的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        months - 要补充的月份，可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间与添加的月份，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • plusWeeks

        public OffsetDateTime plusWeeks​(long weeks)
        返回添加了指定周数的此OffsetDateTime的副本。

        该方法将指定的数量以周为单位，根据需要增加月份和年份字段的日期字段，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2008-12-31加上一周将导致2009-01-07。

        此实例是不可变的，不受此方法调用的影响。

        参数
        weeks - 要添加的星期可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间与添加的星期，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusDays

        public OffsetDateTime plusDays​(long days)
        以指定的天数返回此OffsetDateTime的副本。

        此方法将指定的金额添加到天数字段中，根据需要增加月份和年份字段，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2008-12-31加上一天会导致2009-01-01。

        此实例是不可变的，不受此方法调用的影响。

        参数
        days - 添加的日子可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间与添加的天数，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • plusHours

        public OffsetDateTime plusHours​(long hours)
        返回此OffsetDateTime的副本，并附加指定的小时数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hours - 要添加的时间可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间与添加的时间，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusMinutes

        public OffsetDateTime plusMinutes​(long minutes)
        返回此OffsetDateTime的副本，并添加指定的分钟数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutes - 要添加的分钟，可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间添加分钟，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusSeconds

        public OffsetDateTime plusSeconds​(long seconds)
        返回此OffsetDateTime的副本，并添加指定的秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        seconds - 要添加的秒数，可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间添加秒，而不是null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • plusNanos

        public OffsetDateTime plusNanos​(long nanos)
        返回此OffsetDateTime的副本，并附加指定的纳秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanos - nanos添加，可能是负数
        结果
        一个 OffsetDateTime基于这个日期时间加上纳秒，不为null
        异常
        DateTimeException - 如果单位无法添加到此类型

      • minus

        public OffsetDateTime minus​(TemporalAmount amountToSubtract)
        返回此日期时间的副本，并减去指定的金额。

        这将返回一个OffsetDateTime ，基于此，减去指定的数量。 金额通常为Period或Duration，但可能是实现TemporalAmount界面的任何其他类型。

        通过调用TemporalAmount.subtractFrom(Temporal)将计算委托给金额对象。 数量执行可以以任何方式自由实现减法，但通常可以回调到minus(long, TemporalUnit) 。 请参阅数量执行的文档，以确定是否可以成功减去它们。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去量，不为空
        结果
        一个 OffsetDateTime基于这个日期时间与减法而不是null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        public OffsetDateTime minus​(long amountToSubtract,
                            TemporalUnit unit)
        返回此日期时间的副本，并减去指定的金额。

        这将返回一个OffsetDateTime ，基于这一个，减去的单位数量。 如果不可能减去金额，因为该单位不受支持或出于某种其他原因，则会抛出异常。

        这种方法相当于plus(long, TemporalUnit) ，数量被否定。 请参阅该方法，以了解如何添加，从而减去运算。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 从结果中减去的单位数量可能为负数
        unit - 减去量的单位，不为空
        结果
        一个 OffsetDateTime基于这个日期时间减去指定的数量，不为null
        异常
        DateTimeException - 如果不能进行减法
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minusYears

        public OffsetDateTime minusYears​(long years)
        返回此OffsetDateTime的副本，并减去指定的年数。

        该方法从三个步骤中减去指定的数量：

        1. 从年度字段减去输入年数
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2008-02-29（闰年）减去一年将导致无效日期2007-02-29（标准年）。 而不是返回无效结果，而是选择2007-02-28的该月份的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        years - 减去年份，可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间与减去的年份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusMonths

        public OffsetDateTime minusMonths​(long months)
        返回此OffsetDateTime的副本，并减去指定的月数。

        该方法从以下三个步骤中减去月份字段中指定的数量：

        1. 从月份字段减去输入月份
        2. 检查结果日期是否无效
        3. 如果有必要，将月份调整到最后一个有效日期

        例如，2007-03-31减去一个月将导致无效日期2007-02-31。 而不是返回无效结果，而是选择2007-02-28的该月份的最后一个有效日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        months - 减去数月，可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间减去的月份，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • minusWeeks

        public OffsetDateTime minusWeeks​(long weeks)
        返回此OffsetDateTime的副本，其中指定的星期数减去。

        该方法从必要的日期字段减去月和年字段中减去指定的数量，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2009-01-07减去一周将导致2008-12-31。

        此实例是不可变的，不受此方法调用的影响。

        参数
        weeks - 减去的星期可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间与减去的星期，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusDays

        public OffsetDateTime minusDays​(long days)
        返回此OffsetDateTime的副本，并减去指定的天数。

        该方法根据需要减去月份和年份字段的日期字段减去指定的金额，以确保结果保持有效。 如果超过最大/最小年份，结果将无效。

        例如，2009-01-01减去一天会导致2008-12-31。

        此实例是不可变的，不受此方法调用的影响。

        参数
        days - 减去的日期可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间减去的日期，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusHours

        public OffsetDateTime minusHours​(long hours)
        返回此OffsetDateTime的副本，并减去指定的小时数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hours - 减去的小时数可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间减去的时间，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusMinutes

        public OffsetDateTime minusMinutes​(long minutes)
        返回此OffsetDateTime的副本，并减去指定的分钟数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutes - 减去的分数可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间减去分钟，不为空
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusSeconds

        public OffsetDateTime minusSeconds​(long seconds)
        返回此OffsetDateTime的副本，并减去指定的秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        seconds - 减去秒数，可能为负数
        结果
        一个 OffsetDateTime基于这个日期时间减去秒，而不是null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusNanos

        public OffsetDateTime minusNanos​(long nanos)
        返回此OffsetDateTime的副本，并减去指定的纳秒数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanos - nanos减去，可能是负数
        结果
        一个 OffsetDateTime基于这个日期时间减去纳秒，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此日期时间。

        这将使用指定的查询策略对象查询此日期时间。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在this作为参数的指定查询上调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象与此对象具有相同的偏移量，日期和时间。

        这返回与偏移量相同的可观察类型的时间对象，偏移量，日期和时间更改为与此相同。

        该调整是相当于使用Temporal.with(TemporalField, long)两三次，传球ChronoField.EPOCH_DAY ， ChronoField.NANO_OF_DAY和ChronoField.OFFSET_SECONDS作为字段。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisOffsetDateTime.adjustInto(temporal);
   temporal = temporal.with(thisOffsetDateTime);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果无法做出调整
        ArithmeticException - 如果发生数字溢出

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        根据指定的单位计算到另一个日期时间的时间量。

        这可以计算一个OffsetDateTime对象之间的时间量，单个TemporalUnit 。 起点和终点是this和指定的日期时间。 如果结束在开始之前，结果将为负数。 例如，可以使用startDateTime.until(endDateTime, DAYS)计算两个日期时间之间的天startDateTime.until(endDateTime, DAYS) 。

        所述Temporal传递给此方法被转换为OffsetDateTime使用from(TemporalAccessor) 。 如果偏移量在两个日期时间之间不同，则指定的结束日期时间被归一化为与此日期时间相同的偏移量。

        计算返回一个整数，表示两个日期时间之间的完整单位数。 例如，2012-06-15T00：00Z和2012-08-14T23：59Z之间的月数将只有一个月，因为是两个月不到一分钟。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        计算方法为ChronoUnit 。 单位NANOS ， MICROS ， MILLIS ， SECONDS ， MINUTES ， HOURS和HALF_DAYS ， DAYS ， WEEKS ， MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS的支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，转换为 OffsetDateTime ，不为空
        unit - 衡量金额的单位，不为空
        结果
        在此日期和结束日期时间之间的时间量
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 OffsetDateTime
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • format

        public String format​(DateTimeFormatter formatter)
        使用指定的格式化程序格式化此日期时间。

        这个日期时间将传递给格式化程序以生成一个字符串。

        参数
        formatter - 格式化程序使用，不为空
        结果
        格式化的日期时间字符串，不为空
        异常
        DateTimeException - 打印时是否发生错误

      • atZoneSameInstant

        public ZonedDateTime atZoneSameInstant​(ZoneId zone)
        将此日期时间与时区组合，创建一个ZonedDateTime确保结果具有相同的时间。

        这将从此日期时间和指定的时区返回一个ZonedDateTime 。 此转换将忽略可见的本地日期时间，并使用底层即时代替。 这避免了当地时间线间隙或重叠的任何问题。 结果可能会有不同的值，例如小时，分钟甚至偶数天。

        要尝试保留字段的值，请使用atZoneSimilarLocal(ZoneId) 。 要使用偏移量作为区域ID，请使用toZonedDateTime() 。

        参数
        zone - 使用的时区，不为空
        结果
        从这个日期时间形成的划分的日期时间，不为null

      • atZoneSimilarLocal

        public ZonedDateTime atZoneSimilarLocal​(ZoneId zone)
        将此日期时间与时区组合，以创建一个ZonedDateTime尝试保持相同的本地日期和时间。

        这将返回一个从这个日期时间和指定的时区形成的ZonedDateTime 。 在可能的情况下，结果将具有与此对象相同的本地日期时间。

        时区规则，如夏令时，意味着不是每次当地时间线都存在。 如果本地日期时间根据规则处于间隙或重叠，则使用解析器来确定合成的本地时间和偏移量。 如果可能，此方法使用ZonedDateTime.ofLocal(LocalDateTime, ZoneId, ZoneOffset)保留此实例的偏移量。

        间隙和重叠的更好的控制有两种方式。 如果您只想在重叠时使用稍后的偏移量，则在此方法后立即调用ZonedDateTime.withLaterOffsetAtOverlap() 。

        要在同一时刻创建分区的日期时间，无论本地时间线如何，请使用atZoneSameInstant(ZoneId) 。 要使用偏移量作为区域ID，请使用toZonedDateTime() 。

        参数
        zone - 使用的时区，不为空
        结果
        从该日期形成的划区日期时间和区域的最早有效时间，不为空

      • toOffsetTime

        public OffsetTime toOffsetTime​()
        将此日期时间转换为OffsetTime 。

        这将返回具有相同本地时间和偏移量的偏移时间。

        结果
        表示时间和偏移的OffsetTime，不为null

      • toZonedDateTime

        public ZonedDateTime toZonedDateTime​()
        将此日期时间转换为ZonedDateTime使用偏移量作为区域ID。

        这将创建使用偏移作为区域ID的最简单的ZonedDateTime 。

        要控制使用的时区，请参阅atZoneSameInstant(ZoneId)和atZoneSimilarLocal(ZoneId) 。

        结果
        表示相同本地日期时间和偏移量的分区日期时间，不为空

      • toInstant

        public Instant toInstant​()
        将此日期时间转换为Instant 。

        这将返回一个Instant表示与此日期时间相同的时间点。

        结果
        一个 Instant代表同一瞬间，不为空

      • toEpochSecond

        public long toEpochSecond​()
        将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。

        这样可以将此日期时间转换为epoch-seconds字段的值。 这主要用于低级转换，而不是一般的应用程序使用。

        结果
        从1970-01-01T00：00：00Z的时代开始的秒数

      • compareTo

        public int compareTo​(OffsetDateTime other)
        将此日期时间与其他日期时间进行比较。

        比较是基于当时的当地日期时间。 它与“等于”一致，如Comparable所定义。

        例如，以下是比较器顺序：

        1. 2008-12-03T10:30+01:00
        2. 2008-12-03T11:00+01:00
        3. 2008-12-03T12:00+02:00
        4. 2008-12-03T11:30+01:00
        5. 2008-12-03T12:00+01:00
        6. 2008-12-03T12:30+01:00
        值2和＃3表示时间线上相同的时刻。 当两个值表示相同的时刻时，将本地日期时间进行比较以区分它们。 需要此步骤才能使订购与equals()一致。
        Specified by:
        compareTo在接口 Comparable<OffsetDateTime>
        参数
        other - 其他日期时间来比较，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        public boolean isAfter​(OffsetDateTime other)
        检查此日期时间是否在指定的日期时间之后。

        该方法与compareTo(java.time.OffsetDateTime)和equals(java.lang.Object)中的比较不同之处在于它仅比较日期时间的时间。 这相当于使用dateTime1.toInstant().isAfter(dateTime2.toInstant()); 。

        参数
        other - 其他日期时间来比较，不为空
        结果
        如果这是在指定的日期时间之后，则为真

      • isBefore

        public boolean isBefore​(OffsetDateTime other)
        检查此日期时间是否在指定的日期时间之前。

        该方法与compareTo(java.time.OffsetDateTime)中的比较不同之处仅在于比较日期时间的时间。 这相当于使用dateTime1.toInstant().isBefore(dateTime2.toInstant()); 。

        参数
        other - 其他日期时间来比较，不为null
        结果
        如果这是在指定的日期时间之前，则为真

      • isEqual

        public boolean isEqual​(OffsetDateTime other)
        检查此日期时间的时间是否等于指定的日期时间。

        该方法与compareTo(java.time.OffsetDateTime)和equals(java.lang.Object)中的比较不同之处在于它仅比较日期时间的时间。 这相当于使用dateTime1.toInstant().equals(dateTime2.toInstant()); 。

        参数
        other - 其他日期时间来比较，不为null
        结果
        如果瞬间等于指定日期时间的时间，则为true

      • equals

        public boolean equals​(Object obj)
        检查此日期时间是否等于另一个日期时间。

        比较是基于本地日期时间和偏移量。 要在时间线上相同的时间进行比较，请使用isEqual(java.time.OffsetDateTime) 。 只对OffsetDateTime类型的OffsetDateTime进行比较，其他类型返回false。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期时间，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个日期时间的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        将此日期时间输出为String ，如2007-12-03T10:15:30+01:00 。

        输出将是以下ISO-8601格式之一：

        • uuuu-MM-dd'T'HH:mmXXXXX
        • uuuu-MM-dd'T'HH:mm:ssXXXXX
        • uuuu-MM-dd'T'HH:mm:ss.SSSXXXXX
        • uuuu-MM-dd'T'HH:mm:ss.SSSSSSXXXXX
        • uuuu-MM-dd'T'HH:mm:ss.SSSSSSSSSXXXXX
        所使用的格式将是将省略部分隐含为零的时间的全部值输出的最短。
        重写：
        toString在 Object
        结果
        此日期时间的字符串表示形式，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


OffsetTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class OffsetTime

  • java.lang.Object
    • java.time.OffsetTime
  • All Implemented Interfaces:
    Serializable ， Comparable<OffsetTime> ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class OffsetTime
extends Object
implements Temporal, TemporalAdjuster, Comparable<OffsetTime>, Serializable
    在ISO- 10:15:30+01:00 UTC /格林威治的时间，如10:15:30+01:00 。

    OffsetTime是一个不可变的日期时间对象，表示时间，通常被视为小时 - 秒 - 秒。 该类存储所有时间字段，精度为纳秒，以及区域偏移量。 例如，值“13：45.30.123456789 + 02：00”可以存储在OffsetTime 。

    这是一个value-based类; 对OffsetTime实例的身份敏感操作（包括引用等式（ == ），身份哈希码或同步）的OffsetTime可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static OffsetTime MAX
      最大支持 OffsetTime ，'23：59：59.999999999-18：00'。
      static OffsetTime MIN
      最低支持 OffsetTime ：00：00 + 18：00'。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的偏移量和时间。
      OffsetDateTime atDate​(LocalDate date)
      结合这个时间与一个日期创建一个 OffsetDateTime 。
      int compareTo​(OffsetTime other)
      再比较这个 OffsetTime 。
      boolean equals​(Object obj)
      检查这次是否等于另一次。
      String format​(DateTimeFormatter formatter)
      此时使用指定的格式化程序格式化。
      static OffsetTime from​(TemporalAccessor temporal)
      从时间对象获取 OffsetTime的实例。
      int get​(TemporalField field)
      从此时间获取指定字段的值为 int 。
      int getHour​()
      获取时间字段。
      long getLong​(TemporalField field)
      从此时间获取指定字段的值为 long 。
      int getMinute​()
      获取小时字段。
      int getNano​()
      获得纳秒第二场。
      ZoneOffset getOffset​()
      获取区域偏移量，例如“+01：00”。
      int getSecond​()
      获得第二分钟的字段。
      int hashCode​()
      这个时候的哈希码。
      boolean isAfter​(OffsetTime other)
      检查此 OffsetTime是否在指定的时间之后，将两次都应用到通用日期。
      boolean isBefore​(OffsetTime other)
      检查此 OffsetTime是否在指定的时间之前，将两次都应用到公用日期。
      boolean isEqual​(OffsetTime other)
      检查这个 OffsetTime是否等于在两个时间应用到公共日期的指定时间。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      OffsetTime minus​(long amountToSubtract, TemporalUnit unit)
      返回此次的副本，减去指定的金额。
      OffsetTime minus​(TemporalAmount amountToSubtract)
      返回此次的副本，减去指定的金额。
      OffsetTime minusHours​(long hours)
      返回此 OffsetTime的副本，并减去指定的小时数。
      OffsetTime minusMinutes​(long minutes)
      返回此 OffsetTime的副本，并减去指定的分钟数。
      OffsetTime minusNanos​(long nanos)
      返回此 OffsetTime的副本，减去指定的纳秒数。
      OffsetTime minusSeconds​(long seconds)
      返回此 OffsetTime的副本，并减去指定的秒数。
      static OffsetTime now​()
      从默认时区的系统时钟获取当前时间。
      static OffsetTime now​(Clock clock)
      从指定的时钟获取当前时间。
      static OffsetTime now​(ZoneId zone)
      从指定时区的系统时钟获取当前时间。
      static OffsetTime of​(int hour, int minute, int second, int nanoOfSecond, ZoneOffset offset)
      从一小时，分钟，秒和纳秒获取 OffsetTime的实例。
      static OffsetTime of​(LocalTime time, ZoneOffset offset)
      从当地时间和偏移量获取 OffsetTime的实例。
      static OffsetTime ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 OffsetTime的实例。
      static OffsetTime parse​(CharSequence text)
      从文本字符串（例如 10:15:30+01:00获取 OffsetTime的实例。
      static OffsetTime parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 OffsetTime的实例。
      OffsetTime plus​(long amountToAdd, TemporalUnit unit)
      返回此时添加了指定数量的副本。
      OffsetTime plus​(TemporalAmount amountToAdd)
      返回此时添加了指定数量的副本。
      OffsetTime plusHours​(long hours)
      返回此 OffsetTime的副本，并附加指定的小时数。
      OffsetTime plusMinutes​(long minutes)
      返回此 OffsetTime的副本，并添加指定的分钟数。
      OffsetTime plusNanos​(long nanos)
      返回此 OffsetTime的副本， OffsetTime添加了指定的纳秒数。
      OffsetTime plusSeconds​(long seconds)
      返回此 OffsetTime的副本，并添加指定的秒数。
      <R> R query​(TemporalQuery<R> query)
      此时使用指定的查询进行查询。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      long toEpochSecond​(LocalDate date)
      将此 OffsetTime转换为1970-01-01T00：00：00Z的时代以来的秒数。
      LocalTime toLocalTime​()
      获取此日期时间的 LocalTime部分。
      String toString​()
      此次输出为 String ，如 10:15:30+01:00 。
      OffsetTime truncatedTo​(TemporalUnit unit)
      返回此 OffsetTime的副本，截断时间。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一次的时间量。
      OffsetTime with​(TemporalAdjuster adjuster)
      返回此次调整后的副本。
      OffsetTime with​(TemporalField field, long newValue)
      返回此时间的副本，并将指定的字段设置为新值。
      OffsetTime withHour​(int hour)
      返回此 OffsetTime的副本，并更改日期。
      OffsetTime withMinute​(int minute)
      返回此 OffsetTime的副本，小时改变。
      OffsetTime withNano​(int nanoOfSecond)
      返回这个 OffsetTime的副本，并修改了纳秒。
      OffsetTime withOffsetSameInstant​(ZoneOffset offset)
      返回具有指定偏移量的 OffsetTime的副本，确保结果在隐含日期处于同一时刻。
      OffsetTime withOffsetSameLocal​(ZoneOffset offset)
      返回具有指定偏移量的 OffsetTime的副本，确保结果具有相同的本地时间。
      OffsetTime withSecond​(int second)
      返回此 OffsetTime的副本，其中第二分钟更改。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN

        public static final OffsetTime MIN
        最低支持OffsetTime ：00：00 + 18：00'。 这是在最大偏移量的一天开始的午夜时间（更大的偏移在时间线上较早）。 这结合了LocalTime.MIN和ZoneOffset.MAX 。 应用程序可以将其用作“过去”的日期。

      • MAX

        public static final OffsetTime MAX
        最大支持OffsetTime ，'23：59：59.999999999-18：00'。 这是在最后偏移量的最后一天午夜之前的时间（较大的负偏移量稍后在时间线上）。 这结合了LocalTime.MAX和ZoneOffset.MIN 。 应用程序可以将其用作“远未来”的日期。

    • 方法详细信息

      • now

        public static OffsetTime now​()
        从默认时区的系统时钟获取当前时间。

        这将在默认时区查询system clock以获取当前时间。 偏移量将从时钟的时区计算。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前时间使用系统时钟和默认时区，不为空

      • now

        public static OffsetTime now​(ZoneId zone)
        从指定时区的系统时钟获取当前时间。

        这将查询system clock获取当前时间。 指定时区可以避免对默认时区的依赖。 偏移量将从指定的时区计算。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前时间使用系统时钟，不为空

      • now

        public static OffsetTime now​(Clock clock)
        从指定的时钟获取当前时间。

        这将查询指定的时钟以获取当前时间。 偏移量将从时钟的时区计算。

        使用此方法可以使用备用时钟进行测试。 替代时钟可以使用dependency injection引入。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前时间，不为null

      • of

        public static OffsetTime of​(LocalTime time,
                            ZoneOffset offset)
        从当地时间和偏移量获取 OffsetTime的实例。
        参数
        time - 当地时间，不为空
        offset - 区域偏移，不为空
        结果
        偏移时间，不为空

      • of

        public static OffsetTime of​(int hour,
                            int minute,
                            int second,
                            int nanoOfSecond,
                            ZoneOffset offset)
        从一小时，分钟，秒和纳秒获取OffsetTime的实例。

        这将为四个指定的字段创建一个偏移时间。

        该方法主要用于编写测试用例。 非测试代码通常会使用其他方法来创建一个偏移时间。 LocalTime有两个额外的方便的变体，相当的工厂方法采用较少的参数。 在这里不提供它们来减少API的占用空间。

        参数
        hour - 代表从0到23的小时
        minute - 从0到59表示的小时
        second - 从0到59的秒表示
        nanoOfSecond - 表示从0到999,999,999的纳秒
        offset - 区域偏移，不为空
        结果
        偏移时间，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围

      • ofInstant

        public static OffsetTime ofInstant​(Instant instant,
                                   ZoneId zone)
        从Instant和区域ID获取OffsetTime的实例。

        这将产生与指定的相同时间的偏移时间。 找到UTC /格林威治的偏移量很简单，因为每个瞬间只有一个有效的偏移量。

        在转换期间，该瞬间的日期组件被丢弃。 这意味着转换永远不会因为瞬间超出有效的日期范围而失败。

        参数
        instant - 即时创建时间，不为null
        zone - 可能是偏移的时区，不为空
        结果
        偏移时间，不为空

      • from

        public static OffsetTime from​(TemporalAccessor temporal)
        从时间对象获取OffsetTime的实例。

        这获得了基于指定时间的偏移时间。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为OffsetTime一个实例。

        转换提取并从时间对象中组合ZoneOffset和LocalTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考OffsetTime::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        偏移时间，不为空
        异常
        DateTimeException - 如果无法转换为 OffsetTime

      • parse

        public static OffsetTime parse​(CharSequence text)
        从文本字符串（例如10:15:30+01:00获取OffsetTime的实例。

        字符串必须表示有效时间，并使用DateTimeFormatter.ISO_OFFSET_TIME进行解析。

        参数
        text - 要解析的文本，如“ text + 01：00”，不为空
        结果
        解析当地时间，不为空
        异常
        DateTimeParseException - 如果文本无法解析

      • parse

        public static OffsetTime parse​(CharSequence text,
                               DateTimeFormatter formatter)
        从使用特定格式化程序的文本字符串获取OffsetTime的实例。

        使用格式化程序解析文本，返回一个时间。

        参数
        text - 要解析的文本，不为空
        formatter - 要使用的格式化程序，不为null
        结果
        解析的偏移时间，不为null
        异常
        DateTimeParseException - 如果文本无法解析

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查此时间是否可以查询指定的字段。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 支持的字段有：

        • NANO_OF_SECOND
        • NANO_OF_DAY
        • MICRO_OF_SECOND
        • MICRO_OF_DAY
        • MILLI_OF_SECOND
        • MILLI_OF_DAY
        • SECOND_OF_MINUTE
        • SECOND_OF_DAY
        • MINUTE_OF_HOUR
        • MINUTE_OF_DAY
        • HOUR_OF_AMPM
        • CLOCK_HOUR_OF_AMPM
        • HOUR_OF_DAY
        • CLOCK_HOUR_OF_DAY
        • AMPM_OF_DAY
        • OFFSET_SECONDS
        所有其他ChronoField实例将返回false。

        如果该字段不是ChronoField ，则通过调用TemporalField.isSupportedBy(TemporalAccessor)通过this作为参数获得该方法的结果。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果此时支持该字段，则为true，否则为false

      • isSupported

        public boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定的单位是否可以添加到该偏移时间或从该偏移时间中减去。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        如果单位是ChronoUnit，那么查询是在这里实现的。 支持的单位是：

        • NANOS
        • MICROS
        • MILLIS
        • SECONDS
        • MINUTES
        • HOURS
        • HALF_DAYS
        所有其他ChronoUnit实例将返回false。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 这次用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果不能获得该字段的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持

      • get

        public int get​(TemporalField field)
        从此时间获取指定字段的值为int 。

        此时会查询指定字段的值。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回基于此时间的有效值，除了NANO_OF_DAY和MICRO_OF_DAY ，它们太大，无法适应int并抛出UnsupportedTemporalTypeException 。 所有其他ChronoField实例都会抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从这个时间获取指定字段的值为long 。

        此时会查询指定字段的值。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将基于此时间返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • getOffset

        public ZoneOffset getOffset​()
        获取区域偏移量，例如“+01：00”。

        这是当地时间与UTC /格林威治的抵消。

        结果
        区域偏移，不为空

      • withOffsetSameLocal

        public OffsetTime withOffsetSameLocal​(ZoneOffset offset)
        以指定的偏移量返回此OffsetTime的副本，确保结果具有相同的本地时间。

        此方法返回一个具有相同的对象LocalTime和指定的ZoneOffset 。 不需要或执行计算。 例如，如果此时间表示10:30+02:00并且指定的偏移量为+03:00 ，则此方法将返回10:30+03:00 。

        要考虑到偏差之间的差异，并调整时间字段，请使用withOffsetSameInstant(java.time.ZoneOffset) 。

        此实例是不可变的，不受此方法调用的影响。

        参数
        offset - 要更改的区域偏移量，不为空
        结果
        一个 OffsetTime基于这个时间与请求的偏移量，不为null

      • withOffsetSameInstant

        public OffsetTime withOffsetSameInstant​(ZoneOffset offset)
        返回具有指定偏移量的OffsetTime的副本，确保结果在隐含日期处于同一时刻。

        此方法返回一个具有指定的对象ZoneOffset和LocalTime由两个偏移之间的差异进行调整。 这将导致旧的和新的对象在默示的一天代表同一瞬间。 这对于在不同的偏移量中找到本地时间是有用的。 例如，如果此时间表示10:30+02:00并且指定的偏移量为+03:00 ，则此方法将返回11:30+03:00 。

        要更改偏移量而不调整本地时间，请使用withOffsetSameLocal(java.time.ZoneOffset) 。

        此实例是不可变的，不受此方法调用的影响。

        参数
        offset - 要更改的区域偏移量，不为空
        结果
        一个 OffsetTime基于此时间与请求的偏移量，不为null

      • toLocalTime

        public LocalTime toLocalTime​()
        获得这个日期时间的LocalTime部分。

        这将返回一个LocalTime与这个日期时间相同的小时，分，秒和纳秒。

        结果
        这个日期时间的一部分，不是null

      • getHour

        public int getHour​()
        获取时间字段。
        结果
        时间从0到23

      • getMinute

        public int getMinute​()
        获取小时字段。
        结果
        分钟，从0到59

      • getSecond

        public int getSecond​()
        获得第二分钟的字段。
        结果
        第二分钟，从0到59

      • getNano

        public int getNano​()
        获得纳秒第二场。
        结果
        纳秒，从0到999,999,999

      • with

        public OffsetTime with​(TemporalAdjuster adjuster)
        返回此次调整后的副本。

        这返回一个OffsetTime ，基于这个，随着时间的推移。 调整使用指定的调整器策略对象进行。 阅读调整器的文档，了解将进行什么调整。

        一个简单的调整器可以简单地设置一个字段，如小时字段。 更复杂的调整器可能会将时间设置为一天中的最后一个小时。

        类LocalTime和ZoneOffset实现TemporalAdjuster ，因此该方法可用于改变时间或偏移量：

          result = offsetTime.with(time);
  result = offsetTime.with(offset);

        该方法的结果是通过在指定的调整器通过this作为参数调用TemporalAdjuster.adjustInto(Temporal)方法获得的。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        一个 OffsetTime基于 this进行了调整，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        public OffsetTime with​(TemporalField field,
                       long newValue)
        返回此时间的副本，并将指定的字段设置为新值。

        这将返回一个OffsetTime ，基于此，更改指定字段的值。 这可以用于更改任何支持的字段，如小时，分钟或秒。 如果不可能设置该值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，则在此处执行调整。

        OFFSET_SECONDS字段将返回指定偏移量的时间。 当地时间不变。 如果新的偏移值超出有效范围，则抛出DateTimeException 。

        其他supported fields将按照LocalTime.with(TemporalField, long) LocalTime }上的匹配方法进行操作 。 在这种情况下，偏移不是计算的一部分，将不会改变。

        所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.adjustInto(Temporal, long)传递this作为参数。 在这种情况下，该字段决定是否以及如何调整即时。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        一个 OffsetTime基于 this与指定的字段集，不为null
        异常
        DateTimeException - 如果该字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • withHour

        public OffsetTime withHour​(int hour)
        返回此OffsetTime的副本，并更改日期。

        偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hour - 设置结果的时间从0到23
        结果
        一个 OffsetTime基于此时间与请求的小时，不为null
        异常
        DateTimeException - 如果小时值无效

      • withMinute

        public OffsetTime withMinute​(int minute)
        返回此OffsetTime的副本，小时更改。

        偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minute - 结果中设置的小时从0到59
        结果
        一个 OffsetTime基于此时间与请求的分钟，不为null
        异常
        DateTimeException - 如果分钟值无效

      • withSecond

        public OffsetTime withSecond​(int second)
        返回此OffsetTime的副本，其中第二分钟更改。

        偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        second - 在0到59之间设置结果的 second
        结果
        一个 OffsetTime基于此时与请求的第二个，不为null
        异常
        DateTimeException - 如果第二个值无效

      • withNano

        public OffsetTime withNano​(int nanoOfSecond)
        返回这个OffsetTime的副本， OffsetTime改变了。

        偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanoOfSecond - 纳秒在结果中设置，从0到999,999,999
        结果
        一个 OffsetTime基于这个时间与请求的纳秒，不为null
        异常
        DateTimeException - 如果 DateTimeException值无效

      • truncatedTo

        public OffsetTime truncatedTo​(TemporalUnit unit)
        返回此OffsetTime的副本，截断时间。

        截断返回原始时间的副本，其中小于指定单位的字段设置为零。 例如，使用minutes单位进行截断将将第二分钟和纳秒的字段设置为零。

        该单位必须有一个duration ，划分为标准日期的长度， 无余数。 这包括所有提供的时间单位ChronoUnit和DAYS 。 其他单位抛出异常。

        偏移量不影响计算，结果将相同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        unit - 截断到的单位，不为null
        结果
        一个 OffsetTime基于此时间截断，不为null
        异常
        DateTimeException - 如果无法截断
        UnsupportedTemporalTypeException - 如果不支持本机

      • plus

        public OffsetTime plus​(TemporalAmount amountToAdd)
        返回此时添加了指定数量的副本。

        这将返回一个OffsetTime ，基于此，添加了指定的数量。 金额通常为Duration，但可能是实现TemporalAmount界面的任何其他类型。

        通过调用TemporalAmount.addTo(Temporal)将计算委托给金额对象。 数量执行可以以任何方式实现添加，但是它通常会调用到plus(long, TemporalUnit) 。 请参阅金额执行的文档，以确定是否可以成功添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 OffsetTime基于这个时间与添加，而不是null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        public OffsetTime plus​(long amountToAdd,
                       TemporalUnit unit)
        返回此时添加了指定数量的副本。

        这将返回一个OffsetTime ，基于这一个，以添加的单位计算的金额。 如果不可能添加金额，因为单位不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoUnit，则添加由LocalTime.plus(long, TemporalUnit)实现。 偏移量不是计算的一部分，结果将不变。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为参数。 在这种情况下，单元确定是否以及如何执行添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加到结果中的单位数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        一个 OffsetTime基于这个时间与指定的数量添加，不为null
        异常
        DateTimeException - 如果不能添加
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusHours

        public OffsetTime plusHours​(long hours)
        返回此OffsetTime的副本，并附加指定的小时数。

        这样就增加了指定的小时数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hours - 要添加的时间可能为负数
        结果
        一个 OffsetTime基于这个时间加上小时，不为null

      • plusMinutes

        public OffsetTime plusMinutes​(long minutes)
        以指定的分钟数返回此OffsetTime的副本。

        这样就添加了指定的分钟数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutes - 要添加的分钟，可能为负数
        结果
        一个 OffsetTime基于这个时间加上分钟，不为null

      • plusSeconds

        public OffsetTime plusSeconds​(long seconds)
        返回此OffsetTime的副本，并添加指定的秒数。

        这样就增加了指定的秒数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        seconds - 添加的秒数可能为负数
        结果
        一个 OffsetTime基于这个时间与秒添加，不为null

      • plusNanos

        public OffsetTime plusNanos​(long nanos)
        返回此OffsetTime的副本， OffsetTime添加了指定的纳秒数。

        这样就增加了指定的纳秒数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanos - nanos添加，可能为负
        结果
        一个 OffsetTime基于这个时间加上纳秒，不为null

      • minus

        public OffsetTime minus​(TemporalAmount amountToSubtract)
        返回此次的副本，减去指定的金额。

        这将返回一个OffsetTime ，基于此，减去指定的数量。 金额通常为Duration，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.subtractFrom(Temporal)将计算委托给金额对象。 数量执行可以以任何方式自由实现减法，但通常可以回调到minus(long, TemporalUnit) 。 请参阅数量执行的文档，以确定是否可以成功减去它们。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去量，不为空
        结果
        一个 OffsetTime基于这个时间与减法而不是null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        public OffsetTime minus​(long amountToSubtract,
                        TemporalUnit unit)
        返回此次的副本，减去指定的金额。

        这将返回一个OffsetTime ，基于这一个，减去的单位数量。 如果不可能减去金额，因为该单位不受支持或出于某种其他原因，则会抛出异常。

        该方法相当于plus(long, TemporalUnit) ，数量被否定。 请参阅该方法，以了解如何添加，从而减去运算。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 从结果中减去单位的数量可能为负数
        unit - 减去量的单位，不为空
        结果
        一个 OffsetTime基于此时间减去指定的数量，不为null
        异常
        DateTimeException - 如果不能进行减法
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minusHours

        public OffsetTime minusHours​(long hours)
        返回此OffsetTime的副本，并减去指定的小时数。

        这样从这个时间减去指定的小时数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hours - 减去的时间可能为负数
        结果
        一个 OffsetTime基于此时间减去的小时数，不为空

      • minusMinutes

        public OffsetTime minusMinutes​(long minutes)
        以指定的分钟数减去此OffsetTime的副本。

        这将从此时间减去指定的分钟数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutes - 减去的分数可能为负数
        结果
        一个 OffsetTime基于此时间减去了分数，不为null

      • minusSeconds

        public OffsetTime minusSeconds​(long seconds)
        返回此OffsetTime的副本，并减去指定的秒数。

        从此时间减去指定的秒数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        seconds - 减去的秒数可能为负数
        结果
        一个 OffsetTime基于此时间减去秒，不为空

      • minusNanos

        public OffsetTime minusNanos​(long nanos)
        返回此OffsetTime的副本，减去指定的纳秒数。

        从这个时间减去指定的纳秒数，返回一个新的时间。 计算周期在午夜。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanos - nanos减去，可能是负数
        结果
        一个 OffsetTime基于此时间减去纳秒，不为零

      • query

        public <R> R query​(TemporalQuery<R> query)
        此时使用指定的查询进行查询。

        这样可以使用指定的查询策略对象查询此时间。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过调用TemporalQuery.queryFrom(TemporalAccessor)方法，通过this作为参数的指定查询。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象与此对象具有相同的偏移量和时间。

        这返回与具有偏移和时间的输入相同的可观察类型的时间对象与此相同。

        调整相当于使用Temporal.with(TemporalField, long)两次，通过ChronoField.NANO_OF_DAY和ChronoField.OFFSET_SECONDS作为字段。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisOffsetTime.adjustInto(temporal);
   temporal = temporal.with(thisOffsetTime);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果无法进行调整
        ArithmeticException - 如果发生数字溢出

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        根据指定的单位计算直到另一次的时间量。

        这可以计算一个OffsetTime对象之间的时间量，单个TemporalUnit 。 起点和终点分别为this和指定时间。 如果结束在开始之前，结果将为负数。 例如，两次之间的小时数可以使用startTime.until(endTime, HOURS)计算。

        所述Temporal传递给此方法被转换为OffsetTime使用from(TemporalAccessor) 。 如果偏移量在两次之间不同，则指定的结束时间被归一化为与此时间相同的偏移量。

        计算返回一个整数，表示两次之间的完整单位数。 例如，11：30Z至13：29Z之间的小时数将仅为1小时，为2分钟不到2分钟。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MINUTES);
   amount = MINUTES.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        计算方法为ChronoUnit 。 单位NANOS ， MICROS ， MILLIS ， SECONDS ， MINUTES ， HOURS和HALF_DAYS的支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束时间，排他，转换为 OffsetTime ，不为空
        unit - 衡量金额的单位，不为空
        结果
        这段时间与结束时间之间的时间量
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 OffsetTime
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • format

        public String format​(DateTimeFormatter formatter)
        此时使用指定的格式化程序格式化。

        这一次将被传递给格式化程序来生成一个字符串。

        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的时间字符串，不为null
        异常
        DateTimeException - 打印时是否发生错误

      • atDate

        public OffsetDateTime atDate​(LocalDate date)
        结合这个时间与日期创建一个OffsetDateTime 。

        这将返回从此时间和指定日期形成的OffsetDateTime 。 日期和时间的所有可能的组合都是有效的。

        参数
        date - 要结合的日期，不为空
        结果
        从该时间和指定日期形成的偏移日期时间，不为空

      • toEpochSecond

        public long toEpochSecond​(LocalDate date)
        将此OffsetTime转换为1970-01-01T00：00：00Z的时代以来的秒数。

        这将此偏移时间与指定的日期相结合，以计算从1970-01-01T00：00：00Z起的经过秒数的历元秒数值。 时代之后的时代的实体是积极的，较早的是负的。

        参数
        date - localdate，not null
        结果
        从1970-01-01T00：00：00Z开始的秒数可能为负数
        从以下版本开始：
        9

      • compareTo

        public int compareTo​(OffsetTime other)
        比较这个OffsetTime到另一个时间。

        比较首先是基于UTC等效瞬间，然后在当地时间。 它与“等于”一致，由Comparable定义。

        例如，以下是比较器顺序：

        1. 10:30+01:00
        2. 11:00+01:00
        3. 12:00+02:00
        4. 11:30+01:00
        5. 12:00+01:00
        6. 12:30+01:00
        值2和＃3表示时间线上相同的时刻。 当两个值表示相同的时刻时，比较本地时间以区分它们。 需要这一步才能使订购符合equals() 。

        要比较两个TemporalAccessor实例的基本本地时间，请使用ChronoField.NANO_OF_DAY作为比较器。

        Specified by:
        compareTo在接口 Comparable<OffsetTime>
        参数
        other - 其他时间比较，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        public boolean isAfter​(OffsetTime other)
        检查此OffsetTime是否在指定的时间之后，将两次都应用到通用日期。

        该方法与compareTo(java.time.OffsetTime)中的比较不同之处仅在于比较时间的瞬间。 这相当于使用相同的日期将时间转换为即时，并将时刻进行比较。

        参数
        other - 其他时间比较，不是null
        结果
        如果这是在指定时间之后的时间，则为true

      • isBefore

        public boolean isBefore​(OffsetTime other)
        检查此OffsetTime是否在指定的时间之前，将两次都应用到通用日期。

        该方法与compareTo(java.time.OffsetTime)中的比较不同之处在于它只比较了时间的瞬间。 这相当于使用相同的日期将时间转换为即时，并将时刻进行比较。

        参数
        other - 其他时间比较，不为null
        结果
        如果这是在指定时间的时间之前，则为true

      • isEqual

        public boolean isEqual​(OffsetTime other)
        检查此OffsetTime是否等于将两次应用于公共日期的指定时间。

        该方法与compareTo(java.time.OffsetTime)和equals(java.lang.Object)中的比较不同之处在于它只比较了时刻。 这相当于使用相同的日期将时间转换为即时，并将时刻进行比较。

        参数
        other - 其他时间比较，不为null
        结果
        如果这等于指定时间的时间，则为true

      • equals

        public boolean equals​(Object obj)
        检查这次是否等于另一次。

        比较是基于本地时间和偏移量。 要在时间线上比较相同的时间，请使用isEqual(OffsetTime) 。

        只比较OffsetTime类型的对象，其他类型返回false。 要比较两个TemporalAccessor实例的基本本地时间，请使用ChronoField.NANO_OF_DAY作为比较器。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他时间，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个时候的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        此时输出为String ，如10:15:30+01:00 。

        输出将是以下ISO-8601格式之一：

        • HH:mmXXXXX
        • HH:mm:ssXXXXX
        • HH:mm:ss.SSSXXXXX
        • HH:mm:ss.SSSSSSXXXXX
        • HH:mm:ss.SSSSSSSSSXXXXX
        所使用的格式将是将省略部分隐含为零的时间的全部值输出的最短。
        重写：
        toString在 Object
        结果
        这个时间的字符串表示，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Period (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class Period

  • java.lang.Object
    • java.time.Period
  • All Implemented Interfaces:
    Serializable ， ChronoPeriod ， TemporalAmount

    public final class Period
extends Object
implements ChronoPeriod, Serializable
    ISO-8601日历系统中的日期时间，例如“2年3个月4天”。

    这个课程以年，月和日为单位建立数量或时间量。 请参阅Duration的时间相当于此类。

    在ZonedDateTime加入夏令时期间，持续时间和时间不同。 A Duration将添加确切的秒数，因此一天的持续时间总是24小时。 相比之下， Period将增加一个概念日，试图维持当地时间。

    例如，在夏令时间之前，请考虑在晚上添加一天的时间和一天的时间到18:00。 Period将在第二天的18:00添加概念日，结果为ZonedDateTime 。 相比之下， Duration将正好添加24小时，从而在ZonedDateTime的19:00（假设一小时的DST差距）产生了ZonedDateTime 。

    一段时间的支持单位为YEARS ， MONTHS和DAYS 。 所有三个字段始终存在，但可以设置为零。

    ISO-8601日历系统是当今世界绝大多数的现代民用日历系统。 它相当于今天的闰年规则一直适用于日常生活的公历日历系统。

    这个时期被模拟为一定的时间量，这意味着该时期的各个部分可能是负面的。

    这是一个value-based课; 在Period实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Period ZERO
      一个常数为零。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal addTo​(Temporal temporal)
      将此时段添加到指定的时间对象。
      static Period between​(LocalDate startDateInclusive, LocalDate endDateExclusive)
      获得一个 Period包括两个日期之间的年数，月份和日期。
      boolean equals​(Object obj)
      检查此期间是否等于另一期间。
      static Period from​(TemporalAmount amount)
      从时间量获取 Period的实例。
      long get​(TemporalUnit unit)
      获取所请求单元的值。
      IsoChronology getChronology​()
      获得这个时期的年表，即ISO日历系统。
      int getDays​()
      获得此期间的天数。
      int getMonths​()
      获取此期间的月数。
      List<TemporalUnit> getUnits​()
      获取此期间支持的单位集。
      int getYears​()
      获得这段时间的年数。
      int hashCode​()
      此期间的哈希码。
      boolean isNegative​()
      检查此期间的三个单位是否为负。
      boolean isZero​()
      检查此期间的所有三个单位是否为零。
      Period minus​(TemporalAmount amountToSubtract)
      返回此期间的副本，并减去指定的时间段。
      Period minusDays​(long daysToSubtract)
      返回此期间的副本，并减去指定的天数。
      Period minusMonths​(long monthsToSubtract)
      返回此期间的副本，减去指定的月份。
      Period minusYears​(long yearsToSubtract)
      返回此期间的副本，并减去指定的年数。
      Period multipliedBy​(int scalar)
      返回一个新的实例，该时间段中的每个元素乘以指定的标量。
      Period negated​()
      返回一个新的实例，每个金额在此期间被否定。
      Period normalized​()
      返回此期间的副本，其中标准化了几年和几个月。
      static Period of​(int years, int months, int days)
      获得 Period代表几年，几个月和几天。
      static Period ofDays​(int days)
      获得代表天数的 Period 。
      static Period ofMonths​(int months)
      获得代表数月的 Period 。
      static Period ofWeeks​(int weeks)
      获得代表数周的 Period 。
      static Period ofYears​(int years)
      获得代表多年的 Period 。
      static Period parse​(CharSequence text)
      获得 Period从文本字符串，如 PnYnMnD 。
      Period plus​(TemporalAmount amountToAdd)
      返回指定期间添加的此期间的副本。
      Period plusDays​(long daysToAdd)
      返回添加指定日期的此期间的副本。
      Period plusMonths​(long monthsToAdd)
      返回添加指定月份的此期间的副本。
      Period plusYears​(long yearsToAdd)
      返回添加指定年份的此期间的副本。
      Temporal subtractFrom​(Temporal temporal)
      从指定的时间对象中减去这个时间段。
      String toString​()
      将此期间输出为 String ，如 P6Y3M1D 。
      long toTotalMonths​()
      获得此期间的总月数。
      Period withDays​(int days)
      以指定的天数返回此期间的副本。
      Period withMonths​(int months)
      以指定的月数返回此期间的副本。
      Period withYears​(int years)
      以指定的年数返回此期间的副本。

      • Methods inherited from interface java.time.chrono.ChronoPeriod

        between

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ZERO

        public static final Period ZERO
        一个常数为零。

    • 方法详细信息

      • ofYears

        public static Period ofYears​(int years)
        获得代表多年的Period 。

        由此产生的期间将有特定的年份。 月份和日期单位将为零。

        参数
        years - 正数或负数的年数
        结果
        几年的时间，不为零

      • ofMonths

        public static Period ofMonths​(int months)
        获得代表数月的Period 。

        所产生的期间将有指定的月份。 年和日单位为零。

        参数
        months - 正数或负数的月数
        结果
        几个月的时间，不为零

      • ofWeeks

        public static Period ofWeeks​(int weeks)
        获得代表数周的Period 。

        所产生的期间将以日为单位，天数等于周数乘以7.年和月单位为零。

        参数
        weeks - 周数，正数或负数
        结果
        期间，输入周转换为天，不为空

      • ofDays

        public static Period ofDays​(int days)
        获得Period代表天数。

        所产生的期间将有指定的日期。 年和月单位将为零。

        参数
        days - 天数，正数或负数
        结果
        时间段，不为空

      • of

        public static Period of​(int years,
                        int months,
                        int days)
        获得Period代表几年，几个月和几天。

        这将创建一个基于几年，几个月和几天的实例。

        参数
        years - 年数，可能为负数
        months - 月数，可能为负数
        days - 天数，可能为负数
        结果
        几年，几个月和几天的时间，不为零

      • from

        public static Period from​(TemporalAmount amount)
        从时间量获取Period的实例。

        这取决于指定金额的期限。 A TemporalAmount表示这个工厂提取给Period的时间量，可以是基于日期或时间的。

        该转换围绕该单位的数量循环 ，并使用YEARS,MONTHS和DAYS单位创建期间。 如果找到任何其他单位，则会抛出异常。

        如果金额是ChronoPeriod那么它必须使用ISO年表。

        参数
        amount - 转换的时间量，不为空
        结果
        等效期，不为空
        异常
        DateTimeException - 如果无法转换为 Period
        ArithmeticException - 如果年，月或日数超过int

      • parse

        public static Period parse​(CharSequence text)
        获得Period从文本字符串，如PnYnMnD 。

        这将解析由所生成的字符串toString()这是基于ISO-8601格式的周期PnYnMnD和PnW 。

        字符串以可选符号开头，由ASCII负号或正号表示。 如果是负面的，整个时期都是否定的。 ASCII字母“P”接下来是大写或小写。 然后有四个部分，每个部分由数字和后缀组成。 四个部分中至少有一个必须存在。 这些部分的年份，月，周和日的ASCII为“Y”，“M”，“W”和“D”，后缀为大写或小写。 后缀必须按顺序排列。 每个部分的编号部分必须由ASCII数字组成。 该数字可能以ASCII正或负号为前缀。 该号码必须解析为int 。

        其他单位的前加/减号和负值不属于ISO-8601标准。 此外，ISO-8601不允许混合PnYnMnD和PnW格式。 任何基于周的输入乘以7，并将其视为天数。

        例如，以下是有效的输入：

          "P2Y"             -- Period.ofYears(2)
   "P3M"             -- Period.ofMonths(3)
   "P4W"             -- Period.ofWeeks(4)
   "P5D"             -- Period.ofDays(5)
   "P1Y2M3D"         -- Period.of(1, 2, 3)
   "P1Y2M3W4D"       -- Period.of(1, 2, 25)
   "P-1Y2M"          -- Period.of(-1, 2, 0)
   "-P1Y2M"          -- Period.of(-1, -2, 0)
        参数
        text - 要解析的文本，不为null
        结果
        被解析的时期，不为零
        异常
        DateTimeParseException - 如果文本无法解析为一段时间

      • between

        public static Period between​(LocalDate startDateInclusive,
                             LocalDate endDateExclusive)
        获得一个Period包括两个日期之间的年数，月份和日期。

        包含开始日期，但结束日期不是。 通过删除完整的月份计算该期间，然后计算剩余天数，进行调整，以确保两者都具有相同的符号。 然后根据12个月的时间将月数分为几年和几个月。 如果结束日期的月份大于或等于开始的日期，则会考虑一个月。 例如，从2010-01-15到2011-03-18是一年，两个月三天。

        如果结束在开始之前，该方法的结果可以是负期。 每年，每月的负号将相同。

        参数
        startDateInclusive - 开始日期，包括，不为空
        endDateExclusive - 结束日期，排他，不为空
        结果
        此日期与结束日期之间的期间不为空
        另请参见：
        ChronoLocalDate.until(ChronoLocalDate)

      • get

        public long get​(TemporalUnit unit)
        获取所请求单元的值。

        这将返回这三个支持单位，值YEARS ， MONTHS和DAYS 。 所有其他单位抛出异常。

        Specified by:
        get在接口 ChronoPeriod
        Specified by:
        get在接口 TemporalAmount
        参数
        unit - TemporalUnit返回值的 TemporalUnit
        结果
        单位的长期价值
        异常
        DateTimeException - 如果不支持本机
        UnsupportedTemporalTypeException - 如果不支持本机

      • getUnits

        public List<TemporalUnit> getUnits​()
        获取此期间支持的单位集。

        支持的单位是YEARS ， MONTHS和DAYS 。 他们按照年，月，日的顺序退回。

        该集合可以与get(TemporalUnit)一起使用以访问整个期间的状态。

        Specified by:
        getUnits在接口 ChronoPeriod
        Specified by:
        getUnits在接口 TemporalAmount
        结果
        包含年份，月份和日期单位的列表，不为空

      • getChronology

        public IsoChronology getChronology​()
        获得这个时期的年表，即ISO日历系统。

        Chronology代表正在使用的日历系统。 ISO-8601日历系统是当今世界绝大多数的现代民用日历系统。 它相当于今天的闰年规则一直适用于日常生活的公历日历系统。

        Specified by:
        getChronology在接口 ChronoPeriod
        结果
        ISO年表，不为空

      • isZero

        public boolean isZero​()
        检查此期间的所有三个单位是否为零。

        零期间的年，月和日单位为零。

        Specified by:
        isZero在接口 ChronoPeriod
        结果
        如果这个时期是零长度，则为真

      • isNegative

        public boolean isNegative​()
        检查此期间的三个单位是否为负。

        这检查年，月或日单位是否小于零。

        Specified by:
        isNegative在接口 ChronoPeriod
        结果
        如果这个时期的任何一个单位都是负数，则为真

      • getYears

        public int getYears​()
        获得这段时间的年数。

        这返回年份单位。

        月份单位不会按年份单位自动标准化。 这意味着“15个月”与“1年3个月”不同。

        结果
        这个时期的年数可能是负数

      • getMonths

        public int getMonths​()
        获取此期间的月数。

        这返回月份单位。

        月份单位不会按年份单位自动标准化。 这意味着“15个月”与“1年3个月”不同。

        结果
        这个时期的月数可能是负数

      • getDays

        public int getDays​()
        获得此期间的天数。

        这将返回天数单位。

        结果
        此期间的天数可能为负数

      • withYears

        public Period withYears​(int years)
        以指定的年数返回此期间的副本。

        这设定了这个时期的副本的年数单位。 月和日单位不受影响。

        月份单位不会按年份单位自动标准化。 这意味着“15个月”与“1年3个月”不同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        years - 代表的年份，可能为负数
        结果
        一个 Period基于这个期间与要求的年份，不为null

      • withMonths

        public Period withMonths​(int months)
        以指定的月数返回此期间的副本。

        这设定了这个期间的副本的月份数量。 年和日单位不受影响。

        月份单位不会按年份单位自动标准化。 这意味着“15个月”与“1年3个月”不同。

        此实例是不可变的，不受此方法调用的影响。

        参数
        months - 表示的月份可能为负数
        结果
        一个 Period基于此期间与请求的月份，不为null

      • withDays

        public Period withDays​(int days)
        以指定的天数返回此期间的副本。

        这将设置此期间副本的天数单位。 年和月单位不受影响。

        此实例是不可变的，不受此方法调用的影响。

        参数
        days - 代表的日子，可能是负面的
        结果
        一个 Period基于此期间与请求的天，不为null

      • plus

        public Period plus​(TemporalAmount amountToAdd)
        返回指定期间添加的此期间的副本。

        这在几年，几个月和几天内分开运作。 不执行归一化。

        例如“1年6个月3天”加“2年2个月2天”返还“3年8个月5日”。

        指定数量通常为Period的实例。 其他类型使用from(TemporalAmount)进行解释。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 ChronoPeriod
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 Period基于此期间添加的请求期，不为null
        异常
        DateTimeException - 如果指定的数量具有非ISO年表或包含无效单位
        ArithmeticException - 如果发生数字溢出

      • plusYears

        public Period plusYears​(long yearsToAdd)
        返回添加指定年份的此期间的副本。

        这增加了这个期间的年份单位的数额。 月和日单位不受影响。 例如，“1年6个月3天”加上2年“3年6个月3天”。

        此实例是不可变的，不受此方法调用的影响。

        参数
        yearsToAdd - 增加的年份，正面或负面
        结果
        一个 Period基于这个时期与指定的年份添加，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • plusMonths

        public Period plusMonths​(long monthsToAdd)
        返回添加指定月份的此期间的副本。

        这将增加这个时期的副本中的月份单位的金额。 年和日单位不受影响。 例如，“1年6个月3天”加上2个月返回“1年8个月3天”。

        此实例是不可变的，不受此方法调用的影响。

        参数
        monthsToAdd - 增加的正数或负数
        结果
        一个 Period基于这个时期加上指定的月份，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • plusDays

        public Period plusDays​(long daysToAdd)
        返回添加指定日期的此期间的副本。

        这将增加此期间副本中的天数单位的金额。 年和月单位不受影响。 例如，“1年6个月3天”加上2天返回“1年6个月5天”。

        此实例是不可变的，不受此方法调用的影响。

        参数
        daysToAdd - 添加的日子，正面或负面
        结果
        一个 Period基于这个时期添加了指定的天数，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • minus

        public Period minus​(TemporalAmount amountToSubtract)
        返回此期间的副本，并减去指定的时间段。

        这在几年，几个月和几天内分开运作。 不执行归一化。

        例如，“1年6个月3天”减去“2年2个月2天”返回“1年4个月1天”。

        指定金额通常为Period的实例。 其他类型的解释使用from(TemporalAmount) 。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 ChronoPeriod
        参数
        amountToSubtract - 减去量，不为空
        结果
        一个 Period基于此期间减去所请求的期间，不为null
        异常
        DateTimeException - 如果指定的数量具有非ISO年表或包含无效单位
        ArithmeticException - 如果发生数字溢出

      • minusYears

        public Period minusYears​(long yearsToSubtract)
        返回此期间的副本，并减去指定的年数。

        这减去这个期间的年份单位的数额。 月和日单位不受影响。 例如，“1年6个月3天”减去2年后返回“-1年6个月3天”。

        此实例是不可变的，不受此方法调用的影响。

        参数
        yearsToSubtract - 减去正数或负数的年数
        结果
        一个 Period基于此期间与指定年减去，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • minusMonths

        public Period minusMonths​(long monthsToSubtract)
        返回此期间的副本，减去指定的月份。

        这减去这个期间的月份单位的金额。 年和日单位不受影响。 例如，“1年6个月3天”减去2个月返回“1年4个月3天”。

        此实例是不可变的，不受此方法调用的影响。

        参数
        monthsToSubtract - 减去正数或负数的年数
        结果
        一个 Period基于此期间减去指定的月份，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • minusDays

        public Period minusDays​(long daysToSubtract)
        返回此期间的副本，并减去指定的天数。

        这减去这个期间的日期单位的金额。 年和月单位不受影响。 例如，“1年6个月3天”减去2天返回“1年6个月1天”。

        此实例是不可变的，不受此方法调用的影响。

        参数
        daysToSubtract - 减数，正或负的月数
        结果
        一个 Period基于此期间减去指定的日期，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • multipliedBy

        public Period multipliedBy​(int scalar)
        返回一个新的实例，该时间段中的每个元素乘以指定的标量。

        这返回一个时期，每个年份，月份和日期单位分别乘以。 例如，“2年-3个月4天”乘以3将返回“6年-9个月12天”。 不执行归一化。

        Specified by:
        multipliedBy在接口 ChronoPeriod
        参数
        scalar - 要乘以的标量，不为空
        结果
        一个基于此期间的 Period ，其数量乘以标量，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • negated

        public Period negated​()
        返回一个新的实例，每个金额在此期间被否定。

        这返回一个时期，每个年份，几个月和几个单位各自被否定。 例如，“2年-3个月4天”将被否定为“-2年3个月-4日”。 不执行归一化。

        Specified by:
        negated在接口 ChronoPeriod
        结果
        一个 Period基于这个时期的数额被否定，不为零
        异常
        ArithmeticException - 如果发生数字溢出，只有当其中一个单位的值为 Long.MIN_VALUE时才会发生

      • normalized

        public Period normalized​()
        返回此期间的副本，其中标准化了几年和几个月。

        这使得几个月和几个月的单位正常化，使得日子单位不变。 月份单位调整为绝对值小于12，调整年份单位进行补偿。 例如，“1年零15个月”的时间将被规范化为“2年3个月”。

        正常化后，年份和月份单位的征兆将相同。 例如，“1年和-25个月”的时期将被规范化为“-1年和-1个月”。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        normalized在接口 ChronoPeriod
        结果
        一个 Period基于这个时期，超过几个月正常化为几年，不为零
        异常
        ArithmeticException - 如果发生数字溢出

      • toTotalMonths

        public long toTotalMonths​()
        获得此期间的总月数。

        通过将年数乘以12并添加月数，返回该期间的总月数。

        此实例是不可变的，不受此方法调用的影响。

        结果
        该期间的总月数可能为负数

      • addTo

        public Temporal addTo​(Temporal temporal)
        将此时段添加到指定的时间对象。

        这返回与添加了此周期的输入相同的可观察类型的时间对象。 如果时间有一个年表，它必须是ISO年表。

        在大多数情况下，通过使用Temporal.plus(TemporalAmount)来更正呼叫模式。

          // these two lines are equivalent, but the second approach is recommended
   dateTime = thisPeriod.addTo(dateTime);
   dateTime = dateTime.plus(thisPeriod);

        计算操作如下。 首先，检查时间的年表，以确保它是ISO年表或null。 第二，如果月份为零，则如果不为零，则添加年份，否则如果非零，则添加年份和月份的组合。 最后，添加任何日子。

        这种方法确保可以将部分期间添加到部分日期。 例如，可以在YearMonth添加一段时间和/或几个月，但包括天数在内的期间不能。 该方法在必要时还可以一起添加数年和数月，从而确保月底的正确行为。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        addTo在接口 ChronoPeriod
        Specified by:
        addTo在接口 TemporalAmount
        参数
        temporal - 要调整的时间对象，不为空
        结果
        与调整相同类型的对象，不为空
        异常
        DateTimeException - 如果无法添加
        ArithmeticException - 如果发生数字溢出

      • subtractFrom

        public Temporal subtractFrom​(Temporal temporal)
        从指定的时间对象中减去这个时间段。

        这返回与减去该周期的输入相同的可观察类型的时间对象。 如果时间有一个年表，它必须是ISO年表。

        在大多数情况下，通过使用Temporal.minus(TemporalAmount)来更改呼叫模式。

          // these two lines are equivalent, but the second approach is recommended
   dateTime = thisPeriod.subtractFrom(dateTime);
   dateTime = dateTime.minus(thisPeriod);

        计算操作如下。 首先，检查时间的年表，以确保它是ISO年表或null。 第二，如果月份为零，则如果非零则减去年份，否则如果非零，则减去年和月的组合。 最后，减去任何日子。

        这种方法确保可以从部分日期中减去部分期间。 例如，可以从YearMonth扣除一段时间和/或几个月，但包括天数在内的期间不能。 该方法在必要时也会一起减少数年和数月，从而确保月底的正确行为。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        subtractFrom在接口 ChronoPeriod
        Specified by:
        subtractFrom在接口 TemporalAmount
        参数
        temporal - 要调整的时间对象，不为空
        结果
        与调整相同类型的对象，不为空
        异常
        DateTimeException - 如果不能减去
        ArithmeticException - 如果发生数字溢出

      • equals

        public boolean equals​(Object obj)
        检查此期间是否等于另一期间。

        比较是基于Period的类型和三个金额中的每一个。 要平等，年，月和日单位必须是平等的。 请注意，这意味着“15个月”不等于“1年3个月”。

        Specified by:
        equals在接口 ChronoPeriod
        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他时期，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        此期间的哈希码。
        Specified by:
        hashCode在接口 ChronoPeriod
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        输出这个时期为String ，如P6Y3M1D 。

        输出的格式为ISO-8601。 零期将被表示为零天，“P0D”。

        Specified by:
        toString在接口 ChronoPeriod
        重写：
        toString在 Object
        结果
        此期间的字符串表示，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Package java.time (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.time

  • Packages that use java.time
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    jdk.incubator.http
    高级HTTP和WebSocket API
  • Classes in java.time used by java.lang
    Class 描述
    Duration
    基于时间的时间量，如'34.5秒'。
    Instant
    在时间线上的瞬间点。
  • Classes in java.time used by java.nio.file.attribute
    Class 描述
    Instant
    在时间线上的瞬间点。
  • Classes in java.time used by java.sql
    Class 描述
    Instant
    在时间线上的瞬间点。
    LocalDate
    在ISO- 2007-12-03 ，如 2007-12-03 。
    LocalDateTime
    在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
    LocalTime
    在ISO- 10:15:30 ，如 10:15:30 。
  • Classes in java.time used by java.time
    Class 描述
    Clock
    使用时区提供对当前即时，日期和时间的访问的时钟。
    DayOfWeek
    星期几，如“星期二”。
    Duration
    基于时间的时间量，如'34.5秒'。
    Instant
    在时间线上的瞬间点。
    LocalDate
    在ISO- 2007-12-03 ，如 2007-12-03 。
    LocalDateTime
    在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
    LocalTime
    在ISO- 10:15:30 ，如 10:15:30 。
    Month
    一个月，如“七月”。
    MonthDay
    ISO- --12-03 ，如 --12-03 。
    OffsetDateTime
    在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如 2007-12-03T10:15:30+01:00 。
    OffsetTime
    在ISO- 10:15:30+01:00 UTC /格林威治的时间，如 10:15:30+01:00 。
    Period
    ISO-8601日历系统中的日期时间，例如“2年3个月4天”。
    Year
    ISO- 2007 ，如 2007 。
    YearMonth
    在ISO- 2007-12 ，如 2007-12 。
    ZonedDateTime
    ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。
    ZoneId
    时区ID，如 Europe/Paris 。
    ZoneOffset
    与格林威治/ UTC的时区偏移，如 +02:00 。
  • Classes in java.time used by java.time.chrono
    Class 描述
    Clock
    使用时区提供对当前即时，日期和时间的访问的时钟。
    Instant
    在时间线上的瞬间点。
    LocalDate
    在ISO- 2007-12-03 ，如 2007-12-03 。
    LocalDateTime
    在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
    LocalTime
    在ISO- 10:15:30 ，如 10:15:30 。
    Period
    ISO-8601日历系统中的日期时间，例如“2年3个月4天”。
    ZonedDateTime
    ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。
    ZoneId
    时区ID，如 Europe/Paris 。
    ZoneOffset
    与格林威治/ UTC的时区偏移，如 +02:00 。
  • Classes in java.time used by java.time.format
    Class 描述
    DateTimeException
    用于在计算日期时间时指示问题的异常。
    Period
    ISO-8601日历系统中的日期时间，例如“2年3个月4天”。
    ZoneId
    时区ID，如 Europe/Paris 。
  • Classes in java.time used by java.time.temporal
    Class 描述
    DateTimeException
    用于在计算日期时间时指示问题的异常。
    DayOfWeek
    星期几，如“星期二”。
    Duration
    基于时间的时间量，如'34.5秒'。
    LocalDate
    在ISO- 2007-12-03 ，如 2007-12-03 。
    LocalTime
    在ISO- 10:15:30 ，如 10:15:30 。
    ZoneId
    时区ID，如 Europe/Paris 。
    ZoneOffset
    与格林威治/ UTC的时区偏移量，如 +02:00 。
  • Classes in java.time used by java.time.zone
    Class 描述
    DateTimeException
    用于在计算日期时间时指示问题的异常。
    DayOfWeek
    星期几，如“星期二”。
    Duration
    基于时间的时间量，如'34.5秒'。
    Instant
    在时间线上的瞬间点。
    LocalDateTime
    在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
    LocalTime
    在ISO- 10:15:30 ，如 10:15:30 。
    Month
    一个月，如“七月”。
    ZoneOffset
    与格林威治/ UTC的时区偏移，如 +02:00 。
  • Classes in java.time used by java.util
    Class 描述
    Instant
    在时间线上的瞬间点。
    ZonedDateTime
    ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。
    ZoneId
    时区ID，如 Europe/Paris 。
  • Classes in java.time used by java.util.logging
    Class 描述
    Instant
    在时间线上的瞬间点。
  • Classes in java.time used by java.util.zip
    Class 描述
    LocalDateTime
    在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
  • Classes in java.time used by javafx.scene.control
    Class 描述
    LocalDate
    在ISO- 2007-12-03 ，如 2007-12-03 。
  • Classes in java.time used by javafx.scene.control.skin
    Class 描述
    LocalDate
    在ISO- 2007-12-03 ，如 2007-12-03 。
  • Classes in java.time used by javafx.util.converter
    Class 描述
    LocalDate
    在ISO- 2007-12-03 ，如 2007-12-03 。
    LocalDateTime
    在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
    LocalTime
    在ISO- 10:15:30 ，如 10:15:30 。
  • Classes in java.time used by jdk.incubator.http
    Class 描述
    Duration
    基于时间的时间量，如'34.5秒'。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Year (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class Year

  • java.lang.Object
    • java.time.Year
  • All Implemented Interfaces:
    Serializable ， Comparable<Year> ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class Year
extends Object
implements Temporal, TemporalAdjuster, Comparable<Year>, Serializable
    一年在ISO- 2007 ，如2007 。

    Year是代表一年的不可变日期时间对象。 可以获得可以从一年派生的任何领域。

    请注意，ISO年代的年份只能符合现代几何时期的格里高利 - 朱利安系统。 俄罗斯部分地区直到1920年才转而使用现代公认的ISO法规。因此，必须谨慎对待历史年代。

    该类不存储或表示月，日，时间或时区。 例如，值“2007”可以存储在Year 。

    该类代表的年份遵循ISO-8601标准，并使用了准确的编号系统。 第1年之前是0年，然后是1年。

    ISO-8601日历系统是当今世界绝大多数的现代民用日历系统。 它相当于今天的闰年规则一直适用于日常生活的公历日历系统。 对于今天写的大多数应用，ISO-8601规则是完全合适的。 然而，任何利用历史日期并要求它们准确的应用程序都将发现ISO-8601方法不合适。

    这是一个value-based类; 在Year实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int MAX_VALUE
      最大支持年份为'+ 999,999,999'。
      static int MIN_VALUE
      最低支持年份为'-999,999,999'。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象到今年。
      LocalDate atDay​(int dayOfYear)
      今年与今年的合并创造了 LocalDate 。
      YearMonth atMonth​(int month)
      今年结合一个月创造 YearMonth 。
      YearMonth atMonth​(Month month)
      今年结合一个月创造 YearMonth 。
      LocalDate atMonthDay​(MonthDay monthDay)
      结合今年与一个月的日子，创造一个 LocalDate 。
      int compareTo​(Year other)
      今年再比较一年。
      boolean equals​(Object obj)
      检查今年是否等于另一年。
      String format​(DateTimeFormatter formatter)
      今年格式使用指定的格式化程序。
      static Year from​(TemporalAccessor temporal)
      从时间对象获取 Year的实例。
      int get​(TemporalField field)
      从今年获取指定字段的值作为 int 。
      long getLong​(TemporalField field)
      从今年获取指定字段的值作为 long 。
      int getValue​()
      获取年值。
      int hashCode​()
      今年的哈希码。
      boolean isAfter​(Year other)
      检查今年是否在指定的年份之后。
      boolean isBefore​(Year other)
      检查今年是否在指定年份之前。
      boolean isLeap​()
      根据ISO培训日历系统规则，检查年份是否是闰年。
      static boolean isLeap​(long year)
      根据ISO培训日历系统规则，检查年份是否是闰年。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean isValidMonthDay​(MonthDay monthDay)
      检查今年的月日是否有效。
      int length​()
      在几天内获得今年的长度。
      Year minus​(long amountToSubtract, TemporalUnit unit)
      返回今年的副本，减去指定的金额。
      Year minus​(TemporalAmount amountToSubtract)
      返回今年的副本，减去指定的金额。
      Year minusYears​(long yearsToSubtract)
      返回此 Year的副本，并减去指定的年数。
      static Year now​()
      从默认时区的系统时钟获取当前年份。
      static Year now​(Clock clock)
      从指定时钟获取当年。
      static Year now​(ZoneId zone)
      从指定时区的系统时钟获取当年。
      static Year of​(int isoYear)
      获得 Year的实例。
      static Year parse​(CharSequence text)
      从 2007等文本字符串获取 Year的实例。
      static Year parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 Year的实例。
      Year plus​(long amountToAdd, TemporalUnit unit)
      返回今年的副本，并附加指定的金额。
      Year plus​(TemporalAmount amountToAdd)
      返回今年的副本，并附加指定的金额。
      Year plusYears​(long yearsToAdd)
      返回添加了指定年数的 Year的副本。
      <R> R query​(TemporalQuery<R> query)
      今年查询使用指定的查询。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      String toString​()
      今年产量为 String 。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定单位计算直到另一年的时间。
      Year with​(TemporalAdjuster adjuster)
      返回今年的调整副本。
      Year with​(TemporalField field, long newValue)
      返回今年的副本，并将指定的字段设置为新值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN_VALUE

        public static final int MIN_VALUE
        最低支持年份为'-999,999,999'。
        另请参见：
        Constant Field Values

      • MAX_VALUE

        public static final int MAX_VALUE
        最大支持年份为'+ 999,999,999'。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • now

        public static Year now​()
        从默认时区的系统时钟获取当前年份。

        这将在默认时区中查询system clock以获取当前年份。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前使用系统时钟和默认时区，不为空

      • now

        public static Year now​(ZoneId zone)
        从指定时区的系统时钟获取当年。

        这将查询system clock获得当年。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当年使用系统时钟，不为空

      • now

        public static Year now​(Clock clock)
        从指定时钟获取当年。

        这将查询指定的时钟以获取当前年份。 使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        参数
        clock - 要使用的时钟，不为空
        结果
        当年，不为零

      • of

        public static Year of​(int isoYear)
        获得Year的实例。

        该方法接受来自光学ISO日历系统的年度值。

        2AD / CE年份由2代表。
        1AD / CE年份由1表示。
        1BC / BCE代表0。
        2BC / BCE代表-1。

        参数
        isoYear - ISO isoYear年代表，从 MIN_VALUE到 MAX_VALUE
        结果
        一年，不为零
        异常
        DateTimeException - 如果该字段无效

      • from

        public static Year from​(TemporalAccessor temporal)
        从时间对象获取一个Year的实例。

        这取决于指定时间的一年。 A TemporalAccessor表示任意的日期和时间信息集，该工厂转换为Year一个实例。

        该转换提取了year字段。 仅当时间对象具有ISO年表，或者可以转换为LocalDate ，才允许提取。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考Year::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        一年，不为零
        异常
        DateTimeException - 如果无法转换为 Year

      • parse

        public static Year parse​(CharSequence text)
        从2007等文本字符串获取Year的实例。

        字符串必须表示有效年份。 超出范围0000到9999之间的年份必须加上加号或减号。

        参数
        text - 要解析的文本，如“2007”，不为空
        结果
        被解析的年份，不为零
        异常
        DateTimeParseException - 如果文本无法解析

      • parse

        public static Year parse​(CharSequence text,
                         DateTimeFormatter formatter)
        使用特定的格式化程序从文本字符串获取Year的实例。

        使用格式化程序解析文本，返回一年。

        参数
        text - 要解析的文本，不为空
        formatter - 使用的格式化程序，不为空
        结果
        被解析的年份，不为零
        异常
        DateTimeParseException - 如果文本无法解析

      • isLeap

        public static boolean isLeap​(long year)
        根据ISO培训日历系统规则，检查年份是否是闰年。

        这种方法在整个时间线上应用目前的闰年规则。 一般来说，一年是一个闰年，如果没有余数可以被四分割。 但是，除了100岁之外，年份可以被分割为100岁，除了年龄可以被400除外。

        例如，1904年是一个闰年，可以被4整除。1900年不是一个闰年，因为它可以被100整除，然而2000年是一个闰年，因为它可以被400除数。

        计算是应激的 - 将相同的规则应用到远未来很远的地方。 这在历史上是不准确的，但对于ISO-8601标准是正确的。

        参数
        year - 检查年份
        结果
        如果一年是飞跃，否则为假

      • getValue

        public int getValue​()
        获取年值。

        通过这种方法返回的年份是根据get(YEAR) 。

        结果
        年， MIN_VALUE到 MAX_VALUE

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查今年是否可以查询指定的字段。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 支持的字段有：

        • YEAR_OF_ERA
        • YEAR
        • ERA
        所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果今年支持该字段，则为true，否则为false

      • isSupported

        public boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定的单位是否可以添加到今年或从今年减去。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        如果单位是ChronoUnit，那么查询是在这里实现的。 支持的单位是：

        • YEARS
        • DECADES
        • CENTURIES
        • MILLENNIA
        • ERAS
        所有其他ChronoUnit实例将返回false。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 今年用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持

      • get

        public int get​(TemporalField field)
        从今年获取指定字段的值作为int 。

        今年将查询指定字段的值。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，那么在这里实现查询。 supported fields将根据今年返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从今年获取指定字段的值作为long 。

        今年将查询指定字段的值。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，那么在这里实现查询。 supported fields将根据今年返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • isLeap

        public boolean isLeap​()
        根据ISO培训日历系统规则，检查年份是否是闰年。

        这种方法在整个时间线上应用目前的闰年规则。 一般来说，一年是一个闰年，如果没有余数可以被四分割。 但是，除了100岁之外，年份可以被分割为100岁，除了年龄可以被400除外。

        例如，1904年是一个闰年，可以被4整除。1900年不是一个闰年，因为它可以被100整除，然而2000年是一个闰年，因为它可以被400除数。

        计算是应激的 - 将相同的规则应用到远未来很远的地方。 这在历史上是不准确的，但对于ISO-8601标准是正确的。

        结果
        如果一年是飞跃，否则为假

      • isValidMonthDay

        public boolean isValidMonthDay​(MonthDay monthDay)
        检查今年的月日是否有效。

        此方法检查今年和输入的月份和日期是否形成有效日期。

        参数
        monthDay - 验证的月日，null返回false
        结果
        如果月和日在今年有效，则为真

      • length

        public int length​()
        在几天内获得今年的长度。
        结果
        今年的长短是365天或366天

      • with

        public Year with​(TemporalAdjuster adjuster)
        返回今年的调整副本。

        这返回一个Year ，基于这一个，随着年度的调整。 调整使用指定的调整器策略对象进行。 阅读调整器的文档，了解将进行什么调整。

        该方法的结果是通过调用TemporalAdjuster.adjustInto(Temporal)方法获得的指定调整器通过this作为参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        一个 Year基于 this进行了调整，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        public Year with​(TemporalField field,
                 long newValue)
        返回今年的副本，并将指定的字段设置为新值。

        这将返回一个Year ，基于此，更改指定字段的值。 如果不可能设置该值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，则在此处执行调整。 支持的字段的行为如下：

        • YEAR_OF_ERA - 返回具有特定年代的Year时代将不变。
        • YEAR - 返回指定年份的Year 。 这完全取代了日期，相当于of(int) 。
        • ERA - 返回指定时代的Year 。 年代不变。

        在所有情况下，如果新值超出该字段值的有效范围，则抛出DateTimeException 。

        所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.adjustInto(Temporal, long)传递this作为参数。 在这种情况下，该字段决定是否以及如何调整即时。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        一个 Year基于 this与指定的字段集，不为null
        异常
        DateTimeException - 如果该字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • plus

        public Year plus​(TemporalAmount amountToAdd)
        返回今年的副本，并附加指定的金额。

        这将返回一个Year ，基于此，添加指定的数量。 金额通常为Period，但可能是实现TemporalAmount界面的任何其他类型。

        通过调用TemporalAmount.addTo(Temporal)将计算委托给金额对象。 数量执行可以以任何方式实现添加，但是它通常会调用到plus(long, TemporalUnit) 。 请参阅金额执行的文档，以确定是否可以成功添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 Year基于今年添加，不为null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        public Year plus​(long amountToAdd,
                 TemporalUnit unit)
        返回今年的副本，并附加指定的金额。

        这将返回一个Year ，基于此，以添加的单位数量。 如果不可能添加金额，因为单位不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoUnit，那么在这里实现添加。 支持的字段的行为如下：

        • YEARS - 返回指定年数的Year 。 这相当于plusYears(long) 。
        • DECADES - 返回一个Year ，加上指定的几十年。 这相当于调用plusYears(long) ，数量乘以10。
        • CENTURIES - 返回一个Year ，加上指定的几个世纪。 这相当于调用plusYears(long) ，数量乘以100。
        • MILLENNIA - 返回一个Year ，加上指定的几千年。 这相当于调用plusYears(long) ，数量乘以1,000。
        • ERAS - 返回一个Year ，其中添加了指定的时间。 只支持两个时间，所以数量必须是1，零或者减1。 如果金额不是零，那么这个年份就会改变，使得年龄不变。

        所有其他ChronoUnit实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为参数。 在这种情况下，单元确定是否以及如何执行添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加到结果中的单位数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        一个 Year基于今年与指定的数量添加，不为null
        异常
        DateTimeException - 如果不能添加
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusYears

        public Year plusYears​(long yearsToAdd)
        返回此Year的副本，并附加指定的年数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        yearsToAdd - 多年来补充，可能是负数
        结果
        一个 Year基于今年加上多年，不为零
        异常
        DateTimeException - 如果结果超出了支持的范围

      • minus

        public Year minus​(TemporalAmount amountToSubtract)
        返回今年的副本，减去指定的金额。

        这将返回一个Year ，基于此，减去指定的数量。 金额通常为Period，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.subtractFrom(Temporal)将计算委托给金额对象。 数量执行可以以任何方式实现减法，但是它通常会回调到minus(long, TemporalUnit) 。 请参阅数量执行的文档，以确定是否可以成功减去它们。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去量，不为空
        结果
        一个 Year基于今年的减法而不是null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        public Year minus​(long amountToSubtract,
                  TemporalUnit unit)
        返回今年的副本，减去指定的金额。

        这将返回一个Year ，基于此，减去单位的数量。 如果不可能减去金额，因为该单位不受支持或出于某种其他原因，则会抛出异常。

        这种方法相当于plus(long, TemporalUnit) ，数量被否定。 请参阅该方法，以了解如何添加，从而减去运算。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 从结果中减去的单位数量可能为负数
        unit - 减去量的单位，不为空
        结果
        一个 Year基于今年减去指定的数量，不为null
        异常
        DateTimeException - 如果不能进行减法
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minusYears

        public Year minusYears​(long yearsToSubtract)
        返回此Year的副本，并减去指定的年数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        yearsToSubtract - 减去年份，可能为负数
        结果
        一个 Year基于今年减去年，不为零
        异常
        DateTimeException - 如果结果超出了支持的范围

      • query

        public <R> R query​(TemporalQuery<R> query)
        今年查询使用指定的查询。

        今年使用指定的查询策略对象查询。 TemporalQuery对象定义要用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在指定的查询this作为参数调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象到今年。

        这返回与年份变化相同的输入的相同可观察类型的时间对象。

        该调整是相当于使用Temporal.with(TemporalField, long)通过ChronoField.YEAR作为字段。 如果指定的时间对象不使用ISO日历系统，则抛出DateTimeException 。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisYear.adjustInto(temporal);
   temporal = temporal.with(thisYear);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        根据指定单位计算直到另一年的时间。

        这可以计算一个Year对象之间的时间量，单个TemporalUnit 。 起点和终点为this和指定年份。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为Year使用from(TemporalAccessor) 。 例如，可以使用startYear.until(endYear, DECADES)计算两年之间的数十年。

        计算返回一个整数，表示两年之间的完整单位数。 例如，2012年至2031年之间的数十年将只有二十年的一年。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, YEARS);
   amount = YEARS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        该方法的计算用于ChronoUnit 。 单位YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS的支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，转换为 Year ，不为空
        unit - 衡量金额的单位，不为空
        结果
        今年至年底之间的时间
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 Year
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • format

        public String format​(DateTimeFormatter formatter)
        今年格式使用指定的格式化程序。

        今年将被传递给格式化程序来生成一个字符串。

        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的年份字符串，不为null
        异常
        DateTimeException - 打印时是否发生错误

      • atDay

        public LocalDate atDay​(int dayOfYear)
        今年与今年的合并创造了LocalDate 。

        这将返回一个LocalDate形成从今年和指定的一年。

        日期值366仅在闰年有效。

        参数
        dayOfYear - 使用年限，从1到365-366
        结果
        从今年形成的当地日期和指定的年份，不为零
        异常
        DateTimeException - 如果一年中的一天是零或以下，366或更大或等于366，这不是闰年

      • atMonth

        public YearMonth atMonth​(Month month)
        今年结合一个月创造YearMonth 。

        这将返回一个从今年和特定月份形成的YearMonth 。 年和月的所有可能的组合是有效的。

        该方法可以用作链的一部分来生成日期：

          LocalDate date = year.atMonth(month).atDay(day);
        参数
        month - 使用年月日，不为空
        结果
        从今年和特定月份形成的年月，不为零

      • atMonth

        public YearMonth atMonth​(int month)
        结合今年一个月创造YearMonth 。

        这将返回一个从今年和特定月份形成的YearMonth 。 年和月的所有可能的组合是有效的。

        该方法可以用作链的一部分来生成日期：

          LocalDate date = year.atMonth(month).atDay(day);
        参数
        month - 1月1日至12日（12月）使用的月份
        结果
        从今年和特定月份形成的年月，不为零
        异常
        DateTimeException - 如果月份无效

      • atMonthDay

        public LocalDate atMonthDay​(MonthDay monthDay)
        结合今年与一个月的日子，创造一个LocalDate 。

        这将返回一个LocalDate形成从今年和指定的月日。

        如果这一年不是闰年，那么2月29日的一个月的日子将会调整到2月28日。

        参数
        monthDay - 使用的月份，不为空
        结果
        从今年和指定的月日组成的当地日期，不为空

      • compareTo

        public int compareTo​(Year other)
        今年再比较一年。

        比较是基于一年的价值。 它与“等于”一致，如Comparable所定义。

        Specified by:
        compareTo在接口 Comparable<Year>
        参数
        other - 另一年要比较，不是null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        public boolean isAfter​(Year other)
        检查今年是否在指定的年份之后。
        参数
        other - 另一年要比较，不是null
        结果
        如果这是在指定年份之后，则为真

      • isBefore

        public boolean isBefore​(Year other)
        检查今年是否在指定年份之前。
        参数
        other - 与其他年比较，不为空
        结果
        如果这一点在指定年份之前，则为真

      • equals

        public boolean equals​(Object obj)
        检查今年是否等于另一年。

        比较是基于多年的时间位置。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他年份，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        今年的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        今年产量为 String 。
        重写：
        toString在 Object
        结果
        今年的字符串表示，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


YearMonth (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class YearMonth

  • java.lang.Object
    • java.time.YearMonth
  • All Implemented Interfaces:
    Serializable ， Comparable<YearMonth> ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class YearMonth
extends Object
implements Temporal, TemporalAdjuster, Comparable<YearMonth>, Serializable
    在ISO- 2007-12 ，如2007-12 。

    YearMonth是一个不变的日期时间对象，表示一年和一个月的组合。 可以获得可以从年和月派生的任何字段，例如四分之一年份。

    此类不存储或表示一天，时间或时区。 例如，值“2007年10月”可以存储在YearMonth 。

    ISO-8601日历系统是当今世界绝大多数的现代民用日历系统。 它相当于今天的闰年规则一直适用于日常生活的公历日历系统。 对于今天写的大多数应用，ISO-8601规则是完全合适的。 然而，任何利用历史日期并要求它们准确的应用程序都将发现ISO-8601方法不合适。

    这是一个value-based类; 在YearMonth实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      将指定的时间对象调整为今年。
      LocalDate atDay​(int dayOfMonth)
      结合今年的月份，创造一个 LocalDate 。
      LocalDate atEndOfMonth​()
      在月底返回 LocalDate 。
      int compareTo​(YearMonth other)
      比较今年至另一个月。
      boolean equals​(Object obj)
      检查这个年月是否等于另一个一个月。
      String format​(DateTimeFormatter formatter)
      使用指定的格式化程序在今年的格式。
      static YearMonth from​(TemporalAccessor temporal)
      从时间对象获取一个 YearMonth的实例。
      int get​(TemporalField field)
      从这个月份获取指定字段的值作为 int 。
      long getLong​(TemporalField field)
      从这个月份获取指定字段的值作为 long 。
      Month getMonth​()
      使用 Month枚举获取月份字段。
      int getMonthValue​()
      将月份字段从1到12。
      int getYear​()
      获取年份字段。
      int hashCode​()
      今年的哈希码。
      boolean isAfter​(YearMonth other)
      检查这个年月是否在指定的年月之后。
      boolean isBefore​(YearMonth other)
      检查这个年月是否在指定的年份之前。
      boolean isLeapYear​()
      根据ISO培训日历系统规则，检查年份是否是闰年。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean isValidDay​(int dayOfMonth)
      检查月日是否在今年有效。
      int lengthOfMonth​()
      返回月份的长度，考虑到年份。
      int lengthOfYear​()
      返回一年的长度。
      YearMonth minus​(long amountToSubtract, TemporalUnit unit)
      返回减去指定数量的今年的副本。
      YearMonth minus​(TemporalAmount amountToSubtract)
      返回减去指定数量的今年的副本。
      YearMonth minusMonths​(long monthsToSubtract)
      返回此 YearMonth的副本，并减去指定的月数。
      YearMonth minusYears​(long yearsToSubtract)
      返回此 YearMonth的副本，并减去指定的年数。
      static YearMonth now​()
      从默认时区的系统时钟获取当前的一个月。
      static YearMonth now​(Clock clock)
      从指定的时钟获取当前的一个月。
      static YearMonth now​(ZoneId zone)
      从指定时区的系统时钟获取当前的一个月。
      static YearMonth of​(int year, int month)
      从一年和一个月获得 YearMonth的实例。
      static YearMonth of​(int year, Month month)
      从一个月和一个月获得一个 YearMonth的实例。
      static YearMonth parse​(CharSequence text)
      从 2007-12等文本字符串获取 YearMonth的实例。
      static YearMonth parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 YearMonth的实例。
      YearMonth plus​(long amountToAdd, TemporalUnit unit)
      返回此年份的副本，并添加指定的金额。
      YearMonth plus​(TemporalAmount amountToAdd)
      返回此年份的副本，并添加指定的金额。
      YearMonth plusMonths​(long monthsToAdd)
      返回此 YearMonth的副本，并附加指定的月数。
      YearMonth plusYears​(long yearsToAdd)
      返回此 YearMonth的副本，并附加指定的年数。
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询今年。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      String toString​()
      今年产量为 String ，如 2007-12 。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定单位计算直到另一个一个月的时间量。
      YearMonth with​(TemporalAdjuster adjuster)
      返回今年的调整副本。
      YearMonth with​(TemporalField field, long newValue)
      返回此年月份的副本，并将指定的字段设置为新值。
      YearMonth withMonth​(int month)
      返回这个 YearMonth的副本， YearMonth日更改。
      YearMonth withYear​(int year)
      返回此 YearMonth的副本。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • now

        public static YearMonth now​()
        从默认时区的系统时钟获取当前的一个月。

        这将查询默认时区中的system clock以获取当前的年月。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前年份使用系统时钟和默认时区，不为空

      • now

        public static YearMonth now​(ZoneId zone)
        从指定时区的系统时钟获取当前的一个月。

        这将查询system clock获取当前的一个月。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前年份使用系统时钟，不为空

      • now

        public static YearMonth now​(Clock clock)
        从指定的时钟获取当前的一个月。

        这将查询指定的时钟以获取当前的年月。 使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        参数
        clock - 要使用的时钟，不为空
        结果
        当年，不为零

      • of

        public static YearMonth of​(int year,
                           Month month)
        从一年和一个月获得 YearMonth的实例。
        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 代表的月份，不为null
        结果
        年月，不为零
        异常
        DateTimeException - 如果年值无效

      • of

        public static YearMonth of​(int year,
                           int month)
        从一年和一个月获得 YearMonth的实例。
        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 从1月1日至12日（12月）的月份，
        结果
        年月，不为零
        异常
        DateTimeException - 如果任一字段值无效

      • from

        public static YearMonth from​(TemporalAccessor temporal)
        从时间对象获取YearMonth的实例。

        这取决于指定时间的一个月。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为YearMonth的实例。

        该转换提取了YEAR和MONTH_OF_YEAR字段。 只有当时间对象具有ISO年表，或者可以转换为LocalDate ，才允许提取。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考YearMonth::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        年月，不为零
        异常
        DateTimeException - 如果无法转换为 YearMonth

      • parse

        public static YearMonth parse​(CharSequence text)
        从文本字符串（例如2007-12获取YearMonth的实例。

        字符串必须表示有效的一个月。 格式必须为uuuu-MM 。 超出范围0000到9999之间的年份必须加上加号或减号。

        参数
        text - 要解析的文本，如“2007-12”，不为空
        结果
        解析的年月，不为零
        异常
        DateTimeParseException - 如果文本无法解析

      • parse

        public static YearMonth parse​(CharSequence text,
                              DateTimeFormatter formatter)
        使用特定的格式化程序从文本字符串获取YearMonth的实例。

        使用格式化程序解析文本，返回一个月。

        参数
        text - 要解析的文本，不为空
        formatter - 要使用的格式化程序，不为null
        结果
        解析的年月，不为零
        异常
        DateTimeParseException - 如果文本无法解析

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的年月。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 支持的字段有：

        • MONTH_OF_YEAR
        • PROLEPTIC_MONTH
        • YEAR_OF_ERA
        • YEAR
        • ERA
        所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果该字段在今年支持，则为true，否则为false

      • isSupported

        public boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定的单位是否可以添加到今年或从今年减去。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        如果单位是ChronoUnit，那么查询是在这里实现的。 支持的单位是：

        • MONTHS
        • YEARS
        • DECADES
        • CENTURIES
        • MILLENNIA
        • ERAS
        所有其他ChronoUnit实例将返回false。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 今年用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持

      • get

        public int get​(TemporalField field)
        从本年度获取指定字段的值作为int 。

        这个年月查询指定字段的值。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回基于今年的有效值，除了PROLEPTIC_MONTH ，这太大，无法适应int并抛出DateTimeException 。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取该字段的值或该值超出该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从这个年月获得指定字段的值作为long 。

        这个年月查询指定字段的值。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回基于今年的有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • getYear

        public int getYear​()
        获取年份字段。

        此方法返回一年的原始值int 。

        通过这种方法返回的年份是根据get(YEAR)是灵巧的。

        结果
        年，从MIN_YEAR到MAX_YEAR

      • getMonthValue

        public int getMonthValue​()
        将月份字段从1到12。

        此方法将一个月作为int从1到12返回。如果通过调用getMonth()使用枚举Month，应用程序代码通常更清晰。

        结果
        从1到12年的月份
        另请参见：
        getMonth()

      • getMonth

        public Month getMonth​()
        使用Month枚举获取月份字段。

        此方法返回本月的枚举Month 。 这避免了int值意味着什么的混乱。 如果您需要访问原始的int值，则枚举将提供int value 。

        结果
        月份，不为零
        另请参见：
        getMonthValue()

      • isLeapYear

        public boolean isLeapYear​()
        根据ISO培训日历系统规则，检查年份是否是闰年。

        这种方法在整个时间线上应用目前的闰年规则。 一般来说，一年是一个闰年，如果没有余数可以被四分割。 但是，除了100岁之外，年份可以被分割为100岁，除了年龄可以被400除外。

        例如，1904年是一个闰年，可以被4整除。1900年不是一个闰年，因为它可以被100整除，然而2000年是一个闰年，因为它可以被400除数。

        计算是应激的 - 将相同的规则应用到远未来很远的地方。 这在历史上是不准确的，但对于ISO-8601标准是正确的。

        结果
        如果一年是飞跃，否则为假

      • isValidDay

        public boolean isValidDay​(int dayOfMonth)
        检查月日是否在今年有效。

        此方法检查年，月和输入日形成有效日期。

        参数
        dayOfMonth - 验证的月份，从1到31，无效值返回false
        结果
        如果当天在今年有效，则为真

      • lengthOfMonth

        public int lengthOfMonth​()
        返回月份的长度，考虑到年份。

        这将以天为单位返回月份的长度。 例如，1月份的日期将返回31。

        结果
        月份的天数，从28天到31天

      • lengthOfYear

        public int lengthOfYear​()
        返回一年的长度。

        这将返回年份的长度，以天数为365或366。

        结果
        366如果一年是飞跃，否则为365

      • with

        public YearMonth with​(TemporalAdjuster adjuster)
        返回今年的调整副本。

        这将返回一个YearMonth ，基于此，与年月调整。 调整使用指定的调整器策略对象进行。 阅读调整器的文档，了解将进行什么调整。

        一个简单的调整器可能只是设置一个字段，如年份字段。 一个更复杂的调整者可能会将下个月的月份设定为Halley的彗星将通过地球。

        该方法的结果是通过调用TemporalAdjuster.adjustInto(Temporal)方法在指定的调整器通过this作为参数获得的。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        一个 YearMonth基于 this进行了调整，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        public YearMonth with​(TemporalField field,
                      long newValue)
        返回此年月份的副本，并将指定的字段设置为新值。

        这将返回一个YearMonth ，基于此，更改指定字段的值。 这可以用于更改任何支持的字段，例如年份或月份。 如果不可能设置该值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，则在此处执行调整。 支持的字段的行为如下：

        • MONTH_OF_YEAR - 返回指定月份的YearMonth 。 年将不变。
        • PROLEPTIC_MONTH - 返回一个YearMonth具有指定的月份。 这完全取代了这个对象的年和月。
        • YEAR_OF_ERA - 返回指定年龄的YearMonth月份和时代将不变。
        • YEAR - 返回指定年份的YearMonth 。 这个月不变。
        • ERA - 返回指定时代的YearMonth 。 月份和年龄将不变。

        在所有情况下，如果新值超出该字段值的有效范围，那么将抛出DateTimeException 。

        所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.adjustInto(Temporal, long)传递this作为参数。 在这种情况下，该字段决定是否以及如何调整即时。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        一个 YearMonth基于 this指定字段集，不为null
        异常
        DateTimeException - 如果字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • withYear

        public YearMonth withYear​(int year)
        返回这个YearMonth的副本，并更改年份。

        此实例是不可变的，不受此方法调用的影响。

        参数
        year - 从MIN_YEAR到MAX_YEAR的返回年份设置的年份
        结果
        一个 YearMonth基于今年所要求的一年，不为零
        异常
        DateTimeException - 如果年值无效

      • withMonth

        public YearMonth withMonth​(int month)
        返回这个YearMonth的副本，其中YearMonth了月份。

        此实例是不可变的，不受此方法调用的影响。

        参数
        month - 从1月（1月）至12月（12月），在返回的年份中设定的月份
        结果
        一个 YearMonth基于今年月份与请求的月份，不为null
        异常
        DateTimeException - 如果月份值无效

      • plus

        public YearMonth plus​(TemporalAmount amountToAdd)
        返回此年份的副本，并添加指定的金额。

        这将返回一个YearMonth ，基于此，添加了指定的数量。 金额通常为Period，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.addTo(Temporal)将计算委托给金额对象。 数量执行可以以任何方式实现添加，但是它通常会回调到plus(long, TemporalUnit) 。 请参阅金额执行的文档，以确定是否可以成功添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 YearMonth基于今年的增加，不是null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        public YearMonth plus​(long amountToAdd,
                      TemporalUnit unit)
        返回此年份的副本，并添加指定的金额。

        这将返回一个YearMonth ，基于这一个，以添加的单位数量。 如果不可能添加金额，因为单位不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoUnit，那么添加在这里实现。 支持的字段的行为如下：

        • MONTHS - 返回一个YearMonth ，加上指定的月数。 这相当于plusMonths(long) 。
        • YEARS - 返回指定年数的YearMonth 。 这相当于plusYears(long) 。
        • DECADES - 返回一个YearMonth ，加上指定的几十年。 这相当于调用plusYears(long) ，数量乘以10。
        • CENTURIES - 返回一个YearMonth具有指定的几个世纪。 这相当于调用plusYears(long) ，数量乘以100。
        • MILLENNIA - 返回一个YearMonth ，加上指定的几千年。 这相当于调用plusYears(long) ，数量乘以1,000。
        • ERAS - 返回一个YearMonth ，其中添加了指定的时间。 只支持两个时间，所以数量必须是1，零或者减1。 如果金额不是零，那么这个年份就会改变，使得年龄不变。

        所有其他ChronoUnit实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为参数。 在这种情况下，单元确定是否以及如何执行添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加到结果中的单位数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        一个 YearMonth基于这个年月加上指定的金额，不为null
        异常
        DateTimeException - 如果不能添加
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusYears

        public YearMonth plusYears​(long yearsToAdd)
        返回此YearMonth的副本，并附加指定的年数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        yearsToAdd - 多年来补充，可能是负数
        结果
        一个 YearMonth基于今年增加的年份，不为零
        异常
        DateTimeException - 如果结果超出了支持的范围

      • plusMonths

        public YearMonth plusMonths​(long monthsToAdd)
        返回此YearMonth的副本，并附加指定的月数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        monthsToAdd - 要添加的月份，可能为负数
        结果
        一个 YearMonth基于今年月份增加的月份，不为空
        异常
        DateTimeException - 如果结果超出了支持的范围

      • minus

        public YearMonth minus​(TemporalAmount amountToSubtract)
        返回减去指定数量的今年的副本。

        这将返回一个YearMonth ，基于此，减去指定的数量。 金额通常为Period，但可能是实现TemporalAmount接口的任何其他类型。

        通过调用TemporalAmount.subtractFrom(Temporal)将计算委托给金额对象。 数量执行可以以任何方式实现减法，但是它通常会调用到minus(long, TemporalUnit) 。 请参阅数量执行的文档，以确定是否可以成功减去它们。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去量，不为空
        结果
        一个 YearMonth基于今年的减法而不是null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        public YearMonth minus​(long amountToSubtract,
                       TemporalUnit unit)
        返回减去指定数量的今年的副本。

        这将返回一个YearMonth ，基于此，减去单位的数量。 如果不可能减去金额，因为该单位不受支持或出于某种其他原因，则会抛出异常。

        该方法相当于plus(long, TemporalUnit) ，其数量被否定。 请参阅该方法，以了解如何添加，从而减去运算。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 从结果中减去的单位数量可能为负数
        unit - 减去量的单位，不为空
        结果
        一个 YearMonth基于今年减去指定数量，不为null
        异常
        DateTimeException - 如果不能进行减法
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minusYears

        public YearMonth minusYears​(long yearsToSubtract)
        返回此YearMonth的副本，并减去指定的年数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        yearsToSubtract - 减去年份，可能为负数
        结果
        一个 YearMonth基于今年减去年，不为零
        异常
        DateTimeException - 如果结果超出了支持的范围

      • minusMonths

        public YearMonth minusMonths​(long monthsToSubtract)
        返回此YearMonth的副本，并减去指定的月数。

        此实例是不可变的，不受此方法调用的影响。

        参数
        monthsToSubtract - 减去数月，可能为负数
        结果
        一个 YearMonth基于今年减少的月份，不为零
        异常
        DateTimeException - 如果结果超出了支持范围

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询今年。

        这使用指定的查询策略对象查询今年。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在指定的查询this作为参数调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        将指定的时间对象调整为今年。

        这返回与年和月份的输入相同的可观察类型的时间对象与此相同。

        该调整是相当于使用Temporal.with(TemporalField, long)通过ChronoField.PROLEPTIC_MONTH作为字段。 如果指定的时间对象不使用ISO日历系统，则抛出DateTimeException 。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisYearMonth.adjustInto(temporal);
   temporal = temporal.with(thisYearMonth);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果无法进行调整
        ArithmeticException - 如果发生数字溢出

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        根据指定单位计算直到另一个一个月的时间量。

        这可以计算一个YearMonth对象之间的时间量，单个TemporalUnit 。 起点和终点是this和指定的年月。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为YearMonth使用from(TemporalAccessor) 。 例如，可以使用startYearMonth.until(endYearMonth, YEARS)计算两年之间的年数。

        计算返回一个整数，表示两个月之间的完整单位数。 例如，2012-06年至2032-05年间的数十年将只有二十年的一个月。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        以此方法计算ChronoUnit 。 单位MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS的支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，转换为 YearMonth ，不为空
        unit - 衡量金额的单位，不为空
        结果
        今年至今年底的时间
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 YearMonth
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • format

        public String format​(DateTimeFormatter formatter)
        使用指定的格式化程序在今年的格式。

        今年将被传递给格式化程序来生成一个字符串。

        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的年份字符串，不为空
        异常
        DateTimeException - 打印过程中是否发生错误

      • atDay

        public LocalDate atDay​(int dayOfMonth)
        结合今年的月份，创造一个LocalDate 。

        这将返回一个LocalDate ，从今年月份和指定的日期形成。

        月日的价值必须在年月有效。

        该方法可以用作链的一部分来生成日期：

          LocalDate date = year.atMonth(month).atDay(day);
        参数
        dayOfMonth - 使用月份，从1到31
        结果
        从今年和特定日期形成的日期不为零
        异常
        DateTimeException - 如果一天的年份无效
        另请参见：
        isValidDay(int)

      • atEndOfMonth

        public LocalDate atEndOfMonth​()
        在本月底返回LocalDate 。

        这将返回一个基于今年的LocalDate 。 每月的最后一个有效日期，考虑到闰年。

        该方法可以用作链的一部分来生成日期：

          LocalDate date = year.atMonth(month).atEndOfMonth();
        结果
        今年的最后有效日期，不为空

      • compareTo

        public int compareTo​(YearMonth other)
        比较今年至另一个月。

        这个比较首先是基于年的价值，然后是月的价值。 它与“等于”一致，如Comparable所定义。

        Specified by:
        compareTo在接口 Comparable<YearMonth>
        参数
        other - 与其他年份进行比较，不为空
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        public boolean isAfter​(YearMonth other)
        检查这个年月是否在指定的年月之后。
        参数
        other - 其他年月比较，不为null
        结果
        如果这是指定的年月之后，则为真

      • isBefore

        public boolean isBefore​(YearMonth other)
        检查这个年月是否在指定的年份之前。
        参数
        other - 其他年月比较，不为null
        结果
        如果这一点在指定的年月之前，则为真

      • equals

        public boolean equals​(Object obj)
        检查这个年月是否等于另一个一个月。

        比较是基于年月日的时间位置。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他年份，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        今年的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        今年产量为String ，如2007-12 。

        输出格式为uuuu-MM ：

        重写：
        toString在 Object
        结果
        今年的字符串表示，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ZonedDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class ZonedDateTime

  • java.lang.Object
    • java.time.ZonedDateTime
  • All Implemented Interfaces:
    Serializable ， Comparable<LocalDate> ， ChronoZonedDateTime<LocalDate> ， Temporal ， TemporalAccessor

    public final class ZonedDateTime
extends Object
implements Temporal, ChronoZonedDateTime<LocalDate>, Serializable
    ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如2007-12-03T10:15:30+01:00 Europe/Paris 。

    ZonedDateTime是具有时区的日期时间的不可变表示。 此类存储所有日期和时间字段，精度为纳秒，时区为区域偏移量，用于处理模糊的本地日期时间。 例如，值“2007年10月2日在13：45.30.123456789 +欧洲/巴黎时区的ZonedDateTime ”可以存储在ZonedDateTime 。

    该类处理从本地时间线LocalDateTime到瞬时时间线Instant 。 两个时间线之间的差异是与UTC /格林威治的偏移量，由ZoneOffset表示。

    两个时间线之间的转换包括使用从ZoneId访问的ZoneId计算偏移量。 获取瞬时的偏移是简单的，因为每个瞬间只有一个有效的偏移量。 相比之下，获取本地日期时间的偏移量并不简单。 有三种情况：

    • 正常，有一个有效的偏移。 在一年的绝大多数情况下，正常情况适用于当地日期时间单一有效抵消。
    • 间隙，零有效偏移。 这是由于春季夏令时从“冬季”变为“夏季”，时钟向前倾斜。 在间隙中，存在没有有效偏移量的本地日期时间值。
    • 重叠，有两个有效的偏移。 这是由于秋季夏令时间从“夏季”变为“冬季”而将时钟倒退。 在重叠中，存在具有两个有效偏移量的本地日期时间值。

    任何通过获取偏移量从本地日期时间直接或隐式转换的方法都有可能变得复杂。

    对于差距，总体策略是，如果当地日期时间落在一个差距的中间，那么由此产生的划分的日期时间将有一个本地日期时间向前移动距离的差距，导致一个日期 - 时间在后来的偏移，通常是“夏天”的时间。

    对于重叠，一般的策略是，如果本地日期时间落在重叠的中间，那么以前的偏移将被保留。 如果没有先前的偏移量，或者以前的偏移量是无效的，则使用较早的偏移量，通常是“夏季”时间。另外两个方法， withEarlierOffsetAtOverlap()和withLaterOffsetAtOverlap()可帮助管理重叠的情况。

    在设计方面，这个班主要被视为LocalDateTime和ZoneId的组合。 ZoneOffset是一个重要的但次要的信息，用于确保该类代表即时，特别是在夏令时重叠期间。

    这是一个value-based课; 在ZonedDateTime实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能具有不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    A ZonedDateTime保存相当于三个独立对象的状态，一个LocalDateTime ，一个ZoneId和解析的ZoneOffset 。 偏移量和本地日期时间用于在必要时定义一个瞬间。 区域ID用于获取偏移量如何以及何时更改的规则。 偏移不能自由设置，因为区域控制哪些偏移是有效的。

    这个类是不可变的和线程安全的。

    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查此日期时间是否等于另一个日期时间。
      String format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。
      static ZonedDateTime from​(TemporalAccessor temporal)
      从时间对象获取 ZonedDateTime的实例。
      int get​(TemporalField field)
      从此日期时间获取指定字段的值作为 int 。
      int getDayOfMonth​()
      获取月份字段。
      DayOfWeek getDayOfWeek​()
      获取星期几字段，这是一个枚举 DayOfWeek 。
      int getDayOfYear​()
      获得日期字段。
      int getHour​()
      获取时间字段。
      long getLong​(TemporalField field)
      从此日期时间获取指定字段的值作为 long 。
      int getMinute​()
      获取小时字段。
      Month getMonth​()
      使用 Month枚举获取月份字段。
      int getMonthValue​()
      将月份字段从1到12。
      int getNano​()
      获得纳秒第二场。
      ZoneOffset getOffset​()
      获取区域偏移量，例如“+01：00”。
      int getSecond​()
      获得第二分钟的字段。
      int getYear​()
      获取年份字段。
      ZoneId getZone​()
      获得时区，如“欧洲/巴黎”。
      int hashCode​()
      这个日期时间的哈希码。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      ZonedDateTime minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期时间的副本，并减去指定的金额。
      ZonedDateTime minus​(TemporalAmount amountToSubtract)
      返回此日期时间的副本，并减去指定的金额。
      ZonedDateTime minusDays​(long days)
      返回此 ZonedDateTime的副本，并减去指定的天数。
      ZonedDateTime minusHours​(long hours)
      返回此 ZonedDateTime的副本，并减去指定的小时数。
      ZonedDateTime minusMinutes​(long minutes)
      返回此 ZonedDateTime的副本，并减去指定的分钟数。
      ZonedDateTime minusMonths​(long months)
      返回此 ZonedDateTime的副本，并减去指定的月数。
      ZonedDateTime minusNanos​(long nanos)
      返回此 ZonedDateTime的副本，减去指定的纳秒数。
      ZonedDateTime minusSeconds​(long seconds)
      返回此 ZonedDateTime的副本，并减去指定的秒数。
      ZonedDateTime minusWeeks​(long weeks)
      返回此 ZonedDateTime的副本，并减去指定的周数。
      ZonedDateTime minusYears​(long years)
      返回此 ZonedDateTime的副本，并减去指定的年数。
      static ZonedDateTime now​()
      从默认时区的系统时钟获取当前的日期时间。
      static ZonedDateTime now​(Clock clock)
      从指定的时钟获取当前的日期时间。
      static ZonedDateTime now​(ZoneId zone)
      从指定时区的系统时钟获取当前的日期时间。
      static ZonedDateTime of​(int year, int month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond, ZoneId zone)
      从年，月，日，时，分，秒，纳秒和时区获取 ZonedDateTime的实例。
      static ZonedDateTime of​(LocalDate date, LocalTime time, ZoneId zone)
      从当地的日期和时间获取 ZonedDateTime的实例。
      static ZonedDateTime of​(LocalDateTime localDateTime, ZoneId zone)
      从本地日期时间获取 ZonedDateTime的实例。
      static ZonedDateTime ofInstant​(Instant instant, ZoneId zone)
      从 Instant获取 ZonedDateTime一个实例。
      static ZonedDateTime ofInstant​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      从通过组合本地日期时间和偏移量形成的瞬间获取 ZonedDateTime的实例。
      static ZonedDateTime ofLocal​(LocalDateTime localDateTime, ZoneId zone, ZoneOffset preferredOffset)
      从本地日期时间获取 ZonedDateTime的实例，如果可能，使用首选偏移量。
      static ZonedDateTime ofStrict​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      获取 ZonedDateTime的实例，严格验证本地日期时间，偏移量和区域ID的组合。
      static ZonedDateTime parse​(CharSequence text)
      从 2007-12-03T10:15:30+01:00[Europe/Paris]等文本字符串获取 ZonedDateTime的实例。
      static ZonedDateTime parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 ZonedDateTime的实例。
      ZonedDateTime plus​(long amountToAdd, TemporalUnit unit)
      返回此日期时间的副本，并添加指定的数量。
      ZonedDateTime plus​(TemporalAmount amountToAdd)
      返回此日期时间的副本，并添加指定的数量。
      ZonedDateTime plusDays​(long days)
      以指定的天数返回此 ZonedDateTime的副本。
      ZonedDateTime plusHours​(long hours)
      返回此 ZonedDateTime的副本，并附加指定的小时数。
      ZonedDateTime plusMinutes​(long minutes)
      返回此 ZonedDateTime的副本，并添加指定的分钟数。
      ZonedDateTime plusMonths​(long months)
      返回此 ZonedDateTime的副本，并附加指定的月数。
      ZonedDateTime plusNanos​(long nanos)
      返回此 ZonedDateTime的副本， ZonedDateTime添加了指定的纳秒数。
      ZonedDateTime plusSeconds​(long seconds)
      返回此 ZonedDateTime的副本，并添加指定的秒数。
      ZonedDateTime plusWeeks​(long weeks)
      返回此 ZonedDateTime的副本，并附加指定的周数。
      ZonedDateTime plusYears​(long years)
      返回添加了指定年数的 ZonedDateTime的副本。
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      LocalDate toLocalDate​()
      获得这个日期时间的 LocalDate部分。
      LocalDateTime toLocalDateTime​()
      获取此日期时间的 LocalDateTime部分。
      LocalTime toLocalTime​()
      获得这个日期时间的 LocalTime一部分。
      OffsetDateTime toOffsetDateTime​()
      将此日期时间转换为 OffsetDateTime 。
      String toString​()
      将此日期时间输出为 String ，如 2007-12-03T10:15:30+01:00[Europe/Paris] 。
      ZonedDateTime truncatedTo​(TemporalUnit unit)
      返回此 ZonedDateTime的副本，截断时间。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算到另一个日期时间的时间量。
      ZonedDateTime with​(TemporalAdjuster adjuster)
      返回此日期时间的调整副本。
      ZonedDateTime with​(TemporalField field, long newValue)
      返回此日期时间的副本，并将指定的字段设置为新值。
      ZonedDateTime withDayOfMonth​(int dayOfMonth)
      返回此 ZonedDateTime的副本，并更改日期。
      ZonedDateTime withDayOfYear​(int dayOfYear)
      返回此 ZonedDateTime更改的 ZonedDateTime的副本。
      ZonedDateTime withEarlierOffsetAtOverlap​()
      返回此日期的副本，将区域偏移更改为本地时间线重叠处的两个有效偏移量的较早者。
      ZonedDateTime withFixedOffsetZone​()
      返回此日期时间的副本，区域ID设置为偏移量。
      ZonedDateTime withHour​(int hour)
      返回此 ZonedDateTime的副本，并更改日期。
      ZonedDateTime withLaterOffsetAtOverlap​()
      返回此日期的副本，将区域偏移更改为本地时间线重叠的两个有效偏移量的后面。
      ZonedDateTime withMinute​(int minute)
      返回 ZonedDateTime的副本，小时改变。
      ZonedDateTime withMonth​(int month)
      返回这个 ZonedDateTime的副本， ZonedDateTime更改月份。
      ZonedDateTime withNano​(int nanoOfSecond)
      返回这个 ZonedDateTime的副本，并更改了纳秒。
      ZonedDateTime withSecond​(int second)
      返回此 ZonedDateTime的副本，其中第二分钟更改。
      ZonedDateTime withYear​(int year)
      返回这个 ZonedDateTime的副本，年份被更改。
      ZonedDateTime withZoneSameInstant​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，保留即时。
      ZonedDateTime withZoneSameLocal​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。

      • Methods inherited from interface java.time.chrono.ChronoZonedDateTime

        compareTo, getChronology, isAfter, isBefore, isEqual, timeLineOrder, toEpochSecond, toInstant

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • now

        public static ZonedDateTime now​()
        从默认时区的系统时钟获取当前的日期时间。

        这将在默认时区查询system clock以获取当前的日期时间。 区域和偏移量将根据时钟中的时区设置。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前日期时间使用系统时钟，不为空

      • now

        public static ZonedDateTime now​(ZoneId zone)
        从指定时区的系统时钟获取当前的日期时间。

        这将查询system clock以获取当前日期。 指定时区可以避免对默认时区的依赖。 偏移量将从指定的时区计算。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前日期时间使用系统时钟，不为空

      • now

        public static ZonedDateTime now​(Clock clock)
        从指定的时钟获取当前的日期时间。

        这将查询指定的时钟以获取当前的日期时间。 区域和偏移量将根据时钟中的时区设置。

        使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前日期时间，不为null

      • of

        public static ZonedDateTime of​(LocalDate date,
                               LocalTime time,
                               ZoneId zone)
        从当地的日期和时间获取ZonedDateTime的实例。

        这将创建一个划分的日期时间，尽可能地将输入的本地日期和时间进行匹配。 时区规则（如夏令时）意味着并非每个本地日期时间对指定的区域都有效，因此可能会调整本地日期时间。

        当地的日期时间，首先结合形成当地的日期时间。 然后，本地日期时间在时间线上解析为单个时刻。 这是通过从区域ID的rules定义的本地日期时间中找到UTC /格林威治的有效偏移量来实现的。

        在大多数情况下，本地日期时间只有一个有效的偏移量。 在重叠的情况下，当设置时钟时，有两个有效的偏移量。 该方法使用通常对应于“summer”的较早的偏移量。

        在间隙的情况下，当时钟向前跳转时，没有有效的偏移。 相反，本地日期时间被调整为稍后间隔的长度。 对于典型的1小时夏令时更改，本地日期时间将在一小时后移动到通常对应于“夏季”的偏移量。

        参数
        date - 本地日期，不为空
        time - 当地时间，不为空
        zone - 时区，不为空
        结果
        偏移日期时间，不为null

      • of

        public static ZonedDateTime of​(LocalDateTime localDateTime,
                               ZoneId zone)
        从本地日期时间获取ZonedDateTime的实例。

        这将创建一个与输入本地日期时间相匹配的划分的日期时间。 时区规则（如夏令时）意味着并非每个本地日期时间对指定的区域都有效，因此可能会调整本地日期时间。

        本地日期时间在时间线上解析为单个时刻。 这是通过从区域ID的rules定义的本地日期时间中找到UTC /格林威治的有效偏移量来实现的。

        在大多数情况下，本地日期时间只有一个有效的偏移量。 在重叠的情况下，当设置时钟时，有两个有效的偏移量。 该方法使用通常对应于“summer”的较早的偏移量。

        在间隙的情况下，当时钟向前跳转时，没有有效的偏移。 相反，本地日期时间被调整为稍后间隔的长度。 对于典型的1小时夏令时更改，本地日期时间将在一小时后移动到通常对应于“夏季”的偏移量。

        参数
        localDateTime - 本地日期时间，不为空
        zone - 时区，不为空
        结果
        划分的日期时间，不为空

      • of

        public static ZonedDateTime of​(int year,
                               int month,
                               int dayOfMonth,
                               int hour,
                               int minute,
                               int second,
                               int nanoOfSecond,
                               ZoneId zone)
        从年，月，日，时，分，秒，纳秒和时区获取ZonedDateTime的实例。

        这将创建一个划分的日期时间，尽可能地紧密匹配七个指定字段的本地日期时间。 时区规则（如夏令时）意味着并非每个本地日期时间对指定的区域都有效，因此可能会调整本地日期时间。

        本地日期时间在时间线上解析为单个时刻。 这是通过从区域ID的rules定义的本地日期时间中找到UTC /格林威治的有效偏移量来实现的。

        在大多数情况下，本地日期时间只有一个有效的偏移量。 在重叠的情况下，当设置时钟时，有两个有效的偏移量。 该方法使用通常对应于“summer”的较早的偏移量。

        在间隙的情况下，当时钟向前跳转时，没有有效的偏移。 相反，本地日期时间被调整为稍后间隔的长度。 对于典型的1小时夏令时更改，本地日期时间将在一小时后移动到通常对应于“夏季”的偏移量。

        该方法主要用于编写测试用例。 非测试代码通常会使用其他方法来创建一个偏移时间。 LocalDateTime有相当于工厂方法的五个附加便利变体，参数较少。 在这里不提供它们来减少API的占用空间。

        参数
        year - 从MIN_YEAR到MAX_YEAR的年份
        month - 从1月1日至12日（12月）的月份，
        dayOfMonth - 代表从1到31的月份
        hour - 代表从0到23的小时
        minute - 表示从0到59的小时
        second - 从0到59的秒表示
        nanoOfSecond - 表示从0到999,999,999的纳秒
        zone - 时区，不为空
        结果
        偏移日期时间，不为null
        异常
        DateTimeException - 如果任何字段的值超出范围，或者如果月的日期对于月份无效

      • ofLocal

        public static ZonedDateTime ofLocal​(LocalDateTime localDateTime,
                                    ZoneId zone,
                                    ZoneOffset preferredOffset)
        从本地日期时间获取ZonedDateTime的实例，如果可能，使用首选偏移量。

        本地日期时间在时间线上解析为单个时刻。 这是通过从区域ID的rules定义的本地日期时间中找到UTC /格林威治的有效偏移量来实现的。

        在大多数情况下，本地日期时间只有一个有效的偏移量。 在重叠的情况下，时钟被设置回来，有两个有效的偏移量。 如果首选偏移量是有效偏移之一，则使用它。 否则，将使用较早的有效偏移量，通常对应于“summer”。

        在间隙向前跳跃的情况下，没有有效的偏移。 相反，本地日期时间被调整为稍后间隔的长度。 对于典型的1小时夏令时更改，本地日期时间将在一小时后移动到通常对应于“夏季”的偏移量。

        参数
        localDateTime - 本地日期时间，不为空
        zone - 时区，不为空
        preferredOffset - 区域偏移量，如果没有偏好，则为null
        结果
        划分的日期时间，不为空

      • ofInstant

        public static ZonedDateTime ofInstant​(Instant instant,
                                      ZoneId zone)
        从Instant获取ZonedDateTime的实例。

        这将创建一个与指定的时间相同的分区日期时间。 调用ChronoZonedDateTime.toInstant()将返回等于这里使用的时刻。

        将瞬间转换为划分的日期时间很简单，因为每个时刻只有一个有效的偏移量。

        参数
        instant - 即时创建日期时间，不为null
        zone - 时区，不为空
        结果
        划分的日期时间，不为空
        异常
        DateTimeException - 如果结果超出了支持的范围

      • ofInstant

        public static ZonedDateTime ofInstant​(LocalDateTime localDateTime,
                                      ZoneOffset offset,
                                      ZoneId zone)
        从本地日期时间和偏移量组合形成的瞬间获取ZonedDateTime的实例。

        这样就创建了一个划时代的日期，时间是LocalDateTime和ZoneOffset 。 这种组合唯一地指定了一个没有歧义的瞬间。

        将瞬间转换为划分的日期时间很简单，因为每个时刻只有一个有效的偏移量。 如果有效偏移量与指定的偏移量不同，则划分的日期 - 时间的日期 - 时间和偏移量将与指定的偏移量不同。

        如果ZoneId使用是ZoneOffset ，该方法等效于of(LocalDateTime, ZoneId) 。

        参数
        localDateTime - 本地日期时间，不为空
        offset - 区域偏移，不为空
        zone - 时区，不为空
        结果
        划分的日期时间，不为空

      • ofStrict

        public static ZonedDateTime ofStrict​(LocalDateTime localDateTime,
                                     ZoneOffset offset,
                                     ZoneId zone)
        获取ZonedDateTime的实例，严格验证本地日期时间，偏移量和区域ID的组合。

        这将创建一个分区的日期时间，以确保偏移量对于本地日期时间根据指定的区域的规则有效。 如果偏移量无效，则抛出异常。

        参数
        localDateTime - 本地日期时间，不为空
        offset - 区域偏移，不为空
        zone - 时区，不为空
        结果
        划分的日期时间，不为空
        异常
        DateTimeException - 如果参数组合无效

      • from

        public static ZonedDateTime from​(TemporalAccessor temporal)
        从时间对象获取一个ZonedDateTime的实例。

        这将根据指定的时间获得一个划区的日期时间。 A TemporalAccessor代表日期和时间信息的任意集合，该工厂转换为ZonedDateTime一个实例。

        转换将首先从时间对象获取一个ZoneId ，如有必要，可以回到ZoneOffset 。 然后会尝试获得一个Instant ，如果需要，可以退回到LocalDateTime 。 结果将是ZoneId或ZoneOffset与Instant或LocalDateTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考用作查询， ZonedDateTime::from 。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        划分的日期时间，不为空
        异常
        DateTimeException - 如果无法转换为 ZonedDateTime
        另请参见：
        Chronology.zonedDateTime(TemporalAccessor)

      • parse

        public static ZonedDateTime parse​(CharSequence text)
        从2007-12-03T10:15:30+01:00[Europe/Paris]等文本字符串获取ZonedDateTime的实例。

        字符串必须表示有效的日期时间，并使用DateTimeFormatter.ISO_ZONED_DATE_TIME进行解析。

        参数
        text - 要解析的文本，例如“2007-12-03T10：15：30 + 01：00 [Europe / Paris]”，不为空
        结果
        解析的分区日期时间，不为空
        异常
        DateTimeParseException - 如果文本无法解析

      • parse

        public static ZonedDateTime parse​(CharSequence text,
                                  DateTimeFormatter formatter)
        从使用特定格式化程序的文本字符串获取ZonedDateTime的实例。

        使用格式化程序解析文本，返回日期时间。

        参数
        text - 要解析的文本，不为空
        formatter - 使用的格式化程序，不为空
        结果
        解析的分区日期时间，不为空
        异常
        DateTimeParseException - 如果文本无法解析

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的日期时间。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        如果该字段是ChronoField，那么查询是在这里实现的。 支持的字段有：

        • NANO_OF_SECOND
        • NANO_OF_DAY
        • MICRO_OF_SECOND
        • MICRO_OF_DAY
        • MILLI_OF_SECOND
        • MILLI_OF_DAY
        • SECOND_OF_MINUTE
        • SECOND_OF_DAY
        • MINUTE_OF_HOUR
        • MINUTE_OF_DAY
        • HOUR_OF_AMPM
        • CLOCK_HOUR_OF_AMPM
        • HOUR_OF_DAY
        • CLOCK_HOUR_OF_DAY
        • AMPM_OF_DAY
        • DAY_OF_WEEK
        • ALIGNED_DAY_OF_WEEK_IN_MONTH
        • ALIGNED_DAY_OF_WEEK_IN_YEAR
        • DAY_OF_MONTH
        • DAY_OF_YEAR
        • EPOCH_DAY
        • ALIGNED_WEEK_OF_MONTH
        • ALIGNED_WEEK_OF_YEAR
        • MONTH_OF_YEAR
        • PROLEPTIC_MONTH
        • YEAR_OF_ERA
        • YEAR
        • ERA
        • INSTANT_SECONDS
        • OFFSET_SECONDS
        所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果在此日期时间内支持该字段，则为true，否则为false

      • isSupported

        public boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定的单位是否可以添加到该日期时间或从该日期时间中减去。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        如果单位是ChronoUnit，那么查询是在这里实现的。 支持的单位是：

        • NANOS
        • MICROS
        • MILLIS
        • SECONDS
        • MINUTES
        • HOURS
        • HALF_DAYS
        • DAYS
        • WEEKS
        • MONTHS
        • YEARS
        • DECADES
        • CENTURIES
        • MILLENNIA
        • ERAS
        所有其他ChronoUnit实例将返回false。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 此日期时间用于提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果不能获得该字段的范围
        UnsupportedTemporalTypeException - 如果不支持该字段

      • get

        public int get​(TemporalField field)
        从此日期时间获取指定字段的值作为int 。

        这将查询指定字段的值的此日期时间。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，那么在这里实现查询。 该supported fields将返回基于此日期时间有效值，除了NANO_OF_DAY ， MICRO_OF_DAY ， EPOCH_DAY ， PROLEPTIC_MONTH和INSTANT_SECONDS这是太大，无法在int并抛出UnsupportedTemporalTypeException 。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从此日期时间获取指定字段的值作为long 。

        这将查询指定字段的值的此日期时间。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将根据此日期时间返回有效值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获得该字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • getOffset

        public ZoneOffset getOffset​()
        获取区域偏移量，例如“+01：00”。

        这是当地时间与UTC /格林威治的抵消。

        Specified by:
        getOffset在接口 ChronoZonedDateTime<LocalDate>
        结果
        区域偏移，不为空

      • withEarlierOffsetAtOverlap

        public ZonedDateTime withEarlierOffsetAtOverlap​()
        返回此日期的副本，将区域偏移更改为本地时间线重叠处的两个有效偏移量的较早者。

        当本地时间线重叠时，例如在秋季夏令时切换时，此方法仅有效果。 在这种情况下，本地日期时间有两个有效的偏移量。 调用此方法将返回一个分区的日期时间，其中选择的两个之前的早期。

        如果在不重叠的情况下调用此方法，则返回this 。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        withEarlierOffsetAtOverlap在接口 ChronoZonedDateTime<LocalDate>
        结果
        一个 ZonedDateTime基于这个日期时间与较早的偏移量，不为null

      • withLaterOffsetAtOverlap

        public ZonedDateTime withLaterOffsetAtOverlap​()
        返回此日期的副本，将区域偏移更改为本地时间线重叠的两个有效偏移量的后面。

        当本地时间线重叠时，例如在秋季夏令时切换时，此方法仅有效果。 在这种情况下，本地日期时间有两个有效的偏移量。 调用此方法将返回一个分区的日期时间，后两个选择。

        如果在不重叠的情况下调用此方法，则返回this 。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        withLaterOffsetAtOverlap在接口 ChronoZonedDateTime<LocalDate>
        结果
        一个 ZonedDateTime基于这个日期时间与稍后的偏移量，不为null

      • getZone

        public ZoneId getZone​()
        获得时区，如“欧洲/巴黎”。

        这将返回区域ID。 这标识了时区rules ，该时区决定了UTC /格林威治的偏移量何时以及如何变化。

        区号可能与offset相同。 如果这是真的，那么任何未来的计算（如加法或减法）都不会因时区规则而复杂的边缘情况。 参见withFixedOffsetZone() 。

        Specified by:
        getZone在接口 ChronoZonedDateTime<LocalDate>
        结果
        时区，不为空

      • withZoneSameLocal

        public ZonedDateTime withZoneSameLocal​(ZoneId zone)
        使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。

        此方法更改时区并保留本地日期时间。 如果对于新区域无效，则本地日期时间将被更改，使用与ofLocal(LocalDateTime, ZoneId, ZoneOffset)相同的方法确定。

        要更改区域并调整本地日期时间，请使用withZoneSameInstant(ZoneId) 。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        withZoneSameLocal在接口 ChronoZonedDateTime<LocalDate>
        参数
        zone - 要更改的时区，不为空
        结果
        一个 ZonedDateTime基于这个日期时间与请求的区域，不为null

      • withZoneSameInstant

        public ZonedDateTime withZoneSameInstant​(ZoneId zone)
        使用不同的时区返回此日期时间的副本，保留即时。

        该方法更改时区并保留即时。 这通常会导致本地日期时间的更改。

        该方法基于保留相同的时刻，因此本地时间线上的间隙和重叠对结果没有影响。

        要保持本地时间更改偏移量，请使用withZoneSameLocal(ZoneId) 。

        Specified by:
        withZoneSameInstant在接口 ChronoZonedDateTime<LocalDate>
        参数
        zone - 要更改的时区，不为空
        结果
        一个 ZonedDateTime基于此日期时间与请求的区域，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • withFixedOffsetZone

        public ZonedDateTime withFixedOffsetZone​()
        返回此日期时间的副本，区域ID设置为偏移量。

        这将返回分区日期 - 时间，其中区域ID与getOffset()相同。 结果的当地日期时间，偏移量和时间将与此日期时间相同。

        将日期时间设置为固定的单个偏移量意味着由于时区规则，任何未来的计算（如加法或减法）都不会有复杂的边缘情况。 当通过网络发送分区的日期时间时，这也可能很有用，因为大多数协议（如ISO-8601）只处理偏移量，而不是基于区域的区域ID。

        这相当于ZonedDateTime.of(zdt.toLocalDateTime(), zdt.getOffset()) 。

        结果
        一个 ZonedDateTime ，区域ID设置为偏移量，不为空

      • toLocalDateTime

        public LocalDateTime toLocalDateTime​()
        获取此日期时间的LocalDateTime部分。

        这将返回一个LocalDateTime与这个日期时间相同的年，月，日和时间。

        Specified by:
        toLocalDateTime在接口 ChronoZonedDateTime<LocalDate>
        结果
        这个日期时间的本地日期时间部分，不为空

      • toLocalDate

        public LocalDate toLocalDate​()
        获取此日期时间的LocalDate部分。

        这将返回一个LocalDate与同一年，月和日在这个日期时间。

        Specified by:
        toLocalDate在接口 ChronoZonedDateTime<LocalDate>
        结果
        此日期时间的日期部分不为null

      • getYear

        public int getYear​()
        获取年份字段。

        此方法返回一年的原始值int 。

        通过这种方法返回的年份是根据get(YEAR)是灵巧的。 要获得年龄，请使用get(YEAR_OF_ERA) 。

        结果
        年，从MIN_YEAR到MAX_YEAR

      • getMonthValue

        public int getMonthValue​()
        将月份字段从1到12。

        该方法将一个月从int从1到12返回。如果通过调用getMonth()使用枚举Month，则应用代码通常更清楚。

        结果
        从1到12年的月份
        另请参见：
        getMonth()

      • getMonth

        public Month getMonth​()
        使用Month枚举获取月份字段。

        此方法返回本月的枚举Month 。 这样可以避免混淆int含义。 如果您需要访问原始的int值，则枚举将提供int value 。

        结果
        月份，不为零
        另请参见：
        getMonthValue()

      • getDayOfMonth

        public int getDayOfMonth​()
        获取月份字段。

        此方法返回int的原始值int值。

        结果
        从1到31日

      • getDayOfYear

        public int getDayOfYear​()
        获得日期字段。

        此方法返回int的原始值int值。

        结果
        一年中，从1到365，或闰年366

      • getDayOfWeek

        public DayOfWeek getDayOfWeek​()
        获取星期几字段，这是一个枚举DayOfWeek 。

        此方法返回星期几的枚举DayOfWeek 。 这避免了int值意味着什么的混乱。 如果您需要访问原始的int值，则枚举将提供int value 。

        更多信息可以从DayOfWeek获得。 这包括值的文本名称。

        结果
        星期几不为零

      • toLocalTime

        public LocalTime toLocalTime​()
        获得这个日期时间的LocalTime部分。

        这将返回一个LocalTime与这个日期时间相同的小时，分，秒和纳秒。

        Specified by:
        toLocalTime在接口 ChronoZonedDateTime<LocalDate>
        结果
        这个日期时间的一部分，不是null

      • getHour

        public int getHour​()
        获取时间字段。
        结果
        时间从0到23

      • getMinute

        public int getMinute​()
        获取小时字段。
        结果
        分钟，从0到59

      • getSecond

        public int getSecond​()
        获得第二分钟的字段。
        结果
        第二分钟，从0到59

      • getNano

        public int getNano​()
        获得纳秒第二场。
        结果
        纳秒，从0到999,999,999

      • with

        public ZonedDateTime with​(TemporalAdjuster adjuster)
        返回此日期时间的调整副本。

        这将返回一个ZonedDateTime ，基于此，日期时间调整。 调整使用指定的调整器策略对象进行。 阅读调整器的文档，了解将进行什么调整。

        一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 TemporalAdjusters提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 关键的日期时间类也实现了TemporalAdjuster接口，如Month和MonthDay 。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        例如这个代码在7月的最后一天返回一个日期：

          import static java.time.Month.*;
  import static java.time.temporal.TemporalAdjusters.*;

  result = zonedDateTime.with(JULY).with(lastDayOfMonth());

        LocalDate和LocalTime类实现TemporalAdjuster ，因此该方法可用于更改日期，时间或偏移量：

          result = zonedDateTime.with(date);
  result = zonedDateTime.with(time);

        ZoneOffset也实现了TemporalAdjuster但是使用它作为参数通常没有任何效果。 ZonedDateTime的偏移量主要由时区控制。 因此，更改偏移量通常不会有意义，因为本地日期时间和区域只有一个有效的偏移量。 如果划分的日期时间与夏令时重叠，则偏移量用于在两个有效偏移之间切换。 在所有其他情况下，偏移量将被忽略。

        该方法的结果是通过调用TemporalAdjuster.adjustInto(Temporal)方法，通过this作为参数来指定调整器。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        一个 ZonedDateTime基于 this进行调整，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        public ZonedDateTime with​(TemporalField field,
                          long newValue)
        返回此日期时间的副本，并将指定的字段设置为新值。

        这将返回一个ZonedDateTime ，基于此，更改指定字段的值。 这可以用于更改任何支持的字段，例如年，月或月。 如果不可能设置该值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        在某些情况下，更改指定的字段可能会导致生成的日期时间无效，例如将月份从1月31日更改为2月将导致日期无效。 在这种情况下，该领域负责解决日期。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        如果该字段是ChronoField，那么在这里实现调整。

        INSTANT_SECONDS字段将返回指定时间的日期时间。 区域和纳秒不变。 结果将具有来自新的即时和原始区域的偏移。 如果新的即时值超出有效范围，则将抛出DateTimeException 。

        通常会忽略OFFSET_SECONDS字段。 ZonedDateTime的偏移主要由时区控制。 因此，更改偏移量通常不会有意义，因为本地日期时间和区域只有一个有效的偏移量。 如果划分的日期时间与夏令时重叠，则偏移量用于在两个有效偏移之间切换。 在所有其他情况下，偏移量将被忽略。 如果新的偏移值超出有效范围，则抛出DateTimeException 。

        其他supported fields将按照LocalDateTime上的匹配方法进行操作 。 该区域不是计算的一部分，将不变。 当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.adjustInto(Temporal, long)传递this作为参数。 在这种情况下，该字段决定是否以及如何调整即时。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        with在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        一个 ZonedDateTime基于 this与指定的字段设置，不为null
        异常
        DateTimeException - 如果该字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • withYear

        public ZonedDateTime withYear​(int year)
        返回该ZonedDateTime的副本。

        这是在本地时间线，当地日期时间的changing the year 。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        year - 从MIN_YEAR到MAX_YEAR的结果年份
        结果
        一个 ZonedDateTime基于这个日期时间与所请求的一年，不为null
        异常
        DateTimeException - 如果年值无效

      • withMonth

        public ZonedDateTime withMonth​(int month)
        返回这个ZonedDateTime的副本， ZonedDateTime更改月。

        这是在当地时间线，当地日期时间的changing the month运行。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        month - 从1月1日至12日（12月），确定结果的月份
        结果
        一个 ZonedDateTime基于这个日期时间与请求的月份，不为null
        异常
        DateTimeException - 如果月份值无效

      • withDayOfMonth

        public ZonedDateTime withDayOfMonth​(int dayOfMonth)
        返回ZonedDateTime的副本，更改日期。

        这将在本地时间线（当地日期时间的changing the day-of-month）运行。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        dayOfMonth - 在1月28日至31日之间的结果中设定的月份
        结果
        一个 ZonedDateTime基于这个日期时间与请求的一天，不为null
        异常
        DateTimeException - 如果月日的价值无效，或者月中的日期对于月份无效

      • withDayOfYear

        public ZonedDateTime withDayOfYear​(int dayOfYear)
        返回此ZonedDateTime更改的ZonedDateTime的副本。

        这是在本地时间线，当地日期时间的changing the day-of-year操作。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        dayOfYear - 设定结果的日期，从1到365-366
        结果
        一个 ZonedDateTime基于此日期与请求的日期，不为null
        异常
        DateTimeException - 如果日期年值无效，或者如果当年的日期无效

      • withHour

        public ZonedDateTime withHour​(int hour)
        返回此ZonedDateTime的副本，并更改日期。

        这在本地时间线（ 当地时间的changing the time）运行。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        hour - 设置结果的时间从0到23
        结果
        一个 ZonedDateTime基于这个日期时间与请求的小时，不为null
        异常
        DateTimeException - 如果小时值无效

      • withMinute

        public ZonedDateTime withMinute​(int minute)
        返回此ZonedDateTime的副本，并更改小时。

        这是在本地时间线，当地日期时间的changing the time 。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minute - 在0到59之间设置结果的小时
        结果
        一个 ZonedDateTime基于这个日期时间与请求的分钟，不为null
        异常
        DateTimeException - 如果分钟值无效

      • withSecond

        public ZonedDateTime withSecond​(int second)
        返回此ZonedDateTime的副本，并更改了第二分钟。

        这是在本地时间线，当地日期时间的changing the time运行。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        second - 在0到59之间设置结果的 second
        结果
        一个 ZonedDateTime基于这个日期时间与请求的第二个，不为null
        异常
        DateTimeException - 如果第二个值无效

      • withNano

        public ZonedDateTime withNano​(int nanoOfSecond)
        返回这个ZonedDateTime的副本， ZonedDateTime改变了。

        这在当地的时间线当地的日期时间是changing the time 。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanoOfSecond - 纳秒在结果中设置，从0到999,999,999
        结果
        一个 ZonedDateTime基于这个日期时间与请求的纳秒，不为null
        异常
        DateTimeException - 如果纳米值无效

      • truncatedTo

        public ZonedDateTime truncatedTo​(TemporalUnit unit)
        返回此ZonedDateTime的副本，截断时间。

        截断返回原始日期时间的副本，其中小于指定单位的字段设置为零。 例如，使用minutes单元进行截断将将第二分钟和第二纳秒字段设置为零。

        该单位必须有一个duration ，分为标准日期的长度， 无余数。 这包括所有提供的时间单位ChronoUnit和DAYS 。 其他单位抛出异常。

        这是在本地时间线， truncating本地日期时间的基础上运行。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        unit - 截断到的单位，不为null
        结果
        一个 ZonedDateTime基于此日期时间截断，不为null
        异常
        DateTimeException - 如果无法截断
        UnsupportedTemporalTypeException - 如果不支持本机

      • plus

        public ZonedDateTime plus​(TemporalAmount amountToAdd)
        返回此日期时间的副本，并添加指定的数量。

        这将返回一个ZonedDateTime ，基于此，添加指定的数量。 金额通常为Period或Duration，但可以是实现TemporalAmount界面的任何其他类型。

        通过调用TemporalAmount.addTo(Temporal)将计算委托给金额对象。 数量执行可以以任何方式实现添加，但是它通常会回调到plus(long, TemporalUnit) 。 请参阅金额执行的文档，以确定是否可以成功添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的金额，不为null
        结果
        一个 ZonedDateTime基于这个日期时间与添加，而不是null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        public ZonedDateTime plus​(long amountToAdd,
                          TemporalUnit unit)
        返回此日期时间的副本，并添加指定的数量。

        这将返回一个ZonedDateTime ，基于此，以添加的单位计算。 如果不可能添加金额，因为单位不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoUnit，那么在这里实现添加。 该区域不是计算的一部分，结果将不会改变。 日期和时间单位的计算不同。

        日期单位在当地时间线上运行。 该时间段首先添加到本地日期时间，然后使用区域ID转换回分区日期时间。 该转换使用ofLocal(LocalDateTime, ZoneId, ZoneOffset)与添加之前的偏移量。

        时间单位在即时时间线上运行。 该时间段首先添加到本地日期时间，然后使用区域ID转换回分区日期时间。 该转换使用ofInstant(LocalDateTime, ZoneOffset, ZoneId)与添加之前的偏移量。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为参数。 在这种情况下，单元确定是否以及如何执行添加。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        plus在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 添加到结果中的单位数量可能为负数
        unit - 要添加的单位，不为null
        结果
        一个 ZonedDateTime基于此日期时间与指定的数量添加，不为null
        异常
        DateTimeException - 如果不能添加
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • plusYears

        public ZonedDateTime plusYears​(long years)
        以指定的年数返回此ZonedDateTime的副本。

        这将按当地时间线adding years运行到当地的日期。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        years - 多年来补充，可能是负数
        结果
        一个 ZonedDateTime基于这个日期时间与添加的年份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusMonths

        public ZonedDateTime plusMonths​(long months)
        返回此ZonedDateTime的副本，并附加指定的月数。

        这将按当地时间线adding months运行到当地的日期。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        months - 要添加的月份，可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间与添加的月份，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • plusWeeks

        public ZonedDateTime plusWeeks​(long weeks)
        返回此ZonedDateTime的副本，并附加指定的周数。

        这将在本地时间线上运行，当地日期时间为adding weeks 。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        weeks - 要添加的星期可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间与添加的星期，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusDays

        public ZonedDateTime plusDays​(long days)
        以指定的天数返回此ZonedDateTime的副本。

        这将按当地时间线adding days运行到当地的日期。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        days - 添加的日子可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间与添加的天数，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • plusHours

        public ZonedDateTime plusHours​(long hours)
        返回此ZonedDateTime的副本，并附加指定的小时数。

        这将在即时的时间线上运行，这样添加一个小时将始终是一个小时之后的持续时间。 这可能导致本地日期时间改变一个小时以外的数量。 请注意，这是与日，月，年使用的不同的方法，因此添加一天与添加24小时不同。

        例如，考虑一个时区，如“欧洲/巴黎”，秋季DST切换意味着当地时间02:00至02:59发生两次，从夏季的偏移+02：00发生到+01：00冬天里。

        • 添加一个小时到01：30 + 02：00将导致02：30 + 02：00（夏季时间）
        • 添加一个小时到02：30 + 02：00将导致02：30 + 01：00（从夏季到冬季）
        • 增加一个小时02：30 + 01：00将导致03：30 + 01：00（冬季都会）
        • 在01：30 + 02：00加3个小时将导致03：30 + 01：00（从夏至夏）

        此实例是不可变的，不受此方法调用的影响。

        参数
        hours - 要添加的时间可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间添加的时间，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • plusMinutes

        public ZonedDateTime plusMinutes​(long minutes)
        以指定的分钟数返回此ZonedDateTime的副本。

        这将在即时时间线上运行，这样添加一分钟将始终是一分钟后的持续时间。 这可能导致本地日期时间改变一分钟以外的数量。 请注意，这是与日，月，年使用的不同的方法。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutes - 要添加的分钟，可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间添加分钟，不为null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • plusSeconds

        public ZonedDateTime plusSeconds​(long seconds)
        返回此ZonedDateTime的副本，并添加指定的秒数。

        这在即时时间线上运行，使得添加一秒将始终是一秒钟的持续时间。 这可能导致本地日期时间改变一秒以外的数量。 请注意，这是与日，月，年使用的不同的方法。

        此实例是不可变的，不受此方法调用的影响。

        参数
        seconds - 添加的秒数可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间添加的秒，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • plusNanos

        public ZonedDateTime plusNanos​(long nanos)
        返回此ZonedDateTime的副本， ZonedDateTime添加了指定的纳秒数。

        这在即时时间线上运行，使得添加一个纳米将始终是一纳秒的持续时间。 这可能导致本地日期时间改变不是一个纳米的数量。 请注意，这是与日，月，年使用的不同的方法。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanos - nanos添加，可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间加上纳秒，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minus

        public ZonedDateTime minus​(TemporalAmount amountToSubtract)
        返回此日期时间的副本，并减去指定的金额。

        这将返回一个ZonedDateTime ，基于此，减去指定的数量。 金额通常为Period或Duration，但可能是实现TemporalAmount界面的任何其他类型。

        通过调用TemporalAmount.subtractFrom(Temporal)将计算委托给金额对象。 数量执行可以以任何方式自由实现减法，但是它通常会回调到minus(long, TemporalUnit) 。 请参阅数量执行的文档，以确定是否可以成功减去它们。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去量，不为空
        结果
        一个 ZonedDateTime基于这个日期时间与减法而不是null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        public ZonedDateTime minus​(long amountToSubtract,
                           TemporalUnit unit)
        返回此日期时间的副本，并减去指定的金额。

        这将返回一个ZonedDateTime ，基于此，减去的单位数量。 如果不可能减去金额，因为该单位不受支持或出于某种其他原因，则会抛出异常。

        日期和时间单位的计算不同。

        日期单位在当地时间线上运行。 该时间段首先从本地日期时间中减去，然后使用区域ID转换回分区日期时间。 转换使用ofLocal(LocalDateTime, ZoneId, ZoneOffset)与减法之前的偏移量。

        时间单位在即时时间线上运行。 该时间段首先从本地日期时间中减去，然后使用区域ID转换回分区日期时间。 转换使用ofInstant(LocalDateTime, ZoneOffset, ZoneId)与减法之前的偏移量。

        此方法相当于plus(long, TemporalUnit) ，其数量被否定。 请参阅该方法，以了解如何添加，从而减去运算。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        minus在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 从结果中减去的单位数量可能为负数
        unit - 减去量的单位，不为空
        结果
        一个 ZonedDateTime基于此日期时间减去指定的数量，不为null
        异常
        DateTimeException - 如果不能进行减法
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minusYears

        public ZonedDateTime minusYears​(long years)
        返回此ZonedDateTime的副本，并减去指定的年数。

        这将在本地时间线上运行，当地日期时间为subtracting years 。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        years - 减去年份，可能是负数
        结果
        一个 ZonedDateTime基于这个日期时间与减去的年份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusMonths

        public ZonedDateTime minusMonths​(long months)
        返回此ZonedDateTime的副本，并减去指定的月数。

        这将在本地时间线上运行，当地日期时间为subtracting months 。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        months - 减去数月，可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间与减去的月份，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusWeeks

        public ZonedDateTime minusWeeks​(long weeks)
        返回此ZonedDateTime的副本，并减去指定的周数。

        这将按当地时间线subtracting weeks运行到当地的日期。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        weeks - 减去的星期可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间与减去的星期，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusDays

        public ZonedDateTime minusDays​(long days)
        返回此ZonedDateTime的副本，并减去指定的天数。

        这将按当地时间线subtracting days运行到当地的日期。 然后将其转换回ZonedDateTime ，使用区域ID获取偏移量。

        当转换回ZonedDateTime ，如果本地日期时间重叠，则可能会保留偏移量，否则将使用较早的偏移量。 如果有差距，当地的日期时间将按差距的长短进行调整。

        此实例是不可变的，不受此方法调用的影响。

        参数
        days - 减去的日子可能是负数
        结果
        一个 ZonedDateTime基于这个日期时间减去的日期，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusHours

        public ZonedDateTime minusHours​(long hours)
        返回此ZonedDateTime的副本，并减去指定的小时数。

        这在即时时间线上运行，使得减去一小时将始终是一小时前的持续时间。 这可能导致本地日期时间改变一个小时以外的数量。 请注意，这是与日，月，年使用的不同的方法，因此减去一天与添加24小时不同。

        例如，考虑一个时区，如“欧洲/巴黎”，秋季DST切换意味着当地时间02:00至02:59发生两次，从夏季的偏移+02：00发生到+01：00冬天里。

        • 从03：30 + 01：00减去一小时将导致02：30 + 01：00（冬季时）
        • 从02：30 + 01：00减去一小时将会导致02：30 + 02：00（从冬季到夏季）
        • 从02：30 + 02：00减去一个小时将导致01：30 + 02：00（夏季时间）
        • 从03：30 + 01：00减去三个小时将导致01：30 + 02：00（从冬季到夏季）

        此实例是不可变的，不受此方法调用的影响。

        参数
        hours - 减去的时间可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间减去的小时数，不为空
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusMinutes

        public ZonedDateTime minusMinutes​(long minutes)
        返回此ZonedDateTime的副本，并减去指定的分钟数。

        这在即时时间线上运行，使得减去一分钟将始终是一分钟前的持续时间。 这可能导致本地日期时间改变一分钟以外的数量。 请注意，这是与日，月，年使用的不同的方法。

        此实例是不可变的，不受此方法调用的影响。

        参数
        minutes - 减去的分数可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间减去分钟，而不是null
        异常
        DateTimeException - 如果结果超出了支持的日期范围

      • minusSeconds

        public ZonedDateTime minusSeconds​(long seconds)
        返回此ZonedDateTime的副本，并减去指定的秒数。

        这在即时时间线上操作，使得减去一秒将始终是早一秒的持续时间。 这可能导致本地日期时间改变一秒以外的数量。 请注意，这是与日，月，年使用的不同的方法。

        此实例是不可变的，不受此方法调用的影响。

        参数
        seconds - 减去的秒数可能为负数
        结果
        一个 ZonedDateTime基于这个日期时间减去秒，不为空
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • minusNanos

        public ZonedDateTime minusNanos​(long nanos)
        返回此ZonedDateTime的副本，并减去指定的纳秒数。

        这在即时时间线上操作，使得减去一个纳米将始终是一个纳米的持续时间。 这可能导致本地日期时间改变不是一个纳米的数量。 请注意，这是与日，月，年使用的不同的方法。

        此实例是不可变的，不受此方法调用的影响。

        参数
        nanos - nanos减去，可能是负数
        结果
        一个 ZonedDateTime基于这个日期时间减去纳秒，而不是null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此日期时间。

        这将使用指定的查询策略对象查询此日期时间。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过调用TemporalQuery.queryFrom(TemporalAccessor)方法，通过this作为参数的指定查询。

        Specified by:
        query在接口 ChronoZonedDateTime<LocalDate>
        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        根据指定的单位计算到另一个日期时间的时间量。

        这可以计算一个ZonedDateTime对象之间的时间量，单个TemporalUnit 。 起点和终点是this和指定的日期时间。 如果结束在开始之前，结果将为负数。 例如，可以使用startDateTime.until(endDateTime, DAYS)计算两个日期时间之间的天startDateTime.until(endDateTime, DAYS) 。

        所述Temporal传递给此方法被转换为ZonedDateTime使用from(TemporalAccessor) 。 如果两个划分的日期时间之间的时区不同，则指定的结束日期时间被归一化为与此日期时间相同的区域。

        计算返回一个整数，表示两个日期时间之间的完整单位数。 例如，2012-06-15T00：00Z和2012-08-14T23：59Z之间的月数将只有一个月，因为是两个月不到一分钟。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        此方法的计算用于ChronoUnit 。 单位NANOS ， MICROS ， MILLIS ， SECONDS ， MINUTES ， HOURS和HALF_DAYS ， DAYS ， WEEKS ， MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS的支持。 其他ChronoUnit值将抛出异常。

        日期和时间单位的计算不同。

        日期单位使用本地日期时间在本地时间线上运行。 例如，无论是否有夏令时改变，从第一天中午到第二天，以天为单位的时间段，一律不计一天。

        时间单位在即时时间线上运行。 计算有效地将两个划分的日期时间转换为时刻，然后计算时刻之间的时间间隔。 例如，根据是否有夏令时更改，从第1天中午到第二天（小时）之间的期间可能是23,24或25小时（或其他一些数量）。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，转换为 ZonedDateTime ，不为空
        unit - 测量金额的单位，不为空
        结果
        在此日期和结束日期时间之间的时间量
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 ZonedDateTime
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • format

        public String format​(DateTimeFormatter formatter)
        使用指定的格式化程序格式化此日期时间。

        这个日期时间将传递给格式化程序以生成一个字符串。

        Specified by:
        format在接口 ChronoZonedDateTime<LocalDate>
        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的日期时间字符串，不为空
        异常
        DateTimeException - 打印过程中是否发生错误

      • toOffsetDateTime

        public OffsetDateTime toOffsetDateTime​()
        将此日期时间转换为OffsetDateTime 。

        这将使用本地日期时间和偏移量创建偏移日期时间。 区域ID被忽略。

        结果
        表示相同本地日期时间和偏移量的偏移日期时间，不为空

      • equals

        public boolean equals​(Object obj)
        检查此日期时间是否等于另一个日期时间。

        比较是基于偏移日期时间和区域。 只比较ZonedDateTime类型的对象，其他类型返回false。

        Specified by:
        equals在接口 ChronoZonedDateTime<LocalDate>
        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期时间，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个日期时间的哈希码。
        Specified by:
        hashCode在接口 ChronoZonedDateTime<LocalDate>
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        将此日期时间输出为String ，例如2007-12-03T10:15:30+01:00[Europe/Paris] 。

        格式由LocalDateTime组成，其次是ZoneOffset 。 如果ZoneId与偏移量不相同，则输出ID。 如果偏移量和ID相同，输出与ISO-8601兼容。

        Specified by:
        toString在接口 ChronoZonedDateTime<LocalDate>
        重写：
        toString在 Object
        结果
        此日期时间的字符串表示形式，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ZoneId (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class ZoneId

  • java.lang.Object
    • java.time.ZoneId
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ZoneOffset

    public abstract class ZoneId
extends Object
implements Serializable
    时区ID，如Europe/Paris 。

    A ZoneId用于标识用于在Instant和LocalDateTime之间转换的规则。 有两种不同类型的ID：

    • 固定偏移量 - 从UTC /格林威治完全解析的偏移量，对所有本地日期时间使用相同的偏移量
    • 地理区域 - 适用于查找UTC /格林威治的偏移量的特定规则集的区域
    大多数固定偏移量由ZoneOffset表示。 主叫normalized()上任何ZoneId将确保一个固定的偏移ID将被表示为ZoneOffset 。

    描述偏移变化的时间和方式的实际规则由ZoneRules定义。 这个类只是一个用于获取基本规则的ID。 采取这种方法是因为规则由政府定义并且频繁变化，而ID是稳定的。

    这个区别有其他的影响。 序列化ZoneId只会发送ID，而序列化规则会发送整个数据集。 类似地，两个ID的比较仅检查ID，而两个规则的比较检查整个数据集。

    时区ID

    该ID在系统内是唯一的。 有三种类型的ID。

    最简单的ID是ZoneOffset 。 这由“Z”和以“+”或“ - ”开头的ID组成。

    下一种类型的ID是具有某些形式的前缀的偏移样式ID，例如“GMT + 2”或“UTC + 01：00”。 识别的前缀是“UTC”，“GMT”和“UT”。 偏移量是后缀，在创建过程中将被归一化。 这些ID可以使用normalized()归一ZoneOffset normalized() 。

    第三种类型的ID是基于区域的ID。 基于区域的ID必须为两个或更多个字符，而不是以“UTC”，“GMT”，“UT”+“或” - “开头。 基于区域的ID由配置定义，请参见ZoneRulesProvider 。 配置重点是提供从ID到底层的查找ZoneRules 。

    时区规则由政府界定，频繁变化。 有一些组织，这里被称为组，监视时区更改并整理它们。 默认组是IANA时区数据库（TZDB）。 其他组织包括国际航协（航空业机构）和微软。

    每个组为其提供的区域ID定义其自己的格式。 TZDB组定义了诸如“Europe / London”或“America / New_York”之类的ID。 TZDB ID优先于其他组。

    强烈建议组名称包含在TZDB以外的组所提供的所有ID中，以避免冲突。 例如，IATA航空公司时区区域ID通常与三字母机场代码相同。 但是，乌特勒支机场的代码“UTC”显然是一个冲突。 来自TZDB以外的组的区域ID的推荐格式为“group〜region”。 因此，如果定义了IATA数据，乌得勒支机场将是“IATA〜UTC”。

    序列化

    该类可以序列化，并将字符串区域ID存储在外部表单中。 ZoneOffset子类使用仅存储UTC /格林威治的偏移量的专用格式。

    A ZoneId可以在Java运行时反序列化，其中ID是未知的。 例如，如果服务器端Java运行时已经使用新的区域ID更新，但是客户端Java运行时尚未更新。 在这种情况下， ZoneId对象会存在，并且可以使用被查询getId ， equals ， hashCode ， toString ， getDisplayName和normalized 。 但是，任何拨打getRules电话getRules将与ZoneRulesException失败。 此方法旨在允许在具有不完整时区信息的Java运行时上加载和查询ZonedDateTime ，但不进行修改。

    这是一个value-based课; 在ZoneId实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预知的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个抽象类有两个实现，这两个实现是不可变的和线程安全的。 一个实现模型基于区域的ID，另一个是基于偏移的ID建立ZoneOffset 。 这种差异在序列化中可见。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Map<String,String> SHORT_IDS
      区域覆盖的映射，以启用短时区名称。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查此时区ID是否等于其他时区ID。
      static ZoneId from​(TemporalAccessor temporal)
      从时间对象获取 ZoneId的实例。
      static Set<String> getAvailableZoneIds​()
      获取一组可用的区域ID。
      String getDisplayName​(TextStyle style, Locale locale)
      获取区域的文字表示，例如“英国时间”或“+02：00”。
      abstract String getId​()
      获取唯一的时区ID。
      abstract ZoneRules getRules​()
      获取此ID的时区规则，允许执行计算。
      int hashCode​()
      此时区ID的哈希码。
      ZoneId normalized​()
      规范时区ID，尽可能返回 ZoneOffset 。
      static ZoneId of​(String zoneId)
      从ID获取一个 ZoneId的实例，确保该ID是有效的并且可供使用。
      static ZoneId of​(String zoneId, Map<String,String> aliasMap)
      获取 ZoneId的实例，使用其ID使用别名映射来补充标准区域ID。
      static ZoneId ofOffset​(String prefix, ZoneOffset offset)
      获取一个 ZoneId的实例包装一个偏移量。
      static ZoneId systemDefault​()
      获取系统默认时区。
      String toString​()
      使用ID将该区域输出为 String 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SHORT_IDS

        public static final Map<String,String> SHORT_IDS
        区域覆盖的映射，以启用短时区名称。

        在java.util.TimeZone已经不推荐使用短区域ID。 该地图允许通过of(String, Map)工厂方法继续使用ID。

        此映射包含与TZDB 2005r及更高版本一致的ID的映射，其中“EST”，“MST”和“HST”映射到不包括夏令时的ID。

        这个地图如下：

        • EST - -05：00
        • HST - -10：00
        • MST - -07：00
        • ACT - 澳大利亚/达尔文
        • 澳大利亚/悉尼
        • AGT - 美洲/阿根廷/布宜诺斯艾利斯
        • 艺术 - 非洲/开罗
        • AST - 美国/安克拉治
        • BET - America / Sao_Paulo
        • BST - 亚洲/达卡
        • CAT - 非洲/哈拉雷
        • CNT - America / St_Johns
        • CST - 美国/芝加哥
        • CTT - 亚洲/上海
        • EAT - 非洲/ Addis_Ababa
        • ECT - 欧洲/巴黎
        • IET - 美洲/印第安纳州/印第安纳州
        • IST - 亚洲/加尔各答
        • JST - 亚洲/东京
        • 麻省理工学院 - 太平洋/阿皮亚
        • NET - 亚洲/埃里温
        • NST - 太平洋/奥克兰
        • PLT - 亚洲/卡拉奇
        • PNT - 美国/凤凰城
        • PRT - 美洲/波多黎各
        • PST - 美国/ Los_Angeles
        • 太平洋岛屿/瓜达尔卡纳群岛
        • VST - 亚洲/ Ho_Chi_Minh
        地图是不可修改的。

    • 方法详细信息

      • systemDefault

        public static ZoneId systemDefault​()
        获取系统默认时区。

        查询TimeZone.getDefault()查询默认时区并将其转换为ZoneId 。 如果系统默认时区更改，则此方法的结果也会发生变化。

        结果
        区域ID，不为空
        异常
        DateTimeException - 如果转换的区域ID格式无效
        ZoneRulesException - 如果 ZoneRulesException转换的区域区域ID

      • getAvailableZoneIds

        public static Set<String> getAvailableZoneIds​()
        获取一组可用的区域ID。

        该集合包括所有可用的基于区域的ID的字符串形式。 返回的集合中不包括基于偏移的区域ID。 该ID可以传递给of(String)创建一个ZoneId 。

        区域ID的集合可以随着时间而增加，尽管在典型的应用中，ID集合是固定的。 每次调用此方法都是线程安全的。

        结果
        一组区域ID的可修改副本，不为空

      • of

        public static ZoneId of​(String zoneId,
                        Map<String,String> aliasMap)
        获取使用其ID的ZoneId实例，使用别名映射来补充标准区域ID。

        时区的许多用户使用简短的缩写，例如“太平洋标准时间”的PST和“太平洋夏令时”的PDT。 这些缩写不是唯一的，因此不能用作ID。 该方法允许在应用程序内设置和重新使用字符串到时区的映射。

        参数
        zoneId - 时区ID，不为空
        aliasMap - 实际区域ID的别名区域ID（通常为缩写）的映射，不为空
        结果
        区域ID，不为空
        异常
        DateTimeException - 区域ID是否格式无效
        ZoneRulesException - 如果区域ID是无法找到的区域ID

      • of

        public static ZoneId of​(String zoneId)
        从ID获取ZoneId的实例，确保该ID有效并可供使用。

        此方法解析产生一个ZoneId或ZoneOffset的ID。 如果ID为“Z”，则返回A ZoneOffset ，或以“+”或“ - ”开头。 结果将永远是一个有效的ID， 可以获得ZoneRules 。

        解析如下一步地匹配区域ID。

        • 如果区域ID等于'Z'，结果为ZoneOffset.UTC 。
        • 如果区域ID由单个字母组成，则区域ID无效， DateTimeException抛出DateTimeException 。
        • 如果区域ID以“+”或“ - ” ZoneOffset使用ZoneOffset.of(String)将该ID解析为ZoneOffset 。
        • 如果区域ID等于'GMT'，'UTC'或'UT'，那么结果是一个ZoneId ，其ID和规则相当于ZoneOffset.UTC 。
        • 如果区域ID以“UTC +”，“UTC-”，“GMT +”，“GMT-”，“UT +”或“UT-”开头，那么ID就是前缀的基于偏移量的ID。 ID分为两个，两个或三个字母的前缀和一个以符号开头的后缀。 后缀被解析为ZoneOffset 。 其结果将是一个ZoneId与指定UTC / GMT / UT前缀和归一化的偏移ID作为每ZoneOffset.getId() 。 返回的ZoneId的规则将相当于已解析的ZoneOffset 。
        • 所有其他ID都将被分析为基于区域的区域ID。 区域ID必须与正则表达式[A-Za-z][A-Za-z0-9~/._+-]+匹配，否则抛出DateTimeException 。 如果区域ID不在配置的ID ZoneRulesException则抛出ZoneRulesException 。 区域ID的详细格式取决于提供数据的组。 默认数据集由IANA时区数据库（TZDB）提供。 它具有“{area} / {city}”形式的区域ID，例如“Europe / Paris”或“America / New_York”。 这与TimeZone中的大多数ID兼容。
        参数
        zoneId - 时区ID，不为空
        结果
        区域ID，不为空
        异常
        DateTimeException - 区域ID是否格式无效
        ZoneRulesException - 如果区域ID是无法找到的区域ID

      • ofOffset

        public static ZoneId ofOffset​(String prefix,
                              ZoneOffset offset)
        获取一个ZoneId包装偏移的实例。

        如果前缀为“GMT”，“UTC”或“UT”，则ZoneId带前缀和非零偏移的ZoneId 。 如果前缀为空"" ，则返回ZoneOffset 。

        参数
        prefix - 时区ID，不为空
        offset - offset，not null
        结果
        区域ID，不为空
        异常
        IllegalArgumentException - 如果前缀不是“GMT”，“UTC”或“UT”或“”

      • from

        public static ZoneId from​(TemporalAccessor temporal)
        从时间对象获取一个ZoneId的实例。

        这获得了基于指定时间的区域。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为ZoneId一个实例。

        A TemporalAccessor表示某种形式的日期和时间信息。 该工厂将任意的时间对象转换为ZoneId的实例。

        转换将尝试使用TemporalQueries.zone()以基于偏移的区域为基础的区域获取区域。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考ZoneId::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        区域ID，不为空
        异常
        DateTimeException - 如果无法转换为 ZoneId

      • getId

        public abstract String getId​()
        获取唯一的时区ID。

        此ID唯一地定义了该对象。 基于偏移的ID的格式由ZoneOffset.getId()定义。

        结果
        时区唯一ID，不为空

      • getDisplayName

        public String getDisplayName​(TextStyle style,
                             Locale locale)
        获取区域的文字表示，例如“英国时间”或“+02：00”。

        这返回用于标识时区ID的文本名称，适用于向用户呈现。 参数控制返回的文本和区域设置的样式。

        如果没有发现文本映射，则返回full ID 。

        参数
        style - 所需文本的长度，不为空
        locale - 要使用的语言环境，不为空
        结果
        区域的文本值，不为空

      • getRules

        public abstract ZoneRules getRules​()
        获取此ID的时区规则，允许执行计算。

        规则提供与时区相关联的功能，例如查找给定即时或本地日期时间的偏移量。

        如果在Java运行时反序列化时区，则该时区不能与存储它的Java运行时加载相同的规则。 在这种情况下，调用此方法将抛出一个ZoneRulesException 。

        规则由ZoneRulesProvider提供。 高级提供商可以支持规则的动态更新，而无需重新启动Java运行时。 如果是这样，则该方法的结果可能会随时间而变化。 每个单独的呼叫仍将保持线程安全。

        ZoneOffset将始终返回一组规则，其中偏移量不会更改。

        结果
        规则，不为空
        异常
        ZoneRulesException - 如果没有规则可用于此ID

      • normalized

        public ZoneId normalized​()
        规范时区ID，尽可能返回ZoneOffset 。

        返回归一化的ZoneId可以用于代替此ID。 结果将具有ZoneRules相当于该对象返回的值，但是由getId()返回的ID可能不同。

        规范化检查此ZoneId的规则ZoneId具有固定的偏移量。 如果这样做，则ZoneOffset等于该偏移量的ZoneOffset 。 否则返回this 。

        结果
        时区唯一ID，不为空

      • equals

        public boolean equals​(Object obj)
        检查此时区ID是否等于其他时区ID。

        比较是基于ID。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他时区ID，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        此时区ID的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        输出此区域为 String ，使用ID。
        重写：
        toString在 Object
        结果
        此时区ID的字符串表示形式，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ZoneOffset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time

Class ZoneOffset

  • java.lang.Object
    • java.time.ZoneId
      • java.time.ZoneOffset
  • All Implemented Interfaces:
    Serializable ， Comparable<ZoneOffset> ， TemporalAccessor ， TemporalAdjuster

    public final class ZoneOffset
extends ZoneId
implements TemporalAccessor, TemporalAdjuster, Comparable<ZoneOffset>, Serializable
    与格林威治/ UTC的时区偏移，如+02:00 。

    时区偏移量是时区与格林威治/ UTC不同的时间量。 这通常是固定的几小时和几分钟。

    世界不同的地区有不同的时区偏移。 ZoneId课程中记录了偏移量随地点和年份变化的规则。

    例如，巴黎在冬季比格林威治/ UTC提前了一个小时，夏天还有两个小时。 该ZoneId实例巴黎将两个参考ZoneOffset实例-一个+01:00冬季实例，以及+02:00夏季实例。

    2008年，世界各地的时区偏移从-12：00延长到+14：00。 为了防止该范围的任何问题得到扩展，但仍然提供验证，偏移范围限制在-18：00至18:00（含）。

    该课程旨在与ISO日历系统配合使用。 小时，分钟和秒的字段对这些字段的标准ISO定义有效。 该类可以与其他日历系统一起使用，提供与ISO日历系统的时间字段相匹配的时间字段的定义。

    ZoneOffset实例必须使用equals(java.lang.Object)进行比较。 实现可能会选择缓存某些常见的偏移量，但是应用程序不能依赖这种缓存。

    这是一个value-based类; 在ZoneOffset实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会有不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static ZoneOffset MAX
      最大支持偏移量的常数。
      static ZoneOffset MIN
      最小支持偏移量的常数。
      static ZoneOffset UTC
      UTC的时区偏移量，ID为“Z”。

      • Fields inherited from class java.time.ZoneId

        SHORT_IDS

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象的偏移量相同。
      int compareTo​(ZoneOffset other)
      将此偏移量与其他偏移量按降序进行比较。
      boolean equals​(Object obj)
      检查这个偏移量是否等于另一个偏移量。
      static ZoneOffset from​(TemporalAccessor temporal)
      从时间对象获取 ZoneOffset的实例。
      int get​(TemporalField field)
      从该偏移量获取指定字段的值作为 int 。
      String getId​()
      获取标准化区域偏移ID。
      long getLong​(TemporalField field)
      从该偏移量获取指定字段的值作为 long 。
      ZoneRules getRules​()
      获取相关的时区规则。
      int getTotalSeconds​()
      获取总区域偏移量（以秒为单位）。
      int hashCode​()
      这个偏移的哈希码。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      static ZoneOffset of​(String offsetId)
      使用ID获取 ZoneOffset的实例。
      static ZoneOffset ofHours​(int hours)
      获取 ZoneOffset的实例，使用小时数的偏移量。
      static ZoneOffset ofHoursMinutes​(int hours, int minutes)
      获取 ZoneOffset的实例，以小时和分钟为 ZoneOffset使用偏移量。
      static ZoneOffset ofHoursMinutesSeconds​(int hours, int minutes, int seconds)
      获取 ZoneOffset的实例，使用小时，分钟和秒的偏移量。
      static ZoneOffset ofTotalSeconds​(int totalSeconds)
      获取 ZoneOffset的实例，指定总偏移量（以秒为单位）
      <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此偏移量。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      String toString​()
      使用归一化ID将此偏移量输出为 String 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.time.ZoneId

        getAvailableZoneIds, getDisplayName, normalized, of, ofOffset, systemDefault

    • 字段详细信息

      • UTC

        public static final ZoneOffset UTC
        UTC的时区偏移量，ID为“Z”。

      • MIN

        public static final ZoneOffset MIN
        最小支持偏移量的常数。

      • MAX

        public static final ZoneOffset MAX
        最大支持偏移量的常数。

    • 方法详细信息

      • of

        public static ZoneOffset of​(String offsetId)
        使用ID获取ZoneOffset的实例。

        此方法解析一个ZoneOffset的字符串ID以返回一个实例。 解析接受getId()生成的所有格式，加上一些其他格式：

        • Z - UTC
        • +h
        • +hh
        • +hh:mm
        • -hh:mm
        • +hhmm
        • -hhmm
        • +hh:mm:ss
        • -hh:mm:ss
        • +hhmmss
        • -hhmmss
        请注意，“+”表示正号或负号。

        返回的偏移量的ID将被归一化为getId()描述的格式之一 。

        最大支持范围为+18：00至-18：00。

        参数
        offsetId - 偏移ID，不为空
        结果
        zone-offset，not null
        异常
        DateTimeException - 如果偏移ID无效

      • ofHours

        public static ZoneOffset ofHours​(int hours)
        获得 ZoneOffset的实例，使用小时数的偏移量。
        参数
        hours - 以-18到+18为单位的时区偏移量
        结果
        zone-offset，not null
        异常
        DateTimeException - 如果偏移量不在所需范围内

      • ofHoursMinutes

        public static ZoneOffset ofHoursMinutes​(int hours,
                                        int minutes)
        获取ZoneOffset的实例，以小时和分钟为ZoneOffset使用偏移量。

        小时和分钟组件的符号必须匹配。 因此，如果小时数是负数，则分钟必须为负或为零。 如果小时为零，分钟可能为正，负或零。

        参数
        hours - 以-18到+18为单位的时区偏移量
        minutes - 以分钟为单位的时区偏移量，从0到±59，表示匹配小时数
        结果
        zone-offset，not null
        异常
        DateTimeException - 如果偏移量不在所需范围内

      • ofHoursMinutesSeconds

        public static ZoneOffset ofHoursMinutesSeconds​(int hours,
                                               int minutes,
                                               int seconds)
        获取ZoneOffset的实例，使用小时，分钟和秒的偏移量。

        小时，分钟和秒组件的符号必须匹配。 因此，如果时间是负数，则分钟和秒必须为负或为零。

        参数
        hours - 以-18到+18为单位的时区偏移量
        minutes - 以分钟为单位的时区偏移量，从0到±59，符号匹配小时和秒
        seconds - 以秒为单位的时区偏移量，从0到±59，符号匹配小时和分钟
        结果
        zone-offset，not null
        异常
        DateTimeException - 如果偏移量不在所需范围内

      • from

        public static ZoneOffset from​(TemporalAccessor temporal)
        从时间对象获取ZoneOffset的实例。

        这获得了基于指定时间的偏移量。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为ZoneOffset一个实例。

        A TemporalAccessor表示某种形式的日期和时间信息。 该工厂将任意的时间对象转换为ZoneOffset一个实例。

        转换使用TemporalQueries.offset()查询，它依赖于提取OFFSET_SECONDS字段。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考用作查询， ZoneOffset::from 。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        zone-offset，not null
        异常
        DateTimeException - 如果无法转换为 ZoneOffset

      • ofTotalSeconds

        public static ZoneOffset ofTotalSeconds​(int totalSeconds)
        获取ZoneOffset的实例，指定总偏移量（以秒为单位）

        偏移量必须在-18:00到+18:00 ，对应于-64800到+64800。

        参数
        totalSeconds - 以秒为单位的总时区偏移量，从-64800到+64800
        结果
        ZoneOffset，不为null
        异常
        DateTimeException - 如果偏移量不在所需范围内

      • getTotalSeconds

        public int getTotalSeconds​()
        获取总区域偏移量（以秒为单位）。

        这是访问偏移量的主要方式。 它将小时，分钟和秒字段的总和返回为可以添加到一个时间的单个偏移量。

        结果
        总区域偏移量（以秒为单位）

      • getId

        public String getId​()
        获取标准化区域偏移ID。

        ID是偏移量的标准ISO-8601格式化字符串的微小变化。 有三种格式：

        • Z - UTC（ISO-8601）
        • +hh:mm或-hh:mm - 如果秒为零（ISO-8601）
        • +hh:mm:ss或-hh:mm:ss - 如果秒不为零（不是ISO-8601）
        Specified by:
        getId在 ZoneId
        结果
        区域偏移ID，不为空

      • getRules

        public ZoneRules getRules​()
        获取相关的时区规则。

        查询时，规则将始终返回此偏移量。 实现类是不可变的，线程安全的和可序列化的。

        Specified by:
        getRules在 ZoneId
        结果
        规则，不为空

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的偏移量。 如果是false，那么调用range和get方法会抛出异常。

        如果该字段是ChronoField，那么查询是在这里实现的。 OFFSET_SECONDS字段返回true。 所有其他ChronoField实例将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果该偏移量支持该字段，则为true，否则为false

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 该偏移量用于提高返回范围的精度。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 supported fields将返回适当的范围实例。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果不能获得该字段的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持

      • get

        public int get​(TemporalField field)
        从该偏移量获取指定字段的值作为int 。

        这将查询指定字段的值的偏移量。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 OFFSET_SECONDS字段返回偏移量的值。 所有其他ChronoField实例都会抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        public long getLong​(TemporalField field)
        从该偏移量获取指定字段的值作为long 。

        这将查询指定字段的值的偏移量。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 OFFSET_SECONDS字段返回偏移量的值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取该字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • query

        public <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此偏移量。

        这使用指定的查询策略对象查询此偏移。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在指定的查询this作为参数调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        public Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象与此对象的偏移量相同。

        这返回与偏移量变化相同的输入的相同可观察类型的时间对象。

        该调整是相当于使用Temporal.with(TemporalField, long)通过ChronoField.OFFSET_SECONDS作为字段。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisOffset.adjustInto(temporal);
   temporal = temporal.with(thisOffset);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • compareTo

        public int compareTo​(ZoneOffset other)
        将此偏移量与其他偏移量按降序进行比较。

        这些偏移量按照它们在世界各地的同一时间发生的顺序进行比较。 因此， +10:00的抵消来自+10:00的偏移量+09:00 -18:00 。

        比较是“符合等于”，由Comparable定义。

        Specified by:
        compareTo在接口 Comparable<ZoneOffset>
        参数
        other - 要比较的其他日期，不为空
        结果
        比较器值为负，如果较小，则如果较大则为正
        异常
        NullPointerException - 如果 other为空

      • equals

        public boolean equals​(Object obj)
        检查这个偏移量是否等于另一个偏移量。

        比较是基于偏移量（以秒为单位）。 这相当于ID的比较。

        重写：
        equals在 ZoneId
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他偏移量，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个偏移的哈希码。
        重写：
        hashCode在 ZoneId
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        使用归一化ID将此偏移量输出为 String 。
        重写：
        toString在 ZoneId
        结果
        这个偏移的字符串表示，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AbstractChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class AbstractChronology

  • java.lang.Object
    • java.time.chrono.AbstractChronology
  • All Implemented Interfaces:
    Comparable<Chronology> ， Chronology
    已知直接子类：
    HijrahChronology ， IsoChronology ， JapaneseChronology ， MinguoChronology ， ThaiBuddhistChronology

    public abstract class AbstractChronology
extends Object
implements Chronology
    用于组织和识别日期的日历系统的抽象实现。

    主要的日期和时间API建立在ISO日历系统上。 年表在幕后操作，代表日历系统的一般概念。

    详见Chronology 。

    实现要求：
    该类与Chronology接口分离，以使静态方法不被继承。 虽然可以直接实现Chronology ，但强烈建议扩展这个抽象类。

    必须小心实施此类，以确保其他类正确运行。 可以实例化的所有实现必须是最终的，不可变的和线程安全的。 子类应尽可能可序列化。

    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractChronology​()
      创建一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(Chronology other)
      将这个年表与另一个年表进行比较。
      boolean equals​(Object obj)
      检查这个年表是否等于另一个年表。
      int hashCode​()
      这个年表的哈希码。
      ChronoLocalDate resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField值到一个日期。
      String toString​()
      输出这个年表为 String ，使用年表ID。

      • Methods inherited from interface java.time.chrono.Chronology

        date, date, date, dateEpochDay, dateNow, dateNow, dateNow, dateYearDay, dateYearDay, epochSecond, epochSecond, eraOf, eras, from, getCalendarType, getDisplayName, getId, isLeapYear, localDateTime, period, prolepticYear, range, zonedDateTime, zonedDateTime

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractChronology

        protected AbstractChronology​()
        创建一个实例。

    • 方法详细信息

      • resolveDate

        public ChronoLocalDate resolveDate​(Map<TemporalField,Long> fieldValues,
                                   ResolverStyle resolverStyle)
        解析时解析ChronoField值到一个日期。

        大多数TemporalField实现使用该字段上的resolve方法来解决。 相比之下， ChronoField类定义的字段只能具有相对于年表的意义。 因此，在特定年表的上下文中解决了ChronoField日期字段。

        ChronoField实例通过此方法解决，这可能会在子类中被覆盖。

        • EPOCH_DAY - 如果存在，将转换为日期，然后根据日期对所有其他日期字段进行交叉检查。
        • PROLEPTIC_MONTH - 如果存在，那么它被分割成YEAR和MONTH_OF_YEAR 。 如果模式是严格的或智能的，则该字段被验证。
        • YEAR_OF_ERA和ERA - 如果两者都存在，则它们被组合以形成YEAR 。 在宽松的模式下， YEAR_OF_ERA范围是无法验证的，在智能和严格的模式下。 在所有三种模式下， ERA的范围都被验证。 如果只有YEAR_OF_ERA存在，并且模式是聪明或宽松的，那么假定最后一个可用的时代。 在严格的模式下，没有任何一个时代被假定，而YEAR_OF_ERA没有被触动。 如果只有ERA存在，那么它保持不变。
        • YEAR ， MONTH_OF_YEAR和DAY_OF_MONTH -如果所有三个都存在，那么它们被组合成一个日期。 在所有三种模式下， YEAR都经过验证。 如果模式是聪明或严格的，则验证月和日。 如果模式宽松，则以相当于在请求年份的第一个月的第一天创建日期的方式组合日期，然后将月份中的差额加上差异天数。 如果模式是聪明的，并且月的日期大于年月的最大值，则月的日期被调整到最后一个月。 如果模式严格，则三个字段必须形成有效的日期。
        • YEAR和DAY_OF_YEAR - 如果两者都存在，则将它们组合以形成日期。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期将以相当于在请求年的第一天创建日期的方式组合，然后加上差异。 如果模式是聪明或严格的，那么这两个字段必须形成一个有效的日期。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和ALIGNED_DAY_OF_WEEK_IN_MONTH -如果所有四个都存在，则它们被组合以形成一个日期。 在所有三种模式下， YEAR都经过验证。 如果该模式宽松，那么日期将以相当于在所请求的年份的第一个月的第一天创建日期的方式组合，然后加上月差，然后以周为单位，然后以天为单位。 如果模式是聪明或严格的，那么所有四个字段都将被验证到其外部范围。 然后将该日期以相当于在所请求的年和月的第一天创建日期的方式组合，然后以数周和数天的数量添加以达到其值。 如果模式严格，则还会验证日期，以检查日和周的调整次数是否不变。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和DAY_OF_WEEK -如果所有四个都存在，则它们被组合以形成一个日期。 该方法与上述相同，多年，数月ALIGNED_DAY_OF_WEEK_IN_MONTH周在ALIGNED_DAY_OF_WEEK_IN_MONTH 。 一天一个月，几周和几周已被处理，星期几被调整为下一个或相同的匹配日。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和ALIGNED_DAY_OF_WEEK_IN_YEAR -如果所有三个都存在，那么它们被组合成一个日期。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期以相当于在所请求年的第一天创建日期的方式组合，然后以周为单位加上差异。 如果模式是聪明或严格的，那么所有三个字段都将被验证到其外部范围。 然后，该日期以相当于在所请求年的第一天创建日期的方式组合，然后以数周和数天添加以达到其值。 如果模式严格，日期也会被验证，以检查日和周的调整没有改变年份。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和DAY_OF_WEEK -如果所有三个都存在，那么它们被组合成一个日期。 该方法与上述ALIGNED_DAY_OF_WEEK_IN_YEAR数年ALIGNED_DAY_OF_WEEK_IN_YEAR周ALIGNED_DAY_OF_WEEK_IN_YEAR 。 一天一周的时间一周调整为下一个或相同的匹配日期，一年的时间和周数被处理。

        默认实现适用于大多数日历系统。 如果发现ChronoField.YEAR_OF_ERA没有ChronoField.ERA，那么最后一个时代在Chronology.eras()被使用。 实施假定为7天，第一个月的日期为1，第一天的值为1，并且月份和年份的第一个始终存在。

        Specified by:
        resolveDate在接口 Chronology
        参数
        fieldValues - 可以更新的值的字段映射，不为空
        resolverStyle - 请求的解析类型，不为null
        结果
        解决日期，如果信息不足创建日期，则为null
        异常
        DateTimeException - 如果日期无法解决，通常是因为输入数据中存在冲突

      • compareTo

        public int compareTo​(Chronology other)
        将这个年表与另一个年表进行比较。

        比较顺序首先按年表ID字符串，然后通过特定于子类的任何附加信息。 它与“等于”一致，如Comparable所定义。

        Specified by:
        compareTo在接口 Chronology
        Specified by:
        compareTo在接口 Comparable<Chronology>
        实现要求：
        这个实现比较了时间序列ID。 子类必须比较它们存储的任何其他状态。
        参数
        other - 其他年表要比较，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • equals

        public boolean equals​(Object obj)
        检查这个年表是否等于另一个年表。

        比较是基于对象的整个状态。

        Specified by:
        equals在接口 Chronology
        重写：
        equals在 Object
        实现要求：
        200的X- 200 X-45454545 X-4545 X-4545 X- 200 X-4545 X-4545 X-
        参数
        obj
        结果
        如果这等于其他年表，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个年表的哈希码。

        哈希码应该基于对象的整个状态。

        Specified by:
        hashCode在接口 Chronology
        重写：
        hashCode在 Object
        实现要求：
        这个实现是基于年表ID和类。 子类应该添加它们存储的任何附加状态。
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        输出这个年表为 String ，使用年表ID。
        Specified by:
        toString在接口 Chronology
        重写：
        toString在 Object
        结果
        这个年表的字符串表示，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChronoLocalDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Interface ChronoLocalDate

  • All Superinterfaces:
    Comparable<ChronoLocalDate> ， Temporal ， TemporalAccessor ， TemporalAdjuster
    所有已知实现类：
    HijrahDate ， JapaneseDate ， LocalDate ， MinguoDate ， ThaiBuddhistDate

    public interface ChronoLocalDate
extends Temporal, TemporalAdjuster, Comparable<ChronoLocalDate>
    一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。

    大多数应用程序应声明方法签名，字段和变量为LocalDate ，而不是此接口。

    A ChronoLocalDate是Chronology chronology或日历系统可插拔的日期的抽象表示。 日期由TemporalField表示的字段定义，其中大多数常见实现在ChronoField中定义。 年表定义日历系统的运行方式和标准字段的含义。

    何时使用此界面

    API的设计鼓励使用LocalDate而不是该接口，即使在应用程序需要处理多个日历系统的情况下。

    首先，这个概念似乎令人惊讶，因为全局化应用程序的自然方式可能最初似乎是抽象日历系统。 然而，如下所述，抽象日历系统通常是错误的方法，导致逻辑错误，很难找到错误。 因此，应该认为应用程序范围的架构决定选择使用此接口而不是LocalDate 。

    要考虑的建筑问题

    这些是在整个应用程序中使用此界面之前必须考虑的一些要点。

    1）使用这个界面的应用程序，而不是使用LocalDate ，面临着更高的错误概率。 这是因为正在使用的日历系统在开发时不知道。 错误的主要原因是开发人员将ISO日历系统日常知识的假设应用于旨在处理任意日历系统的代码。 以下部分概述了这些假设如何导致问题。减少错误风险增加的主要机制是强大的代码审查流程。 在代码生命周期中，这也应被视为维护的额外成本。

    2）此接口不强制执行不可变性。 虽然实现说明表明所有实现都必须是不可变的，但代码或类型系统中没有任何内容来执行此操作。 因此，任何声明接受ChronoLocalDate都可能被传递给一个不好或恶意编写的可变实现。

    3）使用此界面的应用程序必须考虑到时代的影响。 LocalDate屏蔽了用户从时代的概念，通过确保getYear()返回getYear()年份。 该决定确保开发人员可以将LocalDate实例视为三个字段（年，月，日和月）。 相比之下，这个界面的用户必须将日期视为包括四个领域 - 时代，年龄，月份和月份。 额外的时代领域经常被遗忘，但是在任意的日历系统中是至关重要的。 例如，在日历系统中，这个时代代表了皇帝的统治地位。 每当一个统治结束，另一个开始时，年龄将重置为一个。

    4）在两个系统之间通过日期的唯一商定的国际标准是需要ISO日历系统的ISO-8601标准。 在整个应用程序中使用此界面将不可避免地导致要求通过网络或组件边界传递日期，需要特定于应用程序的协议或格式。

    5）长期持续性，如数据库，几乎总是只接受ISO-8601日历系统（或相关的朱利安 - 格里高利）的日期。 在其他日历系统中传播日期增加了与持久性相互作用的并发症。

    6）大部分时间，通过一个ChronoLocalDate整个应用程序是不必要的，如下面最后一节所讨论的。

    虚假假设导致多日历系统代码中的错误

    如上所述，尝试在任意日历系统中使用和操纵日期时，需要考虑许多问题。 这些是一些关键问题。

    查询月份的代码，并假定该值永远不会超过31，则无效。 某些日历系统在几个月内有超过31天的时间。

    增加12个月的代码，并假设已经添加了一年是无效的。 一些日历系统有不同的月份，例如科普特人或埃塞俄比亚的13个。

    增加一个月到日期的代码，并假设年月值增加一个或换到下一年是无效的。 一些日历系统在一年中可能有几个月，例如希伯来语。

    增加一个月的代码，然后再增加一个月，并假设月日将保持接近其原始值是无效的。 一些日历系统在最长月份的长度和最短的月份的长度之间有很大差异。 例如，科普特人或埃塞俄比亚人有12个月30天，1个月5天。

    添加七天并假定一周已添加的代码无效。 一些日历系统有七个星期的时间，如法国革命派。

    假设因为date1的年份大于date2 date1年，那么date1之后的date2是无效的。 对于所有的日历系统来说，这是对于年代的无效，尤其是在每个新皇帝统治时代重新开始的日历日历系统的时候。

    将月份中的一个月和一个月中的一个作为年初的代码无效。 当月份值为1时，不是所有的日历系统开始。

    一般来说，操作日期，甚至查询日期，当日历系统在开发时是未知的时，广泛使用错误。 这就是为什么使用此界面的代码必须经过其他代码审查的原因。 这也是为什么避免这种接口类型的架构决策通常是正确的。

    使用LocalDate代替

    在整个应用程序中使用此界面的主要替代方法如下。
    • 以LocalDate引用日期的所有方法签名。
    • 请将用户配置文件中的年表（日历系统）存储或从用户区域设置查找年表
    • 在打印和解析期间将ISO LocalDate转换为用户的首选日历系统
    这种方法将全球化日历系统的问题视为本地化问题，并将其限制在UI层。 这种方法与java平台中的其他本地化问题保持一致。

    如上所述，在日历系统的规则可插拔的日期执行计算需要技能，不推荐。 幸运的是，在任意日历系统的日期执行计算的需求是极少数的。 例如，图书馆租借计划的商业规则极不可能允许租金为一个月，其中月份的含义取决于用户的首选日历系统。

    用于在任意日历系统中的日期进行计算的关键用例是生成逐月显示和用户交互的日历。 再次，这是一个UI问题，仅仅在UI层的几个方法中使用这个接口可能是合理的。

    在系统的任何其他部分，如果在除ISO之外的日历系统中必须操纵日期，则用例通常会指定要使用的日历系统。 例如，申请可能需要计算下一个可能需要操纵日期的伊斯兰教或希伯来节假日。 这种用例可以如下处理：

    • 从ISO LocalDate开始传递给该方法
    • 将日期转换为备用日历系统，对于此用例而言，该日历系统是已知的而不是任意的
    • 执行计算
    • 转换回LocalDate
    编写低级框架或库的开发人员也应该避免这个接口。 而应该使用两个通用接入接口之一。 使用TemporalAccessor如果需要只读访问，或使用Temporal是否需要进行读写访问。
    实现要求：
    该接口必须小心实施，以确保其他类正确运行。 可以实例化的所有实现必须是最终的，不可变的和线程安全的。 子类应尽可能可序列化。

    可以向系统添加其他日历系统。 详见Chronology 。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象的日期相同。
      default ChronoLocalDateTime<?> atTime​(LocalTime localTime)
      结合此日期与时间创建一个 ChronoLocalDateTime 。
      default int compareTo​(ChronoLocalDate other)
      将此日期与其他日期进行比较，包括年表。
      boolean equals​(Object obj)
      检查这个日期是否等于另一个日期，包括年表。
      default String format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期。
      static ChronoLocalDate from​(TemporalAccessor temporal)
      从时间对象获取一个 ChronoLocalDate的实例。
      Chronology getChronology​()
      获得这个日期的年表。
      default Era getEra​()
      获得时代，按年表定义。
      int hashCode​()
      这个日期的哈希码。
      default boolean isAfter​(ChronoLocalDate other)
      检查此日期是否在忽略年表的指定日期之后。
      default boolean isBefore​(ChronoLocalDate other)
      检查此日期是否在忽略年表前的指定日期之前。
      default boolean isEqual​(ChronoLocalDate other)
      检查这个日期是否等于忽略年表的指定日期。
      default boolean isLeapYear​()
      检查年份是否是日历系统定义的闰年。
      default boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      default boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      int lengthOfMonth​()
      返回由日历系统定义的由此日期表示的月份的长度。
      default int lengthOfYear​()
      返回由日历系统定义的由此日期表示的年份的长度。
      default ChronoLocalDate minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default ChronoLocalDate minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      default ChronoLocalDate plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      default ChronoLocalDate plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      default <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此日期。
      static Comparator<ChronoLocalDate> timeLineOrder​()
      获取一个比较器，比较 ChronoLocalDate的时间顺序忽略年表。
      default long toEpochDay​()
      将此日期转换为大纪元日。
      String toString​()
      将此日期输出为 String 。
      ChronoPeriod until​(ChronoLocalDate endDateExclusive)
      将此日期与另一个日期之间的期间计算为 ChronoPeriod 。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。
      default ChronoLocalDate with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      default ChronoLocalDate with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。

      • Methods inherited from interface java.time.temporal.TemporalAccessor

        get, getLong, range

    • 方法详细信息

      • timeLineOrder

        static Comparator<ChronoLocalDate> timeLineOrder​()
        获取一个比较器，比较ChronoLocalDate的时间顺序，忽略年表。

        该比较器与compareTo(java.time.chrono.ChronoLocalDate)中的比较不同之处在于，它仅比较基础日期而不是年表。 这可以根据当地时间线上日期的位置来比较不同日历系统中的日期。 潜在的比较相当于比较时代。

        结果
        比较器比较时间顺序忽略年表
        另请参见：
        isAfter(java.time.chrono.ChronoLocalDate) ，
isBefore(java.time.chrono.ChronoLocalDate) ，
isEqual(java.time.chrono.ChronoLocalDate)

      • from

        static ChronoLocalDate from​(TemporalAccessor temporal)
        从时间对象获取一个ChronoLocalDate的实例。

        这将基于指定的时间获取本地日期。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为ChronoLocalDate一个实例。

        转换提取并结合时间对象的年表和日期。 该行为相当于使用Chronology.date(TemporalAccessor)与提取的年表。 允许实现执行优化，例如访问与相关对象相当的那些字段。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考ChronoLocalDate::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        日期，不为空
        异常
        DateTimeException - 如果无法转换为 ChronoLocalDate
        另请参见：
        Chronology.date(TemporalAccessor)

      • getChronology

        Chronology getChronology​()
        获得这个日期的年表。

        Chronology代表正在使用的日历系统。 时代和其他领域在ChronoField由时间顺序定义。

        结果
        年表，不为空

      • getEra

        default Era getEra​()
        获得时代，按年表定义。

        时代在概念上是时间线上最大的一个部门。 大多数日历系统具有将时间线划分为两个时代的单个时期。 然而，有些有多个时代，比如每个领导人统治的时代。 具体含义由Chronology确定。

        所有正确实现的Era类都是单例，因此它是有效的代码写入date.getEra() == SomeChrono.ERA_NAME) 。

        此默认实现使用Chronology.eraOf(int) 。

        结果
        在这个时间适用的年代比特定时代不为零

      • isLeapYear

        default boolean isLeapYear​()
        检查年份是否是日历系统定义的闰年。

        闰年是一个比正常长的一年。 确切的意义是由年表确定的，其限制是闰年必须意味着比非闰年长一年的长度。

        此默认实现使用Chronology.isLeapYear(long) 。

        结果
        如果此日期在闰年，则为真，否则为false

      • lengthOfMonth

        int lengthOfMonth​()
        返回由日历系统定义的由此日期表示的月份的长度。

        这将以天为单位返回月份的长度。

        结果
        月的长度以天为单位

      • lengthOfYear

        default int lengthOfYear​()
        返回由日历系统定义的由此日期表示的年份的长度。

        这返回一年中的天数。

        默认实现使用isLeapYear()并返回365或366。

        结果
        一年中的天数

      • isSupported

        default boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以在此日期查询指定的字段。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        支持的字段集由年表定义，通常包括所有ChronoField日期字段。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果可以查询该字段，则为true，否则为false

      • isSupported

        default boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查是否可以从该日期添加或减去指定的单位。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        支持单位的集合由年表定义，通常包括除了FOREVER之外的所有ChronoUnit日期单位。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • with

        default ChronoLocalDate with​(TemporalAdjuster adjuster)
        通过进行调整，返回与该对象相同类型的调整对象。

        这将根据指定的调整器的规则调整此日期时间。 一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 TemporalAdjusters中提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.with(Month.JULY);        // most key classes implement TemporalAdjuster
  date = date.with(lastDayOfMonth());  // static import from Adjusters
  date = date.with(next(WEDNESDAY));   // static import from Adjusters and DayOfWeek
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        default ChronoLocalDate with​(TemporalField field,
                             long newValue)
        返回与该对象具有相同类型的对象，并更改指定的字段。

        这将返回一个基于该对象的新对象，其中指定字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        与指定字段集相同类型的对象，不为null
        异常
        DateTimeException - 如果字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • plus

        default ChronoLocalDate plus​(TemporalAmount amount)
        返回与此对象相同类型的对象，并添加一个金额。

        这调整这个时间，根据指定量的规则添加。 金额通常为Period，但可能是实现TemporalAmount接口的任何其他类型，例如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.plus(period);                // add a Period instance
  date = date.plus(duration);              // add a Duration instance
  date = date.plus(workingDays(6));        // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        plus在接口 Temporal
        参数
        amount - 要添加的金额，不为null
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        default ChronoLocalDate plus​(long amountToAdd,
                             TemporalUnit unit)
        返回与此对象相同类型的对象，并添加指定的句点。

        此方法基于添加了指定句点的新对象。 例如，在LocalDate ，这可以用来添加几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则添加一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的指定单位的数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        与指定期间相同类型的对象添加，不为空
        异常
        DateTimeException - 如果无法添加本机
        ArithmeticException - 如果发生数字溢出

      • minus

        default ChronoLocalDate minus​(TemporalAmount amount)
        返回与该对象相同类型的对象，并减去一个数量。

        这调整这个时间，根据指定量的规则减去。 金额通常为Period，但可以是实现TemporalAmount接口的任何其他类型，例如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.minus(period);               // subtract a Period instance
  date = date.minus(duration);             // subtract a Duration instance
  date = date.minus(workingDays(6));       // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        minus在接口 Temporal
        参数
        amount - 减去量，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        default ChronoLocalDate minus​(long amountToSubtract,
                              TemporalUnit unit)
        返回与该对象相同类型的对象，并减去指定的时间段。

        该方法返回一个基于该对象的新对象，减去指定的时间段。 例如，在LocalDate ，这可以用来减去几年，几个月或几天的数量。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表3月31日的日期，则减去一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 扣除指定单位的金额，可能为负数
        unit - 减去量的单位，不为空
        结果
        与指定周期相同类型的对象减去，不为空
        异常
        DateTimeException - 如果不能减去单位
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • query

        default <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此日期。

        这使用指定的查询策略对象查询此日期。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过调用TemporalQuery.queryFrom(TemporalAccessor)方法在指定的查询上传递this作为参数获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        default Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象与此对象的日期相同。

        这返回与日期改变为与之相同的输入的相同可观察类型的时间对象。

        该调整是相当于使用Temporal.with(TemporalField, long)通过ChronoField.EPOCH_DAY作为字段。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisLocalDate.adjustInto(temporal);
   temporal = temporal.with(thisLocalDate);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为空
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • until

        long until​(Temporal endExclusive,
           TemporalUnit unit)
        根据指定的单位计算直到另一个日期的时间量。

        这个计算两个之间的时间量ChronoLocalDate在单一方面对象TemporalUnit 。 起点和终点为this和指定日期。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为ChronoLocalDate使用Chronology.date(TemporalAccessor) 。 计算返回一个整数，表示两个日期之间的完整单位数。 例如，可以使用startDate.until(endDate, DAYS)计算两个日期之间的天startDate.until(endDate, DAYS) 。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        该方法的计算是通过ChronoUnit实现的 。 单位DAYS ， WEEKS ， MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS应该由所有的实现支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，在同一年代转换为 ChronoLocalDate ，不为空
        unit - 衡量金额的单位，不为空
        结果
        此日期与结束日期之间的时间
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为 ChronoLocalDate
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • until

        ChronoPeriod until​(ChronoLocalDate endDateExclusive)
        将此日期与另一个日期之间的期间计算为ChronoPeriod 。

        这计算两个日期之间的期间。 所有提供的年表使用年，月和日计算周期，但是ChronoPeriod API允许使用其他单位来表示期间。

        起点和终点为this和指定日期。 如果结束在开始之前，结果将为负数。 每年，每月的负号将相同。

        计算使用此日期的年表进行。 如有必要，输入日期将被转换为匹配。

        此实例是不可变的，不受此方法调用的影响。

        参数
        endDateExclusive - 结束日期，排他，可能在任何年代，不为空
        结果
        此日期与结束日期之间的期间不为空
        异常
        DateTimeException - 如果期间无法计算
        ArithmeticException - 如果发生数字溢出

      • format

        default String format​(DateTimeFormatter formatter)
        使用指定的格式化程序格式化此日期。

        此日期将传递给格式化程序以生成一个字符串。

        默认实现必须如下所示：

          return formatter.format(this);
        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的日期字符串，不为null
        异常
        DateTimeException - 打印过程中是否发生错误

      • atTime

        default ChronoLocalDateTime<?> atTime​(LocalTime localTime)
        将此日期与时间结合起来创建一个ChronoLocalDateTime 。

        这将在指定的时间返回从此日期形成的ChronoLocalDateTime 。 日期和时间的所有可能的组合都是有效的。

        参数
        localTime - 当地使用时间，不为空
        结果
        从该日期到指定时间形成的本地日期时间，不为空

      • toEpochDay

        default long toEpochDay​()
        将此日期转换为大纪元日。

        Epoch Day count是第0天为1970-01-01（ISO）的简单递增计数。 这个定义对于所有的年表都是一样的，可以进行转换。

        此默认实现查询EPOCH_DAY字段。

        结果
        大纪元日等于这个日期

      • compareTo

        default int compareTo​(ChronoLocalDate other)
        将此日期与其他日期进行比较，包括年表。

        比较首先是基于时间线日期，然后是时间顺序。 它与“等于”一致，由Comparable定义。

        例如，以下是比较器顺序：

        1. 2012-12-03 (ISO)
        2. 2012-12-04 (ISO)
        3. 2555-12-04 (ThaiBuddhist)
        4. 2012-12-05 (ISO)
        值2和＃3表示时间线上相同的日期。 当两个值表示相同的日期时，比较年表ID以区分它们。 需要这一步才能使排序“与...一致”。

        如果所有被比较的日期对象都在相同的年表中，则不需要额外的时间表，只使用本地日期。 要比较两个TemporalAccessor实例的日期，包括两个不同年表中的日期，请使用ChronoField.EPOCH_DAY作为比较。

        此默认实现执行上面定义的比较。

        Specified by:
        compareTo在接口 Comparable<ChronoLocalDate>
        参数
        other - 要比较的其他日期，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        default boolean isAfter​(ChronoLocalDate other)
        检查此日期是否在忽略年表的指定日期之后。

        该方法与compareTo(java.time.chrono.ChronoLocalDate)中的比较不同之处在于，它只比较基础日期而不是年表。 这允许根据时间线位置来比较不同日历系统中的日期。 这相当于使用date1.toEpochDay() > date2.toEpochDay() 。

        此默认实现基于时间段执行比较。

        参数
        other - 要比较的其他日期，不为空
        结果
        如果这是在指定日期之后，则为true

      • isBefore

        default boolean isBefore​(ChronoLocalDate other)
        检查此日期是否在忽略年表前的指定日期之前。

        该方法与compareTo(java.time.chrono.ChronoLocalDate)中的比较不同之处在于，它仅比较基础日期而不是年表。 这允许根据时间线位置来比较不同日历系统中的日期。 这相当于使用date1.toEpochDay() < date2.toEpochDay() 。

        此默认实现基于时间段执行比较。

        参数
        other - 要比较的其他日期，不为空
        结果
        如果这是在指定日期之前，则为true

      • isEqual

        default boolean isEqual​(ChronoLocalDate other)
        检查这个日期是否等于忽略年表的指定日期。

        该方法与compareTo(java.time.chrono.ChronoLocalDate)中的比较不同之处在于，它仅比较基础日期而不是年表。 这允许根据时间线位置来比较不同日历系统中的日期。 这相当于使用date1.toEpochDay() == date2.toEpochDay() 。

        此默认实现基于时间段执行比较。

        参数
        other - 要比较的其他日期，不为null
        结果
        如果基础日期等于指定日期，则为true

      • equals

        boolean equals​(Object obj)
        检查这个日期是否等于另一个日期，包括年表。

        将此日期与另一个日期进行比较，确保日期和年表相同。

        要比较两个TemporalAccessor实例的日期，包括两个不同年表中的日期，请使用ChronoField.EPOCH_DAY作为比较。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        这个日期的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        String toString​()
        将此日期输出为String 。

        输出将包括完整的本地日期。

        重写：
        toString在 Object
        结果
        格式化日期，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChronoLocalDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Interface ChronoLocalDateTime<D extends ChronoLocalDate>

  • 参数类型
    D - 此日期时间的具体类型
    All Superinterfaces:
    Comparable<ChronoLocalDateTime<?>> ， Temporal ， TemporalAccessor ， TemporalAdjuster
    所有已知实现类：
    LocalDateTime

    public interface ChronoLocalDateTime<D extends ChronoLocalDate>
extends Temporal, TemporalAdjuster, Comparable<ChronoLocalDateTime<?>>
    在任意年代没有时区的日期时间，用于高级全球化用例。

    大多数应用程序应声明方法签名，字段和变量为LocalDateTime ，而不是此接口。

    A ChronoLocalDateTime是Chronology chronology或日历系统可插拔的本地日期时间的抽象表示。 日期时间由TemporalField表示的字段定义，其中大多数常见实现在ChronoField中定义。 年表定义日历系统的运行方式和标准字段的含义。

    何时使用此界面

    API的设计鼓励使用LocalDateTime而不是该接口，即使在应用程序需要处理多个日历系统的情况下。 其原理在ChronoLocalDate中详细探讨。

    在使用此界面之前，请确保已阅读并理解ChronoLocalDate中的讨论。

    实现要求：
    该接口必须小心实施，以确保其他类正确运行。 可以实例化的所有实现必须是最终的，不可变的和线程安全的。 子类应尽可能可序列化。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的日期和时间。
      ChronoZonedDateTime<D> atZone​(ZoneId zone)
      结合这个时间与时区创建一个 ChronoZonedDateTime 。
      default int compareTo​(ChronoLocalDateTime<?> other)
      将此日期时间与其他日期时间进行比较，包括年表。
      boolean equals​(Object obj)
      检查这个日期时间是否等于另一个日期时间，包括年表。
      default String format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。
      static ChronoLocalDateTime<?> from​(TemporalAccessor temporal)
      从时间对象获取一个 ChronoLocalDateTime的实例。
      default Chronology getChronology​()
      获得这个日期时间的年表。
      int hashCode​()
      这个日期时间的哈希码。
      default boolean isAfter​(ChronoLocalDateTime<?> other)
      检查这个日期时间是否在指定的日期时间之后，忽略年表。
      default boolean isBefore​(ChronoLocalDateTime<?> other)
      检查这个日期时间是否在指定的日期时间之前忽略年表。
      default boolean isEqual​(ChronoLocalDateTime<?> other)
      检查这个日期时间是否等于指定的日期时间，忽略年表。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      default boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      default ChronoLocalDateTime<D> minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default ChronoLocalDateTime<D> minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      ChronoLocalDateTime<D> plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      default ChronoLocalDateTime<D> plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      default <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      static Comparator<ChronoLocalDateTime<?>> timeLineOrder​()
      获取一个比较器，比较 ChronoLocalDateTime的时间顺序，忽略年表。
      default long toEpochSecond​(ZoneOffset offset)
      将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。
      default Instant toInstant​(ZoneOffset offset)
      将此日期时间转换为 Instant 。
      D toLocalDate​()
      获取此日期时间的本地日期部分。
      LocalTime toLocalTime​()
      获取此日期时间的当地时间部分。
      String toString​()
      将此日期时间输出为 String 。
      default ChronoLocalDateTime<D> with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      ChronoLocalDateTime<D> with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。

      • Methods inherited from interface java.time.temporal.Temporal

        until

      • Methods inherited from interface java.time.temporal.TemporalAccessor

        get, getLong, range

    • 方法详细信息

      • timeLineOrder

        static Comparator<ChronoLocalDateTime<?>> timeLineOrder​()
        获取一个比较器，比较ChronoLocalDateTime的时间顺序，忽略年表。

        该比较器与compareTo(java.time.chrono.ChronoLocalDateTime<?>)中的比较不同之处在于它仅比较基础日期时间而不是年表。 这可以根据当地时间线上的日期时间的位置来比较不同日历系统中的日期。 潜在的比较相当于比较了当代和纳米级。

        结果
        比较器比较时间顺序忽略年表
        另请参见：
        isAfter(java.time.chrono.ChronoLocalDateTime<?>) ，
isBefore(java.time.chrono.ChronoLocalDateTime<?>) ，
isEqual(java.time.chrono.ChronoLocalDateTime<?>)

      • from

        static ChronoLocalDateTime<?> from​(TemporalAccessor temporal)
        从时间对象获取一个ChronoLocalDateTime的实例。

        这可以基于指定的时间获取本地日期时间。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为ChronoLocalDateTime一个实例。

        转换提取并结合时间对象的年表和日期时间。 该行为相当于使用Chronology.localDateTime(TemporalAccessor)与提取的年表。 允许实现执行优化，例如访问与相关对象相当的那些字段。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考用作查询， ChronoLocalDateTime::from 。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        日期时间，不为空
        异常
        DateTimeException - 如果无法转换为 ChronoLocalDateTime
        另请参见：
        Chronology.localDateTime(TemporalAccessor)

      • getChronology

        default Chronology getChronology​()
        获得这个日期时间的年表。

        Chronology表示正在使用的日历系统。 时代和其他领域在ChronoField由时间顺序定义。

        结果
        年表，不为空

      • toLocalDate

        D toLocalDate​()
        获取此日期时间的本地日期部分。

        这将返回与此日期时间相同的年，月和日的本地日期。

        结果
        此日期时间的日期部分不为null

      • toLocalTime

        LocalTime toLocalTime​()
        获取此日期时间的当地时间部分。

        这将返回本地时间与这个日期时间相同的小时，分钟，秒和纳秒。

        结果
        这个日期时间的一部分，不是null

      • isSupported

        boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以在此日期时间查询指定的字段。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        支持的字段集由年表定义，通常包括所有ChronoField日期和时间字段。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果可以查询该字段，则为true，否则为false

      • isSupported

        default boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查是否可以从此日期时间添加或减去指定的单位。 如果是false，那么调用plus(long, TemporalUnit)和minus的方法会抛出异常。

        支持单位的集合由年表定义，通常包括除了FOREVER之外的所有ChronoUnit单位。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • with

        default ChronoLocalDateTime<D> with​(TemporalAdjuster adjuster)
        通过进行调整，返回与该对象相同类型的调整对象。

        这将根据指定的调整器的规则调整此日期时间。 一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 TemporalAdjusters中提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.with(Month.JULY);        // most key classes implement TemporalAdjuster
  date = date.with(lastDayOfMonth());  // static import from Adjusters
  date = date.with(next(WEDNESDAY));   // static import from Adjusters and DayOfWeek
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果无法进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        ChronoLocalDateTime<D> with​(TemporalField field,
                            long newValue)
        返回与该对象具有相同类型的对象，并更改指定的字段。

        这将返回一个基于该对象的新对象，其中指定字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月的日期。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        与指定字段集相同类型的对象，不为null
        异常
        DateTimeException - 如果该字段无法设置
        ArithmeticException - 如果发生数字溢出

      • plus

        default ChronoLocalDateTime<D> plus​(TemporalAmount amount)
        返回与此对象相同类型的对象，并添加一个金额。

        这调整这个时间，根据指定量的规则添加。 金额通常是Period，但可能是实现TemporalAmount接口的任何其他类型，例如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.plus(period);                // add a Period instance
  date = date.plus(duration);              // add a Duration instance
  date = date.plus(workingDays(6));        // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        plus在接口 Temporal
        参数
        amount - 要添加的金额，不为null
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        ChronoLocalDateTime<D> plus​(long amountToAdd,
                            TemporalUnit unit)
        返回与此对象相同类型的对象，并添加指定的句点。

        此方法基于添加了指定句点的新对象。 例如，在LocalDate ，这可以用来添加几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则添加一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的指定单位的数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        与指定期间相同类型的对象添加，不为空
        异常
        DateTimeException - 如果无法添加本机
        ArithmeticException - 如果发生数字溢出

      • minus

        default ChronoLocalDateTime<D> minus​(TemporalAmount amount)
        返回与该对象相同类型的对象，并减去一个数量。

        这调整这个时间，根据指定量的规则减去。 金额通常为Period，但可能是实现TemporalAmount界面的任何其他类型，例如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.minus(period);               // subtract a Period instance
  date = date.minus(duration);             // subtract a Duration instance
  date = date.minus(workingDays(6));       // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        minus在接口 Temporal
        参数
        amount - 减去量，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        default ChronoLocalDateTime<D> minus​(long amountToSubtract,
                                     TemporalUnit unit)
        返回与该对象相同类型的对象，并减去指定的时间段。

        该方法返回一个基于该对象的新对象，减去指定的时间段。 例如，在LocalDate ，这可以用来减去几年，几个月或几天的数量。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表3月31日的日期，则减去一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 扣除指定单位的金额，可能为负数
        unit - 减去量的单位，不为空
        结果
        与指定周期相同类型的对象减去，不为空
        异常
        DateTimeException - 如果不能减去单位
        ArithmeticException - 如果发生数字溢出

      • query

        default <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此日期时间。

        这将使用指定的查询策略对象查询此日期时间。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在指定的查询this作为参数调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        default Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象与此对象具有相同的日期和时间。

        这将返回与输入相同的可观察类型的时间对象，日期和时间更改为与此相同。

        调整相当于使用Temporal.with(TemporalField, long)两次，通过ChronoField.EPOCH_DAY和ChronoField.NANO_OF_DAY作为字段。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisLocalDateTime.adjustInto(temporal);
   temporal = temporal.with(thisLocalDateTime);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果无法进行调整
        ArithmeticException - 如果发生数字溢出

      • format

        default String format​(DateTimeFormatter formatter)
        使用指定的格式化程序格式化此日期时间。

        这个日期时间将传递给格式化程序以生成一个字符串。

        默认实现必须如下所示：

          return formatter.format(this);
        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的日期时间字符串，不为空
        异常
        DateTimeException - 打印过程中是否发生错误

      • atZone

        ChronoZonedDateTime<D> atZone​(ZoneId zone)
        结合这个时间与时区创建一个ChronoZonedDateTime 。

        这将返回从指定时区的此日期时间形成的ChronoZonedDateTime 。 结果将尽可能接近日期时间。 时区规则（如夏令时）意味着并非每个本地日期时间对指定的区域都有效，因此可能会调整本地日期时间。

        本地日期时间在时间线上解析为单个时刻。 这是通过从区域ID的rules定义的本地日期时间中找到UTC /格林威治的有效偏移量来实现的。

        在大多数情况下，本地日期时间只有一个有效的偏移量。 在重叠的情况下，时钟被设置回来，有两个有效的偏移量。 该方法使用通常对应于“summer”的较早的偏移量。

        在间隙向前跳跃的情况下，没有有效的偏移。 相反，本地日期时间被调整为稍后间隔的长度。 对于典型的1小时夏令时更改，本地日期时间将在一小时后移动到通常对应于“夏季”的偏移量。

        为了在重叠期间获得稍后的偏移量，请对此方法的结果调用ChronoZonedDateTime.withLaterOffsetAtOverlap() 。

        参数
        zone - 使用的时区，不为空
        结果
        从这个日期时间形成的划分的日期时间，不为null

      • toInstant

        default Instant toInstant​(ZoneOffset offset)
        将此日期时间转换为Instant 。

        这将此本地日期时间和指定的偏移量组合成一个Instant 。

        这个默认实现是从日期的时间和时间的第二天算起的。

        参数
        offset - 用于转换的偏移量，不为空
        结果
        一个 Instant代表相同的时刻，不为空

      • toEpochSecond

        default long toEpochSecond​(ZoneOffset offset)
        将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。

        这将此本地日期时间和指定的偏移组合，以计算从1970-01-01T00：00：00Z开始的秒数的时代秒值。 时代之后的时代的实体是积极的，较早的是负的。

        这个默认实现是从日期的时间和时间的第二天算起的。

        参数
        offset - 用于转换的偏移量，不为空
        结果
        从1970-01-01T00：00：00Z的时代开始的秒数

      • compareTo

        default int compareTo​(ChronoLocalDateTime<?> other)
        将此日期时间与其他日期时间进行比较，包括年表。

        比较首先是基于时间线的日期时间，然后是时间顺序。 它与“等于”一致，如Comparable所定义。

        例如，以下是比较器顺序：

        1. 2012-12-03T12:00 (ISO)
        2. 2012-12-04T12:00 (ISO)
        3. 2555-12-04T12:00 (ThaiBuddhist)
        4. 2012-12-05T12:00 (ISO)
        值2和＃3表示时间线上相同的日期时间。 当两个值表示相同的日期时间时，比较年表ID以区分它们。 需要这一步才能使排序“与...一致”。

        如果正在比较的所有日期时间对象都是相同的年表，则不需要额外的时间顺序，只使用本地日期时间。

        此默认实现执行上面定义的比较。

        Specified by:
        compareTo在接口 Comparable<D extends ChronoLocalDate>
        参数
        other - 其他日期时间来比较，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isAfter

        default boolean isAfter​(ChronoLocalDateTime<?> other)
        检查这个日期时间是否在指定的日期时间之后，忽略年表。

        该方法与compareTo(java.time.chrono.ChronoLocalDateTime<?>)中的比较不同之处在于，它仅比较基础日期时间而不是年表。 这允许根据时间线位置来比较不同日历系统中的日期。

        该默认实现基于时代和纳秒来执行比较。

        参数
        other - 其他日期时间来比较，不为null
        结果
        如果这是指定的日期时间后，则为true

      • isBefore

        default boolean isBefore​(ChronoLocalDateTime<?> other)
        检查这个日期时间是否在指定的日期时间之前忽略年表。

        该方法与compareTo(java.time.chrono.ChronoLocalDateTime<?>)中的比较不同之处在于，它仅比较基础日期时间而不是年表。 这允许根据时间线位置来比较不同日历系统中的日期。

        该默认实现基于时代和纳秒来执行比较。

        参数
        other - 其他日期时间来比较，不为空
        结果
        如果这是在指定的日期时间之前，则为true

      • isEqual

        default boolean isEqual​(ChronoLocalDateTime<?> other)
        检查这个日期时间是否等于指定的日期时间，忽略年表。

        该方法与compareTo(java.time.chrono.ChronoLocalDateTime<?>)中的比较不同之处在于，它仅比较基础日期和时间，而不是年表。 这允许根据时间线位置来比较不同日历系统中的日期时间。

        该默认实现基于时代和纳秒来执行比较。

        参数
        other - 其他日期时间来比较，不为null
        结果
        如果基准日期时间等于时间轴上指定的日期时间，则为true

      • equals

        boolean equals​(Object obj)
        检查这个日期时间是否等于另一个日期时间，包括年表。

        将此日期时间与另一个日期时间进行比较，确保日期时间和年表相同。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        这个日期时间的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        String toString​()
        将此日期时间输出为String 。

        输出将包括完整的本地日期时间。

        重写：
        toString在 Object
        结果
        此日期时间的字符串表示形式，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Chronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Interface Chronology

  • All Superinterfaces:
    Comparable<Chronology>
    所有已知实现类：
    AbstractChronology ， HijrahChronology ， IsoChronology ， JapaneseChronology ， MinguoChronology ， ThaiBuddhistChronology

    public interface Chronology
extends Comparable<Chronology>
    用于组织和识别日期的日历系统。

    主要的日期和时间API建立在ISO日历系统上。 年表在幕后操作，代表日历系统的一般概念。 例如，日本，曼谷，泰国佛教徒等。

    大多数其他日历系统还可以按照与太阳周围的地球以及地球周围的月球和日子的共同概念进行操作。 这些共享概念由ChronoField定义，可供任何Chronology实现使用：

      LocalDate isoDate = ...
   ThaiBuddhistDate thaiDate = ...
   int isoYear = isoDate.get(ChronoField.YEAR);
   int thaiYear = thaiDate.get(ChronoField.YEAR);
    如图所示，尽管日期对象位于不同的日历系统中，由不同的Chronology实例表示，但可以使用ChronoField上相同的常量来查询。 有关这方面的影响的全面讨论，请参阅ChronoLocalDate 。 一般来说，建议是使用已知的基于ISO的LocalDate ，而不是ChronoLocalDate 。

    虽然Chronology对象通常使用ChronoField ，并且基于一个时代，年龄，月份，日期的日期模型，但这不是必需的。 一个Chronology实例可能代表完全不同的日历系统，如玛雅人。

    实际上， Chronology也是一个工厂。 of(String)方法允许通过标识符查找实例，而ofLocale(Locale)方法允许通过语言环境查找。

    Chronology实例提供了一组创建ChronoLocalDate实例的方法。 日期类用于操纵特定的日期。

    • dateNow()
    • dateNow(clock)
    • dateNow(zone)
    • date(yearProleptic, month, day)
    • date(era, yearOfEra, month, day)
    • dateYearDay(yearProleptic, dayOfYear)
    • dateYearDay(era, yearOfEra, dayOfYear)
    • date(TemporalAccessor)

    添加新日历

    可用的年表可以通过应用程序进行扩展。 添加一个新的日历系统需要实现的写作Chronology ， ChronoLocalDate和Era 。 日历系统特定的大多数逻辑将在ChronoLocalDate实现。 Chronology实施作为一个工厂。

    为了允许发现额外的年表，使用了ServiceLoader 。 必须将一个文件添加到名称为“java.time.chrono.Chronology”的META-INF/services目录中，列出实现类。 有关服务加载的更多详细信息，请参阅ServiceLoader。 对于通过id或calendarType进行查找，系统提供的日历首先被找到，然后是应用程序提供的日历。

    每个年表必须定义系统内唯一的年表ID。 如果时间表表示由CLDR规范定义的日历系统，则日历类型是CLDR类型的连接，如果适用，则为CLDR变体。

    实现要求：
    该接口必须小心实施，以确保其他类正确运行。 可以实例化的所有实现必须是最终的，不可变的和线程安全的。 子类应尽可能可序列化。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      int compareTo​(Chronology other)
      将这个年表与另一个年表进行比较。
      ChronoLocalDate date​(int prolepticYear, int month, int dayOfMonth)
      从年龄，月份和月份月份获取本年度的年表。
      default ChronoLocalDate date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从这个时代，年龄，月份和月份的时代获得这个年表的当地日期。
      ChronoLocalDate date​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期。
      ChronoLocalDate dateEpochDay​(long epochDay)
      从这个时代的时代获得当地的日期。
      default ChronoLocalDate dateNow​()
      从默认时区的系统时钟获取此时间顺序中的当前本地日期。
      default ChronoLocalDate dateNow​(Clock clock)
      从指定的时钟获取本年龄的当前本地日期。
      default ChronoLocalDate dateNow​(ZoneId zone)
      从指定时区的系统时钟获取此时间顺序中的当前本地日期。
      ChronoLocalDate dateYearDay​(int prolepticYear, int dayOfYear)
      在这个年龄和年龄段的年龄中获得当地的日期。
      default ChronoLocalDate dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从这个时代，年龄和时代的年代领域获得这个年表的当地日期。
      default long epochSecond​(int prolepticYear, int month, int dayOfMonth, int hour, int minute, int second, ZoneOffset zoneOffset)
      从1970-01-01T00：00：00Z的时期获取秒数。
      default long epochSecond​(Era era, int yearOfEra, int month, int dayOfMonth, int hour, int minute, int second, ZoneOffset zoneOffset)
      从1970-01-01T00：00：00Z的时期获取秒数。
      boolean equals​(Object obj)
      检查这个年表是否等于另一个年表。
      Era eraOf​(int eraValue)
      根据数值创建年代时代对象。
      List<Era> eras​()
      获取年表的时间列表。
      static Chronology from​(TemporalAccessor temporal)
      从时间对象获取 Chronology的实例。
      static Set<Chronology> getAvailableChronologies​()
      返回可用的年表。
      String getCalendarType​()
      获取日历系统的日历类型。
      default String getDisplayName​(TextStyle style, Locale locale)
      获取这个年表的文本表示。
      String getId​()
      获取年表的ID。
      int hashCode​()
      这个年表的哈希码。
      boolean isLeapYear​(long prolepticYear)
      检查指定年份是否是闰年。
      default ChronoLocalDateTime<? extends ChronoLocalDate> localDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期时间。
      static Chronology of​(String id)
      从时间序列ID或日历系统类型获取 Chronology的实例。
      static Chronology ofLocale​(Locale locale)
      从一个地区获取一个 Chronology的实例。
      default ChronoPeriod period​(int years, int months, int days)
      根据几年，几个月和几天的时间表获得一段时间。
      int prolepticYear​(Era era, int yearOfEra)
      计算年龄和年龄的幼年时期。
      ValueRange range​(ChronoField field)
      获取指定字段的有效值的范围。
      ChronoLocalDate resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField值到解析中的日期。
      String toString​()
      输出这个年表为 String 。
      default ChronoZonedDateTime<? extends ChronoLocalDate> zonedDateTime​(Instant instant, ZoneId zone)
      获得 ChronoZonedDateTime在从这个年表 Instant 。
      default ChronoZonedDateTime<? extends ChronoLocalDate> zonedDateTime​(TemporalAccessor temporal)
      从另一个时间对象获得这个年龄的 ChronoZonedDateTime 。

    • 方法详细信息

      • from

        static Chronology from​(TemporalAccessor temporal)
        从时间对象获取Chronology的实例。

        这获得了基于指定时间的年表。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为Chronology一个实例。

        转换将使用TemporalQueries.chronology()获取年表。 如果指定的时间对象不具有时间顺序，则返回IsoChronology 。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考Chronology::from用作查询。

        参数
        temporal - 时间转换，不为空
        结果
        年表，不为空
        异常
        DateTimeException - 如果无法转换为 Chronology

      • ofLocale

        static Chronology ofLocale​(Locale locale)
        从一个地区获取一个Chronology的实例。

        这将返回一个Chronology基于指定的语言环境，通常返回IsoChronology 。 只有在区域设置中明确选择其他日历系统才会返回。

        Locale课程提供访问一系列有用的本地化应用程序的信息。 这包括英语在英国所使用的语言和地区，例如“en-GB”。

        Locale类还支持一种可用于识别日历系统的扩展机制。 机制是键值对的一种形式，其中日历系统具有键“ca”。 例如，“en-JP-u-ca-japanese”的区域代表日本用日语日历系统使用的英文。

        该方法以等同于将“ca”传递到Locale.getUnicodeLocaleType(String)的方式找到所需的日历系统。 如果“ca”键不存在，则返回IsoChronology 。

        请注意，该方法的行为与旧的Calendar.getInstance(Locale)方法不同。 如果该方法收到“th_TH”的区域设置，它将返回BuddhistCalendar 。 相反，此方法将返回IsoChronology 。 将该地区“th-TH-u-ca-buddhist”传递到任一方法将导致泰国佛教日历系统，因此是泰国日历系统本地化的推荐方法。

        对于日本的日历系统来说，发生类似但更简单的情况。 以前已使用区域设置“jp_JP_JP”访问日历。 然而，与泰国的语言环境，“ja_JP_JP”会自动转换Locale到现代，并建议“JA-JP-U-CA日”的形式。 因此，此方法与Calendar#getInstance(Locale)之间的行为没有差异。

        参数
        locale - 用于获取日历系统的区域设置，不为空
        结果
        与该区域设置相关联的日历系统，不为null
        异常
        DateTimeException - 如果找不到指定地区的日历

      • of

        static Chronology of​(String id)
        从时间序列ID或日历系统类型获取Chronology的实例。

        这将返回基于ID或类型的年表。 chronology ID唯一标识年表。 calendar system type由CLDR规范定义。

        年表可能是由应用程序通过ServiceLoader配置提供的系统年表或年表。

        由于某些日历可以自定义，因此ID或类型通常指默认的定制。 例如，公历可以使用Julian的多个切换日期，但查找只提供默认切换日期。

        参数
        id - 年表ID或日历系统类型，不为null
        结果
        具有所请求的标识符的年表不为空
        异常
        DateTimeException - 如果不能找到年表

      • getAvailableChronologies

        static Set<Chronology> getAvailableChronologies​()
        返回可用的年表。

        每个返回的Chronology可用于系统。 一组年表包括系统年表和应用程序通过ServiceLoader配置提供的任何年表。

        结果
        独立的，可修改的可用年表ID的集合，不为空

      • getId

        String getId​()
        获取年表的ID。

        该ID唯一标识Chronology 。 它可以用于查找Chronology使用of(String) 。

        结果
        年表ID，不为空
        另请参见：
        getCalendarType()

      • getCalendarType

        String getCalendarType​()
        获取日历系统的日历类型。

        日历类型是由CLDR和Unicode区域设置数据标记语言（LDML）规范定义的唯一标识日历的标识符。 getCalendarType是CLDR日历类型和变体的连接（如果适用）由“ - ”分隔。 日历类型用于查找Chronology使用of(String) 。

        结果
        日历系统类型，如果日历未由CLDR / LDML定义，则为null
        另请参见：
        getId()

      • date

        default ChronoLocalDate date​(Era era,
                             int yearOfEra,
                             int month,
                             int dayOfMonth)
        从这个时代，年龄，月份和月份的时代获得这个年表的当地日期。
        实现要求：
        默认实现将时代和年龄结合起来，进入一个 激动人心的年份，然后再拨打 date(int, int, int) 。
        参数
        era - 正确类型为时代的时代，不为零
        yearOfEra - 年代的年代
        month - 年表的年份
        dayOfMonth - 年表日期
        结果
        这个年代的本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不符合年表的正确类型

      • date

        ChronoLocalDate date​(int prolepticYear,
                     int month,
                     int dayOfMonth)
        从年龄，月份和月份月份获取本年度的年表。
        参数
        prolepticYear - 年表学年
        month - 年表的年份
        dayOfMonth - 年表日期
        结果
        这个年代的本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateYearDay

        default ChronoLocalDate dateYearDay​(Era era,
                                    int yearOfEra,
                                    int dayOfYear)
        从这个时代，年龄和时代的年代领域获得这个年表的当地日期。
        实现要求：
        默认的实施将时代和年龄结合起来，进入一个 激动人心的年份，然后再拨打 dateYearDay(int, int) 。
        参数
        era - 时代的正确类型为年表，不为空
        yearOfEra - 年代的年代
        dayOfYear - 年表日期
        结果
        这个年代的本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不是正确的年表类型

      • dateYearDay

        ChronoLocalDate dateYearDay​(int prolepticYear,
                            int dayOfYear)
        在这个年龄和年龄段的年龄中获得当地的日期。
        参数
        prolepticYear - 年表学年
        dayOfYear - 年表日期
        结果
        这个年代的本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateEpochDay

        ChronoLocalDate dateEpochDay​(long epochDay)
        从这个时代的时代获得当地的日期。

        EPOCH_DAY的定义对于所有日历系统是相同的，因此可以用于转换。

        参数
        epochDay - 纪元日
        结果
        这个年代的本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateNow

        default ChronoLocalDate dateNow​()
        从默认时区的系统时钟获取此时间顺序中的当前本地日期。

        这将在默认时区中查询system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        实现要求：
        默认实现调用 dateNow(Clock) 。
        结果
        当前本地日期使用系统时钟和默认时区，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateNow

        default ChronoLocalDate dateNow​(ZoneId zone)
        从指定时区的系统时钟获取此时间顺序中的当前本地日期。

        这将查询system clock以获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        实现要求：
        默认实现调用 dateNow(Clock) 。
        参数
        zone - 要使用的区域ID，不为空
        结果
        当前本地日期使用系统时钟，不为null
        异常
        DateTimeException - 如果无法创建日期

      • dateNow

        default ChronoLocalDate dateNow​(Clock clock)
        从指定的时钟获取本年龄的当前本地日期。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        实现要求：
        默认实现调用 date(TemporalAccessor) 。
        参数
        clock - 要使用的时钟，不为空
        结果
        当前本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期

      • date

        ChronoLocalDate date​(TemporalAccessor temporal)
        从另一个时间对象获取本年龄的本地日期。

        这在这个时间表中基于指定的时间获得日期。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂转换为ChronoLocalDate的实例。

        转换通常使用EPOCH_DAY字段，这是跨日历系统标准化的。

        该方法匹配功能接口TemporalQuery的签名，允许它通过方法参考aChronology::date用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        这个年代的本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期
        另请参见：
        ChronoLocalDate.from(TemporalAccessor)

      • localDateTime

        default ChronoLocalDateTime<? extends ChronoLocalDate> localDateTime​(TemporalAccessor temporal)
        从另一个时间对象获取本年龄的本地日期时间。

        这在这个时间表中基于指定的时间获得日期时间。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为ChronoLocalDateTime的实例。

        该转换提取并结合了来自时间对象的ChronoLocalDate和LocalTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考aChronology::localDateTime用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        在这个年代的本地日期时间，不为空
        异常
        DateTimeException - 如果无法创建日期时间
        另请参见：
        ChronoLocalDateTime.from(TemporalAccessor)

      • zonedDateTime

        default ChronoZonedDateTime<? extends ChronoLocalDate> zonedDateTime​(TemporalAccessor temporal)
        在另一个时间对象的ChronoZonedDateTime中获得一个ChronoZonedDateTime 。

        根据指定的时间，在这个年表中获得一个分区的日期时间。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为ChronoZonedDateTime的实例。

        转换将首先从时间对象获得一个ZoneId ，如有必要，可以回到ZoneOffset 。 然后会尝试获得一个Instant ，如有必要，可以回到ChronoLocalDateTime 。 结果将是ZoneId或ZoneOffset与Instant或ChronoLocalDateTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考aChronology::zonedDateTime用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        在这个年代的分区日期 - 时间，不为空
        异常
        DateTimeException - 如果无法创建日期时间
        另请参见：
        ChronoZonedDateTime.from(TemporalAccessor)

      • zonedDateTime

        default ChronoZonedDateTime<? extends ChronoLocalDate> zonedDateTime​(Instant instant,
                                                                     ZoneId zone)
        获得ChronoZonedDateTime在从这个年表Instant 。

        这将获得与指定的相同时间的分区日期时间。

        参数
        instant - 即时创建日期时间，不为null
        zone - 时区，不为空
        结果
        划分的日期时间，不为空
        异常
        DateTimeException - 如果结果超出了支持范围

      • isLeapYear

        boolean isLeapYear​(long prolepticYear)
        检查指定年份是否是闰年。

        闰年是一个比正常长的一年。 确切的含义由年龄根据以下约束决定。

        • 闰年必须意味着比非闰年更长的一年。
        • 不支持一年概念的年表必须返回假。
        • 正确的结果必须在年龄的有效范围内返回所有年份。

        在有效年龄范围之外，实施可以自由返回最佳猜测或假。 即使该年度超出有效年限的范围，实施也不能抛出异常。

        参数
        prolepticYear - 检查年份，无法验证范围
        结果
        如果这一年是闰年，那么真的

      • prolepticYear

        int prolepticYear​(Era era,
                  int yearOfEra)
        计算年龄和年龄的幼年时期。

        这将时代与时代融为一体的年轻一代。

        如果年表积极使用时代，例如JapaneseChronology那么年龄将在时代得到验证。 对于其他年表，验证是可选的。

        参数
        era - 时代的正确类型为年表，不为空
        yearOfEra - 年代的年代
        结果
        幼稚的一年
        异常
        DateTimeException - 如果无法转化为 DateTimeException ，例如如果一年无效的时代
        ClassCastException - 如果 era不符合年表的正确类型

      • eraOf

        Era eraOf​(int eraValue)
        根据数值创建年代时代对象。

        时代在概念上是时间线上最大的一个部门。 大多数日历系统具有将时间线划分为两个时代的单个时期。 然而，有些有多个时代，比如每个领导人统治的时代。 确切的含义由年龄根据以下约束决定。

        1970-01-01使用的时代必须具有值1.后来的时代必须具有较高的值。 较早的时间必须具有较低的值。 每个年表必须参考枚举或类似的单身，以提供时代价值观。

        该方法返回指定时代值的正确类型的单例时代。

        参数
        eraValue - 时代价值
        结果
        日历系统时代，不为空
        异常
        DateTimeException - 如果不能创造时代

      • eras

        List<Era> eras​()
        获取年表的时间列表。

        大多数日历系统都有一个时代，其中一年有意义。 如果日历系统不支持时间的概念，则必须返回空列表。

        结果
        时间表的时代列表可能是不可变的，不为零

      • range

        ValueRange range​(ChronoField field)
        获取指定字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        无论年表是否支持该字段，此方法将返回结果。

        参数
        field - 获取范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围

      • getDisplayName

        default String getDisplayName​(TextStyle style,
                              Locale locale)
        获取这个年表的文本表示。

        这返回用于标识年表的文本名称，适合向用户呈现。 参数控制返回的文本和区域设置的样式。

        实现要求：
        默认实现的行为就好像格式化程序用于格式化年表文本名称一样。
        参数
        style - 所需文本的样式，不为空
        locale - 要使用的语言环境，不为空
        结果
        年表的文本值，不为null

      • resolveDate

        ChronoLocalDate resolveDate​(Map<TemporalField,Long> fieldValues,
                            ResolverStyle resolverStyle)
        解析解析中的日期为ChronoField 。

        大多数TemporalField实现使用该字段上的resolve方法来解决。 相比之下， ChronoField类定义了与年表相关的字段。 因此，在特定年表的上下文中解决了ChronoField日期字段。

        AbstractChronology提供了默认实现，它解释了典型的解决方案 。

        参数
        fieldValues - 可以更新的字段映射到值，不为null
        resolverStyle - 请求的解析类型，不为null
        结果
        解决日期，如果信息不足创建日期，则为null
        异常
        DateTimeException - 如果日期无法解决，通常是因为输入数据中存在冲突

      • period

        default ChronoPeriod period​(int years,
                            int months,
                            int days)
        根据几年，几个月和几天的时间表获得一段时间。

        这使用指定的年份，月份和日期返回与这个年表相关的时期。 所有提供的年表使用基于年，月和日的期间，但是ChronoPeriod API允许使用其他单位来表示期间。

        实现要求：
        默认实现返回适用于大多数日历系统的实现类。 它完全基于三个单位。 归一化，加减法从range(ChronoField)得出一年中的月数。 如果一年内的月数是固定的，则加法，减法和归一化的计算方法略有不同。

        如果实施不是基于年，月，日等不寻常的日历系统，或者要直接控制的地方，那么ChronoPeriod接口必须直接实现。

        返回的时期是不变的，线程安全的。

        参数
        years - 年数可能为负数
        months - 年数，可能是负数
        days - 年数，可能为负数
        结果
        这个时间期限在这个年代，不为零

      • epochSecond

        default long epochSecond​(int prolepticYear,
                         int month,
                         int dayOfMonth,
                         int hour,
                         int minute,
                         int second,
                         ZoneOffset zoneOffset)
        从1970-01-01T00：00：00Z的时期获取秒数。

        秒数是使用年龄，年龄，月，月，小时，分钟，秒和zoneOffset计算的。

        参数
        prolepticYear - 年表学年
        month - 年表的年份
        dayOfMonth - 年表日期
        hour - 从0到23的小时
        minute - 小时从0到59
        second - 第二分钟，从0到59
        zoneOffset - 区域偏移，不为空
        结果
        相对于1970-01-01T00：00：00Z的秒数可能为负数
        异常
        DateTimeException - 如果任何值超出范围
        从以下版本开始：
        9

      • epochSecond

        default long epochSecond​(Era era,
                         int yearOfEra,
                         int month,
                         int dayOfMonth,
                         int hour,
                         int minute,
                         int second,
                         ZoneOffset zoneOffset)
        从1970-01-01T00：00：00Z的时期获取秒数。

        秒数是使用年龄，年龄，月份，月份，小时，分钟，秒和zoneOffset计算的。

        参数
        era - 时代的正确类型为年表，不为空
        yearOfEra - 年代的年代
        month - 年表的年份
        dayOfMonth - 年表日期
        hour - 从0到23的小时
        minute - 小时，从0到59
        second - 第二分钟，从0到59
        zoneOffset - 区域偏移，不为空
        结果
        相对于1970-01-01T00：00：00Z的秒数可能为负数
        异常
        DateTimeException - 如果任何值超出范围
        从以下版本开始：
        9

      • compareTo

        int compareTo​(Chronology other)
        将这个年表与另一个年表进行比较。

        比较顺序首先按年表ID字符串，然后通过特定于子类的任何附加信息。 它与“等于”一致，如Comparable所定义。

        Specified by:
        compareTo在接口 Comparable<Chronology>
        参数
        other - 其他年表要比较，不是null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • equals

        boolean equals​(Object obj)
        检查这个年表是否等于另一个年表。

        比较是基于对象的整个状态。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他年表，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        这个年表的哈希码。

        哈希码应该基于对象的整个状态。

        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        String toString​()
        输出这个年表为String 。

        该格式应包括对象的整个状态。

        重写：
        toString在 Object
        结果
        这个年表的字符串表示，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChronoPeriod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Interface ChronoPeriod

  • All Superinterfaces:
    TemporalAmount
    所有已知实现类：
    Period

    public interface ChronoPeriod
extends TemporalAmount
    基于日期的时间，例如任意年代的“3年，4个月和5天”，旨在用于高级全球化用例。

    该接口在日历系统中建模基于日期的时间量。 虽然大多数日历系统使用几年，几个月和几天，但有些不是。 因此，此接口仅由Chronology定义的一组受支持单元进行Chronology 。 一组支持的单位是固定的给定的年表。 受支持单元的数量可以设置为零。

    这个时期被模拟为一定的时间量，这意味着该时期的各个部分可能是负面的。

    实现要求：
    该接口必须小心实施，以确保其他类正确运行。 可以实例化的所有实现必须是最终的，不可变的和线程安全的。 子类应尽可能可序列化。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      Temporal addTo​(Temporal temporal)
      将此时段添加到指定的时间对象。
      static ChronoPeriod between​(ChronoLocalDate startDateInclusive, ChronoLocalDate endDateExclusive)
      获得一个 ChronoPeriod包括两个日期之间的时间量。
      boolean equals​(Object obj)
      检查这个时期是否等于另一个时期，包括年表。
      long get​(TemporalUnit unit)
      获取所请求单元的值。
      Chronology getChronology​()
      获取定义支持的单位意义的年表。
      List<TemporalUnit> getUnits​()
      获取此期间支持的单位集。
      int hashCode​()
      此期间的哈希码。
      default boolean isNegative​()
      检查此期间的受支持单位是否为负。
      default boolean isZero​()
      检查此期间所有受支持的单位是否为零。
      ChronoPeriod minus​(TemporalAmount amountToSubtract)
      返回此期间的副本，并减去指定的时间段。
      ChronoPeriod multipliedBy​(int scalar)
      返回一个新的实例，其中在此期间的每个金额乘以指定的标量。
      default ChronoPeriod negated​()
      返回一个新的实例，每个金额在此期间被否定。
      ChronoPeriod normalized​()
      返回此期间的副本，并将每个单位的金额归一化。
      ChronoPeriod plus​(TemporalAmount amountToAdd)
      返回指定期间添加的此期间的副本。
      Temporal subtractFrom​(Temporal temporal)
      从指定的时间对象中减去这个时间段。
      String toString​()
      将此期间输出为 String 。

    • 方法详细信息

      • between

        static ChronoPeriod between​(ChronoLocalDate startDateInclusive,
                            ChronoLocalDate endDateExclusive)
        获得一个ChronoPeriod包括两个日期之间的时间量。

        包含开始日期，但结束日期不是。 期间使用ChronoLocalDate.until(ChronoLocalDate)计算。 因此，计算是具体的年表。

        使用第一个日期的年表。 第二个日期的年表被忽略，在计算开始之前将日期转换为目标年表系统。

        如果结束在开始之前，该方法的结果可以是负期。 在大多数情况下，每个支持的字段中的正/负号将相同。

        参数
        startDateInclusive - 指定计算年表的开始日期，不为空
        endDateExclusive - 结束日期，排除，任何年表，不为空
        结果
        此日期与结束日期之间的期间不为空
        另请参见：
        ChronoLocalDate.until(ChronoLocalDate)

      • get

        long get​(TemporalUnit unit)
        获取所请求单元的值。

        受支持的单位是具体的年表。 他们通常是YEARS ， MONTHS和DAYS 。 请求不受支持的单元将抛出异常。

        Specified by:
        get在接口 TemporalAmount
        参数
        unit - 要为其返回值的 TemporalUnit
        结果
        单位的长期价值
        异常
        DateTimeException - 如果不支持本机
        UnsupportedTemporalTypeException - 如果不支持本机

      • getUnits

        List<TemporalUnit> getUnits​()
        获取此期间支持的单位集。

        受支持的单位是具体的年表。 他们通常是YEARS ， MONTHS和DAYS 。 他们从最大到最小的顺序返回。

        该集合可以与get(TemporalUnit)一起使用以访问整个期间的状态。

        Specified by:
        getUnits在接口 TemporalAmount
        结果
        包含支持的单位的列表，不为空

      • getChronology

        Chronology getChronology​()
        获取定义支持的单位意义的年表。

        这个时期是按年表定义的。 它控制支持的单位，并限制相同年代的ChronoLocalDate实例的加/减。

        结果
        定义期间的年表，不为空

      • isZero

        default boolean isZero​()
        检查此期间所有受支持的单位是否为零。
        结果
        如果这个时期是零长度，则为真

      • isNegative

        default boolean isNegative​()
        检查此期间的受支持单位是否为负。
        结果
        如果这个时期的任何一个单位都是负数，则为真

      • plus

        ChronoPeriod plus​(TemporalAmount amountToAdd)
        返回指定期间添加的此期间的副本。

        如果指定的金额是ChronoPeriod那么它必须与这个时期有相同的年表。 实施可能会选择接受或拒绝其他TemporalAmount实现。

        此实例是不可变的，不受此方法调用的影响。

        参数
        amountToAdd - 添加时间，不为空
        结果
        一个 ChronoPeriod基于此期间添加的请求期，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • minus

        ChronoPeriod minus​(TemporalAmount amountToSubtract)
        返回此期间的副本，并减去指定的时间段。

        如果指定的金额是ChronoPeriod那么它必须与这个时期有相同的年表。 实施可以选择接受或拒绝其他TemporalAmount实现。

        此实例是不可变的，不受此方法调用的影响。

        参数
        amountToSubtract - 扣除的时间，不为空
        结果
        一个 ChronoPeriod基于此期间减去所请求的周期，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • multipliedBy

        ChronoPeriod multipliedBy​(int scalar)
        返回一个新的实例，其中在此期间的每个金额乘以指定的标量。

        这返回一个周期，每个支持的单位分别乘以。 例如，“2年-3个月4天”乘以3将返回“6年-9个月12天”。 不执行归一化。

        参数
        scalar - 要乘以的标量，不为空
        结果
        一个 ChronoPeriod基于这个时期，数量乘以标量，不为null
        异常
        ArithmeticException - 如果发生数字溢出

      • negated

        default ChronoPeriod negated​()
        返回一个新的实例，每个金额在此期间被否定。

        这返回一个期间，每个受支持的单位被单独否定。 例如，“2年-3个月4天”将被否定为“-2年3个月-4日”。 不执行归一化。

        结果
        一个 ChronoPeriod基于这个时期，金额被否定，不为零
        异常
        ArithmeticException - 如果发生数字溢出，仅在其中一个单位的值为 Long.MIN_VALUE

      • normalized

        ChronoPeriod normalized​()
        返回此期间的副本，并将每个单位的金额归一化。

        标准化过程特定于每个日历系统。 例如，在ISO日历系统中，这几年和几个月是正常化的，但日子不是这样，“15个月”将被归一化为“1年3个月”。

        此实例是不可变的，不受此方法调用的影响。

        结果
        一个 ChronoPeriod基于这个时期，每个单位的数量标准化，不为零
        异常
        ArithmeticException - 如果发生数字溢出

      • addTo

        Temporal addTo​(Temporal temporal)
        将此时段添加到指定的时间对象。

        这返回与添加了此周期的输入相同的可观察类型的时间对象。

        在大多数情况下，通过使用Temporal.plus(TemporalAmount)来更正呼叫模式。

          // these two lines are equivalent, but the second approach is recommended
   dateTime = thisPeriod.addTo(dateTime);
   dateTime = dateTime.plus(thisPeriod);

        指定的时间必须与这个时期有相同的年表。 这返回了添加了非零支持单位的时间。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        addTo在接口 TemporalAmount
        参数
        temporal - 要调整的时间对象，不为null
        结果
        与调整相同类型的对象，不为空
        异常
        DateTimeException - 如果无法添加
        ArithmeticException - 如果发生数字溢出

      • subtractFrom

        Temporal subtractFrom​(Temporal temporal)
        从指定的时间对象中减去这个时间段。

        这返回与减去该周期的输入相同的可观察类型的时间对象。

        在大多数情况下，通过使用Temporal.minus(TemporalAmount)来更正呼叫模式。

          // these two lines are equivalent, but the second approach is recommended
   dateTime = thisPeriod.subtractFrom(dateTime);
   dateTime = dateTime.minus(thisPeriod);

        指定的时间必须与这个时期有相同的年表。 这返回一个时间，减去非零支持的单位。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        subtractFrom在接口 TemporalAmount
        参数
        temporal - 要调整的时间对象，不为空
        结果
        与调整相同类型的对象，不为空
        异常
        DateTimeException - 如果不能减去
        ArithmeticException - 如果发生数字溢出

      • equals

        boolean equals​(Object obj)
        检查这个时期是否等于另一个时期，包括年表。

        将这个时期与另一个时期进行比较，确保类型，每个数量和年表是相同的。 请注意，这意味着“15个月”不等于“1年3个月”。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他时期，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        此期间的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        String toString​()
        将此期间输出为String 。

        产出将包括期限金额和年表。

        重写：
        toString在 Object
        结果
        此期间的字符串表示，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChronoZonedDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Interface ChronoZonedDateTime<D extends ChronoLocalDate>

  • 参数类型
    D - 此日期时间的具体类型
    All Superinterfaces:
    Comparable<ChronoZonedDateTime<?>> ， Temporal ， TemporalAccessor
    所有已知实现类：
    ZonedDateTime

    public interface ChronoZonedDateTime<D extends ChronoLocalDate>
extends Temporal, Comparable<ChronoZonedDateTime<?>>
    具有时间序列的日期时间，以任意时间顺序排列，用于高级全球化用例。

    大多数应用程序应声明方法签名，字段和变量为ZonedDateTime ，而不是此接口。

    A ChronoZonedDateTime是Chronology chronology或日历系统可插拔的偏移日期时间的抽象表示。 日期时间由TemporalField表示的字段定义，其中大多数常见实现在ChronoField中定义。 年表定义日历系统的运行方式和标准字段的含义。

    何时使用此界面

    API的设计鼓励使用ZonedDateTime而不是该接口，即使在应用程序需要处理多个日历系统的情况下。 其原理在ChronoLocalDate中详细探讨。

    确保ChronoLocalDate中的讨论在使用此界面之前已被阅读和理解。

    实现要求：
    该接口必须小心实施，以确保其他类正确运行。 可以实例化的所有实现必须是最终的，不可变的和线程安全的。 子类应尽可能可序列化。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default int compareTo​(ChronoZonedDateTime<?> other)
      将此日期时间与其他日期时间进行比较，包括年表。
      boolean equals​(Object obj)
      检查此日期时间是否等于另一个日期时间。
      default String format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。
      static ChronoZonedDateTime<?> from​(TemporalAccessor temporal)
      从时间对象获取一个 ChronoZonedDateTime的实例。
      default int get​(TemporalField field)
      获取指定字段的 int 。
      default Chronology getChronology​()
      获得这个日期时间的年表。
      default long getLong​(TemporalField field)
      获取指定字段的值作为 long 。
      ZoneOffset getOffset​()
      获取区域偏移量，例如“+01：00”。
      ZoneId getZone​()
      获取区域ID，例如“欧洲/巴黎”。
      int hashCode​()
      这个日期时间的哈希码。
      default boolean isAfter​(ChronoZonedDateTime<?> other)
      检查此日期时间是否在指定的日期时间之后。
      default boolean isBefore​(ChronoZonedDateTime<?> other)
      检查此日期时间是否在指定的日期时间之前。
      default boolean isEqual​(ChronoZonedDateTime<?> other)
      检查此日期时间的时间是否等于指定的日期时间。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      default boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      default ChronoZonedDateTime<D> minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default ChronoZonedDateTime<D> minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      ChronoZonedDateTime<D> plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      default ChronoZonedDateTime<D> plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      default <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      default ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      static Comparator<ChronoZonedDateTime<?>> timeLineOrder​()
      获取一个比较器，比较 ChronoZonedDateTime的时间顺序，忽略年表。
      default long toEpochSecond​()
      将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。
      default Instant toInstant​()
      将此日期时间转换为 Instant 。
      default D toLocalDate​()
      获取此日期时间的本地日期部分。
      ChronoLocalDateTime<D> toLocalDateTime​()
      获取此日期时间的本地日期时间部分。
      default LocalTime toLocalTime​()
      获取此日期时间的当地时间部分。
      String toString​()
      将此日期时间输出为 String 。
      default ChronoZonedDateTime<D> with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      ChronoZonedDateTime<D> with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      ChronoZonedDateTime<D> withEarlierOffsetAtOverlap​()
      返回此日期的副本，将区域偏移更改为本地时间线重叠处的两个有效偏移量的较早者。
      ChronoZonedDateTime<D> withLaterOffsetAtOverlap​()
      返回此日期的副本，将区域偏移更改为本地时间线重叠的两个有效偏移量的后面。
      ChronoZonedDateTime<D> withZoneSameInstant​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，保留即时。
      ChronoZonedDateTime<D> withZoneSameLocal​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。

      • Methods inherited from interface java.time.temporal.Temporal

        until

    • 方法详细信息

      • timeLineOrder

        static Comparator<ChronoZonedDateTime<?>> timeLineOrder​()
        获取一个比较器，比较ChronoZonedDateTime的时间顺序，忽略年表。

        该比较器与compareTo(java.time.chrono.ChronoZonedDateTime<?>)中的比较不同之处在于它仅比较底层瞬间而不是年表。 这允许根据即时时间线上的日期时间的位置来比较不同日历系统中的日期。 潜在的比较相当于比较第二纪和第二秒。

        结果
        比较器比较时间顺序忽略年表
        另请参见：
        isAfter(java.time.chrono.ChronoZonedDateTime<?>) ，
isBefore(java.time.chrono.ChronoZonedDateTime<?>) ，
isEqual(java.time.chrono.ChronoZonedDateTime<?>)

      • from

        static ChronoZonedDateTime<?> from​(TemporalAccessor temporal)
        从时间对象获取一个ChronoZonedDateTime的实例。

        这将根据指定的时间创建一个划区的日期时间。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为ChronoZonedDateTime一个实例。

        转换提取并结合时间对象的年表，日期，时间和区域。 该行为相当于使用Chronology.zonedDateTime(TemporalAccessor)与提取的年表。 允许实现执行优化，例如访问与相关对象相当的那些字段。

        该方法匹配功能界面TemporalQuery的签名，允许其通过方法参考ChronoZonedDateTime::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        日期时间，不为空
        异常
        DateTimeException - 如果无法转换为 ChronoZonedDateTime
        另请参见：
        Chronology.zonedDateTime(TemporalAccessor)

      • range

        default ValueRange range​(TemporalField field)
        描述从接口TemporalAccessor复制
        获取指定字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。 该时间对象的值用于提高返回范围的精度。 如果日期时间无法返回范围，因为该字段不受支持或由于其他原因，将抛出异常。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null

      • get

        default int get​(TemporalField field)
        描述从接口TemporalAccessor复制
        获取指定字段的int 。

        这将查询指定字段的值的日期时间。 返回的值将始终在该字段的值的有效范围内。 如果日期时间不能返回值，因为该字段不受支持或由于其他原因，将抛出异常。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值在值的有效范围内

      • getLong

        default long getLong​(TemporalField field)
        说明从接口TemporalAccessor复制
        获取指定字段的long 。

        这将查询指定字段的值的日期时间。 返回的值可能在该字段的值的有效范围之外。 如果日期时间不能返回值，因为该字段不受支持或由于其他原因，将抛出异常。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值

      • toLocalDate

        default D toLocalDate​()
        获取此日期时间的本地日期部分。

        这将返回与此日期时间相同的年，月和日的本地日期。

        结果
        此日期时间的日期部分不为null

      • toLocalTime

        default LocalTime toLocalTime​()
        获取此日期时间的当地时间部分。

        这将返回本地时间与这个日期时间相同的小时，分钟，秒和纳秒。

        结果
        这个日期时间的一部分，不是null

      • toLocalDateTime

        ChronoLocalDateTime<D> toLocalDateTime​()
        获取此日期时间的本地日期时间部分。

        这将返回与此日期时间相同的年，月和日的本地日期。

        结果
        这个日期时间的本地日期时间部分，不为空

      • getChronology

        default Chronology getChronology​()
        获得这个日期时间的年表。

        Chronology代表正在使用的日历系统。 时代和其他领域在ChronoField由年表定义。

        结果
        年表，不为空

      • getOffset

        ZoneOffset getOffset​()
        获取区域偏移量，例如“+01：00”。

        这是当地时间与UTC /格林威治的抵消。

        结果
        区域偏移，不为空

      • getZone

        ZoneId getZone​()
        获取区域ID，例如“欧洲/巴黎”。

        这将返回用于确定时区规则的存储的时区ID。

        结果
        区域ID，不为空

      • withEarlierOffsetAtOverlap

        ChronoZonedDateTime<D> withEarlierOffsetAtOverlap​()
        返回此日期的副本，将区域偏移更改为本地时间线重叠处的两个有效偏移量的较早者。

        当本地时间线重叠时，例如在秋季夏令时切换时，此方法仅有效果。 在这种情况下，本地日期时间有两个有效的偏移量。 调用此方法将返回一个分区的日期时间，其中选择的两个之前的早期。

        如果在不重叠的情况下调用此方法，则返回this 。

        此实例是不可变的，不受此方法调用的影响。

        结果
        一个 ChronoZonedDateTime基于这个日期时间与较早的偏移量，不为null
        异常
        DateTimeException - 如果没有找到该区域的规则
        DateTimeException - 如果没有规则在此日期时间内有效

      • withLaterOffsetAtOverlap

        ChronoZonedDateTime<D> withLaterOffsetAtOverlap​()
        返回此日期的副本，将区域偏移更改为本地时间线重叠的两个有效偏移量的后面。

        当本地时间线重叠时，例如在秋季夏令时切换时，此方法仅有效果。 在这种情况下，本地日期时间有两个有效的偏移量。 调用此方法将返回一个分区的日期时间，后两个选择。

        如果在不重叠的情况下调用此方法，则返回this 。

        此实例是不可变的，不受此方法调用的影响。

        结果
        一个 ChronoZonedDateTime基于这个日期时间与稍后的偏移量，不为null
        异常
        DateTimeException - 如果没有找到该区域的规则
        DateTimeException - 如果没有规则在此日期时间内有效

      • withZoneSameLocal

        ChronoZonedDateTime<D> withZoneSameLocal​(ZoneId zone)
        使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。

        此方法更改时区并保留本地日期时间。 仅当新的区域无效时，才会更改本地日期时间。

        要更改区域并调整本地日期时间，请使用withZoneSameInstant(ZoneId) 。

        此实例是不可变的，不受此方法调用的影响。

        参数
        zone - 要更改的时区，不为空
        结果
        一个 ChronoZonedDateTime基于此日期时间与请求的区域，不为null

      • withZoneSameInstant

        ChronoZonedDateTime<D> withZoneSameInstant​(ZoneId zone)
        使用不同的时区返回此日期时间的副本，保留即时。

        该方法更改时区并保留即时。 这通常会导致本地日期时间的更改。

        该方法基于保留相同的时刻，因此本地时间线上的间隙和重叠对结果没有影响。

        要保持本地时间更改偏移量，请使用withZoneSameLocal(ZoneId) 。

        参数
        zone - 要更改的时区，不为空
        结果
        一个 ChronoZonedDateTime基于这个日期时间与请求的区域，不为null
        异常
        DateTimeException - 如果结果超出支持的日期范围

      • isSupported

        boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以在此日期时间查询指定的字段。 如果是假，然后调用range ， get和with(TemporalField, long)方法会抛出异常。

        支持的字段集由年表定义，通常包括所有ChronoField字段。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果可以查询该字段，则为true，否则为false

      • isSupported

        default boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查是否可以从此日期时间添加或减去指定的单位。 如果是false，那么调用plus(long, TemporalUnit)和minus方法会抛出异常。

        支持单位的集合由年表定义，通常包括除了FOREVER之外的所有ChronoUnit单位。

        如果单位不是ChronoUnit ，则通过调用TemporalUnit.isSupportedBy(Temporal)通过this作为参数获得该方法的结果。 设备是否受支持由本机决定。

        Specified by:
        isSupported在接口 Temporal
        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • with

        default ChronoZonedDateTime<D> with​(TemporalAdjuster adjuster)
        通过进行调整，返回与该对象相同类型的调整对象。

        这将根据指定的调整器的规则调整此日期时间。 一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 TemporalAdjusters提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.with(Month.JULY);        // most key classes implement TemporalAdjuster
  date = date.with(lastDayOfMonth());  // static import from Adjusters
  date = date.with(next(WEDNESDAY));   // static import from Adjusters and DayOfWeek
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果无法进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        ChronoZonedDateTime<D> with​(TemporalField field,
                            long newValue)
        返回与该对象具有相同类型的对象，并更改指定的字段。

        这将返回一个基于该对象的新对象，其中指定字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月的日期。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        与指定字段集相同类型的对象，不为null
        异常
        DateTimeException - 如果该字段无法设置
        ArithmeticException - 如果发生数字溢出

      • plus

        default ChronoZonedDateTime<D> plus​(TemporalAmount amount)
        返回与此对象相同类型的对象，并添加一个金额。

        这调整这个时间，根据指定量的规则添加。 金额通常是Period，但可以是实现TemporalAmount接口的任何其他类型，例如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.plus(period);                // add a Period instance
  date = date.plus(duration);              // add a Duration instance
  date = date.plus(workingDays(6));        // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        plus在接口 Temporal
        参数
        amount - 要添加的金额，不为null
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        ChronoZonedDateTime<D> plus​(long amountToAdd,
                            TemporalUnit unit)
        返回与此对象相同类型的对象，并添加指定的句点。

        此方法基于添加了指定句点的新对象。 例如，在LocalDate ，这可以用来添加几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则添加一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的指定单位的数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        与指定期间相同类型的对象添加，不为空
        异常
        DateTimeException - 如果无法添加本机
        ArithmeticException - 如果发生数字溢出

      • minus

        default ChronoZonedDateTime<D> minus​(TemporalAmount amount)
        返回与该对象相同类型的对象，并减去一个数量。

        这调整这个时间，根据指定量的规则减去。 金额通常是Period，但可能是实现TemporalAmount接口的任何其他类型，例如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.minus(period);               // subtract a Period instance
  date = date.minus(duration);             // subtract a Duration instance
  date = date.minus(workingDays(6));       // example user-written workingDays method

        请注意，呼叫plus后跟minus不能保证返回相同的日期时间。

        Specified by:
        minus在接口 Temporal
        参数
        amount - 减去量，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        default ChronoZonedDateTime<D> minus​(long amountToSubtract,
                                     TemporalUnit unit)
        返回与该对象相同类型的对象，并减去指定的时间段。

        该方法返回一个基于该对象的新对象，减去指定的时间段。 例如，在LocalDate ，这可以用来减去几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表3月31日的日期，则减去一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 扣除指定单位的金额，可能为负数
        unit - 减去量的单位，不为空
        结果
        与指定周期相同类型的对象减去，不为空
        异常
        DateTimeException - 如果不能减去单位
        ArithmeticException - 如果发生数字溢出

      • query

        default <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此日期时间。

        这将使用指定的查询策略对象查询此日期时间。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过在指定的查询this作为参数调用TemporalQuery.queryFrom(TemporalAccessor)方法获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • format

        default String format​(DateTimeFormatter formatter)
        使用指定的格式化程序格式化此日期时间。

        这个日期时间将传递给格式化程序以生成一个字符串。

        默认实现必须如下所示：

          return formatter.format(this);
        参数
        formatter - 要使用的格式化程序，不为null
        结果
        格式化的日期时间字符串，不为空
        异常
        DateTimeException - 打印时是否发生错误

      • toInstant

        default Instant toInstant​()
        将此日期时间转换为Instant 。

        这将返回一个Instant表示与此日期时间相同的时间点。 计算结合了local date-time和offset 。

        结果
        一个 Instant代表同一时刻，不为空

      • toEpochSecond

        default long toEpochSecond​()
        将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。

        这使用local date-time和offset来计算历时秒值，这是从1970-01-01T00：00：00Z起经过的秒数。 时代之后的时代的实体是积极的，较早的是负的。

        结果
        从1970-01-01T00：00：00Z的时代开始的秒数

      • compareTo

        default int compareTo​(ChronoZonedDateTime<?> other)
        将此日期时间与其他日期时间进行比较，包括年表。

        比较首先在瞬间，然后在当地的日期时间，然后在区域ID，然后在时间顺序。 它与“等于”一致，由Comparable定义。

        如果所有被比较的日期时间对象都在相同的年表中，则不需要额外的年表。

        此默认实现执行上面定义的比较。

        Specified by:
        compareTo在接口 Comparable<D extends ChronoLocalDate>
        参数
        other - 其他日期时间来比较，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • isBefore

        default boolean isBefore​(ChronoZonedDateTime<?> other)
        检查此日期时间是否在指定的日期时间之前。

        该方法与compareTo(java.time.chrono.ChronoZonedDateTime<?>)中的比较不同之处在于它仅比较日期时间的时间。 这相当于使用dateTime1.toInstant().isBefore(dateTime2.toInstant()); 。

        该默认实现基于第二纪和第二秒执行比较。

        参数
        other - 与之对比的其他日期时间，不为空
        结果
        如果这一点在指定的日期时间之前，则为true

      • isAfter

        default boolean isAfter​(ChronoZonedDateTime<?> other)
        检查此日期时间是否在指定的日期时间之后。

        该方法与compareTo(java.time.chrono.ChronoZonedDateTime<?>)中的比较不同之处仅在于比较日期时间的时间。 这相当于使用dateTime1.toInstant().isAfter(dateTime2.toInstant()); 。

        该默认实现基于第二纪和第二秒执行比较。

        参数
        other - 与之对比的其他日期时间，不为空
        结果
        如果这是指定的日期时间后，则为true

      • isEqual

        default boolean isEqual​(ChronoZonedDateTime<?> other)
        检查此日期时间的时间是否等于指定的日期时间。

        该方法与compareTo(java.time.chrono.ChronoZonedDateTime<?>)和equals(java.lang.Object)中的比较不同之处在于它仅比较日期时间的时间。 这相当于使用dateTime1.toInstant().equals(dateTime2.toInstant()); 。

        该默认实现基于第二纪和第二秒执行比较。

        参数
        other - 其他日期时间来比较，不为null
        结果
        如果瞬间等于指定日期时间的时间，则为true

      • equals

        boolean equals​(Object obj)
        检查此日期时间是否等于另一个日期时间。

        比较是基于偏移日期时间和区域。 要在时间线上比较相同的时间，请使用compareTo(java.time.chrono.ChronoZonedDateTime<?>) 。 只比较ChronoZonedDateTime类型的对象，其他类型返回false。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期时间，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        这个日期时间的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        String toString​()
        将此日期时间输出为String 。

        输出将包括完整分区的日期时间。

        重写：
        toString类 Object
        结果
        此日期时间的字符串表示形式，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Era (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Interface Era

  • All Superinterfaces:
    TemporalAccessor ， TemporalAdjuster
    所有已知实现类：
    HijrahEra ， IsoEra ， JapaneseEra ， MinguoEra ， ThaiBuddhistEra

    public interface Era
extends TemporalAccessor, TemporalAdjuster
    时代的时代。

    大多数日历系统具有将时间线划分为两个时代的单个时期。 然而，一些日历系统具有多个时代，例如每个领导者统治的时代。 在所有情况下，这个时代在概念上是时间线上最大的一个部门。 每个年表定义了时代已知的Eras和一个Chronology.eras来获得有效的时代。

    例如，泰国佛教日历系统将时间划分为两个时代，在单个日期之前和之后。 相比之下，日本的日历系统有一个统治帝国统治的时代。

    可以使用==运算符比较Era实例。

    实现要求：
    该接口必须小心实施，以确保其他类正确运行。 所有的实现必须是单例 - 最终的，不可变的和线程安全的。 建议尽可能使用枚举。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的时代。
      default int get​(TemporalField field)
      从该时代获取指定字段的值为 int 。
      default String getDisplayName​(TextStyle style, Locale locale)
      获得这个时代的文字表现。
      default long getLong​(TemporalField field)
      从该时代获取指定字段的值为 long 。
      int getValue​()
      获取与年龄相关联的数值，按时间顺序定义。
      default boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      default <R> R query​(TemporalQuery<R> query)
      使用指定的查询查询此时代。
      default ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。

    • 方法详细信息

      • getValue

        int getValue​()
        获取与年龄相关联的数值，按时间顺序定义。 每个年表定义预定义的Eras和方法来列出年表的Eras。

        所有字段（包括时间）都具有关联的数字值。 时代数值的含义是按照这些原则的时间顺序决定的：

        • 时代1970-01-01（ISO）使用的时代的价值为1。
        • 后来的时代有更高的价值。
        • 较早的时代已经有较低的值，这可能是负的。
        结果
        数字时代的价值

      • isSupported

        default boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这检查是否可以在指定的字段查询这个时代。 如果是false，那么调用range和get方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 ERA字段返回true。 所有其他ChronoField实例都将返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果现场在这个时代得到支持，则为真，否则为假

      • range

        default ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 这个时代用来提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 ERA字段返回范围。 所有其他ChronoField实例都将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        默认实现必须将一个范围从0到一个返回ERA ，适用于两个时代的日历系统，如ISO。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围
        UnsupportedTemporalTypeException - 如果不支持本机

      • get

        default int get​(TemporalField field)
        从该时代获取指定字段的值作为int 。

        这可以查询这个时代的指定字段的值。 返回的值将始终在该字段的值的有效范围内。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 ERA字段返回时代的价值。 所有其他ChronoField实例都会抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        get在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果字段的值无法获取或该值超出了该字段的有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        default long getLong​(TemporalField field)
        从这个时代获取指定字段的值为long 。

        这可以查询这个时代的指定字段的值。 如果不可能返回值，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 ERA字段返回时代的价值。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。 该值是否可以获得，该值代表什么值由该字段决定。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果不支持该字段
        ArithmeticException - 如果发生数字溢出

      • query

        default <R> R query​(TemporalQuery<R> query)
        使用指定的查询查询此时代。

        这使用指定的查询策略对象查询这个时代。 TemporalQuery对象定义了用于获取结果的逻辑。 阅读查询的文档，以了解该方法的结果。

        该方法的结果是通过调用TemporalQuery.queryFrom(TemporalAccessor)方法在指定的查询上通过this作为参数获得的。

        Specified by:
        query在接口 TemporalAccessor
        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询（由查询定义）
        ArithmeticException - 如果发生数字溢出（由查询定义）

      • adjustInto

        default Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象与此对象具有相同的时代。

        这返回与时代相同的可观察类型的时间对象与时代相同。

        该调整是相当于使用Temporal.with(TemporalField, long)通过ChronoField.ERA作为字段。

        在大多数情况下，通过使用Temporal.with(TemporalAdjuster)来更正呼叫模式：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisEra.adjustInto(temporal);
   temporal = temporal.with(thisEra);

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        adjustInto在接口 TemporalAdjuster
        参数
        temporal - 要调整的目标对象，不为null
        结果
        调整对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • getDisplayName

        default String getDisplayName​(TextStyle style,
                              Locale locale)
        获得这个时代的文字表现。

        这返回用于识别时代的文字名称，适合呈现给用户。 参数控制返回的文本和区域设置的样式。

        如果没有发现文本映射，则返回numeric value 。

        API Note:
        此默认实现适用于大多数实现。
        参数
        style - 所需文本的样式，不为空
        locale - 要使用的语言环境，不为空
        结果
        时代的文本值，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HijrahChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class HijrahChronology

  • java.lang.Object
    • java.time.chrono.AbstractChronology
      • java.time.chrono.HijrahChronology
  • All Implemented Interfaces:
    Serializable ， Comparable<Chronology> ， Chronology

    public final class HijrahChronology
extends AbstractChronology
implements Serializable
    Hijrah日历是支持伊斯兰教日历的农历。

    HijrahChronology遵循Hijrah日历系统的规则。 Hijrah日历有几个变体，基于新月确定发生的时间和观察的区别。 在一些变型中，每个月的长度由月球和地球的天文数据算术地计算，而在另一些变型中，月的长度由新月的授权瞄准确定。 对于基于算法的日历，日历可以投射到未来。 对于基于瞄准的日历，只有历史数据可以提供。

    每个月的长度是29或30天。 普通年期354天; 闰年有355天。

    CLDR和LDML识别变体：

    Variants of Hijrah Calendars Chronology ID Calendar Type Locale extension, see Locale Description Hijrah-umalqura islamic-umalqura ca-islamic-umalqura Islamic - Umm Al-Qura calendar of Saudi Arabia

    其他变体可通过Chronology.getAvailableChronologies()获得 。

    例

    从区域设置中选择年表使用Chronology.ofLocale(java.util.Locale)查找基于支持BCP 47扩展机制的区域设置的年表来请求特定的日历（“ca”）。 例如，

      Locale locale = Locale.forLanguageTag("en-US-u-ca-islamic-umalqura");
      Chronology chrono = Chronology.ofLocale(locale);
    实现要求：
    这个类是不可变的和线程安全的。
    Implementation Note:
    每个Hijrah变种单独配置。 每个变体是由定义该属性资源定义ID ，在calendar type ，日历，与ISO日历的对准，并且每个月的一定范围的年长度的开始。 这些变体由HijrahChronology作为资源从hijrah-config- <calendar type> .properties加载。

    Hijrah属性资源是描述日历的一组属性。 语法由java.util.Properties#load(Reader)定义。

    Configuration of Hijrah Calendar Property Name Property value Description id Chronology Id, for example, "Hijrah-umalqura" The Id of the calendar in common usage type Calendar type, for example, "islamic-umalqura" LDML defines the calendar types version Version, for example: "1.8.0_1" The version of the Hijrah variant data iso-start ISO start date, formatted as yyyy-MM-dd, for example: "1900-04-30" The ISO date of the first day of the minimum Hijrah year. yyyy - a numeric 4 digit year, for example "1434" The value is a sequence of 12 month lengths, for example: "29 30 29 30 29 30 30 30 29 30 29 29" The lengths of the 12 months of the year separated by whitespace. A numeric year property must be present for every year without any gaps. The month lengths must be between 29-32 inclusive.
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static HijrahChronology INSTANCE
      沙特阿拉伯伊斯兰教Umm Al-Qura日历的单身人士例子。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      HijrahDate date​(int prolepticYear, int month, int dayOfMonth)
      在Hijrah日历系统中，从幼稚年份，月份和月份月份获取当地日期。
      HijrahDate date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从Hijrah日历系统的时代，年龄，月份和月份月份获取当地的日期。
      HijrahDate date​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期。
      HijrahDate dateEpochDay​(long epochDay)
      从Hijrah日历系统中获取当地的日期。
      HijrahDate dateNow​()
      从默认时区的系统时钟获取此时间顺序中的当前本地日期。
      HijrahDate dateNow​(Clock clock)
      从指定的时钟获取本年龄的当前本地日期。
      HijrahDate dateNow​(ZoneId zone)
      从指定时区的系统时钟获取此时间顺序中的当前本地日期。
      HijrahDate dateYearDay​(int prolepticYear, int dayOfYear)
      从日光年和日间字段获取Hijrah日历系统中的当地日期。
      HijrahDate dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从Hijrah日历系统的时代，年龄和日期领域获得当地的日期。
      HijrahEra eraOf​(int eraValue)
      从数值创建HijrahEra对象。
      List<Era> eras​()
      获取年表的时间列表。
      String getCalendarType​()
      获取伊斯兰历法的日历类型。
      String getId​()
      获取年表的ID。
      boolean isLeapYear​(long prolepticYear)
      检查指定年份是否是闰年。
      ChronoLocalDateTime<HijrahDate> localDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期时间。
      int prolepticYear​(Era era, int yearOfEra)
      计算年龄和年龄的幼年时期。
      ValueRange range​(ChronoField field)
      获取指定字段的有效值的范围。
      HijrahDate resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析 ChronoField值到一个日期。
      ChronoZonedDateTime<HijrahDate> zonedDateTime​(Instant instant, ZoneId zone)
      获得 ChronoZonedDateTime在从这个年表 Instant 。
      ChronoZonedDateTime<HijrahDate> zonedDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取这个年表中的 ChronoZonedDateTime 。

      • Methods inherited from class java.time.chrono.AbstractChronology

        compareTo, equals, hashCode, toString

      • Methods inherited from interface java.time.chrono.Chronology

        epochSecond, epochSecond, from, getDisplayName, period

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INSTANCE

        public static final HijrahChronology INSTANCE
        沙特阿拉伯伊斯兰教Umm Al-Qura日历的单身人士例子。 其他Hijrah年表变体可从Chronology.getAvailableChronologies()获得 。

    • 方法详细信息

      • getId

        public String getId​()
        获取年表的ID。

        该ID唯一标识了Chronology 。 它可以用于查找Chronology使用Chronology.of(String) 。

        Specified by:
        getId在接口 Chronology
        结果
        年表ID，非空
        另请参见：
        getCalendarType()

      • getCalendarType

        public String getCalendarType​()
        获取伊斯兰历法的日历类型。

        日历类型是由Unicode区域设置数据标记语言（LDML）规范定义的标识符。 它可以用于查找Chronology使用Chronology.of(String) 。

        Specified by:
        getCalendarType在接口 Chronology
        结果
        日历系统类型; 如果日历具有标准类型，则为非空，否则为空
        另请参见：
        getId()

      • date

        public HijrahDate date​(Era era,
                       int yearOfEra,
                       int month,
                       int dayOfMonth)
        从Hijrah日历系统的时代，年龄，月份和月份月份获取当地的日期。
        Specified by:
        date在接口 Chronology
        参数
        era - Hijrah时代，不为空
        yearOfEra - 年代
        month - 年月
        dayOfMonth - 月的日子
        结果
        Hijrah本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不是 HijrahEra

      • date

        public HijrahDate date​(int prolepticYear,
                       int month,
                       int dayOfMonth)
        在Hijrah日历系统中，从幼稚年份，月份和月份月份获取当地日期。
        Specified by:
        date在接口 Chronology
        参数
        prolepticYear - prolepticYear年
        month - 年月
        dayOfMonth - 月的日子
        结果
        Hijrah本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期

      • dateYearDay

        public HijrahDate dateYearDay​(Era era,
                              int yearOfEra,
                              int dayOfYear)
        从Hijrah日历系统的时代，年龄和日期领域获得当地的日期。
        Specified by:
        dateYearDay在接口 Chronology
        参数
        era - Hijrah时代，不为空
        yearOfEra - 年代
        dayOfYear - 一年的日子
        结果
        Hijrah本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不是 HijrahEra

      • dateYearDay

        public HijrahDate dateYearDay​(int prolepticYear,
                              int dayOfYear)
        从日光年和日间字段获取Hijrah日历系统中的当地日期。
        Specified by:
        dateYearDay在接口 Chronology
        参数
        prolepticYear - prolepticYear年
        dayOfYear - 年的日子
        结果
        Hijrah本地日期，不为null
        异常
        DateTimeException - 如果年度的价值超出了范围，或者如果今年的日期在一年中无效

      • dateEpochDay

        public HijrahDate dateEpochDay​(long epochDay)
        从Hijrah日历系统中获取当地的日期。
        Specified by:
        dateEpochDay在接口 Chronology
        参数
        epochDay - 纪元日
        结果
        Hijrah本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期

      • dateNow

        public HijrahDate dateNow​()
        说明从界面Chronology复制
        从默认时区的系统时钟获取此时间顺序中的当前本地日期。

        这将查询默认时区中的system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow在接口 Chronology
        结果
        当前本地日期使用系统时钟和默认时区，不为空

      • dateNow

        public HijrahDate dateNow​(ZoneId zone)
        描述从接口Chronology复制
        从指定时区的系统时钟获取此时间顺序中的当前本地日期。

        这将查询system clock以获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow在接口 Chronology
        参数
        zone - 要使用的区域ID，不为空
        结果
        当前本地日期使用系统时钟，不为null

      • dateNow

        public HijrahDate dateNow​(Clock clock)
        说明从接口Chronology复制
        从指定的时钟获取本年龄的当前本地日期。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 替代时钟可以使用dependency injection引入。

        Specified by:
        dateNow在接口 Chronology
        参数
        clock - 要使用的时钟，不为空
        结果
        当前本地日期，不为null

      • date

        public HijrahDate date​(TemporalAccessor temporal)
        描述从接口Chronology复制
        从另一个时间对象获取本年龄的本地日期。

        这在这个时间表中基于指定的时间获得日期。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为ChronoLocalDate的实例。

        转换通常使用EPOCH_DAY字段，这是跨日历系统标准化的。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考aChronology::date用作查询。

        Specified by:
        date在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        这个年代的本地日期，不为空
        另请参见：
        ChronoLocalDate.from(TemporalAccessor)

      • localDateTime

        public ChronoLocalDateTime<HijrahDate> localDateTime​(TemporalAccessor temporal)
        描述从接口Chronology复制
        从另一个时间对象获取本年龄的本地日期时间。

        这在这个时间表中基于指定的时间获得日期时间。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为ChronoLocalDateTime一个实例。

        转换提取并从时间对象中组合了ChronoLocalDate和LocalTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能界面TemporalQuery的签名，允许它通过方法参考aChronology::localDateTime用作查询。

        Specified by:
        localDateTime在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        在这个年代的本地日期时间，不为空
        另请参见：
        ChronoLocalDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ChronoZonedDateTime<HijrahDate> zonedDateTime​(TemporalAccessor temporal)
        说明从界面Chronology复制
        从另一个时间对象获得这个年龄的ChronoZonedDateTime 。

        根据指定的时间，在这个年表中获得一个分区的日期时间。 A TemporalAccessor代表日期和时间信息的任意集合，该工厂转换为ChronoZonedDateTime的实例。

        转换将首先从时间对象获取一个ZoneId ，如果需要，可以回到ZoneOffset 。 然后会尝试获得一个Instant ，如果需要的话可以回复到ChronoLocalDateTime 。 结果将是ZoneId或ZoneOffset与Instant或ChronoLocalDateTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能界面TemporalQuery的签名，允许其通过方法参考aChronology::zonedDateTime用作查询。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        在这个年代的分区日期 - 时间，不为空
        另请参见：
        ChronoZonedDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ChronoZonedDateTime<HijrahDate> zonedDateTime​(Instant instant,
                                                     ZoneId zone)
        描述从界面Chronology复制
        获得ChronoZonedDateTime在从这个年表Instant 。

        这将获得与指定的相同时间的分区日期时间。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        instant - 即时创建日期时间，不为null
        zone - 时区，不为空
        结果
        划分的日期时间，不为空

      • isLeapYear

        public boolean isLeapYear​(long prolepticYear)
        描述从接口Chronology复制
        检查指定年份是否是闰年。

        闰年是一个比正常长的一年。 确切的含义由年龄根据以下约束决定。

        • 闰年必须意味着比非闰年更长的一年。
        • 不支持一年概念的年表必须返回假。
        • 正确的结果必须在年龄的有效范围内返回所有年份。

        在有效年龄范围之外，实施可以自由返回最佳猜测或假。 即使该年度超出有效年限的范围，实施也不能抛出异常。

        Specified by:
        isLeapYear在接口 Chronology
        参数
        prolepticYear - 检查年份，无法验证范围
        结果
        如果这一年是闰年，那么真的

      • prolepticYear

        public int prolepticYear​(Era era,
                         int yearOfEra)
        说明从界面Chronology复制
        计算年龄和年龄的幼年时期。

        这将时代与时代融为一体的年轻一代。

        如果年表积极利用时代，如JapaneseChronology那么年龄就会在这个时代得到验证。 对于其他年表，验证是可选的。

        Specified by:
        prolepticYear在接口 Chronology
        参数
        era - 正确类型为时代的时代，不为空
        yearOfEra - 年代的年代
        结果
        幼稚的一年

      • eraOf

        public HijrahEra eraOf​(int eraValue)
        从数值创建HijrahEra对象。 Hijrah日历系统只有一个时代覆盖了大于0的幼年时光。 此方法返回单数HijrahEra的值1。
        Specified by:
        eraOf在接口 Chronology
        参数
        eraValue - 时代价值
        结果
        日历系统时代，不为空
        异常
        DateTimeException - 如果无法创建时代

      • eras

        public List<Era> eras​()
        描述从界面Chronology复制
        获取年表的时间列表。

        大多数日历系统都有一个时代，其中一年有意义。 如果日历系统不支持时间的概念，则必须返回空列表。

        Specified by:
        eras在接口 Chronology
        结果
        时间表的时代列表可能是不可变的，不为零

      • range

        public ValueRange range​(ChronoField field)
        描述从接口Chronology复制
        获取指定字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        无论年表是否支持该字段，此方法将返回结果。

        Specified by:
        range在接口 Chronology
        参数
        field - 获取范围的字段，不为null
        结果
        字段的有效值的范围不为null

      • resolveDate

        public HijrahDate resolveDate​(Map<TemporalField,Long> fieldValues,
                              ResolverStyle resolverStyle)
        描述从类复制： AbstractChronology
        解析解析中的ChronoField的日期。

        大多数TemporalField实现使用该字段上的resolve方法来解析。 相比之下， ChronoField类定义的字段只具有相对于年表的意义。 因此， ChronoField日期字段在具体年表的上下文中解决。

        ChronoField实例通过此方法解决，这可能会在子类中被覆盖。

        • EPOCH_DAY - 如果存在， EPOCH_DAY其转换为日期，然后根据日期对所有其他日期字段进行交叉检查。
        • PROLEPTIC_MONTH - 如果存在，那么它被拆分为YEAR和MONTH_OF_YEAR 。 如果模式是严格的或智能的，则该字段被验证。
        • YEAR_OF_ERA和ERA - 如果两者都存在，则它们被组合以形成YEAR 。 在宽松的模式下， YEAR_OF_ERA范围是无法验证的，在智能和严格的模式下。 在所有三种模式下， ERA的范围都被验证。 如果只有YEAR_OF_ERA存在，并且模式是聪明或宽松的，那么假设最后一个可用的时代。 在严格的模式下，没有任何时代被假定，而YEAR_OF_ERA保持不变。 如果只有ERA存在，那么它是保持不变的。
        • YEAR ， MONTH_OF_YEAR和DAY_OF_MONTH -如果所有三个都存在，那么它们被组合成一个日期。 在所有三种模式下， YEAR都经过验证。 如果模式是聪明或严格的，则验证月和日。 如果模式宽松，则以相当于在请求年份的第一个月的第一天创建日期的方式组合日期，然后将月份中的差额加上差异天数。 如果模式是聪明的，并且月的日期大于年月的最大值，则月的日期被调整到最后一个月。 如果模式严格，则三个字段必须形成有效的日期。
        • YEAR和DAY_OF_YEAR - 如果两者都存在，则它们被组合以形成日期。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期将以相当于在请求年的第一天创建日期的方式组合，然后加上差异。 如果模式是聪明或严格的，那么这两个字段必须形成一个有效的日期。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和ALIGNED_DAY_OF_WEEK_IN_MONTH -如果所有四个都存在，则它们被组合以形成一个日期。 在所有三种模式下， YEAR都经过验证。 如果该模式宽松，那么日期将以相当于在所请求的年份的第一个月的第一天创建日期的方式组合，然后加上月差，然后以周为单位，然后以天为单位。 如果模式是聪明或严格的，那么所有四个字段都将被验证到其外部范围。 然后将该日期以相当于在所请求的年和月的第一天创建日期的方式组合，然后以数周和数天的数量添加以达到其值。 如果模式严格，则还会验证日期，以检查日和周的调整次数是否不变。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和DAY_OF_WEEK -如果所有四个都存在，则它们被组合以形成一个日期。 该方法与上述相同，多年，数月ALIGNED_DAY_OF_WEEK_IN_MONTH周在ALIGNED_DAY_OF_WEEK_IN_MONTH 。 一天一个月，几周和几周已被处理，星期几被调整为下一个或相同的匹配日。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和ALIGNED_DAY_OF_WEEK_IN_YEAR -如果所有三个都存在，那么它们被组合成一个日期。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期以相当于在所请求年的第一天创建日期的方式组合，然后以周为单位加上差异。 如果模式是聪明或严格的，那么所有三个字段都将被验证到其外部范围。 然后，该日期以相当于在所请求年的第一天创建日期的方式组合，然后以数周和数天添加以达到其值。 如果模式严格，日期也会被验证，以检查日和周的调整没有改变年份。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和DAY_OF_WEEK -如果所有三个都存在，那么它们被组合成一个日期。 该方法与上述ALIGNED_DAY_OF_WEEK_IN_YEAR数年ALIGNED_DAY_OF_WEEK_IN_YEAR周ALIGNED_DAY_OF_WEEK_IN_YEAR 。 一天一周的时间一周调整为下一个或相同的匹配日期，一年的时间和周数被处理。

        默认实现适用于大多数日历系统。 如果发现ChronoField.YEAR_OF_ERA没有ChronoField.ERA，那么最后一个时代在Chronology.eras()被使用。 实施假定为7天，第一个月的日期为1，第一天的值为1，并且月份和年份的第一个始终存在。

        Specified by:
        resolveDate在接口 Chronology
        重写：
        resolveDate在 AbstractChronology
        参数
        fieldValues - 可以更新的值的字段映射，不为null
        resolverStyle - 所请求的解析类型，不为空
        结果
        解决日期，如果信息不足创建日期，则为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


HijrahDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class HijrahDate

  • java.lang.Object
    • java.time.chrono.HijrahDate
  • All Implemented Interfaces:
    Serializable ， Comparable<ChronoLocalDate> ， ChronoLocalDate ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class HijrahDate
extends Object
implements ChronoLocalDate, Serializable
    日期在Hijrah日历系统。

    此日期使用Hijrah calendar的几种变体之一运行 。

    Hijrah日历与公历相比，一年的总天数不同，每个月的长度是基于地球上月球完整革命的时期（在连续的新卫星之间）。 有关支持的变体的详细信息，请参阅HijrahChronology 。

    每个HijrahDate都被创建绑定到一个特定的HijrahChronology，相同的年表被传播到从日期计算的每个HijrahDate。 要使用不同的Hijrah变体，它的HijrahChronology可用于创建新的HijrahDate实例。 或者， withVariant(java.time.chrono.HijrahChronology)方法可用于转换为新的HijrahChronology。

    这是一个value-based课; 在HijrahDate实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ChronoLocalDateTime<HijrahDate> atTime​(LocalTime localTime)
      结合这个日期与时间创建一个 ChronoLocalDateTime 。
      boolean equals​(Object obj)
      将此日期与其他日期进行比较，包括年表。
      static HijrahDate from​(TemporalAccessor temporal)
      从时间物体获得伊斯兰教Umm Al-Qura日历的 HijrahDate 。
      HijrahChronology getChronology​()
      获得这个日期的年表，即Hijrah日历系统。
      HijrahEra getEra​()
      获得这个时代适用的时代。
      long getLong​(TemporalField field)
      获取指定字段的值作为 long 。
      int hashCode​()
      这个日期的哈希码。
      boolean isLeapYear​()
      根据Hijrah日历系统规则检查年份是否是闰年。
      int lengthOfMonth​()
      返回由此日期表示的月份的长度。
      int lengthOfYear​()
      返回由此日期表示的年份的长度。
      HijrahDate minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      HijrahDate minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      static HijrahDate now​()
      在默认时区内获得伊斯兰教Umm Al-Qura日历的当前 HijrahDate 。
      static HijrahDate now​(Clock clock)
      从指定的时钟获取当前的伊斯兰教Umm Al-Qura日历的 HijrahDate 。
      static HijrahDate now​(ZoneId zone)
      在指定的时区内获得伊斯兰教Umm Al-Qura日历的当前 HijrahDate 。
      static HijrahDate of​(int prolepticYear, int month, int dayOfMonth)
      从 HijrahDate年，月 - 日和日月份获得伊斯兰教 HijrahDate Al-Qura日历的 HijrahDate 。
      HijrahDate plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      HijrahDate plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      long toEpochDay​()
      将此日期转换为大纪元日。
      String toString​()
      返回对象的字符串表示形式。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。
      ChronoPeriod until​(ChronoLocalDate endDate)
      将此日期和另一个日期之间的期间计算为 ChronoPeriod 。
      HijrahDate with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      HijrahDate with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      HijrahDate withVariant​(HijrahChronology chronology)
      根据年表要求返回 HijrahDate 。

      • Methods inherited from interface java.time.chrono.ChronoLocalDate

        adjustInto, compareTo, format, isAfter, isBefore, isEqual, isSupported, isSupported, query, timeLineOrder, toString, until

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.time.temporal.TemporalAccessor

        get

    • 方法详细信息

      • now

        public static HijrahDate now​()
        在默认的时区获得伊斯兰教Umm Al-Qura日历的当前HijrahDate 。

        这将在默认时区查询system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前日期使用系统时钟和默认时区，不为空

      • now

        public static HijrahDate now​(ZoneId zone)
        在指定的时区获得伊斯兰教Umm Al-Qura日历的当前HijrahDate 。

        这将查询system clock以获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前日期使用系统时钟，不为空

      • now

        public static HijrahDate now​(Clock clock)
        从指定的时钟获取伊斯兰教Umm Al-Qura日历的当前HijrahDate 。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 备用时钟可以使用dependency injection引入。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前日期，不为null
        异常
        DateTimeException - 如果当前日期无法获得

      • of

        public static HijrahDate of​(int prolepticYear,
                            int month,
                            int dayOfMonth)
        从HijrahDate年份，月份和月份月份获得伊斯兰教HijrahDate Al-Qura日历的HijrahDate 。

        这将返回一个HijrahDate与指定的字段。 该日期必须在年和月中有效，否则将抛出异常。

        参数
        prolepticYear - Hijrah proleptic年
        month - Hijrah的月份，从1到12
        dayOfMonth - Hijrah的月份，从1到30
        结果
        日期在Hijrah日历系统中，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者月的日期对于月份无效

      • from

        public static HijrahDate from​(TemporalAccessor temporal)
        从时间物体获得伊斯兰教Umm Al-Qura日历的HijrahDate 。

        这在Hijrah日历系统中基于指定的时间获取日期。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为HijrahDate的实例。

        转换通常使用EPOCH_DAY字段，这是跨日历系统标准化的。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考HijrahDate::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        日期在Hijrah日历系统中，不为空
        异常
        DateTimeException - 如果无法转换为 HijrahDate
        另请参见：
        Chronology.date(TemporalAccessor)

      • getChronology

        public HijrahChronology getChronology​()
        获得这个日期的年表，即Hijrah日历系统。

        Chronology表示正在使用的日历系统。 时代和其他领域在ChronoField由年表定义。

        Specified by:
        getChronology在接口 ChronoLocalDate
        结果
        Hijrah年表，不为空

      • getEra

        public HijrahEra getEra​()
        获得这个时代适用的时代。

        Hijrah日历系统有一个时代，“AH”，由HijrahEra定义。

        Specified by:
        getEra在接口 ChronoLocalDate
        结果
        在此日期适用的时代不为零

      • lengthOfMonth

        public int lengthOfMonth​()
        返回由此日期表示的月份的长度。

        这将以天为单位返回月份的长度。 Hijrah日历系统的月份长度在29到30天之间。

        Specified by:
        lengthOfMonth在接口 ChronoLocalDate
        结果
        月的长度以天为单位

      • lengthOfYear

        public int lengthOfYear​()
        返回由此日期表示的年份的长度。

        这返回一年中的天数。 Hijrah日历系统年通常比ISO日历系统更短。

        Specified by:
        lengthOfYear在接口 ChronoLocalDate
        结果
        一年中的天数

      • range

        public ValueRange range​(TemporalField field)
        描述从接口TemporalAccessor复制
        获取指定字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。 该时间对象的值用于提高返回范围的精度。 如果日期时间无法返回范围，因为该字段不受支持或由于其他原因，将抛出异常。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null

      • getLong

        public long getLong​(TemporalField field)
        描述从接口TemporalAccessor复制
        获取指定字段的long 。

        这将查询指定字段的值的日期时间。 返回的值可能在该字段的值的有效范围之外。 如果日期时间不能返回值，因为该字段不受支持或由于其他原因，将抛出异常。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值

      • with

        public HijrahDate with​(TemporalField field,
                       long newValue)
        说明从界面ChronoLocalDate复制
        返回与该对象具有相同类型的对象，并更改指定的字段。

        这将返回一个基于该对象的新对象，其中指定字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        与指定字段集相同类型的对象，不为null

      • with

        public HijrahDate with​(TemporalAdjuster adjuster)
        通过进行调整，返回与该对象相同类型的调整对象。

        这将根据指定的调整器的规则调整此日期时间。 一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 TemporalAdjusters中提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.with(Month.JULY);        // most key classes implement TemporalAdjuster
  date = date.with(lastDayOfMonth());  // static import from Adjusters
  date = date.with(next(WEDNESDAY));   // static import from Adjusters and DayOfWeek
        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果无法进行调整。 例如，如果调整器需要ISO年表
        ArithmeticException - 如果发生数字溢出

      • withVariant

        public HijrahDate withVariant​(HijrahChronology chronology)
        退回HijrahDate要求的HijrahDate 。

        根据新的HijrahChronology新年检查年，月和日。 如果这个月份的年表长度较短，那么这一天就会减少到这个月的最后一天。

        参数
        chronology - 新的HijrahChonology，非空
        结果
        一个HijrahDate与要求的HijrahChronology，非空

      • plus

        public HijrahDate plus​(TemporalAmount amount)
        返回与此对象相同类型的对象，并添加一个金额。

        这调整这个时间，根据指定量的规则添加。 金额通常是Period，但可能是实现TemporalAmount接口的任何其他类型，如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.plus(period);                // add a Period instance
  date = date.plus(duration);              // add a Duration instance
  date = date.plus(workingDays(6));        // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amount - 要添加的金额，不为null
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • minus

        public HijrahDate minus​(TemporalAmount amount)
        返回与该对象相同类型的对象，并减去一个数量。

        这调整这个时间，根据指定量的规则减去。 金额通常是Period，但可以是实现27059956565648接口的任何其他类型，例如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.minus(period);               // subtract a Period instance
  date = date.minus(duration);             // subtract a Duration instance
  date = date.minus(workingDays(6));       // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amount - 减去量，不为null
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • toEpochDay

        public long toEpochDay​()
        描述从接口ChronoLocalDate复制
        将此日期转换为大纪元日。

        Epoch Day count是第0天为1970-01-01（ISO）的简单递增计数。 这个定义对于所有的年表都是一样的，可以进行转换。

        此默认实现查询EPOCH_DAY字段。

        Specified by:
        toEpochDay在接口 ChronoLocalDate
        结果
        大纪元日等于这个日期

      • isLeapYear

        public boolean isLeapYear​()
        根据Hijrah日历系统规则检查年份是否是闰年。
        Specified by:
        isLeapYear在接口 ChronoLocalDate
        结果
        如果这个日期是闰年，则为真

      • plus

        public HijrahDate plus​(long amountToAdd,
                       TemporalUnit unit)
        描述从接口ChronoLocalDate复制
        返回与此对象相同类型的对象，并添加指定的句点。

        此方法基于添加了指定句点的新对象。 例如，在LocalDate ，这可以用来添加几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则添加一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的指定单位的数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        与指定期间相同类型的对象添加，不为空

      • minus

        public HijrahDate minus​(long amountToSubtract,
                        TemporalUnit unit)
        说明从接口ChronoLocalDate复制
        返回与该对象相同类型的对象，并减去指定的时间段。

        该方法返回一个基于该对象的新对象，减去指定的时间段。 例如，在LocalDate ，这可以用来减去几年，几个月或几天的数量。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表3月31日的日期，则减去一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amountToSubtract - 减去指定单位的金额，可能为负数
        unit - 减去量的单位，不为空
        结果
        与指定周期相同类型的对象减去，不为空

      • atTime

        public final ChronoLocalDateTime<HijrahDate> atTime​(LocalTime localTime)
        描述从接口ChronoLocalDate复制
        结合此日期与时间创建一个ChronoLocalDateTime 。

        这将在指定的时间返回一个ChronoLocalDateTime从此日期形成的。 日期和时间的所有可能的组合都是有效的。

        Specified by:
        atTime在接口 ChronoLocalDate
        参数
        localTime - 本地使用时间，不为空
        结果
        从该日期到指定时间形成的本地日期时间，不为空

      • until

        public ChronoPeriod until​(ChronoLocalDate endDate)
        说明从界面ChronoLocalDate复制
        将此日期和其他日期之间的期间计算为ChronoPeriod 。

        这计算两个日期之间的期间。 所有提供的年表使用年，月和日计算周期，但是ChronoPeriod API允许使用其他单位来表示期间。

        起点和终点为this和指定日期。 如果结束在开始之前，结果将为负数。 每年，每月的负号将相同。

        计算使用此日期的年表进行。 如有必要，输入日期将被转换为匹配。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 ChronoLocalDate
        参数
        endDate - 结束日期，排他，可能在任何年代，不为空
        结果
        此日期与结束日期之间的期间不为空

      • equals

        public boolean equals​(Object obj)
        将此日期与其他日期进行比较，包括年表。

        比较这个HijrahDate与另一个确保日期是一样的。

        只比较HijrahDate类型的对象，其他类型返回false。 要比较两个TemporalAccessor实例的日期，包括两个不同年表中的日期，请使用ChronoField.EPOCH_DAY作为比较。

        Specified by:
        equals在接口 ChronoLocalDate
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期并且年表是相等的，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个日期的哈希码。
        Specified by:
        hashCode在接口 ChronoLocalDate
        结果
        仅基于时间表和日期的合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        说明从界面ChronoLocalDate复制
        根据指定的单位计算直到另一个日期的时间量。

        这个计算两个之间的时间量ChronoLocalDate在单一方面对象TemporalUnit 。 起点和终点是this和指定的日期。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为ChronoLocalDate使用Chronology.date(TemporalAccessor) 。 计算返回一个整数，表示两个日期之间的完整单位数。 例如，可以使用startDate.until(endDate, DAYS)计算两个日期之间的天startDate.until(endDate, DAYS) 。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        该方法对于ChronoUnit进行计算 。 单位DAYS ， WEEKS ， MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS应该由所有的实现支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 ChronoLocalDate
        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，在同一年代转换为 ChronoLocalDate ，不为空
        unit - 衡量金额的单位，不为空
        结果
        此日期与结束日期之间的时间

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        Specified by:
        toString在接口 ChronoLocalDate
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HijrahEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.chrono

Enum HijrahEra

  • java.lang.Object
    • java.lang.Enum<HijrahEra>
      • java.time.chrono.HijrahEra
  • All Implemented Interfaces:
    Serializable ， Comparable<HijrahEra> ， Era ， TemporalAccessor ， TemporalAdjuster

    public enum HijrahEra
extends Enum<HijrahEra>
implements Era
    Hijrah日历系统中的一个时代。

    Hijrah日历系统只有一个时代覆盖了大于0的幼年时光。

    不要使用ordinal()获得的数字表示HijrahEra 。 改用getValue() 。

    实现要求：
    这是一个不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      AH
      当代时代的单身实例“Anno Hegirae”，其数值为1。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getValue​()
      获得数字时代 int价值。
      static HijrahEra of​(int hijrahEra)
      从 int获取 HijrahEra的实例。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      static HijrahEra valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HijrahEra[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from interface java.time.chrono.Era

        adjustInto, get, getDisplayName, getLong, isSupported, query

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • AH

        public static final HijrahEra AH
        当代时代的单身实例“Anno Hegirae”，其数值为1。

    • 方法详细信息

      • values

        public static HijrahEra[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (HijrahEra c : HijrahEra.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static HijrahEra valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • of

        public static HijrahEra of​(int hijrahEra)
        从int获取HijrahEra的实例。

        目前唯一被接受的时代，它的价值是1

        参数
        hijrahEra - 代表的时代，只有1支持
        结果
        HijrahEra.AH单身人士，不为空
        异常
        DateTimeException - 如果值无效

      • getValue

        public int getValue​()
        获取数字时代int值。

        时代AH值为1。

        Specified by:
        getValue在接口 Era
        结果
        时代价值1（AH）

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 这个时代用来提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 ERA字段返回范围。 所有其他ChronoField实例都会抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        ERA字段返回一个有效的Hijrah时代的范围。

        Specified by:
        range在接口 Era
        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果不能获得该字段的范围
        UnsupportedTemporalTypeException - 如果不支持本机
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


IsoChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class IsoChronology

  • java.lang.Object
    • java.time.chrono.AbstractChronology
      • java.time.chrono.IsoChronology
  • All Implemented Interfaces:
    Serializable ， Comparable<Chronology> ， Chronology

    public final class IsoChronology
extends AbstractChronology
implements Serializable
    ISO日历系统。

    这个年表定义了ISO日历系统的规则。 这个日历系统是基于ISO-8601标准，这是世界历史事实 。

    字段定义如下：

    • 时代 - 有两个时代，“当代时代”（CE）和“当前时代之前”（BCE）。
    • 年代 - 同时代与现在的CE时代的幼稚年一样。 对于在ISO纪元前的BCE时代，年份随着时间的推移从1上升。
    • 幼稚年份 - 幼稚年份与当今时代相同。 对于以前的时代，岁月有零，然后负值。
    • 每年的一个月 - ISO年有12个月，从1到12。
    • 月份 - 每个ISO月份的日期为28至31天，编号为1至31.月份4,6,9和11有30天，第1，3，5，7，8，10 12人有31天。 第2个月有28天，闰年有29天。
    • 一年 - 标准ISO年有365天，闰年366天。 天数从1到365或1到366。
    • 闰年 - 闰年每4年发生一次，除了年份是100分，而不是400分。
    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static IsoChronology INSTANCE
      ISO年代的单例实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      LocalDate date​(int prolepticYear, int month, int dayOfMonth)
      从月度，月份和月份月份获取ISO本地日期。
      LocalDate date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份的时代获得ISO本地日期。
      LocalDate date​(TemporalAccessor temporal)
      从另一个日期时间对象获取ISO本地日期。
      LocalDate dateEpochDay​(long epochDay)
      从时代获取ISO本地日期。
      LocalDate dateNow​()
      从默认时区的系统时钟获取当前的ISO本地日期。
      LocalDate dateNow​(Clock clock)
      从指定的时钟获取当前的ISO本地日期。
      LocalDate dateNow​(ZoneId zone)
      从指定时区的系统时钟获取当前的ISO本地日期。
      LocalDate dateYearDay​(int prolepticYear, int dayOfYear)
      从幼稚年份和日期字段获取ISO本地日期。
      LocalDate dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从时代，年龄和日期的领域获得ISO本地日期。
      long epochSecond​(int prolepticYear, int month, int dayOfMonth, int hour, int minute, int second, ZoneOffset zoneOffset)
      从1970-01-01T00：00：00Z的时期获取秒数。
      IsoEra eraOf​(int eraValue)
      根据数值创建年代时代对象。
      List<Era> eras​()
      获取年表的时间列表。
      String getCalendarType​()
      获取底层日历系统的日历类型 - 'iso8601'。
      String getId​()
      获取年表的ID - “ISO”。
      boolean isLeapYear​(long prolepticYear)
      根据ISO培训日历系统规则，检查年份是否是闰年。
      LocalDateTime localDateTime​(TemporalAccessor temporal)
      从另一个日期时间对象获取ISO本地日期时间。
      Period period​(int years, int months, int days)
      根据几年，几个月和几天的时间表获得一段时间。
      int prolepticYear​(Era era, int yearOfEra)
      计算年龄和年龄的幼年时期。
      ValueRange range​(ChronoField field)
      获取指定字段的有效值的范围。
      LocalDate resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析 ChronoField值到一个日期。
      ZonedDateTime zonedDateTime​(Instant instant, ZoneId zone)
      从这个年龄从 Instant获得ISO Instant日期时间。
      ZonedDateTime zonedDateTime​(TemporalAccessor temporal)
      从另一个日期时间对象获取ISO分区的日期时间。

      • Methods inherited from class java.time.chrono.AbstractChronology

        compareTo, equals, hashCode, toString

      • Methods inherited from interface java.time.chrono.Chronology

        epochSecond, from, getDisplayName

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INSTANCE

        public static final IsoChronology INSTANCE
        ISO年代的单例实例。

    • 方法详细信息

      • getId

        public String getId​()
        获取年表的ID - “ISO”。

        ID唯一标识了Chronology 。 它可以用于查找Chronology使用Chronology.of(String) 。

        Specified by:
        getId在接口 Chronology
        结果
        年表ID - 'ISO'
        另请参见：
        getCalendarType()

      • getCalendarType

        public String getCalendarType​()
        获取底层日历系统的日历类型 - 'iso8601'。

        日历类型是由Unicode区域设置数据标记语言（LDML）规范定义的标识符。 它可以用于查找Chronology使用Chronology.of(String) 。 它也可以作为语言环境的一部分使用，可通过Locale.getUnicodeLocaleType(String)使用键“ca”进行访问。

        Specified by:
        getCalendarType在接口 Chronology
        结果
        日历系统类型 - 'iso8601'
        另请参见：
        getId()

      • date

        public LocalDate date​(Era era,
                      int yearOfEra,
                      int month,
                      int dayOfMonth)
        从时代，年龄，月份和月份的时代获得ISO本地日期。
        Specified by:
        date在接口 Chronology
        参数
        era - ISO时代，不为空
        yearOfEra - ISO年代
        month - ISO月份
        dayOfMonth - ISO的日期
        结果
        ISO本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException -如果类型 era不 IsoEra

      • date

        public LocalDate date​(int prolepticYear,
                      int month,
                      int dayOfMonth)
        从月度，月份和月份月份获取ISO本地日期。

        这相当于LocalDate.of(int, int, int) 。

        Specified by:
        date在接口 Chronology
        参数
        prolepticYear - ISO prolepticYear年
        month - ISO月份
        dayOfMonth - ISO的日期
        结果
        ISO本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateYearDay

        public LocalDate dateYearDay​(Era era,
                             int yearOfEra,
                             int dayOfYear)
        从时代，年龄和日期的领域获得ISO本地日期。
        Specified by:
        dateYearDay在接口 Chronology
        参数
        era - ISO时代，不为空
        yearOfEra - ISO年代
        dayOfYear - ISO的日期
        结果
        ISO本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateYearDay

        public LocalDate dateYearDay​(int prolepticYear,
                             int dayOfYear)
        从幼稚年份和日期字段获取ISO本地日期。

        这相当于LocalDate.ofYearDay(int, int) 。

        Specified by:
        dateYearDay在接口 Chronology
        参数
        prolepticYear - ISO prolepticYear年
        dayOfYear - ISO的一年
        结果
        ISO本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateEpochDay

        public LocalDate dateEpochDay​(long epochDay)
        从时代获取ISO本地日期。

        这相当于LocalDate.ofEpochDay(long) 。

        Specified by:
        dateEpochDay在接口 Chronology
        参数
        epochDay - 纪元日
        结果
        ISO本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • date

        public LocalDate date​(TemporalAccessor temporal)
        从另一个日期时间对象获取ISO本地日期。

        这相当于LocalDate.from(TemporalAccessor) 。

        Specified by:
        date在接口 Chronology
        参数
        temporal - 要转换的日期时间对象，不为空
        结果
        ISO本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期
        另请参见：
        ChronoLocalDate.from(TemporalAccessor)

      • epochSecond

        public long epochSecond​(int prolepticYear,
                        int month,
                        int dayOfMonth,
                        int hour,
                        int minute,
                        int second,
                        ZoneOffset zoneOffset)
        从1970-01-01T00：00：00Z的时期获取秒数。

        秒数是使用年，月，日，月，小时，分钟，秒和zoneOffset计算的。

        Specified by:
        epochSecond在接口 Chronology
        参数
        prolepticYear - 从MIN_YEAR到MAX_YEAR的年份
        month - 从1到12的月份
        dayOfMonth - 从1到31的月份
        hour - 时间从0到23
        minute - 小时，从0到59
        second - 第二分钟，从0到59
        zoneOffset - 区域偏移，不为空
        结果
        相对于1970-01-01T00：00：00Z的秒数可能为负数
        异常
        DateTimeException - 如果任何参数的值超出范围，或者如果月的日期对 DateTimeException无效
        从以下版本开始：
        9

      • localDateTime

        public LocalDateTime localDateTime​(TemporalAccessor temporal)
        从另一个日期时间对象获取ISO本地日期时间。

        这相当于LocalDateTime.from(TemporalAccessor) 。

        Specified by:
        localDateTime在接口 Chronology
        参数
        temporal - 要转换的日期时间对象，不为null
        结果
        ISO本地日期时间，不为null
        异常
        DateTimeException - 如果无法创建日期时间
        另请参见：
        ChronoLocalDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ZonedDateTime zonedDateTime​(TemporalAccessor temporal)
        从另一个日期时间对象获取ISO分区的日期时间。

        这相当于ZonedDateTime.from(TemporalAccessor) 。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        temporal - 要转换的日期时间对象，不为null
        结果
        ISO分区日期时间，不为空
        异常
        DateTimeException - 如果无法创建日期时间
        另请参见：
        ChronoZonedDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ZonedDateTime zonedDateTime​(Instant instant,
                                   ZoneId zone)
        从一个Instant获得这个年代的ISO分区日期。

        这相当于ZonedDateTime.ofInstant(Instant, ZoneId) 。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        instant - 即时创建日期时间，不为null
        zone - 时区，不为空
        结果
        划分的日期时间，不为空
        异常
        DateTimeException - 如果结果超出了支持的范围

      • dateNow

        public LocalDate dateNow​()
        从默认时区的系统时钟获取当前的ISO本地日期。

        这将查询默认时区中的system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow在接口 Chronology
        结果
        当前ISO本地日期使用系统时钟和默认时区，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateNow

        public LocalDate dateNow​(ZoneId zone)
        从指定时区的系统时钟获取当前的ISO本地日期。

        这将查询system clock获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow接口 Chronology
        参数
        zone - 要使用的区域ID，不为空
        结果
        当前ISO本地日期使用系统时钟，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateNow

        public LocalDate dateNow​(Clock clock)
        从指定的时钟获取当前的ISO本地日期。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        Specified by:
        dateNow在接口 Chronology
        参数
        clock - 要使用的时钟，不为空
        结果
        当前的ISO本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期

      • isLeapYear

        public boolean isLeapYear​(long prolepticYear)
        根据ISO培训日历系统规则，检查年份是否是闰年。

        这种方法在整个时间线上应用目前的闰年规则。 一般来说，一年是一个闰年，如果没有余数可以被四分割。 但是，除了100岁之外，年份可以被分割为100岁，除了年龄可以被400除外。

        例如，1904年是一个闰年，可以被4整除。1900年不是一个闰年，因为它可以被100整除，然而2000年是一个闰年，因为它可以被400除数。

        计算是应激的 - 将相同的规则应用到远未来很远的地方。 这在历史上是不准确的，但对于ISO-8601标准是正确的。

        Specified by:
        isLeapYear在接口 Chronology
        参数
        prolepticYear - ISO检测年份
        结果
        如果一年是飞跃，否则为假

      • prolepticYear

        public int prolepticYear​(Era era,
                         int yearOfEra)
        说明从界面Chronology复制
        计算年龄和年龄的幼年时期。

        这将时代与时代融为一体的年轻一代。

        如果年表积极使用时代，如JapaneseChronology那么年代将在时代得到验证。 对于其他年表，验证是可选的。

        Specified by:
        prolepticYear在接口 Chronology
        参数
        era - 时代的正确类型为年表，不为空
        yearOfEra - 年代的年代
        结果
        幼稚的一年

      • eraOf

        public IsoEra eraOf​(int eraValue)
        描述从接口Chronology复制
        根据数值创建年代时代对象。

        时代在概念上是时间线上最大的一个部门。 大多数日历系统具有将时间线划分为两个时代的单个时期。 然而，有些有多个时代，比如每个领导人统治的时代。 确切的含义由年龄根据以下约束决定。

        1970-01-01使用的时代必须具有值1.后来的时代必须具有较高的值。 较早的时间必须具有较低的值。 每个年表必须参考枚举或类似的单身，以提供时代价值观。

        该方法返回指定时代值的正确类型的单例时代。

        Specified by:
        eraOf在接口 Chronology
        参数
        eraValue - 时代价值
        结果
        日历系统时代，不为空

      • eras

        public List<Era> eras​()
        说明从界面Chronology复制
        获取年表的时间列表。

        大多数日历系统都有一个时代，其中一年有意义。 如果日历系统不支持时间的概念，则必须返回空列表。

        Specified by:
        eras在接口 Chronology
        结果
        时间表的时代列表可能是不可变的，不为零

      • resolveDate

        public LocalDate resolveDate​(Map<TemporalField,Long> fieldValues,
                             ResolverStyle resolverStyle)
        解析解析中的日期为ChronoField 。

        大多数TemporalField实现使用该字段上的resolve方法来解决。 相比之下， ChronoField类定义的字段只能具有相对于年表的意义。 因此， ChronoField日期字段在具体年表的上下文中解决。

        ISO日历系统上的ChronoField实例解决如下。

        • EPOCH_DAY - 如果存在， EPOCH_DAY其转换为LocalDate ，然后根据日期对所有其他日期字段进行交叉检查。
        • PROLEPTIC_MONTH - 如果存在，那么它被分割成YEAR和MONTH_OF_YEAR 。 如果模式是严格的或智能的，则该字段被验证。
        • YEAR_OF_ERA和ERA - 如果两者都存在，则它们被组合以形成YEAR 。 在宽松的模式下， YEAR_OF_ERA范围是无法验证的，在智能和严格的模式下。 在所有三种模式下， ERA的范围都被验证。 如果只有YEAR_OF_ERA存在，并且模式是聪明或宽松的，则假设当前时代（CE / AD）。 在严格的模式下，没有任何时代被假定，而YEAR_OF_ERA没有被触动。 如果只有ERA存在，那么它是保持不变的。
        • YEAR ， MONTH_OF_YEAR和DAY_OF_MONTH -如果所有三个都存在，则它们被组合以形成LocalDate 。 在所有三种模式下， YEAR都经过验证。 如果模式是聪明的或严格的，则验证月份和日期，日期从1到31.如果模式宽松，那么日期以相当于在1月1日创建日期的方式组合要求的年份，然后加上差异在几个月，然后差异在天。 如果模式是聪明的，并且月的日期大于年月的最大值，则月的日期被调整到最后一个月。 如果模式严格，则三个字段必须形成有效的日期。
        • YEAR和DAY_OF_YEAR - 如果两者都存在，则它们被组合以形成LocalDate 。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期将以等于在请求年份的1月1日创建日期的方式组合，然后加上差异。 如果模式是聪明或严格的，那么这两个字段必须形成一个有效的日期。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和ALIGNED_DAY_OF_WEEK_IN_MONTH -如果所有四个都存在，则它们被组合以形成LocalDate 。 在所有三种模式下， YEAR都经过验证。 如果该模式宽松，那么日期将以等于在请求年份的1月1日创建日期的方式进行组合，然后加上差异月份，然后加上周差，然后加几天。 如果模式是聪明或严格的，那么所有四个字段都将被验证到其外部范围。 然后将该日期以相当于在所请求的年和月的第一天创建日期的方式组合，然后以数周和数天的数量添加以达到其值。 如果模式严格，则还会验证日期，以检查日和周的调整次数是否不变。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和DAY_OF_WEEK -如果所有四个都存在，则它们被组合以形成LocalDate 。 该方法与上述相同，多年，数月ALIGNED_DAY_OF_WEEK_IN_MONTH周在ALIGNED_DAY_OF_WEEK_IN_MONTH 。 一天一个月，几周和几周已被处理，星期几被调整为下一个或相同的匹配日。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和ALIGNED_DAY_OF_WEEK_IN_YEAR -如果所有三个都存在，则它们被组合以形成LocalDate 。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期将以等同于在请求年份的1月1日创建日期的方式组合，然后以周为单位加上差异。 如果模式是聪明或严格的，那么所有三个字段都将被验证到其外部范围。 然后，该日期以相当于在所请求年的第一天创建日期的方式组合，然后以数周和数天添加以达到其值。 如果模式严格，日期也会被验证，以检查日和周的调整没有改变年份。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和DAY_OF_WEEK -如果所有三个都存在，则它们被组合以形成LocalDate 。 该方法与上述ALIGNED_DAY_OF_WEEK_IN_YEAR中的上述相同。 一天一周的时间一周调整为下一个或相同的匹配日期，一年的时间和周数被处理。
        Specified by:
        resolveDate在接口 Chronology
        重写：
        resolveDate在 AbstractChronology
        参数
        fieldValues - 可以更新的值的字段映射，不为空
        resolverStyle - 所请求的解析类型，不为null
        结果
        解决日期，如果信息不足创建日期，则为null
        异常
        DateTimeException - 如果日期无法解决，通常是因为输入数据中存在冲突

      • range

        public ValueRange range​(ChronoField field)
        描述从接口Chronology复制
        获取指定字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        无论年表是否支持该字段，此方法将返回结果。

        Specified by:
        range在接口 Chronology
        参数
        field - 获取范围的字段，不为null
        结果
        字段的有效值的范围不为null

      • period

        public Period period​(int years,
                     int months,
                     int days)
        根据几年，几个月和几天的时间表获得一段时间。

        这将使用指定的年份，月份和日期返回与ISO年表相关的期间。 详见Period 。

        Specified by:
        period在接口 Chronology
        参数
        years - 年数可能为负数
        months - 年数，可能为负数
        days - 年数，可能为负数
        结果
        这个时间期限在这个年代，不为零
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


IsoEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.chrono

Enum IsoEra

  • java.lang.Object
    • java.lang.Enum<IsoEra>
      • java.time.chrono.IsoEra
  • All Implemented Interfaces:
    Serializable ， Comparable<IsoEra> ， Era ， TemporalAccessor ， TemporalAdjuster

    public enum IsoEra
extends Enum<IsoEra>
implements Era
    ISO日历系统中的一个时代。

    ISO-8601标准没有定义时间。 因此，在此之前多年来，在0001-01-01（ISO）之后或之后已经有两个时代 - “当代”（CE），“当前时代”（BCE）之前的定义。

    ISO years and eras year-of-era era proleptic-year 2 CE 2 1 CE 1 1 BCE 0 2 BCE -1

    不要使用ordinal()获得的数字表示IsoEra 。 改用getValue() 。

    实现要求：
    这是一个不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BCE
      在当前时代之前的“当前时代之前”的单例实例，其数值为0。
      CE
      当前时代的单身实例“当前时代”，其数值为1。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getValue​()
      获得数字时代 int价值。
      static IsoEra of​(int isoEra)
      从 int获得 IsoEra的实例。
      static IsoEra valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static IsoEra[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from interface java.time.chrono.Era

        adjustInto, get, getDisplayName, getLong, isSupported, query, range

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BCE

        public static final IsoEra BCE
        在当前时代之前的“当前时代之前”的单例实例，其数值为0。

      • CE

        public static final IsoEra CE
        当前时代的单身实例“当前时代”，其数值为1。

    • 方法详细信息

      • values

        public static IsoEra[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (IsoEra c : IsoEra.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static IsoEra valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • of

        public static IsoEra of​(int isoEra)
        从int价值获得IsoEra的实例。

        IsoEra是一个表示BCE / CE的ISO时代的枚举。 该工厂允许从int获得枚举。

        参数
        isoEra - 从0（BCE）到1（CE）的BCE / CE值，
        结果
        时代单身，不为空
        异常
        DateTimeException - 如果值无效

      • getValue

        public int getValue​()
        获得数字时代int价值。

        时代BCE的值为0，而CE时代的值为1。

        Specified by:
        getValue在接口 Era
        结果
        时代价值从0（BCE）到1（CE）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


JapaneseChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class JapaneseChronology

  • java.lang.Object
    • java.time.chrono.AbstractChronology
      • java.time.chrono.JapaneseChronology
  • All Implemented Interfaces:
    Serializable ， Comparable<Chronology> ， Chronology

    public final class JapaneseChronology
extends AbstractChronology
implements Serializable
    日本帝国历法系统。

    这个年表定义了日本帝国历法系统的规则。 这个日历系统主要在日本使用。 日系帝国日历系统与日历系统相同，除了基于时代的年份编号。

    日本介绍了从明治6开始的公历。只有明治和以后的时代得到支持; 1月1日明治6日之前的日期不受支持。

    支持的ChronoField实例是：

    • DAY_OF_WEEK
    • DAY_OF_MONTH
    • DAY_OF_YEAR
    • EPOCH_DAY
    • MONTH_OF_YEAR
    • PROLEPTIC_MONTH
    • YEAR_OF_ERA
    • YEAR
    • ERA
    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static JapaneseChronology INSTANCE
      日本年代的单身人士例子。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JapaneseDate date​(int prolepticYear, int month, int dayOfMonth)
      从日光年，月 - 日和日月份获取日本日历系统的当地日期。
      JapaneseDate date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从日期，时代，月份和月份的时代，获取日本日历系统中的当地日期。
      JapaneseDate date​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期。
      JapaneseDate dateEpochDay​(long epochDay)
      在日历日历系统中从当天获取本地日期。
      JapaneseDate dateNow​()
      从默认时区的系统时钟获取此时间顺序中的当前本地日期。
      JapaneseDate dateNow​(Clock clock)
      从指定的时钟获取本年龄的当前本地日期。
      JapaneseDate dateNow​(ZoneId zone)
      从指定时区的系统时钟获取此时间顺序中的当前本地日期。
      JapaneseDate dateYearDay​(int prolepticYear, int dayOfYear)
      从日光年和日期字段获取日语日历系统中的当地日期。
      JapaneseDate dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从时代，年龄和日期领域获取日本日历系统中的当地日期。
      JapaneseEra eraOf​(int eraValue)
      从给定的数值返回日历系统时代对象。
      List<Era> eras​()
      获取年表的时间列表。
      String getCalendarType​()
      获取基础日历系统的日历类型 - “日语”。
      String getId​()
      获取年表的ID - “日语”。
      boolean isLeapYear​(long prolepticYear)
      检查指定年份是否是闰年。
      ChronoLocalDateTime<JapaneseDate> localDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期时间。
      int prolepticYear​(Era era, int yearOfEra)
      计算年龄和年龄的幼年时期。
      ValueRange range​(ChronoField field)
      获取指定字段的有效值的范围。
      JapaneseDate resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField值到一个日期。
      ChronoZonedDateTime<JapaneseDate> zonedDateTime​(Instant instant, ZoneId zone)
      获得 ChronoZonedDateTime在从这个年表 Instant 。
      ChronoZonedDateTime<JapaneseDate> zonedDateTime​(TemporalAccessor temporal)
      从另一个时间对象获得这个年龄的 ChronoZonedDateTime 。

      • Methods inherited from class java.time.chrono.AbstractChronology

        compareTo, equals, hashCode, toString

      • Methods inherited from interface java.time.chrono.Chronology

        epochSecond, epochSecond, from, getDisplayName, period

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INSTANCE

        public static final JapaneseChronology INSTANCE
        日本年代的单身人士例子。

    • 方法详细信息

      • getId

        public String getId​()
        获取年表的ID - “日语”。

        该ID唯一标识了Chronology 。 它可以用于查找Chronology使用Chronology.of(String) 。

        Specified by:
        getId在接口 Chronology
        结果
        年表ID - “日语”
        另请参见：
        getCalendarType()

      • getCalendarType

        public String getCalendarType​()
        获取基础日历系统的日历类型 - “日语”。

        日历类型是由Unicode区域设置数据标记语言（LDML）规范定义的标识符。 它可以用于查找Chronology使用Chronology.of(String) 。 它也可以作为语言环境的一部分使用，通过Locale.getUnicodeLocaleType(String)可以使用键'ca'。

        Specified by:
        getCalendarType在接口 Chronology
        结果
        日历系统类型 - 'japanese'
        另请参见：
        getId()

      • date

        public JapaneseDate date​(Era era,
                         int yearOfEra,
                         int month,
                         int dayOfMonth)
        从日期，时代，月份和月份的时代，获取日本日历系统中的当地日期。

        日历月份和日期与ISO日历系统中的日期和日期相同。 当时代发生变化时，它们不会重置。 例如：

          6th Jan Showa 64 = ISO 1989-01-06
  7th Jan Showa 64 = ISO 1989-01-07
  8th Jan Heisei 1 = ISO 1989-01-08
  9th Jan Heisei 1 = ISO 1989-01-09
        Specified by:
        date在接口 Chronology
        参数
        era - 日本时代，不为空
        yearOfEra - 年代
        month - 年月
        dayOfMonth - 月的日子
        结果
        日本本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不是 JapaneseEra

      • date

        public JapaneseDate date​(int prolepticYear,
                         int month,
                         int dayOfMonth)
        从日光年，月 - 日和日月份获取日本日历系统的当地日期。

        日本的摄像年份，月份和日期与ISO日历系统中的相同。 当时代发生变化时，它们不会重置。

        Specified by:
        date在接口 Chronology
        参数
        prolepticYear - prolepticYear年
        month - 年月
        dayOfMonth - 月的日子
        结果
        日本本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateYearDay

        public JapaneseDate dateYearDay​(Era era,
                                int yearOfEra,
                                int dayOfYear)
        从时代，年龄和日期领域获取日本日历系统中的当地日期。

        这个工厂的日期是相对于时代的开始而言的。 这个定义只是在年龄由于时代的变化而重新设定为一年的那些时代，才改变了日常的正常意义。 例如：

          6th Jan Showa 64 = day-of-year 6
  7th Jan Showa 64 = day-of-year 7
  8th Jan Heisei 1 = day-of-year 1
  9th Jan Heisei 1 = day-of-year 2
        Specified by:
        dateYearDay在接口 Chronology
        参数
        era - 日本时代，不为空
        yearOfEra - 年代
        dayOfYear - 一年的一天
        结果
        日本本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不是 JapaneseEra

      • dateYearDay

        public JapaneseDate dateYearDay​(int prolepticYear,
                                int dayOfYear)
        从日光年和日期字段获取日语日历系统中的当地日期。

        这个工厂的日期是相对于开胃的一年表示的。 日本的摄像年和日期与ISO日历系统相同。 当时代发生变化时，它们不会重置。

        Specified by:
        dateYearDay在接口 Chronology
        参数
        prolepticYear - prolepticYear年
        dayOfYear - 年的日子
        结果
        日本本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateEpochDay

        public JapaneseDate dateEpochDay​(long epochDay)
        在日历日历系统中从当天获取本地日期。
        Specified by:
        dateEpochDay在接口 Chronology
        参数
        epochDay - 纪元日
        结果
        日本本地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateNow

        public JapaneseDate dateNow​()
        描述从界面Chronology复制
        从默认时区的系统时钟获取此时间顺序中的当前本地日期。

        这将在默认时区查询system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow在接口 Chronology
        结果
        当前本地日期使用系统时钟和默认时区，不为空

      • dateNow

        public JapaneseDate dateNow​(ZoneId zone)
        描述从接口Chronology复制
        从指定时区的系统时钟获取此时间顺序中的当前本地日期。

        这将查询system clock获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow在接口 Chronology
        参数
        zone - 要使用的区域ID，不为空
        结果
        当前本地日期使用系统时钟，不为null

      • dateNow

        public JapaneseDate dateNow​(Clock clock)
        描述从接口Chronology复制
        从指定的时钟获取本年龄的当前本地日期。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 备用时钟可以使用dependency injection引入。

        Specified by:
        dateNow在接口 Chronology
        参数
        clock - 要使用的时钟，不为空
        结果
        当前本地日期，不为null

      • date

        public JapaneseDate date​(TemporalAccessor temporal)
        描述从接口Chronology复制
        从另一个时间对象获取本年龄的本地日期。

        这在这个时间表中基于指定的时间获得日期。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为ChronoLocalDate一个实例。

        转换通常使用EPOCH_DAY字段，该字段在日历系统之间进行标准化。

        该方法匹配功能界面TemporalQuery的签名，允许其通过方法参考aChronology::date用作查询。

        Specified by:
        date在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        这个年代的本地日期，不为空
        另请参见：
        ChronoLocalDate.from(TemporalAccessor)

      • localDateTime

        public ChronoLocalDateTime<JapaneseDate> localDateTime​(TemporalAccessor temporal)
        描述从接口Chronology复制
        从另一个时间对象获取本年龄的本地日期时间。

        这在这个时间表中基于指定的时间获得日期时间。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为ChronoLocalDateTime的实例。

        转换提取并从时间对象中组合ChronoLocalDate和LocalTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能界面TemporalQuery的签名，允许它通过方法参考aChronology::localDateTime用作查询。

        Specified by:
        localDateTime在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        在这个年代的本地日期时间，不为空
        另请参见：
        ChronoLocalDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ChronoZonedDateTime<JapaneseDate> zonedDateTime​(TemporalAccessor temporal)
        说明从界面Chronology复制
        从另一个时间对象获得这个时间顺序的ChronoZonedDateTime 。

        根据指定的时间，在这个年表中获得一个分区的日期时间。 A TemporalAccessor表示一个任意的日期和时间信息，这个工厂转换为ChronoZonedDateTime一个实例。

        转换将首先从时间对象获取一个ZoneId ，如有必要，可以回到ZoneOffset 。 然后会尝试获得一个Instant ，如果需要的话可以回到一个ChronoLocalDateTime 。 结果将是ZoneId或ZoneOffset与Instant或ChronoLocalDateTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能接口TemporalQuery的签名，允许其通过方法参考aChronology::zonedDateTime用作查询。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        在这个年代的分区日期 - 时间，不为空
        另请参见：
        ChronoZonedDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ChronoZonedDateTime<JapaneseDate> zonedDateTime​(Instant instant,
                                                       ZoneId zone)
        说明从界面Chronology复制
        获得ChronoZonedDateTime在从这个年表Instant 。

        这将获得与指定的相同时间的分区日期时间。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        instant - 即时创建日期时间，不为null
        zone - 时区，不为空
        结果
        划分的日期时间，不为空

      • isLeapYear

        public boolean isLeapYear​(long prolepticYear)
        检查指定年份是否是闰年。

        日历闰年与ISO闰年完全一致。 该方法不能验证所传递的年份，并且在支持的范围内只有明确的结果多年。

        Specified by:
        isLeapYear在接口 Chronology
        参数
        prolepticYear - 检查年份，无法验证范围
        结果
        如果这一年是闰年，那么真的

      • prolepticYear

        public int prolepticYear​(Era era,
                         int yearOfEra)
        说明从界面Chronology复制
        计算年龄和年龄的幼年时期。

        这将时代与时代融为一体的年轻一代。

        如果年表积极使用时代，例如JapaneseChronology那么那个时代的年代就会在这个时代得到验证。 对于其他年表，验证是可选的。

        Specified by:
        prolepticYear在接口 Chronology
        参数
        era - 时代的正确类型为年表，不为空
        yearOfEra - 年代的年代
        结果
        幼稚的一年

      • eraOf

        public JapaneseEra eraOf​(int eraValue)
        从给定的数值返回日历系统时代对象。 看到每个时代的描述为的数值： JapaneseEra.HEISEI ， JapaneseEra.SHOWA ， JapaneseEra.TAISHO ， JapaneseEra.MEIJI ），仅明治和以后的时代的支持。
        Specified by:
        eraOf在接口 Chronology
        参数
        eraValue - 时代价值
        结果
        日语 Era为给定的数字时代价值
        异常
        DateTimeException - 如果 eraValue无效

      • eras

        public List<Era> eras​()
        说明从接口Chronology复制
        获取年表的时间列表。

        大多数日历系统都有一个时代，其中一年有意义。 如果日历系统不支持时间的概念，则必须返回空列表。

        Specified by:
        eras在接口 Chronology
        结果
        时间表的时代列表可能是不可变的，不为零

      • range

        public ValueRange range​(ChronoField field)
        说明从界面Chronology复制
        获取指定字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        无论年表是否支持该字段，此方法将返回结果。

        Specified by:
        range在接口 Chronology
        参数
        field - 获取范围的字段，不为null
        结果
        字段的有效值的范围不为null

      • resolveDate

        public JapaneseDate resolveDate​(Map<TemporalField,Long> fieldValues,
                                ResolverStyle resolverStyle)
        描述从类别复制AbstractChronology
        解析解析中的日期为ChronoField 。

        大多数TemporalField实现使用该字段上的resolve方法来解析。 相比之下， ChronoField类定义的字段只具有相对于年表的意义。 因此， ChronoField日期字段在具体年表的上下文中解决。

        ChronoField实例通过此方法解决，可能会在子类中被覆盖。

        • EPOCH_DAY - 如果存在，将转换为日期，然后根据日期对所有其他日期字段进行交叉检查。
        • PROLEPTIC_MONTH - 如果存在，那么它被拆分为YEAR和MONTH_OF_YEAR 。 如果模式是严格的或智能的，则该字段被验证。
        • YEAR_OF_ERA和ERA - 如果两者都存在，则它们被组合以形成YEAR 。 在宽松的模式下， YEAR_OF_ERA范围是没有验证的，在智能和严格的模式下。 在所有三种模式下， ERA的范围都被验证。 如果只有YEAR_OF_ERA存在，并且模式是聪明或宽松的，那么假设最后一个可用的时代。 在严格的模式下，没有任何一个时代被假定， YEAR_OF_ERA保持不变。 如果只有ERA存在，那么它将保持不变。
        • YEAR和MONTH_OF_YEAR和DAY_OF_MONTH - 如果所有三个都存在，则它们被组合以形成日期。 在所有三种模式下，验证YEAR 。 如果模式是聪明或严格的，则验证月和日。 如果模式宽松，则以相当于在请求年份的第一个月的第一天创建日期的方式组合日期，然后将月份中的差额加上差异天数。 如果模式是聪明的，并且月的日期大于年月的最大值，则月的日期被调整到最后一个月。 如果模式严格，则三个字段必须形成有效的日期。
        • YEAR和DAY_OF_YEAR - 如果两者都存在，则将它们组合以形成日期。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期将以相当于在请求年的第一天创建日期的方式组合，然后加上差异。 如果模式是聪明或严格的，那么这两个字段必须形成一个有效的日期。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和ALIGNED_DAY_OF_WEEK_IN_MONTH -如果所有四个都存在，则它们被组合以形成一个日期。 在所有三种模式下， YEAR都经过验证。 如果该模式宽松，那么日期将以相当于在所请求的年份的第一个月的第一天创建日期的方式组合，然后加上月差，然后以周为单位，然后以天为单位。 如果模式是聪明或严格的，那么所有四个字段都将被验证到其外部范围。 然后将该日期以相当于在所请求的年和月的第一天创建日期的方式组合，然后以数周和数天的数量添加以达到其值。 如果模式严格，则还会验证日期，以检查日和周的调整次数是否不变。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和DAY_OF_WEEK -如果所有四个都存在，则它们被组合以形成一个日期。 这种方法与上述相同，多年，数月ALIGNED_DAY_OF_WEEK_IN_MONTH周在ALIGNED_DAY_OF_WEEK_IN_MONTH 。 一天一个月，几周和几周已被处理，星期几被调整为下一个或相同的匹配日。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和ALIGNED_DAY_OF_WEEK_IN_YEAR -如果所有三个都存在，那么它们被组合成一个日期。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期以相当于在所请求年的第一天创建日期的方式组合，然后以周为单位加上差异。 如果模式是聪明或严格的，那么所有三个字段都将被验证到其外部范围。 然后，该日期以相当于在所请求年的第一天创建日期的方式组合，然后以数周和数天添加以达到其值。 如果模式严格，日期也会被验证，以检查日和周的调整没有改变年份。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和DAY_OF_WEEK -如果所有三个都存在，那么它们被组合成一个日期。 该方法与上述ALIGNED_DAY_OF_WEEK_IN_YEAR中的上述相同。 一天一周的时间一周调整为下一个或相同的匹配日期，一年的时间和周数被处理。

        默认实现适用于大多数日历系统。 如果发现ChronoField.YEAR_OF_ERA没有一个ChronoField.ERA，那么最后一个时代在Chronology.eras()被使用。 实施假定为7天，第一个月的日期为1，第一天的值为1，并且月份和年份的第一个始终存在。

        Specified by:
        resolveDate在接口 Chronology
        重写：
        resolveDate在 AbstractChronology
        参数
        fieldValues - 可以更新的值的字段映射，不为null
        resolverStyle - 请求的解析类型，不为null
        结果
        the resolved date, null if insufficient information to create a date
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


JapaneseDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class JapaneseDate

  • java.lang.Object
    • java.time.chrono.JapaneseDate
  • All Implemented Interfaces:
    Serializable ， Comparable<ChronoLocalDate> ， ChronoLocalDate ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class JapaneseDate
extends Object
implements ChronoLocalDate, Serializable
    在日本帝国日历系统的日期。

    此日期使用Japanese Imperial calendar操作 。 这个日历系统主要在日本使用。

    日系帝国日历系统与日历系统相同，除了基于时代的年份编号。 幼稚年被定义为等同于ISO抗精神病学年。

    日本介绍了从明治6开始的公历。只有明治和以后的时代得到支持; 1月1日明治6日之前的日期不受支持。

    例如，日本年份“平成24”对应于ISO年“2012”。
    致电japaneseDate.get(YEAR_OF_ERA)将返回24。
    致电japaneseDate.get(YEAR)将返回2012年。
    拨打japaneseDate.get(ERA)将返回2，对应JapaneseChronology.ERA_HEISEI 。

    这是一个value-based课; 对于JapaneseDate实例，使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ChronoLocalDateTime<JapaneseDate> atTime​(LocalTime localTime)
      结合这个日期与时间创建一个 ChronoLocalDateTime 。
      boolean equals​(Object obj)
      将此日期与其他日期进行比较，包括年表。
      static JapaneseDate from​(TemporalAccessor temporal)
      从时间对象获取 JapaneseDate 。
      JapaneseChronology getChronology​()
      获得这个日期的年表，这是日本的日历系统。
      JapaneseEra getEra​()
      获得这个时代适用的时代。
      long getLong​(TemporalField field)
      获取指定字段的 long 。
      int hashCode​()
      这个日期的哈希码。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      int lengthOfMonth​()
      返回由此日期表示的月份的长度。
      int lengthOfYear​()
      返回由日历系统定义的由此日期表示的年份的长度。
      JapaneseDate minus​(long amountToAdd, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      JapaneseDate minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      static JapaneseDate now​()
      从默认时区的系统时钟获取当前的 JapaneseDate 。
      static JapaneseDate now​(Clock clock)
      从指定的时钟获取当前的 JapaneseDate 。
      static JapaneseDate now​(ZoneId zone)
      从指定时区的系统时钟获取当前的 JapaneseDate 。
      static JapaneseDate of​(int prolepticYear, int month, int dayOfMonth)
      获取 JapaneseDate表示日历日历系统中的日期，月份和月份字段中的日期。
      static JapaneseDate of​(JapaneseEra era, int yearOfEra, int month, int dayOfMonth)
      从日期，年龄，月份和月份字段中获取 JapaneseDate表示日历日历系统中的日期。
      JapaneseDate plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      JapaneseDate plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      long toEpochDay​()
      将此日期转换为大纪元日。
      String toString​()
      返回对象的字符串表示形式。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。
      ChronoPeriod until​(ChronoLocalDate endDate)
      将此日期和其他日期之间的期间计算为 ChronoPeriod 。
      JapaneseDate with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      JapaneseDate with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。

      • Methods inherited from interface java.time.chrono.ChronoLocalDate

        adjustInto, compareTo, format, isAfter, isBefore, isEqual, isLeapYear, isSupported, query, timeLineOrder, toString, until

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.time.temporal.TemporalAccessor

        get

    • 方法详细信息

      • now

        public static JapaneseDate now​()
        从默认时区的系统时钟获取当前的JapaneseDate 。

        这将在默认时区查询system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前日期使用系统时钟和默认时区，不为空

      • now

        public static JapaneseDate now​(ZoneId zone)
        从指定时区的系统时钟获取当前的JapaneseDate 。

        这将查询system clock获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前日期使用系统时钟，不为空

      • now

        public static JapaneseDate now​(Clock clock)
        从指定的时钟获取当前的JapaneseDate 。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 可以使用dependency injection引入备用时钟。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前日期，不为null
        异常
        DateTimeException - 如果不能获得当前日期

      • of

        public static JapaneseDate of​(JapaneseEra era,
                              int yearOfEra,
                              int month,
                              int dayOfMonth)
        从时代，年龄，月份和月份字段获取日语日历系统中的日期JapaneseDate 。

        这将返回一个JapaneseDate与指定的字段。 该日期必须在年和月中有效，否则将抛出异常。

        日历月份和日期与ISO日历系统中的日期和日期相同。 当时代发生变化时，它们不会重置。 例如：

          6th Jan Showa 64 = ISO 1989-01-06
  7th Jan Showa 64 = ISO 1989-01-07
  8th Jan Heisei 1 = ISO 1989-01-08
  9th Jan Heisei 1 = ISO 1989-01-09
        参数
        era - 日本时代，不为空
        yearOfEra - 日本年代
        month - 日本的月份，从1到12
        dayOfMonth - 日本人的月份，从1到31
        结果
        日语日历系统中的日期，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者月中的日期对于月份无效，或者日期不是日本时代

      • of

        public static JapaneseDate of​(int prolepticYear,
                              int month,
                              int dayOfMonth)
        获取JapaneseDate代表从JapaneseDate月，月和日月份日期的日期。

        这将返回一个JapaneseDate与指定的字段。 该日期必须在年和月中有效，否则将抛出异常。

        日本的摄像年份，月份和日期与ISO日历系统中的相同。 当时代发生变化时，它们不会重置。

        参数
        prolepticYear - 日本的 prolepticYear年
        month - 日本的月份，从1到12
        dayOfMonth - 日本人的月份，从1到31
        结果
        日语日历系统中的日期，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者如果月的日期对于月份无效

      • from

        public static JapaneseDate from​(TemporalAccessor temporal)
        从时间对象获取JapaneseDate 。

        这在日本日历系统中基于指定的时间获取日期。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为JapaneseDate一个实例。

        转换通常使用EPOCH_DAY字段，这是跨日历系统标准化的。

        该方法匹配功能界面TemporalQuery的签名，允许其通过方法参考JapaneseDate::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        日语日历系统中的日期，不为空
        异常
        DateTimeException - 如果无法转换为 JapaneseDate
        另请参见：
        Chronology.date(TemporalAccessor)

      • getChronology

        public JapaneseChronology getChronology​()
        获得这个日期的年表，这是日本的日历系统。

        Chronology表示正在使用的日历系统。 时代和其他领域在ChronoField由时间顺序定义。

        Specified by:
        getChronology在接口 ChronoLocalDate
        结果
        日本的年表，不为空

      • getEra

        public JapaneseEra getEra​()
        获得这个时代适用的时代。

        日历日历系统有多个时间由JapaneseEra定义。

        Specified by:
        getEra在接口 ChronoLocalDate
        结果
        在此日期适用的时代不为零

      • lengthOfMonth

        public int lengthOfMonth​()
        返回由此日期表示的月份的长度。

        这将以天为单位返回月份的长度。 月份长度与ISO日历系统相匹配。

        Specified by:
        lengthOfMonth在接口 ChronoLocalDate
        结果
        月的长度以天为单位

      • lengthOfYear

        public int lengthOfYear​()
        描述从接口ChronoLocalDate复制
        返回由日历系统定义的由此日期表示的年份的长度。

        这返回一年中的天数。

        默认实现使用ChronoLocalDate.isLeapYear()并返回365或366。

        Specified by:
        lengthOfYear在接口 ChronoLocalDate
        结果
        一年中的天数

      • isSupported

        public boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的日期。 如果是false，那么调用range和get方法会抛出异常。

        如果该字段是一个ChronoField，那么查询是在这里实现的。 支持的字段有：

        • DAY_OF_WEEK
        • DAY_OF_MONTH
        • DAY_OF_YEAR
        • EPOCH_DAY
        • MONTH_OF_YEAR
        • PROLEPTIC_MONTH
        • YEAR_OF_ERA
        • YEAR
        • ERA
        所有其他ChronoField实例将返回false。

        如果该字段不是一个ChronoField ，那么这个方法的结果是通过调用this作为参数TemporalField.isSupportedBy(TemporalAccessor)传递的。 字段是否受支持由字段决定。

        Specified by:
        isSupported在接口 ChronoLocalDate
        Specified by:
        isSupported在接口 TemporalAccessor
        参数
        field - 要检查的字段，null返回false
        结果
        如果在此日期支持该字段，则为true，否则为false

      • range

        public ValueRange range​(TemporalField field)
        描述从接口TemporalAccessor复制
        获取指定字段的有效值的范围。

        所有字段都可以表示为long整数。 此方法返回描述该值的有效范围的对象。 该时间对象的值用于提高返回范围的精度。 如果日期时间无法返回范围，因为该字段不受支持或由于其他原因，将抛出异常。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null

      • getLong

        public long getLong​(TemporalField field)
        说明从界面TemporalAccessor复制
        获取指定字段的long 。

        这将查询指定字段的值的日期时间。 返回的值可能在该字段的值的有效范围之外。 如果日期时间不能返回值，因为该字段不受支持或由于其他原因，将抛出异常。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值

      • with

        public JapaneseDate with​(TemporalField field,
                         long newValue)
        说明从界面ChronoLocalDate复制
        返回与该对象具有相同类型的对象，并更改指定的字段。

        这将返回一个基于该对象的新对象，其中指定字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        与指定字段集相同类型的对象，不为null

      • with

        public JapaneseDate with​(TemporalAdjuster adjuster)
        通过进行调整，返回与该对象相同类型的调整对象。

        这将根据指定的调整器的规则调整此日期时间。 一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 在TemporalAdjusters中提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.with(Month.JULY);        // most key classes implement TemporalAdjuster
  date = date.with(lastDayOfMonth());  // static import from Adjusters
  date = date.with(next(WEDNESDAY));   // static import from Adjusters and DayOfWeek
        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • plus

        public JapaneseDate plus​(TemporalAmount amount)
        返回与此对象相同类型的对象，并添加一个金额。

        这调整这个时间，根据指定量的规则添加。 金额通常是Period，但可能是实现TemporalAmount接口的任何其他类型，如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.plus(period);                // add a Period instance
  date = date.plus(duration);              // add a Duration instance
  date = date.plus(workingDays(6));        // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amount - 要添加的金额，不为null
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • minus

        public JapaneseDate minus​(TemporalAmount amount)
        返回与该对象相同类型的对象，并减去一个数量。

        这调整这个时间，根据指定量的规则减去。 金额通常是Period，但可能是实现TemporalAmount接口的任何其他类型，如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.minus(period);               // subtract a Period instance
  date = date.minus(duration);             // subtract a Duration instance
  date = date.minus(workingDays(6));       // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amount - 减去量，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • plus

        public JapaneseDate plus​(long amountToAdd,
                         TemporalUnit unit)
        说明从接口ChronoLocalDate复制
        返回与此对象相同类型的对象，并添加指定的句点。

        此方法基于添加了指定句点的新对象。 例如，在LocalDate ，这可以用来添加几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则添加一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的指定单位的数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        与指定期间相同类型的对象添加，不为空

      • minus

        public JapaneseDate minus​(long amountToAdd,
                          TemporalUnit unit)
        描述从接口ChronoLocalDate复制
        返回与该对象相同类型的对象，并减去指定的时间段。

        该方法返回一个基于该对象的新对象，减去指定的时间段。 例如，在LocalDate ，这可以用来减去几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表3月31日的日期，则减去一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amountToAdd - 扣除指定单位的金额，可能为负数
        unit - 减去量的单位，不为空
        结果
        与指定周期相同类型的对象减去，不为空

      • atTime

        public final ChronoLocalDateTime<JapaneseDate> atTime​(LocalTime localTime)
        说明从接口ChronoLocalDate复制
        结合这个日期与时间创建一个ChronoLocalDateTime 。

        这将在指定的时间返回从此日期形成的ChronoLocalDateTime 。 日期和时间的所有可能的组合都是有效的。

        Specified by:
        atTime在接口 ChronoLocalDate
        参数
        localTime - 当地使用时间，不为空
        结果
        从该日期到指定时间形成的本地日期时间，不为空

      • until

        public ChronoPeriod until​(ChronoLocalDate endDate)
        说明从接口ChronoLocalDate复制
        将此日期和另一个日期之间的期间计算为ChronoPeriod 。

        这计算两个日期之间的期间。 所有提供的年表使用年，月和日计算周期，但是， ChronoPeriod API允许使用其他单位来表示期间。

        起点和终点是this和指定的日期。 如果结束在开始之前，结果将为负数。 每年，每月的负号将相同。

        计算使用此日期的年表进行。 如有必要，输入日期将被转换为匹配。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 ChronoLocalDate
        参数
        endDate - 结束日期，排他，可能在任何年代，不为空
        结果
        此日期与结束日期之间的期间不为空

      • toEpochDay

        public long toEpochDay​()
        说明从接口ChronoLocalDate复制
        将此日期转换为大纪元日。

        Epoch Day count是第0天为1970-01-01（ISO）的简单递增计数。 这个定义对于所有的年表都是一样的，可以进行转换。

        此默认实现查询EPOCH_DAY字段。

        Specified by:
        toEpochDay在接口 ChronoLocalDate
        结果
        大纪元日等于这个日期

      • equals

        public boolean equals​(Object obj)
        将此日期与其他日期进行比较，包括年表。

        比较这个JapaneseDate与另一个确保日期是一样的。

        只有JapaneseDate类型的JapaneseDate被比较，其他类型返回false。 要比较两个TemporalAccessor实例的日期，包括两个不同年表中的日期，请使用ChronoField.EPOCH_DAY作为比较。

        Specified by:
        equals在接口 ChronoLocalDate
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个日期的哈希码。
        Specified by:
        hashCode在接口 ChronoLocalDate
        结果
        仅基于时间表和日期的合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        说明从界面ChronoLocalDate复制
        根据指定的单位计算直到另一个日期的时间量。

        这个计算两个之间的时间量ChronoLocalDate在单一方面对象TemporalUnit 。 起点和终点是this和指定的日期。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为ChronoLocalDate使用Chronology.date(TemporalAccessor) 。 计算返回一个整数，表示两个日期之间的完整单位数。 例如，可以使用startDate.until(endDate, DAYS)计算两个日期之间的天startDate.until(endDate, DAYS) 。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        以此方法计算ChronoUnit 。 单位DAYS ， WEEKS ， MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS应该由所有的实现支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 ChronoLocalDate
        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，在同一年代转换为 ChronoLocalDate ，不为空
        unit - 测量金额的单位，不为空
        结果
        此日期与结束日期之间的时间

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般情况下， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        Specified by:
        toString在接口 ChronoLocalDate
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JapaneseEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class JapaneseEra

  • java.lang.Object
    • java.time.chrono.JapaneseEra
  • All Implemented Interfaces:
    Serializable ， Era ， TemporalAccessor ， TemporalAdjuster

    public final class JapaneseEra
extends Object
implements Era, Serializable
    日本帝国日历系统的一个时代。

    这个类定义了日本年表的有效时代。 日本介绍了从明治6开始的公历。只有明治和以后的时代得到支持; 1月1日明治6日之前的日期不受支持。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static JapaneseEra HEISEI
      “平成”时代的单身例子（1989-01-08 - 现在），价值2。
      static JapaneseEra MEIJI
      “明治”时代（1868-01-01 - 1912-07-29）的单身实例，其值为-1。
      static JapaneseEra SHOWA
      “昭和”时代（1926-12-25 - 1989-01-07）的单身实例，价值1。
      static JapaneseEra TAISHO
      “大正”时代（1912-07-30 - 1926-12-24）的单身人士的例子为0。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getDisplayName​(TextStyle style, Locale locale)
      获得这个时代的文字表现。
      int getValue​()
      获得数值时代 int价值。
      static JapaneseEra of​(int japaneseEra)
      从 int获取 JapaneseEra的实例。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      String toString​()
      返回对象的字符串表示形式。
      static JapaneseEra valueOf​(String japaneseEra)
      返回名称为 JapaneseEra 。
      static JapaneseEra[] values​()
      返回一个JapaneseEras数组。

      • Methods inherited from interface java.time.chrono.Era

        adjustInto, get, getLong, isSupported, query

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MEIJI

        public static final JapaneseEra MEIJI
        “明治”时代（1868-01-01 - 1912-07-29）的单身实例，其值为-1。

      • TAISHO

        public static final JapaneseEra TAISHO
        “大正”时代（1912-07-30 - 1926-12-24）的单身人士的例子为0。

      • SHOWA

        public static final JapaneseEra SHOWA
        “昭和”时代（1926-12-25 - 1989-01-07）的单身实例，价值1。

      • HEISEI

        public static final JapaneseEra HEISEI
        “平成”时代的单身例子（1989-01-08 - 现在），价值2。

    • 方法详细信息

      • of

        public static JapaneseEra of​(int japaneseEra)
        从int获取JapaneseEra的实例。

        含有1970-01-01（ISO日历系统）的SHOWA时代的价值1后来的时代编号为2（ HEISEI ）。 较早的时代编号为0（ TAISHO ），-1（ MEIJI ），仅支持明治和以后的时间。

        参数
        japaneseEra - 代表的时代
        结果
        JapaneseEra单身人士，不为空
        异常
        DateTimeException - 如果值无效

      • valueOf

        public static JapaneseEra valueOf​(String japaneseEra)
        返回名称为JapaneseEra 。

        字符串必须与时代的名称完全一致。 （不允许使用外来空白字符。）

        参数
        japaneseEra - 日文名称; 非空
        结果
        JapaneseEra单身人士，从不为空
        异常
        IllegalArgumentException - 如果没有指定名称的JapaneseEra

      • values

        public static JapaneseEra[] values​()
        返回一个JapaneseEras数组。

        这种方法可以用来遍历JapanEras，如下所示：

          for (JapaneseEra c : JapaneseEra.values())
     System.out.println(c);
        结果
        一系列日本人

      • getDisplayName

        public String getDisplayName​(TextStyle style,
                             Locale locale)
        获得这个时代的文字表现。

        这返回用于识别时代的文字名称，适合呈现给用户。 参数控制返回的文本和区域设置的样式。

        如果没有发现文本映射，则返回numeric value 。

        Specified by:
        getDisplayName在接口 Era
        参数
        style - 所需文本的样式，不为null
        locale - 要使用的语言环境，不为空
        结果
        时代的文本值，不为空

      • getValue

        public int getValue​()
        获取数值时代int值。

        包含1970-01-01（ISO日历系统）的SHOWA时代的值为1.后来的时间从2（ HEISEI ）编号。 较早的时代编号为0（ TAISHO ），-1（ MEIJI ））。

        Specified by:
        getValue在接口 Era
        结果
        时代价值

      • range

        public ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        范围对象表示字段的最小和最大有效值。 这个时代用来提高返回范围的准确性。 如果不可能返回范围，因为该字段不受支持或出于某种其他原因，则抛出异常。

        如果该字段是ChronoField，那么在这里实现查询。 ERA字段返回范围。 所有其他ChronoField实例将抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessor)传递this作为参数。 是否可以获得范围由字段确定。

        由于日本日历系统的性质，日本有效期的范围可能会随时间而变化。

        Specified by:
        range在接口 Era
        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果不能获得该字段的范围
        UnsupportedTemporalTypeException - 如果不支持本机

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


java.time.chrono (Java SE 9 & JDK 9 )

java.time.chrono

Interfaces

  • ChronoLocalDate
  • ChronoLocalDateTime
  • Chronology
  • ChronoPeriod
  • ChronoZonedDateTime
  • Era

Classes

  • AbstractChronology
  • HijrahChronology
  • HijrahDate
  • IsoChronology
  • JapaneseChronology
  • JapaneseDate
  • JapaneseEra
  • MinguoChronology
  • MinguoDate
  • ThaiBuddhistChronology
  • ThaiBuddhistDate

Enums

  • HijrahEra
  • IsoEra
  • MinguoEra
  • ThaiBuddhistEra


java.time.chrono (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.time.chrono

除默认ISO之外的日历系统的通用API。

主要API基于ISO-8601中定义的日历系统。 但是，还有其他日历系统，这个包提供了基本的支持。 备用日历在java.time.chrono包中提供。

日历系统由Chronology界面定义，日历系统中的日期由ChronoLocalDate界面定义。

意图是应用程序尽可能使用主API，包括从持久数据存储（如数据库）读取和写入代码，以及通过网络发送日期和时间。 然后在用户界面级别使用“计时”类来处理本地化的输入/输出。 有关这些问题的全面讨论，请参阅ChronoLocalDate 。

在应用程序中使用非ISO日历系统会引起显着的额外复杂性。 在使用“计时”界面之前， ChronoLocalDate确保已阅读ChronoLocalDate中的警告和建议。

支持的日历系统包括：

  • Hijrah calendar
  • Japanese calendar
  • Minguo calendar
  • Thai Buddhist calendar

例

此示例列出了所有可用日历的今天日期。

  // Enumerate the list of available calendars and print todays date for each.
       Set<Chronology> chronos = Chronology.getAvailableChronologies();
       for (Chronology chrono : chronos) {
           ChronoLocalDate date = chrono.dateNow();
           System.out.printf("   %20s: %s%n", chrono.getId(), date.toString());
       }

此示例在命名的非ISO日历系统中创建和使用日期。

  // Print the Thai Buddhist date
       ChronoLocalDate now1 = Chronology.of("ThaiBuddhist").dateNow();
       int day = now1.get(ChronoField.DAY_OF_MONTH);
       int dow = now1.get(ChronoField.DAY_OF_WEEK);
       int month = now1.get(ChronoField.MONTH_OF_YEAR);
       int year = now1.get(ChronoField.YEAR);
       System.out.printf("  Today is %s %s %d-%s-%d%n", now1.getChronology().getId(),
                 dow, day, month, year);
   // Print today's date and the last day of the year for the Thai Buddhist Calendar.
       ChronoLocalDate first = now1
                 .with(ChronoField.DAY_OF_MONTH, 1)
                 .with(ChronoField.MONTH_OF_YEAR, 1);
       ChronoLocalDate last = first
                 .plus(1, ChronoUnit.YEARS)
                 .minus(1, ChronoUnit.DAYS);
       System.out.printf("  %s: 1st of year: %s; end of year: %s%n", last.getChronology().getId(),
                 first, last);

此示例创建并使用特定ThaiBuddhist日历系统中的日期。

  // Print the Thai Buddhist date
       ThaiBuddhistDate now1 = ThaiBuddhistDate.now();
       int day = now1.get(ChronoField.DAY_OF_MONTH);
       int dow = now1.get(ChronoField.DAY_OF_WEEK);
       int month = now1.get(ChronoField.MONTH_OF_YEAR);
       int year = now1.get(ChronoField.YEAR);
       System.out.printf("  Today is %s %s %d-%s-%d%n", now1.getChronology().getId(),
                 dow, day, month, year);

   // Print today's date and the last day of the year for the Thai Buddhist Calendar.
       ThaiBuddhistDate first = now1
                 .with(ChronoField.DAY_OF_MONTH, 1)
                 .with(ChronoField.MONTH_OF_YEAR, 1);
       ThaiBuddhistDate last = first
                 .plus(1, ChronoUnit.YEARS)
                 .minus(1, ChronoUnit.DAYS);
       System.out.printf("  %s: 1st of year: %s; end of year: %s%n", last.getChronology().getId(),
                 first, last);

包装规格

除非另有说明，否则将null参数传递给此程序包中任何类或接口中的构造函数或方法将导致抛出NullPointerException 。 Javadoc“@param”定义用于总结空行为。 “ @throws NullPointerException ”没有在每个方法中明确记录。

所有计算应检查数字溢出并抛出ArithmeticException或DateTimeException 。

从以下版本开始：
1.8
  • 接口摘要
    接口 描述
    ChronoLocalDate
    一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。
    ChronoLocalDateTime<D extends ChronoLocalDate>
    在任意年代没有时区的日期时间，用于高级全球化用例。
    Chronology
    用于组织和识别日期的日历系统。
    ChronoPeriod
    基于日期的时间，例如任意年代的“3年，4个月和5天”，旨在用于高级全球化用例。
    ChronoZonedDateTime<D extends ChronoLocalDate>
    具有时间序列的日期时间，以任意时间顺序排列，用于高级全球化用例。
    Era
    时代的时代。
  • 类摘要
    Class 描述
    AbstractChronology
    用于组织和识别日期的日历系统的抽象实现。
    HijrahChronology
    Hijrah日历是支持伊斯兰教日历的农历。
    HijrahDate
    日期在Hijrah日历系统。
    IsoChronology
    ISO日历系统。
    JapaneseChronology
    日本帝国历法系统。
    JapaneseDate
    在日本帝国日历系统的日期。
    JapaneseEra
    日本帝国日历系统的一个时代。
    MinguoChronology
    国际日历系统。
    MinguoDate
    在日语系统中的日期。
    ThaiBuddhistChronology
    泰国佛教日历系统。
    ThaiBuddhistDate
    在泰国佛教日历系统的日期。
  • 枚举摘要
    Enum 描述
    HijrahEra
    Hijrah日历系统中的一个时代。
    IsoEra
    ISO日历系统中的一个时代。
    MinguoEra
    国际日历系统中的一个时代。
    ThaiBuddhistEra
    泰国佛教日历系统的时代。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.time.chrono Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.time.chrono

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.time.chrono.AbstractChronology (implements java.time.chrono.Chronology)
      • java.time.chrono.HijrahChronology (implements java.io.Serializable)
      • java.time.chrono.IsoChronology (implements java.io.Serializable)
      • java.time.chrono.JapaneseChronology (implements java.io.Serializable)
      • java.time.chrono.MinguoChronology (implements java.io.Serializable)
      • java.time.chrono.ThaiBuddhistChronology (implements java.io.Serializable)
    • java.time.chrono.HijrahDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable)
    • java.time.chrono.JapaneseDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable)
    • java.time.chrono.JapaneseEra (implements java.time.chrono.Era, java.io.Serializable)
    • java.time.chrono.MinguoDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable)
    • java.time.chrono.ThaiBuddhistDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable)

Interface Hierarchy

  • java.lang.Comparable<T>
    • java.time.chrono.ChronoLocalDate (also extends java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.chrono.ChronoLocalDateTime<D> (also extends java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.chrono.Chronology
    • java.time.chrono.ChronoZonedDateTime<D> (also extends java.time.temporal.Temporal)
  • java.time.temporal.TemporalAccessor
    • java.time.chrono.Era (also extends java.time.temporal.TemporalAdjuster)
    • java.time.temporal.Temporal
      • java.time.chrono.ChronoLocalDate (also extends java.lang.Comparable<T>, java.time.temporal.TemporalAdjuster)
      • java.time.chrono.ChronoLocalDateTime<D> (also extends java.lang.Comparable<T>, java.time.temporal.TemporalAdjuster)
      • java.time.chrono.ChronoZonedDateTime<D> (also extends java.lang.Comparable<T>)
  • java.time.temporal.TemporalAdjuster
    • java.time.chrono.ChronoLocalDate (also extends java.lang.Comparable<T>, java.time.temporal.Temporal)
    • java.time.chrono.ChronoLocalDateTime<D> (also extends java.lang.Comparable<T>, java.time.temporal.Temporal)
    • java.time.chrono.Era (also extends java.time.temporal.TemporalAccessor)
  • java.time.temporal.TemporalAmount
    • java.time.chrono.ChronoPeriod

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.time.chrono.HijrahEra (implements java.time.chrono.Era)
      • java.time.chrono.IsoEra (implements java.time.chrono.Era)
      • java.time.chrono.MinguoEra (implements java.time.chrono.Era)
      • java.time.chrono.ThaiBuddhistEra (implements java.time.chrono.Era)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


MinguoChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class MinguoChronology

  • java.lang.Object
    • java.time.chrono.AbstractChronology
      • java.time.chrono.MinguoChronology
  • All Implemented Interfaces:
    Serializable ， Comparable<Chronology> ， Chronology

    public final class MinguoChronology
extends AbstractChronology
implements Serializable
    国际日历系统。

    这个年表定义了Minguo日历系统的规则。 这个日历系统主要用于中华民国，通常被称为台湾。 日期对齐， 0001-01-01 (Minguo)为1912-01-01 (ISO) 。

    字段定义如下：

    • 时代 - 有两个时代，现在的“共和国”（ERA_ROC）和前一个时代（ERA_BEFORE_ROC）。
    • 年代 - 当代时代的年代从一年的时代起统一起来。 对于前一个时代，一年中随着时间的推移而增加。 当前时代的价值等于ISO抗体年减去1911年。
    • 幼稚年份 - 幼稚年份与当今时代相同。 对于以前的时代，岁月有零，然后负值。 该值等于ISO抗精神病年减去1911年。
    • 月份 - Minguo月份与ISO完全匹配。
    • 月份 - Minguo日期与ISO完全匹配。
    • 日期 - Minguo的日期与ISO完全一致。
    • 闰年 - Minguo闰年模式与ISO完全匹配，使得两个日历永远不会失步。
    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static MinguoChronology INSTANCE
      孟国时代的单身人士实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MinguoDate date​(int prolepticYear, int month, int dayOfMonth)
      从月光年，月和月的月份中获取Minguo日历系统中的当地日期。
      MinguoDate date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份的时代，获得Minguo日历系统中的当地日期。
      MinguoDate date​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期。
      MinguoDate dateEpochDay​(long epochDay)
      从时代到日本的Minguo日历系统获取本地日期。
      MinguoDate dateNow​()
      从默认时区的系统时钟获取此时间顺序中的当前本地日期。
      MinguoDate dateNow​(Clock clock)
      从指定的时钟获取本年龄的当前本地日期。
      MinguoDate dateNow​(ZoneId zone)
      从指定时区的系统时钟获取此时间顺序中的当前本地日期。
      MinguoDate dateYearDay​(int prolepticYear, int dayOfYear)
      从日光年和日期字段获取Minguo日历系统中的当地日期。
      MinguoDate dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从时代，年龄和日期领域获得Minguo日历系统中的当地日期。
      MinguoEra eraOf​(int eraValue)
      根据数值创建年代时代对象。
      List<Era> eras​()
      获取年表的时间列表。
      String getCalendarType​()
      获取底层日历系统的日历类型 - “roc”。
      String getId​()
      获取年代的ID - “Minguo”。
      boolean isLeapYear​(long prolepticYear)
      检查指定年份是否是闰年。
      ChronoLocalDateTime<MinguoDate> localDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期时间。
      int prolepticYear​(Era era, int yearOfEra)
      计算年龄和年龄的幼年时期。
      ValueRange range​(ChronoField field)
      获取指定字段的有效值的范围。
      MinguoDate resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析时解析 ChronoField值到日期。
      ChronoZonedDateTime<MinguoDate> zonedDateTime​(Instant instant, ZoneId zone)
      获得 ChronoZonedDateTime在从这个年表 Instant 。
      ChronoZonedDateTime<MinguoDate> zonedDateTime​(TemporalAccessor temporal)
      从另一个时间对象获得这个年龄的 ChronoZonedDateTime 。

      • Methods inherited from class java.time.chrono.AbstractChronology

        compareTo, equals, hashCode, toString

      • Methods inherited from interface java.time.chrono.Chronology

        epochSecond, epochSecond, from, getDisplayName, period

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INSTANCE

        public static final MinguoChronology INSTANCE
        孟国时代的单身人士实例。

    • 方法详细信息

      • getId

        public String getId​()
        获取年代的ID - “Minguo”。

        该ID唯一标识了Chronology 。 它可以用于查找Chronology使用Chronology.of(String) 。

        Specified by:
        getId在接口 Chronology
        结果
        年表ID - 'Minguo'
        另请参见：
        getCalendarType()

      • getCalendarType

        public String getCalendarType​()
        获取底层日历系统的日历类型 - “roc”。

        日历类型是由Unicode区域设置数据标记语言（LDML）规范定义的标识符。 它可用于查找Chronology使用Chronology.of(String) 。 它也可以作为语言环境的一部分使用，通过Locale.getUnicodeLocaleType(String)可以通过键“ca”访问。

        Specified by:
        getCalendarType在接口 Chronology
        结果
        日历系统类型 - 'roc'
        另请参见：
        getId()

      • date

        public MinguoDate date​(Era era,
                       int yearOfEra,
                       int month,
                       int dayOfMonth)
        从时代，年龄，月份和月份的时代，获得Minguo日历系统中的当地日期。
        Specified by:
        date在接口 Chronology
        参数
        era - 金国时代，不为空
        yearOfEra - 年代
        month - 年月日
        dayOfMonth - 月的日子
        结果
        Minguo本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不是 MinguoEra

      • date

        public MinguoDate date​(int prolepticYear,
                       int month,
                       int dayOfMonth)
        从月光年，月和月的月份中获取Minguo日历系统中的当地日期。
        Specified by:
        date在接口 Chronology
        参数
        prolepticYear - prolepticYear年
        month - 年月
        dayOfMonth - 月的日子
        结果
        Minguo本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期

      • dateYearDay

        public MinguoDate dateYearDay​(Era era,
                              int yearOfEra,
                              int dayOfYear)
        从时代，年龄和日期领域获得Minguo日历系统中的当地日期。
        Specified by:
        dateYearDay在接口 Chronology
        参数
        era - era时代，不为空
        yearOfEra - 年代
        dayOfYear - 年的日子
        结果
        Minguo本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不是 MinguoEra

      • dateYearDay

        public MinguoDate dateYearDay​(int prolepticYear,
                              int dayOfYear)
        从日光年和日期字段获取Minguo日历系统中的当地日期。
        Specified by:
        dateYearDay在接口 Chronology
        参数
        prolepticYear - prolepticYear年
        dayOfYear - 一年的一天
        结果
        Minguo本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期

      • dateEpochDay

        public MinguoDate dateEpochDay​(long epochDay)
        从时代到日本的Minguo日历系统获取本地日期。
        Specified by:
        dateEpochDay在接口 Chronology
        参数
        epochDay - 纪元日
        结果
        Minguo本地日期，不为null
        异常
        DateTimeException - 如果无法创建日期

      • dateNow

        public MinguoDate dateNow​()
        描述从接口Chronology复制
        从默认时区的系统时钟获取此时间顺序中的当前本地日期。

        这将查询默认时区中的system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow在接口 Chronology
        结果
        当前本地日期使用系统时钟和默认时区，不为空

      • dateNow

        public MinguoDate dateNow​(ZoneId zone)
        说明从界面Chronology复制
        从指定时区的系统时钟获取此时间顺序中的当前本地日期。

        这将查询system clock获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow在接口 Chronology
        参数
        zone - 要使用的区域ID，不为空
        结果
        当前本地日期使用系统时钟，不为null

      • dateNow

        public MinguoDate dateNow​(Clock clock)
        说明从接口Chronology复制
        从指定的时钟获取本年龄的当前本地日期。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 备用时钟可以使用dependency injection引入。

        Specified by:
        dateNow在接口 Chronology
        参数
        clock - 要使用的时钟，不为空
        结果
        当前本地日期，不为null

      • date

        public MinguoDate date​(TemporalAccessor temporal)
        说明从界面Chronology复制
        从另一个时间对象获取本年龄的本地日期。

        这在这个时间表中基于指定的时间获得日期。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为ChronoLocalDate的实例。

        转换通常使用EPOCH_DAY字段，该字段在日历系统之间进行标准化。

        该方法匹配功能界面TemporalQuery的签名，允许它通过方法参考aChronology::date作为查询使用。

        Specified by:
        date在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        这个年代的本地日期，不为空
        另请参见：
        ChronoLocalDate.from(TemporalAccessor)

      • localDateTime

        public ChronoLocalDateTime<MinguoDate> localDateTime​(TemporalAccessor temporal)
        说明从界面Chronology复制
        从另一个时间对象获取本年龄的本地日期时间。

        这在这个时间表中基于指定的时间获得日期时间。 A TemporalAccessor表示任意的日期和时间信息集，该工厂将转换为ChronoLocalDateTime的实例。

        转换提取并从时间对象中组合了ChronoLocalDate和LocalTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能界面TemporalQuery的签名，允许其通过方法参考aChronology::localDateTime用作查询。

        Specified by:
        localDateTime在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为空
        结果
        在这个年代的本地日期时间，不为空
        另请参见：
        ChronoLocalDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ChronoZonedDateTime<MinguoDate> zonedDateTime​(TemporalAccessor temporal)
        说明从接口Chronology复制
        从另一个时间对象获得这个年龄的ChronoZonedDateTime 。

        根据指定的时间，在这个年表中获得一个分区的日期时间。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将其转换为ChronoZonedDateTime的实例。

        转换将首先从时间对象获取一个ZoneId ，如有必要，则返回到ZoneOffset 。 然后会尝试获得一个Instant ，如果需要的话可以回到ChronoLocalDateTime 。 结果将是ZoneId或ZoneOffset与Instant或ChronoLocalDateTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能界面TemporalQuery的签名，允许其通过方法参考aChronology::zonedDateTime用作查询。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        在这个年代的分区日期 - 时间，不为空
        另请参见：
        ChronoZonedDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ChronoZonedDateTime<MinguoDate> zonedDateTime​(Instant instant,
                                                     ZoneId zone)
        描述从接口Chronology复制
        获得ChronoZonedDateTime在从这个年表Instant 。

        这将获得与指定的相同时间的分区日期时间。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        instant - 即时创建日期时间，不为null
        zone - 时区，不为空
        结果
        划分的日期时间，不为空

      • isLeapYear

        public boolean isLeapYear​(long prolepticYear)
        检查指定年份是否是闰年。

        Minguo闰年完全符合ISO闰年。 该方法不能验证所传递的年份，并且在支持的范围内只有明确的结果多年。

        Specified by:
        isLeapYear在接口 Chronology
        参数
        prolepticYear - 检查年份，无法验证范围
        结果
        如果这一年是闰年，那么真的

      • prolepticYear

        public int prolepticYear​(Era era,
                         int yearOfEra)
        说明从界面Chronology复制
        计算年龄和年龄的幼年时期。

        这将时代与时代融为一体的年轻一代。

        如果年表积极使用时代，如JapaneseChronology那么年龄将在时代得到验证。 对于其他年表，验证是可选的。

        Specified by:
        prolepticYear在接口 Chronology
        参数
        era - 时代的正确类型为年表，不为空
        yearOfEra - 年代的年代
        结果
        幼稚的一年

      • eraOf

        public MinguoEra eraOf​(int eraValue)
        描述从接口Chronology复制
        根据数值创建年代时代对象。

        时代在概念上是时间线上最大的一个部门。 大多数日历系统具有将时间线划分为两个时代的单个时期。 然而，有些有多个时代，比如每个领导人统治的时代。 确切的含义由年龄根据以下约束决定。

        1970-01-01使用的时代必须具有值1.后来的时代必须具有较高的值。 较早的时间必须具有较低的值。 每个年表必须参考枚举或类似的单身，以提供时代价值观。

        该方法返回指定时代值的正确类型的单例时代。

        Specified by:
        eraOf在接口 Chronology
        参数
        eraValue - 时代价值
        结果
        日历系统时代，不为空

      • eras

        public List<Era> eras​()
        说明从接口Chronology复制
        获取年表的时间列表。

        大多数日历系统都有一个时代，其中一年有意义。 如果日历系统不支持时间的概念，则必须返回空列表。

        Specified by:
        eras在接口 Chronology
        结果
        时间表的时代列表可能是不可变的，不为零

      • range

        public ValueRange range​(ChronoField field)
        说明从接口Chronology复制
        获取指定字段的有效值的范围。

        所有字段都可以表示为long整数。 此方法返回描述该值的有效范围的对象。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        无论年表是否支持该字段，此方法将返回结果。

        Specified by:
        range在接口 Chronology
        参数
        field - 获取范围的字段，不为null
        结果
        字段的有效值的范围不为null

      • resolveDate

        public MinguoDate resolveDate​(Map<TemporalField,Long> fieldValues,
                              ResolverStyle resolverStyle)
        说明从类别复制： AbstractChronology
        解析时解析为ChronoField值。

        大多数TemporalField实现使用该字段上的resolve方法进行解析。 相比之下， ChronoField类定义的字段只具有相对于年表的意义。 因此，在具体年表的上下文中解决了ChronoField日期字段。

        ChronoField实例通过此方法解决，可能会在子类中被覆盖。

        • EPOCH_DAY - 如果存在，将转换为日期，然后根据日期对所有其他日期字段进行交叉检查。
        • PROLEPTIC_MONTH - 如果存在，则分为YEAR和MONTH_OF_YEAR 。 如果模式是严格的或智能的，则该字段被验证。
        • YEAR_OF_ERA和ERA - 如果两者都存在，则它们被组合以形成YEAR 。 在宽松模式下， YEAR_OF_ERA范围不能在智能和严格模式下进行验证。 在所有三种模式下， ERA的范围都被验证。 如果只有YEAR_OF_ERA存在，并且模式是聪明或宽松的，那么假设最后一个可用的时代。 在严格的模式下，没有假设时代， YEAR_OF_ERA保持不变。 如果只有ERA存在，那么它将保持不变。
        • YEAR ， MONTH_OF_YEAR和DAY_OF_MONTH -如果所有三个都存在，那么它们被组合成一个日期。 在所有三种模式下， YEAR都经过验证。 如果模式是聪明或严格的，则验证月和日。 如果模式宽松，则以相当于在请求年份的第一个月的第一天创建日期的方式组合日期，然后将月份中的差额加上差异天数。 如果模式是聪明的，并且月的日期大于年月的最大值，则月的日期被调整到最后一个月。 如果模式严格，则三个字段必须形成有效的日期。
        • YEAR和DAY_OF_YEAR - 如果两者都存在，则将它们组合以形成日期。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期将以相当于在请求年的第一天创建日期的方式组合，然后加上差异。 如果模式是聪明或严格的，那么这两个字段必须形成一个有效的日期。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和ALIGNED_DAY_OF_WEEK_IN_MONTH -如果所有四个都存在，则它们被组合以形成一个日期。 在所有三种模式下， YEAR都经过验证。 如果该模式宽松，那么日期将以相当于在所请求的年份的第一个月的第一天创建日期的方式组合，然后加上月差，然后以周为单位，然后以天为单位。 如果模式是聪明或严格的，那么所有四个字段都将被验证到其外部范围。 然后将该日期以相当于在所请求的年和月的第一天创建日期的方式组合，然后以数周和数天的数量添加以达到其值。 如果模式严格，则还会验证日期，以检查日和周的调整次数是否不变。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和DAY_OF_WEEK -如果所有四个都存在，则它们被组合以形成一个日期。 该方法与上述相同，多年，数月ALIGNED_DAY_OF_WEEK_IN_MONTH周在ALIGNED_DAY_OF_WEEK_IN_MONTH 。 一天一个月，几周和几周已被处理，星期几被调整为下一个或相同的匹配日。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和ALIGNED_DAY_OF_WEEK_IN_YEAR -如果所有三个都存在，那么它们被组合成一个日期。 在所有三种模式下，验证YEAR 。 如果模式宽松，那么日期以相当于在所请求年的第一天创建日期的方式组合，然后以周为单位加上差异。 如果模式是聪明或严格的，那么所有三个字段都将被验证到其外部范围。 然后，该日期以相当于在所请求年的第一天创建日期的方式组合，然后以数周和数天添加以达到其值。 如果模式严格，日期也会被验证，以检查日和周的调整没有改变年份。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和DAY_OF_WEEK -如果所有三个都存在，那么它们被组合成一个日期。 该方法与ALIGNED_DAY_OF_WEEK_IN_YEAR中的上述几年和几周ALIGNED_DAY_OF_WEEK_IN_YEAR 。 一天一周的时间一周调整为下一个或相同的匹配日期，一年的时间和周数被处理。

        默认实现适用于大多数日历系统。 如果ChronoField.YEAR_OF_ERA是没有发现ChronoField.ERA然后在最后的时代Chronology.eras()使用。 实施假定为7天，第一个月的日期为1，第一天的值为1，并且月份和年份的第一个始终存在。

        Specified by:
        resolveDate在接口 Chronology
        重写：
        resolveDate在 AbstractChronology
        参数
        fieldValues - 可以更新的值的字段映射，不为null
        resolverStyle - 请求的解析类型，不为null
        结果
        the resolved date, null if insufficient information to create a date
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


MinguoDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class MinguoDate

  • java.lang.Object
    • java.time.chrono.MinguoDate
  • All Implemented Interfaces:
    Serializable ， Comparable<ChronoLocalDate> ， ChronoLocalDate ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class MinguoDate
extends Object
implements ChronoLocalDate, Serializable
    在日语系统中的日期。

    此日期使用Minguo calendar操作 。 这个日历系统主要用于中华民国，通常被称为台湾。 日期对齐， 0001-01-01 (Minguo)为1912-01-01 (ISO) 。

    这是一个value-based类; 在MinguoDate实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ChronoLocalDateTime<MinguoDate> atTime​(LocalTime localTime)
      结合这个日期与时间创建一个 ChronoLocalDateTime 。
      boolean equals​(Object obj)
      将此日期与其他日期进行比较，包括年表。
      static MinguoDate from​(TemporalAccessor temporal)
      从时间对象获取 MinguoDate 。
      MinguoChronology getChronology​()
      获得这个日期的时间顺序，即Minguo日历系统。
      MinguoEra getEra​()
      获得这个时代适用的时代。
      long getLong​(TemporalField field)
      获取指定字段的值作为 long 。
      int hashCode​()
      这个日期的哈希码。
      int lengthOfMonth​()
      返回由此日期表示的月份的长度。
      MinguoDate minus​(long amountToAdd, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      MinguoDate minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      static MinguoDate now​()
      从默认时区的系统时钟获取当前的 MinguoDate 。
      static MinguoDate now​(Clock clock)
      从指定的时钟获取当前的 MinguoDate 。
      static MinguoDate now​(ZoneId zone)
      从指定时区的系统时钟获取当前的 MinguoDate 。
      static MinguoDate of​(int prolepticYear, int month, int dayOfMonth)
      获取一个 MinguoDate代表了 MinguoDate日，月和月的月份日期。
      MinguoDate plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      MinguoDate plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      long toEpochDay​()
      将此日期转换为大纪元日。
      String toString​()
      返回对象的字符串表示形式。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。
      ChronoPeriod until​(ChronoLocalDate endDate)
      将此日期与另一个日期之间的期间计算为 ChronoPeriod 。
      MinguoDate with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      MinguoDate with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。

      • Methods inherited from interface java.time.chrono.ChronoLocalDate

        adjustInto, compareTo, format, isAfter, isBefore, isEqual, isLeapYear, isSupported, isSupported, lengthOfYear, query, timeLineOrder, toString, until

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.time.temporal.TemporalAccessor

        get

    • 方法详细信息

      • now

        public static MinguoDate now​()
        从默认时区的系统时钟获取当前的MinguoDate 。

        这将查询默认时区中的system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前日期使用系统时钟和默认时区，不为空

      • now

        public static MinguoDate now​(ZoneId zone)
        从指定时区的系统时钟获取当前的MinguoDate 。

        这将查询system clock获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前日期使用系统时钟，不为空

      • now

        public static MinguoDate now​(Clock clock)
        从指定的时钟获取当前的MinguoDate 。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 备用时钟可以使用dependency injection引入。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前日期，不为null
        异常
        DateTimeException - 如果当前日期无法获得

      • of

        public static MinguoDate of​(int prolepticYear,
                            int month,
                            int dayOfMonth)
        获取MinguoDate代表MinguoDate年份，月份和月份字段中MinguoDate日历系统中的日期。

        这将返回一个MinguoDate与指定的字段。 该日期必须在年和月中有效，否则将抛出异常。

        参数
        prolepticYear - prolepticYear年
        month - month年份，从1到12
        dayOfMonth - dayOfMonth的月份，从1到31
        结果
        Minguo日历系统中的日期不为null
        异常
        DateTimeException - 如果任何字段的值超出范围，或者月中的日期对于月份无效

      • from

        public static MinguoDate from​(TemporalAccessor temporal)
        从时间对象获取MinguoDate 。

        这可以在Minguo日历系统中基于指定的时间获取日期。 A TemporalAccessor代表日期和时间信息的任意集合，该工厂将转换为MinguoDate的实例。

        转换通常使用EPOCH_DAY字段，这是跨日历系统标准化的。

        该方法匹配功能界面TemporalQuery的签名，允许它通过方法参考MinguoDate::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        Minguo日历系统中的日期不为null
        异常
        DateTimeException - 如果无法转换为 MinguoDate
        另请参见：
        Chronology.date(TemporalAccessor)

      • getChronology

        public MinguoChronology getChronology​()
        获得这个日期的时间顺序，即Minguo日历系统。

        Chronology代表正在使用的日历系统。 时代和其他领域在ChronoField由年表定义。

        Specified by:
        getChronology在接口 ChronoLocalDate
        结果
        金国年表，不为空

      • getEra

        public MinguoEra getEra​()
        获得这个时代适用的时代。

        Minguo日历系统有两个时代，“ROC”和“BEFORE_ROC”，由MinguoEra定义。

        Specified by:
        getEra在接口 ChronoLocalDate
        结果
        在此日期适用的时代不为零

      • lengthOfMonth

        public int lengthOfMonth​()
        返回由此日期表示的月份的长度。

        这将以天为单位返回月份的长度。 月份长度与ISO日历系统相匹配。

        Specified by:
        lengthOfMonth在接口 ChronoLocalDate
        结果
        月的长度以天为单位

      • range

        public ValueRange range​(TemporalField field)
        描述从接口TemporalAccessor复制
        获取指定字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。 该时间对象的值用于提高返回范围的精度。 如果日期时间无法返回范围，因为该字段不受支持或由于其他原因，将抛出异常。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null

      • getLong

        public long getLong​(TemporalField field)
        描述从接口TemporalAccessor复制
        获取指定字段的值作为long 。

        这将查询指定字段的值的日期时间。 返回的值可能在该字段的值的有效范围之外。 如果日期时间不能返回值，因为该字段不受支持或由于其他原因，将抛出异常。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值

      • with

        public MinguoDate with​(TemporalField field,
                       long newValue)
        说明从界面ChronoLocalDate复制
        返回与该对象具有相同类型的对象，并更改指定的字段。

        这将返回一个基于该对象的新对象，其中指定字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        与指定字段集相同类型的对象，不为null

      • with

        public MinguoDate with​(TemporalAdjuster adjuster)
        通过进行调整，返回与该对象相同类型的调整对象。

        这将根据指定的调整器的规则调整此日期时间。 一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 TemporalAdjusters中提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.with(Month.JULY);        // most key classes implement TemporalAdjuster
  date = date.with(lastDayOfMonth());  // static import from Adjusters
  date = date.with(next(WEDNESDAY));   // static import from Adjusters and DayOfWeek
        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • plus

        public MinguoDate plus​(TemporalAmount amount)
        返回与此对象相同类型的对象，并添加一个金额。

        这调整这个时间，根据指定量的规则添加。 金额通常为Period，但可能是实现TemporalAmount接口的任何其他类型，如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.plus(period);                // add a Period instance
  date = date.plus(duration);              // add a Duration instance
  date = date.plus(workingDays(6));        // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amount - 要添加的金额，不为null
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • minus

        public MinguoDate minus​(TemporalAmount amount)
        返回与该对象相同类型的对象，并减去一个数量。

        这调整这个时间，根据指定量的规则减去。 金额通常是Period，但可能是实现TemporalAmount接口的任何其他类型，如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.minus(period);               // subtract a Period instance
  date = date.minus(duration);             // subtract a Duration instance
  date = date.minus(workingDays(6));       // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amount - 减去量，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • plus

        public MinguoDate plus​(long amountToAdd,
                       TemporalUnit unit)
        说明从接口ChronoLocalDate复制
        返回与此对象相同类型的对象，并添加指定的句点。

        此方法基于添加了指定句点的新对象。 例如，在LocalDate ，这可以用来添加几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则添加一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的指定单位的数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        与指定期间相同类型的对象添加，不为空

      • minus

        public MinguoDate minus​(long amountToAdd,
                        TemporalUnit unit)
        描述从接口ChronoLocalDate复制
        返回与该对象相同类型的对象，并减去指定的时间段。

        该方法返回一个基于该对象的新对象，减去指定的时间段。 例如，在LocalDate ，这可以用来减去几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表3月31日的日期，则减去一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amountToAdd - 减去指定单位的金额，可能为负数
        unit - 减去量的单位，不为空
        结果
        与指定周期相同类型的对象减去，不为空

      • atTime

        public final ChronoLocalDateTime<MinguoDate> atTime​(LocalTime localTime)
        说明从接口ChronoLocalDate复制
        结合此日期与时间创建一个ChronoLocalDateTime 。

        这将在指定的时间返回从此日期形成的ChronoLocalDateTime 。 日期和时间的所有可能的组合都是有效的。

        Specified by:
        atTime在接口 ChronoLocalDate
        参数
        localTime - 本地使用时间，不为空
        结果
        从该日期到指定时间形成的本地日期时间，不为空

      • until

        public ChronoPeriod until​(ChronoLocalDate endDate)
        说明从接口ChronoLocalDate复制
        将此日期和其他日期之间的期间计算为ChronoPeriod 。

        这计算两个日期之间的期间。 所有提供的年表使用年，月和日计算期间，但是ChronoPeriod API允许使用其他单位来表示期间。

        起点和终点是this和指定的日期。 如果结束在开始之前，结果将为负数。 每年，每月的负号将相同。

        计算使用此日期的年表进行。 如有必要，输入日期将被转换为匹配。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 ChronoLocalDate
        参数
        endDate - 结束日期，排他，可能在任何年代，不为空
        结果
        此日期与结束日期之间的期间不为空

      • toEpochDay

        public long toEpochDay​()
        说明从接口ChronoLocalDate复制
        将此日期转换为大纪元日。

        Epoch Day count是第0天为1970-01-01（ISO）的简单递增计数。 这个定义对于所有的年表都是一样的，可以进行转换。

        此默认实现查询EPOCH_DAY字段。

        Specified by:
        toEpochDay在接口 ChronoLocalDate
        结果
        大纪元日等于这个日期

      • equals

        public boolean equals​(Object obj)
        将此日期与其他日期进行比较，包括年表。

        比较这个MinguoDate与另一个确保日期是一样的。

        只有MinguoDate类型的MinguoDate被比较，其他类型返回false。 要比较两个TemporalAccessor实例的日期，包括两个不同年表中的日期，请使用ChronoField.EPOCH_DAY作为比较。

        Specified by:
        equals在接口 ChronoLocalDate
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个日期的哈希码。
        Specified by:
        hashCode在接口 ChronoLocalDate
        结果
        仅基于时间表和日期的合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        说明从界面ChronoLocalDate复制
        根据指定的单位计算直到另一个日期的时间量。

        这可以计算一个ChronoLocalDate对象之间的时间量，单个TemporalUnit 。 起点和终点为this和指定日期。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为ChronoLocalDate使用Chronology.date(TemporalAccessor) 。 计算返回一个整数，表示两个日期之间的完整单位数。 例如，可以使用startDate.until(endDate, DAYS)计算两个日期之间的天startDate.until(endDate, DAYS) 。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        此方法的计算用于ChronoUnit 。 单位DAYS ， WEEKS ， MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS应该由所有的实现支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 ChronoLocalDate
        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，在同一年代转换为 ChronoLocalDate ，不为空
        unit - 衡量金额的单位，不为空
        结果
        此日期与结束日期之间的时间

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        Specified by:
        toString在接口 ChronoLocalDate
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MinguoEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.chrono

Enum MinguoEra

  • java.lang.Object
    • java.lang.Enum<MinguoEra>
      • java.time.chrono.MinguoEra
  • All Implemented Interfaces:
    Serializable ， Comparable<MinguoEra> ， Era ， TemporalAccessor ， TemporalAdjuster

    public enum MinguoEra
extends Enum<MinguoEra>
implements Era
    国际日历系统中的一个时代。

    国语日历系统有两个时代。 目前这个时代，从1年起，被称为“中华民国”时代。 所有前几年，在激进计数为零或更早的时期，也就是年龄以上的数字，都是“中华民国”时代的一部分。

    Minguo years and eras year-of-era era proleptic-year ISO proleptic-year 2 ROC 2 1913 1 ROC 1 1912 1 BEFORE_ROC 0 1911 2 BEFORE_ROC -1 1910

    不要使用ordinal()获得的数字表示MinguoEra 。 改用getValue() 。

    实现要求：
    这是一个不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BEFORE_ROC
      在当前时代之前的“中华民国时代之前”的单例，其数值为0。
      ROC
      当前时代的单身人士例子，“中华民国时代”，其数值为1。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getValue​()
      获得数值时代 int价值。
      static MinguoEra of​(int minguoEra)
      从 int获取 MinguoEra的实例。
      static MinguoEra valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MinguoEra[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from interface java.time.chrono.Era

        adjustInto, get, getDisplayName, getLong, isSupported, query, range

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BEFORE_ROC

        public static final MinguoEra BEFORE_ROC
        在当前时代之前的“中华民国时代之前”的单例，其数值为0。

      • ROC

        public static final MinguoEra ROC
        当前时代的单身人士例子，“中华民国时代”，其数值为1。

    • 方法详细信息

      • values

        public static MinguoEra[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (MinguoEra c : MinguoEra.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static MinguoEra valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • of

        public static MinguoEra of​(int minguoEra)
        从int获取MinguoEra的实例。

        MinguoEra是代表BEFORE_ROC / ROC的Minguo时代的枚举。 该工厂允许从int获取枚举。

        参数
        minguoEra - BEFORE_ROC / ROC值表示，从0（BEFORE_ROC）到1（ROC）
        结果
        时代单身，不为空
        异常
        DateTimeException - 如果值无效

      • getValue

        public int getValue​()
        获得数值时代int价值。

        时代BEFORE_ROC的值为0，而时代ROC的值为1。

        Specified by:
        getValue在接口 Era
        结果
        时代价值从0（BEFORE_ROC）到1（ROC）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ThaiBuddhistChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class ThaiBuddhistChronology

  • java.lang.Object
    • java.time.chrono.AbstractChronology
      • java.time.chrono.ThaiBuddhistChronology
  • All Implemented Interfaces:
    Serializable ， Comparable<Chronology> ， Chronology

    public final class ThaiBuddhistChronology
extends AbstractChronology
implements Serializable
    泰国佛教日历系统。

    这个年表定义了泰国佛教日历系统的规则。 这个日历系统主要用于泰国。 日期对齐，使得2484-01-01 (Buddhist)为1941-01-01 (ISO) 。

    字段定义如下：

    • 时代 - 有两个时代，当前的“佛教”（ERA_BE）和前一个时代（ERA_BEFORE_BE）。
    • 年代 - 当代时代的年代从一年的时代起统一起来。 对于前一个时代，一年中随着时间的推移而增加。 当前时代的价值等于ISO光学年加543。
    • 幼稚年份 - 幼稚年份与当今时代相同。 对于以前的时代，岁月有零，然后负值。 该值等于ISO proleptic-year加上543。
    • 一年的时间 - 泰国Buddhist的年份与ISO完全一致。
    • 每月的日子 - ThaiBuddhist的日期与ISO完全一致。
    • 日期 - 泰国Buddhist日期与ISO完全一致。
    • 闰年 - 泰国的闰年模式与ISO完全匹配，使得两个日历永远不会失步。
    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static ThaiBuddhistChronology INSTANCE
      佛教年龄的单身人士例子。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ThaiBuddhistDate date​(int prolepticYear, int month, int dayOfMonth)
      在泰国佛教日历系统中，从幼稚年份，月份和月份月份获取当地日期。
      ThaiBuddhistDate date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份的时代，获得泰国佛教日历系统的当地日期。
      ThaiBuddhistDate date​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期。
      ThaiBuddhistDate dateEpochDay​(long epochDay)
      从泰国佛教日历系统中获取当地的日期。
      ThaiBuddhistDate dateNow​()
      从默认时区的系统时钟获取此时间顺序中的当前本地日期。
      ThaiBuddhistDate dateNow​(Clock clock)
      从指定的时钟获取本年龄的当前本地日期。
      ThaiBuddhistDate dateNow​(ZoneId zone)
      从指定时区的系统时钟获取此时间顺序中的当前本地日期。
      ThaiBuddhistDate dateYearDay​(int prolepticYear, int dayOfYear)
      在泰国佛教日历系统中，从幼稚年份和日期领域获得当地日期。
      ThaiBuddhistDate dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      在泰国佛教日历系统中，从时代，年龄和日期领域获得当地日期。
      ThaiBuddhistEra eraOf​(int eraValue)
      根据数值创建年代时代对象。
      List<Era> eras​()
      获取年表的时间列表。
      String getCalendarType​()
      获取基础日历系统的日历类型 - “佛教”。
      String getId​()
      获取年代的ID - “泰国人”。
      boolean isLeapYear​(long prolepticYear)
      检查指定年份是否是闰年。
      ChronoLocalDateTime<ThaiBuddhistDate> localDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期时间。
      int prolepticYear​(Era era, int yearOfEra)
      计算年龄和年龄的幼年时期。
      ValueRange range​(ChronoField field)
      获取指定字段的有效值的范围。
      ThaiBuddhistDate resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析时解析为 ChronoField值。
      ChronoZonedDateTime<ThaiBuddhistDate> zonedDateTime​(Instant instant, ZoneId zone)
      获得 ChronoZonedDateTime在从这个年表 Instant 。
      ChronoZonedDateTime<ThaiBuddhistDate> zonedDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取这个年龄的 ChronoZonedDateTime 。

      • Methods inherited from class java.time.chrono.AbstractChronology

        compareTo, equals, hashCode, toString

      • Methods inherited from interface java.time.chrono.Chronology

        epochSecond, epochSecond, from, getDisplayName, period

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INSTANCE

        public static final ThaiBuddhistChronology INSTANCE
        佛教年龄的单身人士例子。

    • 方法详细信息

      • getId

        public String getId​()
        获取年代的ID - “泰国人”。

        该ID唯一标识Chronology 。 它可以用于查找Chronology使用Chronology.of(String) 。

        Specified by:
        getId在接口 Chronology
        结果
        年表ID - 'ThaiBuddhist'
        另请参见：
        getCalendarType()

      • getCalendarType

        public String getCalendarType​()
        获取基础日历系统的日历类型 - “佛教”。

        日历类型是由Unicode区域设置数据标记语言（LDML）规范定义的标识符。 它可以用于查找Chronology使用Chronology.of(String) 。 它也可以作为语言环境的一部分使用，通过Locale.getUnicodeLocaleType(String)可以通过键“ca”访问。

        Specified by:
        getCalendarType在接口 Chronology
        结果
        日历系统类型 - “佛教”
        另请参见：
        getId()

      • date

        public ThaiBuddhistDate date​(Era era,
                             int yearOfEra,
                             int month,
                             int dayOfMonth)
        从时代，年龄，月份和月份的时代，获得泰国佛教日历系统的当地日期。
        Specified by:
        date在接口 Chronology
        参数
        era - 泰国佛教时代，不为空
        yearOfEra - 年代
        month - 年月
        dayOfMonth - 月份
        结果
        泰国佛教当地日期，不为空
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不是一个 ThaiBuddhistEra

      • date

        public ThaiBuddhistDate date​(int prolepticYear,
                             int month,
                             int dayOfMonth)
        在泰国佛教日历系统中，从幼稚年份，月份和月份月份获取当地日期。
        Specified by:
        date在接口 Chronology
        参数
        prolepticYear - prolepticYear年
        month - 年月
        dayOfMonth - 月的日子
        结果
        泰国佛教当地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateYearDay

        public ThaiBuddhistDate dateYearDay​(Era era,
                                    int yearOfEra,
                                    int dayOfYear)
        在泰国佛教日历系统中，从时代，年龄和日期领域获得当地日期。
        Specified by:
        dateYearDay在接口 Chronology
        参数
        era - 泰国佛教时代，不为空
        yearOfEra - 年代
        dayOfYear - 一年的一天
        结果
        泰国佛教当地日期，不为空
        异常
        DateTimeException - 如果无法创建日期
        ClassCastException - 如果 era不是一个 ThaiBuddhistEra

      • dateYearDay

        public ThaiBuddhistDate dateYearDay​(int prolepticYear,
                                    int dayOfYear)
        在泰国佛教日历系统中，从幼稚年份和日期领域获得当地日期。
        Specified by:
        dateYearDay在接口 Chronology
        参数
        prolepticYear - prolepticYear年
        dayOfYear - 一年的一天
        结果
        泰国佛教当地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateEpochDay

        public ThaiBuddhistDate dateEpochDay​(long epochDay)
        从泰国佛教日历系统中获取当地的日期。
        Specified by:
        dateEpochDay在接口 Chronology
        参数
        epochDay - 纪元日
        结果
        泰国佛教当地日期，不为空
        异常
        DateTimeException - 如果无法创建日期

      • dateNow

        public ThaiBuddhistDate dateNow​()
        描述从接口Chronology复制
        从默认时区的系统时钟获取此时间顺序中的当前本地日期。

        这将在默认时区查询system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow在接口 Chronology
        结果
        当前本地日期使用系统时钟和默认时区，不为空

      • dateNow

        public ThaiBuddhistDate dateNow​(ZoneId zone)
        描述从接口Chronology复制
        从指定时区的系统时钟获取此时间顺序中的当前本地日期。

        这将查询system clock获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        Specified by:
        dateNow在接口 Chronology
        参数
        zone - 要使用的区域ID，不为空
        结果
        当前本地日期使用系统时钟，不为null

      • dateNow

        public ThaiBuddhistDate dateNow​(Clock clock)
        说明从接口Chronology复制
        从指定的时钟获取本年龄的当前本地日期。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 备用时钟可能使用dependency injection引入。

        Specified by:
        dateNow在接口 Chronology
        参数
        clock - 要使用的时钟，不为空
        结果
        当前本地日期，不为null

      • date

        public ThaiBuddhistDate date​(TemporalAccessor temporal)
        描述从界面Chronology复制
        从另一个时间对象获取本年龄的本地日期。

        这在这个时间表中基于指定的时间获得日期。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为ChronoLocalDate一个实例。

        转换通常使用EPOCH_DAY字段，这是跨日历系统标准化的。

        该方法匹配功能界面TemporalQuery的签名，允许它通过方法参考aChronology::date用作查询。

        Specified by:
        date在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        这个年代的本地日期，不为空
        另请参见：
        ChronoLocalDate.from(TemporalAccessor)

      • localDateTime

        public ChronoLocalDateTime<ThaiBuddhistDate> localDateTime​(TemporalAccessor temporal)
        说明从接口Chronology复制
        从另一个时间对象获取本年龄的本地日期时间。

        这在这个时间表中基于指定的时间获得日期时间。 A TemporalAccessor表示一个任意的日期和时间信息集，该工厂转换为ChronoLocalDateTime一个实例。

        转换提取并从时间对象中组合了ChronoLocalDate和LocalTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能界面TemporalQuery的签名，允许其通过方法参考aChronology::localDateTime用作查询。

        Specified by:
        localDateTime在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        在这个年代的本地日期时间，不为空
        另请参见：
        ChronoLocalDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ChronoZonedDateTime<ThaiBuddhistDate> zonedDateTime​(TemporalAccessor temporal)
        说明从接口Chronology复制
        从另一个时间对象获得这个年龄的ChronoZonedDateTime 。

        根据指定的时间，在这个年表中获得一个分区的日期时间。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂将转换为ChronoZonedDateTime的实例。

        转换将首先从时间对象获取一个ZoneId ，如有必要，可以回复到ZoneOffset 。 然后会尝试获得一个Instant ，如果需要的话可以回复到ChronoLocalDateTime 。 结果将是ZoneId或ZoneOffset与Instant或ChronoLocalDateTime 。 允许实现执行优化，例如访问与相关对象相当的那些字段。 结果使用这个年表。

        该方法匹配功能界面TemporalQuery的签名，允许其通过方法参考aChronology::zonedDateTime用作查询。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        temporal - 要转换的时间对象，不为null
        结果
        在这个年代的分区日期 - 时间，不为空
        另请参见：
        ChronoZonedDateTime.from(TemporalAccessor)

      • zonedDateTime

        public ChronoZonedDateTime<ThaiBuddhistDate> zonedDateTime​(Instant instant,
                                                           ZoneId zone)
        说明从界面Chronology复制
        获得ChronoZonedDateTime在从这个年表Instant 。

        这将获得与指定的相同时间的分区日期时间。

        Specified by:
        zonedDateTime在接口 Chronology
        参数
        instant - 即时创建日期时间，不为null
        zone - 时区，不为空
        结果
        划分的日期时间，不为空

      • isLeapYear

        public boolean isLeapYear​(long prolepticYear)
        检查指定年份是否是闰年。

        泰国佛教闰年恰好符合ISO闰年。 该方法不能验证所传递的年份，并且在支持的范围内只有明确的结果多年。

        Specified by:
        isLeapYear在接口 Chronology
        参数
        prolepticYear - 检查年份，无法验证范围
        结果
        如果这一年是闰年，那么真的

      • prolepticYear

        public int prolepticYear​(Era era,
                         int yearOfEra)
        说明从接口Chronology复制
        计算年龄和年龄的幼年时期。

        这将时代与时代融为一体的年轻一代。

        如果年表积极使用时代，如JapaneseChronology那么年代将在时代得到验证。 对于其他年表，验证是可选的。

        Specified by:
        prolepticYear在接口 Chronology
        参数
        era - 正确类型为时代的时代，不为零
        yearOfEra - 年代的年代
        结果
        幼稚的一年

      • eraOf

        public ThaiBuddhistEra eraOf​(int eraValue)
        描述从接口Chronology复制
        根据数值创建年代时代对象。

        时代在概念上是时间线上最大的一个部门。 大多数日历系统具有将时间线划分为两个时代的单个时期。 然而，有些有多个时代，比如每个领导人统治的时代。 确切的含义由年龄根据以下约束决定。

        1970-01-01使用的时代必须具有值1.后来的时代必须具有较高的值。 较早的时间必须具有较低的值。 每个年表必须参考枚举或类似的单身，以提供时代价值观。

        该方法返回指定时代值的正确类型的单例时代。

        Specified by:
        eraOf在接口 Chronology
        参数
        eraValue - 时代价值
        结果
        日历系统时代，不为空

      • eras

        public List<Era> eras​()
        说明从界面： Chronology复制
        获取年表的时间列表。

        大多数日历系统都有一个时代，其中一年有意义。 如果日历系统不支持时间的概念，则必须返回空列表。

        Specified by:
        eras在接口 Chronology
        结果
        时间表的时代列表可能是不可变的，不为零

      • range

        public ValueRange range​(ChronoField field)
        描述从接口Chronology复制
        获取指定字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        无论年表是否支持该字段，此方法将返回结果。

        Specified by:
        range在接口 Chronology
        参数
        field - 获取范围的字段，不为空
        结果
        字段的有效值的范围不为null

      • resolveDate

        public ThaiBuddhistDate resolveDate​(Map<TemporalField,Long> fieldValues,
                                    ResolverStyle resolverStyle)
        描述从类别复制： AbstractChronology
        解析解析中的ChronoField值。

        大多数TemporalField实现使用该字段上的resolve方法进行解析。 相比之下， ChronoField类定义的字段只能具有相对于年表的意义。 因此， ChronoField日期字段在具体年表的上下文中解决。

        ChronoField实例通过此方法解决，可能会在子类中被覆盖。

        • EPOCH_DAY - 如果存在，将转换为日期，然后根据日期对所有其他日期字段进行交叉检查。
        • PROLEPTIC_MONTH - 如果存在，则分为YEAR和MONTH_OF_YEAR 。 如果模式是严格的或智能的，则该字段被验证。
        • YEAR_OF_ERA和ERA - 如果两者都存在，则它们被组合以形成YEAR 。 在宽松的模式下， YEAR_OF_ERA范围是无法验证的，在智能和严格的模式下。 在所有三种模式下， ERA的范围都被验证。 如果只有YEAR_OF_ERA存在，并且模式是聪明或宽松的，那么假设最后一个可用的时代。 在严格的模式下，假设没有时代，而YEAR_OF_ERA没有被触动。 如果只有ERA存在，则保持不变。
        • YEAR ， MONTH_OF_YEAR和DAY_OF_MONTH -如果所有三个都存在，那么它们被组合成一个日期。 在所有三种模式下， YEAR都经过验证。 如果模式是聪明或严格的，则验证月和日。 如果模式宽松，则以相当于在请求年份的第一个月的第一天创建日期的方式组合日期，然后将月份中的差额加上差异天数。 如果模式是聪明的，并且月的日期大于年月的最大值，则月的日期被调整到最后一个月。 如果模式严格，则三个字段必须形成有效的日期。
        • YEAR和DAY_OF_YEAR - 如果两者都存在，则它们被组合以形成日期。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期将以相当于在请求年的第一天创建日期的方式组合，然后加上差异。 如果模式是聪明或严格的，那么这两个字段必须形成一个有效的日期。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和ALIGNED_DAY_OF_WEEK_IN_MONTH -如果所有四个都存在，则它们被组合以形成一个日期。 在所有三种模式下，验证YEAR 。 如果该模式宽松，那么日期将以相当于在所请求的年份的第一个月的第一天创建日期的方式组合，然后加上月差，然后以周为单位，然后以天为单位。 如果模式是聪明或严格的，那么所有四个字段都将被验证到其外部范围。 然后将该日期以相当于在所请求的年和月的第一天创建日期的方式组合，然后以数周和数天的数量添加以达到其值。 如果模式严格，则还会验证日期，以检查日和周的调整次数是否不变。
        • YEAR ， MONTH_OF_YEAR ， ALIGNED_WEEK_OF_MONTH和DAY_OF_WEEK -如果所有四个都存在，则它们被组合以形成一个日期。 这种方法与ALIGNED_DAY_OF_WEEK_IN_MONTH数年，数月ALIGNED_DAY_OF_WEEK_IN_MONTH周ALIGNED_DAY_OF_WEEK_IN_MONTH 。 一天一个月，几周和几周已被处理，星期几被调整为下一个或相同的匹配日。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和ALIGNED_DAY_OF_WEEK_IN_YEAR -如果所有三个都存在，那么它们被组合成一个日期。 在所有三种模式下， YEAR都经过验证。 如果模式宽松，那么日期以相当于在所请求年的第一天创建日期的方式组合，然后以周为单位加上差异。 如果模式是聪明或严格的，那么所有三个字段都将被验证到其外部范围。 然后，该日期以相当于在所请求年的第一天创建日期的方式组合，然后以数周和数天添加以达到其值。 如果模式严格，日期也会被验证，以检查日和周的调整没有改变年份。
        • YEAR ， ALIGNED_WEEK_OF_YEAR和DAY_OF_WEEK -如果所有三个都存在，那么它们被组合成一个日期。 该方法与ALIGNED_DAY_OF_WEEK_IN_YEAR数年ALIGNED_DAY_OF_WEEK_IN_YEAR周ALIGNED_DAY_OF_WEEK_IN_YEAR 。 一天一周的时间一周调整为下一个或相同的匹配日期，一年的时间和周数被处理。

        默认实现适用于大多数日历系统。 如果ChronoField.YEAR_OF_ERA是没有发现ChronoField.ERA然后在最后的时代Chronology.eras()使用。 实施假定为7天，第一个月的日期为1，第一天的值为1，并且月份和年份的第一个始终存在。

        Specified by:
        resolveDate在接口 Chronology
        重写：
        resolveDate在 AbstractChronology
        参数
        fieldValues - 可以更新的值的字段映射，不为null
        resolverStyle - 请求的解析类型，不为空
        结果
        the resolved date, null if insufficient information to create a date
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ThaiBuddhistDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.chrono

Class ThaiBuddhistDate

  • java.lang.Object
    • java.time.chrono.ThaiBuddhistDate
  • All Implemented Interfaces:
    Serializable ， Comparable<ChronoLocalDate> ， ChronoLocalDate ， Temporal ， TemporalAccessor ， TemporalAdjuster

    public final class ThaiBuddhistDate
extends Object
implements ChronoLocalDate, Serializable
    在泰国佛教日历系统的日期。

    此日期使用Thai Buddhist calendar操作 。 这个日历系统主要用于泰国。 日期对齐，使得2484-01-01 (Buddhist)为1941-01-01 (ISO) 。

    这是一个value-based课; 在ThaiBuddhistDate实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预知的结果，应该避免。 equals方法应用于比较。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ChronoLocalDateTime<ThaiBuddhistDate> atTime​(LocalTime localTime)
      结合此日期与时间创建一个 ChronoLocalDateTime 。
      boolean equals​(Object obj)
      将此日期与其他日期进行比较，包括年表。
      static ThaiBuddhistDate from​(TemporalAccessor temporal)
      从时间对象获取一个 ThaiBuddhistDate 。
      ThaiBuddhistChronology getChronology​()
      获得这个日期的年表，这是泰国佛教日历系统。
      ThaiBuddhistEra getEra​()
      获得这个时代适用的时代。
      long getLong​(TemporalField field)
      获取指定字段的 long 。
      int hashCode​()
      这个日期的哈希码。
      int lengthOfMonth​()
      返回由此日期表示的月份的长度。
      ThaiBuddhistDate minus​(long amountToAdd, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      ThaiBuddhistDate minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      static ThaiBuddhistDate now​()
      从默认时区的系统时钟获取当前的 ThaiBuddhistDate 。
      static ThaiBuddhistDate now​(Clock clock)
      从指定的时钟获取当前的 ThaiBuddhistDate 。
      static ThaiBuddhistDate now​(ZoneId zone)
      从指定时区的系统时钟获取当前的 ThaiBuddhistDate 。
      static ThaiBuddhistDate of​(int prolepticYear, int month, int dayOfMonth)
      获得 ThaiBuddhistDate表示泰国佛教日历系统中的日期，月份和月份月份的日期。
      ThaiBuddhistDate plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      ThaiBuddhistDate plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。
      long toEpochDay​()
      将此日期转换为大纪元日。
      String toString​()
      返回对象的字符串表示形式。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。
      ChronoPeriod until​(ChronoLocalDate endDate)
      计算此日期和另一个日期之间的期间为 ChronoPeriod 。
      ThaiBuddhistDate with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      ThaiBuddhistDate with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。

      • Methods inherited from interface java.time.chrono.ChronoLocalDate

        adjustInto, compareTo, format, isAfter, isBefore, isEqual, isLeapYear, isSupported, isSupported, lengthOfYear, query, timeLineOrder, toString, until

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.time.temporal.TemporalAccessor

        get

    • 方法详细信息

      • now

        public static ThaiBuddhistDate now​()
        从默认时区的系统时钟获取当前的ThaiBuddhistDate 。

        这将在默认时区查询system clock以获取当前日期。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        结果
        当前日期使用系统时钟和默认时区，不为空

      • now

        public static ThaiBuddhistDate now​(ZoneId zone)
        从指定时区的系统时钟获取当前的ThaiBuddhistDate 。

        这将查询system clock以获取当前日期。 指定时区可以避免对默认时区的依赖。

        使用此方法将阻止使用备用时钟进行测试，因为时钟是硬编码的。

        参数
        zone - 要使用的区域ID，不为空
        结果
        当前日期使用系统时钟，不为空

      • now

        public static ThaiBuddhistDate now​(Clock clock)
        从指定的时钟获取当前的ThaiBuddhistDate 。

        这将查询指定的时钟以获取当前日期 - 今天。 使用此方法可以使用备用时钟进行测试。 替代时钟可以使用dependency injection引入。

        参数
        clock - 要使用的时钟，不为空
        结果
        当前日期，不为null
        异常
        DateTimeException - 如果当前日期无法获得

      • of

        public static ThaiBuddhistDate of​(int prolepticYear,
                                  int month,
                                  int dayOfMonth)
        获取ThaiBuddhistDate代表泰国佛教日历系统中的日期，月份和月份月份的日期。

        这将返回一个ThaiBuddhistDate与指定的字段。 该日期必须在年和月中有效，否则将抛出异常。

        参数
        prolepticYear - 泰国佛教 prolepticYear年
        month - 泰国佛教月份，从1到12
        dayOfMonth - 泰国佛教日月，从1到31
        结果
        泰国佛教日历系统的日期，不为空
        异常
        DateTimeException - 如果任何字段的值超出范围，或者月中的日期对于月份无效

      • from

        public static ThaiBuddhistDate from​(TemporalAccessor temporal)
        从时间对象获取ThaiBuddhistDate 。

        这在泰国佛教日历系统中基于指定的时间获取日期。 A TemporalAccessor表示日期和时间信息的任意集合，该工厂转换为ThaiBuddhistDate的实例。

        转换通常使用EPOCH_DAY字段，这是跨日历系统标准化的。

        该方法匹配功能界面TemporalQuery的签名，允许其通过方法参考ThaiBuddhistDate::from用作查询。

        参数
        temporal - 要转换的时间对象，不为null
        结果
        泰国佛教日历系统的日期，不为空
        异常
        DateTimeException - 如果无法转换为 ThaiBuddhistDate
        另请参见：
        Chronology.date(TemporalAccessor)

      • getChronology

        public ThaiBuddhistChronology getChronology​()
        获得这个日期的年表，这是泰国佛教日历系统。

        Chronology表示正在使用的日历系统。 时代和其他领域在ChronoField由时间顺序定义。

        Specified by:
        getChronology在接口 ChronoLocalDate
        结果
        泰国佛教年表，不为零

      • getEra

        public ThaiBuddhistEra getEra​()
        获得这个时代适用的时代。

        泰国佛教日历系统有两个时代：“BE”和“BEFORE_BE”，由ThaiBuddhistEra定义。

        Specified by:
        getEra在接口 ChronoLocalDate
        结果
        在此日期适用的时代不为零

      • lengthOfMonth

        public int lengthOfMonth​()
        返回由此日期表示的月份的长度。

        这将以天为单位返回月份的长度。 月份长度与ISO日历系统相匹配。

        Specified by:
        lengthOfMonth在接口 ChronoLocalDate
        结果
        月的长度以天为单位

      • range

        public ValueRange range​(TemporalField field)
        说明从界面TemporalAccessor复制
        获取指定字段的有效值的范围。

        所有字段都可以表示为long整数。 此方法返回描述该值的有效范围的对象。 该时间对象的值用于提高返回范围的精度。 如果日期时间无法返回范围，因为该字段不受支持或由于其他原因，将抛出异常。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        Specified by:
        range在接口 TemporalAccessor
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null

      • getLong

        public long getLong​(TemporalField field)
        描述从接口TemporalAccessor复制
        获取指定字段的值作为long 。

        这将查询指定字段的值的日期时间。 返回的值可能在该字段的值的有效范围之外。 如果日期时间不能返回值，因为该字段不受支持或由于其他原因，将抛出异常。

        Specified by:
        getLong在接口 TemporalAccessor
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值

      • with

        public ThaiBuddhistDate with​(TemporalField field,
                             long newValue)
        描述从界面ChronoLocalDate复制
        返回与该对象具有相同类型的对象，并更改指定的字段。

        这将返回一个基于该对象的新对象，其中指定字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        与指定字段集相同类型的对象，不为null

      • with

        public ThaiBuddhistDate with​(TemporalAdjuster adjuster)
        通过进行调整，返回与该对象相同类型的调整对象。

        这将根据指定的调整器的规则调整此日期时间。 一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 在TemporalAdjusters中提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.with(Month.JULY);        // most key classes implement TemporalAdjuster
  date = date.with(lastDayOfMonth());  // static import from Adjusters
  date = date.with(next(WEDNESDAY));   // static import from Adjusters and DayOfWeek
        Specified by:
        with在接口 ChronoLocalDate
        Specified by:
        with在接口 Temporal
        参数
        adjuster - 调整器使用，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出

      • plus

        public ThaiBuddhistDate plus​(TemporalAmount amount)
        返回与此对象相同类型的对象，并添加一个金额。

        这调整这个时间，根据指定量的规则添加。 金额通常为Period，但可能是实现TemporalAmount接口的任何其他类型，例如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.plus(period);                // add a Period instance
  date = date.plus(duration);              // add a Duration instance
  date = date.plus(workingDays(6));        // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amount - 要添加的金额，不为null
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • minus

        public ThaiBuddhistDate minus​(TemporalAmount amount)
        返回与该对象相同类型的对象，并减去一个数量。

        这调整这个时间，根据指定量的规则减去。 金额通常为Period，但可能是实现TemporalAmount接口的任何其他类型，如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.minus(period);               // subtract a Period instance
  date = date.minus(duration);             // subtract a Duration instance
  date = date.minus(workingDays(6));       // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amount - 减去量，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • plus

        public ThaiBuddhistDate plus​(long amountToAdd,
                             TemporalUnit unit)
        描述从接口ChronoLocalDate复制
        返回与此对象相同类型的对象，并添加指定的句点。

        此方法基于添加了指定句点的新对象。 例如，在LocalDate ，这可以用来添加几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则添加一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        plus在接口 ChronoLocalDate
        Specified by:
        plus在接口 Temporal
        参数
        amountToAdd - 要添加的指定单位的数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        与指定期间相同类型的对象添加，不为空

      • minus

        public ThaiBuddhistDate minus​(long amountToAdd,
                              TemporalUnit unit)
        说明从界面ChronoLocalDate复制
        返回与该对象相同类型的对象，并减去指定的时间段。

        该方法返回一个基于该对象的新对象，减去指定的时间段。 例如，在LocalDate ，这可以用来减去几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表3月31日的日期，则减去一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        Specified by:
        minus在接口 ChronoLocalDate
        Specified by:
        minus在接口 Temporal
        参数
        amountToAdd - 减去指定单位的金额，可能为负数
        unit - 减去量的单位，不为空
        结果
        与指定周期相同类型的对象减去，不为空

      • atTime

        public final ChronoLocalDateTime<ThaiBuddhistDate> atTime​(LocalTime localTime)
        说明从接口ChronoLocalDate复制
        结合此日期与时间创建一个ChronoLocalDateTime 。

        这将在指定的时间从此日期返回一个ChronoLocalDateTime 。 日期和时间的所有可能的组合都是有效的。

        Specified by:
        atTime在接口 ChronoLocalDate
        参数
        localTime - 当地使用时间，不为空
        结果
        从该日期到指定时间形成的本地日期时间，不为空

      • until

        public ChronoPeriod until​(ChronoLocalDate endDate)
        说明从界面ChronoLocalDate复制
        将此日期与另一个日期之间的期间计算为ChronoPeriod 。

        这计算两个日期之间的期间。 所有提供的年表使用年，月和日计算周期，但是ChronoPeriod API允许使用其他单位来表示期间。

        起点和终点是this和指定的日期。 如果结束在开始之前，结果将为负数。 每年，每月的负号将相同。

        计算使用此日期的年表进行。 如有必要，输入日期将被转换为匹配。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 ChronoLocalDate
        参数
        endDate - 结束日期，排他，可能在任何年代，不为空
        结果
        此日期与结束日期之间的期间不为空

      • toEpochDay

        public long toEpochDay​()
        说明从接口ChronoLocalDate复制
        将此日期转换为大纪元日。

        Epoch Day count是第0天为1970-01-01（ISO）的简单递增计数。 这个定义对于所有的年表都是一样的，可以进行转换。

        此默认实现查询EPOCH_DAY字段。

        Specified by:
        toEpochDay在接口 ChronoLocalDate
        结果
        大纪元日等于这个日期

      • equals

        public boolean equals​(Object obj)
        将此日期与其他日期进行比较，包括年表。

        将此ThaiBuddhistDate与另一个确认日期相同。

        只有ThaiBuddhistDate类型的ThaiBuddhistDate被比较，其他类型返回false。 要比较两个TemporalAccessor实例的日期，包括两个不同年表中的日期，请使用ChronoField.EPOCH_DAY作为比较。

        Specified by:
        equals在接口 ChronoLocalDate
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个日期的哈希码。
        Specified by:
        hashCode在接口 ChronoLocalDate
        结果
        仅基于时间表和日期的合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • until

        public long until​(Temporal endExclusive,
                  TemporalUnit unit)
        描述从接口ChronoLocalDate复制
        根据指定的单位计算直到另一个日期的时间量。

        这个计算两个之间的时间量ChronoLocalDate在单一方面对象TemporalUnit 。 起点和终点为this和指定日期。 如果结束在开始之前，结果将为负数。 所述Temporal传递给此方法被转换为ChronoLocalDate使用Chronology.date(TemporalAccessor) 。 计算返回一个整数，表示两个日期之间的完整单位数。 例如，可以使用startDate.until(endDate, DAYS)计算两个日期之间的天startDate.until(endDate, DAYS) 。

        使用这种方法有两种等效的方法。 第一个是调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   amount = start.until(end, MONTHS);
   amount = MONTHS.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        该方法的计算用于ChronoUnit 。 单位DAYS ， WEEKS ， MONTHS ， YEARS ， DECADES ， CENTURIES ， MILLENNIA和ERAS应该由所有的实现支持。 其他ChronoUnit值会抛出异常。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        此实例是不可变的，不受此方法调用的影响。

        Specified by:
        until在接口 ChronoLocalDate
        Specified by:
        until在接口 Temporal
        参数
        endExclusive - 结束日期，排他，在同一年代转换为 ChronoLocalDate ，不为空
        unit - 衡量金额的单位，不为空
        结果
        此日期与结束日期之间的时间

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        Specified by:
        toString在接口 ChronoLocalDate
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ThaiBuddhistEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.chrono

Enum ThaiBuddhistEra

  • java.lang.Object
    • java.lang.Enum<ThaiBuddhistEra>
      • java.time.chrono.ThaiBuddhistEra
  • All Implemented Interfaces:
    Serializable ， Comparable<ThaiBuddhistEra> ， Era ， TemporalAccessor ， TemporalAdjuster

    public enum ThaiBuddhistEra
extends Enum<ThaiBuddhistEra>
implements Era
    泰国佛教日历系统的时代。

    泰国佛教日历系统有两个时代。 当今时代，从1年起，被称为“佛教”时期。 所有前几年，在零食或更早的时候，在这个时代的数字，一年或更长的时间，是“前佛教时代”的一部分。

    Buddhist years and eras year-of-era era proleptic-year ISO proleptic-year 2 BE 2 -542 1 BE 1 -543 1 BEFORE_BE 0 -544 2 BEFORE_BE -1 -545

    不要使用ordinal()获得的数字表示ThaiBuddhistEra 。 改用getValue() 。

    实现要求：
    这是一个不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BE
      当代时代的单身实例“佛教时代”，其数值为1。
      BEFORE_BE
      在当前时代之前的“以前的佛教时代”，其数值为0的单例实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getValue​()
      获得数字时代 int价值。
      static ThaiBuddhistEra of​(int thaiBuddhistEra)
      从 int获取 ThaiBuddhistEra的实例。
      static ThaiBuddhistEra valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ThaiBuddhistEra[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from interface java.time.chrono.Era

        adjustInto, get, getDisplayName, getLong, isSupported, query, range

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BEFORE_BE

        public static final ThaiBuddhistEra BEFORE_BE
        在当前时代之前的“以前的佛教时代”，其数值为0的单例实例。

      • BE

        public static final ThaiBuddhistEra BE
        当代时代的单身实例“佛教时代”，其数值为1。

    • 方法详细信息

      • values

        public static ThaiBuddhistEra[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ThaiBuddhistEra c : ThaiBuddhistEra.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ThaiBuddhistEra valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • of

        public static ThaiBuddhistEra of​(int thaiBuddhistEra)
        从int获取ThaiBuddhistEra的实例。

        ThaiBuddhistEra是代表BEFORE_BE / BE的泰国佛教时代的枚举。 该工厂允许从int获得枚举。

        参数
        thaiBuddhistEra - 代表时代，从0到1
        结果
        佛教徒单身人士，从不为空
        异常
        DateTimeException - 如果时代无效

      • getValue

        public int getValue​()
        获得数字时代int价值。

        时代BEFORE_BE的值为0，而时代BE的值为1。

        Specified by:
        getValue在接口 Era
        结果
        时代价值从0（BEFORE_BE）到1（BE）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Uses of Package java.time.chrono (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.time.chrono

  • Packages that use java.time.chrono
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
  • Classes in java.time.chrono used by java.time
    Class 描述
    ChronoLocalDate
    一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。
    ChronoLocalDateTime
    在任意年代没有时区的日期时间，用于高级全球化用例。
    ChronoPeriod
    基于日期的时间，例如任意年代的“3年，4个月和5天”，旨在用于高级全球化用例。
    ChronoZonedDateTime
    具有时间序列的日期时间，以任意时间顺序排列，用于高级全球化用例。
    IsoChronology
    ISO日历系统。
    IsoEra
    ISO日历系统中的一个时代。
  • Classes in java.time.chrono used by java.time.chrono
    Class 描述
    AbstractChronology
    用于组织和识别日期的日历系统的抽象实现。
    ChronoLocalDate
    一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。
    ChronoLocalDateTime
    在任意年代没有时区的日期时间，用于高级全球化用例。
    Chronology
    用于组织和识别日期的日历系统。
    ChronoPeriod
    基于日期的时间，例如任意年代的“3年，4个月和5天”，旨在用于高级全球化用例。
    ChronoZonedDateTime
    具有时间序列的日期时间，以任意时间顺序排列，用于高级全球化用例。
    Era
    时代的时代。
    HijrahChronology
    Hijrah日历是支持伊斯兰教日历的农历。
    HijrahDate
    日期在Hijrah日历系统。
    HijrahEra
    Hijrah日历系统中的一个时代。
    IsoChronology
    ISO日历系统。
    IsoEra
    ISO日历系统中的一个时代。
    JapaneseChronology
    日本帝国历法系统。
    JapaneseDate
    在日本帝国日历系统的日期。
    JapaneseEra
    日本帝国日历系统的一个时代。
    MinguoChronology
    国际日历系统。
    MinguoDate
    在日语系统中的日期。
    MinguoEra
    国际日历系统中的一个时代。
    ThaiBuddhistChronology
    泰国佛教日历系统。
    ThaiBuddhistDate
    在泰国佛教日历系统的日期。
    ThaiBuddhistEra
    泰国佛教日历系统的时代。
  • Classes in java.time.chrono used by java.time.format
    Class 描述
    ChronoLocalDate
    一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。
    Chronology
    用于组织和识别日期的日历系统。
  • Classes in java.time.chrono used by java.time.temporal
    Class 描述
    Chronology
    用于组织和识别日期的日历系统。
  • Classes in java.time.chrono used by javafx.scene.control
    Class 描述
    Chronology
    用于组织和识别日期的日历系统。
  • Classes in java.time.chrono used by javafx.util.converter
    Class 描述
    Chronology
    用于组织和识别日期的日历系统。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.AbstractChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.AbstractChronology

  • Packages that use AbstractChronology
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of AbstractChronology in java.time.chrono

      Subclasses of AbstractChronology in java.time.chrono
      Modifier and Type Class 描述
      class  HijrahChronology
      Hijrah日历是支持伊斯兰教日历的农历。
      class  IsoChronology
      ISO日历系统。
      class  JapaneseChronology
      日本帝国历法系统。
      class  MinguoChronology
      国际日历系统。
      class  ThaiBuddhistChronology
      泰国佛教日历系统。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.HijrahChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.HijrahChronology

  • Packages that use HijrahChronology
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of HijrahChronology in java.time.chrono

      Fields in java.time.chrono declared as HijrahChronology
      Modifier and Type Field 描述
      static HijrahChronology HijrahChronology.INSTANCE
      沙特阿拉伯伊斯兰教Umm Al-Qura日历的单身人士例子。
      Methods in java.time.chrono that return HijrahChronology
      Modifier and Type 方法 描述
      HijrahChronology HijrahDate.getChronology​()
      获得这个日期的年表，即Hijrah日历系统。
      Methods in java.time.chrono with parameters of type HijrahChronology
      Modifier and Type 方法 描述
      HijrahDate HijrahDate.withVariant​(HijrahChronology chronology)
      HijrahDate
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.HijrahDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.HijrahDate

  • Packages that use HijrahDate
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of HijrahDate in java.time.chrono

      Methods in java.time.chrono that return HijrahDate
      Modifier and Type | 方法 | 描述
      HijrahDate HijrahChronology.date​(int prolepticYear, int month, int dayOfMonth)
      在Hijrah日历系统中，从幼稚年份，月份和月份月份获取当地日期。
      HijrahDate HijrahChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从Hijrah日历系统的时代，年龄，月份和月份月份获取当地的日期。
      HijrahDate | HijrahChronology.date​(TemporalAccessor temporal)
      HijrahDate HijrahChronology.dateEpochDay​(long epochDay)
      从Hijrah日历系统中获取当地的日期。
      HijrahDate | HijrahChronology.dateNow​()
      HijrahDate | HijrahChronology.dateNow​(Clock clock)
      HijrahDate | HijrahChronology.dateNow​(ZoneId zone)
      HijrahDate HijrahChronology.dateYearDay​(int prolepticYear, int dayOfYear)
      从日光年和日间字段获取Hijrah日历系统中的当地日期。
      HijrahDate HijrahChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从Hijrah日历系统的时代，年龄和日期领域获得当地的日期。
      static HijrahDate HijrahDate.from​(TemporalAccessor temporal)
      从时间物体获得伊斯兰教Umm Al-Qura日历的 HijrahDate 。
      HijrahDate | HijrahDate.minus​(long amountToSubtract, TemporalUnit unit)
      HijrahDate HijrahDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      static HijrahDate HijrahDate.now​()
      在默认时区内获得伊斯兰教Umm Al-Qura日历的当前 HijrahDate 。
      static HijrahDate HijrahDate.now​(Clock clock)
      从指定的时钟获取当前的伊斯兰教Umm Al-Qura日历的 HijrahDate 。
      static HijrahDate HijrahDate.now​(ZoneId zone)
      在指定的时区获得伊斯兰教Umm Al-Qura日历当前的 HijrahDate 。
      static HijrahDate HijrahDate.of​(int prolepticYear, int month, int dayOfMonth)
      从 HijrahDate年份，月份和月份月份获得伊斯兰教 HijrahDate Al-Qura日历的 HijrahDate 。
      HijrahDate | HijrahDate.plus​(long amountToAdd, TemporalUnit unit)
      HijrahDate HijrahDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      HijrahDate | HijrahChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      HijrahDate HijrahDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      HijrahDate | HijrahDate.with​(TemporalField field, long newValue)
      HijrahDate HijrahDate.withVariant​(HijrahChronology chronology)
      返回一个 HijrahDate与年表要求。
      Methods in java.time.chrono that return types with arguments of type HijrahDate
      Modifier and Type | 方法 | 描述
      ChronoLocalDateTime<HijrahDate> | HijrahDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<HijrahDate> | HijrahChronology.localDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<HijrahDate> | HijrahChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<HijrahDate> | HijrahChronology.zonedDateTime​(TemporalAccessor temporal)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.HijrahEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.HijrahEra

  • Packages that use HijrahEra
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of HijrahEra in java.time.chrono

      Methods in java.time.chrono that return HijrahEra
      Modifier and Type 方法 描述
      HijrahEra HijrahChronology.eraOf​(int eraValue)
      从数值创建HijrahEra对象。
      HijrahEra HijrahDate.getEra​()
      获得这个时代适用的时代。
      static HijrahEra HijrahEra.of​(int hijrahEra)
      从 int价值获得 HijrahEra的实例。
      static HijrahEra HijrahEra.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HijrahEra[] HijrahEra.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.IsoChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.IsoChronology

  • Packages that use IsoChronology
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of IsoChronology in java.time

      Methods in java.time that return IsoChronology
      Modifier and Type 方法 描述
      IsoChronology LocalDate.getChronology​()
      获取这个日期的时间顺序，即ISO日历系统。
      IsoChronology Period.getChronology​()
      获得这个时期的年表，即ISO日历系统。

    • Uses of IsoChronology in java.time.chrono

      Fields in java.time.chrono declared as IsoChronology
      Modifier and Type Field 描述
      static IsoChronology IsoChronology.INSTANCE
      ISO年代的单例实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.IsoEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.IsoEra

  • Packages that use IsoEra
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of IsoEra in java.time

      Methods in java.time that return IsoEra
      Modifier and Type 方法 描述
      IsoEra LocalDate.getEra​()
      获得这个时代适用的时代。

    • Uses of IsoEra in java.time.chrono

      Methods in java.time.chrono that return IsoEra
      Modifier and Type | 方法 | 描述
      IsoEra | IsoChronology.eraOf​(int eraValue)
      static IsoEra IsoEra.of​(int isoEra)
      从 int获取 IsoEra的实例。
      static IsoEra IsoEra.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static IsoEra[] IsoEra.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.JapaneseChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.JapaneseChronology

  • Packages that use JapaneseChronology
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of JapaneseChronology in java.time.chrono

      Fields in java.time.chrono declared as JapaneseChronology
      Modifier and Type Field 描述
      static JapaneseChronology JapaneseChronology.INSTANCE
      日本年代的单身人士例子。
      Methods in java.time.chrono that return JapaneseChronology
      Modifier and Type 方法 描述
      JapaneseChronology JapaneseDate.getChronology​()
      获得这个日期的年表，这是日本的日历系统。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.JapaneseDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.JapaneseDate

  • Packages that use JapaneseDate
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of JapaneseDate in java.time.chrono

      Methods in java.time.chrono that return JapaneseDate
      Modifier and Type | 方法 | 描述
      JapaneseDate JapaneseChronology.date​(int prolepticYear, int month, int dayOfMonth)
      从日光年，月 - 日和日月份获取日本日历系统的当地日期。
      JapaneseDate JapaneseChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从日期，时代，月份和月份的时代，获取日本日历系统中的当地日期。
      JapaneseDate | JapaneseChronology.date​(TemporalAccessor temporal)
      JapaneseDate JapaneseChronology.dateEpochDay​(long epochDay)
      在日历日历系统中从当天获取本地日期。
      JapaneseDate | JapaneseChronology.dateNow​()
      JapaneseDate | JapaneseChronology.dateNow​(Clock clock)
      JapaneseDate | JapaneseChronology.dateNow​(ZoneId zone)
      JapaneseDate JapaneseChronology.dateYearDay​(int prolepticYear, int dayOfYear)
      从日光年和日期字段获取日语日历系统中的当地日期。
      JapaneseDate JapaneseChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从时代，年龄和日期领域获取日本日历系统中的当地日期。
      static JapaneseDate JapaneseDate.from​(TemporalAccessor temporal)
      从时间对象获取 JapaneseDate 。
      JapaneseDate | JapaneseDate.minus​(long amountToAdd, TemporalUnit unit)
      JapaneseDate JapaneseDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      static JapaneseDate JapaneseDate.now​()
      从默认时区的系统时钟获取当前的 JapaneseDate 。
      static JapaneseDate JapaneseDate.now​(Clock clock)
      从指定的时钟获取当前的 JapaneseDate 。
      static JapaneseDate JapaneseDate.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的 JapaneseDate 。
      static JapaneseDate JapaneseDate.of​(int prolepticYear, int month, int dayOfMonth)
      从 JapaneseDate年，月份和月份字段获取 JapaneseDate表示日历日历系统中的日期。
      static JapaneseDate JapaneseDate.of​(JapaneseEra era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份字段获取日语日历系统中的日期 JapaneseDate 。
      JapaneseDate | JapaneseDate.plus​(long amountToAdd, TemporalUnit unit)
      JapaneseDate JapaneseDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      JapaneseDate | JapaneseChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      JapaneseDate JapaneseDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      JapaneseDate | JapaneseDate.with​(TemporalField field, long newValue)
      Methods in java.time.chrono that return types with arguments of type JapaneseDate
      Modifier and Type | 方法 | 描述
      ChronoLocalDateTime<JapaneseDate> | JapaneseDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<JapaneseDate> | JapaneseChronology.localDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<JapaneseDate> | JapaneseChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<JapaneseDate> | JapaneseChronology.zonedDateTime​(TemporalAccessor temporal)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.JapaneseEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.JapaneseEra

  • Packages that use JapaneseEra
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of JapaneseEra in java.time.chrono

      Fields in java.time.chrono declared as JapaneseEra
      Modifier and Type Field 描述
      static JapaneseEra JapaneseEra.HEISEI
      “平成”时代的单身例子（1989-01-08 - 现在），价值2。
      static JapaneseEra JapaneseEra.MEIJI
      “明治”时代（1868-01-01 - 1912-07-29）的单身实例，其值为-1。
      static JapaneseEra JapaneseEra.SHOWA
      “昭和”时代（1926-12-25 - 1989-01-07）的单身实例，价值1。
      static JapaneseEra JapaneseEra.TAISHO
      “大正”时代（1912-07-30 - 1926-12-24）的单身人士的例子为0。
      Methods in java.time.chrono that return JapaneseEra
      Modifier and Type 方法 描述
      JapaneseEra JapaneseChronology.eraOf​(int eraValue)
      从给定的数值返回日历系统时代对象。
      JapaneseEra JapaneseDate.getEra​()
      获得这个时代适用的时代。
      static JapaneseEra JapaneseEra.of​(int japaneseEra)
      从 int获得 JapaneseEra的实例。
      static JapaneseEra JapaneseEra.valueOf​(String japaneseEra)
      返回名称为 JapaneseEra 。
      static JapaneseEra[] JapaneseEra.values​()
      返回一个JapaneseEras数组。
      Methods in java.time.chrono with parameters of type JapaneseEra
      Modifier and Type 方法 描述
      static JapaneseDate JapaneseDate.of​(JapaneseEra era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份字段获取日语日历系统中的日期 JapaneseDate 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.MinguoChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.MinguoChronology

  • Packages that use MinguoChronology
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of MinguoChronology in java.time.chrono

      Fields in java.time.chrono declared as MinguoChronology
      Modifier and Type Field 描述
      static MinguoChronology MinguoChronology.INSTANCE
      孟国时代的单身人士实例。
      Methods in java.time.chrono that return MinguoChronology
      Modifier and Type 方法 描述
      MinguoChronology MinguoDate.getChronology​()
      获得这个日期的时间顺序，即Minguo日历系统。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.MinguoDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.MinguoDate

  • Packages that use MinguoDate
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of MinguoDate in java.time.chrono

      Methods in java.time.chrono that return MinguoDate
      Modifier and Type | 方法 | 描述
      MinguoDate MinguoChronology.date​(int prolepticYear, int month, int dayOfMonth)
      从月光年，月和月的月份中获取Minguo日历系统中的当地日期。
      MinguoDate MinguoChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份的时代，获得Minguo日历系统中的当地日期。
      MinguoDate | MinguoChronology.date​(TemporalAccessor temporal)
      MinguoDate MinguoChronology.dateEpochDay​(long epochDay)
      从时代到日本的Minguo日历系统获取本地日期。
      MinguoDate | MinguoChronology.dateNow​()
      MinguoDate | MinguoChronology.dateNow​(Clock clock)
      MinguoDate | MinguoChronology.dateNow​(ZoneId zone)
      MinguoDate MinguoChronology.dateYearDay​(int prolepticYear, int dayOfYear)
      从日光年和日期字段获取Minguo日历系统中的当地日期。
      MinguoDate MinguoChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从时代，年龄和日期领域获得Minguo日历系统中的当地日期。
      static MinguoDate MinguoDate.from​(TemporalAccessor temporal)
      从时间对象获取一个 MinguoDate 。
      MinguoDate | MinguoDate.minus​(long amountToAdd, TemporalUnit unit)
      MinguoDate MinguoDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      static MinguoDate MinguoDate.now​()
      从默认时区的系统时钟获取当前的 MinguoDate 。
      static MinguoDate MinguoDate.now​(Clock clock)
      从指定的时钟获取当前的 MinguoDate 。
      static MinguoDate MinguoDate.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的 MinguoDate 。
      static MinguoDate MinguoDate.of​(int prolepticYear, int month, int dayOfMonth)
      获取一个 MinguoDate代表了月度，月份和月份字段中 MinguoDate日历系统中的日期。
      MinguoDate | MinguoDate.plus​(long amountToAdd, TemporalUnit unit)
      MinguoDate MinguoDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      MinguoDate | MinguoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      MinguoDate MinguoDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      MinguoDate | MinguoDate.with​(TemporalField field, long newValue)
      Methods in java.time.chrono that return types with arguments of type MinguoDate
      Modifier and Type | 方法 | 描述
      ChronoLocalDateTime<MinguoDate> | MinguoDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<MinguoDate> | MinguoChronology.localDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<MinguoDate> | MinguoChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<MinguoDate> | MinguoChronology.zonedDateTime​(TemporalAccessor temporal)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.MinguoEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.MinguoEra

  • Packages that use MinguoEra
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of MinguoEra in java.time.chrono

      Methods in java.time.chrono that return MinguoEra
      Modifier and Type | 方法 | 描述
      MinguoEra | MinguoChronology.eraOf​(int eraValue)
      MinguoEra MinguoDate.getEra​()
      获得这个时代适用的时代。
      static MinguoEra MinguoEra.of​(int minguoEra)
      从 int获取 MinguoEra一个实例。
      static MinguoEra MinguoEra.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MinguoEra[] MinguoEra.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.ThaiBuddhistChronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.ThaiBuddhistChronology

  • Packages that use ThaiBuddhistChronology
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of ThaiBuddhistChronology in java.time.chrono

      Fields in java.time.chrono declared as ThaiBuddhistChronology
      Modifier and Type Field 描述
      static ThaiBuddhistChronology ThaiBuddhistChronology.INSTANCE
      佛教年龄的单身人士例子。
      Methods in java.time.chrono that return ThaiBuddhistChronology
      Modifier and Type 方法 描述
      ThaiBuddhistChronology ThaiBuddhistDate.getChronology​()
      获得这个日期的年表，这是泰国佛教日历系统。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.ThaiBuddhistDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.ThaiBuddhistDate

  • Packages that use ThaiBuddhistDate
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of ThaiBuddhistDate in java.time.chrono

      Methods in java.time.chrono that return ThaiBuddhistDate
      Modifier and Type | 方法 | 描述
      ThaiBuddhistDate ThaiBuddhistChronology.date​(int prolepticYear, int month, int dayOfMonth)
      在泰国佛教日历系统中，从幼稚年份，月份和月份月份获取当地日期。
      ThaiBuddhistDate ThaiBuddhistChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份的时代，获得泰国佛教日历系统的当地日期。
      ThaiBuddhistDate | ThaiBuddhistChronology.date​(TemporalAccessor temporal)
      ThaiBuddhistDate ThaiBuddhistChronology.dateEpochDay​(long epochDay)
      从泰国佛教日历系统中获取当地的日期。
      ThaiBuddhistDate | ThaiBuddhistChronology.dateNow​()
      ThaiBuddhistDate | ThaiBuddhistChronology.dateNow​(Clock clock)
      ThaiBuddhistDate | ThaiBuddhistChronology.dateNow​(ZoneId zone)
      ThaiBuddhistDate ThaiBuddhistChronology.dateYearDay​(int prolepticYear, int dayOfYear)
      在泰国佛教日历系统中，从幼稚年份和日期领域获得当地日期。
      ThaiBuddhistDate ThaiBuddhistChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      在泰国佛教日历系统中，从时代，年龄和日期领域获得当地日期。
      static ThaiBuddhistDate ThaiBuddhistDate.from​(TemporalAccessor temporal)
      从时间对象获取一个 ThaiBuddhistDate 。
      ThaiBuddhistDate | ThaiBuddhistDate.minus​(long amountToAdd, TemporalUnit unit)
      ThaiBuddhistDate ThaiBuddhistDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      static ThaiBuddhistDate ThaiBuddhistDate.now​()
      从默认时区的系统时钟获取当前的 ThaiBuddhistDate 。
      static ThaiBuddhistDate ThaiBuddhistDate.now​(Clock clock)
      从指定的时钟获取当前的 ThaiBuddhistDate 。
      static ThaiBuddhistDate ThaiBuddhistDate.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的 ThaiBuddhistDate 。
      static ThaiBuddhistDate ThaiBuddhistDate.of​(int prolepticYear, int month, int dayOfMonth)
      获取 ThaiBuddhistDate代表泰国佛教日历系统的日期，从 ThaiBuddhistDate ，月份和月份字段。
      ThaiBuddhistDate | ThaiBuddhistDate.plus​(long amountToAdd, TemporalUnit unit)
      ThaiBuddhistDate ThaiBuddhistDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      ThaiBuddhistDate | ThaiBuddhistChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      ThaiBuddhistDate ThaiBuddhistDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      ThaiBuddhistDate | ThaiBuddhistDate.with​(TemporalField field, long newValue)
      Methods in java.time.chrono that return types with arguments of type ThaiBuddhistDate
      Modifier and Type | 方法 | 描述
      ChronoLocalDateTime<ThaiBuddhistDate> | ThaiBuddhistDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.localDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.zonedDateTime​(TemporalAccessor temporal)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.chrono.ThaiBuddhistEra (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.chrono.ThaiBuddhistEra

  • Packages that use ThaiBuddhistEra
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of ThaiBuddhistEra in java.time.chrono

      Methods in java.time.chrono that return ThaiBuddhistEra
      Modifier and Type | 方法 | 描述
      ThaiBuddhistEra | ThaiBuddhistChronology.eraOf​(int eraValue)
      ThaiBuddhistEra ThaiBuddhistDate.getEra​()
      获得这个时代适用的时代。
      static ThaiBuddhistEra ThaiBuddhistEra.of​(int thaiBuddhistEra)
      从 int获取 ThaiBuddhistEra的实例。
      static ThaiBuddhistEra ThaiBuddhistEra.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ThaiBuddhistEra[] ThaiBuddhistEra.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.chrono.ChronoLocalDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.chrono.ChronoLocalDate

  • Packages that use ChronoLocalDate
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。

    • Uses of ChronoLocalDate in java.time

      Classes in java.time that implement ChronoLocalDate
      Modifier and Type Class 描述
      class  LocalDate
      在ISO- 2007-12-03 ，如 2007-12-03 。
      Methods in java.time with parameters of type ChronoLocalDate
      Modifier and Type 方法 描述
      int LocalDate.compareTo​(ChronoLocalDate other)
      将此日期与另一个日期进行比较。
      boolean LocalDate.isAfter​(ChronoLocalDate other)
      检查此日期是否在指定日期之后。
      boolean LocalDate.isBefore​(ChronoLocalDate other)
      检查此日期是否在指定日期之前。
      boolean LocalDate.isEqual​(ChronoLocalDate other)
      检查此日期是否等于指定的日期。
      Period LocalDate.until​(ChronoLocalDate endDateExclusive)
      将此日期和另一个日期之间的期间计算为 Period 。

    • Uses of ChronoLocalDate in java.time.chrono

      Classes in java.time.chrono with type parameters of type ChronoLocalDate
      Modifier and Type 接口 描述
      interface  ChronoLocalDateTime<D extends ChronoLocalDate>
      在任意年代没有时区的日期时间，用于高级全球化用例。
      interface  ChronoZonedDateTime<D extends ChronoLocalDate>
      具有时间序列的日期时间，以任意时间顺序排列，用于高级全球化用例。
      Classes in java.time.chrono that implement ChronoLocalDate
      Modifier and Type Class 描述
      class  HijrahDate
      日期在Hijrah日历系统。
      class  JapaneseDate
      在日本帝国日历系统的日期。
      class  MinguoDate
      在日语系统中的日期。
      class  ThaiBuddhistDate
      在泰国佛教日历系统的日期。
      Methods in java.time.chrono that return ChronoLocalDate
      Modifier and Type 方法 描述
      ChronoLocalDate Chronology.date​(int prolepticYear, int month, int dayOfMonth)
      从年龄，月份和月份月份获取本年度的年表。
      default ChronoLocalDate Chronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从这个时代，年龄，月份和月份的时代获得这个年表的当地日期。
      ChronoLocalDate Chronology.date​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期。
      ChronoLocalDate Chronology.dateEpochDay​(long epochDay)
      从这个时代的时代获得当地的日期。
      default ChronoLocalDate Chronology.dateNow​()
      从默认时区的系统时钟获取此时间顺序中的当前本地日期。
      default ChronoLocalDate Chronology.dateNow​(Clock clock)
      从指定的时钟获取本年龄的当前本地日期。
      default ChronoLocalDate Chronology.dateNow​(ZoneId zone)
      从指定时区的系统时钟获取此时间顺序中的当前本地日期。
      ChronoLocalDate Chronology.dateYearDay​(int prolepticYear, int dayOfYear)
      在这个年龄和年龄段的年龄中获得当地的日期。
      default ChronoLocalDate Chronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从这个时代，年龄和时代的年代领域获得这个年表的当地日期。
      static ChronoLocalDate ChronoLocalDate.from​(TemporalAccessor temporal)
      从时间对象获取 ChronoLocalDate的实例。
      default ChronoLocalDate ChronoLocalDate.minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default ChronoLocalDate ChronoLocalDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      default ChronoLocalDate ChronoLocalDate.plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      default ChronoLocalDate ChronoLocalDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      ChronoLocalDate AbstractChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField值。
      ChronoLocalDate Chronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField值到一个日期。
      default ChronoLocalDate ChronoLocalDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      default ChronoLocalDate ChronoLocalDate.with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      Methods in java.time.chrono that return types with arguments of type ChronoLocalDate
      Modifier and Type 方法 描述
      default ChronoLocalDateTime<? extends ChronoLocalDate> Chronology.localDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期时间。
      static Comparator<ChronoLocalDate> ChronoLocalDate.timeLineOrder​()
      获取一个比较器，比较 ChronoLocalDate的时间顺序忽略年表。
      default ChronoZonedDateTime<? extends ChronoLocalDate> Chronology.zonedDateTime​(Instant instant, ZoneId zone)
      获得 ChronoZonedDateTime在从这个年表 Instant 。
      default ChronoZonedDateTime<? extends ChronoLocalDate> Chronology.zonedDateTime​(TemporalAccessor temporal)
      从另一个时间对象获得这个年龄的 ChronoZonedDateTime 。
      Methods in java.time.chrono with parameters of type ChronoLocalDate
      Modifier and Type | 方法 | 描述
      static ChronoPeriod ChronoPeriod.between​(ChronoLocalDate startDateInclusive, ChronoLocalDate endDateExclusive)
      获得一个 ChronoPeriod包括两个日期之间的时间量。
      default int ChronoLocalDate.compareTo​(ChronoLocalDate other)
      将此日期与其他日期进行比较，包括年表。
      default boolean ChronoLocalDate.isAfter​(ChronoLocalDate other)
      检查此日期是否在忽略年表的指定日期之后。
      default boolean ChronoLocalDate.isBefore​(ChronoLocalDate other)
      检查此日期是否在忽略年表前的指定日期之前。
      default boolean ChronoLocalDate.isEqual​(ChronoLocalDate other)
      检查这个日期是否等于忽略年表的指定日期。
      ChronoPeriod ChronoLocalDate.until​(ChronoLocalDate endDateExclusive)
      计算此日期和另一个日期之间的期间为 ChronoPeriod 。
      ChronoPeriod | HijrahDate.until​(ChronoLocalDate endDate)
      ChronoPeriod | JapaneseDate.until​(ChronoLocalDate endDate)
      ChronoPeriod | MinguoDate.until​(ChronoLocalDate endDate)
      ChronoPeriod | ThaiBuddhistDate.until​(ChronoLocalDate endDate)

    • Uses of ChronoLocalDate in java.time.format

      Methods in java.time.format with parameters of type ChronoLocalDate
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValueReduced​(TemporalField field, int width, int maxWidth, ChronoLocalDate baseDate)
      将日期时间字段的减小值附加到格式化程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.chrono.ChronoLocalDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.chrono.ChronoLocalDateTime

  • Packages that use ChronoLocalDateTime
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of ChronoLocalDateTime in java.time

      Classes in java.time that implement ChronoLocalDateTime
      Modifier and Type Class 描述
      class  LocalDateTime
      在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
      Methods in java.time with parameters of type ChronoLocalDateTime
      Modifier and Type 方法 描述
      int LocalDateTime.compareTo​(ChronoLocalDateTime<?> other)
      将此日期时间与其他日期时间进行比较。
      boolean LocalDateTime.isAfter​(ChronoLocalDateTime<?> other)
      检查这个日期时间是否在指定的日期之后。
      boolean LocalDateTime.isBefore​(ChronoLocalDateTime<?> other)
      检查此日期时间是否在指定的日期时间之前。
      boolean LocalDateTime.isEqual​(ChronoLocalDateTime<?> other)
      检查此日期时间是否等于指定的日期时间。

    • Uses of ChronoLocalDateTime in java.time.chrono

      Methods in java.time.chrono that return ChronoLocalDateTime
      Modifier and Type | 方法 | 描述
      default ChronoLocalDateTime<?> ChronoLocalDate.atTime​(LocalTime localTime)
      结合这个日期与时间创建一个 ChronoLocalDateTime 。
      ChronoLocalDateTime<HijrahDate> | HijrahDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<JapaneseDate> | JapaneseDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<MinguoDate> | MinguoDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<ThaiBuddhistDate> | ThaiBuddhistDate.atTime​(LocalTime localTime)
      static ChronoLocalDateTime<?> ChronoLocalDateTime.from​(TemporalAccessor temporal)
      从时间对象获取一个 ChronoLocalDateTime的实例。
      default ChronoLocalDateTime<? extends ChronoLocalDate> Chronology.localDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期时间。
      ChronoLocalDateTime<HijrahDate> | HijrahChronology.localDateTime​(TemporalAccessor temporal)
      ChronoLocalDateTime<JapaneseDate> | JapaneseChronology.localDateTime​(TemporalAccessor temporal)
      ChronoLocalDateTime<MinguoDate> | MinguoChronology.localDateTime​(TemporalAccessor temporal)
      ChronoLocalDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.localDateTime​(TemporalAccessor temporal)
      default ChronoLocalDateTime<D> ChronoLocalDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default ChronoLocalDateTime<D> ChronoLocalDateTime.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      ChronoLocalDateTime<D> ChronoLocalDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      default ChronoLocalDateTime<D> ChronoLocalDateTime.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      ChronoLocalDateTime<D> ChronoZonedDateTime.toLocalDateTime​()
      获取此日期时间的本地日期时间部分。
      default ChronoLocalDateTime<D> ChronoLocalDateTime.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      ChronoLocalDateTime<D> ChronoLocalDateTime.with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      Methods in java.time.chrono that return types with arguments of type ChronoLocalDateTime
      Modifier and Type 方法 描述
      static Comparator<ChronoLocalDateTime<?>> ChronoLocalDateTime.timeLineOrder​()
      获取一个比较器，比较 ChronoLocalDateTime的时间顺序忽略年表。
      Methods in java.time.chrono with parameters of type ChronoLocalDateTime
      Modifier and Type 方法 描述
      default int ChronoLocalDateTime.compareTo​(ChronoLocalDateTime<?> other)
      将此日期时间与其他日期时间进行比较，包括年表。
      default boolean ChronoLocalDateTime.isAfter​(ChronoLocalDateTime<?> other)
      检查这个日期时间是否在指定的日期时间之后，忽略年表。
      default boolean ChronoLocalDateTime.isBefore​(ChronoLocalDateTime<?> other)
      检查这个日期时间是否在指定的日期时间之前忽略年表。
      default boolean ChronoLocalDateTime.isEqual​(ChronoLocalDateTime<?> other)
      检查这个日期时间是否等于指定的日期时间，忽略年表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.chrono.Chronology (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.chrono.Chronology

  • Packages that use Chronology
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of Chronology in java.time.chrono

      Classes in java.time.chrono that implement Chronology
      Modifier and Type Class 描述
      class  AbstractChronology
      用于组织和识别日期的日历系统的抽象实现。
      class  HijrahChronology
      Hijrah日历是支持伊斯兰教日历的农历。
      class  IsoChronology
      ISO日历系统。
      class  JapaneseChronology
      日本帝国历法系统。
      class  MinguoChronology
      国际日历系统。
      class  ThaiBuddhistChronology
      泰国佛教日历系统。
      Methods in java.time.chrono that return Chronology
      Modifier and Type 方法 描述
      static Chronology Chronology.from​(TemporalAccessor temporal)
      从时间对象获取一个 Chronology的实例。
      Chronology ChronoLocalDate.getChronology​()
      获得这个日期的年表。
      default Chronology ChronoLocalDateTime.getChronology​()
      获得这个日期时间的年表。
      Chronology ChronoPeriod.getChronology​()
      获取定义支持的单位意义的年表。
      default Chronology ChronoZonedDateTime.getChronology​()
      获得这个日期时间的年表。
      static Chronology Chronology.of​(String id)
      从时间序列ID或日历系统类型获取 Chronology的实例。
      static Chronology Chronology.ofLocale​(Locale locale)
      从区域设置获取 Chronology的实例。
      Methods in java.time.chrono that return types with arguments of type Chronology
      Modifier and Type 方法 描述
      static Set<Chronology> Chronology.getAvailableChronologies​()
      返回可用的年表。
      Methods in java.time.chrono with parameters of type Chronology
      Modifier and Type 方法 描述
      int AbstractChronology.compareTo​(Chronology other)
      将这个年表与另一个年表进行比较。
      int Chronology.compareTo​(Chronology other)
      将这个年表与另一个年表进行比较。

    • Uses of Chronology in java.time.format

      Methods in java.time.format that return Chronology
      Modifier and Type 方法 描述
      Chronology DateTimeFormatter.getChronology​()
      获得在格式化期间使用的压倒一记的年表。
      Methods in java.time.format with parameters of type Chronology
      Modifier and Type 方法 描述
      static String DateTimeFormatterBuilder.getLocalizedDateTimePattern​(FormatStyle dateStyle, FormatStyle timeStyle, Chronology chrono, Locale locale)
      获取区域设置和时间顺序的日期和时间样式的格式模式。
      DateTimeFormatter DateTimeFormatter.withChronology​(Chronology chrono)
      使用新的覆盖年表返回此格式化程序的副本。

    • Uses of Chronology in java.time.temporal

      Methods in java.time.temporal that return types with arguments of type Chronology
      Modifier and Type 方法 描述
      static TemporalQuery<Chronology> TemporalQueries.chronology​()
      查询 Chronology 。

    • Uses of Chronology in javafx.scene.control

      Methods in javafx.scene.control that return Chronology
      Modifier and Type 方法 描述
      Chronology DatePicker.getChronology​()
      获取物业年表的价值。
      Methods in javafx.scene.control that return types with arguments of type Chronology
      Modifier and Type 方法 描述
      ObjectProperty<Chronology> DatePicker.chronologyProperty​()
      用于在DatePicker控件中解析，显示和选择日期的日历系统。
      Methods in javafx.scene.control with parameters of type Chronology
      Modifier and Type 方法 描述
      void DatePicker.setChronology​(Chronology value)
      设置属性年表的值。

    • Uses of Chronology in javafx.util.converter

      Constructors in javafx.util.converter with parameters of type Chronology
      Constructor 描述
      LocalDateStringConverter​(FormatStyle dateStyle, Locale locale, Chronology chronology)
      创建一个字符串转换LocalDate个使用默认的格式和语法分析器，它会根据所提供的值FormatStyle ， Locale ，并Chronology 。
      LocalDateTimeStringConverter​(FormatStyle dateStyle, FormatStyle timeStyle, Locale locale, Chronology chronology)
      创建StringConverter为LocalDateTime使用默认格式化器和解析器，其将基于所提供的值FormatStyle个 S， Locale ，和Chronology 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.chrono.ChronoPeriod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.chrono.ChronoPeriod

  • Packages that use ChronoPeriod
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of ChronoPeriod in java.time

      Classes in java.time that implement ChronoPeriod
      Modifier and Type Class 描述
      class  Period
      ISO-8601日历系统中的日期时间，例如“2年3个月4天”。

    • Uses of ChronoPeriod in java.time.chrono

      Methods in java.time.chrono that return ChronoPeriod
      Modifier and Type | 方法 | 描述
      static ChronoPeriod ChronoPeriod.between​(ChronoLocalDate startDateInclusive, ChronoLocalDate endDateExclusive)
      获得一个 ChronoPeriod包括两个日期之间的时间量。
      ChronoPeriod ChronoPeriod.minus​(TemporalAmount amountToSubtract)
      返回此期间的副本，并减去指定的时间段。
      ChronoPeriod ChronoPeriod.multipliedBy​(int scalar)
      返回一个新的实例，其中在此期间的每个金额乘以指定的标量。
      default ChronoPeriod ChronoPeriod.negated​()
      返回一个新的实例，每个金额在此期间被否定。
      ChronoPeriod ChronoPeriod.normalized​()
      返回此期间的副本，并将每个单位的金额归一化。
      default ChronoPeriod Chronology.period​(int years, int months, int days)
      根据几年，几个月和几天的时间表获得一段时间。
      ChronoPeriod ChronoPeriod.plus​(TemporalAmount amountToAdd)
      返回指定期间添加的此期间的副本。
      ChronoPeriod ChronoLocalDate.until​(ChronoLocalDate endDateExclusive)
      将此日期和其他日期之间的期间计算为 ChronoPeriod 。
      ChronoPeriod | HijrahDate.until​(ChronoLocalDate endDate)
      ChronoPeriod | JapaneseDate.until​(ChronoLocalDate endDate)
      ChronoPeriod | MinguoDate.until​(ChronoLocalDate endDate)
      ChronoPeriod | ThaiBuddhistDate.until​(ChronoLocalDate endDate)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.chrono.ChronoZonedDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.chrono.ChronoZonedDateTime

  • Packages that use ChronoZonedDateTime
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of ChronoZonedDateTime in java.time

      Classes in java.time that implement ChronoZonedDateTime
      Modifier and Type Class 描述
      class  ZonedDateTime
      ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。

    • Uses of ChronoZonedDateTime in java.time.chrono

      Methods in java.time.chrono that return ChronoZonedDateTime
      Modifier and Type | 方法 | 描述
      ChronoZonedDateTime<D> ChronoLocalDateTime.atZone​(ZoneId zone)
      将这个时间与时区结合起来创建一个 ChronoZonedDateTime 。
      static ChronoZonedDateTime<?> ChronoZonedDateTime.from​(TemporalAccessor temporal)
      从时间对象获取 ChronoZonedDateTime的实例。
      default ChronoZonedDateTime<D> ChronoZonedDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default ChronoZonedDateTime<D> ChronoZonedDateTime.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      ChronoZonedDateTime<D> ChronoZonedDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      default ChronoZonedDateTime<D> ChronoZonedDateTime.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      default ChronoZonedDateTime<D> ChronoZonedDateTime.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      ChronoZonedDateTime<D> ChronoZonedDateTime.with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      ChronoZonedDateTime<D> ChronoZonedDateTime.withEarlierOffsetAtOverlap​()
      返回此日期的副本，将区域偏移更改为本地时间线重叠处的两个有效偏移量的较早者。
      ChronoZonedDateTime<D> ChronoZonedDateTime.withLaterOffsetAtOverlap​()
      返回此日期的副本，将区域偏移更改为本地时间线重叠的两个有效偏移量的后面。
      ChronoZonedDateTime<D> ChronoZonedDateTime.withZoneSameInstant​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，保留即时。
      ChronoZonedDateTime<D> ChronoZonedDateTime.withZoneSameLocal​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。
      default ChronoZonedDateTime<? extends ChronoLocalDate> Chronology.zonedDateTime​(Instant instant, ZoneId zone)
      获得 ChronoZonedDateTime在从这个年表 Instant 。
      default ChronoZonedDateTime<? extends ChronoLocalDate> Chronology.zonedDateTime​(TemporalAccessor temporal)
      从另一个时间对象获得这个年龄的 ChronoZonedDateTime 。
      ChronoZonedDateTime<HijrahDate> | HijrahChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<HijrahDate> | HijrahChronology.zonedDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<JapaneseDate> | JapaneseChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<JapaneseDate> | JapaneseChronology.zonedDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<MinguoDate> | MinguoChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<MinguoDate> | MinguoChronology.zonedDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.zonedDateTime​(TemporalAccessor temporal)
      Methods in java.time.chrono that return types with arguments of type ChronoZonedDateTime
      Modifier and Type 方法 描述
      static Comparator<ChronoZonedDateTime<?>> ChronoZonedDateTime.timeLineOrder​()
      获取一个比较器，比较 ChronoZonedDateTime的时间顺序，忽略年表。
      Methods in java.time.chrono with parameters of type ChronoZonedDateTime
      Modifier and Type 方法 描述
      default int ChronoZonedDateTime.compareTo​(ChronoZonedDateTime<?> other)
      将此日期时间与其他日期时间进行比较，包括年表。
      default boolean ChronoZonedDateTime.isAfter​(ChronoZonedDateTime<?> other)
      检查此日期时间是否在指定的日期时间之后。
      default boolean ChronoZonedDateTime.isBefore​(ChronoZonedDateTime<?> other)
      检查此日期时间是否在指定的日期时间之前。
      default boolean ChronoZonedDateTime.isEqual​(ChronoZonedDateTime<?> other)
      检查此日期时间的时间是否等于指定的日期时间。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.chrono.Era (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.chrono.Era

  • Packages that use Era
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of Era in java.time.chrono

      Classes in java.time.chrono that implement Era
      Modifier and Type Class 描述
      class  HijrahEra
      Hijrah日历系统中的一个时代。
      class  IsoEra
      ISO日历系统中的一个时代。
      class  JapaneseEra
      日本帝国日历系统的一个时代。
      class  MinguoEra
      国际日历系统中的一个时代。
      class  ThaiBuddhistEra
      泰国佛教日历系统的时代。
      Methods in java.time.chrono that return Era
      Modifier and Type 方法 描述
      Era Chronology.eraOf​(int eraValue)
      根据数值创建年代时代对象。
      default Era ChronoLocalDate.getEra​()
      获得时代，按年表定义。
      Methods in java.time.chrono that return types with arguments of type Era
      Modifier and Type | 方法 | 描述
      List<Era> Chronology.eras​()
      获取年表的时间列表。
      List<Era> | HijrahChronology.eras​()
      List<Era> | IsoChronology.eras​()
      List<Era> | JapaneseChronology.eras​()
      List<Era> | MinguoChronology.eras​()
      List<Era> | ThaiBuddhistChronology.eras​()
      Methods in java.time.chrono with parameters of type Era
      Modifier and Type | 方法 | 描述
      default ChronoLocalDate Chronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从这个时代，年龄，月份和月份的时代获得这个年表的当地日期。
      HijrahDate HijrahChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从Hijrah日历系统的时代，年龄，月份和月份月份获取当地的日期。
      LocalDate IsoChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份的时代获得ISO本地日期。
      JapaneseDate JapaneseChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从日期，时代，月份和月份的时代，获取日本日历系统中的当地日期。
      MinguoDate MinguoChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份的时代，获得Minguo日历系统中的当地日期。
      ThaiBuddhistDate ThaiBuddhistChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份的时代，获得泰国佛教日历系统的当地日期。
      default ChronoLocalDate Chronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从这个时代，年龄和时代的年代领域获得这个年表的当地日期。
      HijrahDate HijrahChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从Hijrah日历系统的时代，年龄和日期领域获得当地的日期。
      LocalDate IsoChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从时代，年龄和日期的领域获得ISO本地日期。
      JapaneseDate JapaneseChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从时代，年龄和日期领域获取日本日历系统中的当地日期。
      MinguoDate MinguoChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从时代，年龄和日期领域获得Minguo日历系统中的当地日期。
      ThaiBuddhistDate ThaiBuddhistChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      在泰国佛教日历系统中，从时代，年龄和日期领域获得当地日期。
      default long Chronology.epochSecond​(Era era, int yearOfEra, int month, int dayOfMonth, int hour, int minute, int second, ZoneOffset zoneOffset)
      从1970-01-01T00：00：00Z的时期获取秒数。
      int Chronology.prolepticYear​(Era era, int yearOfEra)
      计算年龄和年龄的幼年时期。
      int | HijrahChronology.prolepticYear​(Era era, int yearOfEra)
      int | IsoChronology.prolepticYear​(Era era, int yearOfEra)
      int | JapaneseChronology.prolepticYear​(Era era, int yearOfEra)
      int | MinguoChronology.prolepticYear​(Era era, int yearOfEra)
      int | ThaiBuddhistChronology.prolepticYear​(Era era, int yearOfEra)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.Clock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.Clock

  • Packages that use Clock
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。

    • Uses of Clock in java.time

      Methods in java.time that return Clock
      Modifier and Type 方法 描述
      static Clock Clock.fixed​(Instant fixedInstant, ZoneId zone)
      获得始终返回相同时刻的时钟。
      static Clock Clock.offset​(Clock baseClock, Duration offsetDuration)
      获取一个时钟，从指定的时钟周期返回时钟，并添加指定的时间
      static Clock Clock.system​(ZoneId zone)
      获取使用最佳可用系统时钟返回当前即时的时钟。
      static Clock Clock.systemDefaultZone​()
      获取使用最佳可用系统时钟返回当前即时的时钟，使用默认时区转换为日期和时间。
      static Clock Clock.systemUTC​()
      获取使用最佳可用系统时钟返回当前即时的时钟，使用UTC时区转换为日期和时间。
      static Clock Clock.tick​(Clock baseClock, Duration tickDuration)
      获取时钟，将时钟从指定的时钟截断返回到指定持续时间的最近出现。
      static Clock Clock.tickMillis​(ZoneId zone)
      获取时钟，使用最佳可用系统时钟返回当前瞬间滴答整数毫秒。
      static Clock Clock.tickMinutes​(ZoneId zone)
      获取时钟，使用最佳可用系统时钟在一分钟内返回当前瞬间滴答。
      static Clock Clock.tickSeconds​(ZoneId zone)
      获取时钟，使用最佳可用系统时钟在一秒钟内返回当前瞬间滴答作响。
      abstract Clock Clock.withZone​(ZoneId zone)
      以不同的时区返回此时钟的副本。
      Methods in java.time with parameters of type Clock
      Modifier and Type 方法 描述
      static Instant Instant.now​(Clock clock)
      从指定的时钟获取当前时刻。
      static LocalDate LocalDate.now​(Clock clock)
      从指定的时钟获取当前日期。
      static LocalDateTime LocalDateTime.now​(Clock clock)
      从指定的时钟获取当前的日期时间。
      static LocalTime LocalTime.now​(Clock clock)
      从指定的时钟获取当前时间。
      static MonthDay MonthDay.now​(Clock clock)
      从指定的时钟获取当前的月日。
      static OffsetDateTime OffsetDateTime.now​(Clock clock)
      从指定的时钟获取当前的日期时间。
      static OffsetTime OffsetTime.now​(Clock clock)
      从指定的时钟获取当前时间。
      static Year Year.now​(Clock clock)
      从指定时钟获取当年。
      static YearMonth YearMonth.now​(Clock clock)
      从指定的时钟获取当前的一个月。
      static ZonedDateTime ZonedDateTime.now​(Clock clock)
      从指定的时钟获取当前的日期时间。
      static Clock Clock.offset​(Clock baseClock, Duration offsetDuration)
      获取一个时钟，从指定的时钟周期返回时钟，并添加指定的时间
      static Clock Clock.tick​(Clock baseClock, Duration tickDuration)
      获取时钟，将时钟从指定的时钟截断返回到指定持续时间的最近出现。

    • Uses of Clock in java.time.chrono

      Methods in java.time.chrono with parameters of type Clock
      Modifier and Type | 方法 | 描述
      default ChronoLocalDate Chronology.dateNow​(Clock clock)
      从指定的时钟获取本年龄的当前本地日期。
      HijrahDate | HijrahChronology.dateNow​(Clock clock)
      LocalDate IsoChronology.dateNow​(Clock clock)
      从指定的时钟获取当前的ISO本地日期。
      JapaneseDate | JapaneseChronology.dateNow​(Clock clock)
      MinguoDate | MinguoChronology.dateNow​(Clock clock)
      ThaiBuddhistDate | ThaiBuddhistChronology.dateNow​(Clock clock)
      static HijrahDate HijrahDate.now​(Clock clock)
      从指定的时钟获取当前的 HijrahDate伊斯兰教Umm Al-Qura日历。
      static JapaneseDate JapaneseDate.now​(Clock clock)
      从指定的时钟获取当前的 JapaneseDate 。
      static MinguoDate MinguoDate.now​(Clock clock)
      从指定的时钟获取当前的 MinguoDate 。
      static ThaiBuddhistDate ThaiBuddhistDate.now​(Clock clock)
      从指定的时钟获取当前的 ThaiBuddhistDate 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.DateTimeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.DateTimeException

  • Packages that use DateTimeException
    软件包 描述
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。

    • Uses of DateTimeException in java.time.format

      Subclasses of DateTimeException in java.time.format
      Modifier and Type Class 描述
      class  DateTimeParseException
      解析期间发生错误时抛出异常。

    • Uses of DateTimeException in java.time.temporal

      Subclasses of DateTimeException in java.time.temporal
      Modifier and Type Class 描述
      class  UnsupportedTemporalTypeException
      UnsupportedTemporalTypeException表示Temporal类不支持ChronoField或ChronoUnit。

    • Uses of DateTimeException in java.time.zone

      Subclasses of DateTimeException in java.time.zone
      Modifier and Type Class 描述
      class  ZoneRulesException
      抛出指示时区配置的问题。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.DayOfWeek (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.DayOfWeek

  • Packages that use DayOfWeek
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。

    • Uses of DayOfWeek in java.time

      Methods in java.time that return DayOfWeek
      Modifier and Type 方法 描述
      static DayOfWeek DayOfWeek.from​(TemporalAccessor temporal)
      从时间对象获取一个 DayOfWeek的实例。
      DayOfWeek LocalDate.getDayOfWeek​()
      获取星期几字段，这是一个枚举 DayOfWeek 。
      DayOfWeek LocalDateTime.getDayOfWeek​()
      获取星期几字段，这是一个枚举 DayOfWeek 。
      DayOfWeek OffsetDateTime.getDayOfWeek​()
      获取星期几字段，这是一个枚举 DayOfWeek 。
      DayOfWeek ZonedDateTime.getDayOfWeek​()
      获取星期几字段，这是一个枚举 DayOfWeek 。
      DayOfWeek DayOfWeek.minus​(long days)
      返回指定天数之前的星期几。
      static DayOfWeek DayOfWeek.of​(int dayOfWeek)
      从 int获取 DayOfWeek的实例。
      DayOfWeek DayOfWeek.plus​(long days)
      返回这一天后指定天数的星期几。
      static DayOfWeek DayOfWeek.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DayOfWeek[] DayOfWeek.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of DayOfWeek in java.time.temporal

      Methods in java.time.temporal that return DayOfWeek
      Modifier and Type 方法 描述
      DayOfWeek WeekFields.getFirstDayOfWeek​()
      获得第一个星期。
      Methods in java.time.temporal with parameters of type DayOfWeek
      Modifier and Type 方法 描述
      static TemporalAdjuster TemporalAdjusters.dayOfWeekInMonth​(int ordinal, DayOfWeek dayOfWeek)
      返回月份调整器中的星期几，该日期将根据月份返回具有序数星期的新日期。
      static TemporalAdjuster TemporalAdjusters.firstInMonth​(DayOfWeek dayOfWeek)
      返回月初调整器，它在同一个月内返回与第一个匹配的星期几的新日期。
      static TemporalAdjuster TemporalAdjusters.lastInMonth​(DayOfWeek dayOfWeek)
      返回最近一个月的调整器，它返回与最后一个匹配的星期几相同月份的新日期。
      static TemporalAdjuster TemporalAdjusters.next​(DayOfWeek dayOfWeek)
      返回下一个星期的调整器，该调整器将日期调整为在调整日期之后的指定日期的第一次出现。
      static TemporalAdjuster TemporalAdjusters.nextOrSame​(DayOfWeek dayOfWeek)
      返回下一个或相同的星期几调整器，该调整器将日期调整为在调整日期之后指定的星期几的第一次出现，除非它已在当天在同一对象被返回。
      static WeekFields WeekFields.of​(DayOfWeek firstDayOfWeek, int minimalDaysInFirstWeek)
      从第一个星期几到最短的几天内获得 WeekFields的实例。
      static TemporalAdjuster TemporalAdjusters.previous​(DayOfWeek dayOfWeek)
      返回上一个星期的调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现。
      static TemporalAdjuster TemporalAdjusters.previousOrSame​(DayOfWeek dayOfWeek)
      返回之前或相同的日期调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现，除非已在当天返回相同的对象。

    • Uses of DayOfWeek in java.time.zone

      Methods in java.time.zone that return DayOfWeek
      Modifier and Type 方法 描述
      DayOfWeek ZoneOffsetTransitionRule.getDayOfWeek​()
      获得过渡的星期几。
      Methods in java.time.zone with parameters of type DayOfWeek
      Modifier and Type 方法 描述
      static ZoneOffsetTransitionRule ZoneOffsetTransitionRule.of​(Month month, int dayOfMonthIndicator, DayOfWeek dayOfWeek, LocalTime time, boolean timeEndOfDay, ZoneOffsetTransitionRule.TimeDefinition timeDefnition, ZoneOffset standardOffset, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义年度规则以在两个偏移之间创建转换的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.Duration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.Duration

  • Packages that use Duration
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of Duration in java.lang

      Methods in java.lang that return types with arguments of type Duration
      Modifier and Type 方法 描述
      Optional<Duration> ProcessHandle.Info.totalCpuDuration​()
      返回进程累积的总计。

    • Uses of Duration in java.time

      Fields in java.time declared as Duration
      Modifier and Type Field 描述
      static Duration Duration.ZERO
      持续时间为零的常数。
      Methods in java.time that return Duration
      Modifier and Type 方法 描述
      Duration Duration.abs​()
      以正长度返回此持续时间的副本。
      static Duration Duration.between​(Temporal startInclusive, Temporal endExclusive)
      获取表示两个时间对象之间的持续时间的 Duration 。
      Duration Duration.dividedBy​(long divisor)
      返回此持续时间的副本除以指定的值。
      static Duration Duration.from​(TemporalAmount amount)
      从时间量获取 Duration的实例。
      Duration Duration.minus​(long amountToSubtract, TemporalUnit unit)
      返回指定持续时间的副本减去。
      Duration Duration.minus​(Duration duration)
      返回指定持续时间的副本减去。
      Duration Duration.minusDays​(long daysToSubtract)
      在标准的24小时内减去指定的持续时间，返回此持续时间的副本。
      Duration Duration.minusHours​(long hoursToSubtract)
      以缩小的小时返回指定持续时间的此持续时间的副本。
      Duration Duration.minusMillis​(long millisToSubtract)
      以指定的持续时间返回此持续时间的副本，以毫秒为单位。
      Duration Duration.minusMinutes​(long minutesToSubtract)
      以指定的持续时间返回此持续时间的副本，以分钟为单位。
      Duration Duration.minusNanos​(long nanosToSubtract)
      以指定的持续时间返回此持续时间的副本，减去纳秒。
      Duration Duration.minusSeconds​(long secondsToSubtract)
      以指定的持续时间返回此持续时间的副本，以秒为单位。
      Duration Duration.multipliedBy​(long multiplicand)
      返回此持续时间的副本乘以标量。
      Duration Duration.negated​()
      返回长度为否定的此持续时间的副本。
      static Duration Duration.of​(long amount, TemporalUnit unit)
      获得 Duration表示指定单位的金额。
      static Duration Duration.ofDays​(long days)
      获得一个 Duration代表一些标准的24小时的日子。
      static Duration Duration.ofHours​(long hours)
      获得代表标准时数的 Duration 。
      static Duration Duration.ofMillis​(long millis)
      获得 Duration表示毫秒数。
      static Duration Duration.ofMinutes​(long minutes)
      获得代表标准分钟数的 Duration 。
      static Duration Duration.ofNanos​(long nanos)
      获得 Duration代表数纳秒。
      static Duration Duration.ofSeconds​(long seconds)
      获得一个 Duration代表秒数。
      static Duration Duration.ofSeconds​(long seconds, long nanoAdjustment)
      获得 Duration表示秒数和纳秒的调整。
      static Duration Duration.parse​(CharSequence text)
      获得 Duration从文本字符串，如 PnDTnHnMn.nS 。
      Duration Duration.plus​(long amountToAdd, TemporalUnit unit)
      返回此持续时间的副本，并添加指定的持续时间。
      Duration Duration.plus​(Duration duration)
      返回此持续时间的副本，并添加指定的持续时间。
      Duration Duration.plusDays​(long daysToAdd)
      在标准的24小时内添加指定的持续时间返回此持续时间的副本。
      Duration Duration.plusHours​(long hoursToAdd)
      以指定的持续时间返回此持续时间的副本，小时数。
      Duration Duration.plusMillis​(long millisToAdd)
      以指定的持续时间（以毫秒为单位）返回此持续时间的副本。
      Duration Duration.plusMinutes​(long minutesToAdd)
      以指定的持续时间（以分钟为单位）返回此持续时间的副本。
      Duration Duration.plusNanos​(long nanosToAdd)
      以指定的持续时间返回此持续时间的副本，以纳秒为单位。
      Duration Duration.plusSeconds​(long secondsToAdd)
      以指定的持续时间（以秒为单位）返回此持续时间的副本。
      Duration Duration.truncatedTo​(TemporalUnit unit)
      返回此 Duration的副本截断到指定的单位。
      Duration Duration.withNanos​(int nanoOfSecond)
      以指定的纳秒为单位返回此持续时间的副本。
      Duration Duration.withSeconds​(long seconds)
      以指定的秒数返回此持续时间的副本。
      Methods in java.time with parameters of type Duration
      Modifier and Type 方法 描述
      int Duration.compareTo​(Duration otherDuration)
      将此持续时间与指定的 Duration 。
      long Duration.dividedBy​(Duration divisor)
      在此持续时间内返回指定持续时间的整数倍数。
      Duration Duration.minus​(Duration duration)
      返回指定持续时间的副本减去。
      static Clock Clock.offset​(Clock baseClock, Duration offsetDuration)
      获取一个时钟，从指定的时钟周期返回时钟，并添加指定的时间
      Duration Duration.plus​(Duration duration)
      返回此持续时间的副本，并添加指定的持续时间。
      static Clock Clock.tick​(Clock baseClock, Duration tickDuration)
      获取时钟，将时钟从指定的时钟截断返回到指定持续时间的最近出现。

    • Uses of Duration in java.time.temporal

      Methods in java.time.temporal that return Duration
      Modifier and Type 方法 描述
      Duration ChronoUnit.getDuration​()
      在ISO日历系统中获取本机的预计持续时间。
      Duration TemporalUnit.getDuration​()
      获取此单位的持续时间，这可能是一个估计。

    • Uses of Duration in java.time.zone

      Methods in java.time.zone that return Duration
      Modifier and Type 方法 描述
      Duration ZoneRules.getDaylightSavings​(Instant instant)
      获取此区域中指定时间使用的夏令时数量。
      Duration ZoneOffsetTransition.getDuration​()
      获取转换的持续时间。

    • Uses of Duration in jdk.incubator.http

      Methods in jdk.incubator.http that return Duration
      Modifier and Type 方法 描述
      abstract Duration HttpRequest.duration​()
      返回此请求的持续时间。
      Methods in jdk.incubator.http with parameters of type Duration
      Modifier and Type 方法 描述
      WebSocket.Builder WebSocket.Builder.connectTimeout​(Duration timeout)
      设置开启握手的超时。
      abstract HttpRequest.Builder HttpRequest.Builder.timeout​(Duration duration)
      设置此请求的超时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.Instant (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.Instant

  • Packages that use Instant
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。

    • Uses of Instant in java.lang

      Methods in java.lang that return types with arguments of type Instant
      Modifier and Type 方法 描述
      Optional<Instant> ProcessHandle.Info.startInstant​()
      返回进程的开始时间。

    • Uses of Instant in java.nio.file.attribute

      Methods in java.nio.file.attribute that return Instant
      Modifier and Type 方法 描述
      Instant FileTime.toInstant​()
      将此 FileTime对象转换为 Instant 。
      Methods in java.nio.file.attribute with parameters of type Instant
      Modifier and Type 方法 描述
      static FileTime FileTime.from​(Instant instant)
      返回一个 FileTime表示与所提供的 Instant对象相同的时间点值。

    • Uses of Instant in java.sql

      Methods in java.sql that return Instant
      Modifier and Type 方法 描述
      Instant Date.toInstant​()
      此方法总是引发UnsupportedOperationException，因为SQL Date值没有时间组件，所以不应该使用它。
      Instant Time.toInstant​()
      此方法总是引发UnsupportedOperationException，因为SQL Time值没有日期组件，所以不应该使用它。
      Instant Timestamp.toInstant​()
      将此 Timestamp对象转换为 Instant 。
      Methods in java.sql with parameters of type Instant
      Modifier and Type 方法 描述
      static Timestamp Timestamp.from​(Instant instant)
      从Instant对象获取Timestamp的实例。

    • Uses of Instant in java.time

      Fields in java.time declared as Instant
      Modifier and Type Field 描述
      static Instant Instant.EPOCH
      常数为1970-01-01T00：00：00Z时代瞬间。
      static Instant Instant.MAX
      最大支持 Instant ，'1000000000-12-31T23：59：59.999999999Z'。
      static Instant Instant.MIN
      最低支持 Instant ，'-1000000000-01-01T00：00Z'。
      Methods in java.time that return Instant
      Modifier and Type 方法 描述
      static Instant Instant.from​(TemporalAccessor temporal)
      从时间对象获取一个 Instant的实例。
      abstract Instant Clock.instant​()
      获取当前的时钟瞬间。
      Instant Instant.minus​(long amountToSubtract, TemporalUnit unit)
      返回此时刻的副本，减去指定的金额。
      Instant Instant.minus​(TemporalAmount amountToSubtract)
      返回此时刻的副本，减去指定的金额。
      Instant Instant.minusMillis​(long millisToSubtract)
      以毫秒为单位的指定持续时间返回此瞬间的副本。
      Instant Instant.minusNanos​(long nanosToSubtract)
      以纳秒为单位返回指定持续时间的此瞬间的副本。
      Instant Instant.minusSeconds​(long secondsToSubtract)
      以秒为单位返回指定持续时间的此瞬间的副本。
      static Instant Instant.now​()
      从系统时钟获取当前瞬间。
      static Instant Instant.now​(Clock clock)
      从指定的时钟获取当前时刻。
      static Instant Instant.ofEpochMilli​(long epochMilli)
      使用从1970-01-01T00：00：00Z的时期开始的毫秒数获得 Instant的实例。
      static Instant Instant.ofEpochSecond​(long epochSecond)
      从1970-01-01T00：00：00Z的时代获得使用秒数的 Instant的实例。
      static Instant Instant.ofEpochSecond​(long epochSecond, long nanoAdjustment)
      使用从1970-01-01T00：00：00Z的时期开始的秒数获得 Instant的实例， Instant获得秒的纳秒分数。
      static Instant Instant.parse​(CharSequence text)
      从 2007-12-03T10:15:30.00Z等文本字符串获取 Instant的实例。
      Instant Instant.plus​(long amountToAdd, TemporalUnit unit)
      返回添加指定数量的此瞬间的副本。
      Instant Instant.plus​(TemporalAmount amountToAdd)
      返回添加指定数量的此瞬间的副本。
      Instant Instant.plusMillis​(long millisToAdd)
      以毫秒为单位的指定持续时间返回此瞬间的副本。
      Instant Instant.plusNanos​(long nanosToAdd)
      以指定的持续时间返回此瞬间的副本，以纳秒为单位。
      Instant Instant.plusSeconds​(long secondsToAdd)
      以指定的持续时间返回此瞬间的副本，以秒为单位。
      Instant OffsetDateTime.toInstant​()
      将此日期时间转换为 Instant 。
      Instant Instant.truncatedTo​(TemporalUnit unit)
      返回此 Instant的副本截断到指定的单位。
      Instant Instant.with​(TemporalAdjuster adjuster)
      返回此瞬间的调整副本。
      Instant Instant.with​(TemporalField field, long newValue)
      将指定的字段设置为新值返回此瞬间的副本。
      Methods in java.time with parameters of type Instant
      Modifier and Type 方法 描述
      int Instant.compareTo​(Instant otherInstant)
      将此瞬间与指定的时刻进行比较。
      static Clock Clock.fixed​(Instant fixedInstant, ZoneId zone)
      获得始终返回相同时刻的时钟。
      boolean Instant.isAfter​(Instant otherInstant)
      检查这个瞬间是否在指定的时刻之后。
      boolean Instant.isBefore​(Instant otherInstant)
      检查这个时刻是否在指定的时刻之前。
      static LocalDate LocalDate.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalDate的实例。
      static LocalDateTime LocalDateTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalDateTime的实例。
      static LocalTime LocalTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalTime的实例。
      static OffsetDateTime OffsetDateTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 OffsetDateTime的实例。
      static OffsetTime OffsetTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 OffsetTime的实例。
      static ZonedDateTime ZonedDateTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant获取一个 ZonedDateTime的实例。

    • Uses of Instant in java.time.chrono

      Methods in java.time.chrono that return Instant
      Modifier and Type 方法 描述
      default Instant ChronoLocalDateTime.toInstant​(ZoneOffset offset)
      将此日期时间转换为 Instant 。
      default Instant ChronoZonedDateTime.toInstant​()
      将此日期时间转换为 Instant 。
      Methods in java.time.chrono with parameters of type Instant
      Modifier and Type | 方法 | 描述
      default ChronoZonedDateTime<? extends ChronoLocalDate> Chronology.zonedDateTime​(Instant instant, ZoneId zone)
      获得 ChronoZonedDateTime在从这个年表 Instant 。
      ChronoZonedDateTime<HijrahDate> | HijrahChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ZonedDateTime IsoChronology.zonedDateTime​(Instant instant, ZoneId zone)
      从这个年龄从 Instant获得ISO Instant日期时间。
      ChronoZonedDateTime<JapaneseDate> | JapaneseChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<MinguoDate> | MinguoChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.zonedDateTime​(Instant instant, ZoneId zone)

    • Uses of Instant in java.time.zone

      Methods in java.time.zone that return Instant
      Modifier and Type 方法 描述
      Instant ZoneOffsetTransition.getInstant​()
      获得转换时刻。
      Methods in java.time.zone with parameters of type Instant
      Modifier and Type 方法 描述
      Duration ZoneRules.getDaylightSavings​(Instant instant)
      获取此区域中指定时间使用的夏令时数量。
      ZoneOffset ZoneRules.getOffset​(Instant instant)
      获得这些规则中指定时刻适用的偏移量。
      ZoneOffset ZoneRules.getStandardOffset​(Instant instant)
      获取此区域中指定时刻的标准偏移量。
      boolean ZoneRules.isDaylightSavings​(Instant instant)
      检查指定的时间是否是夏令时。
      ZoneOffsetTransition ZoneRules.nextTransition​(Instant instant)
      在指定的时刻之后获取下一个转换。
      ZoneOffsetTransition ZoneRules.previousTransition​(Instant instant)
      获取指定时刻之前的转换。

    • Uses of Instant in java.util

      Methods in java.util that return Instant
      Modifier and Type 方法 描述
      Instant Calendar.toInstant​()
      将此对象转换为Instant 。
      Instant Date.toInstant​()
      将此 Date对象转换为 Instant 。
      Methods in java.util with parameters of type Instant
      Modifier and Type 方法 描述
      static Date Date.from​(Instant instant)
      从 Instant对象获取一个 Date的实例。

    • Uses of Instant in java.util.logging

      Methods in java.util.logging that return Instant
      Modifier and Type 方法 描述
      Instant LogRecord.getInstant​()
      获取事件发生的时刻。
      Methods in java.util.logging with parameters of type Instant
      Modifier and Type 方法 描述
      void LogRecord.setInstant​(Instant instant)
      设置事件发生的时刻。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.LocalDate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.LocalDate

  • Packages that use LocalDate
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of LocalDate in java.sql

      Methods in java.sql that return LocalDate
      Modifier and Type 方法 描述
      LocalDate Date.toLocalDate​()
      使用这个 Date对象的年，月和日创建 LocalDate实例。
      Methods in java.sql with parameters of type LocalDate
      Modifier and Type 方法 描述
      static Date Date.valueOf​(LocalDate date)
      从LocalDate对象获取一个Date的实例，具有与给定的LocalDate相同的年，月和日的值。

    • Uses of LocalDate in java.time

      Fields in java.time declared as LocalDate
      Modifier and Type Field 描述
      static LocalDate LocalDate.EPOCH
      时代年份 LocalDate ，'1970-01-01'。
      static LocalDate LocalDate.MAX
      最大支持 LocalDate ，'+ 999999999-12-31'。
      static LocalDate LocalDate.MIN
      最低支持 LocalDate ，'- LocalDate '。
      Methods in java.time that return LocalDate
      Modifier and Type 方法 描述
      LocalDate Year.atDay​(int dayOfYear)
      今年与今年的合并创造了 LocalDate 。
      LocalDate YearMonth.atDay​(int dayOfMonth)
      结合今年的月份，创造一个 LocalDate 。
      LocalDate YearMonth.atEndOfMonth​()
      在本月底返回 LocalDate 。
      LocalDate Year.atMonthDay​(MonthDay monthDay)
      结合今年与一个月的日子，创造一个 LocalDate 。
      LocalDate MonthDay.atYear​(int year)
      结合本月与一年创造 LocalDate 。
      static LocalDate LocalDate.from​(TemporalAccessor temporal)
      从时间对象获取一个 LocalDate的实例。
      LocalDate LocalDate.minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期的副本，减去指定的金额。
      LocalDate LocalDate.minus​(TemporalAmount amountToSubtract)
      返回此日期的副本，减去指定的金额。
      LocalDate LocalDate.minusDays​(long daysToSubtract)
      返回此 LocalDate的副本，并减去指定的天数。
      LocalDate LocalDate.minusMonths​(long monthsToSubtract)
      返回此 LocalDate的副本，并减去指定的月数。
      LocalDate LocalDate.minusWeeks​(long weeksToSubtract)
      返回此 LocalDate的副本，并 LocalDate指定的周数。
      LocalDate LocalDate.minusYears​(long yearsToSubtract)
      返回此 LocalDate的副本，并减去指定的年数。
      static LocalDate LocalDate.now​()
      从默认时区的系统时钟获取当前日期。
      static LocalDate LocalDate.now​(Clock clock)
      从指定的时钟获取当前日期。
      static LocalDate LocalDate.now​(ZoneId zone)
      从指定时区的系统时钟获取当前日期。
      static LocalDate LocalDate.of​(int year, int month, int dayOfMonth)
      从一年，一个月和一天获得一个 LocalDate的实例。
      static LocalDate LocalDate.of​(int year, Month month, int dayOfMonth)
      从一年，一个月和一天获得 LocalDate的实例。
      static LocalDate LocalDate.ofEpochDay​(long epochDay)
      从纪元日数获得 LocalDate的实例。
      static LocalDate LocalDate.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalDate的实例。
      static LocalDate LocalDate.ofYearDay​(int year, int dayOfYear)
      从一年和一年的一年中获得 LocalDate的实例。
      static LocalDate LocalDate.parse​(CharSequence text)
      从 2007-12-03等文本字符串获取 LocalDate的实例。
      static LocalDate LocalDate.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 LocalDate的实例。
      LocalDate LocalDate.plus​(long amountToAdd, TemporalUnit unit)
      返回此日期的副本，并添加指定的金额。
      LocalDate LocalDate.plus​(TemporalAmount amountToAdd)
      返回此日期的副本，并添加指定的金额。
      LocalDate LocalDate.plusDays​(long daysToAdd)
      以指定的天数返回此 LocalDate的副本。
      LocalDate LocalDate.plusMonths​(long monthsToAdd)
      返回此 LocalDate的副本，并附加指定的月数。
      LocalDate LocalDate.plusWeeks​(long weeksToAdd)
      返回添加了指定周数的此 LocalDate的副本。
      LocalDate LocalDate.plusYears​(long yearsToAdd)
      以指定的年数返回此 LocalDate的副本。
      LocalDate LocalDateTime.toLocalDate​()
      获得这个日期时间的 LocalDate部分。
      LocalDate OffsetDateTime.toLocalDate​()
      获取此日期时间的 LocalDate部分。
      LocalDate ZonedDateTime.toLocalDate​()
      获取此日期时间的 LocalDate部分。
      LocalDate LocalDate.with​(TemporalAdjuster adjuster)
      返回此日期的调整副本。
      LocalDate LocalDate.with​(TemporalField field, long newValue)
      返回此日期的副本，并将指定的字段设置为新值。
      LocalDate LocalDate.withDayOfMonth​(int dayOfMonth)
      返回这个 LocalDate的副本，并更改日期。
      LocalDate LocalDate.withDayOfYear​(int dayOfYear)
      返回此 LocalDate更改的 LocalDate的副本。
      LocalDate LocalDate.withMonth​(int month)
      返回该 LocalDate的副本。
      LocalDate LocalDate.withYear​(int year)
      返回该 LocalDate的副本。
      Methods in java.time that return types with arguments of type LocalDate
      Modifier and Type 方法 描述
      Stream<LocalDate> LocalDate.datesUntil​(LocalDate endExclusive)
      返回顺序排列的日期流。
      Stream<LocalDate> LocalDate.datesUntil​(LocalDate endExclusive, Period step)
      通过给定的增量步骤返回日期的顺序排序流。
      Methods in java.time with parameters of type LocalDate
      Modifier and Type 方法 描述
      LocalDateTime LocalTime.atDate​(LocalDate date)
      结合这个时间与日期创建一个 LocalDateTime 。
      OffsetDateTime OffsetTime.atDate​(LocalDate date)
      结合这个时间与日期来创建一个 OffsetDateTime 。
      static Period Period.between​(LocalDate startDateInclusive, LocalDate endDateExclusive)
      获得一个 Period包括两个日期之间的年数，月份和日期。
      Stream<LocalDate> LocalDate.datesUntil​(LocalDate endExclusive)
      返回顺序排列的日期流。
      Stream<LocalDate> LocalDate.datesUntil​(LocalDate endExclusive, Period step)
      通过给定的增量步骤返回日期的顺序排序流。
      static LocalDateTime LocalDateTime.of​(LocalDate date, LocalTime time)
      从日期和时间获取 LocalDateTime的实例。
      static OffsetDateTime OffsetDateTime.of​(LocalDate date, LocalTime time, ZoneOffset offset)
      从日期，时间和偏移量获取 OffsetDateTime的实例。
      static ZonedDateTime ZonedDateTime.of​(LocalDate date, LocalTime time, ZoneId zone)
      从当地的日期和时间获取 ZonedDateTime的实例。
      long LocalTime.toEpochSecond​(LocalDate date, ZoneOffset offset)
      将此 LocalTime转换为1970-01-01T00：00：00Z的时代以来的秒数。
      long OffsetTime.toEpochSecond​(LocalDate date)
      将此 OffsetTime转换为1970-01-01T00：00：00Z的时代以来的秒数。

    • Uses of LocalDate in java.time.chrono

      Methods in java.time.chrono that return LocalDate
      Modifier and Type 方法 描述
      LocalDate IsoChronology.date​(int prolepticYear, int month, int dayOfMonth)
      从月度，月份和月份月份获取ISO本地日期。
      LocalDate IsoChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)
      从时代，年龄，月份和月份的时代获得ISO本地日期。
      LocalDate IsoChronology.date​(TemporalAccessor temporal)
      从另一个日期时间对象获取ISO本地日期。
      LocalDate IsoChronology.dateEpochDay​(long epochDay)
      从时代获取ISO本地日期。
      LocalDate IsoChronology.dateNow​()
      从默认时区的系统时钟获取当前的ISO本地日期。
      LocalDate IsoChronology.dateNow​(Clock clock)
      从指定的时钟获取当前的ISO本地日期。
      LocalDate IsoChronology.dateNow​(ZoneId zone)
      从指定时区的系统时钟获取当前的ISO本地日期。
      LocalDate IsoChronology.dateYearDay​(int prolepticYear, int dayOfYear)
      从幼稚年份和日期字段获取ISO本地日期。
      LocalDate IsoChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)
      从时代，年龄和日期的领域获得ISO本地日期。
      LocalDate IsoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析时解析为 ChronoField值。

    • Uses of LocalDate in java.time.temporal

      Methods in java.time.temporal that return types with arguments of type LocalDate
      Modifier and Type 方法 描述
      static TemporalQuery<LocalDate> TemporalQueries.localDate​()
      对于 LocalDate的查询，如果找不到则返回null。
      Method parameters in java.time.temporal with type arguments of type LocalDate
      Modifier and Type 方法 描述
      static TemporalAdjuster TemporalAdjusters.ofDateAdjuster​(UnaryOperator<LocalDate> dateBasedAdjuster)
      获取一个包含日期调整器的 TemporalAdjuster 。

    • Uses of LocalDate in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type LocalDate
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<LocalDate>> DatePicker.converterProperty​()
      将输入文本转换为类型为LocalDate的对象，反之亦然。
      StringConverter<LocalDate> DatePicker.getConverter​()
      获取属性转换器的值。
      Methods in javafx.scene.control with parameters of type LocalDate
      Modifier and Type 方法 描述
      void DateCell.updateItem​(LocalDate item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
      Method parameters in javafx.scene.control with type arguments of type LocalDate
      Modifier and Type 方法 描述
      void DatePicker.setConverter​(StringConverter<LocalDate> value)
      设置属性转换器的值。
      Constructors in javafx.scene.control with parameters of type LocalDate
      Constructor 描述
      DatePicker​(LocalDate localDate)
      创建一个DatePicker实例，并将 value设置为给定日期。

    • Uses of LocalDate in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return types with arguments of type LocalDate
      Modifier and Type 方法 描述
      protected StringConverter<LocalDate> DatePickerSkin.getConverter​()
      子类负责获取转换器。

    • Uses of LocalDate in javafx.util.converter

      Methods in javafx.util.converter that return LocalDate
      Modifier and Type 方法 描述
      LocalDate LocalDateStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type LocalDate
      Modifier and Type 方法 描述
      String LocalDateStringConverter.toString​(LocalDate value)
      将提供的对象转换为其字符串形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.LocalDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.LocalDateTime

  • Packages that use LocalDateTime
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.zone
    支持时区及其规则。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of LocalDateTime in java.sql

      Methods in java.sql that return LocalDateTime
      Modifier and Type 方法 描述
      LocalDateTime Timestamp.toLocalDateTime​()
      将此 Timestamp对象转换为 LocalDateTime 。
      Methods in java.sql with parameters of type LocalDateTime
      Modifier and Type 方法 描述
      static Timestamp Timestamp.valueOf​(LocalDateTime dateTime)
      获取的实例 Timestamp从 LocalDateTime对象，以相同的年，月，月日，时，分，秒和毫微秒日期时间值作为提供 LocalDateTime 。

    • Uses of LocalDateTime in java.time

      Fields in java.time declared as LocalDateTime
      Modifier and Type Field 描述
      static LocalDateTime LocalDateTime.MAX
      最大支持 LocalDateTime ，'+ 999999999-12-31T23：59：59.999999999'。
      static LocalDateTime LocalDateTime.MIN
      最低支持 LocalDateTime ：00：00'。
      Methods in java.time that return LocalDateTime
      Modifier and Type 方法 描述
      LocalDateTime LocalTime.atDate​(LocalDate date)
      结合这个时间与一个日期创建一个 LocalDateTime 。
      LocalDateTime LocalDate.atStartOfDay​()
      将此日期与午夜时间结合 LocalDateTime ，在此日期开始时创建一个 LocalDateTime 。
      LocalDateTime LocalDate.atTime​(int hour, int minute)
      将此日期与时间结合起来创建一个 LocalDateTime 。
      LocalDateTime LocalDate.atTime​(int hour, int minute, int second)
      结合这个日期与时间创建一个 LocalDateTime 。
      LocalDateTime LocalDate.atTime​(int hour, int minute, int second, int nanoOfSecond)
      结合此日期与时间来创建一个 LocalDateTime 。
      LocalDateTime LocalDate.atTime​(LocalTime time)
      将此日期与时间结合起来创建一个 LocalDateTime 。
      static LocalDateTime LocalDateTime.from​(TemporalAccessor temporal)
      从时间对象获取一个 LocalDateTime的实例。
      LocalDateTime LocalDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期时间的副本，并减去指定的金额。
      LocalDateTime LocalDateTime.minus​(TemporalAmount amountToSubtract)
      返回此日期时间的副本，并减去指定的金额。
      LocalDateTime LocalDateTime.minusDays​(long days)
      返回此 LocalDateTime的副本，并减去指定的天数。
      LocalDateTime LocalDateTime.minusHours​(long hours)
      返回此 LocalDateTime的副本，并减去指定的小时数。
      LocalDateTime LocalDateTime.minusMinutes​(long minutes)
      返回此 LocalDateTime的副本，并减去指定的分钟数。
      LocalDateTime LocalDateTime.minusMonths​(long months)
      返回此 LocalDateTime的副本，并减去指定的月数。
      LocalDateTime LocalDateTime.minusNanos​(long nanos)
      返回此 LocalDateTime的副本，并减去指定的纳秒数。
      LocalDateTime LocalDateTime.minusSeconds​(long seconds)
      返回此 LocalDateTime的副本，并减去指定的秒数。
      LocalDateTime LocalDateTime.minusWeeks​(long weeks)
      返回此 LocalDateTime的副本，并 LocalDateTime指定的周数。
      LocalDateTime LocalDateTime.minusYears​(long years)
      返回此 LocalDateTime的副本，并减去指定的年数。
      static LocalDateTime LocalDateTime.now​()
      从默认时区的系统时钟获取当前的日期时间。
      static LocalDateTime LocalDateTime.now​(Clock clock)
      从指定的时钟获取当前的日期时间。
      static LocalDateTime LocalDateTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的日期时间。
      static LocalDateTime LocalDateTime.of​(int year, int month, int dayOfMonth, int hour, int minute)
      从年，月，日，小时和分钟获得 LocalDateTime的实例，将秒和纳秒设置为零。
      static LocalDateTime LocalDateTime.of​(int year, int month, int dayOfMonth, int hour, int minute, int second)
      从年，月，日，小时，分钟和秒获取 LocalDateTime的实例，将纳秒设置为零。
      static LocalDateTime LocalDateTime.of​(int year, int month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond)
      从年，月，日，时，分，秒和纳秒获取 LocalDateTime的实例。
      static LocalDateTime LocalDateTime.of​(int year, Month month, int dayOfMonth, int hour, int minute)
      从年，月，日，小时和分钟获得 LocalDateTime的实例，将第二和纳秒设置为零。
      static LocalDateTime LocalDateTime.of​(int year, Month month, int dayOfMonth, int hour, int minute, int second)
      从年，月，日，小时，分钟和秒获得 LocalDateTime的实例，将纳秒设置为零。
      static LocalDateTime LocalDateTime.of​(int year, Month month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond)
      从年，月，日，时，分，秒，纳秒获取 LocalDateTime的实例。
      static LocalDateTime LocalDateTime.of​(LocalDate date, LocalTime time)
      从日期和时间获取 LocalDateTime的实例。
      static LocalDateTime LocalDateTime.ofEpochSecond​(long epochSecond, int nanoOfSecond, ZoneOffset offset)
      使用从1970-01-01T00：00：00Z的时代开始的秒数获得 LocalDateTime的实例。
      static LocalDateTime LocalDateTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalDateTime的实例。
      static LocalDateTime LocalDateTime.parse​(CharSequence text)
      从 2007-12-03T10:15:30等文本字符串获取 LocalDateTime的实例。
      static LocalDateTime LocalDateTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 LocalDateTime的实例。
      LocalDateTime LocalDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此日期时间的副本，并添加指定的数量。
      LocalDateTime LocalDateTime.plus​(TemporalAmount amountToAdd)
      返回此日期时间的副本，并添加指定的数量。
      LocalDateTime LocalDateTime.plusDays​(long days)
      以指定的天数返回此 LocalDateTime的副本。
      LocalDateTime LocalDateTime.plusHours​(long hours)
      返回此 LocalDateTime的副本，并附加指定的小时数。
      LocalDateTime LocalDateTime.plusMinutes​(long minutes)
      返回此 LocalDateTime的副本，并附加指定的分钟数。
      LocalDateTime LocalDateTime.plusMonths​(long months)
      返回此 LocalDateTime的副本，并附加指定的月数。
      LocalDateTime LocalDateTime.plusNanos​(long nanos)
      返回此 LocalDateTime的副本， LocalDateTime添加了指定的纳秒数。
      LocalDateTime LocalDateTime.plusSeconds​(long seconds)
      返回此 LocalDateTime的副本，并添加指定的秒数。
      LocalDateTime LocalDateTime.plusWeeks​(long weeks)
      返回此 LocalDateTime的副本，并附加指定的周数。
      LocalDateTime LocalDateTime.plusYears​(long years)
      返回此 LocalDateTime的副本，并附加指定的年数。
      LocalDateTime OffsetDateTime.toLocalDateTime​()
      获取此日期时间的 LocalDateTime部分。
      LocalDateTime ZonedDateTime.toLocalDateTime​()
      获取此日期时间的 LocalDateTime部分。
      LocalDateTime LocalDateTime.truncatedTo​(TemporalUnit unit)
      返回此 LocalDateTime的副本，截断时间。
      LocalDateTime LocalDateTime.with​(TemporalAdjuster adjuster)
      返回此日期时间的调整副本。
      LocalDateTime LocalDateTime.with​(TemporalField field, long newValue)
      返回此日期时间的副本，并将指定的字段设置为新值。
      LocalDateTime LocalDateTime.withDayOfMonth​(int dayOfMonth)
      返回 LocalDateTime的副本，并更改日期。
      LocalDateTime LocalDateTime.withDayOfYear​(int dayOfYear)
      返回此 LocalDateTime更改的 LocalDateTime的副本。
      LocalDateTime LocalDateTime.withHour​(int hour)
      返回此 LocalDateTime的副本，并更改日期。
      LocalDateTime LocalDateTime.withMinute​(int minute)
      返回此 LocalDateTime的副本，小时改变。
      LocalDateTime LocalDateTime.withMonth​(int month)
      返回这个 LocalDateTime的副本，同时 LocalDateTime了月份。
      LocalDateTime LocalDateTime.withNano​(int nanoOfSecond)
      返回这个 LocalDateTime的副本，并更改了纳秒。
      LocalDateTime LocalDateTime.withSecond​(int second)
      返回此 LocalDateTime的副本，并更改了第二分钟。
      LocalDateTime LocalDateTime.withYear​(int year)
      返回这个 LocalDateTime的副本，年份被更改。
      Methods in java.time with parameters of type LocalDateTime
      Modifier and Type 方法 描述
      static OffsetDateTime OffsetDateTime.of​(LocalDateTime dateTime, ZoneOffset offset)
      从日期时间和偏移量获取 OffsetDateTime的实例。
      static ZonedDateTime ZonedDateTime.of​(LocalDateTime localDateTime, ZoneId zone)
      从本地日期时间获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.ofInstant​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      从通过组合本地日期时间和偏移量形成的瞬间获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.ofLocal​(LocalDateTime localDateTime, ZoneId zone, ZoneOffset preferredOffset)
      如果可能，从本地日期时间获取 ZonedDateTime的实例，使用首选偏移量。
      static ZonedDateTime ZonedDateTime.ofStrict​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      获取 ZonedDateTime的实例，严格验证本地日期时间，偏移量和区域ID的组合。

    • Uses of LocalDateTime in java.time.chrono

      Methods in java.time.chrono that return LocalDateTime
      Modifier and Type 方法 描述
      LocalDateTime IsoChronology.localDateTime​(TemporalAccessor temporal)
      从另一个日期时间对象获取ISO本地日期时间。

    • Uses of LocalDateTime in java.time.zone

      Methods in java.time.zone that return LocalDateTime
      Modifier and Type 方法 描述
      LocalDateTime ZoneOffsetTransitionRule.TimeDefinition.createDateTime​(LocalDateTime dateTime, ZoneOffset standardOffset, ZoneOffset wallOffset)
      将指定的本地日期时间转换为挂钟上实际看到的本地日期时间。
      LocalDateTime ZoneOffsetTransition.getDateTimeAfter​()
      获取本地转换日期时间，将以“after”偏移量表示。
      LocalDateTime ZoneOffsetTransition.getDateTimeBefore​()
      获取本地转换日期时间，如“before”偏移量所表达的那样。
      Methods in java.time.zone with parameters of type LocalDateTime
      Modifier and Type 方法 描述
      LocalDateTime ZoneOffsetTransitionRule.TimeDefinition.createDateTime​(LocalDateTime dateTime, ZoneOffset standardOffset, ZoneOffset wallOffset)
      将指定的本地日期时间转换为挂钟上实际看到的本地日期时间。
      ZoneOffset ZoneRules.getOffset​(LocalDateTime localDateTime)
      在这些规则中为指定的本地日期时间获取适当的偏移量。
      ZoneOffsetTransition ZoneRules.getTransition​(LocalDateTime localDateTime)
      在这些规则中获取在指定的本地日期时间中适用的偏移量转换。
      List<ZoneOffset> ZoneRules.getValidOffsets​(LocalDateTime localDateTime)
      在这些规则中获取在指定的本地日期时间中适用的偏移量。
      boolean ZoneRules.isValidOffset​(LocalDateTime localDateTime, ZoneOffset offset)
      检查偏移日期时间对于这些规则是否有效。
      static ZoneOffsetTransition ZoneOffsetTransition.of​(LocalDateTime transition, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义两个偏移之间的转换的实例。

    • Uses of LocalDateTime in java.util.zip

      Methods in java.util.zip that return LocalDateTime
      Modifier and Type 方法 描述
      LocalDateTime ZipEntry.getTimeLocal​()
      返回本地日期时间的条目的最后修改时间。
      Methods in java.util.zip with parameters of type LocalDateTime
      Modifier and Type 方法 描述
      void ZipEntry.setTimeLocal​(LocalDateTime time)
      设置本地日期时间的条目的最后修改时间。

    • Uses of LocalDateTime in javafx.util.converter

      Methods in javafx.util.converter that return LocalDateTime
      Modifier and Type 方法 描述
      LocalDateTime LocalDateTimeStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type LocalDateTime
      Modifier and Type 方法 描述
      String LocalDateTimeStringConverter.toString​(LocalDateTime value)
      将提供的对象转换为其字符串形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.LocalTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.LocalTime

  • Packages that use LocalTime
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of LocalTime in java.sql

      Methods in java.sql that return LocalTime
      Modifier and Type 方法 描述
      LocalTime Time.toLocalTime​()
      将此 Time对象转换为 LocalTime 。
      Methods in java.sql with parameters of type LocalTime
      Modifier and Type 方法 描述
      static Time Time.valueOf​(LocalTime time)
      从LocalTime对象获取Time的实例，具有与给定的LocalTime相同的小时，分钟和秒值。

    • Uses of LocalTime in java.time

      Fields in java.time declared as LocalTime
      Modifier and Type Field 描述
      static LocalTime LocalTime.MAX
      最大支持 LocalTime ，'23：59：59.999999999'。
      static LocalTime LocalTime.MIDNIGHT
      午夜开始的时候，'00：00'。
      static LocalTime LocalTime.MIN
      最低支持 LocalTime ，'00：00'。
      static LocalTime LocalTime.NOON
      中午的时候，“12：00”。
      Methods in java.time that return LocalTime
      Modifier and Type 方法 描述
      static LocalTime LocalTime.from​(TemporalAccessor temporal)
      从时间对象获取一个 LocalTime的实例。
      LocalTime LocalTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此次的副本，减去指定的金额。
      LocalTime LocalTime.minus​(TemporalAmount amountToSubtract)
      返回此次的副本，减去指定的金额。
      LocalTime LocalTime.minusHours​(long hoursToSubtract)
      返回此 LocalTime的副本，并减去指定的小时数。
      LocalTime LocalTime.minusMinutes​(long minutesToSubtract)
      以指定的分钟数减去此 LocalTime的副本。
      LocalTime LocalTime.minusNanos​(long nanosToSubtract)
      返回此 LocalTime的副本，并减去指定的纳秒数。
      LocalTime LocalTime.minusSeconds​(long secondsToSubtract)
      返回此 LocalTime的副本，并减去指定的秒数。
      static LocalTime LocalTime.now​()
      从默认时区的系统时钟获取当前时间。
      static LocalTime LocalTime.now​(Clock clock)
      从指定的时钟获取当前时间。
      static LocalTime LocalTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前时间。
      static LocalTime LocalTime.of​(int hour, int minute)
      从一小时分钟获取 LocalTime的实例。
      static LocalTime LocalTime.of​(int hour, int minute, int second)
      从一小时，分钟和秒钟获取 LocalTime的实例。
      static LocalTime LocalTime.of​(int hour, int minute, int second, int nanoOfSecond)
      从一小时，分钟，秒和纳秒获取 LocalTime的实例。
      static LocalTime LocalTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalTime的实例。
      static LocalTime LocalTime.ofNanoOfDay​(long nanoOfDay)
      从 LocalTime值获取 LocalTime的实例。
      static LocalTime LocalTime.ofSecondOfDay​(long secondOfDay)
      从第二天的价值获得 LocalTime的实例。
      static LocalTime LocalTime.parse​(CharSequence text)
      从 10:15等文本字符串获取 LocalTime的实例。
      static LocalTime LocalTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 LocalTime的实例。
      LocalTime LocalTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此时添加了指定数量的副本。
      LocalTime LocalTime.plus​(TemporalAmount amountToAdd)
      返回此时添加了指定数量的副本。
      LocalTime LocalTime.plusHours​(long hoursToAdd)
      返回此 LocalTime的副本，并附加指定的小时数。
      LocalTime LocalTime.plusMinutes​(long minutesToAdd)
      返回此 LocalTime的副本，并添加指定的分钟数。
      LocalTime LocalTime.plusNanos​(long nanosToAdd)
      返回此 LocalTime的副本， LocalTime添加了指定的纳秒数。
      LocalTime LocalTime.plusSeconds​(long secondstoAdd)
      返回此 LocalTime的副本，并添加指定的秒数。
      LocalTime LocalDateTime.toLocalTime​()
      获得这个日期时间的 LocalTime部分。
      LocalTime OffsetDateTime.toLocalTime​()
      获得这个日期时间的 LocalTime部分。
      LocalTime OffsetTime.toLocalTime​()
      获取这个日期时间的 LocalTime一部分。
      LocalTime ZonedDateTime.toLocalTime​()
      获取此日期时间的 LocalTime部分。
      LocalTime LocalTime.truncatedTo​(TemporalUnit unit)
      返回此 LocalTime的副本，截断时间。
      LocalTime LocalTime.with​(TemporalAdjuster adjuster)
      返回此次调整后的副本。
      LocalTime LocalTime.with​(TemporalField field, long newValue)
      返回此时间的副本，并将指定的字段设置为新值。
      LocalTime LocalTime.withHour​(int hour)
      每天更改时，返回此 LocalTime的副本。
      LocalTime LocalTime.withMinute​(int minute)
      返回此 LocalTime的副本，小时更改。
      LocalTime LocalTime.withNano​(int nanoOfSecond)
      返回这个 LocalTime的副本，并修改了纳秒。
      LocalTime LocalTime.withSecond​(int second)
      返回此 LocalTime的副本，并更改了第二分钟。
      Methods in java.time with parameters of type LocalTime
      Modifier and Type 方法 描述
      LocalDateTime LocalDate.atTime​(LocalTime time)
      结合此日期与时间创建一个 LocalDateTime 。
      int LocalTime.compareTo​(LocalTime other)
      比较这个时间到另一个时间。
      boolean LocalTime.isAfter​(LocalTime other)
      检查此时间是否在指定时间后。
      boolean LocalTime.isBefore​(LocalTime other)
      检查此时间是否在指定时间之前。
      static LocalDateTime LocalDateTime.of​(LocalDate date, LocalTime time)
      从日期和时间获取 LocalDateTime的实例。
      static OffsetDateTime OffsetDateTime.of​(LocalDate date, LocalTime time, ZoneOffset offset)
      从日期，时间和偏移量获取 OffsetDateTime的实例。
      static OffsetTime OffsetTime.of​(LocalTime time, ZoneOffset offset)
      从当地时间和偏移量获取 OffsetTime的实例。
      static ZonedDateTime ZonedDateTime.of​(LocalDate date, LocalTime time, ZoneId zone)
      从当地的日期和时间获取 ZonedDateTime的实例。
      long LocalDate.toEpochSecond​(LocalTime time, ZoneOffset offset)
      将此 LocalDate转换为自1970-01-01T00：00：00Z开始的秒数。

    • Uses of LocalTime in java.time.chrono

      Methods in java.time.chrono that return LocalTime
      Modifier and Type 方法 描述
      LocalTime ChronoLocalDateTime.toLocalTime​()
      获取此日期时间的当地时间部分。
      default LocalTime ChronoZonedDateTime.toLocalTime​()
      获取此日期时间的当地时间部分。
      Methods in java.time.chrono with parameters of type LocalTime
      Modifier and Type | 方法 | 描述
      default ChronoLocalDateTime<?> ChronoLocalDate.atTime​(LocalTime localTime)
      结合此日期与时间创建一个 ChronoLocalDateTime 。
      ChronoLocalDateTime<HijrahDate> | HijrahDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<JapaneseDate> | JapaneseDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<MinguoDate> | MinguoDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<ThaiBuddhistDate> | ThaiBuddhistDate.atTime​(LocalTime localTime)

    • Uses of LocalTime in java.time.temporal

      Methods in java.time.temporal that return types with arguments of type LocalTime
      Modifier and Type 方法 描述
      static TemporalQuery<LocalTime> TemporalQueries.localTime​()
      对于 LocalTime的查询，如果找不到则返回null。

    • Uses of LocalTime in java.time.zone

      Methods in java.time.zone that return LocalTime
      Modifier and Type 方法 描述
      LocalTime ZoneOffsetTransitionRule.getLocalTime​()
      获取必须用 ZoneOffsetTransitionRule.isMidnightEndOfDay()检查的 当地时间 。
      Methods in java.time.zone with parameters of type LocalTime
      Modifier and Type 方法 描述
      static ZoneOffsetTransitionRule ZoneOffsetTransitionRule.of​(Month month, int dayOfMonthIndicator, DayOfWeek dayOfWeek, LocalTime time, boolean timeEndOfDay, ZoneOffsetTransitionRule.TimeDefinition timeDefnition, ZoneOffset standardOffset, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义年度规则以在两个偏移之间创建转换的实例。

    • Uses of LocalTime in javafx.util.converter

      Methods in javafx.util.converter that return LocalTime
      Modifier and Type 方法 描述
      LocalTime LocalTimeStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type LocalTime
      Modifier and Type 方法 描述
      String LocalTimeStringConverter.toString​(LocalTime value)
      将提供的对象转换为其字符串形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.Month (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.Month

  • Packages that use Month
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.zone
    支持时区及其规则。

    • Uses of Month in java.time

      Methods in java.time that return Month
      Modifier and Type 方法 描述
      Month Month.firstMonthOfQuarter​()
      获得与本季度第一个月相对应的月份。
      static Month Month.from​(TemporalAccessor temporal)
      从时间对象获取 Month的实例。
      Month LocalDate.getMonth​()
      使用 Month枚举获取月份字段。
      Month LocalDateTime.getMonth​()
      使用 Month枚举获取月份字段。
      Month MonthDay.getMonth​()
      使用 Month枚举获取月份字段。
      Month OffsetDateTime.getMonth​()
      使用 Month枚举获取月份字段。
      Month YearMonth.getMonth​()
      使用 Month枚举获取月份字段。
      Month ZonedDateTime.getMonth​()
      使用 Month枚举获取月份字段。
      Month Month.minus​(long months)
      返回指定月份之前的月份。
      static Month Month.of​(int month)
      从 int获得 Month的实例。
      Month Month.plus​(long months)
      返回指定月份之后的月份。
      static Month Month.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Month[] Month.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.time with parameters of type Month
      Modifier and Type 方法 描述
      YearMonth Year.atMonth​(Month month)
      今年结合一个月创造一个 YearMonth 。
      static LocalDate LocalDate.of​(int year, Month month, int dayOfMonth)
      从一年，一个月和一天获取 LocalDate的实例。
      static LocalDateTime LocalDateTime.of​(int year, Month month, int dayOfMonth, int hour, int minute)
      从年，月，日，小时和分钟获得 LocalDateTime的实例，将秒和纳秒设置为零。
      static LocalDateTime LocalDateTime.of​(int year, Month month, int dayOfMonth, int hour, int minute, int second)
      从年，月，日，小时，分钟和秒获得 LocalDateTime的实例，将纳秒设置为零。
      static LocalDateTime LocalDateTime.of​(int year, Month month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond)
      从年，月，日，时，分，秒，纳秒获取 LocalDateTime的实例。
      static MonthDay MonthDay.of​(Month month, int dayOfMonth)
      获得 MonthDay的实例。
      static YearMonth YearMonth.of​(int year, Month month)
      从一年和一个月获得 YearMonth的实例。
      MonthDay MonthDay.with​(Month month)
      返回该 MonthDay的副本。

    • Uses of Month in java.time.zone

      Methods in java.time.zone that return Month
      Modifier and Type 方法 描述
      Month ZoneOffsetTransitionRule.getMonth​()
      获得过渡的月份。
      Methods in java.time.zone with parameters of type Month
      Modifier and Type 方法 描述
      static ZoneOffsetTransitionRule ZoneOffsetTransitionRule.of​(Month month, int dayOfMonthIndicator, DayOfWeek dayOfWeek, LocalTime time, boolean timeEndOfDay, ZoneOffsetTransitionRule.TimeDefinition timeDefnition, ZoneOffset standardOffset, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      Obtains an instance defining the yearly rule to create transitions between two offsets.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.MonthDay (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.MonthDay

  • Packages that use MonthDay
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。

    • Uses of MonthDay in java.time

      Methods in java.time that return MonthDay
      Modifier and Type 方法 描述
      static MonthDay MonthDay.from​(TemporalAccessor temporal)
      从时间对象获取一个 MonthDay的实例。
      static MonthDay MonthDay.now​()
      从默认时区的系统时钟获取当前月日。
      static MonthDay MonthDay.now​(Clock clock)
      从指定的时钟获取当前的月日。
      static MonthDay MonthDay.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的月日。
      static MonthDay MonthDay.of​(int month, int dayOfMonth)
      获得 MonthDay的实例。
      static MonthDay MonthDay.of​(Month month, int dayOfMonth)
      获得 MonthDay的实例。
      static MonthDay MonthDay.parse​(CharSequence text)
      从 --12-03等文本字符串获取 MonthDay的实例。
      static MonthDay MonthDay.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 MonthDay的实例。
      MonthDay MonthDay.with​(Month month)
      返回该 MonthDay的副本。
      MonthDay MonthDay.withDayOfMonth​(int dayOfMonth)
      返回 MonthDay的副本，并更改日期。
      MonthDay MonthDay.withMonth​(int month)
      返回该 MonthDay的副本。
      Methods in java.time with parameters of type MonthDay
      Modifier and Type 方法 描述
      LocalDate Year.atMonthDay​(MonthDay monthDay)
      结合今年与一个月的日子，创造一个 LocalDate 。
      int MonthDay.compareTo​(MonthDay other)
      比较这个月份到另一个月的日子。
      boolean MonthDay.isAfter​(MonthDay other)
      检查这个月日是否在指定的月日之后。
      boolean MonthDay.isBefore​(MonthDay other)
      检查这个月日是否在指定的月日之前。
      boolean Year.isValidMonthDay​(MonthDay monthDay)
      检查今年的月日是否有效。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.OffsetDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.OffsetDateTime

  • Packages that use OffsetDateTime
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。

    • Uses of OffsetDateTime in java.time

      Fields in java.time declared as OffsetDateTime
      Modifier and Type Field 描述
      static OffsetDateTime OffsetDateTime.MAX
      最大支持 OffsetDateTime ，'+ 999999999-12-31T23：59：59.999999999-18：00'。
      static OffsetDateTime OffsetDateTime.MIN
      最低支持 OffsetDateTime ：00：00 + 18：00'。
      Methods in java.time that return OffsetDateTime
      Modifier and Type 方法 描述
      OffsetDateTime OffsetTime.atDate​(LocalDate date)
      结合这个时间与一个日期创建一个 OffsetDateTime 。
      OffsetDateTime Instant.atOffset​(ZoneOffset offset)
      将此瞬间与偏移组合，创建一个 OffsetDateTime 。
      OffsetDateTime LocalDateTime.atOffset​(ZoneOffset offset)
      将此日期时间与偏移量相结合可创建 OffsetDateTime 。
      OffsetDateTime LocalDate.atTime​(OffsetTime time)
      将此日期与偏移时间相结合以创建 OffsetDateTime 。
      static OffsetDateTime OffsetDateTime.from​(TemporalAccessor temporal)
      从时间对象获取一个 OffsetDateTime的实例。
      OffsetDateTime OffsetDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期时间的副本，并减去指定的金额。
      OffsetDateTime OffsetDateTime.minus​(TemporalAmount amountToSubtract)
      返回此日期时间的副本，并减去指定的金额。
      OffsetDateTime OffsetDateTime.minusDays​(long days)
      返回此 OffsetDateTime的副本，并减去指定的天数。
      OffsetDateTime OffsetDateTime.minusHours​(long hours)
      返回此 OffsetDateTime的副本，并减去指定的小时数。
      OffsetDateTime OffsetDateTime.minusMinutes​(long minutes)
      返回此 OffsetDateTime的副本，并减去指定的分钟数。
      OffsetDateTime OffsetDateTime.minusMonths​(long months)
      返回此 OffsetDateTime的副本，并减去指定的月数。
      OffsetDateTime OffsetDateTime.minusNanos​(long nanos)
      返回此 OffsetDateTime的副本，减去指定的纳秒数。
      OffsetDateTime OffsetDateTime.minusSeconds​(long seconds)
      返回此 OffsetDateTime的副本，并减去指定的秒数。
      OffsetDateTime OffsetDateTime.minusWeeks​(long weeks)
      返回此 OffsetDateTime的副本，并减去指定的周数。
      OffsetDateTime OffsetDateTime.minusYears​(long years)
      返回此 OffsetDateTime的副本，并减去指定的年数。
      static OffsetDateTime OffsetDateTime.now​()
      从默认时区的系统时钟获取当前的日期时间。
      static OffsetDateTime OffsetDateTime.now​(Clock clock)
      从指定的时钟获取当前的日期时间。
      static OffsetDateTime OffsetDateTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的日期时间。
      static OffsetDateTime OffsetDateTime.of​(int year, int month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond, ZoneOffset offset)
      从年，月，日，小时，分，秒，纳秒和偏移中获取 OffsetDateTime的实例。
      static OffsetDateTime OffsetDateTime.of​(LocalDate date, LocalTime time, ZoneOffset offset)
      从日期，时间和偏移量获取 OffsetDateTime的实例。
      static OffsetDateTime OffsetDateTime.of​(LocalDateTime dateTime, ZoneOffset offset)
      从日期时间和偏移量获取 OffsetDateTime的实例。
      static OffsetDateTime OffsetDateTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 OffsetDateTime的实例。
      static OffsetDateTime OffsetDateTime.parse​(CharSequence text)
      从 2007-12-03T10:15:30+01:00等文本字符串获取 OffsetDateTime的实例。
      static OffsetDateTime OffsetDateTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 OffsetDateTime的实例。
      OffsetDateTime OffsetDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此日期时间的副本，并添加指定的数量。
      OffsetDateTime OffsetDateTime.plus​(TemporalAmount amountToAdd)
      返回此日期时间的副本，并添加指定的数量。
      OffsetDateTime OffsetDateTime.plusDays​(long days)
      以指定的天数返回此OffsetDateTime的副本。
      OffsetDateTime OffsetDateTime.plusHours​(long hours)
      返回此 OffsetDateTime的副本，并附加指定的小时数。
      OffsetDateTime OffsetDateTime.plusMinutes​(long minutes)
      以指定的分钟数返回此 OffsetDateTime的副本。
      OffsetDateTime OffsetDateTime.plusMonths​(long months)
      返回此 OffsetDateTime的副本，并附加指定的月数。
      OffsetDateTime OffsetDateTime.plusNanos​(long nanos)
      返回这个 OffsetDateTime的副本， OffsetDateTime添加了指定的纳秒数。
      OffsetDateTime OffsetDateTime.plusSeconds​(long seconds)
      返回此 OffsetDateTime的副本，并添加指定的秒数。
      OffsetDateTime OffsetDateTime.plusWeeks​(long weeks)
      返回添加了指定周数的此OffsetDateTime的副本。
      OffsetDateTime OffsetDateTime.plusYears​(long years)
      以指定的年数返回此 OffsetDateTime的副本。
      OffsetDateTime ZonedDateTime.toOffsetDateTime​()
      将此日期时间转换为 OffsetDateTime 。
      OffsetDateTime OffsetDateTime.truncatedTo​(TemporalUnit unit)
      返回此 OffsetDateTime的副本，截断时间。
      OffsetDateTime OffsetDateTime.with​(TemporalAdjuster adjuster)
      返回此日期时间的调整副本。
      OffsetDateTime OffsetDateTime.with​(TemporalField field, long newValue)
      返回此日期时间的副本，并将指定的字段设置为新值。
      OffsetDateTime OffsetDateTime.withDayOfMonth​(int dayOfMonth)
      返回此 OffsetDateTime的副本，并更改日期。
      OffsetDateTime OffsetDateTime.withDayOfYear​(int dayOfYear)
      每年更改一份 OffsetDateTime的副本。
      OffsetDateTime OffsetDateTime.withHour​(int hour)
      每天更改时返回此 OffsetDateTime的副本。
      OffsetDateTime OffsetDateTime.withMinute​(int minute)
      OffsetDateTime
      OffsetDateTime OffsetDateTime.withMonth​(int month)
      OffsetDateTime - OffsetDateTime - OffsetDateTime - OffsetDateTime - OffsetDateTime - OffsetDateTime - OffsetDateTime - OffsetDateTime - OffsetDateTime
      OffsetDateTime OffsetDateTime.withNano​(int nanoOfSecond)
      OffsetDateTime - OffsetDateTime
      OffsetDateTime OffsetDateTime.withOffsetSameInstant​(ZoneOffset offset)
      以指定的偏移量返回此 OffsetDateTime的副本，确保结果处于同一时刻。
      OffsetDateTime OffsetDateTime.withOffsetSameLocal​(ZoneOffset offset)
      以指定的偏移量返回此 OffsetDateTime的副本，确保结果具有相同的本地日期时间。
      OffsetDateTime OffsetDateTime.withSecond​(int second)
      返回此 OffsetDateTime的副本，其中第二分钟更改。
      OffsetDateTime OffsetDateTime.withYear​(int year)
      返回该 OffsetDateTime的副本。
      Methods in java.time that return types with arguments of type OffsetDateTime
      Modifier and Type 方法 描述
      static Comparator<OffsetDateTime> OffsetDateTime.timeLineOrder​()
      获取一个比较器，只比较两个 OffsetDateTime实例。
      Methods in java.time with parameters of type OffsetDateTime
      Modifier and Type 方法 描述
      int OffsetDateTime.compareTo​(OffsetDateTime other)
      将此日期时间与其他日期时间进行比较。
      boolean OffsetDateTime.isAfter​(OffsetDateTime other)
      检查此日期时间是否在指定的日期时间之后。
      boolean OffsetDateTime.isBefore​(OffsetDateTime other)
      检查此日期时间是否在指定的日期时间之前。
      boolean OffsetDateTime.isEqual​(OffsetDateTime other)
      检查此日期时间的时间是否等于指定的日期时间。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.OffsetTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.OffsetTime

  • Packages that use OffsetTime
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。

    • Uses of OffsetTime in java.time

      Fields in java.time declared as OffsetTime
      Modifier and Type Field 描述
      static OffsetTime OffsetTime.MAX
      最大支持 OffsetTime ，'23：59：59.999999999-18：00'。
      static OffsetTime OffsetTime.MIN
      最低支持 OffsetTime ，'00：00：00 + 18：00'。
      Methods in java.time that return OffsetTime
      Modifier and Type 方法 描述
      OffsetTime LocalTime.atOffset​(ZoneOffset offset)
      结合这个时间与偏移创建一个 OffsetTime 。
      static OffsetTime OffsetTime.from​(TemporalAccessor temporal)
      从时间对象获取一个 OffsetTime的实例。
      OffsetTime OffsetTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此次的副本，减去指定的金额。
      OffsetTime OffsetTime.minus​(TemporalAmount amountToSubtract)
      返回此次的副本，减去指定的金额。
      OffsetTime OffsetTime.minusHours​(long hours)
      返回此 OffsetTime的副本，并减去指定的小时数。
      OffsetTime OffsetTime.minusMinutes​(long minutes)
      返回此 OffsetTime的副本，并减去指定的分钟数。
      OffsetTime OffsetTime.minusNanos​(long nanos)
      返回此 OffsetTime的副本，减去指定的纳秒数。
      OffsetTime OffsetTime.minusSeconds​(long seconds)
      返回此 OffsetTime的副本，并减去指定的秒数。
      static OffsetTime OffsetTime.now​()
      从默认时区的系统时钟获取当前时间。
      static OffsetTime OffsetTime.now​(Clock clock)
      从指定的时钟获取当前时间。
      static OffsetTime OffsetTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前时间。
      static OffsetTime OffsetTime.of​(int hour, int minute, int second, int nanoOfSecond, ZoneOffset offset)
      从一小时，分钟，秒和纳秒获取 OffsetTime的实例。
      static OffsetTime OffsetTime.of​(LocalTime time, ZoneOffset offset)
      从当地时间和偏移量获取 OffsetTime的实例。
      static OffsetTime OffsetTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 OffsetTime的实例。
      static OffsetTime OffsetTime.parse​(CharSequence text)
      从 10:15:30+01:00等文本字符串获取 OffsetTime的实例。
      static OffsetTime OffsetTime.parse​(CharSequence text, DateTimeFormatter formatter)
      从使用特定格式化程序的文本字符串获取 OffsetTime的实例。
      OffsetTime OffsetTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此时添加了指定数量的副本。
      OffsetTime OffsetTime.plus​(TemporalAmount amountToAdd)
      返回此时添加了指定数量的副本。
      OffsetTime OffsetTime.plusHours​(long hours)
      返回此 OffsetTime的副本，并附加指定的小时数。
      OffsetTime OffsetTime.plusMinutes​(long minutes)
      以指定的分钟数返回此 OffsetTime的副本。
      OffsetTime OffsetTime.plusNanos​(long nanos)
      返回此 OffsetTime的副本， OffsetTime添加了指定的纳秒数。
      OffsetTime OffsetTime.plusSeconds​(long seconds)
      返回此 OffsetTime的副本，并添加指定的秒数。
      OffsetTime OffsetDateTime.toOffsetTime​()
      将此日期时间转换为 OffsetTime 。
      OffsetTime OffsetTime.truncatedTo​(TemporalUnit unit)
      返回此 OffsetTime的副本，截断时间。
      OffsetTime OffsetTime.with​(TemporalAdjuster adjuster)
      返回此次调整后的副本。
      OffsetTime OffsetTime.with​(TemporalField field, long newValue)
      返回此时间的副本，并将指定的字段设置为新值。
      OffsetTime OffsetTime.withHour​(int hour)
      返回此 OffsetTime的副本，并更改日期。
      OffsetTime OffsetTime.withMinute​(int minute)
      返回此 OffsetTime的副本，小时更改。
      OffsetTime OffsetTime.withNano​(int nanoOfSecond)
      返回此 OffsetTime的副本，其中纳秒修改。
      OffsetTime OffsetTime.withOffsetSameInstant​(ZoneOffset offset)
      以指定的偏移量返回此 OffsetTime的副本，确保结果在隐含日期处于同一时刻。
      OffsetTime OffsetTime.withOffsetSameLocal​(ZoneOffset offset)
      以指定的偏移量返回此 OffsetTime的副本，确保结果具有相同的本地时间。
      OffsetTime OffsetTime.withSecond​(int second)
      返回此 OffsetTime的副本，其中第二分钟更改。
      Methods in java.time with parameters of type OffsetTime
      Modifier and Type 方法 描述
      OffsetDateTime LocalDate.atTime​(OffsetTime time)
      将此日期与偏移时间相结合，以创建 OffsetDateTime 。
      int OffsetTime.compareTo​(OffsetTime other)
      再比较这个 OffsetTime 。
      boolean OffsetTime.isAfter​(OffsetTime other)
      检查此 OffsetTime是否在指定的时间之后，将两次应用于通用日期。
      boolean OffsetTime.isBefore​(OffsetTime other)
      检查此 OffsetTime是否在指定的时间之前，将两次都应用到公共日期。
      boolean OffsetTime.isEqual​(OffsetTime other)
      检查此 OffsetTime是否等于同时应用到通用日期的指定时间。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.Period (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.Period

  • Packages that use Period
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。

    • Uses of Period in java.time

      Fields in java.time declared as Period
      Modifier and Type Field 描述
      static Period Period.ZERO
      一个常数为零。
      Methods in java.time that return Period
      Modifier and Type 方法 描述
      static Period Period.between​(LocalDate startDateInclusive, LocalDate endDateExclusive)
      获得一个 Period包括两个日期之间的年数，月份和日期。
      static Period Period.from​(TemporalAmount amount)
      从时间量获取 Period的实例。
      Period Period.minus​(TemporalAmount amountToSubtract)
      返回此期间的副本，并减去指定的时间段。
      Period Period.minusDays​(long daysToSubtract)
      返回此期间的副本，并减去指定的天数。
      Period Period.minusMonths​(long monthsToSubtract)
      返回此期间的副本，减去指定的月份。
      Period Period.minusYears​(long yearsToSubtract)
      返回此期间的副本，并减去指定的年数。
      Period Period.multipliedBy​(int scalar)
      返回一个新的实例，该时间段中的每个元素乘以指定的标量。
      Period Period.negated​()
      返回一个新的实例，每个金额在此期间被否定。
      Period Period.normalized​()
      返回此期间的副本，其中标准化了几年和几个月。
      static Period Period.of​(int years, int months, int days)
      获得一个 Period代表几年，几个月和几天。
      static Period Period.ofDays​(int days)
      获得 Period代表天数。
      static Period Period.ofMonths​(int months)
      获得代表数月的 Period 。
      static Period Period.ofWeeks​(int weeks)
      获得代表数周的 Period 。
      static Period Period.ofYears​(int years)
      获得代表多年的 Period 。
      static Period Period.parse​(CharSequence text)
      从 Period的文本字符串获取 PnYnMnD 。
      Period Period.plus​(TemporalAmount amountToAdd)
      返回指定期间添加的此期间的副本。
      Period Period.plusDays​(long daysToAdd)
      返回添加指定日期的此期间的副本。
      Period Period.plusMonths​(long monthsToAdd)
      返回添加指定月份的此期间的副本。
      Period Period.plusYears​(long yearsToAdd)
      返回添加指定年份的此期间的副本。
      Period LocalDate.until​(ChronoLocalDate endDateExclusive)
      将此日期与另一个日期之间的期间计算为 Period 。
      Period Period.withDays​(int days)
      以指定的天数返回此期间的副本。
      Period Period.withMonths​(int months)
      以指定的月数返回此期间的副本。
      Period Period.withYears​(int years)
      以指定的年数返回此期间的副本。
      Methods in java.time with parameters of type Period
      Modifier and Type 方法 描述
      Stream<LocalDate> LocalDate.datesUntil​(LocalDate endExclusive, Period step)
      通过给定的增量步骤返回日期的顺序排序流。

    • Uses of Period in java.time.chrono

      Methods in java.time.chrono that return Period
      Modifier and Type 方法 描述
      Period IsoChronology.period​(int years, int months, int days)
      根据几年，几个月和几天的时间表获得一段时间。

    • Uses of Period in java.time.format

      Methods in java.time.format that return types with arguments of type Period
      Modifier and Type 方法 描述
      static TemporalQuery<Period> DateTimeFormatter.parsedExcessDays​()
      一个查询，可以访问已解析的多余天数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.Year (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.Year

  • Packages that use Year
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。

    • Uses of Year in java.time

      Methods in java.time that return Year
      Modifier and Type 方法 描述
      static Year Year.from​(TemporalAccessor temporal)
      从时间对象获取一个 Year的实例。
      Year Year.minus​(long amountToSubtract, TemporalUnit unit)
      返回今年的副本，减去指定的金额。
      Year Year.minus​(TemporalAmount amountToSubtract)
      返回今年的副本，减去指定的金额。
      Year Year.minusYears​(long yearsToSubtract)
      返回此 Year的副本，并减去指定的年数。
      static Year Year.now​()
      从默认时区的系统时钟获取当前年份。
      static Year Year.now​(Clock clock)
      从指定时钟获取当年。
      static Year Year.now​(ZoneId zone)
      从指定时区的系统时钟获取当年。
      static Year Year.of​(int isoYear)
      获得一个 Year的实例。
      static Year Year.parse​(CharSequence text)
      从 2007等文本字符串获取 Year的实例。
      static Year Year.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 Year的实例。
      Year Year.plus​(long amountToAdd, TemporalUnit unit)
      返回今年的副本，并附加指定的金额。
      Year Year.plus​(TemporalAmount amountToAdd)
      返回今年的副本，并附加指定的金额。
      Year Year.plusYears​(long yearsToAdd)
      返回此 Year的副本，并附加指定的年数。
      Year Year.with​(TemporalAdjuster adjuster)
      返回今年的调整副本。
      Year Year.with​(TemporalField field, long newValue)
      返回今年的副本，并将指定的字段设置为新值。
      Methods in java.time with parameters of type Year
      Modifier and Type 方法 描述
      int Year.compareTo​(Year other)
      今年再比较一年。
      boolean Year.isAfter​(Year other)
      检查今年是否在指定的年份之后。
      boolean Year.isBefore​(Year other)
      Checks if this year is before the specified year.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.YearMonth (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.YearMonth

  • Packages that use YearMonth
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。

    • Uses of YearMonth in java.time

      Methods in java.time that return YearMonth
      Modifier and Type 方法 描述
      YearMonth Year.atMonth​(int month)
      今年结合一个月创造 YearMonth 。
      YearMonth Year.atMonth​(Month month)
      今年结合一个月创建一个 YearMonth 。
      static YearMonth YearMonth.from​(TemporalAccessor temporal)
      从时间对象获取一个 YearMonth的实例。
      YearMonth YearMonth.minus​(long amountToSubtract, TemporalUnit unit)
      返回减去指定数量的今年的副本。
      YearMonth YearMonth.minus​(TemporalAmount amountToSubtract)
      返回减去指定数量的今年的副本。
      YearMonth YearMonth.minusMonths​(long monthsToSubtract)
      返回此 YearMonth的副本，并减去指定的月数。
      YearMonth YearMonth.minusYears​(long yearsToSubtract)
      返回此 YearMonth的副本，减去指定的年数。
      static YearMonth YearMonth.now​()
      从默认时区的系统时钟获取当前的一个月。
      static YearMonth YearMonth.now​(Clock clock)
      从指定的时钟获取当前的一个月。
      static YearMonth YearMonth.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的一个月。
      static YearMonth YearMonth.of​(int year, int month)
      从一年和一个月获得 YearMonth的实例。
      static YearMonth YearMonth.of​(int year, Month month)
      从一年和一个月获得 YearMonth的实例。
      static YearMonth YearMonth.parse​(CharSequence text)
      从 2007-12等文本字符串获取 YearMonth的实例。
      static YearMonth YearMonth.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 YearMonth的实例。
      YearMonth YearMonth.plus​(long amountToAdd, TemporalUnit unit)
      返回此年份的副本，并添加指定的金额。
      YearMonth YearMonth.plus​(TemporalAmount amountToAdd)
      返回此年份的副本，并添加指定的金额。
      YearMonth YearMonth.plusMonths​(long monthsToAdd)
      返回此 YearMonth的副本，并附加指定的月数。
      YearMonth YearMonth.plusYears​(long yearsToAdd)
      返回此 YearMonth的副本，并附加指定的年数。
      YearMonth YearMonth.with​(TemporalAdjuster adjuster)
      返回今年的调整副本。
      YearMonth YearMonth.with​(TemporalField field, long newValue)
      返回此年月份的副本，并将指定的字段设置为新值。
      YearMonth YearMonth.withMonth​(int month)
      返回该 YearMonth的副本。
      YearMonth YearMonth.withYear​(int year)
      返回该 YearMonth的副本。
      Methods in java.time with parameters of type YearMonth
      Modifier and Type 方法 描述
      int YearMonth.compareTo​(YearMonth other)
      比较今年至另一个月。
      boolean YearMonth.isAfter​(YearMonth other)
      检查这个年月是否在指定的年月之后。
      boolean YearMonth.isBefore​(YearMonth other)
      检查这个年月是否在指定的年份之前。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.ZonedDateTime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.ZonedDateTime

  • Packages that use ZonedDateTime
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of ZonedDateTime in java.time

      Methods in java.time that return ZonedDateTime
      Modifier and Type 方法 描述
      ZonedDateTime LocalDate.atStartOfDay​(ZoneId zone)
      根据时区中的规则，在最早的有效时间内从此日期返回划分的日期时间。
      ZonedDateTime Instant.atZone​(ZoneId zone)
      将此瞬间与时区相结合，创建一个 ZonedDateTime 。
      ZonedDateTime LocalDateTime.atZone​(ZoneId zone)
      将此日期时间与时区组合，以创建一个 ZonedDateTime 。
      ZonedDateTime OffsetDateTime.atZoneSameInstant​(ZoneId zone)
      将此日期时间与时区相结合，创建一个 ZonedDateTime确保结果具有相同的时刻。
      ZonedDateTime OffsetDateTime.atZoneSimilarLocal​(ZoneId zone)
      将此日期时间与时区组合，以创建一个 ZonedDateTime尝试保持相同的本地日期和时间。
      static ZonedDateTime ZonedDateTime.from​(TemporalAccessor temporal)
      从时间对象获取一个 ZonedDateTime的实例。
      ZonedDateTime ZonedDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期时间的副本，并减去指定的金额。
      ZonedDateTime ZonedDateTime.minus​(TemporalAmount amountToSubtract)
      返回此日期时间的副本，并减去指定的金额。
      ZonedDateTime ZonedDateTime.minusDays​(long days)
      返回此 ZonedDateTime的副本，并减去指定的天数。
      ZonedDateTime ZonedDateTime.minusHours​(long hours)
      返回此 ZonedDateTime的副本，并减去指定的小时数。
      ZonedDateTime ZonedDateTime.minusMinutes​(long minutes)
      以指定的分钟数减去此 ZonedDateTime的副本。
      ZonedDateTime ZonedDateTime.minusMonths​(long months)
      返回此 ZonedDateTime的副本，并减去指定的月数。
      ZonedDateTime ZonedDateTime.minusNanos​(long nanos)
      返回此 ZonedDateTime的副本，并减去指定的纳秒数。
      ZonedDateTime ZonedDateTime.minusSeconds​(long seconds)
      返回此 ZonedDateTime的副本，并减去指定的秒数。
      ZonedDateTime ZonedDateTime.minusWeeks​(long weeks)
      返回此 ZonedDateTime的副本，并减去指定的周数。
      ZonedDateTime ZonedDateTime.minusYears​(long years)
      返回此 ZonedDateTime的副本，并减去指定的年数。
      static ZonedDateTime ZonedDateTime.now​()
      从默认时区的系统时钟获取当前的日期时间。
      static ZonedDateTime ZonedDateTime.now​(Clock clock)
      从指定的时钟获取当前的日期时间。
      static ZonedDateTime ZonedDateTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的日期时间。
      static ZonedDateTime ZonedDateTime.of​(int year, int month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond, ZoneId zone)
      从年，月，日，时，分，秒，纳秒和时区获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.of​(LocalDate date, LocalTime time, ZoneId zone)
      从当地的日期和时间获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.of​(LocalDateTime localDateTime, ZoneId zone)
      从本地日期时间获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.ofInstant​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      从通过组合本地日期时间和偏移量形成的瞬间获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.ofLocal​(LocalDateTime localDateTime, ZoneId zone, ZoneOffset preferredOffset)
      从本地日期时间获取 ZonedDateTime的实例，如果可能，使用首选偏移量。
      static ZonedDateTime ZonedDateTime.ofStrict​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      获取 ZonedDateTime的实例，严格验证本地日期时间，偏移量和区域ID的组合。
      static ZonedDateTime ZonedDateTime.parse​(CharSequence text)
      从 2007-12-03T10:15:30+01:00[Europe/Paris]等文本字符串获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 ZonedDateTime的实例。
      ZonedDateTime ZonedDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此日期时间的副本，并添加指定的数量。
      ZonedDateTime ZonedDateTime.plus​(TemporalAmount amountToAdd)
      返回此日期时间的副本，并添加指定的数量。
      ZonedDateTime ZonedDateTime.plusDays​(long days)
      以指定的天数返回此 ZonedDateTime的副本。
      ZonedDateTime ZonedDateTime.plusHours​(long hours)
      返回此 ZonedDateTime的副本，并附加指定的小时数。
      ZonedDateTime ZonedDateTime.plusMinutes​(long minutes)
      返回此 ZonedDateTime的副本，并附加指定的分钟数。
      ZonedDateTime ZonedDateTime.plusMonths​(long months)
      返回此 ZonedDateTime的副本，并附加指定的月数。
      ZonedDateTime ZonedDateTime.plusNanos​(long nanos)
      返回此 ZonedDateTime的副本， ZonedDateTime添加了指定的纳秒数。
      ZonedDateTime ZonedDateTime.plusSeconds​(long seconds)
      返回此 ZonedDateTime的副本，并添加指定的秒数。
      ZonedDateTime ZonedDateTime.plusWeeks​(long weeks)
      返回此 ZonedDateTime的副本，并附加指定的周数。
      ZonedDateTime ZonedDateTime.plusYears​(long years)
      返回此 ZonedDateTime的副本，并附加指定的年数。
      ZonedDateTime OffsetDateTime.toZonedDateTime​()
      将此日期时间转换为 ZonedDateTime使用偏移量作为区域ID。
      ZonedDateTime ZonedDateTime.truncatedTo​(TemporalUnit unit)
      返回此 ZonedDateTime的副本，截断时间。
      ZonedDateTime ZonedDateTime.with​(TemporalAdjuster adjuster)
      返回此日期时间的调整副本。
      ZonedDateTime ZonedDateTime.with​(TemporalField field, long newValue)
      返回此日期时间的副本，并将指定的字段设置为新值。
      ZonedDateTime ZonedDateTime.withDayOfMonth​(int dayOfMonth)
      返回 ZonedDateTime的副本，并更改日期。
      ZonedDateTime ZonedDateTime.withDayOfYear​(int dayOfYear)
      返回该 ZonedDateTime的副本。
      ZonedDateTime ZonedDateTime.withEarlierOffsetAtOverlap​()
      返回此日期的副本，将区域偏移更改为本地时间线重叠处的两个有效偏移量的较早者。
      ZonedDateTime ZonedDateTime.withFixedOffsetZone​()
      返回此日期时间的副本，区域ID设置为偏移量。
      ZonedDateTime ZonedDateTime.withHour​(int hour)
      返回此 ZonedDateTime的副本，并更改日期。
      ZonedDateTime ZonedDateTime.withLaterOffsetAtOverlap​()
      返回此日期的副本，将区域偏移更改为本地时间线重叠的两个有效偏移量的后面。
      ZonedDateTime ZonedDateTime.withMinute​(int minute)
      返回 ZonedDateTime的副本，小时改变。
      ZonedDateTime ZonedDateTime.withMonth​(int month)
      返回该 ZonedDateTime的副本。
      ZonedDateTime ZonedDateTime.withNano​(int nanoOfSecond)
      返回这个 ZonedDateTime的副本， ZonedDateTime改变了。
      ZonedDateTime ZonedDateTime.withSecond​(int second)
      返回此 ZonedDateTime的副本，其中第二分钟更改。
      ZonedDateTime ZonedDateTime.withYear​(int year)
      随着年份的更改，返回此 ZonedDateTime的副本。
      ZonedDateTime ZonedDateTime.withZoneSameInstant​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，保留即时。
      ZonedDateTime ZonedDateTime.withZoneSameLocal​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。

    • Uses of ZonedDateTime in java.time.chrono

      Methods in java.time.chrono that return ZonedDateTime
      Modifier and Type 方法 描述
      ZonedDateTime IsoChronology.zonedDateTime​(Instant instant, ZoneId zone)
      从这个年龄从 Instant获得ISO Instant日期时间。
      ZonedDateTime IsoChronology.zonedDateTime​(TemporalAccessor temporal)
      从另一个日期时间对象获取ISO分区的日期时间。

    • Uses of ZonedDateTime in java.util

      Methods in java.util that return ZonedDateTime
      Modifier and Type 方法 描述
      ZonedDateTime GregorianCalendar.toZonedDateTime​()
      此目的是一个转换 ZonedDateTime ，表示基于时间线，因为这同一点 GregorianCalendar 。
      Methods in java.util with parameters of type ZonedDateTime
      Modifier and Type 方法 描述
      static GregorianCalendar GregorianCalendar.from​(ZonedDateTime zdt)
      获取的实例 GregorianCalendar从一个默认的语言环境 ZonedDateTime对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.ZoneId (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.ZoneId

  • Packages that use ZoneId
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of ZoneId in java.time

      Subclasses of ZoneId in java.time
      Modifier and Type Class 描述
      class  ZoneOffset
      与格林威治/ UTC的时区偏移量，如 +02:00 。
      Methods in java.time that return ZoneId
      Modifier and Type 方法 描述
      static ZoneId ZoneId.from​(TemporalAccessor temporal)
      从时间对象获取 ZoneId的实例。
      abstract ZoneId Clock.getZone​()
      获取用于创建日期和时间的时区。
      ZoneId ZonedDateTime.getZone​()
      获得时区，如“欧洲/巴黎”。
      ZoneId ZoneId.normalized​()
      规范时区ID，尽可能返回 ZoneOffset 。
      static ZoneId ZoneId.of​(String zoneId)
      从ID获取一个 ZoneId的实例，确保该ID有效并且可以使用。
      static ZoneId ZoneId.of​(String zoneId, Map<String,String> aliasMap)
      使用其ID来获取 ZoneId的实例，使用别名映射来补充标准区域ID。
      static ZoneId ZoneId.ofOffset​(String prefix, ZoneOffset offset)
      获取包含一个偏移量的 ZoneId的实例。
      static ZoneId ZoneId.systemDefault​()
      获取系统默认时区。
      Methods in java.time with parameters of type ZoneId
      Modifier and Type 方法 描述
      ZonedDateTime LocalDate.atStartOfDay​(ZoneId zone)
      根据时区中的规则，在最早的有效时间内从此日期返回划分的日期时间。
      ZonedDateTime Instant.atZone​(ZoneId zone)
      将此瞬间与时区相结合，创建一个 ZonedDateTime 。
      ZonedDateTime LocalDateTime.atZone​(ZoneId zone)
      将此日期时间与时区组合起来创建一个 ZonedDateTime 。
      ZonedDateTime OffsetDateTime.atZoneSameInstant​(ZoneId zone)
      将此日期时间与时区组合，创建一个 ZonedDateTime确保结果具有相同的时刻。
      ZonedDateTime OffsetDateTime.atZoneSimilarLocal​(ZoneId zone)
      将此日期时间与时区组合，以创建一个 ZonedDateTime试图保持相同的本地日期和时间。
      static Clock Clock.fixed​(Instant fixedInstant, ZoneId zone)
      获得始终返回相同时刻的时钟。
      static LocalDate LocalDate.now​(ZoneId zone)
      从指定时区的系统时钟获取当前日期。
      static LocalDateTime LocalDateTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的日期时间。
      static LocalTime LocalTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前时间。
      static MonthDay MonthDay.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的月日。
      static OffsetDateTime OffsetDateTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的日期时间。
      static OffsetTime OffsetTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前时间。
      static Year Year.now​(ZoneId zone)
      从指定时区的系统时钟获取当年。
      static YearMonth YearMonth.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的一个月。
      static ZonedDateTime ZonedDateTime.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的日期时间。
      static ZonedDateTime ZonedDateTime.of​(int year, int month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond, ZoneId zone)
      从年，月，日，时，分，秒，纳秒和时区获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.of​(LocalDate date, LocalTime time, ZoneId zone)
      从当地的日期和时间获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.of​(LocalDateTime localDateTime, ZoneId zone)
      从本地日期时间获取 ZonedDateTime的实例。
      static LocalDate LocalDate.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalDate的实例。
      static LocalDateTime LocalDateTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalDateTime的实例。
      static LocalTime LocalTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 LocalTime的实例。
      static OffsetDateTime OffsetDateTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 OffsetDateTime的实例。
      static OffsetTime OffsetTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant和区域ID获取 OffsetTime的实例。
      static ZonedDateTime ZonedDateTime.ofInstant​(Instant instant, ZoneId zone)
      从 Instant获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.ofInstant​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      从通过组合本地日期时间和偏移量形成的瞬间获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.ofLocal​(LocalDateTime localDateTime, ZoneId zone, ZoneOffset preferredOffset)
      从本地日期时间获取 ZonedDateTime的实例，如果可能，使用首选偏移量。
      static ZonedDateTime ZonedDateTime.ofStrict​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      获取 ZonedDateTime的实例，严格验证本地日期时间，偏移量和区域ID的组合。
      static Clock Clock.system​(ZoneId zone)
      获取使用最佳可用系统时钟返回当前即时的时钟。
      static Clock Clock.tickMillis​(ZoneId zone)
      获取时钟，使用最佳可用系统时钟返回当前瞬间滴答整数毫秒。
      static Clock Clock.tickMinutes​(ZoneId zone)
      获取时钟，使用最佳可用系统时钟在一分钟内返回当前瞬间滴答。
      static Clock Clock.tickSeconds​(ZoneId zone)
      获取时钟，使用最佳可用系统时钟在一秒钟内返回当前瞬间滴答作响。
      abstract Clock Clock.withZone​(ZoneId zone)
      以不同的时区返回此时钟的副本。
      ZonedDateTime ZonedDateTime.withZoneSameInstant​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，保留即时。
      ZonedDateTime ZonedDateTime.withZoneSameLocal​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。

    • Uses of ZoneId in java.time.chrono

      Methods in java.time.chrono that return ZoneId
      Modifier and Type 方法 描述
      ZoneId ChronoZonedDateTime.getZone​()
      获取区域ID，例如“欧洲/巴黎”。
      Methods in java.time.chrono with parameters of type ZoneId
      Modifier and Type | 方法 | 描述
      ChronoZonedDateTime<D> ChronoLocalDateTime.atZone​(ZoneId zone)
      将此时间与时区相结合，创建一个 ChronoZonedDateTime 。
      default ChronoLocalDate Chronology.dateNow​(ZoneId zone)
      从指定时区的系统时钟获取此时间顺序中的当前本地日期。
      HijrahDate | HijrahChronology.dateNow​(ZoneId zone)
      LocalDate IsoChronology.dateNow​(ZoneId zone)
      从指定时区的系统时钟获取当前的ISO本地日期。
      JapaneseDate | JapaneseChronology.dateNow​(ZoneId zone)
      MinguoDate | MinguoChronology.dateNow​(ZoneId zone)
      ThaiBuddhistDate | ThaiBuddhistChronology.dateNow​(ZoneId zone)
      static HijrahDate HijrahDate.now​(ZoneId zone)
      在指定的时区获得伊斯兰教Umm Al-Qura日历的当前 HijrahDate 。
      static JapaneseDate JapaneseDate.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的 JapaneseDate 。
      static MinguoDate MinguoDate.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的 MinguoDate 。
      static ThaiBuddhistDate ThaiBuddhistDate.now​(ZoneId zone)
      从指定时区的系统时钟获取当前的 ThaiBuddhistDate 。
      ChronoZonedDateTime<D> ChronoZonedDateTime.withZoneSameInstant​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，保留即时。
      ChronoZonedDateTime<D> ChronoZonedDateTime.withZoneSameLocal​(ZoneId zone)
      使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。
      default ChronoZonedDateTime<? extends ChronoLocalDate> Chronology.zonedDateTime​(Instant instant, ZoneId zone)
      获得 ChronoZonedDateTime在从这个年表 Instant 。
      ChronoZonedDateTime<HijrahDate> | HijrahChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ZonedDateTime IsoChronology.zonedDateTime​(Instant instant, ZoneId zone)
      从这个年龄从 Instant获得ISO Instant日期时间。
      ChronoZonedDateTime<JapaneseDate> | JapaneseChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<MinguoDate> | MinguoChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.zonedDateTime​(Instant instant, ZoneId zone)

    • Uses of ZoneId in java.time.format

      Methods in java.time.format that return ZoneId
      Modifier and Type 方法 描述
      ZoneId DateTimeFormatter.getZone​()
      获取在格式化期间使用的覆盖区域。
      Methods in java.time.format with parameters of type ZoneId
      Modifier and Type 方法 描述
      DateTimeFormatter DateTimeFormatter.withZone​(ZoneId zone)
      使用新的覆盖区域返回此格式化程序的副本。
      Method parameters in java.time.format with type arguments of type ZoneId
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendGenericZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将泛型时区名称（如“太平洋时间”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将时区名称（如“英国夏令时”）附加到格式化程序。

    • Uses of ZoneId in java.time.temporal

      Methods in java.time.temporal that return types with arguments of type ZoneId
      Modifier and Type 方法 描述
      static TemporalQuery<ZoneId> TemporalQueries.zone​()
      一个宽松的查询为 ZoneId ，回落到 ZoneOffset 。
      static TemporalQuery<ZoneId> TemporalQueries.zoneId​()
      严格查询 ZoneId 。

    • Uses of ZoneId in java.util

      Methods in java.util that return ZoneId
      Modifier and Type 方法 描述
      ZoneId TimeZone.toZoneId​()
      将此 TimeZone对象转换为 ZoneId 。
      Methods in java.util with parameters of type ZoneId
      Modifier and Type 方法 描述
      static TimeZone TimeZone.getTimeZone​(ZoneId zoneId)
      获取 TimeZone为给定 zoneId 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.ZoneOffset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.ZoneOffset

  • Packages that use ZoneOffset
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。

    • Uses of ZoneOffset in java.time

      Fields in java.time declared as ZoneOffset
      Modifier and Type Field 描述
      static ZoneOffset ZoneOffset.MAX
      最大支持偏移量的常数。
      static ZoneOffset ZoneOffset.MIN
      最小支持偏移量的常数。
      static ZoneOffset ZoneOffset.UTC
      UTC的时区偏移量，ID为“Z”。
      Methods in java.time that return ZoneOffset
      Modifier and Type 方法 描述
      static ZoneOffset ZoneOffset.from​(TemporalAccessor temporal)
      从时间对象获取一个 ZoneOffset的实例。
      ZoneOffset OffsetDateTime.getOffset​()
      获取区域偏移量，例如“+01：00”。
      ZoneOffset OffsetTime.getOffset​()
      获取区域偏移量，例如“+01：00”。
      ZoneOffset ZonedDateTime.getOffset​()
      获取区域偏移量，例如“+01：00”。
      static ZoneOffset ZoneOffset.of​(String offsetId)
      使用ID获取 ZoneOffset的实例。
      static ZoneOffset ZoneOffset.ofHours​(int hours)
      获取 ZoneOffset的实例，使用小时数的偏移量。
      static ZoneOffset ZoneOffset.ofHoursMinutes​(int hours, int minutes)
      获取 ZoneOffset的实例，以小时和分钟为 ZoneOffset使用偏移量。
      static ZoneOffset ZoneOffset.ofHoursMinutesSeconds​(int hours, int minutes, int seconds)
      获取 ZoneOffset的实例，使用小时，分和秒的偏移量。
      static ZoneOffset ZoneOffset.ofTotalSeconds​(int totalSeconds)
      获取 ZoneOffset的实例，指定总偏移量（以秒为单位）
      Methods in java.time with parameters of type ZoneOffset
      Modifier and Type 方法 描述
      OffsetDateTime Instant.atOffset​(ZoneOffset offset)
      将此瞬间与偏移组合，创建一个 OffsetDateTime 。
      OffsetDateTime LocalDateTime.atOffset​(ZoneOffset offset)
      将此日期时间与偏移量相结合，创建一个 OffsetDateTime 。
      OffsetTime LocalTime.atOffset​(ZoneOffset offset)
      结合这个时间与偏移创建一个 OffsetTime 。
      int ZoneOffset.compareTo​(ZoneOffset other)
      将此偏移量与其他偏移量按降序进行比较。
      static OffsetDateTime OffsetDateTime.of​(int year, int month, int dayOfMonth, int hour, int minute, int second, int nanoOfSecond, ZoneOffset offset)
      从年，月，日，小时，分，秒，纳秒和偏移中获取 OffsetDateTime的实例。
      static OffsetDateTime OffsetDateTime.of​(LocalDate date, LocalTime time, ZoneOffset offset)
      从日期，时间和偏移量获取 OffsetDateTime的实例。
      static OffsetDateTime OffsetDateTime.of​(LocalDateTime dateTime, ZoneOffset offset)
      从日期时间和偏移量获取 OffsetDateTime的实例。
      static OffsetTime OffsetTime.of​(int hour, int minute, int second, int nanoOfSecond, ZoneOffset offset)
      从一小时，分钟，秒和纳秒获取 OffsetTime的实例。
      static OffsetTime OffsetTime.of​(LocalTime time, ZoneOffset offset)
      从当地时间和偏移量获取 OffsetTime的实例。
      static LocalDateTime LocalDateTime.ofEpochSecond​(long epochSecond, int nanoOfSecond, ZoneOffset offset)
      使用从1970-01-01T00：00：00Z的时代开始的秒数获得 LocalDateTime的实例。
      static ZonedDateTime ZonedDateTime.ofInstant​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      从本地日期时间和偏移量组合形成的瞬间获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.ofLocal​(LocalDateTime localDateTime, ZoneId zone, ZoneOffset preferredOffset)
      从本地日期时间获取 ZonedDateTime的实例，如果可能，使用首选偏移量。
      static ZoneId ZoneId.ofOffset​(String prefix, ZoneOffset offset)
      获取一个封装偏移的实例 ZoneId 。
      static ZonedDateTime ZonedDateTime.ofStrict​(LocalDateTime localDateTime, ZoneOffset offset, ZoneId zone)
      获取 ZonedDateTime的实例，严格验证本地日期时间，偏移量和区域ID的组合。
      long LocalDate.toEpochSecond​(LocalTime time, ZoneOffset offset)
      将此 LocalDate转换为1970-01-01T00：00：00Z的时代以来的秒数。
      long LocalTime.toEpochSecond​(LocalDate date, ZoneOffset offset)
      将此 LocalTime转换为1970-01-01T00：00：00Z的时代以来的秒数。
      OffsetDateTime OffsetDateTime.withOffsetSameInstant​(ZoneOffset offset)
      以指定的偏移量返回此 OffsetDateTime的副本，确保结果处于同一时刻。
      OffsetTime OffsetTime.withOffsetSameInstant​(ZoneOffset offset)
      返回具有指定偏移量的 OffsetTime的副本，确保结果在隐含日期处于同一时刻。
      OffsetDateTime OffsetDateTime.withOffsetSameLocal​(ZoneOffset offset)
      返回具有指定偏移量的 OffsetDateTime的副本，确保结果具有相同的本地日期时间。
      OffsetTime OffsetTime.withOffsetSameLocal​(ZoneOffset offset)
      以指定的偏移量返回此 OffsetTime的副本，确保结果具有相同的本地时间。

    • Uses of ZoneOffset in java.time.chrono

      Methods in java.time.chrono that return ZoneOffset
      Modifier and Type 方法 描述
      ZoneOffset ChronoZonedDateTime.getOffset​()
      获取区域偏移量，例如“+01：00”。
      Methods in java.time.chrono with parameters of type ZoneOffset
      Modifier and Type 方法 描述
      default long Chronology.epochSecond​(int prolepticYear, int month, int dayOfMonth, int hour, int minute, int second, ZoneOffset zoneOffset)
      从1970-01-01T00：00：00Z的时期获取秒数。
      default long Chronology.epochSecond​(Era era, int yearOfEra, int month, int dayOfMonth, int hour, int minute, int second, ZoneOffset zoneOffset)
      从1970-01-01T00：00：00Z的时期获取秒数。
      long IsoChronology.epochSecond​(int prolepticYear, int month, int dayOfMonth, int hour, int minute, int second, ZoneOffset zoneOffset)
      从1970-01-01T00：00：00Z的时期获取秒数。
      default long ChronoLocalDateTime.toEpochSecond​(ZoneOffset offset)
      将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。
      default Instant ChronoLocalDateTime.toInstant​(ZoneOffset offset)
      将此日期时间转换为 Instant 。

    • Uses of ZoneOffset in java.time.temporal

      Methods in java.time.temporal that return types with arguments of type ZoneOffset
      Modifier and Type 方法 描述
      static TemporalQuery<ZoneOffset> TemporalQueries.offset​()
      对于 ZoneOffset的查询，如果找不到则返回null。

    • Uses of ZoneOffset in java.time.zone

      Methods in java.time.zone that return ZoneOffset
      Modifier and Type 方法 描述
      ZoneOffset ZoneRules.getOffset​(Instant instant)
      获得这些规则中指定时刻适用的偏移量。
      ZoneOffset ZoneRules.getOffset​(LocalDateTime localDateTime)
      在这些规则中为指定的本地日期时间获取适当的偏移量。
      ZoneOffset ZoneOffsetTransition.getOffsetAfter​()
      获得转换后的偏移量。
      ZoneOffset ZoneOffsetTransitionRule.getOffsetAfter​()
      获得转换后的偏移量。
      ZoneOffset ZoneOffsetTransition.getOffsetBefore​()
      在转换之前获取偏移量。
      ZoneOffset ZoneOffsetTransitionRule.getOffsetBefore​()
      在转换之前获取偏移量。
      ZoneOffset ZoneOffsetTransitionRule.getStandardOffset​()
      在转换时获得有效的标准偏移量。
      ZoneOffset ZoneRules.getStandardOffset​(Instant instant)
      获取此区域中指定时刻的标准偏移量。
      Methods in java.time.zone that return types with arguments of type ZoneOffset
      Modifier and Type 方法 描述
      List<ZoneOffset> ZoneRules.getValidOffsets​(LocalDateTime localDateTime)
      在这些规则中获取在指定的本地日期时间中适用的偏移量。
      Methods in java.time.zone with parameters of type ZoneOffset
      Modifier and Type 方法 描述
      LocalDateTime ZoneOffsetTransitionRule.TimeDefinition.createDateTime​(LocalDateTime dateTime, ZoneOffset standardOffset, ZoneOffset wallOffset)
      将指定的本地日期时间转换为挂钟上实际看到的本地日期时间。
      boolean ZoneOffsetTransition.isValidOffset​(ZoneOffset offset)
      在此转换期间检查指定的偏移是否有效。
      boolean ZoneRules.isValidOffset​(LocalDateTime localDateTime, ZoneOffset offset)
      检查偏移日期时间对于这些规则是否有效。
      static ZoneOffsetTransition ZoneOffsetTransition.of​(LocalDateTime transition, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义两个偏移之间的转换的实例。
      static ZoneOffsetTransitionRule ZoneOffsetTransitionRule.of​(Month month, int dayOfMonthIndicator, DayOfWeek dayOfWeek, LocalTime time, boolean timeEndOfDay, ZoneOffsetTransitionRule.TimeDefinition timeDefnition, ZoneOffset standardOffset, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义年度规则以在两个偏移之间创建转换的实例。
      static ZoneRules ZoneRules.of​(ZoneOffset offset)
      获取具有固定区域规则的ZoneRules实例。
      static ZoneRules ZoneRules.of​(ZoneOffset baseStandardOffset, ZoneOffset baseWallOffset, List<ZoneOffsetTransition> standardOffsetTransitionList, List<ZoneOffsetTransition> transitionList, List<ZoneOffsetTransitionRule> lastRules)
      获取ZoneRules的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


DateTimeFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.format

Class DateTimeFormatter

  • java.lang.Object
    • java.time.format.DateTimeFormatter

  • public final class DateTimeFormatter
extends Object
    格式化器用于打印和解析日期时间对象。

    该类提供打印和解析的主要应用程序入口点，并提供DateTimeFormatter常见实现：

    • 使用预定义的常量，如ISO_LOCAL_DATE
    • 使用图案字母，如uuuu-MMM-dd
    • 使用本地化样式，如long或medium

    更复杂的格式化程序由DateTimeFormatterBuilder提供。

    主要的日期时间类提供两种方法 - 一种用于格式化， format(DateTimeFormatter formatter) ，另一种用于解析， parse(CharSequence text, DateTimeFormatter formatter) 。

    例如：

      LocalDate date = LocalDate.now();
  String text = date.format(formatter);
  LocalDate parsedDate = LocalDate.parse(text, formatter);

    除格式之外，可以使用所需的区域设置，年表，ZoneId和DecimalStyle创建格式化程序。

    withLocale方法返回一个覆盖区域设置的新格式化程序。 区域设置影响格式化和解析的一些方面。 例如， ofLocalizedDate提供了一个使用特定于语言环境的日期格式的格式化程序。

    withChronology方法返回一个覆盖年表的新格式化程序。 如果被覆盖，则在格式化之前将日期时间值转换为年表。 在解析期间，返回日期时间值之前将其转换为年表。

    withZone方法返回一个覆盖该区域的新格式化程序。 如果被覆盖，日期时间值将在格式化之前转换为带有请求的ZoneId的ZonedDateTime。 在解析期间，在返回值之前应用ZoneId。

    withDecimalStyle方法返回一个新的格式化程序，覆盖DecimalStyle 。 DecimalStyle符号用于格式化和解析。

    某些应用程序可能需要使用较旧的java.text.Format类进行格式化。 toFormat()方法返回一个java.text.Format的实现。

    预定格式化器

    Predefined Formatters Formatter Description Example ofLocalizedDate(dateStyle) Formatter with date style from the locale '2011-12-03' ofLocalizedTime(timeStyle) Formatter with time style from the locale '10:15:30' ofLocalizedDateTime(dateTimeStyle) Formatter with a style for date and time from the locale '3 Jun 2008 11:05:30' ofLocalizedDateTime(dateStyle,timeStyle) Formatter with date and time styles from the locale '3 Jun 2008 11:05' BASIC_ISO_DATE Basic ISO date '20111203' ISO_LOCAL_DATE ISO Local Date '2011-12-03' ISO_OFFSET_DATE ISO Date with offset '2011-12-03+01:00' ISO_DATE ISO Date with or without offset '2011-12-03+01:00'; '2011-12-03' ISO_LOCAL_TIME Time without offset '10:15:30' ISO_OFFSET_TIME Time with offset '10:15:30+01:00' ISO_TIME Time with or without offset '10:15:30+01:00'; '10:15:30' ISO_LOCAL_DATE_TIME ISO Local Date and Time '2011-12-03T10:15:30' ISO_OFFSET_DATE_TIME Date Time with Offset 2011-12-03T10:15:30+01:00' ISO_ZONED_DATE_TIME Zoned Date Time '2011-12-03T10:15:30+01:00[Europe/Paris]' ISO_DATE_TIME Date and time with ZoneId '2011-12-03T10:15:30+01:00[Europe/Paris]' ISO_ORDINAL_DATE Year and day of year '2012-337' ISO_WEEK_DATE Year and Week 2012-W48-6' ISO_INSTANT Date and Time of an Instant '2011-12-03T10:15:30Z' RFC_1123_DATE_TIME RFC 1123 / RFC 822 'Tue, 3 Jun 2008 11:05:30 GMT'

    格式和解析模式

    模式基于简单的字母和符号序列。 使用模式使用ofPattern(String)和ofPattern(String, Locale)方法创建格式化程序 。 例如， "d MMM uuuu"将格式为2011-12-03，为“2011年12月3日”。 从模式创建的格式化程序可以根据需要多次使用，它是不可变的并且是线程安全的。

    例如：

      LocalDate date = LocalDate.now();
  DateTimeFormatter formatter = DateTimeFormatter.ofPattern("yyyy MM dd");
  String text = date.format(formatter);
  LocalDate parsedDate = LocalDate.parse(text, formatter);

    所有字母“A”至“Z”和“a”至“z”保留为图案字母。 定义了以下图案字母：

      Symbol  Meaning                     Presentation      Examples
  ------  -------                     ------------      -------
   G       era                         text              AD; Anno Domini; A
   u       year                        year              2004; 04
   y       year-of-era                 year              2004; 04
   D       day-of-year                 number            189
   M/L     month-of-year               number/text       7; 07; Jul; July; J
   d       day-of-month                number            10
   g       modified-julian-day         number            2451334

   Q/q     quarter-of-year             number/text       3; 03; Q3; 3rd quarter
   Y       week-based-year             year              1996; 96
   w       week-of-week-based-year     number            27
   W       week-of-month               number            4
   E       day-of-week                 text              Tue; Tuesday; T
   e/c     localized day-of-week       number/text       2; 02; Tue; Tuesday; T
   F       day-of-week-in-month        number            3

   a       am-pm-of-day                text              PM
   h       clock-hour-of-am-pm (1-12)  number            12
   K       hour-of-am-pm (0-11)        number            0
   k       clock-hour-of-day (1-24)    number            24

   H       hour-of-day (0-23)          number            0
   m       minute-of-hour              number            30
   s       second-of-minute            number            55
   S       fraction-of-second          fraction          978
   A       milli-of-day                number            1234
   n       nano-of-second              number            987654321
   N       nano-of-day                 number            1234000000

   V       time-zone ID                zone-id           America/Los_Angeles; Z; -08:30
   v       generic time-zone name      zone-name         Pacific Time; PT
   z       time-zone name              zone-name         Pacific Standard Time; PST
   O       localized zone-offset       offset-O          GMT+8; GMT+08:00; UTC-08:00
   X       zone-offset 'Z' for zero    offset-X          Z; -08; -0830; -08:30; -083015; -08:30:15
   x       zone-offset                 offset-x          +0000; -08; -0830; -08:30; -083015; -08:30:15
   Z       zone-offset                 offset-Z          +0000; -0800; -08:00

   p       pad next                    pad modifier      1

   '       escape for text             delimiter
   ''      single quote                literal           '
   [       optional section start
   ]       optional section end
   #       reserved for future use
   {       reserved for future use
   }       reserved for future use

    模式字母的数量决定了格式。

    文本 ：文字样式是根据所使用的图案字母数确定的。 少于4个图案字母将使用short form 。 完全4个图案字母将使用full form 。 完全5个图案字母将使用narrow form 。 图案字母'L'，'c'和'q'指定文本样式的独立形式。

    编号 ：如果字母数为1，则使用最小位数输出该值，而不填充。 否则，使用数字计数作为输出字段的宽度，根据需要使用零填充值。 以下模式字母对字母数的约束。 只能指定'c'和'F'的一个字母。 可以指定多达两个'd'，'H'，'h'，'K'，'k'，'m'和's'的字母。 最多可以指定三个字母'D'。

    数字/文本 ：如果模式字母的数量为3或更大，请使用上述文本规则。 否则使用上面的数字规则。

    分数 ：输出二分之一纳秒的场。 纳秒值有九位数，因此模式字母的计数从1到9.如果小于9，那么纳秒值将被截断，只有最高有效位被输出。

    年份 ：字母数确定使用最小字段宽度低于哪个填充。 如果字母数为2，则使用两位数字的reduced 。 对于打印，这将输出最右边的两位数字。 对于解析，这将使用基数值2000解析，导致一年在2000到2099之间的范围内。 如果字母数小于四（但不是两个），则符号只能按照SignStyle.NORMAL输出为负数。 否则，如果超过了垫宽，则输出符号，如SignStyle.EXCEEDS_PAD所示 。

    ZoneId ：输出时区ID，如“Europe / Paris”。 如果字母数为2，则输出时区ID。 任何其他字母数字抛出IllegalArgumentException 。

    区域名称 ：输出时区ID的显示名称。 如果模式字母为“z”，则输出为夏令时感知区域名称。 如果没有足够的信息来确定是否适用DST，则将使用忽略夏令时的名称。 如果字母数为1，2或3，则输出短名称。 如果字母数为4，则输出全名。 五个或更多的字母抛出IllegalArgumentException 。

    如果模式字母为“v”，输出将提供忽略夏令时的区域名称。 如果字母数为1，则输出短名称。 如果字母数为4，则输出全名。 二，三，五个以上的字母抛出IllegalArgumentException 。

    偏移X和x ：这将根据模式字母的数量格式化偏移量。 一个字母只输出小时，例如“+01”，除非分钟不为零，在这种情况下也输出分钟，例如“+0130”。 两个字母输出小时和分钟，没有冒号，例如'+0130'。 三个字母输出小时和分钟，冒号如“+01：30”。 四个字母输出小时和分钟，可选第二个，没有冒号，例如'+013015'。 五个字母输出小时和分钟，可选第二个，冒号如“+01：30：15”。 六个或更多的字母抛出IllegalArgumentException 。 当要输出的偏移量为零时，模式字母“X”（大写）将输出“Z”，而模式字母“x”（小写）将输出“+00”，“+0000”或“+00 ：00' 。

    偏移量O ：根据模式字母的数量格式化局部偏移量。 一个字母输出局部偏移量的short形式，它是局部偏移文本，例如'GMT'，小时没有前导零，可选的2位数分钟和秒（如果非零），冒号，例如'GMT + 8 ”。 四个字母输出full表单，它是本地化的偏移文本，例如'GMT，具有2位小时和分钟字段，可选的第二个字段（如果非零），冒号，例如'GMT + 08：00'。 任何其他字母数字抛出IllegalArgumentException 。

    偏移Z ：根据模式字母的数量格式化偏移量。 一个，两个或三个字母输出小时和分钟，没有冒号，例如'+0130'。 当偏移为零时，输出将为“+0000”。 四个字母输出full形式的局部偏移量，相当于Offset-O的四个字母。 如果偏移为零，输出将为相应的局部偏移文本。 五个字母输出小时，分钟，可选第二个（如果非零），冒号。 如果偏移为零，则输出“Z”。 六个或更多的字母抛出IllegalArgumentException 。

    可选部分 ：可选部分标记与调用DateTimeFormatterBuilder.optionalStart()和DateTimeFormatterBuilder.optionalEnd()完全一样。

    垫修饰符 ：修改紧随其后的模式以填充空格。 垫宽度由图案字母的数量决定。 这与拨打DateTimeFormatterBuilder.padNext(int)相同。

    例如，'ppH'输出在左边填充空格的宽度为2的小时。

    任何无法识别的字母都是错误。 除'['，']'，'{'，'}'，'＃'和单引号之外的任何非字母字符都将直接输出。 尽管如此，建议对要直接输出的所有字符使用单引号，以确保将来的更改不会破坏您的应用程序。

    解决

    解析实现为两阶段操作。 首先，使用格式化程序定义的布局解析文本，产生一个Map的字段值，一个ZoneId和一个Chronology 。 第二，通过验证，组合和简化各种领域，使解析的数据得到解决 。

    这个类提供了五种解析方法。 其中四个执行解析和解析阶段。 第五种方法， parseUnresolved(CharSequence, ParsePosition) ，只执行第一阶段，留下结果未解决。 因此，它本质上是一个低级别的操作。

    解析阶段由这个类设置的两个参数控制。

    ResolverStyle是一个枚举，提供三种不同的方法，严格，聪明和宽松。 智能选项是默认值。 可以使用withResolverStyle(ResolverStyle)设置。

    withResolverFields(TemporalField...)参数允许在解析开始之前对要解析的字段进行过滤。 例如，如果格式化程序已经解析了一年，一个月，一个月的日子和一天，那么有两种方法可以解决一个日期：（年+月+月 - 日）和（年+天的年）。 解析器字段允许选择两种方法之一。 如果没有设置解析器字段，则两种方法都必须产生相同的日期。

    解决单独的字段以形成完整的日期和时间是一个复杂的过程，其行为分布在多个类中。 它遵循这些步骤：

    1. 年表是确定的。 结果的年表是被解析的年表，或者如果没有按时间顺序被解析，那么这个时间顺序是在这个类上设置的，或者如果是null，那么是IsoChronology 。
    2. ChronoField日期字段已解决。 这是使用Chronology.resolveDate(Map, ResolverStyle)实现的。 有关现场解析的文档位于Chronology的实现中。
    3. ChronoField时间字段已解决。 这在ChronoField记录，并且对于所有年表是相同的。
    4. 任何不是ChronoField字段都被处理。 这是使用TemporalField.resolve(Map, TemporalAccessor, ResolverStyle)实现的。 关于现场解析的文件位于TemporalField的实施。
    5. ChronoField日期和时间字段被重新解析。 这允许第四步中的字段产生ChronoField值，并将它们处理为日期和时间。
    6. 如果至少有一小时可用，则形成A LocalTime 。 这涉及提供分秒，秒和秒的分数的默认值。
    7. 任何剩余的未解决的字段与已解决的任何日期和/或时间进行交叉检查。 因此，较早的阶段将解决（年+月+月的日）到一个日期，这个阶段将检查星期几是有效的日期。
    8. 如果excess number of days被解析，那么如果有可用的日期，则将其添加到日期。
    9. 如果存在第二个字段，但LocalTime未被解析，那么解析器确保毫微秒和微秒的值可以满足ChronoField的合同。 如果丢失，这些将被设置为零。
    10. 如果解析了日期和时间，并且存在偏移或区域，则创建字段ChronoField.INSTANT_SECONDS 。 如果偏移量被解析，则偏移量将与LocalDateTime组合以形成瞬间，任何区域被忽略。 如果ZoneId未经偏移，则区分析将与合并LocalDateTime ，形成利用规则瞬间ChronoLocalDateTime.atZone(ZoneId) 。
    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static DateTimeFormatter BASIC_ISO_DATE
      格式化或解析没有偏移量的日期的ISO日期格式化程序，例如“20111203”。
      static DateTimeFormatter ISO_DATE
      ISO日期格式化程序格式化或解析具有偏移量的日期（如可用），如“2011-12-03”或“2011-12-03 + 01：00”。
      static DateTimeFormatter ISO_DATE_TIME
      类似ISO的日期格式化程序，用于格式化或解析具有偏移量和区域（如果有的话）的日期时间，如“2011-12-03T10：15：30”，“2011-12-03T10：15：30 + 01” ：00'或'2011-12-03T10：15：30 + 01：00 [欧洲/巴黎]'。
      static DateTimeFormatter ISO_INSTANT
      ISO即时格式化程序，用于格式化或解析UTC中的即时消息，例如“2011-12-03T10：15：30Z”。
      static DateTimeFormatter ISO_LOCAL_DATE
      ISO日期格式化程序格式化或解析没有偏移量的日期，如“2011-12-03”。
      static DateTimeFormatter ISO_LOCAL_DATE_TIME
      ISO日期格式化程序格式化或解析没有偏移量的日期时间，例如“2011-12-03T10：15：30”。
      static DateTimeFormatter ISO_LOCAL_TIME
      ISO时间格式化程序格式化或解析一个没有偏移量的时间，例如“10：15”或“10：15：30”。
      static DateTimeFormatter ISO_OFFSET_DATE
      ISO日期格式化程序格式化或解析具有偏移量的日期，例如“2011-12-03 + 01：00”。
      static DateTimeFormatter ISO_OFFSET_DATE_TIME
      ISO日期格式化程序格式化或解析具有偏移量的日期时间，例如“2011-12-03T10：15：30 + 01：00”。
      static DateTimeFormatter ISO_OFFSET_TIME
      格式化或解析时间偏移的ISO时间格式化程序，例如“10：15 + 01：00”或“10：15：30 + 01：00”。
      static DateTimeFormatter ISO_ORDINAL_DATE
      ISO日期格式化程序格式化或解析没有偏移量的序数日期，例如“2012-337”。
      static DateTimeFormatter ISO_TIME
      格式化或解析时间的ISO时间格式化程序，如果可用的偏移量，如“10：15”，“10：15：30”或“10：15：30 + 01：00”。
      static DateTimeFormatter ISO_WEEK_DATE
      ISO日期格式化程序，用于格式化或解析不带偏移量的基于周的日期，例如“2012-W48-6”。
      static DateTimeFormatter ISO_ZONED_DATE_TIME
      类似ISO的日期格式化程序，用于格式化或解析具有偏移和区域的日期时间，例如“2011-12-03T10：15：30 + 01：00 [Europe / Paris]”。
      static DateTimeFormatter RFC_1123_DATE_TIME
      RFC-1123日期格式化程序，如“星期二，2008年6月3日11:05:30 GMT”。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String format​(TemporalAccessor temporal)
      使用此格式化程序格式化日期时间对象。
      void formatTo​(TemporalAccessor temporal, Appendable appendable)
      使用此格式化程序将日期时间对象格式化为 Appendable 。
      Chronology getChronology​()
      获得在格式化期间使用的压倒一记的年表。
      DecimalStyle getDecimalStyle​()
      获取在格式化期间使用的DecimalStyle。
      Locale getLocale​()
      获取格式化期间要使用的区域设置。
      Set<TemporalField> getResolverFields​()
      获取在解析期间使用的解析器字段。
      ResolverStyle getResolverStyle​()
      获取在解析过程中使用的解析器样式。
      ZoneId getZone​()
      获取在格式化期间使用的覆盖区域。
      static DateTimeFormatter ofLocalizedDate​(FormatStyle dateStyle)
      返回ISO年表的区域设置特定日期格式。
      static DateTimeFormatter ofLocalizedDateTime​(FormatStyle dateTimeStyle)
      返回ISO时代的区域设置特定的日期时间格式化程序。
      static DateTimeFormatter ofLocalizedDateTime​(FormatStyle dateStyle, FormatStyle timeStyle)
      返回ISO时代的特定日期和时间格式。
      static DateTimeFormatter ofLocalizedTime​(FormatStyle timeStyle)
      返回ISO时代的区域设置特定时间格式。
      static DateTimeFormatter ofPattern​(String pattern)
      使用指定的模式创建格式化程序。
      static DateTimeFormatter ofPattern​(String pattern, Locale locale)
      使用指定的模式和区域设置创建格式化程序。
      TemporalAccessor parse​(CharSequence text)
      完全解析产生时间对象的文本。
      TemporalAccessor parse​(CharSequence text, ParsePosition position)
      使用此格式化器解析文本，提供对文本位置的控制。
      <T> T parse​(CharSequence text, TemporalQuery<T> query)
      完全解析产生指定类型对象的文本。
      TemporalAccessor parseBest​(CharSequence text, TemporalQuery<?>... queries)
      完全解析产生指定类型之一的对象的文本。
      static TemporalQuery<Period> parsedExcessDays​()
      一个查询，可以访问已解析的多余天数。
      static TemporalQuery<Boolean> parsedLeapSecond​()
      提供访问是否解析了跨越秒的查询。
      TemporalAccessor parseUnresolved​(CharSequence text, ParsePosition position)
      使用此格式化程序解析文本，而无需解析结果，用于高级用例。
      Format toFormat​()
      将此格式化程序作为 java.text.Format实例返回。
      Format toFormat​(TemporalQuery<?> parseQuery)
      将此格式化器返回为 java.text.Format实例，将使用指定的查询进行解析。
      String toString​()
      返回底层格式化程序的描述。
      DateTimeFormatter withChronology​(Chronology chrono)
      使用新的覆盖年表返回此格式化程序的副本。
      DateTimeFormatter withDecimalStyle​(DecimalStyle decimalStyle)
      使用新的DecimalStyle返回此格式化程序的副本。
      DateTimeFormatter withLocale​(Locale locale)
      使用新的语言环境返回此格式化程序的副本。
      DateTimeFormatter withResolverFields​(TemporalField... resolverFields)
      使用一组新的解析器字段返回此格式化程序的副本。
      DateTimeFormatter withResolverFields​(Set<TemporalField> resolverFields)
      使用一组新的解析器字段返回此格式化程序的副本。
      DateTimeFormatter withResolverStyle​(ResolverStyle resolverStyle)
      使用新的解析器样式返回此格式化程序的副本。
      DateTimeFormatter withZone​(ZoneId zone)
      使用新的覆盖区域返回此格式化程序的副本。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ISO_LOCAL_DATE

        public static final DateTimeFormatter ISO_LOCAL_DATE
        ISO日期格式化程序格式化或解析没有偏移量的日期，如“2011-12-03”。

        这将返回一个不可变形的格式化程序，能够格式化和解析ISO-8601扩展的本地日期格式。 格式包括：

        • year的四位数以上。 在0000到9999之间的年份将被预填零，以确保四位数。 超出该范围的年份将有一个前缀的正或负符号。
        • 一个破折号
        • month-of-year的两位数字。 这被预填充为零以确保两位数字。
        • 一个破折号
        • day-of-month的两位数字。 这被预填充为零以确保两位数字。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • ISO_OFFSET_DATE

        public static final DateTimeFormatter ISO_OFFSET_DATE
        ISO日期格式化程序格式化或解析具有偏移量的日期，例如“2011-12-03 + 01：00”。

        这将返回一个能够格式化和解析ISO-8601扩展偏移日期格式的不可变格式器。 格式包括：

        • ISO_LOCAL_DATE
        • offset ID 。 如果偏移量有秒，那么即使这不是ISO-8601标准的一部分，它们将被处理。 解析不区分大小写。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • ISO_DATE

        public static final DateTimeFormatter ISO_DATE
        ISO日期格式化程序格式化或解析具有偏移量的日期（如可用），如“2011-12-03”或“2011-12-03 + 01：00”。

        这将返回一个不可变形的格式化程序，能够格式化和解析ISO-8601扩展日期格式。 格式包括：

        • ISO_LOCAL_DATE
        • 如果偏移不可用，则格式完成。
        • offset ID 。 如果偏移量有秒，那么即使这不是ISO-8601标准的一部分，它们将被处理。 解析不区分大小写。

        由于此格式化程序具有可选元素，因此可能需要使用parseBest(java.lang.CharSequence, java.time.temporal.TemporalQuery<?>...)进行解析。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • ISO_LOCAL_TIME

        public static final DateTimeFormatter ISO_LOCAL_TIME
        ISO时间格式化程序格式化或解析一个没有偏移量的时间，例如“10：15”或“10：15：30”。

        这将返回一个不可变形的格式化器，能够格式化和解析ISO-8601扩展的本地时间格式。 格式包括：

        • hour-of-day的两位数字。 这被预填充为零以确保两位数字。
        • 一个冒号
        • 两位数字为minute-of-hour 。 这被预填充为零以确保两位数字。
        • 如果第二分钟不可用，则格式完成。
        • 一个冒号
        • 两位数字为second-of-minute 。 这被预填充为零以确保两位数字。
        • 如果纳秒是零或不可用，则格式完成。
        • 小数点
        • 一到九位数为nano-of-second 。 根据需要输出多个数字。

        返回的格式化程序没有覆盖年表或区域。 它使用STRICT解析器风格。

      • ISO_OFFSET_TIME

        public static final DateTimeFormatter ISO_OFFSET_TIME
        格式化或解析时间偏移的ISO时间格式化程序，例如“10：15 + 01：00”或“10：15：30 + 01：00”。

        这将返回能够格式化和解析ISO-8601扩展偏移时间格式的不可变格式器。 格式包括：

        • ISO_LOCAL_TIME
        • offset ID 。 如果偏移量有秒，那么即使这不是ISO-8601标准的一部分，它们将被处理。 解析不区分大小写。

        返回的格式化程序没有覆盖年表或区域。 它使用STRICT解析器风格。

      • ISO_TIME

        public static final DateTimeFormatter ISO_TIME
        格式化或解析时间的ISO时间格式化程序，如果可用的偏移量，如“10：15”，“10：15：30”或“10：15：30 + 01：00”。

        这将返回能够格式化和解析ISO-8601扩展偏移时间格式的不可变格式器。 格式包括：

        • ISO_LOCAL_TIME
        • 如果偏移不可用，则格式完成。
        • offset ID 。 如果偏移量有秒，那么即使这不是ISO-8601标准的一部分，它们将被处理。 解析不区分大小写。

        由于此格式化程序具有可选元素，因此可能需要使用parseBest(java.lang.CharSequence, java.time.temporal.TemporalQuery<?>...)进行解析。

        返回的格式化程序没有覆盖年表或区域。 它使用STRICT解析器风格。

      • ISO_LOCAL_DATE_TIME

        public static final DateTimeFormatter ISO_LOCAL_DATE_TIME
        ISO日期格式化程序格式化或解析没有偏移量的日期时间，例如“2011-12-03T10：15：30”。

        这将返回一个不可变形的格式化器，能够格式化和解析ISO-8601扩展偏移日期时间格式。 格式包括：

        • ISO_LOCAL_DATE
        • 字母“T”。 解析不区分大小写。
        • ISO_LOCAL_TIME

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • ISO_OFFSET_DATE_TIME

        public static final DateTimeFormatter ISO_OFFSET_DATE_TIME
        ISO日期格式化程序格式化或解析具有偏移量的日期时间，例如“2011-12-03T10：15：30 + 01：00”。

        这将返回一个不可变形的格式化器，能够格式化和解析ISO-8601扩展偏移日期时间格式。 格式包括：

        • ISO_LOCAL_DATE_TIME
        • offset ID 。 如果偏移量有秒，那么即使这不是ISO-8601标准的一部分，它们将被处理。 偏移解析是宽松的，这允许分钟和秒是可选的。 解析不区分大小写。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • ISO_ZONED_DATE_TIME

        public static final DateTimeFormatter ISO_ZONED_DATE_TIME
        类似ISO的日期格式化程序，用于格式化或解析具有偏移和区域的日期时间，例如“2011-12-03T10：15：30 + 01：00 [Europe / Paris]”。

        这将返回一个不可变的格式化程序，能够格式化和解析扩展ISO-8601扩展偏移日期时间格式的格式来添加时区。 方括号中的部分不属于ISO-8601标准。 格式包括：

        • ISO_OFFSET_DATE_TIME
        • 如果区域ID不可用或是ZoneOffset则格式已完成。
        • 一个开放的方括号'['。
        • zone ID 。 这不是ISO-8601标准的一部分。 解析区分大小写。
        • 一个近方括号']'。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • ISO_DATE_TIME

        public static final DateTimeFormatter ISO_DATE_TIME
        类似ISO的日期格式化程序，用于格式化或解析具有偏移量和区域（如果有的话）的日期时间，如“2011-12-03T10：15：30”，“2011-12-03T10：15：30 + 01” ：00'或'2011-12-03T10：15：30 + 01：00 [欧洲/巴黎]'。

        这将返回一个不可变形的格式化程序，能够格式化和解析ISO-8601扩展本地或偏移日期时间格式，以及指定时区的扩展非ISO格式。 格式包括：

        • ISO_LOCAL_DATE_TIME
        • 如果偏移量不可用于格式化或解析，则格式完成。
        • offset ID 。 如果偏移量有秒，那么即使这不是ISO-8601标准的一部分，它们将被处理。
        • 如果区域ID不可用或是ZoneOffset则格式已完成。
        • 一个开放的方括号'['。
        • zone ID 。 这不是ISO-8601标准的一部分。 解析区分大小写。
        • 一个近方括号']'。

        由于此格式化程序具有可选元素，因此可能需要使用parseBest(java.lang.CharSequence, java.time.temporal.TemporalQuery<?>...)进行解析。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • ISO_ORDINAL_DATE

        public static final DateTimeFormatter ISO_ORDINAL_DATE
        ISO日期格式化程序格式化或解析没有偏移量的序数日期，例如“2012-337”。

        这将返回一个不可变形格式化器，能够格式化和解析ISO-8601扩展序数日期格式。 格式包括：

        • year的四位数以上。 在0000到9999之间的年份将被预填零，以确保四位数。 超出该范围的年份将有一个前缀的正或负符号。
        • 一个破折号
        • 三位数字为day-of-year 。 这被预填充为零以确保三位数字。
        • 如果偏移量不可用于格式化或解析，则格式完成。
        • offset ID 。 如果偏移量有秒，那么即使这不是ISO-8601标准的一部分，它们将被处理。 解析不区分大小写。

        由于此格式化程序具有可选元素，因此可能需要使用parseBest(java.lang.CharSequence, java.time.temporal.TemporalQuery<?>...)进行解析。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • ISO_WEEK_DATE

        public static final DateTimeFormatter ISO_WEEK_DATE
        ISO日期格式化程序，用于格式化或解析不带偏移量的基于周的日期，例如“2012-W48-6”。

        这将返回一个不可变的格式化程序，能够格式化和解析ISO-8601延伸的基于周的日期格式。 格式包括：

        • week-based-year四位数以上。 在0000到9999之间的年份将被预填零，以确保四位数。 超出该范围的年份将有一个前缀的正或负符号。
        • 一个破折号
        • 字母“W”。 解析不区分大小写。
        • week-of-week-based-year的两位数字。 这被预填充为零以确保三位数字。
        • 一个破折号
        • 一位数字为day-of-week 。 价值从星期一（1）到星期日（7）。
        • 如果偏移量不可用于格式化或解析，则格式完成。
        • offset ID 。 如果偏移量有秒，那么即使这不是ISO-8601标准的一部分，它们将被处理。 解析不区分大小写。

        由于此格式化程序具有可选元素，因此可能需要使用parseBest(java.lang.CharSequence, java.time.temporal.TemporalQuery<?>...)进行解析。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • ISO_INSTANT

        public static final DateTimeFormatter ISO_INSTANT
        ISO即时格式化程序，用于格式化或解析UTC中的即时消息，例如“2011-12-03T10：15：30Z”。

        这将返回能够格式化和解析ISO-8601即时格式的不可变格式化程序。 格式化时，总是输出第二分钟。 根据需要，毫微秒输出零，三，六或九位数字。 解析时，至少需要秒字段的时间。 解析从0到9的小数秒。 不使用本地化的十进制格式。

        这是一个特殊情况格式化程序，旨在允许Instant的人类可读形式。 Instant课程旨在仅代表一个时间点，内部存储从1970-01-01Z固定时期的纳秒值。 因此， Instant不能格式化为日期或时间，而不提供某种形式的时区。 该格式化程序允许Instant格式化，通过使用ZoneOffset.UTC提供合适的转换。

        格式包括：

        • ISO_OFFSET_DATE_TIME其中即时转换为ChronoField.INSTANT_SECONDS和ChronoField.NANO_OF_SECOND，使用UTC偏移量。 解析不区分大小写。

        返回的格式化程序没有覆盖年表或区域。 它使用STRICT解析器样式。

      • BASIC_ISO_DATE

        public static final DateTimeFormatter BASIC_ISO_DATE
        格式化或解析没有偏移量的日期的ISO日期格式化程序，例如“20111203”。

        这将返回一个不可变形的格式化程序，能够格式化和解析ISO-8601基本本地日期格式。 格式包括：

        • year的四位数字。 只支持在0000到9999的范围内。
        • month-of-year的两位数字。 这被预填充为零以确保两位数字。
        • day-of-month的两位数字。 这被预填充为零以确保两位数字。
        • 如果偏移量不可用于格式化或解析，则格式完成。
        • offset ID没有冒号。 如果偏移量有秒，那么即使这不是ISO-8601标准的一部分，它们将被处理。 偏移解析是宽松的，这允许分钟和秒是可选的。 解析不区分大小写。

        由于此格式化程序具有可选元素，因此可能需要使用parseBest(java.lang.CharSequence, java.time.temporal.TemporalQuery<?>...)进行解析。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用STRICT解析器样式。

      • RFC_1123_DATE_TIME

        public static final DateTimeFormatter RFC_1123_DATE_TIME
        RFC-1123日期格式化程序，如“星期二，2008年6月3日11:05:30 GMT”。

        这返回一个不可变的格式化器，能够格式化和解析大部分的RFC-1123格式。 RFC-1123更新RFC-822将年份从两位数更改为四位。 该实施需要四位数的年份。 这种实施也不会处理北美或军区的名称，只有'GMT'和偏移量。

        格式包括：

        • 如果星期几不可用于格式化或解析，然后跳到月份。
        • 三个字母day-of-week英文
        • 一个逗号
        • 一个空间
        • day-of-month的一位或两位数字。
        • 一个空间
        • 三个字母month-of-year英文。
        • 一个空间
        • year的四位数字。 只支持在0000到9999的范围内。
        • 一个空间
        • hour-of-day的两位数字。 这被预填充为零以确保两位数字。
        • 一个冒号
        • 两位数字为minute-of-hour 。 这被预填充为零以确保两位数字。
        • 如果第二分钟不可用，则跳转到下一个空格。
        • 一个冒号
        • second-of-minute的两位数字。 这被预填充为零以确保两位数字。
        • 一个空间
        • offset ID没有冒号或秒钟。 零偏移使用“GMT”。 北美地区名称和军区名称不予处理。

        解析不区分大小写。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用SMART解析器样式。

    • 方法详细信息

      • ofPattern

        public static DateTimeFormatter ofPattern​(String pattern)
        使用指定的模式创建格式化程序。

        该方法将基于类文档中描述的简单的pattern of letters and symbols创建一个格式化程序。 例如， d MMM uuuu将格式为2011-12-03，为“2011年12月3日”。

        格式化程序将使用default FORMAT locale 。 这可以使用withLocale(Locale)在返回的格式化器上更改或者使用此方法的ofPattern(String, Locale)变体。

        返回的格式化程序没有覆盖年表或区域。 它使用SMART解析器风格。

        参数
        pattern - 要使用的模式，不为空
        结果
        格式化程序基于模式，不为空
        异常
        IllegalArgumentException - 如果模式无效
        另请参见：
        DateTimeFormatterBuilder.appendPattern(String)

      • ofPattern

        public static DateTimeFormatter ofPattern​(String pattern,
                                          Locale locale)
        使用指定的模式和区域设置创建格式化程序。

        该方法将基于类文档中所述的简单的pattern of letters and symbols创建一个格式化程序。 例如， d MMM uuuu将格式为2011-12-03，为“2011年12月3日”。

        格式化程序将使用指定的区域设置。 这可以使用返回的格式化程序上的withLocale(Locale)进行更改

        返回的格式化程序没有覆盖年表或区域。 它使用SMART解析器风格。

        参数
        pattern - 使用的模式，不为空
        locale - 要使用的语言环境，不为空
        结果
        格式化程序基于模式，不为空
        异常
        IllegalArgumentException - 如果模式无效
        另请参见：
        DateTimeFormatterBuilder.appendPattern(String)

      • ofLocalizedDate

        public static DateTimeFormatter ofLocalizedDate​(FormatStyle dateStyle)
        返回ISO年表的区域设置特定日期格式。

        这将返回格式化程序，以格式化或解析日期。 所使用的确切格式模式因地区而异。

        区域设置是从格式化程序确定的。 该方法直接返回的格式化程序将使用default FORMAT locale 。 可以使用withLocale(Locale)对该方法的结果进行控制。

        请注意，本地化模式被懒惰地查找。 这个DateTimeFormatter拥有所需的风格和语言环境，查找需要的模式。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用SMART解析器样式。

        参数
        dateStyle - 获取格式化程序样式，不为null
        结果
        日期格式化程序，不为null

      • ofLocalizedTime

        public static DateTimeFormatter ofLocalizedTime​(FormatStyle timeStyle)
        返回ISO时代的区域设置特定时间格式。

        这将返回一个格式化程序，用于格式化或解析一个时间。 所使用的确切格式模式因地区而异。

        区域设置是从格式化程序确定的。 该方法直接返回的格式化程序将使用default FORMAT locale 。 该方法的结果可以使用withLocale(Locale)控制本地区域。

        请注意，本地化模式被懒惰地查找。 这个DateTimeFormatter拥有所需的风格和语言环境，查找需要的模式。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用SMART解析器样式。 FULL和LONG样式通常需要时区。 使用这些样式进行格式化时， ZoneId必须使用ZonedDateTime或withZone(java.time.ZoneId) 。

        参数
        timeStyle - 获取格式化程序样式，不为null
        结果
        时间格式化，不为空

      • ofLocalizedDateTime

        public static DateTimeFormatter ofLocalizedDateTime​(FormatStyle dateTimeStyle)
        返回ISO时代的区域设置特定的日期时间格式化程序。

        这将返回格式化程序，以格式化或解析日期时间。 所使用的确切格式模式因地区而异。

        区域设置是从格式化程序确定的。 通过此方法直接返回的格式化程序将使用default FORMAT locale 。 可以使用withLocale(Locale)对该方法的结果进行控制。

        请注意，本地化模式被懒惰地查找。 这个DateTimeFormatter拥有所需的风格和语言环境，查找需要的模式。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用SMART解析器样式。 FULL和LONG样式通常需要时区。 使用这些样式格式化时， ZoneId必须使用ZonedDateTime或withZone(java.time.ZoneId) 。

        参数
        dateTimeStyle - 格式化器样式获取，不为null
        结果
        日期时间格式化程序，不为空

      • ofLocalizedDateTime

        public static DateTimeFormatter ofLocalizedDateTime​(FormatStyle dateStyle,
                                                    FormatStyle timeStyle)
        返回ISO时代的特定日期和时间格式。

        这将返回格式化程序，以格式化或解析日期时间。 所使用的确切格式模式因地区而异。

        区域设置是从格式化程序确定的。 通过这种方法直接返回的格式化程序将使用default FORMAT locale 。 可以使用withLocale(Locale)对该方法的结果进行控制。

        请注意，本地化模式被懒惰地查找。 这个DateTimeFormatter拥有所需的风格和语言环境，查找需要的模式。

        返回的格式化程序具有ISO设置的时间顺序，以确保其他日历系统中的日期正确转换。 它没有覆盖区域，并使用SMART解析器样式。 FULL和LONG样式通常需要时区。 使用这些样式进行格式化时， ZoneId必须使用ZonedDateTime或withZone(java.time.ZoneId) 。

        参数
        dateStyle - 获取的日期格式化程序样式，不为null
        timeStyle - 获取时间格式化器样式，不为null
        结果
        日期，时间或日期时间格式化程序，不为空

      • parsedExcessDays

        public static final TemporalQuery<Period> parsedExcessDays​()
        一个查询，可以访问已解析的多余天数。

        这将返回一个单例query ，它可以从解析中访问附加信息。 查询始终返回一个非空期，返回零期，而不是null。

        有两种情况，即该查询可能返回非零期。

        • 如果ResolverStyle是LENIENT并且没有日期的时间被解析，则解析的完整结果由LocalTime和过多的Period天数组成。
        • 如果ResolverStyle为SMART和其中时间是24:00:00，一时间不注日期的解析，则解析的完整结果由的LocalTime的00:00:00和过量Period一天。

        在这两种情况下，如果完整的ChronoLocalDateTime或Instant被解析，则多余的天数将添加到日期部分。 因此，此查询将返回零期。

        SMART行为处理常见的“结束”24:00的值。 在LENIENT模式下处理也产生相同的结果：

          Text to parse        Parsed object                         Excess days
  "2012-12-03T00:00"   LocalDateTime.of(2012, 12, 3, 0, 0)   ZERO
  "2012-12-03T24:00"   LocalDateTime.of(2012, 12, 4, 0, 0)   ZERO
  "00:00"              LocalTime.of(0, 0)                    ZERO
  "24:00"              LocalTime.of(0, 0)                    Period.ofDays(1)
        查询可以使用如下：
          TemporalAccessor parsed = formatter.parse(str);
  LocalTime time = parsed.query(LocalTime::from);
  Period extraDays = parsed.query(DateTimeFormatter.parsedExcessDays());
        结果
        一个查询，可以访问已解析的多余天数

      • parsedLeapSecond

        public static final TemporalQuery<Boolean> parsedLeapSecond​()
        提供访问是否解析了跨越秒的查询。

        这将返回一个单数query ，它可以从解析中访问附加信息。 查询总是返回一个非空的布尔值，如果解析看到一个闰秒，则返回true，否则返回false。

        即时解析处理“23：59：60”的特殊“闰秒”时间。 在UTC时区的“23：59：60”发生跳跃秒，但在不同时区的其他本地时间。 为了避免这种潜在的歧义，闰秒的处理限制为DateTimeFormatterBuilder.appendInstant() ，因为该方法总是使用UTC区域偏移解析瞬间。

        如果接收到'23：59：60'的时间，则应用简单的转换，用59替换第60分钟。该查询可以用于解析结果，以确定闰秒调整是否为制作。 查询将返回true如果它调整了删除闰秒，而false如果没有。 请注意，应用跨平台的平滑机制，如UTC-SLS，是应用程序的责任，如下所示：

          TemporalAccessor parsed = formatter.parse(str);
  Instant instant = parsed.query(Instant::from);
  if (parsed.query(DateTimeFormatter.parsedLeapSecond())) {
    // validate leap-second is correct and apply correct smoothing
  }
        结果
        一个提供访问是否解析了闰秒的查询

      • getLocale

        public Locale getLocale​()
        获取格式化期间要使用的区域设置。

        这用于查找需要特定本地化的格式化程序的任何部分，例如文本或本地化模式。

        结果
        这个格式化程序的区域设置不为空

      • withLocale

        public DateTimeFormatter withLocale​(Locale locale)
        使用新的语言环境返回此格式化程序的副本。

        这用于查找需要特定本地化的格式化程序的任何部分，例如文本或本地化模式。

        此实例是不可变的，不受此方法调用的影响。

        参数
        locale - 新的区域设置，不为null
        结果
        一个基于格式化程序的格式化程序，具有所请求的区域设置，不为null

      • getDecimalStyle

        public DecimalStyle getDecimalStyle​()
        获取在格式化期间使用的DecimalStyle。
        结果
        这个格式化程序的区域设置不为空

      • withDecimalStyle

        public DateTimeFormatter withDecimalStyle​(DecimalStyle decimalStyle)
        使用新的DecimalStyle返回此格式化程序的副本。

        此实例是不可变的，不受此方法调用的影响。

        参数
        decimalStyle - 新的DecimalStyle，不为null
        结果
        一个格式化程序基于该格式化程序与请求的DecimalStyle，不为null

      • getChronology

        public Chronology getChronology​()
        获得在格式化期间使用的压倒一记的年表。

        这将返回覆盖年表，用于转换日期。 默认情况下，格式化程序没有覆盖时间顺序，返回null。 有关覆盖的详细信息，请参阅withChronology(Chronology) 。

        结果
        这个格式化器的覆盖年表，如果没有覆盖，则为null

      • withChronology

        public DateTimeFormatter withChronology​(Chronology chrono)
        使用新的覆盖年表返回此格式化程序的副本。

        这会返回一个格式化器，具有与该格式化程序相似的状态，但是覆盖时间顺序集。 默认情况下，格式化程序没有覆盖时间顺序，返回null。

        如果添加了覆盖，则格式化或解析的任何日期都将受到影响。

        格式化时，如果时间对象包含日期，那么它将被转换为覆盖年表中的日期。 是否包含日期是通过查询EPOCH_DAY字段来确定的。 任何时间或区域将保留不变，除非被覆盖。

        如果时间对象不包含日期，但包含一个或多个ChronoField日期字段，然后DateTimeException被抛出。 在所有其他情况下，覆盖年表被添加到时间，替换任何以前的年表，但不更改日期/时间。

        解析时有两种不同的情况需要考虑。 如果一个年表从文本中直接解析出来，也许是因为使用了DateTimeFormatterBuilder.appendChronologyId() ，那么这个覆盖年表没有任何效果。 如果没有分区被解析，那么这个覆盖年表将用于根据年表的日期解析规则将ChronoField值解释为日期。

        此实例是不可变的，不受此方法调用的影响。

        参数
        chrono - 新的年表，如果不覆盖，则为null
        结果
        一个基于该格式化器的格式化程序，具有请求的覆盖时间顺序，不为null

      • getZone

        public ZoneId getZone​()
        获取在格式化期间使用的覆盖区域。

        这将返回覆盖区域，用于转换时刻。 默认情况下，格式化程序没有覆盖区域，返回null。 有关覆盖的更多详细信息，请参阅withZone(ZoneId) 。

        结果
        该格式化程序的覆盖区域为null，如果不覆盖则为null

      • withZone

        public DateTimeFormatter withZone​(ZoneId zone)
        使用新的覆盖区域返回此格式化程序的副本。

        这将返回一个格式化程序，具有与该格式化程序类似的状态，但是覆盖区域设置。 默认情况下，格式化程序没有覆盖区域，返回null。

        如果添加了覆盖，则格式化或解析的任何即时将受到影响。

        格式化时，如果时间对象包含一个瞬间，则将使用覆盖区域将其转换为分区的日期时间。 时间是否是瞬间是通过查询INSTANT_SECONDS字段来确定的。 如果输入具有时间顺序，那么它将被保留，除非被覆盖。 如果输入没有时间顺序，例如Instant ，那么将使用ISO年表。

        如果时间对象不包含一个时刻，但是包含一个偏移量，则进行额外的检查。 如果归一化覆盖区域是与时间偏移量不同的偏移量，则抛出DateTimeException 。 在所有其他情况下，将覆盖区域添加到时间，替换任何先前的区域，但不更改日期/时间。

        解析时有两种不同的情况需要考虑。 如果一个区域直接从文本中解析出来，也许是因为使用了DateTimeFormatterBuilder.appendZoneId() ，那么这个覆盖区域就没有效果。 如果没有分区被解析，那么这个覆盖区域将包含在解析结果中，可以用于构建时间和日期时间。

        此实例是不可变的，不受此方法调用的影响。

        参数
        zone - 新的覆盖区域，如果不覆盖，则为null
        结果
        一个格式化程序基于该格式化程序与请求的覆盖区域，不为null

      • getResolverStyle

        public ResolverStyle getResolverStyle​()
        获取在解析过程中使用的解析器样式。

        这将返回解析器样式，当字段解析为日期和时间时，在解析的第二阶段使用。 默认情况下，格式化程序具有SMART解析器样式。 详见withResolverStyle(ResolverStyle) 。

        结果
        这个格式化程序的解析器样式，不为null

      • withResolverStyle

        public DateTimeFormatter withResolverStyle​(ResolverStyle resolverStyle)
        使用新的解析器样式返回此格式化程序的副本。

        这会返回一个格式化程序，与格式化程序具有类似的状态，但是会使用解析器样式集。 默认情况下，格式化程序具有SMART解析器样式。

        更改解析器样式只能在解析过程中产生效果。 解析文本字符串分两个阶段。 阶段1是根据添加到构建器的字段的基本文本解析。 阶段2将解析的字段值对解析为日期和/或时间对象。 解析器样式用于控制阶段2，解决方式的发生。 有关可用选项的更多信息，请参阅ResolverStyle 。

        此实例是不可变的，不受此方法调用的影响。

        参数
        resolverStyle - 新的解析器样式，不为空
        结果
        一个基于格式化器的格式化程序，具有请求的解析器样式，不为空

      • getResolverFields

        public Set<TemporalField> getResolverFields​()
        获取在解析期间使用的解析器字段。

        这将返回解析器字段，在字段解析为日期和时间时在解析的第二阶段使用。 默认情况下，格式化程序没有解析器字段，因此返回null。 详见withResolverFields(Set) 。

        结果
        这个格式化程序的不可变解析器字段集合，如果没有字段则为null

      • withResolverFields

        public DateTimeFormatter withResolverFields​(TemporalField... resolverFields)
        使用一组新的解析器字段返回此格式化程序的副本。

        这将返回一个格式化程序，与格式化程序具有相似的状态，但解析器字段设置。 默认情况下，格式化程序没有解析器字段。

        在解析过程中，更改解析器字段仅具有效果。 解析文本字符串分两个阶段。 阶段1是根据添加到构建器的字段的基本文本解析。 阶段2将解析的字段值对解析为日期和/或时间对象。 解析器字段用于过滤阶段1和阶段2之间的字段值对。

        这可以用于在日期或时间可能被解决的两种或更多种方式之间进行选择。 例如，如果格式化程序由年，月，日，月和日组成，则有两种方法来解决日期。 使用参数YEAR和DAY_OF_YEAR调用此方法将确保使用年份和日期解决日期，有效地意味着在解决阶段忽略月份和日期。

        以类似的方式，该方法可以用于忽略否则将被交叉检查的次级字段。 例如，如果格式化程序由年份，月份，月份和星期几组成，则只有一种方法可以解决日期，但是每周的解析值将被交叉检查反对解决日期。 调用此方法与参数YEAR ， MONTH_OF_YEAR和DAY_OF_MONTH将确保日期是正确解决，但没有任何交叉检查的某一天的一周。

        在实现方面，该方法的行为如下。 分析阶段的结果可以被认为是一个字段到值的映射。 此方法的行为是使该映射在阶段1和阶段2之间进行过滤，除去除了指定为该方法的参数之外的所有字段。

        此实例是不可变的，不受此方法调用的影响。

        参数
        resolverFields - 新的解析器字段集合，如果没有字段，则为null
        结果
        一个基于格式化器的格式化程序，具有请求的解析器样式，不为空

      • withResolverFields

        public DateTimeFormatter withResolverFields​(Set<TemporalField> resolverFields)
        使用一组新的解析器字段返回此格式化程序的副本。

        这将返回一个格式化程序，与格式化程序具有相似的状态，但解析器字段设置。 默认情况下，格式化程序没有解析器字段。

        在解析过程中，更改解析器字段仅具有效果。 解析文本字符串分两个阶段。 阶段1是根据添加到构建器的字段的基本文本解析。 阶段2将解析的字段值对解析为日期和/或时间对象。 解析器字段用于过滤阶段1和阶段2之间的字段值对。

        这可以用于在日期或时间可能被解决的两种或更多种方式之间进行选择。 例如，如果格式化程序由年，月，日，月和日组成，则有两种方法来解决日期。 使用参数YEAR和DAY_OF_YEAR调用此方法将确保使用年份和日期来解决日期，有效地意味着在解决阶段忽略月份和日期。

        以类似的方式，该方法可以用于忽略否则将被交叉检查的次级字段。 例如，如果格式化程序由年份，月份，月份和星期几组成，则只有一种方法可以解决日期，但是每周的解析值将被交叉检查反对解决日期。 调用此方法与参数YEAR ， MONTH_OF_YEAR和DAY_OF_MONTH将确保日期是正确解决，但没有任何交叉检查的某一天的一周。

        在实现方面，该方法的行为如下。 分析阶段的结果可以被认为是一个字段到值的映射。 此方法的行为是使该映射在阶段1和阶段2之间进行过滤，除去除了指定为该方法的参数之外的所有字段。

        此实例是不可变的，不受此方法调用的影响。

        参数
        resolverFields - 新的解析器字段集合，如果没有字段，则为null
        结果
        一个基于格式化器的格式化程序，具有请求的解析器样式，不为空

      • format

        public String format​(TemporalAccessor temporal)
        使用此格式化程序格式化日期时间对象。

        这将使用格式化程序的规则将日期时间格式化为String。

        参数
        temporal - 要格式化的时间对象，不为null
        结果
        格式化的字符串，不为null
        异常
        DateTimeException - 如果在格式化期间发生错误

      • formatTo

        public void formatTo​(TemporalAccessor temporal,
                     Appendable appendable)
        使用此格式化程序将日期时间对象格式化为Appendable 。

        这将格式化的日期时间输出到指定的目的地。 Appendable是受所有键字符输出类别，包括实现一个通用接口StringBuffer ， StringBuilder ， PrintStream和Writer 。

        虽然Appendable方法抛出一个IOException ，这个方法没有。 相反，任何IOException都包含在运行时异常中。

        参数
        temporal - 要格式化的时间对象，不为空
        appendable - 可附加格式化，不为空
        异常
        DateTimeException - 如果在格式化期间发生错误

      • parse

        public TemporalAccessor parse​(CharSequence text)
        完全解析产生时间对象的文本。

        这解析整个文本，产生一个时间对象。 通常使用parse(CharSequence, TemporalQuery)更有用。 该方法的结果为TemporalAccessor ，已经解决，应用基本的验证检查，以确保有效的日期时间。

        如果解析完成，而不读取文本的整个长度，或者在解析或合并期间发生问题，则抛出异常。

        参数
        text - 要解析的文本，不为空
        结果
        解析的时间对象，不为null
        异常
        DateTimeParseException - 如果无法解析请求的结果

      • parse

        public TemporalAccessor parse​(CharSequence text,
                              ParsePosition position)
        使用此格式化器解析文本，提供对文本位置的控制。

        这样解析文本，而不需要解析从字符串的开头开始，或者在结尾处完成。 该方法的结果为TemporalAccessor ，已经解决，应用基本的验证检查，以确保有效的日期时间。

        文本将从指定的开始ParsePosition解析。 文本的整个长度不需要解析， ParsePosition将在解析结束时用索引进行更新。

        该方法的操作与使用ParsePosition在java.text.Format上的类似方法略有不同。 该类将使用ParsePosition上的错误索引返回错误。 相比之下，如果发生错误，此方法将抛出一个DateTimeParseException ，异常包含错误索引。 由于在此API中解析和解析日期/时间的复杂性增加，因此行为变化是必要的。

        如果格式化程序用不同的值解析相同的字段多次，结果将是一个错误。

        参数
        text - 要解析的文本，不为null
        position - 解析的位置，更新长度解析和任何错误的索引，不为空
        结果
        解析的时间对象，不为null
        异常
        DateTimeParseException - 如果无法解析请求的结果
        IndexOutOfBoundsException - 如果位置无效

      • parse

        public <T> T parse​(CharSequence text,
                   TemporalQuery<T> query)
        完全解析产生指定类型对象的文本。

        大多数应用程序应该使用此方法进行解析。 它解析整个文本以产生所需的日期时间。 该查询通常是对from(TemporalAccessor)方法的方法引用。 例如：

          LocalDateTime dt = parser.parse(str, LocalDateTime::from);
        如果解析完成，而不读取文本的整个长度，或者在解析或合并期间发生问题，则抛出异常。
        参数类型
        T - 解析日期时间的类型
        参数
        text - 要解析的文本，不为空
        query - 定义要解析的类型的查询，不为null
        结果
        解析的日期时间，不为null
        异常
        DateTimeParseException - 如果无法解析请求的结果

      • parseBest

        public TemporalAccessor parseBest​(CharSequence text,
                                  TemporalQuery<?>... queries)
        完全解析产生指定类型之一的对象的文本。

        当解析器可以处理可选元素时，此解析方法便于使用。 例如，'uuuu-MM-dd HH.mm [VV]'的模式可以完全解析为ZonedDateTime ，或部分解析为LocalDateTime 。 必须按顺序指定查询，从最佳匹配的全解析选项开始，以最差匹配的最小分析选项结束。 该查询通常是对from(TemporalAccessor)方法的方法引用。

        结果与成功解析的第一种类型相关联。 通常，应用程序将使用instanceof来检查结果。 例如：

          TemporalAccessor dt = parser.parseBest(str, ZonedDateTime::from, LocalDateTime::from);
  if (dt instanceof ZonedDateTime) {
   ...
  } else {
   ...
  }
        如果解析完成，而不读取文本的整个长度，或者在解析或合并期间发生问题，则抛出异常。
        参数
        text - 要解析的文本，不为空
        queries - 定义要尝试解析的类型的查询必须实现 TemporalAccessor ，不为空
        结果
        解析的日期时间，不为null
        异常
        IllegalArgumentException - 如果指定少于2种类型
        DateTimeParseException - 如果无法解析请求的结果

      • parseUnresolved

        public TemporalAccessor parseUnresolved​(CharSequence text,
                                        ParsePosition position)
        使用此格式化程序解析文本，而无需解析结果，用于高级用例。

        解析实现为两阶段操作。 首先，使用格式化程序定义的布局来解析文本，产生一个Map字段的值，一个ZoneId和一个Chronology 。 第二，通过验证，组合和简化各种领域，使解析的数据得到解决 。 该方法执行解析阶段，但不执行解析阶段。

        该方法的结果为TemporalAccessor ，表示输入中所见的数据。 价值观不验证，因此解析“2012-00-65”的日期字符串将导致三个字段的时间 - “2012”年份，“0”月份和“65”的月份。

        文本将从指定的起始ParsePosition解析。 文本的整个长度不需要解析， ParsePosition将在解析结束时使用索引进行更新。

        使用ParsePosition的错误索引字段而不是DateTimeParseException返回错误。 返回的错误索引将被设置为指示错误的索引。 使用结果之前，来电者必须检查错误。

        如果格式化程序用不同的值解析相同的字段多次，结果将是一个错误。

        此方法适用于在解析期间需要访问内部状态的高级用例。 典型的应用代码应该使用parse(CharSequence, TemporalQuery)或目标类型的解析方法。

        参数
        text - 要解析的文本，不为空
        position - 解析的位置，更新长度解析和任何错误的索引，不为空
        结果
        解析文本，如果解析导致错误，则为null
        异常
        DateTimeException - 如果在解析期间发生某些问题
        IndexOutOfBoundsException - 如果位置无效

      • toFormat

        public Format toFormat​()
        将此格式化程序作为java.text.Format实例返回。

        返回的Format实例将格式化任何TemporalAccessor并解析到解析的TemporalAccessor 。

        例外将遵循Format的定义，有关详细信息，请参阅这些方法IllegalArgumentException在格式化期间和ParseException或解析期间为空。 格式不支持返回格式字符串的属性。

        结果
        这个格式化程序作为一个经典的格式实例，不为null

      • toFormat

        public Format toFormat​(TemporalQuery<?> parseQuery)
        将此格式化程序作为java.text.Format实例返回，使用指定的查询进行解析。

        返回的Format实例将格式化任何TemporalAccessor并解析到指定的类型。 该类型必须是parse(java.lang.CharSequence)支持的类型 。

        例外将遵循Format的定义，有关详细信息，请参阅这些方法IllegalArgumentException在格式化期间和ParseException或解析期间为空。 格式不支持返回格式字符串的属性。

        参数
        parseQuery - 查询定义要解析的类型，不为null
        结果
        这个格式化程序作为一个经典的格式实例，不为null

      • toString

        public String toString​()
        返回底层格式化程序的描述。
        重写：
        toString在 Object
        结果
        a description of this formatter, not null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DateTimeFormatterBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.format

Class DateTimeFormatterBuilder

  • java.lang.Object
    • java.time.format.DateTimeFormatterBuilder

  • public final class DateTimeFormatterBuilder
extends Object
    Builder创建日期格式化程序。

    这样可以创建一个DateTimeFormatter 。 最终使用此构建器创建所有日期时间格式化程序。

    日期时间的基本元素可以全部添加：

    • 值 - 数值
    • 分数 - 包括小数位的小数值。 输出分数时，请务必使用该分数，以确保分数被正确解析
    • 文本 - 该值的文本等价物
    • OffsetId / Offset - zone offset
    • ZoneId - time-zone id
    • ZoneText - 时区的名称
    • ChronologyId - chronology id
    • ChronologyText - 年表的名称
    • 文字 - 文字文字
    • 嵌套和可选 - 格式可以嵌套或选择
    此外，任何元素可以通过填充来装饰，或者具有空格或任何其他字符。

    最后，可以使用与java.text.SimpleDateFormat SimpleDateFormat兼容的速记模式，参见appendPattern(String) 。 在实践中，这简单地解析模式，并在构建器上调用其他方法。

    实现要求：
    这个类是一个可以从单个线程使用的可变构造器。
    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      DateTimeFormatterBuilder​()
      构建构建器的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder append​(DateTimeFormatter formatter)
      将格式化程序的所有元素附加到构建器。
      DateTimeFormatterBuilder appendChronologyId​()
      将时间序列ID（如“ISO”或“ThaiBuddhist”）附加到格式化程序。
      DateTimeFormatterBuilder appendChronologyText​(TextStyle textStyle)
      将年表名称附加到格式化程序。
      DateTimeFormatterBuilder appendFraction​(TemporalField field, int minWidth, int maxWidth, boolean decimalPoint)
      将日期时间字段的小数值附加到格式化程序。
      DateTimeFormatterBuilder appendGenericZoneText​(TextStyle textStyle)
      将泛型时区名称（如“太平洋时间”）附加到格式化程序。
      DateTimeFormatterBuilder appendGenericZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将泛型时区名称（如“太平洋时间”）附加到格式化程序。
      DateTimeFormatterBuilder appendInstant​()
      使用ISO-8601即时添加格式化程序，以三组格式化小数位数。
      DateTimeFormatterBuilder appendInstant​(int fractionalDigits)
      使用ISO-8601即时使用格式化程序，可以控制小数位数。
      DateTimeFormatterBuilder appendLiteral​(char literal)
      在格式化程序中附加一个字符文字。
      DateTimeFormatterBuilder appendLiteral​(String literal)
      将一个字符串字面值附加到格式化程序。
      DateTimeFormatterBuilder appendLocalized​(FormatStyle dateStyle, FormatStyle timeStyle)
      将本地化的日期时间模式附加到格式化程序。
      DateTimeFormatterBuilder appendLocalizedOffset​(TextStyle style)
      将本地化区域偏移量（如“GMT + 01：00”）附加到格式化程序。
      DateTimeFormatterBuilder appendOffset​(String pattern, String noOffsetText)
      将区域偏移（如“+01：00”）附加到格式化程序。
      DateTimeFormatterBuilder appendOffsetId​()
      将区域偏移（如“+01：00”）附加到格式化程序。
      DateTimeFormatterBuilder appendOptional​(DateTimeFormatter formatter)
      将一个格式化程序附加到构建器，该构建器可以格式化/解析。
      DateTimeFormatterBuilder appendPattern​(String pattern)
      将指定模式定义的元素附加到构建器。
      DateTimeFormatterBuilder appendText​(TemporalField field)
      使用全文样式将日期时间字段的文本附加到格式化程序。
      DateTimeFormatterBuilder appendText​(TemporalField field, TextStyle textStyle)
      将日期时间字段的文本附加到格式化程序。
      DateTimeFormatterBuilder appendText​(TemporalField field, Map<Long,String> textLookup)
      使用指定的地图将日期时间字段的文本附加到格式化程序以提供文本。
      DateTimeFormatterBuilder appendValue​(TemporalField field)
      使用正常输出样式将日期时间字段的值附加到格式化程序。
      DateTimeFormatterBuilder appendValue​(TemporalField field, int width)
      使用固定宽度零填充方法将日期时间字段的值附加到格式化程序。
      DateTimeFormatterBuilder appendValue​(TemporalField field, int minWidth, int maxWidth, SignStyle signStyle)
      将日期时间字段的值追加到格式化程序，以提供对格式化的完全控制。
      DateTimeFormatterBuilder appendValueReduced​(TemporalField field, int width, int maxWidth, int baseValue)
      将日期时间字段的减小值附加到格式化程序。
      DateTimeFormatterBuilder appendValueReduced​(TemporalField field, int width, int maxWidth, ChronoLocalDate baseDate)
      将日期时间字段的减小值附加到格式化程序。
      DateTimeFormatterBuilder appendZoneId​()
      将时区ID（例如“欧洲/巴黎”或“+02：00”）附加到格式化程序。
      DateTimeFormatterBuilder appendZoneOrOffsetId​()
      使用最佳可用区域ID将时区ID（例如“欧洲/巴黎”或“+02：00”）附加到格式化程序。
      DateTimeFormatterBuilder appendZoneRegionId​()
      将时区区域ID（如“Europe / Paris”）附加到格式化程序，如果是 ZoneOffset ，则拒绝该区域ID。
      DateTimeFormatterBuilder appendZoneText​(TextStyle textStyle)
      将时区名称（如“英国夏令时”）附加到格式化程序。
      DateTimeFormatterBuilder appendZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将时区名称（如“英国夏令时”）附加到格式化程序。
      static String getLocalizedDateTimePattern​(FormatStyle dateStyle, FormatStyle timeStyle, Chronology chrono, Locale locale)
      获取区域设置和时间顺序的日期和时间样式的格式模式。
      DateTimeFormatterBuilder optionalEnd​()
      结束可选部分。
      DateTimeFormatterBuilder optionalStart​()
      标记可选部分的开始。
      DateTimeFormatterBuilder padNext​(int padWidth)
      使下一个添加的打印机/解析器使用空格来填充到固定宽度。
      DateTimeFormatterBuilder padNext​(int padWidth, char padChar)
      使下一个添加的打印机/解析器粘贴到固定的宽度。
      DateTimeFormatterBuilder parseCaseInsensitive​()
      将解析样式更改为格式化程序的其余部分不区分大小写。
      DateTimeFormatterBuilder parseCaseSensitive​()
      将解析样式更改为格式化程序的其余部分区分大小写。
      DateTimeFormatterBuilder parseDefaulting​(TemporalField field, long value)
      将字段的默认值追加到格式化程序以用于解析。
      DateTimeFormatterBuilder parseLenient​()
      将解析样式更改为对于格式化程序的其余部分来说宽松。
      DateTimeFormatterBuilder parseStrict​()
      将解析样式更改为严格的格式化程序的其余部分。
      DateTimeFormatter toFormatter​()
      通过使用默认语言环境创建 DateTimeFormatter来完成此构建器。
      DateTimeFormatter toFormatter​(Locale locale)
      通过使用指定的区域设置创建 DateTimeFormatter来完成此构建器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DateTimeFormatterBuilder

        public DateTimeFormatterBuilder​()
        构建构建器的新实例。

    • 方法详细信息

      • getLocalizedDateTimePattern

        public static String getLocalizedDateTimePattern​(FormatStyle dateStyle,
                                                 FormatStyle timeStyle,
                                                 Chronology chrono,
                                                 Locale locale)
        获取区域设置和时间顺序的日期和时间样式的格式模式。 用于查找所请求的dateStyle和/或timeStyle的区域设置特定格式的区域设置和时间顺序。
        参数
        dateStyle - 日期的FormatStyle，仅限时间模式为null
        timeStyle - 当时的FormatStyle，仅限日期模式为null
        chrono - 年表，非空
        locale - 区域设置，非空
        结果
        地域和时代具体的格式化模式
        异常
        IllegalArgumentException - 如果dateStyle和timeStyle都为null

      • parseCaseSensitive

        public DateTimeFormatterBuilder parseCaseSensitive​()
        将解析样式更改为格式化程序的其余部分区分大小写。

        解析可以区分大小写或不敏感 - 默认情况下区分大小写。 该方法允许更改解析的区分大小写设置。

        调用此方法可更改构建器的状态，以便所有后续构建器方法调用将在区分大小写模式下解析文本。 请参阅parseCaseInsensitive()相反的设置。 解析器区分敏感/不敏感的方法可能会在构建器中的任何位置被调用，因此解析器可以在解析之间多次在案例解析模式之间进行交换。

        由于默认值区分大小写，因此此方法只能在先前调用#parseCaseInsensitive 。

        结果
        这个，为链接，不为null

      • parseCaseInsensitive

        public DateTimeFormatterBuilder parseCaseInsensitive​()
        将解析样式更改为格式化程序的其余部分不区分大小写。

        解析可以区分大小写或不敏感 - 默认情况下区分大小写。 该方法允许更改解析的区分大小写设置。

        调用此方法会更改构建器的状态，以便所有后续构建器方法调用将在不区分大小写模式下解析文本。 有关相反的设置，请参阅parseCaseSensitive() 。 解析器区分敏感/不敏感的方法可能会在构建器中的任何位置被调用，因此解析器可以在解析之间多次在案例解析模式之间进行交换。

        结果
        这个，为链接，不为null

      • parseStrict

        public DateTimeFormatterBuilder parseStrict​()
        将解析样式更改为严格的格式化程序的其余部分。

        解析可以严格或宽松 - 默认是严格的。 这控制了匹配文本和符号样式的灵活性。

        使用该方法时，此方法将此解析更改为严格。 由于strict是默认值，通常只需要调用parseLenient()才能使用 。 该更改将一直有效，直到最终构建的格式化程序结束或直到parseLenient 。

        结果
        这个，为链接，不为null

      • parseLenient

        public DateTimeFormatterBuilder parseLenient​()
        将解析样式更改为对于格式化程序的其余部分来说宽松。 请注意，区分大小写是分开设置的。

        解析可以严格或宽松 - 默认是严格的。 这控制了匹配文本和符号样式的灵活性。 调用此方法的应用程序通常也应该调用parseCaseInsensitive() 。

        当使用此方法时，此方法将此解析从该点更改为宽松。 该更改将一直有效，直到最终构建的格式化程序结束或直到parseStrict 。

        结果
        这个，为链接，不为null

      • parseDefaulting

        public DateTimeFormatterBuilder parseDefaulting​(TemporalField field,
                                                long value)
        将字段的默认值追加到格式化程序以用于解析。

        这将附加一个指令给构建器，以将默认值注入到解析结果中。 这与格式化程序的可选部分特别有用。

        例如，考虑一个解析年份的格式化程序，然后是可选的月份，另外可以选择一个月。 使用这样的格式化程序将需要调用代码来检查是否已经解析了完整的日期，年月或仅仅一年。 此方法可用于将月份和日期默认为明智的值，例如月中的第一个月，允许呼叫代码始终获取日期。

        格式化时，此方法无效。

        在解析过程中，将检查解析器的当前状态。 如果指定的字段没有关联的值，因为在该点没有成功解析，那么将指定的值注入到解析结果中。 注入是立即的，因此字段值对将对格式化程序中的任何后续元素可见。 因此，通常在构建器的末尾调用此方法。

        参数
        field - 该字段默认值为，不为null
        value - 默认值为
        结果
        这个，为链接，不为null

      • appendValue

        public DateTimeFormatterBuilder appendValue​(TemporalField field)
        使用正常输出样式将日期时间字段的值附加到格式化程序。

        字段的值将在格式化期间输出。 如果无法获取该值，则抛出异常。

        该值将按照整数值的普通格式打印。 只有负数将被签署。 将不添加填充。

        可变宽度值的解析器通常表现得很贪婪，需要一位数字，但尽可能接受数字。 这种行为可能受到“相邻值解析”的影响。 详见appendValue(java.time.temporal.TemporalField, int) 。

        参数
        field - 要追加的字段，不为null
        结果
        这个，为链接，不为null

      • appendValue

        public DateTimeFormatterBuilder appendValue​(TemporalField field,
                                            int width)
        使用固定宽度零填充方法将日期时间字段的值附加到格式化程序。

        字段的值将在格式化期间输出。 如果无法获取该值，则抛出异常。

        该值将在左侧零填充。 如果值的大小意味着它不能在宽度内打印，则抛出异常。 如果该字段的值为负值，则在格式化期间抛出异常。

        该方法支持一种称为“相邻值解析”的特殊解析技术。 该技术解决了值，变量或固定宽度后面跟着一个或多个固定长度值的问题。 标准解析器是贪心的，因此它通常会窃取跟随变量width one的固定宽度值解析器所需的数字。

        启动“相邻值解析”不需要任何操作。 当调用appendValue ，构建器进入相邻值解析设置模式。 如果立即后续方法调用或调用相同的构建器为固定宽度值，则解析器将保留空间，以便可以解析固定宽度值。

        例如，考虑builder.appendValue(YEAR).appendValue(MONTH_OF_YEAR, 2);年是1到19位数之间的变量宽度解析。 这个月是两位数的固定宽度解析。 因为这些被立即附加到同一个构建器上，所以年解析器将为该月份预留两位数字来解析。 因此，文本“201106”将正确解析为2011年和6个月。如果没有相邻的值解析，那么年份会贪婪地解析所有6位数，并且不会对该月份留下任何东西。

        相邻值解析适用于解析器中紧随任何类型的值，变量或固定宽度的每组固定宽度非负值。 调用任何其他追加方法将结束相邻值解析的设置。 因此，在不太可能需要避免相邻值解析行为的情况下，只需将appendValue添加到另一个DateTimeFormatterBuilder ，并将其添加到此构建器。

        如果相邻解析处于活动状态，则解析必须与严格和宽松模式中的指定数字数字完全匹配。 此外，不允许使用正号或负号。

        参数
        field - 要追加的字段，不为null
        width - 打印字段的宽度，从1到19
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果宽度无效

      • appendValue

        public DateTimeFormatterBuilder appendValue​(TemporalField field,
                                            int minWidth,
                                            int maxWidth,
                                            SignStyle signStyle)
        将日期时间字段的值追加到格式化程序，以提供对格式化的完全控制。

        字段的值将在格式化期间输出。 如果无法获取该值，则抛出异常。

        该方法可以完全控制数字格式，包括零填充和正负号。

        可变宽度值的解析器通常表现得很贪婪，尽可能接受多个数字。 这种行为可能受到“相邻值解析”的影响。 有关详细信息，请参阅appendValue(java.time.temporal.TemporalField, int) 。

        在严格解析模式下，解析数字的最小数量为minWidth ，最大数量为maxWidth 。 在宽大的解析模式中，最小解析数字数为1，最大为19（除了由相邻值解析限制）。

        如果以相同的最小和最大宽度调用此方法，并且符号样式为NOT_NEGATIVE则它将委托给appendValue(TemporalField,int) 。 在这种情况下，会出现描述的格式和解析行为。

        参数
        field - 要追加的字段，不为null
        minWidth - 打印字段的最小字段宽度，从1到19
        maxWidth - 打印字段的最大字段宽度，从1到19
        signStyle - 正/负输出样式，不为空
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果宽度无效

      • appendValueReduced

        public DateTimeFormatterBuilder appendValueReduced​(TemporalField field,
                                                   int width,
                                                   int maxWidth,
                                                   int baseValue)
        将日期时间字段的减小值附加到格式化程序。

        由于诸如年份之类的字段因年表而异，因此建议在大多数情况下使用此方法的appendValueReduced(TemporalField, int, int, ChronoLocalDate) date变体。 此变体适用于简单字段或仅使用ISO年表。

        对于格式化， width和maxWidth用于确定要格式化的字符数。 如果它们相等，则格式是固定宽度。 如果字段的值在baseValue使用width字符的范围内，则缩减值将被格式化，否则该值将被截断以适应maxWidth 。 输出最右边的字符以匹配宽度，左填充为零。

        对于严格解析， width到maxWidth允许的字符数被解析。 对于宽泛的解析，字符数必须至少为1且小于10.如果解析的位数等于width ，并且值为正，则该字段的值被计算为大于或等于的第一个数字到baseValue具有相同的最低有效字符，否则解析的值是字段值。 这允许为baseValue和width的范围内的值输入减小的值，并且可以为范围之外的值输入绝对值。

        例如，基数为1980 ，宽度为2将为1980至2079 。 在解析期间，文本"12"将导致值2012因为这是最后两个字符为“12”的范围内的值。 相比之下，解析文本"1915"将导致值1915 。

        参数
        field - 要追加的字段，不为null
        width - 打印和解析字段的字段宽度，从1到10
        maxWidth - 打印字段的最大字段宽度，从1到10
        baseValue - 有效值范围的基值
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果宽度或基数值无效

      • appendValueReduced

        public DateTimeFormatterBuilder appendValueReduced​(TemporalField field,
                                                   int width,
                                                   int maxWidth,
                                                   ChronoLocalDate baseDate)
        将日期时间字段的减小值附加到格式化程序。

        这通常用于格式化和解析两位数年份。

        基准日期用于在解析期间计算完整值。 例如，如果基准日期是1950-01-01，则两位数年份解析的解析值将在1950-01-01到2049-12-31之间。 只有一年才会从日期提取，因此1950-08-25的基准日期也将解析到1950-01-01到2049-12-31之间的范围。 这种行为是必要的，以支持字段，例如周分年或其他日历系统，其中解析值与标准ISO年不一致。

        具体行为如下。 解析整套字段，并使用最后一个年表确定有效的年表，如果它不止一次出现。 然后将基准日期转换为有效的年表。 然后从时间特定的基准日期提取指定的字段，并使用它来确定下面使用的baseValue 。

        对于格式化， width和maxWidth用于确定要格式化的字符数。 如果它们相等，则格式是固定宽度。 如果字段的值在baseValue使用width字符的范围内，则减小的值将被格式化，否则该值被截断以适应maxWidth 。 输出最右边的字符以匹配宽度，左填充为零。

        对于严格解析， width到maxWidth允许的字符数被解析。 对于宽泛的解析，字符数必须至少为1且小于10.如果解析的位数等于width ，并且值为正，则该字段的值被计算为大于或等于的第一个数字到baseValue具有相同的最低有效字符，否则解析的值是字段值。 这允许为baseValue和width的范围内的值输入减小的值，并且可以为范围之外的值输入绝对值。

        例如，基数1980 ，宽度2将有效值为1980至2079 。 在解析期间，文本"12"将导致值2012 ，因为最后两个字符为“12”的范围内的值。 相比之下，解析文本"1915"将导致值1915 。

        参数
        field - 要追加的字段，不为空
        width - 打印和解析字段的字段宽度，从1到10
        maxWidth - 打印字段的最大字段宽度，从1到10
        baseDate - 用于计算解析年表中有效值范围的基本值的基准日期，不为null
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果宽度或基数值无效

      • appendFraction

        public DateTimeFormatterBuilder appendFraction​(TemporalField field,
                                               int minWidth,
                                               int maxWidth,
                                               boolean decimalPoint)
        将日期时间字段的小数值附加到格式化程序。

        将输出字段的小数值，包括前面的小数点。 不输出上述值。 例如，15的第二分钟值将输出为.25 。

        可以控制印刷分数的宽度。 将最小宽度设置为零将不会产生输出。 打印的分数将具有最小宽度和最大宽度之间所需的最小宽度 - 尾随零被省略。 由于最大宽度不会发生舍入 - 数字被简单地丢弃。

        在严格模式下解析时，解析数字的数目必须在最小和最大宽度之间。 在严格模式下，如果最小和最大宽度相等且没有小数点，则解析器将参与相邻值解析，请参见appendValue(java.time.temporal.TemporalField,int) 。 当在宽松模式下解析时，最小宽度被认为是零，最大值为9。

        如果无法获取该值，则抛出异常。 如果值为负，将抛出异常。 如果该字段没有固定的有效值集合，那么将抛出异常。 如果要打印的日期时间中的字段值无效，则无法打印并将抛出异常。

        参数
        field - 要追加的字段，不为null
        minWidth - 不包括小数点的字段的最小宽度，从0到9
        maxWidth - 不包括小数点的字段的最大宽度，从1到9
        decimalPoint - 是否输出本地化的小数点符号
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果该字段具有有效值的变量集或者宽度无效

      • appendText

        public DateTimeFormatterBuilder appendText​(TemporalField field)
        使用全文样式将日期时间字段的文本附加到格式化程序。

        字段的文本将在格式化期间输出。 该值必须在该字段的有效范围内。 如果无法获取该值，则抛出异常。 如果该字段没有文本表示，那么将使用该数值。

        该值将按照整数值的普通格式打印。 只有负数将被签署。 将不添加填充。

        参数
        field - 要追加的字段，不为null
        结果
        这个，为链接，不为null

      • appendText

        public DateTimeFormatterBuilder appendText​(TemporalField field,
                                           TextStyle textStyle)
        将日期时间字段的文本附加到格式化程序。

        字段的文本将在格式化期间输出。 该值必须在该字段的有效范围内。 如果无法获取该值，则抛出异常。 如果该字段没有文本表示，那么将使用该数值。

        该值将按照整数值的普通格式打印。 只有负数将被签署。 将不添加填充。

        参数
        field - 要追加的字段，不为null
        textStyle - 要使用的文本样式，不为null
        结果
        这个，为链接，不为null

      • appendText

        public DateTimeFormatterBuilder appendText​(TemporalField field,
                                           Map<Long,String> textLookup)
        使用指定的地图将日期时间字段的文本附加到格式化程序以提供文本。

        标准文本输出方法使用JDK中的本地化文本。 该方法允许直接指定文本。 提供的映射未由构建器验证，以确保格式化或解析可能，因此无效映射可能会在以后使用时发生错误。

        提供文本的地图在格式化和解析方面提供了很大的灵活性。 例如，遗留应用程序可能要求或提供一年中的几个月为“JNY”，“FBY”，“MCH”等。这些不符合本地化月份名称的标准文本集。 使用此方法，可以创建一个映射，定义每个值和文本之间的连接：

          Map<Long, String> map = new HashMap<>();
 map.put(1L, "JNY");
 map.put(2L, "FBY");
 map.put(3L, "MCH");
 ...
 builder.appendText(MONTH_OF_YEAR, map);

        其他用途可能是用“1st”，“2nd”，“3rd”，或者作为罗马数字“I”，“II”，“III”，“IV”的后缀输出值。

        在格式化期间，获取并检查该值在有效范围内。 如果文本不可用于该值，则将其作为数字输出。 解析期间，解析器将与文本和数值的映射匹配。

        参数
        field - 要追加的字段，不为null
        textLookup - 从值到文本的地图
        结果
        这个，为链接，不为null

      • appendInstant

        public DateTimeFormatterBuilder appendInstant​()
        使用ISO-8601即时添加格式化程序，以三组格式化小数位数。

        实体具有固定的输出格式。 它们被转换为具有UTC的区域偏移量的日期时间，并使用标准ISO-8601格式进行格式化。 使用这种方法，根据需要格式化nano-of-second输出零，三，六或九位数字。 不使用本地化的十进制格式。

        该瞬间使用INSTANT_SECONDS和任选的NANO_OF_SECOND 。 INSTANT_SECONDS的值可能在INSTANT_SECONDS的最大范围LocalDateTime 。

        resolver style对即时解析没有影响。 “24：00”的结束时间在第二天开始的半夜处理。 “ 23：59：59 ”的跨越时间在一定程度上处理，详见DateTimeFormatter.parsedLeapSecond() 。

        该方法的替代方法是将该时间格式化/解析为单个时标值。 这是使用appendValue(INSTANT_SECONDS)实现的。

        结果
        这个，为链接，不为null

      • appendInstant

        public DateTimeFormatterBuilder appendInstant​(int fractionalDigits)
        使用ISO-8601即时使用格式化程序，可以控制小数位数。

        实体有一个固定的输出格式，虽然这个方法提供了对小数位数的一些控制。 它们被转换为具有UTC的区域偏移量的日期时间，并使用标准ISO-8601格式打印。 不使用本地化的十进制格式。

        fractionalDigits参数允许控制小数秒的输出。 指定零将不会输出小数位数。 从1到9将输出越来越多的数字，如果需要，使用零右边填充。 特殊值-1用于输出尽可能多的数字，以避免任何尾随零。

        当在严格模式下解析时，解析数字的数量必须与小数位数相匹配。 当在宽松模式下解析时，任意数目的从零到九的小数位都被接受。

        该瞬间是使用INSTANT_SECONDS和任选的NANO_OF_SECOND 。 INSTANT_SECONDS的值可能在INSTANT_SECONDS的最大范围LocalDateTime 。

        resolver style对即时解析没有影响。 “24：00”的结束时间在第二天开始的半夜处理。 “ 23：59：60 ”的跨越时间在一定程度上处理，详见DateTimeFormatter.parsedLeapSecond() 。

        该方法的替代方法是将该时间格式化/解析为单个时标值。 这是使用appendValue(INSTANT_SECONDS)实现的。

        参数
        fractionalDigits - 要从0到9或-1的格数的小数第二位数，以使用必要的数字
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果小数位数无效

      • appendOffsetId

        public DateTimeFormatterBuilder appendOffsetId​()
        将区域偏移（如“+01：00”）附加到格式化程序。

        这附加了一个指令来格式化/解析偏移ID到构建器。 这相当于调用appendOffset("+HH:mm:ss", "Z") 。 有关格式化和解析的详细信息，请参阅appendOffset(String, String) 。

        结果
        这个，为链接，不为null

      • appendOffset

        public DateTimeFormatterBuilder appendOffset​(String pattern,
                                             String noOffsetText)
        将区域偏移（如“+01：00”）附加到格式化程序。

        这附加了一个指令来格式化/解析偏移ID到构建器。

        在格式化期间，使用等同于使用TemporalQueries.offset()查询时间的机制获得偏移量。 它将使用下面定义的格式进行打印。 如果无法获得偏移量，则抛出异常，除非格式化程序的部分是可选的。

        当以严格模式进行解析时，输入必须包含必须的和可选元素由指定的模式定义。 如果无法解析偏移量，则抛出异常，除非格式化程序的部分是可选的。

        在宽松模式下解析时，只有时间是强制性的 - 分钟和秒是可选的。 如果指定的模式包含冒号，则为冒号。 如果指定的模式是“+ HH”，则冒号的存在是由小数后的字符是否为冒号来确定。 如果无法解析偏移量，则抛出异常，除非格式化程序的部分是可选的。

        偏移的格式由模式控制，模式必须是以下之一：

        • +HH - 小时，忽略分钟和秒
        • +HHmm - 小时，分钟如果非零，忽略秒，没有冒号
        • +HH:mm - 小时，分钟如果非零，忽略第二个，冒号
        • +HHMM - 小时和分钟，忽略第二，没有冒号
        • +HH:MM - 小时和分钟，忽略第二个，冒号
        • +HHMMss - 小时和分钟，第二个如果非零，没有冒号
        • +HH:MM:ss - 小时和分钟，第二个如果非零，用冒号
        • +HHMMSS - 小时，分钟和秒，没有冒号
        • +HH:MM:SS - 小时，分钟和秒，冒号
        • +HHmmss - 小时，分钟如果非零，或者分钟和秒，如果非零，没有冒号
        • +HH:mm:ss - 小时，分钟如果非零，或者分钟，如果非零，则为冒号
        • +H - 小时，忽略分钟和秒
        • +Hmm - 小时，分钟如果非零，忽略秒，没有冒号
        • +H:mm - 小时，分钟如果非零，忽略第二个，冒号
        • +HMM - 小时和分钟，忽略第二个，没有冒号
        • +H:MM - 小时和分钟，忽略第二个，冒号
        • +HMMss - 小时和分钟，第二个如果非零，没有冒号
        • +H:MM:ss - 小时和分钟，第二个如果非零，用冒号
        • +HMMSS - 小时，分钟和秒，没有冒号
        • +H:MM:SS - 小时，分钟和秒，冒号
        • +Hmmss - 小时，分钟如果非零或分钟和秒如果非零，没有冒号
        • +H:mm:ss - 小时，分钟如果非零，或者分钟，如果非零，用冒号
        包含“HH”的模式将格式化并解析两位数的小时，如有必要，填补零填充。 包含“H”的模式将格式化为无填充，并解析一位或两位数字。 在宽松的模式下，解析器会贪婪，并解析最大可能的数字。 当不输出偏移量的总量为零时，“无偏移”文本控制打印什么文本。 示例值为“Z”，“+00：00”，“UTC”或“GMT”。 接受UTC格式的“无偏移”文本以及由模式定义的零加号版本可接受三种格式。
        参数
        pattern - 使用的模式，不为空
        noOffsetText - 偏移量为零时使用的文本，不为空
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果模式无效

      • appendLocalizedOffset

        public DateTimeFormatterBuilder appendLocalizedOffset​(TextStyle style)
        将本地化区域偏移量（如“GMT + 01：00”）附加到格式化程序。

        这将附加本地化区域偏移量到构建器，本地化偏移量的格式由此方法指定的style控制：

        • full - 具有本地偏移文本的格式，例如“GMT”，2位数字小时和分钟字段，可选的第二个字段（如果不为零）和冒号。
        • short - 具有本地化偏移文本的格式，例如“GMT”，小时无前导零，可选的2位数分钟，如果非零则为可选，以及冒号。

        在格式化期间，使用等同于使用TemporalQueries.offset()查询时间的机制获得偏移量。 如果无法获得偏移量，则抛出异常，除非格式化程序的部分是可选的。

        在解析期间，使用上面定义的格式解析偏移量。 如果无法解析偏移量，则抛出异常，除非格式化程序的部分是可选的。

        参数
        style - 要使用的格式样式，不为null
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果样式既不是 full也不是 short

      • appendZoneId

        public DateTimeFormatterBuilder appendZoneId​()
        将时区ID（例如“欧洲/巴黎”或“+02：00”）附加到格式化程序。

        这附加了格式化/解析区域ID到构建器的指令。 区域ID以适合ZonedDateTime的严格方式获得。 相比之下， OffsetDateTime没有适用于此方法的区段ID，请参阅appendZoneOrOffsetId() 。

        在格式化期间，使用等同于使用TemporalQueries.zoneId()查询时间的机制获取区域。 将使用ZoneId.getId()的结果打印 。 如果无法获取该区域，则抛出异常，除非格式化程序的部分是可选的。

        在解析过程中，文本必须与已知区域或偏移量相匹配。 有两种类型的区域ID，基于偏移量，例如“+01：30”和基于区域的“欧洲/伦敦”。 这些被解析不同。 如果解析以“+”，“ - ”，“UT”，“UTC”或“GMT”开头，那么解析器将期望基于偏移的区域，并且将不匹配基于区域的区域。 偏移ID（例如'+02：30'）可能位于解析开头，或以“UT”，“UTC”或“GMT”为前缀。 偏移ID解析等效于使用参数“HH：MM：ss”和no offset字符串“0”使用appendOffset(String, String) 。 如果解析以“UT”，“UTC”或“GMT”开头，并且解析器与以下偏移量ID不匹配，则选择ZoneOffset.UTC 。 在所有其他情况下，已知基于区域的区域列表用于查找最长可用匹配项。 如果没有找到匹配，并且解析以'Z'开始，则选择ZoneOffset.UTC 。 解析器使用case sensitive设置。

        例如，以下将解析：

          "Europe/London"           -- ZoneId.of("Europe/London")
   "Z"                       -- ZoneOffset.UTC
   "UT"                      -- ZoneId.of("UT")
   "UTC"                     -- ZoneId.of("UTC")
   "GMT"                     -- ZoneId.of("GMT")
   "+01:30"                  -- ZoneOffset.of("+01:30")
   "UT+01:30"                -- ZoneOffset.of("+01:30")
   "UTC+01:30"               -- ZoneOffset.of("+01:30")
   "GMT+01:30"               -- ZoneOffset.of("+01:30")
        结果
        这个，为链接，不为null
        另请参见：
        appendZoneRegionId()

      • appendZoneRegionId

        public DateTimeFormatterBuilder appendZoneRegionId​()
        将时区区域ID（如“Europe / Paris”）追加到格式化程序，如果是ZoneOffset ，则拒绝该区域ID。

        这附加了格式化/解析区域ID的指令，只有它是基于区域的ID。

        在格式化期间，使用等同于使用TemporalQueries.zoneId()查询时间的机制获取区域。 如果该区域是ZoneOffset或者无法获取，则抛出异常，除非格式化程序的部分是可选的。 如果区域不是偏移，则区域将使用区域ID从ZoneId.getId()打印 。

        在解析过程中，文本必须与已知区域或偏移量相匹配。 有两种类型的区域ID，基于偏移量，例如“+01：30”和基于区域的“欧洲/伦敦”。 这些被解析不同。 如果解析以“+”，“ - ”，“UT”，“UTC”或“GMT”开头，那么解析器将期望基于偏移的区域，并且将不匹配基于区域的区域。 偏移ID（例如'+02：30'）可能位于解析开头，或以“UT”，“UTC”或“GMT”为前缀。 偏移ID解析等效于使用参数“HH：MM：ss”和no offset字符串'0'使用appendOffset(String, String) 。 如果解析以“UT”，“UTC”或“GMT”开头，并且解析器与以下偏移ID不匹配，则选择ZoneOffset.UTC 。 在所有其他情况下，已知基于区域的区域列表用于查找最长可用匹配项。 如果没有找到匹配，并且解析以“Z”开头，则选择ZoneOffset.UTC 。 解析器使用case sensitive设置。

        例如，以下将解析：

          "Europe/London"           -- ZoneId.of("Europe/London")
   "Z"                       -- ZoneOffset.UTC
   "UT"                      -- ZoneId.of("UT")
   "UTC"                     -- ZoneId.of("UTC")
   "GMT"                     -- ZoneId.of("GMT")
   "+01:30"                  -- ZoneOffset.of("+01:30")
   "UT+01:30"                -- ZoneOffset.of("+01:30")
   "UTC+01:30"               -- ZoneOffset.of("+01:30")
   "GMT+01:30"               -- ZoneOffset.of("+01:30")

        请注意，除了用于获取区域的机制之外，该方法与appendZoneId()相同。 还要注意，解析接受偏移量，而格式化则不会产生偏移量。

        结果
        这个，为链接，不为null
        另请参见：
        appendZoneId()

      • appendZoneOrOffsetId

        public DateTimeFormatterBuilder appendZoneOrOffsetId​()
        使用最佳可用区域ID将时区ID（例如“欧洲/巴黎”或“+02：00”）附加到格式化程序。

        这附加了一个指令来格式化/解析构建器的最佳可用区域或偏移量ID。 以宽松的方式获得区域ID，首先尝试找到真正的区域ID，例如ZonedDateTime ，然后尝试找到一个偏移量，如OffsetDateTime 。

        在格式化期间，使用等同于使用TemporalQueries.zone()查询时间的机制获取区域。 它将使用ZoneId.getId()的结果打印 。 如果无法获取该区域，则抛出异常，除非格式化程序的部分是可选的。

        在解析过程中，文本必须与已知区域或偏移量相匹配。 有两种类型的区域ID，基于偏移量，例如“+01：30”和基于区域的“欧洲/伦敦”。 这些被解析不同。 如果解析以“+”，“ - ”，“UT”，“UTC”或“GMT”开头，那么解析器将期望基于偏移的区域，并且将不匹配基于区域的区域。 偏移ID（例如'+02：30'）可能位于解析开头，或以“UT”，“UTC”或“GMT”为前缀。 偏移ID解析相当于使用参数“HH：MM：ss”和no offset字符串'0'使用appendOffset(String, String) 。 如果解析以“UT”，“UTC”或“GMT”开头，并且解析器与以下偏移量ID不匹配，则选择ZoneOffset.UTC 。 在所有其他情况下，已知基于区域的区域列表用于查找最长可用匹配项。 如果没有找到匹配，并且解析以“Z”开始，则选择ZoneOffset.UTC 。 解析器使用case sensitive设置。

        例如，以下将解析：

          "Europe/London"           -- ZoneId.of("Europe/London")
   "Z"                       -- ZoneOffset.UTC
   "UT"                      -- ZoneId.of("UT")
   "UTC"                     -- ZoneId.of("UTC")
   "GMT"                     -- ZoneId.of("GMT")
   "+01:30"                  -- ZoneOffset.of("+01:30")
   "UT+01:30"                -- ZoneOffset.of("UT+01:30")
   "UTC+01:30"               -- ZoneOffset.of("UTC+01:30")
   "GMT+01:30"               -- ZoneOffset.of("GMT+01:30")

        请注意，除了用于获取区域的机制之外，该方法与appendZoneId()相同。

        结果
        这个，为链接，不为null
        另请参见：
        appendZoneId()

      • appendZoneText

        public DateTimeFormatterBuilder appendZoneText​(TextStyle textStyle)
        将时区名称（如“英国夏令时”）附加到格式化程序。

        这附加了一个指令，以将该区域的文本名称格式化/解析为构建器。

        在格式化期间，使用等同于使用TemporalQueries.zoneId()查询时间的机制获取区域。 如果该区域是ZoneOffset ，则使用ZoneOffset.getId()的结果打印 。 如果区域不是偏移量，则文本名称将被查找DateTimeFormatter中设置的区域设置。 如果正在打印的时间对象表示一个瞬间，或者如果它是不在夏令时或重叠的本地日期时间，则文本将适合夏季或冬季时间文本。 如果查找文本找不到任何合适的结果，那么将打印ID 。 如果无法获取该区域，则抛出异常，除非格式化程序的部分是可选的。

        在解析期间，文本区域名称，区域ID或偏移量被接受。 许多文字区域名称不是唯一的，例如CST可以用于“中央标准时间”和“中国标准时间”。 在这种情况下，区域ID将由格式化程序的locale的区域信息和该区域的标准区域ID确定，例如美洲/纽约州的美国东区。 在这种情况下， appendZoneText(TextStyle, Set)可用于指定一组首选的ZoneId 。

        参数
        textStyle - 要使用的文本样式，不为null
        结果
        这个，为链接，不为null

      • appendZoneText

        public DateTimeFormatterBuilder appendZoneText​(TextStyle textStyle,
                                               Set<ZoneId> preferredZones)
        将时区名称（如“英国夏令时”）附加到格式化程序。

        这附加了一个指令，以将该区域的文本名称格式化/解析为构建器。

        在格式化期间，使用等同于使用TemporalQueries.zoneId()查询时间的机制获取区域。 如果该区域是ZoneOffset ，将使用ZoneOffset.getId()的结果打印 。 如果该区域不是偏移量，则将查找DateTimeFormatter中设置的区域设置的文本名称。 如果正在打印的时间对象表示瞬间，或者如果它是不在夏令时间或重叠的本地日期时间，则文本将适合于夏季或冬季时间文本。 如果查找文本找不到任何合适的结果，那么将打印ID 。 如果无法获取该区域，则抛出异常，除非格式化程序的部分是可选的。

        在解析期间，文本区域名称，区域ID或偏移量被接受。 许多文字区域名称不是唯一的，例如CST可以用于“中央标准时间”和“中国标准时间”。 在这种情况下，区域ID将由格式化程序的locale的区域信息和该区域的标准区域ID确定，例如美洲/纽约州的美国东区。 该方法还允许指定一组优选的ZoneId用于解析。 如果要解析的纹理区域名称不唯一，将使用匹配的首选区域ID。

        如果无法解析该区域，则抛出异常，除非格式化程序的部分是可选的。

        参数
        textStyle - 要使用的文本样式，不为null
        preferredZones - 首选区域ID的集合，不为null
        结果
        这个，为链接，不为null

      • appendGenericZoneText

        public DateTimeFormatterBuilder appendGenericZoneText​(TextStyle textStyle)
        将泛型时区名称（如“太平洋时间”）附加到格式化程序。

        这附加了一个指令，以将该区域的通用文本名称格式化/解析为构建器。 全年的通用名称相同，忽略任何夏令时的变化。 例如，“太平洋时间”是通用名称，而“太平洋标准时间”和“太平洋夏令时”是具体的名称，请参阅appendZoneText(TextStyle) 。

        在格式化期间，使用等同于使用TemporalQueries.zoneId()查询时间的机制获取区域。 如果该区域是ZoneOffset ，则使用ZoneOffset.getId()的结果打印 。 如果该区域不是偏移量，则文本名称将被查找DateTimeFormatter中设置的区域设置。 如果查找文本找不到合适的结果，则打印ID 。 如果无法获取该区域，则抛出异常，除非格式化程序的部分是可选的。

        在解析期间，文本区域名称，区域ID或偏移量被接受。 许多文字区域名称不是唯一的，例如CST可以用于“中央标准时间”和“中国标准时间”。 在这种情况下，区域ID将由来自格式化程序的locale的区域信息和该区域的标准区域ID，例如美国/纽约州的美国东区确定。 在这种情况下， appendGenericZoneText(TextStyle, Set)可用于指定一组优选的ZoneId 。

        参数
        textStyle - 要使用的文本样式，不为null
        结果
        这个，为链接，不为null
        从以下版本开始：
        9

      • appendGenericZoneText

        public DateTimeFormatterBuilder appendGenericZoneText​(TextStyle textStyle,
                                                      Set<ZoneId> preferredZones)
        将泛型时区名称（如“太平洋时间”）附加到格式化程序。

        这附加了一个指令，以将该区域的通用文本名称格式化/解析为构建器。 全年的通用名称相同，忽略任何夏令时的变化。 例如，“太平洋时间”是通用名称，而“太平洋时间”和“太平洋夏令时”是具体名称，请参阅appendZoneText(TextStyle) 。

        该方法还允许指定一组优选的ZoneId进行解析。 如果要解析的纹理区域名称不唯一，将使用匹配的首选区域ID。

        有关格式化和解析的详细信息，请参阅appendGenericZoneText(TextStyle) 。

        参数
        textStyle - 要使用的文本样式，不为空
        preferredZones - 首选区域ID的集合，不为null
        结果
        这个，为链接，不为null
        从以下版本开始：
        9

      • appendChronologyId

        public DateTimeFormatterBuilder appendChronologyId​()
        将时间序列ID（如“ISO”或“ThaiBuddhist”）附加到格式化程序。

        这附加了一个指令，用于格式化/解析编制ID到构建器。

        在格式化期间，使用等同于使用TemporalQueries.chronology()查询时间的机制获得年表。 将使用Chronology.getId()的结果打印 。 如果不能获得年表，则抛出异常，除非格式化程序的部分是可选的。

        在解析期间，年表被解析，并且必须匹配Chronology.getAvailableChronologies()中的一个年表。 如果不能解析年表，则抛出异常，除非格式化程序的部分是可选的。 解析器使用case sensitive设置。

        结果
        这个，为链接，不为null

      • appendChronologyText

        public DateTimeFormatterBuilder appendChronologyText​(TextStyle textStyle)
        将年表名称附加到格式化程序。

        日历系统名称将在格式输出。 如果无法获得年表，则会抛出异常。

        参数
        textStyle - 要使用的文本样式，不为null
        结果
        这个，为链接，不为null

      • appendLocalized

        public DateTimeFormatterBuilder appendLocalized​(FormatStyle dateStyle,
                                                FormatStyle timeStyle)
        将本地化的日期时间模式附加到格式化程序。

        这将本地化部分附加到构建器，适用于输出日期，时间或日期时间组合。 基于四个项目，本地化部分的格式被懒惰地查找：

        • 这个方法指定了dateStyle
        • 这个方法指定了timeStyle
        • Locale的DateTimeFormatter
        • Chronology ，选择最好的可用
        在格式化期间，年龄从被格式化的时间对象获得，这可能已被DateTimeFormatter.withChronology(Chronology)覆盖。 FULL和LONG样式通常需要时区。 使用这些样式格式化时， ZoneId必须使用ZonedDateTime或DateTimeFormatter.withZone(java.time.ZoneId) 。

        在解析期间，如果已经解析了一个年表，那么它将被使用。 否则使用默认值DateTimeFormatter.withChronology(Chronology) ，其中IsoChronology作为后备。

        请注意，此方法提供了与DateFormat方法类似的功能，如DateFormat.getDateTimeInstance(int, int) 。

        参数
        dateStyle - 要使用的日期样式，null表示不需要日期
        timeStyle - 使用的时间风格，null表示无需时间
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果日期和时间样式都为空

      • appendLiteral

        public DateTimeFormatterBuilder appendLiteral​(char literal)
        在格式化程序中附加一个字符文字。

        此格式将输出此字符。

        参数
        literal - 要附加的字面值，不为null
        结果
        这个，为链接，不为null

      • appendLiteral

        public DateTimeFormatterBuilder appendLiteral​(String literal)
        将一个字符串字面值附加到格式化程序。

        此字符串将在格式输出。

        如果文字为空，则不会将任何内容添加到格式化程序中。

        参数
        literal - 要附加的字面值，不为null
        结果
        这个，为链接，不为null

      • append

        public DateTimeFormatterBuilder append​(DateTimeFormatter formatter)
        将格式化程序的所有元素附加到构建器。

        此方法与将格式化器的每个组成部分直接附加到此构建器具有相同的效果。

        参数
        formatter - 格式化程序添加，不为空
        结果
        这个，为链接，不为null

      • appendOptional

        public DateTimeFormatterBuilder appendOptional​(DateTimeFormatter formatter)
        将一个格式化程序附加到构建器，该构建器可以格式化/解析。

        该方法具有与optionalStart()和optionalEnd()包围的每个构成部分直接附加到该建设者相同的效果。

        如果数据可用于其中包含的所有字段，格式化程序将格式化。 如果字符串匹配，格式化程序将解析，否则返回错误。

        参数
        formatter - 格式化程序添加，不为null
        结果
        这个，为链接，不为null

      • appendPattern

        public DateTimeFormatterBuilder appendPattern​(String pattern)
        将指定模式定义的元素附加到构建器。

        所有字母“A”至“Z”和“a”至“z”保留为图案字母。 字符'＃'，'{'和'}'保留供将来使用。 字符'['和']'表示可选模式。 定义了以下图案字母：

          Symbol  Meaning                     Presentation      Examples
  ------  -------                     ------------      -------
   G       era                         text              AD; Anno Domini; A
   u       year                        year              2004; 04
   y       year-of-era                 year              2004; 04
   D       day-of-year                 number            189
   M/L     month-of-year               number/text       7; 07; Jul; July; J
   d       day-of-month                number            10
   g       modified-julian-day         number            2451334

   Q/q     quarter-of-year             number/text       3; 03; Q3; 3rd quarter
   Y       week-based-year             year              1996; 96
   w       week-of-week-based-year     number            27
   W       week-of-month               number            4
   E       day-of-week                 text              Tue; Tuesday; T
   e/c     localized day-of-week       number/text       2; 02; Tue; Tuesday; T
   F       day-of-week-in-month        number            3

   a       am-pm-of-day                text              PM
   h       clock-hour-of-am-pm (1-12)  number            12
   K       hour-of-am-pm (0-11)        number            0
   k       clock-hour-of-day (1-24)    number            24

   H       hour-of-day (0-23)          number            0
   m       minute-of-hour              number            30
   s       second-of-minute            number            55
   S       fraction-of-second          fraction          978
   A       milli-of-day                number            1234
   n       nano-of-second              number            987654321
   N       nano-of-day                 number            1234000000

   V       time-zone ID                zone-id           America/Los_Angeles; Z; -08:30
   v       generic time-zone name      zone-name         PT, Pacific Time
   z       time-zone name              zone-name         Pacific Standard Time; PST
   O       localized zone-offset       offset-O          GMT+8; GMT+08:00; UTC-08:00;
   X       zone-offset 'Z' for zero    offset-X          Z; -08; -0830; -08:30; -083015; -08:30:15
   x       zone-offset                 offset-x          +0000; -08; -0830; -08:30; -083015; -08:30:15
   Z       zone-offset                 offset-Z          +0000; -0800; -08:00

   p       pad next                    pad modifier      1

   '       escape for text             delimiter
   ''      single quote                literal           '
   [       optional section start
   ]       optional section end
   #       reserved for future use
   {       reserved for future use
   }       reserved for future use

        图案字母的数量决定了格式。 有关模式的用户关注描述，请参阅DateTimeFormatter 。 以下表格定义了图案字母如何映射到构建器。

        日期字段 ：输出日期的模式字母。

          Pattern  Count  Equivalent builder methods
  -------  -----  --------------------------
    G       1      appendText(ChronoField.ERA, TextStyle.SHORT)
    GG      2      appendText(ChronoField.ERA, TextStyle.SHORT)
    GGG     3      appendText(ChronoField.ERA, TextStyle.SHORT)
    GGGG    4      appendText(ChronoField.ERA, TextStyle.FULL)
    GGGGG   5      appendText(ChronoField.ERA, TextStyle.NARROW)

    u       1      appendValue(ChronoField.YEAR, 1, 19, SignStyle.NORMAL)
    uu      2      appendValueReduced(ChronoField.YEAR, 2, 2000)
    uuu     3      appendValue(ChronoField.YEAR, 3, 19, SignStyle.NORMAL)
    u..u    4..n   appendValue(ChronoField.YEAR, n, 19, SignStyle.EXCEEDS_PAD)
    y       1      appendValue(ChronoField.YEAR_OF_ERA, 1, 19, SignStyle.NORMAL)
    yy      2      appendValueReduced(ChronoField.YEAR_OF_ERA, 2, 2000)
    yyy     3      appendValue(ChronoField.YEAR_OF_ERA, 3, 19, SignStyle.NORMAL)
    y..y    4..n   appendValue(ChronoField.YEAR_OF_ERA, n, 19, SignStyle.EXCEEDS_PAD)
    Y       1      append special localized WeekFields element for numeric week-based-year
    YY      2      append special localized WeekFields element for reduced numeric week-based-year 2 digits
    YYY     3      append special localized WeekFields element for numeric week-based-year (3, 19, SignStyle.NORMAL)
    Y..Y    4..n   append special localized WeekFields element for numeric week-based-year (n, 19, SignStyle.EXCEEDS_PAD)

    Q       1      appendValue(IsoFields.QUARTER_OF_YEAR)
    QQ      2      appendValue(IsoFields.QUARTER_OF_YEAR, 2)
    QQQ     3      appendText(IsoFields.QUARTER_OF_YEAR, TextStyle.SHORT)
    QQQQ    4      appendText(IsoFields.QUARTER_OF_YEAR, TextStyle.FULL)
    QQQQQ   5      appendText(IsoFields.QUARTER_OF_YEAR, TextStyle.NARROW)
    q       1      appendValue(IsoFields.QUARTER_OF_YEAR)
    qq      2      appendValue(IsoFields.QUARTER_OF_YEAR, 2)
    qqq     3      appendText(IsoFields.QUARTER_OF_YEAR, TextStyle.SHORT_STANDALONE)
    qqqq    4      appendText(IsoFields.QUARTER_OF_YEAR, TextStyle.FULL_STANDALONE)
    qqqqq   5      appendText(IsoFields.QUARTER_OF_YEAR, TextStyle.NARROW_STANDALONE)

    M       1      appendValue(ChronoField.MONTH_OF_YEAR)
    MM      2      appendValue(ChronoField.MONTH_OF_YEAR, 2)
    MMM     3      appendText(ChronoField.MONTH_OF_YEAR, TextStyle.SHORT)
    MMMM    4      appendText(ChronoField.MONTH_OF_YEAR, TextStyle.FULL)
    MMMMM   5      appendText(ChronoField.MONTH_OF_YEAR, TextStyle.NARROW)
    L       1      appendValue(ChronoField.MONTH_OF_YEAR)
    LL      2      appendValue(ChronoField.MONTH_OF_YEAR, 2)
    LLL     3      appendText(ChronoField.MONTH_OF_YEAR, TextStyle.SHORT_STANDALONE)
    LLLL    4      appendText(ChronoField.MONTH_OF_YEAR, TextStyle.FULL_STANDALONE)
    LLLLL   5      appendText(ChronoField.MONTH_OF_YEAR, TextStyle.NARROW_STANDALONE)

    w       1      append special localized WeekFields element for numeric week-of-year
    ww      2      append special localized WeekFields element for numeric week-of-year, zero-padded
    W       1      append special localized WeekFields element for numeric week-of-month
    d       1      appendValue(ChronoField.DAY_OF_MONTH)
    dd      2      appendValue(ChronoField.DAY_OF_MONTH, 2)
    D       1      appendValue(ChronoField.DAY_OF_YEAR)
    DD      2      appendValue(ChronoField.DAY_OF_YEAR, 2, 3, SignStyle.NOT_NEGATIVE)
    DDD     3      appendValue(ChronoField.DAY_OF_YEAR, 3)
    F       1      appendValue(ChronoField.ALIGNED_DAY_OF_WEEK_IN_MONTH)
    g..g    1..n   appendValue(JulianFields.MODIFIED_JULIAN_DAY, n, 19, SignStyle.NORMAL)
    E       1      appendText(ChronoField.DAY_OF_WEEK, TextStyle.SHORT)
    EE      2      appendText(ChronoField.DAY_OF_WEEK, TextStyle.SHORT)
    EEE     3      appendText(ChronoField.DAY_OF_WEEK, TextStyle.SHORT)
    EEEE    4      appendText(ChronoField.DAY_OF_WEEK, TextStyle.FULL)
    EEEEE   5      appendText(ChronoField.DAY_OF_WEEK, TextStyle.NARROW)
    e       1      append special localized WeekFields element for numeric day-of-week
    ee      2      append special localized WeekFields element for numeric day-of-week, zero-padded
    eee     3      appendText(ChronoField.DAY_OF_WEEK, TextStyle.SHORT)
    eeee    4      appendText(ChronoField.DAY_OF_WEEK, TextStyle.FULL)
    eeeee   5      appendText(ChronoField.DAY_OF_WEEK, TextStyle.NARROW)
    c       1      append special localized WeekFields element for numeric day-of-week
    ccc     3      appendText(ChronoField.DAY_OF_WEEK, TextStyle.SHORT_STANDALONE)
    cccc    4      appendText(ChronoField.DAY_OF_WEEK, TextStyle.FULL_STANDALONE)
    ccccc   5      appendText(ChronoField.DAY_OF_WEEK, TextStyle.NARROW_STANDALONE)

        时间字段 ：输出时间的模式字母。

          Pattern  Count  Equivalent builder methods
  -------  -----  --------------------------
    a       1      appendText(ChronoField.AMPM_OF_DAY, TextStyle.SHORT)
    h       1      appendValue(ChronoField.CLOCK_HOUR_OF_AMPM)
    hh      2      appendValue(ChronoField.CLOCK_HOUR_OF_AMPM, 2)
    H       1      appendValue(ChronoField.HOUR_OF_DAY)
    HH      2      appendValue(ChronoField.HOUR_OF_DAY, 2)
    k       1      appendValue(ChronoField.CLOCK_HOUR_OF_DAY)
    kk      2      appendValue(ChronoField.CLOCK_HOUR_OF_DAY, 2)
    K       1      appendValue(ChronoField.HOUR_OF_AMPM)
    KK      2      appendValue(ChronoField.HOUR_OF_AMPM, 2)
    m       1      appendValue(ChronoField.MINUTE_OF_HOUR)
    mm      2      appendValue(ChronoField.MINUTE_OF_HOUR, 2)
    s       1      appendValue(ChronoField.SECOND_OF_MINUTE)
    ss      2      appendValue(ChronoField.SECOND_OF_MINUTE, 2)

    S..S    1..n   appendFraction(ChronoField.NANO_OF_SECOND, n, n, false)
    A..A    1..n   appendValue(ChronoField.MILLI_OF_DAY, n, 19, SignStyle.NOT_NEGATIVE)
    n..n    1..n   appendValue(ChronoField.NANO_OF_SECOND, n, 19, SignStyle.NOT_NEGATIVE)
    N..N    1..n   appendValue(ChronoField.NANO_OF_DAY, n, 19, SignStyle.NOT_NEGATIVE)

        区域ID ：要输出的模式字母ZoneId 。

          Pattern  Count  Equivalent builder methods
  -------  -----  --------------------------
    VV      2      appendZoneId()
    v       1      appendGenericZoneText(TextStyle.SHORT)
    vvvv    4      appendGenericZoneText(TextStyle.FULL)
    z       1      appendZoneText(TextStyle.SHORT)
    zz      2      appendZoneText(TextStyle.SHORT)
    zzz     3      appendZoneText(TextStyle.SHORT)
    zzzz    4      appendZoneText(TextStyle.FULL)

        区域偏移 ：要输出的模式字母ZoneOffset 。

          Pattern  Count  Equivalent builder methods
  -------  -----  --------------------------
    O       1      appendLocalizedOffset(TextStyle.SHORT)
    OOOO    4      appendLocalizedOffset(TextStyle.FULL)
    X       1      appendOffset("+HHmm","Z")
    XX      2      appendOffset("+HHMM","Z")
    XXX     3      appendOffset("+HH:MM","Z")
    XXXX    4      appendOffset("+HHMMss","Z")
    XXXXX   5      appendOffset("+HH:MM:ss","Z")
    x       1      appendOffset("+HHmm","+00")
    xx      2      appendOffset("+HHMM","+0000")
    xxx     3      appendOffset("+HH:MM","+00:00")
    xxxx    4      appendOffset("+HHMMss","+0000")
    xxxxx   5      appendOffset("+HH:MM:ss","+00:00")
    Z       1      appendOffset("+HHMM","+0000")
    ZZ      2      appendOffset("+HHMM","+0000")
    ZZZ     3      appendOffset("+HHMM","+0000")
    ZZZZ    4      appendLocalizedOffset(TextStyle.FULL)
    ZZZZZ   5      appendOffset("+HH:MM:ss","Z")

        修饰符 ：修改模式的其余部分的模式字母：

          Pattern  Count  Equivalent builder methods
  -------  -----  --------------------------
    [       1      optionalStart()
    ]       1      optionalEnd()
    p..p    1..n   padNext(n)

        任何未指定的字母序列，无法识别的字母或保留字符都将抛出异常。 未来版本可能会增加一组模式。 建议对要直接输出的所有字符使用单引号，以确保将来的更改不会破坏您的应用程序。

        请注意，模式字符串与SimpleDateFormat类似，但不完全相同。 模式字符串与Unicode Common Locale Data Repository（CLDR / LDML）定义的模式字符串也类似，但不完全相同。 图案字母'X'和'u'与Unicode CLDR / LDML对齐。 相比之下， SimpleDateFormat使用“u”表示星期几。 模式字母'y'和'Y'分解两位数字，多于4位数字不同。 模式字母'n'，'A'，'N'和'p'。 数字类型将拒绝大量数字。

        参数
        pattern - 要添加的模式，不为空
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果模式无效

      • padNext

        public DateTimeFormatterBuilder padNext​(int padWidth)
        使下一个添加的打印机/解析器使用空格来填充到固定宽度。

        这个填充将使用空格填充到固定的宽度。

        格式化时，装饰元素将被输出，然后填充到指定的宽度。 如果超出了焊盘宽度，则在格式化期间将抛出异常。

        在解析期间，填充和修饰的元素将被解析。 如果解析是宽松的，那么焊盘宽度被视为最大值。 填充被贪婪地解析。 因此，如果装饰元素以pad字符开头，则不会被解析。

        参数
        padWidth - 垫宽度，1或更大
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果垫宽度太小

      • padNext

        public DateTimeFormatterBuilder padNext​(int padWidth,
                                        char padChar)
        使下一个添加的打印机/解析器粘贴到固定的宽度。

        此填充用于除零填充之外的填充。 应使用appendValue方法实现零填充。

        格式化时，装饰元素将被输出，然后填充到指定的宽度。 如果超出了焊盘宽度，则在格式化期间将抛出异常。

        在解析期间，填充和修饰的元素将被解析。 如果解析是宽松的，那么焊盘宽度被视为最大值。 如果解析不区分大小写，则pad字符匹配忽略大小写。 填充被贪婪地解析。 因此，如果装饰元素以pad字符开头，则不会被解析。

        参数
        padWidth - 垫宽度，1或更大
        padChar - 垫字符
        结果
        这个，为链接，不为null
        异常
        IllegalArgumentException - 如果焊盘宽度太小

      • optionalStart

        public DateTimeFormatterBuilder optionalStart​()
        标记可选部分的开始。

        格式化的输出可以包括可以嵌套的可选部分。 通过调用此方法启动可选部分，并通过调用optionalEnd()或通过结束构建过程结束。

        可选部分中的所有元素都被视为可选的。 在格式化期间，只有在TemporalAccessor有关该部分中所有元素的数据的情况下，才会输出该部分。 在解析期间，整个部分可能从解析的字符串中丢失。

        例如，考虑一个构建器设置为builder.appendValue(HOUR_OF_DAY,2).optionalStart().appendValue(MINUTE_OF_HOUR,2) 。 可选部分自动结束在构建器的末尾。 在格式化期间，只有当它的值可以从日期时间获得时，分钟才会被输出。 在解析期间，无论分钟是否存在，输入将被成功解析。

        结果
        这个，为链接，不为null

      • optionalEnd

        public DateTimeFormatterBuilder optionalEnd​()
        结束可选部分。

        格式化的输出可以包括可以嵌套的可选部分。 通过调用optionalStart()启动可选部分，并使用此方法（或构建器的末尾）结束。

        调用此方法而不会先前称为optionalStart将抛出异常。 在调用optionalStart之后立即调用此方法对格式化程序没有影响，而不是结束（空）可选部分。

        可选部分中的所有元素都被视为可选的。 在格式化期间，只有在TemporalAccessor有关该部分中所有元素的数据可用时，才会输出该部分。 在解析期间，整个部分可能从解析的字符串中丢失。

        例如，考虑一个构建器设置为builder.appendValue(HOUR_OF_DAY,2).optionalStart().appendValue(MINUTE_OF_HOUR,2).optionalEnd() 。 在格式化期间，只有当它的值可以从日期时间获得时，分钟才会被输出。 在解析期间，无论分钟是否存在，输入将被成功解析。

        结果
        这个，为链接，不为null
        异常
        IllegalStateException - 如果以前没有拨打 optionalStart

      • toFormatter

        public DateTimeFormatter toFormatter​()
        通过使用默认语言环境创建DateTimeFormatter来完成此构建器。

        这将创建一个格式化程序与default FORMAT locale 。 将使用标准的DecimalStyle打印和解析数字。 解析器样式将为SMART 。

        调用此方法将在创建格式化程序之前重复调用optionalEnd()结束任何打开的可选部分。

        如果需要，该构建器仍然可以在创建格式化程序后使用，尽管状态可能已通过调用更改为optionalEnd 。

        结果
        创建的格式化程序，不为null

      • toFormatter

        public DateTimeFormatter toFormatter​(Locale locale)
        通过使用指定的区域设置创建DateTimeFormatter来完成此构建器。

        这将创建一个具有指定区域设置的格式化程序。 将使用标准的DecimalStyle打印和解析数字。 解析器样式将为SMART 。

        调用此方法将在创建格式化程序之前重复调用optionalEnd()结束任何打开的可选部分。

        如果需要，可以在创建格式化程序后使用此构建器，尽管可能通过调用optionalEnd更改了状态。

        参数
        locale - 用于格式化的区域设置，不为空
        结果
        the created formatter, not null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DateTimeParseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.format

Class DateTimeParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.time.DateTimeException
            • java.time.format.DateTimeParseException
  • All Implemented Interfaces:
    Serializable

    public class DateTimeParseException
extends DateTimeException
    解析期间发生错误时抛出异常。

    此异常包括被解析的文本和错误索引。

    实现要求：
    该类旨在用于单个线程。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DateTimeParseException​(String message, CharSequence parsedData, int errorIndex)
      使用指定的消息构造新的异常。
      DateTimeParseException​(String message, CharSequence parsedData, int errorIndex, Throwable cause)
      构造一个新的异常与指定的消息和原因。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getErrorIndex​()
      返回发现错误的索引。
      String getParsedString​()
      返回要解析的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • DateTimeParseException

        public DateTimeParseException​(String message,
                              CharSequence parsedData,
                              int errorIndex)
        使用指定的消息构造新的异常。
        参数
        message - 用于此异常的消息可能为null
        parsedData - 解析文本，不应为null
        errorIndex - 解析字符串中无效的索引应为有效索引

      • DateTimeParseException

        public DateTimeParseException​(String message,
                              CharSequence parsedData,
                              int errorIndex,
                              Throwable cause)
        构造一个新的异常与指定的消息和原因。
        参数
        message - 用于此异常的消息可能为null
        parsedData - 解析的文本，不应该为空
        errorIndex - 解析的字符串中无效的索引应为有效索引
        cause - 原因异常，可能为null

    • 方法详细信息

      • getParsedString

        public String getParsedString​()
        返回要解析的字符串。
        结果
        要解析的字符串不应为null。

      • getErrorIndex

        public int getErrorIndex​()
        返回发现错误的索引。
        结果
        解析的字符串中无效的索引应为有效索引
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DecimalStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.format

Class DecimalStyle

  • java.lang.Object
    • java.time.format.DecimalStyle

  • public final class DecimalStyle
extends Object
    在日期和时间格式中使用的本地化十进制格式。

    处理日期和时间的重要部分是本地化。 该类作为访问信息的中心点。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static DecimalStyle STANDARD
      非本地化十进制风格符号的标准集。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查这个DecimalStyle是否等于另一个DecimalStyle。
      static Set<Locale> getAvailableLocales​()
      列出支持的所有语言环境。
      char getDecimalSeparator​()
      获取表示小数点的字符。
      char getNegativeSign​()
      获取表示负号的字符。
      char getPositiveSign​()
      获取表示正号的字符。
      char getZeroDigit​()
      获取表示零的字符。
      int hashCode​()
      这个DecimalStyle的哈希码。
      static DecimalStyle of​(Locale locale)
      获取指定区域设置的DecimalStyle。
      static DecimalStyle ofDefaultLocale​()
      获取默认的 FORMAT区域设置的 DecimalStyle 。
      String toString​()
      返回描述此DecimalStyle的字符串。
      DecimalStyle withDecimalSeparator​(char decimalSeparator)
      使用代表小数点的新字符返回信息的副本。
      DecimalStyle withNegativeSign​(char negativeSign)
      以一个新的字符返回信息的副本，表示负号。
      DecimalStyle withPositiveSign​(char positiveSign)
      返回信息的副本，并显示一个表示正号的新字符。
      DecimalStyle withZeroDigit​(char zeroDigit)
      返回信息的副本，其中新的字符表示零。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • STANDARD

        public static final DecimalStyle STANDARD
        非本地化十进制风格符号的标准集。

        这对于小数点使用零，正，负和一个点的标准ASCII字符。

    • 方法详细信息

      • getAvailableLocales

        public static Set<Locale> getAvailableLocales​()
        列出支持的所有语言环境。

        地区“en_US”将始终存在。

        结果
        一组支持本地化的区域设置

      • ofDefaultLocale

        public static DecimalStyle ofDefaultLocale​()
        获取默认的FORMAT区域设置的DecimalStyle 。

        此方法提供对区域设置敏感的小数风格符号的访问。

        这相当于调用of(Locale.getDefault(Locale.Category.FORMAT)) 。

        结果
        十进制格式，不为null
        另请参见：
        Locale.Category.FORMAT

      • of

        public static DecimalStyle of​(Locale locale)
        获取指定区域设置的DecimalStyle。

        此方法提供对区域设置敏感的小数风格符号的访问。

        参数
        locale - 语言环境，不为空
        结果
        十进制格式，不为null

      • getZeroDigit

        public char getZeroDigit​()
        获取表示零的字符。

        用于表示数字的字符可能因文化而异。 该方法指定要使用的零字符，这意味着一到九个字符。

        结果
        字符为零

      • withZeroDigit

        public DecimalStyle withZeroDigit​(char zeroDigit)
        返回信息的副本，其中新的字符表示零。

        用于表示数字的字符可能因文化而异。 该方法指定要使用的零字符，这意味着一到九个字符。

        参数
        zeroDigit - 字符为零
        结果
        具有代表零的新字符的副本，不为空

      • getPositiveSign

        public char getPositiveSign​()
        获取表示正号的字符。

        用于表示正数的字符可能因文化而异。 此方法指定要使用的字符。

        结果
        正号的字符

      • withPositiveSign

        public DecimalStyle withPositiveSign​(char positiveSign)
        返回信息的副本，并显示一个表示正号的新字符。

        用于表示正数的字符可能因文化而异。 此方法指定要使用的字符。

        参数
        positiveSign - 正号的字符
        结果
        具有代表正号的新字符的副本，不为空

      • getNegativeSign

        public char getNegativeSign​()
        获取表示负号的字符。

        用于表示负数的字符可能因文化而异。 此方法指定要使用的字符。

        结果
        负号的字符

      • withNegativeSign

        public DecimalStyle withNegativeSign​(char negativeSign)
        以一个新的字符返回信息的副本，表示负号。

        用于表示负数的字符可能因文化而异。 此方法指定要使用的字符。

        参数
        negativeSign - 负号的字符
        结果
        具有代表负号的新字符的副本，不为空

      • getDecimalSeparator

        public char getDecimalSeparator​()
        获取表示小数点的字符。

        用于表示小数点的字符可能因文化而异。 此方法指定要使用的字符。

        结果
        小数点的字符

      • withDecimalSeparator

        public DecimalStyle withDecimalSeparator​(char decimalSeparator)
        使用代表小数点的新字符返回信息的副本。

        用于表示小数点的字符可能因文化而异。 此方法指定要使用的字符。

        参数
        decimalSeparator - 小数点的字符
        结果
        具有代表小数点的新字符的副本，不为空

      • equals

        public boolean equals​(Object obj)
        检查这个DecimalStyle是否等于另一个DecimalStyle。
        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他日期，则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个DecimalStyle的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回描述此DecimalStyle的字符串。
        重写：
        toString在 Object
        结果
        一个字符串描述，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


FormatStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.format

Enum FormatStyle

  • java.lang.Object
    • java.lang.Enum<FormatStyle>
      • java.time.format.FormatStyle
  • All Implemented Interfaces:
    Serializable ， Comparable<FormatStyle>

    public enum FormatStyle
extends Enum<FormatStyle>
    枚举本地化日期，时间或日期时间格式化的风格。

    从配置获取日期时间样式时，将使用这些样式。 参见DateTimeFormatter和DateTimeFormatterBuilder以供使用。

    实现要求：
    这是一个不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      FULL
      全文风格，最细节。
      LONG
      长文字风格，有很多细节。
      MEDIUM
      中等文字风格，有一些细节。
      SHORT
      短文本样式，通常为数字。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FormatStyle valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FormatStyle[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • FULL

        public static final FormatStyle FULL
        全文风格，最细节。 例如，格式可能是“公元1952年4月12日星期二”或“太平洋标准时间下午3:30:42”。

      • LONG

        public static final FormatStyle LONG
        长文字风格，有很多细节。 例如，格式可能是“1952年1月12日”。

      • MEDIUM

        public static final FormatStyle MEDIUM
        中等文字风格，有一些细节。 例如，格式可能是“1952年1月12日”。

      • SHORT

        public static final FormatStyle SHORT
        短文本样式，通常为数字。 例如，格式可能是“12 .13.52”或“下午3:30”。

    • 方法详细信息

      • values

        public static FormatStyle[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (FormatStyle c : FormatStyle.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static FormatStyle valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


java.time.format (Java SE 9 & JDK 9 )

java.time.format

Classes

  • DateTimeFormatter
  • DateTimeFormatterBuilder
  • DecimalStyle

Enums

  • FormatStyle
  • ResolverStyle
  • SignStyle
  • TextStyle

Exceptions

  • DateTimeParseException


java.time.format (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.time.format

提供打印和解析日期和时间的类。

打印和解析是基于DateTimeFormatter类。 实例通常从DateTimeFormatter获得，然而如果需要更多的功率，则可以使用DateTimeFormatterBuilder 。

本地化通过在格式化程序上调用withLocale(Locale)进行。 使用DecimalStyle进一步定制是可能的。

包装规格

除非另有说明，否则在此包中的任何类或接口中将null参数传递给构造函数或方法将导致抛出NullPointerException 。 Javadoc“@param”定义用于总结空行为。 “ @throws NullPointerException ”没有在每个方法中明确记录。

所有计算应检查数字溢出，并抛出一个ArithmeticException或DateTimeException 。

从以下版本开始：
1.8
  • 类摘要
    Class 描述
    DateTimeFormatter
    格式化器用于打印和解析日期时间对象。
    DateTimeFormatterBuilder
    Builder创建日期格式化程序。
    DecimalStyle
    在日期和时间格式中使用的本地化十进制格式。
  • 枚举摘要
    Enum 描述
    FormatStyle
    枚举本地化日期，时间或日期时间格式化的风格。
    ResolverStyle
    列举不同的方式来解决日期和时间。
    SignStyle
    列举处理正/负号的方法。
    TextStyle
    枚举文本格式和解析的风格。
  • 异常摘要
    异常 描述
    DateTimeParseException
    解析期间发生错误时抛出异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.time.format Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.time.format

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.time.format.DateTimeFormatter
    • java.time.format.DateTimeFormatterBuilder
    • java.time.format.DecimalStyle
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.time.DateTimeException
            • java.time.format.DateTimeParseException

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.time.format.FormatStyle
      • java.time.format.ResolverStyle
      • java.time.format.SignStyle
      • java.time.format.TextStyle
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ResolverStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.format

Enum ResolverStyle

  • java.lang.Object
    • java.lang.Enum<ResolverStyle>
      • java.time.format.ResolverStyle
  • All Implemented Interfaces:
    Serializable ， Comparable<ResolverStyle>

    public enum ResolverStyle
extends Enum<ResolverStyle>
    列举不同的方式来解决日期和时间。

    解析文本字符串分两个阶段。 阶段1是根据添加到构建器的字段的基本文本解析。 阶段2将解析的字段值对解析为日期和/或时间对象。 这种风格用于控制阶段2，解决方式的发生。

    实现要求：
    这是一个不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      LENIENT
      风格大方地解决日期和时间。
      SMART
      风格以智能或智能的方式解决日期和时间。
      STRICT
      风格严格地解决日期和时间。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ResolverStyle valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ResolverStyle[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • STRICT

        public static final ResolverStyle STRICT
        风格严格地解决日期和时间。

        使用严格的分辨率将确保所有解析的值都在该字段的有效值的外部范围内。 可以进一步处理各个领域的严格性。

        例如，使用严格模式在ISO日历系统中解决月份和日期，将确保月日有效，拒绝无效值。

      • SMART

        public static final ResolverStyle SMART
        风格以智能或智能的方式解决日期和时间。

        使用智能分辨率将对每个字段执行合理的默认，这可能与strict相同，与宽松相同，或第三种行为。 个别领域将会有所不同。

        例如，使用智能模式在ISO日历系统中解决月份和日期将确保月日从1到31，将超过上一个有效日期的任何值转换为最后一个有效的日期。

      • LENIENT

        public static final ResolverStyle LENIENT
        风格大方地解决日期和时间。

        使用宽松的解决方案将以适当宽松的方式解析这些值。 个别领域将会有所不同。

        例如，宽松模式允许ISO日历系统中的月份在1到12之间。例如，第15个月被视为在12个月后的3个月。

    • 方法详细信息

      • values

        public static ResolverStyle[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ResolverStyle c : ResolverStyle.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ResolverStyle valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


SignStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.format

Enum SignStyle

  • java.lang.Object
    • java.lang.Enum<SignStyle>
      • java.time.format.SignStyle
  • All Implemented Interfaces:
    Serializable ， Comparable<SignStyle>

    public enum SignStyle
extends Enum<SignStyle>
    列举处理正/负号的方法。

    格式化引擎允许使用此枚举来控制数字的正数和负数。 有关使用情况，请参阅DateTimeFormatterBuilder 。

    实现要求：
    这是一个不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALWAYS
      样式总是输出符号，其中零将输出'+'。
      EXCEEDS_PAD
      如果该值超过焊盘宽度，样式总是输出符号。
      NEVER
      样式从不输出符号，只输出绝对值。
      NORMAL
      只有当值为负时，才能输出符号。
      NOT_NEGATIVE
      风格阻止负值，在打印时抛出异常。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static SignStyle valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SignStyle[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NORMAL

        public static final SignStyle NORMAL
        只有当值为负时，才能输出符号。

        在严格解析中，负号将被接受，正号被拒绝。 在宽松的解析中，任何标志都将被接受。

      • ALWAYS

        public static final SignStyle ALWAYS
        样式总是输出符号，其中零将输出'+'。

        在严格的解析中，没有标志将被拒绝。 在宽松的解析中，任何标志都将被接受，没有一个符号被视为一个正数。

      • NEVER

        public static final SignStyle NEVER
        样式从不输出符号，只输出绝对值。

        在严格解析时，任何标志都将被拒绝。 在宽大的解析中，除非宽度固定，否则任何符号都将被接受。

      • NOT_NEGATIVE

        public static final SignStyle NOT_NEGATIVE
        风格阻止负值，在打印时抛出异常。

        在严格解析时，任何标志都将被拒绝。 在宽大的解析中，除非宽度固定，否则任何符号都将被接受。

      • EXCEEDS_PAD

        public static final SignStyle EXCEEDS_PAD
        如果该值超过焊盘宽度，样式总是输出符号。 负值将始终输出“ - ”号。

        在严格解析时，除非超出了焊盘宽度，否则符号将被拒绝。 在宽松的解析中，任何标志都将被接受，没有一个符号被视为一个正数。

    • 方法详细信息

      • values

        public static SignStyle[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (SignStyle c : SignStyle.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static SignStyle valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TextStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.format

Enum TextStyle

  • java.lang.Object
    • java.lang.Enum<TextStyle>
      • java.time.format.TextStyle
  • All Implemented Interfaces:
    Serializable ， Comparable<TextStyle>

    public enum TextStyle
extends Enum<TextStyle>
    枚举文本格式和解析的风格。

    文本样式定义格式化文本的三种尺寸 - “满”，“短”和“窄”。 这三种尺寸中的每一种均可在“标准”和“独立”变体中使用。

    在大多数语言中，三种尺寸之间的差异是显而易见的。 例如，在英语中，“满月”为“一月”，“短”月为“一月”，“窄”月为“J”。 请注意，狭窄的大小通常不是唯一的。 例如，'1月'，'6月'和'7'都有'窄'文本'J'。

    “标准”和“独立”形式之间的区别是形容词难度很大，英文没有差别。 然而，在其他语言中，单独使用文本时使用的单词与完整日期不同。 例如，一个月在单独使用日期选择器中使用的单词与用于与日期中的日期和年份相关联的月份的单词不同。

    实现要求：
    这是不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      FULL
      全文，通常是完整的描述。
      FULL_STANDALONE
      全文为独立使用，通常为完整描述。
      NARROW
      缩小的文字，通常是单个字母。
      NARROW_STANDALONE
      单独使用的窄文本，通常是单个字母。
      SHORT
      短文，通常是缩写。
      SHORT_STANDALONE
      用于独立使用的简短文本，通常为缩写。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TextStyle asNormal​()
      返回具有相同大小的普通样式。
      TextStyle asStandalone​()
      返回具有相同大小的独立样式。
      boolean isStandalone​()
      如果Style是独立风格，则返回true。
      static TextStyle valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextStyle[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • FULL

        public static final TextStyle FULL
        全文，通常是完整的描述。 例如，周一的星期一可能会输出“星期一”。

      • FULL_STANDALONE

        public static final TextStyle FULL_STANDALONE
        全文为独立使用，通常为完整描述。 例如，周一的星期一可能会输出“星期一”。

      • SHORT

        public static final TextStyle SHORT
        短文，通常是缩写。 例如星期一星期一可能输出“星期一”。

      • SHORT_STANDALONE

        public static final TextStyle SHORT_STANDALONE
        用于独立使用的简短文本，通常为缩写。 例如星期一星期一可能输出“星期一”。

      • NARROW

        public static final TextStyle NARROW
        缩小的文字，通常是单个字母。 例如，星期一星期一可能会输出“M”。

      • NARROW_STANDALONE

        public static final TextStyle NARROW_STANDALONE
        单独使用的窄文本，通常是单个字母。 例如，星期一星期一可能会输出“M”。

    • 方法详细信息

      • values

        public static TextStyle[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TextStyle c : TextStyle.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TextStyle valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • isStandalone

        public boolean isStandalone​()
        如果Style是独立风格，则返回true。
        结果
        如果风格是独立风格，则为真。

      • asStandalone

        public TextStyle asStandalone​()
        返回具有相同大小的独立样式。
        结果
        具有相同尺寸的独立风格

      • asNormal

        public TextStyle asNormal​()
        返回具有相同大小的普通样式。
        结果
        正常样式的大小相同
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Uses of Package java.time.format (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.time.format

  • Packages that use java.time.format
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
  • Classes in java.time.format used by java.time
    Class 描述
    DateTimeFormatter
    格式化器用于打印和解析日期时间对象。
    TextStyle
    枚举文本格式和解析的风格。
  • Classes in java.time.format used by java.time.chrono
    Class 描述
    DateTimeFormatter
    格式化器用于打印和解析日期时间对象。
    ResolverStyle
    列举不同的方式来解决日期和时间。
    TextStyle
    枚举文本格式和解析的风格。
  • Classes in java.time.format used by java.time.format
    Class 描述
    DateTimeFormatter
    格式化器用于打印和解析日期时间对象。
    DateTimeFormatterBuilder
    Builder创建日期格式化程序。
    DecimalStyle
    在日期和时间格式中使用的本地化十进制格式。
    FormatStyle
    枚举本地化日期，时间或日期时间格式化的风格。
    ResolverStyle
    列举不同的方式来解决日期和时间。
    SignStyle
    列举处理正/负号的方法。
    TextStyle
    枚举文本格式和解析的风格。
  • Classes in java.time.format used by java.time.temporal
    Class 描述
    ResolverStyle
    列举不同的方式来解决日期和时间。
  • Classes in java.time.format used by javafx.util.converter
    Class 描述
    DateTimeFormatter
    格式化器用于打印和解析日期时间对象。
    FormatStyle
    枚举本地化日期，时间或日期时间格式化的风格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.format.DateTimeFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.format.DateTimeFormatter

  • Packages that use DateTimeFormatter
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of DateTimeFormatter in java.time

      Methods in java.time with parameters of type DateTimeFormatter
      Modifier and Type 方法 描述
      String LocalDate.format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期。
      String LocalDateTime.format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。
      String LocalTime.format​(DateTimeFormatter formatter)
      此时使用指定的格式化程序格式化。
      String MonthDay.format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化本月。
      String OffsetDateTime.format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。
      String OffsetTime.format​(DateTimeFormatter formatter)
      此时使用指定的格式化程序格式化。
      String Year.format​(DateTimeFormatter formatter)
      今年格式使用指定的格式化程序。
      String YearMonth.format​(DateTimeFormatter formatter)
      使用指定的格式化程序在今年的格式。
      String ZonedDateTime.format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。
      static LocalDate LocalDate.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 LocalDate的实例。
      static LocalDateTime LocalDateTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 LocalDateTime的实例。
      static LocalTime LocalTime.parse​(CharSequence text, DateTimeFormatter formatter)
      从使用特定格式化程序的文本字符串获取 LocalTime的实例。
      static MonthDay MonthDay.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 MonthDay的实例。
      static OffsetDateTime OffsetDateTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 OffsetDateTime的实例。
      static OffsetTime OffsetTime.parse​(CharSequence text, DateTimeFormatter formatter)
      从使用特定格式化程序的文本字符串获取 OffsetTime的实例。
      static Year Year.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 Year的实例。
      static YearMonth YearMonth.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 YearMonth的实例。
      static ZonedDateTime ZonedDateTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 ZonedDateTime的实例。

    • Uses of DateTimeFormatter in java.time.chrono

      Methods in java.time.chrono with parameters of type DateTimeFormatter
      Modifier and Type 方法 描述
      default String ChronoLocalDate.format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期。
      default String ChronoLocalDateTime.format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。
      default String ChronoZonedDateTime.format​(DateTimeFormatter formatter)
      使用指定的格式化程序格式化此日期时间。

    • Uses of DateTimeFormatter in java.time.format

      Fields in java.time.format declared as DateTimeFormatter
      Modifier and Type Field 描述
      static DateTimeFormatter DateTimeFormatter.BASIC_ISO_DATE
      格式化或解析没有偏移量的日期的ISO日期格式化程序，例如“20111203”。
      static DateTimeFormatter DateTimeFormatter.ISO_DATE
      ISO日期格式化程序格式化或解析具有偏移量的日期（如可用），如“2011-12-03”或“2011-12-03 + 01：00”。
      static DateTimeFormatter DateTimeFormatter.ISO_DATE_TIME
      类似ISO的日期格式化程序，用于格式化或解析具有偏移量和区域（如果有的话）的日期时间，如“2011-12-03T10：15：30”，“2011-12-03T10：15：30 + 01” ：00'或'2011-12-03T10：15：30 + 01：00 [欧洲/巴黎]'。
      static DateTimeFormatter DateTimeFormatter.ISO_INSTANT
      ISO即时格式化程序，用于格式化或解析UTC中的即时消息，例如“2011-12-03T10：15：30Z”。
      static DateTimeFormatter DateTimeFormatter.ISO_LOCAL_DATE
      ISO日期格式化程序格式化或解析没有偏移量的日期，如“2011-12-03”。
      static DateTimeFormatter DateTimeFormatter.ISO_LOCAL_DATE_TIME
      ISO日期格式化程序格式化或解析没有偏移量的日期时间，例如“2011-12-03T10：15：30”。
      static DateTimeFormatter DateTimeFormatter.ISO_LOCAL_TIME
      ISO时间格式化程序格式化或解析一个没有偏移量的时间，例如“10：15”或“10：15：30”。
      static DateTimeFormatter DateTimeFormatter.ISO_OFFSET_DATE
      ISO日期格式化程序格式化或解析具有偏移量的日期，例如“2011-12-03 + 01：00”。
      static DateTimeFormatter DateTimeFormatter.ISO_OFFSET_DATE_TIME
      ISO日期格式化程序格式化或解析具有偏移量的日期时间，例如“2011-12-03T10：15：30 + 01：00”。
      static DateTimeFormatter DateTimeFormatter.ISO_OFFSET_TIME
      格式化或解析时间偏移的ISO时间格式化程序，例如“10：15 + 01：00”或“10：15：30 + 01：00”。
      static DateTimeFormatter DateTimeFormatter.ISO_ORDINAL_DATE
      ISO日期格式化程序格式化或解析没有偏移量的序数日期，例如“2012-337”。
      static DateTimeFormatter DateTimeFormatter.ISO_TIME
      格式化或解析时间的ISO时间格式化程序，如果可用的偏移量，如“10：15”，“10：15：30”或“10：15：30 + 01：00”。
      static DateTimeFormatter DateTimeFormatter.ISO_WEEK_DATE
      ISO日期格式化程序，用于格式化或解析不带偏移量的基于周的日期，例如“2012-W48-6”。
      static DateTimeFormatter DateTimeFormatter.ISO_ZONED_DATE_TIME
      类似ISO的日期格式化程序，用于格式化或解析具有偏移和区域的日期时间，例如“2011-12-03T10：15：30 + 01：00 [Europe / Paris]”。
      static DateTimeFormatter DateTimeFormatter.RFC_1123_DATE_TIME
      RFC-1123日期格式化程序，如“星期二，2008年6月3日11:05:30 GMT”。
      Methods in java.time.format that return DateTimeFormatter
      Modifier and Type 方法 描述
      static DateTimeFormatter DateTimeFormatter.ofLocalizedDate​(FormatStyle dateStyle)
      返回ISO年表的区域设置特定日期格式。
      static DateTimeFormatter DateTimeFormatter.ofLocalizedDateTime​(FormatStyle dateTimeStyle)
      返回ISO时代的区域设置特定的日期时间格式化程序。
      static DateTimeFormatter DateTimeFormatter.ofLocalizedDateTime​(FormatStyle dateStyle, FormatStyle timeStyle)
      返回ISO时代的特定日期和时间格式。
      static DateTimeFormatter DateTimeFormatter.ofLocalizedTime​(FormatStyle timeStyle)
      返回ISO时代的区域设置特定时间格式。
      static DateTimeFormatter DateTimeFormatter.ofPattern​(String pattern)
      使用指定的模式创建格式化程序。
      static DateTimeFormatter DateTimeFormatter.ofPattern​(String pattern, Locale locale)
      使用指定的模式和区域设置创建格式化程序。
      DateTimeFormatter DateTimeFormatterBuilder.toFormatter​()
      通过使用默认语言环境创建 DateTimeFormatter来完成此构建器。
      DateTimeFormatter DateTimeFormatterBuilder.toFormatter​(Locale locale)
      通过使用指定的区域设置创建 DateTimeFormatter来完成此构建器。
      DateTimeFormatter DateTimeFormatter.withChronology​(Chronology chrono)
      使用新的覆盖年表返回此格式化程序的副本。
      DateTimeFormatter DateTimeFormatter.withDecimalStyle​(DecimalStyle decimalStyle)
      使用新的DecimalStyle返回此格式化程序的副本。
      DateTimeFormatter DateTimeFormatter.withLocale​(Locale locale)
      使用新的语言环境返回此格式化程序的副本。
      DateTimeFormatter DateTimeFormatter.withResolverFields​(TemporalField... resolverFields)
      使用一组新的解析器字段返回此格式化程序的副本。
      DateTimeFormatter DateTimeFormatter.withResolverFields​(Set<TemporalField> resolverFields)
      使用一组新的解析器字段返回此格式化程序的副本。
      DateTimeFormatter DateTimeFormatter.withResolverStyle​(ResolverStyle resolverStyle)
      使用新的解析器样式返回此格式化程序的副本。
      DateTimeFormatter DateTimeFormatter.withZone​(ZoneId zone)
      使用新的覆盖区域返回此格式化程序的副本。
      Methods in java.time.format with parameters of type DateTimeFormatter
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.append​(DateTimeFormatter formatter)
      将格式化程序的所有元素附加到构建器。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendOptional​(DateTimeFormatter formatter)
      将一个格式化程序附加到构建器，该构建器可以格式化/解析。

    • Uses of DateTimeFormatter in javafx.util.converter

      Constructors in javafx.util.converter with parameters of type DateTimeFormatter
      Constructor 描述
      LocalDateStringConverter​(DateTimeFormatter formatter, DateTimeFormatter parser)
      使用提供的格式化程序和解析器为LocalDate值创建{#link StringConverter}。
      LocalDateTimeStringConverter​(DateTimeFormatter formatter, DateTimeFormatter parser)
      使用提供的格式化程序和解析器为LocalDateTime创建一个270601657213854值。
      LocalTimeStringConverter​(DateTimeFormatter formatter, DateTimeFormatter parser)
      使用提供的格式化程序和解析器为LocalTime值创建一个StringConverter，它们负责选择所需的Locale 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.format.DateTimeFormatterBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.format.DateTimeFormatterBuilder

  • Packages that use DateTimeFormatterBuilder
    软件包 描述
    java.time.format
    提供打印和解析日期和时间的类。

    • Uses of DateTimeFormatterBuilder in java.time.format

      Methods in java.time.format that return DateTimeFormatterBuilder
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.append​(DateTimeFormatter formatter)
      将格式化程序的所有元素附加到构建器。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendChronologyId​()
      将时间序列ID（如“ISO”或“ThaiBuddhist”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendChronologyText​(TextStyle textStyle)
      将年表名称附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendFraction​(TemporalField field, int minWidth, int maxWidth, boolean decimalPoint)
      将日期时间字段的小数值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendGenericZoneText​(TextStyle textStyle)
      将泛型时区名称（如“太平洋时间”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendGenericZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将泛型时区名称（如“太平洋时间”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendInstant​()
      使用ISO-8601即时添加格式化程序，以三组格式化小数位数。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendInstant​(int fractionalDigits)
      使用ISO-8601即时使用格式化程序，可以控制小数位数。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendLiteral​(char literal)
      在格式化程序中附加一个字符文字。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendLiteral​(String literal)
      将一个字符串字面值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendLocalized​(FormatStyle dateStyle, FormatStyle timeStyle)
      将本地化的日期时间模式附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendLocalizedOffset​(TextStyle style)
      将本地化区域偏移量（如“GMT + 01：00”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendOffset​(String pattern, String noOffsetText)
      将区域偏移（如“+01：00”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendOffsetId​()
      将区域偏移（如“+01：00”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendOptional​(DateTimeFormatter formatter)
      将一个格式化程序附加到构建器，该构建器可以格式化/解析。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendPattern​(String pattern)
      将指定模式定义的元素附加到构建器。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendText​(TemporalField field)
      使用全文样式将日期时间字段的文本附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendText​(TemporalField field, TextStyle textStyle)
      将日期时间字段的文本附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendText​(TemporalField field, Map<Long,String> textLookup)
      使用指定的地图将日期时间字段的文本附加到格式化程序以提供文本。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValue​(TemporalField field)
      使用正常输出样式将日期时间字段的值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValue​(TemporalField field, int width)
      使用固定宽度零填充方法将日期时间字段的值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValue​(TemporalField field, int minWidth, int maxWidth, SignStyle signStyle)
      将日期时间字段的值追加到格式化程序，以提供对格式化的完全控制。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValueReduced​(TemporalField field, int width, int maxWidth, int baseValue)
      将日期时间字段的减小值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValueReduced​(TemporalField field, int width, int maxWidth, ChronoLocalDate baseDate)
      将日期时间字段的减小值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendZoneId​()
      将时区ID（例如“欧洲/巴黎”或“+02：00”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendZoneOrOffsetId​()
      使用最佳可用区域ID将时区ID（例如“欧洲/巴黎”或“+02：00”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendZoneRegionId​()
      将时区区域ID（例如“Europe / Paris”）附加到格式化程序，如果是 ZoneOffset ，则拒绝区域ID。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendZoneText​(TextStyle textStyle)
      将时区名称（如“英国夏令时”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将时区名称（如“英国夏令时”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.optionalEnd​()
      结束可选部分。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.optionalStart​()
      标记可选部分的开始。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.padNext​(int padWidth)
      使下一个添加的打印机/解析器使用空格来填充到固定宽度。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.padNext​(int padWidth, char padChar)
      使下一个添加的打印机/解析器粘贴到固定的宽度。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.parseCaseInsensitive​()
      将解析样式更改为格式化程序的其余部分不区分大小写。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.parseCaseSensitive​()
      将解析样式更改为格式化程序的其余部分区分大小写。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.parseDefaulting​(TemporalField field, long value)
      将字段的默认值追加到格式化程序以用于解析。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.parseLenient​()
      将解析样式更改为对于格式化程序的其余部分来说宽松。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.parseStrict​()
      将解析样式更改为严格的格式化程序的其余部分。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.format.DateTimeParseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.format.DateTimeParseException

No usage of java.time.format.DateTimeParseException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.format.DecimalStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.format.DecimalStyle

  • Packages that use DecimalStyle
    软件包 描述
    java.time.format
    提供打印和解析日期和时间的类。

    • Uses of DecimalStyle in java.time.format

      Fields in java.time.format declared as DecimalStyle
      Modifier and Type Field 描述
      static DecimalStyle DecimalStyle.STANDARD
      非本地化十进制风格符号的标准集。
      Methods in java.time.format that return DecimalStyle
      Modifier and Type 方法 描述
      DecimalStyle DateTimeFormatter.getDecimalStyle​()
      获取在格式化期间使用的DecimalStyle。
      static DecimalStyle DecimalStyle.of​(Locale locale)
      获取指定区域设置的DecimalStyle。
      static DecimalStyle DecimalStyle.ofDefaultLocale​()
      获取默认的 FORMAT区域设置的 DecimalStyle 。
      DecimalStyle DecimalStyle.withDecimalSeparator​(char decimalSeparator)
      使用代表小数点的新字符返回信息的副本。
      DecimalStyle DecimalStyle.withNegativeSign​(char negativeSign)
      以一个新的字符返回信息的副本，表示负号。
      DecimalStyle DecimalStyle.withPositiveSign​(char positiveSign)
      返回信息的副本，并显示一个表示正号的新字符。
      DecimalStyle DecimalStyle.withZeroDigit​(char zeroDigit)
      返回信息的副本，其中新的字符表示零。
      Methods in java.time.format with parameters of type DecimalStyle
      Modifier and Type 方法 描述
      DateTimeFormatter DateTimeFormatter.withDecimalStyle​(DecimalStyle decimalStyle)
      使用新的DecimalStyle返回此格式化程序的副本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.format.FormatStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.format.FormatStyle

  • Packages that use FormatStyle
    软件包 描述
    java.time.format
    提供打印和解析日期和时间的类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of FormatStyle in java.time.format

      Methods in java.time.format that return FormatStyle
      Modifier and Type 方法 描述
      static FormatStyle FormatStyle.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FormatStyle[] FormatStyle.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.time.format with parameters of type FormatStyle
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendLocalized​(FormatStyle dateStyle, FormatStyle timeStyle)
      将本地化的日期时间模式附加到格式化程序。
      static String DateTimeFormatterBuilder.getLocalizedDateTimePattern​(FormatStyle dateStyle, FormatStyle timeStyle, Chronology chrono, Locale locale)
      获取区域设置和时间顺序的日期和时间样式的格式模式。
      static DateTimeFormatter DateTimeFormatter.ofLocalizedDate​(FormatStyle dateStyle)
      返回ISO年表的区域设置特定日期格式。
      static DateTimeFormatter DateTimeFormatter.ofLocalizedDateTime​(FormatStyle dateTimeStyle)
      返回ISO时代的区域设置特定的日期时间格式化程序。
      static DateTimeFormatter DateTimeFormatter.ofLocalizedDateTime​(FormatStyle dateStyle, FormatStyle timeStyle)
      返回ISO时代的特定日期和时间格式。
      static DateTimeFormatter DateTimeFormatter.ofLocalizedTime​(FormatStyle timeStyle)
      返回ISO时代的区域设置特定时间格式。

    • Uses of FormatStyle in javafx.util.converter

      Constructors in javafx.util.converter with parameters of type FormatStyle
      Constructor 描述
      LocalDateStringConverter​(FormatStyle dateStyle)
      创建StringConverter为LocalDate值，使用基于默认格式化器和解析器IsoChronology ，指定FormatStyle ，以及用户的Locale 。
      LocalDateStringConverter​(FormatStyle dateStyle, Locale locale, Chronology chronology)
      创建一个字符串转换LocalDate个使用默认的格式和语法分析器，它会根据所提供的值FormatStyle ， Locale ，并Chronology 。
      LocalDateTimeStringConverter​(FormatStyle dateStyle, FormatStyle timeStyle)
      使用LocalDateTime值创建StringConverter ，使用基于IsoChronology的默认格式化程序和解析器，日期和时间的指定值为FormatStyle ，以及用户的Locale 。
      LocalDateTimeStringConverter​(FormatStyle dateStyle, FormatStyle timeStyle, Locale locale, Chronology chronology)
      创建StringConverter为LocalDateTime使用默认格式化器和解析器，其将基于所提供的值FormatStyle个 S， Locale ，和Chronology 。
      LocalTimeStringConverter​(FormatStyle timeStyle)
      为LocalTime创建一个StringConverter ，使用默认格式化程序和解析器与指定的FormatStyle和基于用户的Locale 。
      LocalTimeStringConverter​(FormatStyle timeStyle, Locale locale)
      为LocalTime创建一个StringConverter值，使用默认格式化程序和解析器与指定的FormatStyle和Locale 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.format.ResolverStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.format.ResolverStyle

  • Packages that use ResolverStyle
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of ResolverStyle in java.time.chrono

      Methods in java.time.chrono with parameters of type ResolverStyle
      Modifier and Type | 方法 | 描述
      ChronoLocalDate AbstractChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析时解析为 ChronoField值。
      ChronoLocalDate Chronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField值。
      HijrahDate | HijrahChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      LocalDate IsoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析时解析为 ChronoField值。
      JapaneseDate | JapaneseChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      MinguoDate | MinguoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      ThaiBuddhistDate | ThaiBuddhistChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

    • Uses of ResolverStyle in java.time.format

      Methods in java.time.format that return ResolverStyle
      Modifier and Type 方法 描述
      ResolverStyle DateTimeFormatter.getResolverStyle​()
      获取在解析过程中使用的解析器样式。
      static ResolverStyle ResolverStyle.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ResolverStyle[] ResolverStyle.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.time.format with parameters of type ResolverStyle
      Modifier and Type 方法 描述
      DateTimeFormatter DateTimeFormatter.withResolverStyle​(ResolverStyle resolverStyle)
      使用新的解析器样式返回此格式化程序的副本。

    • Uses of ResolverStyle in java.time.temporal

      Methods in java.time.temporal with parameters of type ResolverStyle
      Modifier and Type 方法 描述
      default TemporalAccessor TemporalField.resolve​(Map<TemporalField,Long> fieldValues, TemporalAccessor partialTemporal, ResolverStyle resolverStyle)
      解决此字段以提供更简单的替代或日期。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.format.SignStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.format.SignStyle

  • Packages that use SignStyle
    软件包 描述
    java.time.format
    提供打印和解析日期和时间的类。

    • Uses of SignStyle in java.time.format

      Methods in java.time.format that return SignStyle
      Modifier and Type 方法 描述
      static SignStyle SignStyle.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SignStyle[] SignStyle.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.time.format with parameters of type SignStyle
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValue​(TemporalField field, int minWidth, int maxWidth, SignStyle signStyle)
      将日期时间字段的值追加到格式化程序，以提供对格式化的完全控制。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.format.TextStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.format.TextStyle

  • Packages that use TextStyle
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。

    • Uses of TextStyle in java.time

      Methods in java.time with parameters of type TextStyle
      Modifier and Type 方法 描述
      String DayOfWeek.getDisplayName​(TextStyle style, Locale locale)
      获取文本表示，如“星期一”或“星期五”。
      String Month.getDisplayName​(TextStyle style, Locale locale)
      获取文本表示，如“1月”或“12月”。
      String ZoneId.getDisplayName​(TextStyle style, Locale locale)
      获取区域的文字表示，例如“英国时间”或“+02：00”。

    • Uses of TextStyle in java.time.chrono

      Methods in java.time.chrono with parameters of type TextStyle
      Modifier and Type 方法 描述
      default String Chronology.getDisplayName​(TextStyle style, Locale locale)
      获取这个年表的文本表示。
      default String Era.getDisplayName​(TextStyle style, Locale locale)
      获得这个时代的文字表现。
      String JapaneseEra.getDisplayName​(TextStyle style, Locale locale)
      获得这个时代的文字表现。

    • Uses of TextStyle in java.time.format

      Methods in java.time.format that return TextStyle
      Modifier and Type 方法 描述
      TextStyle TextStyle.asNormal​()
      返回具有相同大小的普通样式。
      TextStyle TextStyle.asStandalone​()
      返回具有相同大小的独立样式。
      static TextStyle TextStyle.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextStyle[] TextStyle.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.time.format with parameters of type TextStyle
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendChronologyText​(TextStyle textStyle)
      将年表名称附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendGenericZoneText​(TextStyle textStyle)
      将泛型时区名称（如“太平洋时间”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendGenericZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将泛型时区名称（如“太平洋时间”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendLocalizedOffset​(TextStyle style)
      将本地化区域偏移量（如“GMT + 01：00”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendText​(TemporalField field, TextStyle textStyle)
      将日期时间字段的文本附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendZoneText​(TextStyle textStyle)
      将时区名称（如“英国夏令时”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将时区名称（如“英国夏令时”）附加到格式化程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ChronoField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.temporal

Enum ChronoField

  • java.lang.Object
    • java.lang.Enum<ChronoField>
      • java.time.temporal.ChronoField
  • All Implemented Interfaces:
    Serializable ， Comparable<ChronoField> ， TemporalField

    public enum ChronoField
extends Enum<ChronoField>
implements TemporalField
    一套标准的字段。

    这组字段提供基于字段的访问来操纵日期，时间或日期时间。 通过实现TemporalField可以扩展标准的字段集。

    这些字段旨在适用于多个日历系统。 例如，大多数非ISO日历系统将日期定义为年，月和日，只是略有不同的规则。 每个领域的文档解释了它的运作方式。

    实现要求：
    这是一个最终的，不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALIGNED_DAY_OF_WEEK_IN_MONTH
      一个月内排列的星期几。
      ALIGNED_DAY_OF_WEEK_IN_YEAR
      一年内排列的星期几。
      ALIGNED_WEEK_OF_MONTH
      一个月内的对齐周。
      ALIGNED_WEEK_OF_YEAR
      一年内对齐的一周。
      AMPM_OF_DAY
      今天下午。
      CLOCK_HOUR_OF_AMPM
      上午的时钟小时。
      CLOCK_HOUR_OF_DAY
      时钟的一天。
      DAY_OF_MONTH
      月日。
      DAY_OF_WEEK
      星期二，例如星期二。
      DAY_OF_YEAR
      一年的一天。
      EPOCH_DAY
      基于1970-01-01（ISO）的Java时代的时代。
      ERA
      时代。
      HOUR_OF_AMPM
      上午的小时。
      HOUR_OF_DAY
      一天的时间
      INSTANT_SECONDS
      瞬间的时代。
      MICRO_OF_DAY
      微观的一天。
      MICRO_OF_SECOND
      微秒。
      MILLI_OF_DAY
      毫无疑问
      MILLI_OF_SECOND
      毫秒。
      MINUTE_OF_DAY
      一天的时间。
      MINUTE_OF_HOUR
      分钟的小时。
      MONTH_OF_YEAR
      一月份，如三月。
      NANO_OF_DAY
      纳纳天。
      NANO_OF_SECOND
      纳秒秒。
      OFFSET_SECONDS
      从UTC /格林威治的偏移。
      PROLEPTIC_MONTH
      以月份为基础，从0年起连续数月。
      SECOND_OF_DAY
      第二天。
      SECOND_OF_MINUTE
      第二分钟。
      YEAR
      这样的一年，如2012年。
      YEAR_OF_ERA
      时代的一年。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      <R extends Temporal>
      R             		adjustInto​(R temporal, long newValue)
      返回指定时间对象的副本，并设置该字段的值。
      int checkValidIntValue​(long value)
      检查指定的值是否有效并适合 int 。
      long checkValidValue​(long value)
      检查该字段指定的值是否有效。
      TemporalUnit getBaseUnit​()
      获取测量场的单位。
      String getDisplayName​(Locale locale)
      获取所请求语言环境中字段的显示名称。
      long getFrom​(TemporalAccessor temporal)
      从指定的时间对象获取此字段的值。
      TemporalUnit getRangeUnit​()
      获取字段绑定的范围。
      boolean isDateBased​()
      检查此字段是否表示日期的组件。
      boolean isSupportedBy​(TemporalAccessor temporal)
      检查时间对象是否支持该字段。
      boolean isTimeBased​()
      检查此字段是否表示时间的一个组成部分。
      ValueRange range​()
      获取字段的有效值的范围。
      ValueRange rangeRefinedBy​(TemporalAccessor temporal)
      使用时间对象获取此字段的有效值的范围以优化结果。
      String toString​()
      返回声明中包含的此枚举常量的名称。
      static ChronoField valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ChronoField[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.time.temporal.TemporalField

        resolve

    • Enum Constant Detail

      • NANO_OF_SECOND

        public static final ChronoField NANO_OF_SECOND
        纳秒秒。

        这在第二，从0到999,999,999之间的纳秒。 该字段对于所有日历系统具有相同的含义。

        该字段用于表示二分之一处理任何二分之一的纳秒。 的实现TemporalAccessor应该为这一领域提供一个值，如果他们可以返回一个值SECOND_OF_MINUTE ， SECOND_OF_DAY或者INSTANT_SECONDS灌装精度不明零。

        当该字段用于设置值时，应设置与对象存储的精度相同的精度，使用整除除去多余的精度。 例如，如果TemporalAccessor存储时间到毫秒的精度，那么在更换毫秒之前，纳秒必须除以1,000,000。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。 该字段与MILLI_OF_SECOND和MICRO_OF_SECOND结合使用。

      • NANO_OF_DAY

        public static final ChronoField NANO_OF_DAY
        纳纳天。

        这是在一天内的纳秒，从0到（24 * 60 * 60 * 1,000,000,000） - 1.这个字段对于所有日历系统都具有相同的含义。

        该字段用于表示纳秒的处理任何分数的第二。 的实现TemporalAccessor应该为这一领域提供一个值，如果他们可以返回一个值SECOND_OF_DAY填充未知精密零。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。 该值将被分割，以形成NANO_OF_SECOND ， SECOND_OF_MINUTE ， MINUTE_OF_HOUR和HOUR_OF_DAY字段。

      • MICRO_OF_SECOND

        public static final ChronoField MICRO_OF_SECOND
        微秒。

        这在秒数，从0到999,999之间的微秒。 该字段对于所有日历系统具有相同的含义。

        该字段用于表示第二次处理任何分数的微秒。 的实现TemporalAccessor应该为这一领域提供一个值，如果他们可以返回一个值SECOND_OF_MINUTE ， SECOND_OF_DAY或者INSTANT_SECONDS灌装精度不明零。

        当此字段用于设置值时，它的行为方式与设置值为NANO_OF_SECOND的值相乘为1,000。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。 该字段与MILLI_OF_SECOND结合生成NANO_OF_SECOND 。

      • MICRO_OF_DAY

        public static final ChronoField MICRO_OF_DAY
        微观的一天。

        这是一天内的微秒，从0到（24 * 60 * 60 * 1,000,000） - 1.这个字段对于所有的日历系统都是一样的。

        该字段用于表示微时间处理任何第二个分数。 TemporalAccessor实现应该为该字段提供一个值，如果它们可以返回一个SECOND_OF_DAY的值，填充未知精度为零。

        当该字段用于设置值时，它的行为方式与设置值为NANO_OF_DAY的值相乘，值为1,000。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。 该值将被分割，以形成MICRO_OF_SECOND ， SECOND_OF_MINUTE ， MINUTE_OF_HOUR和HOUR_OF_DAY字段。

      • MILLI_OF_SECOND

        public static final ChronoField MILLI_OF_SECOND
        毫秒。

        这将在秒内计数毫秒，从0到999.该字段对于所有日历系统具有相同的含义。

        该字段用于表示第二秒处理任意分数的毫秒。 的实现TemporalAccessor应该为这一领域提供一个值，如果他们可以返回一个值SECOND_OF_MINUTE ， SECOND_OF_DAY或者INSTANT_SECONDS灌装精度不明零。

        当此字段用于设置值时，它的行为方式与设置值为NANO_OF_SECOND的值相乘为1,000,000。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。 该字段与MICRO_OF_SECOND结合使用，生成NANO_OF_SECOND 。

      • MILLI_OF_DAY

        public static final ChronoField MILLI_OF_DAY
        毫无疑问

        这是一天内的毫秒数，从0到（24 * 60 * 60 * 1,000） - 1。这个字段对于所有的日历系统都是一样的。

        该字段用于表示每天处理任何二分之一的数据。 的实现TemporalAccessor应该为这一领域提供一个值，如果他们可以返回一个值SECOND_OF_DAY填充未知精密零。

        当此字段用于设置值时，它的行为方式与设置值为NANO_OF_DAY的值相乘为1,000,000。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。 该值将被分割，以形成MILLI_OF_SECOND ， SECOND_OF_MINUTE ， MINUTE_OF_HOUR和HOUR_OF_DAY字段。

      • SECOND_OF_MINUTE

        public static final ChronoField SECOND_OF_MINUTE
        第二分钟。

        这在一分钟内从0到59计数第二个。该字段对于所有日历系统具有相同的含义。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。

      • SECOND_OF_DAY

        public static final ChronoField SECOND_OF_DAY
        第二天。

        这是一天内的第二个，从0到（24 * 60 * 60） - 1.这个字段对于所有的日历系统都是一样的。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。 该值将被分割，以形成SECOND_OF_MINUTE ， MINUTE_OF_HOUR和HOUR_OF_DAY字段。

      • MINUTE_OF_HOUR

        public static final ChronoField MINUTE_OF_HOUR
        分钟的小时。

        这会计算一小时内的时间，从0到59.该字段对于所有日历系统具有相同的含义。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。

      • MINUTE_OF_DAY

        public static final ChronoField MINUTE_OF_DAY
        一天的时间。

        这将计算一天内的分钟，从0到（24 * 60） - 1。该字段对于所有日历系统具有相同的含义。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。 该值被拆分为MINUTE_OF_HOUR和HOUR_OF_DAY字段。

      • HOUR_OF_AMPM

        public static final ChronoField HOUR_OF_AMPM
        上午的小时。

        这将计算AM / PM中的时间，从0到11.这是在标准的12小时数字时钟上观察到的时间。 该字段对于所有日历系统具有相同的含义。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下从0到11进行验证。 在宽松模式下，该值不被验证。 通过将{AMPM_OF_DAY}值乘以12，结合AMPM_OF_DAY形成HOUR_OF_DAY 。

        有关从1到12的小时数的相关字段，请参阅CLOCK_HOUR_OF_AMPM 。

      • CLOCK_HOUR_OF_AMPM

        public static final ChronoField CLOCK_HOUR_OF_AMPM
        上午的时钟小时。

        这将在AM / PM中的时间从1到12计数。这是在标准的12小时模拟挂钟上观察到的时间。 该字段对于所有日历系统具有相同的含义。

        解析此字段时，其行为等同于以下内容：该值在严格模式下从1到12，在智能模式下从0到12。 在宽松模式下，该值不被验证。 该字段将转换为具有相同值的HOUR_OF_AMPM ，除非该值为12，否则将转换为0。

        有关从0到11的小时数的相关字段，请参阅HOUR_OF_AMPM 。

      • HOUR_OF_DAY

        public static final ChronoField HOUR_OF_DAY
        一天的时间

        这是一天内的时间，从0到23。这是在标准的24小时数字时钟上观察到的时间。 该字段对于所有日历系统具有相同的含义。

        解析此字段时，其行为等同于以下内容：该值在严格和智能模式下验证，但不在宽大模式下验证。 该字段与组合MINUTE_OF_HOUR ， SECOND_OF_MINUTE和NANO_OF_SECOND以产生LocalTime 。 在宽松模式下，任何多余的天数都会被添加到解析日期，或通过DateTimeFormatter.parsedExcessDays()提供 。

        有关从1到24的小时数的相关字段，请参阅CLOCK_HOUR_OF_DAY 。

      • CLOCK_HOUR_OF_DAY

        public static final ChronoField CLOCK_HOUR_OF_DAY
        时钟的一天。

        这是一天内的时间，从1到24。这是在24小时模拟挂钟上观察到的时间。 该字段对于所有日历系统具有相同的含义。

        解析此字段时，其行为等同于以下内容：该值在严格模式下从1到24，在智能模式下从0到24。 在宽松模式下，该值不被验证。 该字段转换为具有相同值的HOUR_OF_DAY ，除非值为24，在这种情况下将其转换为0。

        有关从0到23的小时数的相关字段，请参阅HOUR_OF_DAY 。

      • AMPM_OF_DAY

        public static final ChronoField AMPM_OF_DAY
        今天下午。

        这将在一天内的AM / PM计数，从0（AM）到1（PM）。 该字段对于所有日历系统具有相同的含义。

        当解析此字段时，其行为等同于以下内容：该值在严格和智能模式下从0到1被验证。 在宽松模式下，该值不被验证。 通过将{AMPM_OF_DAY}值乘以12，结合HOUR_OF_AMPM形成HOUR_OF_DAY 。

      • DAY_OF_WEEK

        public static final ChronoField DAY_OF_WEEK
        星期二，例如星期二。

        这代表了星期几的标准概念。 在默认的ISO日历系统中，它具有从星期一（1）到星期日（7）的值。 DayOfWeek类可以用来解释结果。

        大多数非ISO日历系统还定义了符合ISO的七天周。 这些日历系统也必须使用相同的编号系统，从星期一（1）到星期日（7），可以使用DayOfWeek 。

        如果没有标准七天周的日历系统在类似于一周的时间内具有类似的名称或编号天数的概念，则应实施该字段。 建议编号从1开始。

      • ALIGNED_DAY_OF_WEEK_IN_MONTH

        public static final ChronoField ALIGNED_DAY_OF_WEEK_IN_MONTH
        一个月内排列的星期几。

        这表示在星期与本月初相符的一周内的天数计数的概念。 该字段通常与ALIGNED_WEEK_OF_MONTH一起使用 。

        例如，在具有七天周的日历系统中，第一个对齐的月份从月的第1天开始，第二个对齐的周从月8日开始，依此类推。 在每个这些对齐的周内，天数从1到7，并作为该字段的值返回。 因此，1至7月的日期将为1到7的星期数值。8至14的月份将重复此操作，并将周一的值从1到7。

        没有七天的日历系统通常以相同的方式实现此字段，但使用替代周长度。

      • ALIGNED_DAY_OF_WEEK_IN_YEAR

        public static final ChronoField ALIGNED_DAY_OF_WEEK_IN_YEAR
        一年内排列的星期几。

        这表示在一周的时间段内的几天的概念，其周数与年初相符。 该字段通常与ALIGNED_WEEK_OF_YEAR一起使用 。

        例如，在一个七天的日历系统中，第一个对齐的年份从一年的第一天开始，第二个对齐的一周从第8天开始，依此类推。 在每个这些对齐的周内，天数从1到7，并作为该字段的值返回。 因此，1 - 7年的日期将在1到7之间保持一致的日期值。8至14的每一天将重复此操作，每周的值从1到7。

        没有七天的日历系统通常以相同的方式实现此字段，但使用替代周长度。

      • DAY_OF_MONTH

        public static final ChronoField DAY_OF_MONTH
        月日。

        这代表了一个月内的一天的概念。 在默认的ISO日历系统中，它在大多数月份中的值为1到31。 4月，6月，9月，11月有1到30天，而2月有1到28天，闰年29天。

        非ISO日历系统应使用日历系统的用户使用最确定的日期值实现此字段。 通常，这是从1到月的长度的天数。

      • DAY_OF_YEAR

        public static final ChronoField DAY_OF_YEAR
        一年的一天。

        这代表了一年中的一天的概念。 在默认ISO日历系统中，标准年份的值为1到365，闰年的值为1到366。

        非ISO日历系统应使用日历系统用户的最确定日期值实现此字段。 通常，这是从1到年的长度的天数。

        请注意，非ISO日历系统可能具有年号编号系统，在不同点更改月份编号中的自然重置。 一个例子是日历日历系统，其中将时间的变化重置为1，可以在任何日期发生。 年龄和年份重置也导致年的日期重置为1，但不是月的年份或月份。

      • EPOCH_DAY

        public static final ChronoField EPOCH_DAY
        基于1970-01-01（ISO）的Java时代的时代。

        该字段是1970-01-01（ISO）为零的连续计数天数。 请注意，这使用本地时间线，忽略偏移和时区。

        该字段被严格定义为在所有日历系统中具有相同的含义。 这是必要的，以确保日历之间的互操作。

        EpochDay的范围介于（LocalDate.MIN.toEpochDay（），LocalDate.MAX.toEpochDay（））之间。

      • ALIGNED_WEEK_OF_MONTH

        public static final ChronoField ALIGNED_WEEK_OF_MONTH
        一个月内的对齐周。

        这表示在一个月内的周数计数的概念，周数与月初相符。 该字段通常与ALIGNED_DAY_OF_WEEK_IN_MONTH一起使用 。

        例如，在具有七天周的日历系统中，第一个对齐的月份从月的第1天开始，第二个对齐的周从月8日开始，依此类推。 因此，日期值1到7在第1周排列，而月8日至14日在第2周排列，依此类推。

        没有七天的日历系统通常以相同的方式实现此字段，但使用替代周长度。

      • ALIGNED_WEEK_OF_YEAR

        public static final ChronoField ALIGNED_WEEK_OF_YEAR
        一年内对齐的一周。

        这表示在一年中的星期数与几年前相符的周数的概念。 此字段通常与ALIGNED_DAY_OF_WEEK_IN_YEAR一起使用 。

        例如，在一个七天的日历系统中，第一个对齐的年份从一年的第一天开始，第二个对齐的一周从第8天开始，依此类推。 因此，日期值1到7在第1周对齐，而日期值8到14在第2周排列，依此类推。

        没有七天的日历系统通常以相同的方式实现此字段，但使用替代周长度。

      • MONTH_OF_YEAR

        public static final ChronoField MONTH_OF_YEAR
        一月份，如三月。

        这代表了一年中的一个月的概念。 在默认的ISO日历系统中，它具有从1月（1）到12月（12）的值。

        非ISO日历系统应使用日历系统用户最为认可的月份值来实现此字段。 通常，这是从1开始的月数。

      • PROLEPTIC_MONTH

        public static final ChronoField PROLEPTIC_MONTH
        以月份为基础，从0年起连续数月。

        这个字段是在初步年份零的第一个月为零的月份的连续计数。 后来的几个月的价值越来越大。 前几个月的价值越来越小。 几个月的顺序没有差距或断裂。 请注意，这使用本地时间线，忽略偏移和时区。

        在默认ISO日历系统中，2012年6月将具有值(2012 * 12 + 6 - 1) 。 该领域主要用于内部使用。

        非ISO日历系统必须按照上述定义实现此字段。 这仅仅是从开始的初步年份0开始就已经过去的零月份的一个简单的零计数。具有完整的幼年年定义的所有日历系统将有一个零年。 如果日历系统具有排除零年的最小年份，那么必须外推一个，以便定义该方法。

      • YEAR_OF_ERA

        public static final ChronoField YEAR_OF_ERA
        时代的一年。

        这代表了时代的一年的概念。 该字段通常与ERA一起使用 。

        日期的标准心理模型基于三个概念 - 年，月和日。 这些映射到YEAR ， MONTH_OF_YEAR和DAY_OF_MONTH领域。 请注意，没有参考时代。 日期的完整模式需要四个概念 - 时代，年，月和日。 这些映射到ERA ， YEAR_OF_ERA ， MONTH_OF_YEAR和DAY_OF_MONTH领域。 是否使用此字段或YEAR取决于正在使用的心理模型。 有关此主题的更多讨论，请参阅ChronoLocalDate 。

        在默认的ISO日历系统中，有两个定义为“BCE”和“CE”的时间。 “CE”时代是目前正在使用的时代，从年龄的1岁到最大值。 时代“公元前”是前一个时代，而一年的时代倒退了。

        例如，每次减去一年产生以下结果：
        - 年龄2 ='CE'年龄2
        - 年龄1 ='CE'年龄1
        - 年龄0 ='BCE'年龄1
        - 年龄 - 1岁='BCE'年龄2

        请注意，ISO-8601标准没有实际定义时间。 还要注意，由于Julian和Gregorian日历系统之间的变化，ISO时代与公知的AD / BC时代不一致。

        非ISO日历系统应使用日历系统用户最为认可的年龄值实现此领域。 由于大多数日历系统只有两个时代，因此年龄编号方法通常与ISO日历系统使用的方法相同。 年龄的价值通常应该是积极的，但这不是必需的。

      • YEAR

        public static final ChronoField YEAR
        这样的一年，如2012年。

        这代表了一年的概念，顺序排列并使用负数。 这个年龄不是从时代来解释的。 见YEAR_OF_ERA ，显示了从幼年到年龄的映射。

        日期的标准心理模型基于三个概念 - 年，月和日。 这些映射到YEAR ， MONTH_OF_YEAR和DAY_OF_MONTH领域。 请注意，没有参考时代。 日期的完整模式需要四个概念 - 时代，年，月和日。 这些映射到ERA ， YEAR_OF_ERA ， MONTH_OF_YEAR和DAY_OF_MONTH领域。 是否使用此字段或YEAR_OF_ERA取决于正在使用的心理模型。 有关此主题的更多讨论，请参阅ChronoLocalDate 。

        非ISO日历系统应实现此字段如下。 如果日历系统在固定日期之前和之后只有两个时期，则幼年时期的价值必须与后期时代的年龄值相同，而对于较早的时代而言，日渐增长的负值越来越大。 如果日历系统有两个以上的时间，那么可以用任何适当的值来定义幼龄年份值，尽管将其定义为与ISO相同可能是最佳选择。

      • ERA

        public static final ChronoField ERA
        时代。

        这代表了时代的概念，这是时代最大的一个部门。 该字段通常与YEAR_OF_ERA一起使用 。

        在默认的ISO日历系统中，有两个定义为“BCE”和“CE”的时间。 “CE”时代是目前正在使用的时代，从年龄的1岁到最大值。 时代“公元前”是前一个时代，而一年的时代倒退了。 有关完整的示例，请参阅YEAR_OF_ERA 。

        非ISO日历系统应实现此字段来定义时间。 在1970-01-01（ISO）上活跃的时代的价值必须被分配为值1.早期的时间必须具有相对较小的值。 后来的时代必须具有相对较大的值，

      • INSTANT_SECONDS

        public static final ChronoField INSTANT_SECONDS
        瞬间的时代。

        这表示1970-01-01T00：00Z（ISO）为零的顺序计数的概念。 该字段可以与NANO_OF_SECOND一起使用来表示第二个分数。

        Instant表示时间线上的瞬时点。 就自己而言，瞬间信息不足以获得当地的日期时间。 只有当与偏移量或时间段配对时，才能计算当地的日期或时间。

        该字段被严格定义为在所有日历系统中具有相同的含义。 这是必要的，以确保日历之间的互操作。

      • OFFSET_SECONDS

        public static final ChronoField OFFSET_SECONDS
        从UTC /格林威治的偏移。

        这代表UTC /格林威治当地时间的偏移量的概念。

        A ZoneOffset表示当地时间与UTC /格林威治的时间不同。 这通常是固定的几小时和几分钟。 相当于total amount的偏移量，以秒为单位。 例如，在冬季，巴黎的抵消量为+01:00 ，即3600秒。

        该字段被严格定义为在所有日历系统中具有相同的含义。 这是必要的，以确保日历之间的互操作。

    • 方法详细信息

      • values

        public static ChronoField[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ChronoField c : ChronoField.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ChronoField valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • getDisplayName

        public String getDisplayName​(Locale locale)
        描述从接口TemporalField复制
        获取所请求语言环境中字段的显示名称。

        如果区域设置没有显示名称，则必须返回合适的默认值。

        默认实现必须检查locale不为null并返回toString() 。

        Specified by:
        getDisplayName在接口 TemporalField
        参数
        locale - 要使用的语言环境，不为空
        结果
        区域设置的显示名称或合适的默认值，不为空

      • getBaseUnit

        public TemporalUnit getBaseUnit​()
        说明从接口TemporalField复制
        获取测量场的单位。

        字段的单位是在该范围内变化的周期。 例如，在“MonthOfYear”字段中，单位为“Months”。 另见TemporalField.getRangeUnit() 。

        Specified by:
        getBaseUnit在接口 TemporalField
        结果
        定义字段的基本单位的单位不为空

      • getRangeUnit

        public TemporalUnit getRangeUnit​()
        说明从界面TemporalField复制
        获取字段绑定的范围。

        字段的范围是字段在内部变化的周期。 例如，在“MonthOfYear”字段中，范围是“年”。 另见TemporalField.getBaseUnit() 。

        范围从不为空。 例如，'Year'字段是'YearOfForever'的缩写。 因此，它具有“年”和“永远”的单位。

        Specified by:
        getRangeUnit在接口 TemporalField
        结果
        定义字段范围的单位，不为空

      • range

        public ValueRange range​()
        获取字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。

        此方法返回ISO-8601日历系统中的字段范围。 其他日历系统的范围可能不正确。 使用Chronology.range(ChronoField)访问不同日历系统的正确范围。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        Specified by:
        range在接口 TemporalField
        结果
        字段的有效值的范围不为null

      • isDateBased

        public boolean isDateBased​()
        检查此字段是否表示日期的组件。

        从星期几到时代的领域是基于日期的。

        Specified by:
        isDateBased在接口 TemporalField
        结果
        如果它是日期的组成部分，则为true

      • isTimeBased

        public boolean isTimeBased​()
        检查此字段是否表示时间的一个组成部分。

        从纳秒到下午到晚上的场是基于时间的。

        Specified by:
        isTimeBased在接口 TemporalField
        结果
        如果它是时间的一个组成部分，则为真

      • checkValidValue

        public long checkValidValue​(long value)
        检查该字段指定的值是否有效。

        这将验证该值是否在由range()返回的有效值的外部范围内。

        此方法可以检查ISO-8601日历系统中的字段范围。 其他日历系统的范围可能不正确。 使用Chronology.range(ChronoField)访问不同日历系统的正确范围。

        参数
        value - 要检查的值
        结果
        传入的价值

      • checkValidIntValue

        public int checkValidIntValue​(long value)
        检查指定的值是否有效并适合int 。

        这将验证该值是否在由range()返回的有效值的外部范围内。 它还会检查所有有效值是否在int的范围内。

        此方法可以检查ISO-8601日历系统中的字段范围。 其他日历系统的范围可能不正确。 使用Chronology.range(ChronoField)访问不同日历系统的正确范围。

        参数
        value - 要检查的值
        结果
        传入的价值

      • isSupportedBy

        public boolean isSupportedBy​(TemporalAccessor temporal)
        描述从接口TemporalField复制
        检查时间对象是否支持该字段。

        这决定了临时访问者是否支持该字段。 如果这返回false，则不能查询该字段的时间。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用TemporalAccessor.isSupported(TemporalField) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisField.isSupportedBy(temporal);
   temporal = temporal.isSupported(thisField);
        建议使用第二种方法， isSupported(TemporalField) ，因为在代码中阅读更清楚。

        实施应确定是否支持使用ChronoField中可用的字段。

        Specified by:
        isSupportedBy在接口 TemporalField
        参数
        temporal - 要查询的时间对象，不为空
        结果
        如果可以查询此字段的日期时间，则为true，否则为false

      • rangeRefinedBy

        public ValueRange rangeRefinedBy​(TemporalAccessor temporal)
        说明从接口TemporalField复制
        使用时间对象获取此字段的有效值的范围以优化结果。

        这使用时间对象来查找该字段的有效值的范围。 这类似于TemporalField.range() ，但是这种方法使用时间来优化结果。 例如，如果字段为DAY_OF_MONTH则range方法不准确，因为有四个月份的长度可能为DAY_OF_MONTH和31天。 使用此方法与日期允许范围准确，只返回这四个选项之一。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用TemporalAccessor.range(TemporalField) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisField.rangeRefinedBy(temporal);
   temporal = temporal.range(thisField);
        建议使用第二种方法， range(TemporalField) ，因为在代码中阅读更清楚。

        实施应使用ChronoField中可用的字段执行任何查询或计算。 如果不支持该字段，则必须抛出UnsupportedTemporalTypeException 。

        Specified by:
        rangeRefinedBy在接口 TemporalField
        参数
        temporal - 用于细化结果的时间对象，不为null
        结果
        该字段的有效值的范围不为null

      • getFrom

        public long getFrom​(TemporalAccessor temporal)
        说明从接口TemporalField复制
        从指定的时间对象获取此字段的值。

        这将查询该时间对象的该字段的值。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用TemporalAccessor.getLong(TemporalField) （或TemporalAccessor.get(TemporalField) ）：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisField.getFrom(temporal);
   temporal = temporal.getLong(thisField);
        建议使用第二种方法， getLong(TemporalField) ，因为在代码中阅读更清楚。

        实施应使用ChronoField中可用的字段执行任何查询或计算。 如果不支持该字段，则必须抛出UnsupportedTemporalTypeException 。

        Specified by:
        getFrom在接口 TemporalField
        参数
        temporal - 查询的时间对象，不为空
        结果
        该字段的值不为null

      • adjustInto

        public <R extends Temporal> R adjustInto​(R temporal,
                                         long newValue)
        描述从接口TemporalField复制
        返回指定时间对象的副本，并设置该字段的值。

        这将返回一个新的时间对象，该对象基于指定的时间对象，该字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月的日期。 返回的对象具有与指定对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，实施负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用Temporal.with(TemporalField, long) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisField.adjustInto(temporal);
   temporal = temporal.with(thisField);
        建议使用第二种方法， with(TemporalField) ，因为在代码中阅读更清楚。

        实施应使用ChronoField中可用的字段执行任何查询或计算。 如果不支持该字段，则必须抛出UnsupportedTemporalTypeException 。

        实现不能改变指定的时间对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        Specified by:
        adjustInto在接口 TemporalField
        参数类型
        R - 时间对象的类型
        参数
        temporal - 要调整的时间对象，不为null
        newValue - 该字段的新值
        结果
        调整后的时间对象，不为空

      • toString

        public String toString​()
        描述从类复制： Enum
        返回声明中包含的此枚举常量的名称。 该方法可以被覆盖，尽管它通常不是必需或不可取的。 当一个更“程序员友好”的字符串形式存在时，枚举类型应该覆盖此方法。
        Specified by:
        toString在接口 TemporalField
        重写：
        toString在 Enum<ChronoField>
        结果
        这个枚举常数的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ChronoUnit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.temporal

Enum ChronoUnit

  • java.lang.Object
    • java.lang.Enum<ChronoUnit>
      • java.time.temporal.ChronoUnit
  • All Implemented Interfaces:
    Serializable ， Comparable<ChronoUnit> ， TemporalUnit

    public enum ChronoUnit
extends Enum<ChronoUnit>
implements TemporalUnit
    一组标准的日期单位。

    这组单位提供基于单位的访问来操纵日期，时间或日期时间。 可以通过实施TemporalUnit来扩展标准的单位。

    这些单元适用于多个日历系统。 例如，大多数非ISO日历系统定义了几个月，几个月和几天的单位，只是略有不同的规则。 每个单元的文档说明它如何运作。

    实现要求：
    这是一个最终的，不可变的和线程安全的枚举。
    从以下版本开始：
    1.8

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CENTURIES
      代表一个世纪概念的单位。
      DAYS
      代表一天概念的单位。
      DECADES
      代表十年概念的单位。
      ERAS
      代表一个时代概念的单位。
      FOREVER
      代表永恒概念的人造单位。
      HALF_DAYS
      代表AM / PM使用的半天的概念的单位。
      HOURS
      代表一小时概念的单位。
      MICROS
      代表微秒的概念的单位。
      MILLENNIA
      代表千年概念的单位。
      MILLIS
      代表毫秒概念的单位。
      MINUTES
      代表一分钟概念的单位。
      MONTHS
      代表一个月概念的单位。
      NANOS
      代表纳秒概念的单位，最小支持的时间单位。
      SECONDS
      代表第二个概念的单位。
      WEEKS
      代表一周概念的单位。
      YEARS
      代表一年概念的单位。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      <R extends Temporal>
      R             		addTo​(R temporal, long amount)
      返回添加指定句点的指定时间对象的副本。
      long between​(Temporal temporal1Inclusive, Temporal temporal2Exclusive)
      计算两个时间对象之间的时间量。
      Duration getDuration​()
      在ISO日历系统中获取本机的预计持续时间。
      boolean isDateBased​()
      检查本机是否是日期单位。
      boolean isDurationEstimated​()
      检查单位的持续时间是否是估计。
      boolean isSupportedBy​(Temporal temporal)
      检查本机是否受指定的时间对象的支持。
      boolean isTimeBased​()
      检查本机是否是时间单位。
      String toString​()
      返回声明中包含的此枚举常量的名称。
      static ChronoUnit valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ChronoUnit[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NANOS

        public static final ChronoUnit NANOS
        代表纳秒概念的单位，最小支持的时间单位。 对于ISO日历系统，它等于第二单位的第1,000亿分之一。

      • MICROS

        public static final ChronoUnit MICROS
        代表微秒的概念的单位。 对于ISO日历系统，它等于第二单位的第100万部分。

      • MILLIS

        public static final ChronoUnit MILLIS
        代表毫秒概念的单位。 对于ISO日历系统，它等于第二单元的第1000部分。

      • SECONDS

        public static final ChronoUnit SECONDS
        代表第二个概念的单位。 对于ISO日历系统，它等于SI系统中的第二个单位，除了闰秒。

      • MINUTES

        public static final ChronoUnit MINUTES
        代表一分钟概念的单位。 对于ISO日历系统，它等于60秒。

      • HOURS

        public static final ChronoUnit HOURS
        代表一小时概念的单位。 对于ISO日历系统，它等于60分钟。

      • HALF_DAYS

        public static final ChronoUnit HALF_DAYS
        代表AM / PM使用的半天的概念的单位。 对于ISO日历系统，它等于12小时。

      • DAYS

        public static final ChronoUnit DAYS
        代表一天概念的单位。 对于ISO日历系统，这是从午夜到午夜的标准日期。 一天的预计持续时间为24 Hours 。

        当与其他日历系统一起使用时，它必须对应于地球上太阳升起和设定所定义的日期。 不需要从午夜开始 - 在日历系统之间转换时，日期应在中午相当。

      • WEEKS

        public static final ChronoUnit WEEKS
        代表一周概念的单位。 对于ISO日历系统，它等于7天。

        当与其他日历系统一起使用时，它必须对应于整数天。

      • MONTHS

        public static final ChronoUnit MONTHS
        代表一个月概念的单位。 对于ISO日历系统，月份的长度因月份而异。 一个月的预计持续时间是365.2425 Days十二分之一。

        当与其他日历系统一起使用时，它必须对应于整数天。

      • YEARS

        public static final ChronoUnit YEARS
        代表一年概念的单位。 对于ISO日历系统，它等于12个月。 一年的预计持续时间为365.2425 Days 。

        当与其他日历系统一起使用时，它必须对应于大约相当于太阳周围地球通过的一年的整数天数。

      • DECADES

        public static final ChronoUnit DECADES
        代表十年概念的单位。 对于ISO日历系统，它等于10年。

        当与其他日历系统一起使用时，它必须对应于整数天，通常是整数年。

      • CENTURIES

        public static final ChronoUnit CENTURIES
        代表一个世纪概念的单位。 对于ISO日历系统，它等于100年。

        当与其他日历系统一起使用时，它必须对应于整数天，通常是整数年。

      • MILLENNIA

        public static final ChronoUnit MILLENNIA
        代表千年概念的单位。 对于ISO日历系统，它等于1000年。

        当与其他日历系统一起使用时，它必须对应于整数天，通常是整数年。

      • ERAS

        public static final ChronoUnit ERAS
        代表一个时代概念的单位。 ISO日历系统没有时间，因此不可能在日期或日期时间添加时代。 这个时代的估计时间被人为地定义为1,000,000,000 Years 。

        当与其他日历系统一起使用时，本机没有限制。

      • FOREVER

        public static final ChronoUnit FOREVER
        代表永恒概念的人造单位。 这主要与TemporalField一起使用来代表无限的字段，如年份或时代。 该单位的估计持续时间被人为地定义为由Duration支持的最大持续时间。

    • 方法详细信息

      • values

        public static ChronoUnit[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ChronoUnit c : ChronoUnit.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ChronoUnit valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • getDuration

        public Duration getDuration​()
        在ISO日历系统中获取本机的预计持续时间。

        这个班的所有单位都有预计的时间。 天数因夏令时而异，而几个月的长度不同。

        Specified by:
        getDuration在接口 TemporalUnit
        结果
        该单位的估计持续时间不为零

      • isDurationEstimated

        public boolean isDurationEstimated​()
        检查单位的持续时间是否是估计。

        该课程的所有时间单位都被认为是准确的，而该课程中的所有日期单位都被认为是估计的。

        这个定义忽略了闰秒，但是认为由于夏令时和几个月不同，天数不同。

        Specified by:
        isDurationEstimated在接口 TemporalUnit
        结果
        如果持续时间估计为真，则为真，如果准确

      • isDateBased

        public boolean isDateBased​()
        检查本机是否是日期单位。

        从日到日的所有单位都是基于日期的。 基于时间的单位和FOREVER返回false。

        Specified by:
        isDateBased在接口 TemporalUnit
        结果
        如果是日期单位，则为真，如果为单位则为假

      • isTimeBased

        public boolean isTimeBased​()
        检查本机是否是时间单位。

        从纳米到半天的所有单位都是基于时间的。 基于日期的单位和FOREVER返回false。

        Specified by:
        isTimeBased在接口 TemporalUnit
        结果
        如果一个时间单位是真的，如果一个日期单位是假的

      • isSupportedBy

        public boolean isSupportedBy​(Temporal temporal)
        描述从接口TemporalUnit复制
        检查本机是否受指定的时间对象的支持。

        这检查实施日期时间可以加/减这个单位。 这可以用来避免抛出异常。

        此默认实现使用Temporal.plus(long, TemporalUnit)导出值。

        Specified by:
        isSupportedBy在接口 TemporalUnit
        参数
        temporal - 要检查的时间对象，不为空
        结果
        如果设备支持，则为true

      • addTo

        public <R extends Temporal> R addTo​(R temporal,
                                    long amount)
        说明从接口TemporalUnit复制
        返回添加指定句点的指定时间对象的副本。

        增加的时间是这个单位的倍数。 例如，通过在表示“days”的实例上调用该方法，传递日期和期间“3”，可以使用此方法添加“3天”。 要添加的时间可以是负数，这相当于减法。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用Temporal.plus(long, TemporalUnit) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisUnit.addTo(temporal);
   temporal = temporal.plus(thisUnit);
        建议使用第二种方法， plus(TemporalUnit) ，因为在代码中阅读更清楚。

        实现应该执行使用可用的单位有任何疑问或计算ChronoUnit或可用字段ChronoField 。 如果不支持该单元，则必须抛出UnsupportedTemporalTypeException 。

        实现不能改变指定的时间对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        Specified by:
        addTo在接口 TemporalUnit
        参数类型
        R - 时间对象的类型
        参数
        temporal - 要调整的时间对象，不为null
        amount - 要添加的这个单位的数量，正数或负数
        结果
        调整后的时间对象，不为空

      • between

        public long between​(Temporal temporal1Inclusive,
                    Temporal temporal2Exclusive)
        说明从接口TemporalUnit复制
        计算两个时间对象之间的时间量。

        这计算出这个单位的数量。 起始点和终点作为时间对象提供，并且必须是兼容类型。 实施将在计算数量之前将第二类型转换为第一类的实例。 如果结束在开始之前，结果将为负数。 例如，可以使用HOURS.between(startTime, endTime)计算两个时间对象之间的小时HOURS.between(startTime, endTime) 。

        计算返回一个整数，表示两个时间之间的完整单位数。 例如，11时30分至13时29分之间的小时数将只有1小时，因为距离两小时不到1分钟。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用Temporal.until(Temporal, TemporalUnit) ：

          // these two lines are equivalent
   between = thisUnit.between(start, end);
   between = start.until(end, thisUnit);
        应该根据这种做法进行选择，使代码更易读。

        例如，该方法允许计算两个日期之间的天数：

          long daysBetween = DAYS.between(start, end);
  // or alternatively
  long daysBetween = start.until(end, DAYS);

        实现应该执行使用可用的单位有任何疑问或计算ChronoUnit或可用字段ChronoField 。 如果不支持本机，则必须抛出UnsupportedTemporalTypeException 。 实现不能改变指定的时间对象。

        Specified by:
        between在接口 TemporalUnit
        参数
        temporal1Inclusive - 基础时间对象，不为null
        temporal2Exclusive - 另一个时间对象，排他，非空
        结果
        在本单位之间的temporal1Inclusive和temporal2独家之间的时间量; 如果temporal2Exclusive晚于temporal1Inclusive，则为正，如果更早则为负

      • toString

        public String toString​()
        描述从类复制： Enum
        返回声明中包含的此枚举常量的名称。 该方法可以被覆盖，尽管它通常不是必需或不可取的。 当一个更“程序员友好”的字符串形式存在时，枚举类型应该覆盖此方法。
        Specified by:
        toString在接口 TemporalUnit
        重写：
        toString在 Enum<ChronoUnit>
        结果
        这个枚举常数的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


IsoFields (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Class IsoFields

  • java.lang.Object
    • java.time.temporal.IsoFields

  • public final class IsoFields
extends Object
    特定于ISO-8601日历系统的领域和单位，包括季度和周年。

    该类定义了特定于ISO日历系统的字段和单位。

    一年的一年

    ISO-8601标准是基于标准市民12个月的年份。 这通常分为四个季度，通常缩写为Q1，Q2，Q3和Q4。

    1月，2月和3月在第一季度。 四月，五月和六月是第二季度。 7月，8月和9月在第3季度。 十月，十一月和十二月在第四季度。

    完整的日期用三个字段表示：

    • DAY_OF_QUARTER - 四分之一的日子，从1到90，91或92
    • QUARTER_OF_YEAR - 一年内的季度，从1到4
    • YEAR - 标准ISO年

    以周为基础的年

    ISO-8601标准最初是作为数据交换格式，定义日期和时间的字符串格式。 然而，它也定义了基于周年概念的替代方式来表达日期。

    日期用三个字段表示：

    • DAY_OF_WEEK - 从星期一（1）到星期日（7）定义星期几的标准字段
    • WEEK_OF_WEEK_BASED_YEAR - 周内的一周
    • WEEK_BASED_YEAR - 周年
    以周为基础的年份本身就是针对ISO标准的一年。 它与标准年不同，它总是从星期一开始。

    每周一周的第一周是标准ISO年的第一个星期一星期，在新的一年中至少有4天。

    • 如果1月1日是星期一，那么第1周从1月1日开始
    • 如果1月1日是星期二，那么第1周从上一个标准年的12月31日开始
    • 如果1月1日是星期三，那么第1周从上一个标准年的12月30日开始
    • 如果1月1日是星期四，那么第1周从上一年的12月29日开始
    • 如果1月1日是星期五，那么第1周从1月4日开始
    • 如果1月1日是星期六，那么第1周从1月3日开始
    • 如果1月1日是星期天，那么第1周从1月2日开始
    在大多数星期几里有52周，但有时候有53周。

    例如：

    Examples of Week based Years Date Day-of-week Field values 2008-12-28 Sunday Week 52 of week-based-year 2008 2008-12-29 Monday Week 1 of week-based-year 2009 2008-12-31 Wednesday Week 1 of week-based-year 2009 2009-01-01 Thursday Week 1 of week-based-year 2009 2009-01-04 Sunday Week 1 of week-based-year 2009 2009-01-05 Monday Week 2 of week-based-year 2009
    实现要求：

    这个类是不可变的和线程安全的。

    从以下版本开始：
    1.8

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static TemporalField DAY_OF_QUARTER
      代表季度的领域。
      static TemporalField QUARTER_OF_YEAR
      代表季度的领域。
      static TemporalUnit QUARTER_YEARS
      代表四分之一年概念的单位。
      static TemporalField WEEK_BASED_YEAR
      代表周年的领域。
      static TemporalUnit WEEK_BASED_YEARS
      以加法和减法为目的的以星期为单位的单位。
      static TemporalField WEEK_OF_WEEK_BASED_YEAR
      代表周周的一年的领域。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DAY_OF_QUARTER

        public static final TemporalField DAY_OF_QUARTER
        代表季度的领域。

        该字段允许查询和设置第四季度的值。 一季度第一季度的价值从1到90，从闰年第一季度的1降到91，第2季度从1升至91，第3季度和第4季度从1下降到92。

        季度的季度只能在年份，月份和年份可用的情况下计算。

        设置此字段时，该值允许部分宽松，取值范围为1到92.如果该季度少于92天，那么第92天和潜在的第91天在下一个季度。

        在解析的解决阶段，可以从年份，季度和季度创建日期。

        在strict mode中 ，所有三个字段都根据其有效值的范围进行验证。 四分之一场地的验证时间为1到90，91或92，具体取决于年份和季度。

        在smart mode中 ，所有三个字段都根据其有效值的范围进行验证。 四分之一场地在1到92之间验证，忽略了基于年和季的实际范围。 如果一天中的日期超过实际范围一天，则所生成的日期将在一天之后。 如果季度的日期超过实际范围两天，则最后的日期是两天后。

        在lenient mode中 ，仅在有效值的范围内验证年份。 产生的日期相当于以下三个阶段的方法。 首先，在请求的一年的1月1日创建一个日期。 然后取一年的四分之一，减去一个，并将季度的金额添加到日期。 最后，取一季度，减去一个，并将日期中的金额加到日期。

        这个单位是一个不可变的和线程安全的单身人士。

      • QUARTER_OF_YEAR

        public static final TemporalField QUARTER_OF_YEAR
        代表季度的领域。

        该字段允许查询和设置四分之一年的值。 四分之一年的价值从1到4。

        仅当年份可用时，才能计算四分之一季度。

        在解析的解决阶段，可以从年份，季度和季度创建日期。 详见DAY_OF_QUARTER 。

        这个单位是一个不可变的和线程安全的单身人士。

      • WEEK_OF_WEEK_BASED_YEAR

        public static final TemporalField WEEK_OF_WEEK_BASED_YEAR
        代表周周的一年的领域。

        该字段允许查询和设置基于周的年份值。 星期几每周的价值从1到52，如果周为基期为53周，则为53。

        在解析的解决阶段，可以从基于周的年份，周周的年份和星期几创建日期。

        在strict mode中 ，所有三个字段都根据其有效值的范围进行验证。 星期几的年度字段的验证从1到52或53，取决于周年。

        在smart mode中 ，所有三个字段都根据其有效值的范围进行验证。 星期几的年度字段在1到53之间验证，忽略了周年。 如果周的周数为53，但周为周，则只有52周，所以日期是在下周的第1周。

        在lenient mode中 ，仅针对每周的有效值的范围进行验证。 如果星期几超出了1到7的范围，那么生成的日期将被调整适当的周数，以将星期几降至1到7的范围。如果周的周数，基础年值在1到52之间，然后从结果日期添加或减去任何超过周数。

        这个单位是一个不可变的和线程安全的单身人士。

      • WEEK_BASED_YEAR

        public static final TemporalField WEEK_BASED_YEAR
        代表周年的领域。

        该字段允许查询和设置基于周的年份值。

        该字段的范围匹配LocalDate.MAX和LocalDate.MIN 。

        在解析的解决阶段，可以从基于周的年份，周周的年份和星期几创建日期。 详见WEEK_OF_WEEK_BASED_YEAR 。

        这个单位是一个不可变的和线程安全的单身人士。

      • WEEK_BASED_YEARS

        public static final TemporalUnit WEEK_BASED_YEARS
        以加法和减法为目的的以星期为单位的单位。

        这允许将一些以周为基础的年数添加到日期或从日期中减去。 该单位等于52或53周。 一周的估计持续时间与365.2425 Days的标准ISO年度365.2425 Days 。

        添加规则将以周为基数的年数添加到基于周的年份字段的现有值。 如果由此产生的周年只有52周，那么日期将在下一周的第1周。

        这个单位是一个不可变的和线程安全的单身人士。

      • QUARTER_YEARS

        public static final TemporalUnit QUARTER_YEARS
        代表四分之一年概念的单位。 对于ISO日历系统，它等于3个月。 四分之一年的估计时间是365.2425 Days四分之一。

        这个单位是一个不可变的和线程安全的单身人士。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


java.time.temporal (Java SE 9 & JDK 9 )

java.time.temporal

Interfaces

  • Temporal
  • TemporalAccessor
  • TemporalAdjuster
  • TemporalAmount
  • TemporalField
  • TemporalQuery
  • TemporalUnit

Classes

  • IsoFields
  • JulianFields
  • TemporalAdjusters
  • TemporalQueries
  • ValueRange
  • WeekFields

Enums

  • ChronoField
  • ChronoUnit

Exceptions

  • UnsupportedTemporalTypeException


java.time.temporal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.time.temporal

使用字段和单位访问日期和时间，以及日期时间调整器。

该包扩展在基础包上，为更强大的用例提供附加功能。 支持包括：

  • 日期时间单位，如年，月，日，小时
  • 日期时间的字段，如月份，星期几或小时
  • 日期时间调整功能
  • 周的不同定义

领域和单位

日期和时间用字段和单位来表示。 一个单位用来衡量一段时间，例如年，日或分钟。 所有单位实施TemporalUnit 。 众所周知的单位集合在ChronoUnit中定义，如DAYS 。 单元接口设计为允许应用定义单元。

一个字段用于表示较大日期时间的一部分，例如年份，月份或秒数。 所有字段实现TemporalField 。 众所周知的字段集定义在ChronoField中 ，如HOUR_OF_DAY 。 附加字段由定义JulianFields ， WeekFields和IsoFields 。 字段界面旨在允许应用程序定义的字段。

该软件包提供了一些工具，可以以最适合框架的一般方式访问日期和时间的单位和字段。 Temporal提供支持字段的日期时间类型的抽象。 它的方法支持获取一个字段的值，创建一个修改字段的值的新的日期时间，并查询通常用于提取偏移量或时区的其他信息。

应用程序代码中的一个字段的使用是检索没有方便方法的字段。 例如，获取月份是足够普遍的，因为有一个LocalDate称为getDayOfMonth()的方法。 然而，对于更不寻常的领域，有必要使用该领域。 例如， date.get(ChronoField.ALIGNED_WEEK_OF_MONTH) 。 这些字段还提供对有效值范围的访问。

调整和查询

日期时间问题空间的关键部分是将日期调整为新的相关值，例如“月的最后一天”或“下周三”。 这些被建模为调整基准日期时间的函数。 功能实现TemporalAdjuster ，操作Temporal 。 TemporalAdjusters提供了一组常用功能。 例如，要查找给定日期之后的星期几的第一次出现，请使用TemporalAdjusters.next(DayOfWeek) ，例如date.with(next(MONDAY)) 。 应用程序还可以通过实现TemporalAdjuster定义调整器。

TemporalAmount接口模型的相对时间量。

除了调整日期时间外，还提供了一个界面，以通过TemporalQuery进行查询。 查询界面最常用的方法是方法引用。 可以使用主要类的from(TemporalAccessor)方法，如LocalDate::from或Month::from 。 在TemporalQueries中提供了进一步的实现方式作为静态方法。 应用程序还可以通过实现TemporalQuery定义查询。

周

不同的地区有一周不同的定义。 例如，在欧洲，这个星期通常从星期一开始，而在美国，它从星期天开始。 WeekFields类型的这个区别。

ISO日历系统定义了一个额外的基于星期的年份划分。 这定义了整个星期一至星期一的一年。 这是建模在IsoFields 。

包装规格

除非另有说明，否则在此包中的任何类或接口中将null参数传递给构造函数或方法将导致抛出NullPointerException 。 Javadoc“@param”定义用于总结空行为。 “ @throws NullPointerException ”没有在每个方法中明确记录。

所有计算应检查数字溢出，并抛出一个ArithmeticException或DateTimeException 。

从以下版本开始：
1.8
  • 接口摘要
    接口 描述
    Temporal
    定义对时间对象的读写访问的框架级接口，例如日期，时间，偏移或这些的一些组合。
    TemporalAccessor
    框架级接口定义对时间对象的只读访问，例如日期，时间，偏移或这些的某些组合。
    TemporalAdjuster
    调整时间对象的策略。
    TemporalAmount
    定义一段时间的框架级界面，如“6小时”，“8天”或“2年3个月”。
    TemporalField
    日期时间的字段，如月份或小时。
    TemporalQuery<R>
    查询时间对象的策略。
    TemporalUnit
    日期时间单位，如天数或小时数。
  • 类摘要
    Class 描述
    IsoFields
    特定于ISO-8601日历系统的领域和单位，包括季度和周年。
    JulianFields
    一组提供访问朱利安日的日期字段。
    TemporalAdjusters
    常用和有用的TemporalAdjusters。
    TemporalQueries
    通用实现 TemporalQuery 。
    ValueRange
    日期时间字段的有效值的范围。
    WeekFields
    星期几，星期周和周末字段的本地化定义。
  • 枚举摘要
    Enum 描述
    ChronoField
    一套标准的字段。
    ChronoUnit
    一组标准的日期单位。
  • 异常摘要
    异常 描述
    UnsupportedTemporalTypeException
    UnsupportedTemporalTypeException表示Temporal类不支持ChronoField或ChronoUnit。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.time.temporal Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.time.temporal

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.time.temporal.IsoFields
    • java.time.temporal.JulianFields
    • java.time.temporal.TemporalAdjusters
    • java.time.temporal.TemporalQueries
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.time.DateTimeException
            • java.time.temporal.UnsupportedTemporalTypeException
    • java.time.temporal.ValueRange (implements java.io.Serializable)
    • java.time.temporal.WeekFields (implements java.io.Serializable)

Interface Hierarchy

  • java.time.temporal.TemporalAccessor
    • java.time.temporal.Temporal
  • java.time.temporal.TemporalAdjuster
  • java.time.temporal.TemporalAmount
  • java.time.temporal.TemporalField
  • java.time.temporal.TemporalQuery<R>
  • java.time.temporal.TemporalUnit

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.time.temporal.ChronoField (implements java.time.temporal.TemporalField)
      • java.time.temporal.ChronoUnit (implements java.time.temporal.TemporalUnit)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


JulianFields (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Class JulianFields

  • java.lang.Object
    • java.time.temporal.JulianFields

  • public final class JulianFields
extends Object
    一组提供访问朱利安日的日期字段。

    朱利安日是表达科学界常用日期和时间的标准方式。 它表示为从中午开始天数的整数天的十进制数。 这个班级代表了从傍晚的整个日子算起的朱利安天数变化。

    这些字段相对于EPOCH_DAY实现。 支持这些字段，如果有EPOCH_DAY可用，可以查询和设置。 这些领域与所有时间表一起工作。

    实现要求：
    这是一个不可变的和线程安全的课程。
    从以下版本开始：
    1.8

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static TemporalField JULIAN_DAY
      朱利安日字段。
      static TemporalField MODIFIED_JULIAN_DAY
      修改儒略日字段。
      static TemporalField RATA_DIE
      拉塔死场。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • JULIAN_DAY

        public static final TemporalField JULIAN_DAY
        朱利安日字段。

        这是一个基于整数的儒略日号的版本。 朱利安日是一个众所周知的系统，代表了从第0天开始的整个日子的数量，这个系统定义为公元前4713年1月1日，朱利亚历时和-4713-11-24格里高利。 该字段的“JulianDay”为“name”，“DAYS”为“baseUnit”。 字段始终指的是本地日期时间，忽略偏移或区域。

        对于日期时间，“JULIAN_DAY.getFrom（）”从午夜到下一个午夜前的值相同。 当JULIAN_DAY.adjustInto（））应用于日期时间时，时间部分保持不变。 'JULIAN_DAY.adjustInto（）'和'JULIAN_DAY.getFrom（）'仅适用于可转换为ChronoField.EPOCH_DAY的 Temporal对象。 一个UnsupportedTemporalTypeException被抛出任何其他类型的对象。

        在解析的解析阶段，可以从儒略日字段创建日期。 在strict mode和smart mode中 ，朱利安日值根据有效值的范围进行验证。 在lenient mode没有验证发生。

        天文科学笔记

        标准天文定义使用一小部分来表示每天从中午到中午计算的时间。 例如，0的分数表示中午，0.25的分数表示18:00，0.5的分数表示午夜，0.75的分数表示06:00。

        相比之下，此实施方式没有小数部分，并且计算从午夜到午夜的天数。 此实现使用整数和从午夜开始的天数。 朱利安天数的整数值是有关日期中午的天文学朱利安日值。 这相当于天文学的朱利安日，四舍五入到一个整数JDN = floor(JD + 0.5) 。

          | ISO date          |  Julian Day Number | Astronomical Julian Day |
  | 1970-01-01T00:00  |         2,440,588  |         2,440,587.5     |
  | 1970-01-01T06:00  |         2,440,588  |         2,440,587.75    |
  | 1970-01-01T12:00  |         2,440,588  |         2,440,588.0     |
  | 1970-01-01T18:00  |         2,440,588  |         2,440,588.25    |
  | 1970-01-02T00:00  |         2,440,589  |         2,440,588.5     |
  | 1970-01-02T06:00  |         2,440,589  |         2,440,588.75    |
  | 1970-01-02T12:00  |         2,440,589  |         2,440,589.0     |

        有时候Julian Days会暗示世界时间或UTC，但是这个实现总是使用当地日期的儒略日号码，无论偏移量还是时区。

      • MODIFIED_JULIAN_DAY

        public static final TemporalField MODIFIED_JULIAN_DAY
        修改儒略日字段。

        这是一个基于整数的修改儒略日号的版本。 修改朱利安日（MJD）是一个着名的系统，连续几天。 它相对于天文学朱利安日定义为MJD = JD - 2400000.5 。 每个修改后的朱利安日从午夜到午夜。 字段始终指的是本地日期时间，忽略偏移或区域。

        对于日期时间，“MODIFIED_JULIAN_DAY.getFrom（）”从午夜到下一个午夜之前的值相同。 当将MODIFIED_JULIAN_DAY.adjustInto（）'应用于日期时间时，时间部分保持不变。 'MODIFIED_JULIAN_DAY.adjustInto（）'和'MODIFIED_JULIAN_DAY.getFrom（）'仅适用于可转换为ChronoField.EPOCH_DAY的 Temporal对象。 一个UnsupportedTemporalTypeException被抛出任何其他类型的对象。

        该实现是MJD的整数版本，小数部分舍入为floor。

        在解析的解析阶段，可以从修改的儒略日字段创建日期。 在strict mode和smart mode中 ，修改的朱利安日值根据有效值的范围进行验证。 在lenient mode没有验证发生。

        天文科学笔记

          | ISO date          | Modified Julian Day |      Decimal MJD |
  | 1970-01-01T00:00  |             40,587  |       40,587.0   |
  | 1970-01-01T06:00  |             40,587  |       40,587.25  |
  | 1970-01-01T12:00  |             40,587  |       40,587.5   |
  | 1970-01-01T18:00  |             40,587  |       40,587.75  |
  | 1970-01-02T00:00  |             40,588  |       40,588.0   |
  | 1970-01-02T06:00  |             40,588  |       40,588.25  |
  | 1970-01-02T12:00  |             40,588  |       40,588.5   |
        修改后的Julian Days有时被用来表示“世界时间”或“UTC”，但这个实现始终使用修改后的儒略日作为本地日期，而不考虑偏移或时区。

      • RATA_DIE

        public static final TemporalField RATA_DIE
        拉塔死场。

        在零零零年1-01-01年（ISO）开始的午夜，Rata Die从第1天开始计数。 字段始终指的是本地日期时间，忽略偏移或区域。

        对于日期时间，“RATA_DIE.getFrom（）”从午夜到下一个午夜之前的值相同。 当“RATA_DIE.adjustInto（）”应用于日期时间时，时间部分保持不变。 'RATA_DIE.adjustInto（）'和'RATA_DIE.getFrom（）'仅适用于可转换为ChronoField.EPOCH_DAY的 Temporal对象。 一个UnsupportedTemporalTypeException被抛出任何其他类型的对象。

        在解析的解析阶段，可以从Rata Die字段创建一个日期。 在strict mode和smart mode中 ，Rata Die值根据有效值的范围进行验证。 在lenient mode没有验证。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Temporal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Interface Temporal

  • All Superinterfaces:
    TemporalAccessor
    All Known Subinterfaces:
    ChronoLocalDate ， ChronoLocalDateTime<D> ， ChronoZonedDateTime<D>
    所有已知实现类：
    HijrahDate ， Instant ， JapaneseDate ， LocalDate ， LocalDateTime ， LocalTime ， MinguoDate ， OffsetDateTime ， OffsetTime ， ThaiBuddhistDate ， Year ， YearMonth ， ZonedDateTime

    public interface Temporal
extends TemporalAccessor
    定义对时间对象的读写访问的框架级接口，例如日期，时间，偏移或这些的一些组合。

    这是日期，时间和偏移对象的基本界面类型，其完整性足以使用加和减操作。 它由那些可以提供和操纵信息的类实现，如fields或queries 。 有关此接口的只读版本，请参阅TemporalAccessor 。

    大多数日期和时间信息可以表示为一个数字。 这些是使用模拟TemporalField使用保持的号码long处理大值。 年份，月份和日期是字段的简单示例，但它们还包括即时和偏移量。 有关标准的字段集，请参阅ChronoField 。

    两个日期/时间信息不能由数字chronology和time-zone表示 。 这些可以通过queries使用TemporalQuery上定义的静态方法访问 。

    该接口是一个框架级接口，不应该在应用程序代码中广泛使用。 相反，应用程序应该创建并传递具体类型的实例，例如LocalDate 。 这有很多原因，其中一部分是该接口的实现可能在除ISO之外的日历系统中。 有关这些问题的更全面的讨论，请参阅ChronoLocalDate 。

    何时实施

    如果一个类符合三个条件，则应该实现此接口：

    • 它提供访问日期/时间/偏移量信息，按照TemporalAccessor
    • 一组字段是从最大到最小的
    • 该集合的字段是完整的，使得不需要其他字段来定义表示的字段的值的有效范围

    四个例子说明如下：

    • LocalDate实现了这个接口，因为它代表了从几天到永远连续的一组字段，并且不需要外部信息来确定每个日期的有效性。 因此，可以正确地执行正/负。
    • LocalTime实现这个接口，因为它表示一组从nanos到几天的连续字段，并且不需要外部信息来确定有效性。 它能够正确地执行正/负，通过包裹在一天。
    • MonthDay ，月和日的组合不实现这个界面。 虽然组合是连续的，从几天到几个月内，组合没有足够的信息来定义月日的有效价值范围。 因此，无法正确执行正/负。
    • 星期几和星期几（“星期五13号”）的组合不应该实现这个界面。 它不代表连续的一组字段，因为几天到几个星期的重叠几天到几个月。
    实现要求：
    此接口对实现的可变性没有任何限制，但是强烈建议不变性。 所有实现都必须是Comparable 。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      default Temporal minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default Temporal minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      Temporal plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      default Temporal plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      long until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个时间的时间量。
      default Temporal with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      Temporal with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。

      • Methods inherited from interface java.time.temporal.TemporalAccessor

        get, getLong, isSupported, query, range

    • 方法详细信息

      • isSupported

        boolean isSupported​(TemporalUnit unit)
        检查指定的单位是否受支持。

        这将检查指定的单位是否可以添加到该日期时间或从该日期时间中减去。 如果是false，那么调用plus(long, TemporalUnit)和minus的方法会抛出异常。

        实现要求：
        实施必须检查并处理ChronoUnit中定义的所有单位。 如果单位得到支持，则必须返回true，否则返回false。

        如果该字段是不是一个ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.isSupportedBy(Temporal)传递this作为参数。

        当这个只读方法被调用时，实现必须确保没有可观察的状态被改变。

        参数
        unit - 要检查的单位，null返回false
        结果
        如果可以添加/减去单位，则为真，否则为false

      • with

        default Temporal with​(TemporalAdjuster adjuster)
        通过进行调整，返回与该对象相同类型的调整对象。

        这将根据指定的调整器的规则调整此日期时间。 一个简单的调整器可能只是设置一个字段，如年份字段。 更复杂的调整器可能会将日期设置为该月的最后一天。 在TemporalAdjusters中提供了一些常见的调整。 这些包括找到“月的最后一天”和“下周三”。 调整员负责处理特殊情况，如月份和闰年的不同长度。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.with(Month.JULY);        // most key classes implement TemporalAdjuster
  date = date.with(lastDayOfMonth());  // static import from Adjusters
  date = date.with(next(WEDNESDAY));   // static import from Adjusters and DayOfWeek
        实现要求：

        实现不能改变这个对象或指定的时间对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        默认实现必须与此代码相同：

          return adjuster.adjustInto(this);
        参数
        adjuster - 调整器使用，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果无法进行调整
        ArithmeticException - 如果发生数字溢出

      • with

        Temporal with​(TemporalField field,
              long newValue)
        返回与该对象具有相同类型的对象，并更改指定的字段。

        这将返回一个基于该对象的新对象，其中指定字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月的日期。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        实现要求：
        实现必须检查并处理ChronoField中定义的所有字段。 如果该字段被支持，则必须进行调整。 如果不支持，则必须抛出UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.adjustInto(Temporal, long)传递this作为第一个参数。

        实现不能改变这个对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        参数
        field - 要在结果中设置的字段，不为null
        newValue - 结果中字段的新值
        结果
        与指定字段集相同类型的对象，不为null
        异常
        DateTimeException - 如果字段无法设置
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • plus

        default Temporal plus​(TemporalAmount amount)
        返回与此对象相同类型的对象，并添加一个金额。

        这调整这个时间，根据指定量的规则添加。 金额通常是Period，但可能是实现TemporalAmount接口的任何其他类型，例如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.plus(period);                // add a Period instance
  date = date.plus(duration);              // add a Duration instance
  date = date.plus(workingDays(6));        // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        实现要求：

        实现不能改变这个对象或指定的时间对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        默认实现必须与此代码相同：

          return amount.addTo(this);
        参数
        amount - 要添加的金额，不为null
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能添加
        ArithmeticException - 如果发生数字溢出

      • plus

        Temporal plus​(long amountToAdd,
              TemporalUnit unit)
        返回与此对象相同类型的对象，并添加指定的句点。

        此方法基于添加了指定句点的新对象。 例如，在LocalDate ，这可以用来添加几年，几个月或几天。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则添加一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        实现要求：
        实施必须检查并处理ChronoUnit中定义的所有单位。 如果单元被支持，则必须执行添加。 如果不支持，则必须抛出一个UnsupportedTemporalTypeException 。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.addTo(Temporal, long)传递this作为第一个参数。

        实现不能改变这个对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        参数
        amountToAdd - 要添加的指定单位的数量，可能为负数
        unit - 要添加的单位，不为null
        结果
        与指定期间相同类型的对象添加，不为空
        异常
        DateTimeException - 如果无法添加本机
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • minus

        default Temporal minus​(TemporalAmount amount)
        返回与该对象相同类型的对象，并减去一个数量。

        这调整这个时间，根据指定量的规则减去。 金额通常为Period，但可能是实现TemporalAmount界面的任何其他类型，如Duration 。

        一些示例代码，指示如何和为什么使用此方法：

          date = date.minus(period);               // subtract a Period instance
  date = date.minus(duration);             // subtract a Duration instance
  date = date.minus(workingDays(6));       // example user-written workingDays method

        请注意，呼叫plus后跟minus不保证返回相同的日期时间。

        实现要求：

        实现不能改变这个对象或指定的时间对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        默认实现必须与此代码相同：

          return amount.subtractFrom(this);
        参数
        amount - 减去量，不为空
        结果
        具有指定调整的相同类型的对象，不为null
        异常
        DateTimeException - 如果不能进行减法
        ArithmeticException - 如果发生数字溢出

      • minus

        default Temporal minus​(long amountToSubtract,
                       TemporalUnit unit)
        返回与该对象相同类型的对象，并减去指定的时间段。

        该方法返回一个基于该对象的新对象，减去指定的时间段。 例如，在LocalDate ，这可以用来减去几年，几个月或几天的数量。 返回的对象将具有与该对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表3月31日的日期，则减去一个月将不清楚。 在这种情况下，该领域负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        实现要求：
        实现必须以与默认方法行为相当的庄园行为。

        实现不能改变这个对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        默认实现必须与此代码相同：

          return (amountToSubtract == Long.MIN_VALUE ?
      plus(Long.MAX_VALUE, unit).plus(1, unit) : plus(-amountToSubtract, unit));
        参数
        amountToSubtract - 扣除指定单位的金额，可能为负数
        unit - 减去量的单位，不为空
        结果
        与指定周期相同类型的对象减去，不为空
        异常
        DateTimeException - 如果不能减去单位
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出

      • until

        long until​(Temporal endExclusive,
           TemporalUnit unit)
        根据指定的单位计算直到另一个时间的时间量。

        这可以计算单个TemporalUnit之间的两个时间对象之间的时间量。 起点和终点是this和指定的时间。 如果不同，终点被转换为与起始点相同的类型。 如果结束在开始之前，结果将为负数。 例如，可以使用startTime.until(endTime, HOURS)计算两个时间对象之间的小时startTime.until(endTime, HOURS) 。

        计算返回一个整数，表示两个时间之间的完整单位数。 例如，11时30分至13时29分之间的小时数将只有1小时，因为距离两小时不到1分钟。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用TemporalUnit.between(Temporal, Temporal) ：

          // these two lines are equivalent
   temporal = start.until(end, unit);
   temporal = unit.between(start, end);
        应该根据这种做法进行选择，使代码更易读。

        例如，该方法允许计算两个日期之间的天数：

          long daysBetween = start.until(end, DAYS);
  // or alternatively
  long daysBetween = DAYS.between(start, end);
        实现要求：
        实现必须首先检查以确保输入的时间对象与实现具有相同的可观察类型。 然后，他们必须对所有ChronoUnit的实例进行计算。 一个UnsupportedTemporalTypeException必须抛出ChronoUnit情况下是不支持。

        如果该单元不是ChronoUnit ，则此方法的结果是通过调用得到TemporalUnit.between(Temporal, Temporal)传递this作为第一个参数和转换后的输入时间作为第二个参数。

        总而言之，实现必须以与此伪代码相同的方式表现：

          // convert the end temporal to the same type as this class
  if (unit instanceof ChronoUnit) {
    // if unit is supported, then calculate and return result
    // else throw UnsupportedTemporalTypeException for unsupported units
  }
  return unit.between(this, convertedEndTemporal);

        请注意，如果两个时间对象具有与getClass()评估的完全相同的类型，则只能调用该单元的between方法。

        当这个只读方法被调用时，实现必须确保没有可观察的状态被改变。

        参数
        endExclusive - 结束时间，排他，转换为与此对象相同的类型，不为null
        unit - 衡量金额的单位，不为空
        结果
        在该时间对象与指定单位之间的时间量; 如果指定的对象晚于此值，则为正数，如果比此更早，则为负数
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为与该时间相同的类型
        UnsupportedTemporalTypeException - 如果不支持本机
        ArithmeticException - 如果发生数字溢出
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TemporalAccessor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Interface TemporalAccessor

  • All Known Subinterfaces:
    ChronoLocalDate ， ChronoLocalDateTime<D> ， ChronoZonedDateTime<D> ， Era ， Temporal
    所有已知实现类：
    DayOfWeek ， HijrahDate ， HijrahEra ， Instant ， IsoEra ， JapaneseDate ， JapaneseEra ， LocalDate ， LocalDateTime ， LocalTime ， MinguoDate ， MinguoEra ， Month ， MonthDay ， OffsetDateTime ， OffsetTime ， ThaiBuddhistDate ， ThaiBuddhistEra ， Year ， YearMonth ， ZonedDateTime ， ZoneOffset

    public interface TemporalAccessor
    框架级接口定义对时间对象的只读访问，例如日期，时间，偏移或这些的某些组合。

    这是日期，时间和偏移对象的基本界面类型。 这些类可以提供fields或queries的信息 。

    大多数日期和时间信息可以表示为一个数字。 这些是使用模拟TemporalField使用保持的号码long处理大值。 年份，月份和日期是字段的简单示例，但它们还包括即时和偏移量。 有关标准的字段集，请参阅ChronoField 。

    两个日期/时间信息不能用数字表示， chronology和time-zone 。 这些可以通过queries使用TemporalQuery上定义的静态方法访问 。

    子接口Temporal将此定义扩展到也支持对更完整的时间对象进行调整和操纵的定义。

    该接口是一个框架级接口，不应该在应用程序代码中广泛使用。 相反，应用程序应该创建并传递具体类型的实例，如LocalDate 。 这有很多原因，其中一部分是该接口的实现可能在除ISO之外的日历系统中。 有关这些问题的更全面的讨论，请参阅ChronoLocalDate 。

    实现要求：
    此接口对实现的可变性没有任何限制，但是强烈建议不变性。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default int get​(TemporalField field)
      获取指定字段的值作为 int 。
      long getLong​(TemporalField field)
      获取指定字段的 long 。
      boolean isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      default <R> R query​(TemporalQuery<R> query)
      查询此日期时间。
      default ValueRange range​(TemporalField field)
      获取指定字段的有效值的范围。

    • 方法详细信息

      • isSupported

        boolean isSupported​(TemporalField field)
        检查指定的字段是否受支持。

        这将检查是否可以查询指定字段的日期时间。 如果为false，则调用range和get方法将抛出异常。

        实现要求：
        实现必须检查并处理ChronoField中定义的所有字段。 如果该字段被支持，则必须返回true，否则返回false。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.isSupportedBy(TemporalAccessor)传递this作为参数。

        当这个只读方法被调用时，实现必须确保没有可观察的状态被改变。

        参数
        field - 要检查的字段，null返回false
        结果
        如果可以查询该字段的日期时间，则为true，否则为false

      • range

        default ValueRange range​(TemporalField field)
        获取指定字段的有效值的范围。

        所有字段都可以表示为long整数。 此方法返回描述该值的有效范围的对象。 该时间对象的值用于提高返回范围的精度。 如果日期时间无法返回范围，因为该字段不受支持或由于其他原因，将抛出异常。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        实现要求：
        实现必须检查并处理ChronoField中定义的所有字段。 如果该字段被支持，则必须返回该字段的范围。 如果不支持，则必须抛出UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.rangeRefinedBy(TemporalAccessorl)传递this作为参数。

        当这个只读方法被调用时，实现必须确保没有可观察的状态被改变。

        默认实现必须与此代码相同：

          if (field instanceof ChronoField) {
    if (isSupported(field)) {
      return field.range();
    }
    throw new UnsupportedTemporalTypeException("Unsupported field: " + field);
  }
  return field.rangeRefinedBy(this);
        参数
        field - 查询范围的字段，不为null
        结果
        字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围
        UnsupportedTemporalTypeException - 如果该字段不被支持

      • get

        default int get​(TemporalField field)
        获取指定字段的值作为int 。

        这将查询指定字段的值的日期时间。 返回的值将始终在该字段的值的有效范围内。 如果日期时间不能返回值，因为该字段不受支持或由于其他原因，将抛出异常。

        实现要求：
        实现必须检查并处理ChronoField中定义的所有字段。 如果该字段被支持并具有一个int范围，则必须返回该字段的值。 如果不支持，那么必须抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。

        当这个只读方法被调用时，实现必须确保没有可观察的状态被改变。

        默认实现必须与此代码相同：

          if (range(field).isIntValue()) {
    return range(field).checkValidIntValue(getLong(field), field);
  }
  throw new UnsupportedTemporalTypeException("Invalid field " + field + " + for get() method, use getLong() instead");
        参数
        field - 要获取的字段，不为null
        结果
        该字段的值在值的有效范围内
        异常
        DateTimeException - 如果无法获取字段的值，或者该值超出了字段有效值的范围
        UnsupportedTemporalTypeException - 如果该字段不受支持或值的范围超过 int
        ArithmeticException - 如果发生数字溢出

      • getLong

        long getLong​(TemporalField field)
        获取指定字段的long 。

        这将查询指定字段的值的日期时间。 返回的值可能在该字段的值的有效范围之外。 如果日期时间不能返回值，因为该字段不受支持或由于其他原因，将抛出异常。

        实现要求：
        实现必须检查并处理ChronoField中定义的所有字段。 如果该字段被支持，则必须返回该字段的值。 如果不支持，则必须抛出一个UnsupportedTemporalTypeException 。

        如果该字段是不是一个ChronoField ，则此方法的结果是通过调用得到TemporalField.getFrom(TemporalAccessor)传递this作为参数。

        当这个只读方法被调用时，实现必须确保没有可观察的状态被改变。

        参数
        field - 要获取的字段，不为null
        结果
        该字段的值
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果该字段不被支持
        ArithmeticException - 如果发生数字溢出

      • query

        default <R> R query​(TemporalQuery<R> query)
        查询此日期时间。

        这将使用指定的查询策略对象查询此日期时间。

        查询是从日期时间提取信息的关键工具。 它们存在于外部化查询过程，根据策略设计模式允许不同的方法。 示例可能是一个查询，检查日期是闰年前的二月二十九日前一天，还是计算下一个生日的天数。

        最常见的查询实现是方法引用，例如LocalDate::from和ZoneId::from 。 附加的实现在TemporalQuery中作为静态方法提供。

        实现要求：
        默认实现必须与此代码相同：
          if (query == TemporalQueries.zoneId() ||
        query == TemporalQueries.chronology() || query == TemporalQueries.precision()) {
    return null;
  }
  return query.queryFrom(this);
        将来的版本被允许向if语句添加进一步的查询。

        实现此接口并覆盖此方法的所有类都必须调用TemporalAccessor.super.query(query) 。 如果JDK类提供与默认行为相同的行为，则JDK类可能会避免调用super，但是非JDK类可能无法使用此优化，并且必须调用super 。

        如果实现可以为默认实现的if语句中列出的查询之一提供一个值，那么它必须这样做。 例如，存储小时和分钟的应用程序定义的HourMin类必须重写此方法，如下所示：

          if (query == TemporalQueries.precision()) {
    return MINUTES;
  }
  return TemporalAccessor.super.query(query);

        当这个只读方法被调用时，实现必须确保没有可观察的状态被改变。

        参数类型
        R - 结果的类型
        参数
        query - 要调用的查询，不为空
        结果
        查询结果可能返回null（由查询定义）
        异常
        DateTimeException - 如果无法查询
        ArithmeticException - 如果发生数字溢出
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TemporalAdjuster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Interface TemporalAdjuster

  • All Known Subinterfaces:
    ChronoLocalDate ， ChronoLocalDateTime<D> ， Era
    所有已知实现类：
    DayOfWeek ， HijrahDate ， HijrahEra ， Instant ， IsoEra ， JapaneseDate ， JapaneseEra ， LocalDate ， LocalDateTime ， LocalTime ， MinguoDate ， MinguoEra ， Month ， MonthDay ， OffsetDateTime ， OffsetTime ， ThaiBuddhistDate ， ThaiBuddhistEra ， Year ， YearMonth ， ZoneOffset
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface TemporalAdjuster
    调整时间对象的策略。

    调整器是修改时间对象的关键工具。 它们存在于外部化调整过程中，根据策略设计模式允许不同的方法。 示例可以是设置日期避免周末的调整器，或者将日期设置为月份的最后一天。

    有两种等效的方式使用TemporalAdjuster 。 第一个是直接在这个接口上调用方法。 二是使用Temporal.with(TemporalAdjuster) ：

      // these two lines are equivalent, but the second approach is recommended
   temporal = thisAdjuster.adjustInto(temporal);
   temporal = temporal.with(thisAdjuster);
    建议使用第二种方法， with(TemporalAdjuster) ，因为在代码中阅读更清楚。

    TemporalAdjusters类包含一组标准的调整器，可作为静态方法使用。 这些包括：

    • 找到本月的第一天或最后一天
    • 找到下个月的第一天
    • 找到一年中的第一个或最后一天
    • 找到明年的第一天
    • 在一个月内找到第一个或最后一个星期，例如“6月的第一个星期三”
    • 找到下一个或前几个星期，例如“下周四”
    实现要求：
    此接口对实现的可变性没有任何限制，但是强烈建议不变性。
    从以下版本开始：
    1.8
    另请参见：
    TemporalAdjusters

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Temporal adjustInto​(Temporal temporal)
      调整指定的时间对象。

    • 方法详细信息

      • adjustInto

        Temporal adjustInto​(Temporal temporal)
        调整指定的时间对象。

        这使用实现类中封装的逻辑来调整指定的时间对象。 示例可以是设置日期避免周末的调整器，或者将日期设置为月份的最后一天。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用Temporal.with(TemporalAdjuster) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisAdjuster.adjustInto(temporal);
   temporal = temporal.with(thisAdjuster);
        建议使用第二种方法， with(TemporalAdjuster) ，因为在代码中阅读更清楚。
        实现要求：
        实现必须使用输入对象并进行调整。 该实现定义了调整的逻辑，并负责记录该逻辑。 它可以使用Temporal上的任何方法查询时间对象并执行调整。 返回的对象必须具有与输入对象相同的可观察类型

        输入对象不能更改。 相反，必须退还原件的调整副本。 这为不可变和可变的时间对象提供了相当的安全行为。

        输入的时间对象可以在不同于ISO的日历系统中。 实现可以选择记录与其他日历系统的兼容性，或者通过querying the chronology拒绝非ISO临时对象。

        可以从多个并行线程调用此方法。 调用时必须是线程安全的。

        参数
        temporal - 要调整的时间对象，不为空
        结果
        具有相同可观察类型的对象，进行调整，而不是null
        异常
        DateTimeException - 如果不能进行调整
        ArithmeticException - 如果发生数字溢出
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TemporalAdjusters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Class TemporalAdjusters

  • java.lang.Object
    • java.time.temporal.TemporalAdjusters

  • public final class TemporalAdjusters
extends Object
    常用和有用的TemporalAdjusters。

    调整器是修改时间对象的关键工具。 它们存在于外部化调整过程中，根据策略设计模式允许不同的方法。 示例可以是设置日期避免周末的调整器，或者将日期设置为月份的最后一天。

    有两种使用TemporalAdjuster等效方法。 第一个是直接在接口上调用方法。 二是使用Temporal.with(TemporalAdjuster) ：

      // these two lines are equivalent, but the second approach is recommended
   temporal = thisAdjuster.adjustInto(temporal);
   temporal = temporal.with(thisAdjuster);
    建议使用第二种方法， with(TemporalAdjuster) ，因为在代码中阅读更清楚。

    该类包含一组标准的调整器，可作为静态方法使用。 这些包括：

    • 找到本月的第一天或最后一天
    • 找到下个月的第一天
    • 找到一年中的第一个或最后一天
    • 找到明年的第一天
    • 在一个月内找到第一个或最后一个星期，例如“6月的第一个星期三”
    • 找到下一个或前几个星期，例如“下周四”
    实现要求：
    静态方法提供的所有实现都是不可变的。
    从以下版本开始：
    1.8
    另请参见：
    TemporalAdjuster

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TemporalAdjuster dayOfWeekInMonth​(int ordinal, DayOfWeek dayOfWeek)
      返回月份调整器中的星期几，该日期将根据月份返回具有序数星期的新日期。
      static TemporalAdjuster firstDayOfMonth​()
      返回“第一个月的”调整器，它返回设置为当月的第一天的新日期。
      static TemporalAdjuster firstDayOfNextMonth​()
      返回“下一个月的第一天”调整器，它将新的日期设置为下个月的第一天。
      static TemporalAdjuster firstDayOfNextYear​()
      返回“明年的第一天”调整器，返回设置为下一年的第一天的新日期。
      static TemporalAdjuster firstDayOfYear​()
      返回“一年的第一天”调整器，其返回设置为当前第一天的新日期。
      static TemporalAdjuster firstInMonth​(DayOfWeek dayOfWeek)
      返回月初调整器，它在同一个月内返回与第一个匹配的星期几的新日期。
      static TemporalAdjuster lastDayOfMonth​()
      返回“最后一个月的”调整器，该日期设置为当前月份的最后一天。
      static TemporalAdjuster lastDayOfYear​()
      返回“最后一天的”调整器，其返回设置为当前年份的最后一天的新日期。
      static TemporalAdjuster lastInMonth​(DayOfWeek dayOfWeek)
      返回最近一个月的调整器，它返回与最后一个匹配的星期几相同月份的新日期。
      static TemporalAdjuster next​(DayOfWeek dayOfWeek)
      返回下一个星期的调整器，该调整器将日期调整为在调整日期之后的指定日期的第一次出现。
      static TemporalAdjuster nextOrSame​(DayOfWeek dayOfWeek)
      返回下一个或相同的星期几调整器，该调整器将日期调整为在调整日期之后指定的星期几的第一次出现，除非它已在当天在同一对象被返回。
      static TemporalAdjuster ofDateAdjuster​(UnaryOperator<LocalDate> dateBasedAdjuster)
      获取一个 TemporalAdjuster包裹日期调整器。
      static TemporalAdjuster previous​(DayOfWeek dayOfWeek)
      返回上一个星期的调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现。
      static TemporalAdjuster previousOrSame​(DayOfWeek dayOfWeek)
      返回之前或相同的日期调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现，除非已在当天返回相同的对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • ofDateAdjuster

        public static TemporalAdjuster ofDateAdjuster​(UnaryOperator<LocalDate> dateBasedAdjuster)
        获取一个TemporalAdjuster包裹日期调整器。

        TemporalAdjuster是基于Temporal接口。 该方法允许从LocalDate到LocalDate的调整，以匹配基于时间的界面。 这是为了方便使用户编写的调整器更简单。

        一般来说，用户编写的调整器应该是静态常量：

           static TemporalAdjuster TWO_DAYS_LATER = TemporalAdjusters.ofDateAdjuster(date -> date.plusDays(2));
        参数
        dateBasedAdjuster - 基于日期的调整器，不为空
        结果
        时间调整器包装在日期调整器上，不为空

      • firstDayOfMonth

        public static TemporalAdjuster firstDayOfMonth​()
        返回“第一个月的”调整器，它返回设置为当月的第一天的新日期。

        ISO日历系统的行为如下：
        输入2011-01-15将返回2011-01-01。
        输入2011-02-15将返回2011-02-01。

        该行为适用于大多数日历系统。 相当于：

          temporal.with(DAY_OF_MONTH, 1);
        结果
        第一个月的日子调整，不为零

      • lastDayOfMonth

        public static TemporalAdjuster lastDayOfMonth​()
        返回“最后一个月的”调整器，该日期设置为当前月份的最后一天。

        ISO日历系统的行为如下：
        输入2011-01-15将返回2011-01-31。
        输入2011-02-15将返回2011-02-28。
        输入2012-02-15将返回2012-02-29（闰年）。
        输入2011-04-15将返回2011-04-30。

        该行为适用于大多数日历系统。 相当于：

          long lastDay = temporal.range(DAY_OF_MONTH).getMaximum();
  temporal.with(DAY_OF_MONTH, lastDay);
        结果
        最后一个月的调整者，不为零

      • firstDayOfNextMonth

        public static TemporalAdjuster firstDayOfNextMonth​()
        返回“下一个月的第一天”调整器，它将新的日期设置为下个月的第一天。

        ISO日历系统的行为如下：
        输入2011-01-15将返回2011-02-01。
        输入2011-02-15将返回2011-03-01。

        该行为适用于大多数日历系统。 相当于：

          temporal.with(DAY_OF_MONTH, 1).plus(1, MONTHS);
        结果
        下个月的第一天调整，不为null

      • firstDayOfYear

        public static TemporalAdjuster firstDayOfYear​()
        返回“一年的第一天”调整器，其返回设置为当前第一天的新日期。

        ISO日历系统的行为如下：
        输入2011-01-15将返回2011-01-01。
        输入2011-02-15将返回2011-01-01。

        该行为适用于大多数日历系统。 相当于：

          temporal.with(DAY_OF_YEAR, 1);
        结果
        第一个日期调整器，不为零

      • lastDayOfYear

        public static TemporalAdjuster lastDayOfYear​()
        返回“最后一天的”调整器，其返回设置为当前年份的最后一天的新日期。

        ISO日历系统的行为如下：
        输入2011-01-15将返回2011-12-31。
        输入2011-02-15将返回2011-12-31。

        该行为适用于大多数日历系统。 相当于：

          long lastDay = temporal.range(DAY_OF_YEAR).getMaximum();
  temporal.with(DAY_OF_YEAR, lastDay);
        结果
        最后一天的调整者，不是null

      • firstDayOfNextYear

        public static TemporalAdjuster firstDayOfNextYear​()
        返回“明年的第一天”调整器，返回设置为下一年的第一天的新日期。

        ISO日历系统的行为如下：
        输入2011-01-15将返回2012-01-01。

        该行为适用于大多数日历系统。 相当于：

          temporal.with(DAY_OF_YEAR, 1).plus(1, YEARS);
        结果
        下个月的第一天调整，不为null

      • firstInMonth

        public static TemporalAdjuster firstInMonth​(DayOfWeek dayOfWeek)
        返回月初调整器，它在同一个月内返回与第一个匹配的星期几的新日期。 这是用于表达，如“3月的第一个星期二”。

        ISO日历系统的行为如下：
        （MONDAY）2011-12-15输入将于2011-12-05返回。
        （FRIDAY）的输入2011-12-15将返回2011-12-02。

        该行为适用于大多数日历系统。 它使用DAY_OF_WEEK和DAY_OF_MONTH字段和DAYS单位，并假定为期七天。

        参数
        dayOfWeek - 星期几，不为空
        结果
        第一个月调整，不为null

      • lastInMonth

        public static TemporalAdjuster lastInMonth​(DayOfWeek dayOfWeek)
        返回最近一个月的调整器，它返回与最后一个匹配的星期几相同月份的新日期。 这用于像“3月的最后一个星期二”这样的表达。

        ISO日历系统的行为如下：
        （MONDAY）2011-12-15的输入将返回2011-12-26。
        （FRIDAY）的输入2011-12-15将返回2011-12-30。

        该行为适用于大多数日历系统。 它使用DAY_OF_WEEK和DAY_OF_MONTH字段和DAYS单位，并假定为期七天。

        参数
        dayOfWeek - 星期几，不为空
        结果
        第一个月调整，不为null

      • dayOfWeekInMonth

        public static TemporalAdjuster dayOfWeekInMonth​(int ordinal,
                                                DayOfWeek dayOfWeek)
        返回月份调整器中的星期几，该日期将根据月份返回具有序数星期的新日期。 这用于像“3月的第二个星期二”这样的表达。

        ISO日历系统的行为如下：
        （1，TUESDAY）的输入2011-12-15将返回2011-12-06。
        （2，TUESDAY）的输入2011-12-15将返回2011-12-13。
        （3，TUESDAY）的输入2011-12-15将返回2011-12-20。
        （4，TUESDAY）的输入2011-12-15将返回2011-12-27。
        （5，TUESDAY）的输入2011-12-15将返回2012-01-03。
        （-1，TUESDAY）的输入2011-12-15将返回2011-12-27（上个月）。
        （-4，TUESDAY）的输入2011-12-15将于2011-12-06（上个月前3周）返回。
        （-5，TUESDAY）的输入2011-12-15将于2011-11-29（上个月前4周）返回。
        （0，TUESDAY）的输入2011-12-15将返回2011-11-29（上个月的最后一个）。

        对于正序或零序，算法相当于找到在该月内匹配的第一个星期几，然后向其中添加数周。 对于负序数，该算法相当于找到在该月内匹配的最后一个星期，然后减去数周。 星期的序数不被验证，并且根据该算法被宽容地解释。 该定义意味着零的序数找到上个月的最后一个匹配的星期几。

        该行为适用于大多数日历系统。 它使用DAY_OF_WEEK和DAY_OF_MONTH字段和DAYS单位，并假设为期七天。

        参数
        ordinal - 本月内的一周，无限，但通常为-5至5
        dayOfWeek - 星期几，不为空
        结果
        月中的日期调整器，不为空

      • next

        public static TemporalAdjuster next​(DayOfWeek dayOfWeek)
        返回下一个星期的调整器，该调整器将日期调整为在调整日期之后的指定日期的第一次出现。

        ISO日历系统的行为如下：
        输入2011-01-15（星期六）参数（MONDAY）将返回2011-01-17（两天后）。
        参数（WEDNESDAY）2011-01-15（星期六）的输入将返回2011-01-19（四天后）。
        输入2011-01-15（星期六）参数（SATURDAY）将返回2011-01-22（七天后）。

        该行为适用于大多数日历系统。 它使用DAY_OF_WEEK字段和DAYS单位，并假定为期七天。

        参数
        dayOfWeek - 将日期移动到的星期几，不为空
        结果
        下一个星期的调整器，不为null

      • nextOrSame

        public static TemporalAdjuster nextOrSame​(DayOfWeek dayOfWeek)
        返回下一个或相同的星期几调整器，该调整器将日期调整为在调整日期之后指定的星期几的第一次出现，除非它已在当天在同一对象被返回。

        ISO日历系统的行为如下：
        输入2011-01-15（星期六）参数（MONDAY）将返回2011-01-17（两天后）。
        参数（WEDNESDAY）2011-01-15（星期六）的输入将返回2011-01-19（四天后）。
        参数（SATURDAY）的输入2011-01-15（星期六）将返回2011-01-15（与输入相同）。

        该行为适用于大多数日历系统。 它使用DAY_OF_WEEK字段和DAYS单位，并假定为期七天。

        参数
        dayOfWeek - 检查或移动日期的星期几，不为空
        结果
        下一个或相同的日期调整器，不为null

      • previous

        public static TemporalAdjuster previous​(DayOfWeek dayOfWeek)
        返回上一个星期的调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现。

        ISO日历系统的行为如下：
        参数（MONDAY）的输入2011-01-15（星期六）将返回2011-01-10（五天前）。
        输入2011-01-15（星期六）参数（WEDNESDAY）将返回2011-01-12（前三天）。
        输入2011-01-15（星期六）参数（SATURDAY）将返回2011-01-08（七天前）。

        该行为适用于大多数日历系统。 它使用DAY_OF_WEEK字段和DAYS单位，并假定为期七天。

        参数
        dayOfWeek - 将日期移动到的星期几，不为空
        结果
        前一天的调整器，不为空

      • previousOrSame

        public static TemporalAdjuster previousOrSame​(DayOfWeek dayOfWeek)
        返回之前或相同的日期调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现，除非已在当天返回相同的对象。

        ISO日历系统的行为如下：
        参数（MONDAY）的输入2011-01-15（星期六）将返回2011-01-10（五天前）。
        输入2011-01-15（星期六）参数（WEDNESDAY）将返回2011-01-12（前三天）。
        参数（SATURDAY）的输入2011-01-15（星期六）将返回2011-01-15（与输入相同）。

        该行为适用于大多数日历系统。 它使用DAY_OF_WEEK字段和DAYS单位，并假定为期七天。

        参数
        dayOfWeek - 检查或移动日期的星期几，不为空
        结果
        the previous-or-same day-of-week adjuster, not null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TemporalAmount (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Interface TemporalAmount

  • All Known Subinterfaces:
    ChronoPeriod
    所有已知实现类：
    Duration ， Period

    public interface TemporalAmount
    定义一段时间的框架级界面，如“6小时”，“8天”或“2年3个月”。

    这是时间量的基本界面类型。 数额与日期或时间不同，因为它不与时间线上的任何特定点相关。

    这个金额可以认为是Map的TemporalUnit到long ，通过getUnits()和get(TemporalUnit)公开 。 一个简单的情况可能有一个单位值对，例如“6小时”。 更复杂的情况可能有多个单位价值对，例如“7年，3个月和5天”。

    有两个常见的实现。 Period是一个基于日期的实现，存储年，月和日。 Duration是基于时间的实现，存储秒和纳秒，但是使用其他持续时间的单位（如分钟，小时和固定的24小时天）提供一些访问。

    该接口是一个框架级接口，不应该在应用程序代码中广泛使用。 相反，应用程序应该创建并传递具体类型的实例，例如Period和Duration 。

    实现要求：
    此接口对实现的可变性没有任何限制，但是强烈建议不变性。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Temporal addTo​(Temporal temporal)
      添加到指定的时间对象。
      long get​(TemporalUnit unit)
      返回请求的单位的值。
      List<TemporalUnit> getUnits​()
      返回唯一定义此TemporalAmount值的单位列表。
      Temporal subtractFrom​(Temporal temporal)
      从指定的时间对象中减去此对象。

    • 方法详细信息

      • get

        long get​(TemporalUnit unit)
        返回请求的单位的值。 从返回的单位getUnits()唯一定义的值TemporalAmount 。 必须为getUnits列出的每个单位返回值。
        实现要求：
        实施可能声明支持未列出的单位getUnits() 。 通常，为了方便开发人员，实施将定义额外的单位作为转换。
        参数
        unit - 要为其返回值的 TemporalUnit
        结果
        单位的长期价值
        异常
        DateTimeException - 如果无法获取单位的值
        UnsupportedTemporalTypeException - 如果不支持 unit

      • getUnits

        List<TemporalUnit> getUnits​()
        返回唯一定义此TemporalAmount值的单位列表。 TemporalUnits的列表由实现类定义。 该列表是当时getUnits被调用并且不可变的单元的快照。 单位从最长的持续时间到本机的最短持续时间。
        实现要求：
        完整和唯一的单位列表表示物体的状态，没有遗漏，重叠或重复。 单位是从最长的时间到最短的顺序。
        结果
        名单TemporalUnits ; 不为空

      • addTo

        Temporal addTo​(Temporal temporal)
        添加到指定的时间对象。

        使用实现类中封装的逻辑将数量添加到指定的时间对象。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用Temporal.plus(TemporalAmount) ：

          // These two lines are equivalent, but the second approach is recommended
   dateTime = amount.addTo(dateTime);
   dateTime = dateTime.plus(adder);
        建议使用第二种方法， plus(TemporalAmount) ，因为在代码中阅读更清楚。
        实现要求：
        实现必须使用输入对象并添加它。 该实现定义了添加的逻辑，并负责记录该逻辑。 它可以使用Temporal上的任何方法查询时间对象并执行添加。 返回的对象必须具有与输入对象相同的可观察类型

        输入对象不能更改。 相反，必须退还原件的调整副本。 这为不可变和可变的时间对象提供了相当的安全行为。

        输入的时间对象可以在不同于ISO的日历系统中。 实现可以选择记录与其他日历系统的兼容性，或者通过querying the chronology拒绝非ISO临时对象。

        可以从多个并行线程调用此方法。 调用时必须是线程安全的。

        参数
        temporal - 将时间对象添加到，而不是null
        结果
        具有相同可观察类型的对象与添加，而不是null
        异常
        DateTimeException - 如果无法添加
        ArithmeticException - 如果发生数字溢出

      • subtractFrom

        Temporal subtractFrom​(Temporal temporal)
        从指定的时间对象中减去此对象。

        使用实现类中封装的逻辑，从指定的时间对象中减去量。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用Temporal.minus(TemporalAmount) ：

          // these two lines are equivalent, but the second approach is recommended
   dateTime = amount.subtractFrom(dateTime);
   dateTime = dateTime.minus(amount);
        建议使用第二种方法， minus(TemporalAmount) ，因为在代码中阅读更清楚。
        实现要求：
        实现必须使用输入对象并从其中减去。 该实现定义了减法的逻辑，并负责记录该逻辑。 它可以使用Temporal上的任何方法查询时间对象并执行减法。 返回的对象必须具有与输入对象相同的可观察类型

        输入对象不能更改。 相反，必须退还原件的调整副本。 这为不可变和可变的时间对象提供了相当的安全行为。

        输入的时间对象可以在不同于ISO的日历系统中。 实现可以选择记录与其他日历系统的兼容性，或者通过querying the chronology拒绝非ISO临时对象。

        可以从多个并行线程调用此方法。 调用时必须是线程安全的。

        参数
        temporal - 从时间对象中减去金额，不为null
        结果
        相同可观察类型的对象与减法而不是null
        异常
        DateTimeException - 如果不能减去
        ArithmeticException - 如果发生数字溢出
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TemporalField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Interface TemporalField

  • 所有已知实现类：
    ChronoField

    public interface TemporalField
    日期时间的字段，如月份或小时。

    日期和时间使用将时间线划分成对人有意义的东西的字段来表示。 此接口的实现表示这些字段。

    最常用的单位在ChronoField中定义。 此外字段在供给IsoFields ， WeekFields和JulianFields 。 字段也可以通过实现该接口的应用程序代码编写。

    该领域使用双重调度工作。 客户端代码调用日期时间的方法，如LocalDateTime ，检查该字段是否为ChronoField 。 如果是，则日期时间必须处理它。 否则，方法调用将重新分配到此接口中的匹配方法。

    实现要求：
    该接口必须小心实施，以确保其他类正确运行。 可以实例化的所有实现必须是最终的，不可变的和线程安全的。 如果可能的话应该是Serializable 。 枚举是有效的实施选择。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      <R extends Temporal>
      R             		adjustInto​(R temporal, long newValue)
      返回指定时间对象的副本，并设置该字段的值。
      TemporalUnit getBaseUnit​()
      获取测量场的单位。
      default String getDisplayName​(Locale locale)
      获取所请求语言环境中字段的显示名称。
      long getFrom​(TemporalAccessor temporal)
      从指定的时间对象获取此字段的值。
      TemporalUnit getRangeUnit​()
      获取字段绑定的范围。
      boolean isDateBased​()
      检查此字段是否表示日期的组件。
      boolean isSupportedBy​(TemporalAccessor temporal)
      检查时间对象是否支持该字段。
      boolean isTimeBased​()
      检查此字段是否表示时间的一个组成部分。
      ValueRange range​()
      获取字段的有效值的范围。
      ValueRange rangeRefinedBy​(TemporalAccessor temporal)
      使用时间对象获取此字段的有效值的范围以优化结果。
      default TemporalAccessor resolve​(Map<TemporalField,Long> fieldValues, TemporalAccessor partialTemporal, ResolverStyle resolverStyle)
      解决此字段以提供更简单的替代或日期。
      String toString​()
      获取字段的描述性名称。

    • 方法详细信息

      • getDisplayName

        default String getDisplayName​(Locale locale)
        获取所请求语言环境中字段的显示名称。

        如果区域设置没有显示名称，则必须返回合适的默认值。

        默认实现必须检查区域设置不为null并返回toString() 。

        参数
        locale - 要使用的语言环境，不为空
        结果
        区域设置的显示名称或合适的默认值，不为空

      • getBaseUnit

        TemporalUnit getBaseUnit​()
        获取测量场的单位。

        字段的单位是在该范围内变化的周期。 例如，在“MonthOfYear”字段中，单位为“Months”。 参见getRangeUnit() 。

        结果
        定义字段的基本单位的单位不为空

      • getRangeUnit

        TemporalUnit getRangeUnit​()
        获取字段绑定的范围。

        字段的范围是字段在内部变化的周期。 例如，在“MonthOfYear”字段中，范围是“年”。 参见getBaseUnit() 。

        范围从不为空。 例如，'Year'字段是'YearOfForever'的缩写。 因此，它具有“年”和“永远”的单位。

        结果
        定义字段范围的单位，不为空

      • range

        ValueRange range​()
        获取字段的有效值的范围。

        所有字段可以表示为long整数。 此方法返回描述该值的有效范围的对象。 该方法一般仅适用于ISO-8601日历系统。

        请注意，结果仅描述最小和最大有效值，重要的是不要太多读取它们。 例如，可以在该范围内的值对该字段无效。

        结果
        字段的有效值的范围不为null

      • isDateBased

        boolean isDateBased​()
        检查此字段是否表示日期的组件。

        一个字段是基于日期的，如果它可以从EPOCH_DAY派生。 请注意，对于isDateBased()和isTimeBased()可以返回false，例如，当表示像星期几这样的字段时。

        结果
        如果此字段是日期的组成部分，则为true

      • isTimeBased

        boolean isTimeBased​()
        检查此字段是否表示时间的一个组成部分。

        一个字段是基于时间的，如果它可以从NANO_OF_DAY派生。 请注意，对于isDateBased()和isTimeBased()可以返回false，例如表示像星期几这样的字段时。

        结果
        如果此字段是时间的一个组成部分，则为true

      • isSupportedBy

        boolean isSupportedBy​(TemporalAccessor temporal)
        检查时间对象是否支持该字段。

        这决定了临时访问者是否支持该字段。 如果这返回false，则不能查询该字段的时间。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用TemporalAccessor.isSupported(TemporalField) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisField.isSupportedBy(temporal);
   temporal = temporal.isSupported(thisField);
        建议使用第二种方法， isSupported(TemporalField) ，因为在代码中阅读更清楚。

        实施应确定是否支持使用ChronoField中可用的字段。

        参数
        temporal - 要查询的时间对象，不为空
        结果
        如果可以查询此字段的日期时间，则为true，否则为false

      • rangeRefinedBy

        ValueRange rangeRefinedBy​(TemporalAccessor temporal)
        使用时间对象获取此字段的有效值的范围以优化结果。

        这使用时间对象来查找该字段的有效值的范围。 这类似于range() ，但是这种方法使用时间来优化结果。 例如，如果字段是DAY_OF_MONTH则range方法不准确，因为有四个可能的月份长度， range和31天。 使用此方法与日期允许范围准确，只返回这四个选项之一。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用TemporalAccessor.range(TemporalField) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisField.rangeRefinedBy(temporal);
   temporal = temporal.range(thisField);
        建议使用第二种方法， range(TemporalField) ，因为在代码中阅读更清楚。

        实施应使用ChronoField中可用的字段执行任何查询或计算。 如果不支持该字段，则必须抛出UnsupportedTemporalTypeException 。

        参数
        temporal - 用于细化结果的时间对象，不为null
        结果
        该字段的有效值的范围不为null
        异常
        DateTimeException - 如果无法获取字段的范围
        UnsupportedTemporalTypeException - 如果字段不受时间支持

      • getFrom

        long getFrom​(TemporalAccessor temporal)
        从指定的时间对象获取此字段的值。

        这将查询该时间对象的该字段的值。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用TemporalAccessor.getLong(TemporalField) （或TemporalAccessor.get(TemporalField) ）：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisField.getFrom(temporal);
   temporal = temporal.getLong(thisField);
        建议使用第二种方法， getLong(TemporalField) ，因为在代码中阅读更清楚。

        实施应使用ChronoField中的字段执行任何查询或计算。 如果不支持该字段，则必须抛出UnsupportedTemporalTypeException 。

        参数
        temporal - 要查询的时间对象，不为空
        结果
        该字段的值不为null
        异常
        DateTimeException - 如果无法获取字段的值
        UnsupportedTemporalTypeException - 如果字段不受时间支持
        ArithmeticException - 如果发生数字溢出

      • adjustInto

        <R extends Temporal> R adjustInto​(R temporal,
                                  long newValue)
        返回指定时间对象的副本，并设置该字段的值。

        这将返回一个新的时间对象，该对象基于指定的时间对象，该字段的值已更改。 例如，在LocalDate ，这可以用于设置年，月或月的日期。 返回的对象具有与指定对象相同的可观察类型。

        在某些情况下，更改字段尚未完全定义。 例如，如果目标对象是代表1月31日的日期，则将月份更改为2月份将不清楚。 在这种情况下，实施负责解决结果。 通常，它将选择先前的有效日期，这将是本例中最后一个有效的二月份。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用Temporal.with(TemporalField, long) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisField.adjustInto(temporal);
   temporal = temporal.with(thisField);
        建议使用第二种方法， with(TemporalField) ，因为在代码中阅读更清楚。

        实施应使用ChronoField中可用的字段执行任何查询或计算。 如果不支持该字段，则必须抛出UnsupportedTemporalTypeException 。

        实现不能改变指定的时间对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        参数类型
        R - 时间对象的类型
        参数
        temporal - 要调整的时间对象，不为空
        newValue - 该字段的新值
        结果
        调整后的时间对象，不为空
        异常
        DateTimeException - 如果该字段无法设置
        UnsupportedTemporalTypeException - 如果字段不受时间支持
        ArithmeticException - 如果发生数字溢出

      • resolve

        default TemporalAccessor resolve​(Map<TemporalField,Long> fieldValues,
                                 TemporalAccessor partialTemporal,
                                 ResolverStyle resolverStyle)
        解决此字段以提供更简单的替代或日期。

        在解析的解析阶段调用此方法。 它旨在允许将应用程序定义的字段简化为更标准的字段，例如ChronoField或更多的日期。

        应用程序通常不应直接调用此方法。

        实现要求：
        如果一个实现表示一个可以被简化或与其他组合的字段，则必须实现该方法。

        指定的映射包含解析的当前状态。 该地图是可变的，必须进行突变才能解析字段和任何相关字段。 如果地图包含此字段，则此方法仅在解析期间被调用，因此实现应该假定该字段存在。

        解析字段将包括查看此字段的值，以及潜在的其他字段，并使用更简单的值（例如ChronoField更新映射，或返回完整的ChronoLocalDate 。 如果解决方案成功，代码必须从地图中删除已解决的所有字段，包括此字段。

        例如， IsoFields类包含四分之一和四分之一的字段。 该方法在该类中的实现将两个字段加上YEAR，成为一个完整的LocalDate 。 解决方法将在返回LocalDate之前从地图中删除所有三个字段。

        使用部分完整的时间来允许查询年表和区域。 一般来说，只需要年表。 查询除区域或年表之外的项目未定义，不得依赖。 的其他方法，如行为get ， getLong ， range和isSupported是不可预测的，结果不确定。

        如果解决方案是可行的，但数据无效，则应使用解析器样式来确定适当的宽大级别，这可能需要抛出DateTimeException或ArithmeticException 。 如果无法解析，则resolve方法必须返回null。

        当解析时间字段时，映射将被更改并返回null。 当解析日期字段时，通常从方法返回日期，并更改映射以删除已解析的字段。 但是，将日期字段解析成可以生成日期的其他ChronoField实例也是可以接受的，例如EPOCH_DAY 。

        并非所有TemporalAccessor实现都被接受为返回值。 调用此方法的实现必须接受ChronoLocalDate ， ChronoLocalDateTime ， ChronoZonedDateTime和LocalTime 。

        默认实现必须返回null。

        参数
        fieldValues - 可以更新的字段映射到值，不为null
        partialTemporal - 部分完整的时间来查询区域和年表; 查询其他事项是未定义的，不推荐，不为null
        resolverStyle - 请求的解析类型，不为null
        结果
        解决的时间对象; null如果解析只改变了地图，或者没有解决
        异常
        ArithmeticException - 如果发生数字溢出
        DateTimeException - 如果解决导致错误。 在不首先检查是否支持的情况下，通过查询时间上的字段不能抛出此异常

      • toString

        String toString​()
        获取字段的描述性名称。

        应为“BaseOfRange”格式，如“MonthOfYear”，除非该字段的范围为FOREVER ，当仅提及基本单元时，例如“年”或“时代”。

        重写：
        toString在 Object
        结果
        字段的名称，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TemporalQueries (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Class TemporalQueries

  • java.lang.Object
    • java.time.temporal.TemporalQueries

  • public final class TemporalQueries
extends Object
    通用实现TemporalQuery 。

    这个类提供了TemporalQuery的常见实现。 这些定义在这里，因为它们必须是常量，并且lambdas的定义不能保证。 通过在这里分配一次，它们将成为“常规”Java常量。

    查询是从时间对象提取信息的关键工具。 它们存在于外部化查询过程，根据策略设计模式允许不同的方法。 示例可能是一个查询，检查日期是闰年前的二月二十九日前一天，还是计算下一个生日的天数。

    TemporalField接口提供了另一种查询时间对象的机制。 该接口限于返回long 。 相比之下，查询可以返回任何类型。

    有两种等效的方式使用TemporalQuery 。 第一个是直接在这个接口上调用方法。 二是使用TemporalAccessor.query(TemporalQuery) ：

      // these two lines are equivalent, but the second approach is recommended
   temporal = thisQuery.queryFrom(temporal);
   temporal = temporal.query(thisQuery);
    建议使用第二种方法， query(TemporalQuery) ，因为在代码中阅读更清楚。

    最常见的实现是方法引用，例如LocalDate::from和ZoneId::from 。 提供其他常见查询以返回：

    • 一个年表，
    • 一个LocalDate，
    • 一个LocalTime，
    • 一个ZoneOffset，
    • 精度，
    • 一个区域，或
    • 一个zoneId。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TemporalQuery<Chronology> chronology​()
      查询 Chronology 。
      static TemporalQuery<LocalDate> localDate​()
      对于 LocalDate的查询，如果找不到则返回null。
      static TemporalQuery<LocalTime> localTime​()
      对于 LocalTime的查询，如果找不到则返回null。
      static TemporalQuery<ZoneOffset> offset​()
      对于 ZoneOffset的查询，如果找不到则返回null。
      static TemporalQuery<TemporalUnit> precision​()
      对最小支持单位的查询。
      static TemporalQuery<ZoneId> zone​()
      对 ZoneId宽松查询，回落到 ZoneOffset 。
      static TemporalQuery<ZoneId> zoneId​()
      严格查询 ZoneId 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • zoneId

        public static TemporalQuery<ZoneId> zoneId​()
        严格查询ZoneId 。

        这可以查询TemporalAccessor的区域。 如果日期时间概念上包含ZoneId则该区域仅返回。 如果日期时间仅在概念上具有ZoneOffset ，则不会返回。 因此，一个ZonedDateTime将返回结果getZone() ，而是OffsetDateTime将返回null。

        在大多数情况下，应用程序应使用zone()，因为此查询过于严格。

        执行TemporalAccessor JDK课程的结果如下：
        LocalDate返回null
        LocalTime返回null
        LocalDateTime返回null
        ZonedDateTime返回相关联的区域
        OffsetTime返回null
        OffsetDateTime返回null
        ChronoLocalDate返回null
        ChronoLocalDateTime返回null
        ChronoZonedDateTime返回相关联的区域
        Era返回null
        DayOfWeek返回null
        Month返回null
        Year返回null
        YearMonth返回null
        MonthDay返回null
        ZoneOffset返回null
        Instant返回null

        结果
        一个可以获得时间的区域ID的查询，而不是null

      • chronology

        public static TemporalQuery<Chronology> chronology​()
        查询Chronology 。

        这将查询TemporalAccessor的年表。 如果目标TemporalAccessor表示日期或日期的一部分，则应返回表示日期的年表。作为此定义的结果，仅表示时间的对象（如LocalTime ）将返回null。

        执行TemporalAccessor JDK课程的结果如下：
        LocalDate返回IsoChronology.INSTANCE
        LocalTime返回null（不表示日期）
        LocalDateTime返回IsoChronology.INSTANCE
        ZonedDateTime返回IsoChronology.INSTANCE
        OffsetTime返回null（不表示日期）
        OffsetDateTime返回IsoChronology.INSTANCE
        ChronoLocalDate返回相关的年表
        ChronoLocalDateTime返回相关的年表
        ChronoZonedDateTime返回相关的年表
        Era返回相关的年表
        DayOfWeek返回null（按时间顺序共享）
        Month返回IsoChronology.INSTANCE
        Year返回IsoChronology.INSTANCE
        YearMonth返回IsoChronology.INSTANCE
        MonthDay返回null IsoChronology.INSTANCE
        ZoneOffset返回null（不表示日期）
        Instant返回null（不表示日期）

        该方法Chronology.from(TemporalAccessor)可以用作一个TemporalQuery经由方法参考， Chronology::from 。 该方法相当于此查询，但如果无法获取年表，则抛出异常。

        结果
        一个查询，可以获得时间，而不是null的年表

      • precision

        public static TemporalQuery<TemporalUnit> precision​()
        对最小支持单位的查询。

        这可以查询TemporalAccessor的时间精度。 如果目标TemporalAccessor表示一致或完整的日期时间，日期或时间，则必须返回实际支持的最小精度。 请注意，诸如NANO_OF_DAY和NANO_OF_SECOND类的字段被定义为始终返回忽略精度，因此这是找到实际最小支持单元的唯一方法。 例如， GregorianCalendar要实现TemporalAccessor它会返回MILLIS的精度。

        执行TemporalAccessor JDK课程的结果如下：
        LocalDate返回DAYS
        LocalTime返回NANOS
        LocalDateTime返回NANOS
        ZonedDateTime返回NANOS
        OffsetTime返回NANOS
        OffsetDateTime返回NANOS
        ChronoLocalDate返回DAYS
        ChronoLocalDateTime返回NANOS
        ChronoZonedDateTime返回NANOS
        Era返回ERAS
        DayOfWeek返回DAYS
        Month返回MONTHS
        Year返回YEARS
        YearMonth返回MONTHS
        MonthDay返回null（不代表完整的日期或时间）
        ZoneOffset返回null（不表示日期或时间）
        Instant返回NANOS

        结果
        一个可以获得时间的精度的查询，而不是null

      • zone

        public static TemporalQuery<ZoneId> zone​()
        一个宽松的查询为ZoneId ，回落到ZoneOffset 。

        这将查询一个TemporalAccessor的区域。 它首先尝试获得该区域，使用zoneId() 。 如果没有找到它，它会尝试获取offset() 。 因此，一个ZonedDateTime将返回的结果getZone() ，而一个OffsetDateTime将返回的结果getOffset() 。

        在大多数情况下，应用程序应使用此查询而不是#zoneId() 。

        该方法ZoneId.from(TemporalAccessor)可以用作一个TemporalQuery经由方法参考， ZoneId::from 。 该方法相当于此查询，但如果无法获取区域，则抛出异常。

        结果
        一个可以获取时间的区域ID或偏移的查询，而不是null

      • offset

        public static TemporalQuery<ZoneOffset> offset​()
        对于ZoneOffset的查询，如果找不到，返回null。

        这将返回一个TemporalQuery ，可用于查询偏移量的时间对象。 如果时间对象不能提供偏移量，查询将返回null。

        查询实现检查OFFSET_SECONDS字段并使用它来创建一个ZoneOffset 。

        该方法ZoneOffset.from(TemporalAccessor)可以用作一个TemporalQuery经由方法参考， ZoneOffset::from 。 如果时间对象包含一个偏移量，这个查询和ZoneOffset::from将返回相同的结果。 如果时间对象不包含偏移量，则方法引用将抛出异常，而此查询将返回null。

        结果
        一个可以获得时间偏移的查询，而不是null

      • localDate

        public static TemporalQuery<LocalDate> localDate​()
        对于LocalDate的查询，如果找不到则返回null。

        这将返回一个TemporalQuery ，可用于查询本地日期的时间对象。 如果时间对象不能提供本地日期，查询将返回null。

        查询实现检查EPOCH_DAY字段，并使用它来创建一个LocalDate 。

        该方法ZoneOffset.from(TemporalAccessor)可以用作一个TemporalQuery经由方法参考， LocalDate::from 。 该查询和LocalDate::from将返回相同的结果，如果时间对象包含一个日期。 如果时间对象不包含日期，则方法引用将抛出异常，而此查询将返回null。

        结果
        一个查询可以获取时间的日期，而不是null

      • localTime

        public static TemporalQuery<LocalTime> localTime​()
        对于LocalTime的查询，如果找不到则返回null。

        这将返回一个可用于查询本地时间的时间对象的TemporalQuery 。 如果时间对象不能提供本地时间，查询将返回null。

        查询实现检查NANO_OF_DAY字段并使用它来创建一个LocalTime 。

        该方法ZoneOffset.from(TemporalAccessor)可以用作一个TemporalQuery经由方法参考， LocalTime::from 。 该查询和LocalTime::from将返回相同的结果，如果时间对象包含一个时间。 如果时间对象不包含时间，则方法引用将抛出异常，而此查询将返回null。

        结果
        一个可以获得时间的查询，而不是null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TemporalQuery (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Interface TemporalQuery<R>

  • 参数类型
    R - 从查询返回的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface TemporalQuery<R>
    查询时间对象的策略。

    查询是从时间对象提取信息的关键工具。 它们存在于外部化查询过程，根据策略设计模式允许不同的方法。 示例可能是一个查询，检查日期是闰年前的二月二十九日前一天，还是计算下一个生日的天数。

    TemporalField接口提供了另一种用于查询时间对象的机制。 该接口限于返回一个long 。 相比之下，查询可以返回任何类型。

    有两种等效的方式使用TemporalQuery 。 第一个是直接在这个接口上调用方法。 二是使用TemporalAccessor.query(TemporalQuery) ：

      // these two lines are equivalent, but the second approach is recommended
   temporal = thisQuery.queryFrom(temporal);
   temporal = temporal.query(thisQuery);
    建议使用第二种方法， query(TemporalQuery) ，因为在代码中阅读更清楚。

    最常见的实现是方法引用，例如LocalDate::from和ZoneId::from 。 在TemporalQueries中提供了其他常见查询作为静态方法。

    实现要求：
    此接口对实现的可变性没有任何限制，但是强烈建议不变性。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      R queryFrom​(TemporalAccessor temporal)
      查询指定的时间对象。

    • 方法详细信息

      • queryFrom

        R queryFrom​(TemporalAccessor temporal)
        查询指定的时间对象。

        这将查询指定的时间对象以使用实现类中封装的逻辑返回对象。 示例可能是一个查询，检查日期是闰年前的二月二十九日前一天，还是计算下一个生日的天数。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用TemporalAccessor.query(TemporalQuery) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisQuery.queryFrom(temporal);
   temporal = temporal.query(thisQuery);
        建议使用第二种方法， query(TemporalQuery) ，因为在代码中阅读更清楚。
        实现要求：
        实现必须接受输入对象并进行查询。 该实现定义了查询的逻辑，并负责记录该逻辑。 它可以使用TemporalAccessor上的任何方法来确定结果。 输入对象不能更改。

        输入的时间对象可以在不同于ISO的日历系统中。 实现可以选择记录与其他日历系统的兼容性，或者通过querying the chronology拒绝非ISO临时对象。

        可以从多个并行线程调用此方法。 调用时必须是线程安全的。

        参数
        temporal - 要查询的时间对象，不为空
        结果
        查询的值可能返回null表示未找到
        异常
        DateTimeException - 如果无法查询
        ArithmeticException - 如果发生数字溢出
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TemporalUnit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Interface TemporalUnit

  • 所有已知实现类：
    ChronoUnit

    public interface TemporalUnit
    日期时间单位，如天数或小时数。

    时间的测量建立在单位上，如年，月，日，小时，分钟和秒。 该接口的实现表示这些单元。

    该接口的一个实例表示单元本身，而不是单元的数量。 请参阅Period ，表示以公用单位计的金额。

    最常用的单位在ChronoUnit中定义。 其他单位提供IsoFields 。 单元也可以通过应用程序代码来实现这个接口。

    该单位使用双重调度工作。 客户端代码调用日期时间的方法，如LocalDateTime ，检查单元是否为ChronoUnit 。 如果是，则日期时间必须处理它。 否则，方法调用将重新分配到此接口中的匹配方法。

    实现要求：
    该接口必须小心实施，以确保其他类正确运行。 可以实例化的所有实现必须是最终的，不可变的和线程安全的。 建议尽可能使用枚举。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      <R extends Temporal>
      R             		addTo​(R temporal, long amount)
      返回添加指定句点的指定时间对象的副本。
      long between​(Temporal temporal1Inclusive, Temporal temporal2Exclusive)
      计算两个时间对象之间的时间量。
      Duration getDuration​()
      获取此单位的持续时间，这可能是一个估计。
      boolean isDateBased​()
      检查本机是否代表日期的组成部分。
      boolean isDurationEstimated​()
      检查单位的持续时间是否是估计。
      default boolean isSupportedBy​(Temporal temporal)
      检查本机是否受指定的时间对象的支持。
      boolean isTimeBased​()
      检查本机是否代表时间的一个组成部分。
      String toString​()
      获取单位的描述性名称。

    • 方法详细信息

      • getDuration

        Duration getDuration​()
        获取此单位的持续时间，这可能是一个估计。

        所有单位返回从该方法测量的标准纳秒的持续时间。 持续时间将为正且非零。 例如，一小时的持续时间为60 * 60 * 1,000,000,000ns 。

        有些单位可能返回准确的持续时间，而其他单位可能返回估计。 例如，由于夏令时更改的可能性，天数估计有效。 要确定持续时间是否为估计值，请使用isDurationEstimated() 。

        结果
        该单位的持续时间（可能是估计）不为空

      • isDurationEstimated

        boolean isDurationEstimated​()
        检查单位的持续时间是否是估计。

        所有单位都有持续时间，但持续时间并不总是准确的。 例如，由于夏令时更改的可能性，天数估计有效。 如果持续时间是估计值，则此方法返回true，如果是准确的则返回false。 请注意，准确/估计忽略闰秒。

        结果
        如果持续时间估计为真，则为真，如果准确

      • isDateBased

        boolean isDateBased​()
        检查本机是否代表日期的组成部分。

        日期是以时间为基础的，如果它可以用来暗示日期的含义。 它必须有一个duration ，这是标准日的长度的整数倍。 请注意， isDateBased()和isTimeBased()可以返回false，例如当36小时代表单位时。

        结果
        如果此单位是日期的组成部分，则为真

      • isTimeBased

        boolean isTimeBased​()
        检查本机是否代表时间的一个组成部分。

        一个单位是基于时间的，如果它可以用来暗示一段时间的意义。 它必须有一个duration ，分为标准日期的长度，没有余数。 请注意，对于isDateBased()和isTimeBased()可以返回false，例如当表示36小时的单位时。

        结果
        如果这个单位是时间的一个组成部分，则为真

      • isSupportedBy

        default boolean isSupportedBy​(Temporal temporal)
        检查本机是否受指定的时间对象的支持。

        这检查实施日期时间可以加/减这个单位。 这可以用来避免抛出异常。

        此默认实现使用Temporal.plus(long, TemporalUnit)导出值。

        参数
        temporal - 要检查的时间对象，不为空
        结果
        如果设备支持，则为true

      • addTo

        <R extends Temporal> R addTo​(R temporal,
                             long amount)
        返回添加指定句点的指定时间对象的副本。

        增加的时间是这个单位的倍数。 例如，通过在表示“days”的实例上调用该方法，传递日期和期间“3”，可以使用此方法添加“3天”。 要添加的时间可以是负数，这相当于减法。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用Temporal.plus(long, TemporalUnit) ：

          // these two lines are equivalent, but the second approach is recommended
   temporal = thisUnit.addTo(temporal);
   temporal = temporal.plus(thisUnit);
        建议使用第二种方法， plus(TemporalUnit) ，因为在代码中阅读更清楚。

        实现应该执行使用可用的单位有任何疑问或计算ChronoUnit或可用字段ChronoField 。 如果不支持本机，则必须抛出UnsupportedTemporalTypeException 。

        实现不能改变指定的时间对象。 相反，必须退还原件的调整副本。 这为不可变和可变的实现提供了相当的安全行为。

        参数类型
        R - 时间对象的类型
        参数
        temporal - 要调整的时间对象，不为空
        amount - 要添加的单位数量，正数或负数
        结果
        调整后的时间对象，不为空
        异常
        DateTimeException - 如果不能添加金额
        UnsupportedTemporalTypeException - 如果单位不受时间支持

      • between

        long between​(Temporal temporal1Inclusive,
             Temporal temporal2Exclusive)
        计算两个时间对象之间的时间量。

        这计算出这个单位的数量。 起始点和终点作为时间对象提供，并且必须是兼容类型。 实施将在计算数量之前将第二类型转换为第一类的实例。 如果结束在开始之前，结果将为负数。 例如，可以使用HOURS.between(startTime, endTime)计算两个时间对象之间的小时HOURS.between(startTime, endTime) 。

        计算返回一个整数，表示两个时间之间的完整单位数。 例如，11时30分至13时29分之间的小时数将只有1小时，因为距离两小时不到1分钟。

        使用这种方法有两种等效的方法。 第一个是直接调用这个方法。 二是使用Temporal.until(Temporal, TemporalUnit) ：

          // these two lines are equivalent
   between = thisUnit.between(start, end);
   between = start.until(end, thisUnit);
        应该根据这种做法进行选择，使代码更易读。

        例如，该方法允许计算两个日期之间的天数：

          long daysBetween = DAYS.between(start, end);
  // or alternatively
  long daysBetween = start.until(end, DAYS);

        实现应该执行使用可用的单位有任何疑问或计算ChronoUnit或可用字段ChronoField 。 如果不支持本机，则必须抛出UnsupportedTemporalTypeException 。 实现不能改变指定的时间对象。

        实现要求：
        实现必须首先检查两个时间是否与getClass()具有相同的类型。 如果没有，那么结果必须通过调用temporal1Inclusive.until(temporal2Exclusive, this)获得。
        参数
        temporal1Inclusive - 基本的时间对象，不为空
        temporal2Exclusive - 其他时间对象，排他，不为空
        结果
        在本单位之间的temporal1Inclusive和temporal2独家之间的时间量; 如果temporal2Exclusive晚于temporal1Inclusive，则为正，如果更早则为负
        异常
        DateTimeException - 如果不能计算金额，或者结束时间不能转换为与开始时间相同的类型
        UnsupportedTemporalTypeException - 如果单位不受时间支持
        ArithmeticException - 如果发生数字溢出

      • toString

        String toString​()
        获取单位的描述性名称。

        这应该是复数和上第一个骆驼案例，如“天”或“分钟”。

        重写：
        toString在 Object
        结果
        本机的名称，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnsupportedTemporalTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Class UnsupportedTemporalTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.time.DateTimeException
            • java.time.temporal.UnsupportedTemporalTypeException
  • All Implemented Interfaces:
    Serializable

    public class UnsupportedTemporalTypeException
extends DateTimeException
    UnsupportedTemporalTypeException表示Temporal类不支持ChronoField或ChronoUnit。
    实现要求：
    该类旨在用于单个线程。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnsupportedTemporalTypeException​(String message)
      使用指定的消息构造一个新的UnsupportedTemporalTypeException。
      UnsupportedTemporalTypeException​(String message, Throwable cause)
      构造一个新的UnsupportedTemporalTypeException与指定的消息和原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnsupportedTemporalTypeException

        public UnsupportedTemporalTypeException​(String message)
        使用指定的消息构造一个新的UnsupportedTemporalTypeException。
        参数
        message - 用于此异常的消息可能为null

      • UnsupportedTemporalTypeException

        public UnsupportedTemporalTypeException​(String message,
                                        Throwable cause)
        构造一个新的UnsupportedTemporalTypeException与指定的消息和原因。
        参数
        message - 用于此异常的消息可能为null
        cause - 异常的原因可能为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.time.temporal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.time.temporal

  • Packages that use java.time.temporal
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util.concurrent
    实用程序类通常用于并发编程。
  • Classes in java.time.temporal used by java.time
    Class 描述
    Temporal
    定义对时间对象的读写访问的框架级接口，例如日期，时间，偏移或这些的一些组合。
    TemporalAccessor
    框架级接口定义对时间对象的只读访问，例如日期，时间，偏移或这些的某些组合。
    TemporalAdjuster
    调整时间对象的策略。
    TemporalAmount
    定义一段时间的框架级界面，如“6小时”，“8天”或“2年3个月”。
    TemporalField
    日期时间的字段，如月份或小时。
    TemporalQuery
    查询时间对象的策略。
    TemporalUnit
    日期时间单位，如天数或小时数。
    ValueRange
    日期时间字段的有效值的范围。
  • Classes in java.time.temporal used by java.time.chrono
    Class 描述
    ChronoField
    一套标准的字段。
    Temporal
    定义对时间对象的读写访问的框架级接口，例如日期，时间，偏移或这些的一些组合。
    TemporalAccessor
    框架级接口定义对时间对象的只读访问，例如日期，时间，偏移或这些的某些组合。
    TemporalAdjuster
    调整时间对象的策略。
    TemporalAmount
    定义一段时间的框架级界面，如“6小时”，“8天”或“2年3个月”。
    TemporalField
    日期时间的字段，如月份或小时。
    TemporalQuery
    查询时间对象的策略。
    TemporalUnit
    日期时间单位，如天数或小时数。
    ValueRange
    日期时间字段的有效值的范围。
  • Classes in java.time.temporal used by java.time.format
    Class 描述
    TemporalAccessor
    框架级接口定义对时间对象的只读访问，例如日期，时间，偏移或这些的某些组合。
    TemporalField
    日期时间的字段，如月份或小时。
    TemporalQuery
    查询时间对象的策略。
  • Classes in java.time.temporal used by java.time.temporal
    Class 描述
    ChronoField
    一套标准的字段。
    ChronoUnit
    一组标准的日期单位。
    Temporal
    定义对时间对象的读写访问的框架级接口，例如日期，时间，偏移或这些的一些组合。
    TemporalAccessor
    框架级接口定义对时间对象的只读访问，例如日期，时间，偏移或这些的某些组合。
    TemporalAdjuster
    调整时间对象的策略。
    TemporalAmount
    定义一段时间的框架级界面，如“6小时”，“8天”或“2年3个月”。
    TemporalField
    日期时间的字段，如月份或小时。
    TemporalQuery
    查询时间对象的策略。
    TemporalUnit
    日期时间单位，如天数或小时数。
    ValueRange
    日期时间字段的有效值的范围。
    WeekFields
    星期几，星期周和周末字段的本地化定义。
  • Classes in java.time.temporal used by java.util.concurrent
    Class 描述
    ChronoUnit
    A standard set of date periods units.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ValueRange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Class ValueRange

  • java.lang.Object
    • java.time.temporal.ValueRange
  • All Implemented Interfaces:
    Serializable

    public final class ValueRange
extends Object
implements Serializable
    日期时间字段的有效值的范围。

    所有TemporalField实例都具有有效的值范围。 例如，ISO日期从1到28到31之间。这个类捕获有效范围。

    了解这个课程的局限性很重要。 只提供最小值和最大值。 在外部范围内可能存在无效值。 例如，奇怪的字段可能具有1,2,4,6,7的有效值，因此具有范围“1 - 7”，尽管值3和5无效。

    这个类的实例不是绑定到一个特定的领域。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int checkValidIntValue​(long value, TemporalField field)
      检查指定的值是否有效并适合 int 。
      long checkValidValue​(long value, TemporalField field)
      检查指定的值是否有效。
      boolean equals​(Object obj)
      检查此范围是否等于另一个范围。
      long getLargestMinimum​()
      获取该字段可能采取的最大可能最小值。
      long getMaximum​()
      获取字段可以占用的最大值。
      long getMinimum​()
      获取字段可以占用的最小值。
      long getSmallestMaximum​()
      获取该字段可以采用的最小可能最大值。
      int hashCode​()
      此范围的哈希码。
      boolean isFixed​()
      值范围是固定的并且是完全已知的。
      boolean isIntValue​()
      检查范围内的所有值是否适合 int 。
      boolean isValidIntValue​(long value)
      检查值是否在有效范围内，范围内的所有值都适用于 int 。
      boolean isValidValue​(long value)
      检查该值是否在有效范围内。
      static ValueRange of​(long min, long max)
      获得固定值范围。
      static ValueRange of​(long min, long maxSmallest, long maxLargest)
      获取变量值范围。
      static ValueRange of​(long minSmallest, long minLargest, long maxSmallest, long maxLargest)
      获得完全可变的值范围。
      String toString​()
      将此范围输出为 String 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • of

        public static ValueRange of​(long min,
                            long max)
        获得固定值范围。

        该工厂获得最小值和最大值固定的范围。 例如，ISO月份总是从1到12。

        参数
        min - 最小值
        max - 最大值
        结果
        ValueRange为min，max，not null
        异常
        IllegalArgumentException - 如果最小值大于最大值

      • of

        public static ValueRange of​(long min,
                            long maxSmallest,
                            long maxLargest)
        获取变量值范围。

        该工厂获得最小值固定的范围，最大值可能会有所不同。 例如，ISO日历始终从1开始，但是在28和31之间结束。

        参数
        min - 最小值
        maxSmallest - 最小最大值
        maxLargest - 最大最大值
        结果
        ValueRange为最小值，最小值最大值，最大值最大值，非空值
        异常
        IllegalArgumentException - 如果最小值大于最小最大值，或最小最大值大于最大值

      • of

        public static ValueRange of​(long minSmallest,
                            long minLargest,
                            long maxSmallest,
                            long maxLargest)
        获得完全可变的值范围。

        该工厂获得最小值和最大值可能会有所不同的范围。

        参数
        minSmallest - 最小的最小值
        minLargest - 最大的最小值
        maxSmallest - 最小最大值
        maxLargest - 最大最大值
        结果
        ValueRange为最小最小，最大最小，最小最大值，最大最大值，非空值
        异常
        IllegalArgumentException - 如果最小的最小值大于最小的最大值，或者最小的最大值大于最大的最大值，或者最大的最小值大于最大的最大值

      • isFixed

        public boolean isFixed​()
        值范围是固定的并且是完全已知的。

        例如，ISO的日期是从1到28和31之间。由于有最大值的不确定性，范围是不固定的。 但是，1月份，范围总是1到31，因此是固定的。

        结果
        如果值的集合是固定的，则为true

      • getMinimum

        public long getMinimum​()
        获取字段可以占用的最小值。

        例如，ISO的日期始终从1开始。因此，最小值为1。

        结果
        该字段的最小值

      • getLargestMinimum

        public long getLargestMinimum​()
        获取该字段可能采取的最大可能最小值。

        例如，ISO的日期始终始于1.最大的最小值为1。

        结果
        该字段的最大可能最小值

      • getSmallestMaximum

        public long getSmallestMaximum​()
        获取该字段可以采用的最小可能最大值。

        例如，ISO的日期为28到31天。 因此最小的最大值为28。

        结果
        该字段的最小可能最大值

      • getMaximum

        public long getMaximum​()
        获取字段可以占用的最大值。

        例如，ISO的日期为28到31天。 因此最大值为31。

        结果
        该字段的最大值

      • isIntValue

        public boolean isIntValue​()
        检查范围内的所有值是否适合int 。

        这检查所有有效值是否在int的范围内。

        例如，ISO月份的值从1到12，符合int 。 相比之下，ISO nano-of-day的运行时间从1到86,400,000,000,000不符合int 。

        此实现使用getMinimum()和getMaximum() 。

        结果
        如果有效值始终符合 int

      • isValidValue

        public boolean isValidValue​(long value)
        检查该值是否在有效范围内。

        这检查该值是否在存储的值范围内。

        参数
        value - 要检查的值
        结果
        如果值有效，则为true

      • isValidIntValue

        public boolean isValidIntValue​(long value)
        检查值是否在有效范围内，范围内的所有值都适合int 。

        该方法结合了isIntValue()和isValidValue(long) 。

        参数
        value - 要检查的值
        结果
        如果值有效并适合于 int

      • checkValidValue

        public long checkValidValue​(long value,
                            TemporalField field)
        检查指定的值是否有效。

        这将验证该值在有效的值范围内。 该字段仅用于改进错误消息。

        参数
        value - 要检查的值
        field - 被检查的字段可以为空
        结果
        传入的价值
        另请参见：
        isValidValue(long)

      • checkValidIntValue

        public int checkValidIntValue​(long value,
                              TemporalField field)
        检查指定的值是否有效并适合int 。

        这将验证该值在有效的值范围内，并且所有有效值都在int的范围内。 该字段仅用于改进错误消息。

        参数
        value - 要检查的值
        field - 被检查的字段可以为空
        结果
        传入的价值
        另请参见：
        isValidIntValue(long)

      • equals

        public boolean equals​(Object obj)
        检查此范围是否等于另一个范围。

        比较是基于四个值，最小值，最大值，最小值，最小值和最大值。 只对ValueRange类型的ValueRange进行比较，其他类型返回false。

        重写：
        equals在 Object
        参数
        obj - 要检查的对象，null返回false
        结果
        如果这等于其他范围，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        此范围的哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        将此范围输出为String 。

        格式将是“{min} / {maximumMin} - {minimalMax} / {max}'，其中最大的Min或minimumMax部分可以被省略，以及相关的斜杠，如果它们与min或max相同。

        重写：
        toString在 Object
        结果
        a string representation of this range, not null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WeekFields (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.temporal

Class WeekFields

  • java.lang.Object
    • java.time.temporal.WeekFields
  • All Implemented Interfaces:
    Serializable

    public final class WeekFields
extends Object
implements Serializable
    星期几，星期周和周末字段的本地化定义。

    标准的一周是七天，但文化对于一周的其他方面也有不同的定义。 此类表示本周的定义，目的是提供TemporalField个实例。

    WeekFields提供了五个领域， dayOfWeek() ， weekOfMonth() ， weekOfYear() ， weekOfWeekBasedYear() ，并weekBasedYear() ，提供从任何访问值temporal object 。

    对于本周日的最计算，一年周的周的日，以及基于该proleptic-year ， month-of-year ， day-of-month和ISO day-of-week这是基于epoch-day和年表。 这些值可能与year-of-Era不一致，具体取决于年表。

    一周定义为：

    • 第一个星期。 例如，ISO-8601标准认为星期一是第一个星期。
    • 第一周的最少天数。 例如，ISO-8601标准在第一周计算需要至少4天。
    这两个值一起允许一年或一个月分为几周。

    几个月

    使用一个字段：月份。 计算确保星期永远不会与月份边界重叠。 这个月分为每个时期在定义的第一个星期几开始的时期。 如果它的日数少于最小天数，则将最早期称为第0周，如果具有至少最小天数，则将其称为第1周。 Examples of WeekFields Date Day-of-week First day: Monday
    Minimal days: 4 First day: Monday
    Minimal days: 5 2008-12-31 Wednesday Week 5 of December 2008 Week 5 of December 2008 2009-01-01 Thursday Week 1 of January 2009 Week 0 of January 2009 2009-01-04 Sunday Week 1 of January 2009 Week 0 of January 2009 2009-01-05 Monday Week 2 of January 2009 Week 1 of January 2009

    一年一度

    使用一个字段：一周。 计算确保周年不会与年边界重叠。 这一年分为每个时期每周定义的第一个星期开始的时期。 如果它的日数少于最小天数，则将最早期称为第0周，如果具有至少最小天数，则将其称为第1周。

    周年

    两个字段用于周年，一个用于week-of-week-based-year ，一个用于week-based-year 。 在一个星期的一年里，每个星期只属一年。 一年的第1周是从第一天开始的第一周，并且至少具有最少天数。 一年的第一个和最后几个星期可能分别包含上一个日历年或下一个历年的天数。 Examples of WeekFields for week-based-year Date Day-of-week First day: Monday
    Minimal days: 4 First day: Monday
    Minimal days: 5 2008-12-31 Wednesday Week 1 of 2009 Week 53 of 2008 2009-01-01 Thursday Week 1 of 2009 Week 53 of 2008 2009-01-04 Sunday Week 1 of 2009 Week 53 of 2008 2009-01-05 Monday Week 2 of 2009 Week 1 of 2009
    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static WeekFields ISO
      ISO-8601定义，一周从星期一开始，第一周至少有4天。
      static WeekFields SUNDAY_START
      从周日和第一周开始的一周的常见定义至少为1天。
      static TemporalUnit WEEK_BASED_YEARS
      以加法和减法为目的的以星期为单位的单位。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TemporalField dayOfWeek​()
      根据这个 WeekFields返回一个字段来访问星期 WeekFields 。
      boolean equals​(Object object)
      检查这个 WeekFields是否等于指定的对象。
      DayOfWeek getFirstDayOfWeek​()
      获得第一个星期。
      int getMinimalDaysInFirstWeek​()
      在第一周内获得最少天数。
      int hashCode​()
      这个 WeekFields哈希码。
      static WeekFields of​(DayOfWeek firstDayOfWeek, int minimalDaysInFirstWeek)
      从第一天和最短的天数获得 WeekFields的实例。
      static WeekFields of​(Locale locale)
      获取适合于语言环境的 WeekFields实例。
      String toString​()
      这个 WeekFields实例的字符串表示形式。
      TemporalField weekBasedYear​()
      根据这个 WeekFields返回一个字段以访问一周中的一年。
      TemporalField weekOfMonth​()
      根据这个 WeekFields返回一个字段以访问一个月。
      TemporalField weekOfWeekBasedYear​()
      根据这个 WeekFields返回一个字段以访问一周的周。
      TemporalField weekOfYear​()
      根据这个 WeekFields返回一个字段以访问一周中的一周。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ISO

        public static final WeekFields ISO
        ISO-8601定义，一周从星期一开始，第一周至少有4天。

        ISO-8601标准定义了一个基于周的日历系统。 它使用基于周的年份和周周的概念来分解天数，而不是标准的年/月/日。

        请注意，第一周可能在上一个日历年开始。 还要注意，一个日历年的头几天可能在上一个日历年的相应年份里。

      • SUNDAY_START

        public static final WeekFields SUNDAY_START
        从周日和第一周开始的一周的常见定义至少为1天。

        定义为从星期日开始，并在当月至少为1天。 本周的定义在美国和其他欧洲国家使用。

      • WEEK_BASED_YEARS

        public static final TemporalUnit WEEK_BASED_YEARS
        以加法和减法为目的的以星期为单位的单位。

        这允许将一些以周为基础的年数添加到日期或从日期中减去。 该单位等于52或53周。 一周的估计持续时间与365.2425 Days的标准ISO年度365.2425 Days 。

        添加的规则将周数年数添加到保留周周年和周日的基于周期的现有值中，除非周数太大为目标年 在这种情况下，星期将设定为同一天的最后一周。

        这个单位是一个不可变的和线程安全的单身人士。

    • 方法详细信息

      • of

        public static WeekFields of​(Locale locale)
        获取一个适合于语言环境的WeekFields的实例。

        这将从本地化数据提供商中查找适当的值。

        参数
        locale - 要使用的语言环境，不为空
        结果
        周定义，不为null

      • of

        public static WeekFields of​(DayOfWeek firstDayOfWeek,
                            int minimalDaysInFirstWeek)
        从第一天的星期几到最短的几天内获得WeekFields的实例。

        第一个星期几定义了ISO DayOfWeek ，这是一周的第1天。 第一周的最短天数定义了在第一周之前，从第一个星期开始，一个月或一年内必须出现多少天。 值1将计算第一周的一个月或第一天的第一天，而值7将需要整个七天在新的一个月或一年。

        WeekFields实例是单例; 对于firstDayOfWeek和minimalDaysInFirstWeek的每个独特组合，将返回相同的实例。

        参数
        firstDayOfWeek - 一周的第一天，不为空
        minimalDaysInFirstWeek - 第一周的最少天数，从1到7
        结果
        周定义，不为null
        异常
        IllegalArgumentException - 如果最小天数小于1或大于7

      • getFirstDayOfWeek

        public DayOfWeek getFirstDayOfWeek​()
        获得第一个星期。

        第一个星期的日子因文化而异。 例如，美国使用星期天，而法国和ISO-8601标准星期一使用。 此方法使用标准DayOfWeek枚举返回第一天。

        结果
        第一个星期，不是null

      • getMinimalDaysInFirstWeek

        public int getMinimalDaysInFirstWeek​()
        在第一周内获得最少天数。

        考虑定义一个月或一年的第一周的天数因文化而异。 例如，在计算第一周之前，ISO-8601需要4天（超过半周）。

        结果
        一个月或一年的第一周的最少天数，从1到7

      • dayOfWeek

        public TemporalField dayOfWeek​()
        根据这个WeekFields返回一个字段来访问星期WeekFields 。

        这类似于ChronoField.DAY_OF_WEEK，但是基于这个WeekFields星期几的WeekFields 。 天数从1到7，其中first day-of-week被分配值1。

        例如，如果第一个星期几是星期日，那么它将具有值1，其他日期的范围从星期一到2到星期六为7。

        在解析的解决阶段，本周的一周将被转换为标准化的ChronoField星期。 星期几必须在1到7的有效范围内。此类中的其他字段使用标准化的星期几构建日期。

        结果
        一个字段，提供访问本地化编号的星期几，而不是null

      • weekOfMonth

        public TemporalField weekOfMonth​()
        根据这个WeekFields返回一个字段以访问一个月的一周。

        这代表星期几星期开始的星期数周的概念。 此字段通常与dayOfWeek()一起使用 。

        第一周（1）是从getFirstDayOfWeek()开始的一周， 当月至少有getMinimalDaysInFirstWeek()天。 因此，第一周可能会在月初开始时间达minDays天。 如果第一个星期从月初开始，那么之前的周是零（0）。

        例如：
        - 如果一个月的第一天是星期一，那么第一周从第一天开始，没有周零
        - 如果本月的第二天是星期一，则第一周从第二天开始，第一天在第零周
        - 如果这个月的第四天是星期一，那么第一个星期从第四个开始，第一个到第三个是在零周
        - 如果本月的第5天是星期一，则第5周开始第2周，第1到第4周在第1周

        该字段可以与任何日历系统一起使用。

        在解析的解析阶段，可以从年，周，月，月和日的星期创建日期。

        在strict mode中 ，所有四个字段都针对其有效值的范围进行验证。 验证月份字段以确保生成的月份是所请求的月份。

        在smart mode中 ，所有四个字段都根据其有效值的范围进行验证。 “月份”字段的验证时间为0到6，这意味着生成的日期可能与指定的日期不同。

        在lenient mode中 ，根据有效值的范围验证年份和星期几。 产生的日期相当于以下四个阶段的方法。 首先，在请求的一年的1月的第一个星期的第一天创建一个日期。 然后取一个月的年份，减去一个，并将数量添加到几个月的日期。 然后拿一个月的一周，减去一个，并将数量添加到几个星期的日期。 最后，在本周内调整为正确的星期几。

        结果
        提供访问月份的字段不为空

      • weekOfYear

        public TemporalField weekOfYear​()
        根据这个WeekFields返回一个字段以访问一周中的一周。

        这是星期几固定星期几开始的一年内的周数计数的概念。 该字段通常与dayOfWeek()一起使用 。

        第一周（1）是从getFirstDayOfWeek()开始的一周，其中至少有getMinimalDaysInFirstWeek()天。 因此，第一周可能在今年年初之前的minDays天开始。 如果第一周从年初开始，那么前一周是零（0）。

        例如：
        - 如果一年中的第一天是星期一，则第一周从第一个开始，没有周零
        - 如果一年的第二天是星期一，第一周从第二个开始，第一个在第零周
        - 如果一年的第四天是星期一，第一周从第四天开始，第一到第三天在零周
        - 如果一年的第五天是星期一，第二周从第五个开始，第一到第四是在第一周

        该字段可以与任何日历系统一起使用。

        在解析的解决阶段，可以从一年，一周和一周中创建一个日期。

        在strict mode中 ，所有三个字段都根据其有效值的范围进行验证。 验证年周期以确保所产生的年份是所要求的年份。

        在smart mode中 ，所有三个字段都根据其有效值的范围进行验证。 周期字段从0到54验证，这意味着生成的日期可以与指定的日期不同。

        在lenient mode中 ，年份和星期几根据有效值的范围进行验证。 产生的日期相当于以下三个阶段的方法。 首先，在请求的一年的第一周的第一天创建一个日期。 然后拿一周，减去一个，并将数量添加到几个星期的日期。 最后，在本周内调整为正确的星期几。

        结果
        提供访问年份的字段不为空

      • weekOfWeekBasedYear

        public TemporalField weekOfWeekBasedYear​()
        根据这个WeekFields返回一个字段以访问一周的一周。

        这代表了星期几星期从星期一开始的星期几，每周属于一年的周数的概念。 该字段通常与dayOfWeek()和weekBasedYear()一起使用 。

        第一周（1）是从getFirstDayOfWeek()开始的一周，其中至少有getMinimalDaysInFirstWeek()天。 如果第一周从年初开始，那么之前的时期是在上一周的最后一个星期。

        例如：
        - 如果一年的第一天是星期一，那么第一天从第一天开始
        - 如果一年中的第二天是星期一，第一周从第二天开始，第一天在上一周的最后一周
        - 如果一年的第四天是星期一，第一周从第四天开始，第一到第三天是在上一周的最后一周
        - 如果一年的第五天是星期一，第二周从第五个开始，第一到第四是在第一周

        该字段可以与任何日历系统一起使用。

        在解析的解决阶段，可以从一个星期的年份，一周中的一周和一周中创建一个日期。

        在strict mode中 ，所有三个字段都根据其有效值的范围进行验证。 确认一周的工作周期，以确保所产生的周年为周年。

        在smart mode中 ，所有三个字段都根据其有效值的范围进行验证。 星期几的周期字段从1到53验证，这意味着生成的日期可以在指定的下一周的一年中。

        在lenient mode中 ，根据有效值的范围验证年份和星期几。 产生的日期相当于以下三个阶段的方法。 首先，在所请求的每周的第一周的第一天创建一个日期。 然后以周为周的年份，减去一周，并将数量添加到几周内。 最后，在本周内调整为正确的星期几。

        结果
        一个提供访问周周的年份的字段，不为空

      • weekBasedYear

        public TemporalField weekBasedYear​()
        根据这个WeekFields返回一个字段以访问一周的年份。

        这代表了星期几固定星期几开始的一年的概念，例如星期一，每周属于一年。 该字段通常与dayOfWeek()和weekOfWeekBasedYear()一起使用 。

        第一周（1）是从getFirstDayOfWeek()开始的一周，其中至少有getMinimalDaysInFirstWeek()天。 因此，第一周可能在今年年初之前开始。 如果第一周从年初开始，那么之前的时期是在上一周的最后一个星期。

        该字段可以与任何日历系统一起使用。

        在解析的解决阶段，可以从一个星期的年份，一周中的一周和一周中创建一个日期。

        在strict mode中 ，所有三个字段都针对其有效值的范围进行验证。 确认一周的工作周期，以确保所产生的周年为周年。

        在smart mode中 ，所有三个字段都针对其有效值的范围进行验证。 星期几的周期字段从1到53验证，这意味着生成的日期可以在指定的下一周的一年中。

        在lenient mode中 ，根据有效值的范围验证年份和星期几。 产生的日期相当于以下三个阶段的方法。 首先，在所请求的每周的第一周的第一天创建一个日期。 然后以周为周的年份，减去一周，并将数量添加到几周内。 最后，在本周内调整为正确的星期几。

        结果
        一个提供访问周的年份的字段，不为空

      • equals

        public boolean equals​(Object object)
        检查这个WeekFields是否等于指定的对象。

        比较是基于规则的整个状态，这是第一个星期几和最短的日子。

        重写：
        equals在 Object
        参数
        object - 要比较的其他规则，null返回false
        结果
        如果这等于指定的规则，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        这个 WeekFields哈希码。
        重写：
        hashCode在 Object
        结果
        一个合适的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        这个 WeekFields实例的字符串表示形式。
        重写：
        toString在 Object
        结果
        字符串表示，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Class java.time.temporal.ChronoField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.temporal.ChronoField

  • Packages that use ChronoField
    软件包 描述
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of ChronoField in java.time.chrono

      Methods in java.time.chrono with parameters of type ChronoField
      Modifier and Type | 方法 | 描述
      ValueRange Chronology.range​(ChronoField field)
      获取指定字段的有效值的范围。
      ValueRange | HijrahChronology.range​(ChronoField field)
      ValueRange | IsoChronology.range​(ChronoField field)
      ValueRange | JapaneseChronology.range​(ChronoField field)
      ValueRange | MinguoChronology.range​(ChronoField field)
      ValueRange | ThaiBuddhistChronology.range​(ChronoField field)

    • Uses of ChronoField in java.time.temporal

      Methods in java.time.temporal that return ChronoField
      Modifier and Type 方法 描述
      static ChronoField ChronoField.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ChronoField[] ChronoField.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.temporal.ChronoUnit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.temporal.ChronoUnit

  • Packages that use ChronoUnit
    软件包 描述
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ChronoUnit in java.time.temporal

      Methods in java.time.temporal that return ChronoUnit
      Modifier and Type 方法 描述
      static ChronoUnit ChronoUnit.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ChronoUnit[] ChronoUnit.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of ChronoUnit in java.util.concurrent

      Methods in java.util.concurrent that return ChronoUnit
      Modifier and Type 方法 描述
      ChronoUnit TimeUnit.toChronoUnit​()
      将此 TimeUnit转换为等效的 ChronoUnit 。
      Methods in java.util.concurrent with parameters of type ChronoUnit
      Modifier and Type 方法 描述
      static TimeUnit TimeUnit.of​(ChronoUnit chronoUnit)
      将 ChronoUnit转换为等效的 TimeUnit 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.temporal.IsoFields (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.temporal.IsoFields

No usage of java.time.temporal.IsoFields
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.temporal.JulianFields (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.temporal.JulianFields

No usage of java.time.temporal.JulianFields
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.temporal.TemporalAdjusters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.temporal.TemporalAdjusters

No usage of java.time.temporal.TemporalAdjusters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.temporal.TemporalQueries (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.temporal.TemporalQueries

No usage of java.time.temporal.TemporalQueries
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.temporal.UnsupportedTemporalTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.temporal.UnsupportedTemporalTypeException

No usage of java.time.temporal.UnsupportedTemporalTypeException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.temporal.ValueRange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.temporal.ValueRange

  • Packages that use ValueRange
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of ValueRange in java.time

      Methods in java.time that return ValueRange
      Modifier and Type 方法 描述
      ValueRange DayOfWeek.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange Instant.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange LocalDate.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange LocalDateTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange LocalTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange Month.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange MonthDay.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange OffsetDateTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange OffsetTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange Year.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange YearMonth.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange ZonedDateTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange ZoneOffset.range​(TemporalField field)
      获取指定字段的有效值的范围。

    • Uses of ValueRange in java.time.chrono

      Methods in java.time.chrono that return ValueRange
      Modifier and Type | 方法 | 描述
      ValueRange Chronology.range​(ChronoField field)
      获取指定字段的有效值的范围。
      default ValueRange | ChronoZonedDateTime.range​(TemporalField field)
      default ValueRange Era.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange | HijrahChronology.range​(ChronoField field)
      ValueRange | HijrahDate.range​(TemporalField field)
      ValueRange HijrahEra.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange | IsoChronology.range​(ChronoField field)
      ValueRange | JapaneseChronology.range​(ChronoField field)
      ValueRange | JapaneseDate.range​(TemporalField field)
      ValueRange JapaneseEra.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange | MinguoChronology.range​(ChronoField field)
      ValueRange | MinguoDate.range​(TemporalField field)
      ValueRange | ThaiBuddhistChronology.range​(ChronoField field)
      ValueRange | ThaiBuddhistDate.range​(TemporalField field)

    • Uses of ValueRange in java.time.temporal

      Methods in java.time.temporal that return ValueRange
      Modifier and Type | 方法 | 描述
      static ValueRange ValueRange.of​(long min, long max)
      获得固定值范围。
      static ValueRange ValueRange.of​(long min, long maxSmallest, long maxLargest)
      获取变量值范围。
      static ValueRange ValueRange.of​(long minSmallest, long minLargest, long maxSmallest, long maxLargest)
      获得完全可变的值范围。
      ValueRange ChronoField.range​()
      获取字段的有效值的范围。
      default ValueRange TemporalAccessor.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange TemporalField.range​()
      获取字段的有效值的范围。
      ValueRange | ChronoField.rangeRefinedBy​(TemporalAccessor temporal)
      ValueRange TemporalField.rangeRefinedBy​(TemporalAccessor temporal)
      使用时间对象获取此字段的有效值的范围以优化结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.temporal.WeekFields (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.temporal.WeekFields

  • Packages that use WeekFields
    软件包 描述
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of WeekFields in java.time.temporal

      Fields in java.time.temporal declared as WeekFields
      Modifier and Type Field 描述
      static WeekFields WeekFields.ISO
      ISO-8601定义，一周从星期一开始，第一周至少有4天。
      static WeekFields WeekFields.SUNDAY_START
      从周日和第一周开始的一周的常见定义至少为1天。
      Methods in java.time.temporal that return WeekFields
      Modifier and Type 方法 描述
      static WeekFields WeekFields.of​(DayOfWeek firstDayOfWeek, int minimalDaysInFirstWeek)
      从第一天和最短的天数获得 WeekFields的实例。
      static WeekFields WeekFields.of​(Locale locale)
      获取一个适合于语言环境的 WeekFields的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.temporal.Temporal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.temporal.Temporal

  • Packages that use Temporal
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of Temporal in java.time

      Classes in java.time that implement Temporal
      Modifier and Type Class 描述
      class  Instant
      在时间线上的瞬间点。
      class  LocalDate
      在ISO- 2007-12-03 ，如 2007-12-03 。
      class  LocalDateTime
      在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
      class  LocalTime
      在ISO- 10:15:30 ，如 10:15:30 。
      class  OffsetDateTime
      在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如 2007-12-03T10:15:30+01:00 。
      class  OffsetTime
      在ISO- 10:15:30+01:00 UTC /格林威治的时间，如 10:15:30+01:00 。
      class  Year
      一年在ISO- 2007 ，如 2007 。
      class  YearMonth
      ISO- 2007-12 ，如 2007-12 。
      class  ZonedDateTime
      ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。
      Methods in java.time that return Temporal
      Modifier and Type 方法 描述
      Temporal Duration.addTo​(Temporal temporal)
      将此持续时间添加到指定的时间对象。
      Temporal Period.addTo​(Temporal temporal)
      将此时段添加到指定的时间对象。
      Temporal DayOfWeek.adjustInto​(Temporal temporal)
      将指定的时间对象调整为具有这一天的日期。
      Temporal Instant.adjustInto​(Temporal temporal)
      调整指定的时间对象具有这个瞬间。
      Temporal LocalDate.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象的日期相同。
      Temporal LocalDateTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的日期和时间。
      Temporal LocalTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的时间。
      Temporal Month.adjustInto​(Temporal temporal)
      将指定的时间对象调整为具有这个月的年份。
      Temporal MonthDay.adjustInto​(Temporal temporal)
      将指定的时间对象调整为具有这个月日。
      Temporal OffsetDateTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的偏移量，日期和时间。
      Temporal OffsetTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的偏移量和时间。
      Temporal Year.adjustInto​(Temporal temporal)
      调整指定的时间对象到今年。
      Temporal YearMonth.adjustInto​(Temporal temporal)
      将指定的时间对象调整为今年。
      Temporal ZoneOffset.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象的偏移量相同。
      Temporal Duration.subtractFrom​(Temporal temporal)
      从指定的时间对象中减去此持续时间。
      Temporal Period.subtractFrom​(Temporal temporal)
      从指定的时间对象中减去这个时间段。
      Methods in java.time with parameters of type Temporal
      Modifier and Type 方法 描述
      Temporal Duration.addTo​(Temporal temporal)
      将此持续时间添加到指定的时间对象。
      Temporal Period.addTo​(Temporal temporal)
      将此时段添加到指定的时间对象。
      Temporal DayOfWeek.adjustInto​(Temporal temporal)
      将指定的时间对象调整为具有这一天的日期。
      Temporal Instant.adjustInto​(Temporal temporal)
      调整指定的时间对象具有这个瞬间。
      Temporal LocalDate.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象的日期相同。
      Temporal LocalDateTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的日期和时间。
      Temporal LocalTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的时间。
      Temporal Month.adjustInto​(Temporal temporal)
      将指定的时间对象调整为具有这个月的年份。
      Temporal MonthDay.adjustInto​(Temporal temporal)
      将指定的时间对象调整为具有这个月日。
      Temporal OffsetDateTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的偏移量，日期和时间。
      Temporal OffsetTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的偏移量和时间。
      Temporal Year.adjustInto​(Temporal temporal)
      调整指定的时间对象到今年。
      Temporal YearMonth.adjustInto​(Temporal temporal)
      将指定的时间对象调整为今年。
      Temporal ZoneOffset.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象的偏移量相同。
      static Duration Duration.between​(Temporal startInclusive, Temporal endExclusive)
      获取表示两个时间对象之间的持续时间的 Duration 。
      Temporal Duration.subtractFrom​(Temporal temporal)
      从指定的时间对象中减去此持续时间。
      Temporal Period.subtractFrom​(Temporal temporal)
      从指定的时间对象中减去这个时间段。
      long Instant.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定单位计算直到另一瞬间的时间量。
      long LocalDate.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。
      long LocalDateTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算到另一个日期时间的时间量。
      long LocalTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一次的时间量。
      long OffsetDateTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算到另一个日期时间的时间量。
      long OffsetTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一次的时间量。
      long Year.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定单位计算直到另一年的时间。
      long YearMonth.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定单位计算直到另一个一个月的时间量。
      long ZonedDateTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算到另一个日期时间的时间量。

    • Uses of Temporal in java.time.chrono

      Subinterfaces of Temporal in java.time.chrono
      Modifier and Type 接口 描述
      interface  ChronoLocalDate
      一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。
      interface  ChronoLocalDateTime<D extends ChronoLocalDate>
      在任意年代没有时区的日期时间，用于高级全球化用例。
      interface  ChronoZonedDateTime<D extends ChronoLocalDate>
      具有时间序列的日期时间，以任意时间顺序排列，用于高级全球化用例。
      Classes in java.time.chrono that implement Temporal
      Modifier and Type Class 描述
      class  HijrahDate
      日期在Hijrah日历系统。
      class  JapaneseDate
      在日本帝国日历系统的日期。
      class  MinguoDate
      在日语系统中的日期。
      class  ThaiBuddhistDate
      在泰国佛教日历系统的日期。
      Methods in java.time.chrono that return Temporal
      Modifier and Type 方法 描述
      Temporal ChronoPeriod.addTo​(Temporal temporal)
      将此时段添加到指定的时间对象。
      default Temporal ChronoLocalDate.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象的日期相同。
      default Temporal ChronoLocalDateTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的日期和时间。
      default Temporal Era.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的时代。
      Temporal ChronoPeriod.subtractFrom​(Temporal temporal)
      从指定的时间对象中减去这个时间段。
      Methods in java.time.chrono with parameters of type Temporal
      Modifier and Type 方法 描述
      Temporal ChronoPeriod.addTo​(Temporal temporal)
      将此时段添加到指定的时间对象。
      default Temporal ChronoLocalDate.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象的日期相同。
      default Temporal ChronoLocalDateTime.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的日期和时间。
      default Temporal Era.adjustInto​(Temporal temporal)
      调整指定的时间对象与此对象具有相同的时代。
      Temporal ChronoPeriod.subtractFrom​(Temporal temporal)
      从指定的时间对象中减去这个时间段。
      long ChronoLocalDate.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。

    • Uses of Temporal in java.time.temporal

      Methods in java.time.temporal with type parameters of type Temporal
      Modifier and Type 方法 描述
      <R extends Temporal>
      R             		ChronoUnit.addTo​(R temporal, long amount)
      <R extends Temporal>
      R             		TemporalUnit.addTo​(R temporal, long amount)
      返回添加指定句点的指定时间对象的副本。
      <R extends Temporal>
      R             		ChronoField.adjustInto​(R temporal, long newValue)
      <R extends Temporal>
      R             		TemporalField.adjustInto​(R temporal, long newValue)
      返回指定时间对象的副本，并设置该字段的值。
      Methods in java.time.temporal that return Temporal
      Modifier and Type 方法 描述
      Temporal TemporalAmount.addTo​(Temporal temporal)
      添加到指定的时间对象。
      Temporal TemporalAdjuster.adjustInto​(Temporal temporal)
      调整指定的时间对象。
      default Temporal Temporal.minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default Temporal Temporal.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      Temporal Temporal.plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      default Temporal Temporal.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      Temporal TemporalAmount.subtractFrom​(Temporal temporal)
      从指定的时间对象中减去此对象。
      default Temporal Temporal.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      Temporal Temporal.with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      Methods in java.time.temporal with parameters of type Temporal
      Modifier and Type | 方法 | 描述
      Temporal TemporalAmount.addTo​(Temporal temporal)
      添加到指定的时间对象。
      Temporal TemporalAdjuster.adjustInto​(Temporal temporal)
      调整指定的时间对象。
      long | ChronoUnit.between​(Temporal temporal1Inclusive, Temporal temporal2Exclusive)
      long TemporalUnit.between​(Temporal temporal1Inclusive, Temporal temporal2Exclusive)
      计算两个时间对象之间的时间量。
      boolean | ChronoUnit.isSupportedBy​(Temporal temporal)
      default boolean TemporalUnit.isSupportedBy​(Temporal temporal)
      检查本机是否受指定的时间对象的支持。
      Temporal TemporalAmount.subtractFrom​(Temporal temporal)
      从指定的时间对象中减去此对象。
      long Temporal.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个时间的时间量。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.temporal.TemporalAccessor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.temporal.TemporalAccessor

  • Packages that use TemporalAccessor
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of TemporalAccessor in java.time

      Classes in java.time that implement TemporalAccessor
      Modifier and Type Class 描述
      class  DayOfWeek
      星期几，如“星期二”。
      class  Instant
      在时间线上的瞬间点。
      class  LocalDate
      在ISO- 2007-12-03 ，如 2007-12-03 。
      class  LocalDateTime
      在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
      class  LocalTime
      在ISO- 10:15:30 ，如 10:15:30 。
      class  Month
      一个月，如“七月”。
      class  MonthDay
      ISO- --12-03 ，如 --12-03 。
      class  OffsetDateTime
      在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如 2007-12-03T10:15:30+01:00 。
      class  OffsetTime
      在ISO- 10:15:30+01:00 UTC /格林威治的时间，如 10:15:30+01:00 。
      class  Year
      ISO- 2007 ，如 2007 。
      class  YearMonth
      在ISO- 2007-12 ，如 2007-12 。
      class  ZonedDateTime
      ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。
      class  ZoneOffset
      与格林威治/ UTC的时区偏移，如 +02:00 。
      Methods in java.time with parameters of type TemporalAccessor
      Modifier and Type 方法 描述
      static DayOfWeek DayOfWeek.from​(TemporalAccessor temporal)
      从时间对象获取 DayOfWeek的实例。
      static Instant Instant.from​(TemporalAccessor temporal)
      从时间对象获取 Instant的实例。
      static LocalDate LocalDate.from​(TemporalAccessor temporal)
      从时间对象获取 LocalDate的实例。
      static LocalDateTime LocalDateTime.from​(TemporalAccessor temporal)
      从时间对象获取 LocalDateTime的实例。
      static LocalTime LocalTime.from​(TemporalAccessor temporal)
      从时间对象获取 LocalTime的实例。
      static Month Month.from​(TemporalAccessor temporal)
      从时间对象获取一个 Month的实例。
      static MonthDay MonthDay.from​(TemporalAccessor temporal)
      从时间对象获取 MonthDay的实例。
      static OffsetDateTime OffsetDateTime.from​(TemporalAccessor temporal)
      从时间对象获取一个 OffsetDateTime的实例。
      static OffsetTime OffsetTime.from​(TemporalAccessor temporal)
      从时间对象获取 OffsetTime的实例。
      static Year Year.from​(TemporalAccessor temporal)
      从时间对象获取 Year的实例。
      static YearMonth YearMonth.from​(TemporalAccessor temporal)
      从时间对象获取 YearMonth的实例。
      static ZonedDateTime ZonedDateTime.from​(TemporalAccessor temporal)
      从时间对象获取 ZonedDateTime的实例。
      static ZoneId ZoneId.from​(TemporalAccessor temporal)
      从时间对象获取 ZoneId的实例。
      static ZoneOffset ZoneOffset.from​(TemporalAccessor temporal)
      从时间对象获取 ZoneOffset的实例。

    • Uses of TemporalAccessor in java.time.chrono

      Subinterfaces of TemporalAccessor in java.time.chrono
      Modifier and Type 接口 描述
      interface  ChronoLocalDate
      一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。
      interface  ChronoLocalDateTime<D extends ChronoLocalDate>
      在任意年代没有时区的日期时间，用于高级全球化用例。
      interface  ChronoZonedDateTime<D extends ChronoLocalDate>
      具有时间序列的日期时间，以任意时间顺序排列，用于高级全球化用例。
      interface  Era
      时代的时代。
      Classes in java.time.chrono that implement TemporalAccessor
      Modifier and Type Class 描述
      class  HijrahDate
      日期在Hijrah日历系统。
      class  HijrahEra
      Hijrah日历系统中的一个时代。
      class  IsoEra
      ISO日历系统中的一个时代。
      class  JapaneseDate
      在日本帝国日历系统的日期。
      class  JapaneseEra
      日本帝国日历系统的一个时代。
      class  MinguoDate
      在日语系统中的日期。
      class  MinguoEra
      国际日历系统中的一个时代。
      class  ThaiBuddhistDate
      在泰国佛教日历系统的日期。
      class  ThaiBuddhistEra
      泰国佛教日历系统的时代。
      Methods in java.time.chrono with parameters of type TemporalAccessor
      Modifier and Type | 方法 | 描述
      ChronoLocalDate Chronology.date​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期。
      HijrahDate | HijrahChronology.date​(TemporalAccessor temporal)
      LocalDate IsoChronology.date​(TemporalAccessor temporal)
      从另一个日期时间对象获取ISO本地日期。
      JapaneseDate | JapaneseChronology.date​(TemporalAccessor temporal)
      MinguoDate | MinguoChronology.date​(TemporalAccessor temporal)
      ThaiBuddhistDate | ThaiBuddhistChronology.date​(TemporalAccessor temporal)
      static ChronoLocalDate ChronoLocalDate.from​(TemporalAccessor temporal)
      从时间对象获取 ChronoLocalDate的实例。
      static ChronoLocalDateTime<?> ChronoLocalDateTime.from​(TemporalAccessor temporal)
      从时间对象获取 ChronoLocalDateTime的实例。
      static Chronology Chronology.from​(TemporalAccessor temporal)
      从时间对象获取 Chronology的实例。
      static ChronoZonedDateTime<?> ChronoZonedDateTime.from​(TemporalAccessor temporal)
      从时间对象获取 ChronoZonedDateTime的实例。
      static HijrahDate HijrahDate.from​(TemporalAccessor temporal)
      从时间物体获得伊斯兰教Umm Al-Qura日历的 HijrahDate 。
      static JapaneseDate JapaneseDate.from​(TemporalAccessor temporal)
      从时间对象获取 JapaneseDate 。
      static MinguoDate MinguoDate.from​(TemporalAccessor temporal)
      从时间对象获取 MinguoDate 。
      static ThaiBuddhistDate ThaiBuddhistDate.from​(TemporalAccessor temporal)
      从时间对象获取 ThaiBuddhistDate 。
      default ChronoLocalDateTime<? extends ChronoLocalDate> Chronology.localDateTime​(TemporalAccessor temporal)
      从另一个时间对象获取本年龄的本地日期时间。
      ChronoLocalDateTime<HijrahDate> | HijrahChronology.localDateTime​(TemporalAccessor temporal)
      LocalDateTime IsoChronology.localDateTime​(TemporalAccessor temporal)
      从另一个日期时间对象获取ISO本地日期时间。
      ChronoLocalDateTime<JapaneseDate> | JapaneseChronology.localDateTime​(TemporalAccessor temporal)
      ChronoLocalDateTime<MinguoDate> | MinguoChronology.localDateTime​(TemporalAccessor temporal)
      ChronoLocalDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.localDateTime​(TemporalAccessor temporal)
      default ChronoZonedDateTime<? extends ChronoLocalDate> Chronology.zonedDateTime​(TemporalAccessor temporal)
      从另一个时间对象获得这个年龄的 ChronoZonedDateTime 。
      ChronoZonedDateTime<HijrahDate> | HijrahChronology.zonedDateTime​(TemporalAccessor temporal)
      ZonedDateTime IsoChronology.zonedDateTime​(TemporalAccessor temporal)
      从另一个日期时间对象获取ISO分区的日期时间。
      ChronoZonedDateTime<JapaneseDate> | JapaneseChronology.zonedDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<MinguoDate> | MinguoChronology.zonedDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.zonedDateTime​(TemporalAccessor temporal)

    • Uses of TemporalAccessor in java.time.format

      Methods in java.time.format that return TemporalAccessor
      Modifier and Type 方法 描述
      TemporalAccessor DateTimeFormatter.parse​(CharSequence text)
      完全解析产生时间对象的文本。
      TemporalAccessor DateTimeFormatter.parse​(CharSequence text, ParsePosition position)
      使用此格式化器解析文本，提供对文本位置的控制。
      TemporalAccessor DateTimeFormatter.parseBest​(CharSequence text, TemporalQuery<?>... queries)
      完全解析产生指定类型之一的对象的文本。
      TemporalAccessor DateTimeFormatter.parseUnresolved​(CharSequence text, ParsePosition position)
      使用此格式化程序解析文本，而无需解析结果，用于高级用例。
      Methods in java.time.format with parameters of type TemporalAccessor
      Modifier and Type 方法 描述
      String DateTimeFormatter.format​(TemporalAccessor temporal)
      使用此格式化程序格式化日期时间对象。
      void DateTimeFormatter.formatTo​(TemporalAccessor temporal, Appendable appendable)
      使用此格式化程序将日期时间对象格式化为 Appendable 。

    • Uses of TemporalAccessor in java.time.temporal

      Subinterfaces of TemporalAccessor in java.time.temporal
      Modifier and Type 接口 描述
      interface  Temporal
      定义对时间对象的读写访问的框架级接口，例如日期，时间，偏移或这些的一些组合。
      Methods in java.time.temporal that return TemporalAccessor
      Modifier and Type 方法 描述
      default TemporalAccessor TemporalField.resolve​(Map<TemporalField,Long> fieldValues, TemporalAccessor partialTemporal, ResolverStyle resolverStyle)
      解决此字段以提供更简单的替代或日期。
      Methods in java.time.temporal with parameters of type TemporalAccessor
      Modifier and Type | 方法 | 描述
      long | ChronoField.getFrom​(TemporalAccessor temporal)
      long TemporalField.getFrom​(TemporalAccessor temporal)
      从指定的时间对象获取此字段的值。
      boolean | ChronoField.isSupportedBy​(TemporalAccessor temporal)
      boolean TemporalField.isSupportedBy​(TemporalAccessor temporal)
      检查时间对象是否支持该字段。
      R TemporalQuery.queryFrom​(TemporalAccessor temporal)
      查询指定的时间对象。
      ValueRange | ChronoField.rangeRefinedBy​(TemporalAccessor temporal)
      ValueRange TemporalField.rangeRefinedBy​(TemporalAccessor temporal)
      使用时间对象获取此字段的有效值的范围以优化结果。
      default TemporalAccessor TemporalField.resolve​(Map<TemporalField,Long> fieldValues, TemporalAccessor partialTemporal, ResolverStyle resolverStyle)
      解决此字段以提供更简单的替代或日期。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.temporal.TemporalAdjuster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.temporal.TemporalAdjuster

  • Packages that use TemporalAdjuster
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of TemporalAdjuster in java.time

      Classes in java.time that implement TemporalAdjuster
      Modifier and Type Class 描述
      class  DayOfWeek
      星期几，如“星期二”。
      class  Instant
      在时间线上的瞬间点。
      class  LocalDate
      在ISO- 2007-12-03 ，如 2007-12-03 。
      class  LocalDateTime
      在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
      class  LocalTime
      在ISO- 10:15:30 ，如 10:15:30 。
      class  Month
      一个月，如“七月”。
      class  MonthDay
      ISO- --12-03 ，如 --12-03 。
      class  OffsetDateTime
      在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如 2007-12-03T10:15:30+01:00 。
      class  OffsetTime
      在ISO- 10:15:30+01:00 UTC /格林威治的时间，如 10:15:30+01:00 。
      class  Year
      ISO- 2007 ，如 2007 。
      class  YearMonth
      ISO- 2007-12 ，如 2007-12 。
      class  ZoneOffset
      距离格林威治/ UTC的时区偏移，如 +02:00 。
      Methods in java.time with parameters of type TemporalAdjuster
      Modifier and Type 方法 描述
      Instant Instant.with​(TemporalAdjuster adjuster)
      返回此瞬间的调整副本。
      LocalDate LocalDate.with​(TemporalAdjuster adjuster)
      返回此日期的调整副本。
      LocalDateTime LocalDateTime.with​(TemporalAdjuster adjuster)
      返回此日期时间的调整副本。
      LocalTime LocalTime.with​(TemporalAdjuster adjuster)
      返回此次调整后的副本。
      OffsetDateTime OffsetDateTime.with​(TemporalAdjuster adjuster)
      返回此日期时间的调整副本。
      OffsetTime OffsetTime.with​(TemporalAdjuster adjuster)
      返回此次调整后的副本。
      Year Year.with​(TemporalAdjuster adjuster)
      返回今年的调整副本。
      YearMonth YearMonth.with​(TemporalAdjuster adjuster)
      返回今年的调整副本。
      ZonedDateTime ZonedDateTime.with​(TemporalAdjuster adjuster)
      返回此日期时间的调整副本。

    • Uses of TemporalAdjuster in java.time.chrono

      Subinterfaces of TemporalAdjuster in java.time.chrono
      Modifier and Type 接口 描述
      interface  ChronoLocalDate
      一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。
      interface  ChronoLocalDateTime<D extends ChronoLocalDate>
      在任意年代没有时区的日期时间，用于高级全球化用例。
      interface  Era
      时代的时代。
      Classes in java.time.chrono that implement TemporalAdjuster
      Modifier and Type Class 描述
      class  HijrahDate
      日期在Hijrah日历系统。
      class  HijrahEra
      Hijrah日历系统中的一个时代。
      class  IsoEra
      ISO日历系统中的一个时代。
      class  JapaneseDate
      在日本帝国日历系统的日期。
      class  JapaneseEra
      日本帝国日历系统的一个时代。
      class  MinguoDate
      在日语系统中的日期。
      class  MinguoEra
      国际日历系统中的一个时代。
      class  ThaiBuddhistDate
      在泰国佛教日历系统的日期。
      class  ThaiBuddhistEra
      泰国佛教日历系统的时代。
      Methods in java.time.chrono with parameters of type TemporalAdjuster
      Modifier and Type 方法 描述
      default ChronoLocalDate ChronoLocalDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      default ChronoLocalDateTime<D> ChronoLocalDateTime.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      default ChronoZonedDateTime<D> ChronoZonedDateTime.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      HijrahDate HijrahDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      JapaneseDate JapaneseDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      MinguoDate MinguoDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
      ThaiBuddhistDate ThaiBuddhistDate.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。

    • Uses of TemporalAdjuster in java.time.temporal

      Methods in java.time.temporal that return TemporalAdjuster
      Modifier and Type 方法 描述
      static TemporalAdjuster TemporalAdjusters.dayOfWeekInMonth​(int ordinal, DayOfWeek dayOfWeek)
      返回月份调整器中的星期几，该日期将根据月份返回具有序数星期的新日期。
      static TemporalAdjuster TemporalAdjusters.firstDayOfMonth​()
      返回“第一个月的”调整器，它返回设置为当月的第一天的新日期。
      static TemporalAdjuster TemporalAdjusters.firstDayOfNextMonth​()
      返回“下一个月的第一天”调整器，它将新的日期设置为下个月的第一天。
      static TemporalAdjuster TemporalAdjusters.firstDayOfNextYear​()
      返回“明年的第一天”调整器，返回设置为下一年的第一天的新日期。
      static TemporalAdjuster TemporalAdjusters.firstDayOfYear​()
      返回“一年的第一天”调整器，其返回设置为当前第一天的新日期。
      static TemporalAdjuster TemporalAdjusters.firstInMonth​(DayOfWeek dayOfWeek)
      返回月初调整器，它在同一个月内返回与第一个匹配的星期几的新日期。
      static TemporalAdjuster TemporalAdjusters.lastDayOfMonth​()
      返回“最后一个月的”调整器，该日期设置为当前月份的最后一天。
      static TemporalAdjuster TemporalAdjusters.lastDayOfYear​()
      返回“最后一天的”调整器，其返回设置为当前年份的最后一天的新日期。
      static TemporalAdjuster TemporalAdjusters.lastInMonth​(DayOfWeek dayOfWeek)
      返回最近一个月的调整器，它返回与最后一个匹配的星期几相同月份的新日期。
      static TemporalAdjuster TemporalAdjusters.next​(DayOfWeek dayOfWeek)
      返回下一个星期的调整器，该调整器将日期调整为在调整日期之后的指定日期的第一次出现。
      static TemporalAdjuster TemporalAdjusters.nextOrSame​(DayOfWeek dayOfWeek)
      返回下一个或相同的星期几调整器，该调整器将日期调整为在调整日期之后指定的星期几的第一次出现，除非它已在当天在同一对象被返回。
      static TemporalAdjuster TemporalAdjusters.ofDateAdjuster​(UnaryOperator<LocalDate> dateBasedAdjuster)
      获取一个包含日期调整器的 TemporalAdjuster 。
      static TemporalAdjuster TemporalAdjusters.previous​(DayOfWeek dayOfWeek)
      返回上一个星期的调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现。
      static TemporalAdjuster TemporalAdjusters.previousOrSame​(DayOfWeek dayOfWeek)
      返回之前或相同的日期调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现，除非已在当天返回相同的对象。
      Methods in java.time.temporal with parameters of type TemporalAdjuster
      Modifier and Type 方法 描述
      default Temporal Temporal.with​(TemporalAdjuster adjuster)
      通过进行调整，返回与该对象相同类型的调整对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.temporal.TemporalAmount (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.temporal.TemporalAmount

  • Packages that use TemporalAmount
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of TemporalAmount in java.time

      Classes in java.time that implement TemporalAmount
      Modifier and Type Class 描述
      class  Duration
      基于时间的时间量，如'34.5秒'。
      class  Period
      ISO-8601日历系统中的日期时间，例如“2年3个月4天”。
      Methods in java.time with parameters of type TemporalAmount
      Modifier and Type 方法 描述
      static Duration Duration.from​(TemporalAmount amount)
      从时间量获取 Duration的实例。
      static Period Period.from​(TemporalAmount amount)
      从时间量获取 Period的实例。
      Instant Instant.minus​(TemporalAmount amountToSubtract)
      返回此时刻的副本，减去指定的金额。
      LocalDate LocalDate.minus​(TemporalAmount amountToSubtract)
      返回此日期的副本，减去指定的金额。
      LocalDateTime LocalDateTime.minus​(TemporalAmount amountToSubtract)
      返回此日期时间的副本，并减去指定的金额。
      LocalTime LocalTime.minus​(TemporalAmount amountToSubtract)
      返回此次的副本，减去指定的金额。
      OffsetDateTime OffsetDateTime.minus​(TemporalAmount amountToSubtract)
      返回此日期时间的副本，并减去指定的金额。
      OffsetTime OffsetTime.minus​(TemporalAmount amountToSubtract)
      返回此次的副本，减去指定的金额。
      Period Period.minus​(TemporalAmount amountToSubtract)
      返回此期间的副本，并减去指定的时间段。
      Year Year.minus​(TemporalAmount amountToSubtract)
      返回今年的副本，减去指定的金额。
      YearMonth YearMonth.minus​(TemporalAmount amountToSubtract)
      返回减去指定数量的今年的副本。
      ZonedDateTime ZonedDateTime.minus​(TemporalAmount amountToSubtract)
      返回此日期时间的副本，并减去指定的金额。
      Instant Instant.plus​(TemporalAmount amountToAdd)
      返回添加指定数量的此瞬间的副本。
      LocalDate LocalDate.plus​(TemporalAmount amountToAdd)
      返回此日期的副本，并添加指定的金额。
      LocalDateTime LocalDateTime.plus​(TemporalAmount amountToAdd)
      返回此日期时间的副本，并添加指定的数量。
      LocalTime LocalTime.plus​(TemporalAmount amountToAdd)
      返回此时添加了指定数量的副本。
      OffsetDateTime OffsetDateTime.plus​(TemporalAmount amountToAdd)
      返回此日期时间的副本，并添加指定的数量。
      OffsetTime OffsetTime.plus​(TemporalAmount amountToAdd)
      返回此时添加了指定数量的副本。
      Period Period.plus​(TemporalAmount amountToAdd)
      返回指定期间添加的此期间的副本。
      Year Year.plus​(TemporalAmount amountToAdd)
      返回今年的副本，并附加指定的金额。
      YearMonth YearMonth.plus​(TemporalAmount amountToAdd)
      返回此年份的副本，并添加指定的金额。
      ZonedDateTime ZonedDateTime.plus​(TemporalAmount amountToAdd)
      返回此日期时间的副本，并添加指定的数量。

    • Uses of TemporalAmount in java.time.chrono

      Subinterfaces of TemporalAmount in java.time.chrono
      Modifier and Type 接口 描述
      interface  ChronoPeriod
      基于日期的时间，例如任意年代的“3年，4个月和5天”，旨在用于高级全球化用例。
      Methods in java.time.chrono with parameters of type TemporalAmount
      Modifier and Type 方法 描述
      default ChronoLocalDate ChronoLocalDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      default ChronoLocalDateTime<D> ChronoLocalDateTime.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      ChronoPeriod ChronoPeriod.minus​(TemporalAmount amountToSubtract)
      返回此期间的副本，并减去指定的时间段。
      default ChronoZonedDateTime<D> ChronoZonedDateTime.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      HijrahDate HijrahDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      JapaneseDate JapaneseDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      MinguoDate MinguoDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      ThaiBuddhistDate ThaiBuddhistDate.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      default ChronoLocalDate ChronoLocalDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      default ChronoLocalDateTime<D> ChronoLocalDateTime.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      ChronoPeriod ChronoPeriod.plus​(TemporalAmount amountToAdd)
      返回指定期间添加的此期间的副本。
      default ChronoZonedDateTime<D> ChronoZonedDateTime.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      HijrahDate HijrahDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      JapaneseDate JapaneseDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      MinguoDate MinguoDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
      ThaiBuddhistDate ThaiBuddhistDate.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。

    • Uses of TemporalAmount in java.time.temporal

      Methods in java.time.temporal with parameters of type TemporalAmount
      Modifier and Type 方法 描述
      default Temporal Temporal.minus​(TemporalAmount amount)
      返回与该对象相同类型的对象，并减去一个数量。
      default Temporal Temporal.plus​(TemporalAmount amount)
      返回与此对象相同类型的对象，并添加一个金额。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.temporal.TemporalField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.temporal.TemporalField

  • Packages that use TemporalField
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of TemporalField in java.time

      Methods in java.time with parameters of type TemporalField
      Modifier and Type 方法 描述
      int DayOfWeek.get​(TemporalField field)
      从这个星期几获取指定字段的值作为 int 。
      int Instant.get​(TemporalField field)
      从该时刻获取指定字段的值作为 int 。
      int LocalDate.get​(TemporalField field)
      从此日期获取指定字段的值作为 int 。
      int LocalDateTime.get​(TemporalField field)
      从此日期时间获取指定字段的值作为 int 。
      int LocalTime.get​(TemporalField field)
      从这个时间获取指定字段的值作为 int 。
      int Month.get​(TemporalField field)
      从这个月份获取指定字段的值作为 int 。
      int MonthDay.get​(TemporalField field)
      从这个月份获取指定字段的值作为 int 。
      int OffsetDateTime.get​(TemporalField field)
      从此日期时间获取指定字段的值作为 int 。
      int OffsetTime.get​(TemporalField field)
      从此时间获取指定字段的值为 int 。
      int Year.get​(TemporalField field)
      从今年获取指定字段的值作为 int 。
      int YearMonth.get​(TemporalField field)
      从本年度获取指定字段的值为 int 。
      int ZonedDateTime.get​(TemporalField field)
      从此日期时间获取指定字段的值为 int 。
      int ZoneOffset.get​(TemporalField field)
      从此偏移量获取指定字段的值为 int 。
      long DayOfWeek.getLong​(TemporalField field)
      从这个星期几获取指定字段的值作为 long 。
      long Instant.getLong​(TemporalField field)
      从该时刻获取指定字段的值作为 long 。
      long LocalDate.getLong​(TemporalField field)
      从此日期获取指定字段的值作为 long 。
      long LocalDateTime.getLong​(TemporalField field)
      从此日期时间获取指定字段的值作为 long 。
      long LocalTime.getLong​(TemporalField field)
      从此时间获取指定字段的值为 long 。
      long Month.getLong​(TemporalField field)
      从这个月份获取指定字段的值作为 long 。
      long MonthDay.getLong​(TemporalField field)
      从这个月日获取指定字段的值作为 long 。
      long OffsetDateTime.getLong​(TemporalField field)
      从此日期时间获取指定字段的值作为 long 。
      long OffsetTime.getLong​(TemporalField field)
      从此时间获取指定字段的值为 long 。
      long Year.getLong​(TemporalField field)
      从今年获取指定字段的值作为 long 。
      long YearMonth.getLong​(TemporalField field)
      从这个年月获得指定字段的值作为 long 。
      long ZonedDateTime.getLong​(TemporalField field)
      从此日期时间获取指定字段的值作为 long 。
      long ZoneOffset.getLong​(TemporalField field)
      从该偏移量获取指定字段的值作为 long 。
      boolean DayOfWeek.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean Instant.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean LocalDate.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean LocalDateTime.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean LocalTime.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean Month.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean MonthDay.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean OffsetDateTime.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean OffsetTime.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean Year.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean YearMonth.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean ZonedDateTime.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean ZoneOffset.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      ValueRange DayOfWeek.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange Instant.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange LocalDate.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange LocalDateTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange LocalTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange Month.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange MonthDay.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange OffsetDateTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange OffsetTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange Year.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange YearMonth.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange ZonedDateTime.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange ZoneOffset.range​(TemporalField field)
      获取指定字段的有效值的范围。
      Instant Instant.with​(TemporalField field, long newValue)
      将指定的字段设置为新值返回此瞬间的副本。
      LocalDate LocalDate.with​(TemporalField field, long newValue)
      返回此日期的副本，并将指定的字段设置为新值。
      LocalDateTime LocalDateTime.with​(TemporalField field, long newValue)
      返回此日期时间的副本，并将指定的字段设置为新值。
      LocalTime LocalTime.with​(TemporalField field, long newValue)
      返回此时间的副本，并将指定的字段设置为新值。
      OffsetDateTime OffsetDateTime.with​(TemporalField field, long newValue)
      返回此日期时间的副本，并将指定的字段设置为新值。
      OffsetTime OffsetTime.with​(TemporalField field, long newValue)
      返回此时间的副本，并将指定的字段设置为新值。
      Year Year.with​(TemporalField field, long newValue)
      返回今年的副本，并将指定的字段设置为新值。
      YearMonth YearMonth.with​(TemporalField field, long newValue)
      返回此年月份的副本，并将指定的字段设置为新值。
      ZonedDateTime ZonedDateTime.with​(TemporalField field, long newValue)
      返回此日期时间的副本，并将指定的字段设置为新值。

    • Uses of TemporalField in java.time.chrono

      Methods in java.time.chrono with parameters of type TemporalField
      Modifier and Type | 方法 | 描述
      default int | ChronoZonedDateTime.get​(TemporalField field)
      default int Era.get​(TemporalField field)
      从该时代获取指定字段的值作为 int 。
      default long | ChronoZonedDateTime.getLong​(TemporalField field)
      default long Era.getLong​(TemporalField field)
      从这个时代获取指定字段的值作为 long 。
      long | HijrahDate.getLong​(TemporalField field)
      long | JapaneseDate.getLong​(TemporalField field)
      long | MinguoDate.getLong​(TemporalField field)
      long | ThaiBuddhistDate.getLong​(TemporalField field)
      default boolean ChronoLocalDate.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean ChronoLocalDateTime.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean ChronoZonedDateTime.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      default boolean Era.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      boolean JapaneseDate.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      default ValueRange | ChronoZonedDateTime.range​(TemporalField field)
      default ValueRange Era.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange | HijrahDate.range​(TemporalField field)
      ValueRange HijrahEra.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange | JapaneseDate.range​(TemporalField field)
      ValueRange JapaneseEra.range​(TemporalField field)
      获取指定字段的有效值的范围。
      ValueRange | MinguoDate.range​(TemporalField field)
      ValueRange | ThaiBuddhistDate.range​(TemporalField field)
      default ChronoLocalDate ChronoLocalDate.with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      ChronoLocalDateTime<D> ChronoLocalDateTime.with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      ChronoZonedDateTime<D> ChronoZonedDateTime.with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      HijrahDate | HijrahDate.with​(TemporalField field, long newValue)
      JapaneseDate | JapaneseDate.with​(TemporalField field, long newValue)
      MinguoDate | MinguoDate.with​(TemporalField field, long newValue)
      ThaiBuddhistDate | ThaiBuddhistDate.with​(TemporalField field, long newValue)
      Method parameters in java.time.chrono with type arguments of type TemporalField
      Modifier and Type | 方法 | 描述
      ChronoLocalDate AbstractChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField值到解析中的日期。
      ChronoLocalDate Chronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField的日期。
      HijrahDate | HijrahChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      LocalDate IsoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField值。
      JapaneseDate | JapaneseChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      MinguoDate | MinguoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      ThaiBuddhistDate | ThaiBuddhistChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

    • Uses of TemporalField in java.time.format

      Methods in java.time.format that return types with arguments of type TemporalField
      Modifier and Type 方法 描述
      Set<TemporalField> DateTimeFormatter.getResolverFields​()
      获取在解析期间使用的解析器字段。
      Methods in java.time.format with parameters of type TemporalField
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendFraction​(TemporalField field, int minWidth, int maxWidth, boolean decimalPoint)
      将日期时间字段的小数值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendText​(TemporalField field)
      使用全文样式将日期时间字段的文本附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendText​(TemporalField field, TextStyle textStyle)
      将日期时间字段的文本附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendText​(TemporalField field, Map<Long,String> textLookup)
      使用指定的地图将日期时间字段的文本附加到格式化程序以提供文本。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValue​(TemporalField field)
      使用正常输出样式将日期时间字段的值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValue​(TemporalField field, int width)
      使用固定宽度零填充方法将日期时间字段的值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValue​(TemporalField field, int minWidth, int maxWidth, SignStyle signStyle)
      将日期时间字段的值追加到格式化程序，以提供对格式化的完全控制。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValueReduced​(TemporalField field, int width, int maxWidth, int baseValue)
      将日期时间字段的减小值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendValueReduced​(TemporalField field, int width, int maxWidth, ChronoLocalDate baseDate)
      将日期时间字段的减小值附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.parseDefaulting​(TemporalField field, long value)
      将字段的默认值追加到格式化程序以用于解析。
      DateTimeFormatter DateTimeFormatter.withResolverFields​(TemporalField... resolverFields)
      使用一组新的解析器字段返回此格式化程序的副本。
      Method parameters in java.time.format with type arguments of type TemporalField
      Modifier and Type 方法 描述
      DateTimeFormatter DateTimeFormatter.withResolverFields​(Set<TemporalField> resolverFields)
      使用一组新的解析器字段返回此格式化程序的副本。

    • Uses of TemporalField in java.time.temporal

      Classes in java.time.temporal that implement TemporalField
      Modifier and Type Class 描述
      class  ChronoField
      一套标准的字段。
      Fields in java.time.temporal declared as TemporalField
      Modifier and Type Field 描述
      static TemporalField IsoFields.DAY_OF_QUARTER
      代表季度的领域。
      static TemporalField JulianFields.JULIAN_DAY
      朱利安日字段。
      static TemporalField JulianFields.MODIFIED_JULIAN_DAY
      修改儒略日字段。
      static TemporalField IsoFields.QUARTER_OF_YEAR
      代表季度的领域。
      static TemporalField JulianFields.RATA_DIE
      拉塔死场。
      static TemporalField IsoFields.WEEK_BASED_YEAR
      代表周年的领域。
      static TemporalField IsoFields.WEEK_OF_WEEK_BASED_YEAR
      代表周周的一年的领域。
      Methods in java.time.temporal that return TemporalField
      Modifier and Type 方法 描述
      TemporalField WeekFields.dayOfWeek​()
      根据这个 WeekFields返回一个字段来访问星期 WeekFields 。
      TemporalField WeekFields.weekBasedYear​()
      根据这个 WeekFields返回一个字段以访问一周的年份。
      TemporalField WeekFields.weekOfMonth​()
      根据这个 WeekFields返回一个字段来访问一个月。
      TemporalField WeekFields.weekOfWeekBasedYear​()
      根据这个 WeekFields返回一个字段以访问一周的周。
      TemporalField WeekFields.weekOfYear​()
      根据这个 WeekFields返回一个字段以访问一周中的一周。
      Methods in java.time.temporal with parameters of type TemporalField
      Modifier and Type 方法 描述
      int ValueRange.checkValidIntValue​(long value, TemporalField field)
      检查指定的值是否有效并适合 int 。
      long ValueRange.checkValidValue​(long value, TemporalField field)
      检查指定的值是否有效。
      default int TemporalAccessor.get​(TemporalField field)
      获取指定字段的 int 。
      long TemporalAccessor.getLong​(TemporalField field)
      获取指定字段的 long 。
      boolean TemporalAccessor.isSupported​(TemporalField field)
      检查指定的字段是否受支持。
      default ValueRange TemporalAccessor.range​(TemporalField field)
      获取指定字段的有效值的范围。
      Temporal Temporal.with​(TemporalField field, long newValue)
      返回与该对象具有相同类型的对象，并更改指定的字段。
      Method parameters in java.time.temporal with type arguments of type TemporalField
      Modifier and Type 方法 描述
      default TemporalAccessor TemporalField.resolve​(Map<TemporalField,Long> fieldValues, TemporalAccessor partialTemporal, ResolverStyle resolverStyle)
      Resolves this field to provide a simpler alternative or a date.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.temporal.TemporalQuery (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.temporal.TemporalQuery

  • Packages that use TemporalQuery
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of TemporalQuery in java.time

      Methods in java.time with parameters of type TemporalQuery
      Modifier and Type 方法 描述
      <R> R DayOfWeek.query​(TemporalQuery<R> query)
      使用指定的查询查询此星期几。
      <R> R Instant.query​(TemporalQuery<R> query)
      使用指定的查询查询此即时。
      <R> R LocalDate.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期。
      <R> R LocalDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      <R> R LocalTime.query​(TemporalQuery<R> query)
      此时使用指定的查询进行查询。
      <R> R Month.query​(TemporalQuery<R> query)
      使用指定的查询查询此月份的一年。
      <R> R MonthDay.query​(TemporalQuery<R> query)
      使用指定的查询查询此月日。
      <R> R OffsetDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      <R> R OffsetTime.query​(TemporalQuery<R> query)
      此时使用指定的查询进行查询。
      <R> R Year.query​(TemporalQuery<R> query)
      今年查询使用指定的查询。
      <R> R YearMonth.query​(TemporalQuery<R> query)
      使用指定的查询查询今年。
      <R> R ZonedDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      <R> R ZoneOffset.query​(TemporalQuery<R> query)
      使用指定的查询查询此偏移量。

    • Uses of TemporalQuery in java.time.chrono

      Methods in java.time.chrono with parameters of type TemporalQuery
      Modifier and Type 方法 描述
      default <R> R ChronoLocalDate.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期。
      default <R> R ChronoLocalDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      default <R> R ChronoZonedDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      default <R> R Era.query​(TemporalQuery<R> query)
      使用指定的查询查询此时代。

    • Uses of TemporalQuery in java.time.format

      Methods in java.time.format that return TemporalQuery
      Modifier and Type 方法 描述
      static TemporalQuery<Period> DateTimeFormatter.parsedExcessDays​()
      一个查询，可以访问已解析的多余天数。
      static TemporalQuery<Boolean> DateTimeFormatter.parsedLeapSecond​()
      提供访问是否解析了跨越秒的查询。
      Methods in java.time.format with parameters of type TemporalQuery
      Modifier and Type 方法 描述
      <T> T DateTimeFormatter.parse​(CharSequence text, TemporalQuery<T> query)
      完全解析产生指定类型对象的文本。
      TemporalAccessor DateTimeFormatter.parseBest​(CharSequence text, TemporalQuery<?>... queries)
      完全解析产生指定类型之一的对象的文本。
      Format DateTimeFormatter.toFormat​(TemporalQuery<?> parseQuery)
      将此格式化程序作为 java.text.Format实例返回，使用指定的查询进行解析。

    • Uses of TemporalQuery in java.time.temporal

      Methods in java.time.temporal that return TemporalQuery
      Modifier and Type 方法 描述
      static TemporalQuery<Chronology> TemporalQueries.chronology​()
      查询 Chronology 。
      static TemporalQuery<LocalDate> TemporalQueries.localDate​()
      对于 LocalDate的查询，如果找不到则返回null。
      static TemporalQuery<LocalTime> TemporalQueries.localTime​()
      对于 LocalTime的查询，如果找不到， LocalTime返回null。
      static TemporalQuery<ZoneOffset> TemporalQueries.offset​()
      对于 ZoneOffset的查询，如果找不到， ZoneOffset返回null。
      static TemporalQuery<TemporalUnit> TemporalQueries.precision​()
      对最小支持单位的查询。
      static TemporalQuery<ZoneId> TemporalQueries.zone​()
      一个宽松的查询 ZoneId ，回落到 ZoneOffset 。
      static TemporalQuery<ZoneId> TemporalQueries.zoneId​()
      严格查询 ZoneId 。
      Methods in java.time.temporal with parameters of type TemporalQuery
      Modifier and Type 方法 描述
      default <R> R TemporalAccessor.query​(TemporalQuery<R> query)
      查询此日期时间。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.time.temporal.TemporalUnit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.time.temporal.TemporalUnit

  • Packages that use TemporalUnit
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。

    • Uses of TemporalUnit in java.time

      Methods in java.time that return types with arguments of type TemporalUnit
      Modifier and Type 方法 描述
      List<TemporalUnit> Duration.getUnits​()
      获取此持续时间支持的单位集。
      List<TemporalUnit> Period.getUnits​()
      获取此期间支持的单位集。
      Methods in java.time with parameters of type TemporalUnit
      Modifier and Type 方法 描述
      long Duration.get​(TemporalUnit unit)
      获取所请求单元的值。
      long Period.get​(TemporalUnit unit)
      获取所请求单元的值。
      boolean Instant.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean LocalDate.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean LocalDateTime.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean LocalTime.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean OffsetDateTime.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean OffsetTime.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean Year.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean YearMonth.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      boolean ZonedDateTime.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      Duration Duration.minus​(long amountToSubtract, TemporalUnit unit)
      返回指定持续时间的副本减去。
      Instant Instant.minus​(long amountToSubtract, TemporalUnit unit)
      返回此时刻的副本，减去指定的金额。
      LocalDate LocalDate.minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期的副本，减去指定的金额。
      LocalDateTime LocalDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期时间的副本，并减去指定的金额。
      LocalTime LocalTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此次的副本，减去指定的金额。
      OffsetDateTime OffsetDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期时间的副本，并减去指定的金额。
      OffsetTime OffsetTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此次的副本，减去指定的金额。
      Year Year.minus​(long amountToSubtract, TemporalUnit unit)
      返回今年的副本，减去指定的金额。
      YearMonth YearMonth.minus​(long amountToSubtract, TemporalUnit unit)
      返回减去指定数量的今年的副本。
      ZonedDateTime ZonedDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回此日期时间的副本，并减去指定的金额。
      static Duration Duration.of​(long amount, TemporalUnit unit)
      获得 Duration表示指定单位的金额。
      Duration Duration.plus​(long amountToAdd, TemporalUnit unit)
      返回此持续时间的副本，并添加指定的持续时间。
      Instant Instant.plus​(long amountToAdd, TemporalUnit unit)
      返回添加指定数量的此瞬间的副本。
      LocalDate LocalDate.plus​(long amountToAdd, TemporalUnit unit)
      返回此日期的副本，并添加指定的金额。
      LocalDateTime LocalDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此日期时间的副本，并添加指定的数量。
      LocalTime LocalTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此时添加了指定数量的副本。
      OffsetDateTime OffsetDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此日期时间的副本，并添加指定的数量。
      OffsetTime OffsetTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此时添加了指定数量的副本。
      Year Year.plus​(long amountToAdd, TemporalUnit unit)
      返回今年的副本，并附加指定的金额。
      YearMonth YearMonth.plus​(long amountToAdd, TemporalUnit unit)
      返回此年份的副本，并添加指定的金额。
      ZonedDateTime ZonedDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回此日期时间的副本，并添加指定的数量。
      Duration Duration.truncatedTo​(TemporalUnit unit)
      将此 Duration的副本返回给指定的单位。
      Instant Instant.truncatedTo​(TemporalUnit unit)
      将此 Instant的副本截回到指定的单位。
      LocalDateTime LocalDateTime.truncatedTo​(TemporalUnit unit)
      返回此 LocalDateTime的副本，截断时间。
      LocalTime LocalTime.truncatedTo​(TemporalUnit unit)
      返回此 LocalTime的副本，截断时间。
      OffsetDateTime OffsetDateTime.truncatedTo​(TemporalUnit unit)
      返回此 OffsetDateTime的副本，截断时间。
      OffsetTime OffsetTime.truncatedTo​(TemporalUnit unit)
      返回此 OffsetTime的副本，截断时间。
      ZonedDateTime ZonedDateTime.truncatedTo​(TemporalUnit unit)
      返回此 ZonedDateTime的副本，截断时间。
      long Instant.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定单位计算直到另一瞬间的时间量。
      long LocalDate.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。
      long LocalDateTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算到另一个日期时间的时间量。
      long LocalTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一次的时间量。
      long OffsetDateTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算到另一个日期时间的时间量。
      long OffsetTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一次的时间量。
      long Year.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定单位计算直到另一年的时间。
      long YearMonth.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定单位计算直到另一个一个月的时间量。
      long ZonedDateTime.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算到另一个日期时间的时间量。

    • Uses of TemporalUnit in java.time.chrono

      Methods in java.time.chrono that return types with arguments of type TemporalUnit
      Modifier and Type 方法 描述
      List<TemporalUnit> ChronoPeriod.getUnits​()
      获取此期间支持的单位集。
      Methods in java.time.chrono with parameters of type TemporalUnit
      Modifier and Type | 方法 | 描述
      long ChronoPeriod.get​(TemporalUnit unit)
      获取所请求单元的值。
      default boolean ChronoLocalDate.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      default boolean ChronoLocalDateTime.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      default boolean ChronoZonedDateTime.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      default ChronoLocalDate ChronoLocalDate.minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default ChronoLocalDateTime<D> ChronoLocalDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      default ChronoZonedDateTime<D> ChronoZonedDateTime.minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      HijrahDate | HijrahDate.minus​(long amountToSubtract, TemporalUnit unit)
      JapaneseDate | JapaneseDate.minus​(long amountToAdd, TemporalUnit unit)
      MinguoDate | MinguoDate.minus​(long amountToAdd, TemporalUnit unit)
      ThaiBuddhistDate | ThaiBuddhistDate.minus​(long amountToAdd, TemporalUnit unit)
      default ChronoLocalDate ChronoLocalDate.plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      ChronoLocalDateTime<D> ChronoLocalDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      ChronoZonedDateTime<D> ChronoZonedDateTime.plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      HijrahDate | HijrahDate.plus​(long amountToAdd, TemporalUnit unit)
      JapaneseDate | JapaneseDate.plus​(long amountToAdd, TemporalUnit unit)
      MinguoDate | MinguoDate.plus​(long amountToAdd, TemporalUnit unit)
      ThaiBuddhistDate | ThaiBuddhistDate.plus​(long amountToAdd, TemporalUnit unit)
      long ChronoLocalDate.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个日期的时间量。

    • Uses of TemporalUnit in java.time.temporal

      Classes in java.time.temporal that implement TemporalUnit
      Modifier and Type Class 描述
      class  ChronoUnit
      一组标准的日期单位。
      Fields in java.time.temporal declared as TemporalUnit
      Modifier and Type Field 描述
      static TemporalUnit IsoFields.QUARTER_YEARS
      代表四分之一年概念的单位。
      static TemporalUnit IsoFields.WEEK_BASED_YEARS
      以加法和减法为目的的以星期为单位的单位。
      static TemporalUnit WeekFields.WEEK_BASED_YEARS
      以加法和减法为目的的以星期为单位的单位。
      Methods in java.time.temporal that return TemporalUnit
      Modifier and Type | 方法 | 描述
      TemporalUnit | ChronoField.getBaseUnit​()
      TemporalUnit TemporalField.getBaseUnit​()
      获取测量场的单位。
      TemporalUnit | ChronoField.getRangeUnit​()
      TemporalUnit TemporalField.getRangeUnit​()
      获取字段绑定的范围。
      Methods in java.time.temporal that return types with arguments of type TemporalUnit
      Modifier and Type 方法 描述
      List<TemporalUnit> TemporalAmount.getUnits​()
      返回唯一定义此TemporalAmount值的单位列表。
      static TemporalQuery<TemporalUnit> TemporalQueries.precision​()
      对最小支持单位的查询。
      Methods in java.time.temporal with parameters of type TemporalUnit
      Modifier and Type 方法 描述
      long TemporalAmount.get​(TemporalUnit unit)
      返回请求的单位的值。
      boolean Temporal.isSupported​(TemporalUnit unit)
      检查指定的单位是否受支持。
      default Temporal Temporal.minus​(long amountToSubtract, TemporalUnit unit)
      返回与该对象相同类型的对象，并减去指定的时间段。
      Temporal Temporal.plus​(long amountToAdd, TemporalUnit unit)
      返回与此对象相同类型的对象，并添加指定的句点。
      long Temporal.until​(Temporal endExclusive, TemporalUnit unit)
      根据指定的单位计算直到另一个时间的时间量。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


java.time.zone (Java SE 9 & JDK 9 )

java.time.zone

Classes

  • ZoneOffsetTransition
  • ZoneOffsetTransitionRule
  • ZoneRules
  • ZoneRulesProvider

Enums

  • ZoneOffsetTransitionRule.TimeDefinition

Exceptions

  • ZoneRulesException


java.time.zone (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.time.zone

支持时区及其规则。

夏令时间和时区是各国政府改变当地时间的概念。 该包提供对时区，其规则的支持，以及通常由夏令时引起的本地时间线中产生的间隙和重叠。

包装规格

除非另有说明，否则在此包中的任何类或接口中将null参数传递给构造函数或方法将导致抛出NullPointerException 。 Javadoc“@param”定义用于总结空行为。 “ @throws NullPointerException ”没有在每个方法中明确记录。

所有计算应检查数字溢出，并抛出一个ArithmeticException或DateTimeException 。

从以下版本开始：
1.8
  • 类摘要
    Class 描述
    ZoneOffsetTransition
    由本地时间线不连续性引起的两个偏移之间的转换。
    ZoneOffsetTransitionRule
    表达如何创建转换的规则。
    ZoneRules
    定义区域偏移对于单个时区的变化的规则。
    ZoneRulesProvider
    提供给系统的时区规则。
  • 枚举摘要
    Enum 描述
    ZoneOffsetTransitionRule.TimeDefinition
    本地时间可以转换为实际转换日期时间的方式的定义。
  • 异常摘要
    异常 描述
    ZoneRulesException
    Thrown to indicate a problem with time-zone configuration.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.time.zone Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.time.zone

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.time.DateTimeException
            • java.time.zone.ZoneRulesException
    • java.time.zone.ZoneOffsetTransition (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.time.zone.ZoneOffsetTransitionRule (implements java.io.Serializable)
    • java.time.zone.ZoneRules (implements java.io.Serializable)
    • java.time.zone.ZoneRulesProvider

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.time.zone.ZoneOffsetTransitionRule.TimeDefinition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package java.time.zone (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.time.zone

  • Packages that use java.time.zone
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.zone
    支持时区及其规则。
  • Classes in java.time.zone used by java.time
    Class 描述
    ZoneRules
    定义区域偏移对于单个时区的变化的规则。
  • Classes in java.time.zone used by java.time.zone
    Class 描述
    ZoneOffsetTransition
    由本地时间线不连续性引起的两个偏移之间的转换。
    ZoneOffsetTransitionRule
    表达如何创建转换的规则。
    ZoneOffsetTransitionRule.TimeDefinition
    本地时间可以转换为实际转换日期时间的方式的定义。
    ZoneRules
    定义区域偏移对于单个时区的变化的规则。
    ZoneRulesProvider
    提供给系统的时区规则。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ZoneOffsetTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.zone

Class ZoneOffsetTransition

  • java.lang.Object
    • java.time.zone.ZoneOffsetTransition
  • All Implemented Interfaces:
    Serializable ， Comparable<ZoneOffsetTransition>

    public final class ZoneOffsetTransition
extends Object
implements Comparable<ZoneOffsetTransition>, Serializable
    由本地时间线不连续性引起的两个偏移之间的转换。

    两个偏移之间的转换通常是夏令时切换的结果。 不连续性通常是春季的差距，秋季的重叠。 ZoneOffsetTransition模拟两个偏移之间的转换。

    当地的日期时间根本不存在时，会出现差距。 一个例子是当偏移从+03:00变为+04:00 。 这可能被描述为“时钟将在凌晨1点钟前往前进一小时。

    重叠发生在存在两次的本地日期时间。 一个例子是当偏移从+04:00变为+03:00 。 这可能被描述为“时钟将在凌晨2点钟移动一小时。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(ZoneOffsetTransition transition)
      根据转换时刻将此转换与另一个进行比较。
      boolean equals​(Object other)
      检查这个对象是否等于另一个。
      LocalDateTime getDateTimeAfter​()
      获取本地转换日期时间，将以“after”偏移量表示。
      LocalDateTime getDateTimeBefore​()
      获取本地转换日期时间，如“before”偏移量所表达的那样。
      Duration getDuration​()
      获取转换的持续时间。
      Instant getInstant​()
      获得转换时刻。
      ZoneOffset getOffsetAfter​()
      获得转换后的偏移量。
      ZoneOffset getOffsetBefore​()
      在转换之前获取偏移量。
      int hashCode​()
      返回一个合适的哈希码。
      boolean isGap​()
      这个转变是否代表了本地时间线的差距。
      boolean isOverlap​()
      这个转换是否代表本地时间线的重叠。
      boolean isValidOffset​(ZoneOffset offset)
      在此转换期间检查指定的偏移是否有效。
      static ZoneOffsetTransition of​(LocalDateTime transition, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义两个偏移之间的转换的实例。
      long toEpochSecond​()
      将转换瞬间作为第二纪。
      String toString​()
      返回描述此对象的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • of

        public static ZoneOffsetTransition of​(LocalDateTime transition,
                                      ZoneOffset offsetBefore,
                                      ZoneOffset offsetAfter)
        获取定义两个偏移之间的转换的实例。

        应用程序通常应从ZoneRules获取一个实例。 本厂仅供创建ZoneRules时使用。

        参数
        transition - 过渡 transition的转换日期 - 时间（从未实际发生）表示为以前的偏移量，而不是null
        offsetBefore - 转换前的偏移量，不为空
        offsetAfter - 转换过程中和之后的偏移量，不为空
        结果
        转换，不为空
        异常
        IllegalArgumentException - 如果 offsetBefore和 offsetAfter相等，或 transition.getNano()返回非零值

      • getInstant

        public Instant getInstant​()
        获得转换时刻。

        这是不连续的时刻，被定义为“after”偏移量应用的第一个时刻。

        该方法getInstant() ， getDateTimeBefore()和getDateTimeAfter()都代表同一时刻。

        结果
        转换瞬间，不为空

      • toEpochSecond

        public long toEpochSecond​()
        将转换瞬间作为第二纪。
        结果
        过渡时代第二

      • getDateTimeBefore

        public LocalDateTime getDateTimeBefore​()
        获取本地转换日期时间，如“before”偏移量所表达的那样。

        这是日期时间，不连续开始用“before”偏移量表示。 在这个时刻，实际使用'after'偏移量，因此这个日期时间和'before'偏移量的组合将永远不会发生。

        “之前”日期时间和偏移量的组合表示与“之后”日期时间和偏移量相同的时刻。

        结果
        以前偏移量表示的转换日期时间不为null

      • getDateTimeAfter

        public LocalDateTime getDateTimeAfter​()
        获取本地转换日期时间，将以“after”偏移量表示。

        这是在不连续性之后的第一个日期时间，当新的偏移量适用时。

        “之前”日期时间和偏移量的组合表示与“之后”日期时间和偏移量相同的时刻。

        结果
        以后偏移量表示的转换日期时间不为空

      • getOffsetBefore

        public ZoneOffset getOffsetBefore​()
        在转换之前获取偏移量。

        这是转换之前的使用偏移量。

        结果
        转换前的偏移量，不为空

      • getOffsetAfter

        public ZoneOffset getOffsetAfter​()
        获得转换后的偏移量。

        这是在转换瞬间和之后使用的偏移量。

        结果
        转换后的偏移量，不为空

      • getDuration

        public Duration getDuration​()
        获取转换的持续时间。

        在大多数情况下，过渡时间为1小时，但并不总是如此。 持续时间对于差距为正，而重叠的持续时间为负。 时区是次要的，所以持续时间的纳秒部分将为零。

        结果
        过渡期持续时间为负，为重叠

      • isGap

        public boolean isGap​()
        这个转变是否代表了本地时间线的差距。

        当地的日期时间根本不存在时，会出现差距。 一个例子是当偏移从+01:00变为+02:00 。 这可能被描述为“时钟将在凌晨1点钟前往前进一小时。

        结果
        如果这个过渡是间隙，则为真，如果是重叠则为假

      • isOverlap

        public boolean isOverlap​()
        这个转换是否代表本地时间线的重叠。

        重叠发生在存在两次的本地日期时间。 一个例子是当偏移量从+02:00变为+01:00 。 这可能被描述为“时钟将在凌晨2点钟移动一小时。

        结果
        如果这个过渡是重叠，则为真，如果是间隙，则为false

      • isValidOffset

        public boolean isValidOffset​(ZoneOffset offset)
        在此转换期间检查指定的偏移是否有效。

        这将检查给定的偏移量是否在转换中的某个时间点有效。 差距总是返回假。 如果偏移量是前后偏移量，重叠将返回true。

        参数
        offset - 要检查的偏移量，null返回false
        结果
        如果偏移在转换期间有效，则为真

      • compareTo

        public int compareTo​(ZoneOffsetTransition transition)
        根据转换时刻将此转换与另一个进行比较。

        这比较了每个过渡的时刻。 偏移量被忽略，使得该顺序与equals不一致。

        Specified by:
        compareTo在接口 Comparable<ZoneOffsetTransition>
        参数
        transition - 转换为比较，不为null
        结果
        比较器值为负，如果较小，则如果较大则为正

      • equals

        public boolean equals​(Object other)
        检查这个对象是否等于另一个。

        比较对象的整个状态。

        重写：
        equals在 Object
        参数
        other - 要比较的另一个对象，null返回false
        结果
        如果相等则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回一个合适的哈希码。
        重写：
        hashCode在 Object
        结果
        哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回描述此对象的字符串。
        重写：
        toString在 Object
        结果
        一个用于调试的字符串，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ZoneOffsetTransitionRule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.zone

Class ZoneOffsetTransitionRule

  • java.lang.Object
    • java.time.zone.ZoneOffsetTransitionRule
  • All Implemented Interfaces:
    Serializable

    public final class ZoneOffsetTransitionRule
extends Object
implements Serializable
    表达如何创建转换的规则。

    该类允许表达未来转换的规则。 一个规则可以写成许多形式：

    • 三月十六日
    • 3月16日或之后的星期日
    • 3月16日或之前的星期日
    • 二月最后一个星期日
    这些不同的规则类型可以被表达和查询。
    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ZoneOffsetTransitionRule.TimeDefinition
      本地时间可以转换为实际转换日期时间的方式的定义。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ZoneOffsetTransition createTransition​(int year)
      创建指定年份的转换实例。
      boolean equals​(Object otherRule)
      检查这个对象是否等于另一个。
      int getDayOfMonthIndicator​()
      获得转型月份的指标。
      DayOfWeek getDayOfWeek​()
      获得过渡的星期几。
      LocalTime getLocalTime​()
      获取必须用 isMidnightEndOfDay()进行检查的 当地时间 。
      Month getMonth​()
      获得过渡的月份。
      ZoneOffset getOffsetAfter​()
      获得转换后的偏移量。
      ZoneOffset getOffsetBefore​()
      在转换之前获取偏移量。
      ZoneOffset getStandardOffset​()
      在转换时获得有效的标准偏移量。
      ZoneOffsetTransitionRule.TimeDefinition getTimeDefinition​()
      获取时间定义，指定如何将时间转换为即时。
      int hashCode​()
      返回一个合适的哈希码。
      boolean isMidnightEndOfDay​()
      当天的时间是午夜的过渡时间。
      static ZoneOffsetTransitionRule of​(Month month, int dayOfMonthIndicator, DayOfWeek dayOfWeek, LocalTime time, boolean timeEndOfDay, ZoneOffsetTransitionRule.TimeDefinition timeDefnition, ZoneOffset standardOffset, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义年度规则以在两个偏移之间创建转换的实例。
      String toString​()
      返回描述此对象的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • of

        public static ZoneOffsetTransitionRule of​(Month month,
                                          int dayOfMonthIndicator,
                                          DayOfWeek dayOfWeek,
                                          LocalTime time,
                                          boolean timeEndOfDay,
                                          ZoneOffsetTransitionRule.TimeDefinition timeDefnition,
                                          ZoneOffset standardOffset,
                                          ZoneOffset offsetBefore,
                                          ZoneOffset offsetAfter)
        获取定义年度规则以在两个偏移之间创建转换的实例。

        应用程序通常应从ZoneRules获取一个实例。 本厂仅供创建ZoneRules时使用。

        参数
        month - 割接周的第一天的月 - 日的月份，不为空
        dayOfMonthIndicator - 切割周的月日，如果周是当天或以后，则为正，如果周为当天或更早，则为从该日最后一天起计，从-28减去31除外0
        dayOfWeek - 所需的星期几，如果月日不应该更改，则为null
        time - 'before'偏移量的割接时间，不为空
        timeEndOfDay - 是否在一天结束时间是午夜
        timeDefnition - 如何解释割接
        standardOffset - 割接时的标准偏移量，不为空
        offsetBefore - 割接前的偏移量，不为空
        offsetAfter - 割接后的偏移量，不为空
        结果
        规则，不为null
        异常
        IllegalArgumentException - 如果日指标无效
        IllegalArgumentException - 当时间不是午夜时，如果结束日标志为真
        IllegalArgumentException - 如果 time.getNano()返回非零值

      • getMonth

        public Month getMonth​()
        获得过渡的月份。

        如果规则定义了确切的日期，则该月份是该日期的月份。

        如果规则定义了可能发生转换的一周，那么月份是割接的最早或最晚可能日期的月份。

        结果
        过渡的月份，不为空

      • getDayOfMonthIndicator

        public int getDayOfMonthIndicator​()
        获得转型月份的指标。

        如果规则定义了确切的日期，则该日期是该日期的月份。

        如果规则定义了可能发生转换的一周，则该日期定义转换周期结束的开始。

        如果值为正值，则表示正常的日期，并且是过渡可能的最早可能的日期。 日期可能指的是2月29日，应在非闰年内被视为3月1日。

        如果值为负数，则表示从月末的最后一天的-1月底开始的天数。 在这种情况下，确定的日期是过渡可能的最新日期。

        结果
        月份指标，从-28到31，不包括0

      • getDayOfWeek

        public DayOfWeek getDayOfWeek​()
        获得过渡的星期几。

        如果规则定义了一个确切的日期，那么这将返回null。

        如果规则定义了可能发生割接的一周，则此方法将返回月日将被调整到的星期几。 如果当天是正面的，那么调整是晚了。 如果一天是负数，则调整较早。

        结果
        转换发生的星期几，如果规则定义了确切的日期，则为null

      • getLocalTime

        public LocalTime getLocalTime​()
        获取必须用isMidnightEndOfDay()检查的转换当天的当地时间 。

        使用时间定义将时间转换成即时。

        结果
        当地时间的过渡，不是null

      • isMidnightEndOfDay

        public boolean isMidnightEndOfDay​()
        当天的时间是午夜的过渡时间。

        转换可能表示为发生在24:00。

        结果
        当地的午夜时间是在一天的开始还是结束

      • getTimeDefinition

        public ZoneOffsetTransitionRule.TimeDefinition getTimeDefinition​()
        获取时间定义，指定如何将时间转换为即时。

        当地时间可以使用标准偏移量，壁偏移或UTC转换为即时。

        结果
        时间定义，不为空

      • getStandardOffset

        public ZoneOffset getStandardOffset​()
        在转换时获得有效的标准偏移量。
        结果
        标准偏移，不为空

      • getOffsetBefore

        public ZoneOffset getOffsetBefore​()
        在转换之前获取偏移量。
        结果
        之前的偏移量，不为空

      • getOffsetAfter

        public ZoneOffset getOffsetAfter​()
        获得转换后的偏移量。
        结果
        偏移量后，不为空

      • createTransition

        public ZoneOffsetTransition createTransition​(int year)
        创建指定年份的转换实例。

        使用ISO-8601年表进行计算。

        参数
        year - 创建转换的年份，不为null
        结果
        转换实例，不为null

      • equals

        public boolean equals​(Object otherRule)
        检查这个对象是否等于另一个。

        比较对象的整个状态。

        重写：
        equals在 Object
        参数
        otherRule - 要比较的其他对象，null返回false
        结果
        如果相等则为真
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回一个合适的哈希码。
        重写：
        hashCode在 Object
        结果
        哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回描述此对象的字符串。
        重写：
        toString在 Object
        结果
        a string for debugging, not null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ZoneOffsetTransitionRule.TimeDefinition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.time.zone

Enum ZoneOffsetTransitionRule.TimeDefinition

  • java.lang.Object
    • java.lang.Enum<ZoneOffsetTransitionRule.TimeDefinition>
      • java.time.zone.ZoneOffsetTransitionRule.TimeDefinition
  • All Implemented Interfaces:
    Serializable ， Comparable<ZoneOffsetTransitionRule.TimeDefinition>
    Enclosing class:
    ZoneOffsetTransitionRule

    public static enum ZoneOffsetTransitionRule.TimeDefinition
extends Enum<ZoneOffsetTransitionRule.TimeDefinition>
    本地时间可以转换为实际转换日期时间的方式的定义。

    时区规则以三种方式之一表示：

    • 相对于UTC
    • 相对于有效的标准偏移
    • 相对于墙壁偏移（你会在墙上的钟上看到什么）

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      STANDARD
      本地日期时间以标准偏移量表示。
      UTC
      本地日期时间以UTC偏移量表示。
      WALL
      当地的日期时间用墙壁偏移量表示。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      LocalDateTime createDateTime​(LocalDateTime dateTime, ZoneOffset standardOffset, ZoneOffset wallOffset)
      将指定的本地日期时间转换为挂钟上实际看到的本地日期时间。
      static ZoneOffsetTransitionRule.TimeDefinition valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ZoneOffsetTransitionRule.TimeDefinition[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UTC

        public static final ZoneOffsetTransitionRule.TimeDefinition UTC
        本地日期时间以UTC偏移量表示。

      • WALL

        public static final ZoneOffsetTransitionRule.TimeDefinition WALL
        当地的日期时间用墙壁偏移量表示。

      • STANDARD

        public static final ZoneOffsetTransitionRule.TimeDefinition STANDARD
        本地日期时间以标准偏移量表示。

    • 方法详细信息

      • values

        public static ZoneOffsetTransitionRule.TimeDefinition[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ZoneOffsetTransitionRule.TimeDefinition c : ZoneOffsetTransitionRule.TimeDefinition.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ZoneOffsetTransitionRule.TimeDefinition valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • createDateTime

        public LocalDateTime createDateTime​(LocalDateTime dateTime,
                                    ZoneOffset standardOffset,
                                    ZoneOffset wallOffset)
        将指定的本地日期时间转换为挂钟上实际看到的本地日期时间。

        此方法使用此枚举的类型进行转换。 输出相对于转换的'before'偏移定义。

        UTC类型使用UTC偏移量。 STANDARD类型使用标准偏移量。 WALL类型返回输入的日期时间。 结果是用于墙壁偏移。

        参数
        dateTime - 本地日期时间，不为空
        standardOffset - 标准偏移，不为空
        wallOffset - 墙偏移，不为空
        结果
        日期时间相对于墙/之前的偏移量，不为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ZoneRules (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.zone

Class ZoneRules

  • java.lang.Object
    • java.time.zone.ZoneRules
  • All Implemented Interfaces:
    Serializable

    public final class ZoneRules
extends Object
implements Serializable
    定义区域偏移对于单个时区的变化的规则。

    规则模拟了时区的所有历史和未来转型。 ZoneOffsetTransition用于已知的转换，通常是历史记录。 ZoneOffsetTransitionRule用于基于算法结果的未来转换。

    规则通过ZoneRulesProvider使用ZoneId加载。 相同的规则可以在多个区域ID之间内部共享。

    序列化ZoneRules的实例将存储整套规则。 它不存储区域ID，因为它不是此对象的状态的一部分。

    规则实现可以存储或不存储关于历史和未来转换的完整信息，并且存储的信息与提供给规则提供者的实现一样准确。 应用程序应将提供的数据视为可用于执行此规则的最佳信息。

    实现要求：
    这个类是不可变的和线程安全的。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object otherRules)
      检查这套规则是否等于另一个。
      Duration getDaylightSavings​(Instant instant)
      获取此区域中指定时间使用的夏令时数量。
      ZoneOffset getOffset​(Instant instant)
      获得这些规则中指定时刻适用的偏移量。
      ZoneOffset getOffset​(LocalDateTime localDateTime)
      在这些规则中为指定的本地日期时间获取适当的偏移量。
      ZoneOffset getStandardOffset​(Instant instant)
      获取此区域中指定时刻的标准偏移量。
      ZoneOffsetTransition getTransition​(LocalDateTime localDateTime)
      在这些规则中获取在指定的本地日期时间中适用的偏移量转换。
      List<ZoneOffsetTransitionRule> getTransitionRules​()
      获得过渡规则列表，超出转换列表中定义的年限。
      List<ZoneOffsetTransition> getTransitions​()
      获取完全定义的转换的完整列表。
      List<ZoneOffset> getValidOffsets​(LocalDateTime localDateTime)
      在这些规则中获取在指定的本地日期时间中适用的偏移量。
      int hashCode​()
      给出给定 #equals的定义的合适的哈希码。
      boolean isDaylightSavings​(Instant instant)
      检查指定的时间是否是夏令时。
      boolean isFixedOffset​()
      检查区域规则是固定的，使得偏移量不变。
      boolean isValidOffset​(LocalDateTime localDateTime, ZoneOffset offset)
      检查偏移日期时间对于这些规则是否有效。
      ZoneOffsetTransition nextTransition​(Instant instant)
      在指定的时刻之后获取下一个转换。
      static ZoneRules of​(ZoneOffset offset)
      获取具有固定区域规则的ZoneRules实例。
      static ZoneRules of​(ZoneOffset baseStandardOffset, ZoneOffset baseWallOffset, List<ZoneOffsetTransition> standardOffsetTransitionList, List<ZoneOffsetTransition> transitionList, List<ZoneOffsetTransitionRule> lastRules)
      获取ZoneRules的实例。
      ZoneOffsetTransition previousTransition​(Instant instant)
      获取指定时刻之前的转换。
      String toString​()
      返回描述此对象的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • of

        public static ZoneRules of​(ZoneOffset baseStandardOffset,
                           ZoneOffset baseWallOffset,
                           List<ZoneOffsetTransition> standardOffsetTransitionList,
                           List<ZoneOffsetTransition> transitionList,
                           List<ZoneOffsetTransitionRule> lastRules)
        获取ZoneRules的实例。
        参数
        baseStandardOffset - 设置法定规则之前使用的标准偏移量，不为空
        baseWallOffset - 设置法定规则之前使用的墙偏移量，不为空
        standardOffsetTransitionList - 标准偏移量的更改列表，不为空
        transitionList - 转换列表，不为null
        lastRules - 重复的最后一个规则，大小16或更小，不为null
        结果
        区域规则，不为空

      • of

        public static ZoneRules of​(ZoneOffset offset)
        获取具有固定区域规则的ZoneRules实例。
        参数
        offset - 该固定区域规则所基于的偏移量，不为null
        结果
        区域规则，不为空
        另请参见：
        isFixedOffset()

      • isFixedOffset

        public boolean isFixedOffset​()
        检查区域规则是固定的，使得偏移量不变。
        结果
        如果时区是固定的并且偏移量永远不会改变，则为真

      • getOffset

        public ZoneOffset getOffset​(Instant instant)
        获得这些规则中指定时刻适用的偏移量。

        从瞬间到偏移的映射很简单，每个时刻只有一个有效的偏移量。 此方法返回该偏移量。

        参数
        instant - 找到偏移量的时间，不为null，但如果规则对于所有瞬间都有单个偏移量，则可以忽略null
        结果
        偏移量，不为空

      • getOffset

        public ZoneOffset getOffset​(LocalDateTime localDateTime)
        在这些规则中为指定的本地日期时间获取适当的偏移量。

        从本地日期时间到偏移量的映射并不简单。 有三种情况：

        • 正常，有一个有效的偏移。 在一年的绝大多数情况下，正常情况适用于当地日期时间单一有效抵消。
        • 间隙，零有效偏移。 这是由于春季夏令时从“冬季”变为“夏季”，时钟向前倾斜。 在间隙中，存在没有有效偏移量的本地日期时间值。
        • 重叠，有两个有效的偏移。 这是由于秋季夏令时间从“夏季”变为“冬季”而将时钟倒退。 在重叠中，存在具有两个有效偏移量的本地日期时间值。
        因此，对于任何给定的本地日期时间，可以有零个，一个或两个有效的偏移量。 该方法返回正常情况下的单个偏移量，并且在间隙或重叠情况下，它将返回转换之前的偏移量。

        由于在间隙和重叠的情况下，返回的偏移量是“最佳”值，而不是“正确”值，因此应小心对待。 关心正确偏移的应用程序应使用此方法getValidOffsets(LocalDateTime)和getTransition(LocalDateTime)的组合。

        参数
        localDateTime - 查询的本地日期时间，不为空，但是如果规则对于所有瞬间都有单个偏移量，则可以忽略null
        结果
        当地日期时间的最佳可用偏移量，不为空

      • getValidOffsets

        public List<ZoneOffset> getValidOffsets​(LocalDateTime localDateTime)
        在这些规则中获取在指定的本地日期时间中适用的偏移量。

        从本地日期时间到偏移量的映射并不简单。 有三种情况：

        • 正常，有一个有效的偏移。 在一年的绝大多数情况下，正常情况适用于当地日期时间单一有效抵消。
        • 间隙，零有效偏移。 这是由于春季夏令时从“冬季”变为“夏季”，时钟向前倾斜。 在间隙中，存在没有有效偏移量的本地日期时间值。
        • 重叠，有两个有效的偏移。 这是由于秋季夏令时间从“夏季”变为“冬季”而将时钟倒退。 在重叠中，存在具有两个有效偏移量的本地日期时间值。
        因此，对于任何给定的本地日期时间，可以有零个，一个或两个有效的偏移量。 该方法返回有效偏移列表，它是大小为0,1或2的列表。在有两个偏移量的情况下，较早的偏移量在索引0处返回，后一个偏移量在索引1处返回。

        有多种方法来处理来自一个LocalDateTime的转换。 使用这种方法的一种技术是：

          List<ZoneOffset> validOffsets = rules.getOffset(localDT);
  if (validOffsets.size() == 1) {
    // Normal case: only one valid offset
    zoneOffset = validOffsets.get(0);
  } else {
    // Gap or Overlap: determine what to do from transition (which will be non-null)
    ZoneOffsetTransition trans = rules.getTransition(localDT);
  }

        理论上说，有可能有两个以上的有效偏移量。 如果时钟要快速连续放回不止一次，会发生这种情况。 这在时区的历史上从来没有发生过，因此没有特别的处理。 但是，如果发生这种情况，列表将返回两个以上的条目。

        参数
        localDateTime - 查询有效偏移量的本地日期时间，不为null，但如果规则对于所有瞬间具有单个偏移量，则可以忽略null
        结果
        有效偏移的列表可能是不可变的，不为空

      • getTransition

        public ZoneOffsetTransition getTransition​(LocalDateTime localDateTime)
        在这些规则中获取在指定的本地日期时间中适用的偏移量转换。

        从本地日期时间到偏移量的映射并不简单。 有三种情况：

        • 正常，有一个有效的偏移。 在一年的绝大多数情况下，正常情况适用于当地日期时间单一有效抵消。
        • 间隙，零有效偏移。 这是由于春季夏令时从“冬季”变为“夏季”，时钟向前倾斜。 在间隙中，存在没有有效偏移量的本地日期时间值。
        • 重叠，有两个有效的偏移。 这是由于秋季夏令时间从“夏季”变为“冬季”而将时钟倒退。 在重叠中，存在具有两个有效偏移量的本地日期时间值。
        转换用于对间隙或重叠的情况进行建模。 正常情况将返回null。

        有多种方法来处理从LocalDateTime转换。 使用这种方法的一种技术是：

          ZoneOffsetTransition trans = rules.getTransition(localDT);
  if (trans != null) {
    // Gap or Overlap: determine what to do from transition
  } else {
    // Normal case: only one valid offset
    zoneOffset = rule.getOffset(localDT);
  }
        参数
        localDateTime - 查询偏移转换的本地日期时间，不为空，但如果规则对于所有瞬间具有单个偏移量，则可以忽略null
        结果
        偏移转换，如果本地日期时间不在转换中则为null

      • getStandardOffset

        public ZoneOffset getStandardOffset​(Instant instant)
        获取此区域中指定时刻的标准偏移量。

        这提供了有关标准偏移量随时间变化的历史信息。 标准偏移量是在应用任何夏令时之前的偏移量。 这通常是冬季适用的偏移。

        参数
        instant - 如果规则对于所有瞬间都有单个偏移，则可以忽略找到偏移量信息的时间，而不是null，但是null可以被忽略
        结果
        标准偏移，不为空

      • getDaylightSavings

        public Duration getDaylightSavings​(Instant instant)
        获取此区域中指定时间使用的夏令时数量。

        这提供了有关夏令时数随时间变化的历史信息。 这是标准偏移和实际偏移之间的差异。 通常在冬天和夏天一个小时的数量是零。 时区是次要的，所以持续时间的纳秒部分将为零。

        此默认实现计算从actual和standard偏移量的持续时间。

        参数
        instant - 找到夏令时的时间，不为null，但是如果规则对于所有瞬间都有单个偏移量，则可以忽略null
        结果
        标准差和实际偏差之间的差异，不为零

      • isDaylightSavings

        public boolean isDaylightSavings​(Instant instant)
        检查指定的时间是否是夏令时。

        这将检查标准偏移量和实际偏移量对于指定时刻是否相同。 如果不是，则假设夏令时正在运行。

        此默认实现将比较actual和standard的偏移量。

        参数
        instant - 找到偏移量信息的时间，不为空，但是如果规则对于所有瞬间都有单个偏移量，则可以忽略null
        结果
        标准偏移，不为空

      • isValidOffset

        public boolean isValidOffset​(LocalDateTime localDateTime,
                             ZoneOffset offset)
        检查偏移日期时间对于这些规则是否有效。

        为了有效，本地日期时间不能在间隙中，偏移量必须与有效偏移之一匹配。

        此默认实现检查getValidOffsets(java.time.LocalDateTime)是否包含指定的偏移量。

        参数
        localDateTime - 检查的日期时间，不为null，但是如果规则对于所有瞬间具有单个偏移量，则可以忽略null
        offset - 要检查的偏移量，null返回false
        结果
        如果偏移日期时间对这些规则有效，则为true

      • nextTransition

        public ZoneOffsetTransition nextTransition​(Instant instant)
        在指定的时刻之后获取下一个转换。

        这将返回指定时间后的下一个转换的详细信息。 例如，如果瞬间表示“夏季”夏令时适用的点，则该方法将返回到下一个“冬季”时间的过渡。

        参数
        instant - 即时获取下一个转换，不为null，但是如果规则对于所有瞬间都有单个偏移量，则可以忽略null
        结果
        在指定的时间之后的下一个转换，如果这是在最后一个转换之后，则为null

      • previousTransition

        public ZoneOffsetTransition previousTransition​(Instant instant)
        获取指定时刻之前的转换。

        这将在指定时刻之前返回上一个转换的详细信息。 例如，如果瞬间表示“夏季”夏令时适用的点，则该方法将返回从上一个“冬季”时间过渡。

        参数
        instant - 如果规则对于所有时刻都有一个偏移量，则可以忽略之前的转换，而不是null，但是null可能会被忽略
        结果
        之前的转换在指定的时间之前，如果这是在第一次转换之前，则为null

      • getTransitions

        public List<ZoneOffsetTransition> getTransitions​()
        获取完全定义的转换的完整列表。

        该规则实例的完整转换集由此方法和getTransitionRules()定义。 此方法返回已完全定义的转换。 这些通常是历史的，但可能在将来。

        对于固定的偏移量规则以及只有一次偏移量的任何时区，列表将为空。 如果转换规则未知，则列表也将为空。

        结果
        完全定义的转换的不可变列表，不为null

      • getTransitionRules

        public List<ZoneOffsetTransitionRule> getTransitionRules​()
        获得过渡规则列表，超出转换列表中定义的年限。

        此规则实例的完整转换集由此方法和getTransitions()定义。 此方法返回ZoneOffsetTransitionRule的实例，该实例定义了何时发生转换的算法。

        对于任何给定的ZoneRules ，该列表包含已经完全定义的那些年以后的转换规则。 这些规则通常是指未来的夏令时规则更改。

        如果该区域将来将定义夏令时，那么列表通常大小为2，并保存有关进入和退出夏令时的信息。 如果该区域没有夏令时，或有关未来更改的信息不确定，则列表将为空。

        对于固定的偏移规则和没有夏令时的任何时区，列表将为空。 如果转换规则未知，则列表也将为空。

        结果
        一个不可变的过渡规则列表，不为空

      • equals

        public boolean equals​(Object otherRules)
        检查这套规则是否等于另一个。

        如果任何给定的输入即时或本地日期时间总是导致相同的输出，两个规则集是相等的。 来自两个不同群组的规则可能会返回假，即使它们实际上相同。

        这个定义应该导致比较他们整个状态的实现。

        重写：
        equals在 Object
        参数
        otherRules - 其他规则，null返回false
        结果
        如果此规则与指定的规则相同，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        给出给定的 #equals的合适的哈希码。
        重写：
        hashCode在 Object
        结果
        哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回描述此对象的字符串。
        重写：
        toString在 Object
        结果
        一个用于调试的字符串，不为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ZoneRulesException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.zone

Class ZoneRulesException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.time.DateTimeException
            • java.time.zone.ZoneRulesException
  • All Implemented Interfaces:
    Serializable

    public class ZoneRulesException
extends DateTimeException
    抛出指示时区配置的问题。

    此异常用于指示配置的时区规则的问题。

    实现要求：
    该类旨在用于单个线程。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ZoneRulesException​(String message)
      使用指定的消息构造新的日期时间异常。
      ZoneRulesException​(String message, Throwable cause)
      构造一个新的日期时间异常与指定的消息和原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ZoneRulesException

        public ZoneRulesException​(String message)
        使用指定的消息构造新的日期时间异常。
        参数
        message - 用于此异常的消息可能为null

      • ZoneRulesException

        public ZoneRulesException​(String message,
                          Throwable cause)
        构造一个新的日期时间异常与指定的消息和原因。
        参数
        message - 用于此异常的消息可能为null
        cause - 异常的原因可能为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ZoneRulesProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.time.zone

Class ZoneRulesProvider

  • java.lang.Object
    • java.time.zone.ZoneRulesProvider

  • public abstract class ZoneRulesProvider
extends Object
    提供给系统的时区规则。

    该类管理时区规则的配置。 静态方法提供可用于管理提供程序的公共API。 抽象方法提供允许提供规则的SPI。

    ZoneRulesProvider可以作为扩展类安装在Java Platform的实例中，也就是将jar文件放置到任何常见的扩展目录中。 使用由ServiceLoader类定义的服务提供商加载工具加载安装的提供程序。 ZoneRulesProvider使用资源目录META-INF/services名为java.time.zone.ZoneRulesProvider的提供程序配置文件来标识自身。 该文件应包含一条指定完全限定的具体zonerules-provider类名称的行。 提供商也可以通过将它们添加到类路径或通过registerProvider(java.time.zone.ZoneRulesProvider)方法注册自己来提供 。

    Java虚拟机具有为IANA时区数据库（TZDB）定义的时区提供区域规则的默认提供程序。 如果定义了系统属性java.time.zone.DefaultZoneRulesProvider ，则将其作为使用系统类加载器作为默认提供程序加载的具体ZoneRulesProvider类的完全限定名称。 如果未定义此系统属性，系统默认提供程序将被加载为默认提供程序。

    规则主要由区域ID查找，由ZoneId使用 。 只能使用区域区域ID，这里不使用区域偏移ID。

    时区规则是政治性的，因此数据随时可以改变。 每个提供商将提供每个区域ID的最新规则，但它们也可能提供规则更改的历史。

    实现要求：
    此接口是可由多个线程调用的服务提供程序。 实现必须是不可变的和线程安全的。

    提供者必须确保一旦应用程序看到规则，规则必须继续可用。

    鼓励供应商实施有意义的toString方法。

    许多系统希望在不停止JVM的情况下动态更新时区规则。 当详细研究时，这是一个复杂的问题。 提供商可能会选择处理动态更新，但默认提供程序不会。

    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ZoneRulesProvider​()
      构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static Set<String> getAvailableZoneIds​()
      获取一组可用的区域ID。
      static ZoneRules getRules​(String zoneId, boolean forCaching)
      获取区域ID的规则。
      static NavigableMap<String,ZoneRules> getVersions​(String zoneId)
      获取区域ID的规则历史记录。
      protected boolean provideRefresh​()
      SPI方法从底层数据提供者刷新规则。
      protected abstract ZoneRules provideRules​(String zoneId, boolean forCaching)
      SPI方法获取区域ID的规则。
      protected abstract NavigableMap<String,ZoneRules> provideVersions​(String zoneId)
      SPI方法获取区域ID的规则历史。
      protected abstract Set<String> provideZoneIds​()
      SPI方法获取可用的区域ID。
      static boolean refresh​()
      刷新基础数据提供者的规则。
      static void registerProvider​(ZoneRulesProvider provider)
      注册一个区域规则提供者。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ZoneRulesProvider

        protected ZoneRulesProvider​()
        构造函数。

    • 方法详细信息

      • getAvailableZoneIds

        public static Set<String> getAvailableZoneIds​()
        获取一组可用的区域ID。

        这些ID是ZoneId的字符串形式。

        结果
        不可修改的区域ID集，不为空

      • getRules

        public static ZoneRules getRules​(String zoneId,
                                 boolean forCaching)
        获取区域ID的规则。

        这将返回区域ID的最新可用规则。

        此方法依赖于配置的时区数据提供程序文件。 这些都是使用ServiceLoader加载的。

        缓存标志旨在允许提供者实现来阻止在ZoneId中缓存规则。 在正常情况下，区域规则的缓存是非常可取的，因为它将提供更好的性能。 不过，有一个缓存不可取的用例，见provideRules(java.lang.String, boolean) 。

        参数
        zoneId - 由 ZoneId定义的区域ID，不为空
        forCaching - 是否正在查询规则进行缓存，如果返回的规则将被缓存为 ZoneId ， ZoneId true，否则将返回给用户而不被缓存在 ZoneId
        结果
        规则，如果为 forCaching则为null，这是一个动态提供程序，希望在 ZoneId防止缓存，否则不为空
        异常
        ZoneRulesException - 如果无法获取区域ID的规则

      • getVersions

        public static NavigableMap<String,ZoneRules> getVersions​(String zoneId)
        获取区域ID的规则历史记录。

        时区由政府界定，频繁变化。 该方法允许应用程序查找单个区域ID的规则更改的历史记录。 该地图由字符串键入，该字符串是与规则相关联的版本字符串。

        版本的确切含义和格式是提供者特定的。 版本必须遵循字典顺序，因此返回的地图将从最旧的已知规则到最新的可用规则。 默认的“TZDB”组使用版本编号，其中包含一年后跟一个字母，例如“2009e”或“2012f”。

        实施必须为每个有效的区域ID提供一个结果，但是它们不必提供规则的历史记录。 因此，映射将始终包含一个元素，如果历史规则信息可用，则只包含多个元素。

        参数
        zoneId - 由 ZoneId定义的区域ID，不为空
        结果
        ID的规则的历史的可修改副本，从最旧到最新排序，不为null
        异常
        ZoneRulesException - 如果无法获取区域ID的历史记录

      • registerProvider

        public static void registerProvider​(ZoneRulesProvider provider)
        注册一个区域规则提供者。

        这为当前可用的那个添加了一个新的提供者。 提供者提供一个或多个区域ID的规则。 如果供应商提供已经注册的区域ID，则无法注册提供商。 请参阅ZoneId中关于时区ID的注释 ，特别是关于使用“组”概念使ID独一无二的部分。

        为了确保已经创建的时区的完整性，无法注销提供商。

        参数
        provider - 提供者注册，不为null
        异常
        ZoneRulesException - 如果区域ID已经注册

      • refresh

        public static boolean refresh​()
        刷新基础数据提供者的规则。

        此方法允许应用程序请求提供程序检查提供的规则的任何更新。 调用此方法后，存储在任何ZonedDateTime中的偏移可能对区域ID无效。

        规则的动态更新是一个复杂的问题，大多数应用程序不应该使用这种方法或动态规则。 为了实现动态规则，必须根据该类的规范编写提供者实现。 此外， ZoneRules实例不能缓存在应用程序中，因为它们将变得过时。 但是， provideRules(String, boolean)上的布尔标志允许提供者实现来控制ZoneId的缓存， ZoneId潜在地确保系统中的所有对象都能看到新的规则。 请注意，动态规则提供者的性能可能会很高。 还要注意，在本规范中没有动态规则提供者。

        结果
        如果规则更新，则为true
        异常
        ZoneRulesException - 如果在刷新过程中发生错误

      • provideZoneIds

        protected abstract Set<String> provideZoneIds​()
        SPI方法获取可用的区域ID。

        这获得了这个ZoneRulesProvider提供的ID。 提供者应提供至少一个区域ID的数据。

        返回的区域ID在应用程序的生命周期内保持可用且有效。 当更多的数据变得可用时，动态提供者可以增加ID集合。

        结果
        提供的区域ID集合，不为空
        异常
        ZoneRulesException - 提供ID时是否出现问题

      • provideRules

        protected abstract ZoneRules provideRules​(String zoneId,
                                          boolean forCaching)
        SPI方法获取区域ID的规则。

        这将加载指定区域ID的规则。 提供程序实现必须验证区域ID是否有效和可用，如果不是，则抛出一个ZoneRulesException 。 有效的方法的结果取决于缓存标志。

        如果提供程序实现不是动态的，则方法的结果必须是由ID选择的非空规则集。

        如果提供程序实现是动态的，那么该标志可以选择防止返回的规则在ZoneId中被缓存。 当标志为真时，允许提供者返回null，其中null将阻止规则在ZoneId被缓存。 当标志为false时，提供者必须返回非空规则。

        参数
        zoneId - 由 ZoneId定义的区域ID，不为空
        forCaching - 是否正在查询规则进行缓存，如果返回的规则将被缓存为 ZoneId ， ZoneId true，否则将返回给用户而不被缓存在 ZoneId
        结果
        规则，如果是 forCaching则为null，这是一个动态提供程序，希望在 ZoneId防止缓存，否则不为空
        异常
        ZoneRulesException - 如果无法获取区域ID的规则

      • provideVersions

        protected abstract NavigableMap<String,ZoneRules> provideVersions​(String zoneId)
        SPI方法获取区域ID的规则历史。

        这将返回由版本字符串键入的历史规则的映射。 版本的确切含义和格式是提供者特定的。 版本必须遵循字典顺序，因此返回的地图将从最旧的已知规则到最新的可用规则。 默认的“TZDB”组使用版本编号，其中包含一年后跟一个字母，例如“2009e”或“2012f”。

        实施必须为每个有效的区域ID提供一个结果，但是它们不必提供规则的历史记录。 因此，地图将包含至少一个元素，如果历史规则信息可用，则只包含多个元素。

        返回的版本在应用程序的生命周期内保持可用且有效。 动态提供程序可能会随着更多数据可用而增加版本集。

        参数
        zoneId - 由 ZoneId定义的区域ID，不为空
        结果
        ID的规则的历史的可修改副本，从最旧到最新排序，不为null
        异常
        ZoneRulesException - 如果无法获取区域ID的历史记录

      • provideRefresh

        protected boolean provideRefresh​()
        SPI方法从底层数据提供者刷新规则。

        此方法为提供者提供动态重新检查底层数据提供程序以查找最新规则的机会。 这可以用于加载新规则而不停止JVM。 动态行为是完全可选的，大多数提供商都不支持它。

        此实现返回false。

        结果
        如果规则更新，则为true
        异常
        ZoneRulesException - 如果在刷新过程中发生错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class java.time.zone.ZoneOffsetTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.zone.ZoneOffsetTransition

  • Packages that use ZoneOffsetTransition
    软件包 描述
    java.time.zone
    支持时区及其规则。

    • Uses of ZoneOffsetTransition in java.time.zone

      Methods in java.time.zone that return ZoneOffsetTransition
      Modifier and Type 方法 描述
      ZoneOffsetTransition ZoneOffsetTransitionRule.createTransition​(int year)
      创建指定年份的转换实例。
      ZoneOffsetTransition ZoneRules.getTransition​(LocalDateTime localDateTime)
      在这些规则中获取在指定的本地日期时间中适用的偏移量转换。
      ZoneOffsetTransition ZoneRules.nextTransition​(Instant instant)
      在指定的时刻之后获取下一个转换。
      static ZoneOffsetTransition ZoneOffsetTransition.of​(LocalDateTime transition, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义两个偏移之间的转换的实例。
      ZoneOffsetTransition ZoneRules.previousTransition​(Instant instant)
      获取指定时刻之前的转换。
      Methods in java.time.zone that return types with arguments of type ZoneOffsetTransition
      Modifier and Type 方法 描述
      List<ZoneOffsetTransition> ZoneRules.getTransitions​()
      获取完全定义的转换的完整列表。
      Methods in java.time.zone with parameters of type ZoneOffsetTransition
      Modifier and Type 方法 描述
      int ZoneOffsetTransition.compareTo​(ZoneOffsetTransition transition)
      根据转换时刻将此转换与另一个进行比较。
      Method parameters in java.time.zone with type arguments of type ZoneOffsetTransition
      Modifier and Type 方法 描述
      static ZoneRules ZoneRules.of​(ZoneOffset baseStandardOffset, ZoneOffset baseWallOffset, List<ZoneOffsetTransition> standardOffsetTransitionList, List<ZoneOffsetTransition> transitionList, List<ZoneOffsetTransitionRule> lastRules)
      获取ZoneRules的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.zone.ZoneOffsetTransitionRule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.zone.ZoneOffsetTransitionRule

  • Packages that use ZoneOffsetTransitionRule
    软件包 描述
    java.time.zone
    支持时区及其规则。

    • Uses of ZoneOffsetTransitionRule in java.time.zone

      Methods in java.time.zone that return ZoneOffsetTransitionRule
      Modifier and Type 方法 描述
      static ZoneOffsetTransitionRule ZoneOffsetTransitionRule.of​(Month month, int dayOfMonthIndicator, DayOfWeek dayOfWeek, LocalTime time, boolean timeEndOfDay, ZoneOffsetTransitionRule.TimeDefinition timeDefnition, ZoneOffset standardOffset, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义年度规则以在两个偏移之间创建转换的实例。
      Methods in java.time.zone that return types with arguments of type ZoneOffsetTransitionRule
      Modifier and Type 方法 描述
      List<ZoneOffsetTransitionRule> ZoneRules.getTransitionRules​()
      获得过渡规则列表，超出转换列表中定义的年限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.zone.ZoneOffsetTransitionRule.TimeDefinition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.zone.ZoneOffsetTransitionRule.TimeDefinition

  • Packages that use ZoneOffsetTransitionRule.TimeDefinition
    软件包 描述
    java.time.zone
    支持时区及其规则。

    • Uses of ZoneOffsetTransitionRule.TimeDefinition in java.time.zone

      Methods in java.time.zone that return ZoneOffsetTransitionRule.TimeDefinition
      Modifier and Type 方法 描述
      ZoneOffsetTransitionRule.TimeDefinition ZoneOffsetTransitionRule.getTimeDefinition​()
      获取时间定义，指定如何将时间转换为即时。
      static ZoneOffsetTransitionRule.TimeDefinition ZoneOffsetTransitionRule.TimeDefinition.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ZoneOffsetTransitionRule.TimeDefinition[] ZoneOffsetTransitionRule.TimeDefinition.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.time.zone with parameters of type ZoneOffsetTransitionRule.TimeDefinition
      Modifier and Type 方法 描述
      static ZoneOffsetTransitionRule ZoneOffsetTransitionRule.of​(Month month, int dayOfMonthIndicator, DayOfWeek dayOfWeek, LocalTime time, boolean timeEndOfDay, ZoneOffsetTransitionRule.TimeDefinition timeDefnition, ZoneOffset standardOffset, ZoneOffset offsetBefore, ZoneOffset offsetAfter)
      获取定义年度规则以在两个偏移之间创建转换的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.zone.ZoneRules (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.zone.ZoneRules

  • Packages that use ZoneRules
    软件包 描述
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.zone
    支持时区及其规则。

    • Uses of ZoneRules in java.time

      Methods in java.time that return ZoneRules
      Modifier and Type 方法 描述
      abstract ZoneRules ZoneId.getRules​()
      获取此ID的时区规则，允许执行计算。
      ZoneRules ZoneOffset.getRules​()
      获取相关的时区规则。

    • Uses of ZoneRules in java.time.zone

      Methods in java.time.zone that return ZoneRules
      Modifier and Type 方法 描述
      static ZoneRules ZoneRulesProvider.getRules​(String zoneId, boolean forCaching)
      获取区域ID的规则。
      static ZoneRules ZoneRules.of​(ZoneOffset offset)
      获取具有固定区域规则的ZoneRules实例。
      static ZoneRules ZoneRules.of​(ZoneOffset baseStandardOffset, ZoneOffset baseWallOffset, List<ZoneOffsetTransition> standardOffsetTransitionList, List<ZoneOffsetTransition> transitionList, List<ZoneOffsetTransitionRule> lastRules)
      获取ZoneRules的实例。
      protected abstract ZoneRules ZoneRulesProvider.provideRules​(String zoneId, boolean forCaching)
      SPI方法获取区域ID的规则。
      Methods in java.time.zone that return types with arguments of type ZoneRules
      Modifier and Type 方法 描述
      static NavigableMap<String,ZoneRules> ZoneRulesProvider.getVersions​(String zoneId)
      获取区域ID的规则历史记录。
      protected abstract NavigableMap<String,ZoneRules> ZoneRulesProvider.provideVersions​(String zoneId)
      SPI方法获取区域ID的规则历史。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.zone.ZoneRulesException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.zone.ZoneRulesException

No usage of java.time.zone.ZoneRulesException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.time.zone.ZoneRulesProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.time.zone.ZoneRulesProvider

  • Packages that use ZoneRulesProvider
    软件包 描述
    java.time.zone
    支持时区及其规则。

    • Uses of ZoneRulesProvider in java.time.zone

      Methods in java.time.zone with parameters of type ZoneRulesProvider
      Modifier and Type 方法 描述
      static void ZoneRulesProvider.registerProvider​(ZoneRulesProvider provider)
      注册一个区域规则提供者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AbstractCollection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class AbstractCollection<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
  • All Implemented Interfaces:
    Iterable<E> ， Collection<E>
    已知直接子类：
    AbstractList ， AbstractQueue ， AbstractSet ， ArrayDeque ， ConcurrentLinkedDeque

    public abstract class AbstractCollection<E>
extends Object
implements Collection<E>
    此类提供了Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。

    为了实现一个不可修改的集合，程序员只需要扩展这个类并提供iterator和size方法的实现。 （由iterator方法返回的迭代器必须实现hasNext和next ））

    要实现可修改的集合，程序员必须另外覆盖此类的add方法（否则将抛出一个UnsupportedOperationException ），并且由iterator方法返回的迭代器必须另外实现其remove方法。

    根据Collection接口规范中的建议，程序员通常应该提供一个void（无参数）和Collection构造函数。

    该类中每个非抽象方法的文档详细描述了其实现。 如果正在实施的集合承认更有效的实现，则可以覆盖这些方法中的每一种。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Collection

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractCollection​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      确保此集合包含指定的元素（可选操作）。
      boolean addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合（可选操作）。
      void clear​()
      从此集合中删除所有元素（可选操作）。
      boolean contains​(Object o)
      如果此集合包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> c)
      如果此集合包含指定集合中的所有元素，则返回 true 。
      boolean isEmpty​()
      如果此集合不包含元素，则返回 true 。
      abstract Iterator<E> iterator​()
      返回包含在该集合中的元素的迭代器。
      boolean remove​(Object o)
      从该集合中删除指定元素的单个实例（如果存在）（可选操作）。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      abstract int size​()
      返回此集合中的元素数。
      Object[] toArray​()
      返回一个包含此集合中所有元素的数组。
      <T> T[] toArray​(T[] a)
      返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此集合的字符串表示形式。

      • Methods inherited from interface java.util.Collection

        equals, hashCode, parallelStream, removeIf, spliterator, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractCollection

        protected AbstractCollection​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • iterator

        public abstract Iterator<E> iterator​()
        返回包含在该集合中的元素的迭代器。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        结果
        在这个集合中包含的元素的迭代器

      • size

        public abstract int size​()
        说明从接口Collection复制
        返回此集合中的元素数。 如果此集合包含Integer.MAX_VALUE元素，返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<E>
        结果
        此集合中的元素数

      • isEmpty

        public boolean isEmpty​()
        如果此集合不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        实现要求：
        此实现返回 size() == 0 。
        结果
        true如果此集合不包含元素

      • contains

        public boolean contains​(Object o)
        如果此集合包含指定的元素，则返回true 。 更正式地，返回true当且仅当该集合至少包含一个元素e ，使得Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        实现要求：
        此实现遍历集合中的元素，依次检查每个元素以与指定元素相等。
        参数
        o - 要在此集合中存在的元素要进行测试
        结果
        true如果此集合包含指定的元素
        异常
        ClassCastException - 如果指定元素的类型与此集合不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且此集合不允许空元素（ optional ）

      • toArray

        public Object[] toArray​()
        返回一个包含此集合中所有元素的数组。 如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        返回的数组将是“安全的”，因为该集合不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组，即使这个集合是由数组支持的）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        实现要求：
        此实现返回一个数组，其中包含由该集合的迭代器返回的所有元素，以相同的顺序存储在数组的连续元素中，以索引0 。 返回的数组的长度等于迭代器返回的元素数量，即使该迭代器的大小在迭代期间发生变化，如果该迭代允许在迭代期间同时进行修改，则可能会发生这种情况。 size方法仅作为优化提示调用; 即使迭代器返回不同数量的元素，也会返回正确的结果。

        此方法相当于：

           List<E> list = new ArrayList<E>(size()); for (E e : this) list.add(e); return list.toArray();
        结果
        一个包含此集合中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果集合适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此集合的大小分配一个新数组。

        如果此集合适用于指定的数组， null空间（即，该数组具有比此集合更多的元素），则紧跟在集合结束后的数组中的元素将设置为null 。 （这仅在调用者知道此集合不包含任何null元素的情况下才能确定此集合的长度。）

        如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        像Collection.toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的集合。 以下代码可用于将集合转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        实现要求：
        此实现返回一个数组，该数组包含该集合的迭代器返回的所有元素，以与索引0相同的顺序存储在数组的连续元素中。 如果迭代器返回的元素数量太大而不能适应指定的数组，则元素将返回一个新分配的数组，其长度等于迭代器返回的元素数量，即使此集合的大小更改在迭代期间，如果集合允许在迭代期间同时进行修改，则可能会发生。 size方法仅作为优化提示调用; 即使迭代器返回不同数量的元素，也会返回正确的结果。

        此方法相当于：

           List<E> list = new ArrayList<E>(size()); for (E e : this) list.add(e); return list.toArray(a);
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储此集合的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此集合中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此集合中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • add

        public boolean add​(E e)
        确保此集合包含指定的元素（可选操作）。 如果此集合由于调用而更改，则返回true 。 （如果此集合不允许重复且已包含指定的元素，则返回false ））

        支持此操作的集合可能会限制可能添加到此集合的元素。 特别是，一些集合将拒绝添加null元素，其他集合将对可能添加的元素的类型施加限制。 收集类应在其文档中明确说明可能添加哪些元素的限制。

        如果集合拒绝添加特定的元素，除了它已经包含元素之外，它必须引发异常（而不是返回false ）。 这保留了一个集合在此调用返回后始终包含指定元素的不变量。

        Specified by:
        add在接口 Collection<E>
        实现要求：
        这个实现总是抛出一个 UnsupportedOperationException 。
        参数
        e - 要确保在此集合中的存在的元素
        结果
        true如果此集合由于调用而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 add操作
        ClassCastException - 如果指定元素的类阻止将其添加到此集合
        NullPointerException - 如果指定的元素为空，并且此集合不允许空元素
        IllegalArgumentException - 如果元素的某些属性阻止将其添加到此集合
        IllegalStateException - 如果由于插入限制，此时无法添加该元素

      • remove

        public boolean remove​(Object o)
        从该集合中删除指定元素的单个实例（如果存在）（可选操作）。 更正式地，删除元素e ，使得Objects.equals(o, e) ，如果该集合包含一个或多个这样的元素。 如果此集合包含指定的元素（或等效地，如果此集合由于调用而更改），则返回true 。
        Specified by:
        remove在接口 Collection<E>
        实现要求：
        该实现遍历集合，寻找指定的元素。 如果找到该元素，它将使用迭代器的remove方法从集合中删除该元素。

        请注意，如果此集合的迭代器方法返回的迭代器不实现remove方法，并且此集合包含指定的对象，则此实现将抛出一个UnsupportedOperationException 。

        参数
        o - 要从此集合中删除的元素（如果存在）
        结果
        true如果某个元素因此调用而被删除
        异常
        UnsupportedOperationException - 如果此集合不支持 remove操作
        ClassCastException - 如果指定元素的类型与此集合不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且该集合不允许空元素（ optional ）

      • containsAll

        public boolean containsAll​(Collection<?> c)
        如果此集合包含指定集合中的所有元素，则返回 true 。
        Specified by:
        containsAll在接口 Collection<E>
        实现要求：
        这个实现遍历指定的集合，依次检查迭代器返回的每个元素，以查看它是否包含在该集合中。 如果所有元素都这样包含true返回，否则false 。
        参数
        c - 要在此集合中检查遏制的集合
        结果
        true如果此集合包含指定集合中的所有元素
        异常
        ClassCastException - 如果指定集合中的一个或多个元素的类型与此集合不兼容（ optional ）
        NullPointerException - 如果指定的集合包含一个或多个空元素，并且此集合不允许空元素（ optional ），或者指定的集合为空。
        另请参见：
        contains(Object)

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        将指定集合中的所有元素添加到此集合（可选操作）。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （这意味着如果指定的集合是此集合，此调用的行为是未定义的，并且此集合是非空的。）
        Specified by:
        addAll在接口 Collection<E>
        实现要求：
        这个实现遍历指定的集合，并依次将迭代器返回的每个对象添加到该集合中。

        请注意，除非add被覆盖（假定指定的集合不为空），否则此实现将抛出UnsupportedOperationException 。

        参数
        c - 包含要添加到此集合的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 addAll操作
        ClassCastException - 如果指定集合的元素的类阻止将其添加到此集合
        NullPointerException - 如果指定的集合包含一个空元素，并且此集合不允许空元素，或者如果指定的集合为空
        IllegalArgumentException - 如果指定集合的元素的某些属性阻止将其添加到此集合
        IllegalStateException - 如果不是所有的元素可以由于插入限制而在此时添加
        另请参见：
        add(Object)

      • removeAll

        public boolean removeAll​(Collection<?> c)
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<E>
        实现要求：
        这个实现遍历这个集合，依次检查迭代器返回的每个元素，看看它是否包含在指定的集合中。 如果它是如此包含，它将使用迭代器的remove方法从此集合中删除。

        请注意，如果由iterator方法返回的迭代器不实现remove方法，并且此集合包含与指定集合相同的一个或多个元素，则此实现将抛出UnsupportedOperationException 。

        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 removeAll方法
        ClassCastException - 如果此集合中的一个或多个元素的类型与指定集合不兼容（ optional ）
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object) ， contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        实现要求：
        这个实现遍历这个集合，依次检查迭代器返回的每个元素，看看它是否包含在指定的集合中。 如果没有这样包含，它将使用迭代器的remove方法从该集合中删除。

        请注意，如果由iterator方法返回的迭代器未实现remove方法，并且此集合包含指定集合中不存在的一个或多个元素，则此实现将抛出UnsupportedOperationException 。

        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 retainAll操作
        ClassCastException - 如果此集合中的一个或多个元素的类型与指定的集合不兼容（ optional ）
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object) ， contains(Object)

      • clear

        public void clear​()
        从此集合中删除所有元素（可选操作）。 此方法返回后，集合将为空。
        Specified by:
        clear在接口 Collection<E>
        实现要求：
        此实现遍历此集合，使用Iterator.remove操作删除每个元素。 大多数实现可能会选择覆盖此方法的效率。

        请注意，如果此集合的iterator方法返回的迭代器不实现remove方法，并且此集合不为空，则此实现将抛出一个UnsupportedOperationException 。

        异常
        UnsupportedOperationException - 如果此集合不支持 clear操作

      • toString

        public String toString​()
        返回此集合的字符串表示形式。 字符串表示由集合的元素的列表按照它们的迭代器返回的顺序包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 Object
        结果
        此集合的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class AbstractList<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
  • All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E>
    已知直接子类：
    AbstractSequentialList ， ArrayList ， ObservableListBase ， Vector

    public abstract class AbstractList<E>
extends AbstractCollection<E>
implements List<E>
    该类提供了List接口的骨架实现，以最小化实现由“随机存取”数据存储（如阵列）支持的此接口所需的工作量。 对于顺序访问数据（例如链接列表），应该使用AbstractSequentialList优先于此类。

    要实现一个不可修改的列表，程序员只需要扩展这个类并提供get(int)和size()方法的实现。

    要实现可修改的列表，程序员必须另外覆盖set(int, E)方法（否则将抛出一个UnsupportedOperationException ）。 如果列表是可变大小，则程序员必须另外覆盖add(int, E)和remove(int)方法。

    根据Collection接口规范中的建议，程序员通常应该提供一个void（无参数）和集合构造函数。

    不像其他的抽象集合实现，程序员不必提供迭代器实现; 迭代器和列表迭代器由此类实现的，对的“随机访问”方法顶部： get(int) ， set(int, E) ， add(int, E)和remove(int) 。

    该类中每个非抽象方法的文档详细描述了其实现。 如果正在实施的集合承认更有效的实现，则可以覆盖这些方法中的每一种。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int modCount
      此列表已被 结构修改的次数 。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractList​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void add​(int index, E element)
      将指定的元素插入此列表中的指定位置（可选操作）。
      boolean add​(E e)
      将指定的元素追加到此列表的末尾（可选操作）。
      boolean addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
      void clear​()
      从此列表中删除所有元素（可选操作）。
      boolean equals​(Object o)
      将指定的对象与此列表进行比较以获得相等性。
      abstract E get​(int index)
      返回此列表中指定位置的元素。
      int hashCode​()
      返回此列表的哈希码值。
      int indexOf​(Object o)
      返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。
      Iterator<E> iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      int lastIndexOf​(Object o)
      返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
      ListIterator<E> listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
      E remove​(int index)
      删除该列表中指定位置的元素（可选操作）。
      protected void removeRange​(int fromIndex, int toIndex)
      从此列表中删除所有索引为 fromIndex （包括）和 toIndex之间的元素。
      E set​(int index, E element)
      用指定的元素（可选操作）替换此列表中指定位置的元素。
      List<E> subList​(int fromIndex, int toIndex)
      返回指定的 fromIndex （含）和 toIndex之间的列表部分的视图。

      • Methods inherited from class java.util.AbstractCollection

        addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, size, toArray, toArray, toString

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        addAll, contains, containsAll, isEmpty, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, replaceAll, retainAll, size, sort, spliterator, toArray, toArray

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • modCount

        protected transient int modCount
        此列表已被结构修改的次数 。 结构修改是改变列表大小的那些修改，或以其他方式扰乱它，使得正在进行的迭代可能产生不正确的结果。

        该字段由迭代器和列表迭代器实现使用，由iterator和listIterator方法返回。 如果该字段的值意外更改，迭代器（或列表迭代器）将抛出ConcurrentModificationException响应next ， remove ， previous ， set或者add操作。 这提供了故障快速行为，而不是面对在迭代期间的并发修改的非确定性行为。

        子类使用此字段是可选的。 如果一个子类希望提供故障快速迭代器（和列表迭代器），那么它只需要在其add(int, E)和remove(int)方法（以及它覆盖的任何其他方法导致对列表的结构修改）中增加该字段。 对add(int, E)或remove(int)单个调用必须在此字段中添加不超过一个，否则迭代器（和列表迭代器）将抛出伪造ConcurrentModificationExceptions 。 如果实现不希望提供故障快速迭代器，则该字段可能会被忽略。

    • 构造方法详细信息

      • AbstractList

        protected AbstractList​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • add

        public boolean add​(E e)
        将指定的元素追加到此列表的末尾（可选操作）。

        支持此操作的列表可能会限制可能添加到此列表中的元素。 特别地，一些列表将拒绝添加null元素，而其他列表将对可能添加的元素的类型施加限制。 列表类应在其文档中明确指定可能添加哪些元素的限制。

        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 List<E>
        重写：
        add在 AbstractCollection<E>
        实现要求：
        此实现调用add(size(), e) 。

        请注意，除非add(int, E)被覆盖，否则此实现将抛出UnsupportedOperationException 。

        参数
        e - 要附加到此列表的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        UnsupportedOperationException - 如果此列表不支持 add操作
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的元素为空，并且该列表不允许空元素
        IllegalArgumentException - 如果此元素的某些属性阻止将其添加到此列表中

      • get

        public abstract E get​(int index)
        返回此列表中指定位置的元素。
        Specified by:
        get在接口 List<E>
        参数
        index - 要返回的元素的索引
        结果
        该列表中指定位置的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • set

        public E set​(int index,
             E element)
        用指定的元素（可选操作）替换此列表中指定位置的元素。
        Specified by:
        set在接口 List<E>
        实现要求：
        这个实现总是抛出一个 UnsupportedOperationException 。
        参数
        index - 要替换的元素的索引
        element - 要存储在指定位置的元素
        结果
        该元素以前在指定的位置
        异常
        UnsupportedOperationException - 如果此列表不支持 set操作
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的元素为空，并且该列表不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此列表
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • add

        public void add​(int index,
                E element)
        将指定的元素插入此列表中的指定位置（可选操作）。 将当前位于该位置的元素（如果有）和任何后续元素（向其索引添加一个）移动。
        Specified by:
        add在接口 List<E>
        实现要求：
        这个实现总是抛出一个 UnsupportedOperationException 。
        参数
        index - 要在其中插入指定元素的索引
        element - 要插入的元素
        异常
        UnsupportedOperationException - 如果此列表不支持 add操作
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的元素为空，并且此列表不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此列表中
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • remove

        public E remove​(int index)
        删除该列表中指定位置的元素（可选操作）。 将任何后续元素移动到左侧（从其索引中减去一个元素）。 返回从列表中删除的元素。
        Specified by:
        remove在接口 List<E>
        实现要求：
        这个实现总是抛出一个 UnsupportedOperationException 。
        参数
        index - 要删除的元素的索引
        结果
        该元素以前在指定的位置
        异常
        UnsupportedOperationException - 如果此列表不支持 remove操作
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • indexOf

        public int indexOf​(Object o)
        返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地说，返回指数最低i这样Objects.equals(o, get(i)) ，或-1，如果没有这样的指标。
        Specified by:
        indexOf在接口 List<E>
        实现要求：
        这个实现首先得到一个列表迭代器（带有listIterator() ）。 然后，它遍历列表，直到找到指定的元素或达到列表的结尾。
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的首次出现的索引，如果此列表不包含元素，则为-1
        异常
        ClassCastException - 如果指定元素的类型与此列表不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，此列表不允许空元素（ optional ）

      • lastIndexOf

        public int lastIndexOf​(Object o)
        返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地说，返回满足i这样Objects.equals(o, get(i)) ，或-1，如果没有这样的指标。
        Specified by:
        lastIndexOf在接口 List<E>
        实现要求：
        这个实现首先得到一个列表迭代器，它指向列表的末尾（带有listIterator(size()) ）。 然后，它在列表中向后迭代，直到找到指定的元素，或者到达列表的开头。
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则为-1
        异常
        ClassCastException - 如果指定元素的类型与此列表不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且该列表不允许空元素（ optional ）

      • clear

        public void clear​()
        从此列表中删除所有元素（可选操作）。 此呼叫返回后，列表将为空。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 List<E>
        重写：
        clear在 AbstractCollection<E>
        实现要求：
        此实现调用removeRange(0, size()) 。

        请注意，此实现将抛出UnsupportedOperationException除非remove(int index)或removeRange(int fromIndex, int toIndex)被覆盖。

        异常
        UnsupportedOperationException - 如果此列表不支持 clear操作

      • addAll

        public boolean addAll​(int index,
                      Collection<? extends E> c)
        将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。 将当前位于该位置（如果有的话）的元素和随后的任何元素移动到右边（增加其索引）。 新元素将按照指定集合的迭代器返回的顺序显示在此列表中。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （注意，如果指定的集合是此列表，并且它是非空的，则会发生这种情况。）
        Specified by:
        addAll在接口 List<E>
        实现要求：
        此实现在指定的集合中获取迭代器，并对其进行迭代，将使用add(int, E)将迭代器获取的元素插入到该列表中的适当位置，每次一个。 许多实现将覆盖此方法的效率。

        请注意，此实现将抛出一个UnsupportedOperationException除非add(int, E)被覆盖。

        参数
        index - 从中指定集合插入第一个元素的索引
        c - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        UnsupportedOperationException - 如果此列表不支持 addAll操作
        ClassCastException - 如果指定集合的元素的类阻止将其添加到此列表
        NullPointerException - 如果指定的集合包含一个或多个空元素，并且此列表不允许空元素，或者如果指定的集合为空
        IllegalArgumentException - 如果指定集合的元素的某些属性阻止其添加到此列表
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回该列表中的元素的迭代器。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 List<E>
        Specified by:
        iterator在 AbstractCollection<E>
        实现要求：
        此实现返回一个简单的实现Iterator接口，依托后台列表的size() ， get(int) ，并remove(int)方法。

        请注意，该方法返回的迭代器将抛出一个UnsupportedOperationException，以响应其remove方法，除非列表的remove(int)方法被覆盖。

        这种实现可以在面对并发修改时抛出运行时异常，如（protected） modCount字段的说明中所述。

        结果
        在这个列表中的元素以适当的顺序迭代

      • listIterator

        public ListIterator<E> listIterator​()
        返回列表中的列表迭代器（按适当的顺序）。
        Specified by:
        listIterator在接口 List<E>
        实现要求：
        此实现返回 listIterator(0) 。
        结果
        在列表中的元素的列表迭代器（按适当的顺序）
        另请参见：
        listIterator(int)

      • listIterator

        public ListIterator<E> listIterator​(int index)
        从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。 指定的索引指示由初始调用next返回的第一个元素。 初始调用previous将返回指定索引减1的元素。
        Specified by:
        listIterator在接口 List<E>
        实现要求：
        该实现返回了ListIterator接口的直接实现，扩展了iterator()方法返回的Iterator接口的实现。 该ListIterator实现依赖于后台列表的get(int) ， set(int, E) ， add(int, E)和remove(int)方法。

        请注意，此实现返回的列表迭代器将抛出一个UnsupportedOperationException响应其remove ， set和add方法，除非列表的remove(int) ， set(int, E) ，并add(int, E)方法被覆盖。

        如同（protected） modCount字段的规范中所描述的那样，这种实现可以面对并发修改来抛出运行时异常。

        参数
        index - 要从列表迭代器返回的第一个元素的索引（通过调用 next ）
        结果
        在列表中的元素（按正确顺序）的列表迭代器，从列表中的指定位置开始
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • subList

        public List<E> subList​(int fromIndex,
                       int toIndex)
        返回指定的fromIndex （含）和toIndex之间的列表部分的视图。 （如果fromIndex和toIndex相等，返回的列表为空。）返回的列表由此列表支持，因此返回列表中的非结构更改将反映在此列表中，反之亦然。 返回的列表支持此列表支持的所有可选列表操作。

        该方法消除了对显式范围操作（对于数组通常存在的排序）的需要。 任何期望列表的操作都可以通过传递一个子列表视图而不是整个列表来用作范围操作。 例如，以下成语从列表中移除了一系列元素：

           list.subList(from, to).clear();
        可以为indexOf和lastIndexOf构造类似的成语，并且Collections类中的所有算法都可以应用于子列表。

        如果支持列表（即，此列表）以除了通过返回的列表之外的任何方式进行结构修改 ，则此方法返回的列表的语义将变为未定义。 （结构修改是那些改变此列表的大小，或以其他方式扰乱它，使得正在进行的迭代可能产生不正确的结果）。

        Specified by:
        subList在接口 List<E>
        实现要求：
        此实现返回一个子类AbstractList的列表。 子类门店，在私人领域，subList的大小（可以在其生命周期变化），与预期modCount后台列表的价值。 子类有两个变体，其中一个实现了RandomAccess 。 如果此列表实现RandomAccess则返回的列表将是实现RandomAccess的子类的实例。

        子类的set(int, E) ， get(int) ， add(int, E) ， remove(int) ， addAll(int, Collection)和removeRange(int, int)方法都委托给支持抽象列表上的相应方法，边界检查的指标和调整偏移后。 addAll(Collection c)方法只返回addAll(size, c) 。

        listIterator(int)方法通过支持列表上的列表迭代器返回“包装对象”，后者列表中使用相应的方法创建。 iterator方法只返回listIterator() ，而size方法只返回子类的size字段。

        所有方法首先检查一下后备列表的实际modCount是否等于其预期值，如果不是，则抛出一个ConcurrentModificationException 。

        参数
        fromIndex - 子列表的低端点（含）
        toIndex - 子列表的高端点（排他性）
        结果
        该列表中指定范围的视图
        异常
        IndexOutOfBoundsException - 如果端点索引值超出范围 (fromIndex < 0 || toIndex > size)
        IllegalArgumentException - 如果端点索引不正确 (fromIndex > toIndex)

      • equals

        public boolean equals​(Object o)
        将指定的对象与此列表进行比较以获得相等性。 返回true当且仅当指定的对象也是列表时，两个列表都具有相同的大小，并且两个列表中所有相应的元素对相等 。 （两个元素e1和e2如果为(e1==null ? e2==null : e1.equals(e2)) 等于 (e1==null ? e2==null : e1.equals(e2)) ）。换句话说，如果两个列表以相同的顺序包含相同的元素，则它们被定义为相等。
        Specified by:
        equals在接口 Collection<E>
        Specified by:
        equals在接口 List<E>
        重写：
        equals在 Object
        实现要求：
        此实现首先检查指定的对象是否是此列表。 如果是，则返回true ; 如果不是，它检查指定的对象是否是一个列表。 如果没有，则返回false ; 如果是这样，它会遍历两个列表，比较相应的元素对。 如果任何比较返回false ，此方法返回false 。 如果任何一个迭代器在其他元素之前用尽，则返回false （因为列表长度不等）; 否则返回true当迭代完成。
        参数
        o - 要与此列表相等的对象进行比较
        结果
        true如果指定的对象等于此列表
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此列表的哈希码值。
        Specified by:
        hashCode在接口 Collection<E>
        Specified by:
        hashCode在接口 List<E>
        重写：
        hashCode在 Object
        实现要求：
        此实现在 List.hashCode()方法的文档中完全使用用于定义列表哈希函数的 代码 。
        结果
        该列表的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • removeRange

        protected void removeRange​(int fromIndex,
                           int toIndex)
        从此列表中删除所有索引为fromIndex （含）和toIndex之间的元素。 将任何后续元素移动到左侧（减少其索引）。 此电话(toIndex - fromIndex)列表(toIndex - fromIndex)元素。 （如果是toIndex==fromIndex ，这个操作没有效果）

        此方法由该列表及其子列表中的clear操作调用。 覆盖此方法以利用列表实现的内部结构可以大大提高此列表及其子列表中的clear操作的性能。

        实现要求：
        此实现获取位于fromIndex之前的列表迭代器，并重复调用ListIterator.next后跟ListIterator.remove直到整个范围已被删除。 注意：如果ListIterator.remove需要线性时间，则此实现需要二次时间。
        参数
        fromIndex - 要删除的第一个元素的索引
        toIndex - 要删除的最后一个元素后的索引
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AbstractMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class AbstractMap<K,V>

  • java.lang.Object
    • java.util.AbstractMap<K,V>
  • 参数类型
    K - 由该地图维护的键的类型
    V - 映射值的类型
    All Implemented Interfaces:
    Map<K,V>
    已知直接子类：
    ConcurrentHashMap ， ConcurrentSkipListMap ， EnumMap ， HashMap ， IdentityHashMap ， TreeMap ， WeakHashMap

    public abstract class AbstractMap<K,V>
extends Object
implements Map<K,V>
    该类提供了Map接口的骨架实现，以尽量减少实现此接口所需的工作量。

    为了实现一个不可修改的地图，程序员只需要扩展这个类，并为entrySet方法提供一个实现，该方法返回地图映射的设置视图。 通常，返回的集合将反过来实现在AbstractSet 。 这个集合不应该支持add或者remove方法，而且它的迭代器不应该支持remove方法。

    要实现可修改的映射，程序员必须另外覆盖此类的put方法（否则将抛出一个UnsupportedOperationException ），由entrySet().iterator()返回的迭代器必须另外实现其remove方法。

    根据Map接口规范中的建议，程序员通常应该提供一个void（无参数）和map构造函数。

    该类中每个非抽象方法的文档详细描述了其实现。 如果实施的地图承认更有效的实施，则可以覆盖这些方法中的每一个。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Map ， Collection

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  AbstractMap.SimpleEntry<K,V>
      保存密钥和值的条目。
      static class  AbstractMap.SimpleImmutableEntry<K,V>
      保持一个不变的钥匙和价值的条目。

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractMap​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      从该地图中删除所有的映射（可选操作）。
      protected Object clone​()
      返回此 AbstractMap实例的浅拷贝：键和值本身不被克隆。
      boolean containsKey​(Object key)
      如果此映射包含指定键的映射，则返回 true 。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      abstract Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      boolean equals​(Object o)
      将指定的对象与此映射进行比较以获得相等性。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。
      int hashCode​()
      返回此地图的哈希码值。
      boolean isEmpty​()
      如果此映射不包含键值映射，则返回 true 。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      V put​(K key, V value)
      将指定的值与该映射中的指定键相关联（可选操作）。
      void putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此映射（可选操作）。
      V remove​(Object key)
      如果存在（从可选的操作），从该地图中删除一个键的映射。
      int size​()
      返回此地图中键值映射的数量。
      String toString​()
      返回此地图的字符串表示形式。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, forEach, getOrDefault, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractMap

        protected AbstractMap​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • size

        public int size​()
        返回此地图中键值映射的数量。 如果地图包含Integer.MAX_VALUE元素，返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Map<K,V>
        实现要求：
        此实现返回 entrySet().size() 。
        结果
        该地图中键值映射的数量

      • isEmpty

        public boolean isEmpty​()
        如果此映射不包含键值映射，则返回 true 。
        Specified by:
        isEmpty在接口 Map<K,V>
        实现要求：
        此实现返回 size() == 0 。
        结果
        true如果该地图不包含键值映射

      • containsValue

        public boolean containsValue​(Object value)
        如果此映射将一个或多个键映射到指定的值，则返回true 。 更正式地，返回true如果且仅当此映射包含至少一个映射到值v ，使得Objects.equals(value, v) 。 对于Map接口的大多数实现，此操作可能需要在地图大小的时间线性。
        Specified by:
        containsValue在接口 Map<K,V>
        实现要求：
        该实现迭代超过entrySet()搜索具有指定值的条目。 如果找到这样的条目，则返回true 。 如果迭代结束而没有找到这样的条目，则返回false 。 请注意，此实现需要在地图大小上具有线性时间。
        参数
        value - 要在此地图中存在的值要进行测试
        结果
        true如果该地图将一个或多个键映射到指定的值
        异常
        ClassCastException - 如果该值对于该地图是不合适的类型（ optional ）
        NullPointerException - 如果指定的值为空，并且该映射不允许空值（ optional ）

      • containsKey

        public boolean containsKey​(Object key)
        如果此映射包含指定键的映射，则返回true 。 更正式地说，返回true当且仅当此映射包含一个键的映射关系k这样Objects.equals(key, k) 。 （最多可以有一个这样的映射。）
        Specified by:
        containsKey在接口 Map<K,V>
        实现要求：
        该实现遍历entrySet()搜索具有指定键的条目。 如果找到这样的条目，则返回true 。 如果迭代结束而没有找到这样的条目，则返回false 。 请注意，此实现需要在地图大小上具有线性时间; 许多实现将覆盖此方法。
        参数
        key - 要在此地图中存在的密钥要进行测试
        结果
        true如果此映射包含指定键的映射
        异常
        ClassCastException - 如果密钥是该地图不合适的类型（ optional ）
        NullPointerException - 如果指定的键为空，并且该映射不允许空键（ optional ）

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回null 。

        更正式地，如果此映射包含从密钥映射k到值v使得Objects.equals(key, k) ，则此方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        如果此映射允许空值，则返回值null 不一定表示映射不包含该键的映射; 地图也可能将密钥明确地映射到null 。 可以使用containsKey操作来区分这两种情况。

        Specified by:
        get在接口 Map<K,V>
        实现要求：
        该实现遍历entrySet()搜索具有指定键的条目。 如果找到这样的条目，则返回条目的值。 如果迭代结束而没有找到这样的条目，则返回null 。 请注意，此实现需要在地图大小上具有线性时间; 许多实现将覆盖此方法。
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含键的映射， null
        异常
        ClassCastException - 如果密钥对于此地图是不合适的类型（ optional ）
        NullPointerException - 如果指定的键为空，并且此映射不允许空键（ optional ）

      • put

        public V put​(K key,
             V value)
        将指定的值与该映射中的指定键相关联（可选操作）。 如果映射先前包含了密钥的映射，则旧值将被指定的值替换。 （如果且仅当m.containsKey(k)将返回true则映射m被称为包含关键字k的映射。）
        Specified by:
        put在接口 Map<K,V>
        实现要求：
        这个实现总是抛出一个 UnsupportedOperationException 。
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与key相关联的上一个值，如果null没有映射， key 。 （A null返回也可以表示该地图以前关联的null与key ，如果实现支持null值）
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中
        NullPointerException - 如果指定的键或值为空，并且此映射不允许空值或值
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中

      • remove

        public V remove​(Object key)
        如果存在（从可选的操作），从该地图中删除一个键的映射。 更正式地，如果该映射包含从k键到值v的映射，使得Objects.equals(key, k)删除该映射。 （地图最多可以包含一个这样的映射。）

        返回此映射先前关联该键的值，如果映射不包含关键字的映射，则返回null 。

        如果此映射允许空值，则返回值为null并不一定表示该映射不包含该键的映射; 映射也可能显式地将密钥映射到null 。

        一旦呼叫返回，该映射将不包含指定键的映射。

        Specified by:
        remove在接口 Map<K,V>
        实现要求：
        此实现遍历entrySet()搜索具有指定键的条目。 如果找到这样的条目，它的值是通过其getValue操作获得的，使用迭代器的remove操作将该条目从集合（和背景映射）中remove ，并返回保存的值。 如果迭代结束而没有找到这样的条目，则返回null 。 请注意，此实现需要在地图大小上具有线性时间; 许多实现将覆盖此方法。

        请注意，如果entrySet迭代器不支持remove方法，并且此映射包含指定键的映射，则此实现将抛出UnsupportedOperationException 。

        参数
        key - 要从地图中删除其映射的密钥
        结果
        先前的值相关联 key ，或 null如果没有映射 key 。
        异常
        UnsupportedOperationException - 如果此地图不支持 remove操作
        ClassCastException - 如果密钥对于此地图是不合适的类型（ optional ）
        NullPointerException - 如果指定的键为空，并且此映射不允许空键（ optional ）

      • putAll

        public void putAll​(Map<? extends K,? extends V> m)
        将指定地图的所有映射复制到此映射（可选操作）。 此呼叫的效果等同于在此地图上调用put(k, v)一次，从k关键字k到指定地图中的值v 。 如果在操作进行中修改了指定的地图，则此操作的行为是未定义的。
        Specified by:
        putAll在接口 Map<K,V>
        实现要求：
        此实现将遍历指定的地图entrySet()集合，并为迭代返回的每个条目调用此映射的put操作一次。

        请注意，如果此映射不支持put操作，并且指定的映射是非空的，则此实现将抛出UnsupportedOperationException 。

        参数
        m - 要存储在此地图中的映射
        异常
        UnsupportedOperationException - 如果此地图不支持 putAll操作
        ClassCastException - 如果指定地图中的键或值的类阻止它存储在此映射中
        NullPointerException - 如果指定的地图为空，或者该地图不允许空值或值，并且指定的地图包含空值或值
        IllegalArgumentException - 如果指定地图中的键或值的某些属性阻止其存储在此映射中

      • clear

        public void clear​()
        从该地图中删除所有的映射（可选操作）。 此呼叫返回后，地图将为空。
        Specified by:
        clear在接口 Map<K,V>
        实现要求：
        此实现调用entrySet().clear() 。

        注意，此实现抛出UnsupportedOperationException如果entrySet不支持clear操作。

        异常
        UnsupportedOperationException - 如果此地图不支持 clear操作

      • keySet

        public Set<K> keySet​()
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        keySet在接口 Map<K,V>
        实现要求：
        此实现返回一个子类AbstractSet的集合 。 子类的iterator方法在该映射的entrySet()迭代器上返回“包装对象”。 size方法委托给该地图的size方法和contains方法委托给该地图的containsKey方法。

        该集合是在第一次调用此方法时创建的，并响应所有后续调用而返回。 不执行同步，因此对该方法的多次调用将不会全部返回相同的集合。

        结果
        该地图中包含的键的集合视图

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        values在接口 Map<K,V>
        实现要求：
        此实现返回一个子类AbstractCollection的集合。 子类的iterator方法在该映射的entrySet()迭代器上返回“包装对象”。 size方法将该地图的size方法和contains方法委托给该地图的containsValue方法。

        该集合是在第一次调用此方法时创建的，并响应所有后续调用而返回。 不执行同步，因此对该方法的多次调用将不会全部返回相同的集合。

        结果
        该地图中包含的值的集合视图

      • entrySet

        public abstract Set<Map.Entry<K,V>> entrySet​()
        描述从接口Map复制
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时（除了通过迭代器自己的remove操作或通过迭代器返回的映射条目上的setValue操作之外）修改映射，则迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        entrySet在接口 Map<K,V>
        结果
        该地图中包含的映射的集合视图

      • equals

        public boolean equals​(Object o)
        将指定的对象与此映射进行比较以获得相等性。 如果给定的对象也是一个地图，并且两个地图代表相同的映射，则返回true 。 更正式地，如果m1.entrySet().equals(m2.entrySet()) ，两个地图m1和m2表示相同的映射。 这可以确保equals方法在Map接口的不同实现中正常工作。
        Specified by:
        equals在接口 Map<K,V>
        重写：
        equals在 Object
        实现要求：
        该实现首先检查指定的对象是否是该映射; 如果是，则返回true 。 然后，它检查指定的对象是否是与该映射的大小相同大小的映射; 如果没有，则返回false 。 如果是这样，它会遍历该地图的entrySet集合，并检查指定的地图是否包含该地图包含的每个映射。 如果指定的映射不能包含这样的映射，则返回false 。 如果迭代完成，则返回true 。
        参数
        o - 要与该地图相等的对象
        结果
        true如果指定的对象等于此映射
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此地图的哈希码值。 映射的哈希码被定义为地图entrySet()视图中每个条目的哈希码的总和。 这确保了m1.equals(m2)意味着m1.hashCode()==m2.hashCode()对于任何两个地图m1和m2 ，所要求的一般合同Object.hashCode() 。
        Specified by:
        hashCode在接口 Map<K,V>
        重写：
        hashCode在 Object
        实现要求：
        该实现遍历 entrySet() ，在集合中的每个元素（条目）上调用 hashCode() ，并将结果相加。
        结果
        该地图的哈希码值
        另请参见：
        Map.Entry.hashCode() ，
Object.equals(Object) ，
Set.equals(Object)

      • toString

        public String toString​()
        返回此地图的字符串表示形式。 字符串表示由地图entrySet视图的迭代器返回的顺序的键值映射列表（括在大括号中）（ "{}" ）组成。 相邻的映射由字符", " （逗号和空格）分隔。 每个键值映射都作为键后跟一个等号（ "=" ），后跟相关值。 键和值将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 Object
        结果
        该地图的字符串表示形式

      • clone

        protected Object clone​()
                throws CloneNotSupportedException
        返回此 AbstractMap实例的浅拷贝：键和值本身不被克隆。
        重写：
        clone在 Object
        结果
        这张地图的浅拷贝
        异常
        CloneNotSupportedException - 如果对象的类不支持Cloneable接口。 覆盖clone方法的子类也可以抛出此异常以指示实例无法克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractMap.SimpleEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class AbstractMap.SimpleEntry<K,V>

  • java.lang.Object
    • java.util.AbstractMap.SimpleEntry<K,V>
  • All Implemented Interfaces:
    Serializable ， Map.Entry<K,V>
    Enclosing class:
    AbstractMap < K ， V >

    public static class AbstractMap.SimpleEntry<K,V>
extends Object
implements Map.Entry<K,V>, Serializable
    保存密钥和值的条目。 该值可能会使用setValue方法更改。 这个类促进了构建自定义地图实现的过程。 例如，在方法Map.entrySet().toArray返回SimpleEntry实例的数组可能很方便。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleEntry​(Map.Entry<? extends K,? extends V> entry)
      创建表示与指定条目相同的映射的条目。
      SimpleEntry​(K key, V value)
      创建表示从指定键到指定值的映射的条目。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此条目进行比较以获得相等性。
      K getKey​()
      返回与此条目相对应的键。
      V getValue​()
      返回与此条目相对应的值。
      int hashCode​()
      返回此映射条目的哈希码值。
      V setValue​(V value)
      用指定的值替换与该条目相对应的值。
      String toString​()
      返回此映射条目的字符串表示形式。

      • Methods inherited from interface java.util.Map.Entry

        comparingByKey, comparingByKey, comparingByValue, comparingByValue

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SimpleEntry

        public SimpleEntry​(K key,
                   V value)
        创建表示从指定键到指定值的映射的条目。
        参数
        key - 由此条目代表的密钥
        value - 由此条目表示的值

      • SimpleEntry

        public SimpleEntry​(Map.Entry<? extends K,? extends V> entry)
        创建表示与指定条目相同的映射的条目。
        参数
        entry - 复制条目

    • 方法详细信息

      • getKey

        public K getKey​()
        返回与此条目相对应的键。
        Specified by:
        getKey在接口 Map.Entry<K,V>
        结果
        与此条目相对应的键

      • getValue

        public V getValue​()
        返回与此条目相对应的值。
        Specified by:
        getValue在接口 Map.Entry<K,V>
        结果
        与此条目对应的值

      • setValue

        public V setValue​(V value)
        用指定的值替换与该条目相对应的值。
        Specified by:
        setValue在接口 Map.Entry<K,V>
        参数
        value - 要存储在此条目中的新值
        结果
        旧值对应的条目

      • equals

        public boolean equals​(Object o)
        将指定的对象与此条目进行比较以获得相等性。 如果给定对象也是映射条目，则返回true ，并且两个条目表示相同的映射。 更正式地，两个条目e1和e2表示相同的映射
          (e1.getKey()==null ?
    e2.getKey()==null :
    e1.getKey().equals(e2.getKey()))
   &&
   (e1.getValue()==null ?
    e2.getValue()==null :
    e1.getValue().equals(e2.getValue()))
        这可以确保equals方法在Map.Entry接口的不同实现中正常工作。
        Specified by:
        equals在接口 Map.Entry<K,V>
        重写：
        equals在 Object
        参数
        o - 要与该地图条目相等的对象
        结果
        true如果指定的对象等于此映射条目
        另请参见：
        hashCode()

      • hashCode

        public int hashCode​()
        返回此映射条目的哈希码值。 地图条目e的哈希码被定义为：
          (e.getKey()==null   ? 0 : e.getKey().hashCode()) ^
   (e.getValue()==null ? 0 : e.getValue().hashCode())
        这确保e1.equals(e2)意味着e1.hashCode()==e2.hashCode()对于任何两个条目e1和e2 ，根据e2的一般合同要求 。
        Specified by:
        hashCode在接口 Map.Entry<K,V>
        重写：
        hashCode在 Object
        结果
        该地图条目的哈希码值
        另请参见：
        equals(java.lang.Object)

      • toString

        public String toString​()
        返回此映射条目的字符串表示形式。 此实现返回此条目的键的字符串表示形式，后跟等号字符（“ = ”），后跟该条目值的字符串表示形式。
        重写：
        toString在 Object
        结果
        该地图条目的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractMap.SimpleImmutableEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class AbstractMap.SimpleImmutableEntry<K,V>

  • java.lang.Object
    • java.util.AbstractMap.SimpleImmutableEntry<K,V>
  • All Implemented Interfaces:
    Serializable ， Map.Entry<K,V>
    Enclosing class:
    AbstractMap < K ， V >

    public static class AbstractMap.SimpleImmutableEntry<K,V>
extends Object
implements Map.Entry<K,V>, Serializable
    保持一个不变的钥匙和价值的条目。 此类不支持方法setValue 。 该类可以方便地返回键值映射的线程安全快照。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleImmutableEntry​(Map.Entry<? extends K,? extends V> entry)
      创建表示与指定条目相同的映射的条目。
      SimpleImmutableEntry​(K key, V value)
      创建表示从指定键到指定值的映射的条目。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此条目进行比较以获得相等性。
      K getKey​()
      返回与此条目相对应的键。
      V getValue​()
      返回与此条目相对应的值。
      int hashCode​()
      返回此映射条目的哈希码值。
      V setValue​(V value)
      用指定的值替换与该条目相对应的值（可选操作）。
      String toString​()
      返回此映射条目的字符串表示形式。

      • Methods inherited from interface java.util.Map.Entry

        comparingByKey, comparingByKey, comparingByValue, comparingByValue

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SimpleImmutableEntry

        public SimpleImmutableEntry​(K key,
                            V value)
        创建表示从指定键到指定值的映射的条目。
        参数
        key - 此条目所代表的密钥
        value - 由此条目表示的值

      • SimpleImmutableEntry

        public SimpleImmutableEntry​(Map.Entry<? extends K,? extends V> entry)
        创建表示与指定条目相同的映射的条目。
        参数
        entry - 要复制的条目

    • 方法详细信息

      • getKey

        public K getKey​()
        返回与此条目相对应的键。
        Specified by:
        getKey在接口 Map.Entry<K,V>
        结果
        与此条目相对应的键

      • getValue

        public V getValue​()
        返回与此条目相对应的值。
        Specified by:
        getValue在接口 Map.Entry<K,V>
        结果
        与此条目对应的值

      • setValue

        public V setValue​(V value)
        用指定的值替换与该条目相对应的值（可选操作）。 这个实现只是抛出UnsupportedOperationException ，因为这个类实现了一个不可变的地图条目。
        Specified by:
        setValue在接口 Map.Entry<K,V>
        参数
        value - 要存储在此条目中的新值
        结果
        （不返回）
        异常
        UnsupportedOperationException - 永远

      • equals

        public boolean equals​(Object o)
        将指定的对象与此条目进行比较以获得相等性。 如果给定对象也是映射条目，则返回true ，并且两个条目表示相同的映射。 更正式地，两个条目e1和e2表示相同的映射
          (e1.getKey()==null ?
    e2.getKey()==null :
    e1.getKey().equals(e2.getKey()))
   &&
   (e1.getValue()==null ?
    e2.getValue()==null :
    e1.getValue().equals(e2.getValue()))
        这可以确保equals方法在Map.Entry接口的不同实现中正常工作。
        Specified by:
        equals在接口 Map.Entry<K,V>
        重写：
        equals在 Object
        参数
        o - 要与此地图条目相等的对象进行比较
        结果
        true如果指定的对象等于此映射条目
        另请参见：
        hashCode()

      • hashCode

        public int hashCode​()
        返回此映射条目的哈希码值。 地图条目e的哈希码被定义为：
          (e.getKey()==null   ? 0 : e.getKey().hashCode()) ^
   (e.getValue()==null ? 0 : e.getValue().hashCode())
        这确保e1.equals(e2)意味着e1.hashCode()==e2.hashCode()对于任何两个条目e1和e2 ，根据e2的一般合同的要求 。
        Specified by:
        hashCode在接口 Map.Entry<K,V>
        重写：
        hashCode在 Object
        结果
        该地图条目的哈希码值
        另请参见：
        equals(java.lang.Object)

      • toString

        public String toString​()
        返回此映射条目的字符串表示形式。 此实现返回此条目的键的字符串表示形式，后跟等号字符（“ = ”），后跟该条目值的字符串表示形式。
        重写：
        toString在 Object
        结果
        a String representation of this map entry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class AbstractQueue<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
  • 参数类型
    E - 保存在此队列中的元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Queue<E>
    已知直接子类：
    ArrayBlockingQueue ， ConcurrentLinkedQueue ， DelayQueue ， LinkedBlockingDeque ， LinkedBlockingQueue ， LinkedTransferQueue ， PriorityBlockingQueue ， PriorityQueue ， SynchronousQueue

    public abstract class AbstractQueue<E>
extends AbstractCollection<E>
implements Queue<E>
    这个类提供了大约Queue操作的骨架实现。 当基实现不允许在这个类的实现方式是合适null元件。 方法add ， remove ，并element基于offer ， poll ，并peek ，分别，但抛出异常而不是通过指示故障false或者null回报。

    甲Queue扩展此类实现必须最低限度地限定的方法Queue.offer(E)它不允许插入null元素，用方法一起Queue.peek() ， Queue.poll() ， Collection.size() ，和Collection.iterator() 。 通常，其他方法也将被覆盖。 如果无法满足这些要求，请考虑将其分类为AbstractCollection 。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractQueue​()
      子类使用的构造方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素插入此队列中，如果它是立即可行且不会违反容量限制，返回 true在成功和抛出 IllegalStateException ，如果当前没有空间可用。
      boolean addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此队列中。
      void clear​()
      从此队列中删除所有元素。
      E element​()
      检索，但不删除，这个队列的头。
      E remove​()
      检索并删除此队列的头。

      • Methods inherited from class java.util.AbstractCollection

        contains, containsAll, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray, toString

      • Methods inherited from interface java.util.Collection

        contains, containsAll, equals, hashCode, isEmpty, iterator, parallelStream, remove, removeAll, removeIf, retainAll, size, spliterator, stream, toArray, toArray

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Queue

        offer, peek, poll

    • 构造方法详细信息

      • AbstractQueue

        protected AbstractQueue​()
        子类使用的构造方法。

    • 方法详细信息

      • add

        public boolean add​(E e)
        将指定的元素插入到此队列中，如果可以立即执行此操作而不违反容量限制， true成功返回true ，如果当前没有可用空间，则抛出IllegalStateException 。

        如果offer成功，则此实现返回true ，否则抛出IllegalStateException 。

        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractCollection<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空，并且此队列不允许空元素
        IllegalArgumentException - 如果此元素的某些属性阻止将其添加到此队列

      • remove

        public E remove​()
        检索并删除此队列的头。 此方法与poll不同之处在于，如果此队列为空，它将抛出异常。

        此实现返回poll的结果，除非队列为空。

        Specified by:
        remove在接口 Queue<E>
        结果
        这个队列的头
        异常
        NoSuchElementException - 如果此队列为空

      • element

        public E element​()
        检索，但不删除，这个队列的头。 此方法与peek不同之处在于，如果此队列为空，它将抛出异常。

        此实现返回peek的结果，除非队列为空。

        Specified by:
        element在接口 Queue<E>
        结果
        这个队列的头
        异常
        NoSuchElementException - 如果这个队列是空的

      • clear

        public void clear​()
        从此队列中删除所有元素。 此呼叫返回后队列将为空。

        此实现重复调用poll，直到它返回null 。

        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractCollection<E>

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        将指定集合中的所有元素添加到此队列中。 尝试将所有队列添加到自身中会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。

        这个实现遍历指定的集合，并依次将迭代器返回的每个元素添加到此队列中。 尝试添加元素（包括特别是null元素）时遇到的运行时异常可能会导致在引发关联异常时只有部分元素已成功添加。

        Specified by:
        addAll在接口 Collection<E>
        重写：
        addAll在 AbstractCollection<E>
        参数
        c - 包含要添加到此队列的元素的集合
        结果
        true如果此队列由于调用而更改
        异常
        ClassCastException - 如果指定集合的元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的集合包含空元素，并且此队列不允许空元素，或者如果指定的集合为空
        IllegalArgumentException - 如果指定集合的元素的某些属性阻止将其添加到此队列中，或者指定的集合是此队列
        IllegalStateException - 如果不是所有的元素都可以由于插入限制在这个时候被添加
        另请参见：
        add(Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractSequentialList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class AbstractSequentialList<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • java.util.AbstractSequentialList<E>
  • All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E>
    已知直接子类：
    LinkedList

    public abstract class AbstractSequentialList<E>
extends AbstractList<E>
    该类提供了List接口的骨架实现，以最小化实现由“顺序访问”数据存储（如链表）支持的此接口所需的工作量。 对于随机访问数据（如数组），应使用AbstractList优先于此类。

    这个类是相反AbstractList在某种意义上类，它实现了“随机访问”方法（ get(int index) ， set(int index, E element) ， add(int index, E element)和remove(int index)上列表的列表迭代器的顶部），而不是周围的其他方法。

    为了实现一个列表，程序员只需要扩展这个类并提供listIterator和size方法的实现。 对于一个不可修改的列表，程序员只需要实现列表迭代器的hasNext ， next ， hasPrevious ， previous和index方法。

    对于可修改的列表，程序员应该另外实现列表迭代器的set方法。 对于可变大小的列表，程序员还应该实现列表迭代器的remove和add方法。

    根据Collection接口规范中的建议，程序员通常应该提供一个void（无参数）和集合构造函数。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， List ， AbstractList ， AbstractCollection

    • Field Summary

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractSequentialList​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void add​(int index, E element)
      将指定的元素插入此列表中的指定位置（可选操作）。
      boolean addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
      E get​(int index)
      返回此列表中指定位置的元素。
      Iterator<E> iterator​()
      返回此列表中的元素的迭代器（按适当的顺序）。
      abstract ListIterator<E> listIterator​(int index)
      返回列表中的列表迭代器（按适当的顺序）。
      E remove​(int index)
      删除该列表中指定位置的元素（可选操作）。
      E set​(int index, E element)
      用指定的元素（可选操作）替换此列表中指定位置的元素。

      • Methods inherited from class java.util.AbstractCollection

        addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, size, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractList

        add, clear, equals, hashCode, indexOf, lastIndexOf, listIterator, removeRange, subList

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        addAll, contains, containsAll, isEmpty, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, replaceAll, retainAll, size, sort, spliterator, toArray, toArray

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractSequentialList

        protected AbstractSequentialList​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • get

        public E get​(int index)
        返回此列表中指定位置的元素。

        此实现首先获取指向索引元素的列表迭代器（具有listIterator(index) ）。 然后，它使用ListIterator.next获取元素并返回。

        Specified by:
        get在接口 List<E>
        Specified by:
        get在 AbstractList<E>
        参数
        index - 要返回的元素的索引
        结果
        该列表中指定位置的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • set

        public E set​(int index,
             E element)
        用指定的元素（可选操作）替换此列表中指定位置的元素。

        这个实现首先得到一个指向索引元素的列表迭代器（带有listIterator(index) ）。 然后，利用获取当前元素ListIterator.next ，并会将其替换为ListIterator.set 。

        注意，此实现将抛出UnsupportedOperationException如果列表迭代器没有实现set操作。

        Specified by:
        set在接口 List<E>
        重写：
        set在 AbstractList<E>
        参数
        index - 要替换的元素的索引
        element - 要存储在指定位置的元素
        结果
        该元素以前在指定的位置
        异常
        UnsupportedOperationException - 如果此列表不支持 set操作
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的元素为空，并且此列表不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此列表中
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • add

        public void add​(int index,
                E element)
        将指定的元素插入此列表中的指定位置（可选操作）。 将当前位于该位置的元素（如果有）和任何后续元素（向其索引添加一个）移动。

        此实现首先获取指向索引元素的列表迭代器（具有listIterator(index) ）。 然后，它将使用ListIterator.add插入指定的元素。

        注意，此实现将抛出UnsupportedOperationException如果列表迭代器没有实现add操作。

        Specified by:
        add在接口 List<E>
        重写：
        add在 AbstractList<E>
        参数
        index - 要插入指定元素的索引
        element - 要插入的元素
        异常
        UnsupportedOperationException - 如果此列表不支持 add操作
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的元素为空，并且该列表不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此列表中
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • remove

        public E remove​(int index)
        删除该列表中指定位置的元素（可选操作）。 将任何后续元素移动到左侧（从其索引中减去一个元素）。 返回从列表中删除的元素。

        该实现首先获得指向索引元素的列表迭代器（具有listIterator(index) ）。 然后，它用ListIterator.remove删除元素。

        注意，此实现将抛出UnsupportedOperationException如果列表迭代器没有实现remove操作。

        Specified by:
        remove在接口 List<E>
        重写：
        remove在 AbstractList<E>
        参数
        index - 要删除的元素的索引
        结果
        该元素以前在指定的位置
        异常
        UnsupportedOperationException - 如果此列表不支持 remove操作
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • addAll

        public boolean addAll​(int index,
                      Collection<? extends E> c)
        将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。 将当前位于该位置（如果有的话）的元素和随后的任何元素移动到右边（增加其索引）。 新元素将按照指定集合的迭代器返回的顺序显示在此列表中。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （注意，如果指定的集合是此列表，并且它是非空的，则会发生这种情况。）

        此实现在指定的集合上获取迭代器，并在此列表上指向列表迭代器，指向索引元素（具有listIterator(index) ）。 然后，它迭代指定的集合，将从迭代器获取的元素插入到此列表中，一次一个，使用ListIterator.add然后是ListIterator.next （跳过添加的元素）。

        注意，此实现将抛出UnsupportedOperationException如果返回的列表迭代listIterator方法没有实现add操作。

        Specified by:
        addAll在接口 List<E>
        重写：
        addAll在 AbstractList<E>
        参数
        index - 从中指定集合插入第一个元素的索引
        c - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        UnsupportedOperationException - 如果此列表不支持 addAll操作
        ClassCastException - 如果指定集合的元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的集合包含一个或多个空元素，并且此列表不允许空元素，或者如果指定的集合为空
        IllegalArgumentException - 如果指定集合的元素的某些属性阻止其添加到此列表中
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • iterator

        public Iterator<E> iterator​()
        返回此列表中的元素的迭代器（按适当的顺序）。

        该实现只返回列表中的列表迭代器。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 List<E>
        重写：
        iterator在 AbstractList<E>
        结果
        在该列表中的元素的迭代器（按适当的顺序）

      • listIterator

        public abstract ListIterator<E> listIterator​(int index)
        返回列表中的列表迭代器（按适当的顺序）。
        Specified by:
        listIterator在接口 List<E>
        重写：
        listIterator在 AbstractList<E>
        参数
        index - 要从列表迭代器返回的第一个元素的索引（通过调用 next方法）
        结果
        在列表中的元素的列表迭代器（按适当的顺序）
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class AbstractSet<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractSet<E>
  • 参数类型
    E - 由此集合维护的元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Set<E>
    已知直接子类：
    ConcurrentSkipListSet ， CopyOnWriteArraySet ， EnumSet ， HashSet ， TreeSet

    public abstract class AbstractSet<E>
extends AbstractCollection<E>
implements Set<E>
    此类提供了Set接口的骨架实现，以尽量减少实现此接口所需的工作量。

    通过扩展此类实现集合的过程与通过扩展AbstractCollection实现集合的过程相同，除了此类的子类中的所有方法和构造函数都必须遵守由Set接口施加的附加约束（例如，添加方法不能允许将一个对象的多个实例添加到集合中）。

    请注意，此类不会覆盖AbstractCollection类中的任何实现。 它只是添加了equals和hashCode 。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， AbstractCollection ， Set

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractSet​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此集合进行比较以实现相等。
      int hashCode​()
      返回此集合的哈希码值。
      boolean removeAll​(Collection<?> c)
      从此集合中删除指定集合中包含的所有元素（可选操作）。

      • Methods inherited from class java.util.AbstractCollection

        add, addAll, clear, contains, containsAll, isEmpty, iterator, remove, retainAll, size, toArray, toArray, toString

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, retainAll, size, spliterator, toArray, toArray

    • 构造方法详细信息

      • AbstractSet

        protected AbstractSet​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • equals

        public boolean equals​(Object o)
        将指定的对象与此集合进行比较以实现相等。 如果给定的对象也是一个集合，则返回true ，这两个集合的大小相同，给定集合的每个成员都包含在该集合中。 这可以确保equals方法在Set接口的不同实现中正常工作。

        该实现首先检查指定的对象是否是该集合; 如果是，则返回true 。 然后，它检查指定的对象是否是与该集合的大小相同的集合; 如果没有，则返回false。 如果是，则返回containsAll((Collection) o) 。

        Specified by:
        equals在接口 Collection<E>
        Specified by:
        equals在接口 Set<E>
        重写：
        equals在 Object
        参数
        o - 要与该集合相等的对象进行比较
        结果
        如果指定的对象等于此集合， true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此集合的哈希码值。 集合的哈希码被定义为集合中的元素的哈希码的和，其中null元素的哈希码被定义为零。 这确保s1.equals(s2)意味着s1.hashCode()==s2.hashCode()对于任何两套s1和s2 ，根据s2的一般合同要求 。

        该实现遍历集合，在hashCode中的每个元素上调用hashCode方法，并将结果相加。

        Specified by:
        hashCode在接口 Collection<E>
        Specified by:
        hashCode在接口 Set<E>
        重写：
        hashCode在 Object
        结果
        该集合的哈希码值
        另请参见：
        Object.equals(Object) ， Set.equals(Object)

      • removeAll

        public boolean removeAll​(Collection<?> c)
        从此集合中删除指定集合中包含的所有元素（可选操作）。 如果指定的集合也是集合，则该操作有效地修改该集合，使其值是两组的非对称集合差异 。

        该实现通过调用每个集合的size方法来确定哪个是该集合和指定的集合中的size一个。 如果此集合具有较少的元素，则实现将遍历该集合，依次检查迭代器返回的每个元素，以查看它是否包含在指定的集合中。 如果它是如此包含，它将使用迭代器的remove方法从该集合中删除。 如果指定的集合具有较少的元素，则实现将遍历指定的集合，从该集合中删除迭代器返回的每个元素，使用该集合的remove方法。

        注意，此实现将抛出UnsupportedOperationException如果返回的迭代器iterator方法没有实现remove方法。

        Specified by:
        removeAll在接口 Collection<E>
        Specified by:
        removeAll在接口 Set<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 包含要 c集合中删除的元素的集合
        结果
        true如果此设置由于呼叫而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 removeAll操作
        ClassCastException - 如果此集合的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此集合包含一个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ArrayDeque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class ArrayDeque<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.ArrayDeque<E>
  • 参数类型
    E - 在这个deque持有的元素的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， Deque<E> ， Queue<E>

    public class ArrayDeque<E>
extends AbstractCollection<E>
implements Deque<E>, Cloneable, Serializable
    Deque接口的可调整大小的数组实现。 数组deques没有容量限制; 他们根据需要增长以支持使用。 它们不是线程安全的; 在没有外部同步的情况下，它们不支持多线程的并发访问。 零元素被禁止。 当用作堆栈时， 此类可能比Stack更快，并且当用作队列时快于LinkedList 。

    大多数ArrayDeque操作以摊销的恒定时间运行。 例外包括remove ， removeFirstOccurrence ， removeLastOccurrence ， contains ， iterator.remove() ，和批量操作，所有这些都在运行线性时间。

    此类的iterator方法返回的迭代器是故障快速的 ：如果在迭代器创建之后的任何时候修改了deque，除了通过迭代器自己的remove方法之外，迭代器通常会抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速迭代器ConcurrentModificationException抛出ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    该类及其迭代器实现Collection和Iterator接口的所有可选方法。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ArrayDeque​()
      构造一个空数组deque，初始容量足以容纳16个元素。
      ArrayDeque​(int numElements)
      构造一个空数组deque，初始容量足以容纳指定数量的元素。
      ArrayDeque​(Collection<? extends E> c)
      构造一个包含指定集合的元素的deque，按照它们由集合的迭代器返回的顺序。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      在此deque的末尾插入指定的元素。
      boolean addAll​(Collection<? extends E> c)
      在指定集合的末尾添加指定集合中的所有元素，如同通过按集合的迭代器返回的顺序调用每个 元素addLast(E) 。
      void addFirst​(E e)
      在此deque前面插入指定的元素。
      void addLast​(E e)
      在此deque的末尾插入指定的元素。
      void clear​()
      从这个deque中删除所有的元素。
      ArrayDeque<E> clone​()
      返回此deque的副本。
      boolean contains​(Object o)
      如果此deque包含指定的元素，则返回 true 。
      Iterator<E> descendingIterator​()
      以相反的顺序返回此deque中的元素的迭代器。
      E element​()
      检索，但不删除，由这个deque表示的队列的头。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。
      E getFirst​()
      检索，但不删除，这个deque的第一个元素。
      E getLast​()
      检索，但不删除，这个deque的最后一个元素。
      boolean isEmpty​()
      如果此deque不包含元素，则返回 true 。
      Iterator<E> iterator​()
      返回此deque中的元素的迭代器。
      boolean offer​(E e)
      在此deque的末尾插入指定的元素。
      boolean offerFirst​(E e)
      在此deque前面插入指定的元素。
      boolean offerLast​(E e)
      在此deque的末尾插入指定的元素。
      E peek​()
      检索但不删除由此deque表示的队列的头，或者如果此deque为空，则返回 null 。
      E peekFirst​()
      检索但不删除此deque的第一个元素，如果此deque为空，则返回 null 。
      E peekLast​()
      检索但不删除此deque的最后一个元素，如果此deque为空，则返回 null 。
      E poll​()
      检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），或者如果此deque为空，则返回 null 。
      E pollFirst​()
      检索并删除此deque的第一个元素，如果此deque为空，则返回 null 。
      E pollLast​()
      检索并删除此deque的最后一个元素，如果此deque为空，则返回 null 。
      E pop​()
      从这个deque表示的堆栈中弹出一个元素。
      void push​(E e)
      将元素推送到由此deque表示的堆栈上。
      E remove​()
      检索并删除由此deque表示的队列的头部。
      boolean remove​(Object o)
      从此deque中删除指定元素的单个实例。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      E removeFirst​()
      检索并删除此deque的第一个元素。
      boolean removeFirstOccurrence​(Object o)
      删除此deque中指定元素的第一个出现（从头到尾遍历deque时）。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      E removeLast​()
      检索并删除此deque的最后一个元素。
      boolean removeLastOccurrence​(Object o)
      删除此deque中指定元素的最后一次（从头到尾遍历deque时）。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此deque中的元素数。
      Spliterator<E> spliterator​()
      在此deque中的元素上创建一个late-binding和失败快速的 Spliterator 。
      Object[] toArray​()
      以适当的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）。
      <T> T[] toArray​(T[] a)
      以正确的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

      • Methods inherited from class java.util.AbstractCollection

        containsAll, toString

      • Methods inherited from interface java.util.Collection

        containsAll, equals, hashCode, parallelStream, stream

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ArrayDeque

        public ArrayDeque​()
        构造一个空数组deque，初始容量足以容纳16个元素。

      • ArrayDeque

        public ArrayDeque​(int numElements)
        构造一个空数组deque，初始容量足以容纳指定数量的元素。
        参数
        numElements - deque初始容量的下限

      • ArrayDeque

        public ArrayDeque​(Collection<? extends E> c)
        构造一个包含指定集合的元素的deque，按照它们由集合的迭代器返回的顺序。 （集合的迭代器返回的第一个元素成为第一个元素，或者是deque的前面 ）
        参数
        c - 其元素将被放 c的集合
        异常
        NullPointerException - 如果指定的集合为空

    • 方法详细信息

      • addFirst

        public void addFirst​(E e)
        在此deque前面插入指定的元素。
        Specified by:
        addFirst在接口 Deque<E>
        参数
        e - 要添加的元素
        异常
        NullPointerException - 如果指定的元素为空

      • addLast

        public void addLast​(E e)
        在此deque的末尾插入指定的元素。

        这个方法相当于add(int, int, int) 。

        Specified by:
        addLast在接口 Deque<E>
        参数
        e - 要添加的元素
        异常
        NullPointerException - 如果指定的元素为空

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        在指定集合的末尾添加指定集合中的所有元素，如同通过按照集合的迭代器返回的顺序调用每个 元素addLast(E)一样 。
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 Deque<E>
        重写：
        addAll在 AbstractCollection<E>
        参数
        c - 要插入此deque的元素
        结果
        true如果这个deque由于调用而改变了
        异常
        NullPointerException - 如果指定的集合或其任何元素为空
        另请参见：
        AbstractCollection.add(Object)

      • offerFirst

        public boolean offerFirst​(E e)
        在此deque前面插入指定的元素。
        Specified by:
        offerFirst在接口 Deque<E>
        参数
        e - 要添加的元素
        结果
        true （由 Deque.offerFirst(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • offerLast

        public boolean offerLast​(E e)
        在此deque的末尾插入指定的元素。
        Specified by:
        offerLast在接口 Deque<E>
        参数
        e - 要添加的元素
        结果
        true （由 Deque.offerLast(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • removeFirst

        public E removeFirst​()
        说明从接口Deque复制
        检索并删除此deque的第一个元素。 此方法与pollFirst不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        removeFirst在接口 Deque<E>
        结果
        这个德克的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • removeLast

        public E removeLast​()
        描述从接口Deque复制
        检索并删除此deque的最后一个元素。 该方法与pollLast的区别在于，如果此deque为空，它将抛出异常。
        Specified by:
        removeLast在接口 Deque<E>
        结果
        这个德克的尾巴
        异常
        NoSuchElementException - 如果这个deque是空的

      • pollFirst

        public E pollFirst​()
        描述从接口Deque复制
        检索并删除此deque的第一个元素，如果此deque为空，则返回 null 。
        Specified by:
        pollFirst在接口 Deque<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • pollLast

        public E pollLast​()
        说明从界面Deque复制
        检索并删除此deque的最后一个元素，如果此deque为空，则返回 null 。
        Specified by:
        pollLast在接口 Deque<E>
        结果
        这个deque的尾巴，或 null如果这个deque是空的

      • getFirst

        public E getFirst​()
        说明从接口Deque复制
        检索，但不删除，这个deque的第一个元素。 此方法与peekFirst不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        getFirst在接口 Deque<E>
        结果
        这个德克的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • getLast

        public E getLast​()
        描述从接口Deque复制
        检索，但不删除，这个deque的最后一个元素。 此方法与peekLast不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        getLast在接口 Deque<E>
        结果
        这个德克的尾巴
        异常
        NoSuchElementException - 如果这个deque是空的

      • peekFirst

        public E peekFirst​()
        说明从接口Deque复制
        检索但不删除此deque的第一个元素，如果此deque为空，则返回 null 。
        Specified by:
        peekFirst在接口 Deque<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • peekLast

        public E peekLast​()
        描述从接口Deque复制
        检索但不删除此deque的最后一个元素，如果此deque为空，则返回 null 。
        Specified by:
        peekLast在接口 Deque<E>
        结果
        这个deque的尾巴，或 null如果这个deque是空的

      • removeFirstOccurrence

        public boolean removeFirstOccurrence​(Object o)
        删除此deque中指定元素的第一个出现（从头到尾遍历deque时）。 如果deque不包含元素，则它不变。 更正式地，删除第一元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。
        Specified by:
        removeFirstOccurrence在接口 Deque<E>
        参数
        o - 要从此deque中删除的元素（如果存在）
        结果
        true如果deque包含指定的元素

      • removeLastOccurrence

        public boolean removeLastOccurrence​(Object o)
        删除此deque中指定元素的最后一次（从头到尾遍历deque时）。 如果deque不包含元素，则它不变。 更正式地，删除最后一个元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果该deque由于调用而更改），则返回true 。
        Specified by:
        removeLastOccurrence在接口 Deque<E>
        参数
        o - 要从此deque移除的元素（如果存在）
        结果
        如果deque包含指定的元素， true

      • add

        public boolean add​(E e)
        在此deque的末尾插入指定的元素。

        此方法相当于addLast(E) 。

        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Deque<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractCollection<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        在此deque的末尾插入指定的元素。

        此方法相当于offerLast(E) 。

        Specified by:
        offer在接口 Deque<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Queue.offer(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • remove

        public E remove​()
        检索并删除由此deque表示的队列的头部。 此方法与poll的区别在于，如果此deque为空，它将抛出异常。

        这个方法相当于removeFirst() 。

        Specified by:
        remove在接口 Deque<E>
        Specified by:
        remove在接口 Queue<E>
        结果
        由这个德克队代表的队列的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • poll

        public E poll​()
        检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回null 。

        此方法相当于pollFirst() 。

        Specified by:
        poll在接口 Deque<E>
        Specified by:
        poll在接口 Queue<E>
        结果
        由这个deque代表的队列的头，或者如果这个deque是空的，则是 null

      • element

        public E element​()
        检索，但不删除，由这个deque表示的队列的头。 此方法与peek不同之处在于，如果此deque为空，它将抛出异常。

        这个方法相当于getFirst() 。

        Specified by:
        element在接口 Deque<E>
        Specified by:
        element在接口 Queue<E>
        结果
        由这个德克队代表的队列的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • peek

        public E peek​()
        检索但不删除由此deque表示的队列的头部，如果此deque为空，则返回null 。

        此方法相当于peekFirst() 。

        Specified by:
        peek在接口 Deque<E>
        Specified by:
        peek在接口 Queue<E>
        结果
        由这个deque表示的队列的头，或者如果这个deque是空的，则是 null

      • push

        public void push​(E e)
        将元素推送到由此deque表示的堆栈上。 换句话说，将该元素插入到此deque的前面。

        此方法相当于addFirst(E) 。

        Specified by:
        push在接口 Deque<E>
        参数
        e - 要推的元素
        异常
        NullPointerException - 如果指定的元素为空

      • pop

        public E pop​()
        从这个deque表示的堆栈中弹出一个元素。 换句话说，删除并返回此deque的第一个元素。

        此方法相当于removeFirst() 。

        Specified by:
        pop在接口 Deque<E>
        结果
        这个deque前面的元素（它是由这个deque表示的堆栈的顶部）
        异常
        NoSuchElementException - 如果这个deque是空的

      • size

        public int size​()
        返回此deque中的元素数。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Deque<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        这个deque中的元素数量

      • isEmpty

        public boolean isEmpty​()
        如果此deque不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        重写：
        isEmpty在 AbstractCollection<E>
        结果
        true如果这个deque不包含元素

      • iterator

        public Iterator<E> iterator​()
        返回此deque中的元素的迭代器。 元素将从头（头）到最后（尾）排序。 这将是元素出现的顺序（通过连续调用remove()或弹出（通过连续调用pop() ）。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Deque<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        在这个deque中的元素的迭代器

      • descendingIterator

        public Iterator<E> descendingIterator​()
        描述从接口Deque复制
        以相反的顺序返回此deque中的元素的迭代器。 元素将从最后（尾）到第一（头）的顺序返回。
        Specified by:
        descendingIterator在接口 Deque<E>
        结果
        在这个deque中的元素的反向迭代器

      • spliterator

        public Spliterator<E> spliterator​()
        创建一个late-binding和失败快速 Spliterator在这个deque的元素。

        该Spliterator报告Spliterator.SIZED ， Spliterator.SUBSIZED ， Spliterator.ORDERED ，并Spliterator.NONNULL 。 覆盖实现应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        结果
        一个 Spliterator在这个deque的元素
        从以下版本开始：
        1.8

      • forEach

        public void forEach​(Consumer<? super E> action)
        描述从接口Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的动作为空

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        说明从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 要删除的元素返回 true的谓词
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • removeAll

        public boolean removeAll​(Collection<?> c)
        描述从类复制： AbstractCollection
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果这个收集因呼叫而改变了
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        说明从类别复制： AbstractCollection
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果此集合由于调用而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • contains

        public boolean contains​(Object o)
        如果此deque包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此双端队列至少包含一个元素e这样o.equals(e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Deque<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要检查在这个deque的遏制的对象
        结果
        如果此deque包含指定的元素， true

      • remove

        public boolean remove​(Object o)
        从此deque中删除指定元素的单个实例。 如果deque不包含元素，则它不变。 更正式地，删除第一个元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果该deque由于调用而更改），则返回true 。

        此方法相当于removeFirstOccurrence(Object) 。

        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 Deque<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此deque中删除的元素（如果存在）
        结果
        true如果这个deque包含指定的元素

      • clear

        public void clear​()
        从这个deque中删除所有的元素。 此呼叫返回后，deque将为空。
        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractCollection<E>

      • toArray

        public Object[] toArray​()
        以适当的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）。

        返回的数组将是“安全的”，因为这个deque不会保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此deque中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        以正确的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。 如果deque适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此deque的大小分配一个新数组。

        如果这个deque适合指定的数组，有空余的空间（即数组的元素比此deque更多），紧接着deque结尾之后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于阵列和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的deque。 以下代码可用于将deque转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储deque的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组
        结果
        一个包含此deque中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此deque中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • clone

        public ArrayDeque<E> clone​()
        返回此deque的副本。
        重写：
        clone在 Object
        结果
        这个deque的副本
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ArrayList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class ArrayList<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • java.util.ArrayList<E>
  • 参数类型
    E - 此列表中元素的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， List<E> ， RandomAccess
    已知直接子类：
    AttributeList ， RoleList ， RoleUnresolvedList

    public class ArrayList<E>
extends AbstractList<E>
implements List<E>, RandomAccess, Cloneable, Serializable
    List接口的可调整大小的数组实现。 实现所有可选列表操作，并允许所有元素，包括null 。 除了实现List接口之外，该类还提供了一些方法来处理内部用于存储列表的数组的大小。 （这个类大致相当于Vector ，除了它是不同步的。）

    该size ， isEmpty ， get ， set ， iterator ，并listIterator操作在固定时间内运行。 add操作以摊销的常数运行 ，即添加n个元素需要O（n）个时间。 所有其他操作都以线性时间运行（粗略地说）。 与LinkedList实施相比，常数因子较低。

    每个ArrayList实例都有一个容量 。 容量是用于存储列表中的元素的数组的大小。 它总是至少与列表大小一样大。 当元素添加到ArrayList时，其容量会自动增长。 没有规定增长政策的细节，除了添加元素具有不变的摊销时间成本。

    在使用ensureCapacity操作添加大量元素之前，应用程序可以增加ArrayList实例的容量。 这可能会减少增量重新分配的数量。

    请注意，此实现不同步。 如果多个线程同时访问ArrayList实例，并且至少有一个线程在结构上修改列表，则必须在外部进行同步。 （结构修改是添加或删除一个或多个元素的任何操作，或明确调整后台数组的大小;仅设置元素的值不是结构修改。）这通常是通过在一些自然地封装了名单。 如果没有这样的对象存在，列表应该使用Collections.synchronizedList方法“包装”。 这最好在创建时完成，以防止意外的不同步访问列表：

      List list = Collections.synchronizedList(new ArrayList(...));

    由这个类的iterator和listIterator方法返回的迭代器是故障快速的 ：如果列表在迭代器创建之后的任何时间被结构地修改，除了通过迭代器自己的remove或add方法之外，迭代器将抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的迭代器ConcurrentModificationException扔出ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， List ， LinkedList ， Vector ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      构造方法
      Constructor 描述
      ArrayList​()
      构造一个初始容量为十的空列表。
      ArrayList​(int initialCapacity)
      构造具有指定初始容量的空列表。
      ArrayList​(Collection<? extends E> c)
      构造一个包含指定集合的元素的列表，按照它们由集合的迭代器返回的顺序。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(int index, E element)
      在此列表中的指定位置插入指定的元素。
      boolean add​(E e)
      将指定的元素追加到此列表的末尾。
      boolean addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中，从指定的位置开始。
      boolean addAll​(Collection<? extends E> c)
      按指定集合的Iterator返回的顺序将指定集合中的所有元素追加到此列表的末尾。
      void clear​()
      从列表中删除所有元素。
      Object clone​()
      返回此 ArrayList实例的浅拷贝。
      boolean contains​(Object o)
      如果此列表包含指定的元素，则返回 true 。
      void ensureCapacity​(int minCapacity)
      如果需要，增加此 ArrayList实例的容量，以确保它至少能够容纳最小容量参数指定的元素数量。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      E get​(int index)
      返回此列表中指定位置的元素。
      int indexOf​(Object o)
      返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。
      boolean isEmpty​()
      如果此列表不包含元素，则返回 true 。
      Iterator<E> iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      int lastIndexOf​(Object o)
      返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
      ListIterator<E> listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
      E remove​(int index)
      删除该列表中指定位置的元素。
      boolean remove​(Object o)
      从列表中删除指定元素的第一个出现（如果存在）。
      boolean removeAll​(Collection<?> c)
      从此列表中删除指定集合中包含的所有元素。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      protected void removeRange​(int fromIndex, int toIndex)
      从此列表中删除所有索引为 fromIndex （包括）和 toIndex之间的元素。
      void replaceAll​(UnaryOperator<E> operator)
      将该列表的每个元素替换为将该运算符应用于该元素的结果。
      boolean retainAll​(Collection<?> c)
      仅保留此列表中包含在指定集合中的元素。
      E set​(int index, E element)
      用指定的元素替换此列表中指定位置的元素。
      int size​()
      返回此列表中的元素数。
      void sort​(Comparator<? super E> c)
      根据指定的Comparator引发的顺序排列此列表。
      Spliterator<E> spliterator​()
      在此列表中的元素上创建late-binding和故障快速 Spliterator 。
      List<E> subList​(int fromIndex, int toIndex)
      返回指定的 fromIndex （含）和 toIndex之间的列表部分的视图。
      Object[] toArray​()
      以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。
      void trimToSize​()
      修改这个 ArrayList实例的容量是列表的当前大小。

      • Methods inherited from class java.util.AbstractCollection

        containsAll, toString

      • Methods inherited from class java.util.AbstractList

        equals, hashCode

      • Methods inherited from interface java.util.Collection

        parallelStream, stream

      • Methods inherited from interface java.util.List

        containsAll, equals, hashCode, of, of, of, of, of, of, of, of, of, of, of, of

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ArrayList

        public ArrayList​(int initialCapacity)
        构造具有指定初始容量的空列表。
        参数
        initialCapacity - 列表的初始容量
        异常
        IllegalArgumentException - 如果指定的初始容量为负

      • ArrayList

        public ArrayList​()
        构造一个初始容量为十的空列表。

      • ArrayList

        public ArrayList​(Collection<? extends E> c)
        构造一个包含指定集合的元素的列表，按照它们由集合的迭代器返回的顺序。
        参数
        c - c元素放入此列表的集合
        异常
        NullPointerException - 如果指定的集合为空

    • 方法详细信息

      • trimToSize

        public void trimToSize​()
        修改此ArrayList实例的容量成为列表的当前大小。 应用程序可以使用此操作来最小化ArrayList实例的存储。

      • ensureCapacity

        public void ensureCapacity​(int minCapacity)
        如果需要，增加此 ArrayList实例的容量，以确保它至少能够容纳最小容量参数指定的元素数。
        参数
        minCapacity - 所需的最小容量

      • size

        public int size​()
        返回此列表中的元素数。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 List<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此列表中的元素数

      • isEmpty

        public boolean isEmpty​()
        如果此列表不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        Specified by:
        isEmpty在接口 List<E>
        重写：
        isEmpty在 AbstractCollection<E>
        结果
        true如果此列表不包含元素

      • contains

        public boolean contains​(Object o)
        如果此列表包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此列表包含至少一个元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 List<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要在此列表中存在的元素要进行测试
        结果
        true如果此列表包含指定的元素

      • indexOf

        public int indexOf​(Object o)
        返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地，返回最低指数i ，使得Objects.equals(o, get(i)) ，或-1如果没有这样的索引。
        Specified by:
        indexOf在接口 List<E>
        重写：
        indexOf在 AbstractList<E>
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的首次出现的索引，如果此列表不包含元素，则为-1

      • lastIndexOf

        public int lastIndexOf​(Object o)
        返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地说，返回满足i这样Objects.equals(o, get(i)) ，或-1，如果没有这样的指标。
        Specified by:
        lastIndexOf在接口 List<E>
        重写：
        lastIndexOf在 AbstractList<E>
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则为-1

      • clone

        public Object clone​()
        返回此ArrayList实例的浅拷贝。 （元素本身不被复制。）
        重写：
        clone在 Object
        结果
        这个 ArrayList实例的克隆
        另请参见：
        Cloneable

      • toArray

        public Object[] toArray​()
        以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

        返回的数组将是“安全的”，因为该列表不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 List<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含该列表中所有元素的数组的数组
        另请参见：
        Arrays.asList(Object[])

      • toArray

        public <T> T[] toArray​(T[] a)
        以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。 如果列表适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此列表的大小分配一个新数组。

        如果列表适用于指定的数组， null空间（即数组的列表数量较多），则紧跟在集合结束后的数组中的元素设置为null 。 （这仅在调用者知道列表不包含任何空元素的情况下才能确定列表的长度。）

        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 List<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储列表的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含列表元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此列表中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • get

        public E get​(int index)
        返回此列表中指定位置的元素。
        Specified by:
        get在接口 List<E>
        Specified by:
        get在 AbstractList<E>
        参数
        index - 要返回的元素的索引
        结果
        该列表中指定位置的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • set

        public E set​(int index,
             E element)
        用指定的元素替换此列表中指定位置的元素。
        Specified by:
        set在接口 List<E>
        重写：
        set在 AbstractList<E>
        参数
        index - 要替换的元素的索引
        element - 要存储在指定位置的元素
        结果
        该元素以前在指定的位置
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • add

        public boolean add​(E e)
        将指定的元素追加到此列表的末尾。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 List<E>
        重写：
        add在 AbstractList<E>
        参数
        e - 要附加到此列表的元素
        结果
        true （由 Collection.add(E)指定）

      • add

        public void add​(int index,
                E element)
        在此列表中的指定位置插入指定的元素。 将当前位于该位置的元素（如果有）和任何后续元素（向其索引添加一个）移动。
        Specified by:
        add在接口 List<E>
        重写：
        add在 AbstractList<E>
        参数
        index - 要在其中插入指定元素的索引
        element - 要插入的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • remove

        public E remove​(int index)
        删除该列表中指定位置的元素。 将任何后续元素移动到左侧（从其索引中减去一个元素）。
        Specified by:
        remove在接口 List<E>
        重写：
        remove在 AbstractList<E>
        参数
        index - 要删除的元素的索引
        结果
        从列表中删除的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • remove

        public boolean remove​(Object o)
        从列表中删除指定元素的第一个出现（如果存在）。 如果列表不包含该元素，则它不会更改。 更正式地，删除具有最低索引i的元素，使得Objects.equals(o, get(i)) （如果这样的元素存在）。 如果此列表包含指定的元素（或等效地，如果此列表作为调用的结果而更改），则返回true 。
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 List<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此列表中删除的元素（如果存在）
        结果
        true如果此列表包含指定的元素

      • clear

        public void clear​()
        从列表中删除所有元素。 此呼叫返回后，列表将为空。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 List<E>
        重写：
        clear在 AbstractList<E>

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        按指定集合的Iterator返回的顺序将指定集合中的所有元素追加到此列表的末尾。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （这意味着如果指定的集合是此列表，则此调用的行为是未定义的，并且此列表是非空的。）
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 List<E>
        重写：
        addAll在 AbstractCollection<E>
        参数
        c - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        NullPointerException - 如果指定的集合为空
        另请参见：
        AbstractCollection.add(Object)

      • addAll

        public boolean addAll​(int index,
                      Collection<? extends E> c)
        将指定集合中的所有元素插入到此列表中，从指定的位置开始。 将当前位于该位置（如果有的话）的元素和随后的任何元素移动到右边（增加其索引）。 新元素将按照指定集合的迭代器返回的顺序显示在列表中。
        Specified by:
        addAll在接口 List<E>
        重写：
        addAll在 AbstractList<E>
        参数
        index - 从中指定集合插入第一个元素的索引
        c - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）
        NullPointerException - 如果指定的集合为空

      • removeRange

        protected void removeRange​(int fromIndex,
                           int toIndex)
        从此列表中删除所有索引为fromIndex （含）和toIndex之间的元素。 将任何后续元素移动到左侧（减少其索引）。 此通话由(toIndex - fromIndex)元素缩短列表。 （如果是toIndex==fromIndex ，这个操作没有效果）
        重写：
        removeRange在 AbstractList<E>
        参数
        fromIndex - 要删除的第一个元素的索引
        toIndex - 要删除的最后一个元素后的索引
        异常
        IndexOutOfBoundsException - 如果 fromIndex或 toIndex超出范围（ fromIndex < 0 || toIndex > size() || toIndex < fromIndex ）

      • removeAll

        public boolean removeAll​(Collection<?> c)
        从此列表中删除指定集合中包含的所有元素。
        Specified by:
        removeAll在接口 Collection<E>
        Specified by:
        removeAll在接口 List<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 包含要从此列表中删除的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        ClassCastException - 如果此列表的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此列表包含空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        Collection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        仅保留此列表中包含在指定集合中的元素。 换句话说，从此列表中删除其中不包含在指定集合中的所有元素。
        Specified by:
        retainAll在接口 Collection<E>
        Specified by:
        retainAll在接口 List<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此列表中的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        ClassCastException - 如果此列表的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此列表包含空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        Collection.contains(Object)

      • listIterator

        public ListIterator<E> listIterator​(int index)
        从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。 指定的索引指示由初始调用next返回的第一个元素。 初始调用previous将返回指定索引减1的元素。

        返回的列表迭代器是fail-fast 。

        Specified by:
        listIterator在接口 List<E>
        重写：
        listIterator在 AbstractList<E>
        参数
        index - 要从列表迭代器返回的第一个元素的索引（通过调用 next ）
        结果
        在列表中的元素（按正确顺序）的列表迭代器，从列表中的指定位置开始
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • listIterator

        public ListIterator<E> listIterator​()
        返回列表中的列表迭代器（按适当的顺序）。

        返回的列表迭代器是fail-fast 。

        Specified by:
        listIterator在接口 List<E>
        重写：
        listIterator在 AbstractList<E>
        结果
        在列表中的元素的列表迭代器（按适当的顺序）
        另请参见：
        listIterator(int)

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回该列表中的元素的迭代器。

        返回的迭代器是fail-fast 。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 List<E>
        重写：
        iterator在 AbstractList<E>
        结果
        在这个列表中的元素以适当的顺序迭代

      • subList

        public List<E> subList​(int fromIndex,
                       int toIndex)
        返回指定的fromIndex （含）和toIndex之间的列表部分的视图。 （如果fromIndex和toIndex相等，返回的列表为空。）返回的列表由此列表支持，因此返回列表中的非结构更改将反映在此列表中，反之亦然。 返回的列表支持所有可选列表操作。

        该方法消除了对显式范围操作（对于数组通常存在的排序）的需要。 任何期望列表的操作都可以通过传递一个子列表视图而不是整个列表来用作范围操作。 例如，以下成语从列表中移除了一系列元素：

          list.subList(from, to).clear();
        可以为indexOf(Object)和lastIndexOf(Object)构造类似的成语，并且可以将Collections类中的所有算法应用于子列表。

        如果支持列表（即，此列表）以除了通过返回的列表之外的任何方式进行结构修改 ，则此方法返回的列表的语义将变为未定义。 （结构修改是那些改变此列表的大小，或以其他方式扰乱它，使得正在进行的迭代可能产生不正确的结果）。

        Specified by:
        subList在接口 List<E>
        重写：
        subList在 AbstractList<E>
        参数
        fromIndex - 子列表的低端点（含）
        toIndex - 子列表的高端点（排他性）
        结果
        该列表中指定范围的视图
        异常
        IndexOutOfBoundsException - 如果端点索引值超出范围 (fromIndex < 0 || toIndex > size)
        IllegalArgumentException - 如果端点索引不正确 (fromIndex > toIndex)

      • forEach

        public void forEach​(Consumer<? super E> action)
        说明从接口Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要对每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空

      • spliterator

        public Spliterator<E> spliterator​()
        在此列表中的元素上创建late-binding和故障快速 Spliterator 。

        该Spliterator报告Spliterator.SIZED ， Spliterator.SUBSIZED ，并Spliterator.ORDERED 。 覆盖实现应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Specified by:
        spliterator在接口 List<E>
        结果
        一个 Spliterator在这个列表中的元素
        从以下版本开始：
        1.8

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        说明从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 为要删除的元素返回 true的谓词
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • replaceAll

        public void replaceAll​(UnaryOperator<E> operator)
        说明从界面List复制
        将该列表的每个元素替换为将该运算符应用于该元素的结果。 运营商抛出的错误或运行时异常被转发给呼叫者。
        Specified by:
        replaceAll在接口 List<E>
        参数
        operator - 操作员应用于每个元素

      • sort

        public void sort​(Comparator<? super E> c)
        说明从接口List复制
        根据指定的Comparator引发的顺序排列此列表。

        此列表中的所有元素必须使用指定的比较器相互比较（即， c.compare(e1, e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        如果指定的比较器是null则该列表中的所有元素都必须实现Comparable接口，并且应使用元素' natural ordering '。

        该列表必须是可修改的，但不能调整大小。

        Specified by:
        sort在接口 List<E>
        参数
        c - Comparator用于比较列表元素。 A null值表示应使用元素' natural ordering '
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Arrays (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Arrays

  • java.lang.Object
    • java.util.Arrays

  • public class Arrays
extends Object
    该类包含用于操作数组的各种方法（如排序和搜索）。 该类还包含一个静态工厂，可以将数组视为列表。

    这个类中的方法都抛出一个NullPointerException ，如果指定的数组引用为null，除非另有说明。

    包含在此类的方法中的文件包括的实施方式的简要描述。 这些描述应被视为实施说明 ，而不是说明书的一部分 。 只要规范本身得到遵守，实现者就可以随意替代其他算法。 （例如， sort(Object[])使用的算法不一定是sort(Object[]) ，但它必须是稳定的 。）

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static <T> List<T> asList​(T... a)
      返回由指定数组支持的固定大小的列表。
      static int binarySearch​(byte[] a, byte key)
      使用二进制搜索算法搜索指定值的指定字节数组。
      static int binarySearch​(byte[] a, int fromIndex, int toIndex, byte key)
      使用二进制搜索算法搜索指定值的指定字节数组的范围。
      static int binarySearch​(char[] a, char key)
      使用二进制搜索算法搜索指定数组的指定值。
      static int binarySearch​(char[] a, int fromIndex, int toIndex, char key)
      使用二分搜索算法搜索指定值的指定数组的范围。
      static int binarySearch​(double[] a, double key)
      使用二进制搜索算法搜索指定值的指定数组的双精度值。
      static int binarySearch​(double[] a, int fromIndex, int toIndex, double key)
      使用二分搜索算法搜索指定值的指定数组的双精度范围。
      static int binarySearch​(float[] a, float key)
      使用二叉搜索算法搜索指定数组的浮点数。
      static int binarySearch​(float[] a, int fromIndex, int toIndex, float key)
      使用二分搜索算法搜索指定数组的浮点数范围。
      static int binarySearch​(int[] a, int key)
      使用二叉搜索算法搜索指定的int数组的指定值。
      static int binarySearch​(int[] a, int fromIndex, int toIndex, int key)
      使用二叉搜索算法搜索指定值的指定数组的范围。
      static int binarySearch​(long[] a, int fromIndex, int toIndex, long key)
      使用二分搜索算法搜索指定值的指定数组的范围。
      static int binarySearch​(long[] a, long key)
      使用二进制搜索算法搜索指定数组的指定数组。
      static int binarySearch​(short[] a, int fromIndex, int toIndex, short key)
      使用二进制搜索算法搜索指定值的指定数组的短整型范围。
      static int binarySearch​(short[] a, short key)
      使用二进制搜索算法搜索指定值的指定数组的指定值。
      static int binarySearch​(Object[] a, int fromIndex, int toIndex, Object key)
      使用二进制搜索算法搜索指定对象的指定数组的范围。
      static int binarySearch​(Object[] a, Object key)
      使用二叉搜索算法搜索指定对象的指定数组。
      static <T> int binarySearch​(T[] a, int fromIndex, int toIndex, T key, Comparator<? super T> c)
      使用二进制搜索算法搜索指定对象的指定数组的范围。
      static <T> int binarySearch​(T[] a, T key, Comparator<? super T> c)
      使用二叉搜索算法搜索指定对象的指定数组。
      static int compare​(boolean[] a, boolean[] b)
      boolean字典顺序比较两个 boolean阵列。
      static int compare​(boolean[] a, int aFromIndex, int aToIndex, boolean[] b, int bFromIndex, int bToIndex)
      比较两个 boolean阵列在 boolean指定的范围。
      static int compare​(byte[] a, byte[] b)
      byte字典顺序比较两个 byte阵列。
      static int compare​(byte[] a, int aFromIndex, int aToIndex, byte[] b, int bFromIndex, int bToIndex)
      比较两个 byte阵列在 byte指定的范围。
      static int compare​(char[] a, char[] b)
      char字典顺序比较两个 char阵列。
      static int compare​(char[] a, int aFromIndex, int aToIndex, char[] b, int bFromIndex, int bToIndex)
      比较两个 char阵列在字典上超过指定的范围。
      static int compare​(double[] a, double[] b)
      double字典顺序比较两个 double阵列。
      static int compare​(double[] a, int aFromIndex, int aToIndex, double[] b, int bFromIndex, int bToIndex)
      比较两个 double阵列在指定范围内的字典。
      static int compare​(float[] a, float[] b)
      float字典顺序比较两个 float阵列。
      static int compare​(float[] a, int aFromIndex, int aToIndex, float[] b, int bFromIndex, int bToIndex)
      比较两个 float阵列在字典上超过指定的范围。
      static int compare​(int[] a, int[] b)
      int字典顺序比较两个 int阵列。
      static int compare​(int[] a, int aFromIndex, int aToIndex, int[] b, int bFromIndex, int bToIndex)
      比较两个 int阵列在字典上超过指定的范围。
      static int compare​(long[] a, int aFromIndex, int aToIndex, long[] b, int bFromIndex, int bToIndex)
      比较两个 long阵列在 long指定的范围。
      static int compare​(long[] a, long[] b)
      long字典顺序比较两个 long阵列。
      static int compare​(short[] a, int aFromIndex, int aToIndex, short[] b, int bFromIndex, int bToIndex)
      比较两个 short阵列在字典上超过指定的范围。
      static int compare​(short[] a, short[] b)
      short字典顺序比较两个 short阵列。
      static <T extends Comparable<? super T>>
      int             		compare​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex)
      比较两个 Object阵列在 Object指定的范围。
      static <T> int compare​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex, Comparator<? super T> cmp)
      比较两个 Object阵列在 Object指定的范围。
      static <T extends Comparable<? super T>>
      int             		compare​(T[] a, T[] b)
      比较两个 Object阵列，可比较的元素，按字典顺序。
      static <T> int compare​(T[] a, T[] b, Comparator<? super T> cmp)
      比较两个 Object阵列，使用指定的比较器进行字典比对。
      static int compareUnsigned​(byte[] a, byte[] b)
      比较两个 byte阵列的字典，数字处理元素为无符号。
      static int compareUnsigned​(byte[] a, int aFromIndex, int aToIndex, byte[] b, int bFromIndex, int bToIndex)
      比较两个 byte数组在指定范围内，数字处理元素为无符号。
      static int compareUnsigned​(int[] a, int[] b)
      比较两个 int阵列在 int ，数字处理元素为无符号。
      static int compareUnsigned​(int[] a, int aFromIndex, int aToIndex, int[] b, int bFromIndex, int bToIndex)
      将两个 int阵列按 int顺序比较指定范围，将元素数字化处理为无符号。
      static int compareUnsigned​(long[] a, int aFromIndex, int aToIndex, long[] b, int bFromIndex, int bToIndex)
      比较两个 long阵列在指定的范围内，以数字方式处理元素为无符号。
      static int compareUnsigned​(long[] a, long[] b)
      比较两个 long阵列在 long ，数字处理元素为无符号。
      static int compareUnsigned​(short[] a, int aFromIndex, int aToIndex, short[] b, int bFromIndex, int bToIndex)
      将两个 short阵列按照 short顺序比较在指定范围内，将元素数字处理为无符号。
      static int compareUnsigned​(short[] a, short[] b)
      比较两个 short阵列的字典，数字处理元素为无符号。
      static boolean[] copyOf​(boolean[] original, int newLength)
      复制指定的数组，截断或填充 false （如有必要），因此副本具有指定的长度。
      static byte[] copyOf​(byte[] original, int newLength)
      复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。
      static char[] copyOf​(char[] original, int newLength)
      复制指定的数组，截断或填充空字符（如有必要），以便复制具有指定的长度。
      static double[] copyOf​(double[] original, int newLength)
      复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。
      static float[] copyOf​(float[] original, int newLength)
      复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。
      static int[] copyOf​(int[] original, int newLength)
      复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。
      static long[] copyOf​(long[] original, int newLength)
      复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。
      static short[] copyOf​(short[] original, int newLength)
      复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。
      static <T> T[] copyOf​(T[] original, int newLength)
      复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。
      static <T,U> T[] copyOf​(U[] original, int newLength, Class<? extends T[]> newType)
      复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。
      static boolean[] copyOfRange​(boolean[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static byte[] copyOfRange​(byte[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static char[] copyOfRange​(char[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static double[] copyOfRange​(double[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static float[] copyOfRange​(float[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static int[] copyOfRange​(int[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static long[] copyOfRange​(long[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static short[] copyOfRange​(short[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static <T> T[] copyOfRange​(T[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static <T,U> T[] copyOfRange​(U[] original, int from, int to, Class<? extends T[]> newType)
      将指定数组的指定范围复制到新数组中。
      static boolean deepEquals​(Object[] a1, Object[] a2)
      如果两个指定的数组彼此 深度相等 ，则返回 true 。
      static int deepHashCode​(Object[] a)
      根据指定数组的“深度内容”返回哈希码。
      static String deepToString​(Object[] a)
      返回指定数组的“深度内容”的字符串表示形式。
      static boolean equals​(boolean[] a, boolean[] a2)
      如果两个指定的布尔数组彼此 相等 ，则返回 true 。
      static boolean equals​(boolean[] a, int aFromIndex, int aToIndex, boolean[] b, int bFromIndex, int bToIndex)
      如果两个指定的布尔值数组在指定的范围内彼此 相等 ，则返回true。
      static boolean equals​(byte[] a, byte[] a2)
      如果两个指定的字节数组彼此 相等 ，则返回 true 。
      static boolean equals​(byte[] a, int aFromIndex, int aToIndex, byte[] b, int bFromIndex, int bToIndex)
      如果两个指定的字节数组（在指定范围内）彼此 相等 ，则返回true。
      static boolean equals​(char[] a, char[] a2)
      如果两个指定的字符数组彼此 相等 ，则返回 true 。
      static boolean equals​(char[] a, int aFromIndex, int aToIndex, char[] b, int bFromIndex, int bToIndex)
      如果两个指定的字符数组在指定范围内彼此 相等 ，则返回true。
      static boolean equals​(double[] a, double[] a2)
      如果两个指定的双精度数组彼此 相等 ，则返回 true 。
      static boolean equals​(double[] a, int aFromIndex, int aToIndex, double[] b, int bFromIndex, int bToIndex)
      如果指定范围内的两个指定的双精度数组彼此 相等 ，则返回true。
      static boolean equals​(float[] a, float[] a2)
      如果两个指定的浮动数组彼此 相等 ，则返回 true 。
      static boolean equals​(float[] a, int aFromIndex, int aToIndex, float[] b, int bFromIndex, int bToIndex)
      如果两个指定的浮点数在指定范围内相互 相等 ，则返回true。
      static boolean equals​(int[] a, int[] a2)
      如果两个指定的int数组彼此 相等 ，则返回 true 。
      static boolean equals​(int[] a, int aFromIndex, int aToIndex, int[] b, int bFromIndex, int bToIndex)
      如果两个指定的int数组在指定的范围内彼此 相等 ，则返回true。
      static boolean equals​(long[] a, int aFromIndex, int aToIndex, long[] b, int bFromIndex, int bToIndex)
      如果指定范围内的两个指定的long数组彼此 相等 ，则返回true。
      static boolean equals​(long[] a, long[] a2)
      如果两个指定的longs数组彼此 相等 ，则返回 true 。
      static boolean equals​(short[] a, int aFromIndex, int aToIndex, short[] b, int bFromIndex, int bToIndex)
      如果两个指定的短整型数组在指定的范围内彼此 相等 ，则返回true。
      static boolean equals​(short[] a, short[] a2)
      如果两个指定的短裤阵列彼此 相等 ，则返回 true 。
      static boolean equals​(Object[] a, int aFromIndex, int aToIndex, Object[] b, int bFromIndex, int bToIndex)
      如果两个指定的对象数组在指定范围内彼此 相等 ，则返回true。
      static boolean equals​(Object[] a, Object[] a2)
      如果两个指定的对象数组彼此 相等 ，则返回 true 。
      static <T> boolean equals​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex, Comparator<? super T> cmp)
      如果两个指定的对象数组在指定范围内彼此 相等 ，则返回true。
      static <T> boolean equals​(T[] a, T[] a2, Comparator<? super T> cmp)
      如果两个指定的对象数组彼此 相等 ，则返回 true 。
      static void fill​(boolean[] a, boolean val)
      将指定的布尔值分配给指定的布尔数组的每个元素。
      static void fill​(boolean[] a, int fromIndex, int toIndex, boolean val)
      将指定的布尔值分配给指定数组布尔值的指定范围的每个元素。
      static void fill​(byte[] a, byte val)
      将指定的字节值分配给指定字节数组的每个元素。
      static void fill​(byte[] a, int fromIndex, int toIndex, byte val)
      将指定的字节值分配给指定字节数组的指定范围的每个元素。
      static void fill​(char[] a, char val)
      将指定的char值分配给指定的char数组的每个元素。
      static void fill​(char[] a, int fromIndex, int toIndex, char val)
      将指定的char值分配给指定的char数组的指定范围的每个元素。
      static void fill​(double[] a, double val)
      将指定的double值分配给指定的双精度数组的每个元素。
      static void fill​(double[] a, int fromIndex, int toIndex, double val)
      将指定的double值分配给指定的双精度数组范围的每个元素。
      static void fill​(float[] a, float val)
      将指定的float值分配给指定的浮点数组的每个元素。
      static void fill​(float[] a, int fromIndex, int toIndex, float val)
      将指定的浮点值分配给指定的浮点数组的指定范围的每个元素。
      static void fill​(int[] a, int val)
      将指定的int值分配给指定的int数组的每个元素。
      static void fill​(int[] a, int fromIndex, int toIndex, int val)
      将指定的int值分配给指定的int数组的指定范围的每个元素。
      static void fill​(long[] a, int fromIndex, int toIndex, long val)
      将指定的long值分配给指定的longs数组的指定范围的每个元素。
      static void fill​(long[] a, long val)
      将指定的long值分配给指定的longs数组的每个元素。
      static void fill​(short[] a, int fromIndex, int toIndex, short val)
      将指定的短值分配给指定的短裤数组的指定范围的每个元素。
      static void fill​(short[] a, short val)
      将指定的短值分配给指定的短裤数组的每个元素。
      static void fill​(Object[] a, int fromIndex, int toIndex, Object val)
      将指定的对象引用分配给指定的对象数组的指定范围的每个元素。
      static void fill​(Object[] a, Object val)
      将指定的对象引用分配给指定的对象数组的每个元素。
      static int hashCode​(boolean[] a)
      根据指定数组的内容返回哈希码。
      static int hashCode​(byte[] a)
      根据指定数组的内容返回哈希码。
      static int hashCode​(char[] a)
      根据指定数组的内容返回哈希码。
      static int hashCode​(double[] a)
      根据指定数组的内容返回哈希码。
      static int hashCode​(float[] a)
      根据指定数组的内容返回哈希码。
      static int hashCode​(int[] a)
      根据指定数组的内容返回哈希码。
      static int hashCode​(long[] a)
      根据指定数组的内容返回哈希码。
      static int hashCode​(short[] a)
      根据指定数组的内容返回哈希码。
      static int hashCode​(Object[] a)
      根据指定数组的内容返回哈希码。
      static int mismatch​(boolean[] a, boolean[] b)
      查找并返回两个 boolean数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(boolean[] a, int aFromIndex, int aToIndex, boolean[] b, int bFromIndex, int bToIndex)
      查找并返回指定范围内两个 boolean数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
      static int mismatch​(byte[] a, byte[] b)
      查找并返回两个 byte数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(byte[] a, int aFromIndex, int aToIndex, byte[] b, int bFromIndex, int bToIndex)
      查找并返回指定范围内两个 byte数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
      static int mismatch​(char[] a, char[] b)
      查找并返回两个 char数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(char[] a, int aFromIndex, int aToIndex, char[] b, int bFromIndex, int bToIndex)
      查找并返回指定范围内两个 char数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
      static int mismatch​(double[] a, double[] b)
      查找并返回两个 double数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(double[] a, int aFromIndex, int aToIndex, double[] b, int bFromIndex, int bToIndex)
      查找并返回指定范围内两个 double数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
      static int mismatch​(float[] a, float[] b)
      查找并返回两个 float数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(float[] a, int aFromIndex, int aToIndex, float[] b, int bFromIndex, int bToIndex)
      查找并返回指定范围内的两个 float数组之间的第一个不匹配的相对索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(int[] a, int[] b)
      查找并返回两个 int数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(int[] a, int aFromIndex, int aToIndex, int[] b, int bFromIndex, int bToIndex)
      查找并返回指定范围内两个 int数组之间的第一个不匹配的相对索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(long[] a, int aFromIndex, int aToIndex, long[] b, int bFromIndex, int bToIndex)
      查找并返回指定范围内两个 long数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
      static int mismatch​(long[] a, long[] b)
      查找并返回两个 long数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(short[] a, int aFromIndex, int aToIndex, short[] b, int bFromIndex, int bToIndex)
      查找并返回指定范围内两个 short数组之间的第一个不匹配的相对索引，否则返回-1，如果未发现不匹配。
      static int mismatch​(short[] a, short[] b)
      查找并返回两个 short数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static int mismatch​(Object[] a, int aFromIndex, int aToIndex, Object[] b, int bFromIndex, int bToIndex)
      查找并返回指定范围内两个 Object数组之间的第一个不匹配的相对索引，否则返回-1，如果未发现不匹配。
      static int mismatch​(Object[] a, Object[] b)
      查找并返回两个 Object数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static <T> int mismatch​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex, Comparator<? super T> cmp)
      查找并返回指定范围内的两个 Object数组之间的第一个不匹配的相对索引，否则返回-1，如果未发现不匹配。
      static <T> int mismatch​(T[] a, T[] b, Comparator<? super T> cmp)
      查找并返回两个 Object数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static void parallelPrefix​(double[] array, int fromIndex, int toIndex, DoubleBinaryOperator op)
      对于数组的给定子范围执行 parallelPrefix(double[], DoubleBinaryOperator) 。
      static void parallelPrefix​(double[] array, DoubleBinaryOperator op)
      使用提供的功能，并行地计算给定阵列的每个元素。
      static void parallelPrefix​(int[] array, int fromIndex, int toIndex, IntBinaryOperator op)
      对于数组的给定子范围执行 parallelPrefix(int[], IntBinaryOperator) 。
      static void parallelPrefix​(int[] array, IntBinaryOperator op)
      使用提供的功能，并行地计算给定阵列的每个元素。
      static void parallelPrefix​(long[] array, int fromIndex, int toIndex, LongBinaryOperator op)
      对于数组的给定子范围执行 parallelPrefix(long[], LongBinaryOperator) 。
      static void parallelPrefix​(long[] array, LongBinaryOperator op)
      使用提供的功能，并行地计算给定阵列的每个元素。
      static <T> void parallelPrefix​(T[] array, int fromIndex, int toIndex, BinaryOperator<T> op)
      对于数组的给定子范围执行 parallelPrefix(Object[], BinaryOperator) 。
      static <T> void parallelPrefix​(T[] array, BinaryOperator<T> op)
      使用提供的功能，并行地计算给定阵列的每个元素。
      static void parallelSetAll​(double[] array, IntToDoubleFunction generator)
      使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
      static void parallelSetAll​(int[] array, IntUnaryOperator generator)
      使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
      static void parallelSetAll​(long[] array, IntToLongFunction generator)
      使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
      static <T> void parallelSetAll​(T[] array, IntFunction<? extends T> generator)
      使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
      static void parallelSort​(byte[] a)
      按照数字顺序排列指定的数组。
      static void parallelSort​(byte[] a, int fromIndex, int toIndex)
      按照数字顺序排列数组的指定范围。
      static void parallelSort​(char[] a)
      按照数字顺序排列指定的数组。
      static void parallelSort​(char[] a, int fromIndex, int toIndex)
      按照数字顺序排列数组的指定范围。
      static void parallelSort​(double[] a)
      按照数字顺序排列指定的数组。
      static void parallelSort​(double[] a, int fromIndex, int toIndex)
      按照数字顺序排列数组的指定范围。
      static void parallelSort​(float[] a)
      按照数字顺序排列指定的数组。
      static void parallelSort​(float[] a, int fromIndex, int toIndex)
      按照数字顺序排列数组的指定范围。
      static void parallelSort​(int[] a)
      按照数字顺序排列指定的数组。
      static void parallelSort​(int[] a, int fromIndex, int toIndex)
      按照数字顺序排列数组的指定范围。
      static void parallelSort​(long[] a)
      按照数字顺序排列指定的数组。
      static void parallelSort​(long[] a, int fromIndex, int toIndex)
      按照数字顺序排列数组的指定范围。
      static void parallelSort​(short[] a)
      按照数字顺序排列指定的数组。
      static void parallelSort​(short[] a, int fromIndex, int toIndex)
      按照数字顺序排列数组的指定范围。
      static <T extends Comparable<? super T>>
      void             		parallelSort​(T[] a)
      根据其元素的natural ordering ，按照升序排列指定的对象数组。
      static <T extends Comparable<? super T>>
      void             		parallelSort​(T[] a, int fromIndex, int toIndex)
      根据其元素的27060729646982 ，将指定的对象数组的指定范围按升序排列。
      static <T> void parallelSort​(T[] a, int fromIndex, int toIndex, Comparator<? super T> cmp)
      根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。
      static <T> void parallelSort​(T[] a, Comparator<? super T> cmp)
      根据指定的比较器引发的顺序对指定的对象数组进行排序。
      static void setAll​(double[] array, IntToDoubleFunction generator)
      使用提供的生成函数来计算每个元素，设置指定数组的所有元素。
      static void setAll​(int[] array, IntUnaryOperator generator)
      使用提供的生成函数来计算每个元素，设置指定数组的所有元素。
      static void setAll​(long[] array, IntToLongFunction generator)
      使用提供的生成函数来计算每个元素，设置指定数组的所有元素。
      static <T> void setAll​(T[] array, IntFunction<? extends T> generator)
      使用提供的生成函数来计算每个元素，设置指定数组的所有元素。
      static void sort​(byte[] a)
      按照数字顺序排列指定的数组。
      static void sort​(byte[] a, int fromIndex, int toIndex)
      按升序排列数组的指定范围。
      static void sort​(char[] a)
      按照数字顺序排列指定的数组。
      static void sort​(char[] a, int fromIndex, int toIndex)
      按升序排列数组的指定范围。
      static void sort​(double[] a)
      按照数字顺序排列指定的数组。
      static void sort​(double[] a, int fromIndex, int toIndex)
      按升序排列数组的指定范围。
      static void sort​(float[] a)
      按照数字顺序排列指定的数组。
      static void sort​(float[] a, int fromIndex, int toIndex)
      按升序排列数组的指定范围。
      static void sort​(int[] a)
      按照数字顺序排列指定的数组。
      static void sort​(int[] a, int fromIndex, int toIndex)
      按升序排列数组的指定范围。
      static void sort​(long[] a)
      按照数字顺序排列指定的数组。
      static void sort​(long[] a, int fromIndex, int toIndex)
      按升序排列数组的指定范围。
      static void sort​(short[] a)
      按照数字顺序排列指定的数组。
      static void sort​(short[] a, int fromIndex, int toIndex)
      按升序排列数组的指定范围。
      static void sort​(Object[] a)
      根据其元素的natural ordering按照升序排列指定的对象数组。
      static void sort​(Object[] a, int fromIndex, int toIndex)
      根据其元素的natural ordering按照升序排列指定数组对象的指定范围。
      static <T> void sort​(T[] a, int fromIndex, int toIndex, Comparator<? super T> c)
      根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。
      static <T> void sort​(T[] a, Comparator<? super T> c)
      根据指定的比较器引发的顺序对指定的对象数组进行排序。
      static Spliterator.OfDouble spliterator​(double[] array)
      返回覆盖所有指定数组的Spliterator.OfDouble 。
      static Spliterator.OfDouble spliterator​(double[] array, int startInclusive, int endExclusive)
      返回覆盖指定数组的指定范围的Spliterator.OfDouble 。
      static Spliterator.OfInt spliterator​(int[] array)
      返回一个覆盖所有指定数组的Spliterator.OfInt 。
      static Spliterator.OfInt spliterator​(int[] array, int startInclusive, int endExclusive)
      返回覆盖指定数组的指定范围的Spliterator.OfInt 。
      static Spliterator.OfLong spliterator​(long[] array)
      返回一个覆盖所有指定数组的Spliterator.OfLong 。
      static Spliterator.OfLong spliterator​(long[] array, int startInclusive, int endExclusive)
      返回覆盖指定数组的指定范围的Spliterator.OfLong 。
      static <T> Spliterator<T> spliterator​(T[] array)
      返回覆盖所有指定数组的Spliterator 。
      static <T> Spliterator<T> spliterator​(T[] array, int startInclusive, int endExclusive)
      返回覆盖指定数组的指定范围的Spliterator 。
      static DoubleStream stream​(double[] array)
      返回具有指定数组的序列DoubleStream作为其源。
      static DoubleStream stream​(double[] array, int startInclusive, int endExclusive)
      返回具有指定数组的指定范围作为其源的顺序DoubleStream 。
      static IntStream stream​(int[] array)
      返回具有指定数组的序列IntStream作为其来源。
      static IntStream stream​(int[] array, int startInclusive, int endExclusive)
      返回指定数组的指定范围作为其源的顺序IntStream 。
      static LongStream stream​(long[] array)
      返回具有指定数组的序列LongStream作为其源。
      static LongStream stream​(long[] array, int startInclusive, int endExclusive)
      返回指定数组的指定范围作为源的顺序LongStream 。
      static <T> Stream<T> stream​(T[] array)
      返回具有指定数组的序列Stream作为其来源。
      static <T> Stream<T> stream​(T[] array, int startInclusive, int endExclusive)
      返回指定数组的指定范围作为源的顺序Stream 。
      static String toString​(boolean[] a)
      返回指定数组的内容的字符串表示形式。
      static String toString​(byte[] a)
      返回指定数组的内容的字符串表示形式。
      static String toString​(char[] a)
      返回指定数组的内容的字符串表示形式。
      static String toString​(double[] a)
      返回指定数组的内容的字符串表示形式。
      static String toString​(float[] a)
      返回指定数组的内容的字符串表示形式。
      static String toString​(int[] a)
      返回指定数组的内容的字符串表示形式。
      static String toString​(long[] a)
      返回指定数组的内容的字符串表示形式。
      static String toString​(short[] a)
      返回指定数组的内容的字符串表示形式。
      static String toString​(Object[] a)
      返回指定数组的内容的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • sort

        public static void sort​(int[] a)
        按照数字顺序排列指定的数组。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组

      • sort

        public static void sort​(int[] a,
                        int fromIndex,
                        int toIndex)
        按升序排列数组的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 如果是fromIndex == toIndex ， fromIndex == toIndex排序的范围为空。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素（包括）的索引
        toIndex - 最后一个要排序的元素的索引
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • sort

        public static void sort​(long[] a)
        按照数字顺序排列指定的数组。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组

      • sort

        public static void sort​(long[] a,
                        int fromIndex,
                        int toIndex)
        按升序排列数组的指定范围。 要排序的范围从索引号fromIndex扩展到索引toIndex ，排他。 如果是fromIndex == toIndex ， fromIndex == toIndex排序的范围为空。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 最后一个要排序的元素的索引
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • sort

        public static void sort​(short[] a)
        按照数字顺序排列指定的数组。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组

      • sort

        public static void sort​(short[] a,
                        int fromIndex,
                        int toIndex)
        按升序排列数组的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 如果fromIndex == toIndex ，要排序的范围为空。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素（包括）的索引
        toIndex - 最后一个要排序的元素的索引
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • sort

        public static void sort​(char[] a)
        按照数字顺序排列指定的数组。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组

      • sort

        public static void sort​(char[] a,
                        int fromIndex,
                        int toIndex)
        按升序排列数组的指定范围。 要排序的范围从指数fromIndex扩展到索引toIndex ，排他。 如果fromIndex == toIndex ，要排序的范围为空。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 最后一个要排序的元素的索引
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • sort

        public static void sort​(byte[] a)
        按照数字顺序排列指定的数组。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组

      • sort

        public static void sort​(byte[] a,
                        int fromIndex,
                        int toIndex)
        按升序排列数组的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 如果fromIndex == toIndex ，要排序的范围为空。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 要排序的最后一个元素的索引，排他
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • sort

        public static void sort​(float[] a)
        按照数字顺序排列指定的数组。

        <关系不提供所有浮点值的总订单： -0.0f == 0.0f为true而Float.NaN值既不小于，大于也不等于任何值，甚至本身。 该方法使用方法Float.compareTo(java.lang.Float) ： -0.0f处理的总顺序被视为小于值0.0f和Float.NaN被认为大于任何其他值，并且所有Float.NaN值被认为是相等的。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组

      • sort

        public static void sort​(float[] a,
                        int fromIndex,
                        int toIndex)
        按升序排列数组的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 如果fromIndex == toIndex ，要排序的范围是空的。

        所述<关系不能在所有浮点值提供一个总次序： -0.0f == 0.0f是true和Float.NaN值进行比较既不小于，大于，也不等于任何值，甚至本身。 该方法使用方法Float.compareTo(java.lang.Float)施加的总顺序： -0.0f被视为小于值0.0f并且Float.NaN被认为大于任何其他值，并且全部Float.NaN值被认为是相等的。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 要排序的最后一个元素的索引，排他
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • sort

        public static void sort​(double[] a)
        按照数字顺序排列指定的数组。

        所述<关系不能在所有的双精度值提供一个总次序： -0.0d == 0.0d是true和Double.NaN值进行比较既不小于，大于，也不等于任何值，甚至本身。 这种方法使用方法Double.compareTo(java.lang.Double) ： -0.0d处理的总顺序被视为小于值0.0d和Double.NaN被认为大于任何其他值，并且所有Double.NaN值被认为是相等的。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组

      • sort

        public static void sort​(double[] a,
                        int fromIndex,
                        int toIndex)
        按升序排列数组的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他性。 如果是fromIndex == toIndex ， fromIndex == toIndex排序的范围为空。

        所述<关系不能在所有的双精度值提供一个总次序： -0.0d == 0.0d是true和Double.NaN值进行比较既不小于，大于，也不等于任何值，甚至本身。 该方法使用方法Double.compareTo(java.lang.Double) ： -0.0d的总顺序被视为小于值0.0d并且Double.NaN被认为大于任何其他值，并且所有Double.NaN值被认为是相等的。

        实施注意事项：排序算法是由Vladimir Yaroslavskiy，Jon Bentley和Joshua Bloch提供的双轴快速排序。 该算法在许多数据集上提供O（n log（n））性能，导致其他快速排序降级为二次性能，并且通常比传统（单轴）Quicksort实现更快。

        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 最后一个要排序的元素的索引
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • parallelSort

        public static void parallelSort​(byte[] a)
        按照数字顺序排列指定的数组。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要一个不大于原始数组大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(byte[] a,
                                int fromIndex,
                                int toIndex)
        按照数字顺序排列数组的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 如果是fromIndex == toIndex ， fromIndex == toIndex排序的范围为空。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法排序。 该算法需要不大于原始数组的指定范围的大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素（包括）的索引
        toIndex - 最后一个要排序的元素的索引
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(char[] a)
        按照数字顺序排列指定的数组。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法排序。 该算法需要一个不大于原始数组大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(char[] a,
                                int fromIndex,
                                int toIndex)
        按照数字顺序排列数组的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 如果是fromIndex == toIndex ，要排序的范围为空。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法排序。 该算法需要不大于原始数组的指定范围的大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素（包括）的索引
        toIndex - 最后一个要排序的元素的索引
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(short[] a)
        按照数字顺序排列指定的数组。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要一个不大于原始数组大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(short[] a,
                                int fromIndex,
                                int toIndex)
        按照数字顺序排列数组的指定范围。 要排序的范围从索引fromIndex （含）延伸到索引toIndex ，排他。 如果是fromIndex == toIndex ， fromIndex == toIndex排序的范围为空。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要不大于原始数组的指定范围的大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 要排序的最后一个元素的索引，排他
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(int[] a)
        按照数字顺序排列指定的数组。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要一个不大于原始数组大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(int[] a,
                                int fromIndex,
                                int toIndex)
        按照数字顺序排列数组的指定范围。 要排序的范围从索引fromIndex （含）延伸到索引toIndex ，排他。 如果是fromIndex == toIndex ， fromIndex == toIndex排序的范围为空。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要不大于原始数组的指定范围的大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 要排序的最后一个元素的索引，排他
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或者 toIndex > a.length
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(long[] a)
        按照数字顺序排列指定的数组。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要一个不大于原始数组大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(long[] a,
                                int fromIndex,
                                int toIndex)
        按照数字顺序排列数组的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 如果是fromIndex == toIndex ，要排序的范围为空。
        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要不大于原始数组的指定范围的大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 最后一个要排序的元素的索引
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(float[] a)
        按照数字顺序排列指定的数组。

        <关系不会提供所有浮动值的总订单： -0.0f == 0.0f为true而Float.NaN值既不小于，大于也不等于任何值，甚至本身。 这种方法使用方法Float.compareTo(java.lang.Float) ： -0.0f处理的总顺序被视为小于值0.0f和Float.NaN被认为大于任何其他值，并且所有Float.NaN值都被认为是相等的。

        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要一个不大于原始数组大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(float[] a,
                                int fromIndex,
                                int toIndex)
        按照数字顺序排列数组的指定范围。 要排序的范围从指数fromIndex （含）扩展到索引toIndex ，排他性。 如果是fromIndex == toIndex ， fromIndex == toIndex排序的范围为空。

        所述<关系不能在所有浮点值提供一个总次序： -0.0f == 0.0f是true和Float.NaN值进行比较既不小于，大于，也不等于任何值，甚至本身。 该方法使用方法Float.compareTo(java.lang.Float) ： -0.0f处理的总顺序被视为小于值0.0f并且Float.NaN被认为大于任何其他值，并且所有Float.NaN值被认为是相等的。

        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要不大于原始数组的指定范围的大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 要排序的最后一个元素的索引，排他
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(double[] a)
        按照数字顺序排列指定的数组。

        <关系不提供所有双重值的总订单： -0.0d == 0.0d为true而Double.NaN值既不小于，大于也不等于任何值，甚至本身。 该方法使用方法Double.compareTo(java.lang.Double) ： -0.0d处理的总顺序被视为小于值0.0d并且Double.NaN被认为大于任何其他值，并且全部Double.NaN值被认为是相等的。

        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法排序。 该算法需要一个不大于原始数组大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        从以下版本开始：
        1.8

      • parallelSort

        public static void parallelSort​(double[] a,
                                int fromIndex,
                                int toIndex)
        按照数字顺序排列数组的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 如果fromIndex == toIndex ，要排序的范围是空的。

        <关系不能提供所有双重值的总订单： -0.0d == 0.0d为true而Double.NaN值既不小于，大于也不等于任何值，甚至本身。 该方法使用方法Double.compareTo(java.lang.Double) ： -0.0d处理的总顺序被视为小于值0.0d并且Double.NaN被认为大于任何其他值，并且所有Double.NaN值被认为是相等的。

        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要不大于原始数组的指定范围的大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素的索引（包括）
        toIndex - 要排序的最后一个元素的索引，排他
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        从以下版本开始：
        1.8

      • parallelSort

        public static <T extends Comparable<? super T>> void parallelSort​(T[] a)
        根据其元素的natural ordering按照升序排列指定的对象数组。 阵列中的所有元素必须实现Comparable接口。 此外，数组中的所有元素必须相互可比较 （即， e1.compareTo(e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要一个不大于原始数组大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数类型
        T - 要排序的对象的类
        参数
        a - 要排序的数组
        异常
        ClassCastException - 如果数组包含不 相互比较的元素（例如字符串和整数）
        IllegalArgumentException - （可选）如果发现数组元素的自然排序违反了Comparable合同
        从以下版本开始：
        1.8

      • parallelSort

        public static <T extends Comparable<? super T>> void parallelSort​(T[] a,
                                                                  int fromIndex,
                                                                  int toIndex)
        根据其元素的natural ordering ，将指定的对象数组的指定范围按升序排列。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果为fromIndex==toIndex ， fromIndex==toIndex排序的范围为空。）此范围内的所有元素必须实现Comparable接口。 此外，该范围内的所有元素必须相互可比较 （即， e1.compareTo(e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要不大于原始数组的指定范围的大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数类型
        T - 要排序的对象的类
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素（包括）的索引
        toIndex - 要排序的最后一个元素（排他）的索引
        异常
        IllegalArgumentException - 如果是fromIndex > toIndex或（可选）如果发现数组元素的自然排序违反了Comparable合同
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        ClassCastException - 如果数组包含不 相互比较的元素（例如，字符串和整数）。
        从以下版本开始：
        1.8

      • parallelSort

        public static <T> void parallelSort​(T[] a,
                                    Comparator<? super T> cmp)
        根据指定的比较器引发的顺序对指定的对象数组进行排序。 数组中的所有元素必须由指定的比较器相互比较（即， c.compare(e1, e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要一个不大于原始数组大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数类型
        T - 要排序的对象的类
        参数
        a - 要排序的数组
        cmp - 比较器确定阵列的顺序。 A null值表示应使用元素' natural ordering '。
        异常
        ClassCastException - 如果数组包含使用指定比较器不 相互比较的元素
        IllegalArgumentException - （可选）如果比较方发现违反Comparator合同
        从以下版本开始：
        1.8

      • parallelSort

        public static <T> void parallelSort​(T[] a,
                                    int fromIndex,
                                    int toIndex,
                                    Comparator<? super T> cmp)
        根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他性。 （如果fromIndex==toIndex ，则排序范围为空。）范围内的所有元素都必须是指定比较相互比较的 （即， c.compare(e1, e2)不得抛出ClassCastException任何元件e1和e2在范围内）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        Implementation Note:
        排序算法是一个并行排序合并，将数组分解为本身排序然后合并的子数组。 当子阵列长度达到最小粒度时，使用适当的Arrays.sort方法对子阵列进行排序。 如果指定数组的长度小于最小粒度，则使用适当的Arrays.sort方法进行排序。 该算法需要不大于原始数组的指定范围的大小的工作空间。 ForkJoin common pool用于执行任何并行任务。
        参数类型
        T - 要排序的对象的类
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素（包括）的索引
        toIndex - 要排序的最后一个元素（排他）的索引
        cmp - 比较器确定阵列的顺序。 A null值表示应使用元素' natural ordering '。
        异常
        IllegalArgumentException - 如果fromIndex > toIndex或（可选）如果发现数组元素的自然排序违反了Comparable合同
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        ClassCastException - 如果数组包含不 相互比较的元素（例如字符串和整数）。
        从以下版本开始：
        1.8

      • sort

        public static void sort​(Object[] a)
        根据其元素的natural ordering ，按照升序排列指定的对象数组。 阵列中的所有元素必须实现Comparable接口。 此外，数组中的所有元素必须相互可比较 （即， e1.compareTo(e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        实现注意事项：这个实现是一个稳定的，自适应的，迭代的mergeesort，当输入数组被部分排序时，需要比n lg（n）的比较少得多，同时在输入数组被随机排列时提供传统的mergeesort的性能。 如果输入数组几乎被排序，则实现需要大致n个比较。 临时存储要求从几乎排序的输入数组的小常数到随机排序的输入数组的n / 2对象引用。

        该实现在其输入数组中具有上升和下降的同等优势，并且可以在同一输入数组的不同部分中利用升序和降序。 它非常适合合并两个或多个排序的数组：简单地连接数组并排序生成的数组。

        该实现根据Tim Peters的Python列表（ TimSort ）进行了改编。 它使用Peter McIlroy的“乐观排序和信息理论复杂性”中的技术，在第四届ACM-SIAM离散算法研讨会论文集，pp 467-474，1993年1月。

        参数
        a - 要排序的数组
        异常
        ClassCastException - 如果数组包含不 相互比较的元素（例如，字符串和整数）
        IllegalArgumentException - （可选）如果发现数组元素的自然排序违反了Comparable合同

      • sort

        public static void sort​(Object[] a,
                        int fromIndex,
                        int toIndex)
        根据其元素的natural ordering按照升序排列指定数组对象的指定范围。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果fromIndex==toIndex ，要排序的范围为空。）此范围内的所有元素必须实现Comparable接口。 此外，该范围内的所有元素必须相互可比较 （即， e1.compareTo(e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        实现注意事项：这个实现是一个稳定的，自适应的，迭代的mergeesort，当输入数组被部分排序时，需要比n lg（n）的比较少得多，同时在输入数组被随机排列时提供传统的mergeesort的性能。 如果输入数组几乎被排序，则实现需要大致n个比较。 临时存储要求从几乎排序的输入数组的小常数到随机排序的输入数组的n / 2对象引用。

        该实现在其输入数组中具有上升和下降的同等优势，并且可以在同一输入数组的不同部分中利用升序和降序。 它非常适合合并两个或多个排序的数组：简单地连接数组并排序生成的数组。

        实施从Tim Peters的Python列表排序（ TimSort ）进行了改编。 它使用Peter McIlroy的“乐观排序和信息理论复杂性”中的技术，在第四届ACM-SIAM离散算法研讨会论文集，pp 467-474，1993年1月。

        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素（包括）的索引
        toIndex - 要排序的最后一个元素（排他）的索引
        异常
        IllegalArgumentException - 如果是fromIndex > toIndex或（可选）如果发现数组元素的自然排序违反了Comparable合同
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        ClassCastException - 如果数组包含不 相互比较的元素（例如，字符串和整数）。

      • sort

        public static <T> void sort​(T[] a,
                            Comparator<? super T> c)
        根据指定的比较器引发的顺序对指定的对象数组进行排序。 数组中的所有元素必须由指定的比较器相互比较（即， c.compare(e1, e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        实现注意事项：这个实现是一个稳定的，自适应的，迭代的mergeesort，当输入数组被部分排序时，需要比n lg（n）的比较少得多，同时在输入数组被随机排列时提供传统的mergeesort的性能。 如果输入数组几乎被排序，则实现需要大致n个比较。 临时存储要求从几乎排序的输入数组的小常数到随机排序的输入数组的n / 2对象引用。

        该实现在其输入数组中具有上升和下降的同等优势，并且可以在同一输入数组的不同部分中利用升序和降序。 它非常适合合并两个或多个排序的数组：简单地连接数组并排序生成的数组。

        该实现是从Tim Peters的Python列表中进行了改编（ TimSort ）。 它使用Peter McIlroy的“乐观排序和信息理论复杂性”中的技术，在第四届ACM-SIAM离散算法研讨会论文集，pp 467-474，1993年1月。

        参数类型
        T - 要排序的对象的类
        参数
        a - 要排序的数组
        c - 比较器来确定数组的顺序。 A null值表示应使用元素' natural ordering '。
        异常
        ClassCastException - 如果数组包含使用指定的比较器不 相互比较的元素
        IllegalArgumentException - （可选）如果比较器被发现违反了Comparator合同

      • sort

        public static <T> void sort​(T[] a,
                            int fromIndex,
                            int toIndex,
                            Comparator<? super T> c)
        根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。 要排序的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果为fromIndex==toIndex ， fromIndex==toIndex排序的范围为空。）范围中的所有元素必须通过指定的比较器相互比较（即c.compare(e1, e2)不得在任何元素e1和e2范围内抛出ClassCastException ）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        实现注意事项：这个实现是一个稳定的，自适应的，迭代的mergeesort，当输入数组被部分排序时，需要比n lg（n）的比较少得多，同时在输入数组被随机排列时提供传统的mergeesort的性能。 如果输入数组几乎被排序，则实现需要大致n个比较。 临时存储要求从几乎排序的输入数组的小常数到随机排序的输入数组的n / 2对象引用。

        该实现在其输入数组中具有上升和下降的同等优势，并且可以在同一输入数组的不同部分中利用升序和降序。 它非常适合合并两个或多个排序的数组：简单地连接数组并排序生成的数组。

        该实现从Tim Peters的Python列表（ TimSort ）进行了改编。 它使用Peter McIlroy的“乐观排序和信息理论复杂性”中的技术，在第四届ACM-SIAM离散算法研讨会论文集，pp 467-474，1993年1月。

        参数类型
        T - 要排序的对象的类
        参数
        a - 要排序的数组
        fromIndex - 要排序的第一个元素（包括）的索引
        toIndex - 要排序的最后一个元素（排他）的索引
        c - 比较器来确定数组的顺序。 A null值表示应使用元素' natural ordering '。
        异常
        ClassCastException - 如果数组包含使用指定的比较器不 相互比较的元素。
        IllegalArgumentException - 如果是fromIndex > toIndex或（可选）如果比较方发现违反Comparator合同
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • parallelPrefix

        public static <T> void parallelPrefix​(T[] array,
                                      BinaryOperator<T> op)
        使用提供的功能，并行地计算给定阵列的每个元素。 例如，如果阵列最初持有[2, 1, 0, 3]并且操作执行添加，则返回时阵列将保持[2, 3, 3, 6] 。 并行前缀计算通常比大数组的顺序循环更有效。
        参数类型
        T - 数组中对象的类
        参数
        array - 通过这种方法就地修改的数组
        op - 执行累积的无副作用的关联函数
        异常
        NullPointerException - 如果指定的数组或函数为空
        从以下版本开始：
        1.8

      • parallelPrefix

        public static <T> void parallelPrefix​(T[] array,
                                      int fromIndex,
                                      int toIndex,
                                      BinaryOperator<T> op)
        对于数组的给定子范围执行 parallelPrefix(Object[], BinaryOperator) 。
        参数类型
        T - 数组中对象的类
        参数
        array - 数组
        fromIndex - 第一个元素的索引（包括）
        toIndex - 最后一个元素的索引，独占
        op - 执行累积的无副作用的关联函数
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > array.length
        NullPointerException - 如果指定的数组或函数为空
        从以下版本开始：
        1.8

      • parallelPrefix

        public static void parallelPrefix​(long[] array,
                                  LongBinaryOperator op)
        使用提供的功能，并行地计算给定阵列的每个元素。 例如，如果数组最初持有[2, 1, 0, 3] ，并且操作执行添加，则返回时，数组将保持[2, 3, 3, 6] 。 并行前缀计算通常比大数组的顺序循环更有效。
        参数
        array - 通过此方法就地修改的数组
        op - 一种无副作用的关联函数来执行累积
        异常
        NullPointerException - 如果指定的数组或函数为空
        从以下版本开始：
        1.8

      • parallelPrefix

        public static void parallelPrefix​(long[] array,
                                  int fromIndex,
                                  int toIndex,
                                  LongBinaryOperator op)
        对于数组的给定子范围执行 parallelPrefix(long[], LongBinaryOperator) 。
        参数
        array - 数组
        fromIndex - 第一个元素的索引（包括）
        toIndex - 最后一个元素的索引，独占
        op - 执行累积的无副作用的关联函数
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > array.length
        NullPointerException - 如果指定的数组或函数为空
        从以下版本开始：
        1.8

      • parallelPrefix

        public static void parallelPrefix​(double[] array,
                                  DoubleBinaryOperator op)
        使用提供的功能，并行地计算给定阵列的每个元素。 例如，如果阵列最初持有[2.0, 1.0, 0.0, 3.0]并且操作执行添加，则返回时，数组将保持[2.0, 3.0, 3.0, 6.0] 。 并行前缀计算通常比大数组的顺序循环更有效。

        因为浮点运算可能不是严格关联的，所以返回的结果可能不一致，如果顺序执行操作将获得的值。

        参数
        array - 通过此方法就地修改的数组
        op - 执行累积的无副作用的功能
        异常
        NullPointerException - 如果指定的数组或函数为空
        从以下版本开始：
        1.8

      • parallelPrefix

        public static void parallelPrefix​(double[] array,
                                  int fromIndex,
                                  int toIndex,
                                  DoubleBinaryOperator op)
        对于数组的给定子范围执行 parallelPrefix(double[], DoubleBinaryOperator) 。
        参数
        array - 数组
        fromIndex - 第一个元素的索引（含）
        toIndex - 最后一个元素的索引，独占
        op - 用于执行累积的无副作用的关联函数
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > array.length
        NullPointerException - 如果指定的数组或函数为空
        从以下版本开始：
        1.8

      • parallelPrefix

        public static void parallelPrefix​(int[] array,
                                  IntBinaryOperator op)
        使用提供的功能，并行地计算给定阵列的每个元素。 例如，如果阵列最初持有[2, 1, 0, 3]并且操作执行添加，则返回时，阵列将保持[2, 3, 3, 6] 。 并行前缀计算通常比大数组的顺序循环更有效。
        参数
        array - 通过此方法就地修改的数组
        op - 一种无副作用的关联函数来执行累积
        异常
        NullPointerException - 如果指定的数组或函数为空
        从以下版本开始：
        1.8

      • parallelPrefix

        public static void parallelPrefix​(int[] array,
                                  int fromIndex,
                                  int toIndex,
                                  IntBinaryOperator op)
        对于数组的给定子范围执行 parallelPrefix(int[], IntBinaryOperator) 。
        参数
        array - 数组
        fromIndex - 第一个元素的索引（含）
        toIndex - 最后一个元素的索引，独占
        op - 一种无副作用的关联函数来执行累积
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > array.length
        NullPointerException - 如果指定的数组或函数为空
        从以下版本开始：
        1.8

      • binarySearch

        public static int binarySearch​(long[] a,
                               long key)
        使用二进制搜索算法搜索指定数组的指定数组。 在进行此调用之前，必须对数组进行排序（按照sort(long[])方法）。 如果没有排序，结果是未定义的。 如果数组包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键插入到数组中的点：第一个元素的索引大于键，如果数组中的所有元素都小于指定的键， a.length 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。

      • binarySearch

        public static int binarySearch​(long[] a,
                               int fromIndex,
                               int toIndex,
                               long key)
        使用二分搜索算法搜索指定值的指定数组的范围。 在进行此呼叫之前，范围必须按照sort(long[], int, int)方法进行排序。 如果没有排序，结果是未定义的。 如果范围包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        fromIndex - 要搜索的第一个元素（包括）的索引
        toIndex - 要搜索的最后一个元素（排他）的索引
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在指定范围内的数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到数组中的点：第一个元素在大于键的范围内的索引，如果范围中的所有元素都小于指定的键， toIndex 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0 or toIndex > a.length
        从以下版本开始：
        1.6

      • binarySearch

        public static int binarySearch​(int[] a,
                               int key)
        使用二叉搜索算法搜索指定的int数组的指定值。 在进行此调用之前，必须对数组进行排序（按照sort(int[])方法）。 如果没有排序，结果是未定义的。 如果数组包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键插入到数组中的点：第一个元素的索引大于键，如果数组中的所有元素都小于指定的键， a.length 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。

      • binarySearch

        public static int binarySearch​(int[] a,
                               int fromIndex,
                               int toIndex,
                               int key)
        使用二叉搜索算法搜索指定值的指定数组的范围。 在进行此呼叫之前，范围必须按照sort(int[], int, int)方法进行排序。 如果没有排序，结果是未定义的。 如果范围包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        fromIndex - 要搜索的第一个元素（包括）的索引
        toIndex - 要搜索的最后一个元素（排他）的索引
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在指定范围内的数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到数组中的点：第一个元素在大于键的范围内的索引，如果范围中的所有元素都小于指定的键， toIndex 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0 or toIndex > a.length
        从以下版本开始：
        1.6

      • binarySearch

        public static int binarySearch​(short[] a,
                               short key)
        使用二进制搜索算法搜索指定值的指定数组的指定值。 在进行此调用之前，必须对数组进行排序（按照sort(short[])方法）。 如果没有排序，结果是未定义的。 如果数组包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键插入到数组中的点：第一个元素的索引大于键，如果数组中的所有元素都小于指定的键， a.length 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。

      • binarySearch

        public static int binarySearch​(short[] a,
                               int fromIndex,
                               int toIndex,
                               short key)
        使用二进制搜索算法搜索指定值的指定数组的短整型范围。 在进行此呼叫之前，范围必须按照sort(short[], int, int)方法进行排序。 如果没有排序，结果是未定义的。 如果范围包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        fromIndex - 要搜索的第一个元素（包括）的索引
        toIndex - 要搜索的最后一个元素（排他）的索引
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在指定范围内的数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到数组中的点：第一个元素在大于键的范围内的索引，如果范围中的所有元素都小于指定的键， toIndex 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0 or toIndex > a.length
        从以下版本开始：
        1.6

      • binarySearch

        public static int binarySearch​(char[] a,
                               char key)
        使用二进制搜索算法搜索指定数组的指定值。 在进行此调用之前，必须对数组进行排序（按照sort(char[])方法）。 如果没有排序，结果是未定义的。 如果数组包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键插入到数组中的点：第一个元素的索引大于键，如果数组中的所有元素都小于指定的键， a.length 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。

      • binarySearch

        public static int binarySearch​(char[] a,
                               int fromIndex,
                               int toIndex,
                               char key)
        使用二分搜索算法搜索指定值的指定数组的范围。 在进行此呼叫之前，该范围必须按照sort(char[], int, int)方法排序。 如果没有排序，结果是未定义的。 如果范围包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        fromIndex - 要搜索的第一个元素（包括）的索引
        toIndex - 要搜索的最后一个元素（排他）的索引
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在指定范围内的数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到数组中的点：第一个元素在大于键的范围内的索引，如果范围中的所有元素都小于指定的键， toIndex 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0 or toIndex > a.length
        从以下版本开始：
        1.6

      • binarySearch

        public static int binarySearch​(byte[] a,
                               byte key)
        使用二进制搜索算法搜索指定值的指定字节数组。 在进行此调用之前，必须对数组进行排序（按照sort(byte[])方法）。 如果没有排序，结果是未定义的。 如果数组包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键插入阵列的点：第一个元素的索引大于键，如果数组中的所有元素都小于指定的键， a.length 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。

      • binarySearch

        public static int binarySearch​(byte[] a,
                               int fromIndex,
                               int toIndex,
                               byte key)
        使用二进制搜索算法搜索指定值的指定字节数组的范围。 在进行此呼叫之前，范围必须按照sort(byte[], int, int)方法进行排序。 如果没有排序，结果是未定义的。 如果范围包含具有指定值的多个元素，则不能保证将找到哪个元素。
        参数
        a - 要搜索的数组
        fromIndex - 要搜索的第一个元素（包括）的索引
        toIndex - 要搜索的最后一个元素（排他）的索引
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在指定范围内的数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到数组中的点：第一个元素在大于键的范围内的索引，如果范围中的所有元素都小于指定的键， toIndex 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0 or toIndex > a.length
        从以下版本开始：
        1.6

      • binarySearch

        public static int binarySearch​(double[] a,
                               double key)
        使用二进制搜索算法搜索指定值的指定数组的双精度值。 在进行此调用之前，数组必须按照sort(double[])方法进行排序。 如果没有排序，结果是未定义的。 如果数组包含具有指定值的多个元素，则不能保证将找到哪个元素。 该方法认为所有的NaN值都是相等的。
        参数
        a - 要搜索的数组
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键插入到数组中的点：第一个元素的索引大于键，如果数组中的所有元素都小于指定的键， a.length 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。

      • binarySearch

        public static int binarySearch​(double[] a,
                               int fromIndex,
                               int toIndex,
                               double key)
        使用二分搜索算法搜索指定值的指定数组的双精度范围。 在进行此呼叫之前，范围必须按照sort(double[], int, int)方法进行排序。 如果没有排序，结果是未定义的。 如果范围包含具有指定值的多个元素，则不能保证将找到哪个元素。 该方法认为所有的NaN值都是相等的。
        参数
        a - 要搜索的数组
        fromIndex - 要搜索的第一个元素（包括）的索引
        toIndex - 要搜索的最后一个元素（排他）的索引
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在指定范围内的数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到数组中的点：第一个元素在大于键的范围内的索引，如果范围中的所有元素都小于指定的键， toIndex 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0 or toIndex > a.length
        从以下版本开始：
        1.6

      • binarySearch

        public static int binarySearch​(float[] a,
                               float key)
        使用二叉搜索算法搜索指定数组的浮点数。 在进行此调用之前，必须对数组进行排序（按照sort(float[])方法）。 如果没有排序，结果是未定义的。 如果数组包含具有指定值的多个元素，则不能保证将找到哪个元素。 该方法认为所有的NaN值都是相等的。
        参数
        a - 要搜索的数组
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键插入到数组中的点：第一个元素的索引大于键，如果数组中的所有元素都小于指定的键， a.length 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。

      • binarySearch

        public static int binarySearch​(float[] a,
                               int fromIndex,
                               int toIndex,
                               float key)
        使用二分搜索算法搜索指定数组的浮点数范围。 在进行此呼叫之前，范围必须按照sort(float[], int, int)方法进行排序。 如果没有排序，结果是未定义的。 如果范围包含具有指定值的多个元素，则不能保证将找到哪个元素。 该方法认为所有的NaN值都是相等的。
        参数
        a - 要搜索的数组
        fromIndex - 要搜索的第一个元素（包括）的索引
        toIndex - 要搜索的最后一个元素（排他）的索引
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在指定范围内的数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键插入到数组中的点：第一个元素在大于键的范围内的索引，如果该范围中的所有元素都小于指定的键， toIndex 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0 or toIndex > a.length
        从以下版本开始：
        1.6

      • binarySearch

        public static int binarySearch​(Object[] a,
                               Object key)
        使用二叉搜索算法搜索指定对象的指定数组。 所述阵列必须根据被按升序排列natural ordering元素（如由sort(Object[])方法）之前使该呼叫。 如果没有排序，结果是未定义的。 （如果数组包含不相互比较的元素（例如字符串和整数），则不能根据其元素的自然排序进行排序，因此结果未定义。）如果数组包含等于指定对象的多个元素，不能保证会找到哪一个。
        参数
        a - 要搜索的数组
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到数组中的点：第一个元素的索引大于键，如果数组中的所有元素都小于指定的键， a.length 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        ClassCastException - 如果搜索关键字与数组的元素无法比较。

      • binarySearch

        public static int binarySearch​(Object[] a,
                               int fromIndex,
                               int toIndex,
                               Object key)
        使用二进制搜索算法搜索指定对象的指定数组的范围。 的范围必须根据被按升序排列natural ordering元素（如由sort(Object[], int, int)方法）之前使该呼叫。 如果没有排序，结果是未定义的。 （如果范围包含不相互比较的元素（例如字符串和整数），则不能根据其元素的自然排序进行排序，因此结果未定义。）如果范围包含等于指定对象的多个元素，不能保证会找到哪一个。
        参数
        a - 要搜索的数组
        fromIndex - 要搜索的第一个元素（包括）的索引
        toIndex - 要搜索的最后一个元素（排他）的索引
        key - 要搜索的值
        结果
        搜索键的索引，如果它包含在指定范围内的数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到数组中的点：第一个元素在大于键的范围内的索引，如果范围中的所有元素都小于指定的键， toIndex 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        ClassCastException - 如果搜索关键字与指定范围内的数组元素无法比较。
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0 or toIndex > a.length
        从以下版本开始：
        1.6

      • binarySearch

        public static <T> int binarySearch​(T[] a,
                                   T key,
                                   Comparator<? super T> c)
        使用二叉搜索算法搜索指定对象的指定数组。 在进行此呼叫之前，阵列必须根据指定的比较器（如sort(T[], Comparator)方法）按升序排序。 如果没有排序，结果是未定义的。 如果数组包含与指定对象相等的多个元素，则不能保证将找到哪个元素。
        参数类型
        T - 数组中对象的类
        参数
        a - 要搜索的数组
        key - 要搜索的值
        c - 数组被排序的比较器。 A null值表示应使用元素natural ordering 。
        结果
        搜索键的索引，如果它包含在数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为将键插入数组的点：第一个元素的索引大于键，如果数组中的所有元素都小于指定的键， a.length 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        ClassCastException - 如果数组包含使用指定的比较器不 相互比较的元素，或者搜索关键字与使用该比较器的数组元素无法比较。

      • binarySearch

        public static <T> int binarySearch​(T[] a,
                                   int fromIndex,
                                   int toIndex,
                                   T key,
                                   Comparator<? super T> c)
        使用二进制搜索算法搜索指定对象的指定数组的范围。 在进行此呼叫之前，该范围必须根据指定的比较器（如sort(T[], int, int, Comparator)方法）按升序排序。 如果没有排序，结果是未定义的。 如果范围包含等于指定对象的多个元素，则不能保证将找到哪个元素。
        参数类型
        T - 数组中对象的类
        参数
        a - 要搜索的数组
        fromIndex - 要搜索的第一个元素（包括）的索引
        toIndex - 要搜索的最后一个元素（排他）的索引
        key - 要搜索的值
        c - 数组排序的比较器。 A null值表示应使用元素' natural ordering '。
        结果
        搜索键的索引，如果它包含在指定范围内的数组中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到数组中的点：第一个元素在大于键的范围内的索引，如果范围中的所有元素都小于指定的键， toIndex 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        ClassCastException - 如果范围包含使用指定的比较器不 相互比较的元素，或者搜索键与使用该比较器的范围内的元素不可比较。
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0 or toIndex > a.length
        从以下版本开始：
        1.6

      • equals

        public static boolean equals​(long[] a,
                             long[] a2)
        如果两个指定的longs数组彼此相等 ，则返回true 。 如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 换句话说，如果两个数组以相同的顺序包含相同的元素，则它们是相等的。 另外，如果两者都是null ，则两个数组引用被认为是null 。
        参数
        a - 要测试相等的一个数组
        a2 - 要测试的另一个数组是否相等
        结果
        true如果两个数组相等

      • equals

        public static boolean equals​(long[] a,
                             int aFromIndex,
                             int aToIndex,
                             long[] b,
                             int bFromIndex,
                             int bToIndex)
        如果指定范围内的两个指定的long数组彼此相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        参数
        a - 要测试的第一个数组的相等性
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试的第二个数组平等
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        如果两个数组在指定的范围内相等， true
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • equals

        public static boolean equals​(int[] a,
                             int[] a2)
        如果两个指定的int数组彼此相等 ，则返回true 。 如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 换句话说，如果两个数组以相同的顺序包含相同的元素，则它们是相等的。 另外，如果两个数组引用都是null则它们被认为是null 。
        参数
        a - 要进行相等测试的一个数组
        a2 - 要进行相等测试的另一个数组
        结果
        true如果两个数组相等

      • equals

        public static boolean equals​(int[] a,
                             int aFromIndex,
                             int aToIndex,
                             int[] b,
                             int bFromIndex,
                             int bToIndex)
        如果两个指定的int数组在指定的范围内彼此相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        参数
        a - 要测试的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要平等测试的第二个数组
        bFromIndex - 要测试的第二个数组中第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        true如果两个数组在指定范围内相等
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • equals

        public static boolean equals​(short[] a,
                             short[] a2)
        如果两个指定的短裤阵列彼此相等 ，则返回true 。 如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 换句话说，如果两个数组以相同的顺序包含相同的元素，则它们是相等的。 另外，如果两者都是null ，则两个数组引用被认为是null 。
        参数
        a - 要进行相等测试的一个数组
        a2 - 要测试的其他数组相等
        结果
        如果两个数组相等， true

      • equals

        public static boolean equals​(short[] a,
                             int aFromIndex,
                             int aToIndex,
                             short[] b,
                             int bFromIndex,
                             int bToIndex)
        如果两个指定的短整型数组在指定的范围内彼此相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        参数
        a - 要测试的第一个数组是否相等
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要平等测试的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        true如果两个数组在指定范围内相等
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • equals

        public static boolean equals​(char[] a,
                             char[] a2)
        如果两个指定的字符数组彼此相等 ，则返回true 。 如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 换句话说，如果两个数组以相同的顺序包含相同的元素，则它们是相等的。 另外，如果两个数组引用都是null则它们被认为是null 。
        参数
        a - 要测试相等的一个数组
        a2 - 要测试的其他数组是否相等
        结果
        true如果两个数组相等

      • equals

        public static boolean equals​(char[] a,
                             int aFromIndex,
                             int aToIndex,
                             char[] b,
                             int bFromIndex,
                             int bToIndex)
        如果两个指定的字符数组在指定范围内彼此相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        参数
        a - 要进行相等测试的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试的第二个数组平等
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        如果两个数组在指定的范围内相等， true
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或者如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或者如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • equals

        public static boolean equals​(byte[] a,
                             byte[] a2)
        如果两个指定的字节数组彼此相等 ，则返回true 。 如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 换句话说，如果两个数组以相同的顺序包含相同的元素，则它们是相等的。 另外，如果两个数组引用都是null则它们被认为是null 。
        参数
        a - 要测试相等的一个数组
        a2 - 要测试的其他数组是否相等
        结果
        true如果两个数组相等

      • equals

        public static boolean equals​(byte[] a,
                             int aFromIndex,
                             int aToIndex,
                             byte[] b,
                             int bFromIndex,
                             int bToIndex)
        如果两个指定的字节数组（在指定范围内）彼此相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        参数
        a - 要测试的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要平等测试的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        如果两个数组在指定的范围内相等， true
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或者是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • equals

        public static boolean equals​(boolean[] a,
                             boolean[] a2)
        如果两个指定的布尔数组彼此相等 ，则返回true 。 如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 换句话说，如果两个数组以相同的顺序包含相同的元素，则它们是相等的。 另外，如果两个数组引用都是null ，则两个数组引用被认为是null 。
        参数
        a - 要测试相等的一个数组
        a2 - 要进行相等测试的另一个数组
        结果
        true如果两个数组相等

      • equals

        public static boolean equals​(boolean[] a,
                             int aFromIndex,
                             int aToIndex,
                             boolean[] b,
                             int bFromIndex,
                             int bToIndex)
        如果两个指定的布尔值数组在指定的范围内彼此相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        参数
        a - 要测试的第一个数组的相等性
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试的第二个数组相等
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        如果两个数组在指定的范围内相等， true
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个数组是 null
        从以下版本开始：
        9

      • equals

        public static boolean equals​(double[] a,
                             double[] a2)
        如果两个指定的双精度数组彼此相等 ，则返回true 。 如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 换句话说，如果两个数组以相同的顺序包含相同的元素，则它们是相等的。 另外，如果两者都是null ，则两个数组引用被认为是null 。 d1和d2两个双打被认为是相等的：
          new Double(d1).equals(new Double(d2))
        （与==运算符不同，该方法认为NaN等于自身，0.0d不等于-0.0d））
        参数
        a - 要进行相等测试的一个数组
        a2 - 要测试的其他数组是否相等
        结果
        如果两个数组相等， true
        另请参见：
        Double.equals(Object)

      • equals

        public static boolean equals​(double[] a,
                             int aFromIndex,
                             int aToIndex,
                             double[] b,
                             int bFromIndex,
                             int bToIndex)
        如果指定范围内的两个指定的双精度数组彼此相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        d1和d2两个双打被认为是相等的：

          new Double(d1).equals(new Double(d2))
        （与==运算符不同，该方法认为NaN等于自身，0.0d不等于-0.0d））
        参数
        a - 要测试的第一个数组的相等性
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要平等测试的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中的最后一个元素的索引（独占）
        结果
        true如果两个数组在指定范围内相等
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或者如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9
        另请参见：
        Double.equals(Object)

      • equals

        public static boolean equals​(float[] a,
                             float[] a2)
        如果两个指定的浮动数组彼此相等 ，则返回true 。 如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 换句话说，如果两个数组以相同的顺序包含相同的元素，则它们是相等的。 另外，如果两个数组引用都是null ，这两个数组引用被认为是null 。 两个浮标f1和f2被认为是相等的：
          new Float(f1).equals(new Float(f2))
        （与==运算符不同，此方法认为NaN等于自身，0.0f不等于-0.0f））
        参数
        a - 要进行相等测试的一个数组
        a2 - 要测试的其他数组是否相等
        结果
        true如果两个数组相等
        另请参见：
        Float.equals(Object)

      • equals

        public static boolean equals​(float[] a,
                             int aFromIndex,
                             int aToIndex,
                             float[] b,
                             int bFromIndex,
                             int bToIndex)
        如果两个指定的浮点数在指定范围内相互相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        如下所示，两个浮标f1和f2被认为是相等的：

          new Float(f1).equals(new Float(f2))
        （与==运算符不同，该方法认为NaN等于自身，0.0f不等于-0.0f））
        参数
        a - 要测试的第一个数组的相等性
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要平等测试的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        如果两个数组在指定范围内相等， true
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或者如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或者如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任何一个数组是 null
        从以下版本开始：
        9
        另请参见：
        Float.equals(Object)

      • equals

        public static boolean equals​(Object[] a,
                             Object[] a2)
        如果两个指定的对象数组彼此相等 ，则返回true 。 如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 如果Objects.equals(e1, e2)则两个对象e1和e2被认为是相等的 。 换句话说，如果两个数组在相同的顺序中包含相同的元素，则它们是相等的。 另外，如果两者都是null ，则两个数组引用被认为是null 。
        参数
        a - 要测试相等的一个数组
        a2 - 要测试的其他数组是否相等
        结果
        true如果两个数组相等

      • equals

        public static boolean equals​(Object[] a,
                             int aFromIndex,
                             int aToIndex,
                             Object[] b,
                             int bFromIndex,
                             int bToIndex)
        如果两个指定的对象数组在指定范围内彼此相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        两个对象e1和e2被认为是如果相等 Objects.equals(e1, e2) 。

        参数
        a - 要测试的第一个数组相等
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要平等测试的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        如果两个数组在指定的范围内相等， true
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或者如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • equals

        public static <T> boolean equals​(T[] a,
                                 T[] a2,
                                 Comparator<? super T> cmp)
        如果两个指定的对象数组彼此相等 ，则返回true 。

        如果两个数组都包含相同数量的元素，则两个数组被认为是相等的，并且两个数组中所有对应的元素对都相等。 换句话说，如果两个数组在相同的顺序中包含相同的元素，则它们是相等的。 另外，如果两个数组引用都是null则它们被认为是null 。

        两个对象e1和e2如果，考虑到指定的比较，被认为是相等 cmp.compare(e1, e2) == 0 。

        参数类型
        T - 数组元素的类型
        参数
        a - 要测试相等的一个数组
        a2 - 要测试的其他数组是否相等
        cmp - 比较器来比较数组元素
        结果
        true如果两个数组相等
        异常
        NullPointerException - 如果比较器是 null
        从以下版本开始：
        9

      • equals

        public static <T> boolean equals​(T[] a,
                                 int aFromIndex,
                                 int aToIndex,
                                 T[] b,
                                 int bFromIndex,
                                 int bToIndex,
                                 Comparator<? super T> cmp)
        如果两个指定的对象数组在指定范围内彼此相等 ，则返回true。

        如果每个范围覆盖的元素数量相同，则两个数组被认为是相等的，并且两个数组中指定范围内的所有相应元素对相等。 换句话说，如果两个数组在指定范围内以相同的顺序包含相同的元素，则它们是相等的。

        两个对象e1和e2如果，考虑到指定的比较，被认为是相等 cmp.compare(e1, e2) == 0 。

        参数类型
        T - 数组元素的类型
        参数
        a - 要测试的第一个数组的相等性
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要平等测试的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        cmp - 比较器来比较数组元素
        结果
        如果两个数组在指定的范围内相等， true
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任何一个阵列或比较器是 null
        从以下版本开始：
        9

      • fill

        public static void fill​(long[] a,
                        long val)
        将指定的long值分配给指定的longs数组的每个元素。
        参数
        a - 要填充的数组
        val - 要存储在数组的所有元素中的值

      • fill

        public static void fill​(long[] a,
                        int fromIndex,
                        int toIndex,
                        long val)
        将指定的long值分配给指定的longs数组的指定范围的每个元素。 要填充的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果为fromIndex==toIndex ，则填充的范围为空。）
        参数
        a - 要填充的数组
        fromIndex - 要填充指定值的第一个元素（包括）的索引
        toIndex - 要用指定值填充的最后一个元素（排除）的索引
        val - 要存储在数组的所有元素中的值
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • fill

        public static void fill​(int[] a,
                        int val)
        将指定的int值分配给指定的int数组的每个元素。
        参数
        a - 要填充的数组
        val - 要存储在数组的所有元素中的值

      • fill

        public static void fill​(int[] a,
                        int fromIndex,
                        int toIndex,
                        int val)
        将指定的int值分配给指定的int数组的指定范围的每个元素。 要填充的范围从索引fromIndex （包括索引） toIndex到索引toIndex ，排他。 （如果是fromIndex==toIndex ，要填充的范围是空的。）
        参数
        a - 要填充的数组
        fromIndex - 要用指定值填充的第一个元素（包括）的索引
        toIndex - 要用指定值填充的最后一个元素（排除）的索引
        val - 要存储在数组的所有元素中的值
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • fill

        public static void fill​(short[] a,
                        short val)
        将指定的短值分配给指定的短裤数组的每个元素。
        参数
        a - 要填充的数组
        val - 要存储在数组的所有元素中的值

      • fill

        public static void fill​(short[] a,
                        int fromIndex,
                        int toIndex,
                        short val)
        将指定的短值分配给指定的短裤数组的指定范围的每个元素。 要填充的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果是fromIndex==toIndex ，要填充的范围是空的。）
        参数
        a - 要填充的数组
        fromIndex - 要填充指定值的第一个元素（含）的索引
        toIndex - 要用指定值填充的最后一个元素（排除）的索引
        val - 要存储在数组的所有元素中的值
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • fill

        public static void fill​(char[] a,
                        char val)
        将指定的char值分配给指定的char数组的每个元素。
        参数
        a - 要填充的数组
        val - 要存储在数组的所有元素中的值

      • fill

        public static void fill​(char[] a,
                        int fromIndex,
                        int toIndex,
                        char val)
        将指定的char值分配给指定的char数组的指定范围的每个元素。 要填充的范围从索引fromIndex （包括索引） toIndex到索引toIndex ，排他。 （如果为fromIndex==toIndex ，则填充的范围为空。）
        参数
        a - 要填充的数组
        fromIndex - 要用指定值填充的第一个元素（包括）的索引
        toIndex - 要用指定值填充的最后一个元素（独占）的索引
        val - 要存储在数组的所有元素中的值
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • fill

        public static void fill​(byte[] a,
                        byte val)
        将指定的字节值分配给指定字节数组的每个元素。
        参数
        a - 要填充的数组
        val - 要存储在数组的所有元素中的值

      • fill

        public static void fill​(byte[] a,
                        int fromIndex,
                        int toIndex,
                        byte val)
        将指定的字节值分配给指定字节数组的指定范围的每个元素。 要填充的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果是fromIndex==toIndex ，填充的范围是空的。）
        参数
        a - 要填充的数组
        fromIndex - 要用指定值填充的第一个元素（包括）的索引
        toIndex - 要用指定值填充的最后一个元素（排除）的索引
        val - 要存储在数组的所有元素中的值
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • fill

        public static void fill​(boolean[] a,
                        boolean val)
        将指定的布尔值分配给指定的布尔数组的每个元素。
        参数
        a - 要填充的数组
        val - 要存储在数组的所有元素中的值

      • fill

        public static void fill​(boolean[] a,
                        int fromIndex,
                        int toIndex,
                        boolean val)
        将指定的布尔值分配给指定数组布尔值的指定范围的每个元素。 要填充的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果为fromIndex==toIndex ，则填充的范围为空。）
        参数
        a - 要填充的数组
        fromIndex - 要填充指定值的第一个元素（包括）的索引
        toIndex - 要用指定值填充的最后一个元素（排除）的索引
        val - 要存储在数组的所有元素中的值
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • fill

        public static void fill​(double[] a,
                        double val)
        将指定的double值分配给指定的双精度数组的每个元素。
        参数
        a - 要填充的数组
        val - 要存储在数组的所有元素中的值

      • fill

        public static void fill​(double[] a,
                        int fromIndex,
                        int toIndex,
                        double val)
        将指定的double值分配给指定的双精度数组范围的每个元素。 要填充的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果为fromIndex==toIndex ，则填充的范围为空。）
        参数
        a - 要填充的数组
        fromIndex - 要用指定值填充的第一个元素（包括）的索引
        toIndex - 要用指定值填充的最后一个元素（排除）的索引
        val - 要存储在数组的所有元素中的值
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • fill

        public static void fill​(float[] a,
                        float val)
        将指定的float值分配给指定的浮点数组的每个元素。
        参数
        a - 要填充的数组
        val - 要存储在数组的所有元素中的值

      • fill

        public static void fill​(float[] a,
                        int fromIndex,
                        int toIndex,
                        float val)
        将指定的浮点值分配给指定的浮点数组的指定范围的每个元素。 要填充的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果是fromIndex==toIndex ，填充的范围是空的。）
        参数
        a - 要填充的数组
        fromIndex - 要用指定值填充的第一个元素（包括）的索引
        toIndex - 要用指定值填充的最后一个元素（排除）的索引
        val - 要存储在数组的所有元素中的值
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length

      • fill

        public static void fill​(Object[] a,
                        Object val)
        将指定的对象引用分配给指定的对象数组的每个元素。
        参数
        a - 要填充的数组
        val - 要存储在数组的所有元素中的值
        异常
        ArrayStoreException - 如果指定的值不是可以存储在指定数组中的运行时类型

      • fill

        public static void fill​(Object[] a,
                        int fromIndex,
                        int toIndex,
                        Object val)
        将指定的对象引用分配给指定的对象数组的指定范围的每个元素。 要填充的范围从索引fromIndex （包括）扩展到索引toIndex ，排他。 （如果是fromIndex==toIndex ，要填充的范围是空的。）
        参数
        a - 要填充的数组
        fromIndex - 要用指定值填充的第一个元素（包括）的索引
        toIndex - 要用指定值填充的最后一个元素（排除）的索引
        val - 要存储在数组的所有元素中的值
        异常
        IllegalArgumentException - 如果是 fromIndex > toIndex
        ArrayIndexOutOfBoundsException - 如果是 fromIndex < 0或 toIndex > a.length
        ArrayStoreException - 如果指定的值不是可以存储在指定数组中的运行时类型

      • copyOf

        public static <T> T[] copyOf​(T[] original,
                             int newLength)
        复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本而不是原件有效的任何索引，副本将包含null 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。 结果数组与原始数组完全相同的类。
        参数类型
        T - 数组中对象的类
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        结果
        原始数组的副本，截断或填充空值以获取指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOf

        public static <T,U> T[] copyOf​(U[] original,
                               int newLength,
                               Class<? extends T[]> newType)
        复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本中而不是原件有效的任何索引，副本将包含null 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。 最终的数组是newType 。
        参数类型
        U - 原始数组中对象的类
        T - 返回数组中对象的类
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        newType - 要返回的副本的类
        结果
        原始数组的副本，截断或填充空值以获取指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        ArrayStoreException - 如果从 original复制的元素不是可以存储在 newType的数组中的运行时类型
        从以下版本开始：
        1.6

      • copyOf

        public static byte[] copyOf​(byte[] original,
                            int newLength)
        复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本中而不是原件有效的任何索引，副本将包含(byte)0 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        结果
        原始数组的副本，被截断或用零填充以获得指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOf

        public static short[] copyOf​(short[] original,
                             int newLength)
        复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本中有效但不是原件的任何索引，副本将包含(short)0 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        结果
        原始数组的副本，被截断或用零填充以获得指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOf

        public static int[] copyOf​(int[] original,
                           int newLength)
        复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本中而不是原件有效的任何索引，副本将包含0 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        结果
        原始数组的副本，被截断或用零填充以获得指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOf

        public static long[] copyOf​(long[] original,
                            int newLength)
        复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本中而不是原件有效的任何索引，副本将包含0L 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        结果
        原始数组的副本，被截断或用零填充以获得指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOf

        public static char[] copyOf​(char[] original,
                            int newLength)
        复制指定的数组，截断或填充空字符（如有必要），以便复制具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本中而不是原件有效的任何索引，副本将包含'\\u000' 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        结果
        原始数组的副本，截断或填充空字符以获取指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOf

        public static float[] copyOf​(float[] original,
                             int newLength)
        复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本中而不是原件有效的任何索引，副本将包含0f 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        结果
        原始数组的副本，被截断或用零填充以获得指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOf

        public static double[] copyOf​(double[] original,
                              int newLength)
        复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本中而不是原件有效的任何索引，副本将包含0d 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        结果
        原始数组的副本，被截断或用零填充以获得指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOf

        public static boolean[] copyOf​(boolean[] original,
                               int newLength)
        复制指定的数组，截断或填充false （如有必要），因此副本具有指定的长度。 对于原始数组和副本都有效的所有索引，两个数组将包含相同的值。 对于在副本中而不是原件有效的任何索引，副本将包含false 。 当且仅当指定长度大于原始数组的长度时，这些索引才会存在。
        参数
        original - 要复制的数组
        newLength - 要返回的副本的长度
        结果
        原始数组的副本，被截断或填充有假元素以获得指定的长度
        异常
        NegativeArraySizeException - 如果 newLength为负数
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOfRange

        public static <T> T[] copyOfRange​(T[] original,
                                  int from,
                                  int to)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须介于零至original.length之间，包括original.length 。 original[from]的值被放置在副本的初始元素中（除非是from == original.length或from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 范围（ to ）的最终指数（ to ）必须大于或等于from ，可能大于original.length ，在这种情况下， null被放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。

        结果数组与原始数组完全相同的类。

        参数类型
        T - 数组中对象的类
        参数
        original - 要从中复制范围的数组
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        结果
        一个包含原始数组的指定范围的新数组，用空值截断或填充以获取所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOfRange

        public static <T,U> T[] copyOfRange​(U[] original,
                                    int from,
                                    int to,
                                    Class<? extends T[]> newType)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须在零和original.length之间，包括在内。 original[from]的值被放置在副本的初始元素中（除非是from == original.length或from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 范围（ to ）的最终指数（ to ）必须大于或等于from ，可能大于original.length ，在这种情况下， null被放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。 最终的数组是newType 。
        参数类型
        U - 原始数组中对象的类
        T - 返回数组中对象的类
        参数
        original - 要复制范围的阵列
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        newType - 要返回的副本的类
        结果
        一个包含原始数组的指定范围的新数组，用空值截断或填充以获取所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        ArrayStoreException - 如果从 original复制的元素不是可以存储在 newType类的数组中的运行时类型。
        从以下版本开始：
        1.6

      • copyOfRange

        public static byte[] copyOfRange​(byte[] original,
                                 int from,
                                 int to)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须介于零至original.length之间（ from ）。 original[from]的值被放置在副本的初始元素中（除非是from == original.length或from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 范围（ to ）的最终指数（ to ）必须大于或等于from ，可能大于original.length ，在这种情况下， (byte)0被放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。
        参数
        original - 要复制范围的数组
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        结果
        一个包含原始数组的指定范围的新数组，用零截取或填充以获得所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOfRange

        public static short[] copyOfRange​(short[] original,
                                  int from,
                                  int to)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须介于零至original.length之间（ from ）。 original[from]的值被放置在副本的初始元素中（除非是from == original.length或from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 必须大于或等于from的范围（ to ）的最终索引可能大于original.length ，在这种情况下， (short)0被放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。
        参数
        original - 要从中复制范围的数组
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        结果
        一个包含原始数组的指定范围的新数组，用零截取或填充以获得所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOfRange

        public static int[] copyOfRange​(int[] original,
                                int from,
                                int to)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须介于零和original.length之间，包括original.length 。 original[from]的值被放置在副本的初始元素中（除非是from == original.length或from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 范围（ to ）的最终索引（ to ）必须大于或等于from ，可能大于original.length ，在这种情况下， 0被放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。
        参数
        original - 要从中复制范围的数组
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        结果
        一个包含原始数组的指定范围的新数组，用零截取或填充以获得所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOfRange

        public static long[] copyOfRange​(long[] original,
                                 int from,
                                 int to)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须介于零至original.length之间（ from ）。 original[from]的值被放置在副本的初始元素中（除非是from == original.length或from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 必须大于或等于from的范围（ to ）的最终索引可能大于original.length ，在这种情况下， 0L被放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。
        参数
        original - 要从中复制范围的数组
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        结果
        一个包含原始数组的指定范围的新数组，用零截取或填充以获得所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOfRange

        public static char[] copyOfRange​(char[] original,
                                 int from,
                                 int to)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须介于零至original.length之间（ from ）。 original[from]的值被放入副本的初始元素（除非是from == original.length或from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 必须大于或等于from的范围（ to ）的最终索引可能大于original.length ，在这种情况下， '\\u000'将放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。
        参数
        original - 要从中复制范围的数组
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        结果
        一个包含原始数组的指定范围的新数组，被截断或填充有空字符以获取所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOfRange

        public static float[] copyOfRange​(float[] original,
                                  int from,
                                  int to)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须介于零至original.length之间，包括0。 original[from]的值被放置在副本的初始元素中（除非是from == original.length或者from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 范围（ to ）的最终索引（ to ）必须大于或等于from ，可能大于original.length ，在这种情况下， 0f被放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。
        参数
        original - 要从中复制范围的数组
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        结果
        一个包含原始数组的指定范围的新数组，用零截取或填充以获得所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOfRange

        public static double[] copyOfRange​(double[] original,
                                   int from,
                                   int to)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须介于零到original.length之间，包括0。 original[from]的值被放置在副本的初始元素中（除非是from == original.length或from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 范围（ to ）的最终索引（ to ）必须大于或等于from ，可能大于original.length ，在这种情况下， 0d被放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。
        参数
        original - 要从中复制范围的数组
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        结果
        一个包含原始数组的指定范围的新数组，用零截取或填充以获得所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • copyOfRange

        public static boolean[] copyOfRange​(boolean[] original,
                                    int from,
                                    int to)
        将指定数组的指定范围复制到新数组中。 范围（ from ）的初始指数必须介于零和original.length之间（ from ）。 original[from]的值被放置在副本的初始元素中（除非是from == original.length或from == to ）。 原始数组中后续元素的值将被放置在副本中的后续元素中。 范围（ to ）的最终指数（ to ）必须大于或等于from ，可能大于original.length ，在这种情况下， false被放置在索引大于或等于original.length - from的副本的所有元素中。 返回的数组的长度将为to - from 。
        参数
        original - 要从中复制范围的数组
        from - 要复制的范围的初始索引（包括）
        to - 要复制的范围的最终索引，排他。 （该索引可能位于数组之外）
        结果
        一个包含原始数组的指定范围的新数组，被截断或填充了假元素以获得所需的长度
        异常
        ArrayIndexOutOfBoundsException - 如果是 from < 0或 from > original.length
        IllegalArgumentException - 如果是 from > to
        NullPointerException - 如果 original为空
        从以下版本开始：
        1.6

      • asList

        @SafeVarargs
public static <T> List<T> asList​(T... a)
        返回由指定数组支持的固定大小的列表。 （将返回的列表更改为“写入”到数组。）此方法充当基于数组和基于集合的API之间的桥梁，与Collection.toArray()相结合。 返回的列表是可序列化的，并实现RandomAccess 。

        此方法还提供了一种方便的方式来创建一个初始化为包含几个元素的固定大小的列表：

          List<String> stooges = Arrays.asList("Larry", "Moe", "Curly");
        参数类型
        T - 数组中对象的类
        参数
        a - 列表将被支持的数组
        结果
        指定数组的列表视图

      • hashCode

        public static int hashCode​(long[] a)
        根据指定数组的内容返回哈希码。 对于任何两个long阵列a和b等Arrays.equals(a, b) ，也是Arrays.hashCode(a) == Arrays.hashCode(b)的情况。

        通过此方法返回的值是将通过调用能够得到相同的值hashCode上的方法List含有序列Long个实例表示的元素a以相同的顺序。 如果a为null ，则此方法返回0。

        参数
        a - 要计算的哈希值的数组
        结果
        一个基于内容的哈希码为 a
        从以下版本开始：
        1.5

      • hashCode

        public static int hashCode​(int[] a)
        根据指定数组的内容返回哈希码。 对于任何两个非空int阵列a和b等Arrays.equals(a, b) ，也是Arrays.hashCode(a) == Arrays.hashCode(b)的情况。

        此方法返回的值与通过在同一顺序中包含Integer表示a元素的a实例的List调用hashCode方法获得的值相同。 如果a为null ，则此方法返回0。

        参数
        a - 要计算的哈希值的数组
        结果
        一个基于内容的哈希码为 a
        从以下版本开始：
        1.5

      • hashCode

        public static int hashCode​(short[] a)
        根据指定数组的内容返回哈希码。 对于任何两个short阵列a和b等Arrays.equals(a, b) ，也是Arrays.hashCode(a) == Arrays.hashCode(b)的情况。

        此方法返回的值与通过在270607329292179中调用hashCode方法获得的值相同，该值为 270607329302174，其中包含Short实例的序列，表示a元素的顺序相同。 如果a为null ，则此方法返回0。

        参数
        a - 要计算的哈希值的数组
        结果
        一个基于内容的哈希码为 a
        从以下版本开始：
        1.5

      • hashCode

        public static int hashCode​(char[] a)
        根据指定数组的内容返回哈希码。 对于任何两个char阵列a和b等Arrays.equals(a, b) ，也是Arrays.hashCode(a) == Arrays.hashCode(b)的情况。

        此方法返回的值与通过在同一顺序中包含表示a元素的a实例的List的List调用hashCode方法获得的值相同。 如果a为null ，则此方法返回0。

        参数
        a - 要计算的哈希值的数组
        结果
        一个基于内容的哈希码为 a
        从以下版本开始：
        1.5

      • hashCode

        public static int hashCode​(byte[] a)
        根据指定数组的内容返回哈希码。 对于任何两个byte阵列a和b等Arrays.equals(a, b) ，也是Arrays.hashCode(a) == Arrays.hashCode(b)的情况。

        此方法返回的值与通过在List中调用hashCode方法获得的值相同，该值为 List，其中包含Byte个实例，表示a元素的顺序相同。 如果a为null ，则此方法返回0。

        参数
        a - 要计算的哈希值的数组
        结果
        一个基于内容的哈希码为 a
        从以下版本开始：
        1.5

      • hashCode

        public static int hashCode​(boolean[] a)
        根据指定数组的内容返回哈希码。 对于任何两个boolean阵列a和b等Arrays.equals(a, b) ，也是Arrays.hashCode(a) == Arrays.hashCode(b)的情况。

        此方法返回的值与通过在同一顺序中包含表示a元素的a实例的List的List调用hashCode方法获得的值相同。 如果a为null ，则此方法返回0。

        参数
        a - 要计算的哈希值的数组
        结果
        一个基于内容的哈希码为 a
        从以下版本开始：
        1.5

      • hashCode

        public static int hashCode​(float[] a)
        根据指定数组的内容返回哈希码。 对于任何两个float阵列a和b等Arrays.equals(a, b) ，也是Arrays.hashCode(a) == Arrays.hashCode(b)的情况。

        该方法返回的值与通过在同一顺序中包含表示a元素的a实例的List的270607329954208调用hashCode方法获得的值相同。 如果a是null ，则此方法返回0。

        参数
        a - 要计算的哈希值的数组
        结果
        一个基于内容的哈希码为 a
        从以下版本开始：
        1.5

      • hashCode

        public static int hashCode​(double[] a)
        根据指定数组的内容返回哈希码。 对于任何两个double阵列a和b等Arrays.equals(a, b) ，也是Arrays.hashCode(a) == Arrays.hashCode(b)的情况。

        通过此方法返回的值是将通过调用能够得到相同的值hashCode上的方法List含有序列Double个实例表示的元素a以相同的顺序。 如果a为null ，则此方法返回0。

        参数
        a - 要计算的哈希值的数组
        结果
        一个基于内容的哈希码为 a
        从以下版本开始：
        1.5

      • hashCode

        public static int hashCode​(Object[] a)
        根据指定数组的内容返回哈希码。 如果数组包含其他数组作为元素，则哈希码基于它们的身份而不是其内容。 因此，可以直接或间接通过一个或多个数组级别将数组本身作为元素调用此方法。

        对于任何两个阵列a和b ，使得Arrays.equals(a, b) ，也是Arrays.hashCode(a) == Arrays.hashCode(b)的情况。

        通过此方法返回的值等于将由要返回的值Arrays.asList(a).hashCode() ，除非a是null ，在这种情况下0被返回。

        参数
        a - 要计算的基于内容的哈希码的数组
        结果
        一个基于内容的哈希码为 a
        从以下版本开始：
        1.5
        另请参见：
        deepHashCode(Object[])

      • deepHashCode

        public static int deepHashCode​(Object[] a)
        根据指定数组的“深度内容”返回哈希码。 如果数组包含其他数组作为元素，那么哈希码就是基于它们的内容，等等，无穷无尽。 因此，通过一个或多个级别的数组直接或间接地将自身作为元素的数组调用此方法是不可接受的。 这种调用的行为是未定义的。

        对于任何两个阵列a和b等Arrays.deepEquals(a, b) ，也是Arrays.deepHashCode(a) == Arrays.deepHashCode(b)的情况。

        通过此方法返回的值的计算是类似于由返回的值的List.hashCode()包含相同的元素作为列表上a以相同的顺序，有一点不同：如果一个元素e的a本身是一个阵列，其散列代码是通过调用不计算e.hashCode() ，但作为通过调用适当重载Arrays.hashCode(e)如果e是一个基本类型的阵列，或者通过调用Arrays.deepHashCode(e)递归如果e是引用类型的阵列。 如果a为null ，则此方法返回0。

        参数
        a - 其基于深度内容的哈希码计算的阵列
        结果
        一个基于深度内容的哈希码为 a
        从以下版本开始：
        1.5
        另请参见：
        hashCode(Object[])

      • deepEquals

        public static boolean deepEquals​(Object[] a1,
                                 Object[] a2)
        如果两个指定的数组彼此深度相等 ，则返回true 。 与equals(Object[],Object[])方法不同，该方法适用于任意深度的嵌套数组。

        两个数组引用被认为是相当的，如果两者都是null ，或者它们是指包含相同数量的元素的数组，并且两个数组中所有对应的元素对都相等。

        两个可能的null元素e1和e2在以下条件中的任何一个条件下是相当的：

        • e1和e2都是对象引用类型的数组，而Arrays.deepEquals(e1, e2) would return true
        • e1和e2是相同的基本类型的数组，以及适当重载Arrays.equals(e1, e2)将返回true。
        • e1 == e2
        • e1.equals(e2)将返回true。
        请注意，此定义允许任何深度的null元素。

        如果任一指定的数组通过一个或多个数组级别直接或间接包含自身作为元素，则此方法的行为是未定义的。

        参数
        a1 - 要进行相等测试的一个数组
        a2 - 要测试的其他数组是否相等
        结果
        true如果两个数组相等
        从以下版本开始：
        1.5
        另请参见：
        equals(Object[],Object[]) ， Objects.deepEquals(Object, Object)

      • toString

        public static String toString​(long[] a)
        返回指定数组的内容的字符串表示形式。 字符串表示由数组元素的列表组成，括在方括号（ "[]" ）中。 相邻的元素由字符", " （逗号后跟一个空格）分隔开。 元素将转换为字符串，如String.valueOf(long) 。 返回"null"如果a为null 。
        参数
        a - 要返回其字符串表示形式的数组
        结果
        一个字符串表示法 a
        从以下版本开始：
        1.5

      • toString

        public static String toString​(int[] a)
        返回指定数组的内容的字符串表示形式。 字符串表示由数组元素的列表组成，括在方括号（ "[]" ）中。 相邻的元素由字符", " （逗号后跟一个空格）。 元素将转换为字符串，如String.valueOf(int) 。 返回"null"如果a为null 。
        参数
        a - 要返回的字符串表示形式的数组
        结果
        一个字符串表示形式为 a
        从以下版本开始：
        1.5

      • toString

        public static String toString​(short[] a)
        返回指定数组的内容的字符串表示形式。 字符串表示由数组元素的列表组成，括在方括号（ "[]" ）中。 相邻的元素由字符", " （逗号后跟一个空格）。 元素将转换为字符串，如String.valueOf(short) 。 返回"null"如果a为null 。
        参数
        a - 要返回的字符串表示形式的数组
        结果
        一个字符串表示形式为 a
        从以下版本开始：
        1.5

      • toString

        public static String toString​(char[] a)
        返回指定数组的内容的字符串表示形式。 字符串表示由数组元素的列表组成，括在方括号（ "[]" ）中。 相邻的元素由字符", " （逗号后跟一个空格）。 元素将转换为字符串，如String.valueOf(char) 。 返回"null"如果a为null 。
        参数
        a - 要返回其字符串表示形式的数组
        结果
        一个字符串表示形式为 a
        从以下版本开始：
        1.5

      • toString

        public static String toString​(byte[] a)
        返回指定数组的内容的字符串表示形式。 字符串表示由数组元素的列表组成，括在方括号（ "[]" ）中。 相邻元素由字符", " （逗号后跟空格）。 元素将转换为字符串，如String.valueOf(byte) 。 返回"null"如果a为null 。
        参数
        a - 要返回其字符串表示形式的数组
        结果
        一个字符串表示法 a
        从以下版本开始：
        1.5

      • toString

        public static String toString​(boolean[] a)
        返回指定数组的内容的字符串表示形式。 字符串表示由数组元素的列表组成，括在方括号（ "[]" ）中。 相邻的元素由字符", " （逗号后跟一个空格）分隔开。 元素将转换为字符串，如String.valueOf(boolean) 。 返回"null"如果a为null 。
        参数
        a - 要返回的字符串表示形式的数组
        结果
        一个 a的字符串表示
        从以下版本开始：
        1.5

      • toString

        public static String toString​(float[] a)
        返回指定数组的内容的字符串表示形式。 字符串表示由数组元素的列表组成，括在方括号（ "[]" ）中。 相邻元素由字符", " （逗号后跟空格）。 元素将转换为字符串，如String.valueOf(float) 。 返回"null"如果a为null 。
        参数
        a - 要返回其字符串表示形式的数组
        结果
        一个字符串表示形式为 a
        从以下版本开始：
        1.5

      • toString

        public static String toString​(double[] a)
        返回指定数组的内容的字符串表示形式。 字符串表示由数组元素的列表组成，括在方括号（ "[]" ）中。 相邻元素由字符", " （逗号后跟空格）。 元素将转换为字符串，如String.valueOf(double) 。 返回"null"如果a为null 。
        参数
        a - 要返回其字符串表示形式的数组
        结果
        一个字符串表示形式为 a
        从以下版本开始：
        1.5

      • toString

        public static String toString​(Object[] a)
        返回指定数组的内容的字符串表示形式。 如果数组包含其他数组作为元素，那么它们将从继承自Object的Object.toString()方法转换为字符串，该方法描述了它们的身份而不是其内容。

        通过此方法返回的值等于将由要返回的值Arrays.asList(a).toString() ，除非a是null ，在这种情况下"null"被返回。

        参数
        a - 要返回其字符串表示形式的数组
        结果
        一个字符串表示形式为 a
        从以下版本开始：
        1.5
        另请参见：
        deepToString(Object[])

      • deepToString

        public static String deepToString​(Object[] a)
        返回指定数组的“深度内容”的字符串表示形式。 如果数组包含其他数组作为元素，则字符串表示包含其内容等等。 此方法用于将多维数组转换为字符串。

        字符串表示由数组元素的列表组成，括在方括号（ "[]" ）中。 相邻的元素由字符", " （逗号后跟一个空格）。 元素将转换为字符串，如String.valueOf(Object) ，除非它们本身是数组。

        如果元素e是原始类型的数组，则通过调用适当的超载Arrays.toString(e)将其转换为字符串。 如果元素e是引用类型的数组，则通过递归调用此方法将其转换为字符串。

        为了避免无限递归，如果指定的数组包含自身作为元素，或者通过一个或多个数组级别包含对其自身的间接引用，则将自引用转换为字符串"[...]" 。 例如，仅包含对其自身的引用的数组将被呈现为"[[...]]" 。

        此方法返回"null"如果指定数组是null 。

        参数
        a - 要返回的字符串表示形式的数组
        结果
        一个字符串表示形式为 a
        从以下版本开始：
        1.5
        另请参见：
        toString(Object[])

      • setAll

        public static <T> void setAll​(T[] array,
                              IntFunction<? extends T> generator)
        使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

        如果生成器函数引发异常，则将其转发给调用者，并将数组置于不确定状态。

        API Note:
        设置一个数组的子范围，使用生成函数来计算每个元素，可以写成如下：
           IntStream.range(startInclusive, endExclusive) .forEach(i -> array[i] = generator.apply(i));
        参数类型
        T - 数组元素的类型
        参数
        array - 要初始化的数组
        generator - 接受索引并产生该位置所需值的函数
        异常
        NullPointerException - 如果生成器为空
        从以下版本开始：
        1.8

      • parallelSetAll

        public static <T> void parallelSetAll​(T[] array,
                                      IntFunction<? extends T> generator)
        使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。

        如果生成器函数引发异常，则从parallelSetAll抛出未检查的异常，并且数组处于不确定状态。

        API Note:
        使用生成函数来计算每个元素，并行设置数组的子范围，可以写成如下：
           IntStream.range(startInclusive, endExclusive) .parallel() .forEach(i -> array[i] = generator.apply(i));
        参数类型
        T - 数组元素的类型
        参数
        array - 要初始化的数组
        generator - 接受索引并产生该位置所需值的函数
        异常
        NullPointerException - 如果生成器为空
        从以下版本开始：
        1.8

      • setAll

        public static void setAll​(int[] array,
                          IntUnaryOperator generator)
        使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

        如果生成器函数引发异常，则将其转发给调用者，并将数组置于不确定状态。

        API Note:
        设置一个数组的子范围，使用生成函数来计算每个元素，可以写成如下：
           IntStream.range(startInclusive, endExclusive) .forEach(i -> array[i] = generator.applyAsInt(i));
        参数
        array - 要初始化的数组
        generator - 接受索引并产生该位置所需值的函数
        异常
        NullPointerException - 如果生成器为空
        从以下版本开始：
        1.8

      • parallelSetAll

        public static void parallelSetAll​(int[] array,
                                  IntUnaryOperator generator)
        使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。

        如果生成器函数引发异常，则从parallelSetAll抛出未检查的异常，并将数组置于不确定状态。

        API Note:
        使用生成函数来计算每个元素，并行设置数组的子范围，可以写成如下：
           IntStream.range(startInclusive, endExclusive) .parallel() .forEach(i -> array[i] = generator.applyAsInt(i));
        参数
        array - 要初始化的数组
        generator - 接受索引并产生该位置所需值的函数
        异常
        NullPointerException - 如果生成器为空
        从以下版本开始：
        1.8

      • setAll

        public static void setAll​(long[] array,
                          IntToLongFunction generator)
        使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

        如果生成器函数引发异常，则将其转发给调用者，并将数组置于不确定状态。

        API Note:
        设置一个数组的子范围，使用生成函数来计算每个元素，可以写成如下：
           IntStream.range(startInclusive, endExclusive) .forEach(i -> array[i] = generator.applyAsLong(i));
        参数
        array - 要初始化的数组
        generator - 接受索引并产生该位置所需值的函数
        异常
        NullPointerException - 如果生成器为空
        从以下版本开始：
        1.8

      • parallelSetAll

        public static void parallelSetAll​(long[] array,
                                  IntToLongFunction generator)
        使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。

        如果生成函数引发异常，则从parallelSetAll抛出未检查的异常，并且数组处于不确定状态。

        API Note:
        使用生成函数来计算每个元素，并行设置数组的子范围，可以写成如下：
           IntStream.range(startInclusive, endExclusive) .parallel() .forEach(i -> array[i] = generator.applyAsLong(i));
        参数
        array - 要初始化的数组
        generator - 接受索引并产生该位置所需值的函数
        异常
        NullPointerException - 如果生成器为空
        从以下版本开始：
        1.8

      • setAll

        public static void setAll​(double[] array,
                          IntToDoubleFunction generator)
        使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

        如果生成器函数引发异常，则将其转发给调用者，并将数组置于不确定状态。

        API Note:
        设置一个数组的子范围，使用生成函数来计算每个元素，可以写成如下：
           IntStream.range(startInclusive, endExclusive) .forEach(i -> array[i] = generator.applyAsDouble(i));
        参数
        array - 要初始化的数组
        generator - 接受索引并产生该位置的期望值的函数
        异常
        NullPointerException - 如果生成器为空
        从以下版本开始：
        1.8

      • parallelSetAll

        public static void parallelSetAll​(double[] array,
                                  IntToDoubleFunction generator)
        使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。

        如果生成器函数引发异常，则从parallelSetAll抛出未检查的异常，并且数组处于不确定状态。

        API Note:
        使用生成函数来计算每个元素，并行设置数组的子范围，可以写成如下：
           IntStream.range(startInclusive, endExclusive) .parallel() .forEach(i -> array[i] = generator.applyAsDouble(i));
        参数
        array - 要初始化的数组
        generator - 接受索引并产生该位置所需值的函数
        异常
        NullPointerException - 如果生成器为空
        从以下版本开始：
        1.8

      • spliterator

        public static <T> Spliterator<T> spliterator​(T[] array)
        返回覆盖所有指定数组的Spliterator 。

        该报告spliterator Spliterator.SIZED ， Spliterator.SUBSIZED ， Spliterator.ORDERED ，并Spliterator.IMMUTABLE 。

        参数类型
        T - 元素的类型
        参数
        array - 假定在使用过程中未修改的数组
        结果
        数组元素的分割器
        从以下版本开始：
        1.8

      • spliterator

        public static <T> Spliterator<T> spliterator​(T[] array,
                                             int startInclusive,
                                             int endExclusive)
        返回一个覆盖指定数组的指定范围的Spliterator 。

        该报告spliterator Spliterator.SIZED ， Spliterator.SUBSIZED ， Spliterator.ORDERED ，并Spliterator.IMMUTABLE 。

        参数类型
        T - 元素的类型
        参数
        array - 假定在使用过程中未修改的数组
        startInclusive - 第一个涵盖的索引
        endExclusive - 索引立即通过最后一个索引覆盖
        结果
        数组元素的分割器
        异常
        ArrayIndexOutOfBoundsException - 如果 startInclusive为负数，则 endExclusive小于 startInclusive ，或 endExclusive大于数组大小
        从以下版本开始：
        1.8

      • spliterator

        public static Spliterator.OfInt spliterator​(int[] array)
        返回覆盖所有指定数组的Spliterator.OfInt 。

        该报告spliterator Spliterator.SIZED ， Spliterator.SUBSIZED ， Spliterator.ORDERED ，并Spliterator.IMMUTABLE 。

        参数
        array - 假定在使用过程中未修改的数组
        结果
        数组元素的分割器
        从以下版本开始：
        1.8

      • spliterator

        public static Spliterator.OfInt spliterator​(int[] array,
                                            int startInclusive,
                                            int endExclusive)
        返回覆盖指定数组的指定范围的Spliterator.OfInt 。

        该报告spliterator Spliterator.SIZED ， Spliterator.SUBSIZED ， Spliterator.ORDERED ，并Spliterator.IMMUTABLE 。

        参数
        array - 假定在使用过程中未修改的数组
        startInclusive - 第一个涵盖的索引
        endExclusive - 索引立即通过最后一个索引覆盖
        结果
        数组元素的分割器
        异常
        ArrayIndexOutOfBoundsException - 如果 startInclusive为负数，则 endExclusive小于 startInclusive ，或 endExclusive大于数组大小
        从以下版本开始：
        1.8

      • spliterator

        public static Spliterator.OfLong spliterator​(long[] array)
        返回一个覆盖所有指定数组的Spliterator.OfLong 。

        该报告spliterator Spliterator.SIZED ， Spliterator.SUBSIZED ， Spliterator.ORDERED ，并Spliterator.IMMUTABLE 。

        参数
        array - 假定在使用过程中未修改的数组
        结果
        阵列元素的拼接器
        从以下版本开始：
        1.8

      • spliterator

        public static Spliterator.OfLong spliterator​(long[] array,
                                             int startInclusive,
                                             int endExclusive)
        返回覆盖指定数组的指定范围的Spliterator.OfLong 。

        该报告spliterator Spliterator.SIZED ， Spliterator.SUBSIZED ， Spliterator.ORDERED ，并Spliterator.IMMUTABLE 。

        参数
        array - 假定在使用过程中未修改的数组
        startInclusive - 第一个涵盖的索引
        endExclusive - 索引立即通过最后一个索引覆盖
        结果
        数组元素的分割器
        异常
        ArrayIndexOutOfBoundsException - 如果 startInclusive为负数，则 endExclusive小于 startInclusive ，或 endExclusive大于数组大小
        从以下版本开始：
        1.8

      • spliterator

        public static Spliterator.OfDouble spliterator​(double[] array)
        返回一个覆盖所有指定数组的Spliterator.OfDouble 。

        该报告spliterator Spliterator.SIZED ， Spliterator.SUBSIZED ， Spliterator.ORDERED ，并Spliterator.IMMUTABLE 。

        参数
        array - 假定在使用期间未修改的数组
        结果
        数组元素的分割器
        从以下版本开始：
        1.8

      • spliterator

        public static Spliterator.OfDouble spliterator​(double[] array,
                                               int startInclusive,
                                               int endExclusive)
        返回覆盖指定数组的指定范围的Spliterator.OfDouble 。

        该报告spliterator Spliterator.SIZED ， Spliterator.SUBSIZED ， Spliterator.ORDERED ，并Spliterator.IMMUTABLE 。

        参数
        array - 假定在使用过程中未修改的数组
        startInclusive - 第一个涵盖的索引
        endExclusive - 索引立即通过最后一个索引覆盖
        结果
        数组元素的分割器
        异常
        ArrayIndexOutOfBoundsException - 如果 startInclusive为负数，则 endExclusive小于 startInclusive ，或 endExclusive大于数组大小
        从以下版本开始：
        1.8

      • stream

        public static <T> Stream<T> stream​(T[] array)
        返回具有指定数组的序列Stream作为其源。
        参数类型
        T - 数组元素的类型
        参数
        array - 假定在使用过程中未修改的数组
        结果
        一个 Stream的阵列
        从以下版本开始：
        1.8

      • stream

        public static <T> Stream<T> stream​(T[] array,
                                   int startInclusive,
                                   int endExclusive)
        返回指定数组的指定范围作为源的顺序Stream 。
        参数类型
        T - 数组元素的类型
        参数
        array - 假定在使用期间未修改的数组
        startInclusive - 第一个涵盖的索引
        endExclusive - 索引立即通过最后一个索引覆盖
        结果
        一个 Stream的阵列范围
        异常
        ArrayIndexOutOfBoundsException - 如果 startInclusive为负数，则 endExclusive小于 startInclusive ，或 endExclusive大于数组大小
        从以下版本开始：
        1.8

      • stream

        public static IntStream stream​(int[] array)
        返回具有指定数组的序列IntStream作为其源。
        参数
        array - 假定在使用期间未修改的数组
        结果
        一个 IntStream的阵列
        从以下版本开始：
        1.8

      • stream

        public static IntStream stream​(int[] array,
                               int startInclusive,
                               int endExclusive)
        返回指定数组的指定范围作为源的连续IntStream 。
        参数
        array - 假定在使用过程中未修改的数组
        startInclusive - 第一个涵盖的索引
        endExclusive - 索引立即通过最后一个索引覆盖
        结果
        一个 IntStream的阵列范围
        异常
        ArrayIndexOutOfBoundsException - 如果 startInclusive为负，则 endExclusive小于 startInclusive ，或 endExclusive大于数组大小
        从以下版本开始：
        1.8

      • stream

        public static LongStream stream​(long[] array)
        返回指定数组作为源的顺序LongStream 。
        参数
        array - 假定在使用期间未修改的数组
        结果
        一个 LongStream的阵列
        从以下版本开始：
        1.8

      • stream

        public static LongStream stream​(long[] array,
                                int startInclusive,
                                int endExclusive)
        返回指定数组的指定范围作为其源的顺序LongStream 。
        参数
        array - 假定在使用过程中未修改的数组
        startInclusive - 涵盖的首个索引
        endExclusive - 索引立即通过最后一个索引覆盖
        结果
        一个 LongStream的阵列范围
        异常
        ArrayIndexOutOfBoundsException - 如果 startInclusive为负数，则 endExclusive小于 startInclusive ，或 endExclusive大于数组大小
        从以下版本开始：
        1.8

      • stream

        public static DoubleStream stream​(double[] array)
        返回指定数组作为源的顺序DoubleStream 。
        参数
        array - 假定在使用期间未修改的数组
        结果
        一个 DoubleStream的阵列
        从以下版本开始：
        1.8

      • stream

        public static DoubleStream stream​(double[] array,
                                  int startInclusive,
                                  int endExclusive)
        返回指定数组的指定范围作为其源的顺序DoubleStream 。
        参数
        array - 假定在使用期间未修改的数组
        startInclusive - 第一个涵盖的索引
        endExclusive - 索引立即通过最后一个索引覆盖
        结果
        一个 DoubleStream的阵列范围
        异常
        ArrayIndexOutOfBoundsException - 如果 startInclusive为负，则 endExclusive小于 startInclusive ，或 endExclusive大于数组大小
        从以下版本开始：
        1.8

      • compare

        public static int compare​(boolean[] a,
                          boolean[] b)
        boolean字典顺序比较两个boolean阵列。

        如果两个数组共享一个共同的前缀，那么词典比较是比较两个元素的结果，就像在Boolean.compare(boolean, boolean)中一样 ，在作为前缀长度的各个数组中的索引处。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(boolean[], boolean[]) ）

        A null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        该比较与equals一致，更具体地说对于阵列a和b ：

           Arrays.equals(a, b) == (Arrays.compare(a, b) == 0)
        API Note:

        此方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Boolean.compare(a[i], b[i]); return a.length - b.length;
        参数
        a - 要比较的第一个数组
        b - 第二个数组进行比较
        结果
        值0如果第一和第二个数组相等并且以相同的顺序包含相同的元素; 小于0的值，如果第一个数组按字典顺序小于第二个数组; 如果第一个数组的字典大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compare

        public static int compare​(boolean[] a,
                          int aFromIndex,
                          int aToIndex,
                          boolean[] b,
                          int bFromIndex,
                          int bToIndex)
        在指定范围内按字典顺序比较两个boolean阵列。

        如果两个数组在指定的范围内共享一个共同的前缀，那么词典比较就是比较两个元素的结果，就像Boolean.compare(boolean, boolean)一样 ，在作为前缀长度的相应数组内的相对索引处。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关常用和正确的前缀的定义，请参阅mismatch(boolean[], int, int, boolean[], int, int)。 ）

        该比较是一致equals ，更具体地以下适用于阵列a和b与指定的范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别地）：

           Arrays.equals(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == (Arrays.compare(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == 0)
        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Boolean.compare(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 要比较的第一个数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        结果
        值0如果超过指定范围的第一和第二个数组是相等的，并且以相同的顺序包含相同的元素; 小于0的值，如果超过指定范围，则第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一阵列是 null
        从以下版本开始：
        9

      • compare

        public static int compare​(byte[] a,
                          byte[] b)
        byte字典顺序比较两个byte阵列。

        如果两个阵列共享一个共同的前缀，那么词典比较是比较两个元素的结果，就像在Byte.compare(byte, byte)中一样 ，在作为前缀长度的各个数组内的索引处。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(byte[], byte[]) ）

        A null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        该比较与equals一致，更具体地说，对于阵列a和b ，具体如下：

           Arrays.equals(a, b) == (Arrays.compare(a, b) == 0)
        API Note:

        该方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Byte.compare(a[i], b[i]); return a.length - b.length;
        参数
        a - 第一个要比较的数组
        b - 第二个数组进行比较
        结果
        值0如果第一和第二个数组相等并且包含相同的元素相同的顺序; 小于0的值，如果第一个数组的字典小于第二个数组; 如果第一个数组在0大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compare

        public static int compare​(byte[] a,
                          int aFromIndex,
                          int aToIndex,
                          byte[] b,
                          int bFromIndex,
                          int bToIndex)
        比较两个byte阵列在字典上超过指定的范围。

        如果两个数组在指定的范围内共享一个共同的前缀，那么词典比较就是比较两个元素的结果，如Byte.compare(byte, byte)那样 ，在作为前缀长度的相应数组内的相对索引处。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(byte[], int, int, byte[], int, int) ）

        该比较是一致equals ，更具体地以下适用于阵列a和b与指定的范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别地）：

           Arrays.equals(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == (Arrays.compare(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == 0)
        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Byte.compare(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 第一个要比较的数组
        aFromIndex - 要比较的第一个数组中第一个元素的索引（含）
        aToIndex - 要比较的第一个数组中最后一个元素的索引（独占）
        b - 要比较的第二个数组
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        结果
        值0如果超过指定范围的第一和第二个数组是相等的并且包含相同的元素相同的顺序; 小于0的值，如果在指定范围内，第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • compareUnsigned

        public static int compareUnsigned​(byte[] a,
                                  byte[] b)
        比较两个byte阵列在byte ，数字处理元素为无符号。

        如果两个阵列共享一个共同的前缀，那么词典比较是比较两个元素的结果，就像在Byte.compareUnsigned(byte, byte) ，在作为前缀长度的各个数组内的索引。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(byte[], byte[]) ）

        A null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        API Note:

        该方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Byte.compareUnsigned(a[i], b[i]); return a.length - b.length;
        参数
        a - 第一个要比较的数组
        b - 要比较的第二个数组
        结果
        值0如果第一和第二个数组是相等的并且包含相同的元素相同的顺序; 小于0的值，如果第一个数组的字典数字小于第二个数组; 如果第一个数组的字典大小超过第二个数组，则值大于0
        从以下版本开始：
        9

      • compareUnsigned

        public static int compareUnsigned​(byte[] a,
                                  int aFromIndex,
                                  int aToIndex,
                                  byte[] b,
                                  int bFromIndex,
                                  int bToIndex)
        将两个byte阵列按照byte顺序比较在指定范围内，将元素数字处理为无符号。

        如果两个数组在指定范围内共享一个共同的前缀，那么词典比较就是比较两个元素的结果，如Byte.compareUnsigned(byte, byte)那样 ，在相应的数组中作为前缀长度的相对索引。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(byte[], int, int, byte[], int, int) ）

        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Byte.compareUnsigned(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 第一个要比较的数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中的最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        结果
        值0如果超过指定范围的第一和第二个数组是相等的并且以相同的顺序包含相同的元素; 小于0的值，如果超过指定范围，则第一个数组的字典数字小于第二个数组; 并且大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或者是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组为空
        从以下版本开始：
        9

      • compare

        public static int compare​(short[] a,
                          short[] b)
        short字典顺序比较两个short阵列。

        如果两个阵列共享一个共同的前缀，那么词典比较是比较两个元素的结果，就像在Short.compare(short, short)一样，作为前缀长度的各个数组内的索引。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(short[], short[])。 ）

        A null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        比较与equals一致，更具体地说，对于阵列a和b ，具体如下：

           Arrays.equals(a, b) == (Arrays.compare(a, b) == 0)
        API Note:

        此方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Short.compare(a[i], b[i]); return a.length - b.length;
        参数
        a - 要比较的第一个数组
        b - 第二个数组进行比较
        结果
        值0如果第一和第二个数组是相等的并且包含相同的元素的顺序; 如果第一个数组的字典数字小于第二个数组，则该值小于0 ; 如果第一个数组的字典大小超过第二个数组，则值大于0
        从以下版本开始：
        9

      • compare

        public static int compare​(short[] a,
                          int aFromIndex,
                          int aToIndex,
                          short[] b,
                          int bFromIndex,
                          int bToIndex)
        比较两个short阵列在short指定的范围。

        如果两个数组在指定的范围内共享一个共同的前缀，那么词典比较就是比较两个元素的结果，如Short.compare(short, short)那样 ，在作为前缀长度的相应数组中的相对索引处。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(short[], int, int, short[], int, int) ）

        该比较是一致equals ，更具体地以下适用于阵列a和b与指定的范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别地）：

           Arrays.equals(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == (Arrays.compare(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == 0)
        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Short.compare(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 第一个要比较的数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中的最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        结果
        值0如果在指定的范围内，第一和第二个数组是相等的，并且以相同的顺序包含相同的元素; 如果超过指定范围，第一个数组的字典数字小于第二个数组，则该值小于0 ; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • compareUnsigned

        public static int compareUnsigned​(short[] a,
                                  short[] b)
        比较两个short阵列的字典，数字处理元素为无符号。

        如果两个阵列共享一个共同的前缀，那么词典比较是比较两个元素的结果，就像在Short.compareUnsigned(short, short)一样，作为前缀长度的各个数组内的索引。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （见mismatch(short[], short[])关于常用和正确的前缀的定义。）

        A null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        API Note:

        该方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Short.compareUnsigned(a[i], b[i]); return a.length - b.length;
        参数
        a - 第一个要比较的数组
        b - 要比较的第二个数组
        结果
        值0如果第一和第二个数组相等并且以相同的顺序包含相同的元素; 如果第一个数组的字典数字小于第二个数组，则该值小于0 ; 如果第一个数组的字典大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compareUnsigned

        public static int compareUnsigned​(short[] a,
                                  int aFromIndex,
                                  int aToIndex,
                                  short[] b,
                                  int bFromIndex,
                                  int bToIndex)
        将两个short阵列按照short顺序比较在指定范围内，将元素数字处理为无符号。

        如果两个数组在指定的范围内共享一个公用的前缀，那么词典比较就是比较两个元素的结果，就像在Short.compareUnsigned(short, short)中一样 ，在相应的数组内的相对索引是前缀的长度。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(short[], int, int, short[], int, int) ）

        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Short.compareUnsigned(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 要比较的第一个数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        结果
        值0如果超过指定的范围，第一和第二个数组是相等的，并且包含相同的顺序的元素; 小于0的值，如果超过指定范围，则第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组为空
        从以下版本开始：
        9

      • compare

        public static int compare​(char[] a,
                          char[] b)
        char字典顺序比较两个char阵列。

        如果两个数组共享一个共同的前缀，那么词典比较是比较两个元素的结果，如Character.compare(char, char)所示 ，在作为前缀长度的各个数组内的索引处。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(char[], char[]) ）

        A null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        比较与equals一致，更具体地说，对于阵列a和b ：

           Arrays.equals(a, b) == (Arrays.compare(a, b) == 0)
        API Note:

        此方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Character.compare(a[i], b[i]); return a.length - b.length;
        参数
        a - 要比较的第一个数组
        b - 第二个数组进行比较
        结果
        值0如果第一和第二个数组是相等的并且包含相同的元素在相同的顺序; 如果第一个数组的字典数字小于第二个数组，则该值小于0 ; 如果第一个数组的字典数字大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compare

        public static int compare​(char[] a,
                          int aFromIndex,
                          int aToIndex,
                          char[] b,
                          int bFromIndex,
                          int bToIndex)
        比较两个char阵列在char指定的范围。

        如果两个数组在指定的范围内共享一个共同的前缀，那么词典比较就是比较两个元素的结果，就像在Character.compare(char, char)中一样 ，在作为前缀长度的相应数组中的相对索引处。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(char[], int, int, char[], int, int) ）

        该比较是一致equals ，更具体地以下适用于阵列a和b与指定的范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别地）：

           Arrays.equals(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == (Arrays.compare(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == 0)
        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Character.compare(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 要比较的第一个数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中的最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中的最后一个元素的索引（独占）
        结果
        值0如果超过指定范围的第一和第二个数组是相等的，并且以相同的顺序包含相同的元素; 小于0的值，如果超过指定范围，则第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • compare

        public static int compare​(int[] a,
                          int[] b)
        int字典顺序比较两个int阵列。

        如果两个数组共享一个共同的前缀，则字典比较是比较两个元素的结果，如Integer.compare(int, int)所示 ，在作为前缀长度的各个数组内的索引处。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(int[], int[]) ）

        A null阵列引用在字典上被认为小于非null阵列引用。 两个null数组引用被认为是相等的。

        该比较与equals是一致的，更具体地说，对于阵列a和b ，更具体地说：

           Arrays.equals(a, b) == (Arrays.compare(a, b) == 0)
        API Note:

        此方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Integer.compare(a[i], b[i]); return a.length - b.length;
        参数
        a - 第一个要比较的数组
        b - 第二个数组进行比较
        结果
        值0如果第一个和第二个数组是相等的并且包含相同的顺序的元素; 小于0的值，如果第一个数组的字典数字小于第二个数组; 如果第一个数组的字典大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compare

        public static int compare​(int[] a,
                          int aFromIndex,
                          int aToIndex,
                          int[] b,
                          int bFromIndex,
                          int bToIndex)
        比较两个int阵列在字典上超过指定的范围。

        如果两个数组在指定的范围内共享一个公用的前缀，那么字典比较就是比较两个元素的结果，如Integer.compare(int, int)那样 ，在作为前缀长度的相应数组中的相对索引处。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(int[], int, int, int[], int, int) ）

        该比较是一致equals ，更具体地以下适用于阵列a和b与指定的范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别地）：

           Arrays.equals(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == (Arrays.compare(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == 0)
        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Integer.compare(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 要比较的第一个数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中最后一个元素的索引（独占）
        b - 要比较的第二个数组
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        结果
        值0如果在指定的范围内，第一和第二个数组是相等的，并且以相同的顺序包含相同的元素; 小于0的值，如果在指定范围内，第一个数组在字典上小于第二个数组; 并且大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • compareUnsigned

        public static int compareUnsigned​(int[] a,
                                  int[] b)
        比较两个int阵列的字典，数字处理元素为无符号。

        如果两个阵列共享一个共同的前缀，那么词典比较是比较两个元素的结果，就像在Integer.compareUnsigned(int, int)一样，作为前缀长度的相应数组中的索引。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(int[], int[]) ）

        A null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        API Note:

        该方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Integer.compareUnsigned(a[i], b[i]); return a.length - b.length;
        参数
        a - 第一个要比较的数组
        b - 第二个数组进行比较
        结果
        值0如果第一和第二个数组是相等的并且包含相同的元素在相同的顺序; 如果第一个数组的字典数字小于第二个数组，则该值小于0 ; 如果第一个数组的字典大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compareUnsigned

        public static int compareUnsigned​(int[] a,
                                  int aFromIndex,
                                  int aToIndex,
                                  int[] b,
                                  int bFromIndex,
                                  int bToIndex)
        将两个int数组按照指定的范围进行int比较，将元素数字化处理为无符号。

        如果两个数组在指定的范围内共享一个共同的前缀，那么词典比较是比较两个元素的结果，就像在Integer.compareUnsigned(int, int)中一样 ，在作为前缀长度的相应数组内的相对索引处。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(int[], int, int, int[], int, int) ）

        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Integer.compareUnsigned(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 第一个要比较的数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中的最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        结果
        值0如果超过指定的范围，第一和第二个数组是相等的，并且包含相同的顺序的元素; 小于0的值，如果超过指定范围，则第一个数组按字典顺序小于第二个数组; 并且大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或者如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组为空
        从以下版本开始：
        9

      • compare

        public static int compare​(long[] a,
                          long[] b)
        long字典顺序比较两个long阵列。

        如果两个数组共享一个共同的前缀，那么词典比较就是比较两个元素的结果，就像在Long.compare(long, long)一样 ，在作为前缀长度的各个数组内的一个索引。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关常用和正确的前缀的定义，请参阅mismatch(long[], long[]) ）

        null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        比较与equals一致，更具体地说，对于阵列a和b ，更具体地说：

           Arrays.equals(a, b) == (Arrays.compare(a, b) == 0)
        API Note:

        该方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Long.compare(a[i], b[i]); return a.length - b.length;
        参数
        a - 要比较的第一个数组
        b - 第二个数组进行比较
        结果
        值0如果第一和第二个数组是相等的并且包含相同的元素的顺序; 小于0的值，如果第一个数组的字典数字小于第二个数组; 如果第一个数组的字典大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compare

        public static int compare​(long[] a,
                          int aFromIndex,
                          int aToIndex,
                          long[] b,
                          int bFromIndex,
                          int bToIndex)
        比较两个long阵列在long指定的范围。

        如果两个数组在指定的范围内共享一个公用的前缀，那么词典比较就是比较两个元素的结果，就像在Long.compare(long, long)中一样 ，在相应的数组中作为前缀长度的相对索引。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （见mismatch(long[], int, int, long[], int, int)关于常用和正确的前缀的定义。）

        该比较是一致equals ，更具体地以下适用于阵列a和b与指定的范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别地）：

           Arrays.equals(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == (Arrays.compare(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == 0)
        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Long.compare(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 要比较的第一个数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中的最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中的最后一个元素的索引（独占）
        结果
        值0如果超过指定范围的第一和第二个数组是相等的并且以相同的顺序包含相同的元素; 小于0的值，如果超过指定范围，则第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • compareUnsigned

        public static int compareUnsigned​(long[] a,
                                  long[] b)
        比较两个long阵列的字典，数字处理元素为无符号。

        如果两个数组共享一个共同的前缀，那么词典比较是比较两个元素的结果，就像在Long.compareUnsigned(long, long)一样，作为前缀长度的相应数组中的索引。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （见mismatch(long[], long[])，用于定义一个通用和正确的前缀。）

        A null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        API Note:

        此方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Long.compareUnsigned(a[i], b[i]); return a.length - b.length;
        参数
        a - 第一个要比较的数组
        b - 要比较的第二个数组
        结果
        值0如果第一和第二个数组是相等的并且包含相同的元素的顺序; 小于0的值，如果第一个数组按字典顺序小于第二个数组; 如果第一个数组的字典大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compareUnsigned

        public static int compareUnsigned​(long[] a,
                                  int aFromIndex,
                                  int aToIndex,
                                  long[] b,
                                  int bFromIndex,
                                  int bToIndex)
        将两个long数组按照long顺序比较在指定范围内，将元素数字化处理为无符号。

        如果两个数组在指定的范围内共享一个共同的前缀，则词典比较是比较两个元素的结果，如Long.compareUnsigned(long, long)所示 ，在相应的数组中作为前缀长度的相对索引。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关常用和正确的前缀的定义，请参阅mismatch(long[], int, int, long[], int, int) ）

        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Long.compareUnsigned(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 要比较的第一个数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中最后一个元素的索引（独占）
        b - 要比较的第二个数组
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中的最后一个元素的索引（独占）
        结果
        值0如果超过指定的范围，第一和第二个数组是相等的并且以相同的顺序包含相同的元素; 小于0的值，如果在指定范围内，第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或者如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组为空
        从以下版本开始：
        9

      • compare

        public static int compare​(float[] a,
                          float[] b)
        float字典顺序比较两个float阵列。

        如果两个数组共享一个共同的前缀，则词典比较是比较两个元素的结果，就像在Float.compare(float, float)中一样，作为前缀长度的各个数组内的索引。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关常用和正确的前缀的定义，请参阅mismatch(float[], float[]) ）。

        null阵列引用在字典上被认为小于非null阵列引用。 两个null数组引用被认为是相等的。

        比较与equals一致，更具体地说，对于阵列a和b

           Arrays.equals(a, b) == (Arrays.compare(a, b) == 0)
        API Note:

        该方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Float.compare(a[i], b[i]); return a.length - b.length;
        参数
        a - 第一个要比较的数组
        b - 第二个数组进行比较
        结果
        值0如果第一和第二个数组是相同的，并且以相同的顺序包含相同的元素; 小于0的值，如果第一个数组的字典小于第二个数组; 如果第一个数组的字典大小大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compare

        public static int compare​(float[] a,
                          int aFromIndex,
                          int aToIndex,
                          float[] b,
                          int bFromIndex,
                          int bToIndex)
        比较两个float阵列在字典上超过指定的范围。

        如果两个数组在指定的范围内共享一个公用的前缀，那么词典比较就是比较两个元素的结果，就像在Float.compare(float, float)一样 ，在相应的数组内的相对索引是前缀的长度。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关常用和正确的前缀的定义，请参阅mismatch(float[], int, int, float[], int, int) ）

        该比较是一致equals ，更具体地以下适用于阵列a和b与指定的范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别地）：

           Arrays.equals(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == (Arrays.compare(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == 0)
        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Float.compare(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 第一个要比较的数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中的最后一个元素的索引（独占）
        结果
        值0如果超过指定范围的第一和第二个数组是相同的，并且以相同的顺序包含相同的元素; 小于0的值，如果在指定范围内，第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • compare

        public static int compare​(double[] a,
                          double[] b)
        double字典顺序比较两个double阵列。

        如果两个数组共享一个共同的前缀，那么词典比较就是比较两个元素的结果，如Double.compare(double, double)那样 ，在作为前缀长度的各个数组中的索引处。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(double[], double[]) ）

        A null阵列引用在字典上被认为小于非null数组引用。 两个null数组引用被认为是相等的。

        比较与equals一致，更具体地说，对于阵列a和b ，具体如下：

           Arrays.equals(a, b) == (Arrays.compare(a, b) == 0)
        API Note:

        此方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return Double.compare(a[i], b[i]); return a.length - b.length;
        参数
        a - 第一个数组进行比较
        b - 第二个数组进行比较
        结果
        值0如果第一和第二个数组是相等的并且以相同的顺序包含相同的元素; 如果第一个数组的字典数字小于第二个数组，则该值小于0 ; 如果第一个数组的字典大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compare

        public static int compare​(double[] a,
                          int aFromIndex,
                          int aToIndex,
                          double[] b,
                          int bFromIndex,
                          int bToIndex)
        比较两个double阵列在字典上超过指定的范围。

        如果两个数组在指定的范围内共享一个共同的前缀，那么词典比较就是比较两个元素的结果，如Double.compare(double, double)那样 ，在作为前缀长度的相应数组内的相对索引处。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(double[], int, int, double[], int, int) ）

        该比较是一致equals ，更具体地以下适用于阵列a和b与指定的范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别地）：

           Arrays.equals(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == (Arrays.compare(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == 0)
        API Note:

        此方法的行为如下：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return Double.compare(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数
        a - 第一个要比较的数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        结果
        值0如果在指定的范围内，第一和第二个数组是相等的，并且包含相同的顺序相同的元素; 小于0的值，如果超过指定范围，第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • compare

        public static <T extends Comparable<? super T>> int compare​(T[] a,
                                                            T[] b)
        比较两个Object阵列，在可比较的元素内，按字典顺序。

        如果两个数组共享一个共同的前缀，则字典比较是将T类型的两个元素作为前缀长度的相应数组中的索引i进行比较的结果，如下所示：

           Comparator.nullsFirst(Comparator.<T>naturalOrder()). compare(a[i], b[i])
        否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （有关公用和正确前缀的定义，请参阅mismatch(Object[], Object[])。 ）

        A null阵列引用在字典上小于非null数组引用。 两个null数组引用被认为是相等的。 A null数组元素比非null数组元素进行字典比对。 两个null数组元素被认为是相等的。

        比较与equals一致，更具体地说，对于阵列a和b ，具体如下：

           Arrays.equals(a, b) == (Arrays.compare(a, b) == 0)
        API Note:

        该方法的行为就像（对于非null数组引用和元素）：

           int i = Arrays.mismatch(a, b); if (i >= 0 && i < Math.min(a.length, b.length)) return a[i].compareTo(b[i]); return a.length - b.length;
        参数类型
        T - 类似的数组元素
        参数
        a - 第一个要比较的数组
        b - 第二个数组进行比较
        结果
        值0如果第一和第二个数组是相等的并且以相同的顺序包含相同的元素; 小于0的值，如果第一个数组按字典顺序小于第二个数组; 如果第一个数组的字典大于第二个数组，则值大于0
        从以下版本开始：
        9

      • compare

        public static <T extends Comparable<? super T>> int compare​(T[] a,
                                                            int aFromIndex,
                                                            int aToIndex,
                                                            T[] b,
                                                            int bFromIndex,
                                                            int bToIndex)
        比较两个Object阵列在字典上超过指定的范围。

        如果两个数组在指定范围内共享公用前缀，则字典比较是将T类型的两个元素作为前缀长度的相应数组中的相对索引i进行比较的结果，如下所示：

           Comparator.nullsFirst(Comparator.<T>naturalOrder()). compare(a[aFromIndex + i, b[bFromIndex + i])
        否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （见mismatch(Object[], int, int, Object[], int, int)，用于定义一个普通和正确的前缀。）

        该比较是一致equals ，更具体地以下适用于阵列a和b与指定的范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别地）：

           Arrays.equals(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == (Arrays.compare(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex) == 0)
        API Note:

        该方法的行为就像（对于非null数组元素）：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return a[aFromIndex + i].compareTo(b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数类型
        T - 类似的数组元素
        参数
        a - 第一个要比较的数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中的最后一个元素的索引（独占）
        b - 要比较的第二个数组
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        结果
        值0如果超过指定范围的第一和第二个数组是相同的并且以相同的顺序包含相同的元素; 小于0的值，如果超过指定范围，则第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定的范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或者是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任何一个数组是 null
        从以下版本开始：
        9

      • compare

        public static <T> int compare​(T[] a,
                              T[] b,
                              Comparator<? super T> cmp)
        比较两个Object阵列，使用指定的比较器进行字典比对。

        如果两个数组共享一个共同的前缀，则字典比较是与指定的比较器比较的两个元素的结果，两个元素在作为前缀长度的各个数组中的索引处。 否则，一个数组是另一个数组的正确前缀，字典比较是比较两个数组长度的结果。 （见mismatch(Object[], Object[])定义一个通用和正确的前缀。）

        A null阵列引用在字典上小于非null阵列引用。 两个null数组引用被认为是相等的。

        API Note:

        此方法的行为就像（对于非null数组引用）：

           int i = Arrays.mismatch(a, b, cmp); if (i >= 0 && i < Math.min(a.length, b.length)) return cmp.compare(a[i], b[i]); return a.length - b.length;
        参数类型
        T - 数组元素的类型
        参数
        a - 第一个要比较的数组
        b - 第二个数组进行比较
        cmp - 比较器来比较数组元素
        结果
        值0如果第一个和第二个数组相等并且包含相同的元素在相同的顺序; 小于0的值，如果第一个数组按字典顺序小于第二个数组; 如果第一个数组的字典大小大于第二个数组，则值大于0
        异常
        NullPointerException - 如果比较器是 null
        从以下版本开始：
        9

      • compare

        public static <T> int compare​(T[] a,
                              int aFromIndex,
                              int aToIndex,
                              T[] b,
                              int bFromIndex,
                              int bToIndex,
                              Comparator<? super T> cmp)
        比较两个Object阵列在指定范围内的字典。

        如果两个数组在指定的范围内共享一个共同的前缀，则字典比较是与指定比较器的比较结果，两个元素在作为前缀长度的相应数组内的相对索引处。 否则，一个数组是另一个数组的正确的前缀，字典比较是比较两个范围长度的结果。 （有关公用和正确的前缀的定义，请参阅mismatch(Object[], int, int, Object[], int, int) ）

        API Note:

        该方法的行为就像（对于非null数组元素）：

           int i = Arrays.mismatch(a, aFromIndex, aToIndex, b, bFromIndex, bToIndex, cmp); if (i >= 0 && i < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex)) return cmp.compare(a[aFromIndex + i], b[bFromIndex + i]); return (aToIndex - aFromIndex) - (bToIndex - bFromIndex);
        参数类型
        T - 数组元素的类型
        参数
        a - 第一个要比较的数组
        aFromIndex - 要比较的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要比较的第一个数组中的最后一个元素的索引（独占）
        b - 第二个数组进行比较
        bFromIndex - 要比较的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要比较的第二个数组中最后一个元素的索引（独占）
        cmp - 比较数组元素的比较器
        结果
        值0如果超过指定范围的第一和第二个数组是相等的，并且以相同的顺序包含相同的元素; 小于0的值，如果超过指定范围，第一个数组的字典数字小于第二个数组; 大于0的值，如果超过指定范围，则第一个数组的字典大于第二个数组
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或者如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任何一个阵列或比较器是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(boolean[] a,
                           boolean[] b)
        查找并返回两个boolean数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果以下表达式为真， a两个非null数组（ a和b ）共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl) && a[pl] != b[pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果下列表达式为真， a两个非null阵列（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length))
        参数
        a - 要测试不匹配的第一个数组
        b - 要测试不匹配的第二个数组
        结果
        两个阵列之间的首次不匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(boolean[] a,
                           int aFromIndex,
                           int aToIndex,
                           boolean[] b,
                           int bFromIndex,
                           int bToIndex)
        查找并返回指定范围内两个boolean数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl) && a[aFromIndex + pl] != b[bFromIndex + pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex ）分别共享一个适当如果满足下列表达式为真：

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex))
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(byte[] a,
                           byte[] b)
        查找并返回两个byte数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果以下表达式为真， a两个非null阵列（ a和b ）共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl) && a[pl] != b[pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果下列表达式为真， a两个非null阵列（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length))
        参数
        a - 要测试不匹配的第一个数组
        b - 要测试不匹配的第二个数组
        结果
        两个阵列之间的首次匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任何一个数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(byte[] a,
                           int aFromIndex,
                           int aToIndex,
                           byte[] b,
                           int bFromIndex,
                           int bToIndex)
        查找并返回指定范围内两个byte数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl) && a[aFromIndex + pl] != b[bFromIndex + pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex ）分别共享一个适当如果满足下列表达式为真：

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex))
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中第一个元素的索引（含）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一阵列是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(char[] a,
                           char[] b)
        查找并返回两个char数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果以下表达式为真， a两个非null数组（ a和b ）共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl) && a[pl] != b[pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果以下表达式为真， a两个非null数组（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length))
        参数
        a - 要测试不匹配的第一个数组
        b - 要测试不匹配的第二个数组
        结果
        两个阵列之间的首次匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任何一个数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(char[] a,
                           int aFromIndex,
                           int aToIndex,
                           char[] b,
                           int bFromIndex,
                           int bToIndex)
        查找并返回指定范围内两个char数组之间的第一个不匹配的相对索引，否则返回-1，如果未发现不匹配。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl) && a[aFromIndex + pl] != b[bFromIndex + pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex ）分别共享一个适当如果满足下列表达式为真：

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex))
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(short[] a,
                           short[] b)
        查找并返回两个short数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果以下表达式为真， a两个非null阵列（ a和b ）共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl) && a[pl] != b[pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果以下表达式为真， a两个非null阵列（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length))
        参数
        a - 要测试不匹配的第一个数组
        b - 要测试不匹配的第二个数组
        结果
        两个阵列之间的第一个不匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(short[] a,
                           int aFromIndex,
                           int aToIndex,
                           short[] b,
                           int bFromIndex,
                           int bToIndex)
        查找并返回指定范围内的两个short数组之间的第一个不匹配的相对索引，否则返回-1，如果没有发现不匹配。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl) && a[aFromIndex + pl] != b[bFromIndex + pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex ）分别共享一个适当如果满足下列表达式为真：

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex))
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中的最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(int[] a,
                           int[] b)
        查找并返回两个int数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果以下表达式为真， a两个非null阵列a和b共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl) && a[pl] != b[pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果下列表达式为真， a两个非null数组（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length))
        参数
        a - 要测试不匹配的第一个数组
        b - 要测试不匹配的第二个数组
        结果
        两个阵列之间的首次匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任一个数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(int[] a,
                           int aFromIndex,
                           int aToIndex,
                           int[] b,
                           int bFromIndex,
                           int bToIndex)
        查找并返回指定范围内两个int数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl) && a[aFromIndex + pl] != b[bFromIndex + pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex ）分别共享一个适当如果满足下列表达式为真：

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex))
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或者如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任何一个数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(long[] a,
                           long[] b)
        查找并返回两个long数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果以下表达式为真， a两个非null阵列（ a和b ）共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl) && a[pl] != b[pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果以下表达式为真， a两个非null阵列（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length))
        参数
        a - 要测试不匹配的第一个数组
        b - 要测试不匹配的第二个数组
        结果
        两个阵列之间的首次匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任一个数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(long[] a,
                           int aFromIndex,
                           int aToIndex,
                           long[] b,
                           int bFromIndex,
                           int bToIndex)
        查找并返回指定范围内的两个long数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl) && a[aFromIndex + pl] != b[bFromIndex + pl]
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex ）分别共享一个适当如果满足下列表达式为真：

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex))
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(float[] a,
                           float[] b)
        查找并返回两个float数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果下列表达式为真， a两个非null数组a和b共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl) && Float.compare(a[pl], b[pl]) != 0
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果下列表达式为真， a两个非null数组（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length))
        参数
        a - 要测试不匹配的第一个数组
        b - 要测试不匹配的第二个数组
        结果
        两个数组之间的第一个不匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任何一个数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(float[] a,
                           int aFromIndex,
                           int aToIndex,
                           float[] b,
                           int bFromIndex,
                           int bToIndex)
        查找并返回指定范围内两个float数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl) && Float.compare(a[aFromIndex + pl], b[bFromIndex + pl]) != 0
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex ）分别共享一个适当如果满足下列表达式为真：

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex))
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中的最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中第一个元素的索引（含）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或者如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任何一个数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(double[] a,
                           double[] b)
        查找并返回两个double数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果以下表达式为真， a两个非null阵列（ a和b ）共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl) && Double.compare(a[pl], b[pl]) != 0
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果下列表达式为真， a两个非null数组（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length))
        参数
        a - 要测试不匹配的第一个数组
        b - 要测试不匹配的第二个数组
        结果
        两个阵列之间的首次匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任一个数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(double[] a,
                           int aFromIndex,
                           int aToIndex,
                           double[] b,
                           int bFromIndex,
                           int bToIndex)
        查找并返回指定范围内两个double数组之间的第一个不匹配的相对索引，否则返回-1，如果未发现不匹配。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl) && Double.compare(a[aFromIndex + pl], b[bFromIndex + pl]) != 0
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex ）分别共享一个适当如果满足下列表达式为真：

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex))
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或者如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任一数组是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(Object[] a,
                           Object[] b)
        查找并返回两个Object数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果下列表达式为真， a两个非null阵列a和b共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl) && !Objects.equals(a[pl], b[pl])
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果以下表达式为真， a两个非null阵列（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length))
        参数
        a
        b - 要测试不匹配的第二个数组
        结果
        这两个数组之间的第一个不匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任一个阵列是 null
        从以下版本开始：
        9

      • mismatch

        public static int mismatch​(Object[] a,
                           int aFromIndex,
                           int aToIndex,
                           Object[] b,
                           int bFromIndex,
                           int bToIndex)
        查找并返回指定范围内两个Object数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl) && !Objects.equals(a[aFromIndex + pl], b[bFromIndex + pl])
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex ）分别共享一个适当如果满足下列表达式为真：

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex))
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中的第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或者如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任何一个数组是 null
        从以下版本开始：
        9

      • mismatch

        public static <T> int mismatch​(T[] a,
                               T[] b,
                               Comparator<? super T> cmp)
        查找并返回两个Object数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。 索引将在0（包括）到最小数组的长度（包括）的范围内。

        指定的比较器用于确定每个阵列中的两个数组元素是否不相等。

        如果两个数组共享一个共同的前缀，则返回的索引是公共前缀的长度，因此在相应数组内的该索引处的两个元素之间存在不匹配。 如果一个数组是另一个数组的正确前缀，则返回的索引是较小数组的长度，因此该索引仅适用于较大的数组。 否则，没有不匹配。

        如果以下表达式为真， a两个非null数组a和b共享长度为pl的公共前缀：

           pl >= 0 && pl < Math.min(a.length, b.length) && Arrays.equals(a, 0, pl, b, 0, pl, cmp) cmp.compare(a[pl], b[pl]) != 0
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        如果以下表达式为真， a两个非null数组（ a和b ）共享正确的前缀：

           a.length != b.length && Arrays.equals(a, 0, Math.min(a.length, b.length), b, 0, Math.min(a.length, b.length), cmp)
        参数类型
        T - 数组元素的类型
        参数
        a - 要测试不匹配的第一个数组
        b - 要测试不匹配的第二个数组
        cmp - 比较器来比较数组元素
        结果
        两个数组之间的第一个不匹配的索引，否则为 -1 。
        异常
        NullPointerException - 如果任何一个阵列或比较器是 null
        从以下版本开始：
        9

      • mismatch

        public static <T> int mismatch​(T[] a,
                               int aFromIndex,
                               int aToIndex,
                               T[] b,
                               int bFromIndex,
                               int bToIndex,
                               Comparator<? super T> cmp)
        查找并返回指定范围内两个Object数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。 索引将在0（含）以上的范围内，直到较小范围的长度（包括）。

        如果两个数组在指定的范围内共享一个共同的前缀，那么返回的相对索引是公共前缀的长度，因此在相应数组内的相对索引处的两个元素之间存在不匹配。 如果一个数组是另一个的正确前缀，超过指定范围，则返回的相对索引是较小范围的长度，因此相对索引仅对范围较大的数组有效。 否则，没有不匹配。

        两个非null阵列， a和b具有指定范围[ aFromIndex ， atoIndex ）和[ bFromIndex ， btoIndex分别），分享长度的公共前缀pl如果满足下列表达式为真：

           pl >= 0 && pl < Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex) && Arrays.equals(a, aFromIndex, aFromIndex + pl, b, bFromIndex, bFromIndex + pl, cmp) && cmp.compare(a[aFromIndex + pl], b[bFromIndex + pl]) != 0
        请注意，公共前缀长度为0表示每个阵列的第一个元素不匹配。

        null a b - aFromIndex atoIndex - bFromIndex btoIndex - bFromIndex btoIndex - bFromIndex btoIndex - bFromIndex btoIndex - bFromIndex btoIndex - bFromIndex btoIndex - bFromIndex btoIndex - bFromIndex btoIndex - bFromIndex btoIndex - bFromIndex btoIndex - bFromIndex btoIndex

           (aToIndex - aFromIndex) != (bToIndex - bFromIndex) && Arrays.equals(a, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), b, 0, Math.min(aToIndex - aFromIndex, bToIndex - bFromIndex), cmp)
        参数类型
        T - 数组元素的类型
        参数
        a - 要测试不匹配的第一个数组
        aFromIndex - 要测试的第一个数组中的第一个元素的索引（包括）
        aToIndex - 要测试的第一个数组中最后一个元素的索引（独占）
        b - 要测试不匹配的第二个数组
        bFromIndex - 要测试的第二个数组中第一个元素的索引（包括）
        bToIndex - 要测试的第二个数组中最后一个元素的索引（独占）
        cmp - 比较数组元素比较器
        结果
        两个阵列之间在指定范围内的首次不匹配的相对索引，否则为 -1 。
        异常
        IllegalArgumentException - 如果是 aFromIndex > aToIndex或如果是 bFromIndex > bToIndex
        ArrayIndexOutOfBoundsException - 如果是 aFromIndex < 0 or aToIndex > a.length或如果是 bFromIndex < 0 or bToIndex > b.length
        NullPointerException - 如果任何一个阵列或比较器是 null
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Base64 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Base64

  • java.lang.Object
    • java.util.Base64

  • public class Base64
extends Object
    该类仅由用于获得Base64编码方案的编码器和解码器的静态方法组成。 该类的实现支持RFC 4648和RFC 2045中指定的以下类型的Base64。
    • Basic

      使用RFC 4648和RFC 2045表1中规定的“Base64字母表”进行编码和解码操作。 编码器不添加任何换行符（行分隔符）字符。 解码器拒绝包含base64字母外的字符的数据。

    • URL and Filename safe

      使用RFC 4648的表2中规定的“URL和Filename safe Base64 Alphabet”进行编码和解码。 编码器不添加任何换行符（行分隔符）字符。 解码器拒绝包含base64字母外的字符的数据。

    • MIME

      使用RFC 2045表1中规定的“Base64字母表”进行编码和解码操作。 编码输出必须以不超过76个字符的行表示，并使用回车'\r'然后立即以换行符'\n'作为行分隔符。 没有行分隔符添加到编码输出的末尾。 在解码操作中，将忽略base64字母表中未找到的所有行分隔符或其他字符。

    除非另有说明，否则将null参数传递给null的方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.8

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Base64.Decoder
      该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于解码字节数据的解码器。
      static class  Base64.Encoder
      该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于编码字节数据的编码器。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Base64.Decoder getDecoder​()
      返回一个Base64.Decoder ，它使用Basic类型base64编码方案进行解码。
      static Base64.Encoder getEncoder​()
      返回一个Base64.Encoder ，它使用Basic类型base64编码方案进行编码。
      static Base64.Decoder getMimeDecoder​()
      返回一个Base64.Decoder解码使用MIME型BASE64解码方案。
      static Base64.Encoder getMimeEncoder​()
      返回一个Base64.Encoder ，它使用MIME类型的base64编码方案进行编码。
      static Base64.Encoder getMimeEncoder​(int lineLength, byte[] lineSeparator)
      返回一个Base64.Encoder ，它使用具有指定行长和行分隔符的MIME类型base64编码方案进行编码。
      static Base64.Decoder getUrlDecoder​()
      返回一个Base64.Decoder ，它使用URL and Filename safe类型base64编码方案进行解码。
      static Base64.Encoder getUrlEncoder​()
      返回一个Base64.Encoder ，它使用URL and Filename safe类型的base64编码方案进行编码。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getEncoder

        public static Base64.Encoder getEncoder​()
        返回一个Base64.Encoder ，它使用Basic类型base64编码方案进行编码。
        结果
        一个Base64编码器。

      • getUrlEncoder

        public static Base64.Encoder getUrlEncoder​()
        返回Base64.Encoder ，使用URL and Filename safe类型base64编码方案进行编码。
        结果
        一个Base64编码器。

      • getMimeEncoder

        public static Base64.Encoder getMimeEncoder​()
        返回一个Base64.Encoder ，它使用MIME类型的base64编码方案进行编码。
        结果
        一个Base64编码器。

      • getMimeEncoder

        public static Base64.Encoder getMimeEncoder​(int lineLength,
                                            byte[] lineSeparator)
        返回一个Base64.Encoder ，它使用具有指定行长度和行分隔符的MIME类型base64编码方案进行编码。
        参数
        lineLength - 每个输出行的长度（向下舍入为4的最接近的倍数）。 如果lineLength <= 0的输出将不会分开
        lineSeparator - 每个输出行的行分隔符
        结果
        一个Base64编码器。
        异常
        IllegalArgumentException - 如果 lineSeparator包含RFC 2045表1中规定的任何字符“Base64 Alphabet”。

      • getDecoder

        public static Base64.Decoder getDecoder​()
        返回Base64.Decoder解码使用Basic型base64编码方案。
        结果
        一个Base64解码器。

      • getUrlDecoder

        public static Base64.Decoder getUrlDecoder​()
        返回Base64.Decoder解码使用URL and Filename safe型base64编码方案。
        结果
        一个Base64解码器。

      • getMimeDecoder

        public static Base64.Decoder getMimeDecoder​()
        返回一个Base64.Decoder解码使用MIME型BASE64解码方案。
        结果
        一个Base64解码器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Base64.Decoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Base64.Decoder

  • java.lang.Object
    • java.util.Base64.Decoder
  • Enclosing class:
    Base64

    public static class Base64.Decoder
extends Object
    该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于解码字节数据的解码器。

    Base64填充字符'='被接受并解释为编码字节数据的结尾，但不是必需的。 因此，如果编码字节数据的最终单位只有两个或三个Base64字符（没有相应的填充字符被填充），则它们被解码，就像后跟填充字符一样。 如果最终单位中存在填充字符，则必须存在正确数量的填充字符，否则在解码期间抛出IllegalArgumentException （从Base64流读取时为IOException ）。

    Base64.Decoder类的实例可以安全使用多个并发线程。

    除非另有说明，否则将null参数传递给null的方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.8
    另请参见：
    Base64.Encoder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] decode​(byte[] src)
      使用Base64编码方案从输入字节数组中解码所有字节，将结果写入新分配的输出字节数组。
      int decode​(byte[] src, byte[] dst)
      使用Base64编码方案从输入字节数组中解码所有字节，将结果写入给定的输出字节数组，从偏移量0开始。
      byte[] decode​(String src)
      使用Base64编码方案将Base64编码的字符串解码为新分配的字节数组。
      ByteBuffer decode​(ByteBuffer buffer)
      使用Base64编码方案从输入字节缓冲区中解码所有字节，将结果写入新分配的ByteBuffer。
      InputStream wrap​(InputStream is)
      返回用于解码Base64编码字节流的输入流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • decode

        public byte[] decode​(byte[] src)
        使用Base64编码方案从输入字节数组中解码所有字节，将结果写入新分配的输出字节数组。 返回的字节数组是生成字节的长度。
        参数
        src - 要解码的字节数组
        结果
        新分配的包含解码字节的字节数组。
        异常
        IllegalArgumentException - 如果 src不是有效的Base64方案

      • decode

        public byte[] decode​(String src)
        使用Base64编码方案将Base64编码的字符串解码为新分配的字节数组。

        调用此方法与调用decode(src.getBytes(StandardCharsets.ISO_8859_1))具有完全相同的效果

        参数
        src - 要解码的字符串
        结果
        新分配的包含解码字节的字节数组。
        异常
        IllegalArgumentException - 如果 src不是有效的Base64方案

      • decode

        public int decode​(byte[] src,
                  byte[] dst)
        使用Base64编码方案从输入字节数组中解码所有字节，将结果写入给定的输出字节数组，从偏移量0开始。

        这种方法的调用者有责任确保输出字节数组dst具有足够的空间来解码输入字节数组中的所有字节。 如果输出字节数组不够大，则不会将字节写入输出字节数组。

        如果输入字节数组不是有效的Base64编码方案，那么在抛出IllegalargumentException之前，可能会将一些字节写入输出字节数组。

        参数
        src - 要解码的字节数组
        dst - 输出字节数组
        结果
        写入输出字节数组的字节数
        异常
        IllegalArgumentException - 如果 src不是有效的Base64方案，或 dst没有足够的空间来解码所有的输入字节。

      • decode

        public ByteBuffer decode​(ByteBuffer buffer)
        使用Base64编码方案从输入字节缓冲区中解码所有字节，将结果写入新分配的ByteBuffer。

        返回时，源缓冲区的位置将更新为其限制; 其限制将不会改变。 返回的输出缓冲区的位置将为零，其限制将是生成的解码字节数

        如果输入缓冲区不是有效的Base64编码方案，则抛出IllegalArgumentException 。 在这种情况下，输入缓冲区的位置不会提前。

        参数
        buffer - ByteBuffer进行解码
        结果
        一个包含解码字节的新分配的字节缓冲区
        异常
        IllegalArgumentException - 如果 src不是有效的Base64方案。

      • wrap

        public InputStream wrap​(InputStream is)
        返回用于解码Base64编码字节流的输入流。

        当读取不能解码的字节时，返回的InputStream的read方法将抛出IOException 。

        关闭返回的输入流将关闭底层输入流。

        参数
        is - 输入流
        结果
        用于解码指定的Base64编码字节流的输入流
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Base64.Encoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Base64.Encoder

  • java.lang.Object
    • java.util.Base64.Encoder
  • Enclosing class:
    Base64

    public static class Base64.Encoder
extends Object
    该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于编码字节数据的编码器。

    Base64.Encoder类的实例可以安全地被多个并发线程使用。

    除非另有说明，否则将null参数传递给null的方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.8
    另请参见：
    Base64.Decoder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] encode​(byte[] src)
      使用Base64编码方案将指定字节数组中的所有字节编码为新分配的字节数组。
      int encode​(byte[] src, byte[] dst)
      使用Base64编码方案对来自指定字节数组的所有字节进行编码，将生成的字节写入给定的输出字节数组，从偏移量0开始。
      ByteBuffer encode​(ByteBuffer buffer)
      使用Base64编码方案将所有剩余字节从指定的字节缓冲区编码到新分配的ByteBuffer中。
      String encodeToString​(byte[] src)
      使用Base64编码方案将指定的字节数组编码为字符串。
      Base64.Encoder withoutPadding​()
      返回一个编码器实例，编码器等效于此编码器实例，但不会在编码字节数据的末尾添加任何填充字符。
      OutputStream wrap​(OutputStream os)
      使用Base64编码方案包装用于编码字节数据的输出流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • encode

        public byte[] encode​(byte[] src)
        使用Base64编码方案将指定字节数组中的所有字节编码为新分配的字节数组。 返回的字节数组是生成字节的长度。
        参数
        src - 要编码的字节数组
        结果
        一个新分配的字节数组，包含生成的编码字节。

      • encode

        public int encode​(byte[] src,
                  byte[] dst)
        使用Base64编码方案对来自指定字节数组的所有字节进行编码，将生成的字节写入给定的输出字节数组，从偏移0开始。

        该方法的调用者有责任确保输出字节数组dst具有足够的空间来编码来自输入字节数组的所有字节。 如果输出字节数组不够大，则不会将字节写入输出字节数组。

        参数
        src - 要编码的字节数组
        dst - 输出字节数组
        结果
        写入输出字节数组的字节数
        异常
        IllegalArgumentException - 如果 dst没有足够的空间来编码所有输入字节。

      • encodeToString

        public String encodeToString​(byte[] src)
        使用Base64编码方案将指定的字节数组编码为字符串。

        该方法首先将所有输入字节编码为base64编码字节数组，然后使用编码字节数组和ISO-8859-1字符集构造一个新的字符串。

        换句话说，这个方法的调用与调用new String(encode(src), StandardCharsets.ISO_8859_1)有完全相同的效果。

        参数
        src - 要编码的字节数组
        结果
        包含生成的Base64编码字符的字符串

      • encode

        public ByteBuffer encode​(ByteBuffer buffer)
        使用Base64编码方案将所有剩余字节从指定的字节缓冲区编码为新分配的ByteBuffer。 返回时，源缓冲区的位置将更新为其限制; 其限制将不会改变。 返回的输出缓冲区的位置将为零，其限制将是生成的编码字节数。
        参数
        buffer - 来源ByteBuffer进行编码
        结果
        包含编码字节的新分配的字节缓冲区。

      • wrap

        public OutputStream wrap​(OutputStream os)
        使用Base64编码方案包装用于编码字节数据的输出流。

        建议在使用后立即关闭返回的输出流，在此期间，它会将所有可能的剩余字节刷新到底层输出流。 关闭返回的输出流将关闭底层输出流。

        参数
        os - 输出流。
        结果
        用于将字节数据编码为指定的Base64编码格式的输出流

      • withoutPadding

        public Base64.Encoder withoutPadding​()
        返回一个编码器实例，编码器等效于此编码器实例，但不会在编码字节数据的末尾添加任何填充字符。

        该编码器实例的编码方案不受此调用的影响。 返回的编码器实例应用于非填充编码操作。

        结果
        一个等效编码器，编码而不会在末尾添加任何填充字符
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BitSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class BitSet

  • java.lang.Object
    • java.util.BitSet
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class BitSet
extends Object
implements Cloneable, Serializable
    该类实现了根据需要增长的位向量。 位组的每个组件都有一个boolean值。 BitSet的位由非负整数索引。 可以检查，设置或清除各个索引位。 一个BitSet可以用于通过逻辑AND，逻辑包括OR和逻辑异或操作来修改另一个BitSet的内容。

    默认情况下，集合中的所有位最初都具有值false 。

    每个位集具有当前大小，这是位设置当前使用的空间位数。 请注意，这个大小与一个位的实现有关，所以它可能会随着实现而改变。 位集合的长度与位集合的逻辑长度相关，并且独立于实现来定义。

    除非另有说明，否则将null参数传递给BitSet任何方法将导致NullPointerException 。

    A BitSet对于无需外部同步的多线程使用是不安全的。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BitSet​()
      创建一个新的位集。
      BitSet​(int nbits)
      创建一个位集合，其初始大小足够大以显式表示索引为 0到 nbits-1 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void and​(BitSet set)
      执行此参数位置位的此目标位设置的逻辑 AND 。
      void andNot​(BitSet set)
      清除 BitSet的所有位，其相应位在指定的 BitSet设置。
      int cardinality​()
      返回 true中设置为 true的 BitSet 。
      void clear​()
      将该BitSet中的所有位设置为 false 。
      void clear​(int bitIndex)
      将索引指定的位设置为 false 。
      void clear​(int fromIndex, int toIndex)
      将指定的 fromIndex （含）的位设置为 toIndex （排他）到 false 。
      Object clone​()
      克隆这个 BitSet产生一个新的 BitSet等于它。
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      void flip​(int bitIndex)
      将指定索引处的位设置为其当前值的补码。
      void flip​(int fromIndex, int toIndex)
      将指定的 fromIndex （含）的每一位设置为指定的 toIndex （独占），使其为当前值的补码。
      boolean get​(int bitIndex)
      返回具有指定索引的位的值。
      BitSet get​(int fromIndex, int toIndex)
      返回一个新 BitSet组成位从这个 BitSet从 fromIndex （含）至 toIndex （独家）。
      int hashCode​()
      返回此位集的哈希码值。
      boolean intersects​(BitSet set)
      如果指定，则返回true BitSet具有设置为任何位 true ，它们也设置为 true这个 BitSet 。
      boolean isEmpty​()
      如果此 BitSet包含设置为 true位，则返回true。
      int length​()
      返回 BitSet的“逻辑大小”： BitSet加上最高位的索引。
      int nextClearBit​(int fromIndex)
      返回在指定的起始索引上或之后发生的第一个位的索引，设置为 false 。
      int nextSetBit​(int fromIndex)
      返回在指定的起始索引上或之后发生的第一个位的索引，设置为 true 。
      void or​(BitSet set)
      使用位设置参数执行该位的逻辑 或 。
      int previousClearBit​(int fromIndex)
      返回在指定的起始索引上或之前发生的最近位的索引，设置为 false 。
      int previousSetBit​(int fromIndex)
      返回在指定的起始索引上或之前发生的最近位的索引，设置为 true 。
      void set​(int bitIndex)
      将指定索引处的位设置为 true 。
      void set​(int bitIndex, boolean value)
      将指定索引处的位设置为指定值。
      void set​(int fromIndex, int toIndex)
      将指定的 fromIndex （含）的位设置为 toIndex （排他）到 true 。
      void set​(int fromIndex, int toIndex, boolean value)
      将指定的 fromIndex （含）的位设置为指定值的 toIndex （排除）。
      int size​()
      返回 BitSet实际使用的空间位数，以表示位值。
      IntStream stream​()
      返回一个索引流，其中 BitSet包含处于置位状态的位。
      byte[] toByteArray​()
      返回一个包含该位集中所有位的新字节数组。
      long[] toLongArray​()
      返回一个包含该位集合中所有位的新长数组。
      String toString​()
      返回此位集的字符串表示形式。
      static BitSet valueOf​(byte[] bytes)
      返回包含给定字节数组中所有位的新位集合。
      static BitSet valueOf​(long[] longs)
      返回包含给定长数组中所有位的新位集。
      static BitSet valueOf​(ByteBuffer bb)
      返回一个包含给定字节缓冲区中所有位在其位置和极限之间的新位集合。
      static BitSet valueOf​(LongBuffer lb)
      返回包含给定长缓冲区中其位置和极限之间的所有位的新位集合。
      void xor​(BitSet set)
      使用位设置参数执行该位的逻辑 异或 。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BitSet

        public BitSet​()
        创建一个新的位集。 所有位最初为false 。

      • BitSet

        public BitSet​(int nbits)
        创建一个位集合，其初始大小足够大，以明确表示索引为0到nbits-1 。 所有位最初为false 。
        参数
        nbits - 位的初始大小
        异常
        NegativeArraySizeException - 如果指定的初始大小为负

    • 方法详细信息

      • valueOf

        public static BitSet valueOf​(long[] longs)
        返回包含给定长数组中所有位的新位集。

        更确切地说，
        BitSet.valueOf(longs).get(n) == ((longs[n/64] & (1L<<(n%64))) != 0)
        全部为n < 64 * longs.length 。

        此方法相当于BitSet.valueOf(LongBuffer.wrap(longs)) 。

        参数
        longs - 一个长数组，其中包含要用作新位集初始位的位序列的小端位表示
        结果
        一个 BitSet包含长阵列中的所有位
        从以下版本开始：
        1.7

      • valueOf

        public static BitSet valueOf​(LongBuffer lb)
        返回包含给定长缓冲区中其位置和极限之间的所有位的新位集合。

        更确切地说，
        BitSet.valueOf(lb).get(n) == ((lb.get(lb.position()+n/64) & (1L<<(n%64))) != 0)
        全部为n < 64 * lb.remaining() 。

        长缓冲区不被该方法修改，并且不对该缓冲区的引用保留位设置。

        参数
        lb - 一个长缓冲区，包含位置和限制之间的位序列的小 lb表示，用作新位集的初始位
        结果
        一个 BitSet包含指定范围内缓冲区中的所有位
        从以下版本开始：
        1.7

      • valueOf

        public static BitSet valueOf​(byte[] bytes)
        返回包含给定字节数组中所有位的新位集合。

        更确切地说，
        BitSet.valueOf(bytes).get(n) == ((bytes[n/8] & (1<<(n%8))) != 0)
        全部为n < 8 * bytes.length 。

        此方法相当于BitSet.valueOf(ByteBuffer.wrap(bytes)) 。

        参数
        bytes - 一个字节数组，其中包含要用作新位集初始位的位序列的小 bytes表示
        结果
        一个 BitSet包含字节数组中的所有位
        从以下版本开始：
        1.7

      • valueOf

        public static BitSet valueOf​(ByteBuffer bb)
        返回一个包含给定字节缓冲区中所有位在其位置和极限之间的新位集合。

        更确切地说，
        BitSet.valueOf(bb).get(n) == ((bb.get(bb.position()+n/8) & (1<<(n%8))) != 0)
        全部为n < 8 * bb.remaining() 。

        字节缓冲区不被该方法修改，并且该位不保留对缓冲区的引用。

        参数
        bb - 一个字节缓冲区，其中包含位置和极限之间的位序列的小 bb表示，用作新位组的初始位
        结果
        一个 BitSet包含指定范围内缓冲区中的所有位
        从以下版本开始：
        1.7

      • toByteArray

        public byte[] toByteArray​()
        返回一个包含该位集中所有位的新字节数组。

        更准确地说，如果
        byte[] bytes = s.toByteArray();
        然后bytes.length == (s.length()+7)/8和
        s.get(n) == ((bytes[n/8] & (1<<(n%8))) != 0)
        全部为n < 8 * bytes.length 。

        结果
        一个包含该位集中所有位的小端子表示的字节数组
        从以下版本开始：
        1.7

      • toLongArray

        public long[] toLongArray​()
        返回一个包含该位集合中所有位的新长数组。

        更准确地说，如果
        long[] longs = s.toLongArray();
        然后longs.length == (s.length()+63)/64和
        s.get(n) == ((longs[n/64] & (1L<<(n%64))) != 0)
        为所有n < 64 * longs.length 。

        结果
        一个包含该位集中所有位的小端子表示的长数组
        从以下版本开始：
        1.7

      • flip

        public void flip​(int bitIndex)
        将指定索引处的位设置为其当前值的补码。
        参数
        bitIndex - 翻转的位的索引
        异常
        IndexOutOfBoundsException - 指定的索引是否为负
        从以下版本开始：
        1.4

      • flip

        public void flip​(int fromIndex,
                 int toIndex)
        将指定的 fromIndex （含）中的每一位设置为指定的 toIndex （排他）到其当前值的补码。
        参数
        fromIndex - 第一位的索引翻页
        toIndex - 最后一位翻转后的索引
        异常
        IndexOutOfBoundsException - 如果 fromIndex为负数，或 toIndex为负数，或 fromIndex大于 toIndex
        从以下版本开始：
        1.4

      • set

        public void set​(int bitIndex)
        将指定索引的位设置为 true 。
        参数
        bitIndex - 一个位索引
        异常
        IndexOutOfBoundsException - 如果指定的索引为负数
        从以下版本开始：
        1.0

      • set

        public void set​(int bitIndex,
                boolean value)
        将指定索引处的位设置为指定值。
        参数
        bitIndex - 一个位索引
        value - 要设置的布尔值
        异常
        IndexOutOfBoundsException - 如果指定的索引为负数
        从以下版本开始：
        1.4

      • set

        public void set​(int fromIndex,
                int toIndex)
        将指定的 fromIndex （含）的位设置为 toIndex （独占）到 true 。
        参数
        fromIndex - 要设置的第一个位的索引
        toIndex - 最后一位要设置的索引
        异常
        IndexOutOfBoundsException - 如果 fromIndex为负数，或 toIndex为负数，或 fromIndex大于 toIndex
        从以下版本开始：
        1.4

      • set

        public void set​(int fromIndex,
                int toIndex,
                boolean value)
        将指定的 fromIndex （含）的位设置为指定值的 toIndex （排除）。
        参数
        fromIndex - 要设置的第一位的索引
        toIndex - 最后一位要设置的索引
        value - 设置所选位的值
        异常
        IndexOutOfBoundsException - 如果 fromIndex为负数，或 toIndex为负数，或 fromIndex大于 toIndex
        从以下版本开始：
        1.4

      • clear

        public void clear​(int bitIndex)
        将索引指定的位设置为 false 。
        参数
        bitIndex - 要清除的位的索引
        异常
        IndexOutOfBoundsException - 如果指定的索引为负数
        从以下版本开始：
        1.0

      • clear

        public void clear​(int fromIndex,
                  int toIndex)
        将指定的 fromIndex （含）的位设置为 toIndex （独占）到 false 。
        参数
        fromIndex - 要清除的第一个位的索引
        toIndex - 最后一位被清除后的索引
        异常
        IndexOutOfBoundsException - 如果 fromIndex为负数，或 toIndex为负数，或 fromIndex大于 toIndex
        从以下版本开始：
        1.4

      • clear

        public void clear​()
        将此BitSet中的所有位设置为 false 。
        从以下版本开始：
        1.4

      • get

        public boolean get​(int bitIndex)
        返回具有指定索引的位的值。 该值是true如果与索引的比特bitIndex在该当前设置BitSet ; 否则，结果是false 。
        参数
        bitIndex - 位索引
        结果
        该位的值与指定的索引
        异常
        IndexOutOfBoundsException - 指定的索引是否为负

      • get

        public BitSet get​(int fromIndex,
                  int toIndex)
        返回一个新的 BitSet由 BitSet从 fromIndex （含）到 toIndex （排他）组成。
        参数
        fromIndex - 要包含的第一位的索引
        toIndex - 索引后最后一位要包含
        结果
        一个新的 BitSet从这个 BitSet的范围
        异常
        IndexOutOfBoundsException - 如果 fromIndex为负数，或 toIndex为负数，或 fromIndex大于 toIndex
        从以下版本开始：
        1.4

      • nextSetBit

        public int nextSetBit​(int fromIndex)
        返回在指定的起始索引上或之后发生的第一个位的索引，设置为true 。 如果没有这样的位存在，则返回-1 。

        遍历true位在BitSet ，使用以下循环：

           for (int i = bs.nextSetBit(0); i >= 0; i = bs.nextSetBit(i+1)) { // operate on index i here if (i == Integer.MAX_VALUE) { break; // or (i+1) would overflow } }
        参数
        fromIndex - 开始检查的索引（含）
        结果
        下一个设置位的索引，或 -1如果没有这样的位
        异常
        IndexOutOfBoundsException - 如果指定的索引为负数
        从以下版本开始：
        1.4

      • nextClearBit

        public int nextClearBit​(int fromIndex)
        返回在指定的起始索引上或之后发生的第一个位的索引，设置为 false 。
        参数
        fromIndex - 开始检查的索引（含）
        结果
        下一个清除位的索引
        异常
        IndexOutOfBoundsException - 如果指定的索引为负
        从以下版本开始：
        1.4

      • previousSetBit

        public int previousSetBit​(int fromIndex)
        返回在指定的起始索引上或之前发生的最近位的索引，设置为true 。 如果不存在这样的位，或者如果给出-1作为起始索引，则返回-1 。

        遍历true位在BitSet ，使用以下循环：

           for (int i = bs.length(); (i = bs.previousSetBit(i-1)) >= 0; ) { // operate on index i here }
        参数
        fromIndex - 开始检查的索引（含）
        结果
        前一个设置位的索引，或者是 -1如果没有这样的位
        异常
        IndexOutOfBoundsException - 如果指定的索引小于 -1
        从以下版本开始：
        1.7

      • previousClearBit

        public int previousClearBit​(int fromIndex)
        返回在指定的起始索引上或之前发生的最近位的索引，设置为false 。 如果不存在这样的位，或者如果给出了-1作为起始索引，则返回-1 。
        参数
        fromIndex - 开始检查的索引（含）
        结果
        前一个清除位的索引，或 -1如果没有这样的位
        异常
        IndexOutOfBoundsException - 如果指定的索引小于 -1
        从以下版本开始：
        1.7

      • length

        public int length​()
        返回BitSet的“逻辑大小”： BitSet加上最高位的索引。 如果BitSet包含设置位，则返回零。
        结果
        这个 BitSet的逻辑大小
        从以下版本开始：
        1.2

      • isEmpty

        public boolean isEmpty​()
        如果此 BitSet包含设置为 true位，则返回true。
        结果
        布尔值指示此 BitSet是否为空
        从以下版本开始：
        1.4

      • intersects

        public boolean intersects​(BitSet set)
        如果指定，则返回true BitSet具有设置为任何位 true ，它们也设置为 true这个 BitSet 。
        参数
        set - BitSet相交
        结果
        指示此 BitSet是否与指定的 BitSet相交
        从以下版本开始：
        1.4

      • cardinality

        public int cardinality​()
        返回此 BitSet设置为 true的 BitSet 。
        结果
        这个 true中的位数设置为 BitSet
        从以下版本开始：
        1.4

      • and

        public void and​(BitSet set)
        执行此参数位置位的此目标位设置的逻辑AND 。 该位组被修改，使得在它的每个位具有值true当且仅当两者它最初所具有的值true和在比特组参数中的相应位也有值true 。
        参数
        set - 有点位

      • or

        public void or​(BitSet set)
        使用位设置参数执行该位的逻辑或 。 此位设置被修改，使得在某个位值true当且仅当它要么已经有了值true或位设定参数对应位的值为true 。
        参数
        set - 有点设置

      • xor

        public void xor​(BitSet set)
        使用位设置参数执行该位的逻辑异或 。 该位设置被修改，以便当且仅当下列其中一个语句成立时，其位中的值为true ：
        • 该位最初具有值true ，并且参数中的相应位具有值false 。
        • 该位最初具有值false ，并且参数中的相应位具有值true 。
        参数
        set - 有点设置

      • andNot

        public void andNot​(BitSet set)
        清除 BitSet的所有位，其相应位在指定的 BitSet设置。
        参数
        set - BitSet用来掩盖这个 BitSet
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回此位集的哈希码值。 散列码仅依赖于该BitSet内设置的位。

        哈希码被定义为以下计算的结果：

           public int hashCode() { long h = 1234; long[] words = toLongArray(); for (int i = words.length; --i >= 0; ) h ^= words[i] * (i + 1); return (int)((h >> 32) ^ h); }
        请注意，如果该组位被改变，那么哈希代码就会改变。
        重写：
        hashCode在 Object
        结果
        该位的哈希码值设置
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • size

        public int size​()
        返回此BitSet实际使用的空间位数，以表示位值。 集合中的最大元素是大小 - 第一个元素。
        结果
        此位设置中当前位数

      • equals

        public boolean equals​(Object obj)
        将此对象与指定对象进行比较。 结果是true当且仅当参数不是null并且是一个Bitset对象，其完全相同的位设置为true因为该位设置。 也就是说，对于每个非负int索引k ，
          ((BitSet)obj).get(k) == this.get(k)
        一定是真的 不比较两个位组的当前大小。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        true如果对象是一样的; 否则为false
        另请参见：
        size()

      • clone

        public Object clone​()
        克隆BitSet产生一个新的BitSet ，等于它。 该位的克隆是另一个位设置，与该位设置完全相同的位设置为true 。
        重写：
        clone在 Object
        结果
        这个位的一个克隆
        另请参见：
        size()

      • toString

        public String toString​()
        返回此位集的字符串表示形式。 对于此BitSet在设置状态中包含一位的每个索引，该索引的十进制表示都包含在结果中。 这些索引按照从最低到最高的顺序列出，用“，”（逗号和空格）分隔开并被大括号包围，导致一整套整数的通常的数学符号。

        例：

          BitSet drPepper = new BitSet();
        现在drPepper.toString()返回“ {} ”。
          drPepper.set(2);
        现在drPepper.toString()返回“ {2} ”。
          drPepper.set(4);
 drPepper.set(10);
        现在drPepper.toString()返回“ {2, 4, 10} ”。
        重写：
        toString在 Object
        结果
        该位集合的字符串表示形式

      • stream

        public IntStream stream​()
        返回此BitSet包含设置状态位的索引流。 索引按顺序返回，从最低到最高。 流的大小是设置状态中的位数，等于cardinality()方法返回的值。

        当终端流操作开始时（特别地，流的分流器是late-binding ），该流绑定到该位集合。 如果在该操作期间修改了位集，则结果未定义。

        结果
        表示集合索引的整数流
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Calendar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Calendar

  • java.lang.Object
    • java.util.Calendar
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Comparable<Calendar>
    已知直接子类：
    GregorianCalendar

    public abstract class Calendar
extends Object
implements Serializable, Cloneable, Comparable<Calendar>
    所述Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法calendar fields如YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。 时间上的瞬间可以表示为毫秒值，该值与1970年1月1日00：00：00.000 GMT（格里高利）的Epoch偏移。

    该类还提供了用于在包外部实现具体日历系统的其他字段和方法。 这些字段和方法定义为protected 。

    像其他语言环境敏感的类一样， Calendar提供了一个类方法， getInstance ，用于获取这种类型的一般有用的对象。 Calendar的getInstance方法返回一个Calendar对象，其日历字段已使用当前日期和时间初始化：

         Calendar rightNow = Calendar.getInstance();

    Calendar对象可以产生实现特定语言和日历风格的日期时间格式化所需的所有日历字段值（例如日语 - 公历，日语 - 繁体）。 Calendar定义某些日历字段返回的值的范围及其含义。 例如，所有日历的日历系统的第一个月的值为MONTH == JANUARY 。 其他值由具体的子类定义，如ERA 。 有关详细信息，请参阅各个实体文档和子类文档。

    获取和设置日历字段值

    日历字段值可以通过调用set方法设置。 在Calendar设置的任何字段值将不被解释，直到它需要计算其时间值（从Epoch的毫秒）或日历字段的值。 调用get ， getTimeInMillis ， getTime ， add和roll涉及这样的计算。

    宽大

    Calendar有两种方式来解释日历字段， 宽松和不宽泛 。 当Calendar处于宽松模式时，它接受比它产生的更广泛的日历字段值。 当Calendar重新计算日历字段值以返回get() ，所有日历字段都被归一化。 例如，宽松的GregorianCalendar将解释MONTH == JANUARY DAY_OF_MONTH == 32为2月1日。

    当Calendar处于非宽松模式时，如果其日历字段中存在任何不一致，则会抛出异常。 例如， GregorianCalendar总是在1和月份之间产生DAY_OF_MONTH值。 如果设置了超出范围的字段值，则非宽松的GregorianCalendar会在计算其时间或日历字段值时抛出异常。

    First Week

    Calendar使用两个参数定义了一个特定地区的七天周：第一周的第一天和第一周的最小天数（从1到7）。 当构建一个Calendar时，这些数字取自区域设置资源数据。 也可以通过设置其值的方法来明确指定它们。

    设置或获取WEEK_OF_MONTH或WEEK_OF_YEAR字段时， Calendar必须确定月或年的第一周作为参考点。 一个月或一年的第一个星期定义为从getFirstDayOfWeek()开始的最早七天期间，该月份至少包含getMinimalDaysInFirstWeek()天。 星期编号...，-1，0在第一周之前; 周数为2，3，...跟随。 请注意，由get()返回的归一化编号可能不同。 例如，特定的Calendar子类可以指定一年的第1周之前的一周为上一周的n 。

    日历字段分辨率

    在计算日历字段的日期和时间时，可能没有足够的计算信息（例如只有年月日没有月份），或者可能存在不一致的信息（例如1996年7月15日星期二（格里高利） - 1996年7月15日实际上是星期一）。 Calendar将以下列方式解析日历字段值以确定日期和时间。

    If there is any conflict in calendar field values, Calendar gives priorities to calendar fields that have been set more recently.以下是日历字段的默认组合。 将使用由最近设置的单个字段确定的最新组合。

    For the date fields ：

     YEAR + MONTH + DAY_OF_MONTH
 YEAR + MONTH + WEEK_OF_MONTH + DAY_OF_WEEK
 YEAR + MONTH + DAY_OF_WEEK_IN_MONTH + DAY_OF_WEEK
 YEAR + DAY_OF_YEAR
 YEAR + DAY_OF_WEEK + WEEK_OF_YEAR
    For the time of day fields ：
     HOUR_OF_DAY
 AM_PM + HOUR

    如果在所选字段组合中没有设置其值的任何日历字段，则Calendar使用其默认值。 每个字段的默认值可能会因具体的日历系统而异。 例如， GregorianCalendar ，字段的默认值是相同的时代的开始：即YEAR = 1970 ， MONTH = JANUARY ， DAY_OF_MONTH = 1 ，等等。

    注意：在某些奇异时期的解释中存在某些可能的含糊之处，其解决方式如下：

    1. 23:59是一天的最后一分钟，00:00是第二天的第一分钟。 因此，一九九九年十二月三十一日（星期三）在二○○○年一月一日（星期一）
    2. 虽然历史上不太精确，但午夜也属于“am”，中午属于“pm”，所以在同一天12:00（午夜）上午12时01分，中午12:00（中午）下午01点

    日期或时间格式字符串不是日历定义的一部分，因为这些字符串必须在运行时由用户修改或覆盖。 使用DateFormat格式化日期。

    现场操纵

    ：日历字段可以用三种方法来改变set() ， add() ，并roll() 。

    set(f, value)改变日历字段f至value 。 另外，它设置一个内部成员变量来指示日历字段f已被更改。 尽管日历字段f立即更改，以毫秒为单位日历的时间值不重新计算，直到下一次调用get() ， getTime() ， getTimeInMillis() ， add() ，或roll()而成。 因此，多次调用set()不会触发多个不必要的计算。 由于使用set()更改日历字段，其他日历字段也可能会更改，具体取决于日历字段，日历字段值和日历系统。 另外，在重新计算日历字段后， get(f)会通过调用set方法返回value 。 具体细节由具体的日历类确定。

    例如 ：考虑一个GregorianCalendar最初被设置为1999调用8月31日set(Calendar.MONTH, Calendar.SEPTEMBER)台日至九月31日，1999年这是一个临时的内部表示解析为1999年10月1，如果getTime() ，然后调用。 但是，在拨打set(Calendar.DAY_OF_MONTH, 30)之前拨打getTime()将日期设置为1999年9月30日，因为在set()本身之后没有重新计算。

    add(f, delta)增加delta现场f 。 这相当于调用set(f, get(f) + delta)进行了两次调整：

    Add rule 1. The value of field f after the call minus the value of field f before the call is delta, modulo any overflow that has occurred in field f. Overflow occurs when a field value exceeds its range and, as a result, the next larger field is incremented or decremented and the field value is adjusted back into its range.

    Add rule 2. If a smaller field is expected to be invariant, but it is impossible for it to be equal to its prior value because of changes in its minimum or maximum after field f is changed or other constraints, such as time zone offset changes, then its value is adjusted to be as close as possible to its expected value. A smaller field represents a smaller unit of time. HOUR is a smaller field than DAY_OF_MONTH. No adjustment is made to smaller fields that are not expected to be invariant. The calendar system determines what fields are expected to be invariant.

    此外，与set()不同， add()强制立即重新计算日历的毫秒数和所有字段。

    例如 ：考虑一个GregorianCalendar最初被设置为1999调用8月31日， add(Calendar.MONTH, 13)套日历9月30日，2000年添加规则1套MONTH场至九月，因为加入13个月月给明年九月。 由于DAY_OF_MONTH不能在9月31日在GregorianCalendar ， 添加规则2将DAY_OF_MONTH设置为30，最接近的可能值。 虽然它是一个较小的领域， DAY_OF_WEEK没有被规则2调整，因为预期在GregorianCalendar的月份变化时会改变。

    roll(f, delta)增加delta现场f ，不更改更大的字段。 这相当于调用add(f, delta)进行以下调整：

    Roll rule. Larger fields are unchanged after the call. A larger field represents a larger unit of time. DAY_OF_MONTH is a larger field than HOUR.

    示例 ：参见GregorianCalendar.roll(int, int) 。

    使用模式 。 为了激发add()和roll()的行为，请考虑一个用户界面组件，其中包含月，日和年的增量和减量按钮，以及底层的GregorianCalendar 。 如果接口读取1999年1月31日，用户按月增量按钮，应该读什么？ 如果基础实施使用set() ，则可能会在1999年3月3日发布。更好的结果是1999年2月28日。此外，如果用户再次按下月增加按钮，应该在1999年3月31日，而不是1999年3月28日通过保存原始日期并使用add()或roll() ，取决于是否影响较大的字段，用户界面可以像大多数用户一样直观地期待。

    从以下版本开始：
    1.1
    另请参见：
    System.currentTimeMillis() ， Date ， GregorianCalendar ， TimeZone ， DateFormat ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Calendar.Builder
      Calendar.Builder用于从各种日期时间参数创建 Calendar 。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ALL_STYLES
      一个表示 getDisplayNames的样式说明符，表示所有样式的名称，如“1月”和“1月”。
      static int AM
      AM_PM字段的值表示从午夜到中午之前的一天的时间。
      static int AM_PM
      对于现场数 get和 set指示是否 HOUR是前或中午之后。
      static int APRIL
      MONTH字段的价值指示了公历和朱利安日历中的第四个月。
      protected boolean areFieldsSet
      如果 fields[]与当前设置的时间同步， fields[]真。
      static int AUGUST
      MONTH字段的值表示公历和朱利安日历中的第八个月。
      static int DATE
      get和 set字段编号，表示该月的日期。
      static int DAY_OF_MONTH
      get字段编号和 set表示本月的日期。
      static int DAY_OF_WEEK
      get字段编号和 set表示星期几。
      static int DAY_OF_WEEK_IN_MONTH
      get和 set字段编号，表示当月的星期几的序数。
      static int DAY_OF_YEAR
      get字段编号和 set表示 set的日数。
      static int DECEMBER
      MONTH字段的值表示公历和朱利安日历中的第十二个月。
      static int DST_OFFSET
      get字段编号和 set表示夏令时偏移量（以毫秒为单位）。
      static int ERA
      get字段号和 set表示时代，例如，在儒略历中的AD或BC。
      static int FEBRUARY
      MONTH字段的值表示今年第二个月在公历和朱利安日历。
      static int FIELD_COUNT
      由 get和 set识别的不同字段的数量。
      protected int[] fields
      该日历的当前设置时间的日历字段值。
      static int FRIDAY
      DAY_OF_WEEK字段的值表示周五。
      static int HOUR
      get和 set字段编号，表示上午或下午的小时。
      static int HOUR_OF_DAY
      get和 set字段编号，表示当天的小时数。
      protected boolean[] isSet
      说明是否设置日历的指定日历字段的标志。
      protected boolean isTimeSet
      如果那么那么 time的值是有效的。
      static int JANUARY
      MONTH领域的价值指示了公历和朱利安日历中的一年中的第一个月。
      static int JULY
      MONTH领域的价值指示了公历和朱利安日历中的第七个月。
      static int JUNE
      MONTH字段的值代表了公历和朱利安日历中的第六个月。
      static int LONG
      一个样式说明符 getDisplayName和 getDisplayNames相当于 LONG_FORMAT 。
      static int LONG_FORMAT
      getDisplayName和 getDisplayNames的样式说明 符 ，表示用于格式的长名称。
      static int LONG_STANDALONE
      一个表示 getDisplayName和 getDisplayNames的样式说明 符 ，表示一个长名独立使用，如月份名称作为日历头。
      static int MARCH
      MONTH字段的价值，表示今年第三个月在公历和朱利安日历。
      static int MAY
      MONTH字段的价值显示了公历和朱利安日历中的第五个月。
      static int MILLISECOND
      get字段编号和 set表示秒内的毫秒数。
      static int MINUTE
      get字段编号和 set表示小时内的分钟。
      static int MONDAY
      DAY_OF_WEEK字段的值表示星期一。
      static int MONTH
      get和 set字段号表示该月。
      static int NARROW_FORMAT
      一个用于 getDisplayName和 getDisplayNames的样式说明 符 ，表示用于格式的窄名称。
      static int NARROW_STANDALONE
      getDisplayName和 getDisplayNames的样式说明符独立地表示一个狭义的名称。
      static int NOVEMBER
      MONTH字段的值代表了公历和朱利安日历中的第十一个月。
      static int OCTOBER
      MONTH字段的价值表示在公历和朱利安日历中的一年中的第十个月。
      static int PM
      AM_PM字段的值表示从中午到午夜之前的一天中的一段时间。
      static int SATURDAY
      DAY_OF_WEEK字段的值表示星期六。
      static int SECOND
      get字段编号和 set表示分钟内的第二个。
      static int SEPTEMBER
      MONTH字段的值代表了公历和朱利安日历中的第九个月。
      static int SHORT
      一个样式说明符 getDisplayName和 getDisplayNames相当于 SHORT_FORMAT 。
      static int SHORT_FORMAT
      getDisplayName和 getDisplayNames的样式说明 符 ，表示用于格式的短名称。
      static int SHORT_STANDALONE
      一个 getDisplayName和 getDisplayNames的样式说明 符 ，表示一个简单的名称，例如一个月缩写作为日历头。
      static int SUNDAY
      DAY_OF_WEEK字段的值表示星期天。
      static int THURSDAY
      DAY_OF_WEEK字段的值表示周四。
      protected long time
      这个日历的当前设定时间，以1970年1月1日，格林尼治标准时间0:00:00之后的毫秒表示。
      static int TUESDAY
      DAY_OF_WEEK字段的值表示周二。
      static int UNDECIMBER
      MONTH字段的值表示一年的第十三个月。
      static int WEDNESDAY
      价值 DAY_OF_WEEK字段表示周三。
      static int WEEK_OF_MONTH
      get字段编号和 set表示 set的周数。
      static int WEEK_OF_YEAR
      get字段编号和 set表示 set的周数。
      static int YEAR
      get字段编号和 set表示年份。
      static int ZONE_OFFSET
      get字段编号和 set表示以毫秒为单位的GMT的原始偏移量。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Calendar​()
      构造具有默认时区和默认 FORMAT语言环境的日历。
      protected Calendar​(TimeZone zone, Locale aLocale)
      构造具有指定时区和区域设置的日历。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void add​(int field, int amount)
      根据日历的规则，将指定的时间量添加或减去给定的日历字段。
      boolean after​(Object when)
      返回 Calendar是否表示在指定的 Object表示的时间之后的时间。
      boolean before​(Object when)
      返回此 Calendar是否表示由指定的 Object表示的时间之前的时间。
      void clear​()
      将所有的日历字段值和时间值（毫秒从偏移 Epoch如此） Calendar不确定。
      void clear​(int field)
      设置给定日历字段值和时间值（毫秒从偏移 Epoch如此） Calendar不确定。
      Object clone​()
      创建并返回此对象的副本。
      int compareTo​(Calendar anotherCalendar)
      比较由两个 Calendar对象表示的时间值（ Epoch的毫秒偏移量）。
      protected void complete​()
      填写日历字段中的任何未设置的字段。
      protected abstract void computeFields​()
      当前毫秒时间值转换为 time的日历字段值 fields[] 。
      protected abstract void computeTime​()
      将 fields[]中的当前日历字段值 转换为毫秒时间值 time 。
      boolean equals​(Object obj)
      将此 Calendar与指定的 Object 。
      int get​(int field)
      返回给定日历字段的值。
      int getActualMaximum​(int field)
      给定此 Calendar的时间值，返回指定日历字段可能具有的 Calendar 。
      int getActualMinimum​(int field)
      给定此 Calendar的时间值，返回指定日历字段可能具有的 Calendar 。
      static Set<String> getAvailableCalendarTypes​()
      返回一个不可修改的 Set其中包含 Calendar在运行时环境中支持的所有日历类型。
      static Locale[] getAvailableLocales​()
      返回一个所有语言环境的数组，该类的 getInstance方法可以返回本地化实例。
      String getCalendarType​()
      返回此 Calendar的日历类型。
      String getDisplayName​(int field, int style, Locale locale)
      返回给定的 style和 locale中的日历 field的字符串表示。
      Map<String,Integer> getDisplayNames​(int field, int style, Locale locale)
      返回一个 Map其中包含给定的 style和 locale中的日历 field所有名称及其对应的字段值。
      int getFirstDayOfWeek​()
      得到一周的第一天是什么 例如， SUNDAY在美国， MONDAY在法国。
      abstract int getGreatestMinimum​(int field)
      返回此 Calendar实例的给定日历字段的最高最小值。
      static Calendar getInstance​()
      使用默认时区和区域设置获取日历。
      static Calendar getInstance​(Locale aLocale)
      使用默认时区和指定的区域设置获取日历。
      static Calendar getInstance​(TimeZone zone)
      使用指定的时区和默认语言环境获取日历。
      static Calendar getInstance​(TimeZone zone, Locale aLocale)
      获取具有指定时区和区域设置的日历。
      abstract int getLeastMaximum​(int field)
      返回此 Calendar实例的给定日历字段的最低最大值。
      abstract int getMaximum​(int field)
      返回此 Calendar实例的给定日历字段的 Calendar 。
      int getMinimalDaysInFirstWeek​()
      获得一年中第一周所需的最低限度的日子; 例如，如果第一周被定义为包含一年中的第一个月的第一个星期，则此方法返回1。
      abstract int getMinimum​(int field)
      返回此 Calendar实例的给定日历字段的 Calendar 。
      Date getTime​()
      返回表示 Calendar的时间值（与 Epoch的毫秒偏移量）的 Date对象。
      long getTimeInMillis​()
      以毫秒为单位返回此日历的时间值。
      TimeZone getTimeZone​()
      获取时区。
      int getWeeksInWeekYear​()
      返回此 Calendar代表的星期内的星期 Calendar 。
      int getWeekYear​()
      返回此 Calendar代表的 Calendar 。
      int hashCode​()
      返回此日历的哈希码。
      protected int internalGet​(int field)
      返回给定日历字段的值。
      boolean isLenient​()
      告诉日期/时间的解释是否宽松。
      boolean isSet​(int field)
      确定给定的日历字段是否具有值集，包括通过 get方法调用触发的内部字段计算设置的值的情况。
      boolean isWeekDateSupported​()
      是否返回 Calendar是否支持星期。
      abstract void roll​(int field, boolean up)
      在给定时间字段上添加或减少单个时间单位，而不改变较大的字段。
      void roll​(int field, int amount)
      将指定（签名）金额添加到指定的日历字段，而不更改较大的字段。
      void set​(int field, int value)
      将给定的日历字段设置为给定的值。
      void set​(int year, int month, int date)
      设置日历字段的值 YEAR ， MONTH ，并 DAY_OF_MONTH 。
      void set​(int year, int month, int date, int hourOfDay, int minute)
      设置日历字段的值 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR_OF_DAY ，并 MINUTE 。
      void set​(int year, int month, int date, int hourOfDay, int minute, int second)
      设置字段中的值 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR_OF_DAY ， MINUTE ，并 SECOND 。
      void setFirstDayOfWeek​(int value)
      设置一周的第一天是什么？ 例如， SUNDAY在美国， MONDAY在法国。
      void setLenient​(boolean lenient)
      指定日期/时间解释是否宽松。
      void setMinimalDaysInFirstWeek​(int value)
      设定一年中第一个星期所需的最短时间是多少？ 例如，如果第一周被定义为包含一年中第一个月的第一天的第一周，请调用此值为1的方法。
      void setTime​(Date date)
      使用给定的 Date设置此日历的时间。
      void setTimeInMillis​(long millis)
      从给定的长值设置此日历的当前时间。
      void setTimeZone​(TimeZone value)
      以给定的时区值设置时区。
      void setWeekDate​(int weekYear, int weekOfYear, int dayOfWeek)
      设置这个 Calendar的日期与给定的日期说明符 - 周年，年周和星期几。
      Instant toInstant​()
      将此对象转换为Instant 。
      String toString​()
      返回此日历的字符串表示形式。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ERA

        public static final int ERA
        get和set字段号表示时代，例如，在儒略历中的AD或BC。 这是一个日历特定的值 请参阅子类文档。
        另请参见：
        GregorianCalendar.AD ， GregorianCalendar.BC ， Constant Field Values

      • YEAR

        public static final int YEAR
        现场号码为get和set表示年度。 这是一个日历特定的值 请参阅子类文档。
        另请参见：
        Constant Field Values

      • MONTH

        public static final int MONTH
        get字段编号和set表示月份。 这是一个特定于日历的值。 今年第一个月在公历和朱利安日历是JANUARY ，这是0; 最后一个取决于一年中的月数。
        另请参见：
        JANUARY ， FEBRUARY ， MARCH ， APRIL ， MAY ， JUNE ， JULY ， AUGUST ， SEPTEMBER ， OCTOBER ， NOVEMBER ， DECEMBER ， UNDECIMBER ， Constant Field Values

      • WEEK_OF_YEAR

        public static final int WEEK_OF_YEAR
        get和set字段编号， get set的周数。 由getFirstDayOfWeek()和getMinimalDaysInFirstWeek()定义的一年中的第一周具有值1.子类在一年的第一周之前的几天内定义了WEEK_OF_YEAR的值。
        另请参见：
        getFirstDayOfWeek() ， getMinimalDaysInFirstWeek() ， Constant Field Values

      • WEEK_OF_MONTH

        public static final int WEEK_OF_MONTH
        get字段编号和set表示set的周数。 本月的第一个星期，由getFirstDayOfWeek()和getMinimalDaysInFirstWeek()定义，具有值1.子类在本月的第一周之前的天数定义了WEEK_OF_MONTH的值。
        另请参见：
        getFirstDayOfWeek() ， getMinimalDaysInFirstWeek() ， Constant Field Values

      • DATE

        public static final int DATE
        get字段编号和set表示本月的日期。 这是DAY_OF_MONTH的同义词。 本月的第一天价值为1。
        另请参见：
        DAY_OF_MONTH ， Constant Field Values

      • DAY_OF_MONTH

        public static final int DAY_OF_MONTH
        get字段编号和set表示本月的日期。 这是DATE的同义词。 本月的第一天价值为1。
        另请参见：
        DATE ， Constant Field Values

      • DAY_OF_YEAR

        public static final int DAY_OF_YEAR
        get字段编号和set表示set的日数。 今年第一天的价值为1。
        另请参见：
        Constant Field Values

      • DAY_OF_WEEK

        public static final int DAY_OF_WEEK
        get和set字段编号，表示星期几。 此字段值SUNDAY ， MONDAY ， TUESDAY ， WEDNESDAY ， THURSDAY ， FRIDAY ，并SATURDAY 。
        另请参见：
        SUNDAY ， MONDAY ， TUESDAY ， WEDNESDAY ， THURSDAY ， FRIDAY ， SATURDAY ， Constant Field Values

      • DAY_OF_WEEK_IN_MONTH

        public static final int DAY_OF_WEEK_IN_MONTH
        get和set字段编号，表示当月的星期几的序号。 与DAY_OF_WEEK字段一起，它独特地指定了一个月内的一天。 不像WEEK_OF_MONTH和WEEK_OF_YEAR ，该字段的值并不取决于getFirstDayOfWeek()或者getMinimalDaysInFirstWeek() 。 DAY_OF_MONTH 1通过7总是对应DAY_OF_WEEK_IN_MONTH 1 ; 8至14对应DAY_OF_WEEK_IN_MONTH 2 ，依此类推。 DAY_OF_WEEK_IN_MONTH 0表示前一周DAY_OF_WEEK_IN_MONTH 1 。 负值从月底开始计数，所以一个月的最后一个星期日被指定为DAY_OF_WEEK = SUNDAY, DAY_OF_WEEK_IN_MONTH = -1 。 因为负数值倒计时，所以在一个月内通常会与正值不一致。 例如，如果一个月有31天， DAY_OF_WEEK_IN_MONTH -1将重叠DAY_OF_WEEK_IN_MONTH 5 ，结束4 。
        另请参见：
        DAY_OF_WEEK ， WEEK_OF_MONTH ， Constant Field Values

      • AM_PM

        public static final int AM_PM
        get字段编号和set说明HOUR是在中午还是之后。 例如，10：04：15.250 PM， AM_PM是PM 。
        另请参见：
        AM ， PM ， HOUR ， Constant Field Values

      • HOUR

        public static final int HOUR
        get字段编号和set表示上午或下午的小时。 HOUR用于12小时钟（0 - 11）。 中午和午夜由0而不是12表示。例如，10：04：15.250 PM， HOUR是10。
        另请参见：
        AM_PM ， HOUR_OF_DAY ， Constant Field Values

      • HOUR_OF_DAY

        public static final int HOUR_OF_DAY
        get字段编号和set表示当天的小时数。 HOUR_OF_DAY用于24小时制。 例如：10：04：15.250 PM， HOUR_OF_DAY是22。
        另请参见：
        HOUR ， Constant Field Values

      • MINUTE

        public static final int MINUTE
        get和set字段编号表示一小时内的分钟。 例如，10：04：15.250 PM， MINUTE是4。
        另请参见：
        Constant Field Values

      • SECOND

        public static final int SECOND
        get字段编号和set表示分钟内的第二个。 例如，10：04：15.250 PM， SECOND是15。
        另请参见：
        Constant Field Values

      • MILLISECOND

        public static final int MILLISECOND
        get字段编号和set表示秒内的毫秒数。 例如：10：04：15.250 PM， MILLISECOND是250。
        另请参见：
        Constant Field Values

      • ZONE_OFFSET

        public static final int ZONE_OFFSET
        get字段编号和set表示以毫秒为单位的GMT的原始偏移量。

        如果TimeZone实现子类支持历史GMT偏移量更改，则此字段反映该Calendar的时区的正确GMT偏移值。

        另请参见：
        Constant Field Values

      • DST_OFFSET

        public static final int DST_OFFSET
        get字段编号和set表示夏令时偏移量（以毫秒为单位）。

        如果TimeZone实施子类支持历史夏令时计划更改，则此字段反映该Calendar的时区正确的夏令时偏移值。

        另请参见：
        Constant Field Values

      • FIELD_COUNT

        public static final int FIELD_COUNT
        由get和set识别的不同字段的数量。 字段编号范围从0..FIELD_COUNT-1 。
        另请参见：
        Constant Field Values

      • SUNDAY

        public static final int SUNDAY
        DAY_OF_WEEK字段的值表示星期日。
        另请参见：
        Constant Field Values

      • MONDAY

        public static final int MONDAY
        DAY_OF_WEEK字段的值指示星期一。
        另请参见：
        Constant Field Values

      • TUESDAY

        public static final int TUESDAY
        DAY_OF_WEEK字段的值表示周二。
        另请参见：
        Constant Field Values

      • WEDNESDAY

        public static final int WEDNESDAY
        DAY_OF_WEEK字段的值表示周三。
        另请参见：
        Constant Field Values

      • THURSDAY

        public static final int THURSDAY
        DAY_OF_WEEK字段的值表示周四。
        另请参见：
        Constant Field Values

      • FRIDAY

        public static final int FRIDAY
        DAY_OF_WEEK字段的值表示周五。
        另请参见：
        Constant Field Values

      • SATURDAY

        public static final int SATURDAY
        DAY_OF_WEEK字段的值表示星期六。
        另请参见：
        Constant Field Values

      • JANUARY

        public static final int JANUARY
        MONTH字段的值代表了公历和朱利安日历中的一年中的第一个月。
        另请参见：
        Constant Field Values

      • FEBRUARY

        public static final int FEBRUARY
        MONTH字段的值代表了今年第二个月在格里高利和朱利安的日历。
        另请参见：
        Constant Field Values

      • MARCH

        public static final int MARCH
        MONTH字段的值表示公历和朱利安日历中的第三个月。
        另请参见：
        Constant Field Values

      • APRIL

        public static final int APRIL
        MONTH领域的价值指示了公历和朱利安日历中的第四个月。
        另请参见：
        Constant Field Values

      • MAY

        public static final int MAY
        MONTH字段的值代表了公历和朱利安日历中的第五个月。
        另请参见：
        Constant Field Values

      • JUNE

        public static final int JUNE
        MONTH字段的值代表了公历和朱利安日历中的第六个月。
        另请参见：
        Constant Field Values

      • JULY

        public static final int JULY
        MONTH字段的价值，表示今年第七个月在公历和朱利安日历。
        另请参见：
        Constant Field Values

      • AUGUST

        public static final int AUGUST
        MONTH领域的价值指示了公历和朱利安日历中的第八个月。
        另请参见：
        Constant Field Values

      • SEPTEMBER

        public static final int SEPTEMBER
        MONTH领域的价值指示了公历和朱利安日历中的第九个月。
        另请参见：
        Constant Field Values

      • OCTOBER

        public static final int OCTOBER
        MONTH字段的值代表了公历和朱利安日历中的第10个月。
        另请参见：
        Constant Field Values

      • NOVEMBER

        public static final int NOVEMBER
        MONTH字段的值代表了公历和朱利安日历中的第十一个月。
        另请参见：
        Constant Field Values

      • DECEMBER

        public static final int DECEMBER
        MONTH字段的值表示公历和朱利安日历中的第十二个月。
        另请参见：
        Constant Field Values

      • UNDECIMBER

        public static final int UNDECIMBER
        MONTH字段的值表示一年的第十三个月。 虽然GregorianCalendar不使用这个值，但是月历也是这样。
        另请参见：
        Constant Field Values

      • AM

        public static final int AM
        AM_PM字段的值表示从午夜到中午之前的一天的时间。
        另请参见：
        Constant Field Values

      • PM

        public static final int PM
        AM_PM字段的值表示从中午到午夜之前的一天中的一段时间。
        另请参见：
        Constant Field Values

      • ALL_STYLES

        public static final int ALL_STYLES
        一个表示 getDisplayNames的样式说明符，表示所有样式的名称，如“1月”和“1月”。
        从以下版本开始：
        1.6
        另请参见：
        SHORT_FORMAT ， LONG_FORMAT ， SHORT_STANDALONE ， LONG_STANDALONE ， SHORT ， LONG ， Constant Field Values

      • SHORT

        public static final int SHORT
        一个样式说明符 getDisplayName和 getDisplayNames相当于 SHORT_FORMAT 。
        从以下版本开始：
        1.6
        另请参见：
        SHORT_STANDALONE ， LONG ， Constant Field Values

      • LONG

        public static final int LONG
        一个样式说明符 getDisplayName和 getDisplayNames相当于 LONG_FORMAT 。
        从以下版本开始：
        1.6
        另请参见：
        LONG_STANDALONE ， SHORT ， Constant Field Values

      • NARROW_FORMAT

        public static final int NARROW_FORMAT
        getDisplayName和getDisplayNames的样式说明符 ，表示用于格式的窄名称。 狭义名称通常是单个字符串，例如星期一的“M”。
        从以下版本开始：
        1.8
        另请参见：
        NARROW_STANDALONE ， SHORT_FORMAT ， LONG_FORMAT ， Constant Field Values

      • NARROW_STANDALONE

        public static final int NARROW_STANDALONE
        getDisplayName和getDisplayNames的样式说明符独立地表示一个狭义的名称。 狭义名称通常是单个字符串，例如星期一的“M”。
        从以下版本开始：
        1.8
        另请参见：
        NARROW_FORMAT ， SHORT_STANDALONE ， LONG_STANDALONE ， Constant Field Values

      • SHORT_FORMAT

        public static final int SHORT_FORMAT
        getDisplayName和 getDisplayNames的样式说明 符 ，表示用于格式的短名称。
        从以下版本开始：
        1.8
        另请参见：
        SHORT_STANDALONE ， LONG_FORMAT ， LONG_STANDALONE ， Constant Field Values

      • LONG_FORMAT

        public static final int LONG_FORMAT
        getDisplayName和 getDisplayNames的样式说明 符 ，表示用于格式的长名称。
        从以下版本开始：
        1.8
        另请参见：
        LONG_STANDALONE ， SHORT_FORMAT ， SHORT_STANDALONE ， Constant Field Values

      • SHORT_STANDALONE

        public static final int SHORT_STANDALONE
        一个 getDisplayName和 getDisplayNames的样式说明 符 ，表示一个简单的名称，例如一个月缩写作为日历头。
        从以下版本开始：
        1.8
        另请参见：
        SHORT_FORMAT ， LONG_FORMAT ， LONG_STANDALONE ， Constant Field Values

      • LONG_STANDALONE

        public static final int LONG_STANDALONE
        一个表示 getDisplayName和 getDisplayNames的样式说明 符 ，表示一个独立使用的长名称，例如月份名称作为日历头。
        从以下版本开始：
        1.8
        另请参见：
        LONG_FORMAT ， SHORT_FORMAT ， SHORT_STANDALONE ， Constant Field Values

      • fields

        protected int[] fields
        该日历的当前设置时间的日历字段值。 这是一个FIELD_COUNT整数的数组，索引值为ERA到DST_OFFSET 。

      • isSet

        protected boolean[] isSet
        说明是否设置日历的指定日历字段的标志。 一个新对象没有设置字段。 在首次调用生成字段的方法之后，它们都将保持置位。 这是一个FIELD_COUNT布尔阵列，索引值为ERA到DST_OFFSET 。

      • time

        protected long time
        这个日历的当前设定时间，以1970年1月1日，格林尼治标准时间0:00:00之后的毫秒表示。
        另请参见：
        isTimeSet

      • isTimeSet

        protected boolean isTimeSet
        如果那么time的值是有效的。 通过更改field[]的项目使时间无效。
        另请参见：
        time

      • areFieldsSet

        protected boolean areFieldsSet
        如果fields[]与当前设置的时间同步， fields[]真。 如果为false，则下一次尝试获取字段的值将强制从当前值time重新计算所有字段。

    • 构造方法详细信息

      • Calendar

        protected Calendar​()
        构造具有默认时区和默认 FORMAT语言环境的日历。
        另请参见：
        TimeZone.getDefault()

      • Calendar

        protected Calendar​(TimeZone zone,
                   Locale aLocale)
        构造具有指定时区和区域设置的日历。
        参数
        zone - 使用的时区
        aLocale - 周数据的区域设置

    • 方法详细信息

      • getInstance

        public static Calendar getInstance​()
        使用默认时区和区域设置获取日历。 返回的Calendar是基于默认时区的当前时间，默认为FORMAT区域设置。
        结果
        日历。

      • getInstance

        public static Calendar getInstance​(TimeZone zone)
        使用指定的时区和默认语言环境获取日历。 Calendar返回的是基于给定时区的当前时间，默认为FORMAT 。
        参数
        zone - 使用的时区
        结果
        日历。

      • getInstance

        public static Calendar getInstance​(Locale aLocale)
        使用默认时区和指定的区域设置获取日历。 返回的Calendar是基于指定区域设置的默认时区中的当前时间。
        参数
        aLocale - 周数据的区域设置
        结果
        日历。

      • getInstance

        public static Calendar getInstance​(TimeZone zone,
                                   Locale aLocale)
        获取具有指定时区和区域设置的日历。 返回的Calendar是基于给定时区的当前时间与给定的区域设置。
        参数
        zone - 使用的时区
        aLocale - 周数据的区域设置
        结果
        日历。

      • getAvailableLocales

        public static Locale[] getAvailableLocales​()
        返回所有语言环境的数组，该类的getInstance方法可以返回本地化实例。 返回的数组必须至少包含一个等于Locale.US的Locale实例。
        结果
        一组可用本地化 Calendar实例的区域设置。

      • computeTime

        protected abstract void computeTime​()
        将 fields[]中的当前日历字段值 转换为毫秒时间值 time 。
        另请参见：
        complete() ， computeFields()

      • computeFields

        protected abstract void computeFields​()
        当前毫秒时间值转换为time的日历字段值fields[] 。 这样，您可以将日历字段值与为日历设置的新时间进行同步。 时间不重新计算; 重新计算时间，然后字段，调用complete()方法。
        另请参见：
        computeTime()

      • getTime

        public final Date getTime​()
        返回表示 Calendar的时间值（与 Epoch毫秒偏移量）的 Date对象。
        结果
        一个表示时间值的 Date 。
        另请参见：
        setTime(Date) ， getTimeInMillis()

      • setTime

        public final void setTime​(Date date)
        使用给定的Date设置此日历的时间。

        注意：调用setTime()与Date(Long.MAX_VALUE)或者Date(Long.MIN_VALUE)可能产生不正确的字段值get() 。

        参数
        date - 给定的日期。
        另请参见：
        getTime() ， setTimeInMillis(long)

      • getTimeInMillis

        public long getTimeInMillis​()
        以毫秒为单位返回此日历的时间值。
        结果
        当前时间为UTC的毫秒数。
        另请参见：
        getTime() ， setTimeInMillis(long)

      • setTimeInMillis

        public void setTimeInMillis​(long millis)
        从给定的长值设置此日历的当前时间。
        参数
        millis - 从时代以UTC为单位的新时间。
        另请参见：
        setTime(Date) ， getTimeInMillis()

      • get

        public int get​(int field)
        返回给定日历字段的值。 在宽大模式下，所有日历字段都被归一化。 在非宽泛模式下，所有日历字段都被验证，如果任何日历字段具有超出范围的值，该方法将抛出异常。 归一化和验证由complete()方法处理，该过程是与日历系统相关的。
        参数
        field - 给定的日历字段。
        结果
        给定日历字段的值。
        异常
        ArrayIndexOutOfBoundsException - 如果指定的字段超出范围（ field < 0 || field >= FIELD_COUNT ）。
        另请参见：
        set(int,int) ， complete()

      • internalGet

        protected final int internalGet​(int field)
        返回给定日历字段的值。 该方法不涉及字段值的归一化或验证。
        参数
        field - 给定的日历字段。
        结果
        给定日历字段的值。
        另请参见：
        get(int)

      • set

        public void set​(int field,
                int value)
        将给定的日历字段设置为给定的值。 该方法不会解释该值，无论宽恕方式如何。
        参数
        field - 给定的日历字段。
        value - 为给定日历字段设置的值。
        异常
        ArrayIndexOutOfBoundsException - 如果指定的字段超出范围（ field < 0 || field >= FIELD_COUNT ）。 在非宽松模式下。
        另请参见：
        set(int,int,int) ，
set(int,int,int,int,int) ，
set(int,int,int,int,int,int) ，
get(int)

      • set

        public final void set​(int year,
                      int month,
                      int date)
        设置日历字段的值YEAR ， MONTH ，并DAY_OF_MONTH 。 其他日历字段的以前值被保留。 如果不需要， 请先拨打clear() 。
        参数
        year - 用于设置 YEAR日历字段的值。
        month - 用于设置MONTH日历字段的值。 月值为0。 例如，1月份为0。
        date - 用于设置 DAY_OF_MONTH日历字段的值。
        另请参见：
        set(int,int) ，
set(int,int,int,int,int) ，
set(int,int,int,int,int,int)

      • set

        public final void set​(int year,
                      int month,
                      int date,
                      int hourOfDay,
                      int minute)
        设置日历字段的值YEAR ， MONTH ， DAY_OF_MONTH ， HOUR_OF_DAY ，并MINUTE 。 保留其他字段的以前的值。 如果不希望， 请先拨打clear() 。
        参数
        year - 用于设置 YEAR日历字段的值。
        month - 用于设置MONTH日历字段的值。 月值为0。 例如，1月份为0。
        date - 用于设置 DAY_OF_MONTH日历字段的值。
        hourOfDay - 用于设置 HOUR_OF_DAY日历字段的值。
        minute - 用于设置 MINUTE日历字段的值。
        另请参见：
        set(int,int) ，
set(int,int,int) ，
set(int,int,int,int,int,int)

      • set

        public final void set​(int year,
                      int month,
                      int date,
                      int hourOfDay,
                      int minute,
                      int second)
        设置字段中的值YEAR ， MONTH ， DAY_OF_MONTH ， HOUR_OF_DAY ， MINUTE ，并SECOND 。 保留其他字段的以前的值。 如果不希望， 请先拨打clear() 。
        参数
        year - 用于设置 YEAR日历字段的值。
        month - 用于设置MONTH日历字段的值。 月值为0。 例如，1月份为0。
        date - 用于设置 DAY_OF_MONTH日历字段的值。
        hourOfDay - 用于设置 HOUR_OF_DAY日历字段的值。
        minute - 用于设置 MINUTE日历字段的值。
        second - 用于设置 SECOND日历字段的值。
        另请参见：
        set(int,int) ，
set(int,int,int) ，
set(int,int,int,int,int)

      • clear

        public final void clear​()
        将所有的日历字段值和时间值（毫秒从偏移Epoch如此） Calendar不确定。 这意味着isSet()将为所有日历字段返回false ，并且日期和时间计算将会将这些字段视为未被设置。 Calendar实现类可以使用其特定的默认字段值进行日期/时间计算。 例如，如果YEAR字段值未定义，则GregorianCalendar使用1970。
        另请参见：
        clear(int)

      • clear

        public final void clear​(int field)
        设置给定的日历字段值和Calendar未定义的时间值（ Epoch的毫秒偏移量）。 这意味着isSet(field)将返回false ，日期和时间计算将会将该字段视为未被设置。 A Calendar实现类可以使用字段的特定默认值进行日期和时间计算。

        的HOUR_OF_DAY ， HOUR和AM_PM字段独立地处理，并且the resolution rule for the time of day被应用。 清除其中一个字段不会重置此Calendar的小时值。 使用set(Calendar.HOUR_OF_DAY, 0)重置小时值。

        参数
        field - 要清除的日历字段。
        另请参见：
        clear()

      • isSet

        public final boolean isSet​(int field)
        确定给定的日历字段是否具有值集，包括通过由 get方法调用触发的内部字段计算设置的值的情况。
        参数
        field - 要测试的日历字段
        结果
        true如果给定的日历字段有一个值设置; 否则为false 。

      • getDisplayName

        public String getDisplayName​(int field,
                             int style,
                             Locale locale)
        返回给定的style和locale中的日历field的字符串表示locale 。 如果不适用字符串表示，则返回null 。 如果字符串表示适用于给定的日历field此方法调用get(field)获取日历field值。

        例如，如果这个Calendar是GregorianCalendar ，其日期是2005-01-01，那么MONTH字段的字符串表示形式将是英文区域设置中的长形式的“1月”或短格式的“Jan”。 但是， DAY_OF_MONTH字段不能使用字符串表示形式，此方法将返回null 。

        默认实现支持其中的日历字段DateFormatSymbols在给定的名字locale 。

        参数
        field - 返回字符串表示形式的日历字段
        style - 应用于字符串表示形式的样式; 之一SHORT_FORMAT （ SHORT ）， SHORT_STANDALONE ， LONG_FORMAT （ LONG ）， LONG_STANDALONE ， NARROW_FORMAT ，或NARROW_STANDALONE 。
        locale - 字符串表示的区域设置（由 locale指定的任何日历类型都将被忽略）
        结果
        给定的 field在给定的 style字符串表示，或 null如果没有字符串表示是适用的。
        异常
        IllegalArgumentException - 如果 field或 style无效，或者如果此 Calendar不宽容，并且任何日历字段都有无效值
        NullPointerException - 如果 locale为空
        从以下版本开始：
        1.6

      • getDisplayNames

        public Map<String,Integer> getDisplayNames​(int field,
                                           int style,
                                           Locale locale)
        返回一个Map其中包含给定的style和locale中的日历field所有名称及其对应的字段值。 例如，如果这个Calendar是GregorianCalendar ，那么返回的地图将包含“Jan”到JANUARY ，“Feb”到FEBRUARY ，依此类推，在英文语言环境中的short样式中。

        由于使用单个字符（例如星期日和星期六的“S”），狭义名称可能不是唯一的。 在这种情况下，缩小的名称不包括在返回的Map 。

        可以考虑其他日历字段的值来确定一组显示名称。 例如，如果这个Calendar是月历日历系统，并且由YEAR字段给出的年值具有闰月，则此方法将返回包含闰月名称的月份名称，并将月份名称映射到其特定于该年份的值。

        默认实现支持包含在DateFormatSymbols中的显示名称。 例如，如果field为MONTH，而style为ALL_STYLES ，则此方法返回一个Map其中包含DateFormatSymbols.getShortMonths()和DateFormatSymbols.getMonths()返回的所有字符串。

        参数
        field - 显示名称返回的日历字段
        style - 应用于字符串表示形式的样式; 之一SHORT_FORMAT （ SHORT ）， SHORT_STANDALONE ， LONG_FORMAT （ LONG ）， LONG_STANDALONE ， NARROW_FORMAT ，或NARROW_STANDALONE
        locale - 显示名称的区域设置
        结果
        一个 Map包含在所有显示名称 style和 locale和它们的字段值，或 null ，如果没有显示名称为定义 field
        异常
        IllegalArgumentException - 如果 field或 style无效，或者如果此 Calendar不宽容，并且任何日历字段都有无效值
        NullPointerException - 如果 locale为空
        从以下版本开始：
        1.6

      • complete

        protected void complete​()
        填写日历字段中的任何未设置的字段。 首先，如果没有从日历字段值计算时间值（从Epoch的毫秒偏移量），则调用computeTime()方法。 然后，调用computeFields()方法来计算所有日历字段值。

      • getAvailableCalendarTypes

        public static Set<String> getAvailableCalendarTypes​()
        返回一个不可修改的Set包含运行时环境中Calendar支持的所有日历类型。 可用的日历类型可以用于Unicode locale extensions 。 返回的Set至少包含"gregory" 。 日历类型不包括别名，例如"gregorian" for "gregory" 。
        结果
        一个不可修改的 Set包含所有可用的日历类型
        从以下版本开始：
        1.8
        另请参见：
        getCalendarType() ，
Calendar.Builder.setCalendarType(String) ，
Locale.getUnicodeLocaleType(String)

      • getCalendarType

        public String getCalendarType​()
        返回此Calendar的日历类型。 日历类型由Unicode区域设置数据标记语言（LDML）规范定义。

        此方法的默认实现返回此Calendar实例的类名。 任何实现LDML定义的日历系统的子类都应该覆盖此方法以返回适当的日历类型。

        结果
        LDML定义的日历类型或此 Calendar实例的类名称
        从以下版本开始：
        1.8
        另请参见：
        Locale extensions ， Locale.Builder.setLocale(Locale) ， Locale.Builder.setUnicodeLocaleKeyword(String, String)

      • equals

        public boolean equals​(Object obj)
        将此Calendar与指定的Object 。 结果是true当且仅当参数是同一个日历系统的Calendar对象，该对象表示与此对象相同的Calendar参数的相同时间值（与Epoch的毫秒偏移量）。

        的Calendar参数是由表示的值isLenient ， getFirstDayOfWeek ， getMinimalDaysInFirstWeek和getTimeZone方法。 如果两个Calendar之间的参数有差异，则此方法返回false 。

        使用compareTo方法只比较时间值。

        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果这个对象等于obj ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此日历的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        从以下版本开始：
        1.2
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • before

        public boolean before​(Object when)
        返回这个Calendar是否代表指定的Object表示的时间之前的时间。 此方法相当于：
           compareTo(when) < 0
        当且仅当when为Calendar实例时。 否则，该方法返回false 。
        参数
        when - 要比较的 Object
        结果
        true ，如果此时Calendar是由下式表示的时间之前when ; 否则为false 。
        另请参见：
        compareTo(Calendar)

      • after

        public boolean after​(Object when)
        返回Calendar是否表示在指定的Object表示的时间之后的时间。 此方法相当于：
           compareTo(when) > 0
        当且仅当when为Calendar实例时。 否则，该方法返回false 。
        参数
        when - 要比较的 Object
        结果
        true如果这个Calendar的时间是在when表示的时间之后; 否则为false 。
        另请参见：
        compareTo(Calendar)

      • compareTo

        public int compareTo​(Calendar anotherCalendar)
        比较两个 Calendar对象所代表的时间值（ Epoch的毫秒偏移量）。
        Specified by:
        compareTo在接口 Comparable<Calendar>
        参数
        anotherCalendar - 要比较的 Calendar 。
        结果
        值0如果由所述参数表示的时间等于由此表示的时间Calendar ; 一个值小于0如果这个Calendar的时间在参数表示的时间之前; 如果此Calendar的时间在参数表示的时间之后，则值大于0 。
        异常
        NullPointerException - 如果指定的 Calendar是 null 。
        IllegalArgumentException - 如果由于任何无效日历值而无法获取指定的 Calendar对象的时间值。
        从以下版本开始：
        1.5

      • add

        public abstract void add​(int field,
                         int amount)
        根据日历的规则，将指定的时间量添加或减去给定的日历字段。 例如，要从当前日历的时间减去5天，您可以通过调用以下方法来实现：

        add(Calendar.DAY_OF_MONTH, -5) 。

        参数
        field - 日历字段。
        amount - 要添加到该字段的日期或时间的数量。
        另请参见：
        roll(int,int) ， set(int,int)

      • roll

        public abstract void roll​(int field,
                          boolean up)
        在给定时间字段上添加或减少单个时间单位，而不改变较大的字段。 例如，要将当前日期推迟一天，您可以通过以下方式实现：

        roll（Calendar.DATE，true）。 当年滚动或Calendar.YEAR字段时，它将滚动年值在1和通过调用getMaximum(Calendar.YEAR)返回的值之间的范围。 当月滚动或Calendar.MONTH字段时，其他字段如date可能会冲突，需要更改。 例如，在01/31/96日期滚动的月份将在02/29/96。 在日历或Calendar.HOUR_OF_DAY字段中滚动时，它将滚动小时值，范围在0到23之间，这是从零开始的。

        参数
        field - 时间字段。
        up - 指示指定时间字段的值是要卷起还是滚动。 如果卷起，请使用true，否则为false。
        另请参见：
        add(int,int) ， set(int,int)

      • roll

        public void roll​(int field,
                 int amount)
        将指定（签名）金额添加到指定的日历字段，而不更改较大的字段。 负数意味着滚降。

        注意： Calendar上的默认实现只是重复调用一个单位的roll()版本。 这可能不总是做正确的事情。 例如，如果DAY_OF_MONTH字段为31，则滚动到二月将会将其设置为28.该功能的GregorianCalendar版本负责处理此问题。 其他子类也应该提供这个功能的覆盖，做正确的事情。

        参数
        field - 日历字段。
        amount - 加入日历的签名金额 field 。
        从以下版本开始：
        1.2
        另请参见：
        roll(int,boolean) ，
add(int,int) ，
set(int,int)

      • setTimeZone

        public void setTimeZone​(TimeZone value)
        以给定的时区值设置时区。
        参数
        value - 给定的时区。

      • getTimeZone

        public TimeZone getTimeZone​()
        获取时区。
        结果
        与该日历相关联的时区对象。

      • setLenient

        public void setLenient​(boolean lenient)
        指定日期/时间解释是否宽松。 宽松的解释，例如“1996年2月9日”，将被视为等同于1996年2月1日以后的第941天。以严格（不宽容的）解释，这样的日期会引起异常。 默认是宽松的。
        参数
        lenient - true如果宽大模式要打开; false如果要关闭。
        另请参见：
        isLenient() ， DateFormat.setLenient(boolean)

      • isLenient

        public boolean isLenient​()
        告诉日期/时间的解释是否宽松。
        结果
        true如果本日历的解释模式宽松; false否则。
        另请参见：
        setLenient(boolean)

      • setFirstDayOfWeek

        public void setFirstDayOfWeek​(int value)
        设置一周的第一天是什么？ 例如， SUNDAY在美国， MONDAY在法国。
        参数
        value - 一周中给定的第一天。
        另请参见：
        getFirstDayOfWeek() ， getMinimalDaysInFirstWeek()

      • getFirstDayOfWeek

        public int getFirstDayOfWeek​()
        得到一周的第一天是什么 例如， SUNDAY在美国， MONDAY在法国。
        结果
        一周的第一天。
        另请参见：
        setFirstDayOfWeek(int) ， getMinimalDaysInFirstWeek()

      • setMinimalDaysInFirstWeek

        public void setMinimalDaysInFirstWeek​(int value)
        设定一年中第一个星期所需的最短时间是多少？ 例如，如果第一周被定义为包含一年中第一个月的第一天的第一个星期，请将该方法称为值1.如果必须是整周，请使用值7。
        参数
        value - 一年中第一周所需的最短日期。
        另请参见：
        getMinimalDaysInFirstWeek()

      • getMinimalDaysInFirstWeek

        public int getMinimalDaysInFirstWeek​()
        获得一年中第一周所需的最低限度的日子; 例如，如果第一周被定义为包含一年中第一个月的第一天的方法，则此方法返回1.如果所需的最小天数必须是整周，则此方法返回7。
        结果
        在一年的第一周所需的最低限度的日子。
        另请参见：
        setMinimalDaysInFirstWeek(int)

      • isWeekDateSupported

        public boolean isWeekDateSupported​()
        返回此Calendar是否支持周日期。

        此方法的默认实现将返回false 。

        结果
        true如果这个Calendar支持周日期; 否则为false 。
        从以下版本开始：
        1.7
        另请参见：
        getWeekYear() ，
setWeekDate(int,int,int) ，
getWeeksInWeekYear()

      • getWeekYear

        public int getWeekYear​()
        返回此Calendar代表的Calendar 。 周周与周周期同步。 first day of the first week是本周的第一天。

        此方法的默认实现会抛出一个UnsupportedOperationException 。

        结果
        这个 Calendar
        异常
        UnsupportedOperationException - 如果这个 Calendar不支持任何一周的编号。
        从以下版本开始：
        1.7
        另请参见：
        isWeekDateSupported() ，
getFirstDayOfWeek() ，
getMinimalDaysInFirstWeek()

      • setWeekDate

        public void setWeekDate​(int weekYear,
                        int weekOfYear,
                        int dayOfWeek)
        设置这个Calendar的日期与给定的日期说明符 - 周年，年周和星期几。

        与set方法不同，所有日历字段和time值都将在退货时计算。

        如果weekOfYear中的有效周期范围weekYear ，则weekYear和weekOfYear值均以宽松模式进行调整，或者在非宽松模式下抛出IllegalArgumentException 。

        此方法的默认实现会抛出一个UnsupportedOperationException 。

        参数
        weekYear - 周年
        weekOfYear - 周数基于 weekYear
        dayOfWeek - 星期几值： DAY_OF_WEEK字段的常量之一： SUNDAY ，...， SATURDAY 。
        异常
        IllegalArgumentException - 如果任何给定的日期说明符无效或任何日历字段与非宽松模式中的给定日期说明符不一致
        UnsupportedOperationException - 如果这个 Calendar不支持任何一周的编号。
        从以下版本开始：
        1.7
        另请参见：
        isWeekDateSupported() ，
getFirstDayOfWeek() ，
getMinimalDaysInFirstWeek()

      • getWeeksInWeekYear

        public int getWeeksInWeekYear​()
        返回由Calendar表示的周年中的周Calendar 。

        此方法的默认实现会抛出一个UnsupportedOperationException 。

        结果
        在一周的星期数。
        异常
        UnsupportedOperationException - 如果这个 Calendar不支持任何一周的编号。
        从以下版本开始：
        1.7
        另请参见：
        WEEK_OF_YEAR ，
isWeekDateSupported() ，
getWeekYear() ，
getActualMaximum(int)

      • getMinimum

        public abstract int getMinimum​(int field)
        返回此Calendar实例的给定日历字段的Calendar 。 最小值被定义为get方法为任何可能的时间值返回的最小值。 最小值取决于实例的日历系统特定参数。
        参数
        field - 日历字段。
        结果
        给定日历字段的最小值。
        另请参见：
        getMaximum(int) ， getGreatestMinimum(int) ， getLeastMaximum(int) ， getActualMinimum(int) ， getActualMaximum(int)

      • getMaximum

        public abstract int getMaximum​(int field)
        返回此Calendar实例的给定日历字段的Calendar 。 最大值定义为get方法为任何可能的时间值返回的最大值。 最大值取决于实例的日历系统特定参数。
        参数
        field - 日历字段。
        结果
        给定日历字段的最大值。
        另请参见：
        getMinimum(int) ， getGreatestMinimum(int) ， getLeastMaximum(int) ， getActualMinimum(int) ， getActualMaximum(int)

      • getGreatestMinimum

        public abstract int getGreatestMinimum​(int field)
        返回此Calendar实例的给定日历字段的最高最小值。 最高的最小值被定义为getActualMinimum(int)为任何可能的时间值返回的最大值。 最大最小值取决于实例的日历系统特定参数。
        参数
        field - 日历字段。
        结果
        给定日历字段的最低最小值。
        另请参见：
        getMinimum(int) ， getMaximum(int) ， getLeastMaximum(int) ， getActualMinimum(int) ， getActualMaximum(int)

      • getLeastMaximum

        public abstract int getLeastMaximum​(int field)
        返回此Calendar实例的给定日历字段的最低最大值。 最低最大值定义为getActualMaximum(int)为任何可能的时间值返回的最小值 。 最小值取决于实例的日历系统特定参数。 例如， Calendar的公历日历系统为DAY_OF_MONTH字段返回28，因为第28个是这个日历最短的月份的最后一天，2月份在一个普通的年份。
        参数
        field - 日历字段。
        结果
        给定日历字段的最低最大值。
        另请参见：
        getMinimum(int) ， getMaximum(int) ， getGreatestMinimum(int) ， getActualMinimum(int) ， getActualMaximum(int)

      • getActualMinimum

        public int getActualMinimum​(int field)
        给定此Calendar的时间值，返回指定日历字段可能具有的Calendar 。

        该方法的默认实现使用迭代算法来确定日历字段的实际最小值。 如果可能，子类应该用更有效的实现来覆盖它 - 在许多情况下，它们可以简单地返回getMinimum() 。

        参数
        field - 日历字段
        结果
        给定的日期字段的最小值为 Calendar的时间值
        从以下版本开始：
        1.2
        另请参见：
        getMinimum(int) ， getMaximum(int) ， getGreatestMinimum(int) ， getLeastMaximum(int) ， getActualMaximum(int)

      • getActualMaximum

        public int getActualMaximum​(int field)
        给定此Calendar的时间值，返回指定日历字段可能具有的Calendar 。 例如， MONTH字段的实际最大值在一些年份为12，在希伯来语日历系统中的其他年份为13。

        该方法的默认实现使用迭代算法来确定日历字段的实际最大值。 如果可能，子类应该用更有效的实现来覆盖它。

        参数
        field - 日历字段
        结果
        给定日历字段的最大值为此 Calendar的时间值
        从以下版本开始：
        1.2
        另请参见：
        getMinimum(int) ， getMaximum(int) ， getGreatestMinimum(int) ， getLeastMaximum(int) ， getActualMinimum(int)

      • clone

        public Object clone​()
        创建并返回此对象的副本。
        重写：
        clone在 Object
        结果
        这个对象的副本。
        另请参见：
        Cloneable

      • toString

        public String toString​()
        返回此日历的字符串表示形式。 此方法仅用于调试目的，并且返回的字符串的格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        toString在 Object
        结果
        该日历的字符串表示形式。

      • toInstant

        public final Instant toInstant​()
        将此对象转换为Instant 。

        转换创建Instant ，表示基于时间线，因为这同一点Calendar 。

        结果
        该时刻表示时间线上的相同点
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Calendar.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Calendar.Builder

  • java.lang.Object
    • java.util.Calendar.Builder
  • Enclosing class:
    Calendar

    public static class Calendar.Builder
extends Object
    Calendar.Builder用于从各种日期时间参数创建Calendar 。

    将Calendar设置为日期时间值有两种方法。 一个是将即时参数设置为与Epoch毫秒的偏移量。 另一个是将各个字段参数（如YEAR ）设置为所需的值。 这两种方式不能混合。 尝试同时设置即时和个别字段将导致抛出IllegalStateException 。 但是，允许覆盖即时或现场参数的先前值。

    如果没有足够的字段参数来确定日期和/或时间，则在构建Calendar时使用日历特定的默认值。 例如，如果公历中没有给出YEAR的价值，那么将使用1970年。 如果现场参数有任何冲突，则应用resolution rules 。 因此，现场设置的顺序很重要。

    除了日期时间参数，该locale ， time zone ， week definition ，并leniency mode参数进行设置。

    例子

    以下是示例用法。 示例代码假定Calendar常量是静态导入的。

    以下代码产生一个Calendar与日期2012-12-31（格里高利），因为星期一是一个星期的第一天与ISO 8601 compatible week parameters 。

      Calendar cal = new Calendar.Builder().setCalendarType("iso8601")
                        .setWeekDate(2013, 1, MONDAY).build();

    以下代码生成日期为1989-01-08（Gregorian）的日语Calendar ，假设默认的ERA是当天开始的平成 。

      Calendar cal = new Calendar.Builder().setCalendarType("japanese")
                        .setFields(YEAR, 1, DAY_OF_YEAR, 1).build();
    从以下版本开始：
    1.8
    另请参见：
    Calendar.getInstance(TimeZone, Locale) ， Calendar.fields

    • 构造方法摘要

      构造方法
      Constructor 描述
      Builder​()
      构造一个 Calendar.Builder 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Calendar build​()
      返回一个由setter方法设置的参数构建的 Calendar 。
      Calendar.Builder set​(int field, int value)
      将 field参数设置为给定的 value 。
      Calendar.Builder setCalendarType​(String type)
      将日历类型参数设置为给定的 type 。
      Calendar.Builder setDate​(int year, int month, int dayOfMonth)
      将日期字段参数设置 year month和 dayOfMonth给出的值。
      Calendar.Builder setFields​(int... fieldValuePairs)
      将字段参数设置为由 fieldValuePairs给出的值，它们是字段对及其值。
      Calendar.Builder setInstant​(long instant)
      设置即时参数给定 instant值是一毫秒的偏移 the Epoch 。
      Calendar.Builder setInstant​(Date instant)
      设置即时参数设置为instant由给定值Date 。
      Calendar.Builder setLenient​(boolean lenient)
      将宽松模式参数设置为 lenient给出的值。
      Calendar.Builder setLocale​(Locale locale)
      将locale参数设置为给定的 locale 。
      Calendar.Builder setTimeOfDay​(int hourOfDay, int minute, int second)
      将时间字段参数设置 hourOfDay minute和 second给出的值。
      Calendar.Builder setTimeOfDay​(int hourOfDay, int minute, int second, int millis)
      设置由给定的一天领域参数值时 hourOfDay ， minute ， second ，并 millis 。
      Calendar.Builder setTimeZone​(TimeZone zone)
      将时区参数设置为给定的 zone 。
      Calendar.Builder setWeekDate​(int weekYear, int weekOfYear, int dayOfWeek)
      将基于周的日期参数设置为给定日期说明符 - 周年，年周和星期几的值。
      Calendar.Builder setWeekDefinition​(int firstDayOfWeek, int minimalDaysInFirstWeek)
      将 firstDayOfWeek参数设置为 firstDayOfWeek和 minimalDaysInFirstWeek给出的值，用于确定一年中的 first week 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Builder

        public Builder​()
        构造一个 Calendar.Builder 。

    • 方法详细信息

      • setInstant

        public Calendar.Builder setInstant​(long instant)
        设置即时参数给定 instant值是一毫秒的偏移 the Epoch 。
        参数
        instant - 与时代的毫秒偏移
        结果
        这个 Calendar.Builder
        异常
        IllegalStateException - 如果已经设置了任何一个字段参数
        另请参见：
        Calendar.setTime(Date) ， Calendar.setTimeInMillis(long) ， Calendar.time

      • setInstant

        public Calendar.Builder setInstant​(Date instant)
        设置即时参数设置为instant由给定值Date 。 此方法相当于调用setInstant(instant.getTime()) 。
        参数
        instant - 一个 Date代表距离时代的毫秒偏移量
        结果
        这 Calendar.Builder
        异常
        NullPointerException - 如果 instant是 null
        IllegalStateException - 是否已经设置了任何字段参数
        另请参见：
        Calendar.setTime(Date) ， Calendar.setTimeInMillis(long) ， Calendar.time

      • set

        public Calendar.Builder set​(int field,
                            int value)
        将field参数设置为给定的value 。 field是一个索引到Calendar.fields ，如DAY_OF_MONTH 。 此方法不执行字段值验证。 任何超出范围的值在宽松模式下进行归一化，或者在构建Calendar时以非宽松模式检测为无效值。
        参数
        field - 一个索引到 Calendar字段
        value - 字段值
        结果
        这 Calendar.Builder
        异常
        IllegalArgumentException - 如果 field无效
        IllegalStateException - 如果即时值已经设置，或者字段设置太多（约 Integer.MAX_VALUE ）次。
        另请参见：
        Calendar.set(int, int)

      • setFields

        public Calendar.Builder setFields​(int... fieldValuePairs)
        将字段参数设置为由fieldValuePairs给出的值，它们是字段对及其值。 例如，
          setFields(Calendar.YEAR, 2013,
             Calendar.MONTH, Calendar.DECEMBER,
             Calendar.DAY_OF_MONTH, 23);
        相当于以下set调用的顺序：
          set(Calendar.YEAR, 2013)
   .set(Calendar.MONTH, Calendar.DECEMBER)
   .set(Calendar.DAY_OF_MONTH, 23);
        参数
        fieldValuePairs - 字段值对
        结果
        这 Calendar.Builder
        异常
        NullPointerException - 如果 fieldValuePairs是 null
        IllegalArgumentException - 如果任何字段无效，或者如果 fieldValuePairs.length是奇数。
        IllegalStateException - 如果即时值已设置，或者字段设置过多（约 Integer.MAX_VALUE ）次。

      • setDate

        public Calendar.Builder setDate​(int year,
                                int month,
                                int dayOfMonth)
        将日期字段参数设置year month和dayOfMonth给出的值。 此方法相当于调用：
          setFields(Calendar.YEAR, year,
             Calendar.MONTH, month,
             Calendar.DAY_OF_MONTH, dayOfMonth);
        参数
        year - YEAR的价值
        month - MONTH值（月份编号为 0 ）。
        dayOfMonth - DAY_OF_MONTH的价值
        结果
        这 Calendar.Builder

      • setTimeOfDay

        public Calendar.Builder setTimeOfDay​(int hourOfDay,
                                     int minute,
                                     int second)
        将时间字段参数设置hourOfDay minute和second给出的值。 此方法相当于调用：
          setTimeOfDay(hourOfDay, minute, second, 0);
        参数
        hourOfDay - HOUR_OF_DAY值（24小时制）
        minute - MINUTE的价值
        second - SECOND的价值
        结果
        这 Calendar.Builder

      • setTimeOfDay

        public Calendar.Builder setTimeOfDay​(int hourOfDay,
                                     int minute,
                                     int second,
                                     int millis)
        设置由给定的一天领域参数值时hourOfDay ， minute ， second ，并millis 。 此方法相当于调用：
          setFields(Calendar.HOUR_OF_DAY, hourOfDay,
             Calendar.MINUTE, minute,
             Calendar.SECOND, second,
             Calendar.MILLISECOND, millis);
        参数
        hourOfDay - HOUR_OF_DAY的价值（24小时制）
        minute - MINUTE的价值
        second - SECOND的价值
        millis - MILLISECOND的价值
        结果
        这 Calendar.Builder

      • setWeekDate

        public Calendar.Builder setWeekDate​(int weekYear,
                                    int weekOfYear,
                                    int dayOfWeek)
        将基于周的日期参数设置为给定日期说明符 - 周年，年周和星期几的值。

        如果指定的日历不支持周日期，则build方法将抛出IllegalArgumentException 。

        参数
        weekYear - 周年
        weekOfYear - 周数基于 weekYear
        dayOfWeek - 星期几值： DAY_OF_WEEK字段的常量之一： SUNDAY ，...， SATURDAY 。
        结果
        这 Calendar.Builder
        另请参见：
        Calendar.setWeekDate(int, int, int) ， Calendar.isWeekDateSupported()

      • setTimeZone

        public Calendar.Builder setTimeZone​(TimeZone zone)
        将时区参数设置为给定的zone 。 如果没有时区参数给这个Calendar.Builder ，该default TimeZone将在使用build方法。
        参数
        zone - TimeZone
        结果
        这 Calendar.Builder
        异常
        NullPointerException - 如果 zone是 null
        另请参见：
        Calendar.setTimeZone(TimeZone)

      • setLenient

        public Calendar.Builder setLenient​(boolean lenient)
        将宽松模式参数设置为lenient给出的值。 如果没有给这个Calendar.Builder提供宽松的参数，则在build方法中将使用宽大的模式。
        参数
        lenient - true宽松模式; false用于非宽松模式
        结果
        这 Calendar.Builder
        另请参见：
        Calendar.setLenient(boolean)

      • setCalendarType

        public Calendar.Builder setCalendarType​(String type)
        将日历类型参数设置为给定的type 。 该方法给出的日历类型优先于locale给出的任何显式或隐式日历类型。

        除了由返回可用的日历类型Calendar.getAvailableCalendarTypes方法， "gregorian"和"iso8601"作为别名"gregory"可以与此方法一起使用。

        参数
        type - 日历类型
        结果
        这 Calendar.Builder
        异常
        NullPointerException - 如果 type是 null
        IllegalArgumentException - 如果 type未知
        IllegalStateException - 如果已经设置了其他日历类型
        另请参见：
        Calendar.getCalendarType() ， Calendar.getAvailableCalendarTypes()

      • setLocale

        public Calendar.Builder setLocale​(Locale locale)
        将locale参数设置为给定的locale 。 如果没有给这个Calendar.Builder区域设置，将使用default Locale对于Locale.Category.FORMAT 。

        如果没有通过调用setCalendarType方法明确给出日历类型，则使用Locale值来确定要构建的Calendar类型。

        如果没有通过调用setWeekDefinition方法明确给出周定义参数，则使用Locale的默认值。

        参数
        locale - Locale
        结果
        这 Calendar.Builder
        异常
        NullPointerException - 如果 locale是 null
        另请参见：
        Calendar.getInstance(Locale)

      • setWeekDefinition

        public Calendar.Builder setWeekDefinition​(int firstDayOfWeek,
                                          int minimalDaysInFirstWeek)
        将firstDayOfWeek参数设置为由firstDayOfWeek和minimalDaysInFirstWeek给出的值，用于确定一年中的first week 。 此方法给出的参数优先于locale给出的默认值。
        参数
        firstDayOfWeek - 一周的第一天; 一个Calendar.SUNDAY到Calendar.SATURDAY
        minimalDaysInFirstWeek - 第一周的最少天数（1..7）
        结果
        这 Calendar.Builder
        异常
        IllegalArgumentException - 如果 firstDayOfWeek或 minimalDaysInFirstWeek无效
        另请参见：
        Calendar.getFirstDayOfWeek() ， Calendar.getMinimalDaysInFirstWeek()

      • build

        public Calendar build​()
        返回一个由setter方法设置的参数构建的Calendar 。 由setCalendarType方法或locale给出的日历类型用于确定要创建的Calendar 。 如果没有显示明确的日历类型，则会创建语言环境的默认日历。

        如果日历类型为"iso8601" ，该Gregorian change date一个的GregorianCalendar设置为Date(Long.MIN_VALUE)是proleptic公历。 其周定义参数也设置为compatible with the ISO 8601 standard 。 请注意，使用GregorianCalendar创建的"iso8601"的getCalendarType方法返回"gregory" 。

        如果尚未明确给出这些参数，则默认值用于区域设置和时区。

        任何超出范围的字段值都是在宽松模式下进行归一化或在非宽松模式下被检测为无效值。

        结果
        一个 Calendar内置的这个 Calendar.Builder参数
        异常
        IllegalArgumentException - 如果日历类型未知，或者如果在非宽松模式下给出了无效的字段值，或者如果为不支持周日期的日历类型提供了周日期。
        另请参见：
        Calendar.getInstance(TimeZone, Locale),
Locale.getDefault(Locale.Category),
TimeZone.getDefault()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Collection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Collection<E>

  • 参数类型
    E - 此集合中元素的类型
    All Superinterfaces:
    Iterable<E>
    All Known Subinterfaces:
    BeanContext ， BeanContextServices ， BlockingDeque<E> ， BlockingQueue<E> ， Deque<E> ， EventSet ， List<E> ， NavigableSet<E> ， ObservableList<E> ， ObservableListValue<E> ， ObservableSet<E> ， ObservableSetValue<E> ， Queue<E> ， Set<E> ， SortedSet<E> ， TransferQueue<E> ， WritableListValue<E> ， WritableSetValue<E>
    所有已知实现类：
    AbstractCollection ， AbstractList ， AbstractQueue ， AbstractSequentialList ， AbstractSet ， ArrayBlockingQueue ， ArrayDeque ， ArrayList ， AttributeList ， BeanContextServicesSupport ， BeanContextSupport ， ConcurrentHashMap.KeySetView ， ConcurrentLinkedDeque ， ConcurrentLinkedQueue ， ConcurrentSkipListSet ， CopyOnWriteArrayList ， CopyOnWriteArraySet ， DelayQueue ， EnumSet ， FilteredList ， HashSet ， JobStateReasons ， LinkedBlockingDeque ， LinkedBlockingQueue ， LinkedHashSet ， LinkedList ， LinkedTransferQueue ， ListBinding ， ListExpression ， ListProperty ， ListPropertyBase ， ModifiableObservableListBase ， ObservableListBase ， PriorityBlockingQueue ， PriorityQueue ， ReadOnlyListProperty ， ReadOnlyListPropertyBase ， ReadOnlyListWrapper ， ReadOnlySetProperty ， ReadOnlySetPropertyBase ， ReadOnlySetWrapper ， RoleList ， RoleUnresolvedList ， SetBinding ， SetExpression ， SetProperty ， SetPropertyBase ， SimpleListProperty ， SimpleSetProperty ， SortedList ， Stack ， SynchronousQueue ， TransformationList ， TreeSet ， Vector

    public interface Collection<E>
extends Iterable<E>
    集合层次结构中的根界面。 集合表示一组被称为其元素的对象。 一些集合允许重复元素，而其他集合不允许。 有些被命令和其他无序。 JDK不提供此接口的任何直接实现：它提供了更具体的子接口的实现，如Set和List 。 该界面通常用于传递集合，并在需要最大的通用性的情况下对其进行操作。

    包或多重集 （可能包含重复元素的无序集合）应直接实现此接口。

    所有通用的Collection实现类（通常通过其子接口间接实现Collection ）应该提供两个“标准”构造函数：一个void（无参数）构造函数，它创建一个空集合，以及一个具有单个参数类型的构造函数Collection ，它创建一个与其参数相同的元素的新集合。 实际上，后一个构造函数允许用户复制任何集合，生成所需实现类型的等效集合。 没有办法强制执行这个约定（因为接口不能包含构造函数），而是Java平台库中的所有通用的Collection实现。

    如果此集合不支持该操作，则此接口中包含的“破坏性”方法（即修改其操作的集合的方法）将被指定为抛出UnsupportedOperationException 。 如果是这种情况，如果调用对集合没有影响，这些方法可能会但不是必须抛出一个UnsupportedOperationException 。 例如，如果要添加的集合为空，则可以在不可修改的集合上调用addAll(Collection)方法，但不是必须抛出异常。

    Some collection implementations have restrictions on the elements that they may contain.例如，一些实现禁止空元素，一些实现方式对其元素的类型有限制。 尝试添加不合格元素会引发未经检查的异常，通常为NullPointerException或ClassCastException 。 尝试查询不合格元素的存在可能会引发异常，或者可能只是返回false; 一些实现将展现出前者的行为，一些实现将展现出后者。 更一般来说，尝试对不符合条件的元素进行操作时，其完成不会导致将不合格元素插入到集合中，可能会导致异常，或者可能会成功执行该选项。 此异常在此接口的规范中标记为“可选”。

    每个集合决定自己的同步策略。 在没有实现的更强保证的情况下，未定义的行为可能是由于对由另一个线程进行突变的集合的任何方法的调用而导致的; 这包括直接调用，将集合传递给可能执行调用的方法，并使用现有的迭代器来检查集合。

    Collections Framework接口中的许多方法都是按照equals方法进行定义的。 例如，对于在本说明书contains(Object o)方法表示：“返回true当且仅当这个集合包含至少一个元素e使得(o==null ? e==null : o.equals(e)) ”。 该规范不应该被解释为意味着调用Collection.contains与非空参数o会导致o.equals(e)被调用任何元素e 。 实现可以自由地实现优化，从而避免equals调用，例如，首先比较两个元素的哈希码。 （ Object.hashCode()规范保证具有不等的哈希码的两个对象不能相等。）更一般地说，各种Collections框架接口的实现可以随意利用底层的Object方法的指定行为，无论执行者认为是合适的。

    执行递归遍历集合的一些集合操作可能会失败，而自引用实例的异常会导致集合直接或间接包含其自身。 这包括clone() ， equals() ， hashCode()和toString()方法。 实现可以可选地处理自引用场景，然而大多数当前实现不这样做。

    此接口是Java Collections Framework的成员。

    实现要求：
    默认方法实现（继承或其他）不应用任何同步协议。 如果一个Collection实现具有特定的同步协议，则它必须覆盖默认实现以应用该协议。
    从以下版本开始：
    1.2
    另请参见：
    Set ， List ， Map ， SortedSet ， SortedMap ， HashSet ， TreeSet ， ArrayList ， LinkedList ， Vector ， Collections ， Arrays ， AbstractCollection

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean add​(E e)
      确保此集合包含指定的元素（可选操作）。
      boolean addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合（可选操作）。
      void clear​()
      从此集合中删除所有元素（可选操作）。
      boolean contains​(Object o)
      如果此集合包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> c)
      如果此集合包含指定集合中的所有元素，则返回 true 。
      boolean equals​(Object o)
      将指定的对象与此集合进行比较以获得相等性。
      int hashCode​()
      返回此集合的哈希码值。
      boolean isEmpty​()
      如果此集合不包含元素，则返回 true 。
      Iterator<E> iterator​()
      返回此集合中元素的迭代器。
      default Stream<E> parallelStream​()
      返回可能并行的 Stream与此集合作为其来源。
      boolean remove​(Object o)
      从该集合中删除指定元素的单个实例（如果存在）（可选操作）。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      default boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此集合中的元素数。
      default Spliterator<E> spliterator​()
      在此集合中的元素上创建一个Spliterator 。
      default Stream<E> stream​()
      返回一个序列 Stream与此集合作为其来源。
      Object[] toArray​()
      返回一个包含此集合中所有元素的数组。
      <T> T[] toArray​(T[] a)
      返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

      • Methods inherited from interface java.lang.Iterable

        forEach

    • 方法详细信息

      • size

        int size​()
        返回此集合中的元素数。 如果此集合包含Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。
        结果
        此集合中的元素数

      • isEmpty

        boolean isEmpty​()
        如果此集合不包含元素，则返回 true 。
        结果
        true如果此集合不包含元素

      • contains

        boolean contains​(Object o)
        如果此集合包含指定的元素，则返回true 。 更正式地说，返回true当且仅当这个集合包含至少一个元素e这样Objects.equals(o, e) 。
        参数
        o - 要在此集合中存在的元素要进行测试
        结果
        true如果此集合包含指定的元素
        异常
        ClassCastException - 如果指定元素的类型与此集合不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且此集合不允许空元素（ optional ）

      • iterator

        Iterator<E> iterator​()
        返回此集合中元素的迭代器。 没有关于元素返回顺序的保证（除非这个集合是提供保证的某个类的实例）。
        Specified by:
        iterator接口 Iterable<E>
        结果
        一个 Iterator在这个集合中的元素

      • toArray

        Object[] toArray​()
        返回一个包含此集合中所有元素的数组。 如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        返回的数组将是“安全的”，因为该集合不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组，即使这个集合是由数组支持的）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        结果
        一个包含此集合中所有元素的数组

      • toArray

        <T> T[] toArray​(T[] a)
        返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果集合适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此集合的大小分配一个新数组。

        如果此集合适合指定的数组，具有空余空间（即，数组具有比此集合更多的元素），则紧跟在集合结束后的数组中的元素将设置为null 。 （ 仅当调用者知道此集合不包含任何null元素时，这仅用于确定此集合的长度。）

        如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的集合。 以下代码可用于将集合转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储此集合的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此集合中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此集合中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • add

        boolean add​(E e)
        确保此集合包含指定的元素（可选操作）。 如果此集合由于调用而更改，则返回true 。 （如果此集合不允许重复且已包含指定的元素，则返回false ）

        支持此操作的集合可能会限制可能添加到此集合的元素。 特别是一些集合将拒绝添加null元素，其他集合将对可能添加的元素的类型施加限制。 收集类应在其文档中明确说明可能添加哪些元素的限制。

        如果某个集合拒绝添加特定元素，除了它已经包含该元素之外，它必须引发异常（而不是返回false ）。 这保留了一个集合在此调用返回后始终包含指定元素的不变量。

        参数
        e - 要确保在此集合中的存在的元素
        结果
        true如果此集合由于调用而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 add操作
        ClassCastException - 如果指定元素的类阻止将其添加到此集合
        NullPointerException - 如果指定的元素为空，并且该集合不允许空元素
        IllegalArgumentException - 如果元素的某些属性阻止将其添加到此集合
        IllegalStateException - 如果由于插入限制，此时无法添加该元素

      • remove

        boolean remove​(Object o)
        从该集合中删除指定元素的单个实例（如果存在）（可选操作）。 更正式地，删除元素e使得Objects.equals(o, e)如果该集合包含一个或多个这样的元素。 如果此集合包含指定的元素（或等效地，如果此集合由于调用而更改），则返回true 。
        参数
        o - 要从此集合中删除的元素（如果存在）
        结果
        true如果一个元素被删除作为这个调用的结果
        异常
        ClassCastException - 如果指定元素的类型与此集合不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且该集合不允许空元素（ optional ）
        UnsupportedOperationException - 如果此集合不支持 remove操作

      • containsAll

        boolean containsAll​(Collection<?> c)
        如果此集合包含指定集合中的所有元素，则返回 true 。
        参数
        c - 要在此集合中检查遏制的集合
        结果
        true如果此集合包含指定集合中的所有元素
        异常
        ClassCastException - 如果指定集合中的一个或多个元素的类型与此集合不兼容（ optional ）
        NullPointerException - 如果指定的集合包含一个或多个空元素，并且此集合不允许空元素（ optional ）或指定的集合为空。
        另请参见：
        contains(Object)

      • addAll

        boolean addAll​(Collection<? extends E> c)
        将指定集合中的所有元素添加到此集合（可选操作）。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （这意味着如果指定的集合是此集合，此调用的行为是未定义的，并且此集合是非空的。）
        参数
        c - 包含要添加到此集合的元素的集合
        结果
        true如果此集合由于调用而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 addAll操作
        ClassCastException - 如果指定集合的元素的类阻止将其添加到此集合
        NullPointerException - 如果指定的集合包含一个空元素，并且此集合不允许空元素，或者如果指定的集合为空
        IllegalArgumentException - 如果指定集合的元素的某些属性阻止将其添加到此集合
        IllegalStateException - 如果不是，由于插入限制，此时可以添加所有元素
        另请参见：
        add(Object)

      • removeAll

        boolean removeAll​(Collection<?> c)
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 removeAll方法
        ClassCastException - 如果此集合中的一个或多个元素的类型与指定集合不兼容（ optional ）
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object) ， contains(Object)

      • removeIf

        default boolean removeIf​(Predicate<? super E> filter)
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        实现要求：
        默认实现使用其iterator()遍历集合的所有元素。 使用Iterator.remove()删除每个匹配元素。 如果集合的迭代器不支持删除，则第一个匹配元素将抛出UnsupportedOperationException 。
        参数
        filter - 一个谓词，为要删除的元素返回 true
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空
        UnsupportedOperationException - 如果元素无法从此集合中删除。 如果不能删除匹配的元素，或者一般来说，不支持删除，则实现可能会抛出此异常。
        从以下版本开始：
        1.8

      • retainAll

        boolean retainAll​(Collection<?> c)
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果此收集因呼叫而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 retainAll操作
        ClassCastException - 如果此集合中的一个或多个元素的类型与指定集合不兼容（ optional ）
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object) ， contains(Object)

      • clear

        void clear​()
        从此集合中删除所有元素（可选操作）。 此方法返回后，集合将为空。
        异常
        UnsupportedOperationException - 如果此集合不支持 clear操作

      • equals

        boolean equals​(Object o)
        将指定的对象与此集合进行比较以获得相等性。

        虽然Collection接口不会增加规定向工程总承包为Object.equals ，谁落实程序员Collection接口“直接”（换句话说，创建一个类，是Collection ，但不是Set或者List ），如果必须小心谨慎，他们选择覆盖Object.equals 。 没有必要这样做，最简单的做法是依靠Object的实现，但实施者可能希望实现“价值比较”来代替默认的“参考比较”。 （ List和Set接口要求这样的价值比较。）

        Object.equals方法的通用合同规定，等于必须是对称的（换句话说， a.equals(b)如果且仅当b.equals(a) ）。 List.equals和Set.equals的合同规定，列表仅等于其他列表，并设置为其他集合。 因此，当将此集合与任何列表或集合进行比较时，用于既不实现List也不实现Set接口的集合类的自定义equals方法必须返回false 。 （通过相同的逻辑，不可能编写正确实现Set和List接口的类。）

        重写：
        equals在 Object
        参数
        o - 要与此集合相等的对象进行比较
        结果
        true如果指定的对象等于此集合
        另请参见：
        Object.equals(Object) ，
Set.equals(Object) ，
List.equals(Object)

      • hashCode

        int hashCode​()
        返回此集合的哈希码值。 虽然Collection接口不会增加规定为一般合同Object.hashCode方法，程序员应该注意，覆盖任何类Object.equals方法也必须重写Object.hashCode方法，以满足为一般合同Object.hashCode方法。 特别是c1.equals(c2)意味着c1.hashCode()==c2.hashCode() 。
        重写：
        hashCode在 Object
        结果
        该集合的哈希码值
        另请参见：
        Object.hashCode() ， Object.equals(Object)

      • spliterator

        default Spliterator<E> spliterator​()
        在此集合中的元素上创建一个Spliterator 。 实现应该记录分配器报告的特征值。 如果分配器报告Spliterator.SIZED并且该集合不包含元素，则不需要报告这些特征值。

        应该通过可以返回更高效的拼接器的子类覆盖默认实现。 为了保持stream()和parallelStream()方法的预期懒惰行为，拼接器应具有IMMUTABLE或CONCURRENT的特征，或late-binding 。 如果这些都不实际，那么首要的类应该是描述绑定器的绑定和结构性干扰策略，并且应该覆盖stream()和parallelStream()方法以使用Supplier的拼接器创建流，如下所示：

           Stream<E> s = StreamSupport.stream(() -> spliterator(), spliteratorCharacteristics)

        这些要求确保由stream()和parallelStream()方法生成的流将反映起始终端流操作时收集的内容。

        Specified by:
        spliterator在接口 Iterable<E>
        实现要求：
        默认实现从集合的Iterator创建一个late-binding拼接Iterator 。 分割器继承集合的迭代器的故障快速属性。

        创建Spliterator报告Spliterator.SIZED 。

        Implementation Note:
        创建的Spliterator另外报告Spliterator.SUBSIZED 。

        如果拼接器不覆盖任何元素，那么除了SIZED和SUBSIZED以外的其他特征值的报告不能帮助客户控制，专门化或简化计算。 但是，这样做可以使空集合能够共享使用不可变的空分配器实例（参见Spliterators.emptySpliterator() ），并使客户端能够确定这样的分割器是否不覆盖元素。

        结果
        一个 Spliterator在这个集合中的元素
        从以下版本开始：
        1.8

      • stream

        default Stream<E> stream​()
        返回一个序列Stream与此集合作为其来源。

        当此方法应该重写spliterator()方法不能返回spliterator是IMMUTABLE ， CONCURRENT ，或后期绑定 。 （详情请见spliterator() ）

        实现要求：
        默认的实现创建顺序 Stream从收集的 Spliterator 。
        结果
        在这个集合中的元素的顺序 Stream
        从以下版本开始：
        1.8

      • parallelStream

        default Stream<E> parallelStream​()
        返回可能并行的Stream与此集合作为其来源。 该方法允许返回顺序流。

        当此方法应该重写spliterator()方法不能返回spliterator是IMMUTABLE ， CONCURRENT ，或后期绑定 。 （详情请见spliterator() ）

        实现要求：
        默认的实现创建了一个平行 Stream从收集的 Spliterator 。
        结果
        这个集合中的元素可能并行 Stream
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Collections (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Collections

  • java.lang.Object
    • java.util.Collections

  • public class Collections
extends Object
    此类仅由静态方法组合或返回集合。 它包含对集合进行操作的多态算法，“包装器”，返回由指定集合支持的新集合，以及其他一些可能的和最终的。

    如果提供给它们的集合或类对象为null，则此类的方法将抛出一个NullPointerException 。

    包含在这个类中的多态算法的文档通常包括执行情况的简短描述。 这些描述应被视为实施说明 ，而不是说明书的一部分 。 只要规范本身得到遵守，实现者就可以随意替代其他算法。 （例如， sort使用的算法不一定是一个mergeesort，但它必须是稳定的 。）

    如果该集合不支持适当的突变原语，例如set方法，则此类中包含的“破坏性”算法，即修改其操作的集合的算法被指定为抛出UnsupportedOperationException 。 如果调用对集合没有影响，这些算法可能但不是必须抛出此异常。 例如，在已经排序的不可修改的列表上调用sort方法可以抛出或不抛出UnsupportedOperationException 。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， Set ， List ， Map

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static List EMPTY_LIST
      空列表（不可变）。
      static Map EMPTY_MAP
      空地图（immutable）。
      static Set EMPTY_SET
      空集（不可变）。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static <T> boolean addAll​(Collection<? super T> c, T... elements)
      将所有指定的元素添加到指定的集合。
      static <T> Queue<T> asLifoQueue​(Deque<T> deque)
      返回Deque作为先进先出（ Lifo ） Queue的视图 。
      static <T> int binarySearch​(List<? extends Comparable<? super T>> list, T key)
      使用二叉搜索算法搜索指定对象的指定列表。
      static <T> int binarySearch​(List<? extends T> list, T key, Comparator<? super T> c)
      使用二叉搜索算法搜索指定对象的指定列表。
      static <E> Collection<E> checkedCollection​(Collection<E> c, Class<E> type)
      返回指定集合的动态类型安全视图。
      static <E> List<E> checkedList​(List<E> list, Class<E> type)
      返回指定列表的动态类型安全视图。
      static <K,V> Map<K,V> checkedMap​(Map<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定地图的动态类型安全视图。
      static <K,V> NavigableMap<K,V> checkedNavigableMap​(NavigableMap<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定可导航地图的动态类型安全视图。
      static <E> NavigableSet<E> checkedNavigableSet​(NavigableSet<E> s, Class<E> type)
      返回指定的可导航集的动态类型安全视图。
      static <E> Queue<E> checkedQueue​(Queue<E> queue, Class<E> type)
      返回指定队列的动态类型安全视图。
      static <E> Set<E> checkedSet​(Set<E> s, Class<E> type)
      返回指定集合的动态类型安全视图。
      static <K,V> SortedMap<K,V> checkedSortedMap​(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定排序映射的动态类型安全视图。
      static <E> SortedSet<E> checkedSortedSet​(SortedSet<E> s, Class<E> type)
      返回指定排序集的动态类型安全视图。
      static <T> void copy​(List<? super T> dest, List<? extends T> src)
      将所有元素从一个列表复制到另一个列表中。
      static boolean disjoint​(Collection<?> c1, Collection<?> c2)
      如果两个指定的集合没有共同的元素，则返回 true 。
      static <T> Enumeration<T> emptyEnumeration​()
      返回没有元素的枚举。
      static <T> Iterator<T> emptyIterator​()
      返回没有元素的迭代器。
      static <T> List<T> emptyList​()
      返回空列表（immutable）。
      static <T> ListIterator<T> emptyListIterator​()
      返回没有元素的列表迭代器。
      static <K,V> Map<K,V> emptyMap​()
      返回空的地图（不可变）。
      static <K,V> NavigableMap<K,V> emptyNavigableMap​()
      返回空导航地图（不可变）。
      static <E> NavigableSet<E> emptyNavigableSet​()
      返回一个空导航集（immutable）。
      static <T> Set<T> emptySet​()
      返回一个空集（immutable）。
      static <K,V> SortedMap<K,V> emptySortedMap​()
      返回空的排序映射（immutable）。
      static <E> SortedSet<E> emptySortedSet​()
      返回一个空的排序集（immutable）。
      static <T> Enumeration<T> enumeration​(Collection<T> c)
      返回指定集合的枚举。
      static <T> void fill​(List<? super T> list, T obj)
      用指定的元素替换指定列表的所有元素。
      static int frequency​(Collection<?> c, Object o)
      返回指定集合中与指定对象相等的元素数。
      static int indexOfSubList​(List<?> source, List<?> target)
      返回指定源列表中指定目标列表的第一次出现的起始位置，如果没有此类事件，则返回-1。
      static int lastIndexOfSubList​(List<?> source, List<?> target)
      返回指定源列表中指定目标列表的最后一次出现的起始位置，如果没有此类事件则返回-1。
      static <T> ArrayList<T> list​(Enumeration<T> e)
      返回一个数组列表，其中包含由枚举返回的顺序由指定的枚举返回的元素。
      static <T extends Object & Comparable<? super T>>
      T             		max​(Collection<? extends T> coll)
      根据其元素的 自然顺序返回给定集合的最大元素。
      static <T> T max​(Collection<? extends T> coll, Comparator<? super T> comp)
      根据指定的比较器引发的顺序返回给定集合的最大元素。
      static <T extends Object & Comparable<? super T>>
      T             		min​(Collection<? extends T> coll)
      根据其元素的 自然顺序返回给定集合的最小元素。
      static <T> T min​(Collection<? extends T> coll, Comparator<? super T> comp)
      根据指定的比较器引发的顺序返回给定集合的最小元素。
      static <T> List<T> nCopies​(int n, T o)
      返回由指定对象的 n副本组成的不可变列表。
      static <E> Set<E> newSetFromMap​(Map<E,Boolean> map)
      返回由指定地图支持的集合。
      static <T> boolean replaceAll​(List<T> list, T oldVal, T newVal)
      将列表中一个指定值的所有出现替换为另一个。
      static void reverse​(List<?> list)
      反转指定列表中元素的顺序。
      static <T> Comparator<T> reverseOrder​()
      返回一个比较器， Comparable实现 Comparable接口的对象集合施加了 自然排序的相反。
      static <T> Comparator<T> reverseOrder​(Comparator<T> cmp)
      返回一个比较器，它强制指定比较器的反向排序。
      static void rotate​(List<?> list, int distance)
      将指定列表中的元素旋转指定的距离。
      static void shuffle​(List<?> list)
      使用默认的随机源随机排列指定的列表。
      static void shuffle​(List<?> list, Random rnd)
      使用指定的随机源随机排列指定的列表。
      static <T> Set<T> singleton​(T o)
      返回一个只包含指定对象的不可变组。
      static <T> List<T> singletonList​(T o)
      返回一个只包含指定对象的不可变列表。
      static <K,V> Map<K,V> singletonMap​(K key, V value)
      返回一个不可变的地图，只将指定的键映射到指定的值。
      static <T extends Comparable<? super T>>
      void             		sort​(List<T> list)
      根据其元素的natural ordering按照升序排列指定的列表。
      static <T> void sort​(List<T> list, Comparator<? super T> c)
      根据指定的比较器引起的顺序对指定的列表进行排序。
      static void swap​(List<?> list, int i, int j)
      交换指定列表中指定位置的元素。
      static <T> Collection<T> synchronizedCollection​(Collection<T> c)
      返回由指定集合支持的同步（线程安全）集合。
      static <T> List<T> synchronizedList​(List<T> list)
      返回由指定列表支持的同步（线程安全）列表。
      static <K,V> Map<K,V> synchronizedMap​(Map<K,V> m)
      返回由指定地图支持的同步（线程安全）映射。
      static <K,V> NavigableMap<K,V> synchronizedNavigableMap​(NavigableMap<K,V> m)
      返回由指定的可导航地图支持的同步（线程安全）可导航地图。
      static <T> NavigableSet<T> synchronizedNavigableSet​(NavigableSet<T> s)
      返回由指定的可导航集支持的同步（线程安全）可导航集。
      static <T> Set<T> synchronizedSet​(Set<T> s)
      返回由指定集合支持的同步（线程安全）集。
      static <K,V> SortedMap<K,V> synchronizedSortedMap​(SortedMap<K,V> m)
      返回由指定的排序映射支持的同步（线程安全）排序映射。
      static <T> SortedSet<T> synchronizedSortedSet​(SortedSet<T> s)
      返回由指定的排序集支持的同步（线程安全）排序集。
      static <T> Collection<T> unmodifiableCollection​(Collection<? extends T> c)
      返回指定集合的不可修改视图。
      static <T> List<T> unmodifiableList​(List<? extends T> list)
      返回指定列表的不可修改视图。
      static <K,V> Map<K,V> unmodifiableMap​(Map<? extends K,? extends V> m)
      返回指定地图的不可修改视图。
      static <K,V> NavigableMap<K,V> unmodifiableNavigableMap​(NavigableMap<K,? extends V> m)
      返回指定可导航地图的不可修改视图。
      static <T> NavigableSet<T> unmodifiableNavigableSet​(NavigableSet<T> s)
      返回指定的可导航集合的不可修改的视图。
      static <T> Set<T> unmodifiableSet​(Set<? extends T> s)
      返回指定集合的不可修改视图。
      static <K,V> SortedMap<K,V> unmodifiableSortedMap​(SortedMap<K,? extends V> m)
      返回指定排序映射的不可修改视图。
      static <T> SortedSet<T> unmodifiableSortedSet​(SortedSet<T> s)
      返回指定排序集的不可修改视图。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • EMPTY_SET

        public static final Set EMPTY_SET
        空集（不可变）。 这个集是可序列化的。
        另请参见：
        emptySet()

      • EMPTY_LIST

        public static final List EMPTY_LIST
        空列表（不可变）。 此列表是可序列化的。
        另请参见：
        emptyList()

      • EMPTY_MAP

        public static final Map EMPTY_MAP
        空地图（immutable）。 这张地图是可序列化的。
        从以下版本开始：
        1.3
        另请参见：
        emptyMap()

    • 方法详细信息

      • sort

        public static <T extends Comparable<? super T>> void sort​(List<T> list)
        根据其元素的natural ordering ，将指定的列表按升序排序。 列表中的所有元素必须实现Comparable界面。 此外，列表中的所有元素必须相互可比较 （即， e1.compareTo(e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        指定的列表必须是可修改的，但不能调整大小。

        Implementation Note:
        该实现将使用指定的列表和 null比较器来 取代List.sort(Comparator)方法。
        参数类型
        T - 列表中对象的类
        参数
        list - 要排序的列表。
        异常
        ClassCastException - 如果列表包含不 相互比较的元素（例如，字符串和整数）。
        UnsupportedOperationException - 如果指定的列表的list-iterator不支持 set操作。
        IllegalArgumentException - （可选）如果实现检测到发现列表元素的自然排序违反了Comparable合同
        另请参见：
        List.sort(Comparator)

      • sort

        public static <T> void sort​(List<T> list,
                            Comparator<? super T> c)
        根据指定的比较器引起的顺序对指定的列表进行排序。 列表中的所有元素必须使用指定的比较器相互比较（即， c.compare(e1, e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        这种保证是稳定的 ：等同的元素将不会被排序作为排序的结果。

        指定的列表必须是可修改的，但不能调整大小。

        Implementation Note:
        此实现将使用指定的列表和比较器来执行 List.sort(Comparator)方法。
        参数类型
        T - 列表中对象的类
        参数
        list - 要排序的列表。
        c - 比较器来确定列表的顺序。 值null表示元素的自然排序应该被使用。
        异常
        ClassCastException - 如果列表包含使用指定比较器不 相互比较的元素。
        UnsupportedOperationException - 如果指定的列表的list-iterator不支持 set操作。
        IllegalArgumentException - （可选）如果比较方发现违反Comparator合同
        另请参见：
        List.sort(Comparator)

      • binarySearch

        public static <T> int binarySearch​(List<? extends Comparable<? super T>> list,
                                   T key)
        使用二叉搜索算法搜索指定对象的指定列表。 该列表必须根据被按升序排列natural ordering元素（如由sort(List)方法）之前使该呼叫。 如果没有排序，结果是未定义的。 如果列表包含与指定对象相等的多个元素，则不能保证将找到哪个元素。

        该方法以log（n）时间运行“随机访问”列表（提供近常数位置访问）。 如果指定的列表不实现RandomAccess接口并且很大，则该方法将执行基于迭代器的二进制搜索，执行O（n）链接遍历和O（log n）元素比较。

        参数类型
        T - 列表中对象的类
        参数
        list - 要搜索的列表。
        key - 要搜索的关键。
        结果
        搜索键的索引，如果它包含在列表中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到列表中的点：第一个元素的索引大于键，如果列表中的所有元素都小于指定的键， list.size() 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        ClassCastException - 如果列表包含不 相互比较的元素（例如，字符串和整数），或者搜索关键字与列表的元素不能相互比较。

      • binarySearch

        public static <T> int binarySearch​(List<? extends T> list,
                                   T key,
                                   Comparator<? super T> c)
        使用二叉搜索算法搜索指定对象的指定列表。 在进行此呼叫之前，列表必须根据指定的比较器（如sort(List, Comparator)方法）按升序排序。 如果没有排序，结果是未定义的。 如果列表包含与指定对象相等的多个元素，则不能保证将找到哪个元素。

        该方法以log（n）时间运行“随机访问”列表（提供近常数位置访问）。 如果指定的列表不实现RandomAccess接口并且很大，则该方法将执行基于迭代器的二进制搜索，执行O（n）链接遍历和O（log n）元素比较。

        参数类型
        T - 列表中对象的类
        参数
        list - 要搜索的列表。
        key - 要搜索的关键。
        c - 排序列表的比较器。 A null值表示应使用元素' natural ordering '。
        结果
        搜索键的索引，如果它包含在列表中; 否则， (-(insertion point) - 1) 。 插入点被定义为键被插入到列表中的点：第一个元素的索引大于键，如果列表中的所有元素都小于指定的键， list.size() 。 请注意，这确保当且仅当找到该键时返回值将为> = 0。
        异常
        ClassCastException -如果列表中包含使用指定的比较器不可 相互比较的元素，或者检索关键字是不使用此比较的列表的元素相互比较。

      • reverse

        public static void reverse​(List<?> list)
        反转指定列表中元素的顺序。

        该方法运行在线性时间。

        参数
        list - 要反转其元素的列表。
        异常
        UnsupportedOperationException - 如果指定的列表或其列表迭代器不支持 set操作。

      • shuffle

        public static void shuffle​(List<?> list)
        使用默认的随机源随机排列指定的列表。 所有排列都以大致相等的可能性发生。

        在前面的描述中使用了“大约”对冲，因为默认的随机源仅仅是独立选择的比特的无偏差源。 如果它是随机选择位的完美来源，则算法将选择具有完美均匀性的排列。

        该实现从最后一个元素向后移动列表，重复地将随机选择的元素交换到“当前位置”中。 从从第一个元素运行到当前位置（包括）的列表的部分中随机选择元素。

        该方法运行在线性时间。 如果指定的列表不实现RandomAccess接口并且很大，则此实现将混合之前将指定的列表转储到数组中，并将该混洗后的数组转储回列表中。 这避免了将“顺序访问”列表进行混洗所产生的二次行为。

        参数
        list - 要洗牌的列表。
        异常
        UnsupportedOperationException - 如果指定的列表或其列表迭代器不支持 set操作。

      • shuffle

        public static void shuffle​(List<?> list,
                           Random rnd)
        使用指定的随机源随机排列指定的列表。 如果随机性的来源是公平的，则所有排列都以相等的可能性发生。

        该实现从最后一个元素向后移动列表，重复地将随机选择的元素交换到“当前位置”中。 从从第一个元素运行到当前位置（包括）的列表的部分中随机选择元素。

        该方法运行在线性时间。 如果指定的列表不实现RandomAccess接口并且很大，则此实现将混合之前将指定的列表转储到数组中，并将该混洗后的数组转储回列表中。 这避免了将“顺序访问”列表进行混洗所产生的二次行为。

        参数
        list - 要洗牌的列表。
        rnd - 用于随机播放列表的随机源。
        异常
        UnsupportedOperationException - 如果指定的列表或其列表迭代器不支持 set操作。

      • swap

        public static void swap​(List<?> list,
                        int i,
                        int j)
        交换指定列表中指定位置的元素。 （如果指定的位置相等，调用此方法将保持不变。）
        参数
        list - 交换元素的列表。
        i - 要交换的一个元素的索引。
        j - 要交换的其他元素的索引。
        异常
        IndexOutOfBoundsException - 如果 i或 j超出范围（i <0 || i> = list.size（）|| j <0 || j> = list.size（））。
        从以下版本开始：
        1.4

      • fill

        public static <T> void fill​(List<? super T> list,
                            T obj)
        用指定的元素替换指定列表的所有元素。

        该方法运行在线性时间。

        参数类型
        T - 列表中对象的类
        参数
        list - 要填充指定元素的列表。
        obj - 用于填充指定列表的元素。
        异常
        UnsupportedOperationException - 如果指定的列表或其列表迭代器不支持 set操作。

      • copy

        public static <T> void copy​(List<? super T> dest,
                            List<? extends T> src)
        将所有元素从一个列表复制到另一个列表中。 操作完成后，目标列表中每个复制元素的索引将与源列表中的其索引相同。 目的地列表的大小必须大于或等于源列表的大小。 如果它更大，则目的地列表中的剩余元素不受影响。

        该方法运行在线性时间。

        参数类型
        T - 列表中对象的类
        参数
        dest - 目的地列表。
        src - 源列表。
        异常
        IndexOutOfBoundsException - 如果目标列表太小，无法包含整个源列表。
        UnsupportedOperationException - 如果目标列表的list-iterator不支持 set操作。

      • min

        public static <T extends Object & Comparable<? super T>> T min​(Collection<? extends T> coll)
        根据其元素的自然顺序返回给定集合的最小元素。 集合中的所有元素必须实现Comparable界面。 此外，集合中的所有元素必须相互可比较 （即， e1.compareTo(e2)不得为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        该方法遍历整个集合，因此它需要与集合的大小成比例的时间。

        参数类型
        T - 集合中对象的类
        参数
        coll - 要确定其最小元素的集合。
        结果
        根据其元素的 自然顺序 ，给定集合的最小元素。
        异常
        ClassCastException - 如果集合包含不 相互比较的元素（例如，字符串和整数）。
        NoSuchElementException - 如果集合为空。
        另请参见：
        Comparable

      • min

        public static <T> T min​(Collection<? extends T> coll,
                        Comparator<? super T> comp)
        根据指定的比较器引发的顺序返回给定集合的最小元素。 集合中的所有元素必须由指定的比较器相互比较（即， comp.compare(e1, e2)不得为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        该方法遍历整个集合，因此它需要与集合的大小成比例的时间。

        参数类型
        T - 集合中对象的类
        参数
        coll - 要确定其最小元素的集合。
        comp - 用于确定最小元素的比较器。 A null值表示应该使用元素的自然排序 。
        结果
        根据指定的比较器，给定集合的最小元素。
        异常
        ClassCastException - 如果集合包含使用指定的比较器不 相互比较的元素。
        NoSuchElementException - 如果集合为空。
        另请参见：
        Comparable

      • max

        public static <T extends Object & Comparable<? super T>> T max​(Collection<? extends T> coll)
        根据其元素的自然顺序返回给定集合的最大元素。 集合中的所有元素必须实现Comparable接口。 此外，集合中的所有元素必须相互可比较 （即e1.compareTo(e2)不得为ClassCastException中的任何元素e1和e2 ）。

        该方法遍历整个集合，因此它需要与集合的大小成比例的时间。

        参数类型
        T - 集合中对象的类
        参数
        coll - 要确定其最大元素的集合。
        结果
        根据其元素的 自然排序 ，给定集合的最大元素。
        异常
        ClassCastException - 如果集合包含不 相互比较的元素（例如字符串和整数）。
        NoSuchElementException - 如果集合为空。
        另请参见：
        Comparable

      • max

        public static <T> T max​(Collection<? extends T> coll,
                        Comparator<? super T> comp)
        根据指定的比较器引发的顺序返回给定集合的最大元素。 集合中的所有元素必须由指定的比较器相互比较（即， comp.compare(e1, e2)不得为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        该方法遍历整个集合，因此它需要与集合的大小成比例的时间。

        参数类型
        T - 集合中对象的类
        参数
        coll - 要确定其最大元素的集合。
        comp - 用于确定最大元素的比较器。 A null值表示应使用元素的自然排序 。
        结果
        给定集合的最大元素，根据指定的比较器。
        异常
        ClassCastException - 如果集合包含使用指定比较器不 相互比较的元素。
        NoSuchElementException - 如果集合为空。
        另请参见：
        Comparable

      • rotate

        public static void rotate​(List<?> list,
                          int distance)
        将指定列表中的元素旋转指定的距离。 调用此方法后，在索引元件i将是元件预先在索引(i - distance) MOD list.size() ，对于所有值i之间0和list.size()-1 ，包括端值。 （此方法对列表的大小没有影响。）

        例如，假设list包括[t, a, n, k, s] 。 调用Collections.rotate(list, 1) （或Collections.rotate(list, -4) ）后， list将包含[s, t, a, n, k] 。

        请注意，该方法可以有效地应用于子列表以移动列表中的一个或多个元素，同时保留剩余元素的顺序。 例如，以下成语将索引号为j的元素向前移动到位置k （必须大于或等于j ）：

          Collections.rotate(list.subList(j, k+1), -1);
        为了使这个具体，假设list包括[a, b, c, d, e] 。 要将索引号为1 （ b ）的元素向前移动两个位置，请执行以下调用：
          Collections.rotate(l.subList(1, 4), -1);
        得到的列表是[a, c, d, b, e] 。

        要向前移动多个元素，请增加旋转距离的绝对值。 要向后移动元素，请使用正移位距离。

        如果指定的列表较小或实现了RandomAccess接口，则该实现将第一个元素交换到应该进行的位置，然后重复地将移位的元素交换到应该进行的位置，直到将替换的元素交换到第一个元素中。 如果需要，在第二和连续元件上重复该过程，直到旋转完成。 如果指定的列表很大并且没有实现RandomAccess接口，则此实现会将列表分解为索引-distance mod size周围的两个子列表视图。 然后在每个子列表视图中调用reverse(List)方法，最后在整个列表中调用它。 有关这两种算法的更完整的描述，请参见Jon Bentley 编程珍珠的第2.3节（Addison-Wesley，1986）。

        参数
        list - 要旋转的列表。
        distance - 旋转列表的距离。 这个价值没有约束; 它可能为零，负或大于list.size() 。
        异常
        UnsupportedOperationException - 如果指定的列表或其列表迭代器不支持 set操作。
        从以下版本开始：
        1.4

      • replaceAll

        public static <T> boolean replaceAll​(List<T> list,
                                     T oldVal,
                                     T newVal)
        将列表中一个指定值的所有出现替换为另一个。 更正式地，替换newVal每个元素e在list这样(oldVal==null ? e==null : oldVal.equals(e)) 。 （此方法对列表的大小没有影响。）
        参数类型
        T - 列表中对象的类
        参数
        list - 要更换的列表。
        oldVal - 要替换的旧值。
        newVal -与新值 oldVal将被替换。
        结果
        true如果 list包含一个或多个元素 e ，使得 (oldVal==null ? e==null : oldVal.equals(e)) 。
        异常
        UnsupportedOperationException - 如果指定的列表或其列表迭代器不支持 set操作。
        从以下版本开始：
        1.4

      • indexOfSubList

        public static int indexOfSubList​(List<?> source,
                                 List<?> target)
        返回指定源列表中指定目标列表的第一次出现的起始位置，如果没有此类事件，则返回-1。 更正式地说，返回指数最低i这样source.subList(i, i+target.size()).equals(target) ，或-1，如果没有这样的指标。 （如果为target.size() > source.size()返回-1）

        该实现使用扫描源列表的“强力”技术，依次寻找与目标的匹配。

        参数
        source - 搜索第一次出现的 target 。
        target - 作为source的 source列表搜索的列表。
        结果
        在指定源列表中首次出现指定目标列表的起始位置，如果没有此类事件，则为-1。
        从以下版本开始：
        1.4

      • lastIndexOfSubList

        public static int lastIndexOfSubList​(List<?> source,
                                     List<?> target)
        返回指定源列表中指定目标列表的最后一次出现的起始位置，如果没有此类事件则返回-1。 更正式地说，返回满足i这样source.subList(i, i+target.size()).equals(target) ，或-1，如果没有这样的指标。 （如果为target.size() > source.size()返回-1）

        该实现使用在源列表上迭代的“强力”技术，依次查找每个位置上的目标匹配。

        参数
        source - 搜索最近发生的 target 。
        target - 搜索作为source的 source列表的列表。
        结果
        指定源列表中指定目标列表的最后一次出现的起始位置，如果没有此类事件，则为-1。
        从以下版本开始：
        1.4

      • unmodifiableCollection

        public static <T> Collection<T> unmodifiableCollection​(Collection<? extends T> c)
        返回指定集合的不可修改视图。 该方法允许模块向用户提供对内部集合的“只读”访问。 对返回的集合“读取”查询操作到指定的集合，并尝试修改返回的集合，无论是直接还是通过其迭代器生成一个UnsupportedOperationException 。

        返回的集合不将hashCode并传递给底层集合等于操作，而是依赖于Object的equals和hashCode方法。 在后台集合是集合或列表的情况下，必须保留这些操作的合同。

        如果指定的集合是可序列化的，则返回的集合将是可序列化的。

        参数类型
        T - 集合中对象的类
        参数
        c - 要返回不可修改视图的集合。
        结果
        指定集合的不可修改视图。

      • unmodifiableSet

        public static <T> Set<T> unmodifiableSet​(Set<? extends T> s)
        返回指定集合的不可修改视图。 该方法允许模块向用户提供对内部集的“只读”访问。 对返回的集合“读取”查询操作到指定的集合，并尝试修改返回的集合，无论是直接还是通过其迭代器，导致一个UnsupportedOperationException 。

        如果指定的集合是可序列化的，返回的集合将是可序列化的。

        参数类型
        T - 集合中对象的类
        参数
        s - 要返回不可修改视图的集合。
        结果
        指定集合的不可修改视图。

      • unmodifiableSortedSet

        public static <T> SortedSet<T> unmodifiableSortedSet​(SortedSet<T> s)
        返回指定排序集的不可修改视图。 该方法允许模块向用户提供对内部排序集的“只读”访问。 对返回的排序集查询操作“读取”到指定的排序集。 试图修改返回的有序集合，无论是直接的，通过其迭代器，或通过其subSet ， headSet ，或tailSet意见，导致UnsupportedOperationException 。

        如果指定的排序集是可序列化的，则返回的排序集将是可序列化的。

        参数类型
        T - 集合中对象的类
        参数
        s - 要为其返回不可修改的视图的排序集。
        结果
        指定排序集的不可修改视图。

      • unmodifiableNavigableSet

        public static <T> NavigableSet<T> unmodifiableNavigableSet​(NavigableSet<T> s)
        返回指定的可导航集合的不可修改的视图。 该方法允许模块向用户提供对内部导航集的“只读”访问。 对返回的导航集“查阅”查询操作到指定的导航集。 试图修改返回的导航set，不管是直接的，通过其迭代器，或通过其subSet ， headSet ，或tailSet意见，导致UnsupportedOperationException 。

        如果指定的导航集是可序列化的，返回的导航集将是可序列化的。

        参数类型
        T - 集合中对象的类
        参数
        s - 要返回不可修改视图的导航集
        结果
        指定导航集的不可修改的视图
        从以下版本开始：
        1.8

      • unmodifiableList

        public static <T> List<T> unmodifiableList​(List<? extends T> list)
        返回指定列表的不可修改视图。 该方法允许模块向用户提供对内部列表的“只读”访问。 将返回的列表上的查询操作“读取”到指定的列表，并尝试修改返回的列表，无论是直接还是通过其迭代器，都会产生一个UnsupportedOperationException 。

        如果指定的列表是可序列化的，则返回的列表将是可序列化的。 类似地，如果指定的列表，返回的列表将实现RandomAccess 。

        参数类型
        T - 列表中对象的类
        参数
        list - 要返回不可修改视图的列表。
        结果
        指定列表的不可修改的视图。

      • unmodifiableMap

        public static <K,V> Map<K,V> unmodifiableMap​(Map<? extends K,? extends V> m)
        返回指定地图的不可修改视图。 该方法允许模块向用户提供对内部地图的“只读”访问。 将返回的地图上的查询操作“读取”到指定的地图，并尝试修改返回的地图，无论是直接的还是通过其集合视图，都会产生一个UnsupportedOperationException 。

        如果指定的地图是可序列化的，返回的地图将是可序列化的。

        参数类型
        K - 地图键的类
        V - 地图值的类
        参数
        m - 要返回不可修改视图的地图。
        结果
        指定地图的不可修改视图。

      • unmodifiableSortedMap

        public static <K,V> SortedMap<K,V> unmodifiableSortedMap​(SortedMap<K,? extends V> m)
        返回指定排序映射的不可修改视图。 该方法允许模块向用户提供对内部排序映射的“只读”访问。 对返回的排序映射查询操作“读取”到指定的排序映射。 试图修改返回的有序映射，无论是直接的，通过其收集的意见，或通过其subMap ， headMap ，或tailMap意见，导致UnsupportedOperationException 。

        如果指定的排序映射是可序列化的，返回的排序映射将是可序列化的。

        参数类型
        K - 地图键的类
        V - 地图值的类
        参数
        m - 要为其返回不可修改视图的排序映射。
        结果
        指定排序地图的不可修改视图。

      • unmodifiableNavigableMap

        public static <K,V> NavigableMap<K,V> unmodifiableNavigableMap​(NavigableMap<K,? extends V> m)
        返回指定可导航地图的不可修改视图。 这种方法允许模块向用户提供对内部可导航地图的“只读”访问。 在返回的导航地图上查询操作“通读”到指定的可导航地图。 试图修改返回的导航地图，无论是直接的，通过其收集的意见，或通过其subMap ， headMap ，或tailMap意见，导致UnsupportedOperationException 。

        如果指定的可导航地图是可序列化的，返回的导航地图将是可序列化的。

        参数类型
        K - 地图键的类
        V - 地图值的类
        参数
        m - 要返回不可修改的视图的导航地图
        结果
        指定可导航地图的不可修改视图
        从以下版本开始：
        1.8

      • synchronizedCollection

        public static <T> Collection<T> synchronizedCollection​(Collection<T> c)
        返回由指定集合支持的同步（线程安全）集合。 为了保证串行访问，重要的是通过返回的集合完成对后台集合的所有访问。

        至关重要的是，用户通过遍历时，在返回的集合手动同步Iterator ， Spliterator或者Stream ：

          Collection c = Collections.synchronizedCollection(myCollection);
     ...
  synchronized (c) {
      Iterator i = c.iterator(); // Must be in the synchronized block
      while (i.hasNext())
         foo(i.next());
  }
        不遵循此建议可能会导致非确定性行为。

        返回的集合不通过hashCode个equals传递给底层收集操作，而是依赖于Object的equals和hashCode方法。 在后台集合是集合或列表的情况下，必须保留这些操作的合同。

        如果指定的集合是可序列化的，则返回的集合将是可序列化的。

        参数类型
        T - 集合中对象的类
        参数
        c - 要在同步集合中“包装”的集合。
        结果
        指定集合的同步视图。

      • synchronizedSet

        public static <T> Set<T> synchronizedSet​(Set<T> s)
        返回由指定集合支持的同步（线程安全）集。 为了保证串行访问，通过返回的集合完成对后台集的所有访问都是至关重要的。

        至关重要的是，用户通过遍历时，在返回的集合手动同步Iterator ， Spliterator或者Stream ：

          Set s = Collections.synchronizedSet(new HashSet());
      ...
  synchronized (s) {
      Iterator i = s.iterator(); // Must be in the synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        不遵循此建议可能会导致非确定性行为。

        如果指定的集合是可序列化的，返回的集合将是可序列化的。

        参数类型
        T - 集合中对象的类
        参数
        s - 要在同步集中“包装”的集合。
        结果
        指定集合的同步视图。

      • synchronizedSortedSet

        public static <T> SortedSet<T> synchronizedSortedSet​(SortedSet<T> s)
        返回由指定的排序集支持的同步（线程安全）排序集。 为了保证串行访问，重要的是通过返回的排序集（或其视图）完成对后台排序集的所有访问。

        当务之急是用户遍历时，或任何其对返回的有序集合手动同步subSet ， headSet ，或tailSet通过意见Iterator ， Spliterator或者Stream ：

          SortedSet s = Collections.synchronizedSortedSet(new TreeSet());
      ...
  synchronized (s) {
      Iterator i = s.iterator(); // Must be in the synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        要么：
          SortedSet s = Collections.synchronizedSortedSet(new TreeSet());
  SortedSet s2 = s.headSet(foo);
      ...
  synchronized (s) {  // Note: s, not s2!!!
      Iterator i = s2.iterator(); // Must be in the synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        不遵循此建议可能会导致非确定性行为。

        如果指定的排序集是可序列化的，则返回的排序集将是可序列化的。

        参数类型
        T - 集合中对象的类
        参数
        s - 被排序的集合在同步的排序集中被“包装”。
        结果
        指定排序集合的同步视图。

      • synchronizedNavigableSet

        public static <T> NavigableSet<T> synchronizedNavigableSet​(NavigableSet<T> s)
        返回由指定的可导航集支持的同步（线程安全）可导航集。 为了保证串行访问，重要的是可以通过返回的可导航集（或其视图）来完成对后台导航集的所有访问。

        至关重要的是，在用户遍历时对返回的导航set手动同步，或它的任何subSet ， headSet ，或tailSet视图，经由Iterator ， Spliterator或Stream ：

          NavigableSet s = Collections.synchronizedNavigableSet(new TreeSet());
      ...
  synchronized (s) {
      Iterator i = s.iterator(); // Must be in the synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        要么：
          NavigableSet s = Collections.synchronizedNavigableSet(new TreeSet());
  NavigableSet s2 = s.headSet(foo, true);
      ...
  synchronized (s) {  // Note: s, not s2!!!
      Iterator i = s2.iterator(); // Must be in the synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        不遵循此建议可能会导致非确定性行为。

        如果指定的导航集是可序列化的，返回的导航集将是可序列化的。

        参数类型
        T - 集合中对象的类
        参数
        s - 可导航组在同步的可导航集合中被“包装”
        结果
        指定的导航集合的同步视图
        从以下版本开始：
        1.8

      • synchronizedList

        public static <T> List<T> synchronizedList​(List<T> list)
        返回由指定列表支持的同步（线程安全）列表。 为了保证串行访问，重要的是通过返回的列表来完成对后台列表的所有访问。

        至关重要的是，用户通过遍历时，它返回的列表上手动同步Iterator ， Spliterator或者Stream ：

          List list = Collections.synchronizedList(new ArrayList());
      ...
  synchronized (list) {
      Iterator i = list.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        不遵循此建议可能会导致非确定性行为。

        如果指定的列表是可序列化的，则返回的列表将是可序列化的。

        参数类型
        T - 列表中对象的类
        参数
        list - 要在同步列表中“包装”的列表。
        结果
        指定列表的同步视图。

      • synchronizedMap

        public static <K,V> Map<K,V> synchronizedMap​(Map<K,V> m)
        返回由指定地图支持的同步（线程安全）映射。 为了保证串行访问，重要的是通过返回的映射完成对后台映射的所有访问。

        至关重要的是，用户通过遍历它的任何集合视图时返回的地图上手动同步Iterator ， Spliterator或者Stream ：

          Map m = Collections.synchronizedMap(new HashMap());
      ...
  Set s = m.keySet();  // Needn't be in synchronized block
      ...
  synchronized (m) {  // Synchronizing on m, not s!
      Iterator i = s.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        不遵循此建议可能会导致非确定性行为。

        如果指定的地图是可序列化的，返回的地图将是可序列化的。

        参数类型
        K - 地图键的类
        V - 地图值的类
        参数
        m - 要在同步地图中“包裹”的地图。
        结果
        指定地图的同步视图。

      • synchronizedSortedMap

        public static <K,V> SortedMap<K,V> synchronizedSortedMap​(SortedMap<K,V> m)
        返回由指定的排序映射支持的同步（线程安全）排序映射。 为了保证串行访问，至关重要的是，通过返回的排序映射（或其视图）完成对后台排序映射的所有访问。

        当务之急是用户遍历其任何收集意见，或任何其集合视图时返回的有序地图上手动同步subMap ， headMap或者tailMap意见，通过Iterator ， Spliterator或者Stream ：

          SortedMap m = Collections.synchronizedSortedMap(new TreeMap());
      ...
  Set s = m.keySet();  // Needn't be in synchronized block
      ...
  synchronized (m) {  // Synchronizing on m, not s!
      Iterator i = s.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        要么：
          SortedMap m = Collections.synchronizedSortedMap(new TreeMap());
  SortedMap m2 = m.subMap(foo, bar);
      ...
  Set s2 = m2.keySet();  // Needn't be in synchronized block
      ...
  synchronized (m) {  // Synchronizing on m, not m2 or s2!
      Iterator i = s2.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        不遵循此建议可能会导致非确定性行为。

        如果指定的排序映射是可序列化的，返回的排序映射将是可序列化的。

        参数类型
        K - 地图键的类
        V - 地图值的类
        参数
        m - 要在同步的排序映射中“包装”的排序映射。
        结果
        指定排序地图的同步视图。

      • synchronizedNavigableMap

        public static <K,V> NavigableMap<K,V> synchronizedNavigableMap​(NavigableMap<K,V> m)
        返回由指定的可导航地图支持的同步（线程安全）可导航地图。 为了保证串行访问，重要的是可以通过返回的可导航地图（或其视图）来完成对后退导航地图的所有访问。

        当务之急是用户遍历其任何收集意见，或任何其集合视图时返回的导航地图上手动同步subMap ， headMap或者tailMap意见，通过Iterator ， Spliterator或者Stream ：

          NavigableMap m = Collections.synchronizedNavigableMap(new TreeMap());
      ...
  Set s = m.keySet();  // Needn't be in synchronized block
      ...
  synchronized (m) {  // Synchronizing on m, not s!
      Iterator i = s.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        要么：
          NavigableMap m = Collections.synchronizedNavigableMap(new TreeMap());
  NavigableMap m2 = m.subMap(foo, true, bar, false);
      ...
  Set s2 = m2.keySet();  // Needn't be in synchronized block
      ...
  synchronized (m) {  // Synchronizing on m, not m2 or s2!
      Iterator i = s.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
        不遵循此建议可能会导致非确定性行为。

        如果指定的可导航地图是可序列化的，返回的导航地图将是可序列化的。

        参数类型
        K - 地图键的类
        V - 地图值的类
        参数
        m - 可导航地图在同步的可导航地图中被“包裹”
        结果
        指定可导航地图的同步视图。
        从以下版本开始：
        1.8

      • checkedCollection

        public static <E> Collection<E> checkedCollection​(Collection<E> c,
                                                  Class<E> type)
        返回指定集合的动态类型安全视图。 任何插入错误类型的元素的尝试将导致立即ClassCastException 。 假设集合在生成动态类型安全视图之前不包含不正确类型的元素，并且通过视图发生对集合的所有后续访问，则可以确保集合不能包含不正确类型的元素。

        该语言中的泛型机制提供了编译时（静态）类型检查，但是可以用未经检查的转换来击败此机制。 通常这不是问题，因为编译器在所有这些未经检查的操作上发出警告。 然而，有一次静态类型检查是不够的。 例如，假设集合被传递给第三方库，并且库代码不会通过插入错误类型的元素来破坏集合。

        动态类型安全视图的另一个用途是调试。 假设一个程序失败，一个ClassCastException ，表示一个不正确的类型的元素被放入一个参数化的集合。 不幸的是，异常可以在插入错误元素之后的任何时间发生，因此它通常提供很少或没有关于问题的真正来源的信息。 如果问题是可重复的，可以通过临时修改程序来快速确定其来源，以便使用动态类型安全视图来包装该集合。 例如，这个声明：

           Collection<String> c = new HashSet<>();
        可以暂时用这个替换：
           Collection<String> c = Collections.checkedCollection( new HashSet<>(), String.class);
        再次运行该程序将导致它在将不正确类型的元素插入到集合中的位置失败，并清楚地标识出问题的根源。 一旦问题得到解决，修改的声明可能会恢复原来的。

        返回的集合不将hashCode并传递给底层集合等于操作，而是依赖于Object的equals和hashCode方法。 在后台集合是集合或列表的情况下，必须保留这些操作的合同。

        如果指定的集合是可序列化的，则返回的集合将是可序列化的。

        由于null被认为是任何引用类型的值，所以返回的集合允许在后台集合执行时插入空元素。

        参数类型
        E - 集合中对象的类
        参数
        c - 要为其返回动态类型安全视图的集合
        type - c允许持有的元素的类型
        结果
        指定集合的动态类型安全视图
        从以下版本开始：
        1.5

      • checkedQueue

        public static <E> Queue<E> checkedQueue​(Queue<E> queue,
                                        Class<E> type)
        返回指定队列的动态类型安全视图。 任何插入错误类型的元素的尝试都将立即产生ClassCastException 。 假设在生成动态类型安全视图之前，队列中不包含不正确类型的元素，并且通过视图进行对队列的所有后续访问，都保证该队列不能包含不正确类型的元素。

        关于使用动态类型安全视图的讨论可以在checkedCollection方法的文档中找到。

        如果指定的队列是可序列化的，则返回的队列将是可序列化的。

        由于null被认为是任何引用类型的值，所以返回的队列允许在支持队列中插入null元素。

        参数类型
        E - 队列中对象的类
        参数
        queue - 要为其返回动态类型安全视图的队列
        type - queue允许持有的元素的类型
        结果
        指定队列的动态类型安全视图
        从以下版本开始：
        1.8

      • checkedSet

        public static <E> Set<E> checkedSet​(Set<E> s,
                                    Class<E> type)
        返回指定集合的动态类型安全视图。 任何插入错误类型的元素的尝试将导致立即ClassCastException 。 假设一个集合在动态类型安全视图生成之前不包含不正确类型的元素，并且通过视图进行对集合的所有后续访问，则保证该集合不能包含不正确类型的元素。

        关于使用动态类型安全视图的讨论可以在checkedCollection方法的文档中找到。

        如果指定的集合是可序列化的，返回的集合将是可序列化的。

        由于null被认为是任何引用类型的值，所以返回的集允许在后台集合中插入空元素。

        参数类型
        E - 集合中对象的类
        参数
        s - 要为其返回动态类型安全视图的集合
        type - s允许持有的元素的类型
        结果
        指定集合的动态类型安全视图
        从以下版本开始：
        1.5

      • checkedSortedSet

        public static <E> SortedSet<E> checkedSortedSet​(SortedSet<E> s,
                                                Class<E> type)
        返回指定排序集的动态类型安全视图。 任何插入错误类型的元素的尝试都将立即产生ClassCastException 。 假设排序集在生成动态类型安全视图之前不包含不正确类型的元素，并且所有对排序集的后续访问都通过视图进行，则保证排序集不能包含不正确类型的元素。

        关于使用动态类型安全视图的讨论可以在checkedCollection方法的文档中找到。

        如果指定的排序集是可序列化的，则返回的排序集将是可序列化的。

        由于null被认为是任何引用类型的值，所以返回的排序集允许在后台排序集合时插入空元素。

        参数类型
        E - 集合中对象的类
        参数
        s - 要为其返回动态类型安全视图的排序集
        type - s允许持有的元素的类型
        结果
        指定排序集的动态类型安全视图
        从以下版本开始：
        1.5

      • checkedNavigableSet

        public static <E> NavigableSet<E> checkedNavigableSet​(NavigableSet<E> s,
                                                      Class<E> type)
        返回指定的可导航集的动态类型安全视图。 任何插入错误类型的元素的尝试将导致立即ClassCastException 。 假设可导航集在生成动态类型安全视图之前不包含不正确类型的元素，并且通过视图进行对导航集的所有后续访问，则可以确保导航集不能包含不正确类型的元素。

        关于使用动态类型安全视图的讨论可以在checkedCollection方法的文档中找到。

        如果指定的导航集是可序列化的，返回的导航集将是可序列化的。

        由于null被认为是任何引用类型的值，所以返回的导航集允许在后台排序集合时插入空元素。

        参数类型
        E - 集合中对象的类
        参数
        s - 要为其返回动态类型安全视图的导航集
        type - s允许持有的元素的类型
        结果
        指定可导航集的动态类型安全视图
        从以下版本开始：
        1.8

      • checkedList

        public static <E> List<E> checkedList​(List<E> list,
                                      Class<E> type)
        返回指定列表的动态类型安全视图。 任何插入错误类型的元素的尝试都将立即产生ClassCastException 。 假设在生成动态类型安全视图之前，列表中不包含不正确类型的元素，并且通过视图进行对列表的所有后续访问，都保证列表不能包含不正确类型的元素。

        有关使用动态类型安全视图的讨论可以在checkedCollection方法的文档中找到。

        如果指定的列表是可序列化的，则返回的列表将是可序列化的。

        由于null被认为是任何引用类型的值，返回的列表允许在后备列表中插入空元素。

        参数类型
        E - 列表中对象的类
        参数
        list - 要为其返回动态类型安全视图的列表
        type - list允许持有的元素的类型
        结果
        指定列表的动态类型安全视图
        从以下版本开始：
        1.5

      • checkedMap

        public static <K,V> Map<K,V> checkedMap​(Map<K,V> m,
                                        Class<K> keyType,
                                        Class<V> valueType)
        返回指定地图的动态类型安全视图。 任何尝试插入其键或值类型错误的映射将导致立即ClassCastException 。 类似地，任何尝试修改当前与密钥相关联的值将导致立即ClassCastException ，无论是直接通过地图本身进行修改，还是通过从地图的entry set视图获取的一个2706143419311实例。

        假设地图在生成动态类型安全视图之前不包含不正确键入的键或值，并且通过视图（或其集合视图之一）进行对地图的所有后续访问，都保证地图不能包含错误键入的键或值。

        关于使用动态类型安全视图的讨论可以在checkedCollection方法的文档中找到。

        如果指定的地图是可序列化的，返回的地图将是可序列化的。

        由于null被认为是任何引用类型的值，返回的映射允许每当支持地图执行时插入空值或值。

        参数类型
        K - 地图键的类
        V - 地图值的类
        参数
        m - 要为其返回动态类型安全视图的地图
        keyType - m允许持有的密钥的类型
        valueType - m允许持有的值的类型
        结果
        指定地图的动态类型安全视图
        从以下版本开始：
        1.5

      • checkedSortedMap

        public static <K,V> SortedMap<K,V> checkedSortedMap​(SortedMap<K,V> m,
                                                    Class<K> keyType,
                                                    Class<V> valueType)
        返回指定排序映射的动态类型安全视图。 任何尝试插入其键或值具有错误类型的映射将导致立即ClassCastException 。 类似地，任何修改当前与密钥相关联的值的尝试都将立即产生ClassCastException ，无论是通过地图本身直接尝试修改，还是通过从地图的entry set视图获取的一个2706143422977实例。

        假设地图在生成动态类型安全视图之前不包含不正确键入的键或值，并且通过视图（或其集合视图之一）进行对地图的所有后续访问，都保证地图不能包含错误键入的键或值。

        有关使用动态类型安全视图的讨论可以在checkedCollection方法的文档中找到。

        如果指定的地图是可序列化的，返回的地图将是可序列化的。

        由于null被认为是任何引用类型的值，返回的映射允许每当支持地图执行时插入空值或值。

        参数类型
        K - 地图键的类
        V - 地图值的类
        参数
        m - 要为其返回动态类型安全视图的地图
        keyType - m允许的密钥类型
        valueType - m允许持有的值的类型
        结果
        指定地图的动态类型安全视图
        从以下版本开始：
        1.5

      • checkedNavigableMap

        public static <K,V> NavigableMap<K,V> checkedNavigableMap​(NavigableMap<K,V> m,
                                                          Class<K> keyType,
                                                          Class<V> valueType)
        返回指定可导航地图的动态类型安全视图。 任何尝试插入其键或值的类型错误的映射将导致立即ClassCastException 。 类似地，任何修改当前与密钥相关联的值的尝试将导致立即ClassCastException ，无论是通过地图本身直接尝试修改，还是通过从地图entry set视图获取的2706143433384实例。

        假设地图在生成动态类型安全视图之前不包含不正确键入的键或值，并且通过视图（或其集合视图之一）进行对地图的所有后续访问，都保证地图不能包含错误键入的键或值。

        关于使用动态类型安全视图的讨论可以在checkedCollection方法的文档中找到。

        如果指定的地图是可序列化的，返回的地图将是可序列化的。

        由于null被认为是任何引用类型的值，所以返回的映射允许每当支持地图执行时插入空值或值。

        参数类型
        K - 地图键的类型
        V - 地图值的类型
        参数
        m - 要为其返回动态类型安全视图的地图
        keyType - m允许持有的密钥的类型
        valueType - m允许持有的值的类型
        结果
        指定地图的动态类型安全视图
        从以下版本开始：
        1.8

      • emptyIterator

        public static <T> Iterator<T> emptyIterator​()
        返回没有元素的迭代器。 更确切地说，
        • hasNext总是返回false 。
        • next总是抛出NoSuchElementException 。
        • remove总是抛出IllegalStateException 。

        允许这种方法的实现，但不是必需的，从多个调用返回相同的对象。

        参数类型
        T - 迭代器中的元素类型，如果有的话
        结果
        一个空的迭代器
        从以下版本开始：
        1.7

      • emptyListIterator

        public static <T> ListIterator<T> emptyListIterator​()
        返回没有元素的列表迭代器。 更确切地说，
        • hasNext和hasPrevious总是返回false 。
        • next和previous总是抛出NoSuchElementException 。
        • remove和set总是抛出IllegalStateException 。
        • add总是抛出UnsupportedOperationException 。
        • nextIndex总是返回0 。
        • previousIndex总是返回-1 。

        允许这种方法的实现，但不是必需的，从多个调用返回相同的对象。

        参数类型
        T - 迭代器中的元素的类型，如果有的话
        结果
        一个空列表迭代器
        从以下版本开始：
        1.7

      • emptyEnumeration

        public static <T> Enumeration<T> emptyEnumeration​()
        返回没有元素的枚举。 更确切地说，
        • hasMoreElements总是返回false 。
        • nextElement总是抛出NoSuchElementException 。

        允许这种方法的实现，但不是必需的，从多个调用返回相同的对象。

        参数类型
        T - 枚举中的对象的类
        结果
        一个空的枚举
        从以下版本开始：
        1.7

      • emptySet

        public static final <T> Set<T> emptySet​()
        返回一个空集（immutable）。 这个集是可序列化的。 与类似命名的字段不同，该方法被参数化。

        此示例说明了获取空集合的类型安全方式：

          Set<String> s = Collections.emptySet();
        Implementation Note:
        该方法的实现不需要为每个调用创建一个单独的Set对象。 使用此方法可能具有与使用相似名称的字段相当的成本。 （与此方法不同，该字段不提供类型安全性。）
        参数类型
        T - 集合中对象的类
        结果
        空集
        从以下版本开始：
        1.5
        另请参见：
        EMPTY_SET

      • emptySortedSet

        public static <E> SortedSet<E> emptySortedSet​()
        返回一个空的排序集（immutable）。 这个集是可序列化的。

        此示例说明了获取空排序集的类型安全方式：

           SortedSet<String> s = Collections.emptySortedSet();
        Implementation Note:
        该方法的实现不需要为每个调用创建一个单独的 SortedSet对象。
        参数类型
        E - 元素的类型，如果有的话，在集合中
        结果
        空排序集
        从以下版本开始：
        1.8

      • emptyNavigableSet

        public static <E> NavigableSet<E> emptyNavigableSet​()
        返回一个空导航集（immutable）。 这个集是可序列化的。

        此示例说明了获取空导航集的类型安全方式：

           NavigableSet<String> s = Collections.emptyNavigableSet();
        Implementation Note:
        该方法的实现不需要为每个调用创建一个单独的 NavigableSet对象。
        参数类型
        E - 元素的类型，如果有的话，在集合中
        结果
        空导航集
        从以下版本开始：
        1.8

      • emptyList

        public static final <T> List<T> emptyList​()
        返回空列表（immutable）。 此列表是可序列化的。

        此示例说明了获取空列表的类型安全方式：

          List<String> s = Collections.emptyList();
        Implementation Note:
        该方法的实现不需要为每个调用创建一个单独的List对象。 使用此方法可能具有与使用相似名称的字段相当的成本。 （与此方法不同，该字段不提供类型安全性。）
        参数类型
        T - 列表中的元素类型，如果有的话
        结果
        一个空的不变名单
        从以下版本开始：
        1.5
        另请参见：
        EMPTY_LIST

      • emptyMap

        public static final <K,V> Map<K,V> emptyMap​()
        返回空的地图（不可变）。 这张地图是可序列化的。

        此示例说明了获取空地图的类型安全方式：

          Map<String, Date> s = Collections.emptyMap();
        Implementation Note:
        该方法的实现不需要为每个调用创建一个单独的Map对象。 使用此方法可能具有与使用相似名称的字段相当的成本。 （与此方法不同，该字段不提供类型安全性。）
        参数类型
        K - 地图键的类
        V - 地图值的类
        结果
        一张空地图
        从以下版本开始：
        1.5
        另请参见：
        EMPTY_MAP

      • emptySortedMap

        public static final <K,V> SortedMap<K,V> emptySortedMap​()
        返回空的排序映射（immutable）。 这张地图是可序列化的。

        此示例说明了获取空地图的类型安全方式：

           SortedMap<String, Date> s = Collections.emptySortedMap();
        Implementation Note:
        该方法的实现不需要为每个调用创建一个单独的 SortedMap对象。
        参数类型
        K - 地图键的类
        V - 地图值的类
        结果
        一个空的排序地图
        从以下版本开始：
        1.8

      • emptyNavigableMap

        public static final <K,V> NavigableMap<K,V> emptyNavigableMap​()
        返回空导航地图（不可变）。 这张地图是可序列化的。

        此示例说明了获取空地图的类型安全方式：

           NavigableMap<String, Date> s = Collections.emptyNavigableMap();
        Implementation Note:
        该方法的实现不需要为每个调用创建一个单独的 NavigableMap对象。
        参数类型
        K - 地图键的类
        V - 地图值的类
        结果
        一个空的导航地图
        从以下版本开始：
        1.8

      • singleton

        public static <T> Set<T> singleton​(T o)
        返回一个只包含指定对象的不可变组。 返回的集合是可序列化的。
        参数类型
        T - 集合中对象的类
        参数
        o - 要存储在返回集合中的唯一对象。
        结果
        一个不可变的集合，只包含指定的对象。

      • singletonList

        public static <T> List<T> singletonList​(T o)
        返回一个只包含指定对象的不可变列表。 返回的列表是可序列化的。
        参数类型
        T - 列表中对象的类
        参数
        o - 要存储在返回列表中的唯一对象。
        结果
        一个只包含指定对象的不可变列表。
        从以下版本开始：
        1.3

      • singletonMap

        public static <K,V> Map<K,V> singletonMap​(K key,
                                          V value)
        返回一个不可变的地图，只将指定的键映射到指定的值。 返回的地图是可序列化的。
        参数类型
        K - 地图键的类
        V - 地图值的类
        参数
        key - 存储在返回地图中的唯一键。
        value - 返回地图映射的值 key 。
        结果
        一个不可变的地图，只包含指定的键值映射。
        从以下版本开始：
        1.3

      • nCopies

        public static <T> List<T> nCopies​(int n,
                                  T o)
        返回由指定对象的n副本组成的不可变列表。 新分配的数据对象很小（它包含对数据对象的单个引用）。 此方法与List.addAll方法一起增长列表很有用。 返回的列表是可序列化的。
        参数类型
        T - 要复制的对象的类和返回列表中的对象的类。
        参数
        n - 返回列表中的元素数。
        o - 在返回的列表中重复出现的元素。
        结果
        一个不可变的列表，由指定对象的 n副本组成。
        异常
        IllegalArgumentException - 如果是 n < 0
        另请参见：
        List.addAll(Collection) ， List.addAll(int, Collection)

      • reverseOrder

        public static <T> Comparator<T> reverseOrder​()
        返回一个对实现Comparable接口的对象集合的自然排序相反的比较器。 （自然排序是由对象自己的compareTo方法施加的顺序。）这样可以实现一个简单的成语，用于以反向自然顺序排列（或维护）实现Comparable接口的对象的集合（或数组）。 例如，假设a是一个字符串数组。 然后：
          Arrays.sort(a, Collections.reverseOrder());
        以反字典（字母顺序）排列阵列。

        返回的比较器是可序列化的。

        参数类型
        T - 比较对象比较对象的类
        结果
        一个比较器， Comparable实现 Comparable接口的对象集合施加了 自然排序的相反。
        另请参见：
        Comparable

      • reverseOrder

        public static <T> Comparator<T> reverseOrder​(Comparator<T> cmp)
        返回一个比较器，它强制指定比较器的反向排序。 如果指定的比较器是null ，则该方法相当于reverseOrder() （换句话说，它返回一个比较器，它对实现Comparable接口的对象集合施加了自然排序的相反）。

        返回的比较器是可串行化的（假设指定的比较器也可串行化或null ）。

        参数类型
        T - 比较对象比较对象的类
        参数
        cmp - 比较者的排序要由返回的比较器反转，或 null
        结果
        一个比较器，它强制指定比较器的反向排序。
        从以下版本开始：
        1.5

      • enumeration

        public static <T> Enumeration<T> enumeration​(Collection<T> c)
        返回指定集合的枚举。 这提供了与需要枚举作为输入的传统API的互操作性。

        从调用返回的迭代器Enumeration.asIterator()不支持从指定的集合中删除元素。 这是必要的，以避免无意中增加返回的枚举的能力。

        参数类型
        T - 集合中对象的类
        参数
        c - 要返回枚举的集合。
        结果
        指定集合的枚举。
        另请参见：
        Enumeration

      • list

        public static <T> ArrayList<T> list​(Enumeration<T> e)
        返回一个数组列表，其中包含由枚举返回的顺序由指定的枚举返回的元素。 这种方法提供返回枚举的旧API和需要集合的新API之间的互操作性。
        参数类型
        T - 枚举返回的对象的类
        参数
        e - 枚举为返回的数组列表提供元素
        结果
        包含指定枚举返回的元素的数组列表。
        从以下版本开始：
        1.4
        另请参见：
        Enumeration ， ArrayList

      • frequency

        public static int frequency​(Collection<?> c,
                            Object o)
        返回指定集合中与指定对象相等的元素数。 更正式地，返回集合中的元素数量e ，使得Objects.equals(o, e) 。
        参数
        c - 其中确定频率的 o
        o - 要确定频率的对象
        结果
        c中元素的 c等于 o
        异常
        NullPointerException - 如果 c为空
        从以下版本开始：
        1.5

      • disjoint

        public static boolean disjoint​(Collection<?> c1,
                               Collection<?> c2)
        如果两个指定的集合没有共同的元素，则返回true 。

        如果这种方法用于不符合Collection的一般合同的集合，则必须Collection 。 实施方案可以选择在任一集合中迭代并测试另一集合中的包含（或执行任何等效计算）。 如果任何一个收集使用非标准平等的测试（如做一个SortedSet ，其顺序是不是等号 ，或者按键的兼容 IdentityHashMap ），两个集合必须使用相同的非标准相等测试，或者这种方法的结果是不确定的。

        当使用对它们可能包含的元素有限制的集合时，还必须小心。 允许集合实现为涉及其认为不合格的元素的任何操作抛出异常。 为了绝对安全，指定的集合只应包含两个集合的符合条件的元素。

        请注意，允许在两个参数中传递相同的集合，在这种情况下，当且仅当集合为空时，该方法将返回true 。

        参数
        c1 - 一个集合
        c2 - 一个集合
        结果
        true如果两个指定的集合没有共同的元素。
        异常
        NullPointerException - 如果任一集合是 null 。
        NullPointerException - 如果一个集合包含一个null元素，而null不是其他集合的合格元素。 （ optional ）
        ClassCastException - 如果一个集合包含一个不符合其他集合类型的元素。 （ optional ）
        从以下版本开始：
        1.5

      • addAll

        @SafeVarargs
public static <T> boolean addAll​(Collection<? super T> c,
                                 T... elements)
        将所有指定的元素添加到指定的集合。 要添加的元素可以单独指定或作为数组指定。 这种方便方法的行为与c.addAll(Arrays.asList(elements))相同，但是在大多数实现中，该方法可能运行得更快。

        单独指定元素时，此方法为现有集合添加一些元素提供了便利的方法：

          Collections.addAll(flavors, "Peaches 'n Plutonium", "Rocky Racoon");
        参数类型
        T - 要添加和收集的元素的类
        参数
        c -到其中的收集 elements将被插入
        elements - 要插入到 c的元素
        结果
        true如果集合由于调用而更改
        异常
        UnsupportedOperationException - 如果 c不支持 add操作
        NullPointerException - 如果 elements包含一个或多个空值，并且 c不允许空元素，或者如果 c或 elements为 null
        IllegalArgumentException - 如果某些属性在 elements中的值无法将其添加到 c
        从以下版本开始：
        1.5
        另请参见：
        Collection.addAll(Collection)

      • newSetFromMap

        public static <E> Set<E> newSetFromMap​(Map<E,Boolean> map)
        返回由指定地图支持的集合。 结果集显示与背景映射相同的排序，并发和性能特征。 在本质上，此工厂方法提供了一种Set对应于任何执行Map实现。 在已经具有相应的Set实现（例如HashMap或TreeMap ）的Map实现上，不需要使用此方法。

        在该方法返回的集合上的每个方法调用将导致在后备映射或其keySet视图上的一个方法调用，但有一个例外。 addAll方法在支持地图上作为put调用的顺序实现。

        在调用此方法时，指定的映射必须为空，并且在此方法返回后不能直接访问。 如果映射创建为空，直接传递给此方法，并且不保留对映射的引用，则保证这些条件，如以下代码片段所示：

          Set<Object> weakHashSet = Collections.newSetFromMap(
        new WeakHashMap<Object, Boolean>());
        参数类型
        E - 映射关键字和返回集合中对象的类
        参数
        map - 支持地图
        结果
        该集合由地图支持
        异常
        IllegalArgumentException - 如果 map不为空
        从以下版本开始：
        1.6

      • asLifoQueue

        public static <T> Queue<T> asLifoQueue​(Deque<T> deque)
        返回Deque作为先进先出（ Lifo ） Queue的视图 。 方法add被映射到push ， remove映射到pop等。 当您想使用需要Queue的方法但您需要Queue订购时，此视图可能很有用。

        通过此方法返回的队列上的每个方法调用都将在支持deque上完成一个方法调用，但有一个例外。 addAll方法作为支持deque的addFirst调用的序列实现。

        参数类型
        T - 在deque中的对象的类
        参数
        deque - deque
        结果
        队列
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Comparator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Comparator<T>

  • 参数类型
    T - 可以由此比较器进行比较的对象的类型
    所有已知实现类：
    Collator ， RuleBasedCollator
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Comparator<T>
    比较功能，对一些对象的集合施加了一个整体排序 。 比较器可以传递到排序方法（如Collections.sort或Arrays.sort ），以便对排序顺序进行精确控制。 比较器也可用于控制某些数据结构的顺序（如sorted sets或sorted maps ），或为不具有natural ordering2的对象集合提供排序。

    当且仅当c.compare(e1, e2)==0具有与c.compare(e1, e2)==0相同的e1.equals(e2)值e1和e2中的S比较器c对一组元件S施加的排序被称为与等于一致 。

    当使用能够强制排序不一致的比较器时，应注意使用排序集（或排序图）。 假设具有显式比较器c的排序集合（或排序映射）与从集合S绘制的元素（或键） S 。 如果c对S施加的排序与equals不一致，则排序集（或排序映射）将表现为“奇怪”。 特别是排序的集合（或排序的映射）将违反用于集合（或映射）的通用合同，其按照equals定义。

    例如，假设一个将两个元件a和b使得(a.equals(b) && c.compare(a, b) != 0)到空TreeSet与比较c 。 因为a和b与树集的观点不相等，所以第二个add操作将返回true（并且树集的大小将增加），即使这与Set.add方法的规范相反。

    注意：这通常是一个好主意比较，也能实现java.io.Serializable ，因为它们可能被用来作为排序的序列化数据结构的方法（比如TreeSet ， TreeMap ）。 为了使数据结构成功进行序列化，比较器（如果提供）必须实现Serializable 。

    用于限定所施加的顺序 ，给定的比较器的数学倾斜，该关系 c强加一组给定对象的S是：

      {(x, y) such that c.compare(x, y) <= 0}.
    这个总订单的商是：
      {(x, y) such that c.compare(x, y) == 0}.
    它从合同紧跟compare ，该商数是一个等价关系 S ，并且实行排序是一个总的顺序 S 。 当我们说c对S施加的排序与等于一致时 ，我们意味着排序的商是由对象' equals(Object)方法定义的等价关系：
      {(x, y) such that x.equals(y)}.

    与Comparable不同，比较器可以可选地允许比较空参数，同时保持对等价关系的要求。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Comparable ， Serializable

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      int compare​(T o1, T o2)
      比较其两个参数的顺序。
      static <T,U extends Comparable<? super U>>
      Comparator<T>             		comparing​(Function<? super T,? extends U> keyExtractor)
      接受提取功能Comparable从类型排序键T ，并返回一个Comparator<T> ，通过那种关键的。
      static <T,U> Comparator<T> comparing​(Function<? super T,? extends U> keyExtractor, Comparator<? super U> keyComparator)
      接受从类型T提取排序键的功能，并返回一个Comparator<T> ，使用指定的Comparator比较该排序键。
      static <T> Comparator<T> comparingDouble​(ToDoubleFunction<? super T> keyExtractor)
      接受提取功能 double从类型排序键 T ，并返回一个 Comparator<T> ，通过那种关键的。
      static <T> Comparator<T> comparingInt​(ToIntFunction<? super T> keyExtractor)
      接受从类型 T中提取 int排序键的功能，并返回一个按该排序键进行比较的 Comparator<T> 。
      static <T> Comparator<T> comparingLong​(ToLongFunction<? super T> keyExtractor)
      接受提取功能 long从类型排序键 T ，并返回一个 Comparator<T> ，通过那种关键的。
      boolean equals​(Object obj)
      指示某个其他对象是否等于此比较器。
      static <T extends Comparable<? super T>>
      Comparator<T>             		naturalOrder​()
      返回一个以自然顺序比较Comparable对象的比较器。
      static <T> Comparator<T> nullsFirst​(Comparator<? super T> comparator)
      返回一个非常友好的比较器， null考虑为小于非空值。
      static <T> Comparator<T> nullsLast​(Comparator<? super T> comparator)
      返回一个比较友好的比较器， null设置为大于非空值。
      default Comparator<T> reversed​()
      返回一个比较器，强制该比较器的相反顺序。
      static <T extends Comparable<? super T>>
      Comparator<T>             		reverseOrder​()
      返回一个与 自然排序相反的比较器。
      default Comparator<T> thenComparing​(Comparator<? super T> other)
      用另一个比较器返回一个字典顺序比较器。
      default <U extends Comparable<? super U>>
      Comparator<T>             		thenComparing​(Function<? super T,? extends U> keyExtractor)
      返回具有提取 Comparable排序键的功能的字典顺序比较器。
      default <U> Comparator<T> thenComparing​(Function<? super T,? extends U> keyExtractor, Comparator<? super U> keyComparator)
      返回具有提取要与给定的 Comparator进行比较的键的函数的词典顺序比较器。
      default Comparator<T> thenComparingDouble​(ToDoubleFunction<? super T> keyExtractor)
      返回具有提取 double排序键的功能的字典顺序比较器。
      default Comparator<T> thenComparingInt​(ToIntFunction<? super T> keyExtractor)
      返回具有提取 int排序键的功能的字典顺序比较器。
      default Comparator<T> thenComparingLong​(ToLongFunction<? super T> keyExtractor)
      返回具有提取 long排序键的功能的字典顺序比较器。

    • 方法详细信息

      • compare

        int compare​(T o1,
            T o2)
        比较其两个参数的顺序。 返回负整数，零或正整数，因为第一个参数小于，等于或大于第二个参数。

        实施者必须确保sgn(compare(x, y)) == -sgn(compare(y, x))全部为x和y 。 （这意味着当且仅当compare(y, x)引发异常时， compare(x, y)必须抛出异常。）

        实施者还必须确保关系是可传递的： ((compare(x, y)>0) && (compare(y, z)>0))意味着compare(x, z)>0 。

        最后，实施者必须确保compare(x, y)==0意味着sgn(compare(x, z))==sgn(compare(y, z))全部为z 。

        一般情况，但不是严格要求(compare(x, y)==0) == (x.equals(y)) 。 一般而言，任何违反这种情况的比较方都应清楚地表明这一点。 推荐的语言是“注意：该比较器强制与等于”不一致的排序“。

        在前面的描述中，符号sgn( 表达 )表示数学符号函数，其被定义为返回之一-1 ， 0 ，或1分别根据表达式的值是否为负，零或正。

        参数
        o1 - 要比较的第一个对象。
        o2 - 要比较的第二个对象。
        结果
        第一个参数的负整数，零或正整数小于等于或大于第二个参数。
        异常
        NullPointerException - 如果参数为空，并且此比较器不允许空参数
        ClassCastException - 如果参数的类型阻止它们被比较器进行比较。

      • equals

        boolean equals​(Object obj)
        指示某个其他对象是否等于此比较器。 该方法必须符合Object.equals(Object)的一般合同。 另外， 只有指定的对象也是一个比较器，这个方法只能返回true ，它和这个比较器的顺序相同。 因此， comp1.equals(comp2)意味着sgn(comp1.compare(o1, o2))==sgn(comp2.compare(o1, o2))的每个对象的参考o1和o2 。

        请注意， 始终安全不要覆盖Object.equals(Object) 。 然而，在某些情况下，覆盖此方法可以通过允许程序确定两个不同的比较器施加相同的顺序来提高性能。

        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true只有指定的对象也是一个比较器，并且它施加与这个比较器相同的顺序。
        另请参见：
        Object.equals(Object) ， Object.hashCode()

      • reversed

        default Comparator<T> reversed​()
        返回一个比较器，强制该比较器的相反顺序。
        结果
        一个比较器，使比较器的顺序相反。
        从以下版本开始：
        1.8

      • thenComparing

        default Comparator<T> thenComparing​(Comparator<? super T> other)
        用另一个比较器返回一个字典顺序比较器。 如果此Comparator认为两个元件相等，即compare(a, b) == 0 ， other被用来确定顺序。

        如果指定的比较器也可串行化，则返回的比较器是可序列化的。

        API Note:
        例如，为了对基于长度进行排序String ，然后对不区分大小写的自然排序进行排序，比较器可以使用以下代码组成，
           Comparator<String> cmp = Comparator.comparingInt(String::length) .thenComparing(String.CASE_INSENSITIVE_ORDER);
        参数
        other - 当比较器比较两个相等的对象时要使用的另一个比较器。
        结果
        一个由这个和另一个比较器组成的字典顺序比较器
        异常
        NullPointerException - 如果参数为空。
        从以下版本开始：
        1.8

      • thenComparing

        default <U> Comparator<T> thenComparing​(Function<? super T,? extends U> keyExtractor,
                                        Comparator<? super U> keyComparator)
        返回具有提取要与给定的 Comparator比较的键的函数的词典顺序比较器。
        实现要求：
        此默认实现的行为就像 thenComparing(comparing(keyExtractor, cmp)) 。
        参数类型
        U - 排序键的类型
        参数
        keyExtractor - 用于提取排序键的函数
        keyComparator - 用于比较排序键的 Comparator
        结果
        一个字典顺序比较器由该比较器组成，然后对由KeyExtractor函数提取的关键字进行比较
        异常
        NullPointerException - 如果任一参数为空。
        从以下版本开始：
        1.8
        另请参见：
        comparing(Function, Comparator) ， thenComparing(Comparator)

      • thenComparing

        default <U extends Comparable<? super U>> Comparator<T> thenComparing​(Function<? super T,? extends U> keyExtractor)
        返回具有提取 Comparable排序键的功能的字典顺序比较器。
        实现要求：
        此默认实现的行为就像 thenComparing(comparing(keyExtractor)) 。
        参数类型
        U - Comparable排序键的类型
        参数
        keyExtractor - 用于提取Comparable排序键的功能
        结果
        一个字典顺序比较器由此组成，然后是Comparable排序键。
        异常
        NullPointerException - 如果参数为空。
        从以下版本开始：
        1.8
        另请参见：
        comparing(Function) ， thenComparing(Comparator)

      • thenComparingInt

        default Comparator<T> thenComparingInt​(ToIntFunction<? super T> keyExtractor)
        返回具有提取 int排序键的功能的字典顺序比较器。
        实现要求：
        此默认实现的行为就像 thenComparing(comparingInt(keyExtractor)) 。
        参数
        keyExtractor - 用于提取整数排序键的函数
        结果
        一个字典顺序比较器由此组成，然后是 int排序键
        异常
        NullPointerException - 如果参数为空。
        从以下版本开始：
        1.8
        另请参见：
        comparingInt(ToIntFunction) ， thenComparing(Comparator)

      • thenComparingLong

        default Comparator<T> thenComparingLong​(ToLongFunction<? super T> keyExtractor)
        返回具有提取 long排序键的功能的字典顺序比较器。
        实现要求：
        此默认实现的行为就像 thenComparing(comparingLong(keyExtractor)) 。
        参数
        keyExtractor - 用于提取长排序键的函数
        结果
        一个字典顺序比较器由此组成，然后是 long排序键
        异常
        NullPointerException - 如果参数为空。
        从以下版本开始：
        1.8
        另请参见：
        comparingLong(ToLongFunction) ， thenComparing(Comparator)

      • thenComparingDouble

        default Comparator<T> thenComparingDouble​(ToDoubleFunction<? super T> keyExtractor)
        返回具有提取 double排序键的功能的字典顺序比较器。
        实现要求：
        此默认实现的行为就像 thenComparing(comparingDouble(keyExtractor)) 。
        参数
        keyExtractor - 用于提取双排序键的函数
        结果
        一个字典顺序比较器由此组成，然后是 double排序键
        异常
        NullPointerException - 如果参数为空。
        从以下版本开始：
        1.8
        另请参见：
        comparingDouble(ToDoubleFunction) ， thenComparing(Comparator)

      • reverseOrder

        static <T extends Comparable<? super T>> Comparator<T> reverseOrder​()
        返回一个与自然排序相反的比较器。

        返回的比较器是可序列化，并引发NullPointerException比较时null 。

        参数类型
        T - 要比较的Comparable类型的元素
        结果
        一个对 Comparable对象施加与 自然排序相反的比较器。
        从以下版本开始：
        1.8
        另请参见：
        Comparable

      • naturalOrder

        static <T extends Comparable<? super T>> Comparator<T> naturalOrder​()
        返回一个以自然顺序比较Comparable对象的比较器。

        返回的比较器是可序列化，并引发NullPointerException比较时null 。

        参数类型
        T - 要比较的Comparable类型的元素
        结果
        一个对 Comparable对象施加 自然排序的比较器。
        从以下版本开始：
        1.8
        另请参见：
        Comparable

      • nullsFirst

        static <T> Comparator<T> nullsFirst​(Comparator<? super T> comparator)
        返回一个非常友好的比较器， null视为小于非空值。 当两者都是null ，它们被认为是相等的。 如果两者均为非空值，则使用指定的Comparator来确定顺序。 如果指定的比较器是null ，则返回的比较器将所有非空值视为相等。

        如果指定的比较器可串行化，则返回的比较器是可序列化的。

        参数类型
        T - 要比较的元素的类型
        参数
        comparator - a Comparator用于比较非空值
        结果
        一个将 null考虑为小于非空的比较器，并将非空对象与所提供的 Comparator进行比较。
        从以下版本开始：
        1.8

      • nullsLast

        static <T> Comparator<T> nullsLast​(Comparator<? super T> comparator)
        返回一个比较友好的比较器， null设置为大于非空值。 当两者都是null ，它们被认为是相等的。 如果两者均为非空值，则使用指定的Comparator来确定顺序。 如果指定的比较器是null ，则返回的比较器将所有非空值都认为是相等的。

        如果指定的比较器可串行化，则返回的比较器是可序列化的。

        参数类型
        T - 要比较的元素的类型
        参数
        comparator - 用于比较非空值的 Comparator
        结果
        一个比较器，认为 null大于非空，并将非空对象与所提供的 Comparator进行比较。
        从以下版本开始：
        1.8

      • comparing

        static <T,U> Comparator<T> comparing​(Function<? super T,? extends U> keyExtractor,
                                     Comparator<? super U> keyComparator)
        接受从类型T中提取排序键的T ，并返回一个Comparator<T> ，该数据使用指定的Comparator进行比较。

        如果指定的功能和比较器都可串行化，则返回的比较器是可序列化的。

        API Note:
        例如，要获得Comparator比较Person对象的姓氏忽略大小写差异，
           Comparator<Person> cmp = Comparator.comparing( Person::getLastName, String.CASE_INSENSITIVE_ORDER);
        参数类型
        T - 要比较的元素的类型
        U - 排序键的类型
        参数
        keyExtractor - 用于提取排序键的函数
        keyComparator - 用于比较排序键的 Comparator
        结果
        比较器使用指定的 Comparator与提取的密钥进行比较
        异常
        NullPointerException - 如果任一参数为空
        从以下版本开始：
        1.8

      • comparing

        static <T,U extends Comparable<? super U>> Comparator<T> comparing​(Function<? super T,? extends U> keyExtractor)
        接受从T类型中提取Comparable排序键的T ，并返回一个按该排序键进行比较的Comparator<T> 。

        如果指定的功能也可串行化，则返回的比较器是可序列化的。

        API Note:
        例如，要获得一个Comparator ，它比较了Person对象的姓氏，
           Comparator<Person> byLastName = Comparator.comparing(Person::getLastName);
        参数类型
        T - 要比较的元素的类型
        U - Comparable排序键的类型
        参数
        keyExtractor - 用于提取Comparable排序键的功能
        结果
        比较器，其被提取的密钥进行比较
        异常
        NullPointerException - 如果参数为空
        从以下版本开始：
        1.8

      • comparingInt

        static <T> Comparator<T> comparingInt​(ToIntFunction<? super T> keyExtractor)
        接受提取的一个函数int从类型分类键T ，并返回一个Comparator<T> ，通过该排序关键字进行比较。

        如果指定的功能也可串行化，则返回的比较器是可序列化的。

        参数类型
        T - 要比较的元素的类型
        参数
        keyExtractor - 用于提取整数排序键的函数
        结果
        比较器，其被提取的密钥进行比较
        异常
        NullPointerException - 如果参数为空
        从以下版本开始：
        1.8
        另请参见：
        comparing(Function)

      • comparingLong

        static <T> Comparator<T> comparingLong​(ToLongFunction<? super T> keyExtractor)
        接受提取功能long从类型排序键T ，并返回一个Comparator<T> ，通过那种关键的。

        如果指定的功能也可串行化，则返回的比较器是可序列化的。

        参数类型
        T - 要比较的元素的类型
        参数
        keyExtractor - 用于提取长排序键的函数
        结果
        比较器，其被提取的密钥进行比较
        异常
        NullPointerException - 如果参数为null
        从以下版本开始：
        1.8
        另请参见：
        comparing(Function)

      • comparingDouble

        static <T> Comparator<T> comparingDouble​(ToDoubleFunction<? super T> keyExtractor)
        接受从类型T中提取double排序键的T ，并返回一个按该排序键进行比较的Comparator<T> 。

        如果指定的功能也可串行化，则返回的比较器是可序列化的。

        参数类型
        T - 要比较的元素的类型
        参数
        keyExtractor - 用于提取双排序键的函数
        结果
        比较器，其被提取的密钥进行比较
        异常
        NullPointerException - 如果参数为空
        从以下版本开始：
        1.8
        另请参见：
        comparing(Function)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConcurrentModificationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class ConcurrentModificationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.util.ConcurrentModificationException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    DirectoryIteratorException

    public class ConcurrentModificationException
extends RuntimeException
    当不允许这样的修改时，可以通过检测到对象的并发修改的方法来抛出此异常。

    例如，一个线程通常不允许修改集合，而另一个线程正在遍历它。 一般来说，在这种情况下，迭代的结果是未定义的。 某些迭代器实现（包括由JRE提供的所有通用集合实现的实现）可能会选择在检测到此行为时抛出此异常。 这样做的迭代器被称为故障快速迭代器，因为它们快速而干净地失败，而是在未来未确定的时间冒着任意的非确定性行为。

    请注意，此异常并不总是表示对象已被不同的线程同时修改。 如果单个线程发出违反对象合同的方法调用序列，则该对象可能会抛出此异常。 例如，如果线程在使用故障快速迭代器迭代集合时直接修改集合，则迭代器将抛出此异常。

    请注意，故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的操作ConcurrentModificationException抛出ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： ConcurrentModificationException应仅用于检测错误。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， Iterator ， Spliterator ， ListIterator ， Vector ， LinkedList ， HashSet ， Hashtable ， TreeMap ， AbstractList ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConcurrentModificationException​()
      构造一个没有详细消息的ConcurrentModificationException。
      ConcurrentModificationException​(String message)
      构造具有指定详细消息的 ConcurrentModificationException 。
      ConcurrentModificationException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      ConcurrentModificationException​(Throwable cause)
      构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ConcurrentModificationException

        public ConcurrentModificationException​()
        构造一个没有详细消息的ConcurrentModificationException。

      • ConcurrentModificationException

        public ConcurrentModificationException​(String message)
        构造具有指定详细消息的 ConcurrentModificationException 。
        参数
        message - 有关此异常的详细消息。

      • ConcurrentModificationException

        public ConcurrentModificationException​(Throwable cause)
        构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause 。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，表示原因不存在或未知。）
        从以下版本开始：
        1.7

      • ConcurrentModificationException

        public ConcurrentModificationException​(String message,
                                       Throwable cause)
        构造一个新的异常与指定的详细信息和原因。

        请注意，与cause相关联的详细消息不会自动并入此异常的详细消息。

        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Currency (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Currency

  • java.lang.Object
    • java.util.Currency
  • All Implemented Interfaces:
    Serializable

    public final class Currency
extends Object
implements Serializable
    代表货币。 货币由其ISO 4217货币代码确定。 请访问ISO web site了解更多信息。

    该课程的设计使得任何给定货币都不会有多个Currency实例。 因此，没有公共建设者。 您可以使用getInstance方法获取Currency实例。

    用户可以通过系统属性java.util.currency.data取代Java运行时货币数据。 如果定义了该系统属性，则其值是属性文件的位置，其内容分别是ISO 3166国家代码和ISO 4217货币数据的键/值对。 价值部分由货币的三个ISO 4217值组成，即字母代码，数字代码和次要单位。 这三个ISO 4217值用逗号分隔。 以'＃'开头的行被视为注释行。 如果用户需要指定切换日期来指示新数据何时生效，则可以为每个货币条目指定可选的UTC时间戳。 时间戳附加到货币属性的末尾，并使用逗号作为分隔符。 如果UTC时间戳存在且有效，则如果当前UTC日期晚于类加载时指定的日期，JRE将仅使用新的货币属性。 时间戳的格式必须为ISO 8601格式： 'yyyy-MM-dd'T'HH:mm:ss' 。 例如，

    #Sample currency properties
    JP=JPZ,999,0

    将取代日本的货币数据。

    #Sample currency properties with cutover date
    JP=JPZ,999,0,2014-01-01T00:00:00

    如果在2014年1月1日以后载入Currency班， Currency GMT，将取代日本的货币数据。

    在遇到语法错误的条目时，将忽略该条目，并处理文件中其余的条目。 对于存在重复的国家/地区代码条目的情况，该Currency的货币信息的行为是未定义的，并且处理文件中的其余条目。

    建议使用BigDecimal课程，同时处理Currency或货币价值，因为它可以更好地处理浮点数及其操作。

    从以下版本开始：
    1.4
    另请参见：
    BigDecimal ， Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static Set<Currency> getAvailableCurrencies​()
      获得一组可用的货币。
      String getCurrencyCode​()
      获得此货币的ISO 4217货币代码。
      int getDefaultFractionDigits​()
      获取与该货币一起使用的默认小数位数。
      String getDisplayName​()
      获取适用于默认 DISPLAY区域设置显示此货币的名称。
      String getDisplayName​(Locale locale)
      获取适用于显示指定区域设置的货币的名称。
      static Currency getInstance​(String currencyCode)
      返回给定货币代码的 Currency实例。
      static Currency getInstance​(Locale locale)
      返回给定区域的国家/地区的 Currency实例。
      int getNumericCode​()
      返回此货币的ISO 4217数字代码。
      String getNumericCodeAsString​()
      返回此货币的3位数字ISO 4217数字代码，为 String 。
      String getSymbol​()
      获取默认的 DISPLAY区域设置的此货币的符号。
      String getSymbol​(Locale locale)
      获取指定区域设置的货币符号。
      String toString​()
      返回此货币的ISO 4217货币代码。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getInstance

        public static Currency getInstance​(String currencyCode)
        返回给定货币代码的 Currency实例。
        参数
        currencyCode - 货币的ISO 4217代码
        结果
        给定货币代码的 Currency实例
        异常
        NullPointerException - 如果 currencyCode为空
        IllegalArgumentException - 如果 currencyCode不是支持的ISO 4217代码。

      • getInstance

        public static Currency getInstance​(Locale locale)
        返回给定语言环境的国家/地区的Currency实例。 语言环境的语言和变体组件将被忽略。 随着国家改变货币，结果可能会随时间而变化。 例如，对于欧洲货币联盟的原始成员国，该方法将2001年12月31日之前的旧货币和2002年1月1日的欧元兑换为各国当地时间。

        该方法对于没有货币的地区（如南极洲）返回null 。

        参数
        locale - 需要一个 Currency实例的国家/地区
        结果
        给定地区的国家的 Currency实例，或 null
        异常
        NullPointerException - 如果 locale是 null
        IllegalArgumentException - 如果给定的国家/地区 locale不是支持的ISO 3166国家代码。

      • getAvailableCurrencies

        public static Set<Currency> getAvailableCurrencies​()
        获得一组可用的货币。 返回的一组货币包含所有可用的货币，可能包括代表过时的ISO 4217代码的货币。 可以修改该集合，而不影响运行时间中的可用货币。
        结果
        一套可用货币。 如果运行时没有货币可用，则返回的集合为空。
        从以下版本开始：
        1.7

      • getCurrencyCode

        public String getCurrencyCode​()
        获得此货币的ISO 4217货币代码。
        结果
        该货币的ISO 4217货币代码。

      • getSymbol

        public String getSymbol​()
        获取默认的DISPLAY区域设置的货币符号。 例如，对于美元，如果默认语言环境是美国，则符号为“$”，而对于其他语言环境则可能为“US $”。 如果不能确定符号，则返回ISO 4217货币代码。

        这相当于调用getSymbol(Locale.getDefault(Locale.Category.DISPLAY)) 。

        结果
        该货币的符号默认为 DISPLAY区域设置

      • getSymbol

        public String getSymbol​(Locale locale)
        获取指定区域设置的货币符号。 例如，对于美元，如果指定的区域设置为美国，则符号为“$”，而对于其他区域设置，则可能为“US $”。 如果不能确定符号，则返回ISO 4217货币代码。
        参数
        locale - 需要此货币显示名称的区域设置
        结果
        指定地区的货币符号
        异常
        NullPointerException - 如果 locale为空

      • getDefaultFractionDigits

        public int getDefaultFractionDigits​()
        获取与该货币一起使用的默认小数位数。 请注意，小数位数与货币的ISO 4217的次要单位相同。 例如，欧元的小数位数的默认数字是2，而对日元则是0。对于伪货币，如IMF特别提款权，返回-1。
        结果
        与该货币一起使用的默认分数数字

      • getNumericCode

        public int getNumericCode​()
        返回此货币的ISO 4217数字代码。
        结果
        该货币的ISO 4217数字代码
        从以下版本开始：
        1.7

      • getNumericCodeAsString

        public String getNumericCodeAsString​()
        以String返回此货币的3位数字ISO 4217数字代码。 与getNumericCode()不同，它将数字代码返回为int ，该方法总是返回数字代码作为3位数字。 例如，数值32将被返回为“032”，数值为6将返回为“006”。
        结果
        该货币的3位数字ISO 4217数字代码为 String
        从以下版本开始：
        9

      • getDisplayName

        public String getDisplayName​()
        获取适用于默认DISPLAY区域设置显示此货币的名称。 如果找不到适用于默认语言环境的显示名称，则返回ISO 4217货币代码。

        这相当于调用getDisplayName(Locale.getDefault(Locale.Category.DISPLAY)) 。

        结果
        该货币的显示名称为默认的 DISPLAY区域设置
        从以下版本开始：
        1.7

      • getDisplayName

        public String getDisplayName​(Locale locale)
        获取适用于显示指定区域设置的货币的名称。 如果找不到指定区域设置的合适的显示名称，则返回ISO 4217货币代码。
        参数
        locale - 需要为此货币显示名称的区域设置
        结果
        指定区域设置的此货币的显示名称
        异常
        NullPointerException - 如果 locale为空
        从以下版本开始：
        1.7

      • toString

        public String toString​()
        返回此货币的ISO 4217货币代码。
        重写：
        toString在 Object
        结果
        该货币的ISO 4217货币代码
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Date (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Date

  • java.lang.Object
    • java.util.Date
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Comparable<Date>
    已知直接子类：
    Date ， Time ， Timestamp

    public class Date
extends Object
implements Serializable, Cloneable, Comparable<Date>
    Date类代表了一个特定的时间，以毫秒的精度。

    在JDK 1.1之前， Date有两个附加功能。 它允许将日期解释为年，月，日，小时，分钟和第二个值。 它还允许格式化和解析日期字符串。 不幸的是，这些功能的API不适合国际化。 从JDK 1.1开始， Calendar类应用于在日期和时间字段之间进行转换，而DateFormat类应用于格式化和解析日期字符串。 Date中的相应方法Date被弃用。

    尽管Date类旨在反映协调的世界时间（UTC），但根据Java虚拟机的主机环境的不同，它可能无法正确执行。 几乎所有的现代操作系统都假设在所有情况下1天= 24×60×60 = 86400秒。 然而，在UTC的时候，大概每一两年会有一秒钟的时间，叫做“闰秒”。 闰秒总是作为一天的最后一秒，总是在12月31日或6月30日。例如，1995年的最后一分钟是61秒，由于增加了闰秒。 大多数计算机时钟不够准确，不能反映出闰秒的区别。

    一些计算机标准是根据格林尼治标准时间（GMT）定义的，相当于世界时间（UT）。 GMT是标准的“民用”名称; UT是同一标准的“科学”名称。 UTC和UT之间的区别是UTC是基于原子钟，UT是基于天文观测，对于所有的实际目的来说，这是一个看不见的细毛。 因为地球的旋转不均匀（减速并以复杂的方式加速），UT并不总是均匀地流动。 根据需要，将时差引入到UTC中，以使UT在UT1的0.9秒内保持UTC，这是UT的版本，并应用了某些修正。 还有其他的时间和日期系统; 例如，基于卫星的全球定位系统（GPS）使用的时间尺度与UTC同步，但不对闰秒进行调整。 进一步信息的一个有趣的来源是美国海军天文台（USNO）：

         http://www.usno.navy.mil/USNO

    以及关于“时间系统”的材料：

         http://www.usno.navy.mil/USNO/time/master-clock/systems-of-time

    其具有包括UT，UT1和UTC在内的各种不同时间系统的描述。

    在接收或返回年，月，日，小时，分钟和秒值的Date类的所有方法中，使用以下表示：

    • y年代表整数y - 1900 。
    • 一个月由0到11的整数表示; 0是1月，1是2月，等等; 11月12日。
    • 日期（月的一天）以通常的方式从1到31的整数表示。
    • 一小时由0到23之间的整数表示。因此，从午夜到凌晨1点的时间是小时0，从中午到下午1点的小时是12小时。
    • 一般以0〜59的整数表示。
    • 第二个由0到61的整数表示; 值60和61仅发生在闰秒上，甚至仅在实际上正确跟踪闰秒的Java实现中发生。 由于目前引入闰秒的方式，在同一分钟内不会发生两个闰秒，但是本规范遵循ISO C的日期和时间约定。

    在所有情况下，为这些目的而提供的方法的论证不必在指定范围内; 例如，可以将日期指定为1月32日，并将其解释为2月1日。

    从以下版本开始：
    1.0
    另请参见：
    DateFormat ， Calendar ， TimeZone ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Date​()
      分配一个 Date对象并对其进行初始化，以便它表示分配的时间，以最接近的毫秒为单位。
      Date​(int year, int month, int date)
      已过时。
      从JDK 1.1版开始，由Calendar.set(year + 1900, month, date)或GregorianCalendar(year + 1900, month, date) 。
      Date​(int year, int month, int date, int hrs, int min)
      已过时。
      自JDK 1.1版起，由Calendar.set(year + 1900, month, date, hrs, min)或GregorianCalendar(year + 1900, month, date, hrs, min) 。
      Date​(int year, int month, int date, int hrs, int min, int sec)
      已过时。
      截至JDK 1.1版，由Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec) 。
      Date​(long date)
      分配一个 Date对象，并将其初始化为表示从标准基准时间（称为“时代”）即1970年1月1日00:00:00 GMT起的指定毫秒数。
      Date​(String s)
      已过时。
      从JDK 1.1版开始，替换为DateFormat.parse(String s) 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean after​(Date when)
      测试此日期是否在指定日期之后。
      boolean before​(Date when)
      测试此日期是否在指定日期之前。
      Object clone​()
      返回此对象的副本。
      int compareTo​(Date anotherDate)
      比较两个日期进行订购。
      boolean equals​(Object obj)
      比较两个日期来平等。
      static Date from​(Instant instant)
      从 Instant对象获取 Date一个实例。
      int getDate​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.DAY_OF_MONTH)替代。
      int getDay​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.DAY_OF_WEEK)替代。
      int getHours​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.HOUR_OF_DAY)代替。
      int getMinutes​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.MINUTE)替代。
      int getMonth​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.MONTH)替代。
      int getSeconds​()
      已过时。
      截至JDK 1.1版，由Calendar.get(Calendar.SECOND)替代。
      long getTime​()
      返回自1970年1月1日以来，由 Date对象表示的00:00:00 GMT的毫秒数。
      int getTimezoneOffset​()
      已过时。
      从JDK 1.1版开始，由-(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000)代替。
      int getYear​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.YEAR) - 1900替换。
      int hashCode​()
      返回此对象的哈希码值。
      static long parse​(String s)
      已过时。
      从JDK 1.1版开始，由DateFormat.parse(String s)替代。
      void setDate​(int date)
      已过时。
      从JDK 1.1版开始，由Calendar.set(Calendar.DAY_OF_MONTH, int date)替代。
      void setHours​(int hours)
      已过时。
      从JDK 1.1版开始，由Calendar.set(Calendar.HOUR_OF_DAY, int hours)替代。
      void setMinutes​(int minutes)
      已过时。
      截至JDK 1.1版，由Calendar.set(Calendar.MINUTE, int minutes)替代。
      void setMonth​(int month)
      已过时。
      从JDK 1.1版开始，代之以Calendar.set(Calendar.MONTH, int month) 。
      void setSeconds​(int seconds)
      已过时。
      从JDK 1.1版开始，替换为Calendar.set(Calendar.SECOND, int seconds) 。
      void setTime​(long time)
      将此 Date对象设置为1970年1月1日00:00:00 GMT后的 time毫秒的时间点。
      void setYear​(int year)
      已过时。
      从JDK 1.1版开始，替换为Calendar.set(Calendar.YEAR, year + 1900) 。
      String toGMTString​()
      已过时。
      从JDK 1.1版开始，用DateFormat.format(Date date)替换，使用GMT TimeZone 。
      Instant toInstant​()
      将此 Date对象转换为 Instant 。
      String toLocaleString​()
      已过时。
      从JDK 1.1版开始，由DateFormat.format(Date date)替代。
      String toString​()
      将此 Date对象转换为 String的形式：
      static long UTC​(int year, int month, int date, int hrs, int min, int sec)
      已过时。
      截至JDK 1.1版，由Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec) ，使用UTC TimeZone ，其次是Calendar.getTime().getTime() 。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Date

        public Date​()
        分配一个 Date对象，并初始化它，以便它代表它被分配的时间，测量到最接近的毫秒。
        另请参见：
        System.currentTimeMillis()

      • Date

        public Date​(long date)
        分配一个 Date对象，并将其初始化为表示从标准基准时间（称为“时代”）即1970年1月1日00:00:00 GMT起的指定毫秒数。
        参数
        date - 1970年1月1日00:00:00 GMT以来的毫秒数。
        另请参见：
        System.currentTimeMillis()

      • Date

        @Deprecated
public Date​(int year,
            int month,
            int date)
        已过时。 截至JDK 1.1版，由Calendar.set(year + 1900, month, date)或GregorianCalendar(year + 1900, month, date) 。
        分配一个 Date对象，并初始化它，这样它代表午夜，本地时间，在由指定的一天的开始 year ， month ，并 date参数。
        参数
        year - 年减1900。
        month - 0-11之间的月份。
        date - 这个月的日子在1-31之间。
        另请参见：
        Calendar

      • Date

        @Deprecated
public Date​(int year,
            int month,
            int date,
            int hrs,
            int min)
        已过时。 从JDK 1.1版开始，替换为Calendar.set(year + 1900, month, date, hrs, min)或GregorianCalendar(year + 1900, month, date, hrs, min) 。
        分配一个 Date对象，并初始化它，这样它代表的由指定的分钟的开始瞬间 year ， month ， date ， hrs ，并 min参数，在本地时区。
        参数
        year - 年减1900。
        month - 0-11之间的月份。
        date - 1-31之间的月份。
        hrs - 0-23之间的时间。
        min - 0-59之间的分钟。
        另请参见：
        Calendar

      • Date

        @Deprecated
public Date​(int year,
            int month,
            int date,
            int hrs,
            int min,
            int sec)
        已过时。 从JDK 1.1版开始，替换为Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec) 。
        分配一个 Date对象，并初始化它，这样它代表的由指定的第二个开始的瞬间 year ， month ， date ， hrs ， min ，并 sec参数，在本地时区。
        参数
        year - 年减1900。
        month - 0-11之间的月份。
        date - 1月31日之间的月份。
        hrs - 0-23之间的时间。
        min - 0-59之间的分钟。
        sec - 0-59之间的秒数。
        另请参见：
        Calendar

      • Date

        @Deprecated
public Date​(String s)
        已过时。 从JDK 1.1版开始，由DateFormat.parse(String s)替代。
        分配 Date对象并对其进行初始化，以便它表示由字符串 s指示的日期和时间，这被解释为 parse(java.lang.String)方法。
        参数
        s - 日期的字符串表示形式。
        另请参见：
        DateFormat ， parse(java.lang.String)

    • 方法详细信息

      • clone

        public Object clone​()
        返回此对象的副本。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • UTC

        @Deprecated
public static long UTC​(int year,
                       int month,
                       int date,
                       int hrs,
                       int min,
                       int sec)
        已过时。 从JDK 1.1版开始，由Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec)替换，使用UTC TimeZone ，其次是Calendar.getTime().getTime() 。
        根据参数确定日期和时间。 参数被解释为一年，一个月，一天中的一天，一小时内的分钟，一分钟内的Date与具有六个参数的Date构造函数完全相同，但参数相对于UTC解释而不是当地时区。 返回的时间表示为从时代（1970年1月1日00:00:00 GMT）开始的距离（以毫秒为单位）。
        参数
        year - 年减1900。
        month - 0-11之间的月份。
        date - 1月31日之间的月份。
        hrs - 0-23之间的时间。
        min - 0-59之间的分钟。
        sec - 0-59之间的秒数。
        结果
        自1970年1月1日以来，由参数指定的日期和时间的00:00:00 GMT的毫秒数。
        另请参见：
        Calendar

      • parse

        @Deprecated
public static long parse​(String s)
        已过时。 自JDK 1.1版起，由DateFormat.parse(String s)取代。
        尝试将字符串s解释为日期和时间的表示。 如果尝试成功，则返回的时间表示为距离时间（1970年1月1日00:00:00 GMT）的距离（以毫秒为单位）。 如果尝试失败，则抛出IllegalArgumentException 。

        它接受很多语法; 特别是它识别IETF标准日期语法：“Sat，12 Aug 1995 13:30:00 GMT”。 它也了解美国大陆时区缩写，但对于一般使用，应使用时区偏移：“星期六，1995年8月12日13:30:00 GMT + 0430”（格林威治以西30分钟子午线）。 如果未指定时区，则假定为本地时区。 GMT和UTC被认为是等效的。

        字符串s处理，寻找感兴趣的数据。 任何s内的任何材料，在ASCII括号内的字符(和)都将被忽略。 括号可以嵌套。 否则， s中允许的唯一字符是这些ASCII字符：

         abcdefghijklmnopqrstuvwxyz
 ABCDEFGHIJKLMNOPQRSTUVWXYZ
 0123456789,+-:/
        和空格字符。

        十进制数字的连续序列被视为十进制数：

        • 如果一个数字前面有+或- ，一年已经被识别，则该数字是时区偏移量。 如果数字小于24，则以小时计算。 否则，它被视为以分钟为单位的偏移量，以24小时格式表示，没有标点符号。 前面的一个-表示向西偏移。 时区偏移总是相对于UTC（格林威治）。 因此，例如， -5出现的-5意味着“格林威治以西五小时”，而+0430将意味着“格林威治以东四小时三十分钟”。 它允许字符串指定GMT ， UT ，或UTC冗余，例如， GMT-5或utc+0430 。
        • 如果满足以下条件之一，则该数字被视为年数：
          • 数字等于或大于70，后跟空格，逗号，斜杠或字符串结尾
          • 这个数字不到70，这个月的一个月和一个月都已经被认可了
          如果确认的年数小于100，则被解释为相对于在Date类初始化之前的80年以前和19年之后的一个世纪的缩写年。 调整年数后，从其中减去1900。 例如，如果今年是1999年，那么19到99年的年份假定为1919年至1999年，而从0到18的年份假定为2000年至2018年。注意，这与年度解释略有不同小于100，用于SimpleDateFormat 。
        • 如果数字后面是一个冒号，它被认为是一个小时，除非一个小时已经被识别，在这种情况下，它被认为是一分钟。
        • 如果号码后面是斜杠，则视为一个月份（除以1，以产生0到11 ），除非已被确认为一个月，否则被视为一天的月份。
        • 如果数字后面是空格，逗号，连字符或字符串结尾，那么如果一小时已被识别但不是一分钟，则视为分钟; 否则，如果一分钟已被确认但不是第二次，则被视为第二个; 否则被视为一个月的一天。

        连续的字母序列被视为一个单词，并处理如下：

        • 匹配AM （忽略大小写）的单词将被忽略（但如果小时尚未被识别或小于1或大于12 ，则解析失败）。
        • 与PM匹配的PM （忽略大小写）会在小时内添加12 （但如果一小时未识别或小于1或大于12则解析失败）。
        • 任何与任何前缀为SUNDAY, MONDAY, TUESDAY, WEDNESDAY, THURSDAY, FRIDAY或SATURDAY匹配的SUNDAY, MONDAY, TUESDAY, WEDNESDAY, THURSDAY, FRIDAY忽略大小写都将被忽略。 例如， sat, Friday, TUE和Thurs被忽略。
        • 否则，任何与任何前缀JANUARY, FEBRUARY, MARCH, APRIL, MAY, JUNE, JULY, AUGUST, SEPTEMBER, OCTOBER, NOVEMBER或DECEMBER相匹配的单词忽略不计，并按照此处给出的顺序进行考虑，将被确认为指定一个月份，并转换为一个数字（ 0至11 ）。 例如， aug, Sept, april和NOV被确认为月。 所以是Ma ，被认定为MARCH ，而不是MAY 。
        • 任何与GMT, UT或UTC匹配的GMT, UT忽略大小写，都被视为指向UTC。
        • 任何匹配EST, CST, MST或PST ，无视情况，分别被认为是指北美时区，分别是格林威治以西五，六，七，八小时。 匹配EDT, CDT, MDT或PDT （忽略大小写）的任何单词在夏令时分别被识别为指向相同的时区。

        一旦扫描了整个字符串，它将以两种方式之一转换为时间结果。 如果已经识别出时区或时区偏移量，则以UTC为单位解释年，月，日，月，时，分和秒，然后应用时区偏移。 否则，在本地时区解释年，月，日，时，分，秒。

        参数
        s - 要解析为日期的字符串。
        结果
        从1970年1月1日00:00:00 GMT以字符串参数表示的毫秒数。
        另请参见：
        DateFormat

      • getYear

        @Deprecated
public int getYear​()
        已过时。 从JDK 1.1版开始，代之以Calendar.get(Calendar.YEAR) - 1900 。
        返回一个值，该值是从包含或以该 Date对象表示的时刻开始的年份减去1900，如本地时区所解释的那样。
        结果
        这个日期代表的年份，减去1900年。
        另请参见：
        Calendar

      • setYear

        @Deprecated
public void setYear​(int year)
        已过时。 从JDK 1.1版开始，替换为Calendar.set(Calendar.YEAR, year + 1900) 。
        将此Date对象的年份设置为指定值加上1900.该Date对象进行修改，以便它表示指定年份内的时间点，月，日，小时，分钟和秒与之前相同，如当地时区所解释。 （当然，如果日期是例如2月29日，而这一年是非闰年，则新日期将被视为是在3月1日。）
        参数
        year - 年值。
        另请参见：
        Calendar

      • getMonth

        @Deprecated
public int getMonth​()
        已过时。 从JDK 1.1版开始，由Calendar.get(Calendar.MONTH)替代。
        返回表示包含或以该Date对象表示的时刻开始的月份的数字。 返回的值在0和11之间，值为0代表一月。
        结果
        该日期的代表月份。
        另请参见：
        Calendar

      • setMonth

        @Deprecated
public void setMonth​(int month)
        已过时。 从JDK 1.1版开始，由Calendar.set(Calendar.MONTH, int month)替代。
        将此日期的月份设置为指定的值。 该Date对象被修改，以便它表示指定月份内的时间点，年份，日期，小时，分钟和秒与之前相同，如本地时区所解释的。 例如，如果日期是10月31日，而月份定为6月，则新日期将被视为7月1日，因为6月只有30天。
        参数
        month - 0-11之间的月份值。
        另请参见：
        Calendar

      • getDate

        @Deprecated
public int getDate​()
        已过时。 从JDK 1.1版开始，由Calendar.get(Calendar.DAY_OF_MONTH)替换。
        返回此Date对象所代表的月份。 返回的值在1和31之间，代表本月的日期，包含或开始于此Date对象表示的时间，如本地时区所解释的。
        结果
        这个日期的一个月的日子。
        另请参见：
        Calendar

      • setDate

        @Deprecated
public void setDate​(int date)
        已过时。 从JDK 1.1版开始，由Calendar.set(Calendar.DAY_OF_MONTH, int date)取代。
        将此Date对象的月份日期设置为指定的值。 这个Date对象被修改，以便它表示在当地时区解释的指定日期内的时间点，年，月，小时，分钟和秒与之前相同。 例如，如果日期是4月30日，日期设置为31，则将被视为5月1日，因为4月只有30天。
        参数
        date - 月的日期值在1-31之间。
        另请参见：
        Calendar

      • getDay

        @Deprecated
public int getDay​()
        已过时。 从JDK 1.1版开始，替换为Calendar.get(Calendar.DAY_OF_WEEK) 。
        返回由此日期表示的星期几。 返回的值（ 0 =星期日， 1 =星期二， 2 =星期二， 3 =星期三， 4 =星期二， 5 =星期五， 6 =星期六）表示包含或以此时间表示的时刻开始的星期几Date对象，如当地时区所解释。
        结果
        这个日期的星期几。
        另请参见：
        Calendar

      • getHours

        @Deprecated
public int getHours​()
        已过时。 从JDK 1.1版开始，由Calendar.get(Calendar.HOUR_OF_DAY)替代。
        返回此Date对象所表示的小时Date 。 返回的值是一个数字（ 0至23 ），代表一天内包含或以该Date对象表示的时刻开始的时间，如本地时区所解释的。
        结果
        这个日期代表的时间。
        另请参见：
        Calendar

      • setHours

        @Deprecated
public void setHours​(int hours)
        已过时。 从JDK 1.1版开始，由Calendar.set(Calendar.HOUR_OF_DAY, int hours)替代。
        将此Date对象的小时设置为指定的值。 这个Date对象被修改，以便它表示一天中指定的小时内的时间点，年份，月份，日期，分钟和秒与之前相同，如本地时区所解释的。
        参数
        hours - 小时值。
        另请参见：
        Calendar

      • getMinutes

        @Deprecated
public int getMinutes​()
        已过时。 从JDK 1.1版开始，由Calendar.get(Calendar.MINUTE)替代。
        返回由当前时区解释的此日期所表示的小时数。 返回的值在0和59之间。
        结果
        由该日期表示的小时数。
        另请参见：
        Calendar

      • setMinutes

        @Deprecated
public void setMinutes​(int minutes)
        已过时。 从JDK 1.1版开始，由Calendar.set(Calendar.MINUTE, int minutes)替代。
        将此Date对象的分钟数设置为指定的值。 该Date对象被修改，以便它表示在本地时区解释的指定分钟内的时间点内的年份，月份，日期，时间和秒与之前相同的时间点。
        参数
        minutes - 分钟的值。
        另请参见：
        Calendar

      • getSeconds

        @Deprecated
public int getSeconds​()
        已过时。 从JDK 1.1版开始，由Calendar.get(Calendar.SECOND)替代。
        返回由此日期表示的分钟数。 返回的值在0和61之间。 值60和61只能在那些考虑到闰秒的Java虚拟机上发生。
        结果
        由此日期表示的分钟秒数。
        另请参见：
        Calendar

      • setSeconds

        @Deprecated
public void setSeconds​(int seconds)
        已过时。 从JDK 1.1版开始，由Calendar.set(Calendar.SECOND, int seconds)替代。
        将此Date的秒数设置为指定值。 该Date对象被修改，以便它表示在分钟的指定秒钟内的时间点，年份，月份，日期，小时和分钟与之前相同，如当地时区所解释的。
        参数
        seconds - 秒值。
        另请参见：
        Calendar

      • getTime

        public long getTime​()
        返回自1970年1月1日以来，由 Date对象表示的00:00:00 GMT的毫秒数。
        结果
        自1970年1月1日起，以此日期为准的00:00:00 GMT的毫秒数。

      • setTime

        public void setTime​(long time)
        设置此 Date对象以表示1970年1月1日00:00:00 GMT之后的 time毫秒的时间点。
        参数
        time - 毫秒数。

      • before

        public boolean before​(Date when)
        测试此日期是否在指定日期之前。
        参数
        when - 一个日期。
        结果
        true当且仅当这个Date对象所表示的时刻是严格早于when表示的when ; false否则。
        异常
        NullPointerException - 如果 when为空。

      • after

        public boolean after​(Date when)
        测试此日期是否在指定日期之后。
        参数
        when - 一个日期。
        结果
        true当且仅当该Date对象所表示的时刻严格晚于when表示的when ; 否则为false 。
        异常
        NullPointerException - 如果 when为空。

      • equals

        public boolean equals​(Object obj)
        比较两个日期来平等。 结果是true当且仅当参数不是null并且是一个Date对象，表示与该对象相同的时间点（毫秒）。

        因此，当且仅当getTime方法返回相同的long值时，两个Date对象相等。

        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; 否则为false 。
        另请参见：
        getTime()

      • compareTo

        public int compareTo​(Date anotherDate)
        比较两个日期进行订购。
        Specified by:
        compareTo在接口 Comparable<Date>
        参数
        anotherDate - 要比较的 Date 。
        结果
        值为0如果参数Date等于此Date; 如果此日期在Date参数之前，该值小于0 ; 如果此日期在Date参数0则值大于0 。
        异常
        NullPointerException - 如果 anotherDate为空。
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回此对象的哈希码值。 结果是由getTime()方法返回的原始long值的两半的异或。 也就是说，哈希码是表达式的值：

 (int)(this.getTime()^(this.getTime() >>> 32))
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        将此Date对象转换为String的形式：
         dow mon dd hh:mm:ss zzz yyyy
        哪里：
        • dow是星期几（ Sun, Mon, Tue, Wed, Thu, Fri, Sat ）。
        • mon是月（ Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec ）。
        • dd是这个月的日子（ 01到31 ），两位十进制数字。
        • hh是一天中的小时（ 00到23 ），两位十进制数字。
        • mm是一小时内的分钟（ 00到59 ），作为两位十进制数字。
        • ss是分钟内的第二个（ 00到61 ，作为两位十进制数字。
        • zzz是时区（可能反映夏令时）。 标准时区缩写包括方法parse识别的缩写。 如果时区信息不可用，那么zzz是空的 - 也就是说，它没有任何字符。
        • yyyy为yyyy ，为四位十进制数字。
        重写：
        toString在 Object
        结果
        此日期的字符串表示形式。
        另请参见：
        toLocaleString() ， toGMTString()

      • toLocaleString

        @Deprecated
public String toLocaleString​()
        已过时。 从JDK 1.1版开始，替换为DateFormat.format(Date date) 。
        以实现依赖的形式创建此Date对象的字符串表示形式。 意图是，Java应用程序的用户应该熟悉该表单，无论它可能正在运行。 意图与ISO C的strftime()功能支持的“ %c ”格式strftime() 。
        结果
        此日期的字符串表示形式，使用区域设置约定。
        另请参见：
        DateFormat ， toString() ， toGMTString()

      • toGMTString

        @Deprecated
public String toGMTString​()
        已过时。 从JDK 1.1版开始，用DateFormat.format(Date date)替换，使用GMT TimeZone 。
        创建此Date对象的字符串表示形式：
         d mon yyyy hh:mm:ss GMT
        哪里：
        • d是一个月的日期（ 1到31 ），一个或两个十进制数字。
        • mon是月（ Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec ）。
        • yyyy是年份，四位十进制数字。
        • hh是一天中的小时（ 00到23 ），两位十进制数字。
        • mm是一小时内的分钟（ 00至59 ），为两位十进制数字。
        • ss是分钟内的第二个（ 00到61 ），两位十进制数字。
        • GMT正是ASCII字母“ GMT ”来表示格林威治标准时间。

        结果不依赖于当地时区。

        结果
        这个日期的字符串表示法，使用Internet GMT约定。
        另请参见：
        DateFormat ， toString() ， toLocaleString()

      • getTimezoneOffset

        @Deprecated
public int getTimezoneOffset​()
        已过时。 从JDK 1.1版开始，由-(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000)替代。
        返回适用于由此Date对象表示的时间的本地时区相对于UTC的偏移量（以分钟为Date 。

        例如，在马萨诸塞州，格林威治以西的五个时区：

         new Date(96, 1, 14).getTimezoneOffset() returns 300
        因为1996年2月14日，标准时间（东部标准时间）正在使用，从UTC偏移了五个小时; 但：
         new Date(96, 5, 1).getTimezoneOffset() returns 240
        因为在1996年6月1日，夏令时间（Eastern Daylight Time）正在使用中，而UTC距离UTC只有四个小时。

        该方法产生的结果与计算结果相同：

         (this.getTime() - UTC(this.getYear(),
                       this.getMonth(),
                       this.getDate(),
                       this.getHours(),
                       this.getMinutes(),
                       this.getSeconds())) / (60 * 1000)
        结果
        当前时区的时区偏移量（以分钟为单位）。
        另请参见：
        Calendar.ZONE_OFFSET ， Calendar.DST_OFFSET ， TimeZone.getDefault()

      • from

        public static Date from​(Instant instant)
        从Instant对象获取一个Date的实例。

        Instant使用毫微秒的精度，而Date使用毫秒的精度。 转换将截断任何超量精度信息，就好像以毫秒为单位的整数除以一百万。

        Instant可以在未来进一步存储时间点上的积分，并且在过去比Date进一步。 在这种情况下，此方法将抛出异常。

        参数
        instant - 即时转换
        结果
        一个 Date表示与提供的时刻在时间线上的相同点
        异常
        NullPointerException - 如果 instant为空。
        IllegalArgumentException - 如果瞬间太大，无法表示为 Date
        从以下版本开始：
        1.8

      • toInstant

        public Instant toInstant​()
        将此Date对象转换为Instant 。

        转换创建Instant ，表示基于时间线，因为这同一点Date 。

        结果
        即时代表与时间线上的相同点 Date对象
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Deque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Deque<E>

  • 参数类型
    E - 在这个deque中保存的元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E> ， Queue<E>
    All Known Subinterfaces:
    BlockingDeque<E>
    所有已知实现类：
    ArrayDeque ， ConcurrentLinkedDeque ， LinkedBlockingDeque ， LinkedList

    public interface Deque<E>
extends Queue<E>
    支持两端元素插入和移除的线性集合。 名称deque是“双端队列”的缩写，通常发音为“deck”。 大多数Deque实现对它们可能包含的元素数量没有固定的限制，但是该接口支持容量限制的deques以及没有固定大小限制的deques。

    该界面定义了访问deque两端元素的方法。 提供了插入，移除和检查元素的方法。 这些方法中的每一种都有两种形式：如果操作失败，则抛出异常，另一种方法返回一个特殊值（根据操作而定）（ null或false ）。 插入操作的后一种形式专门设计用于容量限制的Deque实现; 在大多数实现中，插入操作不能失败。

    上述十二种方法总结在下表中：

    Summary of Deque methods First Element (Head) Last Element (Tail) Throws exception Special value Throws exception Special value Insert addFirst(e) offerFirst(e) addLast(e) offerLast(e) Remove removeFirst() pollFirst() removeLast() pollLast() Examine getFirst() peekFirst() getLast() peekLast()

    此界面扩展了Queue界面。 当使用deque作为队列时，FIFO（先进先出）行为的结果。 元素将添加到deque的末尾，并从头开始删除。 从Queue接口继承的方法正好等同于Deque方法，如下表所示：

    Comparison of Queue and Deque methods Queue Method Equivalent Deque Method add(e) addLast(e) offer(e) offerLast(e) remove() removeFirst() poll() pollFirst() element() getFirst() peek() peekFirst()

    Deques也可以用作LIFO（先进先出）堆栈。 这个接口应该优先于传统的Stack类。 当一个deque作为一个堆栈时，元素从deque的开头被推出并弹出。 堆栈方法正好等同于Deque方法，如下表所示：

    Comparison of Stack and Deque methods Stack Method Equivalent Deque Method push(e) addFirst(e) pop() removeFirst() peek() peekFirst()

    请注意，当使用deque作为队列或堆栈时， peek方法同样适用; 在任何一种情况下，元素都是从德甲开始绘制的。

    此接口提供两种方法来清除内部元素， removeFirstOccurrence和removeLastOccurrence 。

    与List接口不同，此接口不支持索引对元素的访问。

    尽管不严格要求Deque实现来禁止插入空元素，但是强烈建议这样做。 任何用户Deque强烈建议实现，也允许null元素不采取插入空的能力优势。 这是因为null被用作特殊的返回值通过各种方法来表示deque是空的。

    Deque实现通常不定义基于元素的版本的equals和hashCode方法，而是继承从类别Object的基于身份的版本。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），如果可以立即执行此操作，而不会违反容量限制， true在成功后返回 true ，如果当前没有可用空间，则抛出 IllegalStateException 。
      boolean addAll​(Collection<? extends E> c)
      在指定集合的末尾添加指定集合中的所有元素，如同通过按照集合的迭代器返回的顺序调用每个 元素addLast(E)一样 。
      void addFirst​(E e)
      如果可以立即在没有违反容量限制的情况下将指定的元素插入到此deque的前面，如果当前没有可用空间，则抛出一个 IllegalStateException 。
      void addLast​(E e)
      如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的末尾，则抛出一个 IllegalStateException如果当前没有可用空间）。
      boolean contains​(Object o)
      如果此deque包含指定的元素，则返回 true 。
      Iterator<E> descendingIterator​()
      以相反的顺序返回此deque中的元素的迭代器。
      E element​()
      检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
      E getFirst​()
      检索，但不删除，这个deque的第一个元素。
      E getLast​()
      检索，但不删除，这个deque的最后一个元素。
      Iterator<E> iterator​()
      以正确的顺序返回此deque中的元素的迭代器。
      boolean offer​(E e)
      将指定的元素插入此双端队列表示的队列中（换句话说，在此双端队列的尾部），如果它是立即可行且不会违反容量限制，返回 true在成功和 false ，如果当前没有空间可用。
      boolean offerFirst​(E e)
      在此deque的前面插入指定的元素，除非它会违反容量限制。
      boolean offerLast​(E e)
      在此deque的末尾插入指定的元素，除非它会违反容量限制。
      E peek​()
      检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回 null 。
      E peekFirst​()
      检索但不删除此deque的第一个元素，如果此deque为空，则返回 null 。
      E peekLast​()
      检索但不删除此deque的最后一个元素，如果此deque为空，则返回 null 。
      E poll​()
      检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回 null 。
      E pollFirst​()
      检索并删除此deque的第一个元素，如果此deque为空，则返回 null 。
      E pollLast​()
      检索并删除此deque的最后一个元素，如果此deque为空，则返回 null 。
      E pop​()
      从这个deque表示的堆栈中弹出一个元素。
      void push​(E e)
      将元素推送到由此deque表示的堆栈（换句话说，在此deque的头部），如果可以立即执行此操作，而不会违反容量限制，如果当前没有可用空间，则抛出一个 IllegalStateException 。
      E remove​()
      检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
      boolean remove​(Object o)
      从此deque中删除指定元素的第一个出现。
      E removeFirst​()
      检索并删除此deque的第一个元素。
      boolean removeFirstOccurrence​(Object o)
      从此deque中删除指定元素的第一个出现。
      E removeLast​()
      检索并删除此deque的最后一个元素。
      boolean removeLastOccurrence​(Object o)
      从此deque中删除指定元素的最后一次出现。
      int size​()
      返回此deque中的元素数。

      • Methods inherited from interface java.util.Collection

        clear, containsAll, equals, hashCode, isEmpty, parallelStream, removeAll, removeIf, retainAll, spliterator, stream, toArray, toArray

      • Methods inherited from interface java.lang.Iterable

        forEach

    • 方法详细信息

      • addFirst

        void addFirst​(E e)
        如果可以在不违反容量限制的情况下立即将其指定的元素插入到此deque的前面，如果当前没有可用的空间，则抛出一个IllegalStateException 。 当使用容量限制的deque时，通常优选使用方法offerFirst(E) 。
        参数
        e - 要添加的元素
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空，此deque不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • addLast

        void addLast​(E e)
        如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的末尾，如果当前没有可用的空间，则抛出一个IllegalStateException 。 当使用容量限制的deque时，通常优选使用方法offerLast(E) 。

        此方法相当于add(E) 。

        参数
        e - 要添加的元素
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空，并且此deque不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • offerFirst

        boolean offerFirst​(E e)
        在此deque的前面插入指定的元素，除非它会违反容量限制。 当使用容量限制的deque时，该方法通常比addFirst(E)方法更为方便 ，只能通过抛出异常来插入元素。
        参数
        e - 要添加的元素
        结果
        true如果元素添加到此deque，否则为 false
        异常
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空，并且此deque不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • offerLast

        boolean offerLast​(E e)
        在此deque的末尾插入指定的元素，除非它会违反容量限制。 当使用容量限制的deque时，这种方法通常比addLast(E)方法更为方便 ，只能通过抛出异常来插入元素。
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到此deque，否则为 false
        异常
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空，并且该deque不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • removeFirst

        E removeFirst​()
        检索并删除此deque的第一个元素。 此方法与pollFirst的区别仅在于，如果此deque为空，那么它将抛出异常。
        结果
        这个德克的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • removeLast

        E removeLast​()
        检索并删除此deque的最后一个元素。 此方法与pollLast的不同之处在于，如果此deque为空，它将抛出异常。
        结果
        这个德克的尾巴
        异常
        NoSuchElementException - 如果这个deque是空的

      • pollFirst

        E pollFirst​()
        检索并删除此deque的第一个元素，如果此deque为空，则返回 null 。
        结果
        这个deque的头，或 null如果这个deque是空的

      • pollLast

        E pollLast​()
        检索并删除此deque的最后一个元素，如果此deque为空，则返回 null 。
        结果
        这个deque的尾巴，或 null如果这个deque是空的

      • getFirst

        E getFirst​()
        检索，但不删除，这个deque的第一个元素。 此方法与peekFirst不同之处在于，如果此deque为空，它将抛出异常。
        结果
        这个德克的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • getLast

        E getLast​()
        检索，但不删除，这个deque的最后一个元素。 此方法与peekLast的不同之处在于，如果此deque为空，它将抛出异常。
        结果
        这个德克的尾巴
        异常
        NoSuchElementException - 如果这个deque是空的

      • peekFirst

        E peekFirst​()
        检索但不删除此deque的第一个元素，如果此deque为空，则返回 null 。
        结果
        这个deque的头，或 null如果这个deque是空的

      • peekLast

        E peekLast​()
        检索但不删除此deque的最后一个元素，如果此deque为空，则返回 null 。
        结果
        这个deque的尾巴，或 null如果这个deque是空的

      • removeFirstOccurrence

        boolean removeFirstOccurrence​(Object o)
        从此deque中删除指定元素的第一个出现。 如果deque不包含元素，则它不变。 更正式地，删除第一元素e使得Objects.equals(o, e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。
        参数
        o - 要从此deque中删除的元素（如果存在）
        结果
        true如果一个元素被删除作为此调用的结果
        异常
        ClassCastException - 如果指定元素的类与此deque不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且该deque不允许空元素（ optional ）

      • removeLastOccurrence

        boolean removeLastOccurrence​(Object o)
        从此deque中删除指定元素的最后一次出现。 如果deque不包含元素，则它不变。 更正式地，删除最后一个元素e ，使得Objects.equals(o, e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。
        参数
        o - 要从此deque中删除的元素（如果存在）
        结果
        true如果一个元素被删除作为这个调用的结果
        异常
        ClassCastException - 如果指定元素的类与此deque不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，此deque不允许空元素（ optional ）

      • add

        boolean add​(E e)
        将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），如果可以立即执行，而不违反容量限制， true在成功后返回true ，如果当前没有可用空间，则抛出IllegalStateException 。 当使用容量限制的deque时，通常最好使用offer 。

        此方法相当于addLast(E) 。

        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空，并且该deque不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • offer

        boolean offer​(E e)
        将指定的元素插入此双端队列表示的队列中（换句话说，在此双端队列的尾部），如果它是立即可行且不会违反容量限制，返回true在成功和false ，如果当前没有空间可用。 当使用容量限制的deque时，这种方法通常比add(E)方法更为方便 ，只能通过抛出异常来插入元素。

        此方法相当于offerLast(E) 。

        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到此deque，否则为 false
        异常
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空，并且此deque不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止其添加到此deque

      • remove

        E remove​()
        检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。 该方法与poll()不同之处在于，如果此deque为空，它将抛出异常。

        此方法相当于removeFirst() 。

        Specified by:
        remove在接口 Queue<E>
        结果
        由这个德克队代表的队列的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • poll

        E poll​()
        检索并删除由此deque（换句话说，此deque的第一个元素）表示的队列的头部，或者如果此deque为空，则返回null 。

        此方法相当于pollFirst() 。

        Specified by:
        poll在接口 Queue<E>
        结果
        这个deque的第一个元素，或 null如果这个deque是空的

      • element

        E element​()
        检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。 此方法与peek的区别仅在于如果此deque为空，那么它将抛出异常。

        此方法相当于getFirst() 。

        Specified by:
        element在接口 Queue<E>
        结果
        由这个德克队代表的队列的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • peek

        E peek​()
        检索但不删除由此deque表示的队列的头部（换句话说，此deque的第一个元素），如果此deque为空，则返回null 。

        此方法相当于peekFirst() 。

        Specified by:
        peek在接口 Queue<E>
        结果
        由这个deque表示的队列的头，或者如果这个deque是空的，则是 null

      • addAll

        boolean addAll​(Collection<? extends E> c)
        在指定的集合的末尾添加指定集合中的所有元素，就像通过按照集合的迭代器返回的顺序调用每个元素addLast(E)一样 。

        当使用容量限制的deque时，通常最好在每个元素上单独调用offer 。

        尝试添加元素时遇到的异常可能会导致在抛出关联的异常时成功添加了一些元素。

        Specified by:
        addAll在接口 Collection<E>
        参数
        c - 要插入此deque的元素
        结果
        true如果这个deque由于调用而改变了
        异常
        IllegalStateException - 如果不是所有的元素可以在此时由于插入限制添加
        ClassCastException - 如果指定集合的元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的集合包含一个空元素，并且该deque不允许空元素，或者如果指定的集合为空
        IllegalArgumentException - 如果指定集合的元素的某些属性阻止将其添加到此deque
        另请参见：
        Collection.add(Object)

      • push

        void push​(E e)
        将元素推送到由此deque表示的堆栈（换句话说，在此deque的头部），如果可以立即执行此操作而不违反容量限制，则抛出IllegalStateException如果当前没有可用空间）。

        此方法相当于addFirst(E) 。

        参数
        e - 要推的元素
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空，并且此deque不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • pop

        E pop​()
        从这个deque表示的堆栈中弹出一个元素。 换句话说，删除并返回此deque的第一个元素。

        此方法相当于removeFirst() 。

        结果
        这个deque前面的元素（它是由这个deque表示的堆栈的顶部）
        异常
        NoSuchElementException - 如果这个deque是空的

      • remove

        boolean remove​(Object o)
        从此deque中删除指定元素的第一个出现。 如果deque不包含元素，则它不变。 更正式地，删除第一元素e ，使得Objects.equals(o, e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。

        此方法相当于removeFirstOccurrence(Object) 。

        Specified by:
        remove在接口 Collection<E>
        参数
        o - 要从此deque移除的元素（如果存在）
        结果
        true如果某个元素因此调用而被删除
        异常
        ClassCastException - 如果指定元素的类与此deque不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，此deque不允许空元素（ optional ）

      • contains

        boolean contains​(Object o)
        如果此deque包含指定的元素，则返回true 。 更正式地，返回true如果且仅当此deque包含至少一个元素e ，使得Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        参数
        o - 要在此deque中存在的元素要进行测试
        结果
        true如果此deque包含指定的元素
        异常
        ClassCastException - 如果指定元素的类与此deque不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且此deque不允许空元素（ optional ）

      • size

        int size​()
        返回此deque中的元素数。
        Specified by:
        size在接口 Collection<E>
        结果
        这个deque中的元素数量

      • iterator

        Iterator<E> iterator​()
        以正确的顺序返回此deque中的元素的迭代器。 元素将按照从头（头）到最后（尾）的顺序返回。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        结果
        在这个deque中的元素以适当的顺序迭代

      • descendingIterator

        Iterator<E> descendingIterator​()
        以相反的顺序返回此deque中的元素的迭代器。 元素将从最后（尾）到第一（头）的顺序返回。
        结果
        an iterator over the elements in this deque in reverse sequence
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Dictionary (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Dictionary<K,V>

  • java.lang.Object
    • java.util.Dictionary<K,V>
  • 已知直接子类：
    Hashtable

    public abstract class Dictionary<K,V>
extends Object
    Dictionary类是任何类的抽象父类，例如Hashtable ，它将键映射到值。 每个键和每个值都是一个对象。 在任何一个Dictionary对象中，每个键最多与一个值相关联。 给定一个Dictionary和一个键，可以查找关联的元素。 任何非null对象都可以用作键值和值。

    通常，这个类的实现应该使用equals方法来确定两个键是否相同。

    注意：此类已过时。 新的实现应该实现Map接口，而不是扩展这个类。

    从以下版本开始：
    1.0
    另请参见：
    Map ， Object.equals(java.lang.Object) ， Object.hashCode() ， Hashtable

    • 构造方法摘要

      构造方法
      Constructor 描述
      Dictionary​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Enumeration<V> elements​()
      返回此字典中值的枚举。
      abstract V get​(Object key)
      返回该字典中键映射到的值。
      abstract boolean isEmpty​()
      测试这个字典是否将键值映射到值。
      abstract Enumeration<K> keys​()
      返回此字典中键的枚举。
      abstract V put​(K key, V value)
      将指定的 key到该字典中指定的 value 。
      abstract V remove​(Object key)
      从该字典中删除 key （及其对应的 value ）。
      abstract int size​()
      返回此字典中的条目数（不同的键）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Dictionary

        public Dictionary​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • size

        public abstract int size​()
        返回此字典中的条目数（不同的键）。
        结果
        这个字典中的键数。

      • isEmpty

        public abstract boolean isEmpty​()
        测试这个字典是否将键值映射到值。 isEmpty方法的通用合同是，当且仅当该字典不包含条目时，结果为真。
        结果
        true如果这个字典不把键映射到值; false否则。

      • keys

        public abstract Enumeration<K> keys​()
        返回此字典中键的枚举。 密钥方法的一般合同是返回一个Enumeration对象，该对象将生成此字典包含条目的所有密钥。
        结果
        这个字典中的键的枚举。
        另请参见：
        elements() ， Enumeration

      • elements

        public abstract Enumeration<V> elements​()
        返回此字典中值的枚举。 elements方法的一般合同是返回一个Enumeration ，它将生成此字典中条目中包含的所有元素。
        结果
        这个字典中的值的枚举。
        另请参见：
        keys() ， Enumeration

      • get

        public abstract V get​(Object key)
        返回该字典中键映射到的值。 isEmpty方法的一般合同是，如果该字典包含指定键的条目，则返回关联的值; 否则返回null 。
        参数
        key - 这个字典的关键。 null如果该键不映射到此字典中的任何值。
        结果
        密钥映射到该字典中的值;
        异常
        NullPointerException - 如果 key是 null 。
        另请参见：
        put(java.lang.Object, java.lang.Object)

      • put

        public abstract V put​(K key,
                      V value)
        将指定的key到该字典中指定的value 。 钥匙和价值都不能是null 。

        如果这个字典已经包含指定的条目key ，在这个字典已经值key返回，修改为包含新的元素加入后。

        如果此字典尚未具有指定的key的条目， value为指定的key和value创建一个条目，并返回null 。

        该value可以通过调用被检索get方法与key等于原始key 。

        参数
        key - 哈希表键。
        value - 值。
        结果
        key在此字典中映射的上一个值，如果该键没有先前的映射， null 。
        异常
        NullPointerException - 如果 key或 value是 null 。
        另请参见：
        Object.equals(java.lang.Object) ， get(java.lang.Object)

      • remove

        public abstract V remove​(Object key)
        从该字典中删除key （及其对应的value ）。 如果key不在此字典中，此方法不执行任何操作。
        参数
        key - 需要删除的关键。
        结果
        key已被映射到此字典中的值，如果密钥没有映射， null 。
        异常
        NullPointerException - 如果 key是 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleSummaryStatistics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class DoubleSummaryStatistics

  • java.lang.Object
    • java.util.DoubleSummaryStatistics
  • All Implemented Interfaces:
    DoubleConsumer

    public class DoubleSummaryStatistics
extends Object
implements DoubleConsumer
    统计数据的收集状态，如count，min，max，sum和average。

    这个课程旨在与（但不需要） streams一起工作 。 例如，您可以使用以下方式计算双精度流的汇总统计信息：

       DoubleSummaryStatistics stats = doubleStream.collect(DoubleSummaryStatistics::new, DoubleSummaryStatistics::accept, DoubleSummaryStatistics::combine);

    DoubleSummaryStatistics可用作reduction目标为stream 。 例如：

       DoubleSummaryStatistics stats = people.stream() .collect(Collectors.summarizingDouble(Person::getWeight));
    这样一来，就可以计算出人数，以及权重的最小值，最大值，总和和平均值。
    Implementation Note:
    这个实现不是线程安全的。 然而，并行流中使用Collectors.summarizingDouble()是安全的，因为Stream.collect()的并行实现为安全和高效的并行执行提供了必要的分区，隔离和结果合并。
    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      DoubleSummaryStatistics​()
      用零计数，零和， Double.POSITIVE_INFINITY分钟， Double.NEGATIVE_INFINITY最大和零平均值构造一个空实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void accept​(double value)
      在摘要信息中记录另一个值。
      void combine​(DoubleSummaryStatistics other)
      将另一个 DoubleSummaryStatistics的状态合并到一个。
      double getAverage​()
      返回记录的值的算术平均值，如果没有记录值，则返回零。
      long getCount​()
      返回记录的值的计数。
      double getMax​()
      如果任何记录值为NaN，则返回最大记录值 Double.NaN如果没有记录值，则返回 Double.NEGATIVE_INFINITY 。
      double getMin​()
      如果任何记录值为NaN，则返回最低记录值 Double.NaN如果没有记录值，则返回 Double.POSITIVE_INFINITY 。
      double getSum​()
      返回记录的值的总和，如果没有记录值，则返回零。
      String toString​()
      返回适用于调试的此对象的非空字符串表示形式。

      • Methods inherited from interface java.util.function.DoubleConsumer

        andThen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DoubleSummaryStatistics

        public DoubleSummaryStatistics​()
        构造一个零计数，零和， Double.POSITIVE_INFINITY分钟， Double.NEGATIVE_INFINITY最大和零平均值的空实例。

    • 方法详细信息

      • accept

        public void accept​(double value)
        在摘要信息中记录另一个值。
        Specified by:
        accept在接口 DoubleConsumer
        参数
        value - 输入值

      • combine

        public void combine​(DoubleSummaryStatistics other)
        将另一个 DoubleSummaryStatistics的状态合并到这一个中。
        参数
        other - 另一个 DoubleSummaryStatistics
        异常
        NullPointerException - 如果 other为空

      • getCount

        public final long getCount​()
        返回记录的值的计数。
        结果
        数值计数

      • getSum

        public final double getSum​()
        返回记录的值的总和，如果没有记录值，则返回零。

        浮点和的值是输入值以及加法运算顺序的函数。 该方法的加法运算顺序有意未被定义为允许实现灵活性来提高计算结果的速度和准确性。 特别地，可以使用补偿求和或其他技术来实现该方法，以减少与double值的简单求和相比的数字和中的误差界限。 由于未指定的操作顺序和使用不同求和方案的可能性，该方法的输出可能会在相同的输入值上变化。

        各种条件可导致计算非有限和。 即使所有记录的值相加都可能发生这种情况。 如果任何记录的值是非有限的，则总和将是非限定的：

        • 如果任何记录的值是NaN，则最终总和将为NaN。
        • 如果记录的值包含一个或多个无穷大，则总和将为无限或NaN。
          • 如果记录值含有相反符号的无穷大，则总和将为NaN。
          • 如果记录的值包含一个符号的无穷大，并且中间和溢出到相反符号的无穷大，则该和可以是NaN。
        有限值的中间和可能溢出到相反的无穷大中; 如果发生这种情况，最终的总和将是NaN，即使记录的值都是有限的。 如果所有记录的值都为零，则不能保证零的符号在最后的和中被保留。
        API Note:
        按绝对数量增加排列的数值往往会产生更准确的结果。
        结果
        值的总和，否则为零

      • getMin

        public final double getMin​()
        如果任何记录值为NaN，则返回最小记录值Double.NaN如果没有记录值，则返回Double.POSITIVE_INFINITY 。 与数值比较运算符不同，该方法认为负零严格小于正零。
        结果
        最低记录值 Double.NaN如果任何记录值为NaN或 Double.POSITIVE_INFINITY如果没有记录值

      • getMax

        public final double getMax​()
        如果任何记录值为NaN，则返回最大记录值Double.NaN如果没有记录值，则返回Double.NEGATIVE_INFINITY 。 与数值比较运算符不同，该方法认为负零严格小于正零。
        结果
        最高记录值为 Double.NaN如果任何记录值为NaN或 Double.NEGATIVE_INFINITY如果没有记录值

      • getAverage

        public final double getAverage​()
        返回记录的值的算术平均值，如果没有记录值，则返回零。

        计算的平均值可以数值变化，并具有计算总和的特殊情况行为; 详见getSum() 。

        API Note:
        按绝对数量增加排列的数值往往会产生更准确的结果。
        结果
        值的算术平均值，如果没有值则为零

      • toString

        public String toString​()
        返回适用于调试的此对象的非空字符串表示形式。 准确的表示格式是未指定的，可能会在实现和版本之间变化。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DuplicateFormatFlagsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class DuplicateFormatFlagsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.DuplicateFormatFlagsException
  • All Implemented Interfaces:
    Serializable

    public class DuplicateFormatFlagsException
extends IllegalFormatException
    在格式说明符中提供重复标志时抛出未经检查的异常。

    除非另有规定，否则传递一个null参数到null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DuplicateFormatFlagsException​(String f)
      使用指定的标志构造此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getFlags​()
      返回包含重复标志的标志集。
      String getMessage​()
      返回此throwable的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • DuplicateFormatFlagsException

        public DuplicateFormatFlagsException​(String f)
        使用指定的标志构造此类的实例。
        参数
        f - 包含重复标志的格式标志集。

    • 方法详细信息

      • getFlags

        public String getFlags​()
        返回包含重复标志的标志集。
        结果
        旗帜

      • getMessage

        public String getMessage​()
        说明从类别复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EmptyStackException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class EmptyStackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.util.EmptyStackException
  • All Implemented Interfaces:
    Serializable

    public class EmptyStackException
extends RuntimeException
    由 Stack类中的方法抛出，表示堆栈为空。
    从以下版本开始：
    1.0
    另请参见：
    Stack ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      EmptyStackException​()
      构造新的 EmptyStackException作为其错误消息字符串，其中 null为 null 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • EmptyStackException

        public EmptyStackException​()
        构造新的 EmptyStackException其中包含 null作为其错误消息字符串。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Enumeration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Enumeration<E>

  • All Known Subinterfaces:
    NamingEnumeration<T>
    所有已知实现类：
    StringTokenizer

    public interface Enumeration<E>
    实现枚举接口的对象生成一系列元素，一次一个。 连续调用nextElement方法返回系列的连续元素。

    例如，要打印所有元素的一个Vector<E> v ：

      for (Enumeration<E> e = v.elements(); e.hasMoreElements();)
       System.out.println(e.nextElement());

    提供了通过向量的元素，散列表的键和哈希表中的值来枚举方法。 枚举也用于将输入流指定为SequenceInputStream 。

    API Note:
    该接口的功能由Iterator接口复制。 此外， Iterator添加了可选的删除操作，并且具有较短的方法名称。 新的实现应该考虑使用Iterator ，而不是Enumeration 。 因此能够适应一个Enumeration到Iterator通过使用asIterator()方法。
    从以下版本开始：
    1.0
    另请参见：
    Iterator ， SequenceInputStream ， nextElement() ， Hashtable ， Hashtable.elements() ， Hashtable.keys() ， Vector ， Vector.elements()

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default Iterator<E> asIterator​()
      返回一个Iterator ，它遍历此枚举覆盖的其余元素。
      boolean hasMoreElements​()
      测试此枚举是否包含更多元素。
      E nextElement​()
      如果此枚举对象至少有一个要提供的元素，则返回此枚举的下一个元素。

    • 方法详细信息

      • hasMoreElements

        boolean hasMoreElements​()
        测试此枚举是否包含更多元素。
        结果
        true当且仅当此枚举对象包含至少一个要提供的元素时; 否则为false 。

      • nextElement

        E nextElement​()
        如果此枚举对象至少有一个要提供的元素，则返回此枚举的下一个元素。
        结果
        这个枚举的下一个元素。
        异常
        NoSuchElementException - 如果不存在更多元素。

      • asIterator

        default Iterator<E> asIterator​()
        返回一个Iterator ，它遍历此枚举覆盖的其余元素。 如果在调用asIterator之后对此枚举调用了任何方法，则遍历是未定义的。
        API Note:
        此方法旨在帮助适应代码生成Enumeration实例的代码消耗Iterator实例。 例如， JarFile.entries()方法返回一个Enumeration<JarEntry> 。 这可以变成Iterator ，然后可以使用forEachRemaining()方法：
           JarFile jarFile = ... ; jarFile.entries().asIterator().forEachRemaining(entry -> { ... });
        （注意，还有一个JarFile.stream()方法返回一个Stream的条目，这在某些情况下可能更方便。）
        实现要求：
        默认实现返回 Iterator ，其 hasNext方法调用此枚举的 hasMoreElements方法，其 next方法调用此枚举的 nextElement方法，且其 remove方法抛出 UnsupportedOperationException 。
        结果
        代表这个枚举的其余元素的迭代器
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EnumMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class EnumMap<K extends Enum<K>,V>

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.EnumMap<K,V>
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Map<K,V>

    public class EnumMap<K extends Enum<K>,V>
extends AbstractMap<K,V>
implements Serializable, Cloneable
    专门用于枚举类型键的Map实现。 枚举映射中的所有密钥必须来自创建映射时明确或隐式指定的单个枚举类型。 枚举地图在内部表示为数组。 这种表示非常紧凑和高效。

    枚举映射以其键的自然顺序 （枚举枚举常量的声明）的顺序进行维护。 这反映在由所述集合的视图（返回的迭代keySet() ， entrySet() ，和values() ）。

    收集视图所返回的迭代器是弱一致的 ：它们永远不会抛出ConcurrentModificationException，并且它们可能显示或不显示在迭代进行时发生的映射的任何修改的影响。

    不允许使用空键。 尝试插入空键将抛出NullPointerException 。 然而，尝试测试是否存在空键或删除一个将会正常工作。 允许空值。

    像大多数集合实现EnumMap不同步。 如果多个线程同时访问枚举映射，并且至少有一个线程修改映射，则应该在外部进行同步。 这通常通过在自然地封装枚举映射的某些对象上进行同步来实现。 如果没有这样的对象存在，地图应该使用Collections.synchronizedMap(java.util.Map<K, V>)方法“包装”。 这最好在创建时完成，以防止意外的不同步访问：

      Map<EnumKey, V> m
         = Collections.synchronizedMap(new EnumMap<EnumKey, V>(...));

    实现注意事项：所有基本操作都在不间断执行。 他们可能（虽然不能保证）比他们的HashMap同行更快。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.5
    另请参见：
    EnumSet ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      EnumMap​(Class<K> keyType)
      使用指定的键类型创建一个空的枚举映射。
      EnumMap​(EnumMap<K,? extends V> m)
      创建与指定的枚举映射相同的键类型的枚举映射，最初包含相同的映射（如果有）。
      EnumMap​(Map<K,? extends V> m)
      创建从指定地图初始化的枚举映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      从此地图中删除所有的映射。
      EnumMap<K,V> clone​()
      返回此枚举映射的浅拷贝。
      boolean containsKey​(Object key)
      如果此映射包含指定键的映射，则返回 true 。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      boolean equals​(Object o)
      将指定的对象与此映射进行比较以获得相等性。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。
      int hashCode​()
      返回此地图的哈希码值。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      V put​(K key, V value)
      将指定的值与此映射中的指定键相关联。
      void putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此地图。
      V remove​(Object key)
      从该地图中删除此密钥的映射（如果存在）。
      int size​()
      返回此地图中键值映射的数量。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from class java.util.AbstractMap

        isEmpty, toString

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, forEach, getOrDefault, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • EnumMap

        public EnumMap​(Class<K> keyType)
        使用指定的键类型创建一个空的枚举映射。
        参数
        keyType - 此枚举映射的键类型的类对象
        异常
        NullPointerException - 如果 keyType为空

      • EnumMap

        public EnumMap​(EnumMap<K,? extends V> m)
        创建与指定的枚举映射相同的键类型的枚举映射，最初包含相同的映射（如果有）。
        参数
        m - 从中初始化此枚举映射的枚举映射
        异常
        NullPointerException - 如果 m为空

      • EnumMap

        public EnumMap​(Map<K,? extends V> m)
        创建从指定地图初始化的枚举映射。 如果指定的映射是一个EnumMap实例，该构造函数的行为与EnumMap(EnumMap)相同。 否则，指定的映射必须至少包含一个映射（以确定新的枚举映射的密钥类型）。
        参数
        m - 从中初始化此枚举地图的地图
        异常
        IllegalArgumentException - 如果 m不是 EnumMap实例，并且不包含映射
        NullPointerException - 如果 m为空

    • 方法详细信息

      • size

        public int size​()
        返回此地图中键值映射的数量。
        Specified by:
        size在接口 Map<K extends Enum<K>,V>
        重写：
        size在 AbstractMap<K extends Enum<K>,V>
        结果
        该地图中键值映射的数量

      • containsValue

        public boolean containsValue​(Object value)
        如果此映射将一个或多个键映射到指定的值，则返回 true 。
        Specified by:
        containsValue在接口 Map<K extends Enum<K>,V>
        重写：
        containsValue在类 AbstractMap<K extends Enum<K>,V>
        参数
        value - 要在该地图中存在的值要测试的值
        结果
        true如果此地图将一个或多个键映射到此值

      • containsKey

        public boolean containsKey​(Object key)
        如果此映射包含指定键的映射，则返回 true 。
        Specified by:
        containsKey在接口 Map<K extends Enum<K>,V>
        重写：
        containsKey在 AbstractMap<K extends Enum<K>,V>
        参数
        key - 要在此地图中存在的密钥要进行测试
        结果
        true如果此映射包含指定键的映射

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含键的映射，则返回null 。

        更正式地，如果该映射包含从k键到值v的映射， k该值为(key == k) ，则该方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        返回值为null并不一定表示该映射不包含该键的映射; 地图也可能明确地将密钥映射到null 。 可以使用containsKey操作来区分这两种情况。

        Specified by:
        get在接口 Map<K extends Enum<K>,V>
        重写：
        get在 AbstractMap<K extends Enum<K>,V>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含该键的映射， null

      • put

        public V put​(K key,
             V value)
        将指定的值与此映射中的指定键相关联。 如果地图先前包含该键的映射，则替换旧值。
        Specified by:
        put在接口 Map<K extends Enum<K>,V>
        重写：
        put在类 AbstractMap<K extends Enum<K>,V>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示以前关联的地图null与指定的键。）
        异常
        NullPointerException - 如果指定的键为空

      • remove

        public V remove​(Object key)
        从该地图中删除此密钥的映射（如果存在）。
        Specified by:
        remove在接口 Map<K extends Enum<K>,V>
        重写：
        remove在 AbstractMap<K extends Enum<K>,V>
        参数
        key - 要从地图中删除其映射的密钥
        结果
        与指定键相关联的上一个值，如果没有键的条目， null 。 （A null返回也可以指示以前关联的地图null与指定的关键字。）

      • putAll

        public void putAll​(Map<? extends K,? extends V> m)
        将指定地图的所有映射复制到此地图。 这些映射将替换此映射对当前在指定映射中的任何键的任何映射。
        Specified by:
        putAll在接口 Map<K extends Enum<K>,V>
        重写：
        putAll在 AbstractMap<K extends Enum<K>,V>
        参数
        m - 要存储在此地图中的映射
        异常
        NullPointerException - 指定的映射为空，或指定映射中的一个或多个键为空

      • clear

        public void clear​()
        从此地图中删除所有的映射。
        Specified by:
        clear在接口 Map<K extends Enum<K>,V>
        重写：
        clear在 AbstractMap<K extends Enum<K>,V>

      • keySet

        public Set<K> keySet​()
        返回此地图中包含的键的Set视图。 返回的集合符合Map.keySet()中概述的总体合同。 集合的迭代器将以自然顺序返回键（枚举常量的声明顺序）。
        Specified by:
        keySet在接口 Map<K extends Enum<K>,V>
        重写：
        keySet在 AbstractMap<K extends Enum<K>,V>
        结果
        该枚举地图中包含的键的集合视图

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。 退货的货品符合Map.values()中概述的总合同。 集合的迭代器将按照它们对应的键在map中显示的顺序返回值，这是它们的自然顺序（枚举常量被声明的顺序）。
        Specified by:
        values在接口 Map<K extends Enum<K>,V>
        重写：
        values在 AbstractMap<K extends Enum<K>,V>
        结果
        该地图中包含的值的集合视图

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。 返回的集合符合Map.keySet()中概述的总体合同。 集合的迭代器将按照它们的键在映射中显示的顺序返回映射，这是它们的自然顺序（枚举常量被声明的顺序）。
        Specified by:
        entrySet在接口 Map<K extends Enum<K>,V>
        Specified by:
        entrySet在 AbstractMap<K extends Enum<K>,V>
        结果
        该枚举地图中包含的映射的集合视图

      • equals

        public boolean equals​(Object o)
        将指定的对象与此映射进行比较以获得相等性。 返回true如果给定的对象也是一个地图，并且两个地图代表相同的映射，如Map.equals(Object)合同中规定的。
        Specified by:
        equals在接口 Map<K extends Enum<K>,V>
        重写：
        equals在 AbstractMap<K extends Enum<K>,V>
        参数
        o - 要与此映射相等的对象进行比较
        结果
        true如果指定的对象等于此映射
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此地图的哈希码值。 地图的哈希码被定义为地图中每个条目的哈希码的总和。
        Specified by:
        hashCode在接口 Map<K extends Enum<K>,V>
        重写：
        hashCode在 AbstractMap<K extends Enum<K>,V>
        结果
        该地图的哈希码值
        另请参见：
        Map.Entry.hashCode() ，
Object.equals(Object) ，
Set.equals(Object)

      • clone

        public EnumMap<K,V> clone​()
        返回此枚举映射的浅拷贝。 值本身不被克隆。
        重写：
        clone在 AbstractMap<K extends Enum<K>,V>
        结果
        这个枚举地图的浅拷贝
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EnumSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class EnumSet<E extends Enum<E>>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractSet<E>
        • java.util.EnumSet<E>
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， Set<E>

    public abstract class EnumSet<E extends Enum<E>>
extends AbstractSet<E>
implements Cloneable, Serializable
    一个专门用于枚举类型的Set实现。 枚举集中的所有元素都必须来自创建集合时明确或隐式指定的单个枚举类型。 枚举集在内部表示为位向量。 这种表示非常紧凑和高效。 这个类的空间和时间表现应该足够好，可以将其作为基于传统int的“位标志”的高质量，类型安全的替代品使用。 即使批量操作（如containsAll和retainAll ），如果其参数也是枚举集，则应该运行得很快。

    由iterator方法返回的迭代器以自然顺序 （枚举枚举常量的声明顺序）遍历元素。 返回的迭代器是弱一致的 ：它不会抛出ConcurrentModificationException ，它可能显示或可能不显示在迭代进行时发生的集合的任何修改的影响。

    不允许使用零元素。 尝试插入一个空元素将抛出NullPointerException 。 然而，尝试测试null元素的存在或删除一个将会正常工作。

    像大多数集合实现一样， EnumSet不同步。 如果多个线程同时访问枚举集，并且至少有一个线程修改该集合，则它应该在外部同步。 这通常通过在自然地封装枚举集的一些对象上进行同步来实现。 如果没有这样的对象存在，那么该集合应该使用Collections.synchronizedSet(java.util.Set<T>)方法“包装”。 这最好在创建时完成，以防止意外的不同步访问：

      Set<MyEnum> s = Collections.synchronizedSet(EnumSet.noneOf(MyEnum.class));

    实现注意事项：所有基本操作都在不间断执行。 他们很可能（虽然不能保证）比他们的HashSet同行快得多。 如果它们的参数也是一个枚举集，那么即使批量操作也会在一段时间内执行。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.5
    另请参见：
    EnumMap

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static <E extends Enum<E>>
      EnumSet<E>             		allOf​(Class<E> elementType)
      创建一个包含指定元素类型中所有元素的枚举集。
      EnumSet<E> clone​()
      返回此集合的副本。
      static <E extends Enum<E>>
      EnumSet<E>             		complementOf​(EnumSet<E> s)
      创建与指定枚举集具有相同元素类型的枚举集，最初包含此类型的所有元素，该元素 不包含在指定的集合中。
      static <E extends Enum<E>>
      EnumSet<E>             		copyOf​(Collection<E> c)
      创建从指定集合初始化的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		copyOf​(EnumSet<E> s)
      创建与指定的枚举集相同的元素类型的枚举集，最初包含相同的元素（如果有）。
      static <E extends Enum<E>>
      EnumSet<E>             		noneOf​(Class<E> elementType)
      使用指定的元素类型创建一个空的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		of​(E e)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		of​(E e1, E e2)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		of​(E first, E... rest)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		of​(E e1, E e2, E e3)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		of​(E e1, E e2, E e3, E e4)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		of​(E e1, E e2, E e3, E e4, E e5)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		range​(E from, E to)
      创建最初包含由两个指定端点定义的范围内的所有元素的枚举集。

      • Methods inherited from class java.util.AbstractCollection

        add, addAll, clear, contains, containsAll, isEmpty, iterator, remove, retainAll, size, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractSet

        equals, hashCode, removeAll

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, isEmpty, iterator, of, of, of, of, of, of, remove, retainAll, size, spliterator, toArray, toArray

    • 方法详细信息

      • noneOf

        public static <E extends Enum<E>> EnumSet<E> noneOf​(Class<E> elementType)
        使用指定的元素类型创建一个空的枚举集。
        参数类型
        E - 集合中的元素的类
        参数
        elementType - 此枚举集的元素类型的类对象
        结果
        指定类型的空的枚举集。
        异常
        NullPointerException - 如果 elementType为空

      • allOf

        public static <E extends Enum<E>> EnumSet<E> allOf​(Class<E> elementType)
        创建一个包含指定元素类型中所有元素的枚举集。
        参数类型
        E - 集合中的元素的类
        参数
        elementType - 此枚举集的元素类型的类对象
        结果
        一个包含指定类型的所有元素的枚举集。
        异常
        NullPointerException - 如果 elementType为空

      • copyOf

        public static <E extends Enum<E>> EnumSet<E> copyOf​(EnumSet<E> s)
        创建与指定的枚举集相同的元素类型的枚举集，最初包含相同的元素（如果有）。
        参数类型
        E - 集合中的元素的类
        参数
        s - 从中初始化此枚举集的枚举集
        结果
        指定枚举集的副本。
        异常
        NullPointerException - 如果 s为空

      • copyOf

        public static <E extends Enum<E>> EnumSet<E> copyOf​(Collection<E> c)
        创建从指定集合初始化的枚举集。 如果指定的集合是一个EnumSet实例，则此静态工厂方法的行为与copyOf(EnumSet)相同。 否则，指定的集合必须至少包含一个元素（以确定新的枚举集的元素类型）。
        参数类型
        E - 集合中元素的类
        参数
        c - 从中初始化此枚举集的集合
        结果
        从给定集合初始化的枚举集。
        异常
        IllegalArgumentException - 如果 c不是 EnumSet实例，并且不包含元素
        NullPointerException - 如果 c为空

      • complementOf

        public static <E extends Enum<E>> EnumSet<E> complementOf​(EnumSet<E> s)
        创建与指定枚举集具有相同元素类型的枚举集，最初包含此类型的所有元素，该元素 不包含在指定的集合中。
        参数类型
        E - 枚举集中元素的类
        参数
        s - 从其补码初始化此枚举集的枚举集
        结果
        该集合中指定集合的补码
        异常
        NullPointerException - 如果 s为空

      • of

        public static <E extends Enum<E>> EnumSet<E> of​(E e)
        创建一个最初包含指定元素的枚举集。 存在这种方法的重载，用于初始化一到五个元素的枚举集。 提供了使用varargs功能的第六次重载。 这种重载可能用于创建一个最初包含任意数量的元素的枚举集，但可能运行速度比不使用varargs的重载更慢。
        参数类型
        E - 指定元素和集合的类
        参数
        e - 最初包含该集合的元素
        结果
        最初包含指定元素的枚举集
        异常
        NullPointerException - 如果 e为空

      • of

        public static <E extends Enum<E>> EnumSet<E> of​(E e1,
                                                E e2)
        创建一个最初包含指定元素的枚举集。 存在这种方法的重载，用于初始化一到五个元素的枚举集。 提供了使用varargs功能的第六次重载。 这种重载可能用于创建一个最初包含任意数量的元素的枚举集，但可能运行速度比不使用varargs的重载更慢。
        参数类型
        E - 参数元素和集合的类
        参数
        e1 - 该集合最初包含的元素
        e2 - 此集最初包含的另一个元素
        结果
        一个最初包含指定元素的枚举集
        异常
        NullPointerException - 如果任何参数为空

      • of

        public static <E extends Enum<E>> EnumSet<E> of​(E e1,
                                                E e2,
                                                E e3)
        创建一个最初包含指定元素的枚举集。 存在这种方法的重载，用于初始化一到五个元素的枚举集。 提供了使用varargs功能的第六次重载。 这种重载可能用于创建一个最初包含任意数量的元素的枚举集，但可能运行速度比不使用varargs的重载更慢。
        参数类型
        E - 参数元素和集合的类
        参数
        e1 - 此集最初包含的元素
        e2 - 此集最初包含的另一个元素
        e3 - 此集最初包含的另一个元素
        结果
        一个最初包含指定元素的枚举集
        异常
        NullPointerException - 如果任何参数为空

      • of

        public static <E extends Enum<E>> EnumSet<E> of​(E e1,
                                                E e2,
                                                E e3,
                                                E e4)
        创建一个最初包含指定元素的枚举集。 存在这种方法的重载，用于初始化一到五个元素的枚举集。 提供了使用varargs功能的第六次重载。 这种重载可能用于创建一个最初包含任意数量的元素的枚举集，但可能运行速度比不使用varargs的重载更慢。
        参数类型
        E - 参数元素和集合的类
        参数
        e1 - 此集最初包含的元素
        e2 - 此集最初包含的另一个元素
        e3 - 此集最初包含的另一个元素
        e4 - 此集最初包含的另一个元素
        结果
        一个最初包含指定元素的枚举集
        异常
        NullPointerException - 如果任何参数为空

      • of

        public static <E extends Enum<E>> EnumSet<E> of​(E e1,
                                                E e2,
                                                E e3,
                                                E e4,
                                                E e5)
        创建一个最初包含指定元素的枚举集。 存在这种方法的重载，用于初始化一到五个元素的枚举集。 提供了使用varargs功能的第六次重载。 这种重载可能用于创建一个最初包含任意数量的元素的枚举集，但可能运行速度比不使用varargs的重载更慢。
        参数类型
        E - 参数元素和集合的类
        参数
        e1 - 此集最初包含的元素
        e2 - 此集最初包含的另一个元素
        e3 - 此集最初包含的另一个元素
        e4 - 此集最初包含的另一个元素
        e5 - 此集最初包含的另一个元素
        结果
        一个最初包含指定元素的枚举集
        异常
        NullPointerException - 如果任何参数为空

      • of

        @SafeVarargs
public static <E extends Enum<E>> EnumSet<E> of​(E first,
                                                E... rest)
        创建一个最初包含指定元素的枚举集。 该工厂的参数列表使用varargs功能，可用于创建一个最初包含任意数量元素的枚举集，但它的运行速度可能比不使用varargs的重载更慢。
        参数类型
        E - 参数元素和集合的类
        参数
        first - 该集合最初包含的元素
        rest - 集合最初包含的剩余元素
        结果
        一个最初包含指定元素的枚举集
        异常
        NullPointerException - 如果任何指定的元素为空，或者如果 rest为空

      • range

        public static <E extends Enum<E>> EnumSet<E> range​(E from,
                                                   E to)
        创建最初包含由两个指定端点定义的范围内的所有元素的枚举集。 返回的集合将包含端点本身，这可能是相同的，但不能是无序的。
        参数类型
        E - 参数元素和集合的类
        参数
        from - 范围内的第一个元素
        to - 范围中的最后一个元素
        结果
        最初包含由两个指定端点定义的范围内的所有元素的枚举集
        异常
        NullPointerException - 如果 from或 to为空
        IllegalArgumentException - 如果是 from.compareTo(to) > 0

      • clone

        public EnumSet<E> clone​()
        返回此集合的副本。
        重写：
        clone在 Object
        结果
        这套的副本
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EventListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface EventListener

  • All Known Subinterfaces:
    Action ， ActionListener ， AdjustmentListener ， AncestorListener ， AppForegroundListener ， AppHiddenListener ， AppReopenedListener ， AWTEventListener ， BeanContextMembershipListener ， BeanContextServiceRevokedListener ， BeanContextServices ， BeanContextServicesListener ， CaretListener ， CellEditorListener ， ChangeListener ， ComponentListener ， ConnectionEventListener ， ContainerListener ， ControllerEventListener ， DocumentListener ， DragGestureListener ， DragSourceListener ， DragSourceMotionListener ， DropTargetListener ， EventHandler<T> ， FlavorListener ， FocusListener ， GUIInitializedListener ， HandshakeCompletedListener ， HierarchyBoundsListener ， HierarchyListener ， HyperlinkListener ， IIOReadProgressListener ， IIOReadUpdateListener ， IIOReadWarningListener ， IIOWriteProgressListener ， IIOWriteWarningListener ， InputMethodListener ， InternalFrameListener ， ItemListener ， KeyListener ， LineListener ， ListDataListener ， ListSelectionListener ， MenuDragMouseListener ， MenuKeyListener ， MenuListener ， MetaEventListener ， MouseInputListener ， MouseListener ， MouseMotionListener ， MouseWheelListener ， NamespaceChangeListener ， NamingListener ， NodeChangeListener ， NotificationListener NotificationListener ， ObjectChangeListener ， PopupMenuListener ， PreferenceChangeListener ， PropertyChangeListener ， RowSetListener ， RowSorterListener ， ScreenSleepListener ， SSLSessionBindingListener ， StatementEventListener ， SystemEventListener ， SystemSleepListener ， TableColumnModelListener ， TableModelListener ， TextListener ， TopLevelWindowListener ， TreeExpansionListener ， TreeModelListener ， TreeSelectionListener ， TreeWillExpandListener ， UndoableEditListener ， UnsolicitedNotificationListener ， UserSessionListener ， VetoableChangeListener ， WindowFocusListener ， WindowListener ， WindowStateListener
    所有已知实现类：
    AbstractAction ， AbstractButton.ButtonChangeListener ， AWTEventListenerProxy ， AWTEventMulticaster ， BasicButtonListener ， BasicColorChooserUI.PropertyHandler ， BasicComboBoxEditor ， BasicComboBoxEditor.UIResource ， BasicComboBoxUI.FocusHandler ， BasicComboBoxUI.ItemHandler ， BasicComboBoxUI.KeyHandler ， BasicComboBoxUI.ListDataHandler ， BasicComboBoxUI.PropertyChangeHandler ， BasicComboPopup.InvocationKeyHandler ， BasicComboPopup.InvocationMouseHandler ， BasicComboPopup.InvocationMouseMotionHandler ， BasicComboPopup.ItemHandler ， BasicComboPopup.ListDataHandler ， BasicComboPopup.ListMouseHandler ， BasicComboPopup.ListMouseMotionHandler ， BasicComboPopup.ListSelectionHandler ， BasicComboPopup.PropertyChangeHandler ， BasicDesktopIconUI.MouseInputHandler ， BasicDesktopPaneUI.CloseAction ， BasicDesktopPaneUI.MaximizeAction ， BasicDesktopPaneUI.MinimizeAction ， BasicDesktopPaneUI.NavigateAction ， BasicDesktopPaneUI.OpenAction ， BasicDirectoryModel ， BasicFileChooserUI.ApproveSelectionAction ， BasicFileChooserUI.CancelSelectionAction ， BasicFileChooserUI.ChangeToParentDirectoryAction ， BasicFileChooserUI.DoubleClickListener ， BasicFileChooserUI.GoHomeAction ， BasicFileChooserUI.NewFolderAction ， BasicFileChooserUI.SelectionListener ， BasicFileChooserUI.UpdateAction ， BasicInternalFrameTitlePane.CloseAction ， BasicInternalFrameTitlePane.IconifyAction ， BasicInternalFrameTitlePane.MaximizeAction ， BasicInternalFrameTitlePane.MoveAction ， BasicInternalFrameTitlePane.PropertyChangeHandler ， BasicInternalFrameTitlePane.RestoreAction ， BasicInternalFrameTitlePane.SizeAction ， BasicInternalFrameUI.BasicInternalFrameListener ， BasicInternalFrameUI.BorderListener ， BasicInternalFrameUI.ComponentHandler ， BasicInternalFrameUI.GlassPaneDispatcher ， BasicInternalFrameUI.InternalFramePropertyChangeListener ， BasicLabelUI ， BasicListUI.FocusHandler ， BasicListUI.ListDataHandler ， BasicListUI.ListSelectionHandler ， BasicListUI.MouseInputHandler ， BasicListUI.PropertyChangeHandler ， BasicMenuItemUI.MouseInputHandler BasicMenuItemUI.MouseInputHandler ， BasicMenuUI.ChangeHandler ， BasicMenuUI.MouseInputHandler ， BasicOptionPaneUI.ButtonActionListener ， BasicOptionPaneUI.PropertyChangeHandler ， BasicProgressBarUI.ChangeHandler ， BasicRootPaneUI ， BasicScrollBarUI.ArrowButtonListener ， BasicScrollBarUI.ModelListener ， BasicScrollBarUI.PropertyChangeHandler ， BasicScrollBarUI.ScrollListener ， BasicScrollBarUI.TrackListener ， BasicScrollPaneUI.HSBChangeListener ， BasicScrollPaneUI.MouseWheelHandler ， BasicScrollPaneUI.PropertyChangeHandler ， BasicScrollPaneUI.ViewportChangeHandler ， BasicScrollPaneUI.VSBChangeListener ， BasicSliderUI.ActionScroller ， BasicSliderUI.ChangeHandler ， BasicSliderUI.ComponentHandler ， BasicSliderUI.FocusHandler ， BasicSliderUI.PropertyChangeHandler ， BasicSliderUI.ScrollListener ， BasicSliderUI.TrackListener ， BasicSplitPaneDivider ， BasicSplitPaneDivider.MouseHandler ， BasicSplitPaneUI.FocusHandler ， BasicSplitPaneUI.KeyboardDownRightHandler ， BasicSplitPaneUI.KeyboardEndHandler ， BasicSplitPaneUI.KeyboardHomeHandler ， BasicSplitPaneUI.KeyboardResizeToggleHandler ， BasicSplitPaneUI.KeyboardUpLeftHandler ， BasicSplitPaneUI.PropertyHandler ， BasicTabbedPaneUI.FocusHandler ， BasicTabbedPaneUI.MouseHandler ， BasicTabbedPaneUI.PropertyChangeHandler ， BasicTabbedPaneUI.TabSelectionHandler ， BasicTableHeaderUI.MouseInputHandler ， BasicTableUI.FocusHandler ， BasicTableUI.KeyHandler ， BasicTableUI.MouseInputHandler ， BasicTextUI.BasicCaret ， BasicToolBarUI.DockingListener ， BasicToolBarUI.FrameListener ， BasicToolBarUI.PropertyListener ， BasicToolBarUI.ToolBarContListener ， BasicToolBarUI.ToolBarFocusListener ， BasicTreeUI.CellEditorHandler ， BasicTreeUI.ComponentHandler ， BasicTreeUI.FocusHandler ， BasicTreeUI.KeyHandler ， BasicTreeUI.MouseHandler ， BasicTreeUI.MouseInputHandler ， BasicTreeUI.PropertyChangeHandler ， BasicTreeUI.SelectionModelPropertyChangeHandler ， BasicTreeUI.TreeCancelEditingAction ， BasicTreeUI.TreeExpansionHandler BasicTreeUI.TreeExpansionHandler ， BasicTreeUI.TreeHomeAction ， BasicTreeUI.TreeIncrementAction ， BasicTreeUI.TreeModelHandler ， BasicTreeUI.TreePageAction ， BasicTreeUI.TreeSelectionHandler ， BasicTreeUI.TreeToggleAction ， BasicTreeUI.TreeTraverseAction ， BeanContextChildSupport ， BeanContextServicesSupport ， BeanContextServicesSupport.BCSSProxyServiceProvider ， BeanContextSupport ， Checkbox.AccessibleAWTCheckbox ， Component.AccessibleAWTComponent.AccessibleAWTComponentHandler ， Component.AccessibleAWTComponent.AccessibleAWTFocusHandler ， ComponentAdapter ， Container.AccessibleAWTContainer.AccessibleContainerHandler ， ContainerAdapter ， DefaultCaret ， DefaultCellEditor.EditorDelegate ， DefaultEditorKit.BeepAction ， DefaultEditorKit.CopyAction ， DefaultEditorKit.CutAction ， DefaultEditorKit.DefaultKeyTypedAction ， DefaultEditorKit.InsertBreakAction ， DefaultEditorKit.InsertContentAction ， DefaultEditorKit.InsertTabAction ， DefaultEditorKit.PasteAction ， DefaultTableColumnModel ， DefaultTreeCellEditor ， DragSourceAdapter ， DragSourceContext ， DropTarget ， DropTarget.DropTargetAutoScroller ， DropTargetAdapter ， EventListenerProxy ， EventQueueMonitor ， FocusAdapter ， FormView ， FormView.MouseEventListener ， HierarchyBoundsAdapter ， HTMLEditorKit.HTMLTextAction ， HTMLEditorKit.InsertHTMLTextAction ， HTMLEditorKit.LinkController ， InternalFrameAdapter ， JCheckBox.AccessibleJCheckBox ， JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem ， JComboBox ， JComponent.AccessibleJComponent.AccessibleContainerHandler ， JComponent.AccessibleJComponent.AccessibleFocusHandler ， JEditorPane.AccessibleJEditorPane ， JEditorPane.AccessibleJEditorPaneHTML ， JEditorPane.JEditorPaneAccessibleHypertextSupport ， JLayer ， JList.AccessibleJList ， JMenu.AccessibleJMenu JMenu.AccessibleJMenu ， JMenu.WinListener ， JMenuItem.AccessibleJMenuItem ， JPasswordField.AccessibleJPasswordField ， JPopupMenu.AccessibleJPopupMenu ， JRadioButton.AccessibleJRadioButton ， JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem ， JScrollPane.AccessibleJScrollPane ， JSpinner.AccessibleJSpinner ， JSpinner.DateEditor ， JSpinner.DefaultEditor ， JSpinner.ListEditor ， JSpinner.NumberEditor ， JTabbedPane.AccessibleJTabbedPane ， JTabbedPane.ModelListener ， JTable ， JTable.AccessibleJTable ， JTableHeader ， JTextArea.AccessibleJTextArea ， JTextComponent.AccessibleJTextComponent ， JTextField.AccessibleJTextField ， JToggleButton.AccessibleJToggleButton ， JTree.AccessibleJTree ， JTree.TreeModelHandler ， JTree.TreeSelectionRedirector ， JViewport.ViewListener ， KeyAdapter ， List.AccessibleAWTList ， MetalComboBoxEditor ， MetalComboBoxEditor.UIResource ， MetalComboBoxUI.MetalPropertyChangeListener ， MetalFileChooserUI.DirectoryComboBoxAction ， MetalFileChooserUI.FilterComboBoxModel ， MetalFileChooserUI.SingleClickListener ， MetalLabelUI ， MetalRootPaneUI ， MetalSliderUI.MetalPropertyListener ， MetalToolBarUI.MetalContainerListener ， MetalToolBarUI.MetalDockingListener ， MetalToolBarUI.MetalRolloverListener ， MouseAdapter ， MouseDragGestureRecognizer ， MouseInputAdapter ， MouseMotionAdapter ， ProgressMonitor.AccessibleProgressMonitor ， PropertyChangeListenerProxy ， RelationService ， StyledEditorKit.AlignmentAction ， StyledEditorKit.BoldAction ， StyledEditorKit.FontFamilyAction ， StyledEditorKit.FontSizeAction ， StyledEditorKit.ForegroundAction ， StyledEditorKit.ItalicAction ， StyledEditorKit.StyledTextAction ， StyledEditorKit.UnderlineAction ， SynthButtonUI ， SynthCheckBoxMenuItemUI SynthCheckBoxMenuItemUI ， SynthCheckBoxUI ， SynthColorChooserUI ， SynthComboBoxUI ， SynthDesktopIconUI ， SynthDesktopPaneUI ， SynthInternalFrameUI ， SynthLabelUI ， SynthListUI ， SynthMenuBarUI ， SynthMenuItemUI ， SynthMenuUI ， SynthOptionPaneUI ， SynthPanelUI ， SynthPopupMenuUI ， SynthProgressBarUI ， SynthRadioButtonMenuItemUI ， SynthRadioButtonUI ， SynthRootPaneUI ， SynthScrollBarUI ， SynthScrollPaneUI ， SynthSeparatorUI ， SynthSliderUI ， SynthSpinnerUI ， SynthSplitPaneUI ， SynthTabbedPaneUI ， SynthTableHeaderUI ， SynthTableUI ， SynthToggleButtonUI ， SynthToolBarUI ， SynthToolTipUI ， SynthTreeUI ， SynthViewportUI ， TextAction ， TextArea.AccessibleAWTTextArea ， TextComponent.AccessibleAWTTextComponent ， TextField.AccessibleAWTTextField ， ToolTipManager ， ToolTipManager.insideTimerAction ， ToolTipManager.outsideTimerAction ， ToolTipManager.stillInsideTimerAction ， UndoManager ， VetoableChangeListenerProxy ， WeakEventHandler ， WindowAdapter

    public interface EventListener
    所有事件侦听器接口必须扩展的标记接口。
    从以下版本开始：
    1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EventListenerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class EventListenerProxy<T extends EventListener>

  • java.lang.Object
    • java.util.EventListenerProxy<T>
  • All Implemented Interfaces:
    EventListener
    已知直接子类：
    AWTEventListenerProxy ， PropertyChangeListenerProxy ， VetoableChangeListenerProxy

    public abstract class EventListenerProxy<T extends EventListener>
extends Object
implements EventListener
    EventListener类的抽象包装类， EventListener一组附加参数与侦听器相关联。 子类必须为附加参数或参数提供存储和访问方法。

    例如，支持命名属性的bean将有一个两个参数方法签名，用于为属性添加一个PropertyChangeListener ：

      public void addPropertyChangeListener(String propertyName,
                                       PropertyChangeListener listener)
    如果bean也实现了零参数get listener方法：
      public PropertyChangeListener[] getPropertyChangeListeners()
    那么数组可能包含内部PropertyChangeListeners ，它们也是PropertyChangeListenerProxy对象。

    如果调用方法有兴趣获取命名属性，那么它将必须测试该元素以查看它是否是一个代理类。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      EventListenerProxy​(T listener)
      为指定的侦听器创建代理。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T getListener​()
      返回与代理关联的侦听器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EventListenerProxy

        public EventListenerProxy​(T listener)
        为指定的侦听器创建代理。
        参数
        listener - 侦听器对象

    • 方法详细信息

      • getListener

        public T getListener​()
        返回与代理关联的侦听器。
        结果
        与代理关联的侦听器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EventObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class EventObject

  • java.lang.Object
    • java.util.EventObject
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AppEvent ， AWTEvent ， BeanContextEvent ， CaretEvent ， ChangeEvent ， ConnectionEvent ， DragGestureEvent ， DragSourceEvent ， DropTargetEvent ， Event ， FlavorEvent ， HandshakeCompletedEvent ， HyperlinkEvent ， LineEvent ， ListDataEvent ， ListSelectionEvent ， MenuEvent ， NamingEvent ， NamingExceptionEvent ， NodeChangeEvent ， Notification ， PopupMenuEvent ， PreferenceChangeEvent ， PrintEvent ， PropertyChangeEvent ， RowSetEvent ， RowSorterEvent ， SSLSessionBindingEvent ， StatementEvent ， TableColumnModelEvent ， TableModelEvent ， TreeExpansionEvent ， TreeModelEvent ， TreeSelectionEvent ， UndoableEditEvent ， UnsolicitedNotificationEvent

    public class EventObject
extends Object
implements Serializable

    所有事件状态对象应从其派生的根类。

    所有事件的构造与对象的引用，“源”，逻辑上被认为是最初发生事件的对象。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Object source
      事件最初发生的对象。

    • 构造方法摘要

      构造方法
      Constructor 描述
      EventObject​(Object source)
      构建一个典型的事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getSource​()
      事件最初发生的对象。
      String toString​()
      返回此EventObject的String表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • source

        protected transient Object source
        事件最初发生的对象。

    • 构造方法详细信息

      • EventObject

        public EventObject​(Object source)
        构建一个典型的事件。
        参数
        source - 事件最初发生的对象。
        异常
        IllegalArgumentException - 如果source为null。

    • 方法详细信息

      • getSource

        public Object getSource​()
        事件最初发生的对象。
        结果
        事件最初发生的对象。

      • toString

        public String toString​()
        返回此EventObject的String表示形式。
        重写：
        toString在 Object
        结果
        这个EventObject的一个String表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


FormatFlagsConversionMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class FormatFlagsConversionMismatchException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.FormatFlagsConversionMismatchException
  • All Implemented Interfaces:
    Serializable

    public class FormatFlagsConversionMismatchException
extends IllegalFormatException
    转换和标志不兼容时抛出未经检查的异常。

    除非另有说明，否则将null参数传递给null中的任何方法或构造函数将导致抛出270630241995252 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FormatFlagsConversionMismatchException​(String f, char c)
      使用指定的标志和转换构造此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      char getConversion​()
      返回不兼容的转换。
      String getFlags​()
      返回不兼容的标志。
      String getMessage​()
      返回此throwable的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FormatFlagsConversionMismatchException

        public FormatFlagsConversionMismatchException​(String f,
                                              char c)
        使用指定的标志和转换构造此类的实例。
        参数
        f - 国旗
        c - 转换

    • 方法详细信息

      • getFlags

        public String getFlags​()
        返回不兼容的标志。
        结果
        国旗

      • getConversion

        public char getConversion​()
        返回不兼容的转换。
        结果
        转换

      • getMessage

        public String getMessage​()
        说明从类别复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        the detail message string of this Throwable instance (which may be null).
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Formattable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Formattable

  • public interface Formattable
    所述Formattable接口必须通过需要执行自定义使用格式化任何类来实现's'的转换指定Formatter 。 该界面允许基本控制格式化任意对象。 例如，以下类别根据标志和长度限制打印股票名称的不同表示：
       import java.nio.CharBuffer; import java.util.Formatter; import java.util.Formattable; import java.util.Locale; import static java.util.FormattableFlags.*; ... public class StockName implements Formattable { private String symbol, companyName, frenchCompanyName; public StockName(String symbol, String companyName, String frenchCompanyName) { ... } ... public void formatTo(Formatter fmt, int f, int width, int precision) { StringBuilder sb = new StringBuilder(); // decide form of name String name = companyName; if (fmt.locale().equals(Locale.FRANCE)) name = frenchCompanyName; boolean alternate = (f & ALTERNATE) == ALTERNATE; boolean usesymbol = alternate || (precision != -1 && precision < 10); String out = (usesymbol ? symbol : name); // apply precision if (precision == -1 || out.length() < precision) { // write it all sb.append(out); } else { sb.append(out.substring(0, precision - 1)).append('*'); } // apply width and justification int len = sb.length(); if (len < width) for (int i = 0; i < width - len; i++) if ((f & LEFT_JUSTIFY) == LEFT_JUSTIFY) sb.append(' '); else sb.insert(0, ' '); fmt.format(sb.toString()); } public String toString() { return String.format("%s - %s", symbol, companyName); } }

    当与Formatter一起使用时，上述类为各种格式字符串生成以下输出。

       Formatter fmt = new Formatter(); StockName sn = new StockName("HUGE", "Huge Fruit, Inc.", "Fruit Titanesque, Inc."); fmt.format("%s", sn); // -> "Huge Fruit, Inc." fmt.format("%s", sn.toString()); // -> "HUGE - Huge Fruit, Inc." fmt.format("%#s", sn); // -> "HUGE" fmt.format("%-10.8s", sn); // -> "HUGE " fmt.format("%.12s", sn); // -> "Huge Fruit,*" fmt.format(Locale.FRANCE, "%25s", sn); // -> " Fruit Titanesque, Inc."

    Formattables不一定对多线程访问是安全的。 线程安全是可选的，可以通过扩展和实现此接口的类实现。

    除非另有说明，否则将null参数传递给此接口中的任何方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void formatTo​(Formatter formatter, int flags, int width, int precision)
      使用提供的formatter格式化对象。

    • 方法详细信息

      • formatTo

        void formatTo​(Formatter formatter,
              int flags,
              int width,
              int precision)
        使用提供的formatter格式化对象。
        参数
        formatter - formatter 。 实施课程可以致电formatter.out()或formatter.locale() ，分别获得270630526070137或Locale使用的formatter 。
        flags - 标志修改输出格式。 该值被解释为位掩码。 下列标志的任何组合可被设置： FormattableFlags.LEFT_JUSTIFY ， FormattableFlags.UPPERCASE ，和FormattableFlags.ALTERNATE 。 如果没有设置任何标志，则实施类的默认格式将被应用。
        width - 要写入输出的最小字符数。 如果转换的值的长度小于width则输出将被填充'  '直到字符的总数等于宽。 默认情况下，填充处于开头。 如果设置了FormattableFlags.LEFT_JUSTIFY标志，则填充将在最后。 如果width是-1那么没有最小值。
        precision - 要写入输出的最大字符数。 精度宽度之前施加，因此输出将被截断为precision字符即使width比更大precision 。 如果precision是-1那么字符数没有明确的限制。
        异常
        IllegalFormatException - 如果任何参数无效。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FormattableFlags (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class FormattableFlags

  • java.lang.Object
    • java.util.FormattableFlags

  • public class FormattableFlags
extends Object
    FomattableFlags被传递给Formattable.formatTo()方法和修改的输出格式为Formattables 。 Formattable的实施负责解释和验证任何标志。
    从以下版本开始：
    1.5

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ALTERNATE
      需要输出使用替代形式。
      static int LEFT_JUSTIFY
      左对齐输出。
      static int UPPERCASE
      根据270630525202826方法的formatter参数创建时给出的locale的规则将输出转换为大写。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • LEFT_JUSTIFY

        public static final int LEFT_JUSTIFY
        左对齐输出。 空格（ '\u0020' ）将根据需要添加到转换值的末尾以填充字段的最小宽度。 如果未设置此标志，则输出将被右对齐。

        该标志对应于格式说明符中的'-' （ '\u002d' ）。

        另请参见：
        Constant Field Values

      • UPPERCASE

        public static final int UPPERCASE
        根据2706305253888方法的formatter参数创建时给出的locale的规则将输出转换为大写。 输出应等同于以下调用String.toUpperCase(java.util.Locale)
          out.toUpperCase()

        该标志对应于格式说明符中的'S' （ '\u0053' ）。

        另请参见：
        Constant Field Values

      • ALTERNATE

        public static final int ALTERNATE
        需要输出使用替代形式。 表单的定义由Formattable指定。

        该标志对应于格式说明符中的'#' （ '\u0023' ）。

        另请参见：
        Constant Field Values
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Formatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Formatter

  • java.lang.Object
    • java.util.Formatter
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public final class Formatter
extends Object
implements Closeable, Flushable
    printf风格格式字符串的解释器。 此类提供对布局调整和对齐的支持，数字，字符串和日期/时间数据的常用格式以及特定于区域设置的输出。 常见的Java类型，如byte ， BigDecimal ，并Calendar的支持。 通过Formattable接口提供了用于任意用户类型的限制格式化定制。

    对于多线程访问，格式化器不一定是安全的。 线程安全是可选的，是本课程中用户的责任。

    Java语言的格式化打印受到C的printf极大启发。 虽然格式字符串类似于C，但是已经进行了一些自定义以适应Java语言并利用其一些功能。 此外，Java格式化比C更严格; 例如，如果转换与标志不兼容，将抛出异常。 在C中，不适用的标志被忽略。 因此，格式字符串旨在被C程序员识别，但不一定完全与C中的那些完全兼容。

    预期用途示例：

       StringBuilder sb = new StringBuilder();
   // Send all output to the Appendable object sb
   Formatter formatter = new Formatter(sb, Locale.US);

   // Explicit argument indices may be used to re-order output.
   formatter.format("%4$2s %3$2s %2$2s %1$2s", "a", "b", "c", "d")
   // -> " d  c  b  a"

   // Optional locale as the first argument can be used to get
   // locale-specific formatting of numbers.  The precision and width can be
   // given to round and align the value.
   formatter.format(Locale.FRANCE, "e = %+10.4f", Math.E);
   // -> "e =    +2,7183"

   // The '(' numeric flag may be used to format negative numbers with
   // parentheses rather than a minus sign.  Group separators are
   // automatically inserted.
   formatter.format("Amount gained or lost since last statement: $ %(,.2f",
                    balanceDelta);
   // -> "Amount gained or lost since last statement: $ (6,217.58)"

    存在通用格式化请求的方便方法，如以下调用所示：

       // Writes a formatted string to System.out.
   System.out.format("Local time: %tT", Calendar.getInstance());
   // -> "Local time: 13:34:18"

   // Writes formatted output to System.err.
   System.err.printf("Unable to open file '%1$s': %2$s",
                     fileName, exception.getMessage());
   // -> "Unable to open file 'food': No such file or directory"

    像C的sprintf(3) ，字符串可能使用静态方法String.format进行格式化：

       // Format a string containing a date.
   import java.util.Calendar;
   import java.util.GregorianCalendar;
   import static java.util.Calendar.*;

   Calendar c = new GregorianCalendar(1995, MAY, 23);
   String s = String.format("Duke's Birthday: %1$tb %1$te, %1$tY", c);
   // -> s == "Duke's Birthday: May 23, 1995"

    Organization

    本规范分为两部分。 第一部分， Summary ，涵盖了基本的格式化概念。 本节适用于想要快速入门并熟悉其他编程语言格式化打印的用户。 第二部分， Details ，涵盖具体的实施细节。 它适用于希望更精确地规定格式化行为的用户。

    Summary

    本节旨在提供格式化概念的简要概述。 有关精确的行为细节，请参阅Details部分。

    Format String Syntax

    产生格式化输出的每种方法都需要格式字符串和参数列表 。 格式字符串是一个String ，它可能包含固定文本和一个或多个嵌入式格式说明符 。 请考虑以下示例：

       Calendar c = ...;
   String s = String.format("Duke's Birthday: %1$tm %1$te,%1$tY", c);
    此格式字符串是format方法的第一个参数。 它包含三个格式说明符“ %1$tm ”，“ %1$te ”和“ %1$tY ”，它们指示如何处理参数以及应在文本中插入它们。 格式字符串的其余部分是固定文本，包括"Dukes Birthday: "和任何其他空格或标点符号。 参数列表由传递给格式字符串后的方法的所有参数组成。 在上述示例中，参数列表大小为1，由Calendar对象c 。
    • 一般，字符和数字类型的格式说明符具有以下语法：
         %[argument_index$][flags][width][.precision]conversion

      argument_index是一个十进制整数，表示参数在参数列表中的位置。 第一个参数为“ 1$ ”，第二个为“ 2$ ”等。

      可选标志是修改输出格式的一组字符。 该组有效标志取决于转换。

      可选的宽度是一个正十进制整数，表示要写入输出的最小字符数。

      可选精度是通常用于限制字符数的非负十进制整数。 具体行为取决于转换。

      所需的转换是一个字符，指示参数应如何格式化。 给定参数的一组有效转换取决于参数的数据类型。

    • 用于表示日期和时间的类型的格式说明符具有以下语法：
         %[argument_index$][flags][width]conversion

      argument_index ， flags和width的可选参数如上所述。

      所需的转换是两个字符的顺序。 第一个字符是't'或'T' 。 第二个字符表示要使用的格式。 这些字符与GNU date和POSIX strftime(3c)所定义的字符相似但不完全相同。

    • 与参数不对应的格式说明符具有以下语法：
         %[flags][width]conversion

      可选标志和宽度如上定义。

      所需的转换是指示要插入输出的内容的字符。

    转换

    转换分为以下几类：

    1. 一般 - 可以应用于任何参数类型
    2. 字符 -可以被施加到其代表的Unicode字符基本类型： char ， Character ， byte ， Byte ， short ，和Short 。 这种转换也可以被施加到所述类型int和Integer时Character.isValidCodePoint(int)返回true
    3. 数字
      1. 积分 -可应用于Java的整数类型： byte ， Byte ， short ， Short ， int和Integer ， long ， Long ，并BigInteger （但不char或者Character ）
      2. 浮点 -可用于Java的浮点类型： float ， Float ， double ， Double ，并BigDecimal
    4. 日期/时间 -可以被施加到Java类型，其能够编码的日期或时间的： long ， Long ， Calendar ， Date和TemporalAccessor
    5. 百分比 - 产生字面值'%' （ '\u0025' ）
    6. 线分离器 - 生产平台专用线分离器

    对于A类普通 ， 性格 ， 数字小 ， 积分和日期/时间转换，除非另有规定，如果参数arg为null ，则结果为“ null ”。

    下表总结了支持的转换。 通过一个大写字符标记转换（即'B' ， 'H' ， 'S' ， 'C' ， 'X' ， 'E' ， 'G' ， 'A' ，和'T' ）是相同的那些相应的小写转换字符除了将结果转换成上情况按照现行规定的Locale 。 结果等同于以下调用String.toUpperCase(Locale)

      out.toUpperCase(Locale.getDefault(Locale.Category.FORMAT))
    genConv Conversion Argument Category Description 'b', 'B' general If the argument arg is null, then the result is "false". If arg is a boolean or Boolean, then the result is the string returned by String.valueOf(arg). Otherwise, the result is "true". 'h', 'H' general The result is obtained by invoking Integer.toHexString(arg.hashCode()). 's', 'S' general If arg implements Formattable, then arg.formatTo is invoked. Otherwise, the result is obtained by invoking arg.toString(). 'c', 'C' character The result is a Unicode character 'd' integral The result is formatted as a decimal integer 'o' integral The result is formatted as an octal integer 'x', 'X' integral The result is formatted as a hexadecimal integer 'e', 'E' floating point The result is formatted as a decimal number in computerized scientific notation 'f' floating point The result is formatted as a decimal number 'g', 'G' floating point The result is formatted using computerized scientific notation or decimal format, depending on the precision and the value after rounding. 'a', 'A' floating point The result is formatted as a hexadecimal floating-point number with a significand and an exponent. This conversion is not supported for the BigDecimal type despite the latter's being in the floating point argument category. 't', 'T' date/time Prefix for date and time conversion characters. See Date/Time Conversions. '%' percent The result is a literal '%' ('\u0025') 'n' line separator The result is the platform-specific line separator

    任何未明确定义为转换的字符都是非法的，并保留给将来的扩展。

    Date/Time Conversions

    为't'和'T'转换定义了以下日期和时间转换后缀字符。 类型与GNU date和POSIX strftime(3c)所定义的类似但不完全相同。 提供其他转换类型以访问特定于Java的功能（例如， 'L' ，在第二秒内为毫秒）。

    以下转换字符用于格式化时间：

    time 'H' Hour of the day for the 24-hour clock, formatted as two digits with a leading zero as necessary i.e. 00 - 23. 'I' Hour for the 12-hour clock, formatted as two digits with a leading zero as necessary, i.e. 01 - 12. 'k' Hour of the day for the 24-hour clock, i.e. 0 - 23. 'l' Hour for the 12-hour clock, i.e. 1 - 12. 'M' Minute within the hour formatted as two digits with a leading zero as necessary, i.e. 00 - 59. 'S' Seconds within the minute, formatted as two digits with a leading zero as necessary, i.e. 00 - 60 ("60" is a special value required to support leap seconds). 'L' Millisecond within the second formatted as three digits with leading zeros as necessary, i.e. 000 - 999. 'N' Nanosecond within the second, formatted as nine digits with leading zeros as necessary, i.e. 000000000 - 999999999. 'p' Locale-specific morning or afternoon marker in lower case, e.g."am" or "pm". Use of the conversion prefix 'T' forces this output to upper case. 'z' RFC 822 style numeric time zone offset from GMT, e.g. -0800. This value will be adjusted as necessary for Daylight Saving Time. For long, Long, and Date the time zone used is the default time zone for this instance of the Java virtual machine. 'Z' A string representing the abbreviation for the time zone. This value will be adjusted as necessary for Daylight Saving Time. For long, Long, and Date the time zone used is the default time zone for this instance of the Java virtual machine. The Formatter's locale will supersede the locale of the argument (if any). 's' Seconds since the beginning of the epoch starting at 1 January 1970 00:00:00 UTC, i.e. Long.MIN_VALUE/1000 to Long.MAX_VALUE/1000. 'Q' Milliseconds since the beginning of the epoch starting at 1 January 1970 00:00:00 UTC, i.e. Long.MIN_VALUE to Long.MAX_VALUE.

    以下转换字符用于格式化日期：

    date 'B' Locale-specific full month name, e.g. "January", "February". 'b' Locale-specific abbreviated month name, e.g. "Jan", "Feb". 'h' Same as 'b'. 'A' Locale-specific full name of the day of the week, e.g. "Sunday", "Monday" 'a' Locale-specific short name of the day of the week, e.g. "Sun", "Mon" 'C' Four-digit year divided by 100, formatted as two digits with leading zero as necessary, i.e. 00 - 99 'Y' Year, formatted as at least four digits with leading zeros as necessary, e.g. 0092 equals 92 CE for the Gregorian calendar. 'y' Last two digits of the year, formatted with leading zeros as necessary, i.e. 00 - 99. 'j' Day of year, formatted as three digits with leading zeros as necessary, e.g. 001 - 366 for the Gregorian calendar. 'm' Month, formatted as two digits with leading zeros as necessary, i.e. 01 - 13. 'd' Day of month, formatted as two digits with leading zeros as necessary, i.e. 01 - 31 'e' Day of month, formatted as two digits, i.e. 1 - 31.

    以下转换字符用于格式化常用日期/时间组合。

    composites 'R' Time formatted for the 24-hour clock as "%tH:%tM" 'T' Time formatted for the 24-hour clock as "%tH:%tM:%tS". 'r' Time formatted for the 12-hour clock as "%tI:%tM:%tS %Tp". The location of the morning or afternoon marker ('%Tp') may be locale-dependent. 'D' Date formatted as "%tm/%td/%ty". 'F' ISO 8601 complete date formatted as "%tY-%tm-%td". 'c' Date and time formatted as "%ta %tb %td %tT %tZ %tY", e.g. "Sun Jul 20 16:17:00 EDT 1969".

    未明确定义为日期/时间转换后缀的任何字符都是非法的，并保留给将来的扩展名。

    旗

    下表总结了支持的标志。 y表示指定的参数类型支持该标志。

    genConv Flag General Character Integral Floating Point Date/Time Description '-' y y y y y The result will be left-justified. '#' y1 - y3 y - The result should use a conversion-dependent alternate form '+' - - y4 y - The result will always include a sign ' ' - - y4 y - The result will include a leading space for positive values '0' - - y y - The result will be zero-padded ',' - - y2 y5 - The result will include locale-specific grouping separators '(' - - y4 y5 - The result will enclose negative numbers in parentheses

    1取决于Formattable的定义。

    2仅适用于'd'转换。

    3仅适用'o' 'x'和'X'转换。

    4对于'd' ， 'o' ， 'x'和'X'施加到转换BigInteger或'd'施加到byte ， Byte ， short ， Short ， int和Integer ， long ，和Long 。

    5对于'e' ， 'E' ， 'f' ， 'g' ，并'G'只有转换。

    任何未明确定义为标志的字符都是非法的，并保留给将来的扩展名。

    宽度

    宽度是要写入输出的最小字符数。 对于行分隔符转换，宽度不适用; 如果提供，将抛出异常。

    精确

    对于一般参数类型，精度是要写入输出的最大字符数。

    对于浮点转换'a' ， 'A' ， 'e' ， 'E'和'f'精度的小数点后的位数。 如果转换为'g'或'G' ，则精度是四舍五入后所得大小的总位数。

    对于字符，积分和日期/时间参数类型以及百分比和行分隔符转换，精度不适用; 如果提供精度，将抛出异常。

    参数指数

    参数index是一个十进制整数，表示参数在参数列表中的位置。 第一个参数为“ 1$ ”，第二个为“ 2$ ”等。

    通过位置引用参数的另一种方法是使用'<' （ '\u003c' ）标志，这将导致重新使用先前格式说明符的参数。 例如，以下两个语句将产生相同的字符串：

       Calendar c = ...;
   String s1 = String.format("Duke's Birthday: %1$tm %1$te,%1$tY", c);

   String s2 = String.format("Duke's Birthday: %1$tm %<te,%<tY", c);

    Details

    本节旨在提供格式化的行为细节，包括条件和异常，支持的数据类型，本地化以及标志，转换和数据类型之间的交互。 有关格式化概念的概述，请参阅Summary

    未明确定义为转换，日期/时间转换后缀或标志的任何字符都是非法的，并保留给将来的扩展名。 在格式字符串中使用这样的字符将导致抛出UnknownFormatConversionException或UnknownFormatFlagsException 。

    如果格式说明符包含无效值的宽度或精度，否则不支持， 则将分别抛出IllegalFormatWidthException或IllegalFormatPrecisionException 。

    如果格式说明符包含不适用于相应参数的转换字符，则会抛出IllegalFormatConversionException 。

    所有指定的异常可通过任何的抛出format的方法Formatter以及通过任何format方便的方法，例如String.format和PrintStream.printf 。

    对于类别General ， Character ， Numberic ， Integral和Date / Time转换，除非另有说明，如果参数arg为null ，则结果为“ null ”。

    通过一个大写字符标记转换（即'B' ， 'H' ， 'S' ， 'C' ， 'X' ， 'E' ， 'G' ， 'A' ，和'T' ）是相同的那些相应的小写转换字符除了将结果转换成上情况按照现行规则Locale 。 结果相当于以下调用String.toUpperCase(Locale)

      out.toUpperCase(Locale.getDefault(Locale.Category.FORMAT))

    General

    以下一般转换可能适用于任何参数类型：

    dgConv 'b' '\u0062' Produces either "true" or "false" as returned by Boolean.toString(boolean).

    If the argument is null, then the result is "false". If the argument is a boolean or Boolean, then the result is the string returned by String.valueOf(). Otherwise, the result is "true".

    If the '#' flag is given, then a FormatFlagsConversionMismatchException will be thrown.

    'B' '\u0042' The upper-case variant of 'b'. 'h' '\u0068' Produces a string representing the hash code value of the object.

    The result is obtained by invoking Integer.toHexString(arg.hashCode()).

    If the '#' flag is given, then a FormatFlagsConversionMismatchException will be thrown.

    'H' '\u0048' The upper-case variant of 'h'. 's' '\u0073' Produces a string.

    If the argument implements Formattable, then its formatTo method is invoked. Otherwise, the result is obtained by invoking the argument's toString() method.

    If the '#' flag is given and the argument is not a Formattable , then a FormatFlagsConversionMismatchException will be thrown.

    'S' '\u0053' The upper-case variant of 's'.

    以下flags适用于一般转化：

    dFlags '-' '\u002d' Left justifies the output. Spaces ('\u0020') will be added at the end of the converted value as required to fill the minimum width of the field. If the width is not provided, then a MissingFormatWidthException will be thrown. If this flag is not given then the output will be right-justified. '#' '\u0023' Requires the output use an alternate form. The definition of the form is specified by the conversion.

    width是要写入输出的最小字符数。 如果转换值的长度小于宽度，则输出将被填充'  ' （ '\u0020' ），直到总字符数等于宽度。 默认情况下，填充在左侧。 如果给出了'-'标志，则填充将在右侧。 如果没有指定宽度，则没有最小值。

    精度是写入输出的最大字符数。 精度在宽度之前应用，因此即使宽度大于精度，输出也将被截断为precision字符。 如果未指定精度，则对字符数没有明确的限制。

    Character

    该转换可以应用于char和Character 。 它也可以被施加到类型byte ， Byte ， short ，和Short ， int和Integer时Character.isValidCodePoint(int)返回true 。 如果它返回false那么将抛出一个IllegalFormatCodePointException 。 charConv 'c' '\u0063' Formats the argument as a Unicode character as described in Unicode Character Representation. This may be more than one 16-bit char in the case where the argument represents a supplementary character.

    If the '#' flag is given, then a FormatFlagsConversionMismatchException will be thrown.

    'C' '\u0043' The upper-case variant of 'c'.

    适用于General conversions的'-'标志。 如果给出了'#'标志，那么将抛出一个FormatFlagsConversionMismatchException 。

    宽度定义为General conversions 。

    精度不适用。 如果指定精度，则抛出IllegalFormatPrecisionException 。

    Numeric

    数字转换分为以下几类：

    1. Byte, Short, Integer, and Long
    2. BigInteger
    3. Float and Double
    4. BigDecimal

    数字类型将根据以下算法进行格式化：

    Number Localization Algorithm

    在获得整数部分，小数部分和指数（适用于数据类型）的数字后，应用以下转换：

    1. 字符串中的每个数字字符d被替换为相对于当前语言环境的zero digit z计算的特定于语言环境的数字 ; 那是d - '0' + z 。
    2. 如果存在小数分隔符，则会替换特定于区域的decimal separator18 。
    3. 如果',' （ '\u002c' ） flag给出，那么语言环境的特定grouping separator通过在由区域设置的规定的时间间隔扫描所述字符串从至少显著到最显著位数的整数部分和插入的隔板插入grouping size 。
    4. 如果给出了'0'标志，则在符号字符（如果有的话）和第一个非零数字之前插入区域特定的zero digits ，直到字符串的长度等于所请求的字段宽度。
    5. 如果该值为负且'('标志被给出，那么'(' （ '\u0028' ）被前置和')' （ '\u0029' ）将被附加。
    6. 如果该值为负（或浮点负零），并且没有给出'('标志，那么将添加一个'-' （ '\u002d' ）。
    7. 如果给出了'+'标志，并且该值为正或零（或浮点正零），则将添加一个'+' （ '\u002b' ）。

    如果值为NaN或正无穷大，则将输出文字字符串“NaN”或“Infinity”。 如果值为负无穷大，则如果给出'('标志，则输出将为“（无穷大”），否则输出将为“-Infinity”。 这些值不是本地化的。

    Byte, Short, Integer, and Long

    以下转换可以应用于byte ， Byte ， short ， Short ， int和Integer ， long ，和Long 。

    IntConv 'd' '\u0064' Formats the argument as a decimal integer. The localization algorithm is applied.

    If the '0' flag is given and the value is negative, then the zero padding will occur after the sign.

    If the '#' flag is given then a FormatFlagsConversionMismatchException will be thrown.

    'o' '\u006f' Formats the argument as an integer in base eight. No localization is applied.

    If x is negative then the result will be an unsigned value generated by adding 2n to the value where n is the number of bits in the type as returned by the static SIZE field in the Byte, Short, Integer, or Long classes as appropriate.

    If the '#' flag is given then the output will always begin with the radix indicator '0'.

    If the '0' flag is given then the output will be padded with leading zeros to the field width following any indication of sign.

    If '(', '+', ' ', or ',' flags are given then a FormatFlagsConversionMismatchException will be thrown.

    'x' '\u0078' Formats the argument as an integer in base sixteen. No localization is applied.

    If x is negative then the result will be an unsigned value generated by adding 2n to the value where n is the number of bits in the type as returned by the static SIZE field in the Byte, Short, Integer, or Long classes as appropriate.

    If the '#' flag is given then the output will always begin with the radix indicator "0x".

    If the '0' flag is given then the output will be padded to the field width with leading zeros after the radix indicator or sign (if present).

    If '(', '  ', '+', or ',' flags are given then a FormatFlagsConversionMismatchException will be thrown.

    'X' '\u0058' The upper-case variant of 'x'. The entire string representing the number will be converted to upper case including the 'x' (if any) and all hexadecimal digits 'a' - 'f' ('\u0061' - '\u0066').

    如果转换是'o' ， 'x' ，或'X'并且两个'#'和'0'标志，那么结果将包含（基数指示符'0'为八进制和"0x"或"0X"为十六进制）时，一些数量的零（基于宽度） ，和价值。

    如果没有给出'-'标志，则空格填充将发生在符号之前。

    以下flags适用于数字积分转换：

    intFlags '+' '\u002b' Requires the output to include a positive sign for all positive numbers. If this flag is not given then only negative values will include a sign.

    If both the '+' and '  ' flags are given then an IllegalFormatFlagsException will be thrown.

    '  ' '\u0020' Requires the output to include a single extra space ('\u0020') for non-negative values.

    If both the '+' and '  ' flags are given then an IllegalFormatFlagsException will be thrown.

    '0' '\u0030' Requires the output to be padded with leading zeros to the minimum field width following any sign or radix indicator except when converting NaN or infinity. If the width is not provided, then a MissingFormatWidthException will be thrown.

    If both the '-' and '0' flags are given then an IllegalFormatFlagsException will be thrown.

    ',' '\u002c' Requires the output to include the locale-specific group separators as described in the "group" section of the localization algorithm. '(' '\u0028' Requires the output to prepend a '(' ('\u0028') and append a ')' ('\u0029') to negative values.

    如果没有给出flags ，默认格式如下：

    • 输出在width内width
    • 负数以'-' （ '\u002d' ）开头
    • 正数和零不包括符号或额外的前导空间
    • 不包括分组分隔符

    width是要写入输出的最小字符数。 这包括任何符号，数字，分组分隔符，基数指示符和括号。 如果转换的值的长度小于宽度，那么输出将被空格（ '\u0020' ）填充，直到字符的总数等于宽度。 默认情况下，填充在左侧。 如果给出了'-'标志，则填充将在右侧。 如果没有指定width，那么没有最小值。

    精度不适用。 如果指定精度，则抛出IllegalFormatPrecisionException 。

    BigInteger

    以下转换可能会应用于BigInteger 。

    bIntConv 'd' '\u0064' Requires the output to be formatted as a decimal integer. The localization algorithm is applied.

    If the '#' flag is given FormatFlagsConversionMismatchException will be thrown.

    'o' '\u006f' Requires the output to be formatted as an integer in base eight. No localization is applied.

    If x is negative then the result will be a signed value beginning with '-' ('\u002d'). Signed output is allowed for this type because unlike the primitive types it is not possible to create an unsigned equivalent without assuming an explicit data-type size.

    If x is positive or zero and the '+' flag is given then the result will begin with '+' ('\u002b').

    If the '#' flag is given then the output will always begin with '0' prefix.

    If the '0' flag is given then the output will be padded with leading zeros to the field width following any indication of sign.

    If the ',' flag is given then a FormatFlagsConversionMismatchException will be thrown.

    'x' '\u0078' Requires the output to be formatted as an integer in base sixteen. No localization is applied.

    If x is negative then the result will be a signed value beginning with '-' ('\u002d'). Signed output is allowed for this type because unlike the primitive types it is not possible to create an unsigned equivalent without assuming an explicit data-type size.

    If x is positive or zero and the '+' flag is given then the result will begin with '+' ('\u002b').

    If the '#' flag is given then the output will always begin with the radix indicator "0x".

    If the '0' flag is given then the output will be padded to the field width with leading zeros after the radix indicator or sign (if present).

    If the ',' flag is given then a FormatFlagsConversionMismatchException will be thrown.

    'X' '\u0058' The upper-case variant of 'x'. The entire string representing the number will be converted to upper case including the 'x' (if any) and all hexadecimal digits 'a' - 'f' ('\u0061' - '\u0066').

    如果转换是'o' ， 'x' ，或'X'并且两个'#'和'0'标志，那么结果将包含（基座指示器'0'为八进制和"0x"或"0X"为十六进制）时，一些数量的零（基于宽度） ，和价值。

    如果给出了'0'标志，值为负，则零填充将在符号后面发生。

    如果没有给出'-'标志，则空格填充将发生在符号之前。

    所有flags定义为字节，短，整数和长度适用。 default behavior当没有标志被赋予与字节，短，整数和长度相同。

    width的规格与字节，短，整数和长度相同。

    精度不适用。 如果指定精度，则抛出IllegalFormatPrecisionException 。

    Float and Double

    以下转换可以应用于float ， Float ， double和Double 。

    floatConv 'e' '\u0065' Requires the output to be formatted using computerized scientific notation. The localization algorithm is applied.

    The formatting of the magnitude m depends upon its value.

    If m is NaN or infinite, the literal strings "NaN" or "Infinity", respectively, will be output. These values are not localized.

    If m is positive-zero or negative-zero, then the exponent will be "+00".

    Otherwise, the result is a string that represents the sign and magnitude (absolute value) of the argument. The formatting of the sign is described in the localization algorithm. The formatting of the magnitude m depends upon its value.

    Let n be the unique integer such that 10n <= m < 10n+1; then let a be the mathematically exact quotient of m and 10n so that 1 <= a < 10. The magnitude is then represented as the integer part of a, as a single decimal digit, followed by the decimal separator followed by decimal digits representing the fractional part of a, followed by the exponent symbol 'e' ('\u0065'), followed by the sign of the exponent, followed by a representation of n as a decimal integer, as produced by the method Long.toString(long, int), and zero-padded to include at least two digits.

    The number of digits in the result for the fractional part of m or a is equal to the precision. If the precision is not specified then the default value is 6. If the precision is less than the number of digits which would appear after the decimal point in the string returned by Float.toString(float) or Double.toString(double) respectively, then the value will be rounded using the round half up algorithm. Otherwise, zeros may be appended to reach the precision. For a canonical representation of the value, use Float.toString(float) or Double.toString(double) as appropriate.

    If the ',' flag is given, then an FormatFlagsConversionMismatchException will be thrown.

    'E' '\u0045' The upper-case variant of 'e'. The exponent symbol will be 'E' ('\u0045'). 'g' '\u0067' Requires the output to be formatted in general scientific notation as described below. The localization algorithm is applied.

    After rounding for the precision, the formatting of the resulting magnitude m depends on its value.

    If m is greater than or equal to 10-4 but less than 10precision then it is represented in decimal format.

    If m is less than 10-4 or greater than or equal to 10precision, then it is represented in computerized scientific notation.

    The total number of significant digits in m is equal to the precision. If the precision is not specified, then the default value is 6. If the precision is 0, then it is taken to be 1.

    If the '#' flag is given then an FormatFlagsConversionMismatchException will be thrown.

    'G' '\u0047' The upper-case variant of 'g'. 'f' '\u0066' Requires the output to be formatted using decimal format. The localization algorithm is applied.

    The result is a string that represents the sign and magnitude (absolute value) of the argument. The formatting of the sign is described in the localization algorithm. The formatting of the magnitude m depends upon its value.

    If m NaN or infinite, the literal strings "NaN" or "Infinity", respectively, will be output. These values are not localized.

    The magnitude is formatted as the integer part of m, with no leading zeroes, followed by the decimal separator followed by one or more decimal digits representing the fractional part of m.

    The number of digits in the result for the fractional part of m or a is equal to the precision. If the precision is not specified then the default value is 6. If the precision is less than the number of digits which would appear after the decimal point in the string returned by Float.toString(float) or Double.toString(double) respectively, then the value will be rounded using the round half up algorithm. Otherwise, zeros may be appended to reach the precision. For a canonical representation of the value, use Float.toString(float) or Double.toString(double) as appropriate.

    'a' '\u0061' Requires the output to be formatted in hexadecimal exponential form. No localization is applied.

    The result is a string that represents the sign and magnitude (absolute value) of the argument x.

    If x is negative or a negative-zero value then the result will begin with '-' ('\u002d').

    If x is positive or a positive-zero value and the '+' flag is given then the result will begin with '+' ('\u002b').

    The formatting of the magnitude m depends upon its value.

    • If the value is NaN or infinite, the literal strings "NaN" or "Infinity", respectively, will be output.
    • If m is zero then it is represented by the string "0x0.0p0".
    • If m is a double value with a normalized representation then substrings are used to represent the significand and exponent fields. The significand is represented by the characters "0x1." followed by the hexadecimal representation of the rest of the significand as a fraction. The exponent is represented by 'p' ('\u0070') followed by a decimal string of the unbiased exponent as if produced by invoking Integer.toString on the exponent value. If the precision is specified, the value is rounded to the given number of hexadecimal digits.
    • If m is a double value with a subnormal representation then, unless the precision is specified to be in the range 1 through 12, inclusive, the significand is represented by the characters '0x0.' followed by the hexadecimal representation of the rest of the significand as a fraction, and the exponent represented by 'p-1022'. If the precision is in the interval [1, 12], the subnormal value is normalized such that it begins with the characters '0x1.', rounded to the number of hexadecimal digits of precision, and the exponent adjusted accordingly. Note that there must be at least one nonzero digit in a subnormal significand.

    If the '(' or ',' flags are given, then a FormatFlagsConversionMismatchException will be thrown.

    'A' '\u0041' The upper-case variant of 'a'. The entire string representing the number will be converted to upper case including the 'x' ('\u0078') and 'p' ('\u0070' and all hexadecimal digits 'a' - 'f' ('\u0061' - '\u0066').

    所有flags定义为字节，短，整数和长度适用。

    如果给出了'#'标志，则小数分隔符将始终存在。

    如果没有给出flags ，默认格式如下：

    • 输出在width内width
    • 负数以'-'
    • 正数和正零不包括符号或额外的前导空间
    • 不包括分组分隔符
    • 小数分隔符仅在数字跟随时才会出现

    width是要写入输出的最小字符数。 这包括任何符号，数字，分组分隔符，十进制分隔符，指数符号，基数指示符，括号和表示无穷大和NaN的字符串。 如果转换的值的长度小于宽度，则输出将被空格（ '\u0020' ）填充，直到字符的总数等于宽度。 默认情况下，填充在左侧。 如果给出了'-'标志，则填充将在右侧。 如果没有指定width，那么没有最小值。

    如果conversion是'e' ， 'E'或'f' ，则精度是数字的小数分隔后的位数。 如果未指定精度，则假定为6 。

    如果转换为'g'或'G' ，则精度是四舍五入后产生的大小的有效数字的总数。 如果未指定精度，则默认值为6 。 如果精度为0 ， 1 。

    如果转换为'a'或'A' ，则精度是小数点之后的十六进制数字。 如果没有提供精度，则输出Double.toHexString(double)返回的所有数字。

    BigDecimal

    可以应用以下转换BigDecimal 。

    floatConv 'e' '\u0065' Requires the output to be formatted using computerized scientific notation. The localization algorithm is applied.

    The formatting of the magnitude m depends upon its value.

    If m is positive-zero or negative-zero, then the exponent will be "+00".

    Otherwise, the result is a string that represents the sign and magnitude (absolute value) of the argument. The formatting of the sign is described in the localization algorithm. The formatting of the magnitude m depends upon its value.

    Let n be the unique integer such that 10n <= m < 10n+1; then let a be the mathematically exact quotient of m and 10n so that 1 <= a < 10. The magnitude is then represented as the integer part of a, as a single decimal digit, followed by the decimal separator followed by decimal digits representing the fractional part of a, followed by the exponent symbol 'e' ('\u0065'), followed by the sign of the exponent, followed by a representation of n as a decimal integer, as produced by the method Long.toString(long, int), and zero-padded to include at least two digits.

    The number of digits in the result for the fractional part of m or a is equal to the precision. If the precision is not specified then the default value is 6. If the precision is less than the number of digits to the right of the decimal point then the value will be rounded using the round half up algorithm. Otherwise, zeros may be appended to reach the precision. For a canonical representation of the value, use BigDecimal.toString().

    If the ',' flag is given, then an FormatFlagsConversionMismatchException will be thrown.

    'E' '\u0045' The upper-case variant of 'e'. The exponent symbol will be 'E' ('\u0045'). 'g' '\u0067' Requires the output to be formatted in general scientific notation as described below. The localization algorithm is applied.

    After rounding for the precision, the formatting of the resulting magnitude m depends on its value.

    If m is greater than or equal to 10-4 but less than 10precision then it is represented in decimal format.

    If m is less than 10-4 or greater than or equal to 10precision, then it is represented in computerized scientific notation.

    The total number of significant digits in m is equal to the precision. If the precision is not specified, then the default value is 6. If the precision is 0, then it is taken to be 1.

    If the '#' flag is given then an FormatFlagsConversionMismatchException will be thrown.

    'G' '\u0047' The upper-case variant of 'g'. 'f' '\u0066' Requires the output to be formatted using decimal format. The localization algorithm is applied.

    The result is a string that represents the sign and magnitude (absolute value) of the argument. The formatting of the sign is described in the localization algorithm. The formatting of the magnitude m depends upon its value.

    The magnitude is formatted as the integer part of m, with no leading zeroes, followed by the decimal separator followed by one or more decimal digits representing the fractional part of m.

    The number of digits in the result for the fractional part of m or a is equal to the precision. If the precision is not specified then the default value is 6. If the precision is less than the number of digits to the right of the decimal point then the value will be rounded using the round half up algorithm. Otherwise, zeros may be appended to reach the precision. For a canonical representation of the value, use BigDecimal.toString().

    所有flags为Byte，Short，Integer和Long定义。

    如果给出了'#'标志，则小数分隔符将始终存在。

    default behavior当没有标志被赋予与浮动和双重相同。

    width和precision的规格与Float和Double的定义相同。

    Date/Time

    这种转换可以应用于long ， Long ， Calendar ， Date和TemporalAccessor

    DTConv 't' '\u0074' Prefix for date and time conversion characters. 'T' '\u0054' The upper-case variant of 't'.

    为't'和'T'转换定义了以下日期和时间转换字符后缀。 类型与GNU date和POSIX strftime(3c)所定义的类似但不完全相同。 提供了其他转换类型来访问Java特定的功能（例如'L'在秒内为毫秒）。

    以下转换字符用于格式化时间：

    time 'H' '\u0048' Hour of the day for the 24-hour clock, formatted as two digits with a leading zero as necessary i.e. 00 - 23. 00 corresponds to midnight. 'I' '\u0049' Hour for the 12-hour clock, formatted as two digits with a leading zero as necessary, i.e. 01 - 12. 01 corresponds to one o'clock (either morning or afternoon). 'k' '\u006b' Hour of the day for the 24-hour clock, i.e. 0 - 23. 0 corresponds to midnight. 'l' '\u006c' Hour for the 12-hour clock, i.e. 1 - 12. 1 corresponds to one o'clock (either morning or afternoon). 'M' '\u004d' Minute within the hour formatted as two digits with a leading zero as necessary, i.e. 00 - 59. 'S' '\u0053' Seconds within the minute, formatted as two digits with a leading zero as necessary, i.e. 00 - 60 ("60" is a special value required to support leap seconds). 'L' '\u004c' Millisecond within the second formatted as three digits with leading zeros as necessary, i.e. 000 - 999. 'N' '\u004e' Nanosecond within the second, formatted as nine digits with leading zeros as necessary, i.e. 000000000 - 999999999. The precision of this value is limited by the resolution of the underlying operating system or hardware. 'p' '\u0070' Locale-specific morning or afternoon marker in lower case, e.g."am" or "pm". Use of the conversion prefix 'T' forces this output to upper case. (Note that 'p' produces lower-case output. This is different from GNU date and POSIX strftime(3c) which produce upper-case output.) 'z' '\u007a' RFC 822 style numeric time zone offset from GMT, e.g. -0800. This value will be adjusted as necessary for Daylight Saving Time. For long, Long, and Date the time zone used is the default time zone for this instance of the Java virtual machine. 'Z' '\u005a' A string representing the abbreviation for the time zone. This value will be adjusted as necessary for Daylight Saving Time. For long, Long, and Date the time zone used is the default time zone for this instance of the Java virtual machine. The Formatter's locale will supersede the locale of the argument (if any). 's' '\u0073' Seconds since the beginning of the epoch starting at 1 January 1970 00:00:00 UTC, i.e. Long.MIN_VALUE/1000 to Long.MAX_VALUE/1000. 'Q' '\u004f' Milliseconds since the beginning of the epoch starting at 1 January 1970 00:00:00 UTC, i.e. Long.MIN_VALUE to Long.MAX_VALUE. The precision of this value is limited by the resolution of the underlying operating system or hardware.

    以下转换字符用于格式化日期：

    date 'B' '\u0042' Locale-specific full month name, e.g. "January", "February". 'b' '\u0062' Locale-specific abbreviated month name, e.g. "Jan", "Feb". 'h' '\u0068' Same as 'b'. 'A' '\u0041' Locale-specific full name of the day of the week, e.g. "Sunday", "Monday" 'a' '\u0061' Locale-specific short name of the day of the week, e.g. "Sun", "Mon" 'C' '\u0043' Four-digit year divided by 100, formatted as two digits with leading zero as necessary, i.e. 00 - 99 'Y' '\u0059' Year, formatted to at least four digits with leading zeros as necessary, e.g. 0092 equals 92 CE for the Gregorian calendar. 'y' '\u0079' Last two digits of the year, formatted with leading zeros as necessary, i.e. 00 - 99. 'j' '\u006a' Day of year, formatted as three digits with leading zeros as necessary, e.g. 001 - 366 for the Gregorian calendar. 001 corresponds to the first day of the year. 'm' '\u006d' Month, formatted as two digits with leading zeros as necessary, i.e. 01 - 13, where "01" is the first month of the year and ("13" is a special value required to support lunar calendars). 'd' '\u0064' Day of month, formatted as two digits with leading zeros as necessary, i.e. 01 - 31, where "01" is the first day of the month. 'e' '\u0065' Day of month, formatted as two digits, i.e. 1 - 31 where "1" is the first day of the month.

    以下转换字符用于格式化常用日期/时间组合。

    composites 'R' '\u0052' Time formatted for the 24-hour clock as "%tH:%tM" 'T' '\u0054' Time formatted for the 24-hour clock as "%tH:%tM:%tS". 'r' '\u0072' Time formatted for the 12-hour clock as "%tI:%tM:%tS %Tp". The location of the morning or afternoon marker ('%Tp') may be locale-dependent. 'D' '\u0044' Date formatted as "%tm/%td/%ty". 'F' '\u0046' ISO 8601 complete date formatted as "%tY-%tm-%td". 'c' '\u0063' Date and time formatted as "%ta %tb %td %tT %tZ %tY", e.g. "Sun Jul 20 16:17:00 EDT 1969".

    适用于General conversions的'-'标志。 如果给出了'#'标志，那么将抛出一个FormatFlagsConversionMismatchException 。

    宽度是要写入输出的最小字符数。 如果转换值的长度小于width则输出将以空格（ '\u0020' ）填充，直到总字符数等于宽。 默认情况下，填充在左侧。 如果给出了'-'标志，则填充将在右侧。 如果没有指定width，那么没有最小值。

    精度不适用。 如果指定精度，则抛出IllegalFormatPrecisionException 。

    Percent

    转换不符合任何参数。

    DTConv '%' The result is a literal '%' ('\u0025')

    The width is the minimum number of characters to be written to the output including the '%'. If the length of the converted value is less than the width then the output will be padded by spaces ('\u0020') until the total number of characters equals width. The padding is on the left. If width is not specified then just the '%' is output.

    The '-' flag defined for General conversions applies. If any other flags are provided, then a FormatFlagsConversionMismatchException will be thrown.

    The precision is not applicable. If the precision is specified an IllegalFormatPrecisionException will be thrown.

    Line Separator

    转换不符合任何参数。

    DTConv 'n' the platform-specific line separator as returned by System.lineSeparator().

    标志，宽度和精度不适用。 如果任何提供的IllegalFormatFlagsException ， IllegalFormatWidthException ，并IllegalFormatPrecisionException ，分别将被抛出。

    Argument Index

    格式说明符可以通过三种方式引用参数：

    • 当格式说明符包含参数索引时，将使用显式索引 。 参数index是一个十进制整数，表示参数在参数列表中的位置。 第一个参数由“ 1$ ”引用，第二个参数由“ 2$ ”等引用。参数可以被多次引用。

      例如：

         formatter.format("%4$s %3$s %2$s %1$s %4$s %3$s %2$s %1$s",
                    "a", "b", "c", "d")
   // -> "d c b a d c b a"
    • 当格式说明符包含'<' （ '\u003c' ）标志时，使用相对索引 ，该标志导致先前格式说明符的参数被重新使用。 如果没有以前的参数，则抛出一个MissingFormatArgumentException 。
          formatter.format("%s %s %<s %<s", "a", "b", "c", "d")
    // -> "a b b b"
    // "c" and "d" are ignored because they are not referenced
    • 当格式说明符既不包含参数索引也不包含'<'标志时，将使用普通索引 。 使用普通索引的每个格式说明符都被分配给参数列表中的顺序隐含索引，该索引独立于显式索引或相对索引使用的索引。
         formatter.format("%s %s %s %s", "a", "b", "c", "d")
   // -> "a b c d"

    可以使用使用所有形式的索引的格式字符串，例如：

       formatter.format("%2$s %s %<s %s", "a", "b", "c", "d")
   // -> "b a a b"
   // "c" and "d" are ignored because they are not referenced

    参数的最大数量受限于The Java™ Virtual Machine Specification定义的Java数组的最大维度。 如果参数索引不符合可用的参数，则抛出MissingFormatArgumentException 。

    如果比格式说明符更多的参数，额外的参数将被忽略。

    除非另有说明，否则将null参数传递给null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Formatter.BigDecimalLayoutForm
      枚举为 BigDecimal格式化。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Formatter​()
      构造一个新的格式化程序。
      Formatter​(File file)
      使用指定的文件构造一个新的格式化程序。
      Formatter​(File file, String csn)
      使用指定的文件和字符集构造一个新的格式化程序。
      Formatter​(File file, String csn, Locale l)
      使用指定的文件，字符集和区域设置构造一个新的格式化程序。
      Formatter​(OutputStream os)
      使用指定的输出流构造一个新的格式化程序。
      Formatter​(OutputStream os, String csn)
      使用指定的输出流和字符集构造一个新的格式化程序。
      Formatter​(OutputStream os, String csn, Locale l)
      使用指定的输出流，字符集和区域设置构造一个新的格式化程序。
      Formatter​(PrintStream ps)
      使用指定的打印流构造新的格式化程序。
      Formatter​(Appendable a)
      构造具有指定目的地的新格式化程序。
      Formatter​(Appendable a, Locale l)
      构造一个具有指定目的地和区域设置的新格式化程序。
      Formatter​(String fileName)
      构造具有指定文件名的新格式化程序。
      Formatter​(String fileName, String csn)
      构造具有指定文件名和字符集的新格式化程序。
      Formatter​(String fileName, String csn, Locale l)
      构造具有指定文件名，字符集和区域设置的新格式化程序。
      Formatter​(Locale l)
      构造具有指定区域设置的新格式化程序。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此格式化程序。
      void flush​()
      刷新格式化程序。
      Formatter format​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此对象的目标。
      Formatter format​(Locale l, String format, Object... args)
      使用指定的区域设置，格式字符串和参数将格式化的字符串写入此对象的目标。
      IOException ioException​()
      返回IOException最后通过此格式的抛出Appendable 。
      Locale locale​()
      返回通过构建此格式化程序设置的区域设置。
      Appendable out​()
      返回输出的目的地。
      String toString​()
      返回在输出的目的地调用 toString()的结果。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Formatter

        public Formatter​()
        构造一个新的格式化程序。

        格式化输出的目的地是StringBuilder其可以通过调用被检索out()并且其当前内容可以通过调用被转换成字符串toString() 。 所使用的语言环境是这个Java虚拟机实例的formatting的default locale 。

      • Formatter

        public Formatter​(Appendable a)
        构造具有指定目的地的新格式化程序。

        所使用的语言环境是这个Java虚拟机实例的default locale formatting 。

        参数
        a - 格式化输出的目的地。 如果a是null那么将创建一个StringBuilder 。

      • Formatter

        public Formatter​(Locale l)
        构造具有指定区域设置的新格式化程序。

        格式化输出的目的地是StringBuilder其可以通过调用被检索out()并且其当前内容可以通过调用被转换成字符串toString() 。

        参数
        l - 格式化期间应用的locale 。 如果l是null那么不应用本地化。

      • Formatter

        public Formatter​(Appendable a,
                 Locale l)
        构造一个具有指定目的地和区域设置的新格式化程序。
        参数
        a - 格式化输出的目的地。 如果a是null那么将创建一个StringBuilder 。
        l - 格式化期间应用的locale 。 如果l为null则不应用本地化。

      • Formatter

        public Formatter​(String fileName)
          throws FileNotFoundException
        构造具有指定文件名的新格式化程序。

        所使用的字符集是这个Java虚拟机实例的default charset 。

        使用的语言环境是default locale为formatting Java虚拟机实例。

        参数
        fileName - 用作此格式化程序的目标位置的文件的名称。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        异常
        SecurityException - 如果存在安全管理员，并且 checkWrite(fileName)拒绝对该文件的写入访问
        FileNotFoundException - 如果给定的文件名不表示现有的可写的常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他错误

      • Formatter

        public Formatter​(String fileName,
                 String csn)
          throws FileNotFoundException,
                 UnsupportedEncodingException
        构造具有指定文件名和字符集的新格式化程序。

        使用的语言环境是default locale为formatting Java虚拟机实例。

        参数
        fileName - 用作此格式化程序的目标位置的文件的名称。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        csn - 支持的名称charset
        异常
        FileNotFoundException - 如果给定的文件名不表示现有的可写的常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时出现其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(fileName)拒绝对该文件的写入访问
        UnsupportedEncodingException - 如果不支持命名的字符集

      • Formatter

        public Formatter​(String fileName,
                 String csn,
                 Locale l)
          throws FileNotFoundException,
                 UnsupportedEncodingException
        构造具有指定文件名，字符集和区域设置的新格式化程序。
        参数
        fileName - 要用作此格式化程序的目标的文件的名称。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        csn - 支持的名称charset
        l - 格式化期间应用的locale 。 如果l为null则不应用本地化。
        异常
        FileNotFoundException - 如果给定的文件名不表示现有的，可写的常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(fileName)否认对该文件的写入访问
        UnsupportedEncodingException - 如果不支持命名的字符集

      • Formatter

        public Formatter​(File file)
          throws FileNotFoundException
        使用指定的文件构造一个新的格式化程序。

        所使用的字符集是Java虚拟机的这个实例的default charset 。

        所使用的语言环境是这个Java虚拟机实例的default locale formatting 。

        参数
        file - 用作此格式化程序的目的地的文件。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        异常
        SecurityException - 如果存在安全管理员，并且 checkWrite(file.getPath())拒绝对该文件的写入访问
        FileNotFoundException - 如果给定的文件对象不表示现有的，可写的常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时出现其他错误

      • Formatter

        public Formatter​(File file,
                 String csn)
          throws FileNotFoundException,
                 UnsupportedEncodingException
        使用指定的文件和字符集构造一个新的格式化程序。

        使用的语言环境是default locale为formatting Java虚拟机实例。

        参数
        file - 用作此格式化程序的目的地的文件。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        csn - 支持的名称charset
        异常
        FileNotFoundException - 如果给定的文件对象不表示现有的可写的常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(file.getPath())否认对该文件的写入权限
        UnsupportedEncodingException - 如果不支持命名的字符集

      • Formatter

        public Formatter​(File file,
                 String csn,
                 Locale l)
          throws FileNotFoundException,
                 UnsupportedEncodingException
        使用指定的文件，字符集和区域设置构造一个新的格式化程序。
        参数
        file - 用作此格式化程序的目标位置的文件。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        csn - 支持的名称charset
        l - 格式化期间应用的locale 。 如果l是null则不应用本地化。
        异常
        FileNotFoundException - 如果给定的文件对象不表示现有的可写的常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(file.getPath())否认对该文件的写入权限
        UnsupportedEncodingException - 如果不支持命名的字符集

      • Formatter

        public Formatter​(PrintStream ps)
        使用指定的打印流构造新的格式化程序。

        所使用的语言环境是这个Java虚拟机实例的formatting的default locale 。

        字符写入给定的PrintStream对象，因此使用该对象的字符集进行编码。

        参数
        ps - 用作此格式化程序的目标的流。

      • Formatter

        public Formatter​(OutputStream os)
        使用指定的输出流构造一个新的格式化程序。

        所使用的字符集是Java虚拟机的这个实例的default charset 。

        所使用的语言环境是default locale ，适用于此Java虚拟机实例的formatting 。

        参数
        os - 用作此格式化程序的目标的输出流。 输出将被缓冲。

      • Formatter

        public Formatter​(OutputStream os,
                 String csn)
          throws UnsupportedEncodingException
        使用指定的输出流和字符集构造一个新的格式化程序。

        使用的语言环境是default locale为formatting Java虚拟机实例。

        参数
        os - 用作此格式化程序的目的地的输出流。 输出将被缓冲。
        csn - 支持的名称charset
        异常
        UnsupportedEncodingException - 如果不支持命名的字符集

      • Formatter

        public Formatter​(OutputStream os,
                 String csn,
                 Locale l)
          throws UnsupportedEncodingException
        使用指定的输出流，字符集和区域设置构造一个新的格式化程序。
        参数
        os - 用作此格式化程序目标的输出流。 输出将被缓冲。
        csn - 支持的名称charset
        l - 格式化期间应用的locale 。 如果l是null则不应用本地化。
        异常
        UnsupportedEncodingException - 如果不支持命名的字符集

    • 方法详细信息

      • locale

        public Locale locale​()
        返回通过构建此格式化程序设置的区域设置。

        具有locale参数的此对象的format方法不会更改此值。

        结果
        null如果没有应用本地化，否则是一个区域设置
        异常
        FormatterClosedException - 如果这个格式化程序已经通过调用其 close()方法关闭了

      • out

        public Appendable out​()
        返回输出的目的地。
        结果
        输出的目的地
        异常
        FormatterClosedException - 如果该格式化程序已通过调用其 close()方法关闭

      • toString

        public String toString​()
        返回在输出的目的地上调用toString()的结果。 例如，以下代码将文本格式化为StringBuilder，然后检索结果字符串：
           Formatter f = new Formatter();
   f.format("Last reboot at %tc", lastRebootDate);
   String s = f.toString();
   // -> s == "Last reboot at Sat Jan 01 00:00:00 PST 2000"

        调用此方法的行为方式与调用完全相同

          out().toString()

        取决于toString的toString的规格，返回的字符串可能包含或不包含写入目的地的字符。 例如，缓冲区通常在toString()返回其内容，但是由于数据被丢弃，流不能。

        重写：
        toString在 Object
        结果
        调用 toString()在目的地输出的结果
        异常
        FormatterClosedException - 如果这个格式化程序已经通过调用其 close()方法关闭了

      • flush

        public void flush​()
        刷新格式化程序。 如果目的地实现Flushable接口，则其flush方法将被调用。

        刷新格式器将目标中的任何缓冲输出写入底层流。

        Specified by:
        flush在接口 Flushable
        异常
        FormatterClosedException - 如果该格式化程序通过调用其 close()方法已关闭

      • close

        public void close​()
        关闭此格式化程序。 如果目的地实现了Closeable接口，则会调用其close方法。

        关闭格式化程序允许它释放它可能持有的资源（如打开的文件）。 如果格式化程序已经关闭，则调用此方法没有任何作用。

        在这个格式化程序关闭之后，除了ioException()之外，试图调用任何方法将导致一个FormatterClosedException 。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable

      • ioException

        public IOException ioException​()
        返回IOException最后通过此格式的抛出Appendable 。

        如果目的地的append()方法永远不会抛出IOException ，那么这种方法将永远返回null 。

        结果
        由Appendable抛出的最后一个异常或 null如果不存在此类异常。

      • format

        public Formatter format​(String format,
                        Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入此对象的目标。 所使用的区域是在构建格式化程序期间定义的区域。
        参数
        format -如在描述的格式字符串 Format string syntax 。
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的最大数量受限于由The Java™ Virtual Machine Specification定义的Java数组的最大维度。
        结果
        这个格式化
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        FormatterClosedException - 如果这个格式化程序已经通过调用其 close()方法关闭了

      • format

        public Formatter format​(Locale l,
                        String format,
                        Object... args)
        使用指定的区域设置，格式字符串和参数将格式化的字符串写入此对象的目标。
        参数
        l - 格式化期间应用的locale 。 如果l为null则不应用本地化。 这不会改变在构建期间设置的对象的区域设置。
        format - Format string syntax中描述的格式字符串
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的最大数量受限于The Java™ Virtual Machine Specification定义的Java数组的最大维度。
        结果
        这个格式化
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        FormatterClosedException - 如果该格式化程序通过调用其 close()方法已关闭
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Formatter.BigDecimalLayoutForm (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.util

Enum Formatter.BigDecimalLayoutForm

  • java.lang.Object
    • java.lang.Enum<Formatter.BigDecimalLayoutForm>
      • java.util.Formatter.BigDecimalLayoutForm
  • All Implemented Interfaces:
    Serializable ， Comparable<Formatter.BigDecimalLayoutForm>
    Enclosing class:
    Formatter

    public static enum Formatter.BigDecimalLayoutForm
extends Enum<Formatter.BigDecimalLayoutForm>
    枚举为 BigDecimal格式化。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DECIMAL_FLOAT
      将 BigDecimal格式化为十进制数。
      SCIENTIFIC
      格式化 BigDecimal计算机科学计数。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Formatter.BigDecimalLayoutForm valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Formatter.BigDecimalLayoutForm[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SCIENTIFIC

        public static final Formatter.BigDecimalLayoutForm SCIENTIFIC
        格式化 BigDecimal计算机科学计数。

      • DECIMAL_FLOAT

        public static final Formatter.BigDecimalLayoutForm DECIMAL_FLOAT
        将 BigDecimal格式化为十进制数。

    • 方法详细信息

      • values

        public static Formatter.BigDecimalLayoutForm[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Formatter.BigDecimalLayoutForm c : Formatter.BigDecimalLayoutForm.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Formatter.BigDecimalLayoutForm valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


FormatterClosedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class FormatterClosedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.util.FormatterClosedException
  • All Implemented Interfaces:
    Serializable

    public class FormatterClosedException
extends IllegalStateException
    格式化程序已关闭时抛出未检查的异常。

    除非另有说明，否则传递一个null参数到null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FormatterClosedException​()
      构造这个类的一个实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FormatterClosedException

        public FormatterClosedException​()
        构造这个类的一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GregorianCalendar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class GregorianCalendar

  • java.lang.Object
    • java.util.Calendar
      • java.util.GregorianCalendar
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Comparable<Calendar>

    public class GregorianCalendar
extends Calendar
    GregorianCalendar是的具体子Calendar ，并提供了世界上大多数国家使用的标准日历系统。

    GregorianCalendar是一个混合日历，支持朱利安和公历日历系统，支持一个不连续性，默认情况下对应于格里高利日历（公元1582年10月15日，在一些国家，稍后在其他国家）。 主叫方可以通过拨打setGregorianChange()更改切换日期。

    历史上，1582年10月4日（朱利安）首先采用公历的那些国家，之后是1582年10月15日（格里高利）。 这个日历模型正确。 在格里高利GregorianCalendar之前， GregorianCalendar执行朱利安历。 公历和儒略历的唯一区别是闰年规则。 朱利安历法每四年规定一次闰年，而公历则省略了不能被400整除的百年。

    GregorianCalendar实现proleptic格里高利历和罗马儒略历。 也就是说，日期是通过在时间上无限远地向后和向前推断当前规则来计算的。 因此，可以使用GregorianCalendar多年来产生有意义和一致的结果。 然而，使用GregorianCalendar获得的日期从GregorianCalendar 4月1日起才是历史上准确的，当时采用现代朱利安日历规则。 在此之前，闰年的规则是不规则地应用的，而在公元前45年，朱利安历法甚至不存在。

    在制定公历之前，元旦是3月25日。为了避免混淆，这个日历总是使用1月1日。如果需要在公历转换之前的日期进行手动调整，并且在1月1日之间和3月24日。

    Week Of Year and Week Year

    为WEEK_OF_YEAR字段计算的值范围为1到53.一个日历年的第一周是从getFirstDayOfWeek()开始的最早的七天期间，从该年起至少包含getMinimalDaysInFirstWeek()天。 因而它取决于的值getMinimalDaysInFirstWeek() ， getFirstDayOfWeek() ，和一周的一月的一年1周和下一年的1周（不包括）顺序地被编号为2至52或53（除了间1.周一天一年涉及朱利安 - 格里高利转型）。

    的getFirstDayOfWeek()个getMinimalDaysInFirstWeek()值构建在使用区域设置相关的资源初始化GregorianCalendar 。 The week determination is compatible当所述ISO 8601标准getFirstDayOfWeek()是MONDAY和getMinimalDaysInFirstWeek()是4，其值是在其中标准是优选的语言环境使用。 这些值可以通过调用setFirstDayOfWeek()和setMinimalDaysInFirstWeek()来显式设置。

    A week year与WEEK_OF_YEAR周期同步。 第一周和最后一周（含）之间的所有星期都具有相同的周年价值。 因此，一周的第一天和最后几天可能有不同的日历年值。

    例如，1998年1月1日是星期四。 如果getFirstDayOfWeek()是MONDAY和getMinimalDaysInFirstWeek()是4（ISO 8601标准兼容环境），那么1998年的第1周从1997年12月29日开始，到1998年1月4日结束。1997年是1998年1997年的最后三天但是，如果getFirstDayOfWeek()是SUNDAY ，则1998年第1周从1998年1月4日开始，1998年1月10日结束; 1998年的头三天是1997年第53周的一部分，他们的周末是1997年。

    几个月

    为WEEK_OF_MONTH字段计算的值范围为0至6.一个月的第一周（ WEEK_OF_MONTH = 1的天WEEK_OF_MONTH = 1 ）是该月份至少getMinimalDaysInFirstWeek()连续天数的最早集合，截止于getFirstDayOfWeek()之前的一天。 与一年的第1周不同，一个月的第1周可能短于7天，不需要从getFirstDayOfWeek()开始，不包括上个月的天数。 第1周前一个月的天数为WEEK_OF_MONTH ，为0。

    例如，如果getFirstDayOfWeek()是SUNDAY和getMinimalDaysInFirstWeek()是4，那么1998年1月的第一个星期是1月4日星期日到1月10日星期六。这些日子有一个WEEK_OF_MONTH 1月1日星期四到1月3日星期六有一个WEEK_OF_MONTH为0.如果getMinimalDaysInFirstWeek()改为3，则1月1日至1月3日期间有一个WEEK_OF_MONTH 。

    默认字段值

    clear方法设置日历字段未定义。 如果其值未定义，则GregorianCalendar对每个日历字段使用以下默认值。

    GregorianCalendar default field values Field Default Value ERA AD YEAR 1970 MONTH JANUARY DAY_OF_MONTH 1 DAY_OF_WEEK the first day of week WEEK_OF_MONTH 0 DAY_OF_WEEK_IN_MONTH 1 AM_PM AM HOUR, HOUR_OF_DAY, MINUTE, SECOND, MILLISECOND 0

    默认值不适用于上面未列出的字段。

    例：

     // get the supported ids for GMT-08:00 (Pacific Standard Time)
 String[] ids = TimeZone.getAvailableIDs(-8 * 60 * 60 * 1000);
 // if no ids were returned, something is wrong. get out.
 if (ids.length == 0)
     System.exit(0);

  // begin output
 System.out.println("Current Time");

 // create a Pacific Standard Time time zone
 SimpleTimeZone pdt = new SimpleTimeZone(-8 * 60 * 60 * 1000, ids[0]);

 // set up rules for Daylight Saving Time
 pdt.setStartRule(Calendar.APRIL, 1, Calendar.SUNDAY, 2 * 60 * 60 * 1000);
 pdt.setEndRule(Calendar.OCTOBER, -1, Calendar.SUNDAY, 2 * 60 * 60 * 1000);

 // create a GregorianCalendar with the Pacific Daylight time zone
 // and the current date and time
 Calendar calendar = new GregorianCalendar(pdt);
 Date trialTime = new Date();
 calendar.setTime(trialTime);

 // print out a bunch of interesting things
 System.out.println("ERA: " + calendar.get(Calendar.ERA));
 System.out.println("YEAR: " + calendar.get(Calendar.YEAR));
 System.out.println("MONTH: " + calendar.get(Calendar.MONTH));
 System.out.println("WEEK_OF_YEAR: " + calendar.get(Calendar.WEEK_OF_YEAR));
 System.out.println("WEEK_OF_MONTH: " + calendar.get(Calendar.WEEK_OF_MONTH));
 System.out.println("DATE: " + calendar.get(Calendar.DATE));
 System.out.println("DAY_OF_MONTH: " + calendar.get(Calendar.DAY_OF_MONTH));
 System.out.println("DAY_OF_YEAR: " + calendar.get(Calendar.DAY_OF_YEAR));
 System.out.println("DAY_OF_WEEK: " + calendar.get(Calendar.DAY_OF_WEEK));
 System.out.println("DAY_OF_WEEK_IN_MONTH: "
                    + calendar.get(Calendar.DAY_OF_WEEK_IN_MONTH));
 System.out.println("AM_PM: " + calendar.get(Calendar.AM_PM));
 System.out.println("HOUR: " + calendar.get(Calendar.HOUR));
 System.out.println("HOUR_OF_DAY: " + calendar.get(Calendar.HOUR_OF_DAY));
 System.out.println("MINUTE: " + calendar.get(Calendar.MINUTE));
 System.out.println("SECOND: " + calendar.get(Calendar.SECOND));
 System.out.println("MILLISECOND: " + calendar.get(Calendar.MILLISECOND));
 System.out.println("ZONE_OFFSET: "
                    + (calendar.get(Calendar.ZONE_OFFSET)/(60*60*1000)));
 System.out.println("DST_OFFSET: "
                    + (calendar.get(Calendar.DST_OFFSET)/(60*60*1000)));

 System.out.println("Current Time, with hour reset to 3");
 calendar.clear(Calendar.HOUR_OF_DAY); // so doesn't override
 calendar.set(Calendar.HOUR, 3);
 System.out.println("ERA: " + calendar.get(Calendar.ERA));
 System.out.println("YEAR: " + calendar.get(Calendar.YEAR));
 System.out.println("MONTH: " + calendar.get(Calendar.MONTH));
 System.out.println("WEEK_OF_YEAR: " + calendar.get(Calendar.WEEK_OF_YEAR));
 System.out.println("WEEK_OF_MONTH: " + calendar.get(Calendar.WEEK_OF_MONTH));
 System.out.println("DATE: " + calendar.get(Calendar.DATE));
 System.out.println("DAY_OF_MONTH: " + calendar.get(Calendar.DAY_OF_MONTH));
 System.out.println("DAY_OF_YEAR: " + calendar.get(Calendar.DAY_OF_YEAR));
 System.out.println("DAY_OF_WEEK: " + calendar.get(Calendar.DAY_OF_WEEK));
 System.out.println("DAY_OF_WEEK_IN_MONTH: "
                    + calendar.get(Calendar.DAY_OF_WEEK_IN_MONTH));
 System.out.println("AM_PM: " + calendar.get(Calendar.AM_PM));
 System.out.println("HOUR: " + calendar.get(Calendar.HOUR));
 System.out.println("HOUR_OF_DAY: " + calendar.get(Calendar.HOUR_OF_DAY));
 System.out.println("MINUTE: " + calendar.get(Calendar.MINUTE));
 System.out.println("SECOND: " + calendar.get(Calendar.SECOND));
 System.out.println("MILLISECOND: " + calendar.get(Calendar.MILLISECOND));
 System.out.println("ZONE_OFFSET: "
        + (calendar.get(Calendar.ZONE_OFFSET)/(60*60*1000))); // in hours
 System.out.println("DST_OFFSET: "
        + (calendar.get(Calendar.DST_OFFSET)/(60*60*1000))); // in hours
    从以下版本开始：
    1.1
    另请参见：
    TimeZone ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.Calendar

        Calendar.Builder

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int AD
      价值 ERA字段表示共同的时代（Anno Domini），也被称为CE。
      static int BC
      表示 ERA字段的价值，表示在共同时代之前（基督之前），也称为公元前百年。

      • Fields inherited from class java.util.Calendar

        ALL_STYLES, AM, AM_PM, APRIL, areFieldsSet, AUGUST, DATE, DAY_OF_MONTH, DAY_OF_WEEK, DAY_OF_WEEK_IN_MONTH, DAY_OF_YEAR, DECEMBER, DST_OFFSET, ERA, FEBRUARY, FIELD_COUNT, fields, FRIDAY, HOUR, HOUR_OF_DAY, isSet, isTimeSet, JANUARY, JULY, JUNE, LONG, LONG_FORMAT, LONG_STANDALONE, MARCH, MAY, MILLISECOND, MINUTE, MONDAY, MONTH, NARROW_FORMAT, NARROW_STANDALONE, NOVEMBER, OCTOBER, PM, SATURDAY, SECOND, SEPTEMBER, SHORT, SHORT_FORMAT, SHORT_STANDALONE, SUNDAY, THURSDAY, time, TUESDAY, UNDECIMBER, WEDNESDAY, WEEK_OF_MONTH, WEEK_OF_YEAR, YEAR, ZONE_OFFSET

    • 构造方法摘要

      构造方法
      Constructor 描述
      GregorianCalendar​()
      使用缺省 GregorianCalendar的默认时区中的当前时间构建默认值 GregorianCalendar 。
      GregorianCalendar​(int year, int month, int dayOfMonth)
      构造一个 GregorianCalendar ，其默认时区中的给定日期设置为默认语言环境。
      GregorianCalendar​(int year, int month, int dayOfMonth, int hourOfDay, int minute)
      构造一个 GregorianCalendar ，给定日期和时间为默认时区设置默认语言环境。
      GregorianCalendar​(int year, int month, int dayOfMonth, int hourOfDay, int minute, int second)
      构造一个GregorianCalendar，其中给定的日期和时间为默认时区设置为默认语言环境。
      GregorianCalendar​(Locale aLocale)
      根据具有给定语言环境的默认时区中的当前时间构建一个 GregorianCalendar 。
      GregorianCalendar​(TimeZone zone)
      根据指定时区中的当前时间，使用默认的 FORMAT区域设置构建一个 GregorianCalendar 。
      GregorianCalendar​(TimeZone zone, Locale aLocale)
      根据给定时区的当前时间，使用给定的区域设置构建一个 GregorianCalendar 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(int field, int amount)
      根据日历的规则，将指定的（已签名的）时间添加到给定的日历字段。
      Object clone​()
      创建并返回此对象的副本。
      protected void computeFields​()
      将时间值（从 Epoch的毫秒偏移）转换为日历字段值。
      protected void computeTime​()
      将日历字段值转换为时间值（与 Epoch的毫秒偏移量）。
      boolean equals​(Object obj)
      将此 GregorianCalendar比较为 Object 。
      static GregorianCalendar from​(ZonedDateTime zdt)
      获取的实例 GregorianCalendar从一个默认的语言环境 ZonedDateTime对象。
      int getActualMaximum​(int field)
      返回此日历字段可能有，考虑到给定的时间值和的当前值中的最大值 getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和 getTimeZone方法。
      int getActualMinimum​(int field)
      返回此日历字段可能有，考虑到给定的时间值和的当前值的最小值 getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和 getTimeZone方法。
      String getCalendarType​()
      作为日历类型返回 "gregory" 。
      int getGreatestMinimum​(int field)
      返回此 GregorianCalendar实例的给定日历字段的最高最小值。
      Date getGregorianChange​()
      获取公历日历更改日期。
      int getLeastMaximum​(int field)
      返回此 GregorianCalendar实例的给定日历字段的最低最大值。
      int getMaximum​(int field)
      返回此 GregorianCalendar实例的给定日历字段的 GregorianCalendar 。
      int getMinimum​(int field)
      返回此 GregorianCalendar实例的给定日历字段的 GregorianCalendar 。
      TimeZone getTimeZone​()
      获取时区。
      int getWeeksInWeekYear​()
      返回周在数量 week year由这代表 GregorianCalendar 。
      int getWeekYear​()
      返回 GregorianCalendar代表的 GregorianCalendar 。
      int hashCode​()
      生成此 GregorianCalendar对象的哈希码。
      boolean isLeapYear​(int year)
      确定给定年份是否是闰年。
      boolean isWeekDateSupported​()
      返回 true表示此 GregorianCalendar支持周日期。
      void roll​(int field, boolean up)
      在给定时间字段上添加或减少单个时间单位，而不改变较大的字段。
      void roll​(int field, int amount)
      向指定的日历字段添加签名金额，而不更改较大的字段。
      void setGregorianChange​(Date date)
      设置 GregorianCalendar更改日期。
      void setTimeZone​(TimeZone zone)
      以给定的时区值设置时区。
      void setWeekDate​(int weekYear, int weekOfYear, int dayOfWeek)
      设置此 GregorianCalendar由日期符给出的日期- weekYear ， weekOfYear ，并 dayOfWeek 。
      ZonedDateTime toZonedDateTime​()
      将此对象转换为 ZonedDateTime ，表示时间线上与该 GregorianCalendar相同的点。

      • Methods inherited from class java.util.Calendar

        after, before, clear, clear, compareTo, complete, get, getAvailableCalendarTypes, getAvailableLocales, getDisplayName, getDisplayNames, getFirstDayOfWeek, getInstance, getInstance, getInstance, getInstance, getMinimalDaysInFirstWeek, getTime, getTimeInMillis, internalGet, isLenient, isSet, set, set, set, set, setFirstDayOfWeek, setLenient, setMinimalDaysInFirstWeek, setTime, setTimeInMillis, toInstant, toString

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • BC

        public static final int BC
        ERA字段的价值表示共同时代之前（在基督之前）的时期，也称为公元前9世纪。 从BC转为AD是...，2 BC，1 BC，1 AD，2 AD，...
        另请参见：
        Calendar.ERA ， Constant Field Values

      • AD

        public static final int AD
        ERA字段的值代表共同时代（Anno Domini），也称为CE。 从BC转为AD是...，公元前2年，公元前1年，公元1年，公元2年
        另请参见：
        Calendar.ERA ， Constant Field Values

    • 构造方法详细信息

      • GregorianCalendar

        public GregorianCalendar​()
        构造一个默认 GregorianCalendar使用默认时区的当前时间的默认 FORMAT语言环境。

      • GregorianCalendar

        public GregorianCalendar​(TimeZone zone)
        根据指定时区的当前时间，使用默认的 FORMAT区域设置构建一个 GregorianCalendar 。
        参数
        zone - 给定的时区。

      • GregorianCalendar

        public GregorianCalendar​(Locale aLocale)
        根据给定区域设置的默认时区中的当前时间构建一个 GregorianCalendar 。
        参数
        aLocale - 给定的区域设置。

      • GregorianCalendar

        public GregorianCalendar​(TimeZone zone,
                         Locale aLocale)
        根据给定时区的当前时间，使用给定的区域设置构建一个 GregorianCalendar 。
        参数
        zone - 给定的时区。
        aLocale - 给定的地区。

      • GregorianCalendar

        public GregorianCalendar​(int year,
                         int month,
                         int dayOfMonth)
        构造一个 GregorianCalendar ，并将默认时区中的给定日期设置为默认语言环境。
        参数
        year - 用于在日历中设置 YEAR日历字段的值。
        month - 用于设置日历中MONTH日历字段的值。 月值为0。 例如，1月份为0。
        dayOfMonth - 用于设置日历中的 DAY_OF_MONTH日历字段的值。

      • GregorianCalendar

        public GregorianCalendar​(int year,
                         int month,
                         int dayOfMonth,
                         int hourOfDay,
                         int minute)
        构造一个 GregorianCalendar ，其默认时区的默认语言环境设置了给定的日期和时间。
        参数
        year - 用于设置日历中的 YEAR日历字段的值。
        month - 用于设置日历中MONTH日历字段的值。 月值为0。 例如，1月份为0。
        dayOfMonth - 用于设置日历中 DAY_OF_MONTH日历字段的值。
        hourOfDay - 用于设置日历中 HOUR_OF_DAY日历字段的值。
        minute - 用于设置日历中 MINUTE日历字段的值。

      • GregorianCalendar

        public GregorianCalendar​(int year,
                         int month,
                         int dayOfMonth,
                         int hourOfDay,
                         int minute,
                         int second)
        构造一个GregorianCalendar，其中给定的日期和时间为默认时区设置为默认语言环境。
        参数
        year - 用于设置日历中 YEAR日历字段的值。
        month - 用于设置日历中MONTH日历字段的值。 月值为0。 例如，1月份为0。
        dayOfMonth - 用于设置日历中 DAY_OF_MONTH日历字段的值。
        hourOfDay - 用于设置日历中 HOUR_OF_DAY日历字段的值。
        minute - 用于设置日历中 MINUTE日历字段的值。
        second - 用于设置日历中 SECOND日历字段的值。

    • 方法详细信息

      • setGregorianChange

        public void setGregorianChange​(Date date)
        设置GregorianCalendar更改日期。 这是从朱利安到达格里高利日期的时间点。 默认是1582年10月15日（公历）。 在此之前，日期将在朱利安历。

        要获得纯粹的朱利安历法，请将更改日期设置为Date(Long.MAX_VALUE) 。 要获取纯公历，请将更改日期设置为Date(Long.MIN_VALUE) 。

        参数
        date - 给定的格里高利切割日期。

      • getGregorianChange

        public final Date getGregorianChange​()
        获取公历日历更改日期。 这是从朱利安到达格里高利日期的时间点。 默认是1582年10月15日（公历）。 在此之前，日期将在朱利安历。
        结果
        这个 GregorianCalendar对象的格里高利切割日期。

      • isLeapYear

        public boolean isLeapYear​(int year)
        确定给定年份是否是闰年。 如果给定年份是闰年，则返回true 。 要指定BC年数，必须给出1 - year number 。 例如，年份BC 4被指定为-3。
        参数
        year - 给定年份。
        结果
        true如果给定的一年是闰年; false否则。

      • getCalendarType

        public String getCalendarType​()
        作为日历类型返回 "gregory" 。
        重写：
        getCalendarType在 Calendar
        结果
        "gregory"
        从以下版本开始：
        1.8
        另请参见：
        Locale extensions ， Locale.Builder.setLocale(Locale) ， Locale.Builder.setUnicodeLocaleKeyword(String, String)

      • equals

        public boolean equals​(Object obj)
        将此GregorianCalendar与指定的Object 。 其结果是true当且仅当参数是GregorianCalendar对象，表示同一时间值（毫秒从偏移Epoch下相同） Calendar参数和阳历更改日期与此对象。
        重写：
        equals在 Calendar
        参数
        obj - 要比较的对象。
        结果
        true如果此对象等于obj ; 否则为false 。
        另请参见：
        Calendar.compareTo(Calendar)

      • hashCode

        public int hashCode​()
        生成此 GregorianCalendar对象的哈希码。
        重写：
        hashCode在 Calendar
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • add

        public void add​(int field,
                int amount)
        根据日历的规则，将指定的（已签名的）时间添加到给定的日历字段。

        添加规则1 。 呼叫后field的值减去呼叫前的field的值为amount ，模数发生在field任何溢出。 当字段值超出其范围时发生溢出，结果是下一个较大的字段递增或递减，并将字段值调整回其范围。

        添加规则2 。 如果一个较小的领域预计是不变的，但是由于field之后的最小或最大值的变化，它不可能等于其先前的值，所以其值被调整为尽可能接近其预期值。 较小的字段表示较小的时间单位。 HOUR是一个比DAY_OF_MONTH更小的字段。 没有对未预期不变的较小的领域进行调整。 日历系统确定预期哪些字段是不变的。

        Specified by:
        add在 Calendar
        参数
        field - 日历字段。
        amount - 要添加到字段的日期或时间的数量。
        异常
        IllegalArgumentException -如果 field是 ZONE_OFFSET ， DST_OFFSET ，或未知的，或者如果任何日历字段具有在非宽松模式外的范围内的值。
        另请参见：
        Calendar.roll(int,int) ， Calendar.set(int,int)

      • roll

        public void roll​(int field,
                 boolean up)
        在给定时间字段上添加或减少单个时间单位，而不改变较大的字段。

        例如 ：考虑一个GregorianCalendar最初被设置为1999调用12月31日， roll(Calendar.MONTH, true)套日历至1999年1月31日，该YEAR场是不变的，因为它比一个更大的领域MONTH 。

        Specified by:
        roll在 Calendar
        参数
        up - 指示指定日历字段的值是要卷起还是滚动。 使用true如果卷起， false否则。
        field - 时间字段。
        异常
        IllegalArgumentException -如果 field是 ZONE_OFFSET ， DST_OFFSET ，或未知的，或者如果任何日历字段具有在非宽松模式外的范围内的值。
        另请参见：
        add(int,int) ， Calendar.set(int,int)

      • roll

        public void roll​(int field,
                 int amount)
        向指定的日历字段添加签名金额，而不更改较大的字段。 负滚动量意味着从字段中减去而不改变较大的字段。 如果指定的数量为0，则此方法不执行任何操作。

        此方法调用Calendar.complete()之前添加金额，以便所有的日历字段被归一化。 如果任何日历字段在非宽松模式下具有超出范围值，则抛出一个IllegalArgumentException 。

        例如 ：考虑一个GregorianCalendar最初被设置为1999调用8月31日， roll(Calendar.MONTH, 8)套日历1999年 4月30日。 使用GregorianCalendar ，该DAY_OF_MONTH场不能在一个月四月是31。 DAY_OF_MONTH被设置为最接近的可能值30.由于YEAR字段比MONTH更大，所以YEAR字段保持1999的值。

        示例 ：考虑一个原始设置为1999年6月6日星期日的GregorianCalendar呼叫roll(Calendar.WEEK_OF_MONTH, -1)将日历设置为1999年6月1日星期二，而呼叫add(Calendar.WEEK_OF_MONTH, -1)将日历设置为1999年5月30日星期日。这是因为滚动规则强加了一个附加约束：该MONTH当不能改变WEEK_OF_MONTH卷。 加上规则1，结果日期必须在6月1日星期六至6月5日星期六之间。根据附加规则DAY_OF_WEEK （更改WEEK_OF_MONTH时不变量）设置为星期二，最接近可能的星期日值（其中周日是本周的第一天）。

        重写：
        roll在 Calendar
        参数
        field - 日历字段。
        amount - 签收金额加至 field 。
        异常
        IllegalArgumentException -如果 field是 ZONE_OFFSET ， DST_OFFSET ，或未知的，或者如果任何日历字段具有在非宽松模式外的范围内的值。
        从以下版本开始：
        1.2
        另请参见：
        roll(int,boolean) ，
add(int,int) ，
Calendar.set(int,int)

      • getMinimum

        public int getMinimum​(int field)
        返回此GregorianCalendar实例的给定日历字段的GregorianCalendar 。 最小值被定义为通过返回最小值get方法为任何可能的时间值，同时考虑到的电流值getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和getTimeZone方法。
        Specified by:
        getMinimum在 Calendar
        参数
        field - 日历字段。
        结果
        给定日历字段的最小值。
        另请参见：
        getMaximum(int) ， getGreatestMinimum(int) ， getLeastMaximum(int) ， getActualMinimum(int) ， getActualMaximum(int)

      • getMaximum

        public int getMaximum​(int field)
        返回此GregorianCalendar实例的给定日历字段的GregorianCalendar 。 最大值被定义为通过返回的最大值get方法为任何可能的时间值，同时考虑到的电流值getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和getTimeZone方法。
        Specified by:
        getMaximum在 Calendar
        参数
        field - 日历字段。
        结果
        给定日历字段的最大值。
        另请参见：
        getMinimum(int) ， getGreatestMinimum(int) ， getLeastMaximum(int) ， getActualMinimum(int) ， getActualMaximum(int)

      • getGreatestMinimum

        public int getGreatestMinimum​(int field)
        返回此GregorianCalendar实例的给定日历字段的最高最小值。 最高的最小值被定义为返回的最大价值getActualMinimum(int)任何可能的时间值，同时考虑到的当前值getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和getTimeZone方法。
        Specified by:
        getGreatestMinimum在 Calendar
        参数
        field - 日历字段。
        结果
        给定日历字段的最低最小值。
        另请参见：
        getMinimum(int) ， getMaximum(int) ， getLeastMaximum(int) ， getActualMinimum(int) ， getActualMaximum(int)

      • getLeastMaximum

        public int getLeastMaximum​(int field)
        返回此GregorianCalendar实例的给定日历字段的最低最大值。 的最低的最大值被定义为通过返回最小值getActualMaximum(int)任何可能的时间值，同时考虑到的电流值getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和getTimeZone方法。
        Specified by:
        getLeastMaximum在 Calendar
        参数
        field - 日历字段
        结果
        给定日历字段的最低最大值。
        另请参见：
        getMinimum(int) ， getMaximum(int) ， getGreatestMinimum(int) ， getActualMinimum(int) ， getActualMaximum(int)

      • getActualMinimum

        public int getActualMinimum​(int field)
        返回此日历字段可能有，考虑到给定的时间值和的当前值的最小值getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和getTimeZone方法。

        例如，如果公历的更改日期是1970年1月10日，而这个GregorianCalendar的日期是1970年1月20日，则DAY_OF_MONTH字段的实际最小值为10，因为1970年1月10日的前一个日期是1996年12月27日（在朱利安历）。 因此，1969年12月28日至1970年1月9日不存在。

        重写：
        getActualMinimum在 Calendar
        参数
        field - 日历字段
        结果
        给定字段的最小值为这个 GregorianCalendar的时间值
        从以下版本开始：
        1.2
        另请参见：
        getMinimum(int) ， getMaximum(int) ， getGreatestMinimum(int) ， getLeastMaximum(int) ， getActualMaximum(int)

      • getActualMaximum

        public int getActualMaximum​(int field)
        返回此日历字段可能有，考虑到给定的时间值和的当前值中的最大值getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和getTimeZone方法。 例如，如果该实例的日期是2004年2月1日，则DAY_OF_MONTH字段的实际最大值为29，因为2004年是闰年，如果此实例的日期是2005年2月1日，则为28。

        该方法基于YEAR （日历年）值计算最大值WEEK_OF_YEAR ，而不是week year 。 呼叫getWeeksInWeekYear()得到的最大值WEEK_OF_YEAR在此的一周年GregorianCalendar 。

        重写：
        getActualMaximum在 Calendar
        参数
        field - 日历字段
        结果
        给定字段的最大值为这个 GregorianCalendar的时间值
        从以下版本开始：
        1.2
        另请参见：
        getMinimum(int) ， getMaximum(int) ， getGreatestMinimum(int) ， getLeastMaximum(int) ， getActualMinimum(int)

      • clone

        public Object clone​()
        描述从类复制： Calendar
        创建并返回此对象的副本。
        重写：
        clone在 Calendar
        结果
        这个对象的副本。
        另请参见：
        Cloneable

      • getTimeZone

        public TimeZone getTimeZone​()
        描述从类复制： Calendar
        获取时区。
        重写：
        getTimeZone在 Calendar
        结果
        与该日历相关联的时区对象。

      • setTimeZone

        public void setTimeZone​(TimeZone zone)
        描述从类复制： Calendar
        以给定的时区值设置时区。
        重写：
        setTimeZone在 Calendar
        参数
        zone - 给定的时区。

      • isWeekDateSupported

        public final boolean isWeekDateSupported​()
        返回 true表示此 GregorianCalendar支持周日期。
        重写：
        isWeekDateSupported在 Calendar
        结果
        true （总是）
        从以下版本开始：
        1.7
        另请参见：
        getWeekYear() ，
setWeekDate(int,int,int) ，
getWeeksInWeekYear()

      • getWeekYear

        public int getWeekYear​()
        返回由GregorianCalendar表示的GregorianCalendar 。 星期之间的星期之间的星期数与周年的最大周数有相同的周年值，可能是在YEAR （日历年）值之前或之后的一年。

        在计算周年之前，此方法调用Calendar.complete() 。

        重写：
        getWeekYear在 Calendar
        结果
        这个星期由这个GregorianCalendar代表。 如果ERA值为BC ，则年份为0或负数：BC 1为0，BC 2为-1，BC 3为-2，依此类推。
        异常
        IllegalArgumentException - 如果任何日历字段在非宽松模式下无效。
        从以下版本开始：
        1.7
        另请参见：
        isWeekDateSupported() ，
getWeeksInWeekYear() ，
Calendar.getFirstDayOfWeek() ，
Calendar.getMinimalDaysInFirstWeek()

      • setWeekDate

        public void setWeekDate​(int weekYear,
                        int weekOfYear,
                        int dayOfWeek)
        设置此GregorianCalendar由日期符给出的日期- weekYear ， weekOfYear ，并dayOfWeek 。 weekOfYear遵循WEEK_OF_YEAR numbering 。 dayOfWeek值必须是DAY_OF_WEEK的值之一： SUNDAY到SATURDAY 。

        请注意，数字星期表示与ISO 8601标准不同， weekOfYear编号与getFirstDayOfWeek()为MONDAY和getMinimalDaysInFirstWeek()为4时的标准兼容。

        与set方法不同，所有的日历字段和时间值都是在返回时计算的。

        如果weekOfYear在weekYear的有效周期范围之内，则weekYear和weekOfYear值将在宽松模式下进行调整，或者在非宽松模式下抛出IllegalArgumentException 。

        重写：
        setWeekDate在 Calendar
        参数
        weekYear - 星期
        weekOfYear - 周数基于 weekYear
        dayOfWeek - 星期几值： DAY_OF_WEEK字段的常数之一： SUNDAY ，...， SATURDAY 。
        异常
        IllegalArgumentException - 如果任何给定的日期说明符无效，或者如果任何日历字段与非宽松模式中的给定日期说明符不一致
        从以下版本开始：
        1.7
        另请参见：
        isWeekDateSupported() ，
Calendar.getFirstDayOfWeek() ，
Calendar.getMinimalDaysInFirstWeek()

      • getWeeksInWeekYear

        public int getWeeksInWeekYear​()
        返回周在数量week year由这代表GregorianCalendar 。

        例如，如果这个GregorianCalendar的日期是2008年12月31日，有the ISO 8601 compatible setting ，则该方法将在2008年12月29日至2010年1月3日期间返回53，而getActualMaximum(WEEK_OF_YEAR)将在2007年12月31日至12月期间返回52 28，2008。

        重写：
        getWeeksInWeekYear在 Calendar
        结果
        在一周的星期数。
        从以下版本开始：
        1.7
        另请参见：
        Calendar.WEEK_OF_YEAR ， getWeekYear() ， getActualMaximum(int)

      • computeFields

        protected void computeFields​()
        将时间值（从Epoch的毫秒偏移）转换为日历字段值。 时间不重新计算; 重新计算时间，然后字段，调用complete方法。
        Specified by:
        computeFields在 Calendar
        另请参见：
        Calendar.complete()

      • computeTime

        protected void computeTime​()
        将日历字段值转换为时间值（与 Epoch的毫秒偏移量）。
        Specified by:
        computeTime在 Calendar
        异常
        IllegalArgumentException - 如果任何日历字段无效。
        另请参见：
        Calendar.complete() ， Calendar.computeFields()

      • toZonedDateTime

        public ZonedDateTime toZonedDateTime​()
        将该对象转换为ZonedDateTime ，表示时间线上与该GregorianCalendar相同的点。

        由于此对象支持Julian-Gregorian切换日期，并且ZonedDateTime不支持，因此，生成的年，月和日可能具有不同的值。 结果将表示ISO日历系统中的正确日期，对于修改的朱利安天数也将是相同的值。

        结果
        一个分区的日期时间代表这个格式日历在时间线上的同一点
        从以下版本开始：
        1.8

      • from

        public static GregorianCalendar from​(ZonedDateTime zdt)
        获取的实例GregorianCalendar从一个默认的语言环境ZonedDateTime对象。

        由于ZonedDateTime不支持朱利安- Gregorian转换日期和使用ISO日历系统，返回的GregorianCalendar是一个纯粹的阳历和使用ISO 8601标准定义的一周，其中有MONDAY为FirstDayOfWeek和4作为价值MinimalDaysInFirstWeek 。

        ZoneDateTime可以在未来进一步存储时间点，进一步在GregorianCalendar 。 在这种情况下，此方法将抛出一个IllegalArgumentException异常。

        参数
        zdt - 要转换的划分的日期时间对象
        结果
        该格式的日历表示与分区日期时间相同的时间线上的相同点
        异常
        NullPointerException - 如果 zdt为空
        IllegalArgumentException - 如果分区的日期时间太大，无法表示为 GregorianCalendar
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


HashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class HashMap<K,V>

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.HashMap<K,V>
  • 参数类型
    K - 由该地图维护的键的类型
    V - 映射值的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Map<K,V>
    已知直接子类：
    ClipboardContent ， LinkedHashMap ， PrinterStateReasons

    public class HashMap<K,V>
extends AbstractMap<K,V>
implements Map<K,V>, Cloneable, Serializable
    基于哈希表的实现的Map接口。 该实现提供了所有可选的映射操作，并允许null值和null密钥。 （ HashMap类大致相当于Hashtable ，除了它是不同步的，并允许null）。这个类不能保证地图的顺序; 特别是，它不能保证订单在一段时间内保持不变。

    假定散列函数在桶中正确分散元素，则此实现为基本操作（ get和put ）提供了恒定时间的性能。 收集视图的迭代需要与HashMap实例（桶数）加上其大小（键值映射数）的“容量”成正比。 因此，如果迭代性能很重要，不要将初始容量设置得太高（或负载因子太低）是非常重要的。

    HashMap一个实例有两个影响其性能的参数： 初始容量和负载因子 。 容量是哈希表中的桶数，初始容量只是创建哈希表时的容量。 负载因子是在容量自动增加之前允许哈希表得到满足的度量。 当哈希表中的条目数超过负载因子和当前容量的乘积时， 重新排列哈希表（即，内部数据结构被重新构建），以使散列表具有大约两倍的桶数。

    作为一般规则，默认负载因子（.75）提供了时间和空间成本之间的良好折中。 更高的值会降低空间开销，但会增加查找成本（反映在HashMap类的大部分操作中，包括get和put ）。 在设置其初始容量时，应考虑地图中预期的条目数及其负载因子，以便最小化重新组播操作的数量。 如果初始容量大于最大条目数除以负载因子，则不会发生重新排列操作。

    如果许多映射要存储在HashMap实例中，则以足够大的容量创建映射将允许映射的存储效率高于使其根据需要执行自动重新排序以增长表。 请注意，使用相同的hashCode()许多密钥是降低任何哈希表的性能的一种方法。 为了改善影响，当按键为Comparable时 ，该类可以使用键之间的比较顺序来帮助打破关系。

    请注意，此实现不同步。 如果多个线程同时访问哈希映射，并且至少有一个线程在结构上修改了映射，那么它必须在外部进行同步。 （结构修改是添加或删除一个或多个映射的任何操作;仅改变与实例已经包含的密钥相关联的值不是结构修改。）这通常通过对自然地封装映射的一些对象进行同步来实现。 如果没有这样的对象存在，地图应该使用Collections.synchronizedMap方法“包装”。 这最好在创建时完成，以防止意外的不同步访问地图：

      Map m = Collections.synchronizedMap(new HashMap(...));

    所有这个类的“集合视图方法”返回的迭代器都是故障快速的 ：如果映射在迭代器创建之后的任何时间被结构化地修改，除了通过迭代器自己的remove方法之外，迭代器将抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速迭代器ConcurrentModificationException扔出ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Object.hashCode() ， Collection ， Map ， TreeMap ， Hashtable ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      HashMap​()
      构造一个空的 HashMap ，默认初始容量（16）和默认负载因子（0.75）。
      HashMap​(int initialCapacity)
      构造一个空的 HashMap具有指定的初始容量和默认负载因子（0.75）。
      HashMap​(int initialCapacity, float loadFactor)
      构造一个空的 HashMap具有指定的初始容量和负载因子。
      HashMap​(Map<? extends K,? extends V> m)
      构造一个新的 HashMap具有与指定的相同的映射 Map 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      从这张地图中删除所有的映射。
      Object clone​()
      返回此 HashMap实例的浅拷贝：键和值本身不被克隆。
      V compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      V computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非 null 。
      V computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      boolean containsKey​(Object key)
      如果此映射包含指定键的映射，则返回 true 。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。
      V getOrDefault​(Object key, V defaultValue)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。
      boolean isEmpty​()
      如果此映射不包含键值映射，则返回 true 。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      V merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
      V put​(K key, V value)
      将指定的值与此映射中的指定键相关联。
      void putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此地图。
      V putIfAbsent​(K key, V value)
      如果指定的键尚未与值相关联（或映射到 null ）将其与给定值相关联并返回 null ，否则返回当前值。
      V remove​(Object key)
      从该地图中删除指定键的映射（如果存在）。
      boolean remove​(Object key, Object value)
      仅当指定的密钥当前映射到指定的值时删除该条目。
      V replace​(K key, V value)
      只有当目标映射到某个值时，才能替换指定键的条目。
      boolean replace​(K key, V oldValue, V newValue)
      仅当当前映射到指定的值时，才能替换指定键的条目。
      void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      int size​()
      返回此地图中键值映射的数量。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from class java.util.AbstractMap

        equals, hashCode, toString

      • Methods inherited from interface java.util.Map

        entry, equals, hashCode, of, of, of, of, of, of, of, of, of, of, of, ofEntries

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • HashMap

        public HashMap​(int initialCapacity,
               float loadFactor)
        构造一个空的 HashMap具有指定的初始容量和负载因子。
        参数
        initialCapacity - 初始容量
        loadFactor - 负载因子
        异常
        IllegalArgumentException - 如果初始容量为负值或负载系数为正数

      • HashMap

        public HashMap​(int initialCapacity)
        构造一个空的 HashMap具有指定的初始容量和默认负载因子（0.75）。
        参数
        initialCapacity - 初始容量。
        异常
        IllegalArgumentException - 如果初始容量为负。

      • HashMap

        public HashMap​()
        构造一个空的 HashMap ，默认初始容量（16）和默认负载因子（0.75）。

      • HashMap

        public HashMap​(Map<? extends K,? extends V> m)
        构造一个新的HashMap具有与指定的Map相同的映射。 HashMap以默认负载因子（0.75）创建，初始容量足以容纳指定的Map的映射。
        参数
        m - 其映射将放置在此映射中的映射
        异常
        NullPointerException - 如果指定的地图为空

    • 方法详细信息

      • size

        public int size​()
        返回此地图中键值映射的数量。
        Specified by:
        size在接口 Map<K,V>
        重写：
        size在 AbstractMap<K,V>
        结果
        该地图中键值映射的数量

      • isEmpty

        public boolean isEmpty​()
        如果此映射不包含键值映射，则返回 true 。
        Specified by:
        isEmpty在接口 Map<K,V>
        重写：
        isEmpty在 AbstractMap<K,V>
        结果
        true如果此映射不包含键值映射

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回null 。

        更正式地，如果此映射包含从密钥映射k到值v使得(key==null ? k==null : key.equals(k)) ，则此方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        返回值为null并不一定表示该映射不包含该键的映射; 地图也可能明确地将密钥映射到null 。 可以使用containsKey操作来区分这两种情况。

        Specified by:
        get在接口 Map<K,V>
        重写：
        get AbstractMap<K,V>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含键的映射， null
        另请参见：
        put(Object, Object)

      • containsKey

        public boolean containsKey​(Object key)
        如果此映射包含指定键的映射，则返回 true 。
        Specified by:
        containsKey在接口 Map<K,V>
        重写：
        containsKey在 AbstractMap<K,V>
        参数
        key - 要在此地图中存在的密钥要进行测试
        结果
        true如果此映射包含指定键的映射。

      • put

        public V put​(K key,
             V value)
        将指定的值与此映射中的指定键相关联。 如果地图先前包含了该键的映射，则替换旧值。
        Specified by:
        put在接口 Map<K,V>
        重写：
        put中的 AbstractMap<K,V>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        先前的值相关联key ，或null如果没有映射key 。 （A null返回也可以指示以前关联的地图null与key ）

      • putAll

        public void putAll​(Map<? extends K,? extends V> m)
        将指定地图的所有映射复制到此地图。 这些映射将替换此映射对当前在指定映射中的任何键的任何映射。
        Specified by:
        putAll在接口 Map<K,V>
        重写：
        putAll在 AbstractMap<K,V>
        参数
        m - 要存储在此地图中的映射
        异常
        NullPointerException - 如果指定的地图为空

      • remove

        public V remove​(Object key)
        从该地图中删除指定键的映射（如果存在）。
        Specified by:
        remove在接口 Map<K,V>
        重写：
        remove在 AbstractMap<K,V>
        参数
        key - 要从地图中删除其映射的密钥
        结果
        先前的值相关联key ，或null如果没有映射key 。 （A null返回也可以表示以前关联的地图null与key ）

      • clear

        public void clear​()
        从这张地图中删除所有的映射。 此呼叫返回后，地图将为空。
        Specified by:
        clear在接口 Map<K,V>
        重写：
        clear在 AbstractMap<K,V>

      • containsValue

        public boolean containsValue​(Object value)
        如果此映射将一个或多个键映射到指定的值，则返回 true 。
        Specified by:
        containsValue在接口 Map<K,V>
        重写：
        containsValue在 AbstractMap<K,V>
        参数
        value - 要在此地图中存在的值要进行测试
        结果
        true如果该地图将一个或多个键映射到指定的值

      • keySet

        public Set<K> keySet​()
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        keySet接口 Map<K,V>
        重写：
        keySet在 AbstractMap<K,V>
        结果
        该地图中包含的键的集合视图

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        values在接口 Map<K,V>
        重写：
        values在 AbstractMap<K,V>
        结果
        该地图中包含的值的视图

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时修改映射（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        entrySet在接口 Map<K,V>
        Specified by:
        entrySet在 AbstractMap<K,V>
        结果
        该地图中包含的映射的集合视图

      • getOrDefault

        public V getOrDefault​(Object key,
                      V defaultValue)
        描述从接口Map复制
        返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。
        Specified by:
        getOrDefault在接口 Map<K,V>
        参数
        key - 要返回其关联值的键
        defaultValue - 键的默认映射
        结果
        指定键映射到的值，如果此映射不包含该键的映射， defaultValue

      • putIfAbsent

        public V putIfAbsent​(K key,
                     V value)
        说明从接口Map复制
        如果指定的键尚未与某个值相关联（或映射到 null ）， null其与给定值相关联并返回 null ，否则返回当前值。
        Specified by:
        putIfAbsent在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示映射以前关联的是null ，如果实现支持空值）。

      • remove

        public boolean remove​(Object key,
                      Object value)
        说明从接口Map复制
        仅当指定的密钥当前映射到指定的值时删除该条目。
        Specified by:
        remove接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        value - 预期与指定键相关联的值
        结果
        true如果该值被删除

      • replace

        public boolean replace​(K key,
                       V oldValue,
                       V newValue)
        描述从接口Map复制
        仅当当前映射到指定的值时，才能替换指定键的条目。
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        oldValue - 预期与指定键相关联的值
        newValue - 与指定键相关联的值
        结果
        true如果值被替换

      • replace

        public V replace​(K key,
                 V value)
        说明从接口Map复制
        只有当目标映射到某个值时，才能替换指定键的条目。
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示以前关联的映射关系为null ，如果实现支持空值）。

      • computeIfAbsent

        public V computeIfAbsent​(K key,
                         Function<? super K,? extends V> mappingFunction)
        如果指定的键尚未与值相关联（或映射到null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非null 。

        如果映射函数返回null ，则不记录映射。 如果映射函数本身引发（未检查）异常，则重新抛出异常，并且不记录映射。 最常见的用法是构造一个用作初始映射值或记忆结果的新对象，如：

           map.computeIfAbsent(key, k -> new Value(f(k)));

        或者实现一个多值地图， Map<K,Collection<V>> ，每个键支持多个值：

           map.computeIfAbsent(key, k -> new HashSet<V>()).add(v);

        映射函数在计算过程中不应该修改该映射。

        如果在计算过程中检测到映射函数修改了该映射，则该方法将尽力而为地抛出ConcurrentModificationException 。

        Specified by:
        computeIfAbsent在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        mappingFunction - 计算值的映射函数
        结果
        与指定键相关联的当前（现有或计算）值，如果计算值为空，则为null
        异常
        ConcurrentModificationException - 如果检测到映射函数修改了此映射

      • computeIfPresent

        public V computeIfPresent​(K key,
                          BiFunction<? super K,? super V,? extends V> remappingFunction)
        如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

        如果重映射函数返回null ，则映射将被删除。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        如果检测到重新映射功能在计算过程中修改了该映射，则该方法将尽力而为地抛出ConcurrentModificationException 。

        Specified by:
        computeIfPresent在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        remappingFunction - 用于计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        ConcurrentModificationException - 如果检测到重映射功能修改了该地图

      • compute

        public V compute​(K key,
                 BiFunction<? super K,? super V,? extends V> remappingFunction)
        尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则null ）。 例如，要为值映射创建或附加String msg：
           map.compute(key, (k, v) -> (v == null) ? msg : v.concat(msg))
        （方法merge()通常更简单地用于这些目的。）

        如果重映射函数返回null ，则映射将被删除（如果最初不存在则保持不存在）。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        如果检测到重新映射功能在计算过程中修改了该映射，则该方法将尽力而为地抛出ConcurrentModificationException 。

        Specified by:
        compute在接口 Map<K,V>
        参数
        key - 要与指定值相关联的键
        remappingFunction - 计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        ConcurrentModificationException - 如果检测到重映射功能修改了该地图

      • merge

        public V merge​(K key,
               V value,
               BiFunction<? super V,? super V,? extends V> remappingFunction)
        如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。 否则，将关联值替换为给定重映射函数的结果，如果结果为null ，则将其null 。 当组合键的多个映射值时，该方法可能是有用的。 例如，要创建或附加String msg到值映射：
           map.merge(key, msg, String::concat)

        如果重映射函数返回null ，则映射将被删除。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        如果检测到重新映射功能在计算过程中修改了该映射，这种方法将尽力而为地抛出一个ConcurrentModificationException 。

        Specified by:
        merge在接口 Map<K,V>
        参数
        key - 与结果值相关联的键
        value - 要与与密钥相关联的现有值合并的非空值，或者如果没有现有值或与值相关联的空值与密钥相关联
        remappingFunction - 如果存在重新计算值的重映射功能
        结果
        与指定键相关联的新值，如果没有值与该键相关联，则返回null
        异常
        ConcurrentModificationException - 如果检测到重映射功能修改了该地图

      • forEach

        public void forEach​(BiConsumer<? super K,? super V> action)
        描述从接口Map复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach在接口 Map<K,V>
        参数
        action - 为每个条目执行的操作

      • replaceAll

        public void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        描述从接口Map复制
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll在接口 Map<K,V>
        参数
        function - 应用于每个条目的功能

      • clone

        public Object clone​()
        返回此 HashMap实例的浅拷贝：键和值本身不被克隆。
        重写：
        clone在 AbstractMap<K,V>
        结果
        这张地图的浅拷贝
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HashSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class HashSet<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractSet<E>
        • java.util.HashSet<E>
  • 参数类型
    E - 由此集合维护的元素的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， Set<E>
    已知直接子类：
    JobStateReasons ， LinkedHashSet

    public class HashSet<E>
extends AbstractSet<E>
implements Set<E>, Cloneable, Serializable
    该类实现Set接口，由哈希表（实际为HashMap实例）支持。 对集合的迭代顺序不作任何保证; 特别是，它不能保证订单在一段时间内保持不变。 这个类允许null元素。

    这个类提供了基本的操作（固定时间性能add ， remove ， contains和size ），假定哈希函数将分散的桶中正确的元素。 迭代该集合需要与HashSet实例的大小（元素数量）加上后备HashMap实例（桶数）的“容量”的总和成比例的时间。 因此，如果迭代性能很重要，不要将初始容量设置得太高（或负载因子太低）是非常重要的。

    请注意，此实现不同步。 如果多个线程并发访问哈希集，并且至少有一个线程修改该集合，那么它必须在外部进行同步。 这通常通过在自然地封装集合的一些对象上进行同步来实现。 如果没有这样的对象存在，则应该使用Collections.synchronizedSet方法“包装”。 这最好在创建时完成，以防止意外的非同步访问集：

      Set s = Collections.synchronizedSet(new HashSet(...));

    此类的iterator方法返回的迭代器是故障快速的 ：如果在迭代器创建后的任何时间对集进行了修改，除了通过迭代器自己的remove方法之外，迭代器会抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的迭代器ConcurrentModificationException抛出ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， Set ， TreeSet ， HashMap ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      HashSet​()
      构造一个新的空集合; 背景HashMap实例具有默认初始容量（16）和负载因子（0.75）。
      HashSet​(int initialCapacity)
      构造一个新的空集合; 支持HashMap实例具有指定的初始容量和默认负载因子（0.75）。
      HashSet​(int initialCapacity, float loadFactor)
      构造一个新的空集合; 支持HashMap实例具有指定的初始容量和指定的负载因子。
      HashSet​(Collection<? extends E> c)
      构造一个包含指定集合中的元素的新集合。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素添加到此集合（如果尚未存在）。
      void clear​()
      从此集合中删除所有元素。
      Object clone​()
      返回此 HashSet实例的浅拷贝：元素本身不被克隆。
      boolean contains​(Object o)
      如果此集合包含指定的元素，则返回 true 。
      boolean isEmpty​()
      如果此集合不包含元素，则返回 true 。
      Iterator<E> iterator​()
      返回此集合中元素的迭代器。
      boolean remove​(Object o)
      如果存在，则从该集合中删除指定的元素。
      int size​()
      返回此集合中的元素数（其基数）。
      Spliterator<E> spliterator​()
      在此集合中的元素上创建late-binding和故障快速 Spliterator 。

      • Methods inherited from class java.util.AbstractCollection

        addAll, containsAll, retainAll, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractSet

        equals, hashCode, removeAll

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Set

        addAll, containsAll, equals, hashCode, of, of, of, of, of, of, of, of, of, of, of, of, removeAll, retainAll, toArray, toArray

    • 构造方法详细信息

      • HashSet

        public HashSet​()
        构造一个新的空集合; 背景HashMap实例具有默认初始容量（16）和负载因子（0.75）。

      • HashSet

        public HashSet​(Collection<? extends E> c)
        构造一个包含指定集合中的元素的新集合。 HashMap以默认负载因子（0.75）创建，初始容量足以包含指定集合中的元素。
        参数
        c - c元素放置到此集合中的集合
        异常
        NullPointerException - 如果指定的集合为空

      • HashSet

        public HashSet​(int initialCapacity,
               float loadFactor)
        构造一个新的空集合; 支持HashMap实例具有指定的初始容量和指定的负载因子。
        参数
        initialCapacity - 哈希映射的初始容量
        loadFactor - 哈希映射的负载因子
        异常
        IllegalArgumentException - 如果初始容量小于零，或负载系数是否为正

      • HashSet

        public HashSet​(int initialCapacity)
        构造一个新的空集合; 支持HashMap实例具有指定的初始容量和默认负载因子（0.75）。
        参数
        initialCapacity - 哈希表的初始容量
        异常
        IllegalArgumentException - 如果初始容量小于零

    • 方法详细信息

      • iterator

        public Iterator<E> iterator​()
        返回此集合中元素的迭代器。 元素没有特定的顺序返回。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 Set<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        这个集合中的元素的迭代器
        另请参见：
        ConcurrentModificationException

      • size

        public int size​()
        返回此集合中的元素数（其基数）。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Set<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        该集合中的元素数（其基数）

      • isEmpty

        public boolean isEmpty​()
        如果此集合不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        Specified by:
        isEmpty在接口 Set<E>
        重写：
        isEmpty在 AbstractCollection<E>
        结果
        true如果此集合不包含元素

      • contains

        public boolean contains​(Object o)
        如果此集合包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此set包含的元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Set<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要在此集合中存在的元素要进行测试
        结果
        true如果此集合包含指定的元素

      • add

        public boolean add​(E e)
        将指定的元素添加到此集合（如果尚未存在）。 更正式地，如果该集合不包含元素e2 ，使得指定的元素e为Objects.equals(e, e2) 。 如果该集合已经包含该元素，则该呼叫将保持不变，并返回false 。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Set<E>
        重写：
        add在 AbstractCollection<E>
        参数
        e - 要添加到此集合的元素
        结果
        true如果此集合尚未包含指定的元素

      • remove

        public boolean remove​(Object o)
        如果存在，则从该集合中删除指定的元素。 更正式地，删除元素e ，使得Objects.equals(o, e) ，如果这个集合包含这样的元素。 如果此集合包含元素（或等效地，如果该集合由于调用而更改），则返回true 。 （一旦调用返回，此集合将不包含该元素。）
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 Set<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此集合中删除的对象（如果存在）
        结果
        true如果集合包含指定的元素

      • clear

        public void clear​()
        从此集合中删除所有元素。 此呼叫返回后，该组将为空。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 Set<E>
        重写：
        clear在 AbstractCollection<E>

      • clone

        public Object clone​()
        返回此 HashSet实例的浅拷贝：元素本身不被克隆。
        重写：
        clone在 Object
        结果
        这个集合的浅拷贝
        另请参见：
        Cloneable

      • spliterator

        public Spliterator<E> spliterator​()
        在此集合中的元素上创建late-binding和故障快速 Spliterator 。

        Spliterator报告Spliterator.SIZED和Spliterator.DISTINCT 。 覆盖实现应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Specified by:
        spliterator在接口 Set<E>
        结果
        一个 Spliterator在这个集合中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Hashtable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Hashtable<K,V>

  • java.lang.Object
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V>
  • 参数类型
    K - 由该地图维护的键的类型
    V - 映射值的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Map<K,V>
    已知直接子类：
    Properties ， UIDefaults

    public class Hashtable<K,V>
extends Dictionary<K,V>
implements Map<K,V>, Cloneable, Serializable
    该类实现了一个哈希表，它将键映射到值。 任何非null对象都可以用作键值或值。

    要从哈希表成功存储和检索对象，用作键的对象必须实现hashCode方法和equals方法。

    Hashtable一个实例有两个参数影响其性能： 初始容量和负载因子 。 容量是哈希表中的桶数， 初始容量只是创建哈希表时的容量。 请注意，哈希表是打开的 ：在“哈希冲突”的情况下，单个存储桶存储多个条目，必须依次搜索。 负载因子是在容量自动增加之前允许哈希表得到满足的度量。 初始容量和负载因子参数仅仅是实现的暗示。 关于何时以及是否调用rehash方法的具体细节是依赖于实现的。

    通常，默认负载因子（.75）提供了时间和空间成本之间的良好折衷。 更高的值会降低空间开销，但会增加查询条目的时间成本（这反映在大多数Hashtable操作中，包括get和put ）。

    初始容量控制了浪费空间与rehash操作的需求之间的折中，这是耗时的。 没有rehash如果初始容量大于条目的最大数量永远不会发生的操作Hashtable将其客座率含有分开。 然而，设置初始容量太高可能会浪费空间。

    如果将许多条目设置为Hashtable ，则以足够大的容量创建它可能会使条目更有效地插入，以使其根据需要执行自动重新排序以扩展表。

    此示例创建数字的散列表。 它使用数字的名称作为键：

       Hashtable<String, Integer> numbers = new Hashtable<String, Integer>(); numbers.put("one", 1); numbers.put("two", 2); numbers.put("three", 3);

    要检索一个数字，请使用以下代码：

       Integer n = numbers.get("two"); if (n != null) { System.out.println("two = " + n); }

    由所有这个类的“集合视图方法”返回的集合返回的迭代器是iterator ，它们是fail-fast ：如果Hashtable在迭代器创建之后的任何时间被结构地修改，除了通过迭代器自己的remove方法，迭代器会抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。 Hashtable的keys和elements方法返回的枚举不是故障快速的; 如果在创建枚举后的任何时候Hashtable被结构上修改，那么枚举的结果是未定义的。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速迭代器ConcurrentModificationException抛出ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    从Java 2平台v1.2开始，该类进行了改进，实现了Map接口，使其成为Java Collections Framework的成员。 与新的集合实现不同， Hashtable被同步。 如果不需要线程安全的实现，建议使用HashMap代替Hashtable 。 如果需要线程安全高度并发的实现，那么建议使用ConcurrentHashMap代替Hashtable 。

    从以下版本开始：
    1.0
    另请参见：
    Object.equals(java.lang.Object) ， Object.hashCode() ， rehash() ， Collection ， Map ， HashMap ， TreeMap ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Hashtable​()
      构造一个新的，空的散列表，默认初始容量（11）和负载因子（0.75）。
      Hashtable​(int initialCapacity)
      构造一个新的，空的哈希表，具有指定的初始容量和默认负载因子（0.75）。
      Hashtable​(int initialCapacity, float loadFactor)
      构造一个新的，空的哈希表，具有指定的初始容量和指定的负载因子。
      Hashtable​(Map<? extends K,? extends V> t)
      构造一个与给定地图相同的映射的新哈希表。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      清除此散列表，使其不包含键。
      Object clone​()
      创建这个散列表的浅拷贝。
      V compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      V computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      V computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      boolean contains​(Object value)
      测试一些键映射到这个哈希表中的指定值。
      boolean containsKey​(Object key)
      测试指定的对象是否在此哈希表中的键。
      boolean containsValue​(Object value)
      如果此哈希表将一个或多个键映射到此值，则返回true。
      Enumeration<V> elements​()
      返回此散列表中值的枚举。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      boolean equals​(Object o)
      根据Map界面中的定义，将指定的对象与此Map进行比较以相等。
      void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。
      V getOrDefault​(Object key, V defaultValue)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。
      int hashCode​()
      按照Map界面中的定义返回此Map的哈希码值。
      boolean isEmpty​()
      测试这个哈希表是否将值映射到值。
      Enumeration<K> keys​()
      返回此散列表中键的枚举。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      V merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
      V put​(K key, V value)
      将指定的 key映射到此散列表中指定的 value 。
      void putAll​(Map<? extends K,? extends V> t)
      将所有从指定地图的映射复制到此散列表。
      V putIfAbsent​(K key, V value)
      如果指定的键尚未与值相关联（或映射到 null ）将其与给定值相关联并返回 null ，否则返回当前值。
      protected void rehash​()
      增加这个散列表的内部重组能力，从而更有效地适应和访问其条目。
      V remove​(Object key)
      从此散列表中删除键（及其对应的值）。
      boolean remove​(Object key, Object value)
      仅当指定的密钥当前映射到指定的值时删除该条目。
      V replace​(K key, V value)
      只有当目标映射到某个值时，才能替换指定键的条目。
      boolean replace​(K key, V oldValue, V newValue)
      仅当当前映射到指定的值时，才能替换指定键的条目。
      void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      int size​()
      返回此哈希表中的键数。
      String toString​()
      以一组条目的形式返回此 Hashtable对象的字符串表示形式，其括在大括号中，并以ASCII字符“ ,  ”（逗号和空格）分隔。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from interface java.util.Map

        entry, of, of, of, of, of, of, of, of, of, of, of, ofEntries

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Hashtable

        public Hashtable​(int initialCapacity,
                 float loadFactor)
        构造一个新的，空的哈希表，具有指定的初始容量和指定的负载因子。
        参数
        initialCapacity - 哈希表的初始容量。
        loadFactor - 散列表的负载系数。
        异常
        IllegalArgumentException - 如果初始容量小于零，或者负载因子是非正性的。

      • Hashtable

        public Hashtable​(int initialCapacity)
        构造一个新的，空的哈希表，具有指定的初始容量和默认负载因子（0.75）。
        参数
        initialCapacity - 哈希表的初始容量。
        异常
        IllegalArgumentException - 如果初始容量小于零。

      • Hashtable

        public Hashtable​()
        构造一个新的，空的散列表，默认初始容量（11）和负载因子（0.75）。

      • Hashtable

        public Hashtable​(Map<? extends K,? extends V> t)
        构造一个与给定地图相同的映射的新哈希表。 创建哈希表的初始容量足以保持给定地图中的映射和默认负载因子（0.75）。
        参数
        t - 其映射将放置在此映射中的映射。
        异常
        NullPointerException - 如果指定的地图为空。
        从以下版本开始：
        1.2

    • 方法详细信息

      • size

        public int size​()
        返回此哈希表中的键数。
        Specified by:
        size在接口 Map<K,V>
        Specified by:
        size在 Dictionary<K,V>
        结果
        这个散列表中的键的数量。

      • isEmpty

        public boolean isEmpty​()
        测试这个哈希表是否将值映射到值。
        Specified by:
        isEmpty在接口 Map<K,V>
        Specified by:
        isEmpty在 Dictionary<K,V>
        结果
        true如果这个哈希表将任何键映射到值; false否则。

      • keys

        public Enumeration<K> keys​()
        返回此散列表中键的枚举。 对返回的对象使用枚举方法按顺序获取键。 如果哈希表在结构上被修改，同时枚举了键，则枚举的结果是未定义的。
        Specified by:
        keys在 Dictionary<K,V>
        结果
        这个哈希表中的键的枚举。
        另请参见：
        Enumeration ， elements() ， keySet() ， Map

      • elements

        public Enumeration<V> elements​()
        返回此散列表中值的枚举。 对返回的对象使用枚举方法来顺序获取元素。 如果哈希表在结构上被修改，同时枚举了值，则枚举的结果是未定义的。
        Specified by:
        elements在 Dictionary<K,V>
        结果
        列出这个散列表中的值。
        另请参见：
        Enumeration ， keys() ， values() ， Map

      • contains

        public boolean contains​(Object value)
        测试一些键映射到这个哈希表中的指定值。 此操作比containsKey方法更贵。

        请注意，此方法的功能与containsValue相同（它是集合框架中Map接口的一部分）。

        参数
        value - 要搜索的值
        结果
        true当且仅当某些键映射到equals方法确定的散列表中的value参数时; false否则。
        异常
        NullPointerException - 如果值为 null

      • containsValue

        public boolean containsValue​(Object value)
        如果此哈希表将一个或多个键映射到此值，则返回true。

        请注意，此方法的功能与contains （早于Map界面）相同。

        Specified by:
        containsValue在接口 Map<K,V>
        参数
        value - 要在此散列表中存在的值要进行测试
        结果
        true如果此映射将一个或多个键映射到指定的值
        异常
        NullPointerException - 如果值是 null
        从以下版本开始：
        1.2

      • containsKey

        public boolean containsKey​(Object key)
        测试指定的对象是否在此哈希表中的键。
        Specified by:
        containsKey在接口 Map<K,V>
        参数
        key - 可能的钥匙
        结果
        true当且仅当指定的对象是这个哈希表中的键，由equals方法确定; false否则。
        异常
        NullPointerException - 如果键是 null
        另请参见：
        contains(Object)

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含键的映射，则返回null 。

        更正式地，如果该映射包含从密钥k到值v的映射，使得(key.equals(k)) ，则该方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        Specified by:
        get在接口 Map<K,V>
        Specified by:
        get在 Dictionary<K,V>
        参数
        key - 要返回其关联值的键
        结果
        映射指定键的值，如果此映射不包含该键的映射， null
        异常
        NullPointerException - 如果指定的键为空
        另请参见：
        put(Object, Object)

      • rehash

        protected void rehash​()
        增加这个散列表的内部重组能力，从而更有效地适应和访问其条目。 当哈希表中的键数超过此散列表的容量和载入系数时，将自动调用此方法。

      • put

        public V put​(K key,
             V value)
        将指定的key映射到此散列表中指定的value 。 钥匙和价值都不能是null 。

        可以通过使用等于原始密钥的密钥调用get方法来检索该值。

        Specified by:
        put在接口 Map<K,V>
        Specified by:
        put在 Dictionary<K,V>
        参数
        key - 哈希表键
        value - 值
        结果
        此散列表中指定键的上一个值，如果没有， null
        异常
        NullPointerException - 如果键或值为 null
        另请参见：
        Object.equals(Object) ， get(Object)

      • remove

        public V remove​(Object key)
        从此散列表中删除键（及其对应的值）。 如果键不在哈希表中，此方法不执行任何操作。
        Specified by:
        remove在接口 Map<K,V>
        Specified by:
        remove在 Dictionary<K,V>
        参数
        key - 需要删除的关键
        结果
        密钥映射到此散列表中的值，如果密钥没有映射， null
        异常
        NullPointerException - 如果键是 null

      • putAll

        public void putAll​(Map<? extends K,? extends V> t)
        将所有从指定地图的映射复制到此散列表。 这些映射将替换这个散列表对于指定地图中当前的任何键的任何映射。
        Specified by:
        putAll在接口 Map<K,V>
        参数
        t - 要存储在此地图中的映射
        异常
        NullPointerException - 如果指定的地图为空
        从以下版本开始：
        1.2

      • clear

        public void clear​()
        清除此散列表，使其不包含键。
        Specified by:
        clear在接口 Map<K,V>

      • clone

        public Object clone​()
        创建这个散列表的浅拷贝。 哈希表本身的所有结构都被复制，但是键和值不被克隆。 这是一个相对昂贵的操作。
        重写：
        clone在 Object
        结果
        哈希表克隆
        另请参见：
        Cloneable

      • toString

        public String toString​()
        以一组条目的形式返回此Hashtable对象的字符串表示形式，并以ASCII字符“ ,  ”（逗号和空格）分隔。 每个条目都被渲染为关键字，等号为= ，以及相关联的元素，其中使用toString方法将键和元素转换为字符串。
        重写：
        toString在 Object
        结果
        这个散列表的字符串表示形式

      • keySet

        public Set<K> keySet​()
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），则迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        keySet在接口 Map<K,V>
        结果
        该地图中包含的键的集合视图
        从以下版本开始：
        1.2

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时修改映射（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        entrySet在接口 Map<K,V>
        结果
        该地图中包含的映射的集合视图
        从以下版本开始：
        1.2

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        values在接口 Map<K,V>
        结果
        该地图中包含的值的集合视图
        从以下版本开始：
        1.2

      • equals

        public boolean equals​(Object o)
        根据Map界面中的定义，将指定的对象与此Map进行比较以相等。
        Specified by:
        equals在接口 Map<K,V>
        重写：
        equals在 Object
        参数
        o - 要与此散列表相等的对象进行比较
        结果
        如果指定的Object等于此Map，则为true
        从以下版本开始：
        1.2
        另请参见：
        Map.equals(Object)

      • hashCode

        public int hashCode​()
        按照Map界面中的定义返回此Map的哈希码值。
        Specified by:
        hashCode在接口 Map<K,V>
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        从以下版本开始：
        1.2
        另请参见：
        Map.hashCode()

      • getOrDefault

        public V getOrDefault​(Object key,
                      V defaultValue)
        说明从界面Map复制
        返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。
        Specified by:
        getOrDefault在接口 Map<K,V>
        参数
        key - 要返回其关联值的键
        defaultValue - 键的默认映射
        结果
        映射指定键的值，如果此映射不包含键的映射， defaultValue

      • forEach

        public void forEach​(BiConsumer<? super K,? super V> action)
        说明从界面Map复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach在接口 Map<K,V>
        参数
        action - 要为每个条目执行的操作

      • replaceAll

        public void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        说明从界面Map复制
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll在接口 Map<K,V>
        参数
        function - 应用于每个条目的功能

      • putIfAbsent

        public V putIfAbsent​(K key,
                     V value)
        描述从接口Map复制
        如果指定的键尚未与值相关联（或映射到 null ）将其与给定值相关联并返回 null ，否则返回当前值。
        Specified by:
        putIfAbsent在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示映射以前关联的null与密钥，如果实现支持空值）。

      • remove

        public boolean remove​(Object key,
                      Object value)
        说明从接口Map复制
        仅当指定的密钥当前映射到指定的值时删除该条目。
        Specified by:
        remove在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        value - 预期与指定键相关联的值
        结果
        true如果该值被删除

      • replace

        public boolean replace​(K key,
                       V oldValue,
                       V newValue)
        说明从接口Map复制
        仅当当前映射到指定的值时，才能替换指定键的条目。
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        oldValue - 预期与指定键相关联的值
        newValue - 与指定键相关联的值
        结果
        true如果该值被替换

      • replace

        public V replace​(K key,
                 V value)
        说明从接口Map复制
        只有当目标映射到某个值时，才能替换指定键的条目。
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示以前关联的映射关系为null ，如果实现支持空值）。

      • computeIfAbsent

        public V computeIfAbsent​(K key,
                         Function<? super K,? extends V> mappingFunction)
        如果指定的键尚未与值相关联（或映射到null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是null 。

        如果映射函数返回null ，则不记录映射。 如果映射函数本身引发（未检查）异常，则重新抛出异常，并且不记录映射。 最常见的用法是构造一个用作初始映射值或记忆结果的新对象，如：

           map.computeIfAbsent(key, k -> new Value(f(k)));

        或者实现一个多值地图， Map<K,Collection<V>> ，每个键支持多个值：

           map.computeIfAbsent(key, k -> new HashSet<V>()).add(v);

        映射函数在计算过程中不应该修改该映射。

        如果映射函数在计算过程中修改了该映射，这个方法将尽力而为地抛出一个ConcurrentModificationException 。

        Specified by:
        computeIfAbsent在接口 Map<K,V>
        参数
        key - 与其关联的指定值的键
        mappingFunction - 计算值的映射函数
        结果
        与指定键相关联的当前（现有或计算）值，如果计算值为空，则为null
        异常
        ConcurrentModificationException - 如果检测到映射函数修改了此映射

      • computeIfPresent

        public V computeIfPresent​(K key,
                          BiFunction<? super K,? super V,? extends V> remappingFunction)
        如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

        如果重映射函数返回null ，则映射将被删除。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        如果重映射功能在计算过程中修改了该映射，则该方法将尽力而为地抛出ConcurrentModificationException 。

        Specified by:
        computeIfPresent在接口 Map<K,V>
        参数
        key - 要与其关联的指定值的键
        remappingFunction - 用于计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        ConcurrentModificationException - 如果检测到重映射功能修改了该地图

      • compute

        public V compute​(K key,
                 BiFunction<? super K,? super V,? extends V> remappingFunction)
        尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则null ）。 例如，要为值映射创建或附加String msg：
           map.compute(key, (k, v) -> (v == null) ? msg : v.concat(msg))
        （方法merge()通常更容易用于此目的。）

        如果重映射函数返回null ，映射将被删除（如果最初不存在，则保持不存在）。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        如果重映射功能在计算过程中修改了该映射，这个方法将尽力而为地抛出一个ConcurrentModificationException 。

        Specified by:
        compute在接口 Map<K,V>
        参数
        key - 要与其关联的指定值的键
        remappingFunction - 计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        ConcurrentModificationException - 如果检测到重映射功能修改了该地图

      • merge

        public V merge​(K key,
               V value,
               BiFunction<? super V,? super V,? extends V> remappingFunction)
        如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。 否则，将关联值替换为给定重映射函数的结果，如果结果为null ，则将其null 。 当组合键的多个映射值时，该方法可能是有用的。 例如，要为值映射创建或附加String msg ：
           map.merge(key, msg, String::concat)

        如果重映射函数返回null ，则映射将被删除。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        如果重新映射功能在计算过程中修改了该映射，这个方法将尽力而为地抛出一个ConcurrentModificationException 。

        Specified by:
        merge在接口 Map<K,V>
        参数
        key - 与其结合的值相关联的键
        value - 要与与密钥相关联的现有值合并的非空值，或者如果没有与密钥相关联的现有值或空值与密钥相关联
        remappingFunction - 如果存在重新计算值的重映射功能
        结果
        与指定键相关联的新值，如果没有值与该键相关联，则返回null
        异常
        ConcurrentModificationException - if it is detected that the remapping function modified this map
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IdentityHashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class IdentityHashMap<K,V>

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.IdentityHashMap<K,V>
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Map<K,V>

    public class IdentityHashMap<K,V>
extends AbstractMap<K,V>
implements Map<K,V>, Serializable, Cloneable
    该类使用哈希表实现Map接口，在比较键（和值）时使用引用相等代替对象相等。 换句话说，在IdentityHashMap ，当且仅当(k1==k2) ，两个键k1和k2被认为是相等的。 （正常情况下， Map实现（如HashMap ）当两个键k1和k2被认为是相等的，如果且仅在(k1==null ? k2==null : k1.equals(k2)) ）

    这个类不是通用的Map实现！ 虽然这个类实现了Map接口，但它有意违反了Map's通用协议，当对比时，它要求使用equals方法。 该类仅在需要引用相等语义的罕见情况下才能使用。

    此类的典型用法是拓扑保留对象图转换 ，如序列化或深层复制。 为了执行这种转换，程序必须保持跟踪已经处理的所有对象引用的“节点表”。 节点表不能等于不同的对象，即使它们恰好相等。 此类的另一个典型用途是维护代理对象 。 例如，调试工具可能希望为正在调试的程序中的每个对象维护代理对象。

    此类提供所有可选的地图操作，并允许null值和null键。 该类对地图的顺序不作任何保证; 特别是，它不能保证订单在一段时间内保持不变。

    假设系统标识散列函数（ System.identityHashCode(Object) ）正确地分散在这些存储桶中，这个类提供了基本操作（ get和put ）的恒定时间性能。

    该类有一个调整参数（其影响性能但不影响语义）： 预期的最大大小 。 此参数是映射预期保存的键值映射的最大数量。 在内部，该参数用于确定最初包含散列表的桶数。 预期最大大小和桶数之间的精确关系未明确。

    如果地图的大小（键值映射的数量）足够超过预期的最大大小，则桶的数量增加。 增加桶数（“rehashing”）可能相当昂贵，因此可以创建具有足够大的预期最大大小的身份哈希映射。 另一方面，集合视图的迭代需要时间与哈希表中的桶数成正比，因此如果您特别关注迭代性能或内存使用情况，则不会将预期的最大大小设置得太高。

    请注意，此实现不同步。 如果多个线程同时访问身份哈希映射，并且至少一个线程在结构上修改映射，则必须在外部进行同步。 （结构修改是添加或删除一个或多个映射的任何操作;仅改变与实例已经包含的密钥相关联的值不是结构修改。）这通常通过对自然地封装映射的一些对象进行同步来实现。 如果没有这样的对象存在，应该使用Collections.synchronizedMap方法“包装”地图。 这最好在创建时完成，以防止意外的不同步访问地图：

      Map m = Collections.synchronizedMap(new IdentityHashMap(...));

    由所有这个类的“集合视图方法”返回的集合的iterator方法返回的迭代器是故障快速的 ：如果映射在迭代器创建之后的任何时间被结构化地修改，除了通过迭代器自己的remove方法，迭代器会抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的迭代器ConcurrentModificationException扔ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 故障快速迭代器应仅用于检测错误。

    实现说明：这是一个简单的线性探测哈希表，如Sedgewick和Knuth的文本中所述。 阵列交替保持键和值。 （与使用单独的数组相比，这对于大型表具有更好的局部性。）对于许多JRE实现和操作组合，此类将产生比HashMap更好的性能（使用链接而不是线性检测）。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.4
    另请参见：
    System.identityHashCode(Object) ， Object.hashCode() ， Collection ， Map ， HashMap ， TreeMap ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      IdentityHashMap​()
      构造一个带有默认预期最大大小的新的空标识哈希映射（21）。
      IdentityHashMap​(int expectedMaxSize)
      构造一个具有指定的预期最大大小的新的空白地图。
      IdentityHashMap​(Map<? extends K,? extends V> m)
      构造一个新的标识哈希映射，其中包含指定地图中的键值映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      从这张地图中删除所有的映射。
      Object clone​()
      返回此标识哈希映射的浅拷贝：键和值本身不被克隆。
      boolean containsKey​(Object key)
      测试此标识哈希映射中指定的对象引用是否为密钥。
      boolean containsValue​(Object value)
      测试指定的对象引用是否是此标识哈希映射中的值。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      boolean equals​(Object o)
      将指定的对象与此映射进行比较以获得相等性。
      void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。
      int hashCode​()
      返回此地图的哈希码值。
      boolean isEmpty​()
      如果此标识哈希映射不包含键值映射，则返回 true 。
      Set<K> keySet​()
      返回此地图中包含的键的基于身份的设置视图。
      V put​(K key, V value)
      将指定的值与此标识哈希映射中的指定键相关联。
      void putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此地图。
      V remove​(Object key)
      从该地图中删除此密钥的映射（如果存在）。
      void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      int size​()
      返回此标识哈希映射中的键值映射的数量。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from class java.util.AbstractMap

        toString

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, getOrDefault, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • IdentityHashMap

        public IdentityHashMap​()
        构造一个带有默认预期最大大小的新的空标识哈希映射（21）。

      • IdentityHashMap

        public IdentityHashMap​(int expectedMaxSize)
        构造一个具有指定的预期最大大小的新的空白地图。 将超过预期数量的键值映射放入地图可能会导致内部数据结构增长，这可能会有些耗时。
        参数
        expectedMaxSize - 地图的预期最大大小
        异常
        IllegalArgumentException - 如果 expectedMaxSize为负数

      • IdentityHashMap

        public IdentityHashMap​(Map<? extends K,? extends V> m)
        构造一个新的标识哈希映射，其中包含指定地图中的键值映射。
        参数
        m - 其映射将被放置到该映射中的映射
        异常
        NullPointerException - 如果指定的地图为空

    • 方法详细信息

      • size

        public int size​()
        返回此标识哈希映射中的键值映射的数量。
        Specified by:
        size在接口 Map<K,V>
        重写：
        size在 AbstractMap<K,V>
        结果
        该地图中键值映射的数量

      • isEmpty

        public boolean isEmpty​()
        如果此标识哈希映射不包含键值映射，则返回 true 。
        Specified by:
        isEmpty在接口 Map<K,V>
        重写：
        isEmpty在 AbstractMap<K,V>
        结果
        true如果此标识哈希映射不包含键值映射

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回null 。

        更正式地，如果该映射包含从键k到值v的映射，使得(key == k) ，则该方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        返回值为null并不一定表示该映射不包含该键的映射; 地图也可能明确地将密钥映射到null 。 可以使用containsKey操作来区分这两种情况。

        Specified by:
        get在接口 Map<K,V>
        重写：
        get在 AbstractMap<K,V>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含键的映射， null
        另请参见：
        put(Object, Object)

      • containsKey

        public boolean containsKey​(Object key)
        测试此标识哈希映射中指定的对象引用是否为密钥。
        Specified by:
        containsKey在接口 Map<K,V>
        重写：
        containsKey中的 AbstractMap<K,V>
        参数
        key - 可能的键
        结果
        true如果指定的对象引用是此映射中的键
        另请参见：
        containsValue(Object)

      • containsValue

        public boolean containsValue​(Object value)
        测试指定的对象引用是否是此标识哈希映射中的值。
        Specified by:
        containsValue在接口 Map<K,V>
        重写：
        containsValue在 AbstractMap<K,V>
        参数
        value - 要在此地图中存在的值要进行测试
        结果
        true如果此映射将一个或多个键映射到指定的对象引用
        另请参见：
        containsKey(Object)

      • put

        public V put​(K key,
             V value)
        将指定的值与此标识哈希映射中的指定键相关联。 如果地图先前包含了该键的映射，则替换旧值。
        Specified by:
        put在接口 Map<K,V>
        重写：
        put在 AbstractMap<K,V>
        参数
        key - 指定值与之关联的关键字
        value - 与指定键相关联的值
        结果
        先前的值相关联key ，或null如果没有映射key 。 （A null返回也可以指示以前关联的地图null与key ）
        另请参见：
        Object.equals(Object) ， get(Object) ， containsKey(Object)

      • putAll

        public void putAll​(Map<? extends K,? extends V> m)
        将指定地图的所有映射复制到此地图。 这些映射将替换此映射对当前在指定映射中的任何键的任何映射。
        Specified by:
        putAll在接口 Map<K,V>
        重写：
        putAll在 AbstractMap<K,V>
        参数
        m - 要存储在此地图中的映射
        异常
        NullPointerException - 如果指定的地图为空

      • remove

        public V remove​(Object key)
        从该地图中删除此密钥的映射（如果存在）。
        Specified by:
        remove在接口 Map<K,V>
        重写：
        remove在 AbstractMap<K,V>
        参数
        key - 要从地图中删除其映射的密钥
        结果
        先前的值相关联key ，或null如果没有映射key 。 （A null返回也可以指示以前关联的地图null与key ）

      • clear

        public void clear​()
        从这张地图中删除所有的映射。 此呼叫返回后，地图将为空。
        Specified by:
        clear在接口 Map<K,V>
        重写：
        clear在 AbstractMap<K,V>

      • equals

        public boolean equals​(Object o)
        将指定的对象与此映射进行比较以获得相等性。 如果给定的对象也是一个地图，并且两个地图表示相同的对象引用映射，则返回true 。 更正式地，这张地图等于另一个地图m如果且仅当this.entrySet().equals(m.entrySet()) 。

        由于该映射的基于参考平等的语义，如果将该映射与法线映射进行比较，则可能会违反Object.equals合同的对称性和传递性要求。 但是， Object.equals合约在IdentityHashMap实例中IdentityHashMap 。

        Specified by:
        equals在接口 Map<K,V>
        重写：
        equals在 AbstractMap<K,V>
        参数
        o - 要与此映射相等的对象进行比较
        结果
        true如果指定的对象等于此映射
        另请参见：
        Object.equals(Object)

      • hashCode

        public int hashCode​()
        返回此地图的哈希码值。 地图的哈希码被定义为地图entrySet()视图中每个条目的哈希代码的总和。 这确保了m1.equals(m2)意味着m1.hashCode()==m2.hashCode()对于任何两个IdentityHashMap实例m1和m2 ，所要求的一般合同Object.hashCode() 。

        由于该地图entrySet方法返回的集合中的Map.Entry实例的基于参考平等的语义，如果被比较的两个对象之一是上一段中提到的Object.hashCode的合同要求，则可能会被违反IdentityHashMap实例，另一个是法线贴图。

        Specified by:
        hashCode在接口 Map<K,V>
        重写：
        hashCode在 AbstractMap<K,V>
        结果
        该地图的哈希码值
        另请参见：
        Object.equals(Object) ， equals(Object)

      • clone

        public Object clone​()
        返回此标识哈希映射的浅拷贝：键和值本身不被克隆。
        重写：
        clone在 AbstractMap<K,V>
        结果
        这张地图的浅拷贝
        另请参见：
        Cloneable

      • keySet

        public Set<K> keySet​()
        返回此地图中包含的键的基于身份的设置视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时修改了映射，则迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear方法。 它不支持add或addAll方法。

        当该方法返回的对象实现Set接口时， 不遵守Set's通用合同。 像其背景图一样，该方法返回的集合将元素等式定义为引用相等而不是对象相等。 这会影响其行为contains ， remove ， containsAll ， equals ，并hashCode方法。

        返回的集合的equals方法只有在指定的对象是包含与返回集完全相同的对象引用的集合时才返回true 。 如果将此方法返回的集合与正常集进行比较，则可能会违反Object.equals合同的对称性和传递性要求。 但是， Object.equals合同保证在此方法返回的集合中。

        返回的集合的hashCode方法返回集合中元素的身份哈希码的总和，而不是它们的哈希码的总和。 这是由equals方法的语义变化规定的，以便通过此方法返回的集合中强制执行Object.hashCode方法的一般合同。

        Specified by:
        keySet在接口 Map<K,V>
        重写：
        keySet在 AbstractMap<K,V>
        结果
        该地图中包含的键的基于身份的设置视图
        另请参见：
        Object.equals(Object) ， System.identityHashCode(Object)

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时修改了映射，则迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear方法。 它不支持add或addAll方法。

        虽然此方法返回的对象实现了Collection接口，它不服从Collection's总承包合同。 像其背景图一样，该方法返回的集合将元素等式定义为引用相等而不是对象相等。 这会影响其行为contains ， remove和containsAll方法。

        Specified by:
        values在接口 Map<K,V>
        重写：
        values在 AbstractMap<K,V>
        结果
        该地图中包含的值的集合视图

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。 返回的集合中的每个元素都是基于引用的基于平等的Map.Entry 。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时修改了映射，则迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear方法。 它不支持add或addAll方法。

        与支持映射一样，此方法返回的集合中的Map.Entry对象将键和值相等定义为引用相等而不是对象相等。 这会影响这些Map.Entry对象的equals和hashCode方法的行为。 基于参考平等Map.Entry e等于一个对象o当且仅当o是Map.Entry和e.getKey()==o.getKey() && e.getValue()==o.getValue() 。 为了适应这些等价语义， hashCode方法返回System.identityHashCode(e.getKey()) ^ System.identityHashCode(e.getValue()) 。

        由于此方法返回的集合中的Map.Entry实例的基于参考平等的语义，如果将集合中的任何条目与正常条目进行比较，则可能会违反Object.equals(Object)合同的对称性和传递性要求映射条目，或者如果将此方法返回的集合与一组法线贴图条目进行比较（例如通过在法线贴图上调用该方法将返回）。 但是， Object.equals合同在基于身份的地图条目之间以及这些条目之间保留。

        Specified by:
        entrySet在接口 Map<K,V>
        Specified by:
        entrySet在 AbstractMap<K,V>
        结果
        该地图中包含的身份映射的集合视图

      • forEach

        public void forEach​(BiConsumer<? super K,? super V> action)
        描述从接口Map复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach在接口 Map<K,V>
        参数
        action - 为每个条目执行的操作

      • replaceAll

        public void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        描述从接口Map复制
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll在接口 Map<K,V>
        参数
        function - 应用于每个条目的功能
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalFormatCodePointException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class IllegalFormatCodePointException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.IllegalFormatCodePointException
  • All Implemented Interfaces:
    Serializable

    public class IllegalFormatCodePointException
extends IllegalFormatException
    如果Character.isValidCodePoint(int)定义的Unicode代码无效的字符被传递给Formatter ， 则会抛出未经检查的异常。

    除非另有说明，否则传递一个null参数到null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalFormatCodePointException​(int c)
      使用 Character.isValidCodePoint(int)定义的指定的非法代码点构造此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getCodePoint​()
      返回由 Character.isValidCodePoint(int)定义的非法代码点。
      String getMessage​()
      返回此throwable的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalFormatCodePointException

        public IllegalFormatCodePointException​(int c)
        使用 Character.isValidCodePoint(int)定义的指定的非法代码点构造此类的实例。
        参数
        c - 非法的Unicode代码点

    • 方法详细信息

      • getCodePoint

        public int getCodePoint​()
        返回由 Character.isValidCodePoint(int)定义的非法代码点。
        结果
        非法的Unicode代码点

      • getMessage

        public String getMessage​()
        说明从类别复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalFormatConversionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class IllegalFormatConversionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.IllegalFormatConversionException
  • All Implemented Interfaces:
    Serializable

    public class IllegalFormatConversionException
extends IllegalFormatException
    当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。

    除非另有说明，否则将null参数传递给null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalFormatConversionException​(char c, Class<?> arg)
      使用不匹配的转换和相应的参数类构造此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Class<?> getArgumentClass​()
      返回不匹配参数的类。
      char getConversion​()
      返回不适用的转换。
      String getMessage​()
      返回此throwable的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalFormatConversionException

        public IllegalFormatConversionException​(char c,
                                        Class<?> arg)
        使用不匹配的转换和相应的参数类构造此类的实例。
        参数
        c - 不适用转换
        arg - 不匹配参数的类

    • 方法详细信息

      • getConversion

        public char getConversion​()
        返回不适用的转换。
        结果
        不适用的转换

      • getArgumentClass

        public Class<?> getArgumentClass​()
        返回不匹配参数的类。
        结果
        不匹配的参数的类

      • getMessage

        public String getMessage​()
        描述从类复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        the detail message string of this Throwable instance (which may be null).
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class IllegalFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    DuplicateFormatFlagsException ， FormatFlagsConversionMismatchException ， IllegalFormatCodePointException ， IllegalFormatConversionException ， IllegalFormatFlagsException ， IllegalFormatPrecisionException ， IllegalFormatWidthException ， MissingFormatArgumentException ， MissingFormatWidthException ， UnknownFormatConversionException ， UnknownFormatFlagsException

    public class IllegalFormatException
extends IllegalArgumentException
    当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。 应该实例化仅对应于特定错误的异常的显式子类型。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalFormatFlagsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class IllegalFormatFlagsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.IllegalFormatFlagsException
  • All Implemented Interfaces:
    Serializable

    public class IllegalFormatFlagsException
extends IllegalFormatException
    提供非法组合标志时抛出未检查的异常。

    除非另有说明，否则传递null参数到null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalFormatFlagsException​(String f)
      使用指定的标志构造此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getFlags​()
      返回包含非法组合的标志集。
      String getMessage​()
      返回此throwable的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalFormatFlagsException

        public IllegalFormatFlagsException​(String f)
        使用指定的标志构造此类的实例。
        参数
        f - 包含非法组合的格式标志集

    • 方法详细信息

      • getFlags

        public String getFlags​()
        返回包含非法组合的标志集。
        结果
        旗帜

      • getMessage

        public String getMessage​()
        描述从类别复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalFormatPrecisionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class IllegalFormatPrecisionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.IllegalFormatPrecisionException
  • All Implemented Interfaces:
    Serializable

    public class IllegalFormatPrecisionException
extends IllegalFormatException
    当精度为 -1以外的负值时，抛出未检查的异常，转换不支持精度，否则不支持该值。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalFormatPrecisionException​(int p)
      构造具有指定精度的此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getMessage​()
      返回此throwable的详细消息字符串。
      int getPrecision​()
      返回精度

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalFormatPrecisionException

        public IllegalFormatPrecisionException​(int p)
        构造具有指定精度的此类的实例。
        参数
        p - 精度

    • 方法详细信息

      • getPrecision

        public int getPrecision​()
        返回精度
        结果
        精度

      • getMessage

        public String getMessage​()
        描述从类别复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalFormatWidthException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class IllegalFormatWidthException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.IllegalFormatWidthException
  • All Implemented Interfaces:
    Serializable

    public class IllegalFormatWidthException
extends IllegalFormatException
    当格式宽度为 -1以外的否定值时，将抛出未经检查的异常，否则不受支持。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalFormatWidthException​(int w)
      构造具有指定宽度的此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getMessage​()
      返回此throwable的详细消息字符串。
      int getWidth​()
      返回宽度

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalFormatWidthException

        public IllegalFormatWidthException​(int w)
        构造具有指定宽度的此类的实例。
        参数
        w - 宽度

    • 方法详细信息

      • getWidth

        public int getWidth​()
        返回宽度
        结果
        宽度

      • getMessage

        public String getMessage​()
        说明从类别复制Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllformedLocaleException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class IllformedLocaleException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.util.IllformedLocaleException
  • All Implemented Interfaces:
    Serializable

    public class IllformedLocaleException
extends RuntimeException
    通过Locale和Locale.Builder中的方法抛出，以表明参数不是一个格式正确的BCP 47标签。
    从以下版本开始：
    1.7
    另请参见：
    Locale ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllformedLocaleException​()
      构造一个新的 IllformedLocaleException ，没有详细信息，-1作为错误索引。
      IllformedLocaleException​(String message)
      构造一个新的 IllformedLocaleException与给定的消息和-1作为错误索引。
      IllformedLocaleException​(String message, int errorIndex)
      构造一个新的 IllformedLocaleException与给定的消息和错误索引。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getErrorIndex​()
      返回发现错误的索引。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllformedLocaleException

        public IllformedLocaleException​()
        构造一个新的 IllformedLocaleException ，没有详细信息，-1作为错误索引。

      • IllformedLocaleException

        public IllformedLocaleException​(String message)
        构造一个新的 IllformedLocaleException与给定的消息和-1作为错误索引。
        参数
        message - 消息

      • IllformedLocaleException

        public IllformedLocaleException​(String message,
                                int errorIndex)
        构造一个新的IllformedLocaleException与给定的消息和错误索引。 误差指数是从错误形成值的开始到解析首先检测到错误的点的近似偏移量。 否定的错误索引值表示错误索引不适用或未知。
        参数
        message - 消息
        errorIndex - 指数

    • 方法详细信息

      • getErrorIndex

        public int getErrorIndex​()
        返回发现错误的索引。 负值表示错误索引不适用或未知。
        结果
        错误索引
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InputMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class InputMismatchException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.util.NoSuchElementException
            • java.util.InputMismatchException
  • All Implemented Interfaces:
    Serializable

    public class InputMismatchException
extends NoSuchElementException
    由 Scanner抛出，表示检索到的令牌与预期类型的模式不匹配，或令牌超出预期类型的范围。
    从以下版本开始：
    1.5
    另请参见：
    Scanner ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InputMismatchException​()
      构造一个 InputMismatchException其中 null为错误消息字符串。
      InputMismatchException​(String s)
      构造一个 InputMismatchException ，保存对错误消息字符串 s的引用，以供稍后通过 getMessage方法检索。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InputMismatchException

        public InputMismatchException​()
        构造 InputMismatchException其中包含 null作为其错误消息字符串。

      • InputMismatchException

        public InputMismatchException​(String s)
        构造一个 InputMismatchException ，保存对错误消息字符串 s的引用，以供以后通过 getMessage方法检索。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntSummaryStatistics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class IntSummaryStatistics

  • java.lang.Object
    • java.util.IntSummaryStatistics
  • All Implemented Interfaces:
    IntConsumer

    public class IntSummaryStatistics
extends Object
implements IntConsumer
    统计数据的收集状态，如count，min，max，sum和average。

    这个课程旨在与（但不需要） streams一起工作 。 例如，您可以使用以下方式计算int数据流的汇总统计信息：

       IntSummaryStatistics stats = intStream.collect(IntSummaryStatistics::new, IntSummaryStatistics::accept, IntSummaryStatistics::combine);

    IntSummaryStatistics可以用作reduction目标为stream 。 例如：

       IntSummaryStatistics stats = people.stream() .collect(Collectors.summarizingInt(Person::getDependents));
    这个计算单次通过计算人数，以及其受扶养人数的最小值，最大值，总和和平均值。
    Implementation Note:
    这个实现不是线程安全的。 但是，并行流中使用Collectors.summarizingInt()是安全的，因为Stream.collect()的并行实现为安全和高效的并行执行提供了必要的分区，隔离和结果合并。

    此实现不检查总和的溢出。

    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      IntSummaryStatistics​()
      用零计数，零和， Integer.MAX_VALUE分钟， Integer.MIN_VALUE最大和零平均值构造一个空实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void accept​(int value)
      在摘要信息中记录一个新值
      void combine​(IntSummaryStatistics other)
      将另一个 IntSummaryStatistics的状态合并到这个中。
      double getAverage​()
      返回记录的值的算术平均值，如果没有记录值，则返回零。
      long getCount​()
      返回记录的值的计数。
      int getMax​()
      返回记录的最大值，如果没有记录值，则返回 Integer.MIN_VALUE 。
      int getMin​()
      返回记录的最小值，如果没有记录值，则返回 Integer.MAX_VALUE 。
      long getSum​()
      返回记录的值的总和，如果没有记录值，则返回零。
      String toString​()
      返回适用于调试的此对象的非空字符串表示形式。

      • Methods inherited from interface java.util.function.IntConsumer

        andThen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • IntSummaryStatistics

        public IntSummaryStatistics​()
        构造一个零实例，零计数，零和， Integer.MAX_VALUE分钟， Integer.MIN_VALUE最大和零平均值。

    • 方法详细信息

      • accept

        public void accept​(int value)
        在摘要信息中记录一个新值
        Specified by:
        accept在接口 IntConsumer
        参数
        value - 输入值

      • combine

        public void combine​(IntSummaryStatistics other)
        将另一个 IntSummaryStatistics的状态合并到这个中。
        参数
        other - 另一个 IntSummaryStatistics
        异常
        NullPointerException - 如果 other为空

      • getCount

        public final long getCount​()
        返回记录的值的计数。
        结果
        数值计数

      • getSum

        public final long getSum​()
        返回记录的值的总和，如果没有记录值，则返回零。
        结果
        值的总和，否则为零

      • getMin

        public final int getMin​()
        返回记录的最小值，如果没有记录值，则返回 Integer.MAX_VALUE 。
        结果
        最小值，如果没有， Integer.MAX_VALUE

      • getMax

        public final int getMax​()
        返回记录的最大值，如果没有记录值，则返回 Integer.MIN_VALUE 。
        结果
        最大值，或 Integer.MIN_VALUE如果没有

      • getAverage

        public final double getAverage​()
        返回记录的值的算术平均值，如果没有记录值，则返回零。
        结果
        值的算术平均值，如果没有值则为零

      • toString

        public String toString​()
        返回适用于调试的此对象的非空字符串表示形式。 准确的表示格式是未指定的，可能会在实现和版本之间变化。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidPropertiesFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class InvalidPropertiesFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.util.InvalidPropertiesFormatException
  • All Implemented Interfaces:
    Serializable

    public class InvalidPropertiesFormatException
extends IOException
    抛出以表示操作无法完成，因为输入符合Properties规范的属性集合的相应XML文档类型。

    请注意，尽管InvalidPropertiesFormatException从Exception继承Serializable接口，但它并不是可串行化的。 实现适当的序列化方法来抛出NotSerializableException。

    从以下版本开始：
    1.5
    另请参见：
    Properties

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidPropertiesFormatException​(String message)
      使用指定的详细消息构造InvalidPropertiesFormatException。
      InvalidPropertiesFormatException​(Throwable cause)
      构造具有指定原因的InvalidPropertiesFormatException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidPropertiesFormatException

        public InvalidPropertiesFormatException​(Throwable cause)
        构造具有指定原因的InvalidPropertiesFormatException。
        参数
        cause - 原因（保存以供 Throwable.getCause()方法后续检索）。

      • InvalidPropertiesFormatException

        public InvalidPropertiesFormatException​(String message)
        使用指定的详细消息构造InvalidPropertiesFormatException。
        参数
        message - 详细信息。 保存详细信息以供以后通过Throwable.getMessage()方法检索。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Iterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Iterator<E>

  • 参数类型
    E - 此迭代器返回的元素的类型
    All Known Subinterfaces:
    EventIterator ， ListIterator<E> ， PrimitiveIterator<T,T_CONS> ， PrimitiveIterator.OfDouble ， PrimitiveIterator.OfInt ， PrimitiveIterator.OfLong ， XMLEventReader
    所有已知实现类：
    BeanContextSupport.BCSIterator ， EventReaderDelegate ， Scanner

    public interface Iterator<E>
    一个集合的迭代器。 Iterator代替了Java Collections Framework中的Enumeration 。 迭代器有两种不同的枚举方式：
    • 迭代器允许调用者在迭代期间从底层集合中删除元素，并具有明确定义的语义。
    • 方法名称得到改进。

    此接口是Java Collections Framework的成员。

    API Note:
    一个Enumeration可以被转换成一个Iterator通过使用Enumeration.asIterator()方法。
    从以下版本开始：
    1.2
    另请参见：
    Collection ， ListIterator ， Iterable

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default void forEachRemaining​(Consumer<? super E> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      boolean hasNext​()
      如果迭代具有更多元素，则返回 true 。
      E next​()
      返回迭代中的下一个元素。
      default void remove​()
      从底层集合中删除此迭代器返回的最后一个元素（可选操作）。

    • 方法详细信息

      • hasNext

        boolean hasNext​()
        如果迭代具有更多元素，则返回true 。 （换句话说，如果true将返回一个元素而不是抛出异常，则返回true ）
        结果
        true如果迭代有更多的元素

      • next

        E next​()
        返回迭代中的下一个元素。
        结果
        迭代中的下一个元素
        异常
        NoSuchElementException - 如果迭代没有更多的元素

      • remove

        default void remove​()
        从底层集合中删除此迭代器返回的最后一个元素（可选操作）。 这种方法只能在每次调用next()时调用一次。

        如果在迭代正在进行中，除了通过调用此方法之外的任何方式修改底层集合，否则迭代器的行为是未指定的，除非重写类已指定并发修改策略。

        如果在调用forEachRemaining方法后调用此方法， 则不指定迭代器的行为。

        实现要求：
        默认实现会抛出一个UnsupportedOperationException的实例，并且不执行其他操作。
        异常
        UnsupportedOperationException - 如果此迭代器不支持 remove操作
        IllegalStateException - 如果 next方法尚未被调用，或 remove方法在最后一次调用 next方法之后已经被调用

      • forEachRemaining

        default void forEachRemaining​(Consumer<? super E> action)
        对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作以任何方式修改集合（即使通过调用remove方法或Iterator子类型的其他mutator方法），迭代器的行为也是未指定的，除非重写类已指定并发修改策略。

        如果动作引发异常，则未指定迭代器的后续行为。

        实现要求：

        默认实现的行为如下：

           while (hasNext()) action.accept(next());
        参数
        action - 要对每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.util (Java SE 9 & JDK 9 )

java.util

Interfaces

  • Collection
  • Comparator
  • Deque
  • Enumeration
  • EventListener
  • Formattable
  • Iterator
  • List
  • ListIterator
  • Map
  • Map.Entry
  • NavigableMap
  • NavigableSet
  • Observer
  • PrimitiveIterator
  • PrimitiveIterator.OfDouble
  • PrimitiveIterator.OfInt
  • PrimitiveIterator.OfLong
  • Queue
  • RandomAccess
  • ServiceLoader.Provider
  • Set
  • SortedMap
  • SortedSet
  • Spliterator
  • Spliterator.OfDouble
  • Spliterator.OfInt
  • Spliterator.OfLong
  • Spliterator.OfPrimitive

Classes

  • AbstractCollection
  • AbstractList
  • AbstractMap
  • AbstractMap.SimpleEntry
  • AbstractMap.SimpleImmutableEntry
  • AbstractQueue
  • AbstractSequentialList
  • AbstractSet
  • ArrayDeque
  • ArrayList
  • Arrays
  • Base64
  • Base64.Decoder
  • Base64.Encoder
  • BitSet
  • Calendar
  • Calendar.Builder
  • Collections
  • Currency
  • Date
  • Dictionary
  • DoubleSummaryStatistics
  • EnumMap
  • EnumSet
  • EventListenerProxy
  • EventObject
  • FormattableFlags
  • Formatter
  • GregorianCalendar
  • HashMap
  • HashSet
  • Hashtable
  • IdentityHashMap
  • IntSummaryStatistics
  • LinkedHashMap
  • LinkedHashSet
  • LinkedList
  • ListResourceBundle
  • Locale
  • Locale.Builder
  • Locale.LanguageRange
  • LongSummaryStatistics
  • Objects
  • Observable
  • Optional
  • OptionalDouble
  • OptionalInt
  • OptionalLong
  • PriorityQueue
  • Properties
  • PropertyPermission
  • PropertyResourceBundle
  • Random
  • ResourceBundle
  • ResourceBundle.Control
  • Scanner
  • ServiceLoader
  • SimpleTimeZone
  • Spliterators
  • Spliterators.AbstractDoubleSpliterator
  • Spliterators.AbstractIntSpliterator
  • Spliterators.AbstractLongSpliterator
  • Spliterators.AbstractSpliterator
  • SplittableRandom
  • Stack
  • StringJoiner
  • StringTokenizer
  • Timer
  • TimerTask
  • TimeZone
  • TreeMap
  • TreeSet
  • UUID
  • Vector
  • WeakHashMap

Enums

  • Formatter.BigDecimalLayoutForm
  • Locale.Category
  • Locale.FilteringMode
  • Locale.IsoCountryCode

Exceptions

  • ConcurrentModificationException
  • DuplicateFormatFlagsException
  • EmptyStackException
  • FormatFlagsConversionMismatchException
  • FormatterClosedException
  • IllegalFormatCodePointException
  • IllegalFormatConversionException
  • IllegalFormatException
  • IllegalFormatFlagsException
  • IllegalFormatPrecisionException
  • IllegalFormatWidthException
  • IllformedLocaleException
  • InputMismatchException
  • InvalidPropertiesFormatException
  • MissingFormatArgumentException
  • MissingFormatWidthException
  • MissingResourceException
  • NoSuchElementException
  • TooManyListenersException
  • UnknownFormatConversionException
  • UnknownFormatFlagsException

Errors

  • ServiceConfigurationError


java.util (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util

包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。 此包还包含遗留收集类和传统的日期和时间类。

Java Collections Framework

有关概述，API大纲和设计理由，请参阅：

  • Collections Framework Documentation

有关使用集合框架的教程和编程指南，请参阅：

  • Collections Framework Tutorial
从以下版本开始：
1.0
  • 接口摘要
    接口 描述
    Collection<E>
    集合层次结构中的根界面。
    Comparator<T>
    比较功能，对一些对象的集合施加了一个 整体排序 。
    Deque<E>
    支持两端元素插入和移除的线性集合。
    Enumeration<E>
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    Formattable
    Formattable接口必须由任何需要使用's'转换说明符Formatter进行自定义格式化的类来实现。
    Iterator<E>
    一个集合的迭代器。
    List<E>
    有序集合（也称为 序列 ）。
    ListIterator<E>
    用于允许程序员沿任一方向遍历列表的列表的迭代器，在迭代期间修改列表，并获取列表中迭代器的当前位置。
    Map<K,V>
    将键映射到值的对象。
    Map.Entry<K,V>
    地图条目（键值对）。
    NavigableMap<K,V>
    A SortedMap扩展了导航方法返回给定搜索目标的最接近的匹配。
    NavigableSet<E>
    A SortedSet扩展了导航方法，报告给定搜索目标的最匹配的匹配。
    Observer Deprecated.
    此接口已被弃用。
    PrimitiveIterator<T,T_CONS>
    基本类型为 Iterator基本类型。
    PrimitiveIterator.OfDouble
    一个专门为 double值的迭代器。
    PrimitiveIterator.OfInt
    一个专门为 int值的迭代器。
    PrimitiveIterator.OfLong
    一个专门针对 long值的迭代器。
    Queue<E>
    设计用于在处理之前保留元素的集合。
    RandomAccess
    标记接口由 List实现使用，以表明它们支持快速（通常为恒定时间）随机访问。
    ServiceLoader.Provider<S>
    代表由 ServiceLoader提供的服务提供商。
    Set<E>
    不包含重复元素的集合。
    SortedMap<K,V>
    A Map进一步提供其键上的总排序 。
    SortedSet<E>
    A Set进一步提供了其元素的总排序 。
    Spliterator<T>
    用于遍历和分割源的元素的对象。
    Spliterator.OfDouble
    一个专门针对 double值的 double 。
    Spliterator.OfInt
    一个专业为 int值的 int 。
    Spliterator.OfLong
    一个专门为 long值的 long 。
    Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>
    专门针对原始价值观的Spliterator。
  • 类摘要
    Class 描述
    AbstractCollection<E>
    该类提供了 Collection接口的骨架实现，以尽量减少实现此接口所需的工作量。
    AbstractList<E>
    该类提供了List接口的骨架实现，以最小化实现由“随机访问”数据存储（如数组）支持的此接口所需的工作量。
    AbstractMap<K,V>
    该类提供 Map接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractMap.SimpleEntry<K,V>
    保存密钥和值的条目。
    AbstractMap.SimpleImmutableEntry<K,V>
    保持一个不变的钥匙和价值的条目。
    AbstractQueue<E>
    这个类提供了一些Queue操作的骨架实现。
    AbstractSequentialList<E>
    该类提供了 List接口的骨架实现，以最小化实现由“顺序访问”数据存储（如链表）支持的此接口所需的工作量。
    AbstractSet<E>
    该类提供了 Set接口的骨架实现，以尽量减少实现此接口所需的工作量。
    ArrayDeque<E>
    Deque接口的可调整大小的数组实现。
    ArrayList<E>
    List接口的可调整大小的数组实现。
    Arrays
    该类包含用于操作数组的各种方法（如排序和搜索）。
    Base64
    该类仅由用于获得Base64编码方案的编码器和解码器的静态方法组成。
    Base64.Decoder
    该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于解码字节数据的解码器。
    Base64.Encoder
    该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于编码字节数据的编码器。
    BitSet
    该类实现了根据需要增长的位向量。
    Calendar
    所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
    Calendar.Builder
    Calendar.Builder用于从各种日期时间参数创建 Calendar 。
    Collections
    此类仅由静态方法组合或返回集合。
    Currency
    代表货币。
    Date
    Date类代表了一个特定的时间，以毫秒的精度。
    Dictionary<K,V>
    Dictionary类是任何类的抽象父类，例如 Hashtable ，它将键映射到值。
    DoubleSummaryStatistics
    统计数据的收集状态，如count，min，max，sum和average。
    EnumMap<K extends Enum<K>,V>
    专门用于枚举类型键的Map实现。
    EnumSet<E extends Enum<E>>
    一个专门用于枚举类型的Set实现。
    EventListenerProxy<T extends EventListener>
    一个 EventListener类的抽象包装类， EventListener一组附加参数与侦听器相关联。
    EventObject
    所有事件状态对象应从其派生的根类。
    FormattableFlags
    FomattableFlags被传递给Formattable.formatTo()方法和修改的输出格式为Formattables 。
    Formatter
    printf风格格式字符串的解释器。
    GregorianCalendar
    GregorianCalendar是的具体子 Calendar ，并提供了世界上大多数国家使用的标准日历系统。
    HashMap<K,V>
    基于哈希表的实现的 Map接口。
    HashSet<E>
    该类实现 Set接口，由哈希表（实际为 HashMap实例）支持。
    Hashtable<K,V>
    该类实现了一个哈希表，它将键映射到值。
    IdentityHashMap<K,V>
    该类使用哈希表实现 Map接口，在比较键（和值）时，使用引用相等代替对象相等。
    IntSummaryStatistics
    统计数据的收集状态，如count，min，max，sum和average。
    LinkedHashMap<K,V>
    哈希表和链表实现的 Map接口，具有可预测的迭代次序。
    LinkedHashSet<E>
    哈希表和链表实现的 Set接口，具有可预测的迭代次序。
    LinkedList<E>
    双链表实现了 List和 Deque接口。
    ListResourceBundle
    ListResourceBundle是一个抽象类 ResourceBundle管理资源，以方便和易于使用的列表区域设置。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化区域。
    Locale.Builder
    Builder用于从设置器配置的值构建 Locale实例。
    Locale.LanguageRange
    该类表示在 RFC 4647 Matching of Language Tags中定义的 语言范围 。
    LongSummaryStatistics
    统计数据的收集状态，如count，min，max，sum和average。
    Objects
    此类由 static用于在对象上操作的实用方法或在操作之前检查某些条件。
    Observable Deprecated.
    此类和Observer接口已被弃用。
    Optional<T>
    可能包含或不包含非 null值的容器对象。
    OptionalDouble
    可能包含或可能不包含 double值的容器对象。
    OptionalInt
    可能含有或可能不包含 int值的容器对象。
    OptionalLong
    一个可能含有也可能不包含 long值的容器对象。
    PriorityQueue<E>
    基于优先级堆的无限优先级queue 。
    Properties
    Properties类表示一组持久的属性。
    PropertyPermission
    此类用于属性权限。
    PropertyResourceBundle
    PropertyResourceBundle是的具体子类 ResourceBundle管理资源使用一组属性文件中的静态字符串的语言环境。
    Random
    该类的实例用于生成伪随机数的流。
    ResourceBundle
    资源束包含区域特定的对象。
    ResourceBundle.Control
    ResourceBundle.Control定义了在捆绑包加载过程中由 ResourceBundle.getBundle工厂方法调用的一组回调方法。
    Scanner
    一个简单的文本扫描器，可以使用正则表达式解析原始类型和字符串。
    ServiceLoader<S>
    一种加载服务实现的工具。
    SimpleTimeZone
    SimpleTimeZone是一个具体子类 TimeZone ，表示一个使用格里高利历的时区。
    Spliterators
    静态类和用于上操作或创建的实例的方法Spliterator及其原始特Spliterator.OfInt ， Spliterator.OfLong ，和Spliterator.OfDouble 。
    Spliterators.AbstractDoubleSpliterator
    摘要 Spliterator.OfDouble实现了 trySplit以允许有限的并行性。
    Spliterators.AbstractIntSpliterator
    摘要 Spliterator.OfInt实现 trySplit以允许有限的并行性。
    Spliterators.AbstractLongSpliterator
    一个抽象的 Spliterator.OfLong ，实现 trySplit以允许有限的并行性。
    Spliterators.AbstractSpliterator<T>
    一个抽象的 Spliterator实现 trySplit允许有限的并行性。
    SplittableRandom
    适用于（在其他上下文中）使用可能产生子任务的孤立并行计算的均匀伪随机值的生成器。
    Stack<E>
    Stack类代表最先进先出（LIFO）堆栈的对象。
    StringJoiner
    StringJoiner用于构造由分隔符分隔的字符序列，并可选地以提供的前缀开头，并以提供的后缀结尾。
    StringTokenizer
    字符串tokenizer类允许应用程序将字符串拆分成令牌。
    Timer
    线程调度任务以供将来在后台线程中执行的功能。
    TimerTask
    可以由Timer进行一次性或重复执行的任务 。
    TimeZone
    TimeZone代表时区偏移量，也可以计算出夏令时。
    TreeMap<K,V>
    一个基于红黑树的NavigableMap实现。
    TreeSet<E>
    一个NavigableSet实现基于一个TreeMap 。
    UUID
    一个表示不可变的通用唯一标识符（UUID）的类。
    Vector<E>
    Vector类实现了可扩展的对象数组。
    WeakHashMap<K,V>
    基于哈希表的实现的 Map接口，具有 弱键 。
  • 枚举摘要
    Enum 描述
    Formatter.BigDecimalLayoutForm
    枚举为 BigDecimal格式化。
    Locale.Category
    枚举地区类别。
    Locale.FilteringMode
    此枚举提供常量来选择区域设置匹配的过滤模式。
    Locale.IsoCountryCode
    用于指定ISO 3166中定义的类型的枚举。
  • 异常摘要
    异常 描述
    ConcurrentModificationException
    当不允许这样的修改时，可以通过检测到对象的并发修改的方法来抛出此异常。
    DuplicateFormatFlagsException
    在格式说明符中提供重复标志时抛出未经检查的异常。
    EmptyStackException
    由 Stack类中的方法抛出，表示堆栈为空。
    FormatFlagsConversionMismatchException
    转换和标志不兼容时抛出未经检查的异常。
    FormatterClosedException
    格式化程序已关闭时抛出未检查的异常。
    IllegalFormatCodePointException
    当将具有由Character.isValidCodePoint(int)定义的Unicode代码无效的字符传递给Formatter时，将抛出未经检查的异常。
    IllegalFormatConversionException
    当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。
    IllegalFormatException
    当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。
    IllegalFormatFlagsException
    提供非法组合标志时抛出未检查的异常。
    IllegalFormatPrecisionException
    当精度为 -1以外的负值时，抛出未检查的异常，转换不支持精度，否则不支持该值。
    IllegalFormatWidthException
    格式宽度为 -1以外的否定值或 -1支持的未检查异常。
    IllformedLocaleException
    由Locale和Locale.Builder中的方法抛出，表示参数不是一个格式正确的BCP 47标签。
    InputMismatchException
    由 Scanner抛出，表示检索到的令牌与预期类型的模式不匹配，或令牌超出预期类型的范围。
    InvalidPropertiesFormatException
    抛出以表示操作无法完成，因为输入符合Properties规范的属性集合的相应XML文档类型。
    MissingFormatArgumentException
    当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。
    MissingFormatWidthException
    需要格式宽度时抛出未检查的异常。
    MissingResourceException
    表示资源丢失。
    NoSuchElementException
    被各种访问器方法抛出，表示被请求的元素不存在。
    TooManyListenersException
    TooManyListenersException异常被用作Java事件模型的一部分，用于注释和实现组播事件源的单播特殊情况。
    UnknownFormatConversionException
    给出未知转换时抛出未检查的异常。
    UnknownFormatFlagsException
    给定未知标志时抛出未检查的异常。
  • Error Summary
    Error 描述
    ServiceConfigurationError
    在查找，加载或实例化服务提供商时发生错误时发生错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.AbstractSequentialList<E>
          • java.util.LinkedList<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.util.List<E>, java.io.Serializable)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
        • java.util.Vector<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • java.util.Stack<E>
      • java.util.AbstractQueue<E> (implements java.util.Queue<E>)
        • java.util.PriorityQueue<E> (implements java.io.Serializable)
      • java.util.AbstractSet<E> (implements java.util.Set<E>)
        • java.util.EnumSet<E> (implements java.lang.Cloneable, java.io.Serializable)
        • java.util.HashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
          • java.util.LinkedHashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
        • java.util.TreeSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
      • java.util.ArrayDeque<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.io.Serializable)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.EnumMap<K,V> (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.LinkedHashMap<K,V> (implements java.util.Map<K,V>)
      • java.util.IdentityHashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
      • java.util.TreeMap<K,V> (implements java.lang.Cloneable, java.util.NavigableMap<K,V>, java.io.Serializable)
      • java.util.WeakHashMap<K,V> (implements java.util.Map<K,V>)
    • java.util.AbstractMap.SimpleEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • java.util.AbstractMap.SimpleImmutableEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • java.util.Arrays
    • java.util.Base64
    • java.util.Base64.Decoder
    • java.util.Base64.Encoder
    • java.util.BitSet (implements java.lang.Cloneable, java.io.Serializable)
    • java.util.Calendar (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.util.GregorianCalendar
    • java.util.Calendar.Builder
    • java.util.Collections
    • java.util.Currency (implements java.io.Serializable)
    • java.util.Date (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
    • java.util.DoubleSummaryStatistics (implements java.util.function.DoubleConsumer)
    • java.util.EventListenerProxy<T> (implements java.util.EventListener)
    • java.util.EventObject (implements java.io.Serializable)
    • java.util.FormattableFlags
    • java.util.Formatter (implements java.io.Closeable, java.io.Flushable)
    • java.util.IntSummaryStatistics (implements java.util.function.IntConsumer)
    • java.util.Locale (implements java.lang.Cloneable, java.io.Serializable)
    • java.util.Locale.Builder
    • java.util.Locale.LanguageRange
    • java.util.LongSummaryStatistics (implements java.util.function.IntConsumer, java.util.function.LongConsumer)
    • java.util.Objects
    • java.util.Observable
    • java.util.Optional<T>
    • java.util.OptionalDouble
    • java.util.OptionalInt
    • java.util.OptionalLong
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.util.PropertyPermission
    • java.util.Random (implements java.io.Serializable)
    • java.util.ResourceBundle
      • java.util.ListResourceBundle
      • java.util.PropertyResourceBundle
    • java.util.ResourceBundle.Control
    • java.util.Scanner (implements java.io.Closeable, java.util.Iterator<E>)
    • java.util.ServiceLoader<S> (implements java.lang.Iterable<T>)
    • java.util.Spliterators
    • java.util.Spliterators.AbstractDoubleSpliterator (implements java.util.Spliterator.OfDouble)
    • java.util.Spliterators.AbstractIntSpliterator (implements java.util.Spliterator.OfInt)
    • java.util.Spliterators.AbstractLongSpliterator (implements java.util.Spliterator.OfLong)
    • java.util.Spliterators.AbstractSpliterator<T> (implements java.util.Spliterator<T>)
    • java.util.SplittableRandom
    • java.util.StringJoiner
    • java.util.StringTokenizer (implements java.util.Enumeration<E>)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.util.ServiceConfigurationError
      • java.lang.异常
        • java.io.IOException
          • java.util.InvalidPropertiesFormatException
        • java.lang.RuntimeException
          • java.util.ConcurrentModificationException
          • java.util.EmptyStackException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.DuplicateFormatFlagsException
              • java.util.FormatFlagsConversionMismatchException
              • java.util.IllegalFormatCodePointException
              • java.util.IllegalFormatConversionException
              • java.util.IllegalFormatFlagsException
              • java.util.IllegalFormatPrecisionException
              • java.util.IllegalFormatWidthException
              • java.util.MissingFormatArgumentException
              • java.util.MissingFormatWidthException
              • java.util.UnknownFormatConversionException
              • java.util.UnknownFormatFlagsException
          • java.lang.IllegalStateException
            • java.util.FormatterClosedException
          • java.util.IllformedLocaleException
          • java.util.MissingResourceException
          • java.util.NoSuchElementException
            • java.util.InputMismatchException
        • java.util.TooManyListenersException
    • java.util.Timer
    • java.util.TimerTask (implements java.lang.Runnable)
    • java.util.TimeZone (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.SimpleTimeZone
    • java.util.UUID (implements java.lang.Comparable<T>, java.io.Serializable)

Interface Hierarchy

  • java.util.Comparator<T>
  • java.util.Enumeration<E>
  • java.util.EventListener
  • java.util.Formattable
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
      • java.util.Queue<E>
        • java.util.Deque<E>
      • java.util.Set<E>
        • java.util.SortedSet<E>
          • java.util.NavigableSet<E>
  • java.util.Iterator<E>
    • java.util.ListIterator<E>
    • java.util.PrimitiveIterator<T,T_CONS>
      • java.util.PrimitiveIterator.OfDouble
      • java.util.PrimitiveIterator.OfInt
      • java.util.PrimitiveIterator.OfLong
  • java.util.Map<K,V>
    • java.util.SortedMap<K,V>
      • java.util.NavigableMap<K,V>
  • java.util.Map.Entry<K,V>
  • java.util.Observer
  • java.util.RandomAccess
  • java.util.Spliterator<T>
    • java.util.Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>
      • java.util.Spliterator.OfDouble
      • java.util.Spliterator.OfInt
      • java.util.Spliterator.OfLong
  • java.util.function.Supplier<T>
    • java.util.ServiceLoader.Provider<S>

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.util.Formatter.BigDecimalLayoutForm
      • java.util.Locale.Category
      • java.util.Locale.FilteringMode
      • java.util.Locale.IsoCountryCode
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LinkedHashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class LinkedHashMap<K,V>

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.HashMap<K,V>
        • java.util.LinkedHashMap<K,V>
  • 参数类型
    K - 由此地图维护的键的类型
    V - 映射值的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Map<K,V>

    public class LinkedHashMap<K,V>
extends HashMap<K,V>
implements Map<K,V>

    哈希表和链表实现的Map接口，具有可预测的迭代顺序。 该实现与HashMap不同之处在于它保持双向链接列表的所有条目。 此链接列表定义迭代排序，通常是将键插入到地图（ 插入顺序 ）中的顺序 。 请注意，如果将键重新插入到地图中，则插入顺序不受影响。 （A键k被重新插入到地图m如果m.put(k, v)时被调用m.containsKey(k)将返回true之前立即调用。）

    此实施方式使其客户不受TreeMap （和Hashtable ）提供的未指定的，通常混乱的排序，而不会导致与TreeMap相关的成本增加。 无论原始地图的实现如何，它都可用于生成与原始地图相同顺序的地图副本：

      void foo(Map m) {
         Map copy = new LinkedHashMap(m);
         ...
     }
    如果模块在输入上进行映射，复制它，然后返回其顺序由该副本决定的结果，则此技术特别有用。 （客户一般都喜欢以相同的顺序返回事情。）

    提供了一个特殊的constructor ，用于创建一个链接的哈希映射，其迭代顺序是最后一次访问的条目的顺序，从最近最近被访问到最近的（ 访问顺序 ）。 这种地图非常适合建立LRU缓存。 调用put ， putIfAbsent ， get ， getOrDefault ， compute ， computeIfAbsent ， computeIfPresent ，或merge中的相应条目的接入方法的结果（假设调用完成后它存在）。 如果替换值，则replace方法仅导致条目的访问。 putAll方法按照指定地图的条目集迭代器提供的键值映射的顺序为指定地图中的每个映射生成一个条目访问。 没有其他方法生成条目访问。 特别地，对于集合视图的操作不会影响背景映射的迭代顺序。

    可以覆盖removeEldestEntry(Map.Entry)方法，以便在将新映射添加到地图时自动执行删除过时映射的策略。

    此类提供了所有可选的Map操作，并允许空元素。 像HashMap ，它提供了基本操作（稳定的性能add ， contains和remove ），假设散列函数散桶中适当的元件。 表现可能略低于HashMap ，由于维持链接列表的额外费用，除了一个例外：对LinkedHashMap的收集视图进行LinkedHashMap需要与地图大小成比例的时间，无论其容量如何。 HashMap迭代可能更昂贵，需要与其容量成比例的时间。

    链接的哈希映射有两个参数影响其性能： 初始容量和负载因子 。 它们的定义精确到HashMap 。 但是，请注意，对于这个类别HashMap ，选择过高的初始容量的价值不如HashMap那么严格，因为这个类的迭代次数不受容量的影响。

    请注意，此实现不同步。 如果多个线程同时访问链接的散列映射，并且至少一个线程在结构上修改映射，则必须在外部进行同步。 这通常通过在自然地封装地图的一些对象上同步来实现。 如果没有这样的对象存在，应该使用Collections.synchronizedMap方法“包装”地图。 这最好在创建时完成，以防止意外的不同步访问地图：

      Map m = Collections.synchronizedMap(new LinkedHashMap(...));
    结构修改是添加或删除一个或多个映射的任何操作，或者在访问有序链接的散列图的情况下，影响迭代顺序。 在插入有序的链接散列图中，仅改变与已经包含在地图中的键相关联的值不是结构修改。 在访问有序的链接散列图中，仅使用get查询地图是一种结构修改。 ）

    由所有这个类的集合视图方法返回的集合的iterator方法返回的迭代器是fail-fast ：如果映射在迭代器创建之后的任何时间被结构地修改，除了通过迭代器自己的remove方法之外，迭代器将抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的迭代器ConcurrentModificationException扔出ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    由这个类的所有集合视图方法返回的集合的spliterator方法返回的分配器是late-binding ， fail-fast ，另外报告Spliterator.ORDERED 。

    这个班是Java Collections Framework的会员。

    Implementation Note:
    由所有这个类的集合视图方法返回的集合的spliterator方法返回的spliterator是从相应集合的迭代器创建的。
    从以下版本开始：
    1.4
    另请参见：
    Object.hashCode() ， Collection ， Map ， HashMap ， TreeMap ， Hashtable ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinkedHashMap​()
      构造具有默认初始容量（16）和负载因子（0.75）的空插入 LinkedHashMap实例。
      LinkedHashMap​(int initialCapacity)
      构造具有指定初始容量和默认负载因子（0.75）的空插入订购的 LinkedHashMap实例。
      LinkedHashMap​(int initialCapacity, float loadFactor)
      构造具有指定的初始容量和负载因子的空插入订单的 LinkedHashMap实例。
      LinkedHashMap​(int initialCapacity, float loadFactor, boolean accessOrder)
      构造一个空的 LinkedHashMap实例，具有指定的初始容量，负载因子和排序模式。
      LinkedHashMap​(Map<? extends K,? extends V> m)
      构造具有与指定地图相同映射的插入式 LinkedHashMap实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      从这张地图中删除所有的映射。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。
      V getOrDefault​(Object key, V defaultValue)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      protected boolean removeEldestEntry​(Map.Entry<K,V> eldest)
      如果此地图应删除其最老的条目，则返回 true 。
      void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from class java.util.AbstractMap

        equals, hashCode, toString

      • Methods inherited from class java.util.HashMap

        clone, compute, computeIfAbsent, computeIfPresent, containsKey, isEmpty, merge, put, putAll, putIfAbsent, remove, remove, replace, replace, size

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, containsKey, entry, equals, hashCode, isEmpty, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, size

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LinkedHashMap

        public LinkedHashMap​(int initialCapacity,
                     float loadFactor)
        构造具有指定的初始容量和负载因子的空插入 LinkedHashMap实例。
        参数
        initialCapacity - 初始容量
        loadFactor - 负载系数
        异常
        IllegalArgumentException - 如果初始容量为负值或负载系数为正数

      • LinkedHashMap

        public LinkedHashMap​(int initialCapacity)
        构造具有指定初始容量和默认负载因子（0.75）的空插入订单 LinkedHashMap实例。
        参数
        initialCapacity - 初始容量
        异常
        IllegalArgumentException - 如果初始容量为负

      • LinkedHashMap

        public LinkedHashMap​()
        构造具有默认初始容量（16）和负载因子（0.75）的空插入订单 LinkedHashMap实例。

      • LinkedHashMap

        public LinkedHashMap​(Map<? extends K,? extends V> m)
        构造具有与指定地图相同映射的插入式LinkedHashMap实例。 创建LinkedHashMap实例的默认负载因子（0.75），初始容量足以容纳指定映射中的映射。
        参数
        m - 其映射将放置在此映射中的映射
        异常
        NullPointerException - 如果指定的地图为空

      • LinkedHashMap

        public LinkedHashMap​(int initialCapacity,
                     float loadFactor,
                     boolean accessOrder)
        构造一个空的 LinkedHashMap实例，具有指定的初始容量，负载因子和订购模式。
        参数
        initialCapacity - 初始容量
        loadFactor - 负载系数
        accessOrder - 订购模式 - true用于访问顺序， false用于插入顺序
        异常
        IllegalArgumentException - 如果初始容量为负值或负载系数为非正值

    • 方法详细信息

      • containsValue

        public boolean containsValue​(Object value)
        如果此映射将一个或多个键映射到指定的值，则返回 true 。
        Specified by:
        containsValue在接口 Map<K,V>
        重写：
        containsValue在 HashMap<K,V>
        参数
        value - 要在该地图中存在的值要测试的值
        结果
        true如果该地图将一个或多个键映射到指定的值

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含键的映射，则返回null 。

        更正式地，如果此映射包含从密钥映射k到值v使得(key==null ? k==null : key.equals(k)) ，则此方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        返回值为null并不一定表示该映射不包含该键的映射; 地图也可能明确地将密钥映射到null 。 可以使用containsKey操作来区分这两种情况。

        Specified by:
        get在接口 Map<K,V>
        重写：
        get在 HashMap<K,V>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含该键的映射， null
        另请参见：
        HashMap.put(Object, Object)

      • getOrDefault

        public V getOrDefault​(Object key,
                      V defaultValue)
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。
        Specified by:
        getOrDefault在接口 Map<K,V>
        重写：
        getOrDefault在 HashMap<K,V>
        参数
        key - 要返回其关联值的键
        defaultValue - 键的默认映射
        结果
        映射指定键的值，如果此映射不包含键的映射， defaultValue

      • clear

        public void clear​()
        从这张地图中删除所有的映射。 此呼叫返回后，地图将为空。
        Specified by:
        clear在接口 Map<K,V>
        重写：
        clear在 HashMap<K,V>

      • removeEldestEntry

        protected boolean removeEldestEntry​(Map.Entry<K,V> eldest)
        如果此地图应删除其最老的条目，则返回true 。 在将新条目插入到地图中后，此方法由put和putAll调用。 它为实施者提供每次添加新的条目时删除最老条目的机会。 如果地图表示缓存，则此功能非常有用：它可以通过删除失效条目来减少内存消耗。

        示例使用：此覆盖将允许地图长达100个条目，然后每次添加新条目时删除最老条目，保持100个条目的稳定状态。

          private static final int MAX_ENTRIES = 100;

     protected boolean removeEldestEntry(Map.Entry eldest) {
        return size() > MAX_ENTRIES;
     }

        该方法通常不会以任何方式修改地图，而是允许地图按其返回值的指示进行修改。 它被允许用于此方法来直接修改地图，但如果这样做的话，它必须返回false （指示地图不应试图任何进一步的修改）。 在此方法中修改地图后，返回true的效果未指定。

        这个实现只返回false （这样，这个地图就像一个普通的地图 - 最老的元素永远不会被删除）。

        参数
        eldest - 地图中最近插入的条目，或者如果这是访问顺序的地图，则是最近访问的条目。 这是将被删除的条目，此方法返回true 。 如果在引用此调用的put或putAll调用之前地图为空，则将是刚插入的条目; 换句话说，如果地图包含单个条目，则最长条目也是最新的条目。
        结果
        true如果最长的条目应该从地图中删除; false如果应该保留。

      • keySet

        public Set<K> keySet​()
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。 其Spliterator通常提供更快的顺序性能，但是比HashMap更差的并行性能。
        Specified by:
        keySet在接口 Map<K,V>
        重写：
        keySet在 HashMap<K,V>
        结果
        该地图中包含的键的集合视图

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。 其Spliterator通常提供更快的顺序性能，但是比HashMap更差的并行性能。
        Specified by:
        values在接口 Map<K,V>
        重写：
        values在 HashMap<K,V>
        结果
        该地图中包含的值的视图

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果映射被修改，而该集合中的迭代正在进行（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。 其Spliterator通常提供更快的顺序性能，但是比HashMap更差的并行性能。
        Specified by:
        entrySet在接口 Map<K,V>
        重写：
        entrySet在 HashMap<K,V>
        结果
        该地图中包含的映射的集合视图

      • forEach

        public void forEach​(BiConsumer<? super K,? super V> action)
        说明从接口Map复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach接口 Map<K,V>
        重写：
        forEach在 HashMap<K,V>
        参数
        action - 为每个条目执行的操作

      • replaceAll

        public void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        描述从接口Map复制
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll在接口 Map<K,V>
        重写：
        replaceAll在 HashMap<K,V>
        参数
        function - 应用于每个条目的功能
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LinkedHashSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class LinkedHashSet<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractSet<E>
        • java.util.HashSet<E>
          • java.util.LinkedHashSet<E>
  • 参数类型
    E - 由此集合维护的元素的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， Set<E>

    public class LinkedHashSet<E>
extends HashSet<E>
implements Set<E>, Cloneable, Serializable

    哈希表和链表实现的Set接口，具有可预测的迭代次序。 该实现与HashSet不同之处在于它保持双向链接列表的所有条目。 该链表定义了迭代排序，它是将元素插入集合（ 插入顺序 ） 的顺序 。 请注意，如果一个元件被重新插入到组插入顺序不受影响 。 （如果s.add(e)在调用之前s.contains(e)将立即返回true则e被重新插入到集合s ）。

    该实施方式使其客户不受HashSet提供的未指定的，通常混乱的排序，而不会导致与TreeSet相关的成本增加。 它可以用于生成与原始文件具有相同顺序的集合的副本，而不管原始集的实现：

      void foo(Set s) {
         Set copy = new LinkedHashSet(s);
         ...
     }
    如果模块在输入上进行设置，复制它，并且稍后返回其顺序由该副本确定的结果，则此技术特别有用。 （客户一般都喜欢以相同的顺序返回事情。）

    此类提供所有可选的Set操作，并允许空元素。 像HashSet ，它提供了基本操作（稳定的性能add ， contains和remove ），假设散列函数散桶中适当的元件。 性能可能略低于HashSet ，由于维护链表的额外费用，除了一个例外：迭代超过LinkedHashSet需要与集合的大小成比例的时间，无论其容量如何。 HashSet迭代可能更昂贵，需要与其容量成比例的时间。

    链接哈希集具有影响其性能的两个参数： 初始容量和负载因子 。 它们被精确定义为HashSet 。 但是，请注意，对于这个类别HashSet ，选择过高的初始容量值的惩罚不如HashSet那么严格，因为这个类的迭代次数不受容量的影响。

    请注意，此实现不同步。 如果多个线程同时访问链接的散列集，并且至少有一个线程修改该集合，那么它必须在外部进行同步。 这通常通过在自然地封装集合的一些对象上进行同步来实现。 如果没有这样的对象存在，那么该集合应该使用Collections.synchronizedSet方法“包装”。 这最好在创建时完成，以防止意外的非同步访问集：

      Set s = Collections.synchronizedSet(new LinkedHashSet(...));

    此类的iterator方法返回的迭代器是故障快速的 ：如果在迭代器创建后的任何时间对该集合进行了修改，除了通过迭代器自己的remove方法之外，迭代器将抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的迭代器ConcurrentModificationException扔出ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.4
    另请参见：
    Object.hashCode() ， Collection ， Set ， HashSet ， TreeSet ， Hashtable ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinkedHashSet​()
      构造一个具有默认初始容量（16）和负载因子（0.75）的新的，空的链接散列集。
      LinkedHashSet​(int initialCapacity)
      构造一个具有指定初始容量和默认负载因子（0.75）的新的，空的链接散列集。
      LinkedHashSet​(int initialCapacity, float loadFactor)
      构造具有指定的初始容量和负载因子的新的，空的链接散列集。
      LinkedHashSet​(Collection<? extends E> c)
      构造与指定集合相同的元素的新的链接散列集。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Spliterator<E> spliterator​()
      在此集合中的元素上创建 late-binding和 故障快速 Spliterator 。

      • Methods inherited from class java.util.AbstractCollection

        addAll, containsAll, retainAll, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractSet

        equals, hashCode, removeAll

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from class java.util.HashSet

        add, clear, clone, contains, isEmpty, iterator, remove, size

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, toArray, toArray

    • 构造方法详细信息

      • LinkedHashSet

        public LinkedHashSet​(int initialCapacity,
                     float loadFactor)
        构造具有指定的初始容量和负载因子的新的，空的链接散列集。
        参数
        initialCapacity - 链接散列集的初始容量
        loadFactor - 链接散列集的负载因子
        异常
        IllegalArgumentException - 如果初始容量小于零，或者负载因子是非正值的

      • LinkedHashSet

        public LinkedHashSet​(int initialCapacity)
        构造一个具有指定初始容量和默认负载因子（0.75）的新的，空的链接散列集。
        参数
        initialCapacity - LinkedHashSet的初始容量
        异常
        IllegalArgumentException - 如果初始容量小于零

      • LinkedHashSet

        public LinkedHashSet​()
        构造一个具有默认初始容量（16）和负载因子（0.75）的新的，空的链接散列集。

      • LinkedHashSet

        public LinkedHashSet​(Collection<? extends E> c)
        构造与指定集合相同的元素的新的链接散列集。 创建链接的哈希集合具有足以容纳指定集合中的元素的初始容量和默认负载因子（0.75）。
        参数
        c - c元素放入此集合的集合
        异常
        NullPointerException - 如果指定的集合为空

    • 方法详细信息

      • spliterator

        public Spliterator<E> spliterator​()
        在此集合中的元素上创建late-binding和故障快速 Spliterator 。

        该Spliterator报告Spliterator.SIZED ， Spliterator.DISTINCT ，并ORDERED 。 实施应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator接口 Iterable<E>
        Specified by:
        spliterator在接口 Set<E>
        重写：
        spliterator在 HashSet<E>
        Implementation Note:
        该实现从集合的Iterator创建了一个late-binding拼接Iterator 。 分割器继承集合迭代器的故障快速属性。 创建的Spliterator另外报告Spliterator.SUBSIZED 。
        结果
        一个 Spliterator在这个集合中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LinkedList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class LinkedList<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • java.util.AbstractSequentialList<E>
          • java.util.LinkedList<E>
  • 参数类型
    E - 此集合中保存的元素的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， Deque<E> ， List<E> ， Queue<E>

    public class LinkedList<E>
extends AbstractSequentialList<E>
implements List<E>, Deque<E>, Cloneable, Serializable
    双链表实现了List和Deque接口。 实现所有可选列表操作，并允许所有元素（包括null ）。

    所有的操作都能像双向列表一样预期。 索引到列表中的操作将从开始或结束遍历列表，以更接近指定的索引为准。

    请注意，此实现不同步。 如果多个线程同时访问链接列表，并且至少有一个线程在结构上修改列表，则必须在外部进行同步。 （结构修改是添加或删除一个或多个元素的任何操作;仅设置元素的值不是结构修改。）这通常通过在自然封装列表的对象上进行同步来实现。 如果没有这样的对象存在，列表应该使用Collections.synchronizedList方法“包装”。 这最好在创建时完成，以防止意外的不同步访问列表：

      List list = Collections.synchronizedList(new LinkedList(...));

    该类的iterator和listIterator方法返回的迭代器是故障快速的 ：如果列表在迭代器创建后的任何时间进行结构修改，除了通过Iterator自己的remove或add方法外，迭代器将抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的迭代器ConcurrentModificationException扔掉ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    List ， ArrayList ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinkedList​()
      构造一个空列表。
      LinkedList​(Collection<? extends E> c)
      构造一个包含指定集合的元素的列表，按照它们由集合的迭代器返回的顺序。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(int index, E element)
      在此列表中的指定位置插入指定的元素。
      boolean add​(E e)
      将指定的元素追加到此列表的末尾。
      boolean addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中，从指定的位置开始。
      boolean addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到此列表的末尾。
      void addFirst​(E e)
      在该列表开头插入指定的元素。
      void addLast​(E e)
      将指定的元素追加到此列表的末尾。
      void clear​()
      从列表中删除所有元素。
      Object clone​()
      返回此 LinkedList的浅拷贝。
      boolean contains​(Object o)
      如果此列表包含指定的元素，则返回 true 。
      Iterator<E> descendingIterator​()
      以相反的顺序返回此deque中的元素的迭代器。
      E element​()
      检索但不删除此列表的头（第一个元素）。
      E get​(int index)
      返回此列表中指定位置的元素。
      E getFirst​()
      返回此列表中的第一个元素。
      E getLast​()
      返回此列表中的最后一个元素。
      int indexOf​(Object o)
      返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。
      int lastIndexOf​(Object o)
      返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
      ListIterator<E> listIterator​(int index)
      从列表中的指定位置开始，返回此列表中元素的列表迭代器（按适当的顺序）。
      boolean offer​(E e)
      将指定的元素添加为此列表的尾部（最后一个元素）。
      boolean offerFirst​(E e)
      在此列表的前面插入指定的元素。
      boolean offerLast​(E e)
      在该列表的末尾插入指定的元素。
      E peek​()
      检索但不删除此列表的头（第一个元素）。
      E peekFirst​()
      检索但不删除此列表的第一个元素，如果此列表为空，则返回 null 。
      E peekLast​()
      检索但不删除此列表的最后一个元素，如果此列表为空，则返回 null 。
      E poll​()
      检索并删除此列表的头（第一个元素）。
      E pollFirst​()
      检索并删除此列表的第一个元素，如果此列表为空，则返回 null 。
      E pollLast​()
      检索并删除此列表的最后一个元素，如果此列表为空，则返回 null 。
      E pop​()
      从此列表表示的堆栈中弹出一个元素。
      void push​(E e)
      将元素推送到由此列表表示的堆栈上。
      E remove​()
      检索并删除此列表的头（第一个元素）。
      E remove​(int index)
      删除该列表中指定位置的元素。
      boolean remove​(Object o)
      从列表中删除指定元素的第一个出现（如果存在）。
      E removeFirst​()
      从此列表中删除并返回第一个元素。
      boolean removeFirstOccurrence​(Object o)
      删除此列表中指定元素的第一个出现（从头到尾遍历列表时）。
      E removeLast​()
      从此列表中删除并返回最后一个元素。
      boolean removeLastOccurrence​(Object o)
      删除此列表中指定元素的最后一次出现（从头到尾遍历列表时）。
      E set​(int index, E element)
      用指定的元素替换此列表中指定位置的元素。
      int size​()
      返回此列表中的元素数。
      Spliterator<E> spliterator​()
      在此列表中的元素上创建late-binding和故障快速 Spliterator 。
      Object[] toArray​()
      以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

      • Methods inherited from class java.util.AbstractCollection

        containsAll, isEmpty, removeAll, retainAll, toString

      • Methods inherited from class java.util.AbstractList

        equals, hashCode, listIterator, removeRange, subList

      • Methods inherited from class java.util.AbstractSequentialList

        iterator

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.util.Deque

        iterator

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        containsAll, equals, hashCode, isEmpty, iterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, removeAll, replaceAll, retainAll, sort, subList

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LinkedList

        public LinkedList​()
        构造一个空列表。

      • LinkedList

        public LinkedList​(Collection<? extends E> c)
        构造一个包含指定集合的元素的列表，按照它们由集合的迭代器返回的顺序。
        参数
        c - c元素放入此列表的集合
        异常
        NullPointerException - 如果指定的集合为空

    • 方法详细信息

      • getFirst

        public E getFirst​()
        返回此列表中的第一个元素。
        Specified by:
        getFirst在接口 Deque<E>
        结果
        这个列表中的第一个元素
        异常
        NoSuchElementException - 如果此列表为空

      • getLast

        public E getLast​()
        返回此列表中的最后一个元素。
        Specified by:
        getLast在接口 Deque<E>
        结果
        这个列表中的最后一个元素
        异常
        NoSuchElementException - 如果此列表为空

      • removeFirst

        public E removeFirst​()
        从此列表中删除并返回第一个元素。
        Specified by:
        removeFirst在接口 Deque<E>
        结果
        这个列表中的第一个元素
        异常
        NoSuchElementException - 如果此列表为空

      • removeLast

        public E removeLast​()
        从此列表中删除并返回最后一个元素。
        Specified by:
        removeLast在接口 Deque<E>
        结果
        这个列表中的最后一个元素
        异常
        NoSuchElementException - 如果此列表为空

      • addFirst

        public void addFirst​(E e)
        在该列表开头插入指定的元素。
        Specified by:
        addFirst在接口 Deque<E>
        参数
        e - 要添加的元素

      • addLast

        public void addLast​(E e)
        将指定的元素追加到此列表的末尾。

        此方法相当于add(E) 。

        Specified by:
        addLast在接口 Deque<E>
        参数
        e - 要添加的元素

      • contains

        public boolean contains​(Object o)
        如果此列表包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此列表包含至少一个元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Deque<E>
        Specified by:
        contains在接口 List<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要在此列表中存在的元素要进行测试
        结果
        true如果此列表包含指定的元素

      • size

        public int size​()
        返回此列表中的元素数。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Deque<E>
        Specified by:
        size在接口 List<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此列表中的元素数

      • add

        public boolean add​(E e)
        将指定的元素追加到此列表的末尾。

        这个方法相当于addLast(E) 。

        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Deque<E>
        Specified by:
        add在接口 List<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractList<E>
        参数
        e - 要附加到此列表的元素
        结果
        true （由 Collection.add(E)指定）

      • remove

        public boolean remove​(Object o)
        从列表中删除指定元素的第一个出现（如果存在）。 如果此列表不包含该元素，则它将保持不变。 更正式地，删除具有最低索引i的元素，使得Objects.equals(o, get(i)) （如果这样的元素存在）。 如果此列表包含指定的元素（或等效地，如果此列表作为调用的结果而更改），则返回true 。
        Specified by:
        remove接口 Collection<E>
        Specified by:
        remove在接口 Deque<E>
        Specified by:
        remove在接口 List<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此列表中删除的元素（如果存在）
        结果
        true如果此列表包含指定的元素

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到此列表的末尾。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （注意，如果指定的集合是此列表，并且它是非空的，则会发生这种情况。）
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 Deque<E>
        Specified by:
        addAll在接口 List<E>
        重写：
        addAll在 AbstractCollection<E>
        参数
        c - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        NullPointerException - 如果指定的集合为空
        另请参见：
        AbstractCollection.add(Object)

      • addAll

        public boolean addAll​(int index,
                      Collection<? extends E> c)
        将指定集合中的所有元素插入到此列表中，从指定的位置开始。 将当前位于该位置（如果有的话）的元素和随后的任何元素移动到右边（增加其索引）。 新元素将按照指定集合的迭代器返回的顺序显示在列表中。
        Specified by:
        addAll在接口 List<E>
        重写：
        addAll在 AbstractSequentialList<E>
        参数
        index - 从中指定集合插入第一个元素的索引
        c - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）
        NullPointerException - 如果指定的集合为空

      • clear

        public void clear​()
        从列表中删除所有元素。 此呼叫返回后，列表将为空。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 List<E>
        重写：
        clear在 AbstractList<E>

      • get

        public E get​(int index)
        返回此列表中指定位置的元素。
        Specified by:
        get在接口 List<E>
        重写：
        get在 AbstractSequentialList<E>
        参数
        index - 要返回的元素的索引
        结果
        该列表中指定位置的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • set

        public E set​(int index,
             E element)
        用指定的元素替换此列表中指定位置的元素。
        Specified by:
        set在接口 List<E>
        重写：
        set在 AbstractSequentialList<E>
        参数
        index - 要替换的元素的索引
        element - 要存储在指定位置的元素
        结果
        该元素以前在指定的位置
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • add

        public void add​(int index,
                E element)
        在此列表中的指定位置插入指定的元素。 将当前位于该位置的元素（如果有）和任何后续元素（向其索引添加一个）移动。
        Specified by:
        add在接口 List<E>
        重写：
        add在 AbstractSequentialList<E>
        参数
        index - 要在其中插入指定元素的索引
        element - 要插入的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • remove

        public E remove​(int index)
        删除该列表中指定位置的元素。 将任何后续元素移动到左侧（从其索引中减去一个元素）。 返回从列表中删除的元素。
        Specified by:
        remove在接口 List<E>
        重写：
        remove在 AbstractSequentialList<E>
        参数
        index - 要删除的元素的索引
        结果
        该元素以前在指定的位置
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • indexOf

        public int indexOf​(Object o)
        返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地，返回最低指数i ，使得Objects.equals(o, get(i)) ，或-1如果没有这样的索引。
        Specified by:
        indexOf在接口 List<E>
        重写：
        indexOf在 AbstractList<E>
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的首次出现的索引，如果此列表不包含元素，则为-1

      • lastIndexOf

        public int lastIndexOf​(Object o)
        返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地说，返回满足i这样Objects.equals(o, get(i)) ，或-1，如果没有这样的指标。
        Specified by:
        lastIndexOf在接口 List<E>
        重写：
        lastIndexOf在 AbstractList<E>
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则为-1

      • peek

        public E peek​()
        检索但不删除此列表的头（第一个元素）。
        Specified by:
        peek在接口 Deque<E>
        Specified by:
        peek在接口 Queue<E>
        结果
        该列表的头，或 null如果此列表为空
        从以下版本开始：
        1.5

      • element

        public E element​()
        检索但不删除此列表的头（第一个元素）。
        Specified by:
        element在接口 Deque<E>
        Specified by:
        element在接口 Queue<E>
        结果
        这个名单的头
        异常
        NoSuchElementException - 如果此列表为空
        从以下版本开始：
        1.5

      • poll

        public E poll​()
        检索并删除此列表的头（第一个元素）。
        Specified by:
        poll在接口 Deque<E>
        Specified by:
        poll在接口 Queue<E>
        结果
        该列表的头，或 null如果此列表为空
        从以下版本开始：
        1.5

      • remove

        public E remove​()
        检索并删除此列表的头（第一个元素）。
        Specified by:
        remove在接口 Deque<E>
        Specified by:
        remove在接口 Queue<E>
        结果
        这个名单的头
        异常
        NoSuchElementException - 如果此列表为空
        从以下版本开始：
        1.5

      • offer

        public boolean offer​(E e)
        将指定的元素添加为此列表的尾部（最后一个元素）。
        Specified by:
        offer在接口 Deque<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Queue.offer(E)指定）
        从以下版本开始：
        1.5

      • offerFirst

        public boolean offerFirst​(E e)
        在此列表的前面插入指定的元素。
        Specified by:
        offerFirst在接口 Deque<E>
        参数
        e - 要插入的元素
        结果
        true （由 Deque.offerFirst(E)指定）
        从以下版本开始：
        1.6

      • offerLast

        public boolean offerLast​(E e)
        在该列表的末尾插入指定的元素。
        Specified by:
        offerLast在接口 Deque<E>
        参数
        e - 要插入的元素
        结果
        true （由 Deque.offerLast(E)指定）
        从以下版本开始：
        1.6

      • peekFirst

        public E peekFirst​()
        检索但不删除此列表的第一个元素，如果此列表为空，则返回 null 。
        Specified by:
        peekFirst在接口 Deque<E>
        结果
        该列表的第一个元素，如果此列表为空， null
        从以下版本开始：
        1.6

      • peekLast

        public E peekLast​()
        检索但不删除此列表的最后一个元素，如果此列表为空，则返回 null 。
        Specified by:
        peekLast在接口 Deque<E>
        结果
        该列表的最后一个元素，如果此列表为空， null
        从以下版本开始：
        1.6

      • pollFirst

        public E pollFirst​()
        检索并删除此列表的第一个元素，如果此列表为空，则返回 null 。
        Specified by:
        pollFirst在接口 Deque<E>
        结果
        该列表的第一个元素，如果此列表为空， null
        从以下版本开始：
        1.6

      • pollLast

        public E pollLast​()
        检索并删除此列表的最后一个元素，如果此列表为空，则返回 null 。
        Specified by:
        pollLast在接口 Deque<E>
        结果
        该列表的最后一个元素，如果此列表为空， null
        从以下版本开始：
        1.6

      • push

        public void push​(E e)
        将元素推送到由此列表表示的堆栈上。 换句话说，在该列表的前面插入元素。

        此方法相当于addFirst(E) 。

        Specified by:
        push在接口 Deque<E>
        参数
        e - 要推的元素
        从以下版本开始：
        1.6

      • pop

        public E pop​()
        从此列表表示的堆栈中弹出一个元素。 换句话说，删除并返回此列表的第一个元素。

        此方法相当于removeFirst() 。

        Specified by:
        pop在接口 Deque<E>
        结果
        该列表前面的元素（由此列表表示的堆栈的顶部）
        异常
        NoSuchElementException - 如果此列表为空
        从以下版本开始：
        1.6

      • removeFirstOccurrence

        public boolean removeFirstOccurrence​(Object o)
        删除此列表中指定元素的第一个出现（从头到尾遍历列表时）。 如果列表不包含该元素，则它不会更改。
        Specified by:
        removeFirstOccurrence在接口 Deque<E>
        参数
        o - 要从此列表中删除的元素（如果存在）
        结果
        true如果列表包含指定的元素
        从以下版本开始：
        1.6

      • removeLastOccurrence

        public boolean removeLastOccurrence​(Object o)
        删除此列表中指定元素的最后一次出现（从头到尾遍历列表时）。 如果列表不包含该元素，则它不会更改。
        Specified by:
        removeLastOccurrence在接口 Deque<E>
        参数
        o - 要从此列表中删除的元素（如果存在）
        结果
        true如果列表包含指定的元素
        从以下版本开始：
        1.6

      • listIterator

        public ListIterator<E> listIterator​(int index)
        从列表中的指定位置开始，返回此列表中元素的列表迭代器（按适当的顺序）。 遵守List.listIterator(int)的总体合同。

        该列表迭代器是快速失败的 ：如果列表在任何时间从结构上修改创建的Iterator后，以任何方式除非通过列表迭代器自身remove或者add方法，列表迭代器将抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

        Specified by:
        listIterator在接口 List<E>
        Specified by:
        listIterator在 AbstractSequentialList<E>
        参数
        index - 要从list-iterator返回的第一个元素的索引（通过调用 next ）
        结果
        一个ListIterator的列表中的元素（按顺序），从列表中的指定位置开始
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）
        另请参见：
        List.listIterator(int)

      • descendingIterator

        public Iterator<E> descendingIterator​()
        描述从接口Deque复制
        以相反的顺序返回此deque中的元素的迭代器。 元素将从最后（尾）到第一（头）的顺序返回。
        Specified by:
        descendingIterator在接口 Deque<E>
        结果
        在这个deque中的元素的反向迭代器
        从以下版本开始：
        1.6

      • clone

        public Object clone​()
        返回此LinkedList的浅拷贝。 （元素本身不被克隆。）
        重写：
        clone在 Object
        结果
        这个 LinkedList一个浅拷贝的例子
        另请参见：
        Cloneable

      • toArray

        public Object[] toArray​()
        以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

        返回的数组将是“安全的”，因为该列表不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray接口 List<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含该列表中所有元素的数组的数组
        另请参见：
        Arrays.asList(Object[])

      • toArray

        public <T> T[] toArray​(T[] a)
        以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。 如果列表适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此列表的大小分配一个新数组。

        如果列表适用于指定的数组，并有空余余地（即数组的列表null更多），则紧跟在列表末尾的数组中的元素设置为null 。 （这仅在调用者知道列表不包含任何空元素的情况下才能确定列表的长度。）

        像toArray()方法一样，此方法充当基于阵列和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的列表。 以下代码可用于将列表转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 List<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储列表的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含列表元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此列表中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • spliterator

        public Spliterator<E> spliterator​()
        在此列表中的元素上创建late-binding和故障快速 Spliterator 。

        Spliterator报告Spliterator.SIZED和Spliterator.ORDERED 。 覆盖实现应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Specified by:
        spliterator在接口 List<E>
        Implementation Note:
        Spliterator另外报告 Spliterator.SUBSIZED并实施 trySplit以允许有限的并行性。
        结果
        一个 Spliterator在这个列表中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


List (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface List<E>

  • 参数类型
    E - 此列表中元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E>
    All Known Subinterfaces:
    ObservableList<E> ， ObservableListValue<E> ， WritableListValue<E>
    所有已知实现类：
    AbstractList ， AbstractSequentialList ， ArrayList ， AttributeList ， CopyOnWriteArrayList ， FilteredList ， LinkedList ， ListBinding ， ListExpression ， ListProperty ， ListPropertyBase ， ModifiableObservableListBase ， ObservableListBase ， ReadOnlyListProperty ， ReadOnlyListPropertyBase ， ReadOnlyListWrapper ， RoleList ， RoleUnresolvedList ， SimpleListProperty ， SortedList ， Stack ， TransformationList ， Vector

    public interface List<E>
extends Collection<E>
    有序集合（也称为序列 ）。 该界面的用户可以精确控制列表中每个元素的插入位置。 用户可以通过整数索引（列表中的位置）访问元素，并搜索列表中的元素。

    与集合不同，列表通常允许重复的元素。 更正式地，列表通常允许成对的元素e1和e2 ，使得e1.equals(e2) ，并且如果它们允许空元素，它们通常允许多个空元素。 有人可能希望实现一个禁止重复的列表，当用户尝试插入时会抛出运行时异常，但是我们预计这种使用是罕见的。

    该List接口放置额外的约定，超过指定Collection界面上的合同iterator ， add ， remove ， equals ，并hashCode方法。 其他继承方法的声明也包括在这里以方便。

    List接口提供四种位置（索引）访问列表元素的方法。 列表（如Java数组）为零。 请注意，这些操作可能与某些实现的索引值（例如LinkedList类）成时执行。 因此，如果调用者不知道实现，则通过迭代列表中的元素通常优先于索引。

    List接口提供了一个特殊的迭代器，称为ListIterator ，允许元素插入和替换，以及双向访问以及Iterator接口提供的常规操作。 提供了一种方法来获取从列表中的指定位置开始的列表迭代器。

    List接口提供了两种搜索指定对象的方法。 从性能角度来说，谨慎使用这些方法。 在许多实现中，它们将执行昂贵的线性搜索。

    List接口提供了两种方法来有效地插入和删除列表中任意一点上的多个元素。

    注意：虽然列表允许将其自身作为元素，但建议您非常小心： equals和hashCode方法在这样的列表中不再被很好的定义。

    某些列表实现对它们可能包含的元素有限制。 例如，一些实现禁止空元素，有些实现对元素的类型有限制。 尝试添加不合格元素会引发未经检查的异常，通常为NullPointerException或ClassCastException 。 尝试查询不合格元素的存在可能会引发异常，或者可能只是返回false; 一些实现将展现出前者的行为，一些实现将展现出后者。 更一般来说，对于不完成不会导致将不合格元素插入到列表中的不合格元素的操作，可能会在执行选项时抛出异常或成功。 此异常在此接口的规范中标记为“可选”。

    Immutable List Static Factory Methods

    List.of()静态工厂方法提供了一种创建不可变列表的方便方法。 由这些方法创建的List实例具有以下特征：

    • 它们在结构上是不可变的 。 元素无法添加，删除或替换。 调用任何mutator方法将总是导致UnsupportedOperationException被抛出。 但是，如果包含的元素本身是可变的，则可能会导致列表的内容出现更改。
    • 他们不允许null元素。 尝试使用null元素创建它们将导致NullPointerException 。
    • 如果所有元素是可序列化的，它们是可序列化的。
    • 列表中的元素的顺序与提供的参数或提供的数组中的元素的顺序相同。
    • 他们是value-based 。 调用者不应该对返回的实例的身份进行假设。 工厂可以自由创建新的实例或重用现有的实例。 因此，对这些实例的身份敏感操作（引用等式（ == ），身份哈希码和同步）是不可靠的，应该避免。
    • 它们按Serialized Form页面的规定进行序列化。

    此界面是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， Set ， ArrayList ， LinkedList ， Vector ， Arrays.asList(Object[]) ， Collections.nCopies(int, Object) ， Collections.EMPTY_LIST ， AbstractList ， AbstractSequentialList

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void add​(int index, E element)
      将指定的元素插入此列表中的指定位置（可选操作）。
      boolean add​(E e)
      将指定的元素追加到此列表的末尾（可选操作）。
      boolean addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
      boolean addAll​(Collection<? extends E> c)
      按指定集合的迭代器（可选操作）返回的顺序将指定集合中的所有元素附加到此列表的末尾。
      void clear​()
      从此列表中删除所有元素（可选操作）。
      boolean contains​(Object o)
      如果此列表包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> c)
      如果此列表包含指定集合的所有元素，则返回 true 。
      boolean equals​(Object o)
      将指定的对象与此列表进行比较以获得相等性。
      E get​(int index)
      返回此列表中指定位置的元素。
      int hashCode​()
      返回此列表的哈希码值。
      int indexOf​(Object o)
      返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。
      boolean isEmpty​()
      如果此列表不包含元素，则返回 true 。
      Iterator<E> iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      int lastIndexOf​(Object o)
      返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
      ListIterator<E> listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
      static <E> List<E> of​()
      返回包含零个元素的不可变列表。
      static <E> List<E> of​(E e1)
      返回一个包含一个元素的不可变列表。
      static <E> List<E> of​(E... elements)
      返回包含任意数量元素的不可变列表。
      static <E> List<E> of​(E e1, E e2)
      返回一个包含两个元素的不可变列表。
      static <E> List<E> of​(E e1, E e2, E e3)
      返回一个包含三个元素的不可变列表。
      static <E> List<E> of​(E e1, E e2, E e3, E e4)
      返回一个包含四个元素的不可变列表。
      static <E> List<E> of​(E e1, E e2, E e3, E e4, E e5)
      返回包含五个元素的不可变列表。
      static <E> List<E> of​(E e1, E e2, E e3, E e4, E e5, E e6)
      返回包含六个元素的不可变列表。
      static <E> List<E> of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7)
      返回包含七个元素的不可变列表。
      static <E> List<E> of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8)
      返回包含八个元素的不可变列表。
      static <E> List<E> of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8, E e9)
      返回包含九个元素的不可变列表。
      static <E> List<E> of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8, E e9, E e10)
      返回一个包含十个元素的不可变列表。
      E remove​(int index)
      删除该列表中指定位置的元素（可选操作）。
      boolean remove​(Object o)
      从列表中删除指定元素的第一个出现（如果存在）（可选操作）。
      boolean removeAll​(Collection<?> c)
      从此列表中删除包含在指定集合中的所有元素（可选操作）。
      default void replaceAll​(UnaryOperator<E> operator)
      将该列表的每个元素替换为将该运算符应用于该元素的结果。
      boolean retainAll​(Collection<?> c)
      仅保留此列表中包含在指定集合中的元素（可选操作）。
      E set​(int index, E element)
      用指定的元素（可选操作）替换此列表中指定位置的元素。
      int size​()
      返回此列表中的元素数。
      default void sort​(Comparator<? super E> c)
      根据指定的Comparator引发的顺序排列此列表。
      default Spliterator<E> spliterator​()
      在此列表中的元素上创建一个Spliterator 。
      List<E> subList​(int fromIndex, int toIndex)
      返回指定的 fromIndex （含）和 toIndex之间的列表部分的视图。
      Object[] toArray​()
      以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

    • 方法详细信息

      • size

        int size​()
        返回此列表中的元素数。 如果此列表包含Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<E>
        结果
        此列表中的元素数

      • isEmpty

        boolean isEmpty​()
        如果此列表不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        结果
        true如果此列表不包含元素

      • contains

        boolean contains​(Object o)
        如果此列表包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此列表包含至少一个元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        参数
        o - 要在此列表中存在的元素要测试的元素
        结果
        true如果此列表包含指定的元素
        异常
        ClassCastException - 如果指定元素的类型与此列表不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且该列表不允许空元素（ optional ）

      • iterator

        Iterator<E> iterator​()
        以正确的顺序返回该列表中的元素的迭代器。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        结果
        在这个列表中的元素以适当的顺序迭代

      • toArray

        Object[] toArray​()
        以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

        返回的数组将是“安全的”，因为该列表不保留对它的引用。 （换句话说，即使这个列表被数组支持，这个方法也必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        结果
        一个包含该列表中所有元素的数组的数组
        另请参见：
        Arrays.asList(Object[])

      • toArray

        <T> T[] toArray​(T[] a)
        以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。 如果列表适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此列表的大小分配一个新数组。

        如果列表适用于指定的数组， null空间（即，该数组的列表数量更多），则紧接在列表末尾的数组中的元素将设置为null 。 （这仅在调用者知道列表不包含任何空元素的情况下才能确定列表的长度。）

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的列表。 以下代码可用于将列表转储到新分配的String数组中：

           String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储此列表的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此列表元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此列表中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • add

        boolean add​(E e)
        将指定的元素追加到此列表的末尾（可选操作）。

        支持此操作的列表可能会限制可能添加到此列表中的元素。 特别地，一些列表将拒绝添加null元素，而其他列表将对可能添加的元素的类型施加限制。 列表类应在其文档中明确指定可能添加哪些元素的限制。

        Specified by:
        add在接口 Collection<E>
        参数
        e - 要附加到此列表的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        UnsupportedOperationException - 如果此列表不支持 add操作
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的元素为空，并且该列表不允许空元素
        IllegalArgumentException - 如果此元素的某些属性阻止将其添加到此列表

      • remove

        boolean remove​(Object o)
        从列表中删除指定元素的第一个出现（如果存在）（可选操作）。 如果此列表不包含该元素，则它将保持不变。 更正式地，删除具有最低索引i的元素，使得Objects.equals(o, get(i)) （如果这样的元素存在）。 如果此列表包含指定的元素（或等效地，如果此列表作为调用的结果而更改），则返回true 。
        Specified by:
        remove在接口 Collection<E>
        参数
        o - 要从此列表中删除的元素（如果存在）
        结果
        true如果此列表包含指定的元素
        异常
        ClassCastException - 如果指定元素的类型与此列表不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，此列表不允许空元素（ optional ）
        UnsupportedOperationException - 如果此列表不支持 remove操作

      • containsAll

        boolean containsAll​(Collection<?> c)
        如果此列表包含指定集合的所有元素，则返回 true 。
        Specified by:
        containsAll在接口 Collection<E>
        参数
        c - 要在此列表中检查遏制的集合
        结果
        true如果此列表包含指定集合的所有元素
        异常
        ClassCastException - 如果指定集合中的一个或多个元素的类型与此列表不兼容（ optional ）
        NullPointerException - 如果指定的集合包含一个或多个空元素，并且该列表不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        contains(Object)

      • addAll

        boolean addAll​(Collection<? extends E> c)
        按指定集合的迭代器（可选操作）返回的顺序将指定集合中的所有元素附加到此列表的末尾。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （注意，如果指定的集合是此列表，并且它是非空的，则会发生这种情况。）
        Specified by:
        addAll在接口 Collection<E>
        参数
        c - 包含要添加到此列表中的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        UnsupportedOperationException - 如果此列表不支持 addAll操作
        ClassCastException - 如果指定集合的元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的集合包含一个或多个空元素，并且此列表不允许空元素，或者如果指定的集合为空
        IllegalArgumentException - 如果指定集合的元素的某些属性阻止其添加到此列表中
        另请参见：
        add(Object)

      • addAll

        boolean addAll​(int index,
               Collection<? extends E> c)
        将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。 将当前位于该位置（如果有的话）的元素和随后的任何元素移动到右边（增加其索引）。 新元素将按照指定集合的迭代器返回的顺序显示在此列表中。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （注意，如果指定的集合是此列表，并且它是非空的，则会发生这种情况。）
        参数
        index - 从中指定集合插入第一个元素的索引
        c - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        UnsupportedOperationException - 如果此列表不支持 addAll操作
        ClassCastException - 如果指定集合的元素的类阻止将其添加到此列表
        NullPointerException - 如果指定的集合包含一个或多个空元素，并且该列表不允许空元素，或者如果指定的集合为空
        IllegalArgumentException - 如果指定集合的元素的某些属性阻止将其添加到此列表
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • removeAll

        boolean removeAll​(Collection<?> c)
        从此列表中删除包含在指定集合中的所有元素（可选操作）。
        Specified by:
        removeAll在接口 Collection<E>
        参数
        c - 包含要从此列表中删除的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        UnsupportedOperationException - 如果此列表不支持 removeAll操作
        ClassCastException - 如果此列表的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此列表包含空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object) ， contains(Object)

      • retainAll

        boolean retainAll​(Collection<?> c)
        仅保留此列表中包含在指定集合中的元素（可选操作）。 换句话说，从此列表中删除其中不包含在指定集合中的所有元素。
        Specified by:
        retainAll在接口 Collection<E>
        参数
        c - 包含要保留在此列表中的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        UnsupportedOperationException - 如果此列表不支持 retainAll操作
        ClassCastException - 如果此列表的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此列表包含空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object) ， contains(Object)

      • replaceAll

        default void replaceAll​(UnaryOperator<E> operator)
        将该列表的每个元素替换为将该运算符应用于该元素的结果。 运营商抛出的错误或运行时异常被转发给呼叫者。
        实现要求：
        默认实现相当于，对于这个list ：
           final ListIterator<E> li = list.listIterator(); while (li.hasNext()) { li.set(operator.apply(li.next())); }
        如果列表的list-iterator不支持set操作，则在替换第一个元素时将抛出UnsupportedOperationException 。
        参数
        operator - 运算符应用于每个元素
        异常
        UnsupportedOperationException - 如果此列表不可修改。 如果不能替换元素，或者一般来说，修改不被支持，则实现可能会抛出此异常
        NullPointerException - 如果指定的运算符为空，或者运算符结果为空值，并且该列表不允许空元素（ optional ）
        从以下版本开始：
        1.8

      • sort

        default void sort​(Comparator<? super E> c)
        根据指定的Comparator引发的顺序排列此列表。

        此列表中的所有元素必须使用指定的比较器相互比较（即， c.compare(e1, e2)不能为ClassCastException中的任何元素e1和e2 ）。

        如果指定的比较器是null则该列表中的所有元素都必须实现Comparable接口，并且应使用元素' natural ordering '。

        该列表必须是可修改的，但不能调整大小。

        实现要求：
        默认实现获取包含此列表中所有元素的数组，对数组进行排序，然后迭代该列表，从数组中的相应位置重新设置每个元素。 （这样可以避免尝试对现有的链表进行排序而导致的n 2 log（n）性能。）
        Implementation Note:
        这个实现是一个稳定的，自适应的，迭代的mergeesort，当输入数组被部分排序时，它需要比n lg（n）比较少的比较，同时在输入数组被随机排列时提供传统的mergeesort的性能。 如果输入数组几乎被排序，则实现需要大致n个比较。 临时存储要求从几乎排序的输入数组的小常数到随机排序的输入数组的n / 2对象引用。

        该实现在其输入数组中具有上升和下降的同等优势，并且可以在同一输入数组的不同部分中利用升序和降序。 它非常适合合并两个或多个排序的数组：简单地连接数组并排序生成的数组。

        该实现是从Tim Peters的Python列表中进行了改编的（ TimSort ）。 它使用Peter McIlroy的“乐观排序和信息理论复杂性”中的技术，在第四届ACM-SIAM离散算法研讨会论文集，pp 467-474，1993年1月。

        参数
        c - 用于比较列表元素的Comparator 。 A null值表示应使用元素' natural ordering '
        异常
        ClassCastException - 如果列表包含使用指定的比较器不 相互比较的元素
        UnsupportedOperationException - 如果列表的list-iterator不支持 set操作
        IllegalArgumentException - （ optional ）如果比较方发现违反Comparator合同
        从以下版本开始：
        1.8

      • clear

        void clear​()
        从此列表中删除所有元素（可选操作）。 此呼叫返回后，列表将为空。
        Specified by:
        clear在接口 Collection<E>
        异常
        UnsupportedOperationException - 如果此列表不支持 clear操作

      • equals

        boolean equals​(Object o)
        将指定的对象与此列表进行比较以获得相等性。 返回true当且仅当指定的对象也是列表时，两个列表具有相同的大小，并且两个列表中所有相应的元素对相等 。 （两个元件e1和e2是如果等于 Objects.equals(e1, e2) 。）换句话说，两个列表被定义为等于如果它们包含以相同的顺序相同的元件。 此定义可确保equals方法在List接口的不同实现中正常工作。
        Specified by:
        equals在接口 Collection<E>
        重写：
        equals在 Object
        参数
        o - 要与此列表相等的对象进行比较
        结果
        true如果指定的对象等于此列表
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此列表的哈希码值。 列表的哈希码被定义为以下计算的结果：
           int hashCode = 1; for (E e : list) hashCode = 31*hashCode + (e==null ? 0 : e.hashCode());
        这确保list1.equals(list2)意味着list1.hashCode()==list2.hashCode()对于任何两个列表， list1和list2 ，根据list2的一般合同要求 。
        Specified by:
        hashCode在接口 Collection<E>
        重写：
        hashCode在 Object
        结果
        该列表的哈希码值
        另请参见：
        Object.equals(Object) ， equals(Object)

      • get

        E get​(int index)
        返回此列表中指定位置的元素。
        参数
        index - 要返回的元素的索引
        结果
        该列表中指定位置的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • set

        E set​(int index,
      E element)
        用指定的元素（可选操作）替换此列表中指定位置的元素。
        参数
        index - 要替换的元素的索引
        element - 要存储在指定位置的元素
        结果
        该元素以前在指定的位置
        异常
        UnsupportedOperationException - 如果此列表不支持 set操作
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的元素为空，并且该列表不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此列表中
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • add

        void add​(int index,
         E element)
        将指定的元素插入此列表中的指定位置（可选操作）。 将当前位于该位置的元素（如果有）和任何后续元素（向其索引添加一个）移动。
        参数
        index - 要在其中插入指定元素的索引
        element - 要插入的元素
        异常
        UnsupportedOperationException - 如果此列表不支持 add操作
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        NullPointerException - 如果指定的元素为空，并且该列表不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此列表中
        IndexOutOfBoundsException - 如果指数超出范围（ index < 0 || index > size() ）

      • remove

        E remove​(int index)
        删除该列表中指定位置的元素（可选操作）。 将任何后续元素移动到左侧（从其索引中减去一个元素）。 返回从列表中删除的元素。
        参数
        index - 要删除的元素的索引
        结果
        该元素以前在指定的位置
        异常
        UnsupportedOperationException - 如果此列表不支持 remove操作
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • indexOf

        int indexOf​(Object o)
        返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地说，返回指数最低i这样Objects.equals(o, get(i)) ，或-1，如果没有这样的指标。
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的首次出现的索引，如果此列表不包含元素，则为-1
        异常
        ClassCastException - 如果指定元素的类型与此列表不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且此列表不允许空元素（ optional ）

      • lastIndexOf

        int lastIndexOf​(Object o)
        返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地，返回最高指数i如Objects.equals(o, get(i)) ，或-1如果没有这样的指数。
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则为-1
        异常
        ClassCastException - 如果指定元素的类型与此列表不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且此列表不允许空元素（ optional ）

      • listIterator

        ListIterator<E> listIterator​()
        返回列表中的列表迭代器（按适当的顺序）。
        结果
        在列表中的元素的列表迭代器（按适当的顺序）

      • listIterator

        ListIterator<E> listIterator​(int index)
        从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。 指定的索引指示由初始调用next返回的第一个元素。 对previous的初始调用将返回指定索引减去1的元素。
        参数
        index - 要从列表迭代器返回的第一个元素的索引（通过调用 next ）
        结果
        在列表中的元素（按正确顺序）的列表迭代器，从列表中的指定位置开始
        异常
        IndexOutOfBoundsException - 如果指数超出范围（ index < 0 || index > size() ）

      • subList

        List<E> subList​(int fromIndex,
                int toIndex)
        返回指定的fromIndex （含）和toIndex之间的列表部分的视图。 （如果fromIndex和toIndex相等，则返回的列表为空。）返回的列表由此列表支持，因此返回列表中的非结构性更改将反映在此列表中，反之亦然。 返回的列表支持此列表支持的所有可选列表操作。

        该方法消除了对显式范围操作（对于数组通常存在的排序）的需要。 任何期望列表的操作都可以通过传递一个子列表视图而不是整个列表来用作范围操作。 例如，以下成语从列表中移除了一系列元素：

           list.subList(from, to).clear();
        可以为indexOf和lastIndexOf构造类似的成语，并且可以将Collections类中的所有算法应用于子列表。

        如果支持列表（即，此列表）以除了通过返回的列表之外的任何方式进行结构修改 ，则此方法返回的列表的语义将变为未定义。 （结构修改是那些改变此列表的大小，或以其他方式扰乱它，使得正在进行的迭代可能产生不正确的结果）。

        参数
        fromIndex - 子列表的低端点（含）
        toIndex - 子列表的高端点（独占）
        结果
        该列表中指定范围的视图
        异常
        IndexOutOfBoundsException - 对于非法端点索引值（ fromIndex < 0 || toIndex > size || fromIndex > toIndex ）

      • spliterator

        default Spliterator<E> spliterator​()
        在此列表中的元素上创建一个Spliterator 。

        Spliterator报告Spliterator.SIZED和Spliterator.ORDERED 。 实施应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        实现要求：
        默认实现创建一个late-binding分配器，如下所示：
        • 如果列表是RandomAccess的实例，则默认实现将通过调用方法get(int)创建一个遍历元素的分割器 。 如果这样的调用结果或者会导致一个IndexOutOfBoundsException那么拼接器将会快速失败并抛出一个ConcurrentModificationException 。 如果列表也是AbstractList的一个实例，那么分割器将使用列表的modCount字段提供额外的故障快速行为。
        • 否则，默认实现从列表的Iterator创建一个拼接Iterator 。 分割器继承列表迭代器的故障快速 。
        Implementation Note:
        创建的 Spliterator另外报告 Spliterator.SUBSIZED 。
        结果
        一个 Spliterator在这个列表中的元素
        从以下版本开始：
        1.8

      • of

        static <E> List<E> of​()
        返回包含零个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        结果
        一个空的 List
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1)
        返回一个包含一个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 单一元素
        结果
        一个 List包含指定的元素
        异常
        NullPointerException - 如果元素是 null
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1,
                      E e2)
        返回一个包含两个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        结果
        一个包含指定元素的 List
        异常
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1,
                      E e2,
                      E e3)
        返回一个包含三个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        结果
        一个 List包含指定的元素
        异常
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1,
                      E e2,
                      E e3,
                      E e4)
        返回一个包含四个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        结果
        一个包含指定元素的 List
        异常
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1,
                      E e2,
                      E e3,
                      E e4,
                      E e5)
        返回包含五个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        结果
        一个包含指定元素的 List
        异常
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1,
                      E e2,
                      E e3,
                      E e4,
                      E e5,
                      E e6)
        返回包含六个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        结果
        一个 List包含指定的元素
        异常
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1,
                      E e2,
                      E e3,
                      E e4,
                      E e5,
                      E e6,
                      E e7)
        返回包含七个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        e7 - 第七个元素
        结果
        一个包含指定元素的 List
        异常
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1,
                      E e2,
                      E e3,
                      E e4,
                      E e5,
                      E e6,
                      E e7,
                      E e8)
        返回包含八个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        e7 - 第七个元素
        e8 - 第八个元素
        结果
        一个 List包含指定的元素
        异常
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1,
                      E e2,
                      E e3,
                      E e4,
                      E e5,
                      E e6,
                      E e7,
                      E e8,
                      E e9)
        返回包含九个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        e7 - 第七个要素
        e8 - 第八个元素
        e9 - 第九个元素
        结果
        一个 List包含指定的元素
        异常
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> List<E> of​(E e1,
                      E e2,
                      E e3,
                      E e4,
                      E e5,
                      E e6,
                      E e7,
                      E e8,
                      E e9,
                      E e10)
        返回一个包含十个元素的不可变列表。 详见Immutable List Static Factory Methods 。
        参数类型
        E - List的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        e7 - 第七个元素
        e8 - 第八个元素
        e9 - 第九个元素
        e10 - 第十个元素
        结果
        一个包含指定元素的 List
        异常
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        @SafeVarargs
static <E> List<E> of​(E... elements)
        返回包含任意数量元素的不可变列表。 详见Immutable List Static Factory Methods 。
        API Note:
        该方法也接受一个数组作为参数。 结果列表的元素类型将是数组的组件类型，列表的大小将等于数组的长度。 要使用单个元素创建一个数组，请执行以下操作：
           String[] array = ... ; List<String[]> list = List.<String[]>of(array);
        这将导致List.of(E)方法被调用。
        参数类型
        E - List的元素类型
        参数
        elements - 要包含在列表中的元素
        结果
        一个包含指定元素的 List
        异常
        NullPointerException - 如果一个元素是 null或者如果该数组是 null
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface ListIterator<E>

  • All Superinterfaces:
    Iterator<E>

    public interface ListIterator<E>
extends Iterator<E>
    用于允许程序员沿任一方向遍历列表的列表的迭代器，在迭代期间修改列表，并获取列表中迭代器的当前位置。 A ListIterator没有电流元素; 它的光标位置总是位于通过调用previous()返回的元素和通过调用next()返回的元素next() 。 长度为n的列表的迭代器具有n+1可能的光标位置，如下图所示的插图^ （ ^ ）所示：
      Element(0)   Element(1)   Element(2)   ... Element(n-1)
 cursor positions:  ^            ^            ^            ^                  ^
    请注意， remove()和set(Object)方法未按光标位置进行定义; 它们被定义为对通过调用next()或previous()返回的最后一个元素进行操作。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， List ， Iterator ， Enumeration ， List.listIterator()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void add​(E e)
      将指定的元素插入列表（可选操作）。
      boolean hasNext​()
      如果此列表迭代器在向前方向遍历列表时具有更多元素，则返回 true 。
      boolean hasPrevious​()
      如果此列表迭代器在相反方向遍历列表时具有更多元素，则返回 true 。
      E next​()
      返回列表中的下一个元素，并且前进光标位置。
      int nextIndex​()
      返回由后续调用返回的元素的索引 next() 。
      E previous​()
      返回列表中的上一个元素，并向后移动光标位置。
      int previousIndex​()
      返回由后续调用返回的元素的索引 previous() 。
      void remove​()
      从列表中删除 next()或 previous() （可选操作）返回的最后一个元素。
      void set​(E e)
      用指定的元素（可选操作）替换 next()或 previous()返回的最后一个元素。

      • Methods inherited from interface java.util.Iterator

        forEachRemaining

    • 方法详细信息

      • hasNext

        boolean hasNext​()
        如果此列表迭代器在向前方向遍历列表时具有更多元素，则返回true 。 （换句话说，如果true将返回一个元素而不是抛出异常，则返回true ）
        Specified by:
        hasNext在接口 Iterator<E>
        结果
        true如果列表迭代器在向前方向遍历列表时具有更多元素

      • next

        E next​()
        返回列表中的下一个元素，并且前进光标位置。 这种方法可以重复调用来遍历列表，或者与调用previous()进行混合来回。 （请注意，对next和previous交替调用将重复返回相同的元素。）
        Specified by:
        next在接口 Iterator<E>
        结果
        列表中的下一个元素
        异常
        NoSuchElementException - 如果迭代没有下一个元素

      • hasPrevious

        boolean hasPrevious​()
        如果此列表迭代器在相反方向遍历列表时具有更多元素，则返回true 。 （换句话说，如果true返回一个元素而不是抛出异常，则返回true ）
        结果
        true如果列表迭代器在相反方向遍历列表时具有更多元素

      • previous

        E previous​()
        返回列表中的上一个元素，并向后移动光标位置。 可以反复调用此方法，以便向后迭代列表，或者与来电next()的调用混合。 （请注意，对next和previous交替调用将重复返回相同的元素。）
        结果
        列表中的前一个元素
        异常
        NoSuchElementException - 如果迭代没有以前的元素

      • nextIndex

        int nextIndex​()
        返回由后续调用next()返回的元素的索引。 （如果列表迭代器位于列表的末尾，则返回列表大小。）
        结果
        由后续调用 next返回的元素的索引，如果列表迭代器位于列表的末尾，则为列表大小

      • previousIndex

        int previousIndex​()
        返回由后续调用返回的元素的索引previous() 。 （如果列表迭代器位于列表的开头，则返回-1）
        结果
        由后续调用 previous返回的元素的索引，如果列表迭代器位于列表的开头，则为-1

      • remove

        void remove​()
        从列表中删除由next()或previous()返回的最后一个元素（可选操作）。 此呼叫只能拨打next或previous 。 它可制成只有add(E)尚未到最后通话后称为next或者previous 。
        Specified by:
        remove在接口 Iterator<E>
        异常
        UnsupportedOperationException - 如果此列表迭代器不支持 remove操作
        IllegalStateException - 如果 next和 previous都不被调用，或者 remove或 add在最后一次调用后被调用到 next或 previous

      • set

        void set​(E e)
        用指定的元素替换由next()或previous()返回的最后一个元素（可选操作）。 只有在最后一次拨打next或previous之后既不调用remove()也不add(E)，此呼叫可以进行。
        参数
        e - 用于替换 next或 previous返回的最后一个元素的元素
        异常
        UnsupportedOperationException - 如果 set操作不支持此列表迭代器
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        IllegalArgumentException - 如果指定元素的某些方面阻止将其添加到此列表中
        IllegalStateException - 如果 next和 previous被调用，或者 remove或 add在最后一次通话后被调用到 next或 previous

      • add

        void add​(E e)
        将指定的元素插入列表（可选操作）。 该元素将紧接在由next() （如果有）返回的元素之前，以及由previous()返回的元素之后。 （如果列表不包含元素，则新元素将成为列表中的唯一元素。）新元素插入隐式游标之前：后续调用next将不受影响，后续调用previous将返回新元素。 （此呼叫将增加一个呼叫返回的值为nextIndex或previousIndex 。
        参数
        e - 要插入的元素
        异常
        UnsupportedOperationException - 如果此列表迭代器不支持 add方法
        ClassCastException - 如果指定元素的类阻止将其添加到此列表中
        IllegalArgumentException - 如果此元素的某些方面阻止将其添加到此列表
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListResourceBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class ListResourceBundle

  • java.lang.Object
    • java.util.ResourceBundle
      • java.util.ListResourceBundle
  • 已知直接子类：
    AccessibleResourceBundle

    public abstract class ListResourceBundle
extends ResourceBundle
    ListResourceBundle是一个抽象类ResourceBundle管理资源，以方便和易于使用的列表区域设置。 有关资源束的更多信息，请参阅ResourceBundle 。

    子类必须覆盖getContents并提供一个数组，其中数组中的每个项都是一对对象。 每对的第一个元素是键，它必须是String ，第二个元素是与该键相关联的值。

    以下example显示了基本名称为“MyResources”的资源束系列的两个成员。 “MyResources”是捆绑包系列的默认成员，“MyResources_fr”是法语成员。 这些成员基于ListResourceBundle （相关的example显示了如何根据属性文件向该系列添加包）。 此示例中的键的格式为“s1”等。实际的键完全取决于您的选择，只要它们与您在程序中使用的键相同即可从包中检索对象。 密钥区分大小写。

 public class MyResources extends ListResourceBundle {
     protected Object[][] getContents() {
         return new Object[][] {
         // LOCALIZE THIS
             {"s1", "The disk \"{1}\" contains {0}."},  // MessageFormat pattern
             {"s2", "1"},                               // location of {0} in pattern
             {"s3", "My Disk"},                         // sample disk name
             {"s4", "no files"},                        // first ChoiceFormat choice
             {"s5", "one file"},                        // second ChoiceFormat choice
             {"s6", "{0,number} files"},                // third ChoiceFormat choice
             {"s7", "3 Mar 96"},                        // sample date
             {"s8", new Dimension(1,5)}                 // real object, not just string
         // END OF MATERIAL TO LOCALIZE
         };
     }
 }

 public class MyResources_fr extends ListResourceBundle {
     protected Object[][] getContents() {
         return new Object[][] {
         // LOCALIZE THIS
             {"s1", "Le disque \"{1}\" {0}."},          // MessageFormat pattern
             {"s2", "1"},                               // location of {0} in pattern
             {"s3", "Mon disque"},                      // sample disk name
             {"s4", "ne contient pas de fichiers"},     // first ChoiceFormat choice
             {"s5", "contient un fichier"},             // second ChoiceFormat choice
             {"s6", "contient {0,number} fichiers"},    // third ChoiceFormat choice
             {"s7", "3 mars 1996"},                     // sample date
             {"s8", new Dimension(1,3)}                 // real object, not just string
         // END OF MATERIAL TO LOCALIZE
         };
     }
 }

    如果同时使用多个线程，则ListResourceBundle子类的实现必须是线程安全的。 该类中的方法的默认实现是线程安全的。

    从以下版本开始：
    1.1
    另请参见：
    ResourceBundle ， PropertyResourceBundle

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.ResourceBundle

        ResourceBundle.Control

    • Field Summary

      • Fields inherited from class java.util.ResourceBundle

        parent

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListResourceBundle​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract Object[][] getContents​()
      返回一个数组，其中每个项目是 Object数组中的一对对象。
      Enumeration<String> getKeys​()
      返回一个 Enumeration包含在此按键 ResourceBundle及其父包。
      Object handleGetObject​(String key)
      从此资源包获取给定键的对象。
      protected Set<String> handleKeySet​()
      返回一个 Set的键 只包含在这个 ResourceBundle 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.ResourceBundle

        clearCache, clearCache, containsKey, getBaseBundleName, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getLocale, getObject, getString, getStringArray, keySet, setParent

    • 构造方法详细信息

      • ListResourceBundle

        public ListResourceBundle​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • handleGetObject

        public final Object handleGetObject​(String key)
        描述从类别复制： ResourceBundle
        从此资源包获取给定键的对象。 如果此资源束不包含给定键的对象，则返回null。
        Specified by:
        handleGetObject中的 ResourceBundle
        参数
        key - 所需对象的关键
        结果
        给定键的对象，或null

      • getKeys

        public Enumeration<String> getKeys​()
        返回一个 Enumeration包含在此按键 ResourceBundle及其父包。
        Specified by:
        getKeys在 ResourceBundle
        结果
        一个 Enumeration的这个密钥包含在这个 ResourceBundle及其父包中。
        另请参见：
        ResourceBundle.keySet()

      • handleKeySet

        protected Set<String> handleKeySet​()
        返回一个 Set的键 只包含在这个 ResourceBundle 。
        重写：
        handleKeySet在 ResourceBundle
        结果
        一个 Set的键只包含在这个 ResourceBundle
        从以下版本开始：
        1.6
        另请参见：
        ResourceBundle.keySet()

      • getContents

        protected abstract Object[][] getContents​()
        返回一个数组，其中每个项目是Object数组中的一对对象。 每对的第一个元素是键，它必须是String ，第二个元素是与该键相关联的值。 详见课程说明。
        结果
        表示键值对的 Object数组的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Locale (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Locale

  • java.lang.Object
    • java.util.Locale
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class Locale
extends Object
implements Cloneable, Serializable
    A Locale对象代表具体的地理，政治或文化区域。 需要Locale执行其任务的操作称为区域设置敏感型，并使用Locale为用户定制信息。 例如，显示一个数字是一个区域设置敏感的操作 - 该数字应该根据用户的本地国家，地区或文化的习惯和惯例进行格式化。

    Locale类实现了IETF BCP 47，它由RFC 4647 "Matching of Language Tags"和RFC 5646 "Tags for Identifying Languages"组成，支持LDML（UTS＃35，“Unicode语言环境数据标记语言”）BCP 47兼容的本地数据交换扩展。

    A Locale对象逻辑上由以下描述的字段组成。

    language
    ISO 639 alpha-2或alpha-3语言代码或最多8个字母字母的注册语言子标签（用于未来的增强功能）。 当语言同时具有alpha-2代码和alpha-3代码时，必须使用alpha-2代码。 您可以在IANA Language Subtag Registry中找到有效语言代码的完整列表（搜索“Type：language”）。 语言字段不区分大小写，但Locale总是规范化为小写。
    形式良好的语言值具有形式[a-zA-Z]{2,8} 。 请注意，这不是完整的BCP47语言生产，因为它不包括extlang。 它们不需要，因为现代的三字母语言代码替代它们。
    示例：“en”（英文），“ja”（日语），“kok”（Konkani）
    script
    ISO 15924 alpha-4脚本代码。 您可以在IANA语言小标签注册表中找到有效脚本代码的完整列表（搜索“类型：脚本”）。 脚本字段不区分大小写，但Locale总是规范化到标题大小写（第一个字母大写，其余的字母小写）。
    格式良好的脚本值的格式为[a-zA-Z]{4}
    示例：“Latn”（拉丁文），“Cyrl”（西里尔文）
    country (region)
    ISO 3166 alpha-2国家代码或UN M.49数字-3区号。 新新新新200新新旗新新200新200新新200新200新200新200新200新200新新200新200新新200新200新新200新200新新200新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200 国家（地区）字段不区分大小写，但Locale总是规范化为大写。
    形式良好的国家/地区价值形式为[a-zA-Z]{2} | [0-9]{3}
    示例：“美国”（美国），“FR”（法国），“029”（加勒比）
    variant
    任何用于指示Locale的变化的任意值。 在有两个或多个变体值的情况下，每个值都表示自己的语义，这些值应按重要性排序，最重要的是首先用下划线（'_'）分隔。 变体字段区分大小写。
    注意：IETF BCP 47对变式子标签放置语法限制。 此外，BCP 47子标签也被严格用于表示定义语言或其方言的其他变体，这些语言或语言不被语言，脚本和区域子标签的任何组合覆盖。 您可以在IANA语言小标签注册表中找到有效的变体代码的完整列表（搜索“Type：variant”）。

    Locale 例如，Java SE运行时环境中可用的一些支持的变体表示替代的文化行为，如日历类型或数字脚本。 在BCP 47中，这种不能识别语言的信息受到扩展子标签或私有使用子标签的支持。

    形状良好的变体值的形式为SUBTAG (('_'|'-') SUBTAG)* ，其中SUBTAG = [0-9][0-9a-zA-Z]{3} | [0-9a-zA-Z]{5,8} 。 （注意：BCP 47只使用连字符（' - '）作为分隔符，这个更宽松）。
    示例：“polyton”（Polytonic Greek），“POSIX”
    extensions
    从单个字符键到字符串值的映射，指示除了语言识别之外的扩展。 Locale 扩展名不区分大小写，但是Locale所有扩展键和值规范化为小写。 请注意，扩展名不能有空值。
    [0-9a-zA-Z]键是[0-9a-zA-Z]中的单个字符。 格式SUBTAG ('-' SUBTAG)*值为SUBTAG ('-' SUBTAG)* ，其中对于“x” SUBTAG = [0-9a-zA-Z]{1,8}和其他键SUBTAG = [0-9a-zA-Z]{2,8} （即，“x”允许单字符子标签））。
    示例：key =“u”/ value =“ca-japanese”（日语日历），key =“x”/ value =“java-1-7”
    注意：虽然BCP 47需要在IANA语言分条注册表中注册字段值，但Locale类不提供任何验证功能。 Builder只检查一个字段是否满足句法要求（格式良好），但不验证值本身。 详见Locale.Builder 。

    Unicode locale/language extension

    UTS＃35，“Unicode语言环境数据标记语言”定义了可选属性和关键字来覆盖或改进与语言环境相关联的默认行为。 关键字由一对键和类型表示。 例如，“nu-thai”表示泰国本地数字（值：“thai”）应用于格式化数字（键：“nu”）。

    新新新新新新旗新新新旗新新旗新新新旗新新旗新新新旗新新旗旗新新旗新新旗200新新新新旗新新旗旗新新旗新新200新新新旗200新新新新旗新新200新新200新新新新旗新新200新新200新新新200新新200新新200新新200新新新200新新200新新新200新新200新新新200新新200新新200新新200新新新200新新200新新新200新新200 上述例子“nu-thai”成为“u-nu-thai”的扩展。

    因此，当一个Locale对象包含Unicode区域设置属性和关键字时， getExtension(UNICODE_LOCALE_EXTENSION)将返回一个表示此信息的字符串，例如“nu-thai”。 该Locale类还提供getUnicodeLocaleAttributes() ， getUnicodeLocaleKeys() ，并getUnicodeLocaleType(java.lang.String) ，让你可以直接访问Unicode语言环境属性和关键/类型对。 当以字符串的形式表示时，Unicode区域设置扩展名按字母顺序列出属性，后面是按字母顺序排列的键/类型序列（包含键的类型的子标记的顺序在定义类型时是固定的）

    格式良好的区域密钥的格式为[0-9a-zA-Z]{2} 。 格式良好的区域设置形式为"" | [0-9a-zA-Z]{3,8} ('-' [0-9a-zA-Z]{3,8})* （它可以是空的，或一系列长度为3-8个字母的子"" | [0-9a-zA-Z]{3,8} ('-' [0-9a-zA-Z]{3,8})* ）。 一个格式良好的区域设置属性的格式为[0-9a-zA-Z]{3,8} （它是一个单独的子标签，具有与区域设置类型子标签相同的形式）。

    Unicode区域设置扩展名指定区域设置敏感服务中的可选行为。 虽然LDML规范定义了各种键和值，Java运行时环境中的实际区域设置敏感的服务实现可能不支持任何特定的Unicode区域设置属性或键/类型对。

    创建区域设置

    有几种不同的方法来创建一个Locale对象。

    生成器

    使用Locale.Builder你可以构造一个Locale对象符合BCP 47语法。

    构造函数

    Locale类提供三个构造函数：

         Locale(String language)
     Locale(String language, String country)
     Locale(String language, String country, String variant)
    这些构造函数允许您使用语言，国家和变体创建Locale对象，但不能指定脚本或扩展名。
    工厂方法

    200新 Locale -45 旗新新新新200新新旗新新新新新新新新新旗200新新200 200 200新新200新200新200新新200新新200新新200新新新200新新200新新旗200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新旗 Locale

    区域常数

    Locale类提供了一些方便的常量，可用于为常用的区域设置创建Locale对象。 例如，以下内容为美国创建一个Locale对象：

         Locale.US

    Locale Matching

    如果应用程序或系统被国际化并为多个区域设置提供本地化资源，则有时需要找到满足每个用户的特定偏好的一个或多个区域设置（或语言标签）。 请注意，术语“语言标签”可与本地区匹配文档中的“区域设置”互换使用。

    为了使用户的首选语言环境与一组语言标签相匹配， RFC 4647 Matching of Language Tags定义了两种机制：过滤和查找。 过滤用于获取所有匹配的区域设置，而查找是选择最匹配的区域设置。 匹配是不区分大小写的。 这些匹配机制将在以下部分中介绍。

    用户的偏好被称为语言优先级列表 ，并且表示为语言范围的列表。 语法上有两种语言范围：基本和扩展。 详见Locale.LanguageRange 。

    过滤

    过滤操作返回所有匹配的语言标签。 它在RFC 4647中定义如下：“在过滤中，每个语言范围代表最不特定的语言标签（即具有最少子标签的语言标签），这是可接受的匹配。匹配集合中的所有语言标签的标签将具有与语言范围相同或更多的子标签，语言范围中的每个非通配符子标签都将显示在每个匹配的语言标签中。

    有两种类型的过滤：基本语言范围的过滤（称为“基本过滤”）和扩展语言范围的过滤（称为“扩展过滤”）。 他们可能会通过在给定的语言优先级列表中包含什么样的语言范围来返回不同的结果。 Locale.FilteringMode是一个参数，用于指定如何进行过滤。

    抬头

    查找操作返回最匹配的语言标签。 它在RFC 4647中定义如下：“与过滤相反，每个语言范围代表最可访问匹配的最具体的标签，根据用户的优先级，找到的第一个匹配标签被认为是最接近的匹配项，回。”

    例如，如果语言优先级列表由两个语言范围"zh-Hant-TW"和"en-US" ，按照优先次序，查找方法逐渐搜索下面的语言标签，以便找到最佳匹配语言标签。

        1. zh-Hant-TW
    2. zh-Hant
    3. zh
    4. en-US
    5. en
    如果语言标签与上述语言范围完全匹配，则返回语言标签。

    "*"是特殊的语言范围，在查找中被忽略。

    作为语言范围中包含的子标签'*'的结果，如果多个语言标签相匹配， '*'返回的Iterator超过Collection的语言标签的第一匹配语言标签被视为最佳匹配语言标签。

    使用区域设置

    一旦你创建了一个Locale你可以查询它自己的信息。 使用getCountry获取国家（或地区）代码和getLanguage获取语言代码。 您可以使用getDisplayCountry获取适合向用户显示的国家/地区的名称。 类似地，您可以使用getDisplayLanguage获取适合向用户显示的语言的名称。 有趣的是， getDisplayXXX方法本身是区域设置敏感的，并且有两个版本：一个使用缺省的DISPLAY区域设置，另一个使用指定为参数的区域设置。

    Java平台提供了许多执行区域设置敏感操作的类。 例如， NumberFormat类以区域设置敏感的方式格式化数字，货币和百分比。 类似于NumberFormat类有几种方便的方法来创建该类型的默认对象。 例如， NumberFormat类为创建默认的NumberFormat对象提供了以下三种便利方法：

         NumberFormat.getInstance()
     NumberFormat.getCurrencyInstance()
     NumberFormat.getPercentInstance()
    这些方法中的每一种都有两种变体; 一个有明确的语言环境，一个没有; 后者使用默认的FORMAT语言环境：
         NumberFormat.getInstance(myLocale)
     NumberFormat.getCurrencyInstance(myLocale)
     NumberFormat.getPercentInstance(myLocale)
    A Locale是用于识别您想要获得的对象的种类（ NumberFormat ）的机制。 区域设置只是用于识别对象的机制， 而不是对象本身的容器。

    兼容性

    为了保持与现有使用的兼容性，Locale的构造函数在Java Runtime Environment 1.7之前保留其行为。 对于toString方法也是如此。 因此，区域设置对象可以继续使用。 特别是，将toString的输出解析为语言，国家和变体字段的客户端可以继续这样做（尽管这是非常不鼓励的），尽管如果存在脚本或扩展，变体字段将具有其他信息。

    此外，BCP 47强加了Locale的构造函数不强加的语法限制。 这意味着在不丢失信息的情况下，无法进行某些区域设置和BCP 47语言标记之间的转换。 因此， toLanguageTag不能代表其语言，国家或变体不符合BCP 47的语言环境的状态。

    由于这些问题，建议客户端迁移构建不合格的区域设置，并使用forLanguageTag和Locale.Builder API。 因此，希望完整语言环境的字符串表示的客户端可以始终依赖于toLanguageTag 。

    Special cases

    出于兼容性原因，两个不合格的区域设置被视为特殊情况。 这些是ja_JP_JP和th_TH_TH 。 这些都是在BCP 47中形成的，因为变体太短。 为了缓解迁移到BCP 47，这些在施工期间被特别处理。 这两种情况（只有这些）导致构造函数生成扩展，所有其他值的行为与Java 7之前的行为完全相同。

    Java已经用ja_JP_JP代表日本在日本和日本帝国日历一起使用。 现在可以使用Unicode区域设置扩展名来指定Unicode区域设置密钥ca （对于“日历”）和类型japanese 。 当使用参数“ja”，“JP”，“JP”调用Locale构造函数时，将自动添加扩展名“u-ca-japanese”。

    Java已使用th_TH_TH代表泰国与泰国一起使用的泰语数字。 现在也可以使用Unicode区域设置扩展名来指定Unicode区域设置密钥nu （对于“number”）和值thai 。 当使用参数“th”，“TH”，“TH”调用Locale构造函数时，会自动添加扩展名“u-nu-thai”。

    序列化

    在序列化期间，writeObject将所有字段写入输出流，包括扩展。

    在反序列化期间，readResolve会按照Special Cases中的说明添加扩展，仅适用于th_TH_TH和ja_JP_JP两种情况。

    传统语言代码

    语言环境的构造一直变换的三个语言代码到其以前的，过时的形式： he映射到iw ， yi映射到ji ，并id映射到in 。 这种情况依然如此，为了不破坏兼容性。

    这些API在新旧语言代码之间的1.7地图中添加，并将旧代码保留在Locale内部（以便getLanguage和toString反映旧代码），但是使用BCP 47语言标签API中的新代码（以便toLanguageTag反映新的那一个）。 无论使用哪个代码或API来构造它们，都可以保持区域设置之间的等价性。 Java的默认资源包查找机制也实现了这种映射，因此可以使用任何一种约定命名资源，参见ResourceBundle.Control 。

    三字母语言/国家（地区）代码

    Locale构造函数一直指定语言和国家参数长度为两个字符，但实际上它们已经接受了任何长度。 该规范现已放宽，允许2至8个字符的语言代码和2到3个字符的国家（地区）代码，特别是IANA语言分条注册表中指定的三个字母的语言代码和三位数区域代码。 为了兼容性，实现仍然不会强加长度约束。

    从以下版本开始：
    1.1
    另请参见：
    Locale.Builder ， ResourceBundle ， Format ， NumberFormat ， Collator ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Locale.Builder
      Builder用于从设置器配置的值构建 Locale实例。
      static class  Locale.Category
      枚举地区类别。
      static class  Locale.FilteringMode
      此枚举提供常量来选择区域设置匹配的过滤模式。
      static class  Locale.IsoCountryCode
      用于指定ISO 3166中定义的类型的枚举。
      static class  Locale.LanguageRange
      该类表示 RFC 4647 Matching of Language Tags中定义的 语言范围 。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Locale CANADA
      对国家有用的常数。
      static Locale CANADA_FRENCH
      对国家有用的常数。
      static Locale CHINA
      对国家有用的常数。
      static Locale CHINESE
      有用的语言常数
      static Locale ENGLISH
      有用的语言常数
      static Locale FRANCE
      对国家有用的常数。
      static Locale FRENCH
      有用的语言常数
      static Locale GERMAN
      有用的语言常数
      static Locale GERMANY
      对国家有用的常数。
      static Locale ITALIAN
      有用的语言常数
      static Locale ITALY
      对国家有用的常数。
      static Locale JAPAN
      对国家有用的常数。
      static Locale JAPANESE
      有用的语言常数
      static Locale KOREA
      对国家有用的常数。
      static Locale KOREAN
      有用的语言常数
      static Locale PRC
      对国家有用的常数。
      static char PRIVATE_USE_EXTENSION
      私人使用扩展（'x'）的关键。
      static Locale ROOT
      根区域的常用常数。
      static Locale SIMPLIFIED_CHINESE
      有用的语言常数
      static Locale TAIWAN
      对国家有用的常数。
      static Locale TRADITIONAL_CHINESE
      有用的语言常数
      static Locale UK
      对国家有用的常数。
      static char UNICODE_LOCALE_EXTENSION
      Unicode区域扩展（'u'）的关键。
      static Locale US
      对国家有用的常数。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Locale​(String language)
      从语言代码构建语言环境。
      Locale​(String language, String country)
      从语言和国家构建语言环境。
      Locale​(String language, String country, String variant)
      从语言，国家和变体构建语言环境。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      覆盖可克隆。
      boolean equals​(Object obj)
      如果此区域设置等于另一个对象，则返回true。
      static List<Locale> filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例列表。
      static List<Locale> filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales, Locale.FilteringMode mode)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
      static List<String> filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      static List<String> filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags, Locale.FilteringMode mode)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      static Locale forLanguageTag​(String languageTag)
      返回指定的IETF BCP 47语言标记字符串的语言环境。
      static Locale[] getAvailableLocales​()
      返回所有已安装区域设置的数组。
      String getCountry​()
      返回此区域设置的国家/地区代码，该代码应为空字符串，大写ISO 3166 2字母代码或UN M.49 3位代码。
      static Locale getDefault​()
      获取Java虚拟机的此实例的默认语言环境的当前值。
      static Locale getDefault​(Locale.Category category)
      获取Java虚拟机的此实例的指定类别的默认语言环境的当前值。
      String getDisplayCountry​()
      返回适合显示给用户的区域设置国家/地区的名称。
      String getDisplayCountry​(Locale inLocale)
      返回适合显示给用户的区域设置国家/地区的名称。
      String getDisplayLanguage​()
      返回适合显示给用户的语言环境语言的名称。
      String getDisplayLanguage​(Locale inLocale)
      返回适合显示给用户的语言环境语言的名称。
      String getDisplayName​()
      返回适合显示给用户的区域设置的名称。
      String getDisplayName​(Locale inLocale)
      返回适合显示给用户的区域设置的名称。
      String getDisplayScript​()
      返回适合显示给用户的区域设置脚本的名称。
      String getDisplayScript​(Locale inLocale)
      返回适合显示给用户的区域设置脚本的名称。
      String getDisplayVariant​()
      返回适合显示给用户的区域设置变体代码的名称。
      String getDisplayVariant​(Locale inLocale)
      返回适合显示给用户的区域设置变体代码的名称。
      String getExtension​(char key)
      返回与指定键相关联的扩展名（或私有使用）值，如果没有与密钥关联的扩展名，则返回null。
      Set<Character> getExtensionKeys​()
      返回与此语言环境相关联的扩展键集合，如果没有扩展名则返回空集合。
      String getISO3Country​()
      返回此区域设置的国家/地区的三个字母的缩写。
      String getISO3Language​()
      返回此语言环境的三个字母缩写。
      static String[] getISOCountries​()
      返回ISO 3166中定义的所有2个字母的国家/地区代码的列表。
      static Set<String> getISOCountries​(Locale.IsoCountryCode type)
      返回 Set的指定类型的ISO3166国家代码。
      static String[] getISOLanguages​()
      返回ISO 639中定义的所有2个字母的语言代码的列表。
      String getLanguage​()
      返回此区域设置的语言代码。
      String getScript​()
      返回此语言环境的脚本，该脚本应为空字符串或ISO 15924 4字母脚本代码。
      Set<String> getUnicodeLocaleAttributes​()
      返回与此区域设置关联的unicode区域设置属性集，如果没有属性，则返回空集合。
      Set<String> getUnicodeLocaleKeys​()
      返回此区域设置定义的Unicode区域设置键的集合，如果此区域设置没有，则返回空集合。
      String getUnicodeLocaleType​(String key)
      返回与该区域设置的指定Unicode区域设置键相关联的Unicode区域设置类型。
      String getVariant​()
      返回此区域设置的变体代码。
      boolean hasExtensions​()
      退货 true如果这 Locale有任何 extensions 。
      int hashCode​()
      覆盖hashCode。
      static Locale lookup​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的查找机制返回 Locale最佳匹配语言标签的实例。
      static String lookupTag​(List<Locale.LanguageRange> priorityList, Collection<String> tags)
      使用RFC 4647中定义的查找机制返回最匹配的语言标签。
      static void setDefault​(Locale newLocale)
      设置Java虚拟机的此实例的默认语言环境。
      static void setDefault​(Locale.Category category, Locale newLocale)
      为Java虚拟机的此实例设置指定类别的默认语言环境。
      Locale stripExtensions​()
      返回此 Locale的副本，不包括 extensions 。
      String toLanguageTag​()
      返回一个格式正确的IETF BCP 47语言标签，代表这个区域。
      String toString​()
      返回此 Locale对象的字符串表示形式，由语言，国家/地区，变体，脚本和扩展名组成，如下所示：language +“_”+ country +“_”+（variant +“_＃”|“＃”）+ script +“_”+扩展语言总是小写，国家总是大写，脚本总是标题大小写，而扩展名总是小写。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ENGLISH

        public static final Locale ENGLISH
        有用的语言常数

      • FRENCH

        public static final Locale FRENCH
        有用的语言常数

      • GERMAN

        public static final Locale GERMAN
        有用的语言常数

      • ITALIAN

        public static final Locale ITALIAN
        有用的语言常数

      • JAPANESE

        public static final Locale JAPANESE
        有用的语言常数

      • KOREAN

        public static final Locale KOREAN
        有用的语言常数

      • CHINESE

        public static final Locale CHINESE
        有用的语言常数

      • SIMPLIFIED_CHINESE

        public static final Locale SIMPLIFIED_CHINESE
        有用的语言常数

      • TRADITIONAL_CHINESE

        public static final Locale TRADITIONAL_CHINESE
        有用的语言常数

      • FRANCE

        public static final Locale FRANCE
        对国家有用的常数。

      • GERMANY

        public static final Locale GERMANY
        对国家有用的常数。

      • ITALY

        public static final Locale ITALY
        对国家有用的常数。

      • JAPAN

        public static final Locale JAPAN
        对国家有用的常数。

      • KOREA

        public static final Locale KOREA
        对国家有用的常数。

      • CHINA

        public static final Locale CHINA
        对国家有用的常数。

      • PRC

        public static final Locale PRC
        对国家有用的常数。

      • TAIWAN

        public static final Locale TAIWAN
        对国家有用的常数。

      • UK

        public static final Locale UK
        对国家有用的常数。

      • US

        public static final Locale US
        对国家有用的常数。

      • CANADA

        public static final Locale CANADA
        对国家有用的常数。

      • CANADA_FRENCH

        public static final Locale CANADA_FRENCH
        对国家有用的常数。

      • ROOT

        public static final Locale ROOT
        根区域的常用常数。 根语言环境是语言，国家和变体为空（“”）字符串的语言环境。 这被视为所有语言环境的基础语言环境，并被用作语言/国家中立语言环境的区域敏感操作。
        从以下版本开始：
        1.6

      • PRIVATE_USE_EXTENSION

        public static final char PRIVATE_USE_EXTENSION
        私人使用扩展（'x'）的关键。
        从以下版本开始：
        1.7
        另请参见：
        getExtension(char) ， Locale.Builder.setExtension(char, String) ， Constant Field Values

      • UNICODE_LOCALE_EXTENSION

        public static final char UNICODE_LOCALE_EXTENSION
        Unicode区域扩展（'u'）的关键。
        从以下版本开始：
        1.7
        另请参见：
        getExtension(char) ， Locale.Builder.setExtension(char, String) ， Constant Field Values

    • 构造方法详细信息

      • Locale

        public Locale​(String language,
              String country,
              String variant)
        从语言，国家和变体构建语言环境。 该构造函数将语言值规范化为小写，将国家值标准化为大写。

        注意：

        • ISO 639不是一个稳定的标准; 它定义的一些语言代码（特别是“iw”，“ji”和“in”）已经改变了。 此构造函数接受旧代码（“iw”，“ji”和“in”）和新代码（“he”，“yi”和“id”），但所有其他API在Locale上将仅返回OLD代码。
        • 由于向后兼容性原因，此构造函数不对输入进行任何语法检查。
        • 特殊处理两种情况（“ja”，“JP”，“JP”）和（“th”，“TH”，“TH”），详情请参阅Special Cases 。
        参数
        language - ISO 639 alpha-2或alpha-3语言代码或最多8个字符的语言子标签。 请参阅有关有效语言值的Locale类描述。
        country - ISO 3166 alpha-2国家代码或UN M.49数字-3区号。 请参阅有关有效国家/地区值的Locale类描述。
        variant - 用于指示Locale的变体的任意值。 详见Locale课程说明。
        异常
        NullPointerException - 如果任何参数为空，则抛出。

      • Locale

        public Locale​(String language,
              String country)
        从语言和国家构建语言环境。 该构造函数将语言值规范化为小写，将国家值标准化为大写。

        注意：

        • ISO 639不是一个稳定的标准; 它定义的一些语言代码（特别是“iw”，“ji”和“in”）已经改变了。 此构造函数接受旧代码（“iw”，“ji”和“in”）和新代码（“he”，“yi”和“id”），但所有其他API在Locale上将仅返回OLD代码。
        • 由于向后兼容性原因，此构造函数不对输入进行任何语法检查。
        参数
        language - ISO 639 alpha-2或alpha-3语言代码或最多8个字符的语言子标签。 请参阅有关有效语言值的Locale类描述。
        country - ISO 3166 alpha-2国家代码或UN M.49数字-3区号。 请参阅有关有效国家/地区值的Locale类描述。
        异常
        NullPointerException - 如果任一参数为空，则抛出。

      • Locale

        public Locale​(String language)
        从语言代码构建语言环境。 该构造函数将语言值规范化为小写。

        注意：

        • ISO 639不是一个稳定的标准; 它定义的一些语言代码（特别是“iw”，“ji”和“in”）已经改变了。 此构造函数接受旧代码（“iw”，“ji”和“in”）和新代码（“he”，“yi”和“id”），但所有其他API在Locale上将仅返回OLD代码。
        • 由于向后兼容性原因，此构造函数不对输入进行任何语法检查。
        参数
        language - ISO 639 alpha-2或alpha-3语言代码或最多8个字符的语言子标签。 请参阅有关有效语言值的Locale类描述。
        异常
        NullPointerException - 如果参数为null，则抛出。
        从以下版本开始：
        1.4

    • 方法详细信息

      • getDefault

        public static Locale getDefault​()
        获取Java虚拟机的此实例的默认语言环境的当前值。

        Java虚拟机根据主机环境在启动期间设置默认语言环境。 如果没有显式指定区域设置，则会被许多区域设置敏感的方法使用。 可以使用setDefault方法更改。

        结果
        Java虚拟机的此实例的默认区域设置

      • getDefault

        public static Locale getDefault​(Locale.Category category)
        获取Java虚拟机的此实例的指定类别的默认语言环境的当前值。

        Java虚拟机根据主机环境在启动期间设置默认语言环境。 如果没有显式指定区域设置，则会被许多区域设置敏感的方法使用。 它可以使用setDefault（Locale.Category，Locale）方法更改。

        参数
        category - - 指定类别获取默认语言环境
        结果
        Java虚拟机的此实例的指定类别的默认语言环境
        异常
        NullPointerException - 如果category为null
        从以下版本开始：
        1.7
        另请参见：
        setDefault(Locale.Category, Locale)

      • setDefault

        public static void setDefault​(Locale newLocale)
        设置Java虚拟机的此实例的默认语言环境。 这不影响主机区域设置。

        如果有安全管理器，则在默认语言环境更改之前，其checkPermission方法将被调用PropertyPermission("user.language", "write")权限。

        Java虚拟机根据主机环境在启动期间设置默认语言环境。 如果没有显式指定区域设置，则会被许多区域设置敏感的方法使用。

        因为更改默认语言环境可能会影响许多不同的功能区域，所以只有在调用者准备重新初始化同一Java虚拟机中运行的区域设置敏感代码时，才应使用此方法。

        通过使用此方法设置默认语言环境，每个类别的所有默认语言环境也将设置为指定的默认语言环境。

        参数
        newLocale - 新的默认语言环境
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许操作。
        NullPointerException - 如果 newLocale为空
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， PropertyPermission

      • setDefault

        public static void setDefault​(Locale.Category category,
                              Locale newLocale)
        为Java虚拟机的此实例设置指定类别的默认语言环境。 这不影响主机区域设置。

        如果有安全管理器，则在默认语言环境更改之前，将使用PropertyPermission（“user.language”，“write”）权限调用其checkPermission方法。

        Java虚拟机根据主机环境在启动期间设置默认语言环境。 如果没有显式指定区域设置，则会被许多区域设置敏感的方法使用。

        因为更改默认语言环境可能会影响许多不同的功能区域，所以只有在调用者准备重新初始化同一Java虚拟机中运行的区域设置敏感代码时，才应使用此方法。

        参数
        category - - 设置默认语言环境的指定类别
        newLocale - - 新的默认语言环境
        异常
        SecurityException - 如果安全管理器存在，并且其checkPermission方法不允许该操作。
        NullPointerException - 如果category和/或newLocale为null
        从以下版本开始：
        1.7
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， PropertyPermission ， getDefault(Locale.Category)

      • getAvailableLocales

        public static Locale[] getAvailableLocales​()
        返回所有已安装区域设置的数组。 返回的数组表示由Java运行时环境支持的语言环境的联合以及安装的LocaleServiceProvider实现。 它必须至少包含一个等于Locale.US的Locale实例。
        结果
        一组已安装的区域设置。

      • getISOCountries

        public static String[] getISOCountries​()
        返回在ISO 3166中定义的所有2个字母的国家/地区代码的列表。可用于创建区域设置。 该方法相当于getISOCountries(Locale.IsoCountryCode type)，其中type Locale.IsoCountryCode.PART1_ALPHA2 。

        注意： Locale类还支持国家（地区）的其他代码，例如3字母数字UN M.49区号。 因此，此方法返回的列表不包含可用于创建区域设置的所有有效代码。

        请注意，此方法不会返回过时的2个字母的国家/地区代码。 其中指定的那些过时的代码的国家代码ISO3166-3码，可以从被检索getISOCountries(Locale.IsoCountryCode type)与type Locale.IsoCountryCode.PART3 。

        结果
        一系列ISO 3166双字母国家代码。

      • getISOCountries

        public static Set<String> getISOCountries​(Locale.IsoCountryCode type)
        返回 Set的指定类型的ISO3166国家代码。
        参数
        type - Locale.IsoCountryCode指定的ISO代码类型。
        结果
        一个指定类型的ISO国家代码的 Set 。
        异常
        NullPointerException - 如果type为null
        从以下版本开始：
        9
        另请参见：
        Locale.IsoCountryCode

      • getISOLanguages

        public static String[] getISOLanguages​()
        返回ISO 639中定义的所有2个字母的语言代码的列表。可用于创建区域设置。

        注意：

        • ISO 639不是一个稳定的标准 - 一些语言的代码已经改变。 此函数返回的列表包括代码已更改的语言的新旧代码。
        • Locale类还支持长达8个字符的语言代码。 因此，此方法返回的列表不包含可用于创建区域设置的所有有效代码。
        结果
        一组ISO 639双字母语言代码。

      • getLanguage

        public String getLanguage​()
        返回此区域设置的语言代码。

        注意： ISO 639不是一个稳定的标准 - 一些语言的代码已经改变。 Locale的构造函数识别代码已更改的语言的新旧代码，但此函数始终返回旧代码。 如果要检查其代码已更改的特定语言，请勿执行

          if (locale.getLanguage().equals("he")) // BAD!
    ...
        相反，做
          if (locale.getLanguage().equals(new Locale("he").getLanguage()))
    ...
        结果
        语言代码，如果没有定义，则为空字符串。
        另请参见：
        getDisplayLanguage()

      • getScript

        public String getScript​()
        返回此语言环境的脚本，该脚本应为空字符串或ISO 15924 4字母脚本代码。 第一个字母是大写字母，其余的是小写字母，例如“Latn”，“Cyrl”。
        结果
        脚本代码，或空字符串，如果没有定义。
        从以下版本开始：
        1.7
        另请参见：
        getDisplayScript()

      • getCountry

        public String getCountry​()
        返回此区域设置的国家/地区代码，该代码应为空字符串，大写ISO 3166 2字母代码或UN M.49 3位代码。
        结果
        国家/地区代码，如果没有定义，则为空字符串。
        另请参见：
        getDisplayCountry()

      • getVariant

        public String getVariant​()
        返回此区域设置的变体代码。
        结果
        变量代码，如果没有定义，则为空字符串。
        另请参见：
        getDisplayVariant()

      • hasExtensions

        public boolean hasExtensions​()
        如果这个 Locale有 true则返回 true 。
        结果
        true如果这 Locale有任何扩展
        从以下版本开始：
        1.8

      • stripExtensions

        public Locale stripExtensions​()
        返回此Locale的副本，不包括extensions 。 如果此Locale没有扩展，则返回此Locale 。
        结果
        该 Locale的副本，无扩展名，或 this如果 this没有扩展名
        从以下版本开始：
        1.8

      • getExtension

        public String getExtension​(char key)
        返回与指定键相关联的扩展名（或私有使用）值，如果没有与密钥关联的扩展名，则返回null。 要形成良好的关键，必须是[0-9A-Za-z] 。 键不区分大小写，因此例如“z”和“Z”表示相同的扩展名。
        参数
        key - 扩展键
        结果
        扩展名，如果此区域设置不指定指定键的扩展名，则为null。
        异常
        IllegalArgumentException - 如果密钥 IllegalArgumentException不正确
        从以下版本开始：
        1.7
        另请参见：
        PRIVATE_USE_EXTENSION ， UNICODE_LOCALE_EXTENSION

      • getExtensionKeys

        public Set<Character> getExtensionKeys​()
        返回与此语言环境相关联的扩展键集合，如果没有扩展名则返回空集合。 返回的集合是不可修改的。 钥匙都是小写的。
        结果
        扩展键集合，如果此区域设置没有扩展名，则为空集。
        从以下版本开始：
        1.7

      • getUnicodeLocaleAttributes

        public Set<String> getUnicodeLocaleAttributes​()
        返回与此区域设置关联的unicode区域设置属性集，如果没有属性，则返回空集合。 返回的集合是不可修改的。
        结果
        属性集。
        从以下版本开始：
        1.7

      • getUnicodeLocaleType

        public String getUnicodeLocaleType​(String key)
        返回与该区域设置的指定Unicode区域设置键相关联的Unicode区域设置类型。 返回没有类型定义的键的空字符串。 如果未定义键，则返回null。 密钥不区分大小写。 密钥必须是两个字母数字字符（[0-9a-zA-Z]），或者抛出IllegalArgumentException。
        参数
        key - Unicode区域设置键
        结果
        与密钥相关联的Unicode区域设置类型，如果区域设置未定义密钥，则为空。
        异常
        IllegalArgumentException - 如果密钥 IllegalArgumentException不正确
        NullPointerException - 如果 key为空
        从以下版本开始：
        1.7

      • getUnicodeLocaleKeys

        public Set<String> getUnicodeLocaleKeys​()
        返回此区域设置定义的Unicode区域设置键的集合，如果此区域设置没有，则返回空集合。 返回的集是不可变的。 钥匙都是小写字母。
        结果
        Unicode区域设置键的集合，如果此区域设置没有Unicode区域设置关键字，则为空集。
        从以下版本开始：
        1.7

      • toString

        public final String toString​()
        返回此Locale对象的字符串表示形式，由语言，国家/地区，变体，脚本和扩展名组成，如下所示：
        language + "_" + country + "_" + (variant + "_#" | "#") + script + "_" + extensions
        语言总是小写，国家总是大写，脚本总是标题，扩展总是小写。 扩展和私有使用子标签将按照规范顺序排列，如toLanguageTag()中所述 。

        当语言环境既没有脚本也没有扩展名，结果与Java 6和之前的相同。

        如果语言和国家/地区字段都丢失，则此函数将返回空字符串，即使存在变体，脚本或扩展名字段（您不能只具有变体的语言环境，形成的语言或国家代码）。

        如果脚本或扩展名存在且变体丢失，则在“＃”之前不会添加下划线。

        这种行为被设计为支持调试，并与先前使用兼容toString的预期只有语言，国家和变量字段。 要将交换用作字符串表示为字符串，请使用toLanguageTag() 。

        例子：

        • en
        • de_DE
        • _GB
        • en_US_WIN
        • de__POSIX
        • zh_CN_#Hans
        • zh_TW_#Hant_x-java
        • th_TH_TH_#u-nu-thai
        重写：
        toString在 Object
        结果
        用于调试的语言环境的字符串表示形式。
        另请参见：
        getDisplayName() ， toLanguageTag()

      • toLanguageTag

        public String toLanguageTag​()
        返回一个格式正确的IETF BCP 47语言标签，代表这个区域。

        如果此Locale具有不满足IETF BCP 47语言标签语法要求的语言，国家或变体，则此方法将按如下所述处理这些字段：

        语言：如果语言为空，或者不是well-formed （例如“a”或“e2”），则将以“und”（未确定）的形式发出。

        国家：如果国家不是well-formed （例如“12”或“美国”），将省略。

        变式：如果变量为 well-formed ，则每个子段（以' - '或'_'分隔）作为子标签发出。 除此以外：

        • 如果所有子分段匹配[0-9a-zA-Z]{1,8} （例如“WIN”或“Oracle_JDK_Standard_Edition”），则第一个不合格的子分段和所有以下内容将附加到专用子分段。 第一个附加的子标签将为“lvariant”，后面是子片段，以连字符分隔。 例如，“x-lvariant-WIN”，“Oracle-x-lvariant-JDK-Standard-Edition”。
        • 如果任何子段不匹配[0-9a-zA-Z]{1,8} ，则该变体将被截断，并且将省略有问题的子段和所有后续子段。 如果余数不为空，则它将作为上述的私有使用子标签发布（即使剩余部分结果良好）。 例如，“Solaris_isjustthecoolestthing”作为“x-lvariant-Solaris”发布，而不是“solaris”。

        特殊转换： Java支持一些旧的语言环境表示，包括不推荐使用的ISO语言代码，以实现兼容性。 此方法执行以下转换：

        • 不推荐的ISO语言代码“iw”，“ji”和“in”分别转换为“he”，“yi”和“id”。
        • 语言为“no”，国家“NO”和挪威Nynorsk（挪威）的变体“NY”被转换为语言标签“nn-NO”。

        注意：虽然由此方法创建的语言标签格式正确（满足IETF BCP 47规范定义的语法要求），但并不一定是有效的BCP 47语言标记。 例如，

          new Locale("xx", "YY").toLanguageTag();
        将返回“xx-yy”，但是语言子标签“xx”和区域子标签“YY”无效，因为它们未注册在IANA语言子标签注册表中。
        结果
        一个表示该区域的BCP47语言标签
        从以下版本开始：
        1.7
        另请参见：
        forLanguageTag(String)

      • forLanguageTag

        public static Locale forLanguageTag​(String languageTag)
        返回指定的IETF BCP 47语言标记字符串的语言环境。

        如果指定的语言标签包含任何不正确的子标签，则忽略第一个这样的子标签和所有后续子标签。 与Locale.Builder.setLanguageTag(java.lang.String)相比 ，在这种情况下会引发异常。

        执行以下转换 ：

        • 语言代码“und”映射到语言“”。
        • 语言代码“he”，“yi”和“id”分别映射到“iw”，“ji”和“in”。 （这是在Locale的构造函数中完成的规范化。）
        • 以“lvariant”为前缀的私有使用子标题的部分（如果有的话）被删除，并附加到结果语言环境的变量字段中（无案例归一化）。 如果它是空的，那么私人使用子标签将被丢弃：
            Locale loc;
     loc = Locale.forLanguageTag("en-US-x-lvariant-POSIX");
     loc.getVariant(); // returns "POSIX"
     loc.getExtension('x'); // returns null

     loc = Locale.forLanguageTag("de-POSIX-x-URP-lvariant-Abc-Def");
     loc.getVariant(); // returns "POSIX_Abc_Def"
     loc.getExtension('x'); // returns "urp"
        • 当languageTag参数包含一个extlang子标签时，第一个这样的子标签用作语言，主语言子标签和其他extlang子标签将被忽略：
            Locale.forLanguageTag("ar-aao").getLanguage(); // returns "aao"
     Locale.forLanguageTag("en-abc-def-us").toString(); // returns "abc_US"
        • 除了不变的变量标签外，情况被归一化。 语言标准化为小写，脚本到标题，国家大写，小写扩展。
        • 如果在处理之后，区域设置将与ja_JP_JP或th_TH_TH完全匹配，没有扩展名，那么添加适当的扩展名，就像构造函数被调用一样：
            Locale.forLanguageTag("ja-JP-x-lvariant-JP").toLanguageTag();
    // returns "ja-JP-u-ca-japanese-x-lvariant-JP"
    Locale.forLanguageTag("th-TH-x-lvariant-TH").toLanguageTag();
    // returns "th-TH-u-nu-thai-x-lvariant-TH"

        这实现了BCP47的“语言标签”生成，因此支持grandfathered（常规和不规则）以及私人使用语言标签。 独立的私人使用标签被表示为空语言和扩展名“x-whatever”，并且旧的标签被转换为它们存在的规范替换。

        具有标准替代品的Grandfathered标签如下：

        Grandfathered tags with canonical replacements grandfathered tag modern replacement art-lojban jbo i-ami ami i-bnn bnn i-hak hak i-klingon tlh i-lux lb i-navajo nv i-pwn pwn i-tao tao i-tay tay i-tsu tsu no-bok nb no-nyn nn sgn-BE-FR sfb sgn-BE-NL vgt sgn-CH-DE sgg zh-guoyu cmn zh-hakka hak zh-min-nan nan zh-xiang hsn

        没有现代更换的Grandfathered标签将转换如下：

        Grandfathered tags with no modern replacement grandfathered tag converts to cel-gaulish xtg-x-cel-gaulish en-GB-oed en-GB-x-oed i-default en-x-i-default i-enochian und-x-i-enochian i-mingo see-x-i-mingo zh-min nan-x-zh-min

        有关所有旧融合标签的列表，请参阅IANA语言分条注册表（搜索“类型：grandfathered”）。

        注意 ：不保证toLanguageTag和forLanguageTag将往返。

        参数
        languageTag - 语言标签
        结果
        最能代表语言标签的地区。
        异常
        NullPointerException - 如果 languageTag是 null
        从以下版本开始：
        1.7
        另请参见：
        toLanguageTag() ， Locale.Builder.setLanguageTag(String)

      • getISO3Language

        public String getISO3Language​()
                       throws MissingResourceException
        返回此语言环境的三个字母缩写。 如果语言符合ISO 639-1双字母代码，则返回相应的ISO 639-2 / T三字母小写代码。 ISO 639-2语言代码可以在线查看，请参见“语言名称代码第2部分：Alpha-3代码”。 如果语言环境指定了三个字母的语言，则会按原样返回该语言。 如果语言环境未指定语言，则返回空字符串。
        结果
        这个语言环境的三个字母缩写。
        异常
        MissingResourceException - 如果三个字母的语言缩写不适用于此语言环境，则抛出MissingResourceException异常。

      • getISO3Country

        public String getISO3Country​()
                      throws MissingResourceException
        返回此区域设置的国家/地区的三个字母的缩写。 如果国家符合ISO 3166-1 alpha-2代码，则返回相应的ISO 3166-1 alpha-3大写代码。 如果语言环境没有指定国家，这将是空字符串。

        ISO 3166-1代码可以在线查找。

        结果
        这个地区的国家的三个字母的缩写。
        异常
        MissingResourceException - 如果三个字母的国家/地区缩写不适用于此语言环境，则抛出MissingResourceException异常。

      • getDisplayLanguage

        public final String getDisplayLanguage​()
        返回适合显示给用户的语言环境语言的名称。 如果可能，返回的名称将被本地化为默认的DISPLAY区域设置。 例如，如果语言环境是fr_FR，默认的DISPLAY语言环境是en_US，getDisplayLanguage（）将返回“French”; 如果语言环境是en_US，默认的DISPLAY语言环境是fr_FR，getDisplayLanguage（）将返回“anglais”。 如果返回的名称无法针对默认的DISPLAY语言环境进行本地化（例如，我们没有克罗地亚语的日语名称），则此功能将返回英文名称，并使用ISO代码作为最后的手段值。 如果语言环境未指定语言，则此函数返回空字符串。
        结果
        显示语言的名称。

      • getDisplayLanguage

        public String getDisplayLanguage​(Locale inLocale)
        返回适合显示给用户的语言环境语言的名称。 如果可能，返回的名称将根据“地址”进行本地化。 例如，如果语言环境是fr_FR，而inLocale是en_US，getDisplayLanguage（）将返回“French”; 如果语言环境是en_US，而inLocale是fr_FR，getDisplayLanguage（）将返回“anglais”。 如果返回的名称不能根据inLocale进行本地化（例如，我们没有克罗地亚语的日语名称），则此功能将退回到英文名称，最后以ISO代码作为最后的手段值。 如果语言环境未指定语言，则此函数返回空字符串。
        参数
        inLocale - 要检索显示语言的区域设置。
        结果
        适用于给定语言环境的显示语言的名称。
        异常
        NullPointerException - 如果 inLocale是 null

      • getDisplayScript

        public String getDisplayScript​()
        返回适合显示给用户的区域设置脚本的名称。 如果可能，该名称将被本地化为默认的DISPLAY区域设置。 如果此区域设置未指定脚本代码，则返回空字符串。
        结果
        当前默认 值为DISPLAY的脚本代码的显示名称
        从以下版本开始：
        1.7

      • getDisplayScript

        public String getDisplayScript​(Locale inLocale)
        返回适合显示给用户的区域设置脚本的名称。 如果可能，该名称将被本地化为给定的区域设置。 如果此区域设置未指定脚本代码，则返回空字符串。
        参数
        inLocale - 要检索显示脚本的区域设置。
        结果
        当前默认 值为DISPLAY的脚本代码的显示名称
        异常
        NullPointerException - 如果 inLocale是 null
        从以下版本开始：
        1.7

      • getDisplayCountry

        public final String getDisplayCountry​()
        返回适合显示给用户的区域设置国家/地区的名称。 如果可能，返回的名称将被本地化为默认的DISPLAY区域设置。 例如，如果语言环境是fr_FR，并且默认的DISPLAY语言环境是en_US，则getDisplayCountry（）将返回“France”; 如果语言环境是en_US，默认的DISPLAY语言环境是fr_FR，getDisplayCountry（）将返回“Etats-Unis”。 如果返回的名称无法针对默认的DISPLAY区域设置进行本地化（例如，我们没有克罗地亚的日语名称），则此功能将返回英文名称，并使用ISO代码作为最后的手段。 如果区域设置未指定国家/地区，则此函数返回空字符串。
        结果
        适合本地区的国家的名称。

      • getDisplayCountry

        public String getDisplayCountry​(Locale inLocale)
        返回适合显示给用户的区域设置国家/地区的名称。 如果可能，返回的名称将根据“地址”进行本地化。 例如，如果语言环境是fr_FR，而inLocale是en_US，getDisplayCountry（）将返回“France”; 如果语言环境是en_US，而inLocale是fr_FR，getDisplayCountry（）将返回“Etats-Unis”。 如果返回的名称不能根据inLocale进行本地化。 （比如我们没有克罗地亚的日文名称），这个功能落在英文名字上，最后是ISO代码作为最后的手段。 如果区域设置未指定国家/地区，则此函数返回空字符串。
        参数
        inLocale - 要检索显示国家/地区的区域设置。
        结果
        适用于特定地区的国家的名称。
        异常
        NullPointerException - 如果 inLocale是 null

      • getDisplayVariant

        public final String getDisplayVariant​()
        返回适合显示给用户的区域设置变体代码的名称。 如果可能，该名称将被本地化为默认的DISPLAY区域设置。 如果语言环境未指定变体代码，则此函数返回空字符串。
        结果
        适用于语言环境的显示变体代码的名称。

      • getDisplayVariant

        public String getDisplayVariant​(Locale inLocale)
        返回适合显示给用户的区域设置变体代码的名称。 如果可能，该名称将在本地化为在Locale。 如果语言环境未指定变体代码，则此函数返回空字符串。
        参数
        inLocale - 用于检索显示变体代码的区域设置。
        结果
        适用于给定语言环境的显示变体代码的名称。
        异常
        NullPointerException - 如果 inLocale是 null

      • getDisplayName

        public final String getDisplayName​()
        返回适合显示给用户的区域设置的名称。 这将是getDisplayLanguage（），getDisplayScript（），getDisplayCountry（）和getDisplayVariant（）返回的值组合成一个字符串。 非空值按顺序使用，第二个和后续名称在括号中。 例如：
        language (script, country, variant)
        language (country)
        language (variant)
        script (country)
        country
        取决于在区域设置中指定的字段。 如果语言，脚本，国家和变体字段都为空，则此函数返回空字符串。
        结果
        适合显示的区域的名称。

      • getDisplayName

        public String getDisplayName​(Locale inLocale)
        返回适合显示给用户的区域设置的名称。 这将是getDisplayLanguage（），getDisplayScript（），getDisplayCountry（）和getDisplayVariant（）返回的值组合成一个字符串。 非空值按顺序使用，第二个和后续名称在括号中。 例如：
        language (script, country, variant)
        language (country)
        language (variant)
        script (country)
        country
        取决于在区域设置中指定的字段。 如果语言，脚本，国家和变体字段都为空，则此函数返回空字符串。
        参数
        inLocale - 要检索显示名称的区域设置。
        结果
        适合显示的区域的名称。
        异常
        NullPointerException - 如果 inLocale是 null

      • clone

        public Object clone​()
        覆盖可克隆。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • hashCode

        public int hashCode​()
        覆盖hashCode。 由于语言环境通常用于散列表，因此将速度缓存。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        如果此区域设置等于另一个对象，则返回true。 语言区域被视为与另一个具有相同语言，脚本，国家，变体和扩展名的区域设置相同，并且与所有其他对象不相等。
        重写：
        equals在 Object
        参数
        obj - 用于比较的参考对象。
        结果
        如果此区域设置等于指定的对象，则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • filter

        public static List<Locale> filter​(List<Locale.LanguageRange> priorityList,
                                  Collection<Locale> locales,
                                  Locale.FilteringMode mode)
        使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
        参数
        priorityList - 用户的语言优先级列表，其中每个语言标签根据优先级或权重按降序排序
        locales - Locale用于匹配的实例
        mode - 过滤模式
        结果
        一个Locale实例的列表，用于匹配按照优先级或权重降序排序的语言标签，如果没有匹配，则为空列表。 列表是可修改的。
        异常
        NullPointerException - 如果 priorityList或 locales是 null
        IllegalArgumentException - 如果在指定 Locale.FilteringMode.REJECT_EXTENDED_RANGES时给定列表中包含一个或多个扩展语言范围
        从以下版本开始：
        1.8

      • filter

        public static List<Locale> filter​(List<Locale.LanguageRange> priorityList,
                                  Collection<Locale> locales)
        返回匹配的列表 Locale使用RFC 4647这等同所限定的过滤机制，以实例 filter(List, Collection, FilteringMode)时 mode是 Locale.FilteringMode.AUTOSELECT_FILTERING 。
        参数
        priorityList - 用户语言优先级列表，其中每个语言标签按照优先级或权重按降序排序
        locales - Locale用于匹配的实例
        结果
        一个Locale实例的列表，用于匹配按照优先级或权重降序排序的语言标签，如果没有匹配，则为空列表。 列表是可修改的。
        异常
        NullPointerException - 如果 priorityList或 locales是 null
        从以下版本开始：
        1.8

      • filterTags

        public static List<String> filterTags​(List<Locale.LanguageRange> priorityList,
                                      Collection<String> tags,
                                      Locale.FilteringMode mode)
        使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
        参数
        priorityList - 用户的语言优先级列表，其中每个语言标签根据优先级或权重按降序排序
        tags - 语言标签
        mode - 过滤模式
        结果
        基于优先级或权重按降序排序的匹配语言标签的列表，或者没有匹配的空列表。 列表是可修改的。
        异常
        NullPointerException - 如果 priorityList或 tags是 null
        IllegalArgumentException - 如果指定了 Locale.FilteringMode.REJECT_EXTENDED_RANGES ，则给定列表中包含一个或多个扩展语言范围
        从以下版本开始：
        1.8

      • filterTags

        public static List<String> filterTags​(List<Locale.LanguageRange> priorityList,
                                      Collection<String> tags)
        返回使用RFC 4647。这相当于定义了基本的过滤机制来匹配语言标签的列表 filterTags(List, Collection, FilteringMode)时 mode为 Locale.FilteringMode.AUTOSELECT_FILTERING 。
        参数
        priorityList - 用户的语言优先级列表，其中每个语言标签按照优先级或权重按降序排序
        tags - 语言标签
        结果
        基于优先级或权重按降序排序的匹配语言标签的列表，或者没有匹配的空列表。 列表是可修改的。
        异常
        NullPointerException - 如果 priorityList或 tags是 null
        从以下版本开始：
        1.8

      • lookup

        public static Locale lookup​(List<Locale.LanguageRange> priorityList,
                            Collection<Locale> locales)
        使用RFC 4647中定义的查找机制返回 Locale最佳匹配语言标记的实例。
        参数
        priorityList - 用户语言优先级列表，其中每个语言标签按照优先级或权重按降序排序
        locales - Locale用于匹配的实例
        结果
        根据优先级或权重选择最匹配的 Locale实例，如果没有匹配， null 。
        异常
        NullPointerException - 如果 priorityList或 tags是 null
        从以下版本开始：
        1.8

      • lookupTag

        public static String lookupTag​(List<Locale.LanguageRange> priorityList,
                               Collection<String> tags)
        使用RFC 4647中定义的查找机制返回最匹配的语言标签。
        参数
        priorityList - 用户的语言优先级列表，其中每个语言标签按照优先级或权重按降序排序
        tags - 用于匹配的语言 tags
        结果
        基于优先级或权重选择的最佳匹配语言标签，如果没有匹配， null 。
        异常
        NullPointerException - 如果 priorityList或 tags是 null
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Locale.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Locale.Builder

  • java.lang.Object
    • java.util.Locale.Builder
  • Enclosing class:
    Locale

    public static final class Locale.Builder
extends Object
    Builder用于从由setter配置的值构建Locale实例。 与Locale构造函数不同， Builder检查由setter配置的值是否满足Locale类定义的语法要求。 由Locale创建的Locale对象Builder良好，可以转换成一个格式正确的IETF BCP 47语言标签，而不会丢失信息。

    注意： Locale类不对变体提供任何句法限制，而BCP 47要求每个变体子标签为5至8个字母数字或单个数字，后跟3个字母数字。 对于不满足该限制的变体，方法setVariant抛出IllformedLocaleException 。 如果需要支持这种变体，请使用Locale构造函数。 但是，请记住，以这种方式创建的一个Locale对象可能会在转换为BCP 47语言标记时丢失变体信息。

    下面的例子说明如何创建一个Locale与对象Builder 。

         Locale aLocale = new Builder().setLanguage("sr").setScript("Latn").setRegion("RS").build();

    建筑商可以重用; clear()所有字段重置为其默认值。

    从以下版本开始：
    1.7
    另请参见：
    Locale.forLanguageTag(java.lang.String)

    • 构造方法摘要

      构造方法
      Constructor 描述
      Builder​()
      构造一个空的构建器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Locale.Builder addUnicodeLocaleAttribute​(String attribute)
      添加unicode区域设置属性（如果尚未存在），否则不起作用。
      Locale build​()
      返回从此构建器上设置的字段创建的 Locale实例。
      Locale.Builder clear​()
      将构建器重置为初始状态。
      Locale.Builder clearExtensions​()
      将扩展名重置为初始，空状态。
      Locale.Builder removeUnicodeLocaleAttribute​(String attribute)
      删除unicode区域设置属性（如果存在），否则不起作用。
      Locale.Builder setExtension​(char key, String value)
      设置给定键的扩展名。
      Locale.Builder setLanguage​(String language)
      设置语言。
      Locale.Builder setLanguageTag​(String languageTag)
      重置生成器以匹配提供的IETF BCP 47语言标记。
      Locale.Builder setLocale​(Locale locale)
      复位 Builder以匹配提供的 locale 。
      Locale.Builder setRegion​(String region)
      设置区域。
      Locale.Builder setScript​(String script)
      设置脚本。
      Locale.Builder setUnicodeLocaleKeyword​(String key, String type)
      设置给定键的Unicode区域设置关键字类型。
      Locale.Builder setVariant​(String variant)
      设置变体。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Builder

        public Builder​()
        构造一个空的构建器。 所有字段，扩展名和私人使用信息的默认值为空字符串。

    • 方法详细信息

      • setLocale

        public Locale.Builder setLocale​(Locale locale)
        复位Builder以匹配提供的locale 。 现有状态被丢弃。

        地区的所有领域必须格局良好，请参阅Locale 。

        任何形式不IllformedLocaleException地区都会导致IllformedLocaleException被抛出，除了以下三种被兼容性原因接受的情况外：

        • 地区（“ja”，“JP”，“JP”）被视为“ja-JP-u-ca-japanese”
        • 区域（“th”，“TH”，“TH”）被视为“th-TH-uu-nu-thai”
        • 区域设置（“否”，“否”，“纽约”）被视为“nn-NO”
        参数
        locale - 地区
        结果
        这个建设者。
        异常
        IllformedLocaleException - 如果 locale有任何不合格的字段。
        NullPointerException - 如果 locale为空。

      • setLanguageTag

        public Locale.Builder setLanguageTag​(String languageTag)
        重置生成器以匹配提供的IETF BCP 47语言标记。 丢弃现有状态。 空和空字符串会导致构建器复位，如clear() 。 Grandfathered标签（参见Locale.forLanguageTag(java.lang.String) ）在处理之前被转换为其规范形式。 否则，语言标签必须格式正确（请参阅Locale ）或抛出异常（不像Locale.forLanguageTag ，它仅丢弃标签的不完整和后续部分）。
        参数
        languageTag - 语言标签
        结果
        这个建设者。
        异常
        IllformedLocaleException - 如果 languageTag是 languageTag
        另请参见：
        Locale.forLanguageTag(String)

      • setLanguage

        public Locale.Builder setLanguage​(String language)
        设置语言。 如果language是空字符串或null，则此Builder的语言Builder被删除。 否则，该语言必须是well-formed或抛出异常。

        典型的语言值是ISO639中定义的两个或三个字母的语言代码。

        参数
        language - 语言
        结果
        这个建设者。
        异常
        IllformedLocaleException - 如果 language是 language

      • setScript

        public Locale.Builder setScript​(String script)
        设置脚本。 如果script为空或空字符串，则此Builder的脚本Builder被删除。 否则，脚本必须是well-formed或抛出异常。

        典型的脚本值是由ISO 15924定义的四字母脚本代码。

        参数
        script - 脚本
        结果
        这个建设者。
        异常
        IllformedLocaleException - 如果 script是 script

      • setRegion

        public Locale.Builder setRegion​(String region)
        设置区域。 如果区域为空或空字符串，则删除此Builder的区域。 否则，该区域必须是well-formed或抛出异常。

        典型的区域值是双字母ISO 3166代码或三位数UN M.49区号。

        由Locale创建的Builder的国家值总是归一化为大写。

        参数
        region - 该地区
        结果
        这个建设者。
        异常
        IllformedLocaleException - 如果 region是 region

      • setVariant

        public Locale.Builder setVariant​(String variant)
        设置变体。 如果变量为空或空字符串，则此Builder的变体Builder被删除。 否则，它必须由一个或多个well-formed子标记组成，否则抛出异常。

        注意：此方法检查variant满足IETF BCP 47变体子标记的语法要求，并将该值标准化为小写字母。 然而， Locale类不对变体施加任何句法限制，而Locale的变体值区分大小写。 要设置此类变体，请使用Locale构造函数。

        参数
        variant - 变体
        结果
        这个建设者。
        异常
        IllformedLocaleException - 如果 variant是 variant

      • setExtension

        public Locale.Builder setExtension​(char key,
                                   String value)
        设置给定键的扩展名。 如果值为空或空字符串，则扩展名将被删除。 否则，扩展名必须为well-formed或抛出异常。

        注意： UNICODE_LOCALE_EXTENSION （'u'）键用于Unicode语言环境扩展。 设置此键的值将替换扩展中定义的所有现有Unicode区域设置键/类型对。

        注意：密钥PRIVATE_USE_EXTENSION （'x'）用于私人使用代码。 为了形式良好，该键的值只需要具有一到八个字母数字字符的子标签，而不是一般情况下的两到八个字符。

        参数
        key - 扩展键
        value - 扩展值
        结果
        这个建设者。
        异常
        IllformedLocaleException - 如果 key是非法的或 value是不正式的
        另请参见：
        setUnicodeLocaleKeyword(String, String)

      • setUnicodeLocaleKeyword

        public Locale.Builder setUnicodeLocaleKeyword​(String key,
                                              String type)
        设置给定键的Unicode区域设置关键字类型。 如果类型为空，则会删除Unicode关键字。 否则，密钥必须为非空，并且密钥和类型必须为well-formed或抛出异常。

        键和类型转换为小写。

        注意 ：通过setExtension(char, java.lang.String)设置'u'扩展名将使用扩展名中定义的所有Unicode区域设置关键字替换。

        参数
        key - Unicode区域设置键
        type - Unicode区域设置类型
        结果
        这个建设者。
        异常
        IllformedLocaleException - 如果 key或 type是 type
        NullPointerException - 如果 key为空
        另请参见：
        setExtension(char, String)

      • addUnicodeLocaleAttribute

        public Locale.Builder addUnicodeLocaleAttribute​(String attribute)
        添加unicode区域设置属性（如果尚未存在），否则不起作用。 该属性不能为空，必须为well-formed或抛出异常。
        参数
        attribute - 属性
        结果
        这个建设者。
        异常
        NullPointerException - 如果 attribute为空
        IllformedLocaleException - 如果 attribute是 attribute
        另请参见：
        setExtension(char, String)

      • removeUnicodeLocaleAttribute

        public Locale.Builder removeUnicodeLocaleAttribute​(String attribute)
        删除unicode区域设置属性（如果存在），否则不起作用。 属性不能为空，必须为well-formed或抛出异常。

        删除的属性比较不区分大小写。

        参数
        attribute - 属性
        结果
        这个建设者。
        异常
        NullPointerException - 如果 attribute为空
        IllformedLocaleException - 如果 attribute是 attribute
        另请参见：
        setExtension(char, String)

      • clear

        public Locale.Builder clear​()
        将构建器重置为初始状态。
        结果
        这个建设者。

      • clearExtensions

        public Locale.Builder clearExtensions​()
        将扩展名重置为初始，空状态。 语言，脚本，区域和变体不变。
        结果
        这个建设者。
        另请参见：
        setExtension(char, String)

      • build

        public Locale build​()
        返回从此构建器上设置的字段创建的实例Locale 。

        这样就可以在构建区域设置时应用Locale.forLanguageTag(java.lang.String)中列出的转换。 （Grandfathered标签处理在setLanguageTag(java.lang.String)。 ）

        结果
        一个地方。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Locale.Category (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.util

Enum Locale.Category

  • java.lang.Object
    • java.lang.Enum<Locale.Category>
      • java.util.Locale.Category
  • All Implemented Interfaces:
    Serializable ， Comparable<Locale.Category>
    Enclosing class:
    Locale

    public static enum Locale.Category
extends Enum<Locale.Category>
    枚举地区类别。 这些区域设置类别用于获取/设置由类别表示的特定功能的默认语言环境。
    从以下版本开始：
    1.7
    另请参见：
    Locale.getDefault(Locale.Category) ， Locale.setDefault(Locale.Category, Locale)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DISPLAY
      用于表示用于显示用户界面的默认区域设置的类别。
      FORMAT
      用于表示格式化日期，数字和/或货币的默认区域设置的类别。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Locale.Category valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Locale.Category[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DISPLAY

        public static final Locale.Category DISPLAY
        用于表示用于显示用户界面的默认区域设置的类别。

      • FORMAT

        public static final Locale.Category FORMAT
        用于表示格式化日期，数字和/或货币的默认区域设置的类别。

    • 方法详细信息

      • values

        public static Locale.Category[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Locale.Category c : Locale.Category.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Locale.Category valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Locale.FilteringMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.util

Enum Locale.FilteringMode

  • java.lang.Object
    • java.lang.Enum<Locale.FilteringMode>
      • java.util.Locale.FilteringMode
  • All Implemented Interfaces:
    Serializable ， Comparable<Locale.FilteringMode>
    Enclosing class:
    Locale

    public static enum Locale.FilteringMode
extends Enum<Locale.FilteringMode>
    此枚举提供常量来选择区域设置匹配的过滤模式。 详情请参阅RFC 4647 Matching of Language Tags 。

    例如，考虑两个语言优先级列表，每个语言优先级列表只包含一个语言范围和一组以下语言标签：

      de (German)
    de-DE (German, Germany)
    de-Deva (German, in Devanagari script)
    de-Deva-DE (German, in Devanagari script, Germany)
    de-DE-1996 (German, Germany, orthography of 1996)
    de-Latn-DE (German, in Latin script, Germany)
    de-Latn-DE-1996 (German, in Latin script, Germany, orthography of 1996)
    过滤方法的行为如下： Filtering method behavior Filtering Mode Language Priority List: "de-DE" Language Priority List: "de-*-DE" AUTOSELECT_FILTERING Performs basic filtering and returns "de-DE" and "de-DE-1996". Performs extended filtering and returns "de-DE", "de-Deva-DE", "de-DE-1996", "de-Latn-DE", and "de-Latn-DE-1996". EXTENDED_FILTERING Performs extended filtering and returns "de-DE", "de-Deva-DE", "de-DE-1996", "de-Latn-DE", and "de-Latn-DE-1996". Same as above. IGNORE_EXTENDED_RANGES Performs basic filtering and returns "de-DE" and "de-DE-1996". Performs basic filtering and returns null because nothing matches. MAP_EXTENDED_RANGES Same as above. Performs basic filtering and returns "de-DE" and "de-DE-1996" because "de-*-DE" is mapped to "de-DE". REJECT_EXTENDED_RANGES Same as above. Throws IllegalArgumentException because "de-*-DE" is not a valid basic language range.
    从以下版本开始：
    1.8
    另请参见：
    Locale.filter(List, Collection, FilteringMode) ， Locale.filterTags(List, Collection, FilteringMode)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      AUTOSELECT_FILTERING
      指定基于由语言范围组成的给定语言优先级列表的自动过滤模式。
      EXTENDED_FILTERING
      指定扩展过滤。
      IGNORE_EXTENDED_RANGES
      指定基本过滤：请注意，给定语言优先级列表中包含的任何扩展语言范围都将被忽略。
      MAP_EXTENDED_RANGES
      指定基本过滤：如果任何扩展语言范围包含在给定的语言优先级列表中，它们将映射到基本语言范围。
      REJECT_EXTENDED_RANGES
      指定基本过滤：如果任何扩展语言范围包含在给定的语言优先级列表中，则列表被拒绝，过滤方法将抛出IllegalArgumentException 。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Locale.FilteringMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Locale.FilteringMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • AUTOSELECT_FILTERING

        public static final Locale.FilteringMode AUTOSELECT_FILTERING
        指定基于由语言范围组成的给定语言优先级列表的自动过滤模式。 如果所有范围都是基本的，则选择基本过滤。 否则，选择扩展过滤。

      • EXTENDED_FILTERING

        public static final Locale.FilteringMode EXTENDED_FILTERING
        指定扩展过滤。

      • IGNORE_EXTENDED_RANGES

        public static final Locale.FilteringMode IGNORE_EXTENDED_RANGES
        指定基本过滤：请注意，给定语言优先级列表中包含的任何扩展语言范围都将被忽略。

      • MAP_EXTENDED_RANGES

        public static final Locale.FilteringMode MAP_EXTENDED_RANGES
        指定基本过滤：如果任何扩展语言范围包含在给定的语言优先级列表中，它们将映射到基本语言范围。 特别地，以子标记"*"开始的语言范围被视为语言范围"*" 。 例如， "*-US"被视为"*" 。 如果"*"不是第一"*"标签， "*"和额外的"-"被删除。 例如， "ja-*-JP"映射到"ja-JP" 。

      • REJECT_EXTENDED_RANGES

        public static final Locale.FilteringMode REJECT_EXTENDED_RANGES
        指定基本过滤：如果任何扩展语言范围包含在给定的语言优先级列表中，列表将被拒绝，过滤方法将抛出IllegalArgumentException 。

    • 方法详细信息

      • values

        public static Locale.FilteringMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Locale.FilteringMode c : Locale.FilteringMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Locale.FilteringMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Locale.IsoCountryCode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.util

Enum Locale.IsoCountryCode

  • java.lang.Object
    • java.lang.Enum<Locale.IsoCountryCode>
      • java.util.Locale.IsoCountryCode
  • All Implemented Interfaces:
    Serializable ， Comparable<Locale.IsoCountryCode>
    Enclosing class:
    Locale

    public static enum Locale.IsoCountryCode
extends Enum<Locale.IsoCountryCode>
    用于指定ISO 3166中定义的类型的枚举。该枚举用于检索双字母ISO3166-1 alpha-2，三字母ISO3166-1 alpha-3，四字母ISO3166-3国家代码。
    从以下版本开始：
    9
    另请参见：
    Locale.getISOCountries(Locale.IsoCountryCode)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      PART1_ALPHA2
      PART1_ALPHA2用于表示ISO3166-1 alpha-2两个字母的国家代码。
      PART1_ALPHA3
      PART1_ALPHA3用于表示ISO3166-1 alpha-3三字母国家代码。
      PART3
      PART3用于表示ISO3166-3四个字母的国家/地区代码。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Locale.IsoCountryCode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Locale.IsoCountryCode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PART1_ALPHA2

        public static final Locale.IsoCountryCode PART1_ALPHA2
        PART1_ALPHA2用于表示ISO3166-1 alpha-2两个字母的国家代码。

      • PART1_ALPHA3

        public static final Locale.IsoCountryCode PART1_ALPHA3
        PART1_ALPHA3用于表示ISO3166-1 alpha-3三字母国家代码。

      • PART3

        public static final Locale.IsoCountryCode PART3
        PART3用于表示ISO3166-3四个字母的国家/地区代码。

    • 方法详细信息

      • values

        public static Locale.IsoCountryCode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Locale.IsoCountryCode c : Locale.IsoCountryCode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Locale.IsoCountryCode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Locale.LanguageRange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Locale.LanguageRange

  • java.lang.Object
    • java.util.Locale.LanguageRange
  • Enclosing class:
    Locale

    public static final class Locale.LanguageRange
extends Object
    该类表示在RFC 4647 Matching of Language Tags中定义的语言范围 。 语言范围是用于通过使用Locale Matching中描述的机制来选择满足特定要求的语言标签的标识符 。 表示用户偏好并由语言范围组成的列表称为语言优先级列表 。

    有两种类型的语言范围：基本和扩展。 在RFC 4647中，语言范围的语法如下所示： ABNF

         basic-language-range    = (1*8ALPHA *("-" 1*8alphanum)) / "*"
     extended-language-range = (1*8ALPHA / "*")
                               *("-" (1*8alphanum / "*"))
     alphanum                = ALPHA / DIGIT
    例如， "en" （英文）， "ja-JP" （日本，日本）， "*" （与任何语言标签匹配的特殊语言范围）是基本语言范围，而"*-CH" （任何语言，瑞士）， "es-*" （西班牙语，任何地区）和"zh-Hant-*" （繁体中文，任何地区）是扩展语言范围。
    从以下版本开始：
    1.8
    另请参见：
    Locale.filter(java.util.List<java.util.Locale.LanguageRange>, java.util.Collection<java.util.Locale>, java.util.Locale.FilteringMode) ，
Locale.filterTags(java.util.List<java.util.Locale.LanguageRange>, java.util.Collection<java.lang.String>, java.util.Locale.FilteringMode) ，
Locale.lookup(java.util.List<java.util.Locale.LanguageRange>, java.util.Collection<java.util.Locale>) ，
Locale.lookupTag(java.util.List<java.util.Locale.LanguageRange>, java.util.Collection<java.lang.String>)

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double MAX_WEIGHT
      持有权重最大值的常数为1.0，表示语言范围适合用户。
      static double MIN_WEIGHT
      保持最小权重值的常数为0.0，表示语言范围不适合用户。

    • 构造方法摘要

      构造方法
      Constructor 描述
      LanguageRange​(String range)
      构造一个 LanguageRange使用给定的 range 。
      LanguageRange​(String range, double weight)
      构造一个 LanguageRange使用给定 range和 weight 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此对象与指定的对象进行比较。
      String getRange​()
      返回此 LanguageRange的语言范围。
      double getWeight​()
      返回这个 LanguageRange的重量。
      int hashCode​()
      返回对象的哈希码值。
      static List<Locale.LanguageRange> mapEquivalents​(List<Locale.LanguageRange> priorityList, Map<String,List<String>> map)
      使用给定的 priorityList和 map生成新的自定义语言优先级列表。
      static List<Locale.LanguageRange> parse​(String ranges)
      解析给定的 ranges以生成语言优先级列表。
      static List<Locale.LanguageRange> parse​(String ranges, Map<String,List<String>> map)
      解析给定的 ranges以生成语言优先级列表，然后使用给定的 map自定义列表。
      String toString​()
      返回此 LanguageRange对象的信息字符串表示，如果范围被加权且重量小于最大权重， LanguageRange语言范围和权重组成。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MAX_WEIGHT

        public static final double MAX_WEIGHT
        持有权重最大值的常数为1.0，表示语言范围适合用户。
        另请参见：
        Constant Field Values

      • MIN_WEIGHT

        public static final double MIN_WEIGHT
        保持最小权重值的常数为0.0，表示语言范围不适合用户。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • LanguageRange

        public LanguageRange​(String range)
        构造一个LanguageRange使用给定的range 。 请注意，在建造时，不对IANA语言分条登记处进行验证。

        这相当于LanguageRange(range, MAX_WEIGHT) 。

        参数
        range - 一个语言范围
        异常
        NullPointerException - 如果给定的 range是 null
        IllegalArgumentException - 如果给定的 range不符合RFC 4647中提到的语言范围的语法

      • LanguageRange

        public LanguageRange​(String range,
                     double weight)
        构造一个LanguageRange使用给定range和weight 。 请注意，在建造时，不对IANA语言分条登记处进行验证。
        参数
        range - 一个语言范围
        weight - 权重值在 MIN_WEIGHT和 MAX_WEIGHT之间
        异常
        NullPointerException - 如果给定的 range是 null
        IllegalArgumentException - 如果给定的 range不符合RFC 4647中提及的语言范围的语法，或者如果给定的 weight小于 MIN_WEIGHT或大于 MAX_WEIGHT

    • 方法详细信息

      • getRange

        public String getRange​()
        返回此 LanguageRange的语言范围。
        结果
        语言范围。

      • getWeight

        public double getWeight​()
        返回这个 LanguageRange的权重。
        结果
        重量值。

      • parse

        public static List<Locale.LanguageRange> parse​(String ranges)
        解析给定的ranges以生成语言优先级列表。

        该方法对给定的ranges中的每个语言范围执行句法检查，但不使用IANA语言子标记注册表进行验证。

        要给出的ranges可以采取以下形式之一：

          "Accept-Language: ja,en;q=0.4"  (weighted list with Accept-Language prefix)
   "ja,en;q=0.4"                   (weighted list)
   "ja,en"                         (prioritized list)
        在加权列表中，每个语言范围都被赋予权重值。 权重值与RFC 2616中的“质量值” 相同 ，它表示用户喜欢的语言多少。 重量值在相应的语言范围后面指定为";q=" ，默认权重值为MAX_WEIGHT ，省略。

        与加权列表不同，优先级列表中的语言范围根据其优先级按降序排列。 第一语言范围具有最高优先级，最符合用户的偏好。

        在任一种情况下，语言范围按照优先级或权重在语言优先级列表中按降序进行排序。 如果一个语言范围ranges出现在给定的ranges ，则只有第一个包含在语言优先级列表中。

        返回的列表包括来自给定的ranges的语言范围及其在IANA语言小标签注册表中的等同物。 例如，如果给定的ranges是"Accept-Language: iw,en-us;q=0.7,en;q=0.3" ， "Accept-Language: iw,en-us;q=0.7,en;q=0.3"返回的列表中的元素是：

          Range                                   Weight
    "iw" (older tag for Hebrew)             1.0
    "he" (new preferred code for Hebrew)    1.0
    "en-us" (English, United States)        0.7
    "en" (English)                          0.3
        两个语言范围， "iw"和"he" ，在列表中具有相同的最高优先级。 通过将"he"添加到用户的语言优先级列表中，即使应用程序或系统仅提供"he"作为支持的区域设置（或语言标记），区域设置匹配方法可以将希伯来语作为匹配的语言环境（或语言标签）。
        参数
        ranges - 以逗号分隔的语言范围或语言范围的列表，以 RFC 2616中定义的“接受语言”标题的 形式
        结果
        由给定的ranges包含的语言范围组成的语言优先级列表及其等效语言范围（如果可用）。 列表是可修改的。
        异常
        NullPointerException - 如果 ranges为空
        IllegalArgumentException - 如果在给定的 ranges找到的语言范围或重量是不正确的

      • parse

        public static List<Locale.LanguageRange> parse​(String ranges,
                                               Map<String,List<String>> map)
        解析给定的ranges以生成语言优先级列表，然后使用给定的map自定义列表。 此方法相当于mapEquivalents(parse(ranges), map) 。
        参数
        ranges - 以逗号分隔的语言范围或语言范围的列表，以 RFC 2616中定义的“Accept-Language”标题的 形式
        map - 包含自定义语言范围信息的地图
        结果
        具有自定义功能的语言优先级列表。 列表是可修改的。
        异常
        NullPointerException - 如果 ranges为空
        IllegalArgumentException - 如果在给定的 ranges找到的语言范围或重量不正确
        另请参见：
        parse(String) ， mapEquivalents(java.util.List<java.util.Locale.LanguageRange>, java.util.Map<java.lang.String, java.util.List<java.lang.String>>)

      • mapEquivalents

        public static List<Locale.LanguageRange> mapEquivalents​(List<Locale.LanguageRange> priorityList,
                                                        Map<String,List<String>> map)
        使用给定的priorityList和map生成新的自定义语言优先级列表。 如果给定的map为空，则此方法返回给定的副本priorityList 。

        在地图中，一个键表示一个语言范围，而一个值是其等价物的列表。 '*'不能在地图上使用。 每个等效语言范围与其原始语言范围具有相同的权重值。

          An example of map:
    Key                            Value
      "zh" (Chinese)                 "zh",
                                     "zh-Hans"(Simplified Chinese)
      "zh-HK" (Chinese, Hong Kong)   "zh-HK"
      "zh-TW" (Chinese, Taiwan)      "zh-TW"
        使用IANA语言子标签注册表修改后进行定制。

        例如，如果用户的语言优先级列表包括五个语言范围（ "zh" ， "zh-CN" ， "en" ， "zh-TW" ，和"zh-HK" ），其使用上述地图例将包括定制新生成的语言优先级列表"zh" ， "zh-Hans" ， "zh-CN" ， "zh-Hans-CN" ， "en" ， "zh-TW" ，并"zh-HK" 。

        "zh-HK"和"zh-TW"不会转换为"zh-Hans-HK" ，也不"zh-Hans-TW" ，即使它们都包含在语言优先列表。 在这个例子中，映射用于明确区分简体中文和繁体中文。

        如果地图中未包含"zh" "zh"映射，则将执行简单的替换，并且自定义列表将不包括"zh"和"zh-CN" 。

        参数
        priorityList - 用户语言优先级列表
        map - 包含自定义语言范围信息的地图
        结果
        新的语言优先级列表与定制。 列表是可修改的。
        异常
        NullPointerException - 如果 priorityList是 null
        另请参见：
        parse(String, Map)

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。
        重写：
        hashCode Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将此对象与指定的对象进行比较。 如果且仅当参数不是null且是LanguageRange对象，其值包含与此对象相同的range和weight值，则结果为真。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        true如果这个对象的range和weight是相同的obj的; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回此 LanguageRange对象的信息字符串表示形式，如果范围被加权且重量小于最大权重， LanguageRange语言范围和权重组成。
        重写：
        toString在 Object
        结果
        这个 LanguageRange对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


LongSummaryStatistics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class LongSummaryStatistics

  • java.lang.Object
    • java.util.LongSummaryStatistics
  • All Implemented Interfaces:
    IntConsumer ， LongConsumer

    public class LongSummaryStatistics
extends Object
implements LongConsumer, IntConsumer
    统计数据的收集状态，如count，min，max，sum和average。

    这个课程旨在与（但不需要） streams一起工作 。 例如，您可以使用以下方式计算长流的汇总统计信息：

       LongSummaryStatistics stats = longStream.collect(LongSummaryStatistics::new, LongSummaryStatistics::accept, LongSummaryStatistics::combine);

    LongSummaryStatistics可用作reduction目标为stream 。 例如：

       LongSummaryStatistics stats = people.stream() .collect(Collectors.summarizingLong(Person::getAge));
    这个计算单次通过了人数，以及年龄的最小值，最大值，总和和平均值。
    Implementation Note:
    这个实现不是线程安全的。 但是，平行流中使用Collectors.summarizingLong()是安全的，因为Stream.collect()的并行实现为安全和高效的并行执行提供了必要的分区，隔离和结果合并。

    此实现不检查总和的溢出。

    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      LongSummaryStatistics​()
      使用零计数，零和， Long.MAX_VALUE分钟， Long.MIN_VALUE最大和零平均值构造空实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void accept​(int value)
      在摘要信息中记录新的 int值。
      void accept​(long value)
      在摘要信息中记录一个新的 long值。
      void combine​(LongSummaryStatistics other)
      将另一个 LongSummaryStatistics的状态合并到这一个中。
      double getAverage​()
      返回记录的值的算术平均值，如果没有记录值，则返回零。
      long getCount​()
      返回记录的值的计数。
      long getMax​()
      返回记录的最大值，如果没有记录值，则返回 Long.MIN_VALUE
      long getMin​()
      返回记录的最小值，如果没有记录值，则返回 Long.MAX_VALUE 。
      long getSum​()
      返回记录的值的总和，如果没有记录值，则返回零。
      String toString​()
      返回适用于调试的此对象的非空字符串表示形式。

      • Methods inherited from interface java.util.function.IntConsumer

        andThen

      • Methods inherited from interface java.util.function.LongConsumer

        andThen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LongSummaryStatistics

        public LongSummaryStatistics​()
        用零计数，零和， Long.MAX_VALUE分钟， Long.MIN_VALUE最大值和零平均值构造空实例。

    • 方法详细信息

      • accept

        public void accept​(int value)
        在摘要信息中记录一个新的 int值。
        Specified by:
        accept在接口 IntConsumer
        参数
        value - 输入值

      • accept

        public void accept​(long value)
        在摘要信息中记录一个新的 long值。
        Specified by:
        accept在接口 LongConsumer
        参数
        value - 输入值

      • combine

        public void combine​(LongSummaryStatistics other)
        将另一个 LongSummaryStatistics的状态合并到一个。
        参数
        other - 另一个 LongSummaryStatistics
        异常
        NullPointerException - 如果 other为空

      • getCount

        public final long getCount​()
        返回记录的值的计数。
        结果
        数值计数

      • getSum

        public final long getSum​()
        返回记录的值的总和，如果没有记录值，则返回零。
        结果
        值的总和，否则为零

      • getMin

        public final long getMin​()
        返回记录的最小值，如果没有记录值，则返回 Long.MAX_VALUE 。
        结果
        最小值，如果没有， Long.MAX_VALUE

      • getMax

        public final long getMax​()
        返回记录的最大值，如果没有记录值，则返回 Long.MIN_VALUE
        结果
        最大值，或 Long.MIN_VALUE如果没有

      • getAverage

        public final double getAverage​()
        返回记录的值的算术平均值，如果没有记录值，则返回零。
        结果
        值的算术平均值，如果没有值则为零

      • toString

        public String toString​()
        返回适用于调试的此对象的非空字符串表示形式。 准确的表示格式是未指定的，可能会在实现和版本之间变化。
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Map (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Map<K,V>

  • 参数类型
    K - 由此地图维护的键的类型
    V - 映射值的类型
    All Known Subinterfaces:
    Bindings ， ConcurrentMap<K,V> ， ConcurrentNavigableMap<K,V> ， LogicalMessageContext ， MessageContext ， NavigableMap<K,V> ， ObservableMap<K,V> ， ObservableMapValue<K,V> ， SOAPMessageContext ， SortedMap<K,V> ， WritableMapValue<K,V>
    所有已知实现类：
    AbstractMap ， Attributes ， AuthProvider ， ClipboardContent ， ConcurrentHashMap ， ConcurrentSkipListMap ， EnumMap ， HashMap ， Hashtable ， Headers ， IdentityHashMap ， LinkedHashMap ， MapBinding ， MapExpression ， MapProperty ， MapPropertyBase ， MultiMapResult ， PrinterStateReasons ， Properties ， Provider ， ReadOnlyMapProperty ， ReadOnlyMapPropertyBase ， ReadOnlyMapWrapper ， RenderingHints ， ScriptObjectMirror ， SimpleBindings ， SimpleMapProperty ， TabularDataSupport ， TreeMap ， UIDefaults ， WeakHashMap

    public interface Map<K,V>
    将键映射到值的对象。 地图不能包含重复的键; 每个键可以映射到最多一个值。

    该接口代替了Dictionary类，它是一个完全抽象的类而不是接口。

    Map接口提供了三个集合视图 ，允许将映射的内容视为一组键，值的集合或键值映射集合。 地图的顺序被定义为其中在地图上的集合视图迭代返回元素的顺序。 一些地图实现，如TreeMap类，对其顺序做出特定的保证; 其他人，像HashMap类，不要。

    注意：如果使用可变对象作为地图键，必须非常小心。 如果对象的值以影响equals比较的方式更改，而对象是地图中的键，则不会指定映射的行为。 这个禁令的一个特殊情况是，地图不允许将自己包含在内。 虽然地图可以将其本身作为一个值，但建议您非常小心： equals和hashCode方法在这样的地图上已经不太明确。

    所有通用映射实现类应提供两个“标准”构造函数：一个创建空映射的void（无参数）构造函数和一个具有类型为Map的单个参数的构造函数，它创建一个具有相同键值的新映射映射作为参数。 实际上，后一个构造函数允许用户复制任何地图，产生所需类的等效地图。 没有办法强制执行此建议（因为接口不能包含构造函数），而JDK中的所有通用映射实现都符合要求。

    如果此映射不支持此操作，则此接口中包含的“破坏性”方法（即修改其操作的映射的方法）将被指定为抛出UnsupportedOperationException 。 如果是这种情况，如果调用对地图没有影响，这些方法可能可以但不是必须抛出UnsupportedOperationException 。 例如，在不可修改的地图上调用putAll(Map)方法可能会将其映射为“叠加”的地图空白时，但不是必须抛出异常。

    一些地图实现对它们可能包含的键和值有限制。 例如，一些实现禁止空键和值，有些对键的类型有限制。 尝试插入不合格的键或值会引发未经检查的异常，通常为NullPointerException或ClassCastException 。 尝试查询不合格键或值的存在可能会引发异常，或者可能只是返回false; 一些实现将展现出前者的行为，一些实现将展现出后者。 更一般来说，尝试对不符合条件的密钥或值的操作，其完成不会导致将不合格元素插入到地图中可能会导致异常或可能成功执行该选项。 此异常在此接口的规范中标记为“可选”。

    Collections Framework接口中的许多方法都是按照equals方法进行定义的。 例如， containsKey(Object key)方法的规范说：“当且仅当此映射包含k的映射关系true时才返回(key==null ? k==null : key.equals(k)) 。 该规范不应该被解释为意味着调用Map.containsKey与非空参数key会导致key.equals(k)被调用的任意键k 。 实现可以自由地实现优化，从而避免equals调用，例如，首先比较两个密钥的哈希码。 （ Object.hashCode()规范保证具有不等的哈希码的两个对象不能相等。）更一般地，各种Collections Framework接口的实现可以随意利用底层的Object方法的指定行为，无论执行者认为合适。

    执行递归遍历地图的一些地图操作可能会失败，并且地图直接或间接包含自身的自引用实例有异常。 这包括clone() ， equals() ， hashCode()和toString()方法。 实现可以可选地处理自引用场景，然而大多数当前实现不这样做。

    Immutable Map Static Factory Methods

    Map.of()和Map.ofEntries()静态工厂方法提供了创建不可变地图的便捷方式。 由这些方法创建的Map实例具有以下特征：

    • 它们在结构上是不可变的 。 无法添加，删除或更新密钥和值。 调用任何mutator方法将始终导致UnsupportedOperationException被抛出。 但是，如果包含的键或值本身是可变的，则可能会导致地图行为不一致或其内容似乎更改。
    • 他们不允许使用null键和值。 尝试使用null键或值创建它们将导致NullPointerException 。
    • 如果所有键和值都是可序列化的，它们是可序列化的。
    • 他们在创建时拒绝重复的键。 传递给静态工厂方法的重复键将导致IllegalArgumentException 。
    • 映射的迭代顺序是未指定的，可能会发生变化。
    • 他们是value-based 。 调用者不应该对返回的实例的身份进行假设。 工厂可以自由创建新的实例或重用现有的实例。 因此，对这些实例的身份敏感操作（引用等式（ == ），身份哈希码和同步）是不可靠的，应该避免。
    • 它们按照Serialized Form页面的规定进行序列化。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    HashMap ， TreeMap ， Hashtable ， SortedMap ， Collection ， Set

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  Map.Entry<K,V>
      地图条目（键值对）。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void clear​()
      从该地图中删除所有的映射（可选操作）。
      default V compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定键的映射及其当前映射值（如果没有当前映射，则 null ）。
      default V computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      default V computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      boolean containsKey​(Object key)
      如果此映射包含指定键的映射，则返回 true 。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      static <K,V> Map.Entry<K,V> entry​(K k, V v)
      返回包含给定键和值的不可变Map.Entry 。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      boolean equals​(Object o)
      将指定的对象与此映射进行比较以获得相等性。
      default void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。
      default V getOrDefault​(Object key, V defaultValue)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。
      int hashCode​()
      返回此地图的哈希码值。
      boolean isEmpty​()
      如果此映射不包含键值映射，则返回 true 。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      default V merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
      static <K,V> Map<K,V> of​()
      返回一个包含零映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1)
      返回包含单个映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1, K k2, V v2)
      返回包含两个映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1, K k2, V v2, K k3, V v3)
      返回包含三个映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4)
      返回包含四个映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5)
      返回一个包含五个映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6)
      返回包含六个映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6, K k7, V v7)
      返回包含七个映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6, K k7, V v7, K k8, V v8)
      返回包含八个映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6, K k7, V v7, K k8, V v8, K k9, V v9)
      返回包含九个映射的不可变地图。
      static <K,V> Map<K,V> of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6, K k7, V v7, K k8, V v8, K k9, V v9, K k10, V v10)
      返回包含十个映射的不可变地图。
      static <K,V> Map<K,V> ofEntries​(Map.Entry<? extends K,? extends V>... entries)
      返回包含从给定条目提取的键和值的不可变地图。
      V put​(K key, V value)
      将指定的值与该映射中的指定键相关联（可选操作）。
      void putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此映射（可选操作）。
      default V putIfAbsent​(K key, V value)
      如果指定的键尚未与值相关联（或映射到 null ）将其与给定值相关联并返回 null ，否则返回当前值。
      V remove​(Object key)
      如果存在（从可选的操作），从该地图中删除一个键的映射。
      default boolean remove​(Object key, Object value)
      仅当指定的密钥当前映射到指定的值时删除该条目。
      default V replace​(K key, V value)
      只有当目标映射到某个值时，才能替换指定键的条目。
      default boolean replace​(K key, V oldValue, V newValue)
      仅当当前映射到指定的值时，才能替换指定键的条目。
      default void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      int size​()
      返回此地图中键值映射的数量。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

    • 方法详细信息

      • size

        int size​()
        返回此地图中键值映射的数量。 如果地图包含Integer.MAX_VALUE元素，返回Integer.MAX_VALUE 。
        结果
        该地图中键值映射的数量

      • isEmpty

        boolean isEmpty​()
        如果此映射不包含键值映射，则返回 true 。
        结果
        true如果该地图不包含键值映射

      • containsKey

        boolean containsKey​(Object key)
        如果此映射包含指定键的映射，则返回true 。 更正式地说，返回true当且仅当此映射包含一个键的映射关系k这样Objects.equals(key, k) 。 （最多可以有一个这样的映射。）
        参数
        key - 要在此地图中存在的密钥要进行测试
        结果
        true如果此映射包含指定键的映射
        异常
        ClassCastException - 如果密钥对于该地图是不合适的类型（ optional ）
        NullPointerException - 如果指定的键为空，并且此映射不允许空键（ optional ）

      • containsValue

        boolean containsValue​(Object value)
        如果此映射将一个或多个键映射到指定的值，则返回true 。 更正式地，返回true当且仅当此映射包含至少一个映射到值v ，使得Objects.equals(value, v) 。 对于Map接口的大多数实现，此操作对于地图大小可能需要时间线性。
        参数
        value - 要在此地图中存在的值要进行测试
        结果
        true如果该地图将一个或多个键映射到指定的值
        异常
        ClassCastException - 如果该值是该地图的不当类型（ optional ）
        NullPointerException - 如果指定的值为空，并且此映射不允许空值（ optional ）

      • get

        V get​(Object key)
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回null 。

        更正式地，如果该映射包含从k键到值v的映射，使得Objects.equals(key, k) ，则该方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        如果此映射允许空值，则返回值null并不一定表示该映射不包含该映射关键字; 地图也可能明确地将密钥映射到null 。 可以使用containsKey操作来区分这两种情况。

        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含键的映射， null
        异常
        ClassCastException - 如果密钥对于该地图是不合适的类型（ optional ）
        NullPointerException - 如果指定的键为空，并且此映射不允许空键（ optional ）

      • put

        V put​(K key,
      V value)
        将指定的值与该映射中的指定键相关联（可选操作）。 如果映射先前包含了密钥的映射，则旧值将被指定的值替换。 （映射m被称为包含关键字k的映射，如果且仅当m.containsKey(k)将返回true 。
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与key相关联的上一个值，如果null没有映射， key 。 （A null返回也可以指示以前关联的地图null与key ，如果实现支持null值。）
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中
        NullPointerException - 如果指定的键或值为空，并且此映射不允许空值或值
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中

      • remove

        V remove​(Object key)
        如果存在（从可选的操作），从该地图中删除一个键的映射。 更正式地，如果该映射包含从键k到值v的映射，使得Objects.equals(key, k) ，则删除该映射。 （地图最多可以包含一个这样的映射。）

        返回此映射先前与密钥相关联的值，如果映射不包含关键字的映射，则返回null 。

        如果此映射允许空值，则返回值为null并不一定表示该映射不包含该映射关键字; 映射也可能将密钥明确映射到null 。

        一旦呼叫返回，该映射将不包含指定键的映射。

        参数
        key - 要从地图中删除其映射的密钥
        结果
        先前的值相关联 key ，或 null如果没有映射 key 。
        异常
        UnsupportedOperationException - 如果此地图不支持 remove操作
        ClassCastException - 如果密钥对于该地图是不合适的类型（ optional ）
        NullPointerException - 如果指定的键为空，并且此映射不允许空键（ optional ）

      • putAll

        void putAll​(Map<? extends K,? extends V> m)
        将指定地图的所有映射复制到此映射（可选操作）。 此通话的效果与从映射关键字k到指定地图值v每个映射一次调用put(k, v)一样 。 如果在操作进行中修改了指定的地图，则此操作的行为是未定义的。
        参数
        m - 要存储在此地图中的映射
        异常
        UnsupportedOperationException - 如果此地图不支持 putAll操作
        ClassCastException - 如果指定地图中的键或值的类阻止它存储在此映射中
        NullPointerException - 如果指定的映射为空，或者该映射不允许空值或值，并且指定的映射包含空键或值
        IllegalArgumentException - 如果指定地图中的键或值的某些属性阻止其存储在此映射中

      • clear

        void clear​()
        从该地图中删除所有的映射（可选操作）。 此呼叫返回后，地图将为空。
        异常
        UnsupportedOperationException - 如果此地图不支持 clear操作

      • keySet

        Set<K> keySet​()
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        结果
        该地图中包含的键的集合视图

      • values

        Collection<V> values​()
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        结果
        该地图中包含的值的集合视图

      • entrySet

        Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时修改映射（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        结果
        该地图中包含的映射的集合视图

      • equals

        boolean equals​(Object o)
        将指定的对象与此映射进行比较以获得相等性。 如果给定的对象也是一个地图，并且两个地图代表相同的映射，则返回true 。 更正式地，如果m1.entrySet().equals(m2.entrySet()) ，两个地图m1和m2表示相同的映射。 这可以确保equals方法在Map接口的不同实现中正常工作。
        重写：
        equals在 Object
        参数
        o - 要与该地图相等的对象
        结果
        true如果指定的对象等于此映射
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此地图的哈希码值。 地图的哈希码被定义为地图entrySet()视图中每个条目的哈希码的总和。 这确保了m1.equals(m2)意味着m1.hashCode()==m2.hashCode()对于任何两个地图m1和m2 ，所要求的一般合同Object.hashCode() 。
        重写：
        hashCode在 Object
        结果
        该地图的哈希码值
        另请参见：
        Map.Entry.hashCode() ，
Object.equals(Object) ，
equals(Object)

      • getOrDefault

        default V getOrDefault​(Object key,
                       V defaultValue)
        返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。
        实现要求：
        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。
        参数
        key - 要返回其关联值的键
        defaultValue - 键的默认映射
        结果
        映射指定键的值，如果此映射不包含该键的映射， defaultValue
        异常
        ClassCastException - 如果密钥对于此地图是不合适的类型（ optional ）
        NullPointerException - 如果指定的键为空，并且此映射不允许空键（ optional ）
        从以下版本开始：
        1.8

      • forEach

        default void forEach​(BiConsumer<? super K,? super V> action)
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        实现要求：
        默认实现相当于，对于这个map ：
           for (Map.Entry<K, V> entry : map.entrySet()) action.accept(entry.getKey(), entry.getValue());
        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。
        参数
        action - 对每个条目执行的操作
        异常
        NullPointerException - 如果指定的操作为空
        ConcurrentModificationException - 如果在迭代期间发现条目被删除
        从以下版本开始：
        1.8

      • replaceAll

        default void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        实现要求：

        默认实现相当于，对于这个map ：

           for (Map.Entry<K, V> entry : map.entrySet()) entry.setValue(function.apply(entry.getKey(), entry.getValue()));

        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。

        参数
        function - 应用于每个条目的功能
        异常
        UnsupportedOperationException - 如果此地图的条目集迭代器不支持 set操作。
        ClassCastException - 如果替换值的类阻止它存储在此映射中
        NullPointerException - 如果指定的函数为空，或指定的替换值为空，并且此映射不允许为空值
        ClassCastException - 如果替代值对于该地图是不合适的类型（ optional ）
        NullPointerException - 如果函数或替换值为空，并且此映射不允许空值或值（ optional ）
        IllegalArgumentException - 如果替换值的某些属性阻止其存储在此映射中（ optional ）
        ConcurrentModificationException - 如果在迭代期间发现条目被删除
        从以下版本开始：
        1.8

      • putIfAbsent

        default V putIfAbsent​(K key,
                      V value)
        如果指定的键尚未与某个值（或映射到 null ）相关联，并将其与给定值相关联并返回 null ，否则返回当前值。
        实现要求：
        默认实现相当于，对于这个map ：
           V v = map.get(key); if (v == null) v = map.put(key, value); return v;

        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。

        参数
        key - 要与其关联的指定值的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示映射以前关联的是null ，如果实现支持空值）。
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果该地图的键或值不合适（ optional ）
        NullPointerException - 如果指定的键或值为空，并且此映射不允许空键或值（ optional ）
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中（ optional ）
        从以下版本开始：
        1.8

      • remove

        default boolean remove​(Object key,
                       Object value)
        仅当指定的密钥当前映射到指定的值时删除该条目。
        实现要求：
        默认实现相当于，对于这个map ：
           if (map.containsKey(key) && Objects.equals(map.get(key), value)) { map.remove(key); return true; } else return false;

        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。

        参数
        key - 与指定值相关联的键
        value - 预期与指定键相关联的值
        结果
        true如果该值被删除
        异常
        UnsupportedOperationException - 如果此地图不支持 remove操作（ optional ）
        ClassCastException - 如果该地图的键或值不合适（ optional ）
        NullPointerException - 如果指定的键或值为空，并且此映射不允许空值或值（ optional ）
        从以下版本开始：
        1.8

      • replace

        default boolean replace​(K key,
                        V oldValue,
                        V newValue)
        仅当当前映射到指定的值时，才能替换指定键的条目。
        实现要求：
        默认实现相当于，对于这个map ：
           if (map.containsKey(key) && Objects.equals(map.get(key), value)) { map.put(key, newValue); return true; } else return false;
        如果oldValue为null，则默认实现不会为不支持空值的映射抛出NullPointerException，除非newValue也为空。

        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。

        参数
        key - 与指定值相关联的键
        oldValue - 预期与指定键相关联的值
        newValue - 与指定键相关联的值
        结果
        true如果值被替换
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中
        NullPointerException - 如果指定的键或newValue为空，并且此映射不允许空键或值
        NullPointerException - 如果oldValue为空，并且此映射不允许空值（ optional ）
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中
        从以下版本开始：
        1.8

      • replace

        default V replace​(K key,
                  V value)
        只有当目标映射到某个值时，才能替换指定键的条目。
        实现要求：
        默认实现相当于，对于这个map ：
           if (map.containsKey(key)) { return map.put(key, value); } else return null;

        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。

        参数
        key - 与指定值相关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示映射以前关联的是null的关键字，如果实现支持空值）。
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中（ optional ）
        NullPointerException - 如果指定的键或值为空，并且此映射不允许空值或值
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中
        从以下版本开始：
        1.8

      • computeIfAbsent

        default V computeIfAbsent​(K key,
                          Function<? super K,? extends V> mappingFunction)
        如果指定的键尚未与值相关联（或映射到null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是null 。

        如果映射函数返回null ，则不记录映射。 如果映射函数本身引发（未检查）异常，则重新抛出异常，并且不记录映射。 最常见的用法是构造一个用作初始映射值或记忆结果的新对象，如：

           map.computeIfAbsent(key, k -> new Value(f(k)));

        或者实现一个多值映射Map<K,Collection<V>> ，每个键支持多个值：

           map.computeIfAbsent(key, k -> new HashSet<V>()).add(v);

        映射函数在计算过程中不应该修改该映射。

        实现要求：
        默认实现等同于此map的以下步骤，然后返回当前值或null如果现在不存在）：
           if (map.get(key) == null) { V newValue = mappingFunction.apply(key); if (newValue != null) map.put(key, newValue); }

        默认实现不会保证检测映射函数在计算过程中是否修改此映射，并且在适当情况下报告错误。 非并发实现应该覆盖此方法，如果检测到映射函数在计算过程中修改此映射，则尽力而为地抛出一个ConcurrentModificationException 。 并发实现应该覆盖此方法，如果在计算过程中检测到映射函数修改了该映射，则尽力而为，抛出一个IllegalStateException ，因此计算将永远不会完成。

        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。 特别地，子接口ConcurrentMap的所有实现必须记录是否只有在该值不存在时才以原子方式应用映射函数。

        参数
        key - 指定值与之关联的键
        mappingFunction - 计算值的映射函数
        结果
        与指定键相关联的当前（现有或计算）值，如果计算值为空，则为null
        异常
        NullPointerException - 如果指定的键为空，此映射不支持空键，或者mappingFunction为空
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中（ optional ）
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中（ optional ）
        从以下版本开始：
        1.8

      • computeIfPresent

        default V computeIfPresent​(K key,
                           BiFunction<? super K,? super V,? extends V> remappingFunction)
        如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

        如果重映射函数返回null ，则映射将被删除。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        实现要求：
        默认实现等同于为此map执行以下步骤，然后返回当前值或null如果现在不存在）：
           if (map.get(key) != null) { V oldValue = map.get(key); V newValue = remappingFunction.apply(key, oldValue); if (newValue != null) map.put(key, newValue); else map.remove(key); }

        默认实现不会保证在计算期间检测重映射函数是否修改此映射，并且在适当情况下报告错误。 非并发实现应该覆盖此方法，如果在计算过程中检测到重映射函数修改了该映射，则尽力而为地抛出一个ConcurrentModificationException 。 并发实现应该覆盖此方法，并且尽力而为地抛出一个IllegalStateException如果检测到重新映射函数在计算期间修改该映射，并且因此计算将永远不会完成。

        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。 特别地，子接口ConcurrentMap的所有实现必须记录重映射函数是否仅在原子上被应用，如果该值不存在。

        参数
        key - 要与指定值相关联的键
        remappingFunction - 计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        NullPointerException - 如果指定的键为空，此映射不支持空键，或者remappingFunction为空
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中（ optional ）
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中（ optional ）
        从以下版本开始：
        1.8

      • compute

        default V compute​(K key,
                  BiFunction<? super K,? super V,? extends V> remappingFunction)
        尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则null ）。 例如，要为值映射创建或附加String msg：
           map.compute(key, (k, v) -> (v == null) ? msg : v.concat(msg))
        （方法merge()通常更容易用于此类目的。）

        如果重映射函数返回null ，映射将被删除（如果最初缺少，则保持不存在）。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        实现要求：
        默认实现相当于为此map执行以下步骤，然后返回当前值，如果缺少则返回null ：
           V oldValue = map.get(key); V newValue = remappingFunction.apply(key, oldValue); if (oldValue != null) { if (newValue != null) map.put(key, newValue); else map.remove(key); } else { if (newValue != null) map.put(key, newValue); else return null; }

        默认实现不会保证在计算期间检测重映射函数是否修改此映射，并且在适当情况下报告错误。 非并发实现应该覆盖此方法，如果在计算过程中检测到重映射函数修改了该映射，则尽力而为地抛出一个ConcurrentModificationException 。 并发实现应该覆盖此方法，如果检测到重新映射函数在计算过程中修改了该映射，并且尽力而为，抛出一个IllegalStateException ，因此计算将永远不会完成。

        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。 特别地，子接口ConcurrentMap的所有实现必须记录重新映射函数是否仅在原子上被应用，如果该值不存在。

        参数
        key - 要与其关联的指定值的键
        remappingFunction - 计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        NullPointerException - 如果指定的键为空，此映射不支持空键，或者remappingFunction为空
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中（ optional ）
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中（ optional ）
        从以下版本开始：
        1.8

      • merge

        default V merge​(K key,
                V value,
                BiFunction<? super V,? super V,? extends V> remappingFunction)
        如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。 否则，将关联值替换为给定重映射函数的结果，如果结果为null ，则将其null 。 当组合键的多个映射值时，该方法可能是有用的。 例如，要为值映射创建或附加String msg ：
           map.merge(key, msg, String::concat)

        如果重映射函数返回null ，则映射将被删除。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        实现要求：
        默认实现等同于为此map执行以下步骤，然后返回当前值或null如果不存在）：
           V oldValue = map.get(key); V newValue = (oldValue == null) ? value : remappingFunction.apply(oldValue, value); if (newValue == null) map.remove(key); else map.put(key, newValue);

        默认实现不会保证在计算期间检测重映射函数是否修改此映射，并且在适当情况下报告错误。 非并发实现应该覆盖此方法，如果在计算过程中检测到重映射函数修改了此映射，则尽力而为地抛出一个ConcurrentModificationException 。 并发实现应该覆盖此方法，并且尽力而为地抛出一个IllegalStateException如果检测到重新映射函数在计算期间修改该映射，并且因此计算将永远不会完成。

        默认实现不会保证此方法的同步或原子属性。 提供原子性保证的任何实现都必须覆盖此方法并记录其并发属性。 特别地，子接口ConcurrentMap的所有实现必须记录是否只有在该值不存在时才以原子方式应用重映射功能。

        参数
        key - 与其相关联的结果值的键
        value - 要与与密钥相关联的现有值合并的非空值，或者如果没有与密钥相关联的现有值或空值与密钥相关联
        remappingFunction - 如果存在重新计算值的重映射功能
        结果
        与指定键相关联的新值，如果没有值与该键相关联，则返回null
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中（ optional ）
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中（ optional ）
        NullPointerException - 如果指定的键为空，并且此映射不支持空键或值或remappingFunction为空
        从以下版本开始：
        1.8

      • of

        static <K,V> Map<K,V> of​()
        返回一个包含零映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的关键类型
        V - Map的值类型
        结果
        一个空的 Map
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1)
        返回包含单个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的关键类型
        V - Map的值类型
        参数
        k1 - 映射的关键
        v1 - 映射的值
        结果
        一个 Map包含指定的映射
        异常
        NullPointerException - 如果键或值是 null
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1,
                         K k2,
                         V v2)
        返回包含两个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的键类型
        V - Map的值类型
        参数
        k1 - 第一个映射的关键
        v1 - 第一个映射的值
        k2 - 第二个映射的关键
        v2 - 第二个映射的值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果键是重复的
        NullPointerException - 如果任何键或值是 null
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1,
                         K k2,
                         V v2,
                         K k3,
                         V v3)
        返回包含三个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的关键类型
        V - Map的值类型
        参数
        k1 - 第一个映射的关键
        v1 - 第一个映射的值
        k2 - 第二个映射的关键
        v2 - 第二个映射的值
        k3 - 第三个映射的关键
        v3 - 第三个映射的值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果有重复键
        NullPointerException - 如果任何键或值为 null
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1,
                         K k2,
                         V v2,
                         K k3,
                         V v3,
                         K k4,
                         V v4)
        返回包含四个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的关键类型
        V - Map的值类型
        参数
        k1 - 第一个映射的关键
        v1 - 第一个映射的值
        k2 - 第二个映射的关键
        v2 - 第二个映射的值
        k3 - k3 - k3 - k3 - k3 - k3
        v3 - 第三个映射的值
        k4 - 第四个映射的关键
        v4 - 第四个映射的值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果有重复的键
        NullPointerException - 如果有任何键或值是 null
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1,
                         K k2,
                         V v2,
                         K k3,
                         V v3,
                         K k4,
                         V v4,
                         K k5,
                         V v5)
        返回一个包含五个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的关键类型
        V - Map的值类型
        参数
        k1 - 第一个映射的关键
        v1 - 第一个映射的值
        k2 - 第二个映射的关键
        v2 - 第二个映射的值
        k3 - 第三个映射的关键
        v3 - 第三个映射的值
        k4 - 第四个映射的关键
        v4 - 第四个映射的值
        k5 - 第五个映射的关键
        v5 - 第五个映射的值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果有重复键
        NullPointerException - 如果任何键或值为 null
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1,
                         K k2,
                         V v2,
                         K k3,
                         V v3,
                         K k4,
                         V v4,
                         K k5,
                         V v5,
                         K k6,
                         V v6)
        返回包含六个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的密钥类型
        V - Map的值类型
        参数
        k1 - 第一个映射的关键
        v1 - 第一个映射的值
        k2 - 第二个映射的关键
        v2 - 第二个映射的值
        k3 - 第三个映射的关键
        v3 - 第三个映射的值
        k4 - 第四个映射的关键
        v4 - 第四个映射的值
        k5 - 第五个映射的关键
        v5 - 第五个映射的值
        k6 - 第六个映射的关键
        v6 - 第六个映射的值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果有重复键
        NullPointerException - 如果任何键或值是 null
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1,
                         K k2,
                         V v2,
                         K k3,
                         V v3,
                         K k4,
                         V v4,
                         K k5,
                         V v5,
                         K k6,
                         V v6,
                         K k7,
                         V v7)
        返回包含七个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的关键类型
        V - Map的值类型
        参数
        k1 - 第一个映射的关键
        v1 - 第一个映射的值
        k2 - 第二个映射的关键
        v2 - 第二个映射的值
        k3 - 第三个映射的关键
        v3 - 第三个映射的值
        k4 - 第四个映射的关键
        v4 - 第四个映射的值
        k5 - 第五个映射的关键
        v5 - 第五个映射的值
        k6 - 第六个映射的关键
        v6 - 第六个映射的值
        k7 - 第七映射的关键
        v7 - 第七个映射的值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果有重复键
        NullPointerException - 如果任何键或值为 null
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1,
                         K k2,
                         V v2,
                         K k3,
                         V v3,
                         K k4,
                         V v4,
                         K k5,
                         V v5,
                         K k6,
                         V v6,
                         K k7,
                         V v7,
                         K k8,
                         V v8)
        返回包含八个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的键类型
        V - Map的值类型
        参数
        k1 - 第一个映射的关键
        v1 - 第一个映射的值
        k2 - 第二个映射的关键
        v2 - 第二个映射的值
        k3 - 第三个映射的关键
        v3 - 第三个映射的值
        k4 - 第四个映射的关键
        v4 - 第四个映射的值
        k5 - 第五个映射的关键
        v5 - 第五个映射的值
        k6 - 第六个映射的关键
        v6 - 第六个映射的值
        k7 - 第七映射的关键
        v7 - 第七个映射的值
        k8 - 第八个映射的关键
        v8 - 第八个映射的值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果有重复键
        NullPointerException - 如果任何键或值为 null
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1,
                         K k2,
                         V v2,
                         K k3,
                         V v3,
                         K k4,
                         V v4,
                         K k5,
                         V v5,
                         K k6,
                         V v6,
                         K k7,
                         V v7,
                         K k8,
                         V v8,
                         K k9,
                         V v9)
        返回包含九个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的关键类型
        V - Map的值类型
        参数
        k1 - 第一个映射的关键
        v1 - 第一个映射的值
        k2 - 第二个映射的关键
        v2 - 第二个映射的值
        k3 - 第三个映射的关键
        v3 - 第三个映射的值
        k4 - 第四个映射的关键
        v4 - 第四个映射的值
        k5 - 第五个映射的关键
        v5 - 第五个映射的值
        k6 - 第六个映射的关键
        v6 - 第六个映射的值
        k7 - 第七映射的关键
        v7 - 第七个映射的值
        k8 - 第八个映射的关键
        v8 - 第八个映射的值
        k9 - 第九个映射的关键
        v9 - 第九个映射的值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果有重复键
        NullPointerException - 如果任何键或值是 null
        从以下版本开始：
        9

      • of

        static <K,V> Map<K,V> of​(K k1,
                         V v1,
                         K k2,
                         V v2,
                         K k3,
                         V v3,
                         K k4,
                         V v4,
                         K k5,
                         V v5,
                         K k6,
                         V v6,
                         K k7,
                         V v7,
                         K k8,
                         V v8,
                         K k9,
                         V v9,
                         K k10,
                         V v10)
        返回包含十个映射的不可变地图。 详见Immutable Map Static Factory Methods 。
        参数类型
        K - Map的键类型
        V - Map的值类型
        参数
        k1 - 第一个映射的关键
        v1 - 第一个映射的值
        k2 - 第二个映射的关键
        v2 - 第二个映射的值
        k3 - 第三个映射的关键
        v3 - 第三个映射的值
        k4 - 第四个映射的关键
        v4 - 第四个映射的值
        k5 - 第五个映射的关键
        v5 - 第五个映射的值
        k6 - 第六个映射的关键
        v6 - 第六个映射的值
        k7 - 第七映射的关键
        v7 - 第七个映射的值
        k8 - 第八个映射的关键
        v8 - 第八个映射的值
        k9 - 第九个映射的关键
        v9 - 第九个映射的值
        k10 - 第十个映射的关键
        v10 - 第十个映射的值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果有重复键
        NullPointerException - 如果任何键或值是 null
        从以下版本开始：
        9

      • ofEntries

        @SafeVarargs
static <K,V> Map<K,V> ofEntries​(Map.Entry<? extends K,? extends V>... entries)
        返回包含从给定条目提取的键和值的不可变地图。 条目本身不存储在地图中。 详见Immutable Map Static Factory Methods 。
        API Note:
        使用Map.entry()方法创建地图条目是方便的。 例如，
           import static java.util.Map.entry; Map<Integer,String> map = Map.ofEntries( entry(1, "a"), entry(2, "b"), entry(3, "c"), ... entry(26, "z"));
        参数类型
        K - Map的密钥类型
        V - Map的值类型
        参数
        entries - Map.Entry包含映射填充的键和值
        结果
        一个 Map包含指定的映射
        异常
        IllegalArgumentException - 如果有重复键
        NullPointerException - 如果任何条目，键或值为 null ，或者如果 entries数组为 null
        从以下版本开始：
        9
        另请参见：
        Map.entry()

      • entry

        static <K,V> Map.Entry<K,V> entry​(K k,
                                  V v)
        返回包含给定键和值的不可变的Map.Entry 。 这些条目适用于使用Map.ofEntries()方法填充Map实例。 由此方法创建的Entry实例具有以下特征：
        • 他们不允许null键和值。 尝试使用null键或值创建它们将导致NullPointerException 。
        • 他们是不变的 拨打Entry.setValue()在返回Entry结果UnsupportedOperationException 。
        • 它们不是可序列化的。
        • 他们是value-based 。 调用者不应该对返回的实例的身份进行假设。 此方法可以自由创建新实例或重用现有实例。 因此，对这些实例的身份敏感操作（引用等式（ == ），身份哈希码和同步）是不可靠的，应该避免。
        API Note:
        对于可序列化的Entry ，请参阅AbstractMap.SimpleEntry或AbstractMap.SimpleImmutableEntry 。
        参数类型
        K - 键的类型
        V - 值的类型
        参数
        k - 关键
        v - 值
        结果
        一个 Entry包含指定的键和值
        异常
        NullPointerException - 如果键值是 null
        从以下版本开始：
        9
        另请参见：
        Map.ofEntries()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Map.Entry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Map.Entry<K,V>

  • 所有已知实现类：
    AbstractMap.SimpleEntry ， AbstractMap.SimpleImmutableEntry
    Enclosing interface:
    Map < K ， V >

    public static interface Map.Entry<K,V>
    地图条目（键值对）。 Map.entrySet方法返回地图的集合视图，其元素属于此类。 获取对映射条目的引用的唯一方法是从该集合视图的迭代器。 这些Map.Entry对象仅在迭代期间有效; 更正式地，如果在迭代器返回条目之后修改了后备映射，则映射条目的行为是未定义的，除了通过映射条目上的setValue操作。
    从以下版本开始：
    1.2
    另请参见：
    Map.entrySet()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      static <K extends Comparable<? super K>,V>
      Comparator<Map.Entry<K,V>>             		comparingByKey​()
      返回一个比较器， 按键的自然顺序比较Map.Entry 。
      static <K,V> Comparator<Map.Entry<K,V>> comparingByKey​(Comparator<? super K> cmp)
      返回一个比较器，比较Map.Entry按键使用给定的Comparator 。
      static <K,V extends Comparable<? super V>>
      Comparator<Map.Entry<K,V>>             		comparingByValue​()
      返回一个比较值，以比例Map.Entry在自然顺序的值。
      static <K,V> Comparator<Map.Entry<K,V>> comparingByValue​(Comparator<? super V> cmp)
      返回一个比较器，使用给定的Comparator将值与Map.Entry进行比较。
      boolean equals​(Object o)
      将指定的对象与此条目进行比较以获得相等性。
      K getKey​()
      返回与此条目相对应的键。
      V getValue​()
      返回与此条目相对应的值。
      int hashCode​()
      返回此映射条目的哈希码值。
      V setValue​(V value)
      用指定的值替换与该条目相对应的值（可选操作）。

    • 方法详细信息

      • getKey

        K getKey​()
        返回与此条目相对应的键。
        结果
        与此条目相对应的键
        异常
        IllegalStateException - 如果条目已从后备映射中删除，则实现可能但不是必须抛出此异常。

      • getValue

        V getValue​()
        返回与此条目相对应的值。 如果映射已从背景映射中删除（通过迭代器的remove操作），则此调用的结果未定义。
        结果
        与此条目对应的值
        异常
        IllegalStateException - 如果条目已从后备映射中删除，则实现可能但不是必须抛出此异常。

      • setValue

        V setValue​(V value)
        用指定的值替换与该条目相对应的值（可选操作）。 （写入地图。）如果映射已经从映射中移除（通过迭代器的remove操作），则此调用的行为是未定义的。
        参数
        value - 要存储在此条目中的新值
        结果
        旧值对应的条目
        异常
        UnsupportedOperationException - 如果支持地图不支持 put操作
        ClassCastException - 如果指定值的类阻止它存储在后台映射中
        NullPointerException - 如果后台映射不允许空值，并且指定的值为空
        IllegalArgumentException - 如果此值的某些属性阻止其存储在后台映射中
        IllegalStateException - 如果条目已从后备映射中删除，则实现可能但不是必须抛出此异常。

      • equals

        boolean equals​(Object o)
        将指定的对象与此条目进行比较以获得相等性。 如果给定对象也是映射条目，则返回true ，并且两个条目表示相同的映射。 更正式地，两个条目e1和e2表示相同的映射
          (e1.getKey()==null ?
      e2.getKey()==null : e1.getKey().equals(e2.getKey()))  &&
     (e1.getValue()==null ?
      e2.getValue()==null : e1.getValue().equals(e2.getValue()))
        这可以确保equals方法在Map.Entry接口的不同实现中正常工作。
        重写：
        equals在 Object
        参数
        o - 要与该地图条目相等的对象
        结果
        true如果指定的对象等于此映射条目
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此映射条目的哈希码值。 地图条目e的哈希码被定义为：
          (e.getKey()==null   ? 0 : e.getKey().hashCode()) ^
     (e.getValue()==null ? 0 : e.getValue().hashCode())
        这确保e1.equals(e2)意味着e1.hashCode()==e2.hashCode()对于任何两个条目e1和e2 ，根据e2的一般合同的Object.hashCode 。
        重写：
        hashCode在 Object
        结果
        该地图条目的哈希码值
        另请参见：
        Object.hashCode() ，
Object.equals(Object) ，
equals(Object)

      • comparingByKey

        static <K extends Comparable<? super K>,V> Comparator<Map.Entry<K,V>> comparingByKey​()
        返回一个比较器， 按键的自然顺序比较Map.Entry 。

        返回的比较器是可序列化的，当将条目与空键进行比较时， 它将抛出NullPointerException 。

        参数类型
        K - 那个地图键的Comparable类型
        V - 地图值的类型
        结果
        一个比较，比较Map.Entry在自然顺序的关键。
        从以下版本开始：
        1.8
        另请参见：
        Comparable

      • comparingByValue

        static <K,V extends Comparable<? super V>> Comparator<Map.Entry<K,V>> comparingByValue​()
        返回一个比较值，比较Map.Entry的自然顺序值。

        返回的比较器是可序列化的，并且当比较具有空值的条目时， 它将抛出NullPointerException 。

        参数类型
        K - 地图键的类型
        V - Comparable类型的地图值
        结果
        一个比较值比较Map.Entry的自然顺序。
        从以下版本开始：
        1.8
        另请参见：
        Comparable

      • comparingByKey

        static <K,V> Comparator<Map.Entry<K,V>> comparingByKey​(Comparator<? super K> cmp)
        返回一个比较器，比较Map.Entry按键使用给定的Comparator 。

        如果指定的比较器也可串行化，则返回的比较器是可序列化的。

        参数类型
        K - 地图键的类型
        V - 地图值的类型
        参数
        cmp - 键Comparator
        结果
        一个比较器比较Map.Entry的关键。
        从以下版本开始：
        1.8

      • comparingByValue

        static <K,V> Comparator<Map.Entry<K,V>> comparingByValue​(Comparator<? super V> cmp)
        返回一个比较器，使用给定的Comparator比较Map.Entry的值。

        如果指定的比较器也可串行化，则返回的比较器是可序列化的。

        参数类型
        K - 地图键的类型
        V - 地图值的类型
        参数
        cmp - 值Comparator
        结果
        一个比较器比较Map.Entry的值。
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MissingFormatArgumentException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class MissingFormatArgumentException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.MissingFormatArgumentException
  • All Implemented Interfaces:
    Serializable

    public class MissingFormatArgumentException
extends IllegalFormatException
    当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。

    除非另有说明，否则将null参数传递给null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MissingFormatArgumentException​(String s)
      使用不匹配的格式说明符构造此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getFormatSpecifier​()
      返回不匹配的格式说明符。
      String getMessage​()
      返回此throwable的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MissingFormatArgumentException

        public MissingFormatArgumentException​(String s)
        使用不匹配的格式说明符构造此类的实例。
        参数
        s - 格式说明符没有相应的参数

    • 方法详细信息

      • getFormatSpecifier

        public String getFormatSpecifier​()
        返回不匹配的格式说明符。
        结果
        不匹配的格式说明符

      • getMessage

        public String getMessage​()
        描述从类复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MissingFormatWidthException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class MissingFormatWidthException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.MissingFormatWidthException
  • All Implemented Interfaces:
    Serializable

    public class MissingFormatWidthException
extends IllegalFormatException
    需要格式宽度时抛出未检查的异常。

    除非另有说明，否则将null参数传递给null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MissingFormatWidthException​(String s)
      使用指定的格式说明符构造此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getFormatSpecifier​()
      返回没有宽度的格式说明符。
      String getMessage​()
      返回此throwable的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MissingFormatWidthException

        public MissingFormatWidthException​(String s)
        使用指定的格式说明符构造此类的实例。
        参数
        s - 没有宽度的格式说明符

    • 方法详细信息

      • getFormatSpecifier

        public String getFormatSpecifier​()
        返回没有宽度的格式说明符。
        结果
        不具有宽度的格式说明符

      • getMessage

        public String getMessage​()
        描述从类复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MissingResourceException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class MissingResourceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.util.MissingResourceException
  • All Implemented Interfaces:
    Serializable

    public class MissingResourceException
extends RuntimeException
    表示资源丢失。
    从以下版本开始：
    1.1
    另请参见：
    异常 ， ResourceBundle ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MissingResourceException​(String s, String className, String key)
      构造具有指定信息的MissingResourceException。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getClassName​()
      获取由构造函数传递的参数。
      String getKey​()
      获取由构造函数传递的参数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MissingResourceException

        public MissingResourceException​(String s,
                                String className,
                                String key)
        构造具有指定信息的MissingResourceException。 详细消息是描述此特定异常的字符串。
        参数
        s - 详细信息
        className - 资源类的名称
        key - 缺少资源的关键。

    • 方法详细信息

      • getClassName

        public String getClassName​()
        获取由构造函数传递的参数。
        结果
        资源类的名称

      • getKey

        public String getKey​()
        获取由构造函数传递的参数。
        结果
        缺少资源的关键
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NavigableMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface NavigableMap<K,V>

  • 参数类型
    K - 由此地图维护的键的类型
    V - 映射值的类型
    All Superinterfaces:
    Map<K,V> ， SortedMap<K,V>
    All Known Subinterfaces:
    ConcurrentNavigableMap<K,V>
    所有已知实现类：
    ConcurrentSkipListMap ， TreeMap

    public interface NavigableMap<K,V>
extends SortedMap<K,V>
    A SortedMap扩展了导航方法返回给定搜索目标的最接近的匹配。 方法lowerEntry(K) ， floorEntry(K) ， ceilingEntry(K)和higherEntry(K)返回Map.Entry与键相关联的对象比比大于给定的密钥分别更少，小于或等于，大于或等于，大于，返回null如果不存在这样的密钥。 同样，方法lowerKey(K) ， floorKey(K) ， ceilingKey(K) ，并higherKey(K)回报只有相关联的密钥。 所有这些方法都设计用于定位，而不是遍历条目。

    A NavigableMap可以按升序或降序键顺序访问和遍历。 descendingMap()方法返回地图的视图，其中所有关系和方向方法的意义都反转。 上升操作和观点的表现可能比降序更快。 方法subMap(K, boolean, K, boolean) ， headMap(K, boolean)和tailMap(K, boolean)从等命名的不同SortedMap在接受描述的下限和上限是否是包含性的抗排斥附加参数的方法。 任何NavigableMap子NavigableMap必须实现NavigableMap接口。

    此接口还定义了方法firstEntry() ， pollFirstEntry() ， lastEntry() ，并pollLastEntry()返回和/或删除至少和最大的映射关系，如果存在，否则返回null 。

    预期返回方法的实现将返回Map.Entry对，表示生成映射的快照，因此通常不支持可选的Entry.setValue方法。 但是请注意，可以使用方法put更改关联地图中的映射。

    方法subMap(K, K) ， headMap(K) ，并tailMap(K)被指定为返回SortedMap ，以允许现有的实现SortedMap能相容地改进来实现NavigableMap ，但鼓励扩展和该接口的实现重写这些方法返回NavigableMap 。 同样， SortedMap.keySet()可以覆盖以返回NavigableSet 。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.6

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Map.Entry<K,V> ceilingEntry​(K key)
      返回与大于或等于给定键的最小键相关联的键值映射，如果没有此键，则 null 。
      K ceilingKey​(K key)
      返回大于或等于给定键的 null键，如果没有此键，则 null 。
      NavigableSet<K> descendingKeySet​()
      返回此地图中包含的键的相反顺序NavigableSet 。
      NavigableMap<K,V> descendingMap​()
      返回此映射中包含的映射的反向排序视图。
      Map.Entry<K,V> firstEntry​()
      返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> floorEntry​(K key)
      返回与小于或等于给定键的最大键相关联的键值映射，如果没有此键，则 null 。
      K floorKey​(K key)
      返回小于或等于给定键的最大键，如果没有此键，则 null 。
      SortedMap<K,V> headMap​(K toKey)
      返回该地图的部分密钥严格小于 toKey 。
      NavigableMap<K,V> headMap​(K toKey, boolean inclusive)
      返回该地图部分的视图，其键值小于（或等于，如果 inclusive为真） toKey 。
      Map.Entry<K,V> higherEntry​(K key)
      返回与最小密钥相关联的密钥值映射严格大于给定密钥，如果没有这样的密钥，则 null 。
      K higherKey​(K key)
      返回严格大于给定键的最小键，如果没有这样的键，则返回 null 。
      Map.Entry<K,V> lastEntry​()
      返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> lowerEntry​(K key)
      返回与最大密钥相关联的密钥值映射严格小于给定密钥，如果没有这样的密钥，则 null 。
      K lowerKey​(K key)
      返回严格小于给定键的最大键，如果没有这样的键，则返回 null 。
      NavigableSet<K> navigableKeySet​()
      返回此地图中包含的键的NavigableSet视图。
      Map.Entry<K,V> pollFirstEntry​()
      删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> pollLastEntry​()
      删除并返回与该地图中最大密钥相关联的键值映射，如果地图为空，则 null 。
      NavigableMap<K,V> subMap​(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
      返回此地图部分的视图，其关键字范围从 fromKey到 toKey 。
      SortedMap<K,V> subMap​(K fromKey, K toKey)
      返回此地图部分的视图，其关键字范围从 fromKey （含）到 toKey ，独占。
      SortedMap<K,V> tailMap​(K fromKey)
      返回此地图部分的视图，其键大于或等于 fromKey 。
      NavigableMap<K,V> tailMap​(K fromKey, boolean inclusive)
      返回此地图部分的视图，其键大于（或等于，如果 inclusive为真） fromKey 。

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entry, equals, forEach, get, getOrDefault, hashCode, isEmpty, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size

      • Methods inherited from interface java.util.SortedMap

        comparator, entrySet, firstKey, keySet, lastKey, values

    • 方法详细信息

      • lowerEntry

        Map.Entry<K,V> lowerEntry​(K key)
        返回与最大密钥相关联的密钥值映射严格小于给定密钥，如果没有这样的密钥，则 null 。
        参数
        key - 关键
        结果
        一个条目的最大键值小于 key ，或者是 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且此映射不允许空键

      • lowerKey

        K lowerKey​(K key)
        返回严格小于给定键的最大键，如果没有这样的键，则返回 null 。
        参数
        key - 关键
        结果
        最大的钥匙小于 key ，或 null如果没有这样的钥匙
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且此映射不允许空键

      • floorEntry

        Map.Entry<K,V> floorEntry​(K key)
        返回与小于或等于给定键的最大键相关联的键值映射，如果没有此键，则 null 。
        参数
        key - 关键
        结果
        最大密钥小于或等于 key ，如果没有这样的密钥， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且此映射不允许空键

      • floorKey

        K floorKey​(K key)
        返回小于或等于给定键的最大键，如果没有这样的键，则 null 。
        参数
        key - 关键
        结果
        最大的钥匙小于或等于 key ，或 null如果没有这样的钥匙
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且此映射不允许空键

      • ceilingEntry

        Map.Entry<K,V> ceilingEntry​(K key)
        返回与大于或等于给定键的最小键相关联的键值映射，如果没有此键，则 null 。
        参数
        key - 关键
        结果
        最小键大于或等于 key ，如果没有这样的键， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且此映射不允许空键

      • ceilingKey

        K ceilingKey​(K key)
        返回大于或等于给定键的 null键，如果没有此键，则 null 。
        参数
        key - 关键
        结果
        最小键大于或等于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且此映射不允许空键

      • higherEntry

        Map.Entry<K,V> higherEntry​(K key)
        返回与最小密钥相关联的密钥值映射严格大于给定密钥，如果没有这样的密钥则 null 。
        参数
        key - 关键
        结果
        一个条目的最小键大于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且此映射不允许空键

      • higherKey

        K higherKey​(K key)
        返回严格大于给定键的最小键，如果没有这样的键，则返回 null 。
        参数
        key - 关键
        结果
        最小键大于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射不允许空键

      • firstEntry

        Map.Entry<K,V> firstEntry​()
        返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
        结果
        具有最少键的条目，如果该地图为空， null

      • lastEntry

        Map.Entry<K,V> lastEntry​()
        返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
        结果
        一个有最大密钥的条目，如果该地图为空， null

      • pollFirstEntry

        Map.Entry<K,V> pollFirstEntry​()
        删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
        结果
        该地图被删除的第一个条目，如果该地图为空， null

      • pollLastEntry

        Map.Entry<K,V> pollLastEntry​()
        删除并返回与该地图中最大密钥相关联的键值映射，如果地图为空，则 null 。
        结果
        删除该地图的最后一个条目，如果此地图为空， null

      • descendingMap

        NavigableMap<K,V> descendingMap​()
        返回此映射中包含的映射的反向排序视图。 降序地图由该地图支持，所以对地图的更改反映在降序地图中，反之亦然。 如果在映射的集合视图上进行迭代（如通过迭代器自己的remove操作除外）修改任一映射，则迭代结果未定义。

        返回的地图的订单等同于Collections.reverseOrder (comparator()) 。 表达m.descendingMap().descendingMap()返回一个视图的m实质上等同于m 。

        结果
        这张地图的倒序视图

      • navigableKeySet

        NavigableSet<K> navigableKeySet​()
        返回此地图中包含的键的NavigableSet视图。 该集合的迭代器按升序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        结果
        该地图中的键的可导航集合视图

      • descendingKeySet

        NavigableSet<K> descendingKeySet​()
        返回此映射中包含的键的相反顺序NavigableSet 。 集合的迭代器按降序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        结果
        该地图中的键的反向导航设置视图

      • subMap

        NavigableMap<K,V> subMap​(K fromKey,
                         boolean fromInclusive,
                         K toKey,
                         boolean toInclusive)
        返回此地图部分的视图，其关键字范围从fromKey到toKey 。 如果fromKey和toKey相等，则返回的地图为空，除非fromInclusive和toInclusive都为真。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键，或者构造一个其端点位于其范围之外的子地图。

        参数
        fromKey - 返回地图中键的低端点
        fromInclusive - true如果低端点要包含在返回的视图中
        toKey - 返回地图中的键的高端点
        toInclusive - true如果高端点要包含在返回的视图中
        结果
        该地图的部分视图的视图范围从 fromKey到 toKey
        异常
        ClassCastException - 如果fromKey和toKey无法使用此映射的比较器彼此进行比较（或者，如果映射没有比较器，则使用自然排序）。 如果fromKey或toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey或 toKey为空，并且此映射不允许空键
        IllegalArgumentException - 如果fromKey大于toKey ; 或者如果该地图本身具有有限的范围，并且fromKey或toKey位于范围的范围之外

      • headMap

        NavigableMap<K,V> headMap​(K toKey,
                          boolean inclusive)
        返回此地图部分的视图，其键值小于（或等于，如果inclusive为真） toKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        参数
        toKey - 返回地图中的键的高端点
        inclusive - true如果高端点要包含在返回的视图中
        结果
        键的小于（或等于，如果 inclusive为真）该地图的部分的视图 toKey
        异常
        ClassCastException - 如果toKey与此映射的比较器不兼容（或者，如果映射没有比较器，如果toKey不实现Comparable ）。 如果toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toKey为空，并且此映射不允许空键
        IllegalArgumentException - 如果此地图本身有限制范围，并且 toKey位于范围界限之外

      • tailMap

        NavigableMap<K,V> tailMap​(K fromKey,
                          boolean inclusive)
        返回此地图部分的视图，其键大于（或等于，如果inclusive为真） fromKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        参数
        fromKey - 返回地图中的键的低端点
        inclusive - true如果 true低端点包括在返回的视图中
        结果
        该地图的部分的视图，其键大于（或等于，如果 inclusive为真） fromKey
        异常
        ClassCastException - 如果fromKey与此映射的比较器不兼容（或者如果映射没有比较器，如果fromKey不实现Comparable ）。 如果fromKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey为空，并且此映射不允许空键
        IllegalArgumentException - 如果该地图本身有限制范围，而 fromKey位于范围的范围之外

      • subMap

        SortedMap<K,V> subMap​(K fromKey,
                      K toKey)
        返回此地图部分的视图，其关键字范围从fromKey （含）到toKey ，独占。 （如果fromKey和toKey相等，则返回的地图为空。）返回的地图由该地图支持，所以返回的地图中的更改会反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException尝试在其范围之外插入一个键。

        相当于subMap(fromKey, true, toKey, false) 。

        Specified by:
        subMap在接口 SortedMap<K,V>
        参数
        fromKey - 返回地图中的键的低端点（含）
        toKey - 返回地图中的键的高端点（独占）
        结果
        该地图的部分视图，其关键字范围从 fromKey （含）到 toKey ，独占
        异常
        ClassCastException - 如果fromKey和toKey无法使用此映射的比较器彼此进行比较（或者，如果映射没有比较器，则使用自然排序）。 如果fromKey或toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey或 toKey为空，并且此映射不允许空键
        IllegalArgumentException - 如果fromKey大于toKey ; 或者如果该地图本身具有有限的范围，并且fromKey或toKey位于范围的界限之外

      • headMap

        SortedMap<K,V> headMap​(K toKey)
        返回该地图部分的视图，其密钥严格小于toKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于headMap(toKey, false) 。

        Specified by:
        headMap在接口 SortedMap<K,V>
        参数
        toKey - 返回地图中的键的高端点（排他）
        结果
        该地图的部分密钥严格小于 toKey
        异常
        ClassCastException - 如果toKey与此映射的比较器不兼容（或者，如果映射没有比较器，如果toKey不实现Comparable ）。 如果toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toKey为空，并且此映射不允许空键
        IllegalArgumentException - 如果此地图本身有限制范围，而 toKey位于范围范围之外

      • tailMap

        SortedMap<K,V> tailMap​(K fromKey)
        返回此地图部分的视图，其键大于或等于fromKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于tailMap(fromKey, true) 。

        Specified by:
        tailMap在接口 SortedMap<K,V>
        参数
        fromKey - 返回地图中的键的低端点（含）
        结果
        该地图的部分的视图，其键大于或等于 fromKey
        异常
        ClassCastException - 如果fromKey与此映射的比较器不兼容（或者如果映射没有比较器，则fromKey不实现Comparable ）。 如果fromKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey为空，并且此映射不允许空键
        IllegalArgumentException - if this map itself has a restricted range, and fromKey lies outside the bounds of the range
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NavigableSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface NavigableSet<E>

  • 参数类型
    E - 由此集合维护的元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E> ， Set<E> ， SortedSet<E>
    所有已知实现类：
    ConcurrentSkipListSet ， TreeSet

    public interface NavigableSet<E>
extends SortedSet<E>
    A SortedSet扩展了导航方法报告给定搜索目标的最匹配。 方法lower(E) ， floor(E) ， ceiling(E)和higher(E)个返回元件分别大于给定的元素小于，小于或等于，大于或等于，大于，返回null如果不存在这样的元件。

    A NavigableSet可以按升序或降序进行访问和遍历。 descendingSet()方法返回集合的视图，其中所有关系和方向方法的意义都反转。 上升操作和观点的表现可能比降序更快。 该接口另外定义方法pollFirst()和pollLast() ，返回并移除最低和最高元素（如果存在），否则返回null 。 方法subSet(E, boolean, E, boolean) ， headSet(E, boolean)和tailSet(E, boolean)从等命名的不同SortedSet在接受描述的下限和上限是否是包含性的抗排斥附加参数的方法。 任何NavigableSet子集必须实现NavigableSet接口。

    在允许null元素的实现中，导航方法的返回值可能不明确。 然而，即使在这种情况下，结果可以通过检查contains(null)来消除歧义。 为了避免这样的问题，鼓励这个接口的实现不允许插入null元件。 （请注意， Comparable元素的排序集本质上不允许null ））

    方法subSet(E, E) ， headSet(E) ，并tailSet(E)被指定为返回SortedSet ，以允许现有的实现SortedSet能相容地改进来实现NavigableSet ，但鼓励扩展和该接口的实现重写这些方法返回NavigableSet 。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      E ceiling​(E e)
      返回此集合中最小元素大于或等于给定元素，如果没有此元素，则 null 。
      Iterator<E> descendingIterator​()
      以降序返回该集合中的元素的迭代器。
      NavigableSet<E> descendingSet​()
      返回此集合中包含的元素的反向排序视图。
      E floor​(E e)
      返回该集合中最大的元素小于或等于给定元素，如果没有这样的元素，则 null 。
      SortedSet<E> headSet​(E toElement)
      返回此集合的部分的视图，其元素严格小于 toElement 。
      NavigableSet<E> headSet​(E toElement, boolean inclusive)
      返回此集合的部分的视图，其元素小于（或等于，如果 inclusive为真） toElement 。
      E higher​(E e)
      返回此集中的最小元素严格大于给定元素，如果没有此元素，则 null 。
      Iterator<E> iterator​()
      以升序返回此集合中的元素的迭代器。
      E lower​(E e)
      返回这个集合中最大的元素严格小于给定的元素，如果没有这样的元素，则 null 。
      E pollFirst​()
      检索并删除第一个（最低）元素，如果此集合为空，则返回 null 。
      E pollLast​()
      检索并删除最后一个（最高）元素，如果此集合为空，则返回 null 。
      NavigableSet<E> subSet​(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
      返回该集合的部分的视图，其元素的范围从 fromElement到 toElement 。
      SortedSet<E> subSet​(E fromElement, E toElement)
      返回此集合的部分的视图，其元素的范围从 fromElement （包括）到 toElement ，排他。
      SortedSet<E> tailSet​(E fromElement)
      返回此组件的元素大于或等于 fromElement的部分的视图。
      NavigableSet<E> tailSet​(E fromElement, boolean inclusive)
      返回此集合的部分的视图，其元素大于（或等于，如果 inclusive为真） fromElement 。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, toArray, toArray

      • Methods inherited from interface java.util.SortedSet

        comparator, first, last, spliterator

    • 方法详细信息

      • lower

        E lower​(E e)
        返回这个集合中最大的元素，严格小于给定的元素，如果没有这样的元素，则 null 。
        参数
        e - 要匹配的值
        结果
        最大元素小于 e ，如果没有这样的元素， null
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且该集合不允许空元素

      • floor

        E floor​(E e)
        返回该集合中最大的元素小于或等于给定的元素，如果没有这样的元素，则 null 。
        参数
        e - 要匹配的值
        结果
        最大元素小于或等于 e ，如果没有这样的元素， null
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且此集合不允许空元素

      • ceiling

        E ceiling​(E e)
        返回此集合中最小元素大于或等于给定元素，如果没有此元素，则 null 。
        参数
        e - 要匹配的值
        结果
        最小元素大于或等于 e ，或 null如果没有这样的元素
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且该集合不允许空元素

      • higher

        E higher​(E e)
        返回这个集合中的最小元素严格大于给定的元素，如果没有这样的元素，则 null 。
        参数
        e - 要匹配的值
        结果
        最小元素大于 e ，如果没有这样的元素， null
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且此集合不允许空元素

      • pollFirst

        E pollFirst​()
        检索并删除第一个（最低）元素，如果此集合为空，则返回 null 。
        结果
        第一个元素，或 null如果此集合为空

      • pollLast

        E pollLast​()
        检索并删除最后一个（最高）元素，如果此集合为空，则返回 null 。
        结果
        最后一个元素，或 null如果此集合为空

      • iterator

        Iterator<E> iterator​()
        以升序返回此集合中的元素的迭代器。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 Set<E>
        结果
        在这个集合中的元素的迭代器，按升序排列

      • descendingSet

        NavigableSet<E> descendingSet​()
        返回此集合中包含的元素的反向排序视图。 下降集由此集合支持，因此对集合的更改反映在下降集中，反之亦然。 如果任何一个集合都被修改，而任一集合中的迭代正在进行（除了通过迭代器自己的remove操作），迭代的结果是未定义的。

        返回的集合的订单等价于Collections.reverseOrder (comparator()) 。 表达s.descendingSet().descendingSet()返回一个视图的s实质上等同于s 。

        结果
        这个集合的逆序视图

      • descendingIterator

        Iterator<E> descendingIterator​()
        以降序返回该集合中的元素的迭代器。 等效于descendingSet().iterator() 。
        结果
        在这个集合中的元素的迭代器，按降序

      • subSet

        NavigableSet<E> subSet​(E fromElement,
                       boolean fromInclusive,
                       E toElement,
                       boolean toInclusive)
        返回此集合的部分的视图，其元素的范围从fromElement到toElement 。 如果fromElement和toElement相等，则返回的集合为空，除非fromInclusive和toInclusive都为真。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        参数
        fromElement - 返回集合的低端点
        fromInclusive - true如果低端点要包含在返回的视图中
        toElement - 返回集合的高端点
        toInclusive - true如果高端点要包含在返回的视图中
        结果
        该集合的部分的视图，其元素的范围从 fromElement （含）到 toElement ，独占
        异常
        ClassCastException - 如果fromElement和toElement无法使用该集合的比较器彼此进行比较（或者，如果该集合没有比较器，则使用自然排序）。 如果fromElement或toElement无法与当前在集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement或 toElement为空，并且此集合不允许空元素
        IllegalArgumentException - 如果fromElement大于toElement ; 或者如果此设置本身具有限制范围，并且fromElement或toElement位于范围的边界之外。

      • headSet

        NavigableSet<E> headSet​(E toElement,
                        boolean inclusive)
        返回此集合的部分的视图，该部分的元素小于（或等于，如果inclusive为真） toElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        参数
        toElement - 返回集合的高端点
        inclusive - true如果高端点要包含在返回的视图中
        结果
        该集合的部分的元素的视图小于（或等于，如果为 inclusive为真） toElement
        异常
        ClassCastException - 如果toElement与此集合的比较器不兼容（或者如果该集合没有比较器，如果toElement不实现Comparable ）。 如果toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toElement为空，并且此集合不允许空元素
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 toElement位于范围的边界之外

      • tailSet

        NavigableSet<E> tailSet​(E fromElement,
                        boolean inclusive)
        返回此集合的部分的视图，其元素大于（或等于，如果inclusive为true） fromElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        参数
        fromElement - 返回集合的低端点
        inclusive - true如果低端点要包含在返回的视图中
        结果
        该集合的部分的视图，其元素大于或等于 fromElement
        异常
        ClassCastException - 如果fromElement与此设置的比较器不兼容（或如果该集合没有比较器，如果fromElement不实现Comparable ）。 如果fromElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement为空，并且此集合不允许空元素
        IllegalArgumentException - 如果这个集合本身具有有限的范围，并且 fromElement位于范围的边界之外

      • subSet

        SortedSet<E> subSet​(E fromElement,
                    E toElement)
        返回此集合的部分的视图，其元素的范围从fromElement （含）到toElement ，独占。 （如果fromElement和toElement相等，则返回的集合为空。）返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        相当于subSet(fromElement, true, toElement, false) 。

        Specified by:
        subSet在接口 SortedSet<E>
        参数
        fromElement - 返回集合的低端点（含）
        toElement - 返回集合的高端点（独占）
        结果
        该集合的部分的视图，其元素的范围从 fromElement （包括）到 toElement ，独占
        异常
        ClassCastException - 如果fromElement和toElement无法使用该集合的比较器彼此进行比较（或者如果该集合没有比较器，则使用自然排序）。 如果fromElement或toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement或 toElement为空，并且此集合不允许空元素
        IllegalArgumentException - 如果fromElement大于toElement ; 或者如果此设置本身具有限制范围，并且fromElement或toElement位于范围的边界之外

      • headSet

        SortedSet<E> headSet​(E toElement)
        返回该集合的部分的视图，其元素严格小于toElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        相当于headSet(toElement, false) 。

        Specified by:
        headSet在接口 SortedSet<E>
        参数
        toElement - 返回集合的高端点（独占）
        结果
        该集合的部分的视图，其元素严格小于 toElement
        异常
        ClassCastException - 如果toElement与此设置的比较器不兼容（或者如果该集合没有比较器，如果toElement不实现Comparable ）。 如果toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toElement为空，并且此集合不允许空元素
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 toElement位于范围的边界之外

      • tailSet

        SortedSet<E> tailSet​(E fromElement)
        返回此集合的部分的视图，该部分的元素大于或等于fromElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        相当于tailSet(fromElement, true) 。

        Specified by:
        tailSet在接口 SortedSet<E>
        参数
        fromElement - 返回集合的低端点（含）
        结果
        该集合的部分的视图，其元素大于或等于 fromElement
        异常
        ClassCastException - 如果fromElement与此设置的比较器不兼容（或如果该组没有比较器，则fromElement不实现Comparable ）。 如果fromElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement为空，并且此集合不允许空元素
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 fromElement位于范围的边界之外
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NoSuchElementException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class NoSuchElementException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.util.NoSuchElementException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    InputMismatchException

    public class NoSuchElementException
extends RuntimeException
    被各种访问器方法抛出，表示被请求的元素不存在。
    从以下版本开始：
    1.0
    另请参见：
    Enumeration.nextElement() ， Iterator.next() ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchElementException​()
      构造一个 NoSuchElementException其中 null作为其错误消息字符串。
      NoSuchElementException​(String s)
      构造一个 NoSuchElementException ，保存对错误消息字符串 s的引用，以供稍后通过 getMessage方法检索。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchElementException

        public NoSuchElementException​()
        构造一个 NoSuchElementException其中 null为错误消息字符串。

      • NoSuchElementException

        public NoSuchElementException​(String s)
        构造一个 NoSuchElementException ，保存对错误消息字符串 s的引用，以供稍后通过 getMessage方法检索。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Objects (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Objects

  • java.lang.Object
    • java.util.Objects

  • public final class Objects
extends Object
    此类由static用于在对象上操作的实用方法或在操作之前检查某些条件。 这些实用程序包括用于计算对象的哈希码，返回对象的字符串，比较两个对象以及检查索引或子范围值是否超出范围的null或null - null方法。
    API Note:
    静态方法如checkIndex(int, int) ， checkFromToIndex(int, int, int) ，和checkFromIndexSize(int, int, int)提供了用于检查的方便，如果对应于索引和子范围值外的边界。 这些静态方法的变化支持定制运行时异常以及相应的异常详细消息，当值超出范围时抛出异常。 这种方法接受函数接口参数（ BiFunction实例），将外联值映射到运行时异常。 当使用这样的方法结合使用lambda表达式，方法引用或捕获值的类的参数时，应该小心。 在这种情况下，与功能接口分配相关的捕获成本可能会超过检查边界的成本。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static int checkFromIndexSize​(int fromIndex, int size, int length)
      检查是否在子范围从 fromIndex （含）至 fromIndex + size （不包括）是范围界限内 0 （包括）到 length （不包括）。
      static int checkFromToIndex​(int fromIndex, int toIndex, int length)
      检查是否在子范围从 fromIndex （含）至 toIndex （不包括）是范围界限内 0 （包括）到 length （不包括）。
      static int checkIndex​(int index, int length)
      检查 index是否在范围从 0 （含）到 length （排他）的范围内。
      static <T> int compare​(T a, T b, Comparator<? super T> c)
      如果参数相同，则返回0，否则返回 c.compare(a, b) 。
      static boolean deepEquals​(Object a, Object b)
      返回 true如果参数是深层相等，彼此 false否则。
      static boolean equals​(Object a, Object b)
      返回 true如果参数相等，彼此 false否则。
      static int hash​(Object... values)
      为输入值序列生成哈希码。
      static int hashCode​(Object o)
      返回非的哈希码 null参数，0为 null参数。
      static boolean isNull​(Object obj)
      返回 true如果提供的引用是 null否则返回 false 。
      static boolean nonNull​(Object obj)
      返回 true如果提供的参考是非 null否则返回 false 。
      static <T> T requireNonNull​(T obj)
      检查指定的对象引用不是 null 。
      static <T> T requireNonNull​(T obj, String message)
      检查指定的对象引用不是null并抛出自定义的NullPointerException（如果是）。
      static <T> T requireNonNull​(T obj, Supplier<String> messageSupplier)
      检查指定的对象引用不是null并抛出自定义的NullPointerException（如果是）。
      static <T> T requireNonNullElse​(T obj, T defaultObj)
      如果非 null返回第一个参数，否则返回非 null第二个参数。
      static <T> T requireNonNullElseGet​(T obj, Supplier<? extends T> supplier)
      如果它不是 null ，则返回第一个参数，否则返回非 null值为 supplier.get() 。
      static String toString​(Object o)
      返回非 null参数调用 toString的结果和 null参数的 "null"的 null 。
      static String toString​(Object o, String nullDefault)
      如果第一个参数不是 null ，则返回第一个参数上调用 toString的结果，否则返回第二个参数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • equals

        public static boolean equals​(Object a,
                             Object b)
        返回true如果参数相等，彼此false否则。 因此，如果这两个参数是null ， true返回，如果只有一个参数为null ， false返回。 否则，通过使用第一个参数的equals方法来确定相等性。
        参数
        a - 一个对象
        b - 要与 a进行比较的对象
        结果
        true如果参数彼此相等，否则为 false
        另请参见：
        Object.equals(Object)

      • deepEquals

        public static boolean deepEquals​(Object a,
                                 Object b)
        返回true如果参数是深层相等，彼此false否则。 两个null值相当。 如果两个参数都是数组，则使用Arrays.deepEquals中的算法来确定相等。 否则，使用第一个参数的equals方法确定相等性。
        参数
        a - 一个对象
        b - 要与深度相等的 a进行比较的对象
        结果
        true如果参数彼此深深相等，否则为 false
        另请参见：
        Arrays.deepEquals(Object[], Object[]) ， equals(Object, Object)

      • hashCode

        public static int hashCode​(Object o)
        返回非的哈希码 null参数，0为 null参数。
        参数
        o - 一个对象
        结果
        非的哈希码 null参数，0为 null参数
        另请参见：
        Object.hashCode()

      • hash

        public static int hash​(Object... values)
        为输入值序列生成哈希码。 生成哈希码，就好像将所有输入值都放入数组一样，并且该数组通过调用Arrays.hashCode(Object[])进行哈希处理 。

        该方法对于包含多个字段的对象实现Object.hashCode()很有用。 例如，如果有三个字段，对象x ， y ，以及z ，一个可以这样写：

         @Override public int hashCode() {
     return Objects.hash(x, y, z);
 }
        警告：当提供单个对象引用时，返回的值不等于该对象引用的哈希码。 该值可以通过调用hashCode(Object)来计算。
        参数
        values - 要散列的值
        结果
        输入值序列的哈希值
        另请参见：
        Arrays.hashCode(Object[]) ， List.hashCode()

      • toString

        public static String toString​(Object o)
        返回调用的结果 toString的非 null参数， "null"为 null的说法。
        参数
        o - 一个对象
        结果
        调用 toString非 null参数和 "null"为 null参数的结果
        另请参见：
        Object.toString() ， String.valueOf(Object)

      • toString

        public static String toString​(Object o,
                              String nullDefault)
        如果第一个参数不是 null ，则返回第一个参数中调用 toString的结果，否则返回第二个参数。
        参数
        o - 一个对象
        nullDefault - 如果第一个参数是 null ，则返回的字符串
        结果
        调用 toString对第一个参数的结果，如果不是 null ，否则为第二个参数。
        另请参见：
        toString(Object)

      • compare

        public static <T> int compare​(T a,
                              T b,
                              Comparator<? super T> c)
        如果参数相同，则返回0，否则返回c.compare(a, b) 。 因此，如果两个参数都为null则返回0。

        请注意，如果其中一个参数为null ， NullPointerException可能会抛出null ，或者可能不会抛出null ，具体取决于Comparator选择具有null值的订购策略（如果有）。

        参数类型
        T - 正在比较的对象的类型
        参数
        a - 一个对象
        b - 要与 a进行比较的对象
        c - Comparator比较前两个参数
        结果
        如果参数相同， c.compare(a, b) 0，否则为 c.compare(a, b) 。
        另请参见：
        Comparable ， Comparator

      • requireNonNull

        public static <T> T requireNonNull​(T obj)
        检查指定的对象引用不是null 。 该方法主要用于在方法和构造函数中进行参数验证，如下所示：
         public Foo(Bar bar) {
     this.bar = Objects.requireNonNull(bar);
 }
        参数类型
        T - 参考的类型
        参数
        obj - 检查无效的对象引用
        结果
        obj如果不是 null
        异常
        NullPointerException - 如果 obj是 null

      • requireNonNull

        public static <T> T requireNonNull​(T obj,
                                   String message)
        检查指定的对象引用不是null并抛出自定义的NullPointerException（如果是）。 该方法主要用于在具有多个参数的方法和构造函数中进行参数验证，如下所示：
         public Foo(Bar bar, Baz baz) {
     this.bar = Objects.requireNonNull(bar, "bar must not be null");
     this.baz = Objects.requireNonNull(baz, "baz must not be null");
 }
        参数类型
        T - 参考的类型
        参数
        obj - 检查无效的对象引用
        message - 在抛出 NullPointerException的情况下使用的详细消息
        结果
        obj如果不是 null
        异常
        NullPointerException - 如果 obj是 null

      • isNull

        public static boolean isNull​(Object obj)
        返回 true如果提供的参考是 null ，否则返回 false 。
        API Note:
        这种方法存在着用作Predicate ， filter(Objects::isNull)
        参数
        obj - 对 null进行检查的参考
        结果
        true如果提供的参考是 null否则 false
        从以下版本开始：
        1.8
        另请参见：
        Predicate

      • nonNull

        public static boolean nonNull​(Object obj)
        返回 true如果提供的引用是非 null否则返回 false 。
        API Note:
        这种方法存在着用作Predicate ， filter(Objects::nonNull)
        参数
        obj - 要针对 null进行检查的引用
        结果
        true如果提供的参考是非 null否则 false
        从以下版本开始：
        1.8
        另请参见：
        Predicate

      • requireNonNullElse

        public static <T> T requireNonNullElse​(T obj,
                                       T defaultObj)
        如果非 null返回第一个参数，否则返回非 null第二个参数。
        参数类型
        T - 参考的类型
        参数
        obj - 一个对象
        defaultObj - 如果第一个参数是 null ，则返回一个非 null对象
        结果
        第一个参数，如果它是非 null否则第二个参数，如果它是非 null
        异常
        NullPointerException - 如果 obj为空，而 defaultObj为 null
        从以下版本开始：
        9

      • requireNonNullElseGet

        public static <T> T requireNonNullElseGet​(T obj,
                                          Supplier<? extends T> supplier)
        如果非 null ，则返回第一个参数，否则返回非 null值为 supplier.get() 。
        参数类型
        T - 第一个参数和返回类型的类型
        参数
        obj - 一个对象
        supplier - 如果第一个参数是 null ，则返回一个非 null对象
        结果
        第一个参数如果是非 null ，否则从 supplier.get()的值是非 null
        异常
        NullPointerException - 如果 obj为空，而 supplier为 null或 supplier.get()为 null
        从以下版本开始：
        9

      • requireNonNull

        public static <T> T requireNonNull​(T obj,
                                   Supplier<String> messageSupplier)
        检查指定的对象引用不是null并抛出自定义的NullPointerException（如果是）。

        与方法requireNonNull(Object, String)不同，该方法允许创建要延迟的消息，直到进行空检查为止。 虽然这可能在非空情况下赋予性能优势，但在决定调用此方法时，应注意创建消息提供者的成本低于直接创建字符串消息的成本。

        参数类型
        T - 参考的类型
        参数
        obj - 检查无效的对象引用
        messageSupplier - 在抛出 NullPointerException情况下使用的详细消息的供应商
        结果
        obj如果不是 null
        异常
        NullPointerException - 如果 obj是 null
        从以下版本开始：
        1.8

      • checkIndex

        public static int checkIndex​(int index,
                             int length)
        检查index是否在范围从0 （含）到length （独占）范围内。

        如果以下任何不等式为真，则index被定义为超出界限：

        • index < 0
        • index >= length
        • length < 0 ，这是前不平等所暗示的
        参数
        index - 索引
        length - 范围的上限（排他）
        结果
        index如果它在范围的范围内
        异常
        IndexOutOfBoundsException - 如果 index是超出范围
        从以下版本开始：
        9

      • checkFromToIndex

        public static int checkFromToIndex​(int fromIndex,
                                   int toIndex,
                                   int length)
        检查是否在子范围从fromIndex （含）至toIndex （不包括）是范围界限内0 （包括）到length （不包括）。

        如果以下任何不等式为真，则子范围被定义为超出范围：

        • fromIndex < 0
        • fromIndex > toIndex
        • toIndex > length
        • length < 0 ，这是前不平等所暗示的
        参数
        fromIndex - 子范围的下限（含）
        toIndex - 子范围的上限（排他）
        length - 上限（排除）范围
        结果
        fromIndex如果子范围内的范围内
        异常
        IndexOutOfBoundsException - 如果子范围超出范围
        从以下版本开始：
        9

      • checkFromIndexSize

        public static int checkFromIndexSize​(int fromIndex,
                                     int size,
                                     int length)
        检查是否在子范围从fromIndex （含）至fromIndex + size （不包括）是范围界限内0 （包括）到length （不包括）。

        如果以下任何不等式为真，则子范围被定义为超出范围：

        • fromIndex < 0
        • size < 0
        • fromIndex + size > length ，考虑到整数溢出
        • length < 0 ，这是前不平等所暗示的
        参数
        fromIndex - 子间隔的下限（含）
        size - 子范围的大小
        length - 范围的上限（排除）
        结果
        fromIndex如果子范围内的范围内
        异常
        IndexOutOfBoundsException - 如果子范围超出范围
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Observable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Observable

  • java.lang.Object
    • java.util.Observable
  • 已过时。
    此类和Observer接口已被弃用。 Observer和Observable支持的事件模式是非常有限的， Observable发送的通知顺序是未指定的，状态更改不与通知一一对应。 对于更丰富的事件模型，请考虑使用java.beans软件包。 对于线程之间的可靠和有序的消息传递，请考虑使用java.util.concurrent包中的并发数据结构之一。 对于反应流样式编程，请参阅Flow API。

    @Deprecated(since="9")
public class Observable
extends Object
    此类表示可观察对象或模型视图范例中的“数据”。 它可以被子类化以表示应用程序想要观察到的对象。

    可观察对象可以有一个或多个观察者。 观察者可以是实现接口Observer任何对象。 在可观察到的实例发生变化之后，调用Observable的notifyObservers方法的应用程序会使其所有观察者通过调用其update方法通知更改。

    通知的发送顺序是未指定的。 Observable类中提供的默认实现将以注册感兴趣的顺序通知Observers，但子类可能会更改此顺序，不使用保证的顺序，在单独的线程上发送通知，或者可以保证其子类遵循此顺序，因为它们选择。

    请注意，此通知机制无关，与线程，是从完全独立wait和notify类的机制Object 。

    当新创建一个可观察对象时，其观察者集合为空。 当且仅当equals方法为它们返回true时，两个观察者被认为是相同的。

    从以下版本开始：
    1.0
    另请参见：
    notifyObservers() ， notifyObservers(java.lang.Object) ， Observer ， Observer.update(java.util.Observable, java.lang.Object)

    • 构造方法摘要

      构造方法
      Constructor 描述
      Observable​()
      已过时。
      用零观察者构建可观测值。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addObserver​(Observer o)
      已过时。
      将一个观察者添加到该对象的观察者组中，前提是它与集合中已有的一些观察者不一样。
      protected void clearChanged​()
      已过时。
      表示此对象已不再更改，或已经通知其所有观察者其最近更改，因此 hasChanged方法现在将返回 false 。
      int countObservers​()
      已过时。
      返回此 Observable对象的观察者数。
      void deleteObserver​(Observer o)
      已过时。
      从该对象的观察者组中删除观察者。
      void deleteObservers​()
      已过时。
      清除观察者列表，使此对象不再有任何观察者。
      boolean hasChanged​()
      已过时。
      测试此对象是否已更改。
      void notifyObservers​()
      已过时。
      如果此对象已更改，如 hasChanged方法所示，然后通知所有其观察者，然后调用 clearChanged方法来指示此对象已不再更改。
      void notifyObservers​(Object arg)
      已过时。
      如果此对象已更改，如 hasChanged方法所示，则通知其所有观察者，然后调用 clearChanged方法来指示此对象已不再更改。
      protected void setChanged​()
      已过时。
      将此Observable对象标记为已更改; hasChanged方法现在将返回true 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Observable

        public Observable​()
        已过时。
        用零观察者构建可观测值。

    • 方法详细信息

      • addObserver

        public void addObserver​(Observer o)
        已过时。
        将一个观察者添加到该对象的观察者组中，前提是它与集合中已有的一些观察者不一样。 未指定通知发送给多个观察者的顺序。 看到课堂评论。
        参数
        o - 要添加的观察者。
        异常
        NullPointerException - 如果参数o为空。

      • deleteObserver

        public void deleteObserver​(Observer o)
        已过时。
        从该对象的观察者组中删除观察者。 传递null到这个方法将没有效果。
        参数
        o - 要删除的观察者。

      • notifyObservers

        public void notifyObservers​()
        已过时。
        如果此对象已更改，如hasChanged方法所示，则通知其所有观察者，然后调用clearChanged方法来指示此对象已不再更改。

        每个观察者都有其update方法调用两个参数：这个可观察对象和null 。 换句话说，这个方法相当于：

        notifyObservers(null)
        另请参见：
        clearChanged() ，
hasChanged() ，
Observer.update(java.util.Observable, java.lang.Object)

      • notifyObservers

        public void notifyObservers​(Object arg)
        已过时。
        如果此对象发生更改，如hasChanged ，则通知所有其观察者，然后调用clearChanged方法来指示此对象已不再更改。

        每个观察者都有其update方法调用两个参数：这个可观察对象和arg参数。

        参数
        arg - 任何对象。
        另请参见：
        clearChanged() ，
hasChanged() ，
Observer.update(java.util.Observable, java.lang.Object)

      • deleteObservers

        public void deleteObservers​()
        已过时。
        清除观察者列表，使此对象不再有任何观察者。

      • setChanged

        protected void setChanged​()
        已过时。
        将此Observable对象标记为已更改; hasChanged方法现在将返回true 。

      • clearChanged

        protected void clearChanged​()
        已过时。
        表示此对象已不再更改，或已经通知其所有观察者其最近更改，因此hasChanged方法现在将返回false 。 这种方法是由notifyObservers方法自动调用的。
        另请参见：
        notifyObservers() ， notifyObservers(java.lang.Object)

      • hasChanged

        public boolean hasChanged​()
        已过时。
        测试此对象是否已更改。
        结果
        true当且仅当setChanged方法最近被调用了该对象上的clearChanged方法时; false否则。
        另请参见：
        clearChanged() ， setChanged()

      • countObservers

        public int countObservers​()
        已过时。
        返回此 Observable对象的观察者数。
        结果
        the number of observers of this object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Observer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Observer

  • 已过时。
    此接口已被弃用。 有关详细信息，请参阅Observable课程。

    @Deprecated(since="9")
public interface Observer
    当它想要被通知可观察对象的变化时，类可以实现 Observer接口。
    从以下版本开始：
    1.0
    另请参见：
    Observable

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      void update​(Observable o, Object arg)
      已过时。
      每当观察到的对象发生变化时，都会调用此方法。

    • 方法详细信息

      • update

        void update​(Observable o,
            Object arg)
        已过时。
        每当观察到的对象发生变化时，都会调用此方法。 一个应用程序调用一个Observable对象的notifyObservers方法，让所有对象的观察者通知更改。
        参数
        o - 可观察对象。
        arg - 传递给 notifyObservers方法的参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Optional (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Optional<T>

  • java.lang.Object
    • java.util.Optional<T>
  • 参数类型
    T - 值的类型

    public final class Optional<T>
extends Object
    可能包含或不包含非null值的容器对象。 如果存在值，则isPresent()返回true ，返回值为get() 。

    提供依赖于存在或不存在包含值的附加方法，例如orElse() （如果没有值，则返回默认值）和ifPresent() （如果值存在则执行操作）。

    这是一个value-based课; 在Optional实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预知的结果，应该避免。

    API Note:
    Optional主要用作方法返回类型，其中明确需要表示“否结果”，并且使用null可能会导致错误。 类型为Optional变量本身不应为null ; 它应该总是指向一个Optional实例。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static <T> Optional<T> empty​()
      返回一个空的 Optional实例。
      boolean equals​(Object obj)
      指示某个其他对象是否等于此 Optional 。
      Optional<T> filter​(Predicate<? super T> predicate)
      如果存在值，并且该值与给定谓词匹配，则返回描述该值的 Optional ，否则返回一个空的 Optional 。
      <U> Optional<U> flatMap​(Function<? super T,? extends Optional<? extends U>> mapper)
      如果存在值，则返回将给定的 Optional映射函数应用于该值的结果，否则返回一个空的 Optional 。
      T get​()
      如果值存在，则返回值，否则抛出 NoSuchElementException 。
      int hashCode​()
      返回值的哈希码（如果存在），否则，如果没有值，则 0 （零）。
      void ifPresent​(Consumer<? super T> action)
      如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
      void ifPresentOrElse​(Consumer<? super T> action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      boolean isPresent​()
      如果存在值，则返回 true ，否则为 false 。
      <U> Optional<U> map​(Function<? super T,? extends U> mapper)
      如果存在值，则返回一个 Optional描述（如果由 ofNullable(T) ）将给定的映射函数应用于该值的结果，否则返回一个空的 Optional 。
      static <T> Optional<T> of​(T value)
      返回一个 Optional描述给定的非 null值。
      static <T> Optional<T> ofNullable​(T value)
      返回描述给定值的 Optional ，如果 null ，否则返回一个空的 Optional 。
      Optional<T> or​(Supplier<? extends Optional<? extends T>> supplier)
      如果值存在时，返回一个 Optional描述的值，否则返回一个 Optional通过供给函数产生。
      T orElse​(T other)
      如果存在值，则返回值，否则返回 other 。
      T orElseGet​(Supplier<? extends T> supplier)
      如果存在值，则返回值，否则返回由供应函数产生的结果。
      <X extends Throwable>
      T             		orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      Stream<T> stream​()
      如果存在值，则返回仅包含该值的序列Stream ，否则返回空Stream 。
      String toString​()
      返回适用于调试的 Optional的非空字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • empty

        public static <T> Optional<T> empty​()
        返回一个空的Optional实例。 这个Optional没有值。
        API Note:
        虽然可能很容易这样做，但如果对象是空的，则通过与==返回的实例进行比较，避免测试是否为Optional.empty() 。 不能保证是单身人士。 相反，请使用isPresent() 。
        参数类型
        T - 不存在的值的类型
        结果
        一个空的 Optional

      • of

        public static <T> Optional<T> of​(T value)
        返回一个 Optional描述给定的非 null值。
        参数类型
        T - 值的类型
        参数
        value - 要描述的值，它必须是非 null
        结果
        一个 Optional的值存在
        异常
        NullPointerException - 如果值为 null

      • ofNullable

        public static <T> Optional<T> ofNullable​(T value)
        返回描述给定值的 Optional ，如果非 null ，否则返回一个空的 Optional 。
        参数类型
        T - 值的类型
        参数
        value - 可能描述的 null值
        结果
        一个 Optional ，如果指定的值不是 null ，其值为现值，否则为空 Optional

      • get

        public T get​()
        如果存在值，返回值，否则抛出 NoSuchElementException 。
        API Note:
        方法 orElse和 orElseGet通常优于该方法，因为如果该值不存在则返回替代值，而不是抛出异常。
        结果
        该 null值描述为 Optional
        异常
        NoSuchElementException - 如果没有值
        另请参见：
        isPresent()

      • isPresent

        public boolean isPresent​()
        如果值存在，则返回 true ，否则为 false 。
        结果
        true如果一个值存在，否则 false

      • ifPresent

        public void ifPresent​(Consumer<? super T> action)
        如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
        参数
        action - 要执行的操作，如果值存在
        异常
        NullPointerException - 如果值存在，给定的操作是 null

      • ifPresentOrElse

        public void ifPresentOrElse​(Consumer<? super T> action,
                            Runnable emptyAction)
        如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
        参数
        action - 要执行的操作，如果值存在
        emptyAction - 要执行的基于空的操作，如果没有值
        异常
        NullPointerException - 如果存在值且给定的操作是 null ，或者不存在任何值，并且给定的基于空的操作是 null 。
        从以下版本开始：
        9

      • filter

        public Optional<T> filter​(Predicate<? super T> predicate)
        如果存在值，并且该值与给定谓词匹配，则返回描述该值的 Optional ，否则返回一个空的 Optional 。
        参数
        predicate - 应用于值的谓词（如果存在）
        结果
        一个 Optional描述了这个 Optional的值，如果一个值存在，该值与给定的谓词匹配，否则为空 Optional
        异常
        NullPointerException - 如果谓词是 null

      • map

        public <U> Optional<U> map​(Function<? super T,? extends U> mapper)
        如果存在一个值，则返回一个Optional描述（如果由ofNullable(T) ）将给定的映射函数应用于该值的结果，否则返回一个空的Optional 。

        如果映射函数返回一个null结果，那么这个方法返回一个空的Optional 。

        API Note:
        此方法支持对Optional值进行后处理，无需显式检查返回状态。 例如，以下代码遍历一个URI流，选择一个未处理的流，并从该URI创建路径，返回一个Optional<Path> ：
           Optional<Path> p = uris.stream().filter(uri -> !isProcessedYet(uri)) .findFirst() .map(Paths::get);
        这里， findFirst返回一个Optional<URI> ，然后map返回一个Optional<Path>为所需的URI（如果存在）。
        参数类型
        U - 从映射函数返回的值的类型
        参数
        mapper - 应用于值的映射函数（如果存在）
        结果
        一个 Optional描述了将映射函数应用于该值的值的 Optional ，如果值存在，否则为空 Optional
        异常
        NullPointerException - 映射函数是否为 null

      • flatMap

        public <U> Optional<U> flatMap​(Function<? super T,? extends Optional<? extends U>> mapper)
        如果存在值，则返回将给定的Optional映射函数应用于该值的结果，否则返回一个空的Optional 。

        此方法类似于map(Function) ，但映射函数的结果已经是Optional ，如果被调用， flatMap不会在额外的Optional 。

        参数类型
        U - 映射函数返回的 Optional的值的类型
        参数
        mapper - 应用于值的映射函数（如果存在）
        结果
        将 Optional映射函数应用于此 Optional的值的 Optional ，如果存在值，否则为空 Optional
        异常
        NullPointerException - 如果映射函数是 null或返回一个 null结果

      • or

        public Optional<T> or​(Supplier<? extends Optional<? extends T>> supplier)
        如果值存在时，返回一个 Optional描述的值，否则返回一个 Optional通过供给函数产生。
        参数
        supplier - 产生要返回的 Optional的供应功能
        结果
        返回一个描述 Optional的值的 Optional ，如果存在一个值，否则由供应函数产生一个 Optional 。
        异常
        NullPointerException - 如果供应功能是 null或产生一个 null结果
        从以下版本开始：
        9

      • stream

        public Stream<T> stream​()
        如果存在值，则返回仅包含该值的序列Stream ，否则返回空Stream 。
        API Note:
        该方法可用于将Stream的可选元素转换为Stream的现值元素：
           Stream<Optional<T>> os = .. Stream<T> s = os.flatMap(Optional::stream)
        结果
        可选值为 Stream
        从以下版本开始：
        9

      • orElse

        public T orElse​(T other)
        如果存在值，则返回值，否则返回 other 。
        参数
        other - 如果没有值，则返回的值。 可能是null 。
        结果
        该值，如果存在，否则为 other

      • orElseGet

        public T orElseGet​(Supplier<? extends T> supplier)
        如果存在值，则返回值，否则返回由供应函数产生的结果。
        参数
        supplier - 产生要返回的值的供应函数
        结果
        该值（如果存在），否则由供应功能产生的结果
        异常
        NullPointerException - 如果没有值，并且提供功能是 null

      • orElseThrow

        public <X extends Throwable> T orElseThrow​(Supplier<? extends X> exceptionSupplier)
                                    throws X extends Throwable
        如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
        API Note:
        可以使用具有空参数列表的异常构造函数的方法引用作为供应商。 例如， IllegalStateException::new
        参数类型
        X - 要抛出的异常的类型
        参数
        exceptionSupplier - 产生要抛出的异常的供应函数
        结果
        价值，如果存在
        异常
        X - 如果没有值
        NullPointerException - 如果没有值，异常提供功能是 null
        X extends Throwable

      • equals

        public boolean equals​(Object obj)
        指示某个其他对象是否等于此Optional 。 另一个对象被认为是相等的：
        • 它也是一个Optional和;
        • 或者;
        • 当前值通过equals()彼此“相等”。
        重写：
        equals在 Object
        参数
        obj - 要进行相等测试的对象
        结果
        true如果另一个对象是“等于”这个对象否则 false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回值的哈希码，如果存在，否则为 0 （零），如果没有值。
        重写：
        hashCode在 Object
        结果
        当前值的哈希码值，如果没有值，则为 0
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回适用于调试的Optional的非空字符串表示形式。 准确的表示格式是未指定的，可能会在实现和版本之间变化。
        重写：
        toString在 Object
        实现要求：
        如果存在值，则结果必须在其结果中包含其字符串表示形式。 空和现在Optional必须明确区分。
        结果
        该实例的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OptionalDouble (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class OptionalDouble

  • java.lang.Object
    • java.util.OptionalDouble

  • public final class OptionalDouble
extends Object
    可能包含或可能不包含double值的容器对象。 如果存在值，则isPresent()返回true ，返回值getAsDouble() 。

    提供依赖于包含值的存在或不存在的附加方法，例如orElse() （如果没有值，则返回默认值）和ifPresent() （如果值存在则执行操作）。

    这是一个value-based课; 对于OptionalDouble实例，使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。

    API Note:
    OptionalDouble主要用作方法返回类型，其中明确需要表示“无结果”。 类型为OptionalDouble变量本身不应为null ; 它应该总是指向一个OptionalDouble实例。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static OptionalDouble empty​()
      返回一个空的 OptionalDouble实例。
      boolean equals​(Object obj)
      指示某个其他对象是否等于此 OptionalDouble 。
      double getAsDouble​()
      如果值存在，则返回值，否则抛出 NoSuchElementException 。
      int hashCode​()
      返回值的哈希码，如果存在，否则为 0 （零），如果不存在值。
      void ifPresent​(DoubleConsumer action)
      如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
      void ifPresentOrElse​(DoubleConsumer action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      boolean isPresent​()
      如果存在值，则返回 true ，否则为 false 。
      static OptionalDouble of​(double value)
      返回描述给定值的 OptionalDouble 。
      double orElse​(double other)
      如果存在值，返回值，否则返回 other 。
      double orElseGet​(DoubleSupplier supplier)
      如果存在值，则返回值，否则返回由供应函数产生的结果。
      <X extends Throwable>
      double             		orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      DoubleStream stream​()
      如果存在值，则返回仅包含该值的序列DoubleStream ，否则返回空DoubleStream 。
      String toString​()
      返回适用于调试的 OptionalDouble的非空字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • empty

        public static OptionalDouble empty​()
        返回一个空的OptionalDouble实例。 这个OptionalDouble没有价值。
        API Note:
        虽然它可能是很有诱惑力的话，避免测试如果一个对象是通过比较空==对抗返回实例OptionalDouble.empty() 。 不能保证是单身人士。 相反，请使用isPresent() 。
        结果
        一个空的 OptionalDouble 。

      • of

        public static OptionalDouble of​(double value)
        返回描述给定值的 OptionalDouble 。
        参数
        value - 要描述的值
        结果
        一个 OptionalDouble的价值存在

      • getAsDouble

        public double getAsDouble​()
        如果值存在，则返回值，否则抛出 NoSuchElementException 。
        API Note:
        方法 orElse和 orElseGet通常优于该方法，因为如果该值不存在则返回替代值，而不是抛出异常。
        结果
        该值由此描述 OptionalDouble
        异常
        NoSuchElementException - 如果没有值
        另请参见：
        isPresent()

      • isPresent

        public boolean isPresent​()
        如果值存在，则返回 true ，否则为 false 。
        结果
        true如果一个值存在，否则 false

      • ifPresent

        public void ifPresent​(DoubleConsumer action)
        如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
        参数
        action - 要执行的操作，如果值存在
        异常
        NullPointerException - 如果值存在且给定的操作是 null

      • ifPresentOrElse

        public void ifPresentOrElse​(DoubleConsumer action,
                            Runnable emptyAction)
        如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
        参数
        action - 要执行的操作，如果值存在
        emptyAction - 要执行的基于空的操作，如果没有值
        异常
        NullPointerException - 如果存在值且给定的操作是 null ，或者没有值，而给定的基于空的操作是 null 。
        从以下版本开始：
        9

      • stream

        public DoubleStream stream​()
        如果存在值，则返回仅包含该值的序列DoubleStream ，否则返回空DoubleStream 。
        API Note:
        此方法可用于将Stream的可选双精度DoubleStream为目前双打的DoubleStream ：
           Stream<OptionalDouble> os = .. DoubleStream s = os.flatMapToDouble(OptionalDouble::stream)
        结果
        可选值为 DoubleStream
        从以下版本开始：
        9

      • orElse

        public double orElse​(double other)
        如果存在值，则返回值，否则返回 other 。
        参数
        other - 如果没有值，则返回的值
        结果
        该值，如果存在，否则为 other

      • orElseGet

        public double orElseGet​(DoubleSupplier supplier)
        如果存在值，则返回值，否则返回由供应函数产生的结果。
        参数
        supplier - 产生要返回的值的供应函数
        结果
        该值（如果存在），否则由供应功能产生的结果
        异常
        NullPointerException - 如果没有值，提供功能是 null

      • orElseThrow

        public <X extends Throwable> double orElseThrow​(Supplier<? extends X> exceptionSupplier)
                                         throws X extends Throwable
        如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
        API Note:
        可以使用具有空参数列表的异常构造函数的方法引用作为供应商。 例如， IllegalStateException::new
        参数类型
        X - 要抛出的异常的类型
        参数
        exceptionSupplier - 产生要抛出异常的供应函数
        结果
        价值，如果存在
        异常
        X - 如果没有值
        NullPointerException - 如果没有值，异常提供功能是 null
        X extends Throwable

      • equals

        public boolean equals​(Object obj)
        指示某个其他对象是否等于此OptionalDouble 。 另一个对象被认为是相等的：
        • 它也是一个OptionalDouble和;
        • 或者;
        • 当前值通过Double.compare() == 0彼此“相等”。
        重写：
        equals在 Object
        参数
        obj - 要测试的对象的相等性
        结果
        true如果另一个对象是“等于”这个对象否则 false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回值的哈希码（如果存在），否则，如果没有值，则 0 （零）。
        重写：
        hashCode在 Object
        结果
        当前值的哈希码值，如果没有值，则为 0
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回适用于调试的OptionalDouble的非空字符串表示形式。 准确的表示格式是未指定的，可能会在实现和版本之间变化。
        重写：
        toString在 Object
        实现要求：
        如果存在值，则结果必须在其结果中包含其字符串表示形式。 空和现在OptionalDouble必须明确区分。
        结果
        该实例的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OptionalInt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class OptionalInt

  • java.lang.Object
    • java.util.OptionalInt

  • public final class OptionalInt
extends Object
    可能包含或可能不包含int值的容器对象。 如果存在值，则isPresent()返回true ，返回值为getAsInt() 。

    提供依赖于存在或不存在包含值的附加方法，例如orElse() （如果没有值，则返回默认值）和ifPresent() （如果值存在则执行操作）。

    这是一个value-based类; 对于OptionalInt实例，使用身份敏感操作（包括参考相等性（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免。

    API Note:
    OptionalInt主要用作方法返回类型，其中明确需要表示“无结果”。 类型为OptionalInt变量本身不应为null ; 它应该总是指向一个OptionalInt实例。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static OptionalInt empty​()
      返回一个空的 OptionalInt实例。
      boolean equals​(Object obj)
      指示某个其他对象是否等于此 OptionalInt 。
      int getAsInt​()
      如果值存在，则返回值，否则抛出 NoSuchElementException 。
      int hashCode​()
      返回值的哈希码，如果存在，否则为 0 （零），如果没有值。
      void ifPresent​(IntConsumer action)
      如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
      void ifPresentOrElse​(IntConsumer action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      boolean isPresent​()
      如果存在值，则返回 true ，否则为 false 。
      static OptionalInt of​(int value)
      返回描述给定值的 OptionalInt 。
      int orElse​(int other)
      如果存在值，则返回值，否则返回 other 。
      int orElseGet​(IntSupplier supplier)
      如果存在值，则返回值，否则返回由供应函数产生的结果。
      <X extends Throwable>
      int             		orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      IntStream stream​()
      如果存在值，则返回仅包含该值的序列IntStream ，否则返回一个空的IntStream 。
      String toString​()
      返回适用于调试的 OptionalInt的非空字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • empty

        public static OptionalInt empty​()
        返回一个空的OptionalInt实例。 这个OptionalInt没有值。
        API Note:
        虽然它可能是很有诱惑力的话，避免测试如果一个对象是通过比较空==对抗返回实例OptionalInt.empty() 。 不能保证是单身人士。 相反，请使用isPresent() 。
        结果
        一个空的 OptionalInt

      • of

        public static OptionalInt of​(int value)
        返回描述给定值的 OptionalInt 。
        参数
        value - 要描述的值
        结果
        一个 OptionalInt与值存在

      • getAsInt

        public int getAsInt​()
        如果存在值，返回值，否则抛出 NoSuchElementException 。
        API Note:
        方法 orElse和 orElseGet通常优于该方法，因为如果该值不存在则返回替代值，而不是抛出异常。
        结果
        该值由此描述 OptionalInt
        异常
        NoSuchElementException - 如果没有值
        另请参见：
        isPresent()

      • isPresent

        public boolean isPresent​()
        如果存在值，则返回 true ，否则为 false 。
        结果
        true如果一个值存在，否则 false

      • ifPresent

        public void ifPresent​(IntConsumer action)
        如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
        参数
        action - 要执行的操作，如果值存在
        异常
        NullPointerException - 如果存在值且给定的操作是 null

      • ifPresentOrElse

        public void ifPresentOrElse​(IntConsumer action,
                            Runnable emptyAction)
        如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
        参数
        action - 要执行的操作，如果值存在
        emptyAction - 要执行的基于空的操作，如果没有值
        异常
        NullPointerException - 如果存在值且给定的操作是 null ，或者不存在任何值，并且给定的基于空的操作是 null 。
        从以下版本开始：
        9

      • stream

        public IntStream stream​()
        如果存在值，则返回仅包含该值的序列IntStream ，否则返回空IntStream 。
        API Note:
        此方法可用于将Stream的可选整数IntStream为当前整数的IntStream ：
           Stream<OptionalInt> os = .. IntStream s = os.flatMapToInt(OptionalInt::stream)
        结果
        可选值为 IntStream
        从以下版本开始：
        9

      • orElse

        public int orElse​(int other)
        如果存在值，则返回值，否则返回 other 。
        参数
        other - 如果没有值，则返回的值
        结果
        该值，如果存在，否则为 other

      • orElseGet

        public int orElseGet​(IntSupplier supplier)
        如果存在值，则返回值，否则返回由供应函数产生的结果。
        参数
        supplier - 产生要返回的值的供应函数
        结果
        该值（如果存在），否则由供应功能产生的结果
        异常
        NullPointerException - 如果没有值，并且提供功能是 null

      • orElseThrow

        public <X extends Throwable> int orElseThrow​(Supplier<? extends X> exceptionSupplier)
                                      throws X extends Throwable
        如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
        API Note:
        可以使用具有空参数列表的异常构造函数的方法引用作为供应商。 例如， IllegalStateException::new
        参数类型
        X - 要抛出的异常的类型
        参数
        exceptionSupplier - 产生要抛出的异常的供应函数
        结果
        价值，如果存在
        异常
        X - 如果没有值
        NullPointerException - 如果没有值，异常提供功能是 null
        X extends Throwable

      • equals

        public boolean equals​(Object obj)
        指示某个其他对象是否等于此OptionalInt 。 另一个对象被认为是相等的：
        • 它也是一个OptionalInt和;
        • 或者;
        • 当前值通过==彼此“相等”。
        重写：
        equals在 Object
        参数
        obj - 要进行相等测试的对象
        结果
        true如果另一个对象是“等于”这个对象否则 false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回值的哈希码，如果存在，否则为 0 （零），如果没有值。
        重写：
        hashCode在类 Object
        结果
        当前值的哈希码值，如果没有值，则为 0
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回适用于调试的OptionalInt的非空字符串表示形式。 准确的表示格式是未指定的，可能会在实现和版本之间变化。
        重写：
        toString在 Object
        实现要求：
        如果存在值，则结果必须在其结果中包含其字符串表示形式。 空和现在OptionalInt必须明确区分。
        结果
        该实例的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OptionalLong (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class OptionalLong

  • java.lang.Object
    • java.util.OptionalLong

  • public final class OptionalLong
extends Object
    一个可能含有也可能不包含long值的容器对象。 如果存在值， isPresent()返回true和getAsLong()返回值。

    提供依赖于包含值的存在或不存在的其他方法，例如orElse() （如果没有值，则返回默认值）和ifPresent() （如果值存在则执行操作）。

    这是一个value-based课; 在OptionalLong实例上使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会有不可预测的结果，应该避免。

    API Note:
    OptionalLong主要用作方法返回类型，其中明确需要表示“无结果”。 类型为OptionalLong变量本身不应该是null ; 它应该总是指向一个OptionalLong实例。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static OptionalLong empty​()
      返回一个空的 OptionalLong实例。
      boolean equals​(Object obj)
      指示某个其他对象是否等于此 OptionalLong 。
      long getAsLong​()
      如果值存在，则返回值，否则抛出 NoSuchElementException 。
      int hashCode​()
      返回值的哈希码，如果存在，否则为 0 （零），如果没有值。
      void ifPresent​(LongConsumer action)
      如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
      void ifPresentOrElse​(LongConsumer action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      boolean isPresent​()
      如果存在值，则返回 true ，否则为 false 。
      static OptionalLong of​(long value)
      返回描述给定值的 OptionalLong 。
      long orElse​(long other)
      如果存在值，则返回值，否则返回 other 。
      long orElseGet​(LongSupplier supplier)
      如果存在值，则返回值，否则返回由供应函数产生的结果。
      <X extends Throwable>
      long             		orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      LongStream stream​()
      如果存在值，则返回仅包含该值的顺序LongStream ，否则返回空LongStream 。
      String toString​()
      返回适用于调试的 OptionalLong的非空字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • empty

        public static OptionalLong empty​()
        返回一个空的OptionalLong实例。 这个OptionalLong没有值。
        API Note:
        虽然它可能是很有诱惑力的话，避免测试如果一个对象是通过比较空==对抗返回实例OptionalLong.empty() 。 不能保证是单身人士。 相反，请使用isPresent() 。
        结果
        一个空的 OptionalLong 。

      • of

        public static OptionalLong of​(long value)
        返回描述给定值的 OptionalLong 。
        参数
        value - 要描述的值
        结果
        一个 OptionalLong的价值存在

      • getAsLong

        public long getAsLong​()
        如果值存在，则返回值，否则抛出 NoSuchElementException 。
        API Note:
        方法 orElse和 orElseGet通常优于该方法，因为如果该值不存在则返回替代值，而不是抛出异常。
        结果
        该值由此描述 OptionalLong
        异常
        NoSuchElementException - 如果没有值
        另请参见：
        isPresent()

      • isPresent

        public boolean isPresent​()
        如果值存在，则返回 true ，否则为 false 。
        结果
        true如果一个值存在，否则 false

      • ifPresent

        public void ifPresent​(LongConsumer action)
        如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
        参数
        action - 要执行的操作，如果值存在
        异常
        NullPointerException - 如果存在值且给定的操作是 null

      • ifPresentOrElse

        public void ifPresentOrElse​(LongConsumer action,
                            Runnable emptyAction)
        如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
        参数
        action - 要执行的操作，如果存在值
        emptyAction - 如果没有值， emptyAction执行的基于空的操作
        异常
        NullPointerException - 如果存在值，给定操作是 null ，或者不存在值，并且给定的基于空的操作是 null 。
        从以下版本开始：
        9

      • stream

        public LongStream stream​()
        如果存在值，则返回仅包含该值的顺序LongStream ，否则返回空LongStream 。
        API Note:
        该方法可用于将Stream的可选长LongStream为现在的LongStream为LongStream ：
           Stream<OptionalLong> os = .. LongStream s = os.flatMapToLong(OptionalLong::stream)
        结果
        可选值为 LongStream
        从以下版本开始：
        9

      • orElse

        public long orElse​(long other)
        如果存在值，则返回值，否则返回 other 。
        参数
        other - 如果没有值，则返回的值
        结果
        该值，如果存在，否则为 other

      • orElseGet

        public long orElseGet​(LongSupplier supplier)
        如果存在值，则返回值，否则返回由供应函数产生的结果。
        参数
        supplier - 产生要返回的值的供应函数
        结果
        该值（如果存在），否则由供应功能产生的结果
        异常
        NullPointerException - 如果没有值，并且提供功能是 null

      • orElseThrow

        public <X extends Throwable> long orElseThrow​(Supplier<? extends X> exceptionSupplier)
                                       throws X extends Throwable
        如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
        API Note:
        可以使用具有空参数列表的异常构造函数的方法引用作为供应商。 例如， IllegalStateException::new
        参数类型
        X - 要抛出的异常的类型
        参数
        exceptionSupplier - 产生要抛出异常的供应函数
        结果
        价值，如果存在
        异常
        X - 如果没有值
        NullPointerException - 如果没有值，异常提供功能是 null
        X extends Throwable

      • equals

        public boolean equals​(Object obj)
        指示某个其他对象是否等于此OptionalLong 。 另一个对象被认为是相等的：
        • OptionalLong
        • 或者;
        • 当前值通过== “相等”。
        重写：
        equals在 Object
        参数
        obj - 要进行相等测试的对象
        结果
        true如果另一个对象是“等于”这个对象否则 false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回值的哈希码（如果存在），否则如果没有值，则 0 （零）。
        重写：
        hashCode在 Object
        结果
        当前值的哈希码值，如果没有值，则为 0
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回适用于调试的OptionalLong的非空字符串表示形式。 准确的表示格式是未指定的，可能会在实现和版本之间变化。
        重写：
        toString在 Object
        实现要求：
        如果存在值，则结果必须在其结果中包含其字符串表示形式。 空和现在OptionalLong必须明确区分。
        结果
        该实例的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrimitiveIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface PrimitiveIterator<T,T_CONS>

  • 参数类型
    T - 此PrimitiveIterator返回的元素的类型。 该类型必须是基本类型的包装器类型，例如Integer用于原语int类型。
    T_CONS - 原始消费者的类型。 该类型必须是T的T的原始专业化，例如IntConsumer（对于Integer 。
    All Superinterfaces:
    Iterator<T>
    All Known Subinterfaces:
    PrimitiveIterator.OfDouble ， PrimitiveIterator.OfInt ， PrimitiveIterator.OfLong

    public interface PrimitiveIterator<T,T_CONS>
extends Iterator<T>
    Iterator基本专长的基本类型。 提供了专门的亚型int ， long ，并double值。

    专门的子类型默认实现为Iterator.next()和Iterator.forEachRemaining(java.util.function.Consumer)框原始值到其对应的包装器类的实例。 这种拳击可以抵消在使用原始专长时获得的任何优势。 为了避免拳击，应该使用相应的基于图元的方法。 例如， PrimitiveIterator.OfInt.nextInt()和PrimitiveIterator.OfInt.forEachRemaining(java.util.function.IntConsumer)应优先于PrimitiveIterator.OfInt.next()和PrimitiveIterator.OfInt.forEachRemaining(java.util.function.Consumer)使用 。

    使用基于拳击的方法next()和forEachRemaining()对原始值的迭代不会影响遇到转换为框值的值的顺序。

    Implementation Note:
    如果布尔系统属性 org.openjdk.java.util.stream.tripwire设置为 true则在对原始子类型专用化进行操作时，如果发生基本值的 true则会报告诊断警告。
    从以下版本开始：
    1.8

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  PrimitiveIterator.OfDouble
      一个专门针对 double值的迭代器。
      static interface  PrimitiveIterator.OfInt
      一个专门针对 int值的迭代器。
      static interface  PrimitiveIterator.OfLong
      一个专门针对 long值的迭代器。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void forEachRemaining​(T_CONS action)
      对每个剩余的元素执行给定的动作，按照迭代时发生的顺序，直到所有元素都被处理或动作引发异常。

      • Methods inherited from interface java.util.Iterator

        forEachRemaining, hasNext, next, remove

    • 方法详细信息

      • forEachRemaining

        void forEachRemaining​(T_CONS action)
        对每个剩余的元素执行给定的动作，按照迭代时发生的顺序，直到所有元素都被处理或动作引发异常。 该操作抛出的错误或运行时异常被转发给调用者。
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrimitiveIterator.OfDouble (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface PrimitiveIterator.OfDouble

  • All Superinterfaces:
    Iterator<Double> ， PrimitiveIterator<Double,DoubleConsumer>
    Enclosing interface:
    PrimitiveIterator < T ， T_CONS >

    public static interface PrimitiveIterator.OfDouble
extends PrimitiveIterator<Double,DoubleConsumer>
    一个专门为 double值的迭代器。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.PrimitiveIterator

        PrimitiveIterator.OfDouble, PrimitiveIterator.OfInt, PrimitiveIterator.OfLong

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default void forEachRemaining​(Consumer<? super Double> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void forEachRemaining​(DoubleConsumer action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default Double next​()
      返回迭代中的下一个元素。
      double nextDouble​()
      返回下一个 double元素的迭代。

      • Methods inherited from interface java.util.Iterator

        hasNext, remove

    • 方法详细信息

      • nextDouble

        double nextDouble​()
        返回下一个 double元素的迭代。
        结果
        下一个 double元素在迭代中
        异常
        NoSuchElementException - 如果迭代没有更多的元素

      • forEachRemaining

        default void forEachRemaining​(DoubleConsumer action)
        对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        forEachRemaining在接口 PrimitiveIterator<Double,DoubleConsumer>
        实现要求：

        默认实现的行为如下：

           while (hasNext()) action.accept(nextDouble());
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的动作为空

      • next

        default Double next​()
        返回迭代中的下一个元素。
        Specified by:
        next在接口 Iterator<Double>
        实现要求：
        默认实现框将调用 nextDouble()的结果，并返回该盒装结果。
        结果
        迭代中的下一个元素

      • forEachRemaining

        default void forEachRemaining​(Consumer<? super Double> action)
        对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作以任何方式修改集合（即使通过调用remove方法或Iterator子类型的其他mutator方法），则迭代器的行为是未指定的，除非重写类已指定并发修改策略。

        如果动作引发异常，则未指定迭代器的后续行为。

        Specified by:
        forEachRemaining在接口 Iterator<Double>
        实现要求：
        如果操作是DoubleConsumer一个实例，那么它被转换为DoubleConsumer并传递给forEachRemaining(java.util.function.DoubleConsumer) ; 否则动作适应DoubleConsumer一个实例，通过拳击DoubleConsumer的参数，然后传递给forEachRemaining(java.util.function.DoubleConsumer) 。
        参数
        action - 要对每个元素执行的操作
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrimitiveIterator.OfInt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface PrimitiveIterator.OfInt

  • All Superinterfaces:
    Iterator<Integer> ， PrimitiveIterator<Integer,IntConsumer>
    Enclosing interface:
    PrimitiveIterator < T ， T_CONS >

    public static interface PrimitiveIterator.OfInt
extends PrimitiveIterator<Integer,IntConsumer>
    一个专门为 int值的迭代器。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.PrimitiveIterator

        PrimitiveIterator.OfDouble, PrimitiveIterator.OfInt, PrimitiveIterator.OfLong

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default void forEachRemaining​(Consumer<? super Integer> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void forEachRemaining​(IntConsumer action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default Integer next​()
      返回迭代中的下一个元素。
      int nextInt​()
      返回下一个 int元素的迭代。

      • Methods inherited from interface java.util.Iterator

        hasNext, remove

    • 方法详细信息

      • nextInt

        int nextInt​()
        返回下一个 int元素的迭代。
        结果
        下一个 int元素在迭代中
        异常
        NoSuchElementException - 如果迭代没有更多的元素

      • forEachRemaining

        default void forEachRemaining​(IntConsumer action)
        对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        forEachRemaining在接口 PrimitiveIterator<Integer,IntConsumer>
        实现要求：

        默认实现的行为如下：

           while (hasNext()) action.accept(nextInt());
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的动作为空

      • next

        default Integer next​()
        返回迭代中的下一个元素。
        Specified by:
        next在接口 Iterator<Integer>
        实现要求：
        默认实现框将调用 nextInt()的结果，并返回该盒装结果。
        结果
        迭代中的下一个元素

      • forEachRemaining

        default void forEachRemaining​(Consumer<? super Integer> action)
        对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作以任何方式修改集合（即使通过调用remove方法或Iterator子类型的其他mutator方法），迭代器的行为也是未指定的，除非重写类已指定并发修改策略。

        如果动作引发异常，则未指定迭代器的后续行为。

        Specified by:
        forEachRemaining在接口 Iterator<Integer>
        实现要求：
        如果该操作是IntConsumer一个实例，那么它被转换为IntConsumer并传递给forEachRemaining(java.util.function.IntConsumer) ; 否则动作适应IntConsumer一个实例，通过拳击IntConsumer的参数，然后传递给forEachRemaining(java.util.function.IntConsumer) 。
        参数
        action - 要为每个元素执行的操作
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrimitiveIterator.OfLong (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface PrimitiveIterator.OfLong

  • All Superinterfaces:
    Iterator<Long> ， PrimitiveIterator<Long,LongConsumer>
    Enclosing interface:
    PrimitiveIterator < T ， T_CONS >

    public static interface PrimitiveIterator.OfLong
extends PrimitiveIterator<Long,LongConsumer>
    一个专门针对 long值的迭代器。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.PrimitiveIterator

        PrimitiveIterator.OfDouble, PrimitiveIterator.OfInt, PrimitiveIterator.OfLong

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default void forEachRemaining​(Consumer<? super Long> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void forEachRemaining​(LongConsumer action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default Long next​()
      返回迭代中的下一个元素。
      long nextLong​()
      返回下一个 long元素的迭代。

      • Methods inherited from interface java.util.Iterator

        hasNext, remove

    • 方法详细信息

      • nextLong

        long nextLong​()
        返回下一个 long元素的迭代。
        结果
        下一个 long元素的迭代
        异常
        NoSuchElementException - 如果迭代没有更多的元素

      • forEachRemaining

        default void forEachRemaining​(LongConsumer action)
        对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        forEachRemaining在接口 PrimitiveIterator<Long,LongConsumer>
        实现要求：

        默认实现的行为如下：

           while (hasNext()) action.accept(nextLong());
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的动作为空

      • next

        default Long next​()
        返回迭代中的下一个元素。
        Specified by:
        next在接口 Iterator<Long>
        实现要求：
        默认实现框将调用 nextLong()的结果，并返回该盒装结果。
        结果
        迭代中的下一个元素

      • forEachRemaining

        default void forEachRemaining​(Consumer<? super Long> action)
        对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作以任何方式修改集合（即使通过调用remove方法或Iterator子类型的其他mutator方法），则迭代器的行为是未指定的，除非重写类已指定并发修改策略。

        如果动作引发异常，则未指定迭代器的后续行为。

        Specified by:
        forEachRemaining在接口 Iterator<Long>
        实现要求：
        如果操作是LongConsumer一个实例，那么它被转换为LongConsumer并传递给forEachRemaining(java.util.function.LongConsumer) ; 否则动作适应LongConsumer一个实例，通过拳击LongConsumer的参数，然后传递给forEachRemaining(java.util.function.LongConsumer) 。
        参数
        action - 要为每个元素执行的操作
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PriorityQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class PriorityQueue<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
        • java.util.PriorityQueue<E>
  • 参数类型
    E - 保存在此队列中的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， Queue<E>

    public class PriorityQueue<E>
extends AbstractQueue<E>
implements Serializable
    基于优先级堆的无限优先级queue 。 优先级队列的元素根据它们的natural ordering或由队列构建时间提供的Comparator进行排序 ，这取决于使用哪个构造函数。 优先队列不允许null元素。 依靠自然排序的优先级队列也不允许插入不可比较的对象（这样做可能导致ClassCastException ）。

    这个队列的头是相对于指定顺序的最小元素。 如果多个元素被绑定到最小值，那么头就是这些元素之一 - 关系被任意破坏。 队列检索操作poll ， remove ， peek和element访问在队列的头部的元件。

    优先级队列是无限制的，但是具有管理用于在队列上存储元素的数组的大小的内部容量 。 它始终至少与队列大小一样大。 当元素被添加到优先级队列中时，其容量会自动增长。 没有规定增长政策的细节。

    该类及其迭代器实现Collection和Iterator接口的所有可选方法。 方法iterator()中提供的迭代器和方法spliterator()中提供的分割器不能保证以任何特定顺序遍历优先级队列的元素。 如果需要排序遍历，请考虑使用Arrays.sort(pq.toArray()) 。

    请注意，此实现不同步。 如果任何线程修改队列，多线程不应同时访问PriorityQueue实例。 而是使用线程安全的PriorityBlockingQueue类。

    实现注意事项：此实现提供了O（日志（n））的时间入队和出队方法（ offer ， poll ， remove()和add ）; 线性时间为remove(Object)和contains(Object)方法; 和恒定时间检索方法（ peek ， element ，和size ）。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PriorityQueue​()
      创建PriorityQueue与根据它们的排序其元素默认初始容量（11） natural ordering 。
      PriorityQueue​(int initialCapacity)
      创建具有指定初始容量的PriorityQueue ，根据其natural ordering对其元素进行排序 。
      PriorityQueue​(int initialCapacity, Comparator<? super E> comparator)
      创建具有指定初始容量的 PriorityQueue ，根据指定的比较器对其元素进行排序。
      PriorityQueue​(Collection<? extends E> c)
      创建包含指定集合中的元素的 PriorityQueue 。
      PriorityQueue​(Comparator<? super E> comparator)
      创建具有默认初始容量的 PriorityQueue ，并根据指定的比较器对其元素进行排序。
      PriorityQueue​(PriorityQueue<? extends E> c)
      创建包含指定优先级队列中的元素的 PriorityQueue 。
      PriorityQueue​(SortedSet<? extends E> c)
      创建包含指定排序集中的元素的 PriorityQueue 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素插入到此优先级队列中。
      void clear​()
      从此优先级队列中删除所有元素。
      Comparator<? super E> comparator​()
      返回用于为了在这个队列中的元素，或比较null如果此队列根据所述排序natural ordering的元素。
      boolean contains​(Object o)
      如果此队列包含指定的元素，则返回 true 。
      Iterator<E> iterator​()
      返回此队列中的元素的迭代器。
      boolean offer​(E e)
      将指定的元素插入到此优先级队列中。
      E peek​()
      检索但不删除此队列的头，如果此队列为空，则返回 null 。
      E poll​()
      检索并删除此队列的头部，如果此队列为空，则返回 null 。
      boolean remove​(Object o)
      从该队列中删除指定元素的单个实例（如果存在）。
      int size​()
      返回此集合中的元素数。
      Spliterator<E> spliterator​()
      在此队列中的元素上创建late-binding和故障快速 Spliterator 。
      Object[] toArray​()
      返回一个包含此队列中所有元素的数组。
      <T> T[] toArray​(T[] a)
      返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

      • Methods inherited from class java.util.AbstractCollection

        containsAll, isEmpty, removeAll, retainAll, toString

      • Methods inherited from class java.util.AbstractQueue

        addAll, element, remove

      • Methods inherited from interface java.util.Collection

        containsAll, equals, hashCode, isEmpty, parallelStream, removeAll, removeIf, retainAll, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PriorityQueue

        public PriorityQueue​()
        创建PriorityQueue与根据它们的排序其元素默认初始容量（11） natural ordering 。

      • PriorityQueue

        public PriorityQueue​(int initialCapacity)
        创建具有指定初始容量的PriorityQueue ，根据其natural ordering对其元素进行排序 。
        参数
        initialCapacity - 此优先队列的初始容量
        异常
        IllegalArgumentException - 如果 initialCapacity小于1

      • PriorityQueue

        public PriorityQueue​(Comparator<? super E> comparator)
        创建具有默认初始容量的 PriorityQueue ，并根据指定的比较器对其元素进行排序。
        参数
        comparator - 将用于订购此优先级队列的比较器。 如果是null ，将使用natural ordering的元素。
        从以下版本开始：
        1.8

      • PriorityQueue

        public PriorityQueue​(int initialCapacity,
                     Comparator<? super E> comparator)
        创建具有指定初始容量的 PriorityQueue ，该容量根据指定的比较器对其元素进行排序。
        参数
        initialCapacity - 此优先级队列的初始容量
        comparator - 将用于对此优先级队列进行排序的比较器。 如果是null ，将使用natural ordering的元素。
        异常
        IllegalArgumentException - 如果 initialCapacity小于1

      • PriorityQueue

        public PriorityQueue​(Collection<? extends E> c)
        创建包含指定集合中的元素的PriorityQueue 。 如果指定的集合是SortedSet的实例或另一个PriorityQueue ，则该优先级队列将按照相同的顺序排序。 否则，此优先级队列将根据其元素的natural ordering进行排序。
        参数
        c - c元素放入此优先级队列的集合
        异常
        ClassCastException - 如果指定集合的元素不能根据优先级队列的顺序相互比较
        NullPointerException - 如果指定的集合或其任何元素为空

      • PriorityQueue

        public PriorityQueue​(PriorityQueue<? extends E> c)
        创建包含指定优先级队列中的元素的PriorityQueue 。 该优先级队列将按照与给定优先级队列相同的顺序进行排序。
        参数
        c - 其元素要放入此优先级队列的优先级队列
        异常
        ClassCastException -如果元素 c不能相互比较根据 c的订货
        NullPointerException - 如果指定的优先级队列或其任何元素为空

      • PriorityQueue

        public PriorityQueue​(SortedSet<? extends E> c)
        创建包含指定排序集中的元素的PriorityQueue 。 该优先级队列将按照与给定排序集相同的顺序进行排序。
        参数
        c - c元素放入此优先级队列的排序集
        异常
        ClassCastException - 如果指定的排序集的元素不能根据排序集的排序彼此进行比较
        NullPointerException - 如果指定的排序集或其任何元素为空

    • 方法详细信息

      • add

        public boolean add​(E e)
        将指定的元素插入到此优先级队列中。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractQueue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        ClassCastException - 如果指定的元素不能与当前在此优先级队列中的元素根据优先级队列的排序进行比较
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        将指定的元素插入到此优先级队列中。
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Queue.offer(E)指定）
        异常
        ClassCastException - 如果指定的元素不能与当前在此优先级队列中的元素根据优先级队列的排序进行比较
        NullPointerException - 如果指定的元素为空

      • peek

        public E peek​()
        说明从接口Queue复制
        检索但不删除此队列的头，如果此队列为空，则返回 null 。
        Specified by:
        peek在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • remove

        public boolean remove​(Object o)
        从该队列中删除指定元素的单个实例（如果存在）。 更正式地，删除元素e使o.equals(e) ，如果这个队列包含一个或多个这样的元素。 如果且仅当此队列包含指定的元素（或等效地，如果此队列作为调用的结果而更改），则返回true 。
        Specified by:
        remove在接口 Collection<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此队列中删除的元素（如果存在）
        结果
        true如果此队列由于调用而更改

      • contains

        public boolean contains​(Object o)
        如果此队列包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此队列至少包含一个元素e这样o.equals(e) 。
        Specified by:
        contains在接口 Collection<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要检查此队列中的遏制的对象
        结果
        true如果此队列包含指定的元素

      • toArray

        public Object[] toArray​()
        返回一个包含此队列中所有元素的数组。 元素没有特定的顺序。

        返回的数组将是“安全的”，因为该队列不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此队列中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 返回的数组元素没有特定的顺序。 如果队列适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此队列的大小分配一个新数组。

        如果队列符合指定的数组空间（即阵列中的元素比队列更多），则紧跟集合结束后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的队列。 以下代码可用于将队列转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储队列的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此队列中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • iterator

        public Iterator<E> iterator​()
        返回此队列中的元素的迭代器。 迭代器不以任何特定顺序返回元素。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        这个队列中的元素的迭代器

      • size

        public int size​()
        说明从接口Collection复制
        返回此集合中的元素数。 如果此集合包含超过Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此集合中的元素数

      • clear

        public void clear​()
        从此优先级队列中删除所有元素。 此呼叫返回后队列将为空。
        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractQueue<E>

      • poll

        public E poll​()
        说明从接口Queue复制
        检索并删除此队列的头，如果此队列为空，则返回 null 。
        Specified by:
        poll在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • comparator

        public Comparator<? super E> comparator​()
        返回用于为了在这个队列中的元素，或比较null如果此队列根据所述排序natural ordering的元素。
        结果
        比较器用于排序此队列，或 null如果此队列根据其元素的自然排序进行排序

      • spliterator

        public final Spliterator<E> spliterator​()
        在此队列中的元素上创建late-binding和故障快速 Spliterator 。 拼接器不以任何特定顺序遍历元素（ ORDERED特性未报告）。

        该Spliterator报告Spliterator.SIZED ， Spliterator.SUBSIZED ，并Spliterator.NONNULL 。 覆盖实现应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        结果
        一个 Spliterator在这个队列中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Properties (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Properties

  • java.lang.Object
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<Object,Object>
        • java.util.Properties
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Map<Object,Object>
    已知直接子类：
    Provider

    public class Properties
extends Hashtable<Object,Object>
    Properties类表示一组持久的属性。 Properties可以保存到流中或从流中加载。 属性列表中的每个键及其对应的值都是一个字符串。

    属性列表可以包含另一个属性列表作为其“默认值”; 如果在原始属性列表中找不到属性键，则会搜索此第二个属性列表。

    因为Properties从继承Hashtable ，所述put种putAll方法可应用于Properties对象。 强烈不鼓励使用它们，因为它们允许调用者插入其键或值不是Strings 。 应该使用setProperty方法。 如果在包含非String键或值的“受损害” Properties对象上调用store或save方法，则调用将失败。 类似地，如果在包含非String密钥的“受损害”的Properties对象上调用propertyNames或list方法的调用将失败。

    在返回的迭代器iterator （也就是此类的“集合视图”方法entrySet() ， keySet() ，并values() ）可能不是快速失败的（不像Hashtable的实现）。 这些迭代器被保证遍历元素，因为它们在施工时存在一次，并且可能（但不能保证）反映构造后的任何修改。

    load(Reader) / / /2方法从以下指定的简单的面向行的格式将特性加载和存储到基于字符的流中。 load(InputStream) / store(OutputStream, String)方法与加载（读取器）/存储（Writer，String）对相同，除了输入/输出流以ISO 8859-1字符编码编码。 在该编码中不能直接表示的字符可以使用如The Java™ Language Specification第3.3节中定义的Unicode转义来编写; 在转义序列中只允许使用单个“u”字符。

    loadFromXML(InputStream)和storeToXML(OutputStream, String, String)方法以简单的XML格式加载和存储属性。 默认情况下，使用UTF-8字符编码，但是如果需要，可以指定特定编码。 需要实现支持UTF-8和UTF-16，并可能支持其他编码。 XML属性文档具有以下DOCTYPE声明：

      <!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
    请注意，导出或导入属性时不会访问系统URI（http://java.sun.com/dtd/properties.dtd）; 它只是作为一个字符串来唯一地标识DTD，它是：
      <?xml version="1.0" encoding="UTF-8"?>

    <!-- DTD for properties -->

    <!ELEMENT properties ( comment?, entry* ) >

    <!ATTLIST properties version CDATA #FIXED "1.0">

    <!ELEMENT comment (#PCDATA) >

    <!ELEMENT entry (#PCDATA) >

    <!ATTLIST entry key CDATA #REQUIRED>

    这个类是线程安全的：多个线程可以共享一个Properties对象，而不需要外部同步。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Properties defaults
      属性列表，其中包含此属性列表中未找到的任何键的默认值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Properties​()
      创建一个没有默认值的空属性列表。
      Properties​(Properties defaults)
      创建具有指定默认值的空属性列表。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void clear​()
      清除此散列表，使其不包含键。
      Object clone​()
      创建这个散列表的浅拷贝。
      Object compute​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      Object computeIfAbsent​(Object key, Function<? super Object,?> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      Object computeIfPresent​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      boolean contains​(Object value)
      测试一些键映射到这个哈希表中的指定值。
      boolean containsKey​(Object key)
      测试指定的对象是否在此哈希表中的键。
      boolean containsValue​(Object value)
      如果此哈希表将一个或多个键映射到此值，则返回true。
      Enumeration<Object> elements​()
      返回此散列表中值的枚举。
      Set<Map.Entry<Object,Object>> entrySet​()
      返回此地图中包含的映射的Set视图。
      boolean equals​(Object o)
      根据Map界面中的定义，将指定的对象与此Map进行比较以相等。
      void forEach​(BiConsumer<? super Object,? super Object> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      Object get​(Object key)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。
      Object getOrDefault​(Object key, Object defaultValue)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。
      String getProperty​(String key)
      使用此属性列表中指定的键搜索属性。
      String getProperty​(String key, String defaultValue)
      使用此属性列表中指定的键搜索属性。
      int hashCode​()
      按照Map界面中的定义返回此Map的哈希码值。
      boolean isEmpty​()
      测试这个哈希表是否将值映射到值。
      Enumeration<Object> keys​()
      返回此散列表中键的枚举。
      Set<Object> keySet​()
      返回此地图中包含的键的Set视图。
      void list​(PrintStream out)
      将此属性列表打印到指定的输出流。
      void list​(PrintWriter out)
      将此属性列表打印到指定的输出流。
      void load​(InputStream inStream)
      从输入字节流读取属性列表（键和元素对）。
      void load​(Reader reader)
      以简单的线性格式从输入字符流读取属性列表（关键字和元素对）。
      void loadFromXML​(InputStream in)
      将指定输入流中的XML文档表示的所有属性加载到此属性表中。
      Object merge​(Object key, Object value, BiFunction<? super Object,? super Object,?> remappingFunction)
      如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
      Enumeration<?> propertyNames​()
      返回此属性列表中所有键的枚举，包括默认属性列表中的不同键，如果尚未从主属性列表中找到相同名称的键。
      Object put​(Object key, Object value)
      将指定的 key映射到此散列表中指定的 value 。
      void putAll​(Map<?,?> t)
      将所有从指定地图的映射复制到此散列表。
      Object putIfAbsent​(Object key, Object value)
      如果指定的键尚未与值相关联（或映射到 null ）将其与给定值关联并返回 null ，否则返回当前值。
      protected void rehash​()
      增加这个散列表的内部重组能力，从而更有效地适应和访问其条目。
      Object remove​(Object key)
      从此散列表中删除键（及其对应的值）。
      boolean remove​(Object key, Object value)
      仅当指定的密钥当前映射到指定的值时删除该条目。
      Object replace​(Object key, Object value)
      只有当目标映射到某个值时，才能替换指定键的条目。
      void replaceAll​(BiFunction<? super Object,? super Object,?> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      void save​(OutputStream out, String comments)
      已过时。
      如果在保存属性列表时发生I / O错误，此方法不会抛出IOException。 保存属性列表的首选方法是通过store(OutputStream out, String comments)方法或storeToXML(OutputStream os, String comment)方法。
      Object setProperty​(String key, String value)
      调用 Hashtable方法 put 。
      int size​()
      返回此哈希表中的键数。
      void store​(OutputStream out, String comments)
      将此 Properties表中的此属性列表（键和元素对）以适合于使用 load(InputStream)方法加载到 Properties表格的格式写入输出流。
      void store​(Writer writer, String comments)
      将此属性列表（键和元素对）写入此 Properties表中，以适合使用 load(Reader)方法的格式输出到输出字符流。
      void storeToXML​(OutputStream os, String comment)
      发出表示此表中包含的所有属性的XML文档。
      void storeToXML​(OutputStream os, String comment, String encoding)
      使用指定的编码发出表示此表中包含的所有属性的XML文档。
      Set<String> stringPropertyNames​()
      从该属性列表中返回一个不可修改的键集，其中键及其对应的值是字符串，包括默认属性列表中的不同键，如果尚未从主属性列表中找到相同名称的键。
      String toString​()
      以一组条目的形式返回此 Hashtable对象的字符串表示形式，以大括号括起来，并以ASCII字符“ ,  ”（逗号和空格）分隔。
      Collection<Object> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from interface java.util.Map

        entry, of, of, of, of, of, of, of, of, of, of, of, ofEntries

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • defaults

        protected Properties defaults
        属性列表，其中包含此属性列表中未找到的任何键的默认值。

    • 构造方法详细信息

      • Properties

        public Properties​()
        创建一个没有默认值的空属性列表。

      • Properties

        public Properties​(Properties defaults)
        创建具有指定默认值的空属性列表。
        参数
        defaults - 默认值。

    • 方法详细信息

      • setProperty

        public Object setProperty​(String key,
                          String value)
        调用Hashtable方法put 。 提供与getProperty方法的并行性。 强制使用字符串的属性键和值。 返回的值是Hashtable调用put的结果。
        参数
        key - 要放入此属性列表的关键字。
        value - 对应的值为 key 。
        结果
        该属性列表中指定键的上一个值，如果没有， null 。
        从以下版本开始：
        1.2
        另请参见：
        getProperty(java.lang.String)

      • load

        public void load​(Reader reader)
          throws IOException
        以简单的线性格式从输入字符流读取属性列表（关键字和元素对）。

        属性按照行进行处理。 有两种线， 自然线和逻辑线 。 自然行被定义为由一组行终止符字符（ \n或\r或\r\n ）或流结尾终止的一行字符。 自然线可以是空白行，注释行或保持键或键的一部分。 逻辑行保存键元素对的所有数据，其可以通过以反斜杠字符\转义行终止符序列而跨越多个相邻自然行\ 。 请注意，注释行不能以这种方式扩展; 每个自然界线都是自己的评论指标，如下所述。 从输入读取行，直到流到达结束。

        仅包含空白字符的自然行被视为空白，并被忽略。 注释行具有ASCII '#'或'!'作为其第一个非空白字符; 注释行也被忽略，不对key-element信息进行编码。 除了线终止子，此格式考虑字符空间（ ' ' ， '\u0020' ），标签（ '\t' ， '\u0009' ），和形式进料（ '\f' ， '\u000C' ）是白色的空间。

        如果逻辑行分布在几条自然行中，则反斜杠将转义行终止符序列，行终止符序列以及以下行开始处的任何空格对键或元素值都没有影响。 关键和元素解析的剩余部分（加载时）将假设所有构成键和元素的字符在行连续字符被删除后出现在单个自然行上。 请注意，这是不够的，只检查字符行终止序列之前，以决定是否行结束逃脱; 必须有奇数数量的连续反斜线才能转义线终止符。 由于输入是从左到右处理的，所以在线程终止符（或其他地方）之前，非零偶数的2 n个连续的反斜杠在转义处理后编码n个反斜杠。

        关键包含了所有的从第一个非空格字符以及高达行的字符，但不包括第一个转义'=' ， ':' ，或大于行结束符等空白字符。 所有这些密钥终止字符可以通过用前面的反斜杠字符进行转义而包含在密钥中; 例如，

        \:\=

        将是双字符键":=" 。 可以使用\r和\n转义序列来包括行终止符。 钥匙之后任何空格被跳过; 如果键后的第一个非空白字符为'='或':' ，则会被忽略，并且其后面的任何空白字符也将被跳过。 线上的所有剩余字符都成为相关元素字符串的一部分; 如果没有剩余的字符，则该元素为空字符串"" 。 一旦构成密钥和元素的原始字符序列被识别，则如上所述执行逃逸处理。

        作为示例，以下三行中的每一行指定密钥"Truth"和相关联的元素值"Beauty" ：

          Truth = Beauty
  Truth:Beauty
 Truth                    :Beauty
        作为另一个例子，以下三行指定单个属性：
          fruits                           apple, banana, pear, \
     *                                  cantaloupe, watermelon, \
     *                                  kiwi, mango
        关键是"fruits" ，相关元素是：
          "apple, banana, pear, cantaloupe, watermelon, kiwi, mango"
        请注意，在每个\之前会出现一个空格，以便在最终结果中的每个逗号后面会出现一个空格; \线上的\线路终结器和前导空格仅被丢弃， 不被一个或多个其他字符替代。

        作为第三个例子，行：

          cheeses
        指定键为"cheeses" ，相关元素为空字符串"" 。

        键和元素中的字符可以用类似于用于字符和字符串文字的转义序列来表示（参见The Java™ Language Specification的3.3和3.10.6 ）。 与用于字符和字符串的字符转义序列和Unicode转义的区别是：

        • 八进制转义不被识别。
        • 字符序列\b 不表示退格字符。
        • 该方法在将非有效的转义字符作为错误之前不处理反斜杠字符\ ; 反斜杠默默地掉下来。 例如，在Java字符串中，序列"\z"将导致编译时错误。 相比之下，此方法会静默地丢弃反斜杠。 因此，该方法将两个字符序列"\b"视为等同于单个字符'b' 。
        • 单引号和双引号不需要转义; 然而，通过上面的规则，单引号和双引号字符之前的反斜杠仍然分别产生单引号和双引号字符。
        • 在Unicode转义序列中只允许使用单个'u'字符。

        此方法返回后指定的流保持打开状态。

        参数
        reader - 输入字符流。
        异常
        IOException - 从输入流读取时是否发生错误。
        IllegalArgumentException - 输入中是否出现格式错误的Unicode转义。
        NullPointerException - 如果 reader为空。
        从以下版本开始：
        1.6

      • load

        public void load​(InputStream inStream)
          throws IOException
        从输入字节流读取属性列表（键和元素对）。 输入流采用load(Reader)中规定的简单的面向行的格式，假定使用ISO 8859-1字符编码; 每个字节是一个拉丁字符。 不在Latin1中的字符以及某些特殊字符在按照The Java™ Language Specification第3.3节中定义的Unicode转义的键和元素中进行表示。

        此方法返回后指定的流保持打开状态。

        参数
        inStream - 输入流。
        异常
        IOException - 从输入流读取时是否发生错误。
        IllegalArgumentException - 如果输入流包含格式不正确的Unicode转义序列。
        NullPointerException - 如果 inStream为空。
        从以下版本开始：
        1.2

      • save

        @Deprecated
public void save​(OutputStream out,
                 String comments)
        已过时。 如果在保存属性列表时发生I / O错误，此方法不会抛出IOException。 保存属性列表的首选方法是通过store(OutputStream out, String comments)方法或storeToXML(OutputStream os, String comment)方法。
        调用 store(OutputStream out, String comments)方法并禁止抛出的IOExceptions。
        参数
        out - 输出流。
        comments - 属性列表的描述。
        异常
        ClassCastException - 如果此 Properties对象包含任何不是 Strings键或值。

      • store

        public void store​(Writer writer,
                  String comments)
           throws IOException
        将此属性列表（键和元素对）写入此Properties表格中，以适合使用load(Reader)方法的格式将输出字符流写入 。

        此Properties表（如果有）的默认表中的属性不会被此方法写出。

        如果comments参数不为空，则首先将ASCII #字符，注释字符串和行分隔符写入输出流。 因此， comments可以作为识别评论。 换行符（'\ n'），回车符（'\ r'）或立即在注释中的换行符后面的回车替换为由Writer生成的行分隔符，如果下一个字符在注释中不是字符#或字符!然后在该行分隔符之后写出ASCII # 。

        接下来，注释行总是写入，由ASCII #字符组成，当前日期和时间（如当前时间Date的toString方法生成的）和由Writer生成的行分隔符。

        然后，这个Properties表中的每个条目都将被写出，每行一个。 对于每个条目，键字符串被写入，然后是一个ASCII = ，然后是关联的元素字符串。 对于密钥，所有空格字符都用前面的\字符写入。 对于元素，前导空格字符，但不是嵌入或尾随空格字符，写入前面的\字符。 键和元素字符# ， ! ， = ，和:写入加上正斜杠，以确保它们被正确装载。

        在写入条目之后，输出流被刷新。 此方法返回后，输出流保持打开状态。

        参数
        writer - 输出字符流写入器。
        comments - 属性列表的描述。
        异常
        IOException - 如果将此属性列表写入指定的输出流， IOException抛出一个 IOException 。
        ClassCastException - 如果此 Properties对象包含任何不是 Strings键或值。
        NullPointerException - 如果 writer为空。
        从以下版本开始：
        1.6

      • store

        public void store​(OutputStream out,
                  String comments)
           throws IOException
        将此属性列表（键和元素对）写入此Properties表中，以适合使用load(InputStream)方法加载到Properties表格的格式输出流。

        此Properties表（如果有）的默认表中的属性未通过此方法写出。

        此方法输出与store(Writer)中规定的相同格式的注释，属性键和值，具有以下区别：

        • 流使用ISO 8859-1字符编码编写。
        • 注释中不在拉丁文1中的字符为\u xxxx，用于其相应的unicode十六进制值xxxx 。
        • 字符小于\u0020和大于字符\u007E在属性键或值被写为\u XXXX为适当的十六进制值XXXX。

        在写入条目之后，输出流被刷新。 此方法返回后，输出流保持打开状态。

        参数
        out - 输出流。
        comments - 属性列表的描述。
        异常
        IOException - 如果将此属性列表写入指定的输出流， IOException抛出一个 IOException 。
        ClassCastException - 如果此 Properties对象包含任何不是 Strings键或值。
        NullPointerException - 如果 out为空。
        从以下版本开始：
        1.2

      • loadFromXML

        public void loadFromXML​(InputStream in)
                 throws IOException,
                        InvalidPropertiesFormatException
        将指定输入流中的XML文档表示的所有属性加载到此属性表中。

        XML文档必须具有以下DOCTYPE声明：

          <!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
        此外，文件必须满足上述性质DTD。

        需要一个实现来读取使用“ UTF-8 ”或“ UTF-16 ”编码的XML文档。 实现可以支持额外的编码。

        指定的流在此方法返回后关闭。

        参数
        in - 从中读取XML文档的输入流。
        异常
        IOException - 如果从指定的输入流读取导致一个 IOException 。
        UnsupportedEncodingException - 如果文档的编码声明可以被读取，并且指定不支持的编码
        InvalidPropertiesFormatException - 输入流上的数据不构成具有强制文档类型的有效XML文档。
        NullPointerException - 如果 in为空。
        从以下版本开始：
        1.5
        另请参见：
        storeToXML(OutputStream, String, String) ， Character Encoding in Entities

      • storeToXML

        public void storeToXML​(OutputStream os,
                       String comment)
                throws IOException
        发出表示此表中包含的所有属性的XML文档。

        这种props.storeToXML(os, comment)形式的方法的调用与调用props.storeToXML(os, comment, "UTF-8"); 。

        参数
        os - 发送XML文档的输出流。
        comment - 属性列表的描述，如果没有评论， null 。
        异常
        IOException - 如果写入指定的输出流导致一个 IOException 。
        NullPointerException - 如果 os为空。
        ClassCastException - 如果此 Properties对象包含任何不是 Strings键或值。
        从以下版本开始：
        1.5
        另请参见：
        loadFromXML(InputStream)

      • storeToXML

        public void storeToXML​(OutputStream os,
                       String comment,
                       String encoding)
                throws IOException
        使用指定的编码发出表示此表中包含的所有属性的XML文档。

        XML文档将具有以下DOCTYPE声明：

          <!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">

        如果指定的注释是null则文档中不会存储注释。

        需要一个实现来支持使用“ UTF-8 ”或“ UTF-16 ”编码的XML文档的编写。 实现可以支持额外的编码。

        此方法返回后指定的流保持打开状态。

        参数
        os - 发送XML文档的输出流。
        comment - 属性列表的描述，或 null如果不需要注释）。
        encoding - 支持的名称 character encoding
        异常
        IOException - 如果写入指定的输出流导致一个 IOException 。
        UnsupportedEncodingException - 如果实现不支持编码。
        NullPointerException - 如果 os是 null ，或者如果 encoding是 null 。
        ClassCastException - 如果此 Properties对象包含任何不是 Strings键或值。
        从以下版本开始：
        1.5
        另请参见：
        loadFromXML(InputStream) ， Character Encoding in Entities

      • getProperty

        public String getProperty​(String key)
        使用此属性列表中指定的键搜索属性。 如果在此属性列表中找不到该键，则会默认属性列表及其默认值递归。 如果找不到属性，该方法返回null 。
        参数
        key - 属性键。
        结果
        该属性列表中具有指定键值的值。
        另请参见：
        setProperty(java.lang.String, java.lang.String) ， defaults

      • getProperty

        public String getProperty​(String key,
                          String defaultValue)
        使用此属性列表中指定的键搜索属性。 如果在此属性列表中找不到该键，则会默认属性列表及其默认值递归。 如果找不到属性，该方法返回默认值参数。
        参数
        key - 哈希表键。
        defaultValue - 默认值。
        结果
        该属性列表中具有指定键值的值。
        另请参见：
        setProperty(java.lang.String, java.lang.String) ， defaults

      • propertyNames

        public Enumeration<?> propertyNames​()
        返回此属性列表中所有键的枚举，包括默认属性列表中的不同键，如果尚未从主属性列表中找到相同名称的键。
        结果
        枚举此属性列表中的所有键，包括默认属性列表中的键。
        异常
        ClassCastException - 如果此属性列表中的任何键不是字符串。
        另请参见：
        Enumeration ， defaults ， stringPropertyNames()

      • stringPropertyNames

        public Set<String> stringPropertyNames​()
        从该属性列表中返回一个不可修改的键集，其中键及其对应的值是字符串，包括默认属性列表中的不同键，如果尚未从主属性列表中找到相同名称的键。 其关键字或值不是String类型的String被省略。

        返回的集合不受此Properties对象的支持。 对此Properties对象的更改不会反映在返回的集合中。

        结果
        该属性列表中的一个不可修改的键集，其中键及其对应的值是字符串，包括默认属性列表中的键。
        从以下版本开始：
        1.6
        另请参见：
        defaults

      • list

        public void list​(PrintStream out)
        将此属性列表打印到指定的输出流。 此方法对调试非常有用。
        参数
        out - 输出流。
        异常
        ClassCastException - 如果此属性列表中的任何键不是字符串。

      • list

        public void list​(PrintWriter out)
        将此属性列表打印到指定的输出流。 此方法对调试非常有用。
        参数
        out - 输出流。
        异常
        ClassCastException - 如果此属性列表中的任何键不是字符串。
        从以下版本开始：
        1.1

      • size

        public int size​()
        描述从类别复制： Hashtable
        返回此哈希表中的键数。
        Specified by:
        size在接口 Map<Object,Object>
        重写：
        size在 Hashtable<Object,Object>
        结果
        这个散列表中的键的数量。

      • isEmpty

        public boolean isEmpty​()
        描述从类复制： Hashtable
        测试这个哈希表是否将值映射到值。
        Specified by:
        isEmpty在接口 Map<Object,Object>
        重写：
        isEmpty在 Hashtable<Object,Object>
        结果
        true如果这个哈希表将任何键映射到值; false否则。

      • keys

        public Enumeration<Object> keys​()
        描述从类复制： Hashtable
        返回此散列表中键的枚举。 对返回的对象使用枚举方法按顺序获取键。 如果哈希表在结构上被修改，同时枚举了键，则枚举的结果是未定义的。
        重写：
        keys在 Hashtable<Object,Object>
        结果
        这个哈希表中的键的枚举。
        另请参见：
        Enumeration ， Hashtable.elements() ， Hashtable.keySet() ， Map

      • elements

        public Enumeration<Object> elements​()
        描述从类复制： Hashtable
        返回此散列表中值的枚举。 对返回的对象使用枚举方法来顺序获取元素。 如果哈希表在结构上被修改，同时枚举了值，则枚举的结果是未定义的。
        重写：
        elements在 Hashtable<Object,Object>
        结果
        列出这个散列表中的值。
        另请参见：
        Enumeration ， Hashtable.keys() ， Hashtable.values() ， Map

      • contains

        public boolean contains​(Object value)
        描述从类复制： Hashtable
        测试一些键映射到这个哈希表中的指定值。 这个操作比containsKey方法贵。

        请注意，此方法的功能与containsValue （它是集合框架中的Map接口的一部分）功能相同。

        重写：
        contains在 Hashtable<Object,Object>
        参数
        value - 要搜索的值
        结果
        true当且仅当某些键映射到equals方法确定的散列表中的value参数时; false否则。

      • containsValue

        public boolean containsValue​(Object value)
        描述从类复制： Hashtable
        如果此哈希表将一个或多个键映射到此值，则返回true。

        请注意，此方法的功能与contains （早于Map接口）相同。

        Specified by:
        containsValue在接口 Map<Object,Object>
        重写：
        containsValue在 Hashtable<Object,Object>
        参数
        value - 要在此散列表中存在的值要进行测试
        结果
        true如果该地图将一个或多个键映射到指定的值

      • containsKey

        public boolean containsKey​(Object key)
        描述从类复制： Hashtable
        测试指定的对象是否在此哈希表中的键。
        Specified by:
        containsKey在接口 Map<Object,Object>
        重写：
        containsKey在 Hashtable<Object,Object>
        参数
        key - 可能的键
        结果
        true当且仅当指定的对象是此散列表中的键时，由equals方法确定; false否则。
        另请参见：
        Hashtable.contains(Object)

      • get

        public Object get​(Object key)
        描述从类复制： Hashtable
        返回指定键映射到的值，如果此映射不包含键的映射，则返回null 。

        更正式地，如果该映射包含从k键到值v的映射，使得(key.equals(k)) ，则该方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        Specified by:
        get在接口 Map<Object,Object>
        重写：
        get在 Hashtable<Object,Object>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含该键的映射， null
        另请参见：
        Hashtable.put(Object, Object)

      • put

        public Object put​(Object key,
                  Object value)
        描述从类复制： Hashtable
        将指定的key映射到此散列表中指定的value 。 钥匙和价值都不能是null 。

        可以通过使用等于原始密钥的密钥调用get方法来检索该值。

        Specified by:
        put在接口 Map<Object,Object>
        重写：
        put在 Hashtable<Object,Object>
        参数
        key - 哈希表键
        value - 值
        结果
        该哈希表中指定键的上一个值，如果没有， null
        另请参见：
        Object.equals(Object) ， Hashtable.get(Object)

      • remove

        public Object remove​(Object key)
        描述从类复制： Hashtable
        从此散列表中删除键（及其对应的值）。 如果键不在哈希表中，此方法不执行任何操作。
        Specified by:
        remove在接口 Map<Object,Object>
        重写：
        remove在 Hashtable<Object,Object>
        参数
        key - 需要删除的关键
        结果
        密钥映射到此散列表中的值，如果密钥没有映射， null

      • putAll

        public void putAll​(Map<?,?> t)
        说明从类别Hashtable复制
        将所有从指定地图的映射复制到此散列表。 这些映射将替换这个散列表对于指定地图中当前的任何键的任何映射。
        Specified by:
        putAll在接口 Map<Object,Object>
        重写：
        putAll在 Hashtable<Object,Object>
        参数
        t - 要存储在此地图中的映射

      • clear

        public void clear​()
        描述从类复制： Hashtable
        清除此散列表，使其不包含键。
        Specified by:
        clear在接口 Map<Object,Object>
        重写：
        clear在 Hashtable<Object,Object>

      • toString

        public String toString​()
        描述从类复制： Hashtable
        以一组条目的形式返回此Hashtable对象的字符串表示形式，其括在大括号中，并以ASCII字符“ ,  ”（逗号和空格）分隔。 每个条目都显示为关键字，等号为= ，以及相关联的元素，其中使用toString方法将键和元素转换为字符串。
        重写：
        toString在 Hashtable<Object,Object>
        结果
        这个散列表的字符串表示形式

      • keySet

        public Set<Object> keySet​()
        描述从类复制： Hashtable
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        keySet在接口 Map<Object,Object>
        重写：
        keySet在 Hashtable<Object,Object>
        结果
        该地图中包含的键的集合视图

      • values

        public Collection<Object> values​()
        描述从类复制： Hashtable
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        values在接口 Map<Object,Object>
        重写：
        values在 Hashtable<Object,Object>
        结果
        该地图中包含的值的集合视图

      • entrySet

        public Set<Map.Entry<Object,Object>> entrySet​()
        描述从类复制： Hashtable
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        entrySet在接口 Map<Object,Object>
        重写：
        entrySet在 Hashtable<Object,Object>
        结果
        该地图中包含的映射的集合视图

      • equals

        public boolean equals​(Object o)
        描述从类复制： Hashtable
        根据Map界面中的定义，将指定的对象与此Map进行比较以相等。
        Specified by:
        equals在接口 Map<Object,Object>
        重写：
        equals在 Hashtable<Object,Object>
        参数
        o - 要与此散列表相等的对象进行比较
        结果
        如果指定的Object等于此Map，则为true
        另请参见：
        Map.equals(Object)

      • hashCode

        public int hashCode​()
        描述从类复制： Hashtable
        按照Map界面中的定义返回此Map的哈希码值。
        Specified by:
        hashCode在接口 Map<Object,Object>
        重写：
        hashCode在 Hashtable<Object,Object>
        结果
        该对象的哈希码值。
        另请参见：
        Map.hashCode()

      • getOrDefault

        public Object getOrDefault​(Object key,
                           Object defaultValue)
        说明从接口Map复制
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。
        Specified by:
        getOrDefault在接口 Map<Object,Object>
        重写：
        getOrDefault在 Hashtable<Object,Object>
        参数
        key - 要返回其关联值的键
        defaultValue - 键的默认映射
        结果
        映射指定键的值，如果此映射不包含键的映射， defaultValue

      • forEach

        public void forEach​(BiConsumer<? super Object,? super Object> action)
        说明从接口Map复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach在接口 Map<Object,Object>
        重写：
        forEach在 Hashtable<Object,Object>
        参数
        action - 要为每个条目执行的操作

      • replaceAll

        public void replaceAll​(BiFunction<? super Object,? super Object,?> function)
        说明从界面Map复制
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll在接口 Map<Object,Object>
        重写：
        replaceAll在 Hashtable<Object,Object>
        参数
        function - 应用于每个条目的功能

      • putIfAbsent

        public Object putIfAbsent​(Object key,
                          Object value)
        说明从界面Map复制
        如果指定的键尚未与值（或映射到 null ）相关联，并将其与给定值相关联并返回 null ，否则返回当前值。
        Specified by:
        putIfAbsent在接口 Map<Object,Object>
        重写：
        putIfAbsent在 Hashtable<Object,Object>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示映射先前关联的是null的密钥，如果实现支持空值）。

      • remove

        public boolean remove​(Object key,
                      Object value)
        描述从接口Map复制
        仅当指定的密钥当前映射到指定的值时删除该条目。
        Specified by:
        remove在接口 Map<Object,Object>
        重写：
        remove在 Hashtable<Object,Object>
        参数
        key - 与指定值相关联的键
        value - 预期与指定键相关联的值
        结果
        true如果该值被删除

      • replace

        public Object replace​(Object key,
                      Object value)
        描述从接口Map复制
        只有当目标映射到某个值时，才能替换指定键的条目。
        Specified by:
        replace在接口 Map<Object,Object>
        重写：
        replace在 Hashtable<Object,Object>
        参数
        key - 与指定值相关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示映射以前关联的是null的密钥，如果实现支持空值）。

      • computeIfAbsent

        public Object computeIfAbsent​(Object key,
                              Function<? super Object,?> mappingFunction)
        描述从类别复制： Hashtable
        如果指定的键尚未与值相关联（或映射到null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是null 。

        如果映射函数返回null ，则不记录映射。 如果映射函数本身引发（未检查）异常，则重新抛出异常，并且不记录映射。 最常见的用法是构造一个用作初始映射值或记忆结果的新对象，如：

           map.computeIfAbsent(key, k -> new Value(f(k)));

        或者实现一个多值映射Map<K,Collection<V>> ，每个键支持多个值：

           map.computeIfAbsent(key, k -> new HashSet<V>()).add(v);

        映射函数在计算过程中不应该修改该映射。

        如果映射函数在计算过程中修改了该映射，则该方法将尽力而为地抛出ConcurrentModificationException 。

        Specified by:
        computeIfAbsent在接口 Map<Object,Object>
        重写：
        computeIfAbsent在 Hashtable<Object,Object>
        参数
        key - 要与其关联的指定值的键
        mappingFunction - 计算值的映射函数
        结果
        与指定键相关联的当前（现有或计算）值，如果计算值为空，则为null

      • computeIfPresent

        public Object computeIfPresent​(Object key,
                               BiFunction<? super Object,? super Object,?> remappingFunction)
        描述从类复制： Hashtable
        如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

        如果重映射函数返回null ，则映射将被删除。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        如果重新映射功能在计算过程中修改了该映射，这个方法将尽力而为地抛出一个ConcurrentModificationException 。

        Specified by:
        computeIfPresent在接口 Map<Object,Object>
        重写：
        computeIfPresent在 Hashtable<Object,Object>
        参数
        key - 要与其关联的指定值的键
        remappingFunction - 计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null

      • compute

        public Object compute​(Object key,
                      BiFunction<? super Object,? super Object,?> remappingFunction)
        描述从类复制： Hashtable
        尝试计算指定键的映射及其当前映射的值（如果没有当前映射， null ）。 例如，要为值映射创建或附加String msg：
           map.compute(key, (k, v) -> (v == null) ? msg : v.concat(msg))
        （方法merge()通常更容易用于此类目的。）

        如果重映射函数返回null ，则映射将被删除（如果最初不存在则保持不存在）。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        如果重映射功能在计算过程中修改了该映射，这个方法将尽力而为地抛出一个ConcurrentModificationException 。

        Specified by:
        compute在接口 Map<Object,Object>
        重写：
        compute在 Hashtable<Object,Object>
        参数
        key - 指定值与之关联的键
        remappingFunction - 用于计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null

      • merge

        public Object merge​(Object key,
                    Object value,
                    BiFunction<? super Object,? super Object,?> remappingFunction)
        描述从类复制： Hashtable
        如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。 否则，将关联值替换为给定重映射函数的结果，如果结果为null ，则将其null 。 当组合键的多个映射值时，该方法可能是有用的。 例如，要创建或追加String msg到值映射：
           map.merge(key, msg, String::concat)

        如果重映射函数返回null ，则映射将被删除。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        如果重映射功能在计算过程中修改了该映射，则该方法将尽力而为地抛出ConcurrentModificationException 。

        Specified by:
        merge在接口 Map<Object,Object>
        重写：
        merge在 Hashtable<Object,Object>
        参数
        key - 与其结合的值相关联的键
        value - 要与与密钥相关联的现有值合并的非空值，或者如果没有现有值或与值相关联的空值与密钥相关联
        remappingFunction - 如果存在重新计算值的重映射功能
        结果
        与指定键相关联的新值，如果没有值与该键相关联，则返回null

      • rehash

        protected void rehash​()
        描述从类别复制： Hashtable
        增加这个散列表的内部重组能力，从而更有效地适应和访问其条目。 当哈希表中的键数超过此散列表的容量和载入系数时，将自动调用此方法。
        重写：
        rehash在 Hashtable<Object,Object>

      • clone

        public Object clone​()
        描述从类复制： Hashtable
        创建这个散列表的浅拷贝。 哈希表本身的所有结构都被复制，但是键和值不被克隆。 这是一个相对昂贵的操作。
        重写：
        clone在 Hashtable<Object,Object>
        结果
        哈希表克隆
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PropertyPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class PropertyPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.util.PropertyPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class PropertyPermission
extends BasicPermission
    此类用于属性权限。

    名称是属性的名称（“java.home”，“os.name”等）。 命名约定遵循层次化属性命名约定。 此外，星号可能会出现在名称的末尾，遵循“。”或本身表示通配符匹配。 例如：“java。*”和“*”表示通配符匹配，而“* java”和“a * b”则不表示。

    要授予的操作将以包含一个或多个以逗号分隔的关键字的列表的字符串的形式传递给构造函数。 可能的关键字是“读”和“写”。 其含义定义如下：

    读
    读权限 允许System.getProperty 。
    写
    写许可。 允许System.setProperty 。

    操作字符串在处理之前转换为小写。

    在授予访问某些系统属性的代码权限之前，请注意。 例如，授予访问“java.home”系统属性的权限提供了有关系统环境（Java安装目录）的恶意代码敏感信息。 此外，授予访问“user.name”和“user.home”系统属性的权限提供了有关用户环境（用户的帐户名称和主目录）的恶意代码敏感信息。

    从以下版本开始：
    1.2
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyPermission​(String name, String actions)
      创建一个具有指定名称的新PropertyPermission对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查两个PropertyPermission对象是否相等。
      String getActions​()
      返回动作的“规范字符串表示”。
      int hashCode​()
      返回此对象的哈希码值。
      boolean implies​(Permission p)
      检查此PropertyPermission对象是否“暗示”指定的权限。
      PermissionCollection newPermissionCollection​()
      返回一个用于存储PropertyPermission对象的新的PermissionCollection对象。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • PropertyPermission

        public PropertyPermission​(String name,
                          String actions)
        创建一个具有指定名称的新PropertyPermission对象。 该名称是系统属性的名称， 操作包含在属性上授予的所需操作的逗号分隔列表。 可能的操作是“读取”和“写入”。
        参数
        name - PropertyPermission的名称。
        actions - 操作字符串。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空，或者如果 actions无效。

    • 方法详细信息

      • implies

        public boolean implies​(Permission p)
        检查此PropertyPermission对象是否“暗示”指定的权限。

        更具体地说，这个方法返回true：

        • p是PropertyPermission的一个实例，
        • p的动作是这个对象的动作的一个子集
        • p的名称是由该对象的名称所暗示的。 例如，“java。*”意味着“java.home”。
        重写：
        implies在 BasicPermission
        参数
        p - 允许检查。
        结果
        如果此对象隐含指定的权限，则为true，否则为false。

      • equals

        public boolean equals​(Object obj)
        检查两个PropertyPermission对象是否相等。 检查obj是一个PropertyPermission，并具有与此对象相同的名称和操作。
        重写：
        equals在 BasicPermission
        参数
        obj - 我们正在测试与此对象相等的对象。
        结果
        如果obj是PropertyPermission，则为true，并具有与此PropertyPermission对象相同的名称和操作。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此对象的哈希码值。 使用的哈希码是此权限名称的哈希码，即getName().hashCode() ，其中getName来自Permission超类。
        重写：
        hashCode在 BasicPermission
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getActions

        public String getActions​()
        返回动作的“规范字符串表示”。 也就是说，该方法总是按照以下顺序返回当前操作：读取，写入。 例如，如果此PropertyPermission对象允许写入和读取操作，则调用getActions将返回字符串“读取，写入”。
        重写：
        getActions在 BasicPermission
        结果
        规范字符串表示的动作。

      • newPermissionCollection

        public PermissionCollection newPermissionCollection​()
        返回一个用于存储PropertyPermission对象的新的PermissionCollection对象。
        重写：
        newPermissionCollection在 BasicPermission
        结果
        适用于存储PropertyPermissions的新PermissionCollection对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PropertyResourceBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class PropertyResourceBundle

  • java.lang.Object
    • java.util.ResourceBundle
      • java.util.PropertyResourceBundle

  • public class PropertyResourceBundle
extends ResourceBundle
    PropertyResourceBundle是的具体子类ResourceBundle管理资源使用一组属性文件中的静态字符串的语言环境。 有关资源束的更多信息，请参阅ResourceBundle 。

    与其他类型的资源束不同，您不需要PropertyResourceBundle 。 而是提供包含资源数据的属性文件。 ResourceBundle.getBundle会自动查找相应的属性文件，并创建一个引用它的PropertyResourceBundle 。 有关搜索和实例化策略的完整说明，请参阅ResourceBundle.getBundle 。

    以下example显示基本名称为“MyResources”的资源束系列的成员。 该文本定义了捆绑包系列的德语成员“MyResources_de”捆绑包。 该成员基于PropertyResourceBundle ，因此该文本是“MyResources_de.properties”文件的内容（相关的example显示了如何向该系列添加捆绑包，实现为ListResourceBundle子类）。 此示例中的键的格式为“s1”等。实际的键完全取决于您的选择，只要它们与您在程序中使用的键相同即可从包中检索对象。 密钥区分大小写。

     # MessageFormat pattern
 s1=Die Platte \"{1}\" enthält {0}.

 # location of {0} in pattern
 s2=1

 # sample disk name
 s3=Meine Platte

 # first ChoiceFormat choice
 s4=keine Dateien

 # second ChoiceFormat choice
 s5=eine Datei

 # third ChoiceFormat choice
 s6={0,number} Dateien

 # sample date
 s7=3. März 1996
    API Note:
    PropertyResourceBundle可以由表示属性文件的InputStream或Reader构造。 从InputStream构建一个PropertyResourceBundle实例要求输入流编码在UTF-8 。 默认情况下，如果在读取输入流时发生MalformedInputException或UnmappableCharacterException ，则PropertyResourceBundle实例将重新设置为异常之前的状态，重新读取ISO-8859-1的输入流，并继续读取。 如果系统属性java.util.PropertyResourceBundle.encoding被设置为“ISO-8859-1”或“UTF-8”，则输入流仅以该编码读取，如果遇到无效序列则抛出该异常。 如果指定“ISO-8859-1”时，即不能在ISO-8859-1编码表示的字符必须由Unicode转义如在The Java™ Language Specification第3.3节中定义，而其他的构造，这需要表示Reader没有该限制。 此系统属性将忽略其他编码值。 在初始化此类时读取和评估系统属性。 更改或删除属性在初始化后不起作用。
    实现要求：
    PropertyResourceBundle子类的实现必须是线程安全的，如果它同时被多个线程使用。 该类中非抽象方法的默认实现是线程安全的。
    从以下版本开始：
    1.1
    另请参见：
    ResourceBundle ， ListResourceBundle ， Properties

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.ResourceBundle

        ResourceBundle.Control

    • Field Summary

      • Fields inherited from class java.util.ResourceBundle

        parent

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyResourceBundle​(InputStream stream)
      从InputStream创建属性资源包。
      PropertyResourceBundle​(Reader reader)
      从Reader创建属性资源包。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Enumeration<String> getKeys​()
      返回一个 Enumeration包含在此按键 ResourceBundle及其父包。
      Object handleGetObject​(String key)
      从此资源包获取给定键的对象。
      protected Set<String> handleKeySet​()
      返回一个 Set的键 只包含在这个 ResourceBundle 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.ResourceBundle

        clearCache, clearCache, containsKey, getBaseBundleName, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getLocale, getObject, getString, getStringArray, keySet, setParent

    • 构造方法详细信息

      • PropertyResourceBundle

        public PropertyResourceBundle​(InputStream stream)
                       throws IOException
        从InputStream创建属性资源包。 该构造函数默认读取UTF-8中的属性文件。 如果在读取输入流时出现MalformedInputException或UnmappableCharacterException ，则PropertyResourceBundle实例将重新设置为异常之前的状态，重新读取ISO-8859-1的输入流并继续读取。 如果将系统属性java.util.PropertyResourceBundle.encoding设置为“ISO-8859-1”或“UTF-8”，则输入流只能以该编码读取，如果遇到无效序列则抛出异常。 此系统属性将忽略其他编码值。 在初始化此类时读取和评估系统属性。 更改或删除属性在初始化后不起作用。
        参数
        stream - 表示要读取的属性文件的InputStream。
        异常
        IOException - 如果发生I / O错误
        NullPointerException - 如果 stream为空
        IllegalArgumentException - 如果 stream包含格式不正确的Unicode转义序列。
        MalformedInputException - 如果系统属性 java.util.PropertyResourceBundle.encoding设置为“UTF-8”，并且 stream包含无效的UTF-8字节序列。
        UnmappableCharacterException - 如果系统属性 java.util.PropertyResourceBundle.encoding设置为“UTF-8”，并且 stream包含不可映射的UTF-8字节序列。

      • PropertyResourceBundle

        public PropertyResourceBundle​(Reader reader)
                       throws IOException
        从Reader创建属性资源包。 与构造函数PropertyResourceBundle(InputStream)不同，对输入属性文件的编码没有限制。
        参数
        reader - 表示要读取的属性文件的Reader。
        异常
        IOException - 如果发生I / O错误
        NullPointerException - 如果 reader为空
        IllegalArgumentException - 如果从 reader出现格式错误的Unicode转义序列。
        从以下版本开始：
        1.6

    • 方法详细信息

      • handleGetObject

        public Object handleGetObject​(String key)
        描述从类复制： ResourceBundle
        从此资源包获取给定键的对象。 如果此资源束不包含给定键的对象，则返回null。
        Specified by:
        handleGetObject在 ResourceBundle
        参数
        key - 所需对象的关键
        结果
        给定键的对象，或null

      • getKeys

        public Enumeration<String> getKeys​()
        返回一个 Enumeration包含在此按键 ResourceBundle及其父包。
        Specified by:
        getKeys在 ResourceBundle
        结果
        该 ResourceBundle及其父级包含的密钥中包含 Enumeration个密钥。
        另请参见：
        ResourceBundle.keySet()

      • handleKeySet

        protected Set<String> handleKeySet​()
        返回一个 Set的键 只包含在这个 ResourceBundle 。
        重写：
        handleKeySet在 ResourceBundle
        结果
        一个 Set的键只包含在这个 ResourceBundle
        从以下版本开始：
        1.6
        另请参见：
        ResourceBundle.keySet()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Queue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Queue<E>

  • 参数类型
    E - 保存在此队列中的元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E>
    All Known Subinterfaces:
    BlockingDeque<E> ， BlockingQueue<E> ， Deque<E> ， TransferQueue<E>
    所有已知实现类：
    AbstractQueue ， ArrayBlockingQueue ， ArrayDeque ， ConcurrentLinkedDeque ， ConcurrentLinkedQueue ， DelayQueue ， LinkedBlockingDeque ， LinkedBlockingQueue ， LinkedList ， LinkedTransferQueue ， PriorityBlockingQueue ， PriorityQueue ， SynchronousQueue

    public interface Queue<E>
extends Collection<E>
    设计用于在处理之前保留元素的集合。 除了基本的Collection操作之外，队列还提供额外的插入，抽取和检查操作。 这些方法中的每一种都有两种形式：如果操作失败，则抛出异常，另一种返回一个特殊值（根据操作而异）（ null或false ）。 插入操作的后一种形式专门用于容量限制的Queue实现; 在大多数实现中，插入操作不能失败。 Summary of Queue methods Throws exception Returns special value Insert add(e) offer(e) Remove remove() poll() Examine element() peek()

    队列通常但不一定是以FIFO（先进先出）方式排序元素。 除了优先级队列之外，优先级队列是根据提供的比较器对元素进行排序，还是元素的自然排序，以及对元素LIFO（先进先出）进行排序的LIFO队列（或堆栈）。 无论使用什么顺序，队列的头都是通过调用remove()或poll()删除的元素。 在FIFO队列中，所有新元素都插入到队列尾部 。 其他类型的队列可以使用不同的布局规则。 每个Queue实现必须指定其排序属性。

    如果可能的话， offer方法插入一个元素，否则返回false 。 这与Collection.add方法不同，只能通过抛出未经检查的异常来添加元素。 offer方法设计用于在故障是正常的情况下使用，而不是例外情况下，例如在固定容量（或“有界”）队列中。

    remove()和poll()方法删除并返回队列的头。 从队列中删除哪个元素是队列排序策略的一个功能，它与实现与实现不同。 remove()和poll()方法在队列为空时的行为不同： remove()方法抛出异常，而poll()方法返回null 。

    element()和peek()方法返回，但不要删除，头的队列。

    Queue接口没有定义阻塞队列方法 ，这在并发编程中很常见。 BlockingQueue接口中定义了这些等待元素出现或空格可用的方法，该接口扩展了此接口。

    Queue实现通常不允许插入null元素，尽管一些实现（如LinkedList ）不禁止插入null 。 即使在允许它的实现中， null也不应该插入到Queue ，因为null也被用作poll方法的特殊返回值来指示该队列不包含任何元素。

    Queue实现通常不定义基于元素的方法的方法equals和hashCode ，而是继承从类别Object基于身份的版本，因为基于元素的等式并不总是很好地定义了具有相同元素但不同的排序属性的队列。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素插入到此队列中，如果可以立即执行此操作而不违反容量限制， true成功返回 true ，如果当前没有可用的空间，则抛出 IllegalStateException 。
      E element​()
      检索，但不删除，这个队列的头。
      boolean offer​(E e)
      如果在不违反容量限制的情况下立即执行，则将指定的元素插入到此队列中。
      E peek​()
      检索但不删除此队列的头，如果此队列为空，则返回 null 。
      E poll​()
      检索并删除此队列的头部，如果此队列为空，则返回 null 。
      E remove​()
      检索并删除此队列的头。

      • Methods inherited from interface java.util.Collection

        addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, parallelStream, remove, removeAll, removeIf, retainAll, size, spliterator, stream, toArray, toArray

      • Methods inherited from interface java.lang.Iterable

        forEach

    • 方法详细信息

      • add

        boolean add​(E e)
        将指定的元素插入到此队列中，如果可以立即执行此操作，而不会违反容量限制，成功后返回 true ，如果当前没有可用空间，则抛出 IllegalStateException 。
        Specified by:
        add在接口 Collection<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空，并且此队列不允许空元素
        IllegalArgumentException - 如果此元素的某些属性阻止将其添加到此队列

      • offer

        boolean offer​(E e)
        如果在不违反容量限制的情况下立即执行，则将指定的元素插入到此队列中。 当使用容量限制队列时，此方法通常优于add(E) ，这可能无法仅通过抛出异常来插入元素。
        参数
        e - 要添加的元素
        结果
        true如果该元素已添加到此队列，否则为 false
        异常
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空，并且该队列不允许空元素
        IllegalArgumentException - 如果此元素的某些属性阻止将其添加到此队列

      • remove

        E remove​()
        检索并删除此队列的头。 此方法与poll的不同之处在于，如果此队列为空，它将抛出异常。
        结果
        这个队列的头
        异常
        NoSuchElementException - 如果这个队列是空的

      • poll

        E poll​()
        检索并删除此队列的头部，如果此队列为空，则返回 null 。
        结果
        这个队列的头，或 null如果这个队列是空的

      • element

        E element​()
        检索，但不删除，这个队列的头。 此方法与peek不同之处在于，如果此队列为空，它将抛出异常。
        结果
        这个队列的头
        异常
        NoSuchElementException - 如果这个队列是空的

      • peek

        E peek​()
        检索但不删除此队列的头，如果此队列为空，则返回 null 。
        结果
        这个队列的头，或 null如果这个队列是空的
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Random (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Random

  • java.lang.Object
    • java.util.Random
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    SecureRandom ， ThreadLocalRandom

    public class Random
extends Object
implements Serializable
    该类的实例用于生成伪随机数的流。 该类使用48位种子，其使用线性同余公式进行修改。 （见Donald Knuth， “计算机编程艺术”，第2卷 ，第3.2.1节）

    如果使用相同的种子创建两个Random实例，并且为每个实例生成相同的方法调用序列，则它们将生成并返回相同的数字序列。 为了保证此属性，为Random类指定了特定的算法。 为了Java代码的绝对可移植性，Java实现必须使用这里所示的Random类的所有算法。 但是， Random类的子类允许使用其他算法，只要它们遵守所有方法的一般合同。

    Random实现的算法使用protected实用程序方法，每个调用可以提供多达32个伪随机生成的位。

    许多应用程序会发现方法Math.random()使用起来更简单。

    java.util.Random实例是线程安全的。 但是，同时使用跨线程的java.util.Random实例可能会遇到争用，从而导致性能下降。 在多线程设计中考虑使用ThreadLocalRandom 。

    java.util.Random实例不是加密安全的。 考虑使用SecureRandom获得一个加密安全的伪随机数生成器，供安全敏感应用程序使用。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Random​()
      创建一个新的随机数生成器。
      Random​(long seed)
      使用单个 long种子创建一个新的随机数生成器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleStream doubles​()
      返回一个有效的无限流的伪随机数 double ，每个值在零（包括）和一（独占）之间。
      DoubleStream doubles​(double randomNumberOrigin, double randomNumberBound)
      返回一个有效的无限流伪随机数 double值，每个符合给定的起始（包括）和绑定（排除）。
      DoubleStream doubles​(long streamSize)
      返回一个流，产生给定的 streamSize伪随机数 double值，每个值在零（包括）和一（独占）之间。
      DoubleStream doubles​(long streamSize, double randomNumberOrigin, double randomNumberBound)
      返回一个流，产生给定的 streamSize数量的伪随机数 double值，每个符合给定的起始（包括）和绑定（排他）。
      IntStream ints​()
      返回一个有效的无限流的伪随机数 int值。
      IntStream ints​(int randomNumberOrigin, int randomNumberBound)
      返回一个有效无限流的伪随机数 int值，每个符合给定的起始（包括）和绑定（排除）。
      IntStream ints​(long streamSize)
      返回产生给定的 streamSize数量的伪随机数 int值的流。
      IntStream ints​(long streamSize, int randomNumberOrigin, int randomNumberBound)
      返回一个流，产生给定的 streamSize伪随机数 int值，每个值符合给定的起始（包括）和绑定（排他）。
      LongStream longs​()
      返回一个有效的无限流的伪随机数 long值。
      LongStream longs​(long streamSize)
      返回一个流，产生给定的 streamSize伪随机数 long值。
      LongStream longs​(long randomNumberOrigin, long randomNumberBound)
      返回一个有效的无限流伪随机数 long ，每个值都符合给定的起始（包括）和绑定（排他）。
      LongStream longs​(long streamSize, long randomNumberOrigin, long randomNumberBound)
      返回一个流，产生给定的 streamSize伪随机数 long ，每个符合给定的起始（包括）和绑定（排他）。
      protected int next​(int bits)
      生成下一个伪随机数。
      boolean nextBoolean​()
      从该随机数生成器的序列返回下一个伪随机数，均匀分布的 boolean值。
      void nextBytes​(byte[] bytes)
      生成随机字节并将它们放入用户提供的字节数组中。
      double nextDouble​()
      返回下一个伪，均匀分布 double之间价值 0.0和 1.0从这个随机数生成器的序列。
      float nextFloat​()
      返回下一个伪，均匀分布 float之间价值 0.0和 1.0从这个随机数生成器的序列。
      double nextGaussian​()
      从该随机数发生器的序列返回下一个伪随机数，高斯（“正”）分布的 double值，平均值为 0.0 ，标准偏差为 1.0 。
      int nextInt​()
      从这个随机数生成器的序列返回下一个伪随机数，均匀分布的 int值。
      int nextInt​(int bound)
      返回伪随机的，均匀分布 int值介于0（含）和指定值（不包括），从该随机数生成器的序列绘制。
      long nextLong​()
      返回下一个伪随机数，从这个随机数发生器的序列中均匀分布 long值。
      void setSeed​(long seed)
      使用单个 long种子设置此随机数生成器的种子。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Random

        public Random​()
        创建一个新的随机数生成器。 该构造函数将随机数生成器的种子设置为非常可能与该构造函数的任何其他调用不同的值。

      • Random

        public Random​(long seed)
        使用单个long种子创建一个新的随机数生成器。 种子是由方法next(int)维护的伪随机数发生器的内部状态的初始值。

        调用new Random(seed)相当于：

           Random rnd = new Random(); rnd.setSeed(seed);
        参数
        seed - 初始种子
        另请参见：
        setSeed(long)

    • 方法详细信息

      • setSeed

        public void setSeed​(long seed)
        使用单个long种子设置此随机数生成器的种子。 setSeed的一般合同是它改变这个随机数生成器对象的状态，使其处于与刚刚使用参数seed作为种子创建的状态完全相同的状态。 方法setSeed由类Random通过将种子进行原子更新来实现
          (seed ^ 0x5DEECE66DL) & ((1L << 48) - 1)
        并清除haveNextNextGaussian由已使用标志nextGaussian() 。

        setSeed类的Random恰好只使用给定种子的48位。 然而，一般来说，重写方法可以使用long参数的所有64位作为种子值。

        参数
        seed - 初始种子

      • next

        protected int next​(int bits)
        生成下一个伪随机数。 子类应该覆盖这一点，因为它被所有其他方法所使用。

        next的一般合同是它返回一个int值，如果参数bits在1和32 （含）之间，那么返回值的许多低位将是（大约）独立选择的位值，其中每一个大概相当可能是0或1 。 方法next由类Random通过将种子进行原子更新来实现

          (seed * 0x5DEECE66DL + 0xBL) & ((1L << 48) - 1)
        并返回
          (int)(seed >>> (48 - bits)).
        这是由DH Lehmer定义的线性同余伪随机数生成器，由Donald E. Knuth在“计算机编程艺术”第2卷： 半数学算法 ，第3.2.1节中描述。
        参数
        bits - 随机位
        结果
        来自该随机数发生器序列的下一个伪随机值
        从以下版本开始：
        1.1

      • nextBytes

        public void nextBytes​(byte[] bytes)
        生成随机字节并将它们放入用户提供的字节数组中。 产生的随机字节数等于字节数组的长度。

        方法nextBytes由类Random实现，如：

           public void nextBytes(byte[] bytes) { for (int i = 0; i < bytes.length; ) for (int rnd = nextInt(), n = Math.min(bytes.length - i, 4); n-- > 0; rnd >>= 8) bytes[i++] = (byte)rnd; }
        参数
        bytes - 用随机字节填充的字节数组
        异常
        NullPointerException - 如果字节数组为空
        从以下版本开始：
        1.1

      • nextInt

        public int nextInt​()
        返回下一个伪随机数，从这个随机数发生器的序列中均匀分布int值。 nextInt的一般合同是一个int值被伪随机生成并返回。 全部2 32个可能的int值以（近似）等概率产生。

        方法nextInt由类Random实现，如：

           public int nextInt() { return next(32); }
        结果
        下一个伪随机数，从这个随机数发生器的序列中均匀分布 int值

      • nextInt

        public int nextInt​(int bound)
        返回伪随机数，从0（包括）和指定值（排除）之间均匀分布的int值，从该随机数生成器的序列中抽取出来。 nextInt的一般合同是指定范围内的一个int值被伪随机生成并返回。 全部bound可能的int值以（近似）相等的概率产生。 方法nextInt(int bound)由类Random实现，如下面所示：
           public int nextInt(int bound) { if (bound <= 0) throw new IllegalArgumentException("bound must be positive"); if ((bound & -bound) == bound) // i.e., bound is a power of 2 return (int)((bound * (long)next(31)) >> 31); int bits, val; do { bits = next(31); val = bits % bound; } while (bits - val + (bound-1) < 0); return val; }

        仅在下面的方法仅仅是独立选择的位的无偏差源的情况下，在上述描述中使用了“大约”对冲。 如果它是随机选择的位的完美来源，则所示的算法将从所述范围中选择int值，具有完美的均匀性。

        该算法有点棘手。 它拒绝会导致分配不均的价值（由于2 ^ 31不能被n整除）。 值被拒绝的概率取决于n。 最坏的情况是n = 2 ^ 30 + 1，拒绝概率为1/2，循环终止前的预期迭代次数为2。

        该算法处理n特别是2的幂的情况：它从底层伪随机数发生器返回正确数量的高阶位。 在没有特殊处理的情况下，将返回正确数量的低位 。 已知线性同余伪随机数发生器（例如由该类实现的）产生器在其低阶位的值序列中具有短周期。 因此，如果n是2的小功率，这种特殊情况大大增加了对该方法的连续调用返回的值的序列的长度。

        参数
        bound - 上限（独占）。 必须是积极的。
        结果
        下一个伪随机数，从这个随机数发生器的序列中均匀分布在零（包括）和 bound （排他）之间的 int值
        异常
        IllegalArgumentException - 如果绑定 IllegalArgumentException
        从以下版本开始：
        1.2

      • nextLong

        public long nextLong​()
        返回下一个伪随机数，从这个随机数发生器的序列中均匀分布long值。 nextLong的一般合同是一个long值被伪随机生成并返回。

        方法nextLong由类Random实现，如：

           public long nextLong() { return ((long)next(32) << 32) + next(32); }
        因为Random类使用仅48位的种子，所以该算法将不会返回所有可能的long值。
        结果
        下一个伪随机数，从这个随机数发生器的序列中均匀分布 long值

      • nextBoolean

        public boolean nextBoolean​()
        返回下一个伪随机数，从该随机数发生器的序列中均匀分布boolean值。 nextBoolean的一般合同是一个boolean值被伪随机生成并返回。 值（ true和（ false ）以（近似）等概率产生。

        方法nextBoolean由类Random实现，如：

           public boolean nextBoolean() { return next(1) != 0; }
        结果
        下一个伪随机数，从这个随机数发生器的序列中均匀分布 boolean值
        从以下版本开始：
        1.2

      • nextFloat

        public float nextFloat​()
        返回下一个伪，均匀分布float之间价值0.0和1.0从这个随机数生成器的序列。

        的常规协定nextFloat是一个float值，选择（约）均匀地从范围0.0f （含）至1.0f （不包括），伪随机地生成并返回。 以大致相同的概率产生形式为m× 2 -24 ，其中m是小于2 24的正整数的所有2 24个可能的float值。

        方法nextFloat由类Random实现，好像通过如下：

           public float nextFloat() { return next(24) / ((float)(1 << 24)); }

        仅在下面的方法仅仅是独立选择的位的无偏差源的情况下，在上述描述中使用了“大约”对冲。 如果它是随机选择位的完美源，则所示的算法将从所述范围中选择float值，具有完美的均匀性。

        [在Java的早期版本中，结果错误地计算为：

           return next(30) / ((float)(1 << 30));
        这可能似乎是等同的，如果不是更好，但实际上它引入了一个轻微的不均匀性，因为浮点数的四舍五入的偏差：有意义的低位比较有可能是0这将是1.]
        结果
        下一个伪均匀分布 float值之间 0.0和 1.0从该随机数生成器的序列

      • nextDouble

        public double nextDouble​()
        返回下一个伪，均匀分布double之间价值0.0和1.0从这个随机数生成器的序列。

        的常规协定nextDouble是一个double值，选择（约）均匀地从范围0.0d （含）至1.0d （不包括），伪随机地生成并返回。

        方法nextDouble由类Random实现，如同通过：

           public double nextDouble() { return (((long)next(26) << 27) + next(27)) / (double)(1L << 53); }

        仅在next方法仅仅是独立选择的位的无偏差源时才使用“近似”对冲。 如果它是随机选择位的完美来源，则所示的算法将从所述范围中选择double值，具有完美的均匀性。

        [在Java的早期版本中，结果错误地计算为：

           return (((long)next(27) << 27) + next(27)) / (double)(1L << 54);
        这可能似乎是等同的，如果不是更好，但事实上它引入了一个大的不均匀性，因为浮点数的四舍五入有偏差：有效数的低位是0的可能性是三倍比那会是1！ 这种不均匀性在实践中可能无关紧要，但我们力求完美。]
        结果
        下一个伪均匀分布 double值之间 0.0和 1.0从该随机数生成器的序列
        另请参见：
        Math.random()

      • nextGaussian

        public double nextGaussian​()
        返回下一个伪随机数，高斯（“正常”）分布的double值，平均值为0.0 ，标准偏差为1.0 。

        nextGaussian的一般合同是从（大约）平均值为0.0和标准差1.0的常规正态分布中选出的一个double值被伪随机生成并返回。

        方法nextGaussian由类Random实现，好像通过以下的线程安全版本：

           private double nextNextGaussian; private boolean haveNextNextGaussian = false; public double nextGaussian() { if (haveNextNextGaussian) { haveNextNextGaussian = false; return nextNextGaussian; } else { double v1, v2, s; do { v1 = 2 * nextDouble() - 1; // between -1.0 and 1.0 v2 = 2 * nextDouble() - 1; // between -1.0 and 1.0 s = v1 * v1 + v2 * v2; } while (s >= 1 || s == 0); double multiplier = StrictMath.sqrt(-2 * StrictMath.log(s)/s); nextNextGaussian = v2 * multiplier; haveNextNextGaussian = true; return v1 * multiplier; } }
        这使用GEP Box，ME Muller和G. Marsaglia的极性方法 ，如Donald E. Knuth在“计算机编程艺术”第2卷： Seminumerical Algorithms ，第3.4.1节，C节，算法P中所述。请注意它产生两个独立的值，只需一次呼叫StrictMath.log ，另一个呼叫到StrictMath.sqrt 。
        结果
        下一个伪随机数，高斯（“正常”）分布 double值，平均值为 0.0 ，标准偏差为 1.0来自该随机数发生器的序列

      • ints

        public IntStream ints​(long streamSize)
        返回一个流，产生给定的streamSize伪随机数int值。

        产生伪随机数int值就像调用方法nextInt()的结果一样 。

        参数
        streamSize - 要生成的值的数量
        结果
        一串伪随机数 int
        异常
        IllegalArgumentException - 如果 streamSize小于零
        从以下版本开始：
        1.8

      • ints

        public IntStream ints​()
        返回一个有效的无限流的伪随机数int值。

        伪随机数int值被生成，就像它是调用方法nextInt()的结果一样 。

        Implementation Note:
        该方法实现等同于 ints(Long.MAX_VALUE) 。
        结果
        一串伪随机的数值 int
        从以下版本开始：
        1.8

      • ints

        public IntStream ints​(long streamSize,
                      int randomNumberOrigin,
                      int randomNumberBound)
        返回一个流，产生给定的streamSize伪随机数int值，每个值符合给定的起始（包括）和绑定（排他）。

        伪随机int值被生成，就像它是使用原点和边界调用以下方法的结果一样：

           int nextInt(int origin, int bound) { int n = bound - origin; if (n > 0) { return nextInt(n) + origin; } else { // range not representable as int int r; do { r = nextInt(); } while (r < origin || r >= bound); return r; } }
        参数
        streamSize - 要生成的值的数量
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一系列伪随机数（ int ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 streamSize小于零，或 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • ints

        public IntStream ints​(int randomNumberOrigin,
                      int randomNumberBound)
        返回一个有效的无限流伪随机int ，每个符合给定的起始（包括）和绑定（排除）。

        产生伪随机数int值就像使用原始和绑定调用以下方法的结果一样：

           int nextInt(int origin, int bound) { int n = bound - origin; if (n > 0) { return nextInt(n) + origin; } else { // range not representable as int int r; do { r = nextInt(); } while (r < origin || r >= bound); return r; } }
        Implementation Note:
        该方法实现相当于 ints(Long.MAX_VALUE, randomNumberOrigin, randomNumberBound) 。
        参数
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机流， int ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • longs

        public LongStream longs​(long streamSize)
        返回一个流，产生给定的streamSize伪随机数long值。

        伪随机数long值被生成，就像调用方法nextLong()的结果一样 。

        参数
        streamSize - 要生成的值的数量
        结果
        一串伪随机数 long
        异常
        IllegalArgumentException - 如果 streamSize小于零
        从以下版本开始：
        1.8

      • longs

        public LongStream longs​()
        返回一个有效的无限流的伪随机数long值。

        产生伪随机数long值就像调用方法nextLong()的结果一样 。

        Implementation Note:
        该方法实现为等同于 longs(Long.MAX_VALUE) 。
        结果
        一串伪随机数 long
        从以下版本开始：
        1.8

      • longs

        public LongStream longs​(long streamSize,
                        long randomNumberOrigin,
                        long randomNumberBound)
        返回产生所述给定流streamSize数的伪随机的long ，每个符合给定的原点（含）和结合（不包括）。

        伪随机long值被生成，就像它是使用原点和边界调用以下方法的结果一样：

           long nextLong(long origin, long bound) { long r = nextLong(); long n = bound - origin, m = n - 1; if ((n & m) == 0L) // power of two r = (r & m) + origin; else if (n > 0L) { // reject over-represented candidates for (long u = r >>> 1; // ensure nonnegative u + m - (r = u % n) < 0L; // rejection check u = nextLong() >>> 1) // retry ; r += origin; } else { // range not representable as long while (r < origin || r >= bound) r = nextLong(); } return r; }
        参数
        streamSize - 要生成的值的数量
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数（ long ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 streamSize小于零，或 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • longs

        public LongStream longs​(long randomNumberOrigin,
                        long randomNumberBound)
        返回一个有效的无限流的伪随机数long值，每个符合给定的起始（包括）和绑定（排他）。

        伪随机数long值被生成，就像它是使用原始和绑定调用以下方法的结果一样：

           long nextLong(long origin, long bound) { long r = nextLong(); long n = bound - origin, m = n - 1; if ((n & m) == 0L) // power of two r = (r & m) + origin; else if (n > 0L) { // reject over-represented candidates for (long u = r >>> 1; // ensure nonnegative u + m - (r = u % n) < 0L; // rejection check u = nextLong() >>> 1) // retry ; r += origin; } else { // range not representable as long while (r < origin || r >= bound) r = nextLong(); } return r; }
        Implementation Note:
        该方法实现等同于 longs(Long.MAX_VALUE, randomNumberOrigin, randomNumberBound) 。
        参数
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数 long ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • doubles

        public DoubleStream doubles​(long streamSize)
        返回产生所述给定流streamSize数的伪随机的double值，每个零（含）和一个（不包括）之间。

        产生伪随机数double值就像调用方法nextDouble()的结果一样 。

        参数
        streamSize - 要生成的值的数量
        结果
        一串 double值
        异常
        IllegalArgumentException - 如果 streamSize小于零
        从以下版本开始：
        1.8

      • doubles

        public DoubleStream doubles​()
        返回一个有效的无限流的伪随机数double值，每个值在零（包括）和一（独占）之间。

        伪随机数double值被生成，就像它是调用方法nextDouble()的结果一样 。

        Implementation Note:
        该方法实现为等同于 doubles(Long.MAX_VALUE) 。
        结果
        一串伪随机数 double
        从以下版本开始：
        1.8

      • doubles

        public DoubleStream doubles​(long streamSize,
                            double randomNumberOrigin,
                            double randomNumberBound)
        返回一个流，产生给定的streamSize伪随机数double数值，每个值符合给定的起始（包括）和绑定（排他）。

        产生伪随机数double值就像使用原始和绑定调用以下方法的结果一样：

           double nextDouble(double origin, double bound) { double r = nextDouble(); r = r * (bound - origin) + origin; if (r >= bound) // correct for rounding r = Math.nextDown(bound); return r; }
        参数
        streamSize - 要生成的值的数量
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数（ double ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 streamSize小于零
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • doubles

        public DoubleStream doubles​(double randomNumberOrigin,
                            double randomNumberBound)
        返回一个有效的无限流伪随机数double值，每个符合给定的起始（包括）和绑定（排他）。

        伪随机数double值被生成，就像它是使用原点和边界调用以下方法的结果一样：

           double nextDouble(double origin, double bound) { double r = nextDouble(); r = r * (bound - origin) + origin; if (r >= bound) // correct for rounding r = Math.nextDown(bound); return r; }
        Implementation Note:
        该方法实现等同于 doubles(Long.MAX_VALUE, randomNumberOrigin, randomNumberBound) 。
        参数
        randomNumberOrigin - 每个随机值的起始（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一系列伪随机数（ double ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RandomAccess (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface RandomAccess

  • 所有已知实现类：
    ArrayList ， AttributeList ， CopyOnWriteArrayList ， RoleList ， RoleUnresolvedList ， Stack ， Vector

    public interface RandomAccess
    标记接口由List实现使用，以表明它们支持快速（通常为恒定时间）随机访问。 此接口的主要目的是允许通用算法更改其行为，以便在应用于随机访问列表或顺序访问列表时提供良好的性能。

    用于操纵随机访问列表的最佳算法（例如ArrayList ）可以在应用于顺序访问列表时产生二次行为（如LinkedList ）。 鼓励通用列表算法在应用如果将其应用于顺序访问列表之前提供较差性能的算法时，检查给定列表是否为instanceof ，并在必要时更改其行为以保证可接受的性能。

    人们认识到，随机访问和顺序访问之间的区别通常是模糊的。 例如，一些List实现提供渐近的线性访问时间，如果它们在实践中获得巨大但是恒定的访问时间。 这样的一个List实现应该通常实现这个接口。 根据经验， List实现应实现此接口，如果对于类的典型实例，此循环：

      for (int i=0, n=list.size(); i < n; i++)
         list.get(i);
    比这个循环运行得更快：
      for (Iterator i=list.iterator(); i.hasNext(); )
         i.next();

    此界面是Java Collections Framework的成员。

    从以下版本开始：
    1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ResourceBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class ResourceBundle

  • java.lang.Object
    • java.util.ResourceBundle
  • 已知直接子类：
    ListResourceBundle ， PropertyResourceBundle

    public abstract class ResourceBundle
extends Object
    资源束包含区域特定的对象。 当您的程序需要特定于区域设置的资源（例如， String ，您的程序可以从适合当前用户的区域设置的资源包中加载它。 以这种方式，您可以编写程序代码，这个程序代码大部分独立于用户的区域设置，以隔离资源束中大部分（如果不是全部）特定于区域设置的信息。

    这样就可以编写程序：

    • 容易本地化或翻译成不同的语言
    • 一次处理多个区域设置
    • 稍后可以轻松修改以支持更多的区域设置

    资源束属于其成员共享公共基本名称但其名称还具有标识其区域设置的其他组件的家族。 例如，资源束系列的基本名称可能是“MyResources”。 家庭应该有一个默认的资源包，它与其家族名称 - “MyResources”完全相同，如果不支持特定的区域设置，将会被用作最后的包。 然后，家族可以根据需要提供尽可能多的特定于区域的成员，例如名为“MyResources_de”的德语。

    一个系列中的每个资源包都包含相同的项目，但这些项目已被翻译成由该资源包所表示的区域设置。 例如，“MyResources”和“MyResources_de”都可能有一个用于取消操作的按钮上使用的String 。 在“MyResources”中， String可能包含“取消”，在“MyResources_de”中可能包含“Abbrechen”。

    如果不同国家有不同的资源，您可以进行专业化：例如，“MyResources_de_CH”包含瑞士（CH）中德语（de）的对象。 如果您只想修改专业化中的一些资源，可以这样做。

    当您的程序需要特定于语言环境的对象时，它将使用getBundle方法加载ResourceBundle类：

     ResourceBundle myResources =
      ResourceBundle.getBundle("MyResources", currentLocale);

    资源束包含键/值对。 密钥唯一标识包中特定于区域的对象。 这是一个包含两个键/值对的ListResourceBundle的示例：

     public class MyResources extends ListResourceBundle {
     protected Object[][] getContents() {
         return new Object[][] {
             // LOCALIZE THE SECOND STRING OF EACH ARRAY (e.g., "OK")
             {"OkKey", "OK"},
             {"CancelKey", "Cancel"},
             // END OF MATERIAL TO LOCALIZE
        };
     }
 }
    钥匙总是String s。 在这个例子中，键是“OkKey”和“CancelKey”。 在上面的例子中，值也是String s - “OK”和“Cancel” - 但是它们不一定是。 值可以是任何类型的对象。

    您使用适当的getter方法从资源束检索对象。 因为“OkKey”和“CancelKey”都是字符串，您可以使用getString来检索它们：

     button1 = new Button(myResources.getString("OkKey"));
 button2 = new Button(myResources.getString("CancelKey"));
    getter方法都需要键作为参数，并返回对象（如果找到）。 如果没有找到对象，那么getter方法会抛出一个MissingResourceException 。

    除了getString之外， ResourceBundle还提供了一种获取字符串数组的方法， getStringArray以及用于任何其他类型对象的通用的getObject方法。 使用getObject ，您必须将结果转换为适当的类型。 例如：

     int[] myIntegers = (int[]) myResources.getObject("intList");

    Java平台提供的两个子类ResourceBundle ， ListResourceBundle和PropertyResourceBundle ，提供一个相当简单的方法来创建资源。 如前面的例子中所示， ListResourceBundle其资源作为键/值对列表进行管理。 PropertyResourceBundle使用属性文件来管理其资源。

    如果ListResourceBundle或PropertyResourceBundle不适合您的需要，您可以编写自己的ResourceBundle子类。 您的子类必须覆盖两个方法： handleGetObject和getKeys() 。

    如果同时使用多个线程，则ResourceBundle子类的实现必须是线程安全的。 该类中非抽象方法的默认实现以及直接已知的具体子类ListResourceBundle和PropertyResourceBundle是线程安全的。

    Resource Bundles in Named Modules

    当资源束部署在命名模块中时，将应用以下模块特定的要求和限制。
    • 调用getBundle(String, Locale)的命名模块中的代码将在调用者模块（ 调用者模块 ）中定位资源束。
    • 如果将资源束部署在与调用者模块分开的命名模块中，则需要从ResourceBundleProvider的服务提供商加载这些资源束。 调用者模块必须声明“ uses ”，服务接口名称是基本名称的包名称字符串“ .spi. ”，基本名称的简单类名称和字符串“ Provider ”的连接。 包含资源束的包提供者模块必须使用服务接口名称及其实现类名称声明“ provides ”。 例如，如果基本名称是“ com.example.app.MyResources ”时，呼叫者模块必须声明“ uses com.example.app.spi.MyResourcesProvider; ”和包含资源包的模块必须声明“ provides com.example.app.spi.MyResourcesProvider with com.example.app.internal.MyResourcesProviderImpl; ”，其中com.example.app.internal.MyResourcesProviderImpl是一个实现类的com.example.app.spi.MyResourcesProvider 。
    • 如果要在命名模块（如XML）中使用非标准格式， 则需要使用ResourceBundleProvider 。
    • 该getBundle方法与ClassLoader可能无法找到使用给定的资源包ClassLoader命名模块。 可以使用具有Module的getBundle方法。
    • 命名模块不支持ResourceBundle.Control 。 如果在命名模块中调用ResourceBundle.Control的getBundle方法，则该方法将抛出一个UnsupportedOperationException 。 任何ResourceBundleControlProvider的服务提供商都将在命名模块中被忽略。

    ResourceBundleProvider Service Providers

    getBundle工厂方法加载服务提供商ResourceBundleProvider ，如果可用，使用ServiceLoader 。 服务类型由<package name> + ".spi." + <simple name> + "Provider"指定。 例如，如果基本名称为“ com.example.app.MyResources ”，则服务类型为com.example.app.spi.MyResourcesProvider 。

    在命名模块中，给定基本名称的加载服务提供程序用于加载资源束。 如果没有服务提供商可用，或者如果没有一个服务提供者返回一个资源包，并且调用者模块没有自己的服务提供商，则getBundle工厂方法将搜索调用者模块中本地的可见资源束到调用者模块的类加载器。 本地模块搜索的资源束格式为“java.class”和“java.properties”。

    的ResourceBundle.Control

    ResourceBundle.Control类提供了getBundle工厂方法执行捆绑包加载过程所需的信息，该方法采用ResourceBundle.Control实例。 您可以实现自己的子类，以便启用非标准资源束格式，更改搜索策略或定义缓存参数。 有关详细信息，请参阅类别和getBundle工厂方法的说明。

    For the getBundle factory方法不需要ResourceBundle.Control实例，其default behavior的资源束加载可以通过自定义修改ResourceBundleControlProvider实现。 如果任何一个提供商为给定的基础名称提供了一个ResourceBundle.Control ， 那么将使用ResourceBundle.Control而不是默认的ResourceBundle.Control 。 如果有多个服务提供商支持相同的基本名称，则将使用从ServiceLoader返回的第一个。 命名模块将忽略自定义ResourceBundle.Control实现。

    缓存管理

    默认情况下， getBundle工厂方法创建的资源束实例被缓存，如果已经缓存，工厂方法返回相同的资源束实例多次。 getBundle客户端可以清除缓存，使用生存时间值管理缓存的资源包实例的生命周期，或指定不缓存资源束实例。 请参阅的描述getBundlefactory method ， clearCache ， ResourceBundle.Control.getTimeToLive ，并ResourceBundle.Control.needsReload了解详情。

    例

    以下是ResourceBundle子类MyResources一个非常简单的示例，它管理两个资源（对于大量资源，您可能会使用Map ）。 请注意，如果“父级” ResourceBundle处理具有相同值的相同键（如下面的okKey），则不需要提供值。
     // default (English language, United States)
 public class MyResources extends ResourceBundle {
     public Object handleGetObject(String key) {
         if (key.equals("okKey")) return "Ok";
         if (key.equals("cancelKey")) return "Cancel";
         return null;
     }

     public Enumeration<String> getKeys() {
         return Collections.enumeration(keySet());
     }

     // Overrides handleKeySet() so that the getKeys() implementation
     // can rely on the keySet() value.
     protected Set<String> handleKeySet() {
         return new HashSet<String>(Arrays.asList("okKey", "cancelKey"));
     }
 }

 // German language
 public class MyResources_de extends MyResources {
     public Object handleGetObject(String key) {
         // don't need okKey, since parent level handles it.
         if (key.equals("cancelKey")) return "Abbrechen";
         return null;
     }

     protected Set<String> handleKeySet() {
         return new HashSet<String>(Arrays.asList("cancelKey"));
     }
 }
    你不必限制自己使用一个ResourceBundle的家庭。 例如，你可以有异常的消息一组捆， ExceptionResources （ ExceptionResources_fr ， ExceptionResources_de ，...），以及一个用于小部件， WidgetResource （ WidgetResources_fr ， WidgetResources_de ，...）; 分解你喜欢的资源。
    从以下版本开始：
    1.1
    另请参见：
    ListResourceBundle ， PropertyResourceBundle ， MissingResourceException ， ResourceBundleProvider

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ResourceBundle.Control
      ResourceBundle.Control定义了在捆绑包加载过程中由 ResourceBundle.getBundle工厂方法调用的一组回调方法。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected ResourceBundle parent
      此捆绑包的父捆绑。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ResourceBundle​()
      唯一的构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static void clearCache​()
      从缓存中删除已由调用者模块加载的所有资源束。
      static void clearCache​(ClassLoader loader)
      从缓存中删除由给定的类加载器加载的所有资源束。
      boolean containsKey​(String key)
      确定 key是否包含在此 ResourceBundle或其父级包中。
      String getBaseBundleName​()
      如果已知，则返回此捆绑包的基本名称，如果未知，则返回 null 。
      static ResourceBundle getBundle​(String baseName)
      使用指定的基本名称，默认语言环境和调用者的类加载器获取资源包。
      static ResourceBundle getBundle​(String baseName, Module module)
      使用指定的基本名称和默认语言环境代替指定的模块获取资源包。
      static ResourceBundle getBundle​(String baseName, Locale locale)
      使用指定的基本名称和区域设置以及调用者的类加载器获取资源包。
      static ResourceBundle getBundle​(String baseName, Locale locale, ClassLoader loader)
      使用指定的基本名称，区域设置和类加载器获取资源包。
      static ResourceBundle getBundle​(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)
      使用指定的基本名称，目标语言环境，类加载器和控件返回资源包。
      static ResourceBundle getBundle​(String baseName, Locale targetLocale, Module module)
      使用指定的基本名称和区域设置代替指定的模块获取资源包。
      static ResourceBundle getBundle​(String baseName, Locale targetLocale, ResourceBundle.Control control)
      使用指定的基本名称，目标语言环境和控件以及调用者的类加载器返回资源包。
      static ResourceBundle getBundle​(String baseName, ResourceBundle.Control control)
      X- 2004545 CEEC X-
      abstract Enumeration<String> getKeys​()
      返回键的枚举。
      Locale getLocale​()
      返回此资源包的区域设置。
      Object getObject​(String key)
      从此资源包或其父项之一获取给定密钥的对象。
      String getString​(String key)
      从此资源束或其父项之一获取给定密钥的字符串。
      String[] getStringArray​(String key)
      从此资源包或其父项之一获取给定键的字符串数组。
      protected abstract Object handleGetObject​(String key)
      从此资源包获取给定键的对象。
      protected Set<String> handleKeySet​()
      返回一个 Set的键 只包含在这个 ResourceBundle 。
      Set<String> keySet​()
      返回 Set包含在此的所有键的 ResourceBundle及其父包。
      protected void setParent​(ResourceBundle parent)
      设置此捆绑包的父捆绑包。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • parent

        protected ResourceBundle parent
        此捆绑包的父捆绑。 当该包不包含特定资源时，将通过getObject搜索父包。

    • 构造方法详细信息

      • ResourceBundle

        public ResourceBundle​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getBaseBundleName

        public String getBaseBundleName​()
        如果已知，则返回此包的基本名称，如果未知，则返回null 。 如果不为空，那么这是在加载资源束时传递给ResourceBundle.getBundle(...)方法的baseName参数的值。
        结果
        资源束的基本名称，由 ResourceBundle.getBundle(...)方法提供和预期。
        从以下版本开始：
        1.8
        另请参见：
        getBundle(java.lang.String, java.util.Locale, java.lang.ClassLoader)

      • getString

        public final String getString​(String key)
        从此资源束或其父项之一获取给定密钥的字符串。 调用此方法相当于调用
        (String) getObject(key).
        参数
        key - 所需字符串的键
        结果
        给定键的字符串
        异常
        NullPointerException - 如果 key是 null
        MissingResourceException - 如果没有找到给定键的对象
        ClassCastException - 如果找到给定键的对象不是字符串

      • getStringArray

        public final String[] getStringArray​(String key)
        从此资源包或其父项之一获取给定键的字符串数组。 调用此方法相当于调用
        (String[]) getObject(key).
        参数
        key - 所需字符串数组的键
        结果
        给定键的字符串数组
        异常
        NullPointerException - 如果 key是 null
        MissingResourceException - 如果没有找到给定键的对象
        ClassCastException - 如果找到给定键的对象不是字符串数组

      • getObject

        public final Object getObject​(String key)
        从此资源包或其父项之一获取给定密钥的对象。 此方法首先尝试使用handleGetObject从此资源束获取对象。 如果不成功，并且父资源束不为空，则调用父级的getObject方法。 如果仍然不成功，它会抛出一个MissingResourceException。
        参数
        key - 所需对象的关键
        结果
        给定键的对象
        异常
        NullPointerException - 如果 key是 null
        MissingResourceException - 如果没有找到给定键的对象

      • getLocale

        public Locale getLocale​()
        返回此资源包的区域设置。 调用getBundle（）后，可以使用此方法来确定返回的资源束是否真的对应于所请求的区域设置，或者是后备。
        结果
        该资源包的区域设置

      • setParent

        protected void setParent​(ResourceBundle parent)
        设置此捆绑包的父捆绑包。 当该包不包含特定资源时，将通过getObject搜索父包。
        参数
        parent - 此捆绑包的父包。

      • getBundle

        public static final ResourceBundle getBundle​(String baseName)
        使用指定的基本名称，默认语言环境和调用者的类加载器获取资源包。 调用此方法相当于调用
        getBundle(baseName, Locale.getDefault(), this.getClass().getClassLoader()),
        除了getClassLoader()运行的安全权限为ResourceBundle 。 有关搜索和实例化策略的完整描述，请参阅getBundle 。
        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        结果
        给定基本名称和默认语言环境的资源包
        异常
        NullPointerException - 如果 baseName是 null
        MissingResourceException - 如果没有找到指定基本名称的资源束

      • getBundle

        public static final ResourceBundle getBundle​(String baseName,
                                             ResourceBundle.Control control)
        X- 2004545 CEEC X- 调用此方法相当于调用
          getBundle(baseName, Locale.getDefault(),
           this.getClass().getClassLoader(), control),
        除了getClassLoader()运行的安全权限为ResourceBundle 。 有关ResourceBundle.Control的资源包加载过程的完整说明，请参阅ResourceBundle.Control 。
        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        control - 为资源束加载过程提供信息的控件
        结果
        给定基本名称和默认语言环境的资源包
        异常
        NullPointerException - 如果 baseName或 control是 null
        MissingResourceException - 如果没有找到指定的基础名称的资源束
        IllegalArgumentException - 如果给定的 control不能正常执行（例如， control.getCandidateLocales返回null。）请注意，根据需要执行 control验证。
        UnsupportedOperationException - 如果在命名模块中调用此方法
        从以下版本开始：
        1.6

      • getBundle

        public static final ResourceBundle getBundle​(String baseName,
                                             Locale locale)
        使用指定的基本名称和区域设置以及调用者的类加载器获取资源包。 调用此方法相当于调用
        getBundle(baseName, locale, this.getClass().getClassLoader()),
        除了getClassLoader()的安全权限为ResourceBundle 。 有关搜索和实例化策略的完整描述，请参阅getBundle 。
        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        locale - 需要资源束的区域设置
        结果
        给定的基本名称和语言环境的资源包
        异常
        NullPointerException - 如果 baseName或 locale是 null
        MissingResourceException - 如果没有找到指定基本名称的资源束

      • getBundle

        public static ResourceBundle getBundle​(String baseName,
                                       Module module)
        使用指定的基本名称和默认语言环境代替指定的模块获取资源包。 这个方法相当于调用
        getBundle(baseName, Locale.getDefault(), module)

        命名模块中的资源束可能被封装。 当资源包从提供程序加载时，调用者模块必须在其模块描述符中具有适当的uses子句，以声明该模块使用<package name> + ".spi." + <simple name> + "Provider"实现。 否则，它将加载给定模块中本地的资源束，或对给定模块的类加载器可见的资源束（有关详细信息，请参阅Resource Bundles in Named Modules部分）。 当从指定的模块加载资源束时，会受到Module.getResourceAsStream指定的封装规则的约束 。

        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        module - 搜索资源束的模块
        结果
        给定基本名称和默认语言环境的资源包
        异常
        NullPointerException - 如果 baseName或 module是 null
        SecurityException - 如果安全管理器存在，并且调用方不是指定的模块，并且没有 RuntimePermission("getClassLoader")
        MissingResourceException - 如果在指定的模块中找不到指定基本名称的资源束
        从以下版本开始：
        9
        另请参见：
        ResourceBundleProvider

      • getBundle

        public static ResourceBundle getBundle​(String baseName,
                                       Locale targetLocale,
                                       Module module)
        使用指定的基本名称和区域设置代替指定的模块获取资源包。

        命名模块中的资源束可能被封装。 当资源束从提供程序加载时，调用者模块必须在其模块描述符中具有适当的uses子句，以声明该模块使用<package name> + ".spi." + <simple name> + "Provider"实现。 否则，它将加载给定模块中本地的资源束，或者给定模块的类加载器可见的资源束（有关详细信息，请参阅Resource Bundles in Named Modules部分）。 当资源束从指定的模块加载时，它受到Module.getResourceAsStream指定的封装规则的约束 。

        如果给定的module是一个未命名的模块，那么此方法相当于调用getBundle(baseName, targetLocale, module.getClassLoader()来加载给定未命名模块的类加载器可见的资源束。 如果存在，自定义的ResourceBundleControlProvider实现将仅在指定的模块是未命名的模块时被调用。

        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        targetLocale - 需要资源束的区域设置
        module - 搜索资源束的模块
        结果
        模块中给定基本名称和区域设置的资源束
        异常
        NullPointerException -如果 baseName ， targetLocale ，或 module为 null
        SecurityException - 如果安全管理器存在，并且调用方不是指定的模块，并且没有 RuntimePermission("getClassLoader")
        MissingResourceException - 如果在指定的 module找不到指定的基本名称和区域设置的资源束
        从以下版本开始：
        9

      • getBundle

        public static final ResourceBundle getBundle​(String baseName,
                                             Locale targetLocale,
                                             ResourceBundle.Control control)
        使用指定的基本名称，目标语言环境和控件以及调用者的类加载器返回资源包。 调用此方法相当于调用
          getBundle(baseName, targetLocale, this.getClass().getClassLoader(),
           control),
        除了getClassLoader()用的安全权限运行ResourceBundle 。 有关ResourceBundle.Control的资源包加载过程的完整说明，请参阅ResourceBundle.Control 。
        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        targetLocale - 需要资源束的区域设置
        control - 为资源束加载过程提供信息的控件
        结果
        一个给定基本名称的资源束，一个 Locale在 locales
        异常
        NullPointerException -如果 baseName ， locales或者 control为 null
        MissingResourceException - 如果没有找到任何 locales指定的基本名称的资源束。
        IllegalArgumentException - 如果给定的 control无法正常执行（例如， control.getCandidateLocales返回null。）请注意，根据需要执行 control验证。
        UnsupportedOperationException - 如果在命名模块中调用此方法
        从以下版本开始：
        1.6

      • getBundle

        public static ResourceBundle getBundle​(String baseName,
                                       Locale locale,
                                       ClassLoader loader)
        使用指定的基本名称，区域设置和类加载器获取资源包。

        该方法的行为与调用getBundle(String, Locale, ClassLoader, Control)传递默认实例ResourceBundle.Control相同，除非另有ResourceBundle.Control与ResourceBundleControlProvider SPI一起提供。 请参阅modifying the default behavior的说明。

        The following describes the default behavior 。

        命名模块中的资源束对该模块是私有的。 如果调用者在命名模块中，则该方法将从服务提供商ResourceBundleProvider找到资源束。 否则，它将加载给定的可见的资源束loader （有关详细信息，请参阅Resource Bundles in Named Modules部分）。 如果调用者在命名模块中，给定的loader与调用者的类加载器不同，或者如果调用者不在命名模块中，则此方法将不会从命名模块中找到资源束。

        getBundle使用基本名称，指定的区域设置和默认语言环境（从Locale.getDefault获得）生成candidate bundle names的序列。 如果指定的语言环境的语言，脚本，国家和变体都是空字符串，则基本名称是唯一的候选包名称。 否则，从指定的区域设置（语言，脚本，国家和变体）的属性值生成候选语言环境列表，并附加到基本名称。 通常，这将如下所示：

          baseName + "_" + language + "_" + script + "_" + country + "_" + variant
     baseName + "_" + language + "_" + script + "_" + country
     baseName + "_" + language + "_" + script
     baseName + "_" + language + "_" + country + "_" + variant
     baseName + "_" + language + "_" + country
     baseName + "_" + language

        最后一个组件是一个空字符串的候选组名称，以及下划线。 例如，如果country是一个空字符串，那么上面的第二个和第五个候选组名将被省略。 此外，如果脚本是空字符串，则省略包含脚本的候选名称。 例如，具有语言“de”和变体“JAVA”的区域设置将产生下面具有基本名称“MyResource”的候选名称。

          MyResource_de__JAVA
     MyResource_de
        在变体包含一个或多个下划线（'_'）的情况下，通过截断最后一个下划线及其后面的部分生成的捆绑名称序列将插入到具有原始变体的候选包名称之后。 例如，对于具有语言“en”的语言环境，脚本“Latn，country”US“和变体”WINDOWS_VISTA“以及组合名称”MyResource“，将生成下面的候选组名称列表：
          MyResource_en_Latn_US_WINDOWS_VISTA
 MyResource_en_Latn_US_WINDOWS
 MyResource_en_Latn_US
 MyResource_en_Latn
 MyResource_en_US_WINDOWS_VISTA
 MyResource_en_US_WINDOWS
 MyResource_en_US
 MyResource_en
        Note: For some Locales, the list of candidate bundle names contains extra names, or the order of bundle names is slightly modified. See the description of the default implementation of getCandidateLocales for details.

        getBundle然后迭代候选包名称以找到可以实例化实际资源束的第一个。 它使用默认控件' getFormats方法，它为每个生成的名称生成两个捆绑名称，第一个是一个类名称，另一个是属性文件名。 对于每个候选包名称，它尝试创建一个资源包：

        • 首先，它尝试使用生成的类名加载类。 如果可以使用指定的类加载器找到并加载这样的类，则与ResourceBundle兼容的分配是可以从ResourceBundle访问的，并且可以被实例化， getBundle创建getBundle的新实例并将其用作结果资源束 。
        • 否则， getBundle尝试使用生成的属性文件名定位属性资源文件。 它通过替换所有“”来从候选组名称生成一个路径名。 带有“/”字符并附加字符串“.properties”的字符。 它尝试使用这个名称使用ClassLoader.getResource找到一个“资源”。 （请注意， getResource意义上的“资源”与资源束的内容无关，它只是一个数据容器，例如文件。）如果找到“资源”，则会尝试创建一个新的PropertyResourceBundle实例从其内容。 如果成功，此实例将成为结果资源包 。

        这将一直持续到结果资源束被实例化或者候选包名称列表用尽。 如果没有找到匹配的资源束，则调用默认控件的getFallbackLocale方法，返回当前的默认语言环境。 使用该语言环境生成新的候选语言环境名称序列，并重新搜索，如上所述。

        如果仍然没有找到结果包，则单独查看基本名称。 如果仍然失败，则抛出MissingResourceException 。

        Once a result resource bundle has been found, its parent chain is instantiated 。 如果结果包已经有一个父（可能是因为它从一个缓存返回），那么链就完成了。

        否则， getBundle将检查在生成结果资源束的通过期间使用的候选区域设置列表的剩余部分。 （如前所述，省略最终组件为空字符串的候选bundle名称）。当涉及到候选列表的末尾时，它将尝试使用纯包名称。 使用每个候选包名称，它尝试实例化一个资源包（首先查找一个类，然后是一个属性文件，如上所述）。

        无论何时成功，它将使用新的资源束调用先前实例化的资源束的setParent方法。 这一直持续到名称列表用尽，或者当前的包已经有一个非空的父项。

        一旦父链完成，则返回捆绑包。

        注意： getBundle缓存实例化的资源束，并可能多次返回相同的资源束实例。

        注意： baseName参数应该是一个完全限定的类名。 然而，为了与早期版本兼容，Sun的Java SE运行时环境不会验证这一点，因此可以通过指定路径名（使用“/”）而不是完全限定的类名称（使用“。”来访问PropertyResourceBundle ）。 ）。

        Example:

        提供以下类和属性文件：

          MyResources.class
     MyResources.properties
     MyResources_fr.properties
     MyResources_fr_CH.class
     MyResources_fr_CH.properties
     MyResources_en.properties
     MyResources_es_ES.class
        所有文件的内容都是有效的（即“.class”文件的公共非抽象子类为ResourceBundle ，语法上正确的“.properties”文件）。 默认语言环境为Locale("en", "GB") 。

        使用下面的语言环境参数调用getBundle将实例化资源束，如下所示：

        getBundle() locale to resource bundle mapping Locale("fr", "CH") MyResources_fr_CH.class, parent MyResources_fr.properties, parent MyResources.class Locale("fr", "FR") MyResources_fr.properties, parent MyResources.class Locale("de", "DE") MyResources_en.properties, parent MyResources.class Locale("en", "US") MyResources_en.properties, parent MyResources.class Locale("es", "ES") MyResources_es_ES.class, parent MyResources.class

        文件MyResources_fr_CH.properties永远不会被使用，因为它被MyResources_fr_CH.class隐藏。 同样，MyResources.properties也被MyResources.class隐藏。

        API Note:
        如果调用者模块是一个命名模块，给定的loader是调用者模块的类加载器，则此方法相当于getBundle(baseName, locale) ; 否则，它将不会从命名模块找到资源束。 使用getBundle(String, Locale, Module)代替在特定模块上加载资源束。
        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        locale - 需要资源束的区域设置
        loader - 从中加载资源束的类加载器
        结果
        给定的基本名称和语言环境的资源包
        异常
        NullPointerException -如果 baseName ， locale ，或 loader为 null
        MissingResourceException - 如果没有找到指定的基本名称的资源束
        从以下版本开始：
        1.2

      • getBundle

        public static ResourceBundle getBundle​(String baseName,
                                       Locale targetLocale,
                                       ClassLoader loader,
                                       ResourceBundle.Control control)
        使用指定的基本名称，目标语言环境，类加载器和控件返回资源包。 与getBundlefactory methods with no controlargument不同，给定的control指定了如何定位和实例化资源束。 在概念上，具有给定的control的捆绑包加载过程在以下步骤中执行。
        1. 此工厂方法查找该指定的高速缓存中的资源包baseName ， targetLocale和loader 。 如果在缓存中找到请求的资源束实例，并且实例及其所有父实例的生存周期尚未过期，则将该实例返回给调用者。 否则，此工厂方法继续下面的加载过程。
        2. 调用control.getFormats方法来获取资源束格式来生成包或资源名称。 字符串"java.class"和"java.properties"指定基于类和基于property的资源束。 以"java."开头的其他字符串保留用于将来的扩展名，不能用于应用程序定义的格式。 其他字符串指定应用程序定义格式。
        3. 使用目标区域设置调用control.getCandidateLocales方法以获取搜索资源束的候选Locale的列表。
        4. 调用control.newBundle方法来实例化基本包名称，候选区域设置和格式的ResourceBundle 。 （请参阅下面的缓存查找的注释。）这一步遍历候选语言环境和格式的所有组合，直到newBundle方法返回一个ResourceBundle实例或迭代已经耗尽了所有组合。 例如，如果候选区域设置是Locale("de", "DE") ， Locale("de")和Locale("")和格式是"java.class"和"java.properties" ，再下面是语言环境格式组合的序列，以用于调用control.newBundle 。 locale-format combinations for newBundle Locale
          format
          Locale("de", "DE")
          java.class
          Locale("de", "DE") java.properties
          Locale("de") java.class Locale("de") java.properties Locale("")
          java.class Locale("") java.properties
        5. 如果上一步找不到资源束，请继续执行步骤6.如果发现捆绑包是基本捆绑包（ Locale("")的捆绑包），候选区域设置列表仅包含Locale("") ，则将捆绑包返回给主叫方。 如果发现一个捆绑包是基础包，但是候选区域设置列表中包含Locale（“”）以外的区域设置，则将该包置于保持状态，然后继续执行步骤6.如果发现一个bundle不是基础包，进入步骤7。
        6. 调用control.getFallbackLocale方法来获取后备区域设置（替代当前目标区域设置）以尝试进一步查找资源束。 如果该方法返回非空区域设置，它将成为下一个目标区域设置，加载过程从步骤3开始。否则，如果在前一步骤5中找到并保留基础包，则返回给调用者现在。 否则，将抛出MissingResourceException异常。
        7. 在这一点上，我们发现一个资源束不是基础包。 如果此捆绑包在其实例化期间设置其父级，则将其返回给调用者。 否则，其parent chain将根据找到的候选语言环境列表进行实例化。 最后，该包返回给调用者。

        在上述资源包加载过程中，此工厂方法在调用control.newBundle方法之前查找缓存。 如果高速缓存中发现的资源束的生存周期已过期，则工厂方法将调用control.needsReload方法来确定资源束是否需要重新加载。 如果需要重新加载，工厂方法调用control.newBundle重新加载资源包。 如果control.newBundle返回null ，则工厂方法将虚拟资源束放在缓存中作为不存在的资源束的标记，以避免后续请求的查找开销。 这种虚拟资源束处于与control所指定的相同的到期控制下。

        默认情况下，加载的所有资源束都被缓存。 详情请参阅control.getTimeToLive 。

        以下是使用默认的ResourceBundle.Control实现的捆绑包加载过程的ResourceBundle.Control 。

        条件：

        • 基本名称： foo.bar.Messages
        • 要求Locale ： Locale.ITALY
        • 默认值Locale ： Locale.FRENCH
        • 可用的资源包： foo/bar/Messages_fr.properties和foo/bar/Messages.properties

        首先， getBundle按照以下顺序尝试加载资源束。

        • foo.bar.Messages_it_IT
        • 档案foo/bar/Messages_it_IT.properties
        • foo.bar.Messages_it
        • 档案foo/bar/Messages_it.properties
        • foo.bar.Messages
        • 文件foo/bar/Messages.properties

        此时， getBundle发现foo/bar/Messages.properties ，由于它是基本捆绑，因此被搁置。 getBundle致电control.getFallbackLocale("foo.bar.Messages", Locale.ITALY) ，返回Locale.FRENCH 。 接下来， getBundle尝试按照以下顺序加载捆绑包。

        • foo.bar.Messages_fr
        • 档案foo/bar/Messages_fr.properties
        • foo.bar.Messages
        • 档案foo/bar/Messages.properties

        getBundle查找foo/bar/Messages_fr.properties并创建一个ResourceBundle实例。 然后， getBundle从候选语言环境列表中设置其父链。 列表中只找到foo/bar/Messages.properties ，而getBundle创建一个ResourceBundle实例，成为ResourceBundle实例的父foo/bar/Messages_fr.properties 。

        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        targetLocale - 需要资源束的区域设置
        loader - 从中加载资源束的类加载器
        control - 为资源束加载过程提供信息的控件
        结果
        给定的基本名称和语言环境的资源包
        异常
        NullPointerException -如果 baseName ， targetLocale ， loader ，或 control为 null
        MissingResourceException - 如果没有找到指定的基础名称的资源束
        IllegalArgumentException - 如果给定的 control不正确执行（例如， control.getCandidateLocales返回null。）请注意，根据需要执行 control验证。
        UnsupportedOperationException - 如果在命名模块中调用此方法
        从以下版本开始：
        1.6

      • clearCache

        public static final void clearCache​()
        从缓存中删除已由调用者模块加载的所有资源束。
        从以下版本开始：
        1.6
        另请参见：
        ResourceBundle.Control.getTimeToLive(String,Locale)

      • clearCache

        public static final void clearCache​(ClassLoader loader)
        从缓存中删除由给定的类加载器加载的所有资源束。
        参数
        loader - 类加载器
        异常
        NullPointerException - 如果 loader为空
        从以下版本开始：
        1.6
        另请参见：
        ResourceBundle.Control.getTimeToLive(String,Locale)

      • handleGetObject

        protected abstract Object handleGetObject​(String key)
        从此资源包获取给定键的对象。 如果此资源束不包含给定键的对象，则返回null。
        参数
        key - 所需对象的关键
        结果
        给定键的对象，或null
        异常
        NullPointerException - 如果 key是 null

      • getKeys

        public abstract Enumeration<String> getKeys​()
        返回键的枚举。
        结果
        该 ResourceBundle及其父级包含的密钥中包含 Enumeration个密钥。

      • containsKey

        public boolean containsKey​(String key)
        确定给定的 key是否包含在此 ResourceBundle或其父包中。
        参数
        key - 资源 key
        结果
        true如果给定的key包含在这个ResourceBundle或其父包中; false否则。
        异常
        NullPointerException - 如果 key是 null
        从以下版本开始：
        1.6

      • keySet

        public Set<String> keySet​()
        返回 Set包含在此的所有键的 ResourceBundle及其父包。
        结果
        一个 Set包含在此的所有键的 ResourceBundle及其父包。
        从以下版本开始：
        1.6

      • handleKeySet

        protected Set<String> handleKeySet​()
        返回一个Set的键只包含在这个ResourceBundle 。

        默认实现返回一个Set由返回键getKeys除了为其的那些方法handleGetObject方法返回null 。 一旦创建了Set ，该值保留在此ResourceBundle中，以避免在后续调用中产生相同的Set 。 子类可以覆盖此方法以更快的处理。

        结果
        一个 Set的键只包含在这个 ResourceBundle
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ResourceBundle.Control (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class ResourceBundle.Control

  • java.lang.Object
    • java.util.ResourceBundle.Control
  • Enclosing class:
    ResourceBundle

    public static class ResourceBundle.Control
extends Object
    ResourceBundle.Control定义了在捆绑包加载过程中由ResourceBundle.getBundle工厂方法调用的一组回调方法。 换句话说， ResourceBundle.Control与加载资源束的工厂方法协同工作。 回调方法的默认实现提供了出厂方法执行default behavior所需的信息。 Note that this class is not supported in named modules.

    除了回调方法之外， toBundleName和toResourceName方法的定义主要是为了方便实现回调方法。 但是，可以覆盖toBundleName方法，以在组织和封装本地化资源中提供不同的约定。 toResourceName方法是final以避免使用错误的资源和类名称分隔符。

    两个工厂方法， getControl(List)和getNoFallbackControl(List) ，提供ResourceBundle.Control实例，实现默认捆绑包加载过程的常见变体。

    在返回的格式getFormats种由返回的方法和候选语言环境getCandidateLocales方法必须全部一致ResourceBundle.getBundle调用了同样的基本包。 否则， ResourceBundle.getBundle方法可能会返回意外的捆绑包。 例如，如果getFormats方法仅对"java.class"的第一次调用ResourceBundle.getBundle "java.properties" ，而第二次调用仅"java.properties" ，则第二次调用将返回在第一次调用期间已被缓存的基于类的一个。

    一个ResourceBundle.Control实例必须是线程安全的，如果它被多个线程同时使用。 ResourceBundle.getBundle不同步调用ResourceBundle.Control方法。 这些方法的默认实现是线程安全的。

    应用程序可以指定由getControl工厂方法返回的ResourceBundle.Control实例，或从ResourceBundle.Control的子类创建，以自定义捆绑包加载过程。 以下是更改默认捆绑包加载过程的示例。

    实施例1

    以下代码让ResourceBundle.getBundle只查找基于属性的资源。

      import java.util.*;
 import static java.util.ResourceBundle.Control.*;
 ...
 ResourceBundle bundle =
   ResourceBundle.getBundle("MyResources", new Locale("fr", "CH"),
                            ResourceBundle.Control.getControl(FORMAT_PROPERTIES));
    鉴于example在ResourceBundle.getBundle描述中的资源束，此ResourceBundle.getBundle调用负载MyResources_fr_CH.properties ，其父为MyResources_fr.properties ，其父为MyResources.properties 。 （ MyResources_fr_CH.properties不隐藏，但是MyResources_fr_CH.class是。）

    实施例2

    以下是使用Properties.loadFromXML加载基于XML的软件包的示例 。

      ResourceBundle rb = ResourceBundle.getBundle("Messages",
     new ResourceBundle.Control() {
         public List<String> getFormats(String baseName) {
             if (baseName == null)
                 throw new NullPointerException();
             return Arrays.asList("xml");
         }
         public ResourceBundle newBundle(String baseName,
                                         Locale locale,
                                         String format,
                                         ClassLoader loader,
                                         boolean reload)
                          throws IllegalAccessException,
                                 InstantiationException,
                                 IOException {
             if (baseName == null || locale == null
                   || format == null || loader == null)
                 throw new NullPointerException();
             ResourceBundle bundle = null;
             if (format.equals("xml")) {
                 String bundleName = toBundleName(baseName, locale);
                 String resourceName = toResourceName(bundleName, format);
                 InputStream stream = null;
                 if (reload) {
                     URL url = loader.getResource(resourceName);
                     if (url != null) {
                         URLConnection connection = url.openConnection();
                         if (connection != null) {
                             // Disable caches to get fresh data for
                             // reloading.
                             connection.setUseCaches(false);
                             stream = connection.getInputStream();
                         }
                     }
                 } else {
                     stream = loader.getResourceAsStream(resourceName);
                 }
                 if (stream != null) {
                     BufferedInputStream bis = new BufferedInputStream(stream);
                     bundle = new XMLResourceBundle(bis);
                     bis.close();
                 }
             }
             return bundle;
         }
     });

 ...

 private static class XMLResourceBundle extends ResourceBundle {
     private Properties props;
     XMLResourceBundle(InputStream stream) throws IOException {
         props = new Properties();
         props.loadFromXML(stream);
     }
     protected Object handleGetObject(String key) {
         return props.getProperty(key);
     }
     public Enumeration<String> getKeys() {
         ...
     }
 }
    API Note:
    ResourceBundle.Control is not supported in named modules.如果在命名模块中调用了ResourceBundle.Control的ResourceBundle.getBundle方法，则该方法将抛出一个UnsupportedOperationException 。 任何ResourceBundleControlProvider的服务提供商都将在命名模块中被忽略。
    从以下版本开始：
    1.6
    另请参见：
    ResourceBundleProvider

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static List<String> FORMAT_CLASS
      类别 List包含 "java.class" 。
      static List<String> FORMAT_DEFAULT
      默认格式为 List ，其中包含字符串 "java.class"和 "java.properties" ，按此顺序。
      static List<String> FORMAT_PROPERTIES
      属性格式 List包含 "java.properties" 。
      static long TTL_DONT_CACHE
      不缓存加载的资源束实例的生存时间常数。
      static long TTL_NO_EXPIRATION_CONTROL
      用于禁用高速缓存中加载的资源束实例的到期控制的生存时间常数。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Control​()
      唯一的构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      List<Locale> getCandidateLocales​(String baseName, Locale locale)
      返回 List的 Locale作为 baseName和 locale候选地区。
      static ResourceBundle.Control getControl​(List<String> formats)
      返回一个 ResourceBundle.Control ，其中 getFormats方法返回指定的 formats 。
      Locale getFallbackLocale​(String baseName, Locale locale)
      返回一个 Locale作为后备区域设置，用于通过 ResourceBundle.getBundle工厂方法进一步查找资源。
      List<String> getFormats​(String baseName)
      返回 List的 String其中包含用于为给定的 baseName加载资源束的 baseName 。
      static ResourceBundle.Control getNoFallbackControl​(List<String> formats)
      返回 ResourceBundle.Control其中 getFormats方法返回指定 formats和 getFallbackLocale方法返回 null 。
      long getTimeToLive​(String baseName, Locale locale)
      返回此 ResourceBundle.Control下加载的资源束的生存时间（TTL）值。
      boolean needsReload​(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime)
      根据 loadTime给出的加载时间或其他一些条件，确定高速缓存中的过期 bundle是否需要重新加载。
      ResourceBundle newBundle​(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
      为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。
      String toBundleName​(String baseName, Locale locale)
      将给定的 baseName和 locale转换为包名称。
      String toResourceName​(String bundleName, String suffix)
      将 bundleName转换为 ClassLoader.getResource方法所需的 格式 ，替换所有出现的 '.'

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FORMAT_DEFAULT

        public static final List<String> FORMAT_DEFAULT
        默认格式为List ，其中包含字符串"java.class"和"java.properties" ，按此顺序。 这List是不可修改的。
        另请参见：
        getFormats(String)

      • FORMAT_CLASS

        public static final List<String> FORMAT_CLASS
        类别List包含"java.class" 。 这个List是不可修改的。
        另请参见：
        getFormats(String)

      • FORMAT_PROPERTIES

        public static final List<String> FORMAT_PROPERTIES
        属性格式List包含"java.properties" 。 这个List是不可修改的。
        另请参见：
        getFormats(String)

      • TTL_DONT_CACHE

        public static final long TTL_DONT_CACHE
        不缓存加载的资源束实例的生存时间常数。
        另请参见：
        getTimeToLive(String, Locale) ， Constant Field Values

      • TTL_NO_EXPIRATION_CONTROL

        public static final long TTL_NO_EXPIRATION_CONTROL
        用于禁用高速缓存中加载的资源束实例的到期控制的生存时间常数。
        另请参见：
        getTimeToLive(String, Locale) ， Constant Field Values

    • 构造方法详细信息

      • Control

        protected Control​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getControl

        public static final ResourceBundle.Control getControl​(List<String> formats)
        返回一个ResourceBundle.Control ，其中getFormats方法返回指定的formats 。 所述formats必须等于之一FORMAT_PROPERTIES ， FORMAT_CLASS或FORMAT_DEFAULT 。 ResourceBundle.Control这个方法返回的实例是单例和线程安全的。

        指定FORMAT_DEFAULT等效于实例化ResourceBundle.Control类，但该方法返回单例。

        参数
        formats - ResourceBundle.Control.getFormats方法返回的格式
        结果
        一个 ResourceBundle.Control支持指定的 formats
        异常
        NullPointerException - 如果 formats是 null
        IllegalArgumentException - 如果 formats未知

      • getNoFallbackControl

        public static final ResourceBundle.Control getNoFallbackControl​(List<String> formats)
        返回一个ResourceBundle.Control ，其中getFormats方法返回指定的formats ，而getFallbackLocale方法返回null 。 所述formats必须等于之一FORMAT_PROPERTIES ， FORMAT_CLASS或FORMAT_DEFAULT 。 ResourceBundle.Control这个方法返回的实例是单例和线程安全的。
        参数
        formats - ResourceBundle.Control.getFormats方法返回的格式
        结果
        一个 ResourceBundle.Control支持指定的 formats ，没有后退 Locale支持
        异常
        NullPointerException - 如果 formats是 null
        IllegalArgumentException - 如果 formats未知

      • getFormats

        public List<String> getFormats​(String baseName)
        返回List的String s，其中包含用于为给定的baseName加载资源束的baseName 。 ResourceBundle.getBundle工厂方法尝试使用列表中指定的顺序加载格式的资源束。 此方法返回的列表必须至少有一个String 。 预定义的格式是"java.class"对于基于类的资源包和"java.properties"为properties-based分的。 以"java."开头的字符串保留用于将来的扩展，不能由应用程序定义的格式使用。

        返回不可变（不可修改） List 。 但是，返回List不得它已被退回后，突变getFormats 。

        默认实现返回FORMAT_DEFAULT，以便ResourceBundle.getBundle工厂方法查找基于类的资源束，然后查找基于属性的资源束。

        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        结果
        一个包含 List的 String包含用于加载资源束的格式。
        异常
        NullPointerException - 如果 baseName为空
        另请参见：
        FORMAT_DEFAULT ， FORMAT_CLASS ， FORMAT_PROPERTIES

      • getCandidateLocales

        public List<Locale> getCandidateLocales​(String baseName,
                                        Locale locale)
        返回List的Locale作为baseName和locale候选地区。 每次工厂方法尝试找到目标的资源束时，这种方法由ResourceBundle.getBundle工厂方法调用Locale 。

        候选语言环境的序列也对应于运行时资源查找路径（也称为父链 ），如果候选语言环境存在相应的资源束，并且父节点未由加载的资源束本身定义。 列表中的最后一个元素必须是root locale，如果希望将基础包作为父链的终端。

        如果给定的区域设置为等于Locale.ROOT （根区域），一个List只包含根Locale必须返回。 在这种情况下， ResourceBundle.getBundle工厂方法仅加载基础包作为生成的资源包。

        不要求退回一个不可改变的（不可修改的） List 。 但是，返回List不得它已被退回后，突变getCandidateLocales 。

        默认实现使用下面描述的规则返回一个List其中包含Locale 。 在下面的描述中， L ， S ， C和V分别表示非空语言，脚本，国家和变体。 例如，[ L ， C ]代表一个Locale ，它只对语言和国家有非空值。 形式L （“xx”）表示（非空）语言值为“xx”。 对于所有情况，其最终成分值为空字符串的Locale s被省略。

        1. 对于具有空脚本值的输入Locale ，通过省略最终组件逐个追加候选人Locale ，如下所示：
          • [ L ， C ， V ]
          • [ L ， C ]
          • [ L ]
          • Locale.ROOT
        2. 对于具有非空脚本值的输入Locale ，通过省略最终组件直到语言来追加候选人Locale s，然后追加从Locale生成的Locale国家和变式恢复：
          • [ L ， S ， C ， V ]
          • [ L ， S ， C ]
          • [ L ， S ]
          • [ L ， C ， V ]
          • [ L ， C ]
          • [ L ]
          • Locale.ROOT
        3. 对于具有由下划线分隔的多个子标签组成的变体值的输入Locale ，通过逐个省略变体子标记来生成候选人Locale ，然后在每次出现Locale s之后插入其原始列表中的完整变体值。 例如，如果变体由两个子标签V1和V2组成 ：
          • [ L ， S ， C ， V1 ， V2 ]
          • [ L ， S ， C ， V1 ]
          • [ L ， S ， C ]
          • [ L ， S ]
          • [ L ， C ， V1 ， V2 ]
          • [ L ， C ， V1 ]
          • [ L ， C ]
          • [ L ]
          • Locale.ROOT
        4. 中国特殊情况。 输入Locale具有语言“zh”（中文）和空字符值时，可能会根据国家/地区提供“汉斯”（简体）或“汉特”（繁体）。 当国家是“CN”（中国）或“SG”（新加坡）时，提供“汉斯”。 当国家是“HK”（中国香港特别行政区）时，提供“MO”（中国澳门特别行政区）或“TW”（台湾）“Hant”。 对于所有其他国家或国家/地区为空时，不提供脚本。 例如，对于Locale("zh", "CN") ，候选人名单将是：
          • [ L （“zh”）， S （“Hans”）， C （“CN”）]
          • [ L （“zh”）， S （“汉斯”）]
          • [ L （“zh”）， C （“CN”）]
          • [ L （“zh”）]
          • Locale.ROOT
          对于Locale("zh", "TW") ，候选人名单将是：
          • [ L （“zh”）， S （“Hant”）， C （“TW”）]
          • [ L （“zh”）， S （“Hant”）]
          • [ L （“zh”）， C （“TW”）]
          • [ L （“zh”）]
          • Locale.ROOT
        5. 挪威特殊情况。 Locale("no", "NO", "NY")和Locale("nn", "NO")代表挪威尼诺斯克。 当语言环境的语言为“nn”时，标准候选列表生成最多为[ L （“nn”）]，然后添加以下候选：
          • [ L （“否”）， C （“NO”）， V （“NY”）]
          • [ L （“否”）， C （“否”）]
          • [ L （“否”）]
          • Locale.ROOT
          如果语言环境正好是Locale("no", "NO", "NY") ，则首先将其转换为Locale("nn", "NO") ，然后按照上述步骤进行操作。

          此外，Java将“no”语言视为NorwegianBokmÃ¥l“nb”的同义词。 除了单个案例Locale("no", "NO", "NY") （上面的处理），当输入Locale具有语言“否”或“nb”时，具有语言代码“否”和“nb”的候选人Locale s被交织，首先使用所请求的语言，然后使用其代名词。 例如， Locale("nb", "NO", "POSIX")生成以下候选列表：

          • [ L （“nb”）， C （“NO”）， V （“POSIX”）]
          • [ L （“否”）， C （“否”）， V （“POSIX”）]
          • [ L （“nb”）， C （“NO”）]
          • [ L （“否”）， C （“否”）]
          • [ L （“nb”）]
          • [ L （“否”）]
          • Locale.ROOT
          Locale("no", "NO", "POSIX")将生成相同的列表，除了具有“否”的区域设置将出现在具有“nb”的相应语言环境之前。

        默认实现使用一个ArrayList ，该替换实现可能会在将其返回给调用者之前进行修改。 但是，一个子类在getCandidateLocales返回后不能修改它。

        例如，如果给定的baseName是“消息”，给定的locale是Locale("ja", "", "XX") ，则List的Locale s：

          Locale("ja", "", "XX")
     Locale("ja")
     Locale.ROOT
        被退回 并且如果找到“ja”和“” Locale的资源束，则运行时资源查找路径（父链）是：
           Messages_ja -> Messages
        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        locale - 需要资源束的区域设置
        结果
        一个 List候选人 Locale s给定的 locale
        异常
        NullPointerException - 如果 baseName或 locale是 null

      • getFallbackLocale

        public Locale getFallbackLocale​(String baseName,
                                Locale locale)
        返回一个Locale ，以作为后备区域设置，以进一步的资源束搜索通过ResourceBundle.getBundle工厂方法。 每次当没有为baseName和locale找到生成的资源束时，从工厂方法调用此方法，其中locale是ResourceBundle.getBundle的参数或此方法返回的以前的后备区域设置。

        如果不需要进一步的后备搜索，该方法返回null 。

        如果给定的locale不是默认的，默认实现将返回default Locale 。 否则返回null 。

        参数
        baseName - 资源包的基本名称， ResourceBundle.getBundle无法找到任何资源束（基本包除外）的完全限定类名称，
        locale - Locale ，其中 ResourceBundle.getBundle无法找到任何资源束（基本包除外）
        结果
        一个 Locale用于回退搜索，或 null如果没有进一步的回退搜索是期望的。
        异常
        NullPointerException - 如果 baseName或 locale是 null

      • newBundle

        public ResourceBundle newBundle​(String baseName,
                                Locale locale,
                                String format,
                                ClassLoader loader,
                                boolean reload)
                         throws IllegalAccessException,
                                InstantiationException,
                                IOException
        为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。 如果给定参数没有可用的资源束，此方法返回null 。 如果资源束由于意外错误而无法实例化，则必须通过抛出Error或异常来报告错误，而不是简单地返回null 。

        如果reload标志为true ，则表示此方法正在调用，因为先前加载的资源包已过期。

        实现要求：
        命名模块中的资源束符合Module.getResourceAsStream规定的封装规则。 当与资源束对应的资源文件的包无条件打开时，可以访问给定类加载器可见的命名模块中的资源束。

        默认实现如下实例化一个ResourceBundle 。

        • 捆绑名称是通过调用toBundleName(baseName, locale)获得的。
        • 如果format是"java.class" ，则由包名称指定的Class将加载给定的类加载器。 如果找到并可访问Class ，则ResourceBundle被实例化。 如果bundle类文件的包无条件地打开，则可以访问资源包; 否则，将抛出IllegalAccessException 。 请注意，在此默认实现中加载基于类的资源束时， reload标志将被忽略。
        • 如果format是"java.properties" ，则调用toResourceName(bundlename, "properties")获取资源名称。 如果reload是true ， 则会调用load.getResource获取一个URL来创建一个URLConnection 。 这个URLConnection用于disable the caches的底层资源加载层，并且用于get an InputStream 。 否则， loader.getResourceAsStream被称为获得一个InputStream 。 然后， PropertyResourceBundle用InputStream 。
        • 如果format既不是"java.class"也不是"java.properties" ，则抛出一个IllegalArgumentException 。
        参数
        baseName - 资源包的基础包名称，一个完全限定的类名
        locale - 资源束应实例化的区域设置
        format - 要加载的资源束格式
        loader - 用于加载捆绑的 ClassLoader
        reload - 表示捆绑重新加载的标志; true如果重新加载过期的资源束，否则为false
        结果
        资源束实例，或 null如果没有找到。
        异常
        NullPointerException -如果 bundleName ， locale ， format ，或 loader为 null ，或者如果 null被返回 toBundleName
        IllegalArgumentException - 如果 format未知，或者如果为给定参数找到的资源包含格式错误的数据。
        ClassCastException - 如果加载的类不能转换为 ResourceBundle
        IllegalAccessException - 如果类或其nullary构造函数不可访问。
        InstantiationException - 如果类的实例化由于某种其他原因而失败。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        SecurityException - 如果存在安全管理器，并且新实例的创建被拒绝。 详见Class.newInstance() 。
        IOException - 如果使用任何I / O操作读取资源时发生错误
        另请参见：
        ResourceBundleProvider.getBundle(String, Locale)

      • getTimeToLive

        public long getTimeToLive​(String baseName,
                          Locale locale)
        返回此ResourceBundle.Control下加载的资源束的生存时间（TTL）值。 积极的生存时间值指定捆绑可以保留在缓存中的毫秒数，而不会根据构建它的源数据进行验证。 值0表示每次从高速缓存检索时必须验证捆绑包。 TTL_DONT_CACHE指定加载的资源束不会放在缓存中。 TTL_NO_EXPIRATION_CONTROL指定将加载的资源束放在没有到期控制的高速缓存中。

        该过期仅影响ResourceBundle.getBundle工厂方法的捆绑ResourceBundle.getBundle载过程。 也就是说，如果工厂方法在缓存中找到已经过期的资源束，则工厂方法调用needsReload方法来确定是否需要重新加载资源包。 如果needsReload返回true ，缓存的资源束实例将从高速缓存中删除。 否则，实例将保留在缓存中，并使用此方法返回的新TTL值进行更新。

        由于运行时环境的内存限制，所有缓存的资源包都将从高速缓存中删除。 返回一个大的正值并不意味着在缓存中锁定加载的资源束。

        默认实现返回TTL_NO_EXPIRATION_CONTROL 。

        参数
        baseName - 指定到期值的资源束的基本名称。
        locale - 指定到期值的资源束的区域设置。
        结果
        缓存中的时间（0或从缓存时间的正毫秒偏移量）到达加载的捆绑包已过期， TTL_NO_EXPIRATION_CONTROL禁用过期控制，或 TTL_DONT_CACHE禁用缓存。
        异常
        NullPointerException - 如果是 baseName或 locale是 null

      • needsReload

        public boolean needsReload​(String baseName,
                           Locale locale,
                           String format,
                           ClassLoader loader,
                           ResourceBundle bundle,
                           long loadTime)
        根据loadTime给出的加载时间或其他一些标准，确定高速缓存中的过期bundle是否需要重新加载。 如果需要重新加载，该方法返回true ; false否则。 loadTime是自Calendar Epoch以来的毫秒偏移量。

        调用ResourceBundle.getBundle工厂方法在用于其当前调用的ResourceBundle.Control实例上调用此方法，而不是在最初加载资源束的调用中使用的实例。

        默认实现将比较loadTime和资源束的源数据的最后修改时间。 如果自loadTime确定源数据已被修改，则返回true 。 否则返回false 。 该实现假设给定的format与其文件后缀相同的字符串，如果它不是默认格式"java.class"或"java.properties" 。

        参数
        baseName - 资源束的基础包名称，完全限定类名称
        locale - 资源束应实例化的区域设置
        format - 要加载的资源束格式
        loader - 用于加载捆绑的 ClassLoader
        bundle - 缓存中已过期的资源束实例
        loadTime - bundle加载并放入缓存的时间
        结果
        true如果过期的包需要重新加载; 否则为false 。
        异常
        NullPointerException -如果 baseName ， locale ， format ， loader ，或 bundle为 null

      • toBundleName

        public String toBundleName​(String baseName,
                           Locale locale)
        将给定的baseName和locale转换为包名称。 这种方法是从默认实现的newBundle和needsReload方法中调用的。

        此实现返回以下值：

          baseName + "_" + language + "_" + script + "_" + country + "_" + variant
        其中language ， script ， country ，并variant是语言，脚本，国家和变量值locale分别。 最后的组件值为空字符串与前面的“_”一起被省略。 当脚本为空时，脚本值将与前面的“_”一起被省略。 如果所有值都为空字符串，则返回baseName 。

        例如，如果baseName为"baseName"而locale为Locale("ja", "", "XX") ，则返回"baseName_ja_ _XX" 。 如果给定的区域设置为Locale("en") ，则返回"baseName_en" 。

        覆盖此方法允许应用程序在本地化资源的组织和打包中使用不同的约定。

        参数
        baseName - 资源束的基本名称，一个完全限定的类名
        locale - 应为其加载资源束的区域设置
        结果
        资源束的包名称
        异常
        NullPointerException - 如果是 baseName或 locale是 null
        另请参见：
        AbstractResourceBundleProvider.toBundleName(String, Locale)

      • toResourceName

        public final String toResourceName​(String bundleName,
                                   String suffix)
        所述给定转换bundleName由所要求的形式ClassLoader.getResource通过更换所有出现的方法'.'在bundleName与'/'和追加'.'和给定的文件suffix 。 例如，如果bundleName为"foo.bar.MyResources_ja_JP"而suffix为"properties" ，则返回"foo/bar/MyResources_ja_JP.properties" 。
        参数
        bundleName - 包名称
        suffix - 文件类型后缀
        结果
        转换的资源名称
        异常
        NullPointerException - 如果 bundleName或 suffix为 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Scanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Scanner

  • java.lang.Object
    • java.util.Scanner
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Iterator<String>

    public final class Scanner
extends Object
implements Iterator<String>, Closeable
    一个简单的文本扫描器，可以使用正则表达式解析原始类型和字符串。

    A Scanner使用分隔符模式将其输入打破令牌，默认情况下匹配空格。 然后可以使用各种next方法将得到的令牌转换成不同类型的值。

    例如，该代码允许用户从System.in读取一个数字：

     Scanner sc = new Scanner(System.in);
     int i = sc.nextInt();

    另一个例子，该代码允许从文件myNumbers条目分配long类型：

      Scanner sc = new Scanner(new File("myNumbers"));
      while (sc.hasNextLong()) {
          long aLong = sc.nextLong();
      }

    扫描仪也可以使用除空格之外的分隔符。 此示例从字符串读取几个项目：

     String input = "1 fish 2 fish red fish blue fish";
     Scanner s = new Scanner(input).useDelimiter("\\s*fish\\s*");
     System.out.println(s.nextInt());
     System.out.println(s.nextInt());
     System.out.println(s.next());
     System.out.println(s.next());
     s.close();

    打印以下输出：

     1
     2
     red
     blue

    可以使用此代码生成相同的输出，该代码使用正则表达式一次解析所有四个令牌：

     String input = "1 fish 2 fish red fish blue fish";
     Scanner s = new Scanner(input);
     s.findInLine("(\\d+) fish (\\d+) fish (\\w+) fish (\\w+)");
     MatchResult result = s.match();
     for (int i=1; i<=result.groupCount(); i++)
         System.out.println(result.group(i));
     s.close();

    扫描仪使用的default whitespace delimiter是由Character.isWhitespace()确认的。 reset()方法将将扫描仪分隔符的值重置为默认空格分隔符，而不管以前是否已更改。

    扫描操作可能会阻止等待输入。

    next()和hasNext()方法及其配套方法（例如nextInt()和hasNextInt() ）首先跳过与分隔符模式匹配的任何输入，然后尝试返回下一个令牌。 hasNext()和next()方法都可能会阻止等待进一步的输入。 一个hasNext()方法块是否没有连接到其关联的next()方法是否会阻塞。 tokens()方法也可能会阻止等待输入。

    的findInLine() ， findWithinHorizon() ， skip()和findAll()方法定界符模式的独立操作。 这些方法将尝试匹配指定的模式，而不考虑输入中的分隔符，因此可以在分隔符不相关的特殊情况下使用。 这些方法可能会阻止等待更多的输入。

    当扫描仪抛出InputMismatchException时 ，扫描仪将不会传递导致异常的令牌，以便通过其他方法可以检索或跳过。

    根据定界模式的类型，可以返回空的令牌。 例如，模式"\\s+"将不返回空的令牌，因为它符合分隔符的多个实例。 定界模式"\\s"可以返回空令牌，因为它只能一次传递一个空格。

    扫描仪可以从实现Readable接口的任何对象读取文本。 如果底层可读的read()方法的调用会抛出一个IOException，则扫描器会假定输入的结尾已经到达。 底层可读的抛出最新的IOException可以通过ioException()方法检索。

    当一个Scanner关闭时，如果源实现Closeable接口，它将关闭其输入源。

    A Scanner对于没有外部同步的多线程使用是不安全的。

    除非另有提及，传递null参数成的任何方法Scanner将导致NullPointerException被抛出。

    扫描仪将默认将数字解释为十进制，除非使用useRadix(int)方法设置了不同的基数。 reset()方法将将扫描仪基数的值重置为10 ，无论以前是否已更改。

    Localized numbers

    该类的一个实例能够扫描标准格式的数字以及扫描仪区域的格式。 扫描仪的initial locale是Locale.getDefault(Locale.Category.FORMAT)方法返回的值; 它可以通过useLocale()方法更改。 reset()方法将将扫描仪的区域设置的值重置为初始区域，无论以前是否已更改。

    本地化格式是根据以下参数定义的，特定区域设置取自该区域设置的DecimalFormat对象， df及其和DecimalFormatSymbols对象， dfs 。

    LocalGroupSeparator
    The character used to separate thousands groups, i.e., dfs. getGroupingSeparator()
    LocalDecimalSeparator
    The character used for the decimal point, i.e., dfs. getDecimalSeparator()
    LocalPositivePrefix
    The string that appears before a positive number (may be empty), i.e., df. getPositivePrefix()
    LocalPositiveSuffix
    The string that appears after a positive number (may be empty), i.e., df. getPositiveSuffix()
    LocalNegativePrefix
    The string that appears before a negative number (may be empty), i.e., df. getNegativePrefix()
    LocalNegativeSuffix
    The string that appears after a negative number (may be empty), i.e., df. getNegativeSuffix()
    LocalNaN
    The string that represents not-a-number for floating-point values, i.e., dfs. getNaN()
    LocalInfinity
    The string that represents infinity for floating-point values, i.e., dfs. getInfinity()

    Number syntax

    可以通过该类的实例解析为数字的字符串使用以下正则表达式语法来指定，其中Rmax是所用基数中的最高位数（例如，Rmax在基数10中为9）。

    NonAsciiDigit ：
    一个非ASCII字符c，其中Character.isDigit (c)返回true
    Non0Digit ：
    [1- Rmax ] | NonASCIIDigit
    数字 ：
    [0- Rmax ] | NonASCIIDigit
    分组数 ：
    (  Non0Digit Digit ? 数字 ?
    (  LocalGroupSeparator Digit Digit Digit )+ )
    数字 ：
    ( ( 数字 + ) | GroupedNumeral )
    Integer:
    ( [-+]? ( 数字 ) )
    | LocalPositivePrefix 数字 LocalPositiveSuffix
    | LocalNegativePrefix 数字 LocalNegativeSuffix
    小数点数 ：
    数字
    | 数字 LocalDecimalSeparator 数字 *
    | LocalDecimalSeparator Digit +
    指数 ：
    ( [eE] [+-]? 数字 + )
    Decimal:
    ( [-+]? 小数 指数 ? )
    | LocalPositivePrefix DecimalNumeral LocalPositiveSuffix 指数 ?
    | LocalNegativePrefix DecimalNumeral LocalNegativeSuffix 指数 ?
    HexFloat ：
    [-+]? 0[xX][0-9a-fA-F]*\.[0-9a-fA-F]+ ([pP][-+]?[0-9]+)?
    非数字 ：
    NaN | LocalNan | Infinity | LocalInfinity
    签名号 ：
    ( [-+]? NonNumber )
    | LocalPositivePrefix NonNumber LocalPositiveSuffix
    | LocalNegativePrefix NonNumber LocalNegativeSuffix
    Float ：
    十进制 | HexFloat | 已 签名 | 参数

    上述正则表达式中的空格不重要。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      Scanner​(File source)
      构造一个新的 Scanner ，产生从指定文件扫描的值。
      Scanner​(File source, String charsetName)
      构造一个新的 Scanner ，产生从指定文件扫描的值。
      Scanner​(InputStream source)
      构造一个新的 Scanner ，产生从指定的输入流扫描的值。
      Scanner​(InputStream source, String charsetName)
      构造一个新的 Scanner ，产生从指定的输入流扫描的值。
      Scanner​(Readable source)
      构造一个新的 Scanner ，产生从指定源扫描的值。
      Scanner​(String source)
      构造一个新的 Scanner ，产生从指定字符串扫描的值。
      Scanner​(ReadableByteChannel source)
      构造一个新的 Scanner ，产生从指定通道扫描的值。
      Scanner​(ReadableByteChannel source, String charsetName)
      构造一个新的 Scanner ，产生从指定通道扫描的值。
      Scanner​(Path source)
      构造一个新的 Scanner ，产生从指定文件扫描的值。
      Scanner​(Path source, String charsetName)
      构造一个新的 Scanner ，产生从指定文件扫描的值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此扫描仪。
      Pattern delimiter​()
      返回 Pattern这个 Scanner当前用于匹配分隔符。
      Stream<MatchResult> findAll​(String patString)
      返回与提供的模式字符串相匹配的匹配结果流。
      Stream<MatchResult> findAll​(Pattern pattern)
      返回此扫描仪的匹配结果流。
      String findInLine​(String pattern)
      尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。
      String findInLine​(Pattern pattern)
      尝试找到忽略分隔符的指定模式的下一个出现。
      String findWithinHorizon​(String pattern, int horizon)
      尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。
      String findWithinHorizon​(Pattern pattern, int horizon)
      尝试找到指定模式的下一个出现。
      boolean hasNext​()
      如果此扫描仪在其输入中有另一个令牌，则返回true。
      boolean hasNext​(String pattern)
      如果下一个令牌匹配从指定字符串构造的模式，则返回true。
      boolean hasNext​(Pattern pattern)
      如果下一个完整的令牌匹配指定的模式，则返回true。
      boolean hasNextBigDecimal​()
      如果此扫描仪输入中的下一个标记可以使用 nextBigDecimal()方法解释为 BigDecimal则返回true。
      boolean hasNextBigInteger​()
      如果此扫描仪输入中的下一个标记可以使用 nextBigInteger()方法将其解释为默认基数中的 BigInteger ，则返回true。
      boolean hasNextBigInteger​(int radix)
      如果此扫描仪输入中的下一个标记可以使用 nextBigInteger()方法将其解释为指定基数中的 BigInteger ，则返回true。
      boolean hasNextBoolean​()
      如果此扫描器输入中的下一个标记可以使用从字符串“true | false”创建的不区分大小写的模式解释为布尔值，则返回true。
      boolean hasNextByte​()
      如果此扫描仪输入中的下一个标记可以使用 nextByte()方法将其解释为默认基数中的字节值，则返回true。
      boolean hasNextByte​(int radix)
      如果此扫描仪输入中的下一个标记可以使用 nextByte()方法将其解释为指定基数中的字节值，则返回true。
      boolean hasNextDouble​()
      如果该扫描仪输入中的下一个标记可以使用 nextDouble()方法将其解释为双重值，则返回true。
      boolean hasNextFloat​()
      如果此扫描仪输入中的下一个标记可以使用 nextFloat()方法将其解释为浮点值，则返回true。
      boolean hasNextInt​()
      如果此扫描仪输入中的下一个标记可以使用 nextInt()方法将其解释为默认基数中的int值，则返回true。
      boolean hasNextInt​(int radix)
      如果扫描仪的输入中的下一个标记可以使用 nextInt()方法解释为指定基数中的int值，则返回true。
      boolean hasNextLine​()
      如果扫描仪的输入中有另一行，则返回true。
      boolean hasNextLong​()
      如果此扫描仪的输入中的下一个令牌可以使用 nextLong()方法将其解释为默认基数中的长值，则返回true。
      boolean hasNextLong​(int radix)
      如果此扫描仪输入中的下一个标记可以使用 nextLong()方法将其解释为指定基数中的长 整型值，则返回true。
      boolean hasNextShort​()
      如果此扫描仪输入中的下一个标记可以使用 nextShort()方法将其解释为默认基数中的一个短值，则返回true。
      boolean hasNextShort​(int radix)
      如果此扫描仪输入中的下一个标记可以使用 nextShort()方法将其解释为指定基数中的一个短值，则返回true。
      IOException ioException​()
      返回 IOException最后通过此抛出 Scanner的基本 Readable 。
      Locale locale​()
      返回此扫描仪的区域设置。
      MatchResult match​()
      返回此扫描仪执行的最后扫描操作的匹配结果。
      String next​()
      查找并返回此扫描仪的下一个完整令牌。
      String next​(String pattern)
      如果匹配从指定字符串构造的模式，则返回下一个令牌。
      String next​(Pattern pattern)
      如果匹配指定的模式，则返回下一个令牌。
      BigDecimal nextBigDecimal​()
      将输入的下一个标记扫描为BigDecimal 。
      BigInteger nextBigInteger​()
      将输入的下一个标记扫描为BigInteger 。
      BigInteger nextBigInteger​(int radix)
      将输入的下一个标记扫描为BigInteger 。
      boolean nextBoolean​()
      将输入的下一个标记扫描为布尔值，并返回该值。
      byte nextByte​()
      将输入的下一个标记扫描为 byte 。
      byte nextByte​(int radix)
      将输入的下一个标记扫描为 byte 。
      double nextDouble​()
      将输入的下一个标记扫描为 double 。
      float nextFloat​()
      将输入的下一个标记扫描为 float 。
      int nextInt​()
      将输入的下一个标记扫描为 int 。
      int nextInt​(int radix)
      将输入的下一个标记扫描为 int 。
      String nextLine​()
      将此扫描仪推进到当前行并返回跳过的输入。
      long nextLong​()
      将输入的下一个标记扫描为 long 。
      long nextLong​(int radix)
      将输入的下一个标记扫描为 long 。
      short nextShort​()
      将输入的下一个标记扫描为 short 。
      short nextShort​(int radix)
      将输入的下一个标记扫描为 short 。
      int radix​()
      返回此扫描仪的默认基数。
      void remove​()
      Iterator的此实现不支持删除操作。
      Scanner reset​()
      重设此扫描仪。
      Scanner skip​(String pattern)
      跳过与指定字符串构成的模式匹配的输入。
      Scanner skip​(Pattern pattern)
      跳过与指定模式匹配的输入，忽略分隔符。
      Stream<String> tokens​()
      从此扫描仪返回一个分隔符的分隔符号流。
      String toString​()
      返回此 Scanner的字符串表示 Scanner 。
      Scanner useDelimiter​(String pattern)
      将此扫描仪的分隔模式设置为从指定的 String构造的模式。
      Scanner useDelimiter​(Pattern pattern)
      将此扫描仪的分隔模式设置为指定的模式。
      Scanner useLocale​(Locale locale)
      将此扫描仪的区域设置设置为指定的区域设置。
      Scanner useRadix​(int radix)
      将此扫描仪的默认基数设置为指定的基数。

      • Methods inherited from interface java.util.Iterator

        forEachRemaining

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Scanner

        public Scanner​(Readable source)
        构造新的 Scanner ，产生从指定源扫描的值。
        参数
        source - 实现Readable界面的字符源

      • Scanner

        public Scanner​(InputStream source)
        构造一个新的Scanner ，产生从指定的输入流扫描的值。 流中的字节将使用底层平台的default charset转换为字符。
        参数
        source - 要扫描的输入流

      • Scanner

        public Scanner​(InputStream source,
               String charsetName)
        构造一个新的Scanner ，产生从指定的输入流扫描的值。 流中的字节将使用指定的字符集转换为字符。
        参数
        source - 要扫描的输入流
        charsetName - 用于将流中的字节转换为要扫描的字符的编码类型
        异常
        IllegalArgumentException - 如果指定的字符集不存在

      • Scanner

        public Scanner​(File source)
        throws FileNotFoundException
        构造一个新的Scanner ，产生从指定文件扫描的值。 使用底层平台的default charset将文件中的字节转换为字符。
        参数
        source - 要扫描的文件
        异常
        FileNotFoundException - 如果找不到源

      • Scanner

        public Scanner​(File source,
               String charsetName)
        throws FileNotFoundException
        构造一个新的Scanner ，产生从指定文件扫描的值。 使用指定的字符集将文件中的字节转换为字符。
        参数
        source - 要扫描的文件
        charsetName - 用于将文件中的字节转换为要扫描的字符的编码类型
        异常
        FileNotFoundException - 如果找不到源
        IllegalArgumentException - 如果未找到指定的编码

      • Scanner

        public Scanner​(Path source)
        throws IOException
        构造一个新的Scanner ，产生从指定文件扫描的值。 文件中的字节将使用底层平台的default charset转换为字符。
        参数
        source - 要扫描的文件的路径
        异常
        IOException - 如果I / O错误发生开源
        从以下版本开始：
        1.7

      • Scanner

        public Scanner​(Path source,
               String charsetName)
        throws IOException
        构造一个新的Scanner ，产生从指定文件扫描的值。 使用指定的字符集将文件中的字节转换为字符。
        参数
        source - 要扫描的文件的路径
        charsetName - 用于将文件中的字节转换为要扫描的字符的编码类型
        异常
        IOException - 如果I / O错误发生开源
        IllegalArgumentException - 如果未找到指定的编码
        从以下版本开始：
        1.7

      • Scanner

        public Scanner​(String source)
        构造一个新的 Scanner ，产生从指定字符串扫描的值。
        参数
        source - 要扫描的字符串

      • Scanner

        public Scanner​(ReadableByteChannel source)
        构造一个新的Scanner ，产生从指定通道扫描的值。 源码中的字节将使用底层平台的default charset转换为字符。
        参数
        source - 要扫描的频道

      • Scanner

        public Scanner​(ReadableByteChannel source,
               String charsetName)
        构造新的Scanner ，产生从指定通道扫描的值。 来自源的字节将使用指定的字符集转换为字符。
        参数
        source - 要扫描的频道
        charsetName - 用于将字节从通道转换为要扫描的字符的编码类型
        异常
        IllegalArgumentException - 如果指定的字符集不存在

    • 方法详细信息

      • close

        public void close​()
        关闭此扫描仪。

        如果该扫描仪尚未关闭，那么如果其底层的readable也实现了Closeable接口，那么可读的close方法将被调用。 如果此扫描仪已关闭，则调用此方法将不起作用。

        扫描仪关闭后尝试执行搜索操作将导致IllegalStateException 。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable

      • ioException

        public IOException ioException​()
        返回IOException最后通过此抛出Scanner的基本Readable 。 如果不存在这种异常，此方法返回null 。
        结果
        这个扫描仪可读的抛出的最后一个异常

      • delimiter

        public Pattern delimiter​()
        返回 Pattern这个 Scanner当前正在使用来匹配分隔符。
        结果
        这个扫描仪的划分模式。

      • useDelimiter

        public Scanner useDelimiter​(Pattern pattern)
        将此扫描仪的分隔模式设置为指定的模式。
        参数
        pattern - 定界模式
        结果
        这个扫描仪

      • useDelimiter

        public Scanner useDelimiter​(String pattern)
        将此扫描仪的分隔模式设置为从指定的String构造的模式。

        对这种useDelimiter(pattern)形式的方法的调用与调用useDelimiter(Pattern.compile(pattern)) 。

        调用reset()方法将扫描仪的分隔符设置为default 。

        参数
        pattern - 指定定界模式的字符串
        结果
        这个扫描仪

      • locale

        public Locale locale​()
        返回此扫描仪的区域设置。

        扫描仪的区域设置会影响其默认基元匹配正则表达式的许多元素; 见上面的localized numbers 。

        结果
        这个扫描仪的区域设置

      • useLocale

        public Scanner useLocale​(Locale locale)
        将此扫描仪的区域设置设置为指定的区域设置。

        扫描仪的区域设置会影响其默认基元匹配正则表达式的许多元素; 见上面的localized numbers 。

        调用reset()方法将扫描仪的区域设置设置为initial locale 。

        参数
        locale - 指定要使用的区域设置的字符串
        结果
        这个扫描仪

      • radix

        public int radix​()
        返回此扫描仪的默认基数。

        扫描仪的基数影响与正则表达式匹配的默认数字的元素; 见上面的localized numbers 。

        结果
        该扫描仪的默认基数

      • useRadix

        public Scanner useRadix​(int radix)
        将此扫描仪的默认基数设置为指定的基数。

        扫描仪的基数影响与正则表达式匹配的默认数字的元素; 见上面的localized numbers 。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        调用reset()方法将扫描仪的基数设置为10 。

        参数
        radix - 扫描数字时使用的基数
        结果
        这个扫描仪
        异常
        IllegalArgumentException - 如果基数超出范围

      • match

        public MatchResult match​()
        返回此扫描仪执行的最后扫描操作的匹配结果。 如果未执行任何匹配，或者最后一次匹配IllegalStateException则此方法将抛出IllegalStateException 。

        各种next的方法Scanner使比赛结果可用，如果他们完成未抛出异常。 例如，在调用返回int的nextInt()方法之后，此方法返回一个MatchResult用于搜索上述定义的Integer正则表达式。 同样， findInLine() ， findWithinHorizon() ，并skip()方法将一个匹配结果，如果他们取得成功。

        结果
        最后一场比赛的比赛结果
        异常
        IllegalStateException - 如果没有匹配结果可用

      • toString

        public String toString​()

        返回此Scanner的字符串表示Scanner 。 Scanner的字符串表示Scanner包含可能对调试有用的信息。 确切的格式是未指定的。

        重写：
        toString在 Object
        结果
        该扫描仪的字符串表示

      • hasNext

        public boolean hasNext​()
        如果此扫描仪在其输入中有另一个令牌，则返回true。 此方法可能会在等待输入扫描时屏蔽。 扫描仪不会超过任何输入。
        Specified by:
        hasNext在接口 Iterator<String>
        结果
        当且仅当该扫描仪具有另一个令牌时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭
        另请参见：
        Iterator

      • next

        public String next​()
        查找并返回此扫描仪的下一个完整令牌。 一个完整的令牌在分隔符模式之前和之后是与分隔符模式匹配的输入。 此方法可能会在等待输入扫描时阻塞，即使以前的调用hasNext()返回true 。
        Specified by:
        next在接口 Iterator<String>
        结果
        下一个标记
        异常
        NoSuchElementException - 如果没有更多的令牌可用
        IllegalStateException - 如果此扫描仪已关闭
        另请参见：
        Iterator

      • remove

        public void remove​()
        Iterator的此实现不支持删除操作。
        Specified by:
        remove在接口 Iterator<String>
        异常
        UnsupportedOperationException - 如果这个方法被调用。
        另请参见：
        Iterator

      • hasNext

        public boolean hasNext​(String pattern)
        如果下一个令牌匹配从指定字符串构造的模式，则返回true。 扫描仪不会超过任何输入。

        这种hasNext(pattern)形式的方法的调用与调用hasNext(Pattern.compile(pattern)) 。

        参数
        pattern - 指定要扫描的模式的字符串
        结果
        如果且仅当此扫描仪具有与指定模式匹配的另一个令牌，则为true
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • next

        public String next​(String pattern)
        如果匹配从指定字符串构造的模式，则返回下一个令牌。 如果匹配成功，扫描仪将超过符合图案的输入。

        对这种next(pattern)形式的方法的调用与调用next(Pattern.compile(pattern)) 。

        参数
        pattern - 指定要扫描的模式的字符串
        结果
        下一个标记
        异常
        NoSuchElementException - 如果没有这样的令牌可用
        IllegalStateException - 如果此扫描仪已关闭

      • hasNext

        public boolean hasNext​(Pattern pattern)
        如果下一个完整的令牌匹配指定的模式，则返回true。 完整的令牌前缀并通过与分隔符模式匹配的输入进行后缀。 此方法可能会在等待输入时阻塞。 扫描仪不会超过任何输入。
        参数
        pattern - 要扫描的图案
        结果
        如果且仅当此扫描仪具有与指定模式匹配的另一个令牌，则为true
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • next

        public String next​(Pattern pattern)
        如果匹配指定的模式，则返回下一个令牌。 此方法可能会在等待输入扫描时阻塞，即使以前的调用hasNext(Pattern)返回true 。 如果匹配成功，扫描仪将超过符合图案的输入。
        参数
        pattern - 要扫描的模式
        结果
        下一个标记
        异常
        NoSuchElementException - 如果没有更多的令牌可用
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextLine

        public boolean hasNextLine​()
        如果扫描仪的输入中有另一行，则返回true。 此方法可能会在等待输入时阻塞。 扫描仪不会超过任何输入。
        结果
        当且仅当此扫描仪具有另一行输入时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • nextLine

        public String nextLine​()
        将此扫描仪推进到当前行并返回跳过的输入。 此方法返回当前行的其余部分，不包括末尾的任何行分隔符。 该位置设置为下一行的开头。

        由于该方法继续搜索通过输入寻找行分隔符的输入，所以如果不存在行分隔符，它可以缓冲所有搜索行的输入，以跳过。

        结果
        被跳过的行
        异常
        NoSuchElementException - 如果没有找到行
        IllegalStateException - 如果此扫描仪已关闭

      • findInLine

        public String findInLine​(String pattern)
        尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。

        对这种findInLine(pattern)形式的方法的调用与调用findInLine(Pattern.compile(pattern)) 。

        参数
        pattern - 指定要搜索的模式的字符串
        结果
        匹配指定模式的文本
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • findInLine

        public String findInLine​(Pattern pattern)
        尝试找到忽略分隔符的指定模式的下一个出现。 如果在下一行分隔符之前找到模式，则扫描器将超过匹配的输入，并返回与模式匹配的字符串。 如果在直到下一行分隔符的输入中没有检测到这种模式，则返回null ，扫描仪的位置不变。 此方法可能会阻止等待与模式匹配的输入。

        由于该方法继续搜索输入寻找指定的模式，所以如果不存在线分隔符，它可能会缓冲搜索所需令牌的所有输入。

        参数
        pattern - 要扫描的模式
        结果
        匹配指定模式的文本
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • findWithinHorizon

        public String findWithinHorizon​(String pattern,
                                int horizon)
        尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。

        这种findWithinHorizon(pattern)形式的方法的调用方式与调用findWithinHorizon(Pattern.compile(pattern), horizon) 。

        参数
        pattern - 指定要搜索的模式的字符串
        horizon - 搜索范围
        结果
        匹配指定模式的文本
        异常
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果地平线是负的

      • findWithinHorizon

        public String findWithinHorizon​(Pattern pattern,
                                int horizon)
        尝试找到指定模式的下一个出现。

        该方法通过输入搜索直到指定的搜索范围，忽略分隔符。 如果找到模式，扫描仪将超过匹配的输入，并返回匹配该模式的字符串。 如果没有检测到这种模式，则返回null，扫描仪的位置保持不变。 此方法可能会阻止等待与模式匹配的输入。

        扫描仪永远不会搜索超过其当前位置的horizon代码点。 请注意，比赛可能会被地平线所限制; 也就是说，如果地平线较大，任意匹配结果可能不同。 扫描仪将地平线视为透明的非锚定界限（见Matcher.useTransparentBounds(boolean)和Matcher.useAnchoringBounds(boolean) ）。

        如果地平线是0 ，那么地平线将被忽略，并且该方法继续搜索通过输入寻找指定的模式而不受约束。 在这种情况下，它可以缓冲搜索模式的所有输入。

        如果地平线为负，则抛出IllegalArgumentException。

        参数
        pattern - 要扫描的模式
        horizon - 搜索范围
        结果
        匹配指定模式的文本
        异常
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果地平线是负的

      • skip

        public Scanner skip​(Pattern pattern)
        跳过与指定模式匹配的输入，忽略分隔符。 如果指定模式的锚定匹配成功，此方法将跳过输入。

        如果在当前位置找不到指定模式的匹配项，则不跳过任何输入，并抛出NoSuchElementException 。

        由于该方法旨在匹配从扫描仪当前位置开始的指定模式，因此可以匹配大量输入（例如“。*”）的模式可能会导致扫描程序缓冲大量输入。

        请注意，通过使用可以匹配的模式，例如sc.skip("[ \t]*") ，可以跳过某些东西而不冒NoSuchElementException的风险。

        参数
        pattern - 指定要跳过的模式的字符串
        结果
        这个扫描仪
        异常
        NoSuchElementException - 如果未找到指定的模式
        IllegalStateException - 如果此扫描仪已关闭

      • skip

        public Scanner skip​(String pattern)
        跳过与指定字符串构成的模式匹配的输入。

        这种skip(pattern)形式的方法的调用与调用skip(Pattern.compile(pattern)) 。

        参数
        pattern - 指定要跳过的模式的字符串
        结果
        这个扫描仪
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextBoolean

        public boolean hasNextBoolean​()
        如果此扫描器输入中的下一个标记可以使用从字符串“true | false”创建的不区分大小写的模式解释为布尔值，则返回true。 扫描仪不会超过匹配的输入。
        结果
        当且仅当此扫描器的下一个令牌是有效的布尔值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • nextBoolean

        public boolean nextBoolean​()
        将输入的下一个标记扫描为布尔值，并返回该值。 如果下一个令牌无法转换为有效的布尔值，此方法将抛出InputMismatchException 。 如果匹配成功，扫描仪将超过匹配的输入。
        结果
        从输入中扫描的布尔值
        异常
        InputMismatchException - 如果下一个令牌不是有效的布尔值
        NoSuchElementException - 输入是否耗尽
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextByte

        public boolean hasNextByte​()
        如果扫描仪输入中的下一个标记可以使用nextByte()方法将其解释为默认基数中的字节值，则返回true。 扫描仪不会超过任何输入。
        结果
        当且仅当此扫描仪的下一个令牌是有效的字节值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextByte

        public boolean hasNextByte​(int radix)
        如果此扫描仪输入中的下一个标记可以使用nextByte()方法解释为指定基数中的字节值，则返回true。 扫描仪不会超过任何输入。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于将令牌解释为字节值的基数
        结果
        当且仅当此扫描仪的下一个令牌是有效的字节值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • nextByte

        public byte nextByte​()
        将输入的下一个标记扫描为byte 。

        对这种nextByte()形式的方法的调用与调用nextByte(radix) ，其中radix是该扫描器的默认基数。

        结果
        byte从输入扫描
        异常
        InputMismatchException - 如果下一个令牌与 整数正则表达式不匹配，或超出范围
        NoSuchElementException - 如果输入已用尽
        IllegalStateException - 如果此扫描仪已关闭

      • nextByte

        public byte nextByte​(int radix)
        将输入的下一个标记扫描为byte 。 如果下一个令牌不能转换为有效的字节值，则此方法将抛出InputMismatchException ，如下所述。 如果翻译成功，扫描仪将超过匹配的输入。

        如果下一个令牌符合上面定义的270644548965050正则表达式，则令牌将转换为byte值，如同通过删除所有特定于语言环境的前缀，组分隔符和特定于语言环境的后缀一样，然后通过Character.digit将非ASCII数字映射为ASCII数字如果存在特定的区域设置的前缀和后缀，则使用负号（ - ），并将结果字符串传递给具有指定基数的Byte.parseByte 。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于将令牌解释为字节值的基数
        结果
        byte从输入扫描
        异常
        InputMismatchException - 如果下一个令牌与 整数正则表达式不匹配或超出范围
        NoSuchElementException - 输入是否耗尽
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • hasNextShort

        public boolean hasNextShort​()
        如果此扫描仪输入中的下一个标记可以使用nextShort()方法将其解释为默认基数中的短值，则返回true。 扫描仪不会超过任何输入。
        结果
        当且仅当此扫描仪的下一个标记是默认基数中的有效短值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextShort

        public boolean hasNextShort​(int radix)
        如果此扫描仪输入中的下一个标记可以使用nextShort()方法将其解释为指定基数中的一个短值，则返回true。 扫描仪不会超过任何输入。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于将令牌解释为短值的基数
        结果
        当且仅当此扫描器的下一个标记是指定基数中的有效的短值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • nextShort

        public short nextShort​()
        将输入的下一个标记扫描为short 。

        对这种nextShort()形式的方法的调用与调用nextShort(radix)完全相同 ，其中radix是该扫描仪的默认基数。

        结果
        short从输入扫描
        异常
        InputMismatchException - 如果下一个令牌与 整数正则表达式不匹配或超出范围
        NoSuchElementException - 输入是否耗尽
        IllegalStateException - 如果此扫描仪已关闭

      • nextShort

        public short nextShort​(int radix)
        将输入的下一个标记扫描为short 。 如果下一个令牌不能转换为有效的短值，则此方法将抛出InputMismatchException ，如下所述。 如果翻译成功，扫描仪将超过匹配的输入。

        如果下一个令牌符合上述定义的27064454993838正则表达式，则令牌将转换为short值，如同通过删除所有特定于语言环境的前缀，组分隔符和特定于语言环境的后缀一样，然后通过Character.digit将非ASCII数字映射为ASCII数字， 前缀为如果区域设置特定的负前缀和后缀存在，并将结果字符串传递到具有指定基数的Short.parseShort ， 则为负号（ - ）。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于将令牌解释为短值的基数
        结果
        short从输入扫描
        异常
        InputMismatchException - 如果下一个令牌与 整型正则表达式不匹配，或超出范围
        NoSuchElementException - 输入是否耗尽
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • hasNextInt

        public boolean hasNextInt​()
        如果此扫描仪输入中的下一个标记可以使用nextInt()方法将其解释为默认基数中的int值，则返回true。 扫描仪不会超过任何输入。
        结果
        当且仅当此扫描器的下一个令牌是有效的int值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextInt

        public boolean hasNextInt​(int radix)
        如果此扫描仪的输入中的下一个标记可以使用nextInt()方法解释为指定基数中的int值，则返回true。 扫描仪不会超过任何输入。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于将令牌解释为int值的基数
        结果
        当且仅当此扫描器的下一个令牌是有效的int值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • nextInt

        public int nextInt​()
        将输入的下一个标记扫描为int 。

        调用nextInt()形式的方法与调用nextInt(radix) ，其中radix是此扫描程序的默认基数。

        结果
        int从输入扫描
        异常
        InputMismatchException - 如果下一个令牌与 整数正则表达式不匹配，或超出范围
        NoSuchElementException - 如果输入已用尽
        IllegalStateException - 如果此扫描仪已关闭

      • nextInt

        public int nextInt​(int radix)
        将输入的下一个标记扫描为int 。 如果下一个令牌不能转换为有效的int值，则此方法将抛出InputMismatchException ，如下所述。 如果翻译成功，扫描仪将超过匹配的输入。

        如果下一个令牌符合上面定义的Integer正则表达式，则令牌将转换为int值，就像删除所有特定于语言环境的前缀，组分隔符和特定于语言环境的后缀一样，然后通过Character.digit将非ASCII数字映射为ASCII数字如果存在特定区域的负号前缀和后缀，则使用负号（ - ），并将结果字符串传递给具有指定基数的Integer.parseInt 。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于将令牌解释为int值的基数
        结果
        int从输入扫描
        异常
        InputMismatchException - 如果下一个令牌与 整数正则表达式不匹配，或超出范围
        NoSuchElementException - 输入是否耗尽
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • hasNextLong

        public boolean hasNextLong​()
        如果此扫描仪输入中的下一个标记可以使用nextLong()方法将其解释为默认基数中的长值，则返回true。 扫描仪不会超过任何输入。
        结果
        当且仅当此扫描仪的下一个令牌是有效的长值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextLong

        public boolean hasNextLong​(int radix)
        如果此扫描仪输入中的下一个标记可以使用nextLong()方法将其解释为指定基数中的长整型值，则返回true。 扫描仪不会超过任何输入。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于将令牌解释为长值的基数
        结果
        当且仅当此扫描仪的下一个令牌是有效的长值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • nextLong

        public long nextLong​()
        将输入的下一个标记扫描为long 。

        这种nextLong()形式的方法的调用与调用nextLong(radix) ，其中radix是该扫描仪的默认基数。

        结果
        long从输入扫描
        异常
        InputMismatchException - 如果下一个令牌不匹配 整数正则表达式，或超出范围
        NoSuchElementException - 如果输入已用尽
        IllegalStateException - 如果此扫描仪已关闭

      • nextLong

        public long nextLong​(int radix)
        将输入的下一个标记扫描为long 。 如果下一个令牌不能转换为有效的长值，则此方法将抛出InputMismatchException ，如下所述。 如果翻译成功，扫描仪将超过匹配的输入。

        如果下一个令牌匹配上面定义的Integer正则表达式，则令牌将转换为long值，如同通过删除所有特定于语言环境的前缀，组分隔符和特定于语言环境的后缀一样，然后通过Character.digit将非ASCII数字映射为ASCII数字， 前缀为如果存在特定的区域设置的前缀和后缀，则使用负号（ - ），并将结果字符串传递给具有指定基数的Long.parseLong 。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于将令牌解释为int值的基数
        结果
        long从输入扫描
        异常
        InputMismatchException - 如果下一个标记与 整数正则表达式不匹配，或超出范围
        NoSuchElementException - 如果输入已用尽
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • hasNextFloat

        public boolean hasNextFloat​()
        如果此扫描仪输入中的下一个标记可以使用nextFloat()方法将其解释为浮点值，则返回true。 扫描仪不会超过任何输入。
        结果
        当且仅当此扫描仪的下一个令牌是有效的浮点值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • nextFloat

        public float nextFloat​()
        将输入的下一个标记扫描为float 。 如果下一个令牌不能转换为有效的浮点值，则此方法将抛出InputMismatchException ，如下所述。 如果翻译成功，扫描仪将超过匹配的输入。

        如果下一个令牌符合上面定义的Float正则表达式，则令牌将转换为float值，如同删除所有特定于语言环境的前缀，组分隔符和特定于语言环境的后缀一样，然后通过Character.digit将非ASCII数字映射为ASCII数字如果存在特定区域的负前缀和后缀，则将负号（ - ），并将生成的字符串传递给Float.parseFloat 。 如果令牌与局部NaN或无穷大字符串匹配，则“Nan”或“Infinity”将酌情传递给Float.parseFloat 。

        结果
        float从输入扫描
        异常
        InputMismatchException - 如果下一个标记与 Float正则表达式不匹配或超出范围
        NoSuchElementException - 如果输入已用尽
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextDouble

        public boolean hasNextDouble​()
        如果此扫描仪输入中的下一个标记可以使用nextDouble()方法将其解释为双精度值，则返回true。 扫描仪不会超过任何输入。
        结果
        当且仅当此扫描器的下一个令牌是有效的双重值时才为真
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • nextDouble

        public double nextDouble​()
        将输入的下一个标记扫描为double 。 如果下一个令牌不能转换为有效的双InputMismatchException此方法将抛出InputMismatchException 。 如果翻译成功，扫描仪将超过匹配的输入。

        如果下一个令牌与上述定义的2706445533830正则表达式匹配，则令牌将转换为double值，如同通过删除所有特定于语言环境的前缀，组分隔符和特定于语言环境的后缀一样，然后通过Character.digit将非ASCII数字映射为ASCII数字如果区域设置特定的负前缀和后缀存在，并将结果字符串传递给Double.parseDouble ， 则为负号（ - ）。 如果令牌与局部NaN或无穷大字符串匹配，则“Nan”或“Infinity”根据需要传递给Double.parseDouble 。

        结果
        double从输入扫描
        异常
        InputMismatchException - 如果下一个标记与 Float正则表达式不匹配或超出范围
        NoSuchElementException - 输入是否耗尽
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextBigInteger

        public boolean hasNextBigInteger​()
        如果此扫描仪输入中的下一个令牌可以使用nextBigInteger()方法将其解释为默认基数中的BigInteger ，则返回true。 扫描仪不会超过任何输入。
        结果
        如果且仅当此扫描仪的下一个令牌是有效的 BigInteger
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • hasNextBigInteger

        public boolean hasNextBigInteger​(int radix)
        如果此扫描仪输入中的下一个标记可以使用nextBigInteger()方法解释为指定基数中的BigInteger ，则返回true。 扫描仪不会超过任何输入。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于将令牌解释为整数的基数
        结果
        如果且仅当此扫描仪的下一个令牌是有效的 BigInteger
        异常
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • nextBigInteger

        public BigInteger nextBigInteger​()
        将输入的下一个标记扫描为BigInteger 。

        对这种nextBigInteger()形式的方法的调用与调用nextBigInteger(radix) ，其中radix是该扫描器的默认基数。

        结果
        BigInteger从输入扫描
        异常
        InputMismatchException - 如果下一个令牌与 整数正则表达式不匹配，或超出范围
        NoSuchElementException - 输入是否耗尽
        IllegalStateException - 如果此扫描仪已关闭

      • nextBigInteger

        public BigInteger nextBigInteger​(int radix)
        将输入的下一个标记扫描为BigInteger 。

        如果下一个令牌匹配上面定义的Integer正则表达式，则令牌将转换为BigInteger值，就像删除所有组分隔符一样，通过Character.digit将非ASCII数字映射为ASCII数字，并将生成的字符串传递给BigInteger(String, int)构造函数，指定的基数。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则抛出IllegalArgumentException 。

        参数
        radix - 用于解释令牌的基数
        结果
        BigInteger从输入扫描
        异常
        InputMismatchException - 如果下一个标记与 整数正则表达式不匹配，或超出范围
        NoSuchElementException - 输入是否耗尽
        IllegalStateException - 如果此扫描仪已关闭
        IllegalArgumentException - 如果基数超出范围

      • hasNextBigDecimal

        public boolean hasNextBigDecimal​()
        如果此扫描仪的输入中的下一个标记可以使用nextBigDecimal()方法解释为BigDecimal则返回true。 扫描仪不会超过任何输入。
        结果
        如果且仅当此扫描仪的下一个令牌是有效的 BigDecimal
        异常
        IllegalStateException - 如果此扫描仪已关闭

      • nextBigDecimal

        public BigDecimal nextBigDecimal​()
        将输入的下一个标记扫描为BigDecimal 。

        如果下一个令牌符合上述定义的2706445636270正则表达式，则令牌将转换为BigDecimal值，如同通过删除所有组分隔符一样，通过Character.digit将非ASCII数字映射为ASCII数字，并将生成的字符串传递给270644563669393构造函数。

        结果
        BigDecimal从输入扫描
        异常
        InputMismatchException - 如果下一个标记与 Decimal正则表达式不匹配，或超出范围
        NoSuchElementException - 输入是否耗尽
        IllegalStateException - 如果此扫描仪已关闭

      • reset

        public Scanner reset​()
        重设此扫描仪。

        重置扫描器会丢弃所有可能已经通过调用改变了明确的状态信息useDelimiter() ， useLocale() ，或useRadix() 。

        对这种scanner.reset()形式的方法的调用与调用的方式完全相同

   scanner.useDelimiter("\\p{javaWhitespace}+")
          .useLocale(Locale.getDefault(Locale.Category.FORMAT))
          .useRadix(10);
        结果
        这个扫描仪
        从以下版本开始：
        1.6

      • tokens

        public Stream<String> tokens​()
        从此扫描仪返回一个分隔符的分隔符号流。 该流包含从该扫描器的当前状态开始返回的相同令牌，通过重复调用next()方法直到hasNext()方法返回false。

        生成的流是顺序的和有序的。 所有流元素都不为空。

        使用该扫描仪的当前状态，在启动终端流操作时开始扫描。 随后调用此扫描仪上除close()和ioException()之外的任何方法可能会返回未定义的结果，也可能对返回的流造成未定义的影响。 返回的流的源码Spliterator是故障快速的 ，如果在流管道执行期间检测到任何此类呼叫，将尽力而为地抛出一个ConcurrentModificationException 。

        在流管道执行完成后，该扫描器处于不确定状态，不能重复使用。

        如果此扫描仪包含必须释放的资源，则应关闭此扫描程序，方法是通过调用其close()方法或关闭返回的流。 关闭流将关闭底层扫描程序。 如果在调用此方法时扫描仪已关闭，或者在流程执行期间此扫描程序关闭，则抛出IllegalStateException 。

        此方法可能会阻止等待更多的输入。

        API Note:
        例如，以下代码将从字符串创建一个逗号分隔的令牌列表：
           List<String> result = new Scanner("abc,def,,ghi") .useDelimiter(",") .tokens() .collect(Collectors.toList());

        结果列表将包含"abc" ， "def" ，空字符串，并"ghi" 。

        结果
        令牌串的顺序流
        异常
        IllegalStateException - 如果此扫描仪已关闭
        从以下版本开始：
        9

      • findAll

        public Stream<MatchResult> findAll​(Pattern pattern)
        返回此扫描仪的匹配结果流。 该流包含相同的结果，只要findWithinHorizon()发现匹配，则依次调用findWithinHorizon(pattern, 0)然后match()返回相同的顺序。

        生成的流是顺序的和有序的。 所有流元素都不为空。

        使用该扫描仪的当前状态，在启动终端流操作时开始扫描。 随后调用此扫描仪上除close()和ioException()之外的任何方法可能会返回未定义的结果，或可能对返回的流造成未定义的影响。 返回的流的源Spliterator是故障快速的 ，如果在流管道执行期间检测到任何这样的呼叫，将尽力而为地抛出ConcurrentModificationException 。

        在流管道执行完成后，该扫描器处于不确定状态，不能重复使用。

        如果此扫描仪包含必须释放的资源，则应关闭此扫描仪，方法是通过调用其close()方法或关闭返回的流。 关闭流将关闭底层扫描程序。 如果调用此方法时扫描仪已关闭，或者在流管道执行期间此扫描器关闭，则抛出IllegalStateException 。

        与findWithinHorizon()方法一样，此方法可能会阻止等待其他输入，并可能缓冲无限量的输入搜索匹配。

        API Note:
        例如，以下代码将读取一个文件，并返回由七个或更多拉丁大写字母组成的所有字符序列的列表：
           try (Scanner sc = new Scanner(Paths.get("input.txt"))) { Pattern pat = Pattern.compile("[A-Z]{7,}"); List<String> capWords = sc.findAll(pat) .map(MatchResult::group) .collect(Collectors.toList()); }
        参数
        pattern - 要匹配的模式
        结果
        顺序的匹配结果流
        异常
        NullPointerException - 如果pattern为null
        IllegalStateException - 如果此扫描仪已关闭
        从以下版本开始：
        9

      • findAll

        public Stream<MatchResult> findAll​(String patString)
        返回与提供的模式字符串相匹配的匹配结果流。 效果等同于以下代码：
           scanner.findAll(Pattern.compile(patString))
        参数
        patString - 模式字符串
        结果
        顺序的匹配结果流
        异常
        NullPointerException - 如果patString为空
        IllegalStateException - 如果此扫描仪已关闭
        PatternSyntaxException - 如果正则表达式的语法无效
        从以下版本开始：
        9
        另请参见：
        Pattern
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServiceConfigurationError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class ServiceConfigurationError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.util.ServiceConfigurationError
  • All Implemented Interfaces:
    Serializable

    public class ServiceConfigurationError
extends Error
    在查找，加载或实例化服务提供商时发生错误时发生错误。
    从以下版本开始：
    1.6
    另请参见：
    ServiceLoader ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ServiceConfigurationError​(String msg)
      使用指定的消息构造新的实例。
      ServiceConfigurationError​(String msg, Throwable cause)
      构造具有指定消息和原因的新实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ServiceConfigurationError

        public ServiceConfigurationError​(String msg)
        使用指定的消息构造新的实例。
        参数
        msg - 消息，或 null如果没有消息

      • ServiceConfigurationError

        public ServiceConfigurationError​(String msg,
                                 Throwable cause)
        构造具有指定消息和原因的新实例。
        参数
        msg - 该消息，或 null如果没有消息
        cause - 原因，或 null如果原因不存在或未知
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServiceLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class ServiceLoader<S>

  • java.lang.Object
    • java.util.ServiceLoader<S>
  • 参数类型
    S - 此装载机要加载的服务类型
    All Implemented Interfaces:
    Iterable<S>

    public final class ServiceLoader<S>
extends Object
implements Iterable<S>
    一种加载服务实现的工具。

    服务是一个众所周知的接口或类，零，一个或多个服务提供商存在。 一个服务提供者 （或只是提供者 ）是一个实现或者分类着名的接口或类的类。 A ServiceLoader是在应用程序选择时定位并加载部署在运行时环境中的服务提供者的对象。 应用程序代码仅指服务，而不是服务提供商，并假设能够区分多个服务提供商，以及处理没有服务提供商所在的可能性。

    获取服务装载程序

    一个应用程序通过调用的静态一个获得用于给定服务的服务加载器load的ServiceLoader的方法。 如果应用程序是模块，则其模块声明必须具有指定该服务的uses指令; 这有助于定位提供商并确保它们能够可靠地执行。 另外，如果服务不在应用程序模块中，则模块声明必须具有指定导出服务的模块的require指令。

    可以使用服务装载器通过iterator方法来定位和实例化服务提供者。 ServiceLoader还定义了stream方法来获取可以在不进行实例化的情况下进行检查和筛选的提供程序流。

    例如，假设该服务是com.example.CodecFactory ，这个接口定义了生成编码器和解码器的方法：

       package com.example; public interface CodecFactory { Encoder getEncoder(String encodingName); Decoder getDecoder(String encodingName); }

    以下代码获取CodecFactory服务的服务加载程序，然后使用其迭代器（由enhanced-for循环自动创建）来生成位于以下位置的服务提供程序的实例：

       ServiceLoader<CodecFactory> loader = ServiceLoader.load(CodecFactory.class); for (CodecFactory factory : loader) { Encoder enc = factory.getEncoder("PNG"); if (enc != null) ... use enc to encode a PNG file break; }

    如果该代码驻留在一个模块中，那么为了引用com.example.CodecFactory接口，模块声明将要求导出该接口的模块。 模块声明还将指定使用com.example.CodecFactory ：

       requires com.example.codec.core; uses com.example.CodecFactory;

    有时，应用程序可能希望在实例化之前检查服务提供商，以确定该服务提供商的实例是否有用。 例如，能够产生“PNG”编码器的CodecFactory的服务提供商可以用@PNG来注释。 以下代码使用服务加载器的stream方法来产生Provider<CodecFactory>实例，与迭代器如何生成CodecFactory实例CodecFactory ：

       ServiceLoader<CodecFactory> loader = ServiceLoader.load(CodecFactory.class); Set<CodecFactory> pngFactories = loader .stream() // Note a below .filter(p -> p.type().isAnnotationPresent(PNG.class)) // Note b .map(Provider::get) // Note c .collect(Collectors.toSet());
    1. 一串Provider<CodecFactory>对象
    2. p.type()得到一个Class<CodecFactory>
    3. get()产生的一个实例CodecFactory

    设计服务

    服务是一种单一类型，通常是一个接口或抽象类。 可以使用一个具体的类，但不建议这样做。 该类型可能具有任何可访问性。 服务的方法是高度域特定的，所以这个API规范不能给出关于它们的形式或功能的具体建议。 但是，有两个一般准则：

    1. 服务应根据需要声明尽可能多的方法，以允许服务提供商传达其域特定属性和其他实施质量因素。 获得服务的服务加载器的应用可以随后在服务提供商的每个实例上调用这些方法，以便为该应用选择最佳提供者。

    2. 服务应该表示其服务提供商是否打算直接执行服务，或者是一个间接机制，如“代理”或“工厂”。 当特定于域的对象实例化时，服务提供商往往是间接机制; 在这种情况下，服务应该被设计为使得服务提供商是抽象的，从而根据需要创建“真正的”实现。 例如， CodecFactory服务通过其名称表示，其服务提供商是编解码器的工厂，而不是编解码器本身，因为产生某些编解码器可能是昂贵的或复杂的。

    Developing service providers

    一个服务提供者是一个单一的类型，通常是一个具体的类。 允许接口或抽象类，因为它可以声明静态提供者方法，稍后再讨论。 该类型必须是public，不能是内部类。

    服务提供商及其支持代码可以在模块中开发，然后将其部署在应用模块路径上或模块化图像中。 或者，服务提供商及其支持代码可以打包为JAR文件并部署在应用程序类路径上。 在模块中开发服务提供商的优点是提供者可以被完全封装，以隐藏其实现的所有细节。

    获取给定服务的服务加载程序的应用程序对于服务提供者是否部署在模块中或打包为JAR文件无关紧要。 该应用程序通过服务加载器的迭代器或服务加载器的流中的Provider对象来实例化服务提供者，而不了解服务提供商的位置。

    将服务提供商部署为模块

    这是一个模块中开发的服务供应商必须指定一个在模块的声明提供了指导。 Provide指令指定服务和服务提供者; 这有助于定位提供者，当另一个模块（ 使用服务的使用指令）获取服务的服务装载程序时。 强烈建议模块不导出包含服务提供者的软件包。 不支持在一个提供指令中指定另一个模块中的服务提供者的模块。

    在模块中开发的服务提供商无法控制何时被实例化，因为这是在应用程序的要求下发生的，但它可以控制如何实例化：

    • 如果服务提供者声明一个提供者方法，则服务加载器调用该方法来获取服务提供者的一个实例。 提供者方法是一个名为“provider”的公共静态方法，没有正式参数和可分配给服务的接口或类的返回类型。

      在这种情况下，服务提供商本身不需要分配给服务的接口或类。

    • 如果服务提供商没有声明提供者方法，则通过其提供者构造函数直接实例化服务提供者。 提供者构造函数是没有形式参数的公共构造函数。

      在这种情况下，服务提供商必须可以分配给服务的接口或类

    在应用程序模块路径上部署为automatic module的服务提供商必须具有提供者构造函数。 在这种情况下，不支持提供者方法。

    例如，假设一个模块指定了以下指令：

       provides com.example.CodecFactory with com.example.impl.StandardCodecs; provides com.example.CodecFactory with com.example.impl.ExtendedCodecsFactory;

    哪里

    • com.example.CodecFactory是早期的两种方法服务。
    • com.example.impl.StandardCodecs是一个实现CodecFactory并具有公共无参数构造函数的公共类。
    • com.example.impl.ExtendedCodecsFactory是一个不实现CodecFactory的公共类，但它声明一个名为“provider”的public static no-args方法，返回类型为CodecFactory 。

    服务加载器将通过其构造函数实例化StandardCodecs ，并通过调用其provider方法来实例化ExtendedCodecsFactory 。 提供者构造函数或提供者方法的公开要求有助于记录类（即服务提供者）将被类的包之外的实体（即服务加载器）实例化的意图。

    在类路径上部署服务提供者

    通过在资源目录META-INF/services放置提供者配置文件来标识作为类路径的JAR文件打包的服务提供程序。 提供者配置文件的名称是服务的完全限定二进制名称。 提供者配置文件包含服务提供商的全限定二进制名称列表，每行一个。

    例如，假设服务提供商com.example.impl.StandardCodecs封装在类路径的JAR文件中。 JAR文件将包含一个名为：

    META-INF/services/com.example.CodecFactory
    包含行：
    com.example.impl.StandardCodecs # Standard codecs

    The provider-configuration file must be encoded in UTF-8.每个服务提供商名称以及空白行周围的空格和制表符字符将被忽略。 评论的字符是'#' （ '&#92;u0023' NUMBER SIGN ）; 在每行上，忽略第一个注释字符之后的所有字符。 如果服务提供商类名在提供者配置文件中多次列出，那么该副本将被忽略。 如果服务提供程序类在多个配置文件中命名，那么该副本将被忽略。

    提供者配置文件中提到的服务提供商可能位于与提供商配置文件相同的JAR文件中，或位于不同的JAR文件中。 服务提供者必须从初始查询的类加载器中可见，以查找提供者配置文件; 这不一定是最终找到提供者配置文件的类加载器。

    提供商发现的时间安排

    服务提供商懒惰地加载和实例化，也就是按需。 服务加载器维护到目前为止已经加载的提供程序的缓存。 iterator方法的每次调用iterator返回一个Iterator ，它首先从实例化顺序中获取先前迭代中缓存的所有元素，然后依次放置并实例化任何剩余的提供程序，并将其逐个添加到缓存中。 类似地，流方法的每次调用都返回一个Stream ，它首先处理以先前的流操作加载的所有提供商，并按照加载顺序进行处理，然后懒洋洋地定位任何剩余的提供程序。 缓存通过reload方法清除。

    Errors

    当使用服务加载程序的iterator ，如果在定位，加载或实例化服务提供商处发生错误，则hasNext和next方法将失败，并显示ServiceConfigurationError 。 在处理服务加载程序的流时，可能会导致任何导致服务提供程序找到或加载的方法抛出ServiceConfigurationError 。

    在模块中加载或实例化服务提供商时，可能会抛出ServiceConfigurationError ，原因如下：

    • 服务提供商无法加载。
    • 服务提供商不声明提供者方法，并且它不能分配给服务的接口/类或没有提供者构造函数。
    • 服务提供者声明一个名为“provider”的public static no-args方法，其返回类型不能分配给服务的接口或类。
    • 服务提供程序类文件具有多个名为“ provider ”的公共静态无参数方法。
    • 服务提供商声明提供程序方法，并且返回null或抛出异常失败。
    • 服务提供商没有声明提供者方法，并且其提供者构造函数通过抛出异常而失败。

    当读取提供者配置文件，或加载或实例化提供者配置文件中命名的提供程序类时，可以抛出ServiceConfigurationError ，原因如下：

    • 提供者配置文件的格式违反上述format ;
    • 读取提供者配置文件时发生IOException ;
    • 服务提供商无法加载;
    • 服务提供者不能分配给服务的接口或类，或者不定义提供者构造函数，也不能被实例化。

    安全

    服务加载器总是在迭代器或流方法的调用者的安全上下文中执行，并且还可能受到创建服务加载器的调用者的安全上下文的限制。 受信任的系统代码应通常调用此类中的方法，以及从特权安全上下文中返回的迭代器的方法。

    并发

    此类的实例不能安全地被多个并发线程使用。

    空处理

    除非另有说明，否则传递一个null参数到null中的任何方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static interface  ServiceLoader.Provider<S>
      代表由 ServiceLoader位于的服务提供商。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Optional<S> findFirst​()
      加载此装载程序服务的第一个可用服务提供商。
      Iterator<S> iterator​()
      返回一个迭代器来懒洋洋地加载和实例化此加载程序服务的可用提供程序。
      static <S> ServiceLoader<S> load​(Class<S> service)
      使用当前线程的 context class loader为给定的服务类型创建一个新的服务加载器。
      static <S> ServiceLoader<S> load​(Class<S> service, ClassLoader loader)
      为给定的服务创建一个新的服务加载器。
      static <S> ServiceLoader<S> load​(ModuleLayer layer, Class<S> service)
      为给定的服务类型创建新的服务加载器，以便从给定模块层及其祖先的模块加载服务提供者。
      static <S> ServiceLoader<S> loadInstalled​(Class<S> service)
      使用 platform class loader为给定的服务类型创建一个新的服务加载程序。
      void reload​()
      清除此加载程序的提供程序缓存，以便所有提供程序都将被重新加载。
      Stream<ServiceLoader.Provider<S>> stream​()
      返回一个流，以延迟加载此加载程序服务的可用提供程序。
      String toString​()
      返回描述此服务的字符串。

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • iterator

        public Iterator<S> iterator​()
        返回一个迭代器来懒洋洋地加载和实例化此加载程序服务的可用提供程序。

        为了实现懒惰，定位和实例化提供者的实际工作是由迭代器本身完成的。 因此，其hasNext和next方法因为上述Errors部分规定的任何原因可能会抛出ServiceConfigurationError 。 要编写稳健的代码，只需要在使用迭代器时捕获ServiceConfigurationError 。 如果抛出错误，则迭代器的后续调用将尽力定位和实例化下一个可用提供程序，但一般来说，这种恢复无法保证。

        缓存：此方法返回的迭代器首先按照加载顺序生成提供程序缓存的所有元素。 然后它懒惰地加载和实例化任何剩余的服务提供商，依次添加每个服务提供商到缓存。 如果通过调用reload方法来清除此加载程序的提供程序缓存，则应丢弃此服务加载程序的现有迭代器。 迭代器的hasNext和next方法抛出ConcurrentModificationException，如果在提供程序缓存已清除之后使用。

        该方法返回的迭代器不支持删除。 调用其remove方法将导致抛出UnsupportedOperationException 。

        Specified by:
        iterator在接口 Iterable<S>
        API Note:
        在这些情况下投掷错误似乎是极端的。 这种行为的原因是，格式错误的提供商配置文件（如格式错误的类文件）表明Java虚拟机配置或正在使用的方式存在严重问题。 因此，最好抛出一个错误，而不是试图恢复，或者更糟的是，默默地失败。
        结果
        一个迭代器，它为这个加载程序的服务懒惰地加载提供程序

      • stream

        public Stream<ServiceLoader.Provider<S>> stream​()
        返回一个流，以延迟加载此加载程序服务的可用提供程序。 流元素的类型为Provider ，必须调用Provider的get方法来获取或实例化提供者。

        为了实现懒惰，定位提供商的实际工作在处理流时完成。 如果服务提供商不能被加载用于任何的在指定的原因Errors部则上述ServiceConfigurationError通过任何方法引发造成要加载的服务提供商。

        缓存：处理流时，先前通过流操作加载的提供者按加载顺序进行处理。 然后它懒惰地加载任何剩余的服务提供商。 如果通过调用reload方法来清除此加载程序的提供程序缓存，则该服务加载程序的现有流应该被丢弃。 返回的流的源spliterator是故障快速的 ，如果提供程序缓存已被清除，将抛出ConcurrentModificationException 。

        以下示例演示了如何使用。 第一个示例创建一个CodecFactory对象的流，第二个示例是相同的，除了它按提供程序类名排序提供程序（并且因此定位所有提供程序）。

           Stream<CodecFactory> providers = ServiceLoader.load(CodecFactory.class) .stream() .map(Provider::get); Stream<CodecFactory> providers = ServiceLoader.load(CodecFactory.class) .stream() .sorted(Comparator.comparing(p -> p.type().getName())) .map(Provider::get);
        结果
        一个流懒惰地为这个装载机的服务加载提供商
        从以下版本开始：
        9

      • load

        public static <S> ServiceLoader<S> load​(Class<S> service,
                                        ClassLoader loader)
        为给定的服务创建一个新的服务加载器。 服务加载器使用给定的类加载器作为起始点来定位服务的服务提供者。 服务装载程序的iterator和stream在命名模块和未命名模块中查找提供程序，如下所示：

        • 步骤1：找到命名模块中的提供程序。

          服务提供商位于类加载器的所有命名模块中，或者通过父代理可访问的任何类加载器。

          另外，如果类加载器不是引导或platform class loader ，则服务提供者可能位于其他类加载器的命名模块中。 具体来说，如果通过父委托可以访问类加载器或任何类加载器，则在module layer中具有一个模块，则会定位模块层中所有模块中的服务提供程序。

          例如，假设有一个模块层，每个模块都在其自己的类加载器中（参见defineModulesWithManyLoaders ）。 如果调用此ServiceLoader.load方法来定位使用为模块层创建的任何类加载器的提供程序，则它将定位模块层中的所有提供程序，而不管其定义的类加载器如何。

          订购：服务加载程序将首先将定义的模块中的任何服务提供者定位到类加载器，然后将其父类加载器，其父父等等定位到引导类加载器。 如果类加载器在模块层中具有模块，则在父类加载器中的提供程序位于之前，该模块层中的所有提供程序都位于（不管其类加载器）。 没有定义同一类加载器中的模块的顺序，或模块中模块的顺序。

          如果一个模块声明一个以上的提供者，那么提供者就按其模块描述符lists the providers的顺序排列 。 由仪器代理商（见redefineModule ）动态添加的供应商始终位于由模块声明的提供者之后。

        • 步骤2：找到未命名模块中的提供程序。

          如果他们的类名被列在由类加载器的getResources方法定位的提供者配置文件中，那么它们将定位未命名模块中的服务提供者。

          排序是基于类加载器的getResources方法查找服务配置文件的顺序，以及该类名称在文件中列出的顺序。

          在提供商配置文件中，任何提及部署在命名模块中的服务提供商都将被忽略。 这是为了避免当命名模块具有提供相同服务提供者的提供指令和提供者配置文件时会出现的重复。

          提供者类必须对类加载器可见。

        API Note:
        如果类加载器的类路径包括远程网络URL，那么在搜索提供商配置文件的过程中可以取消引用这些URL。

        此活动是正常的，尽管它可能会导致在Web服务器日志中创建令人困惑的条目。 但是，如果Web服务器配置不正确，则此活动可能导致提供程序加载算法发生故障。

        当所请求的资源不存在时，Web服务器应返回HTTP 404（未找到）响应。 然而，有时，网络服务器错误地配置为在这种情况下返回HTTP 200（OK）响应以及有用的HTML错误页面。 当这个类尝试解析HTML页面作为提供者配置文件时，这将导致抛出ServiceConfigurationError 。 解决此问题的最佳方法是修复配置错误的Web服务器以返回正确的响应代码（HTTP 404）以及HTML错误页面。

        参数类型
        S - 服务类型的类
        参数
        service - 表示服务的接口或抽象类
        loader - 用于加载提供程序配置文件和提供程序类的类加载器，如果要使用系统类加载器（或者不能使用引导类加载器）， null ）
        结果
        一个新的服务装载机
        异常
        ServiceConfigurationError - 如果服务类型不可访问调用者或调用者在显式模块中，并且其模块描述符不声明它使用 service

      • load

        public static <S> ServiceLoader<S> load​(Class<S> service)
        使用当前线程的context class loader为给定的服务类型创建一个新的服务加载器。

        调用这种方便的方式的形式

           ServiceLoader.load(service)
        相当于
           ServiceLoader.load(service, Thread.currentThread().getContextClassLoader())
        API Note:
        使用此方法获取的服务装载器对象不应该在VM范围内缓存。 例如，同一VM中的不同应用程序可能具有不同的线程上下文类加载器。 一个应用程序的查找可以定位仅通过其线程上下文类加载器可见的服务提供者，因此不适合被其他应用程序定位。 内存泄漏也可能出现。 本地线程可能适用于某些应用。
        参数类型
        S - 服务类型的类
        参数
        service - 表示服务的接口或抽象类
        结果
        一个新的服务装载机
        异常
        ServiceConfigurationError - 如果调用者不能访问服务类型，或者调用者在显式模块中，并且其模块描述符不声明它使用 service

      • loadInstalled

        public static <S> ServiceLoader<S> loadInstalled​(Class<S> service)
        使用platform class loader为给定的服务类型创建一个新的服务加载程序。

        这种方便方法相当于：

           ServiceLoader.load(service, ClassLoader.getPlatformClassLoader())

        此方法仅在需要安装的提供程序时使用。 所产生的服务将只找到并加载已安装到当前Java虚拟机中的提供程序; 应用程序的模块路径或类路径上的提供程序将被忽略。

        参数类型
        S - 服务类的类
        参数
        service - 表示服务的接口或抽象类
        结果
        一个新的服务装载机
        异常
        ServiceConfigurationError - 如果调用者不能访问服务类型，或者调用者在显式模块中，并且其模块描述符不声明它使用 service

      • load

        public static <S> ServiceLoader<S> load​(ModuleLayer layer,
                                        Class<S> service)
        为给定的服务类型创建新的服务加载器，以便从给定模块层及其祖先的模块加载服务提供者。 它没有将提供程序定位在未命名的模块中。 服务加载程序的iterator和stream定位提供程序和yield元素的顺序如下：

        • 在父层中定位提供商之前，提供者位于模块层中。 父层的遍历是深度优先的，每层访问最多一次。 例如，假设L0是引导层，L1和L2是以L0为父的模块层。 现在假设L3以L1和L2为父（以该顺序）创建。 使用服务加载程序定位具有L3作为上下文的提供商将按以下顺序定位提供商：L3，L1，L0，L2。

        • 如果一个模块声明多个提供者，那么提供者按照其模块描述符lists the providers的顺序进行定位 。 由仪器代理商动态添加的提供商始终位于模块声明的提供者之后。

        • 未定义模块中模块的顺序。

        API Note:
        与此处定义的其他加载方法不同，服务类型是第二个参数。 原因是为了避免使用load(S, null)代码的源兼容性问题。
        参数类型
        S - 服务类的类
        参数
        layer - 模块层
        service - 表示服务的接口或抽象类
        结果
        一个新的服务装载机
        异常
        ServiceConfigurationError - 如果调用者不能访问服务类型，或者调用者在显式模块中，并且其模块描述符不声明它使用 service
        从以下版本开始：
        9

      • findFirst

        public Optional<S> findFirst​()
        加载此装载程序服务的第一个可用服务提供商。 这种方便方法等同于调用iterator()方法并获得第一个元素。 因此，如果可能，它会从提供程序缓存返回第一个元素，否则将尝试加载和实例化第一个提供程序。

        以下示例加载了第一个可用的服务提供者。 如果没有服务提供商，那么它使用默认实现。

           CodecFactory factory = ServiceLoader.load(CodecFactory.class) .findFirst() .orElse(DEFAULT_CODECSET_FACTORY);
        结果
        第一个服务提供商或空 Optional如果没有服务提供商）
        异常
        ServiceConfigurationError - 如果由于上述 Errors部分中指定的任何原因而无法加载提供者类。
        从以下版本开始：
        9

      • reload

        public void reload​()
        清除此加载程序的提供程序缓存，以便所有提供程序都将被重新加载。

        调用此方法后，随后调用iterator或stream方法将会从头开始iterator定位提供程序（并在iterator的情况下实例化），就像新创建的服务加载程序一样。

        此方法适用于将新服务提供程序安装到正在运行的Java虚拟机中的情况。

      • toString

        public String toString​()
        返回描述此服务的字符串。
        重写：
        toString在 Object
        结果
        A descriptive string
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServiceLoader.Provider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface ServiceLoader.Provider<S>

  • 参数类型
    S - 服务类型
    All Superinterfaces:
    Supplier<S>
    Enclosing class:
    ServiceLoader < S >

    public static interface ServiceLoader.Provider<S>
extends Supplier<S>
    代表由ServiceLoader位于的服务提供商。

    当使用加载程序的stream()方法时，元素的类型为Provider 。 这允许处理在提供程序类上选择或过滤，而不实例化提供程序。

    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      S get​()
      返回提供者的一个实例。
      Class<? extends S> type​()
      返回提供者类型。

    • 方法详细信息

      • type

        Class<? extends S> type​()
        返回提供者类型。 不能保证此类型是可访问的，或者它具有公共无参数构造函数。 应该使用get()方法来获取提供者实例。

        当模块声明提供者类由提供者工厂创建时，该方法返回其公共静态“ provider() ”方法的返回类型。

        结果
        提供者类型

      • get

        S get​()
        返回提供者的一个实例。
        Specified by:
        get在接口 Supplier<S>
        结果
        提供者的一个实例。
        异常
        ServiceConfigurationError - If the service provider cannot be instantiated, or in the case of a provider factory, the public static " provider()" method returns null or throws an error or exception. The ServiceConfigurationError will carry an appropriate cause where possible.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Set (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Set<E>

  • 参数类型
    E - 由此集合维护的元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E>
    All Known Subinterfaces:
    EventSet ， NavigableSet<E> ， ObservableSet<E> ， ObservableSetValue<E> ， SortedSet<E> ， WritableSetValue<E>
    所有已知实现类：
    AbstractSet ， ConcurrentHashMap.KeySetView ， ConcurrentSkipListSet ， CopyOnWriteArraySet ， EnumSet ， HashSet ， JobStateReasons ， LinkedHashSet ， ReadOnlySetProperty ， ReadOnlySetPropertyBase ， ReadOnlySetWrapper ， SetBinding ， SetExpression ， SetProperty ， SetPropertyBase ， SimpleSetProperty ， TreeSet

    public interface Set<E>
extends Collection<E>
    不包含重复元素的集合。 更正式地，集合不包含一对元素e1和e2 ，使得e1.equals(e2) ，并且最多只有一个空元素。 正如其名称所暗示的那样，这个接口模拟了数学集抽象。

    该Set接口放置额外的约定，超过从继承Collection接口，所有构造函数的合同，而位于该合同add ， equals和hashCode方法。 其他继承方法的声明也包括在这里以方便。 （这些声明中附带的规格已针对Set接口进行了定制，但不包含任何其他规定。）

    构造函数的额外规定并不奇怪，所有构造函数都必须创建一个不包含重复元素的集合（如上所定义）。

    注意：如果可变对象用作设置元素，则必须非常小心。 如果对象的值以影响equals比较的方式更改，而对象是集合中的元素，则不指定集合的行为。 这种禁止的一个特殊情况是，一个集合不允许将其本身作为一个元素。

    一些集合实现对它们可能包含的元素有限制。 例如，一些实现禁止空元素，有些实现对元素的类型有限制。 尝试添加不合格元素会引发未经检查的异常，通常为NullPointerException或ClassCastException 。 尝试查询不合格元素的存在可能会引发异常，或者可能只是返回false; 一些实现将展现出前者的行为，一些实现将展现出后者。 更一般来说，尝试对不符合条件的元素的操作，其完成不会导致不合格元素插入到集合中，可能会导致异常，或者可能会成功执行该选项。 此异常在此接口的规范中标记为“可选”。

    Immutable Set Static Factory Methods

    27064454984920静态工厂方法提供了创建不可变集合的便捷方式。 由这些方法创建的Set实例具有以下特征：

    • 它们在结构上是不可变的 。 元素无法添加或删除。 调用任何mutator方法将总是导致UnsupportedOperationException被抛出。 但是，如果包含的元素本身是可变的，这可能会导致Set的行为不一致或其内容看起来会发生变化。
    • 他们不允许null元素。 尝试使用null元素创建它们将导致NullPointerException 。
    • 如果所有元素是可序列化的，它们是可序列化的。
    • 他们在创建时拒绝重复的元素。 传递给静态工厂方法的重复元素将导致IllegalArgumentException 。
    • 集合元素的迭代顺序未指定，可能会更改。
    • 他们是value-based 。 调用者不应该对返回的实例的身份进行假设。 工厂可以自由创建新的实例或重用现有的实例。 因此，对这些实例的身份敏感操作（引用等式（ == ），身份哈希码和同步）是不可靠的，应该避免。
    • 它们按Serialized Form页面的规定进行序列化。

    此界面是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， List ， SortedSet ， HashSet ， TreeSet ， AbstractSet ， Collections.singleton(java.lang.Object) ， Collections.EMPTY_SET

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean add​(E e)
      如果指定的元素不存在，则将其指定的元素添加（可选操作）。
      boolean addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合（如果尚未存在）（可选操作）。
      void clear​()
      从此集合中删除所有元素（可选操作）。
      boolean contains​(Object o)
      如果此集合包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> c)
      如果此集合包含指定集合的所有元素，则返回 true 。
      boolean equals​(Object o)
      将指定的对象与此集合进行比较以实现相等。
      int hashCode​()
      返回此集合的哈希码值。
      boolean isEmpty​()
      如果此集合不包含元素，则返回 true 。
      Iterator<E> iterator​()
      返回此集合中元素的迭代器。
      static <E> Set<E> of​()
      返回一个包含零个元素的不可变集合。
      static <E> Set<E> of​(E e1)
      返回一个包含一个元素的不可变集合。
      static <E> Set<E> of​(E... elements)
      返回一个包含任意数量元素的不可变集合。
      static <E> Set<E> of​(E e1, E e2)
      返回一个包含两个元素的不可变集合。
      static <E> Set<E> of​(E e1, E e2, E e3)
      返回一个包含三个元素的不可变集合。
      static <E> Set<E> of​(E e1, E e2, E e3, E e4)
      返回一个包含四个元素的不可变集合。
      static <E> Set<E> of​(E e1, E e2, E e3, E e4, E e5)
      返回一个包含五个元素的不可变集合。
      static <E> Set<E> of​(E e1, E e2, E e3, E e4, E e5, E e6)
      返回一个包含六个元素的不可变集合。
      static <E> Set<E> of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7)
      返回一个包含七个元素的不可变集合。
      static <E> Set<E> of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8)
      返回一个包含八个元素的不可变集合。
      static <E> Set<E> of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8, E e9)
      返回一个包含九个元素的不可变集合。
      static <E> Set<E> of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8, E e9, E e10)
      返回一个包含十个元素的不可变集合。
      boolean remove​(Object o)
      如果存在，则从该集合中删除指定的元素（可选操作）。
      boolean removeAll​(Collection<?> c)
      从此集合中删除指定集合中包含的所有元素（可选操作）。
      boolean retainAll​(Collection<?> c)
      仅保留该集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此集合中的元素数（其基数）。
      default Spliterator<E> spliterator​()
      在此集合中的元素上创建一个 Spliterator 。
      Object[] toArray​()
      返回一个包含此集合中所有元素的数组。
      <T> T[] toArray​(T[] a)
      返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

    • 方法详细信息

      • size

        int size​()
        返回此集合中的元素数（其基数）。 如果这个集合包含Integer.MAX_VALUE元素，返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<E>
        结果
        该集合中的元素数（其基数）

      • isEmpty

        boolean isEmpty​()
        如果此集合不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        结果
        true如果此集合不包含元素

      • contains

        boolean contains​(Object o)
        如果此集合包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此set包含的元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        参数
        o - 要在此集合中存在的元素要进行测试
        结果
        true如果这个集合包含指定的元素
        异常
        ClassCastException - 如果指定元素的类型与此集不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且该集合不允许空元素（ optional ）

      • iterator

        Iterator<E> iterator​()
        返回此集合中元素的迭代器。 元素没有特定的顺序返回（除非此集合是提供保证的某个类的实例）。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        结果
        这个集合中的元素的迭代器

      • toArray

        Object[] toArray​()
        返回一个包含此集合中所有元素的数组。 如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        返回的数组将是“安全的”，因为该集合不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组，即使这个数组是由数组支持的）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        结果
        一个包含此集合中所有元素的数组

      • toArray

        <T> T[] toArray​(T[] a)
        返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果集合适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此集合的大小分配一个新数组。

        如果这个集合适合指定的数组，有空余的空间（即，该数组的元素多于此集合），紧随集合结束后的数组中的元素设置为null 。 （这仅在调用者知道此集合不包含任何空元素时才可用于确定此集合的长度。）

        如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的集合。 以下代码可用于将集合转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储此集合的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此集合中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此集合中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • add

        boolean add​(E e)
        如果指定的元素不存在，则将其指定的元素添加（可选操作）。 更正式地，将指定的元素e这一套如果集合不包含元素e2这样Objects.equals(e, e2) 。 如果该集合已经包含该元素，则该呼叫将保持不变，并返回false 。 结合对构造函数的限制，这样可以确保集合不会包含重复的元素。

        上述规定并不意味着集合必须接受所有要素; 集合可以拒绝添加任何特定元素，包括null ，并抛出异常，如Collection.add的规范中所述 。 单个集合实现应清楚地记录对它们可能包含的元素的任何限制。

        Specified by:
        add在接口 Collection<E>
        参数
        e - 要添加到此集合的元素
        结果
        true如果此集合尚未包含指定的元素
        异常
        UnsupportedOperationException - 如果此 add不支持 add操作
        ClassCastException - 如果指定元素的类阻止将其添加到此集合
        NullPointerException - 如果指定的元素为空，并且该集合不允许空元素
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此集合中

      • remove

        boolean remove​(Object o)
        如果存在，则从该集合中删除指定的元素（可选操作）。 更正式地，删除一个元素e ，使Objects.equals(o, e) ，如果这个集合包含这样一个元素。 返回true如果这个集合包含元素（或者等效地，如果这个集合由于调用而改变）。 （一旦调用返回，此集合将不包含该元素。）
        Specified by:
        remove在接口 Collection<E>
        参数
        o - 要从此集合中删除的对象（如果存在）
        结果
        true如果这个集合包含指定的元素
        异常
        ClassCastException - 如果指定元素的类型与此集不兼容（ optional ）
        NullPointerException - 如果指定的元素为空，并且该集合不允许空元素（ optional ）
        UnsupportedOperationException - 如果此集合不支持 remove操作

      • containsAll

        boolean containsAll​(Collection<?> c)
        如果此集合包含指定集合的所有元素，则返回true 。 如果指定的集合也是一个集合，如果它是该集合的子集，则此方法返回true 。
        Specified by:
        containsAll在接口 Collection<E>
        参数
        c - 要在此集合中检查遏制的集合
        结果
        true如果此集合包含指定集合的所有元素
        异常
        ClassCastException - 如果指定集合中的一个或多个元素的类型与此集不兼容（ optional ）
        NullPointerException - 如果指定的集合包含一个或多个空元素，并且此集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        contains(Object)

      • addAll

        boolean addAll​(Collection<? extends E> c)
        将指定集合中的所有元素添加到此集合（如果尚未存在）（可选操作）。 如果指定的集合也是集合，则addAll操作有效地修改该集合，使其值是两个集合的并集。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        addAll在接口 Collection<E>
        参数
        c - 包含要添加到此集合的元素的集合
        结果
        true如果此设置由于呼叫而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 addAll操作
        ClassCastException - 如果指定集合的元素的类阻止将其添加到此集合
        NullPointerException - 如果指定的集合包含一个或多个空元素，并且此集合不允许空元素，或者如果指定的集合为空
        IllegalArgumentException - 如果指定集合的元素的某些属性阻止将其添加到此集合
        另请参见：
        add(Object)

      • retainAll

        boolean retainAll​(Collection<?> c)
        仅保留该集合中包含在指定集合中的元素（可选操作）。 换句话说，从这个集合中删除它不包含在指定集合中的所有元素。 如果指定的集合也是一个集合，则此操作有效地修改该集合，使其值是两组的交集 。
        Specified by:
        retainAll在接口 Collection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果此设置由于调用而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 retainAll操作
        ClassCastException - 如果此集合的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此集合包含空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object)

      • removeAll

        boolean removeAll​(Collection<?> c)
        从此集合中删除指定集合中包含的所有元素（可选操作）。 如果指定的集合也是集合，则该操作有效地修改该集合，使其值是两组的非对称集合差异 。
        Specified by:
        removeAll在接口 Collection<E>
        参数
        c - 包含要 c集合中删除的元素的集合
        结果
        true如果此设置由于呼叫而更改
        异常
        UnsupportedOperationException - 如果此集合不支持 removeAll操作
        ClassCastException - 如果此集合的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此集合包含空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object) ， contains(Object)

      • clear

        void clear​()
        从此集合中删除所有元素（可选操作）。 此呼叫返回后，该组将为空。
        Specified by:
        clear在接口 Collection<E>
        异常
        UnsupportedOperationException - 如果此集合不支持 clear方法

      • equals

        boolean equals​(Object o)
        将指定的对象与此集合进行比较以实现相等。 如果指定的对象也是一个集合，则返回true ，这两个集合的大小相同，并且指定集合的每个成员都包含在该集合中（或者等效地，该集合的每个成员都包含在指定的集合中）。 此定义可确保equals方法在集合接口的不同实现之间正常工作。
        Specified by:
        equals在接口 Collection<E>
        重写：
        equals在 Object
        参数
        o - 要与此集合相等的对象进行比较
        结果
        true如果指定的对象等于此集合
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此集合的哈希码值。 集合的哈希码被定义为集合中的元素的哈希码的总和，其中null元素的哈希码被定义为零。 这确保s1.equals(s2)意味着s1.hashCode()==s2.hashCode()对于任何两套s1和s2 ，根据s2的一般合同要求 。
        Specified by:
        hashCode在接口 Collection<E>
        重写：
        hashCode在 Object
        结果
        该集合的哈希码值
        另请参见：
        Object.equals(Object) ， equals(Object)

      • spliterator

        default Spliterator<E> spliterator​()
        在此集合中的元素上创建一个Spliterator 。

        Spliterator报告Spliterator.DISTINCT 。 实施应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        实现要求：
        默认实现从集合的Iterator创建了一个late-binding分割Iterator 。 分割器继承集合迭代器的故障快速属性。

        创建的Spliterator另外报告Spliterator.SIZED 。

        Implementation Note:
        创建的 Spliterator另外报告 Spliterator.SUBSIZED 。
        结果
        一个 Spliterator在这个集合中的元素
        从以下版本开始：
        1.8

      • of

        static <E> Set<E> of​()
        返回一个包含零个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        结果
        一个空的 Set
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1)
        返回一个包含一个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 单个元素
        结果
        一个 Set包含指定的元素
        异常
        NullPointerException - 如果元素是 null
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1,
                     E e2)
        返回一个包含两个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果元素是重复的
        NullPointerException - 如果元素是 null
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1,
                     E e2,
                     E e3)
        返回一个包含三个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果有任何重复的元素
        NullPointerException - 如果元素是 null
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1,
                     E e2,
                     E e3,
                     E e4)
        返回一个包含四个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果有任何重复的元素
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1,
                     E e2,
                     E e3,
                     E e4,
                     E e5)
        返回一个包含五个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果有任何重复的元素
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1,
                     E e2,
                     E e3,
                     E e4,
                     E e5,
                     E e6)
        返回一个包含六个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果有任何重复元素
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1,
                     E e2,
                     E e3,
                     E e4,
                     E e5,
                     E e6,
                     E e7)
        返回一个包含七个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        e7 - 第七个元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果有任何重复的元素
        NullPointerException - 如果元素是 null
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1,
                     E e2,
                     E e3,
                     E e4,
                     E e5,
                     E e6,
                     E e7,
                     E e8)
        返回一个包含八个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        e7 - 第七个元素
        e8 - 第八个元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果有任何重复的元素
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1,
                     E e2,
                     E e3,
                     E e4,
                     E e5,
                     E e6,
                     E e7,
                     E e8,
                     E e9)
        返回一个包含九个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        e7 - 第七个元素
        e8 - 第八个元素
        e9 - 第九个元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果有任何重复的元素
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        static <E> Set<E> of​(E e1,
                     E e2,
                     E e3,
                     E e4,
                     E e5,
                     E e6,
                     E e7,
                     E e8,
                     E e9,
                     E e10)
        返回一个包含十个元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        参数类型
        E - Set的元素类型
        参数
        e1 - 第一个元素
        e2 - 第二个元素
        e3 - 第三个元素
        e4 - 第四个元素
        e5 - 第五个元素
        e6 - 第六个元素
        e7 - 第七个元素
        e8 - 第八个元素
        e9 - 第九个元素
        e10 - 第十个元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果有任何重复的元素
        NullPointerException - 如果一个元素是 null
        从以下版本开始：
        9

      • of

        @SafeVarargs
static <E> Set<E> of​(E... elements)
        返回一个包含任意数量元素的不可变集合。 详见Immutable Set Static Factory Methods 。
        API Note:
        该方法也接受一个数组作为参数。 结果集的元素类型将是数组的组件类型，集合的大小将等于数组的长度。 要使用单个元素创建一个数组，请执行以下操作：
           String[] array = ... ; Set<String[]> list = Set.<String[]>of(array);
        这将导致Set.of(E)方法被调用。
        参数类型
        E - Set的元素类型
        参数
        elements - 要包含在集合中的元素
        结果
        一个包含指定元素的 Set
        异常
        IllegalArgumentException - 如果有任何重复元素
        NullPointerException - 如果元素是 null或者数组是 null
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleTimeZone (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class SimpleTimeZone

  • java.lang.Object
    • java.util.TimeZone
      • java.util.SimpleTimeZone
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class SimpleTimeZone
extends TimeZone
    SimpleTimeZone是一个具体子类TimeZone ，表示一个使用格里高利历的时区。 该类保留与GMT的偏移量，称为原始偏移量 ，以及夏令时计划的开始和结束规则。 由于它仅保留每个值的单个值，因此无法处理与GMT和夏令时偏移量的历史更改，但setStartYear方法可指定夏令时开始生效的年份。

    要构建具有夏令时计划的SimpleTimeZone ，可以使用一组规则， 开始规则和最终规则来描述时间表。 夏令时开始或结束的一天由月份 ， 日期和星期几值的组合指定。 月份值由日历MONTH字段值表示，例如Calendar.MARCH 。 星期几值由日历DAY_OF_WEEK值表示，例如SUNDAY 。 价值组合的含义如下。

    • 确切的月份
      要指定一个确切的月份，请将月份和日期设置为确切的值， 将星期几设置为零。 例如，要指定3月1日，将月份设置为MARCH ， 月中的日期为1， 将星期几设置为0。
    • 一个月的一天或之后的一个星期
      要指定一周的某一天或一个月的具体一天后，将month设置为一个具体的月份值， 日的日到应用规则或之后，每天和每周的某一天的到负DAY_OF_WEEK字段值。 例如，要指定四月份的第二个星期日，请将月份设为APRIL ， 月的日期为8， 星期几为- SUNDAY 。
    • 一个月的一天或之前的一个星期
      要指定一个星期的星期几在当天的确切日期之前，请将日期和星期几设置为负值。 例如，要指定3月21日当天或之前的最后一个星期三，设定月份为MARCH ， 当天为-21， 星期几为- WEDNESDAY 。
    • 一个月的最后一个星期
      要指定，本月的最后一个星期几，将星期几设为DAY_OF_WEEK的值和月的日期为-1。 例如，要指定10月的最后一个星期日，请将月份设为OCTOBER ， 周数为SUNDAY ， 日期为-1。
    夏令时开始或结束的一天中的时间由白天内的毫秒值指定。 有三种模式 S的指定时间： WALL_TIME ， STANDARD_TIME和UTC_TIME 。 例如，如果夏令时在挂钟时间的凌晨2点结束，则可以在WALL_TIME模式下指定7200000毫秒。 在这种情况下， 结束规则的挂钟时间意味着与日光时间相同的事情。

    以下是用于构建时区对象的参数示例。

       // Base GMT offset: -8:00 // DST starts: at 2:00am in standard time // on the first Sunday in April // DST ends: at 2:00am in daylight time // on the last Sunday in October // Save: 1 hour SimpleTimeZone(-28800000, "America/Los_Angeles", Calendar.APRIL, 1, -Calendar.SUNDAY, 7200000, Calendar.OCTOBER, -1, Calendar.SUNDAY, 7200000, 3600000) // Base GMT offset: +1:00 // DST starts: at 1:00am in UTC time // on the last Sunday in March // DST ends: at 1:00am in UTC time // on the last Sunday in October // Save: 1 hour SimpleTimeZone(3600000, "Europe/Paris", Calendar.MARCH, -1, Calendar.SUNDAY, 3600000, SimpleTimeZone.UTC_TIME, Calendar.OCTOBER, -1, Calendar.SUNDAY, 3600000, SimpleTimeZone.UTC_TIME, 3600000)
    这些参数规则也适用于设置规则方法，如setStartRule 。
    从以下版本开始：
    1.1
    另请参见：
    Calendar ， GregorianCalendar ， TimeZone ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int STANDARD_TIME
      作为标准时间指定的开始或结束时间模式的常数。
      static int UTC_TIME
      指定为UTC的开始或结束时间模式的常数。
      static int WALL_TIME
      指定为挂钟时间的开始或结束时间模式的常数。

      • Fields inherited from class java.util.TimeZone

        LONG, SHORT

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleTimeZone​(int rawOffset, String ID)
      构造一个SimpleTimeZone，其给定的基准时区偏离GMT和时区ID，而没有夏令时。
      SimpleTimeZone​(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime)
      构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。
      SimpleTimeZone​(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime, int dstSavings)
      构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。
      SimpleTimeZone​(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int startTimeMode, int endMonth, int endDay, int endDayOfWeek, int endTime, int endTimeMode, int dstSavings)
      构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      返回此 SimpleTimeZone实例的克隆。
      boolean equals​(Object obj)
      比较两个 SimpleTimeZone对象的相等性。
      int getDSTSavings​()
      返回时钟在夏令时期间提前的时间（以毫秒为单位）。
      int getOffset​(int era, int year, int month, int day, int dayOfWeek, int millis)
      在指定的日期和时间内，返回本地时间和UTC之间的毫秒数差异，同时考虑原始偏移量和夏令时的效果。
      int getOffset​(long date)
      在给定时间返回此时区与UTC的偏移量。
      int getRawOffset​()
      获取此时区的GMT偏移量。
      int hashCode​()
      生成SimpleDateFormat对象的哈希码。
      boolean hasSameRules​(TimeZone other)
      如果此区域与其他区域具有相同的规则和偏移量，则返回 true 。
      boolean inDaylightTime​(Date date)
      查询给定日期是否在夏令时。
      boolean observesDaylightTime​()
      如果这个 SimpleTimeZone观察到夏令时，则返回 true 。
      void setDSTSavings​(int millisSavedDuringDST)
      设置时钟在夏令时期间提前的时间（以毫秒为单位）。
      void setEndRule​(int endMonth, int endDay, int endTime)
      将夏令时结束规则设置为一个月内的固定日期。
      void setEndRule​(int endMonth, int endDay, int endDayOfWeek, int endTime)
      设置夏令时结束规则。
      void setEndRule​(int endMonth, int endDay, int endDayOfWeek, int endTime, boolean after)
      将夏令时结束规则设置为在一个月内的给定日期之前或之后的工作日，例如第8个或之后的第一个星期一。
      void setRawOffset​(int offsetMillis)
      将基准时区偏移设置为GMT。
      void setStartRule​(int startMonth, int startDay, int startTime)
      将夏令时开始规则设置为一个月内的固定日期。
      void setStartRule​(int startMonth, int startDay, int startDayOfWeek, int startTime)
      设置夏令时启动规则。
      void setStartRule​(int startMonth, int startDay, int startDayOfWeek, int startTime, boolean after)
      将夏令时开始规则设置为一个月内给定日期之前或之后的工作日，例如第8个或之后的第一个星期一。
      void setStartYear​(int year)
      设置夏令时起始年份。
      String toString​()
      返回此时区的字符串表示形式。
      boolean useDaylightTime​()
      查询此时区是否使用夏令时。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.util.TimeZone

        getAvailableIDs, getAvailableIDs, getDefault, getDisplayName, getDisplayName, getDisplayName, getDisplayName, getID, getTimeZone, getTimeZone, setDefault, setID, toZoneId

    • 字段详细信息

      • WALL_TIME

        public static final int WALL_TIME
        指定为挂钟时间的开始或结束时间模式的常数。 挂钟时间是起始规则的标准时间，最终规则的日光时间。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • STANDARD_TIME

        public static final int STANDARD_TIME
        作为标准时间指定的开始或结束时间模式的常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • UTC_TIME

        public static final int UTC_TIME
        指定为UTC的开始或结束时间模式的常数。 例如，欧盟规则被指定为UTC时间。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SimpleTimeZone

        public SimpleTimeZone​(int rawOffset,
                      String ID)
        构造一个SimpleTimeZone，其给定的基准时区偏离GMT和时区ID，而没有夏令时。
        参数
        rawOffset - GMT的基准时区偏移量（以毫秒为单位）。
        ID - 给予该实例的时区名称。

      • SimpleTimeZone

        public SimpleTimeZone​(int rawOffset,
                      String ID,
                      int startMonth,
                      int startDay,
                      int startDayOfWeek,
                      int startTime,
                      int endMonth,
                      int endDay,
                      int endDayOfWeek,
                      int endTime)
        构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。 startTime和endTime都被指定为在挂钟时间中表示。 夏令时假设为3600000毫秒（即1小时）。 这个构造函数相当于：
           SimpleTimeZone(rawOffset, ID, startMonth, startDay, startDayOfWeek, startTime, SimpleTimeZone.WALL_TIME, endMonth, endDay, endDayOfWeek, endTime, SimpleTimeZone.WALL_TIME, 3600000)
        参数
        rawOffset - 给定的基准时区偏离GMT。
        ID - 给予该对象的时区ID。
        startMonth - 夏令时开始月份。 月份是一个MONTH字段值（基于0），例如1月份为0。
        startDay - 夏令时开始的月份中的日期。 请参阅此参数的特殊情况的类描述。
        startDayOfWeek - 从白天开始的夏令时。 请参阅此参数的特殊情况的类描述。
        startTime - 本地挂钟时间的夏令时开始时间（以毫秒为单位），这是本例中的本地标准时间。
        endMonth - 夏令时结束月份。 月份是一个MONTH字段值（基于0），例如10月的9。
        endDay - 夏令时结束的月份中的日期。 请参阅此参数的特殊情况的类描述。
        endDayOfWeek - 星期几结束的夏令时。 请参阅此参数的特殊情况的类描述。
        endTime - 本地挂钟时间的夏令时结束时间，（本日为毫秒），这是当地的夏令时间。
        异常
        IllegalArgumentException - 如果月，日，dayOfWeek或时间参数超出开始或结束规则的范围

      • SimpleTimeZone

        public SimpleTimeZone​(int rawOffset,
                      String ID,
                      int startMonth,
                      int startDay,
                      int startDayOfWeek,
                      int startTime,
                      int endMonth,
                      int endDay,
                      int endDayOfWeek,
                      int endTime,
                      int dstSavings)
        构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。 假定startTime和endTime均以挂钟时间表示。 这个构造函数相当于：
           SimpleTimeZone(rawOffset, ID, startMonth, startDay, startDayOfWeek, startTime, SimpleTimeZone.WALL_TIME, endMonth, endDay, endDayOfWeek, endTime, SimpleTimeZone.WALL_TIME, dstSavings)
        参数
        rawOffset - 给定的基准时区偏离GMT。
        ID - 给予该对象的时区ID。
        startMonth - 夏令时开始月份。 月份是一个MONTH字段值（基于0），例如1月份为0。
        startDay - 夏令时开始的月份中的日期。 请参阅此参数的特殊情况的类描述。
        startDayOfWeek - 从白天开始的夏令时。 请参阅此参数的特殊情况的类描述。
        startTime - 本地挂钟时间的夏令时开始时间，这是本例中的本地标准时间。
        endMonth - 夏令时结束月份。 月是一个MONTH字段值（基于0），例如10月的9。
        endDay - 夏令时结束的月份中的日期。 请参阅此参数的特殊情况的类描述。
        endDayOfWeek - 星期几结束的夏令时。 请参阅此参数的特殊情况的类描述。
        endTime - 本地挂钟时间的夏令时结束时间，这是本例中的本地日光时间。
        dstSavings - 夏令时期间保存的时间（毫秒）。
        异常
        IllegalArgumentException - 如果月，日，dayOfWeek或时间参数超出开始或结束规则的范围
        从以下版本开始：
        1.2

      • SimpleTimeZone

        public SimpleTimeZone​(int rawOffset,
                      String ID,
                      int startMonth,
                      int startDay,
                      int startDayOfWeek,
                      int startTime,
                      int startTimeMode,
                      int endMonth,
                      int endDay,
                      int endDayOfWeek,
                      int endTime,
                      int endTimeMode,
                      int dstSavings)
        构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。 该构造函数采用完整的开始和结束规则参数，包括startTime和endTime模式。 该模式指定wall time或standard time或UTC time 。
        参数
        rawOffset - 给定的基准时区与GMT的偏移。
        ID - 给予该对象的时区ID。
        startMonth - 夏令时开始月份。 月份是一个MONTH字段值（基于0），例如1月份为0。
        startDay - 夏令时开始的月份中的日期。 请参阅此参数的特殊情况的类描述。
        startDayOfWeek - 从白天开始的夏令时。 请参阅此参数的特殊情况的类描述。
        startTime - startTimeMode指定的时间模式下的夏令时开始时间。
        startTimeMode - 由startTime指定的开始时间模式。
        endMonth - 夏令时结束月份。 月份是一个MONTH字段值（基于0），例如10月的9。
        endDay - 夏令时结束的月份中的日期。 请参阅此参数的特殊情况的类描述。
        endDayOfWeek - 星期几结束的夏令时。 请参阅此参数的特殊情况的类描述。
        endTime - 由 endTimeMode指定的夏时制时间模式。
        endTimeMode - 由endTime指定的结束时间模式
        dstSavings - 在夏令时期间保存的时间（毫秒）。
        异常
        IllegalArgumentException - 如果月，日，dayOfWeek，时间更多或时间参数超出开始或结束规则的范围，或者时间模式值无效。
        从以下版本开始：
        1.4
        另请参见：
        WALL_TIME ， STANDARD_TIME ， UTC_TIME

    • 方法详细信息

      • setStartYear

        public void setStartYear​(int year)
        设置夏令时起始年份。
        参数
        year - 夏令时开始的一年。

      • setStartRule

        public void setStartRule​(int startMonth,
                         int startDay,
                         int startDayOfWeek,
                         int startTime)
        设置夏令时启动规则。 例如，如果夏令时在4月的第一个星期日凌晨2点在本地挂钟时间开始，您可以通过调用以下方式设置启动规则：
          setStartRule(Calendar.APRIL, 1, Calendar.SUNDAY, 2*60*60*1000);
        参数
        startMonth - 夏令时开始月份。 月份是一个MONTH字段值（基于0），例如1月份为0。
        startDay - 夏令时开始的月份中的日期。 请参阅此参数的特殊情况的类描述。
        startDayOfWeek - 从白天开始的夏令时。 请参阅此参数的特殊情况的类描述。
        startTime - 本地挂钟时间的夏令时开始时间，这是本例中的本地标准时间。
        异常
        IllegalArgumentException -如果 startMonth ， startDay ， startDayOfWeek ，或 startTime参数超出范围

      • setStartRule

        public void setStartRule​(int startMonth,
                         int startDay,
                         int startTime)
        将夏令时开始规则设置为一个月内的固定日期。 此方法相当于：
          setStartRule(startMonth, startDay, 0, startTime)
        参数
        startMonth - 夏令时开始月份。 月份是一个MONTH字段值（基于0），例如1月份为0。
        startDay - 夏令时开始的月份中的日期。
        startTime - 本地挂钟时间的夏令时开始时间，在这种情况下是本地标准时间。 请参阅此参数的特殊情况的类描述。
        异常
        IllegalArgumentException -如果 startMonth ， startDayOfMonth ，或 startTime参数超出范围
        从以下版本开始：
        1.2

      • setStartRule

        public void setStartRule​(int startMonth,
                         int startDay,
                         int startDayOfWeek,
                         int startTime,
                         boolean after)
        将夏令时开始规则设置为一个月内给定日期之前或之后的工作日，例如第8个或之后的第一个星期一。
        参数
        startMonth - 夏令时开始月份。 月份是一个MONTH字段值（基于0），例如1月份为0。
        startDay - 夏令时开始的月份中的日期。
        startDayOfWeek - 从星期几开始的夏令时。
        startTime - 本地挂钟时间的夏令时开始时间，这是本例中的本地标准时间。
        after - 如果为真，则此规则将选择dayOfWeek 之后的第一个dayOfMonth 。 如果为false，则此规则选择dayOfWeek 之前或之前的最后dayOfMonth 。
        异常
        IllegalArgumentException -如果 startMonth ， startDay ， startDayOfWeek ，或 startTime参数超出范围
        从以下版本开始：
        1.2

      • setEndRule

        public void setEndRule​(int endMonth,
                       int endDay,
                       int endDayOfWeek,
                       int endTime)
        设置夏令时结束规则。 例如，如果夏令时在十月的最后一个星期日凌晨2点在挂钟时间结束，您可以通过拨打以下setEndRule(Calendar.OCTOBER, -1, Calendar.SUNDAY, 2*60*60*1000);设置结束规则： setEndRule(Calendar.OCTOBER, -1, Calendar.SUNDAY, 2*60*60*1000);
        参数
        endMonth - 夏令时结束月份。 月份是一个MONTH字段值（基于0），例如10月的9。
        endDay - 夏令时结束的月份中的日期。 请参阅此参数的特殊情况的类描述。
        endDayOfWeek - 星期几结束的夏令时。 请参阅此参数的特殊情况的类描述。
        endTime - 在这种情况下，本地挂钟时间的夏令时结束时间（以毫秒为单位），这是当地的日光时间。
        异常
        IllegalArgumentException -如果 endMonth ， endDay ， endDayOfWeek ，或 endTime参数超出范围

      • setEndRule

        public void setEndRule​(int endMonth,
                       int endDay,
                       int endTime)
        将夏令时结束规则设置为一个月内的固定日期。 此方法相当于：
          setEndRule(endMonth, endDay, 0, endTime)
        参数
        endMonth - 夏令时结束月份。 月是一个MONTH字段值（基于0），例如10月10日。
        endDay - 夏令时结束的月份中的日期。
        endTime - 本地挂钟时间的夏令时结束时间，（本日为毫秒），这是当地的夏令时。
        异常
        IllegalArgumentException -的 endMonth ， endDay ，或 endTime参数超出范围
        从以下版本开始：
        1.2

      • setEndRule

        public void setEndRule​(int endMonth,
                       int endDay,
                       int endDayOfWeek,
                       int endTime,
                       boolean after)
        将夏令时结束规则设置为在一个月内的给定日期之前或之后的工作日，例如第8个或之后的第一个星期一。
        参数
        endMonth - 夏令时结束月份。 月是一个MONTH字段值（基于0），例如10月的9。
        endDay - 夏令时结束的月份中的日期。
        endDayOfWeek - 星期几结束的夏令时。
        endTime - 本地挂钟时间的夏令时结束时间，（本日为毫秒），这是当地的夏令时间。
        after - 如果为true，则此规则选择endDayOfWeek 之后的第一个endDay 。 如果是假，这个规则选择最后endDayOfWeek或之前endDay的一个月。
        异常
        IllegalArgumentException -的 endMonth ， endDay ， endDayOfWeek ，或 endTime参数超出范围
        从以下版本开始：
        1.2

      • getOffset

        public int getOffset​(long date)
        在给定时间返回此时区与UTC的偏移量。 如果夏令时在给定的时间有效，则偏移量将随着夏令时的调整而调整。
        重写：
        getOffset在 TimeZone
        参数
        date - 发现时区偏移的时间
        结果
        以毫秒为单位添加到UTC以获取本地时间的时间量。
        从以下版本开始：
        1.4
        另请参见：
        Calendar.ZONE_OFFSET ， Calendar.DST_OFFSET

      • getOffset

        public int getOffset​(int era,
                     int year,
                     int month,
                     int day,
                     int dayOfWeek,
                     int millis)
        在指定的日期和时间内，返回本地时间和UTC之间的毫秒数差异，同时考虑原始偏移量和夏令时的效果。 该方法假定开始和结束月份是不同的。 它还使用默认的GregorianCalendar对象作为其基础日历，例如用于确定闰年。 不要使用除默认值GregorianCalendar之外的日历的此方法的结果。

        注意：一般来说，客户端应该使用Calendar.get(ZONE_OFFSET) + Calendar.get(DST_OFFSET)而不是调用此方法。

        Specified by:
        getOffset在 TimeZone
        参数
        era - 给定日期的时代。
        year - 给定日期的年份。
        month - 给定日期的月份。 月份为0。 例如，1月份为0。
        day - 给定日期的日期。
        dayOfWeek - 给定日期的星期几。
        millis - 标准当地时间的毫秒数。
        结果
        添加到UTC以获取本地时间的毫秒数。
        异常
        IllegalArgumentException -的 era ， month ， day ， dayOfWeek ，或 millis参数超出范围
        另请参见：
        Calendar.ZONE_OFFSET ， Calendar.DST_OFFSET

      • getRawOffset

        public int getRawOffset​()
        获取此时区的GMT偏移量。
        Specified by:
        getRawOffset在 TimeZone
        结果
        GMT偏移值以毫秒为单位
        另请参见：
        setRawOffset(int)

      • setRawOffset

        public void setRawOffset​(int offsetMillis)
        将基准时区偏移设置为GMT。 这是添加到UTC以获取当地时间的偏移量。
        Specified by:
        setRawOffset在 TimeZone
        参数
        offsetMillis - 给定的基准时区偏移到GMT。
        另请参见：
        getRawOffset()

      • setDSTSavings

        public void setDSTSavings​(int millisSavedDuringDST)
        设置时钟在夏令时期间提前的时间（以毫秒为单位）。
        参数
        millisSavedDuringDST - 相对于夏令时规则生效的标准时间，时间提前的毫秒数。 正数，通常为1小时（3600000）。
        从以下版本开始：
        1.2
        另请参见：
        getDSTSavings()

      • getDSTSavings

        public int getDSTSavings​()
        返回时钟在夏令时期间提前的时间（以毫秒为单位）。
        重写：
        getDSTSavings在 TimeZone
        结果
        相对于夏令时规则生效的标准时间，时间提前的毫秒数，如果该时区没有观察到夏令时，则为0（零）。
        从以下版本开始：
        1.2
        另请参见：
        setDSTSavings(int)

      • useDaylightTime

        public boolean useDaylightTime​()
        查询此时区是否使用夏令时。
        Specified by:
        useDaylightTime在 TimeZone
        结果
        如果该时区使用夏令时，则为真; 否则为假。
        另请参见：
        TimeZone.inDaylightTime(Date) ， Calendar.DST_OFFSET

      • observesDaylightTime

        public boolean observesDaylightTime​()
        如果SimpleTimeZone观察到夏令时，则返回true 。 此方法相当于useDaylightTime() 。
        重写：
        observesDaylightTime在 TimeZone
        结果
        true如果这个SimpleTimeZone观察夏令时; 否则为false 。
        从以下版本开始：
        1.7
        另请参见：
        TimeZone.useDaylightTime() ， TimeZone.inDaylightTime(Date) ， Calendar.DST_OFFSET

      • inDaylightTime

        public boolean inDaylightTime​(Date date)
        查询给定日期是否在夏令时。
        Specified by:
        inDaylightTime在 TimeZone
        参数
        date - 给定日期。
        结果
        如果夏令时在给定日期生效，则为真; 否则为假。

      • clone

        public Object clone​()
        返回此 SimpleTimeZone实例的克隆。
        重写：
        clone在 TimeZone
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • hashCode

        public int hashCode​()
        生成SimpleDateFormat对象的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        比较两个 SimpleTimeZone对象的相等性。
        重写：
        equals在 Object
        参数
        obj - 要比较的 SimpleTimeZone对象。
        结果
        如果给定的obj与此SimpleTimeZone对象相同， SimpleTimeZone ; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hasSameRules

        public boolean hasSameRules​(TimeZone other)
        如果此区域具有与其他区域相同的规则和偏移量，则返回 true 。
        重写：
        hasSameRules在 TimeZone
        参数
        other - 要比较的TimeZone对象
        结果
        true如果给定的区域是一个SimpleTimeZone并具有与此相同的规则和偏移量
        从以下版本开始：
        1.2

      • toString

        public String toString​()
        返回此时区的字符串表示形式。
        重写：
        toString在 Object
        结果
        此时区的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


SortedMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface SortedMap<K,V>

  • 参数类型
    K - 由此地图维护的键的类型
    V - 映射值的类型
    All Superinterfaces:
    Map<K,V>
    All Known Subinterfaces:
    ConcurrentNavigableMap<K,V> ， NavigableMap<K,V>
    所有已知实现类：
    ConcurrentSkipListMap ， TreeMap

    public interface SortedMap<K,V>
extends Map<K,V>
    A Map进一步提供其键上的总排序 。 该地图是根据有序natural ordering其密钥，或通过Comparator通常在有序映射创建时提供。 遍历有序映射的集合视图（由返回时，这个顺序反映entrySet ， keySet和values方法）。 提供了几个额外的操作来利用订购。 （此界面是SortedSet的地图模拟。）

    插入分拣地图的所有键必须实现Comparable接口（或被指定的比较器接受）。 另外，所有这些键必须是可互相比较的 ： k1.compareTo(k2) （或comparator.compare(k1, k2) ）不得抛出ClassCastException任何键k1和k2在分类图。 尝试违反此限制将导致违规方法或构造函数调用抛出一个ClassCastException 。

    请注意，如果排序的映射要正确实现Map接口，由排序映射维护的排序（是否提供显式比较器）必须与equals一致 。 （见Comparable接口或Comparator接口，用于与等于一致的精确定义）这是因为Map接口是根据equals操作定义的，但是排序映射使用其compareTo （或compare ）方法执行所有密钥比较因此，从排序图的角度来看，通过这种方法认为相等的两个关键字是相等的。 树图的行为是明确的，即使它的排序与equals不一致; 它只是不符合Map接口的总体合同。

    所有通用排序映射实现类应提供四个“标准”构造函数。 无法通过接口指定必要的构造函数来执行此建议。 所有排序地图实现的预期“标准”构造函数是：

    1. 一个void（无参数）构造函数，它创建一个根据其键的自然顺序排序的空排序映射。
    2. 具有Comparator类型的单个参数的构造函数，它创建根据指定的比较器排序的空的排序映射。
    3. 一个具有类型为Map的单个参数的构造函数，它创建一个与其参数具有相同键值映射的新映射，根据密钥的自然排序进行排序。
    4. 一个具有类型为SortedMap的单个参数的构造函数，它创建一个具有相同键值映射和与输入排序映射相同顺序的新的排序映射。

    注意 ：几个方法返回带有限制键范围的子图。 这种范围是半开放的 ，也就是说，它们包括其低端点，但不包括其高端点（如适用）。 如果您需要一个封闭的范围 （包括两个端点），并且键类型允许计算给定键的后继，只需要从lowEndpoint到successor(highEndpoint)的子范围。 例如，假设m是其键是字符串的地图。 以下成语获得包含m中所有键值映射的m其关键在low和high之间，包括：

      SortedMap<String, V> sub = m.subMap(low, high+"\0");
    可以使用类似的技术来生成开放范围 （其不包含端点）。 以下成语获得包含m中所有键值映射的m其关键在low和high之间，独占：
      SortedMap<String, V> sub = m.subMap(low+"\0", high);

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Map ， TreeMap ， SortedSet ， Comparator ， Comparable ， Collection ， ClassCastException

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Comparator<? super K> comparator​()
      返回用于为了在这个映射中的键，或比较null如果此映射使用natural ordering它的键。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      K firstKey​()
      返回此地图中当前的第一个（最低）键。
      SortedMap<K,V> headMap​(K toKey)
      返回该地图的部分密钥严格小于 toKey 。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      K lastKey​()
      返回当前在此地图中的最后（最高）键。
      SortedMap<K,V> subMap​(K fromKey, K toKey)
      返回此地图部分的视图，其关键字范围从 fromKey （含）到 toKey ，独占。
      SortedMap<K,V> tailMap​(K fromKey)
      返回此地图部分的视图，其键大于或等于 fromKey 。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entry, equals, forEach, get, getOrDefault, hashCode, isEmpty, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size

    • 方法详细信息

      • comparator

        Comparator<? super K> comparator​()
        返回用于为了在这个映射中的键，或比较null如果此映射使用natural ordering它的键。
        结果
        比较器用于订购该地图中的按键，或 null如果该地图使用其键的自然排序

      • subMap

        SortedMap<K,V> subMap​(K fromKey,
                      K toKey)
        返回此地图部分的视图，其关键字范围从fromKey （含）到toKey ，独占。 （如果fromKey和toKey相等，则返回的地图为空。）返回的地图由该地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        参数
        fromKey - 返回地图中键的低端点（含）
        toKey - 返回地图中的键的高端点（独占）
        结果
        该地图的部分视图，其键的范围从 fromKey （含）到 toKey ，独占
        异常
        ClassCastException - 如果fromKey和toKey不能使用该地图的比较器相互比较（或者，如果地图没有比较器，则使用自然排序）。 如果fromKey或toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey或 toKey为空，并且此映射不允许空键
        IllegalArgumentException - 如果fromKey大于toKey ; 或者如果该地图本身具有限制范围，并且fromKey或toKey位于范围的界限之外

      • headMap

        SortedMap<K,V> headMap​(K toKey)
        返回该地图的部分密钥严格小于toKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        参数
        toKey - 返回地图中的键的高端点（独占）
        结果
        该地图的部分密钥严格小于 toKey
        异常
        ClassCastException - 如果toKey与此映射的比较器不兼容（或者，如果映射没有比较器，如果toKey不实现Comparable ）。 如果toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toKey为空，并且此映射不允许空值
        IllegalArgumentException - 如果该地图本身有限制范围，并且 toKey位于范围界限之外

      • tailMap

        SortedMap<K,V> tailMap​(K fromKey)
        返回此地图部分的视图，其键大于或等于fromKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将会IllegalArgumentException一个IllegalArgumentException ，试图在其范围之外插入一个键。

        参数
        fromKey - 返回地图中的键的低端点（含）
        结果
        该地图的部分的视图，其键大于或等于 fromKey
        异常
        ClassCastException - 如果fromKey与此映射的比较器不兼容（或者，如果映射没有比较器，如果fromKey不实现Comparable ）。 如果fromKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey为空，并且此映射不允许空值
        IllegalArgumentException - 如果该地图本身有限制范围，并且 fromKey位于范围界限之外

      • firstKey

        K firstKey​()
        返回此地图中当前的第一个（最低）键。
        结果
        当前在此地图中的第一（最低）键
        异常
        NoSuchElementException - 如果这张地图是空的

      • lastKey

        K lastKey​()
        返回当前在此地图中的最后（最高）键。
        结果
        当前在此地图中的最后（最高）键
        异常
        NoSuchElementException - 如果此地图为空

      • keySet

        Set<K> keySet​()
        返回此地图中包含的键的Set视图。 该集合的迭代器按升序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        keySet在接口 Map<K,V>
        结果
        该地图中包含的键的设置视图，按升序排列

      • values

        Collection<V> values​()
        返回此地图中包含的值的Collection视图。 集合的迭代器按照相应键的升序返回值。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        values在接口 Map<K,V>
        结果
        该地图中包含的值的集合视图，按升序排序

      • entrySet

        Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。 集合的迭代器按升序键顺序返回条目。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        entrySet在接口 Map<K,V>
        结果
        该地图中包含的映射的集合视图，按升序排序
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SortedSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface SortedSet<E>

  • 参数类型
    E - 由此集合维护的元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E> ， Set<E>
    All Known Subinterfaces:
    NavigableSet<E>
    所有已知实现类：
    ConcurrentSkipListSet ， TreeSet

    public interface SortedSet<E>
extends Set<E>
    A Set进一步提供了其元素的总排序 。 元素使用其natural ordering或Comparator进行排序，通常在排序集创建时提供。 集合的迭代器将以递增的元素顺序遍历集合。 提供了几个额外的操作来利用订购。 （此接口是SortedMap的设置模拟。）

    插入到排序集中的所有元素必须实现Comparable接口（或被指定的比较器接受）。 此外，所有这些元素必须相互可比较 ： e1.compareTo(e2) （或comparator.compare(e1, e2) ）不得为排序集中的任何元素e1和e2抛出ClassCastException 。 尝试违反此限制将导致违规方法或构造函数调用抛出ClassCastException 。

    请注意，如果排序集正确实现Set接口，排序集所保留的排序（无论是否提供显式比较器）必须与equals一致 。 （见Comparable接口或Comparator接口，以确定与等于一致的精确定义）这是因为Set接口是根据equals操作定义的，但是排序集使用其compareTo （或compare ）方法执行所有元素比较因此，从排序集合的观点来看，通过该方法认为相等的两个元素是相等的。 排序集合的行为是明确定义的，即使其排序与equals不一致; 它只是不符合Set界面的总体合同。

    所有通用排序集实现类应提供四个“标准”构造函数：1）一个void（无参数）构造函数，它创建一个根据其元素的自然顺序排序的空排序集。 2）具有Comparator型单个参数的构造函数，它创建根据指定的比较器排序的空的排序集。 3）具有Collection类型的单个参数的构造函数，它创建一个具有与其参数相同的元素的新的排序集合，并根据元素的自然排序进行排序。 4）具有类型为SortedSet的单个参数的构造函数，其创建具有与输入排序集相同的元素和相同顺序的新的排序集。 无法执行此建议，因为接口不能包含构造函数。

    注意：几种方法返回限制范围的子集。 这种范围是半开放的 ，也就是说，它们包括其低端点，但不包括其高端点（如适用）。 如果需要一个封闭范围 （包括两个端点），并且元素类型允许计算给定值的后继，只需将子范围从lowEndpoint请求到successor(highEndpoint) 。 例如，假设s是一组排序的字符串。 以下成语取得包含s中low至high所有字符串的视图，包括：

      SortedSet<String> sub = s.subSet(low, high+"\0");
    可以使用类似的技术来生成开放范围 （其不包含端点）。 以下成语获得包含s中所有字符串的s从low到high ，独占：
      SortedSet<String> sub = s.subSet(low+"\0", high);

    此界面是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Set ， TreeSet ， SortedMap ， Collection ， Comparable ， Comparator ， ClassCastException

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      Comparator<? super E> comparator​()
      返回用于为了在这个组中的元素，或比较null如果这个集使用natural ordering的元素。
      E first​()
      返回此集合中当前的第一个（最低）元素。
      SortedSet<E> headSet​(E toElement)
      返回此集合的部分的视图，其元素严格小于 toElement 。
      E last​()
      返回此集合中当前的最后（最高）元素。
      default Spliterator<E> spliterator​()
      在此排序集中的元素上创建一个 Spliterator 。
      SortedSet<E> subSet​(E fromElement, E toElement)
      返回此集合的部分的视图，其元素的范围从 fromElement （含）到 toElement ，独占。
      SortedSet<E> tailSet​(E fromElement)
      返回该集合的元素大于或等于 fromElement的部分的视图。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, toArray, toArray

    • 方法详细信息

      • comparator

        Comparator<? super E> comparator​()
        返回用于为了在这个组中的元素，或比较null如果这个集使用natural ordering的元素。
        结果
        比较器用于对该集合中的元素进行排序，如果此集合使用其元素的自然排序， null

      • subSet

        SortedSet<E> subSet​(E fromElement,
                    E toElement)
        返回该集合的部分的视图，其元素的范围从fromElement （含）到toElement ，排他。 （如果fromElement和toElement相等，则返回的集合为空。）返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        参数
        fromElement - 返回集合的低端点（含）
        toElement - 返回集合的高端点（独占）
        结果
        该集合的部分视图的元素范围为 fromElement ，包括 toElement ，独占
        异常
        ClassCastException - 如果fromElement和toElement无法使用该集合的比较器彼此进行比较（或者如果该集合没有比较器，则使用自然排序）。 如果fromElement或toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement或 toElement为空，并且此集合不允许空元素
        IllegalArgumentException - 如果fromElement大于toElement ; 或者如果此设置本身具有限制范围，并且fromElement或toElement位于范围的边界之外

      • headSet

        SortedSet<E> headSet​(E toElement)
        返回此集合的部分的视图，其元素严格小于toElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图将一个元素插入其范围之外。

        参数
        toElement - 返回集合的高端点（独占）
        结果
        该集合的部分视图的元素严格小于 toElement
        异常
        ClassCastException - 如果toElement与该组比较器不兼容（或者如果该集合没有比较器，则toElement不实现Comparable ）。 如果toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toElement为空，并且此集合不允许空元素
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 toElement位于范围的边界之外

      • tailSet

        SortedSet<E> tailSet​(E fromElement)
        返回该集合的元素大于或等于fromElement的部分的视图。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        参数
        fromElement - 返回集合的低端点（含）
        结果
        该集合的部分的视图，其元素大于或等于 fromElement
        异常
        ClassCastException - 如果fromElement与此集合的比较器不兼容（或者如果该集合没有比较器，则fromElement不实现Comparable ）。 如果fromElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement为空，并且此集合不允许空元素
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 fromElement位于范围的范围之外

      • first

        E first​()
        返回此集合中当前的第一个（最低）元素。
        结果
        当前在这个集合中的第一（最低）元素
        异常
        NoSuchElementException - 如果此设置为空

      • last

        E last​()
        返回此集合中当前的最后（最高）元素。
        结果
        当前在此集合中的最后（最高）元素
        异常
        NoSuchElementException - 如果此设置为空

      • spliterator

        default Spliterator<E> spliterator​()
        在此排序集中的元素上创建一个Spliterator 。

        该Spliterator报告Spliterator.DISTINCT ， Spliterator.SORTED和Spliterator.ORDERED 。 实施应记录其他特征值的报告。

        该spliterator的比较（见Spliterator.getComparator() ）必须是null如果有序set的比较（见comparator() ）是null 。 否则，拼接器的比较器必须与排序集的比较器相同或者施加与排序集的比较器相同的总排序。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Specified by:
        spliterator在接口 Set<E>
        实现要求：
        默认实现从排序集的Iterator创建一个late-binding拼接Iterator 。 分割器继承集合迭代器的故障快速属性。 拼接器的比较器与排序组的比较器相同。

        创建的Spliterator另外报告Spliterator.SIZED 。

        Implementation Note:
        创建的 Spliterator另外报告 Spliterator.SUBSIZED 。
        结果
        一个 Spliterator在这个排序集中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Spliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Spliterator<T>

  • 参数类型
    T - 此Spliter的返回元素的类型
    All Known Subinterfaces:
    Spliterator.OfDouble ， Spliterator.OfInt ， Spliterator.OfLong ， Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>
    所有已知实现类：
    Spliterators.AbstractDoubleSpliterator ， Spliterators.AbstractIntSpliterator ， Spliterators.AbstractLongSpliterator ， Spliterators.AbstractSpliterator

    public interface Spliterator<T>
    用于遍历和分割源的元素的对象。 Spliterator覆盖的元素的来源可以是例如阵列， Collection ，IO通道或生成器函数。

    分割器可以逐个遍历元素（ tryAdvance() ）或批量（ forEachRemaining() ）。

    分割器还可以将其一些元素（使用trySplit() ） 分割为另一个分割器，以在可能的并行操作中使用。 使用不能分割的Spliter的操作或者以非常不平衡或低效的方式进行的操作不太可能受益于并行性。 穿透和分流排气元件; 每个Spliterator仅对单个批量计算有用。

    甲Spliterator还报告一组characteristics()选自其结构，源极和元件的ORDERED ， DISTINCT ， SORTED ， SIZED ， NONNULL ， IMMUTABLE ， CONCURRENT ，和SUBSIZED 。 这些可以由Spliterator客户端使用来控制，专门化或简化计算。 例如，Collection的Spliterator将报告SIZED的Spliterator将报告DISTINCT ，并且SortedSet的Spliterator也将报告SORTED 。 特性报告为简单的单位位。 一些特征还限制了方法行为; 例如，如果ORDERED ，遍历方法必须符合其记录的顺序。 未来可能会定义新特性，因此实现者不应将含义分配给未列出的值。

    A Spliterator that does not report IMMUTABLE or CONCURRENT is expected to have a documented policy concerning: when the spliterator binds to the element source; and detection of structural interference of the element source detected after binding. 后期绑定的 Spliterator在首次遍历，第一次拆分或第一个查询时针对估计大小而不是在创建Spliter时绑定到元素的来源。 没有晚期绑定的拼接器在构造或首次调用任何方法时绑定到元素的来源。 在绑定之前对源进行的修改在Spliter运行时被反映。 绑定后，如果检测到结构性干扰，尽力而为，应该抛出ConcurrentModificationException 。 这样做的分割器称为故障快速 。 分割器的批量遍历方法（ forEachRemaining() ）可以优化遍历并检查所有元素已经遍历之后的结构干扰，而不是立即检查每个元素并失败。

    分配器可以通过estimateSize()方法提供剩余元素数量的估计。 理想情况下，如特征SIZED所反映的，该值与在成功遍历中遇到的元素的数量完全对应。 然而，即使不完全知道，估计值对于在源上执行的操作仍然可能是有用的，例如有助于确定是否优选进一步分割或者顺序地遍历剩余的元素。

    尽管它们在并行算法中具有明显的实用性，但拼接器并不期望是线程安全的; 相反，使用分割器的并行算法的实现应该确保分割器一次只被一个线程使用。 这通常是通过串行线程限制来获得的，这通常是通过递归分解工作的典型并行算法的自然结果。 调用trySplit()的线程可能会将返回的Spliterator移交给另一个线程，而该线程又可以遍历或进一步拆分该分割器。 如果两个或多个线程在同一个分割器上同时运行，则分割和遍历的行为是未定义的。 如果原始线程将一个分离器移离另一个线程进行处理，则最好是在tryAdvance()使用任何元素之前发生切换，因为某些保证（例如SIZED分配器的SIZED准确性）仅在遍历开始之前有效。

    的原始亚型特Spliterator提供用于int ， long ，和double值。 子类型默认实现为tryAdvance(java.util.function.Consumer)和forEachRemaining(java.util.function.Consumer)框原始值到其对应的包装器类的实例。 这种拳击可能会破坏使用原始专长所获得的任何性能优势。 为了避免拳击，应该使用相应的基于图元的方法。 例如， Spliterator.OfInt.tryAdvance(java.util.function.IntConsumer)和Spliterator.OfInt.forEachRemaining(java.util.function.IntConsumer)应优先于Spliterator.OfInt.tryAdvance(java.util.function.Consumer)和Spliterator.OfInt.forEachRemaining(java.util.function.Consumer)使用 。 使用基于拳击的方法tryAdvance()和forEachRemaining()进行原始值的遍历不影响遇到转换为框值的值的顺序。

    API Note:

    Spliterators，如Iterator s，用于遍历源的元素。 Spliterator API旨在通过支持分解和单元素迭代来支持除顺序遍历之外的有效并行遍历。 另外，用于通过分割器访问元件的协议被设计为比Iterator施加更小的每元件开销，并且避免为具有hasNext()和next()单独方法所涉及的固有竞争。

    对于可变源，如果在Striterator绑定到其数据源的时间与遍历结束之间，源在结构上受到干扰（添加，替换或删除的元素），则可能会发生任意和非确定性行为。 例如，当使用java.util.stream框架时，这种干扰将产生任意的非确定性结果。

    源的结构干扰可以通过以下方式进行管理（大概顺序为减少的可取性）：

    • 来源不能在结构上受到干扰。
      例如， CopyOnWriteArrayList的一个实例是一个不可变的来源。 从源头创建的IMMUTABLE报告了IMMUTABLE的特征。
    • 源代码管理并发修改。
      例如， ConcurrentHashMap的密钥集是并发源。 从源创建的CONCURRENT报告了一个CONCURRENT的特征。
    • 可变源提供后期绑定和故障切换快速分割器。
      后期约束使窗口缩小，在此期间干扰可影响计算; 故障快速检测在尽力而为的基础上，遍历开始后发生结构性干扰，并抛出ConcurrentModificationException 。 例如， ArrayList和JDK中的许多其他非并发的Collection类，提供了后期绑定，故障快速拼接器。
    • 可变源提供了一个非后期绑定但是故障快速的分割器。
      由于潜在的干扰窗口较大，源会增加投掷ConcurrentModificationException的可能性。
    • 可变源提供后期绑定和非故障快速的分割器。
      由于没有检测到干扰，因此源头在穿越开始后会产生任意的非确定性行为。
    • 可变源提供非后期绑定和非故障快速的分割器。
      来源会增加任意非确定性行为的风险，因为在建设后可能会发生非检测到的干扰。

    例。 这是一个类（不是非常有用的，除了说明），它维护一个数组，其中实际数据保存在偶数位置，而不相关的标签数据保存在奇数位置。 它的Spliterator忽略标签。

       class TaggedArray<T> { private final Object[] elements; // immutable after construction TaggedArray(T[] data, Object[] tags) { int size = data.length; if (tags.length != size) throw new IllegalArgumentException(); this.elements = new Object[2 * size]; for (int i = 0, j = 0; i < size; ++i) { elements[j++] = data[i]; elements[j++] = tags[i]; } } public Spliterator<T> spliterator() { return new TaggedArraySpliterator<>(elements, 0, elements.length); } static class TaggedArraySpliterator<T> implements Spliterator<T> { private final Object[] array; private int origin; // current index, advanced on split or traversal private final int fence; // one past the greatest index TaggedArraySpliterator(Object[] array, int origin, int fence) { this.array = array; this.origin = origin; this.fence = fence; } public void forEachRemaining(Consumer<? super T> action) { for (; origin < fence; origin += 2) action.accept((T) array[origin]); } public boolean tryAdvance(Consumer<? super T> action) { if (origin < fence) { action.accept((T) array[origin]); origin += 2; return true; } else // cannot advance return false; } public Spliterator<T> trySplit() { int lo = origin; // divide range in half int mid = ((lo + fence) >>> 1) & ~1; // force midpoint to be even if (lo < mid) { // split out left half origin = mid; // reset this Spliterator's origin return new TaggedArraySpliterator<>(array, lo, mid); } else // too small to split return null; } public long estimateSize() { return (long)((fence - origin) / 2); } public int characteristics() { return ORDERED | SIZED | IMMUTABLE | SUBSIZED; } } }

    例如，并行计算框架（例如java.util.stream软件包）将如何在并行计算中使用Spliterator，这里是实现相关联的并行forEach的一种方法，它说明了分解子任务的主要用法，直到估计工作量足够小以顺序执行。 这里我们假设子任务处理的顺序并不重要; 不同的（分叉）任务可以进一步拆分并以未确定的顺序处理元素。 此示例使用CountedCompleter ; 类似的用法适用于其他并行任务构造。

       static <T> void parEach(TaggedArray<T> a, Consumer<T> action) { Spliterator<T> s = a.spliterator(); long targetBatchSize = s.estimateSize() / (ForkJoinPool.getCommonPoolParallelism() * 8); new ParEach(null, s, action, targetBatchSize).invoke(); } static class ParEach<T> extends CountedCompleter<Void> { final Spliterator<T> spliterator; final Consumer<T> action; final long targetBatchSize; ParEach(ParEach<T> parent, Spliterator<T> spliterator, Consumer<T> action, long targetBatchSize) { super(parent); this.spliterator = spliterator; this.action = action; this.targetBatchSize = targetBatchSize; } public void compute() { Spliterator<T> sub; while (spliterator.estimateSize() > targetBatchSize && (sub = spliterator.trySplit()) != null) { addToPendingCount(1); new ParEach<>(this, sub, action, targetBatchSize).fork(); } spliterator.forEachRemaining(action); propagateCompletion(); } }
    Implementation Note:
    如果布尔系统属性 org.openjdk.java.util.stream.tripwire设置为 true则在对原始子类型专用化进行操作时，如果出现基本值的 true则会报告诊断警告。
    从以下版本开始：
    1.8
    另请参见：
    Collection

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  Spliterator.OfDouble
      一个专门针对 double值的 double 。
      static interface  Spliterator.OfInt
      一个专门为 int值的 int 。
      static interface  Spliterator.OfLong
      一个专门针对 long值的 long 。
      static interface  Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>
      专门针对原始价值观的Spliterator。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CONCURRENT
      特征值表示可以通过多个线程安全同时修改元素源（允许添加，替换和/或删除），而无需外部同步。
      static int DISTINCT
      特性值这标志着，对于每对遇到的元件 x, y ， !x.equals(y) 。
      static int IMMUTABLE
      特征值表示元素源不能在结构上进行修改; 也就是说，不能添加，替换或删除元素，因此在遍历过程中不会发生这种更改。
      static int NONNULL
      特征值表示源保证遇到的元素不会是 null 。
      static int ORDERED
      特征值表示为元素定义遇到顺序。
      static int SIZED
      表示在遍历或分割之前从 estimateSize()返回的值的特征值表示在没有结构源修改的情况下表示完全遍历将遇到的元素数量的精确计数的有限大小。
      static int SORTED
      特征值表示遇到的顺序遵循定义的排序顺序。
      static int SUBSIZED
      特征值这标志着从产生的所有Spliterators trySplit()将是既 SIZED和 SUBSIZED 。

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      int characteristics​()
      返回此Spliterator及其元素的一组特征。
      long estimateSize​()
      返回 forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计，如果无穷大，未知数或计算成本太高，则返回 Long.MAX_VALUE 。
      default void forEachRemaining​(Consumer<? super T> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default Comparator<? super T> getComparator​()
      如果这个Spliterator的来源是SORTED由Comparator ，则返回Comparator 。
      default long getExactSizeIfKnown​()
      方便的方法返回 estimateSize()如果这个Spliterator是 SIZED ，否则 -1 。
      default boolean hasCharacteristics​(int characteristics)
      如果此Spliterator的 characteristics()包含所有给定的特征，则返回 true 。
      boolean tryAdvance​(Consumer<? super T> action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。
      Spliterator<T> trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

    • 字段详细信息

      • ORDERED

        static final int ORDERED
        特征值表示为元素定义遇到顺序。 如果是这样，则该Spliterator保证方法trySplit()以前缀顺序将元素的严格前缀（方法tryAdvance(java.util.function.Consumer<? super T>)按步骤按一个元素） 拆分 ，并且forEachRemaining(java.util.function.Consumer<? super T>)以遇到的顺序执行操作。

        A Collection有相应的订单，如果相应的Collection.iterator()文件订单。 如果是这样，遇到的订单与记录的订单相同。 否则，集合没有遇到订单。

        API Note:
        对于任何List，遇到的订单保证是升序索引顺序。 但是，对于基于哈希的集合，如HashSet，没有保证任何顺序。 报告ORDERED的分割器的客户端将在非交换并行计算中保留排序约束。
        另请参见：
        Constant Field Values

      • DISTINCT

        static final int DISTINCT
        特性值这标志着，对于每对遇到的元件x, y ， !x.equals(y) 。 这适用于基于Set的Spliterator 。
        另请参见：
        Constant Field Values

      • SORTED

        static final int SORTED
        特征值表示遇到的顺序遵循定义的排序顺序。 如果是，方法getComparator()返回相关的比较器，或null如果所有元素是Comparable，并按其自然排序进行排序。

        报告SORTED也必须报告ORDERED 。

        API Note:
        在JDK中实现NavigableSet或SortedSet的 Collection类的分配器报告SORTED 。
        另请参见：
        Constant Field Values

      • SIZED

        static final int SIZED
        表示在遍历或分割之前从 estimateSize()返回的值的特征值表示在没有结构源修改的情况下表示完全遍历将遇到的元素数量的精确计数的有限大小。
        API Note:
        大多数集合的分割器，涵盖Collection所有元素报告此特征。 子分割器（例如HashSet的子分割器 ）覆盖了一组子元素并近似于其报告的大小。
        另请参见：
        Constant Field Values

      • NONNULL

        static final int NONNULL
        特征值表示源保证遇到的元素不会是null 。 （这适用于大多数并发集合，队列和映射）。
        另请参见：
        Constant Field Values

      • IMMUTABLE

        static final int IMMUTABLE
        特征值表示元素源不能在结构上进行修改; 也就是说，不能添加，替换或删除元素，因此在遍历过程中不会发生这种更改。 预计不会报告IMMUTABLE或CONCURRENT有关于在遍历期间检测到的结构性干扰的文档化策略（例如抛出ConcurrentModificationException ）。
        另请参见：
        Constant Field Values

      • CONCURRENT

        static final int CONCURRENT
        特征值表示可以通过多个线程安全同时修改元素源（允许添加，替换和/或删除），而无需外部同步。 如果是这样，则Spliterator应该有一个关于在遍历期间修改影响的文件化策略。

        顶级Spliterator不应同时报告CONCURRENT和SIZED ，因为如果已知的有限大小可能会在遍历期间同时修改源时发生更改。 这样的分割器是不一致的，并且不能保证使用该分割器的任何计算。 子分割器可能会报告SIZED如果子分割大小是已知的，并且在遍历时不反映源的添加或删除。

        顶级Spliterator不应同时报告CONCURRENT和IMMUTABLE ，因为它们是互斥的。 这样的分割器是不一致的，并且不能保证使用该分割器的任何计算。 子程序可能会报告IMMUTABLE如果源的添加或删除在运行时不被反映。

        API Note:
        大多数并发收藏集保持一致性政策，保证在Spliterator构建点存在的元素的准确性，但可能不反映随后的添加或删除。
        另请参见：
        Constant Field Values

      • SUBSIZED

        static final int SUBSIZED
        特征值这标志着从产生的所有Spliterators trySplit()将是既SIZED和SUBSIZED 。 （这意味着所有的子代码器，无论是直接还是间接，都将是SIZED ）

        根据SUBSIZED的要求不会报告SIZED的SUBSIZED不一致，并且不能保证使用该Spliterator的任何计算。

        API Note:
        一些拼接器，例如用于近似平衡的二叉树的顶级拼接器，将报告 SIZED而不是 SUBSIZED ，因为通常知道整个树的大小，但不知道子树的确切大小。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • tryAdvance

        boolean tryAdvance​(Consumer<? super T> action)
        如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。 如果此Spliterator是ORDERED ，则会按照遇到的顺序对下一个元素执行操作。 动作抛出的异常被转发给呼叫者。
        参数
        action - 动作
        结果
        false如果在进入此方法时不存在剩余元素，否则为 true 。
        异常
        NullPointerException - 如果指定的动作为空

      • forEachRemaining

        default void forEachRemaining​(Consumer<? super T> action)
        在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。 如果这个Spliterator是ORDERED ，操作将按照遇到的顺序执行。 动作抛出的异常被转发给呼叫者。
        实现要求：
        默认实现反复调用tryAdvance(java.util.function.Consumer<? super T>)，直到它返回false 。 应尽可能覆盖。
        参数
        action - 行动
        异常
        NullPointerException - 如果指定的操作为空

      • trySplit

        Spliterator<T> trySplit​()
        如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

        如果此Spliterator是ORDERED ，则返回的Spliterator必须覆盖元素的严格前缀。

        除非这个Spliterator包含无数的元素，否则重复调用trySplit()必须最终返回null 。 非空返回：

        • 在拆分之前报告的值为estimateSize() ，拆分后必须大于或等于estimateSize()为此和返回的Spliterator; 和
        • 如果这Spliterator是SUBSIZED ，然后estimateSize()这个spliterator分裂之前必须等于总和estimateSize() ，这和拆分后返回Spliterator。

        该方法可能由于任何原因返回null ，包括空虚，遍历开始后无法拆分，数据结构约束和效率考虑。

        API Note:
        理想的trySplit方法（无遍历）将其元素精确地分成两半，从而实现平衡的并行计算。 许多离开这个理想的人仍然是非常有效的; 例如，仅近似分裂近似平衡的树，或者对于叶节点可以包含一个或两个元素的树，不能进一步分割这些节点。 然而，平衡和/或过度无效的trySplit力学的大偏差通常导致差的并行性能。
        结果
        一个 Spliterator涵盖了部分元素，或 null如果此拼接器无法拆分

      • estimateSize

        long estimateSize​()
        返回forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果无穷大，未知数或计算成本太高，则返回Long.MAX_VALUE 。

        如果此Spliterator是SIZED并且尚未部分遍历或拆分，或该Spliterator为SUBSIZED并且尚未部分遍历，则此估计必须是完整遍历将遇到的元素的精确计数。 否则，此估计可能是任意不准确的，但必须按照trySplit()的调用指定的方式减少 。

        API Note:
        即使不精确的估计通常是有用的并且计算成本低廉。 例如，近似平衡的二叉树的子拼接器可以返回将元素的数量估计为其父代的数量的一半的值; 如果根分割器不能保持准确的计数，则可以将尺寸估计为对应于其最大深度的两倍。
        结果
        估计的大小，或 Long.MAX_VALUE如果无限，未知或太贵的计算。

      • getExactSizeIfKnown

        default long getExactSizeIfKnown​()
        方便的方法返回 estimateSize()如果这个Spliterator是 SIZED ，否则是 -1 。
        实现要求：
        如果Spliterator报告的特性为 SIZED ，则默认实现返回 estimateSize()的结果， estimateSize()返回 -1 。
        结果
        确切的大小，如果知道，其他 -1 。

      • characteristics

        int characteristics​()
        返回此Spliterator及其元素的一组特征。 结果从表示为或运算值ORDERED ， DISTINCT ， SORTED ， SIZED ， NONNULL ， IMMUTABLE ， CONCURRENT ， SUBSIZED 。 在给定的分配器之前或之前或之间调用trySplit重复调用characteristics()应始终返回相同的结果。

        如果Spliterator报告不一致的特征集（从单个调用返回的或多个调用返回的），则不能保证使用此Spliter的任何计算。

        API Note:
        分裂之前的给定分配器的特性可能与分裂后的特性不同。 对于具体的例子看到的特性值SIZED ， SUBSIZED和CONCURRENT 。
        结果
        特征的表征

      • hasCharacteristics

        default boolean hasCharacteristics​(int characteristics)
        如果此Spliterator的 characteristics()包含所有给定的特征，则返回 true 。
        实现要求：
        如果给定特征的相应位被设置，默认实现将返回true。
        参数
        characteristics - 检查的特点
        结果
        true如果所有指定的特性都存在，否则为 false

      • getComparator

        default Comparator<? super T> getComparator​()
        如果这个Spliterator的来源是SORTED由Comparator ，返回Comparator 。 如果SORTED中的来源是SORTED ，则返回null 。 否则，如果源不是SORTED ，则抛出IllegalStateException 。
        实现要求：
        默认实现总是抛出IllegalStateException 。
        结果
        比较器，或 null如果元素按照自然顺序排序。
        异常
        IllegalStateException - 如果拼接器不报告 SORTED的特征。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Spliterator.OfDouble (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Spliterator.OfDouble

  • All Superinterfaces:
    Spliterator<Double> ， Spliterator.OfPrimitive<Double,DoubleConsumer,Spliterator.OfDouble>
    所有已知实现类：
    Spliterators.AbstractDoubleSpliterator
    Enclosing interface:
    Spliterator < T >

    public static interface Spliterator.OfDouble
extends Spliterator.OfPrimitive<Double,DoubleConsumer,Spliterator.OfDouble>
    一个专门为 double值的 double 。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Spliterator

        Spliterator.OfDouble, Spliterator.OfInt, Spliterator.OfLong, Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>

    • Field Summary

      • Fields inherited from interface java.util.Spliterator

        CONCURRENT, DISTINCT, IMMUTABLE, NONNULL, ORDERED, SIZED, SORTED, SUBSIZED

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default void forEachRemaining​(Consumer<? super Double> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default void forEachRemaining​(DoubleConsumer action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default boolean tryAdvance​(Consumer<? super Double> action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。
      boolean tryAdvance​(DoubleConsumer action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。
      Spliterator.OfDouble trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

      • Methods inherited from interface java.util.Spliterator

        characteristics, estimateSize, getComparator, getExactSizeIfKnown, hasCharacteristics

    • 方法详细信息

      • trySplit

        Spliterator.OfDouble trySplit​()
        描述从接口Spliterator复制
        如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

        如果此Spliterator是Spliterator.ORDERED ，则返回的Spliterator必须覆盖元素的严格前缀。

        除非这个Spliterator包含无数个元素，否则重复调用trySplit()必须最终返回null 。 非空返回：

        • 在拆分之前报告的值为estimateSize() ，拆分后必须大于或等于estimateSize()为此和返回的Spliterator; 和
        • 如果这Spliterator是SUBSIZED ，然后estimateSize()这个spliterator分裂之前必须等于总和estimateSize() ，这和拆分后返回Spliterator。

        该方法可能由于任何原因返回null ，包括空虚，遍历开始后无法拆分，数据结构约束和效率考虑。

        Specified by:
        trySplit在接口 Spliterator<Double>
        Specified by:
        trySplit在接口 Spliterator.OfPrimitive<Double,DoubleConsumer,Spliterator.OfDouble>
        结果
        一个 Spliterator覆盖部分元素，或 null如果这个拼接器不能被拆分

      • tryAdvance

        boolean tryAdvance​(DoubleConsumer action)
        说明从接口Spliterator.OfPrimitive复制
        如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。 如果此Spliterator是Spliterator.ORDERED ，则会按照遇到的顺序对下一个元素执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        tryAdvance在接口 Spliterator.OfPrimitive<Double,DoubleConsumer,Spliterator.OfDouble>
        参数
        action - 行动
        结果
        false如果在输入此方法时不存在其余元素，否则为 true 。

      • forEachRemaining

        default void forEachRemaining​(DoubleConsumer action)
        描述从接口Spliterator.OfPrimitive复制
        在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。 如果这个Spliterator是Spliterator.ORDERED ，则按照遇到的顺序执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        forEachRemaining在接口 Spliterator.OfPrimitive<Double,DoubleConsumer,Spliterator.OfDouble>
        参数
        action - 行动

      • tryAdvance

        default boolean tryAdvance​(Consumer<? super Double> action)
        如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。 如果此Spliterator是Spliterator.ORDERED ，则会按照遇到顺序对下一个元素执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        tryAdvance在接口 Spliterator<Double>
        实现要求：
        如果操作是DoubleConsumer一个实例，那么它被转换为DoubleConsumer并传递给tryAdvance(java.util.function.DoubleConsumer) ; 否则该动作适应DoubleConsumer一个实例，通过将参数DoubleConsumer ，然后传递给tryAdvance(java.util.function.DoubleConsumer) 。
        参数
        action - 行动
        结果
        false如果在进入此方法时没有剩余的元素，否则为 true 。

      • forEachRemaining

        default void forEachRemaining​(Consumer<? super Double> action)
        在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。 如果这个Spliterator是Spliterator.ORDERED ， 则按相关顺序执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        forEachRemaining在接口 Spliterator<Double>
        实现要求：
        如果操作是DoubleConsumer一个实例，那么它被转换为DoubleConsumer并传递给forEachRemaining(java.util.function.DoubleConsumer) ; 否则该动作适应DoubleConsumer一个实例，通过将参数DoubleConsumer ，然后传递给forEachRemaining(java.util.function.DoubleConsumer) 。
        参数
        action - 行动
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Spliterator.OfInt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Spliterator.OfInt

  • All Superinterfaces:
    Spliterator<Integer> ， Spliterator.OfPrimitive<Integer,IntConsumer,Spliterator.OfInt>
    所有已知实现类：
    Spliterators.AbstractIntSpliterator
    Enclosing interface:
    Spliterator < T >

    public static interface Spliterator.OfInt
extends Spliterator.OfPrimitive<Integer,IntConsumer,Spliterator.OfInt>
    一个专业的 int值的 int 。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Spliterator

        Spliterator.OfDouble, Spliterator.OfInt, Spliterator.OfLong, Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>

    • Field Summary

      • Fields inherited from interface java.util.Spliterator

        CONCURRENT, DISTINCT, IMMUTABLE, NONNULL, ORDERED, SIZED, SORTED, SUBSIZED

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default void forEachRemaining​(Consumer<? super Integer> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default void forEachRemaining​(IntConsumer action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default boolean tryAdvance​(Consumer<? super Integer> action)
      如果剩下的元素存在，执行给定的动作，返回true ; 否则返回false 。
      boolean tryAdvance​(IntConsumer action)
      如果存在剩余元素，执行给定的操作，返回true ; 否则返回false 。
      Spliterator.OfInt trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

      • Methods inherited from interface java.util.Spliterator

        characteristics, estimateSize, getComparator, getExactSizeIfKnown, hasCharacteristics

    • 方法详细信息

      • trySplit

        Spliterator.OfInt trySplit​()
        说明从接口Spliterator复制
        如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

        如果此Spliterator为Spliterator.ORDERED ，则返回的Spliterator必须覆盖元素的严格前缀。

        除非这个Spliterator包含无数个元素，否则重复调用trySplit()必须最终返回null 。 非空返回：

        • 在拆分之前报告的值为estimateSize() ，分割后必须大于等于此值和estimateSize() ，并返回Spliterator; 和
        • 如果这Spliterator是SUBSIZED ，然后estimateSize()这个spliterator分裂之前必须等于总和estimateSize() ，这和拆分后返回Spliterator。

        该方法可能由于任何原因返回null ，包括空虚，遍历开始后无法拆分，数据结构约束和效率考虑。

        Specified by:
        trySplit在接口 Spliterator<Integer>
        Specified by:
        trySplit在接口 Spliterator.OfPrimitive<Integer,IntConsumer,Spliterator.OfInt>
        结果
        一个 Spliterator覆盖了元素的一部分，或 null如果这个拼接器不能被拆分

      • tryAdvance

        boolean tryAdvance​(IntConsumer action)
        描述从接口Spliterator.OfPrimitive复制
        如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。 如果此Spliterator是Spliterator.ORDERED ，则会按照遇到的顺序对下一个元素执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        tryAdvance在接口 Spliterator.OfPrimitive<Integer,IntConsumer,Spliterator.OfInt>
        参数
        action - 行动
        结果
        false如果在进入此方法时没有剩余元素，否则为 true 。

      • forEachRemaining

        default void forEachRemaining​(IntConsumer action)
        描述从接口Spliterator.OfPrimitive复制
        在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。 如果这个Spliterator是Spliterator.ORDERED ，则按照遇到的顺序执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        forEachRemaining在接口 Spliterator.OfPrimitive<Integer,IntConsumer,Spliterator.OfInt>
        参数
        action - 行动

      • tryAdvance

        default boolean tryAdvance​(Consumer<? super Integer> action)
        如果存在剩余元素，则对其执行给定的操作，返回true ; 否则返回false 。 如果此Spliterator是Spliterator.ORDERED ，则会按照遇到的顺序对下一个元素执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        tryAdvance在接口 Spliterator<Integer>
        实现要求：
        如果操作是IntConsumer一个实例，那么它被转换为IntConsumer并传递给tryAdvance(java.util.function.IntConsumer) ; 否则动作适应IntConsumer一个实例，通过对参数IntConsumer进行拳击，然后传递给tryAdvance(java.util.function.IntConsumer) 。
        参数
        action - 行动
        结果
        false如果在进入该方法时不存在剩余元素，否则为 true 。

      • forEachRemaining

        default void forEachRemaining​(Consumer<? super Integer> action)
        在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。 如果这个Spliterator是Spliterator.ORDERED ， 则按相关顺序执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        forEachRemaining在接口 Spliterator<Integer>
        实现要求：
        如果该操作是IntConsumer一个实例，则转换为IntConsumer并传递给forEachRemaining(java.util.function.IntConsumer) ; 否则动作适应IntConsumer一个实例，通过拳击IntConsumer的参数，然后传递给forEachRemaining(java.util.function.IntConsumer) 。
        参数
        action - 行动
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Spliterator.OfLong (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Spliterator.OfLong

  • All Superinterfaces:
    Spliterator<Long> ， Spliterator.OfPrimitive<Long,LongConsumer,Spliterator.OfLong>
    所有已知实现类：
    Spliterators.AbstractLongSpliterator
    Enclosing interface:
    Spliterator < T >

    public static interface Spliterator.OfLong
extends Spliterator.OfPrimitive<Long,LongConsumer,Spliterator.OfLong>
    A Spliterator专门为 long值。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Spliterator

        Spliterator.OfDouble, Spliterator.OfInt, Spliterator.OfLong, Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>

    • Field Summary

      • Fields inherited from interface java.util.Spliterator

        CONCURRENT, DISTINCT, IMMUTABLE, NONNULL, ORDERED, SIZED, SORTED, SUBSIZED

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default void forEachRemaining​(Consumer<? super Long> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default void forEachRemaining​(LongConsumer action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default boolean tryAdvance​(Consumer<? super Long> action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。
      boolean tryAdvance​(LongConsumer action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。
      Spliterator.OfLong trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

      • Methods inherited from interface java.util.Spliterator

        characteristics, estimateSize, getComparator, getExactSizeIfKnown, hasCharacteristics

    • 方法详细信息

      • trySplit

        Spliterator.OfLong trySplit​()
        说明从接口Spliterator复制
        如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

        如果此Spliterator为Spliterator.ORDERED ，则返回的Spliterator必须覆盖元素的严格前缀。

        除非这个Spliterator包含无数的元素，否则重复调用trySplit()必须最终返回null 。 非空返回：

        • 报告的价值estimateSize()分裂之前，必须分割后，大于或等于estimateSize() ，这和返回Spliterator; 和
        • 如果这Spliterator是SUBSIZED ，然后estimateSize()这个spliterator分裂之前必须等于总和estimateSize() ，这和拆分后返回Spliterator。

        该方法可能由于任何原因返回null ，包括空虚，遍历开始后无法拆分，数据结构约束和效率考虑。

        Specified by:
        trySplit在接口 Spliterator<Long>
        Specified by:
        trySplit在接口 Spliterator.OfPrimitive<Long,LongConsumer,Spliterator.OfLong>
        结果
        一个 Spliterator覆盖部分元素，或 null如果此拼接器无法拆分

      • tryAdvance

        boolean tryAdvance​(LongConsumer action)
        描述从接口Spliterator.OfPrimitive复制
        如果存在剩余元素，则对其执行给定的操作，返回true ; 否则返回false 。 如果此Spliterator是Spliterator.ORDERED ，则会按照遇到的顺序对下一个元素执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        tryAdvance在接口 Spliterator.OfPrimitive<Long,LongConsumer,Spliterator.OfLong>
        参数
        action - 行动
        结果
        false如果在输入此方法时不存在剩余元素，否则为 true 。

      • forEachRemaining

        default void forEachRemaining​(LongConsumer action)
        描述从接口Spliterator.OfPrimitive复制
        在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。 如果这个Spliterator是Spliterator.ORDERED ，则按照遇到的顺序执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        forEachRemaining在接口 Spliterator.OfPrimitive<Long,LongConsumer,Spliterator.OfLong>
        参数
        action - 行动

      • tryAdvance

        default boolean tryAdvance​(Consumer<? super Long> action)
        如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。 如果此Spliterator是Spliterator.ORDERED ，则会按照遇到的顺序对下一个元素执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        tryAdvance接口 Spliterator<Long>
        实现要求：
        如果该操作是LongConsumer一个实例，则转换为LongConsumer并传递给tryAdvance(java.util.function.LongConsumer) ; 否则动作适应LongConsumer一个实例，通过拳击LongConsumer的参数，然后传递给tryAdvance(java.util.function.LongConsumer) 。
        参数
        action - 行动
        结果
        false如果在进入此方法时不存在剩余元素，否则为 true 。

      • forEachRemaining

        default void forEachRemaining​(Consumer<? super Long> action)
        在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。 如果此Spliterator是Spliterator.ORDERED ，则会按遇到顺序执行操作。 动作抛出的异常被转发给呼叫者。
        Specified by:
        forEachRemaining在接口 Spliterator<Long>
        实现要求：
        如果该动作是LongConsumer一个实例，则转换为LongConsumer并传递给forEachRemaining(java.util.function.LongConsumer) ; 否则动作适应LongConsumer一个实例，通过拳击LongConsumer的参数，然后传递给forEachRemaining(java.util.function.LongConsumer) 。
        参数
        action - 行动
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Spliterator.OfPrimitive (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Interface Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>

  • 参数类型
    T - 此Spliter的返回元素的类型。 该类型必须是对一个原始类型的包装类型，例如Integer为原始int类型。
    T_CONS - 原始消费者的类型。 该类型必须是Consumer对于T的原始专业化，例如IntConsumer为Integer 。
    T_SPLITR - 原始Spliterator的类型。 该类型必须是T的T的原始专业化，例如2706459338805为Integer 。
    All Superinterfaces:
    Spliterator<T>
    All Known Subinterfaces:
    Spliterator.OfDouble ， Spliterator.OfInt ， Spliterator.OfLong
    所有已知实现类：
    Spliterators.AbstractDoubleSpliterator ， Spliterators.AbstractIntSpliterator ， Spliterators.AbstractLongSpliterator
    Enclosing interface:
    Spliterator < T >

    public static interface Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>
extends Spliterator<T>
    专门针对原始价值观的Spliterator。
    从以下版本开始：
    1.8
    另请参见：
    Spliterator.OfInt ， Spliterator.OfLong ， Spliterator.OfDouble

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Spliterator

        Spliterator.OfDouble, Spliterator.OfInt, Spliterator.OfLong, Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>

    • Field Summary

      • Fields inherited from interface java.util.Spliterator

        CONCURRENT, DISTINCT, IMMUTABLE, NONNULL, ORDERED, SIZED, SORTED, SUBSIZED

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default void forEachRemaining​(T_CONS action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      boolean tryAdvance​(T_CONS action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。
      T_SPLITR trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

      • Methods inherited from interface java.util.Spliterator

        characteristics, estimateSize, forEachRemaining, getComparator, getExactSizeIfKnown, hasCharacteristics, tryAdvance

    • 方法详细信息

      • trySplit

        T_SPLITR trySplit​()
        说明从接口Spliterator复制
        如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

        如果此Spliterator为Spliterator.ORDERED ，则返回的Spliterator必须覆盖元素的严格前缀。

        除非这个Spliterator包含无数个元素，否则重复调用trySplit()必须最终返回null 。 非空返回：

        • 在分割之前报告的值为estimateSize() ，分割后必须大于或等于estimateSize()为此和返回的Spliterator; 和
        • 如果这Spliterator是SUBSIZED ，然后estimateSize()这个spliterator分裂之前必须等于总和estimateSize() ，这和拆分后返回Spliterator。

        该方法可能由于任何原因返回null ，包括空虚，遍历开始后无法拆分，数据结构约束和效率考虑。

        Specified by:
        trySplit在接口 Spliterator<T>
        结果
        一个 Spliterator覆盖部分元素，或 null如果这个拼接器不能被拆分

      • tryAdvance

        boolean tryAdvance​(T_CONS action)
        如果存在剩余元素，执行给定的操作，返回true ; 否则返回false 。 如果此Spliterator是Spliterator.ORDERED ，则会按照遇到的顺序对下一个元素执行操作。 动作抛出的异常被转发给呼叫者。
        参数
        action - 行动
        结果
        false如果在进入此方法时不存在剩余元素，否则为 true 。
        异常
        NullPointerException - 如果指定的动作为空

      • forEachRemaining

        default void forEachRemaining​(T_CONS action)
        在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。 如果这个Spliterator是Spliterator.ORDERED ，则按照遇到的顺序执行操作。 动作抛出的异常被转发给呼叫者。
        实现要求：
        默认实现反复调用tryAdvance(T_CONS)，直到它返回false 。 应尽可能覆盖。
        参数
        action - 行动
        异常
        NullPointerException - if the specified action is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Spliterators (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Spliterators

  • java.lang.Object
    • java.util.Spliterators

  • public final class Spliterators
extends Object
    静态类和用于上操作或创建的实例的方法Spliterator及其原始特Spliterator.OfInt ， Spliterator.OfLong ，和Spliterator.OfDouble 。
    从以下版本开始：
    1.8
    另请参见：
    Spliterator

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Spliterators.AbstractDoubleSpliterator
      一个抽象的 Spliterator.OfDouble实现 trySplit以允许有限的并行性。
      static class  Spliterators.AbstractIntSpliterator
      摘要 Spliterator.OfInt实现了 trySplit以允许有限的并行性。
      static class  Spliterators.AbstractLongSpliterator
      摘要 Spliterator.OfLong实现了 trySplit以允许有限的并行性。
      static class  Spliterators.AbstractSpliterator<T>
      一个抽象的 Spliterator实现 trySplit以允许有限的并行性。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Spliterator.OfDouble emptyDoubleSpliterator​()
      创建一个空的 Spliterator.OfDouble
      static Spliterator.OfInt emptyIntSpliterator​()
      创建一个空的 Spliterator.OfInt
      static Spliterator.OfLong emptyLongSpliterator​()
      创建一个空的 Spliterator.OfLong
      static <T> Spliterator<T> emptySpliterator​()
      创建一个空的 Spliterator
      static PrimitiveIterator.OfDouble iterator​(Spliterator.OfDouble spliterator)
      创建一个 PrimitiveIterator.OfDouble从 Spliterator.OfDouble 。
      static PrimitiveIterator.OfInt iterator​(Spliterator.OfInt spliterator)
      创建一个 PrimitiveIterator.OfInt从 Spliterator.OfInt 。
      static PrimitiveIterator.OfLong iterator​(Spliterator.OfLong spliterator)
      创建一个 PrimitiveIterator.OfLong从 Spliterator.OfLong 。
      static <T> Iterator<T> iterator​(Spliterator<? extends T> spliterator)
      创建一个 Iterator从 Spliterator 。
      static Spliterator.OfDouble spliterator​(double[] array, int additionalCharacteristics)
      创建一个 Spliterator.OfDouble ，使用一组自定义的拼接器特性来覆盖给定阵列的元素。
      static Spliterator.OfDouble spliterator​(double[] array, int fromIndex, int toIndex, int additionalCharacteristics)
      创建一个 Spliterator.OfDouble涵盖给定数组的一系列元素，使用一组自定义的拼接器特性。
      static Spliterator.OfInt spliterator​(int[] array, int additionalCharacteristics)
      创建一个 Spliterator.OfInt覆盖给定阵列的元素，使用一组自定义的拼接器特征。
      static Spliterator.OfInt spliterator​(int[] array, int fromIndex, int toIndex, int additionalCharacteristics)
      创建一个 Spliterator.OfInt涵盖给定阵列的一系列元素，使用一组自定义的拼接器特性。
      static Spliterator.OfLong spliterator​(long[] array, int additionalCharacteristics)
      创建一个 Spliterator.OfLong ，使用自定义的一组拼接器特征来覆盖给定数组的元素。
      static Spliterator.OfLong spliterator​(long[] array, int fromIndex, int toIndex, int additionalCharacteristics)
      创建一个 Spliterator.OfLong涵盖了一组给定阵列的元素，使用了一组自定义的拼接器特性。
      static <T> Spliterator<T> spliterator​(Object[] array, int additionalCharacteristics)
      创建一个 Spliterator覆盖给定数组的元素，使用一组自定义的拼接器特征。
      static <T> Spliterator<T> spliterator​(Object[] array, int fromIndex, int toIndex, int additionalCharacteristics)
      创建一个 Spliterator涵盖给定阵列的一系列元素，使用一组自定义的拼接器特性。
      static <T> Spliterator<T> spliterator​(Collection<? extends T> c, int characteristics)
      使用给定集合的 Collection.iterator()作为元素的来源创建一个 Spliterator ，并报告其 Collection.size()作为其初始大小。
      static <T> Spliterator<T> spliterator​(Iterator<? extends T> iterator, long size, int characteristics)
      使用给定的 Iterator作为元素的来源，并以给定的最初报告的大小创建 Spliterator 。
      static Spliterator.OfDouble spliterator​(PrimitiveIterator.OfDouble iterator, long size, int characteristics)
      创建一个 Spliterator.OfDouble使用给定的 DoubleStream.DoubleIterator作为元素的来源，并给出最初报告的大小。
      static Spliterator.OfInt spliterator​(PrimitiveIterator.OfInt iterator, long size, int characteristics)
      创建一个 Spliterator.OfInt使用给定的 IntStream.IntIterator作为元素的来源，并给出最初报告的大小。
      static Spliterator.OfLong spliterator​(PrimitiveIterator.OfLong iterator, long size, int characteristics)
      使用给定的 LongStream.LongIterator作为元素的来源创建一个 Spliterator.OfLong ，并给出最初报告的大小。
      static <T> Spliterator<T> spliteratorUnknownSize​(Iterator<? extends T> iterator, int characteristics)
      使用给定的 Iterator作为元素的来源创建一个 Spliterator ，没有初始大小估计。
      static Spliterator.OfDouble spliteratorUnknownSize​(PrimitiveIterator.OfDouble iterator, int characteristics)
      创建一个 Spliterator.OfDouble使用给定的 DoubleStream.DoubleIterator作为元素的来源，没有初始大小估计。
      static Spliterator.OfInt spliteratorUnknownSize​(PrimitiveIterator.OfInt iterator, int characteristics)
      创建一个 Spliterator.OfInt使用给定的 IntStream.IntIterator作为元素的来源，没有初始大小估计。
      static Spliterator.OfLong spliteratorUnknownSize​(PrimitiveIterator.OfLong iterator, int characteristics)
      使用给定的 LongStream.LongIterator作为元素的来源创建一个 Spliterator.OfLong ，没有初始大小估计。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • emptySpliterator

        public static <T> Spliterator<T> emptySpliterator​()
        创建一个空的Spliterator

        空的分配器报告Spliterator.SIZED和Spliterator.SUBSIZED 。 致电Spliterator.trySplit()总是返回null 。

        参数类型
        T - 元素类型
        结果
        一个空的拼写器

      • emptyIntSpliterator

        public static Spliterator.OfInt emptyIntSpliterator​()
        创建一个空的Spliterator.OfInt

        空的分配器报告Spliterator.SIZED和Spliterator.SUBSIZED 。 致电Spliterator.trySplit()总是返回null 。

        结果
        一个空的拼写器

      • emptyLongSpliterator

        public static Spliterator.OfLong emptyLongSpliterator​()
        创建一个空的Spliterator.OfLong

        空的分配器报告Spliterator.SIZED和Spliterator.SUBSIZED 。 致电Spliterator.trySplit()总是返回null 。

        结果
        一个空的拼写器

      • emptyDoubleSpliterator

        public static Spliterator.OfDouble emptyDoubleSpliterator​()
        创建一个空的Spliterator.OfDouble

        空的分配器报告Spliterator.SIZED和Spliterator.SUBSIZED 。 致电Spliterator.trySplit()总是返回null 。

        结果
        一个空的拼写器

      • spliterator

        public static <T> Spliterator<T> spliterator​(Object[] array,
                                             int additionalCharacteristics)
        创建一个Spliterator覆盖给定数组的元素，使用一组自定义的拼接器特征。

        该方法被提供为用于将其元素的部分存储在数组中的分割器的实现方便性，并且需要对Spliterator特性的精细控制。 大多数其他情况下，需要使用数组的Spliterator才能使用Arrays.spliterator(Object[]) 。

        返回的分配器总是报告特征SIZED和SUBSIZED 。 呼叫者可以为分组报告提供附加特征; 通常还要指定IMMUTABLE和ORDERED 。

        参数类型
        T - 元素类型
        参数
        array - 假定在使用过程中未修改的数组
        additionalCharacteristics - 这个拼接器的源或超出 SIZED和 SUBSIZED附加拼接器特性，它们始终被报告
        结果
        阵列的拼接器
        异常
        NullPointerException - 如果给定的数组是 null
        另请参见：
        Arrays.spliterator(Object[])

      • spliterator

        public static <T> Spliterator<T> spliterator​(Object[] array,
                                             int fromIndex,
                                             int toIndex,
                                             int additionalCharacteristics)
        创建一个Spliterator涵盖一组给定阵列的元素，使用一组自定义的拼接器特性。

        该方法被提供为用于将其元素的部分存储在数组中的分割器的实现方便性，并且需要对Spliterator特性的精细控制。 大多数其他情况下，需要使用数组的Spliterator才能使用Arrays.spliterator(Object[]) 。

        返回的分配器总是报告特征SIZED和SUBSIZED 。 呼叫者可以为分组报告提供附加特征; 通常还要指定IMMUTABLE和ORDERED 。

        参数类型
        T - 元素类型
        参数
        array - 假定在使用过程中未修改的数组
        fromIndex - 涵盖的最小索引（包括）
        toIndex - 过去最大的索引之一
        additionalCharacteristics - 此剪辑器的源或超出 SIZED和 SUBSIZED附加拼接器特征，它们始终被报告
        结果
        阵列的拼接器
        异常
        NullPointerException - 如果给定的数组是 null
        ArrayIndexOutOfBoundsException - 如果 fromIndex为负数，则 toIndex小于 fromIndex ，或 toIndex大于数组大小
        另请参见：
        Arrays.spliterator(Object[], int, int)

      • spliterator

        public static Spliterator.OfInt spliterator​(int[] array,
                                            int additionalCharacteristics)
        创建一个Spliterator.OfInt覆盖给定数组的元素，使用一组自定义的拼接器特征。

        该方法被提供为用于将其元素的部分存储在数组中的分割器的实现方便性，并且需要对Spliterator特性的精细控制。 大多数其他情况下，需要使用数组的Spliterator才能使用Arrays.spliterator(int[]) 。

        返回的分配器总是报告特征SIZED和SUBSIZED 。 呼叫者可以为分组报告提供附加特征; 通常还要指定IMMUTABLE和ORDERED 。

        参数
        array - 假定在使用过程中未修改的数组
        additionalCharacteristics - 此剪辑器的源或超出 SIZED和 SUBSIZED元素的额外拼接器特征，它们始终被报告
        结果
        阵列的拼接器
        异常
        NullPointerException - 如果给定的数组是 null
        另请参见：
        Arrays.spliterator(int[])

      • spliterator

        public static Spliterator.OfInt spliterator​(int[] array,
                                            int fromIndex,
                                            int toIndex,
                                            int additionalCharacteristics)
        创建一个Spliterator.OfInt涵盖了一组给定阵列的元素，使用了一组自定义的拼接器特性。

        该方法被提供为用于将其元素的部分存储在数组中的分割器的实现方便性，并且需要对Spliterator特性的精细控制。 大多数其他情况下，需要使用数组的Spliterator才能使用Arrays.spliterator(int[], int, int) 。

        返回的分配器总是报告特征SIZED和SUBSIZED 。 呼叫者可以为分组报告提供附加特征; 通常还要指定IMMUTABLE和ORDERED 。

        参数
        array - 假定在使用过程中未修改的数组
        fromIndex - 涵盖的最小索引（包括）
        toIndex - 一个过去最大的索引
        additionalCharacteristics - 这个拼接器的源或额外的拼接器特征，超出了 SIZED和 SUBSIZED ，它们始终被报告
        结果
        阵列的拼接器
        异常
        NullPointerException - 如果给定的数组是 null
        ArrayIndexOutOfBoundsException - 如果 fromIndex为负数，则 toIndex小于 fromIndex ，或 toIndex大于数组大小
        另请参见：
        Arrays.spliterator(int[], int, int)

      • spliterator

        public static Spliterator.OfLong spliterator​(long[] array,
                                             int additionalCharacteristics)
        创建一个覆盖给定数组元素的Spliterator.OfLong ，使用一组自定义的分割器特征。

        该方法被提供为用于将其元素的部分存储在数组中的分割器的实现方便性，并且需要对Spliterator特性的精细控制。 大多数其他情况下，需要使用数组的Spliterator才能使用Arrays.spliterator(long[]) 。

        返回的分配器总是报告特征SIZED和SUBSIZED 。 呼叫者可以为分组报告提供附加特征; 通常还要指定IMMUTABLE和ORDERED 。

        参数
        array - 假定在使用过程中未修改的数组
        additionalCharacteristics - 这个拼接器的来源或超出 SIZED和 SUBSIZED元素的额外拼接器特征，它们始终被报告
        结果
        阵列的拼接器
        异常
        NullPointerException - 如果给定的数组是 null
        另请参见：
        Arrays.spliterator(long[])

      • spliterator

        public static Spliterator.OfLong spliterator​(long[] array,
                                             int fromIndex,
                                             int toIndex,
                                             int additionalCharacteristics)
        创建一个Spliterator.OfLong覆盖给定数组的一系列元素，使用一组自定义的拼接器特征。

        该方法被提供为用于将其元素的部分存储在数组中的分割器的实现方便性，并且需要对Spliterator特性的精细控制。 大多数其他情况下，需要使用数组的Spliterator才能使用Arrays.spliterator(long[], int, int) 。

        返回的分配器总是报告特征SIZED和SUBSIZED 。 呼叫者可以为分组器报告提供附加特性。 （例如，如果知道数组不会被进一步修改，请指定IMMUTABLE ;如果数组数据被认为具有相遇顺序，请指定ORDERED ）。 该方法Arrays.spliterator(long[], int, int)通常可以替代地使用，这将返回一个报告spliterator SIZED ， SUBSIZED ， IMMUTABLE ，和ORDERED 。

        参数
        array - 假定在使用过程中未修改的数组
        fromIndex - 涵盖的最小索引（含）
        toIndex - 过去最大的索引之一
        additionalCharacteristics - 这个拼接器的源的附加拼接器特征或超过 SIZED和 SUBSIZED元素总是被报告
        结果
        阵列的拼接器
        异常
        NullPointerException - 如果给定的数组是 null
        ArrayIndexOutOfBoundsException - 如果 fromIndex为负数，则 toIndex小于 fromIndex ，或 toIndex大于数组大小
        另请参见：
        Arrays.spliterator(long[], int, int)

      • spliterator

        public static Spliterator.OfDouble spliterator​(double[] array,
                                               int additionalCharacteristics)
        创建一个Spliterator.OfDouble ，使用定制的一组拼接器特征来覆盖给定数组的元素。

        该方法被提供为用于将其元素的部分存储在数组中的分割器的实现方便性，并且需要对Spliterator特性的精细控制。 大多数其他情况下，需要使用数组的Spliterator才能使用Arrays.spliterator(double[]) 。

        返回的分配器总是报告特征SIZED和SUBSIZED 。 呼叫者可以为分组报告提供附加特征; 通常还要指定IMMUTABLE和ORDERED 。

        参数
        array - 假定在使用过程中未修改的数组
        additionalCharacteristics - 这个拼接器的源的附加拼接器特性或超过 SIZED和 SUBSIZED元素总是被报告
        结果
        阵列的拼接器
        异常
        NullPointerException - 如果给定的数组是 null
        另请参见：
        Arrays.spliterator(double[])

      • spliterator

        public static Spliterator.OfDouble spliterator​(double[] array,
                                               int fromIndex,
                                               int toIndex,
                                               int additionalCharacteristics)
        创建一个Spliterator.OfDouble ，使用定制的一组拼接器特征来覆盖给定阵列的一系列元素。

        该方法被提供为用于将其元素的部分存储在数组中的分割器的实现方便性，并且需要对Spliterator特性的精细控制。 大多数其他情况下，需要使用数组的Spliterator才能使用Arrays.spliterator(double[], int, int) 。

        返回的分配器总是报告特征SIZED和SUBSIZED 。 呼叫者可以为分组器报告提供附加特性。 （例如，如果知道数组不会被进一步修改，请指定IMMUTABLE ;如果数组数据被认为有遇到顺序，请指定ORDERED ）。 该方法Arrays.spliterator(long[], int, int)通常可以替代地使用，这将返回一个报告spliterator SIZED ， SUBSIZED ， IMMUTABLE ，和ORDERED 。

        参数
        array - 假定在使用过程中未修改的数组
        fromIndex - 涵盖的最小索引（包括）
        toIndex - 过去最大的索引之一
        additionalCharacteristics - 这个拼接器的来源或超出 SIZED和 SUBSIZED元素的附加拼接器特征，它们始终被报告
        结果
        阵列的拼接器
        异常
        NullPointerException - 如果给定的数组是 null
        ArrayIndexOutOfBoundsException - 如果 fromIndex为负数，则 toIndex小于 fromIndex ，或 toIndex大于数组大小
        另请参见：
        Arrays.spliterator(double[], int, int)

      • spliterator

        public static <T> Spliterator<T> spliterator​(Collection<? extends T> c,
                                             int characteristics)
        使用给定集合的Collection.iterator()作为元素的来源创建一个Spliterator ，并报告其Collection.size()作为其初始大小。

        拼接器是late-binding ，继承了集合的迭代器的故障快速属性，并实现了trySplit以允许有限的并行性。

        参数类型
        T - 元素类型
        参数
        c - 集合
        characteristics - 此拼接器的源或元素的特征。 特性SIZED和SUBSIZED额外报告除非CONCURRENT供给。
        结果
        来自迭代器的拼接器
        异常
        NullPointerException - 如果给定的集合是 null

      • spliterator

        public static <T> Spliterator<T> spliterator​(Iterator<? extends T> iterator,
                                             long size,
                                             int characteristics)
        使用给定的Iterator作为元素的来源创建一个Spliterator ，并使用给定的最初报告的大小。

        拼接器不是late-binding ，它继承了迭代器的故障快速属性，并实现了trySplit以允许有限的并行性。

        元素穿越应通过拼接器完成。 如果迭代器在分割器返回后操作，或初始报告的大小不等于源中实际的元素数量，则分割和遍历的行为是未定义的。

        参数类型
        T - 元素的类型
        参数
        iterator - 源的迭代器
        size - 源中元素的数量，以初始值 estimateSize报告
        characteristics - 此拼接器的源或元素的特征。 特性SIZED和SUBSIZED额外报告除非CONCURRENT供给。
        结果
        来自迭代器的拼接器
        异常
        NullPointerException - 如果给定的迭代器是 null

      • spliteratorUnknownSize

        public static <T> Spliterator<T> spliteratorUnknownSize​(Iterator<? extends T> iterator,
                                                        int characteristics)
        创建Spliterator使用给定的Iterator作为元素的来源，没有初始大小估计。

        拼接器不是late-binding ，它继承了迭代器的故障快速属性，并实现了trySplit以允许有限的并行性。

        元素穿越应通过拼接器完成。 如果在返回Spliter之后迭代器被操作，则分割和遍历的行为是未定义的。

        参数类型
        T - 元素的类型
        参数
        iterator - 源的迭代器
        characteristics - 此拼接器的源或元素的特征（ SIZED和 SUBSIZED （如果提供）将被忽略且不会报告。）
        结果
        来自迭代器的拼接器
        异常
        NullPointerException - 如果给定的迭代器是 null

      • spliterator

        public static Spliterator.OfInt spliterator​(PrimitiveIterator.OfInt iterator,
                                            long size,
                                            int characteristics)
        使用给定的IntStream.IntIterator作为元素的来源，并以给定的最初报告的大小创建一个Spliterator.OfInt 。

        拼接器不是late-binding ，它继承了迭代器的故障快速属性，并实现了trySplit以允许有限的并行性。

        元素穿越应通过拼接器完成。 如果迭代器在分割器返回后操作，或初始报告的大小不等于源中实际的元素数量，则分割和遍历的行为是未定义的。

        参数
        iterator - 源的迭代器
        size - 源中元素的数量，报告为初始值 estimateSize 。
        characteristics - 此Spliterator的源或元素的特征。 特性SIZED和SUBSIZED额外报告除非CONCURRENT供给。
        结果
        来自迭代器的拼接器
        异常
        NullPointerException - 如果给定的迭代器是 null

      • spliteratorUnknownSize

        public static Spliterator.OfInt spliteratorUnknownSize​(PrimitiveIterator.OfInt iterator,
                                                       int characteristics)
        创建Spliterator.OfInt使用给定的IntStream.IntIterator作为元素的来源，没有初始大小估计。

        拼接器不是late-binding ，它继承了迭代器的故障快速属性，并实现了trySplit以允许有限的并行性。

        元素穿越应通过拼接器完成。 如果在返回Spliter之后迭代器被操作，则分割和遍历的行为是未定义的。

        参数
        iterator - 源的迭代器
        characteristics - 此拼接器的源或元素的特征（ SIZED和 SUBSIZED ，如果提供，将被忽略，不会报告。）
        结果
        来自迭代器的拼接器
        异常
        NullPointerException - 如果给定的迭代器是 null

      • spliterator

        public static Spliterator.OfLong spliterator​(PrimitiveIterator.OfLong iterator,
                                             long size,
                                             int characteristics)
        使用给定的LongStream.LongIterator作为元素的来源创建一个Spliterator.OfLong ，并使用给定的最初报告的大小。

        拼接器不是late-binding ，它继承了迭代器的故障快速属性，并实现了trySplit以允许有限的并行性。

        元素穿越应通过拼接器完成。 如果迭代器在分割器返回后操作，或初始报告的大小不等于源中实际的元素数量，则分割和遍历的行为是未定义的。

        参数
        iterator - 源的迭代器
        size - 源中的元素数，要作为初始值 estimateSize报告。
        characteristics - 此拼接器的来源或元素的特征。 特性SIZED和SUBSIZED额外报告除非CONCURRENT供给。
        结果
        来自迭代器的拼接器
        异常
        NullPointerException - 如果给定的迭代器是 null

      • spliteratorUnknownSize

        public static Spliterator.OfLong spliteratorUnknownSize​(PrimitiveIterator.OfLong iterator,
                                                        int characteristics)
        创建一个Spliterator.OfLong使用给定的LongStream.LongIterator作为元素的来源，没有初始大小估计。

        拼接器不是late-binding ，它继承了迭代器的故障快速属性，并实现了trySplit以允许有限的并行性。

        元素穿越应通过拼接器完成。 如果在返回Spliter之后迭代器被操作，则分割和遍历的行为是未定义的。

        参数
        iterator - 源的迭代器
        characteristics - 此拼接器的来源或元素的特征（ SIZED和 SUBSIZED （如果提供）将被忽略且不会报告。）
        结果
        来自迭代器的拼接器
        异常
        NullPointerException - 如果给定的迭代器是 null

      • spliterator

        public static Spliterator.OfDouble spliterator​(PrimitiveIterator.OfDouble iterator,
                                               long size,
                                               int characteristics)
        创建Spliterator.OfDouble使用给定DoubleStream.DoubleIterator作为元素的来源，并与给定的初始报告的大小。

        拼接器不是late-binding ，它继承了迭代器的故障快速属性，并实现了trySplit以允许有限的并行性。

        元素穿越应通过拼接器完成。 如果迭代器在分割器返回后操作，或初始报告的大小不等于源中实际的元素数量，则分割和遍历的行为是未定义的。

        参数
        iterator - 源的迭代器
        size - 源中的元素数，将作为初始值 estimateSize报告
        characteristics - 此拼接器的源或元素的特征。 特性SIZED和SUBSIZED额外报告除非CONCURRENT供给。
        结果
        来自迭代器的拼接器
        异常
        NullPointerException - 如果给定的迭代器是 null

      • spliteratorUnknownSize

        public static Spliterator.OfDouble spliteratorUnknownSize​(PrimitiveIterator.OfDouble iterator,
                                                          int characteristics)
        创建一个Spliterator.OfDouble使用给定的DoubleStream.DoubleIterator作为元素的来源，没有初始大小估计。

        拼接器不是late-binding ，它继承了迭代器的故障快速属性，并实现了trySplit以允许有限的并行性。

        元素穿越应通过拼接器完成。 如果在返回Spliter之后迭代器被操作，则分割和遍历的行为是未定义的。

        参数
        iterator - 源的迭代器
        characteristics - 此拼接器的源或元素的特征（ SIZED和 SUBSIZED （如果提供）将被忽略且不会报告。）
        结果
        来自迭代器的拼接器
        异常
        NullPointerException - 如果给定的迭代器是 null

      • iterator

        public static <T> Iterator<T> iterator​(Spliterator<? extends T> spliterator)
        创建一个Iterator从Spliterator 。

        元素的遍历应该通过迭代器完成。 如果在返回迭代器之后操作拼接器，则遍历的行为是未定义的。

        参数类型
        T - 元素类型
        参数
        spliterator - 拼接器
        结果
        迭代器
        异常
        NullPointerException - 如果给定的拼接器是 null

      • iterator

        public static PrimitiveIterator.OfInt iterator​(Spliterator.OfInt spliterator)
        创建一个PrimitiveIterator.OfInt从Spliterator.OfInt 。

        元素的遍历应该通过迭代器完成。 如果在返回迭代器之后操作拼接器，则遍历的行为是未定义的。

        参数
        spliterator - 拼接器
        结果
        迭代器
        异常
        NullPointerException - 如果给定的拼接器是 null

      • iterator

        public static PrimitiveIterator.OfLong iterator​(Spliterator.OfLong spliterator)
        创建一个PrimitiveIterator.OfLong从Spliterator.OfLong 。

        元素的遍历应该通过迭代器完成。 如果在返回迭代器之后操作拼接器，则遍历的行为是未定义的。

        参数
        spliterator - 拼接器
        结果
        迭代器
        异常
        NullPointerException - 如果给定的拼接器是 null

      • iterator

        public static PrimitiveIterator.OfDouble iterator​(Spliterator.OfDouble spliterator)
        创建一个PrimitiveIterator.OfDouble从Spliterator.OfDouble 。

        元素的遍历应该通过迭代器完成。 如果在返回迭代器之后操作拼接器，则遍历的行为是未定义的。

        参数
        spliterator - 拼接器
        结果
        迭代器
        异常
        NullPointerException - 如果给定的拼接器是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Spliterators.AbstractDoubleSpliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Spliterators.AbstractDoubleSpliterator

  • java.lang.Object
    • java.util.Spliterators.AbstractDoubleSpliterator
  • All Implemented Interfaces:
    Spliterator<Double> ， Spliterator.OfDouble ， Spliterator.OfPrimitive<Double,DoubleConsumer,Spliterator.OfDouble>
    Enclosing class:
    Spliterators

    public abstract static class Spliterators.AbstractDoubleSpliterator
extends Object
implements Spliterator.OfDouble
    摘要Spliterator.OfDouble实现了trySplit以允许有限的并行性。

    要实现一个扩展类，只需要实现tryAdvance 。 扩展类应该覆盖forEachRemaining，如果它可以提供更高性能的实现。

    API Note:
    当不可能或难以以允许平衡并行计算的方式有效地分割元素时，此类是创建分割器的有用帮助。

    使用这个类的一个替代方法也允许有限的并行性是从迭代器创建一个分割器（参见Spliterators.spliterator(java.util.PrimitiveIterator.OfDouble, long, int)）根据使用迭代器的情况可能比扩展这个类更容易或更方便，例如，如果已经有可以使用的迭代器，那么就不需要扩展这个类。

    从以下版本开始：
    1.8
    另请参见：
    Spliterators.spliterator(java.util.PrimitiveIterator.OfDouble, long, int)

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Spliterator

        Spliterator.OfDouble, Spliterator.OfInt, Spliterator.OfLong, Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>

    • Field Summary

      • Fields inherited from interface java.util.Spliterator

        CONCURRENT, DISTINCT, IMMUTABLE, NONNULL, ORDERED, SIZED, SORTED, SUBSIZED

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractDoubleSpliterator​(long est, int additionalCharacteristics)
      创建一个报告给定估计大小和特征的分配器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int characteristics​()
      返回此Spliterator及其元素的一组特征。
      long estimateSize​()
      返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果为无穷大，未知或计算太贵，则返回 Long.MAX_VALUE 。
      Spliterator.OfDouble trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.util.Spliterator

        getComparator, getExactSizeIfKnown, hasCharacteristics

      • Methods inherited from interface java.util.Spliterator.OfDouble

        forEachRemaining, forEachRemaining, tryAdvance, tryAdvance

    • 构造方法详细信息

      • AbstractDoubleSpliterator

        protected AbstractDoubleSpliterator​(long est,
                                    int additionalCharacteristics)
        创建一个报告给定估计大小和特征的分配器。
        参数
        est - 如果已知该拼接器的大小，否则为 Long.MAX_VALUE 。
        additionalCharacteristics - 此Spliterator的源或元素的属性。 如果SIZED的报告，那么该spliterator将另外报告SUBSIZED 。

    • 方法详细信息

      • trySplit

        public Spliterator.OfDouble trySplit​()
        如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

        如果此Spliterator为Spliterator.ORDERED ，则返回的Spliterator必须覆盖元素的严格前缀。

        除非这个Spliterator包含无数个元素，否则重复调用trySplit()必须最终返回null 。 非空返回：

        • 在拆分之前报告的值为estimateSize() ，分割后必须大于或等于estimateSize()为此和返回的Spliterator; 和
        • 如果这Spliterator是SUBSIZED ，然后estimateSize()这个spliterator分裂之前必须等于总和estimateSize() ，这和拆分后返回Spliterator。

        该方法可能由于任何原因返回null ，包括空虚，遍历开始后无法拆分，数据结构约束和效率考虑。 这种实现允许有限的并行性。

        Specified by:
        trySplit在接口 Spliterator<Double>
        Specified by:
        trySplit在接口 Spliterator.OfDouble
        Specified by:
        trySplit在接口 Spliterator.OfPrimitive<Double,DoubleConsumer,Spliterator.OfDouble>
        结果
        一个 Spliterator覆盖了元素的一部分，或者 null如果这个拼接器不能被拆分

      • estimateSize

        public long estimateSize​()
        返回Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果无穷大，未知或计算太贵，则返回Long.MAX_VALUE 。

        如果此Spliterator是Spliterator.SIZED并且尚未被部分遍历或拆分，或者该Spliterator是Spliterator.SUBSIZED并且尚未被部分遍历，则此估计必须是完整遍历将遇到的元素的精确计数。 否则，此估计可能是任意不准确的，但必须按照Spliterator.trySplit()的调用规定减少 。

        Specified by:
        estimateSize在接口 Spliterator<Double>
        实现要求：
        此实现返回创建时报告的估计大小，如果估计大小已知，则在分割时会减小大小。
        结果
        估计大小，或 Long.MAX_VALUE如果无限，未知，或太贵无法计算。

      • characteristics

        public int characteristics​()
        返回此Spliterator及其元素的一组特征。 结果从表示为或运算值Spliterator.ORDERED ， Spliterator.DISTINCT ， Spliterator.SORTED ， Spliterator.SIZED ， Spliterator.NONNULL ， Spliterator.IMMUTABLE ， Spliterator.CONCURRENT ， Spliterator.SUBSIZED 。 在给定的分配器之前或之前或之间呼叫trySplit重复呼叫characteristics()应始终返回相同的结果。

        如果Spliterator报告不一致的特征集（从单个调用返回的或多个调用返回的），则不能保证使用此Spliter的任何计算。

        Specified by:
        characteristics在接口 Spliterator<Double>
        实现要求：
        此实现返回创建时报告的特征。
        结果
        特征的表征
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Spliterators.AbstractIntSpliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Spliterators.AbstractIntSpliterator

  • java.lang.Object
    • java.util.Spliterators.AbstractIntSpliterator
  • All Implemented Interfaces:
    Spliterator<Integer> ， Spliterator.OfInt ， Spliterator.OfPrimitive<Integer,IntConsumer,Spliterator.OfInt>
    Enclosing class:
    Spliterators

    public abstract static class Spliterators.AbstractIntSpliterator
extends Object
implements Spliterator.OfInt
    一个抽象的Spliterator.OfInt实现trySplit以允许有限的并行性。

    为了实现一个扩展类，只需要实现tryAdvance 。 如果扩展类可以提供更高性能的实现，则应该覆盖forEachRemaining 。

    API Note:
    当不可能或难以以允许平衡并行计算的方式有效地分割元素时，此类是创建分割器的有用帮助。

    使用这个类的一个替代方法也允许有限的并行性是从迭代器创建一个分片器（参见Spliterators.spliterator(java.util.PrimitiveIterator.OfInt, long, int)）根据使用迭代器的情况可能比扩展这个类更容易或更方便，例如，如果已经有可以使用的迭代器，那么就不需要扩展这个类。

    从以下版本开始：
    1.8
    另请参见：
    Spliterators.spliterator(java.util.PrimitiveIterator.OfInt, long, int)

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Spliterator

        Spliterator.OfDouble, Spliterator.OfInt, Spliterator.OfLong, Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>

    • Field Summary

      • Fields inherited from interface java.util.Spliterator

        CONCURRENT, DISTINCT, IMMUTABLE, NONNULL, ORDERED, SIZED, SORTED, SUBSIZED

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractIntSpliterator​(long est, int additionalCharacteristics)
      创建一个报告给定估计大小和特征的分配器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int characteristics​()
      返回此Spliterator及其元素的一组特征。
      long estimateSize​()
      返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计，如果无穷大，未知数或计算成本太高，则返回 Long.MAX_VALUE 。
      Spliterator.OfInt trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.util.Spliterator

        getComparator, getExactSizeIfKnown, hasCharacteristics

      • Methods inherited from interface java.util.Spliterator.OfInt

        forEachRemaining, forEachRemaining, tryAdvance, tryAdvance

    • 构造方法详细信息

      • AbstractIntSpliterator

        protected AbstractIntSpliterator​(long est,
                                 int additionalCharacteristics)
        创建一个报告给定估计大小和特征的分配器。
        参数
        est - 如果已知，此拼接器的估计大小，否则为 Long.MAX_VALUE 。
        additionalCharacteristics - 此拼接器的源或元素的属性。 如果SIZED的报告，那么该spliterator将另外报告SUBSIZED 。

    • 方法详细信息

      • trySplit

        public Spliterator.OfInt trySplit​()
        如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

        如果此Spliterator是Spliterator.ORDERED ，则返回的Spliterator必须覆盖元素的严格前缀。

        除非这个Spliterator覆盖了无数的元素，否则重复调用trySplit()必须最终返回null 。 非空返回：

        • 在拆分之前报告的值为estimateSize() ，分割后必须大于或等于estimateSize()为此和返回的Spliterator; 和
        • 如果这Spliterator是SUBSIZED ，然后estimateSize()这个spliterator分裂之前必须等于总和estimateSize() ，这和拆分后返回Spliterator。

        该方法可能由于任何原因返回null ，包括空虚，遍历开始后无法拆分，数据结构约束和效率考虑。 这种实现允许有限的并行性。

        Specified by:
        trySplit在接口 Spliterator<Integer>
        Specified by:
        trySplit在接口 Spliterator.OfInt
        Specified by:
        trySplit在接口 Spliterator.OfPrimitive<Integer,IntConsumer,Spliterator.OfInt>
        结果
        一个 Spliterator涵盖了部分元素，或 null如果这个拼接器不能被拆分

      • estimateSize

        public long estimateSize​()
        返回Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计，如果无穷大，未知数或计算成本太高，则返回Long.MAX_VALUE 。

        如果此Spliterator为Spliterator.SIZED ，尚未部分遍历或拆分，或该Spliterator为Spliterator.SUBSIZED ，尚未部分遍历，则此估计值必须是完整遍历将遇到的元素的精确计数。 否则，此估计可能是任意不准确的，但必须按照Spliterator.trySplit()的调用指定减少。

        Specified by:
        estimateSize在接口 Spliterator<Integer>
        实现要求：
        此实现返回创建时报告的估计大小，如果估计大小已知，则在分割时会减小大小。
        结果
        估计大小，或 Long.MAX_VALUE如果无限，未知，或太贵的计算。

      • characteristics

        public int characteristics​()
        返回此Spliterator及其元素的一组特征。 结果从表示为或运算值Spliterator.ORDERED ， Spliterator.DISTINCT ， Spliterator.SORTED ， Spliterator.SIZED ， Spliterator.NONNULL ， Spliterator.IMMUTABLE ， Spliterator.CONCURRENT ， Spliterator.SUBSIZED 。 在给定的分配器之前或之前或之间呼叫trySplit重复呼叫characteristics()应始终返回相同的结果。

        如果Spliterator报告不一致的特征集（从单个调用返回的或多个调用返回的），则不能保证使用此Spliter的任何计算。

        Specified by:
        characteristics在接口 Spliterator<Integer>
        实现要求：
        此实现返回创建时报告的特征。
        结果
        特征的表征
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Spliterators.AbstractLongSpliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Spliterators.AbstractLongSpliterator

  • java.lang.Object
    • java.util.Spliterators.AbstractLongSpliterator
  • All Implemented Interfaces:
    Spliterator<Long> ， Spliterator.OfLong ， Spliterator.OfPrimitive<Long,LongConsumer,Spliterator.OfLong>
    Enclosing class:
    Spliterators

    public abstract static class Spliterators.AbstractLongSpliterator
extends Object
implements Spliterator.OfLong
    一个抽象的Spliterator.OfLong实现trySplit以允许有限的并行性。

    为了实现一个扩展类，只需要实现tryAdvance 。 扩展类应该覆盖forEachRemaining，如果它可以提供更高性能的实现。

    API Note:
    当不可能或难以以允许平衡并行计算的方式有效地分割元素时，此类是创建分割器的有用帮助。

    使用这个类的一个替代方法也允许有限的并行性是从迭代器创建一个分片器（参见Spliterators.spliterator(java.util.PrimitiveIterator.OfLong, long, int)）根据使用迭代器的情况可能比扩展这个类更容易或更方便，例如，如果已经有可以使用的迭代器，那么就不需要扩展这个类。

    从以下版本开始：
    1.8
    另请参见：
    Spliterators.spliterator(java.util.PrimitiveIterator.OfLong, long, int)

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Spliterator

        Spliterator.OfDouble, Spliterator.OfInt, Spliterator.OfLong, Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>

    • Field Summary

      • Fields inherited from interface java.util.Spliterator

        CONCURRENT, DISTINCT, IMMUTABLE, NONNULL, ORDERED, SIZED, SORTED, SUBSIZED

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractLongSpliterator​(long est, int additionalCharacteristics)
      创建一个报告给定估计大小和特征的分配器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int characteristics​()
      返回此Spliterator及其元素的一组特征。
      long estimateSize​()
      返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果无穷大，未知或计算太贵，则返回 Long.MAX_VALUE 。
      Spliterator.OfLong trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.util.Spliterator

        getComparator, getExactSizeIfKnown, hasCharacteristics

      • Methods inherited from interface java.util.Spliterator.OfLong

        forEachRemaining, forEachRemaining, tryAdvance, tryAdvance

    • 构造方法详细信息

      • AbstractLongSpliterator

        protected AbstractLongSpliterator​(long est,
                                  int additionalCharacteristics)
        创建一个报告给定估计大小和特征的分配器。
        参数
        est - 如果已知该拼接器的大小，否则为 Long.MAX_VALUE 。
        additionalCharacteristics - 此拼接器的源或元素的属性。 如果SIZED的报告，那么该spliterator将另外报告SUBSIZED 。

    • 方法详细信息

      • trySplit

        public Spliterator.OfLong trySplit​()
        如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

        如果此Spliterator为Spliterator.ORDERED ，则返回的Spliterator必须覆盖元素的严格前缀。

        除非这个Spliterator包含无数个元素，否则重复调用trySplit()必须最终返回null 。 非空返回：

        • 报告的价值estimateSize()分裂之前，必须分割后，大于或等于estimateSize() ，这和返回Spliterator; 和
        • 如果这Spliterator是SUBSIZED ，然后estimateSize()这个spliterator分裂之前必须等于总和estimateSize() ，这和拆分后返回Spliterator。

        该方法可能由于任何原因返回null ，包括空虚，遍历开始后无法拆分，数据结构约束和效率考虑。 这种实现允许有限的并行性。

        Specified by:
        trySplit在接口 Spliterator<Long>
        Specified by:
        trySplit在接口 Spliterator.OfLong
        Specified by:
        trySplit在接口 Spliterator.OfPrimitive<Long,LongConsumer,Spliterator.OfLong>
        结果
        一个 Spliterator覆盖部分元素，或 null如果这个拼接器不能被拆分

      • estimateSize

        public long estimateSize​()
        返回Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果无穷大，未知或计算太贵，则返回Long.MAX_VALUE 。

        如果此Spliterator是Spliterator.SIZED并且尚未部分遍历或拆分，或该Spliterator为Spliterator.SUBSIZED并且尚未部分遍历，则此估计必须是完整遍历将遇到的元素的精确计数。 否则，此估计可能是任意不准确的，但必须按照Spliterator.trySplit()的调用指定减少。

        Specified by:
        estimateSize在接口 Spliterator<Long>
        实现要求：
        此实现返回创建时报告的估计大小，如果估计大小已知，则在分割时会减小大小。
        结果
        估计大小，或 Long.MAX_VALUE如果无限，未知或太贵，无法计算。

      • characteristics

        public int characteristics​()
        返回此Spliterator及其元素的一组特征。 结果从表示为或运算值Spliterator.ORDERED ， Spliterator.DISTINCT ， Spliterator.SORTED ， Spliterator.SIZED ， Spliterator.NONNULL ， Spliterator.IMMUTABLE ， Spliterator.CONCURRENT ， Spliterator.SUBSIZED 。 重复调用characteristics()在给定的spliterator之前或在两者之间的调用， trySplit ，应始终返回相同的结果。

        如果Spliterator报告不一致的特征集（从单个调用返回的或多个调用返回的），则不能保证使用此Spliter的任何计算。

        Specified by:
        characteristics在接口 Spliterator<Long>
        实现要求：
        此实现返回创建时报告的特征。
        结果
        特征的表征
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Spliterators.AbstractSpliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Spliterators.AbstractSpliterator<T>

  • java.lang.Object
    • java.util.Spliterators.AbstractSpliterator<T>
  • All Implemented Interfaces:
    Spliterator<T>
    Enclosing class:
    Spliterators

    public abstract static class Spliterators.AbstractSpliterator<T>
extends Object
implements Spliterator<T>
    摘要Spliterator实现trySplit以允许有限的并行性。

    扩展类只需要实现tryAdvance 。 扩展类应该覆盖forEachRemaining，如果它可以提供更高性能的实现。

    API Note:
    当不可能或难以以允许平衡并行计算的方式有效地分割元素时，此类是创建分割器的有用帮助。

    使用这个类的一个替代方法也允许有限的并行性是从迭代器创建一个分割器（参见Spliterators.spliterator(Iterator, long, int)）根据使用迭代器的情况可能比扩展这个类更容易或更方便，例如当已经有迭代器可供使用。

    从以下版本开始：
    1.8
    另请参见：
    Spliterators.spliterator(Iterator, long, int)

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Spliterator

        Spliterator.OfDouble, Spliterator.OfInt, Spliterator.OfLong, Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>

    • Field Summary

      • Fields inherited from interface java.util.Spliterator

        CONCURRENT, DISTINCT, IMMUTABLE, NONNULL, ORDERED, SIZED, SORTED, SUBSIZED

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractSpliterator​(long est, int additionalCharacteristics)
      创建一个报告给定估计大小和附加特征的分配器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int characteristics​()
      返回此Spliterator及其元素的一组特征。
      long estimateSize​()
      返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计，如果是无限的，未知的或计算太贵，则返回 Long.MAX_VALUE 。
      Spliterator<T> trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.util.Spliterator

        forEachRemaining, getComparator, getExactSizeIfKnown, hasCharacteristics, tryAdvance

    • 构造方法详细信息

      • AbstractSpliterator

        protected AbstractSpliterator​(long est,
                              int additionalCharacteristics)
        创建一个报告给定估计大小和附加特征的分配器。
        参数
        est - 如果已知此拼接器的大小，否则为 Long.MAX_VALUE 。
        additionalCharacteristics - 此拼接器的源或元素的属性。 如果SIZED的报告，那么该spliterator将另外报告SUBSIZED 。

    • 方法详细信息

      • trySplit

        public Spliterator<T> trySplit​()
        如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

        如果此Spliterator为Spliterator.ORDERED ，则返回的Spliterator必须覆盖元素的严格前缀。

        除非这个Spliterator包含无数个元素，否则重复调用trySplit()必须最终返回null 。 非空返回：

        • 报告的价值estimateSize()分裂之前，必须分割后，大于或等于estimateSize() ，这和返回Spliterator; 和
        • 如果这Spliterator是SUBSIZED ，然后estimateSize()这个spliterator分裂之前必须等于总和estimateSize() ，这和拆分后返回Spliterator。

        该方法可能由于任何原因返回null ，包括空虚，遍历开始后无法拆分，数据结构约束和效率考虑。 这种实现允许有限的并行性。

        Specified by:
        trySplit在接口 Spliterator<T>
        结果
        一个 Spliterator涵盖了部分元素，或 null如果此拼接器无法拆分

      • estimateSize

        public long estimateSize​()
        返回Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果无穷大，未知数或计算成本太高，则返回Long.MAX_VALUE 。

        如果此Spliterator是Spliterator.SIZED并且尚未被部分遍历或拆分，或者该分割器是Spliterator.SUBSIZED并且尚未被部分遍历，则此估计必须是完整遍历将遇到的元素的精确计数。 否则，该估计可能是任意不准确的，但必须按照Spliterator.trySplit()的调用中的规定减少。

        Specified by:
        estimateSize在接口 Spliterator<T>
        实现要求：
        此实现返回创建时报告的估计大小，如果估计大小已知，则在分割时会减小大小。
        结果
        估计大小，或 Long.MAX_VALUE如果无限，未知或太贵，无法计算。

      • characteristics

        public int characteristics​()
        返回此Spliterator及其元素的一组特征。 结果从表示为或运算值Spliterator.ORDERED ， Spliterator.DISTINCT ， Spliterator.SORTED ， Spliterator.SIZED ， Spliterator.NONNULL ， Spliterator.IMMUTABLE ， Spliterator.CONCURRENT ， Spliterator.SUBSIZED 。 重复调用characteristics()在给定的spliterator之前或在两者之间的调用， trySplit ，应始终返回相同的结果。

        如果Spliterator报告不一致的特征集（从单个调用返回的或多个调用返回的），则不能保证使用此Spliter的任何计算。

        Specified by:
        characteristics在接口 Spliterator<T>
        实现要求：
        此实现返回创建时报告的特征。
        结果
        特征的表征
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SplittableRandom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class SplittableRandom

  • java.lang.Object
    • java.util.SplittableRandom

  • public final class SplittableRandom
extends Object
    适用于（在其他上下文中）使用可能产生子任务的孤立并行计算的均匀伪随机值的生成器。 类SplittableRandom支持方法用于生产类型的伪随机数int ， long和double具有类似用途作为类Random但在以下方面不同：
    • 系列生成值通过了DieHarder套件测试随机数发生器的独立性和均匀性。 （最近使用version 3.31.1进行了验证。）这些测试仅验证某些类型和范围的方法，但是类似的属性预期至少约为其他类型。 期间 （其重复之前的任何一系列生成值的长度）至少为2 64 。
    • 方法split()构造并返回与当前实例不共享状态的新SplitableRandom实例。 然而，以非常高的概率，由两个对象共同生成的值具有与使用单个SplittableRandom对象的单个线程生成相同数量的值相同的统计特性。
    • SplittableRandom的实例不是线程安全的。 它们被设计为跨线程分割，不共享。 例如，使用随机数的fork/join-style计算可能包括形式为new Subtask(aSplittableRandom.split()).fork() 。
    • 该类提供了用于生成随机流的附加方法，在stream.parallel()模式下使用上述技术。

    SplittableRandom实例不是加密安全的。 考虑在安全敏感的应用程序中使用SecureRandom 。 此外，默认构造的实例不使用加密随机种子，除非system property java.util.secureRandomSeed设置为true 。

    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      SplittableRandom​()
      创建一个新的SplittableRandom实例，可能会生成与当前程序中任何其他实例统计上独立的值序列; 并且通常可以在程序调用中变化。
      SplittableRandom​(long seed)
      使用指定的初始种子创建一个新的SplittableRandom实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleStream doubles​()
      返回一个有效的无限流的伪随机数double来自该发生器和/或从它的一个分割值; 每个值在零（包括）和一（独占）之间。
      DoubleStream doubles​(double randomNumberOrigin, double randomNumberBound)
      返回一个有效的无限流的伪随机数double值来自该生成器和/或一个从它分割; 每个值符合给定的起始（包括）和绑定（排他）。
      DoubleStream doubles​(long streamSize)
      返回产生所述给定流streamSize数的伪随机的double从该发电机和/或从它一个分割值; 每个值在零（包括）和一（独占）之间。
      DoubleStream doubles​(long streamSize, double randomNumberOrigin, double randomNumberBound)
      返回产生所述给定流streamSize数的伪随机的double从该发电机和/或从它一个分割值; 每个值符合给定的起始（包括）和绑定（排他）。
      IntStream ints​()
      返回一个有效的无限流的伪随机数 int值来自该生成器和/或一次分割。
      IntStream ints​(int randomNumberOrigin, int randomNumberBound)
      返回一个有效的无限流的伪随机数int值来自该发生器和/或一个从它分裂; 每个值符合给定的起始（包括）和绑定（排他）。
      IntStream ints​(long streamSize)
      返回一个流，产生给定的 streamSize伪随机 int从这个发生器和/或从它的一个分割。
      IntStream ints​(long streamSize, int randomNumberOrigin, int randomNumberBound)
      返回一个流，产生给定的streamSize伪随机int从这个发生器和/或从它的一个分裂值; 每个值符合给定的起始（包括）和绑定（排他）。
      LongStream longs​()
      返回一个有效的无限流的伪随机数 long值来自该生成器和/或一个分割。
      LongStream longs​(long streamSize)
      返回一个流，该流从该生成器生成给定的 streamSize个伪随机数 long值，和/或从该生成器中分离出一个值。
      LongStream longs​(long randomNumberOrigin, long randomNumberBound)
      从该生成器返回有效的无限流的伪随机long ，并从其中分离出一个值; 每个值符合给定的起始（包括）和绑定（排他）。
      LongStream longs​(long streamSize, long randomNumberOrigin, long randomNumberBound)
      返回产生所述给定流streamSize数的伪随机的long从该发电机和/或从它一个分割值; 每个值符合给定的起始（包括）和绑定（排他）。
      boolean nextBoolean​()
      返回一个伪随机值 boolean 。
      double nextDouble​()
      返回零（含）和一（独占）之间的伪随机值 double 。
      double nextDouble​(double bound)
      返回值在0.0（含）之间的伪随机 double和指定的绑定（排除）之间。
      double nextDouble​(double origin, double bound)
      返回指定的起始（包括）和绑定（排除）之间的伪随机值 double 。
      int nextInt​()
      返回伪随机数 int值。
      int nextInt​(int bound)
      返回0（包括）和指定的bound（exclusive）之间的伪随机值 int 。
      int nextInt​(int origin, int bound)
      返回指定的原点（含）和指定的界限（排除）之间的伪随机值 int 。
      long nextLong​()
      返回一个伪随机值 long 。
      long nextLong​(long bound)
      返回0（包括）和指定的bound（exclusive）之间的伪随机值 long 。
      long nextLong​(long origin, long bound)
      返回指定的起始（含）和指定的界限（排除）之间的伪随机值 long 。
      SplittableRandom split​()
      构造并返回一个新的SplittableRandom实例，与该实例共享不可变状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SplittableRandom

        public SplittableRandom​(long seed)
        使用指定的初始种子创建一个新的SplittableRandom实例。 在同一程序中使用相同种子创建的SplittableRandom实例生成相同的值序列。
        参数
        seed - 初始种子

      • SplittableRandom

        public SplittableRandom​()
        创建一个新的SplittableRandom实例，可能会生成与当前程序中任何其他实例统计上独立的值序列; 并且通常可以在程序调用中变化。

    • 方法详细信息

      • split

        public SplittableRandom split​()
        构造并返回一个新的SplittableRandom实例，与该实例共享不可变状态。 然而，以非常高的概率，由两个对象共同生成的值集合具有与使用单个SplittableRandom对象的单个线程生成相同数量的值相同的统计属性。 可以使用split()方法进一步拆分两个对象中的一个或两个，并且相同的预期统计特性适用于通过这种递归拆分构造的整个生成器集合。
        结果
        新的SplittableRandom实例

      • nextInt

        public int nextInt​()
        返回一个伪随机数 int值。
        结果
        一个伪随机数 int

      • nextInt

        public int nextInt​(int bound)
        返回0（包括）和指定的绑定（排除）之间的伪随机 int值。
        参数
        bound - 上限（独占）。 必须是积极的。
        结果
        零（包括）和绑定（独占）之间的伪随机值 int
        异常
        IllegalArgumentException - 如果 bound

      • nextInt

        public int nextInt​(int origin,
                   int bound)
        返回指定的原点（含）和指定的界限（排除）之间的伪随机值 int 。
        参数
        origin - 返回的值最小
        bound - 上限（独占）
        结果
        原始（含）和绑定（排他性）之间的伪随机数 int值
        异常
        IllegalArgumentException - 如果 origin大于或等于 bound

      • nextLong

        public long nextLong​()
        返回伪随机值 long 。
        结果
        一个伪随机的 long值

      • nextLong

        public long nextLong​(long bound)
        返回0（包括）和指定的bound（exclusive）之间的伪随机值 long 。
        参数
        bound - 上限（独占）。 必须是积极的。
        结果
        一个伪随机 long （ long在零（包括）和绑定（独占）之间的值
        异常
        IllegalArgumentException - 如果 bound

      • nextLong

        public long nextLong​(long origin,
                     long bound)
        返回指定的起始（含）和指定的界限（排除）之间的伪随机值 long 。
        参数
        origin - 返回的值最小
        bound - 上限（独占）
        结果
        原始（含）和绑定（排他性）之间的伪随机值 long
        异常
        IllegalArgumentException - 如果 origin大于或等于 bound

      • nextDouble

        public double nextDouble​()
        返回零（含）和一（独占）之间的伪随机数 double值。
        结果
        零（含）和一（独占）之间的伪随机 double值

      • nextDouble

        public double nextDouble​(double bound)
        返回在0.0（含）和指定的约束（排除）之间的伪随机数 double值。
        参数
        bound - 上限（独占）。 必须是积极的。
        结果
        零（包括）和绑定（独占）之间的伪随机 double值
        异常
        IllegalArgumentException - 如果 bound

      • nextDouble

        public double nextDouble​(double origin,
                         double bound)
        返回指定原点（含）和绑定（排除）之间的伪随机值 double 。
        参数
        origin - 返回的值最小
        bound - 上限（独占）
        结果
        原始（含）和限制（排他性）之间的伪随机值 double
        异常
        IllegalArgumentException - 如果 origin大于或等于 bound

      • nextBoolean

        public boolean nextBoolean​()
        返回一个伪随机数 boolean值。
        结果
        一个伪随机的 boolean值

      • ints

        public IntStream ints​(long streamSize)
        返回产生给定的 streamSize伪随机 int从这个发生器和/或从它的一个分割的数据流。
        参数
        streamSize - 要生成的值的数量
        结果
        一串伪随机数 int
        异常
        IllegalArgumentException - 如果 streamSize小于零

      • ints

        public IntStream ints​()
        返回一个有效的无限流的伪随机数 int来自该发生器和/或从它的一个分割。
        Implementation Note:
        该方法实现为等同于 ints(Long.MAX_VALUE) 。
        结果
        一串伪随机数 int

      • ints

        public IntStream ints​(long streamSize,
                      int randomNumberOrigin,
                      int randomNumberBound)
        返回一个流，产生给定的streamSize数量的伪随机数int值来自该发生器和/或从其分离一个; 每个值符合给定的起始（包括）和绑定（排他）。
        参数
        streamSize - 要生成的值的数量
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数的 int ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 streamSize小于零，或 randomNumberOrigin大于或等于 randomNumberBound

      • ints

        public IntStream ints​(int randomNumberOrigin,
                      int randomNumberBound)
        返回一个有效的无限流的伪随机数int来自该发生器和/或从它的一个分割值; 每个值符合给定的起始（包括）和绑定（排他）。
        Implementation Note:
        该方法实现为等同于 ints(Long.MAX_VALUE, randomNumberOrigin, randomNumberBound) 。
        参数
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        伪随机流 int值，每个值与所述给定原点（含）和结合（不包括）
        异常
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound

      • longs

        public LongStream longs​(long streamSize)
        返回一个流，从该生成器生成给定的 streamSize个伪随机数 long值，和/或从该生成器中分离出一个值。
        参数
        streamSize - 要生成的值的数量
        结果
        一串伪随机数 long
        异常
        IllegalArgumentException - 如果 streamSize小于零

      • longs

        public LongStream longs​()
        返回一个有效地无限流的伪随机数 long值来自该生成器和/或一个从它分割的值。
        Implementation Note:
        该方法实现为等同于 longs(Long.MAX_VALUE) 。
        结果
        一串伪随机数 long值

      • longs

        public LongStream longs​(long streamSize,
                        long randomNumberOrigin,
                        long randomNumberBound)
        返回产生所述给定流streamSize数的伪随机的long从该发电机和/或从它一个分割值; 每个值符合给定的起始（包括）和绑定（排他）。
        参数
        streamSize - 要生成的值的数量
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机 long ， long ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 streamSize小于零，或 randomNumberOrigin大于或等于 randomNumberBound

      • longs

        public LongStream longs​(long randomNumberOrigin,
                        long randomNumberBound)
        返回一个有效的无限流的伪随机数long来自该发生器和/或从它的一个分裂值; 每个值符合给定的起始（包括）和绑定（排他）。
        Implementation Note:
        该方法实现为等同于 longs(Long.MAX_VALUE, randomNumberOrigin, randomNumberBound) 。
        参数
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数（ long ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound

      • doubles

        public DoubleStream doubles​(long streamSize)
        返回一个流，产生给定的streamSize数量的伪随机数double来自该发生器和/或从它的一个分割值; 每个值在零（包括）和一（独占）之间。
        参数
        streamSize - 要生成的值的数量
        结果
        一串 double值
        异常
        IllegalArgumentException - 如果 streamSize小于零

      • doubles

        public DoubleStream doubles​()
        返回一个有效的无限流的伪随机数double来自该发生器和/或从它的一个分裂值; 每个值在零（包括）和一（独占）之间。
        Implementation Note:
        该方法实现为等同于 doubles(Long.MAX_VALUE) 。
        结果
        一串伪随机数 double

      • doubles

        public DoubleStream doubles​(long streamSize,
                            double randomNumberOrigin,
                            double randomNumberBound)
        返回一个流，产生给定的streamSize伪随机数double值，该值来自该发生器和/或从其分离; 每个值符合给定的起始（包括）和绑定（排他）。
        参数
        streamSize - 要生成的值的数量
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数（ double ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 streamSize小于零，或 randomNumberOrigin大于或等于 randomNumberBound

      • doubles

        public DoubleStream doubles​(double randomNumberOrigin,
                            double randomNumberBound)
        返回一个有效的无限流的伪随机数double从这个发生器和/或从它的一个分裂值; 每个值符合给定的起始（包括）和绑定（排他）。
        Implementation Note:
        该方法实现为等同于 doubles(Long.MAX_VALUE, randomNumberOrigin, randomNumberBound) 。
        参数
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数（ double ，每个都有给定的来源（包括）和绑定（独占）
        异常
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Stack (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Stack<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • java.util.Vector<E>
          • java.util.Stack<E>
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， List<E> ， RandomAccess

    public class Stack<E>
extends Vector<E>
    Stack类代表最先进先出（LIFO）堆栈的对象。 它扩展了类Vector与五个操作，允许一个向量作为一个堆栈。 通常push和pop设置操作，以及作为一种方法来peek在堆栈，以测试堆栈是否为一个方法在顶部项目empty ，以及一种方法search堆栈一个项目，并发现多远它是从顶部。

    当首次创建堆栈时，它不包含项目。

    更完整和一致的LIFO堆栈操作集由Deque接口及其实现提供，应优先于此类使用。 例如：

       Deque<Integer> stack = new ArrayDeque<Integer>();
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.AbstractList

        modCount

      • Fields inherited from class java.util.Vector

        capacityIncrement, elementCount, elementData

    • 构造方法摘要

      构造方法
      Constructor 描述
      Stack​()
      创建一个空堆栈。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean empty​()
      测试此堆栈是否为空。
      E peek​()
      查看此堆栈顶部的对象，而不从堆栈中删除它。
      E pop​()
      删除此堆栈顶部的对象，并将该对象作为此函数的值返回。
      E push​(E item)
      将项目推送到此堆栈的顶部。
      int search​(Object o)
      返回一个对象在此堆栈上的基于1的位置。

      • Methods inherited from interface java.util.Collection

        parallelStream, stream

      • Methods inherited from interface java.util.List

        of, of, of, of, of, of, of, of, of, of, of, of

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.util.Vector

        add, add, addAll, addAll, addElement, capacity, clear, clone, contains, containsAll, copyInto, elementAt, elements, ensureCapacity, equals, firstElement, forEach, get, hashCode, indexOf, indexOf, insertElementAt, isEmpty, iterator, lastElement, lastIndexOf, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, removeAllElements, removeElement, removeElementAt, removeIf, removeRange, replaceAll, retainAll, set, setElementAt, setSize, size, sort, spliterator, subList, toArray, toArray, toString, trimToSize

    • 构造方法详细信息

      • Stack

        public Stack​()
        创建一个空堆栈。

    • 方法详细信息

      • push

        public E push​(E item)
        将项目推送到此堆栈的顶部。 这与以下效果完全相同：
         addElement(item)
        参数
        item - 要推送到此堆栈的项目。
        结果
        item参数。
        另请参见：
        Vector.addElement(E)

      • pop

        public E pop​()
        删除此堆栈顶部的对象，并将该对象作为此函数的值返回。
        结果
        该堆栈顶部的对象（ Vector对象的最后一个项目）。
        异常
        EmptyStackException - 如果这个堆栈是空的。

      • peek

        public E peek​()
        查看此堆栈顶部的对象，而不从堆栈中删除它。
        结果
        该堆栈顶部的对象（ Vector对象的最后一个项目）。
        异常
        EmptyStackException - 如果这个堆栈是空的。

      • empty

        public boolean empty​()
        测试此堆栈是否为空。
        结果
        true当且仅当此堆栈不包含项目时; false否则。

      • search

        public int search​(Object o)
        返回一个对象在此堆栈上的基于1的位置。 如果对象o作为该堆栈中的项目发生，则该方法返回距堆栈顶部最近堆栈顶部的距离; 堆栈中最上面的项目被认为是距离1 。 equals方法用于将o与此堆栈中的项目进行比较。
        参数
        o - 所需的对象。
        结果
        从该对象所在的堆栈顶部的基于1的位置; 返回值-1表示对象不在堆栈上。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringJoiner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class StringJoiner

  • java.lang.Object
    • java.util.StringJoiner

  • public final class StringJoiner
extends Object
    StringJoiner用于构建由分隔符分隔的字符序列，并且可选地从提供的前缀开始，并以提供的后缀结尾。

    在向StringJoiner添加内容之前，其sj.toString()方法将默认返回prefix + suffix 。 但是，如果调用了setEmptyValue方法，则将返回提供的emptyValue 。 这可用于，例如，使用一组表示法来表示空集，即创建字符串时"{}" ，其中prefix是"{"时， suffix是"}"和什么也没有添加到StringJoiner 。

    API Note:

    字符串"[George:Sally:Fred]"可以被构造如下：

       StringJoiner sj = new StringJoiner(":", "[", "]"); sj.add("George").add("Sally").add("Fred"); String desiredString = sj.toString();

    A StringJoiner可以用于使用Collectors.joining(CharSequence)从Stream创建格式化的输出。 例如：

       List<Integer> numbers = Arrays.asList(1, 2, 3, 4); String commaSeparatedNumbers = numbers.stream() .map(i -> i.toString()) .collect(Collectors.joining(", "));
    从以下版本开始：
    1.8
    另请参见：
    Collectors.joining(CharSequence) ， Collectors.joining(CharSequence, CharSequence, CharSequence)

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringJoiner​(CharSequence delimiter)
      构造一个 StringJoiner与其中不带字符，没有 prefix或 suffix ，和所提供的副本 delimiter 。
      StringJoiner​(CharSequence delimiter, CharSequence prefix, CharSequence suffix)
      构造一个 StringJoiner使用的供给拷贝在不带字符 prefix ， delimiter和 suffix 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      StringJoiner add​(CharSequence newElement)
      将给定的副本 CharSequence值作为下一个元素 StringJoiner值。
      int length​()
      返回此 StringJoiner的 String表示的 StringJoiner 。
      StringJoiner merge​(StringJoiner other)
      添加给定的 StringJoiner的内容，不带前缀和后缀作为下一个元素，如果它是非空的。
      StringJoiner setEmptyValue​(CharSequence emptyValue)
      设置确定 StringJoiner的字符串表示时使用的字符序列，并且尚未添加任何元素，即当它为空时。
      String toString​()
      返回当前值，由 prefix ，由 delimiter分隔的值以及 suffix ，除非没有添加任何元素，否则返回 prefix + suffix或 emptyValue字符。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StringJoiner

        public StringJoiner​(CharSequence delimiter)
        构造一个StringJoiner其中没有字符，没有prefix或suffix ，以及所提供的delimiter的副本。 如果没有字符被添加到StringJoiner种方法访问它被调用的值，它不会返回一个prefix或suffix在结果（或其特性），除非setEmptyValue已首先被调用。
        参数
        delimiter - 要添加到 StringJoiner每个元素之间的字符序列
        异常
        NullPointerException - 如果 delimiter是 null

      • StringJoiner

        public StringJoiner​(CharSequence delimiter,
                    CharSequence prefix,
                    CharSequence suffix)
        构造一个StringJoiner使用的供给拷贝在不带字符prefix ， delimiter和suffix 。 如果没有字符被添加到StringJoiner并且访问其字符串值的方法被调用，则返回结果中的prefix + suffix （或其属性），除非首先调用了setEmptyValue 。
        参数
        delimiter - 要添加到 StringJoiner每个元素之间使用的字符序列
        prefix - 开头使用的字符序列
        suffix - 最后使用的字符序列
        异常
        NullPointerException -如果 prefix ， delimiter ，或 suffix为 null

    • 方法详细信息

      • setEmptyValue

        public StringJoiner setEmptyValue​(CharSequence emptyValue)
        设置在确定此StringJoiner的字符串表示时使用的字符序列，并且尚未添加任何元素，即当它为空时。 为此目的提供emptyValue参数的副本。 请注意，一旦调用了一个add方法， StringJoiner不再被认为是空的，即使添加的元素对应于空的String 。
        参数
        emptyValue - 返回值为空的 StringJoiner
        结果
        这个 StringJoiner本身就可以连接这些通话
        异常
        NullPointerException - 当 emptyValue参数是 null

      • toString

        public String toString​()
        返回当前值，由的 prefix ，值加入迄今由分离 delimiter和 suffix ，除非没有元素已经在这种情况下，被添加 prefix + suffix或 emptyValue返回字符。
        重写：
        toString在 Object
        结果
        该字符串表示为 StringJoiner

      • add

        public StringJoiner add​(CharSequence newElement)
        将给定的副本CharSequence值作为下一个元素StringJoiner值。 如果newElement是null ，则添加"null" 。
        参数
        newElement - 要添加的元素
        结果
        参考这个 StringJoiner

      • merge

        public StringJoiner merge​(StringJoiner other)
        添加给定的StringJoiner的内容，没有前缀和后缀作为下一个元素，如果它是非空的。 如果给定的StringJoiner为空，则该呼叫不起作用。

        一个StringJoiner是空的，如果add()从未被调用，如果merge()从未调用一个非空StringJoiner的说法。

        如果另一个StringJoiner正在使用不同的分隔符，则另一个StringJoiner元素将与该分隔符连接，并将结果作为单个元素追加到该StringJoiner 。

        参数
        other - 其内容应合并到该数据的 StringJoiner
        结果
        这 StringJoiner
        异常
        NullPointerException - 如果其他 StringJoiner为空

      • length

        public int length​()
        返回此StringJoiner的String表示的StringJoiner 。 请注意，如果未调用add方法，则将返回String表示（ prefix + suffix或emptyValue ）的长度。 该值应相当于toString().length() 。
        结果
        当前值的长度为 StringJoiner
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringTokenizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class StringTokenizer

  • java.lang.Object
    • java.util.StringTokenizer
  • All Implemented Interfaces:
    Enumeration<Object>

    public class StringTokenizer
extends Object
implements Enumeration<Object>
    字符串tokenizer类允许应用程序将字符串拆分成令牌。 StreamTokenizer化方法比StreamTokenizer类使用的方法简单得多。 StringTokenizer方法不区分标识符，数字和引用的字符串，也不识别和跳过注释。

    可以在创建时或每个令牌的基础上指定一组分隔符（分隔标记的字符）。

    StringTokenizer一个实例以两种方式之一表现，具体取决于它是使用true或false的returnDelims标记创建的：

    • 如果标志为false ，则分隔符用于分隔标记。 令牌是不是分隔符的连续字符的最大序列。
    • 如果标志是true ，则分隔符字符本身被认为是令牌。 因此，令牌是一个定界符字符，或不是分隔符的连续字符的最大序列。

    A StringTokenizer对象内部维护要标记化的字符串中的当前位置。 某些操作会将当前位置提前处理。

    通过使用用于创建StringTokenizer对象的字符串的子字符串来返回令牌。

    以下是使用tokenizer的一个示例。 代码：

         StringTokenizer st = new StringTokenizer("this is a test");
     while (st.hasMoreTokens()) {
         System.out.println(st.nextToken());
     }

    打印以下输出：

         this
     is
     a
     test

    StringTokenizer是由于兼容性原因而保留的遗留类，尽管在新代码中不鼓励使用它。 建议任何寻求此功能的人都可以使用split的String或java.util.regex包。

    以下示例说明了如何将String.split方法用于将字符串分解为其基本令牌：

         String[] result = "this is a test".split("\\s");
     for (int x=0; x<result.length; x++)
         System.out.println(result[x]);

    打印以下输出：

         this
     is
     a
     test
    从以下版本开始：
    1.0
    另请参见：
    StreamTokenizer

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringTokenizer​(String str)
      为指定的字符串构造一个字符串tokenizer。
      StringTokenizer​(String str, String delim)
      为指定的字符串构造一个字符串tokenizer。
      StringTokenizer​(String str, String delim, boolean returnDelims)
      为指定的字符串构造一个字符串tokenizer。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int countTokens​()
      计算这个tokenizer的 nextToken方法在生成异常之前可以调用的次数。
      boolean hasMoreElements​()
      返回与 hasMoreTokens方法相同的值。
      boolean hasMoreTokens​()
      测试此令牌化程序的字符串是否有更多的令牌可用。
      Object nextElement​()
      返回与 nextToken方法相同的值，但其声明的返回值为 Object而不是 String 。
      String nextToken​()
      从此字符串标记器返回下一个令牌。
      String nextToken​(String delim)
      返回此字符串tokenizer字符串中的下一个令牌。

      • Methods inherited from interface java.util.Enumeration

        asIterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StringTokenizer

        public StringTokenizer​(String str,
                       String delim,
                       boolean returnDelims)
        为指定的字符串构造一个字符串tokenizer。 delim参数中的所有字符都是用于分隔标记的分隔符。

        如果returnDelims标志为true ，则分隔符字符也作为令牌返回。 每个分隔符作为长度为1的字符串返回。 如果标志是false ，则会跳过分隔符，只能在令牌之间作为分隔符。

        请注意，如果delim为null ，则此构造函数不会引发异常。 然而，试图调用上所产生的其他方法StringTokenizer可能导致NullPointerException 。

        参数
        str - 要解析的字符串。
        delim - 分隔符。
        指示是否将分隔符作为令牌返回的标志 returnDelims 。
        异常
        NullPointerException - 如果str是 null

      • StringTokenizer

        public StringTokenizer​(String str,
                       String delim)
        为指定的字符串构造一个字符串tokenizer。 delim参数中的字符是用于分隔标记的分隔符。 分隔符字符本身不会被视为令牌。

        请注意，如果delim为null ，则此构造函数不会引发异常。 然而，试图调用上所产生的其他方法StringTokenizer可能导致NullPointerException 。

        参数
        str - 要解析的字符串。
        delim - 分隔符。
        异常
        NullPointerException - 如果str是 null

      • StringTokenizer

        public StringTokenizer​(String str)
        为指定的字符串构造一个字符串tokenizer。 标记器使用默认分隔符集，即" \t\n\r\f" ：空格字符，制表符，换行符，回车字符和换页符。 分隔符字符本身不会被视为令牌。
        参数
        str - 要解析的字符串。
        异常
        NullPointerException - 如果str是 null

    • 方法详细信息

      • hasMoreTokens

        public boolean hasMoreTokens​()
        测试此令牌化程序的字符串是否有更多的令牌可用。 如果此方法返回true ，则后续调用nextToken带参数的nextToken将成功返回令牌。
        结果
        true当且仅当在当前位置之后的字符串中至少有一个令牌时; false否则。

      • nextToken

        public String nextToken​()
        从此字符串标记器返回下一个令牌。
        结果
        来自此字符串标记器的下一个令牌。
        异常
        NoSuchElementException - 如果这个tokenizer的字符串中没有更多的令牌。

      • nextToken

        public String nextToken​(String delim)
        返回此字符串tokenizer字符串中的下一个令牌。 首先，被这个StringTokenizer对象认为是分隔符的一组字符被更改为字符串delim中的字符。 然后返回当前位置后的字符串中的下一个令牌。 当前位置超出了识别的令牌。 新的分隔符集在此调用后保持默认。
        参数
        delim - 新的分隔符。
        结果
        下一个令牌，切换到新的分隔符集后。
        异常
        NoSuchElementException - 如果这个tokenizer的字符串中没有更多的令牌。
        NullPointerException - 如果delim是 null

      • hasMoreElements

        public boolean hasMoreElements​()
        返回与hasMoreTokens方法相同的值。 它存在，以便这个类可以实现Enumeration接口。
        Specified by:
        hasMoreElements在接口 Enumeration<Object>
        结果
        true如果有更多的令牌; false否则。
        另请参见：
        Enumeration ， hasMoreTokens()

      • nextElement

        public Object nextElement​()
        返回与nextToken方法相同的值，但其声明的返回值为Object而不是String 。 它存在，以便这个类可以实现Enumeration接口。
        Specified by:
        nextElement在接口 Enumeration<Object>
        结果
        字符串中的下一个令牌。
        异常
        NoSuchElementException - 如果这个tokenizer的字符串中没有更多的令牌。
        另请参见：
        Enumeration ， nextToken()

      • countTokens

        public int countTokens​()
        计算这个tokenizer的nextToken方法在生成异常之前可以调用的次数。 当前位置不提前。
        结果
        使用当前分隔符集合在字符串中剩余的令牌数。
        另请参见：
        nextToken()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Timer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Timer

  • java.lang.Object
    • java.util.Timer

  • public class Timer
extends Object
    线程调度任务以供将来在后台线程中执行的功能。 任务可以安排一次执行，或者定期重复执行。

    对应于每个Timer对象是单个后台线程，用于依次执行所有定时器的任务。 计时器任务应该快速完成。 如果一个定时器任务需要花费很多时间来完成，它会“计时”计时器的任务执行线程。 这可能会延迟随后的任务的执行，这些任务在（和）如果违规任务最后完成时，可能会“束起来”并快速执行。

    在对Timer对象的最后一次实时引用后，所有未完成的任务已完成执行，定时器的任务执行线程正常终止（并被收集到垃圾回收）。 但是，这可能需要任意长时间的发生。 默认情况下，任务执行线程不作为守护程序线程运行，因此它能够使应用程序终止。 如果呼叫者想要快速终止定时器的任务执行线程，则呼叫者应该调用定时器的cancel方法。

    如果定时器的任务执行线程意外终止，例如，因为它的stop方法被调用，任何进一步的计划任务的尝试将导致一个IllegalStateException ，就像定时器的cancel方法被调用一样。

    这个类是线程安全的：多个线程可以共享一个Timer对象，而不需要外部同步。

    此类不提供实时保证：它使用Object.wait(long)方法调度任务。

    Java 5.0引入了java.util.concurrent软件包，其中一个并发实用程序是ScheduledThreadPoolExecutor ，它是用于以给定速率或延迟重复执行任务的线程池。 这实际上是对一个更灵活的替代Timer / TimerTask组合，因为它允许多个服务线程，接受各种时间单位，并且不需要子类TimerTask （只实现Runnable ）。 使用一个线程配置ScheduledThreadPoolExecutor使其等同于Timer 。

    实现注意事项：这个类可以扩展到大量并发计划任务（千应该没有问题）。 在内部，它使用二进制堆表示其任务队列，因此计划任务的成本为O（log n），其中n为并发计划任务的数量。

    实现注意事项：所有构造函数启动计时器线程。

    从以下版本开始：
    1.3
    另请参见：
    TimerTask ， Object.wait(long)

    • 构造方法摘要

      构造方法
      Constructor 描述
      Timer​()
      创建一个新的计时器。
      Timer​(boolean isDaemon)
      创建一个新的定时器，其相关线程可以指定为 run as a daemon 。
      Timer​(String name)
      创建一个新的定时器，其相关线程具有指定的名称。
      Timer​(String name, boolean isDaemon)
      创建一个新的定时器，其相关线程具有指定的名称，可以指定为 run as a daemon 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancel​()
      终止此计时器，丢弃任何当前计划的任务。
      int purge​()
      从该计时器的任务队列中删除所有取消的任务。
      void schedule​(TimerTask task, long delay)
      在指定的延迟之后安排指定的任务执行。
      void schedule​(TimerTask task, long delay, long period)
      在指定 的延迟之后开始，重新 执行固定延迟执行的指定任务。
      void schedule​(TimerTask task, Date time)
      在指定的时间安排指定的任务执行。
      void schedule​(TimerTask task, Date firstTime, long period)
      从指定的时间开始，对指定的任务执行重复的 固定延迟执行 。
      void scheduleAtFixedRate​(TimerTask task, long delay, long period)
      在指定的延迟之后开始，重新 执行固定速率的指定任务。
      void scheduleAtFixedRate​(TimerTask task, Date firstTime, long period)
      从指定的时间开始，对指定的任务执行重复的 固定速率执行 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Timer

        public Timer​()
        创建一个新的计时器。 相关联的线程不是 run as a daemon 。

      • Timer

        public Timer​(boolean isDaemon)
        创建一个新的定时器，其相关线程可以指定为run as a daemon 。 如果定时器将用于调度重复的“维护活动”，只要应用程序正在运行，但是不应该延长应用程序的使用寿命，则会调用守护线程。
        参数
        isDaemon - 如果关联的线程应该作为守护程序运行， isDaemon true。

      • Timer

        public Timer​(String name)
        创建一个新的定时器，其相关线程具有指定的名称。 相关联的线程不是 run as a daemon 。
        参数
        name - 相关线程的名称
        异常
        NullPointerException - 如果 name为空
        从以下版本开始：
        1.5

      • Timer

        public Timer​(String name,
             boolean isDaemon)
        创建一个新的定时器，其相关线程具有指定的名称，可以指定为 run as a daemon 。
        参数
        name - 相关线程的名称
        isDaemon - 如果关联的线程应该作为守护进程运行， isDaemon true
        异常
        NullPointerException - 如果 name为空
        从以下版本开始：
        1.5

    • 方法详细信息

      • schedule

        public void schedule​(TimerTask task,
                     long delay)
        在指定的延迟之后安排指定的任务执行。
        参数
        task - 要安排的任务。
        delay - 执行任务之前以毫秒为单位的延迟。
        异常
        IllegalArgumentException - 如果 delay为负数，或 delay + System.currentTimeMillis()为负数。
        IllegalStateException - 如果任务已经被调度或取消，定时器被取消或定时器线程被终止。
        NullPointerException - 如果 task为空

      • schedule

        public void schedule​(TimerTask task,
                     Date time)
        在指定的时间安排指定的任务执行。 如果时间过去了，这个任务就被安排立即执行。
        参数
        task - 要安排的任务。
        time - 执行任务的时间。
        异常
        IllegalArgumentException - 如果 time.getTime()为负数。
        IllegalStateException - 如果任务已经被调度或取消，定时器被取消或定时器线程被终止。
        NullPointerException - 如果 task或 time为空

      • schedule

        public void schedule​(TimerTask task,
                     long delay,
                     long period)
        在指定的延迟之后开始，重新执行固定延迟执行的指定任务。 后续执行按照规定的时间间隔间隔进行。

        在固定延迟执行中，每个执行都相对于上一次执行的实际执行时间进行调度。 如果由于任何原因（如垃圾收集或其他背景活动）延迟执行，则后续执行也将被延迟。 从长远来看，执行频率通常会略低于指定期间的倒数（假设Object.wait(long)的系统时钟准确）。

        固定延迟执行适用于需要“平滑”的重复活动。 换句话说，适合在短期内保持频率准确的活动比从长远来看更为重要的活动。 这包括大多数动画任务，例如定期闪烁光标。 它还包括其中响应于人类输入执行常规活动的任务，例如只要按住键被自动重复一个字符。

        参数
        task - 要安排的任务。
        delay - 执行任务之前以毫秒为单位的延迟。
        period - 连续执行任务之间的时间（以毫秒为单位）。
        异常
        IllegalArgumentException - 如果是 delay < 0或 delay + System.currentTimeMillis() < 0或 period <= 0
        IllegalStateException - 如果任务已经被调度或取消，计时器被取消或定时器线程被终止。
        NullPointerException - 如果 task为空

      • schedule

        public void schedule​(TimerTask task,
                     Date firstTime,
                     long period)
        从指定的时间开始，对指定的任务执行重复的固定延迟执行 。 后续执行大约定期进行，间隔指定期间。

        在固定延迟执行中，每个执行都相对于上一次执行的实际执行时间进行调度。 如果由于任何原因（如垃圾收集或其他背景活动）延迟执行，则后续执行也将被延迟。 从长远来看，执行频率通常会略低于指定期间的倒数（假设Object.wait(long)的系统时钟准确）。 作为上述的结果，如果计划的第一次是过去的，则计划立即执行。

        固定延迟执行适用于需要“平滑”的重复活动。 换句话说，适合在短期内保持频率准确的活动比从长远来看更为重要的活动。 这包括大多数动画任务，例如定期闪烁光标。 它还包括其中响应于人类输入执行常规活动的任务，例如只要按住键被自动重复一个字符。

        参数
        task - 要安排的任务。
        firstTime - 第一次执行任务。
        period - 连续执行任务之间的时间（以毫秒为单位）。
        异常
        IllegalArgumentException - 如果是 firstTime.getTime() < 0 ，或者是 period <= 0
        IllegalStateException - 如果任务已经被调度或取消，定时器被取消或定时器线程被终止。
        NullPointerException - 如果 task或 firstTime为空

      • scheduleAtFixedRate

        public void scheduleAtFixedRate​(TimerTask task,
                                long delay,
                                long period)
        在指定的延迟之后开始，重新执行固定速率的指定任务。 后续执行大约定期进行，间隔指定期间。

        在固定速率执行中，相对于初始执行的预定执行时间调度每个执行。 如果由于任何原因（例如垃圾收集或其他背景活动）延迟执行，则两次或多次执行将快速连续发生以“追赶”。 从长远来看，执行的频率将恰好是指定周期的倒数（假设Object.wait(long)的系统时钟准确）。

        固定速率执行适用于对绝对时间敏感的重复活动，例如每小时敲响一次钟声，或在特定时间每天运行定期维护。 对于执行固定次数的执行的总时间很重要的循环活动也是适用的，例如每秒钟打10秒钟的倒数计时器。 最后，固定速率执行适用于调度必须相对于彼此保持同步的多个重复定时器任务。

        参数
        task - 要安排的任务。
        delay - 执行任务之前以毫秒为单位的延迟。
        period - 连续执行任务之间的时间（以毫秒为单位）。
        异常
        IllegalArgumentException - 如果是 delay < 0或 delay + System.currentTimeMillis() < 0或 period <= 0
        IllegalStateException - 如果任务已经被调度或取消，定时器被取消或定时器线程被终止。
        NullPointerException - 如果 task为空

      • scheduleAtFixedRate

        public void scheduleAtFixedRate​(TimerTask task,
                                Date firstTime,
                                long period)
        从指定的时间开始，对指定的任务执行重复的固定速率执行 。 后续执行大约定期进行，间隔指定期间。

        在固定速率执行中，相对于初始执行的预定执行时间调度每个执行。 如果由于任何原因（例如垃圾收集或其他背景活动）延迟执行，则两次或多次执行将快速连续发生以“追赶”。 从长远来看，执行频率将恰好是指定周期的倒数（假设系统时钟为Object.wait(long) ）。 由于上述原因，如果计划的第一次是过去，那么任何“错过”的处决将被安排在立即的“追赶”执行之中。

        固定速率执行适用于对绝对时间敏感的重复活动，例如每小时敲响一次钟声，或在特定时间每天运行定期维护。 对于执行固定次数的执行的总时间很重要的循环活动也是适用的，例如每秒钟打10秒钟的倒数计时器。 最后，固定速率执行适用于调度必须相对于彼此保持同步的多个重复定时器任务。

        参数
        task - 要安排的任务。
        firstTime - 第一次执行任务。
        period - 连续执行任务之间的时间（以毫秒为单位）。
        异常
        IllegalArgumentException - 如果是 firstTime.getTime() < 0或 period <= 0
        IllegalStateException - 如果任务已经被调度或取消，定时器被取消或定时器线程被终止。
        NullPointerException - 如果 task或 firstTime为空

      • cancel

        public void cancel​()
        终止此计时器，丢弃任何当前计划的任务。 不干扰当前执行的任务（如果存在）。 一旦计时器被终止，它的执行线程就会顺利地终止，并且不会再安排任务了。

        请注意，在此定时器调用的定时器任务的运行方法内调用此方法绝对保证正在进行的任务执行是该定时器将执行的最后一个任务执行。

        这个方法可以重复调用; 第二个和以后的呼叫没有任何效果。

      • purge

        public int purge​()
        从该计时器的任务队列中删除所有取消的任务。 调用此方法对定时器的行为没有影响 ，但是消除了对队列中已取消任务的引用。 如果没有对这些任务的外部引用，它们就有资格进行垃圾收集。

        大多数程序将无需调用此方法。 它被设计用于取消大量任务的罕见应用程序使用。 调用此方法可以占用空间：方法的运行时间可能与n + c log n成正比，其中n是队列中任务的数量，c是已取消任务的数量。

        请注意，可以从在此定时器上调度的任务中调用此方法。

        结果
        从队列中删除的任务数。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TimerTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class TimerTask

  • java.lang.Object
    • java.util.TimerTask
  • All Implemented Interfaces:
    Runnable

    public abstract class TimerTask
extends Object
implements Runnable
    可以由Timer进行一次性或重复执行的任务 。

    计时器任务不可重用。 一旦一个任务被安排执行在一个Timer或取消，随后的尝试安排它执行将抛出IllegalStateException 。

    从以下版本开始：
    1.3

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected TimerTask​()
      创建一个新的计时器任务。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean cancel​()
      取消此计时器任务。
      abstract void run​()
      该定时器任务要执行的操作。
      long scheduledExecutionTime​()
      返回此任务最近 实际执行的 预定执行时间。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TimerTask

        protected TimerTask​()
        创建一个新的计时器任务。

    • 方法详细信息

      • run

        public abstract void run​()
        该定时器任务要执行的操作。
        Specified by:
        run在接口 Runnable
        另请参见：
        Thread.run()

      • cancel

        public boolean cancel​()
        取消此计时器任务。 如果任务已安排一次执行，尚未运行或尚未安排，则该任务将永远不会运行。 如果任务已被安排重复执行，它将永远不会再运行。 （如果此呼叫发生时任务正在运行，则任务将运行到完成，但不会再运行。）

        请注意，在重复定时器任务的run方法内调用此方法绝对保证计时器任务不会再次运行。

        这个方法可以重复调用; 第二个和以后的呼叫没有任何效果。

        结果
        如果此任务计划执行一次，并且尚未运行，或者该任务计划重复执行，则为true。 如果任务计划执行一次并已经运行，或者任务从未安排，或任务已被取消，则返回false。 （ true地说，如果它阻止一次或多次安排的执行发生，此方法返回true ）

      • scheduledExecutionTime

        public long scheduledExecutionTime​()
        返回此任务最近实际执行的预定执行时间。 （如果在执行任务时调用此方法，则返回值是执行正在执行的任务的计划执行时间。）

        通常从任务的运行方法中调用此方法，以确定当前执行的任务是否足够及时，以保证执行计划的活动：

           public void run() { if (System.currentTimeMillis() - scheduledExecutionTime() >= MAX_TARDINESS) return; // Too late; skip this execution. // Perform the task }
        该方法通常不与固定延迟执行重复任务结合使用，因为它们的调度执行时间被允许随时间漂移，因此不是非常重要的。
        结果
        以Date.getTime（）返回的格式调度最近执行此任务的时间。 如果任务尚未开始执行，返回值是未定义的。
        另请参见：
        Date.getTime()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TimeZone (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class TimeZone

  • java.lang.Object
    • java.util.TimeZone
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    SimpleTimeZone

    public abstract class TimeZone
extends Object
implements Serializable, Cloneable
    TimeZone代表时区偏移量，也可以显示夏令时。

    通常，您将获得一个TimeZone使用getDefault ，根据程序运行的时区创建一个TimeZone 。 例如，对于在日本运行的程序， getDefault基于日本标准时间创建TimeZone对象。

    您还可以得到一个TimeZone使用getTimeZone具有时区ID一起。 例如，美国太平洋时区的时区ID为“America / Los_Angeles”。 所以，你可以得到一个美国太平洋时间TimeZone对象：

     TimeZone tz = TimeZone.getTimeZone("America/Los_Angeles");
    您可以使用getAvailableIDs方法来遍历所有支持的时区ID。 然后，您可以选择支持的ID来获取TimeZone 。 如果您希望的时区不是由支持的ID之一表示，则可以指定自定义时区ID以生成TimeZone。 自定义时区ID的语法为：
     CustomID:
         GMT Sign Hours : Minutes
         GMT Sign Hours Minutes
         GMT Sign Hours
 Sign: one of
         + -
 Hours:
         Digit
         Digit Digit
 Minutes:
         Digit Digit
 Digit: one of
         0 1 2 3 4 5 6 7 8 9
    小时数必须在0到23之间， 分钟必须介于00到59之间。例如，“GMT + 10”和“GMT + 0010”分别表示GMT前10小时10分钟。

    格式与区域设置无关，数字必须取自Unicode标准的基本拉丁方块。 不能使用自定义时区ID指定夏令时转换时间表。 如果指定的字符串与语法"GMT"则使用"GMT" 。

    创建TimeZone ，指定的自定义时区ID TimeZone以下语法进行标准化：

     NormalizedCustomID:
         GMT Sign TwoDigitHours : Minutes
 Sign: one of
         + -
 TwoDigitHours:
         Digit Digit
 Minutes:
         Digit Digit
 Digit: one of
         0 1 2 3 4 5 6 7 8 9
    例如，TimeZone.getTimeZone（“GMT-8”）。getID（）返回“GMT-08：00”。

    三个字母的时区ID

    为了与JDK 1.1.x兼容，还支持一些其他三个字母的时区ID（如“PST”，“CTT”，“AST”）。 但是， 建议使用它们 ，因为相同的缩写经常用于多个时区（例如，“CST”可以是美国的“中部标准时间”和“中国标准时间”），然后在Java平台只能识别一个他们。
    从以下版本开始：
    1.1
    另请参见：
    Calendar ， GregorianCalendar ， SimpleTimeZone ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int LONG
      getDisplayName()的样式说明 getDisplayName()表示长名称，如“太平洋标准时间”。
      static int SHORT
      getDisplayName()的样式说明符，表示短名称，如“PST”。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TimeZone​()
      唯一的构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建一个这个 TimeZone的副本。
      static String[] getAvailableIDs​()
      获取支持的所有可用ID。
      static String[] getAvailableIDs​(int rawOffset)
      根据给定的时区偏移（以毫秒为单位）获取可用ID。
      static TimeZone getDefault​()
      获取Java虚拟机的默认值 TimeZone 。
      String getDisplayName​()
      返回此 TimeZone的较长标准时间名称， TimeZone适用于默认语言环境中的用户呈现。
      String getDisplayName​(boolean daylight, int style)
      返回此 TimeZone指定的 style中的名称，该名称适用于以默认语言环境向用户呈现。
      String getDisplayName​(boolean daylight, int style, Locale locale)
      返回此 TimeZone指定的 style中的一个名称，适用于在指定的 style中向用户 locale 。
      String getDisplayName​(Locale locale)
      返回此 TimeZone的长标准时间名称，适用于在指定的 locale向用户 locale 。
      int getDSTSavings​()
      返回添加到本地标准时间以获取本地挂钟时间的时间量。
      String getID​()
      获取此时区的ID。
      abstract int getOffset​(int era, int year, int month, int day, int dayOfWeek, int milliseconds)
      获取当前日期的时区偏移，在夏令时情况下进行修改。
      int getOffset​(long date)
      在指定的日期返回此时区与UTC的偏移量。
      abstract int getRawOffset​()
      返回添加到UTC的时间（以毫秒为单位），以获得此时区的标准时间。
      static TimeZone getTimeZone​(String ID)
      获取给定ID的 TimeZone 。
      static TimeZone getTimeZone​(ZoneId zoneId)
      获得 TimeZone给定的 zoneId 。
      boolean hasSameRules​(TimeZone other)
      如果此区域具有与其他区域相同的规则和偏移量，则返回true。
      abstract boolean inDaylightTime​(Date date)
      查询给定的 date是否在此时区的夏令时间内。
      boolean observesDaylightTime​()
      如果此 TimeZone当前处于夏令时，或者如果将来发生从标准时间到夏令时的转换，则返回 true 。
      static void setDefault​(TimeZone zone)
      设置 TimeZone由返回 getDefault方法。
      void setID​(String ID)
      设置时区ID。
      abstract void setRawOffset​(int offsetMillis)
      将基准时区偏移设置为GMT。
      ZoneId toZoneId​()
      将此 TimeZone对象转换为 ZoneId 。
      abstract boolean useDaylightTime​()
      查询 TimeZone使用夏令时。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • SHORT

        public static final int SHORT
        getDisplayName()的样式说明符，表示短名称，如“PST”。
        从以下版本开始：
        1.2
        另请参见：
        LONG ， Constant Field Values

      • LONG

        public static final int LONG
        getDisplayName()的样式说明 getDisplayName()表示长名称，如“太平洋标准时间”。
        从以下版本开始：
        1.2
        另请参见：
        SHORT ， Constant Field Values

    • 构造方法详细信息

      • TimeZone

        public TimeZone​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getOffset

        public abstract int getOffset​(int era,
                              int year,
                              int month,
                              int day,
                              int dayOfWeek,
                              int milliseconds)
        获取当前日期的时区偏移，在夏令时情况下进行修改。 这是添加到UTC以获取当地时间的偏移量。

        如果基础TimeZone实现子类支持历史夏令时计划和GMT偏移量更改，则此方法返回历史正确的偏移量。

        参数
        era - 给定日期的时代。
        year - 给定日期的年份。
        month - 给定日期的月份。 月份为0。 例如，1月份为0。
        day - 给定日期的日期。
        dayOfWeek - 给定日期的星期几。
        milliseconds - 标准本地时间的毫秒数。
        结果
        以毫秒为单位的偏移量添加到GMT以获取本地时间。
        另请参见：
        Calendar.ZONE_OFFSET ， Calendar.DST_OFFSET

      • getOffset

        public int getOffset​(long date)
        在指定的日期返回此时区与UTC的偏移量。 如果夏令时在指定的日期生效，则偏移值将随着夏令时的数量而调整。

        如果底层TimeZone实现子类支持历史夏令时计划和GMT偏移量更改，则此方法返回历史上正确的偏移值。

        参数
        date - 自1970年1月1日00:00:00 GMT以毫秒表示的日期
        结果
        以毫秒为单位添加到UTC以获取本地时间的时间量。
        从以下版本开始：
        1.4
        另请参见：
        Calendar.ZONE_OFFSET ， Calendar.DST_OFFSET

      • setRawOffset

        public abstract void setRawOffset​(int offsetMillis)
        将基准时区偏移设置为GMT。 这是添加到UTC以获取当地时间的偏移量。

        如果底层的TimeZone实现子类支持历史GMT偏移量更改，则将指定的GMT偏移量设置为最新的GMT偏移量，并使用与已知最新GMT偏移量值的差值来调整所有历史GMT偏移值。

        参数
        offsetMillis - 给定的基准时区偏移到GMT。

      • getRawOffset

        public abstract int getRawOffset​()
        返回添加到UTC的时间（以毫秒为单位），以获得此时区的标准时间。 由于此值不受夏令时的影响，因此称为原始偏移量 。

        如果底层的TimeZone实现子类支持历史GMT偏移量更改，则该方法返回当前日期的原始偏移值。 例如，在檀香山，其原始偏移量在1947年从GMT-10：30改为GMT-10：00，该方法总是返回-36000000毫秒（即-10小时）。

        结果
        以UTC为单位的原始偏移时间（以毫秒为单位）的量。
        另请参见：
        Calendar.ZONE_OFFSET

      • getID

        public String getID​()
        获取此时区的ID。
        结果
        此时区的ID。

      • setID

        public void setID​(String ID)
        设置时区ID。 这不会更改时区对象中的任何其他数据。
        参数
        ID - 新的时区ID。

      • getDisplayName

        public final String getDisplayName​()
        返回此TimeZone的较长标准时间名称，适合在默认语言环境中向用户呈现。

        此方法相当于：

         getDisplayName(false, LONG,
                Locale.getDefault(Locale.Category.DISPLAY))
        结果
        默认语言环境中此时区的可读名称。
        从以下版本开始：
        1.2
        另请参见：
        getDisplayName(boolean, int, Locale) ， Locale.getDefault(Locale.Category) ， Locale.Category

      • getDisplayName

        public final String getDisplayName​(Locale locale)
        返回此TimeZone的较长标准时间名称，适用于在指定的locale向用户locale 。

        此方法相当于：

         getDisplayName(false, LONG, locale)
        参数
        locale - 提供显示名称的区域设置。
        结果
        该时区的人机可读名称在给定的区域设置。
        异常
        NullPointerException - 如果 locale是 null 。
        从以下版本开始：
        1.2
        另请参见：
        getDisplayName(boolean, int, Locale)

      • getDisplayName

        public final String getDisplayName​(boolean daylight,
                                   int style)
        返回此TimeZone指定的style中的一个名称，适用于以默认语言环境向用户呈现。 如果指定的daylight为true ，则会返回夏令时名称（即使此TimeZone未遵守夏令时）。 否则返回标准时间名称。

        此方法相当于：

         getDisplayName(daylight, style,
                Locale.getDefault(Locale.Category.DISPLAY))
        参数
        daylight - true指定夏令时名称，或 false指定标准时间名称
        style - LONG或 SHORT
        结果
        默认语言环境中此时区的可读名称。
        异常
        IllegalArgumentException - 如果 style无效。
        从以下版本开始：
        1.2
        另请参见：
        getDisplayName(boolean, int, Locale) ， Locale.getDefault(Locale.Category) ， Locale.Category ， DateFormatSymbols.getZoneStrings()

      • getDisplayName

        public String getDisplayName​(boolean daylight,
                             int style,
                             Locale locale)
        返回该TimeZone指定的style中的一个名称，适用于在指定的style中向用户locale 。 如果指定的daylight为true ，则会返回夏令时名称（即使此TimeZone未遵守夏令时）。 否则返回标准时间名称。

        当查找时区名称时，使用从指定的locale派生的locale 。 （No fallback Locale执行搜索。）如果找到包含Locale.ROOT的搜索路径的任何Locale中的时区名称，则返回该名称。 否则，返回normalized custom ID format中的字符串。

        参数
        daylight - true指定夏令时名称，或指定标准时间名称的 false
        style - LONG或 SHORT
        locale - 提供显示名称的区域设置。
        结果
        该时区的人机可读名称在给定的区域设置。
        异常
        IllegalArgumentException - 如果 style无效。
        NullPointerException - 如果 locale是 null 。
        从以下版本开始：
        1.2
        另请参见：
        DateFormatSymbols.getZoneStrings()

      • getDSTSavings

        public int getDSTSavings​()
        返回添加到本地标准时间以获取本地挂钟时间的时间量。

        如果对useDaylightTime()的调用返回true ，默认实现将返回3600000毫秒（即一小时）。 否则返回0（零）。

        如果底层的TimeZone实现子类支持历史和未来的夏令时计划更改，则此方法返回最后一个已知的夏令时规则的可节约时间量，这可以作为将来的预测。

        如果需要任何给定时间戳的节省时间， 请使用该TimeZone和时间戳构建 ( ，并致电Calendar.get ( Calendar.DST_OFFSET ) 。

        结果
        节省时间（毫秒）
        从以下版本开始：
        1.4
        另请参见：
        inDaylightTime(Date) ， getOffset(long) ， getOffset(int,int,int,int,int,int) ， Calendar.ZONE_OFFSET

      • useDaylightTime

        public abstract boolean useDaylightTime​()
        查询TimeZone使用夏令时。

        如果底层的TimeZone实现子类支持历史和未来的夏令时计划更改，则该方法参考最后一个已知的夏令时规则，该规则可以是将来的预测，并且可能与当前规则不同。 如果现行规则也应该考虑，请考虑拨打observesDaylightTime() 。

        结果
        true如果这 TimeZone使用夏令时， false否则。
        另请参见：
        inDaylightTime(Date) ， Calendar.DST_OFFSET

      • observesDaylightTime

        public boolean observesDaylightTime​()
        如果此TimeZone当前处于夏令时，或者如果从将来的时间发生从标准时间到夏令时的转换，则返回true 。

        默认实现返回true如果useDaylightTime()或者inDaylightTime(new Date())回报true 。

        结果
        true如果此TimeZone当前处于夏令时，或者如果从将来的时间发生从标准时间到夏令时的过渡; false否则。
        从以下版本开始：
        1.7
        另请参见：
        useDaylightTime() ， inDaylightTime(Date) ， Calendar.DST_OFFSET

      • inDaylightTime

        public abstract boolean inDaylightTime​(Date date)
        查询给定的 date是否在此时区的 date时制。
        参数
        date - 给定的日期。
        结果
        true如果给定的日期是夏令时， false ，否则。

      • getTimeZone

        public static TimeZone getTimeZone​(String ID)
        获取给定ID的 TimeZone 。
        参数
        ID -的ID为TimeZone ，要么的缩写如“PST”，一个完整的名称，如“美国/洛杉矶”，或自定义ID，如“GMT-8：00”。 请注意，缩写的支持仅适用于JDK 1.1.x兼容性，应使用全名。
        结果
        指定的 TimeZone或GMT区域，如果给定的ID不能被理解。

      • getTimeZone

        public static TimeZone getTimeZone​(ZoneId zoneId)
        获取 TimeZone为给定 zoneId 。
        参数
        zoneId - 获得时区ID的ZoneId
        结果
        指定的 TimeZone或GMT区域，如果给定的ID不能被理解。
        异常
        NullPointerException - 如果 zoneId是 null
        从以下版本开始：
        1.8

      • toZoneId

        public ZoneId toZoneId​()
        将此 TimeZone对象转换为 ZoneId 。
        结果
        一个 ZoneId代表与这个 TimeZone相同的时区
        从以下版本开始：
        1.8

      • getAvailableIDs

        public static String[] getAvailableIDs​(int rawOffset)
        根据给定的时区偏移（以毫秒为单位）获取可用ID。
        参数
        rawOffset - 给定的时区GMT偏移量（以毫秒为单位）。
        结果
        一组ID，其中该ID的时区具有指定的GMT偏移量。 例如，“美国/凤凰”和“美国/丹佛”都有GMT-07：00，但夏令时不同。
        另请参见：
        getRawOffset()

      • getAvailableIDs

        public static String[] getAvailableIDs​()
        获取支持的所有可用ID。
        结果
        一组ID。

      • getDefault

        public static TimeZone getDefault​()
        获取Java虚拟机的默认值TimeZone 。 如果缓存的默认TimeZone可用，则返回其克隆。 否则，该方法将采取以下步骤来确定默认时区。
        • 如果可用，则使用user.timezone属性值作为默认时区ID。
        • 检测平台时区ID。 平台时区和ID映射的来源可能随实施而变化。
        • 如果给定或检测到的时区ID未知，请使用GMT作为最后的手段。

        从ID创建的默认TimeZone被缓存，并且它的克隆被返回。 user.timezone属性值返回时设置为ID。

        结果
        默认为 TimeZone
        另请参见：
        setDefault(TimeZone)

      • setDefault

        public static void setDefault​(TimeZone zone)
        设置TimeZone由返回getDefault方法。 zone被缓存。 如果zone为空，缓存默认值TimeZone被清除。 此方法不会更改user.timezone属性的值。
        参数
        zone - 新的默认值 TimeZone ，或null
        异常
        SecurityException - 如果安全经理的 checkPermission否认 PropertyPermission("user.timezone", "write")
        另请参见：
        getDefault() ， PropertyPermission

      • hasSameRules

        public boolean hasSameRules​(TimeZone other)
        如果此区域具有与其他区域相同的规则和偏移量，则返回true。 也就是说，如果这个区域只有ID不同，如果有的话。 如果其他区域为空，则返回false。
        参数
        other - 要比较的 TimeZone对象
        结果
        如果其他区域不为空且与此相同，则为true，ID可能为例外
        从以下版本开始：
        1.2

      • clone

        public Object clone​()
        创建一个这个 TimeZone的副本。
        重写：
        clone在 Object
        结果
        这个 TimeZone的克隆
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TooManyListenersException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class TooManyListenersException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.util.TooManyListenersException
  • All Implemented Interfaces:
    Serializable

    public class TooManyListenersException
extends 异常

    TooManyListenersException异常被用作Java事件模型的一部分，以注释和实现组播事件源的单播特殊情况。

    在通常的多播“void addXyzEventListener”事件侦听器注册模式的任何给定的具体实现中存在“throws TooManyListenersException”子句，用于将该接口注释为实现单播侦听器特殊情况，即，只有一个侦听器可能同时在特定事件侦听器源上注册。

    从以下版本开始：
    1.1
    另请参见：
    EventObject ， EventListener ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      TooManyListenersException​()
      构造一个没有详细消息的TooManyListenersException。
      TooManyListenersException​(String s)
      构造具有指定详细消息的TooManyListenersException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • TooManyListenersException

        public TooManyListenersException​()
        构造一个没有详细消息的TooManyListenersException。 详细消息是描述此特定异常的字符串。

      • TooManyListenersException

        public TooManyListenersException​(String s)
        构造具有指定详细消息的TooManyListenersException。 详细消息是描述此特定异常的字符串。
        参数
        s - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class TreeMap<K,V>

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.TreeMap<K,V>
  • 参数类型
    K - 由此地图维护的键的类型
    V - 映射值的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Map<K,V> ， NavigableMap<K,V> ， SortedMap<K,V>

    public class TreeMap<K,V>
extends AbstractMap<K,V>
implements NavigableMap<K,V>, Cloneable, Serializable
    一个基于红黑树的NavigableMap实现。 该地图根据其键值的natural ordering或地图创建时提供的Comparator进行排序，具体取决于使用的构造函数。

    此实现提供了保证的log（n）时间成本containsKey ， get ， put和remove操作。 算法是Cormen，Leiserson和Rivest的算法介绍中的算法的适应性。

    请注意，如果此排序映射要正确实现Map接口，则由树映射维护的排序（如任何排序映射）以及是否提供显式比较器都必须与equals一致 。 （见Comparable或Comparator ，以确定与等于一致的精确定义。）这是因为Map接口是根据equals操作定义的，但是排序的映射使用其compareTo （或compare ）方法执行所有关键比较，因此两从排序图的角度来说，通过该方法认为相等的键是相等的。 排序地图的行为是明确定义的，即使其排序与equals不一致; 它只是不符合Map接口的总体合同。

    请注意，此实现不同步。 如果多个线程同时访问映射，并且至少一个线程在结构上修改映射，则必须在外部进行同步。 （结构修改是添加或删除一个或多个映射的任何操作;仅改变与现有密钥相关联的值不是结构修改。）这通常通过对自然封装映射的一些对象进行同步来实现。 如果没有这样的对象存在，则应使用Collections.synchronizedSortedMap方法“映射”地图。 这最好在创建时完成，以防止意外的不同步访问地图：

      SortedMap m = Collections.synchronizedSortedMap(new TreeMap(...));

    由所有这个类的“集合视图方法”返回的集合的iterator方法返回的迭代器是故障快速的 ：如果映射在迭代器创建之后的任何时间被结构化地修改，除了通过迭代器自己的remove方法，迭代器会抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的迭代器ConcurrentModificationException扔ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    所有Map.Entry对，通过此类中的方法返回，其视图表示生成时映射的快照。 他们不支持Entry.setValue方法。 （请注意，可以使用put更改关联地图中的映射。）

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Map ， HashMap ， Hashtable ， Comparable ， Comparator ， Collection ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeMap​()
      使用其键的自然排序构造一个新的空树状图。
      TreeMap​(Comparator<? super K> comparator)
      构造一个新的，空的树图，按照给定的比较器排序。
      TreeMap​(Map<? extends K,? extends V> m)
      构造一个新的树状图，其中包含与给定地图相同的映射，根据其键的 自然顺序进行排序 。
      TreeMap​(SortedMap<K,? extends V> m)
      构造一个包含相同映射并使用与指定排序映射相同顺序的新树映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Map.Entry<K,V> ceilingEntry​(K key)
      返回与大于或等于给定键的最小键相关联的键值映射，如果没有此键，则 null 。
      K ceilingKey​(K key)
      返回大于或等于给定键的 null键，如果没有这样的键，则 null 。
      void clear​()
      从这张地图中删除所有的映射。
      Object clone​()
      返回此 TreeMap实例的浅拷贝。
      Comparator<? super K> comparator​()
      返回用于为了在这个映射中的键，或比较null如果此映射使用natural ordering它的键。
      boolean containsKey​(Object key)
      如果此映射包含指定键的映射，则返回 true 。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      NavigableSet<K> descendingKeySet​()
      返回此映射中包含的键的相反顺序NavigableSet 。
      NavigableMap<K,V> descendingMap​()
      返回此映射中包含的映射的反向排序视图。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      Map.Entry<K,V> firstEntry​()
      返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      K firstKey​()
      返回此地图中当前的第一个（最低）键。
      Map.Entry<K,V> floorEntry​(K key)
      返回与小于或等于给定键的最大键相关联的键值映射，如果没有此键，则 null 。
      K floorKey​(K key)
      返回小于或等于给定键的最大键，如果没有此键，则 null 。
      void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。
      SortedMap<K,V> headMap​(K toKey)
      返回此地图部分的视图，其密钥严格小于 toKey 。
      NavigableMap<K,V> headMap​(K toKey, boolean inclusive)
      返回此地图部分的视图，其键值小于（或等于，如果为 inclusive为真） toKey 。
      Map.Entry<K,V> higherEntry​(K key)
      返回与最小密钥相关联的密钥值映射严格大于给定密钥，如果没有这样的密钥则 null 。
      K higherKey​(K key)
      返回严格大于给定键的最小键，如果没有这样的键，则返回 null 。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      Map.Entry<K,V> lastEntry​()
      返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
      K lastKey​()
      返回当前在此地图中的最后（最高）键。
      Map.Entry<K,V> lowerEntry​(K key)
      返回与严格小于给定键的最大键相关联的键值映射，如果没有这样的键，则 null 。
      K lowerKey​(K key)
      返回严格小于给定键的最大键，如果没有这样的键，则返回 null 。
      NavigableSet<K> navigableKeySet​()
      返回此地图中包含的键的NavigableSet视图。
      Map.Entry<K,V> pollFirstEntry​()
      删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> pollLastEntry​()
      删除并返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
      V put​(K key, V value)
      将指定的值与此映射中的指定键相关联。
      void putAll​(Map<? extends K,? extends V> map)
      将指定地图的所有映射复制到此地图。
      V remove​(Object key)
      从此TreeMap中删除此键的映射（如果存在）。
      V replace​(K key, V value)
      只有当目标映射到某个值时，才能替换指定键的条目。
      boolean replace​(K key, V oldValue, V newValue)
      仅当当前映射到指定的值时，才能替换指定键的条目。
      void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      int size​()
      返回此地图中键值映射的数量。
      NavigableMap<K,V> subMap​(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
      返回此地图部分的视图，其关键字范围从 fromKey到 toKey 。
      SortedMap<K,V> subMap​(K fromKey, K toKey)
      返回此地图部分的视图，其关键字范围从 fromKey （含）到 toKey ，独占。
      SortedMap<K,V> tailMap​(K fromKey)
      返回此地图部分的视图，其键大于或等于 fromKey 。
      NavigableMap<K,V> tailMap​(K fromKey, boolean inclusive)
      返回此地图部分的视图，其键大于（或等于，如果 inclusive为真） fromKey 。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from class java.util.AbstractMap

        equals, hashCode, isEmpty, toString

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, equals, getOrDefault, hashCode, isEmpty, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TreeMap

        public TreeMap​()
        使用其键的自然排序构造一个新的空树状图。 插入地图的所有键都必须实现Comparable界面。 此外，所有这些密钥必须是相互可比的 ： k1.compareTo(k2)不得为ClassCastException中的任何密钥k1和k2扔ClassCastException 。 如果用户试图将一个键放入违反该约束的地图（例如，用户尝试将一个字符串键放入一个键为整数的地图中），则put(Object key, Object value)调用将抛出一个ClassCastException 。

      • TreeMap

        public TreeMap​(Comparator<? super K> comparator)
        构造一个新的，空的树图，按照给定的比较器排序。 插入到地图中的所有键必须由给定的比较器相互比较： comparator.compare(k1, k2)不能为ClassCastException中的任何键k1和k2抛出ClassCastException 。 如果用户试图将一个键放入地图中，违反这个约束， put(Object key, Object value)调用将会抛出一个ClassCastException 。
        参数
        comparator - 将用于订购此映射的比较器。 如果是null ，将使用natural ordering的键。

      • TreeMap

        public TreeMap​(Map<? extends K,? extends V> m)
        构造一个新的树状图，其中包含与给定地图相同的映射，根据其键的自然顺序进行排序 。 插入新地图的所有键都必须实现Comparable接口。 此外，所有这些密钥必须是相互可比的 ： k1.compareTo(k2)不得为ClassCastException中的任何密钥k1和k2 。 此方法运行在n * log（n）时间。
        参数
        m - 其映射将放置在此映射中的映射
        异常
        ClassCastException - 如果m中的键不是Comparable ，或者不相互比较
        NullPointerException - 如果指定的地图为空

      • TreeMap

        public TreeMap​(SortedMap<K,? extends V> m)
        构造一个包含相同映射并使用与指定排序映射相同顺序的新树映射。 该方法运行在线性时间。
        参数
        m - 其映射将被放置在此映射中的排序映射，并且其比较器将用于对该映射进行排序
        异常
        NullPointerException - 如果指定的地图为空

    • 方法详细信息

      • size

        public int size​()
        返回此地图中键值映射的数量。
        Specified by:
        size在接口 Map<K,V>
        重写：
        size在 AbstractMap<K,V>
        结果
        该地图中键值映射的数量

      • containsKey

        public boolean containsKey​(Object key)
        如果此映射包含指定键的映射，则返回 true 。
        Specified by:
        containsKey在接口 Map<K,V>
        重写：
        containsKey在 AbstractMap<K,V>类
        参数
        key - 要在此地图中存在的密钥要进行测试
        结果
        true如果此映射包含指定键的映射
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射使用自然排序，或者其比较器不允许空键

      • containsValue

        public boolean containsValue​(Object value)
        如果此映射将一个或多个键映射到指定的值，则返回true 。 更正式地，返回true如果且仅当此映射包含至少一个映射到值v ，使得(value==null ? v==null : value.equals(v)) 。 对于大多数实现，此操作可能需要在地图大小的时间线性。
        Specified by:
        containsValue在接口 Map<K,V>
        重写：
        containsValue AbstractMap<K,V>
        参数
        value - 要在此地图中存在的值要测试
        结果
        true如果映射到value存在; 否则为false
        从以下版本开始：
        1.2

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回null 。

        更正式地，如果此映射包含从密钥映射k到值v使得key比较等于k根据地图的排序，则此方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        返回值为null并不一定表示该映射不包含该键的映射; 地图也可能明确地将密钥映射到null 。 可以使用containsKey操作来区分这两种情况。

        Specified by:
        get在接口 Map<K,V>
        重写：
        get在 AbstractMap<K,V>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含该键的映射， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射使用自然排序，或者其比较器不允许空键

      • comparator

        public Comparator<? super K> comparator​()
        描述从接口SortedMap复制
        返回用于订购此地图中的键的比较器，或null如果此地图使用其键的natural ordering 。
        Specified by:
        comparator在接口 SortedMap<K,V>
        结果
        比较器用于对这个地图中的按键进行排序，或者 null如果这个地图使用其键的自然顺序

      • firstKey

        public K firstKey​()
        说明从界面SortedMap复制
        返回此地图中当前的第一个（最低）键。
        Specified by:
        firstKey在接口 SortedMap<K,V>
        结果
        当前在此地图中的第一（最低）键
        异常
        NoSuchElementException - 如果此地图为空

      • lastKey

        public K lastKey​()
        说明从接口SortedMap复制
        返回当前在此地图中的最后（最高）键。
        Specified by:
        lastKey在接口 SortedMap<K,V>
        结果
        当前在此地图中的最后（最高）键
        异常
        NoSuchElementException - 如果该地图为空

      • putAll

        public void putAll​(Map<? extends K,? extends V> map)
        将指定地图的所有映射复制到此地图。 这些映射取代了该地图对当前指定地图中的任何键的任何映射。
        Specified by:
        putAll在接口 Map<K,V>
        重写：
        putAll在 AbstractMap<K,V>
        参数
        map - 要存储在此地图中的映射
        异常
        ClassCastException - 如果指定地图中的键或值的类阻止它存储在此映射中
        NullPointerException - 如果指定的映射为空或指定的映射包含空键，并且此映射不允许空键

      • put

        public V put​(K key,
             V value)
        将指定的值与此映射中的指定键相关联。 如果地图先前包含了该键的映射，则替换旧值。
        Specified by:
        put在接口 Map<K,V>
        重写：
        put在 AbstractMap<K,V>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        先前的值相关联key ，或null如果没有映射key 。 （A null返回也可以指示以前关联的地图null与key ）
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射使用自然排序，或者其比较器不允许空键

      • remove

        public V remove​(Object key)
        从此TreeMap中删除此键的映射（如果存在）。
        Specified by:
        remove在接口 Map<K,V>
        重写：
        remove在 AbstractMap<K,V>
        参数
        key - 应该删除映射的键
        结果
        前一个值与key相关联，或null如果没有映射key 。 （A null返回也可以指示以前关联的地图null与key ））
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，此映射使用自然排序，或者其比较器不允许空键

      • clear

        public void clear​()
        从这张地图中删除所有的映射。 此呼叫返回后，地图将为空。
        Specified by:
        clear在接口 Map<K,V>
        重写：
        clear在 AbstractMap<K,V>

      • clone

        public Object clone​()
        返回此TreeMap实例的浅拷贝。 （键和值本身不被克隆。）
        重写：
        clone在 AbstractMap<K,V>
        结果
        这张地图的浅拷贝
        另请参见：
        Cloneable

      • firstEntry

        public Map.Entry<K,V> firstEntry​()
        描述从接口NavigableMap复制
        返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
        Specified by:
        firstEntry在接口 NavigableMap<K,V>
        结果
        具有最少键的条目，如果此映射为空， null
        从以下版本开始：
        1.6

      • lastEntry

        public Map.Entry<K,V> lastEntry​()
        说明从界面NavigableMap复制
        返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
        Specified by:
        lastEntry在接口 NavigableMap<K,V>
        结果
        一个有最大密钥的条目，如果该地图为空， null
        从以下版本开始：
        1.6

      • pollFirstEntry

        public Map.Entry<K,V> pollFirstEntry​()
        描述从接口NavigableMap复制
        删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
        Specified by:
        pollFirstEntry在接口 NavigableMap<K,V>
        结果
        删除该地图的第一个条目，如果该地图为空， null
        从以下版本开始：
        1.6

      • pollLastEntry

        public Map.Entry<K,V> pollLastEntry​()
        说明从界面： NavigableMap复制
        删除并返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
        Specified by:
        pollLastEntry在接口 NavigableMap<K,V>
        结果
        删除该地图的最后一个条目，如果此地图为空， null
        从以下版本开始：
        1.6

      • lowerEntry

        public Map.Entry<K,V> lowerEntry​(K key)
        说明从接口NavigableMap复制
        返回与最大密钥相关联的密钥值映射严格小于给定密钥，如果没有这样的密钥，则 null 。
        Specified by:
        lowerEntry在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        一个条目的最大键值小于 key ，如果没有这样的键 null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射使用自然排序，或者其比较器不允许空键
        从以下版本开始：
        1.6

      • lowerKey

        public K lowerKey​(K key)
        描述从接口NavigableMap复制
        返回严格小于给定键的最大键，如果没有这样的键，则返回 null 。
        Specified by:
        lowerKey在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最大的钥匙要少于 key ，或者是 null如果没有这样的钥匙
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射使用自然排序，或者其比较器不允许空键
        从以下版本开始：
        1.6

      • floorEntry

        public Map.Entry<K,V> floorEntry​(K key)
        说明从界面NavigableMap复制
        返回与小于或等于给定键的最大键相关联的键值映射，如果没有此键，则 null 。
        Specified by:
        floorEntry在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最大密钥小于或等于 key ，如果没有这样的密钥， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射使用自然排序，或者其比较器不允许空键
        从以下版本开始：
        1.6

      • floorKey

        public K floorKey​(K key)
        说明从接口NavigableMap复制
        返回小于或等于给定键的最大键，如果没有这样的键，则 null 。
        Specified by:
        floorKey在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最大的钥匙小于或等于 key ，或 null如果没有这样的钥匙
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射使用自然排序，或者其比较器不允许空键
        从以下版本开始：
        1.6

      • ceilingEntry

        public Map.Entry<K,V> ceilingEntry​(K key)
        说明从界面NavigableMap复制
        返回与大于或等于给定键的最小键相关联的键值映射，如果没有此键，则 null 。
        Specified by:
        ceilingEntry在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        一个条目的最小键大于或等于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射使用自然排序，或者其比较器不允许空键
        从以下版本开始：
        1.6

      • ceilingKey

        public K ceilingKey​(K key)
        描述从接口NavigableMap复制
        返回大于或等于给定键的 null键，如果没有此键，则 null 。
        Specified by:
        ceilingKey在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最小键大于或等于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且该映射使用自然排序，或者其比较器不允许空值
        从以下版本开始：
        1.6

      • higherEntry

        public Map.Entry<K,V> higherEntry​(K key)
        说明从接口NavigableMap复制
        返回与最小键相关联的键值映射严格大于给定的键，如果没有这样的键，则 null 。
        Specified by:
        higherEntry在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        一个条目的最小键大于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，并且此映射使用自然排序，或者其比较器不允许空键
        从以下版本开始：
        1.6

      • higherKey

        public K higherKey​(K key)
        说明从界面NavigableMap复制
        返回严格大于给定键的最小键，如果没有这样的键，则返回 null 。
        Specified by:
        higherKey在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最小键大于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空，此映射使用自然排序，或者其比较器不允许空键
        从以下版本开始：
        1.6

      • keySet

        public Set<K> keySet​()
        返回此地图中包含的键的Set视图。

        该集合的迭代器按升序返回密钥。 集合的分配器是late-binding ， 故障快速 ，另外报告Spliterator.SORTED和Spliterator.ORDERED ，遇到的订单是升序的关键顺序。 该spliterator的比较（见Spliterator.getComparator() ）是null如果树映射的比较（见comparator() ）是null 。 否则，拼接器的比较器与树形图的比较器相同或者施加相同的总排序。

        该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果映射被修改，而该集合中的迭代正在进行（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。

        Specified by:
        keySet在接口 Map<K,V>
        Specified by:
        keySet在接口 SortedMap<K,V>
        重写：
        keySet在 AbstractMap<K,V>
        结果
        该地图中包含的键的集合视图

      • navigableKeySet

        public NavigableSet<K> navigableKeySet​()
        说明从接口NavigableMap复制
        返回此地图中包含的键的NavigableSet视图。 该集合的迭代器按升序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        navigableKeySet在接口 NavigableMap<K,V>
        结果
        该地图中的键的可导航集合视图
        从以下版本开始：
        1.6

      • descendingKeySet

        public NavigableSet<K> descendingKeySet​()
        说明从接口NavigableMap复制
        返回此映射中包含的键的相反顺序NavigableSet 。 集合的迭代器按降序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        descendingKeySet在接口 NavigableMap<K,V>
        结果
        该地图中的键的反向导航设置视图
        从以下版本开始：
        1.6

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。

        集合的迭代器按照相应键的升序返回值。 集合的分配器是late-binding ， 故障快速 ，另外报告Spliterator.ORDERED ，遇到的顺序是相应键的升序。

        集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。

        Specified by:
        values在接口 Map<K,V>
        Specified by:
        values在接口 SortedMap<K,V>
        重写：
        values在 AbstractMap<K,V>
        结果
        该地图中包含的值的集合视图

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。

        集合的迭代器按升序键顺序返回条目。 集合的分配器是late-binding ， 失败快速 ，另外报告Spliterator.SORTED和Spliterator.ORDERED ，遇到订单是升序的关键顺序。

        该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时修改映射（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。

        Specified by:
        entrySet在接口 Map<K,V>
        Specified by:
        entrySet在接口 SortedMap<K,V>
        Specified by:
        entrySet在 AbstractMap<K,V>
        结果
        该地图中包含的映射的集合视图

      • descendingMap

        public NavigableMap<K,V> descendingMap​()
        说明从接口NavigableMap复制
        返回此映射中包含的映射的反向排序视图。 降序地图由该地图支持，所以对地图的更改反映在降序地图中，反之亦然。 如果在映射的集合视图中的迭代正在进行（除了通过迭代器自己的remove操作），否则修改了任一映射，则迭代的结果是未定义的。

        返回的地图的订单等同于Collections.reverseOrder (comparator()) 。 表达m.descendingMap().descendingMap()返回一个视图的m实质上等同于m 。

        Specified by:
        descendingMap在接口 NavigableMap<K,V>
        结果
        这张地图的倒序视图
        从以下版本开始：
        1.6

      • subMap

        public NavigableMap<K,V> subMap​(K fromKey,
                                boolean fromInclusive,
                                K toKey,
                                boolean toInclusive)
        描述从接口NavigableMap复制
        返回此地图部分的视图，其关键字范围从fromKey到toKey 。 如果fromKey和toKey相等，则返回的地图为空，除非是fromInclusive和toInclusive都为真。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键，或构造一个其端点位于其范围之外的子地图。

        Specified by:
        subMap在接口 NavigableMap<K,V>
        参数
        fromKey - 返回地图中键的低端点
        fromInclusive - true如果低端点要包含在返回的视图中
        toKey - 返回地图中的键的高端点
        toInclusive - true如果高端点要包含在返回的视图中
        结果
        该地图的部分视图的视图范围从 fromKey到 toKey
        异常
        ClassCastException - 如果fromKey和toKey无法使用该地图的比较器相互比较（或者，如果地图没有比较器，则使用自然排序）。 如果fromKey或toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey或 toKey为空，此映射使用自然排序，或其比较器不允许空键
        IllegalArgumentException - 如果fromKey大于toKey ; 或者如果该地图本身具有有限的范围，并且fromKey或toKey位于范围的范围之外
        从以下版本开始：
        1.6

      • headMap

        public NavigableMap<K,V> headMap​(K toKey,
                                 boolean inclusive)
        说明从接口NavigableMap复制
        返回该地图部分的视图，其键值小于（或等于，如果inclusive为true） toKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        Specified by:
        headMap在接口 NavigableMap<K,V>
        参数
        toKey - 返回地图中的键的高端点
        inclusive - true如果高端点要包含在返回的视图中
        结果
        关键字小于（或等于，如果 inclusive为真）的地图部分的视图 toKey
        异常
        ClassCastException - 如果toKey与该地图的比较器不兼容（或者如果地图没有比较器，如果toKey不实现Comparable ）。 如果toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toKey为空，此映射使用自然排序，或其比较器不允许空键
        IllegalArgumentException - 如果此地图本身有限制范围，而 toKey位于范围范围之外
        从以下版本开始：
        1.6

      • tailMap

        public NavigableMap<K,V> tailMap​(K fromKey,
                                 boolean inclusive)
        描述从接口NavigableMap复制
        返回该地图部分的视图，其键大于（或等于，如果inclusive为真） fromKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        Specified by:
        tailMap在接口 NavigableMap<K,V>
        参数
        fromKey - 返回地图中键的低端点
        inclusive - true如果低端点要包含在返回的视图中
        结果
        键的大小（或等于，如果 inclusive为真）的地图部分的视图 fromKey
        异常
        ClassCastException - 如果fromKey与此地图的比较器不兼容（或者如果地图没有比较器，如果fromKey不实现Comparable ）。 如果fromKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey为空，并且此映射使用自然排序，或者其比较器不允许空键
        IllegalArgumentException - 如果此地图本身具有限制范围，并且 fromKey位于范围界限之外
        从以下版本开始：
        1.6

      • subMap

        public SortedMap<K,V> subMap​(K fromKey,
                             K toKey)
        描述从接口NavigableMap复制
        返回该地图部分的视图，其关键字范围从fromKey （含）到toKey ，独占。 （如果fromKey和toKey相等，则返回的地图为空。）返回的地图由该地图支持，所以返回地图中的更改会反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于subMap(fromKey, true, toKey, false) 。

        Specified by:
        subMap在接口 NavigableMap<K,V>
        Specified by:
        subMap在接口 SortedMap<K,V>
        参数
        fromKey - 返回地图中的键的低端点（含）
        toKey - 返回地图中的键的高端点（排他）
        结果
        该地图的部分视图，其关键范围从 fromKey （含）到 toKey ，独占
        异常
        ClassCastException - 如果fromKey和toKey无法使用该地图的比较器相互比较（或者，如果地图没有比较器，则使用自然排序）。 如果fromKey或toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey或 toKey为空，此映射使用自然排序，或其比较器不允许空键
        IllegalArgumentException - 如果fromKey大于toKey ; 或者如果该地图本身具有有限的范围，并且fromKey或toKey位于范围的范围之外

      • headMap

        public SortedMap<K,V> headMap​(K toKey)
        描述从接口NavigableMap复制
        返回该地图部分的视图，其密钥严格小于toKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于headMap(toKey, false) 。

        Specified by:
        headMap在接口 NavigableMap<K,V>
        Specified by:
        headMap在接口 SortedMap<K,V>
        参数
        toKey - 返回地图中的键的高端点（排他）
        结果
        该地图的部分密钥严格小于 toKey
        异常
        ClassCastException - 如果toKey与此映射的比较器不兼容（或者，如果映射没有比较器，如果toKey不实现Comparable ）。 如果toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toKey为空，并且此映射使用自然排序，或者其比较器不允许空键
        IllegalArgumentException - 如果此地图本身有限制范围，并且 toKey位于范围界限之外

      • tailMap

        public SortedMap<K,V> tailMap​(K fromKey)
        说明从接口NavigableMap复制
        返回此地图部分的视图，其键大于或等于fromKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于tailMap(fromKey, true) 。

        Specified by:
        tailMap在接口 NavigableMap<K,V>
        Specified by:
        tailMap在接口 SortedMap<K,V>
        参数
        fromKey - 返回地图中的键的低端点（含）
        结果
        该地图的部分的视图，其键大于或等于 fromKey
        异常
        ClassCastException - 如果fromKey与此地图的比较器不兼容（或者，如果地图没有比较器，如果fromKey不实现Comparable ）。 如果fromKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey为空，并且此映射使用自然排序，或其比较器不允许空键
        IllegalArgumentException - 如果此地图本身有限制范围，并且 fromKey位于范围界限之外

      • replace

        public boolean replace​(K key,
                       V oldValue,
                       V newValue)
        说明从界面Map复制
        仅当当前映射到指定的值时，才能替换指定键的条目。
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        oldValue - 预期与指定键相关联的值
        newValue - 与指定键相关联的值
        结果
        true如果该值被替换

      • replace

        public V replace​(K key,
                 V value)
        说明从接口Map复制
        只有当目标映射到某个值时，才能替换指定键的条目。
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示以前关联的映射关系为null ，如果实现支持空值）。

      • forEach

        public void forEach​(BiConsumer<? super K,? super V> action)
        说明从接口Map复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach在接口 Map<K,V>
        参数
        action - 要为每个条目执行的操作

      • replaceAll

        public void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        说明从接口Map复制
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll在接口 Map<K,V>
        参数
        function - 应用于每个条目的功能
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class TreeSet<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractSet<E>
        • java.util.TreeSet<E>
  • 参数类型
    E - 由此集合维护的元素的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， NavigableSet<E> ， Set<E> ， SortedSet<E>

    public class TreeSet<E>
extends AbstractSet<E>
implements NavigableSet<E>, Cloneable, Serializable
    A NavigableSet实现基于TreeMap 。 的元件使用其有序natural ordering ，或由Comparator集合创建时提供，这取决于所使用的构造方法。

    此实现提供了基本的操作（保证的log（n）时间成本add ， remove和contains ）。

    请注意，如果要正确实现Set接口，由集合维护的排序（无论是否提供显式比较器）必须与equals一致 。 （见Comparable或Comparator ，以获得与等于一致的精确定义）这是因为Set接口是根据equals操作定义的，但TreeSet实例使用其compareTo （或compare ）方法执行所有元素比较，因此两通过该方法认为相等的元素从集合的角度来看是相等的。 集合的行为是明确定义的，即使其排序与equals不一致; 它只是不符合Set接口的总体合同。

    请注意，此实现不同步。 如果多个线程并发访问树，并且至少有一个线程修改该集合，则必须在外部进行同步。 这通常通过在自然地封装集合的一些对象上进行同步来实现。 如果不存在这样的对象，则应使用Collections.synchronizedSortedSet方法“设置”。 这最好在创建时完成，以防止意外的非同步访问集：

      SortedSet s = Collections.synchronizedSortedSet(new TreeSet(...));

    此类的iterator方法返回的迭代器是故障快速的 ：如果集合在迭代器创建后的任何时间被修改，除了通过迭代器自己的remove方法之外，迭代器将抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的迭代器ConcurrentModificationException扔ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Collection ， Set ， HashSet ， Comparable ， Comparator ， TreeMap ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeSet​()
      构造一个新的，空的树组，根据其元素的自然排序进行排序。
      TreeSet​(Collection<? extends E> c)
      构造一个包含指定集合中的元素的新树集，根据其元素的 自然排序进行排序 。
      TreeSet​(Comparator<? super E> comparator)
      构造一个新的，空的树集，根据指定的比较器进行排序。
      TreeSet​(SortedSet<E> s)
      构造一个包含相同元素的新树，并使用与指定排序集相同的顺序。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素添加到此集合（如果尚未存在）。
      boolean addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合中。
      E ceiling​(E e)
      返回此集合中最小元素大于或等于给定元素，如果没有此元素，则 null 。
      void clear​()
      从此集合中删除所有元素。
      Object clone​()
      返回此 TreeSet实例的浅层副本。
      Comparator<? super E> comparator​()
      返回用于为了在这个组中的元素，或比较null如果这个集使用natural ordering的元素。
      boolean contains​(Object o)
      如果此集合包含指定的元素，则返回 true 。
      Iterator<E> descendingIterator​()
      以降序返回该集合中的元素的迭代器。
      NavigableSet<E> descendingSet​()
      返回此集合中包含的元素的反向排序视图。
      E first​()
      返回此集合中当前的第一个（最低）元素。
      E floor​(E e)
      返回此集中最大的元素小于或等于给定元素，如果没有此元素，则 null 。
      SortedSet<E> headSet​(E toElement)
      返回此集合的部分的视图，其元素严格小于 toElement 。
      NavigableSet<E> headSet​(E toElement, boolean inclusive)
      返回此集合的部分的视图，其元素小于（或等于，如果 inclusive为真） toElement 。
      E higher​(E e)
      返回这个集合中的最小元素严格大于给定的元素，如果没有这样的元素，则 null 。
      boolean isEmpty​()
      如果此集合不包含元素，则返回 true 。
      Iterator<E> iterator​()
      以升序返回该集合中的元素的迭代器。
      E last​()
      返回此集合中当前的最后（最高）元素。
      E lower​(E e)
      返回该集合中最大的元素严格小于给定的元素，如果没有这样的元素，则 null 。
      E pollFirst​()
      检索并删除第一个（最低）元素，如果此集合为空，则返回 null 。
      E pollLast​()
      检索并删除最后一个（最高）元素，如果此集合为空，则返回 null 。
      boolean remove​(Object o)
      如果存在，则从该集合中删除指定的元素。
      int size​()
      返回此集合中的元素数（其基数）。
      Spliterator<E> spliterator​()
      在此集合中的元素上创建late-binding和故障快速 Spliterator 。
      NavigableSet<E> subSet​(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
      返回此集合的部分的视图，其元素的范围从 fromElement到 toElement 。
      SortedSet<E> subSet​(E fromElement, E toElement)
      返回此集合的部分的视图，其元素的范围从 fromElement （包括）到 toElement ，独占。
      SortedSet<E> tailSet​(E fromElement)
      返回此集合的部分的视图，该部分的元素大于或等于 fromElement 。
      NavigableSet<E> tailSet​(E fromElement, boolean inclusive)
      返回此集合的部分的视图，其元素大于（或等于，如果 inclusive为true） fromElement 。

      • Methods inherited from class java.util.AbstractCollection

        containsAll, retainAll, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractSet

        equals, hashCode, removeAll

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Set

        containsAll, equals, hashCode, of, of, of, of, of, of, of, of, of, of, of, of, removeAll, retainAll, toArray, toArray

    • 构造方法详细信息

      • TreeSet

        public TreeSet​()
        构造一个新的，空的树组，根据其元素的自然排序进行排序。 插入到集合中的所有元素必须实现Comparable接口。 此外，所有这些元素必须相互可比较 ： e1.compareTo(e2)不得为ClassCastException中的任何元素e1和e2抛出ClassCastException 。 如果用户尝试向组中添加违反此约束的元素（例如，用户尝试将字符串元素添加到其元素为整数的集合），则add调用将抛出一个ClassCastException 。

      • TreeSet

        public TreeSet​(Comparator<? super E> comparator)
        构造一个新的，空的树集，根据指定的比较器进行排序。 插入到集合中的所有元素必须由指定的比较器相互比较： comparator.compare(e1, e2)不能为ClassCastException中的任何元素e1和e2抛出ClassCastException 。 如果用户尝试向该集合中添加违反此约束的元素，那么add调用将抛出一个ClassCastException 。
        参数
        comparator - 将用于对该组进行排序的比较器。 如果是null ，将使用natural ordering的元素。

      • TreeSet

        public TreeSet​(Collection<? extends E> c)
        构造一个包含指定集合中的元素的新树集，根据其元素的自然排序进行排序 。 插入到集合中的所有元素必须实现Comparable接口。 此外，所有这些元素必须相互可比较 ： e1.compareTo(e2)不得为ClassCastException中的任何元素e1和e2抛出ClassCastException 。
        参数
        c - 其元素将组成新集合的集合
        异常
        ClassCastException - 如果c中的元素不是Comparable ，或者不相互比较
        NullPointerException - 如果指定的集合为空

      • TreeSet

        public TreeSet​(SortedSet<E> s)
        构造一个包含相同元素的新树，并使用与指定排序集相同的顺序。
        参数
        s - 其元素将组成新集的排序集
        异常
        NullPointerException - 如果指定的排序集为空

    • 方法详细信息

      • iterator

        public Iterator<E> iterator​()
        以升序返回该集合中的元素的迭代器。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 NavigableSet<E>
        Specified by:
        iterator在接口 Set<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        这个集合中的元素的迭代器按升序排列

      • descendingIterator

        public Iterator<E> descendingIterator​()
        以降序返回该集合中的元素的迭代器。
        Specified by:
        descendingIterator在接口 NavigableSet<E>
        结果
        这个集合中的元素的迭代器按降序排列
        从以下版本开始：
        1.6

      • descendingSet

        public NavigableSet<E> descendingSet​()
        说明从接口NavigableSet复制
        返回此集合中包含的元素的反向排序视图。 下降集由此集合支持，因此对集合的更改反映在下降集中，反之亦然。 如果任何一个集合都被修改，而任一集合中的迭代正在进行（除了通过迭代器自己的remove操作），迭代的结果是未定义的。

        返回的集合的订单等同于Collections.reverseOrder (comparator()) 。 表达s.descendingSet().descendingSet()返回一个视图的s实质上等同于s 。

        Specified by:
        descendingSet在接口 NavigableSet<E>
        结果
        这个集合的逆序视图
        从以下版本开始：
        1.6

      • size

        public int size​()
        返回此集合中的元素数（其基数）。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Set<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        该集合中的元素数（其基数）

      • isEmpty

        public boolean isEmpty​()
        如果此集合不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        Specified by:
        isEmpty在接口 Set<E>
        重写：
        isEmpty在 AbstractCollection<E>
        结果
        true如果此集合不包含元素

      • contains

        public boolean contains​(Object o)
        如果此集合包含指定的元素，则返回true 。 更正式地，返回true当且仅当此集合包含一个元素e ，使Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Set<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要在此集合中检查包含的对象
        结果
        true如果此集合包含指定的元素
        异常
        ClassCastException - 如果指定的对象不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且该集合使用自然排序，或者其比较器不允许空元素

      • add

        public boolean add​(E e)
        将指定的元素添加到此集合（如果尚未存在）。 更正式地，将指定的元素e这一套如果集合不包含元素e2这样Objects.equals(e, e2) 。 如果此集合已经包含该元素，则该呼叫false该集合保持不变，并返回false 。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Set<E>
        重写：
        add在 AbstractCollection<E>
        参数
        e - 要添加到此集合的元素
        结果
        true如果此集合尚未包含指定的元素
        异常
        ClassCastException - 如果指定的对象不能与当前在此集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且该集合使用自然排序，或者其比较器不允许空元素

      • remove

        public boolean remove​(Object o)
        如果存在，则从该集合中删除指定的元素。 更正式地，删除一个元素e ，使Objects.equals(o, e) ，如果这个集合包含这样一个元素。 返回true如果此集合包含元素（或等效地，如果该集合由于调用而更改）。 （一旦调用返回，此集合将不包含该元素。）
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 Set<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此集合中删除的对象（如果存在）
        结果
        true如果这个集合包含指定的元素
        异常
        ClassCastException - 如果指定的对象无法与当前在此集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且该集合使用自然排序，或者其比较器不允许空元素

      • clear

        public void clear​()
        从此集合中删除所有元素。 此呼叫返回后，该组将为空。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 Set<E>
        重写：
        clear在 AbstractCollection<E>

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        将指定集合中的所有元素添加到此集合中。
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 Set<E>
        重写：
        addAll在 AbstractCollection<E>
        参数
        c - 包含要添加到此集合的元素的集合
        结果
        true如果此设置由于呼叫而更改
        异常
        ClassCastException - 如果提供的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的集合为空，或者如果任何元素为空，并且该集合使用自然排序，或者其比较器不允许空元素
        另请参见：
        AbstractCollection.add(Object)

      • subSet

        public NavigableSet<E> subSet​(E fromElement,
                              boolean fromInclusive,
                              E toElement,
                              boolean toInclusive)
        描述从接口NavigableSet复制
        返回此集合的部分的视图，其元素的范围从fromElement到toElement 。 如果fromElement和toElement相等，则返回的集合为空，除非fromInclusive和toInclusive都为真。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        Specified by:
        subSet在接口 NavigableSet<E>
        参数
        fromElement - 返回集合的低端点
        fromInclusive - true如果 true低端点包括在返回的视图中
        toElement - 返回集合的高端点
        toInclusive - true如果高端点要包含在返回的视图中
        结果
        该集合的部分视图的元素范围从 fromElement （含）到 toElement ，独占
        异常
        ClassCastException - 如果fromElement和toElement无法使用该集合的比较器彼此进行比较（或者如果该集合没有比较器，则使用自然排序）。 如果fromElement或toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement或 toElement为空，并且此集合使用自然排序，或其比较器不允许空元素
        IllegalArgumentException - 如果fromElement大于toElement ; 或者如果此设置本身具有限制范围，并且fromElement或toElement位于范围的边界之外。
        从以下版本开始：
        1.6

      • headSet

        public NavigableSet<E> headSet​(E toElement,
                               boolean inclusive)
        描述从接口NavigableSet复制
        返回此集合的部分的视图，其元素小于（或等于，如果inclusive为真） toElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，尝试在其范围之外插入一个元素。

        Specified by:
        headSet在接口 NavigableSet<E>
        参数
        toElement - 返回集合的高端点
        inclusive - true如果高端点要包含在返回的视图中
        结果
        该集合的部分的元素的视图小于（或等于，如果 inclusive为真） toElement
        异常
        ClassCastException - 如果toElement与此设置的比较器不兼容（或者如果该集合没有比较器，如果toElement不实现Comparable ）。 如果toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toElement为空，并且该集合使用自然排序，或者其比较器不允许空元素
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 toElement位于范围范围之外
        从以下版本开始：
        1.6

      • tailSet

        public NavigableSet<E> tailSet​(E fromElement,
                               boolean inclusive)
        描述从接口NavigableSet复制
        返回此组的部分的视图，其元素大于（或等于，如果inclusive为true） fromElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        Specified by:
        tailSet在接口 NavigableSet<E>
        参数
        fromElement - 返回集合的低端点
        inclusive - true如果低端点要包含在返回的视图中
        结果
        该集合的部分的视图，其元素大于或等于 fromElement
        异常
        ClassCastException - 如果fromElement与此集合的比较器不兼容（或如果该集合没有比较器，如果fromElement不实现Comparable ）。 如果fromElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement为空，并且此集合使用自然排序，或其比较器不允许空元素
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 fromElement位于范围的边界之外
        从以下版本开始：
        1.6

      • subSet

        public SortedSet<E> subSet​(E fromElement,
                           E toElement)
        说明从接口NavigableSet复制
        返回此集合的部分的视图，其元素的范围从fromElement （包括）到toElement ，独占。 （如果fromElement和toElement相等，则返回的集合为空。）返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将会抛出一个IllegalArgumentException ，试图将一个元素插入其范围之外。

        相当于subSet(fromElement, true, toElement, false) 。

        Specified by:
        subSet在接口 NavigableSet<E>
        Specified by:
        subSet在接口 SortedSet<E>
        参数
        fromElement - 返回集合的低端点（含）
        toElement - 返回集合的高端点（独占）
        结果
        该集合的部分视图，其元素范围从 fromElement （含）到 toElement ，独占
        异常
        ClassCastException - 如果fromElement和toElement无法使用该集合的比较器彼此进行比较（或者如果该集合没有比较器，则使用自然排序）。 如果fromElement或toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement或 toElement为空，并且此集合使用自然排序，或其比较器不允许空元素
        IllegalArgumentException - 如果fromElement大于toElement ; 或者如果此设置本身具有限制范围，并且fromElement或toElement位于范围范围之外

      • headSet

        public SortedSet<E> headSet​(E toElement)
        描述从接口NavigableSet复制
        返回此集合的部分的视图，其元素严格小于toElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        相当于headSet(toElement, false) 。

        Specified by:
        headSet在接口 NavigableSet<E>
        Specified by:
        headSet在接口 SortedSet<E>
        参数
        toElement - 返回集合的高端点（独占）
        结果
        该集合的部分的视图，其元素严格小于 toElement
        异常
        ClassCastException - 如果toElement与此集合的比较器不兼容（或者如果该集合没有比较器，如果toElement不实现Comparable ）。 如果toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toElement为空，并且此集合使用自然排序，或其比较器不允许空元素
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 toElement位于范围的边界之外

      • tailSet

        public SortedSet<E> tailSet​(E fromElement)
        说明从接口NavigableSet复制
        返回该集合的元素大于或等于fromElement的部分的视图。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        相当于tailSet(fromElement, true) 。

        Specified by:
        tailSet在接口 NavigableSet<E>
        Specified by:
        tailSet在接口 SortedSet<E>
        参数
        fromElement - 返回集合的低端点（含）
        结果
        该集合的部分的视图，其元素大于或等于 fromElement
        异常
        ClassCastException - 如果fromElement与此设置的比较器不兼容（或者如果该集合没有比较器，如果fromElement不实现Comparable ）。 如果fromElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement为空，并且此集合使用自然排序，或其比较器不允许空元素
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 fromElement位于范围的边界之外

      • comparator

        public Comparator<? super E> comparator​()
        说明从界面SortedSet复制
        返回用于对该集合中的元素进行排序的比较器，或null如果此集合使用其元素的natural ordering 。
        Specified by:
        comparator在接口 SortedSet<E>
        结果
        比较器用于对该集合中的元素进行排序，如果此集合使用其元素的自然排序， null

      • first

        public E first​()
        描述从接口SortedSet复制
        返回此集合中当前的第一个（最低）元素。
        Specified by:
        first在接口 SortedSet<E>
        结果
        当前在这个集合中的第一（最低）元素
        异常
        NoSuchElementException - 如果此设置为空

      • last

        public E last​()
        说明从接口SortedSet复制
        返回此集合中当前的最后（最高）元素。
        Specified by:
        last在接口 SortedSet<E>
        结果
        当前在此集合中的最后（最高）元素
        异常
        NoSuchElementException - 如果此设置为空

      • lower

        public E lower​(E e)
        说明从界面NavigableSet复制
        返回这个集合中最大的元素，严格小于给定的元素，如果没有这样的元素，则 null 。
        Specified by:
        lower在接口 NavigableSet<E>
        参数
        e - 要匹配的值
        结果
        最大元素小于 e ，或 null如果没有这样的元素
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且该集合使用自然排序，或者其比较器不允许空元素
        从以下版本开始：
        1.6

      • floor

        public E floor​(E e)
        说明从接口NavigableSet复制
        返回该集合中最大的元素小于或等于给定元素，如果没有这样的元素，则 null 。
        Specified by:
        floor在接口 NavigableSet<E>
        参数
        e - 要匹配的值
        结果
        最大元素小于或等于 e ，或 null如果没有这样的元素
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且该集合使用自然排序，或者其比较器不允许空元素
        从以下版本开始：
        1.6

      • ceiling

        public E ceiling​(E e)
        说明从界面NavigableSet复制
        返回此集合中最小元素大于或等于给定元素，如果没有此元素，则 null 。
        Specified by:
        ceiling在接口 NavigableSet<E>
        参数
        e - 要匹配的值
        结果
        最小元素大于或等于 e ，或 null如果没有这样的元素
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且该集合使用自然排序，或者其比较器不允许空元素
        从以下版本开始：
        1.6

      • higher

        public E higher​(E e)
        说明从界面NavigableSet复制
        返回此集中的最小元素严格大于给定元素，如果没有此元素，则 null 。
        Specified by:
        higher在接口 NavigableSet<E>
        参数
        e - 要匹配的值
        结果
        最小的元素大于 e ，如果没有这样的元素， null
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空，并且该集合使用自然排序，或者其比较器不允许空元素
        从以下版本开始：
        1.6

      • pollFirst

        public E pollFirst​()
        说明从界面NavigableSet复制
        检索并删除第一个（最低）元素，如果此集合为空，则返回 null 。
        Specified by:
        pollFirst在接口 NavigableSet<E>
        结果
        第一个元素，或 null如果此集合为空
        从以下版本开始：
        1.6

      • pollLast

        public E pollLast​()
        描述从接口NavigableSet复制
        检索并删除最后一个（最高）元素，如果此集合为空，则返回 null 。
        Specified by:
        pollLast在接口 NavigableSet<E>
        结果
        最后一个元素，或 null如果此集合为空
        从以下版本开始：
        1.6

      • clone

        public Object clone​()
        返回此TreeSet实例的浅拷贝。 （元素本身不被克隆。）
        重写：
        clone在 Object
        结果
        这个集合的浅拷贝
        另请参见：
        Cloneable

      • spliterator

        public Spliterator<E> spliterator​()
        在此集合中的元素上创建late-binding和故障快速 Spliterator 。

        该Spliterator报告Spliterator.SIZED ， Spliterator.DISTINCT ， Spliterator.SORTED ，并Spliterator.ORDERED 。 覆盖实现应记录其他特征值的报告。

        该spliterator的比较（见Spliterator.getComparator() ）是null如果树集的比较（见comparator() ）是null 。 否则，分配器的比较器与树组的比较器相同或者施加相同的总排序。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Specified by:
        spliterator在接口 Set<E>
        Specified by:
        spliterator在接口 SortedSet<E>
        结果
        一个 Spliterator在这个集合中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnknownFormatConversionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class UnknownFormatConversionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.UnknownFormatConversionException
  • All Implemented Interfaces:
    Serializable

    public class UnknownFormatConversionException
extends IllegalFormatException
    给出未知转换时抛出未检查的异常。

    除非另有说明，否则传递一个null参数到null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownFormatConversionException​(String s)
      构造具有未知转换的此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getConversion​()
      返回未知的转换。
      String getMessage​()
      返回此throwable的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownFormatConversionException

        public UnknownFormatConversionException​(String s)
        构造具有未知转换的此类的实例。
        参数
        s - 未知的转换

    • 方法详细信息

      • getConversion

        public String getConversion​()
        返回未知的转换。
        结果
        未知的转换。

      • getMessage

        public String getMessage​()
        描述从类复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnknownFormatFlagsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class UnknownFormatFlagsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.UnknownFormatFlagsException
  • All Implemented Interfaces:
    Serializable

    public class UnknownFormatFlagsException
extends IllegalFormatException
    给定未知标志时抛出未检查的异常。

    除非另有说明，否则将null参数传递给null中的任何方法或构造函数将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownFormatFlagsException​(String f)
      使用指定的标志构造此类的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getFlags​()
      返回包含未知标志的标志集。
      String getMessage​()
      返回此throwable的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownFormatFlagsException

        public UnknownFormatFlagsException​(String f)
        使用指定的标志构造此类的实例。
        参数
        f - 包含未知标志的格式标志集

    • 方法详细信息

      • getFlags

        public String getFlags​()
        返回包含未知标志的标志集。
        结果
        旗帜

      • getMessage

        public String getMessage​()
        描述从类复制： Throwable
        返回此throwable的详细消息字符串。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util

  • Packages that use java.util
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.security.auth.module
    提供LoginModule的实现。
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。
    com.sun.tools.jconsole
    此程序包包含JConsole API。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.math
    提供用于执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    服务提供商类为 java.nio.channels包。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.charset.spi
    服务提供商类为 java.nio.charset包。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供商类。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    java.util.spi
    java.util包中类的服务提供者类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.application
    提供应用程序生命周期类。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.activation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.event
    一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.plugins.bmp
    包含内置BMP插件使用的公共类的软件包。
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.management.timer
    提供定时器MBean的定义。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming包以提供访问目录服务的功能。
    javax.naming.event
    访问命名和目录服务时，提供对事件通知的支持。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.naming.spi
    提供通过 javax.naming和相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.print.event
    程序包javax.print.event包含事件类和侦听器接口。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.callback
    该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.auth.spi
    该包提供了用于实现可插拔认证模块的接口。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    javax.security.cert
    提供公钥证书类。
    javax.security.sasl
    包含用于支持SASL的类和接口。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dom
    针对 javax.xml.crypto包的DOM特定类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.crypto.dsig.keyinfo
    用于解析和处理KeyInfo元素和结构的类。
    javax.xml.crypto.dsig.spec
    XML数字签名的参数类。
    javax.xml.datatype
    定义XML / Java类型映射。
    javax.xml.namespace
    定义XML命名空间处理。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.stream.events
    定义Streaming API for XML（StAX）的事件接口。
    javax.xml.stream.util
    为Streaming API for XML（StAX）提供实用程序类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.handler
    新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：
    javax.xml.ws.handler.soap
    此包定义SOAP消息处理程序的API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.net
    适用于 java.net和 java.nio.channels套接字类的平台特定套接字选项。
    jdk.packager.services
    定义Java Packager工具使用的服务。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括类 ORB ，该类实现为程序员可以将其用作全功能对象请求代理（ORB）。
    org.xml.sax
    提供核心SAX API。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。
  • Classes in java.util used by com.sun.java.accessibility.util
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by com.sun.jdi
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by com.sun.jdi.connect
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by com.sun.jdi.event
    Class 描述
    Collection
    集合层次结构中的根界面。
    Iterator
    一个集合的迭代器。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by com.sun.jdi.request
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by com.sun.management
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by com.sun.net.httpserver
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by com.sun.nio.sctp
    Class 描述
    Set
    不包含重复元素的集合。
  • Classes in java.util used by com.sun.security.auth.module
    Class 描述
    Map
    将键映射到值的对象。
  • Classes in java.util used by com.sun.source.doctree
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by com.sun.source.tree
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by com.sun.source.util
    Class 描述
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by com.sun.tools.attach
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Properties
    Properties类表示一组持久的属性。
  • Classes in java.util used by com.sun.tools.attach.spi
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by com.sun.tools.jconsole
    Class 描述
    Map
    将键映射到值的对象。
  • Classes in java.util used by java.applet
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Iterator
    一个集合的迭代器。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by java.awt
    Class 描述
    Collection
    集合层次结构中的根界面。
    EmptyStackException
    由 Stack类中的方法抛出，表示堆栈为空。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    Properties
    Properties类表示一组持久的属性。
    ResourceBundle
    资源束包含区域特定的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.awt.datatransfer
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by java.awt.desktop
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by java.awt.dnd
    Class 描述
    ArrayList
    List接口的可调整大小的数组实现。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    TooManyListenersException
    TooManyListenersException异常用作Java事件模型的一部分，用于注释和实现组播事件源的单播特殊情况。
  • Classes in java.util used by java.awt.event
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventListenerProxy
    EventListener类的抽象包装类， EventListener一组附加参数与侦听器相关联。
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by java.awt.font
    Class 描述
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.awt.im
    Class 描述
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化区域。
    Map
    将键映射到值的对象。
  • Classes in java.util used by java.awt.im.spi
    Class 描述
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by java.awt.image
    Class 描述
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    List
    有序集合（也称为 序列 ）。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by java.awt.image.renderable
    Class 描述
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by java.beans
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventListenerProxy
    EventListener类的抽象包装类， EventListener一组附加参数与侦听器相关联。
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by java.beans.beancontext
    Class 描述
    ArrayList
    List接口的可调整大小的数组实现。
    Collection
    集合层次结构中的根界面。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    HashMap
    基于哈希表的实现 Map界面。
    Iterator
    一个集合的迭代器。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    TooManyListenersException
    TooManyListenersException异常用作Java事件模型的一部分，用于注释和实现组播事件源的单播特殊情况。
  • Classes in java.util used by java.io
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by java.lang
    Class 描述
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    Map
    将键映射到值的对象。
    Optional
    可能包含或不包含非 null值的容器对象。
    Properties
    Properties类表示一组持久的属性。
    ResourceBundle
    资源束包含区域特定的对象。
    Set
    不包含重复元素的集合。
    Spliterator
    用于遍历和分割源的元素的对象。
  • Classes in java.util used by java.lang.instrument
    Class 描述
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.lang.invoke
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by java.lang.management
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.lang.module
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Optional
    可能包含或不包含非 null值的容器对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.math
    Class 描述
    Random
    该类的实例用于生成伪随机数的流。
  • Classes in java.util used by java.net
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.nio.channels
    Class 描述
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.nio.channels.spi
    Class 描述
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.nio.charset
    Class 描述
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    Set
    不包含重复元素的集合。
    SortedMap
    A Map进一步提供其键上的总排序 。
  • Classes in java.util used by java.nio.charset.spi
    Class 描述
    Iterator
    一个集合的迭代器。
  • Classes in java.util used by java.nio.file
    Class 描述
    ConcurrentModificationException
    当不允许这样的修改时，可以通过检测到对象的并发修改的方法来抛出此异常。
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.nio.file.attribute
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.nio.file.spi
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.rmi.activation
    Class 描述
    Properties
    Properties类表示一组持久的属性。
  • Classes in java.util used by java.security
    Class 描述
    Collection
    集合层次结构中的根界面。
    Date
    Date代表了一个特定的时间，具有毫秒精度。
    Dictionary
    Dictionary类是任何类的抽象父类，例如 Hashtable ，它将键映射到值。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    Properties
    Properties类表示一组持久的属性。
    Random
    该类的实例用于生成伪随机数的流。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.security.acl
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
  • Classes in java.util used by java.security.cert
    Class 描述
    Collection
    集合层次结构中的根界面。
    Date
    Date类代表一个特定的时间，以毫秒的精度。
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.sql
    Class 描述
    Calendar
    所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
    Date
    Date类代表一个特定的时间，以毫秒的精度。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Iterator
    一个集合的迭代器。
    Map
    将键映射到值的对象。
    Properties
    Properties类表示一组持久的属性。
  • Classes in java.util used by java.text
    Class 描述
    Calendar
    所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    Currency
    代表货币。
    Date
    Date类代表一个特定的时间，以毫秒的精度。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
    TimeZone
    TimeZone表示时区偏移量，也可以计算出夏令时。
  • Classes in java.util used by java.text.spi
    Class 描述
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by java.time
    Class 描述
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.time.chrono
    Class 描述
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.time.format
    Class 描述
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.time.temporal
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化区域。
    Map
    将键映射到值的对象。
  • Classes in java.util used by java.time.zone
    Class 描述
    List
    有序集合（也称为 序列 ）。
    NavigableMap
    A SortedMap扩展了导航方法，为给定的搜索目标返回最接近的匹配。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by java.util
    Class 描述
    AbstractCollection
    该类提供了 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractList
    该类提供了List接口的骨架实现，以最小化实现由“随机访问”数据存储（例如数组）支持的此接口所需的工作量。
    AbstractMap
    此类提供了 Map接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractQueue
    这个类提供了一些Queue操作的骨架实现。
    AbstractSequentialList
    该类提供了 List接口的骨架实现，以最小化实现由“顺序访问”数据存储（如链表）支持的此接口所需的工作量。
    AbstractSet
    此类提供了 Set接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    ArrayDeque
    Deque接口的可调整大小的数组实现。
    ArrayList
    List接口的可调整大小的数组实现。
    Base64.Decoder
    该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于解码字节数据的解码器。
    Base64.Encoder
    该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于编码字节数据的编码器。
    BitSet
    该类实现了根据需要增长的位向量。
    Calendar
    所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
    Calendar.Builder
    Calendar.Builder用于从各种日期时间参数创建 Calendar 。
    Collection
    集合层次结构中的根界面。
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    Currency
    代表货币。
    Date
    Date类代表一个特定的时间，以毫秒的精度。
    Deque
    支持两端元素插入和移除的线性集合。
    Dictionary
    Dictionary类是任何类的抽象父类，例如 Hashtable ，它将键映射到值。
    DoubleSummaryStatistics
    统计数据的收集状态，如count，min，max，sum和average。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EnumMap
    专门用于枚举类型键的Map实现。
    EnumSet
    专门用于枚举类型的Set实现。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    Formatter
    printf风格格式字符串的解释器。
    Formatter.BigDecimalLayoutForm
    枚举为 BigDecimal格式化。
    GregorianCalendar
    GregorianCalendar是的具体子 Calendar ，并提供了世界上大多数国家使用的标准日历系统。
    HashMap
    基于哈希表的实现的 Map接口。
    HashSet
    该类实现 Set接口，由哈希表（实际为 HashMap实例）支持。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    IllegalFormatException
    当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。
    IntSummaryStatistics
    统计数据的收集状态，如count，min，max，sum和average。
    InvalidPropertiesFormatException
    抛出以表示操作无法完成，因为输入符合Properties规范的属性集合的相应XML文档类型。
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    ListIterator
    用于允许程序员沿任一方向遍历列表的列表的迭代器，在迭代期间修改列表，并获取列表中迭代器的当前位置。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    Locale.Builder
    Builder用于从setter配置的值构建 Locale实例。
    Locale.Category
    枚举地区类别。
    Locale.FilteringMode
    此枚举提供常量来选择区域设置匹配的过滤模式。
    Locale.IsoCountryCode
    用于指定ISO 3166中定义的类型的枚举。
    Locale.LanguageRange
    此类表示 RFC 4647 Matching of Language Tags中定义的 语言范围 。
    LongSummaryStatistics
    统计数据的收集状态，如count，min，max，sum和average。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    MissingResourceException
    表示资源丢失。
    NavigableMap
    A SortedMap扩展了导航方法返回给定搜索目标的最接近的匹配。
    NavigableSet
    A SortedSet扩展了导航方法，报告给定搜索目标的最匹配。
    NoSuchElementException
    被各种访问器方法抛出，表示被请求的元素不存在。
    Observable
    已过时。
    此类和Observer接口已被弃用。 Observer和Observable支持的事件模型是非常有限的， Observable发送的通知的Observable是未指定的，状态更改不与通知一一对应。 对于更丰富的事件模型，请考虑使用java.beans软件包。 对于线程之间的可靠和有序的消息传递，请考虑使用java.util.concurrent包中的并发数据结构之一。 对于反应流样式编程，请参阅Flow API。
    Observer
    已过时。
    此接口已被弃用。 有关更多信息，请参阅Observable课程。
    Optional
    可能包含或不包含非 null值的容器对象。
    OptionalDouble
    可能包含或可能不包含 double值的容器对象。
    OptionalInt
    可能包含或可能不包含 int值的容器对象。
    OptionalLong
    一个可能含有也可能不包含 long值的容器对象。
    PrimitiveIterator
    Iterator基本专长的基本类型。
    PrimitiveIterator.OfDouble
    一个专门针对 double值的迭代器。
    PrimitiveIterator.OfInt
    一个专门为 int值的迭代器。
    PrimitiveIterator.OfLong
    一个专门针对 long值的迭代器。
    PriorityQueue
    基于优先级堆的无限优先级queue 。
    Properties
    Properties类表示一组持久的属性。
    Queue
    设计用于在处理之前保留元素的集合。
    Random
    该类的实例用于生成伪随机数的流。
    RandomAccess
    标记接口由 List实现使用，以表明它们支持快速（通常为恒定时间）随机访问。
    ResourceBundle
    资源束包含区域特定的对象。
    ResourceBundle.Control
    ResourceBundle.Control定义了在捆绑包加载过程中由 ResourceBundle.getBundle工厂方法调用的一组回调方法。
    Scanner
    一个简单的文本扫描器，可以使用正则表达式解析原始类型和字符串。
    ServiceLoader
    一种加载服务实现的工具。
    ServiceLoader.Provider
    代表由 ServiceLoader提供的服务提供商。
    Set
    不包含重复元素的集合。
    SortedMap
    A Map进一步提供其键上的总排序 。
    SortedSet
    A Set进一步提供了其元素的总排序 。
    Spliterator
    用于遍历和分割源的元素的对象。
    Spliterator.OfDouble
    一个专门为 double值的 double 。
    Spliterator.OfInt
    一个专门为 int值的 int 。
    Spliterator.OfLong
    A Spliterator专门为 long值。
    Spliterator.OfPrimitive
    专门针对原始价值观的Spliterator。
    SplittableRandom
    适用于（在其他上下文中）使用可能产生子任务的孤立并行计算的均匀伪随机值的生成器。
    StringJoiner
    StringJoiner用于构建由分隔符分隔的字符序列，并且可选地从提供的前缀开始，并以提供的后缀结尾。
    TimerTask
    可以由Timer一次性或重复执行的任务 。
    TimeZone
    TimeZone代表时区偏移量，也可以显示夏令时。
    UUID
    一个表示不可变的通用唯一标识符（UUID）的类。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by java.util.concurrent
    Class 描述
    AbstractCollection
    此类提供了 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractMap
    此类提供了 Map接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractQueue
    这个类提供了一些Queue操作的骨架实现。
    AbstractSet
    此类提供了 Set接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    Collection
    集合层次结构中的根界面。
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    Deque
    支持两端元素插入和移除的线性集合。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    ListIterator
    用于允许程序员沿任一方向遍历列表的列表的迭代器，在迭代期间修改列表，并获取列表中迭代器的当前位置。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    NavigableMap
    A SortedMap扩展了导航方法，为给定的搜索目标返回最接近的匹配。
    NavigableSet
    A SortedSet使用报告与给定搜索目标最匹配的导航方法进行扩展。
    Queue
    设计用于在处理之前保留元素的集合。
    Random
    该类的实例用于生成伪随机数的流。
    RandomAccess
    标记接口由 List实现使用，以表明它们支持快速（通常为恒定时间）随机访问。
    Set
    不包含重复元素的集合。
    SortedMap
    A Map进一步提供其键上的总排序 。
    SortedSet
    A Set进一步提供了其元素的总排序 。
    Spliterator
    用于遍历和分割源的元素的对象。
  • Classes in java.util used by java.util.concurrent.locks
    Class 描述
    Collection
    集合层次结构中的根界面。
    Date
    Date类代表一个特定的时间，以毫秒的精度。
  • Classes in java.util used by java.util.function
    Class 描述
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
  • Classes in java.util used by java.util.jar
    Class 描述
    Collection
    集合层次结构中的根界面。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    Set
    不包含重复元素的集合。
    SortedMap
    A Map进一步提供其键上的总排序 。
  • Classes in java.util used by java.util.logging
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    List
    有序集合（也称为 序列 ）。
    ResourceBundle
    资源束包含区域特定的对象。
  • Classes in java.util used by java.util.prefs
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by java.util.spi
    Class 描述
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    Map
    将键映射到值的对象。
    Optional
    可能包含或不包含非 null值的容器对象。
    ResourceBundle
    资源束包含区域特定的对象。
    ResourceBundle.Control
    ResourceBundle.Control定义了在捆绑包加载过程中由 ResourceBundle.getBundle工厂方法调用的一组回调方法。
  • Classes in java.util used by java.util.stream
    Class 描述
    Collection
    集合层次结构中的根界面。
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    DoubleSummaryStatistics
    统计数据的收集状态，如count，min，max，sum和average。
    IntSummaryStatistics
    统计数据的收集状态，如count，min，max，sum和average。
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    LongSummaryStatistics
    统计数据的收集状态，如count，min，max，sum和average。
    Map
    将键映射到值的对象。
    Optional
    可能包含或不包含非 null值的容器对象。
    OptionalDouble
    可能含有或可能不包含 double值的容器对象。
    OptionalInt
    一个可能含有也可能不包含 int值的容器对象。
    OptionalLong
    可能包含或可能不包含 long值的容器对象。
    PrimitiveIterator.OfDouble
    一个专门为 double值的迭代器。
    PrimitiveIterator.OfInt
    一个专门针对 int值的迭代器。
    PrimitiveIterator.OfLong
    一个专门为 long值的迭代器。
    Set
    不包含重复元素的集合。
    Spliterator
    用于遍历和分割源的元素的对象。
    Spliterator.OfDouble
    一个专门为 double值的 double 。
    Spliterator.OfInt
    一个专门针对 int值的 int 。
    Spliterator.OfLong
    一个Spliterator专门为 long值。
  • Classes in java.util used by java.util.zip
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
  • Classes in java.util used by javafx.animation
    Class 描述
    Collection
    集合层次结构中的根界面。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.application
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javafx.beans.binding
    Class 描述
    Collection
    集合层次结构中的根界面。
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    ListIterator
    用于允许程序员沿任一方向遍历列表的列表的迭代器，在迭代期间修改列表，并获取列表中迭代器的当前位置。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.beans.property
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.beans.value
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.collections
    Class 描述
    AbstractCollection
    此类提供了 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractList
    该类提供List接口的骨架实现，以最小化实现由“随机存取”数据存储（如数组）支持的此接口所需的工作量。
    Collection
    集合层次结构中的根界面。
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Random
    该类的实例用于生成伪随机数的流。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.collections.transformation
    Class 描述
    AbstractCollection
    此类提供了 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractList
    该类提供List接口的骨架实现，以最小化实现由“随机访问”数据存储（如数组）支持的此接口所需的工作量。
    Collection
    集合层次结构中的根界面。
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.concurrent
    Class 描述
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by javafx.css
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.css.converter
    Class 描述
    Map
    将键映射到值的对象。
  • Classes in java.util used by javafx.event
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by javafx.fxml
    Class 描述
    LinkedList
    双链表实现了 List和 Deque接口。
    ResourceBundle
    资源束包含区域特定的对象。
  • Classes in java.util used by javafx.print
    Class 描述
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.scene
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.scene.chart
    Class 描述
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.scene.control
    Class 描述
    Collection
    集合层次结构中的根界面。
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    EventObject
    所有事件状态对象应从其派生的根类。
    List
    有序集合（也称为 序列 ）。
    Optional
    可能包含或不包含非 null值的容器对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.scene.control.cell
    Class 描述
    Map
    将键映射到值的对象。
  • Classes in java.util used by javafx.scene.control.skin
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.scene.image
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.scene.input
    Class 描述
    AbstractMap
    此类提供了 Map接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    EventObject
    所有事件状态对象应从其派生的根类。
    HashMap
    基于哈希表的实现的 Map接口。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javafx.scene.layout
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.scene.media
    Class 描述
    EventObject
    所有事件状态对象应从其派生的根类。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javafx.scene.paint
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.scene.shape
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.scene.text
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.scene.transform
    Class 描述
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by javafx.scene.web
    Class 描述
    Date
    Date类代表了一个特定的时间，以毫秒的精度。
    EventObject
    所有事件状态对象应从其派生的根类。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.stage
    Class 描述
    EventObject
    所有事件状态对象应从其派生的根类。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javafx.util.converter
    Class 描述
    Date
    Date类代表一个特定的时间，以毫秒的精度。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by javax.accessibility
    Class 描述
    ListResourceBundle
    ListResourceBundle是一个抽象类 ResourceBundle管理资源，以方便和易于使用的列表区域设置。
    Locale
    一个 Locale对象代表具体的地理，政治或文化区域。
    ResourceBundle
    资源束包含区域特定的对象。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.activation
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
  • Classes in java.util used by javax.annotation.processing
    Class 描述
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.imageio
    Class 描述
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化地区。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.imageio.event
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
  • Classes in java.util used by javax.imageio.metadata
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by javax.imageio.plugins.bmp
    Class 描述
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
  • Classes in java.util used by javax.imageio.plugins.jpeg
    Class 描述
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by javax.imageio.plugins.tiff
    Class 描述
    List
    有序集合（也称为 序列 ）。
    SortedSet
    A Set进一步提供其元素的总排序 。
  • Classes in java.util used by javax.imageio.spi
    Class 描述
    Iterator
    一个集合的迭代器。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by javax.lang.model
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javax.lang.model.element
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.lang.model.type
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javax.lang.model.util
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.management
    Class 描述
    AbstractCollection
    该类提供 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractList
    该类提供了List接口的骨架实现，以最小化实现由“随机存取”数据存储（如阵列）支持的此接口所需的工作量。
    ArrayList
    List接口的可调整大小的数组实现。
    Collection
    集合层次结构中的根界面。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    RandomAccess
    标记接口由 List实现使用，以表明它们支持快速（通常为恒定时间）随机访问。
    Set
    不包含重复元素的集合。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.management.loading
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.management.monitor
    Class 描述
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by javax.management.openmbean
    Class 描述
    Collection
    集合层次结构中的根界面。
    Date
    Date类代表了一个特定的时间，以毫秒的精度。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.management.relation
    Class 描述
    AbstractCollection
    此类提供了 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractList
    该类提供List接口的骨架实现，以最大限度地减少实现由“随机存取”数据存储（如数组）支持的接口所需的工作量。
    ArrayList
    List接口的可调整大小的数组实现。
    Collection
    集合层次结构中的根界面。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    RandomAccess
    标记接口由 List实现使用，以表明它们支持快速（通常为恒定时间）随机访问。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.management.remote
    Class 描述
    EventObject
    所有事件状态对象应从其派生的根类。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.management.remote.rmi
    Class 描述
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.management.timer
    Class 描述
    Date
    Date类代表一个特定的时间，毫秒精度。
    EventObject
    所有事件状态对象应从其派生的根类。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.naming
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    Properties
    Properties类表示一组持久的属性。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.naming.directory
    Class 描述
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.naming.event
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by javax.naming.ldap
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javax.naming.spi
    Class 描述
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
  • Classes in java.util used by javax.net.ssl
    Class 描述
    Collection
    集合层次结构中的根界面。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javax.print.attribute
    Class 描述
    Date
    Date类代表一个特定的时间，以毫秒的精度。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化区域。
  • Classes in java.util used by javax.print.attribute.standard
    Class 描述
    AbstractCollection
    该类提供了 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractMap
    该类提供 Map接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    AbstractSet
    此类提供了 Set接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
    Collection
    集合层次结构中的根界面。
    Date
    Date类代表一个特定的时间，以毫秒的精度。
    HashMap
    基于哈希表的实现的 Map接口。
    HashSet
    此类实现 Set接口，由哈希表（实际为 HashMap实例）支持。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.print.event
    Class 描述
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by javax.script
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.security.auth
    Class 描述
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.security.auth.callback
    Class 描述
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by javax.security.auth.kerberos
    Class 描述
    Date
    Date类代表一个特定的时间，以毫秒的精度。
  • Classes in java.util used by javax.security.auth.login
    Class 描述
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.security.auth.spi
    Class 描述
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.security.auth.x500
    Class 描述
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.security.cert
    Class 描述
    Date
    Date类代表了一个特定的时间，以毫秒的精度。
  • Classes in java.util used by javax.security.sasl
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.smartcardio
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javax.sound.midi
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.sound.sampled
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.sql
    Class 描述
    Calendar
    所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.sql.rowset
    Class 描述
    Calendar
    所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
    Collection
    集合层次结构中的根界面。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.sql.rowset.serial
    Class 描述
    Map
    将键映射到值的对象。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.sql.rowset.spi
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
  • Classes in java.util used by javax.swing
    Class 描述
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    Date
    Date类代表一个特定的时间，以毫秒的精度。
    Dictionary
    Dictionary类是任何类的抽象父类，例如 Hashtable ，它将键映射到值。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.swing.event
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
  • Classes in java.util used by javax.swing.plaf.basic
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.swing.plaf.metal
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
  • Classes in java.util used by javax.swing.plaf.multi
    Class 描述
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.swing.plaf.synth
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
  • Classes in java.util used by javax.swing.table
    Class 描述
    Comparator
    比较功能，对一些对象的集合施加了一个 整体排序 。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.swing.text
    Class 描述
    Dictionary
    Dictionary类是任何类的抽象父类，例如 Hashtable ，它将键映射到值。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.swing.text.html
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.swing.text.html.parser
    Class 描述
    BitSet
    该类实现了根据需要增长的位向量。
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.swing.tree
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    EventObject
    所有事件状态对象应从其派生的根类。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.swing.undo
    Class 描述
    EventListener
    所有事件侦听器接口必须扩展的标记接口。
    Hashtable
    该类实现了一个哈希表，它将键映射到值。
    Vector
    Vector类实现了可扩展的对象数组。
  • Classes in java.util used by javax.tools
    Class 描述
    Collection
    集合层次结构中的根界面。
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    ServiceLoader
    一种加载服务实现的工具。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.xml.bind
    Class 描述
    Calendar
    所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.xml.crypto
    Class 描述
    Iterator
    一个集合的迭代器。
  • Classes in java.util used by javax.xml.crypto.dom
    Class 描述
    Iterator
    一个集合的迭代器。
    Map.Entry
    地图条目（键值对）。
  • Classes in java.util used by javax.xml.crypto.dsig
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javax.xml.crypto.dsig.keyinfo
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javax.xml.crypto.dsig.spec
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.xml.datatype
    Class 描述
    Calendar
    所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
    Date
    Date类代表一个特定的时间，以毫秒的精度。
    GregorianCalendar
    GregorianCalendar是的具体子 Calendar ，并提供了世界上大多数国家使用的标准日历系统。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化地区。
    TimeZone
    TimeZone代表时区偏移量，也可以显示夏令时。
  • Classes in java.util used by javax.xml.namespace
    Class 描述
    Iterator
    一个集合的迭代器。
  • Classes in java.util used by javax.xml.soap
    Class 描述
    Iterator
    一个集合的迭代器。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by javax.xml.stream
    Class 描述
    Iterator
    一个集合的迭代器。
  • Classes in java.util used by javax.xml.stream.events
    Class 描述
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by javax.xml.stream.util
    Class 描述
    Iterator
    一个集合的迭代器。
  • Classes in java.util used by javax.xml.transform
    Class 描述
    Properties
    Properties类表示一组持久的属性。
  • Classes in java.util used by javax.xml.ws
    Class 描述
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.xml.ws.handler
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.xml.ws.handler.soap
    Class 描述
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.xml.ws.soap
    Class 描述
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.xml.ws.spi
    Class 描述
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by javax.xml.ws.spi.http
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by javax.xml.xpath
    Class 描述
    Iterator
    一个集合的迭代器。
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by jdk.dynalink
    Class 描述
    List
    有序集合（也称为 序列 ）。
    ServiceConfigurationError
    在查找，加载或实例化服务提供商时发生错误时发生错误。
  • Classes in java.util used by jdk.dynalink.beans
    Class 描述
    Set
    不包含重复元素的集合。
  • Classes in java.util used by jdk.dynalink.linker
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by jdk.dynalink.linker.support
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by jdk.incubator.http
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    Optional
    可能包含或不包含非 null值的容器对象。
    OptionalLong
    可能包含或可能不包含 long值的容器对象。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by jdk.javadoc.doclet
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by jdk.jshell
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    Map
    将键映射到值的对象。
  • Classes in java.util used by jdk.jshell.execution
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by jdk.jshell.spi
    Class 描述
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
  • Classes in java.util used by jdk.jshell.tool
    Class 描述
    Locale
    一个 Locale对象代表一个具体的地理，政治或文化地区。
    Map
    将键映射到值的对象。
  • Classes in java.util used by jdk.nashorn.api.scripting
    Class 描述
    Collection
    集合层次结构中的根界面。
    List
    有序集合（也称为 序列 ）。
    Map
    将键映射到值的对象。
    Map.Entry
    地图条目（键值对）。
    Set
    不包含重复元素的集合。
  • Classes in java.util used by jdk.nashorn.api.tree
    Class 描述
    List
    有序集合（也称为 序列 ）。
  • Classes in java.util used by jdk.net
    Class 描述
    Set
    不包含重复元素的集合。
  • Classes in java.util used by jdk.packager.services
    Class 描述
    Map
    将键映射到值的对象。
  • Classes in java.util used by org.omg.CORBA
    Class 描述
    Properties
    Properties类表示一组持久的属性。
  • Classes in java.util used by org.xml.sax
    Class 描述
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
  • Classes in java.util used by org.xml.sax.helpers
    Class 描述
    Enumeration
    实现枚举接口的对象生成一系列元素，一次一个。
    Locale
    一个 Locale对象代表一个特定的地理，政治或文化区域。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


UUID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class UUID

  • java.lang.Object
    • java.util.UUID
  • All Implemented Interfaces:
    Serializable ， Comparable<UUID>

    public final class UUID
extends Object
implements Serializable, Comparable<UUID>
    一个表示不可变的通用唯一标识符（UUID）的类。 UUID表示128位值。

    这些全局标识符存在不同的变体。 该类的方法是用于操纵Leach-Salz变体，尽管构造函数允许创建UUID的任何变体（如下所述）。

    变体2（Leach-Salz）UUID的布局如下：最重要的长度包括以下无符号字段：

      0xFFFFFFFF00000000 time_low
 0x00000000FFFF0000 time_mid
 0x000000000000F000 version
 0x0000000000000FFF time_hi
    最不重要的长度包括以下无符号字段：
      0xC000000000000000 variant
 0x3FFF000000000000 clock_seq
 0x0000FFFFFFFFFFFF node

    变量字段包含一个标识UUID的布局的UUID 。 上述位布局仅适用于变体值为2的UUID ，表示Leach-Salz变体。

    版本字段保存描述此UUID的类型的UUID 。 UUID有四种不同的基本类型：基于时间，DCE安全性，基于名称和随机生成的UUID。 这些类型的版本值分别为1，2，3和4。

    有关包括用于创建UUID s的算法的更多信息，请参阅RFC 4122: A Universally Unique IDentifier (UUID) URN Namespace第4.2节“创建基于时间的UUID的算法”。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UUID​(long mostSigBits, long leastSigBits)
      使用指定的数据构造一个新的 UUID 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int clockSequence​()
      与该UUID相关联的时钟序列值。
      int compareTo​(UUID val)
      将此UUID与指定的UUID进行比较。
      boolean equals​(Object obj)
      将此对象与指定的对象进行比较。
      static UUID fromString​(String name)
      创建 UUID如在所描述的字符串标准表示 toString()方法。
      long getLeastSignificantBits​()
      返回此UUID的128位值的最低有效64位。
      long getMostSignificantBits​()
      返回此UUID的128位值的最高64位。
      int hashCode​()
      返回此 UUID的哈希码。
      static UUID nameUUIDFromBytes​(byte[] name)
      静态工厂根据指定的字节数组检索类型3（基于名称） UUID 。
      long node​()
      与此UUID相关联的节点值。
      static UUID randomUUID​()
      静态工厂检索一个类型4（伪随机生成）的UUID。
      long timestamp​()
      与此UUID相关联的时间戳值。
      String toString​()
      返回一个表示 UUID的 String对象。
      int variant​()
      与此 UUID相关联的变式号。
      int version​()
      与此 UUID相关联的版本号。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UUID

        public UUID​(long mostSigBits,
            long leastSigBits)
        使用指定的数据构造一个新的UUID 。 mostSigBits用于最显著64位UUID和leastSigBits成为的至少显著64位UUID 。
        参数
        mostSigBits -的最显著位 UUID
        leastSigBits -的的最低显著位 UUID

    • 方法详细信息

      • randomUUID

        public static UUID randomUUID​()
        静态工厂检索一个类型4（伪随机生成）的UUID。 使用加密强伪随机数生成器生成UUID 。
        结果
        随机生成 UUID

      • nameUUIDFromBytes

        public static UUID nameUUIDFromBytes​(byte[] name)
        静态工厂根据指定的字节数组检索类型3（基于名称） UUID 。
        参数
        name - 用于构造 UUID字节数组
        结果
        A UUID从指定的数组生成

      • fromString

        public static UUID fromString​(String name)
        创建 UUID如在所描述的字符串标准表示 toString()方法。
        参数
        name - 一个指定 UUID字符串
        结果
        A UUID具有指定的值
        异常
        IllegalArgumentException - 如果名称不符合 toString()中描述的字符串表示 形式

      • getLeastSignificantBits

        public long getLeastSignificantBits​()
        返回此UUID的128位值的最低有效64位。
        结果
        该UUID的128位值的最低有效64位

      • getMostSignificantBits

        public long getMostSignificantBits​()
        返回此UUID的128位值的最高64位。
        结果
        这个UUID的128位值的最高64位

      • version

        public int version​()
        与此UUID相关联的版本号。 版本号描述了如何生成UUID 。 版本号具有以下含义：
        • 1个基于时间的UUID
        • 2 DCE安全UUID
        • 3基于名称的UUID
        • 4随机生成的UUID
        结果
        该版本号为 UUID

      • variant

        public int variant​()
        与此UUID相关联的变式号。 变式号码描述了UUID的布局。 变式号码具有以下含义：
        • 0保留用于NCS向后兼容
        • 2 IETF RFC 4122 （Leach-Salz），由这个类使用
        • 6保留，Microsoft Corporation向后兼容
        • 7保留供将来定义
        结果
        这个 UUID的变体号

      • timestamp

        public long timestamp​()
        与此UUID相关联的时间戳值。

        60位时间戳值由此UUID的time_low，time_mid和time_hi字段UUID 。 所产生的时间戳记是从1582年10月15日UTC 15分钟以100纳秒为单位测量的。

        时间戳记值仅在具有版本类型1的基于时间的UUID中有意义。如果此UUID不是基于时间的UUID，则此方法将引发UnsupportedOperationException。

        结果
        这个 UUID的时间戳。
        异常
        UnsupportedOperationException - 如果此UUID不是版本1 UUID

      • clockSequence

        public int clockSequence​()
        与该UUID相关联的时钟序列值。

        14位时钟序列值由该UUID的时钟序列字段构成。 时钟序列字段用于保证基于时间的UUID中的时间唯一性。

        clockSequence值仅在具有版本类型为1的基于时间的UUID中有意义。如果此UUID不是基于时间的UUID，则此方法将引发UnsupportedOperationException。

        结果
        这个 UUID的时钟顺序
        异常
        UnsupportedOperationException - 如果此UUID不是版本1 UUID

      • node

        public long node​()
        与此UUID相关联的节点值。

        48位节点值由该UUID的节点字段构成。 该字段旨在保存生成此UUID的机器的IEEE 802地址，以保证空间唯一性。

        节点值仅在具有版本类型1的基于时间的UUID中有意义。如果此UUID不是基于时间的UUID，则此方法将抛出UnsupportedOperationException。

        结果
        该值的 UUID的节点值
        异常
        UnsupportedOperationException - 如果此UUID不是版本1 UUID

      • toString

        public String toString​()
        返回一个表示UUID的String对象。

        UUID字符串表示形式由此BNF描述：

 UUID                   = <time_low> "-" <time_mid> "-"
                          <time_high_and_version> "-"
                          <variant_and_sequence> "-"
                          <node>
 time_low               = 4*<hexOctet>
 time_mid               = 2*<hexOctet>
 time_high_and_version  = 2*<hexOctet>
 variant_and_sequence   = 2*<hexOctet>
 node                   = 6*<hexOctet>
 hexOctet               = <hexDigit><hexDigit>
 hexDigit               =
       "0" | "1" | "2" | "3" | "4" | "5" | "6" | "7" | "8" | "9"
       | "a" | "b" | "c" | "d" | "e" | "f"
       | "A" | "B" | "C" | "D" | "E" | "F"
        重写：
        toString在 Object
        结果
        这个 UUID字符串表示 UUID

      • hashCode

        public int hashCode​()
        返回此 UUID的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 UUID哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将此对象与指定的对象进行比较。 结果是true如果且仅当参数不是null ，是一个UUID对象，具有相同的变体，并包含相同的值，位为位，因为这个UUID 。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        true如果对象是一样的; false否则
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(UUID val)
        将此UUID与指定的UUID进行比较。

        如果UUID不同的最重要字段对于第一个UUID而言较大，则两个UUID中的第一个大于第二个UUID。

        Specified by:
        compareTo在接口 Comparable<UUID>
        参数
        val - UUID要对这 UUID进行比较
        结果
        -1，0或1，因为这个 UUID小于，等于或大于 val
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Vector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class Vector<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • java.util.Vector<E>
  • 参数类型
    E - 组件元素的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， List<E> ， RandomAccess
    已知直接子类：
    Stack

    public class Vector<E>
extends AbstractList<E>
implements List<E>, RandomAccess, Cloneable, Serializable
    Vector类实现了可扩展的对象数组。 像数组一样，它包含可以使用整数索引访问的组件。 但是， Vector的大小可以根据需要增长或缩小，以适应在创建Vector之后添加和删除项目。

    每个向量尝试通过维护capacity和capacityIncrement来优化存储管理。 capacity总是至少与矢量大小一样大; 它通常较大，因为将组件添加到向量中，向量的存储以大小为大小增加capacityIncrement 。 应用程序可以在插入大量组件之前增加向量的容量; 这减少了增量重新分配的数量。

    由此类的iterator和listIterator方法返回的迭代器是故障快速的 ：如果向量在迭代器创建后的任何时间进行结构修改，除了通过迭代器自己的remove或add方法之外，迭代器将抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。 该Enumerations由返回elements方法不是快速失败的; 如果Vector在创建枚举之后的任何时间被结构化地修改，则枚举的结果是未定义的。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速的迭代器ConcurrentModificationException扔掉ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    从Java 2平台v1.2开始，该类改进了List接口，使其成为Java Collections Framework的成员。 与新的集合实现不同， Vector被同步。 如果不需要线程安全的实现，建议使用ArrayList代替Vector 。

    从以下版本开始：
    1.0
    另请参见：
    Collection ， LinkedList ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int capacityIncrement
      当矢量的大小大于其容量时，矢量的容量自动增加的量。
      protected int elementCount
      此 Vector对象中有效组件的数量。
      protected Object[] elementData
      存储向量的组件的阵列缓冲区。

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      构造方法
      Constructor 描述
      Vector​()
      构造一个空向量，使其内部数据数组的大小为 10 ，其标准容量增量为零。
      Vector​(int initialCapacity)
      构造具有指定初始容量并且其容量增量等于零的空向量。
      Vector​(int initialCapacity, int capacityIncrement)
      构造具有指定的初始容量和容量增量的空向量。
      Vector​(Collection<? extends E> c)
      构造一个包含指定集合元素的向量，按照集合的迭代器返回的顺序。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(int index, E element)
      在此Vector中的指定位置插入指定的元素。
      boolean add​(E e)
      将指定的元素追加到此Vector的末尾。
      boolean addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此向量中的指定位置。
      boolean addAll​(Collection<? extends E> c)
      将指定集合中的所有元素追加到该向量的末尾，按照它们由指定集合的迭代器返回的顺序。
      void addElement​(E obj)
      将指定的组件添加到此向量的末尾，将其大小增加1。
      int capacity​()
      返回此向量的当前容量。
      void clear​()
      从此Vector中删除所有元素。
      Object clone​()
      返回此向量的克隆。
      boolean contains​(Object o)
      如果此向量包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> c)
      如果此向量包含指定集合中的所有元素，则返回true。
      void copyInto​(Object[] anArray)
      将此向量的组件复制到指定的数组中。
      E elementAt​(int index)
      返回指定索引处的组件。
      Enumeration<E> elements​()
      返回此向量的组件的枚举。
      void ensureCapacity​(int minCapacity)
      如果需要，增加此向量的容量，以确保它可以至少保存最小容量参数指定的组件数。
      boolean equals​(Object o)
      将指定的对象与此向量进行比较以获得相等性。
      E firstElement​()
      返回此向量的第一个组件（索引号为 0的项目）。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。
      E get​(int index)
      返回此向量中指定位置的元素。
      int hashCode​()
      返回此Vector的哈希码值。
      int indexOf​(Object o)
      返回此向量中指定元素的第一次出现的索引，如果此向量不包含元素，则返回-1。
      int indexOf​(Object o, int index)
      返回此向量中指定元素的第一次出现的索引，从 index搜索，如果未找到该元素，则返回-1。
      void insertElementAt​(E obj, int index)
      在指定的 index插入指定对象作为该向量中的一个组件。
      boolean isEmpty​()
      测试此矢量是否没有组件。
      Iterator<E> iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      E lastElement​()
      返回向量的最后一个组件。
      int lastIndexOf​(Object o)
      返回此向量中指定元素的最后一次出现的索引，如果此向量不包含元素，则返回-1。
      int lastIndexOf​(Object o, int index)
      返回此向量中指定元素的最后一次出现的索引，从 index向后搜索，如果未找到元素，则返回-1。
      ListIterator<E> listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
      E remove​(int index)
      删除此向量中指定位置的元素。
      boolean remove​(Object o)
      删除此向量中指定元素的第一个出现如果Vector不包含元素，则它不会更改。
      boolean removeAll​(Collection<?> c)
      从此Vector中删除指定集合中包含的所有元素。
      void removeAllElements​()
      从该向量中删除所有组件，并将其大小设置为零。
      boolean removeElement​(Object obj)
      从此向量中删除参数的第一个（最低索引）出现次数。
      void removeElementAt​(int index)
      删除指定索引处的组件。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      protected void removeRange​(int fromIndex, int toIndex)
      从此列表中删除所有索引为 fromIndex （含）和 toIndex之间的元素。
      void replaceAll​(UnaryOperator<E> operator)
      将该列表的每个元素替换为将该运算符应用于该元素的结果。
      boolean retainAll​(Collection<?> c)
      仅保留此向量中包含在指定集合中的元素。
      E set​(int index, E element)
      用指定的元素替换此Vector中指定位置的元素。
      void setElementAt​(E obj, int index)
      将此向量的指定 index中的组件设置为指定的对象。
      void setSize​(int newSize)
      设置此向量的大小。
      int size​()
      返回此向量中的组件数。
      void sort​(Comparator<? super E> c)
      根据指定的Comparator引发的顺序排列此列表。
      Spliterator<E> spliterator​()
      在此列表中的元素上创建late-binding和故障快速 Spliterator 。
      List<E> subList​(int fromIndex, int toIndex)
      返回此列表之间的fromIndex（包括）和toIndex之间的独占视图。
      Object[] toArray​()
      以正确的顺序返回一个包含此Vector中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以正确的顺序返回一个包含此Vector中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此Vector的字符串表示形式，其中包含每个元素的String表示形式。
      void trimToSize​()
      修改该向量的容量成为向量的当前大小。

      • Methods inherited from interface java.util.Collection

        parallelStream, stream

      • Methods inherited from interface java.util.List

        of, of, of, of, of, of, of, of, of, of, of, of

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • elementData

        protected Object[] elementData
        存储向量的组件的阵列缓冲区。 向量的容量是此数组缓冲区的长度，并且至少足够大以包含所有向量的元素。

        Vector中最后一个元素后面的任何数组元素都为空。

      • elementCount

        protected int elementCount
        此Vector对象中有效组件的数量。 组件elementData[0]至elementData[elementCount-1]是实际项目。

      • capacityIncrement

        protected int capacityIncrement
        当矢量的大小大于其容量时，矢量的容量自动增加的量。 如果容量增量小于或等于零，则每次需要增长时，向量的容量将加倍。

    • 构造方法详细信息

      • Vector

        public Vector​(int initialCapacity,
              int capacityIncrement)
        构造具有指定的初始容量和容量增量的空向量。
        参数
        initialCapacity - 矢量的初始容量
        capacityIncrement - 当向量溢出时容量增加的量
        异常
        IllegalArgumentException - 如果指定的初始容量为负

      • Vector

        public Vector​(int initialCapacity)
        构造具有指定初始容量并且其容量增量等于零的空向量。
        参数
        initialCapacity - 矢量的初始容量
        异常
        IllegalArgumentException - 如果指定的初始容量为负

      • Vector

        public Vector​()
        构造一个空向量，使其内部数据数组的大小为 10 ，其标准容量增量为零。

      • Vector

        public Vector​(Collection<? extends E> c)
        构造一个包含指定集合元素的向量，按照集合的迭代器返回的顺序。
        参数
        c - c元素放入此向量的集合
        异常
        NullPointerException - 如果指定的集合为空
        从以下版本开始：
        1.2

    • 方法详细信息

      • copyInto

        public void copyInto​(Object[] anArray)
        将此向量的组件复制到指定的数组中。 在索引项k该向量被复制到部件k的anArray 。
        参数
        anArray - 组件被复制到的阵列
        异常
        NullPointerException - 如果给定的数组为空
        IndexOutOfBoundsException - 如果指定的数组不够大以容纳此向量的所有组件
        ArrayStoreException - 如果此向量的组件不是可以存储在指定数组中的运行时类型
        另请参见：
        toArray(Object[])

      • trimToSize

        public void trimToSize​()
        修改该向量的容量成为向量的当前大小。 如果该向量的容量大于其当前大小，则通过用保留在字段elementData的较小的内部数据阵列替换其内部数据阵列，将容量更改为等于大小。 应用程序可以使用此操作来最小化向量的存储。

      • ensureCapacity

        public void ensureCapacity​(int minCapacity)
        如果需要，增加此向量的容量，以确保它可以至少保存最小容量参数指定的组件数。

        如果该向量的当前容量小于minCapacity ，则通过将其内部数据阵列替换为elementData的较大的数据阵列来增加其容量。 新的数据阵列的大小将是原来的大小加上capacityIncrement ，除非的值capacityIncrement小于或等于零，在这种情况下，新的容量将是原来容量的两倍; 但是如果这个新的大小仍然小于minCapacity ，那么新的容量将是minCapacity 。

        参数
        minCapacity - 所需的最小容量

      • setSize

        public void setSize​(int newSize)
        设置此向量的大小。 如果新尺寸大于当前大小，则新的null项目将添加到向量的末尾。 如果新大小小于当前大小， newSize丢弃索引为newSize及更高版本的所有组件。
        参数
        newSize - 这个矢量的新的大小
        异常
        ArrayIndexOutOfBoundsException - 如果新大小为负数

      • capacity

        public int capacity​()
        返回此向量的当前容量。
        结果
        当前容量（其内部数据数组的长度，保存在该向量的字段 elementData中）

      • size

        public int size​()
        返回此向量中的组件数。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 List<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        该向量中的组件数量

      • isEmpty

        public boolean isEmpty​()
        测试此矢量是否没有组件。
        Specified by:
        isEmpty在接口 Collection<E>
        Specified by:
        isEmpty在接口 List<E>
        重写：
        isEmpty在 AbstractCollection<E>
        结果
        true当且仅当此向量没有组件时，即其大小为零; 否则为false 。

      • elements

        public Enumeration<E> elements​()
        返回此向量的组件的枚举。 返回的Enumeration对象将生成此向量中的所有项。 生成的第一个项目是索引号为0的项目，然后是索引号为1的项目，等等。 如果向量在枚举过程中被结构化地修改，则枚举的结果是未定义的。
        结果
        这个向量的组件的枚举
        另请参见：
        Iterator

      • contains

        public boolean contains​(Object o)
        true 更正式地，返回true当且仅当此向量包含至少一个元素e使得Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains List<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要在此矢量中存在的元素将被测试
        结果
        true如果此向量包含指定的元素

      • indexOf

        public int indexOf​(Object o)
        返回此向量中指定元素的第一次出现的索引，如果此向量不包含元素，则返回-1。 更正式地，返回最低指数i ，使得Objects.equals(o, get(i)) ，或-1如果没有这样的索引。
        Specified by:
        indexOf在接口 List<E>
        重写：
        indexOf在 AbstractList<E>
        参数
        o - 要搜索的元素
        结果
        该向量中指定元素的第一次出现的索引，如果此向量不包含元素，则为-1

      • indexOf

        public int indexOf​(Object o,
                   int index)
        返回此向量中指定元素的第一次出现的索引，从index向前搜索，如果未找到该元素，则返回-1。 更正式地，返回最低指数i ，使得(i >= index && Objects.equals(o, get(i))) ，或-1如果没有这样的索引。
        参数
        o - 要搜索的元素
        index - 开始搜索的索引
        结果
        该向量中元素第一次出现的位置在位置index或更高的向量中的索引; -1如果没有找到该元素。
        异常
        IndexOutOfBoundsException - 如果指定的索引为负数
        另请参见：
        Object.equals(Object)

      • lastIndexOf

        public int lastIndexOf​(Object o)
        返回此向量中指定元素的最后一次出现的索引，如果此向量不包含元素，则返回-1。 更正式地说，返回满足i这样Objects.equals(o, get(i)) ，或-1，如果没有这样的指标。
        Specified by:
        lastIndexOf在接口 List<E>
        重写：
        lastIndexOf在 AbstractList<E>
        参数
        o - 要搜索的元素
        结果
        该向量中指定元素的最后一次出现的索引，如果此向量不包含元素，则为-1

      • lastIndexOf

        public int lastIndexOf​(Object o,
                       int index)
        返回此向量中指定元素的最后一次出现的索引，从index向后搜索，如果未找到该元素，则返回-1。 更正式地，返回最高指数i ，使(i <= index && Objects.equals(o, get(i))) ，或-1如果没有这样的索引。
        参数
        o - 要搜索的元素
        index - 开始向后搜索的索引
        结果
        该向量中位置小于或等于index的元素的最后一次出现的索引; -1如果没有找到元素。
        异常
        IndexOutOfBoundsException - 如果指定的索引大于或等于此向量的当前大小

      • elementAt

        public E elementAt​(int index)
        返回指定索引处的组件。

        该方法在功能上与get(int)方法相同（这是List接口的一部分）。

        参数
        index - 这个向量的索引
        结果
        指定索引处的组件
        异常
        ArrayIndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • firstElement

        public E firstElement​()
        返回此向量的第一个组件（索引号为 0的项目）。
        结果
        这个向量的第一个组件
        异常
        NoSuchElementException - 如果此向量没有组件

      • lastElement

        public E lastElement​()
        返回向量的最后一个组件。
        结果
        向量的最后一个分量，即索引为 size() - 1的分量
        异常
        NoSuchElementException - 如果此向量为空

      • setElementAt

        public void setElementAt​(E obj,
                         int index)
        将此向量的指定的index中的组件设置为指定的对象。 该位置的上一个组件被丢弃。

        索引必须大于或等于0 ，小于当前的向量大小。

        该方法的功能与set(int, E)方法相同（这是List接口的一部分）。 请注意， set方法会反转参数的顺序，以更紧密地匹配阵列使用。 还要注意， set方法返回存储在指定位置的旧值。

        参数
        obj - 要设置的组件
        index - 指定的索引
        异常
        ArrayIndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • removeElementAt

        public void removeElementAt​(int index)
        删除指定索引处的组件。 具有大于或等于指定的index的索引的该向量中的每个组件向下移动以使索引小于先前的值。 该向量的大小减少1 。

        索引必须大于或等于0并小于当前的向量大小。

        该方法在功能上与remove(int)方法相同（这是List接口的一部分）。 请注意， remove方法返回存储在指定位置的旧值。

        参数
        index - 要删除的对象的索引
        异常
        ArrayIndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • insertElementAt

        public void insertElementAt​(E obj,
                            int index)
        在指定的index插入指定对象作为此向量中的index 。 该向量中具有大于或等于指定值index的索引中的每个组件向上移动以使索引大于先前的值。

        索引必须大于或等于0 ，小于或等于向量的当前大小。 （如果索引等于向量的当前大小，则新元素将附加到向量。）

        该方法的功能与add(int, E)方法相同（这是List接口的一部分）。 请注意， add方法会反转参数的顺序，以更紧密地匹配阵列使用。

        参数
        obj - 要插入的组件
        index - 在哪里插入新组件
        异常
        ArrayIndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • addElement

        public void addElement​(E obj)
        将指定的组件添加到此向量的末尾，将其大小增加1。 如果该载体的大小大于其容量，则该载体的容量增加。

        该方法在功能上与add(E)方法相同（这是List接口的一部分）。

        参数
        obj - 要添加的组件

      • removeElement

        public boolean removeElement​(Object obj)
        从此向量中删除参数的第一个（最低索引）出现次数。 如果在该向量中找到对象，则向量中具有大于或等于对象索引的索引的向量中的每个组件向下移动，以使索引小于之前的值。

        该方法在功能上与remove(Object)方法相同（这是List接口的一部分）。

        参数
        obj - 要删除的组件
        结果
        true如果参数是此向量的一个组件; false另外。

      • removeAllElements

        public void removeAllElements​()
        从该向量中删除所有组件，并将其大小设置为零。

        该方法的功能与clear()方法相同（这是List接口的一部分）。

      • clone

        public Object clone​()
        返回此向量的克隆。 该副本将包含对内部数据数组的克隆的引用，而不是对该Vector对象的原始内部数据数组的Vector 。
        重写：
        clone在 Object
        结果
        这个载体的克隆
        另请参见：
        Cloneable

      • toArray

        public Object[] toArray​()
        以正确的顺序返回一个包含此Vector中所有元素的数组。
        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 List<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此集合中所有元素的数组
        从以下版本开始：
        1.2
        另请参见：
        Arrays.asList(Object[])

      • toArray

        public <T> T[] toArray​(T[] a)
        以正确的顺序返回一个包含此Vector中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果Vector适合指定的数组，则返回其中。 否则，将使用指定数组的运行时类型和此Vector的大小分配一个新数组。

        如果向量适合指定的数组，其余空间（即，该数组具有比Vector更多的元素），则紧接在Vector结束之后的数组中的元素将设置为null。 （ 仅当调用者知道Vector不包含任何空元素时，这才有助于确定Vector的长度。）

        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 List<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 数组元素的类型。 与<E>相同或超类型<E> 。
        参数
        a - 要存储Vector的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含Vector元素的数组
        异常
        ArrayStoreException - 如果a， <T>的运行时类型 <E>此向量中每个元素的运行时类型的超类型（ <E>
        NullPointerException - 如果给定的数组为空
        从以下版本开始：
        1.2

      • get

        public E get​(int index)
        返回此向量中指定位置的元素。
        Specified by:
        get在接口 List<E>
        Specified by:
        get在 AbstractList<E>
        参数
        index - 要返回的元素的索引
        结果
        对象在指定的索引
        异常
        ArrayIndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）
        从以下版本开始：
        1.2

      • set

        public E set​(int index,
             E element)
        用指定的元素替换此Vector中指定位置的元素。
        Specified by:
        set在接口 List<E>
        重写：
        set在 AbstractList<E>
        参数
        index - 要替换的元素的索引
        element - 要存储在指定位置的元素
        结果
        该元素以前在指定的位置
        异常
        ArrayIndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）
        从以下版本开始：
        1.2

      • add

        public boolean add​(E e)
        将指定的元素追加到此Vector的末尾。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 List<E>
        重写：
        add在 AbstractList<E>
        参数
        e - 要附加到此向量的元素
        结果
        true （由 Collection.add(E)指定）
        从以下版本开始：
        1.2

      • remove

        public boolean remove​(Object o)
        删除此向量中指定元素的第一个出现如果Vector不包含元素，则它不会更改。 更正式地，删除具有最低索引i的元素，使得Objects.equals(o, get(i)) （如果这样的元素存在）。
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 List<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此Vector中删除的元素（如果存在）
        结果
        如果Vector包含指定的元素，则为true
        从以下版本开始：
        1.2

      • add

        public void add​(int index,
                E element)
        在此Vector中的指定位置插入指定的元素。 将当前位于该位置的元素（如果有）和任何后续元素（向其索引添加一个）移动。
        Specified by:
        add在接口 List<E>
        重写：
        add在 AbstractList<E>
        参数
        index - 要在其中插入指定元素的索引
        element - 要插入的元素
        异常
        ArrayIndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）
        从以下版本开始：
        1.2

      • remove

        public E remove​(int index)
        删除此向量中指定位置的元素。 将任何后续元素移动到左侧（从其索引中减去一个元素）。 返回从Vector中删除的元素。
        Specified by:
        remove在接口 List<E>
        重写：
        remove在 AbstractList<E>
        参数
        index - 要删除的元素的索引
        结果
        元素被删除
        异常
        ArrayIndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）
        从以下版本开始：
        1.2

      • clear

        public void clear​()
        从此Vector中删除所有元素。 此调用返回后，Vector将为空（除非引发异常）。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 List<E>
        重写：
        clear在 AbstractList<E>
        从以下版本开始：
        1.2

      • containsAll

        public boolean containsAll​(Collection<?> c)
        如果此向量包含指定集合中的所有元素，则返回true。
        Specified by:
        containsAll在接口 Collection<E>
        Specified by:
        containsAll在接口 List<E>
        重写：
        containsAll在 AbstractCollection<E>
        参数
        c - 一个集合，其元素将在此Vector中进行遏制测试
        结果
        如果此向量包含指定集合中的所有元素，则为true
        异常
        NullPointerException - 如果指定的集合为空
        另请参见：
        AbstractCollection.contains(Object)

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        将指定集合中的所有元素追加到该向量的末尾，按照它们由指定集合的迭代器返回的顺序。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （这意味着如果指定的集合是此Vector，则此调用的行为是未定义的，并且此向量是非空的。）
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 List<E>
        重写：
        addAll在 AbstractCollection<E>
        参数
        c - 要插入此向量的元素
        结果
        true如果此向量由于调用而更改
        异常
        NullPointerException - 如果指定的集合为空
        从以下版本开始：
        1.2
        另请参见：
        AbstractCollection.add(Object)

      • removeAll

        public boolean removeAll​(Collection<?> c)
        从此Vector中删除指定集合中包含的所有元素。
        Specified by:
        removeAll在接口 Collection<E>
        Specified by:
        removeAll在接口 List<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 要从Vector中删除的元素的集合
        结果
        如果此向量由于调用而更改，则为true
        异常
        ClassCastException - 如果此向量中的一个或多个元素的类型与指定集合不兼容（ optional ）
        NullPointerException - 如果此向量包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者如果指定的集合为空
        从以下版本开始：
        1.2
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        仅保留此向量中包含在指定集合中的元素。 换句话说，从此Vector中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        Specified by:
        retainAll在接口 List<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 要保留在此向量中的所有元素的集合（所有其他元素都将被删除）
        结果
        如果此向量由于调用而更改，则为true
        异常
        ClassCastException - 如果此向量中的一个或多个元素的类型与指定的集合不兼容（ optional ）
        NullPointerException - 如果此向量包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者如果指定的集合为空
        从以下版本开始：
        1.2
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        描述从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 为要删除的元素返回 true的谓词
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • addAll

        public boolean addAll​(int index,
                      Collection<? extends E> c)
        将指定集合中的所有元素插入到此向量中的指定位置。 将当前位于该位置（如果有的话）的元素和随后的任何元素移动到右边（增加其索引）。 新元素将按照它们由指定的集合的迭代器返回的顺序显示在Vector中。
        Specified by:
        addAll在接口 List<E>
        重写：
        addAll中的 AbstractList<E>
        参数
        index - 从中指定集合插入第一个元素的索引
        c - 要插入此向量的元素
        结果
        true如果此向量由于调用而更改
        异常
        ArrayIndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）
        NullPointerException - 如果指定的集合为空
        从以下版本开始：
        1.2

      • equals

        public boolean equals​(Object o)
        将指定的对象与此向量进行比较以获得相等性。 如果且仅当指定的对象也是列表时，则返回true，两个列表的大小相同，并且两个列表中所有相应的元素对相等 。 （两个元件e1和e2是如果等于 Objects.equals(e1, e2) 。）换句话说，两个列表被定义为等于如果它们包含以相同的顺序相同的元件。
        Specified by:
        equals在接口 Collection<E>
        Specified by:
        equals在接口 List<E>
        重写：
        equals在 AbstractList<E>
        参数
        o - 要与此向量相等的对象进行比较
        结果
        如果指定的Object等于此Vector，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此Vector的哈希码值。
        Specified by:
        hashCode在接口 Collection<E>
        Specified by:
        hashCode在接口 List<E>
        重写：
        hashCode在 AbstractList<E>
        结果
        该列表的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此Vector的字符串表示形式，其中包含每个元素的String表示形式。
        重写：
        toString在 AbstractCollection<E>
        结果
        此集合的字符串表示形式

      • subList

        public List<E> subList​(int fromIndex,
                       int toIndex)
        返回此列表之间的fromIndex（包括）和toIndex之间的独占视图。 （如果fromIndex和toIndex相等，则返回的列表为空。）返回的列表由此列表支持，因此返回的列表中的更改将反映在此列表中，反之亦然。 返回的列表支持此列表支持的所有可选列表操作。

        该方法消除了对显式范围操作（对于数组通常存在的排序）的需要。 任何期望列表的操作都可以通过在子列表视图而不是整个列表中进行操作来用作范围操作。 例如，以下成语从列表中移除了一系列元素：

          list.subList(from, to).clear();
        可以为indexOf和lastIndexOf构造类似的成语，并且Collections类中的所有算法都可以应用于子列表。

        如果支持列表（即，此列表）以除了通过返回的列表之外的任何方式进行结构修改 ，则此方法返回的列表的语义将变得未定义。 （结构修改是那些改变List的大小，或以其他方式扰乱它，使得正在进行的迭代可能产生不正确的结果）。

        Specified by:
        subList在接口 List<E>
        重写：
        subList在 AbstractList<E>
        参数
        fromIndex - 子列表的低端点（含）
        toIndex - 子列表的高端点（排他）
        结果
        该列表中指定范围的视图
        异常
        IndexOutOfBoundsException - 如果端点索引值超出范围 (fromIndex < 0 || toIndex > size)
        IllegalArgumentException - 如果端点索引不正确 (fromIndex > toIndex)

      • removeRange

        protected void removeRange​(int fromIndex,
                           int toIndex)
        从此列表中删除索引在fromIndex （含）和toIndex之间的所有元素，排他。 将任何后续元素移动到左侧（减少其索引）。 此通话将(toIndex - fromIndex)元素的列表。 （如果是toIndex==fromIndex ，这个操作没有效果）
        重写：
        removeRange在 AbstractList<E>
        参数
        fromIndex - 要删除的第一个元素的索引
        toIndex - 要删除的最后一个元素后的索引

      • listIterator

        public ListIterator<E> listIterator​(int index)
        从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。 指定的索引表示初始调用next将返回的第一个元素。 初始调用previous将返回指定索引减1的元素。

        返回的列表迭代器是fail-fast 。

        Specified by:
        listIterator在接口 List<E>
        重写：
        listIterator在 AbstractList<E>
        参数
        index - 要从列表迭代器返回的第一个元素的索引（通过调用 next ）
        结果
        在列表中的元素（按正确顺序）的列表迭代器，从列表中的指定位置开始
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • listIterator

        public ListIterator<E> listIterator​()
        返回列表中的列表迭代器（按适当的顺序）。

        返回的列表迭代器是fail-fast 。

        Specified by:
        listIterator在接口 List<E>
        重写：
        listIterator在 AbstractList<E>
        结果
        在列表中的元素的列表迭代器（按适当的顺序）
        另请参见：
        listIterator(int)

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回该列表中的元素的迭代器。

        返回的迭代器是fail-fast 。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 List<E>
        重写：
        iterator在 AbstractList<E>
        结果
        在这个列表中的元素以适当的顺序迭代

      • forEach

        public void forEach​(Consumer<? super E> action)
        说明从界面Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空

      • replaceAll

        public void replaceAll​(UnaryOperator<E> operator)
        说明从接口List复制
        将该列表的每个元素替换为将该运算符应用于该元素的结果。 运营商抛出的错误或运行时异常被转发给呼叫者。
        Specified by:
        replaceAll在接口 List<E>
        参数
        operator - 操作员应用于每个元素
        异常
        NullPointerException - 如果指定的运算符为空，或者运算符结果为空值，并且该列表不允许空值元素（ optional ）

      • sort

        public void sort​(Comparator<? super E> c)
        说明从接口List复制
        根据指定的Comparator引发的顺序排列此列表。

        该列表中的所有元素必须使用指定的比较器相互比较（即， c.compare(e1, e2)不得为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        如果指定的比较器是null则该列表中的所有元素都必须实现Comparable接口，并且应使用元素' natural ordering '。

        该列表必须是可修改的，但不能调整大小。

        Specified by:
        sort在接口 List<E>
        参数
        c - Comparator用于比较列表元素。 A null值表示应使用元素' natural ordering '

      • spliterator

        public Spliterator<E> spliterator​()
        在此列表中的元素上创建late-binding和故障快速 Spliterator 。

        该Spliterator报告Spliterator.SIZED ， Spliterator.SUBSIZED ，并Spliterator.ORDERED 。 覆盖实现应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Specified by:
        spliterator在接口 List<E>
        结果
        一个 Spliterator在这个列表中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


WeakHashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util

Class WeakHashMap<K,V>

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.WeakHashMap<K,V>
  • 参数类型
    K - 由该地图维护的键的类型
    V - 映射值的类型
    All Implemented Interfaces:
    Map<K,V>

    public class WeakHashMap<K,V>
extends AbstractMap<K,V>
implements Map<K,V>
    基于哈希表的实现的Map接口，具有弱键 。 WeakHashMap的条目在其键不再被普通使用时将自动删除。 更准确地说，给定密钥的映射的存在将不会阻止该密钥被垃圾收集器丢弃，也就是可以最终确定，最终确定，然后被回收。 当一个密钥被丢弃时，它的条目被有效地从地图上移除，所以这个类的行为与其他Map实现有些不同。

    支持null值和空值。 该类具有与HashMap类相似的性能特征，具有初始容量和负载因子的相同效率参数。

    像大多数集合类一样，此类不同步。 甲同步WeakHashMap可使用被构造Collections.synchronizedMap方法。

    此类主要用于equals方法使用==操作符测试对象标识的关键对象。 一旦这样的密钥被丢弃，它就永远不会被重新创建，所以在稍后的一个WeakHashMap中查找该密钥是不可能的，并且惊讶的是它的条目被删除了。 该类将非常适用于其中equals方法不基于对象标识的关键对象，例如String实例。 但是，对于这些可重用的关键对象，自动删除已被丢弃密钥的WeakHashMap条目可能会令人困惑。

    WeakHashMap类的行为部分取决于垃圾收集器的操作，因此几个熟悉的（虽然不是必需的） Map不变量不适用于此类。 因为垃圾收集器可能随时丢弃密钥，所以WeakHashMap可能会表现为未知线程静默地删除条目。 特别是，即使您在一个WeakHashMap实例上进行同步，也没有调用其变异器方法， size方法可以随时间返回较小的值，因为isEmpty方法返回false然后返回true ，为containsKey方法返回true及以后的false对于给定的密钥，对于get方法返回给定密钥的值，但稍后返回null ，为put方法返回null和remove方法，以返回false以前似乎在地图，以及密钥集的连续检查，值集合和条目集合，以产生相继较少数量的元素。

    WeakHashMap每个关键对象间接存储为弱引用的指示。 因此，只有在地图的内部和外部的弱引用之后，密钥才会被垃圾收集器清除。

    实现注释： WeakHashMap中的值对象由普通强引用保存。 因此，应注意确保值对象不直接或间接强烈地引用其自己的键，因为这将阻止键被丢弃。 注意，值对象可以通过WeakHashMap本身间接地引用其键; 也就是说，值对象可能强烈地引用一些其他关键对象，其关联值对象又强烈地引用第一个值对象的键。 如果地图中的值不依赖于强调引用它们的地图，那么处理这种情况的一种方法是在插入之前将值本身包含在WeakReferences ，如： m.put(key, new WeakReference(value)) ，然后在每个get展开。

    由所有这个类的“集合视图方法”返回的集合的iterator方法返回的迭代器是故障快速的 ：如果映射在迭代器创建之后的任何时间被结构地修改，除了通过迭代器自己的remove方法，迭代器会抛出一个ConcurrentModificationException 。 因此，面对并发修改，迭代器将快速而干净地失败，而不是在未来未确定的时间冒着任意的非确定性行为。

    请注意，迭代器的故障快速行为无法保证，因为一般来说，在不同步并发修改的情况下，无法做出任何硬性保证。 失败快速迭代器ConcurrentModificationException扔掉ConcurrentModificationException 。 因此，编写依赖于此异常的程序的正确性将是错误的： 迭代器的故障快速行为应仅用于检测错误。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    HashMap ， WeakReference

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      WeakHashMap​()
      构造一个新的，空的 WeakHashMap ，默认初始容量（16）和负载因子（0.75）。
      WeakHashMap​(int initialCapacity)
      构造一个新的，空的 WeakHashMap具有给定的初始容量和默认负载因子（0.75）。
      WeakHashMap​(int initialCapacity, float loadFactor)
      构造一个新的，空的 WeakHashMap具有给定的初始容量和给定的负载因子。
      WeakHashMap​(Map<? extends K,? extends V> m)
      构造新的 WeakHashMap与指定的地图相同的映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      从这张地图中删除所有的映射。
      boolean containsKey​(Object key)
      如果此映射包含指定键的映射，则返回 true 。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。
      boolean isEmpty​()
      如果此映射不包含键值映射，则返回 true 。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      V put​(K key, V value)
      将指定的值与此映射中的指定键相关联。
      void putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此地图。
      V remove​(Object key)
      如果存在，则从该弱散列映射中删除密钥的映射。
      void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      int size​()
      返回此地图中键值映射的数量。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from class java.util.AbstractMap

        clone, equals, hashCode, toString

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, equals, getOrDefault, hashCode, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • WeakHashMap

        public WeakHashMap​(int initialCapacity,
                   float loadFactor)
        构造一个新的，空的 WeakHashMap具有给定的初始容量和给定的负载因子。
        参数
        initialCapacity - 初始容量为 WeakHashMap
        loadFactor -在所述的负载因数 WeakHashMap
        异常
        IllegalArgumentException - 如果初始容量为负值，或负载因子为非正值。

      • WeakHashMap

        public WeakHashMap​(int initialCapacity)
        构造一个新的，空的 WeakHashMap具有给定的初始容量和默认负载因子（0.75）。
        参数
        initialCapacity - 初始容量为 WeakHashMap
        异常
        IllegalArgumentException - 如果初始容量为负

      • WeakHashMap

        public WeakHashMap​()
        构造一个新的，空的 WeakHashMap ，默认的初始容量（16）和负载因子（0.75）。

      • WeakHashMap

        public WeakHashMap​(Map<? extends K,? extends V> m)
        构造新的WeakHashMap与指定的映射相同的映射。 WeakHashMap创建具有默认负载因子（0.75），初始容量足以容纳指定映射中的映射。
        参数
        m - 其映射将放置在此映射中的映射
        异常
        NullPointerException - 如果指定的地图为空
        从以下版本开始：
        1.3

    • 方法详细信息

      • size

        public int size​()
        返回此地图中键值映射的数量。 此结果是一个快照，并且可能不反映在下次尝试访问之前将被删除的未处理条目，因为它们不再被引用。
        Specified by:
        size在接口 Map<K,V>
        重写：
        size在 AbstractMap<K,V>
        结果
        该地图中键值映射的数量

      • isEmpty

        public boolean isEmpty​()
        如果此映射不包含键值映射，则返回true 。 此结果是一个快照，并且可能不反映在下次尝试访问之前将被删除的未处理条目，因为它们不再被引用。
        Specified by:
        isEmpty在接口 Map<K,V>
        重写：
        isEmpty在 AbstractMap<K,V>
        结果
        true如果此映射不包含键值映射

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含键的映射，则返回null 。

        更正式地，如果此映射包含从密钥映射k到值v使得Objects.equals(key, k) ，则此方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        返回值为null并不一定表示该映射不包含该键的映射; 地图也可能显式地将密钥映射到null 。 可以使用containsKey操作来区分这两种情况。

        Specified by:
        get在接口 Map<K,V>
        重写：
        get在 AbstractMap<K,V>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含键的映射， null
        另请参见：
        put(Object, Object)

      • containsKey

        public boolean containsKey​(Object key)
        如果此映射包含指定键的映射，则返回 true 。
        Specified by:
        containsKey在接口 Map<K,V>
        重写：
        containsKey在 AbstractMap<K,V>
        参数
        key - 要在此地图中存在的密钥要进行测试
        结果
        true如果有一个key的映射; 否则为false

      • put

        public V put​(K key,
             V value)
        将指定的值与此映射中的指定键相关联。 如果地图先前包含该键的映射，则替换旧值。
        Specified by:
        put在接口 Map<K,V>
        重写：
        put在 AbstractMap<K,V>
        参数
        key - 要与其关联的指定值的键。
        value - 与指定键相关联的值。
        结果
        先前的值相关联key ，或null如果没有映射key 。 （A null返回也可以指示以前关联的地图null与key ）

      • putAll

        public void putAll​(Map<? extends K,? extends V> m)
        将指定地图的所有映射复制到此地图。 这些映射将替换此映射对当前在指定映射中的任何键的任何映射。
        Specified by:
        putAll在接口 Map<K,V>
        重写：
        putAll在 AbstractMap<K,V>
        参数
        m - 要存储在此地图中的映射。
        异常
        NullPointerException - 如果指定的地图为空。

      • remove

        public V remove​(Object key)
        如果存在，则从该弱散列映射中删除密钥的映射。 更正式地，如果该映射包含从键k到值v的映射，使得(key==null ? k==null : key.equals(k)) ，则删除该映射。 （地图最多可以包含一个这样的映射。）

        返回此映射先前关联的关键字的值，如果映射不包含关键字的映射，则返回null 。 返回值为null并不一定表示该映射不包含该键的映射; 地图也可能将密钥明确映射到null 。

        一旦呼叫返回，该映射将不包含指定键的映射。

        Specified by:
        remove在接口 Map<K,V>
        重写：
        remove在 AbstractMap<K,V>
        参数
        key - 要从地图中删除其映射的密钥
        结果
        前一个值与 key相关联，或 null如果没有映射 key

      • clear

        public void clear​()
        从这张地图中删除所有的映射。 此呼叫返回后，地图将为空。
        Specified by:
        clear在接口 Map<K,V>
        重写：
        clear在 AbstractMap<K,V>

      • containsValue

        public boolean containsValue​(Object value)
        如果此映射将一个或多个键映射到指定的值，则返回 true 。
        Specified by:
        containsValue在接口 Map<K,V>
        重写：
        containsValue在 AbstractMap<K,V>
        参数
        value - 要在该地图中存在的值要进行测试
        结果
        true如果该地图将一个或多个键映射到指定的值

      • keySet

        public Set<K> keySet​()
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        keySet在接口 Map<K,V>
        重写：
        keySet在 AbstractMap<K,V>
        结果
        该地图中包含的键的集合视图

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        values在接口 Map<K,V>
        重写：
        values在 AbstractMap<K,V>
        结果
        该地图中包含的值的集合视图

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        entrySet在接口 Map<K,V>
        Specified by:
        entrySet在 AbstractMap<K,V>
        结果
        该地图中包含的映射的集合视图

      • forEach

        public void forEach​(BiConsumer<? super K,? super V> action)
        说明从界面Map复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach在接口 Map<K,V>
        参数
        action - 要为每个条目执行的操作

      • replaceAll

        public void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        说明从接口Map复制
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll在接口 Map<K,V>
        参数
        function - 应用于每个条目的功能
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class java.util.AbstractCollection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.AbstractCollection

  • Packages that use AbstractCollection
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.relation
    提供关系服务的定义。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。

    • Uses of AbstractCollection in java.util

      Subclasses of AbstractCollection in java.util
      Modifier and Type Class 描述
      class  AbstractList<E>
      该类提供了List接口的骨架实现，以最小化实现由“随机访问”数据存储（例如阵列）支持的接口所需的工作量。
      class  AbstractQueue<E>
      这个类提供了一些Queue操作的骨架实现。
      class  AbstractSequentialList<E>
      该类提供了 List接口的骨架实现，以最小化实现由“顺序访问”数据存储（如链表）支持的此接口所需的工作量。
      class  AbstractSet<E>
      该类提供 Set接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
      class  ArrayDeque<E>
      Deque接口的可调整大小的数组实现。
      class  ArrayList<E>
      List接口的可调整大小的数组实现。
      class  EnumSet<E extends Enum<E>>
      专门用于枚举类型的Set实现。
      class  HashSet<E>
      该类实现 Set接口，由哈希表（实际为 HashMap实例）支持。
      class  LinkedHashSet<E>
      哈希表和链表实现的 Set接口，具有可预测的迭代次序。
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
      class  PriorityQueue<E>
      基于优先级堆的无限优先级queue 。
      class  Stack<E>
      Stack类代表最先进先出（LIFO）堆栈的对象。
      class  TreeSet<E>
      一个NavigableSet实现基于一个TreeMap 。
      class  Vector<E>
      Vector类实现了可扩展的对象数组。

    • Uses of AbstractCollection in java.util.concurrent

      Subclasses of AbstractCollection in java.util.concurrent
      Modifier and Type Class 描述
      class  ArrayBlockingQueue<E>
      有限的blocking queue由数组支持。
      class  ConcurrentLinkedDeque<E>
      基于链接节点的无界并发deque 。
      class  ConcurrentLinkedQueue<E>
      基于链接节点的无界线程安全queue 。
      class  ConcurrentSkipListSet<E>
      可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
      class  CopyOnWriteArraySet<E>
      A Set 对其所有操作使用内部CopyOnWriteArrayList 。
      class  DelayQueue<E extends Delayed>
      一个无限的blocking queue的Delayed元素，其中一个元素只能在其延迟到期时才被使用。
      class  LinkedBlockingDeque<E>
      基于链接节点的可选限定的blocking deque 。
      class  LinkedBlockingQueue<E>
      基于链接节点的可选限定的blocking queue 。
      class  LinkedTransferQueue<E>
      基于链接节点的无界TransferQueue 。
      class  PriorityBlockingQueue<E>
      无限blocking queue使用与PriorityQueue类相同的订购规则，并提供阻止检索操作。
      class  SynchronousQueue<E>
      A blocking queue其中每个插入操作必须等待另一个线程进行相应的删除操作，反之亦然。

    • Uses of AbstractCollection in javafx.collections

      Subclasses of AbstractCollection in javafx.collections
      Modifier and Type Class 描述
      class  ModifiableObservableListBase<E>
      抽象类作为可修改的ObservableList实现的基类。
      class  ObservableListBase<E>
      抽象类作为ObservableList实现的基类。

    • Uses of AbstractCollection in javafx.collections.transformation

      Subclasses of AbstractCollection in javafx.collections.transformation
      Modifier and Type Class 描述
      class  FilteredList<E>
      包装一个ObservableList并使用提供的谓词过滤其内容。
      class  SortedList<E>
      包装一个ObservableList并对其内容进行排序。
      class  TransformationList<E,F>
      所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。

    • Uses of AbstractCollection in javax.management

      Subclasses of AbstractCollection in javax.management
      Modifier and Type Class 描述
      class  AttributeList
      表示MBean属性值的列表。

    • Uses of AbstractCollection in javax.management.relation

      Subclasses of AbstractCollection in javax.management.relation
      Modifier and Type Class 描述
      class  RoleList
      RoleList表示角色列表（Role对象）。
      class  RoleUnresolvedList
      RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。

    • Uses of AbstractCollection in javax.print.attribute.standard

      Subclasses of AbstractCollection in javax.print.attribute.standard
      Modifier and Type Class 描述
      class  JobStateReasons
      JobStateReasons类是一个打印属性类，一组枚举值，它提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.AbstractList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.AbstractList

  • Packages that use AbstractList
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.relation
    提供关系服务的定义。

    • Uses of AbstractList in java.util

      Subclasses of AbstractList in java.util
      Modifier and Type Class 描述
      class  AbstractSequentialList<E>
      此类提供了 List接口的骨架实现，以最小化实现由“顺序访问”数据存储（例如链表）支持的该接口所需的工作量。
      class  ArrayList<E>
      List接口的可调整大小的数组实现。
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
      class  Stack<E>
      Stack类代表一个最先进先出（LIFO）堆栈的对象。
      class  Vector<E>
      Vector类实现了可扩展的对象数组。

    • Uses of AbstractList in javafx.collections

      Subclasses of AbstractList in javafx.collections
      Modifier and Type Class 描述
      class  ModifiableObservableListBase<E>
      抽象类作为可修改的ObservableList实现的基类。
      class  ObservableListBase<E>
      抽象类，用作ObservableList实现的基类。

    • Uses of AbstractList in javafx.collections.transformation

      Subclasses of AbstractList in javafx.collections.transformation
      Modifier and Type Class 描述
      class  FilteredList<E>
      包装一个ObservableList并使用提供的谓词过滤其内容。
      class  SortedList<E>
      包装一个ObservableList并对其内容进行排序。
      class  TransformationList<E,F>
      所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。

    • Uses of AbstractList in javax.management

      Subclasses of AbstractList in javax.management
      Modifier and Type Class 描述
      class  AttributeList
      表示MBean属性值的列表。

    • Uses of AbstractList in javax.management.relation

      Subclasses of AbstractList in javax.management.relation
      Modifier and Type Class 描述
      class  RoleList
      RoleList表示角色列表（Role对象）。
      class  RoleUnresolvedList
      RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.AbstractMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.AbstractMap

  • Packages that use AbstractMap
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。

    • Uses of AbstractMap in java.util

      Subclasses of AbstractMap in java.util
      Modifier and Type Class 描述
      class  EnumMap<K extends Enum<K>,V>
      专门用于枚举类型键的Map实现。
      class  HashMap<K,V>
      基于哈希表的实现的 Map接口。
      class  IdentityHashMap<K,V>
      该类使用哈希表实现 Map接口，当比较键（和值）时，使用引用相等代替对象相等。
      class  LinkedHashMap<K,V>
      哈希表和链表实现 Map接口，具有可预测的迭代次序。
      class  TreeMap<K,V>
      一个基于红黑树的NavigableMap实现。
      class  WeakHashMap<K,V>
      基于哈希表的实现 Map接口，具有 弱键 。

    • Uses of AbstractMap in java.util.concurrent

      Subclasses of AbstractMap in java.util.concurrent
      Modifier and Type Class 描述
      class  ConcurrentHashMap<K,V>
      支持检索的完全并发性和更新的高预期并发性的哈希表。
      class  ConcurrentSkipListMap<K,V>
      一个可扩展并发的ConcurrentNavigableMap实现。

    • Uses of AbstractMap in javafx.scene.input

      Subclasses of AbstractMap in javafx.scene.input
      Modifier and Type Class 描述
      class  ClipboardContent
      数据容器Clipboard数据。

    • Uses of AbstractMap in javax.print.attribute.standard

      Subclasses of AbstractMap in javax.print.attribute.standard
      Modifier and Type Class 描述
      class  PrinterStateReasons
      PrinterStateReasons类是打印属性类，一组枚举值，它提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.AbstractMap.SimpleEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.AbstractMap.SimpleEntry

No usage of java.util.AbstractMap.SimpleEntry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.AbstractMap.SimpleImmutableEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.AbstractMap.SimpleImmutableEntry

No usage of java.util.AbstractMap.SimpleImmutableEntry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.AbstractQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.AbstractQueue

  • Packages that use AbstractQueue
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of AbstractQueue in java.util

      Subclasses of AbstractQueue in java.util
      Modifier and Type Class 描述
      class  PriorityQueue<E>
      基于优先级堆的无限优先级queue 。

    • Uses of AbstractQueue in java.util.concurrent

      Subclasses of AbstractQueue in java.util.concurrent
      Modifier and Type Class 描述
      class  ArrayBlockingQueue<E>
      有限的blocking queue由数组支持。
      class  ConcurrentLinkedQueue<E>
      基于链接节点的无界线程安全queue 。
      class  DelayQueue<E extends Delayed>
      一个无限制的27060986886860的Delayed元素，其中一个元素只能在其延迟到期时才被使用。
      class  LinkedBlockingDeque<E>
      基于链接节点的可选限定的blocking deque 。
      class  LinkedBlockingQueue<E>
      基于链接节点的可选限定的blocking queue 。
      class  LinkedTransferQueue<E>
      基于链接节点的无界TransferQueue 。
      class  PriorityBlockingQueue<E>
      无限blocking queue使用与PriorityQueue类相同的排序规则，并提供阻止检索操作。
      class  SynchronousQueue<E>
      A blocking queue其中每个插入操作必须等待另一个线程相应的删除操作，反之亦然。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.AbstractSequentialList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.AbstractSequentialList

  • Packages that use AbstractSequentialList
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of AbstractSequentialList in java.util

      Subclasses of AbstractSequentialList in java.util
      Modifier and Type Class 描述
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.AbstractSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.AbstractSet

  • Packages that use AbstractSet
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。

    • Uses of AbstractSet in java.util

      Subclasses of AbstractSet in java.util
      Modifier and Type Class 描述
      class  EnumSet<E extends Enum<E>>
      专门用于枚举类型的Set实现。
      class  HashSet<E>
      该类实现了 Set接口，由哈希表（实际为 HashMap实例）支持。
      class  LinkedHashSet<E>
      哈希表和链表实现 Set接口，具有可预测的迭代次序。
      class  TreeSet<E>
      A NavigableSet实现基于TreeMap 。

    • Uses of AbstractSet in java.util.concurrent

      Subclasses of AbstractSet in java.util.concurrent
      Modifier and Type Class 描述
      class  ConcurrentSkipListSet<E>
      可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
      class  CopyOnWriteArraySet<E>
      A Set在其所有操作中使用内部CopyOnWriteArrayList 。

    • Uses of AbstractSet in javax.print.attribute.standard

      Subclasses of AbstractSet in javax.print.attribute.standard
      Modifier and Type Class 描述
      class  JobStateReasons
      JobStateReasons类是一个打印属性类，一组枚举值，提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.ArrayDeque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.ArrayDeque

  • Packages that use ArrayDeque
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of ArrayDeque in java.util

      Methods in java.util that return ArrayDeque
      Modifier and Type 方法 描述
      ArrayDeque<E> ArrayDeque.clone​()
      返回此deque的副本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.ArrayList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.ArrayList

  • Packages that use ArrayList
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.relation
    提供关系服务的定义。

    • Uses of ArrayList in java.awt.dnd

      Fields in java.awt.dnd declared as ArrayList
      Modifier and Type Field 描述
      protected ArrayList<InputEvent> DragGestureRecognizer.events
      DragGestureRecognizer “识别”作为触发拖动的“手势”的事件列表（按顺序）。

    • Uses of ArrayList in java.beans.beancontext

      Fields in java.beans.beancontext declared as ArrayList
      Modifier and Type Field 描述
      protected ArrayList<BeanContextMembershipListener> BeanContextSupport.bcmListeners
      对 protected ArrayList bcmListeners字段的所有访问应在该对象上同步。
      protected ArrayList<BeanContextServicesListener> BeanContextServicesSupport.bcsListeners
      BeanContextServicesListener对象列表。

    • Uses of ArrayList in java.util

      Methods in java.util that return ArrayList
      Modifier and Type 方法 描述
      static <T> ArrayList<T> Collections.list​(Enumeration<T> e)
      返回一个数组列表，其中包含由枚举返回的顺序由指定的枚举返回的元素。

    • Uses of ArrayList in javax.management

      Subclasses of ArrayList in javax.management
      Modifier and Type Class 描述
      class  AttributeList
      表示MBean属性值的列表。
      Methods in javax.management that return ArrayList
      Modifier and Type 方法 描述
      static ArrayList<MBeanServer> MBeanServerFactory.findMBeanServer​(String agentId)
      返回已注册MBeanServer对象的列表。

    • Uses of ArrayList in javax.management.relation

      Subclasses of ArrayList in javax.management.relation
      Modifier and Type Class 描述
      class  RoleList
      RoleList表示角色列表（Role对象）。
      class  RoleUnresolvedList
      A RoleUnresolvedList represents a list of RoleUnresolved objects, representing roles not retrieved from a relation due to a problem encountered when trying to access (read or write) the roles.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Arrays (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Arrays

No usage of java.util.Arrays
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Base64 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Base64

No usage of java.util.Base64
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Base64.Decoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Base64.Decoder

  • Packages that use Base64.Decoder
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Base64.Decoder in java.util

      Methods in java.util that return Base64.Decoder
      Modifier and Type 方法 描述
      static Base64.Decoder Base64.getDecoder​()
      返回一个Base64.Decoder ，它使用Basic类型的base64编码方案进行解码。
      static Base64.Decoder Base64.getMimeDecoder​()
      返回一个Base64.Decoder解码使用MIME型BASE64解码方案。
      static Base64.Decoder Base64.getUrlDecoder​()
      返回一个Base64.Decoder ，它使用URL and Filename safe类型的base64编码方案进行解码。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Base64.Encoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Base64.Encoder

  • Packages that use Base64.Encoder
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Base64.Encoder in java.util

      Methods in java.util that return Base64.Encoder
      Modifier and Type 方法 描述
      static Base64.Encoder Base64.getEncoder​()
      返回一个Base64.Encoder编码使用Basic型base64编码方案。
      static Base64.Encoder Base64.getMimeEncoder​()
      返回一个Base64.Encoder ，它使用MIME类型base64编码方案进行编码。
      static Base64.Encoder Base64.getMimeEncoder​(int lineLength, byte[] lineSeparator)
      返回一个Base64.Encoder ，它使用具有指定行长和行分隔符的MIME类型base64编码方案进行编码。
      static Base64.Encoder Base64.getUrlEncoder​()
      返回一个Base64.Encoder编码使用URL and Filename safe型base64编码方案。
      Base64.Encoder Base64.Encoder.withoutPadding​()
      返回一个编码器实例，编码器等效于此编码器实例，但不会在编码字节数据的末尾添加任何填充字符。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.BitSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.BitSet

  • Packages that use BitSet
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。

    • Uses of BitSet in java.util

      Methods in java.util that return BitSet
      Modifier and Type 方法 描述
      BitSet BitSet.get​(int fromIndex, int toIndex)
      返回一个新 BitSet组成位从这个 BitSet从 fromIndex （含）至 toIndex （独家）。
      static BitSet BitSet.valueOf​(byte[] bytes)
      返回包含给定字节数组中所有位的新位集合。
      static BitSet BitSet.valueOf​(long[] longs)
      返回包含给定长数组中所有位的新位集。
      static BitSet BitSet.valueOf​(ByteBuffer bb)
      返回一个包含给定字节缓冲区中所有位在其位置和极限之间的新位集合。
      static BitSet BitSet.valueOf​(LongBuffer lb)
      返回包含给定长缓冲区中其位置和极限之间的所有位的新位集合。
      Methods in java.util with parameters of type BitSet
      Modifier and Type 方法 描述
      void BitSet.and​(BitSet set)
      执行此参数位置位的此目标位设置的逻辑 AND 。
      void BitSet.andNot​(BitSet set)
      清除此 BitSet其相应位在指定的 BitSet设置的所有位。
      boolean BitSet.intersects​(BitSet set)
      如果指定，则返回true BitSet具有设置为任何位 true ，它们也设置为 true这个 BitSet 。
      void BitSet.or​(BitSet set)
      使用位设置参数执行该位的逻辑 或 。
      void BitSet.xor​(BitSet set)
      使用位设置参数执行该位的逻辑 异或 。

    • Uses of BitSet in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as BitSet
      Modifier and Type Field 描述
      BitSet Element.exclusions
      元素中不能出现的元素集
      BitSet Element.inclusions
      可以在元素内发生的一组元素
      Methods in javax.swing.text.html.parser with parameters of type BitSet
      Modifier and Type 方法 描述
      Element DTD.defineElement​(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
      返回匹配指定参数的 Element 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Calendar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Calendar

  • Packages that use Calendar
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.datatype
    定义XML / Java类型映射。

    • Uses of Calendar in java.sql

      Methods in java.sql with parameters of type Calendar
      Modifier and Type 方法 描述
      Date CallableStatement.getDate​(int parameterIndex, Calendar cal)
      检索指定的JDBC DATE参数的值作为 java.sql.Date对象，使用给定的 Calendar对象构造日期。
      Date CallableStatement.getDate​(String parameterName, Calendar cal)
      使用给定的 Calendar对象构建日期，将JDBC DATE参数的值检索为 java.sql.Date对象。
      Date ResultSet.getDate​(int columnIndex, Calendar cal)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Date对象。
      Date ResultSet.getDate​(String columnLabel, Calendar cal)
      以Java编程语言中的 ResultSet对象的形式 java.sql.Date此 ResultSet对象的当前行中指定列的值。
      Time CallableStatement.getTime​(int parameterIndex, Calendar cal)
      检索指定的JDBC TIME参数的值作为 java.sql.Time对象，使用给定的 Calendar对象来构造时间。
      Time CallableStatement.getTime​(String parameterName, Calendar cal)
      检索JDBC TIME参数的值作为 java.sql.Time对象，使用给定的 Calendar对象构建时间。
      Time ResultSet.getTime​(int columnIndex, Calendar cal)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
      Time ResultSet.getTime​(String columnLabel, Calendar cal)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。
      Timestamp CallableStatement.getTimestamp​(int parameterIndex, Calendar cal)
      检索指定的JDBC TIMESTAMP参数的值作为 java.sql.Timestamp对象，使用给定的 Calendar对象构造 Timestamp对象。
      Timestamp CallableStatement.getTimestamp​(String parameterName, Calendar cal)
      检索JDBC TIMESTAMP参数的值作为 java.sql.Timestamp对象，使用给定的 Calendar对象构造 Timestamp对象。
      Timestamp ResultSet.getTimestamp​(int columnIndex, Calendar cal)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Timestamp对象。
      Timestamp ResultSet.getTimestamp​(String columnLabel, Calendar cal)
      检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.sql.Timestamp对象。
      void CallableStatement.setDate​(String parameterName, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void PreparedStatement.setDate​(int parameterIndex, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void CallableStatement.setTime​(String parameterName, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void PreparedStatement.setTime​(int parameterIndex, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void CallableStatement.setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。
      void PreparedStatement.setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

    • Uses of Calendar in java.text

      Fields in java.text declared as Calendar
      Modifier and Type Field 描述
      protected Calendar DateFormat.calendar
      用于计算日期时间字段和即时时间的Calendar实例。
      Methods in java.text that return Calendar
      Modifier and Type 方法 描述
      Calendar DateFormat.getCalendar​()
      获取与此日期/时间格式化程序关联的日历。
      Methods in java.text with parameters of type Calendar
      Modifier and Type 方法 描述
      void DateFormat.setCalendar​(Calendar newCalendar)
      将日历设置为使用此日期格式。

    • Uses of Calendar in java.util

      Subclasses of Calendar in java.util
      Modifier and Type Class 描述
      class  GregorianCalendar
      GregorianCalendar是的具体子 Calendar ，并提供了世界上大多数国家使用的标准日历系统。
      Methods in java.util that return Calendar
      Modifier and Type 方法 描述
      Calendar Calendar.Builder.build​()
      返回一个由setter方法设置的参数构建的 Calendar 。
      static Calendar Calendar.getInstance​()
      使用默认时区和区域设置获取日历。
      static Calendar Calendar.getInstance​(Locale aLocale)
      使用默认时区和指定的区域设置获取日历。
      static Calendar Calendar.getInstance​(TimeZone zone)
      使用指定的时区和默认语言环境获取日历。
      static Calendar Calendar.getInstance​(TimeZone zone, Locale aLocale)
      获取具有指定时区和区域设置的日历。
      Methods in java.util with parameters of type Calendar
      Modifier and Type 方法 描述
      int Calendar.compareTo​(Calendar anotherCalendar)
      比较由两个 Calendar对象表示的时间值（来自 Epoch的毫秒偏移量）。

    • Uses of Calendar in javax.sql

      Methods in javax.sql with parameters of type Calendar
      Modifier and Type 方法 描述
      void RowSet.setDate​(int parameterIndex, Date x, Calendar cal)
      使用给定的 java.sql.Date值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setDate​(String parameterName, Date x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。
      void RowSet.setTime​(int parameterIndex, Time x, Calendar cal)
      使用给定的 java.sql.Time值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setTime​(String parameterName, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void RowSet.setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      使用给定的 java.sql.Timestamp值在此 RowSet对象的命令中设置指定的参数。
      void RowSet.setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

    • Uses of Calendar in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Calendar
      Modifier and Type 方法 描述
      void BaseRowSet.setDate​(int parameterIndex, Date x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Date对象。
      void BaseRowSet.setDate​(String parameterName, Date x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Date值，使用给定的 Calendar对象。
      void BaseRowSet.setTime​(int parameterIndex, Time x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Time对象。
      void BaseRowSet.setTime​(String parameterName, Time x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。
      void BaseRowSet.setTimestamp​(int parameterIndex, Timestamp x, Calendar cal)
      将指定的参数设置为给定的 java.sql.Timestamp对象。
      void BaseRowSet.setTimestamp​(String parameterName, Timestamp x, Calendar cal)
      使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

    • Uses of Calendar in javax.xml.bind

      Methods in javax.xml.bind that return Calendar
      Modifier and Type 方法 描述
      static Calendar DatatypeConverter.parseDate​(String lexicalXSDDate)
      将字符串参数转换为日历值。
      Calendar DatatypeConverterInterface.parseDate​(String lexicalXSDDate)
      将字符串参数转换为日历值。
      static Calendar DatatypeConverter.parseDateTime​(String lexicalXSDDateTime)
      将字符串参数转换为日历值。
      Calendar DatatypeConverterInterface.parseDateTime​(String lexicalXSDDateTime)
      将字符串参数转换为日历值。
      static Calendar DatatypeConverter.parseTime​(String lexicalXSDTime)
      将字符串参数转换为日历值。
      Calendar DatatypeConverterInterface.parseTime​(String lexicalXSDTime)
      将字符串参数转换为日历值。
      Methods in javax.xml.bind with parameters of type Calendar
      Modifier and Type 方法 描述
      static String DatatypeConverter.printDate​(Calendar val)
      将日历值转换为字符串。
      String DatatypeConverterInterface.printDate​(Calendar val)
      将日历值转换为字符串。
      static String DatatypeConverter.printDateTime​(Calendar val)
      将日历值转换为字符串。
      String DatatypeConverterInterface.printDateTime​(Calendar val)
      将日历值转换为字符串。
      static String DatatypeConverter.printTime​(Calendar val)
      将日历值转换为字符串。
      String DatatypeConverterInterface.printTime​(Calendar val)
      将日历值转换为字符串。

    • Uses of Calendar in javax.xml.datatype

      Methods in javax.xml.datatype with parameters of type Calendar
      Modifier and Type 方法 描述
      abstract void Duration.addTo​(Calendar calendar)
      将此持续时间添加到Calendar对象。
      long Duration.getTimeInMillis​(Calendar startInstant)
      以毫秒为单位返回持续时间的长度。
      abstract Duration Duration.normalizeWith​(Calendar startTimeInstant)
      通过使用特定的时刻作为参考点，将几个月和几个字段转换为日期字段。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Calendar.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Calendar.Builder

  • Packages that use Calendar.Builder
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Calendar.Builder in java.util

      Methods in java.util that return Calendar.Builder
      Modifier and Type 方法 描述
      Calendar.Builder Calendar.Builder.set​(int field, int value)
      将 field参数设置为给定的 value 。
      Calendar.Builder Calendar.Builder.setCalendarType​(String type)
      将日历类型参数设置为给定的 type 。
      Calendar.Builder Calendar.Builder.setDate​(int year, int month, int dayOfMonth)
      将日期字段参数设置 year month和 dayOfMonth给出的值。
      Calendar.Builder Calendar.Builder.setFields​(int... fieldValuePairs)
      将字段参数设置为 fieldValuePairs给出的值，它们是字段对及其值。
      Calendar.Builder Calendar.Builder.setInstant​(long instant)
      设置即时参数给定 instant值是一毫秒的偏移 the Epoch 。
      Calendar.Builder Calendar.Builder.setInstant​(Date instant)
      设置即时参数设置为instant由给定值Date 。
      Calendar.Builder Calendar.Builder.setLenient​(boolean lenient)
      将宽松模式参数设置为 lenient给出的值。
      Calendar.Builder Calendar.Builder.setLocale​(Locale locale)
      将locale参数设置为给定的 locale 。
      Calendar.Builder Calendar.Builder.setTimeOfDay​(int hourOfDay, int minute, int second)
      将时间字段参数设置 hourOfDay minute和 second给出的值。
      Calendar.Builder Calendar.Builder.setTimeOfDay​(int hourOfDay, int minute, int second, int millis)
      设置由给定的一天领域参数值时 hourOfDay ， minute ， second ，并 millis 。
      Calendar.Builder Calendar.Builder.setTimeZone​(TimeZone zone)
      将时区参数设置为给定的 zone 。
      Calendar.Builder Calendar.Builder.setWeekDate​(int weekYear, int weekOfYear, int dayOfWeek)
      将基于周的日期参数设置为给定日期说明符 - 周年，年周和星期几的值。
      Calendar.Builder Calendar.Builder.setWeekDefinition​(int firstDayOfWeek, int minimalDaysInFirstWeek)
      将 firstDayOfWeek参数设置为 firstDayOfWeek和 minimalDaysInFirstWeek给出的值，用于确定一年中的 first week 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Collections (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Collections

No usage of java.util.Collections
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.ConcurrentModificationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.ConcurrentModificationException

  • Packages that use ConcurrentModificationException
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of ConcurrentModificationException in java.nio.file

      Subclasses of ConcurrentModificationException in java.nio.file
      Modifier and Type Class 描述
      class  DirectoryIteratorException
      如果在遍历目录中的条目时遇到I / O错误，则抛出运行时异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Currency (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Currency

  • Packages that use Currency
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Currency in java.text

      Methods in java.text that return Currency
      Modifier and Type 方法 描述
      Currency DecimalFormat.getCurrency​()
      在格式化货币值时获取此十进制格式使用的货币。
      Currency DecimalFormatSymbols.getCurrency​()
      获取这些DecimalFormatSymbols的货币。
      Currency NumberFormat.getCurrency​()
      在格式化货币值时，获取此数字格式使用的货币。
      Methods in java.text with parameters of type Currency
      Modifier and Type 方法 描述
      void DecimalFormat.setCurrency​(Currency currency)
      设置格式化货币值时此数字格式使用的货币。
      void DecimalFormatSymbols.setCurrency​(Currency currency)
      设置这些DecimalFormatSymbols的货币。
      void NumberFormat.setCurrency​(Currency currency)
      设置格式化货币值时此数字格式使用的货币。

    • Uses of Currency in java.util

      Methods in java.util that return Currency
      Modifier and Type 方法 描述
      static Currency Currency.getInstance​(String currencyCode)
      返回给定货币代码的 Currency实例。
      static Currency Currency.getInstance​(Locale locale)
      返回给定区域的国家/地区的 Currency实例。
      Methods in java.util that return types with arguments of type Currency
      Modifier and Type 方法 描述
      static Set<Currency> Currency.getAvailableCurrencies​()
      获得一组可用的货币。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Date (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Date

  • Packages that use Date
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.timer
    提供定时器MBean的定义。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.security.cert
    提供公钥证书类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.datatype
    定义XML / Java类型映射。

    • Uses of Date in java.security

      Methods in java.security that return Date
      Modifier and Type 方法 描述
      abstract Date KeyStoreSpi.engineGetCreationDate​(String alias)
      返回由给定别名标识的条目的创建日期。
      Date KeyStore.getCreationDate​(String alias)
      返回由给定别名标识的条目的创建日期。
      Date Timestamp.getTimestamp​()
      返回生成时间戳的日期和时间。
      Constructors in java.security with parameters of type Date
      Constructor 描述
      Timestamp​(Date timestamp, CertPath signerCertPath)
      构建时间戳

    • Uses of Date in java.security.cert

      Methods in java.security.cert that return Date
      Modifier and Type 方法 描述
      Date X509CertSelector.getCertificateValid​()
      返回certificateValid条件。
      Date PKIXParameters.getDate​()
      返回确定认证路径有效性的时间。
      Date X509CRLSelector.getDateAndTime​()
      返回dateAndTime条件。
      Date CertificateRevokedException.getInvalidityDate​()
      返回无效日期，如此 CertificateRevokedException的无效日期扩展所指定。
      abstract Date X509CRL.getNextUpdate​()
      从CRL获取 nextUpdate日期。
      abstract Date X509Certificate.getNotAfter​()
      从证书的有效期获取 notAfter日期。
      abstract Date X509Certificate.getNotBefore​()
      从证书的有效期获取 notBefore日期。
      Date X509CertSelector.getPrivateKeyValid​()
      返回privateKeyValid条件。
      Date CertificateRevokedException.getRevocationDate​()
      返回证书被撤销的日期。
      abstract Date X509CRLEntry.getRevocationDate​()
      从此X509CRLEntry（ revocationDate）获取撤销日期。
      abstract Date X509CRL.getThisUpdate​()
      从CRL获取 thisUpdate日期。
      Methods in java.security.cert with parameters of type Date
      Modifier and Type 方法 描述
      abstract void X509Certificate.checkValidity​(Date date)
      检查给定日期是否在证书的有效期内。
      void X509CertSelector.setCertificateValid​(Date certValid)
      设置certificateValid标准。
      void PKIXParameters.setDate​(Date date)
      设置认证路径的有效性应该被确定的时间。
      void X509CRLSelector.setDateAndTime​(Date dateAndTime)
      设置dateAndTime标准。
      void X509CertSelector.setPrivateKeyValid​(Date privateKeyValid)
      设置privateKeyValid条件。
      Constructors in java.security.cert with parameters of type Date
      Constructor 描述
      CertificateRevokedException​(Date revocationDate, CRLReason reason, X500Principal authority, Map<String,Extension> extensions)
      构造具有指定撤销日期，原因代码，权限名称和扩展名映射的 CertificateRevokedException 。

    • Uses of Date in java.sql

      Subclasses of Date in java.sql
      Modifier and Type Class 描述
      class  Date
      大约一毫秒值的薄包装，允许JDBC将其标识为SQL DATE值。
      class  Time
      围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。
      class  Timestamp
      java.util.Date周围的薄型封装，允许JDBC API将其标识为SQL TIMESTAMP值。
      Methods in java.sql with parameters of type Date
      Modifier and Type 方法 描述
      int Timestamp.compareTo​(Date o)
      将此 Timestamp对象与给定的 Date对象进行比较。

    • Uses of Date in java.text

      Methods in java.text that return Date
      Modifier and Type 方法 描述
      Date SimpleDateFormat.get2DigitYearStart​()
      返回100年期间的开始日期，2位数年份被解释为在内。
      Date DateFormat.parse​(String source)
      从给定字符串的开始解析文本以生成日期。
      abstract Date DateFormat.parse​(String source, ParsePosition pos)
      根据给定的解析位置解析日期/时间字符串。
      Date SimpleDateFormat.parse​(String text, ParsePosition pos)
      从字符串中解析文本以产生一个 Date 。
      Methods in java.text with parameters of type Date
      Modifier and Type 方法 描述
      String DateFormat.format​(Date date)
      将日期格式化成日期/时间字符串。
      abstract StringBuffer DateFormat.format​(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition)
      将日期格式化成日期/时间字符串。
      StringBuffer SimpleDateFormat.format​(Date date, StringBuffer toAppendTo, FieldPosition pos)
      将给定的 Date为日期/时间字符串，并将结果追加到给定的 StringBuffer 。
      void SimpleDateFormat.set2DigitYearStart​(Date startDate)
      设置100年期间，两位数年份将被解释为在用户指定的日期开始。

    • Uses of Date in java.util

      Methods in java.util that return Date
      Modifier and Type 方法 描述
      static Date Date.from​(Instant instant)
      从 Instant对象获取 Date的实例。
      Date GregorianCalendar.getGregorianChange​()
      获取公历日历更改日期。
      Date Calendar.getTime​()
      返回表示 Calendar的时间值（与 Epoch的毫秒偏移量）的 Date对象。
      Methods in java.util with parameters of type Date
      Modifier and Type 方法 描述
      boolean Date.after​(Date when)
      测试此日期是否在指定日期之后。
      boolean Date.before​(Date when)
      测试此日期是否在指定日期之前。
      int Date.compareTo​(Date anotherDate)
      比较两个日期进行订购。
      boolean SimpleTimeZone.inDaylightTime​(Date date)
      查询给定日期是否在夏令时。
      abstract boolean TimeZone.inDaylightTime​(Date date)
      查询给定的 date是否在此时区的 date时制。
      void Timer.schedule​(TimerTask task, Date time)
      在指定的时间安排指定的任务执行。
      void Timer.schedule​(TimerTask task, Date firstTime, long period)
      从指定的时间开始，对指定的任务执行重复的 固定延迟执行 。
      void Timer.scheduleAtFixedRate​(TimerTask task, Date firstTime, long period)
      从指定的时间开始，对指定的任务执行重复的 固定速率执行 。
      void GregorianCalendar.setGregorianChange​(Date date)
      设置 GregorianCalendar更改日期。
      Calendar.Builder Calendar.Builder.setInstant​(Date instant)
      设置即时参数设置为instant由给定值Date 。
      void Calendar.setTime​(Date date)
      使用给定的 Date设置此日历的时间。

    • Uses of Date in java.util.concurrent.locks

      Methods in java.util.concurrent.locks with parameters of type Date
      Modifier and Type 方法 描述
      boolean AbstractQueuedLongSynchronizer.ConditionObject.awaitUntil​(Date deadline)
      实现绝对定时条件等待。
      boolean AbstractQueuedSynchronizer.ConditionObject.awaitUntil​(Date deadline)
      实现绝对定时条件等待。
      boolean Condition.awaitUntil​(Date deadline)
      使当前线程等待直到发出信号或中断，或者指定的最后期限过去。

    • Uses of Date in javafx.scene.web

      Methods in javafx.scene.web that return Date
      Modifier and Type 方法 描述
      Date WebHistory.Entry.getLastVisitedDate​()
      获取属性lastVisitedDate的值。
      Methods in javafx.scene.web that return types with arguments of type Date
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Date> WebHistory.Entry.lastVisitedDateProperty​()
      定义页面最后访问的Date 。

    • Uses of Date in javafx.util.converter

      Methods in javafx.util.converter that return Date
      Modifier and Type 方法 描述
      Date DateTimeStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Date
      Modifier and Type 方法 描述
      String DateTimeStringConverter.toString​(Date value)
      将提供的对象转换为其字符串形式。

    • Uses of Date in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Date
      Modifier and Type Field 描述
      static SimpleType<Date> SimpleType.DATE
      描述Java类名称为 java.util.Date值的 SimpleType实例。

    • Uses of Date in javax.management.timer

      Methods in javax.management.timer that return Date
      Modifier and Type 方法 描述
      Date Timer.getDate​(Integer id)
      获取与定时器通知相关联的日期的副本。
      Date TimerMBean.getDate​(Integer id)
      获取与定时器通知相关联的日期的副本。
      Methods in javax.management.timer with parameters of type Date
      Modifier and Type 方法 描述
      Integer Timer.addNotification​(String type, String message, Object userData, Date date)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。
      Integer Timer.addNotification​(String type, String message, Object userData, Date date, long period)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。
      Integer Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

    • Uses of Date in javax.print.attribute

      Methods in javax.print.attribute that return Date
      Modifier and Type 方法 描述
      Date DateTimeSyntax.getValue​()
      返回此日期时间属性的 java.util.Date值。
      Constructors in javax.print.attribute with parameters of type Date
      Constructor 描述
      DateTimeSyntax​(Date value)
      使用给定的 java.util.Date值构造新的日期时间属性。

    • Uses of Date in javax.print.attribute.standard

      Constructors in javax.print.attribute.standard with parameters of type Date
      Constructor 描述
      DateTimeAtCompleted​(Date dateTime)
      使用给定的Date值在完成属性中构建新的日期时间。
      DateTimeAtCreation​(Date dateTime)
      使用给定的Date值创建一个新的创建日期时间属性。
      DateTimeAtProcessing​(Date dateTime)
      在给定的Date值处理属性时构造一个新的日期时间。
      JobHoldUntil​(Date dateTime)
      构造新的作业保持，直到date-time属性与给定的Date值。

    • Uses of Date in javax.security.auth.kerberos

      Methods in javax.security.auth.kerberos that return Date
      Modifier and Type 方法 描述
      Date KerberosTicket.getAuthTime​()
      返回客户端进行身份验证的时间。
      Date KerberosTicket.getEndTime​()
      返回此票证有效期的到期时间。
      Date KerberosTicket.getRenewTill​()
      返回此机票的最新到期时间，包括所有续订。
      Date KerberosTicket.getStartTime​()
      返回此票证有效期的开始时间。
      Constructors in javax.security.auth.kerberos with parameters of type Date
      Constructor 描述
      KerberosTicket​(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
      构建一个 KerberosTicket使用客户端从KDC接收或从缓存读取的凭据信息。

    • Uses of Date in javax.security.cert

      Methods in javax.security.cert that return Date
      Modifier and Type 方法 描述
      abstract Date X509Certificate.getNotAfter​()
      已过时。
      从证书的有效期获取 notAfter日期。
      abstract Date X509Certificate.getNotBefore​()
      已过时。
      从证书的有效期获取 notBefore日期。
      Methods in javax.security.cert with parameters of type Date
      Modifier and Type 方法 描述
      abstract void X509Certificate.checkValidity​(Date date)
      已过时。
      检查指定的日期是否在证书的有效期内。

    • Uses of Date in javax.swing

      Methods in javax.swing that return Date
      Modifier and Type 方法 描述
      Date SpinnerDateModel.getDate​()
      返回此序列中的当前元素 Date s。
      Methods in javax.swing that return types with arguments of type Date
      Modifier and Type 方法 描述
      Comparable<Date> SpinnerDateModel.getEnd​()
      按顺序返回最后一个 Date 。
      Comparable<Date> SpinnerDateModel.getStart​()
      返回序列中的第一个 Date 。
      Methods in javax.swing with parameters of type Date
      Modifier and Type 方法 描述
      static <M,I> RowFilter<M,I> RowFilter.dateFilter​(RowFilter.ComparisonType type, Date date, int... indices)
      返回一个 RowFilter ，其中包含符合指定条件的值至少有一个 Date条目。
      Method parameters in javax.swing with type arguments of type Date
      Modifier and Type 方法 描述
      void SpinnerDateModel.setEnd​(Comparable<Date> end)
      按此顺序更改 Date的上限。
      void SpinnerDateModel.setStart​(Comparable<Date> start)
      更改此顺序中日期的下限。
      Constructors in javax.swing with parameters of type Date
      Constructor 描述
      SpinnerDateModel​(Date value, Comparable<Date> start, Comparable<Date> end, int calendarField)
      创建一个 SpinnerDateModel ，表示 start和 end之间的日期序列。
      Constructor parameters in javax.swing with type arguments of type Date
      Constructor 描述
      SpinnerDateModel​(Date value, Comparable<Date> start, Comparable<Date> end, int calendarField)
      创建一个 SpinnerDateModel ，表示 start和 end之间的日期序列。

    • Uses of Date in javax.xml.datatype

      Methods in javax.xml.datatype with parameters of type Date
      Modifier and Type 方法 描述
      void Duration.addTo​(Date date)
      将此持续时间添加到Date对象。
      long Duration.getTimeInMillis​(Date startInstant)
      以毫秒为单位返回持续时间的长度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Dictionary (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Dictionary

  • Packages that use Dictionary
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Dictionary in java.security

      Subclasses of Dictionary in java.security
      Modifier and Type Class 描述
      class  AuthProvider
      此类为提供程序定义登录和注销方法。
      class  Provider
      该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。

    • Uses of Dictionary in java.util

      Subclasses of Dictionary in java.util
      Modifier and Type Class 描述
      class  Hashtable<K,V>
      该类实现了一个哈希表，它将键映射到值。
      class  Properties
      Properties类表示一组持久的属性。

    • Uses of Dictionary in javax.swing

      Subclasses of Dictionary in javax.swing
      Modifier and Type Class 描述
      class  UIDefaults
      Swing组件的默认表。
      Methods in javax.swing that return Dictionary
      Modifier and Type 方法 描述
      Dictionary JSlider.getLabelTable​()
      返回要在哪些值绘制哪些标签的字典。
      Methods in javax.swing with parameters of type Dictionary
      Modifier and Type 方法 描述
      void JSlider.setLabelTable​(Dictionary labels)
      用于指定在任何给定值下绘制什么标签。

    • Uses of Dictionary in javax.swing.text

      Methods in javax.swing.text that return Dictionary
      Modifier and Type 方法 描述
      Dictionary<Object,Object> AbstractDocument.getDocumentProperties​()
      支持管理一组属性。
      Methods in javax.swing.text with parameters of type Dictionary
      Modifier and Type 方法 描述
      void AbstractDocument.setDocumentProperties​(Dictionary<Object,Object> x)
      Replaces the document properties dictionary for this document.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.DoubleSummaryStatistics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.DoubleSummaryStatistics

  • Packages that use DoubleSummaryStatistics
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleSummaryStatistics in java.util

      Methods in java.util with parameters of type DoubleSummaryStatistics
      Modifier and Type 方法 描述
      void DoubleSummaryStatistics.combine​(DoubleSummaryStatistics other)
      将另一个 DoubleSummaryStatistics的状态合并到一个。

    • Uses of DoubleSummaryStatistics in java.util.stream

      Methods in java.util.stream that return DoubleSummaryStatistics
      Modifier and Type 方法 描述
      DoubleSummaryStatistics DoubleStream.summaryStatistics​()
      返回一个 DoubleSummaryStatistics描述有关此流的元素的各种摘要数据。
      Methods in java.util.stream that return types with arguments of type DoubleSummaryStatistics
      Modifier and Type 方法 描述
      static <T> Collector<T,?,DoubleSummaryStatistics> Collectors.summarizingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 Collector ， double生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.DuplicateFormatFlagsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.DuplicateFormatFlagsException

No usage of java.util.DuplicateFormatFlagsException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.EmptyStackException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.EmptyStackException

  • Packages that use EmptyStackException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of EmptyStackException in java.awt

      Methods in java.awt that throw EmptyStackException
      Modifier and Type 方法 描述
      protected void EventQueue.pop​()
      使用此 EventQueue停止调度事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.EnumMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.EnumMap

  • Packages that use EnumMap
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of EnumMap in java.util

      Methods in java.util that return EnumMap
      Modifier and Type 方法 描述
      EnumMap<K,V> EnumMap.clone​()
      返回此枚举映射的浅拷贝。
      Constructors in java.util with parameters of type EnumMap
      Constructor 描述
      EnumMap​(EnumMap<K,? extends V> m)
      创建与指定的枚举映射相同的键类型的枚举映射，最初包含相同的映射（如果有）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.EnumSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.EnumSet

  • Packages that use EnumSet
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of EnumSet in java.util

      Methods in java.util that return EnumSet
      Modifier and Type 方法 描述
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.allOf​(Class<E> elementType)
      创建一个包含指定元素类型中所有元素的枚举集。
      EnumSet<E> EnumSet.clone​()
      返回此集合的副本。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.complementOf​(EnumSet<E> s)
      创建与指定枚举集具有相同元素类型的枚举集，最初包含此类型的所有元素，该元素 不包含在指定的集合中。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.copyOf​(Collection<E> c)
      创建从指定集合初始化的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.copyOf​(EnumSet<E> s)
      创建与指定的枚举集相同的元素类型的枚举集，最初包含相同的元素（如果有）。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.noneOf​(Class<E> elementType)
      使用指定的元素类型创建一个空的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e1, E e2)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E first, E... rest)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e1, E e2, E e3)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e1, E e2, E e3, E e4)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e1, E e2, E e3, E e4, E e5)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.range​(E from, E to)
      创建最初包含由两个指定端点定义的范围内的所有元素的枚举集。
      Methods in java.util with parameters of type EnumSet
      Modifier and Type 方法 描述
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.complementOf​(EnumSet<E> s)
      创建与指定枚举集具有相同元素类型的枚举集，最初包含此类型的所有元素，该元素 不包含在指定的集合中。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.copyOf​(EnumSet<E> s)
      创建与指定的枚举集相同的元素类型的枚举集，最初包含相同的元素（如果有）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.EventListenerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.EventListenerProxy

  • Packages that use EventListenerProxy
    软件包 描述
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of EventListenerProxy in java.awt.event

      Subclasses of EventListenerProxy in java.awt.event
      Modifier and Type Class 描述
      class  AWTEventListenerProxy
      一个类扩展了 EventListenerProxy专门为特定的事件掩码添加了一个 AWTEventListener 。

    • Uses of EventListenerProxy in java.beans

      Subclasses of EventListenerProxy in java.beans
      Modifier and Type Class 描述
      class  PropertyChangeListenerProxy
      一个类扩展了 EventListenerProxy专门用于添加一个带有“bound”属性的 PropertyChangeListener 。
      class  VetoableChangeListenerProxy
      它扩展了一类 EventListenerProxy专门用于添加 VetoableChangeListener具有“受限”属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.EventObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.EventObject

  • Packages that use EventObject
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.timer
    提供定时器MBean的定义。
    javax.naming.event
    访问命名和目录服务时，提供对事件通知的支持。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print.event
    程序包javax.print.event包含事件类和侦听器接口。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of EventObject in java.awt

      Subclasses of EventObject in java.awt
      Modifier and Type Class 描述
      class  AWTEvent
      所有AWT事件的根事件类。

    • Uses of EventObject in java.awt.datatransfer

      Subclasses of EventObject in java.awt.datatransfer
      Modifier and Type Class 描述
      class  FlavorEvent
      FlavorEvent用于通知有关方面可用的DataFlavor在Clipboard （事件源）中已更改。

    • Uses of EventObject in java.awt.desktop

      Subclasses of EventObject in java.awt.desktop
      Modifier and Type Class 描述
      class  AboutEvent
      当应用程序被要求打开窗口时发送事件。
      class  AppEvent
      AppEvent被发送到安装在Desktop上的监听器和处理程序。
      class  AppForegroundEvent
      当应用程序成为前台应用程序时，发送的事件，以及何时不再是前台应用程序。
      class  AppHiddenEvent
      应用程序隐藏或显示时发送的事件。
      class  AppReopenedEvent
      当应用程序被要求重新打开时发送事件。
      class  FilesEvent
      辅助事件包含文件列表。
      class  OpenFilesEvent
      当应用程序被要求打开文件列表时发送事件。
      class  OpenURIEvent
      当应用程序被要求打开一个 URI时发送的事件。
      class  PreferencesEvent
      当请求应用程序打开其首选项窗口时发送事件。
      class  PrintFilesEvent
      当应用程序被要求打印文件列表时发送事件。
      class  QuitEvent
      当应用程序被要求退出时发送事件。
      class  ScreenSleepEvent
      当系统显示器进入并退出省电睡眠时发送事件。
      class  SystemSleepEvent
      系统进入和退出省电休眠时发送的事件。
      class  UserSessionEvent
      用户会话更改时发送的事件。

    • Uses of EventObject in java.awt.dnd

      Subclasses of EventObject in java.awt.dnd
      Modifier and Type Class 描述
      class  DragGestureEvent
      当特定的 DragGestureRecognizer检测到正在跟踪的 Component上发生平台相关的拖动启动手势时， DragGestureEvent被传递给 DragGestureListener的dragGestureRecognized（）方法。
      class  DragSourceDragEvent
      DragSourceDragEvent是从 DragSourceContextPeer通过 DragSourceContext发送到 DragSourceListener注册的 DragSourceContext及其相关联的 DragSource 。
      class  DragSourceDropEvent
      DragSourceDropEvent从 DragSourceContextPeer通过 DragSourceContext发送到 dragDropEnd的 DragSourceListener的 DragSourceContext及其相关联的 DragSource 。
      class  DragSourceEvent
      这个类是 DragSourceDragEvent和 DragSourceDropEvent的基类。
      class  DropTargetDragEvent
      所述 DropTargetDragEvent被输送到 DropTargetListener经由其dragEnter事件（）和的dragover（）方法。
      class  DropTargetDropEvent
      DropTargetDropEvent通过 DropTargetListener drop（）方法传递。
      class  DropTargetEvent
      DropTargetEvent是 DropTargetDragEvent和 DropTargetDropEvent的基础类。

    • Uses of EventObject in java.awt.event

      Subclasses of EventObject in java.awt.event
      Modifier and Type Class 描述
      class  ActionEvent
      指示组件定义的动作发生的语义事件。
      class  AdjustmentEvent
      可调整对象发出的调整事件，如Scrollbar和ScrollPane 。
      class  ComponentEvent
      指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
      class  ContainerEvent
      低级别事件，表示容器的内容因添加或删除组件而发生更改。
      class  FocusEvent
      指示组件已经获得或丢失了输入焦点的低级事件。
      class  HierarchyEvent
      指示 Component所属的 Component层次结构的更改的事件。
      class  InputEvent
      所有组件级输入事件的根事件类。
      class  InputMethodEvent
      输入法事件包含使用输入法组合的文本信息。
      class  InvocationEvent
      在由AWT事件调度程序线程调度时，在 Runnable执行 run()方法的事件。
      class  ItemEvent
      表示选择或取消选择项目的语义事件。
      class  KeyEvent
      指示组件中发生击键的事件。
      class  MouseEvent
      指示组件中发生鼠标操作的事件。
      class  MouseWheelEvent
      指示鼠标轮在组件中旋转的事件。
      class  PaintEvent
      组件级paint事件。
      class  TextEvent
      表示对象的文本改变的语义事件。
      class  WindowEvent
      指示窗口已更改其状态的低级别事件。

    • Uses of EventObject in java.beans

      Subclasses of EventObject in java.beans
      Modifier and Type Class 描述
      class  IndexedPropertyChangeEvent
      只要符合JavaBeans¢规范（“bean”）的组件更改绑定的索引属性，就会传递“IndexedPropertyChange”事件。
      class  PropertyChangeEvent
      只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。

    • Uses of EventObject in java.beans.beancontext

      Subclasses of EventObject in java.beans.beancontext
      Modifier and Type Class 描述
      class  BeanContextEvent
      BeanContextEvent是从 BeanContext的语义发出的所有事件的抽象根事件类。
      class  BeanContextMembershipEvent
      A BeanContextMembershipEvent封装了添加到特定 BeanContext的成员资格或从其中删除的子项列表。
      class  BeanContextServiceAvailableEvent
      BeanContextServicesListener使用此事件类型来识别正在注册的服务。
      class  BeanContextServiceRevokedEvent
      BeanContextServiceRevokedListener使用此事件类型来识别正在撤销的服务。

    • Uses of EventObject in java.util.prefs

      Subclasses of EventObject in java.util.prefs
      Modifier and Type Class 描述
      class  NodeChangeEvent
      由 Preferences节点发出的一个事件，指示该节点的子节点已被添加或删除。
      class  PreferenceChangeEvent
      由 Preferences节点发出的一个事件，指示已添加，删除或已更改其值的首选项。

    • Uses of EventObject in javafx.concurrent

      Subclasses of EventObject in javafx.concurrent
      Modifier and Type Class 描述
      class  WorkerStateEvent
      当一个工人状态发生变化时发生的事件。

    • Uses of EventObject in javafx.event

      Subclasses of EventObject in javafx.event
      Modifier and Type Class 描述
      class  ActionEvent
      一个Event代表一些类型的动作。
      class  Event
      FX事件的基础类。

    • Uses of EventObject in javafx.scene.control

      Subclasses of EventObject in javafx.scene.control
      Modifier and Type Class 描述
      static class  CheckBoxTreeItem.TreeModificationEvent<T>
      一个TreeModificationEvent类，类似于TreeItem.TreeModificationEvent类，因为这个事件会引发 CheckBoxTreeItem层次结构，直到父节点为空。
      class  DialogEvent
      与对话框显示/隐藏操作相关的事件。
      static class  ListView.EditEvent<T>
      一个Event子类，专门用于ListView中用于表示编辑相关事件。
      class  ScrollToEvent<T>
      事件相关ScrollPane所虚拟化控制，比如ListView ， TableView ， TreeView和TreeTableView 。
      class  SortEvent<C>
      事件涉及TableView和TreeTableView排序。
      static class  TableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TreeItem.TreeModificationEvent<T>
      一个包含所有形式的TreeItem修改的相关信息的Event 。
      static class  TreeTableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TreeTableView.EditEvent<S>
      一个Event子类，专门用于TreeTableView表示编辑相关事件。
      static class  TreeView.EditEvent<T>
      一个Event子类，专门用于TreeView中用于表示编辑相关事件。

    • Uses of EventObject in javafx.scene.input

      Subclasses of EventObject in javafx.scene.input
      Modifier and Type Class 描述
      class  ContextMenuEvent
      当用户请求上下文菜单时，会发生此事件。
      class  DragEvent
      拖动事件在拖放手势时替换鼠标事件。
      class  GestureEvent
      表示手势输入的事件。
      class  InputEvent
      指示用户输入的事件。
      class  InputMethodEvent
      一个表示底层输入法在Node中通知其文本更改的事件 。
      class  KeyEvent
      一个事件，表示一个击键发生在一个Node 。
      class  MouseDragEvent
      鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
      class  MouseEvent
      当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。
      class  RotateEvent
      旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
      class  ScrollEvent
      滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。
      class  SwipeEvent
      滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。
      class  TouchEvent
      触摸事件表示触摸屏操作。
      class  ZoomEvent
      缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。

    • Uses of EventObject in javafx.scene.media

      Subclasses of EventObject in javafx.scene.media
      Modifier and Type Class 描述
      class  MediaErrorEvent
      表示在处理介质中出现错误的Event 。
      class  MediaMarkerEvent
      代表介质标记的ActionEvent 。

    • Uses of EventObject in javafx.scene.transform

      Subclasses of EventObject in javafx.scene.transform
      Modifier and Type Class 描述
      class  TransformChangedEvent
      当它的任何属性发生变化时，这个事件被触发。

    • Uses of EventObject in javafx.scene.web

      Subclasses of EventObject in javafx.scene.web
      Modifier and Type Class 描述
      class  WebErrorEvent
      一个表示WebEngine错误的事件。
      class  WebEvent<T>
      WebEvent实例被传递到EventHandler ，注册小号WebEngine由JavaScript的网页上运行。

    • Uses of EventObject in javafx.stage

      Subclasses of EventObject in javafx.stage
      Modifier and Type Class 描述
      class  WindowEvent
      与窗口显示/隐藏操作相关的事件。

    • Uses of EventObject in javax.management

      Subclasses of EventObject in javax.management
      Modifier and Type Class 描述
      class  AttributeChangeNotification
      提供MBean发送的属性更改通知的定义。
      class  MBeanServerNotification
      表示MBean服务器通过MBeanServerDelegate MBean发出的通知。
      class  Notification
      Notification类表示由MBean发出的通知。

    • Uses of EventObject in javax.management.monitor

      Subclasses of EventObject in javax.management.monitor
      Modifier and Type Class 描述
      class  MonitorNotification
      提供监视器MBean发送的通知的定义。

    • Uses of EventObject in javax.management.relation

      Subclasses of EventObject in javax.management.relation
      Modifier and Type Class 描述
      class  RelationNotification
      关系服务变更通知。

    • Uses of EventObject in javax.management.remote

      Subclasses of EventObject in javax.management.remote
      Modifier and Type Class 描述
      class  JMXConnectionNotification
      客户端连接打开或关闭或通知丢失时发出的通知。

    • Uses of EventObject in javax.management.timer

      Subclasses of EventObject in javax.management.timer
      Modifier and Type Class 描述
      class  TimerNotification
      此类提供了定时器MBeans发送的通知的定义。

    • Uses of EventObject in javax.naming.event

      Subclasses of EventObject in javax.naming.event
      Modifier and Type Class 描述
      class  NamingEvent
      此类表示由命名/目录服务触发的事件。
      class  NamingExceptionEvent
      该类代表当用于收集通知 NamingEvent的听众的信息的过程/过程抛出 NamingException 。

    • Uses of EventObject in javax.naming.ldap

      Subclasses of EventObject in javax.naming.ldap
      Modifier and Type Class 描述
      class  UnsolicitedNotificationEvent
      此类表示响应LDAP服务器发送的未经请求的通知触发的事件。

    • Uses of EventObject in javax.net.ssl

      Subclasses of EventObject in javax.net.ssl
      Modifier and Type Class 描述
      class  HandshakeCompletedEvent
      此事件表示在给定SSL连接上完成SSL握手。
      class  SSLSessionBindingEvent
      此事件传播到SSLSessionBindingListener。

    • Uses of EventObject in javax.print.event

      Subclasses of EventObject in javax.print.event
      Modifier and Type Class 描述
      class  PrintEvent
      PrintEvent类是所有Print Service API事件的超类。
      class  PrintJobAttributeEvent
      PrintJobAttributeEvent类封装PrintService报告的事件，让客户端知道PrintJob的一个或多个打印属性已更改。
      class  PrintJobEvent
      PrintJobEvent类封装了打印作业报告的常见事件，让听众知道处理DocPrintJob的进度 。
      class  PrintServiceAttributeEvent
      PrintServiceAttributeEvent类封装Print Service实例报告的事件，让客户端了解打印服务状态的变化。

    • Uses of EventObject in javax.sound.sampled

      Subclasses of EventObject in javax.sound.sampled
      Modifier and Type Class 描述
      class  LineEvent
      LineEvent类封装了线路打开，关闭，启动或停止时线路发送其监听器的信息。

    • Uses of EventObject in javax.sql

      Subclasses of EventObject in javax.sql
      Modifier and Type Class 描述
      class  ConnectionEvent
      一个 Event对象，提供有关连接相关事件源的信息。
      class  RowSetEvent
      当事件发生到 Event对象时生成的一个 RowSet对象。
      class  StatementEvent
      A StatementEvent发送到所有 StatementEventListener ，其中注册了一个 PooledConnection 。

    • Uses of EventObject in javax.swing

      Methods in javax.swing with parameters of type EventObject
      Modifier and Type 方法 描述
      boolean JTable.editCellAt​(int row, int column, EventObject e)
      以 row和 column编程单元格，如果这些索引处于有效范围，那么这些索引的单元格是可编辑的。
      boolean AbstractCellEditor.isCellEditable​(EventObject e)
      返回true。
      boolean CellEditor.isCellEditable​(EventObject anEvent)
      要求编辑器是否可以使用 anEvent开始编辑。
      boolean DefaultCellEditor.EditorDelegate.isCellEditable​(EventObject anEvent)
      如果返回true anEvent 不是 MouseEvent 。
      boolean DefaultCellEditor.isCellEditable​(EventObject anEvent)
      将消息从 CellEditor转发到 delegate 。
      boolean AbstractCellEditor.shouldSelectCell​(EventObject anEvent)
      返回true。
      boolean CellEditor.shouldSelectCell​(EventObject anEvent)
      如果选择编辑单元格，则返回true，否则返回false。
      boolean DefaultCellEditor.EditorDelegate.shouldSelectCell​(EventObject anEvent)
      返回true表示可以选择编辑单元格。
      boolean DefaultCellEditor.shouldSelectCell​(EventObject anEvent)
      将消息从 CellEditor转发到 delegate 。
      boolean DefaultCellEditor.EditorDelegate.startCellEditing​(EventObject anEvent)
      返回true表示编辑已经开始。

    • Uses of EventObject in javax.swing.event

      Subclasses of EventObject in javax.swing.event
      Modifier and Type Class 描述
      class  AncestorEvent
      向组件层级中的祖先发送的子组件的事件。
      class  CaretEvent
      CaretEvent用于通知有关方面事件源文本插入符已更改。
      class  ChangeEvent
      ChangeEvent用于通知有关方面事件来源状态已更改。
      class  HyperlinkEvent
      HyperlinkEvent用于通知有关方面，超文本链接发生了一些事情。
      class  InternalFrameEvent
      一个 AWTEvent添加了对 JInternalFrame对象作为事件源的支持。
      class  ListDataEvent
      定义将更改封装到列表的事件。
      class  ListSelectionEvent
      表征选择变化的事件。
      class  MenuDragMouseEvent
      MenuDragMouseEvent用于通知有关方面，菜单元素已经在拖动条件下接收到转发给它的MouseEvent。
      class  MenuEvent
      MenuEvent用于通知有关方面，事件源的菜单已经过滤，选择或取消。
      class  MenuKeyEvent
      MenuKeyEvent用于通知有关方菜单元素已经在菜单树中收到转发给它的KeyEvent。
      class  PopupMenuEvent
      PopupMenuEvent仅包含发送事件的JPopupMenu事件的源
      class  RowSorterEvent
      RowSorterEvent提供改变到的通知 RowSorter 。
      class  TableColumnModelEvent
      TableColumnModelEvent用于通知侦听器表列模型已更改，例如添加，删除或移动列。
      class  TableModelEvent
      TableModelEvent用于通知侦听器表模型已更改。
      class  TreeExpansionEvent
      用于标识树中单个路径的事件。
      class  TreeModelEvent
      将描述更改的信息封装到树模型，并用于通知树型模型侦听器的更改。
      class  TreeSelectionEvent
      表示当前选择的变化的事件。
      class  UndoableEditEvent
      发生可以撤消的操作的事件。

    • Uses of EventObject in javax.swing.text.html

      Subclasses of EventObject in javax.swing.text.html
      Modifier and Type Class 描述
      class  FormSubmitEvent
      FormSubmitEvent用于通知有关方面提交表单。
      class  HTMLFrameHyperlinkEvent
      HTMLFrameHyperlinkEvent用于通知相关方链接已在一帧中激活。

    • Uses of EventObject in javax.swing.tree

      Methods in javax.swing.tree with parameters of type EventObject
      Modifier and Type 方法 描述
      protected boolean DefaultTreeCellEditor.canEditImmediately​(EventObject event)
      如果返回true event为 null ，或者它是一个 MouseEvent与点击计数> 2 inHitRegion返回true。
      boolean DefaultTreeCellEditor.isCellEditable​(EventObject event)
      如果 realEditor返回true，则返回 prepareForEditing ，并返回true。
      boolean DefaultTreeCellEditor.shouldSelectCell​(EventObject event)
      消息 realEditor的返回值。
      protected boolean DefaultTreeCellEditor.shouldStartEditingTimer​(EventObject event)
      如果 event是 MouseEvent ，点击次数为1，则返回true。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.FormatFlagsConversionMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.FormatFlagsConversionMismatchException

No usage of java.util.FormatFlagsConversionMismatchException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.FormattableFlags (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.FormattableFlags

No usage of java.util.FormattableFlags
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Formatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Formatter

  • Packages that use Formatter
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Formatter in java.util

      Methods in java.util that return Formatter
      Modifier and Type 方法 描述
      Formatter Formatter.format​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此对象的目标。
      Formatter Formatter.format​(Locale l, String format, Object... args)
      使用指定的区域设置，格式字符串和参数将格式化的字符串写入此对象的目标。
      Methods in java.util with parameters of type Formatter
      Modifier and Type 方法 描述
      void Formattable.formatTo​(Formatter formatter, int flags, int width, int precision)
      使用提供的formatter格式化对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Formatter.BigDecimalLayoutForm (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Formatter.BigDecimalLayoutForm

  • Packages that use Formatter.BigDecimalLayoutForm
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Formatter.BigDecimalLayoutForm in java.util

      Methods in java.util that return Formatter.BigDecimalLayoutForm
      Modifier and Type 方法 描述
      static Formatter.BigDecimalLayoutForm Formatter.BigDecimalLayoutForm.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Formatter.BigDecimalLayoutForm[] Formatter.BigDecimalLayoutForm.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.FormatterClosedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.FormatterClosedException

No usage of java.util.FormatterClosedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.GregorianCalendar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.GregorianCalendar

  • Packages that use GregorianCalendar
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.xml.datatype
    定义XML / Java类型映射。

    • Uses of GregorianCalendar in java.util

      Methods in java.util that return GregorianCalendar
      Modifier and Type 方法 描述
      static GregorianCalendar GregorianCalendar.from​(ZonedDateTime zdt)
      获取的实例 GregorianCalendar从一个默认的语言环境 ZonedDateTime对象。

    • Uses of GregorianCalendar in javax.xml.datatype

      Methods in javax.xml.datatype that return GregorianCalendar
      Modifier and Type 方法 描述
      abstract GregorianCalendar XMLGregorianCalendar.toGregorianCalendar​()
      将此XMLGregorianCalendar转换为GregorianCalendar 。
      abstract GregorianCalendar XMLGregorianCalendar.toGregorianCalendar​(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
      将此XMLGregorianCalendar与提供的参数一起转换为GregorianCalendar实例。
      Methods in javax.xml.datatype with parameters of type GregorianCalendar
      Modifier and Type 方法 描述
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar​(GregorianCalendar cal)
      创建XMLGregorianCalendar从GregorianCalendar 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.HashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.HashMap

  • Packages that use HashMap
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。

    • Uses of HashMap in java.beans.beancontext

      Fields in java.beans.beancontext declared as HashMap
      Modifier and Type Field 描述
      protected HashMap<Object,BeanContextSupport.BCSChild> BeanContextSupport.children
      对该对象的所有对 protected HashMap children字段的访问都应同步。
      protected HashMap<Object,BeanContextServicesSupport.BCSSServiceProvider> BeanContextServicesSupport.services
      protected transient HashMap services字段的所有访问应该在该对象上同步

    • Uses of HashMap in java.util

      Subclasses of HashMap in java.util
      Modifier and Type Class 描述
      class  LinkedHashMap<K,V>
      哈希表和链表实现的 Map接口，具有可预测的迭代次序。

    • Uses of HashMap in javafx.scene.input

      Subclasses of HashMap in javafx.scene.input
      Modifier and Type Class 描述
      class  ClipboardContent
      数据容器Clipboard数据。

    • Uses of HashMap in javax.print.attribute.standard

      Subclasses of HashMap in javax.print.attribute.standard
      Modifier and Type Class 描述
      class  PrinterStateReasons
      PrinterStateReasons类是打印属性类，一组枚举值，它提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.HashSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.HashSet

  • Packages that use HashSet
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。

    • Uses of HashSet in java.util

      Subclasses of HashSet in java.util
      Modifier and Type Class 描述
      class  LinkedHashSet<E>
      哈希表和链表实现的 Set接口，具有可预测的迭代次序。

    • Uses of HashSet in javax.print.attribute.standard

      Subclasses of HashSet in javax.print.attribute.standard
      Modifier and Type Class 描述
      class  JobStateReasons
      JobStateReasons类是一个打印属性类，一组枚举值，它提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Hashtable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Hashtable

  • Packages that use Hashtable
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.management
    提供Java管理扩展的核心类。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming软件包以提供访问目录服务的功能。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.naming.spi
    提供通过 javax.naming和相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。

    • Uses of Hashtable in java.awt

      Fields in java.awt declared as Hashtable
      Modifier and Type Field 描述
      protected Hashtable<Component,GridBagConstraints> GridBagLayout.comptable
      这个散列表维护了一个组件与其gridbag约束之间的关联。

    • Uses of Hashtable in java.awt.image

      Methods in java.awt.image with parameters of type Hashtable
      Modifier and Type 方法 描述
      void CropImageFilter.setProperties​(Hashtable<?,?> props)
      在添加指定裁剪区域的属性后，沿着源对象的属性传递。
      void ImageConsumer.setProperties​(Hashtable<?,?> props)
      设置与此映像关联的属性的可扩展列表。
      void ImageFilter.setProperties​(Hashtable<?,?> props)
      在添加一个指示已经运行的过滤器流的属性之后，从源对象传递属性。
      void PixelGrabber.setProperties​(Hashtable<?,?> props)
      setProperties方法是ImageConsumer API的一部分，该类必须实现以检索像素。
      void ReplicateScaleFilter.setProperties​(Hashtable<?,?> props)
      在添加指示应用比例的属性后，沿着属性从源对象传递。
      Constructors in java.awt.image with parameters of type Hashtable
      Constructor 描述
      BufferedImage​(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
      构造一个新的 BufferedImage与指定的 ColorModel和 Raster 。
      MemoryImageSource​(int w, int h, int[] pix, int off, int scan, Hashtable<?,?> props)
      构造一个ImageProducer对象，它使用默认RGB ColorModel中的整数数组来生成一个Image对象的数据。
      MemoryImageSource​(int w, int h, ColorModel cm, byte[] pix, int off, int scan, Hashtable<?,?> props)
      构造一个ImageProducer对象，它使用一个字节数组来生成一个Image对象的数据。
      MemoryImageSource​(int w, int h, ColorModel cm, int[] pix, int off, int scan, Hashtable<?,?> props)
      构造一个ImageProducer对象，该对象使用整数数组来生成Image对象的数据。

    • Uses of Hashtable in java.security

      Subclasses of Hashtable in java.security
      Modifier and Type Class 描述
      class  AuthProvider
      此类为提供程序定义登录和注销方法。
      class  Provider
      该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。

    • Uses of Hashtable in java.util

      Subclasses of Hashtable in java.util
      Modifier and Type Class 描述
      class  Properties
      Properties类表示一组持久的属性。

    • Uses of Hashtable in javax.management

      Methods in javax.management that return Hashtable
      Modifier and Type 方法 描述
      Hashtable<String,String> ObjectName.getKeyPropertyList​()
      将关键属性作为Hashtable返回。
      Methods in javax.management with parameters of type Hashtable
      Modifier and Type 方法 描述
      static ObjectName ObjectName.getInstance​(String domain, Hashtable<String,String> table)
      返回一个ObjectName的实例，可以在任何可以使用 new ObjectName(domain, table)获得的对象的地方使用。
      Constructors in javax.management with parameters of type Hashtable
      Constructor 描述
      ObjectName​(String domain, Hashtable<String,String> table)
      从Hashtable构造具有多个关键属性的对象名称。

    • Uses of Hashtable in javax.naming

      Fields in javax.naming declared as Hashtable
      Modifier and Type Field 描述
      protected Hashtable<?,?> CannotProceedException.environment
      包含与Context或DirContext方法无关的环境。
      protected Hashtable<Object,Object> InitialContext.myProps
      与此InitialContext关联的环境。
      Methods in javax.naming that return Hashtable
      Modifier and Type | 方法 | 描述
      Hashtable<?,?> CannotProceedException.getEnvironment​()
      检索创建此异常时生效的环境。
      Hashtable<?,?> Context.getEnvironment​()
      检索此环境有效的环境。
      Hashtable<?,?> | InitialContext.getEnvironment​()
      Methods in javax.naming with parameters of type Hashtable
      Modifier and Type 方法 描述
      abstract Context ReferralException.getReferralContext​(Hashtable<?,?> env)
      检索使用环境属性继续该方法的上下文。
      protected void InitialContext.init​(Hashtable<?,?> environment)
      使用提供的环境初始化初始上下文。
      void CannotProceedException.setEnvironment​(Hashtable<?,?> environment)
      设置调用getEnvironment（）时将返回的环境。
      Constructors in javax.naming with parameters of type Hashtable
      Constructor 描述
      InitialContext​(Hashtable<?,?> environment)
      使用提供的环境构建初始上下文。

    • Uses of Hashtable in javax.naming.directory

      Constructors in javax.naming.directory with parameters of type Hashtable
      Constructor 描述
      InitialDirContext​(Hashtable<?,?> environment)
      使用提供的环境构建初始DirContext。

    • Uses of Hashtable in javax.naming.ldap

      Methods in javax.naming.ldap with parameters of type Hashtable
      Modifier and Type 方法 描述
      static Control ControlFactory.getControlInstance​(Control ctl, Context ctx, Hashtable<?,?> env)
      使用已知的控制工厂创建控制。
      abstract Context LdapReferralException.getReferralContext​(Hashtable<?,?> env)
      检索使用环境属性继续该方法的上下文，而不使用控件。
      abstract Context LdapReferralException.getReferralContext​(Hashtable<?,?> env, Control[] reqCtls)
      检索使用请求控件和环境属性继续该方法的上下文。
      Constructors in javax.naming.ldap with parameters of type Hashtable
      Constructor 描述
      InitialLdapContext​(Hashtable<?,?> environment, Control[] connCtls)
      使用环境属性和连接请求控件构造初始上下文。

    • Uses of Hashtable in javax.naming.spi

      Methods in javax.naming.spi with parameters of type Hashtable
      Modifier and Type 方法 描述
      InitialContextFactory InitialContextFactoryBuilder.createInitialContextFactory​(Hashtable<?,?> environment)
      使用指定的环境创建一个初始上下文工厂。
      ObjectFactory ObjectFactoryBuilder.createObjectFactory​(Object obj, Hashtable<?,?> environment)
      使用提供的环境创建一个新的对象工厂。
      Context InitialContextFactory.getInitialContext​(Hashtable<?,?> environment)
      创建起始名称解析的初始上下文。
      static Context NamingManager.getInitialContext​(Hashtable<?,?> env)
      使用指定的环境属性创建初始上下文。
      static Object DirectoryManager.getObjectInstance​(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      为指定的对象，属性和环境创建一个对象的实例。
      Object DirObjectFactory.getObjectInstance​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      使用位置或参考信息和指定的属性创建对象。
      static Object NamingManager.getObjectInstance​(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)
      为指定的对象和环境创建一个对象的实例。
      Object ObjectFactory.getObjectInstance​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      使用指定的位置或引用信息创建对象。
      static DirStateFactory.Result DirectoryManager.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      当给定原始对象及其属性时，检索绑定对象的状态。
      DirStateFactory.Result DirStateFactory.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
      在给定要转换的对象和属性的情况下，检索绑定对象的状态。
      static Object NamingManager.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      检索绑定对象的状态。
      Object StateFactory.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      检索绑定对象的状态。
      static Context NamingManager.getURLContext​(String scheme, Hashtable<?,?> environment)
      为给定的URL方案ID创建上下文。

    • Uses of Hashtable in javax.swing

      Subclasses of Hashtable in javax.swing
      Modifier and Type Class 描述
      class  UIDefaults
      Swing组件的默认表。
      Fields in javax.swing declared as Hashtable
      Modifier and Type Field 描述
      protected Hashtable<Object,Object> JTable.defaultEditorsByColumnClass
      显示和编辑单元格内容的对象表，按 TableModel接口的 getColumnClass中声明的类进行索引。
      protected Hashtable<Object,Object> JTable.defaultRenderersByColumnClass
      一个显示单元格内容的对象表，由 TableModel接口中的 getColumnClass中声明的类索引。
      Methods in javax.swing that return Hashtable
      Modifier and Type 方法 描述
      Hashtable<Integer,JComponent> JSlider.createStandardLabels​(int increment)
      创建一个 Hashtable的数字文本标签，从滑块最小值开始，并使用指定的增量。
      Hashtable<Integer,JComponent> JSlider.createStandardLabels​(int increment, int start)
      创建一个 Hashtable的数字文本标签，从指定的起始点开始，并使用指定的增量。
      protected Hashtable<Component,Integer> JLayeredPane.getComponentToLayer​()
      返回将组件映射到图层的散列表。
      Constructors in javax.swing with parameters of type Hashtable
      Constructor 描述
      JTree​(Hashtable<?,?> value)
      返回一个 JTree创建的 Hashtable ，它不会用root显示。

    • Uses of Hashtable in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as Hashtable
      Modifier and Type Field 描述
      protected Hashtable<TreePath,Boolean> BasicTreeUI.drawingCache
      用于最小化垂直线的绘图。
      protected Hashtable<File,Icon> BasicFileChooserUI.BasicFileView.iconCache
      图标缓存

    • Uses of Hashtable in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as Hashtable
      Modifier and Type Field 描述
      Hashtable<String,Element> DTD.elementHash
      散列表包含元素的名称和相应的元素。
      Hashtable<Object,Entity> DTD.entityHash
      哈希表包含一个 Object和相应的 Entity

    • Uses of Hashtable in javax.swing.undo

      Fields in javax.swing.undo declared as Hashtable
      Modifier and Type Field 描述
      protected Hashtable<Object,Object> StateEdit.postState
      编辑后的状态信息
      protected Hashtable<Object,Object> StateEdit.preState
      编辑前的状态信息
      Methods in javax.swing.undo with parameters of type Hashtable
      Modifier and Type 方法 描述
      void StateEditable.restoreState​(Hashtable<?,?> state)
      收到该消息后，接收方应将任何相关状态提取出 状态 。
      void StateEditable.storeState​(Hashtable<Object,Object> state)
      收到该消息后，接收方应将任何相关状态置于 状态 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.IdentityHashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.IdentityHashMap

No usage of java.util.IdentityHashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.IllegalFormatCodePointException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.IllegalFormatCodePointException

No usage of java.util.IllegalFormatCodePointException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.IllegalFormatConversionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.IllegalFormatConversionException

No usage of java.util.IllegalFormatConversionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.IllegalFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.IllegalFormatException

  • Packages that use IllegalFormatException
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of IllegalFormatException in java.util

      Subclasses of IllegalFormatException in java.util
      Modifier and Type Class 描述
      class  DuplicateFormatFlagsException
      在格式说明符中提供重复标志时抛出未经检查的异常。
      class  FormatFlagsConversionMismatchException
      转换和标志不兼容时抛出未经检查的异常。
      class  IllegalFormatCodePointException
      当一个具有无效Unicode代码的字符由Character.isValidCodePoint(int)定义的字符传递给Formatter时，会抛出未检查的异常。
      class  IllegalFormatConversionException
      当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。
      class  IllegalFormatFlagsException
      提供非法组合标志时抛出未检查的异常。
      class  IllegalFormatPrecisionException
      当精度为 -1以外的负值时，抛出未检查的异常，转换不支持精度，否则不支持该值。
      class  IllegalFormatWidthException
      当格式宽度为 -1以外的否定值时，抛出未经检查的异常，否则不受支持。
      class  MissingFormatArgumentException
      当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。
      class  MissingFormatWidthException
      需要格式宽度时抛出未检查的异常。
      class  UnknownFormatConversionException
      给出未知转换时抛出未检查的异常。
      class  UnknownFormatFlagsException
      给定未知标志时抛出未检查的异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.IllegalFormatFlagsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.IllegalFormatFlagsException

No usage of java.util.IllegalFormatFlagsException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.IllegalFormatPrecisionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.IllegalFormatPrecisionException

No usage of java.util.IllegalFormatPrecisionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.IllegalFormatWidthException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.IllegalFormatWidthException

No usage of java.util.IllegalFormatWidthException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.IllformedLocaleException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.IllformedLocaleException

No usage of java.util.IllformedLocaleException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.InputMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.InputMismatchException

No usage of java.util.InputMismatchException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.IntSummaryStatistics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.IntSummaryStatistics

  • Packages that use IntSummaryStatistics
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntSummaryStatistics in java.util

      Methods in java.util with parameters of type IntSummaryStatistics
      Modifier and Type 方法 描述
      void IntSummaryStatistics.combine​(IntSummaryStatistics other)
      将另一个 IntSummaryStatistics的状态合并到一个。

    • Uses of IntSummaryStatistics in java.util.stream

      Methods in java.util.stream that return IntSummaryStatistics
      Modifier and Type 方法 描述
      IntSummaryStatistics IntStream.summaryStatistics​()
      返回一个 IntSummaryStatistics描述有关此流的元素的各种摘要数据。
      Methods in java.util.stream that return types with arguments of type IntSummaryStatistics
      Modifier and Type 方法 描述
      static <T> Collector<T,?,IntSummaryStatistics> Collectors.summarizingInt​(ToIntFunction<? super T> mapper)
      返回一个 Collector ， int生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.InvalidPropertiesFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.InvalidPropertiesFormatException

  • Packages that use InvalidPropertiesFormatException
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of InvalidPropertiesFormatException in java.util

      Methods in java.util that throw InvalidPropertiesFormatException
      Modifier and Type 方法 描述
      void Properties.loadFromXML​(InputStream in)
      将指定输入流中的XML文档表示的所有属性加载到此属性表中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.LinkedHashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.LinkedHashMap

No usage of java.util.LinkedHashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.LinkedHashSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.LinkedHashSet

No usage of java.util.LinkedHashSet
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.LinkedList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.LinkedList

  • Packages that use LinkedList
    软件包 描述
    javafx.fxml
    包含用于从标记加载对象层次结构的类。

    • Uses of LinkedList in javafx.fxml

      Constructors in javafx.fxml with parameters of type LinkedList
      Constructor 描述
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)
      创建一个新的FXMLLoader实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.ListResourceBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.ListResourceBundle

  • Packages that use ListResourceBundle
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。

    • Uses of ListResourceBundle in javax.accessibility

      Subclasses of ListResourceBundle in javax.accessibility
      Modifier and Type Class 描述
      class  AccessibleResourceBundle
      已过时。
      从Java平台1.3版开始，此类已被弃用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Locale (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Locale

  • Packages that use Locale
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.spi
    java.util包中类的服务提供者类。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.plugins.bmp
    包含内置BMP插件使用的公共类的软件包。
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.security.auth.callback
    该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.datatype
    定义XML / Java类型映射。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。
    org.xml.sax
    提供核心SAX API。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of Locale in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return Locale
      Modifier and Type 方法 描述
      Locale Translator.getLocale​()
      获取组件的 Locale 。

    • Uses of Locale in java.applet

      Methods in java.applet that return Locale
      Modifier and Type 方法 描述
      Locale Applet.getLocale​()
      已过时。
      获取小程序的区域设置。

    • Uses of Locale in java.awt

      Methods in java.awt that return Locale
      Modifier and Type 方法 描述
      Locale Component.AccessibleAWTComponent.getLocale​()
      返回此对象的区域设置。
      Locale Component.getLocale​()
      获取此组件的区域设置。
      Locale List.AccessibleAWTList.AccessibleAWTListChild.getLocale​()
      获取组件的区域设置。
      Locale MenuComponent.AccessibleAWTMenuComponent.getLocale​()
      返回此对象的区域设置。
      Locale Window.getLocale​()
      获取与此窗口相关联的 Locale对象（如果已设置了语言环境）。
      Methods in java.awt with parameters of type Locale
      Modifier and Type 方法 描述
      abstract String[] GraphicsEnvironment.getAvailableFontFamilyNames​(Locale l)
      返回一个包含本地化为指定区域设置的 GraphicsEnvironment中所有字体族的名称的数组。
      String Font.getFamily​(Locale l)
      返回此 Font的家族名称，该名称已针对指定的区域设置进行本地化。
      String Font.getFontName​(Locale l)
      返回 Font的字体名称，该名称已针对指定的区域设置进行本地化。
      static ComponentOrientation ComponentOrientation.getOrientation​(Locale locale)
      返回适合给定区域设置的方向。
      void Component.setLocale​(Locale l)
      设置此组件的区域设置。

    • Uses of Locale in java.awt.im

      Methods in java.awt.im that return Locale
      Modifier and Type 方法 描述
      Locale InputContext.getLocale​()
      返回当前输入法或键盘布局的当前语言环境。
      Methods in java.awt.im with parameters of type Locale
      Modifier and Type 方法 描述
      boolean InputContext.selectInputMethod​(Locale locale)
      尝试选择支持给定区域设置的输入法或键盘布局，并返回一个值，该值指示是否已成功选择此类输入法或键盘布局。

    • Uses of Locale in java.awt.im.spi

      Methods in java.awt.im.spi that return Locale
      Modifier and Type 方法 描述
      Locale[] InputMethodDescriptor.getAvailableLocales​()
      返回相应输入法支持的语言环境。
      Locale InputMethod.getLocale​()
      返回当前的输入区域设置。
      Methods in java.awt.im.spi with parameters of type Locale
      Modifier and Type 方法 描述
      String InputMethodDescriptor.getInputMethodDisplayName​(Locale inputLocale, Locale displayLanguage)
      以显示名称的语言返回给定输入区域设置的相应输入法的用户可见名称。
      Image InputMethodDescriptor.getInputMethodIcon​(Locale inputLocale)
      返回相应输入法的图标。
      boolean InputMethod.setLocale​(Locale locale)
      尝试设置输入区域设置。

    • Uses of Locale in java.beans.beancontext

      Fields in java.beans.beancontext declared as Locale
      Modifier and Type Field 描述
      protected Locale BeanContextSupport.locale
      此BeanContext的当前区域设置。
      Methods in java.beans.beancontext that return Locale
      Modifier and Type 方法 描述
      Locale BeanContextSupport.getLocale​()
      获取此 BeanContext为 BeanContext 。
      Methods in java.beans.beancontext with parameters of type Locale
      Modifier and Type 方法 描述
      void BeanContextSupport.setLocale​(Locale newLocale)
      设置此BeanContext的区域设置。
      Constructors in java.beans.beancontext with parameters of type Locale
      Constructor 描述
      BeanContextServicesSupport​(BeanContextServices peer, Locale lcle)
      使用指定的区域设置创建一个实例
      BeanContextServicesSupport​(BeanContextServices peer, Locale lcle, boolean dtime)
      使用指定的区域设置和设计模式创建一个实例。
      BeanContextServicesSupport​(BeanContextServices peer, Locale lcle, boolean dTime, boolean visible)
      构造一个BeanContextServicesSupport实例
      BeanContextSupport​(BeanContext peer, Locale lcle)
      使用指定的区域设置创建一个实例
      BeanContextSupport​(BeanContext peer, Locale lcle, boolean dtime)
      使用指定的区域设置和设计模式创建一个实例。
      BeanContextSupport​(BeanContext peer, Locale lcle, boolean dTime, boolean visible)
      200新新新新200新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗200新新旗新新200新

    • Uses of Locale in java.io

      Methods in java.io with parameters of type Locale
      Modifier and Type 方法 描述
      PrintStream PrintStream.format​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流。
      PrintWriter PrintWriter.format​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此写入程序。
      PrintStream PrintStream.printf​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。
      PrintWriter PrintWriter.printf​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。

    • Uses of Locale in java.lang

      Methods in java.lang with parameters of type Locale
      Modifier and Type 方法 描述
      static String String.format​(Locale l, String format, Object... args)
      使用指定的区域设置，格式字符串和参数返回格式化的字符串。
      String String.toLowerCase​(Locale locale)
      将 String所有字符转换为小写，使用给定的 Locale的规则。
      String String.toUpperCase​(Locale locale)
      将此 String所有字符转换为大写，使用给定的 Locale的规则。

    • Uses of Locale in java.nio.charset

      Methods in java.nio.charset with parameters of type Locale
      Modifier and Type 方法 描述
      String Charset.displayName​(Locale locale)
      返回此字符集的给定语言环境的人类可读名称。

    • Uses of Locale in java.text

      Methods in java.text that return Locale
      Modifier and Type 方法 描述
      static Locale[] BreakIterator.getAvailableLocales​()
      返回一个所有语言环境的数组，该类的 get*Instance方法可以返回本地化实例。
      static Locale[] Collator.getAvailableLocales​()
      返回一个所有语言环境的数组，该类的 getInstance方法可以返回本地化实例。
      static Locale[] DateFormat.getAvailableLocales​()
      返回一个所有语言环境的数组，该类的 get*Instance方法可以返回本地化实例。
      static Locale[] DateFormatSymbols.getAvailableLocales​()
      返回一个所有区域的数组，该类的 getInstance方法可以返回本地化实例。
      static Locale[] DecimalFormatSymbols.getAvailableLocales​()
      返回一个所有区域设置的数组， getInstance方法可以返回本地化实例。
      static Locale[] NumberFormat.getAvailableLocales​()
      返回一个所有区域设置的数组，该类的 get*Instance方法可以返回本地化实例。
      Locale MessageFormat.getLocale​()
      获取创建或比较子格式时使用的区域设置。
      Methods in java.text with parameters of type Locale
      Modifier and Type 方法 描述
      static BreakIterator BreakIterator.getCharacterInstance​(Locale locale)
      返回一个新 BreakIterator例如 character breaks给定语言环境。
      static NumberFormat NumberFormat.getCurrencyInstance​(Locale inLocale)
      返回指定区域设置的货币格式。
      static DateFormat DateFormat.getDateInstance​(int style, Locale aLocale)
      获取给定区域设置的给定格式化样式的日期格式化程序。
      static DateFormat DateFormat.getDateTimeInstance​(int dateStyle, int timeStyle, Locale aLocale)
      获取给定区域设置的给定格式样式的日期/时间格式化程序。
      static Collator Collator.getInstance​(Locale desiredLocale)
      获取所需语言环境的Collator。
      static DateFormatSymbols DateFormatSymbols.getInstance​(Locale locale)
      获取指定区域设置的 DateFormatSymbols实例。
      static DecimalFormatSymbols DecimalFormatSymbols.getInstance​(Locale locale)
      获取指定区域设置的 DecimalFormatSymbols实例。
      static NumberFormat NumberFormat.getInstance​(Locale inLocale)
      返回指定区域设置的通用数字格式。
      static NumberFormat NumberFormat.getIntegerInstance​(Locale inLocale)
      返回指定区域设置的整数格式。
      static BreakIterator BreakIterator.getLineInstance​(Locale locale)
      返回一个新 BreakIterator例如 line breaks给定语言环境。
      static NumberFormat NumberFormat.getNumberInstance​(Locale inLocale)
      返回指定区域设置的通用数字格式。
      static NumberFormat NumberFormat.getPercentInstance​(Locale inLocale)
      返回指定区域设置的百分比格式。
      static BreakIterator BreakIterator.getSentenceInstance​(Locale locale)
      返回一个新 BreakIterator例如 sentence breaks给定语言环境。
      static DateFormat DateFormat.getTimeInstance​(int style, Locale aLocale)
      获取给定区域设置的给定格式化样式的时间格式化程序。
      static BreakIterator BreakIterator.getWordInstance​(Locale locale)
      返回一个新 BreakIterator例如 word breaks给定语言环境。
      void MessageFormat.setLocale​(Locale locale)
      设置创建或比较子格式时要使用的区域设置。
      Constructors in java.text with parameters of type Locale
      Constructor 描述
      DateFormatSymbols​(Locale locale)
      通过从给定语言环境的资源加载格式数据构造DateFormatSymbols对象。
      DecimalFormatSymbols​(Locale locale)
      为给定的区域设置创建一个DecimalFormatSymbols对象。
      MessageFormat​(String pattern, Locale locale)
      为指定的区域设置和模式构造一个MessageFormat。
      SimpleDateFormat​(String pattern, Locale locale)
      构造一个 SimpleDateFormat使用给定的模式和给定语言环境的默认日期格式符号。

    • Uses of Locale in java.text.spi

      Methods in java.text.spi with parameters of type Locale
      Modifier and Type 方法 描述
      abstract BreakIterator BreakIteratorProvider.getCharacterInstance​(Locale locale)
      返回一个新 BreakIterator例如 character breaks给定语言环境。
      abstract NumberFormat NumberFormatProvider.getCurrencyInstance​(Locale locale)
      返回一个新的 NumberFormat实例，它为指定的区域设置格式化货币值。
      abstract DateFormat DateFormatProvider.getDateInstance​(int style, Locale locale)
      返回一个新的 DateFormat实例，其格式为指定区域设置的给定格式化样式的日期。
      abstract DateFormat DateFormatProvider.getDateTimeInstance​(int dateStyle, int timeStyle, Locale locale)
      返回一个新的 DateFormat实例，该实例使用指定区域设置的给定格式化样式格式化日期和时间。
      abstract Collator CollatorProvider.getInstance​(Locale locale)
      返回指定区域设置的新的 Collator实例。
      abstract DateFormatSymbols DateFormatSymbolsProvider.getInstance​(Locale locale)
      返回指定区域设置的新的 DateFormatSymbols实例。
      abstract DecimalFormatSymbols DecimalFormatSymbolsProvider.getInstance​(Locale locale)
      返回指定区域设置的新的 DecimalFormatSymbols实例。
      abstract NumberFormat NumberFormatProvider.getIntegerInstance​(Locale locale)
      返回一个新的 NumberFormat实例，它为指定的区域设置格式化整数值。
      abstract BreakIterator BreakIteratorProvider.getLineInstance​(Locale locale)
      返回一个新 BreakIterator例如 line breaks给定语言环境。
      abstract NumberFormat NumberFormatProvider.getNumberInstance​(Locale locale)
      返回指定区域设置的新通用 NumberFormat实例。
      abstract NumberFormat NumberFormatProvider.getPercentInstance​(Locale locale)
      返回一个新的 NumberFormat实例，用于格式化指定区域设置的百分比值。
      abstract BreakIterator BreakIteratorProvider.getSentenceInstance​(Locale locale)
      返回一个新 BreakIterator例如 sentence breaks给定语言环境。
      abstract DateFormat DateFormatProvider.getTimeInstance​(int style, Locale locale)
      返回一个新的 DateFormat实例，用于指定区域设置的给定格式化样式格式化时间。
      abstract BreakIterator BreakIteratorProvider.getWordInstance​(Locale locale)
      返回一个新 BreakIterator例如 word breaks给定语言环境。

    • Uses of Locale in java.time

      Methods in java.time with parameters of type Locale
      Modifier and Type 方法 描述
      String DayOfWeek.getDisplayName​(TextStyle style, Locale locale)
      获取文本表示，如“星期一”或“星期五”。
      String Month.getDisplayName​(TextStyle style, Locale locale)
      获取文本表示，如“1月”或“12月”。
      String ZoneId.getDisplayName​(TextStyle style, Locale locale)
      获取区域的文字表示，例如“英国时间”或“+02：00”。

    • Uses of Locale in java.time.chrono

      Methods in java.time.chrono with parameters of type Locale
      Modifier and Type 方法 描述
      default String Chronology.getDisplayName​(TextStyle style, Locale locale)
      获取这个年表的文本表示。
      default String Era.getDisplayName​(TextStyle style, Locale locale)
      获得这个时代的文字表现。
      String JapaneseEra.getDisplayName​(TextStyle style, Locale locale)
      获得这个时代的文字表现。
      static Chronology Chronology.ofLocale​(Locale locale)
      从一个地区获取一个 Chronology的实例。

    • Uses of Locale in java.time.format

      Methods in java.time.format that return Locale
      Modifier and Type 方法 描述
      Locale DateTimeFormatter.getLocale​()
      获取格式化期间要使用的区域设置。
      Methods in java.time.format that return types with arguments of type Locale
      Modifier and Type 方法 描述
      static Set<Locale> DecimalStyle.getAvailableLocales​()
      列出支持的所有语言环境。
      Methods in java.time.format with parameters of type Locale
      Modifier and Type 方法 描述
      static String DateTimeFormatterBuilder.getLocalizedDateTimePattern​(FormatStyle dateStyle, FormatStyle timeStyle, Chronology chrono, Locale locale)
      获取区域设置和时间顺序的日期和时间样式的格式模式。
      static DecimalStyle DecimalStyle.of​(Locale locale)
      获取指定区域设置的DecimalStyle。
      static DateTimeFormatter DateTimeFormatter.ofPattern​(String pattern, Locale locale)
      使用指定的模式和区域设置创建格式化程序。
      DateTimeFormatter DateTimeFormatterBuilder.toFormatter​(Locale locale)
      通过使用指定的区域设置创建 DateTimeFormatter来完成此构建器。
      DateTimeFormatter DateTimeFormatter.withLocale​(Locale locale)
      使用新的语言环境返回此格式化程序的副本。

    • Uses of Locale in java.time.temporal

      Methods in java.time.temporal with parameters of type Locale
      Modifier and Type | 方法 | 描述
      String | ChronoField.getDisplayName​(Locale locale)
      default String TemporalField.getDisplayName​(Locale locale)
      获取所请求语言环境中字段的显示名称。
      static WeekFields WeekFields.of​(Locale locale)
      获取一个适合于语言环境的 WeekFields的实例。

    • Uses of Locale in java.util

      Fields in java.util declared as Locale
      Modifier and Type Field 描述
      static Locale Locale.CANADA
      对国家有用的常数。
      static Locale Locale.CANADA_FRENCH
      对国家有用的常数。
      static Locale Locale.CHINA
      对国家有用的常数。
      static Locale Locale.CHINESE
      有用的语言常数
      static Locale Locale.ENGLISH
      有用的语言常数
      static Locale Locale.FRANCE
      对国家有用的常数。
      static Locale Locale.FRENCH
      有用的语言常数
      static Locale Locale.GERMAN
      有用的语言常数
      static Locale Locale.GERMANY
      对国家有用的常数。
      static Locale Locale.ITALIAN
      有用的语言常数
      static Locale Locale.ITALY
      对国家有用的常数。
      static Locale Locale.JAPAN
      对国家有用的常数。
      static Locale Locale.JAPANESE
      有用的语言常数
      static Locale Locale.KOREA
      对国家有用的常数。
      static Locale Locale.KOREAN
      有用的语言常数
      static Locale Locale.PRC
      对国家有用的常数。
      static Locale Locale.ROOT
      根区域的常用常数。
      static Locale Locale.SIMPLIFIED_CHINESE
      有用的语言常数
      static Locale Locale.TAIWAN
      对国家有用的常数。
      static Locale Locale.TRADITIONAL_CHINESE
      有用的语言常数
      static Locale Locale.UK
      对国家有用的常数。
      static Locale Locale.US
      对国家有用的常数。
      Methods in java.util that return Locale
      Modifier and Type 方法 描述
      Locale Locale.Builder.build​()
      返回从此构建器上设置的字段创建的 Locale实例。
      static Locale Locale.forLanguageTag​(String languageTag)
      返回指定的IETF BCP 47语言标记字符串的语言环境。
      static Locale[] Calendar.getAvailableLocales​()
      返回一个所有语言环境的数组，该类的 getInstance方法可以返回本地化实例。
      static Locale[] Locale.getAvailableLocales​()
      返回所有已安装区域设置的数组。
      static Locale Locale.getDefault​()
      获取Java虚拟机的此实例的默认语言环境的当前值。
      static Locale Locale.getDefault​(Locale.Category category)
      获取Java虚拟机的此实例的指定类别的默认语言环境的当前值。
      Locale ResourceBundle.Control.getFallbackLocale​(String baseName, Locale locale)
      返回一个 Locale ，以作为后备区域设置，用于通过 ResourceBundle.getBundle工厂方法进一步查找资源。
      Locale ResourceBundle.getLocale​()
      返回此资源包的区域设置。
      Locale Formatter.locale​()
      返回通过构建此格式化程序设置的区域设置。
      Locale Scanner.locale​()
      返回此扫描仪的区域设置。
      static Locale Locale.lookup​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的查找机制返回匹配最佳语言标签的 Locale实例。
      Locale Locale.stripExtensions​()
      返回此 Locale的副本，不 包含extensions 。
      Methods in java.util that return types with arguments of type Locale
      Modifier and Type 方法 描述
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例列表。
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales, Locale.FilteringMode mode)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
      List<Locale> ResourceBundle.Control.getCandidateLocales​(String baseName, Locale locale)
      返回 List的 Locale作为 baseName和 locale候选地区。
      Methods in java.util with parameters of type Locale
      Modifier and Type 方法 描述
      Formatter Formatter.format​(Locale l, String format, Object... args)
      使用指定的区域设置，格式字符串和参数将格式化的字符串写入此对象的目标。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale locale)
      使用指定的基本名称和区域设置以及调用者的类加载器获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale locale, ClassLoader loader)
      使用指定的基本名称，区域设置和类加载器获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)
      使用指定的基本名称，目标语言环境，类加载器和控件返回资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, Module module)
      使用指定的基本名称和区域设置代替指定的模块获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, ResourceBundle.Control control)
      使用指定的基本名称，目标语言环境和控件以及调用者的类加载器返回资源包。
      List<Locale> ResourceBundle.Control.getCandidateLocales​(String baseName, Locale locale)
      返回 List的 Locale S作为候选语言环境为 baseName和 locale 。
      String Locale.getDisplayCountry​(Locale inLocale)
      返回适合显示给用户的区域设置国家/地区的名称。
      String Locale.getDisplayLanguage​(Locale inLocale)
      返回适合显示给用户的语言环境语言的名称。
      String Calendar.getDisplayName​(int field, int style, Locale locale)
      返回给定的 style和 locale中的日历 field的字符串表示。
      String Currency.getDisplayName​(Locale locale)
      获取适用于显示指定区域设置的货币的名称。
      String Locale.getDisplayName​(Locale inLocale)
      返回适合显示给用户的区域设置的名称。
      String TimeZone.getDisplayName​(boolean daylight, int style, Locale locale)
      返回此 TimeZone指定的 style中的一个名称，适用于在指定的 style中向用户 locale 。
      String TimeZone.getDisplayName​(Locale locale)
      返回适合在指定的 locale向用户呈现的 TimeZone的长标准时间名称。
      Map<String,Integer> Calendar.getDisplayNames​(int field, int style, Locale locale)
      返回一个 Map其中包含给定的 style和 locale中的日历 field所有名称及其对应的字段值。
      String Locale.getDisplayScript​(Locale inLocale)
      返回适合显示给用户的区域设置脚本的名称。
      String Locale.getDisplayVariant​(Locale inLocale)
      返回适合显示给用户的区域设置变体代码的名称。
      Locale ResourceBundle.Control.getFallbackLocale​(String baseName, Locale locale)
      返回 Locale ，以作为后备区域设置，用于通过 ResourceBundle.getBundle工厂方法进一步查找资源。
      static Calendar Calendar.getInstance​(Locale aLocale)
      使用默认时区和指定的区域设置获取日历。
      static Calendar Calendar.getInstance​(TimeZone zone, Locale aLocale)
      获取具有指定时区和区域设置的日历。
      static Currency Currency.getInstance​(Locale locale)
      返回给定区域的国家/地区的 Currency实例。
      String Currency.getSymbol​(Locale locale)
      获取指定区域设置的货币符号。
      long ResourceBundle.Control.getTimeToLive​(String baseName, Locale locale)
      返回此 ResourceBundle.Control下加载的资源束的生存时间（TTL）值。
      boolean ResourceBundle.Control.needsReload​(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime)
      确定是否需要根据由 loadTime给出的加载时间或其他一些标准重新加载高速缓存中的过期 bundle 。
      ResourceBundle ResourceBundle.Control.newBundle​(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
      为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。
      static void Locale.setDefault​(Locale newLocale)
      设置Java虚拟机的此实例的默认语言环境。
      static void Locale.setDefault​(Locale.Category category, Locale newLocale)
      为Java虚拟机的此实例设置指定类别的默认语言环境。
      Calendar.Builder Calendar.Builder.setLocale​(Locale locale)
      将locale参数设置为给定的 locale 。
      Locale.Builder Locale.Builder.setLocale​(Locale locale)
      复位 Builder以匹配提供的 locale 。
      String ResourceBundle.Control.toBundleName​(String baseName, Locale locale)
      将给定的 baseName和 locale转换为包名称。
      Scanner Scanner.useLocale​(Locale locale)
      将此扫描仪的区域设置设置为指定的区域设置。
      Method parameters in java.util with type arguments of type Locale
      Modifier and Type 方法 描述
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例列表。
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales, Locale.FilteringMode mode)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例列表。
      static Locale Locale.lookup​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的查找机制返回 Locale用于最佳匹配语言标记的实例。
      Constructors in java.util with parameters of type Locale
      Constructor 描述
      Calendar​(TimeZone zone, Locale aLocale)
      构造具有指定时区和区域设置的日历。
      Formatter​(File file, String csn, Locale l)
      使用指定的文件，字符集和区域设置构造一个新的格式化程序。
      Formatter​(OutputStream os, String csn, Locale l)
      使用指定的输出流，字符集和区域设置构造一个新的格式化程序。
      Formatter​(Appendable a, Locale l)
      构造一个具有指定目的地和区域设置的新格式化程序。
      Formatter​(String fileName, String csn, Locale l)
      构造具有指定文件名，字符集和区域设置的新格式化程序。
      Formatter​(Locale l)
      构造具有指定区域设置的新格式化程序。
      GregorianCalendar​(Locale aLocale)
      根据具有给定语言环境的默认时区中的当前时间构建一个 GregorianCalendar 。
      GregorianCalendar​(TimeZone zone, Locale aLocale)
      根据给定时区的当前时间，使用给定的区域设置构建一个 GregorianCalendar 。

    • Uses of Locale in java.util.spi

      Methods in java.util.spi that return Locale
      Modifier and Type 方法 描述
      abstract Locale[] LocaleServiceProvider.getAvailableLocales​()
      返回此区域设置服务提供程序可以为其提供本地化对象或名称的所有区域设置的数组。
      Methods in java.util.spi with parameters of type Locale
      Modifier and Type 方法 描述
      ResourceBundle AbstractResourceBundleProvider.getBundle​(String baseName, Locale locale)
      返回 ResourceBundle为给定 baseName和 locale 。
      ResourceBundle ResourceBundleProvider.getBundle​(String baseName, Locale locale)
      为给定的包名称和区域设置返回一个 ResourceBundle 。
      abstract String LocaleNameProvider.getDisplayCountry​(String countryCode, Locale locale)
      返回给定的 IETF BCP47区域代码（ISO 3166国家代码或UN M.49区域代码）的本地化名称以及适合向用户显示的给定区域。
      abstract String LocaleNameProvider.getDisplayLanguage​(String languageCode, Locale locale)
      返回给定的 IETF BCP47语言代码和适用于向用户显示的给定语言环境的本地化名称。
      abstract String CalendarNameProvider.getDisplayName​(String calendarType, int field, int value, int style, Locale locale)
      返回给定的 style和 locale中的日历 field value的字符串表示（显示名称）。
      String CurrencyNameProvider.getDisplayName​(String currencyCode, Locale locale)
      返回适合显示给用户的货币名称。
      abstract String TimeZoneNameProvider.getDisplayName​(String ID, boolean daylight, int style, Locale locale)
      返回适合在指定语言环境中向用户呈现的给定时区ID的名称。
      abstract Map<String,Integer> CalendarNameProvider.getDisplayNames​(String calendarType, int field, int style, Locale locale)
      返回 Map包含的所有字符串表示（显示名称） Calendar field给定 style和 locale及其相应的字段值。
      String LocaleNameProvider.getDisplayScript​(String scriptCode, Locale locale)
      返回给定的 IETF BCP47脚本代码和适用于向用户显示的给定语言环境的本地化名称。
      abstract String LocaleNameProvider.getDisplayVariant​(String variant, Locale locale)
      返回适用于向用户显示的给定变体代码和给定语言环境的本地化名称。
      abstract int CalendarDataProvider.getFirstDayOfWeek​(Locale locale)
      在给定的 locale返回一周的第一天。
      String TimeZoneNameProvider.getGenericDisplayName​(String ID, int style, Locale locale)
      返回给定时区 ID的通用名称，适用于在指定的 locale向用户 locale 。
      abstract int CalendarDataProvider.getMinimalDaysInFirstWeek​(Locale locale)
      返回一年中第一周所需的最少天数。
      abstract String CurrencyNameProvider.getSymbol​(String currencyCode, Locale locale)
      获取指定区域设置的给定货币代码的符号。
      boolean LocaleServiceProvider.isSupportedLocale​(Locale locale)
      如果本地区服务提供商支持给定的 locale则返回 true 。
      protected String AbstractResourceBundleProvider.toBundleName​(String baseName, Locale locale)
      返回此提供程序提供的给定 baseName和 locale的包名称。

    • Uses of Locale in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type Locale
      Modifier and Type | 方法 | 描述
      StringBinding NumberExpression.asString​(Locale locale, String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      StringBinding | NumberExpressionBase.asString​(Locale locale, String format)
      StringBinding ObjectExpression.asString​(Locale locale, String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      static StringExpression Bindings.format​(Locale locale, String format, Object... args)
      创建一个StringExpression ，其中保存按照格式String和指定的Locale格式化的多个Objects的值

    • Uses of Locale in javafx.scene.media

      Methods in javafx.scene.media that return Locale
      Modifier and Type 方法 描述
      Locale Track.getLocale​()
      Locale指定Track内容格式化的语言，可能指定国家/地区。

    • Uses of Locale in javafx.util.converter

      Fields in javafx.util.converter declared as Locale
      Modifier and Type | Field | 描述
      protected Locale | DateTimeStringConverter.locale
      Constructors in javafx.util.converter with parameters of type Locale
      Constructor 描述
      CurrencyStringConverter​(Locale locale)
      CurrencyStringConverter​(Locale locale, String pattern)
      DateStringConverter​(Locale locale)
      创建StringConverter为Date值，使用指定的语言环境和DateFormat.DEFAULT日期样式。
      DateStringConverter​(Locale locale, int dateStyle)
      创建StringConverter为Date值，使用指定的语言环境和DateFormat日期样式。
      DateStringConverter​(Locale locale, String pattern)
      创建StringConverter为Date值，使用指定的语言环境和模式。
      DateTimeStringConverter​(Locale locale)
      创建一个StringConverter的Date值，使用指定的区域设置和DateFormat.DEFAULT样式的日期和时间。
      DateTimeStringConverter​(Locale locale, int dateStyle, int timeStyle)
      使用Date值创建StringConverter ，使用指定的区域设置和日期和时间的DateFormat样式。
      DateTimeStringConverter​(Locale locale, String pattern)
      使用指定的区域设置和模式创建Date的Date值。
      LocalDateStringConverter​(FormatStyle dateStyle, Locale locale, Chronology chronology)
      创建一个字符串转换LocalDate个使用默认的格式和语法分析器，它会根据所提供的值FormatStyle ， Locale ，并Chronology 。
      LocalDateTimeStringConverter​(FormatStyle dateStyle, FormatStyle timeStyle, Locale locale, Chronology chronology)
      使用默认格式化程序和解析器为LocalDateTime创建一个LocalDateTime值，这将基于所提供的FormatStyle s， Locale和Chronology 。
      LocalTimeStringConverter​(FormatStyle timeStyle, Locale locale)
      创建一个StringConverter为LocalTime值，使用默认格式化程序和解析器与指定的FormatStyle和Locale 。
      NumberStringConverter​(Locale locale)
      NumberStringConverter​(Locale locale, String pattern)
      PercentageStringConverter​(Locale locale)
      TimeStringConverter​(Locale locale)
      使用指定的区域设置和DateFormat.DEFAULT时间样式为Date创建一个StringConverter的值。
      TimeStringConverter​(Locale locale, int timeStyle)
      创建StringConverter的Date值，使用指定的区域设置和DateFormat时间风格。
      TimeStringConverter​(Locale locale, String pattern)
      创建StringConverter为Date值，使用指定的语言环境和模式。

    • Uses of Locale in javax.accessibility

      Methods in javax.accessibility that return Locale
      Modifier and Type 方法 描述
      abstract Locale AccessibleContext.getLocale​()
      获取组件的区域设置。
      Methods in javax.accessibility with parameters of type Locale
      Modifier and Type 方法 描述
      protected String AccessibleBundle.toDisplayString​(String resourceBundleName, Locale locale)
      获取密钥作为本地化字符串。
      String AccessibleBundle.toDisplayString​(Locale locale)
      获取密钥作为本地化字符串。

    • Uses of Locale in javax.annotation.processing

      Methods in javax.annotation.processing that return Locale
      Modifier and Type 方法 描述
      Locale ProcessingEnvironment.getLocale​()
      如果没有语言环境 null则返回当前语言环境或 null 。

    • Uses of Locale in javax.imageio

      Fields in javax.imageio declared as Locale
      Modifier and Type Field 描述
      protected Locale[] ImageReader.availableLocales
      可用于定位警告消息的 Locale s阵列，如果不支持本地化， null 。
      protected Locale[] ImageWriter.availableLocales
      可用于本地化警告消息和压缩设置值的 Locale s阵列，如果不支持本地化， null 。
      protected Locale ImageReader.locale
      目前 Locale用于定位，或 null ;如果没有设置。
      protected Locale ImageWriteParam.locale
      A Locale用于本地化压缩类型名称和质量描述，或 null使用默认值 Locale 。
      protected Locale ImageWriter.locale
      目前 Locale用于定位，或 null ;如果没有设置。
      Fields in javax.imageio with type parameters of type Locale
      Modifier and Type Field 描述
      protected List<Locale> ImageReader.warningLocales
      一个 List的 Locale与每个当前注册的 IIOReadWarningListener相关联，默认初始化为 null ，这是一个空的 List同义词。
      protected List<Locale> ImageWriter.warningLocales
      甲 List的 Locale S，一个用于的每个元素 warningListeners ，默认情况下初始化 null ，它与空同义 List 。
      Methods in javax.imageio that return Locale
      Modifier and Type 方法 描述
      Locale[] ImageReader.getAvailableLocales​()
      返回可用于本地化警告侦听器和压缩设置的 Locale s的数组。
      Locale[] ImageWriter.getAvailableLocales​()
      返回可用于本地化警告侦听器和压缩设置的 Locale的数组。
      Locale ImageReader.getLocale​()
      如果没有设置，返回当前设置的 Locale ，或 null 。
      Locale ImageWriteParam.getLocale​()
      如果仅支持默认值 Locale则返回当前设置的 Locale或 null 。
      Locale ImageWriter.getLocale​()
      如果没有设置，返回当前设置的 Locale或 null 。
      Methods in javax.imageio with parameters of type Locale
      Modifier and Type 方法 描述
      void ImageReader.setLocale​(Locale locale)
      将此 ImageReader的当前 Locale设置为给定值。
      void ImageWriter.setLocale​(Locale locale)
      将此 ImageWriter的当前 Locale设置为给定值。
      Constructors in javax.imageio with parameters of type Locale
      Constructor 描述
      ImageWriteParam​(Locale locale)
      构造一个 ImageWriteParam设置使用给定的 Locale 。

    • Uses of Locale in javax.imageio.metadata

      Methods in javax.imageio.metadata with parameters of type Locale
      Modifier and Type 方法 描述
      String IIOMetadataFormat.getAttributeDescription​(String elementName, String attrName, Locale locale)
      返回 String含有指定属性，或的描述 null 。
      String IIOMetadataFormatImpl.getAttributeDescription​(String elementName, String attrName, Locale locale)
      返回 String含有指定属性，或的描述 null 。
      String IIOMetadataFormat.getElementDescription​(String elementName, Locale locale)
      返回 String含有指定元素，或的描述 null 。
      String IIOMetadataFormatImpl.getElementDescription​(String elementName, Locale locale)
      返回 String含有指定元素，或的描述 null 。

    • Uses of Locale in javax.imageio.plugins.bmp

      Constructors in javax.imageio.plugins.bmp with parameters of type Locale
      Constructor 描述
      BMPImageWriteParam​(Locale locale)
      构造一个 BMPImageWriteParam集，以使用给定的 Locale和所有参数的默认值。

    • Uses of Locale in javax.imageio.plugins.jpeg

      Constructors in javax.imageio.plugins.jpeg with parameters of type Locale
      Constructor 描述
      JPEGImageWriteParam​(Locale locale)
      构造一个 JPEGImageWriteParam 。

    • Uses of Locale in javax.imageio.spi

      Methods in javax.imageio.spi with parameters of type Locale
      Modifier and Type 方法 描述
      abstract String IIOServiceProvider.getDescription​(Locale locale)
      返回此服务提供商及其相关实现的简短可读的描述。

    • Uses of Locale in javax.print.attribute

      Methods in javax.print.attribute that return Locale
      Modifier and Type 方法 描述
      Locale TextSyntax.getLocale​()
      返回此文本属性的文本字符串的自然语言（locale）。
      Constructors in javax.print.attribute with parameters of type Locale
      Constructor 描述
      TextSyntax​(String value, Locale locale)
      构造具有指定字符串和语言环境的TextAttribute。

    • Uses of Locale in javax.print.attribute.standard

      Constructors in javax.print.attribute.standard with parameters of type Locale
      Constructor 描述
      DocumentName​(String documentName, Locale locale)
      使用给定的文档名称和语言环境构造新的文档名称属性。
      JobMessageFromOperator​(String message, Locale locale)
      使用给定的消息和语言环境构造来自operator属性的新作业消息。
      JobName​(String jobName, Locale locale)
      构造具有给定作业名称和区域设置的新作业名称属性。
      JobOriginatingUserName​(String userName, Locale locale)
      构造具有给定用户名和区域设置的新作业发起用户名属性。
      OutputDeviceAssigned​(String deviceName, Locale locale)
      使用给定的设备名称和语言环境构造新的输出设备分配的属性。
      PrinterInfo​(String info, Locale locale)
      使用给定的信息字符串和语言环境构造新的打印机信息属性。
      PrinterLocation​(String location, Locale locale)
      构造具有给定位置和区域设置的新的打印机位置属性。
      PrinterMakeAndModel​(String makeAndModel, Locale locale)
      使用给定的make和model字符串和locale构造一个新的打印机make和model属性。
      PrinterMessageFromOperator​(String message, Locale locale)
      使用给定的消息和区域设置构造来自operator属性的新打印机消息。
      PrinterName​(String printerName, Locale locale)
      构造具有给定名称和区域设置的新的打印机名称属性。
      RequestingUserName​(String userName, Locale locale)
      使用给定的用户名和区域设置构造一个新的请求用户名属性。

    • Uses of Locale in javax.security.auth.callback

      Methods in javax.security.auth.callback that return Locale
      Modifier and Type 方法 描述
      Locale LanguageCallback.getLocale​()
      获取检索到的 Locale 。
      Methods in javax.security.auth.callback with parameters of type Locale
      Modifier and Type 方法 描述
      void LanguageCallback.setLocale​(Locale locale)
      设置检索到的 Locale 。

    • Uses of Locale in javax.swing

      Methods in javax.swing that return Locale
      Modifier and Type | 方法 | 描述
      static Locale JComponent.getDefaultLocale​()
      返回用于在创建时初始化每个JComponent的locale属性的默认区域设置。
      Locale UIDefaults.getDefaultLocale​()
      返回默认语言环境。
      Locale ImageIcon.AccessibleImageIcon.getLocale​()
      返回此对象的区域设置。
      Locale | JList.AccessibleJList.AccessibleJListChild.getLocale​()
      Locale JTable.AccessibleJTable.AccessibleJTableCell.getLocale​()
      获取组件的区域设置。
      Locale JTree.AccessibleJTree.AccessibleJTreeNode.getLocale​()
      获取组件的区域设置。
      Locale ProgressMonitor.AccessibleProgressMonitor.getLocale​()
      获取组件的区域设置。
      Methods in javax.swing with parameters of type Locale
      Modifier and Type 方法 描述
      Object UIDefaults.get​(Object key, Locale l)
      返回与给定语言环境相关联的键的值。
      static Object UIManager.get​(Object key, Locale l)
      从适用于给定语言环境的默认值返回一个对象。
      boolean UIDefaults.getBoolean​(Object key, Locale l)
      如果给定的 Locale的值为 key为boolean，则返回布尔值，否则返回false。
      static boolean UIManager.getBoolean​(Object key, Locale l)
      从与键值和给定的 Locale相关联的默认值返回一个布尔值。
      Border UIDefaults.getBorder​(Object key, Locale l)
      如果 key为 Locale值为 Border返回，否则返回 null 。
      static Border UIManager.getBorder​(Object key, Locale l)
      从适用于给定语言环境的默认值返回一个边框。
      Color UIDefaults.getColor​(Object key, Locale l)
      如果值 key对于给定 Locale是 Color返回它，否则返回 null 。
      static Color UIManager.getColor​(Object key, Locale l)
      从适用于给定语言环境的默认值返回颜色。
      Dimension UIDefaults.getDimension​(Object key, Locale l)
      如果 key的给定 Locale Dimension ，则返回 null ，否则返回 null 。
      static Dimension UIManager.getDimension​(Object key, Locale l)
      从适用于给定语言环境的默认值返回维度。
      Font UIDefaults.getFont​(Object key, Locale l)
      如果给出的 Locale的 key的值是 key ， Font返回它，否则返回 null 。
      static Font UIManager.getFont​(Object key, Locale l)
      从适用于给定语言环境的默认值返回一个字体。
      Icon UIDefaults.getIcon​(Object key, Locale l)
      如果值 key对于给定 Locale是 Icon返回它，否则返回 null 。
      static Icon UIManager.getIcon​(Object key, Locale l)
      从适用于给定语言环境的默认值返回 Icon 。
      Insets UIDefaults.getInsets​(Object key, Locale l)
      如果给出的 Locale的 Insets的值是 key ，则返回 null 。
      static Insets UIManager.getInsets​(Object key, Locale l)
      从适用于给定语言环境的默认值返回 Insets对象。
      int UIDefaults.getInt​(Object key, Locale l)
      如果值 key对于给定 Locale是 Integer返回其整数值，否则返回0。
      static int UIManager.getInt​(Object key, Locale l)
      从适用于给定语言环境的默认值返回一个整数。
      String UIDefaults.getString​(Object key, Locale l)
      如果 key的值为 Locale是 String返回，否则返回 null 。
      static String UIManager.getString​(Object key, Locale l)
      从适用于给定语言环境的默认值返回一个字符串。
      static void JComponent.setDefaultLocale​(Locale l)
      设置用于在创建时初始化每个JComponent的区域设置属性的默认区域设置。
      void UIDefaults.setDefaultLocale​(Locale l)
      设置默认语言环境。

    • Uses of Locale in javax.swing.table

      Methods in javax.swing.table that return Locale
      Modifier and Type | 方法 | 描述
      Locale | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocale​()

    • Uses of Locale in javax.tools

      Methods in javax.tools with parameters of type Locale
      Modifier and Type 方法 描述
      String Diagnostic.getMessage​(Locale locale)
      返回给定区域设置的本地化消息。
      StandardJavaFileManager DocumentationTool.getStandardFileManager​(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      返回此工具的标准文件管理器实现的新实例。
      StandardJavaFileManager JavaCompiler.getStandardFileManager​(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      返回此工具的标准文件管理器实现的新实例。
      void DocumentationTool.DocumentationTask.setLocale​(Locale locale)
      设置在格式化诊断和其他本地化数据时应用的区域设置。
      void JavaCompiler.CompilationTask.setLocale​(Locale locale)
      设置在格式化诊断和其他本地化数据时应用的区域设置。

    • Uses of Locale in javax.xml.datatype

      Methods in javax.xml.datatype with parameters of type Locale
      Modifier and Type 方法 描述
      abstract GregorianCalendar XMLGregorianCalendar.toGregorianCalendar​(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
      将此XMLGregorianCalendar与提供的参数一起转换为GregorianCalendar实例。

    • Uses of Locale in javax.xml.soap

      Methods in javax.xml.soap that return Locale
      Modifier and Type 方法 描述
      Locale SOAPFault.getFaultStringLocale​()
      获取此 SOAPFault对象的故障字符串的区域设置。
      Methods in javax.xml.soap that return types with arguments of type Locale
      Modifier and Type 方法 描述
      Iterator<Locale> SOAPFault.getFaultReasonLocales​()
      返回一个 Iterator了独特序列 Locale对此有关联Reason Text项秒。
      Methods in javax.xml.soap with parameters of type Locale
      Modifier and Type 方法 描述
      SOAPFault SOAPBody.addFault​(QName faultCode, String faultString, Locale locale)
      创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。
      SOAPFault SOAPBody.addFault​(Name faultCode, String faultString, Locale locale)
      创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。
      void SOAPFault.addFaultReasonText​(String text, Locale locale)
      追加或替换包含指定短信的原因文本项目和从 locale派生的 xml：lang 。
      String SOAPFault.getFaultReasonText​(Locale locale)
      返回与给定的 Locale相关联的原因文本。
      void SOAPFault.setFaultString​(String faultString, Locale locale)
      将此 SOAPFault对象的故障字符串设置为给定的字符串，并将其定位到给定的区域设置。

    • Uses of Locale in jdk.javadoc.doclet

      Methods in jdk.javadoc.doclet with parameters of type Locale
      Modifier and Type | 方法 | 描述
      void Doclet.init​(Locale locale, Reporter reporter)
      使用给定的区域设置和错误报告器初始化此doclet。
      void | StandardDoclet.init​(Locale locale, Reporter reporter)

    • Uses of Locale in jdk.jshell

      Methods in jdk.jshell with parameters of type Locale
      Modifier and Type 方法 描述
      abstract String Diag.getMessage​(Locale locale)
      返回给定区域设置的本地化消息。

    • Uses of Locale in jdk.jshell.tool

      Methods in jdk.jshell.tool with parameters of type Locale
      Modifier and Type 方法 描述
      JavaShellToolBuilder JavaShellToolBuilder.locale​(Locale locale)
      设置区域设置。

    • Uses of Locale in org.xml.sax

      Methods in org.xml.sax with parameters of type Locale
      Modifier and Type 方法 描述
      void Parser.setLocale​(Locale locale)
      已过时。
      允许应用程序请求区域设置错误和警告。

    • Uses of Locale in org.xml.sax.helpers

      Methods in org.xml.sax.helpers with parameters of type Locale
      Modifier and Type 方法 描述
      void XMLReaderAdapter.setLocale​(Locale locale)
      设置错误报告的区域设置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Locale.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Locale.Builder

  • Packages that use Locale.Builder
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Locale.Builder in java.util

      Methods in java.util that return Locale.Builder
      Modifier and Type 方法 描述
      Locale.Builder Locale.Builder.addUnicodeLocaleAttribute​(String attribute)
      添加unicode区域设置属性（如果尚未存在），否则不起作用。
      Locale.Builder Locale.Builder.clear​()
      将构建器重置为初始状态。
      Locale.Builder Locale.Builder.clearExtensions​()
      将扩展名重置为初始，空状态。
      Locale.Builder Locale.Builder.removeUnicodeLocaleAttribute​(String attribute)
      删除unicode区域设置属性（如果存在），否则不起作用。
      Locale.Builder Locale.Builder.setExtension​(char key, String value)
      设置给定键的扩展名。
      Locale.Builder Locale.Builder.setLanguage​(String language)
      设置语言。
      Locale.Builder Locale.Builder.setLanguageTag​(String languageTag)
      重置生成器以匹配提供的IETF BCP 47语言标记。
      Locale.Builder Locale.Builder.setLocale​(Locale locale)
      复位 Builder以匹配提供的 locale 。
      Locale.Builder Locale.Builder.setRegion​(String region)
      设置区域。
      Locale.Builder Locale.Builder.setScript​(String script)
      设置脚本。
      Locale.Builder Locale.Builder.setUnicodeLocaleKeyword​(String key, String type)
      设置给定键的Unicode区域设置关键字类型。
      Locale.Builder Locale.Builder.setVariant​(String variant)
      Sets the variant.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Locale.Category (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Locale.Category

  • Packages that use Locale.Category
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Locale.Category in java.util

      Methods in java.util that return Locale.Category
      Modifier and Type 方法 描述
      static Locale.Category Locale.Category.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Locale.Category[] Locale.Category.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.util with parameters of type Locale.Category
      Modifier and Type 方法 描述
      static Locale Locale.getDefault​(Locale.Category category)
      获取Java虚拟机的此实例的指定类别的默认语言环境的当前值。
      static void Locale.setDefault​(Locale.Category category, Locale newLocale)
      为Java虚拟机的此实例设置指定类别的默认语言环境。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Locale.FilteringMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Locale.FilteringMode

  • Packages that use Locale.FilteringMode
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Locale.FilteringMode in java.util

      Methods in java.util that return Locale.FilteringMode
      Modifier and Type 方法 描述
      static Locale.FilteringMode Locale.FilteringMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Locale.FilteringMode[] Locale.FilteringMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.util with parameters of type Locale.FilteringMode
      Modifier and Type 方法 描述
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales, Locale.FilteringMode mode)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
      static List<String> Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags, Locale.FilteringMode mode)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Locale.IsoCountryCode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Locale.IsoCountryCode

  • Packages that use Locale.IsoCountryCode
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Locale.IsoCountryCode in java.util

      Methods in java.util that return Locale.IsoCountryCode
      Modifier and Type 方法 描述
      static Locale.IsoCountryCode Locale.IsoCountryCode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Locale.IsoCountryCode[] Locale.IsoCountryCode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.util with parameters of type Locale.IsoCountryCode
      Modifier and Type 方法 描述
      static Set<String> Locale.getISOCountries​(Locale.IsoCountryCode type)
      返回 Set的指定类型的ISO3166国家代码。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Locale.LanguageRange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Locale.LanguageRange

  • Packages that use Locale.LanguageRange
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Locale.LanguageRange in java.util

      Methods in java.util that return types with arguments of type Locale.LanguageRange
      Modifier and Type 方法 描述
      static List<Locale.LanguageRange> Locale.LanguageRange.mapEquivalents​(List<Locale.LanguageRange> priorityList, Map<String,List<String>> map)
      使用给定的 priorityList和 map生成新的自定义语言优先级列表。
      static List<Locale.LanguageRange> Locale.LanguageRange.parse​(String ranges)
      解析给定的 ranges以生成语言优先级列表。
      static List<Locale.LanguageRange> Locale.LanguageRange.parse​(String ranges, Map<String,List<String>> map)
      解析给定的 ranges以生成语言优先级列表，然后使用给定的 map自定义列表。
      Method parameters in java.util with type arguments of type Locale.LanguageRange
      Modifier and Type 方法 描述
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例列表。
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales, Locale.FilteringMode mode)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
      static List<String> Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      static List<String> Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags, Locale.FilteringMode mode)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      static Locale Locale.lookup​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的查找机制返回 Locale最佳匹配语言标记的实例。
      static String Locale.lookupTag​(List<Locale.LanguageRange> priorityList, Collection<String> tags)
      使用RFC 4647中定义的查找机制返回最匹配的语言标签。
      static List<Locale.LanguageRange> Locale.LanguageRange.mapEquivalents​(List<Locale.LanguageRange> priorityList, Map<String,List<String>> map)
      使用给定的 priorityList和 map生成新的自定义语言优先级列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.LongSummaryStatistics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.LongSummaryStatistics

  • Packages that use LongSummaryStatistics
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongSummaryStatistics in java.util

      Methods in java.util with parameters of type LongSummaryStatistics
      Modifier and Type 方法 描述
      void LongSummaryStatistics.combine​(LongSummaryStatistics other)
      将另一个 LongSummaryStatistics的状态合并到一个。

    • Uses of LongSummaryStatistics in java.util.stream

      Methods in java.util.stream that return LongSummaryStatistics
      Modifier and Type 方法 描述
      LongSummaryStatistics LongStream.summaryStatistics​()
      返回一个描述关于此流的元素的各种摘要数据的 LongSummaryStatistics 。
      Methods in java.util.stream that return types with arguments of type LongSummaryStatistics
      Modifier and Type 方法 描述
      static <T> Collector<T,?,LongSummaryStatistics> Collectors.summarizingLong​(ToLongFunction<? super T> mapper)
      返回一个 Collector ， long映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.MissingFormatArgumentException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.MissingFormatArgumentException

No usage of java.util.MissingFormatArgumentException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.MissingFormatWidthException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.MissingFormatWidthException

No usage of java.util.MissingFormatWidthException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.MissingResourceException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.MissingResourceException

  • Packages that use MissingResourceException
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of MissingResourceException in java.util

      Methods in java.util that throw MissingResourceException
      Modifier and Type 方法 描述
      String Locale.getISO3Country​()
      返回此区域设置的国家/地区的三个字母的缩写。
      String Locale.getISO3Language​()
      返回此语言环境的三个字母缩写。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.NoSuchElementException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.NoSuchElementException

  • Packages that use NoSuchElementException
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of NoSuchElementException in java.util

      Subclasses of NoSuchElementException in java.util
      Modifier and Type Class 描述
      class  InputMismatchException
      由 Scanner抛出，表示检索到的令牌与预期类型的模式不匹配，或令牌超出预期类型的范围。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Objects (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Objects

No usage of java.util.Objects
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Observable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Observable

  • Packages that use Observable
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Observable in java.util

      Methods in java.util with parameters of type Observable
      Modifier and Type 方法 描述
      void Observer.update​(Observable o, Object arg)
      已过时。
      每当观察到的对象发生变化时，都会调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Optional (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Optional

  • Packages that use Optional
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.spi
    java.util包中类的服务提供者类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of Optional in java.lang

      Methods in java.lang that return Optional
      Modifier and Type 方法 描述
      Optional<String[]> ProcessHandle.Info.arguments​()
      返回进程参数的Strings数组。
      Optional<Integer> Runtime.Version.build​()
      返回 build number 。
      Optional<String> ProcessHandle.Info.command​()
      返回进程的可执行路径名。
      Optional<String> ProcessHandle.Info.commandLine​()
      返回进程的命令行。
      Optional<Module> ModuleLayer.findModule​(String name)
      在此层中返回具有给定名称的模块，或者如果不在此层中，则 返回parent层。
      static Optional<ProcessHandle> ProcessHandle.of​(long pid)
      返回现有本机进程的 Optional<ProcessHandle> 。
      Optional<String> Runtime.Version.optional​()
      返回 optional附加识别构建信息。
      Optional<ProcessHandle> ProcessHandle.parent​()
      返回父进程的 Optional<ProcessHandle> 。
      Optional<String> Runtime.Version.pre​()
      返回可选的 pre-release信息。
      Optional<Instant> ProcessHandle.Info.startInstant​()
      返回进程的开始时间。
      Optional<Duration> ProcessHandle.Info.totalCpuDuration​()
      返回进程累积的总计。
      Optional<String> ProcessHandle.Info.user​()
      返回进程的用户。

    • Uses of Optional in java.lang.module

      Methods in java.lang.module that return Optional
      Modifier and Type 方法 描述
      Optional<ModuleDescriptor.Version> ModuleDescriptor.Requires.compiledVersion​()
      如果在编译时记录，则返回模块的版本。
      Optional<ModuleReference> ModuleFinder.find​(String name)
      查找给定名称的模块的引用。
      Optional<URI> ModuleReader.find​(String name)
      查找资源，将URI返回给模块中的资源。
      Optional<ResolvedModule> Configuration.findModule​(String name)
      在此配置中找到一个已解决的模块，或者在此配置中 找不到parent配置。
      Optional<URI> ModuleReference.location​()
      如果已知，返回此模块内容的位置。
      Optional<String> ModuleDescriptor.mainClass​()
      返回模块主类。
      default Optional<InputStream> ModuleReader.open​(String name)
      打开资源，返回输入流以读取模块中的资源。
      Optional<String> ModuleDescriptor.Requires.rawCompiledVersion​()
      如果在编译时记录，则返回具有可能不可粗体版本的模块的字符串。
      Optional<String> ModuleDescriptor.rawVersion​()
      返回具有可能不可粗体版本的模块的字符串
      default Optional<ByteBuffer> ModuleReader.read​(String name)
      读取资源，返回一个具有资源内容的字节缓冲区。
      Optional<ModuleDescriptor.Version> ModuleDescriptor.version​()
      返回模块版本。

    • Uses of Optional in java.util

      Methods in java.util that return Optional
      Modifier and Type 方法 描述
      static <T> Optional<T> Optional.empty​()
      返回一个空的 Optional实例。
      Optional<T> Optional.filter​(Predicate<? super T> predicate)
      如果存在值，并且该值与给定谓词匹配，则返回描述该值的 Optional ，否则返回一个空的 Optional 。
      Optional<S> ServiceLoader.findFirst​()
      加载此装载程序服务的第一个可用服务提供商。
      <U> Optional<U> Optional.flatMap​(Function<? super T,? extends Optional<? extends U>> mapper)
      如果存在值，则返回将给定的 Optional映射函数应用于该值的结果，否则返回一个空的 Optional 。
      <U> Optional<U> Optional.map​(Function<? super T,? extends U> mapper)
      如果存在一个值，则返回一个 Optional （表示为 ofNullable(T) ），将给定的映射函数应用于该值，否则返回一个空的 Optional 。
      static <T> Optional<T> Optional.of​(T value)
      返回一个 Optional描述给定的非 null值。
      static <T> Optional<T> Optional.ofNullable​(T value)
      返回描述给定值的 Optional ，如果 null ，否则返回一个空的 Optional 。
      Optional<T> Optional.or​(Supplier<? extends Optional<? extends T>> supplier)
      如果值存在时，返回一个 Optional描述的值，否则返回一个 Optional通过供给函数产生。
      Method parameters in java.util with type arguments of type Optional
      Modifier and Type 方法 描述
      <U> Optional<U> Optional.flatMap​(Function<? super T,? extends Optional<? extends U>> mapper)
      如果存在值，则返回将给定的 Optional映射函数应用于该值的结果，否则返回一个空的 Optional 。
      Optional<T> Optional.or​(Supplier<? extends Optional<? extends T>> supplier)
      如果值存在时，返回一个 Optional描述的值，否则返回一个 Optional通过供给函数产生。

    • Uses of Optional in java.util.spi

      Methods in java.util.spi that return Optional
      Modifier and Type 方法 描述
      static Optional<ToolProvider> ToolProvider.findFirst​(String name)
      返回具有给定名称的ToolProvider的第一个实例，由使用系统类加载器的ServiceLoader加载。

    • Uses of Optional in java.util.stream

      Methods in java.util.stream that return Optional
      Modifier and Type 方法 描述
      Optional<T> Stream.findAny​()
      返回Optional描述流的一些元件，或一个空Optional如果流是空的。
      Optional<T> Stream.findFirst​()
      返回Optional描述此流的第一个元素，或空Optional如果流是空的。
      Optional<T> Stream.max​(Comparator<? super T> comparator)
      根据提供的 Comparator返回此流的最大元素。
      Optional<T> Stream.min​(Comparator<? super T> comparator)
      根据提供的 Comparator返回此流的最小元素。
      Optional<T> Stream.reduce​(BinaryOperator<T> accumulator)
      使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值（如果有）的 Optional 。
      Methods in java.util.stream that return types with arguments of type Optional
      Modifier and Type 方法 描述
      static <T> Collector<T,?,Optional<T>> Collectors.maxBy​(Comparator<? super T> comparator)
      返回一个 Collector ，它根据给出的 Comparator产生最大元素，描述为 Optional<T> 。
      static <T> Collector<T,?,Optional<T>> Collectors.minBy​(Comparator<? super T> comparator)
      返回 Collector ，它根据给定的 Comparator生成最小元素，描述为 Optional<T> 。
      static <T> Collector<T,?,Optional<T>> Collectors.reducing​(BinaryOperator<T> op)
      返回一个 Collector ，它在指定的 BinaryOperator下执行其输入元素的减少。

    • Uses of Optional in javafx.scene.control

      Methods in javafx.scene.control that return Optional
      Modifier and Type 方法 描述
      Optional<R> Dialog.showAndWait​()
      显示对话框并等待用户响应（换句话说，显示阻止对话框，用户输入的返回值）。

    • Uses of Optional in jdk.incubator.http

      Methods in jdk.incubator.http that return Optional
      Modifier and Type 方法 描述
      abstract Optional<Authenticator> HttpClient.authenticator​()
      返回一个Optional包含该客户端上的Authenticator集。
      abstract Optional<HttpRequest.BodyProcessor> HttpRequest.bodyProcessor​()
      返回一个Optional其中包含该请求的HttpRequest.BodyProcessor集。
      abstract Optional<CookieManager> HttpClient.cookieManager​()
      返回一个Optional ，其中包含该客户端的CookieManager 。
      Optional<String> HttpHeaders.firstValue​(String name)
      返回一个Optional，其中包含给定的已命名（可能是多值）头的第一个值。
      Optional<HttpResponse.BodyHandler<T>> HttpResponse.MultiProcessor.onRequest​(HttpRequest request)
      被称为主要请求和每个推送承诺。
      abstract Optional<ProxySelector> HttpClient.proxy​()
      返回一个 Optional其中包含该客户端的 ProxySelector 。
      abstract Optional<SSLParameters> HttpClient.sslParameters​()
      返回一个Optional其中包含该客户端上的SSLParameters 。
      abstract Optional<HttpClient.Version> HttpRequest.version​()
      返回一个包含HTTP协议版本的 Optional ，该协议版本将被请求 HttpRequest 。
      Method parameters in jdk.incubator.http with type arguments of type Optional
      Modifier and Type 方法 描述
      static HttpResponse.BodyHandler<Void> HttpResponse.BodyHandler.asByteArrayConsumer​(Consumer<Optional<byte[]>> consumer)
      返回一个BodyHandler<Void> ，返回一个从 <Void>获得的BodyProcessor <Void> 。
      static HttpResponse.BodyProcessor<Void> HttpResponse.BodyProcessor.asByteArrayConsumer​(Consumer<Optional<byte[]>> consumer)
      返回一个 BodyProcessor ，它将传入的身体数据提供给所提供的消费者 Optional<byte[]> 。
      static <V> HttpResponse.MultiProcessor<MultiMapResult<V>,V> HttpResponse.MultiProcessor.asMap​(Function<HttpRequest,Optional<HttpResponse.BodyHandler<V>>> pushHandler)
      返回多个响应的通用处理程序。
      static <V> HttpResponse.MultiProcessor<MultiMapResult<V>,V> HttpResponse.MultiProcessor.asMap​(Function<HttpRequest,Optional<HttpResponse.BodyHandler<V>>> pushHandler, boolean completion)
      返回多个响应的通用处理程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.OptionalDouble (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.OptionalDouble

  • Packages that use OptionalDouble
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of OptionalDouble in java.util

      Methods in java.util that return OptionalDouble
      Modifier and Type 方法 描述
      static OptionalDouble OptionalDouble.empty​()
      返回一个空的 OptionalDouble实例。
      static OptionalDouble OptionalDouble.of​(double value)
      返回描述给定值的 OptionalDouble 。

    • Uses of OptionalDouble in java.util.stream

      Methods in java.util.stream that return OptionalDouble
      Modifier and Type 方法 描述
      OptionalDouble DoubleStream.average​()
      返回描述此流的元素的算术平均值的 OptionalDouble ，如果此流为空，则返回一个空的可选项。
      OptionalDouble IntStream.average​()
      返回描述此流的元素的算术平均值的 OptionalDouble ，如果此流为空，则返回一个空的可选项。
      OptionalDouble LongStream.average​()
      返回描述此流的元素的算术平均值的 OptionalDouble ，如果此流为空，则返回一个空的可选项。
      OptionalDouble DoubleStream.findAny​()
      返回OptionalDouble描述流的一些元件，或一个空OptionalDouble如果流是空的。
      OptionalDouble DoubleStream.findFirst​()
      返回OptionalDouble描述此流的第一个元素，或空OptionalDouble如果流是空的。
      OptionalDouble DoubleStream.max​()
      返回描述此流的最大元素的 OptionalDouble ，如果此流为空，则返回空的OptionalDouble。
      OptionalDouble DoubleStream.min​()
      返回描述此流的最小元素的 OptionalDouble ，如果此流为空，则返回空的OptionalDouble。
      OptionalDouble DoubleStream.reduce​(DoubleBinaryOperator op)
      使用 associative累积功能对此流的元素执行 reduction ，并返回描述减小值（如果有）的 OptionalDouble 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.OptionalInt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.OptionalInt

  • Packages that use OptionalInt
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of OptionalInt in java.util

      Methods in java.util that return OptionalInt
      Modifier and Type 方法 描述
      static OptionalInt OptionalInt.empty​()
      返回一个空的 OptionalInt实例。
      static OptionalInt OptionalInt.of​(int value)
      返回描述给定值的 OptionalInt 。

    • Uses of OptionalInt in java.util.stream

      Methods in java.util.stream that return OptionalInt
      Modifier and Type 方法 描述
      OptionalInt IntStream.findAny​()
      返回OptionalInt描述流的一些元件，或一个空OptionalInt如果流是空的。
      OptionalInt IntStream.findFirst​()
      返回OptionalInt描述此流的第一个元素，或空OptionalInt如果流是空的。
      OptionalInt IntStream.max​()
      返回描述此流的最大元素的 OptionalInt ，如果此流为空，则返回一个空的可选项。
      OptionalInt IntStream.min​()
      返回描述此流的最小元素的 OptionalInt ，如果此流为空，则返回一个空的可选项。
      OptionalInt IntStream.reduce​(IntBinaryOperator op)
      使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值的 OptionalInt （如果有）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.OptionalLong (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.OptionalLong

  • Packages that use OptionalLong
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of OptionalLong in java.util

      Methods in java.util that return OptionalLong
      Modifier and Type 方法 描述
      static OptionalLong OptionalLong.empty​()
      返回一个空的 OptionalLong实例。
      static OptionalLong OptionalLong.of​(long value)
      返回描述给定值的 OptionalLong 。

    • Uses of OptionalLong in java.util.stream

      Methods in java.util.stream that return OptionalLong
      Modifier and Type 方法 描述
      OptionalLong LongStream.findAny​()
      返回OptionalLong描述流的一些元件，或一个空OptionalLong如果流是空的。
      OptionalLong LongStream.findFirst​()
      返回OptionalLong描述此流的第一个元素，或空OptionalLong如果流是空的。
      OptionalLong LongStream.max​()
      返回描述此流的最大元素的 OptionalLong ，如果此流为空，则返回一个空的可选项。
      OptionalLong LongStream.min​()
      返回描述此流的最小元素的 OptionalLong ，如果此流为空，则返回一个空的可选项。
      OptionalLong LongStream.reduce​(LongBinaryOperator op)
      使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值（如果有）的 OptionalLong 。

    • Uses of OptionalLong in jdk.incubator.http

      Methods in jdk.incubator.http that return OptionalLong
      Modifier and Type 方法 描述
      OptionalLong HttpHeaders.firstValueAsLong​(String name)
      返回包含命名头字段的第一个值的OptionalLong 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.PriorityQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.PriorityQueue

  • Packages that use PriorityQueue
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of PriorityQueue in java.util

      Constructors in java.util with parameters of type PriorityQueue
      Constructor 描述
      PriorityQueue​(PriorityQueue<? extends E> c)
      创建包含指定优先级队列中的元素的 PriorityQueue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Properties (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Properties

  • Packages that use Properties
    软件包 描述
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.security
    提供安全框架的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为程序员可以将其用作全功能对象请求代理（ORB）。

    • Uses of Properties in com.sun.tools.attach

      Methods in com.sun.tools.attach that return Properties
      Modifier and Type 方法 描述
      abstract Properties VirtualMachine.getAgentProperties​()
      返回目标虚拟机中的当前 代理属性 。
      abstract Properties VirtualMachine.getSystemProperties​()
      返回目标虚拟机中的当前系统属性。
      Methods in com.sun.tools.attach with parameters of type Properties
      Modifier and Type 方法 描述
      abstract void VirtualMachine.startManagementAgent​(Properties agentProperties)
      启动目标虚拟机中的JMX管理代理。

    • Uses of Properties in java.awt

      Methods in java.awt with parameters of type Properties
      Modifier and Type 方法 描述
      abstract PrintJob Toolkit.getPrintJob​(Frame frame, String jobtitle, Properties props)
      获取 PrintJob对象，这是在工具包的平台上启动打印操作的结果。

    • Uses of Properties in java.lang

      Methods in java.lang that return Properties
      Modifier and Type 方法 描述
      static Properties System.getProperties​()
      确定当前的系统属性。
      Methods in java.lang with parameters of type Properties
      Modifier and Type 方法 描述
      static void System.setProperties​(Properties props)
      将系统属性设置为 Properties参数。

    • Uses of Properties in java.rmi.activation

      Methods in java.rmi.activation that return Properties
      Modifier and Type 方法 描述
      Properties ActivationGroupDesc.getPropertyOverrides​()
      返回组的属性覆盖列表。
      Constructors in java.rmi.activation with parameters of type Properties
      Constructor 描述
      ActivationGroupDesc​(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
      指定要用于组的备用组实现和执行环境。
      ActivationGroupDesc​(Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
      构造一个使用系统默认值进行组实现和代码位置的组描述符。

    • Uses of Properties in java.security

      Subclasses of Properties in java.security
      Modifier and Type Class 描述
      class  AuthProvider
      此类为提供程序定义登录和注销方法。
      class  Provider
      该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。

    • Uses of Properties in java.sql

      Methods in java.sql that return Properties
      Modifier and Type 方法 描述
      Properties Connection.getClientInfo​()
      返回包含驱动程序支持的每个客户端信息属性的名称和当前值的列表。
      Methods in java.sql with parameters of type Properties
      Modifier and Type 方法 描述
      Connection Driver.connect​(String url, Properties info)
      尝试使数据库连接到给定的URL。
      static Connection DriverManager.getConnection​(String url, Properties info)
      尝试建立与给定数据库URL的连接。
      DriverPropertyInfo[] Driver.getPropertyInfo​(String url, Properties info)
      获取有关此驱动程序可能属性的信息。
      void Connection.setClientInfo​(Properties properties)
      设置连接的客户端信息属性的值。

    • Uses of Properties in java.util

      Fields in java.util declared as Properties
      Modifier and Type Field 描述
      protected Properties Properties.defaults
      属性列表，其中包含此属性列表中未找到的任何键的默认值。
      Constructors in java.util with parameters of type Properties
      Constructor 描述
      Properties​(Properties defaults)
      创建具有指定默认值的空属性列表。

    • Uses of Properties in javax.naming

      Fields in javax.naming declared as Properties
      Modifier and Type Field 描述
      protected Properties CompoundName.mySyntax
      此化合物名称的语法属性。
      Constructors in javax.naming with parameters of type Properties
      Constructor 描述
      CompoundName​(String n, Properties syntax)
      通过使用提供的语法属性指定的语法解析字符串n来构造新的化合物名称实例。
      CompoundName​(Enumeration<String> comps, Properties syntax)
      使用comps和syntax中指定的组件构造一个新的复合名称实例。

    • Uses of Properties in javax.xml.transform

      Methods in javax.xml.transform that return Properties
      Modifier and Type 方法 描述
      Properties Templates.getOutputProperties​()
      获取与有效xsl：output元素相对应的属性。
      abstract Properties Transformer.getOutputProperties​()
      获取转换的输出属性的副本。
      Methods in javax.xml.transform with parameters of type Properties
      Modifier and Type 方法 描述
      abstract void Transformer.setOutputProperties​(Properties oformat)
      设置转换的输出属性。

    • Uses of Properties in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type Properties
      Modifier and Type 方法 描述
      static ORB ORB.init​(Applet app, Properties props)
      为一个小程序创建一个新的 ORB实例。
      static ORB ORB.init​(String[] args, Properties props)
      为独立应用程序创建一个新的 ORB实例。
      protected abstract void ORB.set_parameters​(Applet app, Properties props)
      允许使用给定的小程序和参数初始化ORB实现。
      protected abstract void ORB.set_parameters​(String[] args, Properties props)
      允许使用给定的参数和属性初始化ORB实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.PropertyPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.PropertyPermission

No usage of java.util.PropertyPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.PropertyResourceBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.PropertyResourceBundle

No usage of java.util.PropertyResourceBundle
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Random (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Random

  • Packages that use Random
    软件包 描述
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of Random in java.math

      Methods in java.math with parameters of type Random
      Modifier and Type 方法 描述
      static BigInteger BigInteger.probablePrime​(int bitLength, Random rnd)
      返回一个正的BigInteger，它可能是素数，具有指定的位长度。
      Constructors in java.math with parameters of type Random
      Constructor 描述
      BigInteger​(int bitLength, int certainty, Random rnd)
      构造一个随机生成的正BigInteger，它可能是素数，具有指定的bitLength。
      BigInteger​(int numBits, Random rnd)
      构造一个随机生成的BigInteger，均匀分布在0到（2 numBits - 1）的范围内。

    • Uses of Random in java.security

      Subclasses of Random in java.security
      Modifier and Type Class 描述
      class  SecureRandom
      这个类提供了一个密码强的随机数生成器（RNG）。

    • Uses of Random in java.util

      Methods in java.util with parameters of type Random
      Modifier and Type 方法 描述
      static void Collections.shuffle​(List<?> list, Random rnd)
      使用指定的随机源随机排列指定的列表。

    • Uses of Random in java.util.concurrent

      Subclasses of Random in java.util.concurrent
      Modifier and Type Class 描述
      class  ThreadLocalRandom
      与当前线程隔离的随机数生成器。

    • Uses of Random in javafx.collections

      Methods in javafx.collections with parameters of type Random
      Modifier and Type 方法 描述
      static void FXCollections.shuffle​(ObservableList list, Random rnd)
      随机播放可观察列表中的所有元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.ResourceBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.ResourceBundle

  • Packages that use ResourceBundle
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.spi
    java.util包中类的服务提供者类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。

    • Uses of ResourceBundle in java.awt

      Methods in java.awt with parameters of type ResourceBundle
      Modifier and Type 方法 描述
      void Window.applyResourceBundle​(ResourceBundle rb)
      已过时。
      截至J2SE 1.4，由Component.applyComponentOrientation替代。
      static ComponentOrientation ComponentOrientation.getOrientation​(ResourceBundle bdl)
      已过时。
      从J2SE 1.4起，使用ComponentOrientation.getOrientation(java.util.Locale) 。

    • Uses of ResourceBundle in java.lang

      Methods in java.lang with parameters of type ResourceBundle
      Modifier and Type 方法 描述
      System.Logger System.LoggerFinder.getLocalizedLogger​(String name, ResourceBundle bundle, Module module)
      返回一个本地化的实例Logger对于给定module 。
      static System.Logger System.getLogger​(String name, ResourceBundle bundle)
      返回可调用者使用的本地化实例Logger 。
      void System.Logger.log​(System.Logger.Level level, ResourceBundle bundle, String format, Object... params)
      使用资源束和可选的参数列表记录消息。
      void System.Logger.log​(System.Logger.Level level, ResourceBundle bundle, String msg, Throwable thrown)
      记录与给定的可抛物线相关联的本地化消息。

    • Uses of ResourceBundle in java.util

      Subclasses of ResourceBundle in java.util
      Modifier and Type Class 描述
      class  ListResourceBundle
      ListResourceBundle是一个抽象类 ResourceBundle管理资源，以方便和易于使用的列表区域设置。
      class  PropertyResourceBundle
      PropertyResourceBundle是的具体子类 ResourceBundle管理资源使用一组属性文件中的静态字符串的语言环境。
      Fields in java.util declared as ResourceBundle
      Modifier and Type Field 描述
      protected ResourceBundle ResourceBundle.parent
      此捆绑包的父捆绑。
      Methods in java.util that return ResourceBundle
      Modifier and Type 方法 描述
      static ResourceBundle ResourceBundle.getBundle​(String baseName)
      使用指定的基本名称，默认语言环境和调用者的类加载器获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Module module)
      使用指定的基本名称和默认语言环境代替指定的模块获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale locale)
      使用指定的基本名称和区域设置以及调用者的类加载器获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale locale, ClassLoader loader)
      使用指定的基本名称，区域设置和类加载器获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)
      使用指定的基本名称，目标语言环境，类加载器和控件返回资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, Module module)
      使用指定的基本名称和区域设置代替指定的模块获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, ResourceBundle.Control control)
      使用指定的基本名称，目标语言环境和控件以及调用者的类加载器返回资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, ResourceBundle.Control control)
      X- 2004545 CEEC X-
      ResourceBundle ResourceBundle.Control.newBundle​(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
      为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。
      Methods in java.util with parameters of type ResourceBundle
      Modifier and Type 方法 描述
      boolean ResourceBundle.Control.needsReload​(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime)
      确定是否需要根据 loadTime或某些其他条件给出的加载时间重新加载高速缓存中的过期 bundle 。
      protected void ResourceBundle.setParent​(ResourceBundle parent)
      设置此捆绑包的父捆绑包。

    • Uses of ResourceBundle in java.util.logging

      Methods in java.util.logging that return ResourceBundle
      Modifier and Type 方法 描述
      ResourceBundle Logger.getResourceBundle​()
      检索此记录器的本地化资源包。
      ResourceBundle LogRecord.getResourceBundle​()
      获取本地化资源包
      Methods in java.util.logging with parameters of type ResourceBundle
      Modifier and Type 方法 描述
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Object... params)
      使用可选的消息参数列表记录消息，指定源类，方法和资源包。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
      void Logger.logrb​(Level level, ResourceBundle bundle, String msg, Object... params)
      使用可选的消息参数列表记录消息，指定源类，方法和资源包。
      void Logger.logrb​(Level level, ResourceBundle bundle, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
      void Logger.setResourceBundle​(ResourceBundle bundle)
      在此记录器上设置资源包。
      void LogRecord.setResourceBundle​(ResourceBundle bundle)
      设置本地化资源包。

    • Uses of ResourceBundle in java.util.spi

      Methods in java.util.spi that return ResourceBundle
      Modifier and Type 方法 描述
      ResourceBundle AbstractResourceBundleProvider.getBundle​(String baseName, Locale locale)
      返回 ResourceBundle为给定 baseName和 locale 。
      ResourceBundle ResourceBundleProvider.getBundle​(String baseName, Locale locale)
      为给定的包名称和区域设置返回 ResourceBundle 。

    • Uses of ResourceBundle in javafx.fxml

      Methods in javafx.fxml that return ResourceBundle
      Modifier and Type 方法 描述
      ResourceBundle FXMLLoader.getResources​()
      返回用于解析资源密钥属性值的资源。
      Methods in javafx.fxml with parameters of type ResourceBundle
      Modifier and Type 方法 描述
      void Initializable.initialize​(URL location, ResourceBundle resources)
      被调用以在其根元素被完全处理之后初始化控制器。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      从FXML文档加载对象层次结构。
      void FXMLLoader.setResources​(ResourceBundle resources)
      设置用于解析资源密钥属性值的资源。
      Constructors in javafx.fxml with parameters of type ResourceBundle
      Constructor 描述
      FXMLLoader​(URL location, ResourceBundle resources)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)
      创建一个新的FXMLLoader实例。

    • Uses of ResourceBundle in javax.accessibility

      Subclasses of ResourceBundle in javax.accessibility
      Modifier and Type Class 描述
      class  AccessibleResourceBundle
      已过时。
      从Java平台1.3版开始，此类已被弃用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.ResourceBundle.Control (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.ResourceBundle.Control

  • Packages that use ResourceBundle.Control
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.spi
    java.util包中类的服务提供者类。

    • Uses of ResourceBundle.Control in java.util

      Methods in java.util that return ResourceBundle.Control
      Modifier and Type 方法 描述
      static ResourceBundle.Control ResourceBundle.Control.getControl​(List<String> formats)
      返回一个 ResourceBundle.Control ，其中 getFormats方法返回指定的 formats 。
      static ResourceBundle.Control ResourceBundle.Control.getNoFallbackControl​(List<String> formats)
      返回 ResourceBundle.Control其中 getFormats方法返回指定 formats和 getFallbackLocale方法返回 null 。
      Methods in java.util with parameters of type ResourceBundle.Control
      Modifier and Type 方法 描述
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)
      使用指定的基本名称，目标语言环境，类加载器和控件返回资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, ResourceBundle.Control control)
      使用指定的基本名称，目标语言环境和控件以及调用者的类加载器返回资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, ResourceBundle.Control control)
      使用指定的基本名称，默认语言环境和指定的控件返回资源包。

    • Uses of ResourceBundle.Control in java.util.spi

      Methods in java.util.spi that return ResourceBundle.Control
      Modifier and Type 方法 描述
      ResourceBundle.Control ResourceBundleControlProvider.getControl​(String baseName)
      返回一个 ResourceBundle.Control实例，用于处理给定的 baseName资源束加载。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Scanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Scanner

  • Packages that use Scanner
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Scanner in java.util

      Methods in java.util that return Scanner
      Modifier and Type 方法 描述
      Scanner Scanner.reset​()
      重设此扫描仪。
      Scanner Scanner.skip​(String pattern)
      跳过与指定字符串构成的模式匹配的输入。
      Scanner Scanner.skip​(Pattern pattern)
      跳过与指定模式匹配的输入，忽略分隔符。
      Scanner Scanner.useDelimiter​(String pattern)
      将此扫描仪的划分模式设置为从指定的 String构造的模式。
      Scanner Scanner.useDelimiter​(Pattern pattern)
      将此扫描仪的分隔模式设置为指定的模式。
      Scanner Scanner.useLocale​(Locale locale)
      将此扫描仪的区域设置设置为指定的区域设置。
      Scanner Scanner.useRadix​(int radix)
      将此扫描仪的默认基数设置为指定的基数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.ServiceConfigurationError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.ServiceConfigurationError

  • Packages that use ServiceConfigurationError
    软件包 描述
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。

    • Uses of ServiceConfigurationError in jdk.dynalink

      Methods in jdk.dynalink that return types with arguments of type ServiceConfigurationError
      Modifier and Type 方法 描述
      List<ServiceConfigurationError> DynamicLinkerFactory.getAutoLoadingErrors​()
      返回在上次调用DynamicLinkerFactory.createLinker()期间加载自动发现的链接器时遇到的ServiceConfigurationError的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.ServiceLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.ServiceLoader

  • Packages that use ServiceLoader
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。

    • Uses of ServiceLoader in java.util

      Methods in java.util that return ServiceLoader
      Modifier and Type 方法 描述
      static <S> ServiceLoader<S> ServiceLoader.load​(Class<S> service)
      使用当前线程的 context class loader为给定的服务类型创建一个新的服务加载器。
      static <S> ServiceLoader<S> ServiceLoader.load​(Class<S> service, ClassLoader loader)
      为给定的服务创建一个新的服务加载器。
      static <S> ServiceLoader<S> ServiceLoader.load​(ModuleLayer layer, Class<S> service)
      为给定的服务类型创建新的服务加载器，以便从给定模块层及其祖先的模块加载服务提供者。
      static <S> ServiceLoader<S> ServiceLoader.loadInstalled​(Class<S> service)
      使用 platform class loader为给定的服务类型创建一个新的服务加载程序。

    • Uses of ServiceLoader in javax.tools

      Methods in javax.tools that return ServiceLoader
      Modifier and Type | 方法 | 描述
      <S> ServiceLoader<S> | ForwardingJavaFileManager.getServiceLoader​(JavaFileManager.Location location, Class<S> service)
      default <S> ServiceLoader<S> JavaFileManager.getServiceLoader​(JavaFileManager.Location location, Class<S> service)
      Get a service loader for a specific service class from a given location.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.SimpleTimeZone (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.SimpleTimeZone

No usage of java.util.SimpleTimeZone
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Spliterators (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Spliterators

No usage of java.util.Spliterators
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Spliterators.AbstractDoubleSpliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Spliterators.AbstractDoubleSpliterator

No usage of java.util.Spliterators.AbstractDoubleSpliterator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Spliterators.AbstractIntSpliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Spliterators.AbstractIntSpliterator

No usage of java.util.Spliterators.AbstractIntSpliterator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Spliterators.AbstractLongSpliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Spliterators.AbstractLongSpliterator

No usage of java.util.Spliterators.AbstractLongSpliterator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Spliterators.AbstractSpliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Spliterators.AbstractSpliterator

No usage of java.util.Spliterators.AbstractSpliterator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.SplittableRandom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.SplittableRandom

  • Packages that use SplittableRandom
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of SplittableRandom in java.util

      Methods in java.util that return SplittableRandom
      Modifier and Type 方法 描述
      SplittableRandom SplittableRandom.split​()
      构造并返回一个新的SplittableRandom实例，与该实例共享不可变状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Stack (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Stack

No usage of java.util.Stack
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.StringJoiner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.StringJoiner

  • Packages that use StringJoiner
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of StringJoiner in java.util

      Methods in java.util that return StringJoiner
      Modifier and Type 方法 描述
      StringJoiner StringJoiner.add​(CharSequence newElement)
      将给定的副本 CharSequence值作为下一个元素 StringJoiner值。
      StringJoiner StringJoiner.merge​(StringJoiner other)
      添加给定的 StringJoiner的内容，没有前缀和后缀作为下一个元素，如果它是非空的。
      StringJoiner StringJoiner.setEmptyValue​(CharSequence emptyValue)
      设置在确定 StringJoiner的字符串表示时使用的字符序列，并且尚未添加任何元素，即当它为空时。
      Methods in java.util with parameters of type StringJoiner
      Modifier and Type 方法 描述
      StringJoiner StringJoiner.merge​(StringJoiner other)
      添加给定的 StringJoiner的内容，不带前缀和后缀作为下一个元素，如果它是非空的。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.StringTokenizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.StringTokenizer

No usage of java.util.StringTokenizer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Timer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Timer

No usage of java.util.Timer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.TimerTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.TimerTask

  • Packages that use TimerTask
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of TimerTask in java.util

      Methods in java.util with parameters of type TimerTask
      Modifier and Type 方法 描述
      void Timer.schedule​(TimerTask task, long delay)
      在指定的延迟之后安排指定的任务执行。
      void Timer.schedule​(TimerTask task, long delay, long period)
      在指定 的延迟之后开始，重新 执行固定延迟执行的指定任务。
      void Timer.schedule​(TimerTask task, Date time)
      在指定的时间安排指定的任务执行。
      void Timer.schedule​(TimerTask task, Date firstTime, long period)
      从指定的时间开始，对指定的任务执行重复的 固定延迟执行 。
      void Timer.scheduleAtFixedRate​(TimerTask task, long delay, long period)
      在指定的延迟之后开始，重新 执行固定速率的指定任务。
      void Timer.scheduleAtFixedRate​(TimerTask task, Date firstTime, long period)
      Schedules the specified task for repeated fixed-rate execution, beginning at the specified time.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.TimeZone (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.TimeZone

  • Packages that use TimeZone
    软件包 描述
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.xml.datatype
    定义XML / Java类型映射。

    • Uses of TimeZone in java.text

      Methods in java.text that return TimeZone
      Modifier and Type 方法 描述
      TimeZone DateFormat.getTimeZone​()
      获取时区。
      Methods in java.text with parameters of type TimeZone
      Modifier and Type 方法 描述
      void DateFormat.setTimeZone​(TimeZone zone)
      设置 DateFormat对象日历的时区。

    • Uses of TimeZone in java.util

      Subclasses of TimeZone in java.util
      Modifier and Type Class 描述
      class  SimpleTimeZone
      SimpleTimeZone是一个具体子类 TimeZone ，表示一个使用格里高利历的时区。
      Methods in java.util that return TimeZone
      Modifier and Type | 方法 | 描述
      static TimeZone TimeZone.getDefault​()
      获取Java虚拟机的默认值 TimeZone 。
      TimeZone Calendar.getTimeZone​()
      获取时区。
      TimeZone | GregorianCalendar.getTimeZone​()
      static TimeZone TimeZone.getTimeZone​(String ID)
      获取给定ID的 TimeZone 。
      static TimeZone TimeZone.getTimeZone​(ZoneId zoneId)
      获取 TimeZone给定的 zoneId 。
      Methods in java.util with parameters of type TimeZone
      Modifier and Type | 方法 | 描述
      static Calendar Calendar.getInstance​(TimeZone zone)
      使用指定的时区和默认语言环境获取日历。
      static Calendar Calendar.getInstance​(TimeZone zone, Locale aLocale)
      获取具有指定时区和区域设置的日历。
      boolean SimpleTimeZone.hasSameRules​(TimeZone other)
      如果此区域与其他区域具有相同的规则和偏移量，则返回 true 。
      boolean TimeZone.hasSameRules​(TimeZone other)
      如果此区域具有与其他区域相同的规则和偏移量，则返回true。
      static void TimeZone.setDefault​(TimeZone zone)
      设置 TimeZone由返回 getDefault方法。
      Calendar.Builder Calendar.Builder.setTimeZone​(TimeZone zone)
      将时区参数设置为给定的 zone 。
      void Calendar.setTimeZone​(TimeZone value)
      以给定的时区值设置时区。
      void | GregorianCalendar.setTimeZone​(TimeZone zone)
      Constructors in java.util with parameters of type TimeZone
      Constructor 描述
      Calendar​(TimeZone zone, Locale aLocale)
      构造具有指定时区和区域设置的日历。
      GregorianCalendar​(TimeZone zone)
      根据指定时区中的当前时间，使用默认的 FORMAT语言环境构建一个 GregorianCalendar 。
      GregorianCalendar​(TimeZone zone, Locale aLocale)
      根据给定时区的当前时间，使用给定的区域设置构建一个 GregorianCalendar 。

    • Uses of TimeZone in javax.xml.datatype

      Methods in javax.xml.datatype that return TimeZone
      Modifier and Type 方法 描述
      abstract TimeZone XMLGregorianCalendar.getTimeZone​(int defaultZoneoffset)
      返回此类别的 java.util.TimeZone 。
      Methods in javax.xml.datatype with parameters of type TimeZone
      Modifier and Type 方法 描述
      abstract GregorianCalendar XMLGregorianCalendar.toGregorianCalendar​(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
      将此XMLGregorianCalendar与提供的参数一起转换为GregorianCalendar实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.TooManyListenersException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.TooManyListenersException

  • Packages that use TooManyListenersException
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of TooManyListenersException in java.awt.dnd

      Methods in java.awt.dnd that throw TooManyListenersException
      Modifier and Type 方法 描述
      void DragGestureRecognizer.addDragGestureListener​(DragGestureListener dgl)
      注册新的 DragGestureListener 。
      void DragSourceContext.addDragSourceListener​(DragSourceListener dsl)
      添加 DragSourceListener这个 DragSourceContext如果一个尚未加入。
      void DropTarget.addDropTargetListener​(DropTargetListener dtl)
      添加一个新的 DropTargetListener （UNICAST SOURCE）。

    • Uses of TooManyListenersException in java.beans.beancontext

      Methods in java.beans.beancontext that throw TooManyListenersException
      Modifier and Type 方法 描述
      Object BeanContextServices.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      A BeanContextChild或与 BeanContextChild相关联的任何任意对象可以通过调用该方法从其嵌套 BeanContextServices获得对当前注册服务的引用。
      Object BeanContextServicesSupport.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      obtain a service which may be delegated
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.TreeMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.TreeMap

No usage of java.util.TreeMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.TreeSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.TreeSet

No usage of java.util.TreeSet
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.UnknownFormatConversionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.UnknownFormatConversionException

No usage of java.util.UnknownFormatConversionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.UnknownFormatFlagsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.UnknownFormatFlagsException

No usage of java.util.UnknownFormatFlagsException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.UUID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.UUID

  • Packages that use UUID
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of UUID in java.util

      Methods in java.util that return UUID
      Modifier and Type 方法 描述
      static UUID UUID.fromString​(String name)
      从 toString()方法中描述的字符串标准表示中创建一个 UUID 。
      static UUID UUID.nameUUIDFromBytes​(byte[] name)
      静态工厂根据指定的字节数组检索类型3（基于名称） UUID 。
      static UUID UUID.randomUUID​()
      静态工厂检索一个类型4（伪随机生成）的UUID。
      Methods in java.util with parameters of type UUID
      Modifier and Type 方法 描述
      int UUID.compareTo​(UUID val)
      将此UUID与指定的UUID进行比较。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.Vector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.Vector

  • Packages that use Vector
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.timer
    提供定时器MBean的定义。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming包以提供访问目录服务的功能。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。

    • Uses of Vector in java.awt.image

      Methods in java.awt.image that return Vector
      Modifier and Type 方法 描述
      Vector<RenderedImage> BufferedImage.getSources​()
      返回Vector的RenderedImage对象是直接来源，而不是这些直接来源的来源，该图像数据的BufferedImage 。
      Vector<RenderedImage> RenderedImage.getSources​()
      返回RenderedImages的矢量，该矢量是此RenderedImage的图像数据的直接来源。

    • Uses of Vector in java.awt.image.renderable

      Fields in java.awt.image.renderable declared as Vector
      Modifier and Type Field 描述
      protected Vector<Object> ParameterBlock.parameters
      非源参数向量，存储为任意对象。
      protected Vector<Object> ParameterBlock.sources
      源的矢量，存储为任意对象。
      Methods in java.awt.image.renderable that return Vector
      Modifier and Type 方法 描述
      Vector<Object> ParameterBlock.getParameters​()
      返回整个参数向量。
      Vector<Object> ParameterBlock.getSources​()
      返回整个Vector的Vector。
      Vector<RenderableImage> RenderableImage.getSources​()
      返回作为此RenderableImage的图像数据的源的RenderableImages的向量。
      Vector<RenderableImage> RenderableImageOp.getSources​()
      返回作为此RenderableImage的图像数据的源的RenderableImages的向量。
      Methods in java.awt.image.renderable with parameters of type Vector
      Modifier and Type 方法 描述
      void ParameterBlock.setParameters​(Vector<Object> parameters)
      将参数的整个Vector设置为给定的Vector。
      void ParameterBlock.setSources​(Vector<Object> sources)
      将整个Vector矢量设置为给定的Vector。
      Constructors in java.awt.image.renderable with parameters of type Vector
      Constructor 描述
      ParameterBlock​(Vector<Object> sources)
      构造一个 ParameterBlock与给定的源的向量。
      ParameterBlock​(Vector<Object> sources, Vector<Object> parameters)
      构造一个 ParameterBlock与给定矢量的源和参数矢量。

    • Uses of Vector in java.util

      Subclasses of Vector in java.util
      Modifier and Type Class 描述
      class  Stack<E>
      Stack类代表一个最先进先出（LIFO）堆栈的对象。

    • Uses of Vector in javax.accessibility

      Fields in javax.accessibility declared as Vector
      Modifier and Type Field 描述
      protected Vector<AccessibleRelation> AccessibleRelationSet.relations
      Vector每个条目代表一个 AccessibleRelation 。
      protected Vector<AccessibleState> AccessibleStateSet.states
      Vector每个条目代表一个 AccessibleState 。

    • Uses of Vector in javax.management

      Methods in javax.management that return Vector
      Modifier and Type 方法 描述
      Vector<String> AttributeChangeNotificationFilter.getEnabledAttributes​()
      获取此过滤器的所有已启用的属性名称。
      Vector<String> NotificationFilterSupport.getEnabledTypes​()
      获取此过滤器的所有启用的通知类型。

    • Uses of Vector in javax.management.relation

      Methods in javax.management.relation that return Vector
      Modifier and Type 方法 描述
      Vector<ObjectName> MBeanServerNotificationFilter.getDisabledObjectNames​()
      获取禁用的所有ObjectNames。
      Vector<ObjectName> MBeanServerNotificationFilter.getEnabledObjectNames​()
      获取所有启用的ObjectName。

    • Uses of Vector in javax.management.timer

      Methods in javax.management.timer that return Vector
      Modifier and Type 方法 描述
      Vector<Integer> Timer.getAllNotificationIDs​()
      获取注册到通知列表中的所有定时器通知标识符。
      Vector<Integer> TimerMBean.getAllNotificationIDs​()
      获取注册到通知列表中的所有定时器通知标识符。
      Vector<Integer> Timer.getNotificationIDs​(String type)
      获取与指定类型相对应的定时器通知的所有标识符。
      Vector<Integer> TimerMBean.getNotificationIDs​(String type)
      获取与指定类型相对应的定时器通知的所有标识符。

    • Uses of Vector in javax.naming

      Fields in javax.naming declared as Vector
      Modifier and Type Field 描述
      protected Vector<RefAddr> Reference.addrs
      包含本参考文献中包含的地址。

    • Uses of Vector in javax.naming.directory

      Fields in javax.naming.directory declared as Vector
      Modifier and Type Field 描述
      protected Vector<Object> BasicAttribute.values
      保留属性的值。

    • Uses of Vector in javax.sound.midi

      Fields in javax.sound.midi declared as Vector
      Modifier and Type Field 描述
      protected Vector<Track> Sequence.tracks
      MIDI序列中的MIDI轨迹。

    • Uses of Vector in javax.sql.rowset.serial

      Constructors in javax.sql.rowset.serial with parameters of type Vector
      Constructor 描述
      SQLOutputImpl​(Vector<?> attributes, Map<String,?> map)
      创建一个新的 SQLOutputImpl对象，使用给定的属性向量初始化并输入map。

    • Uses of Vector in javax.swing

      Fields in javax.swing declared as Vector
      Modifier and Type Field 描述
      protected Vector<AbstractButton> ButtonGroup.buttons
      参与此组的按钮列表。
      Methods in javax.swing with parameters of type Vector
      Modifier and Type 方法 描述
      void JList.setListData​(Vector<? extends E> listData)
      从 Vector构造一个只读的 ListModel ，并使用此模型调用 setModel 。
      Constructors in javax.swing with parameters of type Vector
      Constructor 描述
      DefaultComboBoxModel​(Vector<E> v)
      构造一个使用向量初始化的DefaultComboBoxModel对象。
      JComboBox​(Vector<E> items)
      创建一个 JComboBox ，其中包含指定的向量中的元素。
      JList​(Vector<? extends E> listData)
      构造一个 JList ，显示在指定的元素 Vector 。
      JTable​(Vector<? extends Vector> rowData, Vector<?> columnNames)
      构造一个 JTable以显示的值 Vector的 Vectors ， rowData ，其列名称为 columnNames 。
      JTree​(Vector<?> value)
      返回 JTree ，其中指定的每个元素为 Vector作为未显示的新根节点的子节点。
      Constructor parameters in javax.swing with type arguments of type Vector
      Constructor 描述
      JTable​(Vector<? extends Vector> rowData, Vector<?> columnNames)
      构造一个 JTable以显示的值 Vector的 Vectors ， rowData ，其列名称为 columnNames 。

    • Uses of Vector in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return Vector
      Modifier and Type 方法 描述
      Vector<File> BasicDirectoryModel.getDirectories​()
      返回目录列表。
      Vector<File> BasicDirectoryModel.getFiles​()
      返回文件列表。
      Methods in javax.swing.plaf.basic with parameters of type Vector
      Modifier and Type 方法 描述
      protected void BasicDirectoryModel.sort​(Vector<? extends File> v)
      排序文件列表。

    • Uses of Vector in javax.swing.plaf.multi

      Fields in javax.swing.plaf.multi declared as Vector
      Modifier and Type Field 描述
      protected Vector<ComponentUI> MultiButtonUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiColorChooserUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiComboBoxUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiDesktopIconUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiDesktopPaneUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiFileChooserUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiInternalFrameUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiLabelUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiListUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiMenuBarUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiMenuItemUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiOptionPaneUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiPanelUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiPopupMenuUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiProgressBarUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiRootPaneUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiScrollBarUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiScrollPaneUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiSeparatorUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiSliderUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiSpinnerUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiSplitPaneUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiTabbedPaneUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiTableHeaderUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiTableUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiTextUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiToolBarUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiToolTipUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiTreeUI.uis
      包含真实UI的矢量。
      protected Vector<ComponentUI> MultiViewportUI.uis
      包含真实UI的矢量。
      Methods in javax.swing.plaf.multi with parameters of type Vector
      Modifier and Type 方法 描述
      static ComponentUI MultiLookAndFeel.createUIs​(ComponentUI mui, Vector<ComponentUI> uis, JComponent target)
      创建呈现 target组件所需的 ComponentUI对象，将对象放在 uis向量中，并返回最能代表组件UI的 ComponentUI对象。
      protected static ComponentUI[] MultiLookAndFeel.uisToArray​(Vector<? extends ComponentUI> uis)
      创建一个数组，并从传入的向量中填充UI对象，并返回数组。

    • Uses of Vector in javax.swing.table

      Fields in javax.swing.table declared as Vector
      Modifier and Type Field 描述
      protected Vector DefaultTableModel.columnIdentifiers
      列标识符的 Vector 。
      protected Vector<Vector> DefaultTableModel.dataVector
      Vector的 Vectors的 Object值。
      protected Vector<TableColumn> DefaultTableColumnModel.tableColumns
      此模型中的TableColumn对象数组
      Fields in javax.swing.table with type parameters of type Vector
      Modifier and Type Field 描述
      protected Vector<Vector> DefaultTableModel.dataVector
      Vector的 Vectors的 Object值。
      Methods in javax.swing.table that return Vector
      Modifier and Type 方法 描述
      protected static Vector<Object> DefaultTableModel.convertToVector​(Object[] anArray)
      返回一个包含与数组相同的对象的向量。
      protected static Vector<Vector<Object>> DefaultTableModel.convertToVector​(Object[][] anArray)
      返回包含与数组相同对象的向量向量。
      Vector<Vector> DefaultTableModel.getDataVector​()
      返回包含表的数据值的 Vector的 Vectors 。
      Methods in javax.swing.table that return types with arguments of type Vector
      Modifier and Type 方法 描述
      protected static Vector<Vector<Object>> DefaultTableModel.convertToVector​(Object[][] anArray)
      返回包含与数组相同对象的向量向量。
      Vector<Vector> DefaultTableModel.getDataVector​()
      返回 Vector的 Vectors ，其中包含表的数据值。
      Methods in javax.swing.table with parameters of type Vector
      Modifier and Type 方法 描述
      void DefaultTableModel.addColumn​(Object columnName, Vector<?> columnData)
      向模型添加一列。
      void DefaultTableModel.addRow​(Vector<?> rowData)
      在模型的末尾添加一行。
      void DefaultTableModel.insertRow​(int row, Vector<?> rowData)
      在模型中插入一行 row 。
      void DefaultTableModel.setColumnIdentifiers​(Vector<?> columnIdentifiers)
      替换模型中的列标识符。
      void DefaultTableModel.setDataVector​(Vector<? extends Vector> dataVector, Vector<?> columnIdentifiers)
      用新的 Vector行替换当前的 dataVector实例变量， dataVector 。
      Method parameters in javax.swing.table with type arguments of type Vector
      Modifier and Type 方法 描述
      void DefaultTableModel.setDataVector​(Vector<? extends Vector> dataVector, Vector<?> columnIdentifiers)
      用新的 Vector行替换当前的 dataVector实例变量， dataVector 。
      Constructors in javax.swing.table with parameters of type Vector
      Constructor 描述
      DefaultTableModel​(Vector<?> columnNames, int rowCount)
      构造一个 DefaultTableModel与尽可能多的列有在元件 columnNames和 rowCount的 null对象值。
      DefaultTableModel​(Vector<? extends Vector> data, Vector<?> columnNames)
      构造一个 DefaultTableModel并通过将 data和 columnNames传递给 setDataVector方法来初始化该表。
      Constructor parameters in javax.swing.table with type arguments of type Vector
      Constructor 描述
      DefaultTableModel​(Vector<? extends Vector> data, Vector<?> columnNames)
      构造一个 DefaultTableModel并通过将 data和 columnNames传递给 setDataVector方法来初始化表。

    • Uses of Vector in javax.swing.text

      Methods in javax.swing.text that return Vector
      Modifier and Type 方法 描述
      protected Vector GapContent.getPositionsInRange​(Vector v, int offset, int length)
      返回一个Vector，其中包含UndoPosRef的实例，位置范围为 offset至 offset + length 。
      protected Vector StringContent.getPositionsInRange​(Vector v, int offset, int length)
      返回一个Vector，其范围为 offset至 offset + length的位置的UndoPosRef实例。
      Methods in javax.swing.text with parameters of type Vector
      Modifier and Type 方法 描述
      protected Vector GapContent.getPositionsInRange​(Vector v, int offset, int length)
      返回一个包含UndoPosRef实例的向量，其范围为 offset到 offset + length 。
      protected Vector StringContent.getPositionsInRange​(Vector v, int offset, int length)
      返回一个Vector，其中包含UndoPosRef的实例，其范围为 offset至 offset + length 。
      protected void GapContent.updateUndoPositions​(Vector positions, int offset, int length)
      重置 positions所有UndoPosRef实例的 positions 。
      protected void StringContent.updateUndoPositions​(Vector positions)
      重置 positions所有UndoPosRef实例的 positions 。

    • Uses of Vector in javax.swing.text.html

      Fields in javax.swing.text.html declared as Vector
      Modifier and Type Field 描述
      protected Vector<DefaultStyledDocument.ElementSpec> HTMLDocument.HTMLReader.parseBuffer
      缓冲区以保持建筑元素。

    • Uses of Vector in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as Vector
      Modifier and Type Field 描述
      Vector<Element> DTD.elements
      元素的向量
      Vector<?> AttributeList.values
      可能的属性值
      Methods in javax.swing.text.html.parser with parameters of type Vector
      Modifier and Type 方法 描述
      void ContentModel.getElements​(Vector<Element> elemVec)
      更新elemVec与该contentModel的一部分的元素列表。
      Constructors in javax.swing.text.html.parser with parameters of type Vector
      Constructor 描述
      AttributeList​(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
      创建属性列表元素。

    • Uses of Vector in javax.swing.tree

      Fields in javax.swing.tree declared as Vector
      Modifier and Type Field 描述
      protected Vector<TreeNode> DefaultMutableTreeNode.children
      如果此节点没有子节点，则可能为null
      Methods in javax.swing.tree with parameters of type Vector
      Modifier and Type 方法 描述
      protected void DefaultTreeSelectionModel.notifyPathChange​(Vector<?> changedPaths, TreePath oldLeadSelection)
      已过时。
      从JDK版本1.7开始

    • Uses of Vector in javax.swing.undo

      Fields in javax.swing.undo declared as Vector
      Modifier and Type Field 描述
      protected Vector<UndoableEdit> CompoundEdit.edits
      收集 UndoableEdit撤消/恢复集体通过这一 CompoundEdit 。
      protected Vector<UndoableEditListener> UndoableEditSupport.listeners
      听众列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.WeakHashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.WeakHashMap

No usage of java.util.WeakHashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Collection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Collection

  • Packages that use Collection
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

    • Uses of Collection in com.sun.jdi.event

      Subinterfaces of Collection in com.sun.jdi.event
      Modifier and Type 接口 描述
      interface  EventSet
      可以在给定时间由目标VirtualMachine创建几个Event对象。

    • Uses of Collection in com.sun.management

      Methods in com.sun.management that return Collection
      Modifier and Type | 方法 | 描述
      Collection<?> | GcInfo.values​()

    • Uses of Collection in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return Collection
      Modifier and Type | 方法 | 描述
      Collection<List<String>> | Headers.values​()

    • Uses of Collection in java.awt

      Methods in java.awt that return Collection
      Modifier and Type 方法 描述
      Collection<Object> RenderingHints.values​()
      返回此 RenderingHints包含的值的 Collection视图。

    • Uses of Collection in java.beans.beancontext

      Subinterfaces of Collection in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContext
      BeanContext对JavaBeans起着逻辑分层容器的作用。
      interface  BeanContextServices
      BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
      Classes in java.beans.beancontext that implement Collection
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
      Fields in java.beans.beancontext declared as Collection
      Modifier and Type Field 描述
      protected Collection BeanContextMembershipEvent.children
      受此事件通知影响的小孩列表。
      Methods in java.beans.beancontext with parameters of type Collection
      Modifier and Type 方法 描述
      boolean BeanContextSupport.addAll​(Collection c)
      将集合添加到子集（不支持）的集合实现必须在层次结构锁和“children”保护字段上同步
      boolean BeanContextSupport.containsAll​(Collection c)
      测试以查看指定的 Collection中的所有对象是否为 Collection的子 BeanContext 。
      protected void BeanContextSupport.deserialize​(ObjectInputStream ois, Collection coll)
      由readObject用于反序列化集合。
      boolean BeanContextSupport.removeAll​(Collection c)
      删除所有指定的子（不支持）实现必须在层次结构锁和“children”保护字段上同步
      boolean BeanContextSupport.retainAll​(Collection c)
      只保留指定的子级（不支持）实现必须在层次结构锁和“children”保护字段上同步
      protected void BeanContextSupport.serialize​(ObjectOutputStream oos, Collection<?> coll)
      由writeObject用于序列化集合。
      Constructors in java.beans.beancontext with parameters of type Collection
      Constructor 描述
      BeanContextMembershipEvent​(BeanContext bc, Collection changes)
      引发BeanContextMembershipEvent

    • Uses of Collection in java.lang.module

      Methods in java.lang.module with parameters of type Collection
      Modifier and Type 方法 描述
      Configuration Configuration.resolve​(ModuleFinder before, ModuleFinder after, Collection<String> roots)
      解决一个根模块的集合，以此配置为其父级，以创建新的配置。
      static Configuration Configuration.resolve​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解析根模块的集合以创建配置。
      Configuration Configuration.resolveAndBind​(ModuleFinder before, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定，并将此配置作为其父配置来创建新配置。
      static Configuration Configuration.resolveAndBind​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定功能，以创建配置。

    • Uses of Collection in java.security

      Methods in java.security that return Collection
      Modifier and Type 方法 描述
      Collection<Object> Provider.values​()
      返回此提供程序中包含的属性值的不可修改的集合视图。

    • Uses of Collection in java.security.cert

      Methods in java.security.cert that return Collection
      Modifier and Type 方法 描述
      abstract Collection<? extends Certificate> CertificateFactorySpi.engineGenerateCertificates​(InputStream inStream)
      返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
      abstract Collection<? extends CRL> CertificateFactorySpi.engineGenerateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。
      abstract Collection<? extends Certificate> CertStoreSpi.engineGetCertificates​(CertSelector selector)
      返回匹配指定选择器的 Collection的 Certificate 。
      abstract Collection<? extends CRL> CertStoreSpi.engineGetCRLs​(CRLSelector selector)
      返回匹配指定选择器的 Collection的 CRL 。
      Collection<? extends Certificate> CertificateFactory.generateCertificates​(InputStream inStream)
      返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
      Collection<? extends CRL> CertificateFactory.generateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。
      Collection<? extends Certificate> CertStore.getCertificates​(CertSelector selector)
      返回匹配指定选择器的 Collection的 Certificate 。
      Collection<?> CollectionCertStoreParameters.getCollection​()
      返回 Collection ， Certificate检索 Certificate和 CRL 。
      Collection<? extends CRL> CertStore.getCRLs​(CRLSelector selector)
      返回匹配指定选择器的 Collection的 CRL 。
      Collection<List<?>> X509Certificate.getIssuerAlternativeNames​()
      从 IssuerAltName扩展名（OID = 2.5.29.18）获取不可变的发行人替代名称集合。
      Collection<Object> X509CRLSelector.getIssuerNames​()
      返回issuerNames条件的副本。
      Collection<X500Principal> X509CRLSelector.getIssuers​()
      返回issuerNames条件。
      Collection<List<?>> X509CertSelector.getPathToNames​()
      返回pathToNames条件的副本。
      Collection<List<?>> X509Certificate.getSubjectAlternativeNames​()
      从 SubjectAltName扩展名（OID = 2.5.29.17）获取不可变的主题替代名称集合。
      Collection<List<?>> X509CertSelector.getSubjectAlternativeNames​()
      返回subjectAlternativeNames条件的副本。
      Methods in java.security.cert with parameters of type Collection
      Modifier and Type 方法 描述
      abstract void PKIXCertPathChecker.check​(Certificate cert, Collection<String> unresolvedCritExts)
      使用其内部状态对指定证书执行检查，并从指定的OID字符串集合中删除其处理的任何关键扩展，这些扩展代表未解决的关键扩展。
      void X509CRLSelector.setIssuerNames​(Collection<?> names)
      注意：使用此方法时， 请改为使用 X509CRLSelector.setIssuers(Collection)或仅指定专有名称的字节数组形式。
      void X509CRLSelector.setIssuers​(Collection<X500Principal> issuers)
      设置issuerNames条件。
      void X509CertSelector.setPathToNames​(Collection<List<?>> names)
      设置pathToNames条件。
      void X509CertSelector.setSubjectAlternativeNames​(Collection<List<?>> names)
      设置subjectAlternativeNames标准。
      Constructors in java.security.cert with parameters of type Collection
      Constructor 描述
      CollectionCertStoreParameters​(Collection<?> collection)
      创建一个 CollectionCertStoreParameters的实例，这将允许从指定的 Collection检索证书和CRL。

    • Uses of Collection in java.util

      Subinterfaces of Collection in java.util
      Modifier and Type 接口 描述
      interface  Deque<E>
      支持两端元素插入和移除的线性集合。
      interface  List<E>
      有序集合（也称为 序列 ）。
      interface  NavigableSet<E>
      A SortedSet扩展了导航方法，报告给定搜索目标的最匹配的匹配。
      interface  Queue<E>
      设计用于在处理之前保留元素的集合。
      interface  Set<E>
      不包含重复元素的集合。
      interface  SortedSet<E>
      A Set进一步提供了其元素的总排序 。
      Classes in java.util that implement Collection
      Modifier and Type Class 描述
      class  AbstractCollection<E>
      该类提供了 Collection接口的骨架实现，以尽量减少实现此接口所需的工作量。
      class  AbstractList<E>
      该类提供了List接口的骨架实现，以最小化实现由“随机存取”数据存储（如阵列）支持的此接口所需的工作量。
      class  AbstractQueue<E>
      这个类提供了一些Queue操作的骨架实现。
      class  AbstractSequentialList<E>
      此类提供了 List接口的骨架实现，以最大限度地减少实施由“顺序访问”数据存储（如链表）支持的接口所需的工作量。
      class  AbstractSet<E>
      该类提供了 Set接口的骨架实现，以尽量减少实现此接口所需的工作量。
      class  ArrayDeque<E>
      Deque接口的可调整大小的数组实现。
      class  ArrayList<E>
      List接口的可调整大小的数组实现。
      class  EnumSet<E extends Enum<E>>
      专门用于枚举类型的Set实现。
      class  HashSet<E>
      该类实现了 Set接口，由哈希表（实际为 HashMap实例）支持。
      class  LinkedHashSet<E>
      哈希表和链表实现的 Set接口，具有可预测的迭代次序。
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
      class  PriorityQueue<E>
      基于优先级堆的无限优先级queue 。
      class  Stack<E>
      Stack类代表一个最先进先出（LIFO）堆栈的对象。
      class  TreeSet<E>
      A NavigableSet实现基于TreeMap 。
      class  Vector<E>
      Vector类实现了可扩展的对象数组。
      Methods in java.util that return Collection
      Modifier and Type | 方法 | 描述
      static <E> Collection<E> Collections.checkedCollection​(Collection<E> c, Class<E> type)
      返回指定集合的动态类型安全视图。
      static <T> Collection<T> Collections.synchronizedCollection​(Collection<T> c)
      返回由指定集合支持的同步（线程安全）集合。
      static <T> Collection<T> Collections.unmodifiableCollection​(Collection<? extends T> c)
      返回指定集合的不可修改视图。
      Collection<V> AbstractMap.values​()
      返回此地图中包含的值的Collection视图。
      Collection<V> EnumMap.values​()
      返回此地图中包含的值的Collection视图。
      Collection<V> HashMap.values​()
      返回此地图中包含的值的Collection视图。
      Collection<V> Hashtable.values​()
      返回此地图中包含的值的Collection视图。
      Collection<V> IdentityHashMap.values​()
      返回此地图中包含的值的Collection视图。
      Collection<V> LinkedHashMap.values​()
      返回此地图中包含的值的Collection视图。
      Collection<V> Map.values​()
      返回此地图中包含的值的Collection视图。
      Collection<Object> | Properties.values​()
      Collection<V> SortedMap.values​()
      返回此地图中包含的值的Collection视图。
      Collection<V> TreeMap.values​()
      返回此地图中包含的值的Collection视图。
      Collection<V> WeakHashMap.values​()
      返回此地图中包含的值的Collection视图。
      Methods in java.util with parameters of type Collection
      Modifier and Type | 方法 | 描述
      boolean AbstractCollection.addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合（可选操作）。
      boolean AbstractList.addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
      boolean AbstractQueue.addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此队列中。
      boolean AbstractSequentialList.addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
      boolean ArrayDeque.addAll​(Collection<? extends E> c)
      在指定集合的末尾添加指定集合中的所有元素，如同通过按照集合的迭代器返回的顺序调用每个 元素ArrayDeque.addLast(E)一样 。
      boolean ArrayList.addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中，从指定的位置开始。
      boolean ArrayList.addAll​(Collection<? extends E> c)
      按指定集合的Iterator返回的顺序将指定集合中的所有元素追加到此列表的末尾。
      boolean Collection.addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合（可选操作）。
      static <T> boolean Collections.addAll​(Collection<? super T> c, T... elements)
      将所有指定的元素添加到指定的集合。
      boolean Deque.addAll​(Collection<? extends E> c)
      在指定集合的末尾添加指定集合中的所有元素，如同通过按照集合的迭代器返回的顺序调用每个 元素Deque.addLast(E) 。
      boolean LinkedList.addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中，从指定的位置开始。
      boolean LinkedList.addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到此列表的末尾。
      boolean List.addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
      boolean List.addAll​(Collection<? extends E> c)
      按指定集合的迭代器（可选操作）返回的顺序将指定集合中的所有元素附加到此列表的末尾。
      boolean Set.addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合（如果尚未存在）（可选操作）。
      boolean TreeSet.addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合中。
      boolean Vector.addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此向量中的指定位置。
      boolean Vector.addAll​(Collection<? extends E> c)
      将指定集合中的所有元素追加到该向量的末尾，按照它们由指定集合的迭代器返回的顺序。
      static <E> Collection<E> Collections.checkedCollection​(Collection<E> c, Class<E> type)
      返回指定集合的动态类型安全视图。
      boolean AbstractCollection.containsAll​(Collection<?> c)
      如果此集合包含指定集合中的所有元素，则返回 true 。
      boolean Collection.containsAll​(Collection<?> c)
      如果此集合包含指定集合中的所有元素，则返回 true 。
      boolean List.containsAll​(Collection<?> c)
      如果此列表包含指定集合的所有元素，则返回 true 。
      boolean Set.containsAll​(Collection<?> c)
      如果此集合包含指定集合的所有元素，则返回 true 。
      boolean Vector.containsAll​(Collection<?> c)
      如果此向量包含指定集合中的所有元素，则返回true。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.copyOf​(Collection<E> c)
      创建从指定集合初始化的枚举集。
      static boolean Collections.disjoint​(Collection<?> c1, Collection<?> c2)
      如果两个指定的集合没有共同的元素，则返回 true 。
      static <T> Enumeration<T> Collections.enumeration​(Collection<T> c)
      返回指定集合的枚举。
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales, Locale.FilteringMode mode)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例列表。
      static List<String> Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      static List<String> Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags, Locale.FilteringMode mode)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      static int Collections.frequency​(Collection<?> c, Object o)
      返回指定集合中与指定对象相等的元素数。
      static Locale Locale.lookup​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的查找机制返回 Locale最佳匹配语言标记的实例。
      static String Locale.lookupTag​(List<Locale.LanguageRange> priorityList, Collection<String> tags)
      使用RFC 4647中定义的查找机制返回最匹配的语言标签。
      static <T extends Object & Comparable<? super T>>
      T             		Collections.max​(Collection<? extends T> coll)
      根据其元素的 自然顺序返回给定集合的最大元素。
      static <T> T Collections.max​(Collection<? extends T> coll, Comparator<? super T> comp)
      根据指定的比较器引发的顺序返回给定集合的最大元素。
      static <T extends Object & Comparable<? super T>>
      T             		Collections.min​(Collection<? extends T> coll)
      根据其元素的 自然顺序返回给定集合的最小元素。
      static <T> T Collections.min​(Collection<? extends T> coll, Comparator<? super T> comp)
      根据指定的比较器引发的顺序返回给定集合的最小元素。
      boolean AbstractCollection.removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      boolean AbstractSet.removeAll​(Collection<?> c)
      从此集合中删除指定集合中包含的所有元素（可选操作）。
      boolean | ArrayDeque.removeAll​(Collection<?> c)
      boolean ArrayList.removeAll​(Collection<?> c)
      从此列表中删除指定集合中包含的所有元素。
      boolean Collection.removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      boolean List.removeAll​(Collection<?> c)
      从此列表中删除包含在指定集合中的所有元素（可选操作）。
      boolean Set.removeAll​(Collection<?> c)
      从此集合中删除指定集合中包含的所有元素（可选操作）。
      boolean Vector.removeAll​(Collection<?> c)
      从此Vector中删除指定集合中包含的所有元素。
      boolean AbstractCollection.retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      boolean | ArrayDeque.retainAll​(Collection<?> c)
      boolean ArrayList.retainAll​(Collection<?> c)
      仅保留此列表中包含在指定集合中的元素。
      boolean Collection.retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      boolean List.retainAll​(Collection<?> c)
      仅保留此列表中包含在指定集合中的元素（可选操作）。
      boolean Set.retainAll​(Collection<?> c)
      仅保留该集合中包含在指定集合中的元素（可选操作）。
      boolean Vector.retainAll​(Collection<?> c)
      仅保留此向量中包含在指定集合中的元素。
      static <T> Spliterator<T> Spliterators.spliterator​(Collection<? extends T> c, int characteristics)
      使用给定集合的 iterator()作为元素的来源创建一个 Spliterator ，并报告其 size()作为其初始大小。
      static <T> Collection<T> Collections.synchronizedCollection​(Collection<T> c)
      返回由指定集合支持的同步（线程安全）集合。
      static <T> Collection<T> Collections.unmodifiableCollection​(Collection<? extends T> c)
      返回指定集合的不可修改视图。
      Constructors in java.util with parameters of type Collection
      Constructor 描述
      ArrayDeque​(Collection<? extends E> c)
      构造一个包含指定集合的元素的deque，按照它们由集合的迭代器返回的顺序。
      ArrayList​(Collection<? extends E> c)
      构造一个包含指定集合的元素的列表，按照它们由集合的迭代器返回的顺序。
      HashSet​(Collection<? extends E> c)
      构造一个包含指定集合中的元素的新集合。
      LinkedHashSet​(Collection<? extends E> c)
      构造与指定集合相同的元素的新的链接散列集。
      LinkedList​(Collection<? extends E> c)
      构造一个包含指定集合的元素的列表，按照它们由集合的迭代器返回的顺序。
      PriorityQueue​(Collection<? extends E> c)
      创建包含指定集合中的元素的 PriorityQueue 。
      TreeSet​(Collection<? extends E> c)
      构造一个包含指定集合中的元素的新树集，根据其元素的 自然排序进行排序 。
      Vector​(Collection<? extends E> c)
      构造一个包含指定集合元素的向量，按照集合的迭代器返回的顺序。

    • Uses of Collection in java.util.concurrent

      Subinterfaces of Collection in java.util.concurrent
      Modifier and Type 接口 描述
      interface  BlockingDeque<E>
      A Deque另外支持在检索元素时等待deque变为非空的阻塞操作，并等待存储元素时在deque中可用的空间。
      interface  BlockingQueue<E>
      A Queue另外支持在检索元素时等待队列变为非空的操作，并在存储元素时等待队列中的空间变得可用。
      interface  TransferQueue<E>
      A BlockingQueue其中生产者可能会等待消费者接收元素。
      Classes in java.util.concurrent that implement Collection
      Modifier and Type Class 描述
      class  ArrayBlockingQueue<E>
      有限的blocking queue由数组支持。
      static class  ConcurrentHashMap.KeySetView<K,V>
      ConcurrentHashMap视图为Set的密钥，其中可以通过映射到公共值来选择添加。
      class  ConcurrentLinkedDeque<E>
      基于链接节点的无界并发deque 。
      class  ConcurrentLinkedQueue<E>
      基于链接节点的无界线程安全queue 。
      class  ConcurrentSkipListSet<E>
      可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
      class  CopyOnWriteArrayList<E>
      的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。
      class  CopyOnWriteArraySet<E>
      A Set 对其所有操作使用内部CopyOnWriteArrayList 。
      class  DelayQueue<E extends Delayed>
      一个无限的blocking queue的Delayed元素，其中元素只能在其延迟到期时才被采用。
      class  LinkedBlockingDeque<E>
      基于链接节点的可选限定的blocking deque 。
      class  LinkedBlockingQueue<E>
      基于链接节点的可选限定的blocking queue 。
      class  LinkedTransferQueue<E>
      基于链接节点的无界TransferQueue 。
      class  PriorityBlockingQueue<E>
      一个无限的blocking queue ，它使用与PriorityQueue类相同的排序规则，并提供阻塞检索操作。
      class  SynchronousQueue<E>
      A blocking queue其中每个插入操作必须等待另一个线程进行相应的删除操作，反之亦然。
      Methods in java.util.concurrent that return Collection
      Modifier and Type 方法 描述
      protected Collection<Thread> Semaphore.getQueuedThreads​()
      返回一个包含可能正在等待获取的线程的集合。
      static <T extends ForkJoinTask<?>>
      Collection<T>             		ForkJoinTask.invokeAll​(Collection<T> tasks)
      叉指定集合中的所有任务，当 isDone适用于每个任务或返回（未检查）异常时返回，在这种情况下，异常被重新引导。
      Collection<V> ConcurrentHashMap.values​()
      返回此地图中包含的值的Collection视图。
      Collection<V> ConcurrentSkipListMap.values​()
      返回此地图中包含的值的Collection视图。
      Methods in java.util.concurrent with parameters of type Collection
      Modifier and Type | 方法 | 描述
      boolean ConcurrentHashMap.KeySetView.addAll​(Collection<? extends K> c)
      将指定集合中的所有元素添加到此集合中，就像在每个 元素上调用 ConcurrentHashMap.KeySetView.add(K)一样 。
      boolean ConcurrentLinkedDeque.addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该deque的末尾。
      boolean ConcurrentLinkedQueue.addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该队列的末尾。
      boolean CopyOnWriteArrayList.addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中，从指定的位置开始。
      boolean CopyOnWriteArrayList.addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到此列表的末尾。
      boolean CopyOnWriteArraySet.addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合（如果它们尚未存在）。
      boolean LinkedBlockingDeque.addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该deque的末尾。
      int CopyOnWriteArrayList.addAllAbsent​(Collection<? extends E> c)
      将指定集合中尚未包含在此列表中的所有元素按指定集合的迭代器返回的顺序附加到此列表的末尾。
      boolean CopyOnWriteArrayList.containsAll​(Collection<?> c)
      如果此列表包含指定集合的所有元素，则返回 true 。
      boolean CopyOnWriteArraySet.containsAll​(Collection<?> c)
      如果此集合包含指定集合的所有元素，则返回 true 。
      boolean SynchronousQueue.containsAll​(Collection<?> c)
      返回 false除非给定的集合为空。
      protected int ForkJoinPool.drainTasksTo​(Collection<? super ForkJoinTask<?>> c)
      从调度队列中删除所有可用的未执行的提交和分派任务，并将其添加到给定集合中，而不会更改其执行状态。
      int | ArrayBlockingQueue.drainTo​(Collection<? super E> c)
      int | ArrayBlockingQueue.drainTo​(Collection<? super E> c, int maxElements)
      int BlockingQueue.drainTo​(Collection<? super E> c)
      从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
      int BlockingQueue.drainTo​(Collection<? super E> c, int maxElements)
      最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
      int | DelayQueue.drainTo​(Collection<? super E> c)
      int | DelayQueue.drainTo​(Collection<? super E> c, int maxElements)
      int | LinkedBlockingDeque.drainTo​(Collection<? super E> c)
      int | LinkedBlockingDeque.drainTo​(Collection<? super E> c, int maxElements)
      int | LinkedBlockingQueue.drainTo​(Collection<? super E> c)
      int | LinkedBlockingQueue.drainTo​(Collection<? super E> c, int maxElements)
      int | LinkedTransferQueue.drainTo​(Collection<? super E> c)
      int | LinkedTransferQueue.drainTo​(Collection<? super E> c, int maxElements)
      int | PriorityBlockingQueue.drainTo​(Collection<? super E> c)
      int | PriorityBlockingQueue.drainTo​(Collection<? super E> c, int maxElements)
      int | SynchronousQueue.drainTo​(Collection<? super E> c)
      int | SynchronousQueue.drainTo​(Collection<? super E> c, int maxElements)
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。
      <T> List<Future<T>> | ForkJoinPool.invokeAll​(Collection<? extends Callable<T>> tasks)
      static <T extends ForkJoinTask<?>>
      Collection<T>             		ForkJoinTask.invokeAll​(Collection<T> tasks)
      叉指定集合中的所有任务，当 isDone适用于每个任务时返回，或遇到（未检查）异常，在这种情况下，将重新 isDone异常。
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks)
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回成功完成的结果（即，不抛出异常），如果有的话。
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。
      boolean | ArrayBlockingQueue.removeAll​(Collection<?> c)
      boolean | ConcurrentLinkedDeque.removeAll​(Collection<?> c)
      boolean | ConcurrentLinkedQueue.removeAll​(Collection<?> c)
      boolean ConcurrentSkipListSet.removeAll​(Collection<?> c)
      从此集合中删除指定集合中包含的所有元素。
      boolean CopyOnWriteArrayList.removeAll​(Collection<?> c)
      从此列表中删除指定集合中包含的所有元素。
      boolean CopyOnWriteArraySet.removeAll​(Collection<?> c)
      从此集合中删除指定集合中包含的所有元素。
      boolean | LinkedBlockingDeque.removeAll​(Collection<?> c)
      boolean | LinkedBlockingQueue.removeAll​(Collection<?> c)
      boolean | LinkedTransferQueue.removeAll​(Collection<?> c)
      boolean SynchronousQueue.removeAll​(Collection<?> c)
      始终返回 false 。
      boolean | ArrayBlockingQueue.retainAll​(Collection<?> c)
      boolean | ConcurrentLinkedDeque.retainAll​(Collection<?> c)
      boolean | ConcurrentLinkedQueue.retainAll​(Collection<?> c)
      boolean CopyOnWriteArrayList.retainAll​(Collection<?> c)
      仅保留此列表中包含在指定集合中的元素。
      boolean CopyOnWriteArraySet.retainAll​(Collection<?> c)
      仅保留该集合中包含在指定集合中的元素。
      boolean | LinkedBlockingDeque.retainAll​(Collection<?> c)
      boolean | LinkedBlockingQueue.retainAll​(Collection<?> c)
      boolean | LinkedTransferQueue.retainAll​(Collection<?> c)
      boolean SynchronousQueue.retainAll​(Collection<?> c)
      始终返回 false 。
      Constructors in java.util.concurrent with parameters of type Collection
      Constructor 描述
      ArrayBlockingQueue​(int capacity, boolean fair, Collection<? extends E> c)
      创建具有给定（固定）容量的 ArrayBlockingQueue ，指定的访问策略，并初始包含给定集合的元素，以集合的迭代器的遍历顺序添加。
      ConcurrentLinkedDeque​(Collection<? extends E> c)
      构造最初包含给定集合的元素的deque，以集合的迭代器的遍历顺序添加。
      ConcurrentLinkedQueue​(Collection<? extends E> c)
      创建一个 ConcurrentLinkedQueue最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
      ConcurrentSkipListSet​(Collection<? extends E> c)
      构造一个包含指定集合中的元素的新集合，根据它们的natural ordering对其元素进行排序 。
      CopyOnWriteArrayList​(Collection<? extends E> c)
      按照集合的迭代器返回的顺序创建一个包含指定集合元素的列表。
      CopyOnWriteArraySet​(Collection<? extends E> c)
      创建一个包含指定集合的所有元素的集合。
      DelayQueue​(Collection<? extends E> c)
      创建一个DelayQueue最初包含Delayed个实例的给定集合的元素 。
      LinkedBlockingDeque​(Collection<? extends E> c)
      创建一个 LinkedBlockingDeque ，容量为 Integer.MAX_VALUE ，最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
      LinkedBlockingQueue​(Collection<? extends E> c)
      创建 LinkedBlockingQueue容量为 Integer.MAX_VALUE ，最初包含给定集合中的元素，添加在收集迭代器的遍历顺序。
      LinkedTransferQueue​(Collection<? extends E> c)
      创建一个 LinkedTransferQueue最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
      PriorityBlockingQueue​(Collection<? extends E> c)
      创建包含指定集合中的元素的 PriorityBlockingQueue 。

    • Uses of Collection in java.util.concurrent.locks

      Methods in java.util.concurrent.locks that return Collection
      Modifier and Type 方法 描述
      Collection<Thread> AbstractQueuedLongSynchronizer.getExclusiveQueuedThreads​()
      返回一个包含可能正在等待以独占模式获取的线程的集合。
      Collection<Thread> AbstractQueuedSynchronizer.getExclusiveQueuedThreads​()
      返回一个包含可能正在等待以独占模式获取的线程的集合。
      protected Collection<Thread> ReentrantReadWriteLock.getQueuedReaderThreads​()
      返回一个包含可能正在等待获取读取锁的线程的集合。
      Collection<Thread> AbstractQueuedLongSynchronizer.getQueuedThreads​()
      返回一个包含可能正在等待获取的线程的集合。
      Collection<Thread> AbstractQueuedSynchronizer.getQueuedThreads​()
      返回一个包含可能正在等待获取的线程的集合。
      protected Collection<Thread> ReentrantLock.getQueuedThreads​()
      返回包含可能正在等待获取此锁的线程的集合。
      protected Collection<Thread> ReentrantReadWriteLock.getQueuedThreads​()
      返回一个包含可能正在等待获取读取或写入锁定的线程的集合。
      protected Collection<Thread> ReentrantReadWriteLock.getQueuedWriterThreads​()
      返回一个包含可能正在等待获取写入锁的线程的集合。
      Collection<Thread> AbstractQueuedLongSynchronizer.getSharedQueuedThreads​()
      返回包含可能正在等待在共享模式下获取的线程的集合。
      Collection<Thread> AbstractQueuedSynchronizer.getSharedQueuedThreads​()
      返回包含可能正在等待在共享模式下获取的线程的集合。
      protected Collection<Thread> AbstractQueuedLongSynchronizer.ConditionObject.getWaitingThreads​()
      返回一个包含可能在此条件下等待的线程的集合。
      Collection<Thread> AbstractQueuedLongSynchronizer.getWaitingThreads​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。
      protected Collection<Thread> AbstractQueuedSynchronizer.ConditionObject.getWaitingThreads​()
      返回一个包含可能在此条件下等待的线程的集合。
      Collection<Thread> AbstractQueuedSynchronizer.getWaitingThreads​(AbstractQueuedSynchronizer.ConditionObject condition)
      返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。
      protected Collection<Thread> ReentrantLock.getWaitingThreads​(Condition condition)
      返回包含可能在与此锁相关联的给定条件下等待的线程的集合。
      protected Collection<Thread> ReentrantReadWriteLock.getWaitingThreads​(Condition condition)
      返回包含可能在与写锁相关联的给定条件下等待的线程的集合。

    • Uses of Collection in java.util.jar

      Methods in java.util.jar that return Collection
      Modifier and Type 方法 描述
      Collection<Object> Attributes.values​()
      返回此Map中包含的属性值的集合视图。

    • Uses of Collection in java.util.stream

      Methods in java.util.stream with type parameters of type Collection
      Modifier and Type 方法 描述
      static <T,C extends Collection<T>>
      Collector<T,?,C>             		Collectors.toCollection​(Supplier<C> collectionFactory)
      返回一个 Collector ，按照遇到的顺序将输入元素累加到新的 Collection中。

    • Uses of Collection in javafx.animation

      Constructors in javafx.animation with parameters of type Collection
      Constructor 描述
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      构造函数 KeyFrame

    • Uses of Collection in javafx.beans.binding

      Classes in javafx.beans.binding that implement Collection
      Modifier and Type Class 描述
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      class  ListExpression<E>
      ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。
      class  SetBinding<E>
      提供实现ObservableSet的Binding所需的大部分功能的基类。
      class  SetExpression<E>
      SetExpression是一个ObservableSetValue，另外还有一个方便的方法来生成流畅的绑定。
      Methods in javafx.beans.binding that return Collection
      Modifier and Type | 方法 | 描述
      Collection<V> | MapExpression.values​()
      Methods in javafx.beans.binding with parameters of type Collection
      Modifier and Type | 方法 | 描述
      boolean | ListExpression.addAll​(int i, Collection<? extends E> elements)
      boolean | ListExpression.addAll​(Collection<? extends E> elements)
      boolean | SetExpression.addAll​(Collection<? extends E> elements)
      boolean | ListExpression.containsAll​(Collection<?> objects)
      boolean | SetExpression.containsAll​(Collection<?> objects)
      boolean | ListExpression.removeAll​(Collection<?> objects)
      boolean | SetExpression.removeAll​(Collection<?> objects)
      boolean | ListExpression.retainAll​(Collection<?> objects)
      boolean | SetExpression.retainAll​(Collection<?> objects)
      boolean | ListExpression.setAll​(Collection<? extends E> elements)

    • Uses of Collection in javafx.beans.property

      Classes in javafx.beans.property that implement Collection
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  ReadOnlyListProperty<E>
      超类为所有只读属性包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlySetProperty<E>
      所有readonly属性的超类包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleListProperty<E>
      这个类提供了一个Property包装一个ObservableList的全面实现。
      class  SimpleSetProperty<E>
      这个类提供了一个Property包装ObservableSet的完整实现。

    • Uses of Collection in javafx.beans.value

      Subinterfaces of Collection in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableListValue<E>
      一个可观察的参考ObservableList 。
      interface  ObservableSetValue<E>
      一个可观察的参考ObservableSet 。
      interface  WritableListValue<E>
      对ObservableList的可写参考。
      interface  WritableSetValue<E>
      可写参考ObservableSet 。

    • Uses of Collection in javafx.collections

      Subinterfaces of Collection in javafx.collections
      Modifier and Type 接口 描述
      interface  ObservableList<E>
      允许侦听器发生变化的列表。
      interface  ObservableSet<E>
      一组允许观察者跟踪变化发生时的变化。
      Classes in javafx.collections that implement Collection
      Modifier and Type Class 描述
      class  ModifiableObservableListBase<E>
      抽象类作为可修改的ObservableList实现的基类。
      class  ObservableListBase<E>
      抽象类作为ObservableList实现的基类。
      Methods in javafx.collections with parameters of type Collection
      Modifier and Type | 方法 | 描述
      boolean | ModifiableObservableListBase.addAll​(int index, Collection<? extends E> c)
      boolean | ModifiableObservableListBase.addAll​(Collection<? extends E> c)
      static <E> ObservableList<E> FXCollections.observableArrayList​(Collection<? extends E> col)
      创建一个新的可观察数组列表，并向其添加一个集合 col的内容。
      boolean | ModifiableObservableListBase.removeAll​(Collection<?> c)
      boolean | ModifiableObservableListBase.retainAll​(Collection<?> c)
      boolean | ModifiableObservableListBase.setAll​(Collection<? extends E> col)
      boolean ObservableList.setAll​(Collection<? extends E> col)
      清除ObservableList并添加集合中的所有元素。
      boolean | ObservableListBase.setAll​(Collection<? extends E> col)

    • Uses of Collection in javafx.collections.transformation

      Classes in javafx.collections.transformation that implement Collection
      Modifier and Type Class 描述
      class  FilteredList<E>
      包装一个ObservableList并使用提供的谓词过滤其内容。
      class  SortedList<E>
      包装一个ObservableList并对其内容进行排序。
      class  TransformationList<E,F>
      所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。

    • Uses of Collection in javafx.scene

      Constructors in javafx.scene with parameters of type Collection
      Constructor 描述
      Group​(Collection<Node> children)
      构建由给定的孩子组成的组。

    • Uses of Collection in javafx.scene.control

      Constructors in javafx.scene.control with parameters of type Collection
      Constructor 描述
      ChoiceDialog​(T defaultChoice, Collection<T> choices)
      创建一个新的ChoiceDialog实例，第一个参数指定应向用户显示的默认选择，第二个参数指定用户的所有可用选项的集合。

    • Uses of Collection in javafx.scene.shape

      Constructors in javafx.scene.shape with parameters of type Collection
      Constructor 描述
      Path​(Collection<? extends PathElement> elements)
      创建路径的新实例

    • Uses of Collection in javax.management

      Classes in javax.management that implement Collection
      Modifier and Type Class 描述
      class  AttributeList
      表示MBean属性值的列表。
      Methods in javax.management with parameters of type Collection
      Modifier and Type 方法 描述
      boolean AttributeList.addAll​(int index, Collection<?> c)
      将指定集合中的所有元素插入到此列表中，从指定的位置开始。
      boolean AttributeList.addAll​(Collection<?> c)
      按指定集合的Iterator返回的顺序将指定集合中的所有元素追加到此列表的末尾。

    • Uses of Collection in javax.management.openmbean

      Methods in javax.management.openmbean that return Collection
      Modifier and Type 方法 描述
      Collection<?> CompositeData.values​()
      返回此 CompositeData实例中包含的项目值的不可修改的集合视图。
      Collection<?> CompositeDataSupport.values​()
      返回此 CompositeData实例中包含的项目值的不可修改的集合视图。
      Collection<?> TabularData.values​()
      返回 TabularData实例中包含的 CompositeData值（即行）的集合视图。
      Collection<Object> TabularDataSupport.values​()
      返回此 TabularDataSupport实例中包含的行的集合视图。

    • Uses of Collection in javax.management.relation

      Classes in javax.management.relation that implement Collection
      Modifier and Type Class 描述
      class  RoleList
      RoleList表示角色列表（Role对象）。
      class  RoleUnresolvedList
      RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。
      Methods in javax.management.relation with parameters of type Collection
      Modifier and Type | 方法 | 描述
      boolean | RoleList.addAll​(int index, Collection<?> c)
      boolean | RoleList.addAll​(Collection<?> c)
      boolean | RoleUnresolvedList.addAll​(int index, Collection<?> c)
      boolean | RoleUnresolvedList.addAll​(Collection<?> c)

    • Uses of Collection in javax.net.ssl

      Methods in javax.net.ssl that return Collection
      Modifier and Type 方法 描述
      Collection<SNIMatcher> SSLParameters.getSNIMatchers​()
      返回Collection包含所有SNIMatcher •服务器名称指示的（SNI）的参数，如果没有则为null已设置。
      Methods in javax.net.ssl with parameters of type Collection
      Modifier and Type 方法 描述
      void SSLParameters.setSNIMatchers​(Collection<SNIMatcher> matchers)
      设置服务器名称指示（SNI）参数的SNIMatcher 。

    • Uses of Collection in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement Collection
      Modifier and Type Class 描述
      class  JobStateReasons
      JobStateReasons类是一个打印属性类，一组枚举值，它提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。
      Constructors in javax.print.attribute.standard with parameters of type Collection
      Constructor 描述
      JobStateReasons​(Collection<JobStateReason> collection)
      构造一个新的作业状态原因属性，其中包含与给定集合相同的JobStateReason对象。

    • Uses of Collection in javax.script

      Methods in javax.script that return Collection
      Modifier and Type 方法 描述
      Collection<Object> SimpleBindings.values​()
      返回此地图中包含的值的Collection视图。

    • Uses of Collection in javax.sql.rowset

      Methods in javax.sql.rowset that return Collection
      Modifier and Type 方法 描述
      Collection<?> JoinRowSet.getRowSets​()
      返回 Collection包含对象 RowSet已经添加到该物体 JoinRowSet对象。
      Collection<?> CachedRowSet.toCollection​()
      这个转换 CachedRowSet对象为 Collection包含所有这一切的目的 CachedRowSet对象的数据。
      Collection<?> CachedRowSet.toCollection​(int column)
      将此 CachedRowSet对象中的指定列转换为 Collection对象。
      Collection<?> CachedRowSet.toCollection​(String column)
      将此 CachedRowSet对象中的指定列转换为 Collection对象。

    • Uses of Collection in javax.tools

      Methods in javax.tools with parameters of type Collection
      Modifier and Type 方法 描述
      default void StandardJavaFileManager.setLocationForModule​(JavaFileManager.Location location, String moduleName, Collection<? extends Path> paths)
      将给定的搜索路径与给定的模块和位置相关联，该模块和位置必须是面向模块或输出位置。
      default void StandardJavaFileManager.setLocationFromPaths​(JavaFileManager.Location location, Collection<? extends Path> paths)
      将给定的搜索路径与给定位置相关联。

    • Uses of Collection in jdk.incubator.http

      Methods in jdk.incubator.http that return Collection
      Modifier and Type | 方法 | 描述
      Collection<CompletableFuture<HttpResponse<V>>> | MultiMapResult.values​()

    • Uses of Collection in jdk.jshell

      Methods in jdk.jshell that return Collection
      Modifier and Type 方法 描述
      abstract Collection<Snippet> SourceCodeAnalysis.dependents​(Snippet snippet)
      返回 Snippet的集合，如果给定的 Snippet更新，则可能需要更新。

    • Uses of Collection in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that return Collection
      Modifier and Type | 方法 | 描述
      Collection<Object> | AbstractJSObject.values​()
      Collection<Object> JSObject.values​()
      返回此对象的所有属性值的集合。
      Collection<Object> | ScriptObjectMirror.values​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Comparator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Comparator

  • Packages that use Comparator
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。

    • Uses of Comparator in java.lang

      Fields in java.lang declared as Comparator
      Modifier and Type Field 描述
      static Comparator<String> String.CASE_INSENSITIVE_ORDER
      一个比较器，可以按 compareToIgnoreCase命令 String对象。

    • Uses of Comparator in java.text

      Classes in java.text that implement Comparator
      Modifier and Type Class 描述
      class  Collator
      Collator类执行区域设置敏感的 String比较。
      class  RuleBasedCollator
      所述 RuleBasedCollator类是的具体子类 Collator ，提供了一个简单的，数据驱动的表collator。

    • Uses of Comparator in java.time

      Methods in java.time that return Comparator
      Modifier and Type 方法 描述
      static Comparator<OffsetDateTime> OffsetDateTime.timeLineOrder​()
      获取一个比较器，只比较两个 OffsetDateTime实例。

    • Uses of Comparator in java.time.chrono

      Methods in java.time.chrono that return Comparator
      Modifier and Type 方法 描述
      static Comparator<ChronoLocalDate> ChronoLocalDate.timeLineOrder​()
      获取一个比较器，比较 ChronoLocalDate的时间顺序，忽略年表。
      static Comparator<ChronoLocalDateTime<?>> ChronoLocalDateTime.timeLineOrder​()
      获取一个比较器，比较 ChronoLocalDateTime的时间顺序，忽略年表。
      static Comparator<ChronoZonedDateTime<?>> ChronoZonedDateTime.timeLineOrder​()
      获得一个比较器，比较 ChronoZonedDateTime的时间顺序忽略年表。

    • Uses of Comparator in java.util

      Methods in java.util that return Comparator
      Modifier and Type | 方法 | 描述
      Comparator<? super E> PriorityQueue.comparator​()
      返回用于为了在这个队列中的元素，或比较null如果此队列根据所述排序natural ordering的元素。
      Comparator<? super K> SortedMap.comparator​()
      返回用于为了在这个映射中的键，或比较null如果此映射使用natural ordering它的键。
      Comparator<? super E> SortedSet.comparator​()
      返回用于为了在这个组中的元素，或比较null如果这个集使用natural ordering的元素。
      Comparator<? super K> | TreeMap.comparator​()
      Comparator<? super E> | TreeSet.comparator​()
      static <T,U extends Comparable<? super U>>
      Comparator<T>             		Comparator.comparing​(Function<? super T,? extends U> keyExtractor)
      接受提取功能Comparable从类型排序键T ，并返回一个Comparator<T> ，通过那种关键的。
      static <T,U> Comparator<T> Comparator.comparing​(Function<? super T,? extends U> keyExtractor, Comparator<? super U> keyComparator)
      接受从类型T中提取排序键的T ，并返回Comparator<T> ，使用指定的Comparator进行比较。
      static <K extends Comparable<? super K>,V>
      Comparator<Map.Entry<K,V>>             		Map.Entry.comparingByKey​()
      返回一个比较器， 按键自然顺序比较Map.Entry 。
      static <K,V> Comparator<Map.Entry<K,V>> Map.Entry.comparingByKey​(Comparator<? super K> cmp)
      返回一个比较器，比较Map.Entry按键使用给定的Comparator 。
      static <K,V extends Comparable<? super V>>
      Comparator<Map.Entry<K,V>>             		Map.Entry.comparingByValue​()
      返回一个比较器， 它以自然顺序的值比较Map.Entry 。
      static <K,V> Comparator<Map.Entry<K,V>> Map.Entry.comparingByValue​(Comparator<? super V> cmp)
      返回一个比较器，使用给定的Comparator将值与Map.Entry进行比较。
      static <T> Comparator<T> Comparator.comparingDouble​(ToDoubleFunction<? super T> keyExtractor)
      接受提取功能 double从类型排序键 T ，并返回一个 Comparator<T> ，通过那种关键的。
      static <T> Comparator<T> Comparator.comparingInt​(ToIntFunction<? super T> keyExtractor)
      接受从类型 T中提取 int排序键的功能，并返回与该排序键进行比较的 Comparator<T> 。
      static <T> Comparator<T> Comparator.comparingLong​(ToLongFunction<? super T> keyExtractor)
      接受从 long类型中提取 long排序键的 T ，并返回一个按该排序键进行比较的 Comparator<T> 。
      default Comparator<? super T> Spliterator.getComparator​()
      如果这个Spliterator的来源是Spliterator.SORTED由Comparator ，则返回Comparator 。
      static <T extends Comparable<? super T>>
      Comparator<T>             		Comparator.naturalOrder​()
      返回一个以自然顺序比较Comparable个对象的比较器。
      static <T> Comparator<T> Comparator.nullsFirst​(Comparator<? super T> comparator)
      返回一个比较友好的比较器， null考虑为小于非空值。
      static <T> Comparator<T> Comparator.nullsLast​(Comparator<? super T> comparator)
      返回一个比较 null比较器， null视为大于非空值。
      default Comparator<T> Comparator.reversed​()
      返回一个比较器，强制该比较器的相反顺序。
      static <T> Comparator<T> Collections.reverseOrder​()
      返回一个比较器， Comparable实现 Comparable接口的对象集合施加了 自然排序的相反。
      static <T> Comparator<T> Collections.reverseOrder​(Comparator<T> cmp)
      返回一个比较器，它强制指定比较器的反向排序。
      static <T extends Comparable<? super T>>
      Comparator<T>             		Comparator.reverseOrder​()
      返回一个与 自然排序相反的比较器。
      default Comparator<T> Comparator.thenComparing​(Comparator<? super T> other)
      用另一个比较器返回一个字典顺序比较器。
      default <U extends Comparable<? super U>>
      Comparator<T>             		Comparator.thenComparing​(Function<? super T,? extends U> keyExtractor)
      返回具有提取 Comparable排序键的功能的字典顺序比较器。
      default <U> Comparator<T> Comparator.thenComparing​(Function<? super T,? extends U> keyExtractor, Comparator<? super U> keyComparator)
      返回具有提取要与给定的 Comparator进行比较的键的功能的字典顺序比较器。
      default Comparator<T> Comparator.thenComparingDouble​(ToDoubleFunction<? super T> keyExtractor)
      返回具有提取 double排序键的功能的字典顺序比较器。
      default Comparator<T> Comparator.thenComparingInt​(ToIntFunction<? super T> keyExtractor)
      返回具有提取 int排序键的功能的字典顺序比较器。
      default Comparator<T> Comparator.thenComparingLong​(ToLongFunction<? super T> keyExtractor)
      返回具有提取 long排序键的功能的字典顺序比较器。
      Methods in java.util with parameters of type Comparator
      Modifier and Type | 方法 | 描述
      static <T> int Arrays.binarySearch​(T[] a, int fromIndex, int toIndex, T key, Comparator<? super T> c)
      使用二进制搜索算法搜索指定对象的指定数组的范围。
      static <T> int Arrays.binarySearch​(T[] a, T key, Comparator<? super T> c)
      使用二叉搜索算法搜索指定对象的指定数组。
      static <T> int Collections.binarySearch​(List<? extends T> list, T key, Comparator<? super T> c)
      使用二叉搜索算法搜索指定对象的指定列表。
      static <T> int Arrays.compare​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex, Comparator<? super T> cmp)
      比较两个 Object阵列在 Object指定的范围。
      static <T> int Arrays.compare​(T[] a, T[] b, Comparator<? super T> cmp)
      比较两个 Object阵列，使用指定的比较器进行字典比对。
      static <T> int Objects.compare​(T a, T b, Comparator<? super T> c)
      如果参数相同，则返回0，否则返回 c.compare(a, b) 。
      static <T,U> Comparator<T> Comparator.comparing​(Function<? super T,? extends U> keyExtractor, Comparator<? super U> keyComparator)
      接受从类型T中提取排序键的T ，并返回Comparator<T> ，使用指定的Comparator比较该排序键。
      static <K,V> Comparator<Map.Entry<K,V>> Map.Entry.comparingByKey​(Comparator<? super K> cmp)
      返回一个比较器，比较Map.Entry按键使用给定的Comparator 。
      static <K,V> Comparator<Map.Entry<K,V>> Map.Entry.comparingByValue​(Comparator<? super V> cmp)
      返回一个比较器，使用给定的Comparator将值与Map.Entry进行比较。
      static <T> boolean Arrays.equals​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex, Comparator<? super T> cmp)
      如果两个指定的对象数组在指定范围内彼此 相等 ，则返回true。
      static <T> boolean Arrays.equals​(T[] a, T[] a2, Comparator<? super T> cmp)
      如果两个指定的对象数组彼此 相等 ，则返回 true 。
      static <T> T Collections.max​(Collection<? extends T> coll, Comparator<? super T> comp)
      根据指定的比较器引发的顺序返回给定集合的最大元素。
      static <T> T Collections.min​(Collection<? extends T> coll, Comparator<? super T> comp)
      根据指定的比较器引发的顺序返回给定集合的最小元素。
      static <T> int Arrays.mismatch​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex, Comparator<? super T> cmp)
      查找并返回指定范围内两个 Object数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
      static <T> int Arrays.mismatch​(T[] a, T[] b, Comparator<? super T> cmp)
      查找并返回两个 Object数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
      static <T> Comparator<T> Comparator.nullsFirst​(Comparator<? super T> comparator)
      返回一个比较友好的比较器， null视为小于非空值。
      static <T> Comparator<T> Comparator.nullsLast​(Comparator<? super T> comparator)
      返回一个比较 null比较器， null设置为大于非空值。
      static <T> void Arrays.parallelSort​(T[] a, int fromIndex, int toIndex, Comparator<? super T> cmp)
      根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。
      static <T> void Arrays.parallelSort​(T[] a, Comparator<? super T> cmp)
      根据指定的比较器引发的顺序对指定的对象数组进行排序。
      static <T> Comparator<T> Collections.reverseOrder​(Comparator<T> cmp)
      返回一个比较器，它强制指定比较器的反向排序。
      void | ArrayList.sort​(Comparator<? super E> c)
      static <T> void Arrays.sort​(T[] a, int fromIndex, int toIndex, Comparator<? super T> c)
      根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。
      static <T> void Arrays.sort​(T[] a, Comparator<? super T> c)
      根据指定的比较器引发的顺序对指定的对象数组进行排序。
      static <T> void Collections.sort​(List<T> list, Comparator<? super T> c)
      根据指定的比较器引起的顺序对指定的列表进行排序。
      default void List.sort​(Comparator<? super E> c)
      根据指定的Comparator引发的顺序排列此列表。
      void | Vector.sort​(Comparator<? super E> c)
      default Comparator<T> Comparator.thenComparing​(Comparator<? super T> other)
      用另一个比较器返回一个字典顺序比较器。
      default <U> Comparator<T> Comparator.thenComparing​(Function<? super T,? extends U> keyExtractor, Comparator<? super U> keyComparator)
      返回具有提取要与给定的 Comparator进行比较的键的功能的字典顺序比较器。
      Constructors in java.util with parameters of type Comparator
      Constructor 描述
      PriorityQueue​(int initialCapacity, Comparator<? super E> comparator)
      创建具有指定初始容量的 PriorityQueue ，该容量根据指定的比较器对其元素进行排序。
      PriorityQueue​(Comparator<? super E> comparator)
      创建具有默认初始容量的 PriorityQueue ，并根据指定的比较器对其元素进行排序。
      TreeMap​(Comparator<? super K> comparator)
      构造一个新的，空的树图，按照给定的比较器排序。
      TreeSet​(Comparator<? super E> comparator)
      构造一个新的，空的树集，根据指定的比较器进行排序。

    • Uses of Comparator in java.util.concurrent

      Methods in java.util.concurrent that return Comparator
      Modifier and Type | 方法 | 描述
      Comparator<? super K> | ConcurrentSkipListMap.comparator​()
      Comparator<? super E> | ConcurrentSkipListSet.comparator​()
      Comparator<? super E> PriorityBlockingQueue.comparator​()
      返回用于为了在这个队列中的元素，或比较null如果此队列使用natural ordering的元素。
      Methods in java.util.concurrent with parameters of type Comparator
      Modifier and Type | 方法 | 描述
      void | CopyOnWriteArrayList.sort​(Comparator<? super E> c)
      Constructors in java.util.concurrent with parameters of type Comparator
      Constructor 描述
      ConcurrentSkipListMap​(Comparator<? super K> comparator)
      构造一个新的，空的地图，根据指定的比较器进行排序。
      ConcurrentSkipListSet​(Comparator<? super E> comparator)
      构造一个新的空集合，根据指定的比较器对其元素进行排序。
      PriorityBlockingQueue​(int initialCapacity, Comparator<? super E> comparator)
      创建具有指定初始容量的 PriorityBlockingQueue ，该容量根据指定的比较器对其元素进行排序。

    • Uses of Comparator in java.util.function

      Methods in java.util.function with parameters of type Comparator
      Modifier and Type 方法 描述
      static <T> BinaryOperator<T> BinaryOperator.maxBy​(Comparator<? super T> comparator)
      返回一个BinaryOperator ，它根据指定的Comparator返回两个元素中的较大者。
      static <T> BinaryOperator<T> BinaryOperator.minBy​(Comparator<? super T> comparator)
      返回一个BinaryOperator ，它根据指定的Comparator返回两个元素中较小的一个元素。

    • Uses of Comparator in java.util.stream

      Methods in java.util.stream with parameters of type Comparator
      Modifier and Type 方法 描述
      Optional<T> Stream.max​(Comparator<? super T> comparator)
      根据提供的 Comparator返回此流的最大元素。
      static <T> Collector<T,?,Optional<T>> Collectors.maxBy​(Comparator<? super T> comparator)
      返回一个 Collector ，它根据给出的 Comparator产生最大元素，描述为 Optional<T> 。
      Optional<T> Stream.min​(Comparator<? super T> comparator)
      根据提供的 Comparator返回此流的最小元素。
      static <T> Collector<T,?,Optional<T>> Collectors.minBy​(Comparator<? super T> comparator)
      返回一个 Collector ，它根据给定的 Comparator产生最小元素，描述为 Optional<T> 。
      Stream<T> Stream.sorted​(Comparator<? super T> comparator)
      返回由该流的元素组成的流，根据提供的 Comparator进行排序。

    • Uses of Comparator in javafx.collections

      Methods in javafx.collections with parameters of type Comparator
      Modifier and Type 方法 描述
      static <T> void FXCollections.sort​(ObservableList<T> list, Comparator<? super T> c)
      使用c比较器对提供的可观察列表进行排序。
      default SortedList<E> ObservableList.sorted​(Comparator<E> comparator)
      使用指定的比较器创建此列表的SortedList包装器。

    • Uses of Comparator in javafx.collections.transformation

      Methods in javafx.collections.transformation that return Comparator
      Modifier and Type 方法 描述
      Comparator<? super E> SortedList.getComparator​()
      获取属性比较器的值。
      Methods in javafx.collections.transformation that return types with arguments of type Comparator
      Modifier and Type 方法 描述
      ObjectProperty<Comparator<? super E>> SortedList.comparatorProperty​()
      比较器，表示此SortedList的顺序。
      Methods in javafx.collections.transformation with parameters of type Comparator
      Modifier and Type 方法 描述
      void SortedList.setComparator​(Comparator<? super E> comparator)
      设置属性比较器的值。
      Constructors in javafx.collections.transformation with parameters of type Comparator
      Constructor 描述
      SortedList​(ObservableList<? extends E> source, Comparator<? super E> comparator)
      创建一个围绕源列表的新SortedList。

    • Uses of Comparator in javafx.scene.control

      Fields in javafx.scene.control declared as Comparator
      Modifier and Type Field 描述
      static Comparator TableColumnBase.DEFAULT_COMPARATOR
      默认情况下，所有列将使用此比较器执行排序。
      Methods in javafx.scene.control that return Comparator
      Modifier and Type 方法 描述
      Comparator<T> TableColumnBase.getComparator​()
      获取属性比较器的值。
      Comparator<S> TableView.getComparator​()
      获取属性比较器的值。
      Comparator<TreeItem<S>> TreeTableView.getComparator​()
      获取属性比较器的值。
      Methods in javafx.scene.control that return types with arguments of type Comparator
      Modifier and Type 方法 描述
      ObjectProperty<Comparator<T>> TableColumnBase.comparatorProperty​()
      排序此表列时使用的比较器功能。
      ReadOnlyObjectProperty<Comparator<S>> TableView.comparatorProperty​()
      比较器属性是一个只读属性，代表 sort order列表的当前状态。
      ReadOnlyObjectProperty<Comparator<TreeItem<S>>> TreeTableView.comparatorProperty​()
      比较器属性是一个只读属性，代表 sort order列表的当前状态。
      Methods in javafx.scene.control with parameters of type Comparator
      Modifier and Type 方法 描述
      void TableColumnBase.setComparator​(Comparator<T> value)
      设置属性比较器的值。

    • Uses of Comparator in javax.swing

      Methods in javax.swing that return Comparator
      Modifier and Type 方法 描述
      Comparator<?> DefaultRowSorter.getComparator​(int column)
      返回指定列的 Comparator 。
      protected Comparator<? super Component> SortingFocusTraversalPolicy.getComparator​()
      返回将用于在焦点遍历循环中对“组件”进行排序的“比较器”。
      Methods in javax.swing with parameters of type Comparator
      Modifier and Type 方法 描述
      void DefaultRowSorter.setComparator​(int column, Comparator<?> comparator)
      设置 Comparator在排序指定列时使用。
      protected void SortingFocusTraversalPolicy.setComparator​(Comparator<? super Component> comparator)
      设置在焦点遍历周期中用于对组件进行排序的比较器。
      Constructors in javax.swing with parameters of type Comparator
      Constructor 描述
      SortingFocusTraversalPolicy​(Comparator<? super Component> comparator)
      使用指定的比较器构造SortingFocusTraversalPolicy。

    • Uses of Comparator in javax.swing.table

      Methods in javax.swing.table that return Comparator
      Modifier and Type 方法 描述
      Comparator<?> TableRowSorter.getComparator​(int column)
      返回指定列的 Comparator 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Deque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Deque

  • Packages that use Deque
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of Deque in java.util

      Classes in java.util that implement Deque
      Modifier and Type Class 描述
      class  ArrayDeque<E>
      Deque接口的可调整大小的数组实现。
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
      Methods in java.util with parameters of type Deque
      Modifier and Type 方法 描述
      static <T> Queue<T> Collections.asLifoQueue​(Deque<T> deque)
      返回Deque作为先进先出（ Lifo ） Queue的视图 。

    • Uses of Deque in java.util.concurrent

      Subinterfaces of Deque in java.util.concurrent
      Modifier and Type 接口 描述
      interface  BlockingDeque<E>
      A Deque另外支持在检索元素时等待deque变为非空的阻塞操作，并且在存储元素时等待空白在deque中可用。
      Classes in java.util.concurrent that implement Deque
      Modifier and Type Class 描述
      class  ConcurrentLinkedDeque<E>
      基于链接节点的无界并发deque 。
      class  LinkedBlockingDeque<E>
      基于链接节点的可选限定的blocking deque 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Enumeration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Enumeration

  • Packages that use Enumeration
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.activation
    javax.management.loading
    提供实现高级动态加载的类。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.sasl
    包含用于支持SASL的类和接口。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of Enumeration in java.applet

      Methods in java.applet that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<Applet> AppletContext.getApplets​()
      已过时。
      查找由该applet上下文表示的文档中的所有applet。

    • Uses of Enumeration in java.awt

      Methods in java.awt that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<MenuShortcut> MenuBar.shortcuts​()
      获取此菜单栏正在管理的所有菜单快捷方式的枚举。

    • Uses of Enumeration in java.beans

      Methods in java.beans that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<String> FeatureDescriptor.attributeNames​()
      获取此功能的与区域设置无关的名称的枚举。

    • Uses of Enumeration in java.io

      Constructors in java.io with parameters of type Enumeration
      Constructor 描述
      SequenceInputStream​(Enumeration<? extends InputStream> e)
      通过记住参数，初始化一个新创建的 SequenceInputStream ，该参数必须是 Enumeration生成运行时类型为 InputStream 。

    • Uses of Enumeration in java.lang

      Methods in java.lang that return Enumeration
      Modifier and Type 方法 描述
      protected Enumeration<URL> ClassLoader.findResources​(String name)
      返回表示具有给定名称的所有资源的URL对象的枚举。
      Enumeration<URL> ClassLoader.getResources​(String name)
      查找具有给定名称的所有资源。
      static Enumeration<URL> ClassLoader.getSystemResources​(String name)
      从用于加载类的搜索路径中查找指定名称的所有资源。

    • Uses of Enumeration in java.net

      Methods in java.net that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<URL> URLClassLoader.findResources​(String name)
      返回表示URL搜索路径上具有指定名称的所有资源的URL的枚举。
      Enumeration<InetAddress> NetworkInterface.getInetAddresses​()
      获取绑定到此网络接口的所有或一部分InetAddress的枚举。
      static Enumeration<NetworkInterface> NetworkInterface.getNetworkInterfaces​()
      返回本机上所有接口的 Enumeration 。
      Enumeration<NetworkInterface> NetworkInterface.getSubInterfaces​()
      获取连接到此网络接口的所有子接口（也称为虚拟接口）的枚举。

    • Uses of Enumeration in java.security

      Methods in java.security that return Enumeration
      Modifier and Type | 方法 | 描述
      Enumeration<String> KeyStore.aliases​()
      列出此密钥库的所有别名。
      abstract Enumeration<Permission> PermissionCollection.elements​()
      返回集合中所有Permission对象的枚举。
      Enumeration<Permission> Permissions.elements​()
      返回此Permissions对象中所有PermissionCollections中所有Permission对象的枚举。
      Enumeration<Object> | Provider.elements​()
      abstract Enumeration<String> KeyStoreSpi.engineAliases​()
      列出此密钥库的所有别名。
      abstract Enumeration<Identity> IdentityScope.identities​()
      已过时。
      返回此身份范围内所有身份的枚举。
      Enumeration<Object> | Provider.keys​()

    • Uses of Enumeration in java.security.acl

      Methods in java.security.acl that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<AclEntry> Acl.entries​()
      已过时。
      返回此ACL中条目的枚举。
      Enumeration<Permission> Acl.getPermissions​(Principal user)
      已过时。
      返回指定主体的一组允许权限的枚举（表示一个实体，如个人或组）。
      Enumeration<? extends Principal> Group.members​()
      已过时。
      返回组中成员的枚举。
      Enumeration<Permission> AclEntry.permissions​()
      已过时。
      返回此ACL条目中权限的枚举。

    • Uses of Enumeration in java.sql

      Methods in java.sql that return Enumeration
      Modifier and Type 方法 描述
      static Enumeration<Driver> DriverManager.getDrivers​()
      使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索枚举。

    • Uses of Enumeration in java.util

      Classes in java.util that implement Enumeration
      Modifier and Type Class 描述
      class  StringTokenizer
      字符串tokenizer类允许应用程序将字符串拆分成令牌。
      Methods in java.util that return Enumeration
      Modifier and Type | 方法 | 描述
      abstract Enumeration<V> Dictionary.elements​()
      返回此字典中值的枚举。
      Enumeration<V> Hashtable.elements​()
      返回此散列表中值的枚举。
      Enumeration<Object> | Properties.elements​()
      Enumeration<E> Vector.elements​()
      返回此向量的组件的枚举。
      static <T> Enumeration<T> Collections.emptyEnumeration​()
      返回没有元素的枚举。
      static <T> Enumeration<T> Collections.enumeration​(Collection<T> c)
      返回指定集合的枚举。
      Enumeration<String> ListResourceBundle.getKeys​()
      返回一个 Enumeration包含在此按键 ResourceBundle及其父包。
      Enumeration<String> PropertyResourceBundle.getKeys​()
      返回一个 Enumeration包含在此按键 ResourceBundle及其父包。
      abstract Enumeration<String> ResourceBundle.getKeys​()
      返回键的枚举。
      abstract Enumeration<K> Dictionary.keys​()
      返回此字典中键的枚举。
      Enumeration<K> Hashtable.keys​()
      返回此散列表中键的枚举。
      Enumeration<Object> | Properties.keys​()
      Enumeration<?> Properties.propertyNames​()
      返回此属性列表中所有键的枚举，包括默认属性列表中的不同键，如果尚未从主属性列表中找到相同名称的键。
      Methods in java.util with parameters of type Enumeration
      Modifier and Type 方法 描述
      static <T> ArrayList<T> Collections.list​(Enumeration<T> e)
      返回一个数组列表，其中包含由枚举返回的顺序由指定的枚举返回的元素。

    • Uses of Enumeration in java.util.concurrent

      Methods in java.util.concurrent that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<V> ConcurrentHashMap.elements​()
      返回此表中值的枚举。
      Enumeration<K> ConcurrentHashMap.keys​()
      返回此表中键的枚举。

    • Uses of Enumeration in java.util.jar

      Methods in java.util.jar that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<JarEntry> JarFile.entries​()
      返回枚举jar文件条目。

    • Uses of Enumeration in java.util.logging

      Methods in java.util.logging that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<String> LogManager.getLoggerNames​()
      获取已知记录器名称的枚举。

    • Uses of Enumeration in java.util.zip

      Methods in java.util.zip that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<? extends ZipEntry> ZipFile.entries​()
      返回ZIP文件条目的枚举。

    • Uses of Enumeration in javax.activation

      Methods in javax.activation that return Enumeration
      Modifier and Type 方法 描述
      Enumeration MimeTypeParameterList.getNames​()
      检索此列表中所有名称的枚举。

    • Uses of Enumeration in javax.management.loading

      Methods in javax.management.loading that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<URL> MLetMBean.getResources​(String name)
      查找具有给定名称的所有资源。

    • Uses of Enumeration in javax.naming

      Subinterfaces of Enumeration in javax.naming
      Modifier and Type 接口 描述
      interface  NamingEnumeration<T>
      此接口用于枚举javax.naming和javax.naming.directory包中的方法返回的列表。
      Methods in javax.naming that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<String> CompositeName.getAll​()
      检索此复合名称的组件作为字符串的枚举。
      Enumeration<String> CompoundName.getAll​()
      检索此复合名称的组件作为字符串的枚举。
      Enumeration<String> Name.getAll​()
      检索此名称的组件作为字符串的枚举。
      Enumeration<RefAddr> Reference.getAll​()
      检索本参考文献中地址的列举。
      Constructors in javax.naming with parameters of type Enumeration
      Constructor 描述
      CompositeName​(Enumeration<String> comps)
      使用“comps”指定的组件构造新的组合名称实例。
      CompoundName​(Enumeration<String> comps, Properties syntax)
      使用comps和syntax中指定的组件构造一个新的复合名称实例。

    • Uses of Enumeration in javax.naming.ldap

      Methods in javax.naming.ldap that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<String> LdapName.getAll​()
      检索此名称的组件作为字符串的枚举。

    • Uses of Enumeration in javax.net.ssl

      Methods in javax.net.ssl that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<byte[]> SSLSessionContext.getIds​()
      返回所有会话ID的枚举，分组在此 SSLSessionContext 。

    • Uses of Enumeration in javax.security.sasl

      Methods in javax.security.sasl that return Enumeration
      Modifier and Type 方法 描述
      static Enumeration<SaslClientFactory> Sasl.getSaslClientFactories​()
      获得已知工厂的列表，生产 SaslClient 。
      static Enumeration<SaslServerFactory> Sasl.getSaslServerFactories​()
      获得已知工厂的计数，生产 SaslServer 。

    • Uses of Enumeration in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi that return Enumeration
      Modifier and Type 方法 描述
      static Enumeration<SyncProvider> SyncFactory.getRegisteredProviders​()
      返回当前注册的同步提供程序的枚举。

    • Uses of Enumeration in javax.swing

      Methods in javax.swing that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<TreeNode> JTree.DynamicUtilTreeNode.children​()
      子类加载孩子，如有必要。
      Enumeration<E> DefaultListModel.elements​()
      返回此列表的组件的枚举。
      protected Enumeration<TreePath> JTree.getDescendantToggledPaths​(TreePath parent)
      返回一个 Enumeration的 TreePaths已展开是后裔 parent 。
      Enumeration<AbstractButton> ButtonGroup.getElements​()
      返回参与此组的所有按钮。
      Enumeration<TreePath> JTree.getExpandedDescendants​(TreePath parent)
      返回一个 Enumeration路径的后裔 parent当前展开。
      Methods in javax.swing with parameters of type Enumeration
      Modifier and Type 方法 描述
      protected void JTree.removeDescendantToggledPaths​(Enumeration<TreePath> toRemove)
      删除已扩展的 TreePaths中的 toRemove任何后代。

    • Uses of Enumeration in javax.swing.table

      Methods in javax.swing.table that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<TableColumn> DefaultTableColumnModel.getColumns​()
      返回 Enumeration中所有列的 Enumeration 。
      Enumeration<TableColumn> TableColumnModel.getColumns​()
      返回 Enumeration中所有列的 Enumeration 。

    • Uses of Enumeration in javax.swing.text

      Methods in javax.swing.text that return Enumeration
      Modifier and Type 方法 描述
      abstract Enumeration<TreeNode> AbstractDocument.AbstractElement.children​()
      以 Enumeration返回接收者的 Enumeration 。
      Enumeration<TreeNode> AbstractDocument.BranchElement.children​()
      以 Enumeration返回接收者的 Enumeration 。
      Enumeration<TreeNode> AbstractDocument.LeafElement.children​()
      以 Enumeration返回接收者的 Enumeration 。
      Enumeration<?> AbstractDocument.AbstractElement.getAttributeNames​()
      获取所有属性的名称。
      Enumeration<?> AttributeSet.getAttributeNames​()
      返回在集合中本地定义的属性的名称的枚举。
      Enumeration<?> SimpleAttributeSet.getAttributeNames​()
      获取集合中属性的名称。
      Enumeration<?> StyleContext.NamedStyle.getAttributeNames​()
      获取所有属性的名称。
      Enumeration<?> StyleContext.SmallAttributeSet.getAttributeNames​()
      获取所有属性的名称。
      Enumeration<?> DefaultStyledDocument.getStyleNames​()
      获取样式名称列表。
      Enumeration<?> StyleContext.getStyleNames​()
      获取定义的样式的名称。
      Methods in javax.swing.text with parameters of type Enumeration
      Modifier and Type 方法 描述
      void AbstractDocument.AbstractElement.removeAttributes​(Enumeration<?> names)
      删除元素的一组属性。
      AttributeSet AbstractDocument.AttributeContext.removeAttributes​(AttributeSet old, Enumeration<?> names)
      删除元素的一组属性。
      void MutableAttributeSet.removeAttributes​(Enumeration<?> names)
      删除给定的属性集 names 。
      void SimpleAttributeSet.removeAttributes​(Enumeration<?> names)
      从列表中删除一组属性。
      void StyleContext.NamedStyle.removeAttributes​(Enumeration<?> names)
      删除元素的一组属性。
      AttributeSet StyleContext.removeAttributes​(AttributeSet old, Enumeration<?> names)
      删除元素的一组属性。

    • Uses of Enumeration in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type Enumeration
      Modifier and Type 方法 描述
      AttributeSet StyleSheet.removeAttributes​(AttributeSet old, Enumeration<?> names)
      删除元素的一组属性。

    • Uses of Enumeration in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser that return Enumeration
      Modifier and Type | 方法 | 描述
      Enumeration<?> | AttributeList.getValues​()

    • Uses of Enumeration in javax.swing.tree

      Fields in javax.swing.tree declared as Enumeration
      Modifier and Type Field 描述
      static Enumeration<TreeNode> DefaultMutableTreeNode.EMPTY_ENUMERATION
      一个总是空的枚举。
      Methods in javax.swing.tree that return Enumeration
      Modifier and Type 方法 描述
      Enumeration<TreeNode> DefaultMutableTreeNode.breadthFirstEnumeration​()
      创建并返回以宽度优先顺序遍历以此节点为根的子树的枚举。
      Enumeration<TreeNode> DefaultMutableTreeNode.children​()
      创建并返回该节点的子节点的前向枚举。
      Enumeration<? extends TreeNode> TreeNode.children​()
      以 Enumeration返回接收者的 Enumeration 。
      Enumeration<TreeNode> DefaultMutableTreeNode.depthFirstEnumeration​()
      创建并返回以深度优先顺序遍历以此节点为根的子树的枚举。
      abstract Enumeration<TreePath> AbstractLayoutCache.getVisiblePathsFrom​(TreePath path)
      返回一个 Enumerator ，从传入的位置开始可见的路径递增。
      Enumeration<TreePath> FixedHeightLayoutCache.getVisiblePathsFrom​(TreePath path)
      返回一个枚举器，它从传入的位置开始，以可见路径递增。
      Enumeration<TreePath> VariableHeightLayoutCache.getVisiblePathsFrom​(TreePath path)
      返回一个 Enumerator ，从传入的位置开始可见的路径递增。
      Enumeration<TreeNode> DefaultMutableTreeNode.pathFromAncestorEnumeration​(TreeNode ancestor)
      创建并返回从 ancestor到此节点的路径 ancestor的枚举。
      Enumeration<TreeNode> DefaultMutableTreeNode.postorderEnumeration​()
      创建并返回在postorder中遍历此节点的子树的枚举。
      Enumeration<TreeNode> DefaultMutableTreeNode.preorderEnumeration​()
      创建并返回以预订方式遍历此节点的子树的枚举。

    • Uses of Enumeration in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that return Enumeration
      Modifier and Type 方法 描述
      Enumeration NamespaceSupport.getDeclaredPrefixes​()
      返回在此上下文中声明的所有前缀的枚举。
      Enumeration NamespaceSupport.getPrefixes​()
      返回其声明在当前上下文中处于活动状态的所有前缀的枚举。
      Enumeration NamespaceSupport.getPrefixes​(String uri)
      返回给定URI的所有前缀的枚举，其声明在当前上下文中处于活动状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.EventListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.EventListener

  • Packages that use EventListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javax.imageio.event
    一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.relation
    提供关系服务的定义。
    javax.naming.event
    访问命名和目录服务时，提供对事件通知的支持。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.net.ssl
    为安全套接字包提供类。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。

    • Uses of EventListener in com.sun.java.accessibility.util

      Subinterfaces of EventListener in com.sun.java.accessibility.util
      Modifier and Type 接口 描述
      interface  GUIInitializedListener
      GUIInitializedListener接口由EventQueueMonitor类用于在GUI子系统初始化时通知感兴趣方。
      interface  TopLevelWindowListener
      EventQueueMonitor类使用TopLevelWindowListener接口在Java虚拟机中创建或销毁顶层窗口时通知有关方面。
      Classes in com.sun.java.accessibility.util that implement EventListener
      Modifier and Type Class 描述
      class  EventQueueMonitor
      EventQueueMonitor类为辅助技术提供了关键的核心功能（以及需要与辅助技术需要的一些相同功能的其他系统级技术）。
      Methods in com.sun.java.accessibility.util with parameters of type EventListener
      Modifier and Type 方法 描述
      void AccessibilityListenerList.add​(Class<? extends EventListener> t, EventListener l)
      将侦听器添加为指定类型的侦听器。
      void AccessibilityListenerList.remove​(Class<? extends EventListener> t, EventListener l)
      将侦听器作为指定类型的侦听器删除。
      Method parameters in com.sun.java.accessibility.util with type arguments of type EventListener
      Modifier and Type 方法 描述
      void AccessibilityListenerList.add​(Class<? extends EventListener> t, EventListener l)
      将侦听器添加为指定类型的侦听器。
      int AccessibilityListenerList.getListenerCount​(Class<? extends EventListener> t)
      返回此侦听器列表提供的类型的侦听器总数。
      void AccessibilityListenerList.remove​(Class<? extends EventListener> t, EventListener l)
      将侦听器作为指定类型的侦听器删除。

    • Uses of EventListener in java.awt

      Classes in java.awt that implement EventListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      protected class  Checkbox.AccessibleAWTCheckbox
      该类实现 Checkbox类的可访问性支持。
      protected class  Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
      Fire PropertyChange监听器，如果已注册，显示/隐藏..
      protected class  Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
      Fire PropertyChange监听器，如果有注册，焦点事件发生时
      protected class  Container.AccessibleAWTContainer.AccessibleContainerHandler
      消防 PropertyChange侦听器，如果有人注册，当孩子被添加或删除。
      protected class  List.AccessibleAWTList
      这个类实现 List类的可访问性支持。
      protected class  TextArea.AccessibleAWTTextArea
      该类为 TextArea类实现可访问性支持。
      protected class  TextComponent.AccessibleAWTTextComponent
      该类实现 TextComponent类的可访问性支持。
      protected class  TextField.AccessibleAWTTextField
      这个类实现 TextField类的可访问性支持。
      Fields in java.awt declared as EventListener
      Modifier and Type Field 描述
      protected EventListener AWTEventMulticaster.a
      事件链中的变量（listener-a）
      protected EventListener AWTEventMulticaster.b
      事件链中的一个变量（listener-b）
      Methods in java.awt with type parameters of type EventListener
      Modifier and Type 方法 描述
      static <T extends EventListener>
      T[]             		AWTEventMulticaster.getListeners​(EventListener l, Class<T> listenerType)
      返回链作为所有对象的数组 FooListener由该指定S java.util.EventListener 。
      <T extends EventListener>
      T[]             		Button.getListeners​(Class<T> listenerType)
      返回当前注册的所有对象的数组 FooListener在这个S Button 。
      <T extends EventListener>
      T[]             		Checkbox.getListeners​(Class<T> listenerType)
      返回此 Checkbox当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		CheckboxMenuItem.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组，这个 CheckboxMenuItem 。
      <T extends EventListener>
      T[]             		Choice.getListeners​(Class<T> listenerType)
      返回此 Choice当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Component.getListeners​(Class<T> listenerType)
      返回此 Component当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Container.getListeners​(Class<T> listenerType)
      返回此 Container当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		List.getListeners​(Class<T> listenerType)
      返回此 List当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		MenuItem.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组 MenuItem 。
      <T extends EventListener>
      T[]             		Scrollbar.getListeners​(Class<T> listenerType)
      返回当前注册的所有对象的数组 FooListener在这个S Scrollbar 。
      <T extends EventListener>
      T[]             		TextComponent.getListeners​(Class<T> listenerType)
      在此 TextComponent返回当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		TextField.getListeners​(Class<T> listenerType)
      返回此 TextField当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Window.getListeners​(Class<T> listenerType)
      在此 Window返回当前注册为 FooListener的所有对象的数组。
      Methods in java.awt that return EventListener
      Modifier and Type 方法 描述
      protected static EventListener AWTEventMulticaster.addInternal​(EventListener a, EventListener b)
      通过将listener-a和listener-b添加到一起返回生成的多播监听器。
      static <T extends EventListener>
      T[]             		AWTEventMulticaster.getListeners​(EventListener l, Class<T> listenerType)
      返回由 FooListener链接的所有对象的数组，如 java.util.EventListener 。
      <T extends EventListener>
      T[]             		Button.getListeners​(Class<T> listenerType)
      返回此 Button当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Checkbox.getListeners​(Class<T> listenerType)
      返回当前在 FooListener上注册的所有对象的数组，如 Checkbox 。
      <T extends EventListener>
      T[]             		CheckboxMenuItem.getListeners​(Class<T> listenerType)
      返回当前注册的所有对象的数组 FooListener在这个S CheckboxMenuItem 。
      <T extends EventListener>
      T[]             		Choice.getListeners​(Class<T> listenerType)
      返回此 Choice当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Component.getListeners​(Class<T> listenerType)
      返回此 Component当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Container.getListeners​(Class<T> listenerType)
      返回此 Container当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		List.getListeners​(Class<T> listenerType)
      返回当前注册的所有对象的数组 FooListener在这个S List 。
      <T extends EventListener>
      T[]             		MenuItem.getListeners​(Class<T> listenerType)
      返回此 MenuItem当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Scrollbar.getListeners​(Class<T> listenerType)
      返回当前注册的所有对象的数组 FooListener在这个S Scrollbar 。
      <T extends EventListener>
      T[]             		TextComponent.getListeners​(Class<T> listenerType)
      返回当前注册的所有对象的数组 FooListener在这个S TextComponent 。
      <T extends EventListener>
      T[]             		TextField.getListeners​(Class<T> listenerType)
      返回此 TextField当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Window.getListeners​(Class<T> listenerType)
      在此 Window返回当前注册为 FooListener的所有对象的数组。
      protected EventListener AWTEventMulticaster.remove​(EventListener oldl)
      从这个多维数据删除一个监听器。
      protected static EventListener AWTEventMulticaster.removeInternal​(EventListener l, EventListener oldl)
      从listener-l中删除旧的侦听器后，返回生成的多播侦听器。
      Methods in java.awt with parameters of type EventListener
      Modifier and Type 方法 描述
      protected static EventListener AWTEventMulticaster.addInternal​(EventListener a, EventListener b)
      通过将listener-a和listener-b添加到一起返回生成的多播监听器。
      static <T extends EventListener>
      T[]             		AWTEventMulticaster.getListeners​(EventListener l, Class<T> listenerType)
      返回由指定的 java.util.EventListener链接的 FooListener的所有对象的数组。
      protected EventListener AWTEventMulticaster.remove​(EventListener oldl)
      从这个多维数据删除一个监听器。
      protected static EventListener AWTEventMulticaster.removeInternal​(EventListener l, EventListener oldl)
      从listener-l中删除旧的侦听器后，返回生成的多播侦听器。
      protected static void AWTEventMulticaster.save​(ObjectOutputStream s, String k, EventListener l)
      将可序列化的监听器链保存到序列化流。
      Constructors in java.awt with parameters of type EventListener
      Constructor 描述
      AWTEventMulticaster​(EventListener a, EventListener b)
      创建一个事件多重实例，它将listener-a与listener-b链接起来。

    • Uses of EventListener in java.awt.datatransfer

      Subinterfaces of EventListener in java.awt.datatransfer
      Modifier and Type 接口 描述
      interface  FlavorListener
      定义一个监听FlavorEvent的对象。

    • Uses of EventListener in java.awt.desktop

      Subinterfaces of EventListener in java.awt.desktop
      Modifier and Type 接口 描述
      interface  AppForegroundListener
      当应用程序成为前台应用程序，何时不再是前台应用程序，实施者会收到通知。
      interface  AppHiddenListener
      当应用程序被用户隐藏或显示时，将通知实施者。
      interface  AppReopenedListener
      当应用程序被要求再次打开时，实施者会收到通知。
      interface  ScreenSleepListener
      当连接到系统的显示器进入省电睡眠时，实施者会收到通知。
      interface  SystemEventListener
      所有事件监听器子类的公共接口。
      interface  SystemSleepListener
      当系统进入睡眠状态，系统唤醒后，实施者会收到通知。
      interface  UserSessionListener
      当用户会话更改时，实现者会收到通知。

    • Uses of EventListener in java.awt.dnd

      Subinterfaces of EventListener in java.awt.dnd
      Modifier and Type 接口 描述
      interface  DragGestureListener
      用于接收拖动手势事件的侦听器界面。
      interface  DragSourceListener
      DragSourceListener为拖放操作的 DragSourceListener定义事件接口，以跟踪用户手势的状态，并在整个拖放操作中向用户提供适当的“拖拽”反馈。
      interface  DragSourceMotionListener
      用于在拖动操作期间接收鼠标运动事件的侦听器界面。
      interface  DropTargetListener
      DropTargetListener接口是 DropTarget类使用的回调接口，用于提供涉及主题 DropTarget的DnD操作的通知。
      Classes in java.awt.dnd that implement EventListener
      Modifier and Type Class 描述
      class  DragSourceAdapter
      用于接收拖动源事件的抽象适配器类。
      class  DragSourceContext
      DragSourceContext类负责管理拖放协议的发起方。
      class  DropTarget
      该 DropTarget与相关 Component时 Component希望接受拖放操作期间下降。
      protected static class  DropTarget.DropTargetAutoScroller
      这个受保护的嵌套类实现自动滚动
      class  DropTargetAdapter
      用于接收丢弃目标事件的抽象适配器类。
      class  MouseDragGestureRecognizer
      DragGestureRecognizer这个抽象子类定义了一个基于鼠标的手势的 DragGestureRecognizer 。
      Methods in java.awt.dnd with type parameters of type EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		DragSource.getListeners​(Class<T> listenerType)
      获取当前注册的所有对象为 FooListener s在此 DragSource 。
      Methods in java.awt.dnd that return EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		DragSource.getListeners​(Class<T> listenerType)
      获取当前注册的所有对象为 FooListener s在此 DragSource 。

    • Uses of EventListener in java.awt.event

      Subinterfaces of EventListener in java.awt.event
      Modifier and Type 接口 描述
      interface  ActionListener
      用于接收动作事件的侦听器界面。
      interface  AdjustmentListener
      用于接收调整事件的侦听器接口。
      interface  AWTEventListener
      用于接收分派到作为Component或MenuComponent或其子类的实例的对象的事件的侦听器接口。
      interface  ComponentListener
      用于接收组件事件的侦听器接口。
      interface  ContainerListener
      用于接收容器事件的侦听器接口。
      interface  FocusListener
      用于在组件上接收键盘焦点事件的侦听器界面。
      interface  HierarchyBoundsListener
      用于接收祖先移动和调整大小的事件的侦听器接口。
      interface  HierarchyListener
      用于接收层次结构的侦听器界面更改事件。
      interface  InputMethodListener
      用于接收输入法事件的侦听器接口。
      interface  ItemListener
      用于接收项目事件的侦听器接口。
      interface  KeyListener
      用于接收键盘事件（按键）的侦听器界面。
      interface  MouseListener
      用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
      interface  MouseMotionListener
      用于在组件上接收鼠标运动事件的侦听器界面。
      interface  MouseWheelListener
      用于在组件上接收鼠标滚轮事件的侦听器界面。
      interface  TextListener
      用于接收文本事件的侦听器界面。
      interface  WindowFocusListener
      收听界面接收 WindowEvents ，其中 WINDOW_GAINED_FOCUS和 WINDOW_LOST_FOCUS事件。
      interface  WindowListener
      用于接收窗口事件的侦听器界面。
      interface  WindowStateListener
      用于接收窗口状态事件的侦听器接口。
      Classes in java.awt.event that implement EventListener
      Modifier and Type Class 描述
      class  AWTEventListenerProxy
      一个扩展 EventListenerProxy专门用于为特定事件掩码添加一个 AWTEventListener的类。
      class  ComponentAdapter
      用于接收组件事件的抽象适配器类。
      class  ContainerAdapter
      用于接收容器事件的抽象适配器类。
      class  FocusAdapter
      用于接收键盘焦点事件的抽象适配器类。
      class  HierarchyBoundsAdapter
      用于接收祖先移动和调整大小的事件的抽象适配器类。
      class  KeyAdapter
      用于接收键盘事件的抽象适配器类。
      class  MouseAdapter
      用于接收鼠标事件的抽象适配器类。
      class  MouseMotionAdapter
      用于接收鼠标运动事件的抽象适配器类。
      class  WindowAdapter
      用于接收窗口事件的抽象适配器类。

    • Uses of EventListener in java.beans

      Subinterfaces of EventListener in java.beans
      Modifier and Type 接口 描述
      interface  PropertyChangeListener
      一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
      interface  VetoableChangeListener
      当一个bean更改“constrained”属性时，VetoableChange事件就被触发。
      Classes in java.beans that implement EventListener
      Modifier and Type Class 描述
      class  PropertyChangeListenerProxy
      一个类扩展了 EventListenerProxy专门用于添加一个“bound”属性的 PropertyChangeListener 。
      class  VetoableChangeListenerProxy
      一个类扩展了 EventListenerProxy专门用于添加一个“约束”属性的 VetoableChangeListener 。

    • Uses of EventListener in java.beans.beancontext

      Subinterfaces of EventListener in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContextMembershipListener
      BeanContext的成员状态发生变化时，BeanContexts会在此界面上触发事件。
      interface  BeanContextServiceRevokedListener
      用于接收 BeanContextServiceRevokedEvent对象的侦听器接口。
      interface  BeanContextServices
      BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
      interface  BeanContextServicesListener
      用于接收 BeanContextServiceAvailableEvent对象的侦听器接口。
      Classes in java.beans.beancontext that implement EventListener
      Modifier and Type | Class | 描述
      class  BeanContextChildSupport
      这是一个通用支持类，用于为实现BeanContextChild协议提供支持。
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      protected class  | BeanContextServicesSupport.BCSSProxyServiceProvider
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。

    • Uses of EventListener in java.util

      Classes in java.util with type parameters of type EventListener
      Modifier and Type Class 描述
      class  EventListenerProxy<T extends EventListener>
      EventListener类的抽象包装类， EventListener一组附加参数与侦听器相关联。
      Classes in java.util that implement EventListener
      Modifier and Type Class 描述
      class  EventListenerProxy<T extends EventListener>
      EventListener类的抽象包装类， EventListener一组附加参数与侦听器相关联。

    • Uses of EventListener in java.util.prefs

      Subinterfaces of EventListener in java.util.prefs
      Modifier and Type 接口 描述
      interface  NodeChangeListener
      用于接收偏好节点更改事件的侦听器。
      interface  PreferenceChangeListener
      用于接收偏好更改事件的侦听器。

    • Uses of EventListener in javafx.event

      Subinterfaces of EventListener in javafx.event
      Modifier and Type 接口 描述
      interface  EventHandler<T extends Event>
      处理程序用于特定类/类型的事件。
      Classes in javafx.event that implement EventListener
      Modifier and Type Class 描述
      class  WeakEventHandler<T extends Event>
      用于事件处理程序注册代替其关联的事件处理程序。

    • Uses of EventListener in javax.imageio.event

      Subinterfaces of EventListener in javax.imageio.event
      Modifier and Type 接口 描述
      interface  IIOReadProgressListener
      ImageReader实现通过呼叫者通知其图像和缩略图读取进度方法的界面。
      interface  IIOReadUpdateListener
      ImageReader实现使用的界面来通知呼叫者他们的图像和像素更新的缩略图读取方法。
      interface  IIOReadWarningListener
      ImageReader实现使用的接口来通知呼叫者他们的图像和缩略图读取警告方法（非致命错误）。
      interface  IIOWriteProgressListener
      ImageWriter实现使用的接口通知呼叫者他们的图像写入方法的进度。
      interface  IIOWriteWarningListener
      ImageWriter实现使用的界面来通知呼叫者他们的图像和缩略图读取警告方法（非致命错误）。

    • Uses of EventListener in javax.management

      Subinterfaces of EventListener in javax.management
      Modifier and Type 接口 描述
      interface  NotificationListener
      应该由想要接收通知的对象来实现。

    • Uses of EventListener in javax.management.relation

      Classes in javax.management.relation that implement EventListener
      Modifier and Type Class 描述
      class  RelationService
      关系服务负责创建和删除关系类型和关系，处理一致性和提供查询机制。

    • Uses of EventListener in javax.naming.event

      Subinterfaces of EventListener in javax.naming.event
      Modifier and Type 接口 描述
      interface  NamespaceChangeListener
      指定对名称空间更改感兴趣的侦听器必须实现的方法。
      interface  NamingListener
      该接口是处理 NamingEvent s的侦听器接口的根。
      interface  ObjectChangeListener
      指定事件类型为 OBJECT_CHANGED的 NamingEvent的侦听 OBJECT_CHANGED必须实现的方法。

    • Uses of EventListener in javax.naming.ldap

      Subinterfaces of EventListener in javax.naming.ldap
      Modifier and Type 接口 描述
      interface  UnsolicitedNotificationListener
      该接口用于处理 UnsolicitedNotificationEvent 。

    • Uses of EventListener in javax.net.ssl

      Subinterfaces of EventListener in javax.net.ssl
      Modifier and Type 接口 描述
      interface  HandshakeCompletedListener
      该接口由希望接收关于在给定SSL连接上完成SSL协议握手的通知的任何类实现。
      interface  SSLSessionBindingListener
      该接口由想要知道何时被绑定或从SSLSession绑定的对象来实现。

    • Uses of EventListener in javax.sound.midi

      Subinterfaces of EventListener in javax.sound.midi
      Modifier and Type 接口 描述
      interface  ControllerEventListener
      ControllerEventListener接口应当由Sequencer处理请求类型的MIDI控制更改事件时需要通知实例的类实现。
      interface  MetaEventListener
      MetaEventListener接口应该由Sequencer处理MetaMessage时需要通知实例的类实现。

    • Uses of EventListener in javax.sound.sampled

      Subinterfaces of EventListener in javax.sound.sampled
      Modifier and Type 接口 描述
      interface  LineListener
      实现 LineListener接口的类的实例可以注册以在线路状态更改时接收事件。

    • Uses of EventListener in javax.sql

      Subinterfaces of EventListener in javax.sql
      Modifier and Type 接口 描述
      interface  ConnectionEventListener
      注册要通知由 PooledConnection对象生成的事件的对象。
      interface  RowSetListener
      一个接口，必须由一个组件实现，该组件希望在 RowSet对象的生命中发生重大事件时被通知。
      interface  StatementEventListener
      注册在“声明”池中的PreparedStatements上发生的事件的通知对象。

    • Uses of EventListener in javax.swing

      Subinterfaces of EventListener in javax.swing
      Modifier and Type 接口 描述
      interface  Action
      所述 Action接口提供了一个有用的扩展到 ActionListener在箱子接口，其中相同的功能可以由若干控件访问。
      Classes in javax.swing that implement EventListener
      Modifier and Type Class 描述
      class  AbstractAction
      该类提供了JFC Action接口的默认实现。
      protected class  AbstractButton.ButtonChangeListener
      扩展 ChangeListener可串行化。
      protected class  DefaultCellEditor.EditorDelegate
      受保护的 EditorDelegate课。
      protected class  JCheckBox.AccessibleJCheckBox
      该类实现 JCheckBox类的可访问性支持。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      这个类实现了 JCheckBoxMenuItem类的可访问性支持。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      protected class  JComponent.AccessibleJComponent.AccessibleContainerHandler
      Fire PropertyChange监听器，如果一个注册，当孩子添加/删除。
      protected class  JComponent.AccessibleJComponent.AccessibleFocusHandler
      已过时。
      此类不再使用或需要。 java.awt.Component.AccessibleAWTComponent提供相同的功能，它在Component处理。
      protected class  JEditorPane.AccessibleJEditorPane
      这个类实现 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      该类提供对 AccessibleHypertext支持，并且在 EditorKit安装的 JEditorPane是 JEditorPane的实例的情况下 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText 。
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并接收在其边框内生成的所有 AWTEvent的通知。
      protected class  JList.AccessibleJList
      该类为 JList类实现可访问性支持。
      protected class  JMenu.AccessibleJMenu
      该类为 JMenu类实现可访问性支持。
      protected class  JMenu.WinListener
      监听一个弹出窗口关闭的监听器类。
      protected class  JMenuItem.AccessibleJMenuItem
      该类实现 JMenuItem类的可访问性支持。
      protected class  JPasswordField.AccessibleJPasswordField
      这个类实现 JPasswordField类的可访问性支持。
      protected class  JPopupMenu.AccessibleJPopupMenu
      这个类实现了 JPopupMenu类的可访问性支持。
      protected class  JRadioButton.AccessibleJRadioButton
      这个类实现 JRadioButton类的可访问性支持。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      这个类实现 JRadioButtonMenuItem类的可访问性支持。
      protected class  JScrollPane.AccessibleJScrollPane
      这个类实现 JScrollPane类的可访问性支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner实现 JSpinner类的辅助功能支持。
      static class  JSpinner.DateEditor
      一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。
      static class  JSpinner.DefaultEditor
      更专业的编辑器的简单基类，可以使用 JFormattedTextField显示模型当前值的 JFormattedTextField 。
      static class  JSpinner.ListEditor
      一个 JSpinner的编辑器，其型号是 SpinnerListModel 。
      static class  JSpinner.NumberEditor
      一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
      protected class  JTabbedPane.AccessibleJTabbedPane
      这个类实现 JTabbedPane类的辅助功能支持。
      protected class  JTabbedPane.ModelListener
      我们通过 ModelChanged （而不是模型本身）将 ModelChanged事件传递给听众，作为事件源。
      class  JTable
      JTable用于显示和编辑单元格的常规二维表。
      protected class  JTable.AccessibleJTable
      该类实现 JTable类的辅助功能支持。
      protected class  JTextArea.AccessibleJTextArea
      该类为 JTextArea类实现可访问性支持。
      protected class  JTextField.AccessibleJTextField
      这个类实现 JTextField类的可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      这个类实现 JToggleButton类的可访问性支持。
      protected class  JTree.AccessibleJTree
      这个类实现 JTree类的可访问性支持。
      protected class  JTree.TreeModelHandler
      监听模型并相应地更新 expandedState节点被删除或更改。
      protected class  JTree.TreeSelectionRedirector
      手柄创建一个新的 TreeSelectionEvent与 JTree作为来源，并传递给所有的听众。
      protected class  JViewport.ViewListener
      视图的监听器。
      protected class  ProgressMonitor.AccessibleProgressMonitor
      AccessibleProgressMonitor为 ProgressMonitor类实现可访问性支持。
      class  ToolTipManager
      管理系统中的所有 ToolTips 。
      protected class  ToolTipManager.insideTimerAction
      内部定时器动作。
      protected class  ToolTipManager.outsideTimerAction
      外部定时器动作。
      protected class  ToolTipManager.stillInsideTimerAction
      仍然在定时器动作。
      Methods in javax.swing with type parameters of type EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		AbstractListModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		AbstractSpinnerModel.getListeners​(Class<T> listenerType)
      返回添加到此模型的给定类型的所有侦听器的数组。
      <T extends EventListener>
      T[]             		DefaultBoundedRangeModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultButtonModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultListSelectionModel.getListeners​(Class<T> listenerType)
      返回此模型上当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultSingleSelectionModel.getListeners​(Class<T> listenerType)
      在此模型上返回当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		JComponent.getListeners​(Class<T> listenerType)
      返回此 JComponent当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Timer.getListeners​(Class<T> listenerType)
      返回此 Timer当前注册的所有对象的数组为 FooListener s。
      Methods in javax.swing that return EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		AbstractListModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		AbstractSpinnerModel.getListeners​(Class<T> listenerType)
      返回添加到此模型的给定类型的所有侦听器的数组。
      <T extends EventListener>
      T[]             		DefaultBoundedRangeModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultButtonModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultListSelectionModel.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultSingleSelectionModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		JComponent.getListeners​(Class<T> listenerType)
      返回此 JComponent当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Timer.getListeners​(Class<T> listenerType)
      返回此 Timer当前注册为 FooListener的所有对象的数组。

    • Uses of EventListener in javax.swing.event

      Subinterfaces of EventListener in javax.swing.event
      Modifier and Type 接口 描述
      interface  AncestorListener
      AncestorListener接口，用于在JComponent或其祖先之一发生更改时支持通知。
      interface  CaretListener
      侦听器，用于更改文本组件的插入位置。
      interface  CellEditorListener
      CellEditorListener定义了一个监听CellEditor中更改的对象的接口
      interface  ChangeListener
      定义一个监听ChangeEvents的对象。
      interface  DocumentListener
      观察者注册接收文本文档更改通知的界面。
      interface  HyperlinkListener
      HyperlinkListener
      interface  InternalFrameListener
      用于接收内部帧事件的侦听器接口。
      interface  ListDataListener
      的ListDataListener
      interface  ListSelectionListener
      列表选择值更改时通知的侦听器。
      interface  MenuDragMouseListener
      定义一个菜单鼠标拖动监听器。
      interface  MenuKeyListener
      MenuKeyListener添加
      interface  MenuListener
      定义菜单事件的侦听器。
      interface  MouseInputListener
      在 MouseListener和 MouseMotionListener接口中实现所有方法的侦听器。
      interface  PopupMenuListener
      弹出菜单侦听器
      interface  RowSorterListener
      RowSorterListener被通知更改为 RowSorter 。
      interface  TableColumnModelListener
      TableColumnModelListener定义了一个监听TableColumnModel中更改的对象的接口。
      interface  TableModelListener
      TableModelListener定义了一个监听TableModel中更改的对象的接口。
      interface  TreeExpansionListener
      当树展开或折叠节点时通知的侦听器。
      interface  TreeModelListener
      定义侦听TreeModel中更改的对象的接口。
      interface  TreeSelectionListener
      当TreeSelectionModel中的选择更改时通知的侦听器。
      interface  TreeWillExpandListener
      当树展开或折叠节点时通知的侦听器。
      interface  UndoableEditListener
      接口由有兴趣听取关于可撤销操作的类实现。
      Classes in javax.swing.event that implement EventListener
      Modifier and Type Class 描述
      class  InternalFrameAdapter
      用于接收内部帧事件的抽象适配器类。
      class  MouseInputAdapter
      MouseInputListener接口的空白实现，为简化创建监听者的任务提供了便利，仅通过扩展和实现感兴趣的方法。
      Methods in javax.swing.event with type parameters of type EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      void             		EventListenerList.add​(Class<T> t, T l)
      将侦听器添加为指定类型的侦听器。
      <T extends EventListener>
      T[]             		EventListenerList.getListeners​(Class<T> t)
      返回给定类型的所有侦听器的数组。
      <T extends EventListener>
      void             		EventListenerList.remove​(Class<T> t, T l)
      将侦听器作为指定类型的侦听器删除。
      Methods in javax.swing.event that return EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		EventListenerList.getListeners​(Class<T> t)
      返回给定类型的所有侦听器的数组。

    • Uses of EventListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement EventListener
      Modifier and Type Class 描述
      class  BasicButtonListener
      按钮监听器
      class  BasicColorChooserUI.PropertyHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicComboBoxEditor
      可编辑组合框的默认编辑器。
      static class  BasicComboBoxEditor.UIResource
      BasicComboBoxEditor的子类实现UIResource。
      class  BasicComboBoxUI.FocusHandler
      当焦点丢失时，此侦听器隐藏弹出窗口。
      class  BasicComboBoxUI.ItemHandler
      此监听器监视组合框中对选择的更改。
      class  BasicComboBoxUI.KeyHandler
      该侦听器检查键事件是否不是导航键。
      class  BasicComboBoxUI.ListDataHandler
      这位听众观看 ComboBoxModel变化。
      class  BasicComboBoxUI.PropertyChangeHandler
      该监听器监视组合框中已更改的绑定属性。
      class  BasicComboPopup.InvocationKeyHandler
      从Java 2平台v 1.4开始，此类现在已经过时，仅用于向后兼容API。
      protected class  BasicComboPopup.InvocationMouseHandler
      在组合框（ 而不是其弹出菜单）上注册的侦听器来处理影响弹出菜单状态的鼠标事件。
      protected class  BasicComboPopup.InvocationMouseMotionHandler
      如果拖动列表，该监听器将监视拖动并更新列表中的当前选择。
      protected class  BasicComboPopup.ItemHandler
      此监听器监视组合框中对选择的更改。
      class  BasicComboPopup.ListDataHandler
      从1.4开始，这个类现在已经过时了，不做任何事情，只能包含用于向后兼容的API。
      protected class  BasicComboPopup.ListMouseHandler
      当列表中释放鼠标时，此侦听器会隐藏弹出窗口。
      protected class  BasicComboPopup.ListMouseMotionHandler
      当您将鼠标移动到列表上时，此侦听器将更改所选项。
      protected class  BasicComboPopup.ListSelectionHandler
      从Java 2平台v 1.4开始，这个类现在已经过时了，不做任何事情，只包含在后端的API兼容性中。
      protected class  BasicComboPopup.PropertyChangeHandler
      该监听器监视组合框中已更改的绑定属性。
      class  BasicDesktopIconUI.MouseInputHandler
      监听鼠标移动并对其进行操作。
      protected class  BasicDesktopPaneUI.CloseAction
      处理关闭内部框架。
      protected class  BasicDesktopPaneUI.MaximizeAction
      处理最大化内部框架。
      protected class  BasicDesktopPaneUI.MinimizeAction
      处理最小化内部框架。
      protected class  BasicDesktopPaneUI.NavigateAction
      处理导航到下一个内部框架。
      protected class  BasicDesktopPaneUI.OpenAction
      处理恢复最小化或最大化的内部框架。
      class  BasicDirectoryModel
      文件列表的基本实现。
      protected class  BasicFileChooserUI.ApproveSelectionAction
      响应打开或保存请求
      protected class  BasicFileChooserUI.CancelSelectionAction
      回复取消请求。
      protected class  BasicFileChooserUI.ChangeToParentDirectoryAction
      更改为父目录操作。
      protected class  BasicFileChooserUI.DoubleClickListener
      双击监听器。
      protected class  BasicFileChooserUI.GoHomeAction
      在“家”键事件或等效事件上行事。
      protected class  BasicFileChooserUI.NewFolderAction
      创建一个新文件夹。
      protected class  BasicFileChooserUI.SelectionListener
      选择听众。
      protected class  BasicFileChooserUI.UpdateAction
      重新扫描当前目录中的文件
      class  BasicInternalFrameTitlePane.CloseAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.IconifyAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.MaximizeAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.MoveAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.PropertyChangeHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.RestoreAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.SizeAction
      这个类应该被视为一个“受保护”的内部类。
      protected class  BasicInternalFrameUI.BasicInternalFrameListener
      基本内部框架监听器。
      protected class  BasicInternalFrameUI.BorderListener
      倾听边界调整。
      protected class  BasicInternalFrameUI.ComponentHandler
      组件处理程序
      protected class  BasicInternalFrameUI.GlassPaneDispatcher
      玻璃窗格调度器。
      class  BasicInternalFrameUI.InternalFramePropertyChangeListener
      内部框架属性更改侦听器。
      class  BasicLabelUI
      LabelUI的Windows L＆F实现。
      class  BasicListUI.FocusHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicListUI.ListDataHandler
      ListDataListener被添加到 JLists型号在 installUI time ，并且每当JList.model属性更改。
      class  BasicListUI.ListSelectionHandler
      在installUI时添加到JLists选择模型的ListSelectionListener，以及JList.selectionModel属性更改时。
      class  BasicListUI.MouseInputHandler
      鼠标输入和JList的焦点处理。
      class  BasicListUI.PropertyChangeHandler
      在InstallUI时添加到JList的PropertyChangeListener。
      protected class  BasicMenuItemUI.MouseInputHandler
      鼠标输入处理程序
      class  BasicMenuUI.ChangeHandler
      从Java 2平台1.4开始，这个以前没有记录的类现在已经过时了。
      protected class  BasicMenuUI.MouseInputHandler
      由菜单项实例化和使用，以处理鼠标事件当前的菜单选择。
      class  BasicOptionPaneUI.ButtonActionListener
      这个类应该被视为一个“受保护”的内部类。
      class  BasicOptionPaneUI.PropertyChangeHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicProgressBarUI.ChangeHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicRootPaneUI
      RootPaneUI的基本实现，所有JRootPane实例之间共享一个。
      protected class  BasicScrollBarUI.ArrowButtonListener
      光标键侦听器。
      protected class  BasicScrollBarUI.ModelListener
      监听模式更改的监听器。
      class  BasicScrollBarUI.PropertyChangeHandler
      属性更改处理程序
      protected class  BasicScrollBarUI.ScrollListener
      ScrollPane启动的滚动事件侦听器。
      protected class  BasicScrollBarUI.TrackListener
      跟踪鼠标拖动。
      class  BasicScrollPaneUI.HSBChangeListener
      水平滚动条监听器。
      protected class  BasicScrollPaneUI.MouseWheelHandler
      MouseWheelHandler是一个实现MouseWheelListener接口的内部类。
      class  BasicScrollPaneUI.PropertyChangeHandler
      属性更改处理程序
      class  BasicScrollPaneUI.ViewportChangeHandler
      监听器用于视口事件。
      class  BasicScrollPaneUI.VSBChangeListener
      垂直卷轴侦听器。
      class  BasicSliderUI.ActionScroller
      从Java 2平台v1.3开始，这个未记录的类就不再使用了。
      class  BasicSliderUI.ChangeHandler
      数据模型侦听器
      class  BasicSliderUI.ComponentHandler
      调整事件大小的侦听器。
      class  BasicSliderUI.FocusHandler
      聚焦改变听众
      class  BasicSliderUI.PropertyChangeHandler
      属性更改处理程序。
      class  BasicSliderUI.ScrollListener
      滚动事件侦听器。
      class  BasicSliderUI.TrackListener
      跟踪鼠标移动。
      class  BasicSplitPaneDivider
      BasicSplitPaneUI使用的分隔符。
      protected class  BasicSplitPaneDivider.MouseHandler
      MouseHandler负责将鼠标事件（释放，拖动...）转换为适当的DragController方法。
      class  BasicSplitPaneUI.FocusHandler
      JSplitPane UI使用的FocusListener的实现。
      class  BasicSplitPaneUI.KeyboardDownRightHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicSplitPaneUI.KeyboardEndHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicSplitPaneUI.KeyboardHomeHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicSplitPaneUI.KeyboardResizeToggleHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicSplitPaneUI.KeyboardUpLeftHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicSplitPaneUI.PropertyHandler
      实现JSplitPane UI使用的PropertyChangeListener。
      class  BasicTabbedPaneUI.FocusHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTabbedPaneUI.MouseHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTabbedPaneUI.PropertyChangeHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTabbedPaneUI.TabSelectionHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTableHeaderUI.MouseInputHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTableUI.FocusHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTableUI.KeyHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTableUI.MouseInputHandler
      这个类应该被视为一个“受保护”的内部类。
      static class  BasicTextUI.BasicCaret
      接口默认实现 Caret 。
      class  BasicToolBarUI.DockingListener
      这个类应该被视为一个“受保护”的内部类。
      protected class  BasicToolBarUI.FrameListener
      该类监听窗口事件。
      protected class  BasicToolBarUI.PropertyListener
      该类监听属性更改的事件。
      protected class  BasicToolBarUI.ToolBarContListener
      该类侦听组件事件。
      protected class  BasicToolBarUI.ToolBarFocusListener
      班级聆听焦点事件。
      class  BasicTreeUI.CellEditorHandler
      监听器负责获取单元格编辑事件并相应地更新树。
      class  BasicTreeUI.ComponentHandler
      更新滚动时的首选大小（如有必要）。
      class  BasicTreeUI.FocusHandler
      当重点丢失/获得时，重新排列主导选择行。
      class  BasicTreeUI.KeyHandler
      这用于获取多个关键事件以适当地生成事件。
      class  BasicTreeUI.MouseHandler
      TreeMouseListener负责根据鼠标事件更新选择。
      class  BasicTreeUI.MouseInputHandler
      MouseInputHandler处理所有鼠标事件，包括鼠标移动事件，直到鼠标释放到它构造的目的地。
      class  BasicTreeUI.PropertyChangeHandler
      PropertyChangeListener为树。
      class  BasicTreeUI.SelectionModelPropertyChangeHandler
      在TreeSelectionModel上的侦听器，如果模型的任何属性更改，则重置行选择。
      class  BasicTreeUI.TreeCancelEditingAction
      ActionListener在执行操作时调用cancelEditing。
      class  BasicTreeUI.TreeExpansionHandler
      响应节点扩展/折叠更新TreeState。
      class  BasicTreeUI.TreeHomeAction
      TreeHomeAction用于处理结束/ home操作。
      class  BasicTreeUI.TreeIncrementAction
      TreeIncrementAction用于处理上/下动作。
      class  BasicTreeUI.TreeModelHandler
      将所有TreeModel事件转发给TreeState。
      class  BasicTreeUI.TreePageAction
      TreePageAction处理页面向上和向下翻页事件。
      class  BasicTreeUI.TreeSelectionHandler
      监听选择模型中的更改，并相应地更新显示。
      class  BasicTreeUI.TreeToggleAction
      对于第一个选定的行展开将被切换。
      class  BasicTreeUI.TreeTraverseAction
      TreeTraverseAction是用于左/右键的动作。

    • Uses of EventListener in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement EventListener
      Modifier and Type Class 描述
      class  MetalComboBoxEditor
      Metal可编辑组合框的默认编辑器
      static class  MetalComboBoxEditor.UIResource
      BasicComboBoxEditor的子类实现UIResource。
      class  MetalComboBoxUI.MetalPropertyChangeListener
      这个类应该被视为一个“受保护”的内部类。
      protected class  MetalFileChooserUI.DirectoryComboBoxAction
      当DirectoryComboBox更改所选项目时使用。
      protected class  MetalFileChooserUI.FilterComboBoxModel
      类型面部选择组合框的数据模型。
      protected class  MetalFileChooserUI.SingleClickListener
      已过时。
      截至JDK版本9.过时的课程。
      class  MetalLabelUI
      LabelUI的Windows L＆F实现。
      class  MetalRootPaneUI
      提供金属外观实现 RootPaneUI 。
      protected class  MetalSliderUI.MetalPropertyListener
      PropertyListener为 JSlider.isFilled 。
      protected class  MetalToolBarUI.MetalContainerListener
      不再使用
      protected class  MetalToolBarUI.MetalDockingListener
      DockingListener适用于 MetalToolBarUI 。
      protected class  MetalToolBarUI.MetalRolloverListener
      不再使用

    • Uses of EventListener in javax.swing.plaf.synth

      Classes in javax.swing.plaf.synth that implement EventListener
      Modifier and Type Class 描述
      class  SynthButtonUI
      为JButton提供Synth L＆F UI代表。
      class  SynthCheckBoxMenuItemUI
      为JCheckBoxMenuItem提供Synth L＆F UI代表。
      class  SynthCheckBoxUI
      为JCheckBox提供Synth L＆F UI代表。
      class  SynthColorChooserUI
      为JColorChooser提供Synth L＆F UI代表。
      class  SynthComboBoxUI
      为JComboBox提供Synth L＆F UI代表。
      class  SynthDesktopIconUI
      为桌面上最小化的内部框架提供Synth L＆F UI代理。
      class  SynthDesktopPaneUI
      为JDesktopPane提供Synth L＆F UI代表。
      class  SynthInternalFrameUI
      为JInternalFrame提供Synth L＆F UI代表。
      class  SynthLabelUI
      为JLabel提供Synth L＆F UI代表。
      class  SynthListUI
      为JList提供Synth L＆F UI代表。
      class  SynthMenuBarUI
      为JMenuBar提供Synth L＆F UI代表。
      class  SynthMenuItemUI
      为JMenuItem提供Synth L＆F UI代表。
      class  SynthMenuUI
      为JMenu提供Synth L＆F UI代表。
      class  SynthOptionPaneUI
      为JOptionPane提供Synth L＆F UI代表。
      class  SynthPanelUI
      为JPanel提供Synth L＆F UI代表。
      class  SynthPopupMenuUI
      为JPopupMenu提供Synth L＆F UI代表。
      class  SynthProgressBarUI
      为JProgressBar提供Synth L＆F UI代表。
      class  SynthRadioButtonMenuItemUI
      为JRadioButtonMenuItem提供Synth L＆F UI代表。
      class  SynthRadioButtonUI
      为JRadioButton提供Synth L＆F UI代表。
      class  SynthRootPaneUI
      为JRootPane提供Synth L＆F UI代表。
      class  SynthScrollBarUI
      为JScrollBar提供Synth L＆F UI代表。
      class  SynthScrollPaneUI
      为JScrollPane提供Synth L＆F UI代表。
      class  SynthSeparatorUI
      为JSeparator提供Synth L＆F UI代表。
      class  SynthSliderUI
      为JSlider提供Synth L＆F UI代表。
      class  SynthSpinnerUI
      为JSpinner提供Synth L＆F UI代表。
      class  SynthSplitPaneUI
      为JSplitPane提供Synth L＆F UI代表。
      class  SynthTabbedPaneUI
      为JTabbedPane提供Synth L＆F UI代表。
      class  SynthTableHeaderUI
      为JTableHeader提供Synth L＆F UI代表。
      class  SynthTableUI
      为JTable提供Synth L＆F UI代表。
      class  SynthToggleButtonUI
      为JToggleButton提供Synth L＆F UI代表。
      class  SynthToolBarUI
      为JToolBar提供Synth L＆F UI代表。
      class  SynthToolTipUI
      为JToolTip提供Synth L＆F UI代表。
      class  SynthTreeUI
      为JTree提供Synth L＆F UI代表。
      class  SynthViewportUI
      为JViewport提供Synth L＆F UI代表。

    • Uses of EventListener in javax.swing.table

      Classes in javax.swing.table that implement EventListener
      Modifier and Type Class 描述
      class  DefaultTableColumnModel
      JTable的标准列处理程序。
      class  JTableHeader
      这是管理 JTable的标题的 JTable 。
      Methods in javax.swing.table with type parameters of type EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		AbstractTableModel.getListeners​(Class<T> listenerType)
      返回此 AbstractTableModel当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultTableColumnModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      Methods in javax.swing.table that return EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		AbstractTableModel.getListeners​(Class<T> listenerType)
      返回当前注册的所有对象的数组 FooListener在这个S AbstractTableModel 。
      <T extends EventListener>
      T[]             		DefaultTableColumnModel.getListeners​(Class<T> listenerType)
      返回此模型上当前注册为 FooListener的所有对象的数组。

    • Uses of EventListener in javax.swing.text

      Classes in javax.swing.text that implement EventListener
      Modifier and Type Class 描述
      class  DefaultCaret
      默认的Caret实现。
      static class  DefaultEditorKit.BeepAction
      发出哔声
      static class  DefaultEditorKit.CopyAction
      复制所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.CutAction
      剪切所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.DefaultKeyTypedAction
      如果接收到 键入类型的事件并且没有键映射条目，则默认执行的操作。
      static class  DefaultEditorKit.InsertBreakAction
      在文档中放置一个行/段落。
      static class  DefaultEditorKit.InsertContentAction
      将内容放入相关的文档。
      static class  DefaultEditorKit.InsertTabAction
      将标签字符放在文档中。
      static class  DefaultEditorKit.PasteAction
      将系统剪贴板的内容粘贴到所选区域中，或者如果没有选择任何内容，则将其插入插入符号之前。
      class  JTextComponent.AccessibleJTextComponent
      该类实现 JTextComponent类的可访问性支持。
      static class  StyledEditorKit.AlignmentAction
      设置段落对齐的动作。
      static class  StyledEditorKit.BoldAction
      用于切换粗体属性的操作。
      static class  StyledEditorKit.FontFamilyAction
      在关联的JEditorPane中设置字体系列的操作。
      static class  StyledEditorKit.FontSizeAction
      在关联的JEditorPane中设置字体大小的操作。
      static class  StyledEditorKit.ForegroundAction
      设置前景色的动作。
      static class  StyledEditorKit.ItalicAction
      切换斜体属性的动作。
      static class  StyledEditorKit.StyledTextAction
      一个假定它被安装在一个带有StyledEditorKit（或子类）的JEditorPane上被触发的动作。
      static class  StyledEditorKit.UnderlineAction
      切换下划线属性的动作。
      class  TextAction
      对于跨多个不同文本组件共享的键绑定的Action实现。
      Methods in javax.swing.text with type parameters of type EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		AbstractDocument.getListeners​(Class<T> listenerType)
      返回此文档当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultCaret.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		StyleContext.NamedStyle.getListeners​(Class<T> listenerType)
      返回添加到此模型的给定类型的所有侦听器的数组。
      Methods in javax.swing.text that return EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		AbstractDocument.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultCaret.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		StyleContext.NamedStyle.getListeners​(Class<T> listenerType)
      返回添加到此模型的给定类型的所有侦听器的数组。

    • Uses of EventListener in javax.swing.text.html

      Classes in javax.swing.text.html that implement EventListener
      Modifier and Type Class 描述
      class  FormView
      组件装饰器，用于实现表单元素<input>，<textarea>和<select>的视图界面。
      protected class  FormView.MouseEventListener
      当类型等于图像的输入点击时，MouseEventListener类可以处理表单提交。
      static class  HTMLEditorKit.HTMLTextAction
      一个抽象的Action提供了一些方便的方法，可能有助于将HTML插入到现有文档中。
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction可用于将HTML的任意字符串插入到现有的HTML文档中。
      static class  HTMLEditorKit.LinkController
      在适当的时候，类可以观看相关组件并在其上触发超链接事件。

    • Uses of EventListener in javax.swing.tree

      Classes in javax.swing.tree that implement EventListener
      Modifier and Type Class 描述
      class  DefaultTreeCellEditor
      A TreeCellEditor 。
      Methods in javax.swing.tree with type parameters of type EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		DefaultTreeModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultTreeSelectionModel.getListeners​(Class<T> listenerType)
      在此模型上返回当前注册为 FooListener的所有对象的数组。
      Methods in javax.swing.tree that return EventListener
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		DefaultTreeModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultTreeSelectionModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。

    • Uses of EventListener in javax.swing.undo

      Classes in javax.swing.undo that implement EventListener
      Modifier and Type Class 描述
      class  UndoManager
      UndoManager管理列表 UndoableEdits ，提供了一种方法来撤消或恢复适当的编辑。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Formattable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Formattable

No usage of java.util.Formattable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Iterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Iterator

  • Packages that use Iterator
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.charset.spi
    java.nio.charset包的服务提供商类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dom
    针对 javax.xml.crypto包的DOM特定类。
    javax.xml.namespace
    定义XML命名空间处理。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.stream.events
    定义Streaming API for XML（StAX）的事件接口。
    javax.xml.stream.util
    为Streaming API for XML（StAX）提供实用程序类。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。

    • Uses of Iterator in com.sun.jdi.event

      Subinterfaces of Iterator in com.sun.jdi.event
      Modifier and Type 接口 描述
      interface  EventIterator
      EventIterators是不可修改的。

    • Uses of Iterator in com.sun.source.util

      Methods in com.sun.source.util that return Iterator
      Modifier and Type | 方法 | 描述
      Iterator<DocTree> | DocTreePath.iterator​()
      Iterator<树> TreePath.iterator​()
      从叶到叶重迭。

    • Uses of Iterator in java.applet

      Methods in java.applet that return Iterator
      Modifier and Type 方法 描述
      Iterator<String> AppletContext.getStreamKeys​()
      已过时。
      在此applet上下文中查找流的所有键。

    • Uses of Iterator in java.awt.dnd

      Methods in java.awt.dnd that return Iterator
      Modifier and Type 方法 描述
      Iterator<InputEvent> DragGestureEvent.iterator​()
      为包含手势的事件返回 Iterator 。

    • Uses of Iterator in java.beans.beancontext

      Classes in java.beans.beancontext that implement Iterator
      Modifier and Type Class 描述
      protected static class  BeanContextSupport.BCSIterator
      受保护的final子类封装了一个迭代器，但实现了一个noop remove（）方法。
      Methods in java.beans.beancontext that return Iterator
      Modifier and Type | 方法 | 描述
      protected Iterator<BeanContextSupport.BCSChild> BeanContextSupport.bcsChildren​()
      返回此 BeanContext的所有子代的迭代器。
      Iterator<?> BeanContextServices.getCurrentServiceClasses​()
      获取此上下文的当前可用服务。
      Iterator<Object> | BeanContextServicesSupport.getCurrentServiceClasses​()
      Iterator<?> BeanContextServiceAvailableEvent.getCurrentServiceSelectors​()
      获取服务依赖选择器的列表。
      Iterator<?> BeanContextServiceProvider.getCurrentServiceSelectors​(BeanContextServices bcs, Class<?> serviceClass)
      该方法由 BeanContextServices调用，获取指定服务的当前服务选择器。
      Iterator<?> BeanContextServices.getCurrentServiceSelectors​(Class<?> serviceClass)
      通过调用底层BeanContextServiceProvider上的getCurrentServiceSelectors（），获取指定服务的服务相关服务参数（服务选择器）列表。
      Iterator<?> | BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors​(BeanContextServices bcs, Class<?> serviceClass)
      Iterator<?> | BeanContextServicesSupport.getCurrentServiceSelectors​(Class<?> serviceClass)
      Iterator BeanContextMembershipEvent.iterator​()
      获取受此事件影响的子项数组。
      Iterator<Object> BeanContextSupport.iterator​()
      获取当前嵌套在此 BeanContext中的所有JavaBean或 BeanContext实例。

    • Uses of Iterator in java.lang

      Methods in java.lang that return Iterator
      Modifier and Type 方法 描述
      Iterator<T> Iterable.iterator​()
      返回类型为 T元素的迭代器。

    • Uses of Iterator in java.nio.charset.spi

      Methods in java.nio.charset.spi that return Iterator
      Modifier and Type 方法 描述
      abstract Iterator<Charset> CharsetProvider.charsets​()
      创建一个迭代器来迭代此提供程序支持的字符集。

    • Uses of Iterator in java.nio.file

      Methods in java.nio.file that return Iterator
      Modifier and Type 方法 描述
      Iterator<T> DirectoryStream.iterator​()
      返回与此 DirectoryStream关联的迭代器。
      default Iterator<Path> Path.iterator​()
      返回此路径的名称元素的迭代器。

    • Uses of Iterator in java.security.cert

      Methods in java.security.cert that return Iterator
      Modifier and Type 方法 描述
      Iterator<String> CertificateFactorySpi.engineGetCertPathEncodings​()
      返回此证书工厂支持的 CertPath编码的迭代，首先使用默认编码。
      Iterator<String> CertificateFactory.getCertPathEncodings​()
      返回此证书工厂支持的 CertPath编码的迭代，首先使用默认编码。
      Iterator<? extends PolicyNode> PolicyNode.getChildren​()
      返回该节点的子节点的迭代器。
      abstract Iterator<String> CertPath.getEncodings​()
      返回此认证路径支持的编码的迭代，并使用默认编码。

    • Uses of Iterator in java.sql

      Methods in java.sql that return Iterator
      Modifier and Type 方法 描述
      Iterator<Throwable> SQLException.iterator​()
      返回链接的SQLExceptions的迭代器。

    • Uses of Iterator in java.util

      Subinterfaces of Iterator in java.util
      Modifier and Type 接口 描述
      interface  ListIterator<E>
      用于允许程序员沿任一方向遍历列表的列表的迭代器，在迭代期间修改列表，并获取列表中迭代器的当前位置。
      interface  PrimitiveIterator<T,T_CONS>
      Iterator基本专长的基本类型。
      static interface  PrimitiveIterator.OfDouble
      一个专门为 double值的迭代器。
      static interface  PrimitiveIterator.OfInt
      一个专门为 int值的迭代器。
      static interface  PrimitiveIterator.OfLong
      一个专门为 long值的迭代器。
      Classes in java.util that implement Iterator
      Modifier and Type Class 描述
      class  Scanner
      一个简单的文本扫描器，可以使用正则表达式解析原始类型和字符串。
      Methods in java.util that return Iterator
      Modifier and Type | 方法 | 描述
      default Iterator<E> Enumeration.asIterator​()
      返回一个Iterator ，它遍历此枚举覆盖的其余元素。
      Iterator<E> | ArrayDeque.descendingIterator​()
      Iterator<E> Deque.descendingIterator​()
      以相反的顺序返回此deque中的元素的迭代器。
      Iterator<E> | LinkedList.descendingIterator​()
      Iterator<E> NavigableSet.descendingIterator​()
      以降序返回该集合中的元素的迭代器。
      Iterator<E> TreeSet.descendingIterator​()
      以降序返回该集合中的元素的迭代器。
      static <T> Iterator<T> Collections.emptyIterator​()
      返回没有元素的迭代器。
      abstract Iterator<E> AbstractCollection.iterator​()
      返回包含在该集合中的元素的迭代器。
      Iterator<E> AbstractList.iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      Iterator<E> AbstractSequentialList.iterator​()
      返回此列表中的元素的迭代器（按适当的顺序）。
      Iterator<E> ArrayDeque.iterator​()
      返回此deque中的元素的迭代器。
      Iterator<E> ArrayList.iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      Iterator<E> Collection.iterator​()
      返回此集合中元素的迭代器。
      Iterator<E> Deque.iterator​()
      以正确的顺序返回此deque中的元素的迭代器。
      Iterator<E> HashSet.iterator​()
      返回此集合中元素的迭代器。
      Iterator<E> List.iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      Iterator<E> NavigableSet.iterator​()
      以升序返回此集合中的元素的迭代器。
      Iterator<E> PriorityQueue.iterator​()
      返回此队列中的元素的迭代器。
      Iterator<S> ServiceLoader.iterator​()
      返回一个迭代器来懒洋洋地加载和实例化此加载程序服务的可用提供程序。
      Iterator<E> Set.iterator​()
      返回此集合中元素的迭代器。
      static <T> Iterator<T> Spliterators.iterator​(Spliterator<? extends T> spliterator)
      创建一个 Iterator从 Spliterator 。
      Iterator<E> TreeSet.iterator​()
      以升序返回该集合中的元素的迭代器。
      Iterator<E> Vector.iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      Methods in java.util with parameters of type Iterator
      Modifier and Type 方法 描述
      static <T> Spliterator<T> Spliterators.spliterator​(Iterator<? extends T> iterator, long size, int characteristics)
      创建一个 Spliterator使用给定的 Iterator作为元素的来源，并给定最初报告的大小。
      static <T> Spliterator<T> Spliterators.spliteratorUnknownSize​(Iterator<? extends T> iterator, int characteristics)
      创建一个 Spliterator使用给定的 Iterator作为元素的来源，没有初始大小估计。

    • Uses of Iterator in java.util.concurrent

      Methods in java.util.concurrent that return Iterator
      Modifier and Type | 方法 | 描述
      Iterator<E> ConcurrentLinkedDeque.descendingIterator​()
      以相反的顺序返回此deque中的元素的迭代器。
      Iterator<E> ConcurrentSkipListSet.descendingIterator​()
      以降序返回该集合中的元素的迭代器。
      Iterator<E> LinkedBlockingDeque.descendingIterator​()
      以相反的顺序返回此deque中的元素的迭代器。
      Iterator<E> ArrayBlockingQueue.iterator​()
      以正确的顺序返回该队列中的元素的迭代器。
      Iterator<E> BlockingDeque.iterator​()
      以正确的顺序返回此deque中的元素的迭代器。
      Iterator<K> | ConcurrentHashMap.KeySetView.iterator​()
      Iterator<E> ConcurrentLinkedDeque.iterator​()
      以正确的顺序返回此deque中的元素的迭代器。
      Iterator<E> ConcurrentLinkedQueue.iterator​()
      以正确的顺序返回该队列中的元素的迭代器。
      Iterator<E> ConcurrentSkipListSet.iterator​()
      以升序返回该集合中的元素的迭代器。
      Iterator<E> CopyOnWriteArrayList.iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      Iterator<E> CopyOnWriteArraySet.iterator​()
      按照添加这些元素的顺序返回此集合中包含的元素的迭代器。
      Iterator<E> DelayQueue.iterator​()
      返回此队列中所有元素（已过期和未过期）的迭代器。
      Iterator<E> LinkedBlockingDeque.iterator​()
      以正确的顺序返回此deque中的元素的迭代器。
      Iterator<E> LinkedBlockingQueue.iterator​()
      以正确的顺序返回该队列中的元素的迭代器。
      Iterator<E> LinkedTransferQueue.iterator​()
      以正确的顺序返回该队列中的元素的迭代器。
      Iterator<E> PriorityBlockingQueue.iterator​()
      返回此队列中的元素的迭代器。
      Iterator<E> SynchronousQueue.iterator​()
      返回一个空的迭代器，其中 hasNext总是返回 false 。

    • Uses of Iterator in java.util.stream

      Methods in java.util.stream that return Iterator
      Modifier and Type 方法 描述
      Iterator<T> BaseStream.iterator​()
      返回此流的元素的迭代器。

    • Uses of Iterator in javafx.beans.binding

      Methods in javafx.beans.binding that return Iterator
      Modifier and Type | 方法 | 描述
      Iterator<E> | ListExpression.iterator​()
      Iterator<E> | SetExpression.iterator​()

    • Uses of Iterator in javafx.scene.chart

      Methods in javafx.scene.chart that return Iterator
      Modifier and Type 方法 描述
      protected Iterator<XYChart.Data<X,Y>> XYChart.getDisplayedDataIterator​(XYChart.Series<X,Y> series)
      XYChart维护当前显示的所有项目的列表，其中包括所有当前数据+最近删除的正在淡出的数据项。
      protected Iterator<XYChart.Series<X,Y>> XYChart.getDisplayedSeriesIterator​()
      XYChart维护当前显示的所有系列的列表，其中包括所有当前系列+最近被删除的系列，它们正在被褪色（动画）过程中。

    • Uses of Iterator in javax.imageio

      Methods in javax.imageio that return Iterator
      Modifier and Type 方法 描述
      static Iterator<ImageReader> ImageIO.getImageReaders​(Object input)
      返回一个 Iterator其中包含所有当前注册的 ImageReader ，声称能够解码所提供的 Object ，通常为 ImageInputStream 。
      static Iterator<ImageReader> ImageIO.getImageReadersByFormatName​(String formatName)
      返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码命名格式。
      static Iterator<ImageReader> ImageIO.getImageReadersByMIMEType​(String MIMEType)
      返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码具有给定MIME类型的文件。
      static Iterator<ImageReader> ImageIO.getImageReadersBySuffix​(String fileSuffix)
      返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够使用给定的后缀解码文件。
      static Iterator<ImageTranscoder> ImageIO.getImageTranscoders​(ImageReader reader, ImageWriter writer)
      返回一个 Iterator其中包含所有当前注册的 ImageTranscoder s，声称能够在给定的 ImageReader和 ImageWriter的元数据之间进行转码。
      abstract Iterator<ImageTypeSpecifier> ImageReader.getImageTypes​(int imageIndex)
      返回一个 Iterator其中包含给定图像可能被解码的可能的图像类型，形式为 ImageTypeSpecifiers 。
      static Iterator<ImageWriter> ImageIO.getImageWriters​(ImageTypeSpecifier type, String formatName)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter ，声称能够以给定格式对给定布局（使用 ImageTypeSpecifier指定）的图像进行编码。
      static Iterator<ImageWriter> ImageIO.getImageWritersByFormatName​(String formatName)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够对命名格式进行编码。
      static Iterator<ImageWriter> ImageIO.getImageWritersByMIMEType​(String MIMEType)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter ，声称能够对给定MIME类型的文件进行编码。
      static Iterator<ImageWriter> ImageIO.getImageWritersBySuffix​(String fileSuffix)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够使用给定的后缀对文件进行编码。
      Iterator<IIOImage> ImageReader.readAll​(Iterator<? extends ImageReadParam> params)
      返回 Iterator包含所有图像，缩略图和元数据，开始由下式给出的指数在 getMinIndex ，从形式的输入源 IIOImage对象。
      Methods in javax.imageio with parameters of type Iterator
      Modifier and Type 方法 描述
      protected static BufferedImage ImageReader.getDestination​(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
      返回应编写的解码像素数据的 BufferedImage 。
      Iterator<IIOImage> ImageReader.readAll​(Iterator<? extends ImageReadParam> params)
      返回 Iterator包含所有图像，缩略图和元数据，开始由下式给出的指数在 getMinIndex ，从形式的输入源 IIOImage对象。

    • Uses of Iterator in javax.imageio.spi

      Methods in javax.imageio.spi that return Iterator
      Modifier and Type 方法 描述
      Iterator<Class<?>> ServiceRegistry.getCategories​()
      返回一个 Iterator的 Class对象，指示当前的类别集。
      <T> Iterator<T> ServiceRegistry.getServiceProviders​(Class<T> category, boolean useOrdering)
      返回包含给定类别中的所有注册服务提供商的 Iterator 。
      <T> Iterator<T> ServiceRegistry.getServiceProviders​(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
      返回 Iterator一个给定类别中满足由所提供的定义的条件的含服务提供程序对象 ServiceRegistry.Filter对象的 filter方法。
      static <T> Iterator<T> ServiceRegistry.lookupProviders​(Class<T> providerClass)
      使用上下文类加载器定位并递增实例化给定服务的可用提供程序。
      static <T> Iterator<T> ServiceRegistry.lookupProviders​(Class<T> providerClass, ClassLoader loader)
      使用给定的类加载器搜索特定服务类的实现。
      Methods in javax.imageio.spi with parameters of type Iterator
      Modifier and Type 方法 描述
      void ServiceRegistry.registerServiceProviders​(Iterator<?> providers)
      添加一组服务提供者对象，从 Iterator到注册表。
      Constructors in javax.imageio.spi with parameters of type Iterator
      Constructor 描述
      ServiceRegistry​(Iterator<Class<?>> categories)
      构造一个 ServiceRegistry实例，并从 categories参数中获取一组类别。

    • Uses of Iterator in javax.tools

      Methods in javax.tools with parameters of type Iterator
      Modifier and Type | 方法 | 描述
      boolean | ForwardingJavaFileManager.handleOption​(String current, Iterator<String> remaining)
      boolean JavaFileManager.handleOption​(String current, Iterator<String> remaining)
      处理一个选项

    • Uses of Iterator in javax.xml.crypto

      Methods in javax.xml.crypto that return Iterator
      Modifier and Type 方法 描述
      Iterator<T> NodeSetData.iterator​()
      在 NodeSetData中的 NodeSetData中包含的节点上返回一个只读迭代器。

    • Uses of Iterator in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return Iterator
      Modifier and Type 方法 描述
      Iterator<Map.Entry<String,Element>> DOMCryptoContext.iterator​()
      在这个 DOMCryptoContext的Id / Element映射集中返回一个只读迭代器。

    • Uses of Iterator in javax.xml.namespace

      Methods in javax.xml.namespace that return Iterator
      Modifier and Type 方法 描述
      Iterator NamespaceContext.getPrefixes​(String namespaceURI)
      获取绑定到当前作用域中的命名空间URI的所有前缀。

    • Uses of Iterator in javax.xml.soap

      Methods in javax.xml.soap that return Iterator
      Modifier and Type 方法 描述
      Iterator<SOAPHeaderElement> SOAPHeader.examineAllHeaderElements​()
      返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象。
      Iterator<SOAPHeaderElement> SOAPHeader.examineHeaderElements​(String actor)
      返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象具有指定 演员 。
      Iterator<SOAPHeaderElement> SOAPHeader.examineMustUnderstandHeaderElements​(String actor)
      返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象具有指定 演员 ，有一个mustUnderstand属性，其值等于 true 。
      Iterator<SOAPHeaderElement> SOAPHeader.extractAllHeaderElements​()
      返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象，并从该中分离出来 SOAPHeader对象。
      Iterator<SOAPHeaderElement> SOAPHeader.extractHeaderElements​(String actor)
      返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象中具有指定 的actor并从此中分离出来 SOAPHeader对象。
      Iterator<Name> SOAPElement.getAllAttributes​()
      返回一个 Iterator在所有的属性 Name对象在此 SOAPElement对象。
      Iterator<QName> SOAPElement.getAllAttributesAsQNames​()
      将 Iterator中的所有属性返回 SOAPElement作为 QName对象。
      Iterator<MimeHeader> MimeHeaders.getAllHeaders​()
      返回所有 MimeHeader在这个S MimeHeaders对象。
      abstract Iterator<MimeHeader> AttachmentPart.getAllMimeHeaders​()
      检索这一切的头 AttachmentPart对象为在一个迭代 MimeHeader对象。
      abstract Iterator<MimeHeader> SOAPPart.getAllMimeHeaders​()
      检索这一切的头 SOAPPart对象为在一个迭代 MimeHeader对象。
      abstract Iterator<AttachmentPart> SOAPMessage.getAttachments​()
      检索所有 AttachmentPart对象是这部分 SOAPMessage对象。
      abstract Iterator<AttachmentPart> SOAPMessage.getAttachments​(MimeHeaders headers)
      检索具有与指定标题匹配的标题条目的所有 AttachmentPart对象。
      Iterator<Node> SOAPElement.getChildElements​()
      返回一个Iterator了所有直接子Node s此元素。
      Iterator<Node> SOAPElement.getChildElements​(QName qname)
      返回一个Iterator的所有直接子代Node的这个元素与指定的qname。
      Iterator<Node> SOAPElement.getChildElements​(Name name)
      返回一个Iterator了所有直接子Node s的指定名称的此元素。
      Iterator<DetailEntry> Detail.getDetailEntries​()
      在这个 Detail对象中的所有 DetailEntry获取迭代器。
      Iterator<Locale> SOAPFault.getFaultReasonLocales​()
      返回一个 Iterator了独特序列 Locale对此有关联Reason Text项秒。
      Iterator<String> SOAPFault.getFaultReasonTexts​()
      在 String对象的序列中返回 Iterator ，其中包含此 SOAPFault所有原因文本项。
      Iterator<QName> SOAPFault.getFaultSubcodes​()
      获取SOAPFault的子 SOAPFault作为迭代器超过 QNames 。
      Iterator<MimeHeader> MimeHeaders.getMatchingHeaders​(String[] names)
      返回名称与给定名称数组中的名称相匹配的所有 MimeHeader对象。
      abstract Iterator<MimeHeader> AttachmentPart.getMatchingMimeHeaders​(String[] names)
      检索与给定数组中的名称相匹配的所有 MimeHeader对象。
      abstract Iterator<MimeHeader> SOAPPart.getMatchingMimeHeaders​(String[] names)
      检索与给定数组中的名称相匹配的所有 MimeHeader对象。
      Iterator<String> SOAPElement.getNamespacePrefixes​()
      返回一个 Iterator在命名空间前缀 String此元素声明秒。
      Iterator<MimeHeader> MimeHeaders.getNonMatchingHeaders​(String[] names)
      返回名称与给定名称数组中的名称不匹配的所有 MimeHeader对象。
      abstract Iterator<MimeHeader> AttachmentPart.getNonMatchingMimeHeaders​(String[] names)
      检索名称与给定数组中的名称不匹配的所有 MimeHeader对象。
      abstract Iterator<MimeHeader> SOAPPart.getNonMatchingMimeHeaders​(String[] names)
      检索名称与给定数组中的名称不匹配的所有 MimeHeader对象。
      Iterator<String> SOAPElement.getVisibleNamespacePrefixes​()
      返回 Iterator对该元素可见的命名空间前缀 String 。
      Methods in javax.xml.soap with parameters of type Iterator
      Modifier and Type 方法 描述
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement​(Iterator<String> supportedSOAPURIs)
      创建一个新的升级 SOAPHeaderElement对象，并使用指定的支持SOAP URI的String Iterator进行初始化，并将其添加到此 SOAPHeader对象。

    • Uses of Iterator in javax.xml.stream

      Subinterfaces of Iterator in javax.xml.stream
      Modifier and Type 接口 描述
      interface  XMLEventReader
      这是解析XML事件的顶级界面。
      Methods in javax.xml.stream with parameters of type Iterator
      Modifier and Type 方法 描述
      abstract EndElement XMLEventFactory.createEndElement​(String prefix, String namespaceUri, String localName, Iterator<? extends Namespace> namespaces)
      创建一个新的EndElement
      abstract EndElement XMLEventFactory.createEndElement​(QName name, Iterator<? extends Namespace> namespaces)
      创建一个新的EndElement
      abstract StartElement XMLEventFactory.createStartElement​(String prefix, String namespaceUri, String localName, Iterator<? extends Attribute> attributes, Iterator<? extends Namespace> namespaces)
      创建一个新的StartElement。
      abstract StartElement XMLEventFactory.createStartElement​(String prefix, String namespaceUri, String localName, Iterator<? extends Attribute> attributes, Iterator<? extends Namespace> namespaces, NamespaceContext context)
      创建一个新的StartElement。
      abstract StartElement XMLEventFactory.createStartElement​(QName name, Iterator<? extends Attribute> attributes, Iterator<? extends Namespace> namespaces)
      创建一个新的StartElement。

    • Uses of Iterator in javax.xml.stream.events

      Methods in javax.xml.stream.events that return Iterator
      Modifier and Type 方法 描述
      Iterator<Attribute> StartElement.getAttributes​()
      返回在此START_ELEMENT上声明的非命名空间声明属性的迭代器，如果没有属性，则返回空的迭代器。
      Iterator<Namespace> EndElement.getNamespaces​()
      返回超出范围的命名空间的迭代器。
      Iterator<Namespace> StartElement.getNamespaces​()
      返回在此元素上声明的命名空间的迭代器。

    • Uses of Iterator in javax.xml.stream.util

      Classes in javax.xml.stream.util that implement Iterator
      Modifier and Type Class 描述
      class  EventReaderDelegate
      这是导出XMLEventReader过滤器的基类。

    • Uses of Iterator in javax.xml.ws

      Methods in javax.xml.ws that return Iterator
      Modifier and Type 方法 描述
      Iterator<QName> Service.getPorts​()
      返回 Iterator的 QName的服务端点列表 QName服务分组

    • Uses of Iterator in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Iterator
      Modifier and Type 方法 描述
      abstract Iterator<QName> ServiceDelegate.getPorts​()
      返回 Iterator的 QName的服务端点列表， QName服务分组

    • Uses of Iterator in javax.xml.xpath

      Methods in javax.xml.xpath that return Iterator
      Modifier and Type 方法 描述
      Iterator<Node> XPathNodes.iterator​()
      Returns an iterator of the Nodes.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.List (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.List

  • Packages that use List
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.image
    提供创建和修改图像的类。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.application
    提供应用程序生命周期类。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的工具 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.net.ssl
    为安全套接字包提供类。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.crypto.dsig.keyinfo
    用于解析和处理元素和结构的类别KeyInfo 。
    javax.xml.crypto.dsig.spec
    XML数字签名的参数类。
    javax.xml.stream.events
    定义Streaming API for XML（StAX）的事件接口。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.handler
    新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink
    包含用于链接 invokedynamic调用站点的接口和类。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。

    • Uses of List in com.sun.jdi

      Methods in com.sun.jdi that return List
      Modifier and Type 方法 描述
      List<ReferenceType> VirtualMachine.allClasses​()
      返回所有加载的类型。
      List<Connector> VirtualMachineManager.allConnectors​()
      返回所有已知的Connector对象的列表。
      List<Field> ReferenceType.allFields​()
      返回包含此类型中声明的每个Field及其超类，已实现的接口和/或超级接口的列表。
      List<InterfaceType> ClassType.allInterfaces​()
      获取由此类直接和间接实现的接口。
      List<Location> Method.allLineLocations​()
      在此方法中为每个可执行源行返回一个包含Location对象的列表。
      List<Location> Method.allLineLocations​(String stratum, String sourceName)
      在此方法中，为每个可执行源行返回一个包含Location对象的列表。
      List<Location> ReferenceType.allLineLocations​()
      在此引用类型中，为每个可执行源行返回一个包含Location对象的列表。
      List<Location> ReferenceType.allLineLocations​(String stratum, String sourceName)
      返回包含一个列表Location对该引用类型的每个可执行源极线对象。
      List<方法> ReferenceType.allMethods​()
      返回包含此类型中声明的每个方法及其超类，实现的接口和/或超级接口的列表。
      default List<ModuleReference> VirtualMachine.allModules​()
      返回所有模块。
      List<ThreadReference> VirtualMachine.allThreads​()
      返回当前正在运行的线程的列表。
      List<LocalVariable> Method.arguments​()
      返回一个列表，其中包含声明为此方法参数的每个LocalVariable 。
      List<String> Method.argumentTypeNames​()
      返回一个包含此方法的每个形式参数类型的文本表示的列表。
      List<Type> Method.argumentTypes​()
      返回一个包含此方法的每个形式参数类型的列表。
      List<AttachingConnector> VirtualMachineManager.attachingConnectors​()
      返回已知的AttachingConnector对象的列表。
      List<String> ReferenceType.availableStrata​()
      返回此参考类型的可用层。
      List<String> PathSearchingVirtualMachine.bootClassPath​()
      获取此虚拟机的引导类路径。
      List<ReferenceType> VirtualMachine.classesByName​(String className)
      返回与给定名称相匹配的加载引用类型。
      List<String> PathSearchingVirtualMachine.classPath​()
      获取此虚拟机的类路径。
      List<VirtualMachine> VirtualMachineManager.connectedVirtualMachines​()
      列出连接到调试器的所有目标虚拟机。
      List<ReferenceType> ClassLoaderReference.definedClasses​()
      返回由此类加载器定义的所有加载类的列表。
      List<Field> ReferenceType.fields​()
      返回包含此类型中声明的每个Field的列表。
      List<StackFrame> ThreadReference.frames​()
      返回包含线程当前调用堆栈中的每个StackFrame的列表。
      List<StackFrame> ThreadReference.frames​(int start, int length)
      返回一个列表，该列表包含线程当前调用堆栈的StackFrame镜像范围。
      List<Value> StackFrame.getArgumentValues​()
      返回此框架中所有参数的值。
      List<Value> ArrayReference.getValues​()
      返回此数组中的所有组件。
      List<Value> ArrayReference.getValues​(int index, int length)
      返回一系列数组组件。
      List<ClassType> InterfaceType.implementors​()
      获取直接实现此接口的当前准备的类。
      List<ObjectReference> ReferenceType.instances​(long maxInstances)
      返回此ReferenceType的实例。
      List<InterfaceType> ClassType.interfaces​()
      获取由此类直接实现的接口。
      List<LaunchingConnector> VirtualMachineManager.launchingConnectors​()
      返回已知的LaunchingConnector对象的列表。
      List<ListeningConnector> VirtualMachineManager.listeningConnectors​()
      返回已知的ListeningConnector对象的列表。
      List<Location> Method.locationsOfLine​(int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      List<Location> Method.locationsOfLine​(String stratum, String sourceName, int lineNumber)
      返回包含映射到给定行号和源名称的所有Location对象的列表。
      List<Location> ReferenceType.locationsOfLine​(int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      List<Location> ReferenceType.locationsOfLine​(String stratum, String sourceName, int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      List<方法> ReferenceType.methods​()
      返回一个包含此类型直接声明的方法的列表。
      List<方法> ReferenceType.methodsByName​(String name)
      返回包含具有给定名称的每个可见的方法的列表。
      List<方法> ReferenceType.methodsByName​(String name, String signature)
      返回包含具有给定名称和签名的每个可见的方法的列表。
      List<ReferenceType> ReferenceType.nestedTypes​()
      返回一个包含ReferenceType在此类型中声明并且当前加载到虚拟机中的对象的列表。
      List<ObjectReference> ThreadReference.ownedMonitors​()
      返回列表，该列表包含线程拥有的每个监视器的ObjectReference 。
      List<MonitorInfo> ThreadReference.ownedMonitorsAndFrames​()
      返回一个包含线程所拥有的每个监视器的一个MonitorInfo对象的列表。
      List<ObjectReference> ObjectReference.referringObjects​(long maxReferrers)
      返回直接引用此对象的对象。
      List<String> ReferenceType.sourceNames​(String stratum)
      获取与此类型的声明对应的所有源的识别名称。
      List<String> ReferenceType.sourcePaths​(String stratum)
      获取与此类型的声明对应的源的路径。
      List<ClassType> ClassType.subclasses​()
      获取此类的当前加载的直接子类。
      List<InterfaceType> InterfaceType.subinterfaces​()
      获取当前准备的接口，直接扩展该接口。
      List<InterfaceType> InterfaceType.superinterfaces​()
      获取此接口直接扩展的接口。
      List<ThreadGroupReference> ThreadGroupReference.threadGroups​()
      返回一个包含此线程组中每个活动ThreadGroupReference的列表。
      List<ThreadReference> ThreadGroupReference.threads​()
      返回一个列表，该列表包含此线程组中每个活动线程的ThreadReference 。
      List<ThreadGroupReference> VirtualMachine.topLevelThreadGroups​()
      返回没有父级的每个线程组。
      List<LocalVariable> Method.variables​()
      返回包含此方法中声明的每个LocalVariable的列表。
      List<LocalVariable> Method.variablesByName​(String name)
      在此方法中返回包含给定名称的每个LocalVariable的列表。
      List<ReferenceType> ClassLoaderReference.visibleClasses​()
      返回此类加载器已被记录为目标VM中的启动加载程序的所有类的列表。
      List<Field> ReferenceType.visibleFields​()
      返回一个包含这种类型的每个不隐藏和明确的Field的列表。
      List<方法> ReferenceType.visibleMethods​()
      返回包含此类型声明或继承的每个方法的列表。
      List<LocalVariable> StackFrame.visibleVariables​()
      返回一个列表，其中包含可以从此框架的位置访问的每个LocalVariable 。
      List<ThreadReference> ObjectReference.waitingThreads​()
      返回一个列表，其中包含当前等待该对象监视器的每个线程的ThreadReference 。
      Methods in com.sun.jdi with parameters of type List
      Modifier and Type 方法 描述
      Map<Field,Value> ObjectReference.getValues​(List<? extends Field> fields)
      获取此对象中多个实例和/或静态字段的值。
      Map<Field,Value> ReferenceType.getValues​(List<? extends Field> fields)
      返回包含给定列表中每个静态Field的Value的地图。
      Map<LocalVariable,Value> StackFrame.getValues​(List<? extends LocalVariable> variables)
      返回此框架中多个局部变量的值。
      long[] VirtualMachine.instanceCounts​(List<? extends ReferenceType> refTypes)
      返回“refTypes”列表中每个ReferenceType的实例数。
      Value ClassType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      调用目标VM中指定的静态方法 。
      default Value InterfaceType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      调用目标VM中指定的静态方法 。
      Value ObjectReference.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标VM中调用此对象上指定的方法 。
      ObjectReference ClassType.newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      使用目标VM中的给定构造函数方法构造此类型的新实例。
      void ArrayReference.setValues​(int index, List<? extends Value> values, int srcIndex, int length)
      用其他值替换一系列阵列组件。
      void ArrayReference.setValues​(List<? extends Value> values)
      用其他值替换所有数组组件。

    • Uses of List in com.sun.jdi.connect

      Methods in com.sun.jdi.connect that return List
      Modifier and Type 方法 描述
      List<String> IllegalConnectorArgumentsException.argumentNames​()
      返回一个包含无效或不一致参数的名称的 List 。
      List<String> Connector.SelectedArgument.choices​()
      返回参数的可能值
      Constructors in com.sun.jdi.connect with parameters of type List
      Constructor 描述
      IllegalConnectorArgumentsException​(String s, List<String> names)
      构建 IllegalConnectorArgumentsException带指定详细消息和 List的参数，其是无效的或不一致的名字。

    • Uses of List in com.sun.jdi.request

      Methods in com.sun.jdi.request that return List
      Modifier and Type 方法 描述
      List<AccessWatchpointRequest> EventRequestManager.accessWatchpointRequests​()
      返回启用和禁用的访问观察点请求的不可修改的列表。
      List<BreakpointRequest> EventRequestManager.breakpointRequests​()
      返回启用和禁用的断点请求的不可修改的列表。
      List<ClassPrepareRequest> EventRequestManager.classPrepareRequests​()
      返回启用和禁用的类准备请求的不可修改的列表。
      List<ClassUnloadRequest> EventRequestManager.classUnloadRequests​()
      返回启用和禁用的类卸载请求的不可修改的列表。
      List<ExceptionRequest> EventRequestManager.exceptionRequests​()
      返回启用和禁用的异常请求的不可修改的列表。
      List<MethodEntryRequest> EventRequestManager.methodEntryRequests​()
      返回启用和禁用的方法条目请求的不可修改列表。
      List<MethodExitRequest> EventRequestManager.methodExitRequests​()
      返回启用和禁用的方法退出请求的不可修改的列表。
      List<ModificationWatchpointRequest> EventRequestManager.modificationWatchpointRequests​()
      返回启用和禁用的修改观察点请求的不可修改的列表。
      List<MonitorContendedEnteredRequest> EventRequestManager.monitorContendedEnteredRequests​()
      返回已启用和禁用的已监视输入请求的不可修改的列表。
      List<MonitorContendedEnterRequest> EventRequestManager.monitorContendedEnterRequests​()
      返回启用和禁用的监视器竞争的输入请求的不可修改的列表。
      List<MonitorWaitedRequest> EventRequestManager.monitorWaitedRequests​()
      返回启用和禁用的监视器等待请求的不可修改的列表。
      List<MonitorWaitRequest> EventRequestManager.monitorWaitRequests​()
      返回启用和禁用的监视器等待请求的不可修改的列表。
      List<StepRequest> EventRequestManager.stepRequests​()
      返回启用和禁用的步骤请求的不可修改的列表。
      List<ThreadDeathRequest> EventRequestManager.threadDeathRequests​()
      返回启用和禁用的线程死亡请求的不可修改的列表。
      List<ThreadStartRequest> EventRequestManager.threadStartRequests​()
      返回启用和禁用的线程启动请求的不可修改的列表。
      List<VMDeathRequest> EventRequestManager.vmDeathRequests​()
      返回启用和禁用的VM死亡请求的不可修改的列表。
      Methods in com.sun.jdi.request with parameters of type List
      Modifier and Type 方法 描述
      void EventRequestManager.deleteEventRequests​(List<? extends EventRequest> eventRequests)
      删除EventRequest的列表。

    • Uses of List in com.sun.management

      Methods in com.sun.management that return List
      Modifier and Type 方法 描述
      List<VMOption> HotSpotDiagnosticMXBean.getDiagnosticOptions​()
      返回所有诊断选项的 VMOption对象的列表。

    • Uses of List in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return List
      Modifier and Type | 方法 | 描述
      List<String> | Headers.get​(Object key)
      abstract List<Filter> HttpContext.getFilters​()
      返回此上下文的过滤器列表。
      List<String> | Headers.put​(String key, List<String> value)
      List<String> | Headers.remove​(Object key)
      Methods in com.sun.net.httpserver that return types with arguments of type List
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<String,List<String>>> | Headers.entrySet​()
      Collection<List<String>> | Headers.values​()
      Methods in com.sun.net.httpserver with parameters of type List
      Modifier and Type | 方法 | 描述
      List<String> | Headers.put​(String key, List<String> value)
      Method parameters in com.sun.net.httpserver with type arguments of type List
      Modifier and Type | 方法 | 描述
      void | Headers.putAll​(Map<? extends String,? extends List<String>> t)
      Constructors in com.sun.net.httpserver with parameters of type List
      Constructor 描述
      Chain​(List<Filter> filters, HttpHandler handler)

    • Uses of List in com.sun.source.doctree

      Methods in com.sun.source.doctree that return List
      Modifier and Type 方法 描述
      List<? extends DocTree> StartElementTree.getAttributes​()
      返回此元素定义的任何属性。
      List<? extends DocTree> DocCommentTree.getBlockTags​()
      返回文档注释的块标签。
      List<? extends DocTree> DeprecatedTree.getBody​()
      返回解释为什么不推荐使用某项的描述。
      List<? extends DocTree> DocCommentTree.getBody​()
      返回文档注释的正文，出现在第一个句子之后，并返回任何块标记之前。
      List<? extends DocTree> HiddenTree.getBody​()
      返回说明为什么隐藏项目的描述。
      List<? extends DocTree> SinceTree.getBody​()
      返回说明正在记录的项目的可用性的文本。
      List<? extends DocTree> VersionTree.getBody​()
      返回标签的正文。
      List<? extends DocTree> UnknownBlockTagTree.getContent​()
      返回无法识别的块标签的内容。
      List<? extends DocTree> UnknownInlineTagTree.getContent​()
      返回无法识别的内联代码的内容。
      List<? extends DocTree> IndexTree.getDescription​()
      返回描述，如果有的话。
      List<? extends DocTree> ParamTree.getDescription​()
      返回参数的描述。
      List<? extends DocTree> ProvidesTree.getDescription​()
      返回由模块提供的服务类型的描述。
      List<? extends DocTree> ReturnTree.getDescription​()
      返回方法返回值的描述。
      List<? extends DocTree> SerialDataTree.getDescription​()
      返回串行数据的描述。
      List<? extends DocTree> SerialFieldTree.getDescription​()
      返回串行字段的描述。
      List<? extends DocTree> SerialTree.getDescription​()
      返回字段的描述，或返回“包含”或“排除”一词。
      List<? extends DocTree> ThrowsTree.getDescription​()
      返回说明可能抛出异常的原因。
      List<? extends DocTree> UsesTree.getDescription​()
      返回在模块中使用服务类型的描述。
      List<? extends DocTree> DocCommentTree.getFirstSentence​()
      返回文档注释的第一个句子。
      default List<? extends DocTree> DocCommentTree.getFullBody​()
      返回文档注释的整个正文，出现在任何块标记之前，包括第一个句子。
      List<? extends DocTree> LinkTree.getLabel​()
      返回链接的标签（如果有）。
      List<? extends DocTree> AuthorTree.getName​()
      返回作者的名称。
      List<? extends DocTree> SeeTree.getReference​()
      返回引用。
      List<? extends DocTree> AttributeTree.getValue​()
      返回属性的值，如果该类型为EMPTY，则返回 null 。

    • Uses of List in com.sun.source.tree

      Methods in com.sun.source.tree that return List
      Modifier and Type 方法 描述
      List<? extends AnnotationTree> AnnotatedTypeTree.getAnnotations​()
      返回与此类型表达式关联的注释。
      List<? extends AnnotationTree> ModifiersTree.getAnnotations​()
      返回此修饰符树中的注释。
      List<? extends AnnotationTree> ModuleTree.getAnnotations​()
      返回与此模块声明关联的注释。
      List<? extends AnnotationTree> NewArrayTree.getAnnotations​()
      返回基本类型的注释。
      List<? extends AnnotationTree> PackageTree.getAnnotations​()
      返回与此包声明关联的注释。
      List<? extends AnnotationTree> TypeParameterTree.getAnnotations​()
      返回类型参数声明的注释。
      List<? extends ExpressionTree> AnnotationTree.getArguments​()
      返回注释的参数（如果有）。
      List<? extends ExpressionTree> MethodInvocationTree.getArguments​()
      返回方法调用的参数。
      List<? extends ExpressionTree> NewClassTree.getArguments​()
      返回要调用的构造函数的参数。
      List<? extends 树> IntersectionTypeTree.getBounds​()
      返回类型的边界。
      List<? extends 树> TypeParameterTree.getBounds​()
      返回type参数的边界。
      List<? extends CaseTree> SwitchTree.getCases​()
      返回 switch语句的情况。
      List<? extends CatchTree> TryTree.getCatches​()
      返回 try语句中提供的任何catch块。
      List<? extends List<? extends AnnotationTree>> NewArrayTree.getDimAnnotations​()
      返回每个维度表达式上的注释。
      List<? extends ExpressionTree> NewArrayTree.getDimensions​()
      返回类型的维度表达式。
      List<? extends DirectiveTree> ModuleTree.getDirectives​()
      返回模块声明中的指令。
      List<? extends 树> ErroneousTree.getErrorTrees​()
      返回保存在此节点中的任何树。
      List<? extends ExpressionTree> ProvidesTree.getImplementationNames​()
      返回正在提供的实现类型的名称。
      List<? extends 树> ClassTree.getImplementsClause​()
      返回由此类型声明实现的接口。
      List<? extends ImportTree> CompilationUnitTree.getImports​()
      返回此编译单元中出现的导入声明。
      List<? extends StatementTree> ForLoopTree.getInitializer​()
      返回 for语句的任何初始值。
      List<? extends ExpressionTree> NewArrayTree.getInitializers​()
      返回初始化器表达式。
      List<? extends 树> ClassTree.getMembers​()
      返回在此类型声明中声明的成员。
      List<? extends ExpressionTree> ExportsTree.getModuleNames​()
      返回包导出到的模块的名称，如果软件包导出到所有模块，则返回null。
      List<? extends ExpressionTree> OpensTree.getModuleNames​()
      返回包打开的模块的名称，如果打包到所有模块，则返回null。
      List<? extends AnnotationTree> CompilationUnitTree.getPackageAnnotations​()
      返回在编译单元头部的任何包装声明中列出的注释，如果没有包装声明，则 null 。
      List<? extends VariableTree> LambdaExpressionTree.getParameters​()
      返回此lambda表达式的参数。
      List<? extends VariableTree> MethodTree.getParameters​()
      返回正在声明的方法的参数。
      List<? extends 树> TryTree.getResources​()
      返回 try语句中提供的任何资源声明。
      List<? extends StatementTree> BlockTree.getStatements​()
      返回包含此块的语句。
      List<? extends StatementTree> CaseTree.getStatements​()
      返回由案例标注的语句。
      List<? extends ExpressionTree> MethodTree.getThrows​()
      返回此方法抛出的异常。
      List<? extends 树> UnionTypeTree.getTypeAlternatives​()
      返回替代类型表达式。
      List<? extends ExpressionTree> MemberReferenceTree.getTypeArguments​()
      返回引用的类型参数。
      List<? extends 树> MethodInvocationTree.getTypeArguments​()
      返回此方法调用的类型参数。
      List<? extends 树> NewClassTree.getTypeArguments​()
      返回正在创建的对象的类型参数。
      List<? extends 树> ParameterizedTypeTree.getTypeArguments​()
      返回类型参数。
      List<? extends 树> CompilationUnitTree.getTypeDecls​()
      返回此编译单元中出现的类型声明。
      List<? extends TypeParameterTree> ClassTree.getTypeParameters​()
      返回此类型声明的任何类型参数。
      List<? extends TypeParameterTree> MethodTree.getTypeParameters​()
      返回正在声明的方法的类型参数。
      List<? extends ExpressionStatementTree> ForLoopTree.getUpdate​()
      返回 for语句的更新表达式。
      Methods in com.sun.source.tree that return types with arguments of type List
      Modifier and Type 方法 描述
      List<? extends List<? extends AnnotationTree>> NewArrayTree.getDimAnnotations​()
      返回每个维度表达式上的注释。

    • Uses of List in com.sun.source.util

      Methods in com.sun.source.util that return List
      Modifier and Type 方法 描述
      List<DocTree> DocTreeFactory.getFirstSentence​(List<? extends DocTree> list)
      获取内容列表中的第一个句子。
      abstract List<DocTree> DocTrees.getFirstSentence​(List<? extends DocTree> list)
      返回表示评论第一句的DocTree的列表。
      Methods in com.sun.source.util with parameters of type List
      Modifier and Type 方法 描述
      List<DocTree> DocTreeFactory.getFirstSentence​(List<? extends DocTree> list)
      获取内容列表中的第一个句子。
      abstract List<DocTree> DocTrees.getFirstSentence​(List<? extends DocTree> list)
      返回表示评论的第一句的DocTree的列表。
      AttributeTree DocTreeFactory.newAttributeTree​(Name name, AttributeTree.ValueKind vkind, List<? extends DocTree> value)
      创建一个新的 AttributeTree对象，以表示HTML标签中的HTML属性。
      AuthorTree DocTreeFactory.newAuthorTree​(List<? extends DocTree> name)
      创建一个新的 AuthorTree对象，以表示一个 {@author }标签。
      DeprecatedTree DocTreeFactory.newDeprecatedTree​(List<? extends DocTree> text)
      创建一个新的 DeprecatedTree对象，以表示一个 {@deprecated }标签。
      DocCommentTree DocTreeFactory.newDocCommentTree​(List<? extends DocTree> fullBody, List<? extends DocTree> tags)
      创建一个新的 DocCommentTree对象，以表示完整的文档注释。
      ThrowsTree DocTreeFactory.newExceptionTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ExceptionTree对象，以表示一个 @exception标签。
      HiddenTree DocTreeFactory.newHiddenTree​(List<? extends DocTree> text)
      创建一个新的 HiddenTree对象，以表示一个 {@hidden }标签。
      IndexTree DocTreeFactory.newIndexTree​(DocTree term, List<? extends DocTree> description)
      创建一个新的 IndexTree对象，以表示一个 {@index }标签。
      LinkTree DocTreeFactory.newLinkPlainTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkPlainTree对象，代表一个 {@linkplain }标签。
      LinkTree DocTreeFactory.newLinkTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkTree对象，以表示一个 {@link }标签。
      ParamTree DocTreeFactory.newParamTree​(boolean isTypeParameter, IdentifierTree name, List<? extends DocTree> description)
      创建一个新的 ParamTree对象，以表示一个 @param标签。
      ProvidesTree DocTreeFactory.newProvidesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ProvidesTree对象，以表示一个 @provides标签。
      ReturnTree DocTreeFactory.newReturnTree​(List<? extends DocTree> description)
      创建一个新的 ReturnTree对象，代表一个 @return标签。
      SeeTree DocTreeFactory.newSeeTree​(List<? extends DocTree> reference)
      创建一个新的 SeeTree对象，以表示一个 @see标签。
      SerialDataTree DocTreeFactory.newSerialDataTree​(List<? extends DocTree> description)
      创建一个新的 SerialDataTree对象，以表示一个 @serialData标签。
      SerialFieldTree DocTreeFactory.newSerialFieldTree​(IdentifierTree name, ReferenceTree type, List<? extends DocTree> description)
      创建一个新的 SerialFieldTree对象，以表示一个 @serialField标签。
      SerialTree DocTreeFactory.newSerialTree​(List<? extends DocTree> description)
      创建一个新的 SerialTree对象，以表示一个 @serial标签。
      SinceTree DocTreeFactory.newSinceTree​(List<? extends DocTree> text)
      创建一个新的 SinceTree对象，以表示一个 @since标签。
      StartElementTree DocTreeFactory.newStartElementTree​(Name name, List<? extends DocTree> attrs, boolean selfClosing)
      创建一个新的 StartElementTree对象，以表示HTML元素的开始。
      ThrowsTree DocTreeFactory.newThrowsTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ThrowsTree对象，以表示一个 @throws标签。
      UnknownBlockTagTree DocTreeFactory.newUnknownBlockTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownBlockTagTree对象，以表示一个无法识别的块标记。
      UnknownInlineTagTree DocTreeFactory.newUnknownInlineTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownInlineTagTree对象，以表示无法识别的内联标签。
      UsesTree DocTreeFactory.newUsesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 UsesTree对象，以表示一个 @uses标签。
      VersionTree DocTreeFactory.newVersionTree​(List<? extends DocTree> text)
      创建一个新的 VersionTree对象，以表示一个 {@version }标签。

    • Uses of List in com.sun.tools.attach

      Methods in com.sun.tools.attach that return List
      Modifier and Type 方法 描述
      static List<VirtualMachineDescriptor> VirtualMachine.list​()
      返回Java虚拟机的列表。

    • Uses of List in com.sun.tools.attach.spi

      Methods in com.sun.tools.attach.spi that return List
      Modifier and Type 方法 描述
      abstract List<VirtualMachineDescriptor> AttachProvider.listVirtualMachines​()
      列出此提供程序已知的Java虚拟机。
      static List<AttachProvider> AttachProvider.providers​()
      返回已安装附件提供商的列表。

    • Uses of List in java.awt

      Methods in java.awt that return List
      Modifier and Type 方法 描述
      List<Image> Window.getIconImages​()
      返回要显示为此窗口的图标的图像序列。
      protected List<KeyEventDispatcher> KeyboardFocusManager.getKeyEventDispatchers​()
      将此KeyboardFocusManager的KeyEventDispatcher链作为列表返回。
      protected List<KeyEventPostProcessor> KeyboardFocusManager.getKeyEventPostProcessors​()
      将此KeyboardFocusManager的KeyEventPostProcessor链返回为列表。
      Methods in java.awt with parameters of type List
      Modifier and Type 方法 描述
      void Window.setIconImages​(List<? extends Image> icons)
      设置要显示为该窗口的图标的图像序列。

    • Uses of List in java.awt.datatransfer

      Methods in java.awt.datatransfer that return List
      Modifier and Type 方法 描述
      List<DataFlavor> FlavorTable.getFlavorsForNative​(String nat)
      返回 List的 DataFlavor s到其指定的 String对应。
      List<DataFlavor> SystemFlavorMap.getFlavorsForNative​(String nat)
      返回 List的 DataFlavor s，指定的 String本机可以由数据传输子系统翻译。
      List<String> FlavorTable.getNativesForFlavor​(DataFlavor flav)
      返回 List的 String指定的 DataFlavor对应的 DataFlavor 。
      List<String> SystemFlavorMap.getNativesForFlavor​(DataFlavor flav)
      返回 List的 String原住民，数据传输子系统可以转换指定的 DataFlavor 。

    • Uses of List in java.awt.desktop

      Methods in java.awt.desktop that return List
      Modifier and Type 方法 描述
      List<File> FilesEvent.getFiles​()
      获取文件列表
      Constructors in java.awt.desktop with parameters of type List
      Constructor 描述
      OpenFilesEvent​(List<File> files, String searchTerm)
      构造一个 OpenFilesEvent
      PrintFilesEvent​(List<File> files)
      构造一个 PrintFilesEvent

    • Uses of List in java.awt.dnd

      Methods in java.awt.dnd that return List
      Modifier and Type 方法 描述
      protected List<DataFlavor> DropTargetContext.getCurrentDataFlavorsAsList​()
      该方法返回当前可用的 Transferable操作数DataFlavors作为 java.util.List 。
      List<DataFlavor> DropTargetDragEvent.getCurrentDataFlavorsAsList​()
      此方法返回当前的 DataFlavor s作为 java.util.List
      List<DataFlavor> DropTargetDropEvent.getCurrentDataFlavorsAsList​()
      此方法返回当前可用的 DataFlavor作为 java.util.List 。
      Constructors in java.awt.dnd with parameters of type List
      Constructor 描述
      DragGestureEvent​(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
      构造一个 DragGestureEvent由给定对象 DragGestureRecognizer实例激发此事件中， act表示用户的首选操作参数，一个 ori参数指示拖动原点，和一个 List组成动作（事件 evs参数）。

    • Uses of List in java.awt.image

      Methods in java.awt.image that return List
      Modifier and Type | 方法 | 描述
      List<Image> | BaseMultiResolutionImage.getResolutionVariants​()
      List<Image> MultiResolutionImage.getResolutionVariants​()
      获取所有分辨率变体的可读列表。

    • Uses of List in java.lang

      Methods in java.lang that return List
      Modifier and Type 方法 描述
      List<String> ProcessBuilder.command​()
      返回此流程构建器的操作系统程序和参数。
      List<ModuleLayer> ModuleLayer.parents​()
      返回此图层的父母的列表，除非是 empty layer ，它没有父母，因此返回空列表。
      static List<Process> ProcessBuilder.startPipeline​(List<ProcessBuilder> builders)
      为每个ProcessBuilder启动流程，创建一个由其标准输出流和标准输入流链接的流程。
      List<Integer> Runtime.Version.version​()
      返回version number中包含的整数的不可修改的List 。
      Methods in java.lang with parameters of type List
      Modifier and Type 方法 描述
      ProcessBuilder ProcessBuilder.command​(List<String> command)
      设置此流程构建器的操作系统程序和参数。
      static ModuleLayer.Controller ModuleLayer.defineModules​(Configuration cf, List<ModuleLayer> parentLayers, Function<String,ClassLoader> clf)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithManyLoaders​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithOneLoader​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      static List<Process> ProcessBuilder.startPipeline​(List<ProcessBuilder> builders)
      为每个ProcessBuilder启动流程，创建一个由其标准输出流和标准输入流链接的流程。
      Constructors in java.lang with parameters of type List
      Constructor 描述
      ProcessBuilder​(List<String> command)
      构造具有指定操作系统程序和参数的进程构建器。

    • Uses of List in java.lang.invoke

      Methods in java.lang.invoke that return List
      Modifier and Type 方法 描述
      List<Class<?>> VarHandle.coordinateTypes​()
      返回此VarHandle的坐标类型。
      List<Class<?>> MethodType.parameterList​()
      将参数类型显示为列表（方便方法）。
      Methods in java.lang.invoke with parameters of type List
      Modifier and Type 方法 描述
      MethodType MethodType.appendParameterTypes​(List<Class<?>> ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      static MethodHandle MethodHandles.dropArguments​(MethodHandle target, int pos, List<Class<?>> valueTypes)
      产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
      static MethodHandle MethodHandles.dropArgumentsToMatch​(MethodHandle target, int skip, List<Class<?>> newTypes, int pos)
      适应目标方法句柄以匹配给定的参数类型列表。
      MethodType MethodType.insertParameterTypes​(int num, List<Class<?>> ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      Object MethodHandle.invokeWithArguments​(List<?> arguments)
      执行变量arity调用，将给定数组中的参数传递给方法句柄，好像通过来自调用站点的不正确的 invoke ，其中仅提及类型为 Object ，并且其arity为参数数组的长度。
      static MethodType MethodType.methodType​(Class<?> rtype, List<Class<?>> ptypes)
      查找或创建具有给定组件的方法类型。

    • Uses of List in java.lang.management

      Methods in java.lang.management that return List
      Modifier and Type 方法 描述
      static List<GarbageCollectorMXBean> ManagementFactory.getGarbageCollectorMXBeans​()
      返回Java虚拟机中的GarbageCollectorMXBean对象的列表。
      List<String> RuntimeMXBean.getInputArguments​()
      返回传递给Java虚拟机的输入参数，该虚拟机不包括 main方法的参数。
      List<String> PlatformLoggingMXBean.getLoggerNames​()
      返回当前注册的logger名称的列表。
      static List<MemoryManagerMXBean> ManagementFactory.getMemoryManagerMXBeans​()
      返回Java虚拟机中的MemoryManagerMXBean个对象的列表。
      static List<MemoryPoolMXBean> ManagementFactory.getMemoryPoolMXBeans​()
      返回Java虚拟机中的MemoryPoolMXBean对象的列表。
      static <T extends PlatformManagedObject>
      List<T>             		ManagementFactory.getPlatformMXBeans​(Class<T> mxbeanInterface)
      返回在Java虚拟机中实现给定的 mxbeanInterface的平台 mxbeanInterface的列表。
      static <T extends PlatformManagedObject>
      List<T>             		ManagementFactory.getPlatformMXBeans​(MBeanServerConnection connection, Class<T> mxbeanInterface)
      返回平台MXBean代理的列表，用于通过给定的 MBeanServerConnection转发 mxbeanInterface的方法调用。

    • Uses of List in java.lang.module

      Methods in java.lang.module that return List
      Modifier and Type 方法 描述
      List<Configuration> Configuration.parents​()
      按照搜索顺序返回此配置的父母的不可修改列表。
      List<String> ModuleDescriptor.Provides.providers​()
      返回提供商或提供者工厂的完全限定类名的列表。
      Methods in java.lang.module with parameters of type List
      Modifier and Type 方法 描述
      ModuleDescriptor.Builder ModuleDescriptor.Builder.provides​(String service, List<String> providers)
      提供服务的实现。
      static Configuration Configuration.resolve​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解析根模块的集合以创建配置。
      static Configuration Configuration.resolveAndBind​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定功能，以创建配置。

    • Uses of List in java.net

      Methods in java.net that return List
      Modifier and Type 方法 描述
      List<HttpCookie> CookieStore.get​(URI uri)
      检索与给定URI相关联的Cookie，或者其域与给定的URI匹配。
      List<HttpCookie> CookieStore.getCookies​()
      在Cookie商店中获取所有未过期的Cookie。
      List<InterfaceAddress> NetworkInterface.getInterfaceAddresses​()
      获取此网络接口的 InterfaceAddresses的全部或部分的列表。
      abstract List<Certificate> SecureCacheResponse.getLocalCertificateChain​()
      返回在握手检索网络资源的原始连接期间发送到服务器的证书链。
      abstract List<Certificate> SecureCacheResponse.getServerCertificateChain​()
      返回服务器的证书链，它是作为在检索网络资源的原始连接中从缓存定义会话的一部分而建立的。
      List<URI> CookieStore.getURIs​()
      获取标识Cookie存储区中的Cookie的所有URI。
      static List<HttpCookie> HttpCookie.parse​(String header)
      从set-cookie或set-cookie2头字符串构造cookie。
      abstract List<Proxy> ProxySelector.select​(URI uri)
      根据访问资源的协议选择所有适用的代理以及访问资源的目标地址。
      Methods in java.net that return types with arguments of type List
      Modifier and Type | 方法 | 描述
      abstract Map<String,List<String>> CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)
      从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。
      Map<String,List<String>> | CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)
      Map<String,List<String>> URLConnection.getHeaderFields​()
      返回不可修改的标题字段的映射。
      abstract Map<String,List<String>> CacheResponse.getHeaders​()
      将响应标头作为Map返回。
      Map<String,List<String>> URLConnection.getRequestProperties​()
      返回此连接的一般请求属性的不可修改映射。
      Method parameters in java.net with type arguments of type List
      Modifier and Type | 方法 | 描述
      abstract Map<String,List<String>> CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)
      从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。
      Map<String,List<String>> | CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)
      abstract CacheResponse ResponseCache.get​(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
      根据请求的uri，请求方法和请求标头检索缓存的响应。
      abstract void CookieHandler.put​(URI uri, Map<String,List<String>> responseHeaders)
      设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。
      void | CookieManager.put​(URI uri, Map<String,List<String>> responseHeaders)

    • Uses of List in java.nio.file

      Methods in java.nio.file that return List
      Modifier and Type 方法 描述
      List<WatchEvent<?>> WatchKey.pollEvents​()
      检索并删除此监视键的所有待处理事件，并返回 List到的事件的 List 。
      static List<String> Files.readAllLines​(Path path)
      从文件中读取所有行。
      static List<String> Files.readAllLines​(Path path, Charset cs)
      从文件中读取所有行。

    • Uses of List in java.nio.file.attribute

      Methods in java.nio.file.attribute that return List
      Modifier and Type 方法 描述
      List<AclEntry> AclFileAttributeView.getAcl​()
      读取访问控制列表。
      List<String> UserDefinedFileAttributeView.list​()
      返回包含用户定义属性名称的列表。
      Methods in java.nio.file.attribute with parameters of type List
      Modifier and Type 方法 描述
      void AclFileAttributeView.setAcl​(List<AclEntry> acl)
      更新（替换）访问控制列表。

    • Uses of List in java.nio.file.spi

      Methods in java.nio.file.spi that return List
      Modifier and Type 方法 描述
      static List<FileSystemProvider> FileSystemProvider.installedProviders​()
      返回已安装文件系统提供程序的列表。

    • Uses of List in java.security

      Constructors in java.security with parameters of type List
      Constructor 描述
      Service​(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
      构建新服务

    • Uses of List in java.security.cert

      Methods in java.security.cert that return List
      Modifier and Type 方法 描述
      abstract List<? extends Certificate> CertPath.getCertificates​()
      返回此认证路径中的证书列表。
      List<PKIXCertPathChecker> PKIXParameters.getCertPathCheckers​()
      返回认证路径检查程序的 List 。
      List<CertStore> PKIXParameters.getCertStores​()
      返回用于查找证书和CRL的不可变 List （ CertStore 。
      List<String> X509Certificate.getExtendedKeyUsage​()
      获取表示扩展密钥使用扩展的 ExtKeyUsageSyntax字段的对象标识符（OID = 2.5.29.37）的字符串的不可修改列表。
      List<Extension> PKIXRevocationChecker.getOcspExtensions​()
      获取可选的OCSP请求扩展。
      abstract List<CertPathValidatorException> PKIXRevocationChecker.getSoftFailExceptions​()
      返回一个列表，其中包含当设置了 SOFT_FAIL选项时撤销检查器忽略的异常。
      Methods in java.security.cert that return types with arguments of type List
      Modifier and Type 方法 描述
      Collection<List<?>> X509Certificate.getIssuerAlternativeNames​()
      从 IssuerAltName扩展名（OID = 2.5.29.18）获取不可变的发行人替代名称集合。
      Collection<List<?>> X509CertSelector.getPathToNames​()
      返回pathToNames条件的副本。
      Collection<List<?>> X509Certificate.getSubjectAlternativeNames​()
      从 SubjectAltName扩展名（OID = 2.5.29.17）获取不可变的主题备用名称集合。
      Collection<List<?>> X509CertSelector.getSubjectAlternativeNames​()
      返回subjectAlternativeNames条件的副本。
      Methods in java.security.cert with parameters of type List
      Modifier and Type 方法 描述
      CertPath CertificateFactorySpi.engineGenerateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并用 List （ Certificate初始化它。
      CertPath CertificateFactory.generateCertPath​(List<? extends Certificate> certificates)
      生成一个 CertPath对象，并使用 List （ Certificate初始化。
      void PKIXParameters.setCertPathCheckers​(List<PKIXCertPathChecker> checkers)
      设置一个额外的认证路径检查器 List 。
      void PKIXParameters.setCertStores​(List<CertStore> stores)
      设置用于查找证书和CRL的 CertStore s的列表。
      void PKIXRevocationChecker.setOcspExtensions​(List<Extension> extensions)
      设置可选的OCSP请求扩展。
      Method parameters in java.security.cert with type arguments of type List
      Modifier and Type 方法 描述
      void X509CertSelector.setPathToNames​(Collection<List<?>> names)
      设置pathToNames条件。
      void X509CertSelector.setSubjectAlternativeNames​(Collection<List<?>> names)
      设置subjectAlternativeNames标准。

    • Uses of List in java.time

      Methods in java.time that return List
      Modifier and Type 方法 描述
      List<TemporalUnit> Duration.getUnits​()
      获取此持续时间支持的单位集。
      List<TemporalUnit> Period.getUnits​()
      获取此期间支持的单位集。

    • Uses of List in java.time.chrono

      Methods in java.time.chrono that return List
      Modifier and Type | 方法 | 描述
      List<Era> Chronology.eras​()
      获取年表的时间列表。
      List<Era> | HijrahChronology.eras​()
      List<Era> | IsoChronology.eras​()
      List<Era> | JapaneseChronology.eras​()
      List<Era> | MinguoChronology.eras​()
      List<Era> | ThaiBuddhistChronology.eras​()
      List<TemporalUnit> ChronoPeriod.getUnits​()
      获取此期间支持的单位集。

    • Uses of List in java.time.temporal

      Methods in java.time.temporal that return List
      Modifier and Type 方法 描述
      List<TemporalUnit> TemporalAmount.getUnits​()
      返回唯一定义此TemporalAmount值的单位列表。

    • Uses of List in java.time.zone

      Methods in java.time.zone that return List
      Modifier and Type 方法 描述
      List<ZoneOffsetTransitionRule> ZoneRules.getTransitionRules​()
      获得过渡规则列表，超出转换列表中定义的年限。
      List<ZoneOffsetTransition> ZoneRules.getTransitions​()
      获取完全定义的转换的完整列表。
      List<ZoneOffset> ZoneRules.getValidOffsets​(LocalDateTime localDateTime)
      在这些规则中获取在指定的本地日期时间中适用的偏移量。
      Methods in java.time.zone with parameters of type List
      Modifier and Type 方法 描述
      static ZoneRules ZoneRules.of​(ZoneOffset baseStandardOffset, ZoneOffset baseWallOffset, List<ZoneOffsetTransition> standardOffsetTransitionList, List<ZoneOffsetTransition> transitionList, List<ZoneOffsetTransitionRule> lastRules)
      获取ZoneRules的实例。

    • Uses of List in java.util

      Classes in java.util that implement List
      Modifier and Type Class 描述
      class  AbstractList<E>
      该类提供了List接口的骨架实现，以最小化实现由“随机存取”数据存储（如数组）支持的该接口所需的工作量。
      class  AbstractSequentialList<E>
      此类提供了 List接口的骨架实现，以最大限度地减少由“顺序访问”数据存储（如链接列表）支持的此接口所需的工作量。
      class  ArrayList<E>
      List接口的可调整大小的数组实现。
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
      class  Stack<E>
      Stack类代表一个最先进先出（LIFO）堆栈的对象。
      class  Vector<E>
      Vector类实现了可扩展的对象数组。
      Fields in java.util declared as List
      Modifier and Type Field 描述
      static List Collections.EMPTY_LIST
      空列表（不可变）。
      static List<String> ResourceBundle.Control.FORMAT_CLASS
      类别 List包含 "java.class" 。
      static List<String> ResourceBundle.Control.FORMAT_DEFAULT
      默认格式 List ，其中包含字符串 "java.class"和 "java.properties" ，按此顺序。
      static List<String> ResourceBundle.Control.FORMAT_PROPERTIES
      属性格式 List包含 "java.properties" 。
      Methods in java.util that return List
      Modifier and Type 方法 描述
      static <T> List<T> Arrays.asList​(T... a)
      返回由指定数组支持的固定大小的列表。
      static <E> List<E> Collections.checkedList​(List<E> list, Class<E> type)
      返回指定列表的动态类型安全视图。
      static <T> List<T> Collections.emptyList​()
      返回空列表（immutable）。
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales, Locale.FilteringMode mode)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
      static List<String> Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      static List<String> Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags, Locale.FilteringMode mode)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      List<Locale> ResourceBundle.Control.getCandidateLocales​(String baseName, Locale locale)
      将 List的 Locale作为 baseName和 locale候选语言环境。
      List<String> ResourceBundle.Control.getFormats​(String baseName)
      返回 List的 String包含用于加载给定的 baseName资源束的 baseName 。
      static List<Locale.LanguageRange> Locale.LanguageRange.mapEquivalents​(List<Locale.LanguageRange> priorityList, Map<String,List<String>> map)
      使用给定的 priorityList和 map生成新的自定义语言优先级列表。
      static <T> List<T> Collections.nCopies​(int n, T o)
      返回由指定对象的 n副本组成的不可变列表。
      static <E> List<E> List.of​()
      返回包含零个元素的不可变列表。
      static <E> List<E> List.of​(E e1)
      返回一个包含一个元素的不可变列表。
      static <E> List<E> List.of​(E... elements)
      返回包含任意数量元素的不可变列表。
      static <E> List<E> List.of​(E e1, E e2)
      返回一个包含两个元素的不可变列表。
      static <E> List<E> List.of​(E e1, E e2, E e3)
      返回一个包含三个元素的不可变列表。
      static <E> List<E> List.of​(E e1, E e2, E e3, E e4)
      返回一个包含四个元素的不可变列表。
      static <E> List<E> List.of​(E e1, E e2, E e3, E e4, E e5)
      返回包含五个元素的不可变列表。
      static <E> List<E> List.of​(E e1, E e2, E e3, E e4, E e5, E e6)
      返回包含六个元素的不可变列表。
      static <E> List<E> List.of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7)
      返回包含七个元素的不可变列表。
      static <E> List<E> List.of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8)
      返回包含八个元素的不可变列表。
      static <E> List<E> List.of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8, E e9)
      返回包含九个元素的不可变列表。
      static <E> List<E> List.of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8, E e9, E e10)
      返回一个包含十个元素的不可变列表。
      static List<Locale.LanguageRange> Locale.LanguageRange.parse​(String ranges)
      解析给定的 ranges以生成语言优先级列表。
      static List<Locale.LanguageRange> Locale.LanguageRange.parse​(String ranges, Map<String,List<String>> map)
      解析给定的 ranges以生成语言优先级列表，然后使用给定的 map自定义列表。
      static <T> List<T> Collections.singletonList​(T o)
      返回一个只包含指定对象的不可变列表。
      List<E> AbstractList.subList​(int fromIndex, int toIndex)
      返回指定的 fromIndex （含）和 toIndex之间的列表部分的视图。
      List<E> ArrayList.subList​(int fromIndex, int toIndex)
      返回指定的 fromIndex （含）和 toIndex之间的列表部分的视图。
      List<E> List.subList​(int fromIndex, int toIndex)
      返回指定的 fromIndex （含）和 toIndex之间的列表部分的视图。
      List<E> Vector.subList​(int fromIndex, int toIndex)
      返回此列表之间的fromIndex（包括）和toIndex之间的独占视图。
      static <T> List<T> Collections.synchronizedList​(List<T> list)
      返回由指定列表支持的同步（线程安全）列表。
      static <T> List<T> Collections.unmodifiableList​(List<? extends T> list)
      返回指定列表的不可修改视图。
      Methods in java.util with parameters of type List
      Modifier and Type 方法 描述
      static <T> int Collections.binarySearch​(List<? extends Comparable<? super T>> list, T key)
      使用二叉搜索算法搜索指定对象的指定列表。
      static <T> int Collections.binarySearch​(List<? extends T> list, T key, Comparator<? super T> c)
      使用二叉搜索算法搜索指定对象的指定列表。
      static <E> List<E> Collections.checkedList​(List<E> list, Class<E> type)
      返回指定列表的动态类型安全视图。
      static <T> void Collections.copy​(List<? super T> dest, List<? extends T> src)
      将所有元素从一个列表复制到另一个列表中。
      static <T> void Collections.fill​(List<? super T> list, T obj)
      用指定的元素替换指定列表的所有元素。
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
      static List<Locale> Locale.filter​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales, Locale.FilteringMode mode)
      使用RFC 4647中定义的过滤机制返回匹配的 Locale实例列表。
      static List<String> Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      static List<String> Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags, Locale.FilteringMode mode)
      使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
      static ResourceBundle.Control ResourceBundle.Control.getControl​(List<String> formats)
      返回一个 ResourceBundle.Control ，其中 getFormats方法返回指定的 formats 。
      static ResourceBundle.Control ResourceBundle.Control.getNoFallbackControl​(List<String> formats)
      返回一个 ResourceBundle.Control ，其中 getFormats方法返回指定的 formats ，而 getFallbackLocale方法返回 null 。
      static int Collections.indexOfSubList​(List<?> source, List<?> target)
      返回指定源列表中指定目标列表的第一次出现的起始位置，如果没有此类事件，则返回-1。
      static int Collections.lastIndexOfSubList​(List<?> source, List<?> target)
      返回指定源列表中指定目标列表的最后一次出现的起始位置，如果没有此类事件则返回-1。
      static Locale Locale.lookup​(List<Locale.LanguageRange> priorityList, Collection<Locale> locales)
      使用RFC 4647中定义的查找机制返回 Locale最佳匹配语言标记的实例。
      static String Locale.lookupTag​(List<Locale.LanguageRange> priorityList, Collection<String> tags)
      使用RFC 4647中定义的查找机制返回最匹配的语言标签。
      static List<Locale.LanguageRange> Locale.LanguageRange.mapEquivalents​(List<Locale.LanguageRange> priorityList, Map<String,List<String>> map)
      使用给定的 priorityList和 map生成新的自定义语言优先级列表。
      static <T> boolean Collections.replaceAll​(List<T> list, T oldVal, T newVal)
      将列表中一个指定值的所有出现替换为另一个。
      static void Collections.reverse​(List<?> list)
      反转指定列表中元素的顺序。
      static void Collections.rotate​(List<?> list, int distance)
      将指定列表中的元素旋转指定的距离。
      static void Collections.shuffle​(List<?> list)
      使用默认的随机源随机排列指定的列表。
      static void Collections.shuffle​(List<?> list, Random rnd)
      使用指定的随机源随机排列指定的列表。
      static <T extends Comparable<? super T>>
      void             		Collections.sort​(List<T> list)
      根据其元素的natural ordering按照升序排列指定的列表。
      static <T> void Collections.sort​(List<T> list, Comparator<? super T> c)
      根据指定的比较器引起的顺序对指定的列表进行排序。
      static void Collections.swap​(List<?> list, int i, int j)
      交换指定列表中指定位置的元素。
      static <T> List<T> Collections.synchronizedList​(List<T> list)
      返回由指定列表支持的同步（线程安全）列表。
      static <T> List<T> Collections.unmodifiableList​(List<? extends T> list)
      返回指定列表的不可修改视图。
      Method parameters in java.util with type arguments of type List
      Modifier and Type 方法 描述
      static List<Locale.LanguageRange> Locale.LanguageRange.mapEquivalents​(List<Locale.LanguageRange> priorityList, Map<String,List<String>> map)
      使用给定的 priorityList和 map生成新的自定义语言优先级列表。
      static List<Locale.LanguageRange> Locale.LanguageRange.parse​(String ranges, Map<String,List<String>> map)
      解析给定的 ranges以生成语言优先级列表，然后使用给定的 map自定义列表。

    • Uses of List in java.util.concurrent

      Classes in java.util.concurrent that implement List
      Modifier and Type Class 描述
      class  CopyOnWriteArrayList<E>
      的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。
      Methods in java.util.concurrent that return List
      Modifier and Type | 方法 | 描述
      List<Flow.Subscriber<? super T>> SubmissionPublisher.getSubscribers​()
      返回用于监视和跟踪目的的当前用户列表，而不是在订阅者上调用Flow.Subscriber方法。
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。
      <T> List<Future<T>> | ForkJoinPool.invokeAll​(Collection<? extends Callable<T>> tasks)
      List<Runnable> ExecutorService.shutdownNow​()
      尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。
      List<Runnable> ForkJoinPool.shutdownNow​()
      可能尝试取消和/或停止所有任务，并拒绝所有后续提交的任务。
      List<Runnable> ScheduledThreadPoolExecutor.shutdownNow​()
      尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。
      List<Runnable> ThreadPoolExecutor.shutdownNow​()
      尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。
      List<E> CopyOnWriteArrayList.subList​(int fromIndex, int toIndex)
      返回 fromIndex （包括）和 toIndex之间的列表部分的视图。

    • Uses of List in java.util.logging

      Methods in java.util.logging that return List
      Modifier and Type 方法 描述
      List<String> LoggingMXBean.getLoggerNames​()
      已过时。
      返回当前注册的记录器名称的列表。

    • Uses of List in java.util.stream

      Methods in java.util.stream that return types with arguments of type List
      Modifier and Type 方法 描述
      static <T,K> Collector<T,?,Map<K,List<T>>> Collectors.groupingBy​(Function<? super T,? extends K> classifier)
      返回 Collector对类型为 T输入元素进行“按组”操作，根据分类功能对元素进行分组，并将结果返回到 Map 。
      static <T,K> Collector<T,?,ConcurrentMap<K,List<T>>> Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier)
      返回一个并发 Collector “由基团”上的类型的输入元件操作实现 T ，根据分类功能分组元素。
      static <T> Collector<T,?,Map<Boolean,List<T>>> Collectors.partitioningBy​(Predicate<? super T> predicate)
      返回 Collector由划分根据所述输入元件 Predicate ，并且将它们组织到一个 Map<Boolean, List<T>> 。
      static <T> Collector<T,?,List<T>> Collectors.toList​()
      返回一个 Collector ，将输入元素累加到一个新的 List 。

    • Uses of List in javafx.application

      Methods in javafx.application that return List
      Modifier and Type 方法 描述
      abstract List<String> Application.Parameters.getRaw​()
      检索原始参数的只读列表。
      abstract List<String> Application.Parameters.getUnnamed​()
      检索未命名参数的只读列表。

    • Uses of List in javafx.beans.binding

      Classes in javafx.beans.binding that implement List
      Modifier and Type Class 描述
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      class  ListExpression<E>
      ListExpression是一个ObservableListValue，另外还有一个方便的方法来生成流畅的绑定。
      Methods in javafx.beans.binding that return List
      Modifier and Type | 方法 | 描述
      List<E> | ListExpression.subList​(int from, int to)
      Methods in javafx.beans.binding with parameters of type List
      Modifier and Type 方法 描述
      static <E> void Bindings.bindContent​(List<E> list1, ObservableList<? extends E> list2)
      生成ObservableList和List之间的内容绑定。

    • Uses of List in javafx.beans.property

      Classes in javafx.beans.property that implement List
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个包含ObservableList的Property的完整实现。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  ReadOnlyListProperty<E>
      超类为所有只读属性包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。

    • Uses of List in javafx.beans.value

      Subinterfaces of List in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableListValue<E>
      一个可观察的参考ObservableList 。
      interface  WritableListValue<E>
      一个可写的参考ObservableList 。

    • Uses of List in javafx.collections

      Subinterfaces of List in javafx.collections
      Modifier and Type 接口 描述
      interface  ObservableList<E>
      允许侦听器发生变化的列表。
      Classes in javafx.collections that implement List
      Modifier and Type Class 描述
      class  ModifiableObservableListBase<E>
      抽象类，可作为可修改的ObservableList实现的基类。
      class  ObservableListBase<E>
      抽象类作为ObservableList实现的基类。
      Methods in javafx.collections that return List
      Modifier and Type | 方法 | 描述
      List<E> ListChangeListener.Change.getAddedSubList​()
      要获取仅包含元素的列表的子列表视图，请使用getAddedSubList（）方法。
      abstract List<E> ListChangeListener.Change.getRemoved​()
      已删除/替换元素的不可变列表。
      List<E> | ModifiableObservableListBase.subList​(int fromIndex, int toIndex)
      Methods in javafx.collections with parameters of type List
      Modifier and Type 方法 描述
      static <T> void FXCollections.copy​(ObservableList<? super T> dest, List<? extends T> src)
      将元素从src复制到dest。
      protected void ObservableListBase.nextRemove​(int idx, List<? extends E> removed)
      在更改中添加一个新的删除操作，删除多个项目。
      protected void ObservableListBase.nextReplace​(int from, int to, List<? extends E> removed)
      为更改添加新的替换操作。
      static <E> ObservableList<E> FXCollections.observableList​(List<E> list)
      构造由指定列表支持的ObservableList。
      static <E> ObservableList<E> FXCollections.observableList​(List<E> list, Callback<E,Observable[]> extractor)
      构造由指定列表支持的ObservableList。

    • Uses of List in javafx.collections.transformation

      Classes in javafx.collections.transformation that implement List
      Modifier and Type Class 描述
      class  FilteredList<E>
      包装一个ObservableList并使用提供的谓词过滤其内容。
      class  SortedList<E>
      包装一个ObservableList并对其内容进行排序。
      class  TransformationList<E,F>
      所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。

    • Uses of List in javafx.css

      Fields in javafx.css declared as List
      Modifier and Type | Field | 描述
      List<String> | StyleConverter.StringStore.strings
      Methods in javafx.css that return List
      Modifier and Type | 方法 | 描述
      List<CssMetaData<? extends Styleable,?>> Styleable.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> StyleablePropertyFactory.getCssMetaData​()
      获取给定Styleable的CssMetaData。
      List<FontFace> | Stylesheet.getFontFaces​()
      List<Rule> | Stylesheet.getRules​()
      List<SimpleSelector> CompoundSelector.getSelectors​()
      组合此复合选择器的选择器
      List<String> | SimpleSelector.getStyleClasses​()
      List<CssMetaData<? extends Styleable,?>> CssMetaData.getSubProperties​()
      子属性是指该属性的组成属性（如果有）。
      Constructors in javafx.css with parameters of type List
      Constructor 描述
      CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue, boolean inherits, List<CssMetaData<? extends Styleable,?>> subProperties)
      用给定的参数构造一个CssMetaData，没有子属性。
      StyleablePropertyFactory​(List<CssMetaData<? extends Styleable,?>> parentCssMetaData)
      构造函数通过父类的父类CssMetaData传递，通常通过调用父类的静态方法 getClassCssMetaData() 。

    • Uses of List in javafx.scene

      Methods in javafx.scene that return List
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Node.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Node.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      protected <E extends Node>
      List<E>             		Parent.getManagedChildren​()
      获取此 Parent的所有受管孩子的 Parent 。

    • Uses of List in javafx.scene.chart

      Methods in javafx.scene.chart that return List
      Modifier and Type | 方法 | 描述
      protected List<Number> NumberAxis.calculateMinorTickMarks​()
      计算每个小刻度线的数据值列表
      protected abstract List<T> ValueAxis.calculateMinorTickMarks​()
      计算每个小刻度线的数据值列表
      protected abstract List<T> Axis.calculateTickValues​(double length, Object range)
      计算范围内每个刻度线的所有数据值的列表
      protected List<String> CategoryAxis.calculateTickValues​(double length, Object range)
      计算范围内每个刻度线的所有数据值的列表
      protected List<Number> NumberAxis.calculateTickValues​(double length, Object range)
      计算范围内每个刻度线的所有数据值的列表
      static List<CssMetaData<? extends Styleable,?>> | AreaChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Axis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | BarChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | CategoryAxis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Chart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | LineChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | NumberAxis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | PieChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | StackedAreaChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | StackedBarChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ValueAxis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | XYChart.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> AreaChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Axis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> BarChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> CategoryAxis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Chart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> LineChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> NumberAxis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> PieChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> StackedAreaChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> StackedBarChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ValueAxis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> XYChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      Methods in javafx.scene.chart with parameters of type List
      Modifier and Type 方法 描述
      void Axis.invalidateRange​(List<T> data)
      数据更改时调用，范围可能不再有效。
      void CategoryAxis.invalidateRange​(List<String> data)
      数据更改时调用，范围可能不再有效。
      void ValueAxis.invalidateRange​(List<T> data)
      当数据发生变化并且范围可能不再有效时调用。

    • Uses of List in javafx.scene.control

      Methods in javafx.scene.control that return List
      Modifier and Type | 方法 | 描述
      List<? extends TreeItem<T>> TreeItem.TreeModificationEvent.getAddedChildren​()
      返回在此事件中添加到TreeItem的子项，如果未添加子项，则返回空列表。
      static List<CssMetaData<? extends Styleable,?>> | Control.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | DatePicker.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | DialogPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Labeled.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ListView.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | MenuBar.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Pagination.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | PopupControl.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ScrollBar.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ScrollPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Separator.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> SkinBase.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> | Slider.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | SplitPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Tab.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TableColumn.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TableView.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TabPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextArea.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextField.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextInputControl.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TitledPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ToolBar.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Tooltip.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TreeTableColumn.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TreeTableView.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TreeView.getClassCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | Control.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | DatePicker.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | Labeled.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ListView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | MenuBar.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | Pagination.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ScrollBar.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ScrollPane.getControlCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | Separator.getControlCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | Slider.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | SplitPane.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TableView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TabPane.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TextArea.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TextField.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TextInputControl.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TitledPane.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ToolBar.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TreeTableView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TreeView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Control.getCssMetaData​()
      此方法返回一个List，其中包含所有CssMetaData（用于此控件）（从Control.getControlCssMetaData()返回）及其Skin ，假设skin property为SkinBase 。
      List<CssMetaData<? extends Styleable,?>> DialogPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> | MenuItem.getCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | PopupControl.CSSBridge.getCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> PopupControl.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> SkinBase.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Tab.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> TableColumn.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> Tooltip.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> TreeTableColumn.getCssMetaData​()
      这个样式的CssMetaData。
      List<? extends TreeItem<T>> TreeItem.TreeModificationEvent.getRemovedChildren​()
      返回在此事件中从TreeItem中删除的子项，如果未添加子项，则返回空列表。
      protected List<S> TableView.TableViewSelectionModel.getTableModel​()
      getTableView（）。getItems（）的方便方法。
      Constructors in javafx.scene.control with parameters of type List
      Constructor 描述
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, List<? extends TreeItem<T>> added, List<? extends TreeItem<T>> removed)
      构造一个TreeModificationEvent，当TreeItem的子项列表更改时。

    • Uses of List in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return List
      Modifier and Type 方法 描述
      static List<CssMetaData<? extends Styleable,?>> CellSkinBase.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ColorPickerSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> MenuBarSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> PaginationSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ProgressBarSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ProgressIndicatorSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TableColumnHeader.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TabPaneSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TextInputControlSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ToolBarSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TreeCellSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TreeTableRowSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> CellSkinBase.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ColorPickerSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> MenuBarSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> PaginationSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ProgressBarSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ProgressIndicatorSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TableColumnHeader.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TabPaneSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TextInputControlSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ToolBarSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TreeCellSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TreeTableRowSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      Methods in javafx.scene.control.skin with parameters of type List
      Modifier and Type 方法 描述
      protected void TextAreaSkin.addHighlight​(List<? extends Node> nodes, int start)
      从输入法添加组合文本的高亮。
      protected void TextFieldSkin.addHighlight​(List<? extends Node> nodes, int start)
      从输入法添加组合文本的高亮。
      protected abstract void TextInputControlSkin.addHighlight​(List<? extends Node> nodes, int start)
      从输入法添加组合文本的高亮。
      protected void TextAreaSkin.removeHighlight​(List<? extends Node> nodes)
      从Input Method中删除组合文本的高亮。
      protected void TextFieldSkin.removeHighlight​(List<? extends Node> nodes)
      从Input Method中删除组合文本的高亮。
      protected abstract void TextInputControlSkin.removeHighlight​(List<? extends Node> nodes)
      从Input Method中删除组合文本的高亮。

    • Uses of List in javafx.scene.image

      Methods in javafx.scene.image that return List
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | ImageView.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> ImageView.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of List in javafx.scene.input

      Methods in javafx.scene.input that return List
      Modifier and Type 方法 描述
      List<File> Clipboard.getFiles​()
      从先前已注册的剪贴板获取文件列表。
      List<File> ClipboardContent.getFiles​()
      从之前 ClipboardContent获取文件列表。
      List<TouchPoint> TouchEvent.getTouchPoints​()
      获取由这组触摸事件表示的所有触摸点，包括此事件的触摸点。
      Methods in javafx.scene.input with parameters of type List
      Modifier and Type 方法 描述
      boolean ClipboardContent.putFiles​(List<File> files)
      将文件列表放入 ClipboardContent 。
      boolean ClipboardContent.putFilesByPath​(List<String> filePaths)
      根据文件路径将文件列表放入 ClipboardContent 。
      Constructors in javafx.scene.input with parameters of type List
      Constructor 描述
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造具有空源和目标的新的InputMethodEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。

    • Uses of List in javafx.scene.layout

      Methods in javafx.scene.layout that return List
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Background.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Border.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | FlowPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | GridPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | HBox.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Region.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | StackPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TilePane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | VBox.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> FlowPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> GridPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> HBox.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Region.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> StackPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TilePane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> VBox.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<Double> BorderStrokeStyle.getDashArray​()
      定义表示短划线段长度的数组。
      List<BackgroundFill> Background.getFills​()
      BackgroundFill的列表，它们一起定义了该背景的填充部分。
      List<BackgroundImage> Background.getImages​()
      BackgroundImages的列表，它们一起定义了此Background的图像部分。
      List<BorderImage> Border.getImages​()
      BorderImages的列表，它们一起定义要使用的图像，而不是此边框的笔画。
      List<BorderStroke> Border.getStrokes​()
      BorderStrokes列表，它们一起定义了此边框的划线部分。
      Constructors in javafx.scene.layout with parameters of type List
      Constructor 描述
      Background​(List<BackgroundFill> fills, List<BackgroundImage> images)
      创建一个新的背景提供两个列表，一个用于背景填充，一个用于背景图像。
      Border​(List<BorderStroke> strokes, List<BorderImage> images)
      通过提供BorderStrokes和BorderImages列表创建一个新的边框。
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。

    • Uses of List in javafx.scene.paint

      Methods in javafx.scene.paint that return List
      Modifier and Type 方法 描述
      List<Stop> LinearGradient.getStops​()
      指定如何沿着渐变分布颜色的2个或更多个 Stop值的序列。
      List<Stop> RadialGradient.getStops​()
      指定如何沿着渐变分布颜色的2个或更多个 Stop值的序列。
      Constructors in javafx.scene.paint with parameters of type List
      Constructor 描述
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。

    • Uses of List in javafx.scene.shape

      Methods in javafx.scene.shape that return List
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Rectangle.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Shape.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Rectangle.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Shape.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of List in javafx.scene.text

      Methods in javafx.scene.text that return List
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Text.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextFlow.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Text.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> | TextFlow.getCssMetaData​()
      static List<String> Font.getFamilies​()
      获取用户系统上安装的所有字体，包括任何应用程序字体或SDK字体。
      static List<String> Font.getFontNames​()
      获取用户系统上安装的所有字体的名称，包括任何应用程序字体和SDK字体。
      static List<String> Font.getFontNames​(String family)
      获取用户系统上安装的指定字体系列中所有字体的名称，包括任何应用程序字体和SDK字体。

    • Uses of List in javafx.scene.web

      Methods in javafx.scene.web that return List
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | WebView.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> WebView.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of List in javafx.stage

      Methods in javafx.stage that return List
      Modifier and Type 方法 描述
      List<String> FileChooser.ExtensionFilter.getExtensions​()
      获取此 ExtensionFilter的文件扩展名。
      List<File> FileChooser.showOpenMultipleDialog​(Window ownerWindow)
      显示一个新的文件打开对话框，其中可以选择多个文件。
      Constructors in javafx.stage with parameters of type List
      Constructor 描述
      ExtensionFilter​(String description, List<String> extensions)
      创建一个具有指定描述和文件扩展名的 ExtensionFilter 。

    • Uses of List in javax.imageio

      Fields in javax.imageio declared as List
      Modifier and Type Field 描述
      protected List<IIOReadProgressListener> ImageReader.progressListeners
      A List目前注册的 IIOReadProgressListener s，默认初始化为 null ，这是一个空的 List同义词。
      protected List<IIOWriteProgressListener> ImageWriter.progressListeners
      A List目前注册的 IIOWriteProgressListener s，默认初始化为 null ，这是一个空的 List同义词。
      protected List<? extends BufferedImage> IIOImage.thumbnails
      A List的 BufferedImage缩略图，或 null 。
      protected List<IIOReadUpdateListener> ImageReader.updateListeners
      A List当前注册的 IIOReadUpdateListener s，默认初始化为 null ，这是空的 List同义词。
      protected List<IIOReadWarningListener> ImageReader.warningListeners
      A List当前注册的 IIOReadWarningListener s，默认初始化为 null ，这是一个空的 List同义词。
      protected List<IIOWriteWarningListener> ImageWriter.warningListeners
      A List当前注册的 IIOWriteWarningListener s，默认初始化为 null ，这是一个空的 List同义词。
      protected List<Locale> ImageReader.warningLocales
      一个 List的 Locale与每个当前注册的 IIOReadWarningListener相关联，默认初始化为 null ，这是一个空的 List同义词。
      protected List<Locale> ImageWriter.warningLocales
      甲 List的 Locale S，一个用于的每个元素 warningListeners ，默认情况下初始化 null ，它与空同义 List 。
      Methods in javax.imageio that return List
      Modifier and Type 方法 描述
      List<? extends BufferedImage> IIOImage.getThumbnails​()
      如果没有设置，则返回当前的 List缩略图 BufferedImage s，或 null 。
      Methods in javax.imageio with parameters of type List
      Modifier and Type 方法 描述
      void ImageWriter.prepareInsertEmpty​(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将未定义像素值的新图像插入到现有图像流中。
      void ImageWriter.prepareWriteEmpty​(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将一个完整的图像流写入到包含未定义像素值的单个图像和关联的元数据和缩略图中。
      void IIOImage.setThumbnails​(List<? extends BufferedImage> thumbnails)
      将缩略图列表设置为新的 List （ BufferedImage ，或 null 。
      Constructors in javax.imageio with parameters of type List
      Constructor 描述
      IIOImage​(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 Raster ，和缩略图和元数据与之相关联。
      IIOImage​(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 RenderedImage ，和缩略图和元数据与之相关联。

    • Uses of List in javax.imageio.metadata

      Methods in javax.imageio.metadata with parameters of type List
      Modifier and Type 方法 描述
      protected void IIOMetadataFormatImpl.addAttribute​(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)
      向先前定义的元素添加一个新属性，该元素将由一组枚举值定义。
      protected <T> void IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
      允许给定类类型的 Object引用存储在实现命名元素的节点中。

    • Uses of List in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return List
      Modifier and Type 方法 描述
      List<TIFFTagSet> TIFFImageReadParam.getAllowedTagSets​()
      返回 List包含允许 TIFFTagSet对象。
      Constructors in javax.imageio.plugins.tiff with parameters of type List
      Constructor 描述
      TIFFTagSet​(List<TIFFTag> tags)
      构造一个 TIFFTagSet ，给出一个 List的 TIFFTag对象。

    • Uses of List in javax.lang.model

      Methods in javax.lang.model that return List
      Modifier and Type 方法 描述
      List<? extends AnnotationMirror> AnnotatedConstruct.getAnnotationMirrors​()
      返回 直接存在于此构造上的注释。

    • Uses of List in javax.lang.model.element

      Methods in javax.lang.model.element that return List
      Modifier and Type 方法 描述
      List<? extends AnnotationMirror> Element.getAnnotationMirrors​()
      返回 直接存在于此构造上的注释。
      List<? extends TypeMirror> TypeParameterElement.getBounds​()
      返回此类型参数的边界。
      List<? extends ModuleElement.Directive> ModuleElement.getDirectives​()
      返回此模块声明中包含的伪指令。
      List<? extends Element> Element.getEnclosedElements​()
      返回由这个元素直接包围的松散元素。
      List<? extends Element> ModuleElement.getEnclosedElements​()
      返回此模块中的包。
      List<? extends Element> PackageElement.getEnclosedElements​()
      返回此包中的 top-level类和接口。
      List<? extends Element> TypeElement.getEnclosedElements​()
      返回在此类或接口中直接声明的字段，方法，构造函数和成员类型。
      List<? extends TypeElement> ModuleElement.ProvidesDirective.getImplementations​()
      返回正在提供的服务的实现。
      List<? extends TypeMirror> TypeElement.getInterfaces​()
      返回由此类直接实现的接口类或由此接口扩展的接口类型。
      List<? extends VariableElement> ExecutableElement.getParameters​()
      返回此可执行文件的形式参数。
      List<? extends ModuleElement> ModuleElement.ExportsDirective.getTargetModules​()
      返回要导出软件包的特定模块，如果软件包导出到具有对该模块的可读性的所有模块，则返回null。
      List<? extends ModuleElement> ModuleElement.OpensDirective.getTargetModules​()
      如果程序包打开了对该模块具有可读性的所有模块，则返回打包程序包的特定模块或空值。
      List<? extends TypeMirror> ExecutableElement.getThrownTypes​()
      以声明顺序返回此方法或构造函数 throws子句中列出的异常和其他可抛出物。
      List<? extends TypeParameterElement> ExecutableElement.getTypeParameters​()
      以声明顺序返回此可执行文件的正式类型参数。
      List<? extends TypeParameterElement> Parameterizable.getTypeParameters​()
      以声明顺序返回元素的形式类型参数。
      List<? extends TypeParameterElement> TypeElement.getTypeParameters​()
      以声明顺序返回此类型元素的形式类型参数。
      Methods in javax.lang.model.element with parameters of type List
      Modifier and Type 方法 描述
      R AnnotationValueVisitor.visitArray​(List<? extends AnnotationValue> vals, P p)
      访问注释中的数组值。

    • Uses of List in javax.lang.model.type

      Methods in javax.lang.model.type that return List
      Modifier and Type 方法 描述
      List<? extends TypeMirror> UnionType.getAlternatives​()
      返回包含此联合类型的替代方案。
      List<? extends TypeMirror> IntersectionType.getBounds​()
      返回包含此交集类型的边界。
      List<? extends TypeMirror> ExecutableType.getParameterTypes​()
      返回此可执行文件的形式参数的类型。
      List<? extends TypeMirror> ExecutableType.getThrownTypes​()
      返回此可执行文件 throws子句中列出的异常和其他可抛出物。
      List<? extends TypeMirror> DeclaredType.getTypeArguments​()
      返回此类型的实际类型参数。
      List<? extends TypeMirror> MirroredTypesException.getTypeMirrors​()
      返回与正在访问的类型相对应的类型镜像。
      List<? extends TypeVariable> ExecutableType.getTypeVariables​()
      返回由此可执行文件的形式类型参数声明的类型变量。
      Constructors in javax.lang.model.type with parameters of type List
      Constructor 描述
      MirroredTypesException​(List<? extends TypeMirror> types)
      为指定的类型构造一个新的MirroredTypesException。

    • Uses of List in javax.lang.model.util

      Methods in javax.lang.model.util that return List
      Modifier and Type 方法 描述
      static List<ExecutableElement> ElementFilter.constructorsIn​(Iterable<? extends Element> elements)
      返回 elements中的构造函数列表。
      List<? extends TypeMirror> Types.directSupertypes​(TypeMirror t)
      返回类型的直接超类型。
      static List<ModuleElement.ExportsDirective> ElementFilter.exportsIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 exports指令的列表。
      static List<VariableElement> ElementFilter.fieldsIn​(Iterable<? extends Element> elements)
      返回 elements中的字段列表。
      List<? extends AnnotationMirror> Elements.getAllAnnotationMirrors​(Element e)
      返回元素上 存在的所有注释，无论是直接存在还是通过继承存在。
      List<? extends Element> Elements.getAllMembers​(TypeElement type)
      返回类型元素的所有成员，无论是继承还是直接声明。
      static List<ExecutableElement> ElementFilter.methodsIn​(Iterable<? extends Element> elements)
      返回 elements中的方法列表。
      static List<ModuleElement> ElementFilter.modulesIn​(Iterable<? extends Element> elements)
      返回 elements中的模块列表。
      static List<ModuleElement.OpensDirective> ElementFilter.opensIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 opens指令的列表。
      static List<PackageElement> ElementFilter.packagesIn​(Iterable<? extends Element> elements)
      返回 elements中的软件包列表。
      static List<ModuleElement.ProvidesDirective> ElementFilter.providesIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 provides指令的列表。
      static List<ModuleElement.RequiresDirective> ElementFilter.requiresIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 requires指令的列表。
      static List<TypeElement> ElementFilter.typesIn​(Iterable<? extends Element> elements)
      返回 elements中的类型列表。
      static List<ModuleElement.UsesDirective> ElementFilter.usesIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 uses指令的列表。
      Methods in javax.lang.model.util with parameters of type List
      Modifier and Type 方法 描述
      R SimpleAnnotationValueVisitor6.visitArray​(List<? extends AnnotationValue> vals, P p)
      访问注释中的数组值。

    • Uses of List in javax.management

      Classes in javax.management that implement List
      Modifier and Type Class 描述
      class  AttributeList
      表示MBean属性值的列表。
      Methods in javax.management that return List
      Modifier and Type 方法 描述
      List<Attribute> AttributeList.asList​()
      将此列表的视图作为 List<Attribute> 。
      Constructors in javax.management with parameters of type List
      Constructor 描述
      AttributeList​(List<Attribute> list)
      构造一个 AttributeList其中包含 AttributeList的元素，按 List的迭代器返回的 List 。

    • Uses of List in javax.management.loading

      Methods in javax.management.loading that return List
      Modifier and Type 方法 描述
      List<String> MLetContent.getParameterTypes​()
      获取的值的列表 TYPE在中每个嵌套<PARAM>标记属性 MLET标签。
      List<String> MLetContent.getParameterValues​()
      获取 MLET标签中每个嵌套的<PARAM>标签中的 VALUE属性的值列表。
      Constructors in javax.management.loading with parameters of type List
      Constructor 描述
      MLetContent​(URL url, Map<String,String> attributes, List<String> types, List<String> values)
      创建一个 MLet实例，使用从MLet文本文件中的 MLET标记读取的属性初始化。

    • Uses of List in javax.management.openmbean

      Fields in javax.management.openmbean declared as List
      Modifier and Type Field 描述
      static List<String> OpenType.ALLOWED_CLASSNAMES_LIST
      列出允许开放数据值的Java类的完全限定名称。
      Methods in javax.management.openmbean that return List
      Modifier and Type 方法 描述
      List<String> TabularType.getIndexNames​()
      按照与此实例的构造函数相同的顺序返回一个不可修改的列表，该列表的值用于唯一地索引此 TabularType实例描述的表格数据值的每个行元素。

    • Uses of List in javax.management.relation

      Classes in javax.management.relation that implement List
      Modifier and Type Class 描述
      class  RoleList
      RoleList表示角色列表（Role对象）。
      class  RoleUnresolvedList
      RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。
      Methods in javax.management.relation that return List
      Modifier and Type 方法 描述
      List<Role> RoleList.asList​()
      将此列表的视图作为 List<Role> 。
      List<RoleUnresolved> RoleUnresolvedList.asList​()
      将此列表的视图作为 List<RoleUnresolved> 。
      List<String> RelationService.findRelationsOfType​(String relationTypeName)
      返回给定类型的关系的关系id。
      List<String> RelationServiceMBean.findRelationsOfType​(String relationTypeName)
      返回给定类型的关系的关系id。
      List<String> RelationService.getAllRelationIds​()
      返回由关系服务处理的所有关系的所有关系ID。
      List<String> RelationServiceMBean.getAllRelationIds​()
      返回由关系服务处理的所有关系的所有关系ID。
      List<String> RelationService.getAllRelationTypeNames​()
      检索所有已知关系类型的名称。
      List<String> RelationServiceMBean.getAllRelationTypeNames​()
      检索所有已知关系类型的名称。
      List<ObjectName> RelationNotification.getMBeansToUnregister​()
      返回由于删除关系而导致的预期未注册的MBean的ObjectName的列表（仅用于删除关系）。
      List<ObjectName> RelationNotification.getNewRoleValue​()
      返回更新角色的新值（仅适用于角色更新）。
      List<ObjectName> RelationNotification.getOldRoleValue​()
      返回已更新角色的旧值（仅适用于角色更新）。
      List<ObjectName> Relation.getRole​(String roleName)
      检索给定角色名称的角色值。
      List<ObjectName> RelationService.getRole​(String relationId, String roleName)
      在给定关系中为给定的角色名称检索角色值。
      List<ObjectName> RelationServiceMBean.getRole​(String relationId, String roleName)
      在给定关系中为给定的角色名称检索角色值。
      List<ObjectName> RelationSupport.getRole​(String roleName)
      检索给定角色名称的角色值。
      List<RoleInfo> RelationService.getRoleInfos​(String relationTypeName)
      检索给定关系类型的角色信息（RoleInfo对象）的列表。
      List<RoleInfo> RelationServiceMBean.getRoleInfos​(String relationTypeName)
      检索给定关系类型的角色信息（RoleInfo对象）的列表。
      List<RoleInfo> RelationType.getRoleInfos​()
      返回角色定义列表（RoleInfo对象的ArrayList）。
      List<RoleInfo> RelationTypeSupport.getRoleInfos​()
      返回角色定义列表（RoleInfo对象的ArrayList）。
      List<ObjectName> Role.getRoleValue​()
      检索角色值。
      List<ObjectName> RoleUnresolved.getRoleValue​()
      检索角色值。
      Methods in javax.management.relation that return types with arguments of type List
      Modifier and Type 方法 描述
      Map<ObjectName,List<String>> RelationService.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索与某个关系中的给定关联的MBean。
      Map<ObjectName,List<String>> RelationServiceMBean.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索与某个关系中的给定关联的MBean。
      Map<String,List<String>> RelationService.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索给定MBean引用的关系。
      Map<String,List<String>> RelationServiceMBean.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索给定MBean引用的关系。
      Map<ObjectName,List<String>> Relation.getReferencedMBeans​()
      检索在关系的各种角色中引用的MBean。
      Map<ObjectName,List<String>> RelationService.getReferencedMBeans​(String relationId)
      检索在关系的各种角色中引用的MBean。
      Map<ObjectName,List<String>> RelationServiceMBean.getReferencedMBeans​(String relationId)
      检索在关系的各种角色中引用的MBean。
      Map<ObjectName,List<String>> RelationSupport.getReferencedMBeans​()
      检索在关系的各种角色中引用的MBean。
      Methods in javax.management.relation with parameters of type List
      Modifier and Type 方法 描述
      static String Role.roleValueToString​(List<ObjectName> roleValue)
      返回给定角色值的字符串。
      void RelationService.sendRelationRemovalNotification​(String relationId, List<ObjectName> unregMBeanList)
      发送通知（RelationNotification）用于删除关系。
      void RelationServiceMBean.sendRelationRemovalNotification​(String relationId, List<ObjectName> unregMBeanList)
      发送通知（RelationNotification）用于删除关系。
      void RelationService.sendRoleUpdateNotification​(String relationId, Role newRole, List<ObjectName> oldValue)
      发送给定关系中角色更新的通知（RelationNotification）。
      void RelationServiceMBean.sendRoleUpdateNotification​(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      发送给定关系中角色更新的通知（RelationNotification）。
      void Role.setRoleValue​(List<ObjectName> roleValue)
      设置角色值。
      void RoleUnresolved.setRoleValue​(List<ObjectName> value)
      设置角色值。
      void RelationService.updateRoleMap​(String relationId, Role newRole, List<ObjectName> oldValue)
      处理关系服务角色图更新给定关系中给定角色的更新。
      void RelationServiceMBean.updateRoleMap​(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      处理关系服务角色图更新给定关系中给定角色的更新。
      Constructors in javax.management.relation with parameters of type List
      Constructor 描述
      RelationNotification​(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
      为关系中的角色更新创建通知。
      RelationNotification​(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
      创建关系创建（RelationSupport对象在关系服务内部创建的，或作为关系添加的MBean）或关系删除关系服务的通知。
      Role​(String roleName, List<ObjectName> roleValue)
      创建一个新的角色对象。
      RoleList​(List<Role> list)
      构造一个 RoleList含有的元素 List指定，在其中它们被返回的顺序 List的迭代器。
      RoleUnresolved​(String name, List<ObjectName> value, int pbType)
      构造函数。
      RoleUnresolvedList​(List<RoleUnresolved> list)
      构造一个 RoleUnresolvedList含有的元素 List指定，在其中它们被返回的顺序 List的迭代器。

    • Uses of List in javax.naming.ldap

      Methods in javax.naming.ldap that return List
      Modifier and Type 方法 描述
      List<Rdn> LdapName.getRdns​()
      检索相对可分辨名称的列表。
      Methods in javax.naming.ldap with parameters of type List
      Modifier and Type 方法 描述
      Name LdapName.addAll​(int posn, List<Rdn> suffixRdns)
      在名称中的指定位置添加名称的RDN。
      Name LdapName.addAll​(List<Rdn> suffixRdns)
      将名称的RDN添加到该名称的末尾。
      boolean LdapName.endsWith​(List<Rdn> rdns)
      确定指定的RDN序列是否形成此LDAP名称的后缀。
      boolean LdapName.startsWith​(List<Rdn> rdns)
      确定指定的RDN序列是否形成此LDAP名称的前缀。
      Constructors in javax.naming.ldap with parameters of type List
      Constructor 描述
      LdapName​(List<Rdn> rdns)
      给出其解析的RDN组件构造一个LDAP名称。

    • Uses of List in javax.net.ssl

      Methods in javax.net.ssl that return List
      Modifier and Type 方法 描述
      List<KeyStore.Builder> KeyStoreBuilderParameters.getParameters​()
      返回此对象封装的KeyStore.Builder的不可修改列表。
      List<SNIServerName> ExtendedSSLSession.getRequestedServerNames​()
      获得List包含所有SNIServerName个 S上的请求的服务器名称指示（SNI）扩展的。
      List<SNIServerName> SSLParameters.getServerNames​()
      返回List包含所有SNIServerName •服务器名称指示的（SNI）的参数，如果没有则为null已设置。
      List<byte[]> ExtendedSSLSession.getStatusResponses​()
      返回一个List含DER编码OCSP应答（使用RFC 6960中定义的ASN.1类型OCSPResponse）为客户端握手期间，以验证服务器证书的状态。
      Methods in javax.net.ssl that return types with arguments of type List
      Modifier and Type 方法 描述
      BiFunction<SSLEngine,List<String>,String> SSLEngine.getHandshakeApplicationProtocolSelector​()
      检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。
      BiFunction<SSLSocket,List<String>,String> SSLSocket.getHandshakeApplicationProtocolSelector​()
      检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。
      Methods in javax.net.ssl with parameters of type List
      Modifier and Type 方法 描述
      void SSLParameters.setServerNames​(List<SNIServerName> serverNames)
      设置服务器名称指示（SNI）参数所需的SNIServerName 。
      Method parameters in javax.net.ssl with type arguments of type List
      Modifier and Type 方法 描述
      void SSLEngine.setHandshakeApplicationProtocolSelector​(BiFunction<SSLEngine,List<String>,String> selector)
      注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。
      void SSLSocket.setHandshakeApplicationProtocolSelector​(BiFunction<SSLSocket,List<String>,String> selector)
      注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。
      Constructors in javax.net.ssl with parameters of type List
      Constructor 描述
      KeyStoreBuilderParameters​(List<KeyStore.Builder> parameters)
      从KeyStore.Builder的列表中构造新的KeyStoreBuilderParameters。

    • Uses of List in javax.script

      Methods in javax.script that return List
      Modifier and Type 方法 描述
      List<ScriptEngineFactory> ScriptEngineManager.getEngineFactories​()
      返回一个列表，其元素是发现机制找到的所有 ScriptEngineFactory类的实例。
      List<String> ScriptEngineFactory.getExtensions​()
      返回一个不可变的文件扩展名列表，它们通常标识以 ScriptEngine支持的语言编写的脚本。
      List<String> ScriptEngineFactory.getMimeTypes​()
      返回一个不可变的mimetype列表，与引擎可执行的脚本相关联。
      List<String> ScriptEngineFactory.getNames​()
      返回短名称的不可变列表 ScriptEngine ，可用于识别 ScriptEngine由 ScriptEngineManager 。
      List<Integer> ScriptContext.getScopes​()
      返回不可变的 List ScriptContext中范围的所有有效值。
      List<Integer> SimpleScriptContext.getScopes​()
      为ScriptContext中范围的所有有效值返回不可变的 List 。

    • Uses of List in javax.smartcardio

      Methods in javax.smartcardio that return List
      Modifier and Type 方法 描述
      List<CardTerminal> CardTerminals.list​()
      返回所有可用终端的不可修改列表。
      abstract List<CardTerminal> CardTerminals.list​(CardTerminals.State state)
      返回与指定状态匹配的所有终端的不可修改列表。

    • Uses of List in javax.sound.midi

      Methods in javax.sound.midi that return List
      Modifier and Type 方法 描述
      List<Receiver> MidiDevice.getReceivers​()
      返回与此MidiDevice连接的所有当前活动的非闭合接收器。
      List<Transmitter> MidiDevice.getTransmitters​()
      返回与此MidiDevice连接的所有当前有效的非闭合发射器。

    • Uses of List in javax.swing

      Methods in javax.swing that return List
      Modifier and Type 方法 描述
      List<?> SpinnerListModel.getList​()
      返回定义此模型序列的 List 。
      List<E> JList.getSelectedValuesList​()
      根据列表中的索引，按照增加的顺序返回所有选定项目的列表。
      List<? extends RowSorter.SortKey> DefaultRowSorter.getSortKeys​()
      返回当前的排序键。
      abstract List<? extends RowSorter.SortKey> RowSorter.getSortKeys​()
      返回当前的排序键。
      Methods in javax.swing with parameters of type List
      Modifier and Type 方法 描述
      protected void SwingWorker.process​(List<V> chunks)
      在 事件发送线程上异步接收来自 publish方法的数据块。
      void SpinnerListModel.setList​(List<?> list)
      更改定义此序列的列表，并将模型 value的索引重置为零。
      void DefaultRowSorter.setSortKeys​(List<? extends RowSorter.SortKey> sortKeys)
      设置排序键。
      abstract void RowSorter.setSortKeys​(List<? extends RowSorter.SortKey> keys)
      设置当前的排序键。
      Constructors in javax.swing with parameters of type List
      Constructor 描述
      SpinnerListModel​(List<?> values)
      构造一个 SpinnerModel其值序列由指定的 List定义。

    • Uses of List in javax.tools

      Methods in javax.tools that return List
      Modifier and Type 方法 描述
      List<Diagnostic<? extends S>> DiagnosticCollector.getDiagnostics​()
      返回此对象收集的诊断的列表视图。

    • Uses of List in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return List
      Modifier and Type 方法 描述
      List<XMLStructure> SignatureProperty.getContent​()
      返回一个XMLStructure中包含的XMLStructure s的SignatureProperty 。
      List<XMLStructure> XMLObject.getContent​()
      返回此XMLObject中包含的XMLStructure的XMLObject ，它代表任何命名空间的元素。
      List<XMLObject> XMLSignature.getObjects​()
      返回此XMLSignature中包含的XMLObject的XMLSignature 。
      List<SignatureProperty> SignatureProperties.getProperties​()
      返回此SignatureProperties中包含的一个或多个SignatureProperty的SignatureProperties 。
      List<Reference> Manifest.getReferences​()
      返回Manifest中包含的一个或多个Reference的Manifest 。
      List<Reference> SignedInfo.getReferences​()
      返回一个unmodifiable list一个或多个Reference秒。
      List<Transform> Reference.getTransforms​()
      返回一个unmodifiable list的Transform包含在这个S Reference 。
      Methods in javax.xml.crypto.dsig with parameters of type List
      Modifier and Type 方法 描述
      abstract Manifest XMLSignatureFactory.newManifest​(List<? extends Reference> references)
      创建一个包含Manifest的指定列表的Manifest 。
      abstract Manifest XMLSignatureFactory.newManifest​(List<? extends Reference> references, String id)
      创建Manifest包含指定的列表Reference个 S和可选id。
      abstract Reference XMLSignatureFactory.newReference​(String uri, DigestMethod dm, List<? extends Transform> transforms, String type, String id)
      创建具有指定参数的 Reference 。
      abstract Reference XMLSignatureFactory.newReference​(String uri, DigestMethod dm, List<? extends Transform> transforms, String type, String id, byte[] digestValue)
      创建具有指定参数的 Reference和预计算的摘要值。
      abstract Reference XMLSignatureFactory.newReference​(String uri, DigestMethod dm, List<? extends Transform> appliedTransforms, Data result, List<? extends Transform> transforms, String type, String id)
      创建具有指定参数的 Reference 。
      abstract SignatureProperties XMLSignatureFactory.newSignatureProperties​(List<? extends SignatureProperty> properties, String id)
      创建一个SignatureProperties其中包含指定的SignatureProperty列表和可选的id。
      abstract SignatureProperty XMLSignatureFactory.newSignatureProperty​(List<? extends XMLStructure> content, String target, String id)
      创建一个SignatureProperty其中包含XMLStructure的目标URI和可选的id的指定列表。
      abstract SignedInfo XMLSignatureFactory.newSignedInfo​(CanonicalizationMethod cm, SignatureMethod sm, List<? extends Reference> references)
      创建具有指定的规范化和签名方法的 SignedInfo以及一个或多个引用的列表。
      abstract SignedInfo XMLSignatureFactory.newSignedInfo​(CanonicalizationMethod cm, SignatureMethod sm, List<? extends Reference> references, String id)
      创建具有指定参数的 SignedInfo 。
      abstract XMLObject XMLSignatureFactory.newXMLObject​(List<? extends XMLStructure> content, String id, String mimeType, String encoding)
      从指定的参数创建一个 XMLObject 。
      abstract XMLSignature XMLSignatureFactory.newXMLSignature​(SignedInfo si, KeyInfo ki, List<? extends XMLObject> objects, String id, String signatureValueId)
      创建一个 XMLSignature并用指定的参数进行初始化。

    • Uses of List in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return List
      Modifier and Type 方法 描述
      List<XMLStructure> KeyInfo.getContent​()
      返回包含密钥信息的 unmodifiable list 。
      List<?> X509Data.getContent​()
      返回 unmodifiable list的这个 X509Data的内容。
      List<XMLStructure> PGPData.getExternalElements​()
      返回一个unmodifiable list的XMLStructure s表示来自外部命名空间的元素。
      List<Transform> RetrievalMethod.getTransforms​()
      返回此RetrievalMethod的Transform的RetrievalMethod 。
      Methods in javax.xml.crypto.dsig.keyinfo with parameters of type List
      Modifier and Type 方法 描述
      abstract KeyInfo KeyInfoFactory.newKeyInfo​(List<? extends XMLStructure> content)
      创建包含指定的关键信息类型列表的 KeyInfo 。
      abstract KeyInfo KeyInfoFactory.newKeyInfo​(List<? extends XMLStructure> content, String id)
      创建一个 KeyInfo其中包含指定的关键信息类型和可选标识列表。
      abstract PGPData KeyInfoFactory.newPGPData​(byte[] keyId, byte[] keyPacket, List<? extends XMLStructure> other)
      从指定的PGP公共密钥标识符和可选的密钥材料数据包和外部元素列表创建 PGPData 。
      abstract PGPData KeyInfoFactory.newPGPData​(byte[] keyPacket, List<? extends XMLStructure> other)
      从指定的PGP密钥材料数据包和外部元素的可选列表中创建 PGPData 。
      abstract RetrievalMethod KeyInfoFactory.newRetrievalMethod​(String uri, String type, List<? extends Transform> transforms)
      从指定的参数创建一个 RetrievalMethod 。
      abstract X509Data KeyInfoFactory.newX509Data​(List<?> content)
      创建一个包含指定的X.509内容列表的 X509Data 。

    • Uses of List in javax.xml.crypto.dsig.spec

      Methods in javax.xml.crypto.dsig.spec that return List
      Modifier and Type 方法 描述
      List<String> ExcC14NParameterSpec.getPrefixList​()
      返回包含的名称空间前缀列表。
      List<XPathType> XPathFilter2ParameterSpec.getXPathList​()
      返回一个或多个XPathType对象的列表。
      Constructors in javax.xml.crypto.dsig.spec with parameters of type List
      Constructor 描述
      ExcC14NParameterSpec​(List<String> prefixList)
      创建具有指定的前缀列表的 ExcC14NParameterSpec 。
      XPathFilter2ParameterSpec​(List<XPathType> xPathList)
      创建一个 XPathFilter2ParameterSpec 。

    • Uses of List in javax.xml.stream.events

      Methods in javax.xml.stream.events that return List
      Modifier and Type 方法 描述
      List<EntityDeclaration> DTD.getEntities​()
      返回一个包含在DTD中声明的外部和内部的一般实体的列表。
      List<NotationDeclaration> DTD.getNotations​()
      返回一个包含DTD中声明的符号的列表。

    • Uses of List in javax.xml.ws

      Methods in javax.xml.ws that return List
      Modifier and Type 方法 描述
      List<Handler> Binding.getHandlerChain​()
      获取协议绑定实例的处理程序链的副本。
      abstract List<Source> Endpoint.getMetadata​()
      返回服务的元数据文档列表。
      Methods in javax.xml.ws with parameters of type List
      Modifier and Type 方法 描述
      void Binding.setHandlerChain​(List<Handler> chain)
      设置协议绑定实例的处理程序链。
      abstract void Endpoint.setMetadata​(List<Source> metadata)
      设置此端点的元数据。

    • Uses of List in javax.xml.ws.handler

      Methods in javax.xml.ws.handler that return List
      Modifier and Type 方法 描述
      List<Handler> HandlerResolver.getHandlerChain​(PortInfo portInfo)
      获取指定端口的处理程序链。

    • Uses of List in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type List
      Modifier and Type 方法 描述
      abstract W3CEndpointReference Provider.createW3CEndpointReference​(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      工厂方法创建一个 W3CEndpointReference 。
      W3CEndpointReference Provider.createW3CEndpointReference​(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      工厂方法创建一个 W3CEndpointReference 。

    • Uses of List in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return types with arguments of type List
      Modifier and Type 方法 描述
      abstract Map<String,List<String>> HttpExchange.getRequestHeaders​()
      返回包含此请求中包含的HTTP标头的不可变地图。
      abstract Map<String,List<String>> HttpExchange.getResponseHeaders​()
      返回一个可变地图，可以存储HTTP响应标头，哪个将作为此响应的一部分进行传输。

    • Uses of List in javax.xml.xpath

      Methods in javax.xml.xpath with parameters of type List
      Modifier and Type 方法 描述
      Object XPathFunction.evaluate​(List args)
      用指定的参数来评估函数。

    • Uses of List in jdk.dynalink

      Methods in jdk.dynalink that return List
      Modifier and Type 方法 描述
      List<ServiceConfigurationError> DynamicLinkerFactory.getAutoLoadingErrors​()
      返回在上次调用期间加载自动发现的链接器时遇到的ServiceConfigurationError的列表DynamicLinkerFactory.createLinker() 。
      Methods in jdk.dynalink with parameters of type List
      Modifier and Type 方法 描述
      void DynamicLinkerFactory.setFallbackLinkers​(List<? extends GuardingDynamicLinker> fallbackLinkers)
      设置后备守护动态链接器。
      void DynamicLinkerFactory.setPrioritizedLinkers​(List<? extends GuardingDynamicLinker> prioritizedLinkers)
      设置优先级的守护动态链接器。

    • Uses of List in jdk.dynalink.linker

      Methods in jdk.dynalink.linker with parameters of type List
      Modifier and Type 方法 描述
      GuardedInvocation GuardedInvocation.dropArguments​(int pos, List<Class<?>> valueTypes)
      在调用和保护（如果存在并且至少有 pos参数）中使用 MethodHandles.dropArguments(MethodHandle, int, List)的参数进行 调用 。

    • Uses of List in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support that return List
      Modifier and Type 方法 描述
      static List<GuardingDynamicLinker> CompositeTypeBasedGuardingDynamicLinker.optimize​(Iterable<? extends GuardingDynamicLinker> linkers)
      优化基于类型的链接器的列表。

    • Uses of List in jdk.incubator.http

      Methods in jdk.incubator.http that return List
      Modifier and Type 方法 描述
      List<String> HttpHeaders.allValues​(String name)
      返回给定的命名头的所有值的不可修改的列表。
      Methods in jdk.incubator.http that return types with arguments of type List
      Modifier and Type 方法 描述
      Map<String,List<String>> HttpHeaders.map​()
      返回此HttpHeaders的不可修改的多Map视图。

    • Uses of List in jdk.javadoc.doclet

      Methods in jdk.javadoc.doclet that return List
      Modifier and Type 方法 描述
      List<String> Doclet.Option.getNames​()
      返回可用于标识该选项的名称列表。
      Methods in jdk.javadoc.doclet with parameters of type List
      Modifier and Type 方法 描述
      boolean Doclet.Option.process​(String option, List<String> arguments)
      根据需要处理选项和参数。
      String Taglet.toString​(List<? extends DocTree> tags, Element element)
      返回要包含在生成的输出中的该标签的一系列实例的字符串表示形式。

    • Uses of List in jdk.jshell

      Methods in jdk.jshell that return List
      Modifier and Type 方法 描述
      abstract List<SourceCodeAnalysis.Suggestion> SourceCodeAnalysis.completionSuggestions​(String input, int cursor, int[] anchor)
      计算给定输入的可能跟踪。
      abstract List<SourceCodeAnalysis.Documentation> SourceCodeAnalysis.documentation​(String input, int cursor, boolean computeJavadoc)
      计算给定用户输入的文档。
      List<SnippetEvent> JShell.drop​(Snippet snippet)
      从状态中移除声明。
      List<SnippetEvent> JShell.eval​(String input)
      评估输入字符串，包括定义和/或执行（如果适用）。
      List<String> SourceCodeAnalysis.QualifiedNames.getNames​()
      原始代码中给定简单名称的已知限定名称。
      abstract List<SourceCodeAnalysis.SnippetWrapper> SourceCodeAnalysis.wrappers​(String input)
      返回输入源字符串中代码段的包装器信息。

    • Uses of List in jdk.jshell.execution

      Constructors in jdk.jshell.execution with parameters of type List
      Constructor 描述
      JdiInitiator​(int port, List<String> remoteVMOptions, String remoteAgent, boolean isLaunch, String host, int timeout, Map<String,String> customConnectorArgs)
      启动远程代理并建立一个JDI连接。

    • Uses of List in jdk.jshell.spi

      Methods in jdk.jshell.spi that return List
      Modifier and Type 方法 描述
      List<String> ExecutionEnv.extraRemoteVMOptions​()
      返回启动远程JVM时要使用的其他VM选项。

    • Uses of List in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that return List
      Modifier and Type | 方法 | 描述
      List<String> | NashornScriptEngineFactory.getExtensions​()
      List<String> | NashornScriptEngineFactory.getMimeTypes​()
      List<String> | NashornScriptEngineFactory.getNames​()

    • Uses of List in jdk.nashorn.api.tree

      Methods in jdk.nashorn.api.tree that return List
      Modifier and Type 方法 描述
      List<? extends ExpressionTree> FunctionCallTree.getArguments​()
      返回传递给此函数调用的参数列表。
      List<? extends CaseTree> SwitchTree.getCases​()
      返回'case'语句的列表。
      List<? extends CatchTree> TryTree.getCatches​()
      返回与'try'关联的'catch'语句的列表。
      List<? extends PropertyTree> ClassDeclarationTree.getClassElements​()
      获取除构造函数之外的其他属性定义。
      List<? extends PropertyTree> ClassExpressionTree.getClassElements​()
      获取除构造函数之外的其他属性定义。
      List<? extends ExpressionTree> ArrayLiteralTree.getElements​()
      返回Array元素表达式的列表。
      List<? extends ExpressionTree> TemplateLiteralTree.getExpressions​()
      返回此模板字符串中的表达式列表
      List<? extends ImportEntryTree> ModuleTree.getImportEntries​()
      返回导入条目的列表。
      List<? extends ExportEntryTree> ModuleTree.getIndirectExportEntries​()
      返回间接导出条目的列表。
      List<? extends ExportEntryTree> ModuleTree.getLocalExportEntries​()
      返回本地导出条目的列表。
      List<? extends ExpressionTree> FunctionDeclarationTree.getParameters​()
      返回此函数的参数。
      List<? extends ExpressionTree> FunctionExpressionTree.getParameters​()
      返回此函数的参数。
      List<? extends PropertyTree> ObjectLiteralTree.getProperties​()
      返回此对象文字的属性列表。
      List<? extends 树> CompilationUnitTree.getSourceElements​()
      返回此编译单元中的源元素列表。
      List<? extends ExportEntryTree> ModuleTree.getStarExportEntries​()
      返回明星导出条目的列表。
      List<? extends StatementTree> BlockTree.getStatements​()
      返回此块中的语句列表。
      List<? extends StatementTree> CaseTree.getStatements​()
      返回这个“case”的语句列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.ListIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.ListIterator

  • Packages that use ListIterator
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。

    • Uses of ListIterator in java.util

      Methods in java.util that return ListIterator
      Modifier and Type 方法 描述
      static <T> ListIterator<T> Collections.emptyListIterator​()
      返回没有元素的列表迭代器。
      ListIterator<E> AbstractList.listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> AbstractList.listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
      abstract ListIterator<E> AbstractSequentialList.listIterator​(int index)
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> ArrayList.listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> ArrayList.listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
      ListIterator<E> LinkedList.listIterator​(int index)
      从列表中的指定位置开始，返回此列表中元素的列表迭代器（按适当的顺序）。
      ListIterator<E> List.listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> List.listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
      ListIterator<E> Vector.listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> Vector.listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。

    • Uses of ListIterator in java.util.concurrent

      Methods in java.util.concurrent that return ListIterator
      Modifier and Type 方法 描述
      ListIterator<E> CopyOnWriteArrayList.listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> CopyOnWriteArrayList.listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。

    • Uses of ListIterator in javafx.beans.binding

      Methods in javafx.beans.binding that return ListIterator
      Modifier and Type | 方法 | 描述
      ListIterator<E> | ListExpression.listIterator​()
      ListIterator<E> | ListExpression.listIterator​(int i)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Map (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Map

  • Packages that use Map
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.management
    此软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.security.auth.module
    提供LoginModule的实现。
    com.sun.tools.jconsole
    此程序包包含JConsole API。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.im
    提供输入法框架的类和接口。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供者类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.spi
    java.util包中类的服务提供者类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.application
    提供应用程序生命周期类。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.auth.spi
    该包提供了用于实现可插拔认证模块的接口。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    javax.security.sasl
    包含用于支持SASL的类和接口。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.crypto.dsig.spec
    XML数字签名的参数类。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.handler
    新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：
    javax.xml.ws.handler.soap
    此包定义SOAP消息处理程序的API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.packager.services
    定义Java Packager工具使用的服务。

    • Uses of Map in com.sun.jdi

      Methods in com.sun.jdi that return Map
      Modifier and Type 方法 描述
      Map<Field,Value> ObjectReference.getValues​(List<? extends Field> fields)
      获取此对象中多个实例和/或静态字段的值。
      Map<Field,Value> ReferenceType.getValues​(List<? extends Field> fields)
      返回包含给定列表中每个静态Field的Value的地图。
      Map<LocalVariable,Value> StackFrame.getValues​(List<? extends LocalVariable> variables)
      返回此框架中多个局部变量的值。
      Methods in com.sun.jdi with parameters of type Map
      Modifier and Type 方法 描述
      void VirtualMachine.redefineClasses​(Map<? extends ReferenceType,byte[]> classToBytes)
      根据提供的定义重新定义所有给定的类。

    • Uses of Map in com.sun.jdi.connect

      Methods in com.sun.jdi.connect that return Map
      Modifier and Type 方法 描述
      Map<String,Connector.Argument> Connector.defaultArguments​()
      返回此连接器接受的参数及其默认值。
      Methods in com.sun.jdi.connect with parameters of type Map
      Modifier and Type 方法 描述
      VirtualMachine ListeningConnector.accept​(Map<String,? extends Connector.Argument> arguments)
      等待目标VM附加到此连接器。
      VirtualMachine AttachingConnector.attach​(Map<String,? extends Connector.Argument> arguments)
      附加到正在运行的应用程序并返回其虚拟机的镜像。
      VirtualMachine LaunchingConnector.launch​(Map<String,? extends Connector.Argument> arguments)
      启动应用程序并连接到其VM。
      String ListeningConnector.startListening​(Map<String,? extends Connector.Argument> arguments)
      侦听由目标虚拟机发起的一个或多个连接。
      void ListeningConnector.stopListening​(Map<String,? extends Connector.Argument> arguments)
      取消侦听连接。

    • Uses of Map in com.sun.management

      Methods in com.sun.management that return Map
      Modifier and Type 方法 描述
      Map<String,MemoryUsage> GcInfo.getMemoryUsageAfterGc​()
      返回此GC结尾处的所有内存池的内存使用情况。
      Map<String,MemoryUsage> GcInfo.getMemoryUsageBeforeGc​()
      返回此GC开头的所有内存池的内存使用情况。

    • Uses of Map in com.sun.net.httpserver

      Classes in com.sun.net.httpserver that implement Map
      Modifier and Type Class 描述
      class  Headers
      HTTP请求和响应头通过此类，它实现接口表示Map < String ， List < String >>。
      Methods in com.sun.net.httpserver that return Map
      Modifier and Type 方法 描述
      abstract Map<String,Object> HttpContext.getAttributes​()
      返回一个可变的Map，可以将配置和其他数据传递给Filter模块和上下文的交换处理程序。
      Methods in com.sun.net.httpserver with parameters of type Map
      Modifier and Type | 方法 | 描述
      void | Headers.putAll​(Map<? extends String,? extends List<String>> t)

    • Uses of Map in com.sun.security.auth.module

      Methods in com.sun.security.auth.module with parameters of type Map
      Modifier and Type 方法 描述
      void JndiLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      void KeyStoreLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      void Krb5LoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      void LdapLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      void NTLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      void SolarisLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      初始化 LoginModule 。
      void UnixLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。

    • Uses of Map in com.sun.tools.jconsole

      Methods in com.sun.tools.jconsole that return Map
      Modifier and Type 方法 描述
      abstract Map<String,JPanel> JConsolePlugin.getTabs​()
      返回要在JConsole窗口中添加的选项卡。

    • Uses of Map in java.awt

      Classes in java.awt that implement Map
      Modifier and Type Class 描述
      class  RenderingHints
      RenderingHints类定义和管理密钥和关联值的集合，允许应用程序为执行渲染和图像处理服务的其他类使用的算法选择提供输入。
      Fields in java.awt declared as Map
      Modifier and Type Field 描述
      protected Map<String,Object> Toolkit.desktopProperties
      桌面属性。
      Methods in java.awt that return Map
      Modifier and Type 方法 描述
      Map<TextAttribute,?> Font.getAttributes​()
      返回此 Font可用的字体属性的映射。
      abstract Map<TextAttribute,?> Toolkit.mapInputMethodHighlight​(InputMethodHighlight highlight)
      返回给定输入法突出显示的抽象级别描述的可视属性映射，如果没有找到映射，则返回null。
      Methods in java.awt with parameters of type Map
      Modifier and Type 方法 描述
      abstract void Graphics2D.addRenderingHints​(Map<?,?> hints)
      为渲染算法设置任意数量的首选项的值。
      Font Font.deriveFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      通过复制当前的 Font对象并应用一组新的字体属性来创建一个新的 Font对象。
      static Font Font.getFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      返回一个适合于属性的 Font 。
      void RenderingHints.putAll​(Map<?,?> m)
      将所有映射从指定的 Map到此 RenderingHints 。
      abstract void Graphics2D.setRenderingHints​(Map<?,?> hints)
      用指定的 hints替换渲染算法的所有首选项的值。
      Constructors in java.awt with parameters of type Map
      Constructor 描述
      Font​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      创建具有指定属性的新的 Font 。
      RenderingHints​(Map<RenderingHints.Key,?> init)
      构造一个新对象，该对象具有从指定的Map对象初始化的键和值，该对象可能为null。

    • Uses of Map in java.awt.datatransfer

      Methods in java.awt.datatransfer that return Map
      Modifier and Type 方法 描述
      Map<String,DataFlavor> FlavorMap.getFlavorsForNatives​(String[] natives)
      返回 Map指定的 String native到其相应 DataFlavor 。
      Map<String,DataFlavor> SystemFlavorMap.getFlavorsForNatives​(String[] natives)
      将 Map个特定的 String返回给他们最喜欢的 DataFlavor 。
      Map<DataFlavor,String> FlavorMap.getNativesForFlavors​(DataFlavor[] flavors)
      将 Map的 DataFlavor为相应的 String本机。
      Map<DataFlavor,String> SystemFlavorMap.getNativesForFlavors​(DataFlavor[] flavors)
      将 Map的 DataFlavor为最优惠的 String本机。

    • Uses of Map in java.awt.font

      Constructors in java.awt.font with parameters of type Map
      Constructor 描述
      TextLayout​(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
      从 String构建一个 TextLayout和一个属性集。

    • Uses of Map in java.awt.im

      Methods in java.awt.im that return Map
      Modifier and Type 方法 描述
      Map<TextAttribute,?> InputMethodHighlight.getStyle​()
      返回文本范围的渲染样式属性，或返回null。
      Constructors in java.awt.im with parameters of type Map
      Constructor 描述
      InputMethodHighlight​(boolean selected, int state, int variation, Map<TextAttribute,?> style)
      构造输入法高亮记录。

    • Uses of Map in java.lang

      Methods in java.lang that return Map
      Modifier and Type 方法 描述
      Map<String,String> ProcessBuilder.environment​()
      返回此流程构建器环境的字符串映射视图。
      static Map<Thread,StackTraceElement[]> Thread.getAllStackTraces​()
      返回所有活动线程的堆栈跟踪图。
      static Map<String,String> System.getenv​()
      返回当前系统环境的不可修改的字符串映射视图。

    • Uses of Map in java.lang.instrument

      Methods in java.lang.instrument with parameters of type Map
      Modifier and Type 方法 描述
      void Instrumentation.redefineModule​(Module module, Set<Module> extraReads, Map<String,Set<Module>> extraExports, Map<String,Set<Module>> extraOpens, Set<Class<?>> extraUses, Map<Class<?>,List<Class<?>>> extraProvides)
      重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。

    • Uses of Map in java.lang.management

      Methods in java.lang.management that return Map
      Modifier and Type 方法 描述
      Map<String,String> RuntimeMXBean.getSystemProperties​()
      返回所有系统属性的名称和值的映射。

    • Uses of Map in java.net

      Methods in java.net that return Map
      Modifier and Type | 方法 | 描述
      abstract Map<String,List<String>> CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)
      从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。
      Map<String,List<String>> | CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)
      Map<String,List<String>> URLConnection.getHeaderFields​()
      返回不可修改的标题字段的映射。
      abstract Map<String,List<String>> CacheResponse.getHeaders​()
      将响应标头作为Map返回。
      Map<String,List<String>> URLConnection.getRequestProperties​()
      返回此连接的一般请求属性的不可修改映射。
      Methods in java.net with parameters of type Map
      Modifier and Type | 方法 | 描述
      abstract Map<String,List<String>> CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)
      从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。
      Map<String,List<String>> | CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)
      abstract CacheResponse ResponseCache.get​(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
      根据请求的uri，请求方法和请求标头检索缓存的响应。
      abstract void CookieHandler.put​(URI uri, Map<String,List<String>> responseHeaders)
      设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。
      void | CookieManager.put​(URI uri, Map<String,List<String>> responseHeaders)

    • Uses of Map in java.nio.file

      Methods in java.nio.file that return Map
      Modifier and Type 方法 描述
      static Map<String,Object> Files.readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      Methods in java.nio.file with parameters of type Map
      Modifier and Type 方法 描述
      static FileSystem FileSystems.newFileSystem​(URI uri, Map<String,?> env)
      构造一个由URI标识的新文件系统
      static FileSystem FileSystems.newFileSystem​(URI uri, Map<String,?> env, ClassLoader loader)
      构造一个由URI标识的新文件系统

    • Uses of Map in java.nio.file.spi

      Methods in java.nio.file.spi that return Map
      Modifier and Type 方法 描述
      abstract Map<String,Object> FileSystemProvider.readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      Methods in java.nio.file.spi with parameters of type Map
      Modifier and Type 方法 描述
      abstract FileSystem FileSystemProvider.newFileSystem​(URI uri, Map<String,?> env)
      构造由URI标识的新的 FileSystem对象。
      FileSystem FileSystemProvider.newFileSystem​(Path path, Map<String,?> env)
      构造新的 FileSystem以访问文件的内容作为文件系统。

    • Uses of Map in java.security

      Classes in java.security that implement Map
      Modifier and Type Class 描述
      class  AuthProvider
      此类为提供程序定义登录和注销方法。
      class  Provider
      该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
      Methods in java.security that return Map
      Modifier and Type 方法 描述
      Map<String,KeyStore.ProtectionParameter> DomainLoadStoreParameter.getProtectionParams​()
      获取此域中密钥库的密钥库保护参数。
      Methods in java.security with parameters of type Map
      Modifier and Type 方法 描述
      static Provider[] Security.getProviders​(Map<String,String> filter)
      返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。
      void Provider.putAll​(Map<?,?> t)
      将指定地图中的所有映射复制到此提供程序。
      Constructors in java.security with parameters of type Map
      Constructor 描述
      DomainLoadStoreParameter​(URI configuration, Map<String,KeyStore.ProtectionParameter> protectionParams)
      使用用于保护密钥库数据的参数构建密钥库域的DomainLoadStoreParameter。
      Service​(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
      构建新服务

    • Uses of Map in java.security.cert

      Methods in java.security.cert that return Map
      Modifier and Type 方法 描述
      Map<String,Extension> CertificateRevokedException.getExtensions​()
      返回X.509扩展名的地图，其中包含有关撤销证书的附加信息，例如无效日期扩展。
      Map<X509Certificate,byte[]> PKIXRevocationChecker.getOcspResponses​()
      获得OCSP响应。
      Methods in java.security.cert with parameters of type Map
      Modifier and Type 方法 描述
      void PKIXRevocationChecker.setOcspResponses​(Map<X509Certificate,byte[]> responses)
      设置OCSP响应。
      Constructors in java.security.cert with parameters of type Map
      Constructor 描述
      CertificateRevokedException​(Date revocationDate, CRLReason reason, X500Principal authority, Map<String,Extension> extensions)
      构造具有指定撤销日期，原因代码，权限名称和扩展名映射的 CertificateRevokedException 。

    • Uses of Map in java.sql

      Methods in java.sql that return Map
      Modifier and Type 方法 描述
      Map<String,ClientInfoStatus> SQLClientInfoException.getFailedProperties​()
      返回无法设置的客户端信息属性列表。
      Map<String,Class<?>> Connection.getTypeMap​()
      检索与该 Map对象关联的 Connection对象。
      Methods in java.sql with parameters of type Map
      Modifier and Type 方法 描述
      Object Array.getArray​(long index, int count, Map<String,Class<?>> map)
      检索由 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。
      Object Array.getArray​(Map<String,Class<?>> map)
      检索由该 Array对象指定的SQL ARRAY值的内容。
      Object[] Struct.getAttributes​(Map<String,Class<?>> map)
      生成 Struct对象表示的SQL结构化类型的属性的有序值。
      Object CallableStatement.getObject​(int parameterIndex, Map<String,Class<?>> map)
      返回表示OUT参数 parameterIndex的值的对象，并使用 map作为参数值的自定义映射。
      Object CallableStatement.getObject​(String parameterName, Map<String,Class<?>> map)
      返回表示OUT参数 parameterName的值的对象，并使用 map作为参数值的自定义映射。
      Object Ref.getObject​(Map<String,Class<?>> map)
      检索引用的对象，并使用给定的类型映射将其映射到Java类型。
      Object ResultSet.getObject​(int columnIndex, Map<String,Class<?>> map)
      检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 Object 。
      Object ResultSet.getObject​(String columnLabel, Map<String,Class<?>> map)
      检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Object 。
      ResultSet Array.getResultSet​(long index, int count, Map<String,Class<?>> map)
      检索一个结果集，该结果集包含从索引 index开始的子阵列的元素，并包含最多 count连续元素。
      ResultSet Array.getResultSet​(Map<String,Class<?>> map)
      检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。
      void Connection.setTypeMap​(Map<String,Class<?>> map)
      安装给定 TypeMap对象的类型映射此 Connection对象。
      Constructors in java.sql with parameters of type Map
      Constructor 描述
      SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， vendorCode和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause ， vendorCode和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause和 failedProperties 。
      SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException对象，该对象使用给定的 reason和 failedProperties初始化。
      SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， cause和 failedProperties 。
      SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties)
      构造一个 SQLClientInfoException对象，使用给定的 failedProperties初始化。
      SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException对象，该对象使用给定的 cause和 failedProperties初始化。

    • Uses of Map in java.text

      Methods in java.text that return Map
      Modifier and Type 方法 描述
      Map<AttributedCharacterIterator.Attribute,Object> AttributedCharacterIterator.getAttributes​()
      返回当前字符中定义的属性的地图。
      Methods in java.text with parameters of type Map
      Modifier and Type 方法 描述
      void AttributedString.addAttributes​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes, int beginIndex, int endIndex)
      将一组属性添加到字符串的子范围。
      Constructors in java.text with parameters of type Map
      Constructor 描述
      AttributedString​(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      使用给定的文本和属性构造一个AttributedString实例。

    • Uses of Map in java.time

      Fields in java.time declared as Map
      Modifier and Type Field 描述
      static Map<String,String> ZoneId.SHORT_IDS
      区域覆盖的映射，以启用短时区名称。
      Methods in java.time with parameters of type Map
      Modifier and Type 方法 描述
      static ZoneId ZoneId.of​(String zoneId, Map<String,String> aliasMap)
      获取使用其ID的 ZoneId实例，使用别名映射来补充标准区域ID。

    • Uses of Map in java.time.chrono

      Methods in java.time.chrono with parameters of type Map
      Modifier and Type | 方法 | 描述
      ChronoLocalDate AbstractChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析 ChronoField值到日期。
      ChronoLocalDate Chronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField的日期。
      HijrahDate | HijrahChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      LocalDate IsoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField的日期。
      JapaneseDate | JapaneseChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      MinguoDate | MinguoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      ThaiBuddhistDate | ThaiBuddhistChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

    • Uses of Map in java.time.format

      Methods in java.time.format with parameters of type Map
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendText​(TemporalField field, Map<Long,String> textLookup)
      使用指定的地图将日期时间字段的文本附加到格式化程序以提供文本。

    • Uses of Map in java.time.temporal

      Methods in java.time.temporal with parameters of type Map
      Modifier and Type 方法 描述
      default TemporalAccessor TemporalField.resolve​(Map<TemporalField,Long> fieldValues, TemporalAccessor partialTemporal, ResolverStyle resolverStyle)
      解决此字段以提供更简单的替代或日期。

    • Uses of Map in java.util

      Subinterfaces of Map in java.util
      Modifier and Type 接口 描述
      interface  NavigableMap<K,V>
      A SortedMap通过导航方法扩展，为给定的搜索目标返回最接近的匹配项。
      interface  SortedMap<K,V>
      A Map进一步提供其键上的总排序 。
      Classes in java.util that implement Map
      Modifier and Type Class 描述
      class  AbstractMap<K,V>
      此类提供了 Map接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
      class  EnumMap<K extends Enum<K>,V>
      专门用于枚举类型键的Map实现。
      class  HashMap<K,V>
      基于哈希表的实现的 Map接口。
      class  Hashtable<K,V>
      该类实现了一个哈希表，它将键映射到值。
      class  IdentityHashMap<K,V>
      该类使用哈希表实现 Map接口，比较键（和值）时，使用引用相等代替对象相等。
      class  LinkedHashMap<K,V>
      哈希表和链表实现的 Map接口，具有可预测的迭代次序。
      class  Properties
      Properties类表示一组持久的属性。
      class  TreeMap<K,V>
      一个基于红黑树的NavigableMap实现。
      class  WeakHashMap<K,V>
      基于哈希表的实现的 Map接口，具有 弱键 。
      Fields in java.util declared as Map
      Modifier and Type Field 描述
      static Map Collections.EMPTY_MAP
      空地图（immutable）。
      Methods in java.util that return Map
      Modifier and Type 方法 描述
      static <K,V> Map<K,V> Collections.checkedMap​(Map<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定地图的动态类型安全视图。
      static <K,V> Map<K,V> Collections.emptyMap​()
      返回空的地图（不可变）。
      Map<String,Integer> Calendar.getDisplayNames​(int field, int style, Locale locale)
      返回一个 Map其中包含给定的 style和 locale中的日历 field所有名称及其对应的字段值。
      static <K,V> Map<K,V> Map.of​()
      返回一个包含零映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1)
      返回包含单个映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1, K k2, V v2)
      返回包含两个映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1, K k2, V v2, K k3, V v3)
      返回包含三个映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4)
      返回包含四个映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5)
      返回一个包含五个映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6)
      返回包含六个映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6, K k7, V v7)
      返回包含七个映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6, K k7, V v7, K k8, V v8)
      返回包含八个映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6, K k7, V v7, K k8, V v8, K k9, V v9)
      返回包含九个映射的不可变地图。
      static <K,V> Map<K,V> Map.of​(K k1, V v1, K k2, V v2, K k3, V v3, K k4, V v4, K k5, V v5, K k6, V v6, K k7, V v7, K k8, V v8, K k9, V v9, K k10, V v10)
      返回包含十个映射的不可变地图。
      static <K,V> Map<K,V> Map.ofEntries​(Map.Entry<? extends K,? extends V>... entries)
      返回包含从给定条目提取的键和值的不可变地图。
      static <K,V> Map<K,V> Collections.singletonMap​(K key, V value)
      返回一个不可变的地图，只将指定的键映射到指定的值。
      static <K,V> Map<K,V> Collections.synchronizedMap​(Map<K,V> m)
      返回由指定地图支持的同步（线程安全）映射。
      static <K,V> Map<K,V> Collections.unmodifiableMap​(Map<? extends K,? extends V> m)
      返回指定地图的不可修改视图。
      Methods in java.util with parameters of type Map
      Modifier and Type | 方法 | 描述
      static <K,V> Map<K,V> Collections.checkedMap​(Map<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定地图的动态类型安全视图。
      static List<Locale.LanguageRange> Locale.LanguageRange.mapEquivalents​(List<Locale.LanguageRange> priorityList, Map<String,List<String>> map)
      使用给定的 priorityList和 map生成新的自定义语言优先级列表。
      static <E> Set<E> Collections.newSetFromMap​(Map<E,Boolean> map)
      返回由指定地图支持的集合。
      static List<Locale.LanguageRange> Locale.LanguageRange.parse​(String ranges, Map<String,List<String>> map)
      解析给定的 ranges以生成语言优先级列表，然后使用给定的 map自定义列表。
      void AbstractMap.putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此映射（可选操作）。
      void EnumMap.putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此地图。
      void HashMap.putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此地图。
      void Hashtable.putAll​(Map<? extends K,? extends V> t)
      将所有从指定地图的映射复制到此散列表。
      void IdentityHashMap.putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此地图。
      void Map.putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此映射（可选操作）。
      void | Properties.putAll​(Map<?,?> t)
      void TreeMap.putAll​(Map<? extends K,? extends V> map)
      将指定地图的所有映射复制到此地图。
      void WeakHashMap.putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此地图。
      static <K,V> Map<K,V> Collections.synchronizedMap​(Map<K,V> m)
      返回由指定地图支持的同步（线程安全）映射。
      static <K,V> Map<K,V> Collections.unmodifiableMap​(Map<? extends K,? extends V> m)
      返回指定地图的不可修改视图。
      Constructors in java.util with parameters of type Map
      Constructor 描述
      EnumMap​(Map<K,? extends V> m)
      创建从指定地图初始化的枚举映射。
      HashMap​(Map<? extends K,? extends V> m)
      构造新的 HashMap具有与指定的 Map相同的映射。
      Hashtable​(Map<? extends K,? extends V> t)
      构造一个与给定地图相同的映射的新哈希表。
      IdentityHashMap​(Map<? extends K,? extends V> m)
      构造一个新的标识哈希映射，其中包含指定地图中的键值映射。
      LinkedHashMap​(Map<? extends K,? extends V> m)
      构造具有与指定地图相同映射的插入式 LinkedHashMap实例。
      TreeMap​(Map<? extends K,? extends V> m)
      构造一个新的树状图，其中包含与给定地图相同的映射，根据其键的 自然顺序进行排序 。
      WeakHashMap​(Map<? extends K,? extends V> m)
      构造新的 WeakHashMap与指定的地图相同的映射。

    • Uses of Map in java.util.concurrent

      Subinterfaces of Map in java.util.concurrent
      Modifier and Type 接口 描述
      interface  ConcurrentMap<K,V>
      A Map提供线程安全和原子性保证。
      interface  ConcurrentNavigableMap<K,V>
      A ConcurrentMap支持NavigableMap操作，并且递归地为其可导航的子地图。
      Classes in java.util.concurrent that implement Map
      Modifier and Type Class 描述
      class  ConcurrentHashMap<K,V>
      支持检索的完全并发性和更新的高预期并发性的哈希表。
      class  ConcurrentSkipListMap<K,V>
      可扩展并发ConcurrentNavigableMap实现。
      Methods in java.util.concurrent with parameters of type Map
      Modifier and Type 方法 描述
      void ConcurrentHashMap.putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此映射。
      Constructors in java.util.concurrent with parameters of type Map
      Constructor 描述
      ConcurrentHashMap​(Map<? extends K,? extends V> m)
      创建与给定地图相同的映射的新地图。
      ConcurrentSkipListMap​(Map<? extends K,? extends V> m)
      构造一个包含与给定地图相同的映射的新地图，按照密钥的natural ordering进行排序。

    • Uses of Map in java.util.jar

      Classes in java.util.jar that implement Map
      Modifier and Type Class 描述
      class  Attributes
      属性类将Manifest属性名称映射到关联的字符串值。
      Fields in java.util.jar declared as Map
      Modifier and Type Field 描述
      protected Map<Object,Object> Attributes.map
      属性名称 - 值映射。
      Methods in java.util.jar that return Map
      Modifier and Type 方法 描述
      Map<String,Attributes> Manifest.getEntries​()
      返回此清单中包含的条目的地图。
      Methods in java.util.jar with parameters of type Map
      Modifier and Type 方法 描述
      void Attributes.putAll​(Map<?,?> attr)
      将所有属性名称 - 值映射从指定的属性复制到此映射。

    • Uses of Map in java.util.spi

      Methods in java.util.spi that return Map
      Modifier and Type 方法 描述
      abstract Map<String,Integer> CalendarNameProvider.getDisplayNames​(String calendarType, int field, int style, Locale locale)
      返回 Map包含的所有字符串表示（显示名称） Calendar field给定 style和 locale及其相应的字段值。

    • Uses of Map in java.util.stream

      Methods in java.util.stream with type parameters of type Map
      Modifier and Type 方法 描述
      static <T,K,D,A,M extends Map<K,D>>
      Collector<T,?,M>             		Collectors.groupingBy​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定与给定键相关联的值进行还原操作 Collector 。
      static <T,K,U,M extends Map<K,U>>
      Collector<T,?,M>             		Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      Methods in java.util.stream that return types with arguments of type Map
      Modifier and Type 方法 描述
      static <T,K> Collector<T,?,Map<K,List<T>>> Collectors.groupingBy​(Function<? super T,? extends K> classifier)
      返回一个 Collector对 T类型的输入元素执行“group by”操作，根据分类功能对元素进行分组，并将结果返回到 Map 。
      static <T,K,A,D> Collector<T,?,Map<K,D>> Collectors.groupingBy​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定与给定键相关联的值进行还原操作 Collector 。
      static <T> Collector<T,?,Map<Boolean,List<T>>> Collectors.partitioningBy​(Predicate<? super T> predicate)
      返回 Collector由划分根据所述输入元件 Predicate ，并且将它们组织到一个 Map<Boolean, List<T>> 。
      static <T,D,A> Collector<T,?,Map<Boolean,D>> Collectors.partitioningBy​(Predicate<? super T> predicate, Collector<? super T,A,D> downstream)
      返回 Collector由划分根据所述输入元件 Predicate ，减少了在根据另一每个分区中的值 Collector ，并且将它们组织到一个 Map<Boolean, D>其值是下游减少的结果。
      static <T,K,U> Collector<T,?,Map<K,U>> Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,Map<K,U>> Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个 Collector ，它将元素累加到 Map其键和值是将所提供的映射函数应用于输入元素的结果。

    • Uses of Map in javafx.application

      Methods in javafx.application that return Map
      Modifier and Type 方法 描述
      abstract Map<String,String> Application.Parameters.getNamed​()
      检索命名参数的只读映射。

    • Uses of Map in javafx.beans.binding

      Classes in javafx.beans.binding that implement Map
      Modifier and Type Class 描述
      class  MapBinding<K,V>
      基类，提供大多数的实现所需的功能Binding的的ObservableMap 。
      class  MapExpression<K,V>
      MapExpression是一个ObservableMapValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding with parameters of type Map
      Modifier and Type | 方法 | 描述
      static <K,V> void Bindings.bindContent​(Map<K,V> map1, ObservableMap<? extends K,? extends V> map2)
      生成ObservableMap和Map之间的内容绑定。
      void | MapExpression.putAll​(Map<? extends K,? extends V> elements)

    • Uses of Map in javafx.beans.property

      Classes in javafx.beans.property that implement Map
      Modifier and Type Class 描述
      class  MapProperty<K,V>
      该类提供了一个Property包装ObservableMap的完整实现。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装ObservableMap的属性的基类。
      class  ReadOnlyMapProperty<K,V>
      超类为所有只读属性包装一个ObservableMap 。
      class  ReadOnlyMapPropertyBase<K,V>
      所有只读属性的基类包装一个ObservableMap 。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleMapProperty<K,V>
      该类提供了一个Property包装ObservableMap的完整实现。

    • Uses of Map in javafx.beans.value

      Subinterfaces of Map in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableMapValue<K,V>
      一个可观察的参考ObservableMap 。
      interface  WritableMapValue<K,V>
      可写参考ObservableMap 。

    • Uses of Map in javafx.collections

      Subinterfaces of Map in javafx.collections
      Modifier and Type 接口 描述
      interface  ObservableMap<K,V>
      一个允许观察者跟踪发生变化的地图。
      Methods in javafx.collections with parameters of type Map
      Modifier and Type 方法 描述
      static <K,V> ObservableMap<K,V> FXCollections.observableMap​(Map<K,V> map)
      构造由指定地图支持的ObservableMap。

    • Uses of Map in javafx.css

      Methods in javafx.css with parameters of type Map
      Modifier and Type 方法 描述
      T StyleConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)
      从成分值转换为目标属性类型。

    • Uses of Map in javafx.css.converter

      Methods in javafx.css.converter with parameters of type Map
      Modifier and Type | 方法 | 描述
      Font | FontConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)

    • Uses of Map in javafx.scene.control.cell

      Method parameters in javafx.scene.control.cell with type arguments of type Map
      Modifier and Type | 方法 | 描述
      ObservableValue<T> | MapValueFactory.call​(TableColumn.CellDataFeatures<Map,T> cdf)

    • Uses of Map in javafx.scene.input

      Classes in javafx.scene.input that implement Map
      Modifier and Type Class 描述
      class  ClipboardContent
      数据容器Clipboard数据。
      Methods in javafx.scene.input with parameters of type Map
      Modifier and Type 方法 描述
      boolean Clipboard.setContent​(Map<DataFormat,Object> content)
      将内容放在剪贴板上。

    • Uses of Map in javafx.scene.media

      Methods in javafx.scene.media that return Map
      Modifier and Type | 方法 | 描述
      Map<String,Object> | Track.getMetadata​()

    • Uses of Map in javax.annotation.processing

      Methods in javax.annotation.processing that return Map
      Modifier and Type 方法 描述
      Map<String,String> ProcessingEnvironment.getOptions​()
      返回传递给注解处理工具的处理器特定选项。

    • Uses of Map in javax.lang.model.element

      Methods in javax.lang.model.element that return Map
      Modifier and Type 方法 描述
      Map<? extends ExecutableElement,? extends AnnotationValue> AnnotationMirror.getElementValues​()
      返回此注释元素的值。

    • Uses of Map in javax.lang.model.util

      Methods in javax.lang.model.util that return Map
      Modifier and Type 方法 描述
      Map<? extends ExecutableElement,? extends AnnotationValue> Elements.getElementValuesWithDefaults​(AnnotationMirror a)
      返回注释元素的值，包括默认值。

    • Uses of Map in javax.management

      Constructors in javax.management with parameters of type Map
      Constructor 描述
      ImmutableDescriptor​(Map<String,?> fields)
      构造描述符，其中字段的名称和值是给定Map的键和值。

    • Uses of Map in javax.management.loading

      Methods in javax.management.loading that return Map
      Modifier and Type 方法 描述
      Map<String,String> MLetContent.getAttributes​()
      获取 MLET标签的属性。
      Constructors in javax.management.loading with parameters of type Map
      Constructor 描述
      MLetContent​(URL url, Map<String,String> attributes, List<String> types, List<String> values)
      创建一个 MLet实例，使用从MLet文本文件中的 MLET标记读取的属性初始化。

    • Uses of Map in javax.management.openmbean

      Classes in javax.management.openmbean that implement Map
      Modifier and Type Class 描述
      class  TabularDataSupport
      TabularDataSupport类是 开放数据类，它实现 TabularData和 Map接口，内部是基于散列映射数据结构的。
      Methods in javax.management.openmbean with parameters of type Map
      Modifier and Type 方法 描述
      void TabularDataSupport.putAll​(Map<?,?> t)
      将指定映射 t中包含的所有值添加到此 TabularData实例。
      Constructors in javax.management.openmbean with parameters of type Map
      Constructor 描述
      CompositeDataSupport​(CompositeType compositeType, Map<String,?> items)
      构造具有指定的 compositeType的 CompositeDataSupport实例，其中项目名称和对应的值由映射 items中的映射 items 。

    • Uses of Map in javax.management.relation

      Methods in javax.management.relation that return Map
      Modifier and Type 方法 描述
      Map<ObjectName,List<String>> RelationService.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索与某个关系中的给定关联的MBean。
      Map<ObjectName,List<String>> RelationServiceMBean.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索与某个关系中的给定关联的MBean。
      Map<String,List<String>> RelationService.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索给定MBean引用的关系。
      Map<String,List<String>> RelationServiceMBean.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索给定MBean引用的关系。
      Map<ObjectName,List<String>> Relation.getReferencedMBeans​()
      检索在关系的各种角色中引用的MBean。
      Map<ObjectName,List<String>> RelationService.getReferencedMBeans​(String relationId)
      检索在关系的各种角色中引用的MBean。
      Map<ObjectName,List<String>> RelationServiceMBean.getReferencedMBeans​(String relationId)
      检索在关系的各种角色中引用的MBean。
      Map<ObjectName,List<String>> RelationSupport.getReferencedMBeans​()
      检索在关系的各种角色中引用的MBean。

    • Uses of Map in javax.management.remote

      Methods in javax.management.remote that return Map
      Modifier and Type 方法 描述
      Map<String,?> JMXConnectorServerMBean.getAttributes​()
      此连接器服务器的属性。
      Methods in javax.management.remote with parameters of type Map
      Modifier and Type 方法 描述
      void JMXConnector.connect​(Map<String,?> env)
      建立与连接器服务器的连接。
      static JMXConnector JMXConnectorFactory.connect​(JMXServiceURL serviceURL, Map<String,?> environment)
      创建与给定地址的连接器服务器的连接。
      static JMXConnector JMXConnectorFactory.newJMXConnector​(JMXServiceURL serviceURL, Map<String,?> environment)
      在给定的地址创建连接器服务器的连接器客户端。
      JMXConnector JMXConnectorProvider.newJMXConnector​(JMXServiceURL serviceURL, Map<String,?> environment)
      创建一个新的连接器客户端，可以在给定的地址连接到连接器服务器。
      static JMXConnectorServer JMXConnectorServerFactory.newJMXConnectorServer​(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      在给定的地址创建一个连接器服务器。
      JMXConnectorServer JMXConnectorServerProvider.newJMXConnectorServer​(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      在给定的地址创建一个新的连接器服务器。
      JMXConnector JMXConnectorServer.toJMXConnector​(Map<String,?> env)
      返回此连接器服务器的客户端存根。
      JMXConnector JMXConnectorServerMBean.toJMXConnector​(Map<String,?> env)
      返回此连接器服务器的客户端存根。

    • Uses of Map in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return Map
      Modifier and Type | 方法 | 描述
      Map<String,?> | RMIConnectorServer.getAttributes​()
      Methods in javax.management.remote.rmi with parameters of type Map
      Modifier and Type | 方法 | 描述
      void | RMIConnector.connect​(Map<String,?> environment)
      JMXConnector RMIConnectorServer.toJMXConnector​(Map<String,?> env)
      返回此连接器服务器的客户端存根。
      Constructors in javax.management.remote.rmi with parameters of type Map
      Constructor 描述
      RMIConnectionImpl​(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
      构造新的RMIConnection 。
      RMIConnector​(JMXServiceURL url, Map<String,?> environment)
      构造一个将连接RMI连接器服务器与给定地址的 RMIConnector 。
      RMIConnector​(RMIServer rmiServer, Map<String,?> environment)
      使用给定的RMI存根构造一个 RMIConnector 。
      RMIConnectorServer​(JMXServiceURL url, Map<String,?> environment)
      做一个 RMIConnectorServer 。
      RMIConnectorServer​(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
      为给定的MBean服务器创建一个 RMIConnectorServer 。
      RMIConnectorServer​(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
      为给定的MBean服务器创建一个 RMIConnectorServer 。
      RMIIIOPServerImpl​(Map<String,?> env)
      已过时。
      抛出UnsupportedOperationException
      RMIJRMPServerImpl​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
      创建一个新的RMIServer对象，该对象将使用给定的套接字工厂在给定端口上导出。
      RMIServerImpl​(Map<String,?> env)
      构造新的 RMIServerImpl 。

    • Uses of Map in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement Map
      Modifier and Type Class 描述
      class  PrinterStateReasons
      PrinterStateReasons类是打印属性类，一组枚举值，它提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。
      Constructors in javax.print.attribute.standard with parameters of type Map
      Constructor 描述
      PrinterStateReasons​(Map<PrinterStateReason,Severity> map)
      构造一个新的打印机状态原因属性，其中包含与给定地图相同的PrinterStateReason- to-Severity映射。

    • Uses of Map in javax.script

      Subinterfaces of Map in javax.script
      Modifier and Type 接口 描述
      interface  Bindings
      键/值对的映射，所有键的键均为 Strings 。
      Classes in javax.script that implement Map
      Modifier and Type Class 描述
      class  SimpleBindings
      一个由 HashMap或其他一些指定的 Map支持的绑定的简单实现。
      Methods in javax.script with parameters of type Map
      Modifier and Type 方法 描述
      void Bindings.putAll​(Map<? extends String,? extends Object> toMerge)
      将给定的 Map中的所有映射添加到此 Bindings 。
      void SimpleBindings.putAll​(Map<? extends String,? extends Object> toMerge)
      putAll使用 Map.putAll实现。
      Constructors in javax.script with parameters of type Map
      Constructor 描述
      SimpleBindings​(Map<String,Object> m)
      构造函数使用现有的 Map来存储值。

    • Uses of Map in javax.security.auth.login

      Methods in javax.security.auth.login that return Map
      Modifier and Type 方法 描述
      Map<String,?> AppConfigurationEntry.getOptions​()
      获取为此 LoginModule配置的选项。
      Constructors in javax.security.auth.login with parameters of type Map
      Constructor 描述
      AppConfigurationEntry​(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
      此类的默认构造函数。

    • Uses of Map in javax.security.auth.spi

      Methods in javax.security.auth.spi with parameters of type Map
      Modifier and Type 方法 描述
      void LoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化此LoginModule。

    • Uses of Map in javax.security.auth.x500

      Methods in javax.security.auth.x500 with parameters of type Map
      Modifier and Type 方法 描述
      String X500Principal.getName​(String format, Map<String,String> oidMap)
      使用指定的格式返回X.500可分辨名称的字符串表示形式。
      Constructors in javax.security.auth.x500 with parameters of type Map
      Constructor 描述
      X500Principal​(String name, Map<String,String> keywordMap)
      从X.500专有名称的字符串表示形式（例如：“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”）创建 X500Principal 。

    • Uses of Map in javax.security.sasl

      Methods in javax.security.sasl with parameters of type Map
      Modifier and Type 方法 描述
      static SaslClient Sasl.createSaslClient​(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      使用提供的参数创建一个 SaslClient 。
      SaslClient SaslClientFactory.createSaslClient​(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      使用提供的参数创建SaslClient。
      static SaslServer Sasl.createSaslServer​(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      为指定的机制创建一个 SaslServer 。
      SaslServer SaslServerFactory.createSaslServer​(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      使用提供的参数创建一个 SaslServer 。
      String[] SaslClientFactory.getMechanismNames​(Map<String,?> props)
      返回与指定的机制选择策略匹配的机制名称数组。
      String[] SaslServerFactory.getMechanismNames​(Map<String,?> props)
      返回与指定的机制选择策略匹配的机制名称数组。

    • Uses of Map in javax.sound.midi

      Methods in javax.sound.midi that return Map
      Modifier and Type 方法 描述
      Map<String,Object> MidiFileFormat.properties​()
      获取不可修改的属性地图。
      Constructors in javax.sound.midi with parameters of type Map
      Constructor 描述
      MidiFileFormat​(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)
      构造一个 MidiFileFormat与一组属性。

    • Uses of Map in javax.sound.sampled

      Methods in javax.sound.sampled that return Map
      Modifier and Type 方法 描述
      Map<String,Object> AudioFileFormat.properties​()
      获取不可修改的属性地图。
      Map<String,Object> AudioFormat.properties​()
      获取不可修改的属性地图。
      Constructors in javax.sound.sampled with parameters of type Map
      Constructor 描述
      AudioFileFormat​(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
      使用一组定义的属性构建音频文件格式对象。
      AudioFormat​(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
      构造具有给定参数的 AudioFormat 。

    • Uses of Map in javax.sql

      Methods in javax.sql that return Map
      Modifier and Type 方法 描述
      Map<String,Class<?>> RowSet.getTypeMap​()
      检索与此 Map对象关联的 RowSet对象，该对象指定SQL用户定义类型的自定义映射（如果有）。
      Methods in javax.sql with parameters of type Map
      Modifier and Type 方法 描述
      void RowSet.setTypeMap​(Map<String,Class<?>> map)
      安装给定 java.util.Map对象的默认类型映射此 RowSet对象。

    • Uses of Map in javax.sql.rowset

      Methods in javax.sql.rowset that return Map
      Modifier and Type 方法 描述
      Map<String,Class<?>> BaseRowSet.getTypeMap​()
      检索与该关联的类型映射 Connection对象此 RowSet对象。
      Methods in javax.sql.rowset with parameters of type Map
      Modifier and Type 方法 描述
      void BaseRowSet.setTypeMap​(Map<String,Class<?>> map)
      安装给定 java.util.Map对象作为与相关联的类型映射 Connection对象此 RowSet对象。

    • Uses of Map in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial with parameters of type Map
      Modifier and Type 方法 描述
      Object SerialArray.getArray​(long index, int count, Map<String,Class<?>> map)
      返回一个新数组，它是该 SerialArray对象的一个片段的副本，从给定索引处的元素开始，并包含给定数量的连续元素。
      Object SerialArray.getArray​(Map<String,Class<?>> map)
      返回一个新数组，该数组是该 SerialArray对象的副本，当元素为SQL UDT时，使用给定的类型映射表示每个元素的自定义映射。
      Object[] SerialStruct.getAttributes​(Map<String,Class<?>> map)
      检索 SerialStruct表示为 Object值的数组的SQL结构类型的属性，如果合适，则使用给定的类型映射进行自定义映射。
      Object SerialRef.getObject​(Map<String,Class<?>> map)
      返回 Object表示对此的SQL结构类型 SerialRef对象引用。
      ResultSet SerialArray.getResultSet​(long index, int count, Map<String,Class<?>> map)
      检索设置保持其开始于检索所述子阵列的元素的结果 ResultSet对象，其中包含在该元件的子阵列 SerialArray对象，开始于索引 指数和包含 count个连续元素。
      ResultSet SerialArray.getResultSet​(Map<String,Class<?>> map)
      检索包含 ResultSet对象所表示的SQL ARRAY值的所有元素的 SerialArray对象。
      Constructors in javax.sql.rowset.serial with parameters of type Map
      Constructor 描述
      SerialArray​(Array array, Map<String,Class<?>> map)
      从给定的 Array对象构造一个新的 SerialArray对象，当元素为SQL UDT时，使用给定的类型映射来定位每个元素的映射。
      SerialStruct​(SQLData in, Map<String,Class<?>> map)
      从给定的 SQLData对象构造一个 SerialStruct对象，使用给定的类型映射将其自定义映射到Java编程语言中的类。
      SerialStruct​(Struct in, Map<String,Class<?>> map)
      从给定的 Struct对象构造一个 SerialStruct对象，使用给定的 java.util.Map对象来自定义映射SQL结构化类型或其任何属性是SQL结构化类型。
      SQLInputImpl​(Object[] attributes, Map<String,Class<?>> map)
      创建一个 SQLInputImpl对象，该对象使用给定的属性数组和给定的类型映射进行初始化。
      SQLOutputImpl​(Vector<?> attributes, Map<String,?> map)
      创建一个新的 SQLOutputImpl对象，用给定的属性向量初始化并输入map。

    • Uses of Map in javax.swing

      Classes in javax.swing that implement Map
      Modifier and Type Class 描述
      class  UIDefaults
      Swing组件的默认表。

    • Uses of Map in javax.xml.bind

      Methods in javax.xml.bind with parameters of type Map
      Modifier and Type 方法 描述
      JAXBContext JAXBContextFactory.createContext​(Class<?>[] classesToBeBound, Map<String,?> properties)
      创建一个 JAXBContext类的新实例。
      JAXBContext JAXBContextFactory.createContext​(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      创建一个新的 JAXBContext类的实例。
      static JAXBContext JAXBContext.newInstance​(Class<?>[] classesToBeBound, Map<String,?> properties)
      创建一个新的 JAXBContext类的实例。
      static JAXBContext JAXBContext.newInstance​(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      创建一个新的 JAXBContext类的实例。

    • Uses of Map in javax.xml.crypto.dsig.spec

      Methods in javax.xml.crypto.dsig.spec that return Map
      Modifier and Type 方法 描述
      Map<String,String> XPathFilterParameterSpec.getNamespaceMap​()
      返回名称空间前缀的映射。
      Map<String,String> XPathType.getNamespaceMap​()
      返回名称空间前缀的映射。
      Constructors in javax.xml.crypto.dsig.spec with parameters of type Map
      Constructor 描述
      XPathFilterParameterSpec​(String xPath, Map<String,String> namespaceMap)
      使用指定的XPath表达式和命名空间映射创建一个 XPathFilterParameterSpec 。
      XPathType​(String expression, XPathType.Filter filter, Map<String,String> namespaceMap)
      使用指定的XPath表达式，过滤器和命名空间映射创建一个 XPathType实例。

    • Uses of Map in javax.xml.ws

      Methods in javax.xml.ws that return Map
      Modifier and Type 方法 描述
      Map<String,Object> Response.getContext​()
      获取包含的响应上下文。
      abstract Map<String,Object> Endpoint.getProperties​()
      返回此 Endpoint实例的属性包。
      Map<String,Object> BindingProvider.getRequestContext​()
      获取用于初始化请求消息的消息上下文的上下文。
      Map<String,Object> BindingProvider.getResponseContext​()
      获取处理响应消息产生的上下文。
      Methods in javax.xml.ws with parameters of type Map
      Modifier and Type 方法 描述
      abstract void Endpoint.setProperties​(Map<String,Object> properties)
      设置此 Endpoint实例的属性包。

    • Uses of Map in javax.xml.ws.handler

      Subinterfaces of Map in javax.xml.ws.handler
      Modifier and Type 接口 描述
      interface  LogicalMessageContext
      LogicalMessageContext接口扩展了 MessageContext以提供对包含的消息的访问作为协议中性逻辑消息
      interface  MessageContext
      接口 MessageContext对 handle方法中的处理程序处理的消息上下文进行抽象。

    • Uses of Map in javax.xml.ws.handler.soap

      Subinterfaces of Map in javax.xml.ws.handler.soap
      Modifier and Type 接口 描述
      interface  SOAPMessageContext
      接口 SOAPMessageContext提供对RPC请求或响应的SOAP消息的访问。

    • Uses of Map in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Map
      Modifier and Type 方法 描述
      W3CEndpointReference Provider.createW3CEndpointReference​(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      工厂方法创建一个 W3CEndpointReference 。

    • Uses of Map in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return Map
      Modifier and Type 方法 描述
      abstract Map<String,List<String>> HttpExchange.getRequestHeaders​()
      返回包含此请求中包含的HTTP标头的不可变地图。
      abstract Map<String,List<String>> HttpExchange.getResponseHeaders​()
      返回一个可变地图，可以存储HTTP响应标头，哪个将作为此响应的一部分进行传输。

    • Uses of Map in jdk.incubator.http

      Classes in jdk.incubator.http that implement Map
      Modifier and Type Class 描述
      class  MultiMapResult<V>
      A Map包含HTTP / 2请求和多响应的结果。
      Methods in jdk.incubator.http that return Map
      Modifier and Type 方法 描述
      Map<String,List<String>> HttpHeaders.map​()
      返回此HttpHeaders的不可修改的多Map视图。
      Methods in jdk.incubator.http with parameters of type Map
      Modifier and Type | 方法 | 描述
      void | MultiMapResult.putAll​(Map<? extends HttpRequest,? extends CompletableFuture<HttpResponse<V>>> m)

    • Uses of Map in jdk.jshell

      Methods in jdk.jshell with parameters of type Map
      Modifier and Type 方法 描述
      JShell.Builder JShell.Builder.executionEngine​(ExecutionControlProvider executionControlProvider, Map<String,String> executionControlParameters)
      设置要执行的自定义引擎。

    • Uses of Map in jdk.jshell.execution

      Methods in jdk.jshell.execution that return Map
      Modifier and Type 方法 描述
      Map<String,String> FailOverExecutionControlProvider.defaultParameters​()
      创建并返回此 ExecutionControlProvider的默认参数图。
      Map<String,String> JdiExecutionControlProvider.defaultParameters​()
      创建并返回此 ExecutionControlProvider的默认参数图。
      Map<String,String> LocalExecutionControlProvider.defaultParameters​()
      创建并返回默认参数图 LocalExecutionControlProvider 。
      Methods in jdk.jshell.execution with parameters of type Map
      Modifier and Type | 方法 | 描述
      static void Util.forwardExecutionControlAndIO​(ExecutionControl ec, InputStream inStream, OutputStream outStream, Map<String,Consumer<OutputStream>> outputStreamMap, Map<String,Consumer<InputStream>> inputStreamMap)
      将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
      ExecutionControl FailOverExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)
      创建并返回一个本地执行的 ExecutionControl实例。
      ExecutionControl | JdiExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)
      ExecutionControl LocalExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)
      创建并返回本地执行的 ExecutionControl实例。
      static ExecutionControl Util.remoteInputOutput​(InputStream input, OutputStream output, Map<String,OutputStream> outputStreamMap, Map<String,InputStream> inputStreamMap, BiFunction<ObjectInput,ObjectOutput,ExecutionControl> factory)
      为给定的分组化输入和输出创建一个ExecutionControl。
      Constructors in jdk.jshell.execution with parameters of type Map
      Constructor 描述
      JdiInitiator​(int port, List<String> remoteVMOptions, String remoteAgent, boolean isLaunch, String host, int timeout, Map<String,String> customConnectorArgs)
      启动远程代理并建立一个JDI连接。

    • Uses of Map in jdk.jshell.spi

      Methods in jdk.jshell.spi that return Map
      Modifier and Type 方法 描述
      default Map<String,String> ExecutionControlProvider.defaultParameters​()
      创建并返回此 ExecutionControlProvider的默认参数图。
      Methods in jdk.jshell.spi with parameters of type Map
      Modifier and Type 方法 描述
      static ExecutionControl ExecutionControl.generate​(ExecutionEnv env, String name, Map<String,String> parameters)
      搜索提供者，然后创建并返回 ExecutionControl实例。
      ExecutionControl ExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)
      创建并返回 ExecutionControl实例。

    • Uses of Map in jdk.jshell.tool

      Methods in jdk.jshell.tool with parameters of type Map
      Modifier and Type 方法 描述
      JavaShellToolBuilder JavaShellToolBuilder.env​(Map<String,String> vars)
      设置环境变量的源。
      JavaShellToolBuilder JavaShellToolBuilder.persistence​(Map<String,String> prefsMap)
      设置包含输入历史记录和保留设置的持久信息的存储机制。

    • Uses of Map in jdk.nashorn.api.scripting

      Classes in jdk.nashorn.api.scripting that implement Map
      Modifier and Type Class 描述
      class  ScriptObjectMirror
      包含给定Nashorn Script对象的镜像对象。
      Methods in jdk.nashorn.api.scripting with parameters of type Map
      Modifier and Type | 方法 | 描述
      void | ScriptObjectMirror.putAll​(Map<? extends String,? extends Object> map)

    • Uses of Map in jdk.packager.services

      Methods in jdk.packager.services that return Map
      Modifier and Type 方法 描述
      Map<String,String> UserJvmOptionsService.getUserJVMOptionDefaults​()
      UserJVMOptions的“默认”集合。
      Map<String,String> UserJvmOptionsService.getUserJVMOptions​()
      UserJVMOptions的“当前”集合。
      Methods in jdk.packager.services with parameters of type Map
      Modifier and Type 方法 描述
      void UserJvmOptionsService.setUserJVMOptions​(Map<String,String> options)
      Sets the passed in options as the UserJVMOptions.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Map.Entry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Map.Entry

  • Packages that use Map.Entry
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.xml.crypto.dom
    针对 javax.xml.crypto包的DOM特定类。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

    • Uses of Map.Entry in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return types with arguments of type Map.Entry
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<String,List<String>>> | Headers.entrySet​()

    • Uses of Map.Entry in java.awt

      Methods in java.awt that return types with arguments of type Map.Entry
      Modifier and Type 方法 描述
      Set<Map.Entry<Object,Object>> RenderingHints.entrySet​()
      返回 Set视图包含在此映射的 RenderingHints 。

    • Uses of Map.Entry in java.security

      Methods in java.security that return types with arguments of type Map.Entry
      Modifier and Type 方法 描述
      Set<Map.Entry<Object,Object>> Provider.entrySet​()
      返回此提供程序中包含的属性条目的不可修改的Set视图。

    • Uses of Map.Entry in java.util

      Classes in java.util that implement Map.Entry
      Modifier and Type Class 描述
      static class  AbstractMap.SimpleEntry<K,V>
      保存密钥和值的条目。
      static class  AbstractMap.SimpleImmutableEntry<K,V>
      保持一个不变的钥匙和价值的条目。
      Methods in java.util that return Map.Entry
      Modifier and Type | 方法 | 描述
      Map.Entry<K,V> NavigableMap.ceilingEntry​(K key)
      返回与大于或等于给定键的最小键相关联的键值映射，如果没有这样的键，则 null 。
      Map.Entry<K,V> | TreeMap.ceilingEntry​(K key)
      static <K,V> Map.Entry<K,V> Map.entry​(K k, V v)
      返回包含给定键和值的不可变的Map.Entry 。
      Map.Entry<K,V> NavigableMap.firstEntry​()
      返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> | TreeMap.firstEntry​()
      Map.Entry<K,V> NavigableMap.floorEntry​(K key)
      返回与小于或等于给定键的最大键相关联的键值映射，如果没有这样的键，则 null 。
      Map.Entry<K,V> | TreeMap.floorEntry​(K key)
      Map.Entry<K,V> NavigableMap.higherEntry​(K key)
      返回与最小密钥相关联的密钥值映射严格大于给定密钥，如果没有这样的密钥，则 null 。
      Map.Entry<K,V> | TreeMap.higherEntry​(K key)
      Map.Entry<K,V> NavigableMap.lastEntry​()
      返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> | TreeMap.lastEntry​()
      Map.Entry<K,V> NavigableMap.lowerEntry​(K key)
      返回与最大密钥相关联的密钥值映射严格小于给定密钥，如果没有这样的密钥，则 null 。
      Map.Entry<K,V> | TreeMap.lowerEntry​(K key)
      Map.Entry<K,V> NavigableMap.pollFirstEntry​()
      删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> | TreeMap.pollFirstEntry​()
      Map.Entry<K,V> NavigableMap.pollLastEntry​()
      删除并返回与该地图中最大关键字关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> | TreeMap.pollLastEntry​()
      Methods in java.util that return types with arguments of type Map.Entry
      Modifier and Type | 方法 | 描述
      static <K extends Comparable<? super K>,V>
      Comparator<Map.Entry<K,V>>             		Map.Entry.comparingByKey​()
      返回一个比较器， 按键自然顺序比较Map.Entry 。
      static <K,V> Comparator<Map.Entry<K,V>> Map.Entry.comparingByKey​(Comparator<? super K> cmp)
      返回一个比较器，比较Map.Entry按键使用给定的Comparator 。
      static <K,V extends Comparable<? super V>>
      Comparator<Map.Entry<K,V>>             		Map.Entry.comparingByValue​()
      返回一个比较值，比较Map.Entry的自然顺序值。
      static <K,V> Comparator<Map.Entry<K,V>> Map.Entry.comparingByValue​(Comparator<? super V> cmp)
      返回一个比较器，使用给定的Comparator将值与Map.Entry进行比较。
      abstract Set<Map.Entry<K,V>> | AbstractMap.entrySet​()
      Set<Map.Entry<K,V>> EnumMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> HashMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> Hashtable.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> IdentityHashMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> LinkedHashMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> Map.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<Object,Object>> | Properties.entrySet​()
      Set<Map.Entry<K,V>> SortedMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> TreeMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> WeakHashMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Methods in java.util with parameters of type Map.Entry
      Modifier and Type 方法 描述
      static <K,V> Map<K,V> Map.ofEntries​(Map.Entry<? extends K,? extends V>... entries)
      返回包含从给定条目提取的键和值的不可变地图。
      protected boolean LinkedHashMap.removeEldestEntry​(Map.Entry<K,V> eldest)
      如果此地图应删除其最老的条目，则返回 true 。
      Constructors in java.util with parameters of type Map.Entry
      Constructor 描述
      SimpleEntry​(Map.Entry<? extends K,? extends V> entry)
      创建表示与指定条目相同的映射的条目。
      SimpleImmutableEntry​(Map.Entry<? extends K,? extends V> entry)
      创建表示与指定条目相同的映射的条目。

    • Uses of Map.Entry in java.util.concurrent

      Methods in java.util.concurrent that return Map.Entry
      Modifier and Type 方法 描述
      Map.Entry<K,V> ConcurrentSkipListMap.ceilingEntry​(K key)
      返回与大于或等于给定键的最小键相关联的键值映射，如果没有 null则 null 。
      Map.Entry<K,V> ConcurrentSkipListMap.firstEntry​()
      返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> ConcurrentSkipListMap.floorEntry​(K key)
      返回与小于或等于给定键的最大键相关联的键值映射，如果没有这样的键，则 null 。
      Map.Entry<K,V> ConcurrentSkipListMap.higherEntry​(K key)
      返回与最小密钥相关联的密钥值映射严格大于给定密钥，如果不存在这样的密钥，则 null 。
      Map.Entry<K,V> ConcurrentSkipListMap.lastEntry​()
      返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> ConcurrentSkipListMap.lowerEntry​(K key)
      返回与最大密钥相关联的密钥值映射严格小于给定密钥，如果没有这样的密钥则 null 。
      Map.Entry<K,V> ConcurrentSkipListMap.pollFirstEntry​()
      删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> ConcurrentSkipListMap.pollLastEntry​()
      删除并返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> ConcurrentHashMap.reduceEntries​(long parallelismThreshold, BiFunction<Map.Entry<K,V>,Map.Entry<K,V>,? extends Map.Entry<K,V>> reducer)
      返回使用给定的reducer累加所有条目的结果，以组合值，如果没有则返回null。
      Methods in java.util.concurrent that return types with arguments of type Map.Entry
      Modifier and Type 方法 描述
      Set<Map.Entry<K,V>> ConcurrentHashMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> ConcurrentSkipListMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Method parameters in java.util.concurrent with type arguments of type Map.Entry
      Modifier and Type 方法 描述
      void ConcurrentHashMap.forEachEntry​(long parallelismThreshold, Consumer<? super Map.Entry<K,V>> action)
      对每个条目执行给定的操作。
      <U> void ConcurrentHashMap.forEachEntry​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> transformer, Consumer<? super U> action)
      对每个条目的每个非空变换执行给定的操作。
      Map.Entry<K,V> ConcurrentHashMap.reduceEntries​(long parallelismThreshold, BiFunction<Map.Entry<K,V>,Map.Entry<K,V>,? extends Map.Entry<K,V>> reducer)
      返回使用给定的reducer累加所有条目的结果，以组合值，如果没有则返回null。
      Map.Entry<K,V> ConcurrentHashMap.reduceEntries​(long parallelismThreshold, BiFunction<Map.Entry<K,V>,Map.Entry<K,V>,? extends Map.Entry<K,V>> reducer)
      返回使用给定的reducer累加所有条目的结果，以组合值，如果没有则返回null。
      Map.Entry<K,V> ConcurrentHashMap.reduceEntries​(long parallelismThreshold, BiFunction<Map.Entry<K,V>,Map.Entry<K,V>,? extends Map.Entry<K,V>> reducer)
      返回使用给定的reducer累加所有条目的结果，以组合值，如果没有则返回null。
      <U> U ConcurrentHashMap.reduceEntries​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer将所有条目的给定变换累加到组合值的结果，否则返回null。
      double ConcurrentHashMap.reduceEntriesToDouble​(long parallelismThreshold, ToDoubleFunction<Map.Entry<K,V>> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      int ConcurrentHashMap.reduceEntriesToInt​(long parallelismThreshold, ToIntFunction<Map.Entry<K,V>> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      long ConcurrentHashMap.reduceEntriesToLong​(long parallelismThreshold, ToLongFunction<Map.Entry<K,V>> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      <U> U ConcurrentHashMap.searchEntries​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> searchFunction)
      返回一个非空结果，从每个条目应用给定的搜索函数，如果没有，则返回null。

    • Uses of Map.Entry in java.util.jar

      Methods in java.util.jar that return types with arguments of type Map.Entry
      Modifier and Type 方法 描述
      Set<Map.Entry<Object,Object>> Attributes.entrySet​()
      返回此Map中包含的属性名称 - 值映射的集合视图。

    • Uses of Map.Entry in javafx.beans.binding

      Methods in javafx.beans.binding that return types with arguments of type Map.Entry
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<K,V>> | MapExpression.entrySet​()

    • Uses of Map.Entry in javax.management.openmbean

      Methods in javax.management.openmbean that return types with arguments of type Map.Entry
      Modifier and Type 方法 描述
      Set<Map.Entry<Object,Object>> TabularDataSupport.entrySet​()
      返回此 TabularDataSupport实例中包含的行映射索引的集合视图。

    • Uses of Map.Entry in javax.script

      Methods in javax.script that return types with arguments of type Map.Entry
      Modifier and Type 方法 描述
      Set<Map.Entry<String,Object>> SimpleBindings.entrySet​()
      返回此地图中包含的映射的Set视图。

    • Uses of Map.Entry in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return types with arguments of type Map.Entry
      Modifier and Type 方法 描述
      Iterator<Map.Entry<String,Element>> DOMCryptoContext.iterator​()
      Returns a read-only iterator over the set of Id/Element mappings of this DOMCryptoContext.

    • Uses of Map.Entry in jdk.incubator.http

      Methods in jdk.incubator.http that return types with arguments of type Map.Entry
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<HttpRequest,CompletableFuture<HttpResponse<V>>>> | MultiMapResult.entrySet​()

    • Uses of Map.Entry in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that return types with arguments of type Map.Entry
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<String,Object>> | ScriptObjectMirror.entrySet​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.NavigableMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.NavigableMap

  • Packages that use NavigableMap
    软件包 描述
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of NavigableMap in java.time.zone

      Methods in java.time.zone that return NavigableMap
      Modifier and Type 方法 描述
      static NavigableMap<String,ZoneRules> ZoneRulesProvider.getVersions​(String zoneId)
      获取区域ID的规则历史记录。
      protected abstract NavigableMap<String,ZoneRules> ZoneRulesProvider.provideVersions​(String zoneId)
      SPI方法获取区域ID的规则历史。

    • Uses of NavigableMap in java.util

      Classes in java.util that implement NavigableMap
      Modifier and Type Class 描述
      class  TreeMap<K,V>
      一个基于红黑树的NavigableMap实现。
      Methods in java.util that return NavigableMap
      Modifier and Type | 方法 | 描述
      static <K,V> NavigableMap<K,V> Collections.checkedNavigableMap​(NavigableMap<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定可导航地图的动态类型安全视图。
      NavigableMap<K,V> NavigableMap.descendingMap​()
      返回此映射中包含的映射的反向排序视图。
      NavigableMap<K,V> | TreeMap.descendingMap​()
      static <K,V> NavigableMap<K,V> Collections.emptyNavigableMap​()
      返回空导航地图（不可变）。
      NavigableMap<K,V> NavigableMap.headMap​(K toKey, boolean inclusive)
      返回该地图部分的视图，其键值小于（或等于，如果 inclusive为真） toKey 。
      NavigableMap<K,V> | TreeMap.headMap​(K toKey, boolean inclusive)
      NavigableMap<K,V> NavigableMap.subMap​(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
      返回该地图部分的视图，其关键字范围从 fromKey到 toKey 。
      NavigableMap<K,V> | TreeMap.subMap​(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
      static <K,V> NavigableMap<K,V> Collections.synchronizedNavigableMap​(NavigableMap<K,V> m)
      返回由指定的可导航地图支持的同步（线程安全）可导航地图。
      NavigableMap<K,V> NavigableMap.tailMap​(K fromKey, boolean inclusive)
      返回此地图部分的视图，其键大于（或等于，如果为 inclusive为真） fromKey 。
      NavigableMap<K,V> | TreeMap.tailMap​(K fromKey, boolean inclusive)
      static <K,V> NavigableMap<K,V> Collections.unmodifiableNavigableMap​(NavigableMap<K,? extends V> m)
      返回指定可导航地图的不可修改视图。
      Methods in java.util with parameters of type NavigableMap
      Modifier and Type 方法 描述
      static <K,V> NavigableMap<K,V> Collections.checkedNavigableMap​(NavigableMap<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定可导航地图的动态类型安全视图。
      static <K,V> NavigableMap<K,V> Collections.synchronizedNavigableMap​(NavigableMap<K,V> m)
      返回由指定的可导航地图支持的同步（线程安全）可导航地图。
      static <K,V> NavigableMap<K,V> Collections.unmodifiableNavigableMap​(NavigableMap<K,? extends V> m)
      返回指定可导航地图的不可修改视图。

    • Uses of NavigableMap in java.util.concurrent

      Subinterfaces of NavigableMap in java.util.concurrent
      Modifier and Type 接口 描述
      interface  ConcurrentNavigableMap<K,V>
      A ConcurrentMap支持NavigableMap操作，并递归地为其可导航的子地图。
      Classes in java.util.concurrent that implement NavigableMap
      Modifier and Type Class 描述
      class  ConcurrentSkipListMap<K,V>
      A scalable concurrent ConcurrentNavigableMap implementation.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.NavigableSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.NavigableSet

  • Packages that use NavigableSet
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of NavigableSet in java.util

      Classes in java.util that implement NavigableSet
      Modifier and Type Class 描述
      class  TreeSet<E>
      A NavigableSet实现基于TreeMap 。
      Methods in java.util that return NavigableSet
      Modifier and Type | 方法 | 描述
      static <E> NavigableSet<E> Collections.checkedNavigableSet​(NavigableSet<E> s, Class<E> type)
      返回指定的可导航集的动态类型安全视图。
      NavigableSet<K> NavigableMap.descendingKeySet​()
      返回此映射中包含的键的相反顺序NavigableSet 。
      NavigableSet<K> | TreeMap.descendingKeySet​()
      NavigableSet<E> NavigableSet.descendingSet​()
      返回此集合中包含的元素的反向排序视图。
      NavigableSet<E> | TreeSet.descendingSet​()
      static <E> NavigableSet<E> Collections.emptyNavigableSet​()
      返回一个空导航集（immutable）。
      NavigableSet<E> NavigableSet.headSet​(E toElement, boolean inclusive)
      返回此集合的部分的视图，其元素小于（或等于，如果 inclusive为真） toElement 。
      NavigableSet<E> | TreeSet.headSet​(E toElement, boolean inclusive)
      NavigableSet<K> NavigableMap.navigableKeySet​()
      返回此地图中包含的键的NavigableSet视图。
      NavigableSet<K> | TreeMap.navigableKeySet​()
      NavigableSet<E> NavigableSet.subSet​(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
      返回此集合的部分的视图，其元素的范围从 fromElement到 toElement 。
      NavigableSet<E> | TreeSet.subSet​(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
      static <T> NavigableSet<T> Collections.synchronizedNavigableSet​(NavigableSet<T> s)
      返回由指定的可导航集支持的同步（线程安全）可导航集。
      NavigableSet<E> NavigableSet.tailSet​(E fromElement, boolean inclusive)
      返回此集合的部分的视图，其元素大于（或等于，如果为 inclusive为真） fromElement 。
      NavigableSet<E> | TreeSet.tailSet​(E fromElement, boolean inclusive)
      static <T> NavigableSet<T> Collections.unmodifiableNavigableSet​(NavigableSet<T> s)
      返回指定的可导航集合的不可修改的视图。
      Methods in java.util with parameters of type NavigableSet
      Modifier and Type 方法 描述
      static <E> NavigableSet<E> Collections.checkedNavigableSet​(NavigableSet<E> s, Class<E> type)
      返回指定的可导航集的动态类型安全视图。
      static <T> NavigableSet<T> Collections.synchronizedNavigableSet​(NavigableSet<T> s)
      返回由指定的可导航集支持的同步（线程安全）可导航集。
      static <T> NavigableSet<T> Collections.unmodifiableNavigableSet​(NavigableSet<T> s)
      返回指定的可导航集合的不可修改的视图。

    • Uses of NavigableSet in java.util.concurrent

      Classes in java.util.concurrent that implement NavigableSet
      Modifier and Type Class 描述
      class  ConcurrentSkipListSet<E>
      可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
      Methods in java.util.concurrent that return NavigableSet
      Modifier and Type | 方法 | 描述
      NavigableSet<K> ConcurrentNavigableMap.descendingKeySet​()
      返回此映射中包含的键的相反顺序NavigableSet 。
      NavigableSet<K> | ConcurrentSkipListMap.descendingKeySet​()
      NavigableSet<E> ConcurrentSkipListSet.descendingSet​()
      返回此集合中包含的元素的反向排序视图。
      NavigableSet<E> | ConcurrentSkipListSet.headSet​(E toElement)
      NavigableSet<E> | ConcurrentSkipListSet.headSet​(E toElement, boolean inclusive)
      NavigableSet<K> ConcurrentNavigableMap.keySet​()
      返回此地图中包含的键的NavigableSet视图。
      NavigableSet<K> ConcurrentSkipListMap.keySet​()
      返回此地图中包含的键的NavigableSet视图。
      NavigableSet<K> ConcurrentNavigableMap.navigableKeySet​()
      返回此地图中包含的键的NavigableSet视图。
      NavigableSet<K> | ConcurrentSkipListMap.navigableKeySet​()
      NavigableSet<E> | ConcurrentSkipListSet.subSet​(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
      NavigableSet<E> | ConcurrentSkipListSet.subSet​(E fromElement, E toElement)
      NavigableSet<E> | ConcurrentSkipListSet.tailSet​(E fromElement)
      NavigableSet<E> | ConcurrentSkipListSet.tailSet​(E fromElement, boolean inclusive)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Observer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Observer

  • Packages that use Observer
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Observer in java.util

      Methods in java.util with parameters of type Observer
      Modifier and Type 方法 描述
      void Observable.addObserver​(Observer o)
      已过时。
      将一个观察者添加到该对象的观察者组中，前提是它与集合中已有的一些观察者不一样。
      void Observable.deleteObserver​(Observer o)
      已过时。
      从该对象的观察者组中删除观察者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.PrimitiveIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.PrimitiveIterator

  • Packages that use PrimitiveIterator
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of PrimitiveIterator in java.util

      Subinterfaces of PrimitiveIterator in java.util
      Modifier and Type 接口 描述
      static interface  PrimitiveIterator.OfDouble
      一个专门为 double值的迭代器。
      static interface  PrimitiveIterator.OfInt
      一个专门针对 int值的迭代器。
      static interface  PrimitiveIterator.OfLong
      一个专门为 long值的迭代器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.PrimitiveIterator.OfDouble (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.PrimitiveIterator.OfDouble

  • Packages that use PrimitiveIterator.OfDouble
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of PrimitiveIterator.OfDouble in java.util

      Methods in java.util that return PrimitiveIterator.OfDouble
      Modifier and Type 方法 描述
      static PrimitiveIterator.OfDouble Spliterators.iterator​(Spliterator.OfDouble spliterator)
      创建一个 PrimitiveIterator.OfDouble从 Spliterator.OfDouble 。
      Methods in java.util with parameters of type PrimitiveIterator.OfDouble
      Modifier and Type 方法 描述
      static Spliterator.OfDouble Spliterators.spliterator​(PrimitiveIterator.OfDouble iterator, long size, int characteristics)
      创建一个 Spliterator.OfDouble使用给定的 DoubleStream.DoubleIterator作为元素的来源，并给出最初报告的大小。
      static Spliterator.OfDouble Spliterators.spliteratorUnknownSize​(PrimitiveIterator.OfDouble iterator, int characteristics)
      创建 Spliterator.OfDouble使用给定的 DoubleStream.DoubleIterator作为元素的来源，没有初始大小估计。

    • Uses of PrimitiveIterator.OfDouble in java.util.stream

      Methods in java.util.stream that return PrimitiveIterator.OfDouble
      Modifier and Type | 方法 | 描述
      PrimitiveIterator.OfDouble | DoubleStream.iterator​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.PrimitiveIterator.OfInt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.PrimitiveIterator.OfInt

  • Packages that use PrimitiveIterator.OfInt
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of PrimitiveIterator.OfInt in java.util

      Methods in java.util that return PrimitiveIterator.OfInt
      Modifier and Type 方法 描述
      static PrimitiveIterator.OfInt Spliterators.iterator​(Spliterator.OfInt spliterator)
      创建一个 PrimitiveIterator.OfInt从 Spliterator.OfInt 。
      Methods in java.util with parameters of type PrimitiveIterator.OfInt
      Modifier and Type 方法 描述
      static Spliterator.OfInt Spliterators.spliterator​(PrimitiveIterator.OfInt iterator, long size, int characteristics)
      使用给定的 IntStream.IntIterator作为元素的来源创建一个 Spliterator.OfInt ，并使用给定的最初报告的大小。
      static Spliterator.OfInt Spliterators.spliteratorUnknownSize​(PrimitiveIterator.OfInt iterator, int characteristics)
      使用给定的 IntStream.IntIterator作为元素的来源创建一个 Spliterator.OfInt ，没有初始大小估计。

    • Uses of PrimitiveIterator.OfInt in java.util.stream

      Methods in java.util.stream that return PrimitiveIterator.OfInt
      Modifier and Type | 方法 | 描述
      PrimitiveIterator.OfInt | IntStream.iterator​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.PrimitiveIterator.OfLong (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.PrimitiveIterator.OfLong

  • Packages that use PrimitiveIterator.OfLong
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of PrimitiveIterator.OfLong in java.util

      Methods in java.util that return PrimitiveIterator.OfLong
      Modifier and Type 方法 描述
      static PrimitiveIterator.OfLong Spliterators.iterator​(Spliterator.OfLong spliterator)
      创建一个 PrimitiveIterator.OfLong从 Spliterator.OfLong 。
      Methods in java.util with parameters of type PrimitiveIterator.OfLong
      Modifier and Type 方法 描述
      static Spliterator.OfLong Spliterators.spliterator​(PrimitiveIterator.OfLong iterator, long size, int characteristics)
      创建一个 Spliterator.OfLong使用给定的 LongStream.LongIterator作为元素的来源，并给出最初报告的大小。
      static Spliterator.OfLong Spliterators.spliteratorUnknownSize​(PrimitiveIterator.OfLong iterator, int characteristics)
      使用给定的 LongStream.LongIterator作为元素的来源创建一个 Spliterator.OfLong ，没有初始大小估计。

    • Uses of PrimitiveIterator.OfLong in java.util.stream

      Methods in java.util.stream that return PrimitiveIterator.OfLong
      Modifier and Type | 方法 | 描述
      PrimitiveIterator.OfLong | LongStream.iterator​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Queue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Queue

  • Packages that use Queue
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of Queue in java.util

      Subinterfaces of Queue in java.util
      Modifier and Type 接口 描述
      interface  Deque<E>
      支持两端元素插入和移除的线性集合。
      Classes in java.util that implement Queue
      Modifier and Type Class 描述
      class  AbstractQueue<E>
      这个类提供了一些Queue操作的骨架实现。
      class  ArrayDeque<E>
      Deque接口的可调整大小的数组实现。
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
      class  PriorityQueue<E>
      基于优先级堆的无限优先级queue 。
      Methods in java.util that return Queue
      Modifier and Type 方法 描述
      static <T> Queue<T> Collections.asLifoQueue​(Deque<T> deque)
      返回Deque作为先入先出（ Lifo ） Queue的视图 。
      static <E> Queue<E> Collections.checkedQueue​(Queue<E> queue, Class<E> type)
      返回指定队列的动态类型安全视图。
      Methods in java.util with parameters of type Queue
      Modifier and Type 方法 描述
      static <E> Queue<E> Collections.checkedQueue​(Queue<E> queue, Class<E> type)
      返回指定队列的动态类型安全视图。

    • Uses of Queue in java.util.concurrent

      Subinterfaces of Queue in java.util.concurrent
      Modifier and Type 接口 描述
      interface  BlockingDeque<E>
      A Deque另外支持在检索元素时等待deque变为非空的阻塞操作，并等待存储元素时在deque中空间可用。
      interface  BlockingQueue<E>
      A Queue另外支持在检索元素时等待队列变为非空的操作，并在存储元素时等待队列中的空间变得可用。
      interface  TransferQueue<E>
      A BlockingQueue ，其中生产者可能等待消费者接收元素。
      Classes in java.util.concurrent that implement Queue
      Modifier and Type Class 描述
      class  ArrayBlockingQueue<E>
      有限的blocking queue由数组支持。
      class  ConcurrentLinkedDeque<E>
      基于链接节点的无界并发deque 。
      class  ConcurrentLinkedQueue<E>
      基于链接节点的无界线程安全queue 。
      class  DelayQueue<E extends Delayed>
      一个无限的blocking queue的Delayed元素，其中元素只能在其延迟到期时被采用。
      class  LinkedBlockingDeque<E>
      基于链接节点的可选限定的blocking deque 。
      class  LinkedBlockingQueue<E>
      基于链接节点的可选限定的blocking queue 。
      class  LinkedTransferQueue<E>
      基于链接节点的无界TransferQueue 。
      class  PriorityBlockingQueue<E>
      无限blocking queue使用与PriorityQueue类相同的排序规则，并提供阻止检索操作。
      class  SynchronousQueue<E>
      A blocking queue其中每个插入操作必须等待另一个线程的相应删除操作，反之亦然。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.RandomAccess (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.RandomAccess

  • Packages that use RandomAccess
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.relation
    提供关系服务的定义。

    • Uses of RandomAccess in java.util

      Classes in java.util that implement RandomAccess
      Modifier and Type Class 描述
      class  ArrayList<E>
      List接口的可调整大小的数组实现。
      class  Stack<E>
      Stack类代表最先进先出（LIFO）堆栈的对象。
      class  Vector<E>
      Vector类实现了可扩展的对象数组。

    • Uses of RandomAccess in java.util.concurrent

      Classes in java.util.concurrent that implement RandomAccess
      Modifier and Type Class 描述
      class  CopyOnWriteArrayList<E>
      的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。

    • Uses of RandomAccess in javax.management

      Classes in javax.management that implement RandomAccess
      Modifier and Type Class 描述
      class  AttributeList
      表示MBean属性值的列表。

    • Uses of RandomAccess in javax.management.relation

      Classes in javax.management.relation that implement RandomAccess
      Modifier and Type Class 描述
      class  RoleList
      RoleList表示角色列表（Role对象）。
      class  RoleUnresolvedList
      RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.ServiceLoader.Provider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.ServiceLoader.Provider

  • Packages that use ServiceLoader.Provider
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of ServiceLoader.Provider in java.util

      Methods in java.util that return types with arguments of type ServiceLoader.Provider
      Modifier and Type 方法 描述
      Stream<ServiceLoader.Provider<S>> ServiceLoader.stream​()
      返回一个流，以延迟加载此加载程序服务的可用提供程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Set (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Set

  • Packages that use Set
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    服务提供商类为 java.nio.channels包。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.imageio
    Java Image I / O API的主要包。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的工具 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.handler.soap
    此包定义SOAP消息处理程序的API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.net
    java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of Set in com.sun.jdi.event

      Subinterfaces of Set in com.sun.jdi.event
      Modifier and Type 接口 描述
      interface  EventSet
      可以在给定时间由目标VirtualMachine创建几个Event对象。

    • Uses of Set in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return Set
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<String,List<String>>> | Headers.entrySet​()
      Set<String> | Headers.keySet​()

    • Uses of Set in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return Set
      Modifier and Type 方法 描述
      abstract Set<Association> SctpMultiChannel.associations​()
      返回此通道的套接字上的打开关联。
      abstract Set<SocketAddress> SctpChannel.getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract Set<SocketAddress> SctpMultiChannel.getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract Set<SocketAddress> SctpServerChannel.getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract Set<SocketAddress> SctpChannel.getRemoteAddresses​()
      返回此通道的套接字所连接的所有远程地址。
      abstract Set<SocketAddress> SctpMultiChannel.getRemoteAddresses​(Association association)
      返回此通道的套接字连接给定关联的所有远程地址。
      abstract Set<SctpSocketOption<?>> SctpChannel.supportedOptions​()
      返回此通道支持的一组套接字选项。
      abstract Set<SctpSocketOption<?>> SctpMultiChannel.supportedOptions​()
      返回此通道支持的一组套接字选项。
      abstract Set<SctpSocketOption<?>> SctpServerChannel.supportedOptions​()
      返回此通道支持的一组套接字选项。

    • Uses of Set in com.sun.source.tree

      Methods in com.sun.source.tree that return Set
      Modifier and Type 方法 描述
      Set<Modifier> ModifiersTree.getFlags​()
      返回此修饰符树中的标志。

    • Uses of Set in java.awt

      Methods in java.awt that return Set
      Modifier and Type 方法 描述
      Set<Map.Entry<Object,Object>> RenderingHints.entrySet​()
      返回此 RenderingHints包含的映射的 Set视图。
      Set<AWTKeyStroke> KeyboardFocusManager.getDefaultFocusTraversalKeys​(int id)
      返回给定遍历操作的一组默认焦点遍历键。
      Set<AWTKeyStroke> Component.getFocusTraversalKeys​(int id)
      返回此组件的给定遍历操作的聚焦遍历键集。
      Set<AWTKeyStroke> Container.getFocusTraversalKeys​(int id)
      返回此Container的给定遍历操作的聚焦遍历键集。
      Set<AWTKeyStroke> Window.getFocusTraversalKeys​(int id)
      获取此窗口的焦点遍历键。
      Set<Object> RenderingHints.keySet​()
      返回此 RenderingHints包含的键的 Set视图。
      Methods in java.awt with parameters of type Set
      Modifier and Type 方法 描述
      void KeyboardFocusManager.setDefaultFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置给定遍历操作的默认焦点遍历键。
      void Component.setFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置此组件给定遍历操作的焦点遍历键。
      void Container.setFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置此容器的给定遍历操作的焦点遍历键。

    • Uses of Set in java.awt.font

      Methods in java.awt.font that return Set
      Modifier and Type 方法 描述
      Set<NumericShaper.Range> NumericShaper.getRangeSet​()
      返回 Set代表所有的Unicode范围在此 NumericShaper将要成型。
      Methods in java.awt.font with parameters of type Set
      Modifier and Type 方法 描述
      static NumericShaper NumericShaper.getContextualShaper​(Set<NumericShaper.Range> ranges)
      返回提供的Unicode范围的上下文整形器。
      static NumericShaper NumericShaper.getContextualShaper​(Set<NumericShaper.Range> ranges, NumericShaper.Range defaultContext)
      返回提供的Unicode范围的上下文整形器。

    • Uses of Set in java.lang

      Methods in java.lang that return Set
      Modifier and Type 方法 描述
      Set<String> Module.getPackages​()
      返回此模块中软件包的软件包名称集。
      Set<Module> ModuleLayer.modules​()
      返回此图层中的模块集。
      Methods in java.lang with parameters of type Set
      Modifier and Type 方法 描述
      static StackWalker StackWalker.getInstance​(Set<StackWalker.Option> options)
      返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。
      static StackWalker StackWalker.getInstance​(Set<StackWalker.Option> options, int estimateDepth)
      返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。

    • Uses of Set in java.lang.instrument

      Methods in java.lang.instrument with parameters of type Set
      Modifier and Type 方法 描述
      void Instrumentation.redefineModule​(Module module, Set<Module> extraReads, Map<String,Set<Module>> extraExports, Map<String,Set<Module>> extraOpens, Set<Class<?>> extraUses, Map<Class<?>,List<Class<?>>> extraProvides)
      重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。
      Method parameters in java.lang.instrument with type arguments of type Set
      Modifier and Type 方法 描述
      void Instrumentation.redefineModule​(Module module, Set<Module> extraReads, Map<String,Set<Module>> extraExports, Map<String,Set<Module>> extraOpens, Set<Class<?>> extraUses, Map<Class<?>,List<Class<?>>> extraProvides)
      重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。

    • Uses of Set in java.lang.management

      Methods in java.lang.management that return Set
      Modifier and Type 方法 描述
      static Set<Class<? extends PlatformManagedObject>> ManagementFactory.getPlatformManagementInterfaces​()
      返回Class对象的集合，子接口PlatformManagedObject ，表示用于监视和管理Java平台的所有管理接口。

    • Uses of Set in java.lang.module

      Methods in java.lang.module that return Set
      Modifier and Type 方法 描述
      Set<ModuleDescriptor.Exports> ModuleDescriptor.exports​()
      返回表示导出包的 Exports对象的集合。
      Set<ModuleReference> ModuleFinder.findAll​()
      返回此查找器可以找到的所有模块引用的集合。
      Set<ModuleDescriptor.Exports.Modifier> ModuleDescriptor.Exports.modifiers​()
      返回一组修饰符。
      Set<ModuleDescriptor.Modifier> ModuleDescriptor.modifiers​()
      返回一组模块修饰符。
      Set<ModuleDescriptor.Opens.Modifier> ModuleDescriptor.Opens.modifiers​()
      返回一组修饰符。
      Set<ModuleDescriptor.Requires.Modifier> ModuleDescriptor.Requires.modifiers​()
      返回一组修饰符。
      Set<ResolvedModule> Configuration.modules​()
      在此配置中返回一组不可变的已解析模块。
      Set<ModuleDescriptor.Opens> ModuleDescriptor.opens​()
      返回表示开放包的 Opens对象的集合。
      Set<String> ModuleDescriptor.packages​()
      返回模块中的一组包。
      Set<ModuleDescriptor.Provides> ModuleDescriptor.provides​()
      返回表示模块提供的服务的 Provides对象集。
      Set<ResolvedModule> ResolvedModule.reads​()
      返回已解析模块读取的已解析模块集。
      Set<ModuleDescriptor.Requires> ModuleDescriptor.requires​()
      返回表示模块依赖关系的 Requires对象集。
      Set<String> ModuleDescriptor.Exports.targets​()
      对于合格的导出，返回导出包的模块名称的非空和不可变的集合。
      Set<String> ModuleDescriptor.Opens.targets​()
      对于合格的打开，返回打包该包的模块名称的非空和不可变的集合。
      Set<String> ModuleDescriptor.uses​()
      返回一组服务依赖关系。
      Methods in java.lang.module with parameters of type Set
      Modifier and Type 方法 描述
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(String pn, Set<String> targets)
      添加导出的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn)
      使用给定（可能为空）的修饰符集添加导出的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn, Set<String> targets)
      使用给定（可能为空）的修饰符集添加导出的包。
      static ModuleDescriptor.Builder ModuleDescriptor.newModule​(String name, Set<ModuleDescriptor.Modifier> ms)
      实例化构建器以构建模块描述符。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(String pn, Set<String> targets)
      添加一个开放的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn)
      添加一个带有给定（可能为空）的修饰符集的开放包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn, Set<String> targets)
      添加一个带有给定（可能为空）的修饰符集的开放包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.packages​(Set<String> pns)
      将包添加到模块。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn)
      使用给定（可能为空）的修饰符集添加对模块的依赖。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn, ModuleDescriptor.Version compiledVersion)
      使用给定（可能为空）的修饰符集添加对模块的依赖。
      Method parameters in java.lang.module with type arguments of type Set
      Modifier and Type 方法 描述
      static ModuleDescriptor ModuleDescriptor.read​(InputStream in, Supplier<Set<String>> packageFinder)
      从输入流读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor ModuleDescriptor.read​(ByteBuffer bb, Supplier<Set<String>> packageFinder)
      从字节缓冲区中读取模块声明的二进制形式作为模块描述符。

    • Uses of Set in java.net

      Methods in java.net that return Set
      Modifier and Type | 方法 | 描述
      Set<SocketOption<?>> DatagramSocket.supportedOptions​()
      返回此套接字支持的一组套接字选项。
      protected Set<SocketOption<?>> DatagramSocketImpl.supportedOptions​()
      返回一个由此impl和该impl的套接字（DatagramSocket或MulticastSocket）支持的SocketOptions，
      Set<SocketOption<?>> | MulticastSocket.supportedOptions​()
      Set<SocketOption<?>> ServerSocket.supportedOptions​()
      返回此服务器套接字支持的一组套接字选项。
      Set<SocketOption<?>> Socket.supportedOptions​()
      返回此套接字支持的一组套接字选项。
      protected Set<SocketOption<?>> SocketImpl.supportedOptions​()
      返回一个由此impl和该impl的套接字支持的SocketOptions（Socket或ServerSocket）

    • Uses of Set in java.nio.channels

      Methods in java.nio.channels that return Set
      Modifier and Type 方法 描述
      abstract Set<SelectionKey> Selector.keys​()
      返回此选择器的键集。
      abstract Set<SelectionKey> Selector.selectedKeys​()
      返回此选择器的选择键集。
      Set<SocketOption<?>> NetworkChannel.supportedOptions​()
      返回此通道支持的一组套接字选项。
      Methods in java.nio.channels with parameters of type Set
      Modifier and Type 方法 描述
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static FileChannel FileChannel.open​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回文件通道以访问该文件。

    • Uses of Set in java.nio.channels.spi

      Methods in java.nio.channels.spi that return Set
      Modifier and Type 方法 描述
      protected Set<SelectionKey> AbstractSelector.cancelledKeys​()
      检索此选择器的已取消键集。

    • Uses of Set in java.nio.charset

      Methods in java.nio.charset that return Set
      Modifier and Type 方法 描述
      Set<String> Charset.aliases​()
      返回一个包含此字符集的别名的集合。

    • Uses of Set in java.nio.file

      Methods in java.nio.file that return Set
      Modifier and Type 方法 描述
      static Set<PosixFilePermission> Files.getPosixFilePermissions​(Path path, LinkOption... options)
      返回文件的POSIX文件权限。
      abstract Set<String> FileSystem.supportedFileAttributeViews​()
      返回集的 names的该支持的文件属性意见 FileSystem 。
      Methods in java.nio.file with parameters of type Set
      Modifier and Type 方法 描述
      static SeekableByteChannel Files.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      SeekableByteChannel SecureDirectoryStream.newByteChannel​(T path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      在此目录中打开或创建一个文件，返回可访问的字节通道以访问该文件。
      static Path Files.setPosixFilePermissions​(Path path, Set<PosixFilePermission> perms)
      设置文件的POSIX权限。
      static Path Files.walkFileTree​(Path start, Set<FileVisitOption> options, int maxDepth, FileVisitor<? super Path> visitor)
      走一个文件树。

    • Uses of Set in java.nio.file.attribute

      Methods in java.nio.file.attribute that return Set
      Modifier and Type 方法 描述
      Set<AclEntryFlag> AclEntry.flags​()
      返回flags组件的副本。
      static Set<PosixFilePermission> PosixFilePermissions.fromString​(String perms)
      返回与给定的 String表示相对应的一组权限。
      Set<AclEntryPermission> AclEntry.permissions​()
      返回权限组件的副本。
      Set<PosixFilePermission> PosixFileAttributes.permissions​()
      返回文件的权限。
      Methods in java.nio.file.attribute that return types with arguments of type Set
      Modifier and Type 方法 描述
      static FileAttribute<Set<PosixFilePermission>> PosixFilePermissions.asFileAttribute​(Set<PosixFilePermission> perms)
      创建一个FileAttribute ，封装给定文件的权限，适合传递给createFile或createDirectory的方法。
      Methods in java.nio.file.attribute with parameters of type Set
      Modifier and Type 方法 描述
      static FileAttribute<Set<PosixFilePermission>> PosixFilePermissions.asFileAttribute​(Set<PosixFilePermission> perms)
      创建一个FileAttribute ，封装给定文件的权限，适合传递给createFile或createDirectory的方法。
      AclEntry.Builder AclEntry.Builder.setFlags​(Set<AclEntryFlag> flags)
      设置此构建器的标志组件。
      AclEntry.Builder AclEntry.Builder.setPermissions​(Set<AclEntryPermission> perms)
      设置此构建器的权限组件。
      void PosixFileAttributeView.setPermissions​(Set<PosixFilePermission> perms)
      更新文件权限。
      static String PosixFilePermissions.toString​(Set<PosixFilePermission> perms)
      返回一组权限的 String表示。

    • Uses of Set in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type Set
      Modifier and Type 方法 描述
      AsynchronousFileChannel FileSystemProvider.newAsynchronousFileChannel​(Path path, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      abstract SeekableByteChannel FileSystemProvider.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      FileChannel FileSystemProvider.newFileChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回文件通道以访问该文件。

    • Uses of Set in java.security

      Methods in java.security that return Set
      Modifier and Type 方法 描述
      Set<Map.Entry<Object,Object>> Provider.entrySet​()
      返回此提供程序中包含的属性条目的不可修改的Set视图。
      static Set<String> Security.getAlgorithms​(String serviceName)
      返回一组字符串，其中包含指定Java加密服务的所有可用算法或类型的名称（例如Signature，MessageDigest，Cipher，Mac，KeyStore）。
      default Set<KeyStore.Entry.Attribute> KeyStore.Entry.getAttributes​()
      检索与条目关联的属性。
      Set<KeyStore.Entry.Attribute> KeyStore.PrivateKeyEntry.getAttributes​()
      检索与条目关联的属性。
      Set<KeyStore.Entry.Attribute> KeyStore.SecretKeyEntry.getAttributes​()
      检索与条目关联的属性。
      Set<KeyStore.Entry.Attribute> KeyStore.TrustedCertificateEntry.getAttributes​()
      检索与条目关联的属性。
      Set<Provider.Service> Provider.getServices​()
      获取不可修改的此提供程序支持的所有服务的集合。
      Set<Object> Provider.keySet​()
      返回此提供程序中包含的属性键的不可修改的Set视图。
      Methods in java.security with parameters of type Set
      Modifier and Type 方法 描述
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, String algorithm, AlgorithmParameters parameters)
      确定是否为算法授予了指定的加密原语的权限。
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, String algorithm, Key key, AlgorithmParameters parameters)
      确定算法和相应的密钥是否被授予对指定的加密原语的许可。
      boolean AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, Key key)
      确定一个密钥是否被授予了指定的加密原语的权限。
      Constructors in java.security with parameters of type Set
      Constructor 描述
      PrivateKeyEntry​(PrivateKey privateKey, Certificate[] chain, Set<KeyStore.Entry.Attribute> attributes)
      构造一个具有 PrivateKeyEntry的 PrivateKey和相应的证书链和相关联的条目属性。
      SecretKeyEntry​(SecretKey secretKey, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 SecretKeyEntry与 SecretKey及相关条目中的属性。
      TrustedCertificateEntry​(Certificate trustedCert, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 TrustedCertificateEntry具有可信任的 Certificate和相关联的条目属性。

    • Uses of Set in java.security.cert

      Methods in java.security.cert that return Set
      Modifier and Type 方法 描述
      Set<String> X509Extension.getCriticalExtensionOIDs​()
      获取由实现此接口的对象管理的证书/ CRL中标记为“CRITICAL”的扩展名的OID字符串集。
      Set<String> PolicyNode.getExpectedPolicies​()
      返回在待处理的下一个证书中满足此节点有效策略的一组预期策略。
      Set<String> X509CertSelector.getExtendedKeyUsage​()
      返回extendedKeyUsage标准。
      Set<String> PKIXParameters.getInitialPolicies​()
      返回一个不可变的初始策略标识符（OID字符串）的 Set ，这表明这些策略中的任何一个对证书用户来说都是可以接受的，用于认证路径处理。
      Set<String> X509Extension.getNonCriticalExtensionOIDs​()
      获取由实现此接口的对象管理的证书/ CRL中标记为“非关键性”的扩展名的OID字符串集。
      Set<PKIXRevocationChecker.Option> PKIXRevocationChecker.getOptions​()
      获取吊销选项。
      Set<String> X509CertSelector.getPolicy​()
      返回策略标准。
      Set<? extends PolicyQualifierInfo> PolicyNode.getPolicyQualifiers​()
      返回与此节点所表示的有效策略相关联的策略限定符集。
      abstract Set<? extends X509CRLEntry> X509CRL.getRevokedCertificates​()
      获取此CRL中的所有条目。
      abstract Set<String> PKIXCertPathChecker.getSupportedExtensions​()
      返回 PKIXCertPathChecker支持（即识别，能够处理）的X.509证书扩展的不可变 Set ，如果不支持扩展名，则 null 。
      Set<TrustAnchor> PKIXParameters.getTrustAnchors​()
      返回一个不可变的 Set最受信任的CA。
      Methods in java.security.cert with parameters of type Set
      Modifier and Type 方法 描述
      void X509CertSelector.setExtendedKeyUsage​(Set<String> keyPurposeSet)
      设置extendedKeyUsage标准。
      void PKIXParameters.setInitialPolicies​(Set<String> initialPolicies)
      设置初始策略标识符（OID字符串）的 Set ，指示证书用户为了认证路径处理的目的而可以接受这些策略中的任何一个。
      void PKIXRevocationChecker.setOptions​(Set<PKIXRevocationChecker.Option> options)
      设置撤销选项。
      void X509CertSelector.setPolicy​(Set<String> certPolicySet)
      设置策略约束。
      void PKIXParameters.setTrustAnchors​(Set<TrustAnchor> trustAnchors)
      设置最受信任的CA的 Set 。
      Constructors in java.security.cert with parameters of type Set
      Constructor 描述
      PKIXBuilderParameters​(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
      创建一个 PKIXBuilderParameters的实例，其中指定了 Set的最受信任的CA。
      PKIXParameters​(Set<TrustAnchor> trustAnchors)
      创建具有指定的 Set最受信任的CA的实例 PKIXParameters 。

    • Uses of Set in java.text

      Methods in java.text that return Set
      Modifier and Type 方法 描述
      Set<AttributedCharacterIterator.Attribute> AttributedCharacterIterator.getAllAttributeKeys​()
      返回在迭代器的文本范围上定义的所有属性的关键字。
      Methods in java.text with parameters of type Set
      Modifier and Type 方法 描述
      int AttributedCharacterIterator.getRunLimit​(Set<? extends AttributedCharacterIterator.Attribute> attributes)
      相对于包含当前字符的给定的 attributes返回运行后的第一个字符的索引。
      int AttributedCharacterIterator.getRunStart​(Set<? extends AttributedCharacterIterator.Attribute> attributes)
      相对于包含当前字符的给定的 attributes返回运行的第一个字符的索引。

    • Uses of Set in java.time

      Methods in java.time that return Set
      Modifier and Type 方法 描述
      static Set<String> ZoneId.getAvailableZoneIds​()
      获取一组可用的区域ID。

    • Uses of Set in java.time.chrono

      Methods in java.time.chrono that return Set
      Modifier and Type 方法 描述
      static Set<Chronology> Chronology.getAvailableChronologies​()
      返回可用的年表。

    • Uses of Set in java.time.format

      Methods in java.time.format that return Set
      Modifier and Type 方法 描述
      static Set<Locale> DecimalStyle.getAvailableLocales​()
      列出支持的所有语言环境。
      Set<TemporalField> DateTimeFormatter.getResolverFields​()
      获取在解析期间使用的解析器字段。
      Methods in java.time.format with parameters of type Set
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendGenericZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将泛型时区名称（如“太平洋时间”）附加到格式化程序。
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendZoneText​(TextStyle textStyle, Set<ZoneId> preferredZones)
      将时区名称（如“英国夏令时”）附加到格式化程序。
      DateTimeFormatter DateTimeFormatter.withResolverFields​(Set<TemporalField> resolverFields)
      使用一组新的解析器字段返回此格式化程序的副本。

    • Uses of Set in java.time.zone

      Methods in java.time.zone that return Set
      Modifier and Type 方法 描述
      static Set<String> ZoneRulesProvider.getAvailableZoneIds​()
      获取一组可用的区域ID。
      protected abstract Set<String> ZoneRulesProvider.provideZoneIds​()
      SPI方法获取可用的区域ID。

    • Uses of Set in java.util

      Subinterfaces of Set in java.util
      Modifier and Type 接口 描述
      interface  NavigableSet<E>
      A SortedSet扩展了导航方法，报告给定搜索目标的最匹配的匹配。
      interface  SortedSet<E>
      A Set进一步提供了其元素的总排序 。
      Classes in java.util that implement Set
      Modifier and Type Class 描述
      class  AbstractSet<E>
      此类提供了 Set接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
      class  EnumSet<E extends Enum<E>>
      专门用于枚举类型的Set实现。
      class  HashSet<E>
      该类实现了 Set接口，由哈希表（实际为 HashMap实例）支持。
      class  LinkedHashSet<E>
      哈希表和链表实现了 Set接口，具有可预测的迭代次序。
      class  TreeSet<E>
      A NavigableSet实现基于TreeMap 。
      Fields in java.util declared as Set
      Modifier and Type Field 描述
      static Set Collections.EMPTY_SET
      空集（不可变）。
      Methods in java.util that return Set
      Modifier and Type | 方法 | 描述
      static <E> Set<E> Collections.checkedSet​(Set<E> s, Class<E> type)
      返回指定集合的动态类型安全视图。
      static <T> Set<T> Collections.emptySet​()
      返回一个空集（immutable）。
      abstract Set<Map.Entry<K,V>> | AbstractMap.entrySet​()
      Set<Map.Entry<K,V>> EnumMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> HashMap.entrySet​()
      返回此映射中包含的映射的视图Set 。
      Set<Map.Entry<K,V>> Hashtable.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> IdentityHashMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> LinkedHashMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> Map.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<Object,Object>> | Properties.entrySet​()
      Set<Map.Entry<K,V>> SortedMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> TreeMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> WeakHashMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      static Set<String> Calendar.getAvailableCalendarTypes​()
      返回一个不可修改的 Set其中包含 Calendar在运行时环境中支持的所有日历类型。
      static Set<Currency> Currency.getAvailableCurrencies​()
      获得一组可用的货币。
      Set<Character> Locale.getExtensionKeys​()
      返回与此语言环境相关联的扩展键集合，如果没有扩展名则返回空集合。
      static Set<String> Locale.getISOCountries​(Locale.IsoCountryCode type)
      返回 Set的指定类型的ISO3166国家代码。
      Set<String> Locale.getUnicodeLocaleAttributes​()
      返回与此区域设置关联的unicode区域设置属性集，如果没有属性，则返回空集合。
      Set<String> Locale.getUnicodeLocaleKeys​()
      返回此区域设置定义的Unicode区域设置键的集合，如果此区域设置没有，则返回空集合。
      protected Set<String> ListResourceBundle.handleKeySet​()
      返回一个 Set的键 只包含在这个 ResourceBundle 。
      protected Set<String> PropertyResourceBundle.handleKeySet​()
      返回一个 Set的键 只包含在这个 ResourceBundle 。
      protected Set<String> ResourceBundle.handleKeySet​()
      返回一个 Set的键 只包含在这个 ResourceBundle 。
      Set<K> AbstractMap.keySet​()
      返回此地图中包含的键的Set视图。
      Set<K> EnumMap.keySet​()
      返回此地图中包含的键的Set视图。
      Set<K> HashMap.keySet​()
      返回此地图中包含的键的Set视图。
      Set<K> Hashtable.keySet​()
      返回此地图中包含的键的Set视图。
      Set<K> IdentityHashMap.keySet​()
      返回此地图中包含的键的基于身份的设置视图。
      Set<K> LinkedHashMap.keySet​()
      返回此地图中包含的键的Set视图。
      Set<K> Map.keySet​()
      返回此地图中包含的键的Set视图。
      Set<Object> | Properties.keySet​()
      Set<String> ResourceBundle.keySet​()
      返回 Set包含在此的所有键的 ResourceBundle及其父包。
      Set<K> SortedMap.keySet​()
      返回此地图中包含的键的Set视图。
      Set<K> TreeMap.keySet​()
      返回此地图中包含的键的Set视图。
      Set<K> WeakHashMap.keySet​()
      返回此地图中包含的键的Set视图。
      static <E> Set<E> Collections.newSetFromMap​(Map<E,Boolean> map)
      返回由指定地图支持的集合。
      static <E> Set<E> Set.of​()
      返回一个包含零个元素的不可变集合。
      static <E> Set<E> Set.of​(E e1)
      返回一个包含一个元素的不可变集合。
      static <E> Set<E> Set.of​(E... elements)
      返回一个包含任意数量元素的不可变集合。
      static <E> Set<E> Set.of​(E e1, E e2)
      返回一个包含两个元素的不可变集合。
      static <E> Set<E> Set.of​(E e1, E e2, E e3)
      返回一个包含三个元素的不可变集合。
      static <E> Set<E> Set.of​(E e1, E e2, E e3, E e4)
      返回一个包含四个元素的不可变集合。
      static <E> Set<E> Set.of​(E e1, E e2, E e3, E e4, E e5)
      返回一个包含五个元素的不可变集合。
      static <E> Set<E> Set.of​(E e1, E e2, E e3, E e4, E e5, E e6)
      返回一个包含六个元素的不可变集合。
      static <E> Set<E> Set.of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7)
      返回一个包含七个元素的不可变集合。
      static <E> Set<E> Set.of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8)
      返回一个包含八个元素的不可变集合。
      static <E> Set<E> Set.of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8, E e9)
      返回一个包含九个元素的不可变集合。
      static <E> Set<E> Set.of​(E e1, E e2, E e3, E e4, E e5, E e6, E e7, E e8, E e9, E e10)
      返回一个包含十个元素的不可变集合。
      static <T> Set<T> Collections.singleton​(T o)
      返回一个只包含指定对象的不可变组。
      Set<String> Properties.stringPropertyNames​()
      从该属性列表中返回一个不可修改的键集，其中键及其对应的值是字符串，包括默认属性列表中的不同键，如果尚未从主属性列表中找到相同名称的键。
      static <T> Set<T> Collections.synchronizedSet​(Set<T> s)
      返回由指定集合支持的同步（线程安全）集。
      static <T> Set<T> Collections.unmodifiableSet​(Set<? extends T> s)
      返回指定集合的不可修改视图。
      Methods in java.util with parameters of type Set
      Modifier and Type 方法 描述
      static <E> Set<E> Collections.checkedSet​(Set<E> s, Class<E> type)
      返回指定集合的动态类型安全视图。
      static <T> Set<T> Collections.synchronizedSet​(Set<T> s)
      返回由指定集合支持的同步（线程安全）集。
      static <T> Set<T> Collections.unmodifiableSet​(Set<? extends T> s)
      返回指定集合的不可修改视图。

    • Uses of Set in java.util.concurrent

      Classes in java.util.concurrent that implement Set
      Modifier and Type Class 描述
      static class  ConcurrentHashMap.KeySetView<K,V>
      ConcurrentHashMap视图为Set的密钥，其中可以通过映射到公共值来选择添加。
      class  ConcurrentSkipListSet<E>
      可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
      class  CopyOnWriteArraySet<E>
      A Set 对其所有操作使用内部CopyOnWriteArrayList 。
      Methods in java.util.concurrent that return Set
      Modifier and Type 方法 描述
      Set<Map.Entry<K,V>> ConcurrentHashMap.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<Map.Entry<K,V>> ConcurrentSkipListMap.entrySet​()
      返回此地图中包含的映射的Set视图。

    • Uses of Set in java.util.jar

      Methods in java.util.jar that return Set
      Modifier and Type 方法 描述
      Set<Map.Entry<Object,Object>> Attributes.entrySet​()
      返回此Map中包含的属性名称 - 值映射的集合视图。
      Set<Object> Attributes.keySet​()
      返回此Map中包含的属性名称（键）的Set视图。

    • Uses of Set in java.util.stream

      Methods in java.util.stream that return Set
      Modifier and Type 方法 描述
      Set<Collector.Characteristics> Collector.characteristics​()
      返回 Set的 Collector.Characteristics表示该收藏家的特征。
      Methods in java.util.stream that return types with arguments of type Set
      Modifier and Type 方法 描述
      static <T> Collector<T,?,Set<T>> Collectors.toSet​()
      返回一个 Collector ，它将输入元素累加到一个新的 Set 。

    • Uses of Set in javafx.animation

      Methods in javafx.animation that return Set
      Modifier and Type 方法 描述
      Set<KeyValue> KeyFrame.getValues​()
      返回KeyValue实例的不可变Set 。

    • Uses of Set in javafx.beans.binding

      Classes in javafx.beans.binding that implement Set
      Modifier and Type Class 描述
      class  SetBinding<E>
      提供实现ObservableSet的Binding所需的大部分功能的基类。
      class  SetExpression<E>
      SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的方式生成绑定。
      Methods in javafx.beans.binding that return Set
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<K,V>> | MapExpression.entrySet​()
      Set<K> | MapExpression.keySet​()
      Methods in javafx.beans.binding with parameters of type Set
      Modifier and Type 方法 描述
      static <E> void Bindings.bindContent​(Set<E> set1, ObservableSet<? extends E> set2)
      生成ObservableSet和Set之间的内容绑定。

    • Uses of Set in javafx.beans.property

      Classes in javafx.beans.property that implement Set
      Modifier and Type Class 描述
      class  ReadOnlySetProperty<E>
      超类为所有只读属性包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个课程提供了一个Property包装一个ObservableSet的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleSetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。

    • Uses of Set in javafx.beans.value

      Subinterfaces of Set in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableSetValue<E>
      可以参考一个ObservableSet 。
      interface  WritableSetValue<E>
      可写参考一个ObservableSet 。

    • Uses of Set in javafx.collections

      Subinterfaces of Set in javafx.collections
      Modifier and Type 接口 描述
      interface  ObservableSet<E>
      一组允许观察者跟踪变化发生时的变化。
      Methods in javafx.collections with parameters of type Set
      Modifier and Type 方法 描述
      static <E> ObservableSet<E> FXCollections.observableSet​(Set<E> set)
      构造由指定集合支持的ObservableSet。

    • Uses of Set in javafx.css

      Methods in javafx.css that return Set
      Modifier and Type | 方法 | 描述
      Set<StyleClass> | SimpleSelector.getStyleClassSet​()
      Methods in javafx.css with parameters of type Set
      Modifier and Type | 方法 | 描述
      boolean | CompoundSelector.applies​(Styleable styleable, Set<PseudoClass>[] triggerStates, int depth)
      abstract boolean | Selector.applies​(Styleable styleable, Set<PseudoClass>[] triggerStates, int bit)
      boolean | SimpleSelector.applies​(Styleable styleable, Set<PseudoClass>[] pseudoClasses, int depth)
      boolean | CompoundSelector.stateMatches​(Styleable styleable, Set<PseudoClass> states)
      abstract boolean Selector.stateMatches​(Styleable styleable, Set<PseudoClass> state)
      确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。
      boolean | SimpleSelector.stateMatches​(Styleable styleable, Set<PseudoClass> states)

    • Uses of Set in javafx.print

      Methods in javafx.print that return Set
      Modifier and Type 方法 描述
      Set<Collation> PrinterAttributes.getSupportedCollations​()
      返回此打印机支持的归类设置的不可修改的集合。
      Set<PageOrientation> PrinterAttributes.getSupportedPageOrientations​()
      返回此打印机支持的方向的不可修改的一组。
      Set<Paper> PrinterAttributes.getSupportedPapers​()
      返回此打印机支持的纸张尺寸不可修改的集合。
      Set<PaperSource> PrinterAttributes.getSupportedPaperSources​()
      返回此打印机支持的纸张来源（即输入纸盒或纸盘）的不可修改的一组。
      Set<PrintColor> PrinterAttributes.getSupportedPrintColors​()
      返回此打印机支持的颜色设置的不可修改的集合。
      Set<PrintQuality> PrinterAttributes.getSupportedPrintQuality​()
      返回此打印机支持的质量设置的一组不可修改的集合。
      Set<PrintResolution> PrinterAttributes.getSupportedPrintResolutions​()
      返回此打印机支持的打印分辨率的一组不可修改的集合。
      Set<PrintSides> PrinterAttributes.getSupportedPrintSides​()
      返回此打印机支持的双面设置的不可修改的一组。

    • Uses of Set in javafx.scene

      Methods in javafx.scene that return Set
      Modifier and Type 方法 描述
      Set<Node> Node.lookupAll​(String selector)
      找到所有 Node s，包括这个和任何孩子，匹配给定的CSS选择器。

    • Uses of Set in javafx.scene.control

      Methods in javafx.scene.control that return Set
      Modifier and Type 方法 描述
      Set<Node> TabPane.lookupAll​(String selector)
      查找所有 Node s，包括这个和任何孩子，匹配给定的CSS选择器。

    • Uses of Set in javafx.scene.input

      Methods in javafx.scene.input that return Set
      Modifier and Type 方法 描述
      Set<DataFormat> Clipboard.getContentTypes​()
      获取此剪贴板实例上具有已在剪贴板上注册的关联数据的DataFormat类型集。
      Set<String> DataFormat.getIdentifiers​()
      获取此DataFormat的不可修改的标识符集。
      Set<TransferMode> Dragboard.getTransferModes​()
      获取由此拖动操作的源支持的一组传输模式。

    • Uses of Set in javax.annotation.processing

      Methods in javax.annotation.processing that return Set
      Modifier and Type 方法 描述
      Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith​(Class<? extends Annotation> a)
      返回使用给定注释类型注释的元素。
      Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith​(TypeElement a)
      返回使用给定注释类型注释的元素。
      default Set<? extends Element> RoundEnvironment.getElementsAnnotatedWithAny​(Set<Class<? extends Annotation>> annotations)
      返回使用一个或多个给定注释类型注释的元素。
      default Set<? extends Element> RoundEnvironment.getElementsAnnotatedWithAny​(TypeElement... annotations)
      返回使用一个或多个给定注释类型注释的元素。
      Set<? extends Element> RoundEnvironment.getRootElements​()
      返回上一轮生成的注释处理的root elements 。
      Set<String> AbstractProcessor.getSupportedAnnotationTypes​()
      如果使用SupportedAnnotationTypes注释处理器类，则返回与注释具有相同字符串集的不可修改集。
      Set<String> Processor.getSupportedAnnotationTypes​()
      返回此处理器支持的注释类型的名称。
      Set<String> AbstractProcessor.getSupportedOptions​()
      如果使用SupportedOptions注释处理器类，则返回与注释具有相同字符串集的不可修改集合。
      Set<String> Processor.getSupportedOptions​()
      返回此处理器识别的选项。
      Methods in javax.annotation.processing with parameters of type Set
      Modifier and Type 方法 描述
      default Set<? extends Element> RoundEnvironment.getElementsAnnotatedWithAny​(Set<Class<? extends Annotation>> annotations)
      返回使用一个或多个给定注释类型注释的元素。
      abstract boolean AbstractProcessor.process​(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv)
      对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。
      boolean Processor.process​(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv)
      对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。

    • Uses of Set in javax.imageio

      Methods in javax.imageio with parameters of type Set
      Modifier and Type 方法 描述
      IIOMetadata ImageReader.getImageMetadata​(int imageIndex, String formatName, Set<String> nodeNames)
      返回一个 IIOMetadata表示与给定图像，或相关联的元数据对象 null如果读取器不支持读取元数据或没有可用的。
      IIOMetadata ImageReader.getStreamMetadata​(String formatName, Set<String> nodeNames)
      返回一个 IIOMetadata对象，表示与整个输入源相关联的元数据（即，不与任何特定图像相关联）。

    • Uses of Set in javax.lang.model.element

      Methods in javax.lang.model.element that return Set
      Modifier and Type 方法 描述
      Set<Modifier> Element.getModifiers​()
      返回此元素的修饰符，不包括注释。

    • Uses of Set in javax.lang.model.util

      Methods in javax.lang.model.util that return Set
      Modifier and Type 方法 描述
      static Set<ExecutableElement> ElementFilter.constructorsIn​(Set<? extends Element> elements)
      返回一组构造函数在 elements 。
      static Set<VariableElement> ElementFilter.fieldsIn​(Set<? extends Element> elements)
      返回一组字段在 elements 。
      default Set<? extends ModuleElement> Elements.getAllModuleElements​()
      返回当前环境中的所有模块元素。
      default Set<? extends PackageElement> Elements.getAllPackageElements​(CharSequence name)
      返回具有给定规范名称的所有包元素。
      default Set<? extends TypeElement> Elements.getAllTypeElements​(CharSequence name)
      返回具有给定规范名称的所有类型元素。
      static Set<ExecutableElement> ElementFilter.methodsIn​(Set<? extends Element> elements)
      在 elements返回一组方法。
      static Set<ModuleElement> ElementFilter.modulesIn​(Set<? extends Element> elements)
      在 elements返回一组模块。
      static Set<PackageElement> ElementFilter.packagesIn​(Set<? extends Element> elements)
      在 elements返回一组软件包。
      static Set<TypeElement> ElementFilter.typesIn​(Set<? extends Element> elements)
      在 elements返回一组类型。
      Methods in javax.lang.model.util with parameters of type Set
      Modifier and Type 方法 描述
      static Set<ExecutableElement> ElementFilter.constructorsIn​(Set<? extends Element> elements)
      返回一组构造函数在 elements 。
      static Set<VariableElement> ElementFilter.fieldsIn​(Set<? extends Element> elements)
      返回一组字段在 elements 。
      static Set<ExecutableElement> ElementFilter.methodsIn​(Set<? extends Element> elements)
      返回一组 elements的方法。
      static Set<ModuleElement> ElementFilter.modulesIn​(Set<? extends Element> elements)
      在 elements返回一组模块。
      static Set<PackageElement> ElementFilter.packagesIn​(Set<? extends Element> elements)
      在 elements返回一组软件包。
      static Set<TypeElement> ElementFilter.typesIn​(Set<? extends Element> elements)
      在 elements返回一组类型。

    • Uses of Set in javax.management

      Methods in javax.management that return Set
      Modifier and Type 方法 描述
      Set<ObjectInstance> MBeanServer.queryMBeans​(ObjectName name, QueryExp query)
      获取由MBean服务器控制的MBean。
      Set<ObjectInstance> MBeanServerConnection.queryMBeans​(ObjectName name, QueryExp query)
      获取由MBean服务器控制的MBean。
      Set<ObjectName> MBeanServer.queryNames​(ObjectName name, QueryExp query)
      获取由MBean服务器控制的MBean的名称。
      Set<ObjectName> MBeanServerConnection.queryNames​(ObjectName name, QueryExp query)
      获取由MBean服务器控制的MBean的名称。

    • Uses of Set in javax.management.loading

      Methods in javax.management.loading that return Set
      Modifier and Type 方法 描述
      Set<Object> MLet.getMBeansFromURL​(String url)
      加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。
      Set<Object> MLet.getMBeansFromURL​(URL url)
      加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。
      Set<Object> MLetMBean.getMBeansFromURL​(String url)
      加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。
      Set<Object> MLetMBean.getMBeansFromURL​(URL url)
      加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

    • Uses of Set in javax.management.openmbean

      Methods in javax.management.openmbean that return Set
      Modifier and Type 方法 描述
      Set<Map.Entry<Object,Object>> TabularDataSupport.entrySet​()
      返回此 TabularDataSupport实例中包含的行映射索引的集合视图。
      Set<?> OpenMBeanAttributeInfoSupport.getLegalValues​()
      返回此 OpenMBeanAttributeInfoSupport实例（如果指定）描述的属性的不可修改的合法值集合，否则 null 。
      Set<?> OpenMBeanParameterInfo.getLegalValues​()
      返回此参数的合法值集合，如果它有一个，否则 null 。
      Set<?> OpenMBeanParameterInfoSupport.getLegalValues​()
      返回此 OpenMBeanParameterInfoSupport实例（如果指定）描述的参数的不可修改的合法值集，否则 null 。
      Set<String> CompositeType.keySet​()
      返回此 CompositeType实例定义的所有项目名称的不可修改的集合视图。
      Set<?> TabularData.keySet​()
      返回 TabularData实例中包含的 CompositeData值（即行）的键的集合视图（即索引值）。
      Set<Object> TabularDataSupport.keySet​()
      返回用于对行进行索引的 TabularDataSupport实例的底层映射中包含的键的集视图。

    • Uses of Set in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return Set
      Modifier and Type | 方法 | 描述
      Set<ObjectInstance> RMIConnection.queryMBeans​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      处理方法 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 。
      Set | RMIConnectionImpl_Stub.queryMBeans​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectInstance> | RMIConnectionImpl.queryMBeans​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectName> RMIConnection.queryNames​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      处理方法 MBeanServerConnection.queryNames(ObjectName, QueryExp) 。
      Set | RMIConnectionImpl_Stub.queryNames​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectName> | RMIConnectionImpl.queryNames​(ObjectName name, MarshalledObject query, Subject delegationSubject)

    • Uses of Set in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement Set
      Modifier and Type Class 描述
      class  JobStateReasons
      JobStateReasons类是一个打印属性类，一组枚举值，它提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。
      Methods in javax.print.attribute.standard that return Set
      Modifier and Type 方法 描述
      Set<PrinterStateReason> PrinterStateReasons.printerStateReasonSet​(Severity severity)
      在此PrinterStateReasons属性中，以给定的严重级别获取不可修改的打印机状态原因属性的集合视图。

    • Uses of Set in javax.script

      Methods in javax.script that return Set
      Modifier and Type 方法 描述
      Set<Map.Entry<String,Object>> SimpleBindings.entrySet​()
      返回此地图中包含的映射的Set视图。
      Set<String> SimpleBindings.keySet​()
      返回此地图中包含的键的Set视图。

    • Uses of Set in javax.security.auth

      Methods in javax.security.auth that return Set
      Modifier and Type 方法 描述
      Set<Principal> Subject.getPrincipals​()
      返回 Set与此相关的校长 Subject 。
      <T extends Principal>
      Set<T>             		Subject.getPrincipals​(Class<T> c)
      返回 Set与此关联的Principal Subject是实例或指定的子类 Class 。
      Set<Object> Subject.getPrivateCredentials​()
      返回 Set的私人证书 Subject 。
      <T> Set<T> Subject.getPrivateCredentials​(Class<T> c)
      返回一个 Set与此相关的私有证书 Subject是实例或指定的子类 Class 。
      Set<Object> Subject.getPublicCredentials​()
      退回 Set的公开证书 Subject 。
      <T> Set<T> Subject.getPublicCredentials​(Class<T> c)
      返回一个 Set与此相关的公开证书 Subject是实例或指定的子类 Class 。
      Constructors in javax.security.auth with parameters of type Set
      Constructor 描述
      Subject​(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
      使用主体和凭据创建一个 Subject的实例。

    • Uses of Set in javax.swing

      Methods in javax.swing with parameters of type Set
      Modifier and Type 方法 描述
      void JComponent.setFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置此组件给定遍历操作的焦点遍历键。

    • Uses of Set in javax.tools

      Methods in javax.tools that return Set
      Modifier and Type 方法 描述
      Set<SourceVersion> Tool.getSourceVersions​()
      返回此工具支持的Java™编程语言的源代码版本。
      Methods in javax.tools that return types with arguments of type Set
      Modifier and Type | 方法 | 描述
      Iterable<Set<JavaFileManager.Location>> | ForwardingJavaFileManager.listLocationsForModules​(JavaFileManager.Location location)
      default Iterable<Set<JavaFileManager.Location>> JavaFileManager.listLocationsForModules​(JavaFileManager.Location location)
      列出面向模块的位置或输出位置中所有模块的位置。
      Methods in javax.tools with parameters of type Set
      Modifier and Type | 方法 | 描述
      Iterable<JavaFileObject> | ForwardingJavaFileManager.list​(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Iterable<JavaFileObject> JavaFileManager.list​(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      列出与给定的面向对象位置匹配的所有文件对象。

    • Uses of Set in javax.xml.ws

      Methods in javax.xml.ws that return Set
      Modifier and Type 方法 描述
      abstract Set<Endpoint> EndpointContext.getEndpoints​()
      这给出了应用程序中的端点列表。

    • Uses of Set in javax.xml.ws.handler.soap

      Methods in javax.xml.ws.handler.soap that return Set
      Modifier and Type 方法 描述
      Set<QName> SOAPHandler.getHeaders​()
      获取可由此处理程序实例处理的标题块。
      Set<String> SOAPMessageContext.getRoles​()
      获取与执行处理程序链相关联的SOAP actor角色。

    • Uses of Set in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return Set
      Modifier and Type 方法 描述
      Set<String> SOAPBinding.getRoles​()
      获取SOAP绑定实例扮演的角色。
      Methods in javax.xml.ws.soap with parameters of type Set
      Modifier and Type 方法 描述
      void SOAPBinding.setRoles​(Set<String> roles)
      设置SOAP绑定实例扮演的角色。

    • Uses of Set in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return Set
      Modifier and Type 方法 描述
      abstract Set<String> HttpContext.getAttributeNames​()
      返回容器配置的所有属性名称和jax-ws运行时可以使用的其他数据。
      abstract Set<String> HttpExchange.getAttributeNames​()
      提供与此 HttpExchange相关联的所有属性名称。

    • Uses of Set in jdk.dynalink.beans

      Methods in jdk.dynalink.beans that return Set
      Modifier and Type 方法 描述
      static Set<String> BeansLinker.getInstanceMethodNames​(Class<?> clazz)
      返回一组类的所有实例方法的名称。
      static Set<String> BeansLinker.getReadableInstancePropertyNames​(Class<?> clazz)
      返回一组类的所有可读实例属性的名称。
      static Set<String> BeansLinker.getReadableStaticPropertyNames​(Class<?> clazz)
      返回一组类的所有可读静态属性的名称。
      static Set<String> BeansLinker.getStaticMethodNames​(Class<?> clazz)
      返回类的所有静态方法的一组名称。
      static Set<String> BeansLinker.getWritableInstancePropertyNames​(Class<?> clazz)
      返回一组类的所有可写实例属性的名称。
      static Set<String> BeansLinker.getWritableStaticPropertyNames​(Class<?> clazz)
      返回一组类的所有可写静态属性的名称。

    • Uses of Set in jdk.incubator.http

      Methods in jdk.incubator.http that return Set
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<HttpRequest,CompletableFuture<HttpResponse<V>>>> | MultiMapResult.entrySet​()
      Set<HttpRequest> | MultiMapResult.keySet​()

    • Uses of Set in jdk.javadoc.doclet

      Methods in jdk.javadoc.doclet that return Set
      Modifier and Type | 方法 | 描述
      Set<Taglet.Location> Taglet.getAllowedLocations​()
      返回可以使用标签的位置集合。
      Set<? extends Element> DocletEnvironment.getIncludedElements​()
      返回文档中应为 included的模块，包和类型元素。
      Set<? extends Element> DocletEnvironment.getSpecifiedElements​()
      调用工具时返回元素 specified 。
      Set<? extends Doclet.Option> Doclet.getSupportedOptions​()
      返回所有支持的选项。
      Set<Doclet.Option> | StandardDoclet.getSupportedOptions​()

    • Uses of Set in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that return Set
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<String,Object>> | ScriptObjectMirror.entrySet​()
      Set<String> | AbstractJSObject.keySet​()
      Set<String> JSObject.keySet​()
      返回此对象的所有属性名称集。
      Set<String> | ScriptObjectMirror.keySet​()

    • Uses of Set in jdk.net

      Methods in jdk.net that return Set
      Modifier and Type 方法 描述
      static Set<SocketOption<?>> Sockets.supportedOptions​(Class<?> socketType)
      返回给定套接字类型支持的一组SocketOption s。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.SortedMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.SortedMap

  • Packages that use SortedMap
    软件包 描述
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of SortedMap in java.nio.charset

      Methods in java.nio.charset that return SortedMap
      Modifier and Type 方法 描述
      static SortedMap<String,Charset> Charset.availableCharsets​()
      构造从规范字符集名称到字符集对象的排序映射。

    • Uses of SortedMap in java.util

      Subinterfaces of SortedMap in java.util
      Modifier and Type 接口 描述
      interface  NavigableMap<K,V>
      A SortedMap扩展了导航方法，为给定的搜索目标返回最接近的匹配。
      Classes in java.util that implement SortedMap
      Modifier and Type Class 描述
      class  TreeMap<K,V>
      一个基于红黑树的NavigableMap实现。
      Methods in java.util that return SortedMap
      Modifier and Type | 方法 | 描述
      static <K,V> SortedMap<K,V> Collections.checkedSortedMap​(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定排序映射的动态类型安全视图。
      static <K,V> SortedMap<K,V> Collections.emptySortedMap​()
      返回空的排序映射（immutable）。
      SortedMap<K,V> NavigableMap.headMap​(K toKey)
      返回该地图的部分密钥严格小于 toKey 。
      SortedMap<K,V> SortedMap.headMap​(K toKey)
      返回此地图部分的视图，其密钥严格小于 toKey 。
      SortedMap<K,V> | TreeMap.headMap​(K toKey)
      SortedMap<K,V> NavigableMap.subMap​(K fromKey, K toKey)
      返回该地图部分的视图，其关键字范围从 fromKey （含）到 toKey ，独占。
      SortedMap<K,V> SortedMap.subMap​(K fromKey, K toKey)
      返回此地图部分的视图，其关键字范围从 fromKey （含）到 toKey ，独占。
      SortedMap<K,V> | TreeMap.subMap​(K fromKey, K toKey)
      static <K,V> SortedMap<K,V> Collections.synchronizedSortedMap​(SortedMap<K,V> m)
      返回由指定的排序映射支持的同步（线程安全）排序映射。
      SortedMap<K,V> NavigableMap.tailMap​(K fromKey)
      返回此地图部分的视图，其键大于或等于 fromKey 。
      SortedMap<K,V> SortedMap.tailMap​(K fromKey)
      返回此地图部分的视图，其键大于或等于 fromKey 。
      SortedMap<K,V> | TreeMap.tailMap​(K fromKey)
      static <K,V> SortedMap<K,V> Collections.unmodifiableSortedMap​(SortedMap<K,? extends V> m)
      返回指定排序映射的不可修改视图。
      Methods in java.util with parameters of type SortedMap
      Modifier and Type 方法 描述
      static <K,V> SortedMap<K,V> Collections.checkedSortedMap​(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定排序映射的动态类型安全视图。
      static <K,V> SortedMap<K,V> Collections.synchronizedSortedMap​(SortedMap<K,V> m)
      返回由指定的排序映射支持的同步（线程安全）排序映射。
      static <K,V> SortedMap<K,V> Collections.unmodifiableSortedMap​(SortedMap<K,? extends V> m)
      返回指定排序映射的不可修改视图。
      Constructors in java.util with parameters of type SortedMap
      Constructor 描述
      TreeMap​(SortedMap<K,? extends V> m)
      构造一个包含相同映射并使用与指定排序映射相同顺序的新树映射。

    • Uses of SortedMap in java.util.concurrent

      Subinterfaces of SortedMap in java.util.concurrent
      Modifier and Type 接口 描述
      interface  ConcurrentNavigableMap<K,V>
      A ConcurrentMap支持NavigableMap操作，并递归地为其可导航的子地图。
      Classes in java.util.concurrent that implement SortedMap
      Modifier and Type Class 描述
      class  ConcurrentSkipListMap<K,V>
      可扩展并发ConcurrentNavigableMap实现。
      Constructors in java.util.concurrent with parameters of type SortedMap
      Constructor 描述
      ConcurrentSkipListMap​(SortedMap<K,? extends V> m)
      构造一个包含相同映射并使用与指定排序映射相同顺序的新映射。

    • Uses of SortedMap in java.util.jar

      Methods in java.util.jar that return SortedMap
      Modifier and Type 方法 描述
      SortedMap<String,String> Pack200.Packer.properties​()
      获取此引擎的属性集。
      SortedMap<String,String> Pack200.Unpacker.properties​()
      获取此引擎的属性集。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.SortedSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.SortedSet

  • Packages that use SortedSet
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of SortedSet in java.util

      Subinterfaces of SortedSet in java.util
      Modifier and Type 接口 描述
      interface  NavigableSet<E>
      A SortedSet扩展了报告与给定搜索目标最匹配的导航方法。
      Classes in java.util that implement SortedSet
      Modifier and Type Class 描述
      class  TreeSet<E>
      A NavigableSet实现基于TreeMap 。
      Methods in java.util that return SortedSet
      Modifier and Type | 方法 | 描述
      static <E> SortedSet<E> Collections.checkedSortedSet​(SortedSet<E> s, Class<E> type)
      返回指定排序集的动态类型安全视图。
      static <E> SortedSet<E> Collections.emptySortedSet​()
      返回一个空的排序集（immutable）。
      SortedSet<E> NavigableSet.headSet​(E toElement)
      返回该集合的部分的视图，其元素严格小于 toElement 。
      SortedSet<E> SortedSet.headSet​(E toElement)
      返回该集合的部分的视图，其元素严格小于 toElement 。
      SortedSet<E> | TreeSet.headSet​(E toElement)
      SortedSet<E> NavigableSet.subSet​(E fromElement, E toElement)
      返回此集合的部分的视图，其元素的范围从 fromElement （含）到 toElement ，独占。
      SortedSet<E> SortedSet.subSet​(E fromElement, E toElement)
      返回此集合的部分的视图，其元素的范围从 fromElement （含）到 toElement ，独占。
      SortedSet<E> | TreeSet.subSet​(E fromElement, E toElement)
      static <T> SortedSet<T> Collections.synchronizedSortedSet​(SortedSet<T> s)
      返回由指定的排序集支持的同步（线程安全）排序集。
      SortedSet<E> NavigableSet.tailSet​(E fromElement)
      返回该集合的部分的视图，该部分的元素大于或等于 fromElement 。
      SortedSet<E> SortedSet.tailSet​(E fromElement)
      返回该集合的部分的视图，该部分的元素大于或等于 fromElement 。
      SortedSet<E> | TreeSet.tailSet​(E fromElement)
      static <T> SortedSet<T> Collections.unmodifiableSortedSet​(SortedSet<T> s)
      返回指定排序集的不可修改视图。
      Methods in java.util with parameters of type SortedSet
      Modifier and Type 方法 描述
      static <E> SortedSet<E> Collections.checkedSortedSet​(SortedSet<E> s, Class<E> type)
      返回指定排序集的动态类型安全视图。
      static <T> SortedSet<T> Collections.synchronizedSortedSet​(SortedSet<T> s)
      返回由指定的排序集支持的同步（线程安全）排序集。
      static <T> SortedSet<T> Collections.unmodifiableSortedSet​(SortedSet<T> s)
      返回指定排序集的不可修改视图。
      Constructors in java.util with parameters of type SortedSet
      Constructor 描述
      PriorityQueue​(SortedSet<? extends E> c)
      创建包含指定排序集中的元素的 PriorityQueue 。
      TreeSet​(SortedSet<E> s)
      构造一个包含相同元素的新树，并使用与指定排序集相同的顺序。

    • Uses of SortedSet in java.util.concurrent

      Classes in java.util.concurrent that implement SortedSet
      Modifier and Type Class 描述
      class  ConcurrentSkipListSet<E>
      可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
      Constructors in java.util.concurrent with parameters of type SortedSet
      Constructor 描述
      ConcurrentSkipListSet​(SortedSet<E> s)
      构造一个包含相同元素并使用与指定排序集相同顺序的新集合。

    • Uses of SortedSet in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return SortedSet
      Modifier and Type 方法 描述
      SortedSet<String> TIFFTagSet.getTagNames​()
      检索不可修改的词典增加的标签名称集合。
      SortedSet<Integer> TIFFTagSet.getTagNumbers​()
      检索一个不可修改的数字增加的标签号集合。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Spliterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Spliterator

  • Packages that use Spliterator
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of Spliterator in java.lang

      Methods in java.lang that return Spliterator
      Modifier and Type 方法 描述
      default Spliterator<T> Iterable.spliterator​()
      在Iterable描述的元素上创建一个Iterable 。

    • Uses of Spliterator in java.util

      Subinterfaces of Spliterator in java.util
      Modifier and Type 接口 描述
      static interface  Spliterator.OfDouble
      A Spliterator专门为 double值。
      static interface  Spliterator.OfInt
      一个Spliterator专门为 int值。
      static interface  Spliterator.OfLong
      A Spliterator专门为 long值。
      static interface  Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>
      专门针对原始价值观的Spliterator。
      Classes in java.util that implement Spliterator
      Modifier and Type Class 描述
      static class  Spliterators.AbstractDoubleSpliterator
      摘要 Spliterator.OfDouble实现了 trySplit以允许有限的并行性。
      static class  Spliterators.AbstractIntSpliterator
      摘要 Spliterator.OfInt实现了 trySplit以允许有限的并行性。
      static class  Spliterators.AbstractLongSpliterator
      摘要 Spliterator.OfLong实现 trySplit以允许有限的并行性。
      static class  Spliterators.AbstractSpliterator<T>
      摘要 Spliterator实现 trySplit以允许有限的并行性。
      Methods in java.util that return Spliterator
      Modifier and Type 方法 描述
      static <T> Spliterator<T> Spliterators.emptySpliterator​()
      创建一个空的 Spliterator
      Spliterator<E> ArrayDeque.spliterator​()
      在此deque中的元素上创建一个late-binding和失败快速的 Spliterator 。
      Spliterator<E> ArrayList.spliterator​()
      在此列表中的元素上创建late-binding和故障快速 Spliterator 。
      static <T> Spliterator<T> Arrays.spliterator​(T[] array)
      返回一个覆盖所有指定数组的Spliterator 。
      static <T> Spliterator<T> Arrays.spliterator​(T[] array, int startInclusive, int endExclusive)
      返回覆盖指定数组的指定范围的Spliterator 。
      default Spliterator<E> Collection.spliterator​()
      在此集合中的元素上创建一个Spliterator 。
      Spliterator<E> HashSet.spliterator​()
      在此集合中的元素上创建late-binding和故障快速 Spliterator 。
      Spliterator<E> LinkedHashSet.spliterator​()
      在此集合中的元素上创建 late-binding和 故障快速 Spliterator 。
      Spliterator<E> LinkedList.spliterator​()
      在此列表中的元素上创建late-binding和故障快速 Spliterator 。
      default Spliterator<E> List.spliterator​()
      在此列表中的元素上创建一个Spliterator 。
      Spliterator<E> PriorityQueue.spliterator​()
      在此队列中的元素上创建late-binding和故障快速 Spliterator 。
      default Spliterator<E> Set.spliterator​()
      在此集合中的元素上创建一个 Spliterator 。
      default Spliterator<E> SortedSet.spliterator​()
      在此排序集中的元素上创建一个 Spliterator 。
      static <T> Spliterator<T> Spliterators.spliterator​(Object[] array, int additionalCharacteristics)
      创建一个 Spliterator ，使用自定义的一组拼接器特征来覆盖给定数组的元素。
      static <T> Spliterator<T> Spliterators.spliterator​(Object[] array, int fromIndex, int toIndex, int additionalCharacteristics)
      创建一个 Spliterator涵盖了一组给定阵列的元素，使用了一组自定义的拼接器特性。
      static <T> Spliterator<T> Spliterators.spliterator​(Collection<? extends T> c, int characteristics)
      使用给定集合的 Collection.iterator()作为元素的来源创建一个 Spliterator ，并报告其 Collection.size()作为其初始大小。
      static <T> Spliterator<T> Spliterators.spliterator​(Iterator<? extends T> iterator, long size, int characteristics)
      创建一个 Spliterator使用给定的 Iterator作为元素的来源，并给出最初报告的大小。
      Spliterator<E> TreeSet.spliterator​()
      在此集合中的元素上创建late-binding和故障快速 Spliterator 。
      Spliterator<E> Vector.spliterator​()
      在此列表中的元素上创建late-binding和故障快速 Spliterator 。
      static <T> Spliterator<T> Spliterators.spliteratorUnknownSize​(Iterator<? extends T> iterator, int characteristics)
      创建一个 Spliterator使用给定的 Iterator作为元素的来源，没有初始大小估计。
      Spliterator<T> Spliterator.trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。
      Spliterator<T> Spliterators.AbstractSpliterator.trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。
      Methods in java.util with parameters of type Spliterator
      Modifier and Type 方法 描述
      static <T> Iterator<T> Spliterators.iterator​(Spliterator<? extends T> spliterator)
      创建一个 Iterator从 Spliterator 。

    • Uses of Spliterator in java.util.concurrent

      Methods in java.util.concurrent that return Spliterator
      Modifier and Type | 方法 | 描述
      Spliterator<E> ArrayBlockingQueue.spliterator​()
      返回此队列中的元素Spliterator 。
      Spliterator<K> | ConcurrentHashMap.KeySetView.spliterator​()
      Spliterator<E> ConcurrentLinkedDeque.spliterator​()
      在此deque中的元素上返回Spliterator 。
      Spliterator<E> ConcurrentLinkedQueue.spliterator​()
      返回此队列中元素的Spliterator 。
      Spliterator<E> ConcurrentSkipListSet.spliterator​()
      返回此集合中的元素Spliterator 。
      Spliterator<E> CopyOnWriteArrayList.spliterator​()
      在此列表中的元素上返回Spliterator 。
      Spliterator<E> CopyOnWriteArraySet.spliterator​()
      以这些元素的添加顺序返回此集合中的元素Spliterator 。
      Spliterator<E> LinkedBlockingDeque.spliterator​()
      在此deque中的元素上返回Spliterator 。
      Spliterator<E> LinkedBlockingQueue.spliterator​()
      返回此队列中的元素Spliterator 。
      Spliterator<E> LinkedTransferQueue.spliterator​()
      返回此队列中的元素Spliterator 。
      Spliterator<E> PriorityBlockingQueue.spliterator​()
      返回此队列中的元素Spliterator 。
      Spliterator<E> SynchronousQueue.spliterator​()
      返回一个空的拼接器，其中对 trySplit()的调用总是返回 null 。

    • Uses of Spliterator in java.util.stream

      Methods in java.util.stream that return Spliterator
      Modifier and Type 方法 描述
      Spliterator<T> BaseStream.spliterator​()
      返回此流的元素的拼接器。
      Methods in java.util.stream with parameters of type Spliterator
      Modifier and Type 方法 描述
      static <T> Stream<T> StreamSupport.stream​(Spliterator<T> spliterator, boolean parallel)
      创建一个新的串行或并行 Stream从 Spliterator 。
      Method parameters in java.util.stream with type arguments of type Spliterator
      Modifier and Type 方法 描述
      static <T> Stream<T> StreamSupport.stream​(Supplier<? extends Spliterator<T>> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 Stream从 Supplier的 Spliterator 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Spliterator.OfDouble (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Spliterator.OfDouble

  • Packages that use Spliterator.OfDouble
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of Spliterator.OfDouble in java.util

      Classes in java.util that implement Spliterator.OfDouble
      Modifier and Type Class 描述
      static class  Spliterators.AbstractDoubleSpliterator
      摘要 Spliterator.OfDouble实现了 trySplit以允许有限的并行性。
      Methods in java.util that return Spliterator.OfDouble
      Modifier and Type | 方法 | 描述
      static Spliterator.OfDouble Spliterators.emptyDoubleSpliterator​()
      创建一个空的 Spliterator.OfDouble
      static Spliterator.OfDouble Arrays.spliterator​(double[] array)
      返回一个覆盖所有指定数组的Spliterator.OfDouble 。
      static Spliterator.OfDouble Arrays.spliterator​(double[] array, int startInclusive, int endExclusive)
      返回覆盖指定数组的指定范围的Spliterator.OfDouble 。
      static Spliterator.OfDouble Spliterators.spliterator​(double[] array, int additionalCharacteristics)
      创建一个 Spliterator.OfDouble ，使用一组自定义的拼接器特征来覆盖给定数组的元素。
      static Spliterator.OfDouble Spliterators.spliterator​(double[] array, int fromIndex, int toIndex, int additionalCharacteristics)
      创建一个 Spliterator.OfDouble涵盖给定数组的一系列元素，使用一组自定义的拼接器特征。
      static Spliterator.OfDouble Spliterators.spliterator​(PrimitiveIterator.OfDouble iterator, long size, int characteristics)
      使用给定的 DoubleStream.DoubleIterator作为元素的来源创建一个 Spliterator.OfDouble ，并给出最初报告的大小。
      static Spliterator.OfDouble Spliterators.spliteratorUnknownSize​(PrimitiveIterator.OfDouble iterator, int characteristics)
      创建一个 Spliterator.OfDouble使用给定的 DoubleStream.DoubleIterator作为元素的来源，没有初始大小估计。
      Spliterator.OfDouble | Spliterator.OfDouble.trySplit​()
      Spliterator.OfDouble Spliterators.AbstractDoubleSpliterator.trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。
      Methods in java.util with parameters of type Spliterator.OfDouble
      Modifier and Type 方法 描述
      static PrimitiveIterator.OfDouble Spliterators.iterator​(Spliterator.OfDouble spliterator)
      创建一个 PrimitiveIterator.OfDouble从 Spliterator.OfDouble 。

    • Uses of Spliterator.OfDouble in java.util.stream

      Methods in java.util.stream that return Spliterator.OfDouble
      Modifier and Type | 方法 | 描述
      Spliterator.OfDouble | DoubleStream.spliterator​()
      Methods in java.util.stream with parameters of type Spliterator.OfDouble
      Modifier and Type 方法 描述
      static DoubleStream StreamSupport.doubleStream​(Spliterator.OfDouble spliterator, boolean parallel)
      创建一个新的串行或并行 DoubleStream从 Spliterator.OfDouble 。
      Method parameters in java.util.stream with type arguments of type Spliterator.OfDouble
      Modifier and Type 方法 描述
      static DoubleStream StreamSupport.doubleStream​(Supplier<? extends Spliterator.OfDouble> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 DoubleStream从 Supplier的 Spliterator.OfDouble 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Spliterator.OfInt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Spliterator.OfInt

  • Packages that use Spliterator.OfInt
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of Spliterator.OfInt in java.util

      Classes in java.util that implement Spliterator.OfInt
      Modifier and Type Class 描述
      static class  Spliterators.AbstractIntSpliterator
      摘要 Spliterator.OfInt实现了 trySplit以允许有限的并行性。
      Methods in java.util that return Spliterator.OfInt
      Modifier and Type | 方法 | 描述
      static Spliterator.OfInt Spliterators.emptyIntSpliterator​()
      创建一个空的 Spliterator.OfInt
      static Spliterator.OfInt Arrays.spliterator​(int[] array)
      返回一个覆盖所有指定数组的Spliterator.OfInt 。
      static Spliterator.OfInt Arrays.spliterator​(int[] array, int startInclusive, int endExclusive)
      返回覆盖指定数组的指定范围的Spliterator.OfInt 。
      static Spliterator.OfInt Spliterators.spliterator​(int[] array, int additionalCharacteristics)
      创建一个 Spliterator.OfInt覆盖给定数组的元素，使用一组自定义的拼接器特征。
      static Spliterator.OfInt Spliterators.spliterator​(int[] array, int fromIndex, int toIndex, int additionalCharacteristics)
      创建一个 Spliterator.OfInt涵盖了一组给定阵列的元素，使用了一组自定义的拼接器特性。
      static Spliterator.OfInt Spliterators.spliterator​(PrimitiveIterator.OfInt iterator, long size, int characteristics)
      使用给定的 IntStream.IntIterator作为元素的来源创建一个 Spliterator.OfInt ，并给出最初报告的大小。
      static Spliterator.OfInt Spliterators.spliteratorUnknownSize​(PrimitiveIterator.OfInt iterator, int characteristics)
      创建一个 Spliterator.OfInt使用给定的 IntStream.IntIterator作为元素的来源，没有初始大小估计。
      Spliterator.OfInt | Spliterator.OfInt.trySplit​()
      Spliterator.OfInt Spliterators.AbstractIntSpliterator.trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。
      Methods in java.util with parameters of type Spliterator.OfInt
      Modifier and Type 方法 描述
      static PrimitiveIterator.OfInt Spliterators.iterator​(Spliterator.OfInt spliterator)
      创建一个 PrimitiveIterator.OfInt从 Spliterator.OfInt 。

    • Uses of Spliterator.OfInt in java.util.stream

      Methods in java.util.stream that return Spliterator.OfInt
      Modifier and Type | 方法 | 描述
      Spliterator.OfInt | IntStream.spliterator​()
      Methods in java.util.stream with parameters of type Spliterator.OfInt
      Modifier and Type 方法 描述
      static IntStream StreamSupport.intStream​(Spliterator.OfInt spliterator, boolean parallel)
      创建一个新的串行或并行 IntStream从 Spliterator.OfInt 。
      Method parameters in java.util.stream with type arguments of type Spliterator.OfInt
      Modifier and Type 方法 描述
      static IntStream StreamSupport.intStream​(Supplier<? extends Spliterator.OfInt> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 IntStream从 Supplier的 Spliterator.OfInt 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Spliterator.OfLong (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Spliterator.OfLong

  • Packages that use Spliterator.OfLong
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of Spliterator.OfLong in java.util

      Classes in java.util that implement Spliterator.OfLong
      Modifier and Type Class 描述
      static class  Spliterators.AbstractLongSpliterator
      摘要 Spliterator.OfLong实现了 trySplit以允许有限的并行性。
      Methods in java.util that return Spliterator.OfLong
      Modifier and Type | 方法 | 描述
      static Spliterator.OfLong Spliterators.emptyLongSpliterator​()
      创建一个空的 Spliterator.OfLong
      static Spliterator.OfLong Arrays.spliterator​(long[] array)
      返回覆盖所有指定数组的Spliterator.OfLong 。
      static Spliterator.OfLong Arrays.spliterator​(long[] array, int startInclusive, int endExclusive)
      返回覆盖指定数组的指定范围的Spliterator.OfLong 。
      static Spliterator.OfLong Spliterators.spliterator​(long[] array, int additionalCharacteristics)
      创建一个覆盖给定数组元素的 Spliterator.OfLong ，使用一组自定义的分割器特征。
      static Spliterator.OfLong Spliterators.spliterator​(long[] array, int fromIndex, int toIndex, int additionalCharacteristics)
      创建一个 Spliterator.OfLong覆盖给定阵列的一系列元素，使用一组自定义的拼接器特性。
      static Spliterator.OfLong Spliterators.spliterator​(PrimitiveIterator.OfLong iterator, long size, int characteristics)
      创建一个 Spliterator.OfLong使用给定的 LongStream.LongIterator作为元素的来源，并给出最初报告的大小。
      static Spliterator.OfLong Spliterators.spliteratorUnknownSize​(PrimitiveIterator.OfLong iterator, int characteristics)
      创建一个 Spliterator.OfLong使用给定的 LongStream.LongIterator作为元素的来源，没有初始大小估计。
      Spliterator.OfLong | Spliterator.OfLong.trySplit​()
      Spliterator.OfLong Spliterators.AbstractLongSpliterator.trySplit​()
      如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。
      Methods in java.util with parameters of type Spliterator.OfLong
      Modifier and Type 方法 描述
      static PrimitiveIterator.OfLong Spliterators.iterator​(Spliterator.OfLong spliterator)
      创建一个 PrimitiveIterator.OfLong从 Spliterator.OfLong 。

    • Uses of Spliterator.OfLong in java.util.stream

      Methods in java.util.stream that return Spliterator.OfLong
      Modifier and Type | 方法 | 描述
      Spliterator.OfLong | LongStream.spliterator​()
      Methods in java.util.stream with parameters of type Spliterator.OfLong
      Modifier and Type 方法 描述
      static LongStream StreamSupport.longStream​(Spliterator.OfLong spliterator, boolean parallel)
      创建一个新的串行或并行 LongStream从 Spliterator.OfLong 。
      Method parameters in java.util.stream with type arguments of type Spliterator.OfLong
      Modifier and Type 方法 描述
      static LongStream StreamSupport.longStream​(Supplier<? extends Spliterator.OfLong> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 LongStream从 Supplier的 Spliterator.OfLong 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.Spliterator.OfPrimitive (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.Spliterator.OfPrimitive

  • Packages that use Spliterator.OfPrimitive
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Spliterator.OfPrimitive in java.util

      Classes in java.util with type parameters of type Spliterator.OfPrimitive
      Modifier and Type 接口 描述
      static interface  Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>>
      专门针对原始价值观的Spliterator。
      Subinterfaces of Spliterator.OfPrimitive in java.util
      Modifier and Type 接口 描述
      static interface  Spliterator.OfDouble
      A Spliterator专门为 double值。
      static interface  Spliterator.OfInt
      一个Spliterator专门为 int值。
      static interface  Spliterator.OfLong
      一个Spliterator专门为 long值。
      Classes in java.util that implement Spliterator.OfPrimitive
      Modifier and Type Class 描述
      static class  Spliterators.AbstractDoubleSpliterator
      摘要 Spliterator.OfDouble实现了 trySplit以允许有限的并行性。
      static class  Spliterators.AbstractIntSpliterator
      摘要 Spliterator.OfInt实现了 trySplit以允许有限的并行性。
      static class  Spliterators.AbstractLongSpliterator
      摘要 Spliterator.OfLong实现 trySplit以允许有限的并行性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AbstractExecutorService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class AbstractExecutorService

  • java.lang.Object
    • java.util.concurrent.AbstractExecutorService
  • All Implemented Interfaces:
    Executor ， ExecutorService
    已知直接子类：
    ForkJoinPool ， ThreadPoolExecutor

    public abstract class AbstractExecutorService
extends Object
implements ExecutorService
    提供ExecutorService执行方法的默认实现。 此类实现submit ， invokeAny和invokeAll使用方法RunnableFuture通过返回newTaskFor ，其默认为FutureTask类此包中提供。 例如， submit(Runnable)的实现创建一个执行和返回的关联的RunnableFuture 。 子类可以覆盖newTaskFor方法返回RunnableFuture其他实现比FutureTask 。

    扩展示例 。 以下是自定义ThreadPoolExecutor使用CustomTask类而不是默认值FutureTask类的FutureTask ：

       public class CustomThreadPoolExecutor extends ThreadPoolExecutor { static class CustomTask<V> implements RunnableFuture<V> {...} protected <V> RunnableFuture<V> newTaskFor(Callable<V> c) { return new CustomTask<V>(c); } protected <V> RunnableFuture<V> newTaskFor(Runnable r, V v) { return new CustomTask<V>(r, v); } // ... add constructors, etc. }
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      AbstractExecutorService​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。
      <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。
      <T> T invokeAny​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回成功完成的结果（即，不抛出异常），如果有的话。
      <T> T invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。
      protected <T> RunnableFuture<T> newTaskFor​(Runnable runnable, T value)
      为给定的可运行和默认值返回一个 RunnableFuture 。
      protected <T> RunnableFuture<T> newTaskFor​(Callable<T> callable)
      为给定的可调用任务返回一个 RunnableFuture 。
      Future<?> submit​(Runnable task)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> Future<T> submit​(Runnable task, T result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> Future<T> submit​(Callable<T> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。

      • Methods inherited from interface java.util.concurrent.Executor

        execute

      • Methods inherited from interface java.util.concurrent.ExecutorService

        awaitTermination, isShutdown, isTerminated, shutdown, shutdownNow

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractExecutorService

        public AbstractExecutorService​()

    • 方法详细信息

      • newTaskFor

        protected <T> RunnableFuture<T> newTaskFor​(Runnable runnable,
                                           T value)
        为给定的可运行和默认值返回一个 RunnableFuture 。
        参数类型
        T - 给定值的类型
        参数
        runnable - 正在包装的可运行任务
        value - 返回的未来的默认值
        结果
        一个 RunnableFuture ，当运行时，将运行底层的可运行程序，并且作为一个 Future将产生给定的值作为其结果，并提供取消基础任务
        从以下版本开始：
        1.6

      • newTaskFor

        protected <T> RunnableFuture<T> newTaskFor​(Callable<T> callable)
        为给定的可调用任务返回一个 RunnableFuture 。
        参数类型
        T - 可调用结果的类型
        参数
        callable - 正在包装的可调用任务
        结果
        一个 RunnableFuture ，当运行时，将调用底层可调用，并作为一个 Future ，将产生可调用的结果作为其结果，并提供取消基础任务
        从以下版本开始：
        1.6

      • submit

        public Future<?> submit​(Runnable task)
        说明从接口ExecutorService复制
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 未来的get方法将在成功完成后返回null 。
        Specified by:
        submit在接口 ExecutorService
        参数
        task - 要提交的任务
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果任务为空

      • submit

        public <T> Future<T> submit​(Runnable task,
                            T result)
        说明从接口ExecutorService复制
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 未来的get方法将在成功完成后返回给定的结果。
        Specified by:
        submit在接口 ExecutorService
        参数类型
        T - 结果的类型
        参数
        task - 要提交的任务
        result - 结果返回
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果该任务无法安排执行
        NullPointerException - 如果任务为空

      • submit

        public <T> Future<T> submit​(Callable<T> task)
        说明从接口ExecutorService复制
        提交值返回任务以执行，并返回代表任务待处理结果的Future。 未来的get方法将在成功完成后返回任务的结果。

        如果您想立即阻止等待任务，您可以使用result = exec.submit(aCallable).get();表单的result = exec.submit(aCallable).get();

        注意： Executors类包括一组可以将其他常见的类似闭包的对象（例如PrivilegedAction）转换为Callable表单的方法，以便它们可以提交。

        Specified by:
        submit在接口 ExecutorService
        参数类型
        T - 任务结果的类型
        参数
        task - 提交的任务
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果该任务无法安排执行
        NullPointerException - 如果任务为空

      • invokeAny

        public <T> T invokeAny​(Collection<? extends Callable<T>> tasks)
                throws InterruptedException,
                       ExecutionException
        说明从接口ExecutorService复制
        执行给定的任务，返回成功完成的结果（即，不抛出异常），如果有的话。 正常或异常退货后，尚未完成的任务将被取消。 如果在此操作进行过程中修改了给定的集合，则此方法的结果是未定义的。
        Specified by:
        invokeAny在接口 ExecutorService
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        结果
        其中一个任务返回的结果
        异常
        InterruptedException - 如果等待中断
        ExecutionException - 如果没有任务成功完成

      • invokeAny

        public <T> T invokeAny​(Collection<? extends Callable<T>> tasks,
                       long timeout,
                       TimeUnit unit)
                throws InterruptedException,
                       ExecutionException,
                       TimeoutException
        说明从接口ExecutorService复制
        执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。 正常或异常退货后，尚未完成的任务将被取消。 如果在此操作进行过程中修改了给定的集合，则此方法的结果是未定义的。
        Specified by:
        invokeAny在接口 ExecutorService
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        其中一个任务返回的结果
        异常
        InterruptedException - 如果在等待时中断
        ExecutionException - 如果没有任务成功完成
        TimeoutException - 如果在任务成功完成之前已经过了给定的超时

      • invokeAll

        public <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks)
                              throws InterruptedException
        描述从接口ExecutorService复制
        执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。 Future.isDone()是返回列表的每个元素的true 。 请注意， 完成的任务可能会正常终止或抛出异常。 如果在此操作进行过程中修改了给定的集合，则此方法的结果是未定义的。
        Specified by:
        invokeAll在接口 ExecutorService
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        结果
        表示任务的期货列表，按照给定任务列表的迭代器产生的顺序顺序，每个都已完成
        异常
        InterruptedException - 如果在等待时中断，在这种情况下未完成的任务被取消

      • invokeAll

        public <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks,
                                     long timeout,
                                     TimeUnit unit)
                              throws InterruptedException
        描述从接口ExecutorService复制
        执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。 Future.isDone()是true对于返回列表的每个元素。 退货后，尚未完成的任务将被取消。 请注意， 完成的任务可能会正常终止或抛出异常。 如果在此操作进行过程中修改了给定的集合，则此方法的结果是未定义的。
        Specified by:
        invokeAll接口 ExecutorService
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        一个表示任务的期货列表，按照给定任务列表的迭代器生成的顺序。 如果操作没有超时，每个任务都会完成。 如果超时，其中一些任务将不会完成。
        异常
        InterruptedException - 如果在等待时中断，在这种情况下未完成的任务被取消
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ArrayBlockingQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ArrayBlockingQueue<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
        • java.util.concurrent.ArrayBlockingQueue<E>
  • 参数类型
    E - 保存在此队列中的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， BlockingQueue<E> ， Queue<E>

    public class ArrayBlockingQueue<E>
extends AbstractQueue<E>
implements BlockingQueue<E>, Serializable
    一个有限的blocking queue由数组支持。 这个队列排列元素FIFO（先进先出）。 队列的头部是队列中最长的元素。 队列的尾部是队列中最短时间的元素。 新元素插入队列的尾部，队列检索操作获取队列头部的元素。

    这是一个经典的“有界缓冲区”，其中固定大小的数组保存由生产者插入的元素并由消费者提取。 创建后，容量无法更改。 尝试将一个元素的put尝试到一个完整的队列中将导致操作阻塞; 尝试从一个空队列中的一个元素将同样地阻塞take 。

    此类支持可选的公平策略，用于订购等待的生产者和消费者线程。 默认情况下，此订单不能保证。 然而，由公平设置的队列设置为true以FIFO顺序授予线程访问权限。 公平性通常会降低吞吐量，但会降低变异性并避免饥饿。

    该类及其迭代器实现了Collection和Iterator接口的所有可选方法。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ArrayBlockingQueue​(int capacity)
      创建具有给定（固定）容量和默认访问策略的 ArrayBlockingQueue 。
      ArrayBlockingQueue​(int capacity, boolean fair)
      创建具有给定（固定）容量和指定访问策略的 ArrayBlockingQueue 。
      ArrayBlockingQueue​(int capacity, boolean fair, Collection<? extends E> c)
      创建具有给定（固定）容量的 ArrayBlockingQueue ，指定的访问策略，最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      如果可以立即在不超过队列的容量的情况下将指定的元素插入该队列的尾部，则在成功后返回 true ，如果该队列已满，则抛出 IllegalStateException 。
      void clear​()
      从这个队列中原子地删除所有的元素。
      boolean contains​(Object o)
      如果此队列包含指定的元素，则返回 true 。
      int drainTo​(Collection<? super E> c)
      从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
      int drainTo​(Collection<? super E> c, int maxElements)
      最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      Iterator<E> iterator​()
      以正确的顺序返回该队列中的元素的迭代器。
      boolean offer​(E e)
      插入指定的元素在这个队列的尾部，如果有可能立即这样做不超过该队列的容量，返回 true在成功和 false如果此队列已满。
      boolean offer​(E e, long timeout, TimeUnit unit)
      在该队列的尾部插入指定的元素，等待指定的等待时间，以使空间在队列已满时变为可用。
      E peek​()
      检索但不删除此队列的头，如果此队列为空，则返回 null 。
      E poll​()
      检索并删除此队列的头，如果此队列为空，则返回 null 。
      E poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
      void put​(E e)
      在该队列的尾部插入指定的元素，如果队列已满，则等待空间变为可用。
      int remainingCapacity​()
      返回此队列可以理想地（在没有内存或资源限制）的情况下接受而不阻止的附加元素数。
      boolean remove​(Object o)
      从该队列中删除指定元素的单个实例（如果存在）。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此队列中的元素数。
      Spliterator<E> spliterator​()
      返回此队列中的元素Spliterator 。
      E take​()
      检索并删除此队列的头，如有必要，等待元素可用。
      Object[] toArray​()
      以适当的顺序返回一个包含此队列中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此集合的字符串表示形式。

      • Methods inherited from class java.util.AbstractCollection

        containsAll, isEmpty

      • Methods inherited from class java.util.AbstractQueue

        addAll, element, remove

      • Methods inherited from interface java.util.Collection

        addAll, containsAll, equals, hashCode, isEmpty, parallelStream, stream

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Queue

        element, remove

    • 构造方法详细信息

      • ArrayBlockingQueue

        public ArrayBlockingQueue​(int capacity)
        创建具有给定（固定）容量和默认访问策略的 ArrayBlockingQueue 。
        参数
        capacity - 该队列的容量
        异常
        IllegalArgumentException - 如果是 capacity < 1

      • ArrayBlockingQueue

        public ArrayBlockingQueue​(int capacity,
                          boolean fair)
        创建具有给定（固定）容量和指定访问策略的 ArrayBlockingQueue 。
        参数
        capacity - 这个队列的容量
        fair - 如果true然后对插入或删除阻塞的线程进行队列访问， true FIFO顺序处理; 如果false访问顺序未指定。
        异常
        IllegalArgumentException - 如果是 capacity < 1

      • ArrayBlockingQueue

        public ArrayBlockingQueue​(int capacity,
                          boolean fair,
                          Collection<? extends E> c)
        创建具有给定（固定）容量的 ArrayBlockingQueue ，指定的访问策略，最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
        参数
        capacity - 这个队列的容量
        fair - 如果true然后对插入或删除阻塞的线程进行队列访问， true FIFO顺序处理; 如果false访问顺序是未指定的。
        c - 最初包含的元素的集合
        异常
        IllegalArgumentException - 如果 capacity小于 c.size() ，或小于1。
        NullPointerException - 如果指定的集合或其任何元素为空

    • 方法详细信息

      • add

        public boolean add​(E e)
        在插入此队列的尾部，如果有可能立即这样做不超过该队列的容量，返回指定的元素 true成功时与抛出 IllegalStateException如果此队列已满。
        Specified by:
        add在接口 BlockingQueue<E>
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractQueue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        IllegalStateException - 如果此队列已满
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        插入指定的元素在这个队列的尾部，如果有可能立即这样做不超过该队列的容量，返回true在成功和false如果此队列已满。 该方法通常优于方法add(E) ，其可以仅通过抛出异常来插入元素。
        Specified by:
        offer接口 BlockingQueue<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到此队列，否则为 false
        异常
        NullPointerException - 如果指定的元素为空

      • put

        public void put​(E e)
         throws InterruptedException
        在该队列的尾部插入指定的元素，如果队列已满，则等待空间变为可用。
        Specified by:
        put在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        异常
        InterruptedException - 如果在等待时中断
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e,
                     long timeout,
                     TimeUnit unit)
              throws InterruptedException
        在该队列的尾部插入指定的元素，等待指定的等待时间，以使空间在队列已满时变为可用。
        Specified by:
        offer在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在空间可用之前经过指定的等待时间
        异常
        InterruptedException - 如果在等待时中断
        NullPointerException - 如果指定的元素为空

      • poll

        public E poll​()
        描述从接口Queue复制
        检索并删除此队列的头，如果此队列为空，则返回 null 。
        Specified by:
        poll在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • take

        public E take​()
       throws InterruptedException
        描述从接口BlockingQueue复制
        检索并删除此队列的头，如有必要，等待元素可用。
        Specified by:
        take在接口 BlockingQueue<E>
        结果
        这个队列的头
        异常
        InterruptedException - 如果在等待时中断

      • poll

        public E poll​(long timeout,
              TimeUnit unit)
       throws InterruptedException
        描述从接口BlockingQueue复制
        检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
        Specified by:
        poll在接口 BlockingQueue<E>
        参数
        timeout - 放弃之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        该队列的头部，或者如果在元素可用之前经过指定的等待时间， null
        异常
        InterruptedException - 如果中断等待

      • peek

        public E peek​()
        说明从接口Queue复制
        检索但不删除此队列的头，如果此队列为空，则返回 null 。
        Specified by:
        peek在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • size

        public int size​()
        返回此队列中的元素数。
        Specified by:
        size接口 Collection<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此队列中的元素数

      • remainingCapacity

        public int remainingCapacity​()
        返回此队列可以理想地（在没有内存或资源限制）的情况下接受而不阻止的附加元素数。 这总是等于该队列的初始容量少于此队列的当前size 。

        请注意，您不能总是通过检查remainingCapacity来确定插入元素的尝试是否成功，因为可能是另一个线程即将插入或删除元素的情况。

        Specified by:
        remainingCapacity接口 BlockingQueue<E>
        结果
        剩余容量

      • remove

        public boolean remove​(Object o)
        从该队列中删除指定元素的单个实例（如果存在）。 更正式地，删除元素e ，使得o.equals(e) ，如果该队列包含一个或多个这样的元素。 如果此队列包含指定的元素（或等效地，如果此队列作为调用的结果而更改），则返回true 。

        基于循环阵列的队列中的内部元素的删除是本质上缓慢和破坏性的操作，所以只应在特殊情况下进行，理想情况下只有当队列被其他线程知道时才能访问。

        Specified by:
        remove在接口 BlockingQueue<E>
        Specified by:
        remove在接口 Collection<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此队列中删除的元素（如果存在）
        结果
        true如果此队列由于调用而更改

      • contains

        public boolean contains​(Object o)
        如果此队列包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此队列至少包含一个元素e这样o.equals(e) 。
        Specified by:
        contains在接口 BlockingQueue<E>
        Specified by:
        contains在接口 Collection<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要检查此队列中的遏制的对象
        结果
        true如果此队列包含指定的元素

      • toArray

        public Object[] toArray​()
        以适当的顺序返回一个包含此队列中所有元素的数组。

        返回的数组将是“安全的”，因为该队列不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此队列中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果队列适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此队列的大小分配一个新数组。

        如果这个队列适合指定的数组空间（即，该数组具有比此队列更多的元素），则队列结束后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于阵列和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的队列。 以下代码可用于将队列转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储队列的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组
        结果
        一个包含此队列中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • toString

        public String toString​()
        描述从类复制： AbstractCollection
        返回此集合的字符串表示形式。 字符串表示由集合的元素的列表按照它们的迭代器返回的顺序包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 AbstractCollection<E>
        结果
        此集合的字符串表示形式

      • clear

        public void clear​()
        从这个队列中原子地删除所有的元素。 此呼叫返回后队列将为空。
        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractQueue<E>

      • drainTo

        public int drainTo​(Collection<? super E> c)
        说明从接口BlockingQueue复制
        从该队列中删除所有可用的元素，并将它们添加到给定的集合中。 此操作可能比重复轮询此队列更有效。 尝试向集合c添加元素时遇到的失败可能导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将队列排入自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 将元素传输到的集合
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定集合不支持元素的添加
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或该队列的某个元素的某些属性阻止将其添加到指定的集合

      • drainTo

        public int drainTo​(Collection<? super E> c,
                   int maxElements)
        描述从接口BlockingQueue复制
        最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。 尝试向集合c添加元素时遇到的失败可能导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将队列排入自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 传输元素的集合
        maxElements - 要传输的元素的最大数量
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定的集合不支持添加元素
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或此队列的某个元素的某些属性阻止将其添加到指定的集合

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回该队列中的元素的迭代器。 元素将按照从头（头）到最后（尾）的顺序返回。

        返回的迭代器是weakly consistent 。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        在该队列中的元素以适当的顺序迭代

      • spliterator

        public Spliterator<E> spliterator​()
        返回此队列中的元素Spliterator 。

        返回的拼接器是weakly consistent 。

        该Spliterator报告Spliterator.CONCURRENT ， Spliterator.ORDERED ，并Spliterator.NONNULL 。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Implementation Note:
        Spliterator实现 trySplit以允许有限的并行性。
        结果
        一个 Spliterator在这个队列中的元素
        从以下版本开始：
        1.8

      • forEach

        public void forEach​(Consumer<? super E> action)
        说明从接口Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        说明从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 为要删除的元素返回 true的谓词
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • removeAll

        public boolean removeAll​(Collection<?> c)
        说明从类别复制： AbstractCollection
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果此集合由于调用而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者指定的集合为null
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        描述从类复制： AbstractCollection
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果此集合由于调用而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BlockingDeque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface BlockingDeque<E>

  • 参数类型
    E - 在这个deque中持有的元素的类型
    All Superinterfaces:
    BlockingQueue<E> ， Collection<E> ， Deque<E> ， Iterable<E> ， Queue<E>
    所有已知实现类：
    LinkedBlockingDeque

    public interface BlockingDeque<E>
extends BlockingQueue<E>, Deque<E>
    A Deque另外支持在检索元素时等待deque变为非空的阻塞操作，并且等待在存储元素时在deque中可用的空间。

    BlockingDeque方法有四种形式，具有不同的处理方式，不能立即满足，但可能在将来的某个时间点满足：一个抛出异常，第二个返回一个特殊值（ null或false ，具体取决于操作），第三个程序将无限期地阻止当前线程，直到操作成功为止，而第四个程序块在放弃之前只有给定的最大时限。 这些方法总结在下表中：

    Summary of BlockingDeque methods First Element (Head) Throws exception Special value Blocks Times out Insert addFirst(e) offerFirst(e) putFirst(e) offerFirst(e, time, unit) Remove removeFirst() pollFirst() takeFirst() pollFirst(time, unit) Examine getFirst() peekFirst() not applicable not applicable Last Element (Tail) Throws exception Special value Blocks Times out Insert addLast(e) offerLast(e) putLast(e) offerLast(e, time, unit) Remove removeLast() pollLast() takeLast() pollLast(time, unit) Examine getLast() peekLast() not applicable not applicable

    像任何BlockingQueue一样， BlockingDeque是线程安全的，不允许空元素，并且可能（或可能不）是容量限制的。

    A BlockingDeque实现可以直接用作FIFO BlockingQueue 。 从BlockingQueue接口继承的方法正好等同于BlockingDeque方法，如下表所示：

    Comparison of BlockingQueue and BlockingDeque methods BlockingQueue Method Equivalent BlockingDeque Method Insert add(e) addLast(e) offer(e) offerLast(e) put(e) putLast(e) offer(e, time, unit) offerLast(e, time, unit) Remove remove() removeFirst() poll() pollFirst() take() takeFirst() poll(time, unit) pollFirst(time, unit) Examine element() getFirst() peek() peekFirst()

    存储器一致性效果：当与其他并发集合，事先将物体放置成在一个线程动作BlockingDeque happen-before到该元素的从访问或移除后续动作BlockingDeque在另一个线程。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素插入由此deque（换句话说，在该deque的尾部）表示的队列中，如果可以立即执行此操作而不违反容量限制， true在成功时返回 true ，如果当前没有可用空间，则抛出 IllegalStateException 。
      void addFirst​(E e)
      如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的前面，如果当前没有可用空间，则抛出一个 IllegalStateException 。
      void addLast​(E e)
      如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的末尾，则抛出一个 IllegalStateException如果当前没有空格）。
      boolean contains​(Object o)
      如果此deque包含指定的元素，则返回 true 。
      E element​()
      检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
      Iterator<E> iterator​()
      以正确的顺序返回此deque中的元素的迭代器。
      boolean offer​(E e)
      将指定的元素插入此双端队列表示的队列中（换句话说，在此双端队列的尾部），如果它是立即可行且不会违反容量限制，返回 true在成功和 false ，如果当前没有空间可用。
      boolean offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入由此deque表示的队列中（换句话说，在该deque的尾部），等待指定的等待时间（如果需要空间可用）。
      boolean offerFirst​(E e)
      插入此双端队列的前面，如果它是立即可行且不会违反容量限制，返回指定的元素 true在成功 false如果当前没有空间可用。
      boolean offerFirst​(E e, long timeout, TimeUnit unit)
      在此deque的前面插入指定的元素，等待指定的等待时间（如果需要空间可用）。
      boolean offerLast​(E e)
      插入此双端队列的末尾，如果它是立即可行且不会违反容量限制，返回指定的元素 true在成功 false如果当前没有空间可用。
      boolean offerLast​(E e, long timeout, TimeUnit unit)
      在此deque的末尾插入指定的元素，如果需要空间可用，等待指定的等待时间。
      E peek​()
      检索但不删除由此deque表示的队列的头部（换句话说，此deque的第一个元素），如果此deque为空，则返回 null 。
      E poll​()
      检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回 null 。
      E poll​(long timeout, TimeUnit unit)
      检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，等待到指定的等待时间（如有必要）使元素变为可用。
      E pollFirst​(long timeout, TimeUnit unit)
      检索并删除此deque的第一个元素，等待到指定的等待时间（如有必要）使元素变为可用。
      E pollLast​(long timeout, TimeUnit unit)
      检索并删除此deque的最后一个元素，等待到指定的等待时间，如果需要，元素可用。
      void push​(E e)
      将元素推送到由此deque表示的堆栈（换句话说，在此deque的头部），如果可能立即执行此操作而不违反容量限制，则抛出 IllegalStateException如果当前没有可用空间）。
      void put​(E e)
      将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），等待空格变为可用时。
      void putFirst​(E e)
      在此deque的前面插入指定的元素，如有必要，等待空格变为可用。
      void putLast​(E e)
      在此deque的末尾插入指定的元素，如有必要，等待空格变为可用。
      E remove​()
      检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
      boolean remove​(Object o)
      从此deque中删除指定元素的第一个出现。
      boolean removeFirstOccurrence​(Object o)
      从此deque中删除指定元素的第一个出现。
      boolean removeLastOccurrence​(Object o)
      从此deque中删除指定元素的最后一次出现。
      int size​()
      返回此deque中的元素数。
      E take​()
      检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，如果需要，等待，直到元素可用。
      E takeFirst​()
      检索并删除此deque的第一个元素，如有必要等待，直到元素可用。
      E takeLast​()
      检索并删除此deque的最后一个元素，如有必要等待，直到元素可用。

      • Methods inherited from interface java.util.concurrent.BlockingQueue

        drainTo, drainTo, remainingCapacity

      • Methods inherited from interface java.util.Collection

        clear, containsAll, equals, hashCode, isEmpty, parallelStream, removeAll, removeIf, retainAll, spliterator, stream, toArray, toArray

      • Methods inherited from interface java.util.Deque

        addAll, descendingIterator, getFirst, getLast, peekFirst, peekLast, pollFirst, pollLast, pop, removeFirst, removeLast

      • Methods inherited from interface java.lang.Iterable

        forEach

    • 方法详细信息

      • addFirst

        void addFirst​(E e)
        如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的前面，如果当前没有可用的空间，则抛出一个IllegalStateException 。 当使用容量限制的deque时，通常最好使用offerFirst 。
        Specified by:
        addFirst在接口 Deque<E>
        参数
        e - 要添加的元素
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • addLast

        void addLast​(E e)
        如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的末尾，如果当前没有可用的空间，则抛出一个IllegalStateException 。 当使用容量限制的deque时，通常最好使用offerLast 。
        Specified by:
        addLast在接口 Deque<E>
        参数
        e - 要添加的元素
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止它添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • offerFirst

        boolean offerFirst​(E e)
        插入此双端队列的前面，如果它是立即可行且不会违反容量限制，返回指定的元素true在成功false如果当前没有空间可用。 当使用容量限制的deque时，这种方法通常比addFirst方法更为方便 ，只能通过抛出异常来插入元素。
        Specified by:
        offerFirst在接口 Deque<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到此deque，否则为 false
        异常
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • offerLast

        boolean offerLast​(E e)
        插入此双端队列的末尾，如果它是立即可行且不会违反容量限制，返回指定的元素true在成功false如果当前没有空间可用。 当使用容量限制的deque时，这种方法通常比addLast方法更为方便 ，只能通过抛出异常来插入元素。
        Specified by:
        offerLast在接口 Deque<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到此deque，否则为 false
        异常
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • putFirst

        void putFirst​(E e)
       throws InterruptedException
        在此deque的前面插入指定的元素，如有必要，等待空格变为可用。
        参数
        e - 要添加的元素
        异常
        InterruptedException - 如果在等待时中断
        ClassCastException - 如果指定元素的类阻止它添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • putLast

        void putLast​(E e)
      throws InterruptedException
        在此deque的末尾插入指定的元素，如有必要，等待空格变为可用。
        参数
        e - 要添加的元素
        异常
        InterruptedException - 如果在等待时中断
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • offerFirst

        boolean offerFirst​(E e,
                   long timeout,
                   TimeUnit unit)
            throws InterruptedException
        在此deque的前面插入指定的元素，等待指定的等待时间（如果需要空间可用）。
        参数
        e - 要添加的元素
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在空间可用之前经过指定的等待时间
        异常
        InterruptedException - 如果等待中断
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • offerLast

        boolean offerLast​(E e,
                  long timeout,
                  TimeUnit unit)
           throws InterruptedException
        在此deque的末尾插入指定的元素，如果需要空间可用，等待指定的等待时间。
        参数
        e - 要添加的元素
        timeout - 放弃等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在空间可用之前经过指定的等待时间
        异常
        InterruptedException - 如果中断等待
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • takeFirst

        E takeFirst​()
     throws InterruptedException
        检索并删除此deque的第一个元素，如有必要等待，直到元素可用。
        结果
        这个德克的头
        异常
        InterruptedException - 如果在等待时中断

      • takeLast

        E takeLast​()
    throws InterruptedException
        检索并删除此deque的最后一个元素，如有必要等待，直到元素可用。
        结果
        这个德克的尾巴
        异常
        InterruptedException - 如果在等待时中断

      • pollFirst

        E pollFirst​(long timeout,
            TimeUnit unit)
     throws InterruptedException
        检索并删除此deque的第一个元素，等待到指定的等待时间（如有必要）使元素变为可用。
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        如果在元素可用之前经过了指定的等待时间，那么这个deque的头，或者是 null
        异常
        InterruptedException - 等待时中断

      • pollLast

        E pollLast​(long timeout,
           TimeUnit unit)
    throws InterruptedException
        检索并删除此deque的最后一个元素，等待到指定的等待时间，如果需要，元素可用。
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        如果在元素可用之前经过了指定的等待时间，则此deque的尾部，或 null
        异常
        InterruptedException - 如果在等待时中断

      • removeFirstOccurrence

        boolean removeFirstOccurrence​(Object o)
        从此deque中删除指定元素的第一个出现。 如果deque不包含元素，则它不变。 更正式地，删除第一元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而改变），则返回true 。
        Specified by:
        removeFirstOccurrence在接口 Deque<E>
        参数
        o - 要从此deque中删除的元素（如果存在）
        结果
        true如果一个元素被删除作为这个调用的结果
        异常
        ClassCastException - 如果指定元素的类与此deque不兼容（ optional ）
        NullPointerException - 如果指定的元素为空（ optional ）

      • removeLastOccurrence

        boolean removeLastOccurrence​(Object o)
        从此deque中删除指定元素的最后一次出现。 如果deque不包含元素，则它不变。 更正式地，删除最后一个元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果该deque由于调用而更改），则返回true 。
        Specified by:
        removeLastOccurrence在接口 Deque<E>
        参数
        o - 要从此deque移除的元素（如果存在）
        结果
        true如果一个元素被删除作为这个调用的结果
        异常
        ClassCastException - 如果指定元素的类与此deque不兼容（ optional ）
        NullPointerException - 如果指定的元素为空（ optional ）

      • add

        boolean add​(E e)
        将指定的元素插入由此deque（换句话说，在该deque的尾部）表示的队列中，如果可以立即执行，而不违反容量限制， true在成功后返回true ，如果当前没有可用空间，则抛出IllegalStateException 。 当使用容量限制的deque时，通常最好使用offer 。

        此方法相当于addLast 。

        Specified by:
        add在接口 BlockingQueue<E>
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Deque<E>
        Specified by:
        add在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • offer

        boolean offer​(E e)
        将指定的元素插入此双端队列表示的队列中（换句话说，在此双端队列的尾部），如果它是立即可行且不会违反容量限制，返回true在成功和false ，如果当前没有空间可用。 当使用容量限制的deque时，这种方法通常比add(E)方法更为方便 ，只能通过抛出异常来插入元素。

        此方法相当于offerLast 。

        Specified by:
        offer接口 BlockingQueue<E>
        Specified by:
        offer在接口 Deque<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到该队列，否则为 false
        异常
        ClassCastException - 如果指定元素的类阻止它添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • put

        void put​(E e)
  throws InterruptedException
        将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），等待空格变为可用时。

        此方法相当于putLast 。

        Specified by:
        put在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        异常
        InterruptedException - 如果在等待时中断
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • offer

        boolean offer​(E e,
              long timeout,
              TimeUnit unit)
       throws InterruptedException
        将指定的元素插入由此deque表示的队列中（换句话说，在该deque的尾部），等待指定的等待时间（如果需要空间可用）。

        此方法相当于offerLast 。

        Specified by:
        offer在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果元素被添加到此deque，否则为 false
        异常
        InterruptedException - 如果在等待时中断
        ClassCastException - 如果指定元素的类阻止它添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此deque

      • remove

        E remove​()
        检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。 此方法与poll不同之处在于，如果此deque为空，它将抛出异常。

        此方法相当于removeFirst 。

        Specified by:
        remove接口 Deque<E>
        Specified by:
        remove在接口 Queue<E>
        结果
        由这个德克队代表的队列的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • poll

        E poll​()
        检索并删除由此deque（换句话说，此deque的第一个元素）表示的队列的头部，如果此deque为空，则返回null 。

        此方法相当于Deque.pollFirst() 。

        Specified by:
        poll在接口 Deque<E>
        Specified by:
        poll在接口 Queue<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • take

        E take​()
throws InterruptedException
        检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，如果需要，等待，直到元素可用。

        此方法相当于takeFirst 。

        Specified by:
        take在接口 BlockingQueue<E>
        结果
        这个德克的头
        异常
        InterruptedException - 如果在等待时中断

      • poll

        E poll​(long timeout,
       TimeUnit unit)
throws InterruptedException
        检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，等待到指定的等待时间（如有必要）使元素变为可用。

        这个方法相当于pollFirst 。

        Specified by:
        poll在接口 BlockingQueue<E>
        参数
        timeout - 放弃等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        如果在元素可用之前经过了指定的等待时间，那么这个deque的头，或者是 null
        异常
        InterruptedException - 如果在等待时中断

      • element

        E element​()
        检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。 此方法与peek不同之处在于，如果此deque为空，它将抛出异常。

        此方法相当于getFirst 。

        Specified by:
        element在接口 Deque<E>
        Specified by:
        element在接口 Queue<E>
        结果
        这个德克的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • peek

        E peek​()
        检索但不删除由此deque表示的队列的头部（换句话说，此deque的第一个元素），如果此deque为空，则返回null 。

        此方法相当于peekFirst 。

        Specified by:
        peek在接口 Deque<E>
        Specified by:
        peek在接口 Queue<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • remove

        boolean remove​(Object o)
        从此deque中删除指定元素的第一个出现。 如果deque不包含元素，则它不变。 更正式地，删除第一元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。

        此方法相当于removeFirstOccurrence 。

        Specified by:
        remove在接口 BlockingQueue<E>
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 Deque<E>
        参数
        o - 要从此deque移除的元素（如果存在）
        结果
        true如果这个deque因呼叫而改变了
        异常
        ClassCastException - 如果指定元素的类与此deque不兼容（ optional ）
        NullPointerException - 如果指定的元素为空（ optional ）

      • contains

        boolean contains​(Object o)
        如果此deque包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此双端队列至少包含一个元素e这样o.equals(e) 。
        Specified by:
        contains在接口 BlockingQueue<E>
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Deque<E>
        参数
        o - 要在此 o中检查遏制的对象
        结果
        true如果这个deque包含指定的元素
        异常
        ClassCastException - 如果指定元素的类与此deque不兼容（ optional ）
        NullPointerException - 如果指定的元素为空（ optional ）

      • size

        int size​()
        返回此deque中的元素数。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Deque<E>
        结果
        这个deque中的元素数量

      • iterator

        Iterator<E> iterator​()
        以正确的顺序返回此deque中的元素的迭代器。 元素将按照从头（头）到最后（尾）的顺序返回。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Deque<E>
        Specified by:
        iterator在接口 Iterable<E>
        结果
        在这个deque中的元素以适当的顺序迭代

      • push

        void push​(E e)
        将元素推送到由此deque表示的堆栈（换句话说，在此deque的头部），如果可以立即执行此操作而不违反容量限制，则抛出IllegalStateException如果当前没有可用空间）。

        此方法相当于addFirst 。

        Specified by:
        push在接口 Deque<E>
        参数
        e - 要推的元素
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此deque
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - if some property of the specified element prevents it from being added to this deque
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BlockingQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface BlockingQueue<E>

  • 参数类型
    E - 这个队列中保存的元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E> ， Queue<E>
    All Known Subinterfaces:
    BlockingDeque<E> ， TransferQueue<E>
    所有已知实现类：
    ArrayBlockingQueue ， DelayQueue ， LinkedBlockingDeque ， LinkedBlockingQueue ， LinkedTransferQueue ， PriorityBlockingQueue ， SynchronousQueue

    public interface BlockingQueue<E>
extends Queue<E>
    A Queue另外支持在检索元素时等待队列变为非空的操作，并在存储元素时等待队列中的空间变得可用。

    BlockingQueue方法有四种形式，具有不同的操作方式，不能立即满足，但可能在将来的某个时间点满足：一个异常，第二个返回一个特殊值（ null或false ，具体取决于操作），第三个程序将无限期地阻止当前线程，直到操作成功为止，而第四个程序块在放弃之前只有给定的最大时限。 这些方法总结在下表中：

    Summary of BlockingQueue methods Throws exception Special value Blocks Times out Insert add(e) offer(e) put(e) offer(e, time, unit) Remove remove() poll() take() poll(time, unit) Examine element() peek() not applicable not applicable

    A BlockingQueue不接受null元素。 实现抛出NullPointerException上尝试add ， put或者offer一个null 。 A null用作哨兵值以指示poll操作的故障。

    A BlockingQueue可能是容量有限的。 在任何给定的时间它可能有一个remainingCapacity超过其中没有附加元素可以put没有阻止。 A BlockingQueue没有任何固有的容量限制，总是报告剩余容量为Integer.MAX_VALUE 。

    BlockingQueue实现被设计为主要用于生产者 - 消费者队列，但另外支持Collection接口。 因此，例如，可以使用remove(x)从队列中删除任意元素。 然而，这样的操作通常不能非常有效地执行，并且仅用于偶尔使用，例如当排队的消息被取消时。

    BlockingQueue实现是线程安全的。 所有排队方法使用内部锁或其他形式的并发控制在原子上实现其效果。 然而， 大量的Collection操作addAll ， containsAll ， retainAll和removeAll 不一定原子除非在实现中另有规定执行。 因此有可能，例如，为addAll(c)到只增加一些元件在后失败（抛出异常） c 。

    A BlockingQueue本质上不支持任何类型的“关闭”或“关闭”操作，表示不再添加项目。 这些功能的需求和使用往往依赖于实现。 例如，一个常见的策略是生产者插入特殊的尾流或毒物 ，这些消费者在被消费者摄取时被相应地解释。

    使用示例，基于典型的生产者 - 消费者场景。 请注意， BlockingQueue可以安全地与多个生产者和多个消费者一起使用。

       class Producer implements Runnable { private final BlockingQueue queue; Producer(BlockingQueue q) { queue = q; } public void run() { try { while (true) { queue.put(produce()); } } catch (InterruptedException ex) { ... handle ...} } Object produce() { ... } } class Consumer implements Runnable { private final BlockingQueue queue; Consumer(BlockingQueue q) { queue = q; } public void run() { try { while (true) { consume(queue.take()); } } catch (InterruptedException ex) { ... handle ...} } void consume(Object x) { ... } } class Setup { void main() { BlockingQueue q = new SomeQueueImplementation(); Producer p = new Producer(q); Consumer c1 = new Consumer(q); Consumer c2 = new Consumer(q); new Thread(p).start(); new Thread(c1).start(); new Thread(c2).start(); } }

    内存一致性效果：与其他并发集合一样，在将对象放入BlockingQueue happen-before之后的线程中的操作，随后从另一个线程中的BlockingQueue访问或删除该元素。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素插入到此队列中，如果可以立即执行此操作，而不会违反容量限制，成功后返回 true ，如果没有空间可用，则抛出 IllegalStateException 。
      boolean contains​(Object o)
      如果此队列包含指定的元素，则返回 true 。
      int drainTo​(Collection<? super E> c)
      从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
      int drainTo​(Collection<? super E> c, int maxElements)
      最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
      boolean offer​(E e)
      将指定的元素插入此队列中，如果它是立即可行且不会违反容量限制，返回 true在成功和 false如果当前没有空间可用。
      boolean offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此队列中，等待指定的等待时间（如有必要）才能使空间变得可用。
      E poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
      void put​(E e)
      将指定的元素插入到此队列中，等待空格可用。
      int remainingCapacity​()
      返回此队列可理想地（在没有内存或资源约束的情况下）接受而不阻止的附加元素数，如果没有内在限制则 Integer.MAX_VALUE 。
      boolean remove​(Object o)
      从该队列中删除指定元素的单个实例（如果存在）。
      E take​()
      检索并删除此队列的头，如有必要，等待元素可用。

      • Methods inherited from interface java.util.Collection

        addAll, clear, containsAll, equals, hashCode, isEmpty, iterator, parallelStream, removeAll, removeIf, retainAll, size, spliterator, stream, toArray, toArray

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.Queue

        element, peek, poll, remove

    • 方法详细信息

      • add

        boolean add​(E e)
        将指定的元素插入到此队列中，如果可以立即执行此操作，而不会违反容量限制，成功后返回true ，如果当前没有可用空间，则抛出IllegalStateException 。 当使用容量限制队列时，通常最好使用offer 。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        IllegalStateException - 如果由于容量限制，此时无法添加该元素
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此队列

      • offer

        boolean offer​(E e)
        将指定的元素插入此队列中，如果它是立即可行且不会违反容量限制，返回true在成功和false如果当前没有空间可用。 当使用容量限制队列时，此方法通常优于add(E) ，这可能无法仅通过抛出异常来插入元素。
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到此队列，否则为 false
        异常
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此队列中

      • put

        void put​(E e)
  throws InterruptedException
        将指定的元素插入到此队列中，等待空格可用。
        参数
        e - 要添加的元素
        异常
        InterruptedException - 如果在等待时中断
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此队列中

      • offer

        boolean offer​(E e,
              long timeout,
              TimeUnit unit)
       throws InterruptedException
        将指定的元素插入到此队列中，等待指定的等待时间（如有必要）才能使空间变得可用。
        参数
        e - 要添加的元素
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在空间可用之前经过了指定的等待时间
        异常
        InterruptedException - 如果在等待时中断
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此队列中

      • take

        E take​()
throws InterruptedException
        检索并删除此队列的头，如有必要，等待元素可用。
        结果
        这个队列的头
        异常
        InterruptedException - 如果在等待时中断

      • poll

        E poll​(long timeout,
       TimeUnit unit)
throws InterruptedException
        检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        如果在元素可用之前经过指定的等待时间，则该队列的头部，或 null
        异常
        InterruptedException - 如果在等待时中断

      • remainingCapacity

        int remainingCapacity​()
        返回此队列可理想地（在没有内存或资源约束的情况下）接受而不阻止的附加元素数，如果没有内在限制则Integer.MAX_VALUE 。

        请注意，您不能总是通过检查remainingCapacity来判断插入元素是否会成功，因为可能是另一个线程即将插入或删除元素的情况。

        结果
        剩余容量

      • remove

        boolean remove​(Object o)
        从该队列中删除指定元素的单个实例（如果存在）。 更正式地，删除元素e ，使得o.equals(e) ，如果这个队列包含一个或多个这样的元素。 如果此队列包含指定的元素（或等效地，如果此队列作为调用的结果而更改），则返回true 。
        Specified by:
        remove在接口 Collection<E>
        参数
        o - 要从此队列中删除的元素（如果存在）
        结果
        true如果此队列由于调用而更改
        异常
        ClassCastException - 如果指定元素的类与此队列不兼容（ optional ）
        NullPointerException - 如果指定的元素为空（ optional ）

      • contains

        boolean contains​(Object o)
        如果此队列包含指定的元素，则返回true 。 更正式地，返回true当且仅当该队列至少包含一个元素e ，使得o.equals(e) 。
        Specified by:
        contains在接口 Collection<E>
        参数
        o - 要检查此队列中的遏制的对象
        结果
        true如果此队列包含指定的元素
        异常
        ClassCastException - 如果指定元素的类与此队列不兼容（ optional ）
        NullPointerException - 如果指定的元素为空（ optional ）

      • drainTo

        int drainTo​(Collection<? super E> c)
        从该队列中删除所有可用的元素，并将它们添加到给定的集合中。 此操作可能比重复轮询此队列更有效。 尝试向集合c添加元素时遇到的失败可能导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将队列排入自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        参数
        c - 传输元素的集合
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定的集合不支持添加元素
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或此队列的某个元素的某些属性会阻止将其添加到指定的集合

      • drainTo

        int drainTo​(Collection<? super E> c,
            int maxElements)
        最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。 尝试向集合c添加元素时遇到的失败可能导致元素在抛出关联的异常时既不在两个集合中，也可能不是两个集合。 尝试将队列排入自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        参数
        c - 传输元素的集合
        maxElements - 要传输的元素的最大数量
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定集合不支持添加元素
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - if the specified collection is this queue, or some property of an element of this queue prevents it from being added to the specified collection
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BrokenBarrierException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class BrokenBarrierException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.util.concurrent.BrokenBarrierException
  • All Implemented Interfaces:
    Serializable

    public class BrokenBarrierException
extends 异常
    当线程尝试等待处于断开状态的屏障或线程等待时进入断开状态时抛出异常。
    从以下版本开始：
    1.5
    另请参见：
    CyclicBarrier ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BrokenBarrierException​()
      构造一个没有指定详细消息的 BrokenBarrierException 。
      BrokenBarrierException​(String message)
      构造具有指定详细消息的 BrokenBarrierException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • BrokenBarrierException

        public BrokenBarrierException​()
        构造一个没有指定详细消息的 BrokenBarrierException 。

      • BrokenBarrierException

        public BrokenBarrierException​(String message)
        构造具有指定详细消息的 BrokenBarrierException 。
        参数
        message - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Callable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface Callable<V>

  • 参数类型
    V - 方法的结果类型 call
    All Known Subinterfaces:
    DocumentationTool.DocumentationTask ， JavaCompiler.CompilationTask
    所有已知实现类：
    JavacTask
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Callable<V>
    返回结果并可能引发异常的任务。 实现者定义一个没有参数的单一方法，称为call 。

    Callable接口类似于Runnable ，因为它们都是为其实例可能由另一个线程执行的类设计的。 A Runnable ，但是，不返回结果，也不能抛出被检查的异常。

    该Executors类包含的实用方法，从其他普通形式转换为Callable类。

    从以下版本开始：
    1.5
    另请参见：
    Executor

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      V call​()
      计算一个结果，如果不能这样做，就会抛出一个异常。

    • 方法详细信息

      • call

        V call​()
throws 异常
        计算一个结果，如果不能这样做，就会抛出一个异常。
        结果
        计算结果
        异常
        异常 - 如果无法计算结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CancellationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class CancellationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.util.concurrent.CancellationException
  • All Implemented Interfaces:
    Serializable

    public class CancellationException
extends IllegalStateException
    异常指示由于任务被取消，无法检索值生成任务的结果，如FutureTask 。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CancellationException​()
      构造一个没有详细消息的 CancellationException 。
      CancellationException​(String message)
      构造具有指定详细消息的 CancellationException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CancellationException

        public CancellationException​()
        构造一个没有详细信息的 CancellationException 。

      • CancellationException

        public CancellationException​(String message)
        构造具有指定详细消息的 CancellationException 。
        参数
        message - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompletableFuture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class CompletableFuture<T>

  • java.lang.Object
    • java.util.concurrent.CompletableFuture<T>
  • 参数类型
    T - 未来 join和 get方法返回的结果类型
    All Implemented Interfaces:
    CompletionStage<T> ， Future<T>

    public class CompletableFuture<T>
extends Object
implements Future<T>, CompletionStage<T>
    A Future可以明确完成（设置其值和状态），并可用作CompletionStage ，支持在其完成时触发的依赖功能和操作。

    当两个或多个线程试图complete ， completeExceptionally ，或cancel一个CompletableFuture，只有一个成功。

    除了这些直接操作状态和结果的相关方法外，CompletableFuture还实现了接口CompletionStage，具有以下策略：

    • 为异步方法的依赖完成提供的操作可以由完成当前CompletableFuture的线程或完成方法的任何其他调用者执行。
    • 所有不带显式Executor参数的异步方法都使用ForkJoinPool.commonPool()执行（除非它不支持至少两个并行级别，在这种情况下，创建一个新的线程来运行每个任务）。 这可以通过定义方法defaultExecutor()在子类中的非静态方法中被覆盖。 为了简化监视，调试和跟踪，所有生成的异步任务都是标记接口CompletableFuture.AsynchronousCompletionTask的实例。 具有时间延迟的操作可以使用此类中定义的适配器方法，例如： supplyAsync(supplier, delayedExecutor(timeout, timeUnit)) 。 为了支持延迟和超时的方法，该类最多只能维护一个守护进程线程，用于触发和取消操作，而不是运行它们。
    • 所有CompletionStage方法都是独立于其他公共方法实现的，因此一个方法的行为不会受到子类中其他方法的覆盖的影响。
    • 所有CompletionStage方法返回CompletableFutures。 要将用法限制为仅在接口CompletionStage中定义的方法，请使用方法minimalCompletionStage() 。 或者确保只有客户端自己不修改未来，请使用方法copy() 。

    CompletableFuture还实施了Future以下政策：

    • 由于（不像FutureTask ），这个类不能直接控制导致它完成的计算，所以取消被视为另一种形式的异常完成。 方法cancel具有相同的效果completeExceptionally(new CancellationException()) 。 方法isCompletedExceptionally()可用于确定CompletableFuture是否以任何特殊方式完成。
    • 如果使用CompletionException异常完成，方法get()和get(long, TimeUnit)将抛出与在相应的CompletionException中保持的相同原因的ExecutionException 。 为了简化大多数情况下的使用，该类还定义了方法join()和getNow(T) ，而是在这些情况下直接抛出CompletionException。

    用于传递完成结果的参数（即T型参数）可能为null，但为任何其他参数传递空值将导致抛出NullPointerException 。

    该类的子类通常会覆盖“虚拟构造函数”方法newIncompleteFuture() ，该方法确定了CompletionStage方法返回的具体类型。 例如，这里是一个替代不同的默认Executor并禁用obtrude方法的类：

       class MyCompletableFuture<T> extends CompletableFuture<T> { static final Executor myExecutor = ...; public MyCompletableFuture() { } public <U> CompletableFuture<U> newIncompleteFuture() { return new MyCompletableFuture<U>(); } public Executor defaultExecutor() { return myExecutor; } public void obtrudeValue(T value) { throw new UnsupportedOperationException(); } public void obtrudeException(Throwable ex) { throw new UnsupportedOperationException(); } }
    从以下版本开始：
    1.8

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static interface  CompletableFuture.AsynchronousCompletionTask
      标识接口，用于识别由 async方法生成的异步任务。

    • 构造方法摘要

      构造方法
      Constructor 描述
      CompletableFuture​()
      创建一个新的不完整的CompletableFuture。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CompletableFuture<Void> acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的操作的参数。
      CompletableFuture<Void> acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供的操作的参数。
      CompletableFuture<Void> acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。
      static CompletableFuture<Void> allOf​(CompletableFuture<?>... cfs)
      返回一个新的CompletableFuture，当所有给定的CompletableFutures完成时，完成。
      static CompletableFuture<Object> anyOf​(CompletableFuture<?>... cfs)
      返回一个新的CompletableFuture，当任何一个给定的CompletableFutures完成时，完成相同的结果。
      <U> CompletableFuture<U> applyToEither​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的函数的参数。
      <U> CompletableFuture<U> applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供函数的参数。
      <U> CompletableFuture<U> applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用提供的执行器执行，其中相应的结果作为参数提供给函数。
      boolean cancel​(boolean mayInterruptIfRunning)
      如果尚未完成，请使用CancellationException完成此CompletableFuture。
      boolean complete​(T value)
      如果尚未完成，请将返回的值设置为 get()，并将相关方法设置为给定值。
      CompletableFuture<T> completeAsync​(Supplier<? extends T> supplier)
      使用默认执行程序从异步任务调用给定的供应商函数的结果，完成此CompletableFuture。
      CompletableFuture<T> completeAsync​(Supplier<? extends T> supplier, Executor executor)
      使用给定的执行器从异步任务调用给定的供应商函数的结果来完成此CompletableFuture。
      static <U> CompletableFuture<U> completedFuture​(U value)
      返回已经使用给定值完成的新的CompletableFuture。
      static <U> CompletionStage<U> completedStage​(U value)
      返回已经使用给定值完成的新CompletionStage，并且仅支持接口CompletionStage中的那些方法。
      boolean completeExceptionally​(Throwable ex)
      如果还没有完成，会导致调用 get()和相关方法来抛出给定的异常。
      CompletableFuture<T> completeOnTimeout​(T value, long timeout, TimeUnit unit)
      如果在给定的超时之前未完成，则使用给定值完成此CompletableFuture。
      CompletableFuture<T> copy​()
      返回一个新的CompletableFuture，它在正常完成时正常完成，具有与此CompletableFuture相同的值。
      Executor defaultExecutor​()
      返回用于不指定Executor的异步方法的默认Executor。
      static Executor delayedExecutor​(long delay, TimeUnit unit)
      返回一个新的执行程序，它在给定的延迟之后将任务提交给默认的执行程序（或者如果不为正，则不会延迟）。
      static Executor delayedExecutor​(long delay, TimeUnit unit, Executor executor)
      返回一个新的Executor，它在给定的延迟之后向给定的基本执行器提交一个任务（或者如果非正的则不会延迟）。
      CompletableFuture<T> exceptionally​(Function<Throwable,? extends T> fn)
      返回一个新的CompletableFuture，当CompletableFuture完成时完成，结果是异常触发此CompletableFuture的完成特殊功能的给定功能; 否则，如果此CompletableFuture正常完成，则返回的CompletableFuture也会以相同的值正常完成。
      static <U> CompletableFuture<U> failedFuture​(Throwable ex)
      返回一个已经完成的新的CompletableFuture，特别是给定的异常。
      static <U> CompletionStage<U> failedStage​(Throwable ex)
      返回一个已经完成的新的CompletionStage，特别是给定异常，并且仅支持接口CompletionStage中的那些方法。
      T get​()
      等待这个未来完成的必要，然后返回结果。
      T get​(long timeout, TimeUnit unit)
      如果有必要等待这个未来完成的给定时间，然后返回其结果（如果有的话）。
      T getNow​(T valueIfAbsent)
      如果已完成，则返回结果值（或抛出任何遇到的异常），否则返回给定的值IfAbsent。
      int getNumberOfDependents​()
      返回完成等待完成此CompletableFuture的CompletableFutures的估计数。
      <U> CompletableFuture<U> handle​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用此阶段的结果和异常作为所提供函数的参数执行。
      <U> CompletableFuture<U> handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当该阶段完成正常或异常时，将使用此阶段的默认异步执行工具执行，此阶段的结果和异常作为提供函数的参数。
      <U> CompletableFuture<U> handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用提供的执行程序执行此阶段的结果和异常作为提供的函数的参数。
      boolean isCancelled​()
      如果此CompletableFuture在正常完成之前被取消，则返回 true 。
      boolean isCompletedExceptionally​()
      如果此CompletableFuture以任何方式完成异常，则返回 true 。
      boolean isDone​()
      如果以任何方式完成，则返回 true ：通常，特别地，或通过取消。
      T join​()
      完成后返回结果值，如果完成异常，则返回（未检查）异常。
      CompletionStage<T> minimalCompletionStage​()
      返回一个新的CompletionStage，它在正常完成时与该CompletableFuture的值正常完成，并且不能以未由接口CompletionStage的方法定义的方式独立完成或以其他方式使用。
      <U> CompletableFuture<U> newIncompleteFuture​()
      返回由CompletionStage方法返回的类型的新的不完整的CompletableFuture。
      void obtrudeException​(Throwable ex)
      强制引起方法 get()的后续调用和相关方法抛出给定的异常，无论是否已经完成。
      void obtrudeValue​(T value)
      强制设置或重置方法 get()及相关方法随后返回的值，无论是否已完成。
      CompletableFuture<T> orTimeout​(long timeout, TimeUnit unit)
      如果在给定的超时之前没有完成，可以使用TimeoutException完成此CompletableFuture。
      CompletableFuture<Void> runAfterBoth​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，执行给定的动作。
      CompletableFuture<Void> runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletableFuture<Void> runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。
      CompletableFuture<Void> runAfterEither​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行给定的操作。
      CompletableFuture<Void> runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletableFuture<Void> runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。
      static CompletableFuture<Void> runAsync​(Runnable runnable)
      返回一个新的CompletableFuture，它在运行给定操作后由在 ForkJoinPool.commonPool()中运行的任务异步完成。
      static CompletableFuture<Void> runAsync​(Runnable runnable, Executor executor)
      返回一个新的CompletableFuture，它在运行给定操作之后由在给定执行程序中运行的任务异步完成。
      static <U> CompletableFuture<U> supplyAsync​(Supplier<U> supplier)
      返回一个新的CompletableFuture，它由在 ForkJoinPool.commonPool()中运行的任务异步完成，并通过调用给定的供应商获得的值。
      static <U> CompletableFuture<U> supplyAsync​(Supplier<U> supplier, Executor executor)
      返回一个新的CompletableFuture，由给定执行器中运行的任务异步完成，并通过调用给定的供应商获得的值。
      CompletableFuture<Void> thenAccept​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，以该阶段的结果作为提供的操作的参数执行。
      CompletableFuture<Void> thenAcceptAsync​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用此阶段的默认异步执行工具执行，此阶段的结果作为提供的操作的参数。
      CompletableFuture<Void> thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供的操作的参数。
      <U> CompletableFuture<Void> thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供的操作的参数被执行。
      <U> CompletableFuture<Void> thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供的操作的参数。
      <U> CompletableFuture<Void> thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。
      <U> CompletableFuture<U> thenApply​(Function<? super T,? extends U> fn)
      返回一个新的CompletionStage，当此阶段正常完成时，将以该阶段的结果作为所提供函数的参数执行。
      <U> CompletableFuture<U> thenApplyAsync​(Function<? super T,? extends U> fn)
      返回一个新的CompletionStage，当该阶段正常完成时，将使用此阶段的默认异步执行工具执行此阶段的结果作为所提供函数的参数。
      <U> CompletableFuture<U> thenApplyAsync​(Function<? super T,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供函数的参数。
      <U,V> CompletableFuture<V> thenCombine​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供函数的参数执行。
      <U,V> CompletableFuture<V> thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供函数的参数。
      <U,V> CompletableFuture<V> thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行，其中两个结果作为提供的函数的参数。
      <U> CompletableFuture<U> thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个完成的新的CompletionStage，其值与给定函数返回的CompletionStage相同。
      <U> CompletableFuture<U> thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用该阶段的默认异步执行工具执行。
      <U> CompletableFuture<U> thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用提供的Executor执行。
      CompletableFuture<Void> thenRun​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，执行给定的操作。
      CompletableFuture<Void> thenRunAsync​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletableFuture<Void> thenRunAsync​(Runnable action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，使用提供的执行程序执行给定的操作。
      CompletableFuture<T> toCompletableFuture​()
      返回此CompletableFuture。
      String toString​()
      返回一个标识此CompletableFuture的字符串及其完成状态。
      CompletableFuture<T> whenComplete​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同的结果或异常的新CompletionStage，当此阶段完成时，它将执行给定的操作。
      CompletableFuture<T> whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，将使用此阶段的默认异步执行工具执行给定操作。
      CompletableFuture<T> whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，使用提供的执行程序执行给定操作。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CompletableFuture

        public CompletableFuture​()
        创建一个新的不完整的CompletableFuture。

    • 方法详细信息

      • supplyAsync

        public static <U> CompletableFuture<U> supplyAsync​(Supplier<U> supplier)
        返回由在 ForkJoinPool.commonPool()中运行的任务异步完成的新的CompletableFuture，通过调用给定的供应商获得的值。
        参数类型
        U - 函数的返回类型
        参数
        supplier - 返回用于完成返回的CompletableFuture的值的函数
        结果
        新的CompletableFuture

      • supplyAsync

        public static <U> CompletableFuture<U> supplyAsync​(Supplier<U> supplier,
                                                   Executor executor)
        返回一个新的CompletableFuture，由给定执行器中运行的任务异步完成，并通过调用给定的供应商获得的值。
        参数类型
        U - 函数的返回类型
        参数
        supplier - 返回用于完成返回的CompletableFuture的值的函数
        executor - 执行器用于异步执行
        结果
        新的CompletableFuture

      • runAsync

        public static CompletableFuture<Void> runAsync​(Runnable runnable)
        返回一个新的CompletableFuture，它在运行给定操作后由在 ForkJoinPool.commonPool()中运行的任务异步完成。
        参数
        runnable - 完成返回的CompletableFuture之前运行的操作
        结果
        新的CompletableFuture

      • runAsync

        public static CompletableFuture<Void> runAsync​(Runnable runnable,
                                               Executor executor)
        返回一个新的CompletableFuture，它在运行给定操作之后由在给定执行程序中运行的任务异步完成。
        参数
        runnable - 完成返回的CompletableFuture之前运行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletableFuture

      • completedFuture

        public static <U> CompletableFuture<U> completedFuture​(U value)
        返回已经使用给定值完成的新的CompletableFuture。
        参数类型
        U - 值的类型
        参数
        value - 值
        结果
        完成的CompletableFuture

      • isDone

        public boolean isDone​()
        退货 true如果以任何方式完成：通常，特别地，或通过取消。
        Specified by:
        isDone在接口 Future<T>
        结果
        true如果完成

      • get

        public T get​()
      throws InterruptedException,
             ExecutionException
        等待这个未来完成的必要，然后返回结果。
        Specified by:
        get在接口 Future<T>
        结果
        结果值
        异常
        CancellationException - 如果这个未来被取消
        ExecutionException - 如果这个未来完成例外
        InterruptedException - 如果当前线程在等待时中断

      • get

        public T get​(long timeout,
             TimeUnit unit)
      throws InterruptedException,
             ExecutionException,
             TimeoutException
        如果有必要等待这个未来完成的给定时间，然后返回其结果（如果有的话）。
        Specified by:
        get在接口 Future<T>
        参数
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        结果值
        异常
        CancellationException - 如果这个未来被取消了
        ExecutionException - 如果这个未来完成例外
        InterruptedException - 如果当前线程在等待时中断
        TimeoutException - 如果等待超时

      • join

        public T join​()
        完成后返回结果值，如果完成异常，则返回（未检查）异常。 为了更好地符合常用功能表单的使用，如果完成此CompletableFuture涉及的计算抛出异常，则该方法将引发（未选中） CompletionException作为其原因的基础异常。
        结果
        结果值
        异常
        CancellationException - 如果计算被取消
        CompletionException - 如果这个未来完成异常或完成计算抛出异常

      • getNow

        public T getNow​(T valueIfAbsent)
        如果已完成，则返回结果值（或抛出任何遇到的异常），否则返回给定的值IfAbsent。
        参数
        valueIfAbsent - 如果没有完成，返回的值
        结果
        结果值，如果完成，否则给定值IfAbsent
        异常
        CancellationException - 如果计算被取消
        CompletionException - 如果这个未来完成异常或完成计算会造成例外

      • complete

        public boolean complete​(T value)
        如果尚未完成，请将返回的值设置为 get()，并将相关方法设置为给定值。
        参数
        value - 结果值
        结果
        true如果此调用导致此CompletableFuture过渡到完成状态，否则为 false

      • completeExceptionally

        public boolean completeExceptionally​(Throwable ex)
        如果尚未完成，将导致调用 get()和相关方法来抛出给定的异常。
        参数
        ex - 例外
        结果
        true如果此调用导致此CompletableFuture过渡到完成状态，否则为 false

      • thenApply

        public <U> CompletableFuture<U> thenApply​(Function<? super T,? extends U> fn)
        说明从界面CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常完成时，将以该阶段的结果作为所提供函数的参数执行。

        该方法类似于Optional.map和Stream.map 。

        有关特殊完成的规则，请参阅CompletionStage文档。

        Specified by:
        thenApply在接口 CompletionStage<T>
        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • thenApplyAsync

        public <U> CompletableFuture<U> thenApplyAsync​(Function<? super T,? extends U> fn)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当该阶段正常完成时，将使用此阶段的默认异步执行工具执行此阶段的结果作为所提供函数的参数。 请参阅CompletionStage文档，了解覆盖异常完成的规则。
        Specified by:
        thenApplyAsync在接口 CompletionStage<T>
        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • thenApplyAsync

        public <U> CompletableFuture<U> thenApplyAsync​(Function<? super T,? extends U> fn,
                                               Executor executor)
        说明从界面CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供函数的参数。 请参阅CompletionStage文档，了解完整的规则。
        Specified by:
        thenApplyAsync在接口 CompletionStage<T>
        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • thenAccept

        public CompletableFuture<Void> thenAccept​(Consumer<? super T> action)
        说明从界面CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常完成时，以该阶段的结果作为提供的操作的参数执行。 请参阅CompletionStage有关特殊完成规则的文档。
        Specified by:
        thenAccept在接口 CompletionStage<T>
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenAcceptAsync

        public CompletableFuture<Void> thenAcceptAsync​(Consumer<? super T> action)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常完成时，将使用此阶段的默认异步执行工具执行，此阶段的结果作为提供的操作的参数。 请参阅CompletionStage文档，了解有关特殊完成的规则。
        Specified by:
        thenAcceptAsync在接口 CompletionStage<T>
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenAcceptAsync

        public CompletableFuture<Void> thenAcceptAsync​(Consumer<? super T> action,
                                               Executor executor)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供的操作的参数。 请参阅CompletionStage文档，了解覆盖异常完成的规则。
        Specified by:
        thenAcceptAsync在接口 CompletionStage<T>
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • thenRun

        public CompletableFuture<Void> thenRun​(Runnable action)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常完成时，执行给定的操作。 请参阅CompletionStage文档，了解有关特殊完成的规则。
        Specified by:
        thenRun在接口 CompletionStage<T>
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenRunAsync

        public CompletableFuture<Void> thenRunAsync​(Runnable action)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。 请参阅CompletionStage文档，了解例外完成的规则。
        Specified by:
        thenRunAsync在接口 CompletionStage<T>
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenRunAsync

        public CompletableFuture<Void> thenRunAsync​(Runnable action,
                                            Executor executor)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常完成时，使用提供的执行程序执行给定的操作。 请参阅CompletionStage文档，了解完整的规则。
        Specified by:
        thenRunAsync接口 CompletionStage<T>
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 用于异步执行的执行器
        结果
        新的CompletionStage

      • thenCombine

        public <U,V> CompletableFuture<V> thenCombine​(CompletionStage<? extends U> other,
                                              BiFunction<? super T,? super U,? extends V> fn)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供函数的参数执行。 请参阅CompletionStage有关特殊完成规则的文档。
        Specified by:
        thenCombine接口 CompletionStage<T>
        参数类型
        U - 其他CompletionStage的结果的类型
        V - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • thenCombineAsync

        public <U,V> CompletableFuture<V> thenCombineAsync​(CompletionStage<? extends U> other,
                                                   BiFunction<? super T,? super U,? extends V> fn)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供函数的参数。 请参阅CompletionStage文件，了解有关特殊完成的规则。
        Specified by:
        thenCombineAsync在接口 CompletionStage<T>
        参数类型
        U - 其他CompletionStage的结果的类型
        V - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • thenCombineAsync

        public <U,V> CompletableFuture<V> thenCombineAsync​(CompletionStage<? extends U> other,
                                                   BiFunction<? super T,? super U,? extends V> fn,
                                                   Executor executor)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行，其中两个结果作为提供的函数的参数。 请参阅CompletionStage文档，了解覆盖异常完成的规则。
        Specified by:
        thenCombineAsync接口 CompletionStage<T>
        参数类型
        U - 其他CompletionStage的结果的类型
        V - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • thenAcceptBoth

        public <U> CompletableFuture<Void> thenAcceptBoth​(CompletionStage<? extends U> other,
                                                  BiConsumer<? super T,? super U> action)
        说明从界面CompletionStage复制
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供的操作的参数被执行。 请参阅CompletionStage文档，了解覆盖完成的规则。
        Specified by:
        thenAcceptBoth在接口 CompletionStage<T>
        参数类型
        U - 其他CompletionStage的结果的类型
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenAcceptBothAsync

        public <U> CompletableFuture<Void> thenAcceptBothAsync​(CompletionStage<? extends U> other,
                                                       BiConsumer<? super T,? super U> action)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供的操作的参数。 请参阅CompletionStage文档，了解覆盖异常完成的规则。
        Specified by:
        thenAcceptBothAsync在接口 CompletionStage<T>
        参数类型
        U - 其他CompletionStage的结果的类型
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenAcceptBothAsync

        public <U> CompletableFuture<Void> thenAcceptBothAsync​(CompletionStage<? extends U> other,
                                                       BiConsumer<? super T,? super U> action,
                                                       Executor executor)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。 请参阅CompletionStage有关特殊完成规则的文档。
        Specified by:
        thenAcceptBothAsync在接口 CompletionStage<T>
        参数类型
        U - 其他CompletionStage的结果类型
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行程序用于异步执行
        结果
        新的CompletionStage

      • runAfterBoth

        public CompletableFuture<Void> runAfterBoth​(CompletionStage<?> other,
                                            Runnable action)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，执行给定的动作。 有关特殊完成的规则，请参阅CompletionStage文档。
        Specified by:
        runAfterBoth在接口 CompletionStage<T>
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • runAfterBothAsync

        public CompletableFuture<Void> runAfterBothAsync​(CompletionStage<?> other,
                                                 Runnable action)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，使用此阶段的默认异步执行工具执行给定的操作。 请参阅CompletionStage文档，了解完整的规则。
        Specified by:
        runAfterBothAsync在接口 CompletionStage<T>
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • runAfterBothAsync

        public CompletableFuture<Void> runAfterBothAsync​(CompletionStage<?> other,
                                                 Runnable action,
                                                 Executor executor)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。 请参阅CompletionStage有关特殊完成规则的文档。
        Specified by:
        runAfterBothAsync接口 CompletionStage<T>
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • applyToEither

        public <U> CompletableFuture<U> applyToEither​(CompletionStage<? extends T> other,
                                              Function<? super T,U> fn)
        说明从界面CompletionStage复制
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的函数的参数。 有关特殊完成的规则，请参阅CompletionStage文档。
        Specified by:
        applyToEither在接口 CompletionStage<T>
        参数类型
        U - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • applyToEitherAsync

        public <U> CompletableFuture<U> applyToEitherAsync​(CompletionStage<? extends T> other,
                                                   Function<? super T,U> fn)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供函数的参数。 请参阅CompletionStage文档，了解完整的规则。
        Specified by:
        applyToEitherAsync在接口 CompletionStage<T>
        参数类型
        U - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • applyToEitherAsync

        public <U> CompletableFuture<U> applyToEitherAsync​(CompletionStage<? extends T> other,
                                                   Function<? super T,U> fn,
                                                   Executor executor)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用提供的执行器执行，其中相应的结果作为参数提供给函数。 请参阅CompletionStage文档，了解完整的规则。
        Specified by:
        applyToEitherAsync在接口 CompletionStage<T>
        参数类型
        U - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • acceptEither

        public CompletableFuture<Void> acceptEither​(CompletionStage<? extends T> other,
                                            Consumer<? super T> action)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的操作的参数。 有关特殊完成的规则，请参阅CompletionStage文档。
        Specified by:
        acceptEither在接口 CompletionStage<T>
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • acceptEitherAsync

        public CompletableFuture<Void> acceptEitherAsync​(CompletionStage<? extends T> other,
                                                 Consumer<? super T> action)
        说明从界面CompletionStage复制
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供的操作的参数。 请参阅CompletionStage文档，了解完整的规则。
        Specified by:
        acceptEitherAsync在接口 CompletionStage<T>
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • acceptEitherAsync

        public CompletableFuture<Void> acceptEitherAsync​(CompletionStage<? extends T> other,
                                                 Consumer<? super T> action,
                                                 Executor executor)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。 请参阅CompletionStage文档，了解涵盖特殊完成的规则。
        Specified by:
        acceptEitherAsync在接口 CompletionStage<T>
        参数
        other - 其他CompletionStage
        action - 完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • runAfterEither

        public CompletableFuture<Void> runAfterEither​(CompletionStage<?> other,
                                              Runnable action)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行给定的操作。 请参阅CompletionStage文档，了解覆盖异常完成的规则。
        Specified by:
        runAfterEither在接口 CompletionStage<T>
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • runAfterEitherAsync

        public CompletableFuture<Void> runAfterEitherAsync​(CompletionStage<?> other,
                                                   Runnable action)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。 请参阅CompletionStage文档，了解完整的规则。
        Specified by:
        runAfterEitherAsync在接口 CompletionStage<T>
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • runAfterEitherAsync

        public CompletableFuture<Void> runAfterEitherAsync​(CompletionStage<?> other,
                                                   Runnable action,
                                                   Executor executor)
        说明从界面CompletionStage复制
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。 请参阅CompletionStage文档，了解覆盖异常完成的规则。
        Specified by:
        runAfterEitherAsync在接口 CompletionStage<T>
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • thenCompose

        public <U> CompletableFuture<U> thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
        描述从接口CompletionStage复制
        返回一个完成的新的CompletionStage，其值与给定函数返回的CompletionStage相同。

        当这个阶段正常完成时，以该阶段的结果作为参数调用给定的函数，返回另一个CompletionStage。 当该阶段正常完成时，此方法返回的CompletionStage将以相同的值完成。

        为了确保进度，提供的功能必须最终完成其结果。

        该方法类似于Optional.flatMap和Stream.flatMap 。

        请参阅CompletionStage文档，了解覆盖异常完成的规则。

        Specified by:
        thenCompose在接口 CompletionStage<T>
        参数类型
        U - 返回的CompletionStage结果的类型
        参数
        fn - 用于计算另一个CompletionStage的函数
        结果
        新的CompletionStage

      • thenComposeAsync

        public <U> CompletableFuture<U> thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用该阶段的默认异步执行工具执行。

        当这个阶段正常完成时，以该阶段的结果作为参数调用给定的函数，返回另一个CompletionStage。 当该阶段正常完成时，此方法返回的CompletionStage将以相同的值完成。

        为了确保进度，提供的功能必须最终完成其结果。

        请参阅CompletionStage文档，了解有关特殊完成的规则。

        Specified by:
        thenComposeAsync在接口 CompletionStage<T>
        参数类型
        U - 返回的CompletionStage结果的类型
        参数
        fn - 用于计算另一个CompletionStage的函数
        结果
        新的CompletionStage

      • thenComposeAsync

        public <U> CompletableFuture<U> thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn,
                                                 Executor executor)
        说明从界面CompletionStage复制
        返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用提供的Executor执行。

        当这个阶段正常完成时，以该阶段的结果作为参数调用给定的函数，返回另一个CompletionStage。 当该阶段正常完成时，此方法返回的CompletionStage将以相同的值完成。

        为了确保进度，提供的功能必须最终完成其结果。

        有关特殊完成的规则，请参阅CompletionStage文档。

        Specified by:
        thenComposeAsync在接口 CompletionStage<T>
        参数类型
        U - 返回的CompletionStage结果的类型
        参数
        fn - 用于计算另一个CompletionStage的函数
        executor - 用于异步执行的执行器
        结果
        新的CompletionStage

      • whenComplete

        public CompletableFuture<T> whenComplete​(BiConsumer<? super T,? super Throwable> action)
        说明从接口CompletionStage复制
        返回与此阶段相同的结果或异常的新CompletionStage，当此阶段完成时，它将执行给定的操作。

        当这个阶段完成时，使用结果（或null如果没有）和异常（或null如果没有））作为参数调用给定的动作。 返回的阶段在行动返回时完成。

        与方法handle不同，此方法不是设计为翻译完成结果，因此提供的操作不应抛出异常。 但是，如果这样做，则适用以下规则：如果此阶段正常完成，但提供的操作引发异常，则返回的阶段会以提供的操作异常完成。 或者，如果此阶段完成异常且提供的操作引发异常，那么返回的阶段会在此阶段异常结束。

        Specified by:
        whenComplete在接口 CompletionStage<T>
        参数
        action - 要执行的动作
        结果
        新的CompletionStage

      • whenCompleteAsync

        public CompletableFuture<T> whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
        描述从接口CompletionStage复制
        返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，将使用此阶段的默认异步执行工具执行给定操作。

        当这个阶段完成时，使用结果（或null如果没有）和异常（或null如果没有））调用给定的动作作为参数。 返回的阶段在行动返回时完成。

        与方法handleAsync不同，此方法不是设计为翻译完成结果，因此提供的操作不应抛出异常。 但是，如果这样做，则适用以下规则：如果此阶段正常完成但提供的操作引发异常，那么返回的阶段会以提供的操作异常完成。 或者，如果此阶段完成异常且提供的操作引发异常，那么返回的阶段会在此阶段异常结束。

        Specified by:
        whenCompleteAsync在接口 CompletionStage<T>
        参数
        action - 要执行的动作
        结果
        新的CompletionStage

      • whenCompleteAsync

        public CompletableFuture<T> whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action,
                                              Executor executor)
        说明从界面CompletionStage复制
        返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，使用提供的执行程序执行给定操作。

        当这个阶段完成时，使用结果（或null如果没有））和此阶段的异常（或null如果没有）作为参数）调用给定的操作。 返回的阶段在行动返回时完成。

        与方法handleAsync不同，此方法不是设计为翻译完成结果，因此提供的操作不应抛出异常。 但是，如果这样做，则适用以下规则：如果此阶段正常完成但提供的操作引发异常，那么返回的阶段会以提供的操作异常完成。 或者，如果此阶段完成异常且提供的操作引发异常，那么返回的阶段会在此阶段异常结束。

        Specified by:
        whenCompleteAsync在接口 CompletionStage<T>
        参数
        action - 要执行的动作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • handle

        public <U> CompletableFuture<U> handle​(BiFunction<? super T,Throwable,? extends U> fn)
        说明从接口CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用此阶段的结果和异常作为所提供函数的参数执行。

        当这个阶段完成时，使用结果（或null如果没有）和这个阶段的异常（或null如果没有）作为参数）调用给定的函数，并且使用函数的结果来完成返回的阶段。

        Specified by:
        handle在接口 CompletionStage<T>
        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • handleAsync

        public <U> CompletableFuture<U> handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
        新新新新新CompletionStage
        返回一个新的CompletionStage，当该阶段完成正常或异常时，将使用此阶段的默认异步执行工具执行，此阶段的结果和异常作为提供函数的参数。

        当这个阶段完成时，使用结果（或者null如果没有）和异常（或null如果没有）作为参数调用给定的函数，并且使用函数的结果来完成返回的阶段。

        Specified by:
        handleAsync在接口 CompletionStage<T>
        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • handleAsync

        public <U> CompletableFuture<U> handleAsync​(BiFunction<? super T,Throwable,? extends U> fn,
                                            Executor executor)
        描述从接口CompletionStage复制
        返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用提供的执行程序执行此阶段的结果和异常作为提供的函数的参数。

        当这个阶段完成时，使用结果（或null如果没有））和此阶段的异常（或null如果没有）作为参数）调用给定函数，并使用函数的结果来完成返回的阶段。

        Specified by:
        handleAsync在接口 CompletionStage<T>
        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • toCompletableFuture

        public CompletableFuture<T> toCompletableFuture​()
        返回此CompletableFuture。
        Specified by:
        toCompletableFuture在接口 CompletionStage<T>
        结果
        这个CompletableFuture

      • exceptionally

        public CompletableFuture<T> exceptionally​(Function<Throwable,? extends T> fn)
        返回一个新的CompletableFuture，当CompletableFuture完成时完成，结果是异常触发此CompletableFuture的完成特殊功能的给定功能; 否则，如果此CompletableFuture正常完成，则返回的CompletableFuture也会以相同的值正常完成。 注意：使用方法whenComplete和handle可以使用此功能更灵活的版本。
        Specified by:
        exceptionally在接口 CompletionStage<T>
        参数
        fn - 用于计算返回的CompletableFuture的值的函数，如果此CompletableFuture异常完成
        结果
        新的CompletableFuture

      • allOf

        public static CompletableFuture<Void> allOf​(CompletableFuture<?>... cfs)
        返回一个新的CompletableFuture，当所有给定的CompletableFutures完成时，完成。 如果给定的CompletableFutures中的任何一个完全完成，那么返回的CompletableFuture也会这样做，并且将一个将此异常作为原因的CompletionException异常。 否则，给定的CompletableFutures的结果（如果有的话）没有反映在返回的CompletableFuture中，但可以通过单独检查获得。 如果没有提供CompletableFutures，则返回一个CompletableFuture完成，值为null 。

        这种方法的应用之一是等待完成一套独立的CompletableFutures，然后再继续执行程序，如下所示： CompletableFuture.allOf(c1, c2, c3).join(); 。

        参数
        cfs - CompletableFutures
        结果
        一个新的CompletableFuture完成时，所有给定的CompletableFutures完成
        异常
        NullPointerException - 如果数组或其任何元素是 null

      • anyOf

        public static CompletableFuture<Object> anyOf​(CompletableFuture<?>... cfs)
        返回一个新的CompletableFuture，当任何一个给定的CompletableFutures完成时，完成相同的结果。 否则，如果它完成异常，则返回的CompletableFuture也会这样执行，并以一个将此异常作为原因的CompletionException异常。 如果没有提供CompletableFutures，则返回一个不完整的CompletableFuture。
        参数
        cfs - CompletableFutures
        结果
        一个新的CompletableFuture完成，结果或任何给定的CompletableFutures的任何一个完成
        异常
        NullPointerException - 如果数组或其任何元素是 null

      • cancel

        public boolean cancel​(boolean mayInterruptIfRunning)
        如果尚未完成，请用CancellationException完成此CompletableFuture。 尚未完成的依赖的可完成的功能也将完成异常，由CancellationException引起的CancellationException 。
        Specified by:
        cancel在接口 Future<T>
        参数
        mayInterruptIfRunning - 此值对此实现没有影响，因为中断不用于控制处理。
        结果
        true如果此任务现在已取消

      • isCancelled

        public boolean isCancelled​()
        如果此CompletableFuture在正常完成之前被取消，则返回 true 。
        Specified by:
        isCancelled在接口 Future<T>
        结果
        true如果此CompletableFuture在正常完成之前被取消

      • isCompletedExceptionally

        public boolean isCompletedExceptionally​()
        如果此CompletableFuture以任何方式非常完成，则返回true 。 可能的原因包括取消，显式调用completeExceptionally ，并突然终止CompletionStage操作。
        结果
        true如果此CompletableFuture格外完成

      • obtrudeValue

        public void obtrudeValue​(T value)
        强制设置或重置方法get()及其相关方法随后返回的值，无论是否已完成。 该方法仅用于错误恢复操作，即使在这种情况下也可能导致使用已建立与覆盖结果的持续依赖性完成。
        参数
        value - 完成值

      • obtrudeException

        public void obtrudeException​(Throwable ex)
        强制导致后续调用方法get()和相关方法抛出给定的异常，无论是否已经完成。 该方法仅用于错误恢复操作，即使在这种情况下也可能导致使用已建立与覆盖结果的持续依赖性完成。
        参数
        ex - 例外
        异常
        NullPointerException - 如果异常为null

      • getNumberOfDependents

        public int getNumberOfDependents​()
        返回完成等待完成此CompletableFuture的CompletableFutures的估计数。 该方法设计用于监控系统状态，不用于同步控制。
        结果
        依赖的CompletableFutures的数量

      • toString

        public String toString​()
        返回一个标识此CompletableFuture的字符串及其完成状态。 的状态下，在括号中，包含字符串"Completed Normally"或字符串"Completed Exceptionally" ，或字符串"Not completed"随后依赖其完成后CompletableFutures的数量，如果有的话。
        重写：
        toString在 Object
        结果
        一个标识此CompletableFuture的字符串，以及它的状态

      • newIncompleteFuture

        public <U> CompletableFuture<U> newIncompleteFuture​()
        返回由CompletionStage方法返回的类型的新的不完整的CompletableFuture。 子类通常会覆盖此方法以返回与此CompletableFuture相同类的实例。 默认实现返回一个类CompletableFuture的实例。
        参数类型
        U - 值的类型
        结果
        一个新的CompletableFuture
        从以下版本开始：
        9

      • defaultExecutor

        public Executor defaultExecutor​()
        返回用于不指定Executor的异步方法的默认Executor。 这个类使用ForkJoinPool.commonPool()，如果它支持多个并行线程，或者一个Executor每个异步任务使用一个线程。 这个方法可以在子类中被覆盖，以返回提供至少一个独立线程的Executor。
        结果
        执行人
        从以下版本开始：
        9

      • copy

        public CompletableFuture<T> copy​()
        返回一个新的CompletableFuture，它在正常完成时正常完成，具有与此CompletableFuture相同的值。 如果此CompletableFuture异常完成，则返回的CompletableFuture将以完整异常完成异常，并将此异常作为原因。 行为相当于thenApply(x -> x) 。 这种方法可能作为“防御性复制”的形式是有用的，以防止客户端完成，同时仍然能够安排依赖的操作。
        结果
        新的CompletableFuture
        从以下版本开始：
        9

      • minimalCompletionStage

        public CompletionStage<T> minimalCompletionStage​()
        返回一个新的CompletionStage，它在正常完成时正常完成与此CompletableFuture相同的值，并且不能以未由接口CompletionStage定义的方式独立完成或以其他方式使用。 如果此CompletableFuture完全异常完成，则返回的CompletionStage将以完整异常完成异常，因此导致此异常。

        除非被子类覆盖，否则可以从最小的CompletionStage通过toCompletableFuture()获取可用的所有方法的新的非最小的CompletableFuture。 例如，可以等待最小阶段的完成

          minimalStage.toCompletableFuture().join();
        结果
        新的CompletionStage
        从以下版本开始：
        9

      • completeAsync

        public CompletableFuture<T> completeAsync​(Supplier<? extends T> supplier,
                                          Executor executor)
        使用给定的执行器从异步任务调用给定的供应商函数的结果来完成此CompletableFuture。
        参数
        supplier - 返回用于完成此CompletableFuture的值的函数
        executor - 执行器用于异步执行
        结果
        这个CompletableFuture
        从以下版本开始：
        9

      • completeAsync

        public CompletableFuture<T> completeAsync​(Supplier<? extends T> supplier)
        使用默认执行程序从异步任务调用给定的供应商函数的结果，完成此CompletableFuture。
        参数
        supplier - 返回用于完成此CompletableFuture的值的函数
        结果
        这个CompletableFuture
        从以下版本开始：
        9

      • orTimeout

        public CompletableFuture<T> orTimeout​(long timeout,
                                      TimeUnit unit)
        如果在给定的超时之前未完成，可以使用TimeoutException完成此CompletableFuture。
        参数
        timeout - 在使用超时出现异常之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        这个CompletableFuture
        从以下版本开始：
        9

      • completeOnTimeout

        public CompletableFuture<T> completeOnTimeout​(T value,
                                              long timeout,
                                              TimeUnit unit)
        如果在给定的超时之前未完成，则使用给定值完成此CompletableFuture。
        参数
        value - 超时时使用的值
        timeout - 在给定值正常完成之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        这个CompletableFuture
        从以下版本开始：
        9

      • delayedExecutor

        public static Executor delayedExecutor​(long delay,
                                       TimeUnit unit,
                                       Executor executor)
        返回一个新的Executor，它在给定的延迟之后向给定的基本执行器提交一个任务（或者如果非正的则不会延迟）。 每个延迟都是在调用返回的执行者的execute方法时开始的。
        参数
        delay - 延迟多久，以 unit为单位
        unit - a TimeUnit确定如何解释 delay参数
        executor - 基地执行人
        结果
        新推迟执行人
        从以下版本开始：
        9

      • delayedExecutor

        public static Executor delayedExecutor​(long delay,
                                       TimeUnit unit)
        返回一个新的执行程序，它在给定的延迟之后将任务提交给默认的执行程序（或者如果不为正，则不会延迟）。 每个延迟在调用返回的执行者的execute方法时开始。
        参数
        delay - 以 unit为单位延迟 unit
        unit - a TimeUnit确定如何解释 delay参数
        结果
        新推迟执行人
        从以下版本开始：
        9

      • completedStage

        public static <U> CompletionStage<U> completedStage​(U value)
        返回已经使用给定值完成的新CompletionStage，并仅支持接口CompletionStage中的那些方法。
        参数类型
        U - 值的类型
        参数
        value - 值
        结果
        完成完成
        从以下版本开始：
        9

      • failedFuture

        public static <U> CompletableFuture<U> failedFuture​(Throwable ex)
        返回一个已经完成的新的CompletableFuture，特别是给定的异常。
        参数类型
        U - 值的类型
        参数
        ex - 例外
        结果
        完成的CompletableFuture
        从以下版本开始：
        9

      • failedStage

        public static <U> CompletionStage<U> failedStage​(Throwable ex)
        返回一个已完成的新的CompletionStage，特别是给定异常，并且仅支持接口CompletionStage中的那些方法。
        参数类型
        U - 值的类型
        参数
        ex - 例外
        结果
        完成完成
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompletableFuture.AsynchronousCompletionTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface CompletableFuture.AsynchronousCompletionTask

  • Enclosing class:
    CompletableFuture < T >

    public static interface CompletableFuture.AsynchronousCompletionTask
    标识接口，标识由async方法产生的异步任务。 这对于监视，调试和跟踪异步活动可能很有用。
    从以下版本开始：
    1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompletionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class CompletionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.util.concurrent.CompletionException
  • All Implemented Interfaces:
    Serializable

    public class CompletionException
extends RuntimeException
    在完成结果或任务的过程中遇到错误或其他异常时抛出异常。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CompletionException​()
      构造一个 CompletionException ，没有详细信息。
      protected CompletionException​(String message)
      构造具有指定详细消息的 CompletionException 。
        CompletionException​(String message, Throwable cause)
      构造具有指定的详细信息和原因的 CompletionException 。
        CompletionException​(Throwable cause)
      构造具有指定原因的 CompletionException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CompletionException

        protected CompletionException​()
        构造一个CompletionException ，没有详细信息。 原因未初始化，可以随后通过调用initCause进行初始化。

      • CompletionException

        protected CompletionException​(String message)
        构造具有指定详细消息的CompletionException 。 原因未初始化，可以随后通过调用initCause进行初始化。
        参数
        message - 详细信息

      • CompletionException

        public CompletionException​(String message,
                           Throwable cause)
        构造一个具有指定的详细信息和原因的 CompletionException 。
        参数
        message - 详细信息
        cause - 原因（由 Throwable.getCause()方法保存供以后检索）

      • CompletionException

        public CompletionException​(Throwable cause)
        构造具有指定原因的CompletionException 。 详细消息被设定为(cause == null ? null : cause.toString()) （它通常包含的类和详细消息cause ）。
        参数
        cause - 原因（保存以供 Throwable.getCause()方法后续检索）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompletionService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface CompletionService<V>

  • 所有已知实现类：
    ExecutorCompletionService

    public interface CompletionService<V>
    一种将新异步任务的生产与已完成任务的结果消耗相分离的服务。 生产者submit执行任务。 消费者take完成任务并按照完成的顺序处理其结果。 A CompletionService可以例如用于管理异步I / O，其中执行读取的任务在程序或系统的一部分中提交，然后在读取完成时在程序的不同部分执行操作，可能在不同于他们要求的顺序。

    通常， CompletionService依赖于单独的Executor来实际执行任务，在这种情况下， CompletionService仅管理内部完成队列。 ExecutorCompletionService课程提供了这种方法的实现。

    内存一致性效果：提交任务的前行动线程CompletionService happen-before由该任务所采取的行动，进而发生，之前从以下相应的成功返回行动take() 。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Future<V> poll​()
      检索并删除代表下一个完成的任务的未来，或者如果没有任何一个，则 null 。
      Future<V> poll​(long timeout, TimeUnit unit)
      检索并删除表示下一个完成的任务的未来，如果还没有，则等待必要时直到指定的等待时间。
      Future<V> submit​(Runnable task, V result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      Future<V> submit​(Callable<V> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。
      Future<V> take​()
      检索并删除代表下一个完成任务的未来，等待是否还没有任务。

    • 方法详细信息

      • submit

        Future<V> submit​(Callable<V> task)
        提交值返回任务以执行，并返回代表任务待处理结果的Future。 完成后，可以采取或轮询此任务。
        参数
        task - 要提交的任务
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果任务为空

      • submit

        Future<V> submit​(Runnable task,
                 V result)
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 完成后，可以采取或轮询此任务。
        参数
        task - 提交的任务
        result - 成功完成后返回的结果
        结果
        未来代表待完成的任务，其 get()方法将在完成后返回给定的结果值
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果任务为空

      • take

        Future<V> take​()
        throws InterruptedException
        检索并删除代表下一个完成任务的未来，等待是否还没有任务。
        结果
        未来代表下一个完成的任务
        异常
        InterruptedException - 如果在等待时中断

      • poll

        Future<V> poll​()
        检索并删除代表下一个完成的任务的未来，或者如果没有任何一个，则 null 。
        结果
        未来代表下一个完成的任务，或 null如果没有）

      • poll

        Future<V> poll​(long timeout,
               TimeUnit unit)
        throws InterruptedException
        检索并删除表示下一个完成的任务的未来，如果还没有，则等待必要时直到指定的等待时间。
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        未来代表下一个完成的任务或 null如果指定的等待时间过去之前存在
        异常
        InterruptedException - 如果等待中断
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompletionStage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface CompletionStage<T>

  • 所有已知实现类：
    CompletableFuture

    public interface CompletionStage<T>
    可能的异步计算的阶段，当另一个完成时间完成时，执行一个动作或计算一个值。 一个阶段在其计算结束时完成，但这又可能触发其他相关阶段。 此界面中定义的功能只需要几种基本形式，从而扩展到更大的方法来捕获一系列使用风格：
    • 阶段执行的计算可以表示为功能，消费者或可运行 （分别使用名称包括apply ， accept或run的方法 ），具体取决于是否需要参数和/或生成结果。 例如：
         stage.thenApply(x -> square(x)) .thenAccept(x -> System.out.print(x)) .thenRun(() -> System.out.println());
      附加的形式（ 组合 ）允许从返回完成阶段的功能构建计算管道。

      舞台计算的任何论据是触发阶段计算的结果。

    • 一个阶段的执行可以通过完成一个阶段，或两个阶段的完成，或两个阶段中的任一阶段来触发。 在一个单级的依赖关系使用的是带有前缀方法然后配置。 这些都通过两个阶段的结束为契机可以结合自己的成绩和效果，使用相应的命名方法。 由两个阶段中的任一阶段触发的那些都不能保证结果或效果中的哪一个用于依赖阶段的计算。
    • 阶段之间的依赖性控制计算的触发，但是否则不保证任何特定的顺序。 另外，新阶段计算的执行可以通过以下三种方式进行排列：默认执行，默认异步执行（使用使用阶段的默认异步执行工具的后缀async的方法）或定制（通过提供的Executor ）。 默认和异步模式的执行属性由CompletionStage实现指定，而不是此接口。 具有显式Executor参数的方法可能具有任意执行属性，甚至可能不支持并发执行，而是以适应异步方式进行处理。
    • 两种方法形式（ handle和whenComplete ）支持无条件计算触发阶段是否正常或异常完成。 方法exceptionally支持计算，只有当触发阶段完成异常时，计算替换结果，类似于java catch关键字。 在所有其他情况下，如果一个阶段的计算突然出现（未检查）的异常或错误，那么所有依赖阶段都需要完成，例外情况除外，其中CompletionException将其作为原因。 如果一个阶段是依赖于两个两个阶段，都非常完整，那么CompletionException可以对应于这些例外的任何一个。 如果一个阶段依赖于两个其他的任何一个，并且只有一个完成异常，则不能保证依赖阶段是否正常或异常完成。 在方法whenComplete的情况下，当所提供的动作本身遇到异常时，则除非源whenComplete也异常完成，否则该阶段完成异常，在这种情况下，来自源级的异常完成被赋予优先权并且被传播到从属阶段。

    所有方法都遵循上述触发，执行和特殊完成规范（在各个方法规范中不重复）。 另外，对于接受它们的方法，用于传递完成结果的参数（即T参数）可能为null，传递任何其他参数的空值将导致抛出一个NullPointerException 。

    方法形式handle是创建连续阶段的最通用方法，无条件地执行给出触发CompletionStage的结果和异常（如果有的话）的计算，并计算任意结果。 方法whenComplete是类似的，但保留了触发阶段的结果，而不是计算新的结果。 因为阶段的正常结果可能是null ，所以这两种方法应该具有如下结构：

      (result, exception) -> { if (exception == null) { // triggering stage completed normally } else { // triggering stage completed exceptionally } }

    该接口没有定义初始创建方法，强制完成正常或异常的探测完成状态或结果，或等待阶段完成。 CompletionStage的实施可能会提供适当的方式来实现这种效果。 方法toCompletableFuture()通过提供公共转换类型来实现该接口的不同实现之间的互操作性。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      CompletionStage<Void> acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的操作的参数。
      CompletionStage<Void> acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供的操作的参数。
      CompletionStage<Void> acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。
      <U> CompletionStage<U> applyToEither​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的函数的参数。
      <U> CompletionStage<U> applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供函数的参数。
      <U> CompletionStage<U> applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用提供的执行器执行，其中相应的结果作为参数提供给函数。
      CompletionStage<T> exceptionally​(Function<Throwable,? extends T> fn)
      返回一个新的CompletionStage，当此阶段完成异常时，将以此阶段的异常作为提供函数的参数执行。
      <U> CompletionStage<U> handle​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用此阶段的结果和异常作为所提供函数的参数执行。
      <U> CompletionStage<U> handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当该阶段完成正常或异常时，将使用此阶段的默认异步执行工具执行，此阶段的结果和异常作为提供函数的参数。
      <U> CompletionStage<U> handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用提供的执行程序执行此阶段的结果和异常作为提供的函数的参数。
      CompletionStage<Void> runAfterBoth​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，执行给定的动作。
      CompletionStage<Void> runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。
      CompletionStage<Void> runAfterEither​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行给定的操作。
      CompletionStage<Void> runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。
      CompletionStage<Void> thenAccept​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，以该阶段的结果作为提供的操作的参数执行。
      CompletionStage<Void> thenAcceptAsync​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用此阶段的默认异步执行工具执行，此阶段的结果作为提供的操作的参数。
      CompletionStage<Void> thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供的操作的参数。
      <U> CompletionStage<Void> thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供的操作的参数被执行。
      <U> CompletionStage<Void> thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供的操作的参数。
      <U> CompletionStage<Void> thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。
      <U> CompletionStage<U> thenApply​(Function<? super T,? extends U> fn)
      返回一个新的CompletionStage，当此阶段正常完成时，将以该阶段的结果作为所提供函数的参数执行。
      <U> CompletionStage<U> thenApplyAsync​(Function<? super T,? extends U> fn)
      返回一个新的CompletionStage，当该阶段正常完成时，将使用此阶段的默认异步执行工具执行此阶段的结果作为所提供函数的参数。
      <U> CompletionStage<U> thenApplyAsync​(Function<? super T,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供函数的参数。
      <U,V> CompletionStage<V> thenCombine​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供函数的参数执行。
      <U,V> CompletionStage<V> thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供函数的参数。
      <U,V> CompletionStage<V> thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行，其中两个结果作为提供的函数的参数。
      <U> CompletionStage<U> thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个完成的新的CompletionStage，其值与给定函数返回的CompletionStage相同。
      <U> CompletionStage<U> thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用该阶段的默认异步执行工具执行。
      <U> CompletionStage<U> thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用提供的Executor执行。
      CompletionStage<Void> thenRun​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，执行给定的操作。
      CompletionStage<Void> thenRunAsync​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> thenRunAsync​(Runnable action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，使用提供的执行程序执行给定的操作。
      CompletableFuture<T> toCompletableFuture​()
      返回一个CompletableFuture，维持与这个阶段相同的完成属性。
      CompletionStage<T> whenComplete​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同的结果或异常的新CompletionStage，当此阶段完成时，它将执行给定的操作。
      CompletionStage<T> whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，将使用此阶段的默认异步执行工具执行给定操作。
      CompletionStage<T> whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，使用提供的执行程序执行给定操作。

    • 方法详细信息

      • thenApply

        <U> CompletionStage<U> thenApply​(Function<? super T,? extends U> fn)
        返回一个新的CompletionStage，当此阶段正常完成时，将以该阶段的结果作为所提供函数的参数执行。

        该方法类似于Optional.map和Stream.map 。

        请参阅CompletionStage文档，了解完整的规则。

        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • thenApplyAsync

        <U> CompletionStage<U> thenApplyAsync​(Function<? super T,? extends U> fn)
        返回一个新的CompletionStage，当该阶段正常完成时，将使用此阶段的默认异步执行工具执行此阶段的结果作为所提供函数的参数。 请参阅CompletionStage文档，了解涵盖特殊完成的规则。
        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • thenApplyAsync

        <U> CompletionStage<U> thenApplyAsync​(Function<? super T,? extends U> fn,
                                      Executor executor)
        返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供函数的参数。 请参阅CompletionStage文档，了解覆盖异常完成的规则。
        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • thenAccept

        CompletionStage<Void> thenAccept​(Consumer<? super T> action)
        返回一个新的CompletionStage，当此阶段正常完成时，以该阶段的结果作为提供的操作的参数执行。 请参阅CompletionStage文档，了解有关特殊完成的规则。
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenAcceptAsync

        CompletionStage<Void> thenAcceptAsync​(Consumer<? super T> action)
        返回一个新的CompletionStage，当此阶段正常完成时，将使用此阶段的默认异步执行工具执行，此阶段的结果作为提供的操作的参数。 请参阅CompletionStage文档，了解完整的规则。
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenAcceptAsync

        CompletionStage<Void> thenAcceptAsync​(Consumer<? super T> action,
                                      Executor executor)
        返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供的操作的参数。 请参阅CompletionStage文档，了解完整的规则。
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • thenRun

        CompletionStage<Void> thenRun​(Runnable action)
        返回一个新的CompletionStage，当此阶段正常完成时，执行给定的操作。 请参阅CompletionStage文档，了解完整的规则。
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenRunAsync

        CompletionStage<Void> thenRunAsync​(Runnable action)
        返回一个新的CompletionStage，当此阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。 有关特殊完成的规则，请参阅CompletionStage文档。
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenRunAsync

        CompletionStage<Void> thenRunAsync​(Runnable action,
                                   Executor executor)
        返回一个新的CompletionStage，当此阶段正常完成时，使用提供的执行程序执行给定的操作。 有关特殊完成的规则，请参阅CompletionStage文档。
        参数
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • thenCombine

        <U,V> CompletionStage<V> thenCombine​(CompletionStage<? extends U> other,
                                     BiFunction<? super T,? super U,? extends V> fn)
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供函数的参数执行。 请参阅CompletionStage文档，了解完整的规则。
        参数类型
        U - 其他CompletionStage的结果的类型
        V - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • thenCombineAsync

        <U,V> CompletionStage<V> thenCombineAsync​(CompletionStage<? extends U> other,
                                          BiFunction<? super T,? super U,? extends V> fn)
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供函数的参数。 有关特殊完成的规则，请参阅CompletionStage文档。
        参数类型
        U - 其他CompletionStage的结果类型
        V - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • thenCombineAsync

        <U,V> CompletionStage<V> thenCombineAsync​(CompletionStage<? extends U> other,
                                          BiFunction<? super T,? super U,? extends V> fn,
                                          Executor executor)
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行，其中两个结果作为提供的函数的参数。 请参阅CompletionStage文档，了解完整的规则。
        参数类型
        U - 其他CompletionStage的结果的类型
        V - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • thenAcceptBoth

        <U> CompletionStage<Void> thenAcceptBoth​(CompletionStage<? extends U> other,
                                         BiConsumer<? super T,? super U> action)
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供的操作的参数被执行。 有关特殊完成的规则，请参阅CompletionStage文档。
        参数类型
        U - 其他CompletionStage的结果的类型
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenAcceptBothAsync

        <U> CompletionStage<Void> thenAcceptBothAsync​(CompletionStage<? extends U> other,
                                              BiConsumer<? super T,? super U> action)
        返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供的操作的参数。 有关特殊完成的规则，请参阅CompletionStage文档。
        参数类型
        U - 其他CompletionStage的结果的类型
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • thenAcceptBothAsync

        <U> CompletionStage<Void> thenAcceptBothAsync​(CompletionStage<? extends U> other,
                                              BiConsumer<? super T,? super U> action,
                                              Executor executor)
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。 请参阅CompletionStage文档，了解完整的规则。
        参数类型
        U - 其他CompletionStage的结果的类型
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • runAfterBoth

        CompletionStage<Void> runAfterBoth​(CompletionStage<?> other,
                                   Runnable action)
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，执行给定的动作。 请参阅CompletionStage有关特殊完成规则的文档。
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • runAfterBothAsync

        CompletionStage<Void> runAfterBothAsync​(CompletionStage<?> other,
                                        Runnable action)
        返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，使用此阶段的默认异步执行工具执行给定的操作。 有关特殊完成的规则，请参阅CompletionStage文档。
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • runAfterBothAsync

        CompletionStage<Void> runAfterBothAsync​(CompletionStage<?> other,
                                        Runnable action,
                                        Executor executor)
        返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。 请参阅CompletionStage文档，了解覆盖异常完成的规则。
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • applyToEither

        <U> CompletionStage<U> applyToEither​(CompletionStage<? extends T> other,
                                     Function<? super T,U> fn)
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的函数的参数。 请参阅CompletionStage有关特殊完成规则的文档。
        参数类型
        U - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • applyToEitherAsync

        <U> CompletionStage<U> applyToEitherAsync​(CompletionStage<? extends T> other,
                                          Function<? super T,U> fn)
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供函数的参数。 请参阅CompletionStage文档，了解完整的规则。
        参数类型
        U - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • applyToEitherAsync

        <U> CompletionStage<U> applyToEitherAsync​(CompletionStage<? extends T> other,
                                          Function<? super T,U> fn,
                                          Executor executor)
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用提供的执行器执行，其中相应的结果作为参数提供给函数。 请参阅CompletionStage文档，了解完整的规则。
        参数类型
        U - 函数的返回类型
        参数
        other - 其他CompletionStage
        fn - 用于计算返回的CompletionStage的值的函数
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • acceptEither

        CompletionStage<Void> acceptEither​(CompletionStage<? extends T> other,
                                   Consumer<? super T> action)
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的操作的参数。 请参阅CompletionStage文档，了解完整的规则。
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • acceptEitherAsync

        CompletionStage<Void> acceptEitherAsync​(CompletionStage<? extends T> other,
                                        Consumer<? super T> action)
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供的操作的参数。 有关特殊完成的规则，请参阅CompletionStage文档。
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • acceptEitherAsync

        CompletionStage<Void> acceptEitherAsync​(CompletionStage<? extends T> other,
                                        Consumer<? super T> action,
                                        Executor executor)
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。 请参阅CompletionStage文档，了解完整的规则。
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • runAfterEither

        CompletionStage<Void> runAfterEither​(CompletionStage<?> other,
                                     Runnable action)
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行给定的操作。 有关特殊完成的规则，请参阅CompletionStage文档。
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • runAfterEitherAsync

        CompletionStage<Void> runAfterEitherAsync​(CompletionStage<?> other,
                                          Runnable action)
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。 请参阅CompletionStage文档，了解覆盖异常完成的规则。
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        结果
        新的CompletionStage

      • runAfterEitherAsync

        CompletionStage<Void> runAfterEitherAsync​(CompletionStage<?> other,
                                          Runnable action,
                                          Executor executor)
        返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。 请参阅CompletionStage文档，了解完整的规则。
        参数
        other - 其他CompletionStage
        action - 在完成返回的CompletionStage之前执行的操作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • thenCompose

        <U> CompletionStage<U> thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
        返回一个完成的新的CompletionStage，其值与给定函数返回的CompletionStage相同。

        当这个阶段正常完成时，以该阶段的结果作为参数调用给定的函数，返回另一个CompletionStage。 当该阶段正常完成时，此方法返回的CompletionStage将以相同的值完成。

        为了确保进度，提供的功能必须最终完成其结果。

        该方法类似于Optional.flatMap和Stream.flatMap 。

        有关特殊完成的规则，请参阅CompletionStage文档。

        参数类型
        U - 返回的CompletionStage结果的类型
        参数
        fn - 用于计算另一个CompletionStage的函数
        结果
        新的CompletionStage

      • thenComposeAsync

        <U> CompletionStage<U> thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
        返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用该阶段的默认异步执行工具执行。

        当这个阶段正常完成时，以该阶段的结果作为参数调用给定的函数，返回另一个CompletionStage。 当该阶段正常完成时，此方法返回的CompletionStage将以相同的值完成。

        为了确保进度，提供的功能必须最终完成其结果。

        请参阅CompletionStage文档，了解完整的规则。

        参数类型
        U - 返回的CompletionStage结果的类型
        参数
        fn - 用于计算另一个CompletionStage的函数
        结果
        新的CompletionStage

      • thenComposeAsync

        <U> CompletionStage<U> thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn,
                                        Executor executor)
        返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用提供的Executor执行。

        当这个阶段正常完成时，以该阶段的结果作为参数调用给定的函数，返回另一个CompletionStage。 当该阶段正常完成时，此方法返回的CompletionStage将以相同的值完成。

        为了确保进度，提供的功能必须最终完成其结果。

        请参阅CompletionStage文档，了解覆盖完成的规则。

        参数类型
        U - 返回的CompletionStage结果的类型
        参数
        fn - 用于计算另一个CompletionStage的函数
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • handle

        <U> CompletionStage<U> handle​(BiFunction<? super T,Throwable,? extends U> fn)
        返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用此阶段的结果和异常作为所提供函数的参数执行。

        当这个阶段完成时，使用结果（或null如果没有））和此阶段的异常（或null如果没有）作为参数）调用给定的函数，并且使用函数的结果来完成返回的阶段。

        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • handleAsync

        <U> CompletionStage<U> handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
        返回一个新的CompletionStage，当该阶段完成正常或异常时，将使用此阶段的默认异步执行工具执行，此阶段的结果和异常作为提供函数的参数。

        当这个阶段完成时，使用结果（或null如果没有））和此阶段的异常（或null如果没有）作为参数）调用给定函数，并使用函数的结果来完成返回的阶段。

        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        结果
        新的CompletionStage

      • handleAsync

        <U> CompletionStage<U> handleAsync​(BiFunction<? super T,Throwable,? extends U> fn,
                                   Executor executor)
        返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用提供的执行程序执行此阶段的结果和异常作为提供的函数的参数。

        当这个阶段完成时，使用结果（或者null如果没有）和这个阶段的异常（或者null如果没有）作为参数）调用给定的函数，并且使用函数的结果来完成返回的阶段。

        参数类型
        U - 函数的返回类型
        参数
        fn - 用于计算返回的CompletionStage的值的函数
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • whenComplete

        CompletionStage<T> whenComplete​(BiConsumer<? super T,? super Throwable> action)
        返回与此阶段相同的结果或异常的新CompletionStage，当此阶段完成时，它将执行给定的操作。

        当这个阶段完成时，使用结果（或null如果没有））和此阶段的异常（或null如果没有）作为参数）调用给定的操作。 返回的阶段在行动返回时完成。

        与方法handle不同，此方法不是设计为翻译完成结果，因此提供的操作不应抛出异常。 但是，如果这样做，则适用以下规则：如果此阶段正常完成，但提供的操作引发异常，则返回的阶段会以提供的操作异常完成。 或者，如果此阶段完成异常且提供的操作引发异常，那么返回的阶段会在此阶段异常结束。

        参数
        action - 要执行的动作
        结果
        新的CompletionStage

      • whenCompleteAsync

        CompletionStage<T> whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
        返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，将使用此阶段的默认异步执行工具执行给定操作。

        当这个阶段完成时，使用结果（或null如果没有））和此阶段的异常（或null如果没有）作为参数）调用给定的操作。 返回的阶段在行动返回时完成。

        与方法handleAsync不同，此方法不是设计为翻译完成结果，因此提供的操作不应抛出异常。 但是，如果这样做，则适用以下规则：如果此阶段正常完成但提供的操作引发异常，那么返回的阶段会以提供的操作异常完成。 或者，如果此阶段完成异常且提供的操作引发异常，那么返回的阶段会在此阶段异常结束。

        参数
        action - 要执行的动作
        结果
        新的CompletionStage

      • whenCompleteAsync

        CompletionStage<T> whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action,
                                     Executor executor)
        返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，使用提供的执行程序执行给定操作。

        当这个阶段完成时，使用结果（或者null如果没有）和异常（或null如果没有）作为参数调用给定的动作。 返回的阶段在行动返回时完成。

        与方法handleAsync不同，此方法不是设计为翻译完成结果，因此提供的操作不应抛出异常。 但是，如果这样做，则适用以下规则：如果此阶段正常完成但提供的操作引发异常，那么返回的阶段会以提供的操作异常完成。 或者，如果此阶段完成异常且提供的操作引发异常，那么返回的阶段会在此阶段异常结束。

        参数
        action - 要执行的动作
        executor - 执行器用于异步执行
        结果
        新的CompletionStage

      • exceptionally

        CompletionStage<T> exceptionally​(Function<Throwable,? extends T> fn)
        返回一个新的CompletionStage，当此阶段完成异常时，将以此阶段的异常作为提供函数的参数执行。 否则，如果此阶段正常完成，那么返回的阶段也会以相同的值正常完成。
        参数
        fn - 用于计算返回的CompletionStage的值的函数，如果此CompletionStage异常完成
        结果
        新的CompletionStage

      • toCompletableFuture

        CompletableFuture<T> toCompletableFuture​()
        返回一个CompletableFuture，保持与此阶段相同的完成属性。 如果这个阶段已经是一个CompletableFuture，那么这个方法本身就可以返回这个阶段。 否则，此方法的调用可能等同于thenApply(x -> x) ，但返回的类型为CompletableFuture的实例。
        结果
        the CompletableFuture
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConcurrentHashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ConcurrentHashMap<K,V>

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.concurrent.ConcurrentHashMap<K,V>
  • 参数类型
    K - 由该地图维护的键的类型
    V - 映射值的类型
    All Implemented Interfaces:
    Serializable ， ConcurrentMap<K,V> ， Map<K,V>

    public class ConcurrentHashMap<K,V>
extends AbstractMap<K,V>
implements ConcurrentMap<K,V>, Serializable
    支持检索的完全并发性和更新的高预期并发性的哈希表。 该类符合与Hashtable相同的功能规范，并包括与Hashtable每种方法对应的方法的Hashtable 。 不过，尽管所有操作都是线程安全的，检索操作并不意味着锁定，并没有为防止所有访问的方式锁定整个表的任何支持。 这个课程在程序中完全可以与Hashtable进行互操作，程序依赖于其线程安全性，但不依赖于其同步细节。

    检索操作（包括get ）通常不阻止，因此可能与更新操作重叠（包括put和remove ）。 检索反映了最近完成的更新操作的结果。 （更正式地，对于给定密钥的更新操作熊之前发生与任何（非空关系）检索该键报告经更新的值。）对于聚合操作，比如putAll和clear ，并发检索可能反映插入或移除只有一些条目。 类似地，迭代器，分割器和枚举返回在反映迭代器/枚举创建过程中或之后反映哈希表状态的元素。 他们不抛出ConcurrentModificationException 。 然而，迭代器被设计为一次只能由一个线程使用。 请记住，骨料状态方法的结果，包括size ， isEmpty ，并containsValue通常是有用的，只有当一个地图没有发生在其他线程并发更新。 否则，这些方法的结果反映了可能足以用于监视或估计目的的瞬态状态，但不适用于程序控制。

    当存在太多的冲突（即，具有不同的哈希码但是以表的大小为模数落入相同的时隙的密钥）时，该表被动态扩展，并且每个映射保持大致两个bin的预期平均效果（对应于0.75负载调整大小的因子阈值）。 这个平均值可能会有很多变化，因为映射被添加和删除，但是总的来说，这为哈希表保留了普遍接受的时间/空间权衡。 然而，调整这个或任何其他类型的散列表可能是相对较慢的操作。 如果可能，最好提供一个大小估计作为可选的initialCapacity构造函数参数。 附加的可选的loadFactor构造函数参数提供了通过指定在计算给定数量的元素时要分配的空间量而使用的表密度来定制初始表容量的另一种方法。 此外，为了与此类的以前版本兼容，构造函数可以可选地指定预期的concurrencyLevel作为内部大小调整的附加提示。 请注意，使用完全相同的许多键hashCode()是降低任何哈希表的性能的一种可靠的方法。 为了改善影响，当按键为Comparable时 ，该类可以使用键之间的比较顺序来帮助打破关系。

    甲Set投影一个的ConcurrentHashMap可以（使用被创建newKeySet()或newKeySet(int) ），或观察（使用keySet(Object)时仅键是感兴趣的，并且被映射的值是（可能瞬时）不使用或全部取相同的映射值。

    ConcurrentHashMap可以通过使用LongAdder值作为可缩放频率映射（直方图或多分集的形式），并通过computeIfAbsent进行初始化。 例如，要添加一个计数到ConcurrentHashMap<String,LongAdder> freqs ，可以使用freqs.computeIfAbsent(key, k -> new LongAdder()).increment();

    该类及其视图和迭代器实现了Map和Iterator接口的所有可选方法。

    像Hashtable但不像HashMap ，此类不允许 null用作键或值。

    ConcurrentHashMaps支持一系列顺序和并行批量操作，与大多数Stream方法不同，它们被设计为安全并且经常明智地应用，即使是由其他线程同时更新的映射; 例如，当计算共享注册表中的值的快照摘要时。 有三种操作，每种具有四种形式，接受键，值，条目和（键，值）对作为参数和/或返回值的函数。 由于ConcurrentHashMap的元素不以任何特定的方式排序，并且可能会在不同的并行执行中以不同的顺序进行处理，因此提供的函数的正确性不应该依赖于任何排序，或者任何其他可能瞬时变化的对象或值计算进行中; 除了每一个行动，理想情况下都是无副作用的。 对Map.Entry对象的批量操作不支持方法setValue 。

    • forEach：对每个元素执行给定的操作。 变量形式在执行操作之前对每个元素应用给定的变换。
    • search：返回在每个元素上应用给定函数的第一个可用非空结果; 当找到结果时跳过进一步的搜索。
    • reduce：累积每个元素。 提供的减少功能不能依赖于排序（更正式地，它应该是关联和交换）。 有五种变体：
      • 平原减少 （由于没有相应的返回类型，因此（key，value）函数参数没有这种方法的形式）
      • 映射的减少积累了应用于每个元素的给定函数的结果。
      • 使用给定的基础值减少到标量双，长和int。

    这些批量操作接受一个parallelismThreshold参数。 如果估计当前地图大小小于给定阈值，则方法依次进行。 使用值Long.MAX_VALUE抑制所有的并行性。 使用1的值通过分区到足够的子任务来完全利用用于所有并行计算的ForkJoinPool.commonPool()来实现最大并行度。 通常，您最初将选择其中一个极值，然后测量使用中间值之间的性能，从而降低开销与吞吐量之间的关系。

    批量操作的并发属性遵循ConcurrentHashMap的并发属性：从get(key)返回的任何非空结果和相关的访问方法与关联的插入或更新之间发生的事件关系。 任何批量操作的结果反映了这些每个元素关系的组合（但是除非以某种方式已知静止），而且对于整个地图而言并不一定是原子的。 相反，因为映射中的键和值从不为空，所以null作为目前缺乏任何结果的可靠原子指标。 为了保持此属性，null用作所有非标量缩减操作的隐含基础。 对于double，long和int版本，基础应该是当与任何其他值组合时返回其他值（更正式地，它应该是减少的标识元素）。 最常见的减少有这些属性; 例如，使用基数0或最小值与基准MAX_VALUE计算和。

    作为参数提供的搜索和转换函数应该类似地返回null以指示缺少任何结果（在这种情况下不被使用）。 在映射缩减的情况下，这也使得转换可以用作过滤器，如果不应该组合元素，返回null（或者在原始专业化的情况下，身份基础）。 在使用它们进行搜索或减少操作之前，您可以通过在“null意味着现在没有任何内容”规则下自行构建复合转换和过滤。

    接受和/或返回Entry参数的方法维护键值关联。 例如，当找到最大价值的钥匙时，它们可能是有用的。 请注意，可以使用new AbstractMap.SimpleEntry(k,v)提供“plain”Entry参数。

    批量操作可能突然完成，抛出在应用程序中遇到的异常。 在处理这样的异常时，请注意，其他并发执行的函数也可能引发异常，或者如果没有发生第一个异常，则会这样做。

    与顺序形式相比，加速比是常见的，但不能保证。 如果并行计算的基础工作比计算本身更昂贵，则涉及小地图上的简短功能的并行操作可能比顺序形式执行得更慢。 类似地，如果所有处理器正忙于执行不相关的任务，并行化可能不会导致太多的实际并行。

    所有任务方法的所有参数都必须为非空值。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ConcurrentHashMap.KeySetView<K,V>
      ConcurrentHashMap视图为一个Set的键，其中可以通过映射到公共值来选择添加。

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConcurrentHashMap​()
      创建一个新的，空的地图与默认的初始表大小（16）。
      ConcurrentHashMap​(int initialCapacity)
      创建一个新的空的地图，其初始表格大小适应指定数量的元素，而不需要动态调整大小。
      ConcurrentHashMap​(int initialCapacity, float loadFactor)
      根据给定数量的元素（ initialCapacity ）和初始表密度（ loadFactor ），创建一个新的，空的地图，初始的表格大小。
      ConcurrentHashMap​(int initialCapacity, float loadFactor, int concurrencyLevel)
      创建具有基于给定数量的元件（初始表大小的新的空映射 initialCapacity ），表密度（ loadFactor ），并同时更新线程（数 concurrencyLevel ）。
      ConcurrentHashMap​(Map<? extends K,? extends V> m)
      创建与给定地图相同的映射的新地图。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      从这张地图中删除所有的映射。
      V compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      V computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联，则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      V computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果存在指定键的值，则尝试计算给出键的新映射及其当前映射值。
      boolean contains​(Object value)
      测试一些键映射到此表中的指定值。
      boolean containsKey​(Object key)
      测试此表中的指定对象是否为键。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      Enumeration<V> elements​()
      返回此表中值的枚举。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      boolean equals​(Object o)
      将指定的对象与此映射进行比较以获得相等性。
      void forEach​(long parallelismThreshold, BiConsumer<? super K,? super V> action)
      对每个（键，值）执行给定的动作。
      <U> void forEach​(long parallelismThreshold, BiFunction<? super K,? super V,? extends U> transformer, Consumer<? super U> action)
      对每个（key，value）的每个非空变换执行给定的动作。
      void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      void forEachEntry​(long parallelismThreshold, Consumer<? super Map.Entry<K,V>> action)
      对每个条目执行给定的操作。
      <U> void forEachEntry​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> transformer, Consumer<? super U> action)
      对每个条目的每个非空变换执行给定的操作。
      void forEachKey​(long parallelismThreshold, Consumer<? super K> action)
      对每个键执行给定的动作。
      <U> void forEachKey​(long parallelismThreshold, Function<? super K,? extends U> transformer, Consumer<? super U> action)
      对每个键的每个非空变换执行给定的动作。
      void forEachValue​(long parallelismThreshold, Consumer<? super V> action)
      对每个值执行给定的操作。
      <U> void forEachValue​(long parallelismThreshold, Function<? super V,? extends U> transformer, Consumer<? super U> action)
      对每个值的每个非空转换执行给定的动作。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。
      V getOrDefault​(Object key, V defaultValue)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回给定的默认值。
      int hashCode​()
      返回此Map的哈希码值，即映射中每个键值对的总和，即key.hashCode() ^ value.hashCode() 。
      boolean isEmpty​()
      如果此映射不包含键值映射，则返回 true 。
      Enumeration<K> keys​()
      返回此表中键的枚举。
      ConcurrentHashMap.KeySetView<K,V> keySet​()
      返回此地图中包含的键的Set视图。
      ConcurrentHashMap.KeySetView<K,V> keySet​(V mappedValue)
      使用给定的公共映射值为任何添加（即Collection.add(E)和Collection.addAll(Collection) ）返回此映射中的密钥的Set视图。
      long mappingCount​()
      返回映射数。
      V merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与（非空）值相关联，则将其与给定值相关联。
      static <K> ConcurrentHashMap.KeySetView<K,Boolean> newKeySet​()
      创建一个新的Set支持的ConcurrentHashMap从给定的类型到Boolean.TRUE 。
      static <K> ConcurrentHashMap.KeySetView<K,Boolean> newKeySet​(int initialCapacity)
      创建一个新的Set支持的ConcurrentHashMap从给定的类型到Boolean.TRUE 。
      V put​(K key, V value)
      将指定的键映射到此表中的指定值。
      void putAll​(Map<? extends K,? extends V> m)
      将指定地图的所有映射复制到此映射。
      V putIfAbsent​(K key, V value)
      如果指定的键尚未与值相关联，则将其与给定值相关联。
      <U> U reduce​(long parallelismThreshold, BiFunction<? super K,? super V,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到组合值的结果，如果没有则返回null。
      Map.Entry<K,V> reduceEntries​(long parallelismThreshold, BiFunction<Map.Entry<K,V>,Map.Entry<K,V>,? extends Map.Entry<K,V>> reducer)
      返回使用给定的reducer累加所有条目的结果，以组合值，如果没有则返回null。
      <U> U reduceEntries​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer将所有条目的给定变换累加到组合值的结果，否则返回null。
      double reduceEntriesToDouble​(long parallelismThreshold, ToDoubleFunction<Map.Entry<K,V>> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      int reduceEntriesToInt​(long parallelismThreshold, ToIntFunction<Map.Entry<K,V>> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      long reduceEntriesToLong​(long parallelismThreshold, ToLongFunction<Map.Entry<K,V>> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      K reduceKeys​(long parallelismThreshold, BiFunction<? super K,? super K,? extends K> reducer)
      返回使用给定的reducer累加所有键的结果，以组合值，如果没有则返回null。
      <U> U reduceKeys​(long parallelismThreshold, Function<? super K,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer将所有键的给定变换累加到组合值的结果，否则返回null。
      double reduceKeysToDouble​(long parallelismThreshold, ToDoubleFunction<? super K> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
      int reduceKeysToInt​(long parallelismThreshold, ToIntFunction<? super K> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
      long reduceKeysToLong​(long parallelismThreshold, ToLongFunction<? super K> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
      double reduceToDouble​(long parallelismThreshold, ToDoubleBiFunction<? super K,? super V> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
      int reduceToInt​(long parallelismThreshold, ToIntBiFunction<? super K,? super V> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
      long reduceToLong​(long parallelismThreshold, ToLongBiFunction<? super K,? super V> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
      V reduceValues​(long parallelismThreshold, BiFunction<? super V,? super V,? extends V> reducer)
      返回使用给定的reducer累加所有值的结果，以组合值，如果没有则返回null。
      <U> U reduceValues​(long parallelismThreshold, Function<? super V,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer累加所有值的给定变换以组合值的结果，否则返回null。
      double reduceValuesToDouble​(long parallelismThreshold, ToDoubleFunction<? super V> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。
      int reduceValuesToInt​(long parallelismThreshold, ToIntFunction<? super V> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。
      long reduceValuesToLong​(long parallelismThreshold, ToLongFunction<? super V> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。
      V remove​(Object key)
      从该地图中删除键（及其对应的值）。
      boolean remove​(Object key, Object value)
      仅当当前映射到给定值时才删除密钥的条目。
      V replace​(K key, V value)
      仅当当前映射到某个值时才替换该项的条目。
      boolean replace​(K key, V oldValue, V newValue)
      仅当当前映射到给定值时才替换密钥的条目。
      void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      <U> U search​(long parallelismThreshold, BiFunction<? super K,? super V,? extends U> searchFunction)
      通过在每个（键，值）上应用给定的搜索函数返回非空结果，如果没有则返回null。
      <U> U searchEntries​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> searchFunction)
      返回一个非空结果，从每个条目应用给定的搜索函数，如果没有，则返回null。
      <U> U searchKeys​(long parallelismThreshold, Function<? super K,? extends U> searchFunction)
      返回一个非空结果，在每个键上应用给定的搜索功能，如果没有，返回null。
      <U> U searchValues​(long parallelismThreshold, Function<? super V,? extends U> searchFunction)
      返回一个非空结果，对每个值应用给定的搜索函数，如果没有，返回null。
      int size​()
      返回此地图中键值映射的数量。
      String toString​()
      返回此地图的字符串表示形式。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from class java.util.AbstractMap

        clone

      • Methods inherited from interface java.util.Map

        entry, of, of, of, of, of, of, of, of, of, of, of, ofEntries

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ConcurrentHashMap

        public ConcurrentHashMap​()
        创建一个新的，空的地图与默认的初始表大小（16）。

      • ConcurrentHashMap

        public ConcurrentHashMap​(int initialCapacity)
        创建一个新的空的地图，其初始表格大小适应指定数量的元素，而不需要动态调整大小。
        参数
        initialCapacity - 该实现执行内部大小调整以适应这许多元素。
        异常
        IllegalArgumentException - 元素的初始容量是否为负

      • ConcurrentHashMap

        public ConcurrentHashMap​(Map<? extends K,? extends V> m)
        创建与给定地图相同的映射的新地图。
        参数
        m - 地图

      • ConcurrentHashMap

        public ConcurrentHashMap​(int initialCapacity,
                         float loadFactor)
        根据给定数量的元素（ initialCapacity ）和初始表密度（ loadFactor ），创建一个新的，空的地图，初始的表格大小。
        参数
        initialCapacity - 初始容量。 考虑到指定的负载因子，实现执行内部大小调整以适应这许多元素。
        loadFactor - 用于建立初始表大小的负载因子（表密度）
        异常
        IllegalArgumentException - 如果元件的初始容量为负值或负载因子为非正值
        从以下版本开始：
        1.6

      • ConcurrentHashMap

        public ConcurrentHashMap​(int initialCapacity,
                         float loadFactor,
                         int concurrencyLevel)
        创建具有基于给定数量的元件（初始表大小的新的空映射 initialCapacity ），表密度（ loadFactor ），并同时更新线程（数 concurrencyLevel ）。
        参数
        initialCapacity - 初始容量。 考虑到指定的负载因子，实现执行内部大小调整以适应这许多元素。
        loadFactor - 用于建立初始表大小的负载因子（表密度）
        concurrencyLevel - 同时更新线程的估计数。 实现可以将此值用作大小提示。
        异常
        IllegalArgumentException - 如果初始容量为负值或负载因子或并发 IllegalArgumentException为非正性

    • 方法详细信息

      • size

        public int size​()
        返回此地图中键值映射的数量。 如果地图包含Integer.MAX_VALUE元素，返回Integer.MAX_VALUE 。
        Specified by:
        size接口 Map<K,V>
        重写：
        size中的 AbstractMap<K,V>
        结果
        该地图中键值映射的数量

      • isEmpty

        public boolean isEmpty​()
        如果此映射不包含键值映射，则返回 true 。
        Specified by:
        isEmpty在接口 Map<K,V>
        重写：
        isEmpty中的 AbstractMap<K,V>
        结果
        true如果该地图不包含键值映射

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回null 。

        更正式地，如果该映射包含从键k到值v的映射，使得key.equals(k) ，则该方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        Specified by:
        get在接口 Map<K,V>
        重写：
        get在 AbstractMap<K,V>
        参数
        key - 要返回其关联值的键
        结果
        映射指定键的值，如果此映射不包含键的映射， null
        异常
        NullPointerException - 如果指定的键为空

      • containsKey

        public boolean containsKey​(Object key)
        测试此表中的指定对象是否为键。
        Specified by:
        containsKey在接口 Map<K,V>
        重写：
        containsKey在 AbstractMap<K,V>
        参数
        key - 可能的钥匙
        结果
        true当且仅当指定的对象是该表中的键时，由equals方法确定; 否则为false
        异常
        NullPointerException - 如果指定的键为空

      • containsValue

        public boolean containsValue​(Object value)
        如果此映射将一个或多个键映射到指定的值，则返回true 。 注意：此方法可能需要对地图进行全面遍历，并且比方法containsKey慢得多。
        Specified by:
        containsValue在接口 Map<K,V>
        重写：
        containsValue类 AbstractMap<K,V>
        参数
        value - 要在此地图中存在的值要进行测试
        结果
        true如果该地图将一个或多个键映射到指定的值
        异常
        NullPointerException - 如果指定的值为空

      • put

        public V put​(K key,
             V value)
        将指定的键映射到此表中的指定值。 密钥和值都不能为空。

        可以通过使用等于原始密钥的密钥调用get方法来检索该值。

        Specified by:
        put在接口 Map<K,V>
        重写：
        put在 AbstractMap<K,V>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        以前的值与相关 key ，或 null如果没有映射 key
        异常
        NullPointerException - 如果指定的键或值为空

      • putAll

        public void putAll​(Map<? extends K,? extends V> m)
        将指定地图的所有映射复制到此映射。 这些映射取代了该地图对当前指定地图中的任何键的任何映射。
        Specified by:
        putAll在接口 Map<K,V>
        重写：
        putAll在 AbstractMap<K,V>
        参数
        m - 要存储在此地图中的映射

      • remove

        public V remove​(Object key)
        从该地图中删除键（及其对应的值）。 如果键不在地图中，此方法不执行任何操作。
        Specified by:
        remove在接口 Map<K,V>
        重写：
        remove在 AbstractMap<K,V>
        参数
        key - 需要删除的关键
        结果
        以前的值与相关 key ，或 null如果没有映射 key
        异常
        NullPointerException - 如果指定的键为空

      • clear

        public void clear​()
        从这张地图中删除所有的映射。
        Specified by:
        clear在接口 Map<K,V>
        重写：
        clear在 AbstractMap<K,V>

      • keySet

        public ConcurrentHashMap.KeySetView<K,V> keySet​()
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该组支持元件移除，即从该映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。

        视图的迭代器和拼接器是weakly consistent 。

        视图的spliterator报告Spliterator.CONCURRENT ， Spliterator.DISTINCT ，并Spliterator.NONNULL 。

        Specified by:
        keySet在接口 Map<K,V>
        重写：
        keySet在 AbstractMap<K,V>
        结果
        设置视图

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该collection支持元素移除，即从该映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。

        视图的迭代器和拼接器是weakly consistent 。

        该视图的spliterator报告Spliterator.CONCURRENT和Spliterator.NONNULL 。

        Specified by:
        values在接口 Map<K,V>
        重写：
        values在 AbstractMap<K,V>
        结果
        集合视图

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。

        视图的迭代器和拼接器是weakly consistent 。

        视图的spliterator报告Spliterator.CONCURRENT ， Spliterator.DISTINCT ，并Spliterator.NONNULL 。

        Specified by:
        entrySet在接口 Map<K,V>
        Specified by:
        entrySet在 AbstractMap<K,V>
        结果
        设置视图

      • hashCode

        public int hashCode​()
        返回此Map的哈希码值，即映射中每个键值对的总和，即key.hashCode() ^ value.hashCode() 。
        Specified by:
        hashCode在接口 Map<K,V>
        重写：
        hashCode在 AbstractMap<K,V>
        结果
        该地图的哈希码值
        另请参见：
        Map.Entry.hashCode() ，
Object.equals(Object) ，
Set.equals(Object)

      • toString

        public String toString​()
        返回此地图的字符串表示形式。 字符串表示由包含在大括号（“ {} ”）中的键值映射列表（无特殊顺序）组成。 相邻的映射由字符", " （逗号和空格）分隔。 每个键值映射都作为键后跟一个等号（“ = ”），后跟相关值。
        重写：
        toString在 AbstractMap<K,V>
        结果
        该地图的字符串表示形式

      • equals

        public boolean equals​(Object o)
        将指定的对象与此映射进行比较以获得相等性。 如果给定的对象是与该映射相同的映射的映射，则返回true 。 如果在执行此方法期间同时修改了映射，则此操作可能会返回误导结果。
        Specified by:
        equals在接口 Map<K,V>
        重写：
        equals在 AbstractMap<K,V>
        参数
        o - 要与此映射相等的对象进行比较
        结果
        true如果指定的对象等于此映射
        另请参见：
        Object.hashCode() ， HashMap

      • putIfAbsent

        public V putIfAbsent​(K key,
                     V value)
        如果指定的键尚未与值相关联，则将其与给定值相关联。 这相当于，对于这个map ：
           if (!map.containsKey(key)) return map.put(key, value); else return map.get(key);
        除了动作以原子方式执行。
        Specified by:
        putIfAbsent在接口 ConcurrentMap<K,V>
        Specified by:
        putIfAbsent在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null
        异常
        NullPointerException - 如果指定的键或值为空

      • remove

        public boolean remove​(Object key,
                      Object value)
        仅当当前映射到给定值时才删除密钥的条目。 这相当于，对于这个map ：
           if (map.containsKey(key) && Objects.equals(map.get(key), value)) { map.remove(key); return true; } else { return false; }
        除了动作以原子方式执行。
        Specified by:
        remove在接口 ConcurrentMap<K,V>
        Specified by:
        remove在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        value - 预期与指定键相关联的值
        结果
        true如果该值被删除
        异常
        NullPointerException - 如果指定的键为空

      • replace

        public boolean replace​(K key,
                       V oldValue,
                       V newValue)
        仅当当前映射到给定值时才替换密钥的条目。 这相当于，对于这个map ：
           if (map.containsKey(key) && Objects.equals(map.get(key), oldValue)) { map.put(key, newValue); return true; } else { return false; }
        除了动作以原子方式执行。
        Specified by:
        replace在接口 ConcurrentMap<K,V>
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        oldValue - 预期与指定键相关联的值
        newValue - 与指定键相关联的值
        结果
        true如果值被替换
        异常
        NullPointerException - 如果任何参数为空

      • replace

        public V replace​(K key,
                 V value)
        仅当当前映射到某个值时才替换该项的条目。 这相当于，对于这个map ：
           if (map.containsKey(key)) return map.put(key, value); else return null;
        除了动作以原子方式执行。
        Specified by:
        replace在接口 ConcurrentMap<K,V>
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null
        异常
        NullPointerException - 如果指定的键或值为空

      • getOrDefault

        public V getOrDefault​(Object key,
                      V defaultValue)
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回给定的默认值。
        Specified by:
        getOrDefault在接口 ConcurrentMap<K,V>
        Specified by:
        getOrDefault在接口 Map<K,V>
        参数
        key - 要返回其关联值的键
        defaultValue - 如果此映射不包含给定键的映射，则返回的值
        结果
        键的映射，如果存在; 否则为默认值
        异常
        NullPointerException - 如果指定的键为空

      • forEach

        public void forEach​(BiConsumer<? super K,? super V> action)
        描述从接口ConcurrentMap复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach接口 ConcurrentMap<K,V>
        Specified by:
        forEach接口 Map<K,V>
        参数
        action - 要为每个条目执行的操作

      • replaceAll

        public void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        说明从界面ConcurrentMap复制
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll接口 ConcurrentMap<K,V>
        Specified by:
        replaceAll在接口 Map<K,V>
        参数
        function - 应用于每个条目的功能

      • computeIfAbsent

        public V computeIfAbsent​(K key,
                         Function<? super K,? extends V> mappingFunction)
        如果指定的键尚未与值相关联，则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是null 。 整个方法调用是以原子方式执行的，因此每个键最多应用一次该函数。 在计算过程中可能会阻止其他线程对该映射进行的某些尝试更新操作，因此计算应该简单而简单，不得尝试更新此映射的任何其他映射。
        Specified by:
        computeIfAbsent在接口 ConcurrentMap<K,V>
        Specified by:
        computeIfAbsent在接口 Map<K,V>
        参数
        key - 与其相关联的指定值的键
        mappingFunction - 计算值的函数
        结果
        与指定键相关联的当前（现有或计算）值，如果计算值为空，则为null
        异常
        NullPointerException - 如果指定的键或mappingFunction为空
        IllegalStateException - 如果计算可检测地尝试对此地图的递归更新，否则将永远不会完成
        RuntimeException - 或者如果mappingFunction这样做，则出错，在这种情况下，映射未建立

      • computeIfPresent

        public V computeIfPresent​(K key,
                          BiFunction<? super K,? super V,? extends V> remappingFunction)
        如果存在指定键的值，则尝试计算给出键的新映射及其当前映射值。 整个方法调用是以原子方式执行的。 在计算过程中可能会阻止其他线程对该映射进行的某些尝试更新操作，因此计算应该简单而简单，不得尝试更新此映射的任何其他映射。
        Specified by:
        computeIfPresent在接口 ConcurrentMap<K,V>
        Specified by:
        computeIfPresent在接口 Map<K,V>
        参数
        key - 值可以与之相关联的键
        remappingFunction - 计算值的函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        NullPointerException - 如果指定的键或 NullPointerException为空
        IllegalStateException - 如果计算可检测地尝试对该映射的递归更新，否则将永远不会完成
        RuntimeException - 或者如果重映射功能如此，则出错，在这种情况下映射不变

      • compute

        public V compute​(K key,
                 BiFunction<? super K,? super V,? extends V> remappingFunction)
        尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则null ）。 整个方法调用是以原子方式执行的。 在计算过程中可能会阻止其他线程对此映射进行的一些尝试更新操作，因此计算应该简单而简单，而且不得尝试更新此Map的任何其他映射。
        Specified by:
        compute在接口 ConcurrentMap<K,V>
        Specified by:
        compute在接口 Map<K,V>
        参数
        key - 要与其关联的指定值的键
        remappingFunction - 计算值的函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        NullPointerException - 如果指定的键或 NullPointerException为空
        IllegalStateException - 如果计算可检测地尝试对该映射的递归更新，否则将永远不会完成
        RuntimeException - 或者如果重映射功能如此，则出错，在这种情况下映射不变

      • merge

        public V merge​(K key,
               V value,
               BiFunction<? super V,? super V,? extends V> remappingFunction)
        如果指定的键尚未与（非空）值相关联，则将其与给定值相关联。 否则，使用给定的重映射函数的结果替换该值，如果为null ，则将其null 。 整个方法调用是以原子方式执行的。 在计算过程中可能会阻止其他线程对此映射进行的一些尝试更新操作，因此计算应该简单而简单，而且不得尝试更新此Map的任何其他映射。
        Specified by:
        merge在接口 ConcurrentMap<K,V>
        Specified by:
        merge在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        value - 缺席时使用的值
        remappingFunction - 重新计算值（如果存在）的功能
        结果
        与指定键相关的新值，如果没有则为null
        异常
        NullPointerException - 如果指定的键或 NullPointerException为空
        RuntimeException - 或者如果重映射功能如此，则出错，在这种情况下映射不变

      • contains

        public boolean contains​(Object value)
        测试一些键映射到此表中的指定值。

        请注意，此方法在功能上与containsValue(Object)完全相同 ，仅存在于确保完全兼容Hashtable ，它在引入Java Collections Framework之前支持此方法。

        参数
        value - 要搜索的值
        结果
        true当且仅当某些键映射到本表中的value参数，由equals方法确定; 否则为false
        异常
        NullPointerException - 如果指定的值为空

      • keys

        public Enumeration<K> keys​()
        返回此表中键的枚举。
        结果
        这个表中的键的枚举
        另请参见：
        keySet()

      • elements

        public Enumeration<V> elements​()
        返回此表中值的枚举。
        结果
        枚举此表中的值
        另请参见：
        values()

      • mappingCount

        public long mappingCount​()
        返回映射数。 应使用此方法代替size()，因为ConcurrentHashMap可能包含比可以表示为int的更多映射。 返回的值是估计值; 如果并发插入或移除，实际计数可能会有所不同。
        结果
        映射的数量
        从以下版本开始：
        1.8

      • newKeySet

        public static <K> ConcurrentHashMap.KeySetView<K,Boolean> newKeySet​()
        创建一个新的Set ，由给定类型的ConcurrentHashMap支持Boolean.TRUE 。
        参数类型
        K - 返回集合的元素类型
        结果
        新集
        从以下版本开始：
        1.8

      • newKeySet

        public static <K> ConcurrentHashMap.KeySetView<K,Boolean> newKeySet​(int initialCapacity)
        创建一个新的Set由ConcurrentHashMap从给定类型支持到Boolean.TRUE 。
        参数类型
        K - 返回集合的元素类型
        参数
        initialCapacity - 该实现执行内部大小调整以适应这许多元素。
        结果
        新集
        异常
        IllegalArgumentException - 元素的初始容量是否为负
        从以下版本开始：
        1.8

      • keySet

        public ConcurrentHashMap.KeySetView<K,V> keySet​(V mappedValue)
        返回Set此地图中的键的视图，使用给定的公共映射值进行任何添加（即Collection.add(E)和Collection.addAll(Collection) ）。 这当然只适用于从这个视图中为所有添加使用相同的值。
        参数
        mappedValue - 用于任何添加的映射值
        结果
        设置视图
        异常
        NullPointerException - 如果mappedValue为null

      • forEach

        public void forEach​(long parallelismThreshold,
                    BiConsumer<? super K,? super V> action)
        对每个（键，值）执行给定的动作。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        action - 行动
        从以下版本开始：
        1.8

      • forEach

        public <U> void forEach​(long parallelismThreshold,
                        BiFunction<? super K,? super V,? extends U> transformer,
                        Consumer<? super U> action)
        对每个（key，value）的每个非空变换执行给定的动作。
        参数类型
        U - 变压器的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素数量（估计）
        transformer - 返回元素的变换的函数，如果没有变换，则返回null（在这种情况下不应用动作）
        action - 行动
        从以下版本开始：
        1.8

      • search

        public <U> U search​(long parallelismThreshold,
                    BiFunction<? super K,? super V,? extends U> searchFunction)
        通过在每个（键，值）上应用给定的搜索函数返回非空结果，如果没有则返回null。 成功后，进一步的元素处理被抑制，并且搜索功能的任何其他并行调用的结果被忽略。
        参数类型
        U - 搜索功能的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        searchFunction - 成功返回非空结果的函数，否则为null
        结果
        在每个（键值）上应用给定搜索函数的非空结果，如果没有，则返回null
        从以下版本开始：
        1.8

      • reduce

        public <U> U reduce​(long parallelismThreshold,
                    BiFunction<? super K,? super V,? extends U> transformer,
                    BiFunction<? super U,? super U,? extends U> reducer)
        返回使用给定的reducer将所有（key，value）对的给定变换累加到组合值的结果，如果没有则返回null。
        参数类型
        U - 变压器的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 一个返回元素的变换的函数，如果没有转换，则返回null（在这种情况下不进行组合）
        reducer - 一种交换联想组合函数
        结果
        所有（键，值）对的累加给定变换的结果
        从以下版本开始：
        1.8

      • reduceToDouble

        public double reduceToDouble​(long parallelismThreshold,
                             ToDoubleBiFunction<? super K,? super V> transformer,
                             double basis,
                             DoubleBinaryOperator reducer)
        返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 交换联想组合函数
        结果
        所有（键，值）对的累加给定变换的结果
        从以下版本开始：
        1.8

      • reduceToLong

        public long reduceToLong​(long parallelismThreshold,
                         ToLongBiFunction<? super K,? super V> transformer,
                         long basis,
                         LongBinaryOperator reducer)
        返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 一种交换联想组合函数
        结果
        所有（键，值）对的累加给定变换的结果
        从以下版本开始：
        1.8

      • reduceToInt

        public int reduceToInt​(long parallelismThreshold,
                       ToIntBiFunction<? super K,? super V> transformer,
                       int basis,
                       IntBinaryOperator reducer)
        返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素数量（估计）
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 一种交换联想组合函数
        结果
        所有（键，值）对的累加给定变换的结果
        从以下版本开始：
        1.8

      • forEachKey

        public void forEachKey​(long parallelismThreshold,
                       Consumer<? super K> action)
        对每个键执行给定的动作。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        action - 行动
        从以下版本开始：
        1.8

      • forEachKey

        public <U> void forEachKey​(long parallelismThreshold,
                           Function<? super K,? extends U> transformer,
                           Consumer<? super U> action)
        对每个键的每个非空变换执行给定的动作。
        参数类型
        U - 变压器的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素的变换的函数，如果没有变换，则返回null（在这种情况下不应用动作）
        action - 行动
        从以下版本开始：
        1.8

      • searchKeys

        public <U> U searchKeys​(long parallelismThreshold,
                        Function<? super K,? extends U> searchFunction)
        返回一个非空结果，在每个键上应用给定的搜索功能，如果没有，返回null。 成功后，进一步的元素处理被抑制，并且搜索功能的任何其他并行调用的结果被忽略。
        参数类型
        U - 搜索功能的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        searchFunction - 成功返回非空结果的函数，否则为null
        结果
        在每个键上应用给定搜索功能的非空结果，如果没有，则为null
        从以下版本开始：
        1.8

      • reduceKeys

        public K reduceKeys​(long parallelismThreshold,
                    BiFunction<? super K,? super K,? extends K> reducer)
        返回使用给定的reducer累加所有键的结果，以组合值，如果没有则返回null。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        reducer - 一种交换关联组合函数
        结果
        使用给定的reducer累积所有键的结果来组合值，如果没有，则为null
        从以下版本开始：
        1.8

      • reduceKeys

        public <U> U reduceKeys​(long parallelismThreshold,
                        Function<? super K,? extends U> transformer,
                        BiFunction<? super U,? super U,? extends U> reducer)
        返回使用给定的reducer将所有键的给定变换累加到组合值的结果，否则返回null。
        参数类型
        U - 变压器的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素数量（估计）
        transformer - 一个返回元素变换的函数，如果没有变换，则返回null（在这种情况下不组合）
        reducer - 交换联想组合函数
        结果
        积累所有键的给定变换的结果
        从以下版本开始：
        1.8

      • reduceKeysToDouble

        public double reduceKeysToDouble​(long parallelismThreshold,
                                 ToDoubleFunction<? super K> transformer,
                                 double basis,
                                 DoubleBinaryOperator reducer)
        返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 交换联想组合函数
        结果
        积累所有键的给定变换的结果
        从以下版本开始：
        1.8

      • reduceKeysToLong

        public long reduceKeysToLong​(long parallelismThreshold,
                             ToLongFunction<? super K> transformer,
                             long basis,
                             LongBinaryOperator reducer)
        返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素的变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 交换联想组合函数
        结果
        积累所有键的给定变换的结果
        从以下版本开始：
        1.8

      • reduceKeysToInt

        public int reduceKeysToInt​(long parallelismThreshold,
                           ToIntFunction<? super K> transformer,
                           int basis,
                           IntBinaryOperator reducer)
        返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 交换联想组合功能
        结果
        积累所有键的给定变换的结果
        从以下版本开始：
        1.8

      • forEachValue

        public void forEachValue​(long parallelismThreshold,
                         Consumer<? super V> action)
        对每个值执行给定的操作。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        action - 行动
        从以下版本开始：
        1.8

      • forEachValue

        public <U> void forEachValue​(long parallelismThreshold,
                             Function<? super V,? extends U> transformer,
                             Consumer<? super U> action)
        对每个值的每个非空转换执行给定的动作。
        参数类型
        U - 变压器的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素的变换的函数，如果没有变换，则返回null（在这种情况下，不应用动作）
        action - 行动
        从以下版本开始：
        1.8

      • searchValues

        public <U> U searchValues​(long parallelismThreshold,
                          Function<? super V,? extends U> searchFunction)
        返回一个非空结果，对每个值应用给定的搜索函数，如果没有，返回null。 成功后，进一步的元素处理被抑制，并且搜索功能的任何其他并行调用的结果被忽略。
        参数类型
        U - 搜索功能的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        searchFunction - 成功返回非空结果的函数，否则为null
        结果
        对每个值应用给定搜索函数的非空结果，如果没有，则返回null
        从以下版本开始：
        1.8

      • reduceValues

        public V reduceValues​(long parallelismThreshold,
                      BiFunction<? super V,? super V,? extends V> reducer)
        返回使用给定的reducer累加所有值的结果，以组合值，如果没有则返回null。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        reducer - 一种交换联想组合函数
        结果
        积累所有价值的结果
        从以下版本开始：
        1.8

      • reduceValues

        public <U> U reduceValues​(long parallelismThreshold,
                          Function<? super V,? extends U> transformer,
                          BiFunction<? super U,? super U,? extends U> reducer)
        返回使用给定的reducer累加所有值的给定变换以组合值的结果，否则返回null。
        参数类型
        U - 变压器的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素的变换的函数，如果没有转换，则返回null（在这种情况下不进行组合）
        reducer - 交换联想组合功能
        结果
        积累所有值的给定变换的结果
        从以下版本开始：
        1.8

      • reduceValuesToDouble

        public double reduceValuesToDouble​(long parallelismThreshold,
                                   ToDoubleFunction<? super V> transformer,
                                   double basis,
                                   DoubleBinaryOperator reducer)
        返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 交换联想组合函数
        结果
        积累所有值的给定变换的结果
        从以下版本开始：
        1.8

      • reduceValuesToLong

        public long reduceValuesToLong​(long parallelismThreshold,
                               ToLongFunction<? super V> transformer,
                               long basis,
                               LongBinaryOperator reducer)
        返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素数量（估计）
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 一种交换联想组合函数
        结果
        积累所有值的给定变换的结果
        从以下版本开始：
        1.8

      • reduceValuesToInt

        public int reduceValuesToInt​(long parallelismThreshold,
                             ToIntFunction<? super V> transformer,
                             int basis,
                             IntBinaryOperator reducer)
        返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素数量（估计）
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 交换联想组合函数
        结果
        积累所有值的给定变换的结果
        从以下版本开始：
        1.8

      • forEachEntry

        public void forEachEntry​(long parallelismThreshold,
                         Consumer<? super Map.Entry<K,V>> action)
        对每个条目执行给定的操作。
        参数
        parallelismThreshold - 并行执行此操作所需的元素数量（估计）
        action - 行动
        从以下版本开始：
        1.8

      • forEachEntry

        public <U> void forEachEntry​(long parallelismThreshold,
                             Function<Map.Entry<K,V>,? extends U> transformer,
                             Consumer<? super U> action)
        对每个条目的每个非空变换执行给定的操作。
        参数类型
        U - 变压器的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素数量（估计）
        transformer - 一个返回元素的变换的函数，如果没有变换，则返回null（在这种情况下不应用动作）
        action - 行动
        从以下版本开始：
        1.8

      • searchEntries

        public <U> U searchEntries​(long parallelismThreshold,
                           Function<Map.Entry<K,V>,? extends U> searchFunction)
        返回一个非空结果，从每个条目应用给定的搜索函数，如果没有，则返回null。 成功后，进一步的元素处理被抑制，并且搜索功能的任何其他并行调用的结果被忽略。
        参数类型
        U - 搜索功能的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        searchFunction - 成功返回非空结果的函数，否则为null
        结果
        在每个条目上应用给定搜索功能的非空结果，如果没有，则返回null
        从以下版本开始：
        1.8

      • reduceEntries

        public Map.Entry<K,V> reduceEntries​(long parallelismThreshold,
                                    BiFunction<Map.Entry<K,V>,Map.Entry<K,V>,? extends Map.Entry<K,V>> reducer)
        返回使用给定的reducer累加所有条目的结果，以组合值，如果没有则返回null。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        reducer - 一种交换联想组合函数
        结果
        累积所有条目的结果
        从以下版本开始：
        1.8

      • reduceEntries

        public <U> U reduceEntries​(long parallelismThreshold,
                           Function<Map.Entry<K,V>,? extends U> transformer,
                           BiFunction<? super U,? super U,? extends U> reducer)
        返回使用给定的reducer将所有条目的给定变换累加到组合值的结果，否则返回null。
        参数类型
        U - 变压器的返回类型
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素的变换的函数，如果没有转换，则返回null（在这种情况下不进行组合）
        reducer - 交换联想组合函数
        结果
        累积所有条目的给定转换的结果
        从以下版本开始：
        1.8

      • reduceEntriesToDouble

        public double reduceEntriesToDouble​(long parallelismThreshold,
                                    ToDoubleFunction<Map.Entry<K,V>> transformer,
                                    double basis,
                                    DoubleBinaryOperator reducer)
        返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素的变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 交换联想组合函数
        结果
        累积所有条目的给定转换的结果
        从以下版本开始：
        1.8

      • reduceEntriesToLong

        public long reduceEntriesToLong​(long parallelismThreshold,
                                ToLongFunction<Map.Entry<K,V>> transformer,
                                long basis,
                                LongBinaryOperator reducer)
        返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 一种交换联想组合函数
        结果
        累积所有条目的给定转换的结果
        从以下版本开始：
        1.8

      • reduceEntriesToInt

        public int reduceEntriesToInt​(long parallelismThreshold,
                              ToIntFunction<Map.Entry<K,V>> transformer,
                              int basis,
                              IntBinaryOperator reducer)
        返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
        参数
        parallelismThreshold - 并行执行此操作所需的元素的（估计）数量
        transformer - 返回元素变换的函数
        basis - 减少的身份（初始默认值）
        reducer - 一种交换联想组合函数
        结果
        累积所有条目的给定转换的结果
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConcurrentHashMap.KeySetView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ConcurrentHashMap.KeySetView<K,V>

  • java.lang.Object
    • java.util.concurrent.ConcurrentHashMap.KeySetView<K,V>
  • All Implemented Interfaces:
    Serializable ， Iterable<K> ， Collection<K> ， Set<K>
    Enclosing class:
    ConcurrentHashMap < K ， V >

    public static class ConcurrentHashMap.KeySetView<K,V>
extends Object
implements Set<K>, Serializable
    ConcurrentHashMap视图为Set的密钥，其中可以通过映射到公共值来选择添加。 这个类不能直接实例化。 见keySet() ， keySet(V) ， newKeySet() ， newKeySet(int) 。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(K e)
      通过将键映射到背景映射中的默认映射值（如果已定义），将指定的键添加到此设置视图。
      boolean addAll​(Collection<? extends K> c)
      将指定集合中的所有元素添加到此集合中，就像在每个 元素上调用 add(K)一样 。
      void clear​()
      从该视图中删除所有的元素，通过从支持此视图的地图中删除所有映射。
      boolean contains​(Object o)
      如果此集合包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> c)
      如果此集合包含指定集合中的所有元素，则返回 true 。
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      void forEach​(Consumer<? super K> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      ConcurrentHashMap<K,V> getMap​()
      返回支持此视图的地图。
      V getMappedValue​()
      返回添加的默认映射值，如果不支持添加，则返回 null 。
      int hashCode​()
      返回对象的哈希码值。
      boolean isEmpty​()
      如果此集合不包含元素，则返回 true 。
      Iterator<K> iterator​()
      返回此集合中元素的迭代器。
      boolean remove​(Object o)
      从该地图视图中删除键，方法是从支持地图中删除该键（及其对应的值）。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此集合中的元素数。
      Spliterator<K> spliterator​()
      在此集合中的元素上创建一个 Spliterator 。
      Object[] toArray​()
      返回一个包含此集合中所有元素的数组。
      <T> T[] toArray​(T[] a)
      返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此集合的字符串表示形式。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Set

        clear, containsAll, isEmpty, of, of, of, of, of, of, of, of, of, of, of, of, removeAll, retainAll, size, toArray, toArray

    • 方法详细信息

      • getMappedValue

        public V getMappedValue​()
        返回添加的默认映射值，如果不支持添加，则返回 null 。
        结果
        添加的默认映射值，如果不支持， null

      • contains

        public boolean contains​(Object o)
        如果此集合包含指定的元素，则返回true 。 更正式地说，返回true当且仅当这个集合包含至少一个元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<K>
        Specified by:
        contains在接口 Set<K>
        参数
        o - 要在此集合中存在的元素要进行测试
        结果
        true如果此集合包含指定的元素
        异常
        NullPointerException - 如果指定的键为空

      • remove

        public boolean remove​(Object o)
        从该地图视图中删除键，方法是从支持地图中删除该键（及其对应的值）。 如果键不在地图中，此方法不执行任何操作。
        Specified by:
        remove在接口 Collection<K>
        Specified by:
        remove在接口 Set<K>
        参数
        o - 从背景地图中删除的关键字
        结果
        true如果背景地图包含指定的键
        异常
        NullPointerException - 如果指定的键为空

      • iterator

        public Iterator<K> iterator​()
        返回此集合中元素的迭代器。

        返回的迭代器是weakly consistent 。

        Specified by:
        iterator在接口 Collection<K>
        Specified by:
        iterator在接口 Iterable<K>
        Specified by:
        iterator在接口 Set<K>
        结果
        在背景图上的键的迭代器

      • add

        public boolean add​(K e)
        通过将键映射到背景映射中的默认映射值（如果已定义），将指定的键添加到此设置视图。
        Specified by:
        add在接口 Collection<K>
        Specified by:
        add接口 Set<K>
        参数
        e - 要添加的密钥
        结果
        true如果此设置由于呼叫而更改
        异常
        NullPointerException - 如果指定的键为空
        UnsupportedOperationException - 如果没有提供添加的默认映射值

      • addAll

        public boolean addAll​(Collection<? extends K> c)
        将指定集合中的所有元素添加到此集合中，就像在每个 元素上调用 add(K)一样 。
        Specified by:
        addAll在接口 Collection<K>
        Specified by:
        addAll在接口 Set<K>
        参数
        c - 要插入到这个集合中的元素
        结果
        true如果此设置由于呼叫而更改
        异常
        NullPointerException - 如果集合或其任何元素是 null
        UnsupportedOperationException - 如果没有提供添加的默认映射值
        另请参见：
        Set.add(Object)

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        Specified by:
        hashCode在接口 Collection<K>
        Specified by:
        hashCode在接口 Set<K>
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object o)
        说明从类别复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 一致 ：对于任何非空参考值x和y ， y多个调用x.equals(y)一致地返回true或始终返回false ，前提是在对象上的equals比较中未使用的信息被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，当覆盖该方法时，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        Specified by:
        equals在接口 Collection<K>
        Specified by:
        equals在接口 Set<K>
        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • spliterator

        public Spliterator<K> spliterator​()
        描述从接口Set复制
        在此集合中的元素上创建一个Spliterator 。

        Spliterator报告Spliterator.DISTINCT 。 实施应记录其他特征值的报告。

        Specified by:
        spliterator在接口 Collection<K>
        Specified by:
        spliterator在接口 Iterable<K>
        Specified by:
        spliterator在接口 Set<K>
        结果
        一个 Spliterator在这个集合中的元素

      • forEach

        public void forEach​(Consumer<? super K> action)
        说明从接口Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<K>
        参数
        action - 要为每个元素执行的操作

      • getMap

        public ConcurrentHashMap<K,V> getMap​()
        返回支持此视图的地图。
        结果
        地图支持此视图

      • clear

        public final void clear​()
        从该视图中删除所有的元素，通过从支持此视图的地图中删除所有映射。
        Specified by:
        clear在接口 Collection<K>

      • size

        public final int size​()
        描述从接口Collection复制
        返回此集合中的元素数。 如果此集合包含Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<K>
        结果
        此集合中的元素数

      • isEmpty

        public final boolean isEmpty​()
        说明从界面Collection复制
        如果此集合不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<K>
        结果
        true如果此集合不包含元素

      • toArray

        public final Object[] toArray​()
        描述从接口Collection复制
        返回一个包含此集合中所有元素的数组。 如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        返回的数组将是“安全的”，因为该集合不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组，即使这个集合是由数组支持的）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<K>
        结果
        一个包含此集合中所有元素的数组

      • toArray

        public final <T> T[] toArray​(T[] a)
        描述从接口Collection复制
        返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果集合适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此集合的大小分配一个新数组。

        如果此集合适用于指定的数组，并具有空间（即，该数组具有比此集合更多的元素），则紧跟集合结束后的数组中的元素将设置为null 。 （ 仅当调用者知道此集合不包含任何null元素时，此方法才有助于确定此集合的长度。）

        如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        像Collection.toArray()方法一样，此方法充当基于阵列和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的集合。 以下代码可用于将集合转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<K>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储此集合的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此集合中所有元素的数组

      • toString

        public final String toString​()
        返回此集合的字符串表示形式。 字符串表示由集合的元素的字符串表示形式组成，它们由迭代器返回的顺序包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 Object
        结果
        此集合的字符串表示形式

      • containsAll

        public final boolean containsAll​(Collection<?> c)
        描述从接口Collection复制
        如果此集合包含指定集合中的所有元素，则返回 true 。
        Specified by:
        containsAll在接口 Collection<K>
        参数
        c - 要在此集合中检查遏制的集合
        结果
        true如果此集合包含指定集合中的所有元素
        另请参见：
        Collection.contains(Object)

      • removeAll

        public boolean removeAll​(Collection<?> c)
        描述从接口Collection复制
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<K>
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果该收集因呼叫而更改
        另请参见：
        Collection.remove(Object) ， Collection.contains(Object)

      • retainAll

        public final boolean retainAll​(Collection<?> c)
        描述从接口Collection复制
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<K>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果该收集因呼叫而更改
        另请参见：
        Collection.remove(Object), Collection.contains(Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConcurrentLinkedDeque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ConcurrentLinkedDeque<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.concurrent.ConcurrentLinkedDeque<E>
  • 参数类型
    E - 在这个deque中持有的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， Deque<E> ， Queue<E>

    public class ConcurrentLinkedDeque<E>
extends AbstractCollection<E>
implements Deque<E>, Serializable
    基于链接节点的无界并发deque 。 并发插入，删除和访问操作可以跨多个线程安全执行。 A ConcurrentLinkedDeque是许多线程将共享对公共集合的访问的适当选择。 像大多数其他并发集合实现一样，此类不允许使用null元素。

    迭代器和拼接器是weakly consistent 。

    请注意，与大多数集合不同， size方法不是一个恒定时间的操作。 由于这些deques的异步性质，确定当前元素数量需要遍历元素，因此如果在遍历期间修改此集合，则可能会报告不准确的结果。

    该添加，删除，或检查多个元件批量操作，如addAll(java.util.Collection<? extends E>) ， removeIf(java.util.function.Predicate<? super E>)或forEach(java.util.function.Consumer<? super E>)待原子方式执行， 不能保证。 例如，与addAll操作并发的forEach遍历可能仅观察到一些添加的元素。

    该类及其迭代器实现了Deque和Iterator接口的所有可选方法。

    内存一致性效果：与其他并发集合一样，在将对象放入ConcurrentLinkedDeque happen-before之后的线程中的ConcurrentLinkedDeque在另一个线程中的ConcurrentLinkedDeque中访问或删除该元素之后。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConcurrentLinkedDeque​()
      构造一个空的德克。
      ConcurrentLinkedDeque​(Collection<? extends E> c)
      构造最初包含给定集合的元素的deque，以集合的迭代器的遍历顺序添加。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      在此deque的尾部插入指定的元素。
      boolean addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该deque的末尾。
      void addFirst​(E e)
      在此deque前面插入指定的元素。
      void addLast​(E e)
      在此deque的末尾插入指定的元素。
      void clear​()
      从这个deque中删除所有的元素。
      boolean contains​(Object o)
      如果此deque包含指定的元素，则返回 true 。
      Iterator<E> descendingIterator​()
      以相反的顺序返回此deque中的元素的迭代器。
      E element​()
      检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      E getFirst​()
      检索，但不删除，这个deque的第一个元素。
      E getLast​()
      检索，但不删除，这个deque的最后一个元素。
      boolean isEmpty​()
      如果此集合不包含元素，则返回 true 。
      Iterator<E> iterator​()
      以正确的顺序返回此deque中的元素的迭代器。
      boolean offer​(E e)
      在此deque的尾部插入指定的元素。
      boolean offerFirst​(E e)
      在此deque前面插入指定的元素。
      boolean offerLast​(E e)
      在此deque的末尾插入指定的元素。
      E peek​()
      检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回 null 。
      E peekFirst​()
      检索但不删除此deque的第一个元素，如果此deque为空，则返回 null 。
      E peekLast​()
      检索但不删除此deque的最后一个元素，如果此deque为空，则返回 null 。
      E poll​()
      检索并删除由此deque（换句话说，此deque的第一个元素）表示的队列的头部，如果此deque为空，则返回 null 。
      E pollFirst​()
      检索并删除此deque的第一个元素，如果此deque为空，则返回 null 。
      E pollLast​()
      检索并删除此deque的最后一个元素，如果此deque为空，则返回 null 。
      E pop​()
      从这个deque表示的堆栈中弹出一个元素。
      void push​(E e)
      将元素推送到由此deque表示的堆栈（换句话说，在此deque的头部），如果可以立即执行此操作而不违反容量限制，则抛出 IllegalStateException如果当前没有可用空间）。
      E remove​()
      检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
      boolean remove​(Object o)
      从此deque中删除指定元素的第一个出现。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      E removeFirst​()
      检索并删除此deque的第一个元素。
      boolean removeFirstOccurrence​(Object o)
      从此deque中删除指定元素的第一个出现。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      E removeLast​()
      检索并删除此deque的最后一个元素。
      boolean removeLastOccurrence​(Object o)
      从此deque中删除指定元素的最后一次出现。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此deque中的元素数。
      Spliterator<E> spliterator​()
      在此deque中的元素上返回Spliterator 。
      Object[] toArray​()
      以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此集合的字符串表示形式。

      • Methods inherited from class java.util.AbstractCollection

        containsAll

      • Methods inherited from interface java.util.Collection

        containsAll, equals, hashCode, parallelStream, stream

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ConcurrentLinkedDeque

        public ConcurrentLinkedDeque​()
        构造一个空的德克。

      • ConcurrentLinkedDeque

        public ConcurrentLinkedDeque​(Collection<? extends E> c)
        构造最初包含给定集合的元素的deque，以集合的迭代器的遍历顺序添加。
        参数
        c - 最初包含的元素的集合
        异常
        NullPointerException - 如果指定的集合或其任何元素为空

    • 方法详细信息

      • addFirst

        public void addFirst​(E e)
        在此deque前面插入指定的元素。 由于德克是无限的，这种方法永远不会抛出IllegalStateException 。
        Specified by:
        addFirst在接口 Deque<E>
        参数
        e - 要添加的元素
        异常
        NullPointerException - 如果指定的元素为空

      • addLast

        public void addLast​(E e)
        在此deque的末尾插入指定的元素。 由于德克是无限的，这种方法永远不会抛出IllegalStateException 。

        此方法相当于add(E) 。

        Specified by:
        addLast在接口 Deque<E>
        参数
        e - 要添加的元素
        异常
        NullPointerException - 如果指定的元素为空

      • offerFirst

        public boolean offerFirst​(E e)
        在此deque前面插入指定的元素。 由于deque是无限制的，这种方法永远不会返回false 。
        Specified by:
        offerFirst在接口 Deque<E>
        参数
        e - 要添加的元素
        结果
        true （由 Deque.offerFirst(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • offerLast

        public boolean offerLast​(E e)
        在此deque的末尾插入指定的元素。 由于deque是无限制的，这种方法永远不会返回false 。

        此方法相当于add(E) 。

        Specified by:
        offerLast在接口 Deque<E>
        参数
        e - 要添加的元素
        结果
        true （由 Deque.offerLast(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • peekFirst

        public E peekFirst​()
        描述从接口Deque复制
        检索但不删除此deque的第一个元素，如果此deque为空，则返回 null 。
        Specified by:
        peekFirst在接口 Deque<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • peekLast

        public E peekLast​()
        描述从接口Deque复制
        检索但不删除此deque的最后一个元素，如果此deque为空，则返回 null 。
        Specified by:
        peekLast在接口 Deque<E>
        结果
        这个deque的尾巴，或 null如果这个deque是空的

      • getFirst

        public E getFirst​()
        说明从界面Deque复制
        检索，但不删除，这个deque的第一个元素。 此方法与peekFirst的不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        getFirst在接口 Deque<E>
        结果
        这个德克的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • getLast

        public E getLast​()
        描述从接口Deque复制
        检索，但不删除，这个deque的最后一个元素。 此方法与peekLast不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        getLast在接口 Deque<E>
        结果
        这个德克的尾巴
        异常
        NoSuchElementException - 如果这个deque是空的

      • pollFirst

        public E pollFirst​()
        描述从接口Deque复制
        检索并删除此deque的第一个元素，如果此deque为空，则返回 null 。
        Specified by:
        pollFirst在接口 Deque<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • pollLast

        public E pollLast​()
        说明从界面Deque复制
        检索并删除此deque的最后一个元素，如果此deque为空，则返回 null 。
        Specified by:
        pollLast在接口 Deque<E>
        结果
        这个deque的尾巴，或 null如果这个deque是空的

      • removeFirst

        public E removeFirst​()
        描述从接口Deque复制
        检索并删除此deque的第一个元素。 该方法与pollFirst不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        removeFirst在接口 Deque<E>
        结果
        这个德克的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • removeLast

        public E removeLast​()
        说明从界面Deque复制
        检索并删除此deque的最后一个元素。 此方法与pollLast不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        removeLast在接口 Deque<E>
        结果
        这个德克的尾巴
        异常
        NoSuchElementException - 如果这个deque是空的

      • offer

        public boolean offer​(E e)
        在此deque的尾部插入指定的元素。 由于false是无限的，这种方法永远不会返回false 。
        Specified by:
        offer在接口 Deque<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Queue.offer(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • add

        public boolean add​(E e)
        在此deque的尾部插入指定的元素。 由于德克是无限的，这种方法永远不会抛出IllegalStateException或返回false 。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Deque<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractCollection<E>
        参数
        e - 要确保在该集合中的存在的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • poll

        public E poll​()
        描述从接口Deque复制
        检索并删除由此deque（换句话说，此deque的第一个元素）表示的队列的头部，如果此deque为空，则返回null 。

        此方法相当于Deque.pollFirst() 。

        Specified by:
        poll在接口 Deque<E>
        Specified by:
        poll在接口 Queue<E>
        结果
        这个deque的第一个元素，或 null如果这个deque是空的

      • peek

        public E peek​()
        说明从接口Deque复制
        检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回null 。

        此方法相当于Deque.peekFirst() 。

        Specified by:
        peek在接口 Deque<E>
        Specified by:
        peek在接口 Queue<E>
        结果
        由这个deque表示的队列的头部，或者如果这个deque是空的，则是 null

      • remove

        public E remove​()
        说明从界面Deque复制
        检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。 此方法与poll()不同之处在于，如果此deque为空，它将抛出异常。

        此方法相当于Deque.removeFirst() 。

        Specified by:
        remove在接口 Deque<E>
        Specified by:
        remove在接口 Queue<E>
        结果
        由这个德克队代表的队列的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • pop

        public E pop​()
        说明从界面Deque复制
        从这个deque表示的堆栈中弹出一个元素。 换句话说，删除并返回此deque的第一个元素。

        此方法相当于Deque.removeFirst() 。

        Specified by:
        pop在接口 Deque<E>
        结果
        这个deque前面的元素（它是由这个deque表示的堆栈的顶部）
        异常
        NoSuchElementException - 如果这个deque是空的

      • element

        public E element​()
        说明从接口Deque复制
        检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。 此方法与peek的不同之处在于，如果此deque为空，它将抛出异常。

        此方法相当于Deque.getFirst() 。

        Specified by:
        element在接口 Deque<E>
        Specified by:
        element在接口 Queue<E>
        结果
        由这个德克队代表的队列的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • push

        public void push​(E e)
        说明从界面Deque复制
        将元素推送到由此deque表示的堆栈（换句话说，在该deque的头部），如果可以立即执行此操作而不违反容量限制，则抛出IllegalStateException如果当前没有可用空间）。

        此方法相当于Deque.addFirst(E) 。

        Specified by:
        push在接口 Deque<E>
        参数
        e - 要推的元素
        异常
        NullPointerException - 如果指定的元素为空，并且此deque不允许空元素

      • removeFirstOccurrence

        public boolean removeFirstOccurrence​(Object o)
        从此deque中删除指定元素的第一个出现。 如果deque不包含元素，则它不变。 更正式地，删除第一元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。
        Specified by:
        removeFirstOccurrence在接口 Deque<E>
        参数
        o - 要从此deque移除的元素（如果存在）
        结果
        如果deque包含指定的元素， true
        异常
        NullPointerException - 如果指定的元素为空

      • removeLastOccurrence

        public boolean removeLastOccurrence​(Object o)
        从此deque中删除指定元素的最后一次出现。 如果deque不包含元素，则它不变。 更正式地，删除最后一个元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque因呼叫而改变），则返回true 。
        Specified by:
        removeLastOccurrence在接口 Deque<E>
        参数
        o - 要从此deque中删除的元素（如果存在）
        结果
        如果deque包含指定的元素， true
        异常
        NullPointerException - 如果指定的元素为空

      • contains

        public boolean contains​(Object o)
        如果此deque包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此双端队列至少包含一个元素e这样o.equals(e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Deque<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要在此deque中存在的元素要进行测试
        结果
        如果此deque包含指定的元素， true

      • isEmpty

        public boolean isEmpty​()
        如果此集合不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        重写：
        isEmpty在 AbstractCollection<E>
        结果
        true如果此集合不包含元素

      • size

        public int size​()
        返回此deque中的元素数。 如果此deque包含超过Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。

        请注意，与大多数集合不同，此方法不是一个常时操作。 由于这些deques的异步性质，确定当前数量的元素需要遍历它们才能对它们进行计数。 此外，在执行此方法期间，大小可能会发生更改，在这种情况下，返回的结果将不准确。 因此，这种方法在并发应用程序中通常不是很有用。

        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Deque<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        这个deque中的元素数量

      • remove

        public boolean remove​(Object o)
        从此deque中删除指定元素的第一个出现。 如果deque不包含元素，则它不变。 更正式地，删除第一元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。

        此方法相当于removeFirstOccurrence(Object) 。

        Specified by:
        remove接口 Collection<E>
        Specified by:
        remove接口 Deque<E>
        重写：
        remove中的 AbstractCollection<E>
        参数
        o - 要从此deque移除的元素（如果存在）
        结果
        true如果deque包含指定的元素
        异常
        NullPointerException - 如果指定的元素为空

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该deque的末尾。 尝试到addAll的一个deque的IllegalArgumentException导致IllegalArgumentException 。
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll接口 Deque<E>
        重写：
        addAll中的 AbstractCollection<E>
        参数
        c - 要插入此deque的元素
        结果
        true如果这个deque因呼叫而改变了
        异常
        NullPointerException - 如果指定的集合或其任何元素为空
        IllegalArgumentException - 如果集合是这个deque
        另请参见：
        AbstractCollection.add(Object)

      • clear

        public void clear​()
        从这个deque中删除所有的元素。
        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractCollection<E>

      • toString

        public String toString​()
        描述从类别复制： AbstractCollection
        返回此集合的字符串表示形式。 字符串表示由集合的元素的列表按照它们的迭代器返回的顺序包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 AbstractCollection<E>
        结果
        此集合的字符串表示形式

      • toArray

        public Object[] toArray​()
        以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组。

        返回的数组将是“安全的”，因为这个deque不会保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此deque中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果deque适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此deque的大小分配一个新数组。

        如果这个deque适合指定的数组，有空余的空间（即数组的元素比此deque更多），紧接着deque结尾之后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的deque。 以下代码可用于将deque转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储deque的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组
        结果
        一个包含此deque中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此deque中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回此deque中的元素的迭代器。 元素将按照从头（头）到最后（尾）的顺序返回。

        返回的迭代器是weakly consistent 。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Deque<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        在这个deque中的元素以适当的顺序迭代

      • descendingIterator

        public Iterator<E> descendingIterator​()
        以相反的顺序返回此deque中的元素的迭代器。 元素将从最后（尾）到第一（头）的顺序返回。

        返回的迭代器是weakly consistent 。

        Specified by:
        descendingIterator在接口 Deque<E>
        结果
        在这个deque中的元素的迭代器以相反的顺序

      • spliterator

        public Spliterator<E> spliterator​()
        在这个deque中的元素上返回一个Spliterator 。

        返回的拼接器是weakly consistent 。

        该Spliterator报告Spliterator.CONCURRENT ， Spliterator.ORDERED ，并Spliterator.NONNULL 。

        Specified by:
        spliterator接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Implementation Note:
        Spliterator实现 trySplit以允许有限的并行性。
        结果
        一个 Spliterator在这个deque的元素
        从以下版本开始：
        1.8

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        描述从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 一个谓词，为要删除的元素返回 true
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • removeAll

        public boolean removeAll​(Collection<?> c)
        描述从类别复制： AbstractCollection
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        描述从类别复制： AbstractCollection
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • forEach

        public void forEach​(Consumer<? super E> action)
        描述从接口Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConcurrentLinkedQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ConcurrentLinkedQueue<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
        • java.util.concurrent.ConcurrentLinkedQueue<E>
  • 参数类型
    E - 保存在此队列中的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， Queue<E>

    public class ConcurrentLinkedQueue<E>
extends AbstractQueue<E>
implements Queue<E>, Serializable
    基于链接节点的无界线程安全queue 。 这个队列排列元素FIFO（先进先出）。 队列的头部是队列中最长的元素。 队列的尾部是队列中最短时间的元素。 新元素插入队列的尾部，队列检索操作获取队列头部的元素。 A ConcurrentLinkedQueue是许多线程将共享对公共集合的访问的适当选择。 像大多数其他并发集合实现一样，此类不允许使用null元素。

    该实现采用基于Maged M.Michael和Michael L.Sci的Simple, Fast, and Practical Non-Blocking and Blocking Concurrent Queue Algorithms描述的有效的非阻塞算法。

    迭代器是弱一致的 ，返回的元素反映队列的状态在创建迭代器的某个时刻。 他们不抛出ConcurrentModificationException ，并可能与其他操作同时进行。 创建迭代器后包含在队列中的元素将被精确地返回一次。

    请注意，与大多数集合不同， size方法不是一个常时操作。 由于这些队列的异步性质，确定当前元素数量需要遍历元素，因此如果在遍历期间修改此集合，则可能会报告不准确的结果。

    该添加，删除，或检查多个元件批量操作，如addAll(java.util.Collection<? extends E>) ， removeIf(java.util.function.Predicate<? super E>)或forEach(java.util.function.Consumer<? super E>)待原子方式执行， 不能保证。 例如，与addAll操作并发的forEach遍历可能仅观察到一些添加的元素。

    该类及其迭代器实现Queue和Iterator接口的所有可选方法。

    内存一致性效果：与其他并发集合一样，在将对象放入ConcurrentLinkedQueue happen-before之后的线程中的ConcurrentLinkedQueue在另一个线程中从ConcurrentLinkedQueue访问或删除该元素之后。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConcurrentLinkedQueue​()
      创建一个最初为空的 ConcurrentLinkedQueue 。
      ConcurrentLinkedQueue​(Collection<? extends E> c)
      创建一个 ConcurrentLinkedQueue最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      在该队列的尾部插入指定的元素。
      boolean addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该队列的末尾。
      void clear​()
      从此队列中删除所有元素。
      boolean contains​(Object o)
      如果此队列包含指定的元素，则返回 true 。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      boolean isEmpty​()
      如果此队列不包含元素，则返回 true 。
      Iterator<E> iterator​()
      以正确的顺序返回该队列中的元素的迭代器。
      boolean offer​(E e)
      在该队列的尾部插入指定的元素。
      E peek​()
      检索但不删除此队列的头，如果此队列为空，则返回 null 。
      E poll​()
      检索并删除此队列的头，如果此队列为空，则返回 null 。
      boolean remove​(Object o)
      从该队列中删除指定元素的单个实例（如果存在）。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此队列中的元素数。
      Spliterator<E> spliterator​()
      返回此队列中的元素Spliterator 。
      Object[] toArray​()
      以适当的顺序返回一个包含此队列中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此集合的字符串表示形式。

      • Methods inherited from class java.util.AbstractCollection

        containsAll

      • Methods inherited from class java.util.AbstractQueue

        element, remove

      • Methods inherited from interface java.util.Collection

        containsAll, equals, hashCode, parallelStream, stream

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Queue

        element, remove

    • 构造方法详细信息

      • ConcurrentLinkedQueue

        public ConcurrentLinkedQueue​()
        创建一个最初为空的 ConcurrentLinkedQueue 。

      • ConcurrentLinkedQueue

        public ConcurrentLinkedQueue​(Collection<? extends E> c)
        创建一个 ConcurrentLinkedQueue最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
        参数
        c - 最初包含的元素的集合
        异常
        NullPointerException - 如果指定的集合或其任何元素为空

    • 方法详细信息

      • add

        public boolean add​(E e)
        在该队列的尾部插入指定的元素。 由于队列无限制，此方法将永远不会抛出IllegalStateException或返回false 。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractQueue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        在该队列的尾部插入指定的元素。 由于队列无限制，此方法将永远不会返回false 。
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Queue.offer(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • poll

        public E poll​()
        说明从界面Queue复制
        检索并删除此队列的头，如果此队列为空，则返回 null 。
        Specified by:
        poll在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • peek

        public E peek​()
        说明从界面Queue复制
        检索但不删除此队列的头，如果此队列为空，则返回 null 。
        Specified by:
        peek在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • isEmpty

        public boolean isEmpty​()
        如果此队列不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        重写：
        isEmpty中的 AbstractCollection<E>
        结果
        true如果此队列不包含元素

      • size

        public int size​()
        返回此队列中的元素数。 如果此队列包含Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。

        请注意，与大多数集合不同，此方法不是一个常时操作。 由于这些队列的异步性质，确定当前的元素数需要O（n）遍历。 另外，如果在执行此方法期间添加或删除元素，则返回的结果可能不准确。 因此，这种方法在并发应用程序中通常不是很有用。

        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此队列中的元素数

      • contains

        public boolean contains​(Object o)
        如果此队列包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此队列至少包含一个元素e这样o.equals(e) 。
        Specified by:
        contains在接口 Collection<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要检查此队列中的遏制的对象
        结果
        true如果此队列包含指定的元素

      • remove

        public boolean remove​(Object o)
        从该队列中删除指定元素的单个实例（如果存在）。 更正式地，删除元素e ，使得o.equals(e) ，如果该队列包含一个或多个这样的元素。 如果此队列包含指定的元素（或等效地，如果此队列作为调用的结果而更改），则返回true 。
        Specified by:
        remove在接口 Collection<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此队列中删除的元素（如果存在）
        结果
        true如果此队列由于调用而更改

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该队列的末尾。 尝试addAll队列给自己造成IllegalArgumentException 。
        Specified by:
        addAll在接口 Collection<E>
        重写：
        addAll中的 AbstractQueue<E>
        参数
        c - 要插入此队列的元素
        结果
        true如果此队列由于调用而更改
        异常
        NullPointerException - 如果指定的集合或其任何元素为空
        IllegalArgumentException - 如果集合是这个队列
        另请参见：
        AbstractQueue.add(Object)

      • toString

        public String toString​()
        描述从类别复制： AbstractCollection
        返回此集合的字符串表示形式。 字符串表示由集合的元素的列表按照它们的迭代器返回的顺序包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 AbstractCollection<E>
        结果
        此集合的字符串表示形式

      • toArray

        public Object[] toArray​()
        以适当的顺序返回一个包含此队列中所有元素的数组。

        返回的数组将是“安全的”，因为该队列不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此队列中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果队列适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此队列的大小分配一个新数组。

        如果这个队列符合指定的数组空间（即阵列比此队列更多的元素），则队列结束后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的队列。 以下代码可用于将队列转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储队列的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组
        结果
        一个包含此队列中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回该队列中的元素的迭代器。 元素将按照从头（头）到最后（尾）的顺序返回。

        返回的迭代器是weakly consistent 。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        在该队列中的元素以适当的顺序迭代

      • spliterator

        public Spliterator<E> spliterator​()
        返回此队列中的元素Spliterator 。

        返回的分配器是weakly consistent 。

        该Spliterator报告Spliterator.CONCURRENT ， Spliterator.ORDERED ，并Spliterator.NONNULL 。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Implementation Note:
        Spliterator实现 trySplit以允许有限的并行性。
        结果
        一个 Spliterator在这个队列中的元素
        从以下版本开始：
        1.8

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        说明从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 一个谓词，为要删除的元素返回 true
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • removeAll

        public boolean removeAll​(Collection<?> c)
        描述从类复制： AbstractCollection
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        描述从类复制： AbstractCollection
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • clear

        public void clear​()
        描述从类复制： AbstractQueue
        从此队列中删除所有元素。 此呼叫返回后队列将为空。

        这个实现反复调用poll直到它返回null 。

        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractQueue<E>

      • forEach

        public void forEach​(Consumer<? super E> action)
        说明从界面Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConcurrentMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface ConcurrentMap<K,V>

  • 参数类型
    K - 由该地图维护的键的类型
    V - 映射值的类型
    All Superinterfaces:
    Map<K,V>
    All Known Subinterfaces:
    ConcurrentNavigableMap<K,V>
    所有已知实现类：
    ConcurrentHashMap ， ConcurrentSkipListMap

    public interface ConcurrentMap<K,V>
extends Map<K,V>
    A Map提供线程安全和原子性保证。

    为了保持指定的保证，从Map继承的包括putIfAbsent(K, V)在内的方法的默认实现必须被该接口的实现覆盖。 类似的，集合的实现返回的方法Map.keySet() ， Map.values() ，并Map.entrySet()必须覆盖的方法，如removeIf必要时保留原子性保证。

    内存一致性效果：与其他并发集合一样，在将对象放入ConcurrentMap作为键或happen-before之后的线程中的ConcurrentMap在另一个线程中的ConcurrentMap访问或删除该对象之后。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.5

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default V compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      default V computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      default V computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      default void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      default V getOrDefault​(Object key, V defaultValue)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。
      default V merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
      V putIfAbsent​(K key, V value)
      如果指定的键尚未与值相关联，则将其与给定值相关联。
      boolean remove​(Object key, Object value)
      仅当当前映射到给定值时才删除密钥的条目。
      V replace​(K key, V value)
      仅当当前映射到某个值时才替换该项的条目。
      boolean replace​(K key, V oldValue, V newValue)
      仅当当前映射到给定值时才替换密钥的条目。
      default void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。

      • Methods inherited from interface java.util.Map

        clear, containsKey, containsValue, entry, entrySet, equals, get, hashCode, isEmpty, keySet, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, remove, size, values

    • 方法详细信息

      • getOrDefault

        default V getOrDefault​(Object key,
                       V defaultValue)
        返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。
        Specified by:
        getOrDefault在接口 Map<K,V>
        Implementation Note:
        此实现假定ConcurrentMap不能包含空值，而get()返回null明确表示该键不存在。 支持空值的实现必须覆盖此默认实现。
        参数
        key - 要返回其关联值的键
        defaultValue - 键的默认映射
        结果
        指定键映射到的值，如果此映射不包含键的映射， defaultValue
        异常
        ClassCastException - 如果密钥对于该地图是不合适的类型（ optional ）
        NullPointerException - 如果指定的键为空，并且此映射不允许空键（ optional ）
        从以下版本开始：
        1.8

      • forEach

        default void forEach​(BiConsumer<? super K,? super V> action)
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach在接口 Map<K,V>
        实现要求：
        默认实现相当于，对于这个map ：
           for (Map.Entry<K,V> entry : map.entrySet()) { action.accept(entry.getKey(), entry.getValue()); }
        Implementation Note:
        默认实现假定IllegalStateException被抛出getKey()或者getValue()表示该条目已被删除，无法处理。 继续进行操作。
        参数
        action - 为每个条目执行的操作
        异常
        NullPointerException - 如果指定的操作为空
        从以下版本开始：
        1.8

      • putIfAbsent

        V putIfAbsent​(K key,
              V value)
        如果指定的键尚未与值相关联，则将其与给定值相关联。 这相当于，对于这个map ：
           if (!map.containsKey(key)) return map.put(key, value); else return map.get(key);
        除了动作以原子方式执行。
        Specified by:
        putIfAbsent在接口 Map<K,V>
        Implementation Note:
        该实现有意地重新提取了 Map提供的不正确的默认值。
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示以前关联的映射关系为null ，如果实现支持空值）。
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中
        NullPointerException - 如果指定的键或值为空，并且此映射不允许空值或值
        IllegalArgumentException - 如果指定的键或值的某些属性阻止其存储在此映射中

      • remove

        boolean remove​(Object key,
               Object value)
        仅当当前映射到给定值时才删除密钥的条目。 这相当于，对于这个map ：
           if (map.containsKey(key) && Objects.equals(map.get(key), value)) { map.remove(key); return true; } else { return false; }
        除了动作以原子方式执行。
        Specified by:
        remove在接口 Map<K,V>
        Implementation Note:
        该实现有意地重新提取了 Map提供的不正确的默认值。
        参数
        key - 与指定值相关联的键
        value - 预期与指定键相关联的值
        结果
        true如果该值被删除
        异常
        UnsupportedOperationException - 如果此地图不支持 remove操作
        ClassCastException - 如果该地图的键或值不合适（ optional ）
        NullPointerException - 如果指定的键或值为空，并且此映射不允许空值或值（ optional ）

      • replace

        boolean replace​(K key,
                V oldValue,
                V newValue)
        仅当当前映射到给定值时才替换密钥的条目。 这相当于，对于这个map ：
           if (map.containsKey(key) && Objects.equals(map.get(key), oldValue)) { map.put(key, newValue); return true; } else { return false; }
        除了动作以原子方式执行。
        Specified by:
        replace在接口 Map<K,V>
        Implementation Note:
        此实现有意地重新提取了 Map提供的不正确的默认值。
        参数
        key - 与指定值相关联的键
        oldValue - 预期与指定键相关联的值
        newValue - 与指定键相关联的值
        结果
        true如果该值被替换
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中
        NullPointerException - 如果指定的键或值为空，并且此映射不允许空键或值
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中

      • replace

        V replace​(K key,
          V value)
        仅当当前映射到某个值时才替换该项的条目。 这相当于，对于这个map ：
           if (map.containsKey(key)) return map.put(key, value); else return null;
        除了动作以原子方式执行。
        Specified by:
        replace在接口 Map<K,V>
        Implementation Note:
        该实现有意地重新提取了 Map提供的不正确的默认值。
        参数
        key - 与指定值相关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null 。 （A null返回也可以指示映射以前关联的是null的密钥，如果实现支持null值。）
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中
        NullPointerException - 如果指定的键或值为空，并且此映射不允许空键或值
        IllegalArgumentException - 如果指定的键或值的某些属性阻止其存储在此映射中

      • replaceAll

        default void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll在接口 Map<K,V>
        实现要求：

        默认实现相当于，对于这个map ：

           for (Map.Entry<K,V> entry : map.entrySet()) { K k; V v; do { k = entry.getKey(); v = entry.getValue(); } while (!map.replace(k, v, function.apply(k, v))); }
        当多个线程尝试更新时，默认实现可能会重试这些步骤，包括针对给定的密钥重复地调用该功能。

        此实现假定ConcurrentMap不能包含空值，而get()返回null明确地表示密钥不存在。 支持空值的实现必须覆盖此默认实现。

        参数
        function - 应用于每个条目的功能
        异常
        UnsupportedOperationException - 如果此地图的条目集迭代器不支持 set操作。
        NullPointerException - 如果函数或替换值为空，并且此映射不允许空值或值（ optional ）
        ClassCastException - 如果替代值对于该地图是不合适的类型（ optional ）
        IllegalArgumentException - 如果替换值的某些属性阻止其存储在此映射中（ optional ）
        从以下版本开始：
        1.8

      • computeIfAbsent

        default V computeIfAbsent​(K key,
                          Function<? super K,? extends V> mappingFunction)
        如果指定的键尚未与值相关联（或映射到null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是null 。

        如果映射函数返回null ，则不记录映射。 如果映射函数本身引发（未检查）异常，则重新抛出异常，并且不记录映射。 最常见的用法是构造一个用作初始映射值或记忆结果的新对象，如：

           map.computeIfAbsent(key, k -> new Value(f(k)));

        或者实现一个多值地图， Map<K,Collection<V>> ，每个键支持多个值：

           map.computeIfAbsent(key, k -> new HashSet<V>()).add(v);

        映射函数在计算过程中不应该修改该映射。

        Specified by:
        computeIfAbsent在接口 Map<K,V>
        实现要求：
        默认实现相当于此map的以下步骤：
           V oldValue, newValue; return ((oldValue = map.get(key)) == null && (newValue = mappingFunction.apply(key)) != null && (oldValue = map.putIfAbsent(key, newValue)) == null) ? newValue : oldValue;

        此实现假定ConcurrentMap不能包含空值，而get()明确地返回null表示密钥不存在。 支持空值的实现必须覆盖此默认实现。

        参数
        key - 指定值与之关联的键
        mappingFunction - 计算值的映射函数
        结果
        与指定键相关联的当前（现有或计算）值，如果计算值为空，则为null
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中（ optional ）
        NullPointerException - 如果指定的键为空，此映射不支持空键，或者mappingFunction为空
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中（ optional ）
        从以下版本开始：
        1.8

      • computeIfPresent

        default V computeIfPresent​(K key,
                           BiFunction<? super K,? super V,? extends V> remappingFunction)
        如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

        如果重映射函数返回null ，则删除映射。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        Specified by:
        computeIfPresent接口 Map<K,V>
        实现要求：
        默认实现相当于为此执行以下步骤： map ：
           for (V oldValue; (oldValue = map.get(key)) != null; ) { V newValue = remappingFunction.apply(key, oldValue); if ((newValue == null) ? map.remove(key, oldValue) : map.replace(key, oldValue, newValue)) return newValue; } return null;
        当多个线程尝试更新时，可以多次调用映射操作和重映射功能。

        此实现假定ConcurrentMap不能包含空值，而get()返回null明确表示该键不存在。 支持空值的实现必须覆盖此默认实现。

        参数
        key - 与该值相关联的键
        remappingFunction - 计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类别阻止其存储在此映射中（ optional ）
        NullPointerException - 如果指定的键为空，此映射不支持空键，或者remappingFunction为空
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中（ optional ）
        从以下版本开始：
        1.8

      • compute

        default V compute​(K key,
                  BiFunction<? super K,? super V,? extends V> remappingFunction)
        尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则null ）。 例如，要为值映射创建或追加String msg：
           map.compute(key, (k, v) -> (v == null) ? msg : v.concat(msg))
        （方法merge()通常更简单地用于这些目的。）

        如果重映射函数返回null ，映射将被删除（如果最初缺少，则保持不存在）。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        Specified by:
        compute接口 Map<K,V>
        实现要求：
        默认实现等同于为此map执行以下步骤：
           for (;;) { V oldValue = map.get(key); V newValue = remappingFunction.apply(key, oldValue); if (newValue != null) { if ((oldValue != null) ? map.replace(key, oldValue, newValue) : map.putIfAbsent(key, newValue) == null) return newValue; } else if (oldValue == null || map.remove(key, oldValue)) { return null; } }
        当多个线程尝试更新时，可以多次调用映射操作和重映射功能。

        此实现假定ConcurrentMap不能包含空值，而get()返回null明确表示该键不存在。 支持空值的实现必须覆盖此默认实现。

        参数
        key - 指定值与之关联的键
        remappingFunction - 计算值的重映射函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中（ optional ）
        NullPointerException - 如果指定的键为空，此映射不支持空键，或者remappingFunction为空
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中（ optional ）
        从以下版本开始：
        1.8

      • merge

        default V merge​(K key,
                V value,
                BiFunction<? super V,? super V,? extends V> remappingFunction)
        如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。 否则，将相关值替换为给定重映射函数的结果，如果结果为null ，则将其null 。 当组合键的多个映射值时，该方法可能是有用的。 例如，要为值映射创建或附加String msg ：
           map.merge(key, msg, String::concat)

        如果重映射函数返回null ，则映射将被删除。 如果重映射函数本身引发（未检查）异常，则重新引导异常，并且当前映射保持不变。

        重映射功能在计算过程中不应修改此映射。

        Specified by:
        merge在接口 Map<K,V>
        实现要求：
        默认实现相当于为此执行以下步骤： map ：
           for (;;) { V oldValue = map.get(key); if (oldValue != null) { V newValue = remappingFunction.apply(oldValue, value); if (newValue != null) { if (map.replace(key, oldValue, newValue)) return newValue; } else if (map.remove(key, oldValue)) { return null; } } else if (map.putIfAbsent(key, value) == null) { return value; } }
        当多个线程尝试更新时，可以多次调用映射操作和重映射功能。

        此实现假定ConcurrentMap不能包含空值，而get()明确地返回null表示密钥不存在。 支持空值的实现必须覆盖此默认实现。

        参数
        key - 与结果值相关联的键
        value - 要与与密钥相关联的现有值合并的非空值，或者如果没有与密钥相关联的现有值或空值与密钥相关联
        remappingFunction - 如果存在重新计算值的重映射功能
        结果
        与指定键相关联的新值，如果没有值与该键相关联，则返回null
        异常
        UnsupportedOperationException - 如果此地图不支持 put操作（ optional ）
        ClassCastException - 如果指定的键或值的类阻止它存储在此映射中（ optional ）
        NullPointerException - 如果指定的键为空，并且此映射不支持空键或值或remappingFunction为空
        IllegalArgumentException - 如果指定键或值的某些属性阻止其存储在此映射中（ optional ）
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConcurrentNavigableMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface ConcurrentNavigableMap<K,V>

  • 参数类型
    K - 由此地图维护的键的类型
    V - 映射值的类型
    All Superinterfaces:
    ConcurrentMap<K,V> ， Map<K,V> ， NavigableMap<K,V> ， SortedMap<K,V>
    所有已知实现类：
    ConcurrentSkipListMap

    public interface ConcurrentNavigableMap<K,V>
extends ConcurrentMap<K,V>, NavigableMap<K,V>
    A ConcurrentMap支持NavigableMap操作，并递归地为其导航子地图。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.6

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      NavigableSet<K> descendingKeySet​()
      返回此地图中包含的键的相反顺序NavigableSet 。
      ConcurrentNavigableMap<K,V> descendingMap​()
      返回此映射中包含的映射的反向排序视图。
      ConcurrentNavigableMap<K,V> headMap​(K toKey)
      返回该地图的部分密钥严格小于 toKey 。
      ConcurrentNavigableMap<K,V> headMap​(K toKey, boolean inclusive)
      返回该地图部分的视图，其键值小于（或等于，如果 inclusive为真） toKey 。
      NavigableSet<K> keySet​()
      返回此地图中包含的键的NavigableSet视图。
      NavigableSet<K> navigableKeySet​()
      返回此地图中包含的键的NavigableSet视图。
      ConcurrentNavigableMap<K,V> subMap​(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
      返回此地图部分的视图，其关键字范围从 fromKey到 toKey 。
      ConcurrentNavigableMap<K,V> subMap​(K fromKey, K toKey)
      返回该地图部分的视图，其关键字范围从 fromKey （含）到 toKey ，独占。
      ConcurrentNavigableMap<K,V> tailMap​(K fromKey)
      返回此地图部分的视图，其键大于或等于 fromKey 。
      ConcurrentNavigableMap<K,V> tailMap​(K fromKey, boolean inclusive)
      返回该地图部分的视图，其键大于（或等于，如果 inclusive为真） fromKey 。

      • Methods inherited from interface java.util.concurrent.ConcurrentMap

        compute, computeIfAbsent, computeIfPresent, forEach, getOrDefault, merge, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from interface java.util.Map

        clear, containsKey, containsValue, entry, equals, get, hashCode, isEmpty, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, remove, size

      • Methods inherited from interface java.util.NavigableMap

        ceilingEntry, ceilingKey, firstEntry, floorEntry, floorKey, higherEntry, higherKey, lastEntry, lowerEntry, lowerKey, pollFirstEntry, pollLastEntry

      • Methods inherited from interface java.util.SortedMap

        comparator, entrySet, firstKey, lastKey, values

    • 方法详细信息

      • subMap

        ConcurrentNavigableMap<K,V> subMap​(K fromKey,
                                   boolean fromInclusive,
                                   K toKey,
                                   boolean toInclusive)
        描述从接口NavigableMap复制
        返回此地图部分的视图，其关键字范围从fromKey到toKey 。 如果fromKey和toKey相等，则返回的地图为空，除非fromInclusive和toInclusive都为真。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键，或构造一个其端点位于其范围之外的子地图。

        Specified by:
        subMap在接口 NavigableMap<K,V>
        参数
        fromKey - 返回地图中键的低端点
        fromInclusive - true如果低端点要包括在返回的视图中
        toKey - 返回地图中键的高端点
        toInclusive - true如果高端点要包含在返回的视图中
        结果
        该地图的部分视图的视图范围从 fromKey到 toKey
        异常
        ClassCastException - 如果fromKey和toKey无法使用该地图的比较器相互比较（或者，如果地图没有比较器，则使用自然排序）。 如果fromKey或toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey或 toKey为空，并且此映射不允许空键
        IllegalArgumentException - 如果fromKey大于toKey ; 或者如果此地图本身具有限制范围，而fromKey或toKey位于范围范围之外

      • headMap

        ConcurrentNavigableMap<K,V> headMap​(K toKey,
                                    boolean inclusive)
        描述从接口NavigableMap复制
        返回此地图部分的视图，其键值小于（或等于，如果inclusive为真） toKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        Specified by:
        headMap在接口 NavigableMap<K,V>
        参数
        toKey - 返回地图中的键的高端点
        inclusive - true如果高端点要包含在返回的视图中
        结果
        关键字小于（或等于，如果为 inclusive为真）的地图部分的视图 toKey
        异常
        ClassCastException - 如果toKey与该地图的比较器不兼容（或者如果地图没有比较器，如果toKey不实现Comparable ）。 如果toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toKey为空，并且此映射不允许空值
        IllegalArgumentException - 如果该地图本身有限制范围，并且 toKey位于范围的范围之外

      • tailMap

        ConcurrentNavigableMap<K,V> tailMap​(K fromKey,
                                    boolean inclusive)
        描述从接口NavigableMap复制
        返回该地图部分的视图，其键大于（或等于，如果inclusive为真） fromKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        Specified by:
        tailMap在接口 NavigableMap<K,V>
        参数
        fromKey - 返回地图中键的低端点
        inclusive - true如果低端点要包括在返回的视图中
        结果
        键的大小大于（或等于，如果 inclusive为真）的地图部分的视图） fromKey
        异常
        ClassCastException - 如果fromKey与此地图的比较器不兼容（或者如果地图没有比较器，如果fromKey不实现Comparable ）。 如果fromKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey为空，并且此映射不允许空值
        IllegalArgumentException - 如果此地图本身具有限制范围，并且 fromKey位于范围界限之外

      • subMap

        ConcurrentNavigableMap<K,V> subMap​(K fromKey,
                                   K toKey)
        说明从接口NavigableMap复制
        返回此地图部分的视图，其关键字范围从fromKey （含）到toKey ，独占。 （如果fromKey和toKey相等，则返回的地图为空。）返回的地图由该地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于subMap(fromKey, true, toKey, false) 。

        Specified by:
        subMap在接口 NavigableMap<K,V>
        Specified by:
        subMap在接口 SortedMap<K,V>
        参数
        fromKey - 返回地图中的键的低端点（含）
        toKey - 返回地图中的键的高端点（独占）
        结果
        该地图的部分视图，其关键范围从 fromKey （含）到 toKey ，独占
        异常
        ClassCastException - 如果fromKey和toKey不能使用该地图的比较器进行比较（或者如果地图没有比较器，则使用自然排序）。 如果fromKey或toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey或 toKey为空，并且此映射不允许空键
        IllegalArgumentException - 如果fromKey大于toKey ; 或者如果此地图本身具有有限的范围，并且fromKey或toKey位于范围的范围之外

      • headMap

        ConcurrentNavigableMap<K,V> headMap​(K toKey)
        说明从界面NavigableMap复制
        返回该地图的部分密钥严格小于toKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将扔一个IllegalArgumentException尝试插入一个键超出其范围。

        相当于headMap(toKey, false) 。

        Specified by:
        headMap在接口 NavigableMap<K,V>
        Specified by:
        headMap在接口 SortedMap<K,V>
        参数
        toKey - 返回地图中的键的高端点（独占）
        结果
        该地图的部分密钥严格小于 toKey
        异常
        ClassCastException - 如果toKey与此地图的比较器不兼容（或者如果地图没有比较器，如果toKey不实现Comparable ）。 如果toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toKey为空，并且此映射不允许空键
        IllegalArgumentException - 如果该地图本身有限制范围，而 toKey位于范围的范围之外

      • tailMap

        ConcurrentNavigableMap<K,V> tailMap​(K fromKey)
        描述从接口NavigableMap复制
        返回此地图部分的视图，其键大于或等于fromKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于tailMap(fromKey, true) 。

        Specified by:
        tailMap在接口 NavigableMap<K,V>
        Specified by:
        tailMap在接口 SortedMap<K,V>
        参数
        fromKey - 返回地图中的键的低端点（含）
        结果
        该地图的部分的视图，其键大于或等于 fromKey
        异常
        ClassCastException - 如果fromKey与该地图的比较器不兼容（或者如果地图没有比较器，如果fromKey不实现Comparable ）。 如果fromKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey为空，并且该地图不允许空值
        IllegalArgumentException - 如果此地图本身有限制范围，而 fromKey位于范围范围之外

      • descendingMap

        ConcurrentNavigableMap<K,V> descendingMap​()
        返回此映射中包含的映射的反向排序视图。 降序地图由该地图支持，所以对地图的更改反映在降序地图中，反之亦然。

        返回的地图的订单等价于Collections.reverseOrder (comparator()) 。 表达m.descendingMap().descendingMap()返回一个视图的m实质上等同于m 。

        Specified by:
        descendingMap在接口 NavigableMap<K,V>
        结果
        这张地图的倒序视图

      • navigableKeySet

        NavigableSet<K> navigableKeySet​()
        返回此地图中包含的键的NavigableSet视图。 该集合的迭代器按升序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。

        视图的迭代器和拼接器是weakly consistent 。

        Specified by:
        navigableKeySet在接口 NavigableMap<K,V>
        结果
        该地图中的键的可导航集合视图

      • keySet

        NavigableSet<K> keySet​()
        返回此地图中包含的键的NavigableSet视图。 该集合的迭代器按升序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。

        视图的迭代器和分割器是weakly consistent 。

        该方法等同于方法navigableKeySet 。

        Specified by:
        keySet在接口 Map<K,V>
        Specified by:
        keySet在接口 SortedMap<K,V>
        结果
        该地图中的键的可导航集合视图

      • descendingKeySet

        NavigableSet<K> descendingKeySet​()
        返回此地图中包含的键的相反顺序NavigableSet 。 集合的迭代器按降序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。

        视图的迭代器和拼接器是weakly consistent 。

        Specified by:
        descendingKeySet在接口 NavigableMap<K,V>
        结果
        该地图中的键的反向导航设置视图
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConcurrentSkipListMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ConcurrentSkipListMap<K,V>

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.concurrent.ConcurrentSkipListMap<K,V>
  • 参数类型
    K - 由此地图维护的键的类型
    V - 映射值的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， ConcurrentMap<K,V> ， ConcurrentNavigableMap<K,V> ， Map<K,V> ， NavigableMap<K,V> ， SortedMap<K,V>

    public class ConcurrentSkipListMap<K,V>
extends AbstractMap<K,V>
implements ConcurrentNavigableMap<K,V>, Cloneable, Serializable
    一个可扩展并发的ConcurrentNavigableMap实现。 该地图是根据排序natural ordering其密钥，或通过Comparator在地图创建时提供，这取决于所使用的构造方法。

    这个类实现的并发变种SkipLists提供预期平均log（n）的时间成本，为containsKey ， get ， put和remove操作及其变体。 插入，删除，更新和访问操作由多个线程并发执行安全地执行。

    迭代器和拼接器是weakly consistent 。

    升序关键排序视图及其迭代器比降序更快。

    通过此类中的方法返回的全部Map.Entry对，其视图表示生成时映射的快照。 他们不支持Entry.setValue方法。 （不过要注意的是可以利用改变相关的地图映射put ， putIfAbsent ，或replace ，取决于你到底需要哪些效果。）

    请注意，与大多数集合不同， size方法不是一个常时操作。 由于这些映射的异步性质，确定当前元素数量需要遍历元素，因此如果在遍历期间修改此集合，则可能会报告不准确的结果。 此外，该批量操作putAll ， equals ， toArray ， containsValue和clear待原子方式执行， 不能保证。 例如，与putAll操作同时运行的迭代器可能仅查看一些添加的元素。

    该类及其视图和迭代器实现了Map和Iterator接口的所有可选方法。 与大多数其他并发集合，这个类不允许使用null键或值，因为有些空返回值不能从存在的元素的可靠地区分。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConcurrentSkipListMap​()
      构造一个新的，空的地图，按照natural ordering的按键进行排序。
      ConcurrentSkipListMap​(Comparator<? super K> comparator)
      构造一个新的，空的地图，根据指定的比较器进行排序。
      ConcurrentSkipListMap​(Map<? extends K,? extends V> m)
      构造一个包含与给定地图相同的映射的新地图，根据密钥的natural ordering进行排序。
      ConcurrentSkipListMap​(SortedMap<K,? extends V> m)
      构造一个包含相同映射并使用与指定排序映射相同顺序的新映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Map.Entry<K,V> ceilingEntry​(K key)
      返回与大于或等于给定键的最小键相关联的键值映射，如果没有 null则 null 。
      K ceilingKey​(K key)
      返回大于或等于给定键的 null键，如果没有此键，则 null 。
      void clear​()
      从这张地图中删除所有的映射。
      ConcurrentSkipListMap<K,V> clone​()
      返回此 ConcurrentSkipListMap实例的浅拷贝。
      Comparator<? super K> comparator​()
      返回用于订购此地图中的键的比较器，或null如果此地图使用其键的natural ordering 。
      V compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定键的映射及其当前映射值（如果没有当前映射，则 null ）。
      V computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联，则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      V computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果存在指定键的值，则尝试计算给出键的新映射及其当前映射值。
      boolean containsKey​(Object key)
      如果此映射包含指定键的映射，则返回 true 。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      NavigableSet<K> descendingKeySet​()
      返回此映射中包含的键的相反顺序NavigableSet 。
      ConcurrentNavigableMap<K,V> descendingMap​()
      返回此映射中包含的映射的反向排序视图。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      boolean equals​(Object o)
      将指定的对象与此映射进行比较以获得相等性。
      Map.Entry<K,V> firstEntry​()
      返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      K firstKey​()
      返回此地图中当前的第一个（最低）键。
      Map.Entry<K,V> floorEntry​(K key)
      返回与小于或等于给定键的最大键相关联的键值映射，如果没有这样的键，则 null 。
      K floorKey​(K key)
      返回小于或等于给定键的最大键，如果没有这样的键，则 null 。
      void forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。
      V getOrDefault​(Object key, V defaultValue)
      返回指定键映射到的值或给定的defaultValue，如果该映射不包含该键的映射。
      ConcurrentNavigableMap<K,V> headMap​(K toKey)
      返回此地图部分的视图，其密钥严格小于 toKey 。
      ConcurrentNavigableMap<K,V> headMap​(K toKey, boolean inclusive)
      返回该地图部分的视图，其键值小于（或等于，如果 inclusive为真） toKey 。
      Map.Entry<K,V> higherEntry​(K key)
      返回与最小密钥相关联的密钥值映射严格大于给定密钥，如果没有这样的密钥则 null 。
      K higherKey​(K key)
      返回严格大于给定键的最小键，如果没有这样的键，则返回 null 。
      boolean isEmpty​()
      如果此映射不包含键值映射，则返回 true 。
      NavigableSet<K> keySet​()
      返回此地图中包含的键的NavigableSet视图。
      Map.Entry<K,V> lastEntry​()
      返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
      K lastKey​()
      返回当前在此地图中的最后（最高）键。
      Map.Entry<K,V> lowerEntry​(K key)
      返回与严格小于给定键的最大键相关的键值映射，如果没有这样的键，则 null 。
      K lowerKey​(K key)
      返回严格小于给定键的最大键，如果没有这样的键，则返回 null 。
      V merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联，则将其与给定值相关联。
      NavigableSet<K> navigableKeySet​()
      返回此地图中包含的键的NavigableSet视图。
      Map.Entry<K,V> pollFirstEntry​()
      删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
      Map.Entry<K,V> pollLastEntry​()
      删除并返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
      V put​(K key, V value)
      将指定的值与此映射中的指定键相关联。
      V putIfAbsent​(K key, V value)
      如果指定的键尚未与值相关联，则将其与给定值相关联。
      V remove​(Object key)
      从该地图中删除指定键的映射（如果存在）。
      boolean remove​(Object key, Object value)
      仅当当前映射到给定值时才删除密钥的条目。
      V replace​(K key, V value)
      仅当当前映射到某个值时才替换该项的条目。
      boolean replace​(K key, V oldValue, V newValue)
      仅当当前映射到给定值时才替换密钥的条目。
      void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      int size​()
      返回此地图中键值映射的数量。
      ConcurrentNavigableMap<K,V> subMap​(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
      返回此地图部分的视图，其视图范围从 fromKey到 toKey 。
      ConcurrentNavigableMap<K,V> subMap​(K fromKey, K toKey)
      返回该地图部分的视图，其关键范围从 fromKey （含）到 toKey ，独占。
      ConcurrentNavigableMap<K,V> tailMap​(K fromKey)
      返回此地图部分的视图，其键大于或等于 fromKey 。
      ConcurrentNavigableMap<K,V> tailMap​(K fromKey, boolean inclusive)
      返回此地图部分的视图，其键大于（或等于，如果为 inclusive为真） fromKey 。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from class java.util.AbstractMap

        hashCode, putAll, toString

      • Methods inherited from interface java.util.Map

        entry, hashCode, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putAll

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ConcurrentSkipListMap

        public ConcurrentSkipListMap​()
        构造一个新的，空的地图，按照natural ordering的按键进行排序。

      • ConcurrentSkipListMap

        public ConcurrentSkipListMap​(Comparator<? super K> comparator)
        构造一个新的，空的地图，根据指定的比较器进行排序。
        参数
        comparator - 将用于订购此映射的比较器。 如果是null ，将使用natural ordering的按键。

      • ConcurrentSkipListMap

        public ConcurrentSkipListMap​(Map<? extends K,? extends V> m)
        构造一个包含与给定地图相同的映射的新地图，按照密钥的natural ordering进行排序。
        参数
        m - 其映射将放置在此映射中的映射
        异常
        ClassCastException - 如果m中的键不是Comparable ，或者不相互比较
        NullPointerException - 如果指定的地图或其任何键或值为空

      • ConcurrentSkipListMap

        public ConcurrentSkipListMap​(SortedMap<K,? extends V> m)
        构造一个包含相同映射并使用与指定排序映射相同顺序的新映射。
        参数
        m - 其映射将被放置在此映射中的排序映射，并且其比较器将用于对该映射进行排序
        异常
        NullPointerException - 如果指定的排序映射或其任何键或值为空

    • 方法详细信息

      • clone

        public ConcurrentSkipListMap<K,V> clone​()
        返回此ConcurrentSkipListMap实例的浅拷贝。 （键和值本身不被克隆。）
        重写：
        clone中的 AbstractMap<K,V>
        结果
        这张地图的浅拷贝
        另请参见：
        Cloneable

      • containsKey

        public boolean containsKey​(Object key)
        如果此映射包含指定键的映射，则返回 true 。
        Specified by:
        containsKey在接口 Map<K,V>
        重写：
        containsKey在 AbstractMap<K,V>
        参数
        key - 要在此地图中存在的密钥要进行测试
        结果
        true如果此映射包含指定键的映射
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • get

        public V get​(Object key)
        返回指定键映射到的值，如果此映射不包含键的映射，则返回null 。

        更正式地，如果此映射包含从密钥映射k到值v使得key比较等于k根据地图的排序，则此方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        Specified by:
        get在接口 Map<K,V>
        重写：
        get在 AbstractMap<K,V>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含键的映射， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • getOrDefault

        public V getOrDefault​(Object key,
                      V defaultValue)
        返回指定键映射到的值或给定的defaultValue，如果该映射不包含该键的映射。
        Specified by:
        getOrDefault在接口 ConcurrentMap<K,V>
        Specified by:
        getOrDefault在接口 Map<K,V>
        参数
        key - 关键
        defaultValue - 如果此映射不包含给定键的映射，则返回的值
        结果
        键的映射，如果存在; 否则为defaultValue
        异常
        NullPointerException - 如果指定的键为空
        从以下版本开始：
        1.8

      • put

        public V put​(K key,
             V value)
        将指定的值与此映射中的指定键相关联。 如果地图先前包含了该键的映射，则替换旧值。
        Specified by:
        put在接口 Map<K,V>
        重写：
        put在 AbstractMap<K,V>
        参数
        key - 与其相关联的指定值的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键或值为空

      • remove

        public V remove​(Object key)
        从该地图中删除指定键的映射（如果存在）。
        Specified by:
        remove在接口 Map<K,V>
        重写：
        remove中的 AbstractMap<K,V>
        参数
        key - 应该删除映射的键
        结果
        与指定键相关联的上一个值，如果没有键的映射， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • containsValue

        public boolean containsValue​(Object value)
        如果该地图将一个或多个键映射到指定的值，则返回true 。 此操作需要在地图大小的时间线性。 此外，在执行此方法期间，地图可能会发生更改，在这种情况下，返回的结果可能不准确。
        Specified by:
        containsValue在接口 Map<K,V>
        重写：
        containsValue中的 AbstractMap<K,V>
        参数
        value - 要在此地图中存在的值要进行测试
        结果
        true如果映射到value存在; false否则
        异常
        NullPointerException - 如果指定的值为null

      • size

        public int size​()
        返回此地图中键值映射的数量。 如果此地图包含Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。

        请注意，与大多数集合不同，此方法不是一个常时操作。 由于这些映射的异步性质，确定当前数量的元素需要遍历它们才能对它们进行计数。 此外，在执行此方法期间，大小可能会发生更改，在这种情况下，返回的结果将不准确。 因此，这种方法在并发应用程序中通常不是很有用。

        Specified by:
        size在接口 Map<K,V>
        重写：
        size在 AbstractMap<K,V>
        结果
        该地图中的元素数量

      • isEmpty

        public boolean isEmpty​()
        如果此映射不包含键值映射，则返回 true 。
        Specified by:
        isEmpty在接口 Map<K,V>
        重写：
        isEmpty在 AbstractMap<K,V>
        结果
        true如果此映射不包含键值映射

      • clear

        public void clear​()
        从这张地图中删除所有的映射。
        Specified by:
        clear在接口 Map<K,V>
        重写：
        clear在 AbstractMap<K,V>

      • computeIfAbsent

        public V computeIfAbsent​(K key,
                         Function<? super K,? extends V> mappingFunction)
        如果指定的键尚未与值相关联，则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是null 。 该函数不保证一旦原子仅当值不存在施加。
        Specified by:
        computeIfAbsent在接口 ConcurrentMap<K,V>
        Specified by:
        computeIfAbsent在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        mappingFunction - 计算值的函数
        结果
        与指定键相关联的当前（现有或计算）值，如果计算值为空，则为null
        异常
        NullPointerException - 如果指定的键为空或mappingFunction为空
        从以下版本开始：
        1.8

      • computeIfPresent

        public V computeIfPresent​(K key,
                          BiFunction<? super K,? super V,? extends V> remappingFunction)
        如果存在指定键的值，则尝试计算给出键的新映射及其当前映射值。 该功能不能保证原子应用一次。
        Specified by:
        computeIfPresent在接口 ConcurrentMap<K,V>
        Specified by:
        computeIfPresent在接口 Map<K,V>
        参数
        key - 值可以与之相关联的键
        remappingFunction - 计算值的函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        NullPointerException - 如果指定的键为null或 NullPointerException为空
        从以下版本开始：
        1.8

      • compute

        public V compute​(K key,
                 BiFunction<? super K,? super V,? extends V> remappingFunction)
        尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则null ）。 该功能不能保证原子应用一次。
        Specified by:
        compute在接口 ConcurrentMap<K,V>
        Specified by:
        compute在接口 Map<K,V>
        参数
        key - 要与其关联的指定值的键
        remappingFunction - 计算值的函数
        结果
        与指定键相关的新值，如果没有则为null
        异常
        NullPointerException - 如果指定的键为空或 NullPointerException为空
        从以下版本开始：
        1.8

      • merge

        public V merge​(K key,
               V value,
               BiFunction<? super V,? super V,? extends V> remappingFunction)
        如果指定的键尚未与值相关联，则将其与给定值相关联。 否则，使用给定的重映射函数的结果替换该值，或者如果为null ，则将其null 。 该功能不能保证原子应用一次。
        Specified by:
        merge在接口 ConcurrentMap<K,V>
        Specified by:
        merge在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        value - 缺席时使用的值
        remappingFunction - 重新计算值（如果存在）的功能
        结果
        与指定键相关的新值，如果没有则为null
        异常
        NullPointerException - 如果指定的键或值为空或 NullPointerException为空
        从以下版本开始：
        1.8

      • keySet

        public NavigableSet<K> keySet​()
        返回此地图中包含的键的NavigableSet视图。

        该集合的迭代器按升序返回密钥。 该集的spliterator另外报告Spliterator.CONCURRENT ， Spliterator.NONNULL ， Spliterator.SORTED和Spliterator.ORDERED ，与被按键的升序的顺序相遇。 该spliterator的比较（见Spliterator.getComparator() ）是null如果映射的比较（见comparator() ）是null 。 否则，拼接器的比较器与地图的比较器相同或者施加相同的总排序。

        该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。

        视图的迭代器和拼接器是weakly consistent 。

        该方法等同于方法navigableKeySet 。

        Specified by:
        keySet在接口 ConcurrentNavigableMap<K,V>
        Specified by:
        keySet在接口 Map<K,V>
        Specified by:
        keySet在接口 SortedMap<K,V>
        重写：
        keySet中的 AbstractMap<K,V>
        结果
        该地图中的键的可导航集合视图

      • navigableKeySet

        public NavigableSet<K> navigableKeySet​()
        描述从接口ConcurrentNavigableMap复制
        返回此地图中包含的键的NavigableSet视图。 该集合的迭代器按升序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。

        视图的迭代器和拼接器是weakly consistent 。

        Specified by:
        navigableKeySet接口 ConcurrentNavigableMap<K,V>
        Specified by:
        navigableKeySet接口 NavigableMap<K,V>
        结果
        该地图中的键的可导航集合视图

      • values

        public Collection<V> values​()
        返回此地图中包含的值的Collection视图。

        集合的迭代器按照相应键的升序返回值。 藏品的spliterator另外报告Spliterator.CONCURRENT ， Spliterator.NONNULL和Spliterator.ORDERED ，与正在提升相应的按键顺序的遭遇订单。

        集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。

        视图的迭代器和拼接器是weakly consistent 。

        Specified by:
        values接口 Map<K,V>
        Specified by:
        values在接口 SortedMap<K,V>
        重写：
        values在 AbstractMap<K,V>
        结果
        该地图中包含的值的集合视图

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        返回此地图中包含的映射的Set视图。

        集合的迭代器按升序键顺序返回条目。 该集的spliterator另外报告Spliterator.CONCURRENT ， Spliterator.NONNULL ， Spliterator.SORTED和Spliterator.ORDERED ，与被按键的升序的顺序相遇。

        该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。

        视图的迭代器和拼接器是weakly consistent 。

        由iterator或spliterator遍历的Map.Entry元素不支持setValue操作。

        Specified by:
        entrySet在接口 Map<K,V>
        Specified by:
        entrySet在接口 SortedMap<K,V>
        Specified by:
        entrySet在 AbstractMap<K,V>
        结果
        该地图中包含的映射的集合视图，按升序排序

      • descendingMap

        public ConcurrentNavigableMap<K,V> descendingMap​()
        说明从界面ConcurrentNavigableMap复制
        返回此映射中包含的映射的反向排序视图。 降序地图由该地图支持，所以对地图的更改反映在降序地图中，反之亦然。

        返回的地图的订单等价于Collections.reverseOrder (comparator()) 。 表达m.descendingMap().descendingMap()返回一个视图的m实质上等同于m 。

        Specified by:
        descendingMap在接口 ConcurrentNavigableMap<K,V>
        Specified by:
        descendingMap在接口 NavigableMap<K,V>
        结果
        这张地图的倒序视图

      • descendingKeySet

        public NavigableSet<K> descendingKeySet​()
        描述从接口ConcurrentNavigableMap复制
        返回此地图中包含的键的相反顺序NavigableSet 。 集合的迭代器按降序返回密钥。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。

        视图的迭代器和拼接器是weakly consistent 。

        Specified by:
        descendingKeySet在接口 ConcurrentNavigableMap<K,V>
        Specified by:
        descendingKeySet在接口 NavigableMap<K,V>
        结果
        该地图中的键的反向导航设置视图

      • equals

        public boolean equals​(Object o)
        将指定的对象与此映射进行比较以获得相等性。 如果给定的对象也是一个地图，并且两个地图代表相同的映射，则返回true 。 更正式地，如果m1.entrySet().equals(m2.entrySet()) ，两个地图m1和m2表示相同的映射。 如果在执行此方法期间同时修改了映射，则此操作可能会返回误导结果。
        Specified by:
        equals在接口 Map<K,V>
        重写：
        equals中的 AbstractMap<K,V>
        参数
        o - 要与此地图相等的对象进行比较
        结果
        true如果指定的对象等于此映射
        另请参见：
        Object.hashCode() ， HashMap

      • putIfAbsent

        public V putIfAbsent​(K key,
                     V value)
        如果指定的键尚未与值相关联，则将其与给定值相关联。 这相当于，对于这个map ：
           if (!map.containsKey(key)) return map.put(key, value); else return map.get(key);
        除了动作以原子方式执行。
        Specified by:
        putIfAbsent接口 ConcurrentMap<K,V>
        Specified by:
        putIfAbsent在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键或值为空

      • remove

        public boolean remove​(Object key,
                      Object value)
        仅当当前映射到给定值时才删除密钥的条目。 这相当于，对于这个map ：
           if (map.containsKey(key) && Objects.equals(map.get(key), value)) { map.remove(key); return true; } else { return false; }
        除了动作以原子方式执行。
        Specified by:
        remove在接口 ConcurrentMap<K,V>
        Specified by:
        remove在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        value - 预期与指定键相关联的值
        结果
        true如果该值被删除
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • replace

        public boolean replace​(K key,
                       V oldValue,
                       V newValue)
        仅当当前映射到给定值时才替换密钥的条目。 这相当于，对于这个map ：
           if (map.containsKey(key) && Objects.equals(map.get(key), oldValue)) { map.put(key, newValue); return true; } else { return false; }
        除了动作以原子方式执行。
        Specified by:
        replace接口 ConcurrentMap<K,V>
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        oldValue - 预期与指定键相关联的值
        newValue - 与指定键相关联的值
        结果
        true如果该值被替换
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果任何参数为空

      • replace

        public V replace​(K key,
                 V value)
        仅当当前映射到某个值时才替换该项的条目。 这相当于，对于这个map ：
           if (map.containsKey(key)) return map.put(key, value); else return null;
        除了动作以原子方式执行。
        Specified by:
        replace在接口 ConcurrentMap<K,V>
        Specified by:
        replace在接口 Map<K,V>
        参数
        key - 与指定值相关联的键
        value - 要与指定键相关联的值
        结果
        与指定键相关联的上一个值，如果没有键的映射， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键或值为空

      • comparator

        public Comparator<? super K> comparator​()
        说明从接口SortedMap复制
        返回用于为了在这个映射中的键，或比较null如果此映射使用natural ordering它的键。
        Specified by:
        comparator在接口 SortedMap<K,V>
        结果
        比较器用于对该地图中的键进行排序，如果该地图使用其键的自然排序， null

      • firstKey

        public K firstKey​()
        说明从界面SortedMap复制
        返回此地图中当前的第一个（最低）键。
        Specified by:
        firstKey在接口 SortedMap<K,V>
        结果
        当前在此地图中的第一（最低）键
        异常
        NoSuchElementException - 如果这张地图是空的

      • lastKey

        public K lastKey​()
        描述从接口SortedMap复制
        返回当前在此地图中的最后（最高）键。
        Specified by:
        lastKey接口 SortedMap<K,V>
        结果
        当前在此地图中的最后（最高）键
        异常
        NoSuchElementException - 如果这张地图是空的

      • subMap

        public ConcurrentNavigableMap<K,V> subMap​(K fromKey,
                                          boolean fromInclusive,
                                          K toKey,
                                          boolean toInclusive)
        描述从接口NavigableMap复制
        返回此地图部分的视图，其关键字范围从fromKey到toKey 。 如果fromKey和toKey相等，则返回的地图为空，除非fromInclusive和toInclusive都为真。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键，或者构建一个其端点位于其范围之外的子地图。

        Specified by:
        subMap在接口 ConcurrentNavigableMap<K,V>
        Specified by:
        subMap在接口 NavigableMap<K,V>
        参数
        fromKey - 返回地图中键的低端点
        fromInclusive - true如果 true低端点包括在返回视图中
        toKey - 返回地图中键的高端点
        toInclusive - true如果 true高端点包含在返回视图中
        结果
        该地图的部分视图的视图范围从 fromKey到 toKey
        异常
        ClassCastException - 如果fromKey和toKey无法使用该地图的比较器相互比较（或者，如果地图没有比较器，则使用自然排序）。 如果fromKey或toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey或 toKey为null
        IllegalArgumentException - 如果fromKey大于toKey ; 或者如果该地图本身具有有限的范围，并且fromKey或toKey位于范围的界限之外

      • headMap

        public ConcurrentNavigableMap<K,V> headMap​(K toKey,
                                           boolean inclusive)
        描述从接口NavigableMap复制
        返回此地图部分的视图，其键值小于（或等于，如果inclusive为真） toKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        Specified by:
        headMap在接口 ConcurrentNavigableMap<K,V>
        Specified by:
        headMap在接口 NavigableMap<K,V>
        参数
        toKey - 返回地图中键的高端点
        inclusive - true如果 true高端点包含在返回视图中
        结果
        键的小于（或等于，如果为 inclusive为真）的地图部分的视图） toKey
        异常
        ClassCastException - 如果toKey与该地图的比较器不兼容（或者如果地图没有比较器，如果toKey不实现Comparable ）。 如果toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toKey为空
        IllegalArgumentException - 如果该地图本身有限制范围，而 toKey位于范围的范围之外

      • tailMap

        public ConcurrentNavigableMap<K,V> tailMap​(K fromKey,
                                           boolean inclusive)
        说明从接口NavigableMap复制
        返回此地图部分的视图，其键大于（或等于，如果inclusive为真） fromKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图将抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        Specified by:
        tailMap在接口 ConcurrentNavigableMap<K,V>
        Specified by:
        tailMap在接口 NavigableMap<K,V>
        参数
        fromKey - 返回地图中键的低端点
        inclusive - true如果低端点要包含在返回的视图中
        结果
        该地图的部分的视图，其键大于（或等于，如果 inclusive为真） fromKey
        异常
        ClassCastException - 如果fromKey与此映射的比较器不兼容（或者，如果映射没有比较器，如果fromKey不实现Comparable ）。 如果fromKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey为空
        IllegalArgumentException - 如果此地图本身有限制范围，并且 fromKey位于范围界限之外

      • subMap

        public ConcurrentNavigableMap<K,V> subMap​(K fromKey,
                                          K toKey)
        描述从接口NavigableMap复制
        返回此地图部分的视图，其关键字范围从fromKey （含）到toKey ，独占。 （如果fromKey和toKey相等，则返回的地图为空。）返回的地图由该地图支持，因此返回地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于subMap(fromKey, true, toKey, false) 。

        Specified by:
        subMap在接口 ConcurrentNavigableMap<K,V>
        Specified by:
        subMap在接口 NavigableMap<K,V>
        Specified by:
        subMap在接口 SortedMap<K,V>
        参数
        fromKey - 返回地图中的键的低端点（含）
        toKey - 返回地图中的键的高端点（独占）
        结果
        该地图的部分视图，其关键范围从 fromKey （含）到 toKey ，独占
        异常
        ClassCastException - 如果fromKey和toKey无法使用该地图的比较器相互比较（或者，如果地图没有比较器，则使用自然排序）。 如果fromKey或toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey或 toKey为空
        IllegalArgumentException - 如果fromKey大于toKey ; 或者如果此地图本身具有限制范围，并且fromKey或toKey位于范围范围之外

      • headMap

        public ConcurrentNavigableMap<K,V> headMap​(K toKey)
        说明从接口NavigableMap复制
        返回该地图的部分密钥严格小于toKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于headMap(toKey, false) 。

        Specified by:
        headMap在接口 ConcurrentNavigableMap<K,V>
        Specified by:
        headMap在接口 NavigableMap<K,V>
        Specified by:
        headMap在接口 SortedMap<K,V>
        参数
        toKey - 返回地图中的键的高端点（独占）
        结果
        该地图的部分密钥严格小于 toKey
        异常
        ClassCastException - 如果toKey与此映射的比较器不兼容（或者如果映射没有比较器，则toKey不实现Comparable ）。 如果toKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toKey为空
        IllegalArgumentException - 如果此地图本身有限制范围，而 toKey位于范围范围之外

      • tailMap

        public ConcurrentNavigableMap<K,V> tailMap​(K fromKey)
        说明从接口NavigableMap复制
        返回此地图部分的视图，其键大于或等于fromKey 。 返回的地图由此地图支持，因此返回的地图中的更改将反映在该地图中，反之亦然。 返回的地图支持该地图支持的所有可选地图操作。

        返回的地图会抛出一个IllegalArgumentException ，试图在其范围之外插入一个键。

        相当于tailMap(fromKey, true) 。

        Specified by:
        tailMap在接口 ConcurrentNavigableMap<K,V>
        Specified by:
        tailMap在接口 NavigableMap<K,V>
        Specified by:
        tailMap在接口 SortedMap<K,V>
        参数
        fromKey - 返回地图中的键的低端点（含）
        结果
        该地图的部分的视图，其键大于或等于 fromKey
        异常
        ClassCastException - 如果fromKey与此映射的比较器不兼容（或者，如果映射没有比较器，如果fromKey不实现Comparable ）。 如果fromKey无法与当前在地图中的键进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromKey为空
        IllegalArgumentException - 如果该地图本身有限制范围，并且 fromKey位于范围界限之外

      • lowerEntry

        public Map.Entry<K,V> lowerEntry​(K key)
        返回与最大密钥相关联的密钥值映射严格小于给定密钥，如果没有这样的密钥，则null 。 返回的条目不支持Entry.setValue方法。
        Specified by:
        lowerEntry在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        一个最大密钥小于 key的条目，如果没有这样的密钥， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • lowerKey

        public K lowerKey​(K key)
        描述从接口NavigableMap复制
        返回严格小于给定键的最大键，如果没有这样的键，则返回 null 。
        Specified by:
        lowerKey在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最大的钥匙小于 key ，或者是 null如果没有这样的钥匙
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • floorEntry

        public Map.Entry<K,V> floorEntry​(K key)
        返回与小于或等于给定键的最大键相关联的键值映射，如果没有此键，则null 。 返回的条目不支持Entry.setValue方法。
        Specified by:
        floorEntry在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最大密钥小于或等于 key ，如果没有这样的密钥， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • floorKey

        public K floorKey​(K key)
        说明从接口NavigableMap复制
        返回小于或等于给定键的最大键，如果没有此键，则 null 。
        Specified by:
        floorKey接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最大钥匙小于或等于 key ，或 null如果没有这样的钥匙
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • ceilingEntry

        public Map.Entry<K,V> ceilingEntry​(K key)
        返回与大于或等于给定键的最小键相关联的键值映射，如果没有null则null 。 返回的条目不支持Entry.setValue方法。
        Specified by:
        ceilingEntry在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最小密钥大于或等于 key ，如果没有这样的密钥， null
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • ceilingKey

        public K ceilingKey​(K key)
        说明从接口NavigableMap复制
        返回大于或等于给定键的 null键，如果没有这样的键，则 null 。
        Specified by:
        ceilingKey在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最小键大于等于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • higherEntry

        public Map.Entry<K,V> higherEntry​(K key)
        返回与最小键相关联的键值映射严格大于给定键，如果没有此键，则null 。 返回的条目不支持Entry.setValue方法。
        Specified by:
        higherEntry在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        一个条目的最小键大于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • higherKey

        public K higherKey​(K key)
        说明从界面NavigableMap复制
        返回严格大于给定键的最小键，如果没有这样的键，则返回 null 。
        Specified by:
        higherKey在接口 NavigableMap<K,V>
        参数
        key - 关键
        结果
        最小键大于 key ，或 null如果没有这样的键
        异常
        ClassCastException - 如果指定的键不能与当前在地图中的键进行比较
        NullPointerException - 如果指定的键为空

      • firstEntry

        public Map.Entry<K,V> firstEntry​()
        返回与该地图中的最小键相关联的键值映射，如果地图为空，则null 。 返回的条目不支持Entry.setValue方法。
        Specified by:
        firstEntry在接口 NavigableMap<K,V>
        结果
        具有最少键的条目，如果此映射为空， null

      • lastEntry

        public Map.Entry<K,V> lastEntry​()
        返回与该地图中最大键相关联的键值映射，如果地图为空，则null 。 返回的条目不支持Entry.setValue方法。
        Specified by:
        lastEntry接口 NavigableMap<K,V>
        结果
        如果该地图为空，则该密钥的最大密钥为 null

      • pollFirstEntry

        public Map.Entry<K,V> pollFirstEntry​()
        删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则null 。 返回的条目不支持Entry.setValue方法。
        Specified by:
        pollFirstEntry在接口 NavigableMap<K,V>
        结果
        该地图被删除的第一个条目，如果该地图为空， null

      • pollLastEntry

        public Map.Entry<K,V> pollLastEntry​()
        删除并返回与该地图中最大键相关联的键值映射，如果地图为空，则null 。 返回的条目不支持Entry.setValue方法。
        Specified by:
        pollLastEntry接口 NavigableMap<K,V>
        结果
        删除该地图的最后一个条目，如果该地图为空， null

      • forEach

        public void forEach​(BiConsumer<? super K,? super V> action)
        说明从界面ConcurrentMap复制
        对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。 除非实现类另有指定，否则按照进入设置迭代的顺序执行操作（如果指定了迭代顺序）。操作引发的异常被转发给调用者。
        Specified by:
        forEach在接口 ConcurrentMap<K,V>
        Specified by:
        forEach在接口 Map<K,V>
        参数
        action - 为每个条目执行的操作

      • replaceAll

        public void replaceAll​(BiFunction<? super K,? super V,? extends V> function)
        描述从接口ConcurrentMap复制
        将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。 函数抛出的异常被转发给调用方。
        Specified by:
        replaceAll在接口 ConcurrentMap<K,V>
        Specified by:
        replaceAll在接口 Map<K,V>
        参数
        function - 应用于每个条目的功能
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConcurrentSkipListSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ConcurrentSkipListSet<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractSet<E>
        • java.util.concurrent.ConcurrentSkipListSet<E>
  • 参数类型
    E - 由此集合维护的元素的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， NavigableSet<E> ， Set<E> ， SortedSet<E>

    public class ConcurrentSkipListSet<E>
extends AbstractSet<E>
implements NavigableSet<E>, Cloneable, Serializable
    可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。 集合的元素根据它们的natural ordering或按创建时间提供的Comparator进行分类，具体取决于使用哪个构造函数。

    此实现提供预期平均log（n）的时间成本，为contains ， add ，并remove操作及其变体。 插入，删除和访问操作由多个线程并发执行安全地执行。

    迭代器和拼接器是weakly consistent 。

    升序排序视图及其迭代器比降序更快。

    请注意，与大多数集合不同， size方法不是一个恒定时间的操作。 由于这些集合的异步性质，确定当前元素数量需要遍历元素，因此如果在遍历期间修改此集合，则可能会报告不准确的结果。

    该添加，删除，或检查多个元件批量操作，如AbstractCollection.addAll(java.util.Collection<? extends E>) ， Collection.removeIf(java.util.function.Predicate<? super E>)或Iterable.forEach(java.util.function.Consumer<? super T>)待原子方式执行， 不能保证。 例如，与addAll操作并发的forEach遍历可能仅观察到一些添加的元素。

    该类及其迭代器实现Set和Iterator接口的所有可选方法。 像大多数其他并发收集实现一样，此类不允许使用null元素，因为null参数和返回值不能与不存在元素可靠地区分开。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConcurrentSkipListSet​()
      构造一个新的，空的集合，根据他们的natural ordering订购它的元素。
      ConcurrentSkipListSet​(Collection<? extends E> c)
      构造一个包含指定集合中的元素的新集合，根据它们的natural ordering对其元素进行排序 。
      ConcurrentSkipListSet​(Comparator<? super E> comparator)
      构造一个新的空集合，根据指定的比较器对其元素进行排序。
      ConcurrentSkipListSet​(SortedSet<E> s)
      构造一个包含相同元素并使用与指定排序集相同顺序的新集合。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素添加到此集合（如果尚未存在）。
      E ceiling​(E e)
      返回此集合中最小元素大于或等于给定元素，如果没有此元素，则 null 。
      void clear​()
      从此集合中删除所有元素。
      ConcurrentSkipListSet<E> clone​()
      返回此 ConcurrentSkipListSet实例的浅拷贝。
      Comparator<? super E> comparator​()
      返回用于对该集合中的元素进行排序的比较器，或null如果此集合使用其元素的natural ordering 。
      boolean contains​(Object o)
      如果此集合包含指定的元素，则返回 true 。
      Iterator<E> descendingIterator​()
      以降序返回该集合中的元素的迭代器。
      NavigableSet<E> descendingSet​()
      返回此集合中包含的元素的反向排序视图。
      boolean equals​(Object o)
      将指定的对象与此集合进行比较以实现相等。
      E first​()
      返回此集合中当前的第一个（最低）元素。
      E floor​(E e)
      返回此集合中最大的元素小于或等于给定元素，如果没有此元素，则 null 。
      NavigableSet<E> headSet​(E toElement)
      返回此集合的部分的视图，其元素严格小于 toElement 。
      NavigableSet<E> headSet​(E toElement, boolean inclusive)
      返回此集合的部分的视图，其元素小于（或等于，如果为 inclusive为真） toElement 。
      E higher​(E e)
      返回这个集合中的最小元素严格大于给定的元素，如果没有这样的元素，则 null 。
      boolean isEmpty​()
      如果此集合不包含元素，则返回 true 。
      Iterator<E> iterator​()
      以升序返回该集合中的元素的迭代器。
      E last​()
      返回此集合中当前的最后（最高）元素。
      E lower​(E e)
      返回该集合中最大的元素严格小于给定的元素，如果没有这样的元素，则 null 。
      E pollFirst​()
      检索并删除第一个（最低）元素，如果此集合为空，则返回 null 。
      E pollLast​()
      检索并删除最后一个（最高）元素，如果此集合为空，则返回 null 。
      boolean remove​(Object o)
      如果存在，则从该集合中删除指定的元素。
      boolean removeAll​(Collection<?> c)
      从此集合中删除指定集合中包含的所有元素。
      int size​()
      返回此集合中的元素数。
      Spliterator<E> spliterator​()
      返回此集合中的元素Spliterator 。
      NavigableSet<E> subSet​(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
      返回该集合的部分的视图，其元素的范围从 fromElement到 toElement 。
      NavigableSet<E> subSet​(E fromElement, E toElement)
      返回该集合的部分视图，其元素的范围从 fromElement （含）到 toElement ，独占。
      NavigableSet<E> tailSet​(E fromElement)
      返回该集合的部分的视图，该部分的元素大于或等于 fromElement 。
      NavigableSet<E> tailSet​(E fromElement, boolean inclusive)
      返回该组的部分的视图，其元素大于（或等于，如果 inclusive为真） fromElement 。

      • Methods inherited from class java.util.AbstractCollection

        addAll, containsAll, retainAll, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractSet

        hashCode

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Set

        addAll, containsAll, hashCode, of, of, of, of, of, of, of, of, of, of, of, of, retainAll, toArray, toArray

    • 构造方法详细信息

      • ConcurrentSkipListSet

        public ConcurrentSkipListSet​()
        构造一个新的，空的集合，根据它们的natural ordering命令其元素。

      • ConcurrentSkipListSet

        public ConcurrentSkipListSet​(Comparator<? super E> comparator)
        构造一个新的空集合，根据指定的比较器对其元素进行排序。
        参数
        comparator - 将用于对该集合进行排序的比较器。 如果是null ，将使用natural ordering的元素。

      • ConcurrentSkipListSet

        public ConcurrentSkipListSet​(Collection<? extends E> c)
        构造一个包含指定集合中的元素的新集合，根据它们的natural ordering对其元素进行排序 。
        参数
        c - 将组成新集合的元素
        异常
        ClassCastException - 如果c中的元素不是Comparable ，或者不相互比较
        NullPointerException - 如果指定的集合或其任何元素为空

      • ConcurrentSkipListSet

        public ConcurrentSkipListSet​(SortedSet<E> s)
        构造一个包含相同元素并使用与指定排序集相同顺序的新集合。
        参数
        s - 其元素将组成新集合的排序集
        异常
        NullPointerException - 如果指定的排序集或其任何元素为空

    • 方法详细信息

      • clone

        public ConcurrentSkipListSet<E> clone​()
        返回此ConcurrentSkipListSet实例的浅拷贝。 （元素本身不被克隆。）
        重写：
        clone在 Object
        结果
        这个集合的浅拷贝
        另请参见：
        Cloneable

      • size

        public int size​()
        返回此集合中的元素数。 如果此集合包含Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。

        请注意，与大多数集合不同，此方法不是一个常时操作。 由于这些集合的异步性质，确定当前数量的元素需要遍历它们才能对它们进行计数。 此外，在执行此方法期间，大小可能会发生更改，在这种情况下，返回的结果将不准确。 因此，这种方法在并发应用程序中通常不是很有用。

        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Set<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        该集合中的元素数量

      • isEmpty

        public boolean isEmpty​()
        如果此集合不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        Specified by:
        isEmpty在接口 Set<E>
        重写：
        isEmpty在 AbstractCollection<E>
        结果
        true如果这个集合不包含元素

      • contains

        public boolean contains​(Object o)
        如果此集合包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此set包含的元素e这样o.equals(e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Set<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 该集合中要检查的对象
        结果
        true如果此集合包含指定的元素
        异常
        ClassCastException - 如果指定的元素不能与当前在此集合中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • add

        public boolean add​(E e)
        将指定的元素添加到此集合（如果尚未存在）。 更正式地，如果该集合不包含e2 ，使得指定的元素e e2 e.equals(e2) 。 如果该集合已经包含该元素，则该呼叫将保持不变，并返回false 。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Set<E>
        重写：
        add在 AbstractCollection<E>
        参数
        e - 要添加到此集合的元素
        结果
        true如果此集合尚未包含指定的元素
        异常
        ClassCastException - 如果 e不能与本集合中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • remove

        public boolean remove​(Object o)
        如果存在，则从该集合中删除指定的元素。 更正式地，删除元素e使得o.equals(e) ，如果这个集合包含这样的元素。 如果此集合包含元素（或等效地，如果该集合由于调用而更改），则返回true 。 （一旦调用返回，此集合将不包含该元素。）
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 Set<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从该集合中删除的对象（如果存在）
        结果
        true如果这个集合包含指定的元素
        异常
        ClassCastException - 如果 o不能与本集合中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • clear

        public void clear​()
        从此集合中删除所有元素。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 Set<E>
        重写：
        clear在 AbstractCollection<E>

      • iterator

        public Iterator<E> iterator​()
        以升序返回该集合中的元素的迭代器。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 NavigableSet<E>
        Specified by:
        iterator在接口 Set<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        这个集合中的元素的迭代器按升序排列

      • descendingIterator

        public Iterator<E> descendingIterator​()
        以降序返回该集合中的元素的迭代器。
        Specified by:
        descendingIterator在接口 NavigableSet<E>
        结果
        这个集合中的元素的迭代器按降序排列

      • equals

        public boolean equals​(Object o)
        将指定的对象与此集合进行比较以实现相等。 如果指定的对象也是一个集合，则返回true ，这两个集合的大小相同，并且指定集合中的每个成员都包含在该集合中（或者等效地，该集合的每个成员都包含在指定的集合中）。 此定义可确保equals方法在集合接口的不同实现之间正常工作。
        Specified by:
        equals在接口 Collection<E>
        Specified by:
        equals在接口 Set<E>
        重写：
        equals在 AbstractSet<E>
        参数
        o - 要与此集合相等的对象进行比较
        结果
        true如果指定的对象等于此集合
        另请参见：
        Object.hashCode() ， HashMap

      • removeAll

        public boolean removeAll​(Collection<?> c)
        从此集合中删除指定集合中包含的所有元素。 如果指定的集合也是集合，则该操作有效地修改该集合，使其值是两组的非对称集合差异 。
        Specified by:
        removeAll在接口 Collection<E>
        Specified by:
        removeAll在接口 Set<E>
        重写：
        removeAll在 AbstractSet<E>
        参数
        c - 包含要 c集合中删除的元素的集合
        结果
        true如果此设置由于呼叫而更改
        异常
        ClassCastException - 如果此集合的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果指定的集合或其任何元素为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • lower

        public E lower​(E e)
        说明从界面NavigableSet复制
        返回该集合中最大的元素严格小于给定的元素，如果没有这样的元素，则 null 。
        Specified by:
        lower在接口 NavigableSet<E>
        参数
        e - 要匹配的值
        结果
        最大元素小于 e ，或 null如果没有这样的元素
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • floor

        public E floor​(E e)
        说明从接口NavigableSet复制
        返回此集中小于或等于给定元素的最大元素，如果没有此元素，则 null 。
        Specified by:
        floor在接口 NavigableSet<E>
        参数
        e - 要匹配的值
        结果
        小于或等于 e的最大元素，如果没有这样的元素， null
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • ceiling

        public E ceiling​(E e)
        描述从接口NavigableSet复制
        返回此集合中最小元素大于或等于给定元素，如果没有此元素，则 null 。
        Specified by:
        ceiling在接口 NavigableSet<E>
        参数
        e - 要匹配的值
        结果
        最小元素大于或等于 e ，如果没有这样的元素， null
        异常
        ClassCastException - 如果指定的元素无法与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • higher

        public E higher​(E e)
        描述从界面NavigableSet复制
        返回此集合中的最小元素严格大于给定元素，如果没有此元素，则 null 。
        Specified by:
        higher接口 NavigableSet<E>
        参数
        e - 要匹配的值
        结果
        最小元素大于 e ，或 null如果没有这样的元素
        异常
        ClassCastException - 如果指定的元素不能与当前集合中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • pollFirst

        public E pollFirst​()
        说明从界面NavigableSet复制
        检索并删除第一个（最低）元素，如果此集合为空，则返回 null 。
        Specified by:
        pollFirst在接口 NavigableSet<E>
        结果
        第一个元素，或 null如果此集合为空

      • pollLast

        public E pollLast​()
        说明从接口NavigableSet复制
        检索并删除最后一个（最高）元素，如果该集合为空，则返回 null 。
        Specified by:
        pollLast在接口 NavigableSet<E>
        结果
        最后一个元素，如果该集合为空， null

      • comparator

        public Comparator<? super E> comparator​()
        说明从界面SortedSet复制
        返回用于为了在这个组中的元素，或比较null如果这个集使用natural ordering的元素。
        Specified by:
        comparator在接口 SortedSet<E>
        结果
        比较器用于对该集合中的元素进行排序，如果此集合使用其元素的自然排序， null

      • first

        public E first​()
        说明从界面SortedSet复制
        返回此集合中当前的第一个（最低）元素。
        Specified by:
        first在接口 SortedSet<E>
        结果
        当前在这个集合中的第一（最低）元素
        异常
        NoSuchElementException - 如果此设置为空

      • last

        public E last​()
        说明从界面SortedSet复制
        返回此集合中当前的最后（最高）元素。
        Specified by:
        last在接口 SortedSet<E>
        结果
        当前在此集合中的最后（最高）元素
        异常
        NoSuchElementException - 如果此设置为空

      • subSet

        public NavigableSet<E> subSet​(E fromElement,
                              boolean fromInclusive,
                              E toElement,
                              boolean toInclusive)
        描述从接口NavigableSet复制
        返回此集合的部分的视图，其元素的范围从fromElement到toElement 。 如果fromElement和toElement相等，则返回的集合为空，除非fromInclusive和toInclusive都为真。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        Specified by:
        subSet在接口 NavigableSet<E>
        参数
        fromElement - 返回集合的低端点
        fromInclusive - true如果低端点要包含在返回的视图中
        toElement - 返回集合的高端点
        toInclusive - true如果 true高端点包含在返回视图中
        结果
        该集合的部分视图的元素范围从 fromElement （含）到 toElement ，独占
        异常
        ClassCastException - 如果fromElement和toElement不能使用该集合的比较器彼此进行比较（或者如果该集合没有比较器，则使用自然排序）。 如果fromElement或toElement无法与当前在集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement或 toElement为null
        IllegalArgumentException - 如果fromElement大于toElement ; 或者如果此设置本身具有限制范围，并且fromElement或toElement位于范围的范围之外。

      • headSet

        public NavigableSet<E> headSet​(E toElement,
                               boolean inclusive)
        描述从接口NavigableSet复制
        返回此集合的部分的视图，其元素小于（或等于，如果inclusive为真） toElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        Specified by:
        headSet在接口 NavigableSet<E>
        参数
        toElement - 返回集合的高端点
        inclusive - true如果高端点要包含在返回视图中
        结果
        元素小于（或等于，如果为 inclusive为真）的该集合的部分的视图） toElement
        异常
        ClassCastException - 如果toElement与该组比较器不兼容（或者如果该集合没有比较器，如果toElement不实现Comparable ）。 如果toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toElement为空
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 toElement位于范围的边界之外

      • tailSet

        public NavigableSet<E> tailSet​(E fromElement,
                               boolean inclusive)
        描述从接口NavigableSet复制
        返回此集合的部分的视图，其元素大于（或等于，如果inclusive为真） fromElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图将一个元素插入其范围之外。

        Specified by:
        tailSet在接口 NavigableSet<E>
        参数
        fromElement - 返回集合的低端点
        inclusive - true如果低端点要包含在返回的视图中
        结果
        该集合的部分的视图，其元素大于或等于 fromElement
        异常
        ClassCastException - 如果fromElement与此组比较器不兼容（或如果该组没有比较器，如果fromElement不实现Comparable ）。 如果fromElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement为空
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 fromElement位于范围范围之外

      • subSet

        public NavigableSet<E> subSet​(E fromElement,
                              E toElement)
        说明从界面： NavigableSet复制
        返回该集合的部分的视图，其元素的范围从fromElement （含）到toElement ，排他。 （如果fromElement和toElement相等，则返回的集合为空。）返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        相当于subSet(fromElement, true, toElement, false) 。

        Specified by:
        subSet接口 NavigableSet<E>
        Specified by:
        subSet在接口 SortedSet<E>
        参数
        fromElement - 返回集合的低端点（含）
        toElement - 返回集合的高端点（独占）
        结果
        该集合的部分的视图，其元素的范围从 fromElement （含）到 toElement ，独占
        异常
        ClassCastException - 如果fromElement和toElement不能使用该集合的比较器彼此进行比较（或者如果该集合没有比较器，则使用自然排序）。 如果fromElement或toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement或 toElement为空
        IllegalArgumentException - 如果fromElement大于toElement ; 或者如果此设置本身具有限制范围，并且fromElement或toElement位于范围的范围之外

      • headSet

        public NavigableSet<E> headSet​(E toElement)
        说明从界面NavigableSet复制
        返回该集合的部分的视图，其元素严格小于toElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图将一个元素插入其范围之外。

        相当于headSet(toElement, false) 。

        Specified by:
        headSet在接口 NavigableSet<E>
        Specified by:
        headSet在接口 SortedSet<E>
        参数
        toElement - 返回集合的高端点（独占）
        结果
        该集合的部分的视图，其元素严格小于 toElement
        异常
        ClassCastException - 如果toElement与此设置的比较器不兼容（或者如果该集合没有比较器，则toElement不实现Comparable ）。 如果toElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 toElement为空
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 toElement位于范围范围之外

      • tailSet

        public NavigableSet<E> tailSet​(E fromElement)
        说明从接口NavigableSet复制
        返回该集合的部分的视图，该部分的元素大于或等于fromElement 。 返回的集合由此集合支持，因此返回集合中的更改将反映在此集合中，反之亦然。 返回的集合支持该集支持的所有可选集合操作。

        返回的集合将抛出一个IllegalArgumentException ，试图在其范围之外插入一个元素。

        相当于tailSet(fromElement, true) 。

        Specified by:
        tailSet在接口 NavigableSet<E>
        Specified by:
        tailSet在接口 SortedSet<E>
        参数
        fromElement - 返回集合的低端点（含）
        结果
        该集合的部分的视图，其元素大于或等于 fromElement
        异常
        ClassCastException - 如果fromElement与该组比较器不兼容（或者如果该集合没有比较器，则fromElement不实现Comparable ）。 如果fromElement无法与当前集合中的元素进行比较，则实施可能但不是必须抛出此异常。
        NullPointerException - 如果 fromElement为空
        IllegalArgumentException - 如果此设置本身具有限制范围，并且 fromElement位于范围的范围之外

      • descendingSet

        public NavigableSet<E> descendingSet​()
        返回此集合中包含的元素的反向排序视图。 下降集由此集合支持，因此对集合的更改反映在下降集中，反之亦然。

        返回的集合的订单等效于Collections.reverseOrder (comparator()) 。 表达s.descendingSet().descendingSet()返回一个视图的s实质上等同于s 。

        Specified by:
        descendingSet在接口 NavigableSet<E>
        结果
        这个集合的逆序视图

      • spliterator

        public Spliterator<E> spliterator​()
        返回此集合中的元素Spliterator 。

        该Spliterator报告Spliterator.CONCURRENT ， Spliterator.NONNULL ， Spliterator.DISTINCT ， Spliterator.SORTED和Spliterator.ORDERED ，与被升序的顺序相遇。 覆盖实现应记录其他特征值的报告。

        该spliterator的比较（见Spliterator.getComparator() ）是null如果设定的比较（见comparator() ）是null 。 否则，分配器的比较器与设置的比较器相同或者施加相同的总排序。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Specified by:
        spliterator在接口 Set<E>
        Specified by:
        spliterator在接口 SortedSet<E>
        结果
        一个 Spliterator在这个集合中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CopyOnWriteArrayList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class CopyOnWriteArrayList<E>

  • java.lang.Object
    • java.util.concurrent.CopyOnWriteArrayList<E>
  • 参数类型
    E - 该列表中保存的元素的类型
    All Implemented Interfaces:
    Serializable ， Cloneable ， Iterable<E> ， Collection<E> ， List<E> ， RandomAccess

    public class CopyOnWriteArrayList<E>
extends Object
implements List<E>, RandomAccess, Cloneable, Serializable
    的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。

    这通常是太昂贵的，但是当遍历操作大大超过突变时，可能比替代方法更有效，并且在不能或不想同步遍历时需要使用，但需要排除并发线程之间的干扰。 “快照”样式迭代器方法在创建迭代器的时候使用对数组状态的引用。 该数组在迭代器的生存期内永远不会改变，所以干扰是不可能的，迭代器保证不会抛出ConcurrentModificationException 。 自迭代器创建以来，迭代器将不会反映列表的添加，删除或更改。 元变化的迭代器操作本身（ remove ， set ，并add ）不被支持。 这些方法抛出UnsupportedOperationException 。

    允许所有元素，包括null 。

    内存一致性效果：与其他并发集合一样，在将对象放入CopyOnWriteArrayList happen-before之后的线程中的操作，随后从另一个线程中的CopyOnWriteArrayList访问或删除该元素。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CopyOnWriteArrayList​()
      创建一个空列表。
      CopyOnWriteArrayList​(E[] toCopyIn)
      创建一个包含给定数组的副本的列表。
      CopyOnWriteArrayList​(Collection<? extends E> c)
      按照集合的迭代器返回的顺序创建一个包含指定集合元素的列表。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(int index, E element)
      在此列表中的指定位置插入指定的元素。
      boolean add​(E e)
      将指定的元素追加到此列表的末尾。
      boolean addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中，从指定的位置开始。
      boolean addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到此列表的末尾。
      int addAllAbsent​(Collection<? extends E> c)
      将指定集合中尚未包含在此列表中的所有元素按指定集合的迭代器返回的顺序附加到此列表的末尾。
      boolean addIfAbsent​(E e)
      附加元素，如果不存在。
      void clear​()
      从列表中删除所有元素。
      Object clone​()
      返回此列表的浅层副本。
      boolean contains​(Object o)
      如果此列表包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> c)
      如果此列表包含指定集合的所有元素，则返回 true 。
      boolean equals​(Object o)
      将指定的对象与此列表进行比较以获得相等性。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。
      E get​(int index)
      返回此列表中指定位置的元素。
      int hashCode​()
      返回此列表的哈希码值。
      int indexOf​(E e, int index)
      返回此列表中指定元素的第一次出现的索引，从 index向前搜索，如果未找到该元素，则返回-1。
      int indexOf​(Object o)
      返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。
      boolean isEmpty​()
      如果此列表不包含元素，则返回 true 。
      Iterator<E> iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      int lastIndexOf​(E e, int index)
      返回此列表中指定元素的最后一次出现的索引，从 index向后搜索，如果未找到该元素，则返回-1。
      int lastIndexOf​(Object o)
      返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
      ListIterator<E> listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> listIterator​(int index)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
      E remove​(int index)
      删除该列表中指定位置的元素。
      boolean remove​(Object o)
      从列表中删除指定元素的第一个出现（如果存在）。
      boolean removeAll​(Collection<?> c)
      从此列表中删除指定集合中包含的所有元素。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      void replaceAll​(UnaryOperator<E> operator)
      将该列表的每个元素替换为将该运算符应用于该元素的结果。
      boolean retainAll​(Collection<?> c)
      仅保留此列表中包含在指定集合中的元素。
      E set​(int index, E element)
      用指定的元素替换此列表中指定位置的元素。
      int size​()
      返回此列表中的元素数。
      void sort​(Comparator<? super E> c)
      根据指定的Comparator引发的顺序排列此列表。
      Spliterator<E> spliterator​()
      返回此列表中的元素Spliterator 。
      List<E> subList​(int fromIndex, int toIndex)
      返回 fromIndex （含）和 toIndex之间的该列表部分的视图。
      Object[] toArray​()
      以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此列表的字符串表示形式。

      • Methods inherited from interface java.util.Collection

        parallelStream, stream

      • Methods inherited from interface java.util.List

        of, of, of, of, of, of, of, of, of, of, of, of

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CopyOnWriteArrayList

        public CopyOnWriteArrayList​()
        创建一个空列表。

      • CopyOnWriteArrayList

        public CopyOnWriteArrayList​(Collection<? extends E> c)
        按照集合的迭代器返回的顺序创建一个包含指定集合元素的列表。
        参数
        c - 初始持有的元素的收集
        异常
        NullPointerException - 如果指定的集合为空

      • CopyOnWriteArrayList

        public CopyOnWriteArrayList​(E[] toCopyIn)
        创建一个包含给定数组的副本的列表。
        参数
        toCopyIn - 数组（该数组的副本用作内部数组）
        异常
        NullPointerException - 如果指定的数组为空

    • 方法详细信息

      • size

        public int size​()
        返回此列表中的元素数。
        Specified by:
        size接口 Collection<E>
        Specified by:
        size在接口 List<E>
        结果
        此列表中的元素数

      • isEmpty

        public boolean isEmpty​()
        如果此列表不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        Specified by:
        isEmpty在接口 List<E>
        结果
        true如果此列表不包含元素

      • contains

        public boolean contains​(Object o)
        如果此列表包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此列表包含至少一个元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains接口 List<E>
        参数
        o - 要在此列表中存在的元素将被测试
        结果
        true如果此列表包含指定的元素

      • indexOf

        public int indexOf​(Object o)
        返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地，返回最低指数i ，使得Objects.equals(o, get(i)) ，或-1如果没有这样的索引。
        Specified by:
        indexOf在接口 List<E>
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的首次出现的索引，如果此列表不包含元素，则为-1

      • indexOf

        public int indexOf​(E e,
                   int index)
        返回此列表中指定元素的第一次出现的索引，从index搜索，如果未找到该元素，则返回-1。 更正式地说，返回指数最低i这样i >= index && Objects.equals(get(i), e) ，或-1，如果没有这样的指标。
        参数
        e - 要搜索的元素
        index - 开始搜索的索引
        结果
        该列表中第一次出现的位置的索引位于列表中的位置index或更高版本; -1如果没有找到该元素。
        异常
        IndexOutOfBoundsException - 如果指定的索引为负数

      • lastIndexOf

        public int lastIndexOf​(Object o)
        返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地说，返回满足i这样Objects.equals(o, get(i)) ，或-1，如果没有这样的指标。
        Specified by:
        lastIndexOf在接口 List<E>
        参数
        o - 要搜索的元素
        结果
        此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则为-1

      • lastIndexOf

        public int lastIndexOf​(E e,
                       int index)
        返回此列表中指定元素的最后一次出现的索引，从index向后搜索，如果未找到元素，则返回-1。 更正式地说，返回满足i这样i <= index && Objects.equals(get(i), e) ，或-1，如果没有这样的指标。
        参数
        e - 要搜索的元素
        index - 开始向后搜索的索引
        结果
        该列表中位置小于或等于index的元素的最后一次出现的索引; -1如果没有找到元素。
        异常
        IndexOutOfBoundsException - 如果指定的索引大于或等于此列表的当前大小

      • clone

        public Object clone​()
        返回此列表的浅层副本。 （元素本身不被复制。）
        重写：
        clone在 Object
        结果
        这个列表的克隆
        另请参见：
        Cloneable

      • toArray

        public Object[] toArray​()
        以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

        返回的数组将是“安全的”，因为该列表不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 List<E>
        结果
        一个包含此列表中所有元素的数组
        另请参见：
        Arrays.asList(Object[])

      • toArray

        public <T> T[] toArray​(T[] a)
        以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。 如果列表适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此列表的大小分配一个新数组。

        如果此列表适用于指定的数组， null空间（即，该数组具有比此列表更多的元素），紧接在列表末尾的数组中的元素将设置为null 。 （这仅在调用者知道此列表不包含任何空元素时才能确定此列表的长度）。

        像toArray()方法一样，此方法充当基于阵列和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的列表。 以下代码可用于将列表转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 List<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储列表的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此列表中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此列表中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • get

        public E get​(int index)
        返回此列表中指定位置的元素。
        Specified by:
        get在接口 List<E>
        参数
        index - 要返回的元素的索引
        结果
        该列表中指定位置的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • set

        public E set​(int index,
             E element)
        用指定的元素替换此列表中指定位置的元素。
        Specified by:
        set在接口 List<E>
        参数
        index - 要替换的元素的索引
        element - 要存储在指定位置的元素
        结果
        该元素以前在指定的位置
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • add

        public boolean add​(E e)
        将指定的元素追加到此列表的末尾。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 List<E>
        参数
        e - 要附加到此列表的元素
        结果
        true （由 Collection.add(E)指定）

      • add

        public void add​(int index,
                E element)
        在此列表中的指定位置插入指定的元素。 将当前位于该位置的元素（如果有）和任何后续元素（向其索引添加一个）移动。
        Specified by:
        add在接口 List<E>
        参数
        index - 要在其中插入指定元素的索引
        element - 要插入的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • remove

        public E remove​(int index)
        删除该列表中指定位置的元素。 将任何后续元素移动到左侧（从其索引中减去一个元素）。 返回从列表中删除的元素。
        Specified by:
        remove在接口 List<E>
        参数
        index - 要删除的元素的索引
        结果
        该元素以前在指定的位置
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • remove

        public boolean remove​(Object o)
        从列表中删除指定元素的第一个出现（如果存在）。 如果此列表不包含该元素，则它将保持不变。 更正式地，删除具有最低索引i的元素，使得Objects.equals(o, get(i)) （如果这样的元素存在）。 如果此列表包含指定的元素（或等效地，如果此列表作为调用的结果而更改），则返回true 。
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 List<E>
        参数
        o - 要从此列表中删除的元素（如果存在）
        结果
        true如果此列表包含指定的元素

      • addIfAbsent

        public boolean addIfAbsent​(E e)
        附加元素，如果不存在。
        参数
        e - 要添加到此列表的元素，如果不存在
        结果
        如果添加元素， true

      • containsAll

        public boolean containsAll​(Collection<?> c)
        如果此列表包含指定集合的所有元素，则返回 true 。
        Specified by:
        containsAll在接口 Collection<E>
        Specified by:
        containsAll在接口 List<E>
        参数
        c - 要在此列表中检查遏制的集合
        结果
        true如果此列表包含指定集合的所有元素
        异常
        NullPointerException - 如果指定的集合为空
        另请参见：
        contains(Object)

      • removeAll

        public boolean removeAll​(Collection<?> c)
        从此列表中删除指定集合中包含的所有元素。 这是一个特别昂贵的操作，因为需要一个内部的临时数组。
        Specified by:
        removeAll在接口 Collection<E>
        Specified by:
        removeAll在接口 List<E>
        参数
        c - 包含要从此列表中删除的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        ClassCastException - 如果此列表的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此列表包含空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        仅保留此列表中包含在指定集合中的元素。 换句话说，从此列表中删除其中不包含在指定集合中的所有元素。
        Specified by:
        retainAll在接口 Collection<E>
        Specified by:
        retainAll在接口 List<E>
        参数
        c - 包含要保留在此列表中的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        ClassCastException - 如果此列表的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此列表包含空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object)

      • addAllAbsent

        public int addAllAbsent​(Collection<? extends E> c)
        将指定集合中尚未包含在此列表中的所有元素按指定集合的迭代器返回的顺序附加到此列表的末尾。
        参数
        c - 包含要添加到此列表中的元素的集合
        结果
        添加的元素数量
        异常
        NullPointerException - 如果指定的集合为空
        另请参见：
        addIfAbsent(Object)

      • clear

        public void clear​()
        从列表中删除所有元素。 此呼叫返回后，列表将为空。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 List<E>

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到此列表的末尾。
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll接口 List<E>
        参数
        c - 包含要添加到此列表中的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        NullPointerException - 如果指定的集合为空
        另请参见：
        add(Object)

      • addAll

        public boolean addAll​(int index,
                      Collection<? extends E> c)
        将指定集合中的所有元素插入到此列表中，从指定的位置开始。 将当前位于该位置（如果有的话）的元素和随后的任何元素移动到右边（增加其索引）。 新元素将按照指定集合的迭代器返回的顺序显示在此列表中。
        Specified by:
        addAll在接口 List<E>
        参数
        index - 从指定集合插入第一个元素的索引
        c - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改
        异常
        IndexOutOfBoundsException - 如果指数超出范围（ index < 0 || index > size() ）
        NullPointerException - 如果指定的集合为空
        另请参见：
        add(int,Object)

      • forEach

        public void forEach​(Consumer<? super E> action)
        描述从接口Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要对每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        说明从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 一个谓词，为要删除的元素返回 true
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • replaceAll

        public void replaceAll​(UnaryOperator<E> operator)
        说明从界面List复制
        将该列表的每个元素替换为将该运算符应用于该元素的结果。 运营商抛出的错误或运行时异常被转发给呼叫者。
        Specified by:
        replaceAll在接口 List<E>
        参数
        operator - 操作员应用于每个元素

      • sort

        public void sort​(Comparator<? super E> c)
        说明从界面List复制
        根据指定的Comparator引发的顺序排列此列表。

        该列表中的所有元素必须使用指定的比较器相互比较（即， c.compare(e1, e2)不得为ClassCastException中的任何元素e1和e2抛出ClassCastException ）。

        如果指定的比较器是null则该列表中的所有元素都必须实现Comparable接口，并应使用元素' natural ordering '。

        该列表必须是可修改的，但不能调整大小。

        Specified by:
        sort在接口 List<E>
        参数
        c - 用于比较列表元素的Comparator 。 A null值表示应使用元素' natural ordering '

      • toString

        public String toString​()
        返回此列表的字符串表示形式。 字符串表示由列表元素的字符串表示形式组成，按照它们由迭代器返回的顺序，包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 Object
        结果
        此列表的字符串表示形式

      • equals

        public boolean equals​(Object o)
        将指定的对象与此列表进行比较以获得相等性。 如果指定的对象与此对象相同，则返回true ，或者如果它也是一个List，并且iterator在指定列表上返回的元素序列与迭代器在此列表上返回的序列相同。 如果两个序列具有相同的长度，并且序列中相同位置的相应元素相等，则认为这两个序列是相同的 。 两个元素e1和e2被认为是如果相等 Objects.equals(e1, e2) 。
        Specified by:
        equals在接口 Collection<E>
        Specified by:
        equals在接口 List<E>
        重写：
        equals在 Object
        参数
        o - 要与此列表相等的对象进行比较
        结果
        如果指定的对象等于此列表， true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此列表的哈希码值。

        此实现使用List.hashCode()中的定义。

        Specified by:
        hashCode在接口 Collection<E>
        Specified by:
        hashCode在接口 List<E>
        重写：
        hashCode在 Object
        结果
        该列表的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回该列表中的元素的迭代器。

        返回的迭代器在构建迭代器时提供列表状态的快照。 遍历迭代器时不需要同步。 该迭代器不支持remove方法。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator接口 List<E>
        结果
        在这个列表中的元素以适当的顺序迭代

      • listIterator

        public ListIterator<E> listIterator​()
        返回列表中的列表迭代器（按适当的顺序）。

        返回的迭代器在构建迭代器时提供列表状态的快照。 遍历迭代器时不需要同步。 该迭代器不支持remove ， set或者add方法。

        Specified by:
        listIterator在接口 List<E>
        结果
        在列表中的元素的列表迭代器（按适当的顺序）

      • listIterator

        public ListIterator<E> listIterator​(int index)
        从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。 指定的索引指示由初始调用next返回的第一个元素。 初始调用previous将返回具有指定索引的元素减1。

        返回的迭代器在构建迭代器时提供列表状态的快照。 遍历迭代器时不需要同步。 该迭代器不支持remove ， set或者add方法。

        Specified by:
        listIterator在接口 List<E>
        参数
        index - 从列表迭代器返回的第一个元素的索引（通过调用 next ）
        结果
        在列表中的元素（按正确顺序）的列表迭代器，从列表中的指定位置开始
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index > size() ）

      • spliterator

        public Spliterator<E> spliterator​()
        返回此列表中的元素Spliterator 。

        该Spliterator报告Spliterator.IMMUTABLE ， Spliterator.ORDERED ， Spliterator.SIZED ，并Spliterator.SUBSIZED 。

        拼接器在构建拼接器时提供列表状态的快照。 在拼接器上操作时不需要同步。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Specified by:
        spliterator在接口 List<E>
        结果
        一个 Spliterator在这个列表中的元素
        从以下版本开始：
        1.8

      • subList

        public List<E> subList​(int fromIndex,
                       int toIndex)
        返回fromIndex （含）和toIndex之间的列表部分的视图。 返回的列表由此列表支持，因此返回的列表中的更改将反映在此列表中。

        如果支持列表（即，此列表）以除返回列表之外的任何方式进行修改，则此方法返回的列表的语义将变为未定义。

        Specified by:
        subList在接口 List<E>
        参数
        fromIndex - 子列表的低端点（含）
        toIndex - 子列表的高端点（排他）
        结果
        该列表中指定范围的视图
        异常
        IndexOutOfBoundsException - 对于非法端点索引值（ fromIndex < 0 || toIndex > size || fromIndex > toIndex ）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CopyOnWriteArraySet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class CopyOnWriteArraySet<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractSet<E>
        • java.util.concurrent.CopyOnWriteArraySet<E>
  • 参数类型
    E - 该集合中保存的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， Set<E>

    public class CopyOnWriteArraySet<E>
extends AbstractSet<E>
implements Serializable
    A Set 对其所有操作使用内部CopyOnWriteArrayList 。 因此，它具有相同的基本属性：
    • 它最适合于集合大小通常保持较小，只读操作大大超过突变操作的应用程序，并且您需要防止遍历期间线程之间的干扰。
    • 它是线程安全的。
    • 可变操作（ add ， set ， remove等）是昂贵的，因为它们通常意味着复制整个底层数组。
    • 迭代器不支持突变remove操作。
    • 遍历遍历迭代器是快速的，不能遇到来自其他线程的干扰。 迭代器构建时迭代器依赖于数组的不变快照。

    样品用法。 以下代码草图使用写时复制集来维护在状态更新时执行某些操作的一组Handler对象。

       class Handler { void handle(); ... } class X { private final CopyOnWriteArraySet<Handler> handlers = new CopyOnWriteArraySet<>(); public void addHandler(Handler h) { handlers.add(h); } private long internalState; private synchronized void changeState() { internalState = ...; } public void update() { changeState(); for (Handler handler : handlers) handler.handle(); } }

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.5
    另请参见：
    CopyOnWriteArrayList ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CopyOnWriteArraySet​()
      创建一个空集。
      CopyOnWriteArraySet​(Collection<? extends E> c)
      创建一个包含指定集合的所有元素的集合。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素添加到此集合（如果尚未存在）。
      boolean addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合（如果它们尚未存在）。
      void clear​()
      从此集合中删除所有元素。
      boolean contains​(Object o)
      如果此集合包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> c)
      如果此集合包含指定集合的所有元素，则返回 true 。
      boolean equals​(Object o)
      将指定的对象与此集合进行比较以实现相等。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。
      boolean isEmpty​()
      如果此集合不包含元素，则返回 true 。
      Iterator<E> iterator​()
      按照添加这些元素的顺序返回此集合中包含的元素的迭代器。
      boolean remove​(Object o)
      如果存在，则从该集合中删除指定的元素。
      boolean removeAll​(Collection<?> c)
      从此集合中删除指定集合中包含的所有元素。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      boolean retainAll​(Collection<?> c)
      仅保留该集合中包含在指定集合中的元素。
      int size​()
      返回此集合中的元素数。
      Spliterator<E> spliterator​()
      按照添加这些元素的顺序返回此集合中元素的Spliterator 。
      Object[] toArray​()
      返回一个包含此集合中所有元素的数组。
      <T> T[] toArray​(T[] a)
      返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

      • Methods inherited from class java.util.AbstractCollection

        toString

      • Methods inherited from class java.util.AbstractSet

        hashCode

      • Methods inherited from interface java.util.Collection

        parallelStream, stream

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Set

        of, of, of, of, of, of, of, of, of, of, of, of

    • 构造方法详细信息

      • CopyOnWriteArraySet

        public CopyOnWriteArraySet​()
        创建一个空集。

      • CopyOnWriteArraySet

        public CopyOnWriteArraySet​(Collection<? extends E> c)
        创建一个包含指定集合的所有元素的集合。
        参数
        c - 最初包含的元素的集合
        异常
        NullPointerException - 如果指定的集合为空

    • 方法详细信息

      • size

        public int size​()
        返回此集合中的元素数。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Set<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        该集合中的元素数量

      • isEmpty

        public boolean isEmpty​()
        如果此集合不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        Specified by:
        isEmpty在接口 Set<E>
        重写：
        isEmpty类 AbstractCollection<E>
        结果
        true如果这个集合不包含元素

      • contains

        public boolean contains​(Object o)
        如果此集合包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此set包含的元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Set<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要在此集合中存在的元素要进行测试
        结果
        true如果此集合包含指定的元素

      • toArray

        public Object[] toArray​()
        返回一个包含此集合中所有元素的数组。 如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        返回的数组将是“安全的”，因为该集合不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组，即使这个数组是由数组支持的）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 Set<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此集合中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果集合适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此集合的大小分配一个新数组。

        如果这个集合适合指定的数组，有空余的空间（即，该数组的元素多于此集合），紧接在该集合结束后的数组中的元素将设置为null 。 （这仅在调用者知道此集合不包含任何空元素时才可用于确定此集合的长度。）

        如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的集合。 以下代码可用于将集合转储为新分配的String数组：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 Set<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储此集合的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此集合中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此集合中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • clear

        public void clear​()
        从此集合中删除所有元素。 此呼叫返回后，该组将为空。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 Set<E>
        重写：
        clear在 AbstractCollection<E>

      • remove

        public boolean remove​(Object o)
        如果存在，则从该集合中删除指定的元素。 更正式地，删除元素e ，使得Objects.equals(o, e) ，如果这个集合包含这样的元素。 如果此集合包含元素（或等效地，如果此集合作为调用的结果而更改），则返回true 。 （一旦调用返回，此集合将不包含该元素。）
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 Set<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从该集合中删除的对象（如果存在）
        结果
        true如果这个集合包含指定的元素

      • add

        public boolean add​(E e)
        将指定的元素添加到此集合（如果尚未存在）。 更正式地，将指定的元素e这一套如果集合不包含元素e2这样Objects.equals(e, e2) 。 如果该集合已经包含该元素，则该呼叫将保持不变，并返回false 。
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Set<E>
        重写：
        add在 AbstractCollection<E>
        参数
        e - 要添加到此集合的元素
        结果
        true如果此集合尚未包含指定的元素

      • containsAll

        public boolean containsAll​(Collection<?> c)
        如果此集合包含指定集合的所有元素，则返回true 。 如果指定的集合也是集合，则该方法返回true如果它是该集合的子集。
        Specified by:
        containsAll在接口 Collection<E>
        Specified by:
        containsAll在接口 Set<E>
        重写：
        containsAll在 AbstractCollection<E>
        参数
        c - 要在此集合中检查收集的集合
        结果
        true如果此集合包含指定集合的所有元素
        异常
        NullPointerException - 如果指定的集合为空
        另请参见：
        contains(Object)

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        将指定集合中的所有元素添加到此集合（如果它们尚未存在）。 如果指定的集合也是集合，则addAll操作有效地修改该集合，使其值是两个集合的并集。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 Set<E>
        重写：
        addAll AbstractCollection<E>
        参数
        c - 包含要添加到此集合的元素的集合
        结果
        true如果此设置由于调用而更改
        异常
        NullPointerException - 如果指定的集合为空
        另请参见：
        add(Object)

      • removeAll

        public boolean removeAll​(Collection<?> c)
        从此集合中删除指定集合中包含的所有元素。 如果指定的集合也是集合，则该操作有效地修改该集合，使其值是两组的非对称集合差异 。
        Specified by:
        removeAll在接口 Collection<E>
        Specified by:
        removeAll在接口 Set<E>
        重写：
        removeAll在 AbstractSet<E>
        参数
        c - 包含要 c集合中删除的元素的集合
        结果
        true如果此设置由于呼叫而更改
        异常
        ClassCastException - 如果此集合的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此集合包含一个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        仅保留该集合中包含在指定集合中的元素。 换句话说，从这个集合中删除它不包含在指定集合中的所有元素。 如果指定的集合也是一个集合，则此操作有效地修改该集合，使其值是两组的交集 。
        Specified by:
        retainAll在接口 Collection<E>
        Specified by:
        retainAll在接口 Set<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果此设置由于调用而更改
        异常
        ClassCastException - 如果此集合的元素的类与指定的集合不兼容（ optional ）
        NullPointerException - 如果此集合包含空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        remove(Object)

      • iterator

        public Iterator<E> iterator​()
        按照添加这些元素的顺序返回此集合中包含的元素的迭代器。

        返回的迭代器在构建迭代器时提供集合的状态的快照。 遍历迭代器时不需要同步。 该迭代器不支持remove方法。

        Specified by:
        iterator接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator接口 Set<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        这个集合中的元素的迭代器

      • equals

        public boolean equals​(Object o)
        将指定的对象与此集合进行比较以实现相等。 如果指定的对象与该对象相同，则返回true ，或者如果它也是一个Set，并且由指定集合上的iterator返回的元素与迭代器在此集合上返回的元素相同。 更正式地，如果两个迭代器返回相同数量的元素，并且对于迭代器在指定集合上返回的每个元素e1 ，则这两个迭代器被认为返回相同的元素，则迭代器在该集合上返回的元素为e2 ，使得Objects.equals(e1, e2) 。
        Specified by:
        equals在接口 Collection<E>
        Specified by:
        equals在接口 Set<E>
        重写：
        equals在 AbstractSet<E>
        参数
        o - 要与该集合相等的对象
        结果
        true如果指定的对象等于此集合
        另请参见：
        Object.hashCode() ， HashMap

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        描述从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 一个谓词，为要删除的元素返回 true
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • forEach

        public void forEach​(Consumer<? super E> action)
        描述从接口Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要对每个元素执行的操作
        异常
        NullPointerException - 如果指定的动作为空

      • spliterator

        public Spliterator<E> spliterator​()
        以这些元素的添加顺序返回此集合中的元素Spliterator 。

        该Spliterator报告Spliterator.IMMUTABLE ， Spliterator.DISTINCT ， Spliterator.SIZED ，并Spliterator.SUBSIZED 。

        拼接器在构建拼接器时提供该集合的状态的快照。 在拼接器上操作时不需要同步。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Specified by:
        spliterator在接口 Set<E>
        结果
        一个 Spliterator在这个集合中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CountDownLatch (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class CountDownLatch

  • java.lang.Object
    • java.util.concurrent.CountDownLatch

  • public class CountDownLatch
extends Object
    允许一个或多个线程等待直到在其他线程中执行的一组操作完成的同步辅助。

    A CountDownLatch用给定的计数初始化。 await方法阻塞，直到由于调用countDown()方法，当前计数达到零，此后所有等待线程被释放，并且任何后续的调用await立即返回。 这是一个一次性的现象 - 计数无法重置。 如果您需要重置计数的版本，请考虑使用CyclicBarrier 。

    A CountDownLatch是一种通用的同步工具，可用于多种用途。 用CountDownLatch初始化的CountDownLatch用作简单的开/关锁存器，或者门：所有线程调用await在门口等待，直到被调用countDown()的线程打开 。 一个初始化为N的CountDownLatch可以用来使一个线程等待直到N个线程完成一些动作，或者一些动作已经完成N次。

    CountDownLatch一个有用的属性是，它不需要线程调用countDown等待计数到达零，然后继续，它只是阻止任何线程通过await，直到所有线程可以通过。

    示例用法：这是一组类，其中一组工作线程使用两个倒计时锁存器：

    • 第一个是启动信号，防止任何工作人员进入，直到驾驶员准备好继续前进;
    • 第二个是完成信号，允许司机等到所有的工作人员完成。
       class Driver { // ... void main() throws InterruptedException { CountDownLatch startSignal = new CountDownLatch(1); CountDownLatch doneSignal = new CountDownLatch(N); for (int i = 0; i < N; ++i) // create and start threads new Thread(new Worker(startSignal, doneSignal)).start(); doSomethingElse(); // don't let run yet startSignal.countDown(); // let all threads proceed doSomethingElse(); doneSignal.await(); // wait for all to finish } } class Worker implements Runnable { private final CountDownLatch startSignal; private final CountDownLatch doneSignal; Worker(CountDownLatch startSignal, CountDownLatch doneSignal) { this.startSignal = startSignal; this.doneSignal = doneSignal; } public void run() { try { startSignal.await(); doWork(); doneSignal.countDown(); } catch (InterruptedException ex) {} // return; } void doWork() { ... } }

    另一个典型的用法是将问题划分为N个部分，用一个Runnable来描述每个部分，该Runnable执行该部分并在锁存器上倒计时，并将所有Runnables排队到执行器。 当所有子部件完成时，协调线程将能够通过等待。 （当线程必须以这种方式反复倒数时，请改用CyclicBarrier。 ）

       class Driver2 { // ... void main() throws InterruptedException { CountDownLatch doneSignal = new CountDownLatch(N); Executor e = ... for (int i = 0; i < N; ++i) // create and start threads e.execute(new WorkerRunnable(doneSignal, i)); doneSignal.await(); // wait for all to finish } } class WorkerRunnable implements Runnable { private final CountDownLatch doneSignal; private final int i; WorkerRunnable(CountDownLatch doneSignal, int i) { this.doneSignal = doneSignal; this.i = i; } public void run() { try { doWork(i); doneSignal.countDown(); } catch (InterruptedException ex) {} // return; } void doWork() { ... } }

    内存一致性效果：直到计数调用之前达到零，在一个线程操作countDown() happen-before下从相应的成功返回行动await()在另一个线程。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      CountDownLatch​(int count)
      构造一个以给定计数初始化的 CountDownLatch 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void await​()
      导致当前线程等到锁存器向下计数为零，除非线程为 interrupted 。
      boolean await​(long timeout, TimeUnit unit)
      使当前线程等待直到锁存器计数到零为止，除非线程为 interrupted ，否则指定的等待时间已过。
      void countDown​()
      减少锁存器的计数，如果计数达到零，释放所有等待的线程。
      long getCount​()
      返回当前计数。
      String toString​()
      返回一个标识此锁存器的字符串及其状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CountDownLatch

        public CountDownLatch​(int count)
        构造一个以给定计数初始化的 CountDownLatch 。
        参数
        count -的次数 countDown()前线程可以通过必须调用 await()
        异常
        IllegalArgumentException - 如果 count为负数

    • 方法详细信息

      • await

        public void await​()
           throws InterruptedException
        导致当前线程等到锁存器计数到零，除非线程是interrupted 。

        如果当前计数为零，则此方法立即返回。

        如果当前计数大于零，则当前线程将被禁用以进行线程调度，并处于休眠状态，直至发生两件事情之一：

        • 由于调用了countDown()方法，计数达到零; 要么
        • 一些其他线程interrupts当前线程。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是等待interrupted ，
        那么抛出InterruptedException并清除当前线程的中断状态。
        异常
        InterruptedException - 如果当前线程在等待时中断

      • await

        public boolean await​(long timeout,
                     TimeUnit unit)
              throws InterruptedException
        导致当前线程等到锁存器向下计数到零，除非线程为interrupted或指定的等待时间过去。

        如果当前计数为零，则该方法将立即返回值为true 。

        如果当前计数大于零，则当前线程将被禁用以进行线程调度，并处于休眠状态，直至发生三件事情之一：

        • 由于调用了countDown()方法，计数达到零; 要么
        • 一些其他线程interrupts当前线程; 要么
        • 指定的等待时间过去了。

        如果计数达到零，则方法返回值为true 。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted等待，
        那么抛出InterruptedException并清除当前线程的中断状态。

        如果指定的等待时间过去，则返回值false 。 如果时间小于或等于零，该方法根本不会等待。

        参数
        timeout - 等待的最长时间
        unit - timeout参数的时间单位
        结果
        true如果计数达到零和 false如果在计数达到零之前经过的等待时间
        异常
        InterruptedException - 如果当前线程在等待时中断

      • countDown

        public void countDown​()
        减少锁存器的计数，如果计数达到零，释放所有等待的线程。

        如果当前计数大于零，则它将递减。 如果新计数为零，则所有等待的线程都将被重新启用以进行线程调度。

        如果当前计数等于零，那么没有任何反应。

      • getCount

        public long getCount​()
        返回当前计数。

        该方法通常用于调试和测试。

        结果
        当前计数

      • toString

        public String toString​()
        返回一个标识此锁存器的字符串及其状态。 括号中的状态包括字符串"Count ="后跟当前计数。
        重写：
        toString在 Object
        结果
        识别此锁存器的字符串以及其状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CountedCompleter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class CountedCompleter<T>

  • java.lang.Object
    • java.util.concurrent.ForkJoinTask<T>
      • java.util.concurrent.CountedCompleter<T>
  • All Implemented Interfaces:
    Serializable ， Future<T>

    public abstract class CountedCompleter<T>
extends ForkJoinTask<T>
    A ForkJoinTask ，其触发时执行完成操作，并且没有剩余的待处理操作。 CountedCompleters通常比其他形式的ForkJoinTasks在子任务停顿和阻塞的情况下更加强大，但是不太直观的编程。 CountedCompleter的用途类似于其他基于完成部件（如CompletionHandler ），除了多个挂起完井可能是必要的，以触发完成动作onCompletion(CountedCompleter) ，不只是一个。 除非另有初始化， pending count开始于零，但也可以是（原子），使用方法改变setPendingCount(int) ， addToPendingCount(int) ，和compareAndSetPendingCount(int, int) 。 在调用tryComplete()后 ，如果待处理的行动计数不为零，则递减; 否则，执行完成操作，如果完成者本身具有完整性，则该过程将继续完成。 与Phaser和Semaphore相关的同步组件一样，这些方法仅影响内部计数; 他们没有建立任何进一步的内部簿记。 特别地，未维护未决任务的身份。 如下所示，您可以创建在需要时记录一些或所有待处理任务或其结果的子类。 如下所示，还提供了支持定制完成遍历的实用程序方法。 然而，由于CountedCompleters仅提供基本的同步机制，因此创建进一步的抽象子类可能是有用的，这些子类保持适用于一组相关用法的链接，字段和其他支持方法。

    具体的CountedCompleter类必须定义方法compute() ，在大多数情况下（如下所示），在返回之前调用tryComplete()一次。 该类还可以可选地覆盖方法onCompletion(CountedCompleter)以在正常完成时执行动作，以及方法onExceptionalCompletion(Throwable, CountedCompleter)以对任何异常执行动作。

    CountedCompleter通常不承担结果，在这种情况下，它们通常被声明为CountedCompleter<Void> ，并将始终返回null作为结果值。 在其他情况下，你应该重写方法getRawResult()提供从结果join(), invoke() ，以及相关方法。 一般来说，该方法应该返回在完成后保存结果的CountedCompleter对象的一个字段（或一个或多个字段的函数）的值。 默认方法setRawResult(T)在CountedCompleters中不起作用。 可能但很少适用于覆盖此方法来维护其他对象或保存结果数据的字段。

    一个CountedCompleter本身不具有一个完整的（即getCompleter()返回null ）可以用作这个添加功能的常规ForkJoinTask。 然而，任何完成者又具有另一个完成者只能作为其他计算的内部帮助器，因此其自己的任务状态（如方法如ForkJoinTask.isDone()所报告）是任意的; 这种状况只有在明确调用改变complete(T) ， ForkJoinTask.cancel(boolean) ， ForkJoinTask.completeExceptionally(Throwable)或方法的特殊结束后compute 。 在任何异常完成之后，如果有任何异常可能会被传递到任务的完成者（以及其完成者等），如果存在并且尚未完成。 同样地，取消一个内部的CountedCompleter只对该完成者有局部的影响，所以并不常用。

    示例用法

    并行递归分解。 CountedCompleters可以安排在类似于RecursiveAction中经常使用的树中，尽管与设置相关的构造通常是不同的。 这里，每个任务的完成者是其计算树中的父项。 即使它们需要更多的簿记，CountedCompleters可能是更好的选择，当应用可能耗时的操作（不能进一步细分）到数组或集合的每个元素; 特别是当操作对于一些元素的时间要比其他元素完成时要多得多，这是因为内在的变化（例如I / O）或诸如垃圾收集的辅助效应。 由于CountedCompleters提供自己的延续，其他任务不需要阻止等待执行它们。

    例如，这里是一个实用方法的初始版本，它使用二分法递归分解将工作分成单个部分（叶子任务）。 即使将工作分解为单独的调用，基于树的技术通常比直接分支叶子任务更为可取，因为它们可以减少线程间通信并改善负载平衡。 在递归的情况下，要完成的每对子任务对的第二个触发器完成它们的父onCompletion （因为没有执行结果组合，所以方法onCompletion的默认的无操作实现不被覆盖）。 实用程序方法设置根任务并调用它（这里隐式使用ForkJoinPool.commonPool() ）。 始终将挂起的计数设置为子任务的数量是直接可靠的（但不是最佳的），并在返回之前立即调用tryComplete() 。

       public static <E> void forEach(E[] array, Consumer<E> action) { class Task extends CountedCompleter<Void> { final int lo, hi; Task(Task parent, int lo, int hi) { super(parent); this.lo = lo; this.hi = hi; } public void compute() { if (hi - lo >= 2) { int mid = (lo + hi) >>> 1; // must set pending count before fork setPendingCount(2); new Task(this, mid, hi).fork(); // right child new Task(this, lo, mid).fork(); // left child } else if (hi > lo) action.accept(array[lo]); tryComplete(); } } new Task(null, 0, array.length).invoke(); }
    通过注意到在递归的情况下，该任务在分配正确的任务后无关，因此可以在返回之前直接调用其左任务，从而可以改善此设计。 （这是一个尾递归删除的模拟方法。）而且，当任务中的最后一个动作是分支或调用子任务（“尾呼”）时，可以调用tryComplete() ， tryComplete()造成待定数量看“一个”。
       public void compute() { if (hi - lo >= 2) { int mid = (lo + hi) >>> 1; setPendingCount(1); // looks off by one, but correct! new Task(this, mid, hi).fork(); // right child new Task(this, lo, mid).compute(); // direct invoke } else { if (hi > lo) action.accept(array[lo]); tryComplete(); } }
    作为进一步优化，请注意，左侧任务不需要甚至不存在。 而不是创建一个新的，我们可以继续使用原始任务，并为每个fork添加一个挂起的计数。 另外，因为这个树中的任务没有实现一个onCompletion(CountedCompleter)的方法， tryComplete可以替换为propagateCompletion() 。
       public void compute() { int n = hi - lo; for (; n >= 2; n /= 2) { addToPendingCount(1); new Task(this, lo + n/2, lo + n).fork(); } if (n > 0) action.accept(array[lo]); propagateCompletion(); }
    当待计数可以预先计算时，可以在构造函数中建立它们：
       public static <E> void forEach(E[] array, Consumer<E> action) { class Task extends CountedCompleter<Void> { final int lo, hi; Task(Task parent, int lo, int hi) { super(parent, 31 - Integer.numberOfLeadingZeros(hi - lo)); this.lo = lo; this.hi = hi; } public void compute() { for (int n = hi - lo; n >= 2; n /= 2) new Task(this, lo + n/2, lo + n).fork(); action.accept(array[lo]); propagateCompletion(); } } if (array.length > 0) new Task(null, 0, array.length).invoke(); }
    这些类的其他优化可能需要专门为叶子步骤进行分类，除以四，而不是每次迭代两次，并使用自适应阈值，而不是总是细分为单个元素。

    搜索。 CountedCompleters的树可以在数据结构的不同部分搜索一个值或属性，一旦找到结果，就会在AtomicReference中报告结果。 其他人可以轮询结果，以避免不必要的工作。 （您可以另外添加cancel其他任务，但通常只需让他们注意到结果被设置，并且如果是这样，则进一步处理）通常更简单和更有效。）再次使用完全分区（再次实际上，叶子任务）几乎总是处理多个元素）：

       class Searcher<E> extends CountedCompleter<E> { final E[] array; final AtomicReference<E> result; final int lo, hi; Searcher(CountedCompleter<?> p, E[] array, AtomicReference<E> result, int lo, int hi) { super(p); this.array = array; this.result = result; this.lo = lo; this.hi = hi; } public E getRawResult() { return result.get(); } public void compute() { // similar to ForEach version 3 int l = lo, h = hi; while (result.get() == null && h >= l) { if (h - l >= 2) { int mid = (l + h) >>> 1; addToPendingCount(1); new Searcher(this, array, result, mid, h).fork(); h = mid; } else { E x = array[l]; if (matches(x) && result.compareAndSet(null, x)) quietlyCompleteRoot(); // root task is now joinable break; } } tryComplete(); // normally complete whether or not found } boolean matches(E e) { ... } // return true if found public static <E> E search(E[] array) { return new Searcher<E>(null, array, new AtomicReference<E>(), 0, array.length).invoke(); } }
    在这个例子中，以及除了compareAndSet以外的其他任务的其他任务，通常的结果是tryComplete无条件调用可以作为条件（ if (result.get() == null) tryComplete(); ），因为一旦根任务完成，就不需要进一步的簿记管理完成。

    记录子任务 CountedCompleter任务组合多个子任务的结果通常需要访问这些结果方法onCompletion(CountedCompleter) 。 如下面的类所示（执行map-reduce的简化形式，其中映射和缩减都是类型为E ），分割和征服设计的一种方法是使每个子任务记录成为兄弟，以便它可以可以在方法onCompletion访问。 这种技术适用于结合左和右结果的顺序无关紧要的减少; 有序减少需要明确的左/右指定。 上述示例中可以看到其他流程图的变体。

       class MyMapper<E> { E apply(E v) { ... } } class MyReducer<E> { E apply(E x, E y) { ... } } class MapReducer<E> extends CountedCompleter<E> { final E[] array; final MyMapper<E> mapper; final MyReducer<E> reducer; final int lo, hi; MapReducer<E> sibling; E result; MapReducer(CountedCompleter<?> p, E[] array, MyMapper<E> mapper, MyReducer<E> reducer, int lo, int hi) { super(p); this.array = array; this.mapper = mapper; this.reducer = reducer; this.lo = lo; this.hi = hi; } public void compute() { if (hi - lo >= 2) { int mid = (lo + hi) >>> 1; MapReducer<E> left = new MapReducer(this, array, mapper, reducer, lo, mid); MapReducer<E> right = new MapReducer(this, array, mapper, reducer, mid, hi); left.sibling = right; right.sibling = left; setPendingCount(1); // only right is pending right.fork(); left.compute(); // directly execute left } else { if (hi > lo) result = mapper.apply(array[lo]); tryComplete(); } } public void onCompletion(CountedCompleter<?> caller) { if (caller != this) { MapReducer<E> child = (MapReducer<E>)caller; MapReducer<E> sib = child.sibling; if (sib == null || sib.result == null) result = child.result; else result = reducer.apply(child.result, sib.result); } } public E getRawResult() { return result; } public static <E> E mapReduce(E[] array, MyMapper<E> mapper, MyReducer<E> reducer) { return new MapReducer<E>(null, array, mapper, reducer, 0, array.length).invoke(); } }
    这里，方法onCompletion采用结合结果的许多完成设计共同的形式。 这种回调式方法在每个任务被触发一次，在挂起的计数的两个不同的上下文中，或者当任务本身变为零：（1）时，如果其挂起的计数在调用tryComplete为零，或（2）通过任何其子任务，当它们完成并将待处理的计数递减到零时。 caller论证区分案例。 通常，当来电者是this ，不需要采取任何行动。 否则，可以使用调用者参数（通常通过转换）来提供要组合的值（和/或链接到其他值）。 假设正确使用待处理的计数，则完成任务及其子任务后，会发生onCompletion内的操作（一次）。 在此方法中不需要额外的同步来确保对此任务或其他完成任务的字段的访问的线程安全性。

    完成遍历 。 如果使用onCompletion处理完成不适用或不方便，则可以使用方法firstComplete()和nextComplete()创建自定义遍历。 例如，要定义一个仅以第三个ForEach示例的形式分割右侧任务的MapReducer，完成必须按照未用尽的子任务链接合作减少，可以如下完成：

       class MapReducer<E> extends CountedCompleter<E> { // version 2 final E[] array; final MyMapper<E> mapper; final MyReducer<E> reducer; final int lo, hi; MapReducer<E> forks, next; // record subtask forks in list E result; MapReducer(CountedCompleter<?> p, E[] array, MyMapper<E> mapper, MyReducer<E> reducer, int lo, int hi, MapReducer<E> next) { super(p); this.array = array; this.mapper = mapper; this.reducer = reducer; this.lo = lo; this.hi = hi; this.next = next; } public void compute() { int l = lo, h = hi; while (h - l >= 2) { int mid = (l + h) >>> 1; addToPendingCount(1); (forks = new MapReducer(this, array, mapper, reducer, mid, h, forks)).fork(); h = mid; } if (h > l) result = mapper.apply(array[l]); // process completions by reducing along and advancing subtask links for (CountedCompleter<?> c = firstComplete(); c != null; c = c.nextComplete()) { for (MapReducer t = (MapReducer)c, s = t.forks; s != null; s = t.forks = s.next) t.result = reducer.apply(t.result, s.result); } } public E getRawResult() { return result; } public static <E> E mapReduce(E[] array, MyMapper<E> mapper, MyReducer<E> reducer) { return new MapReducer<E>(null, array, mapper, reducer, 0, array.length, null).invoke(); } }

    触发。 一些CountedCompleters本身从来没有分叉，而是作为其他设计中的一些管道; 包括完成一个或多个异步任务触发另一个异步任务。 例如：

       class HeaderBuilder extends CountedCompleter<...> { ... } class BodyBuilder extends CountedCompleter<...> { ... } class PacketSender extends CountedCompleter<...> { PacketSender(...) { super(null, 1); ... } // trigger on second completion public void compute() { } // never called public void onCompletion(CountedCompleter<?> caller) { sendPacket(); } } // sample use: PacketSender p = new PacketSender(); new HeaderBuilder(p, ...).fork(); new BodyBuilder(p, ...).fork();
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CountedCompleter​()
      创建一个新的CountedCompleter，没有完成，初始挂起计数为零。
      protected CountedCompleter​(CountedCompleter<?> completer)
      创建一个新的CountedCompleter与给定的完成者和初始挂起计数为零。
      protected CountedCompleter​(CountedCompleter<?> completer, int initialPendingCount)
      创建一个新的CountedCompleter与给定的完成和初始挂起计数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addToPendingCount​(int delta)
      将给定值添加（原子地）给挂起的计数。
      boolean compareAndSetPendingCount​(int expected, int count)
      只有当当前持有给定的预期值时，将挂起的计数设置为（原子地）给定计数。
      void complete​(T rawResult)
      无论挂起的数量如何，调用 onCompletion(CountedCompleter) ，将此任务标记为完成，并进一步触发 tryComplete() （如果存在）。
      abstract void compute​()
      这个任务执行的主要计算。
      int decrementPendingCountUnlessZero​()
      如果挂起的计数非零，（原子地）减少它。
      protected boolean exec​()
      实现CountedCompleters的执行约定。
      CountedCompleter<?> firstComplete​()
      如果此任务的挂起计数为零，则返回此任务; 否则递减其挂起的数量并返回null 。
      CountedCompleter<?> getCompleter​()
      返回在此任务的构造函数中建立的完成者，如果没有，则返回 null 。
      int getPendingCount​()
      返回当前挂起的计数。
      T getRawResult​()
      返回计算结果。
      CountedCompleter<?> getRoot​()
      返回当前计算的根; 即这个任务，如果它没有完成，否则它的完成者的根。
      void helpComplete​(int maxTasks)
      如果此任务尚未完成，则尝试至少处理此任务在完成路径上的给定数量的其他未处理任务（如果有）。
      CountedCompleter<?> nextComplete​()
      如果此任务没有完成，请调用 ForkJoinTask.quietlyComplete()并返回 null 。
      void onCompletion​(CountedCompleter<?> caller)
      当方法 tryComplete()被调用并且挂起的计数为零时，或当无条件方法 complete(T)被调用时执行动作。
      boolean onExceptionalCompletion​(Throwable ex, CountedCompleter<?> caller)
      当方法 ForkJoinTask.completeExceptionally(Throwable)被调用或方法 compute()引发异常时，执行一个操作，并且此任务还没有正常完成。
      void propagateCompletion​()
      相当于tryComplete()但不会在完成路径中调用onCompletion(CountedCompleter) ：如果挂起的计数非零，则递减计数; 否则，同样尝试完成此任务的完成，如果存在，否则将此任务标记为完成。
      void quietlyCompleteRoot​()
      相当于 getRoot().quietlyComplete() 。
      void setPendingCount​(int count)
      将待处理计数设置为给定值。
      protected void setRawResult​(T t)
      带有CountedCompleters结果的方法可以可选地用于帮助维护结果数据。
      void tryComplete​()
      如果挂起的计数不为零，则减去计数; 否则调用onCompletion(CountedCompleter) ，然后同样尝试完成此任务的完成，如果存在，否则将此任务标记为完成。

      • Methods inherited from class java.util.concurrent.ForkJoinTask

        adapt, adapt, adapt, cancel, compareAndSetForkJoinTaskTag, completeExceptionally, fork, get, get, getException, getForkJoinTaskTag, getPool, getQueuedTaskCount, getSurplusQueuedTaskCount, helpQuiesce, inForkJoinPool, invoke, invokeAll, invokeAll, invokeAll, isCancelled, isCompletedAbnormally, isCompletedNormally, isDone, join, peekNextLocalTask, pollNextLocalTask, pollSubmission, pollTask, quietlyComplete, quietlyInvoke, quietlyJoin, reinitialize, setForkJoinTaskTag, tryUnfork

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CountedCompleter

        protected CountedCompleter​(CountedCompleter<?> completer,
                           int initialPendingCount)
        创建一个新的CountedCompleter与给定的完成和初始挂起计数。
        参数
        completer - 这个任务的完成，或者 null如果没有
        initialPendingCount - 初始 initialPendingCount

      • CountedCompleter

        protected CountedCompleter​(CountedCompleter<?> completer)
        创建一个新的CountedCompleter与给定的完成者和初始挂起计数为零。
        参数
        completer - 这个任务的完成者，或 null如果没有

      • CountedCompleter

        protected CountedCompleter​()
        创建一个新的CountedCompleter，没有完成，初始挂起计数为零。

    • 方法详细信息

      • compute

        public abstract void compute​()
        这个任务执行的主要计算。

      • onCompletion

        public void onCompletion​(CountedCompleter<?> caller)
        当方法tryComplete()被调用并且挂起的计数为零时，或当无条件方法complete(T)被调用时执行动作。 默认情况下，此方法什么都不做。 您可以通过检查给定的呼叫者参数的身份来区分情况。 如果不等于this ，那么它通常是可以包含结合（和/或其他结果的链接）的子任务。
        参数
        caller - 调用此方法的任务（可能是此任务本身）

      • onExceptionalCompletion

        public boolean onExceptionalCompletion​(Throwable ex,
                                       CountedCompleter<?> caller)
        当方法ForkJoinTask.completeExceptionally(Throwable)被调用或方法compute()引发异常时，执行一个操作，并且此任务尚未正常完成。 进入这个方法，这个任务ForkJoinTask.isCompletedAbnormally() 。 该方法的返回值控制进一步的传播：如果true并且此任务具有尚未完成的完成者，则完成者也完成异常，与此完成相同。 该方法的默认实现不会返回true 。
        参数
        ex - 例外
        caller - 调用此方法的任务（可能是此任务本身）
        结果
        true如果这个异常应该被传播到这个任务的完成者（如果存在）

      • getCompleter

        public final CountedCompleter<?> getCompleter​()
        返回在此任务的构造函数中建立的完成者，如果没有，则返回 null 。
        结果
        完成者

      • getPendingCount

        public final int getPendingCount​()
        返回当前挂起的计数。
        结果
        当前挂单数

      • setPendingCount

        public final void setPendingCount​(int count)
        将待处理计数设置为给定值。
        参数
        count - 计数

      • addToPendingCount

        public final void addToPendingCount​(int delta)
        将给定值添加（原子地）给挂起的计数。
        参数
        delta - 要添加的值

      • compareAndSetPendingCount

        public final boolean compareAndSetPendingCount​(int expected,
                                               int count)
        只有当当前持有给定的预期值时，将挂起的计数设置为（原子地）给定计数。
        参数
        expected - 预期值
        count - 新价值
        结果
        true如果成功

      • decrementPendingCountUnlessZero

        public final int decrementPendingCountUnlessZero​()
        如果挂起的计数非零，（原子地）减少它。
        结果
        初始（未确认）待处理的计数保持进入此方法

      • getRoot

        public final CountedCompleter<?> getRoot​()
        返回当前计算的根; 即这个任务，如果它没有完成，否则它的完成者的根。
        结果
        当前计算的根

      • tryComplete

        public final void tryComplete​()
        如果挂起的计数不为零，则减去计数; 否则调用onCompletion(CountedCompleter) ，然后同样尝试完成此任务的完成，如果存在，否则将此任务标记为完成。

      • propagateCompletion

        public final void propagateCompletion​()
        相当于tryComplete()，但不会在完成路径中调用onCompletion(CountedCompleter) ：如果挂起的计数非零，则递减计数; 否则，同样尝试完成此任务的完成，如果存在，否则将此任务标记为完成。 在方案onCompletion对于计算中的每个完成者不应该或不需要调用的情况下，该方法可能是有用的。

      • complete

        public void complete​(T rawResult)
        无论挂起的数量如何，调用onCompletion(CountedCompleter) ，将此任务标记为完成，并进一步触发tryComplete()对此任务的完成（如果存在）。 在调用onCompletion(CountedCompleter)或将此任务标记为完成之前，给定的rawResult用作参数setRawResult(T) ; 其值仅对setRawResult类有意义。 此方法不会修改挂起的计数。

        当获得几个子任务结果的任何一个（相对于所有）结果时，强制完成时，此方法可能是有用的。 但是，在setRawResult未被覆盖的普通（和推荐）情况下，可以使用quietlyCompleteRoot()更简单地获得该效果。

        重写：
        complete中的 ForkJoinTask<T>
        参数
        rawResult - 原始结果

      • firstComplete

        public final CountedCompleter<?> firstComplete​()
        如果此任务的挂起计数为零，则返回此任务; 否则递减其挂起的计数并返回null 。 该方法设计为与完成遍历循环中的nextComplete()一起使用。
        结果
        这个任务，如果挂起计数为零，否则为 null

      • nextComplete

        public final CountedCompleter<?> nextComplete​()
        如果此任务没有完成，请调用ForkJoinTask.quietlyComplete()并返回null 。 或者，如果完成者的待处理计数不为零，则减少待处理的计数并返回null 。 否则，返回完成者。 此方法可用作同构任务层次结构的完成遍历循环的一部分：
           for (CountedCompleter<?> c = firstComplete(); c != null; c = c.nextComplete()) { // ... process c ... }
        结果
        完成者，或 null如果没有

      • quietlyCompleteRoot

        public final void quietlyCompleteRoot​()
        相当于 getRoot().quietlyComplete() 。

      • helpComplete

        public final void helpComplete​(int maxTasks)
        如果此任务尚未完成，则尝试至少处理此任务在完成路径上的给定数量的其他未处理任务（如果有）。
        参数
        maxTasks - 要处理的最大任务数。 如果小于或等于零，则不处理任务。

      • exec

        protected final boolean exec​()
        实现CountedCompleters的执行约定。
        Specified by:
        exec在 ForkJoinTask<T>
        结果
        true如果此任务已知已正常完成

      • getRawResult

        public T getRawResult​()
        返回计算结果。 默认情况下，返回null ，这适用于Void操作，但在其他情况下应该被覆盖，几乎总是返回在完成后保存结果的字段或函数。
        Specified by:
        getRawResult在 ForkJoinTask<T>
        结果
        计算的结果

      • setRawResult

        protected void setRawResult​(T t)
        带有CountedCompleters结果的方法可以可选地用于帮助维护结果数据。 默认情况下，什么都不做。 不建议使用覆盖。 但是，如果覆盖此方法来更新现有对象或字段，则通常将其定义为线程安全。
        Specified by:
        setRawResult在 ForkJoinTask<T>
        参数
        t - 值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CyclicBarrier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class CyclicBarrier

  • java.lang.Object
    • java.util.concurrent.CyclicBarrier

  • public class CyclicBarrier
extends Object
    允许一组线程全部等待彼此达到共同屏障点的同步辅助。 循环阻塞在涉及固定大小的线程方的程序中很有用，这些线程必须偶尔等待彼此。 屏障被称为循环，因为它可以在等待的线程被释放之后重新使用。

    A CyclicBarrier支持一个可选的Runnable命令，每个屏障点运行一次，在派对中的最后一个线程到达之后，但在任何线程释放之前。 在任何一方继续进行之前，此屏障操作对更新共享状态很有用。

    示例用法：以下是在并行分解设计中使用障碍的示例：

       class Solver { final int N; final float[][] data; final CyclicBarrier barrier; class Worker implements Runnable { int myRow; Worker(int row) { myRow = row; } public void run() { while (!done()) { processRow(myRow); try { barrier.await(); } catch (InterruptedException ex) { return; } catch (BrokenBarrierException ex) { return; } } } } public Solver(float[][] matrix) { data = matrix; N = matrix.length; Runnable barrierAction = () -> mergeRows(...); barrier = new CyclicBarrier(N, barrierAction); List<Thread> threads = new ArrayList<>(N); for (int i = 0; i < N; i++) { Thread thread = new Thread(new Worker(i)); threads.add(thread); thread.start(); } // wait until done for (Thread thread : threads) thread.join(); } }
    这里，每个工作线程处理矩阵的一行，然后等待屏障，直到所有行都被处理。 当处理所有行时，执行提供的Runnable屏障操作并合并行。 如果合并确定已经找到解决方案，那么done()将返回true并且每个工作人员将终止。

    如果屏障操作不依赖于执行方暂停的各方，那么该方可以在释放任何线程时执行该操作。 为了方便这一点，每次调用await()会将该线程的到达索引返回到屏障。 然后，您可以选择哪个线程应该执行屏障操作，例如：

       if (barrier.await() == 0) { // log the completion of this iteration }

    CyclicBarrier对失败的同步尝试使用all-or-none断裂模型：如果线程由于中断，故障或超时而过早离开障碍点，则在该障碍点等待的所有其他线程也将异常通过BrokenBarrierException （或InterruptedException如果他们也在同一时间被打断）。

    内存一致性效应：在调用await() happen-before之前的线程中的操作，这些操作是屏障动作的一部分，而这些操作反过来发生在其他线程中相应的await()成功返回后的操作之前 。

    从以下版本开始：
    1.5
    另请参见：
    CountDownLatch

    • 构造方法摘要

      构造方法
      Constructor 描述
      CyclicBarrier​(int parties)
      创建一个新的 CyclicBarrier ，当给定数量的线程（线程）等待它时，它将跳闸，并且当屏障跳闸时不执行预定义的动作。
      CyclicBarrier​(int parties, Runnable barrierAction)
      创建一个新的 CyclicBarrier ，当给定数量的线程（线程）等待它时，它将跳闸，当屏障跳闸时执行给定的屏障动作，由最后一个线程进入屏障执行。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int await​()
      等待直到所有的 parties已经在这个障碍上调用了 await 。
      int await​(long timeout, TimeUnit unit)
      等待直到所有 parties已经在此屏障上调用了 await ，或指定的等待时间过去。
      int getNumberWaiting​()
      返回目前正在等待障碍的各方的数量。
      int getParties​()
      返回旅行这个障碍所需的聚会数量。
      boolean isBroken​()
      询问这个障碍是否处于破碎状态。
      void reset​()
      将屏障重置为初始状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CyclicBarrier

        public CyclicBarrier​(int parties,
                     Runnable barrierAction)
        创建一个新的 CyclicBarrier ，当给定数量的线程（线程）等待它时，它将跳闸，当屏障跳闸时执行给定的屏障动作，由最后一个线程进入屏障执行。
        参数
        parties - 屏障跳闸之前必须调用 await()的线程数
        barrierAction - 屏障跳闸时执行的命令，如果没有动作， null
        异常
        IllegalArgumentException - 如果 parties小于1

      • CyclicBarrier

        public CyclicBarrier​(int parties)
        创建一个新的 CyclicBarrier ，当给定数量的线程（线程）等待它时，它将跳闸，并且当屏障跳闸时不执行预定义的动作。
        参数
        parties - 屏障跳闸前必须调用 await()的线程数
        异常
        IllegalArgumentException - 如果 parties小于1

    • 方法详细信息

      • getParties

        public int getParties​()
        返回旅行这个障碍所需的聚会数量。
        结果
        要求脱离这个障碍的双方的数量

      • await

        public int await​()
          throws InterruptedException,
                 BrokenBarrierException
        等待，直到所有的parties已经在这个障碍上调用了await 。

        如果当前线程不是最后一个线程，那么它被禁用以进行线程调度，并且处于休眠状态，直到发生下列事情之一：

        • 最后一个线程到达; 要么
        • 一些其他线程interrupts当前线程; 要么
        • 一些其他线程interrupts其他等待线程之一; 要么
        • 一些其他线程在等待屏障时超时; 要么
        • 其他一些线程会在此屏障上调用reset() 。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是等待interrupted
        那么抛出InterruptedException并清除当前线程的中断状态。

        如果障碍是reset() ，而任何线程处于等待状态，或者如果屏障is broken时await被调用，或在任何线程处于等待状态，然后BrokenBarrierException被抛出。

        如果任何线程在等待的时候是interrupted ，那么所有其他等待的线程将会抛出BrokenBarrierException ，并且屏障被置于断开的状态。

        如果当前线程是要到达的最后一个线程，并且在构造函数中提供非空障碍操作，则当前线程在允许其他线程继续之前运行该动作。 如果在屏障动作期间发生异常，则该异常将在当前线程中传播，并且屏障置于断开状态。

        结果
        当前线程的到达索引，其中索引 getParties() - 1表示第一个到达，零表示最后到达
        异常
        InterruptedException - 如果当前线程在等待时中断
        BrokenBarrierException -如果 另一个线程被中断或超时在当前线程在等待，或阻挡被复位或者当屏障被破坏 await叫，或阻挡动作（如果存在）失败，由于一个异常

      • await

        public int await​(long timeout,
                 TimeUnit unit)
          throws InterruptedException,
                 BrokenBarrierException,
                 TimeoutException
        等待直到所有parties已经在此屏障上调用了await ，或指定的等待时间过去。

        如果当前线程不是最后一个线程，那么它被禁用以进行线程调度，并且处于休眠状态，直到发生下列事情之一：

        • 最后一个线程到达; 要么
        • 超过指定的超时 要么
        • 一些其他线程interrupts当前线程; 要么
        • 一些其他线程interrupts其他等待线程之一; 要么
        • 一些其他线程在等待屏障时超时; 要么
        • 其他一些线程会在此屏障上调用reset() 。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是等待interrupted
        然后抛出InterruptedException ，并清除当前线程的中断状态。

        如果指定的等待时间过去，则抛出TimeoutException 。 如果时间小于或等于零，该方法根本不会等待。

        如果障碍是reset() ，而任何线程处于等待状态，或者如果屏障is broken时await被调用，或在任何线程处于等待状态，然后BrokenBarrierException被抛出。

        如果任何线程在等待时为interrupted ，则所有其他等待线程将抛出BrokenBarrierException ，并且屏障置于断开状态。

        如果当前线程是要到达的最后一个线程，并且在构造函数中提供非空障碍操作，则当前线程在允许其他线程继续之前运行该动作。 如果在屏障动作期间发生异常，则该异常将在当前线程中传播，并且屏障置于断开状态。

        参数
        timeout - 等待屏障的时间
        unit - 超时参数的时间单位
        结果
        当前线程的到达索引，其中索引 getParties() - 1表示第一个到达，零表示最后到达
        异常
        InterruptedException - 如果当前线程在等待时中断
        TimeoutException - 如果TimeoutException指定的超时。 在这种情况下，障碍将被破坏。
        BrokenBarrierException - 如果 另一个线程在当前线程正在等待或屏蔽被重置时被中断或超时，或者当 await时屏障被破坏，或者屏蔽动作（如果存在）由于异常而失败

      • isBroken

        public boolean isBroken​()
        询问这个障碍是否处于破碎状态。
        结果
        true如果一个或多个政党由于施工或最后一次重置而导致中断或超时，或由于例外而导致屏障行动失败，则出现此障碍; 否则为false 。

      • reset

        public void reset​()
        将屏障重置为初始状态。 如果任何一方正在等待障碍，他们将返回BrokenBarrierException 。 注意，由于其他原因，发生断线后的复位可能会复杂化; 线程需要以其他方式重新同步，并选择一个执行重置。 可能更好地为后续使用创建新的屏障。

      • getNumberWaiting

        public int getNumberWaiting​()
        返回目前正在等待障碍的各方的数量。 此方法主要用于调试和断言。
        结果
        目前阻止的当事人数在 await()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Delayed (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface Delayed

  • All Superinterfaces:
    Comparable<Delayed>
    All Known Subinterfaces:
    RunnableScheduledFuture<V> ， ScheduledFuture<V>

    public interface Delayed
extends Comparable<Delayed>
    一个混合样式界面，用于标记在给定延迟后应该执行的对象。

    此接口的实现必须定义一个compareTo方法，提供与其getDelay方法一致的排序。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getDelay​(TimeUnit unit)
      在给定的时间单位中返回与此对象相关联的剩余延迟。

      • Methods inherited from interface java.lang.Comparable

        compareTo

    • 方法详细信息

      • getDelay

        long getDelay​(TimeUnit unit)
        在给定的时间单位中返回与此对象相关联的剩余延迟。
        参数
        unit - 时间单位
        结果
        剩余的延迟; 零或负值表示延迟已经过去
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DelayQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class DelayQueue<E extends Delayed>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
        • java.util.concurrent.DelayQueue<E>
  • 参数类型
    E - 保存在此队列中的元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， BlockingQueue<E> ， Queue<E>

    public class DelayQueue<E extends Delayed>
extends AbstractQueue<E>
implements BlockingQueue<E>
    一个无限的blocking queue的Delayed元素，其中元素只能在其延迟到期时才被采用。 队列的头部是Delayed元素，其延迟过去最远。 如果没有延迟到期，那么没有头， poll将返回null 。 当元素的getDelay(TimeUnit.NANOSECONDS)方法返回小于或等于零的值时，就会发生到期。 即使未使用的元素不能使用take或poll删除，因此它们被视为普通元素。 例如， size方法返回到期和未到期元素的计数。 此队列不允许空元素。

    该类及其迭代器实现了Collection和Iterator接口的所有可选方法。 方法iterator()中提供的迭代器不能保证以任何特定顺序遍历DelayQueue的元素。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      DelayQueue​()
      创建一个最初为空的新的 DelayQueue 。
      DelayQueue​(Collection<? extends E> c)
      创建一个DelayQueue最初包含给定集合的元素Delayed实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素插入到此延迟队列中。
      void clear​()
      从此延迟队列中原子地删除所有元素。
      int drainTo​(Collection<? super E> c)
      从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
      int drainTo​(Collection<? super E> c, int maxElements)
      最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
      Iterator<E> iterator​()
      返回此队列中所有元素（已过期和未过期）的迭代器。
      boolean offer​(E e)
      将指定的元素插入到此延迟队列中。
      boolean offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此延迟队列中。
      E peek​()
      检索但不删除此队列的头，如果此队列为空，则返回 null 。
      E poll​()
      检索并删除此队列的头部，如果此队列没有延迟到期的元素，则返回 null 。
      E poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头部，如果需要，等待具有到期延迟的元素可用于此队列，或指定的等待时间到期。
      void put​(E e)
      将指定的元素插入到此延迟队列中。
      int remainingCapacity​()
      始终返回 Integer.MAX_VALUE因为 DelayQueue不是容量限制。
      boolean remove​(Object o)
      从该队列中移除指定元素的单个实例（如果存在），无论其是否已过期。
      int size​()
      返回此集合中的元素数。
      E take​()
      检索并删除此队列的头部，如果需要，等待有一个延迟到期的元素在此队列上可用。
      Object[] toArray​()
      返回一个包含此队列中所有元素的数组。
      <T> T[] toArray​(T[] a)
      返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

      • Methods inherited from class java.util.AbstractCollection

        contains, containsAll, isEmpty, removeAll, retainAll, toString

      • Methods inherited from class java.util.AbstractQueue

        addAll, element, remove

      • Methods inherited from interface java.util.concurrent.BlockingQueue

        contains

      • Methods inherited from interface java.util.Collection

        addAll, containsAll, equals, hashCode, isEmpty, parallelStream, removeAll, removeIf, retainAll, spliterator, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Queue

        element, remove

    • 构造方法详细信息

      • DelayQueue

        public DelayQueue​()
        创建一个最初为空的新的 DelayQueue 。

      • DelayQueue

        public DelayQueue​(Collection<? extends E> c)
        创建一个DelayQueue最初包含给定集合的元素的Delayed实例。
        参数
        c - 最初包含的元素的集合
        异常
        NullPointerException - 如果指定的集合或其任何元素为空

    • 方法详细信息

      • add

        public boolean add​(E e)
        将指定的元素插入到此延迟队列中。
        Specified by:
        add在接口 BlockingQueue<E extends Delayed>
        Specified by:
        add在接口 Collection<E extends Delayed>
        Specified by:
        add在接口 Queue<E extends Delayed>
        重写：
        add在 AbstractQueue<E extends Delayed>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        将指定的元素插入到此延迟队列中。
        Specified by:
        offer在接口 BlockingQueue<E extends Delayed>
        Specified by:
        offer在接口 Queue<E extends Delayed>
        参数
        e - 要添加的元素
        结果
        true
        异常
        NullPointerException - 如果指定的元素为空

      • put

        public void put​(E e)
        将指定的元素插入到此延迟队列中。 队列是无限制的，这个方法永远不会被阻塞。
        Specified by:
        put在接口 BlockingQueue<E extends Delayed>
        参数
        e - 要添加的元素
        异常
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e,
                     long timeout,
                     TimeUnit unit)
        将指定的元素插入到此延迟队列中。 队列是无限制的，这个方法永远不会被阻塞。
        Specified by:
        offer在接口 BlockingQueue<E extends Delayed>
        参数
        e - 要添加的元素
        timeout - 该参数被忽略，因为该方法从不阻止
        unit - 该参数被忽略，因为该方法从不阻止
        结果
        true
        异常
        NullPointerException - 如果指定的元素为空

      • poll

        public E poll​()
        检索并删除此队列的头部，如果此队列没有延迟到期的元素，则返回 null 。
        Specified by:
        poll在接口 Queue<E extends Delayed>
        结果
        这个队列的头，或者 null如果这个队列没有到期的延迟的元素

      • take

        public E take​()
       throws InterruptedException
        检索并删除此队列的头部，如果需要，等待有一个延迟到期的元素在此队列上可用。
        Specified by:
        take在接口 BlockingQueue<E extends Delayed>
        结果
        这个队列的头
        异常
        InterruptedException - 如果在等待时中断

      • poll

        public E poll​(long timeout,
              TimeUnit unit)
       throws InterruptedException
        检索并删除此队列的头部，如果需要，等待具有到期延迟的元素可用于此队列，或指定的等待时间到期。
        Specified by:
        poll在接口 BlockingQueue<E extends Delayed>
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        该队列的头部，或 null如果指定的等待时间超过具有到期延迟的元素可用
        异常
        InterruptedException - 如果在等待时中断

      • peek

        public E peek​()
        检索但不删除此队列的头，如果此队列为空，则返回null 。 与poll不同，如果队列中没有过期的元素可用，则此方法返回将在以后过期的元素（如果存在）。
        Specified by:
        peek在接口 Queue<E extends Delayed>
        结果
        这个队列的头，或 null如果这个队列是空的

      • size

        public int size​()
        说明从接口Collection复制
        返回此集合中的元素数。 如果此集合包含超过Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<E extends Delayed>
        Specified by:
        size在 AbstractCollection<E extends Delayed>
        结果
        此集合中的元素数

      • drainTo

        public int drainTo​(Collection<? super E> c)
        描述从接口BlockingQueue复制
        从该队列中删除所有可用的元素，并将它们添加到给定的集合中。 此操作可能比重复轮询此队列更有效。 尝试向集合c添加元素时遇到的失败可能会导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将排队排队自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E extends Delayed>
        参数
        c - 将元素传输到的集合
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定集合不支持添加元素
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或此队列的某个元素的某些属性会阻止将其添加到指定的集合

      • drainTo

        public int drainTo​(Collection<? super E> c,
                   int maxElements)
        描述从接口BlockingQueue复制
        最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。 尝试向集合c添加元素时遇到的失败可能会导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将队列排入自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E extends Delayed>
        参数
        c - 将元素传输到的集合
        maxElements - 要传输的元素的最大数量
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定集合不支持元素的添加
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或此队列的某个元素的某些属性会阻止将其添加到指定的集合

      • clear

        public void clear​()
        从此延迟队列中原子地删除所有元素。 此呼叫返回后队列将为空。 未到期的元素不等待; 它们被简单地从队列中丢弃。
        Specified by:
        clear在接口 Collection<E extends Delayed>
        重写：
        clear在 AbstractQueue<E extends Delayed>

      • remainingCapacity

        public int remainingCapacity​()
        始终返回 Integer.MAX_VALUE因为 DelayQueue不受容量限制。
        Specified by:
        remainingCapacity在接口 BlockingQueue<E extends Delayed>
        结果
        Integer.MAX_VALUE

      • toArray

        public Object[] toArray​()
        返回一个包含此队列中所有元素的数组。 返回的数组元素没有特定的顺序。

        返回的数组将是“安全的”，因为该队列不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E extends Delayed>
        重写：
        toArray在 AbstractCollection<E extends Delayed>
        结果
        一个包含此队列中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 返回的数组元素没有特定的顺序。 如果队列适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此队列的大小分配一个新数组。

        如果这个队列符合指定的数组空间（即数组的队列比此队列多），则队列结束后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于阵列和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        以下代码可用于将延迟队列转储到新分配的Delayed数组中：

          Delayed[] a = q.toArray(new Delayed[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E extends Delayed>
        重写：
        toArray在 AbstractCollection<E extends Delayed>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储队列的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组
        结果
        一个包含此队列中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • remove

        public boolean remove​(Object o)
        从该队列中移除指定元素的单个实例（如果存在），无论其是否已过期。
        Specified by:
        remove在接口 BlockingQueue<E extends Delayed>
        Specified by:
        remove在接口 Collection<E extends Delayed>
        重写：
        remove在 AbstractCollection<E extends Delayed>
        参数
        o - 要从此集合中删除的元素（如果存在）
        结果
        true如果某个元素因此调用而被删除

      • iterator

        public Iterator<E> iterator​()
        返回此队列中所有元素（已过期和未过期）的迭代器。 迭代器不以任何特定顺序返回元素。

        返回的迭代器是weakly consistent 。

        Specified by:
        iterator在接口 Collection<E extends Delayed>
        Specified by:
        iterator在接口 Iterable<E extends Delayed>
        Specified by:
        iterator类 AbstractCollection<E extends Delayed>
        结果
        an iterator over the elements in this queue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Exchanger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class Exchanger<V>

  • java.lang.Object
    • java.util.concurrent.Exchanger<V>
  • 参数类型
    V - 可以交换的对象的类型

    public class Exchanger<V>
extends Object
    线程可以在成对内配对和交换元素的同步点。 每个线程在输入exchange方法时提供一些对象，与合作伙伴线程匹配，并在返回时接收其合作伙伴的对象。 交换器可以被视为SynchronousQueue的双向形式。 交换器在诸如遗传算法和管道设计的应用中可能是有用的。

    示例用法：以下是使用Exchanger在线程之间交换缓冲区的类的亮点，以便填充缓冲区的线程在需要时将其清空，并将已填充的线程移交给清空缓冲区的线程。

       class FillAndEmpty { Exchanger<DataBuffer> exchanger = new Exchanger<>(); DataBuffer initialEmptyBuffer = ... a made-up type DataBuffer initialFullBuffer = ... class FillingLoop implements Runnable { public void run() { DataBuffer currentBuffer = initialEmptyBuffer; try { while (currentBuffer != null) { addToBuffer(currentBuffer); if (currentBuffer.isFull()) currentBuffer = exchanger.exchange(currentBuffer); } } catch (InterruptedException ex) { ... handle ... } } } class EmptyingLoop implements Runnable { public void run() { DataBuffer currentBuffer = initialFullBuffer; try { while (currentBuffer != null) { takeFromBuffer(currentBuffer); if (currentBuffer.isEmpty()) currentBuffer = exchanger.exchange(currentBuffer); } } catch (InterruptedException ex) { ... handle ...} } } void start() { new Thread(new FillingLoop()).start(); new Thread(new EmptyingLoop()).start(); } }

    内存一致性效果：对于每对线程，其经成功交换对象Exchanger ，在现有的行动exchange()中的每个线程happen-before那些从相应的返回后续exchange()中的其他线程。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      Exchanger​()
      创建一个新的交换器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      V exchange​(V x)
      等待另一个线程到达此交换点（除非当前线程是 interrupted ），然后将给定的对象传递给它，接收其对象作为回报。
      V exchange​(V x, long timeout, TimeUnit unit)
      等待另一个线程到达此交换点（除非当前线程是 interrupted或指定的等待时间过去），然后将给定的对象传输给它，接收其对象作为回报。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Exchanger

        public Exchanger​()
        创建一个新的交换器。

    • 方法详细信息

      • exchange

        public V exchange​(V x)
           throws InterruptedException
        等待另一个线程到达此交换点（除非当前线程为interrupted ），然后将给定对象传输给它，接收其对象作为回报。

        如果另一个线程已经在交换点处等待，那么它将恢复进行线程调度，并接收当前线程传入的对象。 当前线程立即返回，接收通过该另一线程传递到交换机的对象。

        如果没有其他线程已经在交换机上等待，那么当前线程被禁用以进行线程调度，并且休眠，直到发生两件事情之一：

        • 一些其他线程进入交换机; 要么
        • 一些其他线程当前线程interrupts 。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted在等待交换，
        那么抛出InterruptedException并清除当前线程的中断状态。
        参数
        x - 要交换的对象
        结果
        由另一个线程提供的对象
        异常
        InterruptedException - 如果当前线程在等待时中断

      • exchange

        public V exchange​(V x,
                  long timeout,
                  TimeUnit unit)
           throws InterruptedException,
                  TimeoutException
        等待另一个线程到达此交换点（除非当前线程为interrupted或指定的等待时间过去），然后将给定对象传输给它，接收其对象作为回报。

        如果另一个线程已经在交换点处等待，那么它将恢复进行线程调度，并接收当前线程传入的对象。 当前线程立即返回，接收通过该另一线程传递到交换机的对象。

        如果没有其他线程已经在交换机上等待，那么当前线程被禁用以进行线程调度，并且处于休眠状态，直至发生三件事情之一：

        • 一些其他线程进入交换机; 要么
        • 一些其他线程当前线程interrupts ; 要么
        • 指定的等待时间过去了。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是等待交换的interrupted ，
        则抛出InterruptedException ，并清除当前线程的中断状态。

        如果指定的等待时间过去，则抛出TimeoutException 。 如果时间小于或等于零，该方法根本不会等待。

        参数
        x - 要交换的对象
        timeout - 等待的最长时间
        unit - timeout参数的时间单位
        结果
        由另一个线程提供的对象
        异常
        InterruptedException - 如果当前线程在等待时中断
        TimeoutException - 如果在另一个线程进入交换机之前经过了指定的等待时间
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExecutionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ExecutionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.util.concurrent.ExecutionException
  • All Implemented Interfaces:
    Serializable

    public class ExecutionException
extends 异常
    尝试检索通过抛出异常中止的任务的结果时抛出的异常。 可以使用Throwable.getCause()方法检查此异常。
    从以下版本开始：
    1.5
    另请参见：
    Future ， Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ExecutionException​()
      构造一个 ExecutionException ，没有详细信息。
      protected ExecutionException​(String message)
      构造具有指定详细消息的 ExecutionException 。
        ExecutionException​(String message, Throwable cause)
      构造具有指定的详细信息和原因的 ExecutionException 。
        ExecutionException​(Throwable cause)
      构造具有指定原因的 ExecutionException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ExecutionException

        protected ExecutionException​()
        构造一个ExecutionException ，没有详细信息。 原因未初始化，可以随后通过调用initCause进行初始化。

      • ExecutionException

        protected ExecutionException​(String message)
        构造具有指定详细消息的ExecutionException 。 原因未初始化，可以随后通过调用initCause进行初始化。
        参数
        message - 详细信息

      • ExecutionException

        public ExecutionException​(String message,
                          Throwable cause)
        构造一个具有指定的详细信息和原因的 ExecutionException 。
        参数
        message - 详细信息
        cause - 原因（保存以供 Throwable.getCause()方法后续检索）

      • ExecutionException

        public ExecutionException​(Throwable cause)
        构造具有指定原因的ExecutionException 。 详细信息设置为(cause == null ? null : cause.toString()) （通常包含类和详细信息cause ）。
        参数
        cause - 原因（由 Throwable.getCause()方法保存供以后检索）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Executor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface Executor

  • All Known Subinterfaces:
    ExecutorService ， ScheduledExecutorService
    所有已知实现类：
    AbstractExecutorService ， ForkJoinPool ， ScheduledThreadPoolExecutor ， ThreadPoolExecutor

    public interface Executor
    执行提交的对象Runnable任务。 该接口提供了一种将任务提交从每个任务的运行Executor方法，包括线程使用，调度等细节。通常使用Executor而不是显式创建线程。 例如，不是为一组任务调用new Thread(new RunnableTask()).start() ，而是可以使用：
       Executor executor = anExecutor(); executor.execute(new RunnableTask1()); executor.execute(new RunnableTask2()); ...
    但是， Executor接口并不要求执行异步。 在最简单的情况下，执行程序可以立即在调用者的线程中运行提交的任务：
       class DirectExecutor implements Executor { public void execute(Runnable r) { r.run(); } }
    更典型的是，除了调用者的线程之外，任务在一些线程中执行。 下面的执行器为每个任务生成一个新的线程。
       class ThreadPerTaskExecutor implements Executor { public void execute(Runnable r) { new Thread(r).start(); } }
    许多Executor实施对如何和何时安排任务施加某种限制。 下面的执行者将任务的提交序列化到第二个执行者，说明复合执行器。
       class SerialExecutor implements Executor { final Queue<Runnable> tasks = new ArrayDeque<>(); final Executor executor; Runnable active; SerialExecutor(Executor executor) { this.executor = executor; } public synchronized void execute(Runnable r) { tasks.add(() -> { try { r.run(); } finally { scheduleNext(); } }); if (active == null) { scheduleNext(); } } protected synchronized void scheduleNext() { if ((active = tasks.poll()) != null) { executor.execute(active); } } }
    该包中提供的Executor实现实现了ExecutorService ，这是一个更广泛的界面。 ThreadPoolExecutor类提供了一个可扩展的线程池实现。 Executors类为这些执行人员提供了方便的工厂方法。

    内存一致性效果：操作在一个线程提交之前Runnable对象到Executor happen-before其执行开始，也许在另一个线程。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void execute​(Runnable command)
      在将来的某个时间执行给定的命令。

    • 方法详细信息

      • execute

        void execute​(Runnable command)
        在将来的某个时间执行给定的命令。 该命令可以在一个新线程，一个合并的线程中或在调用线程中执行，由Executor实现。
        参数
        command - 可运行的任务
        异常
        RejectedExecutionException - 如果此任务不能被接受执行
        NullPointerException - 如果命令为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExecutorCompletionService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ExecutorCompletionService<V>

  • java.lang.Object
    • java.util.concurrent.ExecutorCompletionService<V>
  • All Implemented Interfaces:
    CompletionService<V>

    public class ExecutorCompletionService<V>
extends Object
implements CompletionService<V>
    A CompletionService使用提供的Executor执行任务。 此类安排提交的任务完成后，可以使用take访问队列。 该类具有足够的轻量级，适合于处理任务组时的瞬时使用。

    用法示例。 假设你有一组解决者为某个问题，每个返回一个值类型Result ，并希望同时运行它们，处理其中返回一个非空值的结果，在某些方法use(Result r) 。 你可以这样写：

       void solve(Executor e, Collection<Callable<Result>> solvers) throws InterruptedException, ExecutionException { CompletionService<Result> cs = new ExecutorCompletionService<>(e); solvers.forEach(cs::submit); for (int i = solvers.size(); i > 0; i--) { Result r = cs.take().get(); if (r != null) use(r); } }
    假设您希望使用该组任务的第一个非空结果，忽略遇到任何异常，并在第一个准备就绪时取消所有其他任务：
       void solve(Executor e, Collection<Callable<Result>> solvers) throws InterruptedException { CompletionService<Result> cs = new ExecutorCompletionService<>(e); int n = solvers.size(); List<Future<Result>> futures = new ArrayList<>(n); Result result = null; try { solvers.forEach(solver -> futures.add(cs.submit(solver))); for (int i = n; i > 0; i--) { try { Result r = cs.take().get(); if (r != null) { result = r; break; } } catch (ExecutionException ignore) {} } } finally { futures.forEach(future -> future.cancel(true)); } if (result != null) use(result); }
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      ExecutorCompletionService​(Executor executor)
      使用提供的执行程序创建一个ExecutorCompletionService，用于执行基本任务，一个LinkedBlockingQueue作为完成队列。
      ExecutorCompletionService​(Executor executor, BlockingQueue<Future<V>> completionQueue)
      使用提供的执行程序创建一个ExecutorCompletionService，用于执行基本任务，并将提供的队列作为其完成队列。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Future<V> poll​()
      检索并删除代表下一个完成的任务的未来，或者如果没有，任务将 null 。
      Future<V> poll​(long timeout, TimeUnit unit)
      检索并删除表示下一个完成的任务的未来，如果还没有，则等待必要时直到指定的等待时间。
      Future<V> submit​(Runnable task, V result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      Future<V> submit​(Callable<V> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。
      Future<V> take​()
      检索并删除代表下一个完成任务的未来，等待是否还没有任务。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ExecutorCompletionService

        public ExecutorCompletionService​(Executor executor)
        使用提供的执行程序创建一个ExecutorCompletionService来执行基本任务，一个LinkedBlockingQueue作为完成队列。
        参数
        executor - 执行者使用
        异常
        NullPointerException - 如果执行人是 null

      • ExecutorCompletionService

        public ExecutorCompletionService​(Executor executor,
                                 BlockingQueue<Future<V>> completionQueue)
        使用提供的执行程序创建一个ExecutorCompletionService，用于执行基本任务，并将提供的队列作为其完成队列。
        参数
        executor - 执行者使用
        completionQueue - 用作完成队列的队列通常由该服务专用。 该队列被视为无限制的尝试Queue.add完成的任务的操作导致它们不可检索。
        异常
        NullPointerException - 如果executor或completionQueue是 null

    • 方法详细信息

      • submit

        public Future<V> submit​(Callable<V> task)
        说明从接口CompletionService复制
        提交值返回任务以执行，并返回代表任务待处理结果的Future。 完成后，可以采取或轮询此任务。
        Specified by:
        submit在接口 CompletionService<V>
        参数
        task - 要提交的任务
        结果
        一个未来的代表，待完成任务

      • submit

        public Future<V> submit​(Runnable task,
                        V result)
        说明从界面CompletionService复制
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 完成后，可以采取或轮询此任务。
        Specified by:
        submit在接口 CompletionService<V>
        参数
        task - 要提交的任务
        result - 成功完成后返回的结果
        结果
        未来任务的完成，其 get()方法将在完成后返回给定的结果值

      • take

        public Future<V> take​()
               throws InterruptedException
        说明从界面CompletionService复制
        检索并删除代表下一个完成任务的未来，等待是否还没有任务。
        Specified by:
        take在接口 CompletionService<V>
        结果
        未来代表下一个完成的任务
        异常
        InterruptedException - 如果在等待时中断

      • poll

        public Future<V> poll​()
        说明从界面CompletionService复制
        检索并删除代表下一个完成的任务的未来，或者如果没有的话，则 null 。
        Specified by:
        poll在接口 CompletionService<V>
        结果
        未来代表下一个完成的任务，或 null如果没有）

      • poll

        public Future<V> poll​(long timeout,
                      TimeUnit unit)
               throws InterruptedException
        说明从接口CompletionService复制
        检索并删除表示下一个完成的任务的未来，如果还没有，则等待必要时直到指定的等待时间。
        Specified by:
        poll在接口 CompletionService<V>
        参数
        timeout - 放弃之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        未来代表下一个完成的任务或 null如果指定的等待时间过去之前存在
        异常
        InterruptedException - 如果在等待时中断
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Executors (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class Executors

  • java.lang.Object
    • java.util.concurrent.Executors

  • public class Executors
extends Object
    工厂和工具方法Executor ， ExecutorService ， ScheduledExecutorService ， ThreadFactory和Callable此包中定义的类。 该类支持以下几种方法：
    • 创建并返回一个ExecutorService设置通常有用的配置设置的方法。
    • 创建并返回一个ScheduledExecutorService的方法，配置常用的配置设置。
    • 创建并返回“包装”ExecutorService的方法，通过使实现特定的方法无法访问来禁用重新配置。
    • 创建并返回将新创建的线程设置为已知状态的ThreadFactory的方法。
    • 创建并返回一个Callable的其他类似闭包形式的方法，因此可以在需要Callable执行方法中使用。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Callable<Object> callable​(Runnable task)
      返回一个Callable对象，当被调用时，它运行给定的任务并返回null 。
      static <T> Callable<T> callable​(Runnable task, T result)
      返回一个Callable对象，当被调用时，它运行给定的任务并返回给定的结果。
      static Callable<Object> callable​(PrivilegedAction<?> action)
      返回一个Callable对象，当被调用时，它运行给定的特权动作并返回其结果。
      static Callable<Object> callable​(PrivilegedExceptionAction<?> action)
      返回一个Callable对象，当被调用时，它运行给定的特权异常操作并返回其结果。
      static ThreadFactory defaultThreadFactory​()
      返回用于创建新线程的默认线程工厂。
      static ExecutorService newCachedThreadPool​()
      创建一个根据需要创建新线程的线程池，但在可用时将重新使用以前构造的线程。
      static ExecutorService newCachedThreadPool​(ThreadFactory threadFactory)
      创建一个根据需要创建新线程的线程池，但在可用时将重新使用以前构造的线程，并在需要时使用提供的ThreadFactory创建新线程。
      static ExecutorService newFixedThreadPool​(int nThreads)
      创建一个线程池，该线程池重用固定数量的从共享无界队列中运行的线程。
      static ExecutorService newFixedThreadPool​(int nThreads, ThreadFactory threadFactory)
      创建一个线程池，重用固定数量的线程，从共享无界队列中运行，使用提供的ThreadFactory在需要时创建新线程。
      static ScheduledExecutorService newScheduledThreadPool​(int corePoolSize)
      创建一个线程池，可以调度命令在给定的延迟之后运行，或定期执行。
      static ScheduledExecutorService newScheduledThreadPool​(int corePoolSize, ThreadFactory threadFactory)
      创建一个线程池，可以调度命令在给定的延迟之后运行，或定期执行。
      static ExecutorService newSingleThreadExecutor​()
      创建一个使用从无界队列运行的单个工作线程的执行程序。
      static ExecutorService newSingleThreadExecutor​(ThreadFactory threadFactory)
      创建一个使用单个工作线程运行无界队列的执行程序，并在需要时使用提供的ThreadFactory创建一个新线程。
      static ScheduledExecutorService newSingleThreadScheduledExecutor​()
      创建一个单线程执行器，可以调度命令在给定的延迟之后运行，或定期执行。
      static ScheduledExecutorService newSingleThreadScheduledExecutor​(ThreadFactory threadFactory)
      创建一个单线程执行器，可以调度命令在给定的延迟之后运行，或定期执行。
      static ExecutorService newWorkStealingPool​()
      创建一个工作窃取线程池，使用数字 available processors作为其目标并行级别。
      static ExecutorService newWorkStealingPool​(int parallelism)
      创建一个维护足够的线程以支持给定的并行级别的线程池，并且可以使用多个队列来减少争用。
      static <T> Callable<T> privilegedCallable​(Callable<T> callable)
      返回一个Callable对象，当被调用时，将在当前访问控制上下文中执行给定的callable 。
      static <T> Callable<T> privilegedCallableUsingCurrentClassLoader​(Callable<T> callable)
      返回一个Callable对象，当被调用时，将在当前访问控制上下文中执行给定的callable ，当前上下文类加载器作为上下文类加载器。
      static ThreadFactory privilegedThreadFactory​()
      返回一个用于创建与当前线程具有相同权限的新线程的线程工厂。
      static ExecutorService unconfigurableExecutorService​(ExecutorService executor)
      返回一个将所有定义的ExecutorService方法委托给给定执行程序的对象，但不能以其他方式使用转换方式访问。
      static ScheduledExecutorService unconfigurableScheduledExecutorService​(ScheduledExecutorService executor)
      返回一个将所有定义的ScheduledExecutorService方法委托给给定执行程序的对象，但不能以其他方式使用转换来访问。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • newFixedThreadPool

        public static ExecutorService newFixedThreadPool​(int nThreads)
        创建一个线程池，该线程池重用固定数量的从共享无界队列中运行的线程。 在任何时候，最多nThreads线程将是主动处理任务。 如果所有线程处于活动状态时都会提交其他任务，则它们将等待队列中直到线程可用。 如果任何线程由于在关闭之前的执行期间发生故障而终止，则如果需要执行后续任务，则新的线程将占用它。 池中的线程将存在，直到它显式为shutdown 。
        参数
        nThreads - 池中的线程数
        结果
        新创建的线程池
        异常
        IllegalArgumentException - 如果是 nThreads <= 0

      • newWorkStealingPool

        public static ExecutorService newWorkStealingPool​(int parallelism)
        创建一个维护足够的线程以支持给定的并行级别的线程池，并且可以使用多个队列来减少争用。 并行级别对应于主动参与或可以从事任务处理的最大线程数。 线程的实际数量可以动态增长和收缩。 工作窃取池不保证执行提交的任务的顺序。
        参数
        parallelism - 目标平行度水平
        结果
        新创建的线程池
        异常
        IllegalArgumentException - 如果是 parallelism <= 0
        从以下版本开始：
        1.8

      • newWorkStealingPool

        public static ExecutorService newWorkStealingPool​()
        创建一个工作窃取线程池，使用数字 available processors作为其目标并行级别。
        结果
        新创建的线程池
        从以下版本开始：
        1.8
        另请参见：
        newWorkStealingPool(int)

      • newFixedThreadPool

        public static ExecutorService newFixedThreadPool​(int nThreads,
                                                 ThreadFactory threadFactory)
        创建一个线程池，重用固定数量的线程，从共享无界队列中运行，使用提供的ThreadFactory在需要时创建新线程。 在任何时候，最多nThreads线程将处于主动处理任务。 如果所有线程处于活动状态时都会提交其他任务，则它们将等待队列中直到线程可用。 如果任何线程由于在关闭之前的执行期间发生故障而终止，则如果需要执行后续任务，则新的线程将占用它。 池中的线程将存在，直到它显式为shutdown 。
        参数
        nThreads - 池中的线程数
        threadFactory - 创建新线程时使用的工厂
        结果
        新创建的线程池
        异常
        NullPointerException - 如果threadFactory为空
        IllegalArgumentException - 如果是 nThreads <= 0

      • newSingleThreadExecutor

        public static ExecutorService newSingleThreadExecutor​()
        创建一个使用从无界队列运行的单个工作线程的执行程序。 （请注意，如果这个单个线程由于在关闭之前的执行过程中发生故障而终止，则如果需要执行后续任务，则新的线程将占用它。）任务保证顺序执行，并且不超过一个任务将被激活在任何给定的时间。 与其他等效的newFixedThreadPool(1)不同，返回的执行器保证不被重新配置以使用额外的线程。
        结果
        新创建的单线程执行器

      • newSingleThreadExecutor

        public static ExecutorService newSingleThreadExecutor​(ThreadFactory threadFactory)
        创建一个使用单个工作线程运行无界队列的执行程序，并在需要时使用提供的ThreadFactory创建一个新线程。 与其他等效的newFixedThreadPool(1, threadFactory)不同，返回的执行器保证不被重新配置以使用额外的线程。
        参数
        threadFactory - 创建新线程时使用的工厂
        结果
        新创建的单线程执行器
        异常
        NullPointerException - 如果threadFactory为空

      • newCachedThreadPool

        public static ExecutorService newCachedThreadPool​()
        创建一个根据需要创建新线程的线程池，但在可用时将重新使用以前构造的线程。 这些池通常会提高执行许多短暂异步任务的程序的性能。 调用execute将重用以前构造的线程（如果可用）。 如果没有可用的线程，将创建一个新的线程并将其添加到该池中。 未使用六十秒的线程将被终止并从缓存中删除。 因此，长时间保持闲置的池将不会消耗任何资源。 请注意，可以使用ThreadPoolExecutor构造函数创建具有相似属性但不同详细信息（例如，超时参数）的池 。
        结果
        新创建的线程池

      • newCachedThreadPool

        public static ExecutorService newCachedThreadPool​(ThreadFactory threadFactory)
        创建一个根据需要创建新线程的线程池，但在可用时将重新使用以前构造的线程，并在需要时使用提供的ThreadFactory创建新线程。
        参数
        threadFactory - 创建新线程时使用的工厂
        结果
        新创建的线程池
        异常
        NullPointerException - 如果threadFactory为空

      • newSingleThreadScheduledExecutor

        public static ScheduledExecutorService newSingleThreadScheduledExecutor​()
        创建一个单线程执行器，可以调度命令在给定的延迟之后运行，或定期执行。 （请注意，如果这个单个线程由于在关闭之前的执行过程中发生故障而终止，则如果需要执行后续任务，则新的线程将占用它。）任务保证顺序执行，并且不超过一个任务将被激活在任何给定的时间。 与其他等效的newScheduledThreadPool(1)不同，返回的执行器保证不被重新配置以使用额外的线程。
        结果
        新创建的预定执行者

      • newSingleThreadScheduledExecutor

        public static ScheduledExecutorService newSingleThreadScheduledExecutor​(ThreadFactory threadFactory)
        创建一个单线程执行器，可以调度命令在给定的延迟之后运行，或定期执行。 （请注意，如果这个单个线程由于在关闭之前的执行过程中发生故障而终止，则如果需要执行后续任务，则新的线程将占用它。）任务保证顺序执行，并且不超过一个任务将被激活在任何给定的时间。 与其他等效的newScheduledThreadPool(1, threadFactory)不同，返回的执行器保证不被重新配置以使用额外的线程。
        参数
        threadFactory - 创建新线程时使用的工厂
        结果
        一个新创建的预定执行者
        异常
        NullPointerException - 如果threadFactory为null

      • newScheduledThreadPool

        public static ScheduledExecutorService newScheduledThreadPool​(int corePoolSize)
        创建一个线程池，可以调度命令在给定的延迟之后运行，或定期执行。
        参数
        corePoolSize - 要保留在池中的线程数，即使它们处于空闲状态
        结果
        一个新创建的线程池
        异常
        IllegalArgumentException - 如果是 corePoolSize < 0

      • newScheduledThreadPool

        public static ScheduledExecutorService newScheduledThreadPool​(int corePoolSize,
                                                              ThreadFactory threadFactory)
        创建一个线程池，可以调度命令在给定的延迟之后运行，或定期执行。
        参数
        corePoolSize - 要保留在池中的线程数，即使它们处于空闲状态
        threadFactory - 当执行器创建新线程时使用的工厂
        结果
        一个新创建的线程池
        异常
        IllegalArgumentException - 如果是 corePoolSize < 0
        NullPointerException - 如果threadFactory为空

      • unconfigurableExecutorService

        public static ExecutorService unconfigurableExecutorService​(ExecutorService executor)
        返回一个将所有定义的ExecutorService方法委托给给定执行程序的对象，但不能以其他方式使用转换方式访问。 这提供了一种安全地“冻结”配置并且不允许调整给定的具体实现的方法。
        参数
        executor - 底层实现
        结果
        一个 ExecutorService例子
        异常
        NullPointerException - 如果执行者为空

      • unconfigurableScheduledExecutorService

        public static ScheduledExecutorService unconfigurableScheduledExecutorService​(ScheduledExecutorService executor)
        返回一个将所有定义的ScheduledExecutorService方法委托给给定执行程序的对象，但不能使用任何其他可能使用转换来访问的方法。 这提供了一种安全地“冻结”配置并且不允许调整给定的具体实现的方法。
        参数
        executor - 底层实现
        结果
        一个 ScheduledExecutorService实例
        异常
        NullPointerException - 如果执行者为空

      • defaultThreadFactory

        public static ThreadFactory defaultThreadFactory​()
        返回用于创建新线程的默认线程工厂。 该工厂在同一个ThreadGroup中创建了Executor使用的所有新线程。 如果有一个SecurityManager ，它使用组System.getSecurityManager() ，否则该组的线程调用这个defaultThreadFactory方法。 每个新线程被创建为非守护线程，优先级设置为Thread.NORM_PRIORITY的较小者，线程组中允许的最大优先级。 新线程的名称可通过pool-N-thread-M的 Thread.getName()访问，其中N是此工厂的序列号， M是此工厂创建的线程的序列号。
        结果
        线工厂

      • privilegedThreadFactory

        public static ThreadFactory privilegedThreadFactory​()
        返回一个用于创建与当前线程具有相同权限的新线程的线程工厂。 该工厂创建与defaultThreadFactory()设置相同的线程，另外将新线程的AccessControlContext和contextClassLoader设置为与调用此privilegedThreadFactory方法的线程相同。 新privilegedThreadFactory可以在中创建AccessController.doPrivileged动作设置当前线程的访问控制上下文来创建具有该操作中保持的所选权限的线程。

        请注意，虽然在这些线程中运行的任务将具有与当前线程相同的访问控制和类加载器设置，但它们不需要具有相同的ThreadLocal或InheritableThreadLocal值。 如果需要，可以在使用ThreadPoolExecutor.beforeExecute(Thread, Runnable)的 ThreadPoolExecutor子类中运行任何任务之前设置或重置线程本地的特定值。 此外，如果需要初始化工作线程以与其他指定的线程具有相同的InheritableThreadLocal设置，则可以创建一个自定义ThreadFactory，该线程等待和服务请求创建将继承其值的其他请求。

        结果
        线工厂
        异常
        AccessControlException - 如果当前的访问控制上下文没有获取和设置上下文类加载器的权限

      • callable

        public static <T> Callable<T> callable​(Runnable task,
                                       T result)
        返回一个27062041414139对象，当被调用时，它运行给定的任务并返回给定的结果。 当将需要Callable方法应用于其他无结果的操作时，这可能很有用。
        参数类型
        T - 结果的类型
        参数
        task - 要运行的任务
        result - 结果返回
        结果
        可调用对象
        异常
        NullPointerException - 如果任务为空

      • callable

        public static Callable<Object> callable​(Runnable task)
        返回一个Callable对象，当被调用时，它运行给定的任务并返回null 。
        参数
        task - 要运行的任务
        结果
        可调用对象
        异常
        NullPointerException - 如果任务为空

      • callable

        public static Callable<Object> callable​(PrivilegedAction<?> action)
        返回一个Callable对象，当被调用时，它运行给定的特权动作并返回其结果。
        参数
        action - 运行的特权操作
        结果
        可调用对象
        异常
        NullPointerException - 如果动作为空

      • callable

        public static Callable<Object> callable​(PrivilegedExceptionAction<?> action)
        返回一个Callable对象，当被调用时，它运行给定的特权异常操作并返回其结果。
        参数
        action - 运行的特权异常操作
        结果
        可调用对象
        异常
        NullPointerException - 如果动作为空

      • privilegedCallable

        public static <T> Callable<T> privilegedCallable​(Callable<T> callable)
        返回一个Callable对象，当被调用时，将在当前访问控制上下文下执行给定的callable 。 通常应在一个AccessController.doPrivileged操作中调用此方法来创建可调用的应用程序，如果可能的话，将在该操作中保存的所选权限设置下执行; 或者如果不可能，抛出一个关联的AccessControlException 。
        参数类型
        T - 可调用结果的类型
        参数
        callable - 基础任务
        结果
        可调用对象
        异常
        NullPointerException - 如果可以调用null

      • privilegedCallableUsingCurrentClassLoader

        public static <T> Callable<T> privilegedCallableUsingCurrentClassLoader​(Callable<T> callable)
        返回一个Callable对象，当被调用时，将在当前访问控制上下文中执行给定的callable ，当前上下文类加载器作为上下文类加载器。 通常在一个AccessController.doPrivileged操作中调用此方法来创建可调用的应用程序，如果可能的话，将在该操作中保留的所选权限设置下执行; 或者如果不可能，抛出一个关联的AccessControlException 。
        参数类型
        T - 可调用结果的类型
        参数
        callable - 基础任务
        结果
        可调用对象
        异常
        NullPointerException - 如果可以调用null
        AccessControlException - 如果当前访问控制上下文没有设置和获取上下文类加载器的权限
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExecutorService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface ExecutorService

  • All Superinterfaces:
    Executor
    All Known Subinterfaces:
    ScheduledExecutorService
    所有已知实现类：
    AbstractExecutorService ， ForkJoinPool ， ScheduledThreadPoolExecutor ， ThreadPoolExecutor

    public interface ExecutorService
extends Executor
    一个Executor提供了管理终止的方法和可以产生用于跟踪一个或多个异步任务进度的Future的方法。

    一个ExecutorService可以关闭，这将导致它拒绝新的任务。 提供了两种不同的方法来关闭ExecutorService 。 shutdown()方法将允许先前提交的任务在终止之前执行，而shutdownNow()方法可以防止等待任务启动并尝试停止当前正在执行的任务。 一旦终止，执行者没有任务正在执行，没有任务正在等待执行，并且不能提交新的任务。 应关闭未使用的ExecutorService ，以便资源回收。

    方法submit延伸的基方法Executor.execute(Runnable)通过创建并返回一个Future可用于取消执行和/或等待完成。 方法invokeAny和invokeAll执行批量执行最常用的形式，执行任务集合，然后等待至少一个或全部完成。 （ ExecutorCompletionService类可用于编写这些方法的自定义变体。）

    Executors类为此包中提供的执行程序服务提供了工厂方法。

    用法示例

    这是一个网络服务的草图，其中线程池中的线程服务传入请求。 它使用预配置的Executors.newFixedThreadPool(int)工厂方法：
       class NetworkService implements Runnable { private final ServerSocket serverSocket; private final ExecutorService pool; public NetworkService(int port, int poolSize) throws IOException { serverSocket = new ServerSocket(port); pool = Executors.newFixedThreadPool(poolSize); } public void run() { // run the service try { for (;;) { pool.execute(new Handler(serverSocket.accept())); } } catch (IOException ex) { pool.shutdown(); } } } class Handler implements Runnable { private final Socket socket; Handler(Socket socket) { this.socket = socket; } public void run() { // read and service request on socket } }
    以下方法ExecutorService两个阶段关闭ExecutorService ，首先通过拨打shutdown拒绝接收任务，然后调用shutdownNow ，如有必要，可以取消任何延迟任务：
       void shutdownAndAwaitTermination(ExecutorService pool) { pool.shutdown(); // Disable new tasks from being submitted try { // Wait a while for existing tasks to terminate if (!pool.awaitTermination(60, TimeUnit.SECONDS)) { pool.shutdownNow(); // Cancel currently executing tasks // Wait a while for tasks to respond to being cancelled if (!pool.awaitTermination(60, TimeUnit.SECONDS)) System.err.println("Pool did not terminate"); } } catch (InterruptedException ie) { // (Re-)Cancel if current thread also interrupted pool.shutdownNow(); // Preserve interrupt status Thread.currentThread().interrupt(); } }

    内存一致性效果：操作在提交之前的螺纹Runnable或Callable任务到ExecutorService happen-before由任务采取的任何行动，这反过来又发生-之前结果通过检索Future.get() 。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean awaitTermination​(long timeout, TimeUnit unit)
      阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
      <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。
      <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。
      <T> T invokeAny​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回成功完成的结果（即，不抛出异常），如果有的话。
      <T> T invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。
      boolean isShutdown​()
      如果这个执行者已被关闭，则返回 true 。
      boolean isTerminated​()
      如果所有任务在关闭后完成，则返回 true 。
      void shutdown​()
      启动有序关闭，其中先前提交的任务将被执行，但不会接受任何新任务。
      List<Runnable> shutdownNow​()
      尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。
      Future<?> submit​(Runnable task)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> Future<T> submit​(Runnable task, T result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> Future<T> submit​(Callable<T> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。

      • Methods inherited from interface java.util.concurrent.Executor

        execute

    • 方法详细信息

      • shutdown

        void shutdown​()
        启动有序关闭，其中先前提交的任务将被执行，但不会接受任何新任务。 如果已经关闭，调用没有额外的作用。

        此方法不等待以前提交的任务完成执行。 使用awaitTermination来做到这一点。

        异常
        SecurityException -如果安全管理器存在并且关闭，此ExecutorService可能操作的调用者不允许修改，因为它不保存线程RuntimePermission ("modifyThread") ，或者安全管理器的checkAccess方法拒绝。

      • shutdownNow

        List<Runnable> shutdownNow​()
        尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。

        此方法不等待主动执行的任务终止。 使用awaitTermination来做到这一点。

        除了努力尝试停止处理积极执行任务之外，没有任何保证。 例如，典型的实现将通过Thread.interrupt()取消，所以不能响应中断的任何任务可能永远不会终止。

        结果
        从未开始执行的任务列表
        异常
        SecurityException - 如果安全管理器存在并关闭此ExecutorService可能会操纵调用者不允许修改的线程，因为它不保留RuntimePermission ("modifyThread")或安全管理器的checkAccess方法拒绝访问。

      • isShutdown

        boolean isShutdown​()
        如果此执行者已被关闭，则返回 true 。
        结果
        true如果这个执行者已被关闭

      • isTerminated

        boolean isTerminated​()
        如果所有任务在关闭后完成，则返回true 。 请注意， isTerminated从不是true除非shutdown或shutdownNow被称为第一。
        结果
        true如果所有任务在关闭后完成

      • awaitTermination

        boolean awaitTermination​(long timeout,
                         TimeUnit unit)
                  throws InterruptedException
        阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
        参数
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        true如果这个执行者终止，而 false如果终止之前的超时时间
        异常
        InterruptedException - 如果中断等待

      • submit

        <T> Future<T> submit​(Callable<T> task)
        提交值返回任务以执行，并返回代表任务待处理结果的Future。 get

        如果您想立即阻止等待任务，您可以使用result = exec.submit(aCallable).get();格式的result = exec.submit(aCallable).get();

        注意： Executors类包括一组可以将其他常见的类似闭包的对象（例如PrivilegedAction）转换为Callable表单的方法，以便它们可以提交。

        参数类型
        T - 任务结果的类型
        参数
        task - 提交的任务
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果任务为空

      • submit

        <T> Future<T> submit​(Runnable task,
                     T result)
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 未来的get方法将在成功完成后返回给定的结果。
        参数类型
        T - 结果的类型
        参数
        task - 要提交的任务
        result - 结果返回
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果任务为空

      • submit

        Future<?> submit​(Runnable task)
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 未来的get方法将在成功完成后返回null 。
        参数
        task - 要提交的任务
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果任务为空

      • invokeAll

        <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks)
                       throws InterruptedException
        执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。 Future.isDone()是true的返回列表的每个元素。 请注意， 完成的任务可能会正常终止或抛出异常。 如果在此操作进行过程中修改了给定的集合，则此方法的结果是未定义的。
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        结果
        表示任务的期货列表，按照给定任务列表的迭代器产生的顺序顺序，每个都已完成
        异常
        InterruptedException - 如果在等待时中断，在这种情况下未完成的任务被取消
        NullPointerException - 如果任务或其任何元素是 null
        RejectedExecutionException - 如果任何任务无法安排执行

      • invokeAll

        <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks,
                              long timeout,
                              TimeUnit unit)
                       throws InterruptedException
        执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。 对于返回的列表的每个元素， Future.isDone()是true 。 退货后，尚未完成的任务将被取消。 请注意， 完成的任务可能会正常终止或抛出异常。 如果在此操作进行过程中修改了给定的集合，则此方法的结果是未定义的。
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        一个表示任务的期货列表，按照给定任务列表的迭代器生成的顺序。 如果操作没有超时，每个任务都会完成。 如果超时，其中一些任务将不会完成。
        异常
        InterruptedException - 如果在等待时中断，在这种情况下未完成的任务将被取消
        NullPointerException - 如果任务，其任何元素或单位是 null
        RejectedExecutionException - 如果任何任务无法安排执行

      • invokeAny

        <T> T invokeAny​(Collection<? extends Callable<T>> tasks)
         throws InterruptedException,
                ExecutionException
        执行给定的任务，返回成功完成的结果（即，不抛出异常），如果有的话。 正常或异常退货后，尚未完成的任务将被取消。 如果在此操作进行过程中修改了给定的集合，则此方法的结果是未定义的。
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        结果
        其中一个任务返回的结果
        异常
        InterruptedException - 如果中断等待
        NullPointerException - 如果执行任务或任何元素任务是 null
        IllegalArgumentException - 如果任务为空
        ExecutionException - 如果没有任务成功完成
        RejectedExecutionException - 如果任务无法安排执行

      • invokeAny

        <T> T invokeAny​(Collection<? extends Callable<T>> tasks,
                long timeout,
                TimeUnit unit)
         throws InterruptedException,
                ExecutionException,
                TimeoutException
        执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。 正常或异常退货后，尚未完成的任务将被取消。 如果在此操作进行过程中修改了给定的集合，则此方法的结果是未定义的。
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        其中一个任务返回的结果
        异常
        InterruptedException - 如果在等待时中断
        NullPointerException - 如果任务或单位或任何要执行的元素任务是 null
        TimeoutException - 如果给定的超时在任务成功完成之前 TimeoutException
        ExecutionException - 如果没有任务成功完成
        RejectedExecutionException - if tasks cannot be scheduled for execution
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Flow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class Flow

  • java.lang.Object
    • java.util.concurrent.Flow

  • public final class Flow
extends Object
    用于建立流量控制组件的相互关联的接口和静态方法，其中Publishers生成由一个或多个Subscribers消耗的项目，每个由Subscription管理。

    这些接口对应于reactive-streams规范。 它们适用于并发和分布式异步设置：全部（七）方法在void “单向”消息样式中定义。 通信依赖于一种简单的流控制形式（方法Flow.Subscription.request(long) ），可用于避免在“推”式系统中可能出现的资源管理问题。

    例子。 A Flow.Publisher通常定义自己的Flow.Subscription实现; 在方法subscribe构造一个并将其发送到呼叫Flow.Subscriber 。 它通过异步方式向用户发布项目，通常使用Executor 。 例如，这是一个非常简单的发行商，只向一个订户发出一个单独的TRUE项目（当请求时）。 因为订户只接收一个项目，所以这个类不使用大多数实现中所需的缓冲和排序控制（例如SubmissionPublisher ）。

       class OneShotPublisher implements Publisher<Boolean> { private final ExecutorService executor = ForkJoinPool.commonPool(); // daemon-based private boolean subscribed; // true after first subscribe public synchronized void subscribe(Subscriber<? super Boolean> subscriber) { if (subscribed) subscriber.onError(new IllegalStateException()); // only one allowed else { subscribed = true; subscriber.onSubscribe(new OneShotSubscription(subscriber, executor)); } } static class OneShotSubscription implements Subscription { private final Subscriber<? super Boolean> subscriber; private final ExecutorService executor; private Future<?> future; // to allow cancellation private boolean completed; OneShotSubscription(Subscriber<? super Boolean> subscriber, ExecutorService executor) { this.subscriber = subscriber; this.executor = executor; } public synchronized void request(long n) { if (n != 0 && !completed) { completed = true; if (n < 0) { IllegalArgumentException ex = new IllegalArgumentException(); executor.execute(() -> subscriber.onError(ex)); } else { future = executor.submit(() -> { subscriber.onNext(Boolean.TRUE); subscriber.onComplete(); }); } } } public synchronized void cancel() { completed = true; if (future != null) future.cancel(false); } } }

    A Flow.Subscriber安排要求和处理的项目。 项目（调用Flow.Subscriber.onNext(T) ）除非另有要求，否则不发出，但可能需要多个项目。 许多订阅者实现可以按照以下示例的风格来排列，其中缓冲区大小为1个单步和较大的大小通常允许更少的通信进行更有效的重叠处理; 例如值为64，这将保持32到64之间的未完成请求。由于给定的Flow.Subscription的订阅方法调用是严格排序的，除非订阅者维护多个订阅，否则这些方法不需要使用锁或挥发性最好是定义多个订阅者，每个订阅者都有自己的订阅）。

       class SampleSubscriber<T> implements Subscriber<T> { final Consumer<? super T> consumer; Subscription subscription; final long bufferSize; long count; SampleSubscriber(long bufferSize, Consumer<? super T> consumer) { this.bufferSize = bufferSize; this.consumer = consumer; } public void onSubscribe(Subscription subscription) { long initialRequestSize = bufferSize; count = bufferSize - bufferSize / 2; // re-request when half consumed (this.subscription = subscription).request(initialRequestSize); } public void onNext(T item) { if (--count <= 0) subscription.request(count = bufferSize - bufferSize / 2); consumer.accept(item); } public void onError(Throwable ex) { ex.printStackTrace(); } public void onComplete() {} }

    默认值defaultBufferSize()可能为基于预期利率，资源和用途的流量组件中选择请求大小和容量提供了有用的起点。 或者，当不需要流量控制时，用户可以最初请求有效无限数量的项目，如：

       class UnboundedSubscriber<T> implements Subscriber<T> { public void onSubscribe(Subscription subscription) { subscription.request(Long.MAX_VALUE); // effectively unbounded } public void onNext(T item) { use(item); } public void onError(Throwable ex) { ex.printStackTrace(); } public void onComplete() {} void use(T item) { ... } }
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static interface  Flow.Processor<T,R>
      作为订阅者和发布者的组件。
      static interface  Flow.Publisher<T>
      订阅者接收的项目（和相关控制消息）的生产者。
      static interface  Flow.Subscriber<T>
      消息的接收者。
      static interface  Flow.Subscription
      消息控件链接Flow.Publisher和Flow.Subscriber 。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static int defaultBufferSize​()
      返回发布者或订阅者缓冲的默认值，可以在没有其他约束的情况下使用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • defaultBufferSize

        public static int defaultBufferSize​()
        返回发布者或订阅者缓冲的默认值，可以在没有其他约束的情况下使用。
        Implementation Note:
        返回的当前值为256。
        结果
        缓冲区大小值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Flow.Processor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface Flow.Processor<T,R>

  • 参数类型
    T - 订阅的项目类型
    R - 已发布的项目类型
    All Superinterfaces:
    Flow.Publisher<R> ， Flow.Subscriber<T>
    Enclosing class:
    Flow

    public static interface Flow.Processor<T,R>
extends Flow.Subscriber<T>, Flow.Publisher<R>
    作为订阅者和发布者的组件。

    • 方法摘要

      • Methods inherited from interface java.util.concurrent.Flow.Publisher

        subscribe

      • Methods inherited from interface java.util.concurrent.Flow.Subscriber

        onComplete, onError, onNext, onSubscribe
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Flow.Publisher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface Flow.Publisher<T>

  • 参数类型
    T - 已发布的项目类型
    All Known Subinterfaces:
    Flow.Processor<T,R> ， HttpRequest.BodyProcessor
    所有已知实现类：
    SubmissionPublisher
    Enclosing class:
    Flow
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public static interface Flow.Publisher<T>
    订阅者接收的项目（和相关控制消息）的生产者。 每个当前的Flow.Subscriber以相同的顺序接收相同的项目（通过方法onNext ），除非遇到丢失或错误。 如果发布商遇到不允许向订阅者发出项目的错误，该订阅者将收到onError ，然后不再收到任何消息。 否则，当知道不再发送其他消息时，订户接收onComplete 。 发行商确保每个订阅的订阅者方法调用是严格按照happens-before订购的。

    发布商可能会因为是否丢弃（由于资源限制而发出项目的失败）被视为不可恢复的错误而在政策上有差异。 发布商也可能会因订阅者是否收到在订阅之前生成或可用的项目而有所不同。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void subscribe​(Flow.Subscriber<? super T> subscriber)
      如果可能，添加给定的订阅者。

    • 方法详细信息

      • subscribe

        void subscribe​(Flow.Subscriber<? super T> subscriber)
        如果可能，添加给定的订阅者。 如果已经认购，或认购的尝试失败，因为违反政策或错误，用户的onError方法被调用与IllegalStateException 。 否则，将使用新的Flow.Subscription调用订阅者的onSubscribe方法。 订阅者可以通过调用此订阅的request方法来启用接收项，并可通过调用其cancel方法取消订阅。
        参数
        subscriber - 订户
        异常
        NullPointerException - 如果用户为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Flow.Subscriber (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface Flow.Subscriber<T>

  • 参数类型
    T - 订阅的项目类型
    All Known Subinterfaces:
    Flow.Processor<T,R> ， HttpResponse.BodyProcessor<T>
    Enclosing class:
    Flow

    public static interface Flow.Subscriber<T>
    消息的接收者。 对于每个Flow.Subscription ，该接口中的方法以严格的顺序调用。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void onComplete​()
      当已知对于还没有被错误终止的订阅不会发生额外的订户方法调用时，调用方法，之后订阅不会调用其他订阅者方法。
      void onError​(Throwable throwable)
      由发布商或订阅者遇到的不可恢复错误调用方法，之后订阅不会调用其他订阅者方法。
      void onNext​(T item)
      使用订阅的下一个项目调用的方法。
      void onSubscribe​(Flow.Subscription subscription)
      在调用给定订阅的任何其他订阅者方法之前调用的方法。

    • 方法详细信息

      • onSubscribe

        void onSubscribe​(Flow.Subscription subscription)
        在调用给定订阅的任何其他订阅者方法之前调用的方法。 如果此方法抛出异常，则不能保证产生的行为，但可能导致订阅不被建立或被取消。

        通常，该方法的实现调用subscription.request以启用接收项目。

        参数
        subscription - 新订阅

      • onNext

        void onNext​(T item)
        使用订阅的下一个项目调用的方法。 如果此方法抛出异常，则不能保证产生的行为，但可能导致订阅被取消。
        参数
        item - 该项目

      • onError

        void onError​(Throwable throwable)
        由发布商或订阅者遇到的不可恢复错误调用方法，之后订阅不会调用其他订阅者方法。 如果此方法本身引发异常，则导致行为未定义。
        参数
        throwable - 例外

      • onComplete

        void onComplete​()
        当已知对于还没有被错误终止的订阅不会发生额外的订户方法调用时，调用方法，之后订阅不会调用其他订阅者方法。 如果此方法抛出异常，则导致行为未定义。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Flow.Subscription (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface Flow.Subscription

  • Enclosing class:
    Flow

    public static interface Flow.Subscription
    消息控件链接Flow.Publisher和Flow.Subscriber 。 订阅者仅在请求时才收到项目，并可随时取消。 此接口中的方法仅由其订阅者调用; 在其他情况下的用法具有未定义的效果。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void cancel​()
      使订阅者（最终）停止接收消息。
      void request​(long n)
      将给定数 n项目为这个订阅目前未实现的需求。

    • 方法详细信息

      • request

        void request​(long n)
        将给定数量的n项目添加到此订阅的当前未实现的需求中。 如果n小于或等于零，则订户将收到onError信号与IllegalArgumentException参数。 否则，订阅者最多可以收到n额外的onNext调用（如果终止则更少）。
        参数
        n - 需求增量 价值Long.MAX_VALUE可能被视为有效无限

      • cancel

        void cancel​()
        Causes the Subscriber to (eventually) stop receiving messages. Implementation is best-effort -- additional messages may be received after invoking this method. A cancelled subscription need not ever receive an onComplete or onError signal.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ForkJoinPool (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ForkJoinPool

  • java.lang.Object
    • java.util.concurrent.AbstractExecutorService
      • java.util.concurrent.ForkJoinPool
  • All Implemented Interfaces:
    Executor ， ExecutorService

    public class ForkJoinPool
extends AbstractExecutorService
    一个ExecutorService运行ForkJoinTask s。 A ForkJoinPool提供了非ForkJoinTask客户提交的入口以及管理和监控操作。

    A ForkJoinPool与其他类型的ForkJoinPool不同之处主要是采用工作窃取 ：池中的所有线程尝试查找和执行提交到池和/或由其他活动任务创建的任务（最终阻止等待工作，如果不存在） 。 当大多数任务产生其他子任务（大多数ForkJoinTask s）以及许多小任务从外部客户端提交到池时，这样可以实现高效的处理。 尤其是在构造函数设置asyncMode为真时， ForkJoinPool S还可能适合于与事件式的任务中使用那些从未加入。 所有工作线程将初始化为Thread.isDaemon()，设置为true 。

    静态commonPool()可用，适用于大多数应用。 公共池被任何未显式提交到指定池的ForkJoinTask使用。 使用公共池通常会减少资源使用（其线程在不使用期间缓慢回收，并在后续使用时恢复）。

    对于需要单独或自定义池的应用程序，可以使用给定的目标并行级别构建一个ForkJoinPool ; 默认情况下，等于可用处理器的数量。 池尝试通过动态添加，挂起或恢复内部工作线程来维护足够的活动（或可用）线程，即使某些任务停止等待加入其他线程。 但是，面对阻塞的I / O或其他非托管同步，不能保证这样的调整。 嵌套的ForkJoinPool.ManagedBlocker接口可以扩展所容纳的同步类型。 可以使用具有与类ThreadPoolExecutor中记录的参数对应的参数的构造函数来覆盖默认策略。

    除了执行和生命周期控制方法之外，该类还提供了用于帮助开发，调优和监视fork / join应用程序的状态检查方法（例如getStealCount() ）。 而且，方法toString()以方便的形式返回池状态的指示用于非正式监视。

    与其他ExecutorServices的情况一样，下表总结了三个主要任务执行方法。 这些设计主要由尚未在当前池中进行fork / join计算的客户端使用。 这些方法的主要形式接受ForkJoinTask实例，但重载的表单也允许混合执行纯粹的Runnable或基于Callable的活动。 但是，通常情况下，在池中已经执行的任务会使用表中列出的计算内表单，除非使用不通常连接的异步事件式任务，否则在方法选择方面几乎没有区别。

    Summary of task execution methods Call from non-fork/join clients Call from within fork/join computations Arrange async execution execute(ForkJoinTask) ForkJoinTask.fork() Await and obtain result invoke(ForkJoinTask) ForkJoinTask.invoke() Arrange exec and obtain Future submit(ForkJoinTask) ForkJoinTask.fork() (ForkJoinTasks are Futures)

    用于构建公共池的参数可以通过设置以下system properties来控制：

    • java.util.concurrent.ForkJoinPool.common.parallelism - 并行级别，非负整数
    • java.util.concurrent.ForkJoinPool.common.threadFactory - 类名ForkJoinPool.ForkJoinWorkerThreadFactory 。 system class loader用于加载此类。
    • java.util.concurrent.ForkJoinPool.common.exceptionHandler - 类名Thread.UncaughtExceptionHandler 。 system class loader用于加载此类。
    • java.util.concurrent.ForkJoinPool.common.maximumSpares - 维持目标并行度允许的额外线程的最大数量（默认为256）。
    如果没有通过系统属性提供线程工厂，则公共池使用使用系统类加载器的工厂作为thread context class loader 。 另外，如果存在SecurityManager ，则公用池使用一个工厂提供的线程不启用Permissions 。 建立这些设置有任何错误，使用默认参数。 通过将并行属性设置为零，和/或使用可能返回null的工厂，可以禁用或限制公共池中的线程的使用。 但是这样做可能导致未连接的任务永远不会被执行。

    实现注意事项 ：此实现将最大正在运行的线程数限制为32767.尝试创建大于最大数目的池导致IllegalArgumentException 。

    只有当池被关闭或内部资源耗尽时，此实现才会拒绝提交的任务（即通过抛出RejectedExecutionException ）。

    从以下版本开始：
    1.7

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static interface  ForkJoinPool.ForkJoinWorkerThreadFactory
      工厂创建新的ForkJoinWorkerThread s。
      static interface  ForkJoinPool.ManagedBlocker
      用于扩展管理并行性的接口，用于运行在ForkJoinPool中的任务。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static ForkJoinPool.ForkJoinWorkerThreadFactory defaultForkJoinWorkerThreadFactory
      创建一个新的ForkJoinWorkerThread。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ForkJoinPool​()
      创建一个 ForkJoinPool ，并行度等于 Runtime.availableProcessors() ，使用所有其他参数的默认值（见 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
      ForkJoinPool​(int parallelism)
      使用指定的并行级别创建一个 ForkJoinPool ，使用所有其他参数的默认值（见 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
      ForkJoinPool​(int parallelism, ForkJoinPool.ForkJoinWorkerThreadFactory factory, Thread.UncaughtExceptionHandler handler, boolean asyncMode)
      使用给定的参数创建一个 ForkJoinPool （使用默认 值为其他参数 - 请参阅 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
      ForkJoinPool​(int parallelism, ForkJoinPool.ForkJoinWorkerThreadFactory factory, Thread.UncaughtExceptionHandler handler, boolean asyncMode, int corePoolSize, int maximumPoolSize, int minimumRunnable, Predicate<? super ForkJoinPool> saturate, long keepAliveTime, TimeUnit unit)
      用给定的参数创建一个 ForkJoinPool 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean awaitQuiescence​(long timeout, TimeUnit unit)
      如果在此池中操作的ForkJoinTask调用，则相当于 ForkJoinTask.helpQuiesce() 。
      boolean awaitTermination​(long timeout, TimeUnit unit)
      阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
      static ForkJoinPool commonPool​()
      返回公共池实例。
      protected int drainTasksTo​(Collection<? super ForkJoinTask<?>> c)
      从调度队列中删除所有可用的未执行的提交和分派任务，并将其添加到给定集合中，而不会更改其执行状态。
      void execute​(Runnable task)
      在将来的某个时间执行给定的命令。
      void execute​(ForkJoinTask<?> task)
      为异步执行给定任务的排列。
      int getActiveThreadCount​()
      返回当前正在窃取或执行任务的线程数的估计。
      boolean getAsyncMode​()
      返回 true如果此池使用本地先入先出调度模式，用于从未加入的分叉任务。
      static int getCommonPoolParallelism​()
      返回公共池的目标并行度级别。
      ForkJoinPool.ForkJoinWorkerThreadFactory getFactory​()
      返回用于构建新工人的工厂。
      int getParallelism​()
      返回此池的目标并行度级别。
      int getPoolSize​()
      返回已启动但尚未终止的工作线程数。
      int getQueuedSubmissionCount​()
      返回提交给此池尚未开始执行的任务数量的估计。
      long getQueuedTaskCount​()
      返回由工作线程（但不包括提交到池中尚未开始执行的任务）当前在队列中保留的任务总数的估计值。
      int getRunningThreadCount​()
      返回等待加入任务或其他受管同步的未阻止的工作线程数的估计。
      long getStealCount​()
      返回从另一个线程的工作队列中偷取的任务总数的估计值。
      Thread.UncaughtExceptionHandler getUncaughtExceptionHandler​()
      返回由于在执行任务时遇到不可恢复的错误而终止的内部工作线程的处理程序。
      boolean hasQueuedSubmissions​()
      如果有任何任务提交到此池尚未开始执行，则返回 true 。
      <T> T invoke​(ForkJoinTask<T> task)
      执行给定的任务，在完成后返回其结果。
      <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。
      boolean isQuiescent​()
      如果所有工作线程当前处于空闲状态，则返回 true 。
      boolean isShutdown​()
      如果此池已关闭，则返回 true 。
      boolean isTerminated​()
      如果所有任务在关闭后完成，则返回 true 。
      boolean isTerminating​()
      如果终止程序已经开始但尚未完成，则返回 true 。
      static void managedBlock​(ForkJoinPool.ManagedBlocker blocker)
      运行给定的可能的阻止任务。
      protected <T> RunnableFuture<T> newTaskFor​(Runnable runnable, T value)
      对于给定的可运行和默认值，返回一个 RunnableFuture 。
      protected <T> RunnableFuture<T> newTaskFor​(Callable<T> callable)
      为给定的可调用任务返回一个 RunnableFuture 。
      protected ForkJoinTask<?> pollSubmission​()
      删除并返回下一个未执行的提交（如果有）。
      void shutdown​()
      可能启动有序关闭，其中先前提交的任务被执行，但不会接受新的任务。
      List<Runnable> shutdownNow​()
      可能尝试取消和/或停止所有任务，并拒绝所有后续提交的任务。
      ForkJoinTask<?> submit​(Runnable task)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> ForkJoinTask<T> submit​(Runnable task, T result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> ForkJoinTask<T> submit​(Callable<T> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。
      <T> ForkJoinTask<T> submit​(ForkJoinTask<T> task)
      提交一个ForkJoinTask来执行。
      String toString​()
      返回一个标识此池的字符串，以及它的状态，包括运行状态，并行级和工作和任务计数的指示。

      • Methods inherited from class java.util.concurrent.AbstractExecutorService

        invokeAll, invokeAny, invokeAny

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • defaultForkJoinWorkerThreadFactory

        public static final ForkJoinPool.ForkJoinWorkerThreadFactory defaultForkJoinWorkerThreadFactory
        创建一个新的ForkJoinWorkerThread。 该工厂被使用，除非在ForkJoinPool构造函数中被覆盖。

    • 构造方法详细信息

      • ForkJoinPool

        public ForkJoinPool​()
        创建 ForkJoinPool ，并行度等于 Runtime.availableProcessors() ，对所有其他参数使用默认值（见 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
        异常
        SecurityException - 如果安全管理器存在，并且主叫方不允许修改线程，因为它不保留RuntimePermission ("modifyThread")

      • ForkJoinPool

        public ForkJoinPool​(int parallelism)
        使用指定的并行级别创建 ForkJoinPool ，对所有其他参数使用默认值（见 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
        参数
        parallelism - 并行级别
        异常
        IllegalArgumentException - 如果并行度小于或等于零，或大于实现限制
        SecurityException - 如果安全管理器存在，并且主叫方不允许修改线程，因为它不保留RuntimePermission ("modifyThread")

      • ForkJoinPool

        public ForkJoinPool​(int parallelism,
                    ForkJoinPool.ForkJoinWorkerThreadFactory factory,
                    Thread.UncaughtExceptionHandler handler,
                    boolean asyncMode)
        使用给定的参数创建一个 ForkJoinPool （使用默认 值为其他参数 - 请参阅 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
        参数
        parallelism - 并行级别。 默认值为Runtime.availableProcessors() 。
        factory - 创建新线程的工厂。 对于默认值，请使用defaultForkJoinWorkerThreadFactory 。
        handler - 由于执行任务时遇到不可恢复的错误而终止的内部工作线程的处理程序。 默认值为null 。
        asyncMode - 如果为true，请为从未加入的分叉任务建立本地先进先出调度模式。 在工作线程仅处理事件式异步任务的应用程序中，此模式可能比默认的基于本地堆栈的模式更合适。 默认值为false 。
        异常
        IllegalArgumentException - 如果并行性小于或等于零，或大于实现限制
        NullPointerException - 如果工厂为空
        SecurityException - 如果安全管理器存在，并且主叫方不允许修改线程，因为它不持有RuntimePermission ("modifyThread")

      • ForkJoinPool

        public ForkJoinPool​(int parallelism,
                    ForkJoinPool.ForkJoinWorkerThreadFactory factory,
                    Thread.UncaughtExceptionHandler handler,
                    boolean asyncMode,
                    int corePoolSize,
                    int maximumPoolSize,
                    int minimumRunnable,
                    Predicate<? super ForkJoinPool> saturate,
                    long keepAliveTime,
                    TimeUnit unit)
        使用给定的参数创建一个 ForkJoinPool 。
        参数
        parallelism - 并行级别。 默认值为Runtime.availableProcessors() 。
        factory - 创建新线程的工厂。 默认值为defaultForkJoinWorkerThreadFactory 。
        handler - 由于执行任务时遇到不可恢复的错误而终止的内部工作线程的处理程序。 默认值为null 。
        asyncMode - 如果为true，请为从未连接的分叉任务建立本地先进先出调度模式。 在工作线程仅处理事件式异步任务的应用程序中，此模式可能比默认的基于本地堆栈的模式更合适。 默认值为false 。
        corePoolSize - 要保留在池中的线程数（除非在保持活动之后超时）。 通常（和默认情况下）这是与并行级别相同的值，但如果任务定期阻塞，可以将其设置为更大的值以减少动态开销。 使用较小的值（例如0 ）具有与默认值相同的效果。
        maximumPoolSize - 允许的最大线程数。 达到最大值时，尝试替换阻塞的线程失败。 （但是，由于不同线程的创建和终止可能会重叠，并且可能由给定的线程工厂进行管理，所以该值可能会被暂时超过。）为了安排与公共池默认使用的值相同的值，请使用256加上parallelism级。 （默认情况下，公共池允许最多256个备用线程。）使用大于实现的总线程限制的值（例如Integer.MAX_VALUE ）与使用此限制（默认值）具有相同的效果。
        minimumRunnable - 未被连接阻止的核心线程允许的最小数量或ForkJoinPool.ManagedBlocker 。 为了确保进度，当存在未被阻塞的线程太少并且可能存在未执行的任务时，将构建新的线程，直到给定的maximumPoolSize。 对于默认值，请使用1 ，以确保活跃。 更大的值可能会在存在受阻的活动的情况下提高吞吐量，但由于增加的开销可能不会。 当提交的任务不具有需要额外线程的依赖项时，值为零可能是可以接受的。
        saturate - 如果非空，则在尝试创建超过最大总允许线程时调用谓词。 默认情况下，当一个线程即将阻止连接或ForkJoinPool.ManagedBlocker ，但由于将超过maximumPoolSize不能被替换，因此抛出一个RejectedExecutionException 。 但是，如果此谓词返回true ，则不会抛出异常，所以池继续以少于可运行线程的目标数量运行，这可能无法确保进度。
        keepAliveTime - 在线程终止之前自上次使用以来经过的时间（然后如果需要，则稍后更换）。 对于默认值，请使用60, TimeUnit.SECONDS 。
        unit - keepAliveTime参数的时间单位
        异常
        IllegalArgumentException - 如果并行性小于或等于零，或者大于实现限制，或者如果maximumPoolSize小于并行性，则为keepAliveTime小于或等于零。
        NullPointerException - 如果工厂为空
        SecurityException - 如果安全管理器存在，并且主叫方不允许修改线程，因为它不保留RuntimePermission ("modifyThread")
        从以下版本开始：
        9

    • 方法详细信息

      • commonPool

        public static ForkJoinPool commonPool​()
        返回公共池实例。 这个游泳池是静态的; 其运行状态不受尝试shutdown()或shutdownNow()的影响 。 然而，该池和任何正在进行的处理在程序System.exit(int)自动终止。 在程序终止前依赖于异步任务处理完成的任何程序应在退出之前调用commonPool(). awaitQuiescence 。
        结果
        公共池实例
        从以下版本开始：
        1.8

      • invoke

        public <T> T invoke​(ForkJoinTask<T> task)
        执行给定的任务，在完成后返回其结果。 如果计算遇到未检查的异常或错误，则将其重新定义为此调用的结果。 Rethrown异常的行为与常规异常的方式相同，但是尽可能包含当前线程以及实际遇到异常的线程的堆栈跟踪（例如使用ex.printStackTrace()显示）; 最低限度只有后者。
        参数类型
        T - 任务结果的类型
        参数
        task - 任务
        结果
        任务的结果
        异常
        NullPointerException - 如果任务为空
        RejectedExecutionException - 如果该任务无法安排执行

      • execute

        public void execute​(ForkJoinTask<?> task)
        为异步执行给定任务的排列。
        参数
        task - 任务
        异常
        NullPointerException - 如果任务为空
        RejectedExecutionException - 如果该任务无法安排执行

      • execute

        public void execute​(Runnable task)
        说明从界面： Executor复制
        在将来的某个时间执行给定的命令。 该命令可以在一个新线程，一个合并的线程中或在调用线程中执行，由Executor实现决定。
        参数
        task - 可运行的任务
        异常
        NullPointerException - 如果任务为空
        RejectedExecutionException - 如果任务无法安排执行

      • submit

        public <T> ForkJoinTask<T> submit​(ForkJoinTask<T> task)
        提交一个ForkJoinTask来执行。
        参数类型
        T - 任务结果的类型
        参数
        task - 要提交的任务
        结果
        任务
        异常
        NullPointerException - 如果任务为空
        RejectedExecutionException - 如果任务无法安排执行

      • submit

        public <T> ForkJoinTask<T> submit​(Callable<T> task)
        说明从界面： ExecutorService复制
        提交值返回任务以执行，并返回代表任务待处理结果的Future。 未来的get方法将在成功完成后返回任务的结果。

        如果您想立即阻止等待任务，您可以使用表单result = exec.submit(aCallable).get();

        注意： Executors类包括一组可以将其他常见的类似闭包的对象（例如PrivilegedAction）转换为Callable表单的方法，以便它们可以提交。

        Specified by:
        submit接口 ExecutorService
        重写：
        submit在 AbstractExecutorService
        参数类型
        T - 任务结果的类型
        参数
        task - 提交的任务
        结果
        一个未来的代表，待完成任务
        异常
        NullPointerException - 如果任务为空
        RejectedExecutionException - 如果任务无法安排执行

      • submit

        public <T> ForkJoinTask<T> submit​(Runnable task,
                                  T result)
        描述从接口ExecutorService复制
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 未来的get方法将在成功完成后返回给定的结果。
        Specified by:
        submit在接口 ExecutorService
        重写：
        submit在 AbstractExecutorService
        参数类型
        T - 结果的类型
        参数
        task - 要提交的任务
        result - 结果返回
        结果
        一个未来的代表，待完成任务
        异常
        NullPointerException - 如果任务为空
        RejectedExecutionException - 如果该任务无法安排执行

      • submit

        public ForkJoinTask<?> submit​(Runnable task)
        说明从界面复制： ExecutorService
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 未来的get方法将在成功完成后返回null 。
        Specified by:
        submit在接口 ExecutorService
        重写：
        submit在 AbstractExecutorService
        参数
        task - 要提交的任务
        结果
        一个未来的代表，待完成任务
        异常
        NullPointerException - 如果任务为空
        RejectedExecutionException - 如果该任务无法安排执行

      • invokeAll

        public <T> List<Future<T>> invokeAll​(Collection<? extends Callable<T>> tasks)
        描述从接口ExecutorService复制
        执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。 Future.isDone()对于返回列表的每个元素是true 。 请注意， 完成的任务可能会正常终止或抛出异常。 如果在此操作进行过程中修改了给定的集合，则此方法的结果是未定义的。
        Specified by:
        invokeAll在接口 ExecutorService
        重写：
        invokeAll在 AbstractExecutorService
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        结果
        表示任务的期货列表，按照给定任务列表的迭代器产生的顺序顺序，每个都已完成
        异常
        NullPointerException - 如果任务或其任何元素是 null
        RejectedExecutionException - 如果任何任务无法安排执行

      • getFactory

        public ForkJoinPool.ForkJoinWorkerThreadFactory getFactory​()
        返回用于构建新工人的工厂。
        结果
        工厂用于建设新工人

      • getUncaughtExceptionHandler

        public Thread.UncaughtExceptionHandler getUncaughtExceptionHandler​()
        返回由于在执行任务时遇到不可恢复的错误而终止的内部工作线程的处理程序。
        结果
        处理程序，或 null如果没有

      • getParallelism

        public int getParallelism​()
        返回此池的目标并行度级别。
        结果
        这个池的目标平行度水平

      • getCommonPoolParallelism

        public static int getCommonPoolParallelism​()
        返回公共池的目标并行度级别。
        结果
        共同池的目标平行度水平
        从以下版本开始：
        1.8

      • getPoolSize

        public int getPoolSize​()
        返回已启动但尚未终止的工作线程数。 该方法返回的结果可能与getParallelism()不同，当创建线程以在其他协作被阻止时保持并行性。
        结果
        工作线程数

      • getAsyncMode

        public boolean getAsyncMode​()
        返回 true如果此池使用从未连接的分叉任务的本地先进先出调度模式。
        结果
        true如果此池使用异步模式

      • getRunningThreadCount

        public int getRunningThreadCount​()
        返回等待加入任务或其他受管同步的未阻止的工作线程数的估计。 此方法可能会高估正在运行的线程数。
        结果
        工作线程数

      • getActiveThreadCount

        public int getActiveThreadCount​()
        返回当前正在窃取或执行任务的线程数的估计。 此方法可能会高估活动线程的数量。
        结果
        活动线程的数量

      • isQuiescent

        public boolean isQuiescent​()
        如果所有工作线程当前处于空闲状态，则返回true 。 空闲的工作者是无法获取执行任务的工作，因为没有可用于从其他线程窃取，并且没有等待提交给池。 这种方法是保守的 它可能不会立即返回true所有线程空闲，但如果线程保持不活动，最终将成为true。
        结果
        如果所有线程当前处于空闲状态， true

      • getStealCount

        public long getStealCount​()
        返回从另一个线程的工作队列中偷取的任务总数的估计值。 报告的价值低估了池不是静止时的实际偷窃总数。 该值可能对于监视和调优fork / join程序很有用：通常来说，窃取计数应该足够高以保持线程忙，但足够低以避免线程间的开销和争用。
        结果
        偷窃的次数

      • getQueuedTaskCount

        public long getQueuedTaskCount​()
        返回由工作线程（但不包括提交到池中尚未开始执行的任务）当前在队列中保留的任务总数的估计值。 该值只是通过遍历池中的所有线程获得的近似值。 此方法对于调整任务粒度可能很有用。
        结果
        排队任务的数量

      • getQueuedSubmissionCount

        public int getQueuedSubmissionCount​()
        返回提交给此池尚未开始执行的任务数量的估计。 该方法可能需要与提交的数量成比例的时间。
        结果
        排队提交的数量

      • hasQueuedSubmissions

        public boolean hasQueuedSubmissions​()
        如果有任何任务提交到此池尚未开始执行，则返回 true 。
        结果
        true如果有任何排队的提交

      • pollSubmission

        protected ForkJoinTask<?> pollSubmission​()
        删除并返回下一个未执行的提交（如果有）。 此方法在对具有多个池的系统中重新分配工作的此类的扩展中可能很有用。
        结果
        下一次提交，或 null如果没有

      • drainTasksTo

        protected int drainTasksTo​(Collection<? super ForkJoinTask<?>> c)
        从调度队列中删除所有可用的未执行的提交和分派任务，并将其添加到给定集合中，而不会更改其执行状态。 这些可能包括人为生成或包装的任务。 该方法仅在池已知静止时被调用。 其他时间的调用可能不会删除所有任务。 尝试向集合c添加元素时遇到的失败可能导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        参数
        c - 将元素传输到的集合
        结果
        转移的元素数量

      • toString

        public String toString​()
        返回一个标识此池的字符串，以及它的状态，包括运行状态，并行级和工作和任务计数的指示。
        重写：
        toString在 Object
        结果
        一个标识这个池的字符串，以及它的状态

      • shutdown

        public void shutdown​()
        可能启动有序关闭，其中先前提交的任务被执行，但不会接受新的任务。 如果这是commonPool() ，调用对执行状态没有影响，如果已经关闭，则不起作用。 在此方法过程中同时提交的任务可能会被拒绝，也可能不会被拒绝。
        异常
        SecurityException - 如果安全管理器存在，并且主叫方不允许修改线程，因为它不保留RuntimePermission ("modifyThread")

      • shutdownNow

        public List<Runnable> shutdownNow​()
        可能尝试取消和/或停止所有任务，并拒绝所有后续提交的任务。 如果这是commonPool() ，调用对执行状态没有影响，如果已经关闭，则不起作用。 否则，在此方法过程中同时提交或执行的任务可能会被拒绝也可能不会被拒绝。 该方法取消现有和未执行的任务，以便在存在任务依赖性的情况下允许终止。 所以方法总是返回一个空列表（与其他执行程序不同）。
        结果
        一个空的列表
        异常
        SecurityException - 如果安全管理器存在并且调用者不允许修改线程，因为它不保留RuntimePermission ("modifyThread")

      • isTerminated

        public boolean isTerminated​()
        如果所有任务在关闭后完成，则返回 true 。
        结果
        true如果所有任务在关闭后已经完成

      • isTerminating

        public boolean isTerminating​()
        如果终止程序已经开始但尚未完成，则返回true 。 此方法可能对调试有用。 返回true报告了关闭后的足够的时间可能表明提交的任务已经忽略或抑制中断，或者正在等待I / O，导致执行器不能正常终止。 （见ForkJoinTask的咨询说明，说明任务通常不应该阻塞操作，但如果这样做，则必须中断它们）。
        结果
        true如果终止但尚未终止

      • isShutdown

        public boolean isShutdown​()
        如果此池已关闭，则返回 true 。
        结果
        true如果这个池已被关闭

      • awaitTermination

        public boolean awaitTermination​(long timeout,
                                TimeUnit unit)
                         throws InterruptedException
        阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。 因为commonPool()从不终止，直到程序关闭，当应用于公共池时，此方法相当于awaitQuiescence(long, TimeUnit)，但始终返回false 。
        参数
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        true如果这个执行者终止并且 false如果终止之前的超时时间
        异常
        InterruptedException - 如果在等待时中断

      • awaitQuiescence

        public boolean awaitQuiescence​(long timeout,
                               TimeUnit unit)
        如果被这个池中的一个ForkJoinTask调用，相当于ForkJoinTask.helpQuiesce() 。 否则，等待和/或尝试协助执行任务，直到该池isQuiescent()或指示的超时过去。
        参数
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        true如果静止; false如果超时已过。

      • managedBlock

        public static void managedBlock​(ForkJoinPool.ManagedBlocker blocker)
                         throws InterruptedException
        运行给定的可能的阻止任务。 当running in a ForkJoinPool时 ，如果需要 ，该方法可能会排列备用线程，以确保当前线程在blocker.block()中被阻塞时的足够的并行性 。

        该方法重复调用blocker.isReleasable()和blocker.block()直到任一方法返回true 。 每次拨打blocker.block()之前都会打电话给blocker.isReleasable() ，返回false 。

        如果没有在ForkJoinPool中运行，则此方法在行为上相当于

           while (!blocker.isReleasable()) if (blocker.block()) break;
        如果在ForkJoinPool中运行，则可以首先扩展池，以确保在呼叫期间提供足够的并行性为blocker.block() 。
        参数
        blocker - 阻止任务
        异常
        InterruptedException - 如果 blocker.block()这样做

      • newTaskFor

        protected <T> RunnableFuture<T> newTaskFor​(Runnable runnable,
                                           T value)
        描述从类别复制： AbstractExecutorService
        为给定的可运行和默认值返回一个 RunnableFuture 。
        重写：
        newTaskFor在 AbstractExecutorService
        参数类型
        T - 给定值的类型
        参数
        runnable - 正在包装的可运行任务
        value - 返回的未来的默认值
        结果
        一个 RunnableFuture ，当运行时，将运行底层可运行程序，并作为一个 Future ，将产生给定的值作为其结果，并提供取消基础任务

      • newTaskFor

        protected <T> RunnableFuture<T> newTaskFor​(Callable<T> callable)
        描述从类复制： AbstractExecutorService
        为给定的可调用任务返回一个 RunnableFuture 。
        重写：
        newTaskFor在 AbstractExecutorService
        参数类型
        T - 可调用结果的类型
        参数
        callable - 被打包的可执行任务
        结果
        一个 RunnableFuture ，当运行时，将调用底层可调用，作为一个 Future ，将作为其结果产生可调用的结果，并提供取消基础任务
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ForkJoinPool.ForkJoinWorkerThreadFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface ForkJoinPool.ForkJoinWorkerThreadFactory

  • Enclosing class:
    ForkJoinPool

    public static interface ForkJoinPool.ForkJoinWorkerThreadFactory
    工厂创建新的ForkJoinWorkerThread s。 A ForkJoinWorkerThreadFactory必须定义并用于扩展基本功能或初始化具有不同上下文的线程的ForkJoinWorkerThread子类。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ForkJoinWorkerThread newThread​(ForkJoinPool pool)
      返回在给定池中运行的新工作线程。

    • 方法详细信息

      • newThread

        ForkJoinWorkerThread newThread​(ForkJoinPool pool)
        返回在给定池中运行的新工作线程。 返回null或引发异常可能导致任务从不执行。 如果此方法引发异常，则将其中继到方法的调用者（例如execute ），从而导致尝试的线程创建。 如果此方法返回null或引发异常，则不会重试，直到下次尝试创建（例如另一个调用execute ）。
        参数
        pool - 此线程工作的池
        结果
        新的工作线程，或 null如果请求创建线程被拒绝
        异常
        NullPointerException - if the pool is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ForkJoinPool.ManagedBlocker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface ForkJoinPool.ManagedBlocker

  • Enclosing class:
    ForkJoinPool

    public static interface ForkJoinPool.ManagedBlocker
    用于扩展管理并行性的接口，用于在ForkJoinPool中运行的任务。

    A ManagedBlocker提供了两种方法。 如果不需要阻塞，方法isReleasable()必须返回true 。 方法block()在必要时阻止当前线程（可能在实际阻止之前内部调用isReleasable ）。 这些操作通过调用ForkJoinPool.managedBlock(ManagedBlocker)的任何线程执行。 此API中的不寻常方法适用于可能但通常不会长时间阻塞的同步器。 同样，它们允许更有效的内部处理案件，其中需要额外的工作人员，但通常不需要确保充分的并行性。 为此，方法isReleasable实现必须适于重复调用。

    例如，这里是一个基于ReentrantLock的ManagedBlocker：

       class ManagedLocker implements ManagedBlocker { final ReentrantLock lock; boolean hasLock = false; ManagedLocker(ReentrantLock lock) { this.lock = lock; } public boolean block() { if (!hasLock) lock.lock(); return true; } public boolean isReleasable() { return hasLock || (hasLock = lock.tryLock()); } }

    这是一个可能阻止等待给定队列上的项目的类：

       class QueueTaker<E> implements ManagedBlocker { final BlockingQueue<E> queue; volatile E item = null; QueueTaker(BlockingQueue<E> q) { this.queue = q; } public boolean block() throws InterruptedException { if (item == null) item = queue.take(); return true; } public boolean isReleasable() { return item != null || (item = queue.poll()) != null; } public E getItem() { // call after pool.managedBlock completes return item; } }

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean block​()
      可能阻止当前线程，例如等待锁或条件。
      boolean isReleasable​()
      如果不需要阻塞，则返回 true 。

    • 方法详细信息

      • block

        boolean block​()
       throws InterruptedException
        可能阻止当前线程，例如等待锁或条件。
        结果
        true如果不需要额外的阻塞（即，如果isReleasable将返回true）
        异常
        InterruptedException - 如果在等待时中断（该方法不需要这样做，但允许）

      • isReleasable

        boolean isReleasable​()
        如果不需要阻塞，则返回 true 。
        结果
        true如果阻塞是不必要的
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ForkJoinTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ForkJoinTask<V>

  • java.lang.Object
    • java.util.concurrent.ForkJoinTask<V>
  • All Implemented Interfaces:
    Serializable ， Future<V>
    已知直接子类：
    CountedCompleter ， RecursiveAction ， RecursiveTask

    public abstract class ForkJoinTask<V>
extends Object
implements Future<V>, Serializable
    在ForkJoinPool内运行的任务的抽象基类。 A ForkJoinTask是一个线程实体，比正常线程重得多。 大量任务和子任务可能由ForkJoinPool中的少量实际线程托管，价格为某些使用限制。

    A“主” ForkJoinTask开始执行时，明确提出到ForkJoinPool ，或者，如果不是已经从事ForkJoin计算，在开始ForkJoinPool.commonPool()通过fork() ， invoke() ，或相关方法。 一旦开始，它通常反过来启动其他子任务。 如该类的名称所示，使用ForkJoinTask许多程序ForkJoinTask使用方法fork()和join() ，或衍生物，例如invokeAll 。 然而，这个课程还提供了许多可以在高级用途中发挥作用的其他方法，以及允许支持新形式的叉/连接处理的扩展机制。

    A ForkJoinTask是一个轻量级的形式Future 。 ForkJoinTask的效率源于一组限制（只有部分可静态执行），反映出它们主要用作计算纯函数或在纯孤立对象上运行的计算任务。 主要的协调机制是fork() ，即安排异步执行，并join() ，不继续，直到任务的结果被计算出来。 理想情况下，计算应避免使用synchronized方法或块，并应尽可能减少其他阻塞同步，除了加入其他任务，或者使用同步器，例如被广告与fork / join调度合作的激活器。 可分割的任务也不应该执行阻塞I / O，理想情况下，访问完全独立于其他运行任务访问的变量。 这些指南通过不允许抛出例如IOExceptions等检查异常来宽松地执行。 但是，计算可能仍然会遇到未经检查的异常，这些异常被转移给尝试加入它们的呼叫者。 这些例外可能还包括来自内部资源耗尽的RejectedExecutionException ，例如无法分配内部任务队列。 Rethrown异常的行为与常规异常的方式相同，但如果可能，则包含启动计算的线程以及实际遇到异常的线程的堆栈跟踪（例如使用ex.printStackTrace()显示）; 最低限度只有后者。

    可以定义和使用可能会阻塞的ForkJoinTasks，但这样做需要三个进一步的考虑：（1）如果任何其他任务应该依赖于阻塞外部同步或I / O的任务，则完成很少。 事件风格的异步任务从未加入（例如，这些子类CountedCompleter ）通常属于此类别。 （2）尽量减少资源影响，任务要小; 理想地仅执行（可能）阻塞动作。 （3）除非使用ForkJoinPool.ManagedBlocker API，否则已知可能已阻止的任务数量小于池的ForkJoinPool.getParallelism()级别， 否则池不能保证有足够的线程可用于确保进度或性能良好。

    等待完成和提取任务结果的主要方法是join() ，但有几个变体： Future.get()方法支持可中断和/或定时等待完成，并使用Future约定报告结果。 方法invoke()在语义上等同于fork(); join()但总是尝试在当前线程中开始执行。 这些方法的“ 安静 ”形式不能提取结果或报告异常。 当执行一组任务时，这些可能很有用，并且您需要延迟对结果或异常的处理，直到完成。 方法invokeAll （可用于多个版本）执行最常见的并行调用形式：分派一组任务并将其全部加入。

    在最典型的用法中，fork-join对就像一个调用（fork）并从并行递归函数返回（join）。 与其他形式的递归调用一样，返回（连接）应该是最内层的。 例如， a.fork(); b.fork(); b.join(); a.join();很可能是显着大于接合更有效a之前b 。

    任务的执行状态可以在多个细节级别查询：如果任务以任何方式完成（包括任务被取消而不执行的情况）， 则为isDone() ; isCompletedNormally()如果任务在没有取消或遇到异常的情况下完成，则为true; isCancelled()如果任务被取消，则为true（在这种情况下， getException()返回一个CancellationException ）; 如果任务被取消或遇到异常，则isCompletedAbnormally()为true，在这种情况下， getException()将返回遇到的异常或CancellationException 。

    ForkJoinTask类通常不是直接子类。 相反，你继承了支持叉的特定风格/连接处理，通常是抽象类的一个RecursiveAction对于不返回结果大多数计算， RecursiveTask对于那些做的， CountedCompleter对于那些在已完成的操作触发其它动作。 通常，具体的ForkJoinTask子类声明包含在构造函数中建立的参数的字段，然后定义一种以某种方式使用此基类提供的控制方法的compute方法。

    方法join()及其变体仅在完成依赖关系为非循环时才适用; 也就是说，并行计算可以被描述为有向无环图（DAG）。 否则，任务可能会遇到一种形式的死锁，因为任务周期性地等待对方。 然而，该框架支持的其它方法和技术（例如使用Phaser ， helpQuiesce()和complete(V) ），其可以使用在构建定制子类为没有静态构造为DAG的问题。 为了支持这种用途，ForkJoinTask可以使用setForkJoinTaskTag(short)或compareAndSetForkJoinTaskTag(short, short)以short值进行原子标记 ，并使用getForkJoinTaskTag()进行检查。 ForkJoinTask实现不为任何目的使用这些protected方法或标签，但它们可能在构建专门的子类中有用。 例如，并行图遍历可以使用提供的方法来避免重新访问已经被处理的节点/任务。 （标记的方法名称部分笨重，以鼓励定义反映其使用模式的方法。）

    大多数基础支持方法是final ，以防止覆盖本质上与底层轻量级任务调度框架相关联的实现。 开发者创建新的基本样式叉/加入处理应最低限度地实现protected方法exec() ， setRawResult(V) ，和getRawResult() ，同时还引入，可以在其子类来实现的抽象计算方法，可能依赖于其他protected由此类提供的方法。

    ForkJoinTasks应该执行相对较少的计算量。 大型任务应分为较小的子任务，通常通过递归分解。 作为一个非常粗略的经验法则，任务应该执行超过100个和少于10000个基本的计算步骤，并且应该避免不确定的循环。 如果任务太大，则并行性不能提高吞吐量。 如果太小，则内存和内部任务维护开销可能会压制处理。

    该类为Runnable和Callable提供adapt方法，当混合执行ForkJoinTasks与其他种类的任务时可能会使用。 当所有任务都是这种形式时，请考虑使用以asyncMode构造的池。

    ForkJoinTasks是Serializable ，它使它们可以用于扩展，如远程执行框架。 仅在执行之前或之后序列化任务是明智的，而不是执行期间。 序列化在执行本身时不依赖。

    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ForkJoinTask​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static ForkJoinTask<?> adapt​(Runnable runnable)
      返回一个新的 ForkJoinTask ，它执行给定的 Runnable作为其操作的 run方法，并返回一个空值结果 join() 。
      static <T> ForkJoinTask<T> adapt​(Runnable runnable, T result)
      返回一个新的 ForkJoinTask ，它执行给定的 Runnable作为其操作的 run方法，并将给定结果返回到 join() 。
      static <T> ForkJoinTask<T> adapt​(Callable<? extends T> callable)
      返回一个新的 ForkJoinTask ，它执行给定的 Callable作为其操作的 call方法，并将其结果返回到 join() ，将遇到的任何检查的异常转换为 RuntimeException 。
      boolean cancel​(boolean mayInterruptIfRunning)
      尝试取消执行此任务。
      boolean compareAndSetForkJoinTaskTag​(short expect, short update)
      以原子方式有条件地设置此任务的标签值。
      void complete​(V value)
      完成此任务，如果尚未中止或取消，则返回给定值作为以后调用的结果 join和相关操作。
      void completeExceptionally​(Throwable ex)
      完成此任务异常，如果尚未中止或取消，将导致给定的异常在 join和相关操作。
      protected abstract boolean exec​()
      立即执行此任务的基本操作，并返回true，如果从此方法返回后，此任务将保证已正常完成。
      ForkJoinTask<V> fork​()
      安排在当前任务正在运行的池中异步执行此任务，如果适用，或使用 ForkJoinPool.commonPool()（如果不是 inForkJoinPool()） 。
      V get​()
      等待计算完成，然后检索其结果。
      V get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      Throwable getException​()
      返回由基本计算引发的异常，如果已取消，则 null如果没有，则返回 CancellationException ，或者方法尚未完成。
      short getForkJoinTaskTag​()
      返回此任务的标签。
      static ForkJoinPool getPool​()
      返回托管当前线程的池，如果当前线程在任何ForkJoinPool之外执行，则返回 null 。
      static int getQueuedTaskCount​()
      返回当前工作线程已分配但尚未执行的任务数量的估计。
      abstract V getRawResult​()
      返回对返回的结果 join() ，即使这个任务异常完成，或 null如果不知道这个任务已经完成。
      static int getSurplusQueuedTaskCount​()
      返回当前工作线程保留的本地排队任务数量多于可能窃取它们的其他工作线程的估计值，如果此线程未在ForkJoinPool中运行，则返回零。
      static void helpQuiesce​()
      可能执行任务，直到托管当前任务的池 is quiescent 。
      static boolean inForkJoinPool​()
      返回true如果当前线程是ForkJoinWorkerThread执行作为ForkJoinPool计算。
      V invoke​()
      开始执行此任务，如有必要，等待完成，并返回其结果，或者如果基础计算结果，则抛出（未选中） RuntimeException或 Error 。
      static <T extends ForkJoinTask<?>>
      Collection<T>             		invokeAll​(Collection<T> tasks)
      叉指定集合中的所有任务，当 isDone适用于每个任务时返回，或遇到（未检查）异常，在这种情况下异常被重新引导。
      static void invokeAll​(ForkJoinTask<?>... tasks)
      叉出给定的任务，当 isDone适用于每个任务时返回，或者遇到（未检查）异常，在这种情况下，异常被重新引导。
      static void invokeAll​(ForkJoinTask<?> t1, ForkJoinTask<?> t2)
      叉出给定的任务，当 isDone适用于每个任务时返回，或者遇到（未检查）异常，在这种情况下，异常被重新引导。
      boolean isCancelled​()
      如果此任务在正常完成之前被取消，则返回 true 。
      boolean isCompletedAbnormally​()
      如果此任务抛出异常或被取消，则返回 true 。
      boolean isCompletedNormally​()
      如果此任务完成而不抛出异常并且未被取消，则返回 true 。
      boolean isDone​()
      如果此任务完成，则返回 true 。
      V join​()
      当它 返回is done的计算结果。
      protected static ForkJoinTask<?> peekNextLocalTask​()
      返回，但不会取消调度或执行当前线程排队但尚未执行的任务（如果可以立即可用）。
      protected static ForkJoinTask<?> pollNextLocalTask​()
      如果当前线程正在ForkJoinPool中运行，则不执行当前线程排队的下一个任务但尚未执行的时间并返回。
      protected static ForkJoinTask<?> pollSubmission​()
      如果当前线程在ForkJoinPool中运行，则不执行外部提交到池的任务（如果有的话）可以取消调度和返回。
      protected static ForkJoinTask<?> pollTask​()
      如果当前线程在ForkJoinPool中运行，则不执行下一个任务，返回当前线程排队的下一个任务，但尚未执行，如果一个可用，或者如果不可用，则由其他线程分派的任务，如果可供使用的话。
      void quietlyComplete​()
      正常完成此任务而不设置值。
      void quietlyInvoke​()
      执行此任务并等待其完成（如有必要），而不返回其结果或抛出异常。
      void quietlyJoin​()
      加入此任务，不返回其结果或抛出异常。
      void reinitialize​()
      重置此任务的内部簿记状态，允许随后的 fork 。
      short setForkJoinTaskTag​(short newValue)
      原子地设置此任务的标签值并返回旧值。
      protected abstract void setRawResult​(V value)
      强制给定的值作为结果返回。
      boolean tryUnfork​()
      尝试取消执行此任务。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ForkJoinTask

        public ForkJoinTask​()

    • 方法详细信息

      • fork

        public final ForkJoinTask<V> fork​()
        在当前任务正在运行的池中异步执行此任务，如果适用，或使用ForkJoinPool.commonPool()（如果不是inForkJoinPool()） 。 虽然它不一定执行，但是除非完成并重新初始化，否则任务多次分配是一种使用错误。 对该任务的状态的后续修改或其操作的任何数据不一定被除了执行它之外的任何线程一致地观察到，除非先前通过呼叫join()或相关方法，或者呼叫isDone()返回true 。
        结果
        this ，以简化使用

      • join

        public final V join​()
        当它返回is done计算的结果。 该方法与get()的不同之处在于，异常完成导致RuntimeException或Error ，而不是ExecutionException ，并且调用线程的中断不会导致该方法通过抛出InterruptedException突然返回。
        结果
        计算结果

      • invoke

        public final V invoke​()
        开始执行此任务，如有必要，等待完成，并返回其结果，或者如果基础计算结果，则抛出（未选中） RuntimeException或 Error 。
        结果
        计算结果

      • invokeAll

        public static void invokeAll​(ForkJoinTask<?> t1,
                             ForkJoinTask<?> t2)
        叉出给定的任务，当isDone适用于每个任务时返回，或遇到（未检查）异常，在这种情况下，异常被重新引导。 如果有多个任务遇到异常，则该方法会抛出任何一个异常。 如果任何一个任务遇到异常，另一个可能会被取消。 但是，单独任务的执行状态在特殊返回时不能得到保证。 每个任务的状态可以使用getException()和相关方法来获取 ，以检查它们是否已被取消，正常完成或异常完成，或者未被处理。
        参数
        t1 - 第一个任务
        t2 - 第二个任务
        异常
        NullPointerException - 如果任何任务为空

      • invokeAll

        public static void invokeAll​(ForkJoinTask<?>... tasks)
        叉出给定的任务，当每个任务保持isDone时返回，或者遇到（未检查）异常，在这种情况下重新引发异常。 如果有多个任务遇到异常，则该方法会抛出任何一个异常。 如果任何一个任务遇到异常，其他任务可能被取消。 但是，单独任务的执行状态在特殊返回时不能得到保证。 每个任务的状态可以使用getException()和相关方法获取，以检查它们是否已被取消，正常完成或异常完成，或者未被处理。
        参数
        tasks - 任务
        异常
        NullPointerException - 如果任何任务为空

      • invokeAll

        public static <T extends ForkJoinTask<?>> Collection<T> invokeAll​(Collection<T> tasks)
        叉指定集合中的所有任务，当isDone适用于每个任务时返回，或遇到（未检查）异常，在这种情况下，将重新isDone异常。 如果有多个任务遇到异常，则该方法会抛出任何一个异常。 如果任何一个任务遇到异常，其他任务可能被取消。 但是，单独任务的执行状态在特殊返回时不能得到保证。 每个任务的状态可以使用getException()和相关方法来获取 ，以检查它们是否已被取消，正常完成或异常完成或未被处理。
        参数类型
        T - 从任务返回的值的类型
        参数
        tasks - 任务的收集
        结果
        任务参数，以简化使用
        异常
        NullPointerException - 如果任务或任何元素为空

      • cancel

        public boolean cancel​(boolean mayInterruptIfRunning)
        尝试取消执行此任务。 如果任务已经完成或由于其他原因不能取消，则此尝试将失败。 如果成功，并且当cancel时此任务尚未启动，则此任务的执行被抑制。 此方法成功返回后，除非有中断呼叫reinitialize() ， 否则后续拨打isCancelled(),isDone()和cancel将返回true并调用join()及相关方法将导致CancellationException 。

        此方法可能会在子类中被覆盖，但如果是这样，仍然必须确保这些属性成立。 特别地， cancel方法本身不能抛出异常。

        该方法被设计为由其他任务调用。 要终止当前任务，您只需从其计算方法返回或抛出未经检查的异常，或调用completeExceptionally(Throwable) 。

        Specified by:
        cancel在接口 Future<V>
        参数
        mayInterruptIfRunning - 该值在默认实现中没有影响，因为中断不用于控制取消。
        结果
        true如果此任务现在已取消

      • isDone

        public final boolean isDone​()
        说明从界面： Future复制
        如果此任务完成，则返回true 。 完成可能是由于正常终止，异常或取消 - 在所有这些情况下，此方法将返回true 。
        Specified by:
        isDone在接口 Future<V>
        结果
        true如果此任务完成

      • isCancelled

        public final boolean isCancelled​()
        说明从界面复制： Future
        如果此任务在正常完成之前已被取消，则返回 true 。
        Specified by:
        isCancelled在接口 Future<V>
        结果
        true如果此任务在完成之前被取消

      • isCompletedAbnormally

        public final boolean isCompletedAbnormally​()
        如果此任务抛出异常或被取消，则返回 true 。
        结果
        true如果此任务抛出异常或被取消

      • isCompletedNormally

        public final boolean isCompletedNormally​()
        如果此任务没有抛出异常并且未被取消，则返回 true 。
        结果
        true如果此任务完成而不抛出异常并且未被取消

      • getException

        public final Throwable getException​()
        返回由基本计算引发的异常，如果已取消，则 null如果没有，则返回 CancellationException ，或者方法尚未完成。
        结果
        例外，如果没有， null

      • completeExceptionally

        public void completeExceptionally​(Throwable ex)
        完成此任务异常，如果尚未中止或取消，将导致给定的异常在join和相关操作。 该方法可用于在异步任务中引发异常，或强制执行否则完成的任务。 不鼓励在其他情况下使用它。 此方法是可以覆盖的，但覆盖的版本必须调用super实现才能保证。
        参数
        ex - 抛出异常。 如果这个异常不是RuntimeException或Error ，抛出的实际异常将是RuntimeException ，原因是ex 。

      • complete

        public void complete​(V value)
        完成此任务，如果尚未中止或取消，则返回给定值作为以后调用join和相关操作的结果。 该方法可用于为异步任务提供结果，或为不能正常完成的任务提供替代处理。 不鼓励在其他情况下使用它。 此方法是可以覆盖的，但是覆盖版本必须调用super实现来维护保证。
        参数
        value - 此任务的结果值

      • quietlyComplete

        public final void quietlyComplete​()
        正常完成此任务而不设置值。 setRawResult(V) （或默认为null ）建立的最新值由于后续调用join和相关操作而返回。
        从以下版本开始：
        1.8

      • get

        public final V get​()
            throws InterruptedException,
                   ExecutionException
        等待计算完成，然后检索其结果。
        Specified by:
        get在接口 Future<V>
        结果
        计算结果
        异常
        CancellationException - 如果计算被取消
        ExecutionException - 如果计算抛出异常
        InterruptedException - 如果当前线程不是ForkJoinPool的成员并且在等待时中断

      • get

        public final V get​(long timeout,
                   TimeUnit unit)
            throws InterruptedException,
                   ExecutionException,
                   TimeoutException
        如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
        Specified by:
        get在接口 Future<V>
        参数
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        计算结果
        异常
        CancellationException - 如果计算被取消
        ExecutionException - 如果计算引发异常
        InterruptedException - 如果当前线程不是ForkJoinPool的成员，并且在等待时中断
        TimeoutException - 如果等待超时

      • quietlyJoin

        public final void quietlyJoin​()
        加入此任务，不返回其结果或抛出异常。 当某些已被取消或以其他方式已知中止时，处理任务集合时，此方法可能是有用的。

      • quietlyInvoke

        public final void quietlyInvoke​()
        执行此任务并等待其完成（如有必要），而不返回其结果或抛出异常。

      • helpQuiesce

        public static void helpQuiesce​()
        可能执行任务，直到托管当前任务的池is quiescent 。 该方法可能在许多任务被分叉的设计中都可以使用，但是没有一个被明确地加入，而是在所有的处理之前执行它们。

      • reinitialize

        public void reinitialize​()
        重置此任务的内部簿记状态，允许随后的fork 。 这个方法允许重复使用这个任务，但是只有当这个任务从未被分支，或已经被分支，然后完成并且这个任务的所有未完成的连接也已完成时重新使用。 在任何其他使用条件下的效果不能保证。 在循环中执行子任务的预构建树时，此方法可能很有用。

        完成此方法后， isDone()报告false和getException()报告null 。 但是，由getRawResult返回的值不受影响。 要清除此值，可以调用setRawResult(null) 。

      • getPool

        public static ForkJoinPool getPool​()
        返回托管当前线程的池，如果当前线程在任何ForkJoinPool之外执行，则返回null 。

        该方法返回null当且仅当inForkJoinPool()个回报false 。

        结果
        池，或 null如果没有

      • inForkJoinPool

        public static boolean inForkJoinPool​()
        返回true如果当前线程是ForkJoinWorkerThread执行作为ForkJoinPool计算。
        结果
        true如果当前线程是作为ForkJoinPool计算执行的ForkJoinWorkerThread ，否则为false

      • tryUnfork

        public boolean tryUnfork​()
        尝试取消执行此任务。 如果此任务是当前线程最近分派的任务，并且尚未开始在另一个线程中执行，则此方法通常（但不能保证）成功。 这种方法在安排可能已被但没有被盗的任务的替代本地处理时可能是有用的。
        结果
        true如果未锁定

      • getQueuedTaskCount

        public static int getQueuedTaskCount​()
        返回当前工作线程已分配但尚未执行的任务数量的估计。 该值对于是否分支其他任务的启发式决策可能是有用的。
        结果
        任务数量

      • getSurplusQueuedTaskCount

        public static int getSurplusQueuedTaskCount​()
        返回当前工作线程保留的本地排队任务数量多于可能窃取它们的其他工作线程的估计值，如果此线程未在ForkJoinPool中运行，则返回零。 该值对于是否分支其他任务的启发式决策可能是有用的。 在许多使用ForkJoinTasks中，在稳定的状态下，每个工作人员应该瞄准维持一个小的不断的剩余（例如3）的任务，并且如果超过该阈值，则在本地处理计算。
        结果
        剩余的任务数量，可能是负数

      • getRawResult

        public abstract V getRawResult​()
        返回对返回的结果join() ，即使这个任务异常完成，或null如果不知道这个任务已经完成。 此方法旨在帮助调试，以及支持扩展。 在任何其他情况下都不鼓励使用它。
        结果
        结果，或 null如果没有完成

      • setRawResult

        protected abstract void setRawResult​(V value)
        强制给定的值作为结果返回。 这种方法被设计为支持扩展，一般不应该以其他方式调用。
        参数
        value - 值

      • exec

        protected abstract boolean exec​()
        立即执行此任务的基本操作，并返回true，如果从此方法返回后，此任务将保证已正常完成。 否则，此方法可能返回false，以指示此任务未必完整（或不知道是完整的），例如在需要显式调用完成方法的异步操作中。 此方法也可能引发（未检查）异常来指示异常退出。 这种方法被设计为支持扩展，一般不应该以其他方式调用。
        结果
        true如果此任务已知已正常完成

      • peekNextLocalTask

        protected static ForkJoinTask<?> peekNextLocalTask​()
        返回，但不会取消调度或执行当前线程排队但尚未执行的任务（如果可以立即可用）。 不能保证这个任务实际上将被接受查询或执行。 相反，即使某个任务存在但是如果不与其他线程相争应，则该方法也可能返回null。 这种方法主要是为了支持扩展，而且不太可能有用。
        结果
        下一个任务，或 null如果没有可用

      • pollNextLocalTask

        protected static ForkJoinTask<?> pollNextLocalTask​()
        如果当前线程正在ForkJoinPool中运行，则不执行当前线程排队的下一个任务但尚未执行的时间并返回。 这种方法主要是为了支持扩展，而且不太可能有用。
        结果
        下一个任务，或 null如果没有可用

      • pollTask

        protected static ForkJoinTask<?> pollTask​()
        如果当前线程在ForkJoinPool中运行，则不执行下一个任务，返回当前线程排队的下一个任务，但尚未执行，如果一个可用，或者如果不可用，则由其他线程分派的任务，如果可供使用的话。 可用性可能是暂时的，因此null结果并不一定意味着此任务正在运行的池的静止。此方法主要用于支持扩展，否则不太有用。
        结果
        一个任务，或 null如果没有可用

      • pollSubmission

        protected static ForkJoinTask<?> pollSubmission​()
        如果当前线程在ForkJoinPool中运行，则不执行外部提交到池的任务（如果有的话）可以取消调度和返回。 可用性可能是暂时的，因此null结果并不一定意味着池的静止。 这种方法主要是为了支持扩展，而且不太可能有用。
        结果
        一个任务，或 null如果没有可用
        从以下版本开始：
        9

      • getForkJoinTaskTag

        public final short getForkJoinTaskTag​()
        返回此任务的标签。
        结果
        该任务的标签
        从以下版本开始：
        1.8

      • setForkJoinTaskTag

        public final short setForkJoinTaskTag​(short newValue)
        原子地设置此任务的标签值并返回旧值。
        参数
        newValue - 新的标签值
        结果
        标签的以前的值
        从以下版本开始：
        1.8

      • compareAndSetForkJoinTaskTag

        public final boolean compareAndSetForkJoinTaskTag​(short expect,
                                                  short update)
        以原子方式有条件地设置此任务的标签值。 在其他应用程序中，标签可以用作在图上操作的任务中的访问标记，如在处理之前检查： if (task.compareAndSetForkJoinTaskTag((short)0, (short)1))方法，否则退出，因为节点已经被访问。
        参数
        expect - 预期的标签值
        update - 新的标签值
        结果
        true如果成功; 即当前值等于expect ，更改为update 。
        从以下版本开始：
        1.8

      • adapt

        public static ForkJoinTask<?> adapt​(Runnable runnable)
        返回一个新的 ForkJoinTask ，它执行给定的 Runnable作为其操作的 run方法，并返回一个空的结果为 join() 。
        参数
        runnable - 可运行的动作
        结果
        任务

      • adapt

        public static <T> ForkJoinTask<T> adapt​(Runnable runnable,
                                        T result)
        返回一个新的 ForkJoinTask ，它执行给定的 Runnable作为其动作的 run方法，并将给定的结果返回给 join() 。
        参数类型
        T - 结果的类型
        参数
        runnable - 可运行的动作
        result - 完成后的结果
        结果
        任务

      • adapt

        public static <T> ForkJoinTask<T> adapt​(Callable<? extends T> callable)
        返回一个新的 ForkJoinTask ，它执行给定的 Callable作为其操作的 call方法，并将其结果返回到 join() ，将遇到的任何检查的异常转换为 RuntimeException 。
        参数类型
        T - 可调用结果的类型
        参数
        callable - 可呼叫动作
        结果
        任务
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ForkJoinWorkerThread (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ForkJoinWorkerThread

  • java.lang.Object
    • java.lang.Thread
      • java.util.concurrent.ForkJoinWorkerThread
  • All Implemented Interfaces:
    Runnable

    public class ForkJoinWorkerThread
extends Thread
    一个由一个ForkJoinPool管理的线程，执行ForkJoinTask 。 这个类仅仅是为了添加功能而进行子类化 - 没有涉及调度或执行的可覆盖的方法。 但是，您可以覆盖主任务处理循环周围的初始化和终止方法。 如果您创建了这样一个子类，您还需要在ForkJoinPool中为use it提供一个自定义的ForkJoinPool 。
    从以下版本开始：
    1.7

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.lang.Thread

        Thread.State, Thread.UncaughtExceptionHandler

    • Field Summary

      • Fields inherited from class java.lang.Thread

        MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ForkJoinWorkerThread​(ForkJoinPool pool)
      在给定的池中创建一个ForkJoinWorkerThread。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ForkJoinPool getPool​()
      返回托管此线程的池。
      int getPoolIndex​()
      返回此线程在其池中的唯一索引号。
      protected void onStart​()
      在施工后初始化内部状态，但在处理任何任务之前。
      protected void onTermination​(Throwable exception)
      执行与该工作线程的终止相关联的清除。
      void run​()
      这种方法是公开的，但不应该被明确地调用。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Thread

        activeCount, checkAccess, clone, countStackFrames, currentThread, destroy, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, onSpinWait, resume, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, stop, stop, suspend, toString, yield

    • 构造方法详细信息

      • ForkJoinWorkerThread

        protected ForkJoinWorkerThread​(ForkJoinPool pool)
        在给定的池中创建一个ForkJoinWorkerThread。
        参数
        pool - 此线程工作的池
        异常
        NullPointerException - 如果池为空

    • 方法详细信息

      • getPool

        public ForkJoinPool getPool​()
        返回托管此线程的池。
        结果
        游泳池

      • getPoolIndex

        public int getPoolIndex​()
        返回此线程在其池中的唯一索引号。 返回的值的范围从零到最大线程数（减一），可能存在于池中，并且在线程的生命周期内不会更改。 该方法对于跟踪状态或收集每个工作者线程而不是每个任务的结果的应用程序可能是有用的。
        结果
        索引号

      • onStart

        protected void onStart​()
        在施工后初始化内部状态，但在处理任何任务之前。 如果您覆盖此方法，则必须在方法开头调用super.onStart() 。 初始化需要注意：大多数字段必须具有合法的默认值，以确保即使在此线程开始处理任务之前，其他线程的尝试访问也能正常工作。

      • onTermination

        protected void onTermination​(Throwable exception)
        执行与该工作线程的终止相关联的清除。 如果您覆盖此方法，则必须在覆盖方法的末尾调用super.onTermination 。
        参数
        exception - 由于不可恢复的错误导致此线程中止的异常，如果正常完成， null

      • run

        public void run​()
        这种方法是公开的，但不应该被明确地调用。 它执行主运行循环执行ForkJoinTask s。
        Specified by:
        run在接口 Runnable
        重写：
        run在 Thread
        另请参见：
        Thread.start() ，
Thread.stop() ，
Thread(ThreadGroup, Runnable, String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Future (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface Future<V>

  • 参数类型
    V - 该未来 get方法返回的结果类型
    All Known Subinterfaces:
    Response<T> ， RunnableFuture<V> ， RunnableScheduledFuture<V> ， ScheduledFuture<V>
    所有已知实现类：
    CompletableFuture ， CountedCompleter ， ForkJoinTask ， FutureTask ， RecursiveAction ， RecursiveTask ， SwingWorker ， Task

    public interface Future<V>
    A Future表示异步计算的结果。 提供方法来检查计算是否完成，等待其完成，并检索计算结果。 只有当计算完成后，才能使用方法get检索结果，如果需要，则阻塞，直到准备就绪。 取消由cancel方法执行。 提供其他方法来确定任务是否正常完成或被取消。 计算完成后，不能取消计算。 如果您想使用Future ，为了不可撤销，但不提供可用的结果，您可以声明表单Future<?>类型并返回null作为基础任务的结果。

    示例使用 （请注意，以下课程都是化妆品。）

       interface ArchiveSearcher { String search(String target); } class App { ExecutorService executor = ... ArchiveSearcher searcher = ... void showSearch(String target) throws InterruptedException { Callable<String> task = () -> searcher.search(target); Future<String> future = executor.submit(task); displayOtherThings(); // do other things while searching try { displayText(future.get()); // use future } catch (ExecutionException ex) { cleanup(); return; } } }
    FutureTask类是实现Future ，实现Runnable ，所以可以由一个Executor执行。 例如，上述结构用submit可以替换为：
       FutureTask<String> future = new FutureTask<>(task); executor.execute(future);

    内存一致性效果：通过异步计算采取的行动happen-before个动作以下相应Future.get()在另一个线程。

    从以下版本开始：
    1.5
    另请参见：
    FutureTask ， Executor

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean cancel​(boolean mayInterruptIfRunning)
      尝试取消执行此任务。
      V get​()
      等待计算完成，然后检索其结果。
      V get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      boolean isCancelled​()
      如果此任务在正常完成之前被取消，则返回 true 。
      boolean isDone​()
      如果此任务完成，则返回 true 。

    • 方法详细信息

      • cancel

        boolean cancel​(boolean mayInterruptIfRunning)
        尝试取消执行此任务。 如果任务已经完成，已经被取消或由于某种其他原因而无法取消，则此尝试将失败。 如果成功，并且当cancel时此任务尚未启动，则此任务不应运行。 如果任务已经启动，则mayInterruptIfRunning参数确定执行此任务的线程是否应该中断，以试图停止该任务。

        此方法返回后，对isDone()的后续调用将始终返回true 。 对后续调用isCancelled()总是返回true如果此方法返回true 。

        参数
        mayInterruptIfRunning - true如果执行该任务的线程应该被中断; 否则，正在进行的任务被允许完成
        结果
        false如果任务无法取消，通常是因为它已经正常完成; 否则为true

      • isCancelled

        boolean isCancelled​()
        如果此任务在正常完成之前被取消，则返回 true 。
        结果
        true如果此任务在完成之前被取消

      • isDone

        boolean isDone​()
        如果此任务完成，则返回true 。 完成可能是由于正常终止，异常或取消 - 在所有这些情况下，此方法将返回true 。
        结果
        true如果此任务完成

      • get

        V get​()
throws InterruptedException,
      ExecutionException
        等待计算完成，然后检索其结果。
        结果
        计算结果
        异常
        CancellationException - 如果计算被取消
        ExecutionException - 如果计算抛出异常
        InterruptedException - 如果当前线程在等待时中断

      • get

        V get​(long timeout,
      TimeUnit unit)
throws InterruptedException,
      ExecutionException,
      TimeoutException
        如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
        参数
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        计算结果
        异常
        CancellationException - 如果计算被取消
        ExecutionException - 如果计算引发异常
        InterruptedException - 如果当前线程在等待时中断
        TimeoutException - if the wait timed out
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FutureTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class FutureTask<V>

  • java.lang.Object
    • java.util.concurrent.FutureTask<V>
  • 参数类型
    V - 该FutureTask的 get方法返回的结果类型
    All Implemented Interfaces:
    Runnable ， Future<V> ， RunnableFuture<V>
    已知直接子类：
    Task

    public class FutureTask<V>
extends Object
implements RunnableFuture<V>
    可取消的异步计算。 该类提供了一个Future的基本实现，具有启动和取消计算的方法，查询计算是否完整，并检索计算结果。 结果只能在计算完成后才能检索; 如果计算尚未完成，则get方法将阻塞。 计算完成后，无法重新启动或取消计算（除非使用runAndReset()调用计算）。

    A FutureTask可用于包装Callable或Runnable对象。 因为FutureTask实现Runnable ，一个FutureTask可以提交给一个Executor执行。

    除了作为独立类之外，此类还提供了protected功能，这在创建自定义任务类时可能很有用。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      FutureTask​(Runnable runnable, V result)
      创建一个 FutureTask ，将在运行时执行给定的 Runnable ，并安排 get将在成功完成后返回给定的结果。
      FutureTask​(Callable<V> callable)
      创建一个 FutureTask ，它将在运行时执行给定的 Callable 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean cancel​(boolean mayInterruptIfRunning)
      尝试取消执行此任务。
      protected void done​()
      此任务转换到状态 isDone （无论是正常还是通过取消）调用的受保护方法。
      V get​()
      等待计算完成，然后检索其结果。
      V get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      boolean isCancelled​()
      如果此任务在正常完成之前被取消，则返回 true 。
      boolean isDone​()
      如果此任务完成，则返回 true 。
      void run​()
      将此未来设置为其计算结果，除非已被取消。
      protected boolean runAndReset​()
      执行计算而不设置其结果，然后将此将来重置为初始状态，如果计算遇到异常或被取消，则不执行此操作。
      protected void set​(V v)
      将此未来的结果设置为给定值，除非此未来已被设置或已被取消。
      protected void setException​(Throwable t)
      导致这个未来报告一个ExecutionException作为其原因，除非这个未来已经被设置或已被取消。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FutureTask

        public FutureTask​(Callable<V> callable)
        创建一个 FutureTask ，它将在运行时执行给定的 Callable 。
        参数
        callable - 可调用任务
        异常
        NullPointerException - 如果可调用为空

      • FutureTask

        public FutureTask​(Runnable runnable,
                  V result)
        创建一个 FutureTask ，它将在运行时执行给定的 Runnable ，并安排 get将在成功完成后返回给定的结果。
        参数
        runnable - 可运行的任务
        result - 成功完成后返回的结果。 如果您不需要特定的结果，请考虑使用以下形式的结构： Future<?> f = new FutureTask<Void>(runnable, null)
        异常
        NullPointerException - 如果runnable为null

    • 方法详细信息

      • isCancelled

        public boolean isCancelled​()
        说明从接口Future复制
        如果此任务在正常完成之前被取消，则返回 true 。
        Specified by:
        isCancelled在接口 Future<V>
        结果
        true如果此任务在完成之前被取消

      • isDone

        public boolean isDone​()
        说明从接口Future复制
        如果此任务完成，则返回true 。 完成可能是由于正常终止，异常或取消 - 在所有这些情况下，此方法将返回true 。
        Specified by:
        isDone在接口 Future<V>
        结果
        true如果此任务完成

      • cancel

        public boolean cancel​(boolean mayInterruptIfRunning)
        描述从接口Future复制
        尝试取消执行此任务。 如果任务已经完成，已经被取消或由于某种其他原因而无法取消，则此尝试将失败。 如果成功，并且当cancel时此任务尚未启动，则此任务不应运行。 如果任务已经开始，则mayInterruptIfRunning参数确定执行此任务的线程是否应该中断以试图停止任务。

        此方法返回后，对Future.isDone()的后续调用将始终返回true 。 对后续调用Future.isCancelled()总是返回true如果此方法返回true 。

        Specified by:
        cancel在接口 Future<V>
        参数
        mayInterruptIfRunning - true如果执行该任务的线程应该被中断; 否则，正在进行的任务被允许完成
        结果
        false如果任务无法取消，通常是因为它已经正常完成; 否则为true

      • get

        public V get​()
      throws InterruptedException,
             ExecutionException
        说明从接口Future复制
        等待计算完成，然后检索其结果。
        Specified by:
        get在接口 Future<V>
        结果
        计算结果
        异常
        CancellationException - 如果计算被取消
        InterruptedException - 如果当前线程在等待时中断
        ExecutionException - 如果计算抛出异常

      • get

        public V get​(long timeout,
             TimeUnit unit)
      throws InterruptedException,
             ExecutionException,
             TimeoutException
        说明从接口Future复制
        如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
        Specified by:
        get在接口 Future<V>
        参数
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        计算结果
        异常
        CancellationException - 如果计算被取消
        InterruptedException - 如果当前线程在等待时中断
        ExecutionException - 如果计算抛出异常
        TimeoutException - 如果等待超时

      • done

        protected void done​()
        此任务转换到状态isDone （无论是正常还是通过取消）调用的受保护方法。 默认实现什么都不做。 子类可以覆盖此方法来调用完成回调或执行簿记。 请注意，您可以在执行此方法之前查询状态，以确定此任务是否已被取消。

      • set

        protected void set​(V v)
        将此未来的结果设置为给定值，除非此未来已被设置或已被取消。

        该方法在成功完成计算后由run()方法内部调用。

        参数
        v - 值

      • setException

        protected void setException​(Throwable t)
        导致这个未来报告一个ExecutionException与给定的可抛弃的原因，除非这个未来已经被设置或已被取消。

        该方法在计算失败时由run()方法内部调用。

        参数
        t - 失败的原因

      • run

        public void run​()
        描述从接口RunnableFuture复制
        将此未来设置为其计算结果，除非已被取消。
        Specified by:
        run在接口 Runnable
        Specified by:
        run在接口 RunnableFuture<V>
        另请参见：
        Thread.run()

      • runAndReset

        protected boolean runAndReset​()
        执行计算而不设置其结果，然后将此将来重置为初始状态，如果计算遇到异常或被取消，则不执行此操作。 这被设计用于内在地执行多次的任务。
        结果
        true如果成功运行并重置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.util.concurrent (Java SE 9 & JDK 9 )

java.util.concurrent

Interfaces

  • BlockingDeque
  • BlockingQueue
  • Callable
  • CompletableFuture.AsynchronousCompletionTask
  • CompletionService
  • CompletionStage
  • ConcurrentMap
  • ConcurrentNavigableMap
  • Delayed
  • Executor
  • ExecutorService
  • Flow.Processor
  • Flow.Publisher
  • Flow.Subscriber
  • Flow.Subscription
  • ForkJoinPool.ForkJoinWorkerThreadFactory
  • ForkJoinPool.ManagedBlocker
  • Future
  • RejectedExecutionHandler
  • RunnableFuture
  • RunnableScheduledFuture
  • ScheduledExecutorService
  • ScheduledFuture
  • ThreadFactory
  • TransferQueue

Classes

  • AbstractExecutorService
  • ArrayBlockingQueue
  • CompletableFuture
  • ConcurrentHashMap
  • ConcurrentHashMap.KeySetView
  • ConcurrentLinkedDeque
  • ConcurrentLinkedQueue
  • ConcurrentSkipListMap
  • ConcurrentSkipListSet
  • CopyOnWriteArrayList
  • CopyOnWriteArraySet
  • CountDownLatch
  • CountedCompleter
  • CyclicBarrier
  • DelayQueue
  • Exchanger
  • ExecutorCompletionService
  • Executors
  • Flow
  • ForkJoinPool
  • ForkJoinTask
  • ForkJoinWorkerThread
  • FutureTask
  • LinkedBlockingDeque
  • LinkedBlockingQueue
  • LinkedTransferQueue
  • Phaser
  • PriorityBlockingQueue
  • RecursiveAction
  • RecursiveTask
  • ScheduledThreadPoolExecutor
  • Semaphore
  • SubmissionPublisher
  • SynchronousQueue
  • ThreadLocalRandom
  • ThreadPoolExecutor
  • ThreadPoolExecutor.AbortPolicy
  • ThreadPoolExecutor.CallerRunsPolicy
  • ThreadPoolExecutor.DiscardOldestPolicy
  • ThreadPoolExecutor.DiscardPolicy

Enums

  • TimeUnit

Exceptions

  • BrokenBarrierException
  • CancellationException
  • CompletionException
  • ExecutionException
  • RejectedExecutionException
  • TimeoutException


java.util.concurrent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util.concurrent

实用程序类通常用于并发编程。 这个包包括一些小的标准化可扩展框架，以及一些类，它们提供有用的功能，而不是繁琐或难以实现。 以下是主要组件的简要说明。 另请参阅java.util.concurrent.locks和java.util.concurrent.atomic软件包。

执行人

接口。 Executor是一个简单的标准化界面，用于定义线程类的子系统，包括线程池，异步I / O和轻量级任务框架。 根据使用哪个具体的Executor类，任务可以在新创建的线程，现有的任务执行线程或调用execute的线程中执行，并且可以顺序或同时执行。 ExecutorService提供了一个更完整的异步任务执行框架。 ExecutorService管理任务的排队和调度，并允许受控关闭。 ScheduledExecutorService子接口和关联接口增加了对延迟和周期性任务执行的支持。 ExecutorServices提供了表示为Callable的任何函数的异步执行的方法，结果轴承类型为Runnable 。 A Future返回函数的结果，允许确定执行是否已完成，并提供取消执行的方法。 A RunnableFuture是一个Future ，拥有一个run方法，在执行时，设置其结果。

实现。 类ThreadPoolExecutor和ScheduledThreadPoolExecutor提供可调谐的，灵活的线程池。 Executors类提供了最常见的Executors种类和配置的工厂方法，以及一些使用它们的实用方法。 基于Executors其他实用程序包括具体的FutureTask类，提供了Futures的共同可扩展实现，以及ExecutorCompletionService ，有助于协调异步任务组的处理。

ForkJoinPool提供了一个主要设计用于处理ForkJoinTask及其子类的实例的执行程序 。 这些类采用一个工作窃取调度程序，它可以满足在计算密集型并行处理中经常保持的限制的任务的高吞吐量。

队列

ConcurrentLinkedQueue类提供了一种高效的可扩展线程安全非阻塞FIFO队列。 ConcurrentLinkedDeque类是类似的，但另外支持Deque接口。

五个实现都java.util.concurrent支持扩展BlockingQueue接口中，定义阻塞put和take的版本： LinkedBlockingQueue ， ArrayBlockingQueue ， SynchronousQueue ， PriorityBlockingQueue ，并DelayQueue 。 不同的类涵盖生产者 - 消费者，消息传递，并行任务和相关并发设计的最常见的使用上下文。

扩展接口TransferQueue和实现LinkedTransferQueue引入同步transfer方法（以及相关特征），其中生产者可以可选地阻止等待其消费者。

BlockingDeque接口扩展了BlockingQueue以支持FIFO和LIFO（基于堆栈）的操作。 LinkedBlockingDeque课程提供了一个实现。

定时

TimeUnit类提供了多个粒度（包括纳秒），用于指定和控制基于超时的操作。 软件包中的大多数类除了无限期的等待之外还包含基于超时的操作。 在所有使用超时的情况下，超时指定方法在指示超时之前应等待的最短时间。 实施做出“尽力而为”，在发现之后尽快检测超时。 然而，在超时检测到的时间和在该超时之后实际执行的线程之间可能经过不定时间。 接受超时参数的所有方法都将小于或等于0的值视为不等待。 要等待“永远”，可以使用值Long.MAX_VALUE 。

同步器

五类帮助常用的专用同步成语。
  • Semaphore是一个经典的并发工具。
  • CountDownLatch是一个非常简单但非常通用的实用程序，直到给定数量的信号，事件或条件成立为止。
  • A CyclicBarrier是一种可复用的多路同步点，可用于某些类型的并行编程。
  • A Phaser提供了可以用于在多个线程之间控制相位计算的更灵活的障碍形式。
  • 一个Exchanger允许两个线程在会合点交换对象，并且在多个管道设计中是有用的。

并发收藏

除了队列，这个包提供的集合实现在多线程环境中设计用于： ConcurrentHashMap ， ConcurrentSkipListMap ， ConcurrentSkipListSet ， CopyOnWriteArrayList ，并CopyOnWriteArraySet 。 当许多线程预期访问给定的集合时， ConcurrentHashMap通常优于同步的HashMap ，而ConcurrentSkipListMap通常优于同步的TreeMap 。 当预期的读取和遍历次数大大超过列表的更新次数时，A CopyOnWriteArrayList优于同步的ArrayList 。

与此包中某些类使用的“并发”前缀是一个简写，表示与类似“同步”类的几个差异。 例如java.util.Hashtable和Collections.synchronizedMap(new HashMap())被同步。 但是ConcurrentHashMap是“并发”。 并发集合是线程安全的，但不受单个排除锁的约束。 在ConcurrentHashMap的特定情况下，它可以安全地允许任意数量的并发读取以及大量的并发写入。 当您需要通过单个锁来阻止对集合的所有访问时，“同步”类可能会有用，而不损害可扩展性。 在预期多个线程访问公共集合的其他情况下，“并发”版本通常是可取的。 并且当两个集合都是非共享的时候，不同步的集合是可取的，或者只有在持有其他锁时才可访问。

大多数并发收集实现（包括大多数队列）也与通常的java.util约定不同，因为它们的Iterators和Spliterators提供弱一致而不是快速失败遍历：

  • 他们可能会同时进行其他行动
  • 他们永远不会抛出ConcurrentModificationException
  • 它们被保证能够在建筑物上存在一次元素，并且可能（但不能保证）反映施工后的任何修改。

内存一致性属性

Chapter 17 of The Java™ Language Specification定义了对存储器操作（例如共享变量的读取和写入）的发生之前的关系。 只有在写操作发生之前 ，一个线程的写入结果才能保证对另一个线程的读取可见。 synchronized和volatile构造以及Thread.start()和Thread.join()方法都可以形成发生之前的关系。 尤其是：
  • 在线程中的每个动作发生在该线程中的每个动作之前 ，程序的顺序将稍后。
  • 在同一个监视器的每个后续锁定（ synchronized块或方法条目） 之前发生监视器的锁定（ synchronized块或方法退出）。 并且因为事件发生之前的关系是可传递的，所以在解锁之前的线程的所有动作都发生在所有线程锁定之后的所有动作之前 。
  • 在写入volatile字段之后， 会在每次后续读取同一个字段之前发生 。 volatile字段的写入和读取与进入和退出显示器具有类似的内存一致性效果，但不要求互斥锁定。
  • 在线程上调用start 发生在启动线程中的任何操作之前 。
  • 在线程中的所有动作发生之前，任何其他线程从该线程上的一个join成功返回。
java.util.concurrent及其子包中的所有类的方法将这些保证扩展到更高级别的同步。 尤其是：
  • 在将对象放入任何并发集合之前，线程中的操作发生在另一个线程中从该集合访问或删除该元素之后的操作之前 。
  • 在提交Runnable到Executor之前，线程中的操作发生在其执行开始之前 。 同样为Callables提交到一个ExecutorService 。
  • 由Future表示的异步计算所采取的动作在通过另一个线程中的Future.get()检索结果之后发生 。
  • 操作之前为“释放”同步器的方法，例如Lock.unlock ， Semaphore.release ，和CountDownLatch.countDown 发生-前行动一个成功的“获取”方法如后续Lock.lock ， Semaphore.acquire ， Condition.await和CountDownLatch.await在另一个线程相同的同步对象。
  • 对于通过Exchanger成功交换对象的每对线程，在每个线程中的exchange()之前的exchange() 发生在另一个线程中对应的exchange()之后的exchange() 。
  • 调用CyclicBarrier.await和Phaser.awaitAdvance 之前的动作（以及其变体） 发生在屏障动作执行的动作之前，以及由其他线程中对应的await成功返回后的动作之前发生的屏障动作执行的动作。
从以下版本开始：
1.5
  • 接口摘要
    接口 描述
    BlockingDeque<E>
    A Deque另外支持在检索元素时等待deque变为非空的阻塞操作，并且在存储元素时等待空白在deque中可用。
    BlockingQueue<E>
    A Queue另外支持在检索元素时等待队列变为非空的操作，并且在存储元素时等待队列中的空间变得可用。
    Callable<V>
    返回结果并可能引发异常的任务。
    CompletableFuture.AsynchronousCompletionTask
    标识接口，标识由 async方法产生的异步任务。
    CompletionService<V>
    一种将新异步任务的生产与已完成任务的结果消耗相分离的服务。
    CompletionStage<T>
    可能的异步计算的阶段，当另一个完成时间完成时，执行一个动作或计算一个值。
    ConcurrentMap<K,V>
    A Map提供线程安全和原子性保证。
    ConcurrentNavigableMap<K,V>
    A ConcurrentMap支持NavigableMap操作，并递归地为其导航子地图。
    Delayed
    一个混合样式界面，用于标记在给定延迟后应该执行的对象。
    Executor
    执行提交的对象Runnable任务。
    ExecutorService
    一个Executor ，其提供了管理终止的方法和可以产生用于跟踪一个或多个异步任务进度的Future的方法。
    Flow.Processor<T,R>
    作为订阅者和发布者的组件。
    Flow.Publisher<T>
    订阅者接收的项目（和相关控制消息）的生产者。
    Flow.Subscriber<T>
    消息的接收者。
    Flow.Subscription
    消息控件链接Flow.Publisher和Flow.Subscriber 。
    ForkJoinPool.ForkJoinWorkerThreadFactory
    工厂创建新的ForkJoinWorkerThread s。
    ForkJoinPool.ManagedBlocker
    用于扩展管理并行性的接口，用于在ForkJoinPool中运行的任务。
    Future<V>
    A Future表示异步计算的结果。
    RejectedExecutionHandler
    一个ThreadPoolExecutor无法执行的任务的处理程序。
    RunnableFuture<V>
    A Future那是Runnable 。
    RunnableScheduledFuture<V>
    A ScheduledFuture是Runnable 。
    ScheduledExecutorService
    一个ExecutorService ，可以调度命令在给定的延迟之后运行，或定期执行。
    ScheduledFuture<V>
    可以取消延迟结果的行动。
    ThreadFactory
    根据需要创建新线程的对象。
    TransferQueue<E>
    A BlockingQueue ，其中生产者可能等待消费者接收元素。
  • 类摘要
    Class 描述
    AbstractExecutorService
    提供ExecutorService执行方法的默认实现。
    ArrayBlockingQueue<E>
    有限的blocking queue由阵列支持。
    CompletableFuture<T>
    A Future可以明确完成（设置其值和状态），并可用作CompletionStage ，支持在其完成时触发的依赖功能和动作。
    ConcurrentHashMap<K,V>
    支持检索的完全并发性和更新的高预期并发性的哈希表。
    ConcurrentHashMap.KeySetView<K,V>
    ConcurrentHashMap视图为Set的密钥，其中可以通过映射到公共值来选择添加。
    ConcurrentLinkedDeque<E>
    基于链接节点的无界并发deque 。
    ConcurrentLinkedQueue<E>
    基于链接节点的无界线程安全queue 。
    ConcurrentSkipListMap<K,V>
    可扩展并发ConcurrentNavigableMap实现。
    ConcurrentSkipListSet<E>
    可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
    CopyOnWriteArrayList<E>
    的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。
    CopyOnWriteArraySet<E>
    A Set 对其所有操作使用内部CopyOnWriteArrayList 。
    CountDownLatch
    允许一个或多个线程等待直到在其他线程中执行的一组操作完成的同步辅助。
    CountedCompleter<T>
    A ForkJoinTask ，当触发时执行完成操作，并且没有剩余的待处理操作。
    CyclicBarrier
    允许一组线程全部等待彼此达到共同屏障点的同步辅助。
    DelayQueue<E extends Delayed>
    一个无限的blocking queue的Delayed元素，其中元素只能在其延迟到期时才被采用。
    Exchanger<V>
    线程可以在成对内配对和交换元素的同步点。
    ExecutorCompletionService<V>
    A CompletionService使用提供的Executor执行任务。
    Executors
    工厂和工具方法Executor ， ExecutorService ， ScheduledExecutorService ， ThreadFactory和Callable此包中定义的类。
    Flow
    用于建立流量控制组件的相互关联的接口和静态方法，其中Publishers生成由一个或多个Subscribers消耗的项目，每个由Subscription管理。
    ForkJoinPool
    一个ExecutorService运行ForkJoinTask s。
    ForkJoinTask<V>
    ForkJoinPool中运行的任务的抽象基类。
    ForkJoinWorkerThread
    一个由ForkJoinPool管理的线程，执行ForkJoinTask 。
    FutureTask<V>
    可取消的异步计算。
    LinkedBlockingDeque<E>
    基于链接节点的可选限定的blocking deque 。
    LinkedBlockingQueue<E>
    基于链接节点的可选限定的blocking queue 。
    LinkedTransferQueue<E>
    基于链接节点的无界TransferQueue 。
    Phaser
    一个可重复使用的同步屏障，功能类似于CyclicBarrier和CountDownLatch，但支持更灵活的使用。
    PriorityBlockingQueue<E>
    无限blocking queue使用与PriorityQueue类相同的排序规则，并提供阻止检索操作。
    RecursiveAction
    一个递归结果ForkJoinTask 。
    RecursiveTask<V>
    递归结果ForkJoinTask 。
    ScheduledThreadPoolExecutor
    A ThreadPoolExecutor可以另外安排在给定延迟之后运行命令或定期执行。
    Semaphore
    一个计数信号量。
    SubmissionPublisher<T>
    A Flow.Publisher ，它将当前订阅者异常发出提交的（非空）项目，直到关闭。
    SynchronousQueue<E>
    A blocking queue其中每个插入操作必须等待另一个线程相应的删除操作，反之亦然。
    ThreadLocalRandom
    与当前线程隔离的随机数生成器。
    ThreadPoolExecutor
    一个ExecutorService ，使用可能的几个合并的线程之一执行每个提交的任务，通常使用Executors工厂方法配置。
    ThreadPoolExecutor.AbortPolicy
    一个抛出 RejectedExecutionException被拒绝任务的处理程序。
    ThreadPoolExecutor.CallerRunsPolicy
    被拒绝的任务的处理程序直接在 execute方法的调用线程中运行被拒绝的任务，除非执行程序已经被关闭，在这种情况下，任务被丢弃。
    ThreadPoolExecutor.DiscardOldestPolicy
    被拒绝的任务的处理程序，丢弃最旧的未处理请求，然后重试 execute ，除非执行程序关闭，在这种情况下，任务被丢弃。
    ThreadPoolExecutor.DiscardPolicy
    被拒绝的任务的处理程序静默地丢弃被拒绝的任务。
  • 枚举摘要
    Enum 描述
    TimeUnit
    A TimeUnit表示给定粒度单位的持续时间，并提供了跨单位转换的实用方法，并在这些单元中执行定时和延迟操作。
  • 异常摘要
    异常 描述
    BrokenBarrierException
    当线程尝试等待处于断开状态的屏障或线程等待时进入断开状态时抛出异常。
    CancellationException
    异常表示由于任务被取消，无法检索生成值的任务（如FutureTask）的结果。
    CompletionException
    在完成结果或任务的过程中遇到错误或其他异常时抛出异常。
    ExecutionException
    尝试检索通过抛出异常中止的任务的结果时抛出的异常。
    RejectedExecutionException
    当一个任务不能接受执行时，由一个Executor抛出的异常。
    TimeoutException
    Exception thrown when a blocking operation times out.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.concurrent Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.concurrent

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractQueue<E> (implements java.util.Queue<E>)
        • java.util.concurrent.ArrayBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.ConcurrentLinkedQueue<E> (implements java.util.Queue<E>, java.io.Serializable)
        • java.util.concurrent.DelayQueue<E> (implements java.util.concurrent.BlockingQueue<E>)
        • java.util.concurrent.LinkedBlockingDeque<E> (implements java.util.concurrent.BlockingDeque<E>, java.io.Serializable)
        • java.util.concurrent.LinkedBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.LinkedTransferQueue<E> (implements java.io.Serializable, java.util.concurrent.TransferQueue<E>)
        • java.util.concurrent.PriorityBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.SynchronousQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
      • java.util.AbstractSet<E> (implements java.util.Set<E>)
        • java.util.concurrent.ConcurrentSkipListSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
        • java.util.concurrent.CopyOnWriteArraySet<E> (implements java.io.Serializable)
      • java.util.concurrent.ConcurrentLinkedDeque<E> (implements java.util.Deque<E>, java.io.Serializable)
    • java.util.concurrent.AbstractExecutorService (implements java.util.concurrent.ExecutorService)
      • java.util.concurrent.ForkJoinPool
      • java.util.concurrent.ThreadPoolExecutor
        • java.util.concurrent.ScheduledThreadPoolExecutor (implements java.util.concurrent.ScheduledExecutorService)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.concurrent.ConcurrentHashMap<K,V> (implements java.util.concurrent.ConcurrentMap<K,V>, java.io.Serializable)
      • java.util.concurrent.ConcurrentSkipListMap<K,V> (implements java.lang.Cloneable, java.util.concurrent.ConcurrentNavigableMap<K,V>, java.io.Serializable)
    • java.util.concurrent.CompletableFuture<T> (implements java.util.concurrent.CompletionStage<T>, java.util.concurrent.Future<V>)
    • java.util.concurrent.ConcurrentHashMap.KeySetView<K,V> (implements java.io.Serializable, java.util.Set<E>)
    • java.util.concurrent.CopyOnWriteArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
    • java.util.concurrent.CountDownLatch
    • java.util.concurrent.CyclicBarrier
    • java.util.concurrent.Exchanger<V>
    • java.util.concurrent.ExecutorCompletionService<V> (implements java.util.concurrent.CompletionService<V>)
    • java.util.concurrent.Executors
    • java.util.concurrent.Flow
    • java.util.concurrent.ForkJoinTask<V> (implements java.util.concurrent.Future<V>, java.io.Serializable)
      • java.util.concurrent.CountedCompleter<T>
      • java.util.concurrent.RecursiveAction
      • java.util.concurrent.RecursiveTask<V>
    • java.util.concurrent.FutureTask<V> (implements java.util.concurrent.RunnableFuture<V>)
    • java.util.concurrent.Phaser
    • java.util.Random (implements java.io.Serializable)
      • java.util.concurrent.ThreadLocalRandom
    • java.util.concurrent.Semaphore (implements java.io.Serializable)
    • java.util.concurrent.SubmissionPublisher<T> (implements java.lang.AutoCloseable, java.util.concurrent.Flow.Publisher<T>)
    • java.lang.Thread (implements java.lang.Runnable)
      • java.util.concurrent.ForkJoinWorkerThread
    • java.util.concurrent.ThreadPoolExecutor.AbortPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.util.concurrent.BrokenBarrierException
        • java.util.concurrent.ExecutionException
        • java.lang.RuntimeException
          • java.util.concurrent.CompletionException
          • java.lang.IllegalStateException
            • java.util.concurrent.CancellationException
          • java.util.concurrent.RejectedExecutionException
        • java.util.concurrent.TimeoutException

Interface Hierarchy

  • java.util.concurrent.Callable<V>
  • java.lang.Comparable<T>
    • java.util.concurrent.Delayed
      • java.util.concurrent.ScheduledFuture<V> (also extends java.util.concurrent.Future<V>)
        • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>)
  • java.util.concurrent.CompletableFuture.AsynchronousCompletionTask
  • java.util.concurrent.CompletionService<V>
  • java.util.concurrent.CompletionStage<T>
  • java.util.concurrent.Executor
    • java.util.concurrent.ExecutorService
      • java.util.concurrent.ScheduledExecutorService
  • java.util.concurrent.Flow.Publisher<T>
    • java.util.concurrent.Flow.Processor<T,R> (also extends java.util.concurrent.Flow.Subscriber<T>)
  • java.util.concurrent.Flow.Subscriber<T>
    • java.util.concurrent.Flow.Processor<T,R> (also extends java.util.concurrent.Flow.Publisher<T>)
  • java.util.concurrent.Flow.Subscription
  • java.util.concurrent.ForkJoinPool.ForkJoinWorkerThreadFactory
  • java.util.concurrent.ForkJoinPool.ManagedBlocker
  • java.util.concurrent.Future<V>
    • java.util.concurrent.RunnableFuture<V> (also extends java.lang.Runnable)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.ScheduledFuture<V> (also extends java.util.concurrent.Delayed)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>)
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.Queue<E>
        • java.util.concurrent.BlockingQueue<E>
          • java.util.concurrent.BlockingDeque<E> (also extends java.util.Deque<E>)
          • java.util.concurrent.TransferQueue<E>
        • java.util.Deque<E>
          • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>)
  • java.util.Map<K,V>
    • java.util.concurrent.ConcurrentMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.NavigableMap<K,V>)
    • java.util.SortedMap<K,V>
      • java.util.NavigableMap<K,V>
        • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.concurrent.ConcurrentMap<K,V>)
  • java.util.concurrent.RejectedExecutionHandler
  • java.lang.Runnable
    • java.util.concurrent.RunnableFuture<V> (also extends java.util.concurrent.Future<V>)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.ScheduledFuture<V>)
  • java.util.concurrent.ThreadFactory

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.util.concurrent.TimeUnit
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LinkedBlockingDeque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class LinkedBlockingDeque<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
        • java.util.concurrent.LinkedBlockingDeque<E>
  • 参数类型
    E - 在这个deque中持有的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， BlockingDeque<E> ， BlockingQueue<E> ， Deque<E> ， Queue<E>

    public class LinkedBlockingDeque<E>
extends AbstractQueue<E>
implements BlockingDeque<E>, Serializable
    基于链接节点的可选限定的blocking deque 。

    可选容量绑定构造函数参数用于防止过度扩展。 容量，如果未指定，等于Integer.MAX_VALUE 。 链接节点在每次插入时都会动态创建，除非这样可以使得超出容量。

    大多数操作都在不间断运行（忽略停止时间）。 例外包括remove ， removeFirstOccurrence ， removeLastOccurrence ， contains ， iterator.remove() ，和批量操作，所有这些都在运行线性时间。

    该类及其迭代器实现Collection和Iterator接口的所有可选方法。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinkedBlockingDeque​()
      创建 LinkedBlockingDeque ，容量为 Integer.MAX_VALUE 。
      LinkedBlockingDeque​(int capacity)
      创建具有给定（固定）容量的 LinkedBlockingDeque 。
      LinkedBlockingDeque​(Collection<? extends E> c)
      创建一个 LinkedBlockingDeque ，容量为 Integer.MAX_VALUE ，最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      在此deque的末尾插入指定的元素，除非它会违反容量限制。
      boolean addAll​(Collection<? extends E> c)
      按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该deque的末尾。
      void addFirst​(E e)
      如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的前面，如果当前没有可用的空间，则抛出一个 IllegalStateException 。
      void addLast​(E e)
      如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的末尾，如果当前没有可用空间，则抛出 IllegalStateException 。
      void clear​()
      从这个deque原子地删除所有的元素。
      boolean contains​(Object o)
      如果此deque包含指定的元素，则返回 true 。
      Iterator<E> descendingIterator​()
      以相反的顺序返回此deque中的元素的迭代器。
      int drainTo​(Collection<? super E> c)
      从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
      int drainTo​(Collection<? super E> c, int maxElements)
      最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
      E element​()
      检索，但不删除，由这个deque表示的队列的头。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。
      E getFirst​()
      检索，但不删除，这个deque的第一个元素。
      E getLast​()
      检索，但不删除，这个deque的最后一个元素。
      Iterator<E> iterator​()
      以正确的顺序返回此deque中的元素的迭代器。
      boolean offer​(E e)
      将指定的元素插入此双端队列表示的队列中（换句话说，在此双端队列的尾部），如果它是立即可行且不会违反容量限制，返回 true在成功和 false ，如果当前没有空间可用。
      boolean offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入由此deque表示的队列中（换句话说，在该deque的尾部），等待指定的等待时间（如果需要空间可用）。
      boolean offerFirst​(E e)
      插入此双端队列的前面，如果它是立即可行且不会违反容量限制，返回指定的元素 true在成功 false如果当前没有空间可用。
      boolean offerFirst​(E e, long timeout, TimeUnit unit)
      在此deque的前面插入指定的元素，等待指定的等待时间（如果需要空间可用）。
      boolean offerLast​(E e)
      插入此双端队列的末尾，如果它是立即可行且不会违反容量限制，返回指定的元素 true在成功 false如果当前没有空间可用。
      boolean offerLast​(E e, long timeout, TimeUnit unit)
      在此deque的末尾插入指定的元素，如果需要空间可用，等待指定的等待时间。
      E peek​()
      检索但不删除由此deque表示的队列的头部（换句话说，此deque的第一个元素），如果此deque为空，则返回 null 。
      E peekFirst​()
      检索，但不删除，此deque的第一个元素，或返回 null如果这个deque是空的。
      E peekLast​()
      检索但不删除此deque的最后一个元素，如果此deque为空，则返回 null 。
      E poll​()
      检索并删除由此deque表示的队列的头（换句话说，该deque的第一个元素），或者如果此deque为空，则返回 null 。
      E poll​(long timeout, TimeUnit unit)
      检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，等待到指定的等待时间（如有必要）使元素变为可用。
      E pollFirst​()
      检索并删除此deque的第一个元素，如果此deque为空，则返回 null 。
      E pollFirst​(long timeout, TimeUnit unit)
      检索并删除此deque的第一个元素，等待到指定的等待时间（如有必要）使元素变为可用。
      E pollLast​()
      检索并删除此deque的最后一个元素，如果此deque为空，则返回 null 。
      E pollLast​(long timeout, TimeUnit unit)
      检索并删除此deque的最后一个元素，等待到指定的等待时间，如果需要，元素可用。
      E pop​()
      从这个deque表示的堆栈中弹出一个元素。
      void push​(E e)
      将元素推送到由此deque表示的堆栈（换句话说，在该deque的头部），如果可以立即执行，而不违反容量限制，则抛出一个 IllegalStateException如果当前没有可用的空间）。
      void put​(E e)
      将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），等待空格变为可用时。
      void putFirst​(E e)
      在此deque的前面插入指定的元素，如有必要，等待空格变为可用。
      void putLast​(E e)
      在此deque的末尾插入指定的元素，如有必要，等待空格变为可用。
      int remainingCapacity​()
      返回此deque可以理想地（在没有内存或资源限制）的情况下接受而不阻止的附加元素数。
      E remove​()
      检索并删除由此deque表示的队列的头部。
      boolean remove​(Object o)
      从此deque中删除指定元素的第一个出现。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      E removeFirst​()
      检索并删除此deque的第一个元素。
      boolean removeFirstOccurrence​(Object o)
      从此deque中删除指定元素的第一个出现。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      E removeLast​()
      检索并删除此deque的最后一个元素。
      boolean removeLastOccurrence​(Object o)
      从此deque中删除指定元素的最后一次出现。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此deque中的元素数。
      Spliterator<E> spliterator​()
      在此deque中的元素上返回一个Spliterator 。
      E take​()
      检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，如果需要，等待，直到元素可用。
      E takeFirst​()
      检索并删除此deque的第一个元素，如有必要等待，直到元素可用。
      E takeLast​()
      检索并删除此deque的最后一个元素，如有必要等待，直到元素可用。
      Object[] toArray​()
      以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以适当的顺序返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此集合的字符串表示形式。

      • Methods inherited from class java.util.AbstractCollection

        containsAll, isEmpty

      • Methods inherited from interface java.util.Collection

        containsAll, equals, hashCode, isEmpty, parallelStream, stream

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LinkedBlockingDeque

        public LinkedBlockingDeque​()
        创建 LinkedBlockingDeque ，容量为 Integer.MAX_VALUE 。

      • LinkedBlockingDeque

        public LinkedBlockingDeque​(int capacity)
        创建一个给定（固定）容量的 LinkedBlockingDeque 。
        参数
        capacity - 这个deque的容量
        异常
        IllegalArgumentException - 如果 capacity小于1

      • LinkedBlockingDeque

        public LinkedBlockingDeque​(Collection<? extends E> c)
        创建一个 LinkedBlockingDeque ，容量为 Integer.MAX_VALUE ，最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
        参数
        c - 最初包含的元素的集合
        异常
        NullPointerException - 如果指定的集合或其任何元素为空

    • 方法详细信息

      • addFirst

        public void addFirst​(E e)
        描述从接口BlockingDeque复制
        如果可以在不违反容量限制的情况下立即将该指定元素插入到此deque的前面，如果当前没有可用的空间，则抛出一个IllegalStateException 。 当使用容量限制的deque时，通常最好使用offerFirst 。
        Specified by:
        addFirst在接口 BlockingDeque<E>
        Specified by:
        addFirst在接口 Deque<E>
        参数
        e - 要添加的元素
        异常
        IllegalStateException - 如果这个deque是满的
        NullPointerException - 如果指定的元素为空

      • addLast

        public void addLast​(E e)
        说明从接口BlockingDeque复制
        如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的末尾，则抛出一个IllegalStateException如果当前没有可用空间）。 当使用容量限制的deque时，通常最好使用offerLast 。
        Specified by:
        addLast在接口 BlockingDeque<E>
        Specified by:
        addLast在接口 Deque<E>
        参数
        e - 要添加的元素
        异常
        IllegalStateException - 如果这个deque是满的
        NullPointerException - 如果指定的元素为空

      • offerFirst

        public boolean offerFirst​(E e)
        说明从接口BlockingDeque复制
        插入此双端队列的前面，如果它是立即可行且不会违反容量限制，返回指定的元素true在成功false如果当前没有空间可用。 当使用容量限制的deque时，这种方法通常比addFirst方法更为方便 ，只能通过抛出异常来插入元素。
        Specified by:
        offerFirst在接口 BlockingDeque<E>
        Specified by:
        offerFirst在接口 Deque<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到此deque，否则为 false
        异常
        NullPointerException - 如果指定的元素为空

      • offerLast

        public boolean offerLast​(E e)
        说明从接口BlockingDeque复制
        插入此双端队列的末尾，如果它是立即可行且不会违反容量限制，返回指定的元素true在成功false如果当前没有空间可用。 当使用容量受限制的deque时，该方法通常比addLast方法更为方便 ，只能通过抛出异常来插入元素。
        Specified by:
        offerLast在接口 BlockingDeque<E>
        Specified by:
        offerLast在接口 Deque<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到此deque，否则为 false
        异常
        NullPointerException - 如果指定的元素为空

      • putFirst

        public void putFirst​(E e)
              throws InterruptedException
        描述从接口BlockingDeque复制
        在此deque的前面插入指定的元素，如有必要，等待空格变为可用。
        Specified by:
        putFirst在接口 BlockingDeque<E>
        参数
        e - 要添加的元素
        异常
        NullPointerException - 如果指定的元素为空
        InterruptedException - 如果在等待时中断

      • putLast

        public void putLast​(E e)
             throws InterruptedException
        说明从界面BlockingDeque复制
        在此deque的末尾插入指定的元素，如有必要，等待空格变为可用。
        Specified by:
        putLast在接口 BlockingDeque<E>
        参数
        e - 要添加的元素
        异常
        NullPointerException - 如果指定的元素为空
        InterruptedException - 如果在等待时中断

      • offerFirst

        public boolean offerFirst​(E e,
                          long timeout,
                          TimeUnit unit)
                   throws InterruptedException
        说明从界面： BlockingDeque复制
        在此deque的前面插入指定的元素，等待指定的等待时间（如果需要空间可用）。
        Specified by:
        offerFirst在接口 BlockingDeque<E>
        参数
        e - 要添加的元素
        timeout - 放弃之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在空间可用之前经过了指定的等待时间
        异常
        NullPointerException - 如果指定的元素为空
        InterruptedException - 如果等待中断

      • offerLast

        public boolean offerLast​(E e,
                         long timeout,
                         TimeUnit unit)
                  throws InterruptedException
        说明从接口BlockingDeque复制
        在此deque的末尾插入指定的元素，如果需要空间可用，等待指定的等待时间。
        Specified by:
        offerLast在接口 BlockingDeque<E>
        参数
        e - 要添加的元素
        timeout - 放弃之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在空间可用之前经过指定的等待时间
        异常
        NullPointerException - 如果指定的元素为空
        InterruptedException - 如果在等待时中断

      • removeFirst

        public E removeFirst​()
        说明从界面： Deque复制
        检索并删除此deque的第一个元素。 此方法与pollFirst的不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        removeFirst在接口 Deque<E>
        结果
        这个德克的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • removeLast

        public E removeLast​()
        说明从界面复制： Deque
        检索并删除此deque的最后一个元素。 此方法与pollLast不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        removeLast接口 Deque<E>
        结果
        这个德克的尾巴
        异常
        NoSuchElementException - 如果这个deque是空的

      • pollFirst

        public E pollFirst​()
        说明从接口Deque复制
        检索并删除此deque的第一个元素，如果此deque为空，则返回 null 。
        Specified by:
        pollFirst接口 Deque<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • pollLast

        public E pollLast​()
        描述从接口Deque复制
        检索并删除此deque的最后一个元素，如果此deque为空，则返回 null 。
        Specified by:
        pollLast在接口 Deque<E>
        结果
        这个deque的尾巴，或 null如果这个deque是空的

      • takeFirst

        public E takeFirst​()
            throws InterruptedException
        说明从界面： BlockingDeque复制
        检索并删除此deque的第一个元素，如有必要等待，直到元素可用。
        Specified by:
        takeFirst在接口 BlockingDeque<E>
        结果
        这个德克的头
        异常
        InterruptedException - 如果在等待时中断

      • takeLast

        public E takeLast​()
           throws InterruptedException
        说明从界面BlockingDeque复制
        检索并删除此deque的最后一个元素，如有必要等待，直到元素可用。
        Specified by:
        takeLast在接口 BlockingDeque<E>
        结果
        这个德克的尾巴
        异常
        InterruptedException - 如果在等待时中断

      • pollFirst

        public E pollFirst​(long timeout,
                   TimeUnit unit)
            throws InterruptedException
        说明从界面： BlockingDeque复制
        检索并删除此deque的第一个元素，等待到指定的等待时间（如有必要）使元素变为可用。
        Specified by:
        pollFirst在接口 BlockingDeque<E>
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        如果在元素可用之前经过了指定的等待时间，则此deque的头部，或 null
        异常
        InterruptedException - 如果在等待时中断

      • pollLast

        public E pollLast​(long timeout,
                  TimeUnit unit)
           throws InterruptedException
        描述从接口BlockingDeque复制
        检索并删除此deque的最后一个元素，等待到指定的等待时间，如果需要，元素可用。
        Specified by:
        pollLast在接口 BlockingDeque<E>
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        如果在元素可用之前经过了指定的等待时间，则此deque的尾部，或 null
        异常
        InterruptedException - 如果在等待时中断

      • getFirst

        public E getFirst​()
        说明从界面复制： Deque
        检索，但不删除，这个deque的第一个元素。 此方法与peekFirst不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        getFirst在接口 Deque<E>
        结果
        这个德克的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • getLast

        public E getLast​()
        说明从界面： Deque复制
        检索，但不删除，这个deque的最后一个元素。 此方法与peekLast不同之处在于，如果此deque为空，它将抛出异常。
        Specified by:
        getLast在接口 Deque<E>
        结果
        这个德克的尾巴
        异常
        NoSuchElementException - 如果这个deque是空的

      • peekFirst

        public E peekFirst​()
        描述从接口Deque复制
        检索但不删除此deque的第一个元素，如果此deque为空，则返回 null 。
        Specified by:
        peekFirst在接口 Deque<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • peekLast

        public E peekLast​()
        说明从界面Deque复制
        检索但不删除此deque的最后一个元素，如果此deque为空，则返回 null 。
        Specified by:
        peekLast在接口 Deque<E>
        结果
        这个deque的尾巴，或 null如果这个deque是空的

      • removeFirstOccurrence

        public boolean removeFirstOccurrence​(Object o)
        描述从接口BlockingDeque复制
        从此deque中删除指定元素的第一个出现。 如果deque不包含元素，则它不变。 更正式地，删除第一元素e使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。
        Specified by:
        removeFirstOccurrence在接口 BlockingDeque<E>
        Specified by:
        removeFirstOccurrence在接口 Deque<E>
        参数
        o - 要从此deque移除的元素（如果存在）
        结果
        true如果一个元素被删除作为这个调用的结果

      • removeLastOccurrence

        public boolean removeLastOccurrence​(Object o)
        说明从界面BlockingDeque复制
        从此deque中删除指定元素的最后一次出现。 如果deque不包含元素，则它不变。 更正式地，删除最后一个元素e ，使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。
        Specified by:
        removeLastOccurrence在接口 BlockingDeque<E>
        Specified by:
        removeLastOccurrence在接口 Deque<E>
        参数
        o - 要从此deque移除的元素（如果存在）
        结果
        true如果一个元素被删除作为这个调用的结果

      • add

        public boolean add​(E e)
        在此deque的末尾插入指定的元素，除非它会违反容量限制。 当使用容量限制的deque时，通常优选使用方法offer 。

        此方法相当于addLast(E) 。

        Specified by:
        add在接口 BlockingDeque<E>
        Specified by:
        add在接口 BlockingQueue<E>
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Deque<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractQueue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        IllegalStateException - 如果这个 IllegalStateException满了
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        说明从界面BlockingDeque复制
        将指定的元素插入此双端队列表示的队列中（换句话说，在此双端队列的尾部），如果它是立即可行且不会违反容量限制，返回true在成功和false ，如果当前没有空间可用。 当使用容量限制的deque时，这种方法通常比BlockingDeque.add(E)方法更为方便 ，只能通过抛出异常来插入元素。

        此方法相当于offerLast 。

        Specified by:
        offer在接口 BlockingDeque<E>
        Specified by:
        offer在接口 BlockingQueue<E>
        Specified by:
        offer在接口 Deque<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到此队列，否则为 false
        异常
        NullPointerException - 如果指定的元素为空

      • put

        public void put​(E e)
         throws InterruptedException
        描述从接口BlockingDeque复制
        将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），等待空格变为可用时。

        此方法相当于putLast 。

        Specified by:
        put在接口 BlockingDeque<E>
        Specified by:
        put在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        异常
        NullPointerException - 如果指定的元素为空
        InterruptedException - 如果在等待时中断

      • offer

        public boolean offer​(E e,
                     long timeout,
                     TimeUnit unit)
              throws InterruptedException
        描述从接口BlockingDeque复制
        将指定的元素插入由此deque表示的队列中（换句话说，在该deque的尾部），等待指定的等待时间（如果需要空间可用）。

        此方法相当于offerLast 。

        Specified by:
        offer在接口 BlockingDeque<E>
        Specified by:
        offer在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        timeout - 放弃之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果元素被添加到此deque，否则为 false
        异常
        NullPointerException - 如果指定的元素为空
        InterruptedException - 如果在等待时中断

      • remove

        public E remove​()
        检索并删除由此deque表示的队列的头部。 此方法与poll不同之处在于，如果此deque为空，它将抛出异常。

        此方法相当于removeFirst 。

        Specified by:
        remove在接口 BlockingDeque<E>
        Specified by:
        remove在接口 Deque<E>
        Specified by:
        remove在接口 Queue<E>
        重写：
        remove在 AbstractQueue<E>
        结果
        由这个德克队代表的队列的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • poll

        public E poll​()
        说明从界面BlockingDeque复制
        检索并删除由此deque（换句话说，此deque的第一个元素）表示的队列的头部，如果此deque为空，则返回null 。

        此方法相当于Deque.pollFirst() 。

        Specified by:
        poll在接口 BlockingDeque<E>
        Specified by:
        poll在接口 Deque<E>
        Specified by:
        poll在接口 Queue<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • take

        public E take​()
       throws InterruptedException
        说明从接口BlockingDeque复制
        检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，如果需要，等待，直到元素可用。

        此方法相当于takeFirst 。

        Specified by:
        take在接口 BlockingDeque<E>
        Specified by:
        take在接口 BlockingQueue<E>
        结果
        这个德克的头
        异常
        InterruptedException - 如果在等待时中断

      • poll

        public E poll​(long timeout,
              TimeUnit unit)
       throws InterruptedException
        说明从界面： BlockingDeque复制
        检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，等待到指定的等待时间（如有必要）使元素变为可用。

        此方法相当于pollFirst 。

        Specified by:
        poll在接口 BlockingDeque<E>
        Specified by:
        poll在接口 BlockingQueue<E>
        参数
        timeout - 放弃等待多久，单位为 unit
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        如果在元素可用之前经过了指定的等待时间，那么这个deque的头，或者是 null
        异常
        InterruptedException - 如果在等待时中断

      • element

        public E element​()
        检索，但不删除，由这个deque表示的队列的头。 此方法与peek的不同之处在于，如果此deque为空，它将抛出异常。

        此方法相当于getFirst 。

        Specified by:
        element在接口 BlockingDeque<E>
        Specified by:
        element在接口 Deque<E>
        Specified by:
        element在接口 Queue<E>
        重写：
        element在 AbstractQueue<E>
        结果
        由这个德克队代表的队列的头
        异常
        NoSuchElementException - 如果这个deque是空的

      • peek

        public E peek​()
        说明从接口BlockingDeque复制
        检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回null 。

        此方法相当于peekFirst 。

        Specified by:
        peek在接口 BlockingDeque<E>
        Specified by:
        peek在接口 Deque<E>
        Specified by:
        peek在接口 Queue<E>
        结果
        这个deque的头，或 null如果这个deque是空的

      • remainingCapacity

        public int remainingCapacity​()
        返回此deque可以理想地（在没有内存或资源限制）的情况下接受而不阻止的附加元素数。 这总是等于这个deque的初始容量，而不是这个deque的当前size 。

        请注意，您不能总是通过检查remainingCapacity来确定插入元素的尝试是否成功，因为可能是另一个线程即将插入或删除元素的情况。

        Specified by:
        remainingCapacity在接口 BlockingQueue<E>
        结果
        剩余容量

      • drainTo

        public int drainTo​(Collection<? super E> c)
        说明从界面BlockingQueue复制
        从该队列中删除所有可用的元素，并将它们添加到给定的集合中。 此操作可能比重复轮询此队列更有效。 尝试向集合c添加元素时遇到的失败可能导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将排队排队自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 将元素传输到的集合
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定集合不支持元素的添加
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或该队列的元素的某些属性会阻止将其添加到指定的集合

      • drainTo

        public int drainTo​(Collection<? super E> c,
                   int maxElements)
        说明从界面BlockingQueue复制
        最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。 尝试向集合c添加元素时遇到的失败可能会导致元素在抛出关联的异常时既不在两个集合中，也可能不是两个集合。 尝试将排队排队自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 将元素传输到的集合
        maxElements - 要传输的元素的最大数量
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定的集合不支持添加元素
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或此队列的某个元素的某些属性会阻止将其添加到指定的集合

      • push

        public void push​(E e)
        说明从接口BlockingDeque复制
        将元素推送到由此deque表示的堆栈（换句话说，在此deque的头部），如果可以立即执行此操作而不违反容量限制，则抛出IllegalStateException如果当前没有可用空间）。

        此方法相当于addFirst 。

        Specified by:
        push在接口 BlockingDeque<E>
        Specified by:
        push在接口 Deque<E>
        参数
        e - 要推送的元素
        异常
        IllegalStateException - 如果这个 IllegalStateException满了
        NullPointerException - 如果指定的元素为空

      • pop

        public E pop​()
        说明从界面： Deque复制
        从这个deque表示的堆栈中弹出一个元素。 换句话说，删除并返回此deque的第一个元素。

        此方法相当于Deque.removeFirst() 。

        Specified by:
        pop在接口 Deque<E>
        结果
        这个deque前面的元素（它是由这个deque表示的堆栈的顶部）
        异常
        NoSuchElementException - 如果这个deque是空的

      • remove

        public boolean remove​(Object o)
        从此deque中删除指定元素的第一个出现。 如果deque不包含元素，则它不变。 更正式地，删除第一元素e使得o.equals(e) （如果这样的元素存在）。 如果此deque包含指定的元素（或等效地，如果此deque由于调用而更改），则返回true 。

        此方法相当于removeFirstOccurrence 。

        Specified by:
        remove在接口 BlockingDeque<E>
        Specified by:
        remove在接口 BlockingQueue<E>
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 Deque<E>
        重写：
        remove在类 AbstractCollection<E>
        参数
        o - 要从此deque中删除的元素（如果存在）
        结果
        true如果这个deque因呼叫而改变了

      • size

        public int size​()
        返回此deque中的元素数。
        Specified by:
        size在接口 BlockingDeque<E>
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Deque<E>
        Specified by:
        size在类 AbstractCollection<E>
        结果
        这个deque中的元素数量

      • contains

        public boolean contains​(Object o)
        如果此deque包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此双端队列至少包含一个元素e这样o.equals(e) 。
        Specified by:
        contains在接口 BlockingDeque<E>
        Specified by:
        contains在接口 BlockingQueue<E>
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Deque<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要在此 o中检查遏制的对象
        结果
        true如果这个deque包含指定的元素

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该deque的末尾。 尝试以addAll为单位出现IllegalArgumentException 。
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 Deque<E>
        重写：
        addAll在类 AbstractQueue<E>
        参数
        c - 要插入此deque的元素
        结果
        true如果这个deque由于调用而改变了
        异常
        NullPointerException - 如果指定的集合或其任何元素为空
        IllegalArgumentException - 如果集合是这个deque
        IllegalStateException - 如果这个deque是满的
        另请参见：
        add(Object)

      • toArray

        public Object[] toArray​()
        以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组。

        返回的数组将是“安全的”，因为这个deque不会保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此deque中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        以适当的顺序返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果deque适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此deque的大小分配一个新数组。

        如果这个deque适合指定的数组，有空余的空间（即数组的元素比这个deque更多），紧接在deque结束之后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的deque。 以下代码可用于将deque转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])在功能上与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储deque的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组
        结果
        一个包含此deque中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此deque中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • toString

        public String toString​()
        描述从类别复制： AbstractCollection
        返回此集合的字符串表示形式。 字符串表示由集合的元素的列表按照它们的迭代器返回的顺序包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在类 AbstractCollection<E>
        结果
        此集合的字符串表示形式

      • clear

        public void clear​()
        从这个deque原子地删除所有的元素。 此呼叫返回后，deque将为空。
        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractQueue<E>

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回此deque中的元素的迭代器。 元素将按照从头（头）到最后（尾）的顺序返回。

        返回的迭代器是weakly consistent 。

        Specified by:
        iterator在接口 BlockingDeque<E>
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Deque<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        在这个deque中的元素以适当的顺序迭代

      • descendingIterator

        public Iterator<E> descendingIterator​()
        以相反的顺序返回此deque中的元素的迭代器。 元素将从最后（尾）到第一（头）的顺序返回。

        返回的迭代器是weakly consistent 。

        Specified by:
        descendingIterator在接口 Deque<E>
        结果
        在这个deque中的元素的迭代器以相反的顺序

      • spliterator

        public Spliterator<E> spliterator​()
        在此deque中的元素上返回Spliterator 。

        返回的拼接器是weakly consistent 。

        该Spliterator报告Spliterator.CONCURRENT ， Spliterator.ORDERED ，并Spliterator.NONNULL 。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Implementation Note:
        Spliterator实现 trySplit以允许有限的并行性。
        结果
        一个 Spliterator在这个deque的元素
        从以下版本开始：
        1.8

      • forEach

        public void forEach​(Consumer<? super E> action)
        说明从界面： Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的动作为空

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        说明从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 要删除的元素返回 true的谓词
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • removeAll

        public boolean removeAll​(Collection<?> c)
        描述从类别复制： AbstractCollection
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<E>
        重写：
        removeAll在类 AbstractCollection<E>
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        描述从类别复制： AbstractCollection
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果此收集因呼叫而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LinkedBlockingQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class LinkedBlockingQueue<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
        • java.util.concurrent.LinkedBlockingQueue<E>
  • 参数类型
    E - 保存在此队列中的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， BlockingQueue<E> ， Queue<E>

    public class LinkedBlockingQueue<E>
extends AbstractQueue<E>
implements BlockingQueue<E>, Serializable
    基于链接节点的可选限定的blocking queue 。 这个队列排列元素FIFO（先进先出）。 队列的头部是队列中最长的元素。 队列的尾部是队列中最短时间的元素。 新元素插入队列的尾部，队列检索操作获取队列头部的元素。 链接队列通常具有比基于阵列的队列更高的吞吐量，但在大多数并发应用程序中的可预测性能较低。

    可选容量绑定构造函数参数用作防止过多队列扩展的一种方法。 容量，如果未指定，等于Integer.MAX_VALUE 。 链接节点在每次插入时动态创建，除非这将使队列高于容量。

    该类及其迭代器实现Collection和Iterator接口的所有可选方法。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinkedBlockingQueue​()
      创建 LinkedBlockingQueue ，容量为 Integer.MAX_VALUE 。
      LinkedBlockingQueue​(int capacity)
      创建一个给定（固定）容量的 LinkedBlockingQueue 。
      LinkedBlockingQueue​(Collection<? extends E> c)
      创建 LinkedBlockingQueue容量为 Integer.MAX_VALUE ，最初包含给定集合中的元素，添加在收集迭代器的遍历顺序。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      从这个队列中原子地删除所有的元素。
      boolean contains​(Object o)
      如果此队列包含指定的元素，则返回 true 。
      int drainTo​(Collection<? super E> c)
      从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
      int drainTo​(Collection<? super E> c, int maxElements)
      最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      Iterator<E> iterator​()
      以正确的顺序返回该队列中的元素的迭代器。
      boolean offer​(E e)
      插入指定的元素在这个队列的尾部，如果有可能立即这样做不超过该队列的容量，返回 true在成功和 false如果此队列已满。
      boolean offer​(E e, long timeout, TimeUnit unit)
      在该队列的尾部插入指定的元素，必要时等待指定的等待时间才能使空间变得可用。
      E peek​()
      检索但不删除此队列的头，如果此队列为空，则返回 null 。
      E poll​()
      检索并删除此队列的头部，如果此队列为空，则返回 null 。
      E poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
      void put​(E e)
      在该队列的尾部插入指定的元素，如果需要，等待空格变为可用。
      int remainingCapacity​()
      返回此队列可以理想地（在没有内存或资源限制）的情况下接受而不阻止的附加元素数。
      boolean remove​(Object o)
      从该队列中删除指定元素的单个实例（如果存在）。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此队列中的元素数。
      Spliterator<E> spliterator​()
      返回此队列中的元素Spliterator 。
      E take​()
      检索并删除此队列的头，如有必要，等待元素可用。
      Object[] toArray​()
      以适当的顺序返回一个包含此队列中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此集合的字符串表示形式。

      • Methods inherited from class java.util.AbstractCollection

        containsAll, isEmpty

      • Methods inherited from class java.util.AbstractQueue

        add, addAll, element, remove

      • Methods inherited from interface java.util.concurrent.BlockingQueue

        add

      • Methods inherited from interface java.util.Collection

        addAll, containsAll, equals, hashCode, isEmpty, parallelStream, stream

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Queue

        element, remove

    • 构造方法详细信息

      • LinkedBlockingQueue

        public LinkedBlockingQueue​()
        创建 LinkedBlockingQueue ，容量为 Integer.MAX_VALUE 。

      • LinkedBlockingQueue

        public LinkedBlockingQueue​(int capacity)
        创建一个具有给定（固定）容量的 LinkedBlockingQueue 。
        参数
        capacity - 这个队列的容量
        异常
        IllegalArgumentException - 如果 capacity不大于零

      • LinkedBlockingQueue

        public LinkedBlockingQueue​(Collection<? extends E> c)
        创建 LinkedBlockingQueue容量为 Integer.MAX_VALUE ，最初包含给定集合中的元素，添加在收集迭代器的遍历顺序。
        参数
        c - 最初包含的元素的集合
        异常
        NullPointerException - 如果指定的集合或其任何元素为空

    • 方法详细信息

      • size

        public int size​()
        返回此队列中的元素数。
        Specified by:
        size在界面 Collection<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此队列中的元素数

      • remainingCapacity

        public int remainingCapacity​()
        返回此队列可以理想地（在没有内存或资源限制）的情况下接受而不阻止的附加元素数。 这总是等于该队列的初始容量少于此队列的当前size 。

        请注意，您不能总是通过检查remainingCapacity来判断是否尝试插入元素，因为可能是另一个线程即将插入或删除元素的情况。

        Specified by:
        remainingCapacity在接口 BlockingQueue<E>
        结果
        剩余容量

      • put

        public void put​(E e)
         throws InterruptedException
        在该队列的尾部插入指定的元素，如果需要，等待空格变为可用。
        Specified by:
        put在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        异常
        InterruptedException - 如果在等待时中断
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e,
                     long timeout,
                     TimeUnit unit)
              throws InterruptedException
        在该队列的尾部插入指定的元素，必要时等待指定的等待时间才能使空间变得可用。
        Specified by:
        offer在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        timeout - 放弃等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在空间可用之前经过指定的等待时间
        异常
        InterruptedException - 如果在等待时中断
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        插入指定的元素在这个队列的尾部，如果有可能立即这样做不超过该队列的容量，返回true在成功和false如果此队列已满。 当使用容量限制队列时，这种方法通常比方法add更为方便 ，只能通过抛出异常来插入元素。
        Specified by:
        offer在接口 BlockingQueue<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到该队列，否则为 false
        异常
        NullPointerException - 如果指定的元素为空

      • take

        public E take​()
       throws InterruptedException
        描述从接口BlockingQueue复制
        检索并删除此队列的头，如有必要，等待元素可用。
        Specified by:
        take在接口 BlockingQueue<E>
        结果
        这个队列的头
        异常
        InterruptedException - 如果在等待时中断

      • poll

        public E poll​(long timeout,
              TimeUnit unit)
       throws InterruptedException
        说明从界面复制： BlockingQueue
        检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
        Specified by:
        poll在接口 BlockingQueue<E>
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        如果在元素可用之前经过指定的等待时间，则该队列的头部，或 null
        异常
        InterruptedException - 如果中断等待

      • poll

        public E poll​()
        说明从界面Queue复制
        检索并删除此队列的头部，如果此队列为空，则返回 null 。
        Specified by:
        poll在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • peek

        public E peek​()
        说明从界面Queue复制
        检索但不删除此队列的头，或者如果此队列为空，则返回 null 。
        Specified by:
        peek在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • remove

        public boolean remove​(Object o)
        从该队列中删除指定元素的单个实例（如果存在）。 更正式地，删除元素e使得o.equals(e) ，如果该队列包含一个或多个这样的元素。 如果此队列包含指定的元素（或等效地，如果此队列作为调用的结果而更改），则返回true 。
        Specified by:
        remove在接口 BlockingQueue<E>
        Specified by:
        remove在接口 Collection<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此队列中删除的元素（如果存在）
        结果
        true如果此队列由于调用而更改

      • contains

        public boolean contains​(Object o)
        如果此队列包含指定的元素，则返回true 。 更正式地，返回true当且仅当该队列至少包含一个元素e ，使得o.equals(e) 。
        Specified by:
        contains在接口 BlockingQueue<E>
        Specified by:
        contains在接口 Collection<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要检查此队列中的遏制的对象
        结果
        true如果此队列包含指定的元素

      • toArray

        public Object[] toArray​()
        以适当的顺序返回一个包含此队列中所有元素的数组。

        返回的数组将是“安全的”，因为该队列不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此队列中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果队列适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此队列的大小分配一个新数组。

        如果这个队列适合指定的数组空间（即阵列比此队列更多的元素），则队列结束后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的队列。 以下代码可用于将队列转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储队列的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组
        结果
        一个包含此队列中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • toString

        public String toString​()
        描述从类别复制： AbstractCollection
        返回此集合的字符串表示形式。 字符串表示由集合的元素的列表按照它们的迭代器返回的顺序包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 AbstractCollection<E>
        结果
        此集合的字符串表示形式

      • clear

        public void clear​()
        从这个队列中原子地删除所有的元素。 此呼叫返回后队列将为空。
        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractQueue<E>

      • drainTo

        public int drainTo​(Collection<? super E> c)
        描述从接口BlockingQueue复制
        从该队列中删除所有可用的元素，并将它们添加到给定的集合中。 此操作可能比重复轮询此队列更有效。 尝试向集合c添加元素时遇到的故障可能会导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将队列排入自身导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 将元素传输到的集合
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定的集合不支持添加元素
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或此队列的某个元素的某些属性阻止将其添加到指定的集合

      • drainTo

        public int drainTo​(Collection<? super E> c,
                   int maxElements)
        说明从接口BlockingQueue复制
        最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。 尝试向集合c添加元素时遇到的失败可能会导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将排队排队自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 传输元素的集合
        maxElements - 要传输的元素的最大数量
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定的集合不支持添加元素
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或该队列的某个元素的某些属性阻止将其添加到指定的集合

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回该队列中的元素的迭代器。 元素将按照从头（头）到最后（尾）的顺序返回。

        返回的迭代器是weakly consistent 。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        在该队列中的元素以适当的顺序迭代

      • spliterator

        public Spliterator<E> spliterator​()
        在此队列中的元素上返回Spliterator 。

        返回的拼接器是weakly consistent 。

        该Spliterator报告Spliterator.CONCURRENT ， Spliterator.ORDERED ，并Spliterator.NONNULL 。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Implementation Note:
        Spliterator实现 trySplit以允许有限的并行性。
        结果
        一个 Spliterator在这个队列中的元素
        从以下版本开始：
        1.8

      • forEach

        public void forEach​(Consumer<? super E> action)
        说明从界面复制： Iterable
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        说明从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 要删除的元素返回 true的谓词
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • removeAll

        public boolean removeAll​(Collection<?> c)
        描述从类别复制： AbstractCollection
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        描述从类复制： AbstractCollection
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LinkedTransferQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class LinkedTransferQueue<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
        • java.util.concurrent.LinkedTransferQueue<E>
  • 参数类型
    E - 保存在此队列中的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， BlockingQueue<E> ， TransferQueue<E> ， Queue<E>

    public class LinkedTransferQueue<E>
extends AbstractQueue<E>
implements TransferQueue<E>, Serializable
    基于链接节点的无界TransferQueue 。 这个队列相对于任何给定的生产者订购元素FIFO（先进先出）。 队列的头部是那些已经排队的元素是一些生产者的最长时间。 队列的尾部是那些已经在队列上的元素是一些生产者的最短时间。

    请注意，与大多数集合不同， size方法不是一个常时操作。 由于这些队列的异步性质，确定当前元素数量需要遍历元素，因此如果在遍历期间修改此集合，则可能会报告不准确的结果。

    该添加，删除，或检查多个元件批量操作，如AbstractQueue.addAll(java.util.Collection<? extends E>) ， removeIf(java.util.function.Predicate<? super E>)或forEach(java.util.function.Consumer<? super E>)待原子方式执行， 不能保证。 例如，与addAll操作并发的forEach遍历可能仅观察到一些添加的元素。

    该类及其迭代器实现了Collection和Iterator接口的所有可选方法。

    内存一致性效果：与其他并发集合一样，在将对象放入LinkedTransferQueue happen-before之后的线程中的操作，随后从另一个线程中的LinkedTransferQueue访问或删除该元素。

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinkedTransferQueue​()
      创建一个最初的空 LinkedTransferQueue 。
      LinkedTransferQueue​(Collection<? extends E> c)
      创建一个 LinkedTransferQueue最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      在该队列的尾部插入指定的元素。
      void clear​()
      从此队列中删除所有元素。
      boolean contains​(Object o)
      如果此队列包含指定的元素，则返回 true 。
      int drainTo​(Collection<? super E> c)
      从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
      int drainTo​(Collection<? super E> c, int maxElements)
      最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
      void forEach​(Consumer<? super E> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。
      int getWaitingConsumerCount​()
      通过 BlockingQueue.take()或定时 poll返回等待接收元素的消费者数量的估计。
      boolean hasWaitingConsumer​()
      返回 true ，如果有至少一个消费者等待经由以接收元件 BlockingQueue.take()或定时 poll 。
      boolean isEmpty​()
      如果此队列不包含元素，则返回 true 。
      Iterator<E> iterator​()
      以正确的顺序返回该队列中的元素的迭代器。
      boolean offer​(E e)
      在该队列的尾部插入指定的元素。
      boolean offer​(E e, long timeout, TimeUnit unit)
      在该队列的尾部插入指定的元素。
      E peek​()
      检索但不删除此队列的头，如果此队列为空，则返回 null 。
      E poll​()
      检索并删除此队列的头部，如果此队列为空，则返回 null 。
      E poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
      void put​(E e)
      在该队列的尾部插入指定的元素。
      int remainingCapacity​()
      始终返回 Integer.MAX_VALUE因为 LinkedTransferQueue不受容量限制。
      boolean remove​(Object o)
      从该队列中删除指定元素的单个实例（如果存在）。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      boolean removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      int size​()
      返回此队列中的元素数。
      Spliterator<E> spliterator​()
      返回此队列中的元素Spliterator 。
      E take​()
      检索并删除此队列的头，如有必要，等待元素可用。
      Object[] toArray​()
      以适当的顺序返回一个包含此队列中所有元素的数组。
      <T> T[] toArray​(T[] a)
      以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此集合的字符串表示形式。
      void transfer​(E e)
      将元素转移给消费者，如有必要，等待。
      boolean tryTransfer​(E e)
      如果可能的话，将元件立即转移给等待的消费者。
      boolean tryTransfer​(E e, long timeout, TimeUnit unit)
      如果可以在超时过程之前将元素传送给消费者。

      • Methods inherited from class java.util.AbstractCollection

        containsAll

      • Methods inherited from class java.util.AbstractQueue

        addAll, element, remove

      • Methods inherited from interface java.util.Collection

        addAll, containsAll, equals, hashCode, parallelStream, stream

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Queue

        element, remove

    • 构造方法详细信息

      • LinkedTransferQueue

        public LinkedTransferQueue​()
        创建一个最初的空 LinkedTransferQueue 。

      • LinkedTransferQueue

        public LinkedTransferQueue​(Collection<? extends E> c)
        创建一个 LinkedTransferQueue最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
        参数
        c - 最初包含的元素的集合
        异常
        NullPointerException - 如果指定的集合或其任何元素为空

    • 方法详细信息

      • toString

        public String toString​()
        描述从类别复制： AbstractCollection
        返回此集合的字符串表示形式。 字符串表示由集合的元素的列表按照它们的迭代器返回的顺序包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 AbstractCollection<E>
        结果
        此集合的字符串表示形式

      • toArray

        public Object[] toArray​()
        以适当的顺序返回一个包含此队列中所有元素的数组。

        返回的数组将是“安全的”，因为该队列不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray中的 AbstractCollection<E>
        结果
        一个包含此队列中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果队列适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此队列的大小分配一个新数组。

        如果这个队列符合指定的数组空间（即数组的队列比此队列更多），则队列结束后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的队列。 以下代码可用于将队列转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储队列的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组
        结果
        一个包含此队列中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • spliterator

        public Spliterator<E> spliterator​()
        返回此队列中的元素Spliterator 。

        返回的分配器是weakly consistent 。

        该Spliterator报告Spliterator.CONCURRENT ， Spliterator.ORDERED ，并Spliterator.NONNULL 。

        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Implementation Note:
        Spliterator实现 trySplit以允许有限的并行性。
        结果
        一个 Spliterator在这个队列中的元素
        从以下版本开始：
        1.8

      • put

        public void put​(E e)
        在该队列的尾部插入指定的元素。 由于队列无限制，此方法将永远不会阻止。
        Specified by:
        put在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        异常
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e,
                     long timeout,
                     TimeUnit unit)
        在该队列的尾部插入指定的元素。 由于队列无限制，此方法将永远不会阻止或返回false 。
        Specified by:
        offer在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        timeout - 放弃之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true （由 BlockingQueue.offer指定）
        异常
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        在该队列的尾部插入指定的元素。 队列无限制时，此方法永远不会返回false 。
        Specified by:
        offer在接口 BlockingQueue<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Queue.offer(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • add

        public boolean add​(E e)
        在该队列的尾部插入指定的元素。 由于队列无限制，此方法将永远不会抛出IllegalStateException或返回false 。
        Specified by:
        add接口 BlockingQueue<E>
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractQueue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        NullPointerException - 如果指定的元素为空

      • tryTransfer

        public boolean tryTransfer​(E e)
        如果可能的话，将元件立即转移给等待的消费者。

        更准确地说，如果存在已经等待接收消费者的消费者（ take()或定时poll ），则立即转移指定的元素，否则返回false而不对该元素进行排队。

        Specified by:
        tryTransfer在接口 TransferQueue<E>
        参数
        e - 要传输的元素
        结果
        true如果元素被转移，否则为 false
        异常
        NullPointerException - 如果指定的元素为空

      • transfer

        public void transfer​(E e)
              throws InterruptedException
        将元素转移给消费者，如有必要，等待。

        更准确地说，如果存在已经等待接收消费者的消费者（ take()或定时poll ），则立即传输指定的元素，否则将指定的元素插入到该队列的尾部，并等待消费者收到该元素。

        Specified by:
        transfer在接口 TransferQueue<E>
        参数
        e - 要传输的元素
        异常
        NullPointerException - 如果指定的元素为空
        InterruptedException - 如果在等待时中断，在这种情况下元素不会被排入队列

      • tryTransfer

        public boolean tryTransfer​(E e,
                           long timeout,
                           TimeUnit unit)
                    throws InterruptedException
        如果可以在超时过程之前将元素传送给消费者。

        更确切地说，如果存在已经等待接收消费者的消费者（ take()或定时poll ）， 则会立即转移指定的元素，否则在该队列的尾部插入指定的元素，并等待消费者收到该元素，返回false如果在元素可以传输之前经过了指定的等待时间。

        Specified by:
        tryTransfer在接口 TransferQueue<E>
        参数
        e - 要传输的元素
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在完成之前经过了指定的等待时间，在这种情况下，元素不会排入队列
        异常
        NullPointerException - 如果指定的元素为空
        InterruptedException - 如果在等待时中断，在这种情况下元素不会被排入队列

      • take

        public E take​()
       throws InterruptedException
        说明从界面BlockingQueue复制
        检索并删除此队列的头，如有必要，等待元素可用。
        Specified by:
        take在接口 BlockingQueue<E>
        结果
        这个队列的头
        异常
        InterruptedException - 如果中断等待

      • poll

        public E poll​(long timeout,
              TimeUnit unit)
       throws InterruptedException
        说明从界面BlockingQueue复制
        检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
        Specified by:
        poll在接口 BlockingQueue<E>
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        该队列的头部，如果在元素可用之前经过了指定的等待时间， null
        异常
        InterruptedException - 如果在等待时中断

      • poll

        public E poll​()
        描述从接口Queue复制
        检索并删除此队列的头部，如果此队列为空，则返回 null 。
        Specified by:
        poll在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • drainTo

        public int drainTo​(Collection<? super E> c)
        描述从接口BlockingQueue复制
        从该队列中删除所有可用的元素，并将它们添加到给定的集合中。 此操作可能比重复轮询此队列更有效。 尝试向集合c添加元素时遇到的故障可能导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将排队排队自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 传输元素的集合
        结果
        转移的元素数量
        异常
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或该队列的某个元素的某些属性阻止将其添加到指定的集合

      • drainTo

        public int drainTo​(Collection<? super E> c,
                   int maxElements)
        描述从接口BlockingQueue复制
        最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。 尝试向集合c添加元素时遇到的失败可能导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将排队排队自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 将元素传输到的集合
        maxElements - 要传输的元素的最大数量
        结果
        转移的元素数量
        异常
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或此队列的某个元素的某些属性会阻止将其添加到指定的集合

      • iterator

        public Iterator<E> iterator​()
        以正确的顺序返回该队列中的元素的迭代器。 元素将按照从头（头）到最后（尾）的顺序返回。

        返回的迭代器是weakly consistent 。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        在该队列中的元素以适当的顺序迭代

      • peek

        public E peek​()
        说明从接口Queue复制
        检索但不删除此队列的头，如果此队列为空，则返回 null 。
        Specified by:
        peek在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • isEmpty

        public boolean isEmpty​()
        如果此队列不包含元素，则返回 true 。
        Specified by:
        isEmpty在接口 Collection<E>
        重写：
        isEmpty在 AbstractCollection<E>
        结果
        true如果此队列不包含元素

      • hasWaitingConsumer

        public boolean hasWaitingConsumer​()
        描述从接口TransferQueue复制
        返回true ，如果有至少一个消费者等待经由以接收元件BlockingQueue.take()或定时poll 。 返回值代表一时的状态。
        Specified by:
        hasWaitingConsumer在接口 TransferQueue<E>
        结果
        true如果至少有一个等待消费者

      • size

        public int size​()
        返回此队列中的元素数。 如果此队列包含Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。

        请注意，与大多数集合不同，此方法不是一个常时操作。 由于这些队列的异步性质，确定当前的元素数需要O（n）遍历。

        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此队列中的元素数

      • getWaitingConsumerCount

        public int getWaitingConsumerCount​()
        描述从接口TransferQueue复制
        通过BlockingQueue.take()或定时poll返回等待接收元素的消费者数量的估计。 返回值是一个近似的瞬间状态，如果消费者已经完成或放弃等待，这可能是不准确的。 该值可能对监控和启发式有用，但不适用于同步控制。 这种方法的实施可能比TransferQueue.hasWaitingConsumer()明显慢。
        Specified by:
        getWaitingConsumerCount在接口 TransferQueue<E>
        结果
        消费者等待接收元素的数量

      • remove

        public boolean remove​(Object o)
        从该队列中删除指定元素的单个实例（如果存在）。 更正式地，删除元素e使得o.equals(e) ，如果该队列包含一个或多个这样的元素。 如果此队列包含指定的元素（或等效地，如果此队列作为调用的结果而更改），则返回true 。
        Specified by:
        remove在接口 BlockingQueue<E>
        Specified by:
        remove在接口 Collection<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此队列中删除的元素（如果存在）
        结果
        true如果此队列由于调用而更改

      • contains

        public boolean contains​(Object o)
        如果此队列包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此队列至少包含一个元素e这样o.equals(e) 。
        Specified by:
        contains在接口 BlockingQueue<E>
        Specified by:
        contains在接口 Collection<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要检查此队列中的遏制的对象
        结果
        true如果此队列包含指定的元素

      • remainingCapacity

        public int remainingCapacity​()
        始终返回 Integer.MAX_VALUE因为 LinkedTransferQueue不受容量限制。
        Specified by:
        remainingCapacity在接口 BlockingQueue<E>
        结果
        Integer.MAX_VALUE （由 BlockingQueue.remainingCapacity指定）

      • removeIf

        public boolean removeIf​(Predicate<? super E> filter)
        描述从接口Collection复制
        删除满足给定谓词的此集合的所有元素。 在迭代或谓词中抛出的错误或运行时异常被转发给调用者。
        Specified by:
        removeIf在接口 Collection<E>
        参数
        filter - 要删除的元素返回 true的谓词
        结果
        true如果有任何元素被删除
        异常
        NullPointerException - 如果指定的过滤器为空

      • removeAll

        public boolean removeAll​(Collection<?> c)
        说明从类别复制： AbstractCollection
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果这个集合由于调用而改变了
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不支持空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        说明从类别复制AbstractCollection
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果该收集因呼叫而更改
        异常
        NullPointerException - 如果此集合包含一个或多个空元素，并且指定的集合不允许空元素（ optional ），或者如果指定的集合为空
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • clear

        public void clear​()
        描述从类别复制： AbstractQueue
        从此队列中删除所有元素。 此呼叫返回后队列将为空。

        这个实现反复调用poll，直到它返回null 。

        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractQueue<E>

      • forEach

        public void forEach​(Consumer<? super E> action)
        描述从接口Iterable复制
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        Specified by:
        forEach在接口 Iterable<E>
        参数
        action - 要对每个元素执行的操作
        异常
        NullPointerException - 如果指定的动作为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Phaser (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class Phaser

  • java.lang.Object
    • java.util.concurrent.Phaser

  • public class Phaser
extends Object
    一个可重复使用的同步屏障，功能类似于CyclicBarrier和CountDownLatch，但支持更灵活的使用。

    注册。 与其他障碍的情况不同， 注册在移相器上同步的各方的数量可能随时间而变化。 任务可以在任何时间（使用的方法来注册register() ， bulkRegister(int) ，或构造建立各方的初始数的形式），和（使用任何抵达时任选注销arriveAndDeregister() ）。 与大多数基本同步结构一样，注册和注销仅影响内部计数; 他们没有建立任何进一步的内部簿记，所以任务无法查询是否注册。 （但是，您可以通过对此类进行子类化来介绍此类簿记。）

    同步。 像CyclicBarrier一样， Phaser可能会重复等待。 方法arriveAndAwaitAdvance()具有类似于CyclicBarrier.await的效果。 每一代移相器都具有相关的相位数。 相位数从零开始，当所有各方到达移相器时，前进，达到Integer.MAX_VALUE后Integer.MAX_VALUE零。 通过使用阶段数字，可以通过两种可由任何注册方调用的方法，在到达移相器和等待其他人时独立控制动作：

    • 到达。 方法arrive()和arriveAndDeregister()记录到达。 这些方法不会阻塞，而是返回相关的到达阶段数 ; 即到达应用的移相器的相位数。 当给定阶段的最后一方到达时，执行可选操作，并且阶段前进。 这些动作由触发相位提前的一方执行，并且通过重写方法onAdvance(int, int)进行排列，该方法也控制终止。 覆盖此方法与CyclicBarrier相似，但更灵活。
    • 等候。 方法awaitAdvance(int)需要一个指示到达阶段数的参数，并且当相位器前进到（或已经处于）不同阶段时返回。 与使用CyclicBarrier类似结构不同，即使等待的线程被中断，方法awaitAdvance继续等待。 中断和超时版本也是可用的，但任务等待中断或超时时遇到的异常不会改变移相器的状态。 如有必要，您可以在调用forceTermination之后，在这些异常的处理程序中执行任何关联的恢复。 也可以在ForkJoinPool中执行的任务使用抖动 。 如果池的并行度级别可以容纳同时被阻止的方的最大数量，则确保进度。

    终止。 移相器可以进入终止状态，可以使用方法isTerminated()进行检查。 一旦终止，所有同步方法立即返回而不等待提前，如负值返回值所示。 同样，终止时注册的尝试也没有效果。 当调用onAdvance返回true时触发终止。 如果注销已经使注册方的数量变为零，默认实现将返回true 。 如下所示，当相位器以固定次数的迭代控制动作时，当当前相位数达到阈值时，通常方便的是重写该方法以导致终止。 方法forceTermination()也可用于突然释放等待线程并允许它们终止。

    分层。 移相器可以分层 （即，以树结构构造）以减少争用。 具有大量聚会的激动剂，否则将会遇到重度的同步竞争成本，可能会被设置为使得一些子相位器共享一个共同的父节点。 这可能会大大增加吞吐量，即使它产生更大的每操作开销。

    在一个分层相位的树中，自动管理儿童相机与其父母的注册和注销。 每当儿童移动设备的注册方数量变为非零（在Phaser(Phaser,int)构造函数register()或bulkRegister(int)中确定 ）时，子移相器已向其父级注册。 无论何时由于引用arriveAndDeregister() ，注册方的数量变为零，则子移动程序将从其父级注销。

    监测。 虽然同步方法只能由注册方调用，但是可以由任何呼叫者监视移相器的当前状态。 任何时候，共有getRegisteredParties()个派对，其中getArrivedParties()已到达现阶段（ getPhase() ）。 剩余的（ getUnarrivedParties() ）派对到达时，阶段进行。 这些方法返回的值可以反映瞬态状态，因此对于同步控制通常不是有用的。 方法toString()以便于非正式监控的形式返回这些状态查询的快照。

    示例用法：

    可以使用A Phaser而不是CountDownLatch来控制为可变数量的方提供服务的一次性动作。 典型的成语是用于首先注册的方法，然后启动所有操作，然后注销，如：

       void runTasks(List<Runnable> tasks) { Phaser startingGate = new Phaser(1); // "1" to register self // create and start threads for (Runnable task : tasks) { startingGate.register(); new Thread(() -> { startingGate.arriveAndAwaitAdvance(); task.run(); }).start(); } // deregister self to allow threads to proceed startingGate.arriveAndDeregister(); }

    导致一组线程重复执行给定次数迭代的一种方法是覆盖onAdvance ：

       void startTasks(List<Runnable> tasks, int iterations) { Phaser phaser = new Phaser() { protected boolean onAdvance(int phase, int registeredParties) { return phase >= iterations - 1 || registeredParties == 0; } }; phaser.register(); for (Runnable task : tasks) { phaser.register(); new Thread(() -> { do { task.run(); phaser.arriveAndAwaitAdvance(); } while (!phaser.isTerminated()); }).start(); } // allow threads to proceed; don't wait for them phaser.arriveAndDeregister(); }
    如果主要任务必须等待终止，则可能会重新注册，然后执行类似的循环：
       // ... phaser.register(); while (!phaser.isTerminated()) phaser.arriveAndAwaitAdvance();

    可以使用相关的结构来等待上下文中的特定阶段数字，在这些上下文中，您确定该阶段永远不会包围Integer.MAX_VALUE 。 例如：

       void awaitPhase(Phaser phaser, int phase) { int p = phaser.register(); // assumes caller not already registered while (p < phase) { if (phaser.isTerminated()) // ... deal with unexpected termination else p = phaser.arriveAndAwaitAdvance(); } phaser.arriveAndDeregister(); }

    要使用一个相n树创建一组n任务，您可以使用以下形式的代码，假设一个具有构造函数的Task类在构造时接受它注册的Phaser 。 在调用build(new Task[n], 0, n, new Phaser())之后，可以启动这些任务，例如通过提交到池：

       void build(Task[] tasks, int lo, int hi, Phaser ph) { if (hi - lo > TASKS_PER_PHASER) { for (int i = lo; i < hi; i += TASKS_PER_PHASER) { int j = Math.min(i + TASKS_PER_PHASER, hi); build(tasks, i, j, new Phaser(ph)); } } else { for (int i = lo; i < hi; ++i) tasks[i] = new Task(ph); // assumes new Task(ph) performs ph.register() } }
    TASKS_PER_PHASER的最佳值主要取决于预期的同步速率。 低至4的值可能适用于非常小的每阶段任务机构（因此高速率），或者对于极大的任务机构可能达到数百。

    实施说明 ：本实施方式将最大派对数限制为65535.尝试注册附加方将导致IllegalStateException 。 但是，您可以并且应该创建分层相位器来适应任意大量的参与者。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Constructor 描述
      Phaser​()
      创建一个新的移相器，没有最初的注册方，没有父级和初始阶段数0。
      Phaser​(int parties)
      创建一个新的移相器与给定数量的注册无障碍方，没有父母和初始阶段0。
      Phaser​(Phaser parent)
      相当于 Phaser(parent, 0) 。
      Phaser​(Phaser parent, int parties)
      与给定的父母和注册的无礼方的数量创建一个新的移相器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int arrive​()
      抵达这个移相器，而不用等待别人到达。
      int arriveAndAwaitAdvance​()
      到达这个移相器，等待其他人。
      int arriveAndDeregister​()
      到达这个移相器并从其中注销，而无需等待别人到达。
      int awaitAdvance​(int phase)
      等待该相位器的相位从给定相位值前进，如果当前相位不等于给定相位值，则立即返回，或者该相位器被终止。
      int awaitAdvanceInterruptibly​(int phase)
      等待相移器的相位从给定的相位值推进，抛出 InterruptedException如果在等待时中断，或者如果当前相位不等于给定的相位值或者该相位器被终止，则立即返回。
      int awaitAdvanceInterruptibly​(int phase, long timeout, TimeUnit unit)
      等待该移相器的相位从给定的相位值或给定的超时时间 InterruptedException到等待时抛出 InterruptedException ，如果当前相位不等于给定的相位值或者该相位器被终止，则立即返回。
      int bulkRegister​(int parties)
      增加给定数量的新的有争议的派对到这个移相器。
      void forceTermination​()
      强制此移相器进入终止状态。
      int getArrivedParties​()
      返回在此移相器的当前阶段到达的已注册方的数量。
      Phaser getParent​()
      返回此移相器的父级，如果没有，则返回 null 。
      int getPhase​()
      返回当前相位数。
      int getRegisteredParties​()
      返回在此移动设备上注册的各方数量。
      Phaser getRoot​()
      返回此移相器的根祖先，如果它没有父代，则与该移相器相同。
      int getUnarrivedParties​()
      返回尚未到达此移相器当前阶段的已注册方的数量。
      boolean isTerminated​()
      如果此移相器已被终止，则返回 true 。
      protected boolean onAdvance​(int phase, int registeredParties)
      在即将进行的相位提前执行动作的可覆盖方法，并控制终止。
      int register​()
      添加一个新的unririved派对这个移相器。
      String toString​()
      返回一个标识此移相器的字符串及其状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Phaser

        public Phaser​()
        创建一个没有初始注册方，没有父级和初始阶段数0的新移相器。使用此移相器的任何线程都需要先注册。

      • Phaser

        public Phaser​(int parties)
        创建一个新的移相器与给定数量的注册无障碍方，没有父母和初始阶段0。
        参数
        parties - 需要进入下一阶段的各方数量
        异常
        IllegalArgumentException - 如果当事人不到零或大于支持的最高人数

      • Phaser

        public Phaser​(Phaser parent)
        相当于 Phaser(parent, 0) 。
        参数
        parent - 父移相器

      • Phaser

        public Phaser​(Phaser parent,
              int parties)
        与给定的父母和注册的无礼方的数量创建一个新的移相器。 当给定的父对象不为空且给定的参与方数量大于零时，该子级移动器在其父级注册。
        参数
        parent - 父移相器
        parties - 进入下一阶段所需的当事人数
        异常
        IllegalArgumentException - 如果当事方小于零或大于所支持的最大数目

    • 方法详细信息

      • register

        public int register​()
        添加一个新的unririved派对这个移相器。 如果正在进行onAdvance(int, int)的调用，则此方法可能会在返回前等待完成。 如果此移动设备有父母，而此移动设备以前没有注册方，则该儿童移动设备也向其父母注册。 如果此移相器被终止，则尝试注册不起作用，并返回负值。
        结果
        此注册申请的到达阶段编号。 如果该值为负值，则该移相器已终止，在这种情况下注册无效。
        异常
        IllegalStateException - 如果尝试注册超过最多支持的方数

      • bulkRegister

        public int bulkRegister​(int parties)
        增加给定数量的新的有争议的派对到这个移相器。 如果持续调用onAdvance(int, int)正在进行中，则此方法可能会在返回前等待完成。 如果此移动设备有父母，而且指定的当事人数量大于零，并且此移动设备以前没有注册方，则该子版移动设备也向其父母注册。 如果此移相器被终止，则尝试注册不起作用，并返回负值。
        参数
        parties - 需要进入下一阶段的附加方的数量
        结果
        此注册申请的到达阶段编号。 如果该值为负值，则该移相器已终止，在这种情况下注册无效。
        异常
        IllegalStateException - 如果尝试注册超过最多支持的方数
        IllegalArgumentException - 如果是 parties < 0

      • arrive

        public int arrive​()
        抵达这个移相器，而不用等待别人到达。

        这是非注册方调用此方法的使用错误。 但是，如果有的话，这个错误可能会导致一个IllegalStateException 。

        结果
        到达阶段数，如果终止则为负值
        异常
        IllegalStateException - 如果没有终止，无礼的人数将变为负数

      • arriveAndDeregister

        public int arriveAndDeregister​()
        到达这个移相器并从其中注销，而无需等待别人到达。 撤销注销减少了在未来阶段推进的各方数量。 如果这个移动设备有父母，并且取消注册会导致此移动设备有零个派对，则此移动设备也将从父母中注销。

        这是非注册方调用此方法的使用错误。 但是，如果有的话，这个错误可能会导致一个IllegalStateException在这个移相器上的后续操作。

        结果
        到达阶段数，如果终止则为负值
        异常
        IllegalStateException - 如果没有终止，登记的或没有任何一方的人数将变为负数

      • arriveAndAwaitAdvance

        public int arriveAndAwaitAdvance​()
        到达这个移相器，等待其他人。 等效于awaitAdvance(arrive()) 。 如果您需要等待中断或超时，您可以使用awaitAdvance方法的其他形式之一使用类似的结构进行awaitAdvance 。 如果相反，您需要在抵达时注销，请使用awaitAdvance(arriveAndDeregister()) 。

        这是非注册方调用此方法的使用错误。 但是，这个错误可能会导致一个IllegalStateException只有在这个移相器上的一些后续操作，如果有的话。

        结果
        到达阶段数，或（负） current phase如果终止
        异常
        IllegalStateException - 如果没有终止，而有争议的党的人数将变为负数

      • awaitAdvance

        public int awaitAdvance​(int phase)
        等待该相位器的相位从给定相位值前进，如果当前相位不等于给定相位值，则立即返回，或者该相位器被终止。
        参数
        phase - 到达阶段数，如果终止则为负值; 此参数通常是由先前调用arrive或arriveAndDeregister返回的值。
        结果
        下一个到达阶段数字，如果是负数则为参数，否则为（负） current phase

      • awaitAdvanceInterruptibly

        public int awaitAdvanceInterruptibly​(int phase)
                              throws InterruptedException
        等待相移器的相位从给定的相位值推进，抛出 InterruptedException如果在等待时中断，或者如果当前相位不等于给定相位值，则立即返回，或者该相位器被终止。
        参数
        phase - 到达阶段数，如果终止则为负值; 此参数通常是由先前调用arrive或arriveAndDeregister返回的值。
        结果
        下一个到达阶段数，或参数如果为负，或（负） current phase如果终止
        异常
        InterruptedException - 如果线程在等待时中断

      • awaitAdvanceInterruptibly

        public int awaitAdvanceInterruptibly​(int phase,
                                     long timeout,
                                     TimeUnit unit)
                              throws InterruptedException,
                                     TimeoutException
        等待该移相器的阶段从给定的相位值或给定的超时 InterruptedException到等待时抛出 InterruptedException ，如果当前相位不等于给定的相位值，则立即返回，或者该相位器被终止。
        参数
        phase - 到达阶段数，如果终止则为负值; 此参数通常是由先前调用arrive或arriveAndDeregister返回的值。
        timeout - 放弃之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        下一个到达阶段的数字，或者参数是否为负数，或者（负） current phase如果终止
        异常
        InterruptedException - 如果线程在等待时中断
        TimeoutException - 如果在等待时超时

      • forceTermination

        public void forceTermination​()
        强制此移相器进入终止状态。 注册方的数量不受影响。 如果这个移相器是分层的相位片的成员，则集合中的所有相移器都将被终止。 如果此移相器已被终止，则此方法无效。 在一个或多个任务遇到意外异常之后，此方法可能有助于协调恢复。

      • getPhase

        public final int getPhase​()
        返回当前相位数。 最大相位数为Integer.MAX_VALUE ，之后重新启动为零。 一旦终止，相位数为负，在这种情况下，终止前的主要阶段可以通过getPhase() + Integer.MIN_VALUE获得。
        结果
        相位数，如果终止则为负值

      • getRegisteredParties

        public int getRegisteredParties​()
        返回在此移动设备上注册的各方数量。
        结果
        当事人数

      • getArrivedParties

        public int getArrivedParties​()
        返回在此移相器的当前阶段到达的已注册方的数量。 如果这个移相器已经终止，返回的值是无意义和任意的。
        结果
        到达方的数量

      • getUnarrivedParties

        public int getUnarrivedParties​()
        返回尚未到达此移相器当前阶段的已注册方的数量。 如果这个移相器已经终止，返回的值是无意义和任意的。
        结果
        无数派的人数

      • getParent

        public Phaser getParent​()
        返回此移相器的父级，如果没有，则返回 null 。
        结果
        该移相器的父级，如果没有， null

      • getRoot

        public Phaser getRoot​()
        返回此移相器的根祖先，如果它没有父代，则与该移相器相同。
        结果
        这个移相器的根祖先

      • isTerminated

        public boolean isTerminated​()
        如果此移相器已被终止，则返回 true 。
        结果
        true如果此移相器已被终止

      • onAdvance

        protected boolean onAdvance​(int phase,
                            int registeredParties)
        在即将进行的相位提前执行动作的可覆盖方法，并控制终止。 这种方法在派对推进这个移相器（当所有其他等待方休眠）的时候被调用。 如果此方法返回true ，则该移相器true将被设置为最终终止状态，并且对isTerminated()的后续调用将返回true。 任何（未选中）通过调用此方法引发的异常或错误将传播给尝试推进此移相器的方，在这种情况下不会发生提前。

        该方法的参数提供了当前转换占优势的状态。 在onAdvance内对这个移相器引用到达，注册和等待方法的onAdvance是未指定的，不应该依赖。

        如果这个移相器是分层的相位器的成员，那么onAdvance仅在每个onAdvance的根onAdvance器上被调用。

        支持最常见的用例，此方法的默认实现返回true时注册方的数量已变为零作为党调用的结果arriveAndDeregister 。 您可以禁用此行为，从而通过覆盖此方法始终返回false ，从而可以在将来注册时继续使用：

           Phaser phaser = new Phaser() { protected boolean onAdvance(int phase, int parties) { return false; } }
        参数
        phase - 在此移相器提前之前输入此方法的当前阶段编号
        registeredParties - 当前注册方的数量
        结果
        true如果这个移相器应该终止

      • toString

        public String toString​()
        返回一个标识此移相器的字符串及其状态。 括号中的状态包括字符串"phase = "后跟阶段号码"parties = "后跟注册方数，而"arrived = "后跟随方数。
        重写：
        toString在 Object
        结果
        一个标识这个移相器的字符串，以及它的状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PriorityBlockingQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class PriorityBlockingQueue<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
        • java.util.concurrent.PriorityBlockingQueue<E>
  • 参数类型
    E - 保存在此队列中的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， BlockingQueue<E> ， Queue<E>

    public class PriorityBlockingQueue<E>
extends AbstractQueue<E>
implements BlockingQueue<E>, Serializable
    无限blocking queue使用与PriorityQueue类相同的排序规则，并提供阻止检索操作。 虽然此队列在逻辑上是无界的，但由于资源耗尽，尝试添加可能会失败（导致OutOfMemoryError ）。 这个类不允许null元素。 依靠natural ordering的优先级队列也不允许插入不可比较的对象（这样做在ClassCastException ）。

    该类及其迭代器实现Collection和Iterator接口的所有可选方法。 方法iterator()中提供的迭代器和方法spliterator()中提供的分割器不能保证以任何特定的顺序遍历PriorityBlockingQueue的元素。 如果需要有序遍历，请考虑使用Arrays.sort(pq.toArray()) 。 此外，方法drainTo可以用于以优先级顺序移除一些或所有元素并将它们放置在另一集合中。

    这个类的操作不会保证等同优先级的元素的排序。 如果需要强制执行排序，您可以定义自定义类或比较器，它们使用辅助键来破坏主优先级值的关系。 例如，这里是一个适用于先进先出的打破破坏类似元素的课程。 要使用它，您将插入一个new FIFOEntry(anEntry)而不是一个简单的条目对象。

       class FIFOEntry<E extends Comparable<? super E>> implements Comparable<FIFOEntry<E>> { static final AtomicLong seq = new AtomicLong(0); final long seqNum; final E entry; public FIFOEntry(E entry) { seqNum = seq.getAndIncrement(); this.entry = entry; } public E getEntry() { return entry; } public int compareTo(FIFOEntry<E> other) { int res = entry.compareTo(other.entry); if (res == 0 && other.entry != this.entry) res = (seqNum < other.seqNum ? -1 : 1); return res; } }

    这个类是Java Collections Framework的成员。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PriorityBlockingQueue​()
      创建PriorityBlockingQueue与根据它们的排序其元素默认初始容量（11） natural ordering 。
      PriorityBlockingQueue​(int initialCapacity)
      创建一个具有指定初始容量的PriorityBlockingQueue ，根据它们的natural ordering对其元素进行排序 。
      PriorityBlockingQueue​(int initialCapacity, Comparator<? super E> comparator)
      创建具有指定初始容量的 PriorityBlockingQueue ，根据指定的比较器对其元素进行排序。
      PriorityBlockingQueue​(Collection<? extends E> c)
      创建一个包含指定集合中的元素的 PriorityBlockingQueue 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E e)
      将指定的元素插入到此优先级队列中。
      void clear​()
      从这个队列中原子地删除所有的元素。
      Comparator<? super E> comparator​()
      返回用于为了在这个队列中的元素，或比较null如果此队列使用natural ordering的元素。
      boolean contains​(Object o)
      如果此队列包含指定的元素，则返回 true 。
      int drainTo​(Collection<? super E> c)
      从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
      int drainTo​(Collection<? super E> c, int maxElements)
      最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
      Iterator<E> iterator​()
      返回此队列中的元素的迭代器。
      boolean offer​(E e)
      将指定的元素插入到此优先级队列中。
      boolean offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此优先级队列中。
      E peek​()
      检索但不删除此队列的头，如果此队列为空，则返回 null 。
      E poll​()
      检索并删除此队列的头部，如果此队列为空，则返回 null 。
      E poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
      void put​(E e)
      将指定的元素插入到此优先级队列中。
      int remainingCapacity​()
      总是返回 Integer.MAX_VALUE因为 PriorityBlockingQueue没有容量限制。
      boolean remove​(Object o)
      从该队列中删除指定元素的单个实例（如果存在）。
      int size​()
      返回此集合中的元素数。
      Spliterator<E> spliterator​()
      返回此队列中的元素Spliterator 。
      E take​()
      检索并删除此队列的头，如有必要，等待元素可用。
      Object[] toArray​()
      返回一个包含此队列中所有元素的数组。
      <T> T[] toArray​(T[] a)
      返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      String toString​()
      返回此集合的字符串表示形式。

      • Methods inherited from class java.util.AbstractCollection

        containsAll, isEmpty, removeAll, retainAll

      • Methods inherited from class java.util.AbstractQueue

        addAll, element, remove

      • Methods inherited from interface java.util.Collection

        addAll, containsAll, equals, hashCode, isEmpty, parallelStream, removeAll, removeIf, retainAll, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Queue

        element, remove

    • 构造方法详细信息

      • PriorityBlockingQueue

        public PriorityBlockingQueue​()
        创建一个PriorityBlockingQueue ，其默认初始容量（11）根据其natural ordering对其元素进行排序 。

      • PriorityBlockingQueue

        public PriorityBlockingQueue​(int initialCapacity)
        创建一个PriorityBlockingQueue具有指定的初始容量，根据它们的natural ordering命令其元素。
        参数
        initialCapacity - 此优先级队列的初始容量
        异常
        IllegalArgumentException - 如果 initialCapacity小于1

      • PriorityBlockingQueue

        public PriorityBlockingQueue​(int initialCapacity,
                             Comparator<? super E> comparator)
        创建具有指定初始容量的 PriorityBlockingQueue ，根据指定的比较器对其元素进行排序。
        参数
        initialCapacity - 此优先级队列的初始容量
        comparator - 将用于排序此优先级队列的比较器。 如果是null ，将使用natural ordering的元素。
        异常
        IllegalArgumentException - 如果 initialCapacity小于1

      • PriorityBlockingQueue

        public PriorityBlockingQueue​(Collection<? extends E> c)
        创建一个包含指定集合中的元素的PriorityBlockingQueue 。 如果指定的集合是SortedSet或PriorityQueue ，则该优先级队列将按照相同的顺序进行排序。 否则，此优先级队列将根据其元素的natural ordering进行排序。
        参数
        c - c元素放入此优先级队列的集合
        异常
        ClassCastException - 如果指定集合的元素不能根据优先级队列的顺序相互比较
        NullPointerException - 如果指定的集合或其任何元素为空

    • 方法详细信息

      • add

        public boolean add​(E e)
        将指定的元素插入到此优先级队列中。
        Specified by:
        add在接口 BlockingQueue<E>
        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Queue<E>
        重写：
        add在 AbstractQueue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Collection.add(E)指定）
        异常
        ClassCastException - 如果指定的元素不能根据优先级队列的顺序与当前在优先级队列中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        将指定的元素插入到此优先级队列中。 队列无限制，此方法永远不会返回false 。
        Specified by:
        offer在接口 BlockingQueue<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true （由 Queue.offer(E)指定）
        异常
        ClassCastException - 如果指定的元素不能根据优先级队列的排序与当前优先级队列中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • put

        public void put​(E e)
        将指定的元素插入到此优先级队列中。 由于队列无限制，此方法将永远不会阻止。
        Specified by:
        put在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        异常
        ClassCastException - 如果指定的元素不能根据优先级队列的顺序与当前优先级队列中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e,
                     long timeout,
                     TimeUnit unit)
        将指定的元素插入到此优先级队列中。 由于队列无限制，此方法将永远不会阻止或返回false 。
        Specified by:
        offer在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        timeout - 该参数被忽略，因为该方法从不阻止
        unit - 该参数被忽略，因为该方法从不阻止
        结果
        true （由 BlockingQueue.offer指定）
        异常
        ClassCastException - 如果指定的元素不能根据优先级队列的顺序与当前在优先级队列中的元素进行比较
        NullPointerException - 如果指定的元素为空

      • poll

        public E poll​()
        说明从接口Queue复制
        检索并删除此队列的头部，如果此队列为空，则返回 null 。
        Specified by:
        poll在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • take

        public E take​()
       throws InterruptedException
        说明从接口BlockingQueue复制
        检索并删除此队列的头，如有必要，等待元素可用。
        Specified by:
        take在接口 BlockingQueue<E>
        结果
        这个队列的头
        异常
        InterruptedException - 如果在等待时中断

      • poll

        public E poll​(long timeout,
              TimeUnit unit)
       throws InterruptedException
        说明从接口BlockingQueue复制
        检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
        Specified by:
        poll在接口 BlockingQueue<E>
        参数
        timeout - 放弃之前等待多长时间，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        该队列的头部，如果在元素可用之前经过指定的等待时间， null
        异常
        InterruptedException - 如果在等待时中断

      • peek

        public E peek​()
        说明从界面Queue复制
        检索但不删除此队列的头，如果此队列为空，则返回 null 。
        Specified by:
        peek在接口 Queue<E>
        结果
        这个队列的头，或 null如果这个队列是空的

      • comparator

        public Comparator<? super E> comparator​()
        返回用于为了在这个队列中的元素，或比较null如果此队列使用natural ordering的元素。
        结果
        比较器用于排序此队列中的元素，如果此队列使用其元素的自然排序， null

      • size

        public int size​()
        描述从接口Collection复制
        返回此集合中的元素数。 如果此集合包含Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此集合中的元素数

      • remainingCapacity

        public int remainingCapacity​()
        总是返回 Integer.MAX_VALUE因为 PriorityBlockingQueue没有容量限制。
        Specified by:
        remainingCapacity在接口 BlockingQueue<E>
        结果
        总是这样的 Integer.MAX_VALUE

      • remove

        public boolean remove​(Object o)
        从该队列中删除指定元素的单个实例（如果存在）。 更正式地，删除元素e使得o.equals(e) ，如果该队列包含一个或多个这样的元素。 返回true当且仅当此队列包含指定元素（或等效地，如果此队列作为调用的结果而更改）。
        Specified by:
        remove在接口 BlockingQueue<E>
        Specified by:
        remove在接口 Collection<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此队列中删除的元素（如果存在）
        结果
        true如果此队列由于调用而更改

      • contains

        public boolean contains​(Object o)
        如果此队列包含指定的元素，则返回true 。 更正式地，返回true当且仅当这个队列包含至少一个元素e这样o.equals(e) 。
        Specified by:
        contains在接口 BlockingQueue<E>
        Specified by:
        contains在接口 Collection<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 要检查此队列中的遏制的对象
        结果
        true如果此队列包含指定的元素

      • toString

        public String toString​()
        说明从类别复制AbstractCollection
        返回此集合的字符串表示形式。 字符串表示由集合的元素的列表按照它们的迭代器返回的顺序包含在方括号（ "[]" ）中。 相邻元素由字符", " （逗号和空格）分隔。 元素将转换为字符串，如String.valueOf(Object) 。
        重写：
        toString在 AbstractCollection<E>
        结果
        此集合的字符串表示形式

      • drainTo

        public int drainTo​(Collection<? super E> c)
        描述从接口BlockingQueue复制
        从该队列中删除所有可用的元素，并将它们添加到给定的集合中。 此操作可能比重复轮询此队列更有效。 尝试向集合c添加元素时遇到的失败可能会导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将队列排入自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 将元素传输到的集合
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定集合不支持添加元素
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或此队列的元素的某些属性会阻止将其添加到指定的集合

      • drainTo

        public int drainTo​(Collection<? super E> c,
                   int maxElements)
        描述从接口BlockingQueue复制
        最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。 尝试向集合c添加元素时遇到的失败可能会导致元素在抛出关联的异常时都不在两个集合中。 尝试将排队排队自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 传输元素的集合
        maxElements - 要传输的元素的最大数量
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定的集合不支持元素的添加
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或此队列的某个元素的某些属性会阻止将其添加到指定的集合

      • clear

        public void clear​()
        从这个队列中原子地删除所有的元素。 此呼叫返回后队列将为空。
        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractQueue<E>

      • toArray

        public Object[] toArray​()
        返回一个包含此队列中所有元素的数组。 返回的数组元素没有特定的顺序。

        返回的数组将是“安全的”，因为该队列不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个包含此队列中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 返回的数组元素没有特定的顺序。 如果队列适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此队列的大小分配一个新数组。

        如果这个队列适合指定的数组空间（即数组比此队列更多的元素），则队列结束后的数组中的元素设置为null 。

        像toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的队列。 以下代码可用于将队列转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 要存储队列的元素的阵列，如果它足够大; 否则，为此目的分配相同运行时类型的新数组
        结果
        一个包含此队列中所有元素的数组
        异常
        ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
        NullPointerException - 如果指定的数组为空

      • iterator

        public Iterator<E> iterator​()
        返回此队列中的元素的迭代器。 迭代器不以任何特定顺序返回元素。

        返回的迭代器是weakly consistent 。

        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        这个队列中的元素的迭代器

      • spliterator

        public Spliterator<E> spliterator​()
        返回此队列中的元素Spliterator 。 拼接器不以任何特定顺序遍历元素（ ORDERED特征未报告）。

        返回的拼接器是weakly consistent 。

        Spliterator报告Spliterator.SIZED和Spliterator.NONNULL 。

        Specified by:
        spliterator接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        Implementation Note:
        Spliterator另外报告 Spliterator.SUBSIZED 。
        结果
        一个 Spliterator在这个队列中的元素
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RecursiveAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class RecursiveAction

  • java.lang.Object
    • java.util.concurrent.ForkJoinTask<Void>
      • java.util.concurrent.RecursiveAction
  • All Implemented Interfaces:
    Serializable ， Future<Void>

    public abstract class RecursiveAction
extends ForkJoinTask<Void>
    一个递归结果ForkJoinTask 。 该类建立了将无结果动作参数化的约定，如Void ForkJoinTask s。 因为null的类型是唯一有效的值Void ，如方法join总是返回null完成时。

    示例用法 这是一个简单但完整的ForkJoin排序，排序给定的long[]数组：

       static class SortTask extends RecursiveAction { final long[] array; final int lo, hi; SortTask(long[] array, int lo, int hi) { this.array = array; this.lo = lo; this.hi = hi; } SortTask(long[] array) { this(array, 0, array.length); } protected void compute() { if (hi - lo < THRESHOLD) sortSequentially(lo, hi); else { int mid = (lo + hi) >>> 1; invokeAll(new SortTask(array, lo, mid), new SortTask(array, mid, hi)); merge(lo, mid, hi); } } // implementation details follow: static final int THRESHOLD = 1000; void sortSequentially(int lo, int hi) { Arrays.sort(array, lo, hi); } void merge(int lo, int mid, int hi) { long[] buf = Arrays.copyOfRange(array, lo, mid); for (int i = 0, j = lo, k = mid; i < buf.length; j++) array[j] = (k == hi || buf[i] < array[k]) ? buf[i++] : array[k++]; } }
    然后，您可以通过创建new SortTask(anArray)并在ForkJoinPool中调用它来排序anArray 。 作为一个更具体的简单示例，以下任务会增加数组的每个元素：
       class IncrementTask extends RecursiveAction { final long[] array; final int lo, hi; IncrementTask(long[] array, int lo, int hi) { this.array = array; this.lo = lo; this.hi = hi; } protected void compute() { if (hi - lo < THRESHOLD) { for (int i = lo; i < hi; ++i) array[i]++; } else { int mid = (lo + hi) >>> 1; invokeAll(new IncrementTask(array, lo, mid), new IncrementTask(array, mid, hi)); } } }

    以下示例说明了可能导致更好性能的一些改进和习语：递归方法不需要完全递归，只要它们保持基本的划分和征服方法。 这是一个通过将仅重复划分的右手区域除以2的双数组的每个元素的平方相加的类，并用next链的next跟踪它们。 它使用基于方法getSurplusQueuedTaskCount的动态阈值，但通过直接执行叶片动作来解决潜在的过度分割，而不是进一步细分。

       double sumOfSquares(ForkJoinPool pool, double[] array) { int n = array.length; Applyer a = new Applyer(array, 0, n, null); pool.invoke(a); return a.result; } class Applyer extends RecursiveAction { final double[] array; final int lo, hi; double result; Applyer next; // keeps track of right-hand-side tasks Applyer(double[] array, int lo, int hi, Applyer next) { this.array = array; this.lo = lo; this.hi = hi; this.next = next; } double atLeaf(int l, int h) { double sum = 0; for (int i = l; i < h; ++i) // perform leftmost base step sum += array[i] * array[i]; return sum; } protected void compute() { int l = lo; int h = hi; Applyer right = null; while (h - l > 1 && getSurplusQueuedTaskCount() <= 3) { int mid = (l + h) >>> 1; right = new Applyer(array, mid, h, right); right.fork(); h = mid; } double sum = atLeaf(l, h); while (right != null) { if (right.tryUnfork()) // directly calculate if not stolen sum += right.atLeaf(right.lo, right.hi); else { right.join(); sum += right.result; } right = right.next; } result = sum; } }
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      RecursiveAction​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract void compute​()
      这个任务执行的主要计算。
      protected boolean exec​()
      执行递归法的执行约定。
      Void getRawResult​()
      始终返回 null 。
      protected void setRawResult​(Void mustBeNull)
      需要空完成值。

      • Methods inherited from class java.util.concurrent.ForkJoinTask

        adapt, adapt, adapt, cancel, compareAndSetForkJoinTaskTag, complete, completeExceptionally, fork, get, get, getException, getForkJoinTaskTag, getPool, getQueuedTaskCount, getSurplusQueuedTaskCount, helpQuiesce, inForkJoinPool, invoke, invokeAll, invokeAll, invokeAll, isCancelled, isCompletedAbnormally, isCompletedNormally, isDone, join, peekNextLocalTask, pollNextLocalTask, pollSubmission, pollTask, quietlyComplete, quietlyInvoke, quietlyJoin, reinitialize, setForkJoinTaskTag, tryUnfork

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RecursiveAction

        public RecursiveAction​()

    • 方法详细信息

      • compute

        protected abstract void compute​()
        这个任务执行的主要计算。

      • getRawResult

        public final Void getRawResult​()
        始终返回 null 。
        Specified by:
        getRawResult在 ForkJoinTask<Void>
        结果
        null总是

      • setRawResult

        protected final void setRawResult​(Void mustBeNull)
        需要空完成值。
        Specified by:
        setRawResult在 ForkJoinTask<Void>
        参数
        mustBeNull - 值

      • exec

        protected final boolean exec​()
        执行递归法的执行约定。
        Specified by:
        exec在 ForkJoinTask<Void>
        结果
        true如果此任务已知正常完成
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RecursiveTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class RecursiveTask<V>

  • java.lang.Object
    • java.util.concurrent.ForkJoinTask<V>
      • java.util.concurrent.RecursiveTask<V>
  • All Implemented Interfaces:
    Serializable ， Future<V>

    public abstract class RecursiveTask<V>
extends ForkJoinTask<V>
    递归结果ForkJoinTask 。

    对于一个典型的例子，这里是一个任务计算斐波纳契数字：

       class Fibonacci extends RecursiveTask<Integer> { final int n; Fibonacci(int n) { this.n = n; } protected Integer compute() { if (n <= 1) return n; Fibonacci f1 = new Fibonacci(n - 1); f1.fork(); Fibonacci f2 = new Fibonacci(n - 2); return f2.compute() + f1.join(); } }
    然而，除了计算斐波纳契函数的一种愚蠢的方法（有一个简单的快速线性算法，您将在实践中使用），这很可能表现不佳，因为最小的子任务太小而不能被分解。 相反，正如几乎所有fork / join应用程序的情况一样，您可以选择一些最小粒度大小（例如，在此为10），您始终依次解决而不是细分。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      RecursiveTask​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract V compute​()
      这个任务执行的主要计算。
      protected boolean exec​()
      实现RecursiveTask的执行约定。
      V getRawResult​()
      返回由 ForkJoinTask.join()返回的结果，即使此任务异常完成，或 null如果此任务未知已完成。
      protected void setRawResult​(V value)
      强制给定的值作为结果返回。

      • Methods inherited from class java.util.concurrent.ForkJoinTask

        adapt, adapt, adapt, cancel, compareAndSetForkJoinTaskTag, complete, completeExceptionally, fork, get, get, getException, getForkJoinTaskTag, getPool, getQueuedTaskCount, getSurplusQueuedTaskCount, helpQuiesce, inForkJoinPool, invoke, invokeAll, invokeAll, invokeAll, isCancelled, isCompletedAbnormally, isCompletedNormally, isDone, join, peekNextLocalTask, pollNextLocalTask, pollSubmission, pollTask, quietlyComplete, quietlyInvoke, quietlyJoin, reinitialize, setForkJoinTaskTag, tryUnfork

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RecursiveTask

        public RecursiveTask​()

    • 方法详细信息

      • compute

        protected abstract V compute​()
        这个任务执行的主要计算。
        结果
        计算的结果

      • getRawResult

        public final V getRawResult​()
        描述从类别复制： ForkJoinTask
        返回对返回的结果ForkJoinTask.join() ，即使这个任务异常完成，或null如果不知道这个任务已经完成。 此方法旨在帮助调试，以及支持扩展。 在任何其他情况下都不鼓励使用它。
        Specified by:
        getRawResult在 ForkJoinTask<V>
        结果
        结果，或 null如果没有完成

      • setRawResult

        protected final void setRawResult​(V value)
        描述从类别复制： ForkJoinTask
        强制给定的值作为结果返回。 这种方法被设计为支持扩展，一般不应该以其他方式调用。
        Specified by:
        setRawResult在 ForkJoinTask<V>
        参数
        value - 值

      • exec

        protected final boolean exec​()
        实现RecursiveTask的执行约定。
        Specified by:
        exec在 ForkJoinTask<V>
        结果
        true如果此任务已知已正常完成
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RejectedExecutionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class RejectedExecutionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.util.concurrent.RejectedExecutionException
  • All Implemented Interfaces:
    Serializable

    public class RejectedExecutionException
extends RuntimeException
    当一个任务不能接受执行时，由一个Executor抛出的异常。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      RejectedExecutionException​()
      构造一个 RejectedExecutionException ，没有详细信息。
      RejectedExecutionException​(String message)
      构造具有指定详细消息的 RejectedExecutionException 。
      RejectedExecutionException​(String message, Throwable cause)
      构造具有指定的详细信息和原因的 RejectedExecutionException 。
      RejectedExecutionException​(Throwable cause)
      构造具有指定原因的 RejectedExecutionException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • RejectedExecutionException

        public RejectedExecutionException​()
        构造一个没有详细消息的RejectedExecutionException 。 原因未初始化，可以随后通过调用initCause进行初始化。

      • RejectedExecutionException

        public RejectedExecutionException​(String message)
        构造具有指定详细消息的RejectedExecutionException 。 原因未初始化，可以随后通过调用initCause进行初始化。
        参数
        message - 详细信息

      • RejectedExecutionException

        public RejectedExecutionException​(String message,
                                  Throwable cause)
        构造具有指定的详细信息和原因的 RejectedExecutionException 。
        参数
        message - 详细信息
        cause - 原因（由 Throwable.getCause()方法保存供以后检索）

      • RejectedExecutionException

        public RejectedExecutionException​(Throwable cause)
        构造具有指定原因的RejectedExecutionException 。 详细信息设置为(cause == null ? null : cause.toString()) （通常包含类和详细信息cause ）。
        参数
        cause - 原因（由 Throwable.getCause()方法保存供以后检索）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RejectedExecutionHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface RejectedExecutionHandler

  • 所有已知实现类：
    ThreadPoolExecutor.AbortPolicy ， ThreadPoolExecutor.CallerRunsPolicy ， ThreadPoolExecutor.DiscardOldestPolicy ， ThreadPoolExecutor.DiscardPolicy

    public interface RejectedExecutionHandler
    一个不能由一个ThreadPoolExecutor执行的任务的处理程序。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void rejectedExecution​(Runnable r, ThreadPoolExecutor executor)
      ThreadPoolExecutor当execute无法接受任务时可能会调用的方法。

    • 方法详细信息

      • rejectedExecution

        void rejectedExecution​(Runnable r,
                       ThreadPoolExecutor executor)
        ThreadPoolExecutor当execute无法接受任务时可能调用的方法。 当没有更多线程或队列插槽可用时，可能会发生这种情况，因为它们的边界将被超出，或者在执行程序关闭时。

        在没有其他替代方案的情况下，该方法可能会引发未经检查的RejectedExecutionException ，这将被传播给呼叫者execute 。

        参数
        r - 请求执行的可运行任务
        executor - 执行者尝试执行此任务
        异常
        RejectedExecutionException - 如果没有补救措施
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RunnableFuture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface RunnableFuture<V>

  • 参数类型
    V - 该未来 get方法返回的结果类型
    All Superinterfaces:
    Future<V> ， Runnable
    All Known Subinterfaces:
    RunnableScheduledFuture<V>
    所有已知实现类：
    FutureTask ， SwingWorker ， Task

    public interface RunnableFuture<V>
extends Runnable, Future<V>
    A Future ，这是Runnable 。 成功执行run方法会导致完成Future并允许访问其结果。
    从以下版本开始：
    1.6
    另请参见：
    FutureTask ， Executor

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void run​()
      将此未来设置为其计算结果，除非已被取消。

      • Methods inherited from interface java.util.concurrent.Future

        cancel, get, get, isCancelled, isDone

    • 方法详细信息

      • run

        void run​()
        将此未来设置为其计算结果，除非已被取消。
        Specified by:
        run在接口 Runnable
        另请参见：
        Thread.run()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RunnableScheduledFuture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface RunnableScheduledFuture<V>

  • 参数类型
    V - 该未来 get方法返回的结果类型
    All Superinterfaces:
    Comparable<V> ， Delayed ， Future<V> ， Runnable ， RunnableFuture<V> ， ScheduledFuture<V>

    public interface RunnableScheduledFuture<V>
extends RunnableFuture<V>, ScheduledFuture<V>
    A ScheduledFuture ，这是Runnable 。 成功执行run方法会导致完成Future并允许访问其结果。
    从以下版本开始：
    1.6
    另请参见：
    FutureTask ， Executor

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean isPeriodic​()
      如果此任务是周期性的，则返回 true 。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface java.util.concurrent.Delayed

        getDelay

      • Methods inherited from interface java.util.concurrent.Future

        cancel, get, get, isCancelled, isDone

      • Methods inherited from interface java.util.concurrent.RunnableFuture

        run

    • 方法详细信息

      • isPeriodic

        boolean isPeriodic​()
        如果此任务是周期性的，则返回true 。 定期任务可以按照一些时间表重新运行。 非周期性任务只能运行一次。
        结果
        true如果这个任务是周期性的
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScheduledExecutorService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface ScheduledExecutorService

  • All Superinterfaces:
    Executor ， ExecutorService
    所有已知实现类：
    ScheduledThreadPoolExecutor

    public interface ScheduledExecutorService
extends ExecutorService
    一个ExecutorService ，可以调度命令在给定的延迟之后运行，或定期执行。

    schedule方法创建具有各种延迟的任务，并返回可用于取消或检查执行的任务对象。 scheduleAtFixedRate和scheduleWithFixedDelay方法创建和执行定期运行的任务，直到取消。

    使用Executor.execute(Runnable)和ExecutorService submit方法提交的命令以请求的延迟为零进行调度。 在schedule方法中也允许零和负延迟（但不是周期），并被视为立即执行的请求。

    全部schedule方法接受相对延迟和句点作为参数，而不是绝对时间或日期。 将表示为Date的绝对时间转换为所需形式是一件很简单的事情。 例如，要在一定的日期安排date ，可以使用： schedule(task, date.getTime() - System.currentTimeMillis(), TimeUnit.MILLISECONDS) 。 然而，请注意，由于网络时间同步协议，时钟漂移或其他因素，相对延迟的到期与当前启用任务的Date不一致。

    Executors类为该包中提供的ScheduledExecutorService实现提供了方便的工厂方法。

    用法示例

    这是一个类，其方法是将ScheduledExecutorService设置为每10秒钟发出一个小时的蜂鸣声：
       import static java.util.concurrent.TimeUnit.*; class BeeperControl { private final ScheduledExecutorService scheduler = Executors.newScheduledThreadPool(1); public void beepForAnHour() { Runnable beeper = () -> System.out.println("beep"); ScheduledFuture<?> beeperHandle = scheduler.scheduleAtFixedRate(beeper, 10, 10, SECONDS); Runnable canceller = () -> beeperHandle.cancel(true); scheduler.schedule(canceller, 1, HOURS); } }
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ScheduledFuture<?> schedule​(Runnable command, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的单次操作。
      <V> ScheduledFuture<V> schedule​(Callable<V> callable, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的ScheduledFuture。
      ScheduledFuture<?> scheduleAtFixedRate​(Runnable command, long initialDelay, long period, TimeUnit unit)
      创建并执行在给定的初始延迟之后，随后以给定的时间段首先启用的周期性动作; 也就是说，执行将在initialDelay之后开始，然后是initialDelay + period ，然后是initialDelay + 2 * period ，等等。
      ScheduledFuture<?> scheduleWithFixedDelay​(Runnable command, long initialDelay, long delay, TimeUnit unit)
      创建并执行在给定的初始延迟之后首先启用的定期动作，随后在一个执行的终止和下一个执行的开始之间给定的延迟。

      • Methods inherited from interface java.util.concurrent.Executor

        execute

      • Methods inherited from interface java.util.concurrent.ExecutorService

        awaitTermination, invokeAll, invokeAll, invokeAny, invokeAny, isShutdown, isTerminated, shutdown, shutdownNow, submit, submit, submit

    • 方法详细信息

      • schedule

        ScheduledFuture<?> schedule​(Runnable command,
                            long delay,
                            TimeUnit unit)
        创建并执行在给定延迟后启用的单次操作。
        参数
        command - 要执行的任务
        delay - 从现在开始延迟执行的时间
        unit - 延迟参数的时间单位
        结果
        一个ScheduledFuture代表待完成的任务，其 get()方法将在完成后返回 null
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果命令为空

      • schedule

        <V> ScheduledFuture<V> schedule​(Callable<V> callable,
                                long delay,
                                TimeUnit unit)
        创建并执行在给定延迟后启用的ScheduledFuture。
        参数类型
        V - 可调用结果的类型
        参数
        callable - 执行的功能
        delay - 从现在开始延迟执行的时间
        unit - 延迟参数的时间单位
        结果
        一个可用于提取结果或取消的ScheduledFuture
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果可调用为空

      • scheduleAtFixedRate

        ScheduledFuture<?> scheduleAtFixedRate​(Runnable command,
                                       long initialDelay,
                                       long period,
                                       TimeUnit unit)
        创建并执行在给定的初始延迟之后，随后以给定的时间段首先启用的周期性动作; 也就是说，执行将在initialDelay之后开始，然后是initialDelay + period ，然后是initialDelay + 2 * period ，等等。

        任务执行的顺序无限期延续，直到出现以下异常完成之一：

        • 任务是通过返回的未来是explicitly cancelled 。
        • 执行者终止，也导致任务取消。
        • 执行任务会引发异常。 在这种情况下，呼叫get将返回未来将抛出ExecutionException 。
        后续执行被抑制。 后续的电话号码isDone()将返回true 。

        如果任务执行时间比其周期长，则后续执行可能会迟到，但不会同时执行。

        参数
        command - 要执行的任务
        initialDelay - 延迟第一次执行的时间
        period - 连续执行之间的时期
        unit - initialDelay和period参数的时间单位
        结果
        一个ScheduledFuture表示一系列重复任务的等待完成。 未来的get()方法将永远不会正常返回，并且在任务取消或任务执行异常终止时将抛出异常。
        异常
        RejectedExecutionException - 如果不能安排任务执行
        NullPointerException - 如果命令为空
        IllegalArgumentException - 如果周期小于或等于零

      • scheduleWithFixedDelay

        ScheduledFuture<?> scheduleWithFixedDelay​(Runnable command,
                                          long initialDelay,
                                          long delay,
                                          TimeUnit unit)
        创建并执行在给定的初始延迟之后首先启用的定期动作，随后在一个执行的终止和下一个执行的开始之间给定的延迟。

        任务执行的顺序无限期延续，直到出现以下异常完成之一：

        • 任务是通过返回的未来是explicitly cancelled 。
        • 执行者终止，也导致任务取消。
        • 执行任务会引发异常。 在这种情况下，呼叫get对未来的回报将会抛出ExecutionException 。
        后续执行被抑制。 后续调用isDone()对返回的未来将返回true 。
        参数
        command - 要执行的任务
        initialDelay - 延迟第一次执行的时间
        delay - 一个执行终止和下一个执行的开始之间的延迟
        unit - initialDelay和delay参数的时间单位
        结果
        一个ScheduledFuture表示一系列重复任务的等待完成。 未来的get()方法将永远不会正常返回，并且在任务取消或异常终止任务执行时将抛出异常。
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果命令为空
        IllegalArgumentException - 如果延迟小于或等于零
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScheduledFuture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface ScheduledFuture<V>

  • 参数类型
    V - 此未来返回的结果类型
    All Superinterfaces:
    Comparable<V> ， Delayed ， Future<V>
    All Known Subinterfaces:
    RunnableScheduledFuture<V>

    public interface ScheduledFuture<V>
extends Delayed, Future<V>
    可以取消延迟结果的行动。 通常一个预定的未来是使用一个ScheduledExecutorService调度一个任务的结果 。
    从以下版本开始：
    1.5

    • 方法摘要

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface java.util.concurrent.Delayed

        getDelay

      • Methods inherited from interface java.util.concurrent.Future

        cancel, get, get, isCancelled, isDone
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScheduledThreadPoolExecutor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ScheduledThreadPoolExecutor

  • java.lang.Object
    • java.util.concurrent.AbstractExecutorService
      • java.util.concurrent.ThreadPoolExecutor
        • java.util.concurrent.ScheduledThreadPoolExecutor
  • All Implemented Interfaces:
    Executor ， ExecutorService ， ScheduledExecutorService

    public class ScheduledThreadPoolExecutor
extends ThreadPoolExecutor
implements ScheduledExecutorService
    A ThreadPoolExecutor ，其可以另外调度在给定延迟之后运行的命令，或者周期性地执行。 该类优选的是Timer需要多个工作线程时，或当附加灵活性或能力ThreadPoolExecutor需要（这此类扩展）。

    延迟任务执行时间早于启用，但没有任何实时保证，在启用后，他们将开始。 计划执行完全相同执行时间的任务将以先进先出（FIFO）的提交顺序启用。

    提交的任务在运行之前被取消，执行被抑制。 默认情况下，这样一个取消的任务在工作队列中不会自动删除，直到其延迟过去。 虽然这样可以进一步检查和监控，但也可能导致取消任务的无限制保留。 为避免这种情况，请使用setRemoveOnCancelPolicy(boolean)在取消时立即从工作队列中删除任务。

    通过scheduleAtFixedRate或scheduleWithFixedDelay安排的定期任务的连续执行不重叠。 虽然不同的执行可以通过不同的线程来执行，先前执行的效果happen-before那些随后的那些的。

    虽然这个类继承自ThreadPoolExecutor ，但是一些继承的调优方法对它是没有用的。 特别是因为它作为使用corePoolSize线程和无限队列的固定大小的池，对maximumPoolSize调整没有任何有用的效果。 另外，将corePoolSize设置为零或使用allowCoreThreadTimeOut几乎是一个好主意，因为这可能会使池没有线程来处理任务，只要它们有资格运行。

    扩展笔记：此类覆盖了execute和submit方法，以生成内部ScheduledFuture对象来控制每个任务的延迟和调度。 为了保护功能，子类中这些方法的任何进一步覆盖都必须调用超类版本，这有效地禁用其他任务自定义。 然而，此类提供替代保护扩展方法decorateTask （每一个用于一个版本Runnable和Callable ），其可以被用于定制用于执行经由输入的命令的具体任务类型execute ， submit ， schedule ， scheduleAtFixedRate ，和scheduleWithFixedDelay 。 默认情况下， ScheduledThreadPoolExecutor使用扩展FutureTask的任务类型。 但是，可以使用以下形式的子类修改或替换：

       public class CustomScheduledExecutor extends ScheduledThreadPoolExecutor { static class CustomTask<V> implements RunnableScheduledFuture<V> { ... } protected <V> RunnableScheduledFuture<V> decorateTask( Runnable r, RunnableScheduledFuture<V> task) { return new CustomTask<V>(r, task); } protected <V> RunnableScheduledFuture<V> decorateTask( Callable<V> c, RunnableScheduledFuture<V> task) { return new CustomTask<V>(c, task); } // ... add constructors, etc. }
    从以下版本开始：
    1.5

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.concurrent.ThreadPoolExecutor

        ThreadPoolExecutor.AbortPolicy, ThreadPoolExecutor.CallerRunsPolicy, ThreadPoolExecutor.DiscardOldestPolicy, ThreadPoolExecutor.DiscardPolicy

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScheduledThreadPoolExecutor​(int corePoolSize)
      创建一个新的 ScheduledThreadPoolExecutor与给定的核心池大小。
      ScheduledThreadPoolExecutor​(int corePoolSize, RejectedExecutionHandler handler)
      使用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。
      ScheduledThreadPoolExecutor​(int corePoolSize, ThreadFactory threadFactory)
      用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。
      ScheduledThreadPoolExecutor​(int corePoolSize, ThreadFactory threadFactory, RejectedExecutionHandler handler)
      使用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected <V> RunnableScheduledFuture<V> decorateTask​(Runnable runnable, RunnableScheduledFuture<V> task)
      修改或替换用于执行runnable的任务。
      protected <V> RunnableScheduledFuture<V> decorateTask​(Callable<V> callable, RunnableScheduledFuture<V> task)
      修改或替换用于执行可调用的任务。
      void execute​(Runnable command)
      执行 command零要求延迟。
      boolean getContinueExistingPeriodicTasksAfterShutdownPolicy​()
      获取关于是否继续执行现有周期性任务的策略，即使该执行者已经是 shutdown 。
      boolean getExecuteExistingDelayedTasksAfterShutdownPolicy​()
      获取关于是否执行现有延迟任务的策略，即使该执行者已经是 shutdown 。
      BlockingQueue<Runnable> getQueue​()
      返回此执行程序使用的任务队列。
      boolean getRemoveOnCancelPolicy​()
      获取关于在取消时是否应立即将已取消任务从工作队列中删除的策略。
      ScheduledFuture<?> schedule​(Runnable command, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的单次操作。
      <V> ScheduledFuture<V> schedule​(Callable<V> callable, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的ScheduledFuture。
      ScheduledFuture<?> scheduleAtFixedRate​(Runnable command, long initialDelay, long period, TimeUnit unit)
      创建并执行在给定的初始延迟之后，随后以给定的时间段首先启用的周期性动作; 也就是说，执行将在initialDelay之后开始，然后是initialDelay + period ，然后是initialDelay + 2 * period ，等等。
      ScheduledFuture<?> scheduleWithFixedDelay​(Runnable command, long initialDelay, long delay, TimeUnit unit)
      创建并执行在给定的初始延迟之后首先启用的定期动作，随后在一个执行的终止和下一个执行的开始之间给定的延迟。
      void setContinueExistingPeriodicTasksAfterShutdownPolicy​(boolean value)
      设置关于是否继续执行现有周期性任务的策略，即使该执行者已经是 shutdown 。
      void setExecuteExistingDelayedTasksAfterShutdownPolicy​(boolean value)
      设置即使执行者已经执行 shutdown是否执行现有延迟任务的 shutdown 。
      void setRemoveOnCancelPolicy​(boolean value)
      设置取消时取消任务是否应立即从工作队列中删除的策略。
      void shutdown​()
      启动有序关闭，其中先前提交的任务将被执行，但不会接受任何新任务。
      List<Runnable> shutdownNow​()
      尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。
      Future<?> submit​(Runnable task)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> Future<T> submit​(Runnable task, T result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> Future<T> submit​(Callable<T> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。

      • Methods inherited from class java.util.concurrent.AbstractExecutorService

        invokeAll, invokeAll, invokeAny, invokeAny, newTaskFor, newTaskFor

      • Methods inherited from interface java.util.concurrent.ExecutorService

        awaitTermination, invokeAll, invokeAll, invokeAny, invokeAny, isShutdown, isTerminated

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.util.concurrent.ThreadPoolExecutor

        afterExecute, allowCoreThreadTimeOut, allowsCoreThreadTimeOut, awaitTermination, beforeExecute, finalize, getActiveCount, getCompletedTaskCount, getCorePoolSize, getKeepAliveTime, getLargestPoolSize, getMaximumPoolSize, getPoolSize, getRejectedExecutionHandler, getTaskCount, getThreadFactory, isShutdown, isTerminated, isTerminating, prestartAllCoreThreads, prestartCoreThread, purge, remove, setCorePoolSize, setKeepAliveTime, setMaximumPoolSize, setRejectedExecutionHandler, setThreadFactory, terminated, toString

    • 构造方法详细信息

      • ScheduledThreadPoolExecutor

        public ScheduledThreadPoolExecutor​(int corePoolSize)
        创建一个新的 ScheduledThreadPoolExecutor与给定的核心池大小。
        参数
        corePoolSize - 即使空闲时仍保留在池中的线程数，除非设置了 allowCoreThreadTimeOut
        异常
        IllegalArgumentException - 如果是 corePoolSize < 0

      • ScheduledThreadPoolExecutor

        public ScheduledThreadPoolExecutor​(int corePoolSize,
                                   ThreadFactory threadFactory)
        使用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。
        参数
        corePoolSize - 即使空闲时仍保留在池中的线程数，除非 allowCoreThreadTimeOut为 allowCoreThreadTimeOut
        threadFactory - 执行程序创建新线程时使用的工厂
        异常
        IllegalArgumentException - 如果是 corePoolSize < 0
        NullPointerException - 如果 threadFactory为空

      • ScheduledThreadPoolExecutor

        public ScheduledThreadPoolExecutor​(int corePoolSize,
                                   RejectedExecutionHandler handler)
        用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。
        参数
        corePoolSize - 即使空闲时仍保留在池中的线程数，除非 allowCoreThreadTimeOut为 allowCoreThreadTimeOut
        handler - 执行被阻止时使用的处理程序，因为达到线程限制和队列容量
        异常
        IllegalArgumentException - 如果是 corePoolSize < 0
        NullPointerException - 如果 handler为空

      • ScheduledThreadPoolExecutor

        public ScheduledThreadPoolExecutor​(int corePoolSize,
                                   ThreadFactory threadFactory,
                                   RejectedExecutionHandler handler)
        用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。
        参数
        corePoolSize - 要保留在池中的线程数，即使它们处于空闲状态，除非设置了 allowCoreThreadTimeOut
        threadFactory - 当执行者创建新线程时使用的工厂
        handler - 执行被阻止时使用的处理程序，因为达到线程限制和队列容量
        异常
        IllegalArgumentException - 如果是 corePoolSize < 0
        NullPointerException - 如果 threadFactory或 handler为空

    • 方法详细信息

      • decorateTask

        protected <V> RunnableScheduledFuture<V> decorateTask​(Runnable runnable,
                                                      RunnableScheduledFuture<V> task)
        修改或替换用于执行runnable的任务。 此方法可用于覆盖用于管理内部任务的具体类。 默认实现只是返回给定的任务。
        参数类型
        V - 任务结果的类型
        参数
        runnable - 提交的Runnable
        task - 创建的执行runnable的任务
        结果
        一个可以执行runnable的任务
        从以下版本开始：
        1.6

      • decorateTask

        protected <V> RunnableScheduledFuture<V> decorateTask​(Callable<V> callable,
                                                      RunnableScheduledFuture<V> task)
        修改或替换用于执行可调用的任务。 此方法可用于覆盖用于管理内部任务的具体类。 默认实现只是返回给定的任务。
        参数类型
        V - 任务结果的类型
        参数
        callable - 提交的Callable
        task - 创建用于执行可调用的任务
        结果
        一个可以执行可调用的任务
        从以下版本开始：
        1.6

      • schedule

        public ScheduledFuture<?> schedule​(Runnable command,
                                   long delay,
                                   TimeUnit unit)
        说明从接口ScheduledExecutorService复制
        创建并执行在给定延迟后启用的单次操作。
        Specified by:
        schedule在接口 ScheduledExecutorService
        参数
        command - 要执行的任务
        delay - 从现在开始延迟执行的时间
        unit - 延迟参数的时间单位
        结果
        一个ScheduledFuture代表待完成的任务，其 get()方法将在完成后返回 null
        异常
        RejectedExecutionException - 如果该任务无法安排执行
        NullPointerException - 如果命令为空

      • schedule

        public <V> ScheduledFuture<V> schedule​(Callable<V> callable,
                                       long delay,
                                       TimeUnit unit)
        描述从接口ScheduledExecutorService复制
        创建并执行在给定延迟后启用的ScheduledFuture。
        Specified by:
        schedule在接口 ScheduledExecutorService
        参数类型
        V - 可调用结果的类型
        参数
        callable - 执行的功能
        delay - 从现在开始延迟执行的时间
        unit - 延迟参数的时间单位
        结果
        一个可用于提取结果或取消的ScheduledFuture
        异常
        RejectedExecutionException - 如果该任务无法安排执行
        NullPointerException - 如果可调用为空

      • scheduleAtFixedRate

        public ScheduledFuture<?> scheduleAtFixedRate​(Runnable command,
                                              long initialDelay,
                                              long period,
                                              TimeUnit unit)
        说明从界面ScheduledExecutorService复制
        创建并执行在给定的初始延迟之后，随后以给定的时间段首先启用的周期性动作; 也就是说，执行将在initialDelay之后开始，然后是initialDelay + period ，然后是initialDelay + 2 * period ，等等。

        任务执行的顺序无限期延续，直到出现以下异常完成之一：

        • 任务是通过返回的未来是explicitly cancelled 。
        • 执行者终止，也导致任务取消。
        • 执行任务会引发异常。 在这种情况下，呼叫get将返回未来将抛出ExecutionException 。
        后续执行被抑制。 后续的电话isDone()返回未来将返回true 。

        如果任务执行时间比其周期长，则后续执行可能会迟到，但不会同时执行。

        Specified by:
        scheduleAtFixedRate在接口 ScheduledExecutorService
        参数
        command - 执行任务
        initialDelay - 延迟第一次执行的时间
        period - 连续执行之间的时期
        unit - initialDelay和period参数的时间单位
        结果
        一个ScheduledFuture表示一系列重复任务的等待完成。 未来的get()方法将永远不会正常返回，并且在任务取消或任务执行异常终止时将抛出异常。
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - if命令为空
        IllegalArgumentException - 如果周期小于或等于零

      • scheduleWithFixedDelay

        public ScheduledFuture<?> scheduleWithFixedDelay​(Runnable command,
                                                 long initialDelay,
                                                 long delay,
                                                 TimeUnit unit)
        说明从界面ScheduledExecutorService复制
        创建并执行在给定的初始延迟之后首先启用的定期动作，随后在一个执行的终止和下一个执行的开始之间给定的延迟。

        任务执行的顺序无限期延续，直到出现以下异常完成之一：

        • 任务是通过返回的未来explicitly cancelled 。
        • 执行者终止，也导致任务取消。
        • 执行任务会引发异常。 在这种情况下，呼叫get将返回未来将会抛出ExecutionException 。
        后续执行被抑制。 后续调用isDone()对返回的未来将返回true 。
        Specified by:
        scheduleWithFixedDelay在接口 ScheduledExecutorService
        参数
        command - 要执行的任务
        initialDelay - 延迟第一次执行的时间
        delay - 一个执行终止和下一个执行的开始之间的延迟
        unit - initialDelay和delay参数的时间单位
        结果
        一个ScheduledFuture表示一系列重复任务的等待完成。 未来的get()方法将永远不会正常返回，并且在任务取消或异常终止任务执行时将抛出异常。
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - if命令为空
        IllegalArgumentException - 如果延迟小于或等于零

      • execute

        public void execute​(Runnable command)
        执行command零需求延迟。 这具有相当于schedule(command, 0, anyUnit)的效果。 请注意，对shutdownNow返回的队列和列表的shutdownNow将访问零延迟的ScheduledFuture ，而不是command本身。

        使用ScheduledFuture对象的后果是， afterExecute始终以空的第二个Throwable参数调用，即使command突然终止。 相反，这样一个任务抛出的Throwable可以通过Future.get()获得。

        Specified by:
        execute在接口 Executor
        重写：
        execute在 ThreadPoolExecutor
        参数
        command - 要执行的任务
        异常
        RejectedExecutionException - 由 RejectedExecutionHandler决定，如果由于执行者已被关闭，任务不能被接受执行
        NullPointerException - 如果 command为空

      • submit

        public Future<?> submit​(Runnable task)
        描述从接口ExecutorService复制
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 未来的get方法在成功完成后将返回null 。
        Specified by:
        submit在接口 ExecutorService
        重写：
        submit在 AbstractExecutorService
        参数
        task - 提交的任务
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果不能安排任务执行
        NullPointerException - 如果任务为空

      • submit

        public <T> Future<T> submit​(Runnable task,
                            T result)
        说明从界面ExecutorService复制
        提交一个可运行的任务执行，并返回一个表示该任务的未来。 未来的get方法将在成功完成后返回给定的结果。
        Specified by:
        submit在接口 ExecutorService
        重写：
        submit在 AbstractExecutorService
        参数类型
        T - 结果的类型
        参数
        task - 提交的任务
        result - 结果返回
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果该任务无法安排执行
        NullPointerException - 如果任务为空

      • submit

        public <T> Future<T> submit​(Callable<T> task)
        描述从接口ExecutorService复制
        提交值返回任务以执行，并返回代表任务待处理结果的Future。 未来的get方法将在成功完成后返回任务的结果。

        如果您想立即阻止等待任务，您可以使用result = exec.submit(aCallable).get();表单的result = exec.submit(aCallable).get();

        注意： Executors类包括一组可以将其他常见的类似闭包的对象（例如PrivilegedAction）转换为Callable表单的方法，以便它们可以提交。

        Specified by:
        submit在接口 ExecutorService
        重写：
        submit在 AbstractExecutorService
        参数类型
        T - 任务结果的类型
        参数
        task - 提交的任务
        结果
        一个未来的代表，待完成任务
        异常
        RejectedExecutionException - 如果任务无法安排执行
        NullPointerException - 如果任务为空

      • setContinueExistingPeriodicTasksAfterShutdownPolicy

        public void setContinueExistingPeriodicTasksAfterShutdownPolicy​(boolean value)
        设置关于是否继续执行现有定期任务的策略，即使该执行者已经是shutdown 。 在这种情况下，这些任务将仅在终止shutdownNow或策略设置后false时已关机。 此值默认为false 。
        参数
        value - 如果 true ，关机后继续，否则不要
        另请参见：
        getContinueExistingPeriodicTasksAfterShutdownPolicy()

      • getContinueExistingPeriodicTasksAfterShutdownPolicy

        public boolean getContinueExistingPeriodicTasksAfterShutdownPolicy​()
        获得关于是否继续执行现有定期任务的策略，即使该执行者已经是shutdown 。 在这种情况下，这些任务将仅在终止shutdownNow或策略设置后false时已关机。 此值默认为false 。
        结果
        true如果将在关机后继续
        另请参见：
        setContinueExistingPeriodicTasksAfterShutdownPolicy(boolean)

      • setExecuteExistingDelayedTasksAfterShutdownPolicy

        public void setExecuteExistingDelayedTasksAfterShutdownPolicy​(boolean value)
        设置关于是否执行现有延迟任务的策略，即使该执行者已经是shutdown 。 在这种情况下，这些任务只能在shutdownNow终止，或者在已经关闭后将策略设置为false后终止。 此值默认为true 。
        参数
        value - 如果是 true ，在关机后执行，否则不要
        另请参见：
        getExecuteExistingDelayedTasksAfterShutdownPolicy()

      • getExecuteExistingDelayedTasksAfterShutdownPolicy

        public boolean getExecuteExistingDelayedTasksAfterShutdownPolicy​()
        获取关于是否执行现有延迟任务的策略，即使这个执行者已经是shutdown 。 在这种情况下，这些任务只能在shutdownNow终止，或者在已经关闭后将策略设置为false之后。 此值默认为true 。
        结果
        true如果在关机后执行
        另请参见：
        setExecuteExistingDelayedTasksAfterShutdownPolicy(boolean)

      • setRemoveOnCancelPolicy

        public void setRemoveOnCancelPolicy​(boolean value)
        设置取消时取消任务是否应立即从工作队列中删除的策略。 此值默认为false 。
        参数
        value - 如果 true ，取消取消，否则不要
        从以下版本开始：
        1.7
        另请参见：
        getRemoveOnCancelPolicy()

      • getRemoveOnCancelPolicy

        public boolean getRemoveOnCancelPolicy​()
        获取关于在取消时是否应立即将已取消任务从工作队列中删除的策略。 此值默认为false 。
        结果
        true如果取消的任务立即从队列中删除
        从以下版本开始：
        1.7
        另请参见：
        setRemoveOnCancelPolicy(boolean)

      • shutdown

        public void shutdown​()
        启动有序关闭，其中先前提交的任务将被执行，但不会接受任何新任务。 如果已经关闭，调用没有额外的作用。

        此方法不等待以前提交的任务完成执行。 使用awaitTermination来做到这一点。

        如果ExecuteExistingDelayedTasksAfterShutdownPolicy已被设置为false ，则其延迟尚未过去的现有延迟任务将被取消。 除了ContinueExistingPeriodicTasksAfterShutdownPolicy已经设置true ，未来执行的定期任务将被取消。

        Specified by:
        shutdown在接口 ExecutorService
        重写：
        shutdown在 ThreadPoolExecutor
        异常
        SecurityException - 如果安全管理器存在并关闭，则ExecutorService可能会操纵调用者不允许修改的线程，因为不支持2706269494952 ("modifyThread")或安全管理器的checkAccess方法拒绝访问。

      • shutdownNow

        public List<Runnable> shutdownNow​()
        尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。 从此方法返回时，这些任务将从任务队列中排除（删除）。

        此方法不等待主动执行的任务终止。 使用awaitTermination做到这一点。

        除了努力尝试停止处理积极执行任务之外，没有任何保证。 该实现通过Thread.interrupt()中断任务; 任何不能响应中断的任务都可能永远不会终止。

        Specified by:
        shutdownNow在接口 ExecutorService
        重写：
        shutdownNow在 ThreadPoolExecutor
        结果
        从未开始执行的任务列表。 该列表的每个元素都是一个ScheduledFuture 。 对于通过schedule方法之一提交的任务，该元素将与返回的ScheduledFuture相同。 对于使用execute提交的任务，元素将为零延迟ScheduledFuture 。
        异常
        SecurityException - 如果安全管理器存在并关闭，则ExecutorService可能会操纵调用者不允许修改的线程，因为它不保留RuntimePermission ("modifyThread")或安全管理器的checkAccess方法拒绝访问。

      • getQueue

        public BlockingQueue<Runnable> getQueue​()
        返回此执行程序使用的任务队列。 访问任务队列主要用于调试和监视。 此队列可能正在使用中。 检索任务队列不会阻止排队的任务执行。

        这个队列的每一个元素都是一个ScheduledFuture 。 对于通过schedule方法之一提交的任务，该元素将与返回的ScheduledFuture相同。 对于使用execute提交的任务，元素将为零延迟ScheduledFuture 。

        这个队列的迭代不能按照它们执行的顺序遍历任务。

        重写：
        getQueue在 ThreadPoolExecutor
        结果
        the task queue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Semaphore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class Semaphore

  • java.lang.Object
    • java.util.concurrent.Semaphore
  • All Implemented Interfaces:
    Serializable

    public class Semaphore
extends Object
implements Serializable
    一个计数信号量。 在概念上，信号量维持一组许可证。 如果有必要，每个acquire()阻止许可证可用，然后取出。 每个release()都添加了一个许可证，潜在地释放一个阻塞获取方。 但是，没有使用实际的许可证对象; Semaphore只保留可用数量的计数，并相应地进行操作。

    信号量通常用于限制线程数，而不是访问某些（物理或逻辑）资源。 例如，这是一个使用信号量来控制对一个项目池的访问的类：

       class Pool { private static final int MAX_AVAILABLE = 100; private final Semaphore available = new Semaphore(MAX_AVAILABLE, true); public Object getItem() throws InterruptedException { available.acquire(); return getNextAvailableItem(); } public void putItem(Object x) { if (markAsUnused(x)) available.release(); } // Not a particularly efficient data structure; just for demo protected Object[] items = ... whatever kinds of items being managed protected boolean[] used = new boolean[MAX_AVAILABLE]; protected synchronized Object getNextAvailableItem() { for (int i = 0; i < MAX_AVAILABLE; ++i) { if (!used[i]) { used[i] = true; return items[i]; } } return null; // not reached } protected synchronized boolean markAsUnused(Object item) { for (int i = 0; i < MAX_AVAILABLE; ++i) { if (item == items[i]) { if (used[i]) { used[i] = false; return true; } else return false; } } return false; } }

    在获得项目之前，每个线程必须从信号量获取许可证，以确保某个项目可用。 当线程完成该项目后，它将返回到池中，并将许可证返回到信号量，允许另一个线程获取该项目。 请注意，当调用acquire()时，不会保持同步锁定，因为这将阻止某个项目返回到池中。 信号量封装了限制对池的访问所需的同步，与保持池本身一致性所需的任何同步分开。

    信号量被初始化为一个，并且被使用，使得它只有至多一个允许可用，可以用作互斥锁。 这通常被称为二进制信号量 ，因为它只有两个状态：一个许可证可用，或零个允许可用。 当以这种方式使用时，二进制信号量具有属性（与许多Lock实现不同），“锁”可以由除所有者之外的线程释放（因为信号量没有所有权概念）。 这在某些专门的上下文中是有用的，例如死锁恢复。

    此类的构造函数可选择接受公平参数。 当设置为false时，此类不会保证线程获取许可的顺序。 特别是允许进行驳斥 ，也就是说，调用acquire()的线程可以在一直等待的线程之前分配一个许可证 - 逻辑上新的线程将自身置于等待线程队列的头部。 当公平设置为真时，信号量保证调用任何acquire方法的线程被选择以按照它们调用这些方法的顺序获得许可（先进先出; FIFO）。 请注意，FIFO排序必须适用于这些方法中的特定内部执行点。 因此，一个线程可以在另一个线程之前调用acquire ，但是到另一个线程之后的顺序点，并且类似地从方法返回。 另请注意，未定义的tryAcquire方法不符合公平性设置，但将采取任何可用的许可证。

    通常，用于控制资源访问的信号量应该被公平地初始化，以确保线程没有被访问资源。 当使用信号量进行其他类型的同步控制时，非正常排序的吞吐量优势往往超过公平性。

    本课程同时提供了acquire和release多个许可证的便利方法。 这些方法通常比循环更有效和有效。 但是，他们没有建立任何偏好顺序。 例如，如果线程A调用s.acquire(3 ），并且线程B调用s.acquire(2) ，并且两个许可证变得可用，则不保证线程B将获得它们，除非它的获取是第一，并且信号量s处于公平模式。

    内存一致性效果：在另一个线程中成功执行“获取”方法（例如acquire()之前，调用“释放”方法之前的线程中的操作，如release() happen-before 。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Semaphore​(int permits)
      创建一个 Semaphore与给定数量的许可证和非公平公平设置。
      Semaphore​(int permits, boolean fair)
      创建一个 Semaphore与给定数量的许可证和给定的公平设置。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void acquire​()
      从此信号量获取许可证，阻止直到可用，或线程为 interrupted 。
      void acquire​(int permits)
      从该信号量获取给定数量的许可证，阻止直到所有可用，或线程是 interrupted 。
      void acquireUninterruptibly​()
      从这个信号灯获取许可证，阻止一个可用的。
      void acquireUninterruptibly​(int permits)
      从该信号量获取给定数量的许可证，阻止直到所有可用。
      int availablePermits​()
      返回此信号量中当前可用的许可数。
      int drainPermits​()
      获得并返回所有可立即获得的许可证，或者如果有可用的许可证，则可以将其释放。
      protected Collection<Thread> getQueuedThreads​()
      返回一个包含可能正在等待获取的线程的集合。
      int getQueueLength​()
      返回等待获取的线程数的估计。
      boolean hasQueuedThreads​()
      查询任何线程是否等待获取。
      boolean isFair​()
      如果此信号量的公平设置为真，则返回 true 。
      protected void reducePermits​(int reduction)
      缩小可用许可证的数量。
      void release​()
      释放许可证，将其返回到信号量。
      void release​(int permits)
      释放给定数量的许可证，将其返回到信号量。
      String toString​()
      返回一个标识此信号量的字符串及其状态。
      boolean tryAcquire​()
      从这个信号量获得许可证，只有在调用时可以使用该许可证。
      boolean tryAcquire​(int permits)
      从这个信号量获取给定数量的许可证，只有在调用时全部可用。
      boolean tryAcquire​(int permits, long timeout, TimeUnit unit)
      从该信号量获取给定数量的许可证，如果在给定的等待时间内全部可用，并且当前线程尚未 interrupted 。
      boolean tryAcquire​(long timeout, TimeUnit unit)
      如果在给定的等待时间内可用，并且当前线程尚未 到达interrupted ，则从该信号量获取许可。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Semaphore

        public Semaphore​(int permits)
        创建一个 Semaphore与给定数量的许可证和非公平公平设置。
        参数
        permits - 可用的初始许可证。 该值可能为负数，在这种情况下，必须在任何获取被授予之前发布释放。

      • Semaphore

        public Semaphore​(int permits,
                 boolean fair)
        创建一个 Semaphore与给定数量的许可证和给定的公平设置。
        参数
        permits - 可用的初始许可证。 该值可能为负数，在这种情况下，必须在任何获取被授予之前发布释放。
        fair - true如果这个信号量将保证首先在竞争中先发许可证，否则 false

    • 方法详细信息

      • acquire

        public void acquire​()
             throws InterruptedException
        从此信号量获取许可证，阻止直到可用，或线程为interrupted 。

        获得许可证，如果有可用并立即返回，则将可用许可证数量减少一个。

        如果没有可用的许可证，那么当前线程将被禁用以进行线程调度，并且处于休眠状态，直至发生两件事情之一：

        • 一些其他线程调用这个信号量的release()方法，当前线程旁边被分配一个许可证; 要么
        • 一些其他线程interrupts当前线程。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted等待许可证，
        然后抛出InterruptedException ，并清除当前线程的中断状态。
        异常
        InterruptedException - 如果当前线程中断

      • acquireUninterruptibly

        public void acquireUninterruptibly​()
        从这个信号灯获取许可证，阻止一个可用的。

        获得许可证，如果有可用并立即返回，则将可用许可证数量减少一个。

        如果没有许可证可用，那么当前线程将被禁用以进行线程调度，并且处于休眠状态，直到某个其他线程调用此信号量的release()方法，并且当前线程接下来被分配许可证。

        如果当前线程在等待许可证时为interrupted ，那么它将继续等待，但是线程被分配许可证的时间可能会与接收到许可证的时间相比可能发生更改。 当该线程从该方法返回时，其中断状态将被设置。

      • tryAcquire

        public boolean tryAcquire​()
        从这个信号量获得许可证，只有在调用时可以使用该许可证。

        获得许可证，如果可用并立即返回，值为true ，将可用许可证数量减少一个。

        如果没有许可证可用，那么该方法将立即返回值为false 。

        即使这个信号量被设置为使用公平的订购策略，如果有可用的话，呼叫tryAcquire() 将立即获取许可证，无论其他线程是否正在等待。 这种“趸船”行为在某些情况下是有用的，尽管它打破了公平。 如果要尊重公平性设置，则使用tryAcquire(0, TimeUnit.SECONDS) 这几乎是等效的（也检测到中断）。

        结果
        true如果获得许可证，否则为 false

      • tryAcquire

        public boolean tryAcquire​(long timeout,
                          TimeUnit unit)
                   throws InterruptedException
        如果在给定的等待时间内可用，并且当前线程尚未被interrupted从该信号量获取许可。

        获得许可证，如果可用并立即返回，值为true ，将可用许可证数量减少一个。

        如果没有许可证可用，那么当前的线程将被禁用以进行线程调度，并且处于休眠状态，直至发生三件事情之一：

        • 一些其他线程调用这个信号量的release()方法，当前线程旁边被分配一个许可证; 要么
        • 一些其他线程当前线程interrupts ; 要么
        • 指定的等待时间过去了。

        如果获得许可证，则返回值true 。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted等待获得许可证，
        则抛出InterruptedException ，并清除当前线程的中断状态。

        如果指定的等待时间过去，则返回值false 。 如果时间小于或等于零，该方法根本不会等待。

        参数
        timeout - 等待许可证的最长时间
        unit - timeout参数的时间单位
        结果
        true如获得许可证，如果获得许可证之前经过的等待时间为 false
        异常
        InterruptedException - 当前线程是否中断

      • release

        public void release​()
        释放许可证，将其返回到信号量。

        发放许可证，将可用许可证的数量增加一个。 如果任何线程尝试获取许可证，那么选择一个被授予刚被释放的许可证。 （重新）线程调度用于线程调度。

        没有要求释放许可证的线程必须通过调用acquire()获取该许可证。 信号量的正确使用通过应用程序中的编程惯例来确定。

      • acquire

        public void acquire​(int permits)
             throws InterruptedException
        从该信号量获取给定数量的许可证，阻止直到所有可用，或线程为interrupted 。

        获得一定数量的许可证，如果可用，并立即返回，将可用许可证数量减少给定数量。 该方法与循环for (int i = 0; i < permits; ++i) acquire();具有相同的效果，除了它一次性原子获取许可证：

        如果没有足够的许可证可用，那么当前线程将被禁用以进行线程调度，并且处于休眠状态，直到发生两件事情之一：

        • 一些其他线程调用这个信号量的一个release方法，当前线程接下来被分配许可证，可用许可证的数量满足这个请求; 要么
        • 一些其他线程interrupts当前线程。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted等待许可证，
        然后抛出InterruptedException ，并清除当前线程的中断状态。 任何被分配给这个线程的许可证被分配给试图获取许可证的其他线程，就像通过调用release()可以获得许可证一样。
        参数
        permits - 获得许可证的数量
        异常
        InterruptedException - 当前线程是否中断
        IllegalArgumentException - 如果 permits为负数

      • acquireUninterruptibly

        public void acquireUninterruptibly​(int permits)
        从该信号量获取给定数量的许可证，阻止直到所有可用。

        获得一定数量的许可证，如果可用，并立即返回，将可用许可证数量减少给定数量。 该方法与循环for (int i = 0; i < permits; ++i) acquireUninterruptibly();具有相同的效果，除了它一次性原子获取许可证：

        如果可用的许可证不足，则当前线程将被禁用以进行线程调度，并处于休眠状态，直到某个其他线程调用此信号量的release方法之一，并且当前线程接下来被分配许可证，并且可用许可证的数量满足此请求。

        如果当前线程在等待许可时为interrupted ，那么它将继续等待，并且其在队列中的位置不受影响。 当该线程从该方法返回时，其中断状态将被设置。

        参数
        permits - 获得许可证的数量
        异常
        IllegalArgumentException - 如果 permits为负数

      • tryAcquire

        public boolean tryAcquire​(int permits)
        从这个信号量获取给定数量的许可证，只有在调用时全部可用。

        获得指定数量的许可证，如果可用，并立即返回，值为true ，将可用许可证数量减少给定金额。

        如果许可证不足，则该方法将立即返回值false ，可用许可证数量不变。

        即使这个信号量被设置为使用公平的订购策略，如果有可用的话，呼叫tryAcquire 将立即获得许可证，无论其他线程是否正在等待。 这种“趸船”行为在某些情况下是有用的，尽管它打破了公平。 如果要尊重公平性设置，那么使用tryAcquire(permits, 0, TimeUnit.SECONDS) 这几乎是等效的（它也检测到中断）。

        参数
        permits - 获得许可证的数量
        结果
        true如果许可证获得，否则为 false
        异常
        IllegalArgumentException - 如果 permits为负数

      • tryAcquire

        public boolean tryAcquire​(int permits,
                          long timeout,
                          TimeUnit unit)
                   throws InterruptedException
        如果在给定的等待时间内全部可用，并且当前线程尚未到达interrupted ，则从该信号量获取给定数量的许可证。

        获得指定数量的许可证（如果可用并立即返回），值为true ，将可用许可证数量减少给定的数量。

        如果没有足够的许可证可用，那么当前的线程将被禁用以进行线程调度，并且处于休眠状态，直至发生三件事情之一：

        • 一些其他线程调用这个信号量的一个release方法，当前线程接下来被分配许可证，可用许可证的数量满足这个请求; 要么
        • 一些其他线程interrupts当前线程; 要么
        • 指定的等待时间过去了。

        如果获得许可证，则返回值true 。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted等待获得许可证，
        那么抛出InterruptedException并清除当前线程的中断状态。 任何分配给此线程的许可证都将转而分配给尝试获取许可证的其他线程，就像通过拨打release()可以使用的许可证一样 。

        如果指定的等待时间过去，则返回值false 。 如果时间小于或等于零，该方法根本不会等待。 任何被分配给这个线程的许可证被分配给试图获取许可证的其他线程，就像通过调用release()可以获得的许可证一样。

        参数
        permits - 获得许可证的数量
        timeout - 等待许可证的最长时间
        unit - timeout参数的时间单位
        结果
        true如果获得所有许可证和 false如果在所有许可证获得之前经过的等待时间
        异常
        InterruptedException - 当前线程是否中断
        IllegalArgumentException - 如果 permits为负数

      • release

        public void release​(int permits)
        释放给定数量的许可证，将其返回到信号量。

        释放给定数量的许可证，增加可用许可证的数量。 如果任何线程尝试获取许可证，则选择一个线程并给出刚刚释放的许可证。 如果可用许可证的数量满足该线程的请求，则该线程（线程）被重新启用以进行线程调度; 否则线程将等待，直到有足够的许可证可用。 如果在该线程的请求已经满足之后还有可用的许可证，那么这些许可证依次被分配给其他尝试获取许可证的线程。

        没有要求释放许可证的线程必须通过调用acquire获得该许可证。 信号量的正确使用通过应用程序中的编程惯例来确定。

        参数
        permits - 释放许可证的数量
        异常
        IllegalArgumentException - 如果 permits为负数

      • availablePermits

        public int availablePermits​()
        返回此信号量中当前可用的许可数。

        该方法通常用于调试和测试。

        结果
        该信号量中可用的许可证数量

      • drainPermits

        public int drainPermits​()
        获得并返回所有可立即获得的许可证，或者如果有可用的许可证，则可以将其释放。 返回时，零许可证可用。
        结果
        获得的许可证数量，或者如果是否定的话，发布的数量

      • reducePermits

        protected void reducePermits​(int reduction)
        缩小可用许可证的数量。 该方法在使用信号量来跟踪变得不可用的资源的子类中是有用的。 该方法与acquire不同之处在于它不阻止等待许可证变为可用。
        参数
        reduction - 删除许可证的数量
        异常
        IllegalArgumentException - 如果 reduction为负数

      • isFair

        public boolean isFair​()
        如果此信号量的公平设置为真，则返回 true 。
        结果
        true如果这个信号量具有公平性

      • hasQueuedThreads

        public final boolean hasQueuedThreads​()
        查询任何线程是否等待获取。 请注意，因为取消可能会在任何时候发生，所以true返回不能保证任何其他线程将获得。 该方法主要用于监视系统状态。
        结果
        true如果可能有其他线程等待获取锁

      • getQueueLength

        public final int getQueueLength​()
        返回等待获取的线程数的估计。 该值只是一个估计，因为线程数可能会在此方法遍历内部数据结构时动态更改。 该方法设计用于监控系统状态，不用于同步控制。
        结果
        估计等待这个锁的线程数

      • getQueuedThreads

        protected Collection<Thread> getQueuedThreads​()
        返回一个包含可能正在等待获取的线程的集合。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。 该方法旨在便于构建提供更广泛监控设施的子类。
        结果
        线程的收集

      • toString

        public String toString​()
        返回一个标识此信号量的字符串及其状态。 括号中的状态包括字符串"Permits ="后跟许可证数量。
        重写：
        toString在 Object
        结果
        a string identifying this semaphore, as well as its state
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SubmissionPublisher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class SubmissionPublisher<T>

  • java.lang.Object
    • java.util.concurrent.SubmissionPublisher<T>
  • 参数类型
    T - 已发布的项目类型
    All Implemented Interfaces:
    AutoCloseable ， Flow.Publisher<T>

    public class SubmissionPublisher<T>
extends Object
implements Flow.Publisher<T>, AutoCloseable
    A Flow.Publisher异步地将提交的（非空）项目发送给当前订户，直到关闭。 每个当前用户以相同的顺序接收新提交的项目，除非遇到丢失或异常。 使用提交发布器允许项目生成器作为兼容性reactive-streams发布者依赖于丢弃处理和/或阻止流控制。

    提交发布者使用其构造函数中提供的Executor来传递给订阅者。 执行人员的最佳选择取决于预期用途。 如果提交的项目的生成器以不同的线程运行，并且可以估计订户的数量，请考虑使用Executors.newFixedThreadPool(int) 。 否则考虑使用默认值，通常是ForkJoinPool.commonPool() 。

    缓冲允许生产者和消费者以不同的速率暂时运作。 每个用户使用独立的缓冲区。 缓冲区是在首次使用时创建的，并根据需要扩展到给定的最大值。 （强制执行的容量可以四舍五入为最接近的权力和/或由此实施支持的最大值限制。） request的调用不直接导致缓冲区扩展，但如果未填充的请求超过最大容量，那么风险将会饱和。 默认值Flow.defaultBufferSize()可能为基于预期利率，资源和用途选择容量提供了有用的起点。

    出版方法支持关于缓冲区饱和时要做什么的不同策略。 方法submit块，直到资源可用。 这是最简单的，但响应不大。 offer方法可能会丢弃项目（立即或有限超时），但提供插入处理程序然后重试的机会。

    如果任何订阅者方法抛出异常，其订阅将被取消。 如果处理程序是作为一个构造函数的参数，它会被取消之前在方法中的异常调用onNext ，但在方法例外onSubscribe ， onError和onComplete不入账或取消之前办理。 如果提供的Executor在尝试执行任务时抛出RejectedExecutionException （或任何其他RuntimeException或Error），或者在处理丢弃的项目时，丢弃处理程序会引发异常，则会重新引发异常。 在这些情况下，并非所有订阅者都将发布已发布的项目。 在这些情况下通常是closeExceptionally的良好做法。

    方法consume(Consumer)简化了对常见情况的支持，其中订户的唯一动作是使用所提供的功能请求和处理所有项目。

    此类也可以作为生成项目的子类的便利基础，并使用此类中的方法发布它们。 例如，这里是定期发布从供应商生成的项目的类。 （实际上，您可以添加独立启动和停止生成的方法，在发布者之间共享Executors等等，或者使用SubmissionPublisher作为组件而不是超类）。

       class PeriodicPublisher<T> extends SubmissionPublisher<T> { final ScheduledFuture<?> periodicTask; final ScheduledExecutorService scheduler; PeriodicPublisher(Executor executor, int maxBufferCapacity, Supplier<? extends T> supplier, long period, TimeUnit unit) { super(executor, maxBufferCapacity); scheduler = new ScheduledThreadPoolExecutor(1); periodicTask = scheduler.scheduleAtFixedRate( () -> submit(supplier.get()), 0, period, unit); } public void close() { periodicTask.cancel(false); scheduler.shutdown(); super.close(); } }

    这是一个Flow.Processor实现的例子。 为了简化说明，它向其发布者使用单步请求。 更自适应的版本可以使用从submit返回的滞后估计以及其他实用方法来监视流量。

       class TransformProcessor<S,T> extends SubmissionPublisher<T> implements Flow.Processor<S,T> { final Function<? super S, ? extends T> function; Flow.Subscription subscription; TransformProcessor(Executor executor, int maxBufferCapacity, Function<? super S, ? extends T> function) { super(executor, maxBufferCapacity); this.function = function; } public void onSubscribe(Flow.Subscription subscription) { (this.subscription = subscription).request(1); } public void onNext(S item) { subscription.request(1); submit(function.apply(item)); } public void onError(Throwable ex) { closeExceptionally(ex); } public void onComplete() { close(); } }
    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Constructor 描述
      SubmissionPublisher​()
      使用 ForkJoinPool.commonPool()创建一个新的SubmissionPublisher，用于向用户进行异步传递（除非它不支持至少两个并行级别，在这种情况下，创建一个新的线程来运行每个任务），最大缓冲区容量为 Flow.defaultBufferSize() ，否则方法 onNext中订阅者异常的处理程序。
      SubmissionPublisher​(Executor executor, int maxBufferCapacity)
      使用给定的Executor创建一个新的SubmissionPublisher，为订阅者提供异步传递，每个订户的给定最大缓冲区大小，方法 onNext中没有用户订户异常的处理程序。
      SubmissionPublisher​(Executor executor, int maxBufferCapacity, BiConsumer<? super Flow.Subscriber<? super T>,? super Throwable> handler)
      使用给定的Executor创建一个新的提交发布者，以便为订阅者提供异步传递，给定每个用户的最大缓冲区大小，如果非空，则在任何订阅者在方法 onNext中引发异常时调用给定的处理程序。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      除非已经关闭，问题 onComplete向当前用户发出信号，并且不允许随后的尝试发布。
      void closeExceptionally​(Throwable error)
      除非已经关闭，否则问题 onError以给定错误向当前用户发出信号，并且不允许随后的尝试发布。
      CompletableFuture<Void> consume​(Consumer<? super T> consumer)
      使用给定的Consumer功能处理所有已发布的项目。
      int estimateMaximumLag​()
      返回所有当前订阅者中生成但尚未消费的最大项目数量的估计值。
      long estimateMinimumDemand​()
      在所有当前订阅者中，返回所要求的最小数量（通过 request ）但尚未生成的估计。
      Throwable getClosedException​()
      返回与 closeExceptionally相关联的异常，如果未关闭或正常关闭，则为null。
      Executor getExecutor​()
      返回用于异步传递的执行程序。
      int getMaxBufferCapacity​()
      返回最大每用户缓冲区容量。
      int getNumberOfSubscribers​()
      返回当前订阅者的数量。
      List<Flow.Subscriber<? super T>> getSubscribers​()
      返回用于监视和跟踪目的的当前用户列表，而不是在订阅者上调用Flow.Subscriber方法。
      boolean hasSubscribers​()
      如果此发布者有任何订阅者，则返回true。
      boolean isClosed​()
      如果此发布商不接受提交，则返回true。
      boolean isSubscribed​(Flow.Subscriber<? super T> subscriber)
      如果给定订阅者当前订阅，则返回true。
      int offer​(T item, long timeout, TimeUnit unit, BiPredicate<Flow.Subscriber<? super T>,? super T> onDrop)
      如果可能，通过异步调用其 onNext方法来发布给定的项目，阻止当任何订阅的资源不可用时，直到指定的超时或直到调用者线程被中断，此时给定的处理程序-null）被调用，如果返回true，则重试一次。
      int offer​(T item, BiPredicate<Flow.Subscriber<? super T>,? super T> onDrop)
      如果可能，通过异步调用其 onNext方法将给定项目发布给每个当前用户。
      int submit​(T item)
      通过异步调用其 onNext方法将给定项目发布给每个当前用户，阻止不中断，而任何用户的资源不可用。
      void subscribe​(Flow.Subscriber<? super T> subscriber)
      添加给定订阅者，除非已经订阅。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SubmissionPublisher

        public SubmissionPublisher​(Executor executor,
                           int maxBufferCapacity,
                           BiConsumer<? super Flow.Subscriber<? super T>,? super Throwable> handler)
        使用给定的Executor创建一个新的SubmissionPublisher，为订户提供异步传递，给定每个订户的最大缓冲区大小，如果非空，则在任何Subscriber在方法 onNext中引发异常时调用给定的处理程序。
        参数
        executor - 执行器用于异步传递，支持创建至少一个独立线程
        maxBufferCapacity - 每个用户缓冲区的最大容量（强制容量可以舍入到最接近的两个幂并且/或由该实现支持的最大值限定）;方法 getMaxBufferCapacity()返回实际值）
        handler - 如果非空，则在方法 onNext抛出异常时调用的过程
        异常
        NullPointerException - 如果executor为null
        IllegalArgumentException - 如果maxBufferCapacity IllegalArgumentException

      • SubmissionPublisher

        public SubmissionPublisher​(Executor executor,
                           int maxBufferCapacity)
        使用给定的Executor创建一个新的SubmissionPublisher，以便为订户提供异步传递，给定每个订户的最大缓冲区大小，并且在方法 onNext中没有用于订阅者异常的处理程序。
        参数
        executor - 执行器用于异步传递，支持创建至少一个独立线程
        maxBufferCapacity - 每个用户缓冲区的最大容量（强制容量可以舍入到最接近的两个幂并且/或由该实现支持的最大值限定）;方法 getMaxBufferCapacity()返回实际值）
        异常
        NullPointerException - 如果executor为null
        IllegalArgumentException - 如果maxBufferCapacity不为正

      • SubmissionPublisher

        public SubmissionPublisher​()
        创建一个新的SubmissionPublisher，使用 ForkJoinPool.commonPool()进行异步传递给用户（除非它不支持至少两个并行性级别，在这种情况下，创建一个新的线程来运行每个任务），最大缓冲容量为 Flow.defaultBufferSize() ，否则方法 onNext中订阅者异常的处理程序。

    • 方法详细信息

      • subscribe

        public void subscribe​(Flow.Subscriber<? super T> subscriber)
        添加给定订阅者，除非已经订阅。 如果已经订阅，订阅者的onError方法将在现有订阅中使用IllegalStateException进行调用 。 否则，成功后，订阅者的onSubscribe方法将与新的Flow.Subscription异步调用。 如果onSubscribe引发异常，订阅将被取消。 否则，如果此提交发布者异常关闭，则用户的onError方法将被调用与相应的异常，或者如果关闭无一例外，则调用订户的onComplete方法。 订阅者可以通过调用新订阅的request方法来启用接收项，并可通过调用其cancel方法取消订阅。
        Specified by:
        subscribe在接口 Flow.Publisher<T>
        参数
        subscriber - 用户
        异常
        NullPointerException - 如果用户为空

      • submit

        public int submit​(T item)
        通过异步调用其onNext方法将给定项目发布给每个当前用户，阻止不间断，而任何用户的资源不可用。 此方法返回所有当前订阅者中最大滞后（已提交但尚未消费的项目数）的估计。 如果有任何用户，此值至少为一（占该提交的项目），否则为零。

        如果此发布者的Executor在尝试异步通知订阅者时引发了RejectedExecutionException（或任何其他RuntimeException或Error），则会重新抛出此异常，在这种情况下，并非所有订阅者都将被发出此项。

        参数
        item - 要发布的（非空）项
        结果
        用户估计最大滞后
        异常
        IllegalStateException - 如果关闭
        NullPointerException - 如果item为null
        RejectedExecutionException - 如果由Executor抛出

      • offer

        public int offer​(T item,
                 BiPredicate<Flow.Subscriber<? super T>,? super T> onDrop)
        如果可能，通过异步调用其onNext方法将给定项目发布给每个当前用户。 如果超出资源限制，该项目可能被一个或多个订户丢弃，在这种情况下调用给定的处理程序（如果非空），如果返回true，则重试一次。 在处理程序被调用时，阻止其他线程在此类中对方法的其他调用。 除非确保恢复，否则选项通常限于记录错误和/或向用户发出onError信号。

        此方法返回一个状态指示器：如果为负，则表示（负）数量的丢弃（尝试将订单发送给订户失败）。 否则，是所有当前订阅者中最大滞后（已提交但尚未消费的项目数）的估计。 如果有任何用户，此值至少为一（占该提交的项目），否则为零。

        如果此发布者的Executor在尝试异步通知订阅者时抛出了RejectedExecutionException（或任何其他RuntimeException或Error），或者在处理丢弃的项目时，drop handler抛出异常，则会重新抛出此异常。

        参数
        item - 要发布的（非空）项
        onDrop - 如果非空，则在删除订户时调用该处理程序，其参数为订阅者和项目; 如果返回true，则重新尝试（一次）
        结果
        如果为负，则（负）滴数; 否则估计最大滞后
        异常
        IllegalStateException - 如果关闭
        NullPointerException - 如果项目为空
        RejectedExecutionException - 如果由Executor抛出

      • offer

        public int offer​(T item,
                 long timeout,
                 TimeUnit unit,
                 BiPredicate<Flow.Subscriber<? super T>,? super T> onDrop)
        如果可能，通过异步调用其onNext方法将给定项目发布给每个当前订户，阻止任何订阅的资源不可用，直到指定的超时或直到调用者线程中断，此时给定的处理程序（如果非-null）被调用，如果返回true，则重试一次。 （丢弃处理程序可以通过检查当前线程是否中断来区分超时与中断）。在调用处理程序时，阻止其他线程在此类中对方法的其他调用。 除非确定恢复，否则选项通常限于记录错误和/或向用户发出onError信号。

        此方法返回一个状态指示器：如果为负，则表示（负）数量的丢弃（尝试将订单发送给订户失败）。 否则，是所有当前订阅者中最大滞后（已提交但尚未消费的项目数）的估计。 如果有任何用户，此值至少为一（占该提交的项目），否则为零。

        如果此发布者的Executor在尝试异步通知订阅者时抛出了RejectedExecutionException（或任何其他RuntimeException或Error），或者在处理丢弃的项目时，drop handler抛出异常，则会重新抛出此异常。

        参数
        item - 要发布的（非空）项
        timeout -等待多久资源对于任何用户放弃，在单位前 unit
        unit - a TimeUnit确定如何解释 timeout参数
        onDrop - 如果非空，则在删除订户时调用该处理程序，其参数为订阅者和项目; 如果返回true，则重新尝试（一次）
        结果
        如果为负，则（负）滴数; 否则估计最大滞后
        异常
        IllegalStateException - 如果关闭
        NullPointerException - 如果item为null
        RejectedExecutionException - 如果由Executor抛出

      • close

        public void close​()
        除非已经关闭，否则问题onComplete向当前用户发出信号，并且不允许随后的尝试发布。 返回时，这种方法并不能保证所有的用户都尚未完成。
        Specified by:
        close在接口 AutoCloseable

      • closeExceptionally

        public void closeExceptionally​(Throwable error)
        除非已经关闭，否则问题onError以给定的错误向当前订户发出信号，并且不允许随后的尝试发布。 未来订阅者也会收到给定的错误。 返回时，这种方法并不能保证所有的用户都尚未完成。
        参数
        error - 发送给订阅者的 onError参数
        异常
        NullPointerException - 如果错误为null

      • isClosed

        public boolean isClosed​()
        如果此发布商不接受提交，则返回true。
        结果
        如果关闭则为true

      • getClosedException

        public Throwable getClosedException​()
        返回与 closeExceptionally相关联的异常，如果未关闭或正常关闭，则为null。
        结果
        异常，如果没有则为null

      • hasSubscribers

        public boolean hasSubscribers​()
        如果此发布者有任何订阅者，则返回true。
        结果
        如果此发布商有任何订阅者，则为true

      • getNumberOfSubscribers

        public int getNumberOfSubscribers​()
        返回当前订阅者的数量。
        结果
        当前订阅者的数量

      • getExecutor

        public Executor getExecutor​()
        返回用于异步传递的执行程序。
        结果
        Executor用于异步传送

      • getMaxBufferCapacity

        public int getMaxBufferCapacity​()
        返回最大每用户缓冲区容量。
        结果
        最大每用户缓冲区容量

      • getSubscribers

        public List<Flow.Subscriber<? super T>> getSubscribers​()
        返回用于监视和跟踪目的的当前用户列表，而不是在订阅者上调用Flow.Subscriber方法。
        结果
        当前订阅者列表

      • isSubscribed

        public boolean isSubscribed​(Flow.Subscriber<? super T> subscriber)
        如果给定订阅者当前订阅，则返回true。
        参数
        subscriber - 用户
        结果
        如果当前订阅，则为true
        异常
        NullPointerException - 如果用户为空

      • estimateMinimumDemand

        public long estimateMinimumDemand​()
        在所有当前订阅者中，返回所要求的最小数量（通过 request ）但尚未生成的估计。
        结果
        估计，如果没有订阅者，则为零

      • estimateMaximumLag

        public int estimateMaximumLag​()
        返回所有当前订阅者中生成但尚未消费的最大项目数量的估计值。
        结果
        估计

      • consume

        public CompletableFuture<Void> consume​(Consumer<? super T> consumer)
        使用给定的Consumer功能处理所有已发布的项目。 返回一个CompletableFuture，当发布商发信号为onComplete ，或者在任何错误时异常地完成，或者消费者抛出异常，或者退回的CompletableFuture被取消，在这种情况下，没有进一步的处理。
        参数
        consumer - 应用于每个onNext项目的函数
        结果
        一个CompletedFuture，当发布商发出信号onComplete时正常完成，特别是在任何错误或取消时
        异常
        NullPointerException - 如果消费者为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynchronousQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class SynchronousQueue<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractQueue<E>
        • java.util.concurrent.SynchronousQueue<E>
  • 参数类型
    E - 保存在此队列中的元素的类型
    All Implemented Interfaces:
    Serializable ， Iterable<E> ， Collection<E> ， BlockingQueue<E> ， Queue<E>

    public class SynchronousQueue<E>
extends AbstractQueue<E>
implements BlockingQueue<E>, Serializable
    A blocking queue其中每个插入操作必须等待另一个线程相应的删除操作，反之亦然。 同步队列没有任何内部容量，甚至没有一个容量。 您不能在同步队列peek因为一个元素只有当您尝试删除它时才存在; 您无法插入元素（使用任何方法），除非另有线程正在尝试删除它; 你不能迭代，因为没有什么可以迭代。 队列的头部是第一个排队的插入线程尝试添加到队列中的元素; 如果没有这样排队的线程，那么没有元素可用于删除， poll()将返回null 。 为了其他Collection方法（例如contains ）的目的， SynchronousQueue用作空集合。 此队列不允许null元素。

    同步队列类似于CSP和Ada中使用的会合通道。 它们非常适用于切换设计，其中运行在一个线程中的对象必须与在另一个线程中运行的对象同步，以便交付一些信息，事件或任务。

    此类支持可选的公平策略，用于订购等待的生产者和消费者线程。 默认情况下，此订单不能保证。 但是，将公平设置为true的队列以FIFO顺序授予线程访问权限。

    该类及其迭代器实现了Collection和Iterator接口的所有可选方法。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SynchronousQueue​()
      创建一个 SynchronousQueue与非访问策略。
      SynchronousQueue​(boolean fair)
      创建具有指定公平政策的 SynchronousQueue 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      什么也没做。
      boolean contains​(Object o)
      始终返回 false 。
      boolean containsAll​(Collection<?> c)
      返回 false除非给定的集合为空。
      int drainTo​(Collection<? super E> c)
      从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
      int drainTo​(Collection<? super E> c, int maxElements)
      最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
      boolean isEmpty​()
      始终返回 true 。
      Iterator<E> iterator​()
      返回一个空的迭代器，其中 hasNext总是返回 false 。
      boolean offer​(E e)
      如果另一个线程正在等待接收，则将指定的元素插入到此队列中。
      boolean offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此队列中，如果需要，等待另一个线程接收到的指定等待时间。
      E peek​()
      始终返回 null 。
      E poll​()
      如果另一个线程正在使一个元素可用，则检索并删除此队列的头。
      E poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，如果需要等待指定的等待时间，另一个线程插入它。
      void put​(E e)
      将指定的元素添加到此队列，等待另一个线程接收它。
      int remainingCapacity​()
      始终返回零。
      boolean remove​(Object o)
      始终返回 false 。
      boolean removeAll​(Collection<?> c)
      始终返回 false 。
      boolean retainAll​(Collection<?> c)
      始终返回 false 。
      int size​()
      始终返回零。
      Spliterator<E> spliterator​()
      返回一个空的分配器，其中对 Spliterator.trySplit()的调用始终返回 null 。
      E take​()
      检索并删除此队列的头，等待另一个线程插入它。
      Object[] toArray​()
      返回零长度数组。
      <T> T[] toArray​(T[] a)
      将指定数组的第零个元素设置为 null （如果数组的长度不为零）并返回。
      String toString​()
      始终返回 "[]" 。

      • Methods inherited from class java.util.AbstractQueue

        add, addAll, element, remove

      • Methods inherited from interface java.util.concurrent.BlockingQueue

        add

      • Methods inherited from interface java.util.Collection

        addAll, equals, hashCode, parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.util.Queue

        element, remove

    • 构造方法详细信息

      • SynchronousQueue

        public SynchronousQueue​()
        创建一个 SynchronousQueue与非访问策略。

      • SynchronousQueue

        public SynchronousQueue​(boolean fair)
        创建具有指定公平政策的 SynchronousQueue 。
        参数
        fair - 如果为真，等待线程以FIFO命令进行访问; 否则订单是未指定的。

    • 方法详细信息

      • put

        public void put​(E e)
         throws InterruptedException
        将指定的元素添加到此队列，等待另一个线程接收它。
        Specified by:
        put在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        异常
        InterruptedException - 如果在等待时中断
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e,
                     long timeout,
                     TimeUnit unit)
              throws InterruptedException
        将指定的元素插入到此队列中，如果需要，等待另一个线程接收到的指定等待时间。
        Specified by:
        offer在接口 BlockingQueue<E>
        参数
        e - 要添加的元素
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在消费者出现之前经过了指定的等待时间
        异常
        InterruptedException - 如果在等待时中断
        NullPointerException - 如果指定的元素为空

      • offer

        public boolean offer​(E e)
        如果另一个线程正在等待接收，则将指定的元素插入到此队列中。
        Specified by:
        offer在接口 BlockingQueue<E>
        Specified by:
        offer在接口 Queue<E>
        参数
        e - 要添加的元素
        结果
        true如果元素被添加到该队列，否则为 false
        异常
        NullPointerException - 如果指定的元素为空

      • take

        public E take​()
       throws InterruptedException
        检索并删除此队列的头，等待另一个线程插入它。
        Specified by:
        take在接口 BlockingQueue<E>
        结果
        这个队列的头
        异常
        InterruptedException - 如果等待中断

      • poll

        public E poll​(long timeout,
              TimeUnit unit)
       throws InterruptedException
        检索并删除此队列的头，如果需要等待指定的等待时间，另一个线程插入它。
        Specified by:
        poll在接口 BlockingQueue<E>
        参数
        timeout - 放弃之前等待多久，以 unit为单位
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        该队列的头部，如果在元素存在之前经过了指定的等待时间， null
        异常
        InterruptedException - 如果中断等待

      • poll

        public E poll​()
        如果另一个线程正在使一个元素可用，则检索并删除此队列的头。
        Specified by:
        poll在接口 Queue<E>
        结果
        这个队列的头，或 null如果没有元素可用

      • isEmpty

        public boolean isEmpty​()
        始终返回true 。 A SynchronousQueue没有内部容量。
        Specified by:
        isEmpty在接口 Collection<E>
        重写：
        isEmpty AbstractCollection<E>
        结果
        true

      • size

        public int size​()
        始终返回零。 A SynchronousQueue没有内部容量。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        零

      • remainingCapacity

        public int remainingCapacity​()
        始终返回零。 A SynchronousQueue没有内部容量。
        Specified by:
        remainingCapacity在接口 BlockingQueue<E>
        结果
        零

      • clear

        public void clear​()
        什么也没做。 A SynchronousQueue没有内部容量。
        Specified by:
        clear在接口 Collection<E>
        重写：
        clear在 AbstractQueue<E>

      • contains

        public boolean contains​(Object o)
        始终返回false 。 A SynchronousQueue没有内部容量。
        Specified by:
        contains在接口 BlockingQueue<E>
        Specified by:
        contains在接口 Collection<E>
        重写：
        contains在 AbstractCollection<E>
        参数
        o - 元素
        结果
        false

      • remove

        public boolean remove​(Object o)
        始终返回false 。 A SynchronousQueue没有内部容量。
        Specified by:
        remove在接口 BlockingQueue<E>
        Specified by:
        remove接口 Collection<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要删除的元素
        结果
        false

      • containsAll

        public boolean containsAll​(Collection<?> c)
        返回false除非给定的集合为空。 A SynchronousQueue没有内部容量。
        Specified by:
        containsAll在接口 Collection<E>
        重写：
        containsAll在 AbstractCollection<E>
        参数
        c - 收藏
        结果
        false除非给定的集合是空的
        另请参见：
        AbstractCollection.contains(Object)

      • removeAll

        public boolean removeAll​(Collection<?> c)
        始终返回false 。 A SynchronousQueue没有内部容量。
        Specified by:
        removeAll在接口 Collection<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 收藏
        结果
        false
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        始终返回false 。 A SynchronousQueue没有内部容量。
        Specified by:
        retainAll在接口 Collection<E>
        重写：
        retainAll中的 AbstractCollection<E>
        参数
        c - 收藏
        结果
        false
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • peek

        public E peek​()
        始终返回null 。 A SynchronousQueue除非积极地等待，否则不返回元素。
        Specified by:
        peek在接口 Queue<E>
        结果
        null

      • iterator

        public Iterator<E> iterator​()
        返回一个空的迭代器，其中 hasNext总是返回 false 。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在 AbstractCollection<E>
        结果
        一个空的迭代器

      • spliterator

        public Spliterator<E> spliterator​()
        返回一个空的分配器，其中对 Spliterator.trySplit()的调用总是返回 null 。
        Specified by:
        spliterator在接口 Collection<E>
        Specified by:
        spliterator在接口 Iterable<E>
        结果
        一个空的拼写器
        从以下版本开始：
        1.8

      • toArray

        public Object[] toArray​()
        返回零长度数组。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        结果
        一个零长度的数组

      • toArray

        public <T> T[] toArray​(T[] a)
        将指定数组的第零个元素设置为 null （如果数组具有非零长度）并返回。
        Specified by:
        toArray在接口 Collection<E>
        重写：
        toArray在 AbstractCollection<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        a - 数组
        结果
        指定的数组
        异常
        NullPointerException - 如果指定的数组为空

      • toString

        public String toString​()
        始终返回 "[]" 。
        重写：
        toString在 AbstractCollection<E>
        结果
        "[]"

      • drainTo

        public int drainTo​(Collection<? super E> c)
        描述从接口BlockingQueue复制
        从该队列中删除所有可用的元素，并将它们添加到给定的集合中。 此操作可能比重复轮询此队列更有效。 尝试向集合c添加元素时遇到的失败可能会导致元素在抛出关联的异常时既不在两个集合中，也可能不是两个集合。 尝试将队列排入自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 将元素传输到的集合
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定的集合不支持添加元素
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或该队列的某个元素的某些属性会阻止将其添加到指定的集合

      • drainTo

        public int drainTo​(Collection<? super E> c,
                   int maxElements)
        说明从接口BlockingQueue复制
        最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。 尝试向集合c添加元素时遇到的失败可能导致在抛出关联的异常时，元素既不在两个集合中，也可能不是两个集合。 尝试将队列排入自身会导致IllegalArgumentException 。 此外，如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        drainTo在接口 BlockingQueue<E>
        参数
        c - 将元素传输到的集合
        maxElements - 要传输的元素的最大数量
        结果
        转移的元素数量
        异常
        UnsupportedOperationException - 如果指定的集合不支持元素的添加
        ClassCastException - 如果此队列的元素的类阻止将其添加到指定的集合
        NullPointerException - 如果指定的集合为空
        IllegalArgumentException - 如果指定的集合是此队列，或该队列的某个元素的某些属性阻止将其添加到指定的集合
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ThreadFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface ThreadFactory

  • public interface ThreadFactory
    根据需要创建新线程的对象。 使用线程工厂可以删除new Thread的硬连线 ，使应用程序能够使用特殊线程子类，优先级等。

    这个界面的最简单的实现只是：

       class SimpleThreadFactory implements ThreadFactory { public Thread newThread(Runnable r) { return new Thread(r); } }
    Executors.defaultThreadFactory()方法提供了一个更有用的简单实现，它将创建的线程上下文设置为已知值，然后返回它。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Thread newThread​(Runnable r)
      构造新的 Thread 。

    • 方法详细信息

      • newThread

        Thread newThread​(Runnable r)
        构造新的Thread 。 实现也可以初始化优先级，名称，守护进程状态， ThreadGroup等。
        参数
        r - 由新的线程实例执行的runnable
        结果
        构造线程，或 null如果创建线程的请求被拒绝
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ThreadLocalRandom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ThreadLocalRandom

  • java.lang.Object
    • java.util.Random
      • java.util.concurrent.ThreadLocalRandom
  • All Implemented Interfaces:
    Serializable

    public class ThreadLocalRandom
extends Random
    与当前线程隔离的随机数生成器。 像Math类使用的全局Random发生器一样， ThreadLocalRandom用内部生成的种子进行初始化，可能不会被修改。 适用时，在并发程序中使用ThreadLocalRandom而不是共享的Random对象通常会遇到更少的开销和争用。 当多个任务（例如，每个ForkJoinTask ）在线程池中并行使用随机数时，使用ThreadLocalRandom是特别合适的。

    这个类的用途通常应该是这样的形式： ThreadLocalRandom.current().nextX(...) （其中X是Int ， Long等）。 当所有用法都是这种形式时，绝对不可能跨多个线程共享一个ThreadLocalRandom 。

    该类还提供了其他常用的有界随机生成方法。

    ThreadLocalRandom实例不是加密安全的。 考虑在安全敏感的应用程序中使用SecureRandom 。 此外，除非默认构造的情况下，不使用加密的随机种子system property java.util.secureRandomSeed设置为true 。

    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static ThreadLocalRandom current​()
      返回当前线程的 ThreadLocalRandom 。
      DoubleStream doubles​()
      返回一个有效的无限流的伪随机数 double值，每个值在零（包括）和一（独占）之间。
      DoubleStream doubles​(double randomNumberOrigin, double randomNumberBound)
      返回一个有效的无限流的伪随机数 double值，每个符合给定的起始（包括）和绑定（排他）。
      DoubleStream doubles​(long streamSize)
      返回一个流，产生给定的 streamSize伪随机数 double数值，每个值在零（包括）和一（独占）之间。
      DoubleStream doubles​(long streamSize, double randomNumberOrigin, double randomNumberBound)
      返回一个流，产生给定的 streamSize伪随机数 double值，每个值符合给定的起始（包括）和绑定（排他）。
      IntStream ints​()
      返回一个有效的无限流的伪随机数 int值。
      IntStream ints​(int randomNumberOrigin, int randomNumberBound)
      返回一个有效无限流的伪随机数 int ，每个值都符合给定的起始（包括）和绑定（排除）。
      IntStream ints​(long streamSize)
      返回一个流，产生给定的 streamSize数量的伪随机数 int值。
      IntStream ints​(long streamSize, int randomNumberOrigin, int randomNumberBound)
      返回一个流，产生给定的 streamSize数量的伪随机数 int值，每个符合给定的起始（包括）和绑定（排他）。
      LongStream longs​()
      返回一个有效的无限流的伪随机数 long值。
      LongStream longs​(long streamSize)
      返回一个流，产生给定的 streamSize数量的伪随机数 long值。
      LongStream longs​(long randomNumberOrigin, long randomNumberBound)
      返回一个有效的无限流的伪随机数 long值，每个符合给定的起始（包括）和绑定（排他）。
      LongStream longs​(long streamSize, long randomNumberOrigin, long randomNumberBound)
      返回产生所述给定流 streamSize数的伪随机的 long ，每个符合给定的原点（含）和结合（不包括）。
      protected int next​(int bits)
      生成带有指定数量的低位位的伪随机数。
      boolean nextBoolean​()
      返回一个伪随机值 boolean 。
      double nextDouble​()
      返回0（包括）和1（排除）之间的伪随机值 double 。
      double nextDouble​(double bound)
      返回值在0.0（含）之间的伪随机数 double和指定的约束（排除）之间。
      double nextDouble​(double origin, double bound)
      返回指定原点（包括）和绑定（排除）之间的伪随机值 double 。
      float nextFloat​()
      返回在零（包括）和一（独占）之间的伪随机 float值。
      double nextGaussian​()
      从该随机数发生器的序列返回下一个伪随机，高斯（“正”）分布的 double值，平均值为 0.0 ，标准偏差为 1.0 。
      int nextInt​()
      返回一个伪随机值 int 。
      int nextInt​(int bound)
      返回零（含）和指定边界（排除）之间的伪随机值 int 。
      int nextInt​(int origin, int bound)
      返回指定的起始（含）和指定的界限（排除）之间的伪随机值 int 。
      long nextLong​()
      返回一个伪随机数 long值。
      long nextLong​(long bound)
      返回0（包括）和指定的bound（exclusive）之间的伪随机值 long 。
      long nextLong​(long origin, long bound)
      返回指定原点（含）和指定边界（独占）之间的伪随机数 long值。
      void setSeed​(long seed)
      投掷 UnsupportedOperationException 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.Random

        nextBytes

    • 方法详细信息

      • current

        public static ThreadLocalRandom current​()
        返回当前线程的 ThreadLocalRandom 。
        结果
        当前线程的 ThreadLocalRandom

      • setSeed

        public void setSeed​(long seed)
        投掷UnsupportedOperationException 。 不支持在此生成器中设置种子。
        重写：
        setSeed在 Random
        参数
        seed - 初始种子
        异常
        UnsupportedOperationException - 永远

      • next

        protected int next​(int bits)
        生成带有指定数量的低位位的伪随机数。 因为此类没有子类，所以无法调用或覆盖此方法。
        重写：
        next在 Random
        参数
        bits - 随机位
        结果
        来自该随机数发生器序列的下一个伪随机值

      • nextInt

        public int nextInt​()
        返回一个伪随机数 int值。
        重写：
        nextInt在 Random
        结果
        一个伪随机的价值 int

      • nextInt

        public int nextInt​(int bound)
        返回零（含）和指定边界（排除）之间的伪随机值 int 。
        重写：
        nextInt在 Random
        参数
        bound - 上限（独占）。 必须是积极的。
        结果
        零（包括）和绑定（独占）之间的伪随机值 int
        异常
        IllegalArgumentException - 如果 bound

      • nextInt

        public int nextInt​(int origin,
                   int bound)
        返回指定原点（含）和指定边界（排除）之间的伪随机值 int 。
        参数
        origin - 返回的值最小
        bound - 上限（独占）
        结果
        原始（含）和绑定（排他性）之间的伪随机 int值
        异常
        IllegalArgumentException - 如果 origin大于或等于 bound

      • nextLong

        public long nextLong​()
        返回一个伪随机值 long 。
        重写：
        nextLong在 Random
        结果
        一个伪随机数 long

      • nextLong

        public long nextLong​(long bound)
        返回0（包括）和指定的bound（exclusive）之间的伪随机值 long 。
        参数
        bound - 上限（独占）。 必须是积极的。
        结果
        一个伪随机 long （ long在零（包括）和绑定（排除）之间的值
        异常
        IllegalArgumentException - 如果 bound

      • nextLong

        public long nextLong​(long origin,
                     long bound)
        返回指定的起始点（含）和指定的边界（排除）之间的伪随机值 long 。
        参数
        origin - 返回的值最小
        bound - 上限（独占）
        结果
        原始（含）和绑定（排他性）之间的伪随机 long值
        异常
        IllegalArgumentException - 如果 origin大于或等于 bound

      • nextDouble

        public double nextDouble​()
        返回0（包括）和1（独占）之间的伪随机值 double 。
        重写：
        nextDouble在 Random
        结果
        零（含）和一（独占）之间的伪随机 double值
        另请参见：
        Math.random()

      • nextDouble

        public double nextDouble​(double bound)
        返回值在0.0（含）和指定的约束（排除）之间的伪随机数 double 。
        参数
        bound - 上限（独占）。 必须是积极的。
        结果
        零（包括）和绑定（排他性）之间的伪随机 double值
        异常
        IllegalArgumentException - 如果 bound

      • nextDouble

        public double nextDouble​(double origin,
                         double bound)
        返回指定的起始（含）和绑定（排除）之间的伪随机值 double 。
        参数
        origin - 返回的最小值
        bound - 上限（独占）
        结果
        原始（含）和限制（排除）之间的伪随机值 double
        异常
        IllegalArgumentException - 如果 origin大于或等于 bound

      • nextBoolean

        public boolean nextBoolean​()
        返回一个伪随机值 boolean 。
        重写：
        nextBoolean在 Random
        结果
        一个伪随机数 boolean

      • nextFloat

        public float nextFloat​()
        返回零（含）和一（独占）之间的伪随机数 float 。
        重写：
        nextFloat在 Random
        结果
        零（包括）和一（独占）之间的伪随机 float值

      • nextGaussian

        public double nextGaussian​()
        描述从类别复制Random
        从该随机数发生器的序列返回下一个伪随机，高斯（“正”）分布的double值，平均值为0.0 ，标准差为1.0 。

        nextGaussian的一般合同是从（大约）平均0.0和标准差1.0的常规正态分布中选出的一个double值被伪随机生成并返回。

        方法nextGaussian由类Random实现，如同通过以下的线程安全版本一样：

           private double nextNextGaussian; private boolean haveNextNextGaussian = false; public double nextGaussian() { if (haveNextNextGaussian) { haveNextNextGaussian = false; return nextNextGaussian; } else { double v1, v2, s; do { v1 = 2 * nextDouble() - 1; // between -1.0 and 1.0 v2 = 2 * nextDouble() - 1; // between -1.0 and 1.0 s = v1 * v1 + v2 * v2; } while (s >= 1 || s == 0); double multiplier = StrictMath.sqrt(-2 * StrictMath.log(s)/s); nextNextGaussian = v2 * multiplier; haveNextNextGaussian = true; return v1 * multiplier; } }
        这使用GEP Box，ME Muller和G. Marsaglia的极性方法 ，如Donald E. Knuth在“计算机编程艺术”第2卷： Seminumerical Algorithms ，第3.4.1节，C节，算法P中所述。请注意它产生两个独立的值，其代价是只有一个呼叫为StrictMath.log ，一个呼叫为StrictMath.sqrt 。
        重写：
        nextGaussian在 Random
        结果
        下一个伪随机数，高斯（“正常”）分布 double值，平均值为 0.0 ，标准偏差为 1.0来自该随机数发生器的序列

      • ints

        public IntStream ints​(long streamSize)
        返回一个流，产生给定的 streamSize伪随机数 int值。
        重写：
        ints在 Random
        参数
        streamSize - 要生成的值的数量
        结果
        一串伪随机数 int
        异常
        IllegalArgumentException - 如果 streamSize小于零
        从以下版本开始：
        1.8

      • ints

        public IntStream ints​()
        返回一个有效的无限流的伪随机数 int值。
        重写：
        ints在 Random
        Implementation Note:
        该方法实现为等同于 ints(Long.MAX_VALUE) 。
        结果
        一串伪随机的数值 int
        从以下版本开始：
        1.8

      • ints

        public IntStream ints​(long streamSize,
                      int randomNumberOrigin,
                      int randomNumberBound)
        返回一个流，产生给定的 streamSize伪随机数 int值，每个值符合给定的起始（包括）和绑定（排他）。
        重写：
        ints在 Random
        参数
        streamSize - 要生成的值的数量
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数 int值，每个具有给定的起始（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 streamSize小于零，或 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • ints

        public IntStream ints​(int randomNumberOrigin,
                      int randomNumberBound)
        返回一个有效无限流的伪随机数 int值，每个符合给定的起始（包括）和绑定（排他）。
        重写：
        ints在 Random
        Implementation Note:
        该方法实现等同于 ints(Long.MAX_VALUE, randomNumberOrigin, randomNumberBound) 。
        参数
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机 int ， int ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • longs

        public LongStream longs​(long streamSize)
        返回一个流，产生给定的 streamSize伪随机数 long数值。
        重写：
        longs在 Random
        参数
        streamSize - 要生成的值的数量
        结果
        一串伪随机数 long
        异常
        IllegalArgumentException - 如果 streamSize小于零
        从以下版本开始：
        1.8

      • longs

        public LongStream longs​()
        返回一个有效的无限流的伪随机数 long值。
        重写：
        longs在 Random
        Implementation Note:
        该方法实现为等同于 longs(Long.MAX_VALUE) 。
        结果
        一串伪随机的数值 long
        从以下版本开始：
        1.8

      • longs

        public LongStream longs​(long streamSize,
                        long randomNumberOrigin,
                        long randomNumberBound)
        返回一个流，产生给定的 streamSize伪随机数 long ，每个符合给定的起始（包括）和绑定（排他）。
        重写：
        longs在 Random
        参数
        streamSize - 要生成的值的数量
        randomNumberOrigin - 每个随机值的起始（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机的 long ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 streamSize小于零，或 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • longs

        public LongStream longs​(long randomNumberOrigin,
                        long randomNumberBound)
        返回一个有效的无限流的伪随机数 long值，每个符合给定的起始（包括）和绑定（排他）。
        重写：
        longs在 Random
        Implementation Note:
        该方法实现为等同于 longs(Long.MAX_VALUE, randomNumberOrigin, randomNumberBound) 。
        参数
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数 long ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • doubles

        public DoubleStream doubles​(long streamSize)
        返回一个流，产生给定的 streamSize数量的伪随机数 double值，每个值在零（包括）和一（独占）之间。
        重写：
        doubles在 Random
        参数
        streamSize - 要生成的值的数量
        结果
        一串 double值
        异常
        IllegalArgumentException - 如果 streamSize小于零
        从以下版本开始：
        1.8

      • doubles

        public DoubleStream doubles​()
        返回一个有效的无限流伪随机数 double值，每个值在零（包括）和一（独占）之间。
        重写：
        doubles在 Random
        Implementation Note:
        该方法实现等于 doubles(Long.MAX_VALUE) 。
        结果
        一串伪随机的数值 double
        从以下版本开始：
        1.8

      • doubles

        public DoubleStream doubles​(long streamSize,
                            double randomNumberOrigin,
                            double randomNumberBound)
        返回一个流，产生给定的 streamSize伪随机数 double值，每个值符合给定的起始（包括）和绑定（排他）。
        重写：
        doubles在 Random
        参数
        streamSize - 要生成的值的数量
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数（ double ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 streamSize小于零，或 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8

      • doubles

        public DoubleStream doubles​(double randomNumberOrigin,
                            double randomNumberBound)
        返回一个有效的无限流的伪随机数 double ，每个符合给定的起始（包括）和绑定（排他）。
        重写：
        doubles在 Random
        Implementation Note:
        该方法实现为等同于 doubles(Long.MAX_VALUE, randomNumberOrigin, randomNumberBound) 。
        参数
        randomNumberOrigin - 每个随机值的起点（含）
        randomNumberBound - 每个随机值的绑定（排他）
        结果
        一个伪随机数 double ，每个都有给定的来源（包括）和绑定（排他）
        异常
        IllegalArgumentException - 如果 randomNumberOrigin大于或等于 randomNumberBound
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ThreadPoolExecutor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ThreadPoolExecutor

  • java.lang.Object
    • java.util.concurrent.AbstractExecutorService
      • java.util.concurrent.ThreadPoolExecutor
  • All Implemented Interfaces:
    Executor ， ExecutorService
    已知直接子类：
    ScheduledThreadPoolExecutor

    public class ThreadPoolExecutor
extends AbstractExecutorService
    一个ExecutorService ，使用可能的几个合并的线程之一执行每个提交的任务，通常使用Executors工厂方法配置。

    线程池解决两个不同的问题：由于每个任务的调用开销减少，它们通常在执行大量异步任务时提供改进的性能，并且它们提供了一种限制和管理资源（包括执行一个任务。 每个ThreadPoolExecutor还维护一些基本的统计信息，例如已完成任务的数量。

    为了在广泛的上下文中有用，此类提供了许多可调参数和可扩展性钩子。 但是，程序员被迫使用更方便的Executors工厂方法Executors.newCachedThreadPool() （无限线程池，具有自动线程回收）， Executors.newFixedThreadPool(int) （固定大小的线程池）和Executors.newSingleThreadExecutor() （单个后台线程），为最常用的使用场景进行预配置设置。 否则，手动配置和调优此类时，请使用以下指南：

    核心和最大池大小
    甲ThreadPoolExecutor将自动调整池大小（见getPoolSize()根据corePoolSize（参见设定的界限） getCorePoolSize() ）和maximumPoolSize（参见getMaximumPoolSize() ）。 当方法execute(Runnable)中提交了新任务，并且运行的corePoolSize线程少于一个，即使其他工作线程处于空闲状态，也会创建一个新的线程来处理该请求。 如果超过corePoolSize但小于maximumPoolSize线程运行，则仅当队列已满时才会创建一个新线程。 通过将corePoolSize和maximumPoolSize设置为相同，您将创建一个固定大小的线程池。 通过将Integer.MAX_VALUE设置为本质上无限制的值（如Integer.MAX_VALUE ，您可以允许池容纳任意数量的并发任务。 最典型的情况是，核心和最大池大小只能在构建时进行设置，但也可以使用setCorePoolSize(int)和setMaximumPoolSize(int)动态更改池大小。
    按需施工
    默认情况下，即使核心线程最初是创建的，只有在新任务到达时才启动，但这可以使用方法prestartCoreThread()或prestartAllCoreThreads()动态地覆盖。 如果您使用非空队列构建池，则可能需要预先提供线程。
    创建新线程
    新线程使用ThreadFactory创建。 如果没有另外指定，则使用一个Executors.defaultThreadFactory() ，它创建所有线程都处于相同的ThreadGroup中 ，具有相同的优先级和非守护进程状态NORM_PRIORITY 。 通过提供不同的ThreadFactory，您可以更改线程的名称，线程组，优先级，守护程序状态等。如果ThreadFactory在通过从newThread返回null请求时无法创建线程，则执行程序将继续，但可能无法执行任务 线程应该拥有“modifyThread” RuntimePermission 。 如果使用池的工作线程或其他线程不具有此权限，则服务可能会降级：配置更改可能无法及时生效，并且关闭池可能仍处于可能终止但未完成的状态。
    活着的时代
    如果池当前具有多于corePoolSize线程，则如果多余的线程已经空闲超过keepAliveTime（见getKeepAliveTime(TimeUnit) ），那么多余线程将被终止。 这提供了当池未被主动使用时减少资源消耗的方法。 如果稍后池变得更加活跃，将构建新的线程。 该参数也可以使用方法setKeepAliveTime(long, TimeUnit)动态更改。 使用值Long.MAX_VALUE TimeUnit.NANOSECONDS有效地禁用空闲线程在关闭之前终止。 默认情况下，只有当存在多于corePoolSize线程的情况下，保持活动策略才适用，但是如果keepAliveTime值不为零，则可以使用方法allowCoreThreadTimeOut(boolean)将此超时策略应用于核心线程。
    排队
    任何BlockingQueue可用于传输和保留提交的任务。 这个队列的使用与池大小相互作用：
    • 如果少于corePoolSize线程正在运行，Executor总是喜欢添加一个新线程，而不是排队。
    • 如果corePoolSize或更多的线程正在运行，Executor总是喜欢排队请求而不是添加一个新的线程。
    • 如果请求无法排队，则会创建一个新线程，除非这将超过maximumPoolSize，否则任务将被拒绝。
    排队有三种一般策略：
    1. 直接切换 一个工作队列的一个很好的默认选择是一个SynchronousQueue ，它将任务交给线程，而不用其他任务。 在这里，如果没有线程可以立即运行，那么尝试排队任务会失败，因此将构建一个新的线程。 处理可能具有内部依赖关系的请求集时，此策略可避免锁定。 直接切换通常需要无限制的maximumPoolSizes，以避免拒绝新提交的任务。 这反过来允许无限线程增长的可能性，当命令继续以平均速度比他们可以处理的速度更快地到达时。
    2. 无界队列 当所有corePoolSize线程都忙时，使用无界队列（例如没有预定义容量的LinkedBlockingQueue ）将导致新任务在队列中等待。 因此，不会再创建corePoolSize线程。 （因此，最大值大小的值没有任何影响。）每个任务完全独立于其他任务时，这可能是适当的，因此任务不会影响其他执行; 例如，在网页服务器中。 虽然这种排队风格可以有助于平滑瞬态突发的请求，但是当命令继续达到的平均速度比可以处理的速度更快时，它承认无界工作队列增长的可能性。
    3. 有边界的队列。 有限队列（例如， ArrayBlockingQueue ）有助于防止在使用有限maxPoolSizes时耗尽资源，但可能更难调整和控制。 队列大小和最大池大小可能彼此交易：使用大队列和小型池可以最大限度地减少CPU使用率，OS资源和上下文切换开销，但可能导致人为的低吞吐量。 如果任务频繁阻塞（例如，如果它们是I / O绑定），则系统可能能够安排比您允许的更多线程的时间。 使用小型队列通常需要较大的池大小，这样可以使CPU繁忙，但可能会遇到不可接受的调度开销，这也降低了吞吐量。
    被拒绝的任务
    方法execute(Runnable)中提交的新任务将在执行程序关闭时被拒绝 ，并且当执行程序对最大线程和工作队列容量都使用有限边界并且饱和时。 在这两种情况下， execute方法调用其RejectedExecutionHandler的RejectedExecutionHandler.rejectedExecution(Runnable, ThreadPoolExecutor)方法。 提供四个预定义的处理程序策略
    1. 在默认的ThreadPoolExecutor.AbortPolicy中 ，处理程序在拒绝时抛出一个运行时RejectedExecutionException 。
    2. 在ThreadPoolExecutor.CallerRunsPolicy中 ，调用execute本身的线程运行该任务。 这提供了一个简单的反馈控制机制，将降低新任务提交的速度。
    3. 在ThreadPoolExecutor.DiscardPolicy中 ，无法执行的任务简单删除。
    4. 在ThreadPoolExecutor.DiscardOldestPolicy中 ，如果执行程序没有关闭，则工作队列头部的任务被删除，然后重试执行（可能会再次失败，导致重复）。
    可以定义和使用其他类型的RejectedExecutionHandler类。 这样做需要特别注意，特别是当策略被设计为仅在特定容量或排队策略下工作时。
    钩子方法
    该类提供了在每个任务执行之前和之后调用的protected可覆盖的beforeExecute(Thread, Runnable)和afterExecute(Runnable, Throwable)方法。 这些可以用来操纵执行环境; 例如，重新初始化ThreadLocals，收集统计信息或添加日志条目。 另外，方法terminated()可以被覆盖，以执行执行者完全终止后需要执行的任何特殊处理。

    如果钩子，回调或BlockingQueue方法抛出异常，内部工作线程可能会失败，突然终止，并可能被替换。

    队列维护
    方法getQueue()允许访问工作队列以进行监视和调试。 强烈不鼓励将此方法用于任何其他目的。 两个提供的方法， remove(Runnable)和purge()可用于在大量排队任务被取消时协助进行存储回收。
    定稿
    即不再在程序中引用， 并没有剩余的线程将成为池shutdown自动。 如果您希望确保未引用的池被回收，即使用户忘记调用shutdown() ，则必须通过使用零个核心线程的下限和/或设置allowCoreThreadTimeOut(boolean)设置适当的保持活动时间来排除未使用的线程。 。

    扩展示例 。 这个类的大部分扩展覆盖了一个或多个受保护的钩子方法。 例如，这里是一个添加一个简单的暂停/恢复功能的子类：

       class PausableThreadPoolExecutor extends ThreadPoolExecutor { private boolean isPaused; private ReentrantLock pauseLock = new ReentrantLock(); private Condition unpaused = pauseLock.newCondition(); public PausableThreadPoolExecutor(...) { super(...); } protected void beforeExecute(Thread t, Runnable r) { super.beforeExecute(t, r); pauseLock.lock(); try { while (isPaused) unpaused.await(); } catch (InterruptedException ie) { t.interrupt(); } finally { pauseLock.unlock(); } } public void pause() { pauseLock.lock(); try { isPaused = true; } finally { pauseLock.unlock(); } } public void resume() { pauseLock.lock(); try { isPaused = false; unpaused.signalAll(); } finally { pauseLock.unlock(); } } }
    从以下版本开始：
    1.5

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ThreadPoolExecutor.AbortPolicy
      一个抛出 RejectedExecutionException被拒绝任务的处理程序。
      static class  ThreadPoolExecutor.CallerRunsPolicy
      被拒绝的任务的处理程序直接在 execute方法的调用线程中运行被拒绝的任务，除非执行程序已经被关闭，否则这个任务被丢弃。
      static class  ThreadPoolExecutor.DiscardOldestPolicy
      被拒绝的任务的处理程序，丢弃最旧的未处理请求，然后重试 execute ，除非执行程序关闭，否则任务被丢弃。
      static class  ThreadPoolExecutor.DiscardPolicy
      被拒绝的任务的处理程序静默地丢弃被拒绝的任务。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂和拒绝的执行处理程序。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
      使用给定的初始参数和默认拒绝的执行处理程序创建一个新的 ThreadPoolExecutor 。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
      用给定的初始参数创建一个新的 ThreadPoolExecutor 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      protected void afterExecute​(Runnable r, Throwable t)
      完成指定Runnable的执行后调用方法。
      void allowCoreThreadTimeOut​(boolean value)
      设置策略是否核心线程可能会超时，如果任务没有在活着的时间内到达，则在新任务到达时被替换。
      boolean allowsCoreThreadTimeOut​()
      如果此池允许核心线程超时并终止，如果没有任务在keepAlive时间内到达，则返回true，如果新任务到达时需要更换。
      boolean awaitTermination​(long timeout, TimeUnit unit)
      阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
      protected void beforeExecute​(Thread t, Runnable r)
      在给定的线程中执行给定的Runnable之前调用方法。
      void execute​(Runnable command)
      在将来某个时候执行给定的任务。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      int getActiveCount​()
      返回正在执行任务的线程的大概数量。
      long getCompletedTaskCount​()
      返回完成执行的任务的大致总数。
      int getCorePoolSize​()
      返回核心线程数。
      long getKeepAliveTime​(TimeUnit unit)
      返回线程保持活动时间，这是线程在终止之前可能保持空闲的时间量。
      int getLargestPoolSize​()
      返回在池中同时进行的最大线程数。
      int getMaximumPoolSize​()
      返回允许的最大线程数。
      int getPoolSize​()
      返回池中当前的线程数。
      BlockingQueue<Runnable> getQueue​()
      返回此执行程序使用的任务队列。
      RejectedExecutionHandler getRejectedExecutionHandler​()
      返回不可执行任务的当前处理程序。
      long getTaskCount​()
      返回计划执行的任务的大概总数。
      ThreadFactory getThreadFactory​()
      返回用于创建新线程的线程工厂。
      boolean isShutdown​()
      如果此执行者已关闭，则返回 true 。
      boolean isTerminated​()
      如果所有任务在关闭后完成，则返回 true 。
      boolean isTerminating​()
      如果此执行者正在终止 shutdown()或 shutdownNow()但尚未完全终止，则返回true。
      int prestartAllCoreThreads​()
      启动所有核心线程，导致他们等待工作。
      boolean prestartCoreThread​()
      启动核心线程，使其无法等待工作。
      void purge​()
      尝试从工作队列中删除已取消的所有Future任务。
      boolean remove​(Runnable task)
      如果此任务存在，则从执行程序的内部队列中删除此任务，从而导致该任务尚未运行。
      void setCorePoolSize​(int corePoolSize)
      设置核心线程数。
      void setKeepAliveTime​(long time, TimeUnit unit)
      设置线程保持活动时间，这是线程在终止之前可能保持空闲的时间量。
      void setMaximumPoolSize​(int maximumPoolSize)
      设置允许的最大线程数。
      void setRejectedExecutionHandler​(RejectedExecutionHandler handler)
      为不可执行的任务设置一个新的处理程序。
      void setThreadFactory​(ThreadFactory threadFactory)
      设置用于创建新线程的线程工厂。
      void shutdown​()
      启动有序关闭，其中先前提交的任务将被执行，但不会接受任何新任务。
      List<Runnable> shutdownNow​()
      尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。
      protected void terminated​()
      执行程序已终止时调用方法。
      String toString​()
      返回标识此池的字符串及其状态，包括运行状态和估计的工作人员和任务计数的指示。

      • Methods inherited from class java.util.concurrent.AbstractExecutorService

        invokeAll, invokeAll, invokeAny, invokeAny, newTaskFor, newTaskFor, submit, submit, submit

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ThreadPoolExecutor

        public ThreadPoolExecutor​(int corePoolSize,
                          int maximumPoolSize,
                          long keepAliveTime,
                          TimeUnit unit,
                          BlockingQueue<Runnable> workQueue)
        创建一个新的ThreadPoolExecutor与给定的初始参数和默认线程工厂和拒绝的执行处理程序。 使用Executors工厂方法之一而不是这种通用构造函数可能会更方便。
        参数
        corePoolSize - 要保留在池中的线程数，即使它们处于空闲状态，除非设置了 allowCoreThreadTimeOut
        maximumPoolSize - 池中允许的最大线程数
        keepAliveTime - 当线程数大于核心时，这是多余的空闲线程在终止之前等待新任务的最大时间。
        unit - keepAliveTime参数的时间单位
        workQueue - 在执行任务之前用于保存任务的队列。 这个队列只能容纳execute方法提交的Runnable任务。
        异常
        IllegalArgumentException - 如果以下 IllegalArgumentException成立：
        corePoolSize < 0
        keepAliveTime < 0
        maximumPoolSize <= 0
        maximumPoolSize < corePoolSize
        NullPointerException - 如果 workQueue为空

      • ThreadPoolExecutor

        public ThreadPoolExecutor​(int corePoolSize,
                          int maximumPoolSize,
                          long keepAliveTime,
                          TimeUnit unit,
                          BlockingQueue<Runnable> workQueue,
                          ThreadFactory threadFactory)
        创建一个新的 ThreadPoolExecutor与给定的初始参数和默认拒绝执行处理程序。
        参数
        corePoolSize - 要保留在池中的线程数，即使它们处于空闲状态，除非设置了 allowCoreThreadTimeOut
        maximumPoolSize - 池中允许的最大线程数
        keepAliveTime - 当线程数大于核心时，这是多余的空闲线程在终止之前等待新任务的最大时间。
        unit - keepAliveTime参数的时间单位
        workQueue - 在执行任务之前用于保存任务的队列。 该队列将仅Runnable execute方法提交的Runnable任务。
        threadFactory - 在执行程序创建新线程时使用的工厂
        异常
        IllegalArgumentException - 如果以下 IllegalArgumentException成立：
        corePoolSize < 0
        keepAliveTime < 0
        maximumPoolSize <= 0
        maximumPoolSize < corePoolSize
        NullPointerException - 如果 workQueue或 threadFactory为空

      • ThreadPoolExecutor

        public ThreadPoolExecutor​(int corePoolSize,
                          int maximumPoolSize,
                          long keepAliveTime,
                          TimeUnit unit,
                          BlockingQueue<Runnable> workQueue,
                          RejectedExecutionHandler handler)
        创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂。
        参数
        corePoolSize - 要保留在池中的线程数，即使它们处于空闲状态，除非设置了 allowCoreThreadTimeOut
        maximumPoolSize - 池中允许的最大线程数
        keepAliveTime - 当线程数大于核心时，这是多余的空闲线程在终止之前等待新任务的最大时间。
        unit - keepAliveTime参数的时间单位
        workQueue - 在执行任务之前用于保存任务的队列。 这个队列只能容纳execute方法提交的Runnable任务。
        handler - 执行被阻止时使用的处理程序，因为达到线程限制和队列容量
        异常
        IllegalArgumentException - 如果以下任一条件成立：
        corePoolSize < 0
        keepAliveTime < 0
        maximumPoolSize <= 0
        maximumPoolSize < corePoolSize
        NullPointerException - 如果 workQueue或 handler为空

      • ThreadPoolExecutor

        public ThreadPoolExecutor​(int corePoolSize,
                          int maximumPoolSize,
                          long keepAliveTime,
                          TimeUnit unit,
                          BlockingQueue<Runnable> workQueue,
                          ThreadFactory threadFactory,
                          RejectedExecutionHandler handler)
        用给定的初始参数创建一个新的 ThreadPoolExecutor 。
        参数
        corePoolSize - 要保留在池中的线程数，即使它们处于空闲状态，除非设置了 allowCoreThreadTimeOut
        maximumPoolSize - 池中允许的最大线程数
        keepAliveTime - 当线程数大于核心时，这是多余的空闲线程在终止之前等待新任务的最大时间。
        unit - keepAliveTime参数的时间单位
        workQueue - 在执行任务之前用于保存任务的队列。 该队列将仅Runnable execute方法提交的Runnable任务。
        threadFactory - 当执行程序创建新线程时使用的工厂
        handler - 执行被阻止时使用的处理程序，因为达到线程限制和队列容量
        异常
        IllegalArgumentException - 如果以下条件之一成立：
        corePoolSize < 0
        keepAliveTime < 0
        maximumPoolSize <= 0
        maximumPoolSize < corePoolSize
        NullPointerException - 如果 workQueue或 threadFactory或 handler为null

    • 方法详细信息

      • execute

        public void execute​(Runnable command)
        在将来某个时候执行给定的任务。 任务可以在新线程或现有的合并的线程中执行。 如果该任务无法提交执行，由于此执行程序已关闭或已达到其容量，该任务将由当前的RejectedExecutionHandler处理。
        参数
        command - 要执行的任务
        异常
        RejectedExecutionException - 如果任务不能被接受执行， RejectedExecutionHandler决定
        NullPointerException - 如果 command为空

      • shutdown

        public void shutdown​()
        启动有序关闭，其中先前提交的任务将被执行，但不会接受任何新任务。 如果已经关闭，调用没有额外的作用。

        此方法不等待以前提交的任务完成执行。 使用awaitTermination做到这一点。

        异常
        SecurityException - 如果安全管理器存在并关闭，则ExecutorService可能会操纵调用者不允许修改的线程，因为它不保留RuntimePermission ("modifyThread")或安全管理器的checkAccess方法拒绝访问。

      • shutdownNow

        public List<Runnable> shutdownNow​()
        尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。 从此方法返回时，这些任务将从任务队列中排除（删除）。

        此方法不等待主动执行的任务终止。 使用awaitTermination来做到这一点。

        除了努力尝试停止处理积极执行任务之外，没有任何保证。 该实现通过Thread.interrupt()中断任务; 任何不能响应中断的任务都可能永远不会终止。

        结果
        从未开始执行的任务列表
        异常
        SecurityException - 如果安全管理器存在并关闭，则ExecutorService可能会操纵调用者不允许修改的线程，因为它不保留RuntimePermission ("modifyThread")或安全管理器的checkAccess方法拒绝访问。

      • isShutdown

        public boolean isShutdown​()
        描述从接口ExecutorService复制
        如果此执行者已关闭，则返回 true 。
        结果
        true如果这个执行者已被关闭

      • isTerminating

        public boolean isTerminating​()
        如果此执行者正在终止shutdown()或shutdownNow()但尚未完全终止，则返回true。 此方法可能对调试有用。 返回true报告了关机后的足够的时间可能表明提交的任务已经忽略或抑制中断，导致执行者不能正常终止。
        结果
        true如果终止但尚未终止

      • isTerminated

        public boolean isTerminated​()
        说明从界面ExecutorService复制
        如果所有任务在关闭后完成，则返回true 。 请注意， isTerminated从不是true除非首先调用了shutdown或shutdownNow 。
        结果
        true如果所有任务在关闭后都已完成

      • awaitTermination

        public boolean awaitTermination​(long timeout,
                                TimeUnit unit)
                         throws InterruptedException
        描述从接口ExecutorService复制
        阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
        参数
        timeout - 等待的最长时间
        unit - 超时参数的时间单位
        结果
        true如果这个执行者终止了，并且终止之前超时的时间是 false
        异常
        InterruptedException - 如果在等待时中断

      • finalize

        @Deprecated(since="9")
protected void finalize​()
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        当这个执行器不再被引用并且没有线程时，调用 shutdown 。
        重写：
        finalize在 Object
        另请参见：
        WeakReference ， PhantomReference

      • setThreadFactory

        public void setThreadFactory​(ThreadFactory threadFactory)
        设置用于创建新线程的线程工厂。
        参数
        threadFactory - 新线工厂
        异常
        NullPointerException - 如果threadFactory为null
        另请参见：
        getThreadFactory()

      • getThreadFactory

        public ThreadFactory getThreadFactory​()
        返回用于创建新线程的线程工厂。
        结果
        当前线程工厂
        另请参见：
        setThreadFactory(ThreadFactory)

      • setRejectedExecutionHandler

        public void setRejectedExecutionHandler​(RejectedExecutionHandler handler)
        为不可执行的任务设置一个新的处理程序。
        参数
        handler - 新的处理程序
        异常
        NullPointerException - 如果处理程序为空
        另请参见：
        getRejectedExecutionHandler()

      • getRejectedExecutionHandler

        public RejectedExecutionHandler getRejectedExecutionHandler​()
        返回不可执行任务的当前处理程序。
        结果
        当前处理程序
        另请参见：
        setRejectedExecutionHandler(RejectedExecutionHandler)

      • setCorePoolSize

        public void setCorePoolSize​(int corePoolSize)
        设置核心线程数。 这将覆盖在构造函数中设置的任何值。 如果新值小于当前值，则过多的现有线程在下一个空闲时将被终止。 如果更大，则如果需要，新线程将被启动以执行任何排队的任务。
        参数
        corePoolSize - 新的核心大小
        异常
        IllegalArgumentException - 如果 corePoolSize < 0或 corePoolSize大于 maximum pool size
        另请参见：
        getCorePoolSize()

      • getCorePoolSize

        public int getCorePoolSize​()
        返回核心线程数。
        结果
        核心线程数
        另请参见：
        setCorePoolSize(int)

      • prestartCoreThread

        public boolean prestartCoreThread​()
        启动核心线程，使其无法等待工作。 这将覆盖仅在执行新任务时启动核心线程的默认策略。 如果所有核心线程已经启动，此方法将返回false 。
        结果
        true如果一个线程启动

      • prestartAllCoreThreads

        public int prestartAllCoreThreads​()
        启动所有核心线程，导致他们等待工作。 这将覆盖仅在执行新任务时启动核心线程的默认策略。
        结果
        线程数已启动

      • allowsCoreThreadTimeOut

        public boolean allowsCoreThreadTimeOut​()
        如果此池允许核心线程超时并终止，如果没有任务在keepAlive时间内到达，则返回true，如果新任务到达时需要更换。 当为true时，应用于非核心线程的同样的保持活动策略也适用于核心线程。 当为false（默认值）时，由于缺少传入任务，核心线程不会终止。
        结果
        true如果核心线程允许超时，否则 false
        从以下版本开始：
        1.6

      • allowCoreThreadTimeOut

        public void allowCoreThreadTimeOut​(boolean value)
        设置策略是否核心线程可能会超时，如果任务没有在活着的时间内到达，则在新任务到达时被替换。 当虚假时，由于缺少传入任务，核心线程不会终止。 当为true时，应用于非核心线程的同样的保持活动策略也适用于核心线程。 为避免连续更换线程，设置true时，保持活动时间必须大于零。 这个方法一般应该在池被主动使用之前调用。
        参数
        value - true如果超时，否则为 false
        异常
        IllegalArgumentException - 如果值为 true ，并且当前保持活动时间不大于零
        从以下版本开始：
        1.6

      • setMaximumPoolSize

        public void setMaximumPoolSize​(int maximumPoolSize)
        设置允许的最大线程数。 这将覆盖在构造函数中设置的任何值。 如果新值小于当前值，则过多的现有线程在下一个空闲时将被终止。
        参数
        maximumPoolSize - 新的最大值
        异常
        IllegalArgumentException - 如果新的最大值小于或等于零，或小于 core pool size
        另请参见：
        getMaximumPoolSize()

      • getMaximumPoolSize

        public int getMaximumPoolSize​()
        返回允许的最大线程数。
        结果
        允许的最大线程数
        另请参见：
        setMaximumPoolSize(int)

      • setKeepAliveTime

        public void setKeepAliveTime​(long time,
                             TimeUnit unit)
        设置线程保持活动时间，这是线程在终止之前可能保持空闲的时间量。 如果存在超过当前在池中的线程核心数，或者如果此池allows core thread timeout ，则等待这段时间而不处理任务的线程将被终止。 这将覆盖在构造函数中设置的任何值。
        参数
        time - 等待的时间 时间值为零将导致多余的线程在执行任务后立即终止。
        unit - time参数的时间单位
        异常
        IllegalArgumentException - 如果 time小于零，或者如果 time为零， allowsCoreThreadTimeOut
        另请参见：
        getKeepAliveTime(TimeUnit)

      • getKeepAliveTime

        public long getKeepAliveTime​(TimeUnit unit)
        返回线程保持活动时间，这是线程在终止之前可能保持空闲的时间量。 如果存在超过当前在池中的线程数目的核心数量，或者如果此池allows core thread timeout ，那么等待这段时间而不处理任务的线程将被终止。
        参数
        unit - 结果所需的时间单位
        结果
        时间限制
        另请参见：
        setKeepAliveTime(long, TimeUnit)

      • getQueue

        public BlockingQueue<Runnable> getQueue​()
        返回此执行程序使用的任务队列。 访问任务队列主要用于调试和监视。 此队列可能正在使用中。 检索任务队列不会阻止排队的任务执行。
        结果
        任务队列

      • remove

        public boolean remove​(Runnable task)
        如果此任务存在，则从执行程序的内部队列中删除此任务，从而导致该任务尚未运行。

        该方法作为取消方案的一部分可能是有用的。 在放入内部队列之前，可能无法删除已转换为其他表单的任务。 例如，使用submit输入的任务可能会转换为维护Future状态的表单。 然而，在这种情况下，方法purge()可以用于去除已被取消的那些期货。

        参数
        task - 要删除的任务
        结果
        true如果任务被删除

      • purge

        public void purge​()
        尝试从工作队列中删除已取消的所有Future任务。 此方法可用作存储回收操作，对功能没有其他影响。 取消的任务永远不会执行，但可能会累积在工作队列中，直到工作线程可以主动删除它们。 现在调用此方法会尝试删除它。 但是，该方法可能无法在其他线程的干扰存在的情况下删除任务。

      • getPoolSize

        public int getPoolSize​()
        返回池中当前的线程数。
        结果
        线程数

      • getActiveCount

        public int getActiveCount​()
        返回正在执行任务的线程的大概数量。
        结果
        线程数

      • getLargestPoolSize

        public int getLargestPoolSize​()
        返回在池中同时进行的最大线程数。
        结果
        线程数

      • getTaskCount

        public long getTaskCount​()
        返回计划执行的任务的大概总数。 因为任务和线程的状态在计算过程中可能会动态地改变，所以返回的值只是一个近似值。
        结果
        任务数量

      • getCompletedTaskCount

        public long getCompletedTaskCount​()
        返回完成执行的任务的大致总数。 因为任务和线程的状态可能在计算过程中动态地改变，所以返回的值只是一个近似值，但是在连续的调用中并不会减少。
        结果
        任务数量

      • toString

        public String toString​()
        返回标识此池的字符串及其状态，包括运行状态和估计的工作人员和任务计数的指示。
        重写：
        toString在 Object
        结果
        一个标识这个池的字符串，以及它的状态

      • beforeExecute

        protected void beforeExecute​(Thread t,
                             Runnable r)
        在给定的线程中执行给定的Runnable之前调用方法。 该方法由线程t调用，该线程将执行任务r ，并可用于重新初始化ThreadLocals或执行日志记录。

        此实现不执行任何操作，但可以在子类中进行自定义。 注意：为了正确嵌套多个覆盖，子类应通常在此方法结束时调用super.beforeExecute 。

        参数
        t - 将运行任务的线程 r
        r - 将执行的任务

      • afterExecute

        protected void afterExecute​(Runnable r,
                            Throwable t)
        完成指定Runnable的执行后调用方法。 该方法由执行该任务的线程调用。 如果非空，则Throwable是未被捕获的RuntimeException或Error ，导致执行突然终止。

        此实现不执行任何操作，但可以在子类中进行自定义。 注意：为了正确嵌套多个覆盖，子类应该在此方法开始时调用super.afterExecute 。

        注意：当操作明确地包含在任务（如FutureTask ）中或通过诸如submit方法包含submit ，这些任务对象捕获并维护计算异常，因此不会导致突然终止，并且内部异常不会传递给此方法。 如果您希望在此方法中捕获两种故障，您可以进一步探测这种情况，如在此示例子类中，如果任务已中止，则会打印直接原因或底层异常：

           class ExtendedExecutor extends ThreadPoolExecutor { // ... protected void afterExecute(Runnable r, Throwable t) { super.afterExecute(r, t); if (t == null && r instanceof Future<?> && ((Future<?>)r).isDone()) { try { Object result = ((Future<?>) r).get(); } catch (CancellationException ce) { t = ce; } catch (ExecutionException ee) { t = ee.getCause(); } catch (InterruptedException ie) { // ignore/reset Thread.currentThread().interrupt(); } } if (t != null) System.out.println(t); } }
        参数
        r - 已完成的runnable
        t - 导致终止的异常，如果执行正常完成，则为null

      • terminated

        protected void terminated​()
        Method invoked when the Executor has terminated. Default implementation does nothing. Note: To properly nest multiple overridings, subclasses should generally invoke super.terminated within this method.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ThreadPoolExecutor.AbortPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ThreadPoolExecutor.AbortPolicy

  • java.lang.Object
    • java.util.concurrent.ThreadPoolExecutor.AbortPolicy
  • All Implemented Interfaces:
    RejectedExecutionHandler
    Enclosing class:
    ThreadPoolExecutor

    public static class ThreadPoolExecutor.AbortPolicy
extends Object
implements RejectedExecutionHandler
    一个抛出 RejectedExecutionException被拒绝任务的处理程序。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AbortPolicy​()
      创建一个 AbortPolicy 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      总是抛出RejectedExecutionException。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbortPolicy

        public AbortPolicy​()
        创建一个 AbortPolicy 。

    • 方法详细信息

      • rejectedExecution

        public void rejectedExecution​(Runnable r,
                              ThreadPoolExecutor e)
        总是抛出RejectedExecutionException。
        Specified by:
        rejectedExecution在接口 RejectedExecutionHandler
        参数
        r - 请求执行的可运行任务
        e - 执行程序尝试执行此任务
        异常
        RejectedExecutionException - 永远
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ThreadPoolExecutor.CallerRunsPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ThreadPoolExecutor.CallerRunsPolicy

  • java.lang.Object
    • java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy
  • All Implemented Interfaces:
    RejectedExecutionHandler
    Enclosing class:
    ThreadPoolExecutor

    public static class ThreadPoolExecutor.CallerRunsPolicy
extends Object
implements RejectedExecutionHandler
    一个被拒绝的任务的处理程序，直接在 execute方法的调用线程中运行被拒绝的任务，除非执行程序已经被关闭，在这种情况下，任务被丢弃。

    • 构造方法摘要

      构造方法
      Constructor 描述
      CallerRunsPolicy​()
      创建一个 CallerRunsPolicy 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      执行调用者线程中的任务r，除非执行程序已经被关闭，否则任务被丢弃。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CallerRunsPolicy

        public CallerRunsPolicy​()
        创建一个 CallerRunsPolicy 。

    • 方法详细信息

      • rejectedExecution

        public void rejectedExecution​(Runnable r,
                              ThreadPoolExecutor e)
        执行调用者线程中的任务r，除非执行程序已经被关闭，否则任务被丢弃。
        Specified by:
        rejectedExecution在接口 RejectedExecutionHandler
        参数
        r - 请求执行的可运行任务
        e - 执行器尝试执行此任务
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ThreadPoolExecutor.DiscardOldestPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ThreadPoolExecutor.DiscardOldestPolicy

  • java.lang.Object
    • java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy
  • All Implemented Interfaces:
    RejectedExecutionHandler
    Enclosing class:
    ThreadPoolExecutor

    public static class ThreadPoolExecutor.DiscardOldestPolicy
extends Object
implements RejectedExecutionHandler
    被拒绝的任务的处理程序，丢弃最旧的未处理请求，然后重试 execute ，除非执行程序被关闭，否则这个任务被丢弃。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DiscardOldestPolicy​()
      为给定的执行者创建一个 DiscardOldestPolicy 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      获取并忽略执行者否则将执行的下一个任务，如果一个可以立即可用，然后重试任务r的执行，除非执行程序关闭，否则任务r被替换为丢弃。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DiscardOldestPolicy

        public DiscardOldestPolicy​()
        为给定的执行者创建一个 DiscardOldestPolicy 。

    • 方法详细信息

      • rejectedExecution

        public void rejectedExecution​(Runnable r,
                              ThreadPoolExecutor e)
        获取并忽略执行者否则将执行的下一个任务，如果一个可以立即可用，然后重试任务r的执行，除非执行程序关闭，否则任务r被替换为丢弃。
        Specified by:
        rejectedExecution在接口 RejectedExecutionHandler
        参数
        r - 请求执行的可运行任务
        e - 执行者尝试执行此任务
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ThreadPoolExecutor.DiscardPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class ThreadPoolExecutor.DiscardPolicy

  • java.lang.Object
    • java.util.concurrent.ThreadPoolExecutor.DiscardPolicy
  • All Implemented Interfaces:
    RejectedExecutionHandler
    Enclosing class:
    ThreadPoolExecutor

    public static class ThreadPoolExecutor.DiscardPolicy
extends Object
implements RejectedExecutionHandler
    被拒绝的任务的处理程序静默地丢弃被拒绝的任务。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DiscardPolicy​()
      创建一个 DiscardPolicy 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      什么也没有，具有丢弃任务r的效果。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DiscardPolicy

        public DiscardPolicy​()
        创建一个 DiscardPolicy 。

    • 方法详细信息

      • rejectedExecution

        public void rejectedExecution​(Runnable r,
                              ThreadPoolExecutor e)
        什么也没有，具有丢弃任务r的效果。
        Specified by:
        rejectedExecution在接口 RejectedExecutionHandler
        参数
        r - 请求执行的可运行任务
        e - 执行程序尝试执行此任务
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Class TimeoutException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.util.concurrent.TimeoutException
  • All Implemented Interfaces:
    Serializable

    public class TimeoutException
extends 异常
    阻塞操作超时时抛出异常。 指定超时的阻止操作需要一种表示超时发生的方法。 对于许多这样的操作，可以返回一个指示超时的值; 当不可能或不可取的时候，应该声明并抛出TimeoutException 。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      TimeoutException​()
      构造一个没有指定详细消息的 TimeoutException 。
      TimeoutException​(String message)
      构造具有指定详细消息的 TimeoutException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • TimeoutException

        public TimeoutException​()
        构造一个 TimeoutException ，没有指定的详细信息。

      • TimeoutException

        public TimeoutException​(String message)
        构造具有指定详细消息的 TimeoutException 。
        参数
        message - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TimeUnit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.util.concurrent

Enum TimeUnit

  • java.lang.Object
    • java.lang.Enum<TimeUnit>
      • java.util.concurrent.TimeUnit
  • All Implemented Interfaces:
    Serializable ， Comparable<TimeUnit>

    public enum TimeUnit
extends Enum<TimeUnit>
    A TimeUnit表示给定的粒度单位的持续时间，并提供了跨单位转换的实用方法，并在这些单元中执行定时和延迟操作。 A TimeUnit不保留时间信息，但仅有助于组织和使用可能在各种上下文中单独维护的时间表示。 一纳秒定义为千分之一秒，微秒为千分之一毫秒，毫秒为千分之一秒，一分钟为六十秒，一小时为六十分钟，一天为二十四小时。

    A TimeUnit主要用于通知基于时间的方法如何解释给定的时序参数。 例如，如果lock不可用，以下代码将在50毫秒内超时：

       Lock lock = ...; if (lock.tryLock(50L, TimeUnit.MILLISECONDS)) ...
    而此代码将在50秒内超时：
       Lock lock = ...; if (lock.tryLock(50L, TimeUnit.SECONDS)) ...
    然而，请注意，不能保证特定的超时执行将能够以与给定的TimeUnit相同的粒度注意到时间的TimeUnit 。
    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DAYS
      时间单位代表二十四小时。
      HOURS
      时间单位代表六十分钟。
      MICROSECONDS
      时间单位代表千分之一毫秒。
      MILLISECONDS
      时间单位为千分之一秒。
      MINUTES
      时间单位代表60秒。
      NANOSECONDS
      时间单位代表千分之一千分之一。
      SECONDS
      时间单位代表一秒。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      long convert​(long sourceDuration, TimeUnit sourceUnit)
      将给定单位的给定持续时间转换为本机。
      static TimeUnit of​(ChronoUnit chronoUnit)
      将 ChronoUnit转换为等效的 TimeUnit 。
      void sleep​(long timeout)
      使用此时间单位执行 Thread.sleep 。
      void timedJoin​(Thread thread, long timeout)
      使用此时间单位执行定时 Thread.join 。
      void timedWait​(Object obj, long timeout)
      使用此时间单位执行定时 Object.wait 。
      ChronoUnit toChronoUnit​()
      将此 TimeUnit转换为等效的 ChronoUnit 。
      long toDays​(long duration)
      相当于 DAYS.convert(duration, this) 。
      long toHours​(long duration)
      相当于 HOURS.convert(duration, this) 。
      long toMicros​(long duration)
      相当于 MICROSECONDS.convert(duration, this) 。
      long toMillis​(long duration)
      相当于 MILLISECONDS.convert(duration, this) 。
      long toMinutes​(long duration)
      相当于 MINUTES.convert(duration, this) 。
      long toNanos​(long duration)
      相当于 NANOSECONDS.convert(duration, this) 。
      long toSeconds​(long duration)
      相当于 SECONDS.convert(duration, this) 。
      static TimeUnit valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TimeUnit[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NANOSECONDS

        public static final TimeUnit NANOSECONDS
        时间单位代表千分之一千分之一。

      • MICROSECONDS

        public static final TimeUnit MICROSECONDS
        时间单位代表千分之一毫秒。

      • MILLISECONDS

        public static final TimeUnit MILLISECONDS
        时间单位为千分之一秒。

      • SECONDS

        public static final TimeUnit SECONDS
        时间单位代表一秒。

      • MINUTES

        public static final TimeUnit MINUTES
        时间单位代表60秒。
        从以下版本开始：
        1.6

      • HOURS

        public static final TimeUnit HOURS
        时间单位代表六十分钟。
        从以下版本开始：
        1.6

      • DAYS

        public static final TimeUnit DAYS
        时间单位代表二十四小时。
        从以下版本开始：
        1.6

    • 方法详细信息

      • values

        public static TimeUnit[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TimeUnit c : TimeUnit.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TimeUnit valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null

      • convert

        public long convert​(long sourceDuration,
                    TimeUnit sourceUnit)
        将给定单位的给定持续时间转换为本机。 从更精细到更粗糙的粒度的转换截断，因此失去精度。 例如，将999毫秒转换为秒会导致0 。 从更粗糙到更细粒度的转换，数值溢出饱和的Long.MIN_VALUE如果为负， Long.MAX_VALUE如果为正值Long.MAX_VALUE 。

        例如，要将10分钟转换成毫秒，请使用： TimeUnit.MILLISECONDS.convert(10L, TimeUnit.MINUTES)

        参数
        sourceDuration - 给定的持续时间 sourceUnit
        sourceUnit - sourceDuration参数的单位
        结果
        该单位转换的持续时间，或 Long.MIN_VALUE如果转换将负面溢出，或 Long.MAX_VALUE如果它会积极的溢出。

      • toNanos

        public long toNanos​(long duration)
        相当于 NANOSECONDS.convert(duration, this) 。
        参数
        duration - 持续时间
        结果
        转换的持续时间，或 Long.MIN_VALUE如果转换将负面溢出，或 Long.MAX_VALUE如果它会积极溢出。

      • toMicros

        public long toMicros​(long duration)
        相当于 MICROSECONDS.convert(duration, this) 。
        参数
        duration - 持续时间
        结果
        转换的持续时间，或 Long.MIN_VALUE如果转换将负面溢出，或 Long.MAX_VALUE如果它会积极溢出。

      • toMillis

        public long toMillis​(long duration)
        相当于 MILLISECONDS.convert(duration, this) 。
        参数
        duration - 持续时间
        结果
        转换的持续时间，或 Long.MIN_VALUE如果转换将负面溢出，或 Long.MAX_VALUE如果它会积极的溢出。

      • toSeconds

        public long toSeconds​(long duration)
        相当于 SECONDS.convert(duration, this) 。
        参数
        duration - 持续时间
        结果
        转换的持续时间，或 Long.MIN_VALUE如果转换将负面溢出，或 Long.MAX_VALUE如果它会积极溢出。

      • toMinutes

        public long toMinutes​(long duration)
        相当于 MINUTES.convert(duration, this) 。
        参数
        duration - 持续时间
        结果
        转换的持续时间，或 Long.MIN_VALUE如果转换将负面溢出，或 Long.MAX_VALUE如果它会积极溢出。
        从以下版本开始：
        1.6

      • toHours

        public long toHours​(long duration)
        相当于 HOURS.convert(duration, this) 。
        参数
        duration - 持续时间
        结果
        转换的持续时间，或 Long.MIN_VALUE如果转换将负面溢出，或 Long.MAX_VALUE如果它会积极溢出。
        从以下版本开始：
        1.6

      • toDays

        public long toDays​(long duration)
        相当于 DAYS.convert(duration, this) 。
        参数
        duration - 持续时间
        结果
        转换的持续时间
        从以下版本开始：
        1.6

      • timedWait

        public void timedWait​(Object obj,
                      long timeout)
               throws InterruptedException
        使用此时间单位执行定时Object.wait 。 这是一个方便的方法，将超时参数转换为Object.wait方法所需的形式。

        例如，您可以使用以下方式实施阻止poll方法（请参阅BlockingQueue.poll ）

           public synchronized Object poll(long timeout, TimeUnit unit) throws InterruptedException { while (empty) { unit.timedWait(this, timeout); ... } }
        参数
        obj - 要等待的对象
        timeout - 等待的最长时间。 如果小于或等于零，不要等待。
        异常
        InterruptedException - 如果在等待时中断

      • timedJoin

        public void timedJoin​(Thread thread,
                      long timeout)
               throws InterruptedException
        使用此时间单位执行定时Thread.join 。 这是一种方便的方法，将时间参数转换为Thread.join方法所需的形式。
        参数
        thread - 等待的线程
        timeout - 等待的最长时间。 如果小于或等于零，不要等待。
        异常
        InterruptedException - 如果在等待时中断

      • sleep

        public void sleep​(long timeout)
           throws InterruptedException
        使用此时间单位执行Thread.sleep 。 这是一种方便的方法，将时间参数转换为Thread.sleep方法所需的形式。
        参数
        timeout - 睡眠时间最短 如果小于或等于零，不要睡觉。
        异常
        InterruptedException - 睡觉时中断

      • toChronoUnit

        public ChronoUnit toChronoUnit​()
        将此 TimeUnit转换为等效的 ChronoUnit 。
        结果
        转换后的等效ChronoUnit
        从以下版本开始：
        9

      • of

        public static TimeUnit of​(ChronoUnit chronoUnit)
        将 ChronoUnit转换为等效的 TimeUnit 。
        参数
        chronoUnit - 要转换的ChronoUnit
        结果
        转换的等效TimeUnit
        异常
        IllegalArgumentException - 如果 chronoUnit没有等效的TimeUnit
        NullPointerException - 如果 chronoUnit为空
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TransferQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent

Interface TransferQueue<E>

  • 参数类型
    E - 保存在此队列中的元素的类型
    All Superinterfaces:
    BlockingQueue<E> ， Collection<E> ， Iterable<E> ， Queue<E>
    所有已知实现类：
    LinkedTransferQueue

    public interface TransferQueue<E>
extends BlockingQueue<E>
    A BlockingQueue ，其中生产者可能等待消费者接收元素。 A TransferQueue可能例如在消息传递应用中是有用的，其中生产者有时（使用方法transfer(E) ）等待消费者调用take或poll的元素的接收，而在其他时间，等待元素（经由方法put ）而不等待接收。 Non-blocking和time-out版本的tryTransfer也可用。 A TransferQueue也可以通过hasWaitingConsumer()询问是否有任何线程等待项目，这是与peek操作相反的类比。

    像其他阻塞队列一样， TransferQueue可能是容量有限的。 如果是这样，尝试的转移操作可以最初阻止等待可用空间，和/或随后阻止等待消费者的接收。 请注意，在与零容量的队列，例如SynchronousQueue ， put和transfer是有效的代名词。

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getWaitingConsumerCount​()
      通过 BlockingQueue.take()或定时 poll返回等待接收元素的消费者数量的估计。
      boolean hasWaitingConsumer​()
      返回 true ，如果有至少一个消费者等待经由以接收元件 BlockingQueue.take()或定时 poll 。
      void transfer​(E e)
      将元素转移给消费者，如有必要，等待。
      boolean tryTransfer​(E e)
      如果可能的话，将元件立即转移给等待的消费者。
      boolean tryTransfer​(E e, long timeout, TimeUnit unit)
      如果可以在超时过程之前将元素传送给消费者。

      • Methods inherited from interface java.util.concurrent.BlockingQueue

        add, contains, drainTo, drainTo, offer, offer, poll, put, remainingCapacity, remove, take

      • Methods inherited from interface java.util.Collection

        addAll, clear, containsAll, equals, hashCode, isEmpty, iterator, parallelStream, removeAll, removeIf, retainAll, size, spliterator, stream, toArray, toArray

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.Queue

        element, peek, poll, remove

    • 方法详细信息

      • tryTransfer

        boolean tryTransfer​(E e)
        如果可能的话，将元件立即转移给等待的消费者。

        更确切地说，如果存在已经等待接收消费者的消费者（ BlockingQueue.take()或定时poll ），则立即转移指定元素，否则返回false而不对该元素进行排队。

        参数
        e - 要传输的元素
        结果
        true如果元素被转移，否则为 false
        异常
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此队列中

      • transfer

        void transfer​(E e)
       throws InterruptedException
        将元素转移给消费者，如有必要，等待。

        更准确地说，如果存在已经等待接收消费者的消费者（ BlockingQueue.take()或定时poll ），则立即传送指定的元素，否则等待消费者收到该元素。

        参数
        e - 要传输的元素
        异常
        InterruptedException - 如果在等待时中断，在这种情况下元素不会被排入队列
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此队列中

      • tryTransfer

        boolean tryTransfer​(E e,
                    long timeout,
                    TimeUnit unit)
             throws InterruptedException
        如果可以在超时过程之前将元素传送给消费者。

        更确切地说，如果存在已经等待接收消费者的消费者（ BlockingQueue.take()或定时poll ），则立即转移指定的元素，否则等待消费者接收到该元素，如果在元素可以在元素之前经过指定的等待时间，则返回false转入。

        参数
        e - 要传输的元素
        timeout - 放弃等待多久，单位为 unit
        unit - a TimeUnit确定如何解释 timeout参数
        结果
        true如果成功，或 false如果在完成之前经过了指定的等待时间，在这种情况下，元素不会排入队列
        异常
        InterruptedException - 如果在等待时中断，在这种情况下元素不会被排入队列
        ClassCastException - 如果指定元素的类阻止将其添加到此队列中
        NullPointerException - 如果指定的元素为空
        IllegalArgumentException - 如果指定元素的某些属性阻止将其添加到此队列中

      • hasWaitingConsumer

        boolean hasWaitingConsumer​()
        返回true ，如果有至少一个消费者等待经由以接收元件BlockingQueue.take()或定时poll 。 返回值代表一时的状态。
        结果
        true如果有至少一个等待消费者

      • getWaitingConsumerCount

        int getWaitingConsumerCount​()
        通过BlockingQueue.take()或定时poll返回等待接收元素的消费者数量的估计。 返回值是一个近似的瞬间状态，如果消费者已经完成或放弃等待，这可能是不准确的。 该值可能对监控和启发式有用，但不适用于同步控制。 这种方法的实施可能比hasWaitingConsumer()明显慢。
        结果
        消费者等待接收元素的数量
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util.concurrent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.concurrent

  • Packages that use java.util.concurrent
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供商类。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.concurrent
    提供javafx.task的一组类。
    javax.management
    提供Java管理扩展的核心类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    jdk.incubator.http
    高级HTTP和WebSocket API
  • Classes in java.util.concurrent used by com.sun.net.httpserver
    Class 描述
    Executor
    执行提交的对象Runnable任务。
  • Classes in java.util.concurrent used by com.sun.source.util
    Class 描述
    Callable
    返回结果并可能引发异常的任务。
  • Classes in java.util.concurrent used by java.lang
    Class 描述
    CompletableFuture
    A Future可以明确完成（设置其值和状态），并可用作CompletionStage ，支持在完成后触发的依赖功能和操作。
    TimeUnit
    A TimeUnit表示给定粒度单位的持续时间，并提供了跨单位转换的实用方法，并在这些单元中执行定时和延迟操作。
  • Classes in java.util.concurrent used by java.lang.ref
    Class 描述
    ThreadFactory
    根据需要创建新线程的对象。
  • Classes in java.util.concurrent used by java.nio.channels
    Class 描述
    ExecutorService
    一个Executor ，它提供了管理终止的方法和可以产生用于跟踪一个或多个异步任务进度的Future的方法。
    Future
    A Future表示异步计算的结果。
    ThreadFactory
    根据需要创建新线程的对象。
    TimeUnit
    A TimeUnit表示给定的粒度单位的持续时间，并提供了跨单位转换的实用方法，并在这些单元中执行定时和延迟操作。
  • Classes in java.util.concurrent used by java.nio.channels.spi
    Class 描述
    ExecutorService
    一个Executor ，其提供了管理终止的方法和可以产生用于跟踪一个或多个异步任务进度的Future的方法。
    ThreadFactory
    根据需要创建新线程的对象。
  • Classes in java.util.concurrent used by java.nio.file
    Class 描述
    TimeUnit
    A TimeUnit表示给定的粒度单位的持续时间，并提供了跨单元转换的实用方法，并在这些单元中执行定时和延迟操作。
  • Classes in java.util.concurrent used by java.nio.file.attribute
    Class 描述
    TimeUnit
    A TimeUnit表示给定粒度单位的持续时间，并提供了跨单位转换的实用方法，并在这些单元中执行定时和延迟操作。
  • Classes in java.util.concurrent used by java.nio.file.spi
    Class 描述
    ExecutorService
    一个Executor ，其提供了管理终止的方法和可以产生用于跟踪一个或多个异步任务的进度的Future的方法。
  • Classes in java.util.concurrent used by java.sql
    Class 描述
    Executor
    执行提交的对象Runnable任务。
  • Classes in java.util.concurrent used by java.util.concurrent
    Class 描述
    AbstractExecutorService
    提供ExecutorService执行方法的默认实现。
    BlockingDeque
    A Deque另外支持在检索元素时等待deque变为非空的阻塞操作，并且在存储元素时等待空白在deque中可用。
    BlockingQueue
    A Queue另外支持在检索元素时等待队列变为非空的操作，并且在存储元素时等待队列中的空间变得可用。
    BrokenBarrierException
    当线程尝试等待处于断开状态的屏障或线程等待时进入断开状态时抛出异常。
    Callable
    返回结果并可能引发异常的任务。
    CompletableFuture
    A Future可以明确完成（设置其值和状态），并可用作CompletionStage ，支持从属功能和完成后触发的操作。
    CompletionService
    一种将新异步任务的生产与已完成任务的结果消耗相分离的服务。
    CompletionStage
    可能的异步计算的阶段，当另一个完成时间完成时，执行一个动作或计算一个值。
    ConcurrentHashMap.KeySetView
    ConcurrentHashMap视图为Set的密钥，其中可以通过映射到公共值来选择添加。
    ConcurrentMap
    A Map提供线程安全和原子性保证。
    ConcurrentNavigableMap
    A ConcurrentMap支持NavigableMap操作，并且递归地为其可导航的子地图。
    ConcurrentSkipListMap
    可扩展的并发ConcurrentNavigableMap实现。
    ConcurrentSkipListSet
    可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
    CountedCompleter
    A ForkJoinTask ，当触发时执行完成操作，并且没有剩余的待处理操作。
    Delayed
    一个混合样式界面，用于标记在给定延迟后应该执行的对象。
    ExecutionException
    尝试检索通过抛出异常中止的任务的结果时抛出的异常。
    Executor
    一个对象执行提交的Runnable任务。
    ExecutorService
    一个Executor ，它提供了管理终止的方法和方法，可以产生一个Future来跟踪一个或多个异步任务的进度。
    Flow.Publisher
    订阅者接收的项目（和相关控制消息）的生产者。
    Flow.Subscriber
    消息的接收者。
    Flow.Subscription
    链接Flow.Publisher和Flow.Subscriber的消息控件。
    ForkJoinPool
    一个ExecutorService ，运行ForkJoinTask s。
    ForkJoinPool.ForkJoinWorkerThreadFactory
    工厂创建新的ForkJoinWorkerThread s。
    ForkJoinPool.ManagedBlocker
    用于扩展管理并行性的接口，用于在ForkJoinPool中运行的任务。
    ForkJoinTask
    ForkJoinPool中运行的任务的抽象基类。
    ForkJoinWorkerThread
    一个由ForkJoinPool管理的线程，执行ForkJoinTask 。
    Future
    A Future表示异步计算的结果。
    Phaser
    一个可重复使用的同步屏障，功能类似于CyclicBarrier和CountDownLatch，但支持更灵活的使用。
    RejectedExecutionHandler
    ThreadPoolExecutor无法执行的任务的处理程序。
    RunnableFuture
    A Future ，这是Runnable 。
    RunnableScheduledFuture
    A ScheduledFuture ，这是Runnable 。
    ScheduledExecutorService
    一个ExecutorService ，可以调度命令在给定的延迟之后运行，或定期执行。
    ScheduledFuture
    可以取消延迟结果的行动。
    ThreadFactory
    根据需要创建新线程的对象。
    ThreadLocalRandom
    与当前线程隔离的随机数生成器。
    ThreadPoolExecutor
    一个ExecutorService ，它使用可能的几个池线程执行每个提交的任务，通常使用Executors工厂方法配置。
    TimeoutException
    阻塞操作超时时抛出异常。
    TimeUnit
    A TimeUnit表示给定的粒度单位的持续时间，并提供了跨单元转换的实用方法，并在这些单元中执行定时和延迟操作。
    TransferQueue
    A BlockingQueue ，其中生产者可能等待消费者接收元素。
  • Classes in java.util.concurrent used by java.util.concurrent.locks
    Class 描述
    TimeUnit
    A TimeUnit表示给定粒度单位的持续时间，并提供了跨单位转换的实用方法，并在这些单元中执行定时和延迟操作。
  • Classes in java.util.concurrent used by java.util.stream
    Class 描述
    ConcurrentMap
    A Map提供线程安全和原子性保证。
  • Classes in java.util.concurrent used by javafx.beans.binding
    Class 描述
    Callable
    返回结果并可能引发异常的任务。
  • Classes in java.util.concurrent used by javafx.concurrent
    Class 描述
    Executor
    执行提交的对象Runnable任务。
    Future
    A Future表示异步计算的结果。
    FutureTask
    可取消的异步计算。
    RunnableFuture
    A Future ，这是Runnable 。
  • Classes in java.util.concurrent used by javax.management
    Class 描述
    Executor
    执行提交的对象Runnable任务。
  • Classes in java.util.concurrent used by javax.swing
    Class 描述
    ExecutionException
    尝试检索通过抛出异常中止的任务的结果时抛出的异常。
    Future
    A Future表示异步计算的结果。
    RunnableFuture
    A Future ，是Runnable 。
    TimeoutException
    阻塞操作超时时抛出异常。
    TimeUnit
    A TimeUnit表示给定粒度单位的持续时间，并提供了跨单位转换的实用方法，并在这些单元中执行定时和延迟操作。
  • Classes in java.util.concurrent used by javax.tools
    Class 描述
    Callable
    返回结果并可能引发异常的任务。
  • Classes in java.util.concurrent used by javax.xml.ws
    Class 描述
    Executor
    一个对象执行提交的Runnable任务。
    Future
    A Future表示异步计算的结果。
  • Classes in java.util.concurrent used by javax.xml.ws.spi
    Class 描述
    Executor
    执行提交的对象Runnable任务。
  • Classes in java.util.concurrent used by jdk.incubator.http
    Class 描述
    CompletableFuture
    A Future可以明确完成（设置其值和状态），并可用作CompletionStage ，支持从属功能和完成后触发的操作。
    CompletionStage
    可能的异步计算的阶段，当另一个完成时间完成时，执行一个动作或计算一个值。
    Executor
    执行提交的对象Runnable任务。
    Flow.Publisher
    订阅者接收的项目（和相关控制消息）的生产者。
    Flow.Subscriber
    A receiver of messages.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AtomicBoolean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicBoolean

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicBoolean
  • All Implemented Interfaces:
    Serializable

    public class AtomicBoolean
extends Object
implements Serializable
    A boolean可能原子更新的值。 200新新新新200新新新新200新新新200新200新新200新200新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新新200新新新新作新新新200新新200新新新作旗新 一个AtomicBoolean用于诸如原子更新标记的应用程序，不能用作Boolean的替代品。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicBoolean​()
      创建一个新的 AtomicBoolean ，初始值为 false 。
      AtomicBoolean​(boolean initialValue)
      用给定的初始值创建一个新的 AtomicBoolean 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean compareAndExchange​(boolean expectedValue, boolean newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。
      boolean compareAndExchangeAcquire​(boolean expectedValue, boolean newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
      boolean compareAndExchangeRelease​(boolean expectedValue, boolean newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。
      boolean compareAndSet​(boolean expectedValue, boolean newValue)
      原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。
      boolean get​()
      返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
      boolean getAcquire​()
      返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
      boolean getAndSet​(boolean newValue)
      将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。
      boolean getOpaque​()
      返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的记忆效应。
      boolean getPlain​()
      返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。
      void lazySet​(boolean newValue)
      将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      void set​(boolean newValue)
      将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
      void setOpaque​(boolean newValue)
      将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
      void setPlain​(boolean newValue)
      将值设置为 newValue ，具有设置的内存语义，如同变量声明为非 volatile ，非 final 。
      void setRelease​(boolean newValue)
      将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      String toString​()
      返回当前值的String表示形式。
      boolean weakCompareAndSet​(boolean expectedValue, boolean newValue)
      已过时。
      该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(boolean, boolean)和compareAndSet(boolean, boolean) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法weakCompareAndSetPlain(boolean, boolean) 。
      boolean weakCompareAndSetAcquire​(boolean expectedValue, boolean newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
      boolean weakCompareAndSetPlain​(boolean expectedValue, boolean newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
      boolean weakCompareAndSetRelease​(boolean expectedValue, boolean newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
      boolean weakCompareAndSetVolatile​(boolean expectedValue, boolean newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AtomicBoolean

        public AtomicBoolean​(boolean initialValue)
        用给定的初始值创建一个新的 AtomicBoolean 。
        参数
        initialValue - 初始值

      • AtomicBoolean

        public AtomicBoolean​()
        创建一个新的 AtomicBoolean ，初始值为 false 。

    • 方法详细信息

      • get

        public final boolean get​()
        返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
        结果
        当前值

      • compareAndSet

        public final boolean compareAndSet​(boolean expectedValue,
                                   boolean newValue)
        原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功。 False return表示实际值不等于预期值。

      • weakCompareAndSet

        @Deprecated(since="9")
public boolean weakCompareAndSet​(boolean expectedValue,
                                 boolean newValue)
        已过时。 该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(boolean, boolean)和compareAndSet(boolean, boolean) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(boolean, boolean) 。
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        另请参见：
        weakCompareAndSetPlain(boolean, boolean)

      • weakCompareAndSetPlain

        public boolean weakCompareAndSetPlain​(boolean expectedValue,
                                      boolean newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • set

        public final void set​(boolean newValue)
        将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值

      • lazySet

        public final void lazySet​(boolean newValue)
        将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        1.6

      • getAndSet

        public final boolean getAndSet​(boolean newValue)
        将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        结果
        以前的值

      • toString

        public String toString​()
        返回当前值的String表示形式。
        重写：
        toString在 Object
        结果
        当前值的String表示形式

      • getPlain

        public final boolean getPlain​()
        返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。
        结果
        价值
        从以下版本开始：
        9

      • setPlain

        public final void setPlain​(boolean newValue)
        将值设置为 newValue ，具有设置的内存语义，如同该变量被声明为非 volatile final 。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • getOpaque

        public final boolean getOpaque​()
        返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
        结果
        价值
        从以下版本开始：
        9

      • setOpaque

        public final void setOpaque​(boolean newValue)
        将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • getAcquire

        public final boolean getAcquire​()
        返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
        结果
        价值
        从以下版本开始：
        9

      • setRelease

        public final void setRelease​(boolean newValue)
        将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • compareAndExchange

        public final boolean compareAndExchange​(boolean expectedValue,
                                        boolean newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeAcquire

        public final boolean compareAndExchangeAcquire​(boolean expectedValue,
                                               boolean newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeRelease

        public final boolean compareAndExchangeRelease​(boolean expectedValue,
                                               boolean newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • weakCompareAndSetVolatile

        public final boolean weakCompareAndSetVolatile​(boolean expectedValue,
                                               boolean newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetAcquire

        public final boolean weakCompareAndSetAcquire​(boolean expectedValue,
                                              boolean newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetRelease

        public final boolean weakCompareAndSetRelease​(boolean expectedValue,
                                              boolean newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicInteger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicInteger

  • java.lang.Object
    • java.lang.Number
      • java.util.concurrent.atomic.AtomicInteger
  • All Implemented Interfaces:
    Serializable

    public class AtomicInteger
extends Number
implements Serializable
    可能原子更新的值为int 。 有关原子访问属性的说明，请参阅VarHandle规范。 一个AtomicInteger用于诸如原子增量计数器的应用中，不能用作Integer的替代品。 但是，该类确实扩展了Number以允许使用基于数字类的工具和实用程序的统一访问。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicInteger​()
      创建一个新的AtomicInteger，初始值为 0 。
      AtomicInteger​(int initialValue)
      用给定的初始值创建一个新的AtomicInteger。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int accumulateAndGet​(int x, IntBinaryOperator accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效应），返回更新后的值。
      int addAndGet​(int delta)
      将给定的值原子地添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
      int compareAndExchange​(int expectedValue, int newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。
      int compareAndExchangeAcquire​(int expectedValue, int newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
      int compareAndExchangeRelease​(int expectedValue, int newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。
      boolean compareAndSet​(int expectedValue, int newValue)
      原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。
      int decrementAndGet​()
      按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果原子减少当前值。
      double doubleValue​()
      返回此的当前值 AtomicInteger作为 double加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
      float floatValue​()
      返回此的当前值 AtomicInteger作为 float加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
      int get​()
      返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
      int getAcquire​()
      返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
      int getAndAccumulate​(int x, IntBinaryOperator accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效应），返回上一个值。
      int getAndAdd​(int delta)
      将给定的值原子地添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的记忆效应。
      int getAndDecrement​()
      按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果原则递减当前值。
      int getAndIncrement​()
      按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子地增加当前值。
      int getAndSet​(int newValue)
      将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。
      int getAndUpdate​(IntUnaryOperator updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。
      int getOpaque​()
      返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
      int getPlain​()
      返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。
      int incrementAndGet​()
      按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子地增加当前值。
      int intValue​()
      返回此的当前值 AtomicInteger作为 int如通过指定，记忆效应 VarHandle.getVolatile(java.lang.Object...) 。
      void lazySet​(int newValue)
      将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      long longValue​()
      返回此的当前值 AtomicInteger作为 long加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
      void set​(int newValue)
      将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
      void setOpaque​(int newValue)
      将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的记忆效果。
      void setPlain​(int newValue)
      将值设置为 newValue ，其内存语义设置为该变量被声明为非 volatile final 。
      void setRelease​(int newValue)
      将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      String toString​()
      返回当前值的String表示形式。
      int updateAndGet​(IntUnaryOperator updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      boolean weakCompareAndSet​(int expectedValue, int newValue)
      已过时。
      该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见compareAndExchange(int, int)和compareAndSet(int, int)等 ）。 为了避免在平常或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(int, int) 。
      boolean weakCompareAndSetAcquire​(int expectedValue, int newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
      boolean weakCompareAndSetPlain​(int expectedValue, int newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
      boolean weakCompareAndSetRelease​(int expectedValue, int newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
      boolean weakCompareAndSetVolatile​(int expectedValue, int newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。

      • Methods inherited from class java.lang.Number

        byteValue, shortValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AtomicInteger

        public AtomicInteger​(int initialValue)
        用给定的初始值创建一个新的AtomicInteger。
        参数
        initialValue - 初始值

      • AtomicInteger

        public AtomicInteger​()
        创建一个新的AtomicInteger，初始值为 0 。

    • 方法详细信息

      • get

        public final int get​()
        返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
        结果
        当前值

      • set

        public final void set​(int newValue)
        将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值

      • lazySet

        public final void lazySet​(int newValue)
        将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新价值
        从以下版本开始：
        1.6

      • getAndSet

        public final int getAndSet​(int newValue)
        将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        结果
        以前的值

      • compareAndSet

        public final boolean compareAndSet​(int expectedValue,
                                   int newValue)
        原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功。 False return表示实际值不等于预期值。

      • weakCompareAndSet

        @Deprecated(since="9")
public final boolean weakCompareAndSet​(int expectedValue,
                                       int newValue)
        已过时。 该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见compareAndExchange(int, int)和compareAndSet(int, int)等方法）。 为了避免在平常或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(int, int) 。
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        另请参见：
        weakCompareAndSetPlain(int, int)

      • weakCompareAndSetPlain

        public final boolean weakCompareAndSetPlain​(int expectedValue,
                                            int newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • getAndIncrement

        public final int getAndIncrement​()
        以VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子地增加当前值。

        相当于getAndAdd(1) 。

        结果
        以前的值

      • getAndDecrement

        public final int getAndDecrement​()
        按照VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子递减当前值。

        相当于getAndAdd(-1) 。

        结果
        以前的值

      • getAndAdd

        public final int getAndAdd​(int delta)
        原始地将给定的值添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
        参数
        delta - 要添加的值
        结果
        以前的值

      • incrementAndGet

        public final int incrementAndGet​()
        按照VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子地增加当前值。

        相当于addAndGet(1) 。

        结果
        更新的值

      • decrementAndGet

        public final int decrementAndGet​()
        按照VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子递减当前值。

        相当于addAndGet(-1) 。

        结果
        更新的值

      • addAndGet

        public final int addAndGet​(int delta)
        原始地将给定的值添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
        参数
        delta - 要添加的值
        结果
        更新的值

      • getAndUpdate

        public final int getAndUpdate​(IntUnaryOperator updateFunction)
        使用给定函数的结果对当前值进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        updateFunction - 无副作用的功能
        结果
        以前的值
        从以下版本开始：
        1.8

      • updateAndGet

        public final int updateAndGet​(IntUnaryOperator updateFunction)
        使用给定函数的结果对当前值进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回更新的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        updateFunction - 无副作用的功能
        结果
        更新的值
        从以下版本开始：
        1.8

      • getAndAccumulate

        public final int getAndAccumulate​(int x,
                                  IntBinaryOperator accumulatorFunction)
        将当前值与给定函数应用于当前值和给定值的原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        x - 更新值
        accumulatorFunction - 两个参数的副作用函数
        结果
        以前的值
        从以下版本开始：
        1.8

      • accumulateAndGet

        public final int accumulateAndGet​(int x,
                                  IntBinaryOperator accumulatorFunction)
        将当前值与给定函数应用于当前值和给定值的原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回更新后的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        更新的值
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回当前值的String表示形式。
        重写：
        toString Object
        结果
        当前值的String表示形式

      • intValue

        public int intValue​()
        将AtomicInteger的当前值作为int ，具有VarHandle.getVolatile(java.lang.Object...)指定的内存效果。 相当于get() 。
        Specified by:
        intValue Number
        结果
        该对象在转换为 int之后表示的数值。

      • longValue

        public long longValue​()
        返回此的当前值 AtomicInteger作为 long加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
        Specified by:
        longValue在 Number
        结果
        该对象在转换为 long之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • floatValue

        public float floatValue​()
        返回此的当前值 AtomicInteger作为 float加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
        Specified by:
        floatValue在 Number
        结果
        该对象在转换为 float型后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • doubleValue

        public double doubleValue​()
        返回此的当前值 AtomicInteger作为 double加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
        Specified by:
        doubleValue在 Number
        结果
        该对象在转换为 double之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • getPlain

        public final int getPlain​()
        返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。
        结果
        价值
        从以下版本开始：
        9

      • setPlain

        public final void setPlain​(int newValue)
        将值设置为 newValue ，具有设置的内存语义，如同该变量被宣告为非 volatile final 。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • getOpaque

        public final int getOpaque​()
        返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
        结果
        价值
        从以下版本开始：
        9

      • setOpaque

        public final void setOpaque​(int newValue)
        将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • getAcquire

        public final int getAcquire​()
        返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
        结果
        价值
        从以下版本开始：
        9

      • setRelease

        public final void setRelease​(int newValue)
        将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • compareAndExchange

        public final int compareAndExchange​(int expectedValue,
                                    int newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeAcquire

        public final int compareAndExchangeAcquire​(int expectedValue,
                                           int newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新价值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeRelease

        public final int compareAndExchangeRelease​(int expectedValue,
                                           int newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • weakCompareAndSetVolatile

        public final boolean weakCompareAndSetVolatile​(int expectedValue,
                                               int newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetAcquire

        public final boolean weakCompareAndSetAcquire​(int expectedValue,
                                              int newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新的价值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetRelease

        public final boolean weakCompareAndSetRelease​(int expectedValue,
                                              int newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新的价值
        结果
        true如果成功
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicIntegerArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicIntegerArray

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicIntegerArray
  • All Implemented Interfaces:
    Serializable

    public class AtomicIntegerArray
extends Object
implements Serializable
    其中元素可以原子更新的int数组。 有关原子访问属性的说明，请参阅VarHandle规范。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicIntegerArray​(int length)
      创建给定长度的新AtomicIntegerArray，所有元素最初为零。
      AtomicIntegerArray​(int[] array)
      创建一个新的AtomicIntegerArray，其长度与从给定数组复制的所有元素相同。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int accumulateAndGet​(int i, int x, IntBinaryOperator accumulatorFunction)
      将索引号为 i的元素原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），并将给定函数应用于当前值和给定值，返回更新后的值。
      int addAndGet​(int i, int delta)
      原子地将给定值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
      int compareAndExchange​(int i, int expectedValue, int newValue)
      如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchange(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
      int compareAndExchangeAcquire​(int i, int expectedValue, int newValue)
      如果元素的当前值，被称为 见证值 == expectedValue ，具有由 VarHandle.compareAndExchangeAcquire(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
      int compareAndExchangeRelease​(int i, int expectedValue, int newValue)
      如果元素的当前值（称为见 值 == expectedValue ）具有由 VarHandle.compareAndExchangeRelease(java.lang.Object...)指定的记忆效应，则原子将索引 i为 newValue的元素设置为 newValue 。
      boolean compareAndSet​(int i, int expectedValue, int newValue)
      如果元素的当前值 == expectedValue具有 VarHandle.compareAndSet(java.lang.Object...)指定的记忆效应，则将索引 i为 newValue的元素原子设置为 newValue 。
      int decrementAndGet​(int i)
      按索引 i原子地递减元素的值，其值由 VarHandle.getAndAdd(java.lang.Object...)指定。
      int get​(int i)
      返回索引号为 i的元素的当前值，由 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
      int getAcquire​(int i)
      返回索引号为 i的元素的当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
      int getAndAccumulate​(int i, int x, IntBinaryOperator accumulatorFunction)
      原始更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回上一个值。
      int getAndAdd​(int i, int delta)
      原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
      int getAndDecrement​(int i)
      原子递减元件的索引值 i如通过指定，记忆效应 VarHandle.getAndAdd(java.lang.Object...) 。
      int getAndIncrement​(int i)
      按索引 i原子地增加元素的值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
      int getAndSet​(int i, int newValue)
      将索引 i为 newValue的元素原子设置为 newValue并返回具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果的旧值。
      int getAndUpdate​(int i, IntUnaryOperator updateFunction)
      原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素与应用给定函数的结果，返回上一个值。
      int getOpaque​(int i)
      返回索引号为 i的元素的当前值，由 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
      int getPlain​(int i)
      返回索引号为 i的元素的当前值，其读取的内存语义就好像变量被声明为非 volatile 。
      int incrementAndGet​(int i)
      在索引 i原子方式增加元素的值，其值由 VarHandle.getAndAdd(java.lang.Object...)指定。
      void lazySet​(int i, int newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      int length​()
      返回数组的长度。
      void set​(int i, int newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
      void setOpaque​(int i, int newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
      void setPlain​(int i, int newValue)
      将索引 i为 newValue的元素设置为 newValue ，其内存语义设置为该变量被声明为非 volatile ， final 。
      void setRelease​(int i, int newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      String toString​()
      返回数组的当前值的String表示形式。
      int updateAndGet​(int i, IntUnaryOperator updateFunction)
      原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素与应用给定函数的结果，返回更新的值。
      boolean weakCompareAndSet​(int i, int expectedValue, int newValue)
      已过时。
      该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(int, int, int)和compareAndSet(int, int, int) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(int, int, int) 。
      boolean weakCompareAndSetAcquire​(int i, int expectedValue, int newValue)
      如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetAcquire(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
      boolean weakCompareAndSetPlain​(int i, int expectedValue, int newValue)
      如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
      boolean weakCompareAndSetRelease​(int i, int expectedValue, int newValue)
      可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
      boolean weakCompareAndSetVolatile​(int i, int expectedValue, int newValue)
      如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSet(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AtomicIntegerArray

        public AtomicIntegerArray​(int length)
        创建给定长度的新AtomicIntegerArray，所有元素最初为零。
        参数
        length - 数组的长度

      • AtomicIntegerArray

        public AtomicIntegerArray​(int[] array)
        创建一个新的AtomicIntegerArray，其长度与从给定数组复制的所有元素相同。
        参数
        array - 从中复制元素的数组
        异常
        NullPointerException - 如果数组为空

    • 方法详细信息

      • length

        public final int length​()
        返回数组的长度。
        结果
        数组的长度

      • get

        public final int get​(int i)
        返回索引号为 i的元素的当前值，由 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        结果
        当前值

      • set

        public final void set​(int i,
                      int newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
        参数
        i - 指数
        newValue - 新值

      • lazySet

        public final void lazySet​(int i,
                          int newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        1.6

      • getAndSet

        public final int getAndSet​(int i,
                           int newValue)
        将索引 i为 newValue的元素原子设置为 newValue并返回具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果的旧值。
        参数
        i - 指数
        newValue - 新值
        结果
        以前的值

      • compareAndSet

        public final boolean compareAndSet​(int i,
                                   int expectedValue,
                                   int newValue)
        如果元素的当前值 == expectedValue具有 == expectedValue所指定的内存效果，则将索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 指数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功。 False return表示实际值不等于预期值。

      • weakCompareAndSet

        @Deprecated(since="9")
public final boolean weakCompareAndSet​(int i,
                                       int expectedValue,
                                       int newValue)
        已过时。 该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(int, int, int)和compareAndSet(int, int, int) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(int, int, int) 。
        如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新价值
        结果
        true如果成功
        另请参见：
        weakCompareAndSetPlain(int, int, int)

      • weakCompareAndSetPlain

        public final boolean weakCompareAndSetPlain​(int i,
                                            int expectedValue,
                                            int newValue)
        如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • getAndIncrement

        public final int getAndIncrement​(int i)
        原子递增元件的索引值i如通过指定，记忆效应VarHandle.getAndAdd(java.lang.Object...) 。

        相当于getAndAdd(i, 1) 。

        参数
        i - 索引
        结果
        以前的值

      • getAndDecrement

        public final int getAndDecrement​(int i)
        原子递减元件的索引值i如通过指定，记忆效应VarHandle.getAndAdd(java.lang.Object...) 。

        相当于getAndAdd(i, -1) 。

        参数
        i - 索引
        结果
        以前的值

      • getAndAdd

        public final int getAndAdd​(int i,
                           int delta)
        原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        delta - 要添加的值
        结果
        以前的值

      • incrementAndGet

        public final int incrementAndGet​(int i)
        原子递增元件的索引值i如通过指定，记忆效应VarHandle.getAndAdd(java.lang.Object...) 。

        相当于addAndGet(i, 1) 。

        参数
        i - 指数
        结果
        更新的值

      • decrementAndGet

        public final int decrementAndGet​(int i)
        原子地递减索引号为i的元素的值，具有由VarHandle.getAndAdd(java.lang.Object...)指定的记忆效应。

        相当于addAndGet(i, -1) 。

        参数
        i - 索引
        结果
        更新的值

      • addAndGet

        public final int addAndGet​(int i,
                           int delta)
        原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的记忆效应。
        参数
        i - 索引
        delta - 要添加的值
        结果
        更新的值

      • getAndUpdate

        public final int getAndUpdate​(int i,
                              IntUnaryOperator updateFunction)
        原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为i的元素与应用给定函数的结果，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        i - 索引
        updateFunction - 一个无副作用的功能
        结果
        以前的值
        从以下版本开始：
        1.8

      • updateAndGet

        public final int updateAndGet​(int i,
                              IntUnaryOperator updateFunction)
        使用索引i的元素与应用给定函数的结果进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        i - 索引
        updateFunction - 无副作用的功能
        结果
        更新的值
        从以下版本开始：
        1.8

      • getAndAccumulate

        public final int getAndAccumulate​(int i,
                                  int x,
                                  IntBinaryOperator accumulatorFunction)
        原始更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为i的元素，并将给定的函数应用于当前值和给定值，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数以索引i作为其第一个参数的元素的当前值应用，给定的更新作为第二个参数。
        参数
        i - 索引
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        以前的值
        从以下版本开始：
        1.8

      • accumulateAndGet

        public final int accumulateAndGet​(int i,
                                  int x,
                                  IntBinaryOperator accumulatorFunction)
        原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为i的元素，并将给定函数应用于当前值和给定值，返回更新后的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用索引i作为第一个参数的元素的当前值，给定更新作为第二个参数。
        参数
        i - 索引
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        更新的值
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回数组的当前值的String表示形式。
        重写：
        toString在 Object
        结果
        数组的当前值的String表示形式

      • getPlain

        public final int getPlain​(int i)
        返回索引号为 i的元素的当前值，读取的内存语义就好像变量被声明为非 volatile 。
        参数
        i - 索引
        结果
        价值
        从以下版本开始：
        9

      • setPlain

        public final void setPlain​(int i,
                           int newValue)
        将索引 i为 newValue的元素设置为 newValue ，其内存语义设置为该变量被声明为非 volatile final 。
        参数
        i - 索引
        newValue - 新的价值
        从以下版本开始：
        9

      • getOpaque

        public final int getOpaque​(int i)
        返回索引号为 i的元素的当前值，由 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        结果
        价值
        从以下版本开始：
        9

      • setOpaque

        public final void setOpaque​(int i,
                            int newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        9

      • getAcquire

        public final int getAcquire​(int i)
        返回索引号为 i的元素的当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        结果
        价值
        从以下版本开始：
        9

      • setRelease

        public final void setRelease​(int i,
                             int newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新价值
        从以下版本开始：
        9

      • compareAndExchange

        public final int compareAndExchange​(int i,
                                    int expectedValue,
                                    int newValue)
        如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchange(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeAcquire

        public final int compareAndExchangeAcquire​(int i,
                                           int expectedValue,
                                           int newValue)
        以原子方式设置在索引元件 i到 newValue如果该元素的当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeRelease

        public final int compareAndExchangeRelease​(int i,
                                           int expectedValue,
                                           int newValue)
        如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchangeRelease(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新价值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • weakCompareAndSetVolatile

        public final boolean weakCompareAndSetVolatile​(int i,
                                               int expectedValue,
                                               int newValue)
        如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSet(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子地设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetAcquire

        public final boolean weakCompareAndSetAcquire​(int i,
                                              int expectedValue,
                                              int newValue)
        可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
        参数
        i - 索引
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetRelease

        public final boolean weakCompareAndSetRelease​(int i,
                                              int expectedValue,
                                              int newValue)
        可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicIntegerFieldUpdater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicIntegerFieldUpdater<T>

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicIntegerFieldUpdater<T>
  • 参数类型
    T - 持有可更新字段的对象的类型

    public abstract class AtomicIntegerFieldUpdater<T>
extends Object
    基于反射的实用程序，可以对指定类的指定volatile int字段进行原子更新。 该类设计用于原子数据结构，其中同一节点的多个字段独立受原子更新的影响。

    请注意， compareAndSet中的compareAndSet方法的保证弱于其他原子类。 因为这个类不能确保该字段的所有用途都适用于原子访问的目的，所以它可以保证原子性仅在相同更新set上的compareAndSet和set其他调用。

    类型为T参数的对象参数不是传递给newUpdater(java.lang.Class<U>, java.lang.String)的类的实例将导致抛出ClassCastException 。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AtomicIntegerFieldUpdater​()
      受保护的do-nothing构造函数供子类使用。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      int accumulateAndGet​(T obj, int x, IntBinaryOperator accumulatorFunction)
      原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。
      int addAndGet​(T obj, int delta)
      将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
      abstract boolean compareAndSet​(T obj, int expect, int update)
      如果当前值为 == ，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。
      int decrementAndGet​(T obj)
      由该更新程序管理的给定对象的字段的当前值原子减1。
      abstract int get​(T obj)
      返回由此更新程序管理的给定对象的字段中保留的当前值。
      int getAndAccumulate​(T obj, int x, IntBinaryOperator accumulatorFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。
      int getAndAdd​(T obj, int delta)
      将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
      int getAndDecrement​(T obj)
      由该更新程序管理的给定对象的字段的当前值原子减1。
      int getAndIncrement​(T obj)
      由此更新程序管理的给定对象的字段的当前值以原子方式递增1。
      int getAndSet​(T obj, int newValue)
      将由此更新程序管理的给定对象的字段原子设置为给定值，并返回旧值。
      int getAndUpdate​(T obj, IntUnaryOperator updateFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回上一个值。
      int incrementAndGet​(T obj)
      由此更新程序管理的给定对象的字段的当前值以原子方式递增1。
      abstract void lazySet​(T obj, int newValue)
      最终将由此更新程序管理的给定对象的字段设置为给定的更新值。
      static <U> AtomicIntegerFieldUpdater<U> newUpdater​(Class<U> tclass, String fieldName)
      创建并返回具有给定字段的对象的更新程序。
      abstract void set​(T obj, int newValue)
      将由此更新程序管理的给定对象的字段设置为给定的更新值。
      int updateAndGet​(T obj, IntUnaryOperator updateFunction)
      通过应用给定函数的结果，原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，返回更新的值。
      abstract boolean weakCompareAndSet​(T obj, int expect, int update)
      如果当前值为 == ，则将由此更新程序管理的给定对象的字段设置为给定的更新值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AtomicIntegerFieldUpdater

        protected AtomicIntegerFieldUpdater​()
        受保护的do-nothing构造函数供子类使用。

    • 方法详细信息

      • newUpdater

        public static <U> AtomicIntegerFieldUpdater<U> newUpdater​(Class<U> tclass,
                                                          String fieldName)
        创建并返回具有给定字段的对象的更新程序。 需要Class参数来检查反射类型和泛型类型是否匹配。
        参数类型
        U - tclass的实例类型
        参数
        tclass - 持有该字段的对象的类
        fieldName - 要更新的字段的名称
        结果
        更新者
        异常
        IllegalArgumentException - 如果该字段不是易失性整数类型
        RuntimeException - 如果类不保存字段或错误的类型，或者根据Java语言访问控制，该调用者不可访问该字段，则基于反射的嵌套异常

      • compareAndSet

        public abstract boolean compareAndSet​(T obj,
                                      int expect,
                                      int update)
        如果当前值==为预期值，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。 相对于其他对compareAndSet和set调用，该方法保证是原子的，但不一定与本领域的其他更改相关。
        参数
        obj - 有条件地设置其字段的对象
        expect - 预期值
        update - 新值
        结果
        true如果成功

      • weakCompareAndSet

        public abstract boolean weakCompareAndSet​(T obj,
                                          int expect,
                                          int update)
        如果当前值==为预期值，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。 相对于其他对compareAndSet和set调用，该方法保证是原子的，但不一定与本领域的其他更改相关。

        May fail spuriously and does not provide ordering guarantees ，所以很少是compareAndSet的适当替代compareAndSet 。

        参数
        obj - 有条件地设置其字段的对象
        expect - 期望值
        update - 新值
        结果
        true如果成功

      • set

        public abstract void set​(T obj,
                         int newValue)
        将由此更新程序管理的给定对象的字段设置为给定的更新值。 该操作被保证作为关于compareAndSet后续调用的易失性存储。
        参数
        obj - 要设置的字段的对象
        newValue - 新值

      • lazySet

        public abstract void lazySet​(T obj,
                             int newValue)
        最终将由此更新程序管理的给定对象的字段设置为给定的更新值。
        参数
        obj - 要设置的字段的对象
        newValue - 新价值
        从以下版本开始：
        1.6

      • get

        public abstract int get​(T obj)
        返回由此更新程序管理的给定对象的字段中保留的当前值。
        参数
        obj - 要获取字段的对象
        结果
        当前值

      • getAndSet

        public int getAndSet​(T obj,
                     int newValue)
        将由此更新程序管理的给定对象的字段原子设置为给定值，并返回旧值。
        参数
        obj - 要获取和设置的字段的对象
        newValue - 新价值
        结果
        以前的值

      • getAndIncrement

        public int getAndIncrement​(T obj)
        由此更新程序管理的给定对象的字段的当前值以原子方式递增1。
        参数
        obj - 一个要获取和设置的字段的对象
        结果
        以前的值

      • getAndDecrement

        public int getAndDecrement​(T obj)
        由该更新程序管理的给定对象的字段的当前值原子减1。
        参数
        obj - 要获取和设置的字段的对象
        结果
        以前的值

      • getAndAdd

        public int getAndAdd​(T obj,
                     int delta)
        将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
        参数
        obj - 一个要获取和设置的字段的对象
        delta - 要添加的值
        结果
        以前的值

      • incrementAndGet

        public int incrementAndGet​(T obj)
        由此更新程序管理的给定对象的字段的当前值以原子方式递增1。
        参数
        obj - 要获取和设置的字段的对象
        结果
        更新的值

      • decrementAndGet

        public int decrementAndGet​(T obj)
        由该更新程序管理的给定对象的字段的当前值原子减1。
        参数
        obj - 一个要获取和设置的字段的对象
        结果
        更新的值

      • addAndGet

        public int addAndGet​(T obj,
                     int delta)
        将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
        参数
        obj - 要获取和设置的字段的对象
        delta - 要添加的值
        结果
        更新的值

      • getAndUpdate

        public final int getAndUpdate​(T obj,
                              IntUnaryOperator updateFunction)
        原始更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        obj - 要获取和设置的字段的对象
        updateFunction - 无副作用的功能
        结果
        以前的值
        从以下版本开始：
        1.8

      • updateAndGet

        public final int updateAndGet​(T obj,
                              IntUnaryOperator updateFunction)
        通过应用给定函数的结果对由该更新程序管理的给定对象的字段进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        obj - 要获取和设置的字段的对象
        updateFunction - 无副作用的功能
        结果
        更新的值
        从以下版本开始：
        1.8

      • getAndAccumulate

        public final int getAndAccumulate​(T obj,
                                  int x,
                                  IntBinaryOperator accumulatorFunction)
        原始更新（由VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        obj - 要获取和设置的字段的对象
        x - 更新值
        accumulatorFunction - 两个参数的无副作用函数
        结果
        以前的值
        从以下版本开始：
        1.8

      • accumulateAndGet

        public final int accumulateAndGet​(T obj,
                                  int x,
                                  IntBinaryOperator accumulatorFunction)
        原始更新（由VarHandle.compareAndSet(java.lang.Object...)指定的内存效应）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        obj - 一个要获取和设置的字段的对象
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        更新的值
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicLong (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicLong

  • java.lang.Object
    • java.lang.Number
      • java.util.concurrent.atomic.AtomicLong
  • All Implemented Interfaces:
    Serializable

    public class AtomicLong
extends Number
implements Serializable
    A long可能原子更新的值。 有关原子访问属性的说明，请参阅VarHandle规范。 一个AtomicLong用于诸如原子增量序列号的应用中，不能用作Long的替代品。 但是，这个类确实扩展了Number以允许使用基于数字类的工具和实用程序的统一访问。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicLong​()
      创建一个新的AtomicLong，初始值为 0 。
      AtomicLong​(long initialValue)
      用给定的初始值创建一个新的AtomicLong。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      long accumulateAndGet​(long x, LongBinaryOperator accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值的原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回更新后的值。
      long addAndGet​(long delta)
      原始地将给定的值添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
      long compareAndExchange​(long expectedValue, long newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。
      long compareAndExchangeAcquire​(long expectedValue, long newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
      long compareAndExchangeRelease​(long expectedValue, long newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。
      boolean compareAndSet​(long expectedValue, long newValue)
      原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。
      long decrementAndGet​()
      按照 VarHandle.getAndAdd(java.lang.Object...)所规定的内存效果原子递减当前值。
      double doubleValue​()
      返回此的当前值 AtomicLong作为 double加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
      float floatValue​()
      返回此的当前值 AtomicLong作为 float加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
      long get​()
      返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
      long getAcquire​()
      返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
      long getAndAccumulate​(long x, LongBinaryOperator accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回上一个值。
      long getAndAdd​(long delta)
      将给定的值原子地添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
      long getAndDecrement​()
      按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果原子递减当前值。
      long getAndIncrement​()
      按照 VarHandle.getAndAdd(java.lang.Object...)所规定的内存效果原则上增加当前值。
      long getAndSet​(long newValue)
      将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。
      long getAndUpdate​(LongUnaryOperator updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。
      long getOpaque​()
      返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
      long getPlain​()
      返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。
      long incrementAndGet​()
      按照 VarHandle.getAndAdd(java.lang.Object...)规定的内存效果，原子地增加当前值。
      int intValue​()
      返回此的当前值 AtomicLong作为 int如通过指定一个基本收缩转换之后，与记忆效应 VarHandle.getVolatile(java.lang.Object...) 。
      void lazySet​(long newValue)
      将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      long longValue​()
      将 AtomicLong的当前值作为 long ，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
      void set​(long newValue)
      将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
      void setOpaque​(long newValue)
      将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
      void setPlain​(long newValue)
      将值设置为 newValue ，具有设置的内存语义，就像该变量被声明为非 volatile final 。
      void setRelease​(long newValue)
      将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      String toString​()
      返回当前值的String表示形式。
      long updateAndGet​(LongUnaryOperator updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      boolean weakCompareAndSet​(long expectedValue, long newValue)
      已过时。
      该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(long, long)和compareAndSet(long, long) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(long, long) 。
      boolean weakCompareAndSetAcquire​(long expectedValue, long newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
      boolean weakCompareAndSetPlain​(long expectedValue, long newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
      boolean weakCompareAndSetRelease​(long expectedValue, long newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
      boolean weakCompareAndSetVolatile​(long expectedValue, long newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。

      • Methods inherited from class java.lang.Number

        byteValue, shortValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AtomicLong

        public AtomicLong​(long initialValue)
        用给定的初始值创建一个新的AtomicLong。
        参数
        initialValue - 初始值

      • AtomicLong

        public AtomicLong​()
        创建一个新的AtomicLong，初始值为 0 。

    • 方法详细信息

      • get

        public final long get​()
        返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
        结果
        当前值

      • set

        public final void set​(long newValue)
        将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新价值

      • lazySet

        public final void lazySet​(long newValue)
        将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        1.6

      • getAndSet

        public final long getAndSet​(long newValue)
        将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        结果
        以前的值

      • compareAndSet

        public final boolean compareAndSet​(long expectedValue,
                                   long newValue)
        原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功。 False return表示实际值不等于预期值。

      • weakCompareAndSet

        @Deprecated(since="9")
public final boolean weakCompareAndSet​(long expectedValue,
                                       long newValue)
        已过时。 该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(long, long)和compareAndSet(long, long) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(long, long) 。
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        另请参见：
        weakCompareAndSetPlain(long, long)

      • weakCompareAndSetPlain

        public final boolean weakCompareAndSetPlain​(long expectedValue,
                                            long newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • getAndIncrement

        public final long getAndIncrement​()
        用VarHandle.getAndAdd(java.lang.Object...)指定的内存效果原子地增加当前值。

        相当于getAndAdd(1) 。

        结果
        以前的值

      • getAndDecrement

        public final long getAndDecrement​()
        按照VarHandle.getAndAdd(java.lang.Object...)指定的内存效应原子递减当前值。

        相当于getAndAdd(-1) 。

        结果
        以前的值

      • getAndAdd

        public final long getAndAdd​(long delta)
        原始地将给定值添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
        参数
        delta - 要添加的值
        结果
        以前的值

      • incrementAndGet

        public final long incrementAndGet​()
        用VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子地增加当前值。

        相当于addAndGet(1) 。

        结果
        更新的值

      • decrementAndGet

        public final long decrementAndGet​()
        按照VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子递减当前值。

        相当于addAndGet(-1) 。

        结果
        更新的值

      • addAndGet

        public final long addAndGet​(long delta)
        原始地将给定的值添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的记忆效应。
        参数
        delta - 要添加的值
        结果
        更新的值

      • getAndUpdate

        public final long getAndUpdate​(LongUnaryOperator updateFunction)
        使用给定函数的结果对当前值进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        updateFunction - 无副作用的功能
        结果
        以前的值
        从以下版本开始：
        1.8

      • updateAndGet

        public final long updateAndGet​(LongUnaryOperator updateFunction)
        使用给定函数的结果对当前值进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        updateFunction - 无副作用的功能
        结果
        更新的值
        从以下版本开始：
        1.8

      • getAndAccumulate

        public final long getAndAccumulate​(long x,
                                   LongBinaryOperator accumulatorFunction)
        将当前值与给定函数应用于当前值和给定值的原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        以前的值
        从以下版本开始：
        1.8

      • accumulateAndGet

        public final long accumulateAndGet​(long x,
                                   LongBinaryOperator accumulatorFunction)
        将当前值与给定函数应用于当前值和给定值的原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回更新后的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        x - 更新值
        accumulatorFunction - 两个参数的无效函数
        结果
        更新的值
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回当前值的String表示形式。
        重写：
        toString在 Object
        结果
        当前值的String表示形式

      • intValue

        public int intValue​()
        在 int之后返回 AtomicLong的当前值，作为 int ，在缩小的原始转换后，具有 VarHandle.getVolatile(java.lang.Object...)规定的记忆效应。
        Specified by:
        intValue在 Number
        结果
        该对象在转换为 int之后表示的数值。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • longValue

        public long longValue​()
        将AtomicLong的当前值作为long ，其记忆效应由VarHandle.getVolatile(java.lang.Object...)指定。 相当于get() 。
        Specified by:
        longValue在 Number
        结果
        该对象在转换为 long之后表示的数值。

      • floatValue

        public float floatValue​()
        返回此的当前值 AtomicLong作为 float加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
        Specified by:
        floatValue在 Number
        结果
        该对象在转换为 float之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • doubleValue

        public double doubleValue​()
        返回此的当前值 AtomicLong作为 double加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
        Specified by:
        doubleValue在 Number
        结果
        该对象在转换为 double类型后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • getPlain

        public final long getPlain​()
        返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。
        结果
        价值
        从以下版本开始：
        9

      • setPlain

        public final void setPlain​(long newValue)
        将值设置为 newValue ，具有设置的内存语义，就像该变量被宣告为非 volatile final 。
        参数
        newValue - 新价值
        从以下版本开始：
        9

      • getOpaque

        public final long getOpaque​()
        返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
        结果
        价值
        从以下版本开始：
        9

      • setOpaque

        public final void setOpaque​(long newValue)
        将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • getAcquire

        public final long getAcquire​()
        返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的记忆效应。
        结果
        价值
        从以下版本开始：
        9

      • setRelease

        public final void setRelease​(long newValue)
        将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • compareAndExchange

        public final long compareAndExchange​(long expectedValue,
                                     long newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新的价值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeAcquire

        public final long compareAndExchangeAcquire​(long expectedValue,
                                            long newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeRelease

        public final long compareAndExchangeRelease​(long expectedValue,
                                            long newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • weakCompareAndSetVolatile

        public final boolean weakCompareAndSetVolatile​(long expectedValue,
                                               long newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetAcquire

        public final boolean weakCompareAndSetAcquire​(long expectedValue,
                                              long newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetRelease

        public final boolean weakCompareAndSetRelease​(long expectedValue,
                                              long newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicLongArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicLongArray

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicLongArray
  • All Implemented Interfaces:
    Serializable

    public class AtomicLongArray
extends Object
implements Serializable
    其中元素可以原子更新的long数组。 有关原子访问属性的说明，请参阅VarHandle规范。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicLongArray​(int length)
      创建给定长度的新AtomicLongArray，所有元素最初为零。
      AtomicLongArray​(long[] array)
      创建一个与原始数组相同长度的新的AtomicLongArray，并复制所有元素。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      long accumulateAndGet​(int i, long x, LongBinaryOperator accumulatorFunction)
      将索引号为 i的元素进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），并将给定的函数应用于当前值和给定值，返回更新后的值。
      long addAndGet​(int i, long delta)
      原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的记忆效应。
      long compareAndExchange​(int i, long expectedValue, long newValue)
      如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchange(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
      long compareAndExchangeAcquire​(int i, long expectedValue, long newValue)
      如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchangeAcquire(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
      long compareAndExchangeRelease​(int i, long expectedValue, long newValue)
      如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchangeRelease(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
      boolean compareAndSet​(int i, long expectedValue, long newValue)
      如果元素的当前值 == expectedValue具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果，则将索引 i为 newValue的元素原子设置为 newValue 。
      long decrementAndGet​(int i)
      原子递减元件的索引值 i如通过指定，记忆效应 VarHandle.getAndAdd(java.lang.Object...) 。
      long get​(int i)
      返回索引号为 i的元素的当前值，其记忆效应由 VarHandle.getVolatile(java.lang.Object...)指定。
      long getAcquire​(int i)
      返回索引号为 i的元素的当前值，由 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
      long getAndAccumulate​(int i, long x, LongBinaryOperator accumulatorFunction)
      原始更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回上一个值。
      long getAndAdd​(int i, long delta)
      原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的记忆效应。
      long getAndDecrement​(int i)
      原子递减元件的索引值 i如通过指定，记忆效应 VarHandle.getAndAdd(java.lang.Object...) 。
      long getAndIncrement​(int i)
      原子递增元件的索引值 i如通过指定，记忆效应 VarHandle.getAndAdd(java.lang.Object...) 。
      long getAndSet​(int i, long newValue)
      将索引 i为 newValue的元素原子设置为 newValue并返回具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果的旧值。
      long getAndUpdate​(int i, LongUnaryOperator updateFunction)
      用索引号为 i的元素进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），并使用给定函数的结果返回上一个值。
      long getOpaque​(int i)
      返回索引号为 i的元素的当前值，具有由 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
      long getPlain​(int i)
      返回索引号为 i的元素的当前值，读取的内存语义就好像变量被声明为非 volatile 。
      long incrementAndGet​(int i)
      按照 VarHandle.getAndAdd(java.lang.Object...)指定的记忆效应，原子地增加索引号为 i的元素的值。
      void lazySet​(int i, long newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      int length​()
      返回数组的长度。
      void set​(int i, long newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
      void setOpaque​(int i, long newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
      void setPlain​(int i, long newValue)
      将索引 i为 newValue的元素设置为 newValue ，其内存语义设置为该变量未声明为 volatile ， final 。
      void setRelease​(int i, long newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      String toString​()
      返回数组的当前值的String表示形式。
      long updateAndGet​(int i, LongUnaryOperator updateFunction)
      使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      boolean weakCompareAndSet​(int i, long expectedValue, long newValue)
      已过时。
      该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(int, long, long)和compareAndSet(int, long, long) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(int, long, long) 。
      boolean weakCompareAndSetAcquire​(int i, long expectedValue, long newValue)
      如果元素的当前值 == expectedValue具有 VarHandle.weakCompareAndSetAcquire(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
      boolean weakCompareAndSetPlain​(int i, long expectedValue, long newValue)
      如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
      boolean weakCompareAndSetRelease​(int i, long expectedValue, long newValue)
      可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
      boolean weakCompareAndSetVolatile​(int i, long expectedValue, long newValue)
      如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSet(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AtomicLongArray

        public AtomicLongArray​(int length)
        创建给定长度的新AtomicLongArray，所有元素最初为零。
        参数
        length - 数组的长度

      • AtomicLongArray

        public AtomicLongArray​(long[] array)
        创建一个与原始数组相同长度的新的AtomicLongArray，并复制所有元素。
        参数
        array - 从中复制元素的数组
        异常
        NullPointerException - 如果数组为空

    • 方法详细信息

      • length

        public final int length​()
        返回数组的长度。
        结果
        数组的长度

      • get

        public final long get​(int i)
        返回索引号为 i的元素的当前值，由 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
        参数
        i - 指数
        结果
        当前值

      • set

        public final void set​(int i,
                      long newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新价值

      • lazySet

        public final void lazySet​(int i,
                          long newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        1.6

      • getAndSet

        public final long getAndSet​(int i,
                            long newValue)
        将索引 i为 newValue的元素原子设置为 newValue并返回具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果的旧值。
        参数
        i - 索引
        newValue - 新值
        结果
        以前的值

      • compareAndSet

        public final boolean compareAndSet​(int i,
                                   long expectedValue,
                                   long newValue)
        如果元素的当前值 == expectedValue具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果，则将索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功。 False return表示实际值不等于预期值。

      • weakCompareAndSet

        @Deprecated(since="9")
public final boolean weakCompareAndSet​(int i,
                                       long expectedValue,
                                       long newValue)
        已过时。 该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(int, long, long)和compareAndSet(int, long, long) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法weakCompareAndSetPlain(int, long, long) 。
        如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        另请参见：
        weakCompareAndSetPlain(int, long, long)

      • weakCompareAndSetPlain

        public final boolean weakCompareAndSetPlain​(int i,
                                            long expectedValue,
                                            long newValue)
        如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • getAndIncrement

        public final long getAndIncrement​(int i)
        原子递增元件的索引值i如通过指定，记忆效应VarHandle.getAndAdd(java.lang.Object...) 。

        相当于getAndAdd(i, 1) 。

        参数
        i - 索引
        结果
        以前的值

      • getAndDecrement

        public final long getAndDecrement​(int i)
        原子递减元件的索引值i如通过指定，记忆效应VarHandle.getAndAdd(java.lang.Object...) 。

        相当于getAndAdd(i, -1) 。

        参数
        i - 索引
        结果
        以前的值

      • getAndAdd

        public final long getAndAdd​(int i,
                            long delta)
        原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的记忆效应。
        参数
        i - 索引
        delta - 要添加的值
        结果
        以前的值

      • incrementAndGet

        public final long incrementAndGet​(int i)
        原子递增元件的索引值i如通过指定，记忆效应VarHandle.getAndAdd(java.lang.Object...) 。

        相当于addAndGet(i, 1) 。

        参数
        i - 索引
        结果
        更新的值

      • decrementAndGet

        public final long decrementAndGet​(int i)
        原子递减元件的索引值i如通过指定，记忆效应VarHandle.getAndAdd(java.lang.Object...) 。

        相当于addAndGet(i, -1) 。

        参数
        i - 指数
        结果
        更新的值

      • addAndGet

        public long addAndGet​(int i,
                      long delta)
        原子地将给定值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        delta - 要添加的值
        结果
        更新的值

      • getAndUpdate

        public final long getAndUpdate​(int i,
                               LongUnaryOperator updateFunction)
        使用索引i的元素与应用给定函数的结果进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        i - 索引
        updateFunction - 无副作用的功能
        结果
        以前的值
        从以下版本开始：
        1.8

      • updateAndGet

        public final long updateAndGet​(int i,
                               LongUnaryOperator updateFunction)
        使用索引i的元素与应用给定函数的结果进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        i - 索引
        updateFunction - 无副作用的功能
        结果
        更新的值
        从以下版本开始：
        1.8

      • getAndAccumulate

        public final long getAndAccumulate​(int i,
                                   long x,
                                   LongBinaryOperator accumulatorFunction)
        原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效应）索引号为i的元素，并将给定函数应用于当前值和给定值，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数以索引i作为其第一个参数的元素的当前值应用，给定更新作为第二个参数。
        参数
        i - 索引
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        以前的值
        从以下版本开始：
        1.8

      • accumulateAndGet

        public final long accumulateAndGet​(int i,
                                   long x,
                                   LongBinaryOperator accumulatorFunction)
        将索引号为i的元素原子更新（由VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），并将给定的函数应用于当前值和给定值，返回更新后的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用索引i为i的元素的当前值作为其第一个参数，给定更新作为第二个参数。
        参数
        i - 指数
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        更新的值
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回数组的当前值的String表示形式。
        重写：
        toString在 Object
        结果
        数组的当前值的String表示形式

      • getPlain

        public final long getPlain​(int i)
        返回索引号为 i的元素的当前值，读取的内存语义就好像变量被声明为非 volatile 。
        参数
        i - 指数
        结果
        价值
        从以下版本开始：
        9

      • setPlain

        public final void setPlain​(int i,
                           long newValue)
        将索引 i为 newValue的元素设置为 newValue ，其内存语义设置为该变量被声明为非 volatile final 。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        9

      • getOpaque

        public final long getOpaque​(int i)
        返回索引号为 i的元素的当前值，由 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        结果
        价值
        从以下版本开始：
        9

      • setOpaque

        public final void setOpaque​(int i,
                            long newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        9

      • getAcquire

        public final long getAcquire​(int i)
        返回索引号为 i的元素的当前值，具有由 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        结果
        价值
        从以下版本开始：
        9

      • setRelease

        public final void setRelease​(int i,
                             long newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        9

      • compareAndExchange

        public final long compareAndExchange​(int i,
                                     long expectedValue,
                                     long newValue)
        如果元素的当前值，被称为 见证值 == expectedValue ，具有由 VarHandle.compareAndExchange(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 i 。
        参数
        i - 索引
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeAcquire

        public final long compareAndExchangeAcquire​(int i,
                                            long expectedValue,
                                            long newValue)
        如果元素的当前值，称为 见证值 == expectedValue ，具有由 VarHandle.compareAndExchangeAcquire(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeRelease

        public final long compareAndExchangeRelease​(int i,
                                            long expectedValue,
                                            long newValue)
        如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchangeRelease(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • weakCompareAndSetVolatile

        public final boolean weakCompareAndSetVolatile​(int i,
                                               long expectedValue,
                                               long newValue)
        如果元素的当前值为 == expectedValue ，具有 VarHandle.weakCompareAndSet(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetAcquire

        public final boolean weakCompareAndSetAcquire​(int i,
                                              long expectedValue,
                                              long newValue)
        如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetAcquire(java.lang.Object...)指定的记忆效应，则可以原子地将索引 i为 newValue的元素设置为 newValue 。
        参数
        i - 指数
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetRelease

        public final boolean weakCompareAndSetRelease​(int i,
                                              long expectedValue,
                                              long newValue)
        如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetRelease(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子地设置为 newValue 。
        参数
        i - 索引
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicLongFieldUpdater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicLongFieldUpdater<T>

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicLongFieldUpdater<T>
  • 参数类型
    T - 持有可更新字段的对象的类型

    public abstract class AtomicLongFieldUpdater<T>
extends Object
    基于反射的实用程序，可以对指定类的指定的volatile long字段进行原子更新。 该类设计用于原子数据结构，其中同一节点的多个字段独立受原子更新的影响。

    请注意， compareAndSet中的compareAndSet方法的保证弱于其他原子类。 因为这个类不能确保该字段的所有用途都适用于原子访问的目的，所以它可以保证在相同更新程序上的compareAndSet和set其他调用的原子性。

    类型为T参数的对象参数不是传递给newUpdater(java.lang.Class<U>, java.lang.String)的类的实例将导致抛出ClassCastException 。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AtomicLongFieldUpdater​()
      受保护的do-nothing构造函数供子类使用。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      long accumulateAndGet​(T obj, long x, LongBinaryOperator accumulatorFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。
      long addAndGet​(T obj, long delta)
      将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
      abstract boolean compareAndSet​(T obj, long expect, long update)
      如果当前值为 == ，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。
      long decrementAndGet​(T obj)
      由该更新程序管理的给定对象的字段的当前值原子减1。
      abstract long get​(T obj)
      返回由此更新程序管理的给定对象的字段中保留的当前值。
      long getAndAccumulate​(T obj, long x, LongBinaryOperator accumulatorFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。
      long getAndAdd​(T obj, long delta)
      将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
      long getAndDecrement​(T obj)
      由该更新程序管理的给定对象的字段的当前值原子减1。
      long getAndIncrement​(T obj)
      由此更新程序管理的给定对象的字段的当前值以原子方式递增1。
      long getAndSet​(T obj, long newValue)
      将由此更新程序管理的给定对象的字段原子设置为给定值，并返回旧值。
      long getAndUpdate​(T obj, LongUnaryOperator updateFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新器管理的给定对象的字段与应用给定函数的结果，返回上一个值。
      long incrementAndGet​(T obj)
      由此更新程序管理的给定对象的字段的当前值以原子方式递增1。
      abstract void lazySet​(T obj, long newValue)
      最终将由此更新程序管理的给定对象的字段设置为给定的更新值。
      static <U> AtomicLongFieldUpdater<U> newUpdater​(Class<U> tclass, String fieldName)
      创建并返回具有给定字段的对象的更新程序。
      abstract void set​(T obj, long newValue)
      将由此更新程序管理的给定对象的字段设置为给定的更新值。
      long updateAndGet​(T obj, LongUnaryOperator updateFunction)
      原始更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回更新的值。
      abstract boolean weakCompareAndSet​(T obj, long expect, long update)
      如果当前值为 == ，则将此更新程序管理的给定对象的字段原子设置为给定的更新值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AtomicLongFieldUpdater

        protected AtomicLongFieldUpdater​()
        受保护的do-nothing构造函数供子类使用。

    • 方法详细信息

      • newUpdater

        public static <U> AtomicLongFieldUpdater<U> newUpdater​(Class<U> tclass,
                                                       String fieldName)
        创建并返回具有给定字段的对象的更新程序。 需要Class参数来检查反射类型和泛型类型是否匹配。
        参数类型
        U - tclass的实例的类型
        参数
        tclass - 持有该字段的对象的类
        fieldName - 要更新的字段的名称
        结果
        更新者
        异常
        IllegalArgumentException - 如果字段不是易失性长类型
        RuntimeException - 如果类不保留字段或错误的类型，或者根据Java语言访问控制，该调用者无法访问该字段， RuntimeException使用嵌套的基于反射的异常

      • compareAndSet

        public abstract boolean compareAndSet​(T obj,
                                      long expect,
                                      long update)
        如果当前值==为预期值，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。 相对于其他对compareAndSet和set调用，该方法保证是原子的，但不一定与本领域的其他更改相关。
        参数
        obj - 有条件设置字段的对象
        expect - 期望值
        update - 新值
        结果
        true如果成功

      • weakCompareAndSet

        public abstract boolean weakCompareAndSet​(T obj,
                                          long expect,
                                          long update)
        如果当前值==为预期值，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。 相对于其他对compareAndSet和set调用，该方法保证是原子的，但不一定与该字段中的其他更改相关。

        May fail spuriously and does not provide ordering guarantees ，所以很少适合替代compareAndSet 。

        参数
        obj - 有条件地设置其字段的对象
        expect - 预期值
        update - 新值
        结果
        true如果成功

      • set

        public abstract void set​(T obj,
                         long newValue)
        将由此更新程序管理的给定对象的字段设置为给定的更新值。 该操作被保证作为关于随后调用的易失性存储器compareAndSet 。
        参数
        obj - 要设置的字段的对象
        newValue - 新值

      • lazySet

        public abstract void lazySet​(T obj,
                             long newValue)
        最终将由此更新程序管理的给定对象的字段设置为给定的更新值。
        参数
        obj - 要设置的字段的对象
        newValue - 新值
        从以下版本开始：
        1.6

      • get

        public abstract long get​(T obj)
        返回由此更新程序管理的给定对象的字段中保留的当前值。
        参数
        obj - 要获取字段的对象
        结果
        当前值

      • getAndSet

        public long getAndSet​(T obj,
                      long newValue)
        将由此更新程序管理的给定对象的字段原子设置为给定值，并返回旧值。
        参数
        obj - 要获取和设置的字段的对象
        newValue - 新值
        结果
        以前的值

      • getAndIncrement

        public long getAndIncrement​(T obj)
        由此更新程序管理的给定对象的字段的当前值以原子方式递增1。
        参数
        obj - 要获取和设置的字段的对象
        结果
        以前的值

      • getAndDecrement

        public long getAndDecrement​(T obj)
        由该更新程序管理的给定对象的字段的当前值原子减1。
        参数
        obj - 要获取和设置的字段的对象
        结果
        以前的值

      • getAndAdd

        public long getAndAdd​(T obj,
                      long delta)
        将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
        参数
        obj - 一个要获取和设置的字段的对象
        delta - 要添加的值
        结果
        以前的值

      • incrementAndGet

        public long incrementAndGet​(T obj)
        由此更新程序管理的给定对象的字段的当前值以原子方式递增1。
        参数
        obj - 一个要获取和设置的字段的对象
        结果
        更新的值

      • decrementAndGet

        public long decrementAndGet​(T obj)
        由该更新程序管理的给定对象的字段的当前值原子减1。
        参数
        obj - 要获取和设置的字段的对象
        结果
        更新的值

      • addAndGet

        public long addAndGet​(T obj,
                      long delta)
        将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
        参数
        obj - 要获取和设置的字段的对象
        delta - 要添加的值
        结果
        更新的值

      • getAndUpdate

        public final long getAndUpdate​(T obj,
                               LongUnaryOperator updateFunction)
        原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        obj - 要获取和设置的字段的对象
        updateFunction - 无副作用的功能
        结果
        以前的值
        从以下版本开始：
        1.8

      • updateAndGet

        public final long updateAndGet​(T obj,
                               LongUnaryOperator updateFunction)
        原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回更新的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        obj - 一个要获取和设置的字段的对象
        updateFunction - 无副作用的功能
        结果
        更新的值
        从以下版本开始：
        1.8

      • getAndAccumulate

        public final long getAndAccumulate​(T obj,
                                   long x,
                                   LongBinaryOperator accumulatorFunction)
        原始更新（由VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        obj - 要获取和设置的字段的对象
        x - 更新值
        accumulatorFunction - 两个参数的无副作用的函数
        结果
        以前的值
        从以下版本开始：
        1.8

      • accumulateAndGet

        public final long accumulateAndGet​(T obj,
                                   long x,
                                   LongBinaryOperator accumulatorFunction)
        原子更新（由VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        obj - 一个要获取和设置的字段的对象
        x - 更新值
        accumulatorFunction - 两个参数的无副作用函数
        结果
        更新的值
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicMarkableReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicMarkableReference<V>

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicMarkableReference<V>
  • 参数类型
    V - 此引用引用的对象的类型

    public class AtomicMarkableReference<V>
extends Object
    一个AtomicMarkableReference维护一个对象引用以及可以原子更新的标记位。

    实现注意：此实现通过创建表示“boxed”[引用，布尔]对的内部对象来维护可标记引用。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicMarkableReference​(V initialRef, boolean initialMark)
      用给定的初始值创建一个新的 AtomicMarkableReference 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean attemptMark​(V expectedReference, boolean newMark)
      如果当前引用为预期引用的 == ，则将标记的值原子设置为给定的更新值。
      boolean compareAndSet​(V expectedReference, V newReference, boolean expectedMark, boolean newMark)
      如果当前引用为预期引用的 ==并且当前标记等于预期标记，则将引用和标记的值原子设置为给定更新值。
      V get​(boolean[] markHolder)
      返回引用和标记的当前值。
      V getReference​()
      返回引用的当前值。
      boolean isMarked​()
      返回标记的当前值。
      void set​(V newReference, boolean newMark)
      无条件地设置引用和标记的值。
      boolean weakCompareAndSet​(V expectedReference, V newReference, boolean expectedMark, boolean newMark)
      如果当前引用为期望引用的 == ，并且当前标记等于预期标记，则将引用和标记的值原子设置为给定更新值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AtomicMarkableReference

        public AtomicMarkableReference​(V initialRef,
                               boolean initialMark)
        创建一个新的 AtomicMarkableReference与给定的初始值。
        参数
        initialRef - 初始参考
        initialMark - 初始标记

    • 方法详细信息

      • getReference

        public V getReference​()
        返回引用的当前值。
        结果
        当前值的参考

      • isMarked

        public boolean isMarked​()
        返回标记的当前值。
        结果
        当前的商标值

      • get

        public V get​(boolean[] markHolder)
        返回引用和标记的当前值。 典型用法是boolean[1] holder; ref = v.get(holder); 。
        参数
        markHolder - 至少有一个大小的数组。 回报时， markHolder[0]将持有该商标的价值。
        结果
        当前值的参考

      • weakCompareAndSet

        public boolean weakCompareAndSet​(V expectedReference,
                                 V newReference,
                                 boolean expectedMark,
                                 boolean newMark)
        如果当前引用为期望引用的==并且当前标记等于预期标记，则将引用和标记的值原子设置为给定的更新值。

        May fail spuriously and does not provide ordering guarantees ，所以很少适合替代compareAndSet 。

        参数
        expectedReference - 参考的预期值
        newReference - 参考的新值
        expectedMark - 商标的预期价值
        newMark - 标记的新值
        结果
        true如果成功

      • compareAndSet

        public boolean compareAndSet​(V expectedReference,
                             V newReference,
                             boolean expectedMark,
                             boolean newMark)
        如果当前引用为预期引用的 == ，并且当前标记等于预期标记，则将引用和标记的值原子设置为给定更新值。
        参数
        expectedReference - 参考的预期值
        newReference - 参考的新值
        expectedMark - 商标的预期价值
        newMark - 标记的新值
        结果
        true如果成功

      • set

        public void set​(V newReference,
                boolean newMark)
        无条件地设置引用和标记的值。
        参数
        newReference - 参考的新值
        newMark - 标记的新值

      • attemptMark

        public boolean attemptMark​(V expectedReference,
                           boolean newMark)
        如果当前引用为期望引用的== ，则将标记的值原子设置为给定的更新值。 任何给定的此操作调用可能会发生错误的返回（返回false ），但是当当前值保持预期值并且没有其他线程也尝试设置该值将最终成功时重复调用。
        参数
        expectedReference - 参考的预期值
        newMark - 标记的新值
        结果
        true如果成功
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicReference<V>

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicReference<V>
  • 参数类型
    V - 此引用引用的对象的类型
    All Implemented Interfaces:
    Serializable

    public class AtomicReference<V>
extends Object
implements Serializable
    可以原子更新的对象引用。 有关原子访问属性的说明，请参阅VarHandle规范。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicReference​()
      使用null初始值创建新的AtomicReference。
      AtomicReference​(V initialValue)
      用给定的初始值创建一个新的AtomicReference。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      V accumulateAndGet​(V x, BinaryOperator<V> accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值的原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回更新后的值。
      V compareAndExchange​(V expectedValue, V newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。
      V compareAndExchangeAcquire​(V expectedValue, V newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
      V compareAndExchangeRelease​(V expectedValue, V newValue)
      原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。
      boolean compareAndSet​(V expectedValue, V newValue)
      如果当前值为 == expectedValue ， newValue设置为 == expectedValue ，具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果。
      V get​()
      返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
      V getAcquire​()
      返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
      V getAndAccumulate​(V x, BinaryOperator<V> accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值的原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回上一个值。
      V getAndSet​(V newValue)
      将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)所指定的内存效果。
      V getAndUpdate​(UnaryOperator<V> updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。
      V getOpaque​()
      返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
      V getPlain​()
      返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。
      void lazySet​(V newValue)
      将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      void set​(V newValue)
      将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
      void setOpaque​(V newValue)
      将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
      void setPlain​(V newValue)
      将值设置为 newValue ，具有设置的内存语义，就像该变量被声明为非 volatile final 。
      void setRelease​(V newValue)
      将值设置为 newValue ，其记忆效应由 VarHandle.setRelease(java.lang.Object...)指定。
      String toString​()
      返回当前值的String表示形式。
      V updateAndGet​(UnaryOperator<V> updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      boolean weakCompareAndSet​(V expectedValue, V newValue)
      已过时。
      该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(V, V)和compareAndSet(V, V) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(V, V) 。
      boolean weakCompareAndSetAcquire​(V expectedValue, V newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
      boolean weakCompareAndSetPlain​(V expectedValue, V newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
      boolean weakCompareAndSetRelease​(V expectedValue, V newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
      boolean weakCompareAndSetVolatile​(V expectedValue, V newValue)
      可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AtomicReference

        public AtomicReference​(V initialValue)
        用给定的初始值创建一个新的AtomicReference。
        参数
        initialValue - 初始值

      • AtomicReference

        public AtomicReference​()
        使用null初始值创建新的AtomicReference。

    • 方法详细信息

      • get

        public final V get​()
        返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
        结果
        当前值

      • set

        public final void set​(V newValue)
        将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值

      • lazySet

        public final void lazySet​(V newValue)
        将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        1.6

      • compareAndSet

        public final boolean compareAndSet​(V expectedValue,
                                   V newValue)
        如果当前值为 == expectedValue ， newValue设置为 == expectedValue ，具有由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功。 False return表示实际值不等于预期值。

      • weakCompareAndSet

        @Deprecated(since="9")
public final boolean weakCompareAndSet​(V expectedValue,
                                       V newValue)
        已过时。 该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如compareAndExchange(V, V)和compareAndSet(V, V) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法weakCompareAndSetPlain(V, V) 。
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新的价值
        结果
        true如果成功
        另请参见：
        weakCompareAndSetPlain(V, V)

      • weakCompareAndSetPlain

        public final boolean weakCompareAndSetPlain​(V expectedValue,
                                            V newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • getAndSet

        public final V getAndSet​(V newValue)
        将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新价值
        结果
        以前的值

      • getAndUpdate

        public final V getAndUpdate​(UnaryOperator<V> updateFunction)
        使用给定函数的结果对当前值进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        updateFunction - 无副作用的功能
        结果
        以前的值
        从以下版本开始：
        1.8

      • updateAndGet

        public final V updateAndGet​(UnaryOperator<V> updateFunction)
        使用给定函数的结果对当前值进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回更新的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        updateFunction - 无副作用的功能
        结果
        更新的值
        从以下版本开始：
        1.8

      • getAndAccumulate

        public final V getAndAccumulate​(V x,
                                BinaryOperator<V> accumulatorFunction)
        将当前值与给定函数应用于当前值和给定值进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        x - 更新值
        accumulatorFunction - 两个参数的无效函数
        结果
        以前的值
        从以下版本开始：
        1.8

      • accumulateAndGet

        public final V accumulateAndGet​(V x,
                                BinaryOperator<V> accumulatorFunction)
        将当前值与给定函数应用于当前值和给定值进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回更新后的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        更新的值
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回当前值的String表示形式。
        重写：
        toString在 Object
        结果
        当前值的String表示形式

      • getPlain

        public final V getPlain​()
        返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。
        结果
        价值
        从以下版本开始：
        9

      • setPlain

        public final void setPlain​(V newValue)
        将值设置为 newValue ，具有设置的内存语义，如同该变量被宣告为非 volatile和非 final 。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • getOpaque

        public final V getOpaque​()
        返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
        结果
        价值
        从以下版本开始：
        9

      • setOpaque

        public final void setOpaque​(V newValue)
        将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • getAcquire

        public final V getAcquire​()
        返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
        结果
        价值
        从以下版本开始：
        9

      • setRelease

        public final void setRelease​(V newValue)
        将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        newValue - 新值
        从以下版本开始：
        9

      • compareAndExchange

        public final V compareAndExchange​(V expectedValue,
                                  V newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeAcquire

        public final V compareAndExchangeAcquire​(V expectedValue,
                                         V newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeRelease

        public final V compareAndExchangeRelease​(V expectedValue,
                                         V newValue)
        原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。
        参数
        expectedValue - 预期值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • weakCompareAndSetVolatile

        public final boolean weakCompareAndSetVolatile​(V expectedValue,
                                               V newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetAcquire

        public final boolean weakCompareAndSetAcquire​(V expectedValue,
                                              V newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetRelease

        public final boolean weakCompareAndSetRelease​(V expectedValue,
                                              V newValue)
        可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
        参数
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicReferenceArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicReferenceArray<E>

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicReferenceArray<E>
  • 参数类型
    E - 在这个数组中保存的元素的基类
    All Implemented Interfaces:
    Serializable

    public class AtomicReferenceArray<E>
extends Object
implements Serializable
    可以以原子方式更新元素的对象引用数组。 有关原子访问属性的说明，请参阅VarHandle规范。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicReferenceArray​(int length)
      创建给定长度的新AtomicReferenceArray，所有元素最初为null。
      AtomicReferenceArray​(E[] array)
      创建一个与原始数组相同的长度和所有元素的AtomicReferenceArray。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      E accumulateAndGet​(int i, E x, BinaryOperator<E> accumulatorFunction)
      将索引号为 i的元素原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），并将给定的函数应用于当前值和给定值，返回更新后的值。
      E compareAndExchange​(int i, E expectedValue, E newValue)
      如果元素的当前值，被称为 见证值 == expectedValue ，具有由 VarHandle.compareAndExchange(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 i 。
      E compareAndExchangeAcquire​(int i, E expectedValue, E newValue)
      以原子方式设置在索引元件 i到 newValue如果该元素的当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。
      E compareAndExchangeRelease​(int i, E expectedValue, E newValue)
      以原子方式设置在索引元件 i到 newValue如果该元素的当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。
      boolean compareAndSet​(int i, E expectedValue, E newValue)
      如果元素的当前值为 == expectedValue ，具有由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果，则将索引 i为 newValue的元素原子设置为 newValue 。
      E get​(int i)
      返回索引号为 i的元素的当前值，其值由 VarHandle.getVolatile(java.lang.Object...)指定。
      E getAcquire​(int i)
      返回索引号为 i的元素的当前值，其值由 VarHandle.getAcquire(java.lang.Object...)指定。
      E getAndAccumulate​(int i, E x, BinaryOperator<E> accumulatorFunction)
      原始更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回上一个值。
      E getAndSet​(int i, E newValue)
      将索引 i为 newValue的元素原子设置为 newValue并返回具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果的旧值。
      E getAndUpdate​(int i, UnaryOperator<E> updateFunction)
      使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。
      E getOpaque​(int i)
      返回索引号为 i的元素的当前值，其值由 VarHandle.getOpaque(java.lang.Object...)指定。
      E getPlain​(int i)
      返回索引 i处的元素的当前值，读取的内存语义就好像变量被声明为非 volatile 。
      void lazySet​(int i, E newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      int length​()
      返回数组的长度。
      void set​(int i, E newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
      void setOpaque​(int i, E newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
      void setPlain​(int i, E newValue)
      将索引 i为 newValue的元素设置为 newValue ，其内存语义设置为该变量被声明为非 volatile final 。
      void setRelease​(int i, E newValue)
      将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
      String toString​()
      返回数组的当前值的String表示形式。
      E updateAndGet​(int i, UnaryOperator<E> updateFunction)
      使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      boolean weakCompareAndSet​(int i, E expectedValue, E newValue)
      已过时。
      该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法，如compareAndExchange(int, E, E)和compareAndSet(int, E, E) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(int, E, E) 。
      boolean weakCompareAndSetAcquire​(int i, E expectedValue, E newValue)
      如果元素的当前值为 == expectedValue ，具有 VarHandle.weakCompareAndSetAcquire(java.lang.Object...)指定的记忆效应，则可以将元素的索引 i为 newValue原子设置为 newValue 。
      boolean weakCompareAndSetPlain​(int i, E expectedValue, E newValue)
      如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
      boolean weakCompareAndSetRelease​(int i, E expectedValue, E newValue)
      如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetRelease(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
      boolean weakCompareAndSetVolatile​(int i, E expectedValue, E newValue)
      如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSet(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AtomicReferenceArray

        public AtomicReferenceArray​(int length)
        创建给定长度的新AtomicReferenceArray，所有元素最初为null。
        参数
        length - 数组的长度

      • AtomicReferenceArray

        public AtomicReferenceArray​(E[] array)
        创建一个与原始数组相同的长度和所有元素的AtomicReferenceArray。
        参数
        array - 从中复制元素的数组
        异常
        NullPointerException - 如果数组为空

    • 方法详细信息

      • length

        public final int length​()
        返回数组的长度。
        结果
        数组的长度

      • get

        public final E get​(int i)
        返回索引号为 i的元素的当前值，由 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        结果
        当前值

      • set

        public final void set​(int i,
                      E newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新值

      • lazySet

        public final void lazySet​(int i,
                          E newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        1.6

      • getAndSet

        public final E getAndSet​(int i,
                         E newValue)
        将索引 i为 newValue的元素原子设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新价值
        结果
        以前的值

      • compareAndSet

        public final boolean compareAndSet​(int i,
                                   E expectedValue,
                                   E newValue)
        以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新的价值
        结果
        true如果成功。 False return表示实际值不等于预期值。

      • weakCompareAndSet

        @Deprecated(since="9")
public final boolean weakCompareAndSet​(int i,
                                       E expectedValue,
                                       E newValue)
        已过时。 该方法具有明显的记忆效应，但方法名称意味着易失性记忆效应（参见compareAndExchange(int, E, E)和compareAndSet(int, E, E)等方法）。 为了避免在平常或易失性记忆效应上的混淆，建议使用方法weakCompareAndSetPlain(int, E, E) 。
        可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
        参数
        i - 索引
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        另请参见：
        weakCompareAndSetPlain(int, E, E)

      • weakCompareAndSetPlain

        public final boolean weakCompareAndSetPlain​(int i,
                                            E expectedValue,
                                            E newValue)
        如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • getAndUpdate

        public final E getAndUpdate​(int i,
                            UnaryOperator<E> updateFunction)
        原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为i的元素与应用给定函数的结果，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        i - 索引
        updateFunction - 无副作用的功能
        结果
        以前的值
        从以下版本开始：
        1.8

      • updateAndGet

        public final E updateAndGet​(int i,
                            UnaryOperator<E> updateFunction)
        使用索引i的元素与应用给定函数的结果进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        i - 索引
        updateFunction - 无副作用的功能
        结果
        更新的值
        从以下版本开始：
        1.8

      • getAndAccumulate

        public final E getAndAccumulate​(int i,
                                E x,
                                BinaryOperator<E> accumulatorFunction)
        原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为i的元素，并将给定的函数应用于当前值和给定值，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数以索引i作为其第一个参数的元素的当前值应用，给定的更新作为第二个参数。
        参数
        i - 索引
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        以前的值
        从以下版本开始：
        1.8

      • accumulateAndGet

        public final E accumulateAndGet​(int i,
                                E x,
                                BinaryOperator<E> accumulatorFunction)
        原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为i的元素，并将给定函数应用于当前值和给定值，返回更新后的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数以索引i作为其第一个参数的元素的当前值应用，给定更新作为第二个参数。
        参数
        i - 索引
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        更新的值
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回数组的当前值的String表示形式。
        重写：
        toString在 Object
        结果
        数组的当前值的String表示形式

      • getPlain

        public final E getPlain​(int i)
        返回索引号为 i的元素的当前值，读取的内存语义就好像变量被声明为非 volatile 。
        参数
        i - 索引
        结果
        价值
        从以下版本开始：
        9

      • setPlain

        public final void setPlain​(int i,
                           E newValue)
        将索引 i为 newValue的元素设置为 newValue ，其内存语义设置为该变量被声明为非 volatile final 。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        9

      • getOpaque

        public final E getOpaque​(int i)
        返回索引号为 i的元素的当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        结果
        价值
        从以下版本开始：
        9

      • setOpaque

        public final void setOpaque​(int i,
                            E newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        9

      • getAcquire

        public final E getAcquire​(int i)
        返回索引号为 i的元素的当前值，由 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        结果
        价值
        从以下版本开始：
        9

      • setRelease

        public final void setRelease​(int i,
                             E newValue)
        将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
        参数
        i - 索引
        newValue - 新值
        从以下版本开始：
        9

      • compareAndExchange

        public final E compareAndExchange​(int i,
                                  E expectedValue,
                                  E newValue)
        以原子方式设置在索引元件 i到 newValue如果该元素的当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeAcquire

        public final E compareAndExchangeAcquire​(int i,
                                         E expectedValue,
                                         E newValue)
        如果元素的当前值，被称为 见证值 == expectedValue ，具有由 VarHandle.compareAndExchangeAcquire(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 期望值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • compareAndExchangeRelease

        public final E compareAndExchangeRelease​(int i,
                                         E expectedValue,
                                         E newValue)
        如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchangeRelease(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        见证价值，如果成功，将与预期价值相同
        从以下版本开始：
        9

      • weakCompareAndSetVolatile

        public final boolean weakCompareAndSetVolatile​(int i,
                                               E expectedValue,
                                               E newValue)
        如果元素的当前值 == expectedValue具有 == expectedValue所指定的内存效果，则可能将元素的索引 i为 newValue设置为 newValue 。
        参数
        i - 索引
        expectedValue - 期望值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetAcquire

        public final boolean weakCompareAndSetAcquire​(int i,
                                              E expectedValue,
                                              E newValue)
        如果元素的当前值 == expectedValue具有 VarHandle.weakCompareAndSetAcquire(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
        参数
        i - 索引
        expectedValue - 预期值
        newValue - 新值
        结果
        true如果成功
        从以下版本开始：
        9

      • weakCompareAndSetRelease

        public final boolean weakCompareAndSetRelease​(int i,
                                              E expectedValue,
                                              E newValue)
        如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetRelease(java.lang.Object...)指定的内存效果，则可以将元素的索引 i为 newValue原子设置为 newValue 。
        参数
        i - 指数
        expectedValue - 预期值
        newValue - 新价值
        结果
        true如果成功
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicReferenceFieldUpdater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicReferenceFieldUpdater<T,V>

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicReferenceFieldUpdater<T,V>
  • 参数类型
    T - 持有可更新字段的对象的类型
    V - 字段的类型

    public abstract class AtomicReferenceFieldUpdater<T,V>
extends Object
    基于反射的实用程序，可以对指定类的指定的volatile参考字段进行原子更新。 此类设计用于原子数据结构，其中同一节点的多个引用字段独立受原子更新。 例如，树节点可能被声明为
       class Node { private volatile Node left, right; private static final AtomicReferenceFieldUpdater<Node, Node> leftUpdater = AtomicReferenceFieldUpdater.newUpdater(Node.class, Node.class, "left"); private static AtomicReferenceFieldUpdater<Node, Node> rightUpdater = AtomicReferenceFieldUpdater.newUpdater(Node.class, Node.class, "right"); Node getLeft() { return left; } boolean compareAndSetLeft(Node expect, Node update) { return leftUpdater.compareAndSet(this, expect, update); } // ... and so on }

    请注意， compareAndSet中的compareAndSet方法的保证弱于其他原子类。 因为这个类不能确保该字段的所有用途都适用于原子访问的目的，所以它只能在同一更新程序上compareAndSet和set其他调用的原子性。

    类型为T参数的对象参数不是传递给newUpdater(java.lang.Class<U>, java.lang.Class<W>, java.lang.String)的类的实例将导致抛出ClassCastException 。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AtomicReferenceFieldUpdater​()
      受保护的do-nothing构造函数供子类使用。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      V accumulateAndGet​(T obj, V x, BinaryOperator<V> accumulatorFunction)
      原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。
      abstract boolean compareAndSet​(T obj, V expect, V update)
      如果当前值为 == ，则将此更新程序管理的给定对象的字段设置为给定的更新值。
      abstract V get​(T obj)
      返回由此更新程序管理的给定对象的字段中保留的当前值。
      V getAndAccumulate​(T obj, V x, BinaryOperator<V> accumulatorFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。
      V getAndSet​(T obj, V newValue)
      将由此更新程序管理的给定对象的字段原子设置为给定值，并返回旧值。
      V getAndUpdate​(T obj, UnaryOperator<V> updateFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回上一个值。
      abstract void lazySet​(T obj, V newValue)
      最终将由此更新程序管理的给定对象的字段设置为给定的更新值。
      static <U,W> AtomicReferenceFieldUpdater<U,W> newUpdater​(Class<U> tclass, Class<W> vclass, String fieldName)
      创建并返回具有给定字段的对象的更新程序。
      abstract void set​(T obj, V newValue)
      将由此更新程序管理的给定对象的字段设置为给定的更新值。
      V updateAndGet​(T obj, UnaryOperator<V> updateFunction)
      由更新器管理的给定对象的字段与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      abstract boolean weakCompareAndSet​(T obj, V expect, V update)
      如果当前值为 ==的预期值，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AtomicReferenceFieldUpdater

        protected AtomicReferenceFieldUpdater​()
        受保护的do-nothing构造函数供子类使用。

    • 方法详细信息

      • newUpdater

        public static <U,W> AtomicReferenceFieldUpdater<U,W> newUpdater​(Class<U> tclass,
                                                                Class<W> vclass,
                                                                String fieldName)
        创建并返回具有给定字段的对象的更新程序。 需要Class参数来检查反射类型和通用类型是否匹配。
        参数类型
        U - tclass的实例的类型
        W - W的实例类型
        参数
        tclass - 持有该字段的对象的类
        vclass - 该字段的类
        fieldName - 要更新的字段的名称
        结果
        更新者
        异常
        ClassCastException - 如果该字段的类型错误
        IllegalArgumentException - 如果字段不是挥发性的
        RuntimeException - 如果类不保留字段或错误的类型，或者根据Java语言访问控制，该调用者无法访问该字段， RuntimeException使用嵌套的基于反射的异常

      • compareAndSet

        public abstract boolean compareAndSet​(T obj,
                                      V expect,
                                      V update)
        如果当前值==为预期值，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。 相对于其他对compareAndSet和set调用，该方法保证是原子的，但不一定与本领域的其他更改相关。
        参数
        obj - 有条件地设置其字段的对象
        expect - 预期值
        update - 新的价值
        结果
        true如果成功

      • weakCompareAndSet

        public abstract boolean weakCompareAndSet​(T obj,
                                          V expect,
                                          V update)
        如果当前值==为期望值，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。 相对于其他调用compareAndSet和set ，该方法保证是原子的，但不一定与本领域的其他更改相关。

        May fail spuriously and does not provide ordering guarantees ，所以很少是compareAndSet的适当替代compareAndSet 。

        参数
        obj - 有条件设置字段的对象
        expect - 预期值
        update - 新值
        结果
        true如果成功

      • set

        public abstract void set​(T obj,
                         V newValue)
        将由此更新程序管理的给定对象的字段设置为给定的更新值。 该操作被保证作为关于compareAndSet后续调用的易失性存储。
        参数
        obj - 要设置的字段的对象
        newValue - 新值

      • lazySet

        public abstract void lazySet​(T obj,
                             V newValue)
        最终将由此更新程序管理的给定对象的字段设置为给定的更新值。
        参数
        obj - 要设置的字段的对象
        newValue - 新值
        从以下版本开始：
        1.6

      • get

        public abstract V get​(T obj)
        返回由此更新程序管理的给定对象的字段中保留的当前值。
        参数
        obj - 要获取字段的对象
        结果
        当前值

      • getAndSet

        public V getAndSet​(T obj,
                   V newValue)
        将由此更新程序管理的给定对象的字段原子设置为给定值，并返回旧值。
        参数
        obj - 要获取和设置的字段的对象
        newValue - 新价值
        结果
        以前的值

      • getAndUpdate

        public final V getAndUpdate​(T obj,
                            UnaryOperator<V> updateFunction)
        原始更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        obj - 一个要获取和设置的字段的对象
        updateFunction - 无副作用的功能
        结果
        以前的值
        从以下版本开始：
        1.8

      • updateAndGet

        public final V updateAndGet​(T obj,
                            UnaryOperator<V> updateFunction)
        通过应用给定函数的结果对由此更新程序管理的给定对象的字段进行原子更新（具有VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。
        参数
        obj - 要获取和设置的字段的对象
        updateFunction - 无副作用的功能
        结果
        更新的值
        从以下版本开始：
        1.8

      • getAndAccumulate

        public final V getAndAccumulate​(T obj,
                                V x,
                                BinaryOperator<V> accumulatorFunction)
        原始更新（由VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        obj - 一个要获取和设置的字段的对象
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        以前的值
        从以下版本开始：
        1.8

      • accumulateAndGet

        public final V accumulateAndGet​(T obj,
                                V x,
                                BinaryOperator<V> accumulatorFunction)
        原始更新（由VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。 该功能应该是无副作用的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。
        参数
        obj - 要获取和设置的字段的对象
        x - 更新值
        accumulatorFunction - 两个参数的无效副作用
        结果
        更新的值
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AtomicStampedReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class AtomicStampedReference<V>

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicStampedReference<V>
  • 参数类型
    V - 此引用引用的对象的类型

    public class AtomicStampedReference<V>
extends Object
    一个AtomicStampedReference维护对象引用以及整数“印记”，可以原子更新。

    实现注意事项：此实现通过创建表示“boxed”[引用，整数]对的内部对象来维护加盖引用。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      AtomicStampedReference​(V initialRef, int initialStamp)
      创建一个新的 AtomicStampedReference与给定的初始值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean attemptStamp​(V expectedReference, int newStamp)
      如果当前引用为预期引用的 == ，则将该戳的值原子设置为给定的更新值。
      boolean compareAndSet​(V expectedReference, V newReference, int expectedStamp, int newStamp)
      如果当前引用为预期引用的 == ，并且当前戳等于预期的戳记，则将引用和戳记的值原子设置为给定的更新值。
      V get​(int[] stampHolder)
      返回引用和戳记的当前值。
      V getReference​()
      返回引用的当前值。
      int getStamp​()
      返回邮票的当前值。
      void set​(V newReference, int newStamp)
      无条件地设置引用和戳记的值。
      boolean weakCompareAndSet​(V expectedReference, V newReference, int expectedStamp, int newStamp)
      如果当前参考值为预期参考值的 == ，并且当前印记等于预期的印记，则将引用和标记的值原子设置为给定的更新值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AtomicStampedReference

        public AtomicStampedReference​(V initialRef,
                              int initialStamp)
        创建一个新的 AtomicStampedReference与给定的初始值。
        参数
        initialRef - 初始参考
        initialStamp - 初始邮票

    • 方法详细信息

      • getReference

        public V getReference​()
        返回引用的当前值。
        结果
        当前值的参考

      • getStamp

        public int getStamp​()
        返回邮票的当前值。
        结果
        邮票的当前值

      • get

        public V get​(int[] stampHolder)
        返回引用和戳记的当前值。 典型用法是int[1] holder; ref = v.get(holder); 。
        参数
        stampHolder - 至少有一个大小的数组。 在退货时， stampHolder[0]将持有该邮票的价值。
        结果
        当前值的参考

      • weakCompareAndSet

        public boolean weakCompareAndSet​(V expectedReference,
                                 V newReference,
                                 int expectedStamp,
                                 int newStamp)
        如果当前引用为期望参考值为==并且当前印记等于预期印记，则将引用和印记的值原子设置为给定的更新值。

        May fail spuriously and does not provide ordering guarantees ，所以很少适合替代compareAndSet 。

        参数
        expectedReference - 参考的预期值
        newReference - 参考的新值
        expectedStamp - 邮票的预期值
        newStamp - 邮票的新价值
        结果
        true如果成功

      • compareAndSet

        public boolean compareAndSet​(V expectedReference,
                             V newReference,
                             int expectedStamp,
                             int newStamp)
        如果当前引用为预期引用的 == ，并且当前印记等于预期的印记，则将引用和印记两者的值原子设置为给定的更新值。
        参数
        expectedReference - 参考的预期值
        newReference - 参考的新值
        expectedStamp - 邮票的预期值
        newStamp - 邮票的新值
        结果
        true如果成功

      • set

        public void set​(V newReference,
                int newStamp)
        无条件地设置引用和戳记的值。
        参数
        newReference - 参考的新值
        newStamp - 邮票的新值

      • attemptStamp

        public boolean attemptStamp​(V expectedReference,
                            int newStamp)
        如果当前引用是预期引用的== ，则将该戳记的值原子地设置为给定的更新值。 对此操作的任何给定的调用可能会失败（返回false ），但是当当前值保持预期值并且没有其他线程也尝试设置该值将最终成功时重复调用。
        参数
        expectedReference - 参考的预期值
        newStamp - 邮票的新价值
        结果
        true如果成功
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleAccumulator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class DoubleAccumulator

  • java.lang.Object
    • java.lang.Number
      • java.util.concurrent.atomic.DoubleAccumulator
  • All Implemented Interfaces:
    Serializable

    public class DoubleAccumulator
extends Number
implements Serializable
    一个或多个变量，它们一起保持运行double使用所提供的功能更新值。 当跨线程争用更新（方法accumulate(double) ）时，该变量集可以动态增长以减少争用。 方法get() （或等效地， doubleValue() ）返回维护更新的变量的当前值。

    当多个线程更新用于诸如经常更新但较不频繁读取的摘要统计信息的常用值时，此类通常优于替代方案。

    提供的累加器功能应该是无效的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。 例如，要保持最大值的运行，您可以提供Double::max以及Double.NEGATIVE_INFINITY作为身份。 线程内或跨线程的累积顺序不能保证。 因此，如果需要数值稳定性，特别是当组合几乎不同数量级的值时，该类可能不适用。

    DoubleAdder类提供了类的功能，用于维护和的常见特殊情况。 电话new DoubleAdder()相当于new DoubleAccumulator((x, y) -> x + y, 0.0) 。

    该类扩展Number ，但不定义诸如方法equals ， hashCode和compareTo ，因为实例预计将发生突变，所以不如收集钥匙有用。

    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DoubleAccumulator​(DoubleBinaryOperator accumulatorFunction, double identity)
      使用给定的累加器函数和identity元素创建一个新的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void accumulate​(double x)
      具有给定值的更新。
      double doubleValue​()
      相当于 get() 。
      float floatValue​()
      在缩小原始转换后，返回 current value作为 float 。
      double get​()
      返回当前值。
      double getThenReset​()
      相当于 get()，其次是 reset() 。
      int intValue​()
      在缩小原始转换后，返回 current value作为 int 。
      long longValue​()
      在缩小原始转换后，返回 current value作为 long 。
      void reset​()
      重置维持更新到标识值的变量。
      String toString​()
      返回当前值的String表示形式。

      • Methods inherited from class java.lang.Number

        byteValue, shortValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DoubleAccumulator

        public DoubleAccumulator​(DoubleBinaryOperator accumulatorFunction,
                         double identity)
        使用给定的累加器函数和identity元素创建一个新的实例。
        参数
        accumulatorFunction - 两个参数的无副作用的函数
        identity - 累加器功能的标识（初始值）

    • 方法详细信息

      • accumulate

        public void accumulate​(double x)
        具有给定值的更新。
        参数
        x - 值

      • get

        public double get​()
        返回当前值。 返回的值不是原子快照; 在没有并发更新的情况下调用返回一个准确的结果，但是在计算该值时发生的并发更新可能未被并入。
        结果
        当前值

      • reset

        public void reset​()
        重置维持更新到标识值的变量。 此方法可能是创建新更新程序的有用替代方法，但仅在没有并发更新时才有效。 因为这个方法本质上是racy，所以只有当已知没有线程同时更新时才应该使用它。

      • getThenReset

        public double getThenReset​()
        相当于get()，其次是reset() 。 该方法可以例如在多线程计算之间的静态点期间使用。 如果与此方法同时存在更新，则返回值不能保证是重置前发生的最终值。
        结果
        复位前的值

      • toString

        public String toString​()
        返回当前值的String表示形式。
        重写：
        toString在 Object
        结果
        当前值的String表示形式

      • doubleValue

        public double doubleValue​()
        相当于 get() 。
        Specified by:
        doubleValue在 Number
        结果
        当前值

      • longValue

        public long longValue​()
        在缩小原始转换后，返回 current value作为 long 。
        Specified by:
        longValue在 Number
        结果
        该对象在转换为 long之后表示的数值。

      • intValue

        public int intValue​()
        在缩小原始转换后，返回 current value作为 int 。
        Specified by:
        intValue在 Number
        结果
        该对象在转换为 int之后表示的数值。

      • floatValue

        public float floatValue​()
        在缩小原始转换后，返回 current value作为 float 。
        Specified by:
        floatValue在 Number
        结果
        该对象在转换为 float之后表示的数值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleAdder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class DoubleAdder

  • java.lang.Object
    • java.lang.Number
      • java.util.concurrent.atomic.DoubleAdder
  • All Implemented Interfaces:
    Serializable

    public class DoubleAdder
extends Number
implements Serializable
    一个或多个变量一起维持起始零点double和。 当跨线程争用更新（方法add(double) ）时，变量集可以动态增长以减少争用。 方法sum() （或等效地doubleValue() ）返回保持总和的整个变量组合的当前总和。 线程内或跨线程的累积顺序不能保证。 因此，如果需要数值稳定性，特别是当组合几乎不同数量级的值时，该类可能不适用。

    当多个线程更新用于诸如经常更新但较不频繁读取的摘要统计信息的常用值时，此类通常优于替代方案。

    该类扩展Number ，但不定义诸如方法equals ， hashCode和compareTo ，因为实例预计将发生突变，所以不如收集钥匙有用。

    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DoubleAdder​()
      创建一个新的加法器，初始和为零。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(double x)
      添加给定值。
      double doubleValue​()
      相当于 sum() 。
      float floatValue​()
      在缩小原始转换后返回 sum()作为 float 。
      int intValue​()
      在缩小原始转换后，返回 sum()作为 int 。
      long longValue​()
      在缩小原始转换后，返回 sum()作为 long 。
      void reset​()
      将保持总和的变量重置为零。
      double sum​()
      返回当前总和。
      double sumThenReset​()
      相当于 sum()，其次是 reset() 。
      String toString​()
      返回 sum()的String表示 形式 。

      • Methods inherited from class java.lang.Number

        byteValue, shortValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DoubleAdder

        public DoubleAdder​()
        创建一个新的加法器，初始和为零。

    • 方法详细信息

      • add

        public void add​(double x)
        添加给定值。
        参数
        x - 要添加的值

      • sum

        public double sum​()
        返回当前总和。 返回的值不是原子快照; 在没有并发更新的情况下调用将返回一个准确的结果，但是在计算总和时发生的并发更新可能不会被并入。 另外，因为浮点运算并不是严格的关联性，所以返回的结果不一定等于在单个变量的连续序列更新中获得的值。
        结果
        总和

      • reset

        public void reset​()
        将保持总和的变量重置为零。 该方法可能是创建新加法器的有用替代方法，但仅在没有并发更新时才有效。 因为这个方法本质上是racy，所以只有当已知没有线程同时更新时才应该使用它。

      • sumThenReset

        public double sumThenReset​()
        相当于sum()，其次是reset() 。 该方法可以例如在多线程计算之间的静态点期间使用。 如果与此方法同时存在更新，则返回值不能保证是重置前发生的最终值。
        结果
        总和

      • toString

        public String toString​()
        返回 sum()的String表示 形式 。
        重写：
        toString在 Object
        结果
        该字符串表示的 sum()

      • doubleValue

        public double doubleValue​()
        相当于 sum() 。
        Specified by:
        doubleValue在 Number
        结果
        总和

      • longValue

        public long longValue​()
        在缩小原始转换后，返回 sum()作为 long 。
        Specified by:
        longValue在 Number
        结果
        该对象在转换为 long型后表示的数值。

      • intValue

        public int intValue​()
        在缩小原始转换后返回 sum()作为 int 。
        Specified by:
        intValue在 Number
        结果
        在转换为 int类型后由该对象表示的数值。

      • floatValue

        public float floatValue​()
        在缩小原始转换后，返回 sum()作为 float 。
        Specified by:
        floatValue在 Number
        结果
        the numeric value represented by this object after conversion to type float.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.util.concurrent.atomic (Java SE 9 & JDK 9 )

java.util.concurrent.atomic

Classes

  • AtomicBoolean
  • AtomicInteger
  • AtomicIntegerArray
  • AtomicIntegerFieldUpdater
  • AtomicLong
  • AtomicLongArray
  • AtomicLongFieldUpdater
  • AtomicMarkableReference
  • AtomicReference
  • AtomicReferenceArray
  • AtomicReferenceFieldUpdater
  • AtomicStampedReference
  • DoubleAccumulator
  • DoubleAdder
  • LongAccumulator
  • LongAdder


java.util.concurrent.atomic (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util.concurrent.atomic

一个小型工具包，支持单个变量上的无锁线程安全编程。 Atomic类的实例维护使用关联原子VarHandle操作的字段可用的方法来访问和更新的值。

类的实例AtomicBoolean ， AtomicInteger ， AtomicLong和AtomicReference各自提供访问和更新相应的类型的单个变量。 每个类还提供了适用于该类型的实用方法。 例如，类AtomicLong和AtomicInteger提供原子增量方法。 一个应用是生成序列号，如：

   class Sequencer { private final AtomicLong sequenceNumber = new AtomicLong(0); public long next() { return sequenceNumber.getAndIncrement(); } }

所含值的任意的转化通过低级别读-修改-写操作，如提供两个compareAndSet和由更高级别的方法，例如getAndUpdate 。

这些类不是通用替代java.lang.Integer和相关类。 他们没有定义方法，比如equals ， hashCode和compareTo 。 因为原子变量预计会被突变，所以它们是散列表键的不好选择。

的AtomicIntegerArray ， AtomicLongArray和AtomicReferenceArray类进一步扩展到这些类型的数组原子操作的支持。 这些类别对于为其数组元素提供volatile访问语义也是值得注意的。

除了表示单个值和数组的类之外，此程序包还包含Updater类，可用于获取任何所选类别的任何所选volatile字段上的compareAndSet和相关操作。 这些课程早于VarHandle的介绍，并且使用的限制更为有限。 AtomicReferenceFieldUpdater ， AtomicIntegerFieldUpdater ，和AtomicLongFieldUpdater是基于反射的实用程序，提供对相关联的字段类型。 这些主要用于原子数据结构中，其中相同节点（例如，树节点的链接）的多个volatile字段独立地受到原子更新。 这些类可以在如何和何时使用原子更新方面提供更大的灵活性，牺牲更加尴尬的基于反射的设置，不太方便的使用和更弱的保证。

AtomicMarkableReference类将一个布尔值与引用相关联。 例如，该位可能在数据结构中使用，意味着被引用的对象在逻辑上被删除。 AtomicStampedReference类将整数值与引用相关联。 这可以用于例如表示对应于一系列更新的版本号。

从以下版本开始：
1.5
  • 类摘要
    Class 描述
    AtomicBoolean
    A boolean可能原子更新的值。
    AtomicInteger
    可能原子更新的值为 int 。
    AtomicIntegerArray
    其中可以原子更新元素的 int数组。
    AtomicIntegerFieldUpdater<T>
    基于反射的实用程序，可以对指定类的指定的 volatile int字段进行原子更新。
    AtomicLong
    A long可能原子更新的值。
    AtomicLongArray
    其中可以原子地更新元素的 long数组。
    AtomicLongFieldUpdater<T>
    基于反射的实用程序，可以对指定类的指定的 volatile long字段进行原子更新。
    AtomicMarkableReference<V>
    一个 AtomicMarkableReference维护一个对象引用以及一个可以原子更新的标记位。
    AtomicReference<V>
    可以原子更新的对象引用。
    AtomicReferenceArray<E>
    可以以原子方式更新元素的对象引用数组。
    AtomicReferenceFieldUpdater<T,V>
    基于反射的实用程序，可以对指定类的指定 volatile参考字段进行原子更新。
    AtomicStampedReference<V>
    一个 AtomicStampedReference维护对象引用以及整数“印记”，可以原子更新。
    DoubleAccumulator
    一个或多个变量，它们一起保持运行 double使用所提供的功能更新值。
    DoubleAdder
    一个或多个变量一起维持起始零点 double 。
    LongAccumulator
    一个或多个变量一起保持正在运行的 long值使用提供的函数进行更新。
    LongAdder
    一个或多个变量一起维持起始零点 long总和。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.concurrent.atomic Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.concurrent.atomic

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicBoolean (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicLongArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicLongFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicMarkableReference<V>
    • java.util.concurrent.atomic.AtomicReference<V> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceArray<E> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceFieldUpdater<T,V>
    • java.util.concurrent.atomic.AtomicStampedReference<V>
    • java.lang.Number (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicInteger (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicLong (implements java.io.Serializable)
      • java.util.concurrent.atomic.DoubleAccumulator (implements java.io.Serializable)
      • java.util.concurrent.atomic.DoubleAdder (implements java.io.Serializable)
      • java.util.concurrent.atomic.LongAccumulator (implements java.io.Serializable)
      • java.util.concurrent.atomic.LongAdder (implements java.io.Serializable)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LongAccumulator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class LongAccumulator

  • java.lang.Object
    • java.lang.Number
      • java.util.concurrent.atomic.LongAccumulator
  • All Implemented Interfaces:
    Serializable

    public class LongAccumulator
extends Number
implements Serializable
    一个或多个变量，它们一起保持运行long使用所提供的功能更新值。 当跨线程争用更新（方法accumulate(long) ）时，该变量集可以动态增长以减少争用。 方法get() （或等效地， longValue() ）返回维护更新的变量的当前值。

    当多线程更新用于收集统计信息，而不是细粒度同步控制的常用值时，此类通常优于AtomicLong 。 在低更新争议下，这两类具有相似的特征。 但是，在高度争议的情况下，这一类的预期吞吐量明显高于牺牲更高的空间消耗。

    线程内或跨线程的累积顺序不能得到保证，不能依赖，所以此类仅适用于积累顺序无关的功能。 提供的累加器功能应该是无效的，因为尝试的更新由于线程之间的争用而失败时可能会被重新应用。 该函数应用当前值作为其第一个参数，给定的更新作为第二个参数。 例如，要保持最大值的运行，您可以提供Long::max以及Long.MIN_VALUE作为身份。

    LongAdder类提供了类别的维护计数和总和的常见特殊情况的这一类的功能。 电话new LongAdder()相当于new LongAccumulator((x, y) -> x + y, 0L) 。

    该类扩展Number ，但不定义诸如方法equals ， hashCode和compareTo ，因为实例预计将发生突变，所以不如收集钥匙有用。

    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LongAccumulator​(LongBinaryOperator accumulatorFunction, long identity)
      使用给定的累加器函数和identity元素创建一个新的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void accumulate​(long x)
      具有给定值的更新。
      double doubleValue​()
      在扩展原始转换后，返回 current value作为 double 。
      float floatValue​()
      在扩展原始转换后，返回 current value作为 float 。
      long get​()
      返回当前值。
      long getThenReset​()
      相当于 get()，其次是 reset() 。
      int intValue​()
      在缩小原始转换后，返回 current value作为 int 。
      long longValue​()
      相当于 get() 。
      void reset​()
      重置维持更新到标识值的变量。
      String toString​()
      返回当前值的String表示形式。

      • Methods inherited from class java.lang.Number

        byteValue, shortValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LongAccumulator

        public LongAccumulator​(LongBinaryOperator accumulatorFunction,
                       long identity)
        使用给定的累加器函数和identity元素创建一个新的实例。
        参数
        accumulatorFunction - 两个参数的无副作用函数
        identity - 累加器函数的标识（初始值）

    • 方法详细信息

      • accumulate

        public void accumulate​(long x)
        具有给定值的更新。
        参数
        x - 值

      • get

        public long get​()
        返回当前值。 返回的值不是原子快照; 在没有并发更新的情况下调用返回一个准确的结果，但是在计算该值时发生的并发更新可能未被并入。
        结果
        当前值

      • reset

        public void reset​()
        重置维持更新到标识值的变量。 此方法可能是创建新更新程序的有用替代方法，但仅在没有并发更新时才有效。 因为这个方法本质上是racy，所以只有当已知没有线程同时更新时才应该使用它。

      • getThenReset

        public long getThenReset​()
        等效于get()，其次是reset() 。 该方法可以例如在多线程计算之间的静态点期间使用。 如果与此方法同时存在更新，则返回值不能保证是重置前发生的最终值。
        结果
        复位前的值

      • toString

        public String toString​()
        返回当前值的String表示形式。
        重写：
        toString在 Object
        结果
        当前值的String表示形式

      • longValue

        public long longValue​()
        相当于 get() 。
        Specified by:
        longValue在 Number
        结果
        当前值

      • intValue

        public int intValue​()
        在缩小原始转换后，返回 current value作为 int 。
        Specified by:
        intValue在 Number
        结果
        该对象在转换为 int之后表示的数值。

      • floatValue

        public float floatValue​()
        在扩展原始转换后，返回 current value作为 float 。
        Specified by:
        floatValue在 Number
        结果
        该对象在转换为 float型之后表示的数值。

      • doubleValue

        public double doubleValue​()
        在扩展原始转换后，返回 current value作为 double 。
        Specified by:
        doubleValue在 Number
        结果
        该对象在转换为 double之后表示的数值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongAdder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.atomic

Class LongAdder

  • java.lang.Object
    • java.lang.Number
      • java.util.concurrent.atomic.LongAdder
  • All Implemented Interfaces:
    Serializable

    public class LongAdder
extends Number
implements Serializable
    一个或多个变量一起保持初始为零long和。 当跨线程争用更新（方法add(long) ）时，该变量集可以动态增长以减少争用。 方法sum() （或等效地， longValue() ）返回保持总和的整个变量组合的当前总和。

    当多个线程更新用于诸如收集统计信息，而不是细粒度同步控制的常用总和时，此类通常优于AtomicLong 。 在低更新争议下，这两类具有相似的特征。 但是，在高度争议的情况下，这一类的预期吞吐量明显高于牺牲更高的空间消耗。

    LongAdders可以使用ConcurrentHashMap来维护可扩展的频率映射（直方图或多集的形式）。 例如，要将一个计数添加到ConcurrentHashMap<String,LongAdder> freqs ，如果尚未存在，则可以使用freqs.computeIfAbsent(key, k -> new LongAdder()).increment();

    该类扩展Number ，但不定义诸如方法equals ， hashCode和compareTo ，因为实例预计将发生突变，所以不如收集钥匙有用。

    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LongAdder​()
      创建一个新的加法器，初始和为零。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(long x)
      添加给定值。
      void decrement​()
      相当于 add(-1) 。
      double doubleValue​()
      在扩展原始转换后，返回 sum()作为 double 。
      float floatValue​()
      在扩展原始转换后，返回 sum()作为 float 。
      void increment​()
      相当于 add(1) 。
      int intValue​()
      在缩小原始转换后，返回 sum()作为 int 。
      long longValue​()
      相当于 sum() 。
      void reset​()
      将保持总和的变量重置为零。
      long sum​()
      返回当前总和。
      long sumThenReset​()
      等效于 sum()，其次是 reset() 。
      String toString​()
      返回 sum()的String表示 形式 。

      • Methods inherited from class java.lang.Number

        byteValue, shortValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LongAdder

        public LongAdder​()
        创建一个新的加法器，初始和为零。

    • 方法详细信息

      • add

        public void add​(long x)
        添加给定值。
        参数
        x - 要添加的值

      • increment

        public void increment​()
        相当于 add(1) 。

      • decrement

        public void decrement​()
        相当于 add(-1) 。

      • sum

        public long sum​()
        返回当前总和。 返回的值不是原子快照; 在没有并发更新的情况下调用将返回一个准确的结果，但是在计算总和时发生的并发更新可能不会被并入。
        结果
        总和

      • reset

        public void reset​()
        将保持总和的变量重置为零。 该方法可能是创建新加法器的有用替代方法，但仅在没有并发更新时才有效。 因为这个方法本质上是racy，所以只有当已知没有线程同时更新时才应该使用它。

      • sumThenReset

        public long sumThenReset​()
        相当于sum()，其次是reset() 。 该方法可以例如在多线程计算之间的静态点期间使用。 如果与此方法同时存在更新，则返回值不能保证是重置前发生的最终值。
        结果
        总和

      • toString

        public String toString​()
        返回 sum()的String表示 形式 。
        重写：
        toString在 Object
        结果
        该字符串表示的 sum()

      • longValue

        public long longValue​()
        相当于 sum() 。
        Specified by:
        longValue在 Number
        结果
        总和

      • intValue

        public int intValue​()
        在缩小原始转换后返回 sum()作为 int 。
        Specified by:
        intValue在 Number
        结果
        该对象在转换为 int之后表示的数值。

      • floatValue

        public float floatValue​()
        在扩展原始转换后，返回 sum()作为 float 。
        Specified by:
        floatValue在 Number
        结果
        该对象在转换为 float之后表示的数值。

      • doubleValue

        public double doubleValue​()
        在扩展原始转换后，返回 sum()作为 double 。
        Specified by:
        doubleValue在 Number
        结果
        该对象在转换为 double之后表示的数值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util.concurrent.atomic (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.concurrent.atomic

  • Packages that use java.util.concurrent.atomic
    软件包 描述
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
  • Classes in java.util.concurrent.atomic used by java.util.concurrent.atomic
    Class 描述
    AtomicIntegerFieldUpdater
    基于反射的实用程序，可以对指定类的指定 volatile int字段进行原子更新。
    AtomicLongFieldUpdater
    基于反射的实用程序，可以对指定类的指定的 volatile long字段进行原子更新。
    AtomicReferenceFieldUpdater
    基于反射的实用程序，可以对指定类的指定 volatile参考字段进行原子更新。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicBoolean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicBoolean

No usage of java.util.concurrent.atomic.AtomicBoolean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicInteger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicInteger

No usage of java.util.concurrent.atomic.AtomicInteger
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicIntegerArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicIntegerArray

No usage of java.util.concurrent.atomic.AtomicIntegerArray
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicIntegerFieldUpdater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicIntegerFieldUpdater

  • Packages that use AtomicIntegerFieldUpdater
    软件包 描述
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。

    • Uses of AtomicIntegerFieldUpdater in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic that return AtomicIntegerFieldUpdater
      Modifier and Type 方法 描述
      static <U> AtomicIntegerFieldUpdater<U> AtomicIntegerFieldUpdater.newUpdater​(Class<U> tclass, String fieldName)
      创建并返回具有给定字段的对象的更新程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicLong (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicLong

No usage of java.util.concurrent.atomic.AtomicLong
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicLongArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicLongArray

No usage of java.util.concurrent.atomic.AtomicLongArray
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicLongFieldUpdater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicLongFieldUpdater

  • Packages that use AtomicLongFieldUpdater
    软件包 描述
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。

    • Uses of AtomicLongFieldUpdater in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic that return AtomicLongFieldUpdater
      Modifier and Type 方法 描述
      static <U> AtomicLongFieldUpdater<U> AtomicLongFieldUpdater.newUpdater​(Class<U> tclass, String fieldName)
      创建并返回具有给定字段的对象的更新程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicMarkableReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicMarkableReference

No usage of java.util.concurrent.atomic.AtomicMarkableReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicReference

No usage of java.util.concurrent.atomic.AtomicReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicReferenceArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicReferenceArray

No usage of java.util.concurrent.atomic.AtomicReferenceArray
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicReferenceFieldUpdater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicReferenceFieldUpdater

  • Packages that use AtomicReferenceFieldUpdater
    软件包 描述
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。

    • Uses of AtomicReferenceFieldUpdater in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic that return AtomicReferenceFieldUpdater
      Modifier and Type 方法 描述
      static <U,W> AtomicReferenceFieldUpdater<U,W> AtomicReferenceFieldUpdater.newUpdater​(Class<U> tclass, Class<W> vclass, String fieldName)
      创建并返回具有给定字段的对象的更新程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.AtomicStampedReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.AtomicStampedReference

No usage of java.util.concurrent.atomic.AtomicStampedReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.DoubleAccumulator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.DoubleAccumulator

No usage of java.util.concurrent.atomic.DoubleAccumulator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.DoubleAdder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.DoubleAdder

No usage of java.util.concurrent.atomic.DoubleAdder
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.LongAccumulator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.LongAccumulator

No usage of java.util.concurrent.atomic.LongAccumulator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.atomic.LongAdder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.atomic.LongAdder

No usage of java.util.concurrent.atomic.LongAdder
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.AbstractExecutorService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.AbstractExecutorService

  • Packages that use AbstractExecutorService
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of AbstractExecutorService in java.util.concurrent

      Subclasses of AbstractExecutorService in java.util.concurrent
      Modifier and Type Class 描述
      class  ForkJoinPool
      一个ExecutorService运行ForkJoinTask s。
      class  ScheduledThreadPoolExecutor
      A ThreadPoolExecutor可以另外安排在给定延迟之后运行命令或定期执行。
      class  ThreadPoolExecutor
      一个ExecutorService ，它使用可能的几个合并的线程执行每个提交的任务，通常使用Executors工厂方法配置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ArrayBlockingQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ArrayBlockingQueue

No usage of java.util.concurrent.ArrayBlockingQueue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.BrokenBarrierException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.BrokenBarrierException

  • Packages that use BrokenBarrierException
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of BrokenBarrierException in java.util.concurrent

      Methods in java.util.concurrent that throw BrokenBarrierException
      Modifier and Type 方法 描述
      int CyclicBarrier.await​()
      等待直到所有的 parties已经在这个障碍上调用了 await 。
      int CyclicBarrier.await​(long timeout, TimeUnit unit)
      等待直到所有 parties已经在此屏障上调用了 await ，或者指定的等待时间 await 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.CancellationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.CancellationException

No usage of java.util.concurrent.CancellationException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.CompletableFuture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.CompletableFuture

  • Packages that use CompletableFuture
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of CompletableFuture in java.lang

      Methods in java.lang that return CompletableFuture
      Modifier and Type 方法 描述
      CompletableFuture<Process> Process.onExit​()
      返回一个 CompletableFuture<Process>终止进程。
      CompletableFuture<ProcessHandle> ProcessHandle.onExit​()
      返回一个 CompletableFuture<ProcessHandle>终止进程。

    • Uses of CompletableFuture in java.util.concurrent

      Methods in java.util.concurrent that return CompletableFuture
      Modifier and Type | 方法 | 描述
      CompletableFuture<Void> | CompletableFuture.acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      CompletableFuture<Void> | CompletableFuture.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      CompletableFuture<Void> | CompletableFuture.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      static CompletableFuture<Void> CompletableFuture.allOf​(CompletableFuture<?>... cfs)
      返回一个新的CompletableFuture，当所有给定的CompletableFutures完成时，完成。
      static CompletableFuture<Object> CompletableFuture.anyOf​(CompletableFuture<?>... cfs)
      返回一个新的CompletableFuture，当任何一个给定的CompletableFutures完成时，完成相同的结果。
      <U> CompletableFuture<U> | CompletableFuture.applyToEither​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      <U> CompletableFuture<U> | CompletableFuture.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      <U> CompletableFuture<U> | CompletableFuture.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      CompletableFuture<T> CompletableFuture.completeAsync​(Supplier<? extends T> supplier)
      使用默认执行程序从异步任务调用给定的供应商函数的结果，完成此CompletableFuture。
      CompletableFuture<T> CompletableFuture.completeAsync​(Supplier<? extends T> supplier, Executor executor)
      使用给定的执行器从异步任务调用给定的供应商函数的结果来完成此CompletableFuture。
      static <U> CompletableFuture<U> CompletableFuture.completedFuture​(U value)
      返回已经使用给定值完成的新的CompletableFuture。
      CompletableFuture<T> CompletableFuture.completeOnTimeout​(T value, long timeout, TimeUnit unit)
      如果在给定的超时之前未完成，则使用给定值完成此CompletableFuture。
      CompletableFuture<Void> SubmissionPublisher.consume​(Consumer<? super T> consumer)
      使用给定的Consumer功能处理所有已发布的项目。
      CompletableFuture<T> CompletableFuture.copy​()
      返回一个新的CompletableFuture，它在正常完成时正常完成，具有与此CompletableFuture相同的值。
      CompletableFuture<T> CompletableFuture.exceptionally​(Function<Throwable,? extends T> fn)
      返回一个新的CompletableFuture，当CompletableFuture完成时完成，结果是异常触发此CompletableFuture的完成特殊功能的给定功能; 否则，如果此CompletableFuture正常完成，则返回的CompletableFuture也会以相同的值正常完成。
      static <U> CompletableFuture<U> CompletableFuture.failedFuture​(Throwable ex)
      返回一个已经完成的新的CompletableFuture，特别是给定的异常。
      <U> CompletableFuture<U> | CompletableFuture.handle​(BiFunction<? super T,Throwable,? extends U> fn)
      <U> CompletableFuture<U> | CompletableFuture.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
      <U> CompletableFuture<U> | CompletableFuture.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      <U> CompletableFuture<U> CompletableFuture.newIncompleteFuture​()
      返回由CompletionStage方法返回的类型的新的不完整的CompletableFuture。
      CompletableFuture<T> CompletableFuture.orTimeout​(long timeout, TimeUnit unit)
      如果在给定的超时之前未完成，请使用TimeoutException完成此CompletableFuture。
      CompletableFuture<Void> | CompletableFuture.runAfterBoth​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      CompletableFuture<Void> | CompletableFuture.runAfterEither​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      static CompletableFuture<Void> CompletableFuture.runAsync​(Runnable runnable)
      返回一个新的CompletableFuture，它在运行给定操作之后由在 ForkJoinPool.commonPool()中运行的任务异步完成。
      static CompletableFuture<Void> CompletableFuture.runAsync​(Runnable runnable, Executor executor)
      返回一个新的CompletableFuture，它在运行给定操作之后由在给定执行程序中运行的任务异步完成。
      static <U> CompletableFuture<U> CompletableFuture.supplyAsync​(Supplier<U> supplier)
      返回由 ForkJoinPool.commonPool()中运行的任务异步完成的新的CompletableFuture，并通过调用给定的供应商获得的值。
      static <U> CompletableFuture<U> CompletableFuture.supplyAsync​(Supplier<U> supplier, Executor executor)
      返回一个新的CompletableFuture，由给定执行器中运行的任务异步完成，并通过调用给定的供应商获得的值。
      CompletableFuture<Void> | CompletableFuture.thenAccept​(Consumer<? super T> action)
      CompletableFuture<Void> | CompletableFuture.thenAcceptAsync​(Consumer<? super T> action)
      CompletableFuture<Void> | CompletableFuture.thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      <U> CompletableFuture<U> | CompletableFuture.thenApply​(Function<? super T,? extends U> fn)
      <U> CompletableFuture<U> | CompletableFuture.thenApplyAsync​(Function<? super T,? extends U> fn)
      <U> CompletableFuture<U> | CompletableFuture.thenApplyAsync​(Function<? super T,? extends U> fn, Executor executor)
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombine​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      <U> CompletableFuture<U> | CompletableFuture.thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
      <U> CompletableFuture<U> | CompletableFuture.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
      <U> CompletableFuture<U> | CompletableFuture.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      CompletableFuture<Void> | CompletableFuture.thenRun​(Runnable action)
      CompletableFuture<Void> | CompletableFuture.thenRunAsync​(Runnable action)
      CompletableFuture<Void> | CompletableFuture.thenRunAsync​(Runnable action, Executor executor)
      CompletableFuture<T> CompletableFuture.toCompletableFuture​()
      返回此CompletableFuture。
      CompletableFuture<T> CompletionStage.toCompletableFuture​()
      返回一个CompletableFuture维持与这个阶段相同的完成属性。
      CompletableFuture<T> | CompletableFuture.whenComplete​(BiConsumer<? super T,? super Throwable> action)
      CompletableFuture<T> | CompletableFuture.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
      CompletableFuture<T> | CompletableFuture.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      Methods in java.util.concurrent with parameters of type CompletableFuture
      Modifier and Type 方法 描述
      static CompletableFuture<Void> CompletableFuture.allOf​(CompletableFuture<?>... cfs)
      返回一个新的CompletableFuture，当所有给定的CompletableFutures完成时，完成。
      static CompletableFuture<Object> CompletableFuture.anyOf​(CompletableFuture<?>... cfs)
      返回一个新的CompletableFuture，当任何一个给定的CompletableFutures完成时，完成相同的结果。

    • Uses of CompletableFuture in jdk.incubator.http

      Methods in jdk.incubator.http that return CompletableFuture
      Modifier and Type | 方法 | 描述
      CompletableFuture<WebSocket> WebSocket.Builder.buildAsync​()
      构建一个 WebSocket 。
      CompletableFuture<U> HttpResponse.MultiProcessor.completion​(CompletableFuture<Void> onComplete, CompletableFuture<Void> onFinalPushPromise)
      当聚合结果对象本身可用时，返回CompletableFuture <U> 。
      CompletableFuture<HttpResponse<V>> | MultiMapResult.get​(Object key)
      CompletableFuture<HttpResponse<V>> | MultiMapResult.put​(HttpRequest key, CompletableFuture<HttpResponse<V>> value)
      CompletableFuture<HttpResponse<V>> | MultiMapResult.remove​(Object key)
      abstract <T> CompletableFuture<HttpResponse<T>> HttpClient.sendAsync​(HttpRequest req, HttpResponse.BodyHandler<T> responseBodyHandler)
      使用此客户端和给定的响应处理程序异步发送给定的请求。
      abstract <U,T> CompletableFuture<U> HttpClient.sendAsync​(HttpRequest req, HttpResponse.MultiProcessor<U,T> multiProcessor)
      使用此客户端和给定的多响应处理程序异步发送给定的请求。
      CompletableFuture<WebSocket> WebSocket.sendBinary​(ByteBuffer message, boolean isLast)
      从给定的 ByteBuffer发送带有字节的二进制消息。
      CompletableFuture<WebSocket> WebSocket.sendClose​(int statusCode, String reason)
      发送关闭消息与给定的状态代码和原因。
      CompletableFuture<WebSocket> WebSocket.sendPing​(ByteBuffer message)
      从给定的ByteBuffer发送带有字节的Ping消息。
      CompletableFuture<WebSocket> WebSocket.sendPong​(ByteBuffer message)
      从给定的ByteBuffer发送带有字节的Pong消息。
      CompletableFuture<WebSocket> WebSocket.sendText​(CharSequence message, boolean isLast)
      发送带有来自给定的 CharSequence的文本的短信。
      abstract CompletableFuture<HttpHeaders> HttpResponse.trailers​()
      返回接收到的响应预告片（如果有），当它们可用时。
      Methods in jdk.incubator.http that return types with arguments of type CompletableFuture
      Modifier and Type | 方法 | 描述
      Set<Map.Entry<HttpRequest,CompletableFuture<HttpResponse<V>>>> | MultiMapResult.entrySet​()
      Collection<CompletableFuture<HttpResponse<V>>> | MultiMapResult.values​()
      Methods in jdk.incubator.http with parameters of type CompletableFuture
      Modifier and Type | 方法 | 描述
      CompletableFuture<U> HttpResponse.MultiProcessor.completion​(CompletableFuture<Void> onComplete, CompletableFuture<Void> onFinalPushPromise)
      当聚合结果对象本身可用时，返回CompletableFuture <U> 。
      CompletableFuture<HttpResponse<V>> | MultiMapResult.put​(HttpRequest key, CompletableFuture<HttpResponse<V>> value)
      Method parameters in jdk.incubator.http with type arguments of type CompletableFuture
      Modifier and Type | 方法 | 描述
      void | MultiMapResult.putAll​(Map<? extends HttpRequest,? extends CompletableFuture<HttpResponse<V>>> m)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.CompletionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.CompletionException

No usage of java.util.concurrent.CompletionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ConcurrentHashMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ConcurrentHashMap

No usage of java.util.concurrent.ConcurrentHashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ConcurrentHashMap.KeySetView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ConcurrentHashMap.KeySetView

  • Packages that use ConcurrentHashMap.KeySetView
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ConcurrentHashMap.KeySetView in java.util.concurrent

      Methods in java.util.concurrent that return ConcurrentHashMap.KeySetView
      Modifier and Type 方法 描述
      ConcurrentHashMap.KeySetView<K,V> ConcurrentHashMap.keySet​()
      返回此地图中包含的键的Set视图。
      ConcurrentHashMap.KeySetView<K,V> ConcurrentHashMap.keySet​(V mappedValue)
      返回此地图中键的Set视图，使用给定的通用映射值进行任何添加（即Collection.add(E)和Collection.addAll(Collection) ）。
      static <K> ConcurrentHashMap.KeySetView<K,Boolean> ConcurrentHashMap.newKeySet​()
      创建一个新的Set ，由给定类型的ConcurrentHashMap支持Boolean.TRUE 。
      static <K> ConcurrentHashMap.KeySetView<K,Boolean> ConcurrentHashMap.newKeySet​(int initialCapacity)
      创建一个新的Set由ConcurrentHashMap支持从给定的类型到Boolean.TRUE 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ConcurrentLinkedDeque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ConcurrentLinkedDeque

No usage of java.util.concurrent.ConcurrentLinkedDeque
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ConcurrentLinkedQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ConcurrentLinkedQueue

No usage of java.util.concurrent.ConcurrentLinkedQueue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ConcurrentSkipListMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ConcurrentSkipListMap

  • Packages that use ConcurrentSkipListMap
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ConcurrentSkipListMap in java.util.concurrent

      Methods in java.util.concurrent that return ConcurrentSkipListMap
      Modifier and Type 方法 描述
      ConcurrentSkipListMap<K,V> ConcurrentSkipListMap.clone​()
      返回此 ConcurrentSkipListMap实例的浅拷贝。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ConcurrentSkipListSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ConcurrentSkipListSet

  • Packages that use ConcurrentSkipListSet
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ConcurrentSkipListSet in java.util.concurrent

      Methods in java.util.concurrent that return ConcurrentSkipListSet
      Modifier and Type 方法 描述
      ConcurrentSkipListSet<E> ConcurrentSkipListSet.clone​()
      返回此 ConcurrentSkipListSet实例的浅拷贝。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.CopyOnWriteArrayList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.CopyOnWriteArrayList

No usage of java.util.concurrent.CopyOnWriteArrayList
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.CopyOnWriteArraySet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.CopyOnWriteArraySet

No usage of java.util.concurrent.CopyOnWriteArraySet
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.CountDownLatch (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.CountDownLatch

No usage of java.util.concurrent.CountDownLatch
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.CountedCompleter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.CountedCompleter

  • Packages that use CountedCompleter
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of CountedCompleter in java.util.concurrent

      Methods in java.util.concurrent that return CountedCompleter
      Modifier and Type 方法 描述
      CountedCompleter<?> CountedCompleter.firstComplete​()
      如果此任务的挂起计数为零，则返回此任务; 否则减少其挂起的数量并返回null 。
      CountedCompleter<?> CountedCompleter.getCompleter​()
      返回在此任务的构造函数中建立的完成者，如果没有，则返回 null 。
      CountedCompleter<?> CountedCompleter.getRoot​()
      返回当前计算的根; 即这个任务，如果它没有完成，否则它的完成者的根。
      CountedCompleter<?> CountedCompleter.nextComplete​()
      如果此任务没有完成，请调用 ForkJoinTask.quietlyComplete()并返回 null 。
      Methods in java.util.concurrent with parameters of type CountedCompleter
      Modifier and Type 方法 描述
      void CountedCompleter.onCompletion​(CountedCompleter<?> caller)
      当方法 tryComplete()被调用并且挂起的计数为零时，或当无条件方法 complete(T)被调用时执行动作。
      boolean CountedCompleter.onExceptionalCompletion​(Throwable ex, CountedCompleter<?> caller)
      当方法 ForkJoinTask.completeExceptionally(Throwable)被调用或方法 compute()引发异常并且此任务尚未正常完成时执行操作。
      Constructors in java.util.concurrent with parameters of type CountedCompleter
      Constructor 描述
      CountedCompleter​(CountedCompleter<?> completer)
      创建一个新的CountedCompleter与给定的完成者和初始挂起计数为零。
      CountedCompleter​(CountedCompleter<?> completer, int initialPendingCount)
      创建一个新的CountedCompleter与给定的完成和初始挂起计数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.CyclicBarrier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.CyclicBarrier

No usage of java.util.concurrent.CyclicBarrier
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.DelayQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.DelayQueue

No usage of java.util.concurrent.DelayQueue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.Exchanger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.Exchanger

No usage of java.util.concurrent.Exchanger
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ExecutionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ExecutionException

  • Packages that use ExecutionException
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of ExecutionException in java.util.concurrent

      Methods in java.util.concurrent that throw ExecutionException
      Modifier and Type | 方法 | 描述
      T CompletableFuture.get​()
      等待这个未来完成的必要，然后返回结果。
      T CompletableFuture.get​(long timeout, TimeUnit unit)
      如果有必要等待这个未来完成的给定时间，然后返回其结果（如果有的话）。
      V ForkJoinTask.get​()
      等待计算完成，然后检索其结果。
      V ForkJoinTask.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      V Future.get​()
      等待计算完成，然后检索其结果。
      V Future.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      V | FutureTask.get​()
      V | FutureTask.get​(long timeout, TimeUnit unit)
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks)
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回成功完成的结果（即，不抛出异常），如果有的话。
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。

    • Uses of ExecutionException in javax.swing

      Methods in javax.swing that throw ExecutionException
      Modifier and Type 方法 描述
      T SwingWorker.get​()
      等待计算完成，然后检索其结果。
      T SwingWorker.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ExecutorCompletionService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ExecutorCompletionService

No usage of java.util.concurrent.ExecutorCompletionService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.Executors (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.Executors

No usage of java.util.concurrent.Executors
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.Flow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.Flow

No usage of java.util.concurrent.Flow
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ForkJoinPool (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ForkJoinPool

  • Packages that use ForkJoinPool
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ForkJoinPool in java.util.concurrent

      Methods in java.util.concurrent that return ForkJoinPool
      Modifier and Type 方法 描述
      static ForkJoinPool ForkJoinPool.commonPool​()
      返回公共池实例。
      static ForkJoinPool ForkJoinTask.getPool​()
      返回托管当前线程的池，如果当前线程正在任何ForkJoinPool外部执行，则返回 null 。
      ForkJoinPool ForkJoinWorkerThread.getPool​()
      返回托管此线程的池。
      Methods in java.util.concurrent with parameters of type ForkJoinPool
      Modifier and Type 方法 描述
      ForkJoinWorkerThread ForkJoinPool.ForkJoinWorkerThreadFactory.newThread​(ForkJoinPool pool)
      返回在给定池中运行的新工作线程。
      Constructors in java.util.concurrent with parameters of type ForkJoinPool
      Constructor 描述
      ForkJoinWorkerThread​(ForkJoinPool pool)
      在给定的池中创建一个ForkJoinWorkerThread。
      Constructor parameters in java.util.concurrent with type arguments of type ForkJoinPool
      Constructor 描述
      ForkJoinPool​(int parallelism, ForkJoinPool.ForkJoinWorkerThreadFactory factory, Thread.UncaughtExceptionHandler handler, boolean asyncMode, int corePoolSize, int maximumPoolSize, int minimumRunnable, Predicate<? super ForkJoinPool> saturate, long keepAliveTime, TimeUnit unit)
      Creates a ForkJoinPool with the given parameters.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ForkJoinTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ForkJoinTask

  • Packages that use ForkJoinTask
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ForkJoinTask in java.util.concurrent

      Subclasses of ForkJoinTask in java.util.concurrent
      Modifier and Type Class 描述
      class  CountedCompleter<T>
      A ForkJoinTask ，当触发时执行完成操作，并且没有剩余的待处理操作。
      class  RecursiveAction
      一个递归结果ForkJoinTask 。
      class  RecursiveTask<V>
      递归结果ForkJoinTask 。
      Methods in java.util.concurrent with type parameters of type ForkJoinTask
      Modifier and Type 方法 描述
      static <T extends ForkJoinTask<?>>
      Collection<T>             		ForkJoinTask.invokeAll​(Collection<T> tasks)
      叉指定集合中的所有任务，当 isDone适用于每个任务或返回（未检查）异常时返回，在这种情况下，异常被重新引导。
      Methods in java.util.concurrent that return ForkJoinTask
      Modifier and Type | 方法 | 描述
      static ForkJoinTask<?> ForkJoinTask.adapt​(Runnable runnable)
      返回一个新的 ForkJoinTask ，它执行给定的 Runnable作为其动作的 run方法，并在 join()返回一个空值结果。
      static <T> ForkJoinTask<T> ForkJoinTask.adapt​(Runnable runnable, T result)
      返回一个新的 ForkJoinTask ，它执行给定的 Runnable的 run方法作为其动作，并将给定的结果返回给 join() 。
      static <T> ForkJoinTask<T> ForkJoinTask.adapt​(Callable<? extends T> callable)
      返回一个新的 ForkJoinTask ，它执行给定的 Callable作为其操作的 call方法，并将其结果返回到 join() ，将遇到的任何检查的异常转换为 RuntimeException 。
      ForkJoinTask<V> ForkJoinTask.fork​()
      在当前任务正在运行的池中异步执行此任务（如果适用）或使用 ForkJoinPool.commonPool()（如果不是 inForkJoinPool()） 。
      protected static ForkJoinTask<?> ForkJoinTask.peekNextLocalTask​()
      返回，但不会取消调度或执行当前线程排队但尚未执行的任务（如果可以立即可用）。
      protected static ForkJoinTask<?> ForkJoinTask.pollNextLocalTask​()
      如果当前线程正在ForkJoinPool中运行，则不执行当前线程排队的下一个任务但尚未执行的时间并返回。
      protected ForkJoinTask<?> ForkJoinPool.pollSubmission​()
      删除并返回下一个未执行的提交（如果有）。
      protected static ForkJoinTask<?> ForkJoinTask.pollSubmission​()
      如果当前线程在ForkJoinPool中运行，则不执行外部提交到池的任务（如果有的话）可以取消调度和返回。
      protected static ForkJoinTask<?> ForkJoinTask.pollTask​()
      如果当前线程在ForkJoinPool中运行，则不执行下一个任务，返回当前线程排队的下一个任务，但尚未执行，如果一个可用，或者如果不可用，则由其他线程分派的任务，如果可供使用的话。
      ForkJoinTask<?> | ForkJoinPool.submit​(Runnable task)
      <T> ForkJoinTask<T> | ForkJoinPool.submit​(Runnable task, T result)
      <T> ForkJoinTask<T> | ForkJoinPool.submit​(Callable<T> task)
      <T> ForkJoinTask<T> ForkJoinPool.submit​(ForkJoinTask<T> task)
      提交一个ForkJoinTask来执行。
      Methods in java.util.concurrent with parameters of type ForkJoinTask
      Modifier and Type 方法 描述
      void ForkJoinPool.execute​(ForkJoinTask<?> task)
      为异步执行给定任务的排列。
      <T> T ForkJoinPool.invoke​(ForkJoinTask<T> task)
      执行给定的任务，在完成后返回其结果。
      static void ForkJoinTask.invokeAll​(ForkJoinTask<?>... tasks)
      叉出给定的任务，当 isDone适用于每个任务时返回，或遇到（未选中）异常，在这种情况下，异常被重新引导。
      static void ForkJoinTask.invokeAll​(ForkJoinTask<?> t1, ForkJoinTask<?> t2)
      叉出给定的任务，当 isDone适用于每个任务时返回，或者遇到（未检查）异常，在这种情况下，异常被重新引导。
      <T> ForkJoinTask<T> ForkJoinPool.submit​(ForkJoinTask<T> task)
      提交一个ForkJoinTask来执行。
      Method parameters in java.util.concurrent with type arguments of type ForkJoinTask
      Modifier and Type 方法 描述
      protected int ForkJoinPool.drainTasksTo​(Collection<? super ForkJoinTask<?>> c)
      从调度队列中删除所有可用的未执行的提交和分派任务，并将其添加到给定集合中，而不会更改其执行状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ForkJoinWorkerThread (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ForkJoinWorkerThread

  • Packages that use ForkJoinWorkerThread
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ForkJoinWorkerThread in java.util.concurrent

      Methods in java.util.concurrent that return ForkJoinWorkerThread
      Modifier and Type 方法 描述
      ForkJoinWorkerThread ForkJoinPool.ForkJoinWorkerThreadFactory.newThread​(ForkJoinPool pool)
      返回在给定池中运行的新工作线程。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.FutureTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.FutureTask

  • Packages that use FutureTask
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。

    • Uses of FutureTask in javafx.concurrent

      Subclasses of FutureTask in javafx.concurrent
      Modifier and Type Class 描述
      class  Task<V>
      一个完全可观察到的一个FutureTask的实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.LinkedBlockingDeque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.LinkedBlockingDeque

No usage of java.util.concurrent.LinkedBlockingDeque
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.LinkedBlockingQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.LinkedBlockingQueue

No usage of java.util.concurrent.LinkedBlockingQueue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.LinkedTransferQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.LinkedTransferQueue

No usage of java.util.concurrent.LinkedTransferQueue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.Phaser (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.Phaser

  • Packages that use Phaser
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of Phaser in java.util.concurrent

      Methods in java.util.concurrent that return Phaser
      Modifier and Type 方法 描述
      Phaser Phaser.getParent​()
      返回此移相器的父级，如果没有，则返回 null 。
      Phaser Phaser.getRoot​()
      返回此移相器的根祖先，如果它没有父代，则与该移相器相同。
      Constructors in java.util.concurrent with parameters of type Phaser
      Constructor 描述
      Phaser​(Phaser parent)
      相当于 Phaser(parent, 0) 。
      Phaser​(Phaser parent, int parties)
      与给定的父母和注册的无礼方的数量创建一个新的移相器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.PriorityBlockingQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.PriorityBlockingQueue

No usage of java.util.concurrent.PriorityBlockingQueue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.RecursiveAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.RecursiveAction

No usage of java.util.concurrent.RecursiveAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.RecursiveTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.RecursiveTask

No usage of java.util.concurrent.RecursiveTask
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.RejectedExecutionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.RejectedExecutionException

No usage of java.util.concurrent.RejectedExecutionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ScheduledThreadPoolExecutor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ScheduledThreadPoolExecutor

No usage of java.util.concurrent.ScheduledThreadPoolExecutor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.Semaphore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.Semaphore

No usage of java.util.concurrent.Semaphore
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.SubmissionPublisher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.SubmissionPublisher

No usage of java.util.concurrent.SubmissionPublisher
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.SynchronousQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.SynchronousQueue

No usage of java.util.concurrent.SynchronousQueue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ThreadLocalRandom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ThreadLocalRandom

  • Packages that use ThreadLocalRandom
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ThreadLocalRandom in java.util.concurrent

      Methods in java.util.concurrent that return ThreadLocalRandom
      Modifier and Type 方法 描述
      static ThreadLocalRandom ThreadLocalRandom.current​()
      返回当前线程的 ThreadLocalRandom 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ThreadPoolExecutor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ThreadPoolExecutor

  • Packages that use ThreadPoolExecutor
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ThreadPoolExecutor in java.util.concurrent

      Subclasses of ThreadPoolExecutor in java.util.concurrent
      Modifier and Type Class 描述
      class  ScheduledThreadPoolExecutor
      A ThreadPoolExecutor可以额外地调度命令在给定的延迟之后运行，或者周期性地执行。
      Methods in java.util.concurrent with parameters of type ThreadPoolExecutor
      Modifier and Type 方法 描述
      void RejectedExecutionHandler.rejectedExecution​(Runnable r, ThreadPoolExecutor executor)
      ThreadPoolExecutor当execute无法接受任务时可能调用的方法。
      void ThreadPoolExecutor.AbortPolicy.rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      总是抛出RejectedExecutionException。
      void ThreadPoolExecutor.CallerRunsPolicy.rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      执行调用者线程中的任务r，除非执行程序已经被关闭，否则任务被丢弃。
      void ThreadPoolExecutor.DiscardOldestPolicy.rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      获取并忽略执行者否则将执行的下一个任务，如果一个可以立即可用，然后重试任务r的执行，除非执行程序关闭，否则任务r被替换为丢弃。
      void ThreadPoolExecutor.DiscardPolicy.rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      Does nothing, which has the effect of discarding task r.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ThreadPoolExecutor.AbortPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ThreadPoolExecutor.AbortPolicy

No usage of java.util.concurrent.ThreadPoolExecutor.AbortPolicy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy

No usage of java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy

No usage of java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.ThreadPoolExecutor.DiscardPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.ThreadPoolExecutor.DiscardPolicy

No usage of java.util.concurrent.ThreadPoolExecutor.DiscardPolicy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.TimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.TimeoutException

  • Packages that use TimeoutException
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of TimeoutException in java.util.concurrent

      Methods in java.util.concurrent that throw TimeoutException
      Modifier and Type | 方法 | 描述
      int CyclicBarrier.await​(long timeout, TimeUnit unit)
      等待直到所有 parties已经在此屏障上调用了 await ，或指定的等待时间过去。
      int Phaser.awaitAdvanceInterruptibly​(int phase, long timeout, TimeUnit unit)
      等待该移相器的阶段从给定的相位值或给定的超时到达，等待时抛出 InterruptedException ，或者如果当前相位不等于给定的相位值，则立即返回，否则该相位器被终止。
      V Exchanger.exchange​(V x, long timeout, TimeUnit unit)
      等待另一个线程到达此交换点（除非当前线程是 interrupted或指定的等待时间过去），然后将给定对象传输给它，接收其对象作为回报。
      T CompletableFuture.get​(long timeout, TimeUnit unit)
      如果有必要等待这个未来完成的给定时间，然后返回其结果（如果有的话）。
      V ForkJoinTask.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      V Future.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      V | FutureTask.get​(long timeout, TimeUnit unit)
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。

    • Uses of TimeoutException in javax.swing

      Methods in javax.swing that throw TimeoutException
      Modifier and Type 方法 描述
      T SwingWorker.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.TimeUnit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.TimeUnit

  • Packages that use TimeUnit
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of TimeUnit in java.lang

      Methods in java.lang with parameters of type TimeUnit
      Modifier and Type 方法 描述
      boolean Process.waitFor​(long timeout, TimeUnit unit)
      导致当前线程等待，如有必要，直到此 Process对象表示的进程已终止，或指定的等待时间过去。

    • Uses of TimeUnit in java.nio.channels

      Methods in java.nio.channels with parameters of type TimeUnit
      Modifier and Type 方法 描述
      abstract boolean AsynchronousChannelGroup.awaitTermination​(long timeout, TimeUnit unit)
      等待该组终止。
      abstract <A> void AsynchronousSocketChannel.read​(ByteBuffer[] dsts, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从该通道读取字节序列到给定缓冲区的子序列中。
      abstract <A> void AsynchronousSocketChannel.read​(ByteBuffer dst, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      abstract <A> void AsynchronousSocketChannel.write​(ByteBuffer[] srcs, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从给定缓冲区的子序列将一个字节序列写入该通道。
      abstract <A> void AsynchronousSocketChannel.write​(ByteBuffer src, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向该通道写入一个字节序列。

    • Uses of TimeUnit in java.nio.file

      Methods in java.nio.file with parameters of type TimeUnit
      Modifier and Type 方法 描述
      WatchKey WatchService.poll​(long timeout, TimeUnit unit)
      检索并删除下一个watch键，如果还没有，则等待必要时直到指定的等待时间。

    • Uses of TimeUnit in java.nio.file.attribute

      Methods in java.nio.file.attribute with parameters of type TimeUnit
      Modifier and Type 方法 描述
      static FileTime FileTime.from​(long value, TimeUnit unit)
      返回一个 FileTime表示给定的粒度单位的值。
      long FileTime.to​(TimeUnit unit)
      返回给定的粒度单位的值。

    • Uses of TimeUnit in java.util.concurrent

      Methods in java.util.concurrent that return TimeUnit
      Modifier and Type 方法 描述
      static TimeUnit TimeUnit.of​(ChronoUnit chronoUnit)
      将 ChronoUnit转换为等效的 TimeUnit 。
      static TimeUnit TimeUnit.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TimeUnit[] TimeUnit.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.util.concurrent with parameters of type TimeUnit
      Modifier and Type | 方法 | 描述
      boolean CountDownLatch.await​(long timeout, TimeUnit unit)
      使当前线程等待直到锁存器向下计数为零，除非线程为 interrupted ，否则指定的等待时间过去。
      int CyclicBarrier.await​(long timeout, TimeUnit unit)
      等待直到所有 parties已经在此屏障上调用了 await ，或指定的等待时间过去。
      int Phaser.awaitAdvanceInterruptibly​(int phase, long timeout, TimeUnit unit)
      等待该移相器的相位从给定的相位值或给定的超时时间 InterruptedException到等待时抛出 InterruptedException ，或者如果当前相位不等于给定的相位值，则立即返回，或者该相位器被终止。
      boolean ForkJoinPool.awaitQuiescence​(long timeout, TimeUnit unit)
      如果被这个池中的一个ForkJoinTask调用，相当于 ForkJoinTask.helpQuiesce() 。
      boolean ExecutorService.awaitTermination​(long timeout, TimeUnit unit)
      阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
      boolean ForkJoinPool.awaitTermination​(long timeout, TimeUnit unit)
      阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
      boolean | ThreadPoolExecutor.awaitTermination​(long timeout, TimeUnit unit)
      CompletableFuture<T> CompletableFuture.completeOnTimeout​(T value, long timeout, TimeUnit unit)
      如果在给定的超时之前未完成，则使用给定值完成此CompletableFuture。
      long TimeUnit.convert​(long sourceDuration, TimeUnit sourceUnit)
      将给定单位的给定持续时间转换为本机。
      static Executor CompletableFuture.delayedExecutor​(long delay, TimeUnit unit)
      返回一个新的执行程序，它在给定的延迟之后将任务提交给默认的执行程序（或者如果不为正，则不会延迟）。
      static Executor CompletableFuture.delayedExecutor​(long delay, TimeUnit unit, Executor executor)
      返回一个新的Executor，它在给定的延迟之后向给定的基本执行器提交一个任务（或者如果非正的则不会延迟）。
      V Exchanger.exchange​(V x, long timeout, TimeUnit unit)
      等待另一个线程到达此交换点（除非当前线程为 interrupted或指定的等待时间已过），然后将给定对象传输给它，接收其对象作为回报。
      T CompletableFuture.get​(long timeout, TimeUnit unit)
      如果有必要等待这个未来完成的给定时间，然后返回其结果（如果有的话）。
      V ForkJoinTask.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      V Future.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      V | FutureTask.get​(long timeout, TimeUnit unit)
      long Delayed.getDelay​(TimeUnit unit)
      在给定的时间单位中返回与此对象相关联的剩余延迟。
      long ThreadPoolExecutor.getKeepAliveTime​(TimeUnit unit)
      返回线程保持活动时间，这是线程在终止之前可能保持空闲的时间量。
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。
      boolean ArrayBlockingQueue.offer​(E e, long timeout, TimeUnit unit)
      在该队列的尾部插入指定的元素，等待指定的等待时间，以使空间在队列已满时变为可用。
      boolean BlockingDeque.offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入由此deque表示的队列中（换句话说，在该deque的尾部），等待指定的等待时间（如果需要空间可用）。
      boolean BlockingQueue.offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此队列中，等待指定的等待时间（如有必要）才能使空间变得可用。
      boolean DelayQueue.offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此延迟队列中。
      boolean | LinkedBlockingDeque.offer​(E e, long timeout, TimeUnit unit)
      boolean LinkedBlockingQueue.offer​(E e, long timeout, TimeUnit unit)
      在该队列的尾部插入指定的元素，必要时等待指定的等待时间才能使空间变得可用。
      boolean LinkedTransferQueue.offer​(E e, long timeout, TimeUnit unit)
      在该队列的尾部插入指定的元素。
      boolean PriorityBlockingQueue.offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此优先级队列中。
      int SubmissionPublisher.offer​(T item, long timeout, TimeUnit unit, BiPredicate<Flow.Subscriber<? super T>,? super T> onDrop)
      如果可能，通过异步调用其 onNext方法将给定项目发布给每个当前订户，阻止任何订阅的资源不可用，直到指定的超时或直到调用者线程中断，此时给定的处理程序（如果非-null）被调用，如果返回true，则重试一次。
      boolean SynchronousQueue.offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此队列中，如果需要，等待另一个线程接收到的指定等待时间。
      boolean BlockingDeque.offerFirst​(E e, long timeout, TimeUnit unit)
      在此deque的前面插入指定的元素，等待指定的等待时间（如果需要空间可用）。
      boolean | LinkedBlockingDeque.offerFirst​(E e, long timeout, TimeUnit unit)
      boolean BlockingDeque.offerLast​(E e, long timeout, TimeUnit unit)
      在此deque的末尾插入指定的元素，如果需要空间可用，等待指定的等待时间。
      boolean | LinkedBlockingDeque.offerLast​(E e, long timeout, TimeUnit unit)
      CompletableFuture<T> CompletableFuture.orTimeout​(long timeout, TimeUnit unit)
      如果在给定的超时之前没有完成，可以使用TimeoutException完成此CompletableFuture。
      E | ArrayBlockingQueue.poll​(long timeout, TimeUnit unit)
      E BlockingDeque.poll​(long timeout, TimeUnit unit)
      检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，等待到指定的等待时间（如有必要）使元素变为可用。
      E BlockingQueue.poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
      Future<V> CompletionService.poll​(long timeout, TimeUnit unit)
      检索并删除表示下一个完成的任务的未来，如果还没有，则等待必要时直到指定的等待时间。
      E DelayQueue.poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头部，如果需要，等待具有到期延迟的元素可用于此队列，或指定的等待时间到期。
      Future<V> | ExecutorCompletionService.poll​(long timeout, TimeUnit unit)
      E | LinkedBlockingDeque.poll​(long timeout, TimeUnit unit)
      E | LinkedBlockingQueue.poll​(long timeout, TimeUnit unit)
      E | LinkedTransferQueue.poll​(long timeout, TimeUnit unit)
      E | PriorityBlockingQueue.poll​(long timeout, TimeUnit unit)
      E SynchronousQueue.poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，如果需要等待指定的等待时间，另一个线程插入它。
      E BlockingDeque.pollFirst​(long timeout, TimeUnit unit)
      检索并删除此deque的第一个元素，等待到指定的等待时间（如有必要）使元素变为可用。
      E | LinkedBlockingDeque.pollFirst​(long timeout, TimeUnit unit)
      E BlockingDeque.pollLast​(long timeout, TimeUnit unit)
      检索并删除此deque的最后一个元素，等待到指定的等待时间，如果需要，元素可用。
      E | LinkedBlockingDeque.pollLast​(long timeout, TimeUnit unit)
      ScheduledFuture<?> ScheduledExecutorService.schedule​(Runnable command, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的单次操作。
      <V> ScheduledFuture<V> ScheduledExecutorService.schedule​(Callable<V> callable, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的ScheduledFuture。
      ScheduledFuture<?> | ScheduledThreadPoolExecutor.schedule​(Runnable command, long delay, TimeUnit unit)
      <V> ScheduledFuture<V> | ScheduledThreadPoolExecutor.schedule​(Callable<V> callable, long delay, TimeUnit unit)
      ScheduledFuture<?> ScheduledExecutorService.scheduleAtFixedRate​(Runnable command, long initialDelay, long period, TimeUnit unit)
      创建并执行在给定的初始延迟之后，随后以给定的时间段首先启用的周期性动作; 也就是说，执行将在initialDelay之后开始，然后是initialDelay + period ，然后是initialDelay + 2 * period ，等等。
      ScheduledFuture<?> | ScheduledThreadPoolExecutor.scheduleAtFixedRate​(Runnable command, long initialDelay, long period, TimeUnit unit)
      ScheduledFuture<?> ScheduledExecutorService.scheduleWithFixedDelay​(Runnable command, long initialDelay, long delay, TimeUnit unit)
      创建并执行在给定的初始延迟之后首先启用的定期动作，随后在一个执行的终止和下一个执行的开始之间给定的延迟。
      ScheduledFuture<?> | ScheduledThreadPoolExecutor.scheduleWithFixedDelay​(Runnable command, long initialDelay, long delay, TimeUnit unit)
      void ThreadPoolExecutor.setKeepAliveTime​(long time, TimeUnit unit)
      设置线程保持活动时间，这是线程在终止之前可能保持空闲的时间量。
      boolean Semaphore.tryAcquire​(int permits, long timeout, TimeUnit unit)
      如果在给定的等待时间内全部可用，并且当前线程尚未 到达interrupted ，则从该信号量获取给定数量的许可证。
      boolean Semaphore.tryAcquire​(long timeout, TimeUnit unit)
      如果在给定的等待时间内可用，并且当前线程尚未 到达interrupted ，则从该信号量获取许可。
      boolean LinkedTransferQueue.tryTransfer​(E e, long timeout, TimeUnit unit)
      如果可以在超时过程之前将元素传送给消费者。
      boolean TransferQueue.tryTransfer​(E e, long timeout, TimeUnit unit)
      如果可以在超时过程之前将元素传送给消费者。
      Constructors in java.util.concurrent with parameters of type TimeUnit
      Constructor 描述
      ForkJoinPool​(int parallelism, ForkJoinPool.ForkJoinWorkerThreadFactory factory, Thread.UncaughtExceptionHandler handler, boolean asyncMode, int corePoolSize, int maximumPoolSize, int minimumRunnable, Predicate<? super ForkJoinPool> saturate, long keepAliveTime, TimeUnit unit)
      使用给定的参数创建一个 ForkJoinPool 。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂和拒绝的执行处理程序。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认拒绝执行处理程序。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
      使用给定的初始参数创建一个新的 ThreadPoolExecutor 。

    • Uses of TimeUnit in java.util.concurrent.locks

      Methods in java.util.concurrent.locks with parameters of type TimeUnit
      Modifier and Type 方法 描述
      boolean AbstractQueuedLongSynchronizer.ConditionObject.await​(long time, TimeUnit unit)
      实现定时状态等待。
      boolean AbstractQueuedSynchronizer.ConditionObject.await​(long time, TimeUnit unit)
      实现定时状态等待。
      boolean Condition.await​(long time, TimeUnit unit)
      使当前线程等待直到发出信号或中断，或指定的等待时间过去。
      boolean Lock.tryLock​(long time, TimeUnit unit)
      如果在给定的等待时间内空闲，并且当前线程尚未被 interrupted获取该锁。
      boolean ReentrantLock.tryLock​(long timeout, TimeUnit unit)
      如果在给定的等待时间内没有被另一个线程 占用 ，并且当前线程尚未被 interrupted获取锁定 。
      boolean ReentrantReadWriteLock.ReadLock.tryLock​(long timeout, TimeUnit unit)
      如果写锁定在给定等待时间内未被另一个线程 占用 ，并且当前线程尚未被 interrupted获取读取锁定。
      boolean ReentrantReadWriteLock.WriteLock.tryLock​(long timeout, TimeUnit unit)
      如果在给定的等待时间内没有被另一个线程 占用 ，并且当前线程尚未被 interrupted采集写入锁定 。
      long StampedLock.tryReadLock​(long time, TimeUnit unit)
      如果在给定时间内可用，并且当前线程未被中断，则非排他性地获取锁。
      long StampedLock.tryWriteLock​(long time, TimeUnit unit)
      如果在给定时间内可用，并且当前线程未被中断，则专门获取该锁。

    • Uses of TimeUnit in javax.swing

      Methods in javax.swing with parameters of type TimeUnit
      Modifier and Type 方法 描述
      T SwingWorker.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.BlockingDeque (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.BlockingDeque

  • Packages that use BlockingDeque
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of BlockingDeque in java.util.concurrent

      Classes in java.util.concurrent that implement BlockingDeque
      Modifier and Type Class 描述
      class  LinkedBlockingDeque<E>
      基于链接节点的可选限定的blocking deque 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.BlockingQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.BlockingQueue

  • Packages that use BlockingQueue
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of BlockingQueue in java.util.concurrent

      Subinterfaces of BlockingQueue in java.util.concurrent
      Modifier and Type 接口 描述
      interface  BlockingDeque<E>
      A Deque另外支持在检索元素时等待deque变为非空的阻塞操作，并且在存储元素时等待空白在deque中可用。
      interface  TransferQueue<E>
      A BlockingQueue ，其中生产者可能等待消费者接收元素。
      Classes in java.util.concurrent that implement BlockingQueue
      Modifier and Type Class 描述
      class  ArrayBlockingQueue<E>
      有限的blocking queue由阵列支持。
      class  DelayQueue<E extends Delayed>
      一个无限制的blocking queue的Delayed元素，其中元素只能在其延迟到期时才被使用。
      class  LinkedBlockingDeque<E>
      基于链接节点的可选限定的blocking deque 。
      class  LinkedBlockingQueue<E>
      基于链接节点的可选限定的blocking queue 。
      class  LinkedTransferQueue<E>
      基于链接节点的无界TransferQueue 。
      class  PriorityBlockingQueue<E>
      无限blocking queue使用与PriorityQueue类相同的排序规则，并提供阻止检索操作。
      class  SynchronousQueue<E>
      A blocking queue其中每个插入操作必须等待另一个线程相应的删除操作，反之亦然。
      Methods in java.util.concurrent that return BlockingQueue
      Modifier and Type 方法 描述
      BlockingQueue<Runnable> ScheduledThreadPoolExecutor.getQueue​()
      返回此执行程序使用的任务队列。
      BlockingQueue<Runnable> ThreadPoolExecutor.getQueue​()
      返回此执行程序使用的任务队列。
      Constructors in java.util.concurrent with parameters of type BlockingQueue
      Constructor 描述
      ExecutorCompletionService​(Executor executor, BlockingQueue<Future<V>> completionQueue)
      使用提供的执行程序创建一个ExecutorCompletionService，用于执行基本任务，并将提供的队列作为其完成队列。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂和拒绝执行处理程序。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认拒绝执行处理程序。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
      用给定的初始参数创建一个新的 ThreadPoolExecutor 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.Callable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.Callable

  • Packages that use Callable
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。

    • Uses of Callable in com.sun.source.util

      Classes in com.sun.source.util that implement Callable
      Modifier and Type Class 描述
      class  JavacTask
      提供对JDK Java编译器javac特有的功能的访问。

    • Uses of Callable in java.util.concurrent

      Methods in java.util.concurrent that return Callable
      Modifier and Type 方法 描述
      static Callable<Object> Executors.callable​(Runnable task)
      返回一个Callable对象，当被调用时，它运行给定的任务并返回null 。
      static <T> Callable<T> Executors.callable​(Runnable task, T result)
      返回一个Callable对象，当被调用时，它运行给定的任务并返回给定的结果。
      static Callable<Object> Executors.callable​(PrivilegedAction<?> action)
      返回一个Callable对象，当被调用时，它运行给定的特权动作并返回其结果。
      static Callable<Object> Executors.callable​(PrivilegedExceptionAction<?> action)
      返回一个Callable对象，当被调用时，它运行给定的特权异常操作并返回其结果。
      static <T> Callable<T> Executors.privilegedCallable​(Callable<T> callable)
      返回一个Callable对象，当被调用时，将在当前访问控制上下文中执行给定的callable 。
      static <T> Callable<T> Executors.privilegedCallableUsingCurrentClassLoader​(Callable<T> callable)
      返回一个Callable对象，当被调用时，将在当前访问控制上下文中执行给定的callable ，当前上下文类加载器作为上下文类加载器。
      Methods in java.util.concurrent with parameters of type Callable
      Modifier and Type | 方法 | 描述
      static <T> ForkJoinTask<T> ForkJoinTask.adapt​(Callable<? extends T> callable)
      返回一个新的 ForkJoinTask ，执行给定的 Callable作为其操作的 call方法，并将其结果返回到 ForkJoinTask.join() ，将遇到的任何检查的异常转换为 RuntimeException 。
      protected <V> RunnableScheduledFuture<V> ScheduledThreadPoolExecutor.decorateTask​(Callable<V> callable, RunnableScheduledFuture<V> task)
      修改或替换用于执行可调用的任务。
      protected <T> RunnableFuture<T> AbstractExecutorService.newTaskFor​(Callable<T> callable)
      为给定的可调用任务返回一个 RunnableFuture 。
      protected <T> RunnableFuture<T> | ForkJoinPool.newTaskFor​(Callable<T> callable)
      static <T> Callable<T> Executors.privilegedCallable​(Callable<T> callable)
      返回一个Callable对象，当被调用时，将在当前访问控制上下文中执行给定的callable 。
      static <T> Callable<T> Executors.privilegedCallableUsingCurrentClassLoader​(Callable<T> callable)
      返回一个Callable对象，当被调用时，将在当前访问控制上下文中执行给定的callable ，当前上下文类加载器作为上下文类加载器。
      <V> ScheduledFuture<V> ScheduledExecutorService.schedule​(Callable<V> callable, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的ScheduledFuture。
      <V> ScheduledFuture<V> | ScheduledThreadPoolExecutor.schedule​(Callable<V> callable, long delay, TimeUnit unit)
      <T> Future<T> | AbstractExecutorService.submit​(Callable<T> task)
      Future<V> CompletionService.submit​(Callable<V> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。
      Future<V> | ExecutorCompletionService.submit​(Callable<V> task)
      <T> Future<T> ExecutorService.submit​(Callable<T> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。
      <T> ForkJoinTask<T> | ForkJoinPool.submit​(Callable<T> task)
      <T> Future<T> | ScheduledThreadPoolExecutor.submit​(Callable<T> task)
      Method parameters in java.util.concurrent with type arguments of type Callable
      Modifier and Type | 方法 | 描述
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。
      <T> List<Future<T>> | ForkJoinPool.invokeAll​(Collection<? extends Callable<T>> tasks)
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks)
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回成功完成的结果（即，不抛出异常），如果有的话。
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。
      Constructors in java.util.concurrent with parameters of type Callable
      Constructor 描述
      FutureTask​(Callable<V> callable)
      创建一个 FutureTask ，它将在运行时执行给定的 Callable 。

    • Uses of Callable in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type Callable
      Modifier and Type 方法 描述
      static BooleanBinding Bindings.createBooleanBinding​(Callable<Boolean> func, Observable... dependencies)
      助手功能创建自定义BooleanBinding 。
      static DoubleBinding Bindings.createDoubleBinding​(Callable<Double> func, Observable... dependencies)
      助手功能创建一个自定义DoubleBinding 。
      static FloatBinding Bindings.createFloatBinding​(Callable<Float> func, Observable... dependencies)
      助手功能创建一个自定义的FloatBinding 。
      static IntegerBinding Bindings.createIntegerBinding​(Callable<Integer> func, Observable... dependencies)
      助手功能创建自定义IntegerBinding 。
      static LongBinding Bindings.createLongBinding​(Callable<Long> func, Observable... dependencies)
      助手功能创建自定义LongBinding 。
      static <T> ObjectBinding<T> Bindings.createObjectBinding​(Callable<T> func, Observable... dependencies)
      助手功能创建自定义ObjectBinding 。
      static StringBinding Bindings.createStringBinding​(Callable<String> func, Observable... dependencies)
      助手功能创建自定义StringBinding 。

    • Uses of Callable in javax.tools

      Subinterfaces of Callable in javax.tools
      Modifier and Type 接口 描述
      static interface  DocumentationTool.DocumentationTask
      表示文档任务的未来的接口。
      static interface  JavaCompiler.CompilationTask
      代表编译任务的未来的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.CompletableFuture.AsynchronousCompletionTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.CompletableFuture.AsynchronousCompletionTask

No usage of java.util.concurrent.CompletableFuture.AsynchronousCompletionTask
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.CompletionService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.CompletionService

  • Packages that use CompletionService
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of CompletionService in java.util.concurrent

      Classes in java.util.concurrent that implement CompletionService
      Modifier and Type Class 描述
      class  ExecutorCompletionService<V>
      A CompletionService使用提供的Executor执行任务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.CompletionStage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.CompletionStage

  • Packages that use CompletionStage
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of CompletionStage in java.util.concurrent

      Classes in java.util.concurrent that implement CompletionStage
      Modifier and Type Class 描述
      class  CompletableFuture<T>
      A Future可以显式完成（设置其值和状态），并可用作CompletionStage ，支持在完成后触发的依赖功能和操作。
      Methods in java.util.concurrent that return CompletionStage
      Modifier and Type 方法 描述
      CompletionStage<Void> CompletionStage.acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的操作的参数。
      CompletionStage<Void> CompletionStage.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供的操作的参数。
      CompletionStage<Void> CompletionStage.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。
      <U> CompletionStage<U> CompletionStage.applyToEither​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的函数的参数。
      <U> CompletionStage<U> CompletionStage.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供函数的参数。
      <U> CompletionStage<U> CompletionStage.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用提供的执行器执行，其中相应的结果作为参数提供给函数。
      static <U> CompletionStage<U> CompletableFuture.completedStage​(U value)
      返回已经使用给定值完成的新CompletionStage，并且仅支持接口CompletionStage中的那些方法。
      CompletionStage<T> CompletionStage.exceptionally​(Function<Throwable,? extends T> fn)
      返回一个新的CompletionStage，当此阶段完成异常时，将以此阶段的异常作为提供函数的参数执行。
      static <U> CompletionStage<U> CompletableFuture.failedStage​(Throwable ex)
      返回一个已经完成的新的CompletionStage，特别是给定异常，并且仅支持接口CompletionStage中的那些方法。
      <U> CompletionStage<U> CompletionStage.handle​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用此阶段的结果和异常作为所提供函数的参数执行。
      <U> CompletionStage<U> CompletionStage.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当该阶段完成正常或异常时，将使用此阶段的默认异步执行工具执行，此阶段的结果和异常作为提供函数的参数。
      <U> CompletionStage<U> CompletionStage.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用提供的执行程序执行此阶段的结果和异常作为提供的函数的参数。
      CompletionStage<T> CompletableFuture.minimalCompletionStage​()
      返回一个新的CompletionStage，它在正常完成时正常完成与此CompletableFuture相同的值，并且不能以未由接口CompletionStage定义的方式独立完成或以其他方式使用。
      CompletionStage<Void> CompletionStage.runAfterBoth​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，执行给定的动作。
      CompletionStage<Void> CompletionStage.runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。
      CompletionStage<Void> CompletionStage.runAfterEither​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行给定的操作。
      CompletionStage<Void> CompletionStage.runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。
      CompletionStage<Void> CompletionStage.thenAccept​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，以该阶段的结果作为提供的操作的参数执行。
      CompletionStage<Void> CompletionStage.thenAcceptAsync​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用此阶段的默认异步执行工具执行，此阶段的结果作为提供的操作的参数。
      CompletionStage<Void> CompletionStage.thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供的操作的参数。
      <U> CompletionStage<Void> CompletionStage.thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供的操作的参数被执行。
      <U> CompletionStage<Void> CompletionStage.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供的操作的参数。
      <U> CompletionStage<Void> CompletionStage.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。
      <U> CompletionStage<U> CompletionStage.thenApply​(Function<? super T,? extends U> fn)
      返回一个新的CompletionStage，当此阶段正常完成时，将以该阶段的结果作为所提供函数的参数执行。
      <U> CompletionStage<U> CompletionStage.thenApplyAsync​(Function<? super T,? extends U> fn)
      返回一个新的CompletionStage，当该阶段正常完成时，将使用此阶段的默认异步执行工具执行此阶段的结果作为所提供函数的参数。
      <U> CompletionStage<U> CompletionStage.thenApplyAsync​(Function<? super T,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供函数的参数。
      <U,V> CompletionStage<V> CompletionStage.thenCombine​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供函数的参数执行。
      <U,V> CompletionStage<V> CompletionStage.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供函数的参数。
      <U,V> CompletionStage<V> CompletionStage.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行，其中两个结果作为提供的函数的参数。
      <U> CompletionStage<U> CompletionStage.thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个完成的新的CompletionStage，其值与给定函数返回的CompletionStage相同。
      <U> CompletionStage<U> CompletionStage.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用该阶段的默认异步执行工具执行。
      <U> CompletionStage<U> CompletionStage.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用提供的Executor执行。
      CompletionStage<Void> CompletionStage.thenRun​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，执行给定的操作。
      CompletionStage<Void> CompletionStage.thenRunAsync​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.thenRunAsync​(Runnable action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，使用提供的执行程序执行给定的操作。
      CompletionStage<T> CompletionStage.whenComplete​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同的结果或异常的新CompletionStage，当此阶段完成时，它将执行给定的操作。
      CompletionStage<T> CompletionStage.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，将使用此阶段的默认异步执行工具执行给定操作。
      CompletionStage<T> CompletionStage.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，使用提供的执行程序执行给定操作。
      Methods in java.util.concurrent with parameters of type CompletionStage
      Modifier and Type | 方法 | 描述
      CompletableFuture<Void> | CompletableFuture.acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      CompletionStage<Void> CompletionStage.acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的操作的参数。
      CompletableFuture<Void> | CompletableFuture.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      CompletableFuture<Void> | CompletableFuture.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      CompletionStage<Void> CompletionStage.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供的操作的参数。
      CompletionStage<Void> CompletionStage.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。
      <U> CompletableFuture<U> | CompletableFuture.applyToEither​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      <U> CompletionStage<U> CompletionStage.applyToEither​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的函数的参数。
      <U> CompletableFuture<U> | CompletableFuture.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      <U> CompletableFuture<U> | CompletableFuture.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供函数的参数。
      <U> CompletionStage<U> CompletionStage.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用提供的执行器执行，其中相应的结果作为参数提供给函数。
      CompletableFuture<Void> | CompletableFuture.runAfterBoth​(CompletionStage<?> other, Runnable action)
      CompletionStage<Void> CompletionStage.runAfterBoth​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，执行给定的动作。
      CompletableFuture<Void> | CompletableFuture.runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。
      CompletableFuture<Void> | CompletableFuture.runAfterEither​(CompletionStage<?> other, Runnable action)
      CompletionStage<Void> CompletionStage.runAfterEither​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行给定的操作。
      CompletableFuture<Void> | CompletableFuture.runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      <U> CompletionStage<Void> CompletionStage.thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供的操作的参数被执行。
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      <U> CompletionStage<Void> CompletionStage.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供的操作的参数。
      <U> CompletionStage<Void> CompletionStage.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombine​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      <U,V> CompletionStage<V> CompletionStage.thenCombine​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供函数的参数执行。
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      <U,V> CompletionStage<V> CompletionStage.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供函数的参数。
      <U,V> CompletionStage<V> CompletionStage.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行，其中两个结果作为提供的函数的参数。
      Method parameters in java.util.concurrent with type arguments of type CompletionStage
      Modifier and Type | 方法 | 描述
      <U> CompletableFuture<U> | CompletableFuture.thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
      <U> CompletionStage<U> CompletionStage.thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个完成的新的CompletionStage，其值与给定函数返回的CompletionStage相同。
      <U> CompletableFuture<U> | CompletableFuture.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
      <U> CompletableFuture<U> | CompletableFuture.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用该阶段的默认异步执行工具执行。
      <U> CompletionStage<U> CompletionStage.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用提供的Executor执行。

    • Uses of CompletionStage in jdk.incubator.http

      Methods in jdk.incubator.http that return CompletionStage
      Modifier and Type 方法 描述
      CompletionStage<T> HttpResponse.BodyProcessor.getBody​()
      返回一个 CompletionStage ，当完成后将返回响应体对象。
      default CompletionStage<?> WebSocket.Listener.onBinary​(WebSocket webSocket, ByteBuffer message, WebSocket.MessagePart part)
      接收二进制消息。
      default CompletionStage<?> WebSocket.Listener.onClose​(WebSocket webSocket, int statusCode, String reason)
      接收到一条关闭消息。
      default CompletionStage<?> WebSocket.Listener.onPing​(WebSocket webSocket, ByteBuffer message)
      接收Ping消息。
      default CompletionStage<?> WebSocket.Listener.onPong​(WebSocket webSocket, ByteBuffer message)
      收到乒乓消息。
      default CompletionStage<?> WebSocket.Listener.onText​(WebSocket webSocket, CharSequence message, WebSocket.MessagePart part)
      接收短信。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.ConcurrentMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.ConcurrentMap

  • Packages that use ConcurrentMap
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of ConcurrentMap in java.util.concurrent

      Subinterfaces of ConcurrentMap in java.util.concurrent
      Modifier and Type 接口 描述
      interface  ConcurrentNavigableMap<K,V>
      A ConcurrentMap支持NavigableMap操作，并且递归地为其可导航的子地图。
      Classes in java.util.concurrent that implement ConcurrentMap
      Modifier and Type Class 描述
      class  ConcurrentHashMap<K,V>
      支持检索的完全并发性和更新的高预期并发性的哈希表。
      class  ConcurrentSkipListMap<K,V>
      可扩展并发ConcurrentNavigableMap实现。

    • Uses of ConcurrentMap in java.util.stream

      Methods in java.util.stream with type parameters of type ConcurrentMap
      Modifier and Type 方法 描述
      static <T,K,A,D,M extends ConcurrentMap<K,D>>
      Collector<T,?,M>             		Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回一个并发的 Collector ，对类型为 T输入元素执行级联“分组”操作，根据分类功能分组元素，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K,U,M extends ConcurrentMap<K,U>>
      Collector<T,?,M>             		Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个并发的 Collector ，它将元素累加到一个 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。
      Methods in java.util.stream that return types with arguments of type ConcurrentMap
      Modifier and Type 方法 描述
      static <T,K> Collector<T,?,ConcurrentMap<K,List<T>>> Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier)
      返回 Collector对 T类型的输入元素实施“分组”操作，根据分类功能对元素进行分组。
      static <T,K,A,D> Collector<T,?,ConcurrentMap<K,D>> Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回一个并发 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定执行与给定键相关联的值的归约运算 Collector 。
      static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.ConcurrentNavigableMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.ConcurrentNavigableMap

  • Packages that use ConcurrentNavigableMap
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ConcurrentNavigableMap in java.util.concurrent

      Classes in java.util.concurrent that implement ConcurrentNavigableMap
      Modifier and Type Class 描述
      class  ConcurrentSkipListMap<K,V>
      可扩展的并发ConcurrentNavigableMap实现。
      Methods in java.util.concurrent that return ConcurrentNavigableMap
      Modifier and Type | 方法 | 描述
      ConcurrentNavigableMap<K,V> ConcurrentNavigableMap.descendingMap​()
      返回此映射中包含的映射的反向排序视图。
      ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.descendingMap​()
      ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.headMap​(K toKey)
      ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.headMap​(K toKey, boolean inclusive)
      ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.headMap​(K toKey)
      ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.headMap​(K toKey, boolean inclusive)
      ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.subMap​(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
      ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.subMap​(K fromKey, K toKey)
      ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.subMap​(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
      ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.subMap​(K fromKey, K toKey)
      ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.tailMap​(K fromKey)
      ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.tailMap​(K fromKey, boolean inclusive)
      ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.tailMap​(K fromKey)
      ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.tailMap​(K fromKey, boolean inclusive)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.Delayed (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.Delayed

  • Packages that use Delayed
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of Delayed in java.util.concurrent

      Classes in java.util.concurrent with type parameters of type Delayed
      Modifier and Type Class 描述
      class  DelayQueue<E extends Delayed>
      无界blocking queue的Delayed元件，其中，当其延迟已到期的元素只能采取。
      Subinterfaces of Delayed in java.util.concurrent
      Modifier and Type 接口 描述
      interface  RunnableScheduledFuture<V>
      A ScheduledFuture ，这是Runnable 。
      interface  ScheduledFuture<V>
      可以取消延迟结果的行动。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.Executor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.Executor

  • Packages that use Executor
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.concurrent
    提供javafx.task的一组类。
    javax.management
    提供Java管理扩展的核心类。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of Executor in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return Executor
      Modifier and Type 方法 描述
      abstract Executor HttpServer.getExecutor​()
      如果指定了 HttpServer.setExecutor(Executor)或 null如果没有指定），则返回此服务器的Executor对象。
      Methods in com.sun.net.httpserver with parameters of type Executor
      Modifier and Type 方法 描述
      abstract void HttpServer.setExecutor​(Executor executor)
      设置此服务器的Executor对象。

    • Uses of Executor in java.sql

      Methods in java.sql with parameters of type Executor
      Modifier and Type 方法 描述
      void Connection.abort​(Executor executor)
      终止打开的连接。
      void Connection.setNetworkTimeout​(Executor executor, int milliseconds)
      设置 Connection的最大周期或从 Connection创建的 Connection将等待数据库回复任何一个请求。

    • Uses of Executor in java.util.concurrent

      Subinterfaces of Executor in java.util.concurrent
      Modifier and Type 接口 描述
      interface  ExecutorService
      一个Executor提供了管理终止和方法的方法，可以产生一个Future来跟踪一个或多个异步任务的进度。
      interface  ScheduledExecutorService
      一个ExecutorService ，可以调度命令在给定的延迟之后运行，或定期执行。
      Classes in java.util.concurrent that implement Executor
      Modifier and Type Class 描述
      class  AbstractExecutorService
      提供ExecutorService执行方法的默认实现。
      class  ForkJoinPool
      一个ExecutorService ，运行ForkJoinTask s。
      class  ScheduledThreadPoolExecutor
      A ThreadPoolExecutor可以额外地调度命令在给定的延迟之后运行，或者定期执行。
      class  ThreadPoolExecutor
      一个ExecutorService ，使用可能的几个合并的线程执行每个提交的任务，通常使用Executors工厂方法配置。
      Methods in java.util.concurrent that return Executor
      Modifier and Type 方法 描述
      Executor CompletableFuture.defaultExecutor​()
      返回用于不指定Executor的异步方法的默认Executor。
      static Executor CompletableFuture.delayedExecutor​(long delay, TimeUnit unit)
      返回一个新的执行程序，它在给定的延迟之后将任务提交给默认的执行程序（或者如果不为正，则不会延迟）。
      static Executor CompletableFuture.delayedExecutor​(long delay, TimeUnit unit, Executor executor)
      返回一个新的Executor，它在给定的延迟之后向给定的基本执行器提交一个任务（或者如果非正的则不会延迟）。
      Executor SubmissionPublisher.getExecutor​()
      返回用于异步传递的执行程序。
      Methods in java.util.concurrent with parameters of type Executor
      Modifier and Type | 方法 | 描述
      CompletableFuture<Void> | CompletableFuture.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      CompletionStage<Void> CompletionStage.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。
      <U> CompletableFuture<U> | CompletableFuture.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用提供的执行器执行，其中相应的结果作为参数提供给函数。
      CompletableFuture<T> CompletableFuture.completeAsync​(Supplier<? extends T> supplier, Executor executor)
      使用给定的执行器从异步任务调用给定的供应商函数的结果来完成此CompletableFuture。
      static Executor CompletableFuture.delayedExecutor​(long delay, TimeUnit unit, Executor executor)
      返回一个新的Executor，它在给定的延迟之后向给定的基本执行器提交一个任务（或者如果非正的则不会延迟）。
      <U> CompletableFuture<U> | CompletableFuture.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用提供的执行程序执行此阶段的结果和异常作为提供的函数的参数。
      CompletableFuture<Void> | CompletableFuture.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。
      CompletableFuture<Void> | CompletableFuture.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。
      static CompletableFuture<Void> CompletableFuture.runAsync​(Runnable runnable, Executor executor)
      返回一个新的CompletableFuture，它在运行给定操作之后由在给定执行程序中运行的任务异步完成。
      static <U> CompletableFuture<U> CompletableFuture.supplyAsync​(Supplier<U> supplier, Executor executor)
      返回一个新的CompletableFuture，由给定执行器中运行的任务异步完成，并通过调用给定的供应商获得的值。
      CompletableFuture<Void> | CompletableFuture.thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      CompletionStage<Void> CompletionStage.thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供的操作的参数。
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      <U> CompletionStage<Void> CompletionStage.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。
      <U> CompletableFuture<U> | CompletableFuture.thenApplyAsync​(Function<? super T,? extends U> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.thenApplyAsync​(Function<? super T,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供函数的参数。
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      <U,V> CompletionStage<V> CompletionStage.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行，其中两个结果作为提供的函数的参数。
      <U> CompletableFuture<U> | CompletableFuture.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用提供的Executor执行。
      CompletableFuture<Void> | CompletableFuture.thenRunAsync​(Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.thenRunAsync​(Runnable action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，使用提供的执行程序执行给定的操作。
      CompletableFuture<T> | CompletableFuture.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      CompletionStage<T> CompletionStage.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，使用提供的执行程序执行给定操作。
      Constructors in java.util.concurrent with parameters of type Executor
      Constructor 描述
      ExecutorCompletionService​(Executor executor)
      使用提供的执行程序创建一个ExecutorCompletionService，用于执行基本任务，一个LinkedBlockingQueue作为完成队列。
      ExecutorCompletionService​(Executor executor, BlockingQueue<Future<V>> completionQueue)
      使用提供的执行程序创建一个ExecutorCompletionService，用于执行基本任务，并将提供的队列作为其完成队列。
      SubmissionPublisher​(Executor executor, int maxBufferCapacity)
      使用给定的执行程序创建一个新的提交发布者，以便为订户提供异步传递，每个订户具有给定的最大缓冲区大小，方法 onNext中没有用于订阅者异常的处理程序。
      SubmissionPublisher​(Executor executor, int maxBufferCapacity, BiConsumer<? super Flow.Subscriber<? super T>,? super Throwable> handler)
      使用给定的Executor创建一个新的SubmissionPublisher，为订户提供异步传递，给定每个订户的最大缓冲区大小，如果非空，则在任何订阅者在方法 onNext中引发异常时调用给定的处理程序。

    • Uses of Executor in javafx.concurrent

      Methods in javafx.concurrent that return Executor
      Modifier and Type 方法 描述
      Executor Service.getExecutor​()
      获取属性执行器的值。
      Methods in javafx.concurrent that return types with arguments of type Executor
      Modifier and Type 方法 描述
      ObjectProperty<Executor> Service.executorProperty​()
      执行者用于运行此服务。
      Methods in javafx.concurrent with parameters of type Executor
      Modifier and Type 方法 描述
      void Service.setExecutor​(Executor value)
      设置属性执行器的值。

    • Uses of Executor in javax.management

      Constructors in javax.management with parameters of type Executor
      Constructor 描述
      NotificationBroadcasterSupport​(Executor executor)
      构造一个NotificationBroadcasterSupport，其中使用给定的Executor调用每个侦听器 。
      NotificationBroadcasterSupport​(Executor executor, MBeanNotificationInfo... info)
      构造一个NotificationBroadcasterSupport，其中包含有关可能发送的通知的信息，以及使用给定的Executor调用每个监听器的信息 。

    • Uses of Executor in javax.xml.ws

      Methods in javax.xml.ws that return Executor
      Modifier and Type 方法 描述
      abstract Executor Endpoint.getExecutor​()
      返回此 Endpoint实例的执行者。
      Executor Service.getExecutor​()
      返回此 Service实例的执行器。
      Methods in javax.xml.ws with parameters of type Executor
      Modifier and Type 方法 描述
      abstract void Endpoint.setExecutor​(Executor executor)
      设置这个 Endpoint实例的执行器。
      void Service.setExecutor​(Executor executor)
      设置这个 Service实例的执行器。

    • Uses of Executor in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Executor
      Modifier and Type 方法 描述
      abstract Executor ServiceDelegate.getExecutor​()
      返回这个 Service实例的执行器。
      Methods in javax.xml.ws.spi with parameters of type Executor
      Modifier and Type 方法 描述
      abstract void ServiceDelegate.setExecutor​(Executor executor)
      设置这个 Service实例的执行器。

    • Uses of Executor in jdk.incubator.http

      Methods in jdk.incubator.http that return Executor
      Modifier and Type 方法 描述
      abstract Executor HttpClient.executor​()
      返回此客户端上设置的 Executor 。
      Methods in jdk.incubator.http with parameters of type Executor
      Modifier and Type 方法 描述
      abstract HttpClient.Builder HttpClient.Builder.executor​(Executor executor)
      Sets the executor to be used for asynchronous tasks.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.ExecutorService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.ExecutorService

  • Packages that use ExecutorService
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ExecutorService in java.nio.channels

      Methods in java.nio.channels with parameters of type ExecutorService
      Modifier and Type 方法 描述
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static AsynchronousChannelGroup AsynchronousChannelGroup.withCachedThreadPool​(ExecutorService executor, int initialSize)
      创建具有给定线程池的异步通道组，根据需要创建新线程。
      static AsynchronousChannelGroup AsynchronousChannelGroup.withThreadPool​(ExecutorService executor)
      使用给定的线程池创建异步通道组。

    • Uses of ExecutorService in java.nio.channels.spi

      Methods in java.nio.channels.spi with parameters of type ExecutorService
      Modifier and Type 方法 描述
      abstract AsynchronousChannelGroup AsynchronousChannelProvider.openAsynchronousChannelGroup​(ExecutorService executor, int initialSize)
      使用给定的线程池构造新的异步通道组。

    • Uses of ExecutorService in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type ExecutorService
      Modifier and Type 方法 描述
      AsynchronousFileChannel FileSystemProvider.newAsynchronousFileChannel​(Path path, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。

    • Uses of ExecutorService in java.util.concurrent

      Subinterfaces of ExecutorService in java.util.concurrent
      Modifier and Type 接口 描述
      interface  ScheduledExecutorService
      一个ExecutorService ，可以调度命令在给定的延迟之后运行，或定期执行。
      Classes in java.util.concurrent that implement ExecutorService
      Modifier and Type Class 描述
      class  AbstractExecutorService
      提供ExecutorService执行方法的默认实现。
      class  ForkJoinPool
      一个ExecutorService，用于运行ForkJoinTask s。
      class  ScheduledThreadPoolExecutor
      A ThreadPoolExecutor可以额外地调度命令在给定的延迟之后运行，或者周期性地执行。
      class  ThreadPoolExecutor
      一个ExecutorService ，它使用可能的几个合并的线程中的一个执行每个提交的任务，通常使用Executors工厂方法配置。
      Methods in java.util.concurrent that return ExecutorService
      Modifier and Type 方法 描述
      static ExecutorService Executors.newCachedThreadPool​()
      创建一个根据需要创建新线程的线程池，但在可用时将重新使用以前构造的线程。
      static ExecutorService Executors.newCachedThreadPool​(ThreadFactory threadFactory)
      创建一个根据需要创建新线程的线程池，但在可用时将重新使用以前构造的线程，并在需要时使用提供的ThreadFactory创建新线程。
      static ExecutorService Executors.newFixedThreadPool​(int nThreads)
      创建一个线程池，该线程池重用固定数量的从共享无界队列中运行的线程。
      static ExecutorService Executors.newFixedThreadPool​(int nThreads, ThreadFactory threadFactory)
      创建一个线程池，重用固定数量的线程，从共享无界队列中运行，使用提供的ThreadFactory在需要时创建新线程。
      static ExecutorService Executors.newSingleThreadExecutor​()
      创建一个使用从无界队列运行的单个工作线程的执行程序。
      static ExecutorService Executors.newSingleThreadExecutor​(ThreadFactory threadFactory)
      创建一个使用单个工作线程运行无界队列的执行程序，并在需要时使用提供的ThreadFactory创建一个新线程。
      static ExecutorService Executors.newWorkStealingPool​()
      使用 available processors作为其目标并行级别创建一个工作窃取线程池。
      static ExecutorService Executors.newWorkStealingPool​(int parallelism)
      创建一个维护足够的线程以支持给定的并行级别的线程池，并且可以使用多个队列来减少争用。
      static ExecutorService Executors.unconfigurableExecutorService​(ExecutorService executor)
      返回一个将所有定义的ExecutorService方法委托给给定执行程序的对象，但不能使用任何其他可能使用转换访问的方法。
      Methods in java.util.concurrent with parameters of type ExecutorService
      Modifier and Type 方法 描述
      static ExecutorService Executors.unconfigurableExecutorService​(ExecutorService executor)
      返回一个将所有定义的ExecutorService方法委托给给定执行程序的对象，但不能使用任何其他可能使用转换访问的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.Flow.Processor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.Flow.Processor

No usage of java.util.concurrent.Flow.Processor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.Flow.Publisher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.Flow.Publisher

  • Packages that use Flow.Publisher
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of Flow.Publisher in java.util.concurrent

      Subinterfaces of Flow.Publisher in java.util.concurrent
      Modifier and Type 接口 描述
      static interface  Flow.Processor<T,R>
      作为订阅者和发布者的组件。
      Classes in java.util.concurrent that implement Flow.Publisher
      Modifier and Type Class 描述
      class  SubmissionPublisher<T>
      A Flow.Publisher ，它向当前订阅者异步发出提交的（非空）项目，直到关闭。

    • Uses of Flow.Publisher in jdk.incubator.http

      Subinterfaces of Flow.Publisher in jdk.incubator.http
      Modifier and Type 接口 描述
      static interface  HttpRequest.BodyProcessor
      将高级Java对象转换为适合作为请求体发送的ByteBuffer的流的处理器 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.Flow.Subscriber (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.Flow.Subscriber

  • Packages that use Flow.Subscriber
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of Flow.Subscriber in java.util.concurrent

      Subinterfaces of Flow.Subscriber in java.util.concurrent
      Modifier and Type 接口 描述
      static interface  Flow.Processor<T,R>
      作为订阅者和发布者的组件。
      Methods in java.util.concurrent that return types with arguments of type Flow.Subscriber
      Modifier and Type 方法 描述
      List<Flow.Subscriber<? super T>> SubmissionPublisher.getSubscribers​()
      返回用于监视和跟踪目的的当前用户列表，而不是在订阅者上调用Flow.Subscriber方法。
      Methods in java.util.concurrent with parameters of type Flow.Subscriber
      Modifier and Type 方法 描述
      boolean SubmissionPublisher.isSubscribed​(Flow.Subscriber<? super T> subscriber)
      如果给定订阅者当前订阅，则返回true。
      void Flow.Publisher.subscribe​(Flow.Subscriber<? super T> subscriber)
      如果可能，添加给定的订阅者。
      void SubmissionPublisher.subscribe​(Flow.Subscriber<? super T> subscriber)
      添加给定订阅者，除非已经订阅。
      Method parameters in java.util.concurrent with type arguments of type Flow.Subscriber
      Modifier and Type 方法 描述
      int SubmissionPublisher.offer​(T item, long timeout, TimeUnit unit, BiPredicate<Flow.Subscriber<? super T>,? super T> onDrop)
      如果可能，通过异步调用其 onNext方法来发布给定的项目，阻止当任何订阅的资源不可用时，直到指定的超时或直到调用者线程被中断，此时给定的处理程序-null）被调用，如果返回true，则重试一次。
      int SubmissionPublisher.offer​(T item, BiPredicate<Flow.Subscriber<? super T>,? super T> onDrop)
      如果可能，通过异步调用其 onNext方法向每个当前用户发布给定项目。
      Constructor parameters in java.util.concurrent with type arguments of type Flow.Subscriber
      Constructor 描述
      SubmissionPublisher​(Executor executor, int maxBufferCapacity, BiConsumer<? super Flow.Subscriber<? super T>,? super Throwable> handler)
      使用给定的Executor创建一个新的SubmissionPublisher，用于为订户提供异步传递，每个订户具有给定的最大缓冲区大小，如果非空，则在任何订阅者在方法 onNext中引发异常时调用给定处理程序。

    • Uses of Flow.Subscriber in jdk.incubator.http

      Subinterfaces of Flow.Subscriber in jdk.incubator.http
      Modifier and Type 接口 描述
      static interface  HttpResponse.BodyProcessor<T>
      响应机构的处理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.Flow.Subscription (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.Flow.Subscription

  • Packages that use Flow.Subscription
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of Flow.Subscription in java.util.concurrent

      Methods in java.util.concurrent with parameters of type Flow.Subscription
      Modifier and Type 方法 描述
      void Flow.Subscriber.onSubscribe​(Flow.Subscription subscription)
      在调用给定订阅的任何其他订阅者方法之前调用的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.ForkJoinPool.ForkJoinWorkerThreadFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.ForkJoinPool.ForkJoinWorkerThreadFactory

  • Packages that use ForkJoinPool.ForkJoinWorkerThreadFactory
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ForkJoinPool.ForkJoinWorkerThreadFactory in java.util.concurrent

      Fields in java.util.concurrent declared as ForkJoinPool.ForkJoinWorkerThreadFactory
      Modifier and Type Field 描述
      static ForkJoinPool.ForkJoinWorkerThreadFactory ForkJoinPool.defaultForkJoinWorkerThreadFactory
      创建一个新的ForkJoinWorkerThread。
      Methods in java.util.concurrent that return ForkJoinPool.ForkJoinWorkerThreadFactory
      Modifier and Type 方法 描述
      ForkJoinPool.ForkJoinWorkerThreadFactory ForkJoinPool.getFactory​()
      返回用于构建新工人的工厂。
      Constructors in java.util.concurrent with parameters of type ForkJoinPool.ForkJoinWorkerThreadFactory
      Constructor 描述
      ForkJoinPool​(int parallelism, ForkJoinPool.ForkJoinWorkerThreadFactory factory, Thread.UncaughtExceptionHandler handler, boolean asyncMode)
      使用给定的参数创建一个 ForkJoinPool （使用默认 值为其他参数 - 参见 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
      ForkJoinPool​(int parallelism, ForkJoinPool.ForkJoinWorkerThreadFactory factory, Thread.UncaughtExceptionHandler handler, boolean asyncMode, int corePoolSize, int maximumPoolSize, int minimumRunnable, Predicate<? super ForkJoinPool> saturate, long keepAliveTime, TimeUnit unit)
      用给定的参数创建一个 ForkJoinPool 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.ForkJoinPool.ManagedBlocker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.ForkJoinPool.ManagedBlocker

  • Packages that use ForkJoinPool.ManagedBlocker
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ForkJoinPool.ManagedBlocker in java.util.concurrent

      Methods in java.util.concurrent with parameters of type ForkJoinPool.ManagedBlocker
      Modifier and Type 方法 描述
      static void ForkJoinPool.managedBlock​(ForkJoinPool.ManagedBlocker blocker)
      运行给定的可能的阻止任务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.Future (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.Future

  • Packages that use Future
    软件包 描述
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.concurrent
    提供javafx.task的一组类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.ws
    此软件包包含核心JAX-WS API。

    • Uses of Future in java.nio.channels

      Methods in java.nio.channels that return Future
      Modifier and Type | 方法 | 描述
      abstract Future<AsynchronousSocketChannel> AsynchronousServerSocketChannel.accept​()
      接受连接。
      abstract Future<Void> AsynchronousSocketChannel.connect​(SocketAddress remote)
      连接此频道。
      Future<FileLock> AsynchronousFileChannel.lock​()
      获取此通道文件的排他锁。
      abstract Future<FileLock> AsynchronousFileChannel.lock​(long position, long size, boolean shared)
      获取此通道文件的给定区域的锁定。
      Future<Integer> AsynchronousByteChannel.read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      abstract Future<Integer> AsynchronousFileChannel.read​(ByteBuffer dst, long position)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      abstract Future<Integer> | AsynchronousSocketChannel.read​(ByteBuffer dst)
      Future<Integer> AsynchronousByteChannel.write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      abstract Future<Integer> AsynchronousFileChannel.write​(ByteBuffer src, long position)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
      abstract Future<Integer> | AsynchronousSocketChannel.write​(ByteBuffer src)

    • Uses of Future in java.util.concurrent

      Subinterfaces of Future in java.util.concurrent
      Modifier and Type 接口 描述
      interface  RunnableFuture<V>
      A Future那是Runnable 。
      interface  RunnableScheduledFuture<V>
      A ScheduledFuture ，这是Runnable 。
      interface  ScheduledFuture<V>
      可以取消延迟结果的行动。
      Classes in java.util.concurrent that implement Future
      Modifier and Type Class 描述
      class  CompletableFuture<T>
      A Future可以明确完成（设置其值和状态），并可用作CompletionStage ，支持在完成后触发的依赖功能和动作。
      class  CountedCompleter<T>
      A ForkJoinTask ，其触发时执行完成操作，并且没有剩余的待处理操作。
      class  ForkJoinTask<V>
      ForkJoinPool中运行的任务的抽象基类。
      class  FutureTask<V>
      可取消的异步计算。
      class  RecursiveAction
      一个递归结果ForkJoinTask 。
      class  RecursiveTask<V>
      递归结果ForkJoinTask 。
      Methods in java.util.concurrent that return Future
      Modifier and Type | 方法 | 描述
      Future<V> CompletionService.poll​()
      检索并删除代表下一个完成任务的未来，或者如果没有，则 null 。
      Future<V> CompletionService.poll​(long timeout, TimeUnit unit)
      检索并删除表示下一个完成的任务的未来，如果还没有，则等待必要时直到指定的等待时间。
      Future<V> | ExecutorCompletionService.poll​()
      Future<V> | ExecutorCompletionService.poll​(long timeout, TimeUnit unit)
      Future<?> | AbstractExecutorService.submit​(Runnable task)
      <T> Future<T> | AbstractExecutorService.submit​(Runnable task, T result)
      <T> Future<T> | AbstractExecutorService.submit​(Callable<T> task)
      Future<V> CompletionService.submit​(Runnable task, V result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      Future<V> CompletionService.submit​(Callable<V> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。
      Future<V> | ExecutorCompletionService.submit​(Runnable task, V result)
      Future<V> | ExecutorCompletionService.submit​(Callable<V> task)
      Future<?> ExecutorService.submit​(Runnable task)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> Future<T> ExecutorService.submit​(Runnable task, T result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> Future<T> ExecutorService.submit​(Callable<T> task)
      提交值返回任务以执行，并返回代表任务待处理结果的Future。
      Future<?> | ScheduledThreadPoolExecutor.submit​(Runnable task)
      <T> Future<T> | ScheduledThreadPoolExecutor.submit​(Runnable task, T result)
      <T> Future<T> | ScheduledThreadPoolExecutor.submit​(Callable<T> task)
      Future<V> CompletionService.take​()
      检索并删除代表下一个完成任务的未来，等待是否还没有任务。
      Future<V> | ExecutorCompletionService.take​()
      Methods in java.util.concurrent that return types with arguments of type Future
      Modifier and Type | 方法 | 描述
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。
      <T> List<Future<T>> | ForkJoinPool.invokeAll​(Collection<? extends Callable<T>> tasks)
      Constructor parameters in java.util.concurrent with type arguments of type Future
      Constructor 描述
      ExecutorCompletionService​(Executor executor, BlockingQueue<Future<V>> completionQueue)
      使用提供的执行程序创建一个ExecutorCompletionService，用于执行基本任务，并将提供的队列作为其完成队列。

    • Uses of Future in javafx.concurrent

      Classes in javafx.concurrent that implement Future
      Modifier and Type Class 描述
      class  Task<V>
      一个完全可观察到的一个FutureTask的实现。

    • Uses of Future in javax.swing

      Classes in javax.swing that implement Future
      Modifier and Type Class 描述
      class  SwingWorker<T,V>
      在后台线程中执行冗长的GUI交互任务的抽象类。

    • Uses of Future in javax.xml.ws

      Subinterfaces of Future in javax.xml.ws
      Modifier and Type 接口 描述
      interface  Response<T>
      Response接口提供了用于获取响应于操作调用发送的消息的有效载荷和上下文的方法。
      Methods in javax.xml.ws that return Future
      Modifier and Type 方法 描述
      Future<?> Dispatch.invokeAsync​(T msg, AsyncHandler<T> handler)
      Invoke a service operation asynchronously.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.RejectedExecutionHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.RejectedExecutionHandler

  • Packages that use RejectedExecutionHandler
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of RejectedExecutionHandler in java.util.concurrent

      Classes in java.util.concurrent that implement RejectedExecutionHandler
      Modifier and Type Class 描述
      static class  ThreadPoolExecutor.AbortPolicy
      被拒绝的任务的处理程序，抛出一个 RejectedExecutionException 。
      static class  ThreadPoolExecutor.CallerRunsPolicy
      一个被拒绝的任务的处理程序，直接在 execute方法的调用线程中运行被拒绝的任务，除非执行程序已经被关闭，否则这个任务被丢弃。
      static class  ThreadPoolExecutor.DiscardOldestPolicy
      被拒绝的任务的处理程序，丢弃最旧的未处理请求，然后重试 execute ，除非执行程序关闭，在这种情况下，任务被丢弃。
      static class  ThreadPoolExecutor.DiscardPolicy
      被拒绝的任务的处理程序静默地丢弃被拒绝的任务。
      Methods in java.util.concurrent that return RejectedExecutionHandler
      Modifier and Type 方法 描述
      RejectedExecutionHandler ThreadPoolExecutor.getRejectedExecutionHandler​()
      返回不可执行任务的当前处理程序。
      Methods in java.util.concurrent with parameters of type RejectedExecutionHandler
      Modifier and Type 方法 描述
      void ThreadPoolExecutor.setRejectedExecutionHandler​(RejectedExecutionHandler handler)
      为不可执行的任务设置一个新的处理程序。
      Constructors in java.util.concurrent with parameters of type RejectedExecutionHandler
      Constructor 描述
      ScheduledThreadPoolExecutor​(int corePoolSize, RejectedExecutionHandler handler)
      用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。
      ScheduledThreadPoolExecutor​(int corePoolSize, ThreadFactory threadFactory, RejectedExecutionHandler handler)
      用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
      使用给定的初始参数创建一个新的 ThreadPoolExecutor 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.RunnableFuture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.RunnableFuture

  • Packages that use RunnableFuture
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.concurrent
    提供javafx.task的一组类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of RunnableFuture in java.util.concurrent

      Subinterfaces of RunnableFuture in java.util.concurrent
      Modifier and Type 接口 描述
      interface  RunnableScheduledFuture<V>
      A ScheduledFuture ，这是Runnable 。
      Classes in java.util.concurrent that implement RunnableFuture
      Modifier and Type Class 描述
      class  FutureTask<V>
      可取消的异步计算。
      Methods in java.util.concurrent that return RunnableFuture
      Modifier and Type | 方法 | 描述
      protected <T> RunnableFuture<T> AbstractExecutorService.newTaskFor​(Runnable runnable, T value)
      为给定的可运行和默认值返回一个 RunnableFuture 。
      protected <T> RunnableFuture<T> AbstractExecutorService.newTaskFor​(Callable<T> callable)
      返回给定可调用任务的 RunnableFuture 。
      protected <T> RunnableFuture<T> | ForkJoinPool.newTaskFor​(Runnable runnable, T value)
      protected <T> RunnableFuture<T> | ForkJoinPool.newTaskFor​(Callable<T> callable)

    • Uses of RunnableFuture in javafx.concurrent

      Classes in javafx.concurrent that implement RunnableFuture
      Modifier and Type Class 描述
      class  Task<V>
      一个完全可观察到的一个FutureTask的实现。

    • Uses of RunnableFuture in javax.swing

      Classes in javax.swing that implement RunnableFuture
      Modifier and Type Class 描述
      class  SwingWorker<T,V>
      在后台线程中执行冗长的GUI交互任务的抽象类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.RunnableScheduledFuture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.RunnableScheduledFuture

  • Packages that use RunnableScheduledFuture
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of RunnableScheduledFuture in java.util.concurrent

      Methods in java.util.concurrent that return RunnableScheduledFuture
      Modifier and Type 方法 描述
      protected <V> RunnableScheduledFuture<V> ScheduledThreadPoolExecutor.decorateTask​(Runnable runnable, RunnableScheduledFuture<V> task)
      修改或替换用于执行runnable的任务。
      protected <V> RunnableScheduledFuture<V> ScheduledThreadPoolExecutor.decorateTask​(Callable<V> callable, RunnableScheduledFuture<V> task)
      修改或替换用于执行可调用的任务。
      Methods in java.util.concurrent with parameters of type RunnableScheduledFuture
      Modifier and Type 方法 描述
      protected <V> RunnableScheduledFuture<V> ScheduledThreadPoolExecutor.decorateTask​(Runnable runnable, RunnableScheduledFuture<V> task)
      修改或替换用于执行runnable的任务。
      protected <V> RunnableScheduledFuture<V> ScheduledThreadPoolExecutor.decorateTask​(Callable<V> callable, RunnableScheduledFuture<V> task)
      修改或替换用于执行可调用的任务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.ScheduledExecutorService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.ScheduledExecutorService

  • Packages that use ScheduledExecutorService
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ScheduledExecutorService in java.util.concurrent

      Classes in java.util.concurrent that implement ScheduledExecutorService
      Modifier and Type Class 描述
      class  ScheduledThreadPoolExecutor
      A ThreadPoolExecutor可以额外地调度在给定延迟之后运行的命令，或者周期性地执行。
      Methods in java.util.concurrent that return ScheduledExecutorService
      Modifier and Type 方法 描述
      static ScheduledExecutorService Executors.newScheduledThreadPool​(int corePoolSize)
      创建一个线程池，可以调度命令在给定的延迟之后运行，或定期执行。
      static ScheduledExecutorService Executors.newScheduledThreadPool​(int corePoolSize, ThreadFactory threadFactory)
      创建一个线程池，可以调度命令在给定的延迟之后运行，或定期执行。
      static ScheduledExecutorService Executors.newSingleThreadScheduledExecutor​()
      创建一个单线程执行器，可以调度命令在给定的延迟之后运行，或定期执行。
      static ScheduledExecutorService Executors.newSingleThreadScheduledExecutor​(ThreadFactory threadFactory)
      创建一个单线程执行器，可以调度命令在给定的延迟之后运行，或定期执行。
      static ScheduledExecutorService Executors.unconfigurableScheduledExecutorService​(ScheduledExecutorService executor)
      返回一个将所有定义的ScheduledExecutorService方法委托给给定执行程序的对象，但不能以其他方式使用转换方式访问。
      Methods in java.util.concurrent with parameters of type ScheduledExecutorService
      Modifier and Type 方法 描述
      static ScheduledExecutorService Executors.unconfigurableScheduledExecutorService​(ScheduledExecutorService executor)
      返回一个将所有定义的ScheduledExecutorService方法委托给给定执行程序的对象，但不能以任何其他可能使用转换方式访问的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.ScheduledFuture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.ScheduledFuture

  • Packages that use ScheduledFuture
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ScheduledFuture in java.util.concurrent

      Subinterfaces of ScheduledFuture in java.util.concurrent
      Modifier and Type 接口 描述
      interface  RunnableScheduledFuture<V>
      A ScheduledFuture那是Runnable 。
      Methods in java.util.concurrent that return ScheduledFuture
      Modifier and Type | 方法 | 描述
      ScheduledFuture<?> ScheduledExecutorService.schedule​(Runnable command, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的单次操作。
      <V> ScheduledFuture<V> ScheduledExecutorService.schedule​(Callable<V> callable, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的ScheduledFuture。
      ScheduledFuture<?> | ScheduledThreadPoolExecutor.schedule​(Runnable command, long delay, TimeUnit unit)
      <V> ScheduledFuture<V> | ScheduledThreadPoolExecutor.schedule​(Callable<V> callable, long delay, TimeUnit unit)
      ScheduledFuture<?> ScheduledExecutorService.scheduleAtFixedRate​(Runnable command, long initialDelay, long period, TimeUnit unit)
      创建并执行在给定的初始延迟之后，随后以给定的时间段首先启用的周期性动作; 即处决将在initialDelay之后开始，然后是initialDelay + period ，然后是initialDelay + 2 * period ，等等。
      ScheduledFuture<?> | ScheduledThreadPoolExecutor.scheduleAtFixedRate​(Runnable command, long initialDelay, long period, TimeUnit unit)
      ScheduledFuture<?> ScheduledExecutorService.scheduleWithFixedDelay​(Runnable command, long initialDelay, long delay, TimeUnit unit)
      创建并执行在给定的初始延迟之后首先启用的定期动作，随后在一个执行的终止和下一个执行的开始之间给定的延迟。
      ScheduledFuture<?> | ScheduledThreadPoolExecutor.scheduleWithFixedDelay​(Runnable command, long initialDelay, long delay, TimeUnit unit)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.ThreadFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.ThreadFactory

  • Packages that use ThreadFactory
    软件包 描述
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    2706187864977包的服务提供商类。
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ThreadFactory in java.lang.ref

      Methods in java.lang.ref with parameters of type ThreadFactory
      Modifier and Type 方法 描述
      static Cleaner Cleaner.create​(ThreadFactory threadFactory)
      返回一个新的 Cleaner使用 Thread从 ThreadFactory 。

    • Uses of ThreadFactory in java.nio.channels

      Methods in java.nio.channels with parameters of type ThreadFactory
      Modifier and Type 方法 描述
      static AsynchronousChannelGroup AsynchronousChannelGroup.withFixedThreadPool​(int nThreads, ThreadFactory threadFactory)
      创建具有固定线程池的异步通道组。

    • Uses of ThreadFactory in java.nio.channels.spi

      Methods in java.nio.channels.spi with parameters of type ThreadFactory
      Modifier and Type 方法 描述
      abstract AsynchronousChannelGroup AsynchronousChannelProvider.openAsynchronousChannelGroup​(int nThreads, ThreadFactory threadFactory)
      构造一个具有固定线程池的新的异步通道组。

    • Uses of ThreadFactory in java.util.concurrent

      Methods in java.util.concurrent that return ThreadFactory
      Modifier and Type 方法 描述
      static ThreadFactory Executors.defaultThreadFactory​()
      返回用于创建新线程的默认线程工厂。
      ThreadFactory ThreadPoolExecutor.getThreadFactory​()
      返回用于创建新线程的线程工厂。
      static ThreadFactory Executors.privilegedThreadFactory​()
      返回一个用于创建与当前线程具有相同权限的新线程的线程工厂。
      Methods in java.util.concurrent with parameters of type ThreadFactory
      Modifier and Type 方法 描述
      static ExecutorService Executors.newCachedThreadPool​(ThreadFactory threadFactory)
      创建一个根据需要创建新线程的线程池，但在可用时将重新使用以前构造的线程，并在需要时使用提供的ThreadFactory创建新线程。
      static ExecutorService Executors.newFixedThreadPool​(int nThreads, ThreadFactory threadFactory)
      创建一个线程池，重用固定数量的线程，从共享无界队列中运行，使用提供的ThreadFactory在需要时创建新线程。
      static ScheduledExecutorService Executors.newScheduledThreadPool​(int corePoolSize, ThreadFactory threadFactory)
      创建一个线程池，可以调度命令在给定的延迟之后运行，或定期执行。
      static ExecutorService Executors.newSingleThreadExecutor​(ThreadFactory threadFactory)
      创建一个使用单个工作线程运行无界队列的执行程序，并在需要时使用提供的ThreadFactory创建一个新线程。
      static ScheduledExecutorService Executors.newSingleThreadScheduledExecutor​(ThreadFactory threadFactory)
      创建一个单线程执行器，可以调度命令在给定的延迟之后运行，或定期执行。
      void ThreadPoolExecutor.setThreadFactory​(ThreadFactory threadFactory)
      设置用于创建新线程的线程工厂。
      Constructors in java.util.concurrent with parameters of type ThreadFactory
      Constructor 描述
      ScheduledThreadPoolExecutor​(int corePoolSize, ThreadFactory threadFactory)
      使用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。
      ScheduledThreadPoolExecutor​(int corePoolSize, ThreadFactory threadFactory, RejectedExecutionHandler handler)
      使用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认拒绝执行处理程序。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
      使用给定的初始参数创建一个新的 ThreadPoolExecutor 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.TransferQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.TransferQueue

  • Packages that use TransferQueue
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of TransferQueue in java.util.concurrent

      Classes in java.util.concurrent that implement TransferQueue
      Modifier and Type Class 描述
      class  LinkedTransferQueue<E>
      基于链接节点的无界TransferQueue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AbstractOwnableSynchronizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class AbstractOwnableSynchronizer

  • java.lang.Object
    • java.util.concurrent.locks.AbstractOwnableSynchronizer
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AbstractQueuedLongSynchronizer ， AbstractQueuedSynchronizer

    public abstract class AbstractOwnableSynchronizer
extends Object
implements Serializable
    可以由线程专有的同步器。 该类提供了创建可能需要所有权概念的锁和相关同步器的基础。 AbstractOwnableSynchronizer类本身不管理或使用此信息。 然而，子类和工具可以使用适当维护的值来帮助控制和监视访问并提供诊断。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractOwnableSynchronizer​()
      空构造器供子类使用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Thread getExclusiveOwnerThread​()
      返回最后设置的线程为 setExclusiveOwnerThread ，如果从未设置，则返回 null 。
      protected void setExclusiveOwnerThread​(Thread thread)
      设置当前拥有独占访问权限的线程。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractOwnableSynchronizer

        protected AbstractOwnableSynchronizer​()
        空构造器供子类使用。

    • 方法详细信息

      • setExclusiveOwnerThread

        protected final void setExclusiveOwnerThread​(Thread thread)
        设置当前拥有独占访问权限的线程。 一个null参数表示没有线程拥有访问权限。 这种方法不会强加任何同步或volatile字段访问。
        参数
        thread - 所有者线程

      • getExclusiveOwnerThread

        protected final Thread getExclusiveOwnerThread​()
        返回由setExclusiveOwnerThread最后设置的线程，如果从未设置，则返回null 。 这种方法没有另外强加任何同步或volatile字段访问。
        结果
        the owner thread
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractQueuedLongSynchronizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class AbstractQueuedLongSynchronizer

  • java.lang.Object
    • java.util.concurrent.locks.AbstractOwnableSynchronizer
      • java.util.concurrent.locks.AbstractQueuedLongSynchronizer
  • All Implemented Interfaces:
    Serializable

    public abstract class AbstractQueuedLongSynchronizer
extends AbstractOwnableSynchronizer
implements Serializable
    AbstractQueuedSynchronizer的版本，其中同步状态维持为long 。 该类具有与AbstractQueuedSynchronizer完全相同的结构，属性和方法，除了所有与状态相关的参数和结果定义为long而不是int 。 当创建同步器（例如需要64位状态的多级锁和障碍）时，此类可能很有用。

    有关使用说明和示例，请参阅AbstractQueuedSynchronizer 。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      class  AbstractQueuedLongSynchronizer.ConditionObject
      条件实施AbstractQueuedLongSynchronizer作为Lock实施的基础。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractQueuedLongSynchronizer​()
      创建一个初始同步状态为零的新的 AbstractQueuedLongSynchronizer实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void acquire​(long arg)
      以独占模式获取，忽略中断。
      void acquireInterruptibly​(long arg)
      以独占方式获得，如果中断，中止。
      void acquireShared​(long arg)
      以共享模式获取，忽略中断。
      void acquireSharedInterruptibly​(long arg)
      以共享方式获取，如果中断，中止。
      protected boolean compareAndSetState​(long expect, long update)
      如果当前状态值等于期望值，则将同步状态原子设置为给定的更新值。
      Collection<Thread> getExclusiveQueuedThreads​()
      返回一个包含可能正在等待以独占模式获取的线程的集合。
      Thread getFirstQueuedThread​()
      返回队列中的第一个（最长等待）线程，如果当前没有线程排队，则 null 。
      Collection<Thread> getQueuedThreads​()
      返回一个包含可能正在等待获取的线程的集合。
      int getQueueLength​()
      返回等待获取的线程数的估计。
      Collection<Thread> getSharedQueuedThreads​()
      返回包含可能正在等待在共享模式下获取的线程的集合。
      protected long getState​()
      返回同步状态的当前值。
      Collection<Thread> getWaitingThreads​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。
      int getWaitQueueLength​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      返回等待与此同步器相关联的给定条件的线程数量的估计。
      boolean hasContended​()
      查询任何线程是否有争取获取此同步器; 也就是说，如果获取方法被阻止。
      boolean hasQueuedPredecessors​()
      查询任何线程是否等待获取比当前线程更长的时间。
      boolean hasQueuedThreads​()
      查询任何线程是否等待获取。
      boolean hasWaiters​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      查询任何线程是否等待与此同步器相关联的给定条件。
      protected boolean isHeldExclusively​()
      如果同步仅针对当前（调用）线程进行 true则返回 true 。
      boolean isQueued​(Thread thread)
      如果给定的线程当前排队，则返回true。
      boolean owns​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      查询给定的ConditionObject是否将此同步器用作其锁。
      boolean release​(long arg)
      以专属模式发布。
      boolean releaseShared​(long arg)
      以共享模式发布。
      protected void setState​(long newState)
      设置同步状态的值。
      String toString​()
      返回一个标识此同步器的字符串及其状态。
      protected boolean tryAcquire​(long arg)
      尝试以独占模式获取。
      boolean tryAcquireNanos​(long arg, long nanosTimeout)
      尝试以独占模式获取，如果中断则中止，如果给定的超时时间失败。
      protected long tryAcquireShared​(long arg)
      尝试以共享模式获取。
      boolean tryAcquireSharedNanos​(long arg, long nanosTimeout)
      尝试以共享模式获取，如果中断则中止，如果给定的时间超过，则失败。
      protected boolean tryRelease​(long arg)
      尝试设置状态以独占模式反映释放。
      protected boolean tryReleaseShared​(long arg)
      尝试将状态设置为以共享模式反映发布。

      • Methods inherited from class java.util.concurrent.locks.AbstractOwnableSynchronizer

        getExclusiveOwnerThread, setExclusiveOwnerThread

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractQueuedLongSynchronizer

        protected AbstractQueuedLongSynchronizer​()
        创建一个初始同步状态为零的新的 AbstractQueuedLongSynchronizer实例。

    • 方法详细信息

      • getState

        protected final long getState​()
        返回同步状态的当前值。 这个操作具有volatile读取的记忆语义。
        结果
        当前状态值

      • setState

        protected final void setState​(long newState)
        设置同步状态的值。 此操作具有volatile写入的内存语义。
        参数
        newState - 新的状态值

      • compareAndSetState

        protected final boolean compareAndSetState​(long expect,
                                           long update)
        如果当前状态值等于期望值，则将同步状态原子设置为给定的更新值。 此操作具有volatile读写的内存语义。
        参数
        expect - 预期值
        update - 新价值
        结果
        true如果成功。 False return表示实际值不等于预期值。

      • tryAcquire

        protected boolean tryAcquire​(long arg)
        尝试以独占模式获取。 该方法应该查询对象的状态是否允许以独占模式获取，如果是，则获取它。

        该方法总是由执行获取的线程调用。 如果此方法报告失败，则获取方法可能将线程排队（如果尚未排队），直到被其他线程释放为止。 这可以用于实现方法Lock.tryLock() 。

        默认实现抛出UnsupportedOperationException 。

        参数
        arg - 获取的论据。 该值始终是传递给获取方法的值，也可以是进入条件等待时保存的值。 该值否则无法解释，可以代表您喜欢的任何内容。
        结果
        true如果成功。 一旦成功，这个对象就被收购了。
        异常
        IllegalMonitorStateException - 如果获取将使该同步器处于非法状态。 必须以一致的方式抛出此异常，以使同步正常工作。
        UnsupportedOperationException - 如果不支持排他模式

      • tryRelease

        protected boolean tryRelease​(long arg)
        尝试设置状态以独占模式反映释放。

        该方法总是由执行释放的线程调用。

        默认实现会抛出UnsupportedOperationException 。

        参数
        arg - 释放参数。 该值始终是传递给release方法的值，或者进入条件等待时的当前状态值。 该值否则无法解释，可以代表您喜欢的任何内容。
        结果
        true如果此对象现在处于完全释放状态，以便任何等待线程可能尝试获取; 另外false 。
        异常
        IllegalMonitorStateException - 如果释放将使该同步器处于非法状态。 必须以一致的方式抛出此异常，以使同步正常工作。
        UnsupportedOperationException - 如果不支持排他模式

      • tryAcquireShared

        protected long tryAcquireShared​(long arg)
        尝试以共享模式获取。 该方法应该查询对象的状态是否允许在共享模式下获取该对象，如果是这样，就可以获取它。

        该方法总是由执行获取的线程调用。 如果此方法报告失败，则获取方法可能将线程排队（如果尚未排队），直到被其他线程释放为止。

        默认实现抛出UnsupportedOperationException 。

        参数
        arg - 获取的论据。 该值始终是传递给获取方法的值，也可以是进入条件等待时保存的值。 该值否则无法解释，可以代表您喜欢的任何内容。
        结果
        失败的负值 如果在共享模式下获取成功但没有后续共享模式获取可以成功，则为零; 并且如果在共享模式下的获取成功并且随后的共享模式获取可能成功，则为正值，在这种情况下，后续等待线程必须检查可用性。 （支持三种不同的返回值使得这种方法可以在仅获取有时只能完全执行的上下文中使用。）成功后，该对象已被获取。
        异常
        IllegalMonitorStateException - 如果获取将该同步器置于非法状态。 必须以一致的方式抛出此异常，以使同步正常工作。
        UnsupportedOperationException - 如果不支持共享模式

      • tryReleaseShared

        protected boolean tryReleaseShared​(long arg)
        尝试将状态设置为以共享模式反映发布。

        该方法总是由执行释放的线程调用。

        默认实现抛出UnsupportedOperationException 。

        参数
        arg - 释放参数。 该值始终是传递给release方法的值，或者进入条件等待时的当前状态值。 该值否则无法解释，可以代表您喜欢的任何内容。
        结果
        true如果这种共享模式的发布可能允许等待获取（共享或排他）成功; 而另外false
        异常
        IllegalMonitorStateException - 如果释放将使该同步器处于非法状态。 必须以一致的方式抛出此异常，以使同步正常工作。
        UnsupportedOperationException - 如果不支持共享模式

      • isHeldExclusively

        protected boolean isHeldExclusively​()
        如果同步仅针对当前（调用）线程进行true则返回true 。 每次调用不等待AbstractQueuedLongSynchronizer.ConditionObject方法时调用此方法。 （等待方法调用release(long)。 ）

        默认实现抛出UnsupportedOperationException 。 此方法仅在AbstractQueuedLongSynchronizer.ConditionObject方法内部调用，因此如果不使用条件，则不需要定义该方法。

        结果
        true如果同步是唯一的; false否则
        异常
        UnsupportedOperationException - 如果不支持条件

      • acquire

        public final void acquire​(long arg)
        以独占模式获取，忽略中断。 通过调用至少一次执行tryAcquire(long) ，成功返回。 否则线程排队，可能会重复阻塞和解除阻塞，直到成功才调用tryAcquire(long) 。 该方法可以用于实现方法Lock.lock() 。
        参数
        arg - 获取的论据。 该值传达到tryAcquire(long) ，否则将被解释，可以代表您喜欢的任何内容。

      • acquireInterruptibly

        public final void acquireInterruptibly​(long arg)
                                throws InterruptedException
        以独占方式获得，如果中断，中止。 通过首先检查中断状态，然后调用至少一次tryAcquire(long) ，成功返回。 否则线程排队，可能会重复阻塞和解除阻塞，调用tryAcquire(long)直到成功或线程中断。 该方法可用于实现方法Lock.lockInterruptibly() 。
        参数
        arg - 收购论据。 该值传达到tryAcquire(long) ，否则将被解释，并可以代表您喜欢的任何内容。
        异常
        InterruptedException - 当前线程是否中断

      • tryAcquireNanos

        public final boolean tryAcquireNanos​(long arg,
                                     long nanosTimeout)
                              throws InterruptedException
        尝试以独占模式获取，如果中断则中止，如果给定的超时时间失败。 通过首先检查中断状态，然后调用至少一次tryAcquire(long) ，成功返回。 否则，线程排队，可能会重复阻塞和解除阻塞，调用tryAcquire(long)直到成功或线程中断或超时。 该方法可用于实现方法Lock.tryLock(long, TimeUnit) 。
        参数
        arg - 获取的论据。 该值被传送到tryAcquire(long) ，否则将被解释并且可以代表你喜欢的任何东西。
        nanosTimeout - 等待的最大纳秒数
        结果
        true如果获得; false如果超时
        异常
        InterruptedException - 当前线程是否中断

      • release

        public final boolean release​(long arg)
        以专属模式发布。 如果tryRelease(long)返回true，则通过解除阻塞一个或多个线程来实现。 该方法可以用于实现方法Lock.unlock() 。
        参数
        arg - 释放参数。 该值被传送到tryRelease(long) ，否则将被解释，并且可以代表你喜欢的任何东西。
        结果
        该值从 tryRelease(long)返回

      • acquireShared

        public final void acquireShared​(long arg)
        以共享模式获取，忽略中断。 通过首次调用至少一次执行tryAcquireShared(long) ，成功返回。 否则线程排队，可能重复阻塞和解锁，调用tryAcquireShared(long)直到成功。
        参数
        arg - 获取的论据。 该值传达到tryAcquireShared(long) ，否则将被解释，并可以代表您喜欢的任何内容。

      • acquireSharedInterruptibly

        public final void acquireSharedInterruptibly​(long arg)
                                      throws InterruptedException
        以共享方式获取，如果中断，中止。 通过首先检查中断状态，然后调用至少一次tryAcquireShared(long) ，成功返回。 否则线程排队，可能会重复阻塞和解除阻塞，调用tryAcquireShared(long)直到成功或线程中断。
        参数
        arg - 获取的论据。 该值传达到tryAcquireShared(long) ，否则将被解释，并可以代表您喜欢的任何内容。
        异常
        InterruptedException - 当前线程是否中断

      • tryAcquireSharedNanos

        public final boolean tryAcquireSharedNanos​(long arg,
                                           long nanosTimeout)
                                    throws InterruptedException
        尝试以共享模式获取，如果中断则中止，如果给定的时间超过，则失败。 通过首先检查中断状态，然后调用至少一次tryAcquireShared(long) ，成功返回。 否则，线程排队，可能会重复阻塞和解除阻塞，调用tryAcquireShared(long)直到成功或线程中断或超时。
        参数
        arg - 获取的论据。 该值被传送到tryAcquireShared(long) ，否则将被解释，并且可以代表你喜欢的任何东西。
        nanosTimeout - 等待的最大纳秒数
        结果
        true如果获得; false如果超时
        异常
        InterruptedException - 当前线程是否中断

      • releaseShared

        public final boolean releaseShared​(long arg)
        以共享模式发布。 如果tryReleaseShared(long)返回true，则通过解除阻塞一个或多个线程来实现。
        参数
        arg - 释放参数。 该值被传送到tryReleaseShared(long) ，否则无法解释，可以代表您喜欢的任何东西。
        结果
        该值从 tryReleaseShared(long)返回

      • hasQueuedThreads

        public final boolean hasQueuedThreads​()
        查询任何线程是否等待获取。 请注意，由于中断和超时可能会随时发生取消，因此true返回不能保证任何其他线程将获得。

        在这个实现中，这个操作返回恒定的时间。

        结果
        true如果可能有其他线程等待获取

      • hasContended

        public final boolean hasContended​()
        查询任何线程是否有争取获取此同步器; 也就是说，如果获取方法被阻止。

        在这个实现中，这个操作返回恒定的时间。

        结果
        true如果有争论

      • getFirstQueuedThread

        public final Thread getFirstQueuedThread​()
        返回队列中的第一个（最长等待）线程，如果没有线程当前排队，则null 。

        在这个实现中，这个操作通常在常量时间内返回，但如果其他线程同时修改队列，则可以在争用时迭代。

        结果
        队列中的第一个（最长等待）线程，如果没有线程当前排队， null

      • isQueued

        public final boolean isQueued​(Thread thread)
        如果给定的线程当前排队，则返回true。

        该实现遍历队列以确定给定线程的存在。

        参数
        thread - 线程
        结果
        true如果给定的线程在队列上
        异常
        NullPointerException - 如果线程为空

      • hasQueuedPredecessors

        public final boolean hasQueuedPredecessors​()
        查询任何线程是否等待获取比当前线程更长的时间。

        调用此方法等同于（但可能更有效）：

           getFirstQueuedThread() != Thread.currentThread() && hasQueuedThreads()

        请注意，因为由于中断和超时而导致的取消可能随时发生，所以true返回不能保证其他一些线程将在当前线程之前获取。 同样，由于队列为空，这个方法返回了false后，另一个线程可能会赢得比赛排队。

        该方法被设计为由公平同步器使用以避免barging 。 这种同步器的tryAcquire(long)方法应该返回false ，其tryAcquireShared(long)方法应该返回一个负值，如果此方法返回true （除非这是一个可重入获取）。 例如，公平，可重入，独占模式同步器的tryAcquire方法可能如下所示：

           protected boolean tryAcquire(int arg) { if (isHeldExclusively()) { // A reentrant acquire; increment hold count return true; } else if (hasQueuedPredecessors()) { return false; } else { // try to acquire normally } }
        结果
        true如果当前线程前面有一个排队的线程，而 false如果当前线程在队列的头部或队列是空的
        从以下版本开始：
        1.7

      • getQueueLength

        public final int getQueueLength​()
        返回等待获取的线程数的估计。 该值只是一个估计，因为线程数可能会在此方法遍历内部数据结构时动态更改。 该方法设计用于监控系统状态，不用于同步控制。
        结果
        估计等待获取的线程数

      • getQueuedThreads

        public final Collection<Thread> getQueuedThreads​()
        返回一个包含可能正在等待获取的线程的集合。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。 该方法旨在便于构建提供更广泛监控设施的子类。
        结果
        线程的收集

      • getExclusiveQueuedThreads

        public final Collection<Thread> getExclusiveQueuedThreads​()
        返回一个包含可能正在等待以独占模式获取的线程的集合。 这与getQueuedThreads()具有相同的属性，除了它只返回那些由于排他获取等待的线程。
        结果
        线程的收集

      • getSharedQueuedThreads

        public final Collection<Thread> getSharedQueuedThreads​()
        返回包含可能正在等待在共享模式下获取的线程的集合。 这与getQueuedThreads()具有相同的属性，除了它只返回那些由于共享获取等待的线程。
        结果
        线程的收集

      • toString

        public String toString​()
        返回一个标识此同步器的字符串及其状态。 括号中的状态包括字符串"State ="后跟当前值getState() ，并且"nonempty"或"empty"取决于队列是否为空。
        重写：
        toString在 Object
        结果
        识别此同步器的字符串以及其状态

      • owns

        public final boolean owns​(AbstractQueuedLongSynchronizer.ConditionObject condition)
        查询给定的ConditionObject是否将此同步器用作其锁。
        参数
        condition - 条件
        结果
        true如果拥有
        异常
        NullPointerException - 如果条件为空

      • hasWaiters

        public final boolean hasWaiters​(AbstractQueuedLongSynchronizer.ConditionObject condition)
        查询任何线程是否等待与此同步器相关联的给定条件。 请注意，由于超时和中断可能随时发生，所以true返回不能保证未来的signal将唤醒任何线程。 该方法主要用于监视系统状态。
        参数
        condition - 条件
        结果
        true如果有任何等待线程
        异常
        IllegalMonitorStateException - 如果不保留独占同步
        IllegalArgumentException - 如果给定的条件与此同步器没有关联
        NullPointerException - 如果条件为空

      • getWaitQueueLength

        public final int getWaitQueueLength​(AbstractQueuedLongSynchronizer.ConditionObject condition)
        返回等待与此同步器相关联的给定条件的线程数量的估计。 请注意，由于超时和中断可能在任何时间发生，估计仅作为实际服务员人数的上限。 该方法设计用于监控系统状态，不用于同步控制。
        参数
        condition - 条件
        结果
        估计等待线程数
        异常
        IllegalMonitorStateException - 如果不保留独占同步
        IllegalArgumentException - 如果给定条件与该同步器不相关联
        NullPointerException - 如果条件为空

      • getWaitingThreads

        public final Collection<Thread> getWaitingThreads​(AbstractQueuedLongSynchronizer.ConditionObject condition)
        返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。
        参数
        condition - 条件
        结果
        线程的收集
        异常
        IllegalMonitorStateException - 如果不保留独占同步
        IllegalArgumentException - 如果给定的条件与此同步器没有关联
        NullPointerException - 如果条件为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractQueuedLongSynchronizer.ConditionObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class AbstractQueuedLongSynchronizer.ConditionObject

  • java.lang.Object
    • java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
  • All Implemented Interfaces:
    Serializable ， Condition
    Enclosing class:
    AbstractQueuedLongSynchronizer

    public class AbstractQueuedLongSynchronizer.ConditionObject
extends Object
implements Condition, Serializable
    条件实施为AbstractQueuedLongSynchronizer作为Lock实施的基础。

    该类的方法文档描述了从锁定和条件用户角度看的机制，而不是行为规范。 该类的导出版本一般需要附有说明依赖于相关联的AbstractQueuedLongSynchronizer条件语义的文档。

    这个类是Serializable，但是所有字段都是暂时的，所以反序列化的条件没有服务器。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConditionObject​()
      创建一个新的 ConditionObject实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void await​()
      实现可中断条件等待。
      boolean await​(long time, TimeUnit unit)
      实现定时状态等待。
      long awaitNanos​(long nanosTimeout)
      实现定时状态等待。
      void awaitUninterruptibly​()
      实现不间断状态等待。
      boolean awaitUntil​(Date deadline)
      实现绝对定时条件等待。
      protected Collection<Thread> getWaitingThreads​()
      返回一个包含可能在此条件下等待的线程的集合。
      protected int getWaitQueueLength​()
      返回等待此条件的线程数的估计。
      protected boolean hasWaiters​()
      查询是否有线程正在等待这种情况。
      void signal​()
      将最长等待的线程（如果存在）从等待队列移动到拥有锁的等待队列。
      void signalAll​()
      将所有线程从这个条件的等待队列移动到拥有锁的等待队列。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ConditionObject

        public ConditionObject​()
        创建一个新的 ConditionObject实例。

    • 方法详细信息

      • signal

        public final void signal​()
        将最长等待的线程（如果存在）从等待队列移动到拥有锁的等待队列。
        Specified by:
        signal在接口 Condition
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively()返回 false

      • signalAll

        public final void signalAll​()
        将所有线程从这个条件的等待队列移动到拥有锁的等待队列。
        Specified by:
        signalAll在接口 Condition
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively()返回 false

      • awaitUninterruptibly

        public final void awaitUninterruptibly​()
        实现不间断状态等待。
        1. 保存锁定状态由AbstractQueuedLongSynchronizer.getState()返回。
        2. 以保存状态为参数调用AbstractQueuedLongSynchronizer.release(long) ，如果失败，则抛出IllegalMonitorStateException。
        3. 阻止直到发信号。
        4. 通过调用具有保存状态的专用版本的AbstractQueuedLongSynchronizer.acquire(long)作为参数来重新获取。
        Specified by:
        awaitUninterruptibly在接口 Condition

      • await

        public final void await​()
                 throws InterruptedException
        实现可中断条件等待。
        1. 如果当前线程中断，则抛出InterruptedException。
        2. 保存锁定状态由AbstractQueuedLongSynchronizer.getState()返回。
        3. 以保存状态为参数调用AbstractQueuedLongSynchronizer.release(long) ，如果失败，则抛出IllegalMonitorStateException。
        4. 阻塞直到发信号或中断。
        5. 通过调用具有保存状态的AbstractQueuedLongSynchronizer.acquire(long)的专用版本作为参数来重新获取。
        6. 如果在步骤4中被阻塞时中断，则抛出InterruptedException。
        Specified by:
        await在接口 Condition
        异常
        InterruptedException - 如果当前线程中断（并且支持线程中断）

      • awaitNanos

        public final long awaitNanos​(long nanosTimeout)
                      throws InterruptedException
        实现定时状态等待。
        1. 如果当前线程中断，则抛出InterruptedException。
        2. 保存锁定状态返回AbstractQueuedLongSynchronizer.getState() 。
        3. 调用AbstractQueuedLongSynchronizer.release(long) ，保存状态为参数，如果失败，则抛出IllegalMonitorStateException。
        4. 阻塞直到发信号，中断或超时。
        5. 通过调用具有保存状态的专用版本的AbstractQueuedLongSynchronizer.acquire(long)作为参数来重新获取。
        6. 如果在步骤4中被阻塞时中断，则抛出InterruptedException。
        Specified by:
        awaitNanos在接口 Condition
        参数
        nanosTimeout - 以纳秒为 nanosTimeout的最长等待时间
        结果
        估计nanosTimeout值减去等待从此方法返回的时间。 可以使用正值作为随后调用此方法的参数，以完成等待所需时间。 小于或等于零的值表示没有时间。
        异常
        InterruptedException - 如果当前线程被中断（并且支持线程中断的中断）

      • awaitUntil

        public final boolean awaitUntil​(Date deadline)
                         throws InterruptedException
        实现绝对定时条件等待。
        1. 如果当前线程中断，则抛出InterruptedException。
        2. 保存锁定状态返回AbstractQueuedLongSynchronizer.getState() 。
        3. 调用AbstractQueuedLongSynchronizer.release(long) ，保存状态为参数，如果失败，则抛出IllegalMonitorStateException。
        4. 阻塞直到发信号，中断或超时。
        5. 通过调用具有保存状态的AbstractQueuedLongSynchronizer.acquire(long)的专用版本作为参数来重新获取。
        6. 如果在步骤4中被阻塞时中断，则抛出InterruptedException。
        7. 如果在步骤4中被阻止时超时，返回false，否则返回true。
        Specified by:
        awaitUntil在接口 Condition
        参数
        deadline - 绝对等待的时间
        结果
        false如果最后期限在退货后已过，否则为 true
        异常
        InterruptedException - 如果当前线程中断（并且支持线程中断）

      • await

        public final boolean await​(long time,
                           TimeUnit unit)
                    throws InterruptedException
        实现定时状态等待。
        1. 如果当前线程中断，则抛出InterruptedException。
        2. 保存锁定状态返回AbstractQueuedLongSynchronizer.getState() 。
        3. 以保存状态为参数调用AbstractQueuedLongSynchronizer.release(long) ，如果失败，则抛出IllegalMonitorStateException。
        4. 阻塞直到发信号，中断或超时。
        5. 通过调用专用版本的AbstractQueuedLongSynchronizer.acquire(long)通过保存的状态作为参数来获取。
        6. 如果在步骤4中被阻塞时中断，则抛出InterruptedException。
        7. 如果在步骤4中被阻止时超时，返回false，否则返回true。
        Specified by:
        await在接口 Condition
        参数
        time - 等待的最长时间
        unit - time参数的时间单位
        结果
        false如果等待时间可以从方法返回前经过，否则 true
        异常
        InterruptedException - 如果当前线程中断（支持线程中断）

      • hasWaiters

        protected final boolean hasWaiters​()
        查询是否有线程正在等待这种情况。 实现AbstractQueuedLongSynchronizer.hasWaiters(ConditionObject) 。
        结果
        true如果有任何等待线程
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively()返回 false

      • getWaitQueueLength

        protected final int getWaitQueueLength​()
        返回等待此条件的线程数的估计。 实现AbstractQueuedLongSynchronizer.getWaitQueueLength(ConditionObject) 。
        结果
        估计等待线程数
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively()返回 false

      • getWaitingThreads

        protected final Collection<Thread> getWaitingThreads​()
        返回一个包含可能在此条件下等待的线程的集合。 实现AbstractQueuedLongSynchronizer.getWaitingThreads(ConditionObject) 。
        结果
        线程的收集
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively()返回 false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractQueuedSynchronizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class AbstractQueuedSynchronizer

  • java.lang.Object
    • java.util.concurrent.locks.AbstractOwnableSynchronizer
      • java.util.concurrent.locks.AbstractQueuedSynchronizer
  • All Implemented Interfaces:
    Serializable

    public abstract class AbstractQueuedSynchronizer
extends AbstractOwnableSynchronizer
implements Serializable
    提供一个框架，用于实现依赖先进先出（FIFO）等待队列的阻塞锁和相关同步器（信号量，事件等）。 这个类被设计为大多数类型的同步器的有用的依据，这些同步器依赖于单个原子int值来表示状态。 子类必须定义改变此状态的受保护方法，以及根据该对象获取或释放的方式来定义该状态。 给定这些，这个类中的其他方法执行所有排队和阻塞机制。 子类可以保持其他状态字段，但只以原子方式更新int使用方法操纵值getState() ， setState(int)和compareAndSetState(int, int)跟踪相对于同步。

    子类应定义为非公共内部助手类，用于实现其封闭类的同步属性。 AbstractQueuedSynchronizer类不实现任何同步接口。 相反，它定义了可以通过具体锁和相关同步器适当地调用的方法，例如acquireInterruptibly(int)来实现其公共方法。

    此类支持默认独占模式和共享模式。 当以独占模式获取时，尝试通过其他线程获取不能成功。 多线程获取的共享模式可能（但不需要）成功。 除了在机械意义上，这个类不理解这些差异，当共享模式获取成功时，下一个等待线程（如果存在）也必须确定它是否也可以获取。 在不同模式下等待的线程共享相同的FIFO队列。 通常，实现子类仅支持这些模式之一，但是二者可以在ReadWriteLock中发挥作用 。 仅支持独占或仅共享模式的子类不需要定义支持未使用模式的方法。

    该类定义了一个嵌套的AbstractQueuedSynchronizer.ConditionObject类，可以通过支持独占模式的子类用作Condition实现，方法isHeldExclusively()报告是否同步针对当前线程进行独占保留，使用当前getState()值调用的方法release(int)完全释放此对象，和acquire(int) ，给定此保存的状态值，最终将此对象恢复到其先前获取的状态。 否则AbstractQueuedSynchronizer方法会创建这样的条件，所以如果不能满足这个约束，不要使用它。 AbstractQueuedSynchronizer.ConditionObject的行为当然取决于其同步器实现的语义。

    该类为内部队列提供检查，检测和监控方法，以及条件对象的类似方法。 这些可以根据需要导出到类中，使用AbstractQueuedSynchronizer进行同步机制。

    此类的序列化仅存储底层原子整数维持状态，因此反序列化对象具有空线程队列。 需要可序列化的典型子类将定义一个readObject方法，可以将其恢复为反序列化时的已知初始状态。

    用法

    使用这个类用作同步的基础上，重新定义以下方法，如适用，通过检查和/或修改使用所述同步状态getState() ， setState(int)和/或compareAndSetState(int, int) ：

    • tryAcquire(int)
    • tryRelease(int)
    • tryAcquireShared(int)
    • tryReleaseShared(int)
    • isHeldExclusively()
    这些方法中的每一个默认抛出UnsupportedOperationException 。 这些方法的实现必须是线程安全的，通常应该是短的而不是阻塞的。 定义这些方法是唯一支持使用此类的方法。 所有其他方法都被声明为final因为它们不能独立变化。

    您也可以从AbstractOwnableSynchronizer中找到继承的方法，用于跟踪拥有独占同步器的线程。 我们鼓励您使用它们 - 这样可以使监控和诊断工具帮助用户确定哪些线程持有锁定。

    即使这个类基于内部FIFO队列，它也不会自动执行FIFO采集策略。 排他同步的核心形式如下：

      Acquire:
     while (!tryAcquire(arg)) {
        enqueue thread if it is not already queued;
        possibly block current thread;
     }

 Release:
     if (tryRelease(arg))
        unblock the first queued thread;
    （共享模式类似，但可能包含级联信号。）

    因为在采集检查入队之前调用，所以新获取的线程可能闯入其他被阻塞和排队的。 但是，如果需要，您可以定义tryAcquire和/或tryAcquireShared以通过内部调用一个或多个检查方法来禁用驳船，从而提供公平的 FIFO采购订单。 特别地，最公平同步器可以定义tryAcquire返回false如果hasQueuedPredecessors() （具体地设计成由公平同步器中使用的方法）返回true 。 其他变化是可能的。

    吞吐量和可扩展性通常对于默认的驳船（也称为贪心 ， 放弃和车队避免 ）战略来说是最高的。 虽然这不能保证是公平的或无饥饿的，但较早排队的线程在稍后排队的线程之前被允许重新侦听，并且每次重新注入都有不偏不倚的机会成功接收线程。 而且，在通常的意义上，获取不要“旋转”，它们可以在阻塞之前执行tryAcquire多次调用，并tryAcquire其他计算。 当独占同步只是简单地持有时，这样可以提供旋转的大部分好处，而没有大部分负债。 如果需要，您可以通过以前通过“快速路径”检查获取方法的调用进行扩充，可能预先检查hasContended()和/或hasQueuedThreads()，以便只有在同步器可能不被竞争的情况下才能进行。

    该类为同步提供了一个高效和可扩展的基础，部分原因是可以依赖于int状态，获取和释放参数以及内部FIFO等待队列的同步器的使用范围。 当这不足够时，您可以使用atomic类，自己的自定义Queue类和LockSupport类来构建较低级别的同步器。

    用法示例

    这是一个不可重入互斥锁类，它使用零值来表示解锁状态，一个表示锁定状态。 虽然不可重入锁不严格要求记录当前的所有者线程，但是这样做无论如何使得使用更容易监视。 它还支持条件并公开其中一种仪器方法：

       class Mutex implements Lock, java.io.Serializable { // Our internal helper class private static class Sync extends AbstractQueuedSynchronizer { // Reports whether in locked state protected boolean isHeldExclusively() { return getState() == 1; } // Acquires the lock if state is zero public boolean tryAcquire(int acquires) { assert acquires == 1; // Otherwise unused if (compareAndSetState(0, 1)) { setExclusiveOwnerThread(Thread.currentThread()); return true; } return false; } // Releases the lock by setting state to zero protected boolean tryRelease(int releases) { assert releases == 1; // Otherwise unused if (getState() == 0) throw new IllegalMonitorStateException(); setExclusiveOwnerThread(null); setState(0); return true; } // Provides a Condition Condition newCondition() { return new ConditionObject(); } // Deserializes properly private void readObject(ObjectInputStream s) throws IOException, ClassNotFoundException { s.defaultReadObject(); setState(0); // reset to unlocked state } } // The sync object does all the hard work. We just forward to it. private final Sync sync = new Sync(); public void lock() { sync.acquire(1); } public boolean tryLock() { return sync.tryAcquire(1); } public void unlock() { sync.release(1); } public Condition newCondition() { return sync.newCondition(); } public boolean isLocked() { return sync.isHeldExclusively(); } public boolean hasQueuedThreads() { return sync.hasQueuedThreads(); } public void lockInterruptibly() throws InterruptedException { sync.acquireInterruptibly(1); } public boolean tryLock(long timeout, TimeUnit unit) throws InterruptedException { return sync.tryAcquireNanos(1, unit.toNanos(timeout)); } }

    这是一个闩锁类，就像一个CountDownLatch，除了它只需要一个signal发射。 因为锁存器是非排他的，所以它使用shared获取和释放方法。

       class BooleanLatch { private static class Sync extends AbstractQueuedSynchronizer { boolean isSignalled() { return getState() != 0; } protected int tryAcquireShared(int ignore) { return isSignalled() ? 1 : -1; } protected boolean tryReleaseShared(int ignore) { setState(1); return true; } } private final Sync sync = new Sync(); public boolean isSignalled() { return sync.isSignalled(); } public void signal() { sync.releaseShared(1); } public void await() throws InterruptedException { sync.acquireSharedInterruptibly(1); } }
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      class  AbstractQueuedSynchronizer.ConditionObject
      条件实施AbstractQueuedSynchronizer作为Lock实施的基础。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractQueuedSynchronizer​()
      创建一个初始同步状态为零的新的 AbstractQueuedSynchronizer实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void acquire​(int arg)
      以独占模式获取，忽略中断。
      void acquireInterruptibly​(int arg)
      以独占方式获得，如果中断，中止。
      void acquireShared​(int arg)
      以共享模式获取，忽略中断。
      void acquireSharedInterruptibly​(int arg)
      以共享方式获取，如果中断，中止。
      protected boolean compareAndSetState​(int expect, int update)
      如果当前状态值等于期望值，则将同步状态原子设置为给定的更新值。
      Collection<Thread> getExclusiveQueuedThreads​()
      返回一个包含可能正在等待以独占模式获取的线程的集合。
      Thread getFirstQueuedThread​()
      返回队列中的第一个（最长等待）线程，如果没有线程当前排队，则 null 。
      Collection<Thread> getQueuedThreads​()
      返回一个包含可能正在等待获取的线程的集合。
      int getQueueLength​()
      返回等待获取的线程数的估计。
      Collection<Thread> getSharedQueuedThreads​()
      返回包含可能正在等待在共享模式下获取的线程的集合。
      protected int getState​()
      返回同步状态的当前值。
      Collection<Thread> getWaitingThreads​(AbstractQueuedSynchronizer.ConditionObject condition)
      返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。
      int getWaitQueueLength​(AbstractQueuedSynchronizer.ConditionObject condition)
      返回等待与此同步器相关联的给定条件的线程数量的估计。
      boolean hasContended​()
      查询任何线程是否有争取获取此同步器; 也就是说，如果获取方法被阻止。
      boolean hasQueuedPredecessors​()
      查询任何线程是否等待获取比当前线程更长的时间。
      boolean hasQueuedThreads​()
      查询任何线程是否等待获取。
      boolean hasWaiters​(AbstractQueuedSynchronizer.ConditionObject condition)
      查询任何线程是否等待与此同步器相关联的给定条件。
      protected boolean isHeldExclusively​()
      返回 true如果同步仅针对当前（调用）线程进行。
      boolean isQueued​(Thread thread)
      如果给定的线程当前排队，则返回true。
      boolean owns​(AbstractQueuedSynchronizer.ConditionObject condition)
      查询给定的ConditionObject是否将此同步器用作其锁。
      boolean release​(int arg)
      以专属模式发布。
      boolean releaseShared​(int arg)
      以共享模式发布。
      protected void setState​(int newState)
      设置同步状态的值。
      String toString​()
      返回一个标识此同步器的字符串及其状态。
      protected boolean tryAcquire​(int arg)
      尝试以独占模式获取。
      boolean tryAcquireNanos​(int arg, long nanosTimeout)
      尝试以独占模式获取，如果中断则中止，如果给定的超时时间失败。
      protected int tryAcquireShared​(int arg)
      尝试以共享模式获取。
      boolean tryAcquireSharedNanos​(int arg, long nanosTimeout)
      尝试以共享模式获取，如果中断则中止，如果给定的时间超过，则失败。
      protected boolean tryRelease​(int arg)
      尝试设置状态以独占模式反映释放。
      protected boolean tryReleaseShared​(int arg)
      尝试将状态设置为以共享模式反映发布。

      • Methods inherited from class java.util.concurrent.locks.AbstractOwnableSynchronizer

        getExclusiveOwnerThread, setExclusiveOwnerThread

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractQueuedSynchronizer

        protected AbstractQueuedSynchronizer​()
        创建一个新的 AbstractQueuedSynchronizer初始同步状态为零的实例。

    • 方法详细信息

      • getState

        protected final int getState​()
        返回同步状态的当前值。 这个操作有volatile读取的内存语义。
        结果
        当前状态值

      • setState

        protected final void setState​(int newState)
        设置同步状态的值。 此操作具有volatile写入的内存语义。
        参数
        newState - 新的状态值

      • compareAndSetState

        protected final boolean compareAndSetState​(int expect,
                                           int update)
        如果当前状态值等于期望值，则将同步状态原子设置为给定的更新值。 此操作具有volatile读写的内存语义。
        参数
        expect - 期望值
        update - 新值
        结果
        true如果成功。 False return表示实际值不等于预期值。

      • tryAcquire

        protected boolean tryAcquire​(int arg)
        尝试以独占模式获取。 该方法应该查询对象的状态是否允许以独占模式获取，如果是，则获取它。

        该方法总是由执行获取的线程调用。 如果此方法报告失败，则获取方法可能将线程排队（如果尚未排队），直到被其他线程释放为止。 这可以用于实现方法Lock.tryLock() 。

        默认实现抛出UnsupportedOperationException 。

        参数
        arg - 获取的论据。 该值始终是传递给获取方法的值，也可以是进入条件等待时保存的值。 该值否则无法解释，可以代表您喜欢的任何内容。
        结果
        true如果成功。 一旦成功，这个对象就被收购了。
        异常
        IllegalMonitorStateException - 如果获取将使该同步器处于非法状态。 必须以一致的方式抛出此异常，以使同步正常工作。
        UnsupportedOperationException - 如果不支持独占模式

      • tryRelease

        protected boolean tryRelease​(int arg)
        尝试设置状态以独占模式反映释放。

        该方法总是由执行释放的线程调用。

        默认实现会抛出UnsupportedOperationException 。

        参数
        arg - 释放参数。 该值始终是传递给release方法的值，或者进入条件等待时的当前状态值。 该值否则无法解释，可以代表您喜欢的任何内容。
        结果
        true如果此对象现在处于完全释放状态，以便任何等待线程可能尝试获取; 而另外false 。
        异常
        IllegalMonitorStateException - 如果释放将使该同步器处于非法状态。 必须以一致的方式抛出此异常，以使同步正常工作。
        UnsupportedOperationException - 如果不支持独占模式

      • tryAcquireShared

        protected int tryAcquireShared​(int arg)
        尝试以共享模式获取。 该方法应该查询对象的状态是否允许在共享模式下获取该对象，如果是这样，就可以获取它。

        该方法总是由执行获取的线程调用。 如果此方法报告失败，则获取方法可能将线程排队（如果尚未排队），直到被其他线程释放为止。

        默认实现抛出UnsupportedOperationException 。

        参数
        arg - 获取的论据。 该值始终是传递给获取方法的值，也可以是进入条件等待时保存的值。 该值否则无法解释，可以代表您喜欢的任何内容。
        结果
        失败的负值 如果在共享模式下获取成功但没有后续共享模式获取可以成功，则为零; 并且如果在共享模式下的获取成功并且随后的共享模式获取可能成功，则为正值，在这种情况下，后续等待线程必须检查可用性。 （支持三种不同的返回值使得这种方法可以在仅获取有时只能完全执行的上下文中使用。）成功后，该对象已被获取。
        异常
        IllegalMonitorStateException - 如果获取将使该同步器处于非法状态。 必须以一致的方式抛出此异常，以使同步正常工作。
        UnsupportedOperationException - 如果不支持共享模式

      • tryReleaseShared

        protected boolean tryReleaseShared​(int arg)
        尝试将状态设置为以共享模式反映发布。

        该方法总是由执行释放的线程调用。

        默认实现抛出UnsupportedOperationException 。

        参数
        arg - 释放参数。 该值始终是传递给release方法的值，或者进入条件等待时的当前状态值。 该值否则无法解释，可以代表您喜欢的任何内容。
        结果
        true如果这种共享模式的释放可能允许等待获取（共享或排他）成功; 而另外false
        异常
        IllegalMonitorStateException - 如果释放将使该同步器处于非法状态。 必须以一致的方式抛出此异常，以使同步正常工作。
        UnsupportedOperationException - 如果不支持共享模式

      • isHeldExclusively

        protected boolean isHeldExclusively​()
        返回true如果同步仅针对当前（调用）线程进行保存。 每次调用不等待的方法都调用此方法AbstractQueuedSynchronizer.ConditionObject方法。 （等待方法调用release(int)。 ）

        默认实现抛出UnsupportedOperationException 。 此方法仅在AbstractQueuedSynchronizer.ConditionObject方法内部调用，因此如果不使用条件，则不需要定义该方法。

        结果
        true如果同步是唯一的; 否则为false
        异常
        UnsupportedOperationException - 如果不支持条件

      • acquire

        public final void acquire​(int arg)
        以独占模式获取，忽略中断。 通过调用至少一次执行tryAcquire(int) ，成功返回。 否则线程排队，可能会重复阻塞和解除阻塞，调用tryAcquire(int)直到成功。 该方法可用于实现方法Lock.lock() 。
        参数
        arg - 获取的论据。 该值传达给tryAcquire(int) ，否则无法解释，可以代表您喜欢的任何内容。

      • acquireInterruptibly

        public final void acquireInterruptibly​(int arg)
                                throws InterruptedException
        以独占方式获得，如果中断，中止。 通过首先检查中断状态，然后调用至少一次tryAcquire(int) ，成功返回。 否则线程排队，可能会重复阻塞和解除阻塞，调用tryAcquire(int)直到成功或线程中断。 该方法可以用于实现方法Lock.lockInterruptibly() 。
        参数
        arg - 获取的论据。 该值传达到tryAcquire(int) ，否则无法解释，可以代表您喜欢的任何内容。
        异常
        InterruptedException - 当前线程是否中断

      • tryAcquireNanos

        public final boolean tryAcquireNanos​(int arg,
                                     long nanosTimeout)
                              throws InterruptedException
        尝试以独占模式获取，如果中断则中止，如果给定的超时时间失败。 通过首先检查中断状态，然后调用至少一次tryAcquire(int) ，成功返回。 否则，线程排队，可能会重复阻塞和解除阻塞，调用tryAcquire(int)直到成功或线程中断或超时。 该方法可用于实现方法Lock.tryLock(long, TimeUnit) 。
        参数
        arg - 获取的论据。 该值传送到tryAcquire(int) ，否则将被解释，并可以代表您喜欢的任何内容。
        nanosTimeout - 要等待的最大纳秒数
        结果
        true如果获得; false如果超时
        异常
        InterruptedException - 当前线程是否中断

      • release

        public final boolean release​(int arg)
        以专属模式发布。 如果tryRelease(int)返回true，则通过解除阻塞一个或多个线程来实现。 该方法可以用于实现方法Lock.unlock() 。
        参数
        arg - 释放参数。 该值传达给tryRelease(int) ，否则将被解释，并可以代表您喜欢的任何内容。
        结果
        该值从 tryRelease(int)返回

      • acquireShared

        public final void acquireShared​(int arg)
        以共享模式获取，忽略中断。 通过首次调用至少一次执行tryAcquireShared(int) ，成功返回。 否则线程排队，可能会重复阻塞和解除阻塞，直到成功才调用tryAcquireShared(int) 。
        参数
        arg - 获取的论据。 该值传达到tryAcquireShared(int) ，否则将被解释，并可以表示任何您喜欢的。

      • acquireSharedInterruptibly

        public final void acquireSharedInterruptibly​(int arg)
                                      throws InterruptedException
        以共享方式获取，如果中断，中止。 通过首先检查中断状态，然后至少调用一次tryAcquireShared(int) ，成功返回。 否则线程排队，可能会重复阻塞和解除阻塞，调用tryAcquireShared(int)直到成功或线程中断。
        参数
        arg - 获取的论据。 该值传达给tryAcquireShared(int) ，否则将被解释，可以代表您喜欢的任何内容。
        异常
        InterruptedException - 当前线程是否中断

      • tryAcquireSharedNanos

        public final boolean tryAcquireSharedNanos​(int arg,
                                           long nanosTimeout)
                                    throws InterruptedException
        尝试以共享模式获取，如果中断则中止，如果给定的时间超过，则失败。 通过首先检查中断状态，然后至少调用一次tryAcquireShared(int) ，成功返回。 否则，线程排队，可能会重复阻塞和解除阻塞，调用tryAcquireShared(int)直到成功或线程中断或超时。
        参数
        arg - 获取的论据。 该值被传送到tryAcquireShared(int) ，否则将被解释并且可以表示任何你喜欢的。
        nanosTimeout - 要等待的最大纳秒数
        结果
        true如果获得; false如果超时
        异常
        InterruptedException - 当前线程是否中断

      • releaseShared

        public final boolean releaseShared​(int arg)
        以共享模式发布。 如果tryReleaseShared(int)返回true，则通过解除阻塞一个或多个线程来实现。
        参数
        arg - 释放参数。 该值传达到tryReleaseShared(int) ，否则将被无法解释，可以代表您喜欢的任何内容。
        结果
        该值从 tryReleaseShared(int)返回

      • hasQueuedThreads

        public final boolean hasQueuedThreads​()
        查询任何线程是否等待获取。 请注意，由于中断和超时可能会随时发生取消，因此true返回不能保证任何其他线程将获得。

        在这个实现中，这个操作返回恒定的时间。

        结果
        true如果可能有其他线程等待获取

      • hasContended

        public final boolean hasContended​()
        查询任何线程是否有争取获取此同步器; 也就是说，如果获取方法被阻止。

        在这个实现中，这个操作返回恒定的时间。

        结果
        true如果有过争论

      • getFirstQueuedThread

        public final Thread getFirstQueuedThread​()
        返回队列中的第一个（最长等待）线程，如果没有线程当前排队，则null 。

        在这个实现中，这个操作通常在常量时间内返回，但如果其他线程同时修改队列，则可以在争用时迭代。

        结果
        队列中的第一（最长等待）线程，如果没有线程当前排队， null

      • isQueued

        public final boolean isQueued​(Thread thread)
        如果给定的线程当前排队，则返回true。

        该实现遍历队列以确定给定线程的存在。

        参数
        thread - 线程
        结果
        true如果给定的线程在队列上
        异常
        NullPointerException - 如果线程为空

      • hasQueuedPredecessors

        public final boolean hasQueuedPredecessors​()
        查询任何线程是否等待获取比当前线程更长的时间。

        调用此方法等同于（但可能更有效）：

           getFirstQueuedThread() != Thread.currentThread() && hasQueuedThreads()

        请注意，由于中断和超时可能会随时发生取消，因此true返回不能保证其他一些线程将在当前线程之前获取。 同样，由于队列为空，这个方法返回了false之后，另一个线程可能会赢得比赛进入排队。

        该方法设计为由公平同步器使用，以避免barging 。 这样的同步器的tryAcquire(int)方法应该返回false ，其tryAcquireShared(int)方法应该返回一个负值，如果这个方法返回true （除非这是一个可重入的获取）。 例如，公平，可重入，独占模式同步器的tryAcquire方法可能如下所示：

           protected boolean tryAcquire(int arg) { if (isHeldExclusively()) { // A reentrant acquire; increment hold count return true; } else if (hasQueuedPredecessors()) { return false; } else { // try to acquire normally } }
        结果
        true如果当前线程前面有一个排队的线程，而 false如果当前线程在队列的头部或队列是空的
        从以下版本开始：
        1.7

      • getQueueLength

        public final int getQueueLength​()
        返回等待获取的线程数的估计。 该值只是一个估计，因为线程数可能会在此方法遍历内部数据结构时动态更改。 该方法设计用于监控系统状态，不用于同步控制。
        结果
        估计等待获取的线程数

      • getQueuedThreads

        public final Collection<Thread> getQueuedThreads​()
        返回一个包含可能正在等待获取的线程的集合。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。 该方法旨在便于构建提供更广泛监控设施的子类。
        结果
        线程的收集

      • getExclusiveQueuedThreads

        public final Collection<Thread> getExclusiveQueuedThreads​()
        返回一个包含可能正在等待以独占模式获取的线程的集合。 这与getQueuedThreads()具有相同的属性，除了它只返回那些由于排他获取等待的线程。
        结果
        线程的收集

      • getSharedQueuedThreads

        public final Collection<Thread> getSharedQueuedThreads​()
        返回包含可能正在等待在共享模式下获取的线程的集合。 这与getQueuedThreads()具有相同的属性，除了它只返回由于共享获取而等待的那些线程。
        结果
        线程的收集

      • toString

        public String toString​()
        返回一个标识此同步器的字符串及其状态。 括号中的状态包括字符串"State ="后跟当前值getState() ，而"nonempty"或"empty"取决于队列是否为空。
        重写：
        toString在 Object
        结果
        识别此同步器的字符串以及其状态

      • owns

        public final boolean owns​(AbstractQueuedSynchronizer.ConditionObject condition)
        查询给定的ConditionObject是否将此同步器用作其锁。
        参数
        condition - 条件
        结果
        true如果拥有
        异常
        NullPointerException - 如果条件为空

      • hasWaiters

        public final boolean hasWaiters​(AbstractQueuedSynchronizer.ConditionObject condition)
        查询任何线程是否等待与此同步器相关联的给定条件。 请注意，由于超时和中断可能随时发生，因此true返回不能保证未来的signal将唤醒任何线程。 该方法主要用于监视系统状态。
        参数
        condition - 条件
        结果
        true如果有任何等待线程
        异常
        IllegalMonitorStateException - 如果不保留独占同步
        IllegalArgumentException - 如果给定的条件与该同步器没有关联
        NullPointerException - 条件为空

      • getWaitQueueLength

        public final int getWaitQueueLength​(AbstractQueuedSynchronizer.ConditionObject condition)
        返回等待与此同步器相关联的给定条件的线程数量的估计。 请注意，由于超时和中断可能在任何时间发生，估计仅作为实际服务员人数的上限。 该方法设计用于监控系统状态，不用于同步控制。
        参数
        condition - 条件
        结果
        估计等待线程数
        异常
        IllegalMonitorStateException - 如果不保留独占同步
        IllegalArgumentException - 如果给定的条件与该同步器没有关联
        NullPointerException - 如果条件为空

      • getWaitingThreads

        public final Collection<Thread> getWaitingThreads​(AbstractQueuedSynchronizer.ConditionObject condition)
        返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。
        参数
        condition - 条件
        结果
        线程的收集
        异常
        IllegalMonitorStateException - 如果不保留独占同步
        IllegalArgumentException - 如果给定的条件与此同步器没有关联
        NullPointerException - 如果条件为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractQueuedSynchronizer.ConditionObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class AbstractQueuedSynchronizer.ConditionObject

  • java.lang.Object
    • java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
  • All Implemented Interfaces:
    Serializable ， Condition
    Enclosing class:
    AbstractQueuedSynchronizer

    public class AbstractQueuedSynchronizer.ConditionObject
extends Object
implements Condition, Serializable
    AbstractQueuedSynchronizer作为Lock实施基础的条件实施。

    该类的方法文档描述了从锁定和条件用户角度看的机制，而不是行为规范。 该类的导出版本通常需要附有说明依赖于相关联的AbstractQueuedSynchronizer条件语义的文档。

    这个类是Serializable，但是所有字段都是暂时的，所以反序列化的条件没有服务器。

    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConditionObject​()
      创建一个新的 ConditionObject实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void await​()
      实现可中断条件等待。
      boolean await​(long time, TimeUnit unit)
      实现定时状态等待。
      long awaitNanos​(long nanosTimeout)
      实现定时状态等待。
      void awaitUninterruptibly​()
      实现不间断状态等待。
      boolean awaitUntil​(Date deadline)
      实现绝对定时条件等待。
      protected Collection<Thread> getWaitingThreads​()
      返回一个包含可能在此条件下等待的线程的集合。
      protected int getWaitQueueLength​()
      返回等待此条件的线程数的估计。
      protected boolean hasWaiters​()
      查询是否有线程正在等待这种情况。
      void signal​()
      将最长等待的线程（如果存在）从等待队列移动到拥有锁的等待队列。
      void signalAll​()
      将所有线程从这个条件的等待队列移动到拥有锁的等待队列。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ConditionObject

        public ConditionObject​()
        创建一个新的 ConditionObject实例。

    • 方法详细信息

      • signal

        public final void signal​()
        将最长等待的线程（如果存在）从等待队列移动到拥有锁的等待队列。
        Specified by:
        signal在接口 Condition
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively()返回 false

      • signalAll

        public final void signalAll​()
        将所有线程从这个条件的等待队列移动到拥有锁的等待队列。
        Specified by:
        signalAll在接口 Condition
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively()返回 false

      • awaitUninterruptibly

        public final void awaitUninterruptibly​()
        实现不间断状态等待。
        1. 保存锁定状态返回AbstractQueuedSynchronizer.getState() 。
        2. 以保存状态为参数调用AbstractQueuedSynchronizer.release(int) ，如果失败，则抛出IllegalMonitorStateException。
        3. 阻止直到发信号。
        4. 通过调用专用版本的AbstractQueuedSynchronizer.acquire(int) ，保存状态作为参数。
        Specified by:
        awaitUninterruptibly在接口 Condition

      • await

        public final void await​()
                 throws InterruptedException
        实现可中断条件等待。
        1. 如果当前线程中断，则抛出InterruptedException。
        2. 保存锁定状态返回AbstractQueuedSynchronizer.getState() 。
        3. 以保存状态为参数调用AbstractQueuedSynchronizer.release(int) ，如果失败，则抛出IllegalMonitorStateException。
        4. 阻塞直到发信号或中断。
        5. 通过调用具有保存状态的特定版本的AbstractQueuedSynchronizer.acquire(int)作为参数来重新获取。
        6. 如果在步骤4中被阻塞时中断，则抛出InterruptedException。
        Specified by:
        await在接口 Condition
        异常
        InterruptedException - 如果当前线程中断（支持线程中断）

      • awaitNanos

        public final long awaitNanos​(long nanosTimeout)
                      throws InterruptedException
        实现定时状态等待。
        1. 如果当前线程中断，则抛出InterruptedException。
        2. 保存锁定状态返回AbstractQueuedSynchronizer.getState() 。
        3. 以保存状态为参数调用AbstractQueuedSynchronizer.release(int) ，如果失败，则抛出IllegalMonitorStateException。
        4. 阻塞直到发信号，中断或超时。
        5. 通过调用具有保存状态的特定版本的AbstractQueuedSynchronizer.acquire(int)作为参数来重新获取。
        6. 如果在步骤4中被阻塞时中断，则抛出InterruptedException。
        Specified by:
        awaitNanos在接口 Condition
        参数
        nanosTimeout - 等待的最长时间，以纳秒为单位
        结果
        估计nanosTimeout值减去等待从此方法返回的时间。 可以使用正值作为随后调用此方法的参数，以完成等待所需时间。 小于或等于零的值表示没有时间。
        异常
        InterruptedException - 如果当前线程中断（支持线程中断）

      • awaitUntil

        public final boolean awaitUntil​(Date deadline)
                         throws InterruptedException
        实现绝对定时条件等待。
        1. 如果当前线程中断，则抛出InterruptedException。
        2. 保存锁定状态返回AbstractQueuedSynchronizer.getState() 。
        3. 调用AbstractQueuedSynchronizer.release(int)保存状态作为参数，如果失败，则抛出IllegalMonitorStateException。
        4. 阻塞直到发信号，中断或超时。
        5. 通过调用具有保存状态的特定版本的AbstractQueuedSynchronizer.acquire(int)作为参数来重新获取。
        6. 如果在步骤4中被阻塞时中断，则抛出InterruptedException。
        7. 如果在步骤4中被阻止时超时，返回false，否则返回true。
        Specified by:
        awaitUntil在接口 Condition
        参数
        deadline - 绝对等待的时间
        结果
        false如果最后期限已经过了，还有 true
        异常
        InterruptedException - 如果当前线程中断（并且支持线程中断的中断）

      • await

        public final boolean await​(long time,
                           TimeUnit unit)
                    throws InterruptedException
        实现定时状态等待。
        1. 如果当前线程中断，则抛出InterruptedException。
        2. 保存锁定状态返回AbstractQueuedSynchronizer.getState() 。
        3. 以保存状态为参数调用AbstractQueuedSynchronizer.release(int) ，如果失败，则抛出IllegalMonitorStateException。
        4. 阻塞直到发信号，中断或超时。
        5. 通过调用专用版本的AbstractQueuedSynchronizer.acquire(int)重新获取 ，保存状态为参数。
        6. 如果在步骤4中被阻塞时中断，则抛出InterruptedException。
        7. 如果在步骤4中被阻止时超时，返回false，否则返回true。
        Specified by:
        await在接口 Condition
        参数
        time - 等待的最长时间
        unit - time参数的时间单位
        结果
        false如果等待时间可以从方法返回之前经过，否则 true
        异常
        InterruptedException - 如果当前线程中断（支持线程中断）

      • hasWaiters

        protected final boolean hasWaiters​()
        查询是否有线程正在等待这种情况。 实现AbstractQueuedSynchronizer.hasWaiters(ConditionObject) 。
        结果
        true如果有任何等待线程
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively()返回 false

      • getWaitQueueLength

        protected final int getWaitQueueLength​()
        返回等待此条件的线程数的估计。 实现AbstractQueuedSynchronizer.getWaitQueueLength(ConditionObject) 。
        结果
        估计等待线程数
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively()返回 false

      • getWaitingThreads

        protected final Collection<Thread> getWaitingThreads​()
        返回一个包含可能在此条件下等待的线程的集合。 实现AbstractQueuedSynchronizer.getWaitingThreads(ConditionObject) 。
        结果
        线程的收集
        异常
        IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively()返回 false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Condition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Interface Condition

  • 所有已知实现类：
    AbstractQueuedLongSynchronizer.ConditionObject ， AbstractQueuedSynchronizer.ConditionObject

    public interface Condition
    Condition因素出Object监视器方法（ wait ， notify和notifyAll ）成不同的对象，以得到具有多个等待集的每个对象，通过将它们与使用任意的组合的效果Lock个实现。 Lock替代synchronized方法和语句的使用， Condition替代了使用对象监视器方法。

    条件（也称为条件队列或条件变量 ）为一个线程暂停执行（“等待”）提供了一种方法，直到另一个线程通知某些状态现在可能为真。 因为访问此共享状态信息发生在不同的线程中，所以它必须被保护，因此某种形式的锁与该条件相关联。 等待条件的关键属性是它会原子释放相关的锁并挂起当前线程，就像Object.wait一样。

    一个Condition实例本质上绑定到一个锁。 要为特定的Lock实例获取Condition实例，请使用其newCondition()方法。

    例如，假设我们有一个有限的缓冲区，支持put和take方法。 如果在空的缓冲区上尝试了一个take ，则线程将阻塞，直到一个项目可用; 如果在完整缓冲区上尝试了一个put ，则线程将阻塞，直到空间可用。 我们希望在单独的等待集中等待put线程和take线程，以便我们可以在缓冲区中的项目或空间可用时才可以使用仅通知单个线程的优化。 这可以使用两个Condition实例来实现。

      class BoundedBuffer {
   final Lock lock = new ReentrantLock();
   final Condition notFull  = lock.newCondition();
   final Condition notEmpty = lock.newCondition();

   final Object[] items = new Object[100];
   int putptr, takeptr, count;

   public void put(Object x) throws InterruptedException {
     lock.lock(); try {
       while (count == items.length)
         notFull.await();
       items[putptr] = x;
       if (++putptr == items.length) putptr = 0;
       ++count;
       notEmpty.signal();
     } finally { lock.unlock(); }
   }

   public Object take() throws InterruptedException {
     lock.lock(); try {
       while (count == 0)
         notEmpty.await();
       Object x = items[takeptr];
       if (++takeptr == items.length) takeptr = 0;
       --count;
       notFull.signal();
       return x;
     } finally { lock.unlock(); }
   }
 }
    （ ArrayBlockingQueue类提供此功能，因此没有理由实现此示例使用类。）

    Condition实现可以提供与Object监视器方法不同的行为和语义，例如保证通知的顺序，或者在执行通知时不需要锁定。 如果一个实现提供了这样的专门的语义，那么实现必须记录这些语义。

    请注意， Condition实例只是普通对象，它们本身可以用作synchronized语句中的目标，并且可以调用自己的监视器wait和notify方法。 获取Condition实例的监视锁或使用其监视方法与获取与该Lock相关联的Condition或使用其waiting和signalling方法没有具体关系。 建议为避免混淆，您永远不会以这种方式使用Condition实例，除了可能在自己的实现之内。

    除非另有说明，传递任何参数的null值将导致抛出NullPointerException 。

    实施注意事项

    当等待Condition ，允许发生“ 虚假唤醒 ”，一般来说，作为底层平台语义的让步。 这对大多数应用程序几乎没有实际的影响，因为Condition应该始终在循环中等待，测试正在等待的状态谓词。 一个实现可以免除虚假唤醒的可能性，但建议应用程序员总是假定它们可以发生，因此始终等待循环。

    条件等待（可中断，不可中断和定时）的三种形式在一些平台上的易用性和性能特征可能不同。 特别地，可能难以提供这些特征并保持特定的语义，例如排序保证。 此外，中断线程实际挂起的能力可能并不总是在所有平台上实现。

    因此，不需要一个实现来为所有三种形式的等待定义完全相同的保证或语义，也不需要支持中断线程的实际暂停。

    需要一个实现来清楚地记录每个等待方法提供的语义和保证，并且当一个实现确实支持线程挂起的中断时，它必须遵守该接口中定义的中断语义。

    由于中断通常意味着取消，并且检查中断通常是不频繁的，所以实现可以有利于通过正常方法返回来响应中断。 即使可以显示中断发生在另一个可能解除阻塞线程的动作之后，这一点也是如此。 一个实现应该记录这个行为。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void await​()
      导致当前线程等到发信号或 interrupted 。
      boolean await​(long time, TimeUnit unit)
      使当前线程等待直到发出信号或中断，或指定的等待时间过去。
      long awaitNanos​(long nanosTimeout)
      使当前线程等待直到发出信号或中断，或指定的等待时间过去。
      void awaitUninterruptibly​()
      使当前线程等待直到发出信号。
      boolean awaitUntil​(Date deadline)
      使当前线程等待直到发出信号或中断，或者指定的最后期限过去。
      void signal​()
      唤醒一个等待线程。
      void signalAll​()
      唤醒所有等待线程。

    • 方法详细信息

      • await

        void await​()
    throws InterruptedException
        导致当前线程等到发信号或interrupted 。

        与此相关的锁Condition以原子方式释放，并且当前线程用于线程调度目的，禁用并一直处于休眠状态的四两件事发生对象 ：

        • 一些其他线程调用signal()的方法，这个Condition和当前线程恰好被选为被唤醒的线程; 要么
        • 一些其他线程调用signalAll()方法为这个Condition ; 要么
        • 一些其他线程当前线程为interrupts ，并支持线程中断中断; 要么
        • 发生“ 虚假唤醒 ”。

        在所有情况下，在此方法返回之前，当前线程必须重新获取与此条件相关的锁。 当线程返回时，它保证保持此锁。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted等待和中断螺纹悬挂支持，
        那么抛出InterruptedException并清除当前线程的中断状态。 在第一种情况下，没有规定在释放锁之前是否发生中断测试。

        实施注意事项

        当调用此方法时，假定当前线程保持与此Condition相关联的锁。 由执行决定是否是这种情况，如果没有，应如何回应。 通常，将抛出异常（例如IllegalMonitorStateException ），并且实现必须记录该事实。

        响应于信号，实现可以有利于响应正常方法返回的中断。 在这种情况下，实现必须确保信号被重定向到另一个等待的线程（如果有的话）。

        异常
        InterruptedException - 如果当前线程中断（并且支持线程中断的中断）

      • awaitUninterruptibly

        void awaitUninterruptibly​()
        使当前线程等待直到发出信号。

        与此条件相关的锁以原子方式释放，并且当前线程的线程调度目的就退出，一直处于休眠状态的三种情况之一发生：

        • 一些其它线程调用signal()方法本Condition和当前线程碰巧被选择作为被唤醒线程; 要么
        • 一些其他线程调用signalAll()方法为这个Condition ; 要么
        • 发生“ 虚假唤醒 ”。

        在所有情况下，在此方法返回之前，当前线程必须重新获取与此条件相关的锁。 当线程返回时，它保证保持此锁。

        如果当前线程的中断状态在进入此方法时设置，或者等待时为interrupted ，则会继续等待直到发信号。 当它最终从该方法返回时，它的中断状态将仍然被设置。

        实施注意事项

        当调用此方法时，假定当前线程保持与此Condition相关联的锁。 由执行决定是否是这种情况，如果没有，应如何回应。 通常，将抛出异常（如IllegalMonitorStateException ），实现必须记录该事实。

      • awaitNanos

        long awaitNanos​(long nanosTimeout)
         throws InterruptedException
        使当前线程等待直到发出信号或中断，或指定的等待时间过去。

        与此条件相关的锁以原子方式释放，并且当前线程的线程调度目的就退出，一直处于休眠状态的五件事情发生对象 ：

        • 一些其它线程调用signal()方法本Condition和当前线程碰巧被选择作为被唤醒线程; 要么
        • 一些其他线程调用signalAll()方法为这个Condition ; 要么
        • 一些其他线程当前线程为interrupts ，并支持线程中断中断; 要么
        • 指定的等待时间过去了; 要么
        • 发生“ 虚假唤醒 ”。

        在所有情况下，在此方法返回之前，当前线程必须重新获取与此条件相关的锁。 当线程返回时，它保证保持此锁。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted等待和中断螺纹悬挂支持，
        那么抛出InterruptedException并清除当前线程的中断状态。 在第一种情况下，没有规定在释放锁之前是否发生中断测试。

        该方法返回时给出所提供的nanosTimeout值时剩余的纳秒数的估计，或者如果超时，小于或等于零的值。 该值可用于确定等待返回但待机状态仍然不成立的情况下是否以及等待多长时间。 此方法的典型用途如下：

           boolean aMethod(long timeout, TimeUnit unit) { long nanos = unit.toNanos(timeout); lock.lock(); try { while (!conditionBeingWaitedFor()) { if (nanos <= 0L) return false; nanos = theCondition.awaitNanos(nanos); } // ... } finally { lock.unlock(); } }

        设计说明：此方法需要一个纳秒参数，以避免报告剩余时间中的截断错误。 这样的精度损失将使程序员难以确保在重新等待时总的等待时间不会比指定的时间短。

        实施注意事项

        当调用此方法时，假定当前线程保持与此Condition关联的锁。 由执行决定是否是这种情况，如果没有，应如何回应。 通常，将抛出异常（如IllegalMonitorStateException ），实现必须记录该事实。

        一个实现可以有助于响应于信号响应正常方法返回的中断，或者指示经过指定的等待时间。 在任一情况下，实现必须确保信号被重定向到另一个等待线程（如果有的话）。

        参数
        nanosTimeout - 等待的最长时间，以纳秒为单位
        结果
        估计nanosTimeout值减去等待从此方法返回的时间。 可以使用正值作为随后调用此方法的参数，以完成等待所需时间。 小于或等于零的值表示没有时间。
        异常
        InterruptedException - 如果当前线程被中断（并且支持线程中断的中断）

      • await

        boolean await​(long time,
              TimeUnit unit)
       throws InterruptedException
        使当前线程等待直到发出信号或中断，或指定的等待时间过去。 这种方法在行为上等同于：
          awaitNanos(unit.toNanos(time)) > 0
        参数
        time - 等待的最长时间
        unit - time参数的时间单位
        结果
        false如果等待时间可以从方法返回之前经过，否则 true
        异常
        InterruptedException - 如果当前线程被中断（并且支持线程中断的中断）

      • awaitUntil

        boolean awaitUntil​(Date deadline)
            throws InterruptedException
        使当前线程等待直到发出信号或中断，或者指定的最后期限过去。

        与此条件相关的锁以原子方式释放，并且当前线程的线程调度目的就退出，一直处于休眠状态的五件事情发生对象 ：

        • 一些其它线程调用signal()方法本Condition和当前线程碰巧被选择作为被唤醒线程; 要么
        • 一些其他线程调用signalAll()方法为这个Condition ; 要么
        • 一些其他线程当前线程interrupts ，并支持线程中断中断; 要么
        • 规定的期限过去了; 要么
        • 发生“ 虚假唤醒 ”。

        在所有情况下，在此方法返回之前，当前线程必须重新获取与此条件相关的锁。 当线程返回时，它保证保持此锁。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted ，等待和中断螺纹悬挂支持，
        那么抛出InterruptedException并清除当前线程的中断状态。 在第一种情况下，没有规定在释放锁之前是否发生中断测试。

        返回值表示截止期限是否过去，可以如下使用：

           boolean aMethod(Date deadline) { boolean stillWaiting = true; lock.lock(); try { while (!conditionBeingWaitedFor()) { if (!stillWaiting) return false; stillWaiting = theCondition.awaitUntil(deadline); } // ... } finally { lock.unlock(); } }

        实施注意事项

        当调用此方法时，假定当前线程保持与此Condition关联的锁。 由执行决定是否是这种情况，如果没有，应如何回应。 通常，将抛出异常（如IllegalMonitorStateException ），实现必须记录该事实。

        一个实现可以有助于响应于信号响应正常方法返回的中断，或者指示通过指定的期限。 在任一情况下，实现必须确保信号被重定向到另一个等待线程（如果有的话）。

        参数
        deadline - 绝对等待的时间
        结果
        false如果截止日期已过，返回时，其他 true
        异常
        InterruptedException - 如果当前线程中断（并且支持线程中断的中断）

      • signal

        void signal​()
        唤醒一个等待线程。

        如果任何线程正在等待此条件，则选择一个线程进行唤醒。 那么线程必须在从await返回之前重新获取锁。

        实施注意事项

        当调用此方法时，实现可能（通常是）要求当前线程保存与此Condition相关联的锁。 执行必须记录此前提条件，如果不保持锁定，则采取任何措施。 通常，会抛出异常，如IllegalMonitorStateException 。

      • signalAll

        void signalAll​()
        唤醒所有等待线程。

        如果任何线程正在等待这个条件，那么它们都被唤醒。 每个线程必须重新获取锁，才能从await返回。

        实施注意事项

        当调用此方法时，实现可能（通常是）要求当前线程保存与此Condition相关联的锁。 执行必须记录此前提条件，如果不保持锁定，则采取任何措施。 通常，将抛出例如IllegalMonitorStateException的异常。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.util.concurrent.locks (Java SE 9 & JDK 9 )

java.util.concurrent.locks

Interfaces

  • Condition
  • Lock
  • ReadWriteLock

Classes

  • AbstractOwnableSynchronizer
  • AbstractQueuedLongSynchronizer
  • AbstractQueuedSynchronizer
  • LockSupport
  • ReentrantLock
  • ReentrantReadWriteLock
  • ReentrantReadWriteLock.ReadLock
  • ReentrantReadWriteLock.WriteLock
  • StampedLock


java.util.concurrent.locks (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util.concurrent.locks

接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。 该框架在使用锁和条件方面允许更大的灵活性，而牺牲了更尴尬的语法。

Lock接口支持语义（可重入，公平等）不同的锁定规则，可用于非块结构上下文中，包括手持和锁重新排序算法。 主要实现为ReentrantLock 。

ReadWriteLock接口类似地定义了可能在读者之间共享的锁，但是作者是排他性的。 只提供一个单一的实现， ReentrantReadWriteLock ，因为它涵盖了大多数标准的使用上下文。 但程序员可能会创建自己的实现来覆盖非标准要求。

Condition接口描述可能与锁相关联的条件变量。 这些使用方式与使用Object.wait访问的隐式监视器Object.wait ，但提供扩展功能。 特别地，多个Condition对象可以与单个Lock相关联。 为避免兼容性问题， Condition方法的名称与相应的Object版本不同。

AbstractQueuedSynchronizer类用作定义锁和其他依赖排队阻塞线程的同步器的有用超类。 AbstractQueuedLongSynchronizer类提供相同的功能，但扩展了对64位同步状态的支持。 两者都扩展类AbstractOwnableSynchronizer ，一个简单的类，有助于记录当前持有排他同步的线程。 LockSupport类提供了较低级别的阻塞和解除阻止支持，对于那些开发自己的定制锁类的开发人员来说，这是非常有用的。

从以下版本开始：
1.5
  • 接口摘要
    接口 描述
    Condition
    Condition因素出Object监视器方法（ wait ， notify和notifyAll ）成不同的对象，以得到具有多个等待集的每个对象，通过将它们与使用任意的组合的效果Lock个实现。
    Lock
    Lock实现提供比使用 synchronized方法和语句可以获得的更广泛的锁定操作。
    ReadWriteLock
    A ReadWriteLock维护一对关联的locks ，一个用于只读操作，一个用于写入。
  • 类摘要
    Class 描述
    AbstractOwnableSynchronizer
    可以由线程专有的同步器。
    AbstractQueuedLongSynchronizer
    的一个版本AbstractQueuedSynchronizer ，其中同步状态保持为long 。
    AbstractQueuedSynchronizer
    提供一个框架，用于实现依赖先进先出（FIFO）等待队列的阻塞锁和相关同步器（信号量，事件等）。
    LockSupport
    用于创建锁和其他同步类的基本线程阻塞原语。
    ReentrantLock
    具有与使用synchronized方法和语句访问的隐式监视锁相同的基本行为和语义的可重入互斥Lock ，但具有扩展功能。
    ReentrantReadWriteLock
    一个ReadWriteLock的实现支持类似的语义到ReentrantLock 。
    ReentrantReadWriteLock.ReadLock
    该锁由方法 ReentrantReadWriteLock.readLock()返回。
    ReentrantReadWriteLock.WriteLock
    方法 ReentrantReadWriteLock.writeLock()返回的锁。
    StampedLock
    A capability-based lock with three modes for controlling read/write access.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.concurrent.locks Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.concurrent.locks

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.concurrent.locks.AbstractOwnableSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedLongSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedSynchronizer (implements java.io.Serializable)
    • java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • java.util.concurrent.locks.LockSupport
    • java.util.concurrent.locks.ReentrantLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock (implements java.util.concurrent.locks.ReadWriteLock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.StampedLock (implements java.io.Serializable)

Interface Hierarchy

  • java.util.concurrent.locks.Condition
  • java.util.concurrent.locks.Lock
  • java.util.concurrent.locks.ReadWriteLock
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Lock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Interface Lock

  • 所有已知实现类：
    ReentrantLock ， ReentrantReadWriteLock.ReadLock ， ReentrantReadWriteLock.WriteLock

    public interface Lock
    Lock实现提供比使用synchronized方法和语句可以获得的更广泛的锁定操作。 它们允许更灵活的结构化，可能具有完全不同的属性，并且可以支持多个关联的Condition对象。

    锁是用于通过多个线程控制对共享资源的访问的工具。 通常，锁提供对共享资源的独占访问：一次只能有一个线程可以获取锁，并且对共享资源的所有访问都要求首先获取锁。 但是，某些锁可能允许并发访问共享资源，例如ReadWriteLock的读取锁。

    使用synchronized方法或语句提供对与每个对象相关联的隐式监视锁的访问，但是强制所有锁获取和释放以块结构的方式发生：当获取多个锁时，它们必须以相反的顺序被释放，并且所有的锁都必须被释放在与它们相同的词汇范围内。

    虽然synchronized方法和语句的范围化机制使得使用监视器锁更容易编程，并且有助于避免涉及锁的许多常见编程错误，但有时您需要以更灵活的方式处理锁。 例如，用于遍历并发访问的数据结构的一些算法需要使用“手动”或“链锁定”：您获取节点A的锁定，然后获取节点B，然后释放A并获取C，然后释放B并获得D等。 Lock接口的实现使得能够通过允许在不同范围内获取和释放锁来实现这种技术，并允许以任何顺序获取和释放多个锁。

    随着这种增加的灵活性会增加责任。 不存在块结构锁定的去除锁的自动释放，与发生synchronized方法和语句。 在大多数情况下，应使用以下惯用语：

       Lock l = ...; l.lock(); try { // access the resource protected by this lock } finally { l.unlock(); }
    当在不同范围内发生锁定和解锁时，必须注意确保在锁定时执行的所有代码由try-finally或try-catch保护，以确保在必要时释放锁定。

    Lock实现提供了使用synchronized方法和语句的附加功能，通过提供非阻塞尝试来获取锁（ tryLock() ），尝试获取可被中断的锁（ lockInterruptibly()） ，以及尝试获取可以超时（ tryLock(long, TimeUnit) ）。

    一个Lock类还可以提供与隐式监视锁定的行为和语义完全不同的行为和语义，例如保证排序，非重入使用或死锁检测。 如果一个实现提供了这样的专门的语义，那么实现必须记录这些语义。

    请注意， Lock实例只是普通对象，它们本身可以用作synchronized语句中的目标。 获取Lock实例的监视器锁与调用该实例的任何lock()方法没有特定关系。 建议为避免混淆，您永远不会以这种方式使用Lock实例，除了在自己的实现中。

    除非另有说明，传递任何参数的null值将导致抛出NullPointerException 。

    内存同步

    所有Lock实现必须执行与内置监视器锁相同的内存同步语义，如Chapter 17 of The Java™ Language Specification所述 ：

    • 成功的lock操作具有与成功锁定动作相同的内存同步效果。
    • 成功的unlock操作具有与成功解锁动作相同的内存同步效果。
    不成功的锁定和解锁操作以及重入锁定/解锁操作，不需要任何内存同步效果。

    实施注意事项

    锁定采集（可中断，不可中断和定时）的三种形式在性能特征，排序保证或其他实现质量方面可能不同。 此外，在给定的Lock课程中，中断正在获取锁的能力可能不可用。 因此，不需要实现对所有三种形式的锁获取完全相同的保证或语义，也不需要支持正在进行的锁获取的中断。 需要一个实现来清楚地记录每个锁定方法提供的语义和保证。 它还必须遵守此接口中定义的中断语义，只要支持锁获取的中断，即全部或仅在方法输入。

    由于中断通常意味着取消，并且检查中断通常是不频繁的，所以实现可以有利于通过正常方法返回来响应中断。 即使可以显示中断发生在另一个动作可能已经解除了线程之后，这是真的。 一个实现应该记录这个行为。

    从以下版本开始：
    1.5
    另请参见：
    ReentrantLock ， Condition ， ReadWriteLock

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void lock​()
      获得锁。
      void lockInterruptibly​()
      获取锁定，除非当前线程是 interrupted 。
      Condition newCondition​()
      返回一个新Condition绑定到该实例Lock实例。
      boolean tryLock​()
      只有在调用时才可以获得锁。
      boolean tryLock​(long time, TimeUnit unit)
      如果在给定的等待时间内没有锁定，并且当前线程尚未被 interrupted获取锁定。
      void unlock​()
      释放锁。

    • 方法详细信息

      • lock

        void lock​()
        获得锁。

        如果锁不可用，则当前线程将被禁用以进行线程调度，并处于休眠状态，直到获取锁。

        实施注意事项

        A Lock实现可能能够检测锁的错误使用，例如将导致死锁的调用，并且可能在这种情况下抛出（未检查）异常。 情况和异常类型必须由该Lock实现记录。

      • lockInterruptibly

        void lockInterruptibly​()
                throws InterruptedException
        获取锁定，除非当前线程是interrupted 。

        获取锁，如果可用并立即返回。

        如果锁不可用，那么当前线程将被禁用以进行线程调度，并且处于休眠状态，直到发生两件事情之一：

        • 锁是由当前线程获取的; 要么
        • 一些其他线程当前线程interrupts ，并支持锁中断中断。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted同时获取锁，并支持锁中断，
        则抛出InterruptedException ，并清除当前线程的中断状态。

        实施注意事项

        在某些实现中中断锁获取的能力可能是不可能的，如果可能的话可能是昂贵的操作。 程序员应该知道，可能是这种情况。 在这种情况下，实施应该记录。

        一个实现可以有利于通过正常的方法返回来响应中断。

        一个Lock实现可能能够检测到锁的错误使用，例如将导致死锁的调用，并且可能在这种情况下抛出（未检查）异常。 情况和异常类型必须由该Lock实现记录。

        异常
        InterruptedException - 如果当前线程在获取锁定时中断（并且支持锁定获取的中断）

      • tryLock

        boolean tryLock​()
        只有在调用时才可以获得锁。

        获取锁定，如果可用，并立即返回值为true 。 如果锁不可用，则此方法将立即返回值为false 。

        此方法的典型用法是：

           Lock lock = ...; if (lock.tryLock()) { try { // manipulate protected state } finally { lock.unlock(); } } else { // perform alternative actions }
        此用法可确保锁定已被取消，如果未获取锁定，则不会尝试解锁。
        结果
        true如果锁被收购， false另外 false

      • tryLock

        boolean tryLock​(long time,
                TimeUnit unit)
         throws InterruptedException
        如果在给定的等待时间内是空闲的，并且当前的线程尚未被interrupted获取该锁。

        如果锁可用，此方法将立即返回值为true 。 如果锁不可用，则当前线程将被禁用以进行线程调度，并处于休眠状态，直至发生三件事情之一：

        • 锁是由当前线程获取的; 要么
        • 一些其他线程当前线程interrupts ，并且支持中断锁获取; 要么
        • 指定的等待时间过去了

        如果锁获取，则返回值true 。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted，同时获取锁，并支持锁中断，
        然后抛出InterruptedException ，并清除当前线程的中断状态。

        如果指定的等待时间过去，则返回值false 。 如果时间小于或等于零，该方法根本不会等待。

        实施注意事项

        在某些实现中中断锁获取的能力可能是不可能的，如果可能的话可能是昂贵的操作。 程序员应该知道，可能是这种情况。 在这种情况下，实施应该记录。

        实现可以有助于通过正常的方法返回来响应中断或报告超时。

        A Lock实现可能能够检测锁的错误使用，例如将导致死锁的调用，并且可能在这种情况下抛出（未检查）异常。 情况和异常类型必须由该Lock实现记录。

        参数
        time - 等待锁的最长时间
        unit - time参数的时间单位
        结果
        true如果锁已被获取，并且 false如果在获取锁之前经过的等待时间
        异常
        InterruptedException - 如果当前线程在获取锁定时中断（并且支持锁定获取的中断）

      • unlock

        void unlock​()
        释放锁。

        实施注意事项

        一个Lock实现通常会限制哪个线程可以释放一个锁（通常只有锁的持有者可以释放它），并且如果限制被违反则可能引发（未检查）异常。 任何限制和异常类型必须由该Lock实现记录。

      • newCondition

        Condition newCondition​()
        返回一个新Condition绑定到该实例Lock实例。

        在等待条件之前，锁必须由当前线程保持。 调用Condition.await()将在等待之前将原子释放锁，并在等待返回之前重新获取锁。

        实施注意事项

        Condition实例的确切操作取决于Lock实现，必须由该实现记录。

        结果
        一个新的27062366376707实例为这个Lock实例
        异常
        UnsupportedOperationException - 如果这个 Lock实现不支持条件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LockSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class LockSupport

  • java.lang.Object
    • java.util.concurrent.locks.LockSupport

  • public class LockSupport
extends Object
    用于创建锁和其他同步类的基本线程阻塞原语。

    这个类与每个使用它的线程关联，允许（在Semaphore类的意义上）。 如果许可证可用，则在park的电话将立即返回，在此过程中消耗许可证; 否则可能会阻止。 致电unpark使许可证可用，如果尚未提供。 （与信号量不同，尽管许可证不能累积，最多只有一个。）可靠的使用需要使用volatile（或atomic）变量来控制何时停放或取消标记。 对于易失性变量访问，维护对这些方法的调用排序，但不一定是非易失性变量访问。

    方法park和unpark提供了阻止和解除阻塞线程的有效手段，该方式不会遇到导致不推荐使用的方法Thread.suspend和Thread.resume不能用于此类目的的问题：一个线程调用park和另一个线程之间的尝试unpark线程将保持活跃性，由于许可证。 另外，如果调用者的线程中断，则返回park ，并且支持超时版本。 park方法也可能在任何其他时间返回，因为“无理由”，所以通常必须在循环中调用，在返回时重新检查条件。 在这个意义上， park用作“忙碌等待”的优化，这并不浪费时间旋转，但必须与unpark配对才能有效。

    这三种形式的park每个也支持一个blocker对象参数。 线程被阻止时记录此对象，以允许监视和诊断工具识别线程被阻止的原因。 （这样的工具可以使用方法getBlocker(Thread)访问阻止程序 。）强烈地鼓励使用这些形式而不是没有此参数的原始形式。 在锁实现中作为blocker提供的正常参数是this 。

    这些方法被设计为用作创建更高级同步实用程序的工具，并不适用于大多数并发控制应用程序。 park方法仅适用于以下形式的构造：

       while (!canProceed()) { // ensure request to unpark is visible to other threads ... LockSupport.park(this); }
    在线程没有动作的情况下发布请求park ，在调用park ，需要锁定或阻塞。 由于只有一个许可证与每个线程相关联，所以park任何中介使用（包括通过类加载隐式）可能导致无响应的线程（“丢失的未标记”）。

    样品用法。 这是一个先入先出的非可重入锁类的草图：

       class FIFOMutex { private final AtomicBoolean locked = new AtomicBoolean(false); private final Queue<Thread> waiters = new ConcurrentLinkedQueue<>(); public void lock() { boolean wasInterrupted = false; // publish current thread for unparkers waiters.add(Thread.currentThread()); // Block while not first in queue or cannot acquire lock while (waiters.peek() != Thread.currentThread() || !locked.compareAndSet(false, true)) { LockSupport.park(this); // ignore interrupts while waiting if (Thread.interrupted()) wasInterrupted = true; } waiters.remove(); // ensure correct interrupt status on return if (wasInterrupted) Thread.currentThread().interrupt(); } public void unlock() { locked.set(false); LockSupport.unpark(waiters.peek()); } static { // Reduce the risk of "lost unpark" due to classloading Class<?> ensureLoaded = LockSupport.class; } }
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Object getBlocker​(Thread t)
      返回提供给最近调用尚未解除阻塞的park方法的阻止程序对象，如果不阻止则返回null。
      static void park​()
      禁止当前线程进行线程调度，除非许可证可用。
      static void park​(Object blocker)
      禁止当前线程进行线程调度，除非许可证可用。
      static void parkNanos​(long nanos)
      禁用当前线程进行线程调度，直到指定的等待时间，除非许可证可用。
      static void parkNanos​(Object blocker, long nanos)
      禁用当前线程进行线程调度，直到指定的等待时间，除非许可证可用。
      static void parkUntil​(long deadline)
      禁用当前线程进行线程调度，直到指定的截止日期，除非许可证可用。
      static void parkUntil​(Object blocker, long deadline)
      禁用当前线程进行线程调度，直到指定的截止日期，除非许可证可用。
      static void unpark​(Thread thread)
      为给定的线程提供许可证（如果尚未提供）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • unpark

        public static void unpark​(Thread thread)
        为给定的线程提供许可证（如果尚未提供）。 如果线程被阻塞在park那么它将被解除阻塞。 否则，其下一次拨打park保证不被阻止。 如果给定的线程尚未启动，则此操作无法保证完全没有任何影响。
        参数
        thread - 要 thread的线程，或 null ，在这种情况下，此操作无效

      • park

        public static void park​(Object blocker)
        禁止当前线程进行线程调度，除非许可证可用。

        如果许可证可用，则它被消耗，并且该呼叫立即返回; 否则当前线程对于线程调度目的将被禁用，并且处于休眠状态，直至发生三件事情之一：

        • 一些其他线程调用unpark以当前线程作为目标; 要么
        • 一些其他线程当前线程为interrupts ; 要么
        • 电话虚假（也就是说，没有理由）返回。

        这种方法不报告是哪个线程导致该方法返回。 来电者应重新检查导致线程首先停放的条件。 呼叫者还可以确定线程在返回时的中断状态。

        参数
        blocker - 负责此线程停车的同步对象
        从以下版本开始：
        1.6

      • parkNanos

        public static void parkNanos​(Object blocker,
                             long nanos)
        禁用当前线程进行线程调度，直到指定的等待时间，除非许可证可用。

        如果许可证可用，则它被消耗，并且该呼叫立即返回; 否则当前线程对于线程调度目的将被禁用，并且处于休眠状态，直到发生四件事情之一：

        • 一些其他的线程调用unpark当前线程作为目标; 要么
        • 一些其他线程当前线程interrupts ; 要么
        • 指定的等待时间过去了; 要么
        • 电话虚假（也就是说，没有理由）返回。

        这种方法不报告是哪个线程导致该方法返回。 来电者应重新检查导致线程首先停放的条件。 呼叫者还可以确定线程的中断状态，或者返回时经过的时间。

        参数
        blocker - 负责此线程停放的同步对象
        nanos - 要等待的最大纳秒数
        从以下版本开始：
        1.6

      • parkUntil

        public static void parkUntil​(Object blocker,
                             long deadline)
        禁用当前线程进行线程调度，直到指定的截止日期，除非许可证可用。

        如果许可证可用，则它被消耗，并且该呼叫立即返回; 否则当前线程对于线程调度目的将被禁用，并且处于休眠状态，直到发生四件事情之一：

        • 一些其他线程调用unpark当前线程作为目标; 要么
        • 其他一些线程当前线程为interrupts ; 要么
        • 指定期限通过; 要么
        • 电话虚假（也就是说，没有理由）返回。

        这种方法不报告是哪个线程导致该方法返回。 来电者应重新检查导致线程首先停放的条件。 呼叫者还可以确定线程的中断状态，或返回当前的时间。

        参数
        blocker - 负责此线程停放的同步对象
        deadline - 绝对时间，以毫秒为单位，从大纪元到等到
        从以下版本开始：
        1.6

      • getBlocker

        public static Object getBlocker​(Thread t)
        返回提供给最近调用尚未解除阻塞的park方法的阻止程序对象，如果不阻止则返回null。 返回的值只是一个瞬间的快照 - 线程可能已经被阻止或阻止在不同的阻止对象上。
        参数
        t - 线程
        结果
        阻滞剂
        异常
        NullPointerException - 如果参数为空
        从以下版本开始：
        1.6

      • park

        public static void park​()
        禁止当前线程进行线程调度，除非许可证可用。

        如果许可证可用，则它被消耗，并且该呼叫立即返回; 否则当前线程对于线程调度目的将被禁用，并且处于休眠状态，直至发生三件事情之一：

        • 一些其他线程调用unpark以当前线程作为目标; 要么
        • 一些其他线程当前线程是interrupts ; 要么
        • 电话虚假（也就是说，没有理由）返回。

        这种方法不报告是哪个线程导致该方法返回。 来电者应重新检查导致线程首先停放的条件。 呼叫者还可以确定线程在返回时的中断状态。

      • parkNanos

        public static void parkNanos​(long nanos)
        禁用当前线程进行线程调度，直到指定的等待时间，除非许可证可用。

        如果许可证可用，则它被消耗，并且该呼叫立即返回; 否则当前线程对于线程调度目的将被禁用，并且处于休眠状态，直到发生四件事情之一：

        • 一些其他的线程调用unpark当前线程作为目标; 要么
        • 一些其他线程当前线程为interrupts ; 要么
        • 指定的等待时间过去了; 要么
        • 电话虚假（也就是说，没有理由）返回。

        这种方法不报告是哪个线程导致该方法返回。 来电者应重新检查导致线程首先停放的条件。 呼叫者还可以确定线程的中断状态，或者返回时经过的时间。

        参数
        nanos - 等待的最大纳秒数

      • parkUntil

        public static void parkUntil​(long deadline)
        禁用当前线程进行线程调度，直到指定的截止日期，除非许可证可用。

        如果许可证可用，则它被消耗，并且该呼叫立即返回; 否则当前线程对于线程调度目的将被禁用，并且处于休眠状态，直到发生四件事情之一：

        • 一些其他线程调用unpark与当前线程作为目标; 要么
        • 其他一些线程当前线程为interrupts ; 要么
        • 指定期限通过; 要么
        • 电话虚假（也就是说，没有理由）返回。

        这种方法不报告是哪个线程导致该方法返回。 来电者应重新检查导致线程首先停放的条件。 呼叫者还可以确定线程的中断状态，或返回当前的时间。

        参数
        deadline - 绝对时间，以毫秒为单位，从时代到等到
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadWriteLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Interface ReadWriteLock

  • 所有已知实现类：
    ReentrantReadWriteLock

    public interface ReadWriteLock
    A ReadWriteLock维护一对关联的locks ，一个用于只读操作，一个用于写入。 read lock可以由多个阅读器线程同时进行，只要没有作者。 write lock是独家的。

    所有的ReadWriteLock实现都必须保证writeLock操作的内存同步效果（在Lock接口中指定）也适用于相关的readLock 。 也就是说，一个线程成功获取读锁定将会看到在之前发布的写锁定所做的所有更新。

    读写锁允许访问共享数据时的并发性高于互斥锁所允许的并发性。 它利用了这样一个事实：一次只有一个线程（ 写入线程）可以修改共享数据，在许多情况下，任何数量的线程都可以同时读取数据（因此读取器线程）。 从理论上讲，通过使用读写锁允许的并发性增加将导致性能改进超过使用互斥锁。 实际上，并发性的增加只能在多处理器上完全实现，然后只有在共享数据的访问模式是合适的时才可以。

    读写锁是否会提高使用互斥锁的性能取决于数据被读取的频率与被修改的频率相比，读取和写入操作的持续时间以及数据的争用 - 即是，将尝试同时读取或写入数据的线程数。 例如，最初填充数据的集合，然后经常被修改的频繁搜索（例如某种目录）是使用读写锁的理想候选者。 然而，如果更新变得频繁，那么数据的大部分时间将被专门锁定，并且并发性增加很少。 此外，如果读取操作太短，则读写锁定实现（其本身比互斥锁更复杂）的开销可以支配执行成本，特别是因为许多读写锁定实现仍将序列化所有线程通过小部分代码。 最终，只有剖析和测量将确定使用读写锁是否适合您的应用程序。

    虽然读写锁的基本操作是直接的，但是执行必须做出许多策略决策，这可能会影响给定应用程序中读写锁定的有效性。 这些政策的例子包括：

    • 在写入器释放写入锁定时，确定在读取器和写入器都在等待时是否授予读取锁定或写入锁定。 作家偏好是常见的，因为写作预计会很短，很少见。 读者喜好不常见，因为如果读者经常和长期的预期，写作可能导致漫长的延迟。 公平的或“按顺序”的实现也是可能的。
    • 确定在读卡器处于活动状态并且写入器正在等待时请求读取锁定的读取器是否被授予读取锁定。 读者的偏好可以无限期地拖延作者，而对作者的偏好可以减少并发的潜力。
    • 确定锁是否可重入：一个具有写锁的线程是否可以重新获取？ 持有写锁可以获取读锁吗？ 读锁本身是否可重入？
    • 写入锁可以降级到读锁，而不允许插入写者？ 读锁可以升级到写锁，优先于其他等待读者或作者吗？
    在评估应用程序的给定实现的适用性时，应考虑所有这些问题。
    从以下版本开始：
    1.5
    另请参见：
    ReentrantReadWriteLock ， Lock ， ReentrantLock

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Lock readLock​()
      返回用于阅读的锁。
      Lock writeLock​()
      返回用于写入的锁。

    • 方法详细信息

      • readLock

        Lock readLock​()
        返回用于阅读的锁。
        结果
        用于阅读的锁

      • writeLock

        Lock writeLock​()
        返回用于写入的锁。
        结果
        用于书写的锁
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReentrantLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class ReentrantLock

  • java.lang.Object
    • java.util.concurrent.locks.ReentrantLock
  • All Implemented Interfaces:
    Serializable ， Lock

    public class ReentrantLock
extends Object
implements Lock, Serializable
    可重入互斥Lock具有与使用synchronized方法和语句访问的隐式监视锁相同的基本行为和语义，但具有扩展功能。

    A ReentrantLock由线程拥有 ，最后成功锁定，但尚未解锁。 调用lock的线程将返回，当锁不是由另一个线程拥有时，成功获取锁。 如果当前线程已经拥有该锁，该方法将立即返回。 这可以使用方法isHeldByCurrentThread()和getHoldCount()进行检查。

    该类的构造函数接受可选的公平参数。 设置true ，在争用的情况下，锁有利于授予对最长等待线程的访问权限。 否则，该锁不保证任何特定的访问顺序。 使用许多线程访问的公平锁的程序可能会比使用默认设置的整体吞吐量（即，更慢，通常要慢得多），但是具有更小的差异来获得锁定并保证缺乏饥饿。 但是请注意，锁的公平性不能保证线程调度的公平性。 因此，使用公平锁的许多线程之一可以连续获得多次，而其他活动线程不进行而不是当前持有锁。 另请注意，未定义的tryLock()方法不符合公平性设置。 如果锁可用，即使其他线程正在等待，它也会成功。

    建议您务必立即致电lock与try块，最典型的是在之前/之后施工，如：

       class X { private final ReentrantLock lock = new ReentrantLock(); // ... public void m() { lock.lock(); // block until condition holds try { // ... method body } finally { lock.unlock() } } }

    除了实现Lock接口，该类还定义了一些public和protected方法来检查锁的状态。 其中一些方法仅适用于仪器和监控。

    此类的序列化与内置锁的操作方式相同：反序列化锁处于未锁定状态，无论其序列化时的状态如何。

    此锁最多支持同一个线程的2147483647递归锁。 超过此限制的尝试将导致Error从锁定方法中抛出。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReentrantLock​()
      创建一个 ReentrantLock的实例。
      ReentrantLock​(boolean fair)
      使用给定的公平政策创建一个 ReentrantLock的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getHoldCount​()
      查询当前线程对此锁的暂停数量。
      protected Thread getOwner​()
      返回当前拥有此锁的线程，如果不拥有，则返回 null 。
      protected Collection<Thread> getQueuedThreads​()
      返回包含可能正在等待获取此锁的线程的集合。
      int getQueueLength​()
      返回等待获取此锁的线程数的估计。
      protected Collection<Thread> getWaitingThreads​(Condition condition)
      返回包含可能在与此锁相关联的给定条件下等待的线程的集合。
      int getWaitQueueLength​(Condition condition)
      返回与此锁相关联的给定条件等待的线程数的估计。
      boolean hasQueuedThread​(Thread thread)
      查询给定线程是否等待获取此锁。
      boolean hasQueuedThreads​()
      查询是否有线程正在等待获取此锁。
      boolean hasWaiters​(Condition condition)
      查询任何线程是否等待与此锁相关联的给定条件。
      boolean isFair​()
      如果此锁的公平设置为true，则返回 true 。
      boolean isHeldByCurrentThread​()
      查询此锁是否由当前线程持有。
      boolean isLocked​()
      查询此锁是否由任何线程持有。
      void lock​()
      获得锁。
      void lockInterruptibly​()
      获取锁定，除非当前线程是 interrupted 。
      Condition newCondition​()
      返回Condition与此使用实例Lock实例。
      String toString​()
      返回一个标识此锁的字符串以及其锁定状态。
      boolean tryLock​()
      只有在调用时它不被另一个线程占用才能获取锁。
      boolean tryLock​(long timeout, TimeUnit unit)
      如果在给定的等待时间内没有被另一个线程 占用 ，并且当前线程尚未被 interrupted采集锁定 。
      void unlock​()
      尝试释放此锁。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ReentrantLock

        public ReentrantLock​()
        创建一个ReentrantLock的实例。 这相当于使用ReentrantLock(false) 。

      • ReentrantLock

        public ReentrantLock​(boolean fair)
        使用给定的公平政策创建 ReentrantLock的实例。
        参数
        fair - true如果此锁应使用合理的订购策略

    • 方法详细信息

      • lock

        public void lock​()
        获得锁。

        如果锁没有被另一个线程占用并且立即返回，则将锁定计数设置为1。

        如果当前线程已经保持锁定，则保持计数增加1，该方法立即返回。

        如果锁被另一个线程保持，则当前线程将被禁用以进行线程调度，并且在锁定已被获取之前处于休眠状态，此时锁定保持计数被设置为1。

        Specified by:
        lock在接口 Lock

      • lockInterruptibly

        public void lockInterruptibly​()
                       throws InterruptedException
        获取锁定，除非当前线程是interrupted 。

        如果锁没有被另一个线程占用并且立即返回，则将锁定计数设置为1。

        如果当前线程已经保存此锁，则保持计数将递增1，该方法立即返回。

        如果锁被另一个线程保持，则当前线程将被禁用以进行线程调度，并且处于休眠状态，直到发生两件事情之一：

        • 锁是由当前线程获取的; 要么
        • 一些其他线程当前线程interrupts 。

        如果当前线程获取锁定，则锁定保持计数被设置为1。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted同时获取锁，
        然后抛出InterruptedException ，并清除当前线程的中断状态。

        在该实现中，由于该方法是明确的中断点，所以优先考虑通过锁定正常或可重入的采集来响应中断。

        Specified by:
        lockInterruptibly在接口 Lock
        异常
        InterruptedException - 当前线程是否中断

      • tryLock

        public boolean tryLock​()
        只有在调用时它不被另一个线程占用才能获取锁。

        如果锁定不被另一个线程true并且立即返回值true ，将锁定保持计数设置为1，则获取锁定。 即使此锁已设置为使用合理的排序策略，如果可用，则呼叫tryLock() 将立即获取锁，无论其他线程是否正在等待锁定。 这种“趸船”行为在某些情况下是有用的，尽管它打破了公平。 如果要遵守该锁的公平性设置，则使用tryLock(0, TimeUnit.SECONDS) 几乎相当（也检测到中断）。

        如果当前线程已经保存该锁，则保持计数增加1，该方法返回true 。

        如果锁由另一个线程持有，则该方法将立即返回值为false 。

        Specified by:
        tryLock接口 Lock
        结果
        true如果锁是空闲的并且被当前线程获取，或者锁已经被当前线程保持; 而另外false

      • tryLock

        public boolean tryLock​(long timeout,
                       TimeUnit unit)
                throws InterruptedException
        如果在给定的等待时间内没有被另一个线程占用 ，并且当前线程尚未被interrupted获取锁定 。

        获取锁定，如果没有被另一个线程保持，并立即返回值true ，将锁定保持计数设置为1。 如果此锁已设置为使用合理的排序策略，则如果任何其他线程正在等待锁定， 则不会获取可用的锁。 这与tryLock()方法不同。 如果你想要一个定时的tryLock ，允许在公平的锁定驳船，那么将定时和非定时的形式组合在一起：

           if (lock.tryLock() || lock.tryLock(timeout, unit)) { ... }

        如果当前线程已经保存该锁，则保持计数增加1，该方法返回true 。

        如果锁被另一个线程保持，则当前线程将被禁用以进行线程调度，并且处于休眠状态，直至发生三件事情之一：

        • 锁是由当前线程获取的; 要么
        • 一些其他线程当前线程interrupts ; 要么
        • 指定的等待时间过去了

        如果锁获取，则返回值true ，锁定保持计数设置为1。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted同时获取锁，
        然后抛出InterruptedException ，并清除当前线程的中断状态。

        如果指定的等待时间过去，则返回值false 。 如果时间小于或等于零，该方法根本不会等待。

        在这种实现中，由于该方法是明确的中断点，所以优先考虑响应中断超过正常或可重入的锁的获取，并且报告等待时间的过去。

        Specified by:
        tryLock在接口 Lock
        参数
        timeout - 等待锁的时间
        unit - 超时参数的时间单位
        结果
        true如果锁是空闲的并且被当前线程获取，或者锁已经被当前线程保持; 如果可以获取锁定之前经过的等待时间， false
        异常
        InterruptedException - 当前线程是否中断
        NullPointerException - 如果时间单位为空

      • unlock

        public void unlock​()
        尝试释放此锁。

        如果当前线程是该锁的持有者，则保持计数递减。 如果保持计数现在为零，则锁定被释放。 如果当前线程不是该锁的持有者，则抛出IllegalMonitorStateException 。

        Specified by:
        unlock在接口 Lock
        异常
        IllegalMonitorStateException - 如果当前线程不持有此锁

      • newCondition

        public Condition newCondition​()
        返回Condition与此使用实例Lock实例。

        返回Condition实例支持相同的用途为做Object种监视器方法（ wait ， notify ，并notifyAll与使用时）内置监视器锁定。

        • 如果在调用任何Condition waiting或signalling方法时未锁定此锁，则抛出IllegalMonitorStateException 。
        • 当条件waiting方法被调用时，锁将被释放，并且在它们返回之前，重新获取锁并且锁定保持计数恢复为调用该方法时的值。
        • 如果一个线程是interrupted，而等待，则等待将终止，则会抛出一个InterruptedException ，线程的中断状态将被清除。
        • 等待线程以FIFO顺序发出信号。
        • 从等待方法返回的线程的锁重新获取的顺序与初始获取锁的线程相同，这在默认情况下未指定，但是对于公平的锁有利于那些等待最长的线程。
        Specified by:
        newCondition在接口 Lock
        结果
        Condition对象

      • getHoldCount

        public int getHoldCount​()
        查询当前线程对此锁的暂停数量。

        一个线程对于与解锁动作不匹配的每个锁定动作都有一个锁定。

        保持计数信息通常仅用于测试和调试目的。 例如，如果一段代码不应该被锁定，那么我们可以断言这个事实：

           class X { ReentrantLock lock = new ReentrantLock(); // ... public void m() { assert lock.getHoldCount() == 0; lock.lock(); try { // ... method body } finally { lock.unlock(); } } }
        结果
        当前线程对此锁定的保持次数，如果此锁定不由当前线程保持，则为零

      • isHeldByCurrentThread

        public boolean isHeldByCurrentThread​()
        查询此锁是否由当前线程持有。

        类似于内置监视器锁的Thread.holdsLock(Object)方法，该方法通常用于调试和测试。 例如，只有在锁定时才应该调用的方法可以断言是这样的：

           class X { ReentrantLock lock = new ReentrantLock(); // ... public void m() { assert lock.isHeldByCurrentThread(); // ... method body } }

        它也可以用于确保以非折返方式使用折返锁，例如：

           class X { ReentrantLock lock = new ReentrantLock(); // ... public void m() { assert !lock.isHeldByCurrentThread(); lock.lock(); try { // ... method body } finally { lock.unlock(); } } }
        结果
        true如果当前线程持有该锁，否则为 false

      • isLocked

        public boolean isLocked​()
        查询此锁是否由任何线程持有。 该方法设计用于监视系统状态，不用于同步控制。
        结果
        true如果任何线程持有此锁，否则为 false

      • isFair

        public final boolean isFair​()
        如果此锁的公平设置为true，则返回 true 。
        结果
        true如果这个锁的公平设置为true

      • getOwner

        protected Thread getOwner​()
        返回当前拥有此锁的线程，如果不拥有，则返回null 。 当这个方法被不是所有者的线程调用时，返回值反映了当前锁定状态的尽力近似。 例如，即使有线程试图获取锁定但还没有这样做，所有者可能暂时是null 。 该方法旨在便于构建提供更广泛的锁定监控设施的子类。
        结果
        所有者，或 null如果不拥有

      • hasQueuedThreads

        public final boolean hasQueuedThreads​()
        查询是否有线程正在等待获取此锁。 请注意，由于取消可能随时发生，因此true返回不能保证任何其他线程将获得此锁。 该方法主要用于监视系统状态。
        结果
        true如果可能有其他线程等待获取锁

      • hasQueuedThread

        public final boolean hasQueuedThread​(Thread thread)
        查询给定线程是否等待获取此锁。 请注意，由于取消可能随时发生，因此true返回不能保证此线程将获取此锁。 该方法主要用于监视系统状态。
        参数
        thread - 线程
        结果
        true如果给定的线程排队等待此锁
        异常
        NullPointerException - 如果线程为空

      • getQueueLength

        public final int getQueueLength​()
        返回等待获取此锁的线程数的估计。 该值只是一个估计，因为线程数可能会在此方法遍历内部数据结构时动态更改。 该方法设计用于监控系统状态，不用于同步控制。
        结果
        估计等待这个锁的线程数

      • getQueuedThreads

        protected Collection<Thread> getQueuedThreads​()
        返回包含可能正在等待获取此锁的线程的集合。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。 该方法旨在便于构建提供更广泛监控设施的子类。
        结果
        线程的收集

      • hasWaiters

        public boolean hasWaiters​(Condition condition)
        查询任何线程是否等待与此锁相关联的给定条件。 请注意，由于超时和中断可能随时发生，因此true返回不能保证未来的任何线程将唤醒signal 。 该方法主要用于监视系统状态。
        参数
        condition - 条件
        结果
        true如果有任何等待线程
        异常
        IllegalMonitorStateException - 如果此锁没有保持
        IllegalArgumentException - 如果给定的条件与此锁没有关联
        NullPointerException - 如果条件为空

      • getWaitQueueLength

        public int getWaitQueueLength​(Condition condition)
        返回与此锁相关联的给定条件等待的线程数的估计。 请注意，由于超时和中断可能在任何时间发生，估计仅作为实际服务员人数的上限。 该方法设计用于监视系统状态，不用于同步控制。
        参数
        condition - 条件
        结果
        估计等待线程数
        异常
        IllegalMonitorStateException - 如果此锁不被保留
        IllegalArgumentException - 如果给定的条件不与此锁相关联
        NullPointerException - 如果条件为空

      • getWaitingThreads

        protected Collection<Thread> getWaitingThreads​(Condition condition)
        返回包含可能在与此锁相关联的给定条件下等待的线程的集合。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。 该方法旨在便于构建提供更广泛的状态监测设施的子类。
        参数
        condition - 条件
        结果
        线程的收集
        异常
        IllegalMonitorStateException - 如果此锁没有保持
        IllegalArgumentException - 如果给定的条件不与此锁相关联
        NullPointerException - 条件为空

      • toString

        public String toString​()
        返回一个标识此锁的字符串以及其锁定状态。 括号中的状态包括字符串"Unlocked"或字符串"Locked by"后跟所拥有的线程的name 。
        重写：
        toString在 Object
        结果
        标识此锁的字符串以及其锁定状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReentrantReadWriteLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class ReentrantReadWriteLock

  • java.lang.Object
    • java.util.concurrent.locks.ReentrantReadWriteLock
  • All Implemented Interfaces:
    Serializable ， ReadWriteLock

    public class ReentrantReadWriteLock
extends Object
implements ReadWriteLock, Serializable
    支持ReadWriteLock的类似语义ReentrantLock的实现 。

    此类具有以下属性：

    • 收购令

      此类不会强制使用读取器或写入器优先顺序进行锁定访问。 但是，它确实支持可选的公平政策。

      非公平模式（默认）
      当被构造为不公平（默认）时，进入读写锁定的顺序是未指定的，受到重入限制。 持续竞争的非空格锁可能无限期地推迟一个或多个读卡器或写入器线程，但通常具有比公平锁定更高的吞吐量。
      公平模式
      当公平地构建时，线程使用近似到达订单策略来争取进入。 当释放当前持有的锁时，最长等待的单个写入器线程将被分配写入锁定，或者如果有一组读取器线程等待比所有等待写入器线程长的时间，则该组将被分配读取锁定。

      尝试获取公平读锁（不可重入）的线程将阻塞，如果写锁定或有等待的写入程序线程。 直到最旧的当前正在等待的写入程序线程获取并释放写入锁之后，该线程才会获取读锁定。 当然，如果一个等待的作家放弃了等待，留下一个或多个阅读器线程作为队列中最长的服务器，其中写锁定空闲，那么这些读取器将被分配读取锁定。

      尝试获取公正的写锁定（非重入）的线程将阻止，除非读锁定和写锁定都是空闲的（这意味着没有等待线程）。 （请注意，非阻塞ReentrantReadWriteLock.ReadLock.tryLock()和ReentrantReadWriteLock.WriteLock.tryLock()方法不符合此公平的设置，如果可能，将立即获取锁定，而不管等待线程）。

    • 重入

      这个锁允许读者和作者以ReentrantLock的风格重新获取读写锁。 在写入线程所持有的所有写入锁已经被释放之前，不允许非重入读取器。

      另外，写入器可以获取读锁，但反之亦然。 在其他应用程序中，当在执行在读锁定下执行读取的方法的调用或回调期间保留写入锁时，重入可能是有用的。 如果读者尝试获取写入锁定，它将永远不会成功。

    • 锁定降级

      重入还允许通过获取写入锁定，然后读取锁定然后释放写入锁定从写入锁定到读取锁定。 然而，从读锁定写锁定升级是不可能的。

    • 中断锁获取

      读取锁定和写入锁定在锁定采集期间都支持中断。

    • Condition支持

      写入锁提供了一个Condition实现，其行为以同样的方式，相对于写入锁定，为Condition提供实现ReentrantLock.newCondition()确实为ReentrantLock 。 这个Condition当然只能用于写锁。

      读锁不支持Condition和readLock().newCondition()投掷UnsupportedOperationException 。

    • 仪表

      该类支持确定锁是否被保持或竞争的方法。 这些方法设计用于监视系统状态，而不是进行同步控制。

    此类的序列化与内置锁的操作方式相同：反序列化锁处于未锁定状态，无论其序列化时的状态如何。

    示例用法 这是一个代码草图，显示了如何在更新缓存后执行锁定降级（异常处理在以非嵌套方式处理多个锁时尤为棘手）：

       class CachedData { Object data; boolean cacheValid; final ReentrantReadWriteLock rwl = new ReentrantReadWriteLock(); void processCachedData() { rwl.readLock().lock(); if (!cacheValid) { // Must release read lock before acquiring write lock rwl.readLock().unlock(); rwl.writeLock().lock(); try { // Recheck state because another thread might have // acquired write lock and changed state before we did. if (!cacheValid) { data = ... cacheValid = true; } // Downgrade by acquiring read lock before releasing write lock rwl.readLock().lock(); } finally { rwl.writeLock().unlock(); // Unlock write, still hold read } } try { use(data); } finally { rwl.readLock().unlock(); } } }
    ReentrantReadWriteLocks可用于改进某些类型集合的某些用途中的并发性。 这通常只有当集合被预期为较大时才能访问，比读者线程更多的读者线程访问，并且需要超出同步开销的开销的操作。 例如，这里是一个使用TreeMap的类，该类将被大量并且被同时访问。
       class RWDictionary { private final Map<String, Data> m = new TreeMap<>(); private final ReentrantReadWriteLock rwl = new ReentrantReadWriteLock(); private final Lock r = rwl.readLock(); private final Lock w = rwl.writeLock(); public Data get(String key) { r.lock(); try { return m.get(key); } finally { r.unlock(); } } public List<String> allKeys() { r.lock(); try { return new ArrayList<>(m.keySet()); } finally { r.unlock(); } } public Data put(String key, Data value) { w.lock(); try { return m.put(key, value); } finally { w.unlock(); } } public void clear() { w.lock(); try { m.clear(); } finally { w.unlock(); } } }

    实施说明

    此锁最多支持65535个递归写锁和65535个读锁。 尝试超过这些限制会导致Error从锁定方法中抛出。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ReentrantReadWriteLock.ReadLock
      方法 readLock()返回的锁。
      static class  ReentrantReadWriteLock.WriteLock
      方法 writeLock()返回的锁。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReentrantReadWriteLock​()
      使用默认（非空）订购属性创建新的 ReentrantReadWriteLock 。
      ReentrantReadWriteLock​(boolean fair)
      创建一个新的 ReentrantReadWriteLock与给定的公平政策。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Thread getOwner​()
      返回当前拥有写锁的线程，如果不拥有，则返回 null 。
      protected Collection<Thread> getQueuedReaderThreads​()
      返回一个包含可能正在等待获取读取锁的线程的集合。
      protected Collection<Thread> getQueuedThreads​()
      返回一个包含可能正在等待获取读取或写入锁定的线程的集合。
      protected Collection<Thread> getQueuedWriterThreads​()
      返回一个包含可能正在等待获取写入锁的线程的集合。
      int getQueueLength​()
      返回等待获取读取或写入锁定的线程数的估计。
      int getReadHoldCount​()
      查询当前线程对此锁的可重入读取保留数。
      int getReadLockCount​()
      查询为此锁持有的读取锁的数量。
      protected Collection<Thread> getWaitingThreads​(Condition condition)
      返回包含可能在与写锁相关联的给定条件下等待的线程的集合。
      int getWaitQueueLength​(Condition condition)
      返回与写入锁相关联的给定条件等待的线程数的估计。
      int getWriteHoldCount​()
      查询当前线程对此锁的可重入写入数量。
      boolean hasQueuedThread​(Thread thread)
      查询给定线程是否等待获取读取或写入锁定。
      boolean hasQueuedThreads​()
      查询是否有任何线程正在等待获取读取或写入锁定。
      boolean hasWaiters​(Condition condition)
      查询任何线程是否等待与写锁相关联的给定条件。
      boolean isFair​()
      如果此锁的公平设置为true，则返回 true 。
      boolean isWriteLocked​()
      查询写锁是否由任何线程持有。
      boolean isWriteLockedByCurrentThread​()
      查询写锁是否由当前线程持有。
      ReentrantReadWriteLock.ReadLock readLock​()
      返回用于阅读的锁。
      String toString​()
      返回一个标识此锁的字符串以及其锁定状态。
      ReentrantReadWriteLock.WriteLock writeLock​()
      返回用于写入的锁。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ReentrantReadWriteLock

        public ReentrantReadWriteLock​()
        创建一个新的 ReentrantReadWriteLock与默认（非空）订购属性。

      • ReentrantReadWriteLock

        public ReentrantReadWriteLock​(boolean fair)
        创建一个新的 ReentrantReadWriteLock与给定的公平政策。
        参数
        fair - true如果此锁应使用合理的订购策略

    • 方法详细信息

      • writeLock

        public ReentrantReadWriteLock.WriteLock writeLock​()
        描述从接口ReadWriteLock复制
        返回用于写入的锁。
        Specified by:
        writeLock在接口 ReadWriteLock
        结果
        用于书写的锁

      • readLock

        public ReentrantReadWriteLock.ReadLock readLock​()
        描述从接口ReadWriteLock复制
        返回用于阅读的锁。
        Specified by:
        readLock在接口 ReadWriteLock
        结果
        用于阅读的锁

      • isFair

        public final boolean isFair​()
        如果此锁的公平设置为true，则返回 true 。
        结果
        true如果这个锁的公平设置为true

      • getOwner

        protected Thread getOwner​()
        返回当前拥有写锁的线程，如果不拥有，则返回null 。 当这个方法被不是所有者的线程调用时，返回值反映了当前锁定状态的尽力近似。 例如，即使有线程试图获取锁定但还没有这样做，所有者可能暂时是null 。 该方法旨在便于构建提供更广泛的锁定监控设施的子类。
        结果
        所有者，或 null如果不拥有

      • getReadLockCount

        public int getReadLockCount​()
        查询为此锁持有的读取锁的数量。 该方法设计用于监控系统状态，不用于同步控制。
        结果
        持有的读取锁的数量

      • isWriteLocked

        public boolean isWriteLocked​()
        查询写锁是否由任何线程持有。 该方法设计用于监控系统状态，不用于同步控制。
        结果
        true如果任何线程保持写锁定，否则为 false

      • isWriteLockedByCurrentThread

        public boolean isWriteLockedByCurrentThread​()
        查询写锁是否由当前线程持有。
        结果
        true如果当前线程保持写锁定，否则为 false

      • getWriteHoldCount

        public int getWriteHoldCount​()
        查询当前线程对此锁的可重入写入数量。 写入线程对于与解锁操作不匹配的每个锁定操作都保持锁定。
        结果
        当前线程对写锁定的保持数，如果当前线程不保留写锁定，则为零

      • getReadHoldCount

        public int getReadHoldCount​()
        查询当前线程对此锁的可重入读取保留数。 读取器线程对于与解锁动作不匹配的每个锁定动作保持锁定。
        结果
        当前线程读锁定的保持数，如果当前线程未读取锁定，则为零
        从以下版本开始：
        1.6

      • getQueuedWriterThreads

        protected Collection<Thread> getQueuedWriterThreads​()
        返回一个包含可能正在等待获取写入锁的线程的集合。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。 该方法旨在便于构建提供更广泛的锁定监控设施的子类。
        结果
        线程的收集

      • getQueuedReaderThreads

        protected Collection<Thread> getQueuedReaderThreads​()
        返回一个包含可能正在等待获取读取锁的线程的集合。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。 该方法旨在便于构建提供更广泛的锁定监控设施的子类。
        结果
        线程的收集

      • hasQueuedThreads

        public final boolean hasQueuedThreads​()
        查询是否有任何线程正在等待获取读取或写入锁定。 请注意，由于取消可能随时发生，因此true返回不能保证任何其他线程将获得锁定。 该方法主要用于监视系统状态。
        结果
        true如果可能有其他线程等待获取锁

      • hasQueuedThread

        public final boolean hasQueuedThread​(Thread thread)
        查询给定线程是否等待获取读取或写入锁定。 请注意，由于取消可能随时发生，因此true返回不能保证此线程将获取锁定。 该方法主要用于监视系统状态。
        参数
        thread - 线程
        结果
        true如果给定的线程排队等待这个锁
        异常
        NullPointerException - 如果线程为空

      • getQueueLength

        public final int getQueueLength​()
        返回等待获取读取或写入锁定的线程数的估计。 该值只是一个估计，因为线程数可能会在此方法遍历内部数据结构时动态更改。 该方法设计用于监控系统状态，不用于同步控制。
        结果
        估计等待这个锁的线程数

      • getQueuedThreads

        protected Collection<Thread> getQueuedThreads​()
        返回一个包含可能正在等待获取读取或写入锁定的线程的集合。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。 该方法旨在便于构建提供更广泛监控设施的子类。
        结果
        线程的收集

      • hasWaiters

        public boolean hasWaiters​(Condition condition)
        查询任何线程是否等待与写锁相关联的给定条件。 请注意，由于超时和中断可能随时发生，因此true返回不能保证未来的signal将唤醒任何线程。 该方法主要用于监视系统状态。
        参数
        condition - 条件
        结果
        true如果有任何等待线程
        异常
        IllegalMonitorStateException - 如果此锁没有保持
        IllegalArgumentException - 如果给定的条件不与此锁相关联
        NullPointerException - 如果条件为空

      • getWaitQueueLength

        public int getWaitQueueLength​(Condition condition)
        返回与写入锁相关联的给定条件等待的线程数的估计。 请注意，由于超时和中断可能在任何时间发生，估计仅作为实际服务员人数的上限。 该方法设计用于监视系统状态，不用于同步控制。
        参数
        condition - 条件
        结果
        估计等待线程数
        异常
        IllegalMonitorStateException - 如果此锁不保持
        IllegalArgumentException - 如果给定的条件不与此锁相关联
        NullPointerException - 如果条件为空

      • getWaitingThreads

        protected Collection<Thread> getWaitingThreads​(Condition condition)
        返回包含可能在与写锁相关联的给定条件下等待的线程的集合。 因为在构建此结果时，实际的线程集可能会动态更改，所以返回的集合只是尽力而为的估计。 返回的集合的元素没有特定的顺序。 该方法旨在便于构建提供更广泛的状态监测设施的子类。
        参数
        condition - 条件
        结果
        线程的收集
        异常
        IllegalMonitorStateException - 如果此锁没有保持
        IllegalArgumentException - 如果给定的条件不与此锁相关联
        NullPointerException - 如果条件为空

      • toString

        public String toString​()
        返回一个标识此锁的字符串以及其锁定状态。 括号中的状态包括字符串"Write locks ="其后是可重入的写入锁的数量，而字符串"Read locks ="之后是持有的读锁定数。
        重写：
        toString在 Object
        结果
        标识此锁的字符串以及其锁定状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReentrantReadWriteLock.ReadLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class ReentrantReadWriteLock.ReadLock

  • java.lang.Object
    • java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
  • All Implemented Interfaces:
    Serializable ， Lock
    Enclosing class:
    ReentrantReadWriteLock

    public static class ReentrantReadWriteLock.ReadLock
extends Object
implements Lock, Serializable
    方法 ReentrantReadWriteLock.readLock()返回的锁。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ReadLock​(ReentrantReadWriteLock lock)
      子类使用的构造方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void lock​()
      获取读锁。
      void lockInterruptibly​()
      获取读锁定，除非当前线程是 interrupted 。
      Condition newCondition​()
      抛出 UnsupportedOperationException因为 ReadLocks不支持条件。
      String toString​()
      返回一个标识此锁的字符串以及其锁定状态。
      boolean tryLock​()
      只有在调用时写锁定不被其他线程占用才能获取读锁。
      boolean tryLock​(long timeout, TimeUnit unit)
      如果写锁定在给定等待时间内未被另一个线程 占用 ，并且当前线程尚未被 interrupted获取读取锁定。
      void unlock​()
      尝试释放此锁。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ReadLock

        protected ReadLock​(ReentrantReadWriteLock lock)
        子类使用的构造方法。
        参数
        lock - 外锁对象
        异常
        NullPointerException - 如果锁为空

    • 方法详细信息

      • lock

        public void lock​()
        获取读锁。

        如果写锁定不被另一个线程占用并立即返回，则获取读取锁定。

        如果写锁定由另一个线程保存，则当前线程将被禁用以进行线程调度，并处于休眠状态，直到获取读取锁定为止。

        Specified by:
        lock在接口 Lock

      • lockInterruptibly

        public void lockInterruptibly​()
                       throws InterruptedException
        获取读锁定，除非当前线程为interrupted 。

        如果写锁定不被另一个线程占用并立即返回，则获取读取锁定。

        如果写锁定由另一个线程保存，则当前线程将被禁用以进行线程调度，并且处于休眠状态，直到发生两件事情之一：

        • 读锁定由当前线程获取; 要么
        • 一些其他线程interrupts当前线程。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted，同时获取读锁，
        则抛出InterruptedException并清除当前线程的中断状态。

        在该实现中，由于该方法是明确的中断点，所以优先考虑通过锁定正常或可重入的采集来响应中断。

        Specified by:
        lockInterruptibly在接口 Lock
        异常
        InterruptedException - 当前线程是否中断

      • tryLock

        public boolean tryLock​()
        只有在调用时写锁定不被其他线程占用才能获取读锁。

        如果写锁定不被另一个线程true则获取读锁定，并立即返回值为true 。 即使此锁已设置为使用合理的订购策略，如果可用的话，无论其他线程是否正在等待读锁定，对tryLock()的调用将立即获取读锁。 这种“趸船”行为在某些情况下是有用的，尽管它打破了公平。 如果要尊重此锁的公平性设置，则使用tryLock(0, TimeUnit.SECONDS) 几乎相当（也检测到中断）。

        如果写锁定由另一个线程持有，则该方法将立即返回值为false 。

        Specified by:
        tryLock在接口 Lock
        结果
        true如果读取锁被获取

      • tryLock

        public boolean tryLock​(long timeout,
                       TimeUnit unit)
                throws InterruptedException
        如果写锁定在给定等待时间内未被另一个线程占用并且当前线程尚未被interrupted采集读取锁定 。

        如果写锁定不被另一个线程true则获取读锁定，并立即返回值为true 。 如果此锁已设置为使用合理的排序策略，则如果任何其他线程正在等待锁定， 则不会获取可用的锁。 这与tryLock()方法相反。 如果你想要一个定时的tryLock ，允许在公平的锁定驳船，那么将定时和不定时的形式结合在一起：

           if (lock.tryLock() || lock.tryLock(timeout, unit)) { ... }

        如果写锁定由另一个线程保存，则当前线程将被禁用以进行线程调度，并处于休眠状态，直至发生三件事情之一：

        • 读锁定由当前线程获取; 要么
        • 一些其他线程当前线程interrupts ; 要么
        • 指定的等待时间过去了。

        如果读取锁定，则返回值true 。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted同时获取读锁，
        然后抛出InterruptedException ，并清除当前线程的中断状态。

        如果指定的等待时间过去，则返回值false 。 如果时间小于或等于零，该方法根本不会等待。

        在这种实现中，由于该方法是明确的中断点，所以优先考虑响应中断超过正常或可重入的锁的获取，并且报告等待时间的过去。

        Specified by:
        tryLock在接口 Lock
        参数
        timeout - 等待读锁的时间
        unit - 超时参数的时间单位
        结果
        true如果读锁被获取
        异常
        InterruptedException - 当前线程是否中断
        NullPointerException - 如果时间单位为空

      • unlock

        public void unlock​()
        尝试释放此锁。

        如果读取器的数量现在为零，则锁定可用于写入锁定尝试。 如果当前线程不保持此锁，则抛出IllegalMonitorStateException 。

        Specified by:
        unlock在接口 Lock
        异常
        IllegalMonitorStateException - 如果当前线程不持有此锁

      • newCondition

        public Condition newCondition​()
        抛出 UnsupportedOperationException因为 ReadLocks不支持条件。
        Specified by:
        newCondition在接口 Lock
        结果
        一个新的Condition实例为这个Lock实例
        异常
        UnsupportedOperationException - 永远

      • toString

        public String toString​()
        返回一个标识此锁的字符串以及其锁定状态。 括号中的状态包括字符串"Read locks ="后跟保持的读锁定数。
        重写：
        toString在 Object
        结果
        标识此锁的字符串以及其锁定状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReentrantReadWriteLock.WriteLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class ReentrantReadWriteLock.WriteLock

  • java.lang.Object
    • java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
  • All Implemented Interfaces:
    Serializable ， Lock
    Enclosing class:
    ReentrantReadWriteLock

    public static class ReentrantReadWriteLock.WriteLock
extends Object
implements Lock, Serializable
    该锁由方法 ReentrantReadWriteLock.writeLock()返回。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected WriteLock​(ReentrantReadWriteLock lock)
      子类使用的构造方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getHoldCount​()
      查询当前线程对此写锁定的暂停数量。
      boolean isHeldByCurrentThread​()
      查询这个写锁是否由当前线程持有。
      void lock​()
      获取写锁。
      void lockInterruptibly​()
      获取写锁定，除非当前线程为 interrupted 。
      Condition newCondition​()
      返回Condition与此使用实例Lock实例。
      String toString​()
      返回一个标识此锁的字符串以及其锁定状态。
      boolean tryLock​()
      只有在调用时没有被另一个线程占用才能获取写入锁。
      boolean tryLock​(long timeout, TimeUnit unit)
      如果在给定的等待时间内没有被另一个线程 占用并且当前线程尚未被 interrupted获取写入锁定。
      void unlock​()
      尝试释放此锁。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • WriteLock

        protected WriteLock​(ReentrantReadWriteLock lock)
        子类使用的构造方法。
        参数
        lock - 外锁对象
        异常
        NullPointerException - 如果锁为空

    • 方法详细信息

      • lock

        public void lock​()
        获取写锁。

        如果读锁定和写锁定都不被另一个线程保持并且立即返回，则将获取写锁定，将写锁定保持计数设置为1。

        如果当前线程已经保持写锁定，则保持计数增加1，该方法立即返回。

        如果锁被另一个线程保持，那么当前线程将被禁用以进行线程调度，并且处于休眠状态，直到获取写入锁定为止，此时写锁定保持计数设置为1。

        Specified by:
        lock在接口 Lock

      • lockInterruptibly

        public void lockInterruptibly​()
                       throws InterruptedException
        获取写锁定，除非当前线程为interrupted 。

        如果读锁定和写锁定都不被另一个线程保持并且立即返回，则将获取写锁定，将写锁定保持计数设置为1。

        如果当前线程已经保存此锁，则保持计数将递增1，该方法立即返回。

        如果锁被另一个线程保持，则当前线程将被禁用以进行线程调度，并且处于休眠状态，直到发生两件事情之一：

        • 写锁由当前线程获取; 要么
        • 一些其他线程interrupts当前线程。

        如果当前线程获取了写入锁定，则锁定保持计数被设置为1。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted同时获取写锁，
        然后抛出InterruptedException并清除当前线程的中断状态。

        在该实现中，由于该方法是明确的中断点，所以优先考虑通过锁定正常或可重入的采集来响应中断。

        Specified by:
        lockInterruptibly在接口 Lock
        异常
        InterruptedException - 当前线程是否中断

      • tryLock

        public boolean tryLock​()
        只有在调用时没有被另一个线程占用才能获取写入锁。

        如果读锁定和写锁定都不被另一个线程保持，并且立即返回值true ，将写锁定保持计数设置为1，则获取写入锁定。 即使该锁已设置为使用公平的订购策略，如果可用的话，呼叫tryLock() 将立即获取锁定，无论其他线程是否正在等待写锁定。 这种“趸船”行为在某些情况下是有用的，尽管它打破了公平。 如果要遵守该锁的公平性设置，则使用几乎相当的tryLock(0, TimeUnit.SECONDS) （也检测到中断）。

        如果当前线程已经保存该锁，则保持计数增加1，该方法返回true 。

        如果锁由另一个线程持有，则该方法将立即返回值为false 。

        Specified by:
        tryLock在接口 Lock
        结果
        true如果锁是空闲的并且被当前线程获取，或者写锁已经被当前线程保持; 而另外false 。

      • tryLock

        public boolean tryLock​(long timeout,
                       TimeUnit unit)
                throws InterruptedException
        如果在给定的等待时间内没有被另一个线程占用 ，并且当前线程尚未被interrupted采集写锁定。

        如果读锁定和写锁定都不被另一个线程保持并且立即返回值true ，将写锁定保持计数设置为1，则获取写入锁定。 如果此锁已设置为使用合理的排序策略，则如果其他任何线程正在等待写锁定， 则不会获取可用的锁。 这与tryLock()方法相反。 如果你想要一个定时的tryLock ，允许在公平的锁定驳船，那么将定时和不定时的形式结合在一起：

           if (lock.tryLock() || lock.tryLock(timeout, unit)) { ... }

        如果当前线程已经保存该锁，则保持计数增加1，该方法返回true 。

        如果锁被另一个线程保持，则当前线程将被禁用以进行线程调度，并且处于休眠状态，直至发生三件事情之一：

        • 写锁由当前线程获取; 要么
        • 一些其他线程当前线程interrupts ; 要么
        • 指定的等待时间过去了

        如果获取了写锁定，则返回值true ，并将写锁定保持计数设置为1。

        如果当前线程：

        • 在进入该方法时设置了中断状态; 要么
        • 是interrupted同时获取写锁，
        然后抛出InterruptedException并清除当前线程的中断状态。

        如果指定的等待时间过去，则返回值false 。 如果时间小于或等于零，该方法根本不会等待。

        在这种实现中，由于该方法是明确的中断点，所以优先考虑响应中断超过正常或可重入的锁的获取，并且报告等待时间的过去。

        Specified by:
        tryLock在接口 Lock
        参数
        timeout - 等待写锁的时间
        unit - 超时参数的时间单位
        结果
        true如果锁是空闲的并且被当前线程获取，或者写锁已经被当前线程保持; 和false如果在获得锁之前经过的等待时间。
        异常
        InterruptedException - 当前线程是否中断
        NullPointerException - 如果时间单位为空

      • unlock

        public void unlock​()
        尝试释放此锁。

        如果当前线程是该锁的持有者，则保持计数递减。 如果保持计数现在为零，则锁定被释放。 如果当前线程不是该锁的持有者，则抛出IllegalMonitorStateException 。

        Specified by:
        unlock在接口 Lock
        异常
        IllegalMonitorStateException - 如果当前线程不持有此锁

      • newCondition

        public Condition newCondition​()
        返回Condition与此使用实例Lock实例。

        返回Condition实例支持相同的用途为做Object种监视器方法（ wait ， notify ，并notifyAll与使用时）内置监视器锁定。

        • 如果在调用任何Condition方法时不保留此写锁定，则抛出IllegalMonitorStateException 。 （读取锁定与写入锁定无关，因此不会被检查或受到影响，但是当当前线程也获取了读锁定时，它本质上总是调用条件等待方法的错误，因为可以解除阻塞的其他线程不会能够获取写锁。）
        • 当条件waiting方法被调用时，写锁定被释放，在它们返回之前，重新获取写入锁定，并且锁定保持计数恢复为调用该方法时的值。
        • 如果一个线程是interrupted，而等待，那么等待将终止，一个InterruptedException将被抛出，线程的中断状态将被清除。
        • 等待线程以FIFO顺序发出信号。
        • 从等待方法返回的线程的锁重新获取的顺序与初始获取锁的线程相同，这在默认情况下未指定，但是对于公平的锁有利于那些等待最长的线程。
        Specified by:
        newCondition在接口 Lock
        结果
        Condition对象

      • toString

        public String toString​()
        返回一个标识此锁的字符串以及其锁定状态。 括号中的状态包括字符串"Unlocked"或字符串"Locked by"后跟所属线程的name 。
        重写：
        toString在 Object
        结果
        标识此锁的字符串以及其锁定状态

      • isHeldByCurrentThread

        public boolean isHeldByCurrentThread​()
        查询这个写锁是否由当前线程持有。 相同于ReentrantReadWriteLock.isWriteLockedByCurrentThread() 。
        结果
        true如果当前线程持有该锁，否则为 false
        从以下版本开始：
        1.6

      • getHoldCount

        public int getHoldCount​()
        查询当前线程对此写锁定的暂停数量。 一个线程对于与解锁动作不匹配的每个锁定动作都有一个锁定。 相同于ReentrantReadWriteLock.getWriteHoldCount() 。
        结果
        当前线程对此锁定的保持次数，如果此锁定不由当前线程保持，则为零
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StampedLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.concurrent.locks

Class StampedLock

  • java.lang.Object
    • java.util.concurrent.locks.StampedLock
  • All Implemented Interfaces:
    Serializable

    public class StampedLock
extends Object
implements Serializable
    一种基于能力的锁，具有三种模式用于控制读/写访问。 StampedLock的状态由版本和模式组成。 锁定采集方法返回一个表示和控制相对于锁定状态的访问的印记; 这些方法的“尝试”版本可能会返回特殊值为零以表示获取访问失败。 锁定释放和转换方法要求邮票作为参数，如果它们与锁的状态不匹配则失败。 这三种模式是：
    • 写作。 方法writeLock()可能阻止等待独占访问，返回可以在方法unlockWrite(long)中使用的印记来释放锁定。 还提供了tryWriteLock未定义和定时版本。 当锁保持写入模式时，不能获得读取锁定，并且所有乐观读取验证都将失败。
    • 读。 方法readLock()可能阻止等待非独占访问，返回可以在方法unlockRead(long)中使用的印记来释放锁。 还提供了tryReadLock未定义和定时版本。
    • 乐观阅读 方法tryOptimisticRead()只有当锁当前未保持在写入模式时才返回非零标记。 方法validate(long)如果在获取给定的印记之后尚未在写入模式中获取锁，则返回true。 这种模式可以被认为是一个非常弱的版本的读锁，可以随时由作家打破。 对简单的只读代码段使用乐观模式通常会减少争用并提高吞吐量。 然而，其使用本质上是脆弱的。 乐观阅读部分只能读取字段并将其保存在局部变量中，以供后验证使用。 以乐观模式读取的字段可能会非常不一致，因此只有在熟悉数据表示以检查一致性和/或重复调用方法validate()时，使用情况才适用。 例如，当首次读取对象或数组引用，然后访问其字段，元素或方法之一时，通常需要这样的步骤。

    此类还支持有条件地在三种模式下提供转换的方法。 例如，方法tryConvertToWriteLock(long)尝试“升级”模式，如果（1）已经在书写模式（2）处于读取模式并且没有其他读取器或（3）处于乐观模式并且锁可用的情况下返回有效写入戳记。 这些方法的形式旨在帮助减少在基于重试的设计中出现的一些代码膨胀。

    StampedLocks设计用作线程安全组件开发中的内部实用程序。 他们的使用依赖于他们保护的数据，对象和方法的内部属性的知识。 它们不是可重入的，所以锁定的机构不应该调用其他可能尝试重新获取锁的未知方法（尽管您可以将戳记传递给可以使用或转换它的其他方法）。 读锁定模式的使用依赖于相关的代码段是无副作用的。 未经验证的乐观阅读部分不能调用不知道容忍潜在不一致的方法。 邮票使用有限表示，并且不是加密安全的（即，有效的邮票可能是可猜测的）。 邮票值可以在连续运行一年（不早于）之后回收。 不超过此期限使用或验证的邮票可能无法正确验证。 StampedLocks是可序列化的，但总是反序列化为初始解锁状态，因此它们对于远程锁定无用。

    像Semaphore一样，但与大多数Lock实现不同，StampedLocks没有所有权概念。 在一个线程中获取的锁可以在另一个线程中释放或转换。

    StampedLock的调度策略不一致优先于读者，反之亦然。 所有“尝试”方法都是尽力而为，并不一定符合任何调度或公平政策。 用于获取或转换锁定的任何“try”方法的零返回不携带关于锁的状态的任何信息; 随后的调用可能会成功。

    因为它支持跨多种锁定模式的协调使用，所以该类不直接实现Lock或ReadWriteLock接口。 然而，StampedLock可以看作asReadLock() ， asWriteLock() ，或asReadWriteLock()中，仅需要在一组相关联的功能的应用程序。

    样品用法。 下面说明了一个维护简单二维点的类中的一些使用习语。 示例代码说明了一些try / catch约定，即使这些惯例在这里不是严格需要的，因为它们的身体中不会发生异常。

       class Point { private double x, y; private final StampedLock sl = new StampedLock(); void move(double deltaX, double deltaY) { // an exclusively locked method long stamp = sl.writeLock(); try { x += deltaX; y += deltaY; } finally { sl.unlockWrite(stamp); } } double distanceFromOrigin() { // A read-only method long stamp = sl.tryOptimisticRead(); double currentX = x, currentY = y; if (!sl.validate(stamp)) { stamp = sl.readLock(); try { currentX = x; currentY = y; } finally { sl.unlockRead(stamp); } } return Math.sqrt(currentX * currentX + currentY * currentY); } void moveIfAtOrigin(double newX, double newY) { // upgrade // Could instead start with optimistic, not read mode long stamp = sl.readLock(); try { while (x == 0.0 && y == 0.0) { long ws = sl.tryConvertToWriteLock(stamp); if (ws != 0L) { stamp = ws; x = newX; y = newY; break; } else { sl.unlockRead(stamp); stamp = sl.writeLock(); } } } finally { sl.unlock(stamp); } } }
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      StampedLock​()
      创建一个新的锁，最初处于未锁定状态。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Lock asReadLock​()
      返回此StampedLock的平面Lock视图，其中Lock.lock()方法映射到readLock() ，对于其他方法也是如此。
      ReadWriteLock asReadWriteLock​()
      返回此StampedLock的ReadWriteLock视图，其中ReadWriteLock.readLock()方法映射到asReadLock() ，而ReadWriteLock.writeLock()映射到asWriteLock() 。
      Lock asWriteLock​()
      返回此StampedLock的一个平面Lock视图，其中Lock.lock()方法映射到writeLock() ，其他方法类似。
      int getReadLockCount​()
      查询为此锁持有的读取锁的数量。
      boolean isReadLocked​()
      如果锁定当前非排他地，则返回 true 。
      boolean isWriteLocked​()
      返回 true如果锁目前是唯一的。
      long readLock​()
      不排他地获取锁定，如有必要，阻塞。
      long readLockInterruptibly​()
      非排他性地获取锁定，如有必要，阻塞，直到可用或当前线程中断。
      String toString​()
      返回一个标识此锁的字符串以及其锁定状态。
      long tryConvertToOptimisticRead​(long stamp)
      如果锁定状态与给定的印记相匹配，则原子地，如果印记表示持有锁定，则释放它并返回观察印记。
      long tryConvertToReadLock​(long stamp)
      如果锁定状态与给定的标记匹配，则原子地执行以下操作之一。
      long tryConvertToWriteLock​(long stamp)
      如果锁定状态与给定的标记匹配，则原子地执行以下操作之一。
      long tryOptimisticRead​()
      返回可以稍后验证的印记，如果专门锁定则返回零。
      long tryReadLock​()
      非专门获取锁，如果它立即可用。
      long tryReadLock​(long time, TimeUnit unit)
      如果在给定时间内可用，并且当前线程未被中断，则非排他性地获取锁。
      boolean tryUnlockRead​()
      释放读锁定的一个保持位，如果保持，而不需要戳记值。
      boolean tryUnlockWrite​()
      释放写入锁定，如果被保留，而不需要标记值。
      long tryWriteLock​()
      专门获取锁，如果它立即可用。
      long tryWriteLock​(long time, TimeUnit unit)
      如果在给定时间内可用，并且当前线程未被中断，则专门获取该锁。
      void unlock​(long stamp)
      如果锁定状态与给定的标记匹配，则释放相应的锁定模式。
      void unlockRead​(long stamp)
      如果锁定状态与给定的标记匹配，则释放非排他锁。
      void unlockWrite​(long stamp)
      如果锁定状态与给定的邮票相匹配，则释放排他锁。
      boolean validate​(long stamp)
      如果从发布给定邮票以来没有专门获取锁，则返回true。
      long writeLock​()
      专门获取锁定，如有必要，阻塞。
      long writeLockInterruptibly​()
      专门获取锁定，如有必要，阻塞，直到可用或当前线程中断。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StampedLock

        public StampedLock​()
        创建一个新的锁，最初处于未锁定状态。

    • 方法详细信息

      • writeLock

        public long writeLock​()
        专门获取锁定，如有必要，阻塞。
        结果
        可用于解锁或转换模式的写印章

      • tryWriteLock

        public long tryWriteLock​()
        专门获取锁，如果它立即可用。
        结果
        可用于解锁或转换模式的写入戳记，如果锁定不可用，则为零

      • tryWriteLock

        public long tryWriteLock​(long time,
                         TimeUnit unit)
                  throws InterruptedException
        如果在给定时间内可用，并且当前线程未被中断，则专门获取该锁。 超时和中断下的行为匹配方法Lock.tryLock(long,TimeUnit) 。
        参数
        time - 等待锁的最长时间
        unit - time参数的时间单位
        结果
        可用于解锁或转换模式的写入戳记，如果锁定不可用，则为零
        异常
        InterruptedException - 如果当前线程在获取锁定之前中断

      • writeLockInterruptibly

        public long writeLockInterruptibly​()
                            throws InterruptedException
        专门获取锁定，如有必要，阻塞，直到可用或当前线程中断。 中断行为符合方法Lock.lockInterruptibly()规定的行为 。
        结果
        可用于解锁或转换模式的写印章
        异常
        InterruptedException - 如果当前线程在获取锁定之前中断

      • readLock

        public long readLock​()
        不排他地获取锁定，如有必要，阻塞。
        结果
        一个可用于解锁或转换模式的读印

      • tryReadLock

        public long tryReadLock​()
        非专门获取锁，如果它立即可用。
        结果
        可用于解锁或转换模式的读取戳记，如果锁定不可用，则为零

      • tryReadLock

        public long tryReadLock​(long time,
                        TimeUnit unit)
                 throws InterruptedException
        如果在给定时间内可用，并且当前线程未被中断，则非排他性地获取锁。 超时和中断下的行为匹配方法Lock.tryLock(long,TimeUnit)指定。
        参数
        time - 等待锁的最长时间
        unit - time参数的时间单位
        结果
        可用于解锁或转换模式的读取戳记，如果锁定不可用，则为零
        异常
        InterruptedException - 如果当前线程在获取锁定之前中断

      • readLockInterruptibly

        public long readLockInterruptibly​()
                           throws InterruptedException
        非排他性地获取锁定，如有必要，阻塞，直到可用或当前线程中断。 中断行为符合方法Lock.lockInterruptibly()规定的行为 。
        结果
        一个可用于解锁或转换模式的读印
        异常
        InterruptedException - 如果当前线程在获取锁定之前中断

      • tryOptimisticRead

        public long tryOptimisticRead​()
        返回可以稍后验证的印记，如果专门锁定则返回零。
        结果
        有效的乐观阅读印记，如果专门锁定，则为零

      • validate

        public boolean validate​(long stamp)
        如果从发布给定邮票以来没有专门获取锁，则返回true。 如果邮票为零，则总是返回false。 如果邮票代表当前持有的锁，则始终返回true。 使用从tryOptimisticRead()获取的值或此锁定的锁定方法调用此方法没有定义的效果或结果。
        参数
        stamp - 邮票
        结果
        true如果锁从发行给定邮票以来没有被专门获取; 否则假

      • unlockWrite

        public void unlockWrite​(long stamp)
        如果锁定状态与给定的邮票相匹配，则释放排他锁。
        参数
        stamp - 由写锁定操作返回的邮票
        异常
        IllegalMonitorStateException - 如果邮票与此锁的当前状态不匹配

      • unlockRead

        public void unlockRead​(long stamp)
        如果锁定状态与给定的标记匹配，则释放非排他锁。
        参数
        stamp - 通过读锁操作返回的邮票
        异常
        IllegalMonitorStateException - 如果邮票与此锁的当前状态不匹配

      • unlock

        public void unlock​(long stamp)
        如果锁定状态与给定的标记匹配，则释放相应的锁定模式。
        参数
        stamp - 由锁定操作返回的邮票
        异常
        IllegalMonitorStateException - 如果邮票与此锁的当前状态不匹配

      • tryConvertToWriteLock

        public long tryConvertToWriteLock​(long stamp)
        如果锁定状态与给定的标记匹配，则原子地执行以下操作之一。 如果邮票表示持有写锁，则返回。 或者，如果读取锁定，如果写入锁定可用，则释放读取锁定并返回写入戳记。 或者，如果乐观读取，只有在立即可用时才返回写入戳。 在所有其他情况下，此方法返回零。
        参数
        stamp - 邮票
        结果
        有效写入戳记，或失败时为零

      • tryConvertToReadLock

        public long tryConvertToReadLock​(long stamp)
        如果锁定状态与给定的标记匹配，则原子地执行以下操作之一。 如果邮票表示持有写锁，则释放它并获取读锁。 或者，如果读锁，返回。 或者，如果乐观读取，只有在立即可用的情况下才能获取读取锁并返回读取戳。 在所有其他情况下，此方法返回零。
        参数
        stamp - 邮票
        结果
        有效的读取戳记，或失败时为零

      • tryConvertToOptimisticRead

        public long tryConvertToOptimisticRead​(long stamp)
        如果锁定状态与给定的印记相匹配，则原子地，如果印记表示持有锁定，则释放它并返回观察印记。 或者，如果乐观阅读，如果验证返回。 在所有其他情况下，此方法返回零，因此可能作为“tryUnlock”的形式有用。
        参数
        stamp - 邮票
        结果
        有效的乐观阅读印记，或失败时为零

      • tryUnlockWrite

        public boolean tryUnlockWrite​()
        释放写入锁定，如果被保留，而不需要标记值。 此方法可能对错误后的恢复有用。
        结果
        如果锁定是 true ，否则为false

      • tryUnlockRead

        public boolean tryUnlockRead​()
        释放读锁定的一个保持位，如果保持，而不需要戳记值。 此方法可能对错误后的恢复有用。
        结果
        true如果读取锁定，否则为false

      • isWriteLocked

        public boolean isWriteLocked​()
        如果锁当前仅被 true则返回 true 。
        结果
        true如果锁当前是唯一的

      • isReadLocked

        public boolean isReadLocked​()
        如果锁定当前非排他地，则返回 true 。
        结果
        true如果锁当前是非排他地

      • getReadLockCount

        public int getReadLockCount​()
        查询为此锁持有的读取锁的数量。 该方法设计用于监控系统状态，不用于同步控制。
        结果
        持有的读取锁的数量

      • toString

        public String toString​()
        返回一个标识此锁的字符串以及其锁定状态。 括号中的状态包括字符串"Unlocked"或字符串"Write-locked"或字符串"Read-locks:"后跟当前持有的读锁定数。
        重写：
        toString在 Object
        结果
        标识此锁的字符串以及其锁定状态

      • asReadLock

        public Lock asReadLock​()
        返回此StampedLock的Lock视图，其中Lock.lock()方法映射到readLock() ，其他方法类似。
返回的Lock不支持Condition ;
方法Lock.newCondition()抛出UnsupportedOperationException 。
        结果
        锁

      • asWriteLock

        public Lock asWriteLock​()
        返回此StampedLock的一个简单的Lock视图，其中Lock.lock()方法映射到writeLock() ，并且类似于其他方法。
返回的Lock不支持Condition ;
方法Lock.newCondition()抛出UnsupportedOperationException 。
        结果
        锁

      • asReadWriteLock

        public ReadWriteLock asReadWriteLock​()
        返回一个ReadWriteLock视图此StampedLock的其中ReadWriteLock.readLock()方法被映射到asReadLock() ，和ReadWriteLock.writeLock()到asWriteLock() 。
        结果
        the lock
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util.concurrent.locks (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.concurrent.locks

  • Packages that use java.util.concurrent.locks
    软件包 描述
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
  • Classes in java.util.concurrent.locks used by java.util.concurrent.locks
    Class 描述
    AbstractOwnableSynchronizer
    可以由线程专有的同步器。
    AbstractQueuedLongSynchronizer.ConditionObject
    AbstractQueuedLongSynchronizer的条件实现作为Lock实现的基础。
    AbstractQueuedSynchronizer.ConditionObject
    条件实施AbstractQueuedSynchronizer作为Lock实施的基础。
    Condition
    Condition因素出Object监视器方法（ wait ， notify和notifyAll ）成不同的对象，以得到具有多个等待集的每个对象，通过将它们与使用任意的组合的效果Lock个实现。
    Lock
    Lock实现提供比使用 synchronized方法和语句可以获得的更广泛的锁定操作。
    ReadWriteLock
    A ReadWriteLock维护一对关联的locks ，一个用于只读操作，一个用于写入。
    ReentrantReadWriteLock
    支持ReadWriteLock的类似语义ReentrantLock的实现 。
    ReentrantReadWriteLock.ReadLock
    该锁由方法 ReentrantReadWriteLock.readLock()返回。
    ReentrantReadWriteLock.WriteLock
    方法 ReentrantReadWriteLock.writeLock()返回的锁。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.AbstractOwnableSynchronizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.AbstractOwnableSynchronizer

  • Packages that use AbstractOwnableSynchronizer
    软件包 描述
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。

    • Uses of AbstractOwnableSynchronizer in java.util.concurrent.locks

      Subclasses of AbstractOwnableSynchronizer in java.util.concurrent.locks
      Modifier and Type Class 描述
      class  AbstractQueuedLongSynchronizer
      的一个版本AbstractQueuedSynchronizer ，其中同步状态保持为long 。
      class  AbstractQueuedSynchronizer
      提供一个框架，用于实现依赖先进先出（FIFO）等待队列的阻塞锁和相关同步器（信号量，事件等）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.AbstractQueuedLongSynchronizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.AbstractQueuedLongSynchronizer

No usage of java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject

  • Packages that use AbstractQueuedLongSynchronizer.ConditionObject
    软件包 描述
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。

    • Uses of AbstractQueuedLongSynchronizer.ConditionObject in java.util.concurrent.locks

      Methods in java.util.concurrent.locks with parameters of type AbstractQueuedLongSynchronizer.ConditionObject
      Modifier and Type 方法 描述
      Collection<Thread> AbstractQueuedLongSynchronizer.getWaitingThreads​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。
      int AbstractQueuedLongSynchronizer.getWaitQueueLength​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      返回等待与此同步器相关联的给定条件的线程数量的估计。
      boolean AbstractQueuedLongSynchronizer.hasWaiters​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      查询任何线程是否等待与此同步器相关联的给定条件。
      boolean AbstractQueuedLongSynchronizer.owns​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      查询给定的ConditionObject是否将此同步器用作其锁。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.AbstractQueuedSynchronizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.AbstractQueuedSynchronizer

No usage of java.util.concurrent.locks.AbstractQueuedSynchronizer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject

  • Packages that use AbstractQueuedSynchronizer.ConditionObject
    软件包 描述
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。

    • Uses of AbstractQueuedSynchronizer.ConditionObject in java.util.concurrent.locks

      Methods in java.util.concurrent.locks with parameters of type AbstractQueuedSynchronizer.ConditionObject
      Modifier and Type 方法 描述
      Collection<Thread> AbstractQueuedSynchronizer.getWaitingThreads​(AbstractQueuedSynchronizer.ConditionObject condition)
      返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。
      int AbstractQueuedSynchronizer.getWaitQueueLength​(AbstractQueuedSynchronizer.ConditionObject condition)
      返回等待与此同步器相关联的给定条件的线程数量的估计。
      boolean AbstractQueuedSynchronizer.hasWaiters​(AbstractQueuedSynchronizer.ConditionObject condition)
      查询任何线程是否等待与此同步器相关联的给定条件。
      boolean AbstractQueuedSynchronizer.owns​(AbstractQueuedSynchronizer.ConditionObject condition)
      查询给定的ConditionObject是否将此同步器用作其锁。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.LockSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.LockSupport

No usage of java.util.concurrent.locks.LockSupport
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.ReentrantLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.ReentrantLock

No usage of java.util.concurrent.locks.ReentrantLock
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.ReentrantReadWriteLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.ReentrantReadWriteLock

  • Packages that use ReentrantReadWriteLock
    软件包 描述
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。

    • Uses of ReentrantReadWriteLock in java.util.concurrent.locks

      Constructors in java.util.concurrent.locks with parameters of type ReentrantReadWriteLock
      Constructor 描述
      ReadLock​(ReentrantReadWriteLock lock)
      子类使用的构造方法。
      WriteLock​(ReentrantReadWriteLock lock)
      子类使用的构造方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock

  • Packages that use ReentrantReadWriteLock.ReadLock
    软件包 描述
    java.util.concurrent.locks
    Interfaces and classes providing a framework for locking and waiting for conditions that is distinct from built-in synchronization and monitors.

    • Uses of ReentrantReadWriteLock.ReadLock in java.util.concurrent.locks

      Methods in java.util.concurrent.locks that return ReentrantReadWriteLock.ReadLock
      Modifier and Type | 方法 | 描述
      ReentrantReadWriteLock.ReadLock | ReentrantReadWriteLock.readLock​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock

  • Packages that use ReentrantReadWriteLock.WriteLock
    软件包 描述
    java.util.concurrent.locks
    Interfaces and classes providing a framework for locking and waiting for conditions that is distinct from built-in synchronization and monitors.

    • Uses of ReentrantReadWriteLock.WriteLock in java.util.concurrent.locks

      Methods in java.util.concurrent.locks that return ReentrantReadWriteLock.WriteLock
      Modifier and Type | 方法 | 描述
      ReentrantReadWriteLock.WriteLock | ReentrantReadWriteLock.writeLock​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.concurrent.locks.StampedLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.concurrent.locks.StampedLock

No usage of java.util.concurrent.locks.StampedLock
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.locks.Condition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.locks.Condition

  • Packages that use Condition
    软件包 描述
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。

    • Uses of Condition in java.util.concurrent.locks

      Classes in java.util.concurrent.locks that implement Condition
      Modifier and Type Class 描述
      class  AbstractQueuedLongSynchronizer.ConditionObject
      AbstractQueuedLongSynchronizer的条件实现作为Lock实现的基础。
      class  AbstractQueuedSynchronizer.ConditionObject
      AbstractQueuedSynchronizer的条件实施作为Lock实施的基础。
      Methods in java.util.concurrent.locks that return Condition
      Modifier and Type 方法 描述
      Condition Lock.newCondition​()
      返回一个新Condition绑定到该实例Lock实例。
      Condition ReentrantLock.newCondition​()
      返回Condition与此使用实例Lock实例。
      Condition ReentrantReadWriteLock.ReadLock.newCondition​()
      抛出 UnsupportedOperationException因为 ReadLocks不支持条件。
      Condition ReentrantReadWriteLock.WriteLock.newCondition​()
      返回Condition与此使用实例Lock实例。
      Methods in java.util.concurrent.locks with parameters of type Condition
      Modifier and Type 方法 描述
      protected Collection<Thread> ReentrantLock.getWaitingThreads​(Condition condition)
      返回包含可能在与此锁相关联的给定条件下等待的线程的集合。
      protected Collection<Thread> ReentrantReadWriteLock.getWaitingThreads​(Condition condition)
      返回包含可能在与写锁相关联的给定条件下等待的线程的集合。
      int ReentrantLock.getWaitQueueLength​(Condition condition)
      返回与此锁相关联的给定条件等待的线程数的估计。
      int ReentrantReadWriteLock.getWaitQueueLength​(Condition condition)
      返回与写入锁相关联的给定条件等待的线程数的估计。
      boolean ReentrantLock.hasWaiters​(Condition condition)
      查询任何线程是否等待与此锁相关联的给定条件。
      boolean ReentrantReadWriteLock.hasWaiters​(Condition condition)
      Queries whether any threads are waiting on the given condition associated with the write lock.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.locks.Lock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.locks.Lock

  • Packages that use Lock
    软件包 描述
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。

    • Uses of Lock in java.util.concurrent.locks

      Classes in java.util.concurrent.locks that implement Lock
      Modifier and Type Class 描述
      class  ReentrantLock
      一个可重入的互斥Lock具有与使用synchronized方法和语句访问的隐式监视锁相同的基本行为和语义，但具有扩展功能。
      static class  ReentrantReadWriteLock.ReadLock
      该锁由方法 ReentrantReadWriteLock.readLock()返回。
      static class  ReentrantReadWriteLock.WriteLock
      方法 ReentrantReadWriteLock.writeLock()返回的锁。
      Methods in java.util.concurrent.locks that return Lock
      Modifier and Type 方法 描述
      Lock StampedLock.asReadLock​()
      返回此StampedLock的一个平面Lock视图，其中lock()方法映射到StampedLock.readLock() ，其他方法类似。
      Lock StampedLock.asWriteLock​()
      返回此StampedLock的一个普通的Lock视图，其中lock()方法映射到StampedLock.writeLock() ，其他方法类似。
      Lock ReadWriteLock.readLock​()
      返回用于阅读的锁。
      Lock ReadWriteLock.writeLock​()
      返回用于写入的锁。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.concurrent.locks.ReadWriteLock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.concurrent.locks.ReadWriteLock

  • Packages that use ReadWriteLock
    软件包 描述
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。

    • Uses of ReadWriteLock in java.util.concurrent.locks

      Classes in java.util.concurrent.locks that implement ReadWriteLock
      Modifier and Type Class 描述
      class  ReentrantReadWriteLock
      ReadWriteLock的支持类似语义的实现为ReentrantLock 。
      Methods in java.util.concurrent.locks that return ReadWriteLock
      Modifier and Type 方法 描述
      ReadWriteLock StampedLock.asReadWriteLock​()
      返回一个ReadWriteLock视图此StampedLock的其中readLock()方法被映射到StampedLock.asReadLock() ，和writeLock()到StampedLock.asWriteLock() 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Collections Framework Overview

Introduction

The Java platform includes a collections framework. A collection is an object that represents a group of objects (such as the classic ArrayList class). A collections framework is a unified architecture for representing and manipulating collections, enabling collections to be manipulated independently of implementation details.

The primary advantages of a collections framework are that it:

  • Reduces programming effort by providing data structures and algorithms so you don't have to write them yourself.
  • Increases performance by providing high-performance implementations of data structures and algorithms. Because the various implementations of each interface are interchangeable, programs can be tuned by switching implementations.
  • Provides interoperability between unrelated APIs by establishing a common language to pass collections back and forth.
  • Reduces the effort required to learn APIs by requiring you to learn multiple ad hoc collection APIs.
  • Reduces the effort required to design and implement APIs by not requiring you to produce ad hoc collections APIs.
  • Fosters software reuse by providing a standard interface for collections and algorithms with which to manipulate them.

The collections framework consists of:

  • Collection interfaces. Represent different types of collections, such as sets, lists, and maps. These interfaces form the basis of the framework.
  • General-purpose implementations. Primary implementations of the collection interfaces.
  • Legacy implementations. The collection classes from earlier releases, Vector and Hashtable, were retrofitted to implement the collection interfaces.
  • Special-purpose implementations. Implementations designed for use in special situations. These implementations display nonstandard performance characteristics, usage restrictions, or behavior.
  • Concurrent implementations. Implementations designed for highly concurrent use.
  • Wrapper implementations. Add functionality, such as synchronization, to other implementations.
  • Convenience implementations. High-performance "mini-implementations" of the collection interfaces.
  • Abstract implementations. Partial implementations of the collection interfaces to facilitate custom implementations.
  • Algorithms. Static methods that perform useful functions on collections, such as sorting a list.
  • Infrastructure. Interfaces that provide essential support for the collection interfaces.
  • Array Utilities. Utility functions for arrays of primitive types and reference objects. Not, strictly speaking, a part of the collections framework, this feature was added to the Java platform at the same time as the collections framework and relies on some of the same infrastructure.

Collection Interfaces

The collection interfaces are divided into two groups. The most basic interface, java.util.Collection, has the following descendants:

  • java.util.Set
  • java.util.SortedSet
  • java.util.NavigableSet
  • java.util.Queue
  • java.util.concurrent.BlockingQueue
  • java.util.concurrent.TransferQueue
  • java.util.Deque
  • java.util.concurrent.BlockingDeque

The other collection interfaces are based on java.util.Map and are not true collections. However, these interfaces contain collection-view operations, which enable them to be manipulated as collections. Map has the following offspring:

  • java.util.SortedMap
  • java.util.NavigableMap
  • java.util.concurrent.ConcurrentMap
  • java.util.concurrent.ConcurrentNavigableMap

Many of the modification methods in the collection interfaces are labeled optional. Implementations are permitted to not perform one or more of these operations, throwing a runtime exception (UnsupportedOperationException) if they are attempted. The documentation for each implementation must specify which optional operations are supported. Several terms are introduced to aid in this specification:

  • Collections that do not support modification operations (such as add, remove and clear) are referred to as unmodifiable. Collections that are not unmodifiable are modifiable.
  • Collections that additionally guarantee that no change in the Collection object will be visible are referred to as immutable. Collections that are not immutable are mutable.
  • Lists that guarantee that their size remains constant even though the elements can change are referred to as fixed-size. Lists that are not fixed-size are referred to as variable-size.
  • Lists that support fast (generally constant time) indexed element access are known as random access lists. Lists that do not support fast indexed element access are known as sequential access lists. The RandomAccess marker interface enables lists to advertise the fact that they support random access. This enables generic algorithms to change their behavior to provide good performance when applied to either random or sequential access lists.

Some implementations restrict what elements (or in the case of Maps, keys and values) can be stored. Possible restrictions include requiring elements to:

  • Be of a particular type.
  • Be not null.
  • Obey some arbitrary predicate.

Attempting to add an element that violates an implementation's restrictions results in a runtime exception, typically a ClassCastException, an IllegalArgumentException, or a NullPointerException. Attempting to remove or test for the presence of an element that violates an implementation's restrictions can result in an exception. Some restricted collections permit this usage.

Collection Implementations

Classes that implement the collection interfaces typically have names in the form of <Implementation-style><接口>. The general purpose implementations are summarized in the following table:

接口 | Hash Table | Resizable Array | Balanced Tree | Linked List | Hash Table + Linked List
Set | HashSet |  | TreeSet |  | LinkedHashSet
List |  | ArrayList |  | LinkedList |
Deque |  | ArrayDeque |  | LinkedList |
Map | HashMap |  | TreeMap |  | LinkedHashMap

The general-purpose implementations support all of the optional operations in the collection interfaces and have no restrictions on the elements they may contain. They are unsynchronized, but the Collections class contains static factories called synchronization wrappers that can be used to add synchronization to many unsynchronized collections. All of the new implementations have fail-fast iterators, which detect invalid concurrent modification, and fail quickly and cleanly (rather than behaving erratically).

The AbstractCollection, AbstractSet, AbstractList, AbstractSequentialList and AbstractMap classes provide basic implementations of the core collection interfaces, to minimize the effort required to implement them. The API documentation for these classes describes precisely how each method is implemented so the implementer knows which methods must be overridden, given the performance of the basic operations of a specific implementation.

Concurrent Collections

Applications that use collections from more than one thread must be carefully programmed. In general, this is known as concurrent programming. The Java platform includes extensive support for concurrent programming. See Java Concurrency Utilities for details.

Collections are so frequently used that various concurrent friendly interfaces and implementations of collections are included in the APIs. These types go beyond the synchronization wrappers discussed previously to provide features that are frequently needed in concurrent programming.

These concurrent-aware interfaces are available:

  • BlockingQueue
  • TransferQueue
  • BlockingDeque
  • ConcurrentMap
  • ConcurrentNavigableMap

The following concurrent-aware implementation classes are available. See the API documentation for the correct usage of these implementations.

  • LinkedBlockingQueue
  • ArrayBlockingQueue
  • PriorityBlockingQueue
  • DelayQueue
  • SynchronousQueue
  • LinkedBlockingDeque
  • LinkedTransferQueue
  • CopyOnWriteArrayList
  • CopyOnWriteArraySet
  • ConcurrentSkipListSet
  • ConcurrentHashMap
  • ConcurrentSkipListMap

Design Goals

The main design goal was to produce an API that was small in size and, more importantly, in "conceptual weight." It was critical that the new functionality not seem too different to current Java programmers; it had to augment current facilities, rather than replace them. At the same time, the new API had to be powerful enough to provide all the advantages described previously.

To keep the number of core interfaces small, the interfaces do not attempt to capture such subtle distinctions as mutability, modifiability, and resizability. Instead, certain calls in the core interfaces are optional, enabling implementations to throw an UnsupportedOperationException to indicate that they do not support a specified optional operation. Collection implementers must clearly document which optional operations are supported by an implementation.

To keep the number of methods in each core interface small, an interface contains a method only if either:

  • It is a truly fundamental operation: a basic operations in terms of which others could be reasonably defined,
  • There is a compelling performance reason why an important implementation would want to override it.

It was critical that all reasonable representations of collections interoperate well. This included arrays, which cannot be made to implement the Collection interface directly without changing the language. Thus, the framework includes methods to enable collections to be moved into arrays, arrays to be viewed as collections, and maps to be viewed as collections.

Copyright © 1998, 2017, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Java Collections API Design FAQ

This document answers frequently asked questions concerning the design of the Java collections framework. It is derived from the large volume of traffic on the collections-comments alias. It serves as a design rationale for the collections framework.

Core Interfaces - General Questions

  1. Why don't you support immutability directly in the core collection interfaces so that you can do away with optional operations (and UnsupportedOperationException)?
  2. Won't programmers have to surround any code that calls optional operations with a try-catch clause in case they throw an UnsupportedOperationException?
  3. Why isn't there a core interface for "bags" (AKA multisets)?
  4. Why didn't you use "Beans-style names" for consistency?

Collection Interface

  1. Why doesn't Collection extend Cloneable and Serializable?
  2. Why don't you provide an "apply" method in Collection to apply a given method ("upcall") to all the elements of the Collection?
  3. Why didn't you provide a "Predicate" interface, and related methods (e.g., a method to find the first element in the Collection satisfying the predicate)?
  4. Why don't you provide a form of the addAll method that takes an Enumeration (or an Iterator)?
  5. Why don't the concrete implementations in the JDK have Enumeration (or Iterator) constructors?
  6. Why don't you provide an Iterator.add method?

List Interface

  1. Why don't you rename the List interface to Sequence; doesn't "list" generally suggest "linked list"? Also, doesn't it conflict with java.awt.List?
  2. Why don't you rename List's set method to replace, to avoid confusion with Set.

Map Interface

  1. Why doesn't Map extend Collection?

Iterator Interface

  1. Why doesn't Iterator extend Enumeration?
  2. Why don't you provide an Iterator.peek method that allows you to look at the next element in an iteration without advancing the iterator?

Miscellaneous

  1. Why did you write a new collections framework instead of adopting JGL (a preexisting collections package from ObjectSpace, Inc.) into the JDK?
  2. Why don't you eliminate all of the methods and classes that return "views" (Collections backed by other collection-like objects). This would greatly reduce aliasing.
  3. Why don't you provide for "observable" collections that send out Events when they're modified?

Core Interfaces - General Questions

  1. Why don't you support immutability directly in the core collection interfaces so that you can do away with optional operations (and UnsupportedOperationException)?

    This is the most controversial design decision in the whole API. Clearly, static (compile time) type checking is highly desirable, and is the norm in Java. We would have supported it if we believed it were feasible. Unfortunately, attempts to achieve this goal cause an explosion in the size of the interface hierarchy, and do not succeed in eliminating the need for runtime exceptions (though they reduce it substantially).

    Doug Lea, who wrote a popular Java collections package that did reflect mutability distinctions in its interface hierarchy, no longer believes it is a viable approach, based on user experience with his collections package. In his words (from personal correspondence) "Much as it pains me to say it, strong static typing does not work for collection interfaces in Java."

    To illustrate the problem in gory detail, suppose you want to add the notion of modifiability to the Hierarchy. You need four new interfaces: ModifiableCollection, ModifiableSet, ModifiableList, and ModifiableMap. What was previously a simple hierarchy is now a messy heterarchy. Also, you need a new Iterator interface for use with unmodifiable Collections, that does not contain the remove operation. Now can you do away with UnsupportedOperationException? Unfortunately not.

    Consider arrays. They implement most of the List operations, but not remove and add. They are "fixed-size" Lists. If you want to capture this notion in the hierarchy, you have to add two new interfaces: VariableSizeList and VariableSizeMap. You don't have to add VariableSizeCollection and VariableSizeSet, because they'd be identical to ModifiableCollection and ModifiableSet, but you might choose to add them anyway for consistency's sake. Also, you need a new variety of ListIterator that doesn't support the add and remove operations, to go along with unmodifiable List. Now we're up to ten or twelve interfaces, plus two new Iterator interfaces, instead of our original four. Are we done? No.

    Consider logs (such as error logs, audit logs and journals for recoverable data objects). They are natural append-only sequences, that support all of the List operations except for remove and set (replace). They require a new core interface, and a new iterator.

    And what about immutable Collections, as opposed to unmodifiable ones? (i.e., Collections that cannot be changed by the client AND will never change for any other reason). Many argue that this is the most important distinction of all, because it allows multiple threads to access a collection concurrently without the need for synchronization. Adding this support to the type hierarchy requires four more interfaces.

    Now we're up to twenty or so interfaces and five iterators, and it's almost certain that there are still collections arising in practice that don't fit cleanly into any of the interfaces. For example, the collection-views returned by Map are natural delete-only collections. Also, there are collections that will reject certain elements on the basis of their value, so we still haven't done away with runtime exceptions.

    When all was said and done, we felt that it was a sound engineering compromise to sidestep the whole issue by providing a very small set of core interfaces that can throw a runtime exception.

  2. Won't programmers have to surround any code that calls optional operations with a try-catch clause in case they throw an UnsupportedOperationException?

    It was never our intention that programs should catch these exceptions: that's why they're unchecked (runtime) exceptions. They should only arise as a result of programming errors, in which case, your program will halt due to the uncaught exception.

  3. Why isn't there a core interface for "bags" (AKA multisets)?

    The Collection interface provides this functionality. We are not providing any public implementations of this interface, as we think that it wouldn't be used frequently enough to "pull its weight." We occasionally return such Collections, which are implemented easily atop AbstractCollection (for example, the Collection returned by Map.values).

  4. Why didn't you use "Beans-style names" for consistency?

    While the names of the new collections methods do not adhere to the "Beans naming conventions", we believe that they are reasonable, consistent and appropriate to their purpose. It should be remembered that the Beans naming conventions do not apply to the JDK as a whole; the AWT did adopt these conventions, but that decision was somewhat controversial. We suspect that the collections APIs will be used quite pervasively, often with multiple method calls on a single line of code, so it is important that the names be short. Consider, for example, the Iterator methods. Currently, a loop over a collection looks like this:

        for (Iterator i = c.iterator(); i.hasNext(); )
        System.out.println(i.next());
    Everything fits neatly on one line, even if the Collection name is a long expression. If we named the methods "getIterator", "hasNextElement" and "getNextElement", this would no longer be the case. Thus, we adopted the "traditional" JDK style rather than the Beans style.

Collection Interface

  1. Why doesn't Collection extend Cloneable and Serializable?

    Many Collection implementations (including all of the ones provided by the JDK) will have a public clone method, but it would be mistake to require it of all Collections. For example, what does it mean to clone a Collection that's backed by a terabyte SQL database? Should the method call cause the company to requisition a new disk farm? Similar arguments hold for serializable.

    If the client doesn't know the actual type of a Collection, it's much more flexible and less error prone to have the client decide what type of Collection is desired, create an empty Collection of this type, and use the addAll method to copy the elements of the original collection into the new one.

  2. Why don't you provide an "apply" method in Collection to apply a given method ("upcall") to all the elements of the Collection?

    This is what is referred to as an "Internal Iterator" in the "Design Patterns" book (Gamma et al.). We considered providing it, but decided not to as it seems somewhat redundant to support internal and external iterators, and Java already has a precedent for external iterators (with Enumerations). The "throw weight" of this functionality is increased by the fact that it requires a public interface to describe upcalls.

  3. Why didn't you provide a "Predicate" interface, and related methods (e.g., a method to find the first element in the Collection satisfying the predicate)?

    It's easy to implement this functionality atop Iterators, and the resulting code may actually look cleaner as the user can inline the predicate. Thus, it's not clear whether this facility pulls its weight. It could be added to the Collections class at a later date (implemented atop Iterator), if it's deemed useful.

  4. Why don't you provide a form of the addAll method that takes an Enumeration (or an Iterator)?

    Because we don't believe in using Enumerations (or Iterators) as "poor man's collections." This was occasionally done in prior releases, but now that we have the Collection interface, it is the preferred way to pass around abstract collections of objects.

  5. Why don't the concrete implementations in the JDK have Enumeration (or Iterator) constructors?

    Again, this is an instance of an Enumeration serving as a "poor man's collection" and we're trying to discourage that. Note however, that we strongly suggest that all concrete implementations should have constructors that take a Collection (and create a new Collection with the same elements).

  6. Why don't you provide an Iterator.add method?

    The semantics are unclear, given that the contract for Iterator makes no guarantees about the order of iteration. Note, however, that ListIterator does provide an add operation, as it does guarantee the order of the iteration.

List Interface

  1. Why don't you rename the List interface to Sequence; doesn't "list" generally suggest "linked list"? Also, doesn't it conflict with java.awt.List?

    People were evenly divided as to whether List suggests linked lists. Given the implementation naming convention, <Implementation><接口>, there was a strong desire to keep the core interface names short. Also, several existing names (AbstractSequentialList, LinkedList) would have been decidedly worse if we changed List to Sequence. The naming conflict can be dealt with by the following incantation:

        import java.util.*;
    import java.awt.*;
    import java.util.List;   // Dictates interpretation of "List"
  2. Why don't you rename List's set method to replace, to avoid confusion with Set.

    It was decided that the "set/get" naming convention was strongly enough enshrined in the language that we'd stick with it.

Map Interface

  1. Why doesn't Map extend Collection?

    This was by design. We feel that mappings are not collections and collections are not mappings. Thus, it makes little sense for Map to extend the Collection interface (or vice versa).

    If a Map is a Collection, what are the elements? The only reasonable answer is "Key-value pairs", but this provides a very limited (and not particularly useful) Map abstraction. You can't ask what value a given key maps to, nor can you delete the entry for a given key without knowing what value it maps to.

    Collection could be made to extend Map, but this raises the question: what are the keys? There's no really satisfactory answer, and forcing one leads to an unnatural interface.

    Maps can be viewed as Collections (of keys, values, or pairs), and this fact is reflected in the three "Collection view operations" on Maps (keySet, entrySet, and values). While it is, in principle, possible to view a List as a Map mapping indices to elements, this has the nasty property that deleting an element from the List changes the Key associated with every element before the deleted element. That's why we don't have a map view operation on Lists.

Iterator Interface

  1. Why doesn't Iterator extend Enumeration?

    We view the method names for Enumeration as unfortunate. They're very long, and very frequently used. Given that we were adding a method and creating a whole new framework, we felt that it would be foolish not to take advantage of the opportunity to improve the names. Of course we could support the new and old names in Iterator, but it doesn't seem worthwhile.

  2. Why don't you provide an Iterator.peek method that allows you to look at the next element in an iteration without advancing the iterator?

    It can be implemented atop the current Iterators (a similar pattern to java.io.PushbackInputStream). We believe that its use would be rare enough that it isn't worth including in the interface that everyone has to implement.

Miscellaneous

  1. Why did you write a new collections framework instead of adopting JGL (a preexisting collections package from ObjectSpace, Inc.) into the JDK?

    If you examine the goals for our Collections framework (in the Overview), you'll see that we are not really "playing in the same space" as JGL. Quoting from the "Design Goals" Section of the Java Collections Overview: "Our main design goal was to produce an API that was reasonably small, both in size, and (more importantly) in 'conceptual weight.'"

    JGL consists of approximately 130 classes and interfaces; its main goal was consistency with the C++ Standard Template Library (STL). This was not one of our goals. Java has traditionally stayed away from C++'s more complex features (e.g., multiple inheritance, operator overloading). Our entire framework, including all infrastructure, contains approximately 25 classes and interfaces.

    While this may cause some discomfort for some C++ programmers, we feel that it will be good for Java in the long run. As the Java libraries mature, they inevitably grow, but we are trying as hard as we can to keep them small and manageable, so that Java continues to be an easy, fun language to learn and to use.

  2. Why don't you eliminate all of the methods and classes that return "views" (Collections backed by other collection-like objects). This would greatly reduce aliasing.

    Given that we provide core collection interfaces behind which programmers can "hide" their own implementations, there will be aliased collections whether the JDK provides them or not. Eliminating all views from the JDK would greatly increase the cost of common operations like making a Collection out of an array, and would do away with many useful facilities (like synchronizing wrappers). One view that we see as being particularly useful is List.subList. The existence of this method means that people who write methods taking List on input do not have to write secondary forms taking an offset and a length (as they do for arrays).

  3. Why don't you provide for "observable" collections that send out Events when they're modified?

    Primarily, resource constraints. If we're going to commit to such an API, it has to be something that works for everyone, that we can live with for the long haul. We may provide such a facility some day. In the meantime, it's not difficult to implement such a facility on top of the public APIs.

Copyright © 1998, 2017, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Outline of the Collections Framework

The collections framework consists of:
  • Collection interfaces - The primary means by which collections are manipulated.
    • Collection - A group of objects. No assumptions are made about the order of the collection (if any) or whether it can contain duplicate elements.
    • Set - The familiar set abstraction. No duplicate elements permitted. May or may not be ordered. Extends the Collection interface.
    • List - Ordered collection, also known as a sequence. Duplicates are generally permitted. Allows positional access. Extends the Collection interface.
    • Queue - A collection designed for holding elements before processing. Besides basic Collection operations, queues provide additional insertion, extraction, and inspection operations.
    • Deque - A double ended queue, supporting element insertion and removal at both ends. Extends the Queue interface.
    • Map - A mapping from keys to values. Each key can map to one value.
    • SortedSet - A set whose elements are automatically sorted, either in their natural ordering (see the Comparable interface) or by a Comparator object provided when a SortedSet instance is created. Extends the Set interface.
    • SortedMap - A map whose mappings are automatically sorted by key, either using the natural ordering of the keys or by a comparator provided when a SortedMap instance is created. Extends the Map interface.
    • NavigableSet - A SortedSet extended with navigation methods reporting closest matches for given search targets. A NavigableSet may be accessed and traversed in either ascending or descending order.
    • NavigableMap - A SortedMap extended with navigation methods returning the closest matches for given search targets. A NavigableMap can be accessed and traversed in either ascending or descending key order.
    • BlockingQueue - A Queue with operations that wait for the queue to become nonempty when retrieving an element and that wait for space to become available in the queue when storing an element. (This interface is part of the java.util.concurrent package.)
    • TransferQueue - A BlockingQueue in which producers can wait for consumers to receive elements. (This interface is part of the java.util.concurrent package.)
    • BlockingDeque - A Deque with operations that wait for the deque to become nonempty when retrieving an element and wait for space to become available in the deque when storing an element. Extends both the Deque and BlockingQueue interfaces. (This interface is part of the java.util.concurrent package.)
    • ConcurrentMap - A Map with atomic putIfAbsent, remove, and replace methods. (This interface is part of the java.util.concurrent package.)
    • ConcurrentNavigableMap - A ConcurrentMap that is also a NavigableMap.
  • General-purpose implementations - The primary implementations of the collection interfaces.
    • HashSet - Hash table implementation of the Set interface. The best all-around implementation of the Set interface.
    • TreeSet - Red-black tree implementation of the NavigableSet interface.
    • LinkedHashSet - Hash table and linked list implementation of the Set interface. An insertion-ordered Set implementation that runs nearly as fast as HashSet.
    • ArrayList - Resizable array implementation of the List interface (an unsynchronized Vector). The best all-around implementation of the List interface.
    • ArrayDeque - Efficient, resizable array implementation of the Deque interface.
    • LinkedList - Doubly-linked list implementation of the List interface. Provides better performance than the ArrayList implementation if elements are frequently inserted or deleted within the list. Also implements the Deque interface. When accessed through the Queue interface, LinkedList acts as a FIFO queue.
    • PriorityQueue - Heap implementation of an unbounded priority queue.
    • HashMap - Hash table implementation of the Map interface (an unsynchronized Hashtable that supports null keys and values). The best all-around implementation of the Map interface.
    • TreeMap Red-black tree implementation of the NavigableMap interface.
    • LinkedHashMap - Hash table and linked list implementation of the Map interface. An insertion-ordered Map implementation that runs nearly as fast as HashMap. Also useful for building caches (see removeEldestEntry(Map.Entry) ).
  • Wrapper implementations - Functionality-enhancing implementations for use with other implementations. Accessed solely through static factory methods.
    • Collections.unmodifiable接口 - Returns an unmodifiable view of a specified collection that throws an UnsupportedOperationException if the user attempts to modify it.
    • Collections.synchronized接口 - Returns a synchronized collection that is backed by the specified (typically unsynchronized) collection. As long as all accesses to the backing collection are through the returned collection, thread safety is guaranteed.
    • Collections.checked接口 - Returns a dynamically type-safe view of the specified collection, which throws a ClassCastException if a client attempts to add an element of the wrong type. The generics mechanism in the language provides compile-time (static) type checking, but it is possible to bypass this mechanism. Dynamically type-safe views eliminate this possibility.
  • Adapter implementations - Implementations that adapt one collections interface to another:
    • newSetFromMap(Map) - Creates a general-purpose Set implementation from a general-purpose Map implementation.
    • asLifoQueue(Deque) - Returns a view of a Deque as a Last In First Out (LIFO) Queue.
  • Convenience implementations - High-performance "mini-implementations" of the collection interfaces.
    • Arrays.asList - Enables an array to be viewed as a list.
    • emptySet, emptyList and emptyMap - Return an immutable empty set, list, or map.
    • singleton, singletonList, and singletonMap - Return an immutable singleton set, list, or map, containing only the specified object (or key-value mapping).
    • nCopies - Returns an immutable list consisting of n copies of a specified object.
  • Legacy implementations - Older collection classes were retrofitted to implement the collection interfaces.
    • Vector - Synchronized resizable array implementation of the List interface with additional legacy methods.
    • Hashtable - Synchronized hash table implementation of the Map interface that does not allow null keys or values, plus additional legacy methods.
  • Special-purpose implementations
    • WeakHashMap - An implementation of the Map interface that stores only weak references to its keys. Storing only weak references enables key-value pairs to be garbage collected when the key is no longer referenced outside of the WeakHashMap. This class is the easiest way to use the power of weak references. It is useful for implementing registry-like data structures, where the utility of an entry vanishes when its key is no longer reachable by any thread.
    • IdentityHashMap - Identity-based Map implementation based on a hash table. This class is useful for topology-preserving object graph transformations (such as serialization or deep copying). To perform these transformations, you must maintain an identity-based "node table" that keeps track of which objects have already been seen. Identity-based maps are also used to maintain object-to-meta-information mappings in dynamic debuggers and similar systems. Finally, identity-based maps are useful in preventing "spoof attacks" resulting from intentionally perverse equals methods. (IdentityHashMap never invokes the equals method on its keys.) An added benefit of this implementation is that it is fast.
    • CopyOnWriteArrayList - A List implementation backed by an copy-on-write array. All mutative operations (such as add, set, and remove) are implemented by making a new copy of the array. No synchronization is necessary, even during iteration, and iterators are guaranteed never to throw ConcurrentModificationException. This implementation is well-suited to maintaining event-handler lists (where change is infrequent, and traversal is frequent and potentially time-consuming).
    • CopyOnWriteArraySet - A Set implementation backed by a copy-on-write array. This implementation is similar to CopyOnWriteArrayList. Unlike most Set implementations, the add, remove, and contains methods require time proportional to the size of the set. This implementation is well suited to maintaining event-handler lists that must prevent duplicates.
    • EnumSet - A high-performance Set implementation backed by a bit vector. All elements of each EnumSet instance must be elements of a single enum type.
    • EnumMap - A high-performance Map implementation backed by an array. All keys in each EnumMap instance must be elements of a single enum type.
  • Concurrent implementations - These implementations are part of java.util.concurrent.
    • ConcurrentLinkedQueue - An unbounded first in, first out (FIFO) queue based on linked nodes.
    • LinkedBlockingQueue - An optionally bounded FIFO blocking queue backed by linked nodes.
    • ArrayBlockingQueue - A bounded FIFO blocking queue backed by an array.
    • PriorityBlockingQueue - An unbounded blocking priority queue backed by a priority heap.
    • DelayQueue - A time-based scheduling queue backed by a priority heap.
    • SynchronousQueue - A simple rendezvous mechanism that uses the BlockingQueue interface.
    • LinkedBlockingDeque - An optionally bounded FIFO blocking deque backed by linked nodes.
    • LinkedTransferQueue - An unbounded TransferQueue backed by linked nodes.
    • ConcurrentHashMap - A highly concurrent, high-performance ConcurrentMap implementation based on a hash table. This implementation never blocks when performing retrievals and enables the client to select the concurrency level for updates. It is intended as a drop-in replacement for Hashtable. In addition to implementing ConcurrentMap, it supports all of the legacy methods of Hashtable.
    • ConcurrentSkipListSet - Skips list implementation of the NavigableSet interface.
    • ConcurrentSkipListMap - Skips list implementation of the ConcurrentNavigableMap interface.
  • Abstract implementations - Skeletal implementations of the collection interfaces to facilitate custom implementations.
    • AbstractCollection - Skeletal Collection implementation that is neither a set nor a list (such as a "bag" or multiset).
    • AbstractSet - Skeletal Set implementation.
    • AbstractList - Skeletal List implementation backed by a random access data store (such as an array).
    • AbstractSequentialList - Skeletal List implementation backed by a sequential access data store (such as a linked list).
    • AbstractQueue - Skeletal Queue implementation.
    • AbstractMap - Skeletal Map implementation.
  • Algorithms - The Collections class contains these useful static methods.
    • sort(List) - Sorts a list using a merge sort algorithm, which provides average case performance comparable to a high quality quicksort, guaranteed O(n*log n) performance (unlike quicksort), and stability (unlike quicksort). A stable sort is one that does not reorder equal elements.
    • binarySearch(List, Object) - Searches for an element in an ordered list using the binary search algorithm.
    • reverse(List) - Reverses the order of the elements in a list.
    • shuffle(List) - Randomly changes the order of the elements in a list.
    • fill(List, Object) - Overwrites every element in a list with the specified value.
    • copy(List dest, List src) - Copies the source list into the destination list.
    • min(Collection) - Returns the minimum element in a collection.
    • max(Collection) - Returns the maximum element in a collection.
    • rotate(List list, int distance) - Rotates all of the elements in the list by the specified distance.
    • replaceAll(List list, Object oldVal, Object newVal) - Replaces all occurrences of one specified value with another.
    • indexOfSubList(List source, List target) - Returns the index of the first sublist of source that is equal to target.
    • lastIndexOfSubList(List source, List target) - Returns the index of the last sublist of source that is equal to target.
    • swap(List, int, int) - Swaps the elements at the specified positions in the specified list.
    • frequency(Collection, Object) - Counts the number of times the specified element occurs in the specified collection.
    • disjoint(Collection, Collection) - Determines whether two collections are disjoint, in other words, whether they contain no elements in common.
    • addAll(Collection<? super T>, T...) - Adds all of the elements in the specified array to the specified collection.
  • Infrastructure
    • Iterators - Similar to the familiar Enumeration interface, but more powerful, and with improved method names.
      • Iterator - In addition to the functionality of the Enumeration interface, enables the user to remove elements from the backing collection with well-defined, useful semantics.
      • ListIterator - Iterator for use with lists. In addition to the functionality of the Iterator interface, supports bidirectional iteration, element replacement, element insertion, and index retrieval.
    • Ordering
      • Comparable - Imparts a natural ordering to classes that implement it. The natural ordering can be used to sort a list or maintain order in a sorted set or map. Many classes were retrofitted to implement this interface.
      • Comparator - Represents an order relation, which can be used to sort a list or maintain order in a sorted set or map. Can override a type's natural ordering or order objects of a type that does not implement the Comparable interface.
    • Runtime exceptions
      • UnsupportedOperationException - Thrown by collections if an unsupported optional operation is called.
      • ConcurrentModificationException - Thrown by iterators and list iterators if the backing collection is changed unexpectedly while the iteration is in progress. Also thrown by sublist views of lists if the backing list is changed unexpectedly.
    • Performance
      • RandomAccess - Marker interface that lets List implementations indicate that they support fast (generally constant time) random access. This lets generic algorithms change their behavior to provide good performance when applied to either random or sequential access lists.
  • Array Utilities
    • Arrays - Contains static methods to sort, search, compare, hash, copy, resize, convert to String, and fill arrays of primitives and objects.

Copyright © 1998, 2017, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


The Collections Framework

The collections framework is a unified architecture for representing and manipulating collections, enabling them to be manipulated independently of the details of their representation. It reduces programming effort while increasing performance. It enables interoperability among unrelated APIs, reduces effort in designing and learning new APIs, and fosters software reuse. The framework is based on more than a dozen collection interfaces. It includes implementations of these interfaces and algorithms to manipulate them.

The documents in this section are non-normative portions of the Java™ Platform, Standard Edition API Specification.

  • 概述 - An overview of the collections framework.
  • Annotated API Outline - An annotated outline of the classes and interfaces comprising the collections framework, with links into the API Specification.
  • Design FAQ - Answers to frequently asked questions (FAQ) about the design of the collections framework.

Copyright © 1998, 2017, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


BiConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface BiConsumer<T,U>

  • 参数类型
    T - 操作的第一个参数的类型
    U - 操作的第二个参数的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface BiConsumer<T,U>
    表示接受两个输入参数并且不返回结果的操作。 这是Consumer的二元专业化。 与大多数其他功能接口不同， BiConsumer预期通过副作用进行操作。

    这是一个functional interface的功能方法是accept(Object, Object) 。

    从以下版本开始：
    1.8
    另请参见：
    Consumer

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void accept​(T t, U u)
      对给定的参数执行此操作。
      default BiConsumer<T,U> andThen​(BiConsumer<? super T,? super U> after)
      返回一个组成的 BiConsumer ，依次执行该操作，然后执行 after操作。

    • 方法详细信息

      • accept

        void accept​(T t,
            U u)
        对给定的参数执行此操作。
        参数
        t - 第一个输入参数
        u - 第二个输入参数

      • andThen

        default BiConsumer<T,U> andThen​(BiConsumer<? super T,? super U> after)
        返回一个组合的BiConsumer ，依次执行该操作，然后执行after操作。 如果执行任一操作会抛出异常，它将被转发到组合操作的调用者。 如果执行此操作会引发异常，则不会执行after操作。
        参数
        after - 此操作后执行的操作
        结果
        一个组成的 BiConsumer ，依次执行 after操作
        异常
        NullPointerException - 如果 after为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BiFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface BiFunction<T,U,R>

  • 参数类型
    T - 函数的第一个参数的类型
    U - 函数的第二个参数的类型
    R - 函数结果的类型
    All Known Subinterfaces:
    BinaryOperator<T>
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface BiFunction<T,U,R>
    表示接受两个参数并产生结果的函数。 这是二位一体的专业化Function 。

    这是一个functional interface的功能方法是apply(Object, Object) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default <V> BiFunction<T,U,V> andThen​(Function<? super R,? extends V> after)
      返回一个组合函数，首先将该函数应用于其输入，然后将 after函数应用于结果。
      R apply​(T t, U u)
      将此函数应用于给定的参数。

    • 方法详细信息

      • apply

        R apply​(T t,
        U u)
        将此函数应用于给定的参数。
        参数
        t - 第一个函数参数
        u - 第二个函数参数
        结果
        功能结果

      • andThen

        default <V> BiFunction<T,U,V> andThen​(Function<? super R,? extends V> after)
        返回一个组合函数，首先将该函数应用于其输入，然后将after函数应用于结果。 如果任一函数的评估引发异常，则将其转发给组合函数的调用者。
        参数类型
        V - after函数的输出类型和组合函数
        参数
        after - 应用此功能后应用的功能
        结果
        一个组合函数，首先应用此函数，然后应用 after函数
        异常
        NullPointerException - if after is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BinaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface BinaryOperator<T>

  • 参数类型
    T - 操作数的类型和操作符的结果
    All Superinterfaces:
    BiFunction<T,T,T>
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface BinaryOperator<T>
extends BiFunction<T,T,T>
    表示对同一类型的两个操作数的操作，产生与操作数相同类型的结果。 对于操作数和结果都是相同类型的情况，这是一个BiFunction的专业化。

    这是一个functional interface的功能方法是BiFunction.apply(Object, Object) 。

    从以下版本开始：
    1.8
    另请参见：
    BiFunction ， UnaryOperator

    • 方法摘要

      所有方法 静态方法 Default Methods
      Modifier and Type 方法 描述
      static <T> BinaryOperator<T> maxBy​(Comparator<? super T> comparator)
      返回一个BinaryOperator ，它根据指定的Comparator返回两个元素中的较大者。
      static <T> BinaryOperator<T> minBy​(Comparator<? super T> comparator)
      返回一个BinaryOperator ，它根据指定的Comparator返回两个元素中较小的一个元素。

      • Methods inherited from interface java.util.function.BiFunction

        andThen, apply

    • 方法详细信息

      • minBy

        static <T> BinaryOperator<T> minBy​(Comparator<? super T> comparator)
        返回一个BinaryOperator ，它根据指定的Comparator返回两个元素中较小的一个元素。
        参数类型
        T - 比较器的输入参数的类型
        参数
        comparator - 用于比较两个值的 Comparator
        结果
        根据提供的 Comparator ，一个 BinaryOperator返回其操作数中较小的 Comparator
        异常
        NullPointerException - 如果参数为空

      • maxBy

        static <T> BinaryOperator<T> maxBy​(Comparator<? super T> comparator)
        返回一个BinaryOperator ，它根据指定的Comparator返回两个元素中的较大者。
        参数类型
        T - 比较器输入参数的类型
        参数
        comparator - 一个 Comparator用于比较两个值
        结果
        一个 BinaryOperator ，它返回的操作数越大，根据提供的 Comparator
        异常
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BiPredicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface BiPredicate<T,U>

  • 参数类型
    T - 谓词的第一个参数的类型
    U - 谓词的第二个参数的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface BiPredicate<T,U>
    表示两个参数的谓词（布尔值函数）。 这是Predicate的二元专业化。

    这是一个functional interface的功能方法是test(Object, Object) 。

    从以下版本开始：
    1.8
    另请参见：
    Predicate

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default BiPredicate<T,U> and​(BiPredicate<? super T,? super U> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default BiPredicate<T,U> negate​()
      返回表示此谓词的逻辑否定的谓词。
      default BiPredicate<T,U> or​(BiPredicate<? super T,? super U> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      boolean test​(T t, U u)
      根据给定的参数来评估这个谓词。

    • 方法详细信息

      • test

        boolean test​(T t,
             U u)
        根据给定的参数来评估这个谓词。
        参数
        t - 第一个输入参数
        u - 第二个输入参数
        结果
        true如果输入参数匹配谓词，否则为 false

      • and

        default BiPredicate<T,U> and​(BiPredicate<? super T,? super U> other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。 当评估组合谓词时，如果该谓词为false ，则不评估other谓词。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与此谓词进行逻辑与操作的谓词
        结果
        一个代表该谓词与 other谓词的短路逻辑AND的 other谓词
        异常
        NullPointerException - 如果其他为空

      • negate

        default BiPredicate<T,U> negate​()
        返回表示此谓词的逻辑否定的谓词。
        结果
        一个表示该谓词的逻辑否定的谓词

      • or

        default BiPredicate<T,U> or​(BiPredicate<? super T,? super U> other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。 当评估组合谓词时，如果此谓词为true ，则不评估other谓词。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与此谓词进行逻辑关系的谓词
        结果
        一个组成的谓词，表示该谓词和 other谓词的短路逻辑或
        异常
        NullPointerException - 如果其他为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BooleanSupplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface BooleanSupplier

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface BooleanSupplier
    代表boolean结果。 这是boolean的制造用原始的专业化Supplier 。

    没有要求每次调用供应商时都会返回新的或不同的结果。

    这是一个functional interface的功能方法是getAsBoolean() 。

    从以下版本开始：
    1.8
    另请参见：
    Supplier

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean getAsBoolean​()
      获得结果。

    • 方法详细信息

      • getAsBoolean

        boolean getAsBoolean​()
        获得结果。
        结果
        a result
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Consumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface Consumer<T>

  • 参数类型
    T - 操作输入的类型
    All Known Subinterfaces:
    Stream.Builder<T>
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Consumer<T>
    表示接受单个输入参数并且不返回结果的操作。 与大多数其他功能接口不同， Consumer预期通过副作用进行操作。

    这是一个functional interface的功能方法是accept(Object) 。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void accept​(T t)
      对给定的参数执行此操作。
      default Consumer<T> andThen​(Consumer<? super T> after)
      返回一个组成的 Consumer ，依次执行此操作，然后执行 after操作。

    • 方法详细信息

      • accept

        void accept​(T t)
        对给定的参数执行此操作。
        参数
        t - 输入参数

      • andThen

        default Consumer<T> andThen​(Consumer<? super T> after)
        返回一个组合的Consumer ，依次执行此操作，然后执行after操作。 如果执行任一操作会抛出异常，它将被转发到组合操作的调用者。 如果执行此操作会引发异常，则不会执行after操作。
        参数
        after - 此操作后执行的操作
        结果
        一个组成的 Consumer ，依次执行 after操作
        异常
        NullPointerException - if after is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleBinaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface DoubleBinaryOperator

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface DoubleBinaryOperator
    表示对两个double值操作数的操作，并产生一个double结果。 这是BinaryOperator的double的原始类型专业化。

    这是一个functional interface的功能方法是applyAsDouble(double, double) 。

    从以下版本开始：
    1.8
    另请参见：
    BinaryOperator ， DoubleUnaryOperator

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      double applyAsDouble​(double left, double right)
      将此运算符应用于给定的操作数。

    • 方法详细信息

      • applyAsDouble

        double applyAsDouble​(double left,
                     double right)
        将此运算符应用于给定的操作数。
        参数
        left - 第一个操作数
        right - 第二个操作数
        结果
        操作员结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface DoubleConsumer

  • All Known Subinterfaces:
    DoubleStream.Builder
    所有已知实现类：
    DoubleSummaryStatistics
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface DoubleConsumer
    表示接受单个double参数的操作，不返回任何结果。 这是Consumer对于double的原始类型专业化。 与大多数其他功能接口不同， DoubleConsumer预期通过副作用进行操作。

    这是一个functional interface的功能方法是accept(double) 。

    从以下版本开始：
    1.8
    另请参见：
    Consumer

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void accept​(double value)
      对给定的参数执行此操作。
      default DoubleConsumer andThen​(DoubleConsumer after)
      返回一个组合的 DoubleConsumer ，依次执行此操作，然后执行 after操作。

    • 方法详细信息

      • accept

        void accept​(double value)
        对给定的参数执行此操作。
        参数
        value - 输入参数

      • andThen

        default DoubleConsumer andThen​(DoubleConsumer after)
        返回一个组合的DoubleConsumer ，依次执行此操作，然后执行after操作。 如果执行任一操作会抛出异常，它将被转发到组合操作的调用者。 如果执行此操作会引发异常，则不会执行after操作。
        参数
        after - 此操作后执行的操作
        结果
        一个组成的 DoubleConsumer按顺序执行这个操作，然后是 after操作
        异常
        NullPointerException - 如果 after为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface DoubleFunction<R>

  • 参数类型
    R - 函数结果的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface DoubleFunction<R>
    表示接受双值参数并产生结果的函数。 这是double消耗原始专业Function 。

    这是一个functional interface的功能方法是apply(double) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      R apply​(double value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • apply

        R apply​(double value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoublePredicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface DoublePredicate

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface DoublePredicate
    表示一个double值参数的谓词（布尔值函数）。 这是double的-consuming原始类型专业化Predicate 。

    这是一个functional interface的功能方法是test(double) 。

    从以下版本开始：
    1.8
    另请参见：
    Predicate

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default DoublePredicate and​(DoublePredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default DoublePredicate negate​()
      返回表示此谓词的逻辑否定的谓词。
      default DoublePredicate or​(DoublePredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      boolean test​(double value)
      在给定的参数上评估这个谓词。

    • 方法详细信息

      • test

        boolean test​(double value)
        在给定的参数上评估这个谓词。
        参数
        value - 输入参数
        结果
        true如果输入参数与谓词匹配，否则为 false

      • and

        default DoublePredicate and​(DoublePredicate other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。 评估组合谓词时，如果此谓词为false ，则不other谓词进行评估。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与此谓词进行逻辑与操作的谓词
        结果
        一个代表该谓词与 other谓词的短路逻辑AND的 other谓词
        异常
        NullPointerException - 如果其他为空

      • negate

        default DoublePredicate negate​()
        返回表示此谓词的逻辑否定的谓词。
        结果
        一个表示该谓词的逻辑否定的谓词

      • or

        default DoublePredicate or​(DoublePredicate other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。 当评估组合谓词时，如果该谓词为true ，则不评估other谓词。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与该谓词进行逻辑关系的谓词
        结果
        一个代表该谓词与 other谓词的短路逻辑或的 other谓词
        异常
        NullPointerException - 如果其他为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleSupplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface DoubleSupplier

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface DoubleSupplier
    代表double结果的供应商。 这是double的制造用原始的专业化Supplier 。

    不要求每次调用供应商时返回不同的结果。

    这是一个functional interface的功能方法是getAsDouble() 。

    从以下版本开始：
    1.8
    另请参见：
    Supplier

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      double getAsDouble​()
      获得结果。

    • 方法详细信息

      • getAsDouble

        double getAsDouble​()
        获得结果。
        结果
        a result
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleToIntFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface DoubleToIntFunction

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface DoubleToIntFunction
    表示接受双值参数并产生int值结果的函数。 这是double int原始专业Function 。

    这是一个functional interface的功能方法是applyAsInt(double) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int applyAsInt​(double value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsInt

        int applyAsInt​(double value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleToLongFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface DoubleToLongFunction

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface DoubleToLongFunction
    表示接受双值参数并产生长期值结果的函数。 这是double long原始专业Function 。

    这是一个functional interface的功能方法是applyAsLong(double) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long applyAsLong​(double value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsLong

        long applyAsLong​(double value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleUnaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface DoubleUnaryOperator

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface DoubleUnaryOperator
    表示对一个double值的操作数的操作，产生一个double结果。 这是double的double的原始类型专业化。

    这是一个functional interface的功能方法是applyAsDouble(double) 。

    从以下版本开始：
    1.8
    另请参见：
    UnaryOperator

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default DoubleUnaryOperator andThen​(DoubleUnaryOperator after)
      返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
      double applyAsDouble​(double operand)
      将此运算符应用于给定的操作数。
      default DoubleUnaryOperator compose​(DoubleUnaryOperator before)
      返回一个组合运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。
      static DoubleUnaryOperator identity​()
      返回始终返回其输入参数的一元运算符。

    • 方法详细信息

      • applyAsDouble

        double applyAsDouble​(double operand)
        将此运算符应用于给定的操作数。
        参数
        operand - 操作数
        结果
        操作员结果

      • compose

        default DoubleUnaryOperator compose​(DoubleUnaryOperator before)
        返回一个组合运算符，首先将before运算符应用于其输入，然后将该运算符应用于结果。 如果任一运算符的评估引发异常，则将其中继到组合运算符的调用者。
        参数
        before - 应用此操作员之前应用的操作员
        结果
        一个组合的操作员，首先应用 before操作符，然后应用此运算符
        异常
        NullPointerException - 如果以前是空
        另请参见：
        andThen(DoubleUnaryOperator)

      • andThen

        default DoubleUnaryOperator andThen​(DoubleUnaryOperator after)
        返回一个组合运算符，首先将该运算符应用于其输入，然后将after运算符应用于结果。 如果任一运算符的评估引发异常，则将其中继到组合运算符的调用者。
        参数
        after - 应用此操作符后应用的操作员
        结果
        一个组合运算符，首先应用此运算符，然后应用 after运算符
        异常
        NullPointerException - 如果after为null
        另请参见：
        compose(DoubleUnaryOperator)

      • identity

        static DoubleUnaryOperator identity​()
        返回始终返回其输入参数的一元运算符。
        结果
        总是返回其输入参数的一元运算符
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Function (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface Function<T,R>

  • 参数类型
    T - 函数输入的类型
    R - 函数结果的类型
    All Known Subinterfaces:
    UnaryOperator<T>
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Function<T,R>
    表示接受一个参数并产生结果的函数。

    这是一个functional interface的功能方法是apply(Object) 。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default <V> Function<T,V> andThen​(Function<? super R,? extends V> after)
      返回一个组合函数，首先将该函数应用于其输入，然后将 after函数应用于结果。
      R apply​(T t)
      将此函数应用于给定的参数。
      default <V> Function<V,R> compose​(Function<? super V,? extends T> before)
      返回一个组合函数，首先将 before函数应用于其输入，然后将此函数应用于结果。
      static <T> Function<T,T> identity​()
      返回一个总是返回其输入参数的函数。

    • 方法详细信息

      • apply

        R apply​(T t)
        将此函数应用于给定的参数。
        参数
        t - 函数参数
        结果
        功能结果

      • compose

        default <V> Function<V,R> compose​(Function<? super V,? extends T> before)
        返回一个组合函数，首先将before函数应用于其输入，然后将此函数应用于结果。 如果任一函数的评估引发异常，则将其转发给组合函数的调用者。
        参数类型
        V - 对 before函数的输入类型，以及组合函数
        参数
        before - 应用此函数之前应用的功能
        结果
        一个组合函数首先应用 before函数，然后应用此功能
        异常
        NullPointerException - 如果以前是空
        另请参见：
        andThen(Function)

      • andThen

        default <V> Function<T,V> andThen​(Function<? super R,? extends V> after)
        返回一个组合函数，首先将该函数应用于其输入，然后将after函数应用于结果。 如果任一函数的评估引发异常，则将其转发给组合函数的调用者。
        参数类型
        V - after函数的输出类型，以及组合函数的输出类型
        参数
        after - 应用此功能后应用的功能
        结果
        一个组合函数首先应用此函数，然后应用 after函数
        异常
        NullPointerException - 如果after为null
        另请参见：
        compose(Function)

      • identity

        static <T> Function<T,T> identity​()
        返回一个总是返回其输入参数的函数。
        参数类型
        T - 函数的输入和输出对象的类型
        结果
        一个总是返回其输入参数的函数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntBinaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface IntBinaryOperator

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface IntBinaryOperator
    代表两个int操作数的操作，并产生一个int结果。 这是BinaryOperator的int的原始类型专业化。

    这是一个functional interface的功能方法是applyAsInt(int, int) 。

    从以下版本开始：
    1.8
    另请参见：
    BinaryOperator ， IntUnaryOperator

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int applyAsInt​(int left, int right)
      将此运算符应用于给定的操作数。

    • 方法详细信息

      • applyAsInt

        int applyAsInt​(int left,
               int right)
        将此运算符应用于给定的操作数。
        参数
        left - 第一个操作数
        right - 第二个操作数
        结果
        操作员结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface IntConsumer

  • All Known Subinterfaces:
    IntStream.Builder
    所有已知实现类：
    IntSummaryStatistics ， LongSummaryStatistics
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface IntConsumer
    表示接受单个int参数的操作，不返回任何结果。 这是Consumer的int的原始类型专业化。 与大多数其他功能接口不同， IntConsumer预期通过副作用进行操作。

    这是一个functional interface的功能方法是accept(int) 。

    从以下版本开始：
    1.8
    另请参见：
    Consumer

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void accept​(int value)
      对给定的参数执行此操作。
      default IntConsumer andThen​(IntConsumer after)
      返回一个组合的 IntConsumer ，依次执行此操作，然后执行 after操作。

    • 方法详细信息

      • accept

        void accept​(int value)
        对给定的参数执行此操作。
        参数
        value - 输入参数

      • andThen

        default IntConsumer andThen​(IntConsumer after)
        返回一个组合的IntConsumer ，依次执行此操作，然后执行after操作。 如果执行任一操作会抛出异常，它将被转发到组合操作的调用者。 如果执行此操作会引发异常，则不会执行after操作。
        参数
        after - 此操作后执行的操作
        结果
        一个组成的 IntConsumer ，依次执行这个操作，然后执行 after操作
        异常
        NullPointerException - 如果 after为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface IntFunction<R>

  • 参数类型
    R - 函数结果的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface IntFunction<R>
    表示一个接受int值参数并产生结果的函数。 这是int消耗原始专业Function 。

    这是一个functional interface的功能方法是apply(int) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      R apply​(int value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • apply

        R apply​(int value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntPredicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface IntPredicate

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface IntPredicate
    表示一个int值参数的谓词（布尔值函数）。 这是int消耗原始类型专业化Predicate 。

    这是一个functional interface的功能方法是test(int) 。

    从以下版本开始：
    1.8
    另请参见：
    Predicate

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default IntPredicate and​(IntPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default IntPredicate negate​()
      返回表示此谓词的逻辑否定的谓词。
      default IntPredicate or​(IntPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      boolean test​(int value)
      在给定的参数上评估这个谓词。

    • 方法详细信息

      • test

        boolean test​(int value)
        在给定的参数上评估这个谓词。
        参数
        value - 输入参数
        结果
        true如果输入参数与谓词匹配，否则为 false

      • and

        default IntPredicate and​(IntPredicate other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。 当评估组合谓词时，如果此谓词为false ，则不会评估other谓词。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与该谓词进行逻辑AND操作的谓词
        结果
        一个代表该谓词和 other谓词的短路逻辑与的 other谓词
        异常
        NullPointerException - 如果其他为空

      • negate

        default IntPredicate negate​()
        返回表示此谓词的逻辑否定的谓词。
        结果
        一个表示该谓词的逻辑否定的谓词

      • or

        default IntPredicate or​(IntPredicate other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。 当评估组合谓词时，如果该谓词为true ，则不会评估other谓词。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与此谓词进行逻辑关系的谓词
        结果
        一个代表该谓词与 other谓词的短路逻辑OR的 other谓词
        异常
        NullPointerException - 如果其他为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntSupplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface IntSupplier

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface IntSupplier
    代表int结果。 这是int的制造用原始的专业化Supplier 。

    不要求每次调用供应商时返回不同的结果。

    这是一个functional interface的功能方法是getAsInt() 。

    从以下版本开始：
    1.8
    另请参见：
    Supplier

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getAsInt​()
      获得结果。

    • 方法详细信息

      • getAsInt

        int getAsInt​()
        获得结果。
        结果
        a result
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntToDoubleFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface IntToDoubleFunction

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface IntToDoubleFunction
    表示接受一个int值参数并产生一个双值结果的函数。 这是int至- double的原始专业化Function 。

    这是一个functional interface的功能方法是applyAsDouble(int) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      double applyAsDouble​(int value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsDouble

        double applyAsDouble​(int value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntToLongFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface IntToLongFunction

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface IntToLongFunction
    表示接受一个int值参数并产生一个长效结果的函数。 这是int long原始专业Function 。

    这是一个functional interface的功能方法是applyAsLong(int) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long applyAsLong​(int value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsLong

        long applyAsLong​(int value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntUnaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface IntUnaryOperator

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface IntUnaryOperator
    表示对单个int值的操作数的操作，产生一个int值结果。 这是int的int的原始类型专业化。

    这是一个functional interface的功能方法是applyAsInt(int) 。

    从以下版本开始：
    1.8
    另请参见：
    UnaryOperator

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default IntUnaryOperator andThen​(IntUnaryOperator after)
      返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
      int applyAsInt​(int operand)
      将此运算符应用于给定的操作数。
      default IntUnaryOperator compose​(IntUnaryOperator before)
      返回一个 before运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。
      static IntUnaryOperator identity​()
      返回始终返回其输入参数的一元运算符。

    • 方法详细信息

      • applyAsInt

        int applyAsInt​(int operand)
        将此运算符应用于给定的操作数。
        参数
        operand - 操作数
        结果
        操作员结果

      • compose

        default IntUnaryOperator compose​(IntUnaryOperator before)
        返回一个before运算符，首先将before运算符应用于其输入，然后将该运算符应用于结果。 如果任一运算符的评估引发异常，则将其中继到组合运算符的调用者。
        参数
        before ：
        结果
        一个组合的操作员，首先应用 before操作符，然后应用此运算符
        异常
        NullPointerException - 如果以前是空
        另请参见：
        andThen(IntUnaryOperator)

      • andThen

        default IntUnaryOperator andThen​(IntUnaryOperator after)
        返回一个组合运算符，首先将该运算符应用于其输入，然后将after运算符应用于结果。 如果任一运算符的评估引发异常，则将其中继到组合运算符的调用者。
        参数
        after - after
        结果
        一个组合运算符，首先应用此运算符，然后应用 after运算符
        异常
        NullPointerException - 如果after为null
        另请参见：
        compose(IntUnaryOperator)

      • identity

        static IntUnaryOperator identity​()
        返回始终返回其输入参数的一元运算符。
        结果
        总是返回其输入参数的一元运算符
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.util.function (Java SE 9 & JDK 9 )

java.util.function

Interfaces

  • BiConsumer
  • BiFunction
  • BinaryOperator
  • BiPredicate
  • BooleanSupplier
  • Consumer
  • DoubleBinaryOperator
  • DoubleConsumer
  • DoubleFunction
  • DoublePredicate
  • DoubleSupplier
  • DoubleToIntFunction
  • DoubleToLongFunction
  • DoubleUnaryOperator
  • Function
  • IntBinaryOperator
  • IntConsumer
  • IntFunction
  • IntPredicate
  • IntSupplier
  • IntToDoubleFunction
  • IntToLongFunction
  • IntUnaryOperator
  • LongBinaryOperator
  • LongConsumer
  • LongFunction
  • LongPredicate
  • LongSupplier
  • LongToDoubleFunction
  • LongToIntFunction
  • LongUnaryOperator
  • ObjDoubleConsumer
  • ObjIntConsumer
  • ObjLongConsumer
  • Predicate
  • Supplier
  • ToDoubleBiFunction
  • ToDoubleFunction
  • ToIntBiFunction
  • ToIntFunction
  • ToLongBiFunction
  • ToLongFunction
  • UnaryOperator


java.util.function (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util.function

功能界面提供了lambda表达式和方法引用的目标类型。 每个功能界面都有一个抽象方法，称为功能接口的功能方法 ，lambda表达式的参数和返回类型与之匹配或调整。 功能界面可以在多个上下文中提供目标类型，如赋值上下文，方法调用或转换上下文：
   // Assignment context Predicate<String> p = String::isEmpty; // Method invocation context stream.filter(e -> e.getSize() > 10)... // Cast context stream.map((ToIntFunction) e -> e.getSize())...

该包中的接口是JDK使用的通用功能接口，可供用户代码使用。 虽然它们不能识别lambda表达式可能适应的一整套功能形状，但它们足以满足常见要求。 为特定目的而提供的其他功能界面（如FileFilter）在使用它们的包中定义。

该包中的接口注释为FunctionalInterface 。 该注释不是编译器将接口识别为功能接口的要求，而只是帮助捕获设计意图，并引导编译器帮助识别意外违反设计意图。

功能界面通常表示抽象概念，如函数，动作或谓词。 在记录功能界面或引用类型为功能接口的变量时，通常直接引用这些抽象概念，例如使用“this function”而不是“由该对象表示的函数”。 当API方法被称为以这种方式接受或返回功能界面时，例如“将所提供的功能应用于...”，这被理解为对实现适当功能界面的对象的非空引用，除非明确指定潜在的无效。

该包中的功能接口遵循可扩展的命名约定，如下所示：

  • 有几个基本功能的形状，包括Function （一元函数从T到R ） Consumer （一元函数从T到void ） Predicate （一元函数从T到boolean ），和Supplier （无参函数R ）。
  • 功能形状基于它们最常用的方式具有自然界。 这些基本形状可以通过一个arity前缀来修改，以表示不同的特征，如BiFunction （二进制函数从T和U到R ）。
  • 还有额外的派生功能形状可扩展基本功能形状，包括UnaryOperator （扩展Function ）和BinaryOperator （扩展BiFunction ）。
  • 功能接口的类型参数可以专用于具有附加类型前缀的原语。 要为具有通用返回类型和通用参数的类型专用返回类型，我们前缀为ToXxx ，如ToIntFunction 。 否则，类型参数是专门从左到右的，如DoubleConsumer或ObjIntConsumer 。 （类型前缀Obj用于表示我们不想专门化此参数，但要转到下一个参数，如ObjIntConsumer所示） 。这些方案可以组合，如IntToDoubleFunction 。
  • 如果所有参数都有专门化的前缀，则可以省略arity前缀（如ObjIntConsumer ）。
从以下版本开始：
1.8
另请参见：
FunctionalInterface
  • 接口摘要
    接口 描述
    BiConsumer<T,U>
    表示接受两个输入参数并且不返回结果的操作。
    BiFunction<T,U,R>
    表示接受两个参数并产生结果的函数。
    BinaryOperator<T>
    表示对同一类型的两个操作数的操作，产生与操作数相同类型的结果。
    BiPredicate<T,U>
    表示两个参数的谓词（布尔值函数）。
    BooleanSupplier
    代表 boolean结果。
    Consumer<T>
    表示接受单个输入参数并且不返回结果的操作。
    DoubleBinaryOperator
    代表两个 double操作数的操作，并产生一个 double结果。
    DoubleConsumer
    表示接受单个 double参数的操作，并且不返回任何结果。
    DoubleFunction<R>
    表示接受双值参数并产生结果的函数。
    DoublePredicate
    表示一个 double值参数的谓词（布尔值函数）。
    DoubleSupplier
    代表 double结果。
    DoubleToIntFunction
    表示接受双值参数并产生int值结果的函数。
    DoubleToLongFunction
    表示接受双值参数并产生长期值结果的函数。
    DoubleUnaryOperator
    表示对一个 double值的操作数的操作，产生一个 double值结果。
    Function<T,R>
    表示接受一个参数并产生结果的函数。
    IntBinaryOperator
    表示对两个 int操作数的操作，并产生一个 int结果。
    IntConsumer
    表示接受单个 int参数的操作，并且不返回任何结果。
    IntFunction<R>
    表示一个接受int值参数并产生结果的函数。
    IntPredicate
    表示一个 int值参数的谓词（布尔值函数）。
    IntSupplier
    代表 int结果的供应商。
    IntToDoubleFunction
    表示接受一个int值参数并产生一个双值结果的函数。
    IntToLongFunction
    表示接受一个int值参数并产生一个长效结果的函数。
    IntUnaryOperator
    表示对单个 int值的操作数的操作，产生一个 int结果。
    LongBinaryOperator
    表示对两个 long操作数的操作，并产生一个 long结果。
    LongConsumer
    表示接受单个 long参数的操作，并且不返回任何结果。
    LongFunction<R>
    表示接受长期参数并产生结果的函数。
    LongPredicate
    表示一个 long值参数的谓词（布尔值函数）。
    LongSupplier
    代表 long结果。
    LongToDoubleFunction
    表示接受长期参数并产生双值结果的函数。
    LongToIntFunction
    表示接受长值参数并产生int值结果的函数。
    LongUnaryOperator
    表示对单个 long值的操作数的操作，产生一个 long值结果。
    ObjDoubleConsumer<T>
    表示接受对象值和 double参数的操作，并且不返回任何结果。
    ObjIntConsumer<T>
    表示接受对象值和 int值参数的操作，并且不返回任何结果。
    ObjLongConsumer<T>
    表示接受对象值和 long值参数的操作，并且不返回任何结果。
    Predicate<T>
    表示一个参数的谓词（布尔值函数）。
    Supplier<T>
    代表结果供应商。
    ToDoubleBiFunction<T,U>
    表示接受两个参数并产生双值结果的函数。
    ToDoubleFunction<T>
    表示产生双值结果的函数。
    ToIntBiFunction<T,U>
    表示一个接受两个参数并产生一个int值结果的函数。
    ToIntFunction<T>
    表示产生一个int值结果的函数。
    ToLongBiFunction<T,U>
    表示接受两个参数并产生长效结果的函数。
    ToLongFunction<T>
    表示产生长期效果的函数。
    UnaryOperator<T>
    表示对单个操作数产生与其操作数相同类型的结果的操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.function Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.function

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • java.util.function.BiConsumer<T,U>
  • java.util.function.BiFunction<T,U,R>
    • java.util.function.BinaryOperator<T>
  • java.util.function.BiPredicate<T,U>
  • java.util.function.BooleanSupplier
  • java.util.function.Consumer<T>
  • java.util.function.DoubleBinaryOperator
  • java.util.function.DoubleConsumer
  • java.util.function.DoubleFunction<R>
  • java.util.function.DoublePredicate
  • java.util.function.DoubleSupplier
  • java.util.function.DoubleToIntFunction
  • java.util.function.DoubleToLongFunction
  • java.util.function.DoubleUnaryOperator
  • java.util.function.Function<T,R>
    • java.util.function.UnaryOperator<T>
  • java.util.function.IntBinaryOperator
  • java.util.function.IntConsumer
  • java.util.function.IntFunction<R>
  • java.util.function.IntPredicate
  • java.util.function.IntSupplier
  • java.util.function.IntToDoubleFunction
  • java.util.function.IntToLongFunction
  • java.util.function.IntUnaryOperator
  • java.util.function.LongBinaryOperator
  • java.util.function.LongConsumer
  • java.util.function.LongFunction<R>
  • java.util.function.LongPredicate
  • java.util.function.LongSupplier
  • java.util.function.LongToDoubleFunction
  • java.util.function.LongToIntFunction
  • java.util.function.LongUnaryOperator
  • java.util.function.ObjDoubleConsumer<T>
  • java.util.function.ObjIntConsumer<T>
  • java.util.function.ObjLongConsumer<T>
  • java.util.function.Predicate<T>
  • java.util.function.Supplier<T>
  • java.util.function.ToDoubleBiFunction<T,U>
  • java.util.function.ToDoubleFunction<T>
  • java.util.function.ToIntBiFunction<T,U>
  • java.util.function.ToIntFunction<T>
  • java.util.function.ToLongBiFunction<T,U>
  • java.util.function.ToLongFunction<T>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LongBinaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface LongBinaryOperator

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface LongBinaryOperator
    表示对两个long操作数的操作，并产生long结果。 这是BinaryOperator的原始类型专业化long 。

    这是一个functional interface的功能方法是applyAsLong(long, long) 。

    从以下版本开始：
    1.8
    另请参见：
    BinaryOperator ， LongUnaryOperator

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long applyAsLong​(long left, long right)
      将此运算符应用于给定的操作数。

    • 方法详细信息

      • applyAsLong

        long applyAsLong​(long left,
                 long right)
        将此运算符应用于给定的操作数。
        参数
        left - 第一个操作数
        right - 第二个操作数
        结果
        操作员结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface LongConsumer

  • All Known Subinterfaces:
    LongStream.Builder
    所有已知实现类：
    LongSummaryStatistics
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface LongConsumer
    表示接受单个long参数的操作，并且不返回任何结果。 这是long的long的原始类型专业化。 与大多数其他功能接口不同， LongConsumer预计通过副作用进行操作。

    这是一个functional interface的功能方法是accept(long) 。

    从以下版本开始：
    1.8
    另请参见：
    Consumer

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void accept​(long value)
      对给定的参数执行此操作。
      default LongConsumer andThen​(LongConsumer after)
      返回一个组成的 LongConsumer ，依次执行此操作，然后执行 after操作。

    • 方法详细信息

      • accept

        void accept​(long value)
        对给定的参数执行此操作。
        参数
        value - 输入参数

      • andThen

        default LongConsumer andThen​(LongConsumer after)
        返回一个组合的LongConsumer ，依次执行此操作，然后执行after操作。 如果执行任一操作会抛出异常，它将被转发到组合操作的调用者。 如果执行此操作将抛出异常，则不会执行after操作。
        参数
        after - 此操作后执行的操作
        结果
        一个组成的 LongConsumer ，按顺序执行这个操作，然后是 after操作
        异常
        NullPointerException - 如果 after为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface LongFunction<R>

  • 参数类型
    R - 函数结果的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface LongFunction<R>
    表示接受长期参数并产生结果的函数。 这是long消耗原始专业Function 。

    这是一个functional interface的功能方法是apply(long) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      R apply​(long value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • apply

        R apply​(long value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongPredicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface LongPredicate

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface LongPredicate
    表示一个long值参数的谓词（布尔值函数）。 这是long消耗原始类型专业化Predicate 。

    这是一个functional interface的功能方法是test(long) 。

    从以下版本开始：
    1.8
    另请参见：
    Predicate

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default LongPredicate and​(LongPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default LongPredicate negate​()
      返回表示此谓词的逻辑否定的谓词。
      default LongPredicate or​(LongPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      boolean test​(long value)
      在给定的参数上评估这个谓词。

    • 方法详细信息

      • test

        boolean test​(long value)
        在给定的参数上评估这个谓词。
        参数
        value - 输入参数
        结果
        true如果输入参数匹配谓词，否则为 false

      • and

        default LongPredicate and​(LongPredicate other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。 当评估组合谓词时，如果此谓词为false ，则不会评估other谓词。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与此谓词进行逻辑AND的谓词
        结果
        一个代表该谓词与 other谓词的短路逻辑与的 other谓词
        异常
        NullPointerException - 如果其他为空

      • negate

        default LongPredicate negate​()
        返回表示此谓词的逻辑否定的谓词。
        结果
        一个表示该谓词的逻辑否定的谓词

      • or

        default LongPredicate or​(LongPredicate other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。 当评估组合谓词时，如果此谓词为true ，则不other谓词进行评估。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与该谓词进行逻辑关系的谓词
        结果
        一个代表该谓词与 other谓词的短路逻辑或的 other谓词
        异常
        NullPointerException - 如果其他为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongSupplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface LongSupplier

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface LongSupplier
    代表long结果。 这是long的制造用原始的专业化Supplier 。

    不要求每次调用供应商时返回不同的结果。

    这是一个functional interface的功能方法是getAsLong() 。

    从以下版本开始：
    1.8
    另请参见：
    Supplier

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getAsLong​()
      获得结果。

    • 方法详细信息

      • getAsLong

        long getAsLong​()
        获得结果。
        结果
        a result
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongToDoubleFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface LongToDoubleFunction

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface LongToDoubleFunction
    表示接受长期参数并产生双值结果的函数。 这是long double原始专业Function 。

    这是一个functional interface的功能方法是applyAsDouble(long) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      double applyAsDouble​(long value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsDouble

        double applyAsDouble​(long value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongToIntFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface LongToIntFunction

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface LongToIntFunction
    表示接受长值参数并产生int值结果的函数。 这是long int原始专业Function 。

    这是一个functional interface，其功能方法是applyAsInt(long) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int applyAsInt​(long value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsInt

        int applyAsInt​(long value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongUnaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface LongUnaryOperator

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface LongUnaryOperator
    代表产生long值的单个long值操作数的操作。 这是UnaryOperator为long的原始类型专业化。

    这是一个functional interface的功能方法是applyAsLong(long) 。

    从以下版本开始：
    1.8
    另请参见：
    UnaryOperator

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default LongUnaryOperator andThen​(LongUnaryOperator after)
      返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
      long applyAsLong​(long operand)
      将此运算符应用于给定的操作数。
      default LongUnaryOperator compose​(LongUnaryOperator before)
      返回一个组合的运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。
      static LongUnaryOperator identity​()
      返回始终返回其输入参数的一元运算符。

    • 方法详细信息

      • applyAsLong

        long applyAsLong​(long operand)
        将此运算符应用于给定的操作数。
        参数
        operand - 操作数
        结果
        操作员结果

      • compose

        default LongUnaryOperator compose​(LongUnaryOperator before)
        返回一个组合运算符，首先将before运算符应用于其输入，然后将该运算符应用于结果。 如果任一运算符的评估引发异常，则将其中继到组合运算符的调用者。
        参数
        before - 应用操作员之前应用的操作员
        结果
        一个组合运算符，首先应用 before运算符，然后应用此运算符
        异常
        NullPointerException - 如果以前是空
        另请参见：
        andThen(LongUnaryOperator)

      • andThen

        default LongUnaryOperator andThen​(LongUnaryOperator after)
        返回一个组合运算符，首先将该运算符应用于其输入，然后将after运算符应用于结果。 如果任一运算符的评估引发异常，则将其中继到组合运算符的调用者。
        参数
        after - 应用此操作符后应用的操作员
        结果
        一个组合的操作员，首先应用此操作符，然后应用 after操作符
        异常
        NullPointerException - 如果after为null
        另请参见：
        compose(LongUnaryOperator)

      • identity

        static LongUnaryOperator identity​()
        返回始终返回其输入参数的一元运算符。
        结果
        总是返回其输入参数的一元运算符
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObjDoubleConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface ObjDoubleConsumer<T>

  • 参数类型
    T - 操作的对象参数的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ObjDoubleConsumer<T>
    表示接受对象值和double值参数的操作，不返回任何结果。 这是(reference, double)专业化BiConsumer 。 与大多数其他功能界面不同， ObjDoubleConsumer预计通过副作用进行操作。

    这是一个functional interface的功能方法是accept(Object, double) 。

    从以下版本开始：
    1.8
    另请参见：
    BiConsumer

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void accept​(T t, double value)
      对给定的参数执行此操作。

    • 方法详细信息

      • accept

        void accept​(T t,
            double value)
        对给定的参数执行此操作。
        参数
        t - 第一个输入参数
        value - 第二个输入参数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObjIntConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface ObjIntConsumer<T>

  • 参数类型
    T - 操作的对象参数的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ObjIntConsumer<T>
    表示接受对象值和int参数的操作，并且不返回任何结果。 这是(reference, int)专业化BiConsumer 。 与大多数其他功能接口不同， ObjIntConsumer预期通过副作用进行操作。

    这是一个functional interface的功能方法是accept(Object, int) 。

    从以下版本开始：
    1.8
    另请参见：
    BiConsumer

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void accept​(T t, int value)
      对给定的参数执行此操作。

    • 方法详细信息

      • accept

        void accept​(T t,
            int value)
        对给定的参数执行此操作。
        参数
        t - 第一个输入参数
        value - 第二个输入参数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObjLongConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface ObjLongConsumer<T>

  • 参数类型
    T - 操作的对象参数的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ObjLongConsumer<T>
    表示接受对象值的操作和long参数，并且不返回任何结果。 这是(reference, long)专业BiConsumer 。 与大多数其他功能界面不同， ObjLongConsumer预计将通过副作用进行操作。

    这是一个functional interface的功能方法是accept(Object, long) 。

    从以下版本开始：
    1.8
    另请参见：
    BiConsumer

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void accept​(T t, long value)
      对给定的参数执行此操作。

    • 方法详细信息

      • accept

        void accept​(T t,
            long value)
        对给定的参数执行此操作。
        参数
        t - 第一个输入参数
        value - 第二个输入参数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Predicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface Predicate<T>

  • 参数类型
    T - 谓词输入的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Predicate<T>
    表示一个参数的谓词（布尔值函数）。

    这是一个functional interface，其功能方法是test(Object) 。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default Predicate<T> and​(Predicate<? super T> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      static <T> Predicate<T> isEqual​(Object targetRef)
      返回一个谓词，根据 Objects.equals(Object, Object)测试两个参数是否相等。
      default Predicate<T> negate​()
      返回表示此谓词的逻辑否定的谓词。
      default Predicate<T> or​(Predicate<? super T> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      boolean test​(T t)
      在给定的参数上评估这个谓词。

    • 方法详细信息

      • test

        boolean test​(T t)
        在给定的参数上评估这个谓词。
        参数
        t - 输入参数
        结果
        true如果输入参数与谓词匹配，否则为 false

      • and

        default Predicate<T> and​(Predicate<? super T> other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。 当评估组合谓词时，如果该谓词为false ，则不评估other谓词。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与此谓词进行逻辑与操作的谓词
        结果
        一个代表该谓词和 other谓词的短路逻辑AND的 other谓词
        异常
        NullPointerException - 如果其他为空

      • negate

        default Predicate<T> negate​()
        返回表示此谓词的逻辑否定的谓词。
        结果
        一个表示该谓词的逻辑否定的谓词

      • or

        default Predicate<T> or​(Predicate<? super T> other)
        返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。 当评估组合谓词时，如果该谓词为true ，则不会评估other谓词。

        在评估任一谓词期间抛出的任何异常被中继到调用者; 如果此谓词的评估引发异常，则不会评估other谓词。

        参数
        other - 将与此谓词进行逻辑关系的谓词
        结果
        一个组成的谓词，表示该谓词与 other谓词的短路逻辑或
        异常
        NullPointerException - 如果其他为空

      • isEqual

        static <T> Predicate<T> isEqual​(Object targetRef)
        返回一个谓词，根据 Objects.equals(Object, Object)测试两个参数是否相等。
        参数类型
        T - 谓词的参数类型
        参数
        targetRef - 用于比较相等的对象引用，可能是 null
        结果
        根据 Objects.equals(Object, Object)测试两个参数是否相等的 谓词
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Supplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface Supplier<T>

  • 参数类型
    T - 该供应商提供的结果类型
    All Known Subinterfaces:
    ServiceLoader.Provider<S>
    所有已知实现类：
    GuardingDynamicLinkerExporter
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Supplier<T>
    代表结果供应商。

    没有要求每次调用供应商时都会返回新的或不同的结果。

    这是一个functional interface的功能方法是get() 。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      T get​()
      获得结果。

    • 方法详细信息

      • get

        T get​()
        获得结果。
        结果
        结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToDoubleBiFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface ToDoubleBiFunction<T,U>

  • 参数类型
    T - 函数的第一个参数的类型
    U - 函数的第二个参数的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ToDoubleBiFunction<T,U>
    表示接受两个参数并产生双值结果的函数。 这是针对double生产原始专业版 。

    这是一个functional interface的功能方法是applyAsDouble(Object, Object) 。

    从以下版本开始：
    1.8
    另请参见：
    BiFunction

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      double applyAsDouble​(T t, U u)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsDouble

        double applyAsDouble​(T t,
                     U u)
        将此函数应用于给定的参数。
        参数
        t - 第一个函数参数
        u - 第二个函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToDoubleFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface ToDoubleFunction<T>

  • 参数类型
    T - 函数输入的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ToDoubleFunction<T>
    表示产生双值结果的函数。 这是double用于制造用原始的专业化Function 。

    这是一个functional interface的功能方法是applyAsDouble(Object) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      double applyAsDouble​(T value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsDouble

        double applyAsDouble​(T value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToIntBiFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface ToIntBiFunction<T,U>

  • 参数类型
    T - 函数的第一个参数的类型
    U - 函数的第二个参数的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ToIntBiFunction<T,U>
    表示一个接受两个参数并产生一个int值结果的函数。 这是int用于制造用原始的专业化BiFunction 。

    这是一个functional interface的功能方法是applyAsInt(Object, Object) 。

    从以下版本开始：
    1.8
    另请参见：
    BiFunction

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int applyAsInt​(T t, U u)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsInt

        int applyAsInt​(T t,
               U u)
        将此函数应用于给定的参数。
        参数
        t - 第一个函数参数
        u - 第二个函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToIntFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface ToIntFunction<T>

  • 参数类型
    T - 函数输入的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ToIntFunction<T>
    表示产生一个int值结果的函数。 这是int用于制造用原始的专业化Function 。

    这是一个functional interface的功能方法是applyAsInt(Object) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int applyAsInt​(T value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsInt

        int applyAsInt​(T value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToLongBiFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface ToLongBiFunction<T,U>

  • 参数类型
    T - 函数的第一个参数的类型
    U - 函数的第二个参数的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ToLongBiFunction<T,U>
    表示接受两个参数并产生长效结果的函数。 这是long用于制造用原始的专业化BiFunction 。

    这是一个functional interface的功能方法是applyAsLong(Object, Object) 。

    从以下版本开始：
    1.8
    另请参见：
    BiFunction

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long applyAsLong​(T t, U u)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsLong

        long applyAsLong​(T t,
                 U u)
        将此函数应用于给定的参数。
        参数
        t - 第一个函数参数
        u - 第二个函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToLongFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface ToLongFunction<T>

  • 参数类型
    T - 函数输入的类型
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ToLongFunction<T>
    表示产生长期效果的函数。 这是long用于制造用原始的专业化Function 。

    这是一个functional interface，其功能方法是applyAsLong(Object) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long applyAsLong​(T value)
      将此函数应用于给定的参数。

    • 方法详细信息

      • applyAsLong

        long applyAsLong​(T value)
        将此函数应用于给定的参数。
        参数
        value - 函数参数
        结果
        功能结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.function

Interface UnaryOperator<T>

  • 参数类型
    T - 操作数的类型和运算符的结果
    All Superinterfaces:
    Function<T,T>
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface UnaryOperator<T>
extends Function<T,T>
    表示对单个操作数产生与其操作数相同类型的结果的操作。 对于操作数和结果是相同类型的情况，这是Function的专业化。

    这是一个functional interface，其功能方法是Function.apply(Object) 。

    从以下版本开始：
    1.8
    另请参见：
    Function

    • 方法摘要

      所有方法 静态方法 Default Methods
      Modifier and Type 方法 描述
      static <T> UnaryOperator<T> identity​()
      返回始终返回其输入参数的一元运算符。

      • Methods inherited from interface java.util.function.Function

        andThen, apply, compose

    • 方法详细信息

      • identity

        static <T> UnaryOperator<T> identity​()
        返回始终返回其输入参数的一元运算符。
        参数类型
        T - 运算符的输入和输出类型
        结果
        总是返回其输入参数的一元运算符
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util.function (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.function

  • Packages that use java.util.function
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.security
    提供安全框架的类和接口。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javax.net.ssl
    为安全套接字包提供类。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.security.jarsigner
  • Classes in java.util.function used by java.lang
    Class 描述
    Consumer
    表示接受单个输入参数并且不返回结果的操作。
    Function
    表示接受一个参数并产生结果的函数。
    Supplier
    代表结果供应商。
  • Classes in java.util.function used by java.lang.module
    Class 描述
    Supplier
    代表结果供应商。
  • Classes in java.util.function used by java.nio.file
    Class 描述
    BiPredicate
    表示两个参数的谓词（布尔值函数）。
  • Classes in java.util.function used by java.security
    Class 描述
    BiConsumer
    表示接受两个输入参数并且不返回结果的操作。
    BiFunction
    表示接受两个参数并产生结果的函数。
    Function
    表示接受一个参数并产生结果的函数。
  • Classes in java.util.function used by java.time.temporal
    Class 描述
    UnaryOperator
    表示对单个操作数产生与其操作数相同类型的结果的操作。
  • Classes in java.util.function used by java.util
    Class 描述
    BiConsumer
    表示接受两个输入参数并且不返回结果的操作。
    BiFunction
    表示接受两个参数并产生结果的函数。
    BinaryOperator
    表示对同一类型的两个操作数的操作，产生与操作数相同类型的结果。
    Consumer
    表示接受单个输入参数并且不返回结果的操作。
    DoubleBinaryOperator
    表示对两个 double值操作数的操作，并产生一个 double结果。
    DoubleConsumer
    表示接受一个 double值的参数并且不返回结果的操作。
    DoubleSupplier
    代表 double结果的供应商。
    Function
    表示接受一个参数并产生结果的函数。
    IntBinaryOperator
    代表两个 int操作数的操作，并产生一个 int结果。
    IntConsumer
    表示接受单个 int参数的操作，并且不返回任何结果。
    IntFunction
    表示一个接受int值参数并产生结果的函数。
    IntSupplier
    代表 int结果。
    IntToDoubleFunction
    表示接受一个int值参数并产生一个双值结果的函数。
    IntToLongFunction
    表示接受一个int值参数并产生一个长效结果的函数。
    IntUnaryOperator
    代表一个 int值操作数的操作，产生一个 int结果。
    LongBinaryOperator
    表示对两个 long值操作数的操作，并产生一个 long结果。
    LongConsumer
    表示接受单个 long值参数的操作，不返回结果。
    LongSupplier
    代表 long结果。
    Predicate
    表示一个参数的谓词（布尔值函数）。
    Supplier
    代表结果供应商。
    ToDoubleFunction
    表示产生双值结果的函数。
    ToIntFunction
    表示产生一个int值结果的函数。
    ToLongFunction
    表示产生长期效果的函数。
    UnaryOperator
    表示对单个操作数产生与其操作数相同类型的结果的操作。
  • Classes in java.util.function used by java.util.concurrent
    Class 描述
    BiConsumer
    表示接受两个输入参数并且不返回结果的操作。
    BiFunction
    表示接受两个参数并产生结果的函数。
    BiPredicate
    表示两个参数的谓词（布尔值函数）。
    Consumer
    表示接受单个输入参数并且不返回结果的操作。
    DoubleBinaryOperator
    代表两个 double操作数的操作，并产生 double结果。
    Function
    表示接受一个参数并产生结果的函数。
    IntBinaryOperator
    代表两个 int操作数的操作，并产生一个 int结果。
    LongBinaryOperator
    代表两个 long操作数的操作，并产生一个 long结果。
    Predicate
    表示一个参数的谓词（布尔值函数）。
    Supplier
    代表结果供应商。
    ToDoubleBiFunction
    表示接受两个参数并产生双值结果的函数。
    ToDoubleFunction
    表示产生双值结果的函数。
    ToIntBiFunction
    表示一个接受两个参数并产生一个int值结果的函数。
    ToIntFunction
    表示产生一个int值结果的函数。
    ToLongBiFunction
    表示接受两个参数并产生长效结果的函数。
    ToLongFunction
    表示产生长期效果的函数。
    UnaryOperator
    表示对单个操作数产生与其操作数相同类型的结果的操作。
  • Classes in java.util.function used by java.util.concurrent.atomic
    Class 描述
    BinaryOperator
    表示对同一类型的两个操作数的操作，产生与操作数相同类型的结果。
    DoubleBinaryOperator
    代表两个 double操作数的操作，并产生 double结果。
    IntBinaryOperator
    代表两个 int操作数的操作，并产生一个 int结果。
    IntUnaryOperator
    代表产生一个 int值的操作数的单个 int操作数的操作。
    LongBinaryOperator
    代表对两个 long操作数的操作，并产生一个 long结果。
    LongUnaryOperator
    表示对单个 long值操作数的操作，产生一个 long值结果。
    UnaryOperator
    表示对单个操作数产生与其操作数相同类型的结果的操作。
  • Classes in java.util.function used by java.util.function
    Class 描述
    BiConsumer
    表示接受两个输入参数并且不返回结果的操作。
    BiFunction
    表示接受两个参数并产生结果的函数。
    BinaryOperator
    表示对同一类型的两个操作数的操作，产生与操作数相同类型的结果。
    BiPredicate
    表示两个参数的谓词（布尔值函数）。
    Consumer
    表示接受单个输入参数并且不返回结果的操作。
    DoubleConsumer
    表示接受单个 double参数的操作，不返回任何结果。
    DoublePredicate
    表示一个 double值参数的谓词（布尔值函数）。
    DoubleUnaryOperator
    表示对一个 double值的操作数的操作，产生一个 double结果。
    Function
    表示接受一个参数并产生结果的函数。
    IntConsumer
    表示接受单个 int参数的操作，并且不返回任何结果。
    IntPredicate
    表示一个 int值参数的谓词（布尔值函数）。
    IntUnaryOperator
    表示对单个 int值操作数的操作，产生一个 int结果。
    LongConsumer
    表示接受单个 long参数的操作，并且不返回任何结果。
    LongPredicate
    表示一个 long值参数的谓词（布尔值函数）。
    LongUnaryOperator
    表示对一个 long值的操作数的操作，产生一个 long结果。
    Predicate
    表示一个参数的谓词（布尔值函数）。
    UnaryOperator
    表示对单个操作数产生与其操作数相同类型的结果的操作。
  • Classes in java.util.function used by java.util.logging
    Class 描述
    BiFunction
    表示接受两个参数并产生结果的函数。
    Function
    表示接受一个参数并产生结果的函数。
    Supplier
    代表结果供应商。
  • Classes in java.util.function used by java.util.regex
    Class 描述
    Function
    表示接受一个参数并产生结果的函数。
    Predicate
    表示一个参数的谓词（布尔值函数）。
  • Classes in java.util.function used by java.util.stream
    Class 描述
    BiConsumer
    表示接受两个输入参数并且不返回结果的操作。
    BiFunction
    表示接受两个参数并产生结果的函数。
    BinaryOperator
    表示对同一类型的两个操作数的操作，产生与操作数相同类型的结果。
    Consumer
    表示接受单个输入参数并且不返回结果的操作。
    DoubleBinaryOperator
    代表对两个 double操作数的操作，并产生一个 double结果。
    DoubleConsumer
    表示接受单个 double参数的操作，并且不返回任何结果。
    DoubleFunction
    表示接受双值参数并产生结果的函数。
    DoublePredicate
    表示一个 double值参数的谓词（布尔值函数）。
    DoubleSupplier
    代表 double结果的供应商。
    DoubleToIntFunction
    表示接受双值参数并产生int值结果的函数。
    DoubleToLongFunction
    表示接受双值参数并产生长期值结果的函数。
    DoubleUnaryOperator
    表示对一个 double值的操作数的操作，产生一个 double结果。
    Function
    表示接受一个参数并产生结果的函数。
    IntBinaryOperator
    代表两个 int操作数的操作，并产生一个 int结果。
    IntConsumer
    表示接受单个 int值参数的操作，并且不返回任何结果。
    IntFunction
    表示一个接受int值参数并产生结果的函数。
    IntPredicate
    表示一个 int值参数的谓词（布尔值函数）。
    IntSupplier
    代表 int结果。
    IntToDoubleFunction
    表示接受一个int值参数并产生一个双值结果的函数。
    IntToLongFunction
    表示接受一个int值参数并产生一个长效结果的函数。
    IntUnaryOperator
    表示对单个 int值操作数的操作，产生一个 int值结果。
    LongBinaryOperator
    表示对两个 long值操作数的操作，并产生一个 long结果。
    LongConsumer
    表示接受单个 long参数的操作，并且不返回任何结果。
    LongFunction
    表示接受长期参数并产生结果的函数。
    LongPredicate
    表示一个 long值参数的谓词（布尔值函数）。
    LongSupplier
    代表 long结果。
    LongToDoubleFunction
    表示接受长期参数并产生双值结果的函数。
    LongToIntFunction
    表示接受长值参数并产生int值结果的函数。
    LongUnaryOperator
    表示对单个 long值的操作数的操作，产生一个 long值结果。
    ObjDoubleConsumer
    表示接受对象值和 double值参数的操作，并且不返回任何结果。
    ObjIntConsumer
    表示接受对象值和 int值参数的操作，并且不返回任何结果。
    ObjLongConsumer
    表示接受对象值的操作和 long参数，并且不返回结果。
    Predicate
    表示一个参数的谓词（布尔值函数）。
    Supplier
    代表结果供应商。
    ToDoubleFunction
    表示产生双值结果的函数。
    ToIntFunction
    表示产生一个int值结果的函数。
    ToLongFunction
    表示产生长期效果的函数。
    UnaryOperator
    表示对单个操作数产生与其操作数相同类型的结果的操作。
  • Classes in java.util.function used by javafx.collections
    Class 描述
    Predicate
    表示一个参数的谓词（布尔值函数）。
  • Classes in java.util.function used by javafx.collections.transformation
    Class 描述
    Predicate
    表示一个参数的谓词（布尔值函数）。
  • Classes in java.util.function used by javafx.css
    Class 描述
    Function
    表示接受一个参数并产生结果的函数。
  • Classes in java.util.function used by javafx.scene.control
    Class 描述
    Consumer
    表示接受单个输入参数并且不返回结果的操作。
    UnaryOperator
    表示对单个操作数产生与其操作数相同类型的结果的操作。
  • Classes in java.util.function used by javax.net.ssl
    Class 描述
    BiFunction
    表示接受两个参数并产生结果的函数。
  • Classes in java.util.function used by jdk.dynalink.linker
    Class 描述
    Supplier
    代表结果供应商。
  • Classes in java.util.function used by jdk.incubator.http
    Class 描述
    Consumer
    表示接受单个输入参数并且不返回结果的操作。
    Function
    表示接受一个参数并产生结果的函数。
    Supplier
    代表结果供应商。
  • Classes in java.util.function used by jdk.jshell
    Class 描述
    BiFunction
    表示接受两个参数并产生结果的函数。
    Consumer
    表示接受单个输入参数并且不返回结果的操作。
    Function
    表示接受一个参数并产生结果的函数。
    Supplier
    代表结果供应商。
  • Classes in java.util.function used by jdk.jshell.execution
    Class 描述
    BiFunction
    表示接受两个参数并产生结果的函数。
    Consumer
    表示接受单个输入参数并且不返回结果的操作。
  • Classes in java.util.function used by jdk.security.jarsigner
    Class 描述
    BiConsumer
    表示接受两个输入参数并且不返回结果的操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.BiConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.BiConsumer

  • Packages that use BiConsumer
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    jdk.security.jarsigner

    • Uses of BiConsumer in java.security

      Methods in java.security with parameters of type BiConsumer
      Modifier and Type | 方法 | 描述
      void | Provider.forEach​(BiConsumer<? super Object,? super Object> action)

    • Uses of BiConsumer in java.util

      Methods in java.util with parameters of type BiConsumer
      Modifier and Type | 方法 | 描述
      void | HashMap.forEach​(BiConsumer<? super K,? super V> action)
      void | Hashtable.forEach​(BiConsumer<? super K,? super V> action)
      void | IdentityHashMap.forEach​(BiConsumer<? super K,? super V> action)
      void | LinkedHashMap.forEach​(BiConsumer<? super K,? super V> action)
      default void Map.forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      void | Properties.forEach​(BiConsumer<? super Object,? super Object> action)
      void | TreeMap.forEach​(BiConsumer<? super K,? super V> action)
      void | WeakHashMap.forEach​(BiConsumer<? super K,? super V> action)

    • Uses of BiConsumer in java.util.concurrent

      Methods in java.util.concurrent with parameters of type BiConsumer
      Modifier and Type | 方法 | 描述
      void ConcurrentHashMap.forEach​(long parallelismThreshold, BiConsumer<? super K,? super V> action)
      对每个（键，值）执行给定的动作。
      void | ConcurrentHashMap.forEach​(BiConsumer<? super K,? super V> action)
      default void ConcurrentMap.forEach​(BiConsumer<? super K,? super V> action)
      对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
      void | ConcurrentSkipListMap.forEach​(BiConsumer<? super K,? super V> action)
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      <U> CompletionStage<Void> CompletionStage.thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供的操作的参数被执行。
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      <U> CompletionStage<Void> CompletionStage.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供的操作的参数。
      <U> CompletionStage<Void> CompletionStage.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。
      CompletableFuture<T> | CompletableFuture.whenComplete​(BiConsumer<? super T,? super Throwable> action)
      CompletionStage<T> CompletionStage.whenComplete​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同的结果或异常的新CompletionStage，当此阶段完成时，它将执行给定的操作。
      CompletableFuture<T> | CompletableFuture.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
      CompletableFuture<T> | CompletableFuture.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      CompletionStage<T> CompletionStage.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，将使用此阶段的默认异步执行工具执行给定操作。
      CompletionStage<T> CompletionStage.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，使用提供的执行程序执行给定操作。
      Constructors in java.util.concurrent with parameters of type BiConsumer
      Constructor 描述
      SubmissionPublisher​(Executor executor, int maxBufferCapacity, BiConsumer<? super Flow.Subscriber<? super T>,? super Throwable> handler)
      使用给定的Executor创建一个新的SubmissionPublisher，为订户提供异步传递，给定每个订户的最大缓冲区大小，如果非空，则在任何订阅者在方法 onNext中引发异常时调用给定的处理程序。

    • Uses of BiConsumer in java.util.function

      Methods in java.util.function that return BiConsumer
      Modifier and Type 方法 描述
      default BiConsumer<T,U> BiConsumer.andThen​(BiConsumer<? super T,? super U> after)
      返回一个组成的 BiConsumer ，依次执行该操作，后跟 after操作。
      Methods in java.util.function with parameters of type BiConsumer
      Modifier and Type 方法 描述
      default BiConsumer<T,U> BiConsumer.andThen​(BiConsumer<? super T,? super U> after)
      返回一个组合的 BiConsumer ，依次执行该操作，然后执行 after操作。

    • Uses of BiConsumer in java.util.stream

      Methods in java.util.stream that return BiConsumer
      Modifier and Type 方法 描述
      BiConsumer<A,T> Collector.accumulator​()
      将值折叠成可变结果容器的函数。
      Methods in java.util.stream with parameters of type BiConsumer
      Modifier and Type 方法 描述
      <R> R DoubleStream.collect​(Supplier<R> supplier, ObjDoubleConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      <R> R IntStream.collect​(Supplier<R> supplier, ObjIntConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      <R> R LongStream.collect​(Supplier<R> supplier, ObjLongConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      <R> R Stream.collect​(Supplier<R> supplier, BiConsumer<R,? super T> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      static <T,A,R> Collector<T,A,R> Collector.of​(Supplier<A> supplier, BiConsumer<A,T> accumulator, BinaryOperator<A> combiner, Function<A,R> finisher, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ， combiner ，并 finisher功能。
      static <T,R> Collector<T,R,R> Collector.of​(Supplier<R> supplier, BiConsumer<R,T> accumulator, BinaryOperator<R> combiner, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ，并 combiner功能。

    • Uses of BiConsumer in jdk.security.jarsigner

      Methods in jdk.security.jarsigner with parameters of type BiConsumer
      Modifier and Type 方法 描述
      JarSigner.Builder JarSigner.Builder.eventHandler​(BiConsumer<String,String> handler)
      Sets en event handler that will be triggered when a JarEntry is to be added, signed, or updated during the signing process.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.BiFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.BiFunction

  • Packages that use BiFunction
    软件包 描述
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javax.net.ssl
    为安全套接字包提供类。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。

    • Uses of BiFunction in java.security

      Methods in java.security with parameters of type BiFunction
      Modifier and Type 方法 描述
      Object Provider.compute​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      Object Provider.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      Object Provider.merge​(Object key, Object value, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)
      如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。
      void Provider.replaceAll​(BiFunction<? super Object,? super Object,? extends Object> function)
      用条目集迭代器返回的顺序，直到所有的条目都被处理或函数抛出一个异常，替换每个条目的值，结果是对该条目调用给定的函数。

    • Uses of BiFunction in java.util

      Methods in java.util with parameters of type BiFunction
      Modifier and Type | 方法 | 描述
      V HashMap.compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      V Hashtable.compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定键的映射及其当前映射的值（如果没有当前映射， null ）。
      default V Map.compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定键的映射及其当前映射值（如果没有当前映射，则 null ）。
      Object | Properties.compute​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)
      V HashMap.computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      V Hashtable.computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      default V Map.computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      Object | Properties.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)
      V HashMap.merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
      V Hashtable.merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
      default V Map.merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
      Object | Properties.merge​(Object key, Object value, BiFunction<? super Object,? super Object,?> remappingFunction)
      void | HashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      void | Hashtable.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      void | IdentityHashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      void | LinkedHashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      default void Map.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      void | Properties.replaceAll​(BiFunction<? super Object,? super Object,?> function)
      void | TreeMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      void | WeakHashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)

    • Uses of BiFunction in java.util.concurrent

      Methods in java.util.concurrent with parameters of type BiFunction
      Modifier and Type | 方法 | 描述
      V ConcurrentHashMap.compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      default V ConcurrentMap.compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      V ConcurrentSkipListMap.compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。
      V ConcurrentHashMap.computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果存在指定键的值，则尝试计算给出键的新映射及其当前映射值。
      default V ConcurrentMap.computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。
      V ConcurrentSkipListMap.computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)
      如果存在指定键的值，则尝试计算给出键的新映射及其当前映射值。
      <U> void ConcurrentHashMap.forEach​(long parallelismThreshold, BiFunction<? super K,? super V,? extends U> transformer, Consumer<? super U> action)
      对每个（key，value）的每个非空变换执行给定的动作。
      <U> CompletableFuture<U> | CompletableFuture.handle​(BiFunction<? super T,Throwable,? extends U> fn)
      <U> CompletionStage<U> CompletionStage.handle​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用此阶段的结果和异常作为所提供函数的参数执行。
      <U> CompletableFuture<U> | CompletableFuture.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
      <U> CompletableFuture<U> | CompletableFuture.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当该阶段完成正常或异常时，将使用此阶段的默认异步执行工具执行，此阶段的结果和异常作为提供函数的参数。
      <U> CompletionStage<U> CompletionStage.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用提供的执行程序执行此阶段的结果和异常作为提供的函数的参数。
      V ConcurrentHashMap.merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与（非空）值相关联，则将其与给定值相关联。
      default V ConcurrentMap.merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
      V ConcurrentSkipListMap.merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)
      如果指定的键尚未与值相关联，则将其与给定值相关联。
      <U> U ConcurrentHashMap.reduce​(long parallelismThreshold, BiFunction<? super K,? super V,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到组合值的结果，如果没有则返回null。
      Map.Entry<K,V> ConcurrentHashMap.reduceEntries​(long parallelismThreshold, BiFunction<Map.Entry<K,V>,Map.Entry<K,V>,? extends Map.Entry<K,V>> reducer)
      返回使用给定的reducer累加所有条目的结果，以组合值，如果没有则返回null。
      <U> U ConcurrentHashMap.reduceEntries​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer将所有条目的给定变换累加到组合值的结果，否则返回null。
      K ConcurrentHashMap.reduceKeys​(long parallelismThreshold, BiFunction<? super K,? super K,? extends K> reducer)
      返回使用给定的reducer累加所有键的结果，以组合值，如果没有则返回null。
      <U> U ConcurrentHashMap.reduceKeys​(long parallelismThreshold, Function<? super K,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer将所有键的给定变换累加到组合值的结果，否则返回null。
      V ConcurrentHashMap.reduceValues​(long parallelismThreshold, BiFunction<? super V,? super V,? extends V> reducer)
      返回使用给定的reducer累加所有值的结果，以组合值，如果没有则返回null。
      <U> U ConcurrentHashMap.reduceValues​(long parallelismThreshold, Function<? super V,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer累加所有值的给定变换以组合值的结果，否则返回null。
      void | ConcurrentHashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      default void ConcurrentMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
      void | ConcurrentSkipListMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      <U> U ConcurrentHashMap.search​(long parallelismThreshold, BiFunction<? super K,? super V,? extends U> searchFunction)
      通过在每个（键，值）上应用给定的搜索函数返回非空结果，如果没有则返回null。
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombine​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      <U,V> CompletionStage<V> CompletionStage.thenCombine​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供函数的参数执行。
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      <U,V> CompletableFuture<V> | CompletableFuture.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      <U,V> CompletionStage<V> CompletionStage.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供函数的参数。
      <U,V> CompletionStage<V> CompletionStage.thenCombineAsync​(CompletionStage<? extends U> other, BiFunction<? super T,? super U,? extends V> fn, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行，其中两个结果作为提供的函数的参数。

    • Uses of BiFunction in java.util.function

      Subinterfaces of BiFunction in java.util.function
      Modifier and Type 接口 描述
      interface  BinaryOperator<T>
      表示对同一类型的两个操作数的操作，产生与操作数相同类型的结果。
      Methods in java.util.function that return BiFunction
      Modifier and Type 方法 描述
      default <V> BiFunction<T,U,V> BiFunction.andThen​(Function<? super R,? extends V> after)
      返回一个组合函数，首先将该函数应用于其输入，然后将 after函数应用于结果。

    • Uses of BiFunction in java.util.logging

      Method parameters in java.util.logging with type arguments of type BiFunction
      Modifier and Type 方法 描述
      void LogManager.updateConfiguration​(InputStream ins, Function<String,BiFunction<String,String,String>> mapper)
      更新日志记录配置。
      void LogManager.updateConfiguration​(Function<String,BiFunction<String,String,String>> mapper)
      更新日志记录配置。

    • Uses of BiFunction in java.util.stream

      Methods in java.util.stream with parameters of type BiFunction
      Modifier and Type 方法 描述
      <U> U Stream.reduce​(U identity, BiFunction<U,? super T,U> accumulator, BinaryOperator<U> combiner)
      使用提供的身份，积累和组合功能，对此流的元素执行 reduction 。

    • Uses of BiFunction in javax.net.ssl

      Methods in javax.net.ssl that return BiFunction
      Modifier and Type 方法 描述
      BiFunction<SSLEngine,List<String>,String> SSLEngine.getHandshakeApplicationProtocolSelector​()
      检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。
      BiFunction<SSLSocket,List<String>,String> SSLSocket.getHandshakeApplicationProtocolSelector​()
      检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。
      Methods in javax.net.ssl with parameters of type BiFunction
      Modifier and Type 方法 描述
      void SSLEngine.setHandshakeApplicationProtocolSelector​(BiFunction<SSLEngine,List<String>,String> selector)
      注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。
      void SSLSocket.setHandshakeApplicationProtocolSelector​(BiFunction<SSLSocket,List<String>,String> selector)
      注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。

    • Uses of BiFunction in jdk.jshell

      Methods in jdk.jshell with parameters of type BiFunction
      Modifier and Type 方法 描述
      JShell.Builder JShell.Builder.idGenerator​(BiFunction<Snippet,Integer,String> generator)
      设置代码段识别名称的生成器。

    • Uses of BiFunction in jdk.jshell.execution

      Methods in jdk.jshell.execution with parameters of type BiFunction
      Modifier and Type 方法 描述
      static ExecutionControl Util.remoteInputOutput​(InputStream input, OutputStream output, Map<String,OutputStream> outputStreamMap, Map<String,InputStream> inputStreamMap, BiFunction<ObjectInput,ObjectOutput,ExecutionControl> factory)
      为给定的分组化输入和输出创建一个ExecutionControl。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.BinaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.BinaryOperator

  • Packages that use BinaryOperator
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of BinaryOperator in java.util

      Methods in java.util with parameters of type BinaryOperator
      Modifier and Type 方法 描述
      static <T> void Arrays.parallelPrefix​(T[] array, int fromIndex, int toIndex, BinaryOperator<T> op)
      对于数组的给定子范围执行 Arrays.parallelPrefix(Object[], BinaryOperator) 。
      static <T> void Arrays.parallelPrefix​(T[] array, BinaryOperator<T> op)
      使用提供的功能，并行地计算给定阵列的每个元素。

    • Uses of BinaryOperator in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic with parameters of type BinaryOperator
      Modifier and Type 方法 描述
      V AtomicReference.accumulateAndGet​(V x, BinaryOperator<V> accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值的原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回更新后的值。
      E AtomicReferenceArray.accumulateAndGet​(int i, E x, BinaryOperator<E> accumulatorFunction)
      将索引号为 i的元素原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），并将给定的函数应用于当前值和给定值，返回更新后的值。
      V AtomicReferenceFieldUpdater.accumulateAndGet​(T obj, V x, BinaryOperator<V> accumulatorFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。
      V AtomicReference.getAndAccumulate​(V x, BinaryOperator<V> accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回上一个值。
      E AtomicReferenceArray.getAndAccumulate​(int i, E x, BinaryOperator<E> accumulatorFunction)
      将索引号为 i的元素原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），并将给定的函数应用于当前值和给定值，返回上一个值。
      V AtomicReferenceFieldUpdater.getAndAccumulate​(T obj, V x, BinaryOperator<V> accumulatorFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。

    • Uses of BinaryOperator in java.util.function

      Methods in java.util.function that return BinaryOperator
      Modifier and Type 方法 描述
      static <T> BinaryOperator<T> BinaryOperator.maxBy​(Comparator<? super T> comparator)
      返回一个BinaryOperator ，它根据指定的Comparator返回两个元素中的较大者。
      static <T> BinaryOperator<T> BinaryOperator.minBy​(Comparator<? super T> comparator)
      返回一个BinaryOperator ，它根据指定的Comparator返回两个元素中的较小者。

    • Uses of BinaryOperator in java.util.stream

      Methods in java.util.stream that return BinaryOperator
      Modifier and Type 方法 描述
      BinaryOperator<A> Collector.combiner​()
      一个接受两个部分结果并将其合并的函数。
      Methods in java.util.stream with parameters of type BinaryOperator
      Modifier and Type 方法 描述
      static <T,A,R> Collector<T,A,R> Collector.of​(Supplier<A> supplier, BiConsumer<A,T> accumulator, BinaryOperator<A> combiner, Function<A,R> finisher, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ， combiner ，并 finisher功能。
      static <T,R> Collector<T,R,R> Collector.of​(Supplier<R> supplier, BiConsumer<R,T> accumulator, BinaryOperator<R> combiner, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ，并 combiner功能。
      Optional<T> Stream.reduce​(BinaryOperator<T> accumulator)
      使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值（如果有）的 Optional 。
      T Stream.reduce​(T identity, BinaryOperator<T> accumulator)
      使用提供的身份值和 associative累积功能对此流的元素执行 reduction ，并返回减小的值。
      <U> U Stream.reduce​(U identity, BiFunction<U,? super T,U> accumulator, BinaryOperator<U> combiner)
      使用提供的身份，积累和组合功能，对此流的元素执行 reduction 。
      static <T> Collector<T,?,Optional<T>> Collectors.reducing​(BinaryOperator<T> op)
      返回一个 Collector ，它在指定的 BinaryOperator下执行其输入元素的减少。
      static <T> Collector<T,?,T> Collectors.reducing​(T identity, BinaryOperator<T> op)
      返回一个 Collector ，它使用提供的身份在指定的 BinaryOperator下执行其输入元素的减少。
      static <T,U> Collector<T,?,U> Collectors.reducing​(U identity, Function<? super T,? extends U> mapper, BinaryOperator<U> op)
      返回一个 Collector ，它在指定的映射函数和 BinaryOperator下执行其输入元素的减少。
      static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。
      static <T,K,U,M extends ConcurrentMap<K,U>>
      Collector<T,?,M>             		Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,Map<K,U>> Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U,M extends Map<K,U>>
      Collector<T,?,M>             		Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.BiPredicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.BiPredicate

  • Packages that use BiPredicate
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。

    • Uses of BiPredicate in java.nio.file

      Methods in java.nio.file with parameters of type BiPredicate
      Modifier and Type 方法 描述
      static Stream<Path> Files.find​(Path start, int maxDepth, BiPredicate<Path,BasicFileAttributes> matcher, FileVisitOption... options)
      返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件来懒惰地填充 Path 。

    • Uses of BiPredicate in java.util.concurrent

      Methods in java.util.concurrent with parameters of type BiPredicate
      Modifier and Type 方法 描述
      int SubmissionPublisher.offer​(T item, long timeout, TimeUnit unit, BiPredicate<Flow.Subscriber<? super T>,? super T> onDrop)
      如果可能的话，通过异步调用其 onNext方法来发布给定的项目，阻止当任何订阅的资源不可用时，直到指定的超时或直到调用者线程被中断，此时给定的处理程序-null）被调用，如果返回true，则重试一次。
      int SubmissionPublisher.offer​(T item, BiPredicate<Flow.Subscriber<? super T>,? super T> onDrop)
      如果可能，通过异步调用其 onNext方法将每个当前用户发布给定项目。

    • Uses of BiPredicate in java.util.function

      Methods in java.util.function that return BiPredicate
      Modifier and Type 方法 描述
      default BiPredicate<T,U> BiPredicate.and​(BiPredicate<? super T,? super U> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default BiPredicate<T,U> BiPredicate.negate​()
      返回表示此谓词的逻辑否定的谓词。
      default BiPredicate<T,U> BiPredicate.or​(BiPredicate<? super T,? super U> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      Methods in java.util.function with parameters of type BiPredicate
      Modifier and Type 方法 描述
      default BiPredicate<T,U> BiPredicate.and​(BiPredicate<? super T,? super U> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default BiPredicate<T,U> BiPredicate.or​(BiPredicate<? super T,? super U> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.BooleanSupplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.BooleanSupplier

No usage of java.util.function.BooleanSupplier
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.Consumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.Consumer

  • Packages that use Consumer
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。

    • Uses of Consumer in java.lang

      Methods in java.lang with parameters of type Consumer
      Modifier and Type 方法 描述
      default void Iterable.forEach​(Consumer<? super T> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      void StackWalker.forEach​(Consumer<? super StackWalker.StackFrame> action)
      对当前线程的 StackFrame流的每个元素执行给定的动作，从堆栈的顶部框架遍历，这是调用此 forEach方法的方法。

    • Uses of Consumer in java.util

      Methods in java.util with parameters of type Consumer
      Modifier and Type | 方法 | 描述
      void | ArrayDeque.forEach​(Consumer<? super E> action)
      void | ArrayList.forEach​(Consumer<? super E> action)
      void | Vector.forEach​(Consumer<? super E> action)
      default void Iterator.forEachRemaining​(Consumer<? super E> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void PrimitiveIterator.OfDouble.forEachRemaining​(Consumer<? super Double> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void PrimitiveIterator.OfInt.forEachRemaining​(Consumer<? super Integer> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void PrimitiveIterator.OfLong.forEachRemaining​(Consumer<? super Long> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void Spliterator.forEachRemaining​(Consumer<? super T> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default void Spliterator.OfDouble.forEachRemaining​(Consumer<? super Double> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default void Spliterator.OfInt.forEachRemaining​(Consumer<? super Integer> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default void Spliterator.OfLong.forEachRemaining​(Consumer<? super Long> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      void Optional.ifPresent​(Consumer<? super T> action)
      如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
      void Optional.ifPresentOrElse​(Consumer<? super T> action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      default boolean Spliterator.OfDouble.tryAdvance​(Consumer<? super Double> action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。
      default boolean Spliterator.OfInt.tryAdvance​(Consumer<? super Integer> action)
      如果剩下的元素存在，执行给定的动作，返回true ; 否则返回false 。
      default boolean Spliterator.OfLong.tryAdvance​(Consumer<? super Long> action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。
      boolean Spliterator.tryAdvance​(Consumer<? super T> action)
      如果剩余的元素存在，执行给定的操作，返回true ; 否则返回false 。

    • Uses of Consumer in java.util.concurrent

      Methods in java.util.concurrent with parameters of type Consumer
      Modifier and Type | 方法 | 描述
      CompletableFuture<Void> | CompletableFuture.acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      CompletionStage<Void> CompletionStage.acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的操作的参数。
      CompletableFuture<Void> | CompletableFuture.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      CompletableFuture<Void> | CompletableFuture.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      CompletionStage<Void> CompletionStage.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供的操作的参数。
      CompletionStage<Void> CompletionStage.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。
      CompletableFuture<Void> SubmissionPublisher.consume​(Consumer<? super T> consumer)
      使用给定的Consumer功能处理所有已发布的项目。
      void | ArrayBlockingQueue.forEach​(Consumer<? super E> action)
      <U> void ConcurrentHashMap.forEach​(long parallelismThreshold, BiFunction<? super K,? super V,? extends U> transformer, Consumer<? super U> action)
      对每个（key，value）的每个非空变换执行给定的动作。
      void | ConcurrentHashMap.KeySetView.forEach​(Consumer<? super K> action)
      void | ConcurrentLinkedDeque.forEach​(Consumer<? super E> action)
      void | ConcurrentLinkedQueue.forEach​(Consumer<? super E> action)
      void | CopyOnWriteArrayList.forEach​(Consumer<? super E> action)
      void | CopyOnWriteArraySet.forEach​(Consumer<? super E> action)
      void | LinkedBlockingDeque.forEach​(Consumer<? super E> action)
      void | LinkedBlockingQueue.forEach​(Consumer<? super E> action)
      void | LinkedTransferQueue.forEach​(Consumer<? super E> action)
      void ConcurrentHashMap.forEachEntry​(long parallelismThreshold, Consumer<? super Map.Entry<K,V>> action)
      对每个条目执行给定的操作。
      <U> void ConcurrentHashMap.forEachEntry​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> transformer, Consumer<? super U> action)
      对每个条目的每个非空变换执行给定的操作。
      void ConcurrentHashMap.forEachKey​(long parallelismThreshold, Consumer<? super K> action)
      对每个键执行给定的动作。
      <U> void ConcurrentHashMap.forEachKey​(long parallelismThreshold, Function<? super K,? extends U> transformer, Consumer<? super U> action)
      对每个键的每个非空变换执行给定的动作。
      void ConcurrentHashMap.forEachValue​(long parallelismThreshold, Consumer<? super V> action)
      对每个值执行给定的操作。
      <U> void ConcurrentHashMap.forEachValue​(long parallelismThreshold, Function<? super V,? extends U> transformer, Consumer<? super U> action)
      对每个值的每个非空转换执行给定的动作。
      CompletableFuture<Void> | CompletableFuture.thenAccept​(Consumer<? super T> action)
      CompletionStage<Void> CompletionStage.thenAccept​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，以该阶段的结果作为提供的操作的参数执行。
      CompletableFuture<Void> | CompletableFuture.thenAcceptAsync​(Consumer<? super T> action)
      CompletableFuture<Void> | CompletableFuture.thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      CompletionStage<Void> CompletionStage.thenAcceptAsync​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用此阶段的默认异步执行工具执行，此阶段的结果作为提供的操作的参数。
      CompletionStage<Void> CompletionStage.thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供的操作的参数。

    • Uses of Consumer in java.util.function

      Methods in java.util.function that return Consumer
      Modifier and Type 方法 描述
      default Consumer<T> Consumer.andThen​(Consumer<? super T> after)
      返回一个组成的 Consumer ，依次执行此操作，然后执行 after操作。
      Methods in java.util.function with parameters of type Consumer
      Modifier and Type 方法 描述
      default Consumer<T> Consumer.andThen​(Consumer<? super T> after)
      返回一个组成的 Consumer ，依次执行该操作，然后执行 after操作。

    • Uses of Consumer in java.util.stream

      Subinterfaces of Consumer in java.util.stream
      Modifier and Type 接口 描述
      static interface  Stream.Builder<T>
      一个可变的构建器为 Stream 。
      Methods in java.util.stream with parameters of type Consumer
      Modifier and Type 方法 描述
      void Stream.forEach​(Consumer<? super T> action)
      对此流的每个元素执行操作。
      void Stream.forEachOrdered​(Consumer<? super T> action)
      如果流具有定义的遇到顺序，则以流的遇到顺序对该流的每个元素执行操作。
      Stream<T> Stream.peek​(Consumer<? super T> action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。

    • Uses of Consumer in javafx.scene.control

      Methods in javafx.scene.control that return Consumer
      Modifier and Type 方法 描述
      protected Consumer<ObservableValue<?>> SkinBase.unregisterChangeListeners​(ObservableValue<?> property)
      取消注册已使用 SkinBase.registerChangeListener(ObservableValue, Consumer)注册的所有更改侦听器的给定属性。
      Methods in javafx.scene.control with parameters of type Consumer
      Modifier and Type 方法 描述
      protected void SkinBase.registerChangeListener​(ObservableValue<?> property, Consumer<ObservableValue<?>> consumer)
      子类可以调用此方法来注册他们想要监听给定属性的属性更改事件。

    • Uses of Consumer in jdk.incubator.http

      Methods in jdk.incubator.http with parameters of type Consumer
      Modifier and Type 方法 描述
      static HttpResponse.BodyHandler<Void> HttpResponse.BodyHandler.asByteArrayConsumer​(Consumer<Optional<byte[]>> consumer)
      返回一个BodyHandler<Void> ，返回一个从 <Void>获得的BodyProcessor <Void> 。
      static HttpResponse.BodyProcessor<Void> HttpResponse.BodyProcessor.asByteArrayConsumer​(Consumer<Optional<byte[]>> consumer)
      返回一个 BodyProcessor ，它将提供的传入身体数据提供给所提供的消费者 Optional<byte[]> 。

    • Uses of Consumer in jdk.jshell

      Methods in jdk.jshell with parameters of type Consumer
      Modifier and Type 方法 描述
      JShell.Subscription JShell.onShutdown​(Consumer<JShell> listener)
      当JShell实例终止时，注册要调用的回调。
      JShell.Subscription JShell.onSnippetEvent​(Consumer<SnippetEvent> listener)
      当代码段的状态更改时，注册要调用的回调。

    • Uses of Consumer in jdk.jshell.execution

      Methods in jdk.jshell.execution with parameters of type Consumer
      Modifier and Type 方法 描述
      static void Util.detectJdiExitEvent​(VirtualMachine vm, Consumer<String> unbiddenExitHandler)
      监视JDI事件流VMDeathEvent和VMDisconnectEvent 。
      Method parameters in jdk.jshell.execution with type arguments of type Consumer
      Modifier and Type 方法 描述
      static void Util.forwardExecutionControlAndIO​(ExecutionControl ec, InputStream inStream, OutputStream outStream, Map<String,Consumer<OutputStream>> outputStreamMap, Map<String,Consumer<InputStream>> inputStreamMap)
      将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.DoubleBinaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.DoubleBinaryOperator

  • Packages that use DoubleBinaryOperator
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleBinaryOperator in java.util

      Methods in java.util with parameters of type DoubleBinaryOperator
      Modifier and Type 方法 描述
      static void Arrays.parallelPrefix​(double[] array, int fromIndex, int toIndex, DoubleBinaryOperator op)
      对于数组的给定子范围执行 Arrays.parallelPrefix(double[], DoubleBinaryOperator) 。
      static void Arrays.parallelPrefix​(double[] array, DoubleBinaryOperator op)
      使用提供的功能，并行地计算给定阵列的每个元素。

    • Uses of DoubleBinaryOperator in java.util.concurrent

      Methods in java.util.concurrent with parameters of type DoubleBinaryOperator
      Modifier and Type 方法 描述
      double ConcurrentHashMap.reduceEntriesToDouble​(long parallelismThreshold, ToDoubleFunction<Map.Entry<K,V>> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      double ConcurrentHashMap.reduceKeysToDouble​(long parallelismThreshold, ToDoubleFunction<? super K> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
      double ConcurrentHashMap.reduceToDouble​(long parallelismThreshold, ToDoubleBiFunction<? super K,? super V> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
      double ConcurrentHashMap.reduceValuesToDouble​(long parallelismThreshold, ToDoubleFunction<? super V> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。

    • Uses of DoubleBinaryOperator in java.util.concurrent.atomic

      Constructors in java.util.concurrent.atomic with parameters of type DoubleBinaryOperator
      Constructor 描述
      DoubleAccumulator​(DoubleBinaryOperator accumulatorFunction, double identity)
      使用给定的累加器函数和identity元素创建一个新的实例。

    • Uses of DoubleBinaryOperator in java.util.stream

      Methods in java.util.stream with parameters of type DoubleBinaryOperator
      Modifier and Type 方法 描述
      double DoubleStream.reduce​(double identity, DoubleBinaryOperator op)
      使用提供的身份值和 associative累积功能对此流的元素执行 reduction ，并返回减小的值。
      OptionalDouble DoubleStream.reduce​(DoubleBinaryOperator op)
      Performs a reduction on the elements of this stream, using an associative accumulation function, and returns an OptionalDouble describing the reduced value, if any.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.DoubleConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.DoubleConsumer

  • Packages that use DoubleConsumer
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleConsumer in java.util

      Classes in java.util that implement DoubleConsumer
      Modifier and Type Class 描述
      class  DoubleSummaryStatistics
      统计数据的收集状态，如count，min，max，sum和average。
      Methods in java.util with parameters of type DoubleConsumer
      Modifier and Type | 方法 | 描述
      default void PrimitiveIterator.OfDouble.forEachRemaining​(DoubleConsumer action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void | Spliterator.OfDouble.forEachRemaining​(DoubleConsumer action)
      void OptionalDouble.ifPresent​(DoubleConsumer action)
      如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
      void OptionalDouble.ifPresentOrElse​(DoubleConsumer action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      boolean | Spliterator.OfDouble.tryAdvance​(DoubleConsumer action)

    • Uses of DoubleConsumer in java.util.function

      Methods in java.util.function that return DoubleConsumer
      Modifier and Type 方法 描述
      default DoubleConsumer DoubleConsumer.andThen​(DoubleConsumer after)
      返回一个组成的 DoubleConsumer ，依次执行此操作，然后执行 after操作。
      Methods in java.util.function with parameters of type DoubleConsumer
      Modifier and Type 方法 描述
      default DoubleConsumer DoubleConsumer.andThen​(DoubleConsumer after)
      返回一个组成的 DoubleConsumer ，依次执行此操作，然后执行 after操作。

    • Uses of DoubleConsumer in java.util.stream

      Subinterfaces of DoubleConsumer in java.util.stream
      Modifier and Type 接口 描述
      static interface  DoubleStream.Builder
      一个可变的构建器，用于 DoubleStream 。
      Methods in java.util.stream with parameters of type DoubleConsumer
      Modifier and Type 方法 描述
      void DoubleStream.forEach​(DoubleConsumer action)
      对此流的每个元素执行操作。
      void DoubleStream.forEachOrdered​(DoubleConsumer action)
      对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。
      DoubleStream DoubleStream.peek​(DoubleConsumer action)
      Returns a stream consisting of the elements of this stream, additionally performing the provided action on each element as elements are consumed from the resulting stream.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.DoubleFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.DoubleFunction

  • Packages that use DoubleFunction
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleFunction in java.util.stream

      Methods in java.util.stream with parameters of type DoubleFunction
      Modifier and Type 方法 描述
      DoubleStream DoubleStream.flatMap​(DoubleFunction<? extends DoubleStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      <U> Stream<U> DoubleStream.mapToObj​(DoubleFunction<? extends U> mapper)
      返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.DoublePredicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.DoublePredicate

  • Packages that use DoublePredicate
    软件包 描述
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoublePredicate in java.util.function

      Methods in java.util.function that return DoublePredicate
      Modifier and Type 方法 描述
      default DoublePredicate DoublePredicate.and​(DoublePredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default DoublePredicate DoublePredicate.negate​()
      返回表示此谓词的逻辑否定的谓词。
      default DoublePredicate DoublePredicate.or​(DoublePredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      Methods in java.util.function with parameters of type DoublePredicate
      Modifier and Type 方法 描述
      default DoublePredicate DoublePredicate.and​(DoublePredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default DoublePredicate DoublePredicate.or​(DoublePredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。

    • Uses of DoublePredicate in java.util.stream

      Methods in java.util.stream with parameters of type DoublePredicate
      Modifier and Type 方法 描述
      boolean DoubleStream.allMatch​(DoublePredicate predicate)
      返回此流的所有元素是否与提供的谓词匹配。
      boolean DoubleStream.anyMatch​(DoublePredicate predicate)
      返回此流的任何元素是否与提供的谓词匹配。
      default DoubleStream DoubleStream.dropWhile​(DoublePredicate predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      DoubleStream DoubleStream.filter​(DoublePredicate predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      static DoubleStream DoubleStream.iterate​(double seed, DoublePredicate hasNext, DoubleUnaryOperator next)
      返回通过将给定的 next函数迭代应用于初始元素 DoubleStream产生的顺序 DoubleStream ，其条件是满足给定的 hasNext谓词。
      boolean DoubleStream.noneMatch​(DoublePredicate predicate)
      返回此流的元素是否与提供的谓词匹配。
      default DoubleStream DoubleStream.takeWhile​(DoublePredicate predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.DoubleSupplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.DoubleSupplier

  • Packages that use DoubleSupplier
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleSupplier in java.util

      Methods in java.util with parameters of type DoubleSupplier
      Modifier and Type 方法 描述
      double OptionalDouble.orElseGet​(DoubleSupplier supplier)
      如果存在值，则返回值，否则返回由供应函数产生的结果。

    • Uses of DoubleSupplier in java.util.stream

      Methods in java.util.stream with parameters of type DoubleSupplier
      Modifier and Type 方法 描述
      static DoubleStream DoubleStream.generate​(DoubleSupplier s)
      返回无限顺序无序流，其中每个元素由提供的 DoubleSupplier生成。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.DoubleToIntFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.DoubleToIntFunction

  • Packages that use DoubleToIntFunction
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleToIntFunction in java.util.stream

      Methods in java.util.stream with parameters of type DoubleToIntFunction
      Modifier and Type 方法 描述
      IntStream DoubleStream.mapToInt​(DoubleToIntFunction mapper)
      返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.DoubleToLongFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.DoubleToLongFunction

  • Packages that use DoubleToLongFunction
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleToLongFunction in java.util.stream

      Methods in java.util.stream with parameters of type DoubleToLongFunction
      Modifier and Type 方法 描述
      LongStream DoubleStream.mapToLong​(DoubleToLongFunction mapper)
      返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.DoubleUnaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.DoubleUnaryOperator

  • Packages that use DoubleUnaryOperator
    软件包 描述
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleUnaryOperator in java.util.function

      Methods in java.util.function that return DoubleUnaryOperator
      Modifier and Type 方法 描述
      default DoubleUnaryOperator DoubleUnaryOperator.andThen​(DoubleUnaryOperator after)
      返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
      default DoubleUnaryOperator DoubleUnaryOperator.compose​(DoubleUnaryOperator before)
      返回一个组合运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。
      static DoubleUnaryOperator DoubleUnaryOperator.identity​()
      返回始终返回其输入参数的一元运算符。
      Methods in java.util.function with parameters of type DoubleUnaryOperator
      Modifier and Type 方法 描述
      default DoubleUnaryOperator DoubleUnaryOperator.andThen​(DoubleUnaryOperator after)
      返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
      default DoubleUnaryOperator DoubleUnaryOperator.compose​(DoubleUnaryOperator before)
      返回一个 before运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。

    • Uses of DoubleUnaryOperator in java.util.stream

      Methods in java.util.stream with parameters of type DoubleUnaryOperator
      Modifier and Type 方法 描述
      static DoubleStream DoubleStream.iterate​(double seed, DoublePredicate hasNext, DoubleUnaryOperator next)
      返回通过将给定的 next函数迭代应用于初始元素 DoubleStream产生的顺序 DoubleStream ，其条件是满足给定的 hasNext谓词。
      static DoubleStream DoubleStream.iterate​(double seed, DoubleUnaryOperator f)
      返回有序无限连续 DoubleStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      DoubleStream DoubleStream.map​(DoubleUnaryOperator mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.Function (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.Function

  • Packages that use Function
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。

    • Uses of Function in java.lang

      Methods in java.lang with parameters of type Function
      Modifier and Type 方法 描述
      ModuleLayer ModuleLayer.defineModules​(Configuration cf, Function<String,ClassLoader> clf)
      通过在Java虚拟机的给定的 Configuration定义模块，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller ModuleLayer.defineModules​(Configuration cf, List<ModuleLayer> parentLayers, Function<String,ClassLoader> clf)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      <T> T StackWalker.walk​(Function<? super Stream<StackWalker.StackFrame>,? extends T> function)
      将给定的函数应用于当前线程的 StackFrame的流，从堆栈的顶部框架遍历，这是调用此 walk方法的方法。

    • Uses of Function in java.security

      Methods in java.security with parameters of type Function
      Modifier and Type 方法 描述
      Object Provider.computeIfAbsent​(Object key, Function<? super Object,? extends Object> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

    • Uses of Function in java.util

      Methods in java.util with parameters of type Function
      Modifier and Type | 方法 | 描述
      static <T,U extends Comparable<? super U>>
      Comparator<T>             		Comparator.comparing​(Function<? super T,? extends U> keyExtractor)
      接受一个从T类型中提取Comparable排序键的T ，并返回一个按该排序键进行比较的Comparator<T> 。
      static <T,U> Comparator<T> Comparator.comparing​(Function<? super T,? extends U> keyExtractor, Comparator<? super U> keyComparator)
      接受从类型T提取排序键的T ，并返回一个Comparator<T> ，使用指定的Comparator比较该排序键。
      V HashMap.computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      V Hashtable.computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      default V Map.computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      Object | Properties.computeIfAbsent​(Object key, Function<? super Object,?> mappingFunction)
      <U> Optional<U> Optional.flatMap​(Function<? super T,? extends Optional<? extends U>> mapper)
      如果存在值，则返回将给定的 Optional映射函数应用于该值的结果，否则返回一个空的 Optional 。
      <U> Optional<U> Optional.map​(Function<? super T,? extends U> mapper)
      如果存在一个值，则返回一个 Optional （如果由 Optional.ofNullable(T)表示 ）将给定映射函数应用于该值的结果，否则返回一个空的 Optional 。
      default <U extends Comparable<? super U>>
      Comparator<T>             		Comparator.thenComparing​(Function<? super T,? extends U> keyExtractor)
      返回具有提取 Comparable排序键的功能的字典顺序比较器。
      default <U> Comparator<T> Comparator.thenComparing​(Function<? super T,? extends U> keyExtractor, Comparator<? super U> keyComparator)
      返回具有提取要与给定的 Comparator进行比较的键的功能的字典顺序比较器。

    • Uses of Function in java.util.concurrent

      Methods in java.util.concurrent with parameters of type Function
      Modifier and Type | 方法 | 描述
      <U> CompletableFuture<U> | CompletableFuture.applyToEither​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      <U> CompletionStage<U> CompletionStage.applyToEither​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的函数的参数。
      <U> CompletableFuture<U> | CompletableFuture.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      <U> CompletableFuture<U> | CompletableFuture.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供函数的参数。
      <U> CompletionStage<U> CompletionStage.applyToEitherAsync​(CompletionStage<? extends T> other, Function<? super T,U> fn, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用提供的执行器执行，其中相应的结果作为参数提供给函数。
      V ConcurrentHashMap.computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联，则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      default V ConcurrentMap.computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      V ConcurrentSkipListMap.computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)
      如果指定的键尚未与值相关联，则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。
      CompletableFuture<T> CompletableFuture.exceptionally​(Function<Throwable,? extends T> fn)
      返回一个新的CompletableFuture，当CompletableFuture完成时完成，结果是异常触发此CompletableFuture的完成特殊功能的给定功能; 否则，如果此CompletableFuture正常完成，则返回的CompletableFuture也会以相同的值正常完成。
      CompletionStage<T> CompletionStage.exceptionally​(Function<Throwable,? extends T> fn)
      返回一个新的CompletionStage，当此阶段完成异常时，将以此阶段的异常作为提供函数的参数执行。
      <U> void ConcurrentHashMap.forEachEntry​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> transformer, Consumer<? super U> action)
      对每个条目的每个非空变换执行给定的操作。
      <U> void ConcurrentHashMap.forEachKey​(long parallelismThreshold, Function<? super K,? extends U> transformer, Consumer<? super U> action)
      对每个键的每个非空变换执行给定的动作。
      <U> void ConcurrentHashMap.forEachValue​(long parallelismThreshold, Function<? super V,? extends U> transformer, Consumer<? super U> action)
      对每个值的每个非空转换执行给定的动作。
      <U> U ConcurrentHashMap.reduceEntries​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer将所有条目的给定变换累加到组合值的结果，否则返回null。
      <U> U ConcurrentHashMap.reduceKeys​(long parallelismThreshold, Function<? super K,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer将所有键的给定变换累加到组合值的结果，否则返回null。
      <U> U ConcurrentHashMap.reduceValues​(long parallelismThreshold, Function<? super V,? extends U> transformer, BiFunction<? super U,? super U,? extends U> reducer)
      返回使用给定的reducer累加所有值的给定变换以组合值的结果，否则返回null。
      <U> U ConcurrentHashMap.searchEntries​(long parallelismThreshold, Function<Map.Entry<K,V>,? extends U> searchFunction)
      返回一个非空结果，从每个条目应用给定的搜索函数，如果没有，则返回null。
      <U> U ConcurrentHashMap.searchKeys​(long parallelismThreshold, Function<? super K,? extends U> searchFunction)
      返回一个非空结果，在每个键上应用给定的搜索功能，如果没有，返回null。
      <U> U ConcurrentHashMap.searchValues​(long parallelismThreshold, Function<? super V,? extends U> searchFunction)
      返回一个非空结果，对每个值应用给定的搜索函数，如果没有，返回null。
      <U> CompletableFuture<U> | CompletableFuture.thenApply​(Function<? super T,? extends U> fn)
      <U> CompletionStage<U> CompletionStage.thenApply​(Function<? super T,? extends U> fn)
      返回一个新的CompletionStage，当此阶段正常完成时，将以该阶段的结果作为所提供函数的参数执行。
      <U> CompletableFuture<U> | CompletableFuture.thenApplyAsync​(Function<? super T,? extends U> fn)
      <U> CompletableFuture<U> | CompletableFuture.thenApplyAsync​(Function<? super T,? extends U> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.thenApplyAsync​(Function<? super T,? extends U> fn)
      返回一个新的CompletionStage，当该阶段正常完成时，将使用此阶段的默认异步执行工具执行此阶段的结果作为所提供函数的参数。
      <U> CompletionStage<U> CompletionStage.thenApplyAsync​(Function<? super T,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供函数的参数。
      <U> CompletableFuture<U> | CompletableFuture.thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
      <U> CompletionStage<U> CompletionStage.thenCompose​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个完成的新的CompletionStage，其值与给定函数返回的CompletionStage相同。
      <U> CompletableFuture<U> | CompletableFuture.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
      <U> CompletableFuture<U> | CompletableFuture.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用该阶段的默认异步执行工具执行。
      <U> CompletionStage<U> CompletionStage.thenComposeAsync​(Function<? super T,? extends CompletionStage<U>> fn, Executor executor)
      返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用提供的Executor执行。

    • Uses of Function in java.util.function

      Subinterfaces of Function in java.util.function
      Modifier and Type 接口 描述
      interface  UnaryOperator<T>
      表示对单个操作数产生与其操作数相同类型的结果的操作。
      Methods in java.util.function that return Function
      Modifier and Type 方法 描述
      default <V> Function<T,V> Function.andThen​(Function<? super R,? extends V> after)
      返回一个组合函数，首先将该函数应用于其输入，然后将 after函数应用于结果。
      default <V> Function<V,R> Function.compose​(Function<? super V,? extends T> before)
      返回一个组合函数，该函数首先将 before函数应用于其输入，然后将此函数应用于结果。
      static <T> Function<T,T> Function.identity​()
      返回一个总是返回其输入参数的函数。
      Methods in java.util.function with parameters of type Function
      Modifier and Type 方法 描述
      default <V> BiFunction<T,U,V> BiFunction.andThen​(Function<? super R,? extends V> after)
      返回一个组合函数，首先将该函数应用于其输入，然后将 after函数应用于结果。
      default <V> Function<T,V> Function.andThen​(Function<? super R,? extends V> after)
      返回一个组合函数，首先将该函数应用于其输入，然后将 after函数应用于结果。
      default <V> Function<V,R> Function.compose​(Function<? super V,? extends T> before)
      返回一个组合函数，首先将 before函数应用于其输入，然后将此函数应用于结果。

    • Uses of Function in java.util.logging

      Methods in java.util.logging with parameters of type Function
      Modifier and Type 方法 描述
      void LogManager.updateConfiguration​(InputStream ins, Function<String,BiFunction<String,String,String>> mapper)
      更新日志记录配置。
      void LogManager.updateConfiguration​(Function<String,BiFunction<String,String,String>> mapper)
      更新日志记录配置。

    • Uses of Function in java.util.regex

      Methods in java.util.regex with parameters of type Function
      Modifier and Type 方法 描述
      String Matcher.replaceAll​(Function<MatchResult,String> replacer)
      将与模式匹配的输入序列的每个子序列替换为将给定的替换器函数应用于与该子序列相对应的匹配器的匹配结果的结果。
      String Matcher.replaceFirst​(Function<MatchResult,String> replacer)
      将与模式匹配的输入序列的第一个子序列替换为将给定的替换器函数应用于与该子序列对应的匹配器的匹配结果的结果。

    • Uses of Function in java.util.stream

      Methods in java.util.stream that return Function
      Modifier and Type 方法 描述
      Function<A,R> Collector.finisher​()
      执行从中间累积类型 A到最终结果类型 R的最终 R 。
      Methods in java.util.stream with parameters of type Function
      Modifier and Type 方法 描述
      static <T,A,R,RR> Collector<T,A,RR> Collectors.collectingAndThen​(Collector<T,A,R> downstream, Function<R,RR> finisher)
      适应 Collector进行额外的完成转换。
      <R> Stream<R> Stream.flatMap​(Function<? super T,? extends Stream<? extends R>> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      static <T,U,A,R> Collector<T,?,R> Collectors.flatMapping​(Function<? super T,? extends Stream<? extends U>> mapper, Collector<? super U,A,R> downstream)
      适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累之前施加平坦映射函数应用于每个输入元件。
      DoubleStream Stream.flatMapToDouble​(Function<? super T,? extends DoubleStream> mapper)
      返回一个 DoubleStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
      IntStream Stream.flatMapToInt​(Function<? super T,? extends IntStream> mapper)
      返回一个 IntStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
      LongStream Stream.flatMapToLong​(Function<? super T,? extends LongStream> mapper)
      返回一个 LongStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
      static <T,K> Collector<T,?,Map<K,List<T>>> Collectors.groupingBy​(Function<? super T,? extends K> classifier)
      返回一个 Collector对类型为 T输入元素进行“按组”操作，根据分类功能对元素进行分组，并将结果返回到 Map 。
      static <T,K,D,A,M extends Map<K,D>>
      Collector<T,?,M>             		Collectors.groupingBy​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回一个 Collector ，对 T类型的输入元素执行级联“分组”操作，根据分类功能分组元素，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K,A,D> Collector<T,?,Map<K,D>> Collectors.groupingBy​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定与给定键相关联的值进行还原操作 Collector 。
      static <T,K> Collector<T,?,ConcurrentMap<K,List<T>>> Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier)
      返回一个并发的 Collector ，对类型为 T输入元素实施“分组”操作，根据分类功能对元素进行分组。
      static <T,K,A,D,M extends ConcurrentMap<K,D>>
      Collector<T,?,M>             		Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回并行的 Collector ，对 T类型的输入元素进行级联“分组”操作，根据分类功能对元素进行分组，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K,A,D> Collector<T,?,ConcurrentMap<K,D>> Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回并行的 Collector ，对类型为 T输入元素进行级联“分组”操作，根据分类功能分组元素，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      <R> Stream<R> Stream.map​(Function<? super T,? extends R> mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
      static <T,U,A,R> Collector<T,?,R> Collectors.mapping​(Function<? super T,? extends U> mapper, Collector<? super U,A,R> downstream)
      适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累前应用映射函数到每个输入元素。
      static <T,A,R> Collector<T,A,R> Collector.of​(Supplier<A> supplier, BiConsumer<A,T> accumulator, BinaryOperator<A> combiner, Function<A,R> finisher, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ， combiner ，并 finisher功能。
      static <T,U> Collector<T,?,U> Collectors.reducing​(U identity, Function<? super T,? extends U> mapper, BinaryOperator<U> op)
      返回一个 Collector ，它在指定的映射函数和 BinaryOperator下执行其输入元素的减少。
      static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U,M extends ConcurrentMap<K,U>>
      Collector<T,?,M>             		Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,Map<K,U>> Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,Map<K,U>> Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U,M extends Map<K,U>>
      Collector<T,?,M>             		Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。

    • Uses of Function in javafx.css

      Methods in javafx.css with parameters of type Function
      Modifier and Type 方法 描述
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function)
      创建一个具有初始值的CssMetaData <S，Boolean>，并继承标志，两者都默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建具有初始值的CssMetaData <S，Boolean>，并将标志默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Boolean>，并继承标志。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function)
      创建一个CssMetaData <S，Color>，初始值为Color.BLACK，并继承标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Color>并继承标志。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function)
      创建一个具有Duration.BLACK的初始值的CssMetaData <S，Duration>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Duration>并继承标志。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，Effect>，初始值为null，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，Effect>，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Effect>并继承标志。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，枚举>，并继承标志。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function)
      创建CssMetaData <S，Font>，初始值为 Font.getDefault() ，并将标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的CssMetaData <S，Font>并继承标志。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function)
      创建CssMetaData <S，Insets>，初始值为 Insets.EMPTY ，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Insets>并继承标志。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function)
      使用Color.BLACK的初始值创建一个CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Paint>并继承标志。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function)
      创建CssMetaData <S，Number>，初始值为 0d ，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Number>，并继承标志。
      CssMetaData<S,String> StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function)
      创建CssMetaData <S，String>，初始值为null，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)
      创建具有初始值的CssMetaData <S，String>，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，String>并继承标志。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function)
      创建一个StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建一个具有初始值的StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Boolean>并继承标志。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function)
      创建一个StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建一个具有初始值的StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Color>并继承标志。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function)
      创建一个StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建一个具有初始值的StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Duration>并继承标志。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function)
      创建一个StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue)
      创建一个具有初始值的StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Effect>并继承标志。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass)
      创建一个StyleableProperty <E extends Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue)
      创建一个StyleableProperty <E使用初始值扩展Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue, boolean inherits)
      创建一个StyleableProperty <E使用初始值扩展枚举<E >>并继承标志。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function)
      创建一个StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建一个具有初始值的StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Font>并继承标志。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function)
      创建一个StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建一个具有初始值的StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Inset>并继承标志。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function)
      创建一个StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建一个具有初始值的StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Number>并继承标志。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function)
      创建一个StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建一个具有初始值的StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Paint>并继承标志。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)
      创建一个StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <String>并继承标志。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <String>并继承标志。
      CssMetaData<S,String> StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function)
      创建CssMetaData <S，String>，初始值为null，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)
      创建具有初始值的CssMetaData <S，String>，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，String>并继承标志。

    • Uses of Function in jdk.incubator.http

      Methods in jdk.incubator.http with parameters of type Function
      Modifier and Type 方法 描述
      static <V> HttpResponse.MultiProcessor<MultiMapResult<V>,V> HttpResponse.MultiProcessor.asMap​(Function<HttpRequest,Optional<HttpResponse.BodyHandler<V>>> pushHandler)
      返回多个响应的通用处理程序。
      static <V> HttpResponse.MultiProcessor<MultiMapResult<V>,V> HttpResponse.MultiProcessor.asMap​(Function<HttpRequest,Optional<HttpResponse.BodyHandler<V>>> pushHandler, boolean completion)
      返回多个响应的通用处理程序。

    • Uses of Function in jdk.jshell

      Methods in jdk.jshell with parameters of type Function
      Modifier and Type 方法 描述
      JShell.Builder JShell.Builder.fileManager​(Function<StandardJavaFileManager,StandardJavaFileManager> mapping)
      配置通过编译和源分析使用的 FileManager 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.IntBinaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.IntBinaryOperator

  • Packages that use IntBinaryOperator
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntBinaryOperator in java.util

      Methods in java.util with parameters of type IntBinaryOperator
      Modifier and Type 方法 描述
      static void Arrays.parallelPrefix​(int[] array, int fromIndex, int toIndex, IntBinaryOperator op)
      对于数组的给定子范围执行 Arrays.parallelPrefix(int[], IntBinaryOperator) 。
      static void Arrays.parallelPrefix​(int[] array, IntBinaryOperator op)
      使用提供的功能，并行地计算给定阵列的每个元素。

    • Uses of IntBinaryOperator in java.util.concurrent

      Methods in java.util.concurrent with parameters of type IntBinaryOperator
      Modifier and Type 方法 描述
      int ConcurrentHashMap.reduceEntriesToInt​(long parallelismThreshold, ToIntFunction<Map.Entry<K,V>> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      int ConcurrentHashMap.reduceKeysToInt​(long parallelismThreshold, ToIntFunction<? super K> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
      int ConcurrentHashMap.reduceToInt​(long parallelismThreshold, ToIntBiFunction<? super K,? super V> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
      int ConcurrentHashMap.reduceValuesToInt​(long parallelismThreshold, ToIntFunction<? super V> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。

    • Uses of IntBinaryOperator in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic with parameters of type IntBinaryOperator
      Modifier and Type 方法 描述
      int AtomicInteger.accumulateAndGet​(int x, IntBinaryOperator accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值的原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回更新后的值。
      int AtomicIntegerArray.accumulateAndGet​(int i, int x, IntBinaryOperator accumulatorFunction)
      原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回更新后的值。
      int AtomicIntegerFieldUpdater.accumulateAndGet​(T obj, int x, IntBinaryOperator accumulatorFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。
      int AtomicInteger.getAndAccumulate​(int x, IntBinaryOperator accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值的原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回上一个值。
      int AtomicIntegerArray.getAndAccumulate​(int i, int x, IntBinaryOperator accumulatorFunction)
      原始更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回上一个值。
      int AtomicIntegerFieldUpdater.getAndAccumulate​(T obj, int x, IntBinaryOperator accumulatorFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。

    • Uses of IntBinaryOperator in java.util.stream

      Methods in java.util.stream with parameters of type IntBinaryOperator
      Modifier and Type 方法 描述
      int IntStream.reduce​(int identity, IntBinaryOperator op)
      使用提供的身份值和 associative累积功能对此流的元素执行 reduction ，并返回减小的值。
      OptionalInt IntStream.reduce​(IntBinaryOperator op)
      使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值（如果有的话）的 OptionalInt 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.IntConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.IntConsumer

  • Packages that use IntConsumer
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntConsumer in java.util

      Classes in java.util that implement IntConsumer
      Modifier and Type Class 描述
      class  IntSummaryStatistics
      统计数据的收集状态，如count，min，max，sum和average。
      class  LongSummaryStatistics
      统计数据的收集状态，如count，min，max，sum和average。
      Methods in java.util with parameters of type IntConsumer
      Modifier and Type | 方法 | 描述
      default void PrimitiveIterator.OfInt.forEachRemaining​(IntConsumer action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void | Spliterator.OfInt.forEachRemaining​(IntConsumer action)
      void OptionalInt.ifPresent​(IntConsumer action)
      如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
      void OptionalInt.ifPresentOrElse​(IntConsumer action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      boolean | Spliterator.OfInt.tryAdvance​(IntConsumer action)

    • Uses of IntConsumer in java.util.function

      Methods in java.util.function that return IntConsumer
      Modifier and Type 方法 描述
      default IntConsumer IntConsumer.andThen​(IntConsumer after)
      返回一个组成的 IntConsumer ，依次执行此操作，然后执行 after操作。
      Methods in java.util.function with parameters of type IntConsumer
      Modifier and Type 方法 描述
      default IntConsumer IntConsumer.andThen​(IntConsumer after)
      返回一个组成的 IntConsumer ，依次执行此操作，然后执行 after操作。

    • Uses of IntConsumer in java.util.stream

      Subinterfaces of IntConsumer in java.util.stream
      Modifier and Type 接口 描述
      static interface  IntStream.Builder
      一个可变的构建器为 IntStream 。
      Methods in java.util.stream with parameters of type IntConsumer
      Modifier and Type 方法 描述
      void IntStream.forEach​(IntConsumer action)
      对此流的每个元素执行操作。
      void IntStream.forEachOrdered​(IntConsumer action)
      对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。
      IntStream IntStream.peek​(IntConsumer action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.IntFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.IntFunction

  • Packages that use IntFunction
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntFunction in java.util

      Methods in java.util with parameters of type IntFunction
      Modifier and Type 方法 描述
      static <T> void Arrays.parallelSetAll​(T[] array, IntFunction<? extends T> generator)
      使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
      static <T> void Arrays.setAll​(T[] array, IntFunction<? extends T> generator)
      使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

    • Uses of IntFunction in java.util.stream

      Methods in java.util.stream with parameters of type IntFunction
      Modifier and Type 方法 描述
      IntStream IntStream.flatMap​(IntFunction<? extends IntStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      <U> Stream<U> IntStream.mapToObj​(IntFunction<? extends U> mapper)
      返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
      <A> A[] Stream.toArray​(IntFunction<A[]> generator)
      Returns an array containing the elements of this stream, using the provided generator function to allocate the returned array, as well as any additional arrays that might be required for a partitioned execution or for resizing.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.IntPredicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.IntPredicate

  • Packages that use IntPredicate
    软件包 描述
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntPredicate in java.util.function

      Methods in java.util.function that return IntPredicate
      Modifier and Type 方法 描述
      default IntPredicate IntPredicate.and​(IntPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default IntPredicate IntPredicate.negate​()
      返回表示此谓词的逻辑否定的谓词。
      default IntPredicate IntPredicate.or​(IntPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      Methods in java.util.function with parameters of type IntPredicate
      Modifier and Type 方法 描述
      default IntPredicate IntPredicate.and​(IntPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default IntPredicate IntPredicate.or​(IntPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。

    • Uses of IntPredicate in java.util.stream

      Methods in java.util.stream with parameters of type IntPredicate
      Modifier and Type 方法 描述
      boolean IntStream.allMatch​(IntPredicate predicate)
      返回此流的所有元素是否与提供的谓词匹配。
      boolean IntStream.anyMatch​(IntPredicate predicate)
      返回此流的任何元素是否与提供的谓词匹配。
      default IntStream IntStream.dropWhile​(IntPredicate predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      IntStream IntStream.filter​(IntPredicate predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      static IntStream IntStream.iterate​(int seed, IntPredicate hasNext, IntUnaryOperator next)
      返回通过将给定的 next函数的迭代应用到初始元素产生的顺序 IntStream ，其条件是满足给定的 hasNext谓词。
      boolean IntStream.noneMatch​(IntPredicate predicate)
      返回此流的元素是否与提供的谓词匹配。
      default IntStream IntStream.takeWhile​(IntPredicate predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.IntSupplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.IntSupplier

  • Packages that use IntSupplier
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntSupplier in java.util

      Methods in java.util with parameters of type IntSupplier
      Modifier and Type 方法 描述
      int OptionalInt.orElseGet​(IntSupplier supplier)
      如果存在值，则返回值，否则返回由供应函数产生的结果。

    • Uses of IntSupplier in java.util.stream

      Methods in java.util.stream with parameters of type IntSupplier
      Modifier and Type 方法 描述
      static IntStream IntStream.generate​(IntSupplier s)
      返回无限顺序无序流，其中每个元素由提供的 IntSupplier生成。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.IntToDoubleFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.IntToDoubleFunction

  • Packages that use IntToDoubleFunction
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntToDoubleFunction in java.util

      Methods in java.util with parameters of type IntToDoubleFunction
      Modifier and Type 方法 描述
      static void Arrays.parallelSetAll​(double[] array, IntToDoubleFunction generator)
      使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
      static void Arrays.setAll​(double[] array, IntToDoubleFunction generator)
      使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

    • Uses of IntToDoubleFunction in java.util.stream

      Methods in java.util.stream with parameters of type IntToDoubleFunction
      Modifier and Type 方法 描述
      DoubleStream IntStream.mapToDouble​(IntToDoubleFunction mapper)
      返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.IntToLongFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.IntToLongFunction

  • Packages that use IntToLongFunction
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntToLongFunction in java.util

      Methods in java.util with parameters of type IntToLongFunction
      Modifier and Type 方法 描述
      static void Arrays.parallelSetAll​(long[] array, IntToLongFunction generator)
      使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
      static void Arrays.setAll​(long[] array, IntToLongFunction generator)
      使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

    • Uses of IntToLongFunction in java.util.stream

      Methods in java.util.stream with parameters of type IntToLongFunction
      Modifier and Type 方法 描述
      LongStream IntStream.mapToLong​(IntToLongFunction mapper)
      返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.IntUnaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.IntUnaryOperator

  • Packages that use IntUnaryOperator
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntUnaryOperator in java.util

      Methods in java.util with parameters of type IntUnaryOperator
      Modifier and Type 方法 描述
      static void Arrays.parallelSetAll​(int[] array, IntUnaryOperator generator)
      使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
      static void Arrays.setAll​(int[] array, IntUnaryOperator generator)
      使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

    • Uses of IntUnaryOperator in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic with parameters of type IntUnaryOperator
      Modifier and Type 方法 描述
      int AtomicInteger.getAndUpdate​(IntUnaryOperator updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。
      int AtomicIntegerArray.getAndUpdate​(int i, IntUnaryOperator updateFunction)
      原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素与应用给定函数的结果，返回上一个值。
      int AtomicIntegerFieldUpdater.getAndUpdate​(T obj, IntUnaryOperator updateFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回上一个值。
      int AtomicInteger.updateAndGet​(IntUnaryOperator updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新后的值。
      int AtomicIntegerArray.updateAndGet​(int i, IntUnaryOperator updateFunction)
      使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      int AtomicIntegerFieldUpdater.updateAndGet​(T obj, IntUnaryOperator updateFunction)
      通过应用给定函数的结果，原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，返回更新的值。

    • Uses of IntUnaryOperator in java.util.function

      Methods in java.util.function that return IntUnaryOperator
      Modifier and Type 方法 描述
      default IntUnaryOperator IntUnaryOperator.andThen​(IntUnaryOperator after)
      返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
      default IntUnaryOperator IntUnaryOperator.compose​(IntUnaryOperator before)
      返回一个 before运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。
      static IntUnaryOperator IntUnaryOperator.identity​()
      返回始终返回其输入参数的一元运算符。
      Methods in java.util.function with parameters of type IntUnaryOperator
      Modifier and Type 方法 描述
      default IntUnaryOperator IntUnaryOperator.andThen​(IntUnaryOperator after)
      返回一个 after运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
      default IntUnaryOperator IntUnaryOperator.compose​(IntUnaryOperator before)
      返回一个组合运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。

    • Uses of IntUnaryOperator in java.util.stream

      Methods in java.util.stream with parameters of type IntUnaryOperator
      Modifier and Type 方法 描述
      static IntStream IntStream.iterate​(int seed, IntPredicate hasNext, IntUnaryOperator next)
      返回通过将给定的 next函数迭代应用到初始元素产生的顺序 IntStream ，其条件是满足给定的 hasNext谓词。
      static IntStream IntStream.iterate​(int seed, IntUnaryOperator f)
      返回有序无限连续 IntStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      IntStream IntStream.map​(IntUnaryOperator mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.LongBinaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.LongBinaryOperator

  • Packages that use LongBinaryOperator
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongBinaryOperator in java.util

      Methods in java.util with parameters of type LongBinaryOperator
      Modifier and Type 方法 描述
      static void Arrays.parallelPrefix​(long[] array, int fromIndex, int toIndex, LongBinaryOperator op)
      对于数组的给定子范围执行 Arrays.parallelPrefix(long[], LongBinaryOperator) 。
      static void Arrays.parallelPrefix​(long[] array, LongBinaryOperator op)
      使用提供的功能，并行地计算给定阵列的每个元素。

    • Uses of LongBinaryOperator in java.util.concurrent

      Methods in java.util.concurrent with parameters of type LongBinaryOperator
      Modifier and Type 方法 描述
      long ConcurrentHashMap.reduceEntriesToLong​(long parallelismThreshold, ToLongFunction<Map.Entry<K,V>> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      long ConcurrentHashMap.reduceKeysToLong​(long parallelismThreshold, ToLongFunction<? super K> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
      long ConcurrentHashMap.reduceToLong​(long parallelismThreshold, ToLongBiFunction<? super K,? super V> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
      long ConcurrentHashMap.reduceValuesToLong​(long parallelismThreshold, ToLongFunction<? super V> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。

    • Uses of LongBinaryOperator in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic with parameters of type LongBinaryOperator
      Modifier and Type 方法 描述
      long AtomicLong.accumulateAndGet​(long x, LongBinaryOperator accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效应），返回更新后的值。
      long AtomicLongArray.accumulateAndGet​(int i, long x, LongBinaryOperator accumulatorFunction)
      原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定的函数应用于当前值和给定值，返回更新后的值。
      long AtomicLongFieldUpdater.accumulateAndGet​(T obj, long x, LongBinaryOperator accumulatorFunction)
      原始更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。
      long AtomicLong.getAndAccumulate​(long x, LongBinaryOperator accumulatorFunction)
      将当前值与给定函数应用于当前值和给定值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回上一个值。
      long AtomicLongArray.getAndAccumulate​(int i, long x, LongBinaryOperator accumulatorFunction)
      原始更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回上一个值。
      long AtomicLongFieldUpdater.getAndAccumulate​(T obj, long x, LongBinaryOperator accumulatorFunction)
      原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。
      Constructors in java.util.concurrent.atomic with parameters of type LongBinaryOperator
      Constructor 描述
      LongAccumulator​(LongBinaryOperator accumulatorFunction, long identity)
      使用给定的累加器函数和identity元素创建一个新的实例。

    • Uses of LongBinaryOperator in java.util.stream

      Methods in java.util.stream with parameters of type LongBinaryOperator
      Modifier and Type 方法 描述
      long LongStream.reduce​(long identity, LongBinaryOperator op)
      使用提供的身份值和 associative累积函数对此流的元素执行 reduction ，并返回减小的值。
      OptionalLong LongStream.reduce​(LongBinaryOperator op)
      Performs a reduction on the elements of this stream, using an associative accumulation function, and returns an OptionalLong describing the reduced value, if any.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.LongConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.LongConsumer

  • Packages that use LongConsumer
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongConsumer in java.util

      Classes in java.util that implement LongConsumer
      Modifier and Type Class 描述
      class  LongSummaryStatistics
      统计数据的收集状态，如count，min，max，sum和average。
      Methods in java.util with parameters of type LongConsumer
      Modifier and Type | 方法 | 描述
      default void PrimitiveIterator.OfLong.forEachRemaining​(LongConsumer action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void | Spliterator.OfLong.forEachRemaining​(LongConsumer action)
      void OptionalLong.ifPresent​(LongConsumer action)
      如果存在值，则使用该值执行给定的操作，否则不执行任何操作。
      void OptionalLong.ifPresentOrElse​(LongConsumer action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      boolean | Spliterator.OfLong.tryAdvance​(LongConsumer action)

    • Uses of LongConsumer in java.util.function

      Methods in java.util.function that return LongConsumer
      Modifier and Type 方法 描述
      default LongConsumer LongConsumer.andThen​(LongConsumer after)
      返回一个组成的 LongConsumer ，依次执行此操作，然后执行 after操作。
      Methods in java.util.function with parameters of type LongConsumer
      Modifier and Type 方法 描述
      default LongConsumer LongConsumer.andThen​(LongConsumer after)
      返回一个组成的 LongConsumer ，依次执行此操作，然后执行 after操作。

    • Uses of LongConsumer in java.util.stream

      Subinterfaces of LongConsumer in java.util.stream
      Modifier and Type 接口 描述
      static interface  LongStream.Builder
      一个 LongStream可变构建器。
      Methods in java.util.stream with parameters of type LongConsumer
      Modifier and Type 方法 描述
      void LongStream.forEach​(LongConsumer action)
      对此流的每个元素执行操作。
      void LongStream.forEachOrdered​(LongConsumer action)
      对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。
      LongStream LongStream.peek​(LongConsumer action)
      Returns a stream consisting of the elements of this stream, additionally performing the provided action on each element as elements are consumed from the resulting stream.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.LongFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.LongFunction

  • Packages that use LongFunction
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongFunction in java.util.stream

      Methods in java.util.stream with parameters of type LongFunction
      Modifier and Type 方法 描述
      LongStream LongStream.flatMap​(LongFunction<? extends LongStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      <U> Stream<U> LongStream.mapToObj​(LongFunction<? extends U> mapper)
      返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.LongPredicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.LongPredicate

  • Packages that use LongPredicate
    软件包 描述
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongPredicate in java.util.function

      Methods in java.util.function that return LongPredicate
      Modifier and Type 方法 描述
      default LongPredicate LongPredicate.and​(LongPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default LongPredicate LongPredicate.negate​()
      返回表示此谓词的逻辑否定的谓词。
      default LongPredicate LongPredicate.or​(LongPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      Methods in java.util.function with parameters of type LongPredicate
      Modifier and Type 方法 描述
      default LongPredicate LongPredicate.and​(LongPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default LongPredicate LongPredicate.or​(LongPredicate other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。

    • Uses of LongPredicate in java.util.stream

      Methods in java.util.stream with parameters of type LongPredicate
      Modifier and Type 方法 描述
      boolean LongStream.allMatch​(LongPredicate predicate)
      返回此流的所有元素是否与提供的谓词匹配。
      boolean LongStream.anyMatch​(LongPredicate predicate)
      返回此流的任何元素是否与提供的谓词匹配。
      default LongStream LongStream.dropWhile​(LongPredicate predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      LongStream LongStream.filter​(LongPredicate predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      static LongStream LongStream.iterate​(long seed, LongPredicate hasNext, LongUnaryOperator next)
      返回通过将给定的 next函数迭代应用于初始元素产生的顺序 LongStream ，其条件是满足给定的 hasNext谓词。
      boolean LongStream.noneMatch​(LongPredicate predicate)
      返回此流的元素是否与提供的谓词匹配。
      default LongStream LongStream.takeWhile​(LongPredicate predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.LongSupplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.LongSupplier

  • Packages that use LongSupplier
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongSupplier in java.util

      Methods in java.util with parameters of type LongSupplier
      Modifier and Type 方法 描述
      long OptionalLong.orElseGet​(LongSupplier supplier)
      如果存在值，则返回值，否则返回由供应函数产生的结果。

    • Uses of LongSupplier in java.util.stream

      Methods in java.util.stream with parameters of type LongSupplier
      Modifier and Type 方法 描述
      static LongStream LongStream.generate​(LongSupplier s)
      返回无限顺序无序流，其中每个元素由提供的 LongSupplier生成。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.LongToDoubleFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.LongToDoubleFunction

  • Packages that use LongToDoubleFunction
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongToDoubleFunction in java.util.stream

      Methods in java.util.stream with parameters of type LongToDoubleFunction
      Modifier and Type 方法 描述
      DoubleStream LongStream.mapToDouble​(LongToDoubleFunction mapper)
      返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.LongToIntFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.LongToIntFunction

  • Packages that use LongToIntFunction
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongToIntFunction in java.util.stream

      Methods in java.util.stream with parameters of type LongToIntFunction
      Modifier and Type 方法 描述
      IntStream LongStream.mapToInt​(LongToIntFunction mapper)
      返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.LongUnaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.LongUnaryOperator

  • Packages that use LongUnaryOperator
    软件包 描述
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongUnaryOperator in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic with parameters of type LongUnaryOperator
      Modifier and Type 方法 描述
      long AtomicLong.getAndUpdate​(LongUnaryOperator updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。
      long AtomicLongArray.getAndUpdate​(int i, LongUnaryOperator updateFunction)
      使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。
      long AtomicLongFieldUpdater.getAndUpdate​(T obj, LongUnaryOperator updateFunction)
      原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回上一个值。
      long AtomicLong.updateAndGet​(LongUnaryOperator updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新后的值。
      long AtomicLongArray.updateAndGet​(int i, LongUnaryOperator updateFunction)
      使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      long AtomicLongFieldUpdater.updateAndGet​(T obj, LongUnaryOperator updateFunction)
      原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新器管理的给定对象的字段与应用给定函数的结果，返回更新的值。

    • Uses of LongUnaryOperator in java.util.function

      Methods in java.util.function that return LongUnaryOperator
      Modifier and Type 方法 描述
      default LongUnaryOperator LongUnaryOperator.andThen​(LongUnaryOperator after)
      返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
      default LongUnaryOperator LongUnaryOperator.compose​(LongUnaryOperator before)
      返回一个 before运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。
      static LongUnaryOperator LongUnaryOperator.identity​()
      返回始终返回其输入参数的一元运算符。
      Methods in java.util.function with parameters of type LongUnaryOperator
      Modifier and Type 方法 描述
      default LongUnaryOperator LongUnaryOperator.andThen​(LongUnaryOperator after)
      返回一个 after运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
      default LongUnaryOperator LongUnaryOperator.compose​(LongUnaryOperator before)
      返回一个组合运算符，首先将其 before符应用于其输入，然后将该运算符应用于结果。

    • Uses of LongUnaryOperator in java.util.stream

      Methods in java.util.stream with parameters of type LongUnaryOperator
      Modifier and Type 方法 描述
      static LongStream LongStream.iterate​(long seed, LongPredicate hasNext, LongUnaryOperator next)
      返回通过将给定的 next函数迭代应用到初始元素产生的顺序 LongStream ，其条件是满足给定的 hasNext谓词。
      static LongStream LongStream.iterate​(long seed, LongUnaryOperator f)
      返回有序无限连续 LongStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      LongStream LongStream.map​(LongUnaryOperator mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.ObjDoubleConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.ObjDoubleConsumer

  • Packages that use ObjDoubleConsumer
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of ObjDoubleConsumer in java.util.stream

      Methods in java.util.stream with parameters of type ObjDoubleConsumer
      Modifier and Type 方法 描述
      <R> R DoubleStream.collect​(Supplier<R> supplier, ObjDoubleConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.ObjIntConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.ObjIntConsumer

  • Packages that use ObjIntConsumer
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of ObjIntConsumer in java.util.stream

      Methods in java.util.stream with parameters of type ObjIntConsumer
      Modifier and Type 方法 描述
      <R> R IntStream.collect​(Supplier<R> supplier, ObjIntConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.ObjLongConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.ObjLongConsumer

  • Packages that use ObjLongConsumer
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of ObjLongConsumer in java.util.stream

      Methods in java.util.stream with parameters of type ObjLongConsumer
      Modifier and Type 方法 描述
      <R> R LongStream.collect​(Supplier<R> supplier, ObjLongConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.Predicate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.Predicate

  • Packages that use Predicate
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。

    • Uses of Predicate in java.util

      Methods in java.util with parameters of type Predicate
      Modifier and Type | 方法 | 描述
      Optional<T> Optional.filter​(Predicate<? super T> predicate)
      如果存在值，并且该值与给定谓词匹配，则返回描述该值的 Optional ，否则返回一个空的 Optional 。
      boolean | ArrayDeque.removeIf​(Predicate<? super E> filter)
      boolean | ArrayList.removeIf​(Predicate<? super E> filter)
      default boolean Collection.removeIf​(Predicate<? super E> filter)
      删除满足给定谓词的此集合的所有元素。
      boolean | Vector.removeIf​(Predicate<? super E> filter)

    • Uses of Predicate in java.util.concurrent

      Methods in java.util.concurrent with parameters of type Predicate
      Modifier and Type | 方法 | 描述
      boolean | ArrayBlockingQueue.removeIf​(Predicate<? super E> filter)
      boolean | ConcurrentLinkedDeque.removeIf​(Predicate<? super E> filter)
      boolean | ConcurrentLinkedQueue.removeIf​(Predicate<? super E> filter)
      boolean | CopyOnWriteArrayList.removeIf​(Predicate<? super E> filter)
      boolean | CopyOnWriteArraySet.removeIf​(Predicate<? super E> filter)
      boolean | LinkedBlockingDeque.removeIf​(Predicate<? super E> filter)
      boolean | LinkedBlockingQueue.removeIf​(Predicate<? super E> filter)
      boolean | LinkedTransferQueue.removeIf​(Predicate<? super E> filter)
      Constructors in java.util.concurrent with parameters of type Predicate
      Constructor 描述
      ForkJoinPool​(int parallelism, ForkJoinPool.ForkJoinWorkerThreadFactory factory, Thread.UncaughtExceptionHandler handler, boolean asyncMode, int corePoolSize, int maximumPoolSize, int minimumRunnable, Predicate<? super ForkJoinPool> saturate, long keepAliveTime, TimeUnit unit)
      使用给定的参数创建一个 ForkJoinPool 。

    • Uses of Predicate in java.util.function

      Methods in java.util.function that return Predicate
      Modifier and Type 方法 描述
      default Predicate<T> Predicate.and​(Predicate<? super T> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      static <T> Predicate<T> Predicate.isEqual​(Object targetRef)
      返回根据 Objects.equals(Object, Object)测试两个参数是否相等的 谓词 。
      default Predicate<T> Predicate.negate​()
      返回表示此谓词的逻辑否定的谓词。
      default Predicate<T> Predicate.or​(Predicate<? super T> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
      Methods in java.util.function with parameters of type Predicate
      Modifier and Type 方法 描述
      default Predicate<T> Predicate.and​(Predicate<? super T> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
      default Predicate<T> Predicate.or​(Predicate<? super T> other)
      返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。

    • Uses of Predicate in java.util.regex

      Methods in java.util.regex that return Predicate
      Modifier and Type 方法 描述
      Predicate<String> Pattern.asPredicate​()
      创建可用于匹配字符串的谓词。

    • Uses of Predicate in java.util.stream

      Methods in java.util.stream with parameters of type Predicate
      Modifier and Type 方法 描述
      boolean Stream.allMatch​(Predicate<? super T> predicate)
      返回此流的所有元素是否与提供的谓词匹配。
      boolean Stream.anyMatch​(Predicate<? super T> predicate)
      返回此流的任何元素是否与提供的谓词匹配。
      default Stream<T> Stream.dropWhile​(Predicate<? super T> predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      Stream<T> Stream.filter​(Predicate<? super T> predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      static <T,A,R> Collector<T,?,R> Collectors.filtering​(Predicate<? super T> predicate, Collector<? super T,A,R> downstream)
      适应一个 Collector相同类型的一个接受元件 T通过将谓词给每个输入元素并且如果所述谓词仅返回累积 true 。
      static <T> Stream<T> Stream.iterate​(T seed, Predicate<? super T> hasNext, UnaryOperator<T> next)
      返回通过将给定的 next函数迭代应用于初始元素 Stream产生的顺序 Stream ，其条件是满足给定的 hasNext谓词。
      boolean Stream.noneMatch​(Predicate<? super T> predicate)
      返回此流的元素是否与提供的谓词匹配。
      static <T> Collector<T,?,Map<Boolean,List<T>>> Collectors.partitioningBy​(Predicate<? super T> predicate)
      返回 Collector由划分根据所述输入元件 Predicate ，并且将它们组织到一个 Map<Boolean, List<T>> 。
      static <T,D,A> Collector<T,?,Map<Boolean,D>> Collectors.partitioningBy​(Predicate<? super T> predicate, Collector<? super T,A,D> downstream)
      返回 Collector由划分根据所述输入元件 Predicate ，减少了在根据另一每个分区中的值 Collector ，并且将它们组织到一个 Map<Boolean, D>其值是下游减少的结果。
      default Stream<T> Stream.takeWhile​(Predicate<? super T> predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。

    • Uses of Predicate in javafx.collections

      Methods in javafx.collections with parameters of type Predicate
      Modifier and Type 方法 描述
      default FilteredList<E> ObservableList.filtered​(Predicate<E> predicate)
      使用指定的谓词创建此列表的FilteredList包装器。

    • Uses of Predicate in javafx.collections.transformation

      Methods in javafx.collections.transformation that return Predicate
      Modifier and Type 方法 描述
      Predicate<? super E> FilteredList.getPredicate​()
      获取属性谓词的值。
      Methods in javafx.collections.transformation that return types with arguments of type Predicate
      Modifier and Type 方法 描述
      ObjectProperty<Predicate<? super E>> FilteredList.predicateProperty​()
      该谓词将匹配此FilteredList中的元素。
      Methods in javafx.collections.transformation with parameters of type Predicate
      Modifier and Type 方法 描述
      void FilteredList.setPredicate​(Predicate<? super E> predicate)
      设置属性谓词的值。
      Constructors in javafx.collections.transformation with parameters of type Predicate
      Constructor 描述
      FilteredList​(ObservableList<E> source, Predicate<? super E> predicate)
      在源列表周围构造一个新的FilteredList包装器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.Supplier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.Supplier

  • Packages that use Supplier
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。

    • Uses of Supplier in java.lang

      Methods in java.lang with parameters of type Supplier
      Modifier and Type 方法 描述
      default void System.Logger.log​(System.Logger.Level level, Supplier<String> msgSupplier)
      记录一个懒惰的提供的消息。
      default void System.Logger.log​(System.Logger.Level level, Supplier<String> msgSupplier, Throwable thrown)
      记录与给定的可抛物线相关联的延迟提供的消息。
      static <S> ThreadLocal<S> ThreadLocal.withInitial​(Supplier<? extends S> supplier)
      创建线程局部变量。

    • Uses of Supplier in java.lang.module

      Methods in java.lang.module with parameters of type Supplier
      Modifier and Type 方法 描述
      static ModuleDescriptor ModuleDescriptor.read​(InputStream in, Supplier<Set<String>> packageFinder)
      从输入流读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor ModuleDescriptor.read​(ByteBuffer bb, Supplier<Set<String>> packageFinder)
      从字节缓冲区中读取模块声明的二进制形式作为模块描述符。

    • Uses of Supplier in java.util

      Subinterfaces of Supplier in java.util
      Modifier and Type 接口 描述
      static interface  ServiceLoader.Provider<S>
      代表由 ServiceLoader位于的服务提供商。
      Methods in java.util with parameters of type Supplier
      Modifier and Type 方法 描述
      Optional<T> Optional.or​(Supplier<? extends Optional<? extends T>> supplier)
      如果值存在时，返回一个 Optional描述的值，否则返回一个 Optional通过供给函数产生。
      T Optional.orElseGet​(Supplier<? extends T> supplier)
      如果存在值，则返回值，否则返回由供应函数产生的结果。
      <X extends Throwable>
      T             		Optional.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      <X extends Throwable>
      double             		OptionalDouble.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      <X extends Throwable>
      int             		OptionalInt.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      <X extends Throwable>
      long             		OptionalLong.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      static <T> T Objects.requireNonNull​(T obj, Supplier<String> messageSupplier)
      检查指定的对象引用不是null并抛出自定义的NullPointerException（如果是）。
      static <T> T Objects.requireNonNullElseGet​(T obj, Supplier<? extends T> supplier)
      如果非 null返回第一个参数，否则返回非 null值为 supplier.get() 。

    • Uses of Supplier in java.util.concurrent

      Methods in java.util.concurrent with parameters of type Supplier
      Modifier and Type 方法 描述
      CompletableFuture<T> CompletableFuture.completeAsync​(Supplier<? extends T> supplier)
      使用默认执行程序从异步任务调用给定的供应商函数的结果，完成此CompletableFuture。
      CompletableFuture<T> CompletableFuture.completeAsync​(Supplier<? extends T> supplier, Executor executor)
      使用给定的执行器从异步任务调用给定的供应商函数的结果来完成此CompletableFuture。
      static <U> CompletableFuture<U> CompletableFuture.supplyAsync​(Supplier<U> supplier)
      返回一个新的CompletableFuture，它由在 ForkJoinPool.commonPool()中运行的任务异步完成，并通过调用给定的供应商获得的值。
      static <U> CompletableFuture<U> CompletableFuture.supplyAsync​(Supplier<U> supplier, Executor executor)
      返回一个新的CompletableFuture，由给定执行器中运行的任务异步完成，并通过调用给定的供应商获得的值。

    • Uses of Supplier in java.util.logging

      Methods in java.util.logging with parameters of type Supplier
      Modifier and Type 方法 描述
      void Logger.config​(Supplier<String> msgSupplier)
      记录一个CONFIG消息，只有在记录级别实际上记录该消息时，才能构建一个CONFIG消息。
      void Logger.fine​(Supplier<String> msgSupplier)
      记录一个FINE消息，只有在记录级别实际上记录该消息时才会被构造。
      void Logger.finer​(Supplier<String> msgSupplier)
      记录一个FINER消息，只有在记录级别实际上记录该消息时，才会构建一个FINER消息。
      void Logger.finest​(Supplier<String> msgSupplier)
      记录一个FINEST消息，只有当记录级别实际上记录消息时，才能构建FINEST消息。
      void Logger.info​(Supplier<String> msgSupplier)
      记录INFO消息，只有在记录级别实际记录消息时，才能构建INFO消息。
      void Logger.log​(Level level, Throwable thrown, Supplier<String> msgSupplier)
      记录一个懒惰构造的消息，并附带相关的Throwable信息。
      void Logger.log​(Level level, Supplier<String> msgSupplier)
      记录一条消息，只有在日志记录级别实际上记录该消息时才会被构造。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, Throwable thrown, Supplier<String> msgSupplier)
      记录一个懒惰构造的消息，指定源类和方法以及相关联的Throwable信息。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, Supplier<String> msgSupplier)
      记录一个延迟构造的消息，指定源类和方法，没有参数。
      void Logger.severe​(Supplier<String> msgSupplier)
      记录一个SEVERE消息，只有当记录级别实际上记录该消息时，才会构建一个SEVERE消息。
      void Logger.warning​(Supplier<String> msgSupplier)
      记录一条警告消息，只有当记录级别实际上记录消息时，才能构建一条警告消息。

    • Uses of Supplier in java.util.stream

      Methods in java.util.stream that return Supplier
      Modifier and Type 方法 描述
      Supplier<A> Collector.supplier​()
      一个创建并返回一个新的可变结果容器的函数。
      Methods in java.util.stream with parameters of type Supplier
      Modifier and Type 方法 描述
      <R> R DoubleStream.collect​(Supplier<R> supplier, ObjDoubleConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      <R> R IntStream.collect​(Supplier<R> supplier, ObjIntConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      <R> R LongStream.collect​(Supplier<R> supplier, ObjLongConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      <R> R Stream.collect​(Supplier<R> supplier, BiConsumer<R,? super T> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      static DoubleStream StreamSupport.doubleStream​(Supplier<? extends Spliterator.OfDouble> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 DoubleStream从 Supplier的 Spliterator.OfDouble 。
      static <T> Stream<T> Stream.generate​(Supplier<? extends T> s)
      返回无限顺序无序流，其中每个元素由提供的 Supplier生成。
      static <T,K,D,A,M extends Map<K,D>>
      Collector<T,?,M>             		Collectors.groupingBy​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回一个 Collector对类型为 T输入元素进行级联“分组”操作，根据分类功能分组元素，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K,A,D,M extends ConcurrentMap<K,D>>
      Collector<T,?,M>             		Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回并行的 Collector ，对 T类型的输入元素执行级联“分组”操作，根据分类功能分组元素，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static IntStream StreamSupport.intStream​(Supplier<? extends Spliterator.OfInt> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 IntStream从 Supplier的 Spliterator.OfInt 。
      static LongStream StreamSupport.longStream​(Supplier<? extends Spliterator.OfLong> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 LongStream从 Supplier的 Spliterator.OfLong 。
      static <T,A,R> Collector<T,A,R> Collector.of​(Supplier<A> supplier, BiConsumer<A,T> accumulator, BinaryOperator<A> combiner, Function<A,R> finisher, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ， combiner ，并 finisher功能。
      static <T,R> Collector<T,R,R> Collector.of​(Supplier<R> supplier, BiConsumer<R,T> accumulator, BinaryOperator<R> combiner, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ，并 combiner功能。
      static <T> Stream<T> StreamSupport.stream​(Supplier<? extends Spliterator<T>> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 Stream从 Supplier的 Spliterator 。
      static <T,C extends Collection<T>>
      Collector<T,?,C>             		Collectors.toCollection​(Supplier<C> collectionFactory)
      返回一个 Collector ，按照遇到的顺序将输入元素累加到新的 Collection中。
      static <T,K,U,M extends ConcurrentMap<K,U>>
      Collector<T,?,M>             		Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U,M extends Map<K,U>>
      Collector<T,?,M>             		Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个 Collector ，它将元素累加到 Map其键和值是将所提供的映射函数应用于输入元素的结果。

    • Uses of Supplier in jdk.dynalink.linker

      Classes in jdk.dynalink.linker that implement Supplier
      Modifier and Type Class 描述
      class  GuardingDynamicLinkerExporter
      作为保护动态链接器的供应商的类，可以由其他语言运行时自动加载。
      Methods in jdk.dynalink.linker with parameters of type Supplier
      Modifier and Type 方法 描述
      GuardedInvocation GuardingTypeConverterFactory.convertToType​(Class<?> sourceType, Class<?> targetType, Supplier<MethodHandles.Lookup> lookupSupplier)
      返回受保护的类型转换，它接收指定的源类型的值，并返回转换为指定的目标类型的值。
      <T> T LinkerServices.getWithLookup​(Supplier<T> operation, SecureLookupSupplier lookupSupplier)
      在特定的 MethodHandles.Lookup查找对象的上下文中执行操作。

    • Uses of Supplier in jdk.incubator.http

      Methods in jdk.incubator.http with parameters of type Supplier
      Modifier and Type 方法 描述
      static HttpRequest.BodyProcessor HttpRequest.BodyProcessor.fromInputStream​(Supplier<? extends InputStream> streamSupplier)
      请求体处理器从InputStream中读取其数据。

    • Uses of Supplier in jdk.jshell

      Methods in jdk.jshell with parameters of type Supplier
      Modifier and Type 方法 描述
      JShell.Builder JShell.Builder.tempVariableNameGenerator​(Supplier<String> generator)
      为VarSnippet设置Snippet.SubKind.TEMP_VAR_EXPRESSION_SUBKIND的临时变量名称生成器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.ToDoubleBiFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.ToDoubleBiFunction

  • Packages that use ToDoubleBiFunction
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ToDoubleBiFunction in java.util.concurrent

      Methods in java.util.concurrent with parameters of type ToDoubleBiFunction
      Modifier and Type 方法 描述
      double ConcurrentHashMap.reduceToDouble​(long parallelismThreshold, ToDoubleBiFunction<? super K,? super V> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.ToDoubleFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.ToDoubleFunction

  • Packages that use ToDoubleFunction
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of ToDoubleFunction in java.util

      Methods in java.util with parameters of type ToDoubleFunction
      Modifier and Type 方法 描述
      static <T> Comparator<T> Comparator.comparingDouble​(ToDoubleFunction<? super T> keyExtractor)
      接受提取功能 double从类型排序键 T ，并返回一个 Comparator<T> ，通过那种关键的。
      default Comparator<T> Comparator.thenComparingDouble​(ToDoubleFunction<? super T> keyExtractor)
      返回具有提取 double排序键的功能的字典顺序比较器。

    • Uses of ToDoubleFunction in java.util.concurrent

      Methods in java.util.concurrent with parameters of type ToDoubleFunction
      Modifier and Type 方法 描述
      double ConcurrentHashMap.reduceEntriesToDouble​(long parallelismThreshold, ToDoubleFunction<Map.Entry<K,V>> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      double ConcurrentHashMap.reduceKeysToDouble​(long parallelismThreshold, ToDoubleFunction<? super K> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
      double ConcurrentHashMap.reduceValuesToDouble​(long parallelismThreshold, ToDoubleFunction<? super V> transformer, double basis, DoubleBinaryOperator reducer)
      返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。

    • Uses of ToDoubleFunction in java.util.stream

      Methods in java.util.stream with parameters of type ToDoubleFunction
      Modifier and Type 方法 描述
      static <T> Collector<T,?,Double> Collectors.averagingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个产生应用于输入元素的双值函数的算术平均值的 Collector 。
      DoubleStream Stream.mapToDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
      static <T> Collector<T,?,DoubleSummaryStatistics> Collectors.summarizingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 Collector ，它为每个输入元素应用 double生产映射函数，并返回结果值的汇总统计信息。
      static <T> Collector<T,?,Double> Collectors.summingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个产生应用于输入元素的双值函数之和的 Collector 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.ToIntBiFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.ToIntBiFunction

  • Packages that use ToIntBiFunction
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ToIntBiFunction in java.util.concurrent

      Methods in java.util.concurrent with parameters of type ToIntBiFunction
      Modifier and Type 方法 描述
      int ConcurrentHashMap.reduceToInt​(long parallelismThreshold, ToIntBiFunction<? super K,? super V> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.ToIntFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.ToIntFunction

  • Packages that use ToIntFunction
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of ToIntFunction in java.util

      Methods in java.util with parameters of type ToIntFunction
      Modifier and Type 方法 描述
      static <T> Comparator<T> Comparator.comparingInt​(ToIntFunction<? super T> keyExtractor)
      接受从类型 T中提取 int排序键的功能，并返回一个 Comparator<T> ，该数据按该排序键进行比较。
      default Comparator<T> Comparator.thenComparingInt​(ToIntFunction<? super T> keyExtractor)
      返回具有提取 int排序键的功能的字典顺序比较器。

    • Uses of ToIntFunction in java.util.concurrent

      Methods in java.util.concurrent with parameters of type ToIntFunction
      Modifier and Type 方法 描述
      int ConcurrentHashMap.reduceEntriesToInt​(long parallelismThreshold, ToIntFunction<Map.Entry<K,V>> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      int ConcurrentHashMap.reduceKeysToInt​(long parallelismThreshold, ToIntFunction<? super K> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
      int ConcurrentHashMap.reduceValuesToInt​(long parallelismThreshold, ToIntFunction<? super V> transformer, int basis, IntBinaryOperator reducer)
      返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。

    • Uses of ToIntFunction in java.util.stream

      Methods in java.util.stream with parameters of type ToIntFunction
      Modifier and Type 方法 描述
      static <T> Collector<T,?,Double> Collectors.averagingInt​(ToIntFunction<? super T> mapper)
      返回一个产生应用于输入元素的整数值函数的算术平均值的 Collector 。
      IntStream Stream.mapToInt​(ToIntFunction<? super T> mapper)
      返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
      static <T> Collector<T,?,IntSummaryStatistics> Collectors.summarizingInt​(ToIntFunction<? super T> mapper)
      返回一个 Collector ， int生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
      static <T> Collector<T,?,Integer> Collectors.summingInt​(ToIntFunction<? super T> mapper)
      返回一个 Collector ，它产生应用于输入元素的整数值函数的和。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.ToLongBiFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.ToLongBiFunction

  • Packages that use ToLongBiFunction
    软件包 描述
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of ToLongBiFunction in java.util.concurrent

      Methods in java.util.concurrent with parameters of type ToLongBiFunction
      Modifier and Type 方法 描述
      long ConcurrentHashMap.reduceToLong​(long parallelismThreshold, ToLongBiFunction<? super K,? super V> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.ToLongFunction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.ToLongFunction

  • Packages that use ToLongFunction
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of ToLongFunction in java.util

      Methods in java.util with parameters of type ToLongFunction
      Modifier and Type 方法 描述
      static <T> Comparator<T> Comparator.comparingLong​(ToLongFunction<? super T> keyExtractor)
      接受提取功能 long从类型排序键 T ，并返回一个 Comparator<T> ，通过那种关键的。
      default Comparator<T> Comparator.thenComparingLong​(ToLongFunction<? super T> keyExtractor)
      返回具有提取 long排序键的功能的字典顺序比较器。

    • Uses of ToLongFunction in java.util.concurrent

      Methods in java.util.concurrent with parameters of type ToLongFunction
      Modifier and Type 方法 描述
      long ConcurrentHashMap.reduceEntriesToLong​(long parallelismThreshold, ToLongFunction<Map.Entry<K,V>> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
      long ConcurrentHashMap.reduceKeysToLong​(long parallelismThreshold, ToLongFunction<? super K> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
      long ConcurrentHashMap.reduceValuesToLong​(long parallelismThreshold, ToLongFunction<? super V> transformer, long basis, LongBinaryOperator reducer)
      返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。

    • Uses of ToLongFunction in java.util.stream

      Methods in java.util.stream with parameters of type ToLongFunction
      Modifier and Type 方法 描述
      static <T> Collector<T,?,Double> Collectors.averagingLong​(ToLongFunction<? super T> mapper)
      返回产生应用于输入元素的长值函数的算术平均值的 Collector 。
      LongStream Stream.mapToLong​(ToLongFunction<? super T> mapper)
      返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
      static <T> Collector<T,?,LongSummaryStatistics> Collectors.summarizingLong​(ToLongFunction<? super T> mapper)
      返回一个 Collector ， long生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
      static <T> Collector<T,?,Long> Collectors.summingLong​(ToLongFunction<? super T> mapper)
      返回一个 Collector ，它产生应用于输入元素的长值函数的和。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.function.UnaryOperator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.function.UnaryOperator

  • Packages that use UnaryOperator
    软件包 描述
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of UnaryOperator in java.time.temporal

      Methods in java.time.temporal with parameters of type UnaryOperator
      Modifier and Type 方法 描述
      static TemporalAdjuster TemporalAdjusters.ofDateAdjuster​(UnaryOperator<LocalDate> dateBasedAdjuster)
      获取一个 TemporalAdjuster包裹日期调整器。

    • Uses of UnaryOperator in java.util

      Methods in java.util with parameters of type UnaryOperator
      Modifier and Type | 方法 | 描述
      void | ArrayList.replaceAll​(UnaryOperator<E> operator)
      default void List.replaceAll​(UnaryOperator<E> operator)
      将该列表的每个元素替换为将该运算符应用于该元素的结果。
      void | Vector.replaceAll​(UnaryOperator<E> operator)

    • Uses of UnaryOperator in java.util.concurrent

      Methods in java.util.concurrent with parameters of type UnaryOperator
      Modifier and Type | 方法 | 描述
      void | CopyOnWriteArrayList.replaceAll​(UnaryOperator<E> operator)

    • Uses of UnaryOperator in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic with parameters of type UnaryOperator
      Modifier and Type 方法 描述
      V AtomicReference.getAndUpdate​(UnaryOperator<V> updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回上一个值。
      E AtomicReferenceArray.getAndUpdate​(int i, UnaryOperator<E> updateFunction)
      使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。
      V AtomicReferenceFieldUpdater.getAndUpdate​(T obj, UnaryOperator<V> updateFunction)
      原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新器管理的给定对象的字段与应用给定函数的结果，返回上一个值。
      V AtomicReference.updateAndGet​(UnaryOperator<V> updateFunction)
      使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      E AtomicReferenceArray.updateAndGet​(int i, UnaryOperator<E> updateFunction)
      使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
      V AtomicReferenceFieldUpdater.updateAndGet​(T obj, UnaryOperator<V> updateFunction)
      通过应用给定函数的结果，原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段返回更新的值。

    • Uses of UnaryOperator in java.util.function

      Methods in java.util.function that return UnaryOperator
      Modifier and Type 方法 描述
      static <T> UnaryOperator<T> UnaryOperator.identity​()
      返回始终返回其输入参数的一元运算符。

    • Uses of UnaryOperator in java.util.stream

      Methods in java.util.stream with parameters of type UnaryOperator
      Modifier and Type 方法 描述
      static <T> Stream<T> Stream.iterate​(T seed, Predicate<? super T> hasNext, UnaryOperator<T> next)
      返回通过将给定的 next函数迭代应用于初始元素 Stream产生的顺序 Stream ，其条件是满足给定的 hasNext谓词。
      static <T> Stream<T> Stream.iterate​(T seed, UnaryOperator<T> f)
      返回有序无限连续 Stream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等

    • Uses of UnaryOperator in javafx.scene.control

      Methods in javafx.scene.control that return UnaryOperator
      Modifier and Type 方法 描述
      UnaryOperator<TextFormatter.Change> TextFormatter.getFilter​()
      过滤器允许用户截取和修改对文本内容所做的任何更改。
      Constructors in javafx.scene.control with parameters of type UnaryOperator
      Constructor 描述
      TextFormatter​(UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器创建一个新的Formatter。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue, UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器，值转换器和默认值创建一个新的格式化器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Attributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Class Attributes

  • java.lang.Object
    • java.util.jar.Attributes
  • All Implemented Interfaces:
    Cloneable ， Map<Object,Object>

    public class Attributes
extends Object
implements Map<Object,Object>, Cloneable
    属性类将Manifest属性名称映射到关联的字符串值。 有效的属性名称不区分大小写，限于set [0-9a-zA-Z_-]中的ASCII字符，长度不能超过70个字符。 属性值可以包含任何字符，并且在写入输出流时将被UTF8编码。 有关有效属性名称和值的更多信息，请参阅JAR File Specification 。

    该地图及其视图具有可预测的迭代顺序，即密钥插入到地图中的顺序，如LinkedHashMap所示 。

    从以下版本开始：
    1.2
    另请参见：
    Manifest

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Attributes.Name
      Attributes.Name类表示存储在此Map中的属性名称。

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Map<Object,Object> map
      属性名称 - 值映射。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Attributes​()
      构造一个具有默认大小的新的空的Attributes对象。
      Attributes​(int size)
      构造具有指定的初始大小的新的空的Attributes对象。
      Attributes​(Attributes attr)
      构造具有与指定属性中相同的属性名称 - 值映射的新Attributes对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      从此地图中删除所有属性。
      Object clone​()
      返回属性的副本，实现如下：
      boolean containsKey​(Object name)
      如果此Map包含指定的属性名称（key），则返回true。
      boolean containsValue​(Object value)
      如果此Map将一个或多个属性名称（键）映射到指定的值，则返回true。
      Set<Map.Entry<Object,Object>> entrySet​()
      返回此Map中包含的属性名称 - 值映射的集合视图。
      boolean equals​(Object o)
      将指定的Attributes对象与此Map进行比较以获得相等性。
      Object get​(Object name)
      返回指定属性名的值，如果未找到属性名，则返回null。
      String getValue​(String name)
      返回指定为字符串的指定属性名称的值，如果未找到该属性，则返回null。
      String getValue​(Attributes.Name name)
      返回指定的Attributes.Name的值，如果未找到该属性，则返回null。
      int hashCode​()
      返回此Map的哈希码值。
      boolean isEmpty​()
      如果此Map不包含属性，则返回true。
      Set<Object> keySet​()
      返回此Map中包含的属性名称（键）的Set视图。
      Object put​(Object name, Object value)
      将指定的值与此Map中的指定属性名称（键）相关联。
      void putAll​(Map<?,?> attr)
      将所有属性名称 - 值映射从指定的属性复制到此映射。
      String putValue​(String name, String value)
      将指定的值与指定的属性名称相关联，指定为String。
      Object remove​(Object name)
      从此Map中删除具有指定名称（键）的属性。
      int size​()
      返回此Map中的属性数。
      Collection<Object> values​()
      返回此Map中包含的属性值的集合视图。

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, forEach, getOrDefault, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • map

        protected Map<Object,Object> map
        属性名称 - 值映射。

    • 构造方法详细信息

      • Attributes

        public Attributes​()
        构造一个具有默认大小的新的空的Attributes对象。

      • Attributes

        public Attributes​(int size)
        构造具有指定的初始大小的新的空的Attributes对象。
        参数
        size - 属性的初始数

      • Attributes

        public Attributes​(Attributes attr)
        构造具有与指定属性中相同的属性名称 - 值映射的新Attributes对象。
        参数
        attr - 指定的属性

    • 方法详细信息

      • get

        public Object get​(Object name)
        返回指定属性名的值，如果未找到属性名，则返回null。
        Specified by:
        get在接口 Map<Object,Object>
        参数
        name - 属性名称
        结果
        指定属性名称的值，如果未找到，则为null。

      • getValue

        public String getValue​(String name)
        返回指定为字符串的指定属性名称的值，如果未找到该属性，则返回null。 属性名称不区分大小写。

        此方法定义为：

          return (String)get(new Attributes.Name((String)name));
        参数
        name - 属性名称作为字符串
        结果
        指定属性名称的String值，如果未找到，则返回null。
        异常
        IllegalArgumentException - 如果属性名称无效

      • getValue

        public String getValue​(Attributes.Name name)
        返回指定的Attributes.Name的值，如果未找到该属性，则返回null。

        此方法定义为：

          return (String)get(name);
        参数
        name - Attributes.Name对象
        结果
        指定的Attribute.Name的String值，如果没有找到，则返回null。

      • put

        public Object put​(Object name,
                  Object value)
        将指定的值与此Map中的指定属性名称（键）相关联。 如果地图先前包含属性名称的映射，则替换旧值。
        Specified by:
        put在接口 Map<Object,Object>
        参数
        name - 属性名称
        value - 属性值
        结果
        属性的前一个值，如果没有，则返回null
        异常
        ClassCastException - 如果名称不是Attributes.Name或值不是String

      • putValue

        public String putValue​(String name,
                       String value)
        将指定的值与指定的属性名称相关联，指定为String。 属性名称不区分大小写。 如果地图先前包含属性名称的映射，则替换旧值。

        此方法定义为：

          return (String)put(new Attributes.Name(name), value);
        参数
        name - 属性名称作为字符串
        value - 属性值
        结果
        属性的前一个值，如果没有，则返回null
        异常
        IllegalArgumentException - 属性名称是否无效

      • remove

        public Object remove​(Object name)
        从此Map中删除具有指定名称（键）的属性。 返回上一个属性值，如果没有，返回null。
        Specified by:
        remove在接口 Map<Object,Object>
        参数
        name - 属性名称
        结果
        属性的前一个值，如果没有，则返回null

      • containsValue

        public boolean containsValue​(Object value)
        如果此Map将一个或多个属性名称（键）映射到指定的值，则返回true。
        Specified by:
        containsValue在接口 Map<Object,Object>
        参数
        value - 属性值
        结果
        如果此Map将一个或多个属性名称映射到指定的值，则为true

      • containsKey

        public boolean containsKey​(Object name)
        如果此Map包含指定的属性名称（key），则返回true。
        Specified by:
        containsKey在接口 Map<Object,Object>
        参数
        name - 属性名称
        结果
        如果此Map包含指定的属性名称，则为true

      • putAll

        public void putAll​(Map<?,?> attr)
        将所有属性名称 - 值映射从指定的属性复制到此映射。 重复的映射将被替换。
        Specified by:
        putAll在接口 Map<Object,Object>
        参数
        attr - 要存储在此地图中的属性
        异常
        ClassCastException - 如果attr不是属性

      • clear

        public void clear​()
        从此地图中删除所有属性。
        Specified by:
        clear在接口 Map<Object,Object>

      • size

        public int size​()
        返回此Map中的属性数。
        Specified by:
        size在接口 Map<Object,Object>
        结果
        该地图中键值映射的数量

      • isEmpty

        public boolean isEmpty​()
        如果此Map不包含属性，则返回true。
        Specified by:
        isEmpty在接口 Map<Object,Object>
        结果
        true如果该地图不包含键值映射

      • keySet

        public Set<Object> keySet​()
        返回此Map中包含的属性名称（键）的Set视图。
        Specified by:
        keySet接口 Map<Object,Object>
        结果
        该地图中包含的键的集合视图

      • values

        public Collection<Object> values​()
        返回此Map中包含的属性值的集合视图。
        Specified by:
        values在接口 Map<Object,Object>
        结果
        该地图中包含的值的集合视图

      • entrySet

        public Set<Map.Entry<Object,Object>> entrySet​()
        返回此Map中包含的属性名称 - 值映射的集合视图。
        Specified by:
        entrySet在接口 Map<Object,Object>
        结果
        该地图中包含的映射的集合视图

      • equals

        public boolean equals​(Object o)
        将指定的Attributes对象与此Map进行比较以获得相等性。 如果给定对象也是属性的实例，并且两个Attributes对象表示相同的映射，则返回true。
        Specified by:
        equals在接口 Map<Object,Object>
        重写：
        equals中的 Object
        参数
        o - 要比较的对象
        结果
        如果指定的Object等于此Map，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此Map的哈希码值。
        Specified by:
        hashCode在接口 Map<Object,Object>
        重写：
        hashCode中的 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • clone

        public Object clone​()
        返回属性的副本，实现如下：
          public Object clone() { return new Attributes(this); }
        由于属性名称和值本身是不可变的，所以返回的属性可以安全地修改而不影响原始属性。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Attributes.Name (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Class Attributes.Name

  • java.lang.Object
    • java.util.jar.Attributes.Name
  • Enclosing class:
    Attributes

    public static class Attributes.Name
extends Object
    Attributes.Name类表示存储在此Map中的属性名称。 有效的属性名称不区分大小写，限于set [0-9a-zA-Z_-]中的ASCII字符，长度不能超过70个字符。 属性值可以包含任何字符，并且在写入输出流时将被UTF8编码。 有关有效的属性名称和值的更多信息，请参阅JAR File Specification 。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Attributes.Name CLASS_PATH
      Name对象为 Class-Path清单属性。
      static Attributes.Name CONTENT_TYPE
      Name对象为 Content-Type清单属性。
      static Attributes.Name EXTENSION_INSTALLATION
      已过时。
      扩展机制不再受支持。
      static Attributes.Name EXTENSION_LIST
      Name对象为 Extension-List清单属性用于不再支持的扩展机制。
      static Attributes.Name EXTENSION_NAME
      Name对象为 Extension-Name清单属性。
      static Attributes.Name IMPLEMENTATION_TITLE
      Name对象为 Implementation-Title用于包版本控制的清单属性。
      static Attributes.Name IMPLEMENTATION_URL
      已过时。
      扩展机制不再受支持。
      static Attributes.Name IMPLEMENTATION_VENDOR
      Name对象为 Implementation-Vendor用于包版本控制的清单属性。
      static Attributes.Name IMPLEMENTATION_VENDOR_ID
      已过时。
      扩展机制不再受支持。
      static Attributes.Name IMPLEMENTATION_VERSION
      Name对象为 Implementation-Version清单属性用于包版本控制。
      static Attributes.Name MAIN_CLASS
      Name对象，用于启动打包在JAR文件中的应用程序的 Main-Class清单属性。
      static Attributes.Name MANIFEST_VERSION
      Name对象为 Manifest-Version清单属性。
      static Attributes.Name MULTI_RELEASE
      Name对象为 Multi-Release manifest属性，表示这是一个多版本的JAR文件。
      static Attributes.Name SEALED
      Name对象为 Sealed用于密封的清单属性。
      static Attributes.Name SIGNATURE_VERSION
      Name对象为 Signature-Version签署JAR文件时使用的manifest属性。
      static Attributes.Name SPECIFICATION_TITLE
      Name对象为 Specification-Title清单属性用于包版本控制。
      static Attributes.Name SPECIFICATION_VENDOR
      Name对象为 Specification-Vendor清单属性用于包版本控制。
      static Attributes.Name SPECIFICATION_VERSION
      Name对象为 Specification-Version用于包版本控制的清单属性。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Name​(String name)
      使用给定的字符串名称构造一个新的属性名称。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将此属性名称与其他名称进行比较以获得相等性
      int hashCode​()
      计算此属性名称的哈希值。
      String toString​()
      返回属性名称作为字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MANIFEST_VERSION

        public static final Attributes.Name MANIFEST_VERSION
        Name对象为Manifest-Version清单属性。 此属性指示JAR文件的清单符合的清单标准的版本号。
        另请参见：
        Manifest and Signature Specification

      • SIGNATURE_VERSION

        public static final Attributes.Name SIGNATURE_VERSION
        Name对象，用于在签名JAR文件时使用的清单属性 Signature-Version 。
        另请参见：
        Manifest and Signature Specification

      • CONTENT_TYPE

        public static final Attributes.Name CONTENT_TYPE
        Name对象为 Content-Type清单属性。

      • CLASS_PATH

        public static final Attributes.Name CLASS_PATH
        Name对象为 Class-Path清单属性。
        另请参见：
        JAR file specification

      • MAIN_CLASS

        public static final Attributes.Name MAIN_CLASS
        Name对象为Main-Class清单属性用于启动打包在JAR文件中的应用程序。 Main-Class属性与java应用程序启动器的-jar命令行选项配合使用。

      • SEALED

        public static final Attributes.Name SEALED
        Name对象为 Sealed用于密封的manifest属性。
        另请参见：
        Package Sealing

      • EXTENSION_LIST

        public static final Attributes.Name EXTENSION_LIST
        Name对象为 Extension-List用于不再支持的扩展机制的manifest属性。

      • EXTENSION_NAME

        public static final Attributes.Name EXTENSION_NAME
        Name对象为Extension-Name清单属性。 用于不再支持的扩展机制。

      • EXTENSION_INSTALLATION

        @Deprecated
public static final Attributes.Name EXTENSION_INSTALLATION
        已过时。 扩展机制不再受支持。
        Name对象为 Extension-Installation清单属性。

      • IMPLEMENTATION_TITLE

        public static final Attributes.Name IMPLEMENTATION_TITLE
        Name对象为 Implementation-Title用于包版本控制的清单属性。

      • IMPLEMENTATION_VERSION

        public static final Attributes.Name IMPLEMENTATION_VERSION
        Name对象为 Implementation-Version用于包版本控制的清单属性。

      • IMPLEMENTATION_VENDOR

        public static final Attributes.Name IMPLEMENTATION_VENDOR
        Name对象为 Implementation-Vendor清单属性用于包版本控制。

      • IMPLEMENTATION_VENDOR_ID

        @Deprecated
public static final Attributes.Name IMPLEMENTATION_VENDOR_ID
        已过时。 扩展机制不再受支持。
        Name对象为 Implementation-Vendor-Id清单属性。

      • IMPLEMENTATION_URL

        @Deprecated
public static final Attributes.Name IMPLEMENTATION_URL
        已过时。 扩展机制不再受支持。
        Name对象为 Implementation-URL清单属性。

      • SPECIFICATION_TITLE

        public static final Attributes.Name SPECIFICATION_TITLE
        Name对象为 Specification-Title清单属性用于包版本控制。

      • SPECIFICATION_VERSION

        public static final Attributes.Name SPECIFICATION_VERSION
        Name对象为 Specification-Version用于包版本控制的manifest属性。

      • SPECIFICATION_VENDOR

        public static final Attributes.Name SPECIFICATION_VENDOR
        Name对象为 Specification-Vendor用于包版本控制的清单属性。

      • MULTI_RELEASE

        public static final Attributes.Name MULTI_RELEASE
        Name对象为 Multi-Release manifest属性，表示这是一个多版本的JAR文件。
        从以下版本开始：
        9

    • 构造方法详细信息

      • Name

        public Name​(String name)
        使用给定的字符串名称构造一个新的属性名称。
        参数
        name - 属性字符串名称
        异常
        IllegalArgumentException - 如果属性名称无效
        NullPointerException - 如果属性名称为空

    • 方法详细信息

      • equals

        public boolean equals​(Object o)
        将此属性名称与其他名称进行比较以获得相等性
        重写：
        equals在 Object
        参数
        o - 要比较的对象
        结果
        如果此属性名称等于指定的属性对象，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算此属性名称的哈希值。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回属性名称作为字符串。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


JarEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Class JarEntry

  • java.lang.Object
    • java.util.zip.ZipEntry
      • java.util.jar.JarEntry
  • All Implemented Interfaces:
    Cloneable

    public class JarEntry
extends ZipEntry
    此类用于表示JAR文件条目。
    从以下版本开始：
    1.2

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static int | CENATT
      static int | CENATX
      static int | CENCOM
      static int | CENCRC
      static int | CENDSK
      static int | CENEXT
      static int | CENFLG
      static int | CENHDR
      static int | CENHOW
      static int | CENLEN
      static int | CENNAM
      static int | CENOFF
      static long | CENSIG
      static int | CENSIZ
      static int | CENTIM
      static int | CENVEM
      static int | CENVER
      static int | ENDCOM
      static int | ENDHDR
      static int | ENDOFF
      static long | ENDSIG
      static int | ENDSIZ
      static int | ENDSUB
      static int | ENDTOT
      static int | EXTCRC
      static int | EXTHDR
      static int | EXTLEN
      static long | EXTSIG
      static int | EXTSIZ
      static int | LOCCRC
      static int | LOCEXT
      static int | LOCFLG
      static int | LOCHDR
      static int | LOCHOW
      static int | LOCLEN
      static int | LOCNAM
      static long | LOCSIG
      static int | LOCSIZ
      static int | LOCTIM
      static int | LOCVER

      • Fields inherited from class java.util.zip.ZipEntry

        DEFLATED, STORED

    • 构造方法摘要

      构造方法
      Constructor 描述
      JarEntry​(String name)
      为指定的JAR文件条目名称创建一个新的 JarEntry 。
      JarEntry​(JarEntry je)
      创建一个新的 JarEntry其中的字段取自指定的 JarEntry对象。
      JarEntry​(ZipEntry ze)
      创建一个新的 JarEntry其中的字段取自指定的 ZipEntry对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Attributes getAttributes​()
      返回 Manifest Attributes此条，或 null如果没有。
      Certificate[] getCertificates​()
      返回 Certificate对象此条，或 null如果没有。
      CodeSigner[] getCodeSigners​()
      返回 CodeSigner对象此条，或 null如果没有。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.util.zip.ZipEntry

        clone, getComment, getCompressedSize, getCrc, getCreationTime, getExtra, getLastAccessTime, getLastModifiedTime, getMethod, getName, getSize, getTime, getTimeLocal, hashCode, isDirectory, setComment, setCompressedSize, setCrc, setCreationTime, setExtra, setLastAccessTime, setLastModifiedTime, setMethod, setSize, setTime, setTimeLocal, toString

    • 字段详细信息

      • LOCSIG

        public static final long LOCSIG
        另请参见：
        Constant Field Values

      • EXTSIG

        public static final long EXTSIG
        另请参见：
        Constant Field Values

      • CENSIG

        public static final long CENSIG
        另请参见：
        Constant Field Values

      • ENDSIG

        public static final long ENDSIG
        另请参见：
        Constant Field Values

      • LOCHDR

        public static final int LOCHDR
        另请参见：
        Constant Field Values

      • EXTHDR

        public static final int EXTHDR
        另请参见：
        Constant Field Values

      • CENHDR

        public static final int CENHDR
        另请参见：
        Constant Field Values

      • ENDHDR

        public static final int ENDHDR
        另请参见：
        Constant Field Values

      • LOCVER

        public static final int LOCVER
        另请参见：
        Constant Field Values

      • LOCFLG

        public static final int LOCFLG
        另请参见：
        Constant Field Values

      • LOCHOW

        public static final int LOCHOW
        另请参见：
        Constant Field Values

      • LOCTIM

        public static final int LOCTIM
        另请参见：
        Constant Field Values

      • LOCCRC

        public static final int LOCCRC
        另请参见：
        Constant Field Values

      • LOCSIZ

        public static final int LOCSIZ
        另请参见：
        Constant Field Values

      • LOCLEN

        public static final int LOCLEN
        另请参见：
        Constant Field Values

      • LOCNAM

        public static final int LOCNAM
        另请参见：
        Constant Field Values

      • LOCEXT

        public static final int LOCEXT
        另请参见：
        Constant Field Values

      • EXTCRC

        public static final int EXTCRC
        另请参见：
        Constant Field Values

      • EXTSIZ

        public static final int EXTSIZ
        另请参见：
        Constant Field Values

      • EXTLEN

        public static final int EXTLEN
        另请参见：
        Constant Field Values

      • CENVEM

        public static final int CENVEM
        另请参见：
        Constant Field Values

      • CENVER

        public static final int CENVER
        另请参见：
        Constant Field Values

      • CENFLG

        public static final int CENFLG
        另请参见：
        Constant Field Values

      • CENHOW

        public static final int CENHOW
        另请参见：
        Constant Field Values

      • CENTIM

        public static final int CENTIM
        另请参见：
        Constant Field Values

      • CENCRC

        public static final int CENCRC
        另请参见：
        Constant Field Values

      • CENSIZ

        public static final int CENSIZ
        另请参见：
        Constant Field Values

      • CENLEN

        public static final int CENLEN
        另请参见：
        Constant Field Values

      • CENNAM

        public static final int CENNAM
        另请参见：
        Constant Field Values

      • CENEXT

        public static final int CENEXT
        另请参见：
        Constant Field Values

      • CENCOM

        public static final int CENCOM
        另请参见：
        Constant Field Values

      • CENDSK

        public static final int CENDSK
        另请参见：
        Constant Field Values

      • CENATT

        public static final int CENATT
        另请参见：
        Constant Field Values

      • CENATX

        public static final int CENATX
        另请参见：
        Constant Field Values

      • CENOFF

        public static final int CENOFF
        另请参见：
        Constant Field Values

      • ENDSUB

        public static final int ENDSUB
        另请参见：
        Constant Field Values

      • ENDTOT

        public static final int ENDTOT
        另请参见：
        Constant Field Values

      • ENDSIZ

        public static final int ENDSIZ
        另请参见：
        Constant Field Values

      • ENDOFF

        public static final int ENDOFF
        另请参见：
        Constant Field Values

      • ENDCOM

        public static final int ENDCOM
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JarEntry

        public JarEntry​(String name)
        为指定的JAR文件条目名称创建一个新的 JarEntry 。
        参数
        name - JAR文件条目名称
        异常
        NullPointerException - 如果条目名称是 null
        IllegalArgumentException - 如果条目名称长于0xFFFF字节。

      • JarEntry

        public JarEntry​(ZipEntry ze)
        创建一个新的 JarEntry其中的字段取自指定的 ZipEntry对象。
        参数
        ze - ZipEntry对象创建 JarEntry从

      • JarEntry

        public JarEntry​(JarEntry je)
        创建一个新的 JarEntry其中的字段取自指定的 JarEntry对象。
        参数
        je - 复制 JarEntry

    • 方法详细信息

      • getAttributes

        public Attributes getAttributes​()
                         throws IOException
        返回 Manifest Attributes此条，或 null如果没有。
        结果
        Manifest Attributes Manifest Attributes ，或 null如果没有
        异常
        IOException - 如果发生了I / O错误

      • getCertificates

        public Certificate[] getCertificates​()
        返回Certificate对象此条，或null如果没有。 一旦JarEntry已经通过从入口输入流读取直到流已到达完全验证，此方法才能被调用。 否则，此方法将返回null 。

        返回的证书数组包括用于验证此条目的所有签署者证书。 每个签名者证书后面都有其支持证书链（可能为空）。 每个签名者证书及其支持证书链从底部到顶部排序（即，首先签名者证书和（根）证书颁发机构的最后）。

        结果
        Certificate目的 Certificate对象，如果没有， null 。

      • getCodeSigners

        public CodeSigner[] getCodeSigners​()
        返回CodeSigner对象此条，或null如果没有。 一旦JarEntry已经通过从入口输入流读取直到流已到达完全验证，此方法才能被调用。 否则，此方法将返回null 。

        返回的数组包括已签署此条目的所有代码签名者。

        结果
        CodeSigner目的 CodeSigner对象，如果没有， null 。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


JarException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Class JarException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.util.zip.ZipException
            • java.util.jar.JarException
  • All Implemented Interfaces:
    Serializable

    public class JarException
extends ZipException
    表示在读取或写入JAR文件时发生了某种错误。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      JarException​()
      构造一个没有详细消息的JarException。
      JarException​(String s)
      构造具有指定详细消息的JarException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • JarException

        public JarException​()
        构造一个没有详细消息的JarException。

      • JarException

        public JarException​(String s)
        构造具有指定详细消息的JarException。
        参数
        s - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JarFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Class JarFile

  • java.lang.Object
    • java.util.zip.ZipFile
      • java.util.jar.JarFile
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class JarFile
extends ZipFile
    JarFile类用于从可以使用java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。 它扩展了类java.util.zip.ZipFile ，支持读取可选的Manifest条目，并支持处理多版本jar文件。 Manifest可用于指定有关jar文件及其条目的元信息。

    A multi-release jar file是一个jar文件，它包含一个名为“Multi-Release”的主属性的清单，一组“基本”条目，其中一些是具有公共或受保护方法的公共类，它们包含jar文件的公共接口，以及一组包含在“META-INF / versions”目录的子目录中的“版本化”条目。 版本化条目由Java平台的主要版本分区。 甲版本条目，具有版本n ， 8 < n ，在“META-INF /版本/ {N}”目录重写基条目以及与一个版本号中的任何条目i其中8 < i < n 。

    默认情况下，多版本jar文件的JarFile配置为处理多版本的jar文件，就像它是一个简单（未版本）的jar文件一样，并且这样的条目名称最多与一个基本条目相关联。 JarFile可以配置为通过使用JarFile(File, boolean, int, Runtime.Version)构造函数创建JarFile来处理多版本的jar文件。 Runtime.Version对象设置搜索版本条目时使用的最大版本。 当这样配置时，条目名称可以对应至多一个基本条目和零个或多个版本化条目。 需要进行搜索以将条目名称与版本小于或等于最大版本的最新版本条目相关联（请参阅getEntry(String) ）。

    利用类装载器JarFile从内容加载类JarFile条目应构建JarFile通过调用JarFile(File, boolean, int, Runtime.Version)与值构造Runtime.version()分配给最后一个参数。 这确保与主要版本的运行JVM兼容的类从多版本jar文件加载。

    如果打开签名的jar文件时验证标志已打开，则文件的内容将根据嵌入文件中的签名进行验证。 请注意，验证过程不包括验证签名者的证书。 来电者应检查JarEntry.getCodeSigners()的返回值，以进一步确定签名是否可信。

    除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    Implementation Note:
    如果API不能用于配置JarFile （例如，覆盖已编译应用程序或库的配置），则可以使用两个System属性。
    • jdk.util.jar.version可以分配一个值，即String表示的非负整数<= Runtime.version().major() 。 该值用于将有效的运行时版本设置为通过评估Runtime.version().major()获得的默认值以外的值。 当最后一个参数的值为JarFile.runtimeVersion()时，有效的运行时版本是JarFile(File, boolean, int, Runtime.Version)构造函数使用的版本。
    • jdk.util.jar.enableMultiRelease可分配三者之一String值真 ， 假 ，或力 。 值true ，默认值，启用多版本jar文件处理。 值false将禁用多版本jar处理，忽略“多版本”清单属性，如果存在多版本的jar文件，则会忽略多版本jar文件中的版本化目录。 此外，方法isMultiRelease()返回假 。 值强制使JarFile在构建后初始化为运行时版本控制。 它有效地与代码相同： (new JarFile(File, boolean, int, JarFile.runtimeVersion()) 。
    从以下版本开始：
    1.2
    另请参见：
    Manifest ， ZipFile ， JarEntry

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static int | CENATT
      static int | CENATX
      static int | CENCOM
      static int | CENCRC
      static int | CENDSK
      static int | CENEXT
      static int | CENFLG
      static int | CENHDR
      static int | CENHOW
      static int | CENLEN
      static int | CENNAM
      static int | CENOFF
      static long | CENSIG
      static int | CENSIZ
      static int | CENTIM
      static int | CENVEM
      static int | CENVER
      static int | ENDCOM
      static int | ENDHDR
      static int | ENDOFF
      static long | ENDSIG
      static int | ENDSIZ
      static int | ENDSUB
      static int | ENDTOT
      static int | EXTCRC
      static int | EXTHDR
      static int | EXTLEN
      static long | EXTSIG
      static int | EXTSIZ
      static int | LOCCRC
      static int | LOCEXT
      static int | LOCFLG
      static int | LOCHDR
      static int | LOCHOW
      static int | LOCLEN
      static int | LOCNAM
      static long | LOCSIG
      static int | LOCSIZ
      static int | LOCTIM
      static int | LOCVER
      static String MANIFEST_NAME
      JAR清单文件名。

      • Fields inherited from class java.util.zip.ZipFile

        OPEN_DELETE, OPEN_READ

    • 构造方法摘要

      构造方法
      Constructor 描述
      JarFile​(File file)
      创建一个新的 JarFile从指定的 File对象读取。
      JarFile​(File file, boolean verify)
      创建一个新的 JarFile从指定的 File对象读取。
      JarFile​(File file, boolean verify, int mode)
      创建新的 JarFile以指定的方式从指定的 File对象读取。
      JarFile​(File file, boolean verify, int mode, Runtime.Version version)
      创建新的 JarFile以指定的方式从指定的 File对象中读取。
      JarFile​(String name)
      创建一个新的 JarFile从指定的文件 name 。
      JarFile​(String name, boolean verify)
      创建一个新的 JarFile从指定的文件 name 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static Runtime.Version baseVersion​()
      返回表示多版本jar文件的未版本化配置的版本。
      Enumeration<JarEntry> entries​()
      返回枚举jar文件条目。
      ZipEntry getEntry​(String name)
      返回 ZipEntry用于给定基本条目名称 null如果没有找到。
      InputStream getInputStream​(ZipEntry ze)
      返回用于读取指定zip文件条目内容的输入流。
      JarEntry getJarEntry​(String name)
      如果 JarEntry ，则返回给定基本条目名称的 null或 null 。
      Manifest getManifest​()
      返回jar文件清单，如果没有，则返回 null 。
      Runtime.Version getVersion​()
      返回搜索版本化条目时使用的最大版本。
      boolean isMultiRelease​()
      指示此jar文件是否为多版本jar文件。
      static Runtime.Version runtimeVersion​()
      返回表示多版本jar文件的有效运行时版本配置的版本。
      Stream<JarEntry> stream​()
      在jar文件条目上返回一个有序的 Stream 。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.zip.ZipFile

        close, finalize, getComment, getName, size

    • 字段详细信息

      • MANIFEST_NAME

        public static final String MANIFEST_NAME
        JAR清单文件名。
        另请参见：
        Constant Field Values

      • LOCSIG

        public static final long LOCSIG
        另请参见：
        Constant Field Values

      • EXTSIG

        public static final long EXTSIG
        另请参见：
        Constant Field Values

      • CENSIG

        public static final long CENSIG
        另请参见：
        Constant Field Values

      • ENDSIG

        public static final long ENDSIG
        另请参见：
        Constant Field Values

      • LOCHDR

        public static final int LOCHDR
        另请参见：
        Constant Field Values

      • EXTHDR

        public static final int EXTHDR
        另请参见：
        Constant Field Values

      • CENHDR

        public static final int CENHDR
        另请参见：
        Constant Field Values

      • ENDHDR

        public static final int ENDHDR
        另请参见：
        Constant Field Values

      • LOCVER

        public static final int LOCVER
        另请参见：
        Constant Field Values

      • LOCFLG

        public static final int LOCFLG
        另请参见：
        Constant Field Values

      • LOCHOW

        public static final int LOCHOW
        另请参见：
        Constant Field Values

      • LOCTIM

        public static final int LOCTIM
        另请参见：
        Constant Field Values

      • LOCCRC

        public static final int LOCCRC
        另请参见：
        Constant Field Values

      • LOCSIZ

        public static final int LOCSIZ
        另请参见：
        Constant Field Values

      • LOCLEN

        public static final int LOCLEN
        另请参见：
        Constant Field Values

      • LOCNAM

        public static final int LOCNAM
        另请参见：
        Constant Field Values

      • LOCEXT

        public static final int LOCEXT
        另请参见：
        Constant Field Values

      • EXTCRC

        public static final int EXTCRC
        另请参见：
        Constant Field Values

      • EXTSIZ

        public static final int EXTSIZ
        另请参见：
        Constant Field Values

      • EXTLEN

        public static final int EXTLEN
        另请参见：
        Constant Field Values

      • CENVEM

        public static final int CENVEM
        另请参见：
        Constant Field Values

      • CENVER

        public static final int CENVER
        另请参见：
        Constant Field Values

      • CENFLG

        public static final int CENFLG
        另请参见：
        Constant Field Values

      • CENHOW

        public static final int CENHOW
        另请参见：
        Constant Field Values

      • CENTIM

        public static final int CENTIM
        另请参见：
        Constant Field Values

      • CENCRC

        public static final int CENCRC
        另请参见：
        Constant Field Values

      • CENSIZ

        public static final int CENSIZ
        另请参见：
        Constant Field Values

      • CENLEN

        public static final int CENLEN
        另请参见：
        Constant Field Values

      • CENNAM

        public static final int CENNAM
        另请参见：
        Constant Field Values

      • CENEXT

        public static final int CENEXT
        另请参见：
        Constant Field Values

      • CENCOM

        public static final int CENCOM
        另请参见：
        Constant Field Values

      • CENDSK

        public static final int CENDSK
        另请参见：
        Constant Field Values

      • CENATT

        public static final int CENATT
        另请参见：
        Constant Field Values

      • CENATX

        public static final int CENATX
        另请参见：
        Constant Field Values

      • CENOFF

        public static final int CENOFF
        另请参见：
        Constant Field Values

      • ENDSUB

        public static final int ENDSUB
        另请参见：
        Constant Field Values

      • ENDTOT

        public static final int ENDTOT
        另请参见：
        Constant Field Values

      • ENDSIZ

        public static final int ENDSIZ
        另请参见：
        Constant Field Values

      • ENDOFF

        public static final int ENDOFF
        另请参见：
        Constant Field Values

      • ENDCOM

        public static final int ENDCOM
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JarFile

        public JarFile​(String name)
        throws IOException
        创建一个新的JarFile从指定的文件name 。 JarFile将被验证是否已签署。
        参数
        name - 要打开阅读的jar文件的名称
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果SecurityManager拒绝对该文件的访问

      • JarFile

        public JarFile​(String name,
               boolean verify)
        throws IOException
        创建一个新的 JarFile从指定的文件 name 。
        参数
        name - 要打开阅读的jar文件的名称
        verify - 是否验证jar文件是否被签名。
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果SecurityManager对该文件的访问被拒绝

      • JarFile

        public JarFile​(File file)
        throws IOException
        创建一个新的JarFile从指定的File对象读取。 JarFile将被验证是否签署。
        参数
        file - 要打开阅读的jar文件
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果SecurityManager对该文件的访问被拒绝

      • JarFile

        public JarFile​(File file,
               boolean verify)
        throws IOException
        创建一个新的 JarFile从指定的 File对象读取。
        参数
        file - 要打开阅读的jar文件
        verify - 是否验证jar文件是否被签名。
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果SecurityManager对该文件的访问被拒绝。

      • JarFile

        public JarFile​(File file,
               boolean verify,
               int mode)
        throws IOException
        创建一个新的JarFile以指定的模式从指定的File对象中读取。 mode参数必须是OPEN_READ或OPEN_READ | OPEN_DELETE 。
        参数
        file - 要打开阅读的jar文件
        verify - 是否验证jar文件是否被签名。
        mode - 要打开文件的模式
        异常
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果 mode参数无效
        SecurityException - 如果SecurityManager对该文件的访问被拒绝
        从以下版本开始：
        1.3

      • JarFile

        public JarFile​(File file,
               boolean verify,
               int mode,
               Runtime.Version version)
        throws IOException
        创建新的JarFile以指定的方式从指定的File对象中读取。 mode参数必须是OPEN_READ或OPEN_READ | OPEN_DELETE 。 版本参数在转换为规范表单后，用于配置JarFile以处理多版本的jar文件。

        从版本参数派生的规范形式为Runtime.Version.parse(Integer.toString(n)) ，其中n为Math.max(version.major(), JarFile.baseVersion().major()) 。

        参数
        file - 要打开阅读的jar文件
        verify - 是否验证jar文件是否被签名。
        mode - 要打开文件的模式
        version - 指定多版本jar文件的发行版本
        异常
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果 mode参数无效
        SecurityException - 如果SecurityManager对该文件的访问被拒绝
        NullPointerException - 如果 version是 null
        从以下版本开始：
        9

    • 方法详细信息

      • baseVersion

        public static Runtime.Version baseVersion​()
        返回表示多版本jar文件的未版本化配置的版本。
        结果
        代表未版本化配置的版本
        从以下版本开始：
        9

      • runtimeVersion

        public static Runtime.Version runtimeVersion​()
        返回表示多版本jar文件的有效运行时版本配置的版本。

        默认情况下，返回的主要版本号Version将等于主版本号Runtime.version() 。 但是，如果设置了jdk.util.jar.version属性，则返回的Version将从该属性派生，并且主版本号可能不相等。

        结果
        表示运行时版本配置的版本
        从以下版本开始：
        9

      • getVersion

        public final Runtime.Version getVersion​()
        返回搜索版本化条目时使用的最大版本。

        如果这个JarFile不是多版本的jar文件，或者没有被配置为这样处理，则返回的版本将与从baseVersion()返回的版本相同。

        结果
        最大版本
        从以下版本开始：
        9

      • isMultiRelease

        public final boolean isMultiRelease​()
        指示此jar文件是否为多版本jar文件。
        结果
        如果这个JarFile是一个多版本的jar文件，则为true
        从以下版本开始：
        9

      • getManifest

        public Manifest getManifest​()
                     throws IOException
        返回jar文件清单，如果没有，则返回 null 。
        结果
        jar文件清单，或 null如果没有
        异常
        IllegalStateException - 如果jar文件已关闭，可能会抛出
        IOException - 如果发生I / O错误

      • getJarEntry

        public JarEntry getJarEntry​(String name)
        如果JarEntry ，则返回给定基本条目名称的null或null 。

        如果这个JarFile是一个多版本的jar文件，并且被配置为这样进行处理，则执行搜索以查找并返回与给定条目名称相关联的最新版本化条目的JarEntry 。 返回的JarEntry是与给定基本条目名称相对应的版本号，前缀为字符串"META-INF/versions/{n}/" ，最大值为n ，条目存在。 如果这样的版本条目不存在，则返回基本条目的JarEntry ，否则如果没有找到条目，则返回null 。 版本n的初始值是方法getVersion()返回的最大版本。

        实现要求：
        此实现调用 getEntry(String) 。
        参数
        name - jar文件条目名称
        结果
        指定条目名称的 JarEntry或版本号的条目名称，如果未找到， null
        异常
        IllegalStateException - 如果jar文件已关闭，可能会抛出
        另请参见：
        JarEntry

      • getEntry

        public ZipEntry getEntry​(String name)
        返回ZipEntry用于给定基本条目名称null如果没有找到。

        如果这个JarFile是一个多版本的jar文件，并且被配置为这样进行处理，则执行搜索以查找并返回与给定条目名称相关联的最新版本化条目的ZipEntry 。 返回的ZipEntry是对应于给定基本条目名称的版本号，前缀为字符串"META-INF/versions/{n}/" ，最大值为n ，条目存在。 如果此类版本的条目不存在，则返回基本条目的ZipEntry ，否则如果没有找到条目，则返回null 。 版本n的初始值是方法getVersion()返回的最大版本。

        重写：
        getEntry在 ZipFile
        实现要求：
        即使没有相应的基本条目，此实现也可能返回所请求名称的版本化条目。 如果有私有或包私有版本的条目匹配，则可能会发生这种情况。 如果子类覆盖此方法，请确保覆盖方法调用super.getEntry(name)以获取所有版本化条目。
        参数
        name - jar文件条目名称
        结果
        ZipEntry的给定条目名称或版本号的条目名称或 null如果没有找到
        异常
        IllegalStateException - 如果jar文件已关闭，可能会抛出
        另请参见：
        ZipEntry

      • entries

        public Enumeration<JarEntry> entries​()
        返回枚举jar文件条目。
        重写：
        entries在 ZipFile
        结果
        枚举jar文件条目
        异常
        IllegalStateException - 如果jar文件已关闭，可能会抛出

      • stream

        public Stream<JarEntry> stream​()
        在jar文件条目上返回一个有序的Stream 。 条目按照它们出现在jar文件的中央目录中的顺序出现在Stream中。
        重写：
        stream在 ZipFile
        结果
        这个jar文件中有一个 Stream的条目
        异常
        IllegalStateException - 如果jar文件已关闭
        从以下版本开始：
        1.8

      • getInputStream

        public InputStream getInputStream​(ZipEntry ze)
                           throws IOException
        返回用于读取指定zip文件条目内容的输入流。
        重写：
        getInputStream在 ZipFile
        参数
        ze - zip文件条目
        结果
        用于读取指定的zip文件条目的内容的输入流
        异常
        ZipException - 如果发生zip文件格式错误
        IOException - 如果发生I / O错误
        SecurityException - 如果任何jar文件条目未正确签名。
        IllegalStateException - 如果jar文件已关闭，可能会抛出
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


JarInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Class JarInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.ZipInputStream
            • java.util.jar.JarInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class JarInputStream
extends ZipInputStream
    JarInputStream类用于从任何输入流读取JAR文件的内容。 它扩展了类java.util.zip.ZipInputStream ，支持阅读可选的Manifest条目。 Manifest可用于存储有关JAR文件及其条目的元信息。
    从以下版本开始：
    1.2
    另请参见：
    Manifest ， ZipInputStream

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static int | CENATT
      static int | CENATX
      static int | CENCOM
      static int | CENCRC
      static int | CENDSK
      static int | CENEXT
      static int | CENFLG
      static int | CENHDR
      static int | CENHOW
      static int | CENLEN
      static int | CENNAM
      static int | CENOFF
      static long | CENSIG
      static int | CENSIZ
      static int | CENTIM
      static int | CENVEM
      static int | CENVER
      static int | ENDCOM
      static int | ENDHDR
      static int | ENDOFF
      static long | ENDSIG
      static int | ENDSIZ
      static int | ENDSUB
      static int | ENDTOT
      static int | EXTCRC
      static int | EXTHDR
      static int | EXTLEN
      static long | EXTSIG
      static int | EXTSIZ
      static int | LOCCRC
      static int | LOCEXT
      static int | LOCFLG
      static int | LOCHDR
      static int | LOCHOW
      static int | LOCLEN
      static int | LOCNAM
      static long | LOCSIG
      static int | LOCSIZ
      static int | LOCTIM
      static int | LOCVER

      • Fields inherited from class java.io.FilterInputStream

        in

      • Fields inherited from class java.util.zip.InflaterInputStream

        buf, inf, len

    • 构造方法摘要

      构造方法
      Constructor 描述
      JarInputStream​(InputStream in)
      创建一个新的 JarInputStream并读取可选的清单。
      JarInputStream​(InputStream in, boolean verify)
      创建一个新的 JarInputStream并读取可选的清单。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected ZipEntry createZipEntry​(String name)
      为指定的JAR文件条目名称创建一个新的 JarEntry （ ZipEntry ）。
      Manifest getManifest​()
      返回此JAR文件的 null如果没有，则返回 Manifest 。
      ZipEntry getNextEntry​()
      读取下一个ZIP文件条目，并将流定位在条目数据的开头。
      JarEntry getNextJarEntry​()
      读取下一个JAR文件条目，并将流定位在条目数据的开头。
      int read​(byte[] b, int off, int len)
      从当前的JAR文件条目读入一个字节数组。

      • Methods inherited from class java.io.FilterInputStream

        read

      • Methods inherited from class java.util.zip.InflaterInputStream

        fill, mark, markSupported, read, reset

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.zip.ZipInputStream

        available, close, closeEntry, skip

    • 字段详细信息

      • LOCSIG

        public static final long LOCSIG
        另请参见：
        Constant Field Values

      • EXTSIG

        public static final long EXTSIG
        另请参见：
        Constant Field Values

      • CENSIG

        public static final long CENSIG
        另请参见：
        Constant Field Values

      • ENDSIG

        public static final long ENDSIG
        另请参见：
        Constant Field Values

      • LOCHDR

        public static final int LOCHDR
        另请参见：
        Constant Field Values

      • EXTHDR

        public static final int EXTHDR
        另请参见：
        Constant Field Values

      • CENHDR

        public static final int CENHDR
        另请参见：
        Constant Field Values

      • ENDHDR

        public static final int ENDHDR
        另请参见：
        Constant Field Values

      • LOCVER

        public static final int LOCVER
        另请参见：
        Constant Field Values

      • LOCFLG

        public static final int LOCFLG
        另请参见：
        Constant Field Values

      • LOCHOW

        public static final int LOCHOW
        另请参见：
        Constant Field Values

      • LOCTIM

        public static final int LOCTIM
        另请参见：
        Constant Field Values

      • LOCCRC

        public static final int LOCCRC
        另请参见：
        Constant Field Values

      • LOCSIZ

        public static final int LOCSIZ
        另请参见：
        Constant Field Values

      • LOCLEN

        public static final int LOCLEN
        另请参见：
        Constant Field Values

      • LOCNAM

        public static final int LOCNAM
        另请参见：
        Constant Field Values

      • LOCEXT

        public static final int LOCEXT
        另请参见：
        Constant Field Values

      • EXTCRC

        public static final int EXTCRC
        另请参见：
        Constant Field Values

      • EXTSIZ

        public static final int EXTSIZ
        另请参见：
        Constant Field Values

      • EXTLEN

        public static final int EXTLEN
        另请参见：
        Constant Field Values

      • CENVEM

        public static final int CENVEM
        另请参见：
        Constant Field Values

      • CENVER

        public static final int CENVER
        另请参见：
        Constant Field Values

      • CENFLG

        public static final int CENFLG
        另请参见：
        Constant Field Values

      • CENHOW

        public static final int CENHOW
        另请参见：
        Constant Field Values

      • CENTIM

        public static final int CENTIM
        另请参见：
        Constant Field Values

      • CENCRC

        public static final int CENCRC
        另请参见：
        Constant Field Values

      • CENSIZ

        public static final int CENSIZ
        另请参见：
        Constant Field Values

      • CENLEN

        public static final int CENLEN
        另请参见：
        Constant Field Values

      • CENNAM

        public static final int CENNAM
        另请参见：
        Constant Field Values

      • CENEXT

        public static final int CENEXT
        另请参见：
        Constant Field Values

      • CENCOM

        public static final int CENCOM
        另请参见：
        Constant Field Values

      • CENDSK

        public static final int CENDSK
        另请参见：
        Constant Field Values

      • CENATT

        public static final int CENATT
        另请参见：
        Constant Field Values

      • CENATX

        public static final int CENATX
        另请参见：
        Constant Field Values

      • CENOFF

        public static final int CENOFF
        另请参见：
        Constant Field Values

      • ENDSUB

        public static final int ENDSUB
        另请参见：
        Constant Field Values

      • ENDTOT

        public static final int ENDTOT
        另请参见：
        Constant Field Values

      • ENDSIZ

        public static final int ENDSIZ
        另请参见：
        Constant Field Values

      • ENDOFF

        public static final int ENDOFF
        另请参见：
        Constant Field Values

      • ENDCOM

        public static final int ENDCOM
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JarInputStream

        public JarInputStream​(InputStream in)
               throws IOException
        创建一个新的JarInputStream并读取可选的清单。 如果存在清单，还尝试验证JarInputStream是否已经签名的签名。
        参数
        in - 实际的输入流
        异常
        IOException - 如果发生I / O错误

      • JarInputStream

        public JarInputStream​(InputStream in,
                      boolean verify)
               throws IOException
        创建一个新的JarInputStream并读取可选的清单。 如果清单存在并且验证是真的，那么如果JarInputStream被签名，也尝试验证签名。
        参数
        in - 实际的输入流
        verify - 是否验证JarInputStream是否被签名。
        异常
        IOException - 如果发生I / O错误

    • 方法详细信息

      • getManifest

        public Manifest getManifest​()
        返回此JAR文件的 null如果没有，则返回 Manifest 。
        结果
        该 Manifest此JAR文件，或者 null如果没有。

      • getNextEntry

        public ZipEntry getNextEntry​()
                      throws IOException
        读取下一个ZIP文件条目，并将流定位在条目数据的开头。 如果已启用验证，则在为下一个条目定位流时检测到任何无效的签名将导致异常。
        重写：
        getNextEntry在 ZipInputStream
        结果
        下一个ZIP文件条目，如果没有更多条目，则为null
        异常
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O错误
        SecurityException - 如果任何jar文件条目未正确签名。

      • getNextJarEntry

        public JarEntry getNextJarEntry​()
                         throws IOException
        读取下一个JAR文件条目，并将流定位在条目数据的开头。 如果已启用验证，则在为下一个条目定位流时检测到任何无效的签名将导致异常。
        结果
        下一个JAR文件条目，如果没有更多条目，则为null
        异常
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O错误
        SecurityException - 如果任何jar文件条目未正确签名。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从当前的JAR文件条目读入一个字节数组。 如果len不为零，则该方法将阻塞，直到某些输入可用; 否则，不会读取字节，并返回0 。 如果已启用验证，则在到达条目结束前的某个时刻将会报告当前条目中的任何无效签名。
        重写：
        read在 ZipInputStream
        参数
        b - 读取数据的缓冲区
        off - 目标数组 b的起始偏移量
        len - 要读取的最大字节数
        结果
        读取的实际字节数，如果达到条目结束，则为-1
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负，则 len为负数，或 len大于 b.length - off
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O错误
        SecurityException - 如果任何jar文件条目未正确签名。
        另请参见：
        FilterInputStream.in

      • createZipEntry

        protected ZipEntry createZipEntry​(String name)
        为指定的JAR文件条目名称创建一个新的JarEntry （ ZipEntry ）。 指定的JAR文件条目名称的清单属性将被复制到新的JarEntry 。
        重写：
        createZipEntry在 ZipInputStream
        参数
        name - JAR / ZIP文件条目的名称
        结果
        刚刚创建的 JarEntry对象
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


JarOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Class JarOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.ZipOutputStream
            • java.util.jar.JarOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class JarOutputStream
extends ZipOutputStream
    JarOutputStream类用于将JAR文件的内容写入任何输出流。 它扩展了类java.util.zip.ZipOutputStream ，支持写入可选的Manifest条目。 Manifest可用于指定有关JAR文件及其条目的元信息。
    从以下版本开始：
    1.2
    另请参见：
    Manifest ， ZipOutputStream

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static int | CENATT
      static int | CENATX
      static int | CENCOM
      static int | CENCRC
      static int | CENDSK
      static int | CENEXT
      static int | CENFLG
      static int | CENHDR
      static int | CENHOW
      static int | CENLEN
      static int | CENNAM
      static int | CENOFF
      static long | CENSIG
      static int | CENSIZ
      static int | CENTIM
      static int | CENVEM
      static int | CENVER
      static int | ENDCOM
      static int | ENDHDR
      static int | ENDOFF
      static long | ENDSIG
      static int | ENDSIZ
      static int | ENDSUB
      static int | ENDTOT
      static int | EXTCRC
      static int | EXTHDR
      static int | EXTLEN
      static long | EXTSIG
      static int | EXTSIZ
      static int | LOCCRC
      static int | LOCEXT
      static int | LOCFLG
      static int | LOCHDR
      static int | LOCHOW
      static int | LOCLEN
      static int | LOCNAM
      static long | LOCSIG
      static int | LOCSIZ
      static int | LOCTIM
      static int | LOCVER

      • Fields inherited from class java.util.zip.DeflaterOutputStream

        buf, def

      • Fields inherited from class java.io.FilterOutputStream

        out

      • Fields inherited from class java.util.zip.ZipOutputStream

        DEFLATED, STORED

    • 构造方法摘要

      构造方法
      Constructor 描述
      JarOutputStream​(OutputStream out)
      创建一个新的 JarOutputStream没有清单。
      JarOutputStream​(OutputStream out, Manifest man)
      创建一个新的 JarOutputStream与指定的 Manifest 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void putNextEntry​(ZipEntry ze)
      开始编写一个新的JAR文件条目，并将流定位到入口数据的开头。

      • Methods inherited from class java.util.zip.DeflaterOutputStream

        deflate, flush, write

      • Methods inherited from class java.io.FilterOutputStream

        write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.zip.ZipOutputStream

        close, closeEntry, finish, setComment, setLevel, setMethod, write

    • 字段详细信息

      • LOCSIG

        public static final long LOCSIG
        另请参见：
        Constant Field Values

      • EXTSIG

        public static final long EXTSIG
        另请参见：
        Constant Field Values

      • CENSIG

        public static final long CENSIG
        另请参见：
        Constant Field Values

      • ENDSIG

        public static final long ENDSIG
        另请参见：
        Constant Field Values

      • LOCHDR

        public static final int LOCHDR
        另请参见：
        Constant Field Values

      • EXTHDR

        public static final int EXTHDR
        另请参见：
        Constant Field Values

      • CENHDR

        public static final int CENHDR
        另请参见：
        Constant Field Values

      • ENDHDR

        public static final int ENDHDR
        另请参见：
        Constant Field Values

      • LOCVER

        public static final int LOCVER
        另请参见：
        Constant Field Values

      • LOCFLG

        public static final int LOCFLG
        另请参见：
        Constant Field Values

      • LOCHOW

        public static final int LOCHOW
        另请参见：
        Constant Field Values

      • LOCTIM

        public static final int LOCTIM
        另请参见：
        Constant Field Values

      • LOCCRC

        public static final int LOCCRC
        另请参见：
        Constant Field Values

      • LOCSIZ

        public static final int LOCSIZ
        另请参见：
        Constant Field Values

      • LOCLEN

        public static final int LOCLEN
        另请参见：
        Constant Field Values

      • LOCNAM

        public static final int LOCNAM
        另请参见：
        Constant Field Values

      • LOCEXT

        public static final int LOCEXT
        另请参见：
        Constant Field Values

      • EXTCRC

        public static final int EXTCRC
        另请参见：
        Constant Field Values

      • EXTSIZ

        public static final int EXTSIZ
        另请参见：
        Constant Field Values

      • EXTLEN

        public static final int EXTLEN
        另请参见：
        Constant Field Values

      • CENVEM

        public static final int CENVEM
        另请参见：
        Constant Field Values

      • CENVER

        public static final int CENVER
        另请参见：
        Constant Field Values

      • CENFLG

        public static final int CENFLG
        另请参见：
        Constant Field Values

      • CENHOW

        public static final int CENHOW
        另请参见：
        Constant Field Values

      • CENTIM

        public static final int CENTIM
        另请参见：
        Constant Field Values

      • CENCRC

        public static final int CENCRC
        另请参见：
        Constant Field Values

      • CENSIZ

        public static final int CENSIZ
        另请参见：
        Constant Field Values

      • CENLEN

        public static final int CENLEN
        另请参见：
        Constant Field Values

      • CENNAM

        public static final int CENNAM
        另请参见：
        Constant Field Values

      • CENEXT

        public static final int CENEXT
        另请参见：
        Constant Field Values

      • CENCOM

        public static final int CENCOM
        另请参见：
        Constant Field Values

      • CENDSK

        public static final int CENDSK
        另请参见：
        Constant Field Values

      • CENATT

        public static final int CENATT
        另请参见：
        Constant Field Values

      • CENATX

        public static final int CENATX
        另请参见：
        Constant Field Values

      • CENOFF

        public static final int CENOFF
        另请参见：
        Constant Field Values

      • ENDSUB

        public static final int ENDSUB
        另请参见：
        Constant Field Values

      • ENDTOT

        public static final int ENDTOT
        另请参见：
        Constant Field Values

      • ENDSIZ

        public static final int ENDSIZ
        另请参见：
        Constant Field Values

      • ENDOFF

        public static final int ENDOFF
        另请参见：
        Constant Field Values

      • ENDCOM

        public static final int ENDCOM
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JarOutputStream

        public JarOutputStream​(OutputStream out,
                       Manifest man)
                throws IOException
        创建一个新的JarOutputStream与指定的Manifest 。 清单被写入输出流的第一个条目。
        参数
        out - 实际的输出流
        man - 可选 Manifest
        异常
        IOException - 如果发生I / O错误

      • JarOutputStream

        public JarOutputStream​(OutputStream out)
                throws IOException
        创建一个新的 JarOutputStream没有清单。
        参数
        out - 实际的输出流
        异常
        IOException - 如果发生I / O错误

    • 方法详细信息

      • putNextEntry

        public void putNextEntry​(ZipEntry ze)
                  throws IOException
        开始编写一个新的JAR文件条目，并将流定位到入口数据的开头。 此方法也将关闭任何以前的条目。 如果没有为条目指定压缩方法，将使用默认压缩方法。 如果条目没有设置修改时间，将使用当前时间。
        重写：
        putNextEntry在 ZipOutputStream
        参数
        ze - 要写入的ZIP / JAR条目
        异常
        ZipException - 如果发生ZIP错误
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


java.util.jar (Java SE 9 & JDK 9 )

java.util.jar

Interfaces

  • Pack200.Packer
  • Pack200.Unpacker

Classes

  • Attributes
  • Attributes.Name
  • JarEntry
  • JarFile
  • JarInputStream
  • JarOutputStream
  • Manifest
  • Pack200

Exceptions

  • JarException


java.util.jar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util.jar

提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。 清单存储有关JAR文件内容的元信息，并且还用于签名JAR文件。

包装规格

java.util.jar包是基于以下规格：
  • Info-ZIP文件格式 - JAR格式基于Info-ZIP文件格式。 见java.util.zip package description.

    在JAR文件中，所有文件名必须以UTF-8编码编码。

  • Manifest and Signature Specification - 清单格式规范。
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    Pack200.Packer
    打包机引擎对输入的JAR文件进行各种转换，使包流由压缩器（如gzip或zip）高度压缩。
    Pack200.Unpacker
    解包器引擎将打包流转换为JAR文件。
  • 类摘要
    Class 描述
    Attributes
    属性类将Manifest属性名称映射到关联的字符串值。
    Attributes.Name
    Attributes.Name类表示存储在此Map中的属性名称。
    JarEntry
    此类用于表示JAR文件条目。
    JarFile
    JarFile类用于从可以使用 java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。
    JarInputStream
    JarInputStream类用于从任何输入流读取JAR文件的内容。
    JarOutputStream
    JarOutputStream类用于将JAR文件的内容写入任何输出流。
    Manifest
    Manifest类用于维护清单条目名称及其相关属性。
    Pack200
    从Pack200格式的压缩流转换JAR文件。
  • 异常摘要
    异常 描述
    JarException
    表示在读取或写入JAR文件时发生了某种错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.jar Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.jar

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.jar.Attributes (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.util.jar.Attributes.Name
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.ZipInputStream
            • java.util.jar.JarInputStream
    • java.util.jar.Manifest (implements java.lang.Cloneable)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.ZipOutputStream
            • java.util.jar.JarOutputStream
    • java.util.jar.Pack200
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • java.util.zip.ZipException
            • java.util.jar.JarException
    • java.util.zip.ZipEntry (implements java.lang.Cloneable)
      • java.util.jar.JarEntry
    • java.util.zip.ZipFile (implements java.io.Closeable)
      • java.util.jar.JarFile

Interface Hierarchy

  • java.util.jar.Pack200.Packer
  • java.util.jar.Pack200.Unpacker
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Manifest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Class Manifest

  • java.lang.Object
    • java.util.jar.Manifest
  • All Implemented Interfaces:
    Cloneable

    public class Manifest
extends Object
implements Cloneable
    Manifest类用于维护清单条目名称及其相关属性。 有主要的清单属性以及每个入口属性。 有关清单格式的信息，请参阅Manifest format specification 。
    从以下版本开始：
    1.2
    另请参见：
    Attributes

    • 构造方法摘要

      构造方法
      Constructor 描述
      Manifest​()
      构建一个新的，空的清单。
      Manifest​(InputStream is)
      从指定的输入流构造一个新的清单。
      Manifest​(Manifest man)
      构造一个新的清单，它是指定的清单的副本。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      清除主要属性以及此清单中的条目。
      Object clone​()
      返回此清单的浅层副本。
      boolean equals​(Object o)
      如果指定的对象也是清单并具有相同的主要属性和条目，则返回true。
      Attributes getAttributes​(String name)
      返回指定条目名称的属性。
      Map<String,Attributes> getEntries​()
      返回此清单中包含的条目的地图。
      Attributes getMainAttributes​()
      返回清单的主要属性。
      int hashCode​()
      返回此清单的哈希码。
      void read​(InputStream is)
      从指定的InputStream读取清单。
      void write​(OutputStream out)
      将清单写入指定的OutputStream。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Manifest

        public Manifest​()
        构建一个新的，空的清单。

      • Manifest

        public Manifest​(InputStream is)
         throws IOException
        从指定的输入流构造一个新的清单。
        参数
        is - 包含清单数据的输入流
        异常
        IOException - 如果发生I / O错误

      • Manifest

        public Manifest​(Manifest man)
        构造一个新的清单，它是指定的清单的副本。
        参数
        man - 要复制的清单

    • 方法详细信息

      • getMainAttributes

        public Attributes getMainAttributes​()
        返回清单的主要属性。
        结果
        主要属性的清单

      • getEntries

        public Map<String,Attributes> getEntries​()
        返回此清单中包含的条目的地图。 每个条目由字符串名称（键）和关联的属性（值）表示。 该地图允许null密钥，但是read(java.io.InputStream)创建了无空条目的条目，也不使用write(java.io.OutputStream)写入该条目。
        结果
        该清单中包含的条目的地图

      • getAttributes

        public Attributes getAttributes​(String name)
        返回指定条目名称的属性。 此方法定义为：
          return (Attributes)getEntries().get(name)
        虽然null是有效name ，当getAttributes(null)是在调用Manifest从JAR文件中获得的， null将被退回。 虽然JAR文件本身不允许null -named属性，也可以调用getEntries()上Manifest ，并且该结果，调用put用null键和任意值。 随后的getAttributes(null)调用将返回put值。

        请注意，此方法不返回清单的主要属性; 见getMainAttributes() 。

        参数
        name - 条目名称
        结果
        指定条目名称的属性

      • clear

        public void clear​()
        清除主要属性以及此清单中的条目。

      • write

        public void write​(OutputStream out)
           throws IOException
        将清单写入指定的OutputStream。 在调用此方法之前，必须在MainAttributes中设置Attributes.Name.MANIFEST_VERSION。
        参数
        out - 输出流
        异常
        IOException - 如果发生I / O错误
        另请参见：
        getMainAttributes()

      • read

        public void read​(InputStream is)
          throws IOException
        从指定的InputStream读取清单。 读取的条目名称和属性将与当前清单条目合并。
        参数
        is - 输入流
        异常
        IOException - 如果发生I / O错误

      • equals

        public boolean equals​(Object o)
        如果指定的对象也是清单并具有相同的主要属性和条目，则返回true。
        重写：
        equals在 Object
        参数
        o - 要比较的对象
        结果
        如果指定的对象也是清单并具有相同的主要属性和条目，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此清单的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • clone

        public Object clone​()
        返回此清单的浅层副本。 浅层拷贝的实现如下：
          public Object clone() { return new Manifest(this); }
        重写：
        clone在 Object
        结果
        这个清单的浅拷贝
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Pack200 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Class Pack200

  • java.lang.Object
    • java.util.jar.Pack200

  • public abstract class Pack200
extends Object
    从Pack200格式的压缩流转换JAR文件。 请参阅Network Transfer Format JSR 200 Specification

    通常，应用程序开发人员使用打包机引擎在网站上部署或托管JAR文件。 解包器引擎被部署应用程序用于将字节流转换回JAR格式。

    以下是使用packer和unpacker的示例：

       import java.util.jar.Pack200; import java.util.jar.Pack200.*; ... // Create the Packer object Packer packer = Pack200.newPacker(); // Initialize the state by setting the desired properties Map p = packer.properties(); // take more time choosing codings for better compression p.put(Packer.EFFORT, "7"); // default is "5" // use largest-possible archive segments (>10% better compression). p.put(Packer.SEGMENT_LIMIT, "-1"); // reorder files for better compression. p.put(Packer.KEEP_FILE_ORDER, Packer.FALSE); // smear modification times to a single value. p.put(Packer.MODIFICATION_TIME, Packer.LATEST); // ignore all JAR deflation requests, // transmitting a single request to use "store" mode. p.put(Packer.DEFLATE_HINT, Packer.FALSE); // discard debug attributes p.put(Packer.CODE_ATTRIBUTE_PFX+"LineNumberTable", Packer.STRIP); // throw an error if an attribute is unrecognized p.put(Packer.UNKNOWN_ATTRIBUTE, Packer.ERROR); // pass one class file uncompressed: p.put(Packer.PASS_FILE_PFX+0, "mutants/Rogue.class"); try { JarFile jarFile = new JarFile("/tmp/testref.jar"); FileOutputStream fos = new FileOutputStream("/tmp/test.pack"); // Call the packer packer.pack(jarFile, fos); jarFile.close(); fos.close(); File f = new File("/tmp/test.pack"); FileOutputStream fostream = new FileOutputStream("/tmp/test.jar"); JarOutputStream jostream = new JarOutputStream(fostream); Unpacker unpacker = Pack200.newUnpacker(); // Call the unpacker unpacker.unpack(f, jostream); // Must explicitly close the output. jostream.close(); } catch (IOException ioe) { ioe.printStackTrace(); }

    使用gzip压缩的Pack200文件可以托管在HTTP / 1.1 Web服务器上。 部署应用程序可以使用“Accept-Encoding = pack200-gzip”。 这向服务器指示客户端应用程序需要使用Pack200编码的文件的版本，并使用gzip进一步压缩。 有关技术和详细信息，请参阅Java部署指南。

    除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.5

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static interface  Pack200.Packer
      打包机引擎对输入的JAR文件进行各种转换，使包流由压缩器（如gzip或zip）高度压缩。
      static interface  Pack200.Unpacker
      解包器引擎将打包流转换为JAR文件。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Pack200.Packer newPacker​()
      获取实现Packer的类的新实例。
      static Pack200.Unpacker newUnpacker​()
      获取实现Unpacker的类的新实例。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • newPacker

        public static Pack200.Packer newPacker​()
        获取实现Packer的类的新实例。

        • 如果定义了系统属性java.util.jar.Pack200.Packer ，则该值将被视为具体实现类的完全限定名称，必须实现Packer。 这个类被加载和实例化。 如果此过程失败，则抛出未指定的错误。

        • 如果没有使用系统属性指定实现，则将系统默认实现类实例化，并返回结果。

        注意：如果多个线程同时使用返回的对象不能保证正常运行。 多线程应用程序应该分配多个封隔器引擎，或者使用一个带有锁定的引擎进行序列化。

        结果
        一个新分配的Packer引擎。

      • newUnpacker

        public static Pack200.Unpacker newUnpacker​()
        获取实现Unpacker的类的新实例。

        • 如果定义了系统属性java.util.jar.Pack200.Unpacker ，则该值将被视为具体实现类的完全限定名称，必须实现Unpacker。 该类被加载并实例化。 如果此过程失败，则抛出未指定的错误。

        • 如果没有使用系统属性指定实现，则将系统默认实现类实例化，并返回结果。

        注意：如果多个线程同时使用返回的对象不能保证正常运行。 多线程应用程序应该分配多个解包器引擎，或者使用一个引擎来锁定。

        结果
        一个新分配的Unpacker引擎。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Pack200.Packer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Interface Pack200.Packer

  • Enclosing class:
    Pack200

    public static interface Pack200.Packer
    打包机引擎对输入的JAR文件进行各种转换，使包流由压缩器（如gzip或zip）高度压缩。 发动机的一个实例可以使用Pack200.newPacker()获得。 通过使用JSR200规范中描述的许多技术来实现高度的压缩。 一些技术是对常量池进行排序，重新排序和共同定位。

    包引擎被初始化为初始状态，如下面的属性所述。 可以通过获取引擎属性（使用properties() ）并将修改的属性存储在地图上来处理初始状态。 资源文件将被传递，完全没有变化。 类文件不会包含相同的字节，因为解包程序可以自由地更改次要的类文件功能，如常量池顺序。 但是，类文件将在语义上相同，如The Java™ Virtual Machine Specification中所述 。

    默认情况下，打包程序不会更改JAR元素的顺序。 此外，每个JAR元素的修改时间和通缩提示不变。 （任何其他ZIP档案信息，如授予Unix文件权限的额外属性都将丢失。）

    请注意，打包和解包JAR通常会改变JAR中类文件的副本内容。 这意味着打包和拆包通常会使依赖于JAR元素的副图像的任何数字签名无效。 为了签名和打包JAR，您必须首先打包和解压缩JAR以“归一化”它，然后在未打包的JAR元素上计算签名，最后重新打包已签名的JAR。 两个包装步骤都应该使用完全相同的选项，并且片段限制也可能需要设置为“-1”，以防止分段边界的意外变化，因为类文件大小稍有变化。

    （这就是为什么这样工作：任何重新排序任何类文件结构的打包程序都是幂等的，所以第二个打包不会改变第一个打包生成的顺序。而且，解包器由JSR 200规范保证，以产生一个特定的旁边图像对于归档元素的任何给定的传输顺序）

    为了保持向后兼容性，包文件的版本被设置为适应输入JAR文件中存在的类文件。 换句话说，包文件版本将是最新的，如果类文件是最新的，相反，如果类文件版本也是最旧的，则包文件版本将是最旧的。 对于中间类文件版本，将使用相应的包文件版本。 例如：如果输入的JAR文件仅由1.5（或更小）的类文件构成，则会生成1.5兼容的包文件。 对于没有类文件的档案也是如此。 如果输入的JAR文件包含1.6类文件，则包文件版本将设置为1.6。

    注意：除非另有说明，否则null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.5

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String CLASS_ATTRIBUTE_PFX
      当与类属性名称连接时，使用JSR 200规范中指定的布局语言来指示该属性的格式。
      static String CODE_ATTRIBUTE_PFX
      当与代码属性名称连接时，表示该属性的格式。
      static String DEFLATE_HINT
      如果此属性设置为 TRUE或 FALSE ，则 打包程序将在输出存档中相应设置通配提示，并且不会传送归档元素的各个通缩提示。
      static String EFFORT
      如果此属性设置为单个十进制数字，打包程序将使用指定的压缩压缩数据量。
      static String ERROR
      字符串“error”是某些属性的可能值。
      static String FALSE
      字符串“false”是某些属性的可能值。
      static String FIELD_ATTRIBUTE_PFX
      当与字段属性名称连接时，表示该属性的格式。
      static String KEEP
      字符串“keep”是某些属性的可能值。
      static String KEEP_FILE_ORDER
      如果此属性设置为 TRUE ，则 打包程序将以源原始文件中的原始顺序传输所有元素。
      static String LATEST
      字符串“最新”，某些属性的可能值。
      static String METHOD_ATTRIBUTE_PFX
      当与方法属性名称连接时，表示该属性的格式。
      static String MODIFICATION_TIME
      如果将此属性设置为特殊字符串 LATEST ， 打包程序将尝试确定原始存档中的所有可用条目或每个段中所有可用条目的最新修改时间之间的最新修改时间。
      static String PASS
      字符串“pass”是某些属性的可能值。
      static String PASS_FILE_PFX
      表示一个文件应该被传递通过，没有压缩。
      static String PROGRESS
      封隔器的进度为百分比，由封隔器定期更新。
      static String SEGMENT_LIMIT
      该属性是给出每个归档段的估计目标大小N（以字节为单位）的数字。
      static String STRIP
      字符串“strip”，某些属性的可能值。
      static String TRUE
      字符串“true”是某些属性的可能值。
      static String UNKNOWN_ATTRIBUTE
      指示遇到包含未知属性的类文件时要执行的操作。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void pack​(JarFile in, OutputStream out)
      使用JarFile并将其转换为Pack200存档。
      void pack​(JarInputStream in, OutputStream out)
      使用JarInputStream并将其转换为Pack200归档文件。
      SortedMap<String,String> properties​()
      获取此引擎的属性集。

    • 字段详细信息

      • SEGMENT_LIMIT

        static final String SEGMENT_LIMIT
        该属性是给出每个归档段的估计目标大小N（以字节为单位）的数字。 如果单个输入文件需要多于N个字节，则它将被赋予其自己的归档段。

        作为特殊情况，值-1将产生一个带有所有输入文件的单个大段，而值0将为每个类生成一个段。 更大的存档段导致较少的碎片和更好的压缩，但是处理它们需要更多的内存。

        每个段的大小通过计算要在段中传输的每个输入文件的大小以及其名称和其他传输属性的大小来估计。

        默认值为-1，这意味着打包程序将始终创建单个段输出文件。 在生成非常大的输出文件的情况下，强烈建议用户使用分割或将输入文件分解成更小的JAR。

        一个没有这个限制的10Mb JAR通常会减小约10％，但是打包程序可能需要一个较大的Java堆（大约是分段限制的十倍）。

        另请参见：
        Constant Field Values

      • KEEP_FILE_ORDER

        static final String KEEP_FILE_ORDER
        如果此属性设置为TRUE ，则打包程序将以源原始文件中的原始顺序传输所有元素。

        如果设置为FALSE ，则打包程序可能会重新排序元素，并删除JAR目录条目，这些条目不会为Java应用程序提供有用的信息。 （通常这样可以实现更好的压缩。）

        默认值为TRUE ，它保留输入信息，但可能导致传送的归档大于必要。

        另请参见：
        Constant Field Values

      • EFFORT

        static final String EFFORT
        如果此属性设置为单个十进制数字，打包程序将使用指定的压缩压缩数据量。 1级可能产生更大的尺寸和更快的压缩速度，而9级将需要更长的时间，但可能产生更好的压缩。

        特殊值0指示打包机直接复制原始JAR文件，而不进行压缩。 JSR 200标准要求任何解包器将这种特殊情况理解为整个存档的传递。

        默认为5，投入适量的时间来产生合理的压缩。

        另请参见：
        Constant Field Values

      • DEFLATE_HINT

        static final String DEFLATE_HINT
        如果此属性设置为TRUE或FALSE ，则打包程序将在输出存档中相应设置通配提示，并且不会传送归档元素的各个通缩提示。

        如果此属性设置为特殊字符串KEEP ，则打包程序将尝试为输入存档的每个可用元素确定独立的通关提示，并分别发送此提示。

        默认值为KEEP ，它保留输入信息，但可能导致发送的归档大于必要。

        解压器实现取决于采取行动，提示适当地压缩所生成的未打包的jar的元素。

        ZIP或JAR元素的通缩提示表示元素是否被放气或直接存储。

        另请参见：
        Constant Field Values

      • MODIFICATION_TIME

        static final String MODIFICATION_TIME
        如果此属性设置为特殊字符串LATEST ， 打包程序将尝试确定最初修改时间，原始存档中的所有可用条目或每个段中所有可用条目的最新修改时间。 该单个值将作为段的一部分传输，并应用于每个段的所有条目， SEGMENT_LIMIT 。

        这可以大大减少存档的传输大小，而不必将所有安装的文件设置为单个日期。

        如果将此属性设置为特殊字符串KEEP ，则打包器会为每个输入元素发送单独的修改时间。

        默认值为KEEP ，它保留输入信息，但可能导致传输的归档大于必要。

        取消程序实现取决于采取措施，适当地设置其输出文件的每个元素的修改时间。

        另请参见：
        SEGMENT_LIMIT ， Constant Field Values

      • PASS_FILE_PFX

        static final String PASS_FILE_PFX
        表示一个文件应该被传递通过，没有压缩。 可以通过指定附加的不同字符串的附加属性来指定多个文件，以使具有公共前缀的属性族。

        没有路径名转换，除了系统文件分隔符被JAR文件分隔符'/'替换。

        生成的文件名必须与JAR文件中出现的字符串完全一致。

        如果属性值是目录名称，则该目录下的所有文件也将被传递。

        例子：

           Map p = packer.properties(); p.put(PASS_FILE_PFX+0, "mutants/Rogue.class"); p.put(PASS_FILE_PFX+1, "mutants/Wolverine.class"); p.put(PASS_FILE_PFX+2, "mutants/Storm.class"); # Pass all files in an entire directory hierarchy: p.put(PASS_FILE_PFX+3, "police/");
        另请参见：
        Constant Field Values

      • UNKNOWN_ATTRIBUTE

        static final String UNKNOWN_ATTRIBUTE
        指示遇到包含未知属性的类文件时要执行的操作。 可能的值是字符串ERROR ， STRIP ，并PASS 。

        字符串ERROR意味着作为一个整体的包操作将失败，但类型为IOException 。 字符串STRIP表示该属性将被删除。 字符串PASS意味着整个类文件将被传递（如同它是一个资源文件）而没有压缩，并带有适当的警告。 这是此属性的默认值。

        例子：

           Map p = pack200.getProperties(); p.put(UNKNOWN_ATTRIBUTE, ERROR); p.put(UNKNOWN_ATTRIBUTE, STRIP); p.put(UNKNOWN_ATTRIBUTE, PASS);
        另请参见：
        Constant Field Values

      • CLASS_ATTRIBUTE_PFX

        static final String CLASS_ATTRIBUTE_PFX
        当与类属性名称连接时，使用JSR 200规范中指定的布局语言来指示该属性的格式。

        例如，此选项的效果内置于： pack.class.attribute.SourceFile=RUH 。

        特殊字符串ERROR ， STRIP ，并PASS也可以，用相同的含义UNKNOWN_ATTRIBUTE 。 这为用户提供了一种拒绝，剥离或按位传递特定属性（没有类压缩）的方法。

        像这样的代码可能用于支持JCOV的属性：

           Map p = packer.properties(); p.put(CODE_ATTRIBUTE_PFX+"CoverageTable", "NH[PHHII]"); p.put(CODE_ATTRIBUTE_PFX+"CharacterRangeTable", "NH[PHPOHIIH]"); p.put(CLASS_ATTRIBUTE_PFX+"SourceID", "RUH"); p.put(CLASS_ATTRIBUTE_PFX+"CompilationID", "RUH");

        这样的代码可能用于剥离调试属性：

           Map p = packer.properties(); p.put(CODE_ATTRIBUTE_PFX+"LineNumberTable", STRIP); p.put(CODE_ATTRIBUTE_PFX+"LocalVariableTable", STRIP); p.put(CLASS_ATTRIBUTE_PFX+"SourceFile", STRIP);
        另请参见：
        Constant Field Values

      • FIELD_ATTRIBUTE_PFX

        static final String FIELD_ATTRIBUTE_PFX
        当与字段属性名称连接时，表示该属性的格式。 例如，此选项的效果内置于： pack.field.attribute.Deprecated= 。 特殊字符串ERROR ， STRIP ，并PASS也是允许的。
        另请参见：
        CLASS_ATTRIBUTE_PFX ， Constant Field Values

      • METHOD_ATTRIBUTE_PFX

        static final String METHOD_ATTRIBUTE_PFX
        当与方法属性名称连接时，表示该属性的格式。 例如，此选项的效果内置于： pack.method.attribute.Exceptions=NH[RCH] 。 特殊字符串ERROR ， STRIP ，并PASS也是允许的。
        另请参见：
        CLASS_ATTRIBUTE_PFX ， Constant Field Values

      • CODE_ATTRIBUTE_PFX

        static final String CODE_ATTRIBUTE_PFX
        当与代码属性名称连接时，表示该属性的格式。 例如，此选项的效果内置于： pack.code.attribute.LocalVariableTable=NH[PHOHRUHRSHH] 。 特殊字符串ERROR ， STRIP ，并PASS也是允许的。
        另请参见：
        CLASS_ATTRIBUTE_PFX ， Constant Field Values

      • PROGRESS

        static final String PROGRESS
        封隔器的进度为百分比，由封隔器定期更新。 0到100的值是正常值，-1表示失速。 可以通过轮询此属性的值来监视进度。

        至少打包机必须在打包操作开始时将进度设置为0，最后将其设置为100。

        另请参见：
        Constant Field Values

      • KEEP

        static final String KEEP
        字符串“keep”是某些属性的可能值。
        另请参见：
        DEFLATE_HINT ， MODIFICATION_TIME ， Constant Field Values

      • PASS

        static final String PASS
        字符串“pass”是某些属性的可能值。
        另请参见：
        UNKNOWN_ATTRIBUTE ， CLASS_ATTRIBUTE_PFX ， FIELD_ATTRIBUTE_PFX ， METHOD_ATTRIBUTE_PFX ， CODE_ATTRIBUTE_PFX ， Constant Field Values

      • STRIP

        static final String STRIP
        字符串“strip”，某些属性的可能值。
        另请参见：
        UNKNOWN_ATTRIBUTE ， CLASS_ATTRIBUTE_PFX ， FIELD_ATTRIBUTE_PFX ， METHOD_ATTRIBUTE_PFX ， CODE_ATTRIBUTE_PFX ， Constant Field Values

      • ERROR

        static final String ERROR
        字符串“error”是某些属性的可能值。
        另请参见：
        UNKNOWN_ATTRIBUTE ， CLASS_ATTRIBUTE_PFX ， FIELD_ATTRIBUTE_PFX ， METHOD_ATTRIBUTE_PFX ， CODE_ATTRIBUTE_PFX ， Constant Field Values

      • TRUE

        static final String TRUE
        字符串“true”是某些属性的可能值。
        另请参见：
        KEEP_FILE_ORDER ， DEFLATE_HINT ， Constant Field Values

      • FALSE

        static final String FALSE
        字符串“false”是某些属性的可能值。
        另请参见：
        KEEP_FILE_ORDER ， DEFLATE_HINT ， Constant Field Values

      • LATEST

        static final String LATEST
        字符串“最新”，某些属性的可能值。
        另请参见：
        MODIFICATION_TIME ， Constant Field Values

    • 方法详细信息

      • properties

        SortedMap<String,String> properties​()
        获取此引擎的属性集。 该集合是一个“实时视图”，因此更改其内容立即影响打包机引擎，并且引擎中的更改（如进度指示）将立即在映射中显示。

        属性映射可能包含预定义的实现特定和默认属性。 在修改预先存在的属性之前，鼓励用户阅读信息并充分了解其含义。

        实现特定的属性前缀为与实现者相关联的包名称，以com.开头或类似的前缀。 以pack.和unpack.开头的所有属性名称均保留供该API使用。

        未知的属性可能会被忽略或被拒绝与未指定的错误，无效条目可能会导致未指定的错误被抛出。

        返回的地图实现了所有可选的SortedMap操作

        结果
        属性键字符串与属性值的排序关联。

      • pack

        void pack​(JarFile in,
          OutputStream out)
   throws IOException
        使用JarFile并将其转换为Pack200存档。

        关闭输入，但不输出。 （Pack200档案可追加）

        参数
        in - 一个JarFile
        out - 一个OutputStream
        异常
        IOException - 如果遇到错误。

      • pack

        void pack​(JarInputStream in,
          OutputStream out)
   throws IOException
        使用JarInputStream并将其转换为Pack200归档文件。

        关闭输入，但不输出。 （Pack200档案可追加）

        对于JAR清单文件及其包含目录，修改时间和通缩提示属性不可用。

        参数
        in - 一个JarInputStream
        out - 一个OutputStream
        异常
        IOException - 如果遇到错误。
        另请参见：
        MODIFICATION_TIME ， DEFLATE_HINT
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Pack200.Unpacker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.jar

Interface Pack200.Unpacker

  • Enclosing class:
    Pack200

    public static interface Pack200.Unpacker
    解包器引擎将打包流转换为JAR文件。 引擎的实例可以使用Pack200.newUnpacker()获得。

    此引擎生成的每个JAR文件将包含字符串“ PACK200 ”作为zip文件注释。 这允许部署者检测JAR存档是否被打包和解包。

    注意：除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    该版本的解包器与所有以前的版本兼容。

    从以下版本开始：
    1.5

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String DEFLATE_HINT
      表明解包器应该忽略DEFLATE_HINT的所有传输值，将其替换为给定值 TRUE或 FALSE 。
      static String FALSE
      字符串“false”是某些属性的可能值。
      static String KEEP
      字符串“keep”是某些属性的可能值。
      static String PROGRESS
      解包器的进度占百分比，由打包机定期更新。
      static String TRUE
      字符串“true”是某些属性的可能值。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      SortedMap<String,String> properties​()
      获取此引擎的属性集。
      void unpack​(File in, JarOutputStream out)
      读取Pack200存档，并将编码的JAR写入JarOutputStream。
      void unpack​(InputStream in, JarOutputStream out)
      读取Pack200存档，并将编码的JAR写入JarOutputStream。

    • 字段详细信息

      • KEEP

        static final String KEEP
        字符串“keep”是某些属性的可能值。
        另请参见：
        DEFLATE_HINT ， Constant Field Values

      • TRUE

        static final String TRUE
        字符串“true”是某些属性的可能值。
        另请参见：
        DEFLATE_HINT ， Constant Field Values

      • FALSE

        static final String FALSE
        字符串“false”是某些属性的可能值。
        另请参见：
        DEFLATE_HINT ， Constant Field Values

      • DEFLATE_HINT

        static final String DEFLATE_HINT
        表明解包器应该忽略DEFLATE_HINT的所有传输值，将其替换为给定值TRUE或FALSE 。 默认值是特殊字符串KEEP ，它要求解包器保留所有传送的通缩提示。
        另请参见：
        Constant Field Values

      • PROGRESS

        static final String PROGRESS
        解包器的进度占百分比，由打包机定期更新。 0到100的值是正常值，-1表示失速。 可以通过轮询此属性的值来监视进度。

        至少在解包操作开始时，解包器必须将进度设置为0，最后将其设置为100。

        另请参见：
        Constant Field Values

    • 方法详细信息

      • properties

        SortedMap<String,String> properties​()
        获取此引擎的属性集。 该集合是一个“实时视图”，因此更改其内容立即影响Unpacker引擎，并且引擎中的更改（如进度指示）将立即在映射中显示。

        属性映射可能包含预定义的实现特定和默认属性。 在修改预先存在的属性之前，鼓励用户阅读信息并充分了解其含义。

        实现特定的属性前缀为与实现者相关联的包名称，以com.开头或类似的前缀。 以pack.和unpack.开头的所有财产名称均保留供该API使用。

        未知的属性可能会被忽略或被拒绝与未指定的错误，无效条目可能会导致未指定的错误被抛出。

        结果
        选项键字符串与选项值的排序关联。

      • unpack

        void unpack​(InputStream in,
            JarOutputStream out)
     throws IOException
        读取Pack200存档，并将编码的JAR写入JarOutputStream。 将读取输入流的全部内容。 将Pack200归档文件读取到文件可能会更有效，并使用下面描述的备用方法传递File对象。

        关闭输入，但不输出。 （输出可以累积更多的元素。）

        参数
        in - 一个InputStream。
        out - 一个JarOutputStream。
        异常
        IOException - 如果遇到错误。

      • unpack

        void unpack​(File in,
            JarOutputStream out)
     throws IOException
        读取Pack200存档，并将编码的JAR写入JarOutputStream。

        不关闭其输出。 （输出可以累积更多的元素。）

        参数
        in - 一个文件。
        out - 一个JarOutputStream。
        异常
        IOException - if an error is encountered.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Package java.util.jar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.jar

  • Packages that use java.util.jar
    软件包 描述
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.net
    提供实现网络应用程序的类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
  • Classes in java.util.jar used by java.lang.instrument
    Class 描述
    JarFile
    JarFile类用于从可以使用 java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。
  • Classes in java.util.jar used by java.net
    Class 描述
    Attributes
    属性类将Manifest属性名称映射到关联的字符串值。
    JarEntry
    此类用于表示JAR文件条目。
    JarFile
    JarFile类用于从可以使用 java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。
    Manifest
    Manifest类用于维护清单条目名称及其相关属性。
  • Classes in java.util.jar used by java.util.jar
    Class 描述
    Attributes
    属性类将Manifest属性名称映射到关联的字符串值。
    Attributes.Name
    Attributes.Name类表示存储在此Map中的属性名称。
    JarEntry
    此类用于表示JAR文件条目。
    JarFile
    JarFile类用于从可以使用 java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。
    JarInputStream
    JarInputStream类用于从任何输入流读取JAR文件的内容。
    JarOutputStream
    JarOutputStream类用于将JAR文件的内容写入任何输出流。
    Manifest
    Manifest类用于维护清单条目名称及其相关属性。
    Pack200.Packer
    打包机引擎对输入的JAR文件进行各种转换，使包流由压缩器（如gzip或zip）高度压缩。
    Pack200.Unpacker
    解包器引擎将打包流转换为JAR文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.jar.Attributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.jar.Attributes

  • Packages that use Attributes
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of Attributes in java.net

      Methods in java.net that return Attributes
      Modifier and Type 方法 描述
      Attributes JarURLConnection.getAttributes​()
      如果该连接的URL指向JAR文件条目，则返回此连接的Attributes对象，否则返回null。
      Attributes JarURLConnection.getMainAttributes​()
      返回此连接的JAR文件的主要属性。

    • Uses of Attributes in java.util.jar

      Methods in java.util.jar that return Attributes
      Modifier and Type 方法 描述
      Attributes JarEntry.getAttributes​()
      返回 Manifest Attributes此条，或 null如果没有。
      Attributes Manifest.getAttributes​(String name)
      返回指定条目名称的属性。
      Attributes Manifest.getMainAttributes​()
      返回清单的主要属性。
      Methods in java.util.jar that return types with arguments of type Attributes
      Modifier and Type 方法 描述
      Map<String,Attributes> Manifest.getEntries​()
      返回此清单中包含的条目的地图。
      Constructors in java.util.jar with parameters of type Attributes
      Constructor 描述
      Attributes​(Attributes attr)
      构造具有与指定属性中相同的属性名称 - 值映射的新Attributes对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.jar.Attributes.Name (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.jar.Attributes.Name

  • Packages that use Attributes.Name
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of Attributes.Name in java.util.jar

      Fields in java.util.jar declared as Attributes.Name
      Modifier and Type Field 描述
      static Attributes.Name Attributes.Name.CLASS_PATH
      Name对象为 Class-Path清单属性。
      static Attributes.Name Attributes.Name.CONTENT_TYPE
      Name对象为 Content-Type清单属性。
      static Attributes.Name Attributes.Name.EXTENSION_INSTALLATION
      已过时。
      扩展机制不再受支持。
      static Attributes.Name Attributes.Name.EXTENSION_LIST
      Name对象为 Extension-List manifest属性用于不再支持的扩展机制。
      static Attributes.Name Attributes.Name.EXTENSION_NAME
      Name对象为 Extension-Name清单属性。
      static Attributes.Name Attributes.Name.IMPLEMENTATION_TITLE
      Name对象为 Implementation-Title用于包版本控制的清单属性。
      static Attributes.Name Attributes.Name.IMPLEMENTATION_URL
      已过时。
      扩展机制不再受支持。
      static Attributes.Name Attributes.Name.IMPLEMENTATION_VENDOR
      Name对象为 Implementation-Vendor清单属性用于包版本控制。
      static Attributes.Name Attributes.Name.IMPLEMENTATION_VENDOR_ID
      已过时。
      扩展机制不再受支持。
      static Attributes.Name Attributes.Name.IMPLEMENTATION_VERSION
      Name对象为 Implementation-Version清单属性用于包版本控制。
      static Attributes.Name Attributes.Name.MAIN_CLASS
      Name对象，用于启动打包在JAR文件中的应用程序的 Main-Class清单属性。
      static Attributes.Name Attributes.Name.MANIFEST_VERSION
      Name对象为 Manifest-Version清单属性。
      static Attributes.Name Attributes.Name.MULTI_RELEASE
      Name对象为 Multi-Release manifest属性，表示这是一个多版本的JAR文件。
      static Attributes.Name Attributes.Name.SEALED
      Name对象为 Sealed用于密封的清单属性。
      static Attributes.Name Attributes.Name.SIGNATURE_VERSION
      Name对象，用于在签名JAR文件时使用的清单属性 Signature-Version 。
      static Attributes.Name Attributes.Name.SPECIFICATION_TITLE
      Name对象为 Specification-Title用于包版本控制的清单属性。
      static Attributes.Name Attributes.Name.SPECIFICATION_VENDOR
      Name对象为 Specification-Vendor用于包版本控制的清单属性。
      static Attributes.Name Attributes.Name.SPECIFICATION_VERSION
      Name对象为 Specification-Version清单属性用于包版本控制。
      Methods in java.util.jar with parameters of type Attributes.Name
      Modifier and Type 方法 描述
      String Attributes.getValue​(Attributes.Name name)
      返回指定的Attributes.Name的值，如果未找到该属性，则返回null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.jar.JarEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.jar.JarEntry

  • Packages that use JarEntry
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of JarEntry in java.net

      Methods in java.net that return JarEntry
      Modifier and Type 方法 描述
      JarEntry JarURLConnection.getJarEntry​()
      返回此连接的JAR条目对象（如果有）。

    • Uses of JarEntry in java.util.jar

      Methods in java.util.jar that return JarEntry
      Modifier and Type 方法 描述
      JarEntry JarFile.getJarEntry​(String name)
      如果 JarEntry ，则返回给定基本条目名称的 null或 null 。
      JarEntry JarInputStream.getNextJarEntry​()
      读取下一个JAR文件条目，并将流定位在条目数据的开头。
      Methods in java.util.jar that return types with arguments of type JarEntry
      Modifier and Type 方法 描述
      Enumeration<JarEntry> JarFile.entries​()
      返回枚举jar文件条目。
      Stream<JarEntry> JarFile.stream​()
      返回一个有序的 Stream超过jar文件条目。
      Constructors in java.util.jar with parameters of type JarEntry
      Constructor 描述
      JarEntry​(JarEntry je)
      创建一个新的 JarEntry其中的字段取自指定的 JarEntry对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.jar.JarException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.jar.JarException

No usage of java.util.jar.JarException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.jar.JarFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.jar.JarFile

  • Packages that use JarFile
    软件包 描述
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.net
    提供实现网络应用程序的类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of JarFile in java.lang.instrument

      Methods in java.lang.instrument with parameters of type JarFile
      Modifier and Type 方法 描述
      void Instrumentation.appendToBootstrapClassLoaderSearch​(JarFile jarfile)
      指定具有由引导类加载器定义的检测类的JAR文件。
      void Instrumentation.appendToSystemClassLoaderSearch​(JarFile jarfile)
      指定具有由系统类加载器定义的检测类的JAR文件。

    • Uses of JarFile in java.net

      Methods in java.net that return JarFile
      Modifier and Type 方法 描述
      abstract JarFile JarURLConnection.getJarFile​()
      返回此连接的JAR文件。

    • Uses of JarFile in java.util.jar

      Methods in java.util.jar with parameters of type JarFile
      Modifier and Type 方法 描述
      void Pack200.Packer.pack​(JarFile in, OutputStream out)
      Takes a JarFile and converts it into a Pack200 archive.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.jar.JarInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.jar.JarInputStream

  • Packages that use JarInputStream
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of JarInputStream in java.util.jar

      Methods in java.util.jar with parameters of type JarInputStream
      Modifier and Type 方法 描述
      void Pack200.Packer.pack​(JarInputStream in, OutputStream out)
      使用JarInputStream并将其转换为Pack200归档文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.jar.JarOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.jar.JarOutputStream

  • Packages that use JarOutputStream
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of JarOutputStream in java.util.jar

      Methods in java.util.jar with parameters of type JarOutputStream
      Modifier and Type 方法 描述
      void Pack200.Unpacker.unpack​(File in, JarOutputStream out)
      读取Pack200存档，并将编码的JAR写入JarOutputStream。
      void Pack200.Unpacker.unpack​(InputStream in, JarOutputStream out)
      读取Pack200存档，并将编码的JAR写入JarOutputStream。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.jar.Manifest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.jar.Manifest

  • Packages that use Manifest
    软件包 描述
    java.net
    提供实现网络应用程序的类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of Manifest in java.net

      Methods in java.net that return Manifest
      Modifier and Type 方法 描述
      Manifest JarURLConnection.getManifest​()
      返回此连接的清单，否则返回null。
      Methods in java.net with parameters of type Manifest
      Modifier and Type 方法 描述
      protected 软件包 URLClassLoader.definePackage​(String name, Manifest man, URL url)
      在这个 URLClassLoader按名称定义一个新的包。

    • Uses of Manifest in java.util.jar

      Methods in java.util.jar that return Manifest
      Modifier and Type 方法 描述
      Manifest JarFile.getManifest​()
      返回jar文件清单，如果没有，则返回 null 。
      Manifest JarInputStream.getManifest​()
      返回此JAR文件的 null如果没有，则返回 Manifest 。
      Constructors in java.util.jar with parameters of type Manifest
      Constructor 描述
      JarOutputStream​(OutputStream out, Manifest man)
      创建一个新的 JarOutputStream与指定的 Manifest 。
      Manifest​(Manifest man)
      构造一个新的清单，它是指定的清单的副本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.jar.Pack200 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.jar.Pack200

No usage of java.util.jar.Pack200
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.jar.Pack200.Packer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.jar.Pack200.Packer

  • Packages that use Pack200.Packer
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of Pack200.Packer in java.util.jar

      Methods in java.util.jar that return Pack200.Packer
      Modifier and Type 方法 描述
      static Pack200.Packer Pack200.newPacker​()
      获取实现Packer的类的新实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.jar.Pack200.Unpacker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.jar.Pack200.Unpacker

  • Packages that use Pack200.Unpacker
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of Pack200.Unpacker in java.util.jar

      Methods in java.util.jar that return Pack200.Unpacker
      Modifier and Type 方法 描述
      static Pack200.Unpacker Pack200.newUnpacker​()
      获取实现Unpacker的类的新实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ConsoleHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class ConsoleHandler

  • java.lang.Object
    • java.util.logging.Handler
      • java.util.logging.StreamHandler
        • java.util.logging.ConsoleHandler

  • public class ConsoleHandler
extends StreamHandler
    这个Handler将日志记录发布到System.err 。 默认情况下， SimpleFormatter用于生成简要摘要。

    配置：默认情况下，每个ConsoleHandler使用以下LogManager配置属性进行初始化，其中<handler-name>引用处理程序的完全限定类名。 如果未定义属性（或具有无效值），则使用指定的默认值。

    • <处理程序名> .LEVEL指定了默认级别Handler （默认为Level.INFO ）。
    • <处理程序名> .filter指定的名称Filter类中使用（默认为无Filter ）。
    • <处理程序名> .formatter指定的名称Formatter类中使用（默认为java.util.logging.SimpleFormatter ）。
    • <handler-name>。编码要使用的字符集编码的名称（默认为默认平台编码）。

    例如， ConsoleHandler的属性将是：

    • java.util.logging.ConsoleHandler.level = INFO
    • java.util.logging.ConsoleHandler.formatter = java.util.logging.SimpleFormatter

    对于自定义处理程序，例如com.foo.MyHandler，属性将是：

    • com.foo.MyHandler.level = INFO
    • com.foo.MyHandler.formatter = java.util.logging.SimpleFormatter
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConsoleHandler​()
      创建 ConsoleHandler为 System.err 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      覆盖 StreamHandler.close进行刷新，但不关闭输出流。
      void publish​(LogRecord record)
      发表 LogRecord 。

      • Methods inherited from class java.util.logging.Handler

        getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setErrorManager, setFilter, setFormatter, setLevel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.logging.StreamHandler

        flush, isLoggable, setEncoding, setOutputStream

    • 构造方法详细信息

      • ConsoleHandler

        public ConsoleHandler​()
        创建ConsoleHandler为System.err 。

        ConsoleHandler基于LogManager属性（或其默认值）进行配置。

    • 方法详细信息

      • publish

        public void publish​(LogRecord record)
        发表LogRecord 。

        日志记录请求初始化为Logger对象，初始化LogRecord并将其转发到此处。

        重写：
        publish在 StreamHandler
        参数
        record - 日志事件的描述。 空值记录被默认忽略并且未发布

      • close

        public void close​()
        覆盖StreamHandler.close进行刷新，但不关闭输出流。 也就是说，我们不关闭System.err 。
        重写：
        close在 StreamHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ErrorManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class ErrorManager

  • java.lang.Object
    • java.util.logging.ErrorManager

  • public class ErrorManager
extends Object
    可以将ErrorManager对象附加到处理程序，以处理在记录期间在处理程序中发生的任何错误。

    处理日志记录输出时，如果处理程序遇到问题，而不是将异常返回给日志调用的发行者（谁不太可能感兴趣），则处理程序应调用其关联的ErrorManager。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CLOSE_FAILURE
      当关闭输出流失败时使用CLOSE_FAILURE。
      static int FLUSH_FAILURE
      当输出流的刷新失败时使用FLUSH_FAILURE。
      static int FORMAT_FAILURE
      由于任何原因格式化失败时使用FORMAT_FAILURE。
      static int GENERIC_FAILURE
      GENERIC_FAILURE用于不符合其他类别的故障。
      static int OPEN_FAILURE
      当输出流的打开失败时使用OPEN_FAILURE。
      static int WRITE_FAILURE
      写输出流失败时使用WRITE_FAILURE。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ErrorManager​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void error​(String msg, 异常 ex, int code)
      发生处理程序失败时调用错误方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • GENERIC_FAILURE

        public static final int GENERIC_FAILURE
        GENERIC_FAILURE用于不符合其他类别的故障。
        另请参见：
        Constant Field Values

      • WRITE_FAILURE

        public static final int WRITE_FAILURE
        写输出流失败时使用WRITE_FAILURE。
        另请参见：
        Constant Field Values

      • FLUSH_FAILURE

        public static final int FLUSH_FAILURE
        当输出流的刷新失败时使用FLUSH_FAILURE。
        另请参见：
        Constant Field Values

      • CLOSE_FAILURE

        public static final int CLOSE_FAILURE
        当关闭输出流失败时使用CLOSE_FAILURE。
        另请参见：
        Constant Field Values

      • OPEN_FAILURE

        public static final int OPEN_FAILURE
        当输出流的打开失败时使用OPEN_FAILURE。
        另请参见：
        Constant Field Values

      • FORMAT_FAILURE

        public static final int FORMAT_FAILURE
        由于任何原因格式化失败时使用FORMAT_FAILURE。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ErrorManager

        public ErrorManager​()

    • 方法详细信息

      • error

        public void error​(String msg,
                  异常 ex,
                  int code)
        发生处理程序失败时调用错误方法。

        此方法可能会在子类中被覆盖。 此基类中的默认行为是将第一个调用报告给System.err，后续调用将被忽略。

        参数
        msg - 一个描述性字符串（可以为空）
        ex - 异常（可能为空）
        code - ErrorManager中定义的错误代码
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


FileHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class FileHandler

  • java.lang.Object
    • java.util.logging.Handler
      • java.util.logging.StreamHandler
        • java.util.logging.FileHandler

  • public class FileHandler
extends StreamHandler
    简单的文件记录Handler 。

    FileHandler可以写入指定的文件，也可以写入一组旋转的文件。

    对于一组旋转的文件，当每个文件达到给定的大小限制时，它将被关闭，旋转并打开一个新文件。 以前的文件通过将“0”，“1”，“2”等添加到基本文件名中来命名。

    默认情况下，IO库中启用了缓存，但是每个日志记录在完成后才会被刷新。

    默认情况下， XMLFormatter类用于格式化。

    配置：默认情况下，每个FileHandler都使用以下LogManager配置属性进行初始化，其中<handler-name>引用处理程序的完全限定类名。 如果未定义属性（或具有无效值），则使用指定的默认值。

    • <处理程序名> .LEVEL指定了默认级别Handler （默认为Level.ALL ）。
    • <处理程序名> .filter指定的名称Filter类中使用（默认为无Filter ）。
    • <处理程序名> .formatter指定的名称Formatter使用（默认为class java.util.logging.XMLFormatter ）
    • <handler-name>。编码要使用的字符集编码的名称（默认为默认平台编码）。
    • <handler-name> .limit指定要写入的大致最大数量（以字节为单位）到任何一个文件。 如果这是零，那么没有限制。 （默认为无限制）。
    • <handler-name> .count指定要循环多少个输出文件（默认为1）。
    • <handler-name> .pattern指定用于生成输出文件名的模式。 详见下文。 （默认为“％h / java％u.log”）。
    • <handler-name> .append指定FileHandler是否应该附加到任何现有文件（默认为false）。
    • <handler-name> .maxLocks指定由FileHandler持有的最大并发锁数（默认为100）。

    例如， FileHandler的属性将是：

    • java.util.logging.FileHandler.level = INFO
    • java.util.logging.FileHandler.formatter = java.util.logging.SimpleFormatter

    对于自定义处理程序，例如com.foo.MyHandler，属性将是：

    • com.foo.MyHandler.level = INFO
    • com.foo.MyHandler.formatter = java.util.logging.SimpleFormatter

    模式由包含以下特殊组件的字符串组成，将在运行时被替换：

    • “/”本地路径名分隔符
    • “％t”系统临时目录
    • “％h”的“user.home”系统属性的值
    • “％g”代表旋转日志的代数
    • “％u”是解决冲突的唯一编号
    • “%%”转换为单个百分号“％”
    如果没有指定“％g”字段，并且文件数大于1，则生成号将被添加到生成的文件名的末尾。

    因此，例如，计数为2的“％t / java％g.log”模式通常会将日志文件写入Solaris到/var/tmp/java0.log和/var/tmp/java1.log，而在Windows 95上，它们通常会写入C：\ TEMP \ java0.log和C：\ TEMP \ java1.log

    代数遵循序列0,1,2等

    通常，“％u”唯一字段设置为0.但是，如果FileHandler尝试打开文件名，并发现该文件当前正在被另一个进程使用，则会增加唯一的数字字段，然后重试。 这将重复，直到FileHandler找到当前未使用的文件名。 如果存在冲突，并且没有指定“％u”字段，则会在文件名的末尾添加点。 （这将是任何自动添加的代号之后）。

    因此，如果三个进程都尝试登录到fred％u。％g.txt，那么他们可能会使用fred0.0.txt，fred1.0.txt，fred2.0.txt作为其旋转序列中的第一个文件。

    请注意，使用唯一的ids来避免冲突只能保证在使用本地磁盘文件系统时可靠地工作。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileHandler​()
      构造默认值 FileHandler 。
      FileHandler​(String pattern)
      初始化 FileHandler以写入给定的文件名。
      FileHandler​(String pattern, boolean append)
      初始化一个 FileHandler写入给定的文件名，可选附加。
      FileHandler​(String pattern, int limit, int count)
      初始化一个 FileHandler写入一组文件。
      FileHandler​(String pattern, int limit, int count, boolean append)
      初始化 FileHandler以写入一组可选附加的文件。
      FileHandler​(String pattern, long limit, int count, boolean append)
      初始化一个 FileHandler以写入一组可选附加的文件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭所有文件。
      void publish​(LogRecord record)
      格式化并发布 LogRecord 。

      • Methods inherited from class java.util.logging.Handler

        getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setErrorManager, setFilter, setFormatter, setLevel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.logging.StreamHandler

        flush, isLoggable, setEncoding, setOutputStream

    • 构造方法详细信息

      • FileHandler

        public FileHandler​()
            throws IOException,
                   SecurityException
        构造默认值FileHandler 。 这将完全由LogManager属性（或其默认值）配置。
        异常
        IOException - 如果打开文件时有IO问题。
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control")) 。
        NullPointerException - 如果pattern属性是一个空字符串。

      • FileHandler

        public FileHandler​(String pattern)
            throws IOException,
                   SecurityException
        初始化FileHandler以写入给定的文件名。

        FileHandler是基于LogManager属性（或其默认值）配置的，除了给定的模式参数用作文件名模式，文件限制设置为无限制，文件数设置为1。

        可能写入的数据量没有限制，因此请谨慎使用。

        参数
        pattern - 输出文件的名称
        异常
        IOException - 如果存在打开文件的IO问题。
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control") 。
        IllegalArgumentException - 如果pattern是一个空字符串

      • FileHandler

        public FileHandler​(String pattern,
                   boolean append)
            throws IOException,
                   SecurityException
        初始化一个FileHandler以写入给定的文件名，可选附加。

        FileHandler是基于LogManager属性（或其默认值）配置的，除了使用给定的模式参数作为文件名模式，文件限制设置为无限制，文件数设置为1，并设置追加模式到给定的append参数。

        可能写入的数据量没有限制，因此请谨慎使用。

        参数
        pattern - 输出文件的名称
        append - 指定追加模式
        异常
        IOException - 如果打开文件时有IO问题。
        SecurityException - 如果存在安全管理员，并且呼叫者没有 LoggingPermission("control") 。
        IllegalArgumentException - 如果pattern是空字符串

      • FileHandler

        public FileHandler​(String pattern,
                   int limit,
                   int count)
            throws IOException,
                   SecurityException
        初始化FileHandler以写入一组文件。 当（大约）给定的限制已写入一个文件时，将打开另一个文件。 输出将循环通过一组计数文件。

        FileHandler基于LogManager属性（或其默认值）进行配置，除了给定的模式参数用作文件名模式，文件限制设置为limit参数，文件计数设置为给定的计数参数。

        计数必须至少为1。

        参数
        pattern - 命名输出文件的模式
        limit - 写入任何一个文件的最大字节数
        count - 要使用的文件数
        异常
        IOException - 如果打开文件时有IO问题。
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control") 。
        IllegalArgumentException - 如果是 limit < 0 ，或者是 count < 1 。
        IllegalArgumentException - 如果模式是空字符串

      • FileHandler

        public FileHandler​(String pattern,
                   int limit,
                   int count,
                   boolean append)
            throws IOException,
                   SecurityException
        初始化FileHandler以写入一组可选的附加文件。 当（大约）给定的限制已写入一个文件时，将打开另一个文件。 输出将循环通过一组计数文件。

        FileHandler是基于LogManager属性（或其默认值）配置的，除了给定的模式参数用作文件名模式，文件限制设置为limit参数，文件数设置为给定的计数参数，追加模式设置为给定的append参数。

        计数必须至少为1。

        参数
        pattern - 命名输出文件的模式
        limit - 写入任何一个文件的最大字节数
        count - 要使用的文件数
        append - 指定追加模式
        异常
        IOException - 如果打开文件时有IO问题。
        SecurityException - 如果安全管理器存在，并且主叫方没有 LoggingPermission("control") 。
        IllegalArgumentException - 如果是 limit < 0或 count < 1 。
        IllegalArgumentException - 如果pattern是空字符串

      • FileHandler

        public FileHandler​(String pattern,
                   long limit,
                   int count,
                   boolean append)
            throws IOException
        初始化一个FileHandler写入一组可选附加的文件。 当（大约）给定的限制已写入一个文件时，将打开另一个文件。 输出将循环通过一组计数文件。

        FileHandler是基于LogManager属性（或其默认值）配置的，除了给定的模式参数用作文件名模式，文件限制设置为limit参数，文件数设置为给定的计数参数，追加模式设置为给定的append参数。

        计数必须至少为1。

        参数
        pattern - 命名输出文件的模式
        limit - 要写入任何一个文件的最大字节数
        count - 要使用的文件数
        append - 指定追加模式
        异常
        IOException - 如果打开文件时有IO问题。
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control") 。
        IllegalArgumentException - 如果是 limit < 0 ，或者是 count < 1 。
        IllegalArgumentException - 如果pattern是一个空字符串
        从以下版本开始：
        9

    • 方法详细信息

      • publish

        public void publish​(LogRecord record)
        格式化并发布一个 LogRecord 。
        重写：
        publish在 StreamHandler
        参数
        record - 日志事件的描述。 空值记录被默认忽略并且未发布

      • close

        public void close​()
           throws SecurityException
        关闭所有文件。
        重写：
        close在 StreamHandler
        异常
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control") 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Filter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Interface Filter

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Filter
    可以使用过滤器对超出记录级别提供的控制范围内的记录进行细粒度控制。

    每个记录器和每个处理程序都可以有一个与之关联的过滤器。 Logger或Handler将调用isLoggable方法来检查是否应发布给定的LogRecord。 如果isLoggable返回false，LogRecord将被丢弃。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean isLoggable​(LogRecord record)
      检查是否应发布给定的日志记录。

    • 方法详细信息

      • isLoggable

        boolean isLoggable​(LogRecord record)
        检查是否应发布给定的日志记录。
        参数
        record - 一个LogRecord
        结果
        true if the log record should be published.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Formatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class Formatter

  • java.lang.Object
    • java.util.logging.Formatter
  • 已知直接子类：
    SimpleFormatter ， XMLFormatter

    public abstract class Formatter
extends Object
    格式化程序提供对LogRecords进行格式化的支持。

    通常每个记录处理程序都将有一个与它相关联的格式化程序。 格式化器采用LogRecord并将其转换为字符串。

    一些格式化器（如XMLFormatter）需要围绕一组格式化的记录包裹头和尾字符串。 getHeader和getTail方法可用于获取这些字符串。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Formatter​()
      构造一个新的格式化程序

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract String format​(LogRecord record)
      格式化给定的日志记录并返回格式化的字符串。
      String formatMessage​(LogRecord record)
      从日志记录本地化和格式化消息字符串。
      String getHead​(Handler h)
      返回一组格式化记录的标题字符串。
      String getTail​(Handler h)
      返回一组格式化记录的尾部字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Formatter

        protected Formatter​()
        构造一个新的格式化程序

    • 方法详细信息

      • format

        public abstract String format​(LogRecord record)
        格式化给定的日志记录并返回格式化的字符串。

        生成的格式化的字符串通常会包含LogRecord消息字段的本地化和格式化版本。 建议使用formatMessage(java.util.logging.LogRecord)方便的方法来定位和格式化消息字段。

        参数
        record - 要格式化的日志记录。
        结果
        格式化的日志记录

      • getHead

        public String getHead​(Handler h)
        返回一组格式化记录的标题字符串。

        这个基类返回一个空字符串，但这可以被子类覆盖。

        参数
        h - 目标处理程序（可以为null）
        结果
        标题字符串

      • getTail

        public String getTail​(Handler h)
        返回一组格式化记录的尾部字符串。

        这个基类返回一个空字符串，但这可以被子类覆盖。

        参数
        h - 目标处理程序（可以为null）
        结果
        尾弦

      • formatMessage

        public String formatMessage​(LogRecord record)
        从日志记录本地化和格式化消息字符串。 提供此方法作为Formatter子类在执行格式化时使用的方便。

        消息字符串首先使用记录的ResourceBundle本地化为格式字符串。 （如果没有ResourceBundle，或者如果没有找到消息键，则将该键用作格式字符串。）格式String使用java.text样式格式。

        • 如果没有参数，则不使用格式化器。
        • 否则，如果字符串中包含“{<digit>”，其中<digit>在[0-9]中，则使用java.text.MessageFormat格式化该字符串。
        • 否则不执行格式化。
        参数
        record - 包含原始消息的日志记录
        结果
        本地化和格式化的消息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Handler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class Handler

  • java.lang.Object
    • java.util.logging.Handler
  • 已知直接子类：
    MemoryHandler ， StreamHandler

    public abstract class Handler
extends Object
    一个Handler对象从需要日志消息Logger和出口他们。 例如，可以将它们写入控制台或将其写入文件，或者将其发送到网络日志记录服务，或将其转发到操作系统日志或其他任何操作系统。

    A Handler可以通过执行setLevel(Level.OFF)禁用，并且可以通过执行适当级别的setLevel重新启用。

    Handler类通常使用LogManager属性来用于设置默认值的Handler的Filter ， Formatter ，和Level 。 请参阅每个具体的具体文档Handler课程。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Handler​()
      默认构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void close​()
      关闭 Handler并释放所有相关资源。
      abstract void flush​()
      冲洗任何缓冲输出。
      String getEncoding​()
      返回这个 Handler的字符编码。
      ErrorManager getErrorManager​()
      检索此处理程序的ErrorManager。
      Filter getFilter​()
      获取当前的 Filter为这 Handler 。
      Formatter getFormatter​()
      返回 Formatter为这个 Handler 。
      Level getLevel​()
      获取日志级别，指定 Handler将记录哪些消息。
      boolean isLoggable​(LogRecord record)
      检查这个 Handler是否会实际记录给定的 LogRecord 。
      abstract void publish​(LogRecord record)
      发表 LogRecord 。
      protected void reportError​(String msg, 异常 ex, int code)
      受保护的方便方法来向此处理程序的ErrorManager报告错误。
      void setEncoding​(String encoding)
      设置 Handler使用的字符编码。
      void setErrorManager​(ErrorManager em)
      为此处理程序定义一个ErrorManager。
      void setFilter​(Filter newFilter)
      设置 Filter以控制此 Handler输出。
      void setFormatter​(Formatter newFormatter)
      设置 Formatter 。
      void setLevel​(Level newLevel)
      设置日志级别，指定 Handler将记录哪些消息级别。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Handler

        protected Handler​()
        默认构造函数。 得到的Handler的日志级别为Level.ALL ，不是Formatter ，而不是Filter 。 默认ErrorManager实例作为ErrorManager安装。

    • 方法详细信息

      • publish

        public abstract void publish​(LogRecord record)
        发表LogRecord 。

        日志记录请求初始化为一个Logger对象，初始化了LogRecord并在此转发。

        Handler负责格式化消息，何时和如有必要。 格式应包括本地化。

        参数
        record - 日志事件的描述。 空值记录被默认忽略并且未发布

      • flush

        public abstract void flush​()
        冲洗任何缓冲输出。

      • close

        public abstract void close​()
                    throws SecurityException
        关闭Handler并释放所有相关资源。

        关闭方法将执行flush ，然后关闭Handler 。 在关闭之后，这个Handler应该不再被使用了。 方法调用可能会被忽略或可能抛出运行时异常。

        异常
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control") 。

      • setFormatter

        public void setFormatter​(Formatter newFormatter)
                  throws SecurityException
        设置Formatter 。 这个Formatter将用于格式LogRecords为这Handler 。

        有些Handlers可能不使用Formatters ，在这种情况下， Formatter将被记住，但不被使用。

        参数
        newFormatter - 要使用的 Formatter （可能不为空）
        异常
        SecurityException - 如果存在安全管理员，并且呼叫者没有 LoggingPermission("control") 。

      • getFormatter

        public Formatter getFormatter​()
        返回 Formatter为这 Handler 。
        结果
        Formatter （可能为null）。

      • setEncoding

        public void setEncoding​(String encoding)
                 throws SecurityException,
                        UnsupportedEncodingException
        设置Handler使用的字符编码。

        之前的任何编码应设置LogRecords被写入Handler 。

        参数
        encoding - 支持的字符编码的名称。 可以为空，表示默认的平台编码。
        异常
        SecurityException - 如果存在安全管理员，并且呼叫方没有 LoggingPermission("control") 。
        UnsupportedEncodingException - 如果不支持命名编码。

      • getEncoding

        public String getEncoding​()
        返回此 Handler的字符编码。
        结果
        编码名称。 可能为null，表示应使用默认编码。

      • setFilter

        public void setFilter​(Filter newFilter)
               throws SecurityException
        设置Filter以控制此Handler输出。

        对于每个呼叫publish的Handler会调用这个Filter （如果非空），以检查是否LogRecord应发布或放弃。

        参数
        newFilter - a Filter对象（可能为空）
        异常
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control") 。

      • getFilter

        public Filter getFilter​()
        获取当前的 Filter为这 Handler 。
        结果
        一个 Filter对象（可能为null）

      • setErrorManager

        public void setErrorManager​(ErrorManager em)
        为此处理程序定义一个ErrorManager。

        如果在使用此处理程序时发生任何错误，将会调用ErrorManager的“错误”方法。

        参数
        em - 新的ErrorManager
        异常
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control") 。

      • getErrorManager

        public ErrorManager getErrorManager​()
        检索此处理程序的ErrorManager。
        结果
        该处理程序的ErrorManager
        异常
        SecurityException - 如果安全管理器存在，并且主叫方没有 LoggingPermission("control") 。

      • reportError

        protected void reportError​(String msg,
                           异常 ex,
                           int code)
        受保护的方便方法来向此处理程序的ErrorManager报告错误。 请注意，此方法在不进行安全检查的情况下检索并使用ErrorManager。 因此，它可以在呼叫者可能是非特权的环境中使用。
        参数
        msg - 描述性字符串（可以为空）
        ex - 异常（可能为空）
        code - ErrorManager中定义的错误代码

      • setLevel

        public void setLevel​(Level newLevel)
              throws SecurityException
        设置日志级别，指定Handler记录哪些消息级别。 消息级别低于此值将被丢弃。

        目的是允许开发人员打开大量日志记录，但是限制发送到某些Handlers的消息。

        参数
        newLevel - 日志级别的新值
        异常
        SecurityException - 如果安全管理器存在，并且主叫方没有 LoggingPermission("control") 。

      • getLevel

        public Level getLevel​()
        获取日志级别，指定Handler记录哪些消息。 消息级别低于此级别将被丢弃。
        结果
        正在记录的消息级别。

      • isLoggable

        public boolean isLoggable​(LogRecord record)
        检查这个Handler是否会实际记录给定的LogRecord 。

        此方法检查LogRecord是否适合Level以及是否满足任何Filter 。 它也可能使其他Handler具体检查可能会阻止处理程序记录LogRecord 。 如果LogRecord为null，则返回false。

        参数
        record - a LogRecord
        结果
        如果要记录 LogRecord true。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.util.logging (Java SE 9 & JDK 9 )

java.util.logging

Interfaces

  • Filter
  • LoggingMXBean

Classes

  • ConsoleHandler
  • ErrorManager
  • FileHandler
  • Formatter
  • Handler
  • Level
  • Logger
  • LoggingPermission
  • LogManager
  • LogRecord
  • MemoryHandler
  • SimpleFormatter
  • SocketHandler
  • StreamHandler
  • XMLFormatter


java.util.logging (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.logging

Package java.util.logging

提供Java¢2平台核心日志记录工具的类和接口。 日志API的核心目标是支持在客户站点维护和维护软件。

日志有四个主要目标用途：

  1. 最终用户和系统管理员的问题诊断 。 这包括简单记录可以在本地修复或跟踪的常见问题，例如资源耗尽，安全故障和简单的配置错误。
  2. 现场服务工程师的问题诊断 。 现场服务工程师使用的日志信息可能比系统管理员要求的复杂和冗长。 通常，这些信息将需要在特定子系统内进行额外的记录
  3. 发展组织的问题诊断 。 当现场出现问题时，可能需要将捕获的记录信息返回原始开发团队进行诊断。 这种记录信息可能非常详细和不可忽视。 这些信息可能包括对特定子系统的内部执行的详细跟踪。
  4. 开发人员的问题诊断 Logging API也可用于帮助调试正在开发的应用程序。 这可能包括目标应用程序生成的记录信息以及下级库生成的日志信息。 但是请注意，尽管这种使用是完全合理的，但记录API并不打算替代开发环境中可能已经存在的正常调试和剖析工具。

该包的关键要素包括：

  • 记录器 ：应用程序进行日志记录调用的主要实体。 Logger对象用于记录特定系统或应用程序组件的消息。
  • LogRecord ：用于在日志记录框架和各个日志处理程序之间传递日志请求。
  • 处理程序 ：将LogRecord对象导出到各种目标，包括内存，输出流，控制台，文件和套接字。 为此目的存在各种Handler子类。 附加处理程序可能由第三方开发并交付在核心平台之上。
  • 级别 ：定义可用于控制日志记录输出的一组标准日志记录级别。 程序可以配置为输出某些级别的日志记录，而忽略其他级别的输出。
  • 过滤器 ：提供对日志记录的精细控制，超出日志级别提供的控制。 日志记录API支持通用过滤器机制，允许应用程序代码附加任意过滤器来控制日志输出。
  • 格式化器 ：支持格式化LogRecord对象。 该包包括两个格式化程序SimpleFormatter和XMLFormatter，用于分别以纯文本或XML格式化日志记录。 与处理程序一样，第三方可能会开发其他格式化程序。

日志API提供静态和动态配置控制。 静态控制使现场服务人员可以设置特定配置，然后使用新的日志记录设置重新启动应用程序。 动态控制允许在当前运行的程序中更新日志记录配置。 API还允许为系统的不同功能区域启用或禁用日志记录。 例如，现场服务工程师可能有兴趣跟踪所有AWT事件，但可能对套接字事件或内存管理不感兴趣。

空指针

通常，除非在javadoc中另有说明，否则方法和构造函数将抛出NullPointerException（如果传递一个空参数）。 这个规则的一个大例外是Logger类中的记录方便方法（config，enter，exiting，fine，fine，finest，log，logp，logrb，severe，throwing和warning方法）将接受null值所有参数除了初始的Level参数（如果有的话）。

相关文档

有关控制流程的概述，请参阅Java Logging Overview

从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    Filter
    可以使用过滤器对超出记录级别提供的控制范围内的记录进行细粒度控制。
    LoggingMXBean Deprecated.
    LoggingMXBean不再是platform MXBean ，而是用PlatformLoggingMXBean替代。
  • 类摘要
    Class 描述
    ConsoleHandler
    这个 Handler发布日志记录到 System.err 。
    ErrorManager
    可以将ErrorManager对象附加到处理程序，以处理在记录期间在处理程序中发生的任何错误。
    FileHandler
    简单文件记录 Handler 。
    Formatter
    格式化程序提供对LogRecords进行格式化的支持。
    Handler
    一个 Handler对象从需要日志消息 Logger和出口他们。
    Level
    Level类定义了一组可用于控制日志输出的标准日志记录级别。
    Logger
    Logger对象用于记录特定系统或应用程序组件的消息。
    LoggingPermission
    当SecurityManager运行的代码调用其中一个日志控件方法（如Logger.setLevel）时，SecurityManager将检查该权限。
    LogManager
    有一个全局LogManager对象用于维护关于日志记录器和日志服务的一组共享状态。
    LogRecord
    LogRecord对象用于在日志框架和各个日志处理程序之间传递日志请求。
    MemoryHandler
    Handler缓冲区内存中循环缓冲区中的请求。
    SimpleFormatter
    以人类可读格式打印 LogRecord的简要摘要。
    SocketHandler
    简单网络记录 Handler 。
    StreamHandler
    基于流的日志记录 Handler 。
    XMLFormatter
    将LogRecord格式化为标准XML格式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.logging Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.logging

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.logging.ErrorManager
    • java.util.logging.Formatter
      • java.util.logging.SimpleFormatter
      • java.util.logging.XMLFormatter
    • java.util.logging.Handler
      • java.util.logging.MemoryHandler
      • java.util.logging.StreamHandler
        • java.util.logging.ConsoleHandler
        • java.util.logging.FileHandler
        • java.util.logging.SocketHandler
    • java.util.logging.Level (implements java.io.Serializable)
    • java.util.logging.Logger
    • java.util.logging.LogManager
    • java.util.logging.LogRecord (implements java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.util.logging.LoggingPermission

Interface Hierarchy

  • java.util.logging.Filter
  • java.util.logging.LoggingMXBean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Level (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class Level

  • java.lang.Object
    • java.util.logging.Level
  • All Implemented Interfaces:
    Serializable

    public class Level
extends Object
implements Serializable
    Level类定义了一组可用于控制日志输出的标准日志记录级别。 记录级别对象被排序并且由有序整数指定。 在给定级别启用日志记录还可以在所有更高级别进行日志记录。

    客户端应通常使用预定义的Level常量，如Level.SEVERE。

    降序的级别是：

    • SEVERE（最高值）
    • 警告
    • 信息
    • CONFIG
    • 精细
    • FINER
    • FINEST（最低值）
    另外还有一个可以用来关闭日志记录的级别OFF，还有一个可以用来启用所有消息日志记录的级别ALL。

    通过对Level进行子类化，第三方有可能定义附加的日志记录级别。 在这种情况下，子类应该注意选择唯一的整数级别值，并确保它们通过定义合适的readResolve方法在整个序列化过程中维护Object唯一性。

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Level ALL
      ALL表示所有消息都应该被记录。
      static Level CONFIG
      CONFIG是静态配置消息的消息级别。
      static Level FINE
      FINE是提供跟踪信息的消息级别。
      static Level FINER
      FINER表示相当详细的跟踪消息。
      static Level FINEST
      FINEST表示高度详细的跟踪消息。
      static Level INFO
      INFO是信息性消息的消息级别。
      static Level OFF
      OFF是可用于关闭日志记录的特殊级别。
      static Level SEVERE
      SEVERE是指示严重故障的消息级别。
      static Level WARNING
      警告是指示潜在问题的消息级别。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Level​(String name, int value)
      创建一个具有给定整数值的命名级别。
      protected Level​(String name, int value, String resourceBundleName)
      创建一个具有给定整数值和给定的本地化资源名称的命名级别。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object ox)
      比较两个对象的值相等。
      String getLocalizedName​()
      返回当前默认语言环境的Level的本地化字符串名称。
      String getName​()
      返回Level的非本地化字符串名称。
      String getResourceBundleName​()
      返回级别的本地化资源包名称，如果未定义本地化包，则返回null。
      int hashCode​()
      生成哈希码。
      int intValue​()
      获取此级别的整数值。
      static Level parse​(String name)
      将级别名称字符串解析为级别。
      String toString​()
      返回此级别的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • OFF

        public static final Level OFF
        OFF是可用于关闭日志记录的特殊级别。 该级别初始化为Integer.MAX_VALUE 。

      • SEVERE

        public static final Level SEVERE
        SEVERE是指示严重故障的消息级别。

        一般来说，SEVERE消息应描述相当重要的事件，哪些会阻止正常的程序执行。 对于最终用户和系统管理员来说，它们应该是合理的。 该级别初始化为1000 。

      • WARNING

        public static final Level WARNING
        警告是指示潜在问题的消息级别。

        一般来说，警告消息应描述终端用户或系统管理员感兴趣的事件，或者说明潜在的问题。 该级别初始化为900 。

      • INFO

        public static final Level INFO
        INFO是信息性消息的消息级别。

        通常，INFO消息将被写入控制台或其等效项。 因此，INFO级别只能用于对终端用户和系统管理员有意义的合理重要的消息。 该级别初始化为800 。

      • CONFIG

        public static final Level CONFIG
        CONFIG是静态配置消息的消息级别。

        CONFIG消息旨在提供各种静态配置信息，以帮助调试可能与特定配置相关联的问题。 例如，CONFIG消息可能包括CPU类型，图形深度，GUI外观等。此级别初始化为700 。

      • FINE

        public static final Level FINE
        FINE是提供跟踪信息的消息级别。

        所有FINE，FINER和FINEST都用于相对详细的追踪。 三个级别的确切含义将在子系统之间变化，但通常，FINEST应用于最大体积的详细输出，FINER用于稍微不太详细的输出，FINE用于最低音量（和最重要的）消息。

        一般来说，FINE级别应用于对特定子系统没有特殊兴趣的开发人员将会很有趣的信息。

        FINE消息可能包括诸如次要（可恢复）故障。 表明潜在性能问题的问题也值得记录为FINE。 该级别初始化为500 。

      • FINER

        public static final Level FINER
        FINER表示相当详细的跟踪消息。 默认情况下，在此级别跟踪进入，返回或抛出异常的日志记录。 该级别初始化为400 。

      • FINEST

        public static final Level FINEST
        FINEST表示高度详细的跟踪消息。 该级别初始化为300 。

      • ALL

        public static final Level ALL
        ALL表示所有消息都应该被记录。 该级别初始化为Integer.MIN_VALUE 。

    • 构造方法详细信息

      • Level

        protected Level​(String name,
                int value)
        创建一个具有给定整数值的命名级别。

        注意这个构造函数是“protected”来允许子类化。 一般来说，日志记录的客户端应该使用一个恒定的Level对象，如SEVERE或FINEST。 但是，如果客户端需要添加新的日志记录级别，则它们可能会对Level进行子类化并定义新的常量。

        参数
        name - 级别的名称，例如“SEVERE”。
        value - 级别的整数值。
        异常
        NullPointerException - 如果名称为空

      • Level

        protected Level​(String name,
                int value,
                String resourceBundleName)
        创建一个具有给定整数值和给定的本地化资源名称的命名级别。
        参数
        name - 级别的名称，例如“SEVERE”。
        value - 级别的整数值。
        resourceBundleName - 用于本地化给定名称的资源束的名称。 如果resourceBundleName为空或空字符串，则会被忽略。
        异常
        NullPointerException - 如果名称为空

    • 方法详细信息

      • getResourceBundleName

        public String getResourceBundleName​()
        返回级别的本地化资源包名称，如果未定义本地化包，则返回null。
        结果
        本地化资源包名称

      • getName

        public String getName​()
        返回Level的非本地化字符串名称。
        结果
        非本地化名称

      • getLocalizedName

        public String getLocalizedName​()
        返回当前默认语言环境的Level的本地化字符串名称。

        如果没有可用的本地化信息，则返回非本地化名称。

        结果
        本地化名称

      • toString

        public final String toString​()
        返回此级别的字符串表示形式。
        重写：
        toString在 Object
        结果
        Level的非本地化名称，例如“INFO”。

      • intValue

        public final int intValue​()
        获取此级别的整数值。 该整数值可用于Level对象之间的有效排序比较。
        结果
        该级别的整数值。

      • parse

        public static Level parse​(String name)
                   throws IllegalArgumentException
        将级别名称字符串解析为级别。

        参数字符串可以由级别名称或整数值组成。

        例如：

        • “严重”
        • “1000”
        参数
        name - 要解析的字符串
        结果
        被解析的价值。 传递一个与已知名称相对应的整数（例如700）将返回相关联的名称（例如， CONFIG ）。 传递一个不是（例如，1）的整数将返回一个初始化为该值的新级别名称。
        异常
        NullPointerException - 如果名称为空
        IllegalArgumentException - 如果该值无效。 有效值为Integer.MIN_VALUE和Integer.MAX_VALUE之间的整数，以及所有已知级别名称。 已知的名称是由此类定义的水平（例如， FINE ， FINER ， FINEST ），或由该类适当的包访问，或子类中定义或创建新的水平建立。

      • equals

        public boolean equals​(Object ox)
        比较两个对象的值相等。
        重写：
        equals在 Object
        参数
        ox - 与之比较的参考对象。
        结果
        如果且仅当两个对象具有相同的级别值，则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        生成哈希码。
        重写：
        hashCode在 Object
        结果
        基于级别值的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Logger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class Logger

  • java.lang.Object
    • java.util.logging.Logger

  • public class Logger
extends Object
    Logger对象用于记录特定系统或应用程序组件的消息。 记录器通常被命名，使用分层的点分隔命名空间。 记录器名称可以是任意字符串，但它们通常应基于记录组件的包名或类名，例如java.net或javax.swing。 此外，还可以创建不存储在记录器命名空间中的“匿名”记录器。

    Logger对象可以通过getLogger工厂方法之一的调用获得。 这些将创建一个新的Logger或返回一个合适的现有Logger。 重要的是要注意，如果不保留对Logger的强烈引用，则可以随时从getLogger工厂方法之一返回的记录器getLogger被垃圾回收。

    记录消息将被转发到已注册的Handler对象，该对象可以将消息转发到各种目的地，包括控制台，文件，操作系统日志等。

    每个记录器跟踪一个“父”记录器，它是Logger命名空间中最近的祖先。

    每个记录器都有一个与其关联的“级别”。 这反映了该记录器关心的最低级别。 如果记录器的级别设置为null ，则其有效级别将从其父级继承，这可以从其父级递归地获取它，并且等等。

    可以根据日志配置文件的属性配置日志级别，如LogManager类的描述中所述。 但是也可以通过Logger.setLevel方法的调用动态更改。 如果记录器的级别发生更改，则更改也可能会影响到子记录器，因为任何具有null级别的子记录器将从其父级继承其有效级别。

    在每个日志记录中，记录器首先根据记录器的有效日志级别执行对请求级别的便宜检查（例如SEVERE或FINE）。 如果请求级别低于日志级别，日志记录调用将立即返回。

    在通过此初始（便宜）测试之后，记录器将分配一个LogRecord来描述记录消息。 然后它将调用过滤器（如果存在）来更详细地检查是否应该发布记录。 如果通过它，则将LogRecord发布到其输出处理程序。 默认情况下，记录器也会向树的父进程发布。

    每个记录器可能有一个ResourceBundle与之相关联。 ResourceBundle可以通过名称，使用getLogger(java.lang.String, java.lang.String)工厂方法或按值 - 使用setResourceBundle方法指定。 此捆绑包将用于本地化日志消息。 如果一个记录器没有自己的ResourceBundle或资源束名称，那么它会从它的父级继承ResourceBundle或资源束名称，递归地上传树。

    大多数记录器输出方法都采用“msg”参数。 该msg参数可以是原始值或本地化密钥。 在格式化期间，如果记录器具有（或继承）本地化ResourceBundle ，如果ResourceBundle具有msg字符串的映射，则msg字符串将被本地化值替换。 否则使用原始msg字符串。 通常，格式化程序使用java.text.MessageFormat样式格式来设置参数格式，例如，格式字符串“{0} {1}”会将两个参数格式化为字符串。

    一组方法或者采用“msgSupplier”而不是“msg”参数。 这些方法采用Supplier <String>函数，只有当消息实际上要根据有效日志级别进行记录，从而消除不必要的消息构造时，才调用它来构造所需的日志消息。 例如，如果开发者想要使用字符串接受版本来记录诊断的系统运行状况，代码将如下所示：

       class DiagnosisMessages { static String systemHealthStatus() { // collect system health information ... } } ... logger.log(Level.FINER, DiagnosisMessages.systemHealthStatus());
    使用上述代码，即使日志级别FINER被禁用，也会不必要地收集运行状况。 使用如下的供应商接受版本，只有启用日志级别FINER时才会收集该状态。
       logger.log(Level.FINER, DiagnosisMessages::systemHealthStatus);

    当查找ResourceBundle ，记录器将首先查看是否使用setResourceBundle指定了一个包，然后只查看是否通过getLogger工厂方法指定了资源包名称。 如果没有ResourceBundle或没有资源束名，那么它将使用从其父树继承的最近的ResourceBundle或资源束名。
    当ResourceBundle被继承或指定通过setResourceBundle方法，则该ResourceBundle将被使用。 否则，如果记录器仅具有或继承了资源包名称，则该资源包名称将映射到ResourceBundle对象，在记录时使用默认的区域设置。
    将资源包名称映射到ResourceBundle对象时，记录器将首先尝试使用线程的context class loader将给定的资源包名称映射到ResourceBundle 。 如果线程上下文类加载器是null ，那么它会尝试system class loader 。 如果仍然没有找到ResourceBundle ，它将使用getLogger工厂方法的第一个调用者的类加载器。

    格式化（包括本地化）是输出Handler的责任，通常会调用Formatter。

    请注意，格式化不需要同步进行。 它可能会被延迟，直到LogRecord实际写入外部接收器。

    记录方法分为五大类：

    • 有一组“日志”方法采用日志级别，消息字符串以及可选的一些参数到消息字符串。

    • 有一套类似于“log”方法的“logp”方法（对于“log精确”），而且还需要一个明确的源类名和方法名称。

    • 有一组“logrb”方法（对于“log with resource bundle”），类似于“logp”方法，而且还需要使用明确的资源束对象来用于本地化日志消息。

    • 有方便的跟踪方法条目（“输入”方法），方法返回（“退出”方法）和抛出异常（“抛出”方法）的方便方法。

    • 最后，当一个开发人员只想在一个给定的日志级别上记录一个简单的字符串时，最简单的情况就是使用一组方便的方法。 这些方法以标准级别名称（“严重”，“警告”，“信息”等）命名，并采用单个参数，即消息字符串。

    对于不使用明确的源名称和方法名称的方法，Logging框架将作出“尽力而为”来确定调用到日志记录方法中的哪个类和方法。 然而，重要的是要意识到，这个自动推断的信息可能只是近似的（或者甚至可能是错误的！）。 允许虚拟机在JITing时进行大量优化，并可能完全删除堆栈帧，从而无法可靠地定位调用类和方法。

    Logger上的所有方法都是多线程安全的。

    子类化信息：请注意，LogManager类可以为命名空间中的任何一个点提供自己的命名记录器实现。 因此，Logger的任何子类（除非它们与新的LogManager类一起实现）应该注意从LogManager类获取Logger实例，并且应该将诸如“isLoggable”和“log（LogRecord）”等操作委派给该实例。 请注意，为了拦截所有日志输出，子类只需要覆盖日志（LogRecord）方法。 所有其他日志记录方法都被实现为对该日志（LogRecord）方法的调用。

    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Logger global
      已过时。
      此字段的初始化容易出现死锁。 该字段必须由Logger类初始化初始化，这可能会导致与LogManager类初始化的死锁。 在这种情况下，两个类初始化等待彼此完成。 获取全局记录器对象的首选方法是通过调用Logger.getGlobal() 。 为了兼容Logger.getGlobal()不可用的旧JDK版本，请使用电话Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)或Logger.getLogger("global") 。
      static String GLOBAL_LOGGER_NAME
      GLOBAL_LOGGER_NAME是全球记录器的名称。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Logger​(String name, String resourceBundleName)
      构建命名子系统的记录器的受保护方法。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addHandler​(Handler handler)
      添加日志处理程序以接收日志消息。
      void config​(String msg)
      记录CONFIG消息。
      void config​(Supplier<String> msgSupplier)
      记录一个CONFIG消息，只有在记录级别实际上记录该消息时，才能构建一个CONFIG消息。
      void entering​(String sourceClass, String sourceMethod)
      记录方法条目。
      void entering​(String sourceClass, String sourceMethod, Object param1)
      使用一个参数记录方法条目。
      void entering​(String sourceClass, String sourceMethod, Object[] params)
      使用参数数组记录方法条目。
      void exiting​(String sourceClass, String sourceMethod)
      记录方法返回。
      void exiting​(String sourceClass, String sourceMethod, Object result)
      使用结果对象记录方法返回。
      void fine​(String msg)
      记录一个FINE消息。
      void fine​(Supplier<String> msgSupplier)
      记录一个FINE消息，只有在记录级别实际上记录该消息时才会被构造。
      void finer​(String msg)
      记录一个FINER消息。
      void finer​(Supplier<String> msgSupplier)
      记录一个FINER消息，只有在记录级别实际上记录该消息时，才会构建一个FINER消息。
      void finest​(String msg)
      记录一条FINEST消息。
      void finest​(Supplier<String> msgSupplier)
      记录一个FINEST消息，只有当记录级别实际上记录消息时，才能构建FINEST消息。
      static Logger getAnonymousLogger​()
      创建一个匿名记录器。
      static Logger getAnonymousLogger​(String resourceBundleName)
      创建一个匿名记录器。
      Filter getFilter​()
      获取此Logger的当前过滤器。
      static Logger getGlobal​()
      返回名为Logger.GLOBAL_LOGGER_NAME的全局记录器对象。
      Handler[] getHandlers​()
      获取与此记录器关联的处理程序。
      Level getLevel​()
      获取为此记录器指定的日志级别。
      static Logger getLogger​(String name)
      查找或创建一个命名子系统的记录器。
      static Logger getLogger​(String name, String resourceBundleName)
      查找或创建一个命名子系统的记录器。
      String getName​()
      获取此记录器的名称。
      Logger getParent​()
      返回此记录器的父级。
      ResourceBundle getResourceBundle​()
      检索此记录器的本地化资源包。
      String getResourceBundleName​()
      检索此记录器的本地化资源包名称。
      boolean getUseParentHandlers​()
      发现这个记录器是否将其输出发送到其父记录器。
      void info​(String msg)
      记录INFO消息。
      void info​(Supplier<String> msgSupplier)
      记录INFO消息，只有在记录级别实际记录消息时，才能构建INFO消息。
      boolean isLoggable​(Level level)
      检查该记录器是否实际记录给定级别的消息。
      void log​(Level level, String msg)
      记录消息，没有参数。
      void log​(Level level, String msg, Object param1)
      使用一个对象参数记录消息。
      void log​(Level level, String msg, Object[] params)
      用一个对象参数数组记录消息。
      void log​(Level level, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息。
      void log​(Level level, Throwable thrown, Supplier<String> msgSupplier)
      记录一个懒惰构造的消息，并附带相关的Throwable信息。
      void log​(Level level, Supplier<String> msgSupplier)
      记录一条消息，只有在日志记录级别实际上记录该消息时才会被构造。
      void log​(LogRecord record)
      登录LogRecord。
      void logp​(Level level, String sourceClass, String sourceMethod, String msg)
      记录消息，指定源类和方法，没有参数。
      void logp​(Level level, String sourceClass, String sourceMethod, String msg, Object param1)
      使用单个对象参数记录消息，指定源类和方法到日志消息。
      void logp​(Level level, String sourceClass, String sourceMethod, String msg, Object[] params)
      使用对象参数数组记录消息，指定源类和方法。
      void logp​(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类和方法。
      void logp​(Level level, String sourceClass, String sourceMethod, Throwable thrown, Supplier<String> msgSupplier)
      记录一个懒惰构造的消息，指定源类和方法以及相关联的Throwable信息。
      void logp​(Level level, String sourceClass, String sourceMethod, Supplier<String> msgSupplier)
      记录一个延迟构造的消息，指定源类和方法，没有参数。
      void logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg)
      已过时。
      改用logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
      void logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1)
      已过时。
      改用logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...)
      void logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params)
      已过时。
      改用logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
      void logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown)
      已过时。
      改用logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Throwable) 。
      void logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Object... params)
      使用可选的消息参数列表记录消息，指定源类，方法和资源包。
      void logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
      void logrb​(Level level, ResourceBundle bundle, String msg, Object... params)
      使用可选的消息参数列表记录消息，指定源类，方法和资源包。
      void logrb​(Level level, ResourceBundle bundle, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
      void removeHandler​(Handler handler)
      删除日志处理程序。
      void setFilter​(Filter newFilter)
      设置一个过滤器来控制此记录器的输出。
      void setLevel​(Level newLevel)
      设置日志级别，指定该记录器将记录哪些消息级别。
      void setParent​(Logger parent)
      设置此记录器的父级。
      void setResourceBundle​(ResourceBundle bundle)
      在此记录器上设置资源包。
      void setUseParentHandlers​(boolean useParentHandlers)
      指定此记录器是否应将其输出发送到其父记录器。
      void severe​(String msg)
      记录一个SEVERE消息。
      void severe​(Supplier<String> msgSupplier)
      记录一个SEVERE消息，只有当记录级别实际上记录该消息时，才会构建一个SEVERE消息。
      void throwing​(String sourceClass, String sourceMethod, Throwable thrown)
      日志抛出异常。
      void warning​(String msg)
      记录警告消息。
      void warning​(Supplier<String> msgSupplier)
      记录一条警告消息，只有当记录级别实际上记录消息时，才能构建一条警告消息。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • GLOBAL_LOGGER_NAME

        public static final String GLOBAL_LOGGER_NAME
        GLOBAL_LOGGER_NAME是全球记录器的名称。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • global

        @Deprecated
public static final Logger global
        已过时。 此字段的初始化容易出现死锁。 该字段必须由Logger类初始化初始化，这可能会导致与LogManager类初始化的死锁。 在这种情况下，两个类初始化等待彼此完成。 获取全局记录器对象的首选方法是通过调用Logger.getGlobal() 。 为了兼容Logger.getGlobal()不可用的旧JDK版本，请使用Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)或Logger.getLogger("global") 。
        提供了“全局”Logger对象，方便那些正在使用日志记录软件包的开发人员。 正在严重使用日志记录包的开发人员（例如在产品中）应该创建并使用自己的Logger对象和适当的名称，以便可以以合适的每个Logger粒度来控制日志记录。 开发人员还需要强力引用Logger对象，以防止它们被垃圾回收。

    • 构造方法详细信息

      • Logger

        protected Logger​(String name,
                 String resourceBundleName)
        构建命名子系统的记录器的受保护方法。

        记录器最初将配置为空级别，并将useParentHandlers设置为true。

        参数
        name - 记录器的名称。 这应该是一个点分隔的名称，通常应该基于子系统的包名或类名，如java.net或javax.swing。 匿名记录器可能为空。
        resourceBundleName - 用于本地化此记录器消息的ResourceBundle的名称。 如果没有任何消息需要本地化，则可以为null。
        异常
        MissingResourceException - 如果resourceBundleName为非空，并且不能找到相应的资源。

    • 方法详细信息

      • getGlobal

        public static final Logger getGlobal​()
        返回名为Logger.GLOBAL_LOGGER_NAME的全局记录器对象。
        结果
        全局记录器对象
        从以下版本开始：
        1.7

      • getLogger

        public static Logger getLogger​(String name)
        查找或创建一个命名子系统的记录器。 如果已经使用给定名称创建了记录器，则返回它。 否则将创建一个新的记录器。

        如果创建了一个新的记录器，则它的日志级别将根据LogManager配置进行配置，并将其配置为也将记录输出发送到其父代的处理程序。 它将在LogManager全局命名空间中注册。

        注意：LogManager可能只保留对新创建的Logger的弱引用。 重要的是要明白，如果没有强有力的引用Logger，以前创建的具有给定名称的Logger可能随时被垃圾回收。 特别地，这意味着像getLogger("MyLogger").log(...)这样的两个背靠背调用可能会使用名为“MyLogger”的不同Logger对象，如果程序中其他地方没有强大的引用名为“MyLogger”的Logger。

        参数
        name - 记录器的名称。 这应该是一个点分隔的名称，通常应该基于子系统的包名或类名，如java.net或javax.swing
        结果
        一个合适的记录器
        异常
        NullPointerException - 如果名称为空。

      • getLogger

        public static Logger getLogger​(String name,
                               String resourceBundleName)
        查找或创建一个命名子系统的记录器。 如果已经使用给定名称创建了记录器，则返回它。 否则将创建一个新的记录器。

        如果创建了一个新的记录器，它将根据LogManager配置其日志级别，并将其配置为也将记录输出发送到其父代的处理程序。 它将在LogManager全局命名空间中注册。

        注意：LogManager可能只保留对新创建的Logger的弱引用。 重要的是要明白，如果没有强有力的引用Logger，以前创建的具有给定名称的Logger可能随时被垃圾回收。 特别地，这意味着像getLogger("MyLogger", ...).log(...)这样的两个背靠背调用可能会使用名为“MyLogger”的不同Logger对象，如果程序中其他地方没有强大的引用名为“MyLogger”的Logger。

        如果命名的Logger已经存在并且还没有本地化资源包，那么将使用给定的资源包名称。 如果命名的Logger已经存在且具有不同的资源包名称，则会抛出IllegalArgumentException。

        参数
        name - 记录器的名称。 这应该是一个点分隔的名称，通常应该基于子系统的包名或类名，如java.net或javax.swing
        resourceBundleName - 用于本地化此记录器消息的ResourceBundle的名称。 如果没有任何消息需要本地化，可能是null 。
        结果
        一个合适的记录器
        异常
        MissingResourceException - 如果resourceBundleName为非空，并且不能找到相应的资源。
        IllegalArgumentException - 如果记录器已存在并使用不同的资源包名称; 或者如果resourceBundleName是null但命名的记录器具有一个资源束集合。
        NullPointerException - 如果名称为空。

      • getAnonymousLogger

        public static Logger getAnonymousLogger​()
        创建一个匿名记录器。 新创建的Logger未在LogManager命名空间中注册。 对记录器的更新将不会进行访问检查。

        这种工厂方法主要用于从小程序中使用。 因为生成的Logger是匿名的，所以它可以被创建类保留为私有。 这消除了对正常安全检查的需要，这进而允许不可信的小程序代码更新记录器的控制状态。 例如，applet可以在匿名记录器上执行setLevel或addHandler。

        即使新的记录器是匿名的，它被配置为使用根记录器（“”）作为其父记录器。 这意味着默认情况下，它会从根记录器继承其有效的级别和处理程序。 通过setParent方法更改其父项仍将需要该方法指定的安全权限。

        结果
        一个新创建的私有Logger

      • getAnonymousLogger

        public static Logger getAnonymousLogger​(String resourceBundleName)
        创建一个匿名记录器。 新创建的Logger未在LogManager命名空间中注册。 对记录器的更新将不会进行访问检查。

        这种工厂方法主要用于从小程序中使用。 因为生成的Logger是匿名的，所以它可以被创建类保留为私有。 这消除了对正常安全检查的需要，这进而允许不可信的小程序代码更新记录器的控制状态。 例如，applet可以在匿名记录器上执行setLevel或addHandler。

        即使新的记录器是匿名的，它被配置为使用根记录器（“”）作为其父记录器。 这意味着默认情况下，它会从根记录器继承其有效的级别和处理程序。 通过setParent方法更改其父项仍将需要该方法指定的安全权限。

        参数
        resourceBundleName - 用于本地化此记录器消息的ResourceBundle的名称。 如果没有任何消息需要本地化，则可以为null。
        结果
        一个新创建的私有Logger
        异常
        MissingResourceException - 如果resourceBundleName为非空，并且不能找到相应的资源。

      • getResourceBundle

        public ResourceBundle getResourceBundle​()
        检索此记录器的本地化资源包。 该方法将返回一个ResourceBundle这样做，要么通过设置setResourceBundle方法或mapped from the the resource bundle name组通过getLogger当前默认语言环境的工厂方法。
        请注意，如果结果为null ，则Logger将使用从其父级继承的资源包或资源包名称。
        结果
        本地化捆绑（可能是 null ）

      • getResourceBundleName

        public String getResourceBundleName​()
        检索此记录器的本地化资源包名称。 这是既可以通过指定的名称getLogger工厂方法，或base name的ResourceBundle的设定通过setResourceBundle方法。
        请注意，如果结果为null ，则记录器将使用从其父级继承的资源束或资源束名称。
        结果
        本地化组名称（可能为 null ）

      • setFilter

        public void setFilter​(Filter newFilter)
               throws SecurityException
        设置一个过滤器来控制此记录器的输出。

        通过初始“级别”检查后，记录器将调用此过滤器来检查是否应该发布日志记录。

        参数
        newFilter - 过滤器对象（可以为空）
        异常
        SecurityException - 如果安全管理器存在，则该记录器不是匿名的，并且调用者没有LoggingPermission（“control”）。

      • getFilter

        public Filter getFilter​()
        获取此Logger的当前过滤器。
        结果
        过滤器对象（可以为空）

      • log

        public void log​(LogRecord record)
        登录LogRecord。

        该类中的所有其他日志记录方法通过此方法调用以实际执行任何日志记录。 子类可以覆盖此单一方法来捕获所有日志活动。

        参数
        record - 要发布的LogRecord

      • log

        public void log​(Level level,
                String msg)
        记录消息，没有参数。

        如果当前对于给定的消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        参数
        level - 消息级标识符之一，例如SEVERE
        msg - 字符串消息（或消息目录中的键）

      • log

        public void log​(Level level,
                Supplier<String> msgSupplier)
        记录一条消息，只有在日志记录级别实际上记录该消息时才会被构造。

        如果当前对于给定消息级别启用了记录器，则通过调用提供的供应商功能并将其转发到所有注册的输出处理程序对象来构建消息。

        参数
        level - 其中一个消息级标识符，例如SEVERE
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • log

        public void log​(Level level,
                String msg,
                Object param1)
        使用一个对象参数记录消息。

        如果当前为给定消息级别启用了记录器，则会创建一个相应的LogRecord并转发给所有注册的输出处理程序对象。

        参数
        level - 消息级标识符之一，例如SEVERE
        msg - 字符串消息（或消息目录中的键）
        param1 - 消息的参数

      • log

        public void log​(Level level,
                String msg,
                Object[] params)
        用一个对象参数数组记录消息。

        如果当前为给定消息级别启用了记录器，则会创建一个相应的LogRecord并转发给所有注册的输出处理程序对象。

        参数
        level - 消息级标识符之一，例如SEVERE
        msg - 字符串消息（或消息目录中的键）
        params - 消息的参数数组

      • log

        public void log​(Level level,
                String msg,
                Throwable thrown)
        使用相关联的Throwable信息记录消息。

        如果当前为给定消息级别启用了记录器，则给定的参数将存储在LogRecord中，该LogRecord将转发给所有注册的输出处理程序。

        请注意，抛出的参数存储在LogRecord throwwn属性中，而不是LogRecord参数属性。 因此，它由输出格式化程序特别处理，不被视为LogRecord消息属性的格式参数。

        参数
        level - 其中一个消息级标识符，例如SEVERE
        msg - 字符串消息（或消息目录中的键）
        thrown - 与日志消息相关联的Throwable。

      • log

        public void log​(Level level,
                Throwable thrown,
                Supplier<String> msgSupplier)
        记录一个懒惰构造的消息，并附带相关的Throwable信息。

        如果当前对于给定消息级别启用了记录器，则通过调用提供的供应商功能来构建消息。 然后将消息和给定的Throwable存储在LogRecord中 ，该LogRecord转发给所有注册的输出处理程序。

        请注意，抛出的参数存储在LogRecord throwwn属性中，而不是LogRecord参数属性。 因此，它由输出格式化程序特别处理，不被视为LogRecord消息属性的格式参数。

        参数
        level - 其中一个消息级标识符，例如SEVERE
        thrown - 与日志消息相关联的Throwable。
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • logp

        public void logp​(Level level,
                 String sourceClass,
                 String sourceMethod,
                 String msg)
        记录消息，指定源类和方法，没有参数。

        如果当前对于给定的消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        参数
        level - 其中一个消息级标识符，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        msg - 字符串消息（或消息目录中的键）

      • logp

        public void logp​(Level level,
                 String sourceClass,
                 String sourceMethod,
                 Supplier<String> msgSupplier)
        记录一个延迟构造的消息，指定源类和方法，没有参数。

        如果当前对于给定消息级别启用了记录器，则通过调用提供的供应商功能并将其转发到所有注册的输出处理程序对象来构建消息。

        参数
        level - 其中一个消息级标识符，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • logp

        public void logp​(Level level,
                 String sourceClass,
                 String sourceMethod,
                 String msg,
                 Object param1)
        使用单个对象参数记录消息，指定源类和方法到日志消息。

        如果当前为给定消息级别启用了记录器，则会创建一个相应的LogRecord并转发给所有注册的输出处理程序对象。

        参数
        level - 消息级标识符之一，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        msg - 字符串消息（或消息目录中的键）
        param1 - 日志消息的参数。

      • logp

        public void logp​(Level level,
                 String sourceClass,
                 String sourceMethod,
                 String msg,
                 Object[] params)
        使用对象参数数组记录消息，指定源类和方法。

        如果当前为给定消息级别启用了记录器，则会创建一个相应的LogRecord并转发给所有注册的输出处理程序对象。

        参数
        level - 消息级标识符之一，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        msg - 字符串消息（或消息目录中的键）
        params - 消息的参数数组

      • logp

        public void logp​(Level level,
                 String sourceClass,
                 String sourceMethod,
                 String msg,
                 Throwable thrown)
        使用相关联的Throwable信息记录消息，指定源类和方法。

        如果当前为给定消息级别启用了记录器，则给定的参数将存储在LogRecord中，该LogRecord将转发给所有注册的输出处理程序。

        请注意，抛出的参数存储在LogRecord throwwn属性中，而不是LogRecord参数属性。 因此，它由输出格式化程序特别处理，不被视为LogRecord消息属性的格式参数。

        参数
        level - 其中一个消息级标识符，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        msg - 字符串消息（或消息目录中的一个键）
        thrown - 与日志消息相关联的Throwable。

      • logp

        public void logp​(Level level,
                 String sourceClass,
                 String sourceMethod,
                 Throwable thrown,
                 Supplier<String> msgSupplier)
        记录一个懒惰构造的消息，指定源类和方法以及相关联的Throwable信息。

        如果当前对于给定消息级别启用了记录器，则通过调用提供的供应商功能来构建消息。 然后将消息和给定的Throwable存储在LogRecord中 ，该LogRecord转发给所有注册的输出处理程序。

        请注意，抛出的参数存储在LogRecord throwwn属性中，而不是LogRecord参数属性。 因此，它由输出格式化程序特别处理，不被视为LogRecord消息属性的格式参数。

        参数
        level - 其中一个消息级标识符，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        thrown - 与日志消息相关联的Throwable。
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • logrb

        @Deprecated
public void logrb​(Level level,
                  String sourceClass,
                  String sourceMethod,
                  String bundleName,
                  String msg)
        已过时。 改用logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
        记录消息，指定没有参数的源类，方法和资源包名称。

        如果当前对于给定的消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        msg字符串使用命名的资源包进行本地化。 如果资源包名称为空，或空字符串或无效，则msg字符串未本地化。

        参数
        level - 消息级标识符之一，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        bundleName - 本地化msg的资源束的名称可以为null
        msg - 字符串消息（或消息目录中的键）

      • logrb

        @Deprecated
public void logrb​(Level level,
                  String sourceClass,
                  String sourceMethod,
                  String bundleName,
                  String msg,
                  Object param1)
        已过时。 改用logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...)
        使用单个对象参数记录消息，指定源类，方法和资源包名称。

        如果当前为给定消息级别启用了记录器，则会创建一个相应的LogRecord并转发给所有注册的输出处理程序对象。

        msg字符串使用命名的资源包进行本地化。 如果资源包名称为空，或空字符串或无效，则msg字符串未本地化。

        参数
        level - 其中一个消息级标识符，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        bundleName - 本地化msg的资源束的名称可以为null
        msg - 字符串消息（或消息目录中的键）
        param1 - 日志消息的参数。

      • logrb

        @Deprecated
public void logrb​(Level level,
                  String sourceClass,
                  String sourceMethod,
                  String bundleName,
                  String msg,
                  Object[] params)
        已过时。 改用logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
        使用对象参数数组记录消息，指定源类，方法和资源包名称。

        如果当前为给定消息级别启用了记录器，则会创建一个相应的LogRecord并转发给所有注册的输出处理程序对象。

        msg字符串使用命名的资源包进行本地化。 如果资源包名称为空，或空字符串或无效，则msg字符串未本地化。

        参数
        level - 其中一个消息级标识符，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        bundleName - 本地化msg的资源束的名称可以为null。
        msg - 字符串消息（或消息目录中的键）
        params - 消息的参数数组

      • logrb

        public void logrb​(Level level,
                  String sourceClass,
                  String sourceMethod,
                  ResourceBundle bundle,
                  String msg,
                  Object... params)
        使用可选的消息参数列表记录消息，指定源类，方法和资源包。

        如果对于给定消息level当前启用了记录器，则创建对应的LogRecord并转发给所有注册的输出Handler对象。

        msg字符串使用给定的资源束进行本地化。 如果资源束为null ，则msg字符串未本地化。

        参数
        level - 其中一个消息级标识符，例如 SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        bundle - 资源束定位 msg ，可以是 null 。
        msg - 字符串消息（或消息目录中的键）
        params - 消息的参数（可选，可能不是）。
        从以下版本开始：
        1.8

      • logrb

        public void logrb​(Level level,
                  ResourceBundle bundle,
                  String msg,
                  Object... params)
        使用可选的消息参数列表记录消息，指定源类，方法和资源包。

        如果对于给定消息level当前启用了记录器，则创建对应的LogRecord并转发给所有注册的输出Handler对象。

        msg字符串使用给定的资源包进行本地化。 如果资源束是null ，则msg字符串未被本地化。

        参数
        level - 消息级别标识之一，例如 SEVERE
        bundle - 本地化资源包msg ; 可以是null 。
        msg - 字符串消息（或消息目录中的键）
        params - 消息的参数（可选，可能不是）。
        从以下版本开始：
        9

      • logrb

        @Deprecated
public void logrb​(Level level,
                  String sourceClass,
                  String sourceMethod,
                  String bundleName,
                  String msg,
                  Throwable thrown)
        已过时。 改用logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Throwable) 。
        使用相关联的Throwable信息记录消息，指定源类，方法和资源包名称。

        如果当前为给定消息级别启用了记录器，则给定的参数将存储在LogRecord中，该LogRecord将转发给所有注册的输出处理程序。

        msg字符串使用命名的资源包进行本地化。 如果资源包名称为空，或空字符串或无效，则msg字符串未本地化。

        请注意，抛出的参数存储在LogRecord throwwn属性中，而不是LogRecord参数属性。 因此，它由输出格式化程序特别处理，不被视为LogRecord消息属性的格式参数。

        参数
        level - 消息级标识符之一，例如SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        bundleName - 本地化msg的资源束的名称，可以为null
        msg - 字符串消息（或消息目录中的键）
        thrown - 与日志消息相关联的Throwable。

      • logrb

        public void logrb​(Level level,
                  String sourceClass,
                  String sourceMethod,
                  ResourceBundle bundle,
                  String msg,
                  Throwable thrown)
        使用相关联的Throwable信息记录消息，指定源类，方法和资源包。

        如果当前对于给定消息level启用了记录器，则给定的参数存储在LogRecord ，转发给所有注册的输出处理程序。

        msg字符串使用给定的资源包进行本地化。 如果资源束为null ，则msg字符串未本地化。

        请注意， thrown参数是存储在LogRecord thrown属性，而不是LogRecord parameters属性。 因此，它由输出Formatter对象特别处理，并不被视为LogRecord message属性的格式参数。

        参数
        level - 消息级别标识之一，例如 SEVERE
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 发出日志记录请求的方法的名称
        bundle - 本地化的资源包 msg ，可以是 null
        msg - 字符串消息（或消息目录中的键）
        thrown - 与日志消息相关联的Throwable。
        从以下版本开始：
        1.8

      • logrb

        public void logrb​(Level level,
                  ResourceBundle bundle,
                  String msg,
                  Throwable thrown)
        使用相关联的Throwable信息记录消息，指定源类，方法和资源包。

        如果当前对于给定消息level启用了记录器，则给定的参数将存储在LogRecord ，该参数转发给所有注册的输出处理程序。

        msg字符串使用给定的资源包进行本地化。 如果资源束为null ，则msg字符串未本地化。

        请注意， thrown参数是存储在LogRecord thrown属性，而不是LogRecord parameters属性。 因此，它通过输出Formatter对象进行特殊处理，并不被视为LogRecord message属性的格式参数。

        参数
        level - 消息级别标识之一，例如 SEVERE
        bundle - 本地化的资源束msg ; 可以是null 。
        msg - 字符串消息（或消息目录中的键）
        thrown - 与日志消息相关联的Throwable。
        从以下版本开始：
        9

      • entering

        public void entering​(String sourceClass,
                     String sourceMethod)
        记录方法条目。

        这是一种方便的方法，可用于将条目记录到方法中。 具有消息“ENTRY”的LogRecord，日志级别FINER，并且记录给定的sourceMethod和sourceClass。

        参数
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 正在输入的方法的名称

      • entering

        public void entering​(String sourceClass,
                     String sourceMethod,
                     Object param1)
        使用一个参数记录方法条目。

        这是一种方便的方法，可用于将条目记录到方法中。 具有消息“ENTRY {0}”的LogRecord，日志级别FINER，并且记录给定的sourceMethod，sourceClass和参数。

        参数
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 正在输入的方法的名称
        param1 - 输入方法的参数

      • entering

        public void entering​(String sourceClass,
                     String sourceMethod,
                     Object[] params)
        使用参数数组记录方法条目。

        这是一种方便的方法，可用于将条目记录到方法中。 具有消息“ENTRY”（后跟参数数组中每个条目的格式{N}指示符）的LogRecord，记录级别FINER，并记录给定的sourceMethod，sourceClass和参数。

        参数
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 正在输入的方法的名称
        params - 要输入的方法的参数数组

      • exiting

        public void exiting​(String sourceClass,
                    String sourceMethod)
        记录方法返回。

        这是一种方便的方法，可用于记录从方法返回的日志。 具有消息“RETURN”的LogRecord，日志级别FINER以及给定的sourceMethod和sourceClass被记录。

        参数
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 方法的名称

      • exiting

        public void exiting​(String sourceClass,
                    String sourceMethod,
                    Object result)
        使用结果对象记录方法返回。

        这是一种方便的方法，可用于记录从方法返回的日志。 具有消息“RETURN {0}”的LogRecord，日志级别FINER，并记录给出sourceMethod，sourceClass和result对象。

        参数
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 方法的名称
        result - 正在返回的对象

      • throwing

        public void throwing​(String sourceClass,
                     String sourceMethod,
                     Throwable thrown)
        日志抛出异常。

        这是一种方便的方法来记录一个方法正在通过抛出异常来终止。 使用FINER级别进行日志记录。

        如果当前为给定消息级别启用了记录器，则给定的参数将存储在LogRecord中，该LogRecord将转发给所有注册的输出处理程序。 LogRecord的消息设置为“THROW”。

        请注意，抛出的参数存储在LogRecord throwwn属性中，而不是LogRecord参数属性。 因此，它由输出格式化程序特别处理，不被视为LogRecord消息属性的格式参数。

        参数
        sourceClass - 发出日志记录请求的类的名称
        sourceMethod - 方法的名称。
        thrown - 被抛出的Throwable。

      • severe

        public void severe​(String msg)
        记录一个SEVERE消息。

        如果当前为SEVERE消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        参数
        msg - 字符串消息（或消息目录中的键）

      • warning

        public void warning​(String msg)
        记录警告消息。

        如果当前为“警告”消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        参数
        msg - 字符串消息（或消息目录中的键）

      • info

        public void info​(String msg)
        记录INFO消息。

        如果当前为INFO消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        参数
        msg - 字符串消息（或消息目录中的键）

      • config

        public void config​(String msg)
        记录CONFIG消息。

        如果当前为CONFIG消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        参数
        msg - 字符串消息（或消息目录中的键）

      • fine

        public void fine​(String msg)
        记录一个FINE消息。

        如果当前为FINE消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        参数
        msg - 字符串消息（或消息目录中的键）

      • finer

        public void finer​(String msg)
        记录一个FINER消息。

        如果当前为FINER消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        参数
        msg - 字符串消息（或消息目录中的键）

      • finest

        public void finest​(String msg)
        记录一条FINEST消息。

        如果当前为FINEST消息级别启用了记录器，则给定的消息将转发给所有注册的输出处理程序对象。

        参数
        msg - 字符串消息（或消息目录中的键）

      • severe

        public void severe​(Supplier<String> msgSupplier)
        记录一个SEVERE消息，只有当记录级别实际上记录该消息时，才会构建一个SEVERE消息。

        如果当前为SEVERE消息级别启用了记录器，则通过调用提供的供应商功能并转发给所有注册的输出处理程序对象来构建消息。

        参数
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • warning

        public void warning​(Supplier<String> msgSupplier)
        记录一条警告消息，只有当记录级别实际上记录消息时，才能构建一条警告消息。

        如果当前为“警告”消息级别启用了记录器，则通过调用提供的供应商功能并转发到所有注册的输出处理程序对象来构建消息。

        参数
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • info

        public void info​(Supplier<String> msgSupplier)
        记录INFO消息，只有在记录级别实际记录消息时，才能构建INFO消息。

        如果当前为INFO消息级别启用了记录器，则通过调用提供的供应商功能并将其转发到所有注册的输出处理程序对象来构建消息。

        参数
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • config

        public void config​(Supplier<String> msgSupplier)
        记录一个CONFIG消息，只有在记录级别实际上记录该消息时，才能构建一个CONFIG消息。

        如果目前为CONFIG消息级别启用了记录器，则通过调用提供的供应商功能并转发给所有注册的输出处理程序对象来构建消息。

        参数
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • fine

        public void fine​(Supplier<String> msgSupplier)
        记录一个FINE消息，只有在记录级别实际上记录该消息时才会被构造。

        如果当前为FINE消息级别启用了记录器，则通过调用提供的供应商功能并将其转发到所有注册的输出处理程序对象来构建消息。

        参数
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • finer

        public void finer​(Supplier<String> msgSupplier)
        记录一个FINER消息，只有在记录级别实际上记录该消息时，才会构建一个FINER消息。

        如果当前为FINER消息级别启用了记录器，则通过调用提供的供应商功能并将其转发到所有注册的输出处理程序对象来构建消息。

        参数
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • finest

        public void finest​(Supplier<String> msgSupplier)
        记录一个FINEST消息，只有当记录级别实际上记录消息时，才能构建FINEST消息。

        如果当前为FINEST消息级别启用了记录器，则通过调用提供的供应商函数并转发给所有注册的输出处理程序对象来构建消息。

        参数
        msgSupplier - 一个函数，当被调用时，产生所需的日志消息
        从以下版本开始：
        1.8

      • setLevel

        public void setLevel​(Level newLevel)
              throws SecurityException
        设置日志级别，指定该记录器将记录哪些消息级别。 消息级别低于此值将被丢弃。 级别值Level.OFF可用于关闭日志记录。

        如果新级别为空，则表示该节点应从具有（非空）级别值的最近祖先继承其级别。

        参数
        newLevel - 日志级别的新值（可能为空）
        异常
        SecurityException - 如果存在安全管理员，则该记录器不是匿名的，并且调用者没有LoggingPermission（“control”）。

      • getLevel

        public Level getLevel​()
        获取为此记录器指定的日志级别。 结果可能为null，这意味着该记录器的有效级别将从其父级继承。
        结果
        这个记录器的级别

      • isLoggable

        public boolean isLoggable​(Level level)
        检查该记录器是否实际记录给定级别的消息。 此检查基于Loggers有效级别，可以从其父级继承。
        参数
        level - 消息记录级别
        结果
        如果给定的消息级别正在被记录，则为true。

      • getName

        public String getName​()
        获取此记录器的名称。
        结果
        记录器名称 匿名记录器将为空。

      • addHandler

        public void addHandler​(Handler handler)
                throws SecurityException
        添加日志处理程序以接收日志消息。

        默认情况下，记录器还将其输出发送到其父记录器。 通常，根记录器配置有一组基本上充当所有记录器的默认处理程序的处理程序。

        参数
        handler - 一个记录处理程序
        异常
        SecurityException - 如果存在安全管理员，则该记录器不是匿名的，并且调用者没有LoggingPermission（“control”）。

      • removeHandler

        public void removeHandler​(Handler handler)
                   throws SecurityException
        删除日志处理程序。

        如果找不到给定的处理程序，则返回静默方式，否则返回null

        参数
        handler - 一个记录处理程序
        异常
        SecurityException - 如果存在安全管理员，则该记录器不是匿名的，并且调用者没有LoggingPermission（“control”）。

      • getHandlers

        public Handler[] getHandlers​()
        获取与此记录器关联的处理程序。
        结果
        所有注册的处理程序的数组

      • setUseParentHandlers

        public void setUseParentHandlers​(boolean useParentHandlers)
        指定此记录器是否应将其输出发送到其父记录器。 这意味着任何LogRecords也将被写入到父进程的处理程序中，并且可能会向其父进程递归地命名命名空间。
        参数
        useParentHandlers - 如果输出要发送到记录器的父级， useParentHandlers true。
        异常
        SecurityException - 如果安全管理器存在，则此记录器不是匿名的，并且调用者没有LoggingPermission（“control”）。

      • getUseParentHandlers

        public boolean getUseParentHandlers​()
        发现这个记录器是否将其输出发送到其父记录器。
        结果
        如果输出要发送到记录器的父级，则为true

      • setResourceBundle

        public void setResourceBundle​(ResourceBundle bundle)
        在此记录器上设置资源包。 将使用给定的资源束针对其特定的locale记录所有消息。
        参数
        bundle - 此记录器将使用的资源包。
        异常
        NullPointerException - 如果给定的包是 null 。
        IllegalArgumentException - 如果给定的包不具有 base name ，或者如果此记录器已经具有资源束集，但给定的包具有不同的基本名称。
        SecurityException - 如果存在安全管理员，该记录器不是匿名的，并且调用者没有LoggingPermission（“control”）。
        从以下版本开始：
        1.8

      • getParent

        public Logger getParent​()
        返回此记录器的父级。

        此方法返回命名空间中最近的父实体。 因此，如果Logger被称为“abcd”，并且已经创建了一个名为“ab”的记录器，但没有记录器“abc”，则记录器“abcd”上的调用getParent将返回记录器“ab”。

        如果在命名空间中的根记录器上调用，结果将为null。

        结果
        最近现有的父记录器

      • setParent

        public void setParent​(Logger parent)
        设置此记录器的父级。 LogManager在命名空间更改时更新Logger时使用此方法。

        不应该从应用程序代码中调用。

        参数
        parent - 新的父记录器
        异常
        SecurityException - 如果安全管理器存在，并且调用方没有LoggingPermission（“控制”）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


LoggingMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Interface LoggingMXBean

  • 已过时。
    LoggingMXBean不再是platform MXBean ，而是用PlatformLoggingMXBean替代。 它不会在平台上注册MBeanServer 。 改用ManagementFactory.getPlatformMXBean(PlatformLoggingMXBean.class) 。

    @Deprecated(since="9")
public interface LoggingMXBean
    记录设备的管理界面。 java.lang.management.PlatformLoggingMXBean是在platform MBeanServer注册的记录设施的管理界面。 它建议使用了PlatformLoggingMXBean经由得到ManagementFactory.getPlatformMXBean(PlatformLoggingMXBean.class)方法。
    从以下版本开始：
    1.5
    另请参见：
    PlatformLoggingMXBean

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      String getLoggerLevel​(String loggerName)
      已过时。
      获取与指定记录器关联的日志级别的名称。
      List<String> getLoggerNames​()
      已过时。
      返回当前注册的记录器名称的列表。
      String getParentLoggerName​(String loggerName)
      已过时。
      返回指定记录器的父级名称。
      void setLoggerLevel​(String loggerName, String levelName)
      已过时。
      将指定的记录器设置为指定的新级别。

    • 方法详细信息

      • getLoggerNames

        List<String> getLoggerNames​()
        已过时。
        返回当前注册的记录器名称的列表。 此方法调用LogManager.getLoggerNames()并返回一个记录器名称列表。
        结果
        一份 String的名单，目前已注册 Logger 。

      • getLoggerLevel

        String getLoggerLevel​(String loggerName)
        已过时。
        获取与指定记录器关联的日志级别的名称。 如果指定的记录器不存在，则返回null 。 此方法首先找到给定名称的记录器，然后通过调用以下命令返回日志级别的名称：
        Logger.getLevel(). getName();

        如果Level指定logger是null ，这意味着此logger的有效级别从其父继承，一个空字符串将被退回。

        参数
        loggerName - 要检索的 Logger的名称。
        结果
        指定记录器的日志级别的名称; 如果指定的记录器的日志级别为null空字符串。 如果指定的记录器不存在，则返回null 。
        另请参见：
        Logger.getLevel()

      • setLoggerLevel

        void setLoggerLevel​(String loggerName,
                    String levelName)
        已过时。
        将指定的记录器设置为指定的新级别。 如果levelName不是null ，则指定记录器的级别设置为Level匹配levelName 。 如果levelName为null ，则指定记录器的级别设置为null并且记录器的有效级别从具有（非空）级别值的最近祖先继承。
        参数
        loggerName - 要设置的Logger的名称。 必须非空。
        levelName - 在指定记录器上设置的级别的名称，如果设置级别从其最近的祖先继承， null 。
        异常
        IllegalArgumentException - 如果指定的记录器不存在，或者 levelName不是有效的级别名称。
        SecurityException - 如果安全管理器存在，并且调用者没有LoggingPermission（“控制”）。
        另请参见：
        Logger.setLevel(java.util.logging.Level)

      • getParentLoggerName

        String getParentLoggerName​(String loggerName)
        已过时。
        返回指定记录器的父级名称。 如果指定的记录器不存在，则返回null 。 如果指定的记录器是命名空间中的根Logger ，则结果将为空字符串。
        参数
        loggerName - 一个 Logger的名字。
        结果
        最近的现有父记录器的名称; 一个空字符串，如果指定的记录器是根记录器。 如果指定的记录器不存在，则返回null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LoggingPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class LoggingPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.util.logging.LoggingPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class LoggingPermission
extends BasicPermission
    当SecurityManager运行的代码调用其中一个日志控件方法（如Logger.setLevel）时，SecurityManager将检查该权限。

    目前只有一个名为LoggingPermission。 这是“控制”，它允许控制日志记录配置的能力，例如添加或删除处理程序，添加或删除过滤器或更改日志记录级别。

    程序员通常不会直接创建LoggingPermission对象。 相反，它们是基于阅读安全策略文件的安全策略代码创建的。

    从以下版本开始：
    1.4
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LoggingPermission​(String name, String actions)
      创建一个新的LoggingPermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • LoggingPermission

        public LoggingPermission​(String name,
                         String actions)
                  throws IllegalArgumentException
        创建一个新的LoggingPermission对象。
        参数
        name - 权限名称。 必须是“控制”。
        actions - 必须为null或空字符串。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空或参数无效。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LogManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class LogManager

  • java.lang.Object
    • java.util.logging.LogManager

  • public class LogManager
extends Object
    有一个全局LogManager对象用于维护关于日志记录器和日志服务的一组共享状态。

    这个LogManager对象：

    • 管理Logger对象的分层命名空间。 所有命名的记录器都存储在此命名空间中。
    • 管理一组日志控制属性。 这些是简单的键值对，可以由处理程序和其他日志记录对象来配置自己。

    可以使用LogManager.getLogManager（）检索全局LogManager对象。 LogManager对象在类初始化期间创建，不能随后更改。

    在启动时，使用java.util.logging.manager系统属性定位LogManager类。

    LogManager配置

    LogManager初始化期间，LogManager通过readConfiguration()方法初始化日志记录配置。 缺省情况下，使用LogManager缺省配置。 LogManager读取的日志记录配置必须是properties file格式。

    LogManager定义了两个可选的系统属性，允许对初始配置进行控制，如readConfiguration()中所述：

    • “java.util.logging.config.class”
    • “java.util.logging.config.file”

    这两个系统属性可以在命令行中指定到“java”命令，或者作为传递给JNI_CreateJavaVM的系统属性定义。

    用于记录器和处理程序的properties将具有以处理程序或记录器的点分隔名称开头的名称。
    全局日志记录属性可能包括：

    • 一个财产“处理者”。 这定义了一个空格或逗号分隔的类名列表，用于处理程序类，以加载和注册为根记录器（名为“”的记录器）上的处理程序。 每个类名必须是具有默认构造函数的Handler类。 请注意，这些处理程序可能会在第一次使用时被懒惰地创建。
    • 属性“<logger> .handlers”。 这定义了处理程序类的空格或逗号分隔的类名列表，以加载和注册为指定的记录器的处理程序。 每个类名必须是具有默认构造函数的Handler类。 请注意，这些处理程序可能会在第一次使用时被懒惰地创建。
    • 属性“<logger> .handlers.ensureCloseOnReset”。 这定义了一个布尔值。 如果“<logger> .handlers”未定义或为空，则此属性将被忽略。 否则默认为true 。 当值为true ，与记录器关联的处理程序保证在reset()关闭并关闭。 这可以通过在配置中显式设置“<logger> .handlers.ensureCloseOnReset = false”来关闭。 请注意，关闭此属性会导致引入资源泄漏的风险，因为记录器可能会在reset()被调用之前收集垃圾，从而防止其处理程序关闭reset() 。 在这种情况下，应用程序有责任确保处理程序在记录器被垃圾回收之前关闭。
    • 属性“<logger> .useParentHandlers”。 这定义了一个布尔值。 默认情况下，每个记录器除了处理日志消息本身之外都调用其父进程，这通常导致消息由根记录器处理。 将此属性设置为false时，需要为此记录器配置处理程序，否则不会传送日志记录消息。
    • 属性“config”。 此属性旨在允许运行任意配置代码。 该属性定义了一个空格或逗号分隔的类名列表。 将为每个已命名的类创建一个新的实例。 每个类的默认构造函数可以执行任意代码来更新日志记录配置，例如设置记录器级别，添加处理程序，添加过滤器等。

    请注意，在任何用户类路径之前，首先在系统类路径上搜索LogManager配置期间加载的所有类。 这包括LogManager类，任何配置类和任何处理程序类。

    记录器根据它们的点分隔名称组织成命名层次结构。 因此，“abc”是“ab”的孩子，但是“a.b1”和a.b2“是对等体。

    名称以“.level”结尾的所有属性都假定为Loggers定义日志级别。 因此，“foo.level”定义了名为“foo”的记录器的日志级别，并且（递归地）为命名层次结构中的任何子节点定义了日志级别。 日志级别按照它们在属性文件中定义的顺序应用。 因此，树中的子节点的级别设置应该来自其父母的设置。 属性名称“.level”可用于设置树根的级别。

    LogManager对象上的所有方法都是多线程安全的。

    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String LOGGING_MXBEAN_NAME
      ObjectName用于日志记录工具的管理界面的字符串表示。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected LogManager​()
      受保护的构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      LogManager addConfigurationListener​(Runnable listener)
      添加每次读取日志配置时调用的配置监听器。
      boolean addLogger​(Logger logger)
      添加一个命名记录器。
      void checkAccess​()
      检查当前上下文是否受信任以修改日志记录配置。
      Logger getLogger​(String name)
      找到一个命名记录器的方法。
      Enumeration<String> getLoggerNames​()
      获取已知记录器名称的枚举。
      static LoggingMXBean getLoggingMXBean​()
      已过时。
      java.util.logging.LoggingMXBean已被弃用，替换为java.lang.management.PlatformLoggingMXBean 。 改用ManagementFactory.getPlatformMXBean （PlatformLoggingMXBean.class）。
      static LogManager getLogManager​()
      返回全局LogManager对象。
      String getProperty​(String name)
      获取日志记录属性的值。
      void readConfiguration​()
      读取并初始化日志记录配置。
      void readConfiguration​(InputStream ins)
      从给定的输入流读取和初始化日志记录配置。
      void removeConfigurationListener​(Runnable listener)
      删除以前注册的配置监听器。
      void reset​()
      重置日志配置。
      void updateConfiguration​(InputStream ins, Function<String,BiFunction<String,String,String>> mapper)
      更新日志记录配置。
      void updateConfiguration​(Function<String,BiFunction<String,String,String>> mapper)
      更新日志记录配置。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • LOGGING_MXBEAN_NAME

        public static final String LOGGING_MXBEAN_NAME
        ObjectName用于日志记录工具的管理界面的字符串表示。
        从以下版本开始：
        1.5
        另请参见：
        PlatformLoggingMXBean ， Constant Field Values

    • 构造方法详细信息

      • LogManager

        protected LogManager​()
        受保护的构造函数。 这是受保护的，因此容器应用程序（如J2EE容器）可以对象进行子类化。 它是非公开的，因为只有一个LogManager对象，其值通过调用LogManager.getLogManager来检索。

    • 方法详细信息

      • getLogManager

        public static LogManager getLogManager​()
        返回全局LogManager对象。
        结果
        全局LogManager对象

      • addLogger

        public boolean addLogger​(Logger logger)
        添加一个命名记录器。 如果已经注册了具有相同名称的记录器，则此操作不会返回false。

        记录器工厂方法调用此方法来注册每个新创建的记录器。

        应用程序应该保留自己对Logger对象的引用，以避免它被垃圾回收。 LogManager可能只保留弱引用。

        参数
        logger - 新的记录器。
        结果
        如果参数记录器已成功注册，则为true，如果该名称的记录器已存在则为false。
        异常
        NullPointerException - 如果记录器名称为空。

      • getLogger

        public Logger getLogger​(String name)
        找到一个命名记录器的方法。

        请注意，由于不可信代码可能会创建具有任意名称的日志记录器，因此不应依赖此方法来查找日志记录器以进行安全敏感日志记录。 同样重要的是注意，如果没有强大的引用记录器，与字符串name相关联的记录器可能随时被垃圾回收。 该方法的调用者必须检查null的返回值才能正确处理Logger已被垃圾回收的情况。

        参数
        name - 记录器的名称
        结果
        匹配记录器，如果没有找到，则返回null

      • getLoggerNames

        public Enumeration<String> getLoggerNames​()
        获取已知记录器名称的枚举。

        注意：加载新类时，可以动态添加记录器。 此方法仅报告当前注册的记录器。 同样重要的是，该方法只返回Logger的名称，而不是对Logger本身的强参考。 返回的String不会阻止Logger被垃圾回收。 具体来说，如果返回的名称传递给LogManager.getLogger() ，则调用者必须从LogManager.getLogger()检查null的值，以正确处理在此方法返回名称后，Logger已被垃圾回收的情况。

        结果
        记录器名称字符串的枚举

      • readConfiguration

        public void readConfiguration​()
                       throws IOException,
                              SecurityException
        读取并初始化日志记录配置。

        如果设置了“java.util.logging.config.class”系统属性，那么属性值将被视为一个类名。 给定的类将被加载，一个对象将被实例化，该对象的构造函数负责在初始配置中进行读取。 （该对象可以使用其他系统属性来控制其配置。）备用配置类可以使用readConfiguration(InputStream)定义LogManager中的属性。

        如果未设置“java.util.logging.config.class”系统属性，则该方法将从属性文件读取初始配置，并调用readConfiguration(InputStream)方法初始化配置。 可以使用“java.util.logging.config.file”系统属性指定要作为初始配置读取的属性文件; 如果未设置，则使用LogManager默认配置。 默认配置通常从Java安装目录中的属性文件“ conf/logging.properties ”加载。

        任何registered configuration listener将在属性被读取后被调用。

        API Note:
        此readConfiguration方法只能用于在LogManager初始化期间初始化配置或与“java.util.logging.config.class”属性一起使用。 在创建记录器之后调用此方法，并且未设置“java.util.logging.config.class”系统属性时，所有现有的记录器将为reset 。 那么具有在新配置流中指定的级别属性的所有现有记录器将为指定日志级别的set 。

        要正确更新日志记录配置，请改用updateConfiguration(java.util.function.Function)或updateConfiguration(java.io.InputStream, java.util.function.Function)方法。

        异常
        SecurityException - 如果安全管理器存在，并且调用者没有LoggingPermission（“control”）。
        IOException - 读取配置是否存在IO问题。

      • reset

        public void reset​()
           throws SecurityException
        重置日志配置。

        对于所有命名的记录器，复位操作将删除并关闭所有处理程序，除了根记录器之外，将级别设置为null 。 根记录器的级别设置为Level.INFO 。

        API Note:
        调用此方法也会清除LogManager properties 。 updateConfiguration(Function)或updateConfiguration(InputStream, Function)方法可用于正确更新到新配置。
        异常
        SecurityException - 如果安全管理器存在，并且调用者没有LoggingPermission（“控制”）。

      • readConfiguration

        public void readConfiguration​(InputStream ins)
                       throws IOException,
                              SecurityException
        从给定的输入流读取和初始化日志记录配置。

        任何registered configuration listener将在属性被读取后被调用。

        API Note:
        此readConfiguration方法仅应用于在LogManager初始化期间初始化配置或与“java.util.logging.config.class”属性一起使用。 在创建记录器后调用此方法时，所有现有的记录器将为reset 。 那么具有指定输入流中指定的级别属性的任何现有记录器将为指定日志级别的set 。

        要正确更新日志记录配置，请改用updateConfiguration(java.util.function.Function)或updateConfiguration(java.io.InputStream, java.util.function.Function)方法。

        参数
        ins - 从中读取属性的流
        异常
        SecurityException - 如果安全管理器存在，并且主叫方没有LoggingPermission（“控制”）。
        IOException - 如果从流读取有问题，或者给定的流不是在properties file格式。

      • updateConfiguration

        public void updateConfiguration​(Function<String,BiFunction<String,String,String>> mapper)
                         throws IOException
        更新日志记录配置。

        如果设置了“java.util.logging.config.file”系统属性，则属性值指定要作为新配置读取的属性文件。 否则，将使用LogManager默认配置。
        默认配置通常从Java安装目录中的属性文件“ conf/logging.properties ”加载。

        此方法读取新配置并调用updateConfiguration(ins, mapper)方法来更新配置。

        API Note:
        此方法从读取属性文件更新日志记录配置，并忽略“java.util.logging.config.class”系统属性。 “java.util.logging.config.class”属性仅由readConfiguration()方法用于将自定义配置类作为初始配置加载。
        参数
        mapper - 一个功能界面，它接受配置密钥k，并返回一个函数f（o，n） ，该函数的返回值将被应用于最终的配置。 函数f可以返回null以指示不会将属性k添加到结果配置。
        如果mapper为null然后(k) -> ((o, n) -> n)假设。
        对于每个k ，映射函数f将使用与旧配置（即o ）中的k相关联的值和与新配置（即n ）中的k相关联的值来调用。
        o or n的值为null ，表示相应配置中的k没有值。
        异常
        SecurityException - 如果安全管理器存在，并且调用者没有LoggingPermission（“控制”），或者没有设置配置所需的权限（例如，为FileHandlers等指定的打开文件）
        NullPointerException - 如果 mapper在调用时返回 null函数。
        IOException - 如果从日志记录配置文件读取有问题。
        从以下版本开始：
        9
        另请参见：
        updateConfiguration(java.io.InputStream, java.util.function.Function)

      • updateConfiguration

        public void updateConfiguration​(InputStream ins,
                                Function<String,BiFunction<String,String,String>> mapper)
                         throws IOException
        更新日志记录配置。

        对于existing configuration中的每个配置密钥和给定的输入流配置，将调用给定的mapper函数从配置密钥映射到函数f（o，n） ，该函数采用旧值和新值，并返回结果值应用于最终配置，如下表所示。

        令k为旧配置或新配置中的配置密钥， o为旧值（即与旧配置中与k相关的值）， n为新值（即与新配置中的k相关的值），以及f是由mapper.apply( k )返回的函数：那么v = f（o，n）是结果值。 如果v不是null ，那么具有值v的属性k将被添加到结果配置中。 否则将省略。
        可以将null值传递给函数f，以指示相应的配置没有配置密钥k 。 函数f可以返回null以指示在结果配置中将不存在与k相关联的值。

        如果mapper是null ，则v将被设置为n 。

        LogManager properties将在结果配置中更新结果值。

        注册的configuration listeners将在配置成功更新后被调用。

        Updating configuration properties Property Resulting Behavior <logger>.level
        • If the resulting configuration defines a level for a logger and if the resulting level is different than the level specified in the the old configuration, or not specified in the old configuration, then if the logger exists or if children for that logger exist, the level for that logger will be updated, and the change propagated to any existing logger children. This may cause the logger to be created, if necessary.
        • If the old configuration defined a level for a logger, and the resulting configuration doesn't, then this change will not be propagated to existing loggers, if any. To completely replace a configuration - the caller should therefore call reset to empty the current configuration, before calling updateConfiguration.
        <logger>.useParentHandlers
        • If either the resulting or the old value for the useParentHandlers property is not null, then if the logger exists or if children for that logger exist, that logger will be updated to the resulting value. The value of the useParentHandlers property is the value specified in the configuration; if not specified, the default is true.
        <logger>.handlers
        • If the resulting configuration defines a list of handlers for a logger, and if the resulting list is different than the list specified in the old configuration for that logger (that could be empty), then if the logger exists or its children exist, the handlers associated with that logger are closed and removed and the new handlers will be created per the resulting configuration and added to that logger, creating that logger if necessary.
        • If the old configuration defined some handlers for a logger, and the resulting configuration doesn't, if that logger exists, its handlers will be removed and closed.
        • Changing the list of handlers on an existing logger will cause all its previous handlers to be removed and closed, regardless of whether they had been created from the configuration or programmatically. The old handlers will be replaced by new handlers, if any.
        <handler-name>.*
        • Properties configured/changed on handler classes will only affect newly created handlers. If a node is configured with the same list of handlers in the old and the resulting configuration, then these handlers will remain unchanged.
        config and any other property
        • The resulting value for these property will be stored in the LogManager properties, but updateConfiguration will not parse or process their values.

        示例映射器函数：

        • 使用新配置替换所有日志记录属性：

          (k) -> ((o, n) -> n) ：

          这相当于传递null mapper参数。
        • 合并新配置和旧配置，并在新配置中存在k时使用新值：

          (k) -> ((o, n) -> n == null ? o : n) ：

          好像合并两个集合如下： result.putAll(oldc); result.putAll(newc) 。
        • 合并新配置和旧配置，并使用旧值（如果k存在于旧配置中）：

          (k) -> ((o, n) -> o == null ? n : o) ：

          好像合并两个集合如下： result.putAll(newc); result.putAll(oldc) 。
        • 使用新配置替换所有属性，除了处理程序属性以配置不是root logger的Logger处理程序：
            (k) -> k.endsWith(".handlers")
       ? ((o, n) -> (o == null ? n : o))
       : ((o, n) -> n)

        要完全重新配置配置，应用程序可以先调用reset，以完全删除旧配置，然后updateConfiguration初始化新配置。

        参数
        ins - 从中读取属性的流
        mapper - 一个功能界面，它接受配置密钥k并返回一个函数f（o，n） ，返回值将被应用于最终的配置。 函数f可以返回null以指示不会将属性k添加到结果配置中。
        如果mapper为null然后(k) -> ((o, n) -> n)假设。
        对于每个k ，映射函数f将使用与旧配置（即o ）中的k相关联的值和与新配置（即n ）中的k相关联的值来调用。
        o or n的值为null ，表示对应的配置中k不存在任何值。
        异常
        SecurityException - 如果安全管理器存在，并且调用者没有LoggingPermission（“控制”），或者没有设置配置所需的权限（例如打开为FileHandler指定的文件）
        NullPointerException - 如果 ins为空，或者如果 mapper在调用时返回空函数。
        IOException - 如果从流读取有问题，或给定的流不是在properties file格式。
        从以下版本开始：
        9

      • getProperty

        public String getProperty​(String name)
        获取日志记录属性的值。 如果找不到该属性，该方法返回null。
        参数
        name - 物业名称
        结果
        属性值

      • checkAccess

        public void checkAccess​()
                 throws SecurityException
        检查当前上下文是否受信任以修改日志记录配置。 这需要LoggingPermission（“control”）。

        如果检查失败，我们抛出一个SecurityException，否则返回正常。

        异常
        SecurityException - 如果安全管理器存在，并且主叫方没有LoggingPermission（“控制”）。

      • getLoggingMXBean

        @Deprecated(since="9")
public static LoggingMXBean getLoggingMXBean​()
        已过时。 java.util.logging.LoggingMXBean已被弃用，替换为java.lang.management.PlatformLoggingMXBean 。 请改用ManagementFactory.getPlatformMXBean （PlatformLoggingMXBean.class）。
        返回 LoggingMXBean用于管理记录器。
        结果
        一个LoggingMXBean对象。
        从以下版本开始：
        1.5
        另请参见：
        PlatformLoggingMXBean

      • addConfigurationListener

        public LogManager addConfigurationListener​(Runnable listener)
        添加每次读取日志配置时调用的配置监听器。 如果监听器已经注册，该方法什么也不做。

        调用该调用方法的调用上下文限制的权限。 调用侦听器的顺序是未指定的。

        建议听众不要抛出错误或异常。 如果监听器以未捕获的错误或异常终止，则在调用所有侦听器之后，第一个异常将传播给调用方readConfiguration() （或readConfiguration(java.io.InputStream) ）。

        Implementation Note:
        如果多个侦听器以未捕获的错误或异常终止，则实现可能将其他错误或异常记录为 suppressed exceptions 。
        参数
        listener - 在配置更改后调用的配置监听器。
        结果
        这个LogManager。
        异常
        SecurityException - 如果安全管理器存在，并且主叫方没有LoggingPermission（“控制”）。
        NullPointerException - 如果侦听器为空。
        从以下版本开始：
        9

      • removeConfigurationListener

        public void removeConfigurationListener​(Runnable listener)
        删除以前注册的配置监听器。 如果没有找到侦听器，则默认返回。
        参数
        listener - 要删除的配置监听器。
        异常
        NullPointerException - 如果监听器为null。
        SecurityException - 如果安全管理器存在，并且主叫方没有LoggingPermission（“控制”）。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


LogRecord (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class LogRecord

  • java.lang.Object
    • java.util.logging.LogRecord
  • All Implemented Interfaces:
    Serializable

    public class LogRecord
extends Object
implements Serializable
    LogRecord对象用于在日志框架和各个日志处理程序之间传递日志请求。

    当LogRecord被传递到日志框架中时，逻辑上属于框架，不应再被客户端应用程序使用或更新。

    请注意，如果客户端应用程序尚未指定明确的源代码方法名称和源类名称，则LogRecord类将在首次访问（由于通过调用getSourceMethodName或getSourceClassName）分析调用堆栈时自动推断它们。 因此，如果记录处理程序希望将LogRecord传递到另一个线程，或者通过RMI传输，并且如果希望随后获取方法名称或类名称信息，则它应该调用getSourceClassName或getSourceMethodName之一来强制将值填写。

    序列化注释：

    • LogRecord类是可序列化的。
    • 因为参数数组中的对象可能不可串行化，所以在序列化期间，参数数组中的所有对象都将被写为相应的字符串（使用Object.toString）。
    • ResourceBundle不作为序列化表单的一部分传输，但是资源包名称是，并且收件人对象的readObject方法将尝试找到合适的资源包。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LogRecord​(Level level, String msg)
      使用给定的级别和消息值构造LogRecord。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Instant getInstant​()
      获取事件发生的时刻。
      Level getLevel​()
      获取日志消息级别，例如Level.SEVERE。
      String getLoggerName​()
      获取源记录器的名称。
      String getMessage​()
      在本地化或格式化之前获取“原始”日志消息。
      long getMillis​()
      自1970年以来，截止事件时间为毫秒。
      Object[] getParameters​()
      获取日志消息的参数。
      ResourceBundle getResourceBundle​()
      获取本地化资源包
      String getResourceBundleName​()
      获取本地化资源包名称
      long getSequenceNumber​()
      获取序列号。
      String getSourceClassName​()
      获取（据称）发出日志记录请求的类的名称。
      String getSourceMethodName​()
      获取（据称）发出日志记录请求的方法的名称。
      int getThreadID​()
      获取消息发起的线程的标识符。
      Throwable getThrown​()
      获取与日志记录相关联的任何可抛出的值。
      void setInstant​(Instant instant)
      设置事件发生的时刻。
      void setLevel​(Level level)
      设置日志消息级别，例如Level.SEVERE。
      void setLoggerName​(String name)
      设置源记录器的名称。
      void setMessage​(String message)
      在本地化或格式化之前设置“原始”日志消息。
      void setMillis​(long millis)
      已过时。
      LogRecord使用Instant值维护纳秒分辨率的时间戳。 因此， setInstant()应优先于setMillis() 。
      void setParameters​(Object[] parameters)
      将参数设置为日志消息。
      void setResourceBundle​(ResourceBundle bundle)
      设置本地化资源包。
      void setResourceBundleName​(String name)
      设置本地化资源包名称。
      void setSequenceNumber​(long seq)
      设置序列号。
      void setSourceClassName​(String sourceClassName)
      设置（据称）发出日志记录请求的类的名称。
      void setSourceMethodName​(String sourceMethodName)
      设置（据称）发出日志记录请求的方法的名称。
      void setThreadID​(int threadID)
      设置消息始发线程的标识符。
      void setThrown​(Throwable thrown)
      设置与日志事件相关联的可抛出。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LogRecord

        public LogRecord​(Level level,
                 String msg)
        使用给定的级别和消息值构造LogRecord。

        sequence属性将被初始化为一个新的唯一值。 这些序列值在VM内以增加的顺序分配。

        自JDK 9起，事件时间由Instant表示。 即时属性将被初始化为current instant ，使用系统上最好的clock 。

        线程ID属性将使用当前线程的唯一ID进行初始化。

        所有其他属性将被初始化为“null”。

        参数
        level - 记录级别值
        msg - 原始非本地化日志消息（可能为null）
        另请参见：
        Clock.systemUTC()

    • 方法详细信息

      • getLoggerName

        public String getLoggerName​()
        获取源记录器的名称。
        结果
        源记录器名称（可能为null）

      • setLoggerName

        public void setLoggerName​(String name)
        设置源记录器的名称。
        参数
        name - 源记录器名称（可以为空）

      • getResourceBundle

        public ResourceBundle getResourceBundle​()
        获取本地化资源包

        这是ResourceBundle，它应该用于在格式化之前本地化消息字符串。 如果消息不可本地化，或者没有合适的ResourceBundle可用，则结果可能为null。

        结果
        本地化资源包

      • setResourceBundle

        public void setResourceBundle​(ResourceBundle bundle)
        设置本地化资源包。
        参数
        bundle - 本地化包（可能为null）

      • getResourceBundleName

        public String getResourceBundleName​()
        获取本地化资源包名称

        这是ResourceBundle的名称，它应该用于在格式化之前本地化消息字符串。 如果消息不可本地化，结果可能为null。

        结果
        本地化资源包名称

      • setResourceBundleName

        public void setResourceBundleName​(String name)
        设置本地化资源包名称。
        参数
        name - 本地化包名称（可能为null）

      • getLevel

        public Level getLevel​()
        获取日志消息级别，例如Level.SEVERE。
        结果
        日志消息级别

      • setLevel

        public void setLevel​(Level level)
        设置日志消息级别，例如Level.SEVERE。
        参数
        level - 日志消息级别

      • getSequenceNumber

        public long getSequenceNumber​()
        获取序列号。

        序列号通常在LogRecord构造函数中分配，它以增加的顺序为每个新的LogRecord分配唯一的序列号。

        结果
        序列号

      • setSequenceNumber

        public void setSequenceNumber​(long seq)
        设置序列号。

        序列号通常在LogRecord构造函数中分配，因此通常不需要使用此方法。

        参数
        seq - 序列号

      • getSourceClassName

        public String getSourceClassName​()
        获取（据称）发出日志记录请求的类的名称。

        请注意，该sourceClassName未经验证，可能会被欺骗。 该信息可能已经作为日志记录调用的一部分提供，也可能由日志记录框架自动推断出来。 在后一种情况下，信息可能仅仅是近似的，并且实际上可以描述堆栈帧上的较早的呼叫。

        如果不能获得任何信息，则可以为null。

        结果
        源类名称

      • setSourceClassName

        public void setSourceClassName​(String sourceClassName)
        设置（据称）发出日志记录请求的类的名称。
        参数
        sourceClassName - 源类名（可以为空）

      • getSourceMethodName

        public String getSourceMethodName​()
        获取（据称）发出日志记录请求的方法的名称。

        请注意，此sourceMethodName未经过验证，可能会被欺骗。 该信息可能已经作为日志记录调用的一部分提供，也可能由日志记录框架自动推断出来。 在后一种情况下，信息可能仅仅是近似的，并且实际上可以描述堆栈帧上的较早的呼叫。

        如果不能获得任何信息，则可以为null。

        结果
        源方法名称

      • setSourceMethodName

        public void setSourceMethodName​(String sourceMethodName)
        设置（据称）发出日志记录请求的方法的名称。
        参数
        sourceMethodName - 源方法名（可以为空）

      • getMessage

        public String getMessage​()
        在本地化或格式化之前获取“原始”日志消息。

        可以为空，这相当于空字符串“”。

        该消息可以是最终文本或本地化密钥。

        在格式化期间，如果源记录器具有本地化ResourceBundle，并且如果该ResourceBundle具有此消息字符串的条目，则消息字符串将替换为本地化值。

        结果
        原始消息字符串

      • setMessage

        public void setMessage​(String message)
        在本地化或格式化之前设置“原始”日志消息。
        参数
        message - 原始消息字符串（可以为空）

      • getParameters

        public Object[] getParameters​()
        获取日志消息的参数。
        结果
        日志消息参数。 如果没有参数，可能为null。

      • setParameters

        public void setParameters​(Object[] parameters)
        将参数设置为日志消息。
        参数
        parameters - 日志消息参数。 （可能为空）

      • getThreadID

        public int getThreadID​()
        获取消息发起的线程的标识符。

        这是Java VM中的线程标识符，并且可能映射到或不映射到任何操作系统ID。

        结果
        线程ID

      • setThreadID

        public void setThreadID​(int threadID)
        设置消息始发线程的标识符。
        参数
        threadID - 线程ID

      • getMillis

        public long getMillis​()
        自1970年以来，截止事件时间为毫秒。
        API Note:
        要获得全纳秒的分辨率事件时间，请使用 getInstant() 。
        实现要求：
        这相当于调用 getInstant().toEpochMilli() 。
        结果
        自1970年以来，截止的事件时间以毫秒为单位
        另请参见：
        getInstant()

      • setMillis

        @Deprecated
public void setMillis​(long millis)
        已过时。 LogRecord使用纳秒分辨率维持时间戳，使用Instant值。 因此， setInstant()应优先使用setMillis() 。
        设置事件时间。
        实现要求：
        这相当于调用 setInstant(Instant.ofEpochMilli(millis)) 。
        参数
        millis - 自1970年以来以 millis事件时间。
        另请参见：
        setInstant(java.time.Instant)

      • getInstant

        public Instant getInstant​()
        获取事件发生的时刻。
        结果
        事件发生的瞬间。
        从以下版本开始：
        9

      • setInstant

        public void setInstant​(Instant instant)
        设置事件发生的时刻。

        如果给定的instant表示时间线上的点在将来或过去太远以适应long毫秒和纳秒调整，则将抛出ArithmeticException 。

        参数
        instant - 事件发生的瞬间。
        异常
        NullPointerException - 如果 instant为空。
        ArithmeticException - 如果在调用 instant.toEpochMilli()时发生数字溢出。
        从以下版本开始：
        9

      • getThrown

        public Throwable getThrown​()
        获取与日志记录相关联的任何可抛出的值。

        如果事件涉及异常，这将是异常对象。 否则为null。

        结果
        一个可扔的

      • setThrown

        public void setThrown​(Throwable thrown)
        设置与日志事件相关联的可抛出。
        参数
        thrown - 一个可抛出（可以是null）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MemoryHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class MemoryHandler

  • java.lang.Object
    • java.util.logging.Handler
      • java.util.logging.MemoryHandler

  • public class MemoryHandler
extends Handler
    Handler缓冲区内存中循环缓冲区中的请求。

    通常这个Handler简单地将进入的LogRecords存入其内存缓冲区并丢弃早期的记录。 这种缓冲非常便宜，避免了格式化成本。 在某些触发条件下， MemoryHandler将其当前的缓冲区内容推送到目标Handler ，通常将其发布到外部世界。

    触发缓冲区的主要模式有三种：

    • 传入的LogRecord的类型大于预定义级别，即pushLevel 。
    • 一个外部类显式地调用push方法。
    • 子类覆盖log方法并扫描每个传入的LogRecord ，如果记录符合某些所需条件，则调用push 。

    配置：默认情况下，每个MemoryHandler都使用以下LogManager配置属性进行初始化，其中<handler-name>引用处理程序的完全限定类名。 如果未定义属性（或具有无效值），则使用指定的默认值。 如果未定义默认值，则抛出RuntimeException。

    • <处理程序名> .LEVEL指定了水平Handler （默认为Level.ALL ）。
    • <处理程序名> .filter指定的名称Filter类中使用（默认为无Filter ）。
    • <handler-name> .size定义缓冲区大小（默认为1000）。
    • <handler-name> .push定义了pushLevel （默认为level.SEVERE ）。
    • <handler-name> .target指定目标的名称Handler类。 （无默认）。

    例如， MemoryHandler的属性将是：

    • java.util.logging.MemoryHandler.level = INFO
    • java.util.logging.MemoryHandler.formatter = java.util.logging.SimpleFormatter

    对于自定义处理程序，例如com.foo.MyHandler，属性将是：

    • com.foo.MyHandler.level = INFO
    • com.foo.MyHandler.formatter = java.util.logging.SimpleFormatter
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      MemoryHandler​()
      创建一个 MemoryHandler并配置它基于 LogManager配置属性。
      MemoryHandler​(Handler target, int size, Level pushLevel)
      创建一个 MemoryHandler 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭 Handler并释放所有相关资源。
      void flush​()
      导致目标 Handler 。
      Level getPushLevel​()
      获取 pushLevel 。
      boolean isLoggable​(LogRecord record)
      检查这个 Handler是否会将给定的 LogRecord实际记录到其内部缓冲区中。
      void publish​(LogRecord record)
      将 LogRecord存储在内部缓冲区中。
      void push​()
      将任何缓冲输出推送到目标 Handler 。
      void setPushLevel​(Level newLevel)
      设置 pushLevel 。

      • Methods inherited from class java.util.logging.Handler

        getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setEncoding, setErrorManager, setFilter, setFormatter, setLevel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MemoryHandler

        public MemoryHandler​()
        创建一个 MemoryHandler并配置它基于 LogManager配置属性。

      • MemoryHandler

        public MemoryHandler​(Handler target,
                     int size,
                     Level pushLevel)
        创建一个MemoryHandler 。

        MemoryHandler基于LogManager属性（或其默认值）进行配置，但使用给定的pushLevel参数和缓冲区大小参数。

        参数
        target - 发布输出的处理程序。
        size - 要缓冲的日志记录数（必须大于零）
        pushLevel - 消息级别推送
        异常
        IllegalArgumentException - 如果是 size is <= 0

    • 方法详细信息

      • publish

        public void publish​(LogRecord record)
        将LogRecord存储在内部缓冲区中。

        如果有一个Filter ，则调用其isLoggable方法来检查给定的日志记录是否可记录。 如果不是我们回来 否则给定的记录被复制到一个内部循环缓冲区。 然后将记录的级别属性与pushLevel进行比较。 如果给定的级别大于或等于pushLevel然后push被称为所有已缓冲的记录写入到目标输出Handler 。

        Specified by:
        publish在 Handler
        参数
        record - 日志事件的描述。 空值记录被默认忽略并且未发布

      • push

        public void push​()
        将任何缓冲输出推送到目标Handler 。

        然后清除缓冲区。

      • flush

        public void flush​()
        对目标Handler 。

        请注意， MemoryHandler缓冲区的当前内容未写出。 这需要一个“推”。

        Specified by:
        flush在 Handler

      • close

        public void close​()
           throws SecurityException
        关闭Handler并释放所有相关资源。 这也将关闭目标Handler 。
        Specified by:
        close在 Handler
        异常
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control") 。

      • setPushLevel

        public void setPushLevel​(Level newLevel)
                  throws SecurityException
        设置pushLevel 。 将LogRecord复制到我们的内部缓冲区后，如果其级别大于或等于pushLevel ，则会调用push 。
        参数
        newLevel - 新值 pushLevel
        异常
        SecurityException - 如果安全管理器存在，并且呼叫者没有 LoggingPermission("control") 。

      • getPushLevel

        public Level getPushLevel​()
        获取 pushLevel 。
        结果
        的价值 pushLevel

      • isLoggable

        public boolean isLoggable​(LogRecord record)
        检查这个Handler是否会将给定的LogRecord实际记录到其内部缓冲区中。

        该方法检查LogRecord是否具有适当的级别，以及是否满足任何Filter 。 然而，它不检查是否LogRecord将导致的缓冲区的内容“推”。 如果LogRecord为null，它将返回false。

        重写：
        isLoggable在 Handler
        参数
        record - a LogRecord
        结果
        如果要记录 LogRecord true。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class SimpleFormatter

  • java.lang.Object
    • java.util.logging.Formatter
      • java.util.logging.SimpleFormatter

  • public class SimpleFormatter
extends Formatter
    以人类可读格式打印LogRecord的简要摘要。 摘要通常为1或2行。

    Configuration:将SimpleFormatter初始化为format string ，在java.util.logging.SimpleFormatter.format属性中指定的日志信息为format 。 该属性可以在logging properties配置文件中定义或作为系统属性定义。 如果在记录属性和系统属性中设置此属性，则将使用系统属性中指定的格式字符串。 如果未定义此属性或给定的格式字符串是illegal ，默认格式是实现特定的。

    从以下版本开始：
    1.4
    另请参见：
    Formatter

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleFormatter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String format​(LogRecord record)
      格式化给定的LogRecord。

      • Methods inherited from class java.util.logging.Formatter

        formatMessage, getHead, getTail

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SimpleFormatter

        public SimpleFormatter​()

    • 方法详细信息

      • format

        public String format​(LogRecord record)
        格式化给定的LogRecord。

        可以通过在java.util.logging.SimpleFormatter.format属性中指定format string来自定义格式。 给定的LogRecord将格式化为通过调用：

          String.format(format, date, source, logger, level, message, thrown);
        其中的论点是：
        1. format - java.util.logging.SimpleFormatter.format属性中指定的java.util.Formatter格式字符串或默认格式。
        2. date -一个ZonedDateTime表示对象event time的日志记录的ZoneId.systemDefault()系统时区。
        3. source - 表示呼叫者的字符串（如果有）; 否则，记录器的名称。
        4. logger - 记录器名称。
        5. level - log level 。
        6. message - 从Formatter.formatMessage(LogRecord)方法返回格式化的日志消息。 它使用java.text格式化，不使用java.util.Formatter format参数。
        7. thrown - 表示与日志记录相关联的throwable的字符串，以及以换行符开头的回溯（如果有）; 否则，一个空字符串。

        一些示例格式：

        • java.util.logging.SimpleFormatter.format="%4$s: %5$s [%1$tc]%n"

          这1$方括号中的日志级别（ 4$ ），日志消息（ 5$ ）和时间戳（ 1$ ）打印1行。

            WARNING: warning message [Tue Mar 22 13:11:31 PDT 2011]
        • java.util.logging.SimpleFormatter.format="%1$tc %2$s%n%4$s: %5$s%6$s%n"

          这将打印2行，其中第一行包括时间戳（ 1$ ）和源（ 2$ ）; 第二行包括日志级别（ 4$ ）和日志消息（ 5$ ），后跟可抛出和其追溯（ 6$ ）（如果有）：

            Tue Mar 22 13:11:31 PDT 2011 MyClass fatal
     SEVERE: several message with an exception
     java.lang.IllegalArgumentException: invalid argument
             at MyClass.mash(MyClass.java:9)
             at MyClass.crunch(MyClass.java:6)
             at MyClass.main(MyClass.java:3)
        • java.util.logging.SimpleFormatter.format="%1$tb %1$td, %1$tY %1$tl:%1$tM:%1$tS %1$Tp %2$s%n%4$s: %5$s%n"

          这样打印出与上述示例类似的两行，并使用不同的日期/时间格式化，并且不会打印可抛出物体及其回溯：

            Mar 22, 2011 1:11:31 PM MyClass fatal
     SEVERE: several message with an exception
        • java.util.logging.SimpleFormatter.format="%1$tb %1$td, %1$tY %1$tl:%1$tM:%1$tS.%1$tN %1$Tp %2$s%n%4$s: %5$s%6$s%n"

          由于JDK java.util.logging使用java.time创建更精确的时间戳。 上述格式可用于将.%1$tN添加到日期/时间格式，以便纳秒也可以打印：

            Feb 06, 2015 5:33:10.279216000 PM example.Main main
     INFO: This is a test

        这个方法也可以在一个子类中被覆盖。 建议使用Formatter.formatMessage(java.util.logging.LogRecord)方便的方法来本地化和格式化消息字段。

        Specified by:
        format在 Formatter
        参数
        record - 要格式化的日志记录。
        结果
        格式化的日志记录
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SocketHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class SocketHandler

  • java.lang.Object
    • java.util.logging.Handler
      • java.util.logging.StreamHandler
        • java.util.logging.SocketHandler

  • public class SocketHandler
extends StreamHandler
    简单网络记录Handler 。

    LogRecords被发布到网络流连接。 默认情况下， XMLFormatter类用于格式化。

    配置：默认情况下，每个SocketHandler都使用以下LogManager配置属性进行初始化，其中<handler-name>引用处理程序的完全限定类名。 如果未定义属性（或具有无效值），则使用指定的默认值。

    • <处理程序名> .LEVEL指定了默认级别Handler （默认为Level.ALL ）。
    • <处理程序名> .filter指定的名称Filter类中使用（默认为无Filter ）。
    • <handler-name> .formatter指定要使用的Formatter类的名称（默认为java.util.logging.XMLFormatter ）。
    • <handler-name>。编码要使用的字符集编码的名称（默认为默认平台编码）。
    • <handler-name> .host指定要连接的目标主机名（不是默认值）。
    • <handler-name> .port指定要使用的目标TCP端口（不使用默认值）。

    例如， SocketHandler的属性将是：

    • java.util.logging.SocketHandler.level = INFO
    • java.util.logging.SocketHandler.formatter = java.util.logging.SimpleFormatter

    对于自定义处理程序，例如com.foo.MyHandler，属性将是：

    • com.foo.MyHandler.level = INFO
    • com.foo.MyHandler.formatter = java.util.logging.SimpleFormatter

    输出IO流是缓冲的，但在写入每个LogRecord之后被刷新。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      SocketHandler​()
      创建一个 SocketHandler ，仅使用 LogManager属性（或其默认值）。
      SocketHandler​(String host, int port)
      构造一个 SocketHandler使用指定的主机和端口。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此输出流。
      void publish​(LogRecord record)
      格式化并发布 LogRecord 。

      • Methods inherited from class java.util.logging.Handler

        getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setErrorManager, setFilter, setFormatter, setLevel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.logging.StreamHandler

        flush, isLoggable, setEncoding, setOutputStream

    • 构造方法详细信息

      • SocketHandler

        public SocketHandler​()
              throws IOException
        创建一个 SocketHandler ，仅使用 LogManager属性（或其默认值）。
        异常
        IllegalArgumentException - 如果主机或端口无效或未指定为LogManager属性。
        IOException - 如果我们无法连接到目标主机和端口。

      • SocketHandler

        public SocketHandler​(String host,
                     int port)
              throws IOException
        使用指定的主机和端口构建一个SocketHandler 。 SocketHandler基于LogManager属性（或其默认值）进行配置，但使用给定的目标主机和端口参数。 如果host参数为空，而不是空String，则使用localhost。
        参数
        host - 目标主机。
        port - 目标端口。
        异常
        IllegalArgumentException - 如果主机或端口无效。
        IOException - 如果我们无法连接到目标主机和端口。

    • 方法详细信息

      • close

        public void close​()
           throws SecurityException
        关闭此输出流。
        重写：
        close在 StreamHandler
        异常
        SecurityException - 如果安全管理器存在，并且主叫方没有 LoggingPermission("control") 。

      • publish

        public void publish​(LogRecord record)
        格式化并发布 LogRecord 。
        重写：
        publish在 StreamHandler
        参数
        record - 日志事件的描述。 空值记录被默认忽略并且未发布
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StreamHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class StreamHandler

  • java.lang.Object
    • java.util.logging.Handler
      • java.util.logging.StreamHandler
  • 已知直接子类：
    ConsoleHandler ， FileHandler ， SocketHandler

    public class StreamHandler
extends Handler
    基于流记录Handler 。

    这主要是作为基础类或支持类用于实现其他日志记录Handlers 。

    LogRecords已发布给给定的java.io.OutputStream 。

    配置：默认情况下，每个StreamHandler都使用以下LogManager配置属性进行初始化，其中<handler-name>引用处理程序的完全限定类名。 如果未定义属性（或具有无效值），则使用指定的默认值。

    • <处理程序名> .LEVEL指定了默认级别Handler （默认为Level.INFO ）。
    • <处理程序名> .filter指定的名称Filter类中使用（默认为无Filter ）。
    • <处理程序名> .formatter指定的名称Formatter类中使用（默认为java.util.logging.SimpleFormatter ）。
    • <handler-name>。编码要使用的字符集编码的名称（默认为默认平台编码）。

    例如， StreamHandler的属性将是：

    • java.util.logging.StreamHandler.level = INFO
    • java.util.logging.StreamHandler.formatter = java.util.logging.SimpleFormatter

    对于自定义处理程序，例如com.foo.MyHandler，属性将是：

    • com.foo.MyHandler.level = INFO
    • com.foo.MyHandler.formatter = java.util.logging.SimpleFormatter
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      StreamHandler​()
      创建一个 StreamHandler ，没有当前的输出流。
      StreamHandler​(OutputStream out, Formatter formatter)
      创建一个 StreamHandler与给定的 Formatter和输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭当前的输出流。
      void flush​()
      刷新任何缓冲的消息。
      boolean isLoggable​(LogRecord record)
      检查这个 Handler是否会实际记录给定的 LogRecord 。
      void publish​(LogRecord record)
      格式化并发布一个 LogRecord 。
      void setEncoding​(String encoding)
      设置（或更改）此 Handler使用的字符编码。
      protected void setOutputStream​(OutputStream out)
      更改输出流。

      • Methods inherited from class java.util.logging.Handler

        getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setErrorManager, setFilter, setFormatter, setLevel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StreamHandler

        public StreamHandler​()
        创建一个 StreamHandler ，没有当前的输出流。

      • StreamHandler

        public StreamHandler​(OutputStream out,
                     Formatter formatter)
        创建一个 StreamHandler与给定的 Formatter和输出流。
        参数
        out - 目标输出流
        formatter - 用于格式化输出的格式化器

    • 方法详细信息

      • setOutputStream

        protected void setOutputStream​(OutputStream out)
                        throws SecurityException
        更改输出流。

        如果有当前输出流，则写入Formatter的尾字符串，并且流被刷新并关闭。 然后输出流被替换为新的输出流。

        参数
        out - 新的输出流。 可能不为空
        异常
        SecurityException - 如果存在安全管理员，并且呼叫者没有 LoggingPermission("control") 。

      • setEncoding

        public void setEncoding​(String encoding)
                 throws SecurityException,
                        UnsupportedEncodingException
        设置（或更改）此Handler使用的字符编码。

        之前的任何编码应设置LogRecords被写入Handler 。

        重写：
        setEncoding的 Handler
        参数
        encoding - 支持的字符编码的名称。 可以为空，表示默认的平台编码。
        异常
        SecurityException - 如果存在安全管理员，并且呼叫方没有 LoggingPermission("control") 。
        UnsupportedEncodingException - 如果不支持命名编码。

      • publish

        public void publish​(LogRecord record)
        格式化并发布一个LogRecord 。

        StreamHandler首先检查是否有OutputStream ，如果给定的LogRecord至少具有所需的日志级别。 如果不是，它会默默地返回。 如果是这样，它会调用任何关联的Filter来检查是否应该发布记录。 如果是这样，它调用其Formatter来格式化记录，然后将结果写入当前输出流。

        如果这是第LogRecord被写入给定OutputStream ，该Formatter了之前的‘头部’字符串写入流LogRecord被写入。

        Specified by:
        publish在 Handler
        参数
        record - 日志事件的描述。 空值记录被默认忽略并且未发布

      • isLoggable

        public boolean isLoggable​(LogRecord record)
        检查这个Handler是否会实际记录给定的LogRecord 。

        该方法检查LogRecord是否具有适当的级别，以及是否满足任何Filter 。 如果没有分配任何输出流或LogRecord为空，它也将返回false。

        重写：
        isLoggable在 Handler
        参数
        record - a LogRecord
        结果
        如果将记录 LogRecord true。

      • flush

        public void flush​()
        刷新任何缓冲的消息。
        Specified by:
        flush在 Handler

      • close

        public void close​()
           throws SecurityException
        关闭当前的输出流。

        Formatter的“尾”字符串在关闭之前写入流中。 另外，如果Formatter的“头”字符串还没有被写入到流中，它将被写在“尾”字符串之前。

        Specified by:
        close在 Handler
        异常
        SecurityException - 如果存在安全管理员，并且主叫方没有LoggingPermission（“控制”）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util.logging (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.logging

  • Packages that use java.util.logging
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
  • Classes in java.util.logging used by java.sql
    Class 描述
    Logger
    Logger对象用于记录特定系统或应用程序组件的消息。
  • Classes in java.util.logging used by java.util.logging
    Class 描述
    ErrorManager
    可以将ErrorManager对象附加到处理程序，以处理在记录期间在处理程序中发生的任何错误。
    Filter
    可以使用过滤器对超出记录级别提供的控制范围内的记录进行细粒度控制。
    Formatter
    格式化程序提供对LogRecords进行格式化的支持。
    Handler
    一个 Handler对象从需要日志消息 Logger和出口他们。
    Level
    Level类定义了一组可用于控制日志输出的标准日志记录级别。
    Logger
    Logger对象用于记录特定系统或应用程序组件的消息。
    LoggingMXBean
    已过时。
    LoggingMXBean不再是platform MXBean并被替换为PlatformLoggingMXBean 。 它不会在平台上注册MBeanServer 。 改用ManagementFactory.getPlatformMXBean(PlatformLoggingMXBean.class) 。
    LogManager
    有一个全局LogManager对象用于维护关于日志记录器和日志服务的一组共享状态。
    LogRecord
    LogRecord对象用于在日志框架和各个日志处理程序之间传递日志请求。
    StreamHandler
    基于流记录 Handler 。
  • Classes in java.util.logging used by javax.sql
    Class 描述
    Logger
    Logger对象用于记录特定系统或应用程序组件的消息。
  • Classes in java.util.logging used by javax.sql.rowset.spi
    Class 描述
    Level
    Level类定义了一组可用于控制日志输出的标准日志记录级别。
    Logger
    A Logger object is used to log messages for a specific system or application component.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


XMLFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.logging
软件包 java.util.logging

Class XMLFormatter

  • java.lang.Object
    • java.util.logging.Formatter
      • java.util.logging.XMLFormatter

  • public class XMLFormatter
extends Formatter
    将LogRecord格式化为标准XML格式。

    DTD规范作为Java Logging API规范的附录A提供。

    XMLFormatter可以使用任意字符编码，但建议通常与UTF-8一起使用。 字符编码可以在输出处理程序中设置。

    实现要求：
    由于JDK 9，LogRecord的实例包含一个Instant ，其可以具有低于毫秒分辨率的纳秒。 DTD规范已更新，以允许可选的<nanos>元素。 默认情况下，XMLFormatter将计算毫秒分辨率下的纳秒调整（使用LogRecord.getInstant().getNano() % 1000_000 ） - 如果不是0，则该调整值将打印在新的<nanos>元素中。 然后可以使用Instant.ofEpochSecond(millis/1000L, (millis % 1000L) * 1000_000L + nanos)来重构事件瞬间，其中millis和nanos代表序列化在<millis>和<nanos>元素中的数字。
    <date>元素现在将包含DateTimeFormatter.ISO_INSTANT格式化程序格式化的整个瞬间。

    为了与旧解析器兼容，可以通过在日志记录配置中指定<xml-formatter-fully-qualified-class-name>.useInstant = false property ，将XMLFormatter配置为恢复为旧格式。 当useInstant为false ，旧格式将被保留。 当useInstant是true （缺省值），该<nanos>元件将被打印和<date>元素将包含formatted瞬间。

    例如，为了配置XMLFormatter的简单实例以省略新的<nano>元素，可以在日志记录配置中指定java.util.logging.XMLFormatter.useInstant = false 。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      XMLFormatter​()
      创建一个新的XMLFormatter实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String format​(LogRecord record)
      将给定的消息格式化为XML。
      String getHead​(Handler h)
      返回一组XML格式记录的标题字符串。
      String getTail​(Handler h)
      返回一组XML格式记录的尾字符串。

      • Methods inherited from class java.util.logging.Formatter

        formatMessage

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XMLFormatter

        public XMLFormatter​()
        创建一个新的XMLFormatter实例。
        实现要求：
        从JDK 9开始，XMLFormatter将打印出作为Instant的记录event time 。 这个瞬间有系统上可用的最佳分辨率。 <date>元素将包含由DateTimeFormatter.ISO_INSTANT格式化的时刻 。 此外，如果该瞬间含有低于毫秒分辨率的纳秒，则将打印包含纳秒调整的可选<nanos>元素。

        可以关闭此新行为，并通过在logging configuration中指定属性来恢复旧的格式。 如果LogManager.getLogManager().getProperty( this.getClass().getName()+".useInstant")是"false"或"0" ，旧的格式将被恢复。

    • 方法详细信息

      • format

        public String format​(LogRecord record)
        将给定的消息格式化为XML。

        这个方法可以在一个子类中被覆盖。 建议使用Formatter.formatMessage(java.util.logging.LogRecord)方便的方法来本地化和格式化消息字段。

        Specified by:
        format在 Formatter
        参数
        record - 要格式化的日志记录。
        结果
        格式化的日志记录

      • getHead

        public String getHead​(Handler h)
        返回一组XML格式记录的标题字符串。
        重写：
        getHead在 Formatter
        参数
        h - 目标处理程序（可以为null）
        结果
        一个有效的XML字符串

      • getTail

        public String getTail​(Handler h)
        返回一组XML格式记录的尾字符串。
        重写：
        getTail在 Formatter
        参数
        h - 目标处理程序（可以为null）
        结果
        一个有效的XML字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class java.util.logging.ConsoleHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.ConsoleHandler

No usage of java.util.logging.ConsoleHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.ErrorManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.ErrorManager

  • Packages that use ErrorManager
    软件包 描述
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。

    • Uses of ErrorManager in java.util.logging

      Methods in java.util.logging that return ErrorManager
      Modifier and Type 方法 描述
      ErrorManager Handler.getErrorManager​()
      检索此处理程序的ErrorManager。
      Methods in java.util.logging with parameters of type ErrorManager
      Modifier and Type 方法 描述
      void Handler.setErrorManager​(ErrorManager em)
      为此处理程序定义一个ErrorManager。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.FileHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.FileHandler

No usage of java.util.logging.FileHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.Formatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.Formatter

  • Packages that use Formatter
    软件包 描述
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。

    • Uses of Formatter in java.util.logging

      Subclasses of Formatter in java.util.logging
      Modifier and Type Class 描述
      class  SimpleFormatter
      以人类可读格式打印 LogRecord的简要摘要。
      class  XMLFormatter
      将LogRecord格式化为标准XML格式。
      Methods in java.util.logging that return Formatter
      Modifier and Type 方法 描述
      Formatter Handler.getFormatter​()
      返回 Formatter为这个 Handler 。
      Methods in java.util.logging with parameters of type Formatter
      Modifier and Type 方法 描述
      void Handler.setFormatter​(Formatter newFormatter)
      设置 Formatter 。
      Constructors in java.util.logging with parameters of type Formatter
      Constructor 描述
      StreamHandler​(OutputStream out, Formatter formatter)
      创建一个 StreamHandler与给定的 Formatter和输出流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.Handler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.Handler

  • Packages that use Handler
    软件包 描述
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。

    • Uses of Handler in java.util.logging

      Subclasses of Handler in java.util.logging
      Modifier and Type Class 描述
      class  ConsoleHandler
      此 Handler将日志记录发布到 System.err 。
      class  FileHandler
      简单的文件记录 Handler 。
      class  MemoryHandler
      Handler缓冲区内存中循环缓冲区中的请求。
      class  SocketHandler
      简单网络记录 Handler 。
      class  StreamHandler
      基于流的日志记录 Handler 。
      Methods in java.util.logging that return Handler
      Modifier and Type 方法 描述
      Handler[] Logger.getHandlers​()
      获取与此记录器关联的处理程序。
      Methods in java.util.logging with parameters of type Handler
      Modifier and Type 方法 描述
      void Logger.addHandler​(Handler handler)
      添加日志处理程序以接收日志消息。
      String Formatter.getHead​(Handler h)
      返回一组格式化记录的标题字符串。
      String XMLFormatter.getHead​(Handler h)
      返回一组XML格式记录的标题字符串。
      String Formatter.getTail​(Handler h)
      返回一组格式化记录的尾部字符串。
      String XMLFormatter.getTail​(Handler h)
      返回一组XML格式记录的尾字符串。
      void Logger.removeHandler​(Handler handler)
      删除日志处理程序。
      Constructors in java.util.logging with parameters of type Handler
      Constructor 描述
      MemoryHandler​(Handler target, int size, Level pushLevel)
      创建一个 MemoryHandler 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.Level (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.Level

  • Packages that use Level
    软件包 描述
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。

    • Uses of Level in java.util.logging

      Fields in java.util.logging declared as Level
      Modifier and Type Field 描述
      static Level Level.ALL
      ALL表示所有消息都应该被记录。
      static Level Level.CONFIG
      CONFIG是静态配置消息的消息级别。
      static Level Level.FINE
      FINE是提供跟踪信息的消息级别。
      static Level Level.FINER
      FINER表示相当详细的跟踪消息。
      static Level Level.FINEST
      FINEST表示高度详细的跟踪消息。
      static Level Level.INFO
      INFO是信息性消息的消息级别。
      static Level Level.OFF
      OFF是可用于关闭日志记录的特殊级别。
      static Level Level.SEVERE
      SEVERE是指示严重故障的消息级别。
      static Level Level.WARNING
      警告是指示潜在问题的消息级别。
      Methods in java.util.logging that return Level
      Modifier and Type 方法 描述
      Level Handler.getLevel​()
      获取日志级别，指定 Handler将记录哪些消息。
      Level Logger.getLevel​()
      获取为此记录器指定的日志级别。
      Level LogRecord.getLevel​()
      获取日志消息级别，例如Level.SEVERE。
      Level MemoryHandler.getPushLevel​()
      获取 pushLevel 。
      static Level Level.parse​(String name)
      将级别名称字符串解析为级别。
      Methods in java.util.logging with parameters of type Level
      Modifier and Type 方法 描述
      boolean Logger.isLoggable​(Level level)
      检查该记录器是否实际记录给定级别的消息。
      void Logger.log​(Level level, String msg)
      记录消息，没有参数。
      void Logger.log​(Level level, String msg, Object param1)
      使用一个对象参数记录消息。
      void Logger.log​(Level level, String msg, Object[] params)
      用一个对象参数数组记录消息。
      void Logger.log​(Level level, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息。
      void Logger.log​(Level level, Throwable thrown, Supplier<String> msgSupplier)
      记录一个懒惰构造的消息，并附带相关的Throwable信息。
      void Logger.log​(Level level, Supplier<String> msgSupplier)
      记录一条消息，只有在日志记录级别实际上记录该消息时才会被构造。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg)
      记录消息，指定源类和方法，没有参数。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg, Object param1)
      使用单个对象参数记录消息，指定源类和方法到日志消息。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg, Object[] params)
      使用对象参数数组记录消息，指定源类和方法。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类和方法。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, Throwable thrown, Supplier<String> msgSupplier)
      记录一个懒惰构造的消息，指定源类和方法以及相关联的Throwable信息。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, Supplier<String> msgSupplier)
      记录一个延迟构造的消息，指定源类和方法，没有参数。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg)
      已过时。
      改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1)
      已过时。
      改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...)
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params)
      已过时。
      改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown)
      已过时。
      改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Throwable) 。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Object... params)
      使用可选的消息参数列表记录消息，指定源类，方法和资源包。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
      void Logger.logrb​(Level level, ResourceBundle bundle, String msg, Object... params)
      使用可选的消息参数列表记录消息，指定源类，方法和资源包。
      void Logger.logrb​(Level level, ResourceBundle bundle, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
      void Handler.setLevel​(Level newLevel)
      设置日志级别，指定 Handler将记录哪些消息级别。
      void Logger.setLevel​(Level newLevel)
      设置日志级别，指定该记录器将记录哪些消息级别。
      void LogRecord.setLevel​(Level level)
      设置日志消息级别，例如Level.SEVERE。
      void MemoryHandler.setPushLevel​(Level newLevel)
      设置 pushLevel 。
      Constructors in java.util.logging with parameters of type Level
      Constructor 描述
      LogRecord​(Level level, String msg)
      使用给定的级别和消息值构造LogRecord。
      MemoryHandler​(Handler target, int size, Level pushLevel)
      创建一个 MemoryHandler 。

    • Uses of Level in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi with parameters of type Level
      Modifier and Type 方法 描述
      static void SyncFactory.setLogger​(Logger logger, Level level)
      设置由 SyncFactory SPI提供的 SyncProvider实现使用的记录对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.Logger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.Logger

  • Packages that use Logger
    软件包 描述
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。

    • Uses of Logger in java.sql

      Methods in java.sql that return Logger
      Modifier and Type 方法 描述
      Logger Driver.getParentLogger​()
      返回此驱动程序使用的所有日志记录器的父记录器。

    • Uses of Logger in java.util.logging

      Fields in java.util.logging declared as Logger
      Modifier and Type Field 描述
      static Logger Logger.global
      已过时。
      此字段的初始化容易出现死锁。 该字段必须由Logger类初始化初始化，这可能会导致与LogManager类初始化的死锁。 在这种情况下，两个类初始化等待彼此完成。 获取全局记录器对象的首选方法是通过调用Logger.getGlobal() 。 为了兼容Logger.getGlobal()不可用的旧JDK版本，请使用Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)或Logger.getLogger("global") 。
      Methods in java.util.logging that return Logger
      Modifier and Type 方法 描述
      static Logger Logger.getAnonymousLogger​()
      创建一个匿名记录器。
      static Logger Logger.getAnonymousLogger​(String resourceBundleName)
      创建一个匿名记录器。
      static Logger Logger.getGlobal​()
      返回名为Logger.GLOBAL_LOGGER_NAME的全局记录器对象。
      static Logger Logger.getLogger​(String name)
      查找或创建一个命名子系统的记录器。
      static Logger Logger.getLogger​(String name, String resourceBundleName)
      查找或创建一个命名子系统的记录器。
      Logger LogManager.getLogger​(String name)
      找到一个命名记录器的方法。
      Logger Logger.getParent​()
      返回此记录器的父级。
      Methods in java.util.logging with parameters of type Logger
      Modifier and Type 方法 描述
      boolean LogManager.addLogger​(Logger logger)
      添加一个命名记录器。
      void Logger.setParent​(Logger parent)
      设置此记录器的父级。

    • Uses of Logger in javax.sql

      Methods in javax.sql that return Logger
      Modifier and Type 方法 描述
      Logger CommonDataSource.getParentLogger​()
      返回此数据源使用的所有日志记录器的父记录器。

    • Uses of Logger in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi that return Logger
      Modifier and Type 方法 描述
      static Logger SyncFactory.getLogger​()
      返回应用程序的记录对象，以检索SyncProvider实现发布的同步事件。
      Methods in javax.sql.rowset.spi with parameters of type Logger
      Modifier and Type 方法 描述
      static void SyncFactory.setLogger​(Logger logger)
      设置由所使用的日志对象 SyncProvider由提供的实现 SyncFactory 。
      static void SyncFactory.setLogger​(Logger logger, Level level)
      设置由 SyncFactory SPI提供的 SyncProvider实现使用的记录对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.LoggingPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.LoggingPermission

No usage of java.util.logging.LoggingPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.LogManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.LogManager

  • Packages that use LogManager
    软件包 描述
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。

    • Uses of LogManager in java.util.logging

      Methods in java.util.logging that return LogManager
      Modifier and Type 方法 描述
      LogManager LogManager.addConfigurationListener​(Runnable listener)
      添加每次读取日志配置时调用的配置监听器。
      static LogManager LogManager.getLogManager​()
      返回全局LogManager对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.LogRecord (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.LogRecord

  • Packages that use LogRecord
    软件包 描述
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。

    • Uses of LogRecord in java.util.logging

      Methods in java.util.logging with parameters of type LogRecord
      Modifier and Type 方法 描述
      abstract String Formatter.format​(LogRecord record)
      格式化给定的日志记录并返回格式化的字符串。
      String SimpleFormatter.format​(LogRecord record)
      格式化给定的LogRecord。
      String XMLFormatter.format​(LogRecord record)
      将给定的消息格式化为XML。
      String Formatter.formatMessage​(LogRecord record)
      从日志记录本地化和格式化消息字符串。
      boolean Filter.isLoggable​(LogRecord record)
      检查是否应发布给定的日志记录。
      boolean Handler.isLoggable​(LogRecord record)
      检查这个 Handler是否会实际记录给定的 LogRecord 。
      boolean MemoryHandler.isLoggable​(LogRecord record)
      检查这个 Handler是否会将给定的 LogRecord实际记录到其内部缓冲区中。
      boolean StreamHandler.isLoggable​(LogRecord record)
      检查这个 Handler是否会实际记录给定的 LogRecord 。
      void Logger.log​(LogRecord record)
      登录LogRecord。
      void ConsoleHandler.publish​(LogRecord record)
      发表 LogRecord 。
      void FileHandler.publish​(LogRecord record)
      格式化并发布 LogRecord 。
      abstract void Handler.publish​(LogRecord record)
      发表 LogRecord 。
      void MemoryHandler.publish​(LogRecord record)
      将 LogRecord存储在内部缓冲区中。
      void SocketHandler.publish​(LogRecord record)
      格式化并发布 LogRecord 。
      void StreamHandler.publish​(LogRecord record)
      格式化并发布一个 LogRecord 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.MemoryHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.MemoryHandler

No usage of java.util.logging.MemoryHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.SimpleFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.SimpleFormatter

No usage of java.util.logging.SimpleFormatter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.SocketHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.SocketHandler

No usage of java.util.logging.SocketHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.StreamHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.StreamHandler

  • Packages that use StreamHandler
    软件包 描述
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。

    • Uses of StreamHandler in java.util.logging

      Subclasses of StreamHandler in java.util.logging
      Modifier and Type Class 描述
      class  ConsoleHandler
      这个 Handler将日志记录发布到 System.err 。
      class  FileHandler
      简单的文件记录 Handler 。
      class  SocketHandler
      简单网络记录 Handler 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.logging.XMLFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.logging.XMLFormatter

No usage of java.util.logging.XMLFormatter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.logging.Filter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.logging.Filter

  • Packages that use Filter
    软件包 描述
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。

    • Uses of Filter in java.util.logging

      Methods in java.util.logging that return Filter
      Modifier and Type 方法 描述
      Filter Handler.getFilter​()
      获取当前的 Filter为这 Handler 。
      Filter Logger.getFilter​()
      获取此Logger的当前过滤器。
      Methods in java.util.logging with parameters of type Filter
      Modifier and Type 方法 描述
      void Handler.setFilter​(Filter newFilter)
      设置 Filter以控制此 Handler输出。
      void Logger.setFilter​(Filter newFilter)
      设置一个过滤器来控制此记录器的输出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.logging.LoggingMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.logging.LoggingMXBean

  • Packages that use LoggingMXBean
    软件包 描述
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。

    • Uses of LoggingMXBean in java.util.logging

      Methods in java.util.logging that return LoggingMXBean
      Modifier and Type 方法 描述
      static LoggingMXBean LogManager.getLoggingMXBean​()
      已过时。
      java.util.logging.LoggingMXBean已被弃用，替换为java.lang.management.PlatformLoggingMXBean 。 改用ManagementFactory.getPlatformMXBean （PlatformLoggingMXBean.class）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AbstractPreferences (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.prefs
软件包 java.util.prefs

Class AbstractPreferences

  • java.lang.Object
    • java.util.prefs.Preferences
      • java.util.prefs.AbstractPreferences

  • public abstract class AbstractPreferences
extends Preferences
    这个类提供了一个Preferences类的骨架实现，大大简化了实现它的任务。

    这个类只适用于Preferences实现者。 Preferences工厂的普通用户不需要查阅本文档。 Preferences文档应该足够了。

    实现者必须重写九个抽象服务提供者接口（SPI）方法： getSpi(String) ， putSpi(String,String) ， removeSpi(String) ， childSpi(String) ， removeNodeSpi() ， keysSpi() ， childrenNamesSpi() ， syncSpi()和flushSpi() 。 所有具体的方法都精确地指定了如何在这些SPI方法之上实现它们。 如果默认实现由于任何原因（例如性能）而不能令人满意，则实施者可以自行决定覆盖一个或多个具体方法。

    SPI方法分为三组关于异常行为。 getSpi方法不应该抛出异常，但并不重要，因为此方法抛出的任何异常都将被get(String,String)截取，这将返回给调用者指定的默认值。 removeNodeSpi, keysSpi, childrenNamesSpi, syncSpi和flushSpi方法被指定为抛出BackingStoreException ，如果无法执行该操作，则需要执行该抛出异常。 该异常向外传播，导致相应的API方法失败。

    其余的SPI方法putSpi(String,String) ， removeSpi(String)和childSpi(String)有更复杂的异常行为。 它们没有被指定为抛出BackingStoreException ，因为他们通常可以服从他们的合同，即使后备商店不可用。 这是真的，因为它们不会返回任何信息，并且在后续调用Preferences.flush()或Preferences.sync()时 ，它们的效果不需要变为永久性。 一般来说，这些SPI方法不应该抛出异常。 在一些实现中，可能存在这样的情况，这些呼叫甚至不能排队所请求的操作以供稍后处理。 即使在这种情况下，通常最好简单地忽略调用和返回，而不是抛出异常。 然而，在这种情况下，随后调用flush()或sync并不意味着所有以前的操作都成功地被永久化。

    有一种情况下， putSpi, removeSpi and childSpi 应该抛出异常：如果调用者对底层操作系统没有足够的权限来执行请求的操作。 例如，如果非特权用户尝试修改系统首选项，这将在大多数系统上发生。 （所需的权限将从实现到实现有所不同，在某些实现中，它们是修改文件系统中某些目录的内容的权利;在其他实现中，它们是修改注册表中某些密钥的内容的权利。）在任何在这种情况下，通常不宜让程序继续执行，就好像这些操作将在以后永久存在一样。 虽然在这种情况下实现不需要抛出异常，但是鼓励它们这样做。 A SecurityException将是适当的。

    大多数SPI方法需要实现在首选节点读取或写入信息。 实施者应该注意，另一个VM可能同时从后备存储中删除该节点。 重新创建节点（如果已被删除）的实施是有责任的。

    实现说明：在Sun的默认Preferences实现中，用户的身份从底层操作系统继承，并且在虚拟机的生命周期内不会更改。 应当认识到，服务器端的Preferences实现可以使用户身份从请求到请求的变化，通过使用静态的ThreadLocal实例来隐含地传递给Preferences方法。 强烈鼓励这种实现的作者在访问偏好时（例如通过get(String,String)或put(String,String)方法）来确定用户，而不是将用户永久地关联到每个Preferences实例。 后者的行为与正常的Preferences使用冲突，并将导致很大的混乱。

    从以下版本开始：
    1.4
    另请参见：
    Preferences

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Object lock
      监视器用于锁定此节点的对象。
      protected boolean newNode
      如果此节点在创建此对象之前在后台存储中不存在，则此字段应为 true 。

      • Fields inherited from class java.util.prefs.Preferences

        MAX_KEY_LENGTH, MAX_NAME_LENGTH, MAX_VALUE_LENGTH

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractPreferences​(AbstractPreferences parent, String name)
      创建具有指定父项和相对于其父对象的指定名称的首选项节点。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      String absolutePath​()
      实现 absolutePath方法按照在本说明书中 Preferences.absolutePath() 。
      void addNodeChangeListener​(NodeChangeListener ncl)
      注册指定的侦听器以接收该节点的 节点更改事件 。
      void addPreferenceChangeListener​(PreferenceChangeListener pcl)
      注册指定的侦听器以接收此首选项节点的 优先级更改事件 。
      protected AbstractPreferences[] cachedChildren​()
      返回此节点的所有已知未被删除的子节点。
      String[] childrenNames​()
      实现 children方法按照在本说明书中 Preferences.childrenNames() 。
      protected abstract String[] childrenNamesSpi​()
      返回此首选项节点的子节点的名称。
      protected abstract AbstractPreferences childSpi​(String name)
      返回此首选项节点的命名子节点，如果它不存在则创建它。
      void clear​()
      实现 clear方法按照在本说明书中 Preferences.clear() 。
      void exportNode​(OutputStream os)
      实现 exportNode方法按照在本说明书中 Preferences.exportNode(OutputStream) 。
      void exportSubtree​(OutputStream os)
      实现 exportSubtree方法按照在本说明书中 Preferences.exportSubtree(OutputStream) 。
      void flush​()
      实现 flush方法按照在本说明书中 Preferences.flush() 。
      protected abstract void flushSpi​()
      此方法在此节点锁定时被调用。
      String get​(String key, String def)
      实现 get方法按照在本说明书中 Preferences.get(String,String) 。
      boolean getBoolean​(String key, boolean def)
      实现 getBoolean方法按照在本说明书中 Preferences.getBoolean(String,boolean) 。
      byte[] getByteArray​(String key, byte[] def)
      实现 getByteArray方法按照在本说明书中 Preferences.getByteArray(String,byte[]) 。
      protected AbstractPreferences getChild​(String nodeName)
      如果命名的子项存在，则返回它，否则 null 。
      double getDouble​(String key, double def)
      实现 getDouble方法按照在本说明书中 Preferences.getDouble(String,double) 。
      float getFloat​(String key, float def)
      实现 getFloat方法按照在本说明书中 Preferences.getFloat(String,float) 。
      int getInt​(String key, int def)
      实现 getInt方法按照在本说明书中 Preferences.getInt(String,int) 。
      long getLong​(String key, long def)
      实现 getLong方法按照在本说明书中 Preferences.getLong(String,long) 。
      protected abstract String getSpi​(String key)
      在此首选项节点返回与指定键相关联的值，如果此键不存在关联，则 null ，否则此时无法确定关联。
      protected boolean isRemoved​()
      返回 true iff此节点（或祖先）已使用 removeNode()方法删除。
      boolean isUserNode​()
      实现 isUserNode方法按照在本说明书中 Preferences.isUserNode() 。
      String[] keys​()
      实现 keys方法按照在本说明书中 Preferences.keys() 。
      protected abstract String[] keysSpi​()
      返回在此首选项节点中具有关联值的所有键。
      String name​()
      实现 name方法按照在本说明书中 Preferences.name() 。
      Preferences node​(String path)
      实现 node方法按照在本说明书中 Preferences.node(String) 。
      boolean nodeExists​(String path)
      实现 nodeExists方法按照在本说明书中 Preferences.nodeExists(String) 。
      Preferences parent​()
      实现 parent方法按照在本说明书中 Preferences.parent() 。
      void put​(String key, String value)
      实现 put方法按照在本说明书中 Preferences.put(String,String) 。
      void putBoolean​(String key, boolean value)
      实现 putBoolean方法按照在本说明书中 Preferences.putBoolean(String,boolean) 。
      void putByteArray​(String key, byte[] value)
      实现 putByteArray方法按照在本说明书中 Preferences.putByteArray(String,byte[]) 。
      void putDouble​(String key, double value)
      实现 putDouble方法按照在本说明书中 Preferences.putDouble(String,double) 。
      void putFloat​(String key, float value)
      实现 putFloat方法按照在本说明书中 Preferences.putFloat(String,float) 。
      void putInt​(String key, int value)
      实现 putInt方法按照在本说明书中 Preferences.putInt(String,int) 。
      void putLong​(String key, long value)
      实现 putLong方法按照在本说明书中 Preferences.putLong(String,long) 。
      protected abstract void putSpi​(String key, String value)
      将给定的键值关联放入此首选项节点。
      void remove​(String key)
      实现 remove(String)方法按照在本说明书中 Preferences.remove(String) 。
      void removeNode​()
      实现 removeNode()方法按照在本说明书中 Preferences.removeNode() 。
      void removeNodeChangeListener​(NodeChangeListener ncl)
      删除指定的 NodeChangeListener ，所以它不再收到更改事件。
      protected abstract void removeNodeSpi​()
      删除此首选项节点，使其无效及其包含的任何首选项。
      void removePreferenceChangeListener​(PreferenceChangeListener pcl)
      删除指定的首选项更改侦听器，因此它不再接收首选项更改事件。
      protected abstract void removeSpi​(String key)
      删除此首选项节点上指定键的关联（如果有）。
      void sync​()
      实现 sync方法按照在本说明书中 Preferences.sync() 。
      protected abstract void syncSpi​()
      此方法在此节点锁定时被调用。
      String toString​()
      返回此首选项节点的绝对路径名。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.util.prefs.Preferences

        importPreferences, systemNodeForPackage, systemRoot, userNodeForPackage, userRoot

    • 字段详细信息

      • newNode

        protected boolean newNode
        如果此节点在创建此对象之前在后台存储中不存在，则此字段应为true 。 该字段初始化为false，但可以由子类构造函数设置为true（此后不应修改）。 此字段指示创建完成时是否应触发节点更改事件。

      • lock

        protected final Object lock
        监视器用于锁定此节点的对象。 该对象优先于节点本身，以减少由于锁定节点而导致的故意或无意拒绝服务的可能性。 为了避免死锁，一个节点永远不会被一个线程锁定，该线程在该节点的后代保持锁定。

    • 构造方法详细信息

      • AbstractPreferences

        protected AbstractPreferences​(AbstractPreferences parent,
                              String name)
        创建具有指定父项和相对于其父对象的指定名称的首选项节点。
        参数
        parent - 此首选项节点的父节点，如果为根，则为null。
        name - 此首选项节点的名称，相对于其父节点，或 ""如果这是根）。
        异常
        IllegalArgumentException - 如果 name包含斜杠（ '/' ），或 parent是 null并且名称不是 "" 。

    • 方法详细信息

      • put

        public void put​(String key,
                String value)
        实现put方法按照在本说明书中Preferences.put(String,String) 。

        该实现检查密钥和值是否合法，获取此偏好节点的锁定，检查节点是否尚未被删除，调用putSpi(String,String) ，如果有任何偏好更改侦听器，则将通知事件排入队列以进行事件分派线程处理。

        Specified by:
        put在 Preferences
        参数
        key - 指定值与之关联的键。
        value - 与指定键相关联的值。
        异常
        NullPointerException - 如果键或值为 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH或如果 value.length超过 MAX_VALUE_LENGTH 。
        IllegalArgumentException - 如果任一键或值包含空控制字符，则代码点U + 0000。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。

      • get

        public String get​(String key,
                  String def)
        实现get方法按照在本说明书中Preferences.get(String,String) 。

        这个实现首先检查是否key是null抛出一个NullPointerException如果是这种情况。 然后它获取此首选项节点的锁定，检查节点是否尚未被删除，调用getSpi(String) ，并返回结果，除非getSpi调用返回null或引发异常，在这种情况下，此调用将返回def 。

        Specified by:
        get在 Preferences
        参数
        key - 要返回其关联值的键。
        def - 在此首选项节点没有与 key相关联的值的情况下返回的值。
        结果
        值相关联 key ，或 def如果没有值相关联 key 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果键是null 。 （A null 是默认值。）
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。

      • remove

        public void remove​(String key)
        实现remove(String)方法按照在本说明书中Preferences.remove(String) 。

        此实现获取此首选项节点的锁定，检查节点是否尚未被删除，调用removeSpi(String)，并且如果有任何首选项更改侦听器，则将通知事件入队由事件分派线程处理。

        Specified by:
        remove在 Preferences
        参数
        key - 要从偏好节点删除其映射的密钥。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        NullPointerException - 如果 key是 null ..

      • clear

        public void clear​()
           throws BackingStoreException
        实现clear方法按照在本说明书中Preferences.clear() 。

        此实现获得此首选项节点的锁定，调用keys()获取一个键数组，并在每个键上迭代数组调用remove(String) 。

        Specified by:
        clear在 Preferences
        异常
        BackingStoreException - 如果由于后备存储器故障或无法与之通信，此操作无法完成。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        Preferences.removeNode()

      • putInt

        public void putInt​(String key,
                   int value)
        实现putInt方法按照在本说明书中Preferences.putInt(String,int) 。

        此实现将value转换为value的字符串， 并对结果调用put(String,String) 。

        Specified by:
        putInt在 Preferences
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与密钥相关联的值。
        异常
        NullPointerException - 如果键是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        Preferences.getInt(String,int)

      • getInt

        public int getInt​(String key,
                  int def)
        实现getInt方法按照在本说明书中Preferences.getInt(String,int) 。

        此实现调用get(key, null) 。 如果返回值不为空，则该实现将尝试将其转换为int与Integer.parseInt(String) 。 如果尝试成功，则返回值由此方法返回。 否则返回def 。

        Specified by:
        getInt在 Preferences
        参数
        key - 其关联值将作为int返回的键。
        def - 如果此首选项节点没有与 key相关联的值或相关联的值不能被解释为int，则返回值。
        结果
        由此偏好节点中与 key相关联的字符串表示的int值，如果关联值不存在或不能解释为int， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        Preferences.putInt(String,int) ， Preferences.get(String,String)

      • putLong

        public void putLong​(String key,
                    long value)
        实现putLong方法按照在本说明书中Preferences.putLong(String,long) 。

        该实现将value转换为value的字符串， 并对结果调用put(String,String) 。

        Specified by:
        putLong在 Preferences
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键关联的值。
        异常
        NullPointerException - 如果键是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        Preferences.getLong(String,long)

      • getLong

        public long getLong​(String key,
                    long def)
        实现getLong方法按照在本说明书中Preferences.getLong(String,long) 。

        此实现调用get(key, null) 。 如果返回值不为空，则该实现将尝试将其转换为long其中包含Long.parseLong(String) 。 如果尝试成功，则返回值由此方法返回。 否则返回def 。

        Specified by:
        getLong在 Preferences
        参数
        key - 其关联值将作为长期返回的键。
        def - 如果此首选项节点没有与 key相关联的值或相关联的值不能被解释为长时间，则返回的值。
        结果
        由此偏好节点中与 key相关联的字符串表示的长值，如果关联值不存在或不能解释为长时间， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        Preferences.putLong(String,long) ， Preferences.get(String,String)

      • putBoolean

        public void putBoolean​(String key,
                       boolean value)
        实现putBoolean方法按照在本说明书中Preferences.putBoolean(String,boolean) 。

        此实现将value转换为value的字符串， 并对结果调用put(String,String) 。

        Specified by:
        putBoolean在 Preferences
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与密钥相关联的值。
        异常
        NullPointerException - 如果键是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        Preferences.getBoolean(String,boolean) ， Preferences.get(String,String)

      • getBoolean

        public boolean getBoolean​(String key,
                          boolean def)
        实现getBoolean方法按照在本说明书中Preferences.getBoolean(String,boolean) 。

        此实现调用get(key, null) 。 如果返回值为非空值，则使用String.equalsIgnoreCase(String)与"true"进行比较 。 如果比较返回true ，则此调用返回true 。 否则，原始返回值与"false"进行比较，再次使用String.equalsIgnoreCase(String) 。 如果比较返回true ，则此调用返回false 。 否则，此调用返回def 。

        Specified by:
        getBoolean在 Preferences
        参数
        key - 其关联值将作为布尔值返回的键。
        def - 如果此首选项节点没有与 key关联的值或相关联的值不能被解释为布尔值，则返回值。
        结果
        由此偏好节点中与 key相关联的字符串表示的布尔值，如果关联值不存在或不能解释为布尔值， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        Preferences.get(String,String) ， Preferences.putBoolean(String,boolean)

      • putFloat

        public void putFloat​(String key,
                     float value)
        实现putFloat方法按照在本说明书中Preferences.putFloat(String,float) 。

        此实现将value转换为value的字符串， 并对结果调用put(String,String) 。

        Specified by:
        putFloat在 Preferences
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键相关联的值。
        异常
        NullPointerException - 如果键是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        Preferences.getFloat(String,float)

      • getFloat

        public float getFloat​(String key,
                      float def)
        实现getFloat方法按照在本说明书中Preferences.getFloat(String,float) 。

        此实现调用get(key, null) 。 如果返回值不为空，则该实现将尝试将其转换为float （ Float.parseFloat(String)） 。 如果尝试成功，则返回值由此方法返回。 否则返回def 。

        Specified by:
        getFloat在 Preferences
        参数
        key - 其关联值将作为浮点数返回的键。
        def - 如果此首选项节点没有与 key相关联的值或相关联的值不能被解释为浮点数时返回的值。
        结果
        由此偏好节点中与 key相关联的字符串表示的浮点值，如果关联值不存在或不能解释为浮点数， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        Preferences.putFloat(String,float) ， Preferences.get(String,String)

      • putDouble

        public void putDouble​(String key,
                      double value)
        实现putDouble方法按照在本说明书中Preferences.putDouble(String,double) 。

        此实现将value转换为带有Double.toString(double)的字符串， 并对结果调用put(String,String) 。

        Specified by:
        putDouble在 Preferences
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键关联的值。
        异常
        NullPointerException - 如果键是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        Preferences.getDouble(String,double)

      • getDouble

        public double getDouble​(String key,
                        double def)
        实现getDouble方法按照在本说明书中Preferences.getDouble(String,double) 。

        此实现调用get(key, null) 。 如果返回值不为空，则该实现将尝试将其转换为double （ Double.parseDouble(String)） 。 如果尝试成功，则返回值由此方法返回。 否则返回def 。

        Specified by:
        getDouble在 Preferences
        参数
        key - 其关联值将以双 key返回的键。
        def - 如果此首选项节点没有与 key关联的值或相关联的值不能被解释为双 key ，则返回的值。
        结果
        由此偏好节点中与 key相关联的字符串表示的双 def值，如果关联值不存在或不能解释为双 def值， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        Preferences.putDouble(String,double) ， Preferences.get(String,String)

      • putByteArray

        public void putByteArray​(String key,
                         byte[] value)
        实现 putByteArray方法按照在本说明书中 Preferences.putByteArray(String,byte[]) 。
        Specified by:
        putByteArray在类 Preferences
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键关联的值。
        异常
        NullPointerException - 如果键值或值为 null 。
        IllegalArgumentException - 如果key.length（）超过MAX_KEY_LENGTH或者如果value.length超过MAX_VALUE_LENGTH * 3/4。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        Preferences.getByteArray(String,byte[]) ， Preferences.get(String,String)

      • getByteArray

        public byte[] getByteArray​(String key,
                           byte[] def)
        实现 getByteArray方法按照在本说明书中 Preferences.getByteArray(String,byte[]) 。
        Specified by:
        getByteArray在 Preferences
        参数
        key - 将其关联值作为字节数组返回的键。
        def - 如果此首选项节点没有与 key相关联的值或相关联的值不能被解释为字节数组，则返回值。
        结果
        由此偏好节点中与 key相关联的字符串表示的字节数组值，如果关联值不存在或不能解释为字节数组，则表示 def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果key是null 。 （A null值为def ） 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        Preferences.get(String,String) ， Preferences.putByteArray(String,byte[])

      • keys

        public String[] keys​()
              throws BackingStoreException
        实现keys方法按照在本说明书中Preferences.keys() 。

        此实现获取此首选节点的锁定，检查节点是否尚未被删除并调用keysSpi() 。

        Specified by:
        keys在 Preferences
        结果
        在此首选项节点中具有关联值的键的数组。
        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与其进行通信，此操作无法完成。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。

      • childrenNames

        public String[] childrenNames​()
                       throws BackingStoreException
        实现children方法按照在本说明书中Preferences.childrenNames() 。

        此实现获取此首选项节点的锁，检查该节点已不被删除，构建了一个TreeSet初始化为已缓存的孩子（在此节点的“子缓存”孩子们）的名字，调用childrenNamesSpi() ，并将所有返回的子名进入集合。 使用toArray方法将树集的元素转储到String阵列中，并返回此数组。

        Specified by:
        childrenNames在 Preferences
        结果
        此偏好节点的子节点名称。
        异常
        BackingStoreException - 如果由于后备存储中的故障导致此操作无法完成，或无法与之通信。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        cachedChildren()

      • cachedChildren

        protected final AbstractPreferences[] cachedChildren​()
        返回此节点的所有已知未被删除的子节点。
        结果
        这个节点的所有已知的未被删除的子节点。

      • parent

        public Preferences parent​()
        实现parent方法按照在本说明书中Preferences.parent() 。

        此实现获取此首选项节点的锁定，检查节点是否尚未被删除并返回传递给该节点的构造函数的父值。

        Specified by:
        parent在 Preferences
        结果
        此首选项节点的父级。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。

      • node

        public Preferences node​(String path)
        实现node方法按照在本说明书中Preferences.node(String) 。

        此实现获取此首选节点的锁定并检查节点是否尚未被删除。 如果path为"" ，则返回该节点; 如果path为"/" ，则返回该节点的根。 如果第一个字符path不'/' ，实施突破path为标记和递归遍历从该节点到指定节点的路径，“消费”的姓名和斜线path在遍历的每一步。 在每个步骤中，当前节点被锁定，并且为命名节点检查节点的子缓存。 如果找不到，将检查名称以确保其长度不超过MAX_NAME_LENGTH 。 然后调用childSpi(String)方法，结果存储在此节点的子缓存中。 如果新创建的Preferences对象的newNode字段为true并且有任何节点更改侦听器， true通知事件排入队列，以便事件分派线程进行处理。

        当没有更多的令牌时，通过此方法返回在子缓存中找到的最后一个值或由childSpi返回的值。 如果在遍历期间，连续出现两个"/"令牌，或者最后一个令牌是"/" （而不是一个名称），则抛出适当的IllegalArgumentException 。

        如果path的第一个字符为'/' （表示绝对路径名称），则在将path分解为令牌之前，将首选节点的锁定被删除，并且此方法递归地遍历从根开始的路径（而不是从该节点开始）。 遍历与所描述的相对路径名称相同。 根据locking invariant ，在根节点开始遍历之前删除此节点上的锁是至关重要的，以避免死锁的可能性。

        Specified by:
        node在 Preferences
        参数
        path - 要返回的首选项节点的路径名。
        结果
        指定的首选项节点。
        异常
        IllegalArgumentException - 如果路径名无效（即，它包含多个连续的斜杠字符，或以斜杠字符结尾，并且长度超过一个字符）。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        Preferences.flush()

      • nodeExists

        public boolean nodeExists​(String path)
                   throws BackingStoreException
        实现nodeExists方法按照在本说明书中Preferences.nodeExists(String) 。

        这个实现非常类似于node(String) ，除了使用getChild(String)而不是childSpi(String) 。

        Specified by:
        nodeExists在类 Preferences
        参数
        path - 要检查其存在的节点的路径名。
        结果
        如果指定的节点存在，则为true。
        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与之通信，此操作无法完成。
        IllegalArgumentException - 如果路径名称无效（即，它包含多个连续的斜杠字符，或以斜杠字符结尾，并且长度超过一个字符）。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除，并且 pathname不是空字符串（ "" ）。

      • removeNode

        public void removeNode​()
                throws BackingStoreException
        实现removeNode()方法按照在本说明书中Preferences.removeNode() 。

        该实现检查以查看该节点是否为根; 如果是这样，它会引发适当的异常。 然后，它锁定该节点的父节点，并调用遍历通过此节点生成的子树的递归辅助方法。 递归方法锁定其所调用的节点，检查它尚未被删除的节点，然后确保其所有子节点被缓存：调用childrenNamesSpi()方法，并检查每个返回的子名称，缓存。 如果尚未缓存小孩，则会调用childSpi(String)方法为其创建一个Preferences实例，并将此实例放入子缓存中。 然后，辅助方法在其子缓存中包含的每个节点上递归调用自身。 接下来，它调用removeNodeSpi() ，将其标记为已删除，并将其自身从其父级缓存中删除。 最后，如果有任何节点更改侦听器，它会将通知事件排入队列，以便事件发送线程进行处理。

        请注意，所有祖先始终调用助手方法，直到“最近的未删除祖先”被锁定。

        Specified by:
        removeNode在 Preferences
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        UnsupportedOperationException - 如果在根节点上调用此方法。
        BackingStoreException - 如果由于后备存储器中的故障导致此操作无法完成，或无法与之通信。
        另请参见：
        Preferences.flush()

      • name

        public String name​()
        实现name方法按照在本说明书中Preferences.name() 。

        此实现仅返回传递给此节点构造函数的名称。

        Specified by:
        name在 Preferences
        结果
        此首选项节点的名称，相对于其父节点。

      • absolutePath

        public String absolutePath​()
        实现absolutePath方法按照在本说明书中Preferences.absolutePath() 。

        此实现仅返回在构建此节点时计算的绝对路径名（基于传递给此节点的构造函数的名称以及传递给此节点的祖先构造函数的名称）。

        Specified by:
        absolutePath在 Preferences
        结果
        这个偏好节点的绝对路径名。

      • isUserNode

        public boolean isUserNode​()
        实现isUserNode方法按照在本说明书中Preferences.isUserNode() 。

        此实现将此节点的根节点（存储在专用字段中）与Preferences.userRoot()返回的值进行比较 。 如果两个对象引用相同，则此方法返回true。

        Specified by:
        isUserNode在 Preferences
        结果
        true如果此首选项节点在用户首选项树中， false如果它在系统首选项树中。

      • addPreferenceChangeListener

        public void addPreferenceChangeListener​(PreferenceChangeListener pcl)
        说明从类别复制： Preferences
        注册指定的侦听器以接收此首选项节点的优先级更改事件 。 当偏好被添加到该节点，从该节点移除时，或者当与偏好相关联的值被改变时，生成偏好改变事件。 （偏好改变事件不会由所产生的Preferences.removeNode()方法，该方法生成事件 。优选变化事件是由所生成的节点改变 clear方法）。

        事件只能保证在与注册的侦听器相同的JVM中进行的更改，尽管某些实现可能会为此JVM之外的更改生成事件。 可能在更改持续存在之前生成事件。 当在该节点的后代修改首选项时，不会生成事件; 想要这样的事件的主叫必须向每个后代注册。

        Specified by:
        addPreferenceChangeListener在 Preferences
        参数
        pcl - 要添加的首选项更改侦听器。
        另请参见：
        Preferences.removePreferenceChangeListener(PreferenceChangeListener) ， Preferences.addNodeChangeListener(NodeChangeListener)

      • removePreferenceChangeListener

        public void removePreferenceChangeListener​(PreferenceChangeListener pcl)
        描述从类复制： Preferences
        删除指定的首选项更改侦听器，因此它不再接收首选项更改事件。
        Specified by:
        removePreferenceChangeListener在 Preferences
        参数
        pcl - 要删除的首选项更改侦听器。
        另请参见：
        Preferences.addPreferenceChangeListener(PreferenceChangeListener)

      • addNodeChangeListener

        public void addNodeChangeListener​(NodeChangeListener ncl)
        描述从类复制： Preferences
        注册指定的侦听器以接收该节点的节点更改事件 。 当子节点添加到该节点或从该节点移除时，将生成节点更改事件。 （单个Preferences.removeNode()调用导致多个节点更改事件 ，一个针对根除在已删除节点的子树中的每个节点）。

        事件只能保证在与注册的侦听器相同的JVM中进行的更改，尽管某些实现可能会为此JVM之外的更改生成事件。 在更改变得永久之前可能会生成事件。 当添加或删除此节点的间接后代时，不会生成事件; 想要这样的事件的主叫必须向每个后代注册。

        关于节点创建几乎不能保证。 因为在访问时隐式创建节点，因此实现可能无法确定在访问之前后备存储中是否存在子节点（例如，因为后备存储不可达或缓存的信息已过期）。 在这种情况下，实现既不需要生成节点更改事件，也不禁止这样做。

        Specified by:
        addNodeChangeListener在 Preferences
        参数
        ncl - 要添加的 NodeChangeListener 。
        另请参见：
        Preferences.removeNodeChangeListener(NodeChangeListener) ， Preferences.addPreferenceChangeListener(PreferenceChangeListener)

      • removeNodeChangeListener

        public void removeNodeChangeListener​(NodeChangeListener ncl)
        描述从类复制： Preferences
        删除指定的 NodeChangeListener ，所以它不再收到更改事件。
        Specified by:
        removeNodeChangeListener在 Preferences
        参数
        ncl - 要删除的 NodeChangeListener 。
        另请参见：
        Preferences.addNodeChangeListener(NodeChangeListener)

      • putSpi

        protected abstract void putSpi​(String key,
                               String value)
        将给定的键值关联放入此首选项节点。 保证key和value为非空且合法的长度。 此外，保证该节点尚未被删除。 （实施者不需要检查任何这些事情。）

        这个方法是用这个节点上的锁来调用的。

        参数
        key - 关键
        value - 值

      • getSpi

        protected abstract String getSpi​(String key)
        在此首选项节点返回与指定键相关联的值，如果此键不存在关联，则null ，否则此时无法确定关联。 保证key不为空。 此外，保证该节点尚未被删除。 （实现者不需要检查这些东西。）

        一般来说，这种方法在任何情况下都不应该抛出异常。 但是，如果它抛出异常，该异常将被拦截并被视为一个null返回值。

        这个方法是用这个节点上的锁来调用的。

        参数
        key - 关键
        结果
        与此首选项节点上指定的键相关联的值，如果此键不存在关联， null ，或者此时无法确定关联。

      • removeSpi

        protected abstract void removeSpi​(String key)
        删除此首选项节点上指定键的关联（如果有）。 保证key不为空。 此外，保证该节点尚未被删除。 （实现者不需要检查这些东西。）

        这个方法是用这个节点上的锁来调用的。

        参数
        key - 关键

      • removeNodeSpi

        protected abstract void removeNodeSpi​()
                               throws BackingStoreException
        删除此首选项节点，使其无效及其包含的任何首选项。 命名的子进程在调用时不会有后代（即， Preferences.removeNode()方法以自下而上的方式重复此方法，在删除节点本身之前删除节点的后代）。

        此方法是使用该节点及其父（并且作为单次调用的结果被删除的所有祖先到Preferences.removeNode() ）保持的锁来调用的。

        在该节点（或祖先）上调用flush方法之前，不需要删除节点。

        如果此节点抛出一个BackingStoreException ，异常将传播超出封闭的removeNode()调用。

        异常
        BackingStoreException - 如果由于后备存储器中的故障导致此操作无法完成，或无法与之通信。

      • keysSpi

        protected abstract String[] keysSpi​()
                             throws BackingStoreException
        返回在此首选项节点中具有关联值的所有键。 （如果此节点没有首选项，则返回的数组的大小为零）。保证该节点尚未被删除。

        这个方法是用这个节点上的锁来调用的。

        如果此节点抛出一个BackingStoreException ，异常将传播超出封闭的keys()调用。

        结果
        在此首选项节点中具有关联值的键的数组。
        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与其进行通信，则此操作无法完成。

      • childrenNamesSpi

        protected abstract String[] childrenNamesSpi​()
                                      throws BackingStoreException
        返回此首选项节点的子节点的名称。 （如果此节点没有子节点，则返回的数组的大小为零）。此方法不需要返回任何已缓存的节点的名称，但可能没有损害。

        这个方法是用这个节点上的锁来调用的。

        如果这个节点抛出一个BackingStoreException ，这个异常将传播超出封闭的childrenNames()调用。

        结果
        一个包含此首选项节点的子节点名称的数组。
        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与之通信，此操作无法完成。

      • getChild

        protected AbstractPreferences getChild​(String nodeName)
                                throws BackingStoreException
        如果命名的子项存在，则返回它，否则null 。 保证nodeName为非空，非空，不包含斜杠字符（'/'），不超过Preferences.MAX_NAME_LENGTH个字符。 此外，保证该节点尚未被删除。 （如果他选择覆盖这种方法，那么实现者不需要检查这些事情。）

        最后，保证命名的节点在上次调用该方法之后还没有被返回，或者在最后一次被删除之后才被返回childSpi(java.lang.String) 。 换句话说，缓存的值将始终优先于调用此方法。 （如果他选择覆盖此方法，那么实现者不需要维护自己先前返回的孩子的缓存。）

        此实现获取此首选项节点的锁定，调用childrenNames()以获取此节点子节点名称的数组，然后迭代数组，将每个子节点的名称与指定的节点名称进行比较。 如果子节点具有正确的名称，则调用childSpi(String)方法，并返回结果节点。 如果迭代完成而没有找到指定的名称，则返回null 。

        参数
        nodeName - 要搜索的小孩的姓名。
        结果
        命名的子项（如果存在），如果不存在则为null。
        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与之通信，此操作无法完成。

      • childSpi

        protected abstract AbstractPreferences childSpi​(String name)
        返回此首选项节点的命名子节点，如果它不存在则创建它。 保证name为非空，非空，不包含斜杠字符（'/'），不超过Preferences.MAX_NAME_LENGTH个字符。 此外，保证该节点尚未被删除。 （实施者不需要检查任何这些事情。）

        最后，确保命名的节点在上次调用该方法之后还没有被返回，或者在最后一次被删除之后是getChild(String) 。 换句话说，缓存的值将始终优先于调用此方法。 子类不需要维护自己先前返回的子节点的缓存。

        实现者必须确保返回的节点尚未被删除。 如果先前删除了这个节点的一个相似的子节点，那么实现者必须返回一个新构建的AbstractPreferences节点; 一旦删除，一个AbstractPreferences节点不能“复苏”。

        如果此方法导致创建节点，则在该节点或其祖先（或后代）上调用flush方法之前，不会保证此节点是持久的。

        这个方法是用这个节点上的锁来调用的。

        参数
        name - 相对于此首选项节点返回的子节点的名称。
        结果
        命名的子节点。

      • toString

        public String toString​()
        返回此首选项节点的绝对路径名。
        Specified by:
        toString在 Preferences
        结果
        对象的字符串表示形式。

      • sync

        public void sync​()
          throws BackingStoreException
        实现sync方法按照在本说明书中Preferences.sync() 。

        此实现调用一个递归的帮助程序来锁定此节点，调用它上的syncSpi（），解锁该节点，并递归地调用每个“缓存的子”的方法。 缓存的子节点是此虚拟机中已创建但未随后删除的此节点的子节点。 实际上，该方法对根据此节点的“高速缓存子树”进行深度优先遍历，仅在该节点被锁定时调用子树中每个节点上的syncSpi（）。 请注意，syncSpi（）是从上而下调用的。

        Specified by:
        sync在 Preferences
        异常
        BackingStoreException - 如果由于后备存储器中的故障导致此操作无法完成，或无法与之通信。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        flush()

      • syncSpi

        protected abstract void syncSpi​()
                         throws BackingStoreException
        此方法在此节点锁定时被调用。 此方法的合同是将存储在此节点的任何缓存首选项与存储在后备存储中的任何内容进行同步。 （这是完全可能的，这点上不支持存储存在，可能是因为它已被其他虚拟机删除，或者因为它尚未创建）。注意，在这个任意子节点，此方法不应同步偏好节点。 如果后台存储自动同步整个子树，则鼓励实现者重写sync（），而不是仅仅覆盖此方法。

        如果此节点抛出一个BackingStoreException ，异常将传播超出封闭的sync()调用。

        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与之通信，此操作无法完成。

      • flush

        public void flush​()
           throws BackingStoreException
        实现flush方法按照在本说明书中Preferences.flush() 。

        此实现调用一个递归帮助程序来锁定此节点，调用其上的flushSpi（），解锁此节点，并递归地在每个“缓存的子节点”上调用此方法。 缓存的子节点是此虚拟机中已创建但未随后删除的此节点的子节点。 实际上，此方法会深入第一遍遍历此节点的“缓存子树”，在子树中的每个节点上调用flushSpi（），而只锁定该节点。 请注意，flushSpi（）是从上而下调用的。

        如果在已使用removeNode()方法删除的节点上调用此方法，则在此节点上调用flushSpi（），但不调用其他节点。

        Specified by:
        flush在 Preferences
        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与之通信，此操作无法完成。
        另请参见：
        flush()

      • flushSpi

        protected abstract void flushSpi​()
                          throws BackingStoreException
        此方法在此节点锁定时被调用。 此方法的合同是强制将此偏好节点的内容中的任何缓存更改加入后备存储，以保证其持久性。 （这是完全可能的是，该节点上不后备存储器中存在，或者是因为它已被另一个VM删除，或因为它尚未被创建）。注意，在此任何子节点此方法不应冲洗喜好节点。 如果后台存储自动刷新整个子树，则鼓励实现者重写flush（），而不是仅仅覆盖此方法。

        如果此节点抛出一个BackingStoreException ，异常将传播超出封闭的flush()调用。

        异常
        BackingStoreException - 如果由于后备存储器中的故障导致此操作无法完成，或无法与之通信。

      • isRemoved

        protected boolean isRemoved​()
        返回true如果此节点（或其祖先）已经被除去的removeNode()方法。 此方法在返回用于跟踪此状态的私有字段的内容之前锁定此节点。
        结果
        true iff此节点（或祖先）已被删除与 removeNode()方法。

      • exportNode

        public void exportNode​(OutputStream os)
                throws IOException,
                       BackingStoreException
        实现 exportNode方法按照在本说明书中 Preferences.exportNode(OutputStream) 。
        Specified by:
        exportNode在 Preferences
        参数
        os - 要在其上发出XML文档的输出流。
        异常
        IOException - 如果写入指定的输出流导致一个 IOException 。
        BackingStoreException - 如果不能从后备存储读取偏好数据。
        另请参见：
        Preferences.importPreferences(InputStream)

      • exportSubtree

        public void exportSubtree​(OutputStream os)
                   throws IOException,
                          BackingStoreException
        实现 exportSubtree方法按照在本说明书中 Preferences.exportSubtree(OutputStream) 。
        Specified by:
        exportSubtree在 Preferences
        参数
        os - 发送XML文档的输出流。
        异常
        IOException - 如果写入指定的输出流导致一个 IOException 。
        BackingStoreException - 如果无法从后备存储读取偏好数据。
        另请参见：
        Preferences.importPreferences(InputStream) ， Preferences.exportNode(OutputStream)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


BackingStoreException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.prefs
软件包 java.util.prefs

Class BackingStoreException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.util.prefs.BackingStoreException
  • All Implemented Interfaces:
    Serializable

    public class BackingStoreException
extends 异常
    抛出以表示由于后备存储中的故障而无法完成首选项操作，或无法联系后备存储。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BackingStoreException​(String s)
      构造具有指定详细消息的BackingStoreException。
      BackingStoreException​(Throwable cause)
      构造具有指定原因的BackingStoreException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • BackingStoreException

        public BackingStoreException​(String s)
        构造具有指定详细消息的BackingStoreException。
        参数
        s - 详细信息。

      • BackingStoreException

        public BackingStoreException​(Throwable cause)
        构造具有指定原因的BackingStoreException。
        参数
        cause - 原因
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidPreferencesFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.prefs
软件包 java.util.prefs

Class InvalidPreferencesFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.util.prefs.InvalidPreferencesFormatException
  • All Implemented Interfaces:
    Serializable

    public class InvalidPreferencesFormatException
extends 异常
    抛出以表示操作无法完成，因为输入符合Preferences规范的偏好集合的相应XML文档类型。
    从以下版本开始：
    1.4
    另请参见：
    Preferences ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidPreferencesFormatException​(String message)
      使用指定的详细消息构造InvalidPreferencesFormatException。
      InvalidPreferencesFormatException​(String message, Throwable cause)
      构造一个InvalidPreferencesFormatException与指定的详细信息和原因。
      InvalidPreferencesFormatException​(Throwable cause)
      构造具有指定原因的InvalidPreferencesFormatException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidPreferencesFormatException

        public InvalidPreferencesFormatException​(Throwable cause)
        构造具有指定原因的InvalidPreferencesFormatException。
        参数
        cause - 原因（保存以供 Throwable.getCause()方法稍后检索）。

      • InvalidPreferencesFormatException

        public InvalidPreferencesFormatException​(String message)
        使用指定的详细消息构造InvalidPreferencesFormatException。
        参数
        message - 详细信息。 保存详细信息以供稍后通过Throwable.getMessage()检索。

      • InvalidPreferencesFormatException

        public InvalidPreferencesFormatException​(String message,
                                         Throwable cause)
        构造一个InvalidPreferencesFormatException与指定的详细信息和原因。
        参数
        message - 详细信息。 保存详细信息以供稍后通过Throwable.getMessage()检索。
        cause - 原因（由 Throwable.getCause()方法保存供以后检索）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.util.prefs (Java SE 9 & JDK 9 )

java.util.prefs

Interfaces

  • NodeChangeListener
  • PreferenceChangeListener
  • PreferencesFactory

Classes

  • AbstractPreferences
  • NodeChangeEvent
  • PreferenceChangeEvent
  • Preferences

Exceptions

  • BackingStoreException
  • InvalidPreferencesFormatException


java.util.prefs (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.prefs

Package java.util.prefs

该软件包允许应用程序存储和检索用户和系统首选项和配置数据。 该数据永久存储在实现相关的后备存储中。 有两个单独的首选节点树，一个用于用户首选项，一个用于系统首选项。
从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    NodeChangeListener
    用于接收偏好节点更改事件的侦听器。
    PreferenceChangeListener
    用于接收偏好更改事件的侦听器。
    PreferencesFactory
    生成首选项对象的工厂对象。
  • 类摘要
    Class 描述
    AbstractPreferences
    这个类提供了一个Preferences类的骨架实现，大大简化了实现它的任务。
    NodeChangeEvent
    由 Preferences节点发出的一个事件，指示已添加或删除该节点的子节点。
    PreferenceChangeEvent
    由 Preferences节点发出的一个事件，表示已添加，删除或已更改其值的首选项。
    Preferences
    优先级数据的分层收集中的节点。
  • 异常摘要
    异常 描述
    BackingStoreException
    抛出以表示由于后备存储中的故障而无法完成首选项操作，或无法联系后备存储。
    InvalidPreferencesFormatException
    抛出以表示操作无法完成，因为输入符合Preferences规范的首选项集合的相应XML文档类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.prefs Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.prefs

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • java.util.prefs.NodeChangeEvent
      • java.util.prefs.PreferenceChangeEvent
    • java.util.prefs.Preferences
      • java.util.prefs.AbstractPreferences
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.util.prefs.BackingStoreException
        • java.util.prefs.InvalidPreferencesFormatException

Interface Hierarchy

  • java.util.EventListener
    • java.util.prefs.NodeChangeListener
    • java.util.prefs.PreferenceChangeListener
  • java.util.prefs.PreferencesFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


NodeChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.prefs
软件包 java.util.prefs

Class NodeChangeEvent

  • java.lang.Object
    • java.util.EventObject
      • java.util.prefs.NodeChangeEvent
  • All Implemented Interfaces:
    Serializable

    public class NodeChangeEvent
extends EventObject
    由Preferences节点发出的一个事件，指示已经添加或删除该节点的子节点。

    请注意，尽管NodeChangeEvent继承了java.util.EventObject中的Serializable接口，但它并不是可串行化的。 实现适当的序列化方法来抛出NotSerializableException。

    从以下版本开始：
    1.4
    另请参见：
    Preferences ， NodeChangeListener ， PreferenceChangeEvent

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      NodeChangeEvent​(Preferences parent, Preferences child)
      构造一个新的 NodeChangeEvent实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Preferences getChild​()
      返回添加或删除的节点。
      Preferences getParent​()
      返回添加或删除的节点的父节点。

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NodeChangeEvent

        public NodeChangeEvent​(Preferences parent,
                       Preferences child)
        构造一个新的 NodeChangeEvent实例。
        参数
        parent - 添加或删除的节点的父节点。
        child - 添加或删除的节点。

    • 方法详细信息

      • getParent

        public Preferences getParent​()
        返回添加或删除的节点的父节点。
        结果
        添加或删除子项的父“首选项”节点

      • getChild

        public Preferences getChild​()
        返回添加或删除的节点。
        结果
        添加或删除的节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NodeChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.prefs
软件包 java.util.prefs

Interface NodeChangeListener

  • All Superinterfaces:
    EventListener

    public interface NodeChangeListener
extends EventListener
    用于接收偏好节点更改事件的侦听器。
    从以下版本开始：
    1.4
    另请参见：
    Preferences ， NodeChangeEvent ， PreferenceChangeListener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void childAdded​(NodeChangeEvent evt)
      添加子节点时调用此方法。
      void childRemoved​(NodeChangeEvent evt)
      删除子节点时调用此方法。

    • 方法详细信息

      • childAdded

        void childAdded​(NodeChangeEvent evt)
        添加子节点时调用此方法。
        参数
        evt - 描述父节点和子节点的节点更改事件对象。

      • childRemoved

        void childRemoved​(NodeChangeEvent evt)
        删除子节点时调用此方法。
        参数
        evt - 描述父节点和子节点的节点更改事件对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PreferenceChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.prefs
软件包 java.util.prefs

Class PreferenceChangeEvent

  • java.lang.Object
    • java.util.EventObject
      • java.util.prefs.PreferenceChangeEvent
  • All Implemented Interfaces:
    Serializable

    public class PreferenceChangeEvent
extends EventObject
    由Preferences节点发出的一个事件，指示已添加，删除或已更改其值的首选项。

    请注意，尽管PreferenceChangeEvent从EventObject继承了Serializable接口，但它并不是可串行化的。 实现适当的序列化方法来抛出NotSerializableException。

    从以下版本开始：
    1.4
    另请参见：
    Preferences ， PreferenceChangeListener ， NodeChangeEvent

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      PreferenceChangeEvent​(Preferences node, String key, String newValue)
      构造一个新的 PreferenceChangeEvent实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getKey​()
      返回更改的首选项的键。
      String getNewValue​()
      返回首选项的新值。
      Preferences getNode​()
      返回发出事件的首选节点。

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PreferenceChangeEvent

        public PreferenceChangeEvent​(Preferences node,
                             String key,
                             String newValue)
        构造一个新的 PreferenceChangeEvent实例。
        参数
        node - 发出事件的首选项节点。
        key - 改变的首选项的关键。
        newValue - 首选项的新值，如果偏好被删除， null 。

    • 方法详细信息

      • getNode

        public Preferences getNode​()
        返回发出事件的首选节点。
        结果
        发出事件的首选节点。

      • getKey

        public String getKey​()
        返回更改的首选项的键。
        结果
        改变的偏好的关键。

      • getNewValue

        public String getNewValue​()
        返回首选项的新值。
        结果
        偏好的新值，如果偏好被删除， null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PreferenceChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.prefs
软件包 java.util.prefs

Interface PreferenceChangeListener

  • All Superinterfaces:
    EventListener
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface PreferenceChangeListener
extends EventListener
    用于接收偏好更改事件的侦听器。
    从以下版本开始：
    1.4
    另请参见：
    Preferences ， PreferenceChangeEvent ， NodeChangeListener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void preferenceChange​(PreferenceChangeEvent evt)
      当添加，删除首选项或更改其值时，将调用此方法。

    • 方法详细信息

      • preferenceChange

        void preferenceChange​(PreferenceChangeEvent evt)
        当添加，删除首选项或更改其值时，将调用此方法。
        参数
        evt - 描述事件源和已更改的首选项的PreferenceChangeEvent对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Preferences (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.prefs
软件包 java.util.prefs

Class Preferences

  • java.lang.Object
    • java.util.prefs.Preferences
  • 已知直接子类：
    AbstractPreferences

    public abstract class Preferences
extends Object
    优先级数据的分层收集中的节点。 该类允许应用程序存储和检索用户和系统首选项和配置数据。 该数据永久存储在实现相关的后备存储中。 典型的实现包括平面文件，特定于OS的注册表，目录服务器和SQL数据库。 该类的用户不需要关注后备存储的细节。

    有两个单独的首选节点树，一个用于用户首选项，一个用于系统首选项。 每个用户都有一个单独的用户偏好树，给定系统中的所有用户共享相同的系统偏好树。 “用户”和“系统”的准确描述将因实施而异。 存储在用户偏好树中的典型信息可能包括特定应用程序的字体选择，颜色选择或首选窗口位置和大小。 存储在系统首选项树中的典型信息可能包括应用程序的安装配置数据。

    优先树中的节点以类似于分层文件系统中的目录的方式命名。 在首选项树的每个节点都具有节点名称 （这不一定是唯一的），唯一的绝对路径名 ，并且相对于每个祖先的路径名，包括本身。

    根节点具有空字符串（“”）的节点名称。 每个其他节点都有一个任意的节点名称，在创建时指定。 对这个名称的唯一限制是它不能是空字符串，它不能包含斜杠字符（'/'）。

    根节点的绝对路径名为"/" 。 根节点的子节点的绝对路径名为"/" + <node name> 。 所有其他节点的绝对路径名称为<parent的绝对路径名> + "/" + <node name> 。 请注意，所有绝对路径名以斜杠字符开头。

    节点n的相对路径名到它的祖先一个仅仅是必须附加到字符串的绝对路径名，以便以形成n的绝对路径名，与初始斜杠字符（如果存在的话）中除去。 注意：

    • 没有相对路径名以斜杠字符开头。
    • 每个节点的相对于自身的路径名是空字符串。
    • 每个节点的相对于其父节点的路径名称是其节点名称（除了根节点，不具有父节点）。
    • 每个节点相对于根的路径名是其绝对路径名，并删除了最初的斜线字符。

    请注意：

    • 没有路径名称包含多个连续的斜杠字符。
    • 除了根的绝对路径名之外，没有路径名称以斜杠字符结尾。
    • 任何符合这两条规则的字符串都是有效的路径名。

    修改偏好数据的所有方法都允许异步操作; 他们可能会立即返回，更改将最终传播到具有实现相关延迟的持久后备存储。 flush方法可用于同步强制更新到后备存储。 Java虚拟机的正常终止不会导致挂起更新的损失-明确flush调用不需要终止时，确保挂起更新变得持久。

    从Preferences对象读取首选项的所有方法都需要调用者提供默认值。 如果以前没有设置任何值或者后备存储不可用，则返回默认值。 其目的是允许应用程序运行，尽管功能略有降低，即使后备存储不可用。 几种方法，如flush ，具有阻止它们在后备存储不可用的情况下运行的语义。 普通应用程序应该不需要调用任何这些方法，可以通过这些方法来声明它们被抛出BackingStoreException 。

    该类中的方法可以由单个JVM中的多个线程并发调用，而不需要外部同步，并且结果将等同于一些串行执行。 如果此类由多个JVM同时使用 ，它们将偏好数据存储在相同的后备存储中，则数据存储将不会被破坏，但不会对偏好数据的一致性做出其他保证。

    此类包含导出/导入工具，允许将偏好“导出”到XML文档，并将表示要“导入”的偏好的XML文档重新导入系统。 此设施可用于备份偏好树的全部或部分，并随后从备份恢复。

    XML文档具有以下DOCTYPE声明：

       <!DOCTYPE preferences SYSTEM "http://java.sun.com/dtd/preferences.dtd">
    请注意，导出或导入首选项时不会访问系统URI（http://java.sun.com/dtd/preferences.dtd）; 它只是作为一个字符串来唯一地标识DTD，它是：
       <?xml version="1.0" encoding="UTF-8"?> <!-- DTD for a Preferences tree. --> <!-- The preferences element is at the root of an XML document representing a Preferences tree. --> <!ELEMENT preferences (root)> <!-- The preferences element contains an optional version attribute, which specifies version of DTD. --> <!ATTLIST preferences EXTERNAL_XML_VERSION CDATA "0.0" > <!-- The root element has a map representing the root's preferences (if any), and one node for each child of the root (if any). --> <!ELEMENT root (map, node*) > <!-- Additionally, the root contains a type attribute, which specifies whether it's the system or user root. --> <!ATTLIST root type (system|user) #REQUIRED > <!-- Each node has a map representing its preferences (if any), and one node for each child (if any). --> <!ELEMENT node (map, node*) > <!-- Additionally, each node has a name attribute --> <!ATTLIST node name CDATA #REQUIRED > <!-- A map represents the preferences stored at a node (if any). --> <!ELEMENT map (entry*) > <!-- An entry represents a single preference, which is simply a key-value pair. --> <!ELEMENT entry EMPTY > <!ATTLIST entry key CDATA #REQUIRED value CDATA #REQUIRED >
    每个Preferences实现必须有一个关联的PreferencesFactory实现。 每个Java（TM）SE实现都必须提供一些方法来指定哪个PreferencesFactory实现用于生成根首选项节点。 这允许管理员用替代实现来替换默认首选项实现。
    Implementation Note:
    PreferencesFactory实现位置如下：

    1. 如果定义了系统属性java.util.prefs.PreferencesFactory ，则将其作为实现PreferencesFactory接口的类的完全限定名称。 该类被加载和实例化; 如果此过程失败，则抛出未指定的错误。

    2. 如果PreferencesFactory实现类文件已经被安装在一个jar文件，它是可见的system class loader ，以及jar文件包含一个名为供应商的配置文件java.util.prefs.PreferencesFactory在资源目录META-INF/services ，然后在该文件中指定的第一个类名称取。 如果提供了多个这样的jar文件，那么将使用第一个。 该类被加载和实例化; 如果此过程失败，则抛出未指定的错误。

    3. 最后，如果既不提供上述系统属性也不提供扩展jar文件，则会为基础平台的系统级默认PreferencesFactory实现加载和实例化。

    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int MAX_KEY_LENGTH
      字符串允许的最大长度（80个字符）。
      static int MAX_NAME_LENGTH
      节点名称的最大长度（80个字符）。
      static int MAX_VALUE_LENGTH
      字符串的最大长度允许为一个值（8192个字符）。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Preferences​()
      唯一的构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract String absolutePath​()
      返回此首选项节点的绝对路径名。
      abstract void addNodeChangeListener​(NodeChangeListener ncl)
      注册指定的侦听器以接收该节点的 节点更改事件 。
      abstract void addPreferenceChangeListener​(PreferenceChangeListener pcl)
      注册指定的侦听器以接收此首选项节点的 优先级更改事件 。
      abstract String[] childrenNames​()
      返回此首选项节点的子节点相对于此节点的名称。
      abstract void clear​()
      删除此首选项节点中的所有首选项（键值关联）。
      abstract void exportNode​(OutputStream os)
      在指定的输出流上发出一个XML文档，表示此节点中包含的所有首选项（而不是其后代）。
      abstract void exportSubtree​(OutputStream os)
      发出表示此节点及其所有后代中包含的所有首选项的XML文档。
      abstract void flush​()
      强制将此首选项节点及其后代的内容更改为永久存储。
      abstract String get​(String key, String def)
      返回与此首选项节点中指定键相关联的值。
      abstract boolean getBoolean​(String key, boolean def)
      返回由此首选项节点中与指定键相关联的字符串表示的布尔值。
      abstract byte[] getByteArray​(String key, byte[] def)
      返回由此首选项节点中与指定键相关联的字符串表示的字节数组值。
      abstract double getDouble​(String key, double def)
      返回由此首选项节点中与指定键相关联的字符串表示的双精度值。
      abstract float getFloat​(String key, float def)
      返回由此首选项节点中与指定键相关联的字符串表示的浮点值。
      abstract int getInt​(String key, int def)
      返回由此首选项节点中与指定键相关联的字符串表示的int值。
      abstract long getLong​(String key, long def)
      返回由此首选项节点中与指定键相关联的字符串表示的长整型值。
      static void importPreferences​(InputStream is)
      在指定的输入流中导入由XML文档表示的所有首选项。
      abstract boolean isUserNode​()
      返回 true如果此首选项节点位于用户首选项树， false ，如果它在系统首选项树。
      abstract String[] keys​()
      返回在此首选项节点中具有关联值的所有键。
      abstract String name​()
      返回此首选项节点的名称，相对于其父项。
      abstract Preferences node​(String pathName)
      返回与该节点相同树中的命名偏好节点，创建它及其任何祖先（如果它们不存在）。
      abstract boolean nodeExists​(String pathName)
      如果指定的首选节点存在于与该节点相同的树中，则返回true。
      abstract Preferences parent​()
      返回此首选项节点的父节点，如果这是根节点，则返回 null 。
      abstract void put​(String key, String value)
      将指定的值与此首选项节点中的指定键相关联。
      abstract void putBoolean​(String key, boolean value)
      将表示指定布尔值的字符串与此首选项节点中指定的键相关联。
      abstract void putByteArray​(String key, byte[] value)
      将表示指定字节数组的字符串与此首选项节点中指定的键相关联。
      abstract void putDouble​(String key, double value)
      将表示指定双重值的字符串与此首选项节点中指定的键相关联。
      abstract void putFloat​(String key, float value)
      将表示指定浮点值的字符串与此首选项节点中指定的键相关联。
      abstract void putInt​(String key, int value)
      将表示指定int值的字符串与此首选项节点中的指定键相关联。
      abstract void putLong​(String key, long value)
      将表示指定长值的字符串与此首选项节点中指定的键相关联。
      abstract void remove​(String key)
      删除与此首选项节点中指定键相关联的值（如果有）。
      abstract void removeNode​()
      删除此首选项节点及其所有后代，使包含在已删除节点中的任何首选项无效。
      abstract void removeNodeChangeListener​(NodeChangeListener ncl)
      删除指定的 NodeChangeListener ，所以它不再收到更改事件。
      abstract void removePreferenceChangeListener​(PreferenceChangeListener pcl)
      删除指定的首选项更改侦听器，因此它不再接收首选项更改事件。
      abstract void sync​()
      确保未来从该偏好节点及其后代读取的内容将反映在 sync调用之前提交给永久存储（从任何VM）的任何更改。
      static Preferences systemNodeForPackage​(Class<?> c)
      从与指定类的包关联（按照约定）的系统首选项树返回首选项节点。
      static Preferences systemRoot​()
      返回系统的根首选项节点。
      abstract String toString​()
      返回此首选项节点的字符串表示形式，如同由以下表达式计算： (this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 。
      static Preferences userNodeForPackage​(Class<?> c)
      从调用用户的偏好树中返回偏好节点，该树通过指定的类的包（与约定）相关联。
      static Preferences userRoot​()
      返回主叫用户的根优先级节点。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MAX_KEY_LENGTH

        public static final int MAX_KEY_LENGTH
        字符串允许的最大长度（80个字符）。
        另请参见：
        Constant Field Values

      • MAX_VALUE_LENGTH

        public static final int MAX_VALUE_LENGTH
        字符串的最大长度允许为一个值（8192个字符）。
        另请参见：
        Constant Field Values

      • MAX_NAME_LENGTH

        public static final int MAX_NAME_LENGTH
        节点名称的最大长度（80个字符）。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Preferences

        protected Preferences​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • userNodeForPackage

        public static Preferences userNodeForPackage​(Class<?> c)
        从调用用户的偏好树中返回偏好节点，该树通过指定的类的包（与约定）相关联。 约定如下：节点的绝对路径名称是完全限定的包名称，前面加上斜杠（ '/' ），每个句点（ '.' ）被斜杠替换。 例如，与com.acme.widget.Foo类关联的节点的绝对路径名称为/com/acme/widget 。

        此约定不适用于未命名的包，其关联首选项节点为<unnamed> 。 该节点不是为了长期使用，而是为了方便早期开发尚不属于包的程序，以及“一次性”程序。 有价值的数据不应该存储在这个节点，因为它被所有使用它的程序共享。

        希望访问与其包相关的偏好的类Foo可以获得如下的首选节点：

          static Preferences prefs = Preferences.userNodeForPackage(Foo.class);
        这个成语避免了使用字符串来描述首选项节点的需要，并减少了运行时失败的可能性。 （如果类名拼写错误，通常会导致编译时错误。）

        调用此方法将导致返回的节点及其祖先（如果它们不存在）的创建。 如果返回的节点在此调用之前不存在，则此节点和由此调用创建的任何祖先不会保证变为永久性，直到在返回的节点（或其祖先或后代之一）上调用flush方法。

        参数
        c - 需要其用户首选项节点的包的类。
        结果
        与其中 c是其成员的包相关联的用户偏好节点。
        异常
        NullPointerException - 如果 c是 null 。
        SecurityException - 如果安全管理器存在，并且它拒绝 RuntimePermission("preferences") 。
        另请参见：
        RuntimePermission

      • systemNodeForPackage

        public static Preferences systemNodeForPackage​(Class<?> c)
        从与指定类的包关联（按照约定）的系统首选项树返回首选项节点。 约定如下：节点的绝对路径名称是完全限定的包名称，前面带有斜杠（ '/' ），每个句点（ '.' ）被替换为斜杠。 例如，与com.acme.widget.Foo类关联的节点的绝对路径名是/com/acme/widget 。

        此约定不适用于未命名的包，其关联首选项节点为<unnamed> 。 该节点不是为了长期使用，而是为了方便早期开发尚不属于包的程序，以及“一次性”程序。 有价值的数据不应该存储在这个节点，因为它被所有使用它的程序共享。

        希望访问与其包相关的偏好的类Foo可以获得如下的偏好节点：

          static Preferences prefs = Preferences.systemNodeForPackage(Foo.class);
        这个成语避免了使用字符串来描述首选项节点的需要，并减少了运行时失败的可能性。 （如果类名拼写错误，通常会导致编译时错误。）

        调用此方法将导致返回的节点及其祖先（如果它们不存在）的创建。 如果返回的节点在此调用之前不存在，则此节点和由此调用创建的任何祖先不会保证变为永久，直到在返回的节点（或其祖先或后代之一）上调用flush方法。

        参数
        c - 需要其包的系统偏好节点的类。
        结果
        与其中 c是其成员的包相关联的系统偏好节点。
        异常
        NullPointerException - 如果 c是 null 。
        SecurityException - 如果安全管理器存在并且它拒绝 RuntimePermission("preferences") 。
        另请参见：
        RuntimePermission

      • userRoot

        public static Preferences userRoot​()
        返回主叫用户的根优先级节点。
        结果
        呼叫用户的根优先级节点。
        异常
        SecurityException - 如果安全管理员存在并且它拒绝 RuntimePermission("preferences") 。
        另请参见：
        RuntimePermission

      • systemRoot

        public static Preferences systemRoot​()
        返回系统的根首选项节点。
        结果
        系统的根首选项节点。
        异常
        SecurityException - 如果安全管理器存在，并且它拒绝 RuntimePermission("preferences") 。
        另请参见：
        RuntimePermission

      • put

        public abstract void put​(String key,
                         String value)
        将指定的值与此首选项节点中的指定键相关联。
        参数
        key - 指定值与之关联的键。
        value - 与指定键相关联的值。
        异常
        NullPointerException - 如果键或值为 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH或 value.length超过 MAX_VALUE_LENGTH 。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        IllegalArgumentException - 如果任一键或值包含空控制字符，则代码点U + 0000。

      • get

        public abstract String get​(String key,
                           String def)
        返回与此首选项节点中指定键相关联的值。 如果没有与密钥相关联的值，或者后台存储不可访问，则返回指定的默认值。

        一些实现可以在其后备存储中存储默认值。 如果没有与指定键相关联的值，但存在这样的存储缺省值 ，则优先于指定的默认值返回。

        参数
        key - 其关联值将被返回的键。
        def - 在此首选项节点没有与 key相关联的值的情况下返回的值。
        结果
        与 key相关联的值，或 def如果没有值与 key相关联，或后备存储不可访问。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果key是null 。 （A null值为def ） 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。

      • remove

        public abstract void remove​(String key)
        删除与此首选项节点中指定键相关联的值（如果有）。

        如果此实现支持存储的默认值 ，并且对于指定的首选项具有这样的默认值，则由此呼叫将存储的默认值“暴露”，因为它将由后续调用返回get 。

        参数
        key - 要从偏好节点删除其映射的密钥。
        异常
        NullPointerException - 如果 key是 null 。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。

      • clear

        public abstract void clear​()
                    throws BackingStoreException
        删除此首选项节点中的所有首选项（键值关联）。 此呼叫对此节点的任何后代都没有影响。

        如果此实现支持存储的默认值 ，并且首选项层次结构中的此节点包含任何此类默认值，则通过此调用将存储的默认值“暴露”，因为它们将通过后续调用返回get 。

        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与之通信，此操作无法完成。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        removeNode()

      • putInt

        public abstract void putInt​(String key,
                            int value)
        将表示指定int值的字符串与此首选项节点中的指定键相关联。 如果将int值传递给Integer.toString(int)，则相关联的字符串将返回。 此方法旨在与getInt(java.lang.String, int)一起使用。
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键关联的值。
        异常
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        getInt(String,int)

      • getInt

        public abstract int getInt​(String key,
                           int def)
        返回由此首选项节点中与指定键相关联的字符串表示的int值。 该字符串将转换为Integer.parseInt(String)的整数。 如果没有与该关键字关联的值，则返回指定的默认值，后台存储不可访问，或者如果相关值已通过，则Integer.parseInt(String)将抛出NumberFormatException 。 此方法旨在与putInt(java.lang.String, int)结合使用。

        如果实现支持存储的默认值，并且这样的默认值存在，则可以访问，并且可以使用Integer.parseInt将其转换为int，该int返回优先于指定的默认值。

        参数
        key - 其关联值将作为int返回的键。
        def - 如果此首选项节点没有与 key关联的值或相关联的值不能被解释为int，或者后台存储不可访问，则返回值。
        结果
        由此偏好节点中与 key相关联的字符串表示的int值，如果关联值不存在或不能解释为int， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        putInt(String,int) ， get(String,String)

      • putLong

        public abstract void putLong​(String key,
                             long value)
        将表示指定长值的字符串与此首选项节点中指定的键相关联。 相关的字符串是将long值传递给Long.toString(long)时返回的字符串 。 该方法旨在与getLong(java.lang.String, long)一起使用。
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键关联的值。
        异常
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        getLong(String,long)

      • getLong

        public abstract long getLong​(String key,
                             long def)
        返回由此首选项节点中与指定键相关联的字符串表示的长整型值。 该字符串转换为长，如Long.parseLong(String) 。 如果没有与密钥相关联的值，则返回指定的默认值，后台存储不可访问，或者如果相关联的值被传递，则Long.parseLong(String)将抛出NumberFormatException 。 此方法旨在与putLong(java.lang.String, long)结合使用。

        如果实现支持存储的默认值，并且这样的默认值是可以访问的，并且可以使用Long.parseLong转换为long，这个长度优先于指定的默认值。

        参数
        key - 其关联值将作为长期返回的键。
        def - 如果此首选项节点没有与 key相关联的值或相关联的值不能被解释为长时间或后备存储无法访问，则返回值。
        结果
        由此偏好节点中与 key相关联的字符串表示的长值，如果相关联的值不存在或不能解释为长， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        putLong(String,long) ， get(String,String)

      • putBoolean

        public abstract void putBoolean​(String key,
                                boolean value)
        将表示指定布尔值的字符串与此首选项节点中指定的键相关联。 如果值为true，则相关联的字符串为"true"如果为false， "false" 。 此方法旨在与getBoolean(java.lang.String, boolean)一起使用。
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键关联的值。
        异常
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        getBoolean(String,boolean) ， get(String,String)

      • getBoolean

        public abstract boolean getBoolean​(String key,
                                   boolean def)
        返回由此首选项节点中与指定键相关联的字符串表示的布尔值。 有效的字符串为"true" ，代表true，而"false"表示false。 情况被忽略，因此，例如， "TRUE"和"False"也是有效的。 此方法旨在与putBoolean(java.lang.String, boolean)结合使用。

        如果没有与密钥相关联的值，后台存储不可访问，或者如果关联值不是"true"或"false" ，忽略大小写，则返回指定的默认值。

        如果实现支持存储的默认值，并且这样的默认值存在且可访问，则优先于指定的默认值，除非存储的默认值不是"true"或"false" ，否则将忽略大小写，在这种情况下使用指定的默认值。

        参数
        key - 其关联值将作为布尔值返回的键。
        def - 如果此首选项节点没有与 key相关联的值或相关联的值不能被解释为布尔值，或者后台存储不可访问，则返回值。
        结果
        由此偏好节点中与 key相关联的字符串表示的布尔值，如果关联值不存在或不能解释为布尔值， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空值控制字符，则代码点U + 0000。
        另请参见：
        get(String,String) ， putBoolean(String,boolean)

      • putFloat

        public abstract void putFloat​(String key,
                              float value)
        将表示指定浮点值的字符串与此首选项节点中指定的键相关联。 相关的字符串是将float值传递给Float.toString(float)时返回的字符串 。 此方法旨在与getFloat(java.lang.String, float)一起使用。
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键相关联的值。
        异常
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        getFloat(String,float)

      • getFloat

        public abstract float getFloat​(String key,
                               float def)
        返回由此首选项节点中与指定键相关联的字符串表示的浮点值。 字符串转换为一个整数，按Float.parseFloat(String) 。 如果没有与密钥相关联的值，则返回指定的默认值，后台存储不可访问，或者如果相关联的值被传递，则Float.parseFloat(String)将抛出NumberFormatException 。 该方法旨在与putFloat(java.lang.String, float)一起使用。

        如果实现支持存储的默认值，并且这样的默认值是可以访问的，并且可以转换为具有Float.parseFloat的浮点数，则此浮点优先于指定的默认值。

        参数
        key - 其关联值将作为浮点数返回的键。
        def - 如果此首选项节点没有与 key关联的值或相关联的值不能被解释为浮点型或后备存储不可访问，则返回值。
        结果
        由此偏好节点中与 key相关联的字符串表示的浮点值，如果关联值不存在或不能解释为浮点数， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        putFloat(String,float) ， get(String,String)

      • putDouble

        public abstract void putDouble​(String key,
                               double value)
        将表示指定双重值的字符串与此首选项节点中指定的键相关联。 相关的字符串是将double值传递给Double.toString(double)时返回的字符串 。 此方法旨在与getDouble(java.lang.String, double)一起使用。
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键相关联的值。
        异常
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果 key.length()超过 MAX_KEY_LENGTH 。
        IllegalStateException - 如果已使用 removeNode()方法删除了此节点（或祖先）。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        getDouble(String,double)

      • getDouble

        public abstract double getDouble​(String key,
                                 double def)
        返回由此首选项节点中与指定键相关联的字符串表示的双精度值。 该字符串转换为一个整数，如Double.parseDouble(String) 。 如果没有与密钥相关联的值，则返回指定的默认值，后台存储不可访问，或者如果相关联的值被传递，则Double.parseDouble(String)将抛出NumberFormatException 。 此方法旨在与putDouble(java.lang.String, double)一起使用。

        如果实现支持存储的默认值，并且这样的默认值存在，则可以访问，并且可以使用Double.parseDouble将其转换为双Double.parseDouble ，这个double值优先于指定的默认值。

        参数
        key - 其关联值将作为双重返回的键。
        def - 如果此首选项节点没有与 key相关联的值或相关联的值不能被解释为双 key值，或后备存储不可访问，则返回值。
        结果
        由此偏好节点中与 key相关联的字符串表示的双 def值，如果关联值不存在或不能解释为双 def值， def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        putDouble(String,double) ， get(String,String)

      • putByteArray

        public abstract void putByteArray​(String key,
                                  byte[] value)
        将表示指定字节数组的字符串与此首选项节点中指定的键相关联。 相关联的字符串是字节数组的Base64编码，如RFC 2045第6.8节中定义的，其中一个较小的更改：字符串将仅包含Base64字母表中的字符; 它不会包含任何换行符。 请注意，字节数组的最大长度限制为MAX_VALUE_LENGTH四分之三， MAX_VALUE_LENGTH使Base64编码的字符串的长度不超过MAX_VALUE_LENGTH 。 该方法旨在与getByteArray(java.lang.String, byte[])一起使用。
        参数
        key - 与字符串形式的值相关联的键。
        value - 其字符串形式与键相关联的值。
        异常
        NullPointerException - 如果键或值为 null 。
        IllegalArgumentException - 如果key.length（）超过MAX_KEY_LENGTH或者如果value.length超过MAX_VALUE_LENGTH * 3/4。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        getByteArray(String,byte[]) ， get(String,String)

      • getByteArray

        public abstract byte[] getByteArray​(String key,
                                    byte[] def)
        返回由此首选项节点中与指定键相关联的字符串表示的字节数组值。 有效的字符串是Base64编码的二进制数据，如RFC 2045第6.8节中定义的，其中一个较小的更改：字符串必须仅包含Base64字母表中的字符; 不允许换行符或无关字符。 此方法旨在与putByteArray(java.lang.String, byte[])一起使用。

        如果没有与密钥关联的值，后台存储不可访问，或者相关联的值不是有效的Base64编码字节数组（如上所述），则返回指定的默认值。

        如果实现支持存储的默认值，并且这样的默认值存在且可访问，则优先于指定的默认值，除非存储的默认值不是有效的Base64编码字节数组（如上定义），在这种情况下，指定的默认值为用过的。

        参数
        key - 将其关联值作为字节数组返回的键。
        def - 如果此首选项节点没有与 key相关联的值或相关联的值不能被解释为字节数组，或后备存储不可访问，则返回值。
        结果
        由此偏好节点中与 key相关联的字符串表示的字节数组值，如果关联值不存在或不能解释为字节数组，则表示 def 。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        NullPointerException - 如果key是null 。 （A null为值def 是允许的。）
        IllegalArgumentException - 如果键包含空控制字符，则代码点U + 0000。
        另请参见：
        get(String,String) ， putByteArray(String,byte[])

      • keys

        public abstract String[] keys​()
                       throws BackingStoreException
        返回在此首选项节点中具有关联值的所有键。 （如果此节点没有首选项，返回的数组的大小为零）。

        如果实现支持存储的默认值，并且在此节点上有任何未被覆盖的默认值，通过显式偏好设置，除了任何显式偏好之外，还会在数组中返回默认值。

        结果
        在此首选项节点中具有关联值的键的数组。
        异常
        BackingStoreException - 如果由于后备存储器中的故障导致此操作无法完成，或无法与之通信。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。

      • childrenNames

        public abstract String[] childrenNames​()
                                throws BackingStoreException
        返回此首选项节点的子节点相对于此节点的名称。 （如果此节点没有子节点，则返回的数组的大小为零）。
        结果
        此偏好节点的子节点名称。
        异常
        BackingStoreException - 如果由于后备存储器中的故障导致此操作无法完成，或无法与之通信。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。

      • parent

        public abstract Preferences parent​()
        返回此首选项节点的父节点，如果这是根节点，则返回 null 。
        结果
        此首选项节点的父级。
        异常
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。

      • node

        public abstract Preferences node​(String pathName)
        返回与该节点相同树中的命名偏好节点，创建它及其任何祖先（如果它们不存在）。 接受相对或绝对路径名。 相对路径名（不以斜杠字符('/') ）相对于此首选节点进行解释。

        如果返回的节点在此调用之前不存在，则在返回的节点（或其祖先或后代之一）调用flush方法之前，此节点和由此调用创建的任何祖先不能保证变为永久性。

        参数
        pathName - 要返回的首选项节点的路径名。
        结果
        指定的首选项节点。
        异常
        IllegalArgumentException - 如果路径名无效（即，它包含多个连续的斜杠字符，或以斜杠字符结尾，并且长度超过一个字符）。
        NullPointerException - 如果路径名是 null 。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        flush()

      • nodeExists

        public abstract boolean nodeExists​(String pathName)
                            throws BackingStoreException
        如果指定的首选节点存在于与该节点相同的树中，则返回true。 相对路径名称（不以斜杠字符('/') ）相对于此首选项节点进行解释。

        如果已经使用removeNode()方法删除了此节点（或祖先），则调用此方法是合法的，但只能使用路径名"" ; 调用将返回false 。 因此，成语p.nodeExists("")可用于测试是否已经删除了p 。

        参数
        pathName - 要检查其存在的节点的路径名。
        结果
        如果指定的节点存在，则为true。
        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与之通信，此操作无法完成。
        IllegalArgumentException - 如果路径名无效（即，它包含多个连续的斜杠字符，或以斜杠字符结尾，长度超过一个字符）。
        NullPointerException - 如果路径名是 null 。
        IllegalStateException - 如果这个节点（或祖先）已经用 removeNode()方法删除，而 pathName不是空字符串（ "" ）。

      • removeNode

        public abstract void removeNode​()
                         throws BackingStoreException
        删除此首选项节点及其所有后代，使包含在已删除节点中的任何首选项无效。 一旦节点已被去除，试图比其他任何方法name() ， absolutePath() ， isUserNode() ， flush()或nodeExists("")在相应Preferences实例将失败，并IllegalStateException 。 （在Object上定义的方法在删除后仍可以在节点上调用;它们不会抛出IllegalStateException ）

        在该节点（或祖先）上调用flush方法之前，删除不能保证是持久的。

        如果此实现支持存储的默认值 ，则删除节点会在此节点或其下方公开任何存储的默认值。 因此，在后续调用nodeExists这个节点的路径名称可能会返回true ，以及后续调用node这个路径名称可能会返回（不同） Preferences代表的偏好和/或儿童的非空的集合实例。

        异常
        BackingStoreException - 如果由于后备存储器中的故障导致此操作无法完成，或无法与之通信。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        UnsupportedOperationException - 如果在根节点上调用此方法。
        另请参见：
        flush()

      • name

        public abstract String name​()
        返回此首选项节点的名称，相对于其父项。
        结果
        此首选项节点的名称，相对于其父节点。

      • absolutePath

        public abstract String absolutePath​()
        返回此首选项节点的绝对路径名。
        结果
        这个偏好节点的绝对路径名。

      • isUserNode

        public abstract boolean isUserNode​()
        返回 true如果此首选项节点位于用户首选项树， false ，如果它在系统首选项树。
        结果
        true如果此首选项节点在用户首选项树中， false如果它在系统首选项树中。

      • toString

        public abstract String toString​()
        返回此首选项节点的字符串表示形式，如以下表达式计算： (this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • flush

        public abstract void flush​()
                    throws BackingStoreException
        强制将此首选项节点及其后代的内容更改为永久存储。 一旦这种方法成功返回，可以安全地假设在方法调用之前，在根节点的子树中进行的所有更改都已变为永久性。

        实现可以随时将更改刷新到持久存储中。 他们不需要等待这个方法被调用。

        当在新创建的节点上发生冲突时，它会被永久化，而且还有待进行持久化的任何祖先（和后代）也是如此。 但是请注意，祖先的任何偏好值变化都不能保证被持久化。

        如果在已使用removeNode()方法删除的节点上调用此方法，则在此节点上调用flushSpi（），但不调用其他节点。

        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与之通信，此操作无法完成。
        另请参见：
        sync()

      • sync

        public abstract void sync​()
                   throws BackingStoreException
        确保从该偏好节点及其后代的未来读取反映在sync调用之前提交给永久存储（从任何VM）的任何更改。 作为副作用，强制将此首选项节点及其后代的内容更改为持久存储，就像在此节点上已调用flush方法一样。
        异常
        BackingStoreException - 如果由于后备存储器中的故障或无法与之通信，此操作无法完成。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        flush()

      • addPreferenceChangeListener

        public abstract void addPreferenceChangeListener​(PreferenceChangeListener pcl)
        注册指定的侦听器以接收此首选项节点的优先级更改事件 。 当偏好被添加到该节点，从该节点移除时，或者当与偏好相关联的值被改变时，生成偏好改变事件。 （偏好改变事件不会由所产生的removeNode()方法，该方法生成事件 。优选变化事件是由所生成的节点改变 clear方法）。

        事件只能保证在与注册的侦听器相同的JVM中进行的更改，尽管某些实现可能会为此JVM之外的更改生成事件。 可能在更改持续存在之前生成事件。 当在该节点的后代修改首选项时，不会生成事件; 想要这样的事件的主叫必须向每个后代注册。

        参数
        pcl - 要添加的首选项更改侦听器。
        异常
        NullPointerException - 如果 pcl为空。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        removePreferenceChangeListener(PreferenceChangeListener) ， addNodeChangeListener(NodeChangeListener)

      • removePreferenceChangeListener

        public abstract void removePreferenceChangeListener​(PreferenceChangeListener pcl)
        删除指定的首选项更改侦听器，因此它不再接收首选项更改事件。
        参数
        pcl - 要删除的首选项更改侦听器。
        异常
        IllegalArgumentException - 如果 pcl不是此节点上注册的首选项更改侦听器。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        addPreferenceChangeListener(PreferenceChangeListener)

      • addNodeChangeListener

        public abstract void addNodeChangeListener​(NodeChangeListener ncl)
        注册指定的侦听器以接收该节点的节点更改事件 。 当子节点添加到该节点或从该节点移除时，将生成节点更改事件。 （单个removeNode()调用会导致多个节点更改事件 ，一个针对以删除节点为根的子树中的每个节点）。

        事件只能保证在与注册的侦听器相同的JVM中进行的更改，尽管某些实现可能会为此JVM之外的更改生成事件。 在更改变得永久之前可能会生成事件。 当添加或删除此节点的间接后代时，不会生成事件; 想要这样的事件的主叫必须向每个后代注册。

        关于节点创建几乎不能保证。 因为在访问时隐式创建节点，因此实现可能无法确定在访问之前后备存储中是否存在子节点（例如，因为后备存储不可达或缓存的信息已过期）。 在这种情况下，实现既不需要生成节点更改事件，也不禁止这样做。

        参数
        ncl - 要添加的 NodeChangeListener 。
        异常
        NullPointerException - 如果 ncl为空。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        removeNodeChangeListener(NodeChangeListener) ， addPreferenceChangeListener(PreferenceChangeListener)

      • removeNodeChangeListener

        public abstract void removeNodeChangeListener​(NodeChangeListener ncl)
        删除指定的 NodeChangeListener ，所以它不再收到更改事件。
        参数
        ncl - 要删除的 NodeChangeListener 。
        异常
        IllegalArgumentException - 如果 ncl在此节点上未注册 NodeChangeListener 。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        addNodeChangeListener(NodeChangeListener)

      • exportNode

        public abstract void exportNode​(OutputStream os)
                         throws IOException,
                                BackingStoreException
        在指定的输出流上发出一个XML文档，表示此节点中包含的所有首选项（而不是其后代）。 实际上，该XML文档是该节点的脱机备份。

        XML文档将具有以下DOCTYPE声明：

           <!DOCTYPE preferences SYSTEM "http://java.sun.com/dtd/preferences.dtd">
        将使用UTF-8字符编码。

        该方法是一般规则的异常，即同时执行此类中的多个方法的结果产生等同于一些串行执行的结果。 如果在该节点的调用同时修改此节点的首选项，则导出的首选项包含节点中包含的首选项的“模糊快照”; 一些并发修改可能反映在导出的数据中，而其他可能不会。

        参数
        os - 发送XML文档的输出流。
        异常
        IOException - 如果写入指定的输出流导致一个 IOException 。
        BackingStoreException - 如果不能从后备存储读取偏好数据。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        importPreferences(InputStream)

      • exportSubtree

        public abstract void exportSubtree​(OutputStream os)
                            throws IOException,
                                   BackingStoreException
        发出表示此节点及其所有后代中包含的所有首选项的XML文档。 实际上，这个XML文档是存在于该节点的子树的脱机备份。

        XML文档将具有以下DOCTYPE声明：

           <!DOCTYPE preferences SYSTEM "http://java.sun.com/dtd/preferences.dtd">
        将使用UTF-8字符编码。

        该方法是一般规则的异常，即同时执行此类中的多个方法的结果产生等同于一些串行执行的结果。 如果根据此方法调用的子树中的首选项或节点与此方法的调用同时修改，则导出的优选项包含子树的“模糊快照”; 一些并发修改可能反映在导出的数据中，而其他可能不会。

        参数
        os - 发送XML文档的输出流。
        异常
        IOException - 如果写入指定的输出流导致一个 IOException 。
        BackingStoreException - 如果无法从后备存储读取偏好数据。
        IllegalStateException - 如果此节点（或祖先）已使用 removeNode()方法删除。
        另请参见：
        importPreferences(InputStream) ， exportNode(OutputStream)

      • importPreferences

        public static void importPreferences​(InputStream is)
                              throws IOException,
                                     InvalidPreferencesFormatException
        在指定的输入流中导入由XML文档表示的所有首选项。 文档可以表示用户偏好或系统偏好。 如果它表示用户偏好，则首选项将被导入到主叫用户的首选项树中（即使它们最初来自不同用户的偏好树）。 如果文档中描述的任何偏好居住在不存在的优先级节点，则将创建节点。

        XML文档必须具有以下DOCTYPE声明：

           <!DOCTYPE preferences SYSTEM "http://java.sun.com/dtd/preferences.dtd">
        （此方法设计为与exportNode(OutputStream)和exportSubtree(OutputStream)结合使用。

        该方法是一般规则的异常，即同时执行此类中的多个方法的结果产生等同于一些串行执行的结果。 该方法类似于在该类中的其他公共方法之上实现，特别是node(String)和put(String, String) 。

        参数
        is - 从中读取XML文档的输入流。
        异常
        IOException - 如果从指定的输入流读取导致一个 IOException 。
        InvalidPreferencesFormatException - 输入流上的数据不构成具有强制文档类型的有效XML文档。
        SecurityException - 如果安全管理器存在并且它拒绝 RuntimePermission("preferences") 。
        另请参见：
        RuntimePermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PreferencesFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.prefs
软件包 java.util.prefs

Interface PreferencesFactory

  • public interface PreferencesFactory
    生成首选项对象的工厂对象。 新的Preferences实现的提供商应提供相应的PreferencesFactory实现，以便可以安装新的Preferences实现来代替平台特定的默认实现。

    这个类只适用于Preferences实现者。 Preferences工厂的正常用户不需要参考本文档。

    从以下版本开始：
    1.4
    另请参见：
    Preferences

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Preferences systemRoot​()
      返回系统根首选项节点。
      Preferences userRoot​()
      返回与主叫用户对应的用户根优先级节点。

    • 方法详细信息

      • systemRoot

        Preferences systemRoot​()
        返回系统根首选项节点。 （该方法的多次调用将返回相同的对象引用。）
        结果
        系统根优先级节点

      • userRoot

        Preferences userRoot​()
        返回与主叫用户对应的用户根优先级节点。 在服务器中，返回的值通常取决于一些隐式的客户端上下文。
        结果
        用户根优先级节点对应于主叫用户
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util.prefs (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.prefs

  • Packages that use java.util.prefs
    软件包 描述
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。
  • Classes in java.util.prefs used by java.util.prefs
    Class 描述
    AbstractPreferences
    这个类提供了一个Preferences类的骨架实现，大大简化了实现它的任务。
    BackingStoreException
    抛出以表示由于后备存储中的故障而无法完成首选项操作，或无法联系后备存储。
    InvalidPreferencesFormatException
    抛出以表示操作无法完成，因为输入符合Preferences规范的偏好集合的相应XML文档类型。
    NodeChangeEvent
    由 Preferences节点发出的一个事件，指示已添加或删除该节点的子节点。
    NodeChangeListener
    用于接收偏好节点更改事件的侦听器。
    PreferenceChangeEvent
    由 Preferences节点发出的一个事件，表明偏好已被添加，删除或已更改其值。
    PreferenceChangeListener
    用于接收偏好更改事件的侦听器。
    Preferences
    优先级数据的分层收集中的节点。
  • Classes in java.util.prefs used by jdk.jshell.tool
    Class 描述
    Preferences
    优先级数据的分层收集中的节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.prefs.AbstractPreferences (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.prefs.AbstractPreferences

  • Packages that use AbstractPreferences
    软件包 描述
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

    • Uses of AbstractPreferences in java.util.prefs

      Methods in java.util.prefs that return AbstractPreferences
      Modifier and Type 方法 描述
      protected AbstractPreferences[] AbstractPreferences.cachedChildren​()
      返回此节点的所有已知未被删除的子节点。
      protected abstract AbstractPreferences AbstractPreferences.childSpi​(String name)
      返回此首选项节点的命名子节点，如果它不存在则创建它。
      protected AbstractPreferences AbstractPreferences.getChild​(String nodeName)
      如果命名的子项存在，返回命名的子项，如果不存在则返回 null 。
      Constructors in java.util.prefs with parameters of type AbstractPreferences
      Constructor 描述
      AbstractPreferences​(AbstractPreferences parent, String name)
      创建具有指定父项和相对于其父对象的指定名称的首选项节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.prefs.BackingStoreException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.prefs.BackingStoreException

  • Packages that use BackingStoreException
    软件包 描述
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

    • Uses of BackingStoreException in java.util.prefs

      Methods in java.util.prefs that throw BackingStoreException
      Modifier and Type 方法 描述
      String[] AbstractPreferences.childrenNames​()
      实现 children方法按照在本说明书中 Preferences.childrenNames() 。
      abstract String[] Preferences.childrenNames​()
      返回此首选项节点的子节点相对于此节点的名称。
      protected abstract String[] AbstractPreferences.childrenNamesSpi​()
      返回此首选项节点的子节点的名称。
      void AbstractPreferences.clear​()
      实现 clear方法按照在本说明书中 Preferences.clear() 。
      abstract void Preferences.clear​()
      删除此首选项节点中的所有首选项（键值关联）。
      void AbstractPreferences.exportNode​(OutputStream os)
      实现 exportNode方法按照在本说明书中 Preferences.exportNode(OutputStream) 。
      abstract void Preferences.exportNode​(OutputStream os)
      在指定的输出流上发出一个XML文档，表示此节点中包含的所有首选项（而不是其后代）。
      void AbstractPreferences.exportSubtree​(OutputStream os)
      实现 exportSubtree方法按照在本说明书中 Preferences.exportSubtree(OutputStream) 。
      abstract void Preferences.exportSubtree​(OutputStream os)
      发出表示此节点及其所有后代中包含的所有首选项的XML文档。
      void AbstractPreferences.flush​()
      实现 flush方法按照在本说明书中 Preferences.flush() 。
      abstract void Preferences.flush​()
      强制将此首选项节点及其后代的内容更改为永久存储。
      protected abstract void AbstractPreferences.flushSpi​()
      此方法在此节点锁定时被调用。
      protected AbstractPreferences AbstractPreferences.getChild​(String nodeName)
      如果命名的子项存在，返回命名的子项，如果不存在则返回 null 。
      String[] AbstractPreferences.keys​()
      实现 keys方法按照在本说明书中 Preferences.keys() 。
      abstract String[] Preferences.keys​()
      返回在此首选项节点中具有关联值的所有键。
      protected abstract String[] AbstractPreferences.keysSpi​()
      返回在此首选项节点中具有关联值的所有键。
      boolean AbstractPreferences.nodeExists​(String path)
      实现 nodeExists方法按照在本说明书中 Preferences.nodeExists(String) 。
      abstract boolean Preferences.nodeExists​(String pathName)
      如果指定的首选节点存在于与该节点相同的树中，则返回true。
      void AbstractPreferences.removeNode​()
      实现 removeNode()方法按照在本说明书中 Preferences.removeNode() 。
      abstract void Preferences.removeNode​()
      删除此首选项节点及其所有后代，使包含在已删除节点中的任何首选项无效。
      protected abstract void AbstractPreferences.removeNodeSpi​()
      删除此首选项节点，使其无效及其包含的任何首选项。
      void AbstractPreferences.sync​()
      实现 sync方法按照在本说明书中 Preferences.sync() 。
      abstract void Preferences.sync​()
      确保从该偏好节点及其后代的未来读取反映在 sync调用之前提交给永久存储（从任何VM）的任何更改。
      protected abstract void AbstractPreferences.syncSpi​()
      This method is invoked with this node locked.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.prefs.InvalidPreferencesFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.prefs.InvalidPreferencesFormatException

  • Packages that use InvalidPreferencesFormatException
    软件包 描述
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

    • Uses of InvalidPreferencesFormatException in java.util.prefs

      Methods in java.util.prefs that throw InvalidPreferencesFormatException
      Modifier and Type 方法 描述
      static void Preferences.importPreferences​(InputStream is)
      在指定的输入流中导入由XML文档表示的所有首选项。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.prefs.NodeChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.prefs.NodeChangeEvent

  • Packages that use NodeChangeEvent
    软件包 描述
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

    • Uses of NodeChangeEvent in java.util.prefs

      Methods in java.util.prefs with parameters of type NodeChangeEvent
      Modifier and Type 方法 描述
      void NodeChangeListener.childAdded​(NodeChangeEvent evt)
      添加子节点时调用此方法。
      void NodeChangeListener.childRemoved​(NodeChangeEvent evt)
      删除子节点时调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.prefs.PreferenceChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.prefs.PreferenceChangeEvent

  • Packages that use PreferenceChangeEvent
    软件包 描述
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

    • Uses of PreferenceChangeEvent in java.util.prefs

      Methods in java.util.prefs with parameters of type PreferenceChangeEvent
      Modifier and Type 方法 描述
      void PreferenceChangeListener.preferenceChange​(PreferenceChangeEvent evt)
      当添加，删除首选项或更改其值时，将调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.prefs.Preferences (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.prefs.Preferences

  • Packages that use Preferences
    软件包 描述
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。

    • Uses of Preferences in java.util.prefs

      Subclasses of Preferences in java.util.prefs
      Modifier and Type Class 描述
      class  AbstractPreferences
      这个类提供了一个Preferences类的骨架实现，大大简化了实现它的任务。
      Methods in java.util.prefs that return Preferences
      Modifier and Type 方法 描述
      Preferences NodeChangeEvent.getChild​()
      返回添加或删除的节点。
      Preferences PreferenceChangeEvent.getNode​()
      返回发出事件的首选节点。
      Preferences NodeChangeEvent.getParent​()
      返回添加或删除的节点的父节点。
      Preferences AbstractPreferences.node​(String path)
      实现 node方法按照在本说明书中 node(String) 。
      abstract Preferences Preferences.node​(String pathName)
      返回与该节点相同树中的命名偏好节点，创建它及其任何祖先（如果它们不存在）。
      Preferences AbstractPreferences.parent​()
      实现 parent方法按照在本说明书中 parent() 。
      abstract Preferences Preferences.parent​()
      返回此首选项节点的父节点，如果是根节点，则返回 null 。
      static Preferences Preferences.systemNodeForPackage​(Class<?> c)
      从与指定类的包关联（按照约定）的系统首选项树返回首选项节点。
      static Preferences Preferences.systemRoot​()
      返回系统的根首选项节点。
      Preferences PreferencesFactory.systemRoot​()
      返回系统根首选项节点。
      static Preferences Preferences.userNodeForPackage​(Class<?> c)
      从调用用户的偏好树中返回偏好节点，该树通过指定的类的包（与约定）相关联。
      static Preferences Preferences.userRoot​()
      返回主叫用户的根优先级节点。
      Preferences PreferencesFactory.userRoot​()
      返回与主叫用户对应的用户根优先级节点。
      Constructors in java.util.prefs with parameters of type Preferences
      Constructor 描述
      NodeChangeEvent​(Preferences parent, Preferences child)
      构造一个新的 NodeChangeEvent实例。
      PreferenceChangeEvent​(Preferences node, String key, String newValue)
      构造一个新的 PreferenceChangeEvent实例。

    • Uses of Preferences in jdk.jshell.tool

      Methods in jdk.jshell.tool with parameters of type Preferences
      Modifier and Type 方法 描述
      JavaShellToolBuilder JavaShellToolBuilder.persistence​(Preferences prefs)
      Set the storage mechanism for persistent information which includes input history and retained settings.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.prefs.NodeChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.prefs.NodeChangeListener

  • Packages that use NodeChangeListener
    软件包 描述
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

    • Uses of NodeChangeListener in java.util.prefs

      Methods in java.util.prefs with parameters of type NodeChangeListener
      Modifier and Type | 方法 | 描述
      void | AbstractPreferences.addNodeChangeListener​(NodeChangeListener ncl)
      abstract void Preferences.addNodeChangeListener​(NodeChangeListener ncl)
      注册指定的侦听器以接收该节点的 节点更改事件 。
      void | AbstractPreferences.removeNodeChangeListener​(NodeChangeListener ncl)
      abstract void Preferences.removeNodeChangeListener​(NodeChangeListener ncl)
      删除指定的 NodeChangeListener ，所以它不再收到更改事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.prefs.PreferenceChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.prefs.PreferenceChangeListener

  • Packages that use PreferenceChangeListener
    软件包 描述
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

    • Uses of PreferenceChangeListener in java.util.prefs

      Methods in java.util.prefs with parameters of type PreferenceChangeListener
      Modifier and Type | 方法 | 描述
      void | AbstractPreferences.addPreferenceChangeListener​(PreferenceChangeListener pcl)
      abstract void Preferences.addPreferenceChangeListener​(PreferenceChangeListener pcl)
      注册指定的侦听器以接收此首选项节点的 优先级更改事件 。
      void | AbstractPreferences.removePreferenceChangeListener​(PreferenceChangeListener pcl)
      abstract void Preferences.removePreferenceChangeListener​(PreferenceChangeListener pcl)
      删除指定的首选项更改侦听器，因此它不再接收首选项更改事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.prefs.PreferencesFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.prefs.PreferencesFactory

No usage of java.util.prefs.PreferencesFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


java.util.regex (Java SE 9 & JDK 9 )

java.util.regex

Interfaces

  • MatchResult

Classes

  • Matcher
  • Pattern

Exceptions

  • PatternSyntaxException


java.util.regex (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util.regex

匹配字符序列与正则表达式指定的模式的类。

Pattern类的一个实例表示一个正则表达式，它以与Perl所使用的类似的语法以字符串形式指定。

Matcher类的实例用于匹配给定模式的字符序列。 输入通过CharSequence接口提供给匹配器，以支持与来自各种输入源的字符的匹配。

除非另有说明，否则将null参数传递给此程序包中任何类或接口中的方法将导致抛出NullPointerException 。

相关文档

一个很好的教程和正则表达式的概述是Mastering Regular Expressions, Jeffrey E. F. Friedl, O'Reilly and Associates, 1997.

从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    MatchResult
    匹配操作的结果。
  • 类摘要
    Class 描述
    Matcher
    通过解释Pattern对character sequence执行匹配操作的引擎。
    Pattern
    正则表达式的编译表示。
  • 异常摘要
    异常 描述
    PatternSyntaxException
    抛出未经检查的异常，以指示正则表达式模式中的语法错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.regex Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.regex

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.regex.Matcher (implements java.util.regex.MatchResult)
    • java.util.regex.Pattern (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.regex.PatternSyntaxException

Interface Hierarchy

  • java.util.regex.MatchResult
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Matcher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.regex

Class Matcher

  • java.lang.Object
    • java.util.regex.Matcher
  • All Implemented Interfaces:
    MatchResult

    public final class Matcher
extends Object
implements MatchResult
    通过解释Pattern对character sequence执行匹配操作的引擎。

    通过调用模式的matcher方法，从模式创建匹配器。 创建后，可以使用匹配器执行三种不同类型的匹配操作：

    • matches方法尝试将整个输入序列与模式进行匹配。

    • lookingAt方法尝试将起始于输入序列的输入序列与模式进行匹配。

    • find方法扫描输入序列，寻找匹配模式的下一个子序列。

    这些方法中的每一个返回一个指示成功或失败的布尔值。 通过查询匹配器的状态可以获得有关成功匹配的更多信息。

    匹配器在其输入的子集中找到称为该区域的匹配项。 默认情况下，该区域包含所有匹配器的输入。 该区域可以通过region方法进行修改，并通过regionStart和regionEnd方法进行查询。 区域边界与某些模式构造交互的方式可以改变。 有关详细信息，请参阅useAnchoringBounds和useTransparentBounds 。

    该类还定义了用新字符串替换匹配子序列的方法，如果需要，可以根据匹配结果计算其内容。 可以串联使用appendReplacement和appendTail方法，以便将结果收集到现有的字符串缓冲区或字符串构建器中。 或者，可以使用更方便的方法replaceAll来创建一个字符串，其中输入序列中的每个匹配子序列被替换。

    匹配器的显式状态包括最近成功匹配的开始和结束索引。 它还包括每个capturing group在模式中捕获的输入子序列的开始和结束索引以及这样的子序列的总计数。 为了方便起见，还提供了用于以字符串形式返回这些捕获的子序列的方法。

    最初未定义匹配器的显式状态; 尝试在成功匹配之前查询任何部分将导致抛出IllegalStateException 。 匹配器的显式状态由每个匹配操作重新计算。

    匹配器的隐含状态包括输入字符序列以及附加位置 ，其最初为零，并由appendReplacement方法更新。

    匹配器可以通过调用其reset()方法显式地重置，或者如果需要新的输入序列，则它的reset(CharSequence)方法。 重置匹配器会丢弃其显式状态信息，并将附加位置设置为零。

    此类的实例不能安全地被多个并发线程使用。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Matcher appendReplacement​(StringBuffer sb, String replacement)
      实施非终端附加和替换步骤。
      Matcher appendReplacement​(StringBuilder sb, String replacement)
      实施非终端附加和替换步骤。
      StringBuffer appendTail​(StringBuffer sb)
      实施终端附加和替换步骤。
      StringBuilder appendTail​(StringBuilder sb)
      实施终端附加和替换步骤。
      int end​()
      返回最后一个字符匹配后的偏移量。
      int end​(int group)
      返回在上次匹配操作期间由给定组捕获的子序列的最后一个字符之后的偏移量。
      int end​(String name)
      返回在上一次匹配操作期间由给定的 named-capturing group捕获的子序列的最后一个字符之后的偏移量。
      boolean find​()
      尝试找到匹配模式的输入序列的下一个子序列。
      boolean find​(int start)
      重新设置该匹配器，然后尝试从指定的索引开始找到匹配模式的输入序列的下一个子序列。
      String group​()
      返回与上一个匹配匹配的输入子序列。
      String group​(int group)
      返回在上一次匹配操作期间由给定组捕获的输入子序列。
      String group​(String name)
      返回在上一次匹配操作期间由给定的 named-capturing group捕获的输入子序列。
      int groupCount​()
      返回此匹配器模式中捕获组的数量。
      boolean hasAnchoringBounds​()
      查询该匹配器的区域边界的锚定。
      boolean hasTransparentBounds​()
      查询此匹配器的区域边界的透明度。
      boolean hitEnd​()
      如果在匹配器执行的最后一次匹配操作中输入的结尾被搜索引擎命中，则返回true。
      boolean lookingAt​()
      尝试将输入序列从区域开头开始与模式相匹配。
      boolean matches​()
      尝试将整个区域与模式进行匹配。
      Pattern pattern​()
      返回该匹配器解释的模式。
      static String quoteReplacement​(String s)
      返回面值替换 String指定的 String 。
      Matcher region​(int start, int end)
      设置该匹配器区域的限制。
      int regionEnd​()
      报告该匹配器区域的最终索引（排他）。
      int regionStart​()
      报告该匹配器区域的开始索引。
      String replaceAll​(String replacement)
      将与模式匹配的输入序列的每个子序列替换为给定的替换字符串。
      String replaceAll​(Function<MatchResult,String> replacer)
      将与模式匹配的输入序列的每个子序列替换为将给定的替换器函数应用于与该子序列相对应的匹配器的匹配结果的结果。
      String replaceFirst​(String replacement)
      将与模式匹配的输入序列的第一个子序列替换为给定的替换字符串。
      String replaceFirst​(Function<MatchResult,String> replacer)
      将与模式匹配的输入序列的第一个子序列替换为将给定的替换器函数应用于与该子序列对应的匹配器的匹配结果的结果。
      boolean requireEnd​()
      如果更多输入可以将正匹配更改为否定，则返回true。
      Matcher reset​()
      重设此匹配器。
      Matcher reset​(CharSequence input)
      使用新的输入序列重置此匹配器。
      Stream<MatchResult> results​()
      返回与模式匹配的输入序列的每个子序列的匹配结果流。
      int start​()
      返回上一个匹配的起始索引。
      int start​(int group)
      返回给定组在上一个匹配操作期间捕获的子序列的开始索引。
      int start​(String name)
      返回在上一个匹配操作期间由给定的 named-capturing group捕获的子序列的起始索引。
      MatchResult toMatchResult​()
      将该匹配器的匹配状态返回为MatchResult 。
      String toString​()
      返回此匹配器的字符串表示形式。
      Matcher useAnchoringBounds​(boolean b)
      设置该匹配器的区域边界的锚定。
      Matcher usePattern​(Pattern newPattern)
      更改 Pattern ，这 Matcher用于查找与匹配。
      Matcher useTransparentBounds​(boolean b)
      设置此匹配器的区域边界的透明度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • pattern

        public Pattern pattern​()
        返回该匹配器解释的模式。
        结果
        该匹配器创建的模式

      • toMatchResult

        public MatchResult toMatchResult​()
        将该匹配器的匹配状态返回为MatchResult 。 结果不受在此匹配器上执行的后续操作的影响。
        结果
        一个 MatchResult与这个匹配器的状态
        从以下版本开始：
        1.5

      • usePattern

        public Matcher usePattern​(Pattern newPattern)
        更改Pattern ，这个Matcher用于查找匹配。

        此方法会导致此匹配器丢失有关发生的最后一个匹配的组的信息。 匹配器在输入中的位置得到维护，其最后一个附加位置不受影响。

        参数
        newPattern - 该匹配器使用的新模式
        结果
        这个匹配器
        异常
        IllegalArgumentException - 如果newPattern是 null
        从以下版本开始：
        1.5

      • reset

        public Matcher reset​()
        重设此匹配器。

        重置匹配器会丢弃其所有的显式状态信息，并将其附加位置设置为零。 匹配器的区域设置为默认区域，它是其整个字符序列。 该匹配器区域边界的锚定和透明度不受影响。

        结果
        这个匹配器

      • reset

        public Matcher reset​(CharSequence input)
        使用新的输入序列重置此匹配器。

        重置匹配器会丢弃其所有的显式状态信息，并将其附加位置设置为零。 匹配器的区域设置为默认区域，它是其整个字符序列。 该匹配器区域边界的锚定和透明度不受影响。

        参数
        input - 新的输入字符序列
        结果
        这个匹配器

      • start

        public int start​()
        返回上一个匹配的起始索引。
        Specified by:
        start在接口 MatchResult
        结果
        第一个字符的索引匹配
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一个匹配操作失败

      • start

        public int start​(int group)
        返回给定组在上一个匹配操作期间捕获的子序列的开始索引。

        Capturing groups从左到右索引，从一开始。 组零表示整个模式，所以表达式m。 start(0)相当于m。 start() 。

        Specified by:
        start在接口 MatchResult
        参数
        group - 此匹配器模式中捕获组的索引
        结果
        该组捕获的第一个角色的索引，或 -1如果匹配成功，但组本身不匹配任何东西
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一个匹配操作失败
        IndexOutOfBoundsException - 如果在给定索引的模式中没有捕获组

      • start

        public int start​(String name)
        返回在上一次匹配操作期间由给定的 named-capturing group捕获的子序列的起始索引。
        参数
        name - 此匹配器模式中的命名捕获组的名称
        结果
        该组所捕获的第一个角色的索引，如果匹配成功但是该组本身不匹配任何内容， -1
        异常
        IllegalStateException - 如果尚未尝试匹配，或者以前的匹配操作失败
        IllegalArgumentException - 如果在给定名称的模式中没有捕获组
        从以下版本开始：
        1.8

      • end

        public int end​()
        返回最后一个字符匹配后的偏移量。
        Specified by:
        end在接口 MatchResult
        结果
        最后一个字符匹配后的偏移量
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一匹配操作失败

      • end

        public int end​(int group)
        返回在上次匹配操作期间由给定组捕获的子序列的最后一个字符之后的偏移量。

        Capturing groups从左到右索引，从一开始。 组零表示整个模式，所以表达式m。 end(0)相当于m。 end() 。

        Specified by:
        end在接口 MatchResult
        参数
        group - 该匹配器模式中捕获组的索引
        结果
        在组合捕获的最后一个角色之后的偏移量，或 -1如果匹配成功但组本身不匹配任何
        异常
        IllegalStateException - 如果尚未尝试匹配，或者以前的匹配操作失败
        IndexOutOfBoundsException - 如果在给定索引的模式中没有捕获组

      • end

        public int end​(String name)
        返回在上一次匹配操作期间由给定的 named-capturing group捕获的子序列的最后一个字符之后的偏移量。
        参数
        name - 此匹配器模式中的命名捕获组的名称
        结果
        由组合捕获的最后一个角色后的偏移量，如果匹配成功，但组合本身不匹配任何内容， -1
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一个匹配操作失败
        IllegalArgumentException - 如果在给定名称的模式中没有捕获组
        从以下版本开始：
        1.8

      • group

        public String group​()
        返回与上一个匹配匹配的输入子序列。

        对于具有输入序列s的匹配器m ，表达式m。 group()和s。 substring( m。 start(), m。 end())是等效的。

        请注意，某些模式，例如a* ，匹配空字符串。 当模式成功匹配输入中的空字符串时，此方法将返回空字符串。

        Specified by:
        group在接口 MatchResult
        结果
        以前的匹配匹配的（可能是空的）子序列，以字符串形式
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一匹配操作失败

      • group

        public String group​(int group)
        返回在上一次匹配操作期间由给定组捕获的输入子序列。

        对于匹配器m ，输入序列s和组索引g ，表达式m。 group( g )和s。 substring( m。 start( g ), m。 end( g ))是等效的。

        Capturing groups从左到右索引，从一开始。 组零表示整个模式，因此表达式m.group(0)相当于m.group() 。

        如果匹配成功，但指定的组失败，则匹配输入序列的任何部分，则返回null 。 请注意，某些组（例如(a*) ）与空字符串匹配。 当这样的组成功匹配输入中的空字符串时，此方法将返回空字符串。

        Specified by:
        group在接口 MatchResult
        参数
        group - 此匹配器模式中捕获组的索引
        结果
        在上一次比赛期间由组捕获的（可能为空的）子序列，如果组未能匹配输入的一部分， null
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一个匹配操作失败
        IndexOutOfBoundsException - 如果在给定索引的模式中没有捕获组

      • group

        public String group​(String name)
        返回在上一次匹配操作期间由给定的named-capturing group捕获的输入子序列。

        如果匹配成功，但指定的组失败，则匹配输入序列的任何部分，则返回null 。 请注意，某些组（例如(a*) ）与空字符串匹配。 当这样的组成功匹配输入中的空字符串时，此方法将返回空字符串。

        参数
        name - 此匹配器模式中的命名捕获组的名称
        结果
        在上一次匹配期间由命名组捕获的（可能为空的）子序列，如果组未能匹配输入的一部分， null
        异常
        IllegalStateException - 如果尚未尝试匹配，或者以前的匹配操作失败
        IllegalArgumentException - 如果在给定名称的模式中没有捕获组
        从以下版本开始：
        1.7

      • groupCount

        public int groupCount​()
        返回此匹配器模式中捕获组的数量。

        组零表示按照惯例的整个模式。 它不包括在这个计数。

        任何小于或等于此方法返回值的非负整数将被保证为此匹配器的有效组索引。

        Specified by:
        groupCount在接口 MatchResult
        结果
        在该匹配器模式中捕获组的数量

      • matches

        public boolean matches​()
        尝试将整个区域与模式进行匹配。

        如果匹配成功可以通过获得那么更多的信息start ， end ，和group方法。

        结果
        true如果并且仅当整个区域序列匹配该匹配器的模式

      • find

        public boolean find​()
        尝试找到匹配模式的输入序列的下一个子序列。

        该方法从该匹配器区域的开始处开始，或者如果该方法的先前调用成功，并且匹配器尚未被重置，则在与之前匹配不匹配的第一个字符处。

        如果匹配成功可以通过获得那么更多的信息start ， end ，和group方法。

        结果
        true如果并且仅当输入序列的子序列匹配该匹配器的模式

      • find

        public boolean find​(int start)
        重新设置该匹配器，然后尝试从指定的索引开始找到匹配模式的输入序列的下一个子序列。

        如果匹配成功可以通过获得那么更多的信息start ， end ，和group方法和的后续调用find()方法将在不受此匹配匹配的第一个字符开始。

        参数
        start - 开始搜索匹配的索引
        结果
        true如果并且仅当从给定索引开始的输入序列的子序列匹配该匹配器的模式
        异常
        IndexOutOfBoundsException - 如果start小于零，或者start大于输入序列的长度。

      • lookingAt

        public boolean lookingAt​()
        尝试将输入序列从区域开头开始与模式相匹配。

        像matches方法一样，该方法始终从该区域的开头开始; 不同于该方法，它不要求整个区域匹配。

        如果匹配成功可以通过获得那么更多的信息start ， end ，和group方法。

        结果
        true如果并且仅当输入序列的前缀匹配该匹配器的模式

      • quoteReplacement

        public static String quoteReplacement​(String s)
        返回String的文字替换String 。 这种方法产生一个String ，将工作作为文字置换s在appendReplacement所述的方法Matcher类。 产生的String将匹配s被视为文字序列的字符序列。 斜杠（'''）和美元符号（'$'）将没有特殊意义。
        参数
        s - 要被字面化的字符串
        结果
        一个文字字符串替换
        从以下版本开始：
        1.5

      • appendReplacement

        public Matcher appendReplacement​(StringBuffer sb,
                                 String replacement)
        实施非终端附加和替换步骤。

        此方法执行以下操作：

        1. 它从输入序列读取字符，从附加位置开始，并将它们附加到给定的字符串缓冲区。 读取上一个匹配之前的最后一个字符，即索引号start() - 1处的字符1 。

        2. 它将给定的替换字符串附加到字符串缓冲区。

        3. 它将该匹配器的附加位置设置为匹配的最后一个字符的索引，加上一个，即end() 。

        替换字符串可能包含对上次匹配期间捕获的子序列的引用：每次出现的${ 名称 }或$ g将分别由相应的group(name)或group(g)的评估结果代替。 为$ g，则之后的第一数目$始终被视为该组参考的一部分。 如果他们将组成法律团体参考，则将后续数字并入g。 只有数字“0”到“9”被认为是组参考的潜在组件。 例如，如果第二组匹配字符串"foo" ，则传递替换字符串"$2bar"将导致将"foobar"附加到字符串缓冲器。 一个美元符号（ $ ）可以作为替代字符串中的文字包含在反斜杠前面（ \$ ）。

        请注意，替换字符串中的反斜杠（ \ ）和美元符号（ $ ）可能会导致结果与将其视为文字替换字符串时的结果不同。 如上所述，美元符号可被视为对捕获子序列的引用，反斜杠用于转义替换字符串中的文字字符。

        该方法旨在与appendTail和find方法一起用于循环。 例如，以下代码将one dog two dogs in the yard写入标准输出流：

         Pattern p = Pattern.compile("cat");
 Matcher m = p.matcher("one cat two cats in the yard");
 StringBuffer sb = new StringBuffer();
 while (m.find()) {
     m.appendReplacement(sb, "dog");
 }
 m.appendTail(sb);
 System.out.println(sb.toString());
        参数
        sb - 目标字符串缓冲区
        replacement - 替换字符串
        结果
        这个匹配器
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一个匹配操作失败
        IllegalArgumentException - 如果替换字符串是指在模式中不存在的命名捕获组
        IndexOutOfBoundsException - 如果替换字符串是指在模式中不存在的捕获组

      • appendReplacement

        public Matcher appendReplacement​(StringBuilder sb,
                                 String replacement)
        实施非终端附加和替换步骤。

        此方法执行以下操作：

        1. 它从输入序列读取字符，从附加位置开始，并将它们附加到给定的字符串构建器。 在读取上一个匹配之前的最后一个字符，即索引号为start() - 1的字符后1 。

        2. 它将给定的替换字符串附加到字符串构建器。

        3. 它将此匹配器的附加位置设置为匹配的最后一个字符的索引，加上一个，即end() 。

        替换字符串可能包含对上次匹配期间捕获的子序列的引用：每次出现的$ g将被评估结果group ( g ) 。 $之后的第一个数字始终被视为组参考的一部分。 如果他们将组成法律团体参考，则将后续数字并入g。 只有数字“0”到“9”被认为是组参考的潜在组件。 例如，如果第二组匹配字符串"foo" ，则传递替换字符串"$2bar"将导致"foobar"附加到字符串构建器。 可以在替换字符串中包含一个美元符号（ $ ）作为文字，然后使用反斜杠（ \$ ）。

        请注意，替换字符串中的反斜杠（ \ ）和美元符号（ $ ）可能会导致结果与将其视为文字替换字符串时的结果不同。 如上所述，美元符号可被视为对捕获子序列的引用，反斜杠用于转义替换字符串中的文字字符。

        该方法旨在与appendTail和find方法一起用于循环。 例如，以下代码将one dog two dogs in the yard写入标准输出流：

         Pattern p = Pattern.compile("cat");
 Matcher m = p.matcher("one cat two cats in the yard");
 StringBuilder sb = new StringBuilder();
 while (m.find()) {
     m.appendReplacement(sb, "dog");
 }
 m.appendTail(sb);
 System.out.println(sb.toString());
        参数
        sb - 目标字符串构建器
        replacement - 替换字符串
        结果
        这个匹配器
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一个匹配操作失败
        IllegalArgumentException - 如果替换字符串是指在模式中不存在的命名捕获组
        IndexOutOfBoundsException - 如果替换字符串是指在模式中不存在的捕获组
        从以下版本开始：
        9

      • appendTail

        public StringBuffer appendTail​(StringBuffer sb)
        实施终端附加和替换步骤。

        此方法从输入序列读取字符，从追加位置开始，并将其附加到给定的字符串缓冲区。 打算在appendReplacement方法的一次或多次调用后调用，以复制输入序列的其余部分。

        参数
        sb - 目标字符串缓冲区
        结果
        目标字符串缓冲区

      • appendTail

        public StringBuilder appendTail​(StringBuilder sb)
        实施终端附加和替换步骤。

        此方法从输入序列读取字符，从追加位置开始，并将其附加到给定的字符串构建器。 在appendReplacement方法的一个或多个调用之后，它将被调用，以便复制输入序列的其余部分。

        参数
        sb - 目标字符串构建器
        结果
        目标字符串构建器
        从以下版本开始：
        9

      • replaceAll

        public String replaceAll​(String replacement)
        将与模式匹配的输入序列的每个子序列替换为给定的替换字符串。

        该方法首先重置此匹配器。 然后扫描输入序列，查找模式的匹配。 不属于任何匹配的字符将直接追加到结果字符串中; 每个匹配在替换字符串的结果中被替换。 替换字符串可能包含对appendReplacement方法中捕获的子序列的引用 。

        请注意，替换字符串中的反斜杠（ \ ）和美元符号（ $ ）可能会导致结果与被视为文字替换字符串时的结果不同。 如上所述，美元符号可被视为对捕获子序列的引用，反斜杠用于转义替换字符串中的文字字符。

        给定正则表达式a*b ，输入"aabfooaabfooabfoob"和替换字符串"-" ，在该表达式的匹配器上调用此方法将产生字符串"-foo-foo-foo-" 。

        调用此方法会更改此匹配器的状态。 如果匹配器用于进一步的匹配操作，那么应该首先被重置。

        参数
        replacement - 替换字符串
        结果
        通过用替换字符串替换每个匹配子序列构造的字符串，根据需要代替捕获的子序列

      • replaceAll

        public String replaceAll​(Function<MatchResult,String> replacer)
        将与模式匹配的输入序列的每个子序列替换为将给定的替换器函数应用于与该子序列相对应的匹配器的匹配结果的结果。 函数抛出的异常被转发给调用方。

        该方法首先重置此匹配器。 然后扫描输入序列，查找模式的匹配。 不属于任何匹配的字符将直接追加到结果字符串中; 通过应用返回替换字符串的替换函数，在结果中替换每个匹配项。 每个替换字符串可能包含对appendReplacement方法中捕获的子序列的引用 。

        请注意，替换字符串中的反斜杠（ \ ）和美元符号（ $ ）可能会导致结果与被视为文字替换字符串时的结果不同。 如上所述，美元符号可被视为对捕获子序列的引用，反斜杠用于转义替换字符串中的文字字符。

        给定正则表达式dog ，输入"zzzdogzzzdogzzz"和函数mr -> mr.group().toUpperCase() ，在该表达式的匹配器上调用此方法将产生字符串"zzzDOGzzzDOGzzz" 。

        调用此方法会更改此匹配器的状态。 如果匹配器用于进一步的匹配操作，那么应该首先被重置。

        替换功能不应在更换期间修改该匹配器的状态。 如果检测到这种修改，这个方法将尽力而为地抛出一个ConcurrentModificationException 。

        传递给替换器函数的每个匹配结果的状态只有在替换器函数调用的持续时间才被保持为常量，并且仅当替换器函数不修改该匹配器的状态时才保持。

        Implementation Note:
        此实现将 MatchResult器函数应用于此匹配器，该匹配器是 MatchResult的实例。
        参数
        replacer - 应用于此匹配器的匹配结果的函数，该匹配结果返回替换字符串。
        结果
        通过将每个匹配子序列替换为将匹配子函数应用到匹配子序列的结果来构造的字符串，根据需要代替捕获的子序列。
        异常
        NullPointerException - 如果 NullPointerException函数为空
        ConcurrentModificationException - 如果在尽力而为的基础上检测到 ConcurrentModificationException功能修改了该匹配器的状态
        从以下版本开始：
        9

      • results

        public Stream<MatchResult> results​()
        返回与模式匹配的输入序列的每个子序列的匹配结果流。 匹配结果以与输入序列中的匹配子序列相同的顺序发生。

        每个匹配结果的产生如toMatchResult() 。

        此方法不会重置此匹配器。 在该匹配器区域的开始处开始终端流操作时开始匹配，或者如果匹配器尚未被重置，则在与之前的匹配不匹配的第一个字符处。

        如果匹配器在终端流操作完成后用于进一步匹配操作，则应首先重新设置。

        在执行返回的流的管道期间，不应修改该匹配器的状态。 返回的流的源码Spliterator是故障快速的 ，如果检测到这样的修改，将尽力而为地抛出一个ConcurrentModificationException 。

        结果
        顺序的匹配结果流。
        从以下版本开始：
        9

      • replaceFirst

        public String replaceFirst​(String replacement)
        将与模式匹配的输入序列的第一个子序列替换为给定的替换字符串。

        该方法首先重置此匹配器。 然后扫描输入序列寻找模式的匹配。 不属于匹配的字符将直接附加到结果字符串中; 匹配在结果中被替换字符串替换。 替换字符串可能包含对appendReplacement方法中捕获的子序列的引用 。

        请注意，替换字符串中的反斜杠（ \ ）和美元符号（ $ ）可能会导致结果与将其视为文字替换字符串时的结果不同。 如上所述，美元符号可被视为对捕获子序列的引用，反斜杠用于转义替换字符串中的文字字符。

        给定正则表达式dog ，输入"zzzdogzzzdogzzz"和替换字符串"cat" ，对该表达式的匹配器上的此方法的调用将产生字符串"zzzcatzzzdogzzz" 。

        调用此方法会更改此匹配器的状态。 如果匹配器用于进一步的匹配操作，那么应该首先被重置。

        参数
        replacement - 替换字符串
        结果
        通过用替换字符串替换第一匹配子序列构造的字符串，根据需要代替捕获的子序列

      • replaceFirst

        public String replaceFirst​(Function<MatchResult,String> replacer)
        将与模式匹配的输入序列的第一个子序列替换为将给定的替换器函数应用于与该子序列对应的匹配器的匹配结果的结果。 替换功能抛出的异常被转发给调用者。

        该方法首先重置此匹配器。 然后扫描输入序列寻找模式的匹配。 不属于匹配的字符将直接附加到结果字符串中; 通过应用返回替换字符串的替换函数，在结果中替换匹配项。 替换字符串可能包含对appendReplacement方法中捕获的子序列的引用 。

        请注意，替换字符串中的反斜杠（ \ ）和美元符号（ $ ）可能会导致结果与将其视为文字替换字符串时的结果不同。 如上所述，美元符号可被视为对捕获子序列的引用，反斜杠用于转义替换字符串中的文字字符。

        给定正则表达式dog ，输入"zzzdogzzzdogzzz"和函数mr -> mr.group().toUpperCase() ，对该表达式的匹配器调用此方法将产生字符串"zzzDOGzzzdogzzz" 。

        调用此方法会更改此匹配器的状态。 如果匹配器用于进一步的匹配操作，那么应该首先被重置。

        替换功能不应在更换期间修改该匹配器的状态。 如果检测到这种修改，该方法将尽力而为地抛出ConcurrentModificationException 。

        传递给替换器函数的匹配结果的状态只有在替换器函数调用的持续时间才被保持为常量，并且仅当替换器函数不修改该匹配器的状态时才保持。

        Implementation Note:
        此实现将 MatchResult器函数应用于此匹配器，该匹配器是 MatchResult的实例。
        参数
        replacer - 要应用于该匹配器的返回替换字符串的匹配结果的函数。
        结果
        通过将第一匹配子序列替换为将匹配子序列应用到匹配子序列的结果来构造的字符串，根据需要代替捕获的子序列。
        异常
        NullPointerException - 如果 NullPointerException函数为空
        ConcurrentModificationException - 如果在尽力而为的基础上检测到 ConcurrentModificationException功能修改了该匹配器的状态
        从以下版本开始：
        9

      • region

        public Matcher region​(int start,
                      int end)
        设置该匹配器区域的限制。 该区域是将被搜索以找到匹配的输入序列的一部分。 调用此方法重置匹配器，然后设置区域由指定的索引处开始start由指定的索引在参数和结束end参数。

        根据所使用的透明度和锚定（参见useTransparentBounds和useAnchoringBounds ），诸如锚的某些构造可能在该区域的边界处或周围具有不同的表现。

        参数
        start - 开始搜索的索引（含）
        end - 结束搜索的索引（独占）
        结果
        这个匹配器
        异常
        IndexOutOfBoundsException - 如果start或end小于零，如果start大于输入序列的长度，如果end大于输入序列的长度，或者start大于end。
        从以下版本开始：
        1.5

      • regionStart

        public int regionStart​()
        报告该匹配器区域的开始索引。 此匹配器进行的搜索仅限于在regionStart （含）和regionEnd （排他）中找到匹配项 。
        结果
        这个匹配者地区的起点
        从以下版本开始：
        1.5

      • regionEnd

        public int regionEnd​()
        报告该匹配器区域的最终索引（排他）。 此匹配器进行的搜索仅限于在regionStart （含）和regionEnd （排他）中找到匹配项 。
        结果
        该匹配器区域的终点
        从以下版本开始：
        1.5

      • hasTransparentBounds

        public boolean hasTransparentBounds​()
        查询此匹配器的区域边界的透明度。

        此方法返回true如果此匹配使用透明边界， false如果它使用不透明边界。

        有关透明和不透明边界的说明，请参阅useTransparentBounds 。

        默认情况下，匹配器使用不透明区域边界。

        结果
        true iff这个匹配器是否使用透明边界，否则 false 。
        从以下版本开始：
        1.5
        另请参见：
        useTransparentBounds(boolean)

      • useTransparentBounds

        public Matcher useTransparentBounds​(boolean b)
        设置此匹配器的区域边界的透明度。

        使用参数true调用此方法将设置此匹配器以使用透明边界。 如果布尔参数为false ，则将使用不透明边界。

        使用透明边界，该匹配器区域的边界对于lookahead，lookbehind和边界匹配结构是透明的。 那些结构可以超越该地区的边界，看看匹配是否合适。

        使用不透明边界，该匹配器区域的边界对于可能尝试超越它们的查找，lookbehind和边界匹配结构是不透明的。 这些构造不能超越边界，因此它们将无法匹配该区域之外的任何内容。

        默认情况下，匹配器使用不透明边界。

        参数
        b - 指示是否使用不透明或透明区域的布尔值
        结果
        这个匹配器
        从以下版本开始：
        1.5
        另请参见：
        hasTransparentBounds()

      • hasAnchoringBounds

        public boolean hasAnchoringBounds​()
        查询该匹配器的区域边界的锚定。

        该方法返回true如果此匹配使用固定界限， false否则。

        有关锚定界限的描述，请参阅useAnchoringBounds 。

        默认情况下，匹配器使用锚定区域边界。

        结果
        true如果这个匹配器正在使用锚定边界，否则为 false 。
        从以下版本开始：
        1.5
        另请参见：
        useAnchoringBounds(boolean)

      • useAnchoringBounds

        public Matcher useAnchoringBounds​(boolean b)
        设置该匹配器的区域边界的锚定。

        使用参数true调用此方法将设置此匹配器以使用锚定边界。 如果布尔参数为false ，则将使用非锚定边界。

        使用锚定边界，该匹配器区域的边界匹配诸如^和$之类的锚点。

        没有锚定边界，该匹配器区域的边界将不匹配诸如^和$之类的锚点。

        默认情况下，匹配器使用锚定区域边界。

        参数
        b - 一个布尔值，表示是否使用固定边界。
        结果
        这个匹配器
        从以下版本开始：
        1.5
        另请参见：
        hasAnchoringBounds()

      • toString

        public String toString​()

        返回此匹配器的字符串表示形式。 Matcher的字符串表示Matcher包含可能对调试有用的信息。 确切的格式是未指定的。

        重写：
        toString在 Object
        结果
        该匹配器的字符串表示形式
        从以下版本开始：
        1.5

      • hitEnd

        public boolean hitEnd​()

        如果在匹配器执行的最后一次匹配操作中输入的结尾被搜索引擎命中，则返回true。

        当此方法返回true时，可能更多的输入会改变上一次搜索的结果。

        结果
        如果输入的结尾在最后一场比赛中被击中，则为true; 否则为假
        从以下版本开始：
        1.5

      • requireEnd

        public boolean requireEnd​()

        如果更多输入可以将正匹配更改为否定，则返回true。

        如果此方法返回true，并且找到匹配，则更多的输入可能会导致匹配丢失。 如果此方法返回false并找到匹配，则更多输入可能会更改匹配，但匹配不会丢失。 如果没有找到匹配项，那么requireEnd就没有意义了。

        结果
        如果更多的输入可以将正匹配改变为负值，则为true。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MatchResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.regex

Interface MatchResult

  • 所有已知实现类：
    Matcher

    public interface MatchResult
    匹配操作的结果。

    该界面包含用于确定与正则表达式匹配的结果的查询方法。 可以看到匹配边界，组和组边界，但不能通过MatchResult修改。

    从以下版本开始：
    1.5
    另请参见：
    Matcher

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int end​()
      返回最后一个字符匹配后的偏移量。
      int end​(int group)
      返回给定组在此匹配期间捕获的子序列的最后一个字符之后的偏移量。
      String group​()
      返回与上一个匹配匹配的输入子序列。
      String group​(int group)
      返回在上一次匹配操作期间由给定组捕获的输入子序列。
      int groupCount​()
      返回此匹配结果模式中捕获组的数量。
      int start​()
      返回匹配的起始索引。
      int start​(int group)
      返回在此匹配期间由给定组捕获的子序列的开始索引。

    • 方法详细信息

      • start

        int start​()
        返回匹配的起始索引。
        结果
        第一个字符的索引匹配
        异常
        IllegalStateException - 如果尚未尝试匹配，或者以前的匹配操作失败

      • start

        int start​(int group)
        返回在此匹配期间由给定组捕获的子序列的开始索引。

        Capturing groups从左到右索引，从一开始。 组零表示整个模式，所以表达式m。 start(0)相当于m。 start() 。

        参数
        group - 此匹配器模式中捕获组的索引
        结果
        该组捕获的第一个角色的索引，或 -1如果匹配成功，但组本身不匹配任何东西
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一个匹配操作失败
        IndexOutOfBoundsException - 如果在给定索引的模式中没有捕获组

      • end

        int end​()
        返回最后一个字符匹配后的偏移量。
        结果
        最后一个字符匹配后的偏移量
        异常
        IllegalStateException - 如果尚未尝试匹配，或者以前的匹配操作失败

      • end

        int end​(int group)
        返回给定组在此匹配期间捕获的子序列的最后一个字符之后的偏移量。

        Capturing groups从左到右进行索引，从一开始。 组零表示整个模式，所以表达式m。 end(0)相当于m。 end() 。

        参数
        group - 此匹配器模式中捕获组的索引
        结果
        在组合捕获的最后一个角色之后的偏移量，或 -1如果匹配成功但组本身不匹配任何内容
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一匹配操作失败
        IndexOutOfBoundsException - 如果在给定索引的模式中没有捕获组

      • group

        String group​()
        返回与上一个匹配匹配的输入子序列。

        对于具有输入序列s的匹配器m ，表达式m。 group()和s。 substring( m。 start(), m end())是等效的。

        请注意，某些模式（例如a* ）与空字符串匹配。 当模式成功匹配输入中的空字符串时，此方法将返回空字符串。

        结果
        以前的匹配匹配的（可能是空的）子序列，以字符串形式
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一匹配操作失败

      • group

        String group​(int group)
        返回在上一次匹配操作期间由给定组捕获的输入子序列。

        对于匹配器m ，输入序列s和组索引g ，表达式m。 group( g )和s。 substring( m。 start( g ), m。 end( g ))是等效的。

        Capturing groups从左到右索引，从一开始。 组零表示整个模式，因此表达式m.group(0)相当于m.group() 。

        如果匹配成功，但是指定的组不符合输入序列的任何部分，则返回null 。 请注意，某些组（例如(a*) ）与空字符串匹配。 当这样的组成功匹配输入中的空字符串时，此方法将返回空字符串。

        参数
        group - 此匹配器模式中捕获组的索引
        结果
        在前一次比赛期间，该组捕获的（可能为空的）子序列，如果该组未能匹配部分输入， null
        异常
        IllegalStateException - 如果尚未尝试匹配，或者前一匹配操作失败
        IndexOutOfBoundsException - 如果在给定索引的模式中没有捕获组

      • groupCount

        int groupCount​()
        返回此匹配结果模式中捕获组的数量。

        组零表示按照惯例的整个模式。 它不包括在这个计数。

        任何小于或等于此方法返回值的非负整数将被保证为此匹配器的有效组索引。

        结果
        The number of capturing groups in this matcher's pattern
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Pattern (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.regex

Class Pattern

  • java.lang.Object
    • java.util.regex.Pattern
  • All Implemented Interfaces:
    Serializable

    public final class Pattern
extends Object
implements Serializable
    正则表达式的编译表示。

    必须首先将正则表达式（指定为字符串）编译为此类的实例。 然后可以使用所得到的模式来创建一个Matcher对象，该对象可以匹配任意的character sequences与正则表达式。 执行匹配的所有状态都驻留在匹配器中，所以许多匹配者可以共享相同的模式。

    因此，典型的调用序列

     Pattern p = Pattern.compile("a*b");
 Matcher m = p.matcher("aaaaab");
 boolean b = m.matches();

    这个类定义了一个matches方法，以便在正常表达式只使用一次时方便。 该方法编译一个表达式，并在单个调用中匹配输入序列。 该声明

     boolean b = Pattern.matches("a*b", "aaaaab");
    相当于上面的三个语句，尽管对于重复匹配，它的效率较低，因为它不允许编译的模式被重用。

    这个类的实例是不可变的，可以安全地被多个并发线程使用。 Matcher课程的实例对于这种使用是不安全的。

    Summary of regular-expression constructs

    Regular expression constructs, and what they match Construct Matches Characters x The character x \\ The backslash character \0 n The character with octal value 0 n (0 <= n <= 7) \0 nn The character with octal value 0 nn (0 <= n <= 7) \0 mnn The character with octal value 0 mnn (0 <= m <= 3, 0 <= n <= 7) \x hh The character with hexadecimal value 0x hh \u hhhh The character with hexadecimal value 0x hhhh \x{h...h} The character with hexadecimal value 0x h...h (Character.MIN_CODE_POINT <= 0x h...h <= Character.MAX_CODE_POINT) \N{name} The character with Unicode character name 'name' \t The tab character ('\u0009') \n The newline (line feed) character ('\u000A') \r The carriage-return character ('\u000D') \f The form-feed character ('\u000C') \a The alert (bell) character ('\u0007') \e The escape character ('\u001B') \c x The control character corresponding to x Character classes [abc] a, b, or c (simple class) [^abc] Any character except a, b, or c (negation) [a-zA-Z] a through z or A through Z, inclusive (range) [a-d[m-p]] a through d, or m through p: [a-dm-p] (union) [a-z&&[def]] d, e, or f (intersection) [a-z&&[^bc]] a through z, except for b and c: [ad-z] (subtraction) [a-z&&[^m-p]] a through z, and not m through p: [a-lq-z](subtraction) Predefined character classes . Any character (may or may not match line terminators) \d A digit: [0-9] \D A non-digit: [^0-9] \h A horizontal whitespace character: [ \t\xA0\u1680\u180e\u2000-\u200a\u202f\u205f\u3000] \H A non-horizontal whitespace character: [^\h] \s A whitespace character: [ \t\n\x0B\f\r] \S A non-whitespace character: [^\s] \v A vertical whitespace character: [\n\x0B\f\r\x85\u2028\u2029] \V A non-vertical whitespace character: [^\v] \w A word character: [a-zA-Z_0-9] \W A non-word character: [^\w] POSIX character classes (US-ASCII only) \p{Lower} A lower-case alphabetic character: [a-z] \p{Upper} An upper-case alphabetic character:[A-Z] \p{ASCII} All ASCII:[\x00-\x7F] \p{Alpha} An alphabetic character:[\p{Lower}\p{Upper}] \p{Digit} A decimal digit: [0-9] \p{Alnum} An alphanumeric character:[\p{Alpha}\p{Digit}] \p{Punct} Punctuation: One of !"#$%&'()*+,-./:;<=>?@[\]^_`{|}~ \p{Graph} A visible character: [\p{Alnum}\p{Punct}] \p{Print} A printable character: [\p{Graph}\x20] \p{Blank} A space or a tab: [ \t] \p{Cntrl} A control character: [\x00-\x1F\x7F] \p{XDigit} A hexadecimal digit: [0-9a-fA-F] \p{Space} A whitespace character: [ \t\n\x0B\f\r] java.lang.Character classes (simple java character type) \p{javaLowerCase} Equivalent to java.lang.Character.isLowerCase() \p{javaUpperCase} Equivalent to java.lang.Character.isUpperCase() \p{javaWhitespace} Equivalent to java.lang.Character.isWhitespace() \p{javaMirrored} Equivalent to java.lang.Character.isMirrored() Classes for Unicode scripts, blocks, categories and binary properties \p{IsLatin} A Latin script character (script) \p{InGreek} A character in the Greek block (block) \p{Lu} An uppercase letter (category) \p{IsAlphabetic} An alphabetic character (binary property) \p{Sc} A currency symbol \P{InGreek} Any character except one in the Greek block (negation) [\p{L}&&[^\p{Lu}]] Any letter except an uppercase letter (subtraction) Boundary matchers ^ The beginning of a line $ The end of a line \b A word boundary \b{g} A Unicode extended grapheme cluster boundary \B A non-word boundary \A The beginning of the input \G The end of the previous match \Z The end of the input but for the final terminator, if any \z The end of the input Linebreak matcher \R Any Unicode linebreak sequence, is equivalent to \u000D\u000A|[\u000A\u000B\u000C\u000D\u0085\u2028\u2029] Unicode Extended Grapheme matcher \X Any Unicode extended grapheme cluster Greedy quantifiers X? X, once or not at all X* X, zero or more times X+ X, one or more times X{n} X, exactly n times X{n,} X, at least n times X{n,m} X, at least n but not more than m times Reluctant quantifiers X?? X, once or not at all X*? X, zero or more times X+? X, one or more times X{n}? X, exactly n times X{n,}? X, at least n times X{n,m}? X, at least n but not more than m times Possessive quantifiers X?+ X, once or not at all X*+ X, zero or more times X++ X, one or more times X{n}+ X, exactly n times X{n,}+ X, at least n times X{n,m}+ X, at least n but not more than m times Logical operators XY X followed by Y X|Y Either X or Y (X) X, as a capturing group Back references \n Whatever the nth capturing group matched \k<name> Whatever the named-capturing group "name" matched Quotation \ Nothing, but quotes the following character \Q Nothing, but quotes all characters until \E \E Nothing, but ends quoting started by \Q Special constructs (named-capturing and non-capturing) (?<name>X) X, as a named-capturing group (?:X) X, as a non-capturing group (?idmsuxU-idmsuxU)  Nothing, but turns match flags i d m s u x U on - off (?idmsux-idmsux:X) X, as a non-capturing group with the given flags i d m s u x on - off (?=X) X, via zero-width positive lookahead (?!X) X, via zero-width negative lookahead (?<=X) X, via zero-width positive lookbehind (?<!X) X, via zero-width negative lookbehind (?>X) X, as an independent, non-capturing group

    Backslashes, escapes, and quoting

    反斜杠字符（ '\' ）用于引入如上表中定义的转义结构，以及引用否则将被解释为未转义构造的字符。 因此，表达式\\匹配单个反斜杠，而\{匹配左括号。

    在任何不表示转义构造的字母字符之前使用反斜杠是一个错误; 这些保留用于将来的正则表达式语言的扩展。 反斜杠可以在非字母字符之前使用，而不管该角色是否是未转义构造的一部分。

    Java源代码中的字符串文字中的反斜杠按The Java™ Language Specification的要求解释为Unicode转义（3.3节）或其他字符转义（第3.10.6节）。因此，需要在表示正则表达式的字符串文字中加上反斜杠，以保护它们免受由Java字节码编译器解释。 例如，字符串文字"\b"在解释为正则表达式时匹配单个退格字符，而"\\b"匹配单词边界。 字符串字面值"\(hello\)"是非法的，并导致编译时错误; 为了匹配字符串(hello) ，必须使用字符串文字"\\(hello\\)" 。

    Character Classes

    字符类可能出现在其他字符类中，可以由联合运算符（隐式）和交集运算符（ && ）组成。 union运算符表示一个包含至少一个操作数类中的每个字符的类。 交点运算符表示包含两个操作数类中的每个字符的类。

    字符类运算符的优先级如下，从最高到最低：

    Precedence of character class operators.
    1 | Literal escape | \x
    2 Grouping [...]
    3 | Range | a-z
    4 | Union | [a-e][i-u]
    5 | Intersection | [a-z&&[aeiou]]

    请注意，一个不同的元字符集在字符类中比字符类以外有效。 例如，正则表达式.在字符类中失去其特殊含义，而表达式-成为形成元字符的范围。

    Line terminators

    行终止符是一个或两个字符的序列，用于标记输入字符序列的一行的末尾。 以下内容被识别为线路终端器：

    • 换行符（换行）字符（ '\n' ），
    • 一个回车字符后跟一个换行字符（ "\r\n" ），
    • 独立的回车字符（ '\r' ），
    • 下一行字符（ '\u0085' ），
    • 行分隔符（ '\u2028' ）或
    • 段落分隔符（ '\u2029' ）。

    如果激活UNIX_LINES模式，则唯一识别的行终止符是换行符。

    正则表达式.匹配除行终止符之外的任何字符，除非指定了DOTALL标志。

    默认情况下，正则表达式^和$忽略行终止符，仅分别在整个输入序列的开始和结尾进行匹配。 如果激活MULTILINE模式，则^在输入开始和任何行终止符之后匹配，除了输入结束。 当在MULTILINE模式下， $与行终止符之前匹配或输入序列的结尾。

    Groups and capturing

    Group number

    捕获组通过从左到右计算其开始括号进行编号。 在表达式((A)(B(C))) ，例如，有四个这样的组：

    Capturing group numberings
    1 | ((A)(B(C)))
    2 | (A)
    3 | (B(C))
    4 | (C)

    组零总是代表整个表达式。

    捕获组被如此命名，因为在匹配期间，保存与这样的组匹配的输入序列的每个子序列。 捕获的子序列可以在表达式中稍后通过后向引用使用，并且一旦匹配操作完成，也可以从匹配器中获取捕获的子序列。

    Group name

    捕获组也可以分配一个“名称”，一个named-capturing group ，然后被“名称”后面引用。 组名由以下字符组成。 第一个字符必须是letter 。

    • 大写字母'A'至'Z' （ '\u0041'至'\u005a' ），
    • 小写字母'a'至'z' （ '\u0061'至'\u007a' ），
    • 数字'0'至'9' （ '\u0030'至'\u0039' ），

    A named-capturing group仍然编号如Group number所述 。

    与组相关联的捕获输入始终是组最近匹配的子序列。 如果由于量化而对一个组进行了第二次评估，那么如果第二次评估失败，那么其以前捕获的值（如果有的话）将被保留。 将字符串"aba"与表达式(a(b)?)+ ，例如，将组第2组设置为"b" 。 所有捕获的输入在每次匹配开始时被丢弃。

    以(?开头的组是纯粹的非捕获组，不捕获文本，不计入组总数或命名捕获组。

    Unicode支持

    该课程符合Unicode Technical Standard #18: Unicode Regular Expression的 1 级 ，加上RL2.1规范等同。

    如Unicode转义序列 \u2014在Java源代码作为的The Java™ Language Specification第3.3节描述的进行处理。 这样的转义序列也由正则表达式解析器直接实现，以便可以在从文件或键盘读取的表达式中使用Unicode转义。 因此，字符串"\u2014"和"\\u2014"虽然不相等，但编译成与十六进制值0x2014的字符匹配的相同模式。

    Unicode字符还可以通过使用其十六进制表示法 （十六进制代码点值）来直接表示，如构造\x{...} ，例如补充字符U + 2011F可以指定为\x{2011F} ，而不是代理对的两个连续的Unicode转义序列\uD840 \uDD1F 。

    Unicode字符名称由命名字符构造\N{ ... } ，例如， \N{WHITE SMILING FACE}指定字符\u263A 。 此类支持的字符名称是由Character.codePointOf(name)匹配的有效Unicode字符名称。

    Unicode extended grapheme clusters由图形集群匹配器\X和对应的边界匹配器\b{g} 。

    Unicode脚本，块，类别和二进制属性用Perl中的\p和\P结构编写。 \p{ 道具 }比赛如果输入有prop属性，而\P{ 道具 }如果输入有属性不匹配。

    脚本，块，类别和二进制属性可以在字符类的内部和外部使用。

    Scripts被指定为前缀Is ，如IsHiragana或script关键字（或其简称sc ），如script=Hiragana或sc=Hiragana 。

    所支持的脚本名称Pattern是接受和定义的有效脚本名称UnicodeScript.forName 。

    Blocks具有如InMongolian的前缀In或block （或其缩写形式blk ）中的相关信息，如block=Mongolian或blk=Mongolian 。

    受支持的块名称Pattern是接受和定义的有效块名称UnicodeBlock.forName 。

    Categories可以用可选前缀Is指定： \p{L}和\p{IsL}表示Unicode字母的类别。 与脚本和块相同，也可以使用关键字general_category （或其缩写形式gc ）指定类别，如general_category=Lu或gc=Lu 。

    支持的类别是那些The Unicode Standard由指定的版本Character类。 类别名称是标准中定义的，包括规范性和信息性。

    Binary properties用前缀Is指定，如IsAlphabetic 。 由Pattern支持的二进制属性是

    • 拼音
    • 表意的
    • 信
    • 小写
    • 大写
    • 首字母大写
    • 标点
    • 控制
    • White_Space
    • 数字
    • 16进制数字
    • Join_Control
    • Noncharacter_Code_Point
    • 分配

    以下预定义字符类和POSIX字符类符合附录C： Unicode Regular Expression 的 兼容性属性 （当指定了UNICODE_CHARACTER_CLASS标志时）的建议 。

    predefined and posix character classes in Unicode mode Classes Matches \p{Lower} A lowercase character:\p{IsLowercase} \p{Upper} An uppercase character:\p{IsUppercase} \p{ASCII} All ASCII:[\x00-\x7F] \p{Alpha} An alphabetic character:\p{IsAlphabetic} \p{Digit} A decimal digit character:p{IsDigit} \p{Alnum} An alphanumeric character:[\p{IsAlphabetic}\p{IsDigit}] \p{Punct} A punctuation character:p{IsPunctuation} \p{Graph} A visible character: [^\p{IsWhite_Space}\p{gc=Cc}\p{gc=Cs}\p{gc=Cn}] \p{Print} A printable character: [\p{Graph}\p{Blank}&&[^\p{Cntrl}]] \p{Blank} A space or a tab: [\p{IsWhite_Space}&&[^\p{gc=Zl}\p{gc=Zp}\x0a\x0b\x0c\x0d\x85]] \p{Cntrl} A control character: \p{gc=Cc} \p{XDigit} A hexadecimal digit: [\p{gc=Nd}\p{IsHex_Digit}] \p{Space} A whitespace character:\p{IsWhite_Space} \d A digit: \p{IsDigit} \D A non-digit: [^\d] \s A whitespace character: \p{IsWhite_Space} \S A non-whitespace character: [^\s] \w A word character: [\p{Alpha}\p{gc=Mn}\p{gc=Me}\p{gc=Mc}\p{Digit}\p{gc=Pc}\p{IsJoin_Control}] \W A non-word character: [^\w]

    Categories that behave like the java.lang.Character boolean ismethodname methods (except for the deprecated ones) are available through the same \p{prop} syntax where the specified property has the name javamethodname 。

    与Perl比较5

    Pattern引擎执行传统的基于NFA的匹配与Perl 5中发生的有序交替。

    此类不支持Perl构造：

    • 反向引用构造， \g{ ñ } 第 n 个 capturing group和\g{ 名称 }为named-capturing group 。

    • 条件构造(?( 条件 ) X )和(?( 条件 ) X | Y ) ，

    • 嵌入代码构造(?{ 代码 })和(??{ 代码 }) ，

    • 嵌入式注释语法(?#comment) ，和

    • 预处理操作\l \u ， \L ，并\U 。

    Perl支持的构造方法

    • 字符类联合和交集，如above所述。

    与Perl有显着差异

    • 在Perl中， \1至\9始终被解释为反向引用; 如果至少存在许多子表达式，则大于9的反斜杠转义的数字9被视为返回引用，否则，如果可能，将它解释为八进制转义。 在这个类中，八进制转义必须始终以零开头。 在这个类中， \1到\9总是被解释为反向引用，并且如果正则表达式中的那个点至少存在许多子表达式，则更大的数字被接受为反向引用，否则解析器将丢弃数字直到数字更小或等于现有的组数，或者是一位数。

    • Perl使用g标志来请求在最后一场比赛离开的地方恢复的比赛。 该功能由Matcher类隐含提供： find方法的重复调用将在最后一个匹配关闭的位置恢复，除非匹配器被重置。

    • 在Perl中，表达式顶层的嵌入式标志会影响整个表达式。 在这个类中，嵌入的标志总是在它们出现的时刻生效，无论它们在顶层还是在一个组中; 在后一种情况下，标志在组的结尾恢复，就像在Perl中一样。

    有关正则表达式构造的行为的更准确的描述，请参阅Mastering Regular Expressions, 3nd Edition, Jeffrey E. F. Friedl, O'Reilly and Associates, 2006.

    从以下版本开始：
    1.4
    另请参见：
    String.split(String, int) ， String.split(String) ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CANON_EQ
      实现规范等价。
      static int CASE_INSENSITIVE
      启用不区分大小写的匹配。
      static int COMMENTS
      允许空格和注释格式。
      static int DOTALL
      启用点阵模式。
      static int LITERAL
      启用模式的文字解析。
      static int MULTILINE
      启用多行模式。
      static int UNICODE_CASE
      启用Unicode感知案例折叠。
      static int UNICODE_CHARACTER_CLASS
      启用Unicode版本的 预定义字符类和 POSIX字符类 。
      static int UNIX_LINES
      启用Unix行模式。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Predicate<String> asPredicate​()
      创建可用于匹配字符串的谓词。
      static Pattern compile​(String regex)
      将给定的正则表达式编译为模式。
      static Pattern compile​(String regex, int flags)
      将给定的正则表达式编译为带有给定标志的模式。
      int flags​()
      返回此模式的匹配标志。
      Matcher matcher​(CharSequence input)
      创建一个匹配器，匹配给定的输入与此模式。
      static boolean matches​(String regex, CharSequence input)
      编译给定的正则表达式，并尝试匹配给定的输入。
      String pattern​()
      返回编译此模式的正则表达式。
      static String quote​(String s)
      返回面值模式 String指定的 String 。
      String[] split​(CharSequence input)
      将给定的输入序列分成这个模式的匹配。
      String[] split​(CharSequence input, int limit)
      将给定的输入序列分成这个模式的匹配。
      Stream<String> splitAsStream​(CharSequence input)
      根据给定的输入序列创建一个流，该流与该模式匹配。
      String toString​()
      返回此模式的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • UNIX_LINES

        public static final int UNIX_LINES
        启用Unix行模式。

        在这种模式下，只有'\n'行结束在行为认可. ， ^ ，并$ 。

        Unix行模式也可以通过嵌入式标志表达式(?d)启用。

        另请参见：
        Constant Field Values

      • CASE_INSENSITIVE

        public static final int CASE_INSENSITIVE
        启用不区分大小写的匹配。

        默认情况下，不区分大小写的匹配假定仅匹配US-ASCII字符集中的字符。 可以通过与此标志一起指定UNICODE_CASE标志来启用Unicode感知不区分大小写的匹配。

        也可以通过嵌入式标志表达式(?i)启用不区分大小写的匹配。

        指定此标志可能会造成轻微的性能损失。

        另请参见：
        Constant Field Values

      • COMMENTS

        public static final int COMMENTS
        允许空格和注释格式。

        在此模式下，将忽略空格，并且以#开头的嵌入式注释#被忽略，直到行尾。

        注释模式也可以通过嵌入式标志表达式(?x)启用。

        另请参见：
        Constant Field Values

      • MULTILINE

        public static final int MULTILINE
        启用多行模式。

        在多行模式中，表达式^和$匹配行终止符或输入序列的结尾。 默认情况下，这些表达式仅在整个输入序列的开头和结尾匹配。

        多行模式也可以通过嵌入式标志表达式(?m)启用。

        另请参见：
        Constant Field Values

      • LITERAL

        public static final int LITERAL
        启用模式的文字解析。

        当指定此标志时，指定模式的输入字符串将被视为文字字符序列。 输入序列中的元字符或转义序列将没有特殊的含义。

        CASE_INSENSITIVE和UNICODE_CASE标志在与此标志一起使用时保持对匹配的影响。 其他旗帜变得多余。

        没有嵌入的标志字符用于启用文字解析。

        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • DOTALL

        public static final int DOTALL
        启用点阵模式。

        在dotall模式下，表达式.匹配任何字符，包括行终止符。 默认情况下，此表达式与行终止符不匹配。

        Dotall模式也可以通过嵌入式标志表达式(?s)启用。 （ s是“单线”模式的助记符，这在Perl中被称为）。

        另请参见：
        Constant Field Values

      • UNICODE_CASE

        public static final int UNICODE_CASE
        启用Unicode感知案例折叠。

        当指定此标志时，由CASE_INSENSITIVE标志启用的不区分大小写的匹配以与Unicode标准一致的方式完成。 默认情况下，不区分大小写的匹配假定仅匹配US-ASCII字符集中的字符。

        Unicode感知案例折叠也可以通过嵌入式标志表达式(?u)启用。

        指定此标志可能会造成性能损失。

        另请参见：
        Constant Field Values

      • CANON_EQ

        public static final int CANON_EQ
        实现规范等价。

        当指定这个标志时，两个字符将被认为是匹配的，只有当他们的完整的规范分解符合时才匹配。 例如，当指定此标志时，表达式"a\u030A"将匹配字符串"\u00E5" 。 默认情况下，匹配不考虑规范等价。

        没有嵌入的标志字符用于启用规范等效。

        指定此标志可能会造成性能损失。

        另请参见：
        Constant Field Values

      • UNICODE_CHARACTER_CLASS

        public static final int UNICODE_CHARACTER_CLASS
        启用Unicode版本的预定义字符类和POSIX字符类 。

        当指定此标志时，（仅US-ASCII） 预定义字符类和POSIX字符类符合Unicode Technical Standard #18: Unicode Regular Expression 附件C：兼容性属性 。

        也可以通过嵌入式标志表达式(?U)启用UNICODE_CHARACTER_CLASS模式。

        该标志意味着UNICODE_CASE，也就是说，它可以支持Unicode感知案例折叠。

        指定此标志可能会造成性能损失。

        从以下版本开始：
        1.7
        另请参见：
        Constant Field Values

    • 方法详细信息

      • compile

        public static Pattern compile​(String regex)
        将给定的正则表达式编译为模式。
        参数
        regex - 要编译的表达式
        结果
        给定的正则表达式编译成一个模式
        异常
        PatternSyntaxException - 如果表达式的语法无效

      • compile

        public static Pattern compile​(String regex,
                              int flags)
        将给定的正则表达式编译为带有给定标志的模式。
        参数
        regex - 要编译的表达式
        flags -匹配标志，一个位掩码，可能包括 CASE_INSENSITIVE ， MULTILINE ， DOTALL ， UNICODE_CASE ， CANON_EQ ， UNIX_LINES ， LITERAL ， UNICODE_CHARACTER_CLASS和 COMMENTS
        结果
        给定的正则表达式编译成带有给定标志的模式
        异常
        IllegalArgumentException - 如果在 flags中设置了与定义的匹配标志相对应的位之外的位值
        PatternSyntaxException - 如果表达式的语法无效

      • pattern

        public String pattern​()
        返回编译此模式的正则表达式。
        结果
        这种模式的来源

      • toString

        public String toString​()

        返回此模式的字符串表示形式。 这是编译此模式的正则表达式。

        重写：
        toString在 Object
        结果
        该模式的字符串表示形式
        从以下版本开始：
        1.5

      • matcher

        public Matcher matcher​(CharSequence input)
        创建一个匹配器，匹配给定的输入与此模式。
        参数
        input - 要匹配的字符序列
        结果
        这种模式的新匹配器

      • flags

        public int flags​()
        返回此模式的匹配标志。
        结果
        编译此模式时指定的匹配标志

      • matches

        public static boolean matches​(String regex,
                              CharSequence input)
        编译给定的正则表达式，并尝试匹配给定的输入。

        调用这种方便的方式的形式

         Pattern.matches(regex, input);
        表现方式与表达式完全相同
         Pattern.compile(regex).matcher(input).matches()

        如果一个模式多次被使用，编译一次并重用它将比每次调用此方法更有效。

        参数
        regex - 要编译的表达式
        input - 要匹配的字符序列
        结果
        正则表达式是否匹配输入
        异常
        PatternSyntaxException - 如果表达式的语法无效

      • split

        public String[] split​(CharSequence input,
                      int limit)
        将给定的输入序列分成这个模式的匹配。

        由此方法返回的数组包含输入序列的每个子字符串，由与该模式匹配的另一个子序列终止，或者由输入序列的末尾终止。 数组中的子字符串按照它们在输入中出现的顺序。 如果该模式与输入的任何子序列不匹配，则生成的数组只有一个元素，即字符串形式的输入序列。

        当在输入序列的开始处存在正宽度匹配时，在结果数组的开始处包含一个空的前导子串。 开始时的零宽度匹配不会产生这样的空的前导子串。

        limit参数控制应用模式的次数，因此影响生成的数组的长度。 如果极限n大于0，则模式最多应用n -1次，数组的长度不大于n ，数组的最后一个条目将包含超出最后一个匹配分隔符的所有输入。 如果n是非正的，那么模式将被应用到尽可能多的次数，并且数组可以有任何长度。 如果n为0，则模式将被应用尽可能多次，数组可以有任何长度，并且尾随的空字符串将被丢弃。

        输入"boo:and:foo" ，例如，使用以下参数产生以下结果：

        Split examples showing regex, limit, and result
        Regex | Limit | Result
        : 2 { "boo", "and:foo" }
        : 5 { "boo", "and", "foo" }
        : -2 { "boo", "and", "foo" }
        o | 5 | { "b", "", ":and:f", "", "" }
        o | -2 | { "b", "", ":and:f", "", "" }
        o | 0 | { "b", "", ":and:f" }
        参数
        input - 要分割的字符序列
        limit - 结果阈值，如上所述
        结果
        通过将输入围绕该模式的匹配分割来计算的字符串数组

      • split

        public String[] split​(CharSequence input)
        将给定的输入序列分成这个模式的匹配。

        该方法的工作原理是通过调用具有给定输入序列和限制参数为零的双参数split方法。 因此，尾随的空字符串不会包含在结果数组中。

        输入"boo:and:foo" ，例如，使用以下表达式得到以下结果：

        Split examples showing regex and result
        Regex | Result
        : { "boo", "and", "foo" }
        o | { "b", "", ":and:f" }
        参数
        input - 要分割的字符序列
        结果
        通过将输入围绕该模式的匹配分割来计算的字符串数组

      • quote

        public static String quote​(String s)
        返回面值模式String指定的String 。

        此方法产生一个String ，可用于创建一个Pattern ，它将匹配字符串s ，就像它是一个文字模式。

        输入序列中的元字符或转义序列将没有特殊的含义。
        参数
        s - 要被字面化的字符串
        结果
        一个文字字符串替换
        从以下版本开始：
        1.5

      • asPredicate

        public Predicate<String> asPredicate​()
        创建可用于匹配字符串的谓词。
        结果
        可用于匹配字符串的谓词
        从以下版本开始：
        1.8

      • splitAsStream

        public Stream<String> splitAsStream​(CharSequence input)
        根据给定的输入序列创建一个流，该流与该模式匹配。

        由此方法返回的流包含输入序列的每个子字符串，由与该模式匹配的另一个子序列终止，或者由输入序列的结尾终止。 流中的子串按照它们在输入中出现的顺序。 尾随的空字符串将被丢弃，不会在流中遇到。

        如果该模式与输入的任何子序列不匹配，则生成的流只有一个元素，即字符串形式的输入序列。

        当在输入序列的开始处存在正宽度匹配时，在流的开始处包含空的前导子串。 开始时的零宽度匹配不会产生这样的空的前导子串。

        如果输入序列是可变的，则在执行终端流操作期间它必须保持不变。 否则，终端流操作的结果未定义。

        参数
        input - 要分割的字符序列
        结果
        通过将输入围绕该模式的匹配分割来计算的字符串流
        从以下版本开始：
        1.8
        另请参见：
        split(CharSequence)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PatternSyntaxException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.regex

Class PatternSyntaxException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.regex.PatternSyntaxException
  • All Implemented Interfaces:
    Serializable

    public class PatternSyntaxException
extends IllegalArgumentException
    抛出未经检查的异常，以指示正则表达式模式中的语法错误。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PatternSyntaxException​(String desc, String regex, int index)
      构造一个这个类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getDescription​()
      检索错误的描述。
      int getIndex​()
      检索错误索引。
      String getMessage​()
      返回一个多行字符串，其中包含语法错误及其索引的描述，错误的正则表达式模式以及模式中错误索引的可视指示。
      String getPattern​()
      检索错误的正则表达式模式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • PatternSyntaxException

        public PatternSyntaxException​(String desc,
                              String regex,
                              int index)
        构造一个这个类的新实例。
        参数
        desc - 错误的描述
        regex - 错误的模式
        index - 错误模式中的近似指数，如果指数不知道， -1

    • 方法详细信息

      • getIndex

        public int getIndex​()
        检索错误索引。
        结果
        错误的模式中的近似指数，或 -1如果指数不知道

      • getDescription

        public String getDescription​()
        检索错误的描述。
        结果
        错误的描述

      • getPattern

        public String getPattern​()
        检索错误的正则表达式模式。
        结果
        错误的模式

      • getMessage

        public String getMessage​()
        返回一个多行字符串，其中包含语法错误及其索引的描述，错误的正则表达式模式以及模式中错误索引的可视指示。
        重写：
        getMessage在 Throwable
        结果
        完整的详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util.regex (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.regex

  • Packages that use java.util.regex
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
  • Classes in java.util.regex used by java.util
    Class 描述
    MatchResult
    匹配操作的结果。
    Pattern
    正则表达式的编译表示。
  • Classes in java.util.regex used by java.util.regex
    Class 描述
    Matcher
    通过解释Pattern对character sequence执行匹配操作的引擎。
    MatchResult
    匹配操作的结果。
    Pattern
    A compiled representation of a regular expression.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.regex.Matcher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.regex.Matcher

  • Packages that use Matcher
    软件包 描述
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。

    • Uses of Matcher in java.util.regex

      Methods in java.util.regex that return Matcher
      Modifier and Type 方法 描述
      Matcher Matcher.appendReplacement​(StringBuffer sb, String replacement)
      实施非终端附加和替换步骤。
      Matcher Matcher.appendReplacement​(StringBuilder sb, String replacement)
      实施非终端附加和替换步骤。
      Matcher Pattern.matcher​(CharSequence input)
      创建一个匹配器，匹配给定的输入与此模式。
      Matcher Matcher.region​(int start, int end)
      设置该匹配器区域的限制。
      Matcher Matcher.reset​()
      重设此匹配器。
      Matcher Matcher.reset​(CharSequence input)
      使用新的输入序列重置此匹配器。
      Matcher Matcher.useAnchoringBounds​(boolean b)
      设置该匹配器的区域边界的锚定。
      Matcher Matcher.usePattern​(Pattern newPattern)
      更改 Pattern这个 Matcher用于查找匹配。
      Matcher Matcher.useTransparentBounds​(boolean b)
      设置此匹配器的区域边界的透明度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.regex.Pattern (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.regex.Pattern

  • Packages that use Pattern
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。

    • Uses of Pattern in java.util

      Methods in java.util that return Pattern
      Modifier and Type 方法 描述
      Pattern Scanner.delimiter​()
      返回 Pattern这个 Scanner当前正在使用来匹配分隔符。
      Methods in java.util with parameters of type Pattern
      Modifier and Type 方法 描述
      Stream<MatchResult> Scanner.findAll​(Pattern pattern)
      返回此扫描仪的匹配结果流。
      String Scanner.findInLine​(Pattern pattern)
      尝试找到忽略分隔符的指定模式的下一个出现。
      String Scanner.findWithinHorizon​(Pattern pattern, int horizon)
      尝试找到指定模式的下一个出现。
      boolean Scanner.hasNext​(Pattern pattern)
      如果下一个完整的令牌匹配指定的模式，则返回true。
      String Scanner.next​(Pattern pattern)
      如果匹配指定的模式，则返回下一个令牌。
      Scanner Scanner.skip​(Pattern pattern)
      跳过与指定模式匹配的输入，忽略分隔符。
      Scanner Scanner.useDelimiter​(Pattern pattern)
      将此扫描仪的分隔模式设置为指定的模式。

    • Uses of Pattern in java.util.regex

      Methods in java.util.regex that return Pattern
      Modifier and Type 方法 描述
      static Pattern Pattern.compile​(String regex)
      将给定的正则表达式编译为模式。
      static Pattern Pattern.compile​(String regex, int flags)
      将给定的正则表达式编译为带有给定标志的模式。
      Pattern Matcher.pattern​()
      返回该匹配器解释的模式。
      Methods in java.util.regex with parameters of type Pattern
      Modifier and Type 方法 描述
      Matcher Matcher.usePattern​(Pattern newPattern)
      更改 Pattern ，这 Matcher用于查找与匹配。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.regex.PatternSyntaxException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.regex.PatternSyntaxException

No usage of java.util.regex.PatternSyntaxException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.regex.MatchResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.regex.MatchResult

  • Packages that use MatchResult
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。

    • Uses of MatchResult in java.util

      Methods in java.util that return MatchResult
      Modifier and Type 方法 描述
      MatchResult Scanner.match​()
      返回此扫描仪执行的最后扫描操作的匹配结果。
      Methods in java.util that return types with arguments of type MatchResult
      Modifier and Type 方法 描述
      Stream<MatchResult> Scanner.findAll​(String patString)
      返回与提供的模式字符串相匹配的匹配结果流。
      Stream<MatchResult> Scanner.findAll​(Pattern pattern)
      返回此扫描仪的匹配结果流。

    • Uses of MatchResult in java.util.regex

      Classes in java.util.regex that implement MatchResult
      Modifier and Type Class 描述
      class  Matcher
      通过解释Pattern对character sequence执行匹配操作的引擎。
      Methods in java.util.regex that return MatchResult
      Modifier and Type 方法 描述
      MatchResult Matcher.toMatchResult​()
      返回此匹配器的匹配状态为MatchResult 。
      Methods in java.util.regex that return types with arguments of type MatchResult
      Modifier and Type 方法 描述
      Stream<MatchResult> Matcher.results​()
      返回与模式匹配的输入序列的每个子序列的匹配结果流。
      Method parameters in java.util.regex with type arguments of type MatchResult
      Modifier and Type 方法 描述
      String Matcher.replaceAll​(Function<MatchResult,String> replacer)
      将与模式匹配的输入序列的每个子序列替换为将给定的替换器函数应用于与该子序列相对应的匹配器的匹配结果的结果。
      String Matcher.replaceFirst​(Function<MatchResult,String> replacer)
      将与模式匹配的输入序列的第一个子序列替换为将给定的替换器函数应用于与该子序列对应的匹配器的匹配结果的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AbstractResourceBundleProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Class AbstractResourceBundleProvider

  • java.lang.Object
    • java.util.spi.AbstractResourceBundleProvider
  • All Implemented Interfaces:
    ResourceBundleProvider

    public abstract class AbstractResourceBundleProvider
extends Object
implements ResourceBundleProvider
    AbstractResourceBundleProvider是一个抽象类，为ResourceBundleProvider的提供程序实现类提供基本支持。

    资源束可以封装在一个或多个命名模块， 捆绑模块中 。 资源包的消费者是一个呼叫ResourceBundle.getBundle(String)的消息 。 为了使消费者模块加载由另一个模块提供的资源束“ com.example.app.MyResources ”，它将使用service loader机制。 必须定义名为“ com.example.app.MyResourcesProvider ”的服务接口，并且捆绑提供程序模块将提供“ com.example.app.MyResourcesProvider ”的实现类，如下所示：

       import com.example.app.MyResourcesProvider; class MyResourcesProviderImpl extends AbstractResourceBundleProvider implements MyResourcesProvider { protected String toBundleName(String baseName, Locale locale) { // return the bundle name per the naming of the resource bundle : } public ResourceBundle getBundle(String baseName, Locale locale) { // this module only provides bundles in french if (locale.equals(Locale.FRENCH)) { return super.getBundle(baseName, locale); } return null; } }
    从以下版本开始：
    9
    另请参见：
    Resource Bundles in Named Modules ， ResourceBundleProvider Service Providers

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractResourceBundleProvider​()
      构造一个具有“java.properties”格式的 AbstractResourceBundleProvider 。
      protected AbstractResourceBundleProvider​(String... formats)
      构造一个 AbstractResourceBundleProvider与指定的 formats 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ResourceBundle getBundle​(String baseName, Locale locale)
      返回 ResourceBundle为给定 baseName和 locale 。
      protected String toBundleName​(String baseName, Locale locale)
      返回此提供程序提供的给定 baseName和 locale的包名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractResourceBundleProvider

        protected AbstractResourceBundleProvider​()
        构造一个具有“java.properties”格式的AbstractResourceBundleProvider 。 该构造函数相当于AbstractResourceBundleProvider("java.properties") 。

      • AbstractResourceBundleProvider

        protected AbstractResourceBundleProvider​(String... formats)
        构造一个AbstractResourceBundleProvider与指定的formats 。 getBundle(String, Locale)方法查找给定的formats资源束。 formats必须是“java.class”或“java.properties”。
        参数
        formats - 用于加载资源束的格式
        异常
        NullPointerException - 如果给定的 formats为空
        IllegalArgumentException - 如果给定的 formats不是“java.class”或“java.properties”。

    • 方法详细信息

      • toBundleName

        protected String toBundleName​(String baseName,
                              Locale locale)
        返回此提供商提供的给定 baseName和 locale的包名称。
        API Note:
        资源束提供者可以将其资源束打包在与资源束的基本名称相同的包中，如果包不与其他命名模块分割。 如果有多个捆绑提供商提供给定基本名称的资源束，则可以使用每个语言分组或每个区域分组打包资源束，以消除拆分包。

        例如，如果baseName为"p.resources.Bundle"那么的资源包名称"p.resources.Bundle"的Locale("ja",&nbsp;"",&nbsp;"XX")和Locale("en")可能是"p.resources.ja.Bundle_ja_&thinsp;_XX"和p.resources.Bundle_en"分别

        该方法是从默认实现的getBundle(String, Locale)方法中调用的 。

        Implementation Note:
        该方法的默认实现与实现 ResourceBundle.Control.toBundleName(String, Locale)相同。
        参数
        baseName - 资源包的基本名称，一个完全限定的类名
        locale - 应为其加载资源束的区域设置
        结果
        资源束的包名称

      • getBundle

        public ResourceBundle getBundle​(String baseName,
                                Locale locale)
        返回 ResourceBundle为给定 baseName和 locale 。
        Specified by:
        getBundle在接口 ResourceBundleProvider
        Implementation Note:
        此方法的默认实现将调用toBundleName方法来获取baseName和locale的软件包名称，并在该提供程序的模块中找到软件包名称的本地资源包。 它将只搜索在提供者构建时指定的格式。
        参数
        baseName - 资源包的基础包名称，完全限定类名称。
        locale - 资源束应实例化的区域设置
        结果
        ResourceBundle给定的 baseName和 locale ，或 null如果没有资源包中发现
        异常
        NullPointerException - 如果 baseName或 locale是 null
        UncheckedIOException - 如果在资源束加载期间发生任何IO异常
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CalendarDataProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Class CalendarDataProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.util.spi.CalendarDataProvider

  • public abstract class CalendarDataProvider
extends LocaleServiceProvider
    服务提供商的抽象类，提供依赖于区域设置的Calendar参数。
    从以下版本开始：
    1.8
    另请参见：
    CalendarNameProvider

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CalendarDataProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract int getFirstDayOfWeek​(Locale locale)
      在给定的 locale返回一周的第一天。
      abstract int getMinimalDaysInFirstWeek​(Locale locale)
      返回一年中第一周所需的最少天数。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CalendarDataProvider

        protected CalendarDataProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getFirstDayOfWeek

        public abstract int getFirstDayOfWeek​(Locale locale)
        在给定的locale返回一周的第一天。 Calendar需要此信息来支持与周相关的日历字段的操作。
        参数
        locale - 所需的语言环境
        结果
        一个星期的第一天; 一个Calendar.SUNDAY .. Calendar.SATURDAY ，或0如果该值不可用于locale
        异常
        NullPointerException - 如果 locale是 null 。
        另请参见：
        Calendar.getFirstDayOfWeek() ， First Week

      • getMinimalDaysInFirstWeek

        public abstract int getMinimalDaysInFirstWeek​(Locale locale)
        返回一年中第一周所需的最少天数。 Calendar要求这个信息来确定一年的第一周。 请参阅how Calendar determines the first week的说明。
        参数
        locale - 所需的语言环境
        结果
        第一周的最小天数，如果该值不可用于 locale
        异常
        NullPointerException - 如果 locale是 null 。
        另请参见：
        Calendar.getMinimalDaysInFirstWeek()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CalendarNameProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Class CalendarNameProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.util.spi.CalendarNameProvider

  • public abstract class CalendarNameProvider
extends LocaleServiceProvider
    提供Calendar字段值的本地化字符串表示（显示名称）的服务提供者的抽象类。

    Calendar Types

    日历类型用于指定getDisplayName和getDisplayNames方法提供日历字段值名称的日历系统。 详见Calendar.getCalendarType() 。

    日历字段

    日历字段由Calendar中定义的常量指定。 以下是日历常用字段及其每个日历系统支持的值。

    Field values Field Value Description Calendar.MONTH Calendar.JANUARY to Calendar.UNDECIMBER Month numbering is 0-based (e.g., 0 - January, ..., 11 - December). Some calendar systems have 13 months. Month names need to be supported in both the formatting and stand-alone forms if required by the supported locales. If there's no distinction in the two forms, the same names should be returned in both of the forms. Calendar.DAY_OF_WEEK Calendar.SUNDAY to Calendar.SATURDAY Day-of-week numbering is 1-based starting from Sunday (i.e., 1 - Sunday, ..., 7 - Saturday). Calendar.AM_PM Calendar.AM to Calendar.PM 0 - AM, 1 - PM

    以下是日历特定的字段及其值将被支持。

    Calendar type and field values Calendar Type Field Value Description "gregory" Calendar.ERA 0 GregorianCalendar.BC (BCE) 1 GregorianCalendar.AD (CE) "buddhist" Calendar.ERA 0 BC (BCE) 1 B.E. (Buddhist Era) "japanese" Calendar.ERA 0 Seireki (Before Meiji) 1 Meiji 2 Taisho 3 Showa 4 Heisei Calendar.YEAR 1 the first year in each era. It should be returned when a long style (Calendar.LONG_FORMAT or Calendar.LONG_STANDALONE) is specified. See also the Year representation in SimpleDateFormat. "roc" Calendar.ERA 0 Before R.O.C. 1 R.O.C. "islamic" Calendar.ERA 0 Before AH 1 Anno Hijrah (AH)

    "gregory"日历字段值名称必须与"gregory"提供的日期时间符号一致 。

    时区名称由TimeZoneNameProvider支持。

    从以下版本开始：
    1.8
    另请参见：
    CalendarDataProvider ， Locale.getUnicodeLocaleType(String)

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CalendarNameProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract String getDisplayName​(String calendarType, int field, int value, int style, Locale locale)
      返回给定的 style和 locale中的日历 field value的字符串表示（显示名称）。
      abstract Map<String,Integer> getDisplayNames​(String calendarType, int field, int style, Locale locale)
      返回 Map包含的所有字符串表示（显示名称） Calendar field给定 style和 locale及其相应的字段值。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CalendarNameProvider

        protected CalendarNameProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getDisplayName

        public abstract String getDisplayName​(String calendarType,
                                      int field,
                                      int value,
                                      int style,
                                      Locale locale)
        返回给定的style和locale中的日历field value的字符串表示（显示名称）。 如果不适用字符串表示，则返回null 。

        field是一个Calendar字段索引，如Calendar.MONTH 。 此方法不支持时区字段Calendar.ZONE_OFFSET和Calendar.DST_OFFSET 。 如果指定了任何时区字段，则必须返回null 。

        value是field值的数字表示。 例如，如果field为Calendar.DAY_OF_WEEK ，则有效值为Calendar.SUNDAY至Calendar.SATURDAY （含）。

        style给出了字符串表示形式。 它是一个Calendar.SHORT_FORMAT （ SHORT ）， Calendar.SHORT_STANDALONE ， Calendar.LONG_FORMAT （ LONG ）， Calendar.LONG_STANDALONE ， Calendar.NARROW_FORMAT ，或Calendar.NARROW_STANDALONE 。

        例如，以下调用将返回"Sunday" 。

          getDisplayName("gregory", Calendar.DAY_OF_WEEK, Calendar.SUNDAY,
                Calendar.LONG_STANDALONE, Locale.ENGLISH);
        参数
        calendarType - 日历类型。 （由locale给出的任何日历类型都将被忽略。）
        field - Calendar字段索引，如 Calendar.DAY_OF_WEEK
        value -该值 Calendar field ，如 Calendar.MONDAY
        style -字符串表示风格：之一 Calendar.SHORT_FORMAT （ SHORT ）， Calendar.SHORT_STANDALONE ， Calendar.LONG_FORMAT （ LONG ）， Calendar.LONG_STANDALONE ， Calendar.NARROW_FORMAT ，或 Calendar.NARROW_STANDALONE
        locale - 所需的语言环境
        结果
        所述的字符串表示 field value ，或 null如果字符串表示不适用，或给定日历类型是未知的
        异常
        IllegalArgumentException - 如果 field或 style无效
        NullPointerException - 如果 locale是 null
        另请参见：
        TimeZoneNameProvider ， Calendar.get(int) ， Calendar.getDisplayName(int, int, Locale)

      • getDisplayNames

        public abstract Map<String,Integer> getDisplayNames​(String calendarType,
                                                    int field,
                                                    int style,
                                                    Locale locale)
        返回Map包含的所有字符串表示（显示名称） Calendar field给定style和locale及其相应的字段值。

        field是一个Calendar字段索引，如Calendar.MONTH 。 此方法不支持时区字段Calendar.ZONE_OFFSET和Calendar.DST_OFFSET 。 如果指定了任何时区字段，则必须返回null 。

        style给出了字符串表示形式。 它必须是一个Calendar.ALL_STYLES ， Calendar.SHORT_FORMAT （ SHORT ）， Calendar.SHORT_STANDALONE ， Calendar.LONG_FORMAT （ LONG ）， Calendar.LONG_STANDALONE ， Calendar.NARROW_FORMAT ，或Calendar.NARROW_STANDALONE 。 请注意，由于使用单个字符，例如星期日和星期六使用“S”，并且在该情况下不包括窄名称，因此狭义名称可能不是唯一的。

        例如，下面的调用将返回一个Map含"January"至Calendar.JANUARY ， "Jan"至Calendar.JANUARY ， "February"至Calendar.FEBRUARY ， "Feb"至Calendar.FEBRUARY ，等等。

          getDisplayNames("gregory", Calendar.MONTH, Calendar.ALL_STYLES, Locale.ENGLISH);
        参数
        calendarType - 日历类型。 （由locale给出的任何日历类型locale被忽略。）
        field - 显示名称返回的日历字段
        style - 应用于显示名称的样式; 之一Calendar.ALL_STYLES ， Calendar.SHORT_FORMAT （ SHORT ）， Calendar.SHORT_STANDALONE ， Calendar.LONG_FORMAT （ LONG ）， Calendar.LONG_STANDALONE ， Calendar.NARROW_FORMAT ，或Calendar.NARROW_STANDALONE
        locale - 所需的语言环境
        结果
        一个 Map包含的所有显示名称 field在 style和 locale及其 field值，或者 null ，如果没有显示名称为定义 field
        异常
        NullPointerException - 如果 locale是 null
        另请参见：
        Calendar.getDisplayNames(int, int, Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CurrencyNameProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Class CurrencyNameProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.util.spi.CurrencyNameProvider

  • public abstract class CurrencyNameProvider
extends LocaleServiceProvider
    为Currency类提供本地化货币符号和显示名称的服务提供商的抽象类。 请注意，在确定LocaleServiceProvider规范中描述的行为时，货币符号被认为是名称。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CurrencyNameProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      String getDisplayName​(String currencyCode, Locale locale)
      返回适合显示给用户的货币名称。
      abstract String getSymbol​(String currencyCode, Locale locale)
      获取指定区域设置的给定货币代码的符号。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CurrencyNameProvider

        protected CurrencyNameProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getSymbol

        public abstract String getSymbol​(String currencyCode,
                                 Locale locale)
        获取指定区域设置的给定货币代码的符号。 例如，对于“USD”（美元），如果指定的区域设置是美国，则符号为“$”，而对于其他区域设置，则可能为“US $”。 如果不能确定符号，则应返回null。
        参数
        currencyCode - ISO 4217货币代码，由“A”（U + 0041）和“Z”（U + 005A）之间的三个大写字母组成，
        locale - 所需的语言环境
        结果
        指定区域设置的给定货币代码的符号，如果符号不可用于区域设置，则为null
        异常
        NullPointerException - 如果 currencyCode或 locale为空
        IllegalArgumentException - 如果 currencyCode不是三个大写字母的形式，或者 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        Currency.getSymbol(java.util.Locale)

      • getDisplayName

        public String getDisplayName​(String currencyCode,
                             Locale locale)
        返回适合显示给用户的货币名称。 默认实现返回null。
        参数
        currencyCode - ISO 4217货币代码，由“A”（U + 0041）和“Z”（U + 005A）之间的三个大写字母组成，
        locale - 所需的语言环境
        结果
        适用于显示给用户的货币的名称，如果名称不可用于区域设置，则为空
        异常
        IllegalArgumentException - 如果 currencyCode不是三个大写字母的形式，或者 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        NullPointerException - 如果 currencyCode或 locale是 null
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.util.spi (Java SE 9 & JDK 9 )

java.util.spi

Interfaces

  • ResourceBundleControlProvider
  • ResourceBundleProvider
  • ToolProvider

Classes

  • AbstractResourceBundleProvider
  • CalendarDataProvider
  • CalendarNameProvider
  • CurrencyNameProvider
  • LocaleNameProvider
  • LocaleServiceProvider
  • TimeZoneNameProvider


java.util.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util.spi

java.util包中类的服务提供者类。
从以下版本开始：
1.6
  • 接口摘要
    接口 描述
    ResourceBundleControlProvider
    提供ResourceBundle.Control实现的服务提供商的接口。
    ResourceBundleProvider
    ResourceBundleProvider是一个提供者接口，用于加载命名模块的资源束。
    ToolProvider
    一个用于命令行工具的界面，用于提供一种无需启动新VM即可调用的方法。
  • 类摘要
    Class 描述
    AbstractResourceBundleProvider
    AbstractResourceBundleProvider是一个抽象类，为ResourceBundleProvider的提供程序实现类提供基本支持。
    CalendarDataProvider
    服务提供商的抽象类，提供依赖于区域设置的Calendar参数。
    CalendarNameProvider
    提供 Calendar字段值的本地化字符串表示（显示名称）的服务提供者的抽象类。
    CurrencyNameProvider
    为Currency类提供本地化货币符号和显示名称的服务提供商的抽象类。
    LocaleNameProvider
    为Locale类提供本地化名称的服务提供商的抽象类。
    LocaleServiceProvider
    这是所有区域设置敏感的服务提供商接口（SPI）的超类。
    TimeZoneNameProvider
    为TimeZone类提供本地化时区名称的服务提供商的抽象类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.spi.AbstractResourceBundleProvider (implements java.util.spi.ResourceBundleProvider)
    • java.util.spi.LocaleServiceProvider
      • java.util.spi.CalendarDataProvider
      • java.util.spi.CalendarNameProvider
      • java.util.spi.CurrencyNameProvider
      • java.util.spi.LocaleNameProvider
      • java.util.spi.TimeZoneNameProvider

Interface Hierarchy

  • java.util.spi.ResourceBundleControlProvider
  • java.util.spi.ResourceBundleProvider
  • java.util.spi.ToolProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LocaleNameProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Class LocaleNameProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.util.spi.LocaleNameProvider

  • public abstract class LocaleNameProvider
extends LocaleServiceProvider
    为Locale类提供本地化名称的服务提供商的抽象类。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected LocaleNameProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract String getDisplayCountry​(String countryCode, Locale locale)
      返回给定的 IETF BCP47区域代码（ISO 3166国家代码或UN M.49区域代码）的本地化名称以及适合向用户显示的给定区域设置。
      abstract String getDisplayLanguage​(String languageCode, Locale locale)
      返回给定的 IETF BCP47语言代码和适用于向用户显示的给定语言环境的本地化名称。
      String getDisplayScript​(String scriptCode, Locale locale)
      返回给定的 IETF BCP47脚本代码和适用于向用户显示的给定语言环境的本地化名称。
      abstract String getDisplayVariant​(String variant, Locale locale)
      返回适用于向用户显示的给定变体代码和给定语言环境的本地化名称。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LocaleNameProvider

        protected LocaleNameProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getDisplayLanguage

        public abstract String getDisplayLanguage​(String languageCode,
                                          Locale locale)
        返回给定的IETF BCP47语言代码的本地化名称以及适合向用户显示的给定语言环境。 例如，如果languageCode是“fr”，而locale是en_US，getDisplayLanguage（）将返回“French”; 如果languageCode是“en”，而locale是fr_FR，getDisplayLanguage（）将返回“anglais”。 如果返回的名称不能根据locale进行本地化（例如，提供者没有克罗地亚语的日语名称），则此方法返回null。
        参数
        languageCode - 'a'（U + 0061）和'z'（U + 007A）之间的两到八个小写字母形式的语言代码字符串，
        locale - 所需的语言环境
        结果
        指定语言环境的给定语言代码的名称，如果不可用，则为null。
        异常
        NullPointerException - 如果 languageCode或 locale为空
        IllegalArgumentException - 如果 languageCode不是两个或三个小写字母的形式，或者 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        Locale.getDisplayLanguage(java.util.Locale)

      • getDisplayScript

        public String getDisplayScript​(String scriptCode,
                               Locale locale)
        返回给定的IETF BCP47脚本代码和适用于向用户显示的给定语言环境的本地化名称。 例如，如果scriptCode是“Latn”，而locale是en_US，getDisplayScript（）将返回“Latin”; 如果scriptCode是“Cyrl”，而locale是fr_FR，getDisplayScript（）将返回“cyrillique”。 如果返回的名称不能根据locale进行本地化（例如，提供程序没有西里尔文的日文名称），则此方法返回null。 默认实现返回null。
        参数
        scriptCode - 以字母大小写字母形式的四字母脚本代码字符串（第一个字母是'A'（U + 0041）和'Z'（U + 005A）之间的大写字母，后跟三个小写字母在'a'（U + 0061）和'z'（U + 007A）之间）。
        locale - 所需的语言环境
        结果
        指定语言环境的给定脚本代码的名称，如果不可用，则为null。
        异常
        NullPointerException - 如果 scriptCode或 locale为空
        IllegalArgumentException - 如果 scriptCode不是四个标题字母的形式，或 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        从以下版本开始：
        1.7
        另请参见：
        Locale.getDisplayScript(java.util.Locale)

      • getDisplayCountry

        public abstract String getDisplayCountry​(String countryCode,
                                         Locale locale)
        返回给定的IETF BCP47区域代码（ISO 3166国家代码或UN M.49区域代码）的本地化名称以及适合向用户显示的给定区域设置。 例如，如果countryCode为“FR”，而locale为en_US，则getDisplayCountry（）将返回“法国”; 如果countryCode是“US”，而locale是fr_FR，则getDisplayCountry（）将返回“Etats-Unis”。 如果返回的名称不能根据locale进行本地化（例如，提供者没有克罗地亚的日语名称），则此方法返回null。
        参数
        countryCode - 国家（地区）代码字符串，以“A”（U + 0041）和“Z”（U + 005A）之间的两个大写字母的形式或以三位数字形式的UN M.49区号'0'（U + 0030）和'9'之间的字母（U + 0039）。
        locale - 所需的语言环境
        结果
        指定区域设置的给定国家代码的名称，如果不可用，则为null。
        异常
        NullPointerException - 如果 countryCode或 locale为空
        IllegalArgumentException - 如果 countryCode不是两个大写字母或三位数字母的形式，或 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        Locale.getDisplayCountry(java.util.Locale)

      • getDisplayVariant

        public abstract String getDisplayVariant​(String variant,
                                         Locale locale)
        返回适用于向用户显示的给定变体代码和给定语言环境的本地化名称。 如果返回的名称不能根据locale进行本地化，则此方法返回null。
        参数
        variant - 变体字符串
        locale - 所需的语言环境
        结果
        指定区域设置的给定变体字符串的名称，如果不可用，则为null。
        异常
        NullPointerException - 如果 variant或 locale为空
        IllegalArgumentException - 如果 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        另请参见：
        Locale.getDisplayVariant(java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LocaleServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Class LocaleServiceProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
  • 已知直接子类：
    BreakIteratorProvider ， CalendarDataProvider ， CalendarNameProvider ， CollatorProvider ， CurrencyNameProvider ， DateFormatProvider ， DateFormatSymbolsProvider ， DecimalFormatSymbolsProvider ， LocaleNameProvider ， NumberFormatProvider ， TimeZoneNameProvider

    public abstract class LocaleServiceProvider
extends Object

    这是所有区域设置敏感的服务提供商接口（SPI）的超类。

    区域设置敏感的服务提供者接口是对应于java.text和java.util包中的区域设置敏感类的java.text 。 这些接口使得能够构建区域设置敏感对象并检索这些包的本地化名称。 java.text和java.util包中的区域设置敏感的工厂方法和名称检索方法使用提供程序接口的实现来为Java运行时环境本身支持的语言环境提供支持。

    包装区域敏感服务提供商实施

    通过将这些区域设置敏感服务的实现添加到应用程序的类路径中可以实现。 提供商使用资源目录META-INF / services中的提供者配置文件来标识自身，使用完全限定的提供者接口类名作为文件名。 该文件应包含一个完全限定的具体提供程序类名称列表，每行一个。 一行由任何换行符（'\ n'），回车符（'\ r'）或回车符后跟随换行符终止。 忽略每个名称周围的空格和制表符，以及空白行。 注释字符为'＃'（'＃'）; 在每行上，忽略第一个注释字符之后的所有字符。 文件必须以UTF-8编码。

    如果特定的具体提供程序类在多个配置文件中命名，或者在同一配置文件中多次命名，那么重复的项将被忽略。 命名特定提供者的配置文件不需要与提供者本身在同一个jar文件或其他分发单元中。 提供程序必须可以从初始查询的相同类加载器访问以查找配置文件; 这不一定是加载文件的类加载器。

    例如， DateFormatProvider类的实现应采用包含该文件的jar文件的形式：

      META-INF/services/java.text.spi.DateFormatProvider
    而文件java.text.spi.DateFormatProvider应该有一行如：
      com.foo.DateFormatProviderImpl
    这是执行DateFormatProvider的类的完全合格的类名。

    调用区域敏感服务

    在java.text和java.util包中进行名称检索的区域设置敏感的工厂方法和方法在需要时调用服务提供者方法来支持请求的区域设置。 方法首先检查Java运行时环境本身是否支持所请求的区域设置，并使用其支持（如果可用）。 否则，他们将安装的提供商的isSupportedLocale方法称为相应的接口，以找到支持所请求的区域设置的方法。 如果找到这样的提供者，则调用其他方法来获取请求的对象或名称。 当检查是否支持语言环境时，默认情况下将忽略locale's extensions 。 （如果还应检查语言环境的扩展名，则必须覆盖isSupportedLocale方法。）如果Java运行时环境本身或已安装的提供程序都不支持所请求的语言环境，则方法将通过候选语言环境列表，并重复每次可用性检查，直到找到了一个匹配。 用于创建候选语言环境列表的算法与ResourceBundle默认使用的算法相同（详细信息请参阅getCandidateLocales ）。 即使从候选列表中解析出语言环境，返回请求的对象或名称的方法也将使用原始请求的语言环境（包括Locale扩展名）进行调用。 Java运行时环境必须支持所有区域设置敏感服务的根区域设置，以确保此过程终止。

    名称提供者（但不是其他对象的提供者）允许为某些名称请求返回null，即使对于他们声称支持的语言环境，它们的返回值为getAvailableLocales 。 类似地，Java运行时环境本身可能没有它支持的所有区域设置的所有名称。 这是因为要求名称的对象集可能很大，随时间而变化，因此完全覆盖它们并不总是可行的。 如果Java运行时环境或提供程序返回null而不是名称，则查找将如上所述进行，如同不支持语言环境一样。

    可以通过使用“java.locale.providers”系统属性来配置区域设置敏感服务的搜索顺序。 此系统属性声明用户查找由逗号分隔的区域设置敏感服务的首选顺序。 只能在Java运行时启动时读取，所以稍后调用System.setProperty（）不会影响顺序。

    Java运行时环境提供以下四个区域设置提供程序：

    • “CLDR”：基于Unicode Consortium的CLDR Project的提供商 。
    • “COMPAT”：表示与JDK8之前的JDK版本（与JDK8的“JRE”相同）兼容的区域设置敏感服务。
    • “SPI”：表示实现LocaleServiceProvider类的子类的区域敏感服务。
    • “HOST”：反映用户在底层操作系统中的自定义设置的提供者。 根据Java运行时环境的实现，此提供程序可能不可用。
    • “JRE”：代表“COMPAT”的同义词。 该名称已被弃用，将在将来的JDK版本中删除。

    例如，如果在属性中指定了以下内容：

      java.locale.providers=SPI,CLDR,COMPAT
    首先查询SPI提供商中的区域敏感服务。 如果所需的区域设置敏感服务不可用，则运行时将以该顺序查找CLDR，COMPAT。

    查找首选语言环境提供程序的默认顺序为“CLDR，COMPAT”，因此指定“CLDR，COMPAT”与默认行为相同。 需要实施区域设置敏感服务的应用程序必须明确指定“SPI”，以便Java运行时从类路径加载它们。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected LocaleServiceProvider​()
      初始化新的区域设置服务提供程序。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Locale[] getAvailableLocales​()
      返回此区域设置服务提供程序可以为其提供本地化对象或名称的所有区域设置的数组。
      boolean isSupportedLocale​(Locale locale)
      如果本地区服务提供商支持给定的 locale则返回 true 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LocaleServiceProvider

        protected LocaleServiceProvider​()
        初始化新的区域设置服务提供程序。
        异常
        SecurityException - 如果安全管理器已经安装并且它拒绝了RuntimePermission("localeServiceProvider")

    • 方法详细信息

      • getAvailableLocales

        public abstract Locale[] getAvailableLocales​()
        返回此区域设置服务提供程序可以为其提供本地化对象或名称的所有区域设置的数组。 此信息用于组成getAvailableLocales()与区域设置相关的服务的值，如DateFormat.getAvailableLocales() 。

        此方法返回的数组不应包含两个或多个仅扩展名不同的Locale对象。

        结果
        所有语言环境的数组，这个语言环境服务提供者可以为其提供本地化的对象或名称。

      • isSupportedLocale

        public boolean isSupportedLocale​(Locale locale)
        如果本地区服务提供商支持给定的locale则返回true 。 给定的locale可能包含extensions ，应考虑支持确定。

        如果给定的locale等于Locale返回的任何可用的Locale ，忽略给定的locale和可用区域设置中的任何扩展，默认实现将返回true 。 如果这些实现是Locale扩展感知，则具体的区域设置服务提供者实现应该覆盖此方法。 例如， DecimalFormatSymbolsProvider实现将需要检查给定的locale扩展，以查看是否指定了任何编号系统并可以被支持。 但是， CollatorProvider实现可能不受任何特定编号系统的影响，在这种情况下，编号系统的扩展应该被忽略。

        参数
        locale - a Locale待测试
        结果
        true如果给定的locale由该提供商支持; false否则。
        异常
        NullPointerException - 如果给出的 locale是 null
        从以下版本开始：
        1.8
        另请参见：
        Locale.hasExtensions() ， Locale.stripExtensions()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ResourceBundleControlProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Interface ResourceBundleControlProvider

  • public interface ResourceBundleControlProvider
    服务提供商的接口，提供ResourceBundle.Control的实现。 ResourceBundle.getBundle的ResourceBundle.getBundle工厂方法中没有ResourceBundle.Control实例可以修改ResourceBundleControlProvider实现。

    在第一次调用ResourceBundle.getBundle工厂方法时，将使用ServiceLoader从应用程序的类路径加载提供程序实现，该方法不需要ResourceBundle.Control实例。

    全部ResourceBundleControlProvider在命名模块中被忽略。

    从以下版本开始：
    1.8
    另请参见：
    ResourceBundle.getBundle ， ServiceLoader.load(Class)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ResourceBundle.Control getControl​(String baseName)
      返回一个 ResourceBundle.Control实例，用于处理给定的 baseName资源束加载。

    • 方法详细信息

      • getControl

        ResourceBundle.Control getControl​(String baseName)
        返回一个ResourceBundle.Control实例，用于处理给定的baseName资源束加载。 如果给定的baseName不由此提供商处理，则此方法必须返回null 。
        参数
        baseName - 资源束的基本名称
        结果
        一个 ResourceBundle.Control实例，或 null如果给定的 baseName不适用于此提供商。
        异常
        NullPointerException - 如果 baseName是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ResourceBundleProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Interface ResourceBundleProvider

  • 所有已知实现类：
    AbstractResourceBundleProvider

    public interface ResourceBundleProvider
    ResourceBundleProvider是一个提供者接口，用于加载命名模块的资源束。 在ResourceBundle.getBundle方法的调用期间，此接口的实现类加载了ServiceLoader 。 提供商服务类型由<package name> + ".spi." + <simple name> + "Provider"确定。

    例如，如果基本名称是“com.example.app.MyResources”，则com.example.app.spi.MyResourcesProvider将是提供者服务类型：

       public interface MyResourcesProvider extends ResourceBundleProvider { }

    通过资源包加载过程而不是ResourceBundle.Control.newBundle()调用此提供商的getBundle方法。 详情请参阅ResourceBundle 。

    从以下版本开始：
    9
    另请参见：
    Resource Bundles in Named Modules ， ResourceBundleProvider Service Providers

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ResourceBundle getBundle​(String baseName, Locale locale)
      为给定的包名和区域设置返回一个 ResourceBundle 。

    • 方法详细信息

      • getBundle

        ResourceBundle getBundle​(String baseName,
                         Locale locale)
        为给定的包名称和区域设置返回一个ResourceBundle 。 该方法返回null如果没有ResourceBundle发现给定参数。
        参数
        baseName - 资源包的基础包名称，一个完全限定的类名称
        locale - 应为其加载资源束的区域设置
        结果
        为给定参数创建的ResourceBundle，如果没有找到给定参数的 ResourceBundle则为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TimeZoneNameProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Class TimeZoneNameProvider

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.util.spi.TimeZoneNameProvider

  • public abstract class TimeZoneNameProvider
extends LocaleServiceProvider
    为TimeZone类提供本地化时区名称的服务提供商的抽象类。 本类实现中可用的本地化时区名称也是DateFormatSymbols.getZoneStrings()方法的源。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected TimeZoneNameProvider​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract String getDisplayName​(String ID, boolean daylight, int style, Locale locale)
      返回适合在指定语言环境中向用户呈现的给定时区ID的名称。
      String getGenericDisplayName​(String ID, int style, Locale locale)
      返回给定时区 ID的通用名称，适用于在指定的 locale向用户 locale 。

      • Methods inherited from class java.util.spi.LocaleServiceProvider

        getAvailableLocales, isSupportedLocale

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TimeZoneNameProvider

        protected TimeZoneNameProvider​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • getDisplayName

        public abstract String getDisplayName​(String ID,
                                      boolean daylight,
                                      int style,
                                      Locale locale)
        返回适合在指定语言环境中向用户呈现的给定时区ID的名称。 给定的时区ID是“GMT”，或者是使用“tz数据库”中的“区域”条目定义的名称之一，公共域时区数据库是ftp://elsie.nci.nih.gov/pub/ 。 该数据库的数据包含在名称以“tzdata”开头的文件中，数据格式的说明是zic.8手册页的一部分，它包含在名称以“tzcode”开头的文件中。

        如果daylight为true，则该方法应返回适合夏令时的名称，即使指定的时区过去没有观察到夏令时。

        参数
        ID - 时区ID字符串
        daylight - 如果为true，则返回夏令时名称。
        style - TimeZone.LONG或 TimeZone.SHORT
        locale - 所需的语言环境
        结果
        给定区域中给定时区的人类可读名称，如果不可用，则为null。
        异常
        IllegalArgumentException - 如果 style无效，或 locale不是从 getAvailableLocales()返回的语言环境 之一 。
        NullPointerException - 如果 ID或 locale为空
        另请参见：
        TimeZone.getDisplayName(boolean, int, java.util.Locale)

      • getGenericDisplayName

        public String getGenericDisplayName​(String ID,
                                    int style,
                                    Locale locale)
        返回给定时区ID的通用名称，适用于在指定的locale向用户locale 。 通用时区名称在标准时间和夏令时是中性的。 例如，“PT”是时区ID America/Los_Angeles的简短通用名称，而其标准时间和夏令时间名称分别为“PST”和“PDT”。 有关有效的时区ID，请参阅getDisplayName 。

        此方法的默认实现将返回null 。

        参数
        ID - 时区ID字符串
        style - TimeZone.LONG或 TimeZone.SHORT
        locale - 所需的语言环境
        结果
        给定语言环境中给定时区的人类可读的通用名称，如果不可用， null 。
        异常
        IllegalArgumentException - 如果 style无效，或 locale不是从 getAvailableLocales()返回的区域设置 之一 。
        NullPointerException - 如果 ID或 locale是 null
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToolProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.spi

Interface ToolProvider

  • public interface ToolProvider
    一个用于命令行工具的界面，用于提供一种无需启动新VM即可调用的方法。

    工具提供者通常使用由ServiceLoader定义的服务提供商加载工具。 每个提供者必须提供一个名称和一个运行相应工具实例的方法。 当一个工具运行时，它将提供一个字符串参数数组和一对流：一个用于正常（或预期）输出，另一个用于报告可能发生的任何错误。 字符串参数的解释通常由每个单独的工具提供程序定义，但通常对应于在从命令行调用该工具时可以提供给该工具的参数。

    从以下版本开始：
    9

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      static Optional<ToolProvider> findFirst​(String name)
      返回具有给定名称的ToolProvider的第一个实例，由使用系统类加载器的ServiceLoader加载。
      String name​()
      返回此工具提供程序的名称。
      default int run​(PrintStream out, PrintStream err, String... args)
      运行该工具的实例，返回零以成功运行。
      int run​(PrintWriter out, PrintWriter err, String... args)
      运行该工具的实例，返回零以成功运行。

    • 方法详细信息

      • name

        String name​()
        返回此工具提供程序的名称。
        API Note:
        建议名称与命令行上使用的名称相同：例如“javac”，“jar”，“jlink”。
        结果
        这个工具提供者的名字

      • run

        int run​(PrintWriter out,
        PrintWriter err,
        String... args)
        运行该工具的实例，返回零以成功运行。 任何非零返回值表示在执行过程中特定于刀具的错误。 应提供两个流，“预期”输出和任何错误消息。 如果不需要区分输出，则可以同时使用相同的流。
        API Note:
        论点的解释将针对每个工具。
        参数
        out - 应写入“预期”输出的流
        err - 应写入任何错误消息的流
        args - 工具的命令行参数
        结果
        执行工具的结果。 返回值为0表示该工具没有遇到任何错误; 任何其他值表示执行期间至少有一个错误。
        异常
        NullPointerException - 如果任何参数是 null ，或者 args数组中有 null值

      • run

        default int run​(PrintStream out,
                PrintStream err,
                String... args)
        运行该工具的实例，返回零以成功运行。 任何非零返回值表示在执行过程中特定于刀具的错误。 应提供两个流，“预期”输出和任何错误消息。 如果不需要区分输出，则可以同时使用相同的流。
        API Note:
        论点的解释将针对每个工具。
        Implementation Note:
        这个实现将out和err流中的err封装 ，然后调用run(PrintWriter, PrintWriter, String[]) 。
        参数
        out - 应写入“预期”输出的流
        err - 应写入任何错误消息的流
        args - 工具的命令行参数
        结果
        执行工具的结果。 返回值为0表示该工具没有遇到任何错误; 任何其他值表示执行期间至少有一个错误。
        异常
        NullPointerException - 如果任何参数是 null ，或者 args数组中有任何 null值

      • findFirst

        static Optional<ToolProvider> findFirst​(String name)
        返回具有给定名称的ToolProvider的第一个实例，由使用系统类加载器的ServiceLoader加载。
        参数
        name - 所需工具提供程序的名称
        结果
        一发现 Optional<ToolProvider>
        异常
        NullPointerException - 如果 name是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.spi

  • Packages that use java.util.spi
    软件包 描述
    java.text.spi
    java.text包中类的服务提供者类。
    java.util.spi
    java.util包中类的服务提供者类。
  • Classes in java.util.spi used by java.text.spi
    Class 描述
    LocaleServiceProvider
    这是所有区域设置敏感的服务提供商接口（SPI）的超类。
  • Classes in java.util.spi used by java.util.spi
    Class 描述
    LocaleServiceProvider
    这是所有区域设置敏感的服务提供商接口（SPI）的超类。
    ResourceBundleProvider
    ResourceBundleProvider是一个提供者接口，用于加载命名模块的资源束。
    ToolProvider
    一个用于命令行工具的界面，用于提供一种无需启动新VM即可调用的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.spi.AbstractResourceBundleProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.spi.AbstractResourceBundleProvider

No usage of java.util.spi.AbstractResourceBundleProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.spi.CalendarDataProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.spi.CalendarDataProvider

No usage of java.util.spi.CalendarDataProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.spi.CalendarNameProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.spi.CalendarNameProvider

No usage of java.util.spi.CalendarNameProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.spi.CurrencyNameProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.spi.CurrencyNameProvider

No usage of java.util.spi.CurrencyNameProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.spi.LocaleNameProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.spi.LocaleNameProvider

No usage of java.util.spi.LocaleNameProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.spi.LocaleServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.spi.LocaleServiceProvider

  • Packages that use LocaleServiceProvider
    软件包 描述
    java.text.spi
    java.text包中类的服务提供者类。
    java.util.spi
    java.util包中类的服务提供者类。

    • Uses of LocaleServiceProvider in java.text.spi

      Subclasses of LocaleServiceProvider in java.text.spi
      Modifier and Type Class 描述
      class  BreakIteratorProvider
      提供BreakIterator类的具体实现的服务提供者的抽象类。
      class  CollatorProvider
      提供Collator类的具体实现的服务提供者的抽象类。
      class  DateFormatProvider
      提供DateFormat类的具体实现的服务提供者的抽象类。
      class  DateFormatSymbolsProvider
      提供DateFormatSymbols类的实例的服务提供者的抽象类。
      class  DecimalFormatSymbolsProvider
      提供DecimalFormatSymbols类实例的服务提供者的抽象类。
      class  NumberFormatProvider
      提供NumberFormat类的具体实现的服务提供者的抽象类。

    • Uses of LocaleServiceProvider in java.util.spi

      Subclasses of LocaleServiceProvider in java.util.spi
      Modifier and Type Class 描述
      class  CalendarDataProvider
      服务提供商的抽象类，提供依赖于区域设置的Calendar参数。
      class  CalendarNameProvider
      提供 Calendar字段值的本地化字符串表示（显示名称）的服务提供者的抽象类。
      class  CurrencyNameProvider
      为Currency类提供本地化货币符号和显示名称的服务提供商的抽象类。
      class  LocaleNameProvider
      为Locale类提供本地化名称的服务提供商的抽象类。
      class  TimeZoneNameProvider
      An abstract class for service providers that provide localized time zone names for the TimeZone class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.spi.TimeZoneNameProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.spi.TimeZoneNameProvider

No usage of java.util.spi.TimeZoneNameProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.spi.ResourceBundleControlProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.spi.ResourceBundleControlProvider

No usage of java.util.spi.ResourceBundleControlProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.spi.ResourceBundleProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.spi.ResourceBundleProvider

  • Packages that use ResourceBundleProvider
    软件包 描述
    java.util.spi
    java.util包中类的服务提供者类。

    • Uses of ResourceBundleProvider in java.util.spi

      Classes in java.util.spi that implement ResourceBundleProvider
      Modifier and Type Class 描述
      class  AbstractResourceBundleProvider
      AbstractResourceBundleProvider是一个抽象类，为ResourceBundleProvider的提供程序实现类提供基本支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.spi.ToolProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.spi.ToolProvider

  • Packages that use ToolProvider
    软件包 描述
    java.util.spi
    java.util包中类的服务提供者类。

    • Uses of ToolProvider in java.util.spi

      Methods in java.util.spi that return types with arguments of type ToolProvider
      Modifier and Type 方法 描述
      static Optional<ToolProvider> ToolProvider.findFirst​(String name)
      返回具有给定名称的ToolProvider的第一个实例，由使用系统类加载器的ServiceLoader加载。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


BaseStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface BaseStream<T,S extends BaseStream<T,S>>

  • 参数类型
    T - 流元素的类型
    S - 实现 BaseStream的流的类型
    All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    DoubleStream ， IntStream ， LongStream ， Stream<T>

    public interface BaseStream<T,S extends BaseStream<T,S>>
extends AutoCloseable
    流的基本界面，它们是支持顺序和并行聚合操作的元素序列。 以下示例说明使用流类型Stream和IntStream的汇总操作，计算红色小部件的权重之和：
       int sum = widgets.stream() .filter(w -> w.getColor() == RED) .mapToInt(w -> w.getWeight()) .sum();
    请参阅类文档Stream ，为包文档java.util.stream的流附加规格，流操作，流管道，以及并行性，支配所有流类型的行为。
    从以下版本开始：
    1.8
    另请参见：
    Stream ， IntStream ， LongStream ， DoubleStream ， java.util.stream

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭此流，导致此流管道的所有关闭处理程序被调用。
      boolean isParallel​()
      返回此流是否要执行终端操作，将并行执行。
      Iterator<T> iterator​()
      返回此流的元素的迭代器。
      S onClose​(Runnable closeHandler)
      返回带有附加关闭处理程序的等效流。
      S parallel​()
      返回平行的等效流。
      S sequential​()
      返回顺序的等效流。
      Spliterator<T> spliterator​()
      返回此流的元素的拼接器。
      S unordered​()
      返回等效的流，即 unordered 。

    • 方法详细信息

      • iterator

        Iterator<T> iterator​()
        返回此流的元素的迭代器。

        这是一个terminal operation 。

        结果
        该流的元素迭代器

      • spliterator

        Spliterator<T> spliterator​()
        返回此流的元素的拼接器。

        这是一个terminal operation 。

        返回的分配器应该报告从流管道导出的特征集（即从流源分割器和中间操作导出的特性）。 实施可能会报告这些特征的子集。 例如，为一些或所有可能的流管线计算整个集合可能太贵了。

        结果
        该流的元素拼接器

      • isParallel

        boolean isParallel​()
        返回此流是否要执行终端操作，将并行执行。 在调用终端流操作方法后调用此方法可能会产生不可预测的结果。
        结果
        true如果这个数据流将执行并行执行

      • sequential

        S sequential​()
        返回顺序的等效流。 可能返回自己，因为流已经是顺序的，或者因为底层流状态被修改为顺序的。

        这是一个intermediate operation 。

        结果
        顺序流

      • parallel

        S parallel​()
        返回平行的等效流。 可能会返回自己，因为流已经是并行的，或者因为底层流状态被修改为并行。

        这是一个intermediate operation 。

        结果
        并行流

      • unordered

        S unordered​()
        返回等效的流，即unordered 。 可能会返回自己，因为流已经无序，或者因为基础流状态被修改为无序。

        这是一个intermediate operation 。

        结果
        无序的流

      • onClose

        S onClose​(Runnable closeHandler)
        返回带有附加关闭处理程序的等效流。 在流上调用close()方法时运行关闭处理程序，并按照添加的顺序执行。 所有关闭的处理程序都运行，即使较早的关闭处理程序抛出异常。 如果任何关闭处理程序抛出异常，抛出的第一个异常将被转发给close()的调用者，其余任何其余的异常作为禁止异常添加到该异常中（除非其中一个异常与第一个异常相同，否则为异常不能压制自己。）可能返回自己。

        这是一个intermediate operation 。

        参数
        closeHandler - 流关闭时执行的任务
        结果
        具有处理程序的流，如果流已关闭，则运行该流

      • close

        void close​()
        关闭此流，导致此流管道的所有关闭处理程序被调用。
        Specified by:
        close在接口 AutoCloseable
        另请参见：
        AutoCloseable.close()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Collector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface Collector<T,A,R>

  • 参数类型
    T - 还原操作的输入元素的类型
    A - 缩减操作的可变累积类型（通常作为实现细节隐藏）
    R - 缩小操作的结果类型

    public interface Collector<T,A,R>
    A mutable reduction operation将输入元素累加到可变结果容器中，可选地将所有输入元素处理后的累加结果转换成最终表示。 还原操作可以顺序还是并行执行。

    可变缩减操作的示例包括：将元素累加到一个Collection ; 使用StringBuilder连接字符串; 计算诸如sum，min，max或average的元素的概要信息; 计算“枢纽表”摘要，如“卖方最大价值交易”等。Collectors类提供了许多常见的可变减少的实现。

    A Collector由四个函数指定，这四个函数一起工作以将条目累加到可变结果容器中，并可选择对结果执行最终转换。 他们是：

    • 创建新的结果容器（ supplier() ）
    • 在结果容器中加入新的数据元素（ accumulator() ）
    • 将两个结果容器组合成一个（ combiner() ）
    • 在容器上执行可选的最终变换（ finisher() ）

    收集者还具有一系列特征，例如Collector.Characteristics.CONCURRENT ，它提供可由减少实现使用以提供更好性能的提示。

    使用收集器的顺序实现减少将使用供应商函数创建单个结果容器，并为每个输入元素调用累加器函数一次。 并行实现将分区输入，为每个分区创建一个结果容器，将每个分区的内容累加到该分区的子结果中，然后使用组合器函数将子结果合并为一个组合结果。

    为了确保顺序和并行执行产生相同的结果，收集器函数必须满足一个身份和一个associativity约束。

    身份约束说，对于任何部分累积的结果，将其与空结果容器组合必须产生等效的结果。 也就是说，部分累加结果a即任何系列累加器和组合器的调用的结果， a必须等于combiner.apply(a, supplier.get()) 。

    关联约束说，分割计算必须产生等效的结果。 也就是说，对于任何输入元件t1和t2 ，下面的计算中的结果r1和r2必须等效：

       A a1 = supplier.get(); accumulator.accept(a1, t1); accumulator.accept(a1, t2); R r1 = finisher.apply(a1); // result without splitting A a2 = supplier.get(); accumulator.accept(a2, t1); A a3 = supplier.get(); accumulator.accept(a3, t2); R r2 = finisher.apply(combiner.apply(a2, a3)); // result with splitting

    对于不具备收藏UNORDERED特征，二累加结果a1和a2是等价的，如果finisher.apply(a1).equals(finisher.apply(a2)) 。 对于无序的收藏者，放宽等价以允许与秩序的差异相关的不平等。 （例如，如果List元素累积到一个无序的收集器，如果它们包含相同的元素，则会考虑两个列表，忽略顺序。）

    基于Collector实现减少的Collector （如Stream.collect(Collector) ）必须遵守以下约束：

    • 第一个参数传递给累加器函数，两个参数传递给组合函数，传递给完成者函数的参数必须是先前调用结果提供程序，累加器或组合函数的结果。
    • 除了将其再次传递给累加器，组合器或修整器功能之外，实现不应该对任何结果提供者，累加器或组合器功能进行任何操作，也可以将它们返回给还原操作的调用者。
    • 如果结果传递给组合器或整理器函数，并且不从该函数返回相同的对象，则不会再次使用该对象。
    • 一旦结果传递给组合器或整理器函数，它就不会再次传递给累加器函数。
    • 对于非并发收集器，从结果提供者，累加器或组合器函数返回的任何结果必须是串行线程限制的。 这使得集合并行发生，而Collector需要实现任何其他同步。 还原实现必须管理输入被正确分区，分区被隔离处理，并且组合仅在累积完成后才进行。
    • 对于并发收集器，实现可以自由（但不是必须）同时实现还原。 并发减少是使用同一可同时修改的结果容器从多个线程并发调用累加器函数，而不是在累积期间保持结果隔离。 仅当收集器具有Collector.Characteristics.UNORDERED特性或者起始数据无序时，才应用并发减少。

    除了Collectors中的预定义实现之外 ，静态工厂方法of(Supplier, BiConsumer, BinaryOperator, Characteristics...)可用于构建收集器。 例如，您可以创建一个收集器，将小部件累积到TreeSet中：

       Collector<Widget, ?, TreeSet<Widget>> intoSet = Collector.of(TreeSet::new, TreeSet::add, (left, right) -> { left.addAll(right); return left; });
    （此行为也由预定义的收集器Collectors.toCollection(Supplier)实现 ）。
    API Note:
    使用Collector执行缩减操作时应产生等效于：
       R container = collector.supplier().get(); for (T t : data) collector.accumulator().accept(container, t); return collector.finisher().apply(container);

    然而，库可以自由分割输入，执行分区的减少，然后使用组合器函数组合部分结果以实现并行还原。 （根据具体的减速操作，这可能会更好或更差，取决于累加器和组合器功能的相对成本。）

    收藏家的目的是组成 ; Collectors中的许多方法是使用收集器并生成新收集器的函数。 例如，给定以下收集器来计算员工流的总和：

       Collector<Employee, ?, Integer> summingSalaries = Collectors.summingInt(Employee::getSalary))
    如果我们想创建一个收藏家，按部门列出工资总额，我们可以使用Collectors.groupingBy(Function, Collector)重新使用“薪金总额”逻辑：
       Collector<Employee, ?, Map<Department, Integer>> summingSalariesByDept = Collectors.groupingBy(Employee::getDepartment, summingSalaries);
    从以下版本开始：
    1.8
    另请参见：
    Stream.collect(Collector) ， Collectors

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  Collector.Characteristics
      指示 Collector属性的特性，可用于优化还原实现。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      BiConsumer<A,T> accumulator​()
      将值折叠成可变结果容器的函数。
      Set<Collector.Characteristics> characteristics​()
      返回一个 Set的 Collector.Characteristics表明该收藏家的特征。
      BinaryOperator<A> combiner​()
      一个接受两个部分结果并将其合并的函数。
      Function<A,R> finisher​()
      执行从中间累加类型 A到最终结果类型 R的最终 R 。
      static <T,A,R> Collector<T,A,R> of​(Supplier<A> supplier, BiConsumer<A,T> accumulator, BinaryOperator<A> combiner, Function<A,R> finisher, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ， combiner ，并 finisher功能。
      static <T,R> Collector<T,R,R> of​(Supplier<R> supplier, BiConsumer<R,T> accumulator, BinaryOperator<R> combiner, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ，并 combiner功能。
      Supplier<A> supplier​()
      一个创建并返回一个新的可变结果容器的函数。

    • 方法详细信息

      • supplier

        Supplier<A> supplier​()
        一个创建并返回一个新的可变结果容器的函数。
        结果
        一个返回一个新的可变结果容器的函数

      • accumulator

        BiConsumer<A,T> accumulator​()
        将值折叠成可变结果容器的函数。
        结果
        将值折叠成可变结果容器的函数

      • combiner

        BinaryOperator<A> combiner​()
        一个接受两个部分结果并将其合并的函数。 组合器功能可以将状态从一个参数折叠到另一个参数，并返回，或者可能返回一个新的结果容器。
        结果
        将两个部分结果组合成一个组合结果的函数

      • finisher

        Function<A,R> finisher​()
        执行从中间累积类型A到最终结果类型R的最终R 。

        如果设置了特征IDENTITY_FINISH则可以将该功能推定为具有从A到R的未经检查的转换的身份变换。

        结果
        将中间结果转换为最终结果的函数

      • characteristics

        Set<Collector.Characteristics> characteristics​()
        返回Set的Collector.Characteristics表明该收藏家的特征。 这一套应该是不变的。
        结果
        一套不可变的收集器特征

      • of

        static <T,R> Collector<T,R,R> of​(Supplier<R> supplier,
                                 BiConsumer<R,T> accumulator,
                                 BinaryOperator<R> combiner,
                                 Collector.Characteristics... characteristics)
        返回一个新Collector由给定的描述supplier ， accumulator ，并combiner功能。 所得到的Collector具有Collector.Characteristics.IDENTITY_FINISH特点。
        参数类型
        T - 新收集器的输入元素的类型
        R - 新收集器的中间累积结果类型和最终结果
        参数
        supplier - 新收藏家的供应商功能
        accumulator - 新收集器的累加器功能
        combiner - 新收集器的组合器功能
        characteristics - 新收集器的收集器特性
        结果
        新的 Collector
        异常
        NullPointerException - 如果任何参数为空

      • of

        static <T,A,R> Collector<T,A,R> of​(Supplier<A> supplier,
                                   BiConsumer<A,T> accumulator,
                                   BinaryOperator<A> combiner,
                                   Function<A,R> finisher,
                                   Collector.Characteristics... characteristics)
        返回一个新 Collector由给定的描述 supplier ， accumulator ， combiner ，并 finisher功能。
        参数类型
        T - 新收集器的输入元素的类型
        A - 新收藏家的中间累积类型
        R - 新收集器的最终结果类型
        参数
        supplier - 新收藏家的供应商功能
        accumulator - 新收集器的累加器功能
        combiner - 新收集器的组合器功能
        finisher - 新收藏家的完成器功能
        characteristics - 新收集器的收集器特性
        结果
        新的 Collector
        异常
        NullPointerException - 如果任何参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Collector.Characteristics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.util.stream

Enum Collector.Characteristics

  • java.lang.Object
    • java.lang.Enum<Collector.Characteristics>
      • java.util.stream.Collector.Characteristics
  • All Implemented Interfaces:
    Serializable ， Comparable<Collector.Characteristics>
    Enclosing interface:
    Collector < T ， A ， R >

    public static enum Collector.Characteristics
extends Enum<Collector.Characteristics>
    指示 Collector属性的特性，可用于优化还原实现。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CONCURRENT
      表示此收集器是 并发的 ，这意味着结果容器可以支持与多个线程相同的结果容器同时调用的累加器函数。
      IDENTITY_FINISH
      表示整理器功能是身份功能，可以被删除。
      UNORDERED
      表示收集操作不承诺保留输入元素的遇到顺序。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Collector.Characteristics valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Collector.Characteristics[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONCURRENT

        public static final Collector.Characteristics CONCURRENT
        表示此收集器是并发的 ，这意味着结果容器可以支持与多个线程相同的结果容器同时调用的累加器函数。

        如果CONCURRENT收集器也不是UNORDERED ，那么它应该只在同时应用于无序数据源时才能被求值。

      • UNORDERED

        public static final Collector.Characteristics UNORDERED
        表示收集操作不承诺保留输入元素的遇到顺序。 （如果结果容器没有内在顺序（如Set ），则可能是这样）。

      • IDENTITY_FINISH

        public static final Collector.Characteristics IDENTITY_FINISH
        表示整理器功能是身份功能，可以被删除。 如果设置，则必须将从A到R的未经检查的转换成功。

    • 方法详细信息

      • values

        public static Collector.Characteristics[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Collector.Characteristics c : Collector.Characteristics.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Collector.Characteristics valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Collectors (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Class Collectors

  • java.lang.Object
    • java.util.stream.Collectors

  • public final class Collectors
extends Object
    实现各种有用的还原操作的Collector ，例如将元素累积到集合中，根据各种标准汇总元素等。

    以下是使用预定义的收集器执行常见的可变缩减任务的示例：

       // Accumulate names into a List List<String> list = people.stream() .map(Person::getName) .collect(Collectors.toList()); // Accumulate names into a TreeSet Set<String> set = people.stream() .map(Person::getName) .collect(Collectors.toCollection(TreeSet::new)); // Convert elements to strings and concatenate them, separated by commas String joined = things.stream() .map(Object::toString) .collect(Collectors.joining(", ")); // Compute sum of salaries of employee int total = employees.stream() .collect(Collectors.summingInt(Employee::getSalary)); // Group employees by department Map<Department, List<Employee>> byDept = employees.stream() .collect(Collectors.groupingBy(Employee::getDepartment)); // Compute sum of salaries by department Map<Department, Integer> totalByDept = employees.stream() .collect(Collectors.groupingBy(Employee::getDepartment, Collectors.summingInt(Employee::getSalary))); // Partition students into passing and failing Map<Boolean, List<Student>> passingFailing = students.stream() .collect(Collectors.partitioningBy(s -> s.getGrade() >= PASS_THRESHOLD));
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static <T> Collector<T,?,Double> averagingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个产生应用于输入元素的双值函数的算术平均值的 Collector 。
      static <T> Collector<T,?,Double> averagingInt​(ToIntFunction<? super T> mapper)
      返回一个产生应用于输入元素的整数值函数的算术平均值的 Collector 。
      static <T> Collector<T,?,Double> averagingLong​(ToLongFunction<? super T> mapper)
      返回一个产生应用于输入元素的长值函数的算术平均值的 Collector 。
      static <T,A,R,RR> Collector<T,A,RR> collectingAndThen​(Collector<T,A,R> downstream, Function<R,RR> finisher)
      适应 Collector执行额外的完成转换。
      static <T> Collector<T,?,Long> counting​()
      返回 Collector类型的接受元件 T计数输入元件的数量。
      static <T,A,R> Collector<T,?,R> filtering​(Predicate<? super T> predicate, Collector<? super T,A,R> downstream)
      适应一个 Collector相同类型的一个接受元件 T通过将谓词给每个输入元素并且如果所述谓词仅返回累积 true 。
      static <T,U,A,R> Collector<T,?,R> flatMapping​(Function<? super T,? extends Stream<? extends U>> mapper, Collector<? super U,A,R> downstream)
      适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累之前施加平坦映射函数应用于每个输入元件。
      static <T,K> Collector<T,?,Map<K,List<T>>> groupingBy​(Function<? super T,? extends K> classifier)
      返回一个 Collector对类型为 T输入元素执行“按组”操作，根据分类功能对元素进行分组，并将结果返回到 Map 。
      static <T,K,D,A,M extends Map<K,D>>
      Collector<T,?,M>             		groupingBy​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定与给定键相关联的值进行还原操作 Collector 。
      static <T,K,A,D> Collector<T,?,Map<K,D>> groupingBy​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回 Collector对 T类型的输入元素进行级联“分组”操作，根据分类功能对元素进行分组，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K> Collector<T,?,ConcurrentMap<K,List<T>>> groupingByConcurrent​(Function<? super T,? extends K> classifier)
      返回并行的 Collector对 T类型的输入元素实施“分组”操作，根据分类功能对元素进行分组。
      static <T,K,A,D,M extends ConcurrentMap<K,D>>
      Collector<T,?,M>             		groupingByConcurrent​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回一个并发 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定执行与给定键相关联的值的归约运算 Collector 。
      static <T,K,A,D> Collector<T,?,ConcurrentMap<K,D>> groupingByConcurrent​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回一个并发 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定执行与给定键相关联的值的归约运算 Collector 。
      static Collector<CharSequence,?,String> joining​()
      返回一个 Collector ，将输入元素连接到一个 String ，按照顺序。
      static Collector<CharSequence,?,String> joining​(CharSequence delimiter)
      返回一个 Collector ，按照遇到的顺序连接由指定的分隔符分隔的输入元素。
      static Collector<CharSequence,?,String> joining​(CharSequence delimiter, CharSequence prefix, CharSequence suffix)
      返回一个 Collector ，按照遇到的顺序将指定的分隔符分隔的输入元素与指定的前缀和后缀进行连接。
      static <T,U,A,R> Collector<T,?,R> mapping​(Function<? super T,? extends U> mapper, Collector<? super U,A,R> downstream)
      适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累前应用映射函数到每个输入元素。
      static <T> Collector<T,?,Optional<T>> maxBy​(Comparator<? super T> comparator)
      返回一个 Collector ，它根据给定的 Comparator产生最大元素，描述为 Optional<T> 。
      static <T> Collector<T,?,Optional<T>> minBy​(Comparator<? super T> comparator)
      返回 Collector ，它根据给定的 Comparator生成最小元素，描述为 Optional<T> 。
      static <T> Collector<T,?,Map<Boolean,List<T>>> partitioningBy​(Predicate<? super T> predicate)
      返回 Collector由划分根据所述输入元件 Predicate ，并且将它们组织到一个 Map<Boolean, List<T>> 。
      static <T,D,A> Collector<T,?,Map<Boolean,D>> partitioningBy​(Predicate<? super T> predicate, Collector<? super T,A,D> downstream)
      返回 Collector由划分根据所述输入元件 Predicate ，减少了在根据另一每个分区中的值 Collector ，并且将它们组织到一个 Map<Boolean, D>其值是下游减少的结果。
      static <T> Collector<T,?,Optional<T>> reducing​(BinaryOperator<T> op)
      返回一个 Collector ，它在指定的 BinaryOperator下执行其输入元素的减少。
      static <T> Collector<T,?,T> reducing​(T identity, BinaryOperator<T> op)
      返回一个 Collector ，它使用提供的身份在指定的 BinaryOperator下执行其输入元素的减少。
      static <T,U> Collector<T,?,U> reducing​(U identity, Function<? super T,? extends U> mapper, BinaryOperator<U> op)
      返回一个 Collector ，它在指定的映射函数和 BinaryOperator下执行其输入元素的减少。
      static <T> Collector<T,?,DoubleSummaryStatistics> summarizingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 Collector ， double映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
      static <T> Collector<T,?,IntSummaryStatistics> summarizingInt​(ToIntFunction<? super T> mapper)
      返回一个 Collector ， int生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
      static <T> Collector<T,?,LongSummaryStatistics> summarizingLong​(ToLongFunction<? super T> mapper)
      返回一个 Collector ，它为每个输入元素应用 long生产映射函数，并返回结果值的汇总统计信息。
      static <T> Collector<T,?,Double> summingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 Collector ，它产生应用于输入元素的双值函数的和。
      static <T> Collector<T,?,Integer> summingInt​(ToIntFunction<? super T> mapper)
      返回一个产生应用于输入元素的整数值函数之和的 Collector 。
      static <T> Collector<T,?,Long> summingLong​(ToLongFunction<? super T> mapper)
      返回一个产生应用于输入元素的长值函数的和的 Collector 。
      static <T,C extends Collection<T>>
      Collector<T,?,C>             		toCollection​(Supplier<C> collectionFactory)
      返回一个 Collector ，按照遇到的顺序将输入元素累加到新的 Collection中。
      static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U,M extends ConcurrentMap<K,U>>
      Collector<T,?,M>             		toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。
      static <T> Collector<T,?,List<T>> toList​()
      返回一个 Collector ，将输入元素累加到一个新的 List 。
      static <T,K,U> Collector<T,?,Map<K,U>> toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,Map<K,U>> toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U,M extends Map<K,U>>
      Collector<T,?,M>             		toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T> Collector<T,?,Set<T>> toSet​()
      返回一个 Collector ，将输入元素累加到一个新的 Set 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • toCollection

        public static <T,C extends Collection<T>> Collector<T,?,C> toCollection​(Supplier<C> collectionFactory)
        返回一个Collector ，按照遇到的顺序将输入元素累加到新的Collection中。 Collection由提供的工厂创建。
        参数类型
        T - 输入元素的类型
        C - 所得的 Collection的类型
        参数
        collectionFactory - 供应商提供一个新的空 Collection ，其中将插入结果
        结果
        一个 Collector将所有输入元素收集到一个 Collection ，按照顺序

      • toList

        public static <T> Collector<T,?,List<T>> toList​()
        返回一个Collector ，将输入元素累加到一个新的List 。 List返回的类型，可变性，可序列化或线程安全性没有保证; 如果需要更多控制返回的List ，请使用toCollection(Supplier) 。
        参数类型
        T - 输入元素的类型
        结果
        一个 Collector将所有输入元素收集到一个 List ，按照顺序

      • toSet

        public static <T> Collector<T,?,Set<T>> toSet​()
        返回一个Collector ，将输入元素累加到一个新的Set 。 Set返回的类型，可变性，可序列化或线程安全性没有保证; 如果需要更多的控制返回Set ，请使用toCollection(Supplier) 。

        这是一个unordered收藏家。

        参数类型
        T - 输入元素的类型
        结果
        一个 Collector将所有输入元素收集到一个 Set

      • joining

        public static Collector<CharSequence,?,String> joining​()
        返回一个 Collector ，按照遇到的顺序将输入元素连接到一个 String 。
        结果
        一个 Collector将输入元素连接到一个 String ，按照顺序

      • joining

        public static Collector<CharSequence,?,String> joining​(CharSequence delimiter)
        返回一个 Collector ，按照遇到的顺序连接由指定的分隔符分隔的输入元素。
        参数
        delimiter - 要在每个元素之间使用的分隔符
        结果
        A Collector ，它以相遇的顺序连接由指定的分隔符分隔的CharSequence元素

      • joining

        public static Collector<CharSequence,?,String> joining​(CharSequence delimiter,
                                                       CharSequence prefix,
                                                       CharSequence suffix)
        返回一个 Collector ，它将按照指定的分隔符分隔的输入元素与指定的前缀和后缀进行连接。
        参数
        delimiter - 要在每个元素之间使用的分隔符
        prefix - 在连接结果开始时使用的字符序列
        suffix - 在结合结果结束时使用的字符序列
        结果
        A Collector ，其以相遇顺序连接由指定的分隔符分隔的CharSequence元素

      • mapping

        public static <T,U,A,R> Collector<T,?,R> mapping​(Function<? super T,? extends U> mapper,
                                                 Collector<? super U,A,R> downstream)
        适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累前应用映射函数到每个输入元素。
        API Note:
        mapping()收集器在用于多级mapping()时最为有用，例如groupingBy或partitioningBy下游。 例如，给出一个Person的流，以累积每个城市中的一组姓氏：
           Map<City, Set<String>> lastNamesByCity = people.stream().collect( groupingBy(Person::getCity, mapping(Person::getLastName, toSet())));
        参数类型
        T - 输入元素的类型
        U - 下游收集器接受的元素类型
        A - 下游收集器的中间堆积型
        R - 收集器的结果类型
        参数
        mapper - 要应用于输入元素的函数
        downstream - 将接受映射值的收集器
        结果
        一个收集器，将映射函数应用于输入元素，并将映射结果提供给下游收集器

      • flatMapping

        public static <T,U,A,R> Collector<T,?,R> flatMapping​(Function<? super T,? extends Stream<? extends U>> mapper,
                                                     Collector<? super U,A,R> downstream)
        适应一个Collector类型的接受元件U到类型的一个接受元件T通过积累之前施加平坦映射函数应用于每个输入元件。 平面映射函数将输入元素映射到stream，覆盖零个或多个输出元素，然后在下游累积。 每个映射的流在其内容被放置在下游之后是closed 。 （如果映射的流为null ，则使用空的流。）
        API Note:
        flatMapping()收集器在多级flatMapping()中使用最为有用，例如groupingBy或partitioningBy下游。 例如，给定一个Order的流，以累积每个客户的一组订单项：
           Map<String, Set<LineItem>> itemsByCustomerName = orders.stream().collect( groupingBy(Order::getCustomerName, flatMapping(order -> order.getLineItems().stream(), toSet())));
        参数类型
        T - 输入元素的类型
        U - 下游收集器接受的元素类型
        A - 下游收集器的中间堆积型
        R - 收集器的结果类型
        参数
        mapper - 要应用于输入元素的函数，它返回结果流
        downstream - 一个收集器，它将接收由mapper返回的流的元素
        结果
        一个收集器，将映射函数应用于输入元素，并将平面映射结果提供给下游收集器
        从以下版本开始：
        9

      • filtering

        public static <T,A,R> Collector<T,?,R> filtering​(Predicate<? super T> predicate,
                                                 Collector<? super T,A,R> downstream)
        适应一个 Collector相同类型的一个接受元件 T通过将谓词给每个输入元素并且如果所述谓词仅返回累积 true 。
        API Note:
        filtering()收集器在多级别缩减时最为有用，例如groupingBy或partitioningBy下游。 例如，给出Employee ，累积每个部门的员工的工资高于一定的门槛值：
           Map<Department, Set<Employee>> wellPaidEmployeesByDepartment = employees.stream().collect( groupingBy(Employee::getDepartment, filtering(e -> e.getSalary() > 2000, toSet())));
        过滤收集器与流的filter()操作不同。 在这个例子中，假设在某些部门没有员工的工资高于门槛。 使用如上所示的过滤收集器将导致从该部门到空的映射Set 。 如果完成了一个流filter()操作，那根本就没有该部门的映射。
        参数类型
        T - 输入元素的类型
        A - 下游收集器的中间堆积型
        R - 收集器的结果类型
        参数
        predicate - 要应用于输入元素的谓词
        downstream - 将接受与谓词匹配的值的收集器
        结果
        一个收集器，将谓词应用于输入元素，并向下游收集器提供匹配元素
        从以下版本开始：
        9

      • collectingAndThen

        public static <T,A,R,RR> Collector<T,A,RR> collectingAndThen​(Collector<T,A,R> downstream,
                                                             Function<R,RR> finisher)
        适应Collector进行额外的整理转换。 例如，可以使toList()收集器适应总是产生一个不可变的列表：
           List<String> list = people.stream().collect( collectingAndThen(toList(), Collections::unmodifiableList));
        参数类型
        T - 输入元素的类型
        A - 下游收集器的中间堆积型
        R - 下游收集器的结果类型
        RR - 结果收集器的结果类型
        参数
        downstream - 收藏家
        finisher - 应用于下游收集器的最终结果的函数
        结果
        执行下游收集器的动作的收集器，随后进行另外的精加工步骤

      • counting

        public static <T> Collector<T,?,Long> counting​()
        返回Collector类型的接受元素T ，它计算输入元素的数量。 如果没有元素，结果为0。
        实现要求：
        这产生的结果相当于：
           reducing(0L, e -> 1L, Long::sum)
        参数类型
        T - 输入元素的类型
        结果
        一个计数输入元素的 Collector

      • minBy

        public static <T> Collector<T,?,Optional<T>> minBy​(Comparator<? super T> comparator)
        返回一个 Collector ，它根据给定的 Comparator产生最小元素，描述为 Optional<T> 。
        实现要求：
        这产生的结果相当于：
           reducing(BinaryOperator.minBy(comparator))
        参数类型
        T - 输入元素的类型
        参数
        comparator - a Comparator用于比较元素
        结果
        一个产生最小值的 Collector

      • maxBy

        public static <T> Collector<T,?,Optional<T>> maxBy​(Comparator<? super T> comparator)
        返回一个 Collector ，它根据给定的 Comparator产生最大元素，描述为 Optional<T> 。
        实现要求：
        这产生的结果相当于：
           reducing(BinaryOperator.maxBy(comparator))
        参数类型
        T - 输入元素的类型
        参数
        comparator - a Comparator用于比较元素
        结果
        一个产生最大值的 Collector

      • summingInt

        public static <T> Collector<T,?,Integer> summingInt​(ToIntFunction<? super T> mapper)
        返回一个Collector ，它产生应用于输入元素的整数值函数的和。 如果没有元素，结果为0。
        参数类型
        T - 输入元素的类型
        参数
        mapper - 提取要求和的属性的函数
        结果
        一个 Collector生成派生属性的总和

      • summingLong

        public static <T> Collector<T,?,Long> summingLong​(ToLongFunction<? super T> mapper)
        返回一个产生应用于输入元素的长值函数的和的Collector 。 如果没有元素，结果为0。
        参数类型
        T - 输入元素的类型
        参数
        mapper - 提取要求和的属性的函数
        结果
        一个产生派生属性的和的 Collector

      • summingDouble

        public static <T> Collector<T,?,Double> summingDouble​(ToDoubleFunction<? super T> mapper)
        返回一个Collector ，它产生应用于输入元素的双值函数的和。 如果没有元素，结果为0。

        返回的总和可以根据记录值的顺序而变化，这是由于除了不同数值的值之外的累积舍入误差。 按绝对数量增加排列的数值往往会产生更准确的结果。 如果任何记录值是NaN或总和在任何点NaN那么总和将是NaN 。

        参数类型
        T - 输入元素的类型
        参数
        mapper - 提取要求和的属性的函数
        结果
        一个产生派生属性的总和的 Collector

      • averagingInt

        public static <T> Collector<T,?,Double> averagingInt​(ToIntFunction<? super T> mapper)
        返回一个产生应用于输入元素的整数值函数的算术平均值的Collector 。 如果没有元素，结果为0。
        参数类型
        T - 输入元素的类型
        参数
        mapper - 提取要平均的属性的函数
        结果
        一个产生派生属性的算术平均值的 Collector

      • averagingLong

        public static <T> Collector<T,?,Double> averagingLong​(ToLongFunction<? super T> mapper)
        返回一个产生应用于输入元素的长值函数的算术平均值的Collector 。 如果没有元素，结果为0。
        参数类型
        T - 输入元素的类型
        参数
        mapper - 提取要平均的属性的函数
        结果
        一个产生派生属性的算术平均值的 Collector

      • averagingDouble

        public static <T> Collector<T,?,Double> averagingDouble​(ToDoubleFunction<? super T> mapper)
        返回一个产生应用于输入元素的双值函数的算术平均值的Collector 。 如果没有元素，结果为0。

        返回的平均值可以根据记录值的顺序而变化，这是由于除了不同数值的值之外的累积舍入误差。 按绝对数量增加排列的数值往往会产生更准确的结果。 如果任何记录值是NaN或总和在任何点NaN则平均值将为NaN 。

        Implementation Note:
        double格式可以表示-2 53至2 53范围内的所有连续整数。 如果管道超过2 53个值，平均计算中的除数将在23 53度饱和，导致额外的数值误差。
        参数类型
        T - 输入元素的类型
        参数
        mapper - 提取要平均的属性的函数
        结果
        一个产生派生属性的算术平均值的 Collector

      • reducing

        public static <T> Collector<T,?,T> reducing​(T identity,
                                            BinaryOperator<T> op)
        返回一个 Collector ，它使用提供的身份在指定的 BinaryOperator下执行其输入元素的减少。
        API Note:
        reducing()收集器在多级别缩减时使用最为有用， groupingBy或partitioningBy下游。 要简单地减少流，请使用Stream.reduce(Object, BinaryOperator) }。
        参数类型
        T - 减少输入和输出的元素类型
        参数
        identity - 减少的身份值（也是没有输入元素时返回的值）
        op - 一个 BinaryOperator<T>用于减少输入元素
        结果
        一个实现缩减操作的 Collector
        另请参见：
        reducing(BinaryOperator) ， reducing(Object, Function, BinaryOperator)

      • reducing

        public static <T> Collector<T,?,Optional<T>> reducing​(BinaryOperator<T> op)
        返回一个Collector ，它在指定的BinaryOperator下执行其输入元素的减少。 结果被描述为Optional<T> 。
        API Note:
        reducing()收集器在多级减少中使用时最有用， groupingBy或partitioningBy下游。 要简单地减少流，请改用Stream.reduce(BinaryOperator) 。

        例如，给出Person的流，计算每个城市的最高Person ：

           Comparator<Person> byHeight = Comparator.comparing(Person::getHeight); Map<City, Optional<Person>> tallestByCity = people.stream().collect( groupingBy(Person::getCity, reducing(BinaryOperator.maxBy(byHeight))));
        参数类型
        T - 减少的输入和输出的元素类型
        参数
        op - a BinaryOperator<T>用于减少输入元素
        结果
        一个实现缩小操作的 Collector
        另请参见：
        reducing(Object, BinaryOperator) ， reducing(Object, Function, BinaryOperator)

      • reducing

        public static <T,U> Collector<T,?,U> reducing​(U identity,
                                              Function<? super T,? extends U> mapper,
                                              BinaryOperator<U> op)
        返回一个Collector ，它在指定的映射函数和BinaryOperator下执行其输入元素的减少。 这是reducing(Object, BinaryOperator)的泛化，允许在还原之前对元素进行转换。
        API Note:
        reducing()收集器在多级别减少中使用时最有用， groupingBy或partitioningBy下游。 要在流上执行简单的map-reduce，请改用Stream.map(Function)和Stream.reduce(Object, BinaryOperator) 。

        例如，给出Person ，计算每个城市居民的最长姓氏：

           Comparator<String> byLength = Comparator.comparing(String::length); Map<City, String> longestLastNameByCity = people.stream().collect( groupingBy(Person::getCity, reducing("", Person::getLastName, BinaryOperator.maxBy(byLength))));
        参数类型
        T - 输入元素的类型
        U - 映射值的类型
        参数
        identity - 减少的标识值（也是没有输入元素时返回的值）
        mapper - 应用于每个输入值的映射函数
        op - a BinaryOperator<U>用于减少映射值
        结果
        一个 Collector实现了map-reduce操作
        另请参见：
        reducing(Object, BinaryOperator) ， reducing(BinaryOperator)

      • groupingBy

        public static <T,K> Collector<T,?,Map<K,List<T>>> groupingBy​(Function<? super T,? extends K> classifier)
        返回一个Collector对类型为T输入元素执行“按组”操作，根据分类功能对元素进行分组，并将结果返回到Map 。

        分类功能将元素映射到一些关键类型K 。 收集器产生一个Map<K, List<T>>其关键字是将分类函数应用于输入元素而得到的值，其相应值为List其中包含映射到分类函数下的关联键的输入元素。

        对于返回的Map或List对象的类型，可变性，可序列性或线程安全性，不保证。

        实现要求：
        这产生的结果类似于：
           groupingBy(classifier, toList());
        Implementation Note:
        返回的Collector不是并发的。 对于并行流管道， combiner功能通过将一个地图的密钥合并到另一个地图来进行操作，这可能是一项昂贵的操作。 如果保存元素出现在生成的Map收集器中的顺序不是必需的，那么使用groupingByConcurrent(Function)可能会提供更好的并行性能。
        参数类型
        T - 输入元素的类型
        K - 键的类型
        参数
        classifier - 将输入元素映射到键的分类器函数
        结果
        一个实现group-by操作的 Collector
        另请参见：
        groupingBy(Function, Collector) ，
groupingBy(Function, Supplier, Collector) ，
groupingByConcurrent(Function)

      • groupingBy

        public static <T,K,A,D> Collector<T,?,Map<K,D>> groupingBy​(Function<? super T,? extends K> classifier,
                                                           Collector<? super T,A,D> downstream)
        返回Collector “由基团”上的类型的输入元件操作实现级联T ，根据分类功能分组元素，然后使用下游的指定与给定键相关联的值进行还原操作Collector 。

        分类功能将元素映射到某些键类型K 。 下游收集器上类型的元素进行操作T并产生类型的结果D 。 所得的收集器产生一个Map<K, D> 。

        Map返回的类型，可变性，可串行性或线程安全性没有保证。

        例如，要计算每个城市的一组姓氏：

           Map<City, Set<String>> namesByCity = people.stream().collect( groupingBy(Person::getCity, mapping(Person::getLastName, toSet())));
        Implementation Note:
        返回的Collector不是并发的。 对于并行流管道， combiner功能通过将密钥从一个映射合并到另一个映射来操作，这可能是一个昂贵的操作。 如果不需要保存向下游收集器提供元素的顺序，则使用groupingByConcurrent(Function, Collector)可能会提供更好的并行性能。
        参数类型
        T - 输入元素的类型
        K - 键的类型
        A - 下游收集器的中间累积类型
        D - 下游减少的结果类型
        参数
        classifier - 将输入元素映射到键的分类器函数
        downstream - a Collector实现下游减少
        结果
        一个实现级联组合操作的 Collector
        另请参见：
        groupingBy(Function) ， groupingBy(Function, Supplier, Collector) ， groupingByConcurrent(Function, Collector)

      • groupingBy

        public static <T,K,D,A,M extends Map<K,D>> Collector<T,?,M> groupingBy​(Function<? super T,? extends K> classifier,
                                                                       Supplier<M> mapFactory,
                                                                       Collector<? super T,A,D> downstream)
        返回Collector对T类型的输入元素进行级联“分组”操作，根据分类功能对元素进行分组，然后使用指定的下游Collector对与给定键相关联的值执行缩减操作。 由收藏Map生产的Map使用提供的工厂功能创建。

        分类功能将元素映射到某些键类型K 。 下游收集器上类型的元素进行操作T并产生类型的结果D 。 所得收集器产生一个Map<K, D> 。

        例如，计算城市名称排序的每个城市的人姓名集：

           Map<City, Set<String>> namesByCity = people.stream().collect( groupingBy(Person::getCity, TreeMap::new, mapping(Person::getLastName, toSet())));
        Implementation Note:
        返回的Collector不是并发的。 对于并行流管道， combiner功能通过将一个地图的密钥合并到另一个地图中进行操作，这可能是一项昂贵的操作。 如果不需要保存元素提交给下游收集器的顺序，则使用groupingByConcurrent(Function, Supplier, Collector)可能会提供更好的并行性能。
        参数类型
        T - 输入元素的类型
        K - 键的类型
        A - 下游收集器的中间累积类型
        D - 下游减少的结果类型
        M - 所得的类型 Map
        参数
        classifier - 将输入元素映射到键的分类器函数
        downstream - a Collector实现下游缩减
        mapFactory - 供应商提供一个新的空白 Map ，其中将插入结果
        结果
        一个实现级联组合操作的 Collector
        另请参见：
        groupingBy(Function, Collector) ， groupingBy(Function) ， groupingByConcurrent(Function, Supplier, Collector)

      • groupingByConcurrent

        public static <T,K> Collector<T,?,ConcurrentMap<K,List<T>>> groupingByConcurrent​(Function<? super T,? extends K> classifier)
        返回并行执行Collector对T类型的输入元素进行“按组”操作，根据分类功能对元素进行分组。

        这是一个concurrent和unordered收藏家。

        分类功能将元素映射到一些关键类型K 。 收集器产生一个ConcurrentMap<K, List<T>>其键是将分类函数应用于输入元素而得到的值，其相应值为List其中包含映射到分类函数下的关联键的输入元素。

        对于返回的ConcurrentMap或List对象的类型，可变性或可序列化，或返回的List对象的线程安全性，不List 。

        实现要求：
        这产生的结果类似于：
           groupingByConcurrent(classifier, toList());
        参数类型
        T - 输入元素的类型
        K - 键的类型
        参数
        classifier - 将输入元素映射到键的分类器函数
        结果
        一个并发的，无序的 Collector实现分组操作
        另请参见：
        groupingBy(Function) ， groupingByConcurrent(Function, Collector) ， groupingByConcurrent(Function, Supplier, Collector)

      • groupingByConcurrent

        public static <T,K,A,D> Collector<T,?,ConcurrentMap<K,D>> groupingByConcurrent​(Function<? super T,? extends K> classifier,
                                                                               Collector<? super T,A,D> downstream)
        返回并行的Collector ，对T类型的输入元素执行级联“分组”操作，根据分类功能对元素进行分组，然后使用指定的下游Collector对与给定键相关联的值执行缩减操作。

        这是一个concurrent和unordered收藏家。

        分类功能将元素映射到一些关键类型K 。 下游收集器上类型的元素进行操作T并产生类型的结果D 。 所得的收集器产生一个ConcurrentMap<K, D> 。

        ConcurrentMap返回的ConcurrentMap的类型，可变性或可序列性没有保证。

        例如，计算城市名称排序的每个城市的人姓名集：

           ConcurrentMap<City, Set<String>> namesByCity = people.stream().collect( groupingByConcurrent(Person::getCity, mapping(Person::getLastName, toSet())));
        参数类型
        T - 输入元素的类型
        K - 键的类型
        A - 下游收集器的中间累积类型
        D - 下游减少的结果类型
        参数
        classifier - 将输入元素映射到键的分类器函数
        downstream - a Collector实施下游削减
        结果
        一个并发的，无序的 Collector实现级联组合操作
        另请参见：
        groupingBy(Function, Collector) ， groupingByConcurrent(Function) ， groupingByConcurrent(Function, Supplier, Collector)

      • groupingByConcurrent

        public static <T,K,A,D,M extends ConcurrentMap<K,D>> Collector<T,?,M> groupingByConcurrent​(Function<? super T,? extends K> classifier,
                                                                                Supplier<M> mapFactory,
                                                                                Collector<? super T,A,D> downstream)
        返回并行的Collector ，对T类型的输入元素进行级联“分组”操作，根据分类功能对元素进行分组，然后使用指定的下游Collector对与给定键相关联的值执行缩减操作。 由收藏ConcurrentMap生产的ConcurrentMap是由提供的工厂功能创建的。

        这是一个concurrent和unordered收藏家。

        分类功能将元素映射到一些关键类型K 。 下游收集器上类型的元素进行操作T并产生类型的结果D 。 得到的收集器产生一个ConcurrentMap<K, D> 。

        例如，计算城市名称排序的每个城市的人姓名集：

           ConcurrentMap<City, Set<String>> namesByCity = people.stream().collect( groupingByConcurrent(Person::getCity, ConcurrentSkipListMap::new, mapping(Person::getLastName, toSet())));
        参数类型
        T - 输入元素的类型
        K - 键的类型
        A - 下游收集器的中间累积类型
        D - 下游减少的结果类型
        M - 所得的类型 ConcurrentMap
        参数
        classifier - 将输入元素映射到键的分类器函数
        downstream - 实现下游减少的 Collector
        mapFactory - 供应商提供一个新的空的 ConcurrentMap ，其中将插入结果
        结果
        一个并发的无序 Collector实现了级联组合操作
        另请参见：
        groupingByConcurrent(Function) ， groupingByConcurrent(Function, Collector) ， groupingBy(Function, Supplier, Collector)

      • partitioningBy

        public static <T> Collector<T,?,Map<Boolean,List<T>>> partitioningBy​(Predicate<? super T> predicate)
        返回Collector由划分根据所述输入元件Predicate ，并且将它们组织到一个Map<Boolean, List<T>> 。 返回的Map总是包含false和true键的映射。 Map或List返回的类型，可变性，可序列化或线程安全性不保证。
        API Note:
        如果一个分区没有元素，其结果Map中的值将为空List。
        参数类型
        T - 输入元素的类型
        参数
        predicate - 用于对输入元素进行分类的谓词
        结果
        一个 Collector实现分区操作
        另请参见：
        partitioningBy(Predicate, Collector)

      • partitioningBy

        public static <T,D,A> Collector<T,?,Map<Boolean,D>> partitioningBy​(Predicate<? super T> predicate,
                                                                   Collector<? super T,A,D> downstream)
        返回Collector由划分根据所述输入元件Predicate ，减少了在根据另一每个分区中的值Collector ，并且将它们组织到一个Map<Boolean, D>其值是下游减少的结果。

        返回的Map总是包含false和true键的映射。 Map返回的Map的类型，可变性，可串行性或线程安全性没有保证。

        API Note:
        如果分区没有元素，则通过调用下游收集器的供应商函数，然后应用整理器函数，获取结果图中的值。
        参数类型
        T - 输入元素的类型
        A - 下游收集器的中间堆积型
        D - 下游减少的结果类型
        参数
        predicate - 用于对输入元素进行分类的谓词
        downstream - a Collector实现下游减少
        结果
        一个 Collector实现级联分区操作
        另请参见：
        partitioningBy(Predicate)

      • toMap

        public static <T,K,U> Collector<T,?,Map<K,U>> toMap​(Function<? super T,? extends K> keyMapper,
                                                    Function<? super T,? extends U> valueMapper)
        返回一个Collector ，它将元素累加到Map其键和值是将提供的映射函数应用于输入元素的结果。

        如果映射的密钥包含重复（根据Object.equals(Object) ），则在执行集合操作时抛出IllegalStateException 。 如果映射的键可能有重复，请改用toMap(Function, Function, BinaryOperator) 。

        Map返回的Map的类型，可变性，可串行性或线程安全性没有保证。

        API Note:
        键或值作为输入元素是常见的。 在这种情况下，实用方法Function.identity()可能是有帮助的。 例如，以下产生一个Map映射学生到他们的平均成绩点：
           Map<Student, Double> studentToGPA = students.stream().collect( toMap(Function.identity(), student -> computeGPA(student)));
        以下产生一个Map映射学生的唯一标识符：
           Map<String, Student> studentIdToStudent = students.stream().collect( toMap(Student::getId, Function.identity()));
        Implementation Note:
        返回的Collector不是并发的。 对于并行流管道， combiner功能通过将一个地图的密钥合并到另一个地图来进行操作，这可能是一项昂贵的操作。 如果不需要将结果插入到Map中，使用toConcurrentMap(Function, Function)可能会提供更好的并行性能。
        参数类型
        T - 输入元素的类型
        K - 键映射功能的输出类型
        U - 值映射函数的输出类型
        参数
        keyMapper - 产生密钥的映射函数
        valueMapper - 产生值的映射函数
        结果
        一个 Collector ，其将元素收集到 Map其键和值是将映射函数应用于输入元素的结果
        另请参见：
        toMap(Function, Function, BinaryOperator) ，
toMap(Function, Function, BinaryOperator, Supplier) ，
toConcurrentMap(Function, Function)

      • toMap

        public static <T,K,U> Collector<T,?,Map<K,U>> toMap​(Function<? super T,? extends K> keyMapper,
                                                    Function<? super T,? extends U> valueMapper,
                                                    BinaryOperator<U> mergeFunction)
        返回一个Collector ，它将元素累加到Map其键和值是将提供的映射函数应用于输入元素的结果。

        如果映射的密钥包含重复（根据Object.equals(Object) ），则值映射函数应用于每个相等的元素，并使用提供的合并函数合并结果。

        Map返回的Map的类型，可变性，可序列化或线程安全性，没有保证。

        API Note:
        有多种方法来处理映射到同一个密钥的多个元素之间的冲突。 其他形式的toMap只是使用无条件抛出的合并函数，但您可以轻松编写更灵活的合并策略。 例如，如果您有一个Person的流，并且您想生成一个“电话簿”映射名称来寻址，但是可能有两个人具有相同的名称，则可以如下处理这些冲突，并产生一个Map映射名称到一个并置的地址列表：
           Map<String, String> phoneBook = people.stream().collect( toMap(Person::getName, Person::getAddress, (s, a) -> s + ", " + a));
        Implementation Note:
        返回的Collector不是并发的。 对于并行流管道， combiner功能通过将一个地图的密钥合并到另一个地图来进行操作，这可能是一项昂贵的操作。 如果不需要将结果合并到Map中，使用toConcurrentMap(Function, Function, BinaryOperator)可能会提供更好的并行性能。
        参数类型
        T - 输入元素的类型
        K - 键映射功能的输出类型
        U - 值映射函数的输出类型
        参数
        keyMapper - 产生密钥的映射函数
        valueMapper - 产生值的映射函数
        mergeFunction - 一个合并函数，用于解决与相同键相关联的值之间的冲突，提供给 Map.merge(Object, Object, BiFunction)
        结果
        一个 Collector ，它将元素收集到一个 Map其关键是将键映射函数应用于输入元素，其值是将值映射函数应用于所有等于键的输入元素的结果，并使用合并功能
        另请参见：
        toMap(Function, Function) ，
toMap(Function, Function, BinaryOperator, Supplier) ，
toConcurrentMap(Function, Function, BinaryOperator)

      • toMap

        public static <T,K,U,M extends Map<K,U>> Collector<T,?,M> toMap​(Function<? super T,? extends K> keyMapper,
                                                                Function<? super T,? extends U> valueMapper,
                                                                BinaryOperator<U> mergeFunction,
                                                                Supplier<M> mapFactory)
        返回一个Collector ，它将元素累加到Map其键和值是将提供的映射函数应用于输入元素的结果。

        如果映射的密钥包含重复（根据Object.equals(Object) ），值映射函数将应用于每个相等的元素，并使用提供的合并函数合并结果。 Map由提供的供应商功能创建。

        Implementation Note:
        返回的Collector不是并发的。 对于并行流管道， combiner功能通过将密钥从一个映射合并到另一个映射来操作，这可能是一个昂贵的操作。 如果不需要将结果合并到Map中，使用toConcurrentMap(Function, Function, BinaryOperator, Supplier)可能会提供更好的并行性能。
        参数类型
        T - 输入元素的类型
        K - 键映射功能的输出类型
        U - 值映射函数的输出类型
        M - 所得的 Map的类型
        参数
        keyMapper - 产生密钥的映射函数
        valueMapper - 产生值的映射函数
        mergeFunction - 一个合并函数，用于解决与相同键相关联的值之间的冲突，提供给 Map.merge(Object, Object, BiFunction)
        mapFactory - 供应商提供一个新的空的 Map ，其中将插入结果
        结果
        一个 Collector ，它将元素收集到一个 Map其关键是将键映射函数应用于输入元素，其值是将值映射函数应用于所有等于键的输入元素的结果，并使用合并功能
        另请参见：
        toMap(Function, Function) ，
toMap(Function, Function, BinaryOperator) ，
toConcurrentMap(Function, Function, BinaryOperator, Supplier)

      • toConcurrentMap

        public static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> toConcurrentMap​(Function<? super T,? extends K> keyMapper,
                                                                        Function<? super T,? extends U> valueMapper)
        返回一个并发的Collector ，它将元素累加到一个ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。

        如果映射的密钥包含重复（根据Object.equals(Object) ），则在执行集合操作时抛出IllegalStateException 。 如果映射的密钥可能有重复，请改用toConcurrentMap(Function, Function, BinaryOperator) 。

        ConcurrentMap返回的类型，可变性或可序列化没有保证。

        API Note:
        键或值作为输入元素是常见的。 在这种情况下，实用方法Function.identity()可能是有帮助的。 例如，以下产生一个ConcurrentMap映射学生到他们的平均成绩点：
           ConcurrentMap<Student, Double> studentToGPA = students.stream().collect( toConcurrentMap(Function.identity(), student -> computeGPA(student)));
        以下产生一个ConcurrentMap映射学生的唯一标识符：
           ConcurrentMap<String, Student> studentIdToStudent = students.stream().collect( toConcurrentMap(Student::getId, Function.identity()));

        这是一个concurrent和unordered收藏家。

        参数类型
        T - 输入元素的类型
        K - 键映射功能的输出类型
        U - 值映射函数的输出类型
        参数
        keyMapper - 产生密钥的映射函数
        valueMapper - 产生值的映射函数
        结果
        一个并发的，无序的 Collector ，其将元素收集到 ConcurrentMap其密钥是将键映射函数应用于输入元素的结果，并且其值是将值映射函数应用于输入元素的结果
        另请参见：
        toMap(Function, Function) ，
toConcurrentMap(Function, Function, BinaryOperator) ，
toConcurrentMap(Function, Function, BinaryOperator, Supplier)

      • toConcurrentMap

        public static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> toConcurrentMap​(Function<? super T,? extends K> keyMapper,
                                                                        Function<? super T,? extends U> valueMapper,
                                                                        BinaryOperator<U> mergeFunction)
        返回一个并发的Collector ，它将元素累加到ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。

        如果映射的密钥包含重复（根据Object.equals(Object) ），则值映射函数应用于每个相等的元素，并使用提供的合并函数合并结果。

        ConcurrentMap返回的ConcurrentMap的类型，可变性或可序列性没有保证。

        API Note:
        有多种方法来处理映射到同一个密钥的多个元素之间的冲突。 其他形式的toConcurrentMap只是使用无条件抛出的合并函数，但您可以轻松编写更灵活的合并策略。 例如，如果您有一个Person的流，并且您想要生成一个“电话簿”映射名称来寻址，但是可能有两个人具有相同的名称，则可以如下处理这些冲突，并产生一个ConcurrentMap映射名称到一个并置的地址列表：
           ConcurrentMap<String, String> phoneBook = people.stream().collect( toConcurrentMap(Person::getName, Person::getAddress, (s, a) -> s + ", " + a));

        这是一个concurrent和unordered收藏家。

        参数类型
        T - 输入元素的类型
        K - 键映射功能的输出类型
        U - 值映射函数的输出类型
        参数
        keyMapper - 产生密钥的映射函数
        valueMapper - 产生值的映射函数
        mergeFunction - 一个合并函数，用于解决与相同键相关联的值之间的冲突，提供给 Map.merge(Object, Object, BiFunction)
        结果
        一个并发的，无序的 Collector ，它将元素收集到 ConcurrentMap其关键是将键映射函数应用于输入元素，其值是将值映射函数应用于等于键的所有输入元素并结合它们的结果使用合并功能
        另请参见：
        toConcurrentMap(Function, Function) ，
toConcurrentMap(Function, Function, BinaryOperator, Supplier) ，
toMap(Function, Function, BinaryOperator)

      • toConcurrentMap

        public static <T,K,U,M extends ConcurrentMap<K,U>> Collector<T,?,M> toConcurrentMap​(Function<? super T,? extends K> keyMapper,
                                                                                Function<? super T,? extends U> valueMapper,
                                                                                BinaryOperator<U> mergeFunction,
                                                                                Supplier<M> mapFactory)
        返回一个并发的Collector ，它将元素累加到ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。

        如果映射的密钥包含重复（根据Object.equals(Object) ），则值映射函数应用于每个相等元素，并使用提供的合并函数合并结果。 ConcurrentMap由提供的供应商功能创建。

        这是一个concurrent和unordered收藏家。

        参数类型
        T - 输入元素的类型
        K - 键映射功能的输出类型
        U - 值映射函数的输出类型
        M - 所得的 ConcurrentMap的类型
        参数
        keyMapper - 产生密钥的映射函数
        valueMapper - 产生值的映射函数
        mergeFunction - 一个合并函数，用于解决与相同键相关联的值之间的冲突，提供给 Map.merge(Object, Object, BiFunction)
        mapFactory - 供应商提供一个新的空 ConcurrentMap ，其中将插入结果
        结果
        一个并发的，无序的 Collector ，它将元素收集到 ConcurrentMap其关键是将键映射函数应用于输入元素，其值是将值映射函数应用于等于键的所有输入元素并结合它们的结果使用合并功能
        另请参见：
        toConcurrentMap(Function, Function) ，
toConcurrentMap(Function, Function, BinaryOperator) ，
toMap(Function, Function, BinaryOperator, Supplier)

      • summarizingInt

        public static <T> Collector<T,?,IntSummaryStatistics> summarizingInt​(ToIntFunction<? super T> mapper)
        返回一个 Collector ， int生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
        参数类型
        T - 输入元素的类型
        参数
        mapper - 应用于每个元素的映射函数
        结果
        a Collector实施汇总统计减少
        另请参见：
        summarizingDouble(ToDoubleFunction) ， summarizingLong(ToLongFunction)

      • summarizingLong

        public static <T> Collector<T,?,LongSummaryStatistics> summarizingLong​(ToLongFunction<? super T> mapper)
        返回一个 Collector ， long生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
        参数类型
        T - 输入元素的类型
        参数
        mapper - 应用于每个元素的映射函数
        结果
        a Collector实施汇总统计减少
        另请参见：
        summarizingDouble(ToDoubleFunction) ， summarizingInt(ToIntFunction)

      • summarizingDouble

        public static <T> Collector<T,?,DoubleSummaryStatistics> summarizingDouble​(ToDoubleFunction<? super T> mapper)
        返回一个 Collector ， double生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
        参数类型
        T - 输入元素的类型
        参数
        mapper - 应用于每个元素的映射函数
        结果
        a Collector执行汇总统计减少
        另请参见：
        summarizingLong(ToLongFunction) ， summarizingInt(ToIntFunction)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface DoubleStream

  • All Superinterfaces:
    AutoCloseable ， BaseStream<Double,DoubleStream>

    public interface DoubleStream
extends BaseStream<Double,DoubleStream>
    支持顺序和并行聚合操作的原始双值元素序列。 这是double原始专业Stream 。

    以下示例说明了使用Stream和DoubleStream的汇总操作，计算红色小部件的权重之和：

       double sum = widgets.stream() .filter(w -> w.getColor() == RED) .mapToDouble(w -> w.getWeight()) .sum();
    请参阅Stream的类文档和java.util.stream的软件包文档， 以了解流，流操作，流管线和并行性的其他规范。
    从以下版本开始：
    1.8
    另请参见：
    Stream ， java.util.stream

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  DoubleStream.Builder
      一个可变的构建器，用于 DoubleStream 。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean allMatch​(DoublePredicate predicate)
      返回此流的所有元素是否与提供的谓词匹配。
      boolean anyMatch​(DoublePredicate predicate)
      返回此流的任何元素是否与提供的谓词匹配。
      OptionalDouble average​()
      返回描述此流的元素的算术平均值的 OptionalDouble ，如果此流为空，则返回一个空的可选项。
      Stream<Double> boxed​()
      返回一个 Stream组成的这个流的元素，装箱到 Double 。
      static DoubleStream.Builder builder​()
      返回一个 DoubleStream生成器。
      <R> R collect​(Supplier<R> supplier, ObjDoubleConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      static DoubleStream concat​(DoubleStream a, DoubleStream b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      long count​()
      返回此流中的元素数。
      DoubleStream distinct​()
      返回由该流的不同元素组成的流。
      default DoubleStream dropWhile​(DoublePredicate predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      static DoubleStream empty​()
      返回一个空序列 DoubleStream 。
      DoubleStream filter​(DoublePredicate predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      OptionalDouble findAny​()
      返回OptionalDouble描述流的一些元件，或一个空OptionalDouble如果流是空的。
      OptionalDouble findFirst​()
      返回OptionalDouble描述此流的第一个元素，或空OptionalDouble如果流是空的。
      DoubleStream flatMap​(DoubleFunction<? extends DoubleStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      void forEach​(DoubleConsumer action)
      对此流的每个元素执行操作。
      void forEachOrdered​(DoubleConsumer action)
      对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。
      static DoubleStream generate​(DoubleSupplier s)
      返回无限顺序无序流，其中每个元素由提供的 DoubleSupplier生成。
      static DoubleStream iterate​(double seed, DoublePredicate hasNext, DoubleUnaryOperator next)
      返回通过将给定的 next函数迭代应用于初始元素 DoubleStream产生的顺序 DoubleStream ，其条件是满足给定的 hasNext谓词。
      static DoubleStream iterate​(double seed, DoubleUnaryOperator f)
      返回有序无限连续 DoubleStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      PrimitiveIterator.OfDouble iterator​()
      返回此流的元素的迭代器。
      DoubleStream limit​(long maxSize)
      返回由此流的元素组成的流，截短长度不能超过 maxSize 。
      DoubleStream map​(DoubleUnaryOperator mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
      IntStream mapToInt​(DoubleToIntFunction mapper)
      返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
      LongStream mapToLong​(DoubleToLongFunction mapper)
      返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
      <U> Stream<U> mapToObj​(DoubleFunction<? extends U> mapper)
      返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
      OptionalDouble max​()
      返回描述此流的最大元素的 OptionalDouble ，如果此流为空，则返回空的OptionalDouble。
      OptionalDouble min​()
      返回描述此流的最小元素的 OptionalDouble ，如果此流为空，则返回空的OptionalDouble。
      boolean noneMatch​(DoublePredicate predicate)
      返回此流的元素是否与提供的谓词匹配。
      static DoubleStream of​(double t)
      返回包含单个元素的序列 DoubleStream 。
      static DoubleStream of​(double... values)
      返回其元素是指定值的顺序排序流。
      DoubleStream parallel​()
      返回平行的等效流。
      DoubleStream peek​(DoubleConsumer action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
      double reduce​(double identity, DoubleBinaryOperator op)
      使用提供的身份值和 associative累积功能对此流的元素执行 reduction ，并返回减小的值。
      OptionalDouble reduce​(DoubleBinaryOperator op)
      使用 associative累积功能对此流的元素执行 reduction ，并返回描述减小值（如果有）的 OptionalDouble 。
      DoubleStream sequential​()
      返回顺序的等效流。
      DoubleStream skip​(long n)
      在丢弃流的第一个 n元素后，返回由该流的其余元素组成的流。
      DoubleStream sorted​()
      以排序顺序返回由该流的元素组成的流。
      Spliterator.OfDouble spliterator​()
      返回此流的元素的拼接器。
      double sum​()
      返回此流中元素的总和。
      DoubleSummaryStatistics summaryStatistics​()
      返回描述关于该流的元素的各种摘要数据的 DoubleSummaryStatistics 。
      default DoubleStream takeWhile​(DoublePredicate predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
      double[] toArray​()
      返回一个包含此流的元素的数组。

      • Methods inherited from interface java.util.stream.BaseStream

        close, isParallel, onClose, unordered

    • 方法详细信息

      • filter

        DoubleStream filter​(DoublePredicate predicate)
        返回由与此给定谓词匹配的此流的元素组成的流。

        这是一个intermediate operation 。

        参数
        predicate -一个 non-interfering ， stateless谓词应用到每个元素，以确定是否它应包含
        结果
        新的流

      • map

        DoubleStream map​(DoubleUnaryOperator mapper)
        返回由给定函数应用于此流的元素的结果组成的流。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToObj

        <U> Stream<U> mapToObj​(DoubleFunction<? extends U> mapper)
        返回一个对象值Stream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数类型
        U - 新流的元素类型
        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToInt

        IntStream mapToInt​(DoubleToIntFunction mapper)
        返回一个IntStream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToLong

        LongStream mapToLong​(DoubleToLongFunction mapper)
        返回一个LongStream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • flatMap

        DoubleStream flatMap​(DoubleFunction<? extends DoubleStream> mapper)
        返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。 每个映射的流在其内容被放入此流之后是closed 。 （如果映射的流为null ，则使用空的流。）

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless功能应用到其产生的每个元素 DoubleStream新值的
        结果
        新的流
        另请参见：
        Stream.flatMap(Function)

      • distinct

        DoubleStream distinct​()
        返回由该流的不同元素组成的流。 根据Double.compare(double, double)对元素进行比较。

        这是一个stateful intermediate operation 。

        结果
        结果流

      • sorted

        DoubleStream sorted​()
        以排序顺序返回由该流的元素组成的流。 根据Double.compare(double, double)对元素进行比较。

        这是一个stateful intermediate operation 。

        结果
        结果流

      • peek

        DoubleStream peek​(DoubleConsumer action)
        返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。

        这是一个intermediate operation 。

        对于并行流管线，可以在上游操作的任何时间和任何线程中调用该元素可用的动作。 如果操作修改共享状态，则负责提供所需的同步。

        API Note:
        该方法主要用于支持调试，您希望在流程中流过某个特定点时查看元素：
           DoubleStream.of(1, 2, 3, 4) .filter(e -> e > 2) .peek(e -> System.out.println("Filtered value: " + e)) .map(e -> e * e) .peek(e -> System.out.println("Mapped value: " + e)) .sum();

        在情况下，流实现能够优化掉生产一些或所有的元件（如与像短路操作findFirst ，或在所描述的示例count() ），动作将不被调用这些元素。

        参数
        action - 一个 non-interfering要从流中消耗的元素执行的操作
        结果
        新的流

      • limit

        DoubleStream limit​(long maxSize)
        返回由此流的元素组成的流，截短长度不能超过maxSize 。

        这是一个short-circuiting stateful intermediate operation 。

        API Note:
        虽然limit()通常是顺序流管线上的便宜操作，但是在有序并行流水线上可能是相当昂贵的，特别是对于maxSize大值，因为limit(n)被限制为不仅返回任何n个元素，而且在遇到顺序中的前n个元素。 如果您的情况允许，则使用无序流源（如generate(DoubleSupplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线中limit()显着加速。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与limit()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        参数
        maxSize - 流应该限制的元素数量
        结果
        新的流
        异常
        IllegalArgumentException - 如果 maxSize为负数

      • skip

        DoubleStream skip​(long n)
        在丢弃流的第一个n元素后，返回由该流的剩余元素组成的流。 如果此流包含少于n元素，则将返回一个空流。

        这是一个stateful intermediate operation 。

        API Note:
        虽然skip()通常是顺序流管线上的廉价操作，但是在有序的并行流水线上可能相当昂贵，特别是对于n大值，因为skip(n)被限制为不仅跳过任何n个元素，而且会遇到顺序的前n个元素。 如果您的情况允许，则使用无序流源（例如generate(DoubleSupplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线显着加速skip() 。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与skip()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        参数
        n - 要跳过的主要元素的数量
        结果
        新的流
        异常
        IllegalArgumentException - 如果 n为负数

      • takeWhile

        default DoubleStream takeWhile​(DoublePredicate predicate)
        如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。 否则返回，如果该流是无序的，则由从与该给定谓词匹配的该流中取得的元素的子集组成的流。

        如果该流被排序，则最长的前缀是与给定谓词匹配的该流的连续的元素序列。 序列的第一个元素是此流的第一个元素，并且紧跟该序列的最后一个元素的元素与给定谓词不匹配。

        如果该流是无序的，并且该流的一些（但不是全部）元素与给定的谓词匹配，则该操作的行为是非确定性的; 可以自由地采取匹配元素的任何子集（包括空集）。

        独立于该流是否被排序或无序，如果此流的所有元素与给定谓词匹配，则此操作将采用所有元素（结果与输入相同），或者如果流的元素与给定谓词匹配，则没有元素被采取（结果是一个空的流）。

        这是一个short-circuiting stateful intermediate operation 。

        API Note:
        虽然takeWhile()通常是顺序流管线上的廉价操作，但是在有序并行流水线上可能是相当昂贵的，因为操作被限制为不仅返回任何有效前缀，而且返回遇到顺序中元素的最长前缀。 如果您的情况允许，则使用无序流源（如generate(DoubleSupplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线显着加速takeWhile() 。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与takeWhile()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        实现要求：
        默认实现获得此流的spliterator ，包装该分割器，以便在遍历时支持此操作的语义，并返回与包装的拼接器相关联的新流。 返回的流保留该流的执行特性（即按BaseStream.isParallel()并行或顺序执行），但是包装的分割器可能选择不支持拆分。 当返回的流关闭时，将调用返回的流和此流的关闭处理程序。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于元素，以确定元素的最长前缀。
        结果
        新的流
        从以下版本开始：
        9

      • dropWhile

        default DoubleStream dropWhile​(DoublePredicate predicate)
        如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。 否则返回，如果该流是无序的，则在丢弃与给定谓词匹配的元素的子集之后，返回由该流的剩余元素组成的流。

        如果该流被排序，则最长的前缀是与给定谓词匹配的该流的连续的元素序列。 序列的第一个元素是此流的第一个元素，并且紧跟该序列的最后一个元素的元素与给定谓词不匹配。

        如果该流是无序的，并且该流的一些（但不是全部）元素与给定的谓词匹配，则该操作的行为是非确定性的; 可以放置匹配元素的任何子集（包括空集合）。

        独立于该流是否被排序或无序，如果此流的所有元素与给定谓词匹配，则此操作将删除所有元素（结果为空流），或者如果流中的元素与给定谓词匹配，则不会删除元素（结果与输入相同）。

        这是一个stateful intermediate operation 。

        API Note:
        虽然dropWhile()通常是顺序流管线上的廉价操作，但是在有序的并行流水线上可能相当昂贵，因为操作被限制为不仅返回任何有效的前缀，而且返回遇到顺序中的元素的最长前缀。 如果您的情况允许，则使用无序流源（例如generate(DoubleSupplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线显着加速dropWhile() 。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与dropWhile()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        实现要求：
        默认实现获取此流的spliterator ，包装该分割器，以便在遍历时支持此操作的语义，并返回与包装拼接器相关联的新流。 返回的流保留此流的执行特性（即按照BaseStream.isParallel()并行或顺序执行），但是包装的拼接器可能选择不支持拆分。 当返回的流关闭时，将调用返回的流和此流的关闭处理程序。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于元素，以确定元素的最长前缀。
        结果
        新的流
        从以下版本开始：
        9

      • forEach

        void forEach​(DoubleConsumer action)
        对此流的每个元素执行操作。

        这是一个terminal operation 。

        对于并行流管道，此操作不能保证遵守流的遇到顺序，因为这样做会牺牲并行性的好处。 对于任何给定的元素，动作可以在图书馆选择的任何时间和任何线索中执行。 如果操作访问共享状态，则负责提供所需的同步。

        参数
        action - 一个 non-interfering对元素执行的操作

      • forEachOrdered

        void forEachOrdered​(DoubleConsumer action)
        对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。

        这是一个terminal operation 。

        参数
        action - 一个 non-interfering对元素执行的操作
        另请参见：
        forEach(DoubleConsumer)

      • toArray

        double[] toArray​()
        返回一个包含此流的元素的数组。

        这是一个terminal operation 。

        结果
        一个包含此流的元素的数组

      • reduce

        double reduce​(double identity,
              DoubleBinaryOperator op)
        使用提供的身份值和associative累积函数对此流的元素执行reduction ，并返回减小的值。 这相当于：
           double result = identity; for (double element : this stream) result = accumulator.applyAsDouble(result, element) return result;
        但不限于顺序执行。

        identity值必须是累加器函数的标识。 这意味着，对于所有x ， accumulator.apply(identity, x)等于x 。 accumulator功能必须是associative功能。

        这是一个terminal operation 。

        API Note:
        总和，最小，最大和平均都是减少的特殊情况。 一个数字流可以表示为：
           double sum = numbers.reduce(0, (a, b) -> a+b);
        或更紧凑：
           double sum = numbers.reduce(0, Double::sum);

        尽管与简单地将循环中的总体变量相比，这可能看起来更为迂回的方式进行，但减少操作更平稳地并行化，而不需要额外的同步，并大大降低了数据竞争的风险。

        参数
        identity - 累积函数的身份值
        op -一个 associative ， non-interfering ， stateless功能组合两个值
        结果
        减少的结果
        另请参见：
        sum() ，
min() ，
max() ，
average()

      • reduce

        OptionalDouble reduce​(DoubleBinaryOperator op)
        使用associative累积函数对此流的元素执行reduction ，并返回描述减小值（如果有）的OptionalDouble 。 这相当于：
           boolean foundAny = false; double result = null; for (double element : this stream) { if (!foundAny) { foundAny = true; result = element; } else result = accumulator.applyAsDouble(result, element); } return foundAny ? OptionalDouble.of(result) : OptionalDouble.empty();
        但不限于顺序执行。

        accumulator功能必须是associative功能。

        这是一个terminal operation 。

        参数
        op -一个 associative ， non-interfering ， stateless功能组合两个值
        结果
        减少的结果
        另请参见：
        reduce(double, DoubleBinaryOperator)

      • collect

        <R> R collect​(Supplier<R> supplier,
              ObjDoubleConsumer<R> accumulator,
              BiConsumer<R,R> combiner)
        对此流的元素执行mutable reduction操作。 可变减少是减少值是可变结果容器的缩减值，例如ArrayList ，并且通过更新结果的状态而不是通过替换结果来合并元素。 这产生的结果相当于：
           R result = supplier.get(); for (double element : this stream) accumulator.accept(result, element); return result;

        像reduce(double, DoubleBinaryOperator)一样， collect操作可以并行化，无需额外的同步。

        这是一个terminal operation 。

        参数类型
        R - 可变结果容器的类型
        参数
        supplier - 创建一个新的可变结果容器的函数。 对于并行执行，可以多次调用此函数，并且每次都必须返回一个新的值。
        accumulator -一个 associative ， non-interfering ， stateless功能必须的元件折叠成的结果容器。
        combiner -一个associative ， non-interfering ， stateless函数接受两个部分结果的容器和将它们合并，这必须与累加器功能兼容。 组合器功能必须将第二个结果容器中的元素折叠到第一个结果容器中。
        结果
        减少的结果
        另请参见：
        Stream.collect(Supplier, BiConsumer, BiConsumer)

      • sum

        double sum​()
        返回此流中元素的总和。 总结是一个reduction的特例 。 如果浮点求和是准确的，这个方法将相当于：
           return reduce(0, Double::sum);
        然而，由于浮点求和不是精确的，所以上述代码不一定等于通过这种方法进行的求和计算。

        浮点和的值是输入值以及加法运算顺序的函数。 该方法的加法运算顺序有意未被定义为允许实现灵活性来提高计算结果的速度和准确性。 特别地，可以使用补偿求和或其他技术来实现该方法，以减少与double值的简单求和相比数值和中的误差界限。 由于操作的不明确的顺序和使用不同的求和方案的可能性，该方法的输出可能会在相同的输入元素上变化。

        各种条件可导致计算非有限和。 即使求和的所有元素都是有限的，也可能发生这种情况。 如果任何元素是非有限的，则总和将是非限定的：

        • 如果任何元素是NaN，则最后的总和将为NaN。
        • 如果元素包含一个或多个无穷大，则总和将为无限或NaN。
          • 如果这些元素含有相反的符号，那么这个总和就是NaN。
          • 如果元素含有一个符号的无穷大，中间和溢出到相反符号的无穷大，则总和可以是NaN。
        有限值的中间和可能溢出到相反的无穷大中; 如果发生这种情况，即使元素都是有限的，最终总和也将是NaN。 如果所有元素都为零，则不能保证零的符号在最后的和中被保留。

        这是一个terminal operation 。

        API Note:
        通过增加绝对数量排序的元素往往会产生更准确的结果。
        结果
        这个流中元素的总和

      • min

        OptionalDouble min​()
        返回描述此流的最小元素的OptionalDouble ，如果此流为空，则返回空的OptionalDouble。 如果任何流元素是NaN，最小元素将为Double.NaN 。 与数值比较运算符不同，该方法认为负零严格小于正零。 这是一个reduction的特殊情况，相当于：
           return reduce(Double::min);

        这是一个terminal operation 。

        结果
        一个包含此流的最小元素的 OptionalDouble ，如果流为空，则为空可选

      • max

        OptionalDouble max​()
        返回描述此流的最大元素的OptionalDouble ，如果此流为空，则返回空的OptionalDouble。 如果任何流元素是NaN，最大元素将为Double.NaN 。 与数值比较运算符不同，该方法认为负零严格小于正零。 这是一个reduction的特殊情况，相当于：
           return reduce(Double::max);

        这是一个terminal operation 。

        结果
        一个包含此流的最大元素的 OptionalDouble ，如果流为空，则为空可选

      • count

        long count​()
        返回此流中的元素数。 这是一个reduction的特殊情况，相当于：
           return mapToLong(e -> 1L).sum();

        这是一个terminal operation 。

        API Note:
        如果能够直接从流源计算计数，则实现可以选择不执行流管线（顺序地或并行地）。 在这种情况下，不会遍历源元素，并且不会评估中间操作。 除了无害的情况（如调试），强烈不鼓励具有副作用的行为参数可能会受到影响。 例如，考虑以下流：
           DoubleStream s = DoubleStream.of(1, 2, 3, 4); long count = s.peek(System.out::println).count();
        流源所覆盖的元素的数量是已知的，并且中间操作（ peek ）不从流注入或移除元素（如flatMap或filter操作的情况）。 因此，计数为4，不需要执行管道，作为副作用，打印出元素。
        结果
        这个流中元素的数量

      • average

        OptionalDouble average​()
        返回描述此流的元素的算术平均值的OptionalDouble ，如果此流为空，则返回一个空的可选项。

        计算的平均值可以数值变化，并具有计算总和的特殊情况行为; 详见sum() 。

        平均值是reduction的特例 。

        这是一个terminal operation 。

        API Note:
        通过增加绝对数量排序的元素往往会产生更准确的结果。
        结果
        一个包含此流的平均元素的 OptionalDouble ，如果流为空，则为空可选

      • summaryStatistics

        DoubleSummaryStatistics summaryStatistics​()
        返回描述有关此流的元素的各种摘要数据的DoubleSummaryStatistics 。 这是一个reduction的特例 。

        这是一个terminal operation 。

        结果
        一个 DoubleSummaryStatistics描述了关于该流的元素的各种摘要数据

      • anyMatch

        boolean anyMatch​(DoublePredicate predicate)
        返回此流的任何元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回false ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于某些x P（x））的谓词的 存在量化 。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的任何元素匹配提供的谓词，否则为 false

      • allMatch

        boolean allMatch​(DoublePredicate predicate)
        返回此流的所有元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回true ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于所有x P（x））的谓词的通用量化 。 如果流是空的，量化据说是空洞地满意 ，始终是true （不管的P（X））。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的所有元素匹配所提供的谓词或流为空，否则为 false

      • noneMatch

        boolean noneMatch​(DoublePredicate predicate)
        返回此流的元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回true ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于所有x〜P（x））的否定谓词的通用量化 。 如果流是空的，那么量化被认为是空虚的，并且始终是true ，而不论P（x）如何。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流中的任何元素与提供的谓词匹配，或者流为空，否则为 false

      • findFirst

        OptionalDouble findFirst​()
        返回OptionalDouble描述此流的第一个元素，或空OptionalDouble如果流是空的。 如果流没有遇到顺序，则可能会返回任何元素。

        这是一个short-circuiting terminal operation 。

        结果
        一个 OptionalDouble描述此流的第一个元素，或空 OptionalDouble如果流是空

      • findAny

        OptionalDouble findAny​()
        返回OptionalDouble描述流的一些元件，或一个空OptionalDouble如果流是空的。

        这是一个short-circuiting terminal operation 。

        这个操作的行为显然是不确定的; 可以自由选择流中的任何元素。 这是为了允许并行操作中的最大性能; 成本是同一来源上的多次调用可能不会返回相同的结果。 （如果需要稳定的结果，请改用findFirst() ）

        结果
        一个 OptionalDouble描述该流的一些元件，或一个空 OptionalDouble如果流是空
        另请参见：
        findFirst()

      • boxed

        Stream<Double> boxed​()
        返回一个由这个流的元素组成的Stream ，装箱到Double 。

        这是一个intermediate operation 。

        结果
        一个 Stream一致的这个流的元素，每个盒装到一个 Double

      • sequential

        DoubleStream sequential​()
        说明从接口BaseStream复制
        返回顺序的等效流。 可能返回自己，因为流已经是顺序的，或者因为底层流状态被修改为顺序的。

        这是一个intermediate operation 。

        Specified by:
        sequential在接口 BaseStream<Double,DoubleStream>
        结果
        顺序流

      • parallel

        DoubleStream parallel​()
        说明从界面BaseStream复制
        返回平行的等效流。 可能会返回自己，因为流已经是并行的，或者因为底层流状态被修改为并行。

        这是一个intermediate operation 。

        Specified by:
        parallel在接口 BaseStream<Double,DoubleStream>
        结果
        并行流

      • iterator

        PrimitiveIterator.OfDouble iterator​()
        描述从接口BaseStream复制
        返回此流的元素的迭代器。

        这是一个terminal operation 。

        Specified by:
        iterator在接口 BaseStream<Double,DoubleStream>
        结果
        该流的元素迭代器

      • spliterator

        Spliterator.OfDouble spliterator​()
        描述从接口BaseStream复制
        返回此流的元素的拼接器。

        这是一个terminal operation 。

        返回的分配器应该报告从流管道导出的特征集（即从流源分割器和中间操作导出的特性）。 实施可能会报告这些特征的子集。 例如，为一些或所有可能的流管线计算整个集合可能太贵了。

        Specified by:
        spliterator在接口 BaseStream<Double,DoubleStream>
        结果
        该流的元素拼接器

      • builder

        static DoubleStream.Builder builder​()
        返回一个 DoubleStream的构建器。
        结果
        流构建器

      • empty

        static DoubleStream empty​()
        返回一个空的序列 DoubleStream 。
        结果
        一个空的顺序流

      • of

        static DoubleStream of​(double t)
        返回包含单个元素的序列 DoubleStream 。
        参数
        t - 单一元素
        结果
        单例顺序流

      • of

        static DoubleStream of​(double... values)
        返回其元素是指定值的顺序排序流。
        参数
        values - 新流的元素
        结果
        新的流

      • iterate

        static DoubleStream iterate​(double seed,
                            DoubleUnaryOperator f)
        返回有序无限连续DoubleStream由函数的迭代应用产生f到初始元素seed ，产生Stream由seed ， f(seed) ， f(f(seed))等

        第一元件（位置0在） DoubleStream将是提供seed 。 对于n > 0 ，位置n的元素将是将函数f应用于位置n - 1的元素的n - 1 。

        施加的作用f为一个元件happens-before施加的作用f用于随后的元件。 对于任何给定的元素，动作可以在库选择的任何线程中执行。

        参数
        seed - 初始元素
        f - 要应用于前一个元素以生成新元素的函数
        结果
        一个新的顺序 DoubleStream

      • iterate

        static DoubleStream iterate​(double seed,
                            DoublePredicate hasNext,
                            DoubleUnaryOperator next)
        返回通过将给定的next函数迭代应用于初始元素DoubleStream产生的顺序DoubleStream ，其条件是满足给定的hasNext谓词。 一旦hasNext谓词返回false，流即终止。

        DoubleStream.iterate应该产生与相应的for-loop相同的元素序列：

           for (double index=seed; hasNext.test(index); index = next.applyAsDouble(index)) { ... }

        如果hasNext谓词不持有种子值，则结果序列可能为空。 否则第一个元素将是提供的seed值，下一个元素（如果存在）将是将next函数应用于seed值的结果，等等，直到hasNext谓词指示流应该终止。

        将hasNext谓词应用于元素happens-before的操作将next函数应用于该元素。 在为后续元素应用hasNext谓词的动作之前 ， 会发生一个元素应用next函数的动作。 对于任何给定的元素，可以在库选择的任何线程中执行一个动作。

        参数
        seed - 初始元素
        hasNext - 应用于元素以确定流何时终止的谓词。
        next - 要应用于前一个元素以生成新元素的函数
        结果
        一个新的顺序 DoubleStream
        从以下版本开始：
        9

      • generate

        static DoubleStream generate​(DoubleSupplier s)
        返回无限顺序无序流，其中每个元素由提供的DoubleSupplier生成。 这适合于产生恒定流，随机元素流等
        参数
        s - 用于生成元素的 DoubleSupplier
        结果
        一个新的无限顺序无序 DoubleStream

      • concat

        static DoubleStream concat​(DoubleStream a,
                           DoubleStream b)
        创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。 如果两个输入流都被排序，则生成的流被排序，并且如果任何一个输入流是并行的，则并行。 当结果流关闭时，调用两个输入流的关闭处理程序。
        Implementation Note:
        在重复连接构建流时要小心。 访问深层级流的元素可能导致深层调用链，甚至可能导致StackOverflowError 。
        参数
        a - 第一个流
        b - 第二个流
        结果
        两个输入流的并置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleStream.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface DoubleStream.Builder

  • All Superinterfaces:
    DoubleConsumer
    Enclosing interface:
    DoubleStream

    public static interface DoubleStream.Builder
extends DoubleConsumer
    一个DoubleStream可变构建器。

    流构建器具有生命周期，其从构建阶段开始，在该阶段期间可以添加元素，然后转换到内置阶段，之后可能不添加元素。 内建阶段从调用build()方法开始，它创建一个有序流，其元素是添加到流构建器的元素，按照它们的添加顺序。

    从以下版本开始：
    1.8
    另请参见：
    DoubleStream.builder()

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void accept​(double t)
      向要构建的流添加元素。
      default DoubleStream.Builder add​(double t)
      向要构建的流添加元素。
      DoubleStream build​()
      构建流，将此构建器转换为内置状态。

      • Methods inherited from interface java.util.function.DoubleConsumer

        andThen

    • 方法详细信息

      • accept

        void accept​(double t)
        向要构建的流添加元素。
        Specified by:
        accept在接口 DoubleConsumer
        参数
        t - 输入参数
        异常
        IllegalStateException - 如果构建器已经转换到内置状态

      • add

        default DoubleStream.Builder add​(double t)
        向要构建的流添加元素。
        实现要求：
        默认实现的行为如下：
           accept(t) return this;
        参数
        t - 要添加的元素
        结果
        this建设者
        异常
        IllegalStateException - 如果构建器已经转换到内置状态

      • build

        DoubleStream build​()
        构建流，将此构建器转换为内置状态。 如果进一步尝试在构建器进入构建状态后对构建器进行操作，则抛出一个IllegalStateException 。
        结果
        内建流
        异常
        IllegalStateException - 如果构建器已经转换到内置状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface IntStream

  • All Superinterfaces:
    AutoCloseable ， BaseStream<Integer,IntStream>

    public interface IntStream
extends BaseStream<Integer,IntStream>
    支持顺序和并行聚合操作的原始int值元素序列。 这是int原始专业Stream 。

    以下示例说明了使用Stream和IntStream的汇总操作，计算红色小部件的权重之和：

       int sum = widgets.stream() .filter(w -> w.getColor() == RED) .mapToInt(w -> w.getWeight()) .sum();
    请参阅类文档Stream和用于包文档java.util.stream用于流的附加说明书中，流操作，流管道，和平行度。
    从以下版本开始：
    1.8
    另请参见：
    Stream ， java.util.stream

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  IntStream.Builder
      一个可变的构建器，用于 IntStream 。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean allMatch​(IntPredicate predicate)
      返回此流的所有元素是否与提供的谓词匹配。
      boolean anyMatch​(IntPredicate predicate)
      返回此流的任何元素是否与提供的谓词匹配。
      DoubleStream asDoubleStream​()
      返回由该流的元素组成的 DoubleStream ，转换为 double 。
      LongStream asLongStream​()
      返回由该流的元素组成的 LongStream ，转换为 long 。
      OptionalDouble average​()
      返回描述此流的元素的算术平均值的 OptionalDouble ，如果此流为空，则返回一个空的可选项。
      Stream<Integer> boxed​()
      返回一个由这个流的元素组成的 Stream ，每个包含一个 Integer 。
      static IntStream.Builder builder​()
      返回一个 IntStream生成器。
      <R> R collect​(Supplier<R> supplier, ObjIntConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      static IntStream concat​(IntStream a, IntStream b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      long count​()
      返回此流中的元素数。
      IntStream distinct​()
      返回由该流的不同元素组成的流。
      default IntStream dropWhile​(IntPredicate predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      static IntStream empty​()
      返回空序列 IntStream 。
      IntStream filter​(IntPredicate predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      OptionalInt findAny​()
      返回OptionalInt描述流的一些元件，或一个空OptionalInt如果流是空的。
      OptionalInt findFirst​()
      返回OptionalInt描述此流的第一个元素，或空OptionalInt如果流是空的。
      IntStream flatMap​(IntFunction<? extends IntStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      void forEach​(IntConsumer action)
      对此流的每个元素执行操作。
      void forEachOrdered​(IntConsumer action)
      对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。
      static IntStream generate​(IntSupplier s)
      返回无限顺序无序流，其中每个元素由提供的 IntSupplier生成。
      static IntStream iterate​(int seed, IntPredicate hasNext, IntUnaryOperator next)
      返回通过将给定的 next函数迭代应用于初始元素 IntStream产生的顺序排列的 IntStream ，其条件是满足给定的 hasNext谓词。
      static IntStream iterate​(int seed, IntUnaryOperator f)
      返回有序无限连续 IntStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      PrimitiveIterator.OfInt iterator​()
      返回此流的元素的迭代器。
      IntStream limit​(long maxSize)
      返回由此流的元素组成的流，截短长度不能超过 maxSize 。
      IntStream map​(IntUnaryOperator mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
      DoubleStream mapToDouble​(IntToDoubleFunction mapper)
      返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
      LongStream mapToLong​(IntToLongFunction mapper)
      返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
      <U> Stream<U> mapToObj​(IntFunction<? extends U> mapper)
      返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
      OptionalInt max​()
      返回描述此流的最大元素的 OptionalInt ，如果此流为空，则返回一个空的可选项。
      OptionalInt min​()
      返回描述此流的最小元素的 OptionalInt ，如果此流为空，则返回一个空的可选项。
      boolean noneMatch​(IntPredicate predicate)
      返回此流的元素是否与提供的谓词匹配。
      static IntStream of​(int t)
      返回包含单个元素的序列 IntStream 。
      static IntStream of​(int... values)
      返回其元素是指定值的顺序排序流。
      IntStream parallel​()
      返回平行的等效流。
      IntStream peek​(IntConsumer action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
      static IntStream range​(int startInclusive, int endExclusive)
      返回有序的顺序 IntStream从 startInclusive （含）至 endExclusive由增量步骤（独家） 1 。
      static IntStream rangeClosed​(int startInclusive, int endInclusive)
      返回 startInclusive （含）的序列 IntStream至 endInclusive （含），增量为 1 。
      int reduce​(int identity, IntBinaryOperator op)
      使用提供的身份值和 associative累积功能对此流的元素执行 reduction ，并返回减小的值。
      OptionalInt reduce​(IntBinaryOperator op)
      使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值（如果有）的 OptionalInt 。
      IntStream sequential​()
      返回顺序的等效流。
      IntStream skip​(long n)
      在丢弃流的第一个 n元素后，返回由该流的剩余元素组成的流。
      IntStream sorted​()
      以排序顺序返回由该流的元素组成的流。
      Spliterator.OfInt spliterator​()
      返回此流的元素的拼接器。
      int sum​()
      返回此流中元素的总和。
      IntSummaryStatistics summaryStatistics​()
      返回描述有关此流的元素的各种摘要数据的 IntSummaryStatistics 。
      default IntStream takeWhile​(IntPredicate predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
      int[] toArray​()
      返回一个包含此流的元素的数组。

      • Methods inherited from interface java.util.stream.BaseStream

        close, isParallel, onClose, unordered

    • 方法详细信息

      • filter

        IntStream filter​(IntPredicate predicate)
        返回由与此给定谓词匹配的此流的元素组成的流。

        这是一个intermediate operation 。

        参数
        predicate -一个 non-interfering ， stateless谓词应用到每个元素，以确定是否它应包含
        结果
        新的流

      • map

        IntStream map​(IntUnaryOperator mapper)
        返回由给定函数应用于此流的元素的结果组成的流。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToObj

        <U> Stream<U> mapToObj​(IntFunction<? extends U> mapper)
        返回一个对象值Stream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数类型
        U - 新流的元素类型
        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToLong

        LongStream mapToLong​(IntToLongFunction mapper)
        返回一个LongStream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToDouble

        DoubleStream mapToDouble​(IntToDoubleFunction mapper)
        返回一个DoubleStream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • flatMap

        IntStream flatMap​(IntFunction<? extends IntStream> mapper)
        返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。 每个映射的流在其内容被放入此流之后是closed 。 （如果映射的流为null ，则使用空的流。）

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless功能应用到其中产生的每个元素 IntStream新值的
        结果
        新的流
        另请参见：
        Stream.flatMap(Function)

      • distinct

        IntStream distinct​()
        返回由该流的不同元素组成的流。

        这是一个stateful intermediate operation 。

        结果
        新的流

      • sorted

        IntStream sorted​()
        以排序顺序返回由该流的元素组成的流。

        这是一个stateful intermediate operation 。

        结果
        新的流

      • peek

        IntStream peek​(IntConsumer action)
        返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。

        这是一个intermediate operation 。

        对于并行流管线，可以在上游操作的任何时间和任何线程中调用该元素可用的动作。 如果操作修改共享状态，则负责提供所需的同步。

        API Note:
        该方法主要用于支持调试，您希望在流程中流过某个特定点时查看元素：
           IntStream.of(1, 2, 3, 4) .filter(e -> e > 2) .peek(e -> System.out.println("Filtered value: " + e)) .map(e -> e * e) .peek(e -> System.out.println("Mapped value: " + e)) .sum();

        在情况下，流实现能够优化掉生产一些或所有的元件（如与像短路操作findFirst ，或在所描述的示例count() ），动作将不被调用这些元素。

        参数
        action - 一个 non-interfering对要从流中消耗的元素执行的操作
        结果
        新的流

      • limit

        IntStream limit​(long maxSize)
        返回由此流的元素组成的流，截短长度不能超过maxSize 。

        这是一个short-circuiting stateful intermediate operation 。

        API Note:
        虽然limit()通常是顺序流管线上的廉价操作，但是在有序的并行流水线上可能相当昂贵，特别是对于maxSize大值，因为limit(n)被限制为不仅返回任何n个元素，而且在遇到顺序中的前n个元素。 使用无序流源（例如generate(IntSupplier) ）或去除所述排序约束与BaseStream.unordered()可能导致显著加速比limit()在并行管线，如果情况许可的语义。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与limit()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        参数
        maxSize - 流应该限制的元素数量
        结果
        新的流
        异常
        IllegalArgumentException - 如果 maxSize为负数

      • skip

        IntStream skip​(long n)
        在丢弃流的第一个n元素后，返回由该流的其余元素组成的流。 如果此流包含少于n元素，则将返回一个空流。

        这是一个stateful intermediate operation 。

        API Note:
        虽然skip()通常是顺序流管线上的廉价操作，但是在有序的并行流水线上可能是相当昂贵的，特别是对于n大值，因为skip(n)被限制为不仅跳过任何n个元素，而且在遇到顺序中的前n个元素。 如果您的情况允许，则使用无序流源（例如generate(IntSupplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线显着加速skip() 。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与skip()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        参数
        n - 要跳过的主要元素的数量
        结果
        新的流
        异常
        IllegalArgumentException - 如果 n为负数

      • takeWhile

        default IntStream takeWhile​(IntPredicate predicate)
        如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。 否则返回，如果该流是无序的，则由从与该给定谓词匹配的该流中取得的元素的子集组成的流。

        如果该流被排序，则最长的前缀是与给定谓词匹配的该流的连续的元素序列。 序列的第一个元素是此流的第一个元素，并且紧跟该序列的最后一个元素的元素与给定谓词不匹配。

        如果该流是无序的，并且该流的一些（但不是全部）元素与给定的谓词匹配，则该操作的行为是非确定性的; 可以自由地采取匹配元素的任何子集（包括空集）。

        独立于该流是否被排序或无序，如果此流的所有元素与给定谓词匹配，则此操作将采用所有元素（结果与输入相同），或者如果流的元素与给定谓词匹配，则没有元素被采取（结果是一个空的流）。

        这是一个short-circuiting stateful intermediate operation 。

        API Note:
        虽然takeWhile()通常是顺序流管线上的廉价操作，但是在有序并行流水线上可能是相当昂贵的，因为操作被限制为不仅返回任何有效的前缀，而且返回遇到顺序中元素的最长前缀。 如果您的情况允许，则使用无序流源（如generate(IntSupplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线中takeWhile()显着加速。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与takeWhile()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        实现要求：
        默认实现获取此流的spliterator ，包装该分割器，以便在遍历时支持此操作的语义，并返回与包装拼接器相关联的新流。 返回的流保留该流的执行特性（即根据BaseStream.isParallel()并行或顺序执行），但是封装的分割器可能选择不支持拆分。 当返回的流关闭时，将调用返回的流和此流的关闭处理程序。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于元素，以确定元素的最长前缀。
        结果
        新的流
        从以下版本开始：
        9

      • dropWhile

        default IntStream dropWhile​(IntPredicate predicate)
        如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。 否则返回，如果该流是无序的，则在丢弃与给定谓词匹配的元素的子集之后，返回由该流的剩余元素组成的流。

        如果该流被排序，则最长的前缀是与给定谓词匹配的该流的连续的元素序列。 序列的第一个元素是此流的第一个元素，并且紧跟该序列的最后一个元素的元素与给定谓词不匹配。

        如果该流是无序的，并且该流的一些（但不是全部）元素与给定的谓词匹配，则该操作的行为是非确定性的; 可以放置匹配元素的任何子集（包括空集合）。

        独立于该流是否被排序或无序，如果此流的所有元素与给定谓词匹配，则此操作将删除所有元素（结果为空流），或者如果流中的元素与给定谓词匹配，则不会删除元素（结果与输入相同）。

        这是一个stateful intermediate operation 。

        API Note:
        虽然dropWhile()通常是顺序流管线上的便宜操作，但是在有序并行流水线上可能会相当昂贵，因为操作被限制为不仅返回任何有效的前缀，而且返回遇到顺序中元素的最长前缀。 如果您的情况允许，则使用无序流源（如generate(IntSupplier) ）或者使用BaseStream.unordered()删除排序约束可能会导致并行流水线显着加速dropWhile() 。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与dropWhile()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        实现要求：
        默认实现获取此流的spliterator ，包装该分割器，以便在遍历时支持此操作的语义，并返回与包装剪辑器相关联的新流。 返回的流保留此流的执行特性（即根据BaseStream.isParallel()并行或顺序执行），但是包装的拼接器可能选择不支持拆分。 当返回的流关闭时，将调用返回的流和此流的关闭处理程序。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于元素，以确定元素的最长前缀。
        结果
        新的流
        从以下版本开始：
        9

      • forEach

        void forEach​(IntConsumer action)
        对此流的每个元素执行操作。

        这是一个terminal operation 。

        对于并行流管道，此操作不能保证遵守流的遇到顺序，因为这样做会牺牲并行性的好处。 对于任何给定的元素，动作可以在图书馆选择的任何时间和任何线索中执行。 如果操作访问共享状态，则负责提供所需的同步。

        参数
        action - 一个 non-interfering对元素执行的操作

      • forEachOrdered

        void forEachOrdered​(IntConsumer action)
        对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。

        这是一个terminal operation 。

        参数
        action - 一个 non-interfering对元素执行的操作
        另请参见：
        forEach(IntConsumer)

      • toArray

        int[] toArray​()
        返回一个包含此流的元素的数组。

        这是一个terminal operation 。

        结果
        一个包含此流的元素的数组

      • reduce

        int reduce​(int identity,
           IntBinaryOperator op)
        对该流的元素执行reduction ，使用提供的身份值和associative累积函数，并返回减小的值。 这相当于：
           int result = identity; for (int element : this stream) result = accumulator.applyAsInt(result, element) return result;
        但不限于顺序执行。

        identity值必须是累加器函数的标识。 这意味着，对于所有x ， accumulator.apply(identity, x)等于x 。 accumulator函数必须是一个associative函数。

        这是一个terminal operation 。

        API Note:
        总和，最小，最大和平均都是减少的特殊情况。 一个数字流可以表示为：
           int sum = integers.reduce(0, (a, b) -> a+b);
        或更紧凑：
           int sum = integers.reduce(0, Integer::sum);

        尽管与简单地将循环中的总体变量相比，这可能看起来更为迂回的方式进行，但减少操作更平稳地并行化，而不需要额外的同步，并大大降低了数据竞争的风险。

        参数
        identity - 累积函数的身份值
        op -一个 associative ， non-interfering ， stateless功能组合两个值
        结果
        减少的结果
        另请参见：
        sum() ，
min() ，
max() ，
average()

      • reduce

        OptionalInt reduce​(IntBinaryOperator op)
        使用associative累积函数对此流的元素执行reduction ，并返回描述减小值（如果有）的OptionalInt 。 这相当于：
           boolean foundAny = false; int result = null; for (int element : this stream) { if (!foundAny) { foundAny = true; result = element; } else result = accumulator.applyAsInt(result, element); } return foundAny ? OptionalInt.of(result) : OptionalInt.empty();
        但不限于顺序执行。

        accumulator函数必须是一个associative函数。

        这是一个terminal operation 。

        参数
        op -一个 associative ， non-interfering ， stateless功能组合两个值
        结果
        减少的结果
        另请参见：
        reduce(int, IntBinaryOperator)

      • collect

        <R> R collect​(Supplier<R> supplier,
              ObjIntConsumer<R> accumulator,
              BiConsumer<R,R> combiner)
        对此流的元素执行mutable reduction操作。 可变的缩减是其中减小的值是可变结果容器的缩减值，例如ArrayList ，并且通过更新结果的状态而不是通过替换结果来合并元素。 这产生的结果相当于：
           R result = supplier.get(); for (int element : this stream) accumulator.accept(result, element); return result;

        像reduce(int, IntBinaryOperator)一样， collect操作可以并行化，无需额外的同步。

        这是一个terminal operation 。

        参数类型
        R - 可变结果容器的类型
        参数
        supplier - 创建一个新的可变结果容器的函数。 对于并行执行，可以多次调用此函数，并且每次都必须返回一个新的值。
        accumulator -一个 associative ， non-interfering ， stateless功能必须的元件折叠成的结果容器。
        combiner -一个associative ， non-interfering ， stateless函数接受两个部分结果的容器和将它们合并，这必须与累加器功能兼容。 组合器功能必须将第二个结果容器中的元素折叠到第一个结果容器中。
        结果
        减少的结果
        另请参见：
        Stream.collect(Supplier, BiConsumer, BiConsumer)

      • sum

        int sum​()
        返回此流中元素的总和。 这是一个reduction的特殊情况，相当于：
           return reduce(0, Integer::sum);

        这是一个terminal operation 。

        结果
        这个流中元素的总和

      • min

        OptionalInt min​()
        返回描述此流的最小元素的OptionalInt ，如果此流为空，则返回一个空的可选项。 这是一个reduction的特例 ，相当于：
           return reduce(Integer::min);

        这是一个terminal operation 。

        结果
        一个 OptionalInt含有该料流的一个空的最小元件，或 OptionalInt如果流是空

      • max

        OptionalInt max​()
        返回描述此流的最大元素的OptionalInt ，如果此流为空，则返回一个空的可选项。 这是一个reduction的特殊情况，相当于：
           return reduce(Integer::max);

        这是一个terminal operation 。

        结果
        一个 OptionalInt含有该料流的最大元素，或空 OptionalInt如果流是空

      • count

        long count​()
        返回此流中的元素数。 这是一个reduction的特殊情况，相当于：
           return mapToLong(e -> 1L).sum();

        这是一个terminal operation 。

        API Note:
        如果能够直接从流源计算计数，则实现可以选择不执行流管线（顺序地或并行地）。 在这种情况下，不会遍历源元素，并且不会评估中间操作。 除了无害的情况（如调试），强烈不鼓励具有副作用的行为参数可能会受到影响。 例如，考虑以下流：
           IntStream s = IntStream.of(1, 2, 3, 4); long count = s.peek(System.out::println).count();
        流源所涵盖的元素的数量是已知的，并且中间操作（ peek ）不会从流中注入或移除元素（如flatMap或filter操作的情况）。 因此，计数为4，不需要执行管道，作为副作用，打印出元素。
        结果
        这个流中元素的数量

      • average

        OptionalDouble average​()
        返回描述此流的元素的算术平均值的OptionalDouble ，如果此流为空，则返回空可选。 这是一个reduction的特例 。

        这是一个terminal operation 。

        结果
        一个包含此流的平均元素的 OptionalDouble ，如果流为空，则为空可选

      • summaryStatistics

        IntSummaryStatistics summaryStatistics​()
        返回一个描述关于此流的元素的各种摘要数据的IntSummaryStatistics 。 这是一个reduction的特例 。

        这是一个terminal operation 。

        结果
        一个描述关于该流的元素的各种摘要数据的 IntSummaryStatistics

      • anyMatch

        boolean anyMatch​(IntPredicate predicate)
        返回此流的任何元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回false ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于某些x P（x））的谓词的 存在量化 。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的任何元素匹配提供的谓词，否则为 false

      • allMatch

        boolean allMatch​(IntPredicate predicate)
        返回此流的所有元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回true ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于所有x P（x））的谓词的通用量化 。 如果流是空的，量化据说是空洞地满意 ，始终是true （不管的P（X））。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的所有元素匹配提供的谓词或流是空的，否则为 false

      • noneMatch

        boolean noneMatch​(IntPredicate predicate)
        返回此流的元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回true ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于所有x〜P（x））的否定谓词的通用量化 。 如果流是空的，那么量化被认为是空的，并且始终是true ，而不考虑P（x）。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的任何元素与提供的谓词匹配，或者流为空，否则为 false

      • findFirst

        OptionalInt findFirst​()
        返回OptionalInt描述此流的第一个元素，或空OptionalInt如果流是空的。 如果流没有遇到顺序，则可能会返回任何元素。

        这是一个short-circuiting terminal operation 。

        结果
        一个 OptionalInt描述此流的第一个元素，或空 OptionalInt如果流是空

      • findAny

        OptionalInt findAny​()
        返回OptionalInt描述流的一些元件，或一个空OptionalInt如果流是空的。

        这是一个short-circuiting terminal operation 。

        这个操作的行为显然是不确定的; 可以自由选择流中的任何元素。 这是为了允许并行操作中的最大性能; 成本是同一来源上的多次调用可能不会返回相同的结果。 （如果需要稳定的结果，请改用findFirst() ）

        结果
        一个 OptionalInt描述该流的一些元件，或一个空 OptionalInt如果流是空
        另请参见：
        findFirst()

      • asLongStream

        LongStream asLongStream​()
        返回一个由该流的元素组成的LongStream ，转换为long 。

        这是一个intermediate operation 。

        结果
        一个由这个流的元素组成的 LongStream ，转换为 long

      • asDoubleStream

        DoubleStream asDoubleStream​()
        返回一个由这个流的元素组成的DoubleStream ，转换为double 。

        这是一个intermediate operation 。

        结果
        一个由这个流的元素组成的 DoubleStream ，转换为 double

      • boxed

        Stream<Integer> boxed​()
        返回一个Stream由该流的元素组成，每个元素包含一个Integer 。

        这是一个intermediate operation 。

        结果
        一个 Stream一致的这个流的元素，每个盒装到一个 Integer

      • sequential

        IntStream sequential​()
        描述从接口BaseStream复制
        返回顺序的等效流。 可能返回自己，因为流已经是顺序的，或者因为底层流状态被修改为顺序的。

        这是一个intermediate operation 。

        Specified by:
        sequential在接口 BaseStream<Integer,IntStream>
        结果
        顺序流

      • parallel

        IntStream parallel​()
        说明从接口BaseStream复制
        返回平行的等效流。 可能会返回自己，因为流已经是并行的，或者因为底层流状态被修改为并行。

        这是一个intermediate operation 。

        Specified by:
        parallel在接口 BaseStream<Integer,IntStream>
        结果
        并行流

      • iterator

        PrimitiveIterator.OfInt iterator​()
        说明从接口BaseStream复制
        返回此流的元素的迭代器。

        这是一个terminal operation 。

        Specified by:
        iterator在接口 BaseStream<Integer,IntStream>
        结果
        该流的元素迭代器

      • spliterator

        Spliterator.OfInt spliterator​()
        描述从接口BaseStream复制
        返回此流的元素的拼接器。

        这是一个terminal operation 。

        返回的分配器应该报告从流管道导出的特征集（即从流源分割器和中间操作导出的特性）。 实施可能会报告这些特征的子集。 例如，为一些或所有可能的流管线计算整个集合可能太贵了。

        Specified by:
        spliterator在接口 BaseStream<Integer,IntStream>
        结果
        该流的元素拼接器

      • builder

        static IntStream.Builder builder​()
        返回一个 IntStream生成器。
        结果
        流构建器

      • empty

        static IntStream empty​()
        返回一个空的序列 IntStream 。
        结果
        一个空的顺序流

      • of

        static IntStream of​(int t)
        返回包含单个元素的序列 IntStream 。
        参数
        t - 单个元素
        结果
        单例顺序流

      • of

        static IntStream of​(int... values)
        返回其元素是指定值的顺序排序流。
        参数
        values - 新流的元素
        结果
        新的流

      • iterate

        static IntStream iterate​(int seed,
                         IntUnaryOperator f)
        返回有序无限连续IntStream由函数的迭代应用产生f到初始元素seed ，产生Stream由seed ， f(seed) ， f(f(seed))等

        第一元件（位置0在） IntStream将是提供seed 。 对于n > 0 ，位置n处的元素将是将函数f应用于位置n - 1的元素的n - 1 。

        施加的作用f为一个元件happens-before施加的作用f用于随后的元件。 对于任何给定的元素，动作可以在库选择的任何线程中执行。

        参数
        seed - 初始元素
        f - 要应用于前一个元素以生成新元素的函数
        结果
        一个新的顺序 IntStream

      • iterate

        static IntStream iterate​(int seed,
                         IntPredicate hasNext,
                         IntUnaryOperator next)
        返回通过将给定的next函数迭代应用到初始元素IntStream产生的顺序IntStream ，其条件是满足给定的hasNext谓词。 一旦hasNext谓词返回false，流即会终止。

        IntStream.iterate应该产生与相应for-loop相同的元素序列：

           for (int index=seed; hasNext.test(index); index = next.applyAsInt(index)) { ... }

        如果hasNext谓词不持有种子值，则结果序列可能为空。 否则第一个元素将是所提供的seed值，下一个元素（如果存在）将是将next函数应用于seed值的结果，等等，直到hasNext谓词指示流应该终止。

        将hasNext谓词应用于元素happens-before的操作将next函数应用于该元素的操作。 在为后续元素应用hasNext谓词的动作之前 ， 会发生一个元素应用next函数的动作。 对于任何给定的元素，可以在库选择的任何线程中执行一个动作。

        参数
        seed - 初始元素
        hasNext - 应用于元素以确定流何时必须终止的谓词。
        next - 要应用于前一个元素以生成新元素的函数
        结果
        一个新的顺序 IntStream
        从以下版本开始：
        9

      • generate

        static IntStream generate​(IntSupplier s)
        返回无限顺序无序流，其中每个元素由提供的IntSupplier生成。 这适合于产生恒定流，随机元素流等
        参数
        s - 生成元素的 IntSupplier
        结果
        一个新的无限顺序无序 IntStream

      • range

        static IntStream range​(int startInclusive,
                       int endExclusive)
        返回有序的顺序 IntStream从 startInclusive （含）至 endExclusive由增量步骤（独家） 1 。
        API Note:

        可以使用for循环顺序地产生递增值的等效序列，如下所示：

           for (int i = startInclusive; i < endExclusive ; i++) { ... }
        参数
        startInclusive - （含）初始值
        endExclusive - 排他上限
        结果
        一个序列 IntStream的范围为 int元素

      • rangeClosed

        static IntStream rangeClosed​(int startInclusive,
                             int endInclusive)
        返回有序顺序 IntStream从 startInclusive （含）至 endInclusive通过的递增步长（含） 1 。
        API Note:

        可以使用for循环顺序地产生递增值的等效序列，如下所示：

           for (int i = startInclusive; i <= endInclusive ; i++) { ... }
        参数
        startInclusive - （含）初始值
        endInclusive - 包含上限
        结果
        一个连续 IntStream的 int元素的范围

      • concat

        static IntStream concat​(IntStream a,
                        IntStream b)
        创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。 如果两个输入流都被排序，则生成的流被排序，并且如果任何一个输入流是并行的，则并行。 当结果流关闭时，调用两个输入流的关闭处理程序。
        Implementation Note:
        在重复连接构建流时要小心。 访问深层级流的元素可能导致深度的调用链，甚至可能导致StackOverflowError 。
        参数
        a - 第一个流
        b - 第二个流
        结果
        两个输入流的并置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntStream.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface IntStream.Builder

  • All Superinterfaces:
    IntConsumer
    Enclosing interface:
    IntStream

    public static interface IntStream.Builder
extends IntConsumer
    一个IntStream可变构建器。

    流构建器具有生命周期，其从构建阶段开始，在该阶段期间可以添加元素，然后转换到内置阶段，之后可能不添加元素。 构建阶段将在调用build()方法时开始，它创建一个有序流，其元素是添加到流构建器的元素，按照它们的添加顺序。

    从以下版本开始：
    1.8
    另请参见：
    IntStream.builder()

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void accept​(int t)
      向要构建的流添加元素。
      default IntStream.Builder add​(int t)
      向要构建的流添加元素。
      IntStream build​()
      构建流，将此构建器转换为内置状态。

      • Methods inherited from interface java.util.function.IntConsumer

        andThen

    • 方法详细信息

      • accept

        void accept​(int t)
        向要构建的流添加元素。
        Specified by:
        accept在接口 IntConsumer
        参数
        t - 输入参数
        异常
        IllegalStateException - 如果构建器已经转换到内置状态

      • add

        default IntStream.Builder add​(int t)
        向要构建的流添加元素。
        实现要求：
        默认实现的行为如下：
           accept(t) return this;
        参数
        t - 要添加的元素
        结果
        this建设者
        异常
        IllegalStateException - 如果构建器已经转换到内置状态

      • build

        IntStream build​()
        构建流，将此构建器转换为内置状态。 如果在构建器进入内置状态后进一步尝试对构建器进行操作，则抛出IllegalStateException 。
        结果
        内建流
        异常
        IllegalStateException - 如果构建器已经转换到内置状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


java.util.stream (Java SE 9 & JDK 9 )

java.util.stream

Interfaces

  • BaseStream
  • Collector
  • DoubleStream
  • DoubleStream.Builder
  • IntStream
  • IntStream.Builder
  • LongStream
  • LongStream.Builder
  • Stream
  • Stream.Builder

Classes

  • Collectors
  • StreamSupport

Enums

  • Collector.Characteristics


java.util.stream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util.stream

支持元素流功能性操作的类，例如集合上的map-reduce转换。 例如：
   int sum = widgets.stream() .filter(b -> b.getColor() == RED) .mapToInt(b -> b.getWeight()) .sum();

这里我们使用widgets ，一个Collection<Widget>作为流的源，然后在流上执行filter-map-reduce以获得红色小部件的权重之和。 （ Summation是一个reduction操作的例子）

这个包中引入的关键抽象是流 。 类Stream ， IntStream ， LongStream ，和DoubleStream超过目的和原始流int ， long和double类型。 流与集合有以下几种不同：

  • 没有存储空间 流不是存储元素的数据结构; 相反，它通过计算操作的流水线传送诸如数据结构，阵列，生成器功能或I / O通道的源的元件。
  • 功能性质。 流上的操作产生结果，但不会修改其来源。 例如，过滤从集合中获取的Stream会生成新的Stream而不需要过滤的元素，而不是从源集合中删除元素。
  • 懒惰寻求。 许多流操作（如过滤，映射或重复删除）可以懒惰地实现，从而暴露优化的机会。 例如，“找到具有三个连续元音的第一个String ”不需要检查所有的输入字符串。 流操作分为中间（ Stream生产）操作和终端（价值或副作用生成）操作。 中级操作总是懒惰。
  • 可能无限。 虽然集合的大小有限，但流不需要。 诸如limit(n)或findFirst()类的短路操作可以允许无限流上的计算在有限的时间内完成。
  • 耗材。 流的元素只能在流的一生中访问一次。 像Iterator一样，必须生成一个新的流来重新访问源的相同元素。
流可以通过多种方式获得。 一些例子包括：
  • 从Collection通过stream()和parallelStream()方法;
  • 从阵列通过Arrays.stream(Object[]) ;
  • 从上流类静态工厂的方法，例如Stream.of(Object[]) ， IntStream.range(int, int)或Stream.iterate(Object, UnaryOperator) ;
  • 文件的行可以从BufferedReader.lines()获取 ;
  • 文件路径流可以从Files中的方法获得;
  • 随机数字流可以从Random.ints()获得;
  • 许多其它的数据流的方法的轴承在JDK，包括BitSet.stream() ， Pattern.splitAsStream(java.lang.CharSequence) ，和JarFile.stream() 。

其他流源可以由第三方库使用these techniques提供 。

Stream operations and pipelines

流操作分为中间和终端操作，并且组合以形成流管线 。 流管线由源（例如Collection ，阵列，发生器功能或I / O通道）组成; 后跟零个或多个中间操作，如Stream.filter或Stream.map ; 以及诸如Stream.forEach或Stream.reduce的终端操作。

中间操作返回一个新的流。 他们总是懒惰 执行中间操作（例如filter()实际上不执行任何过滤，而是创建一个新的流，当遍历时，它包含与给定谓词匹配的初始流的元素。 在管道的终端操作被执行之前，管道源的遍历不会开始。

诸如Stream.forEach或IntStream.sum终端操作可以遍历流以产生结果或副作用。 在执行终端操作之后，流管道被认为被消耗，并且不能再使用; 如果您需要再次遍历相同的数据源，则必须返回到数据源以获取新的流。 在几乎所有情况下，终端操作都是渴望的 ，在返回之前完成对数据源的遍历和处理。 只有终端操作iterator()和spliterator()不是; 在现有操作不足以满足任务的情况下，这些提供为“逃生舱”，以允许任意客户端控制的管道遍历。

处理流懒惰地实现了显着的效率; 在诸如上述的滤波器 - 映射和示例的流水线中，过滤，映射和求和可以融合到数据的单次传递中，具有最小的中间状态。 懒惰也允许避免在没有必要时检查所有数据; 对于诸如“找到长度超过1000个字符的第一个字符串”等操作，只需检查足够的字符串即可找到具有所需特性的字符串，而无需检查源中可用的所有字符串。 （当输入流是无限大而不仅仅是大的时候，这种行为变得更加重要）

中级操作进一步分为无状态和有状态操作。 无状态操作（例如filter和map在处理新元素时，不会从先前看到的元素中保留状态 - 每个元素都可以独立于其他元素的操作进行处理。 有状态操作（例如distinct和sorted ）可以在处理新元素时结合先前看到的元素的状态。

在产生结果之前，状态操作可能需要处理整个输入。 例如，在流已经看到流的所有元素之前，不能产生排序流的任何结果。 因此，在并行计算下，包含有状态中间操作的一些流水线可能需要对数据进行多遍，或者可能需要缓冲重要的数据。 包含无状态中间操作的流水线可以在一次通过中处理，无论是顺序还是并行，具有最少的数据缓冲。

此外，一些操作被认为是短路操作。 如果使用无限输入，则可以产生有限流，因此中间操作是短路的。 如果当无限输入呈现时，终端操作可能会在有限时间内终止。 在流水线中进行短路操作是处理无限流在有限时间内正常终止的必要但不足够的条件。

Parallelism

具有显式for-循环的处理元素本质上是串行的。 流通过将计算重构为聚合操作的管道来促进并行执行，而不是作为每个单独元素的必要操作。 所有流操作可以串行或并行执行。 JDK中的流实现创建串行流，除非显式请求并行。 例如， Collection具有方法Collection.stream()和Collection.parallelStream() ，其分别产生顺序和并行流; 其他流承载方法，如IntStream.range(int, int)产生顺序流，但是可以通过调用它们的BaseStream.parallel()方法来有效地并行化这些流。 要并行执行先前的“小部件权重总和”查询，我们可以这样做：

   int sumOfWeights = widgets.parallelStream() .filter(b -> b.getColor() == RED) .mapToInt(b -> b.getWeight()) .sum();

此示例的串行和并行版本之间的唯一区别是使用“ parallelStream() ”而不是“ stream() ”创建初始流。 根据调用终端操作的流的模式，顺序地或并行地执行流管线。 可以使用BaseStream.isParallel()方法确定流的顺序或并行模式，并可以使用BaseStream.sequential()和BaseStream.parallel()操作修改流的模式。 最新的顺序或并行模式设置适用于整个流管线的执行。

除非确定findAny()确定性的操作（例如findAny() ，否则流顺序执行或并行执行不应更改计算结果。

大多数流操作接受描述用户指定行为的参数，这些行为通常是lambda表达式。 为了保持正确的行为，这些行为参数必须是非干扰的 ，在大多数情况下必须是无状态的 。 这样的参数总是functional interface的实例，例如Function ，并且通常是lambda表达式或方法引用。

Non-interference

Streams使您能够对各种数据源执行可能并行的聚合操作，包括甚至非线程安全的集合，如ArrayList 。 这是可能的，只有当我们可以防止在流管道执行期间对数据源的干扰 。 除了逃生舱操作iterator()和spliterator() ，当调用终端操作时，执行开始，终端操作完成时结束。 对于大多数数据源，防止干扰意味着确保在流管线的执行期间完全不修改数据源。 其中值得注意的例外是其源是并发集合的流，它们专门用于处理并发修改。 并发流源是Spliterator报告CONCURRENT特征的流。

因此，源流可能不并发的流管道中的行为参数不应该修改流的数据源。 据说行为参数会干扰非并发数据源，如果它修改或导致修改流的数据源。 不干扰的需要适用于所有管道，而不仅仅是平行管道。 除非流源是并发的，否则在流管道的执行期间修改流的数据源可能会导致异常，错误的答案或不合规的行为。 对于良好的流源，可以在终端操作开始之前修改源，并且这些修改将反映在被覆盖的元素中。 例如，考虑以下代码：

   List<String> l = new ArrayList(Arrays.asList("one", "two")); Stream<String> sl = l.stream(); l.add("three"); String s = sl.collect(joining(" "));
首先创建一个由两个字符串组成的列表：“一个”; 和“二”。 然后从该列表创建流。 接下来，通过添加第三个字符串“three”修改列表。 最后，流的元素被收集并连接在一起。 由于列表在终端collect操作开始之前被修改，结果将是一个“一二三”字符串。 从JDK集合返回的所有流和大多数其他JDK类都以这种方式表现良好; 对于其他库生成的流，请参阅Low-level stream construction了解构建良好流的要求。

Stateless behaviors

如果流操作的行为参数是有状态的，流管道结果可能不确定或不正确。 有状态的lambda（或实现适当的功能接口的其他对象）是结果取决于在流管道的执行期间可能改变的任何状态。 有状态的lambda的一个例子是map()的参数：
   Set<Integer> seen = Collections.synchronizedSet(new HashSet<>()); stream.parallel().map(e -> { if (seen.add(e)) return 0; else return e; })...
这里，如果并行执行映射操作，由于线程调度的差异，相同输入的结果可能因运行而异，而使用无状态的lambda表达式，结果将始终相同。

还要注意，尝试从行为参数访问可变状态会给您带来安全和性能方面的不良选择; 如果您不同步对该状态的访问，则会有数据竞争，因此您的代码已损坏，但是如果您同步访问该状态，则冒有争议的风险有可能破坏您正在寻求的并行性。 最好的方法是避免有状态的行为参数完全流式传输; 通常有一种重组流管道以避免状态的方法。

Side-effects

一般而言，流行为的行为参数的副作用是不鼓励的，因为它们经常会导致无意识地违反无状态要求以及其他线程安全危害。

如果行为参数确实有副作用，除非明确说明，否则不能保证：

  • 对其他线程的这些副作用的visibility ;
  • 在相同的流管道中的“相同”元素上的不同操作在相同的线程中执行; 和
  • 总是调用行为参数，因为流实现可以自由地从流管道中清除操作（或整个阶段），如果它可以证明它不会影响计算结果。

副作用的排序可能令人惊讶。 即使当管道被限制以产生与流源的遇到顺序一致的结果 （例如， IntStream.range(0,5).parallel().map(x -> x*2).toArray()必须产生[0, 2, 4, 6, 8] ）时，不保证将映射器功能应用于各个元件的顺序，或者在什么线程中为给定元素执行任何行为参数。

副作用的消除也可能令人惊讶。 除了终端操作forEach和forEachOrdered之外 ，当流实现可以优化行为参数的执行而不影响计算结果时，行为参数的副作用可能不总是被执行。 （有关具体示例，请参阅count操作中记录的API说明。）

许多可能诱惑使用副作用的计算可以更安全有效地表达而无副作用，例如使用reduction代替可变累加器。 但是，使用println()进行调试的副作用通常是无害的。 少量的流操作，如forEach()和peek() ，只能通过副作用进行操作; 这些应谨慎使用。

作为如何将不正确地使用副作用的流管道转换为不适用的流管道的示例，以下代码搜索与给定正则表达式匹配的字符串，并将匹配放在列表中。

   ArrayList<String> results = new ArrayList<>(); stream.filter(s -> pattern.matcher(s).matches()) .forEach(s -> results.add(s)); // Unnecessary use of side-effects!
此代码不必要地使用副作用。 如果并行执行，则ArrayList的非线程安全性将导致不正确的结果，并且添加所需的同步将导致争用，从而破坏并行性的好处。 此外，这里使用副作用是完全不必要的; forEach()可以简单地替换为更安全，更高效，更适合并行化的还原操作：
   List<String>results = stream.filter(s -> pattern.matcher(s).matches()) .collect(Collectors.toList()); // No side-effects!

Ordering

流可能有也可能没有定义的遇到顺序 。 流是否有遇到顺序取决于源和中间操作。 某些流源（如List或数组）本质上是排序的，而其他流源（例如HashSet ）不是。 一些中间操作（例如sorted() ）可以在其他无序流上施加遇到命令，而其他中间操作可能使排序的流无序，例如BaseStream.unordered() 。 此外，一些终端操作可能会忽略遇到的顺序，如forEach() 。

如果一个流被命令，大多数操作被限制为在遇到的顺序中对元素进行操作; 如果流的源是List其中包含[1, 2, 3] ，那么执行map(x -> x*2)的结果必须是[2, 4, 6] 。 然而，如果源没有定义的遇到顺序，则值[2, 4, 6]任何置换将是有效的结果。

对于顺序流，遇到顺序的存在或不存在不影响性能，仅影响确定性。 如果流被排序，在相同的源上重复执行相同的流管线将产生相同的结果; 如果没有订购，重复执行可能会产生不同的结果。

对于并行流，放宽排序约束有时可以实现更有效的执行。 如果元素的排序不相关，则可以更有效地实现某些聚合操作，例如过滤重复（ distinct() ）或分组缩减（ Collectors.groupingBy() ）。 类似地，与内部limit()相关的操作（例如limit() ）可能需要缓冲以确保正确排序，从而破坏并行性的好处。 在流具有遇到顺序的情况下，但是用户并不特别关心该遭遇顺序时，使用unordered()明确地排序流可以提高某些有状态或终端操作的并行性能。 然而，大多数流管线，例如上面的例子的“权重之和”，仍然在订购限制下有效地并行化。

Reduction operations

缩减操作（也称为折叠 ）采用一系列输入元素，并通过重复应用组合操作将其组合成单个摘要结果，例如查找一组数字的和或最大值，或将元素累加到列表中。 该流的类具有普遍减少操作，所谓的多种形式reduce()和collect() ，以及多个专业化还原的形式，如sum() ， max() ，或count() 。

当然，这样的操作可以容易地被实现为简单的顺序循环，如：

   int sum = 0; for (int x : numbers) { sum += x; }
然而，有一个很好的理由喜欢减少操作超过如上所述的突变积累。 不仅减少“更抽象” - 它在整个流上运行，而不是单个元素 - 但正确构造的减少操作本质上是可并行的，只要用于处理元素的功能是associative和stateless 。 例如，给定一个我们要找到的数字的数据流，我们可以写：
   int sum = numbers.stream().reduce(0, (x,y) -> x+y);
要么：
   int sum = numbers.stream().reduce(0, Integer::sum);

这些还原操作可以安全地并行运行，几乎没有修改：

   int sum = numbers.parallelStream().reduce(0, Integer::sum);

减少并行化很好，因为实现可以并行地对数据的子集进行操作，然后组合中间结果以获得最终的正确答案。 （即使该语言具有“每个并行”的构造，变异累积方法仍然需要开发人员向共享累加变量sum提供线程安全更新，然后所需的同步可能消除并行性的任何性能增益。）使用reduce()代替删除并行化还原操作的所有负担，并且库可以提供高效的并行实现，而不需要额外的同步。

前面显示的“widgets”示例显示了如何将reduce与其他操作结合来替代大量操作的循环。 如果widgets是Widget对象的集合，它们具有getWeight方法，我们可以找到最重的小部件：

   OptionalInt heaviest = widgets.parallelStream() .mapToInt(Widget::getWeight) .max();

在其更一般的形式，一个reduce上类型的元素的操作<T>得到类型的结果<U>需要三个参数：

   <U> U reduce(U identity, BiFunction<U, ? super T, U> accumulator, BinaryOperator<U> combiner);
这里， 身份元素既是减少的初始种子值，也是没有输入元素的默认结果。 累加器函数获得部分结果和下一个元素，并产生新的部分结果。 组合器功能组合两个部分结果以产生新的部分结果。 （组合器在并行减少中是必需的，其中输入被分割，为每个分区计算的部分累加，然后组合部分结果以产生最终结果。）

更正式地， identity值必须是组合器功能的标识 。 这意味着，对于所有u ， combiner.apply(identity, u)等于u 。 此外， combiner功能必须是associative ，并必须与兼容accumulator功能：对所有u和t ， combiner.apply(u, accumulator.apply(identity, t))必须equals()至accumulator.apply(u, t) 。

三参数形式是双参数形式的泛化，将映射步骤纳入积累步骤。 我们可以使用更一般的形式重写简单的权重权重示例，如下所示：

   int sumOfWeights = widgets.stream() .reduce(0, (sum, b) -> sum + b.getWeight(), Integer::sum);
虽然显式的map-reduce表单更易读，因此通常应该是首选。 通过将映射和缩小组合成单个功能，可以优化远程工作的广泛形式。

Mutable reduction

当可处理流中的元素时， 可变缩减操作将输入元素累加到可变结果容器中，例如Collection或StringBuilder 。

如果我们想采取一串字符串并将它们连接成一个长的字符串，我们可以通过普通的减少来实现这一点：

   String concatenated = strings.reduce("", String::concat)

我们会得到所需的结果，甚至可以并行工作。 但是，我们可能不会对演出感到高兴！ 这样的实现将执行大量的字符串复制，并且运行时间将是字符数为O（n ^ 2） 。 更有效的方法是将结果累加到一个StringBuilder ，这是一个用于累积字符串的可变容器。 我们可以使用相同的技术并行化可变减少，就像我们用普通的减少一样。

可变缩减操作称为collect() ，因为它将所需结果汇总到结果容器中，如Collection 。 A collect操作需要三个功能：供应商功能来构造结果容器的新实例，将输入元素合并到结果容器中的累加器函数，以及将一个结果容器的内容合并到另一个的组合函数。 这种形式与普通缩减的一般形式非常相似：

   <R> R collect(Supplier<R> supplier, BiConsumer<R, ? super T> accumulator, BiConsumer<R, R> combiner);

与reduce() ，以抽象的方式表达collect的好处是可以直接适应并行化：只要积累和组合函数满足适当的要求，我们可以并行累积部分结果，然后将它们组合起来。 例如，要将流中的元素的String表示集合到一个ArrayList ，我们可以为每个表单写出明显的顺序：

   ArrayList<String> strings = new ArrayList<>(); for (T element : stream) { strings.add(element.toString()); }
或者我们可以使用可并行化的收集表单：
   ArrayList<String> strings = stream.collect(() -> new ArrayList<>(), (c, e) -> c.add(e.toString()), (c1, c2) -> c1.addAll(c2));
或者将绘图操作拉出累加器函数，我们可以更简洁地表达：
   List<String> strings = stream.map(Object::toString) .collect(ArrayList::new, ArrayList::add, ArrayList::addAll);
在这里，我们的供应商只是ArrayList constructor ，该累加器将一个字符串元素添加到一个ArrayList ，组合器只需使用addAll将字符串从一个容器复制到另一个容器中。

collect - 供应商，蓄能器和组合器的三个方面紧密耦合。 我们可以使用Collector的抽象来捕获所有三个方面。 将字符串收集到List的上述示例可以使用标准Collector重写为：

   List<String> strings = stream.map(Object::toString) .collect(Collectors.toList());

将可变减少包装到收集器中有另一个优点：可组合性。 Collectors课程包含许多收集器的预定义工厂，包括将一个收集器转换为另一个收集器的组合器。 例如，假设我们有一个收集器来计算员工流量的总和，如下所示：

   Collector<Employee, ?, Integer> summingSalaries = Collectors.summingInt(Employee::getSalary);
（第二类参数的?仅表示我们不关心此收集器使用的中间表示。）如果要创建收集器以按部门列出工资总额，可以使用summingSalaries重新使用summingSalaries ：
   Map<Department, Integer> salariesByDept = employees.stream().collect(Collectors.groupingBy(Employee::getDepartment, summingSalaries));

与常规缩小操作一样，如果满足条件，只能并行化collect()操作。 对于任何部分累积的结果，将其与空结果容器组合必须产生等效结果。 也就是说，部分累加结果p即任何系列累加器和组合器的调用的结果， p必须等于combiner.apply(p, supplier.get()) 。

此外，然而，计算是分裂的，它必须产生等效的结果。 对于任何输入要素t1和t2 ，以下计算中的结果r1和r2必须等效：

   A a1 = supplier.get(); accumulator.accept(a1, t1); accumulator.accept(a1, t2); R r1 = finisher.apply(a1); // result without splitting A a2 = supplier.get(); accumulator.accept(a2, t1); A a3 = supplier.get(); accumulator.accept(a3, t2); R r2 = finisher.apply(combiner.apply(a2, a3)); // result with splitting

这里，等效通常意味着根据Object.equals(Object) 。 但是在某些情况下，可以放松等价以解决秩序的差异。

Reduction, concurrency, and ordering

对于一些复杂的归约操作，例如collect()产生一个Map ，如：
   Map<Buyer, List<Transaction>> salesByBuyer = txns.parallelStream() .collect(Collectors.groupingBy(Transaction::getBuyer));
实际上并行执行操作可能会适得其反。 这是因为一些Map实现的组合步骤（将一个Map合并成另一个按键）可能是昂贵的。

但是，假设在此减少中使用的结果容器是可同时修改的集合 - 例如ConcurrentHashMap 。 在这种情况下，累加器的并行调用实际上可以将它们的结果同时存入相同的共享结果容器中，从而无需组合器来合并不同的结果容器。 这可能会提高并行执行性能。 我们称之为并发减少。

甲Collector支持并发还原标有Collector.Characteristics.CONCURRENT特性。 然而，并发收集也有缺点。 如果多个线程将结果同时存入共享容器中，则结果存入的顺序是非确定性的。 因此，只有对于正在处理的流的顺序不重要，并发减少才是可能的。 Stream.collect(Collector)实现只会执行并发减少

  • 流平行;
  • 收藏者有Collector.Characteristics.CONCURRENT的特点，
  • 流是无序的，或者收集器具有Collector.Characteristics.UNORDERED的特征。
您可以使用BaseStream.unordered()方法确保流无序。 例如：
   Map<Buyer, List<Transaction>> salesByBuyer = txns.parallelStream() .unordered() .collect(groupingByConcurrent(Transaction::getBuyer));
（其中Collectors.groupingByConcurrent(java.util.function.Function<? super T, ? extends K>)是同时相当于groupingBy ）。

请注意，如果给定键的元素按照它们在源中显示的顺序重要，那么我们不能使用并发缩减，因为排序是并发插入的一种伤害。 然后，我们将被限制为执行顺序减少或基于并行的并行还原。

Associativity

如果以下条件成立，操作员或功能op是关联的：
   (a op b) op c == a op (b op c)
如果我们将其扩展为四个术语，那么可以看出这一点对于并行评估的重要性：
   a op b op c op d == (a op b) op (c op d)
所以我们可以评估(a op b)与(c op d)并行，然后调用op的结果。

关联操作的示例包括数字加法，最小和最大值以及字符串连接。

Low-level stream construction

到目前为止，所有的流示例都使用像Collection.stream()或Arrays.stream(Object[])这样的方法来获取流。 这些流动方法如何实施？

StreamSupport课程有许多低级的创建流的方法，全部使用某种形式的Spliterator 。 甲spliterator是的并行模拟Iterator ; 它描述了（可能是无限的）元素集合，支持顺序前进，批量遍历，并将输入的一部分分解成可并行处理的另一个分割器。 在最底层，所有的流都由一个分流器驱动。

在实现拼接器方面有许多实现选择，几乎所有这些都是实现简单性和使用该拼接器的流的运行时性能之间的权衡。 使用Spliterators.spliteratorUnknownSize(java.util.Iterator, int)从迭代器创建一个最简单的但是性能最差的方法来创建一个分割器。 虽然这样的分配器将会工作，但由于我们丢失了大小的信息（底层数据集有多大）以及被限制在简单的分割算法上，所以可能会提供较差的并行性能。

更高质量的拼接器将提供平衡和已知尺寸的分割，精确的尺寸信息以及许多可以由实现使用的拼接器或数据的其他characteristics来优化执行。

可变数据源的分流器有另外的挑战; 因为数据可能在创建分割器的时间和流管线的执行时间之间改变，所以与数据的绑定时间。 理想情况下，流的分流器将报告IMMUTABLE或CONCURRENT的特征; 如果不是应该是late-binding 。 如果源不能直接提供推荐的拼接器，则可以使用Supplier间接提供拼接器，并通过Supplier接受版本的stream()构建流。 只有在流量管道的终端运行开始之后，才能从供应商获得分配器。

这些要求大大降低了流源的突变和流管线的执行之间的潜在干扰的范围。 基于具有所需特性的分流器或使用基于供应商的工厂形式的流的流在终端操作开始之前不受数据源的修改（提供到流操作的行为参数满足非标准的要求标准）干扰和无国籍）。 详情请参阅Non-Interference 。

从以下版本开始：
1.8
  • 接口摘要
    接口 描述
    BaseStream<T,S extends BaseStream<T,S>>
    流的基本界面，它们是支持顺序和并行聚合操作的元素序列。
    Collector<T,A,R>
    A mutable reduction operation将输入元素累加到可变结果容器中，可选地在所有输入元素被处理之后将累积结果转换成最终表示。
    DoubleStream
    支持顺序和并行聚合操作的原始双值元素序列。
    DoubleStream.Builder
    一个可变的构建器为 DoubleStream 。
    IntStream
    支持顺序和并行聚合操作的原始int值元素序列。
    IntStream.Builder
    一个可变的构建器，用于 IntStream 。
    LongStream
    支持顺序和并行聚合操作的原始长值元素序列。
    LongStream.Builder
    一个可变的构建器，用于 LongStream 。
    Stream<T>
    支持顺序和并行聚合操作的一系列元素。
    Stream.Builder<T>
    一个可变的构建器，用于 Stream 。
  • 类摘要
    Class 描述
    Collectors
    实现各种有用的还原操作的Collector ，例如将元素累积到集合中，根据各种标准汇总元素等。
    StreamSupport
    用于创建和操纵流的低级实用程序方法。
  • 枚举摘要
    Enum 描述
    Collector.Characteristics
    指示 Collector属性的特性，可用于优化还原实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.stream Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.stream

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.stream.Collectors
    • java.util.stream.StreamSupport

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.util.stream.BaseStream<T,S>
      • java.util.stream.DoubleStream
      • java.util.stream.IntStream
      • java.util.stream.LongStream
      • java.util.stream.Stream<T>
  • java.util.stream.Collector<T,A,R>
  • java.util.function.Consumer<T>
    • java.util.stream.Stream.Builder<T>
  • java.util.function.DoubleConsumer
    • java.util.stream.DoubleStream.Builder
  • java.util.function.IntConsumer
    • java.util.stream.IntStream.Builder
  • java.util.function.LongConsumer
    • java.util.stream.LongStream.Builder

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.util.stream.Collector.Characteristics
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LongStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface LongStream

  • All Superinterfaces:
    AutoCloseable ， BaseStream<Long,LongStream>

    public interface LongStream
extends BaseStream<Long,LongStream>
    支持顺序和并行聚合操作的原始长值元素序列。 这是long原始专业Stream 。

    以下示例说明了使用Stream和LongStream的汇总操作，计算红色小部件的权重之和：

       long sum = widgets.stream() .filter(w -> w.getColor() == RED) .mapToLong(w -> w.getWeight()) .sum();
    请参阅Stream的类文档和java.util.stream的包文档， 以了解流，流操作，流管线和并行性的其他规范。
    从以下版本开始：
    1.8
    另请参见：
    Stream ， java.util.stream

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  LongStream.Builder
      一个可变的构建器，用于 LongStream 。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean allMatch​(LongPredicate predicate)
      返回此流的所有元素是否与提供的谓词匹配。
      boolean anyMatch​(LongPredicate predicate)
      返回此流的任何元素是否与提供的谓词匹配。
      DoubleStream asDoubleStream​()
      返回一个由此流的元素组成的 DoubleStream ，转换为 double 。
      OptionalDouble average​()
      返回描述此流的元素的算术平均值的 OptionalDouble ，如果此流为空，则返回一个空的可选项。
      Stream<Long> boxed​()
      返回一个由这个流的元素组成的 Stream ，每个包含一个 Long 。
      static LongStream.Builder builder​()
      返回一个 LongStream生成器。
      <R> R collect​(Supplier<R> supplier, ObjLongConsumer<R> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      static LongStream concat​(LongStream a, LongStream b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      long count​()
      返回此流中的元素数。
      LongStream distinct​()
      返回由该流的不同元素组成的流。
      default LongStream dropWhile​(LongPredicate predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      static LongStream empty​()
      返回一个空的序列 LongStream 。
      LongStream filter​(LongPredicate predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      OptionalLong findAny​()
      返回OptionalLong描述流的一些元件，或一个空OptionalLong如果流是空的。
      OptionalLong findFirst​()
      返回OptionalLong描述此流的第一个元素，或空OptionalLong如果流是空的。
      LongStream flatMap​(LongFunction<? extends LongStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      void forEach​(LongConsumer action)
      对此流的每个元素执行操作。
      void forEachOrdered​(LongConsumer action)
      对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。
      static LongStream generate​(LongSupplier s)
      返回无限顺序无序流，其中每个元素由提供的 LongSupplier生成。
      static LongStream iterate​(long seed, LongPredicate hasNext, LongUnaryOperator next)
      返回通过将给定的 next函数迭代应用于初始元素产生的顺序 LongStream ，其条件是满足给定的 hasNext谓词。
      static LongStream iterate​(long seed, LongUnaryOperator f)
      返回有序无限连续 LongStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      PrimitiveIterator.OfLong iterator​()
      返回此流的元素的迭代器。
      LongStream limit​(long maxSize)
      返回由此流的元素组成的流，截短长度不能超过 maxSize 。
      LongStream map​(LongUnaryOperator mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
      DoubleStream mapToDouble​(LongToDoubleFunction mapper)
      返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
      IntStream mapToInt​(LongToIntFunction mapper)
      返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
      <U> Stream<U> mapToObj​(LongFunction<? extends U> mapper)
      返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
      OptionalLong max​()
      返回描述此流的最大元素的 OptionalLong ，如果此流为空，则为空可选。
      OptionalLong min​()
      返回描述此流的最小元素的 OptionalLong ，如果此流为空，则返回一个空的可选项。
      boolean noneMatch​(LongPredicate predicate)
      返回此流的元素是否与提供的谓词匹配。
      static LongStream of​(long t)
      返回包含单个元素的序列 LongStream 。
      static LongStream of​(long... values)
      返回其元素是指定值的顺序排序流。
      LongStream parallel​()
      返回平行的等效流。
      LongStream peek​(LongConsumer action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
      static LongStream range​(long startInclusive, long endExclusive)
      从 startInclusive （含）返回 endExclusive （排除）的顺序 LongStream ，增量步长为 1 。
      static LongStream rangeClosed​(long startInclusive, long endInclusive)
      返回有序顺序 LongStream从 startInclusive （含）至 endInclusive通过的递增步长（含） 1 。
      long reduce​(long identity, LongBinaryOperator op)
      对该流的元素执行 reduction ，使用提供的身份值和 associative累积函数，并返回减小的值。
      OptionalLong reduce​(LongBinaryOperator op)
      使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值（如果有）的 OptionalLong 。
      LongStream sequential​()
      返回顺序的等效流。
      LongStream skip​(long n)
      在丢弃流的第一个 n元素后，返回由该流的剩余元素组成的流。
      LongStream sorted​()
      以排序顺序返回由该流的元素组成的流。
      Spliterator.OfLong spliterator​()
      返回此流的元素的拼接器。
      long sum​()
      返回此流中元素的总和。
      LongSummaryStatistics summaryStatistics​()
      返回描述有关此流的元素的各种摘要数据的 LongSummaryStatistics 。
      default LongStream takeWhile​(LongPredicate predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
      long[] toArray​()
      返回一个包含此流的元素的数组。

      • Methods inherited from interface java.util.stream.BaseStream

        close, isParallel, onClose, unordered

    • 方法详细信息

      • filter

        LongStream filter​(LongPredicate predicate)
        返回由与此给定谓词匹配的此流的元素组成的流。

        这是一个intermediate operation 。

        参数
        predicate -一个 non-interfering ， stateless谓词应用到每个元素，以确定是否它应包含
        结果
        新的流

      • map

        LongStream map​(LongUnaryOperator mapper)
        返回由给定函数应用于此流的元素的结果组成的流。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToObj

        <U> Stream<U> mapToObj​(LongFunction<? extends U> mapper)
        返回一个对象值Stream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数类型
        U - 新流的元素类型
        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToInt

        IntStream mapToInt​(LongToIntFunction mapper)
        返回一个IntStream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToDouble

        DoubleStream mapToDouble​(LongToDoubleFunction mapper)
        返回一个DoubleStream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • flatMap

        LongStream flatMap​(LongFunction<? extends LongStream> mapper)
        返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。 每个映射的流在其内容被放入此流之后是closed 。 （如果映射的流为null ，则使用空的流。）

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless功能应用到其产生的每个元素 LongStream新值的
        结果
        新的流
        另请参见：
        Stream.flatMap(Function)

      • distinct

        LongStream distinct​()
        返回由该流的不同元素组成的流。

        这是一个stateful intermediate operation 。

        结果
        新的流

      • sorted

        LongStream sorted​()
        以排序顺序返回由该流的元素组成的流。

        这是一个stateful intermediate operation 。

        结果
        新的流

      • peek

        LongStream peek​(LongConsumer action)
        返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。

        这是一个intermediate operation 。

        对于并行流管线，可以在上游操作的任何时间和任何线程中调用该元素可用的动作。 如果操作修改共享状态，则负责提供所需的同步。

        API Note:
        该方法主要用于支持调试，您希望在流程中流过某个特定点时查看元素：
           LongStream.of(1, 2, 3, 4) .filter(e -> e > 2) .peek(e -> System.out.println("Filtered value: " + e)) .map(e -> e * e) .peek(e -> System.out.println("Mapped value: " + e)) .sum();

        在情况下，流实现能够优化掉生产一些或所有的元件（如与像短路操作findFirst ，或在所描述的示例count() ），动作将不被调用这些元素。

        参数
        action - 一个 non-interfering要从流中消耗的元素上执行的操作
        结果
        新的流

      • limit

        LongStream limit​(long maxSize)
        返回由此流的元素组成的流，截短长度不能超过maxSize 。

        这是一个short-circuiting stateful intermediate operation 。

        API Note:
        虽然limit()通常是顺序流管道上的廉价操作，但是在有序并行流水线上可能相当昂贵，特别是对于maxSize大值，因为limit(n)被限制为不仅返回任何n个元素，而且在遇到顺序中返回前n个元素。 如果您的情况允许，则使用无序流源（例如generate(LongSupplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线显着加速limit() 。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与limit()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        参数
        maxSize - 流应该限制的元素数量
        结果
        新的流
        异常
        IllegalArgumentException - 如果 maxSize为负数

      • skip

        LongStream skip​(long n)
        在丢弃流的第一个n元素后，返回由该流的剩余元素组成的流。 如果此流包含少于n元素，那么将返回一个空流。

        这是一个stateful intermediate operation 。

        API Note:
        虽然skip()通常是顺序流管线上的廉价操作，但是在有序并行流水线上可能相当昂贵，特别是对于n大值，因为skip(n)被限制为不仅跳过任何n个元素，而且会遇到顺序的前n个元素。 如果您的情况允许，则使用无序流源（如generate(LongSupplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线显着加速skip() 。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与skip()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        参数
        n - 要跳过的主要元素的数量
        结果
        新的流
        异常
        IllegalArgumentException - 如果 n为负数

      • takeWhile

        default LongStream takeWhile​(LongPredicate predicate)
        如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。 否则返回，如果该流是无序的，则由从与该给定谓词匹配的该流中取得的元素的子集组成的流。

        如果该流被排序，则最长的前缀是与给定谓词匹配的该流的连续的元素序列。 序列的第一个元素是此流的第一个元素，并且紧跟该序列的最后一个元素的元素与给定谓词不匹配。

        如果该流是无序的，并且该流的一些（但不是全部）元素与给定的谓词匹配，则该操作的行为是非确定性的; 可以自由地采取匹配元素的任何子集（包括空集）。

        独立于该流是否被排序或无序，如果此流的所有元素与给定谓词匹配，则此操作将采用所有元素（结果与输入相同），或者如果流的元素与给定谓词匹配，则没有元素被采取（结果是一个空的流）。

        这是一个short-circuiting stateful intermediate operation 。

        API Note:
        虽然takeWhile()通常是在顺序流管线上的廉价操作，但是在有序并行流水线上可能是相当昂贵的，因为操作被限制为不仅返回任何有效的前缀，而且返回遇到顺序中的元素的最长前缀。 使用无序流源（例如generate(LongSupplier) ）或去除所述排序约束与BaseStream.unordered()可能导致显著加速比takeWhile()在并行管线，如果情况许可的语义。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与takeWhile()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        实现要求：
        默认实现获取此流的spliterator ，包装该分割器，以便在遍历时支持此操作的语义，并返回与包装的spliterator相关联的新流。 返回的流保留此流的执行特性（即根据BaseStream.isParallel()并行或顺序执行），但是封装的分割器可能选择不支持拆分。 当返回的流关闭时，将调用返回的流和此流的关闭处理程序。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于元素，以确定元素的最长前缀。
        结果
        新的流
        从以下版本开始：
        9

      • dropWhile

        default LongStream dropWhile​(LongPredicate predicate)
        如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。 否则返回，如果该流是无序的，则在丢弃与给定谓词匹配的元素的子集之后，返回由该流的剩余元素组成的流。

        如果该流被排序，则最长的前缀是与给定谓词匹配的该流的连续的元素序列。 序列的第一个元素是此流的第一个元素，并且紧跟该序列的最后一个元素的元素与给定谓词不匹配。

        如果该流是无序的，并且该流的一些（但不是全部）元素与给定的谓词匹配，则该操作的行为是非确定性的; 可以放置匹配元素的任何子集（包括空集合）。

        独立于该流是否被排序或无序，如果此流的所有元素与给定谓词匹配，则此操作将删除所有元素（结果为空流），或者如果流中的元素与给定谓词匹配，则不会删除元素（结果与输入相同）。

        这是一个stateful intermediate operation 。

        API Note:
        虽然dropWhile()通常是顺序流管线上的廉价操作，但是在有序并行流水线上可能相当昂贵，因为操作被限制为不仅返回任何有效的前缀，而且返回遇到顺序中元素的最长前缀。 使用无序流源（例如generate(LongSupplier) ）或去除所述排序约束与BaseStream.unordered()可能导致显著加速比dropWhile()在并行管线，如果情况许可的语义。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与dropWhile()在并行管线，在切换到的顺序执行与sequential()可以提高性能。
        实现要求：
        默认实现获取此流的spliterator ，包装该分片器，以便在遍历时支持此操作的语义，并返回与包装拼接器相关联的新流。 返回的流保留此流的执行特性（即根据BaseStream.isParallel()并行或顺序执行），但是包装的分割器可能选择不支持拆分。 当返回的流关闭时，将调用返回的流和此流的关闭处理程序。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于元素，以确定元素的最长前缀。
        结果
        新的流
        从以下版本开始：
        9

      • forEach

        void forEach​(LongConsumer action)
        对此流的每个元素执行操作。

        这是一个terminal operation 。

        对于并行流管道，此操作不能保证遵守流的遇到顺序，因为这样做会牺牲并行性的好处。 对于任何给定的元素，动作可以在图书馆选择的任何时间和任何线索中执行。 如果操作访问共享状态，则负责提供所需的同步。

        参数
        action - 一个 non-interfering对元素执行的操作

      • forEachOrdered

        void forEachOrdered​(LongConsumer action)
        对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。

        这是一个terminal operation 。

        参数
        action - 要对元素执行的一个 non-interfering操作
        另请参见：
        forEach(LongConsumer)

      • toArray

        long[] toArray​()
        返回一个包含此流的元素的数组。

        这是一个terminal operation 。

        结果
        一个包含此流的元素的数组

      • reduce

        long reduce​(long identity,
            LongBinaryOperator op)
        使用提供的身份值和associative累积函数对此流的元素执行reduction ，并返回减小的值。 这相当于：
           long result = identity; for (long element : this stream) result = accumulator.applyAsLong(result, element) return result;
        但不限于顺序执行。

        identity值必须是累加器函数的标识。 这意味着，对于所有x ， accumulator.apply(identity, x)等于x 。 accumulator函数必须是一个associative函数。

        这是一个terminal operation 。

        API Note:
        总和，最小，最大和平均都是减少的特殊情况。 一个数字流可以表示为：
           long sum = integers.reduce(0, (a, b) -> a+b);
        或更紧凑：
           long sum = integers.reduce(0, Long::sum);

        尽管与简单地将循环中的总体变量相比，这可能看起来更为迂回的方式进行，但减少操作更平稳地并行化，而不需要额外的同步，并大大降低了数据竞争的风险。

        参数
        identity - 累积函数的标识值
        op -一个 associative ， non-interfering ， stateless功能组合两个值
        结果
        减少的结果
        另请参见：
        sum() ，
min() ，
max() ，
average()

      • reduce

        OptionalLong reduce​(LongBinaryOperator op)
        使用associative累积函数对此流的元素执行reduction ，并返回描述减小值（如果有）的OptionalLong 。 这相当于：
           boolean foundAny = false; long result = null; for (long element : this stream) { if (!foundAny) { foundAny = true; result = element; } else result = accumulator.applyAsLong(result, element); } return foundAny ? OptionalLong.of(result) : OptionalLong.empty();
        但不限于顺序执行。

        accumulator功能必须是associative功能。

        这是一个terminal operation 。

        参数
        op -一个 associative ， non-interfering ， stateless功能组合两个值
        结果
        减少的结果
        另请参见：
        reduce(long, LongBinaryOperator)

      • collect

        <R> R collect​(Supplier<R> supplier,
              ObjLongConsumer<R> accumulator,
              BiConsumer<R,R> combiner)
        对此流的元素执行mutable reduction操作。 可变缩减是其中减值是可变结果容器的缩减值，例如ArrayList ，并且通过更新结果的状态而不是替换结果来合并元素。 这产生的结果相当于：
           R result = supplier.get(); for (long element : this stream) accumulator.accept(result, element); return result;

        像reduce(long, LongBinaryOperator)一样， collect操作可以并行化，而不需要额外的同步。

        这是一个terminal operation 。

        参数类型
        R - 可变结果容器的类型
        参数
        supplier - 创建一个新的可变结果容器的函数。 对于并行执行，可以多次调用此函数，并且每次都必须返回一个新的值。
        accumulator -一个 associative ， non-interfering ， stateless功能必须的元件折叠成的结果容器。
        combiner -一个associative ， non-interfering ， stateless函数接受两个部分结果的容器和将它们合并，这必须与累加器功能兼容。 组合器功能必须将第二个结果容器中的元素折叠到第一个结果容器中。
        结果
        减少的结果
        另请参见：
        Stream.collect(Supplier, BiConsumer, BiConsumer)

      • sum

        long sum​()
        返回此流中元素的总和。 这是一个reduction的特殊情况，相当于：
           return reduce(0, Long::sum);

        这是一个terminal operation 。

        结果
        这个流中元素的总和

      • min

        OptionalLong min​()
        返回描述此流的最小元素的OptionalLong ，如果此流为空，则返回一个空的可选项。 这是一个reduction的特殊情况，相当于：
           return reduce(Long::min);

        这是一个terminal operation 。

        结果
        一个 OptionalLong含有该料流的一个空的最小元件，或 OptionalLong如果流是空

      • max

        OptionalLong max​()
        返回描述此流的最大元素的OptionalLong ，如果此流为空，则返回一个空的可选项。 这是一个reduction的特殊情况，相当于：
           return reduce(Long::max);

        这是一个terminal operation 。

        结果
        一个 OptionalLong含有该料流的最大元素，或空 OptionalLong如果流是空

      • count

        long count​()
        返回此流中的元素数。 这是一个reduction的特殊情况，相当于：
           return map(e -> 1L).sum();

        这是一个terminal operation 。

        API Note:
        如果能够直接从流源计算计数，则实现可以选择不执行流管线（顺序地或并行地）。 在这种情况下，不会遍历源元素，并且不会评估中间操作。 除了无害的情况（如调试），强烈不鼓励具有副作用的行为参数可能会受到影响。 例如，考虑以下流：
           LongStream s = LongStream.of(1, 2, 3, 4); long count = s.peek(System.out::println).count();
        流源所覆盖的元素的数量是已知的，并且中间操作（ peek ）不会从流注入或移除元素（如flatMap或filter操作的情况）。 因此，计数为4，不需要执行管道，作为副作用，打印出元素。
        结果
        这个流中元素的数量

      • average

        OptionalDouble average​()
        返回描述此流的元素的算术平均值的OptionalDouble ，如果此流为空，则返回一个空的可选项。 这是一个reduction的特例 。

        这是一个terminal operation 。

        结果
        一个包含此流的平均元素的 OptionalDouble ，如果流为空，则为空可选

      • summaryStatistics

        LongSummaryStatistics summaryStatistics​()
        返回一个LongSummaryStatistics描述有关此流的元素的各种摘要数据。 这是一个reduction的特例 。

        这是一个terminal operation 。

        结果
        一个描述关于该流的元素的各种摘要数据的 LongSummaryStatistics

      • anyMatch

        boolean anyMatch​(LongPredicate predicate)
        返回此流的任何元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回false ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于某些x P（x））的谓词的 存在量化 。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的任何元素与提供的谓词匹配，否则为 false

      • allMatch

        boolean allMatch​(LongPredicate predicate)
        返回此流的所有元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回true ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于所有x P（x））的谓词的通用量化 。 如果流是空的，量化据说是空洞地满意 ，始终是true （不管的P（X））。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的所有元素匹配提供的谓词或流为空，否则为 false

      • noneMatch

        boolean noneMatch​(LongPredicate predicate)
        返回此流的元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回true ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于所有x〜P（x））的否定谓词的通用量化 。 如果流是空的，那么量化被认为是空虚的，并且始终是true ，不论P（x）如何。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的任何元素与提供的谓词匹配，或者流为空，否则为 false

      • findFirst

        OptionalLong findFirst​()
        返回OptionalLong描述此流的第一个元素，或空OptionalLong如果流是空的。 如果流没有遇到顺序，则可能会返回任何元素。

        这是一个short-circuiting terminal operation 。

        结果
        一个 OptionalLong描述此流的第一个元素，或空 OptionalLong如果流是空

      • findAny

        OptionalLong findAny​()
        返回OptionalLong描述流的一些元件，或一个空OptionalLong如果流是空的。

        这是一个short-circuiting terminal operation 。

        这个操作的行为显然是不确定的; 可以自由选择流中的任何元素。 这是为了允许并行操作中的最大性能; 成本是同一来源上的多次调用可能不会返回相同的结果。 （如果需要稳定的结果，请改用findFirst() ）

        结果
        一个 OptionalLong描述该流的一些元件，或一个空 OptionalLong如果流是空
        另请参见：
        findFirst()

      • asDoubleStream

        DoubleStream asDoubleStream​()
        返回由该流的元素组成的DoubleStream ，转换为double 。

        这是一个intermediate operation 。

        结果
        一个由这个流的元素组成的 DoubleStream ，转换为 double

      • boxed

        Stream<Long> boxed​()
        返回一个Stream ，由此流的元素组成，每个元素包含一个Long 。

        这是一个intermediate operation 。

        结果
        一个 Stream一致的这个流的元素，每个盒装到 Long

      • sequential

        LongStream sequential​()
        描述从接口BaseStream复制
        返回顺序的等效流。 可能返回自己，因为流已经是顺序的，或者因为底层流状态被修改为顺序的。

        这是一个intermediate operation 。

        Specified by:
        sequential在接口 BaseStream<Long,LongStream>
        结果
        顺序流

      • parallel

        LongStream parallel​()
        描述从接口BaseStream复制
        返回平行的等效流。 可能会返回自己，因为流已经是并行的，或者因为底层流状态被修改为并行。

        这是一个intermediate operation 。

        Specified by:
        parallel在接口 BaseStream<Long,LongStream>
        结果
        并行流

      • iterator

        PrimitiveIterator.OfLong iterator​()
        说明从界面BaseStream复制
        返回此流的元素的迭代器。

        这是一个terminal operation 。

        Specified by:
        iterator在接口 BaseStream<Long,LongStream>
        结果
        该流的元素迭代器

      • spliterator

        Spliterator.OfLong spliterator​()
        说明从界面BaseStream复制
        返回此流的元素的拼接器。

        这是一个terminal operation 。

        返回的分配器应该报告从流管道导出的特征集（即从流源分割器和中间操作导出的特性）。 实施可能会报告这些特征的子集。 例如，为一些或所有可能的流管线计算整个集合可能太贵了。

        Specified by:
        spliterator在接口 BaseStream<Long,LongStream>
        结果
        该流的元素拼接器

      • builder

        static LongStream.Builder builder​()
        返回一个 LongStream生成器。
        结果
        流构建器

      • empty

        static LongStream empty​()
        返回一个空序列 LongStream 。
        结果
        一个空的顺序流

      • of

        static LongStream of​(long t)
        返回包含单个元素的序列 LongStream 。
        参数
        t - 单一元素
        结果
        单例顺序流

      • of

        static LongStream of​(long... values)
        返回其元素是指定值的顺序排序流。
        参数
        values - 新流的元素
        结果
        新的流

      • iterate

        static LongStream iterate​(long seed,
                          LongUnaryOperator f)
        返回有序无限连续LongStream由函数的迭代应用产生f到初始元素seed ，产生Stream由seed ， f(seed) ， f(f(seed))等

        第一元件（位置0在） LongStream将是提供seed 。 对于n > 0 ，位置n的元素将是将函数f应用于位置n - 1的元素的n - 1 。

        施加的作用f为一个元件happens-before施加的作用f用于随后的元件。 对于任何给定的元素，动作可以在库选择的任何线程中执行。

        参数
        seed - 初始元素
        f - 要应用于前一个元素以生成新元素的函数
        结果
        一个新的顺序 LongStream

      • iterate

        static LongStream iterate​(long seed,
                          LongPredicate hasNext,
                          LongUnaryOperator next)
        返回通过将给定的next函数迭代应用于初始元素LongStream产生的顺序LongStream ，其条件是满足给定的hasNext谓词。 一旦hasNext谓词返回false，流即会终止。

        LongStream.iterate应该产生与相应的for-loop相同的元素序列：

           for (long index=seed; hasNext.test(index); index = next.applyAsLong(index)) { ... }

        如果hasNext谓词不持有种子值，则结果序列可能为空。 否则第一个元素将是提供的seed值，下一个元素（如果存在）将是将next函数应用于seed值的结果，等等，直到hasNext谓词指示流应该终止。

        将hasNext谓词应用到元素happens-before的动作将next函数应用于该元素。 在为后续元素应用hasNext谓词的动作之前 ， 会发生一个元素应用next函数的动作。 对于任何给定的元素，可以在库选择的任何线程中执行一个动作。

        参数
        seed - 初始元素
        hasNext - 应用于元素以确定流何时终止的谓词。
        next - 要应用于前一个元素以生成新元素的函数
        结果
        一个新的顺序 LongStream
        从以下版本开始：
        9

      • generate

        static LongStream generate​(LongSupplier s)
        返回无限顺序无序流，其中每个元素由提供的LongSupplier生成。 这适合于产生恒定流，随机元素流等
        参数
        s - 用于生成元素的 LongSupplier
        结果
        一个新的无限顺序无序 LongStream

      • range

        static LongStream range​(long startInclusive,
                        long endExclusive)
        从 startInclusive （含）的顺序排列 LongStream ，返回 endExclusive （排除），增量为 1 。
        API Note:

        可以使用for循环顺序地产生递增值的等效序列，如下所示：

           for (long i = startInclusive; i < endExclusive ; i++) { ... }
        参数
        startInclusive - （含）初始值
        endExclusive - 独占上限
        结果
        一个序列 LongStream为 long元素的范围

      • rangeClosed

        static LongStream rangeClosed​(long startInclusive,
                              long endInclusive)
        返回有序顺序 LongStream从 startInclusive （含）至 endInclusive通过的递增步长（含） 1 。
        API Note:

        可以使用for循环依次生成等价的递增值序列，如下所示：

           for (long i = startInclusive; i <= endInclusive ; i++) { ... }
        参数
        startInclusive - （含）初始值
        endInclusive - 包含上限
        结果
        一个连续 LongStream的 long元素的范围

      • concat

        static LongStream concat​(LongStream a,
                         LongStream b)
        创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。 如果两个输入流都被排序，则生成的流被排序，并且如果任何一个输入流是并行的，则并行。 当结果流关闭时，调用两个输入流的关闭处理程序。
        Implementation Note:
        在重复连接构建流时要小心。 访问深度级联流的元素可能导致深度的调用链，甚至可能导致StackOverflowError 。
        参数
        a - 第一个流
        b - 第二个流
        结果
        两个输入流的并置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongStream.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface LongStream.Builder

  • All Superinterfaces:
    LongConsumer
    Enclosing interface:
    LongStream

    public static interface LongStream.Builder
extends LongConsumer
    一个可变的构建器为LongStream 。

    流构建器具有生命周期，其从构建阶段开始，在该阶段期间可以添加元素，然后转换到内置阶段，之后可能不添加元素。 当调用build()方法时，内置阶段开始，它创建一个有序流，其元素是添加到流构建器的元素，按照它们的添加顺序。

    从以下版本开始：
    1.8
    另请参见：
    LongStream.builder()

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void accept​(long t)
      向要构建的流添加元素。
      default LongStream.Builder add​(long t)
      向要构建的流添加元素。
      LongStream build​()
      构建流，将此构建器转换为内置状态。

      • Methods inherited from interface java.util.function.LongConsumer

        andThen

    • 方法详细信息

      • accept

        void accept​(long t)
        向要构建的流添加元素。
        Specified by:
        accept在接口 LongConsumer
        参数
        t - 输入参数
        异常
        IllegalStateException - 如果构建器已经转换到内置状态

      • add

        default LongStream.Builder add​(long t)
        向要构建的流添加元素。
        实现要求：
        默认实现的行为如下：
           accept(t) return this;
        参数
        t - 要添加的元素
        结果
        this建设者
        异常
        IllegalStateException - 如果构建器已经转换到内置状态

      • build

        LongStream build​()
        构建流，将此构建器转换为内置状态。 如果进一步尝试在构建器进入构建状态后对其进行操作，则抛出IllegalStateException 。
        结果
        内建流
        异常
        IllegalStateException - 如果构建器已经转换到内置状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Stream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface Stream<T>

  • 参数类型
    T - 流元素的类型
    All Superinterfaces:
    AutoCloseable ， BaseStream<T,Stream<T>>

    public interface Stream<T>
extends BaseStream<T,Stream<T>>
    支持顺序和并行聚合操作的一系列元素。 以下示例说明了使用Stream和IntStream的汇总操作：
       int sum = widgets.stream() .filter(w -> w.getColor() == RED) .mapToInt(w -> w.getWeight()) .sum();
    在这个例子中， widgets是一个Collection<Widget> 。 我们通过Collection.stream()创建一个Widget对象的流，过滤它以生成仅包含红色小部件的流，然后将其转换为表示每个红色小部件的权重的int值。 然后将该流相加以产生总重量。

    除了Stream ，这是对象引用的流，存在原语特为IntStream ， LongStream ，和DoubleStream ，所有这些都称为“流”和符合此处描述的特征和限制。

    为了执行计算，流operations被组合成流管道 。 流管线由源（其可以是阵列，集合，生成函数，I / O通道等），零个或多个中间操作 （其将流转换成另一个流，例如filter(Predicate) ）组成，以及终端操作 （产生结果或副作用，如count()或forEach(Consumer) ）。 流懒惰 源数据上的计算仅在终端操作启动时执行，源元素仅在需要时才被使用。

    允许流实现在优化结果的计算方面具有显着的纬度。 例如，如果流实现可以证明它不会影响计算结果，则流实现可以自由地从流流程中删除操作（或整个阶段），并且因此删除行为参数。 这意味着行为参数的副作用可能并不总是执行，除非另有规定（例如通过终端操作forEach和forEachOrdered ），否则不应被依赖。 （有关这种优化的具体示例，请参阅count()操作中记录的API说明。有关详细信息，请参阅流包文档的side-effects部分。）

    集合和流动，同时具有一些表面上的相似之处，具有不同的目标。 集合主要关注其元素的有效管理和访问。 相比之下，流不提供直接访问或操纵其元素的手段，而是关心声明性地描述其源和将在该源上进行聚合的计算操作。 但是，如果提供的流操作不提供所需的功能，则可以使用BaseStream.iterator()和BaseStream.spliterator()操作来执行受控遍历。

    流管道，如上面的“小部件”示例，可以被视为流源上的查询 。 除非源是明确设计用于并发修改（如ConcurrentHashMap ），否则在查询流源时可能会导致不可预测或错误的行为。

    大多数流操作接受描述用户指定行为的参数，例如上述示例中传递给mapToInt的lambda表达式w -> w.getWeight() 。 为了保持正确的行为，这些行为参数 ：

    • 必须是non-interfering （他们不修改流源）; 和
    • 在大多数情况下必须是stateless （它们的结果不应该依赖于在流管道的执行期间可能改变的任何状态）。

    这样的参数总是functional interface的例子 ，如Function ，并且通常是lambda表达式或方法引用。 除非另有说明，否则这些参数必须为非空值 。

    流只能运行（调用中间或终端流操作）一次。 这排除了例如“分叉”流，其中相同的源提供两条或多条流水线，或同一流的多遍。 流实现可能会导致IllegalStateException，如果它检测到流被重用。 然而，由于一些流操作可能返回其接收器而不是新的流对象，所以在所有情况下可能无法检测到重用。

    Streams具有BaseStream.close()方法并实现AutoCloseable 。 关闭后在流上操作会抛出IllegalStateException 。 大多数流实例在使用后实际上不需要关闭，因为它们由集合，数组或生成函数支持，这些功能不需要特殊的资源管理。 通常，只有源为IO通道的流，例如由Files.lines(Path)返回的流将需要关闭。 如果一个流确实需要关闭，那么它必须作为资源在资源或者类似的控件结构中打开，以确保在操作完成后立即被关闭。

    流管线可以顺序执行，也可以在parallel中执行。 此执行模式是流的属性。 流被创建为具有顺序或并行执行的初始选择。 （例如， Collection.stream()创建一个顺序流，并且Collection.parallelStream()创建一个并行的）。执行模式的选择可以由BaseStream.sequential()或BaseStream.parallel()方法修改，并且可以使用BaseStream.isParallel()方法进行查询。

    从以下版本开始：
    1.8
    另请参见：
    IntStream ， LongStream ， DoubleStream ， java.util.stream

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  Stream.Builder<T>
      一个可变的构建器，用于 Stream 。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean allMatch​(Predicate<? super T> predicate)
      返回此流的所有元素是否与提供的谓词匹配。
      boolean anyMatch​(Predicate<? super T> predicate)
      返回此流的任何元素是否与提供的谓词匹配。
      static <T> Stream.Builder<T> builder​()
      返回一个 Stream生成器。
      <R> R collect​(Supplier<R> supplier, BiConsumer<R,? super T> accumulator, BiConsumer<R,R> combiner)
      对此流的元素执行 mutable reduction操作。
      <R,A> R collect​(Collector<? super T,A,R> collector)
      使用 Collector对此流的元素执行 mutable reduction操作。
      static <T> Stream<T> concat​(Stream<? extends T> a, Stream<? extends T> b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      long count​()
      返回此流中的元素数。
      Stream<T> distinct​()
      返回由该流的不同元素（根据 Object.equals(Object) ）组成的流。
      default Stream<T> dropWhile​(Predicate<? super T> predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      static <T> Stream<T> empty​()
      返回空序列 Stream 。
      Stream<T> filter​(Predicate<? super T> predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      Optional<T> findAny​()
      返回Optional描述流的一些元件，或一个空Optional如果流是空的。
      Optional<T> findFirst​()
      返回Optional描述此流的第一个元素，或空Optional如果流是空的。
      <R> Stream<R> flatMap​(Function<? super T,? extends Stream<? extends R>> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      DoubleStream flatMapToDouble​(Function<? super T,? extends DoubleStream> mapper)
      返回一个 DoubleStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
      IntStream flatMapToInt​(Function<? super T,? extends IntStream> mapper)
      返回一个 IntStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
      LongStream flatMapToLong​(Function<? super T,? extends LongStream> mapper)
      返回一个 LongStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
      void forEach​(Consumer<? super T> action)
      对此流的每个元素执行操作。
      void forEachOrdered​(Consumer<? super T> action)
      如果流具有定义的遇到顺序，则以流的遇到顺序对该流的每个元素执行操作。
      static <T> Stream<T> generate​(Supplier<? extends T> s)
      返回无限顺序无序流，其中每个元素由提供的 Supplier生成。
      static <T> Stream<T> iterate​(T seed, Predicate<? super T> hasNext, UnaryOperator<T> next)
      返回通过将给定的 next函数迭代应用于初始元素 Stream产生的顺序 Stream ，其条件是满足给定的 hasNext谓词。
      static <T> Stream<T> iterate​(T seed, UnaryOperator<T> f)
      返回有序无限连续 Stream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      Stream<T> limit​(long maxSize)
      返回由此流的元素组成的流，截短长度不能超过 maxSize 。
      <R> Stream<R> map​(Function<? super T,? extends R> mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
      DoubleStream mapToDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
      IntStream mapToInt​(ToIntFunction<? super T> mapper)
      返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
      LongStream mapToLong​(ToLongFunction<? super T> mapper)
      返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
      Optional<T> max​(Comparator<? super T> comparator)
      根据提供的 Comparator返回此流的最大元素。
      Optional<T> min​(Comparator<? super T> comparator)
      根据提供的 Comparator返回此流的最小元素。
      boolean noneMatch​(Predicate<? super T> predicate)
      返回此流的元素是否与提供的谓词匹配。
      static <T> Stream<T> of​(T t)
      返回包含单个元素的序列 Stream 。
      static <T> Stream<T> of​(T... values)
      返回其元素是指定值的顺序排序流。
      static <T> Stream<T> ofNullable​(T t)
      返回包含单个元素的序列 Stream ，如果非空，则返回一个空的 Stream 。
      Stream<T> peek​(Consumer<? super T> action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
      Optional<T> reduce​(BinaryOperator<T> accumulator)
      使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值（如果有）的 Optional 。
      T reduce​(T identity, BinaryOperator<T> accumulator)
      使用提供的身份值和 associative累积函数对此流的元素执行 reduction ，并返回减小的值。
      <U> U reduce​(U identity, BiFunction<U,? super T,U> accumulator, BinaryOperator<U> combiner)
      使用提供的身份，积累和组合功能，对此流的元素执行 reduction 。
      Stream<T> skip​(long n)
      在丢弃流的第一个 n元素后，返回由该流的剩余元素组成的流。
      Stream<T> sorted​()
      返回由此流的元素组成的流，根据自然顺序排序。
      Stream<T> sorted​(Comparator<? super T> comparator)
      返回由该流的元素组成的流，根据提供的 Comparator进行排序。
      default Stream<T> takeWhile​(Predicate<? super T> predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
      Object[] toArray​()
      返回一个包含此流的元素的数组。
      <A> A[] toArray​(IntFunction<A[]> generator)
      使用提供的 generator函数返回一个包含此流的元素的数组，以分配返回的数组，以及分区执行或调整大小可能需要的任何其他数组。

      • Methods inherited from interface java.util.stream.BaseStream

        close, isParallel, iterator, onClose, parallel, sequential, spliterator, unordered

    • 方法详细信息

      • filter

        Stream<T> filter​(Predicate<? super T> predicate)
        返回由与此给定谓词匹配的此流的元素组成的流。

        这是一个intermediate operation 。

        参数
        predicate -一个 non-interfering ， stateless谓词应用到每个元素，以确定是否它应包含
        结果
        新的流

      • map

        <R> Stream<R> map​(Function<? super T,? extends R> mapper)
        返回由给定函数应用于此流的元素的结果组成的流。

        这是一个intermediate operation 。

        参数类型
        R - 新流的元素类型
        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToInt

        IntStream mapToInt​(ToIntFunction<? super T> mapper)
        返回一个IntStream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToLong

        LongStream mapToLong​(ToLongFunction<? super T> mapper)
        返回一个LongStream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • mapToDouble

        DoubleStream mapToDouble​(ToDoubleFunction<? super T> mapper)
        返回一个DoubleStream其中包含将给定函数应用于此流的元素的结果。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless函数应用到每个元件
        结果
        新的流

      • flatMap

        <R> Stream<R> flatMap​(Function<? super T,? extends Stream<? extends R>> mapper)
        返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。 每个映射的流在其内容被放入此流之后是closed 。 （如果映射的流为null ，则使用空的流。）

        这是一个intermediate operation 。

        API Note:
        flatMap()操作具有将一对多变换应用于流的元素，然后将所得到的元素平坦化为新流的效果。

        例子。

        如果orders是采购订单流，并且每个采购订单都包含订单项集合，则以下产生包含所有订单中所有订单项的流：

           orders.flatMap(order -> order.getLineItems().stream())...

        如果path是文件的路径，则以下内容将生成包含在该文件中的words的流：

           Stream<String> lines = Files.lines(path, StandardCharsets.UTF_8); Stream<String> words = lines.flatMap(line -> Stream.of(line.split(" +")));
        传递给flatMap的mapper函数将一行（使用简单的正则表达式）分割成一个单词数组，然后从该数组中创建一个单词。
        参数类型
        R - 新流的元素类型
        参数
        mapper -一个 non-interfering ， stateless功能应用到其产生新的值的流的每个元素
        结果
        新的流

      • flatMapToInt

        IntStream flatMapToInt​(Function<? super T,? extends IntStream> mapper)
        返回一个IntStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。 每个映射的流在其内容被放入此流之后是closed 。 （如果映射的流为null ，则使用空的流。）

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless功能应用到其产生新的值的流的每个元素
        结果
        新的流
        另请参见：
        flatMap(Function)

      • flatMapToLong

        LongStream flatMapToLong​(Function<? super T,? extends LongStream> mapper)
        返回一个LongStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。 每个映射的流在其内容被放入此流之后是closed 。 （如果映射的流为null ，则使用空的流。）

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless功能应用到其产生新的值的流的每个元素
        结果
        新的流
        另请参见：
        flatMap(Function)

      • flatMapToDouble

        DoubleStream flatMapToDouble​(Function<? super T,? extends DoubleStream> mapper)
        返回一个DoubleStream ，其结果是将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容。 每个映射的流在其内容放入此流后为closed 。 （如果映射的流是null ，则使用空的流）。

        这是一个intermediate operation 。

        参数
        mapper -一个 non-interfering ， stateless功能应用到其产生新的值的流的每个元素
        结果
        新的流
        另请参见：
        flatMap(Function)

      • distinct

        Stream<T> distinct​()
        返回由该流的不同元素（根据Object.equals(Object) ）组成的流。

        对于有序流，选择不同的元素是稳定的（对于重复的元素，首先在遇到顺序中出现的元素被保留。）对于无序流，不能保证稳定性。

        这是一个stateful intermediate operation 。

        API Note:
        在并行管道中保持distinct()稳定性相对较高（要求操作充当完全障碍，具有实质的缓冲开销），并且通常不需要稳定性。 如果您的情况允许，则使用无序流源（如generate(Supplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线中distinct()执行效率显着提高。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与distinct()在并行管线，在切换到的顺序执行与BaseStream.sequential()可以提高性能。
        结果
        新的流

      • sorted

        Stream<T> sorted​()
        返回由此流的元素组成的流，根据自然顺序排序。 如果此流的元素不是Comparable ，则在执行终端操作时可能会抛出java.lang.ClassCastException 。

        对于有序流，排序稳定。 对于无序的流，不能保证稳定性。

        这是一个stateful intermediate operation 。

        结果
        新的流

      • sorted

        Stream<T> sorted​(Comparator<? super T> comparator)
        返回由该流的元素组成的流，根据提供的Comparator进行排序。

        对于有序流，排序稳定。 对于无序的流，不能保证稳定性。

        这是一个stateful intermediate operation 。

        参数
        comparator -一个 non-interfering ， stateless Comparator到用于比较流元素
        结果
        新的流

      • peek

        Stream<T> peek​(Consumer<? super T> action)
        返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。

        这是一个intermediate operation 。

        对于并行流管线，可以在上游操作的任何时间和任何线程中调用该元素可用的动作。 如果操作修改共享状态，则负责提供所需的同步。

        API Note:
        该方法主要用于支持调试，您希望在流程中流过某个特定点时查看元素：
           Stream.of("one", "two", "three", "four") .filter(e -> e.length() > 3) .peek(e -> System.out.println("Filtered value: " + e)) .map(String::toUpperCase) .peek(e -> System.out.println("Mapped value: " + e)) .collect(Collectors.toList());

        在情况下，流实现能够优化掉生产一些或所有的元件（如与像短路操作findFirst ，或在所描述的示例count() ），动作将不被调用这些元素。

        参数
        action - 一个 non-interfering要从流中消耗的元素执行的操作
        结果
        新的流

      • limit

        Stream<T> limit​(long maxSize)
        返回由此流的元素组成的流，截短长度不要超过maxSize 。

        这是一个short-circuiting stateful intermediate operation 。

        API Note:
        虽然limit()通常是在顺序流管线上的廉价操作，但是在有序并行流水线上可能是相当昂贵的，特别是对于maxSize大值，因为limit(n)被限制为不仅返回任何n个元素，而且在遇到顺序中的前n个元素。 使用无序流源（例如generate(Supplier) ）或去除所述排序约束与BaseStream.unordered()可能导致显著加速比limit()在并行管线，如果情况许可的语义。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与limit()在并行管线，在切换到的顺序执行与BaseStream.sequential()可以提高性能。
        参数
        maxSize - 流应该限制的元素数量
        结果
        新的流
        异常
        IllegalArgumentException - 如果 maxSize为负数

      • skip

        Stream<T> skip​(long n)
        在丢弃流的第一个n元素后，返回由该流的剩余元素组成的流。 如果此流包含少于n元素，那么将返回一个空流。

        这是一个stateful intermediate operation 。

        API Note:
        虽然skip()通常是在顺序流管线上的廉价操作，但是在有序的并行流水线上可能是相当昂贵的，特别是对于n大值，因为skip(n)被限制为不仅跳过任何n个元素，而且在遇到顺序中的前n个元素。 使用无序流源（例如generate(Supplier) ）或去除所述排序约束与BaseStream.unordered()可能导致显著加速比skip()在并行管线，如果情况许可的语义。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与skip()在并行管线，在切换到的顺序执行与BaseStream.sequential()可以提高性能。
        参数
        n - 要跳过的主要元素的数量
        结果
        新的流
        异常
        IllegalArgumentException - 如果 n为负数

      • takeWhile

        default Stream<T> takeWhile​(Predicate<? super T> predicate)
        如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。 否则返回，如果该流是无序的，则由从与该给定谓词匹配的该流中取得的元素的子集组成的流。

        如果该流被排序，则最长的前缀是与给定谓词匹配的该流的连续的元素序列。 序列的第一个元素是此流的第一个元素，并且紧跟该序列的最后一个元素的元素与给定谓词不匹配。

        如果该流是无序的，并且该流的一些（但不是全部）元素与给定的谓词匹配，则该操作的行为是非确定性的; 可以自由地采取匹配元素的任何子集（包括空集）。

        独立于该流是否被排序或无序，如果此流的所有元素与给定谓词匹配，则此操作将采用所有元素（结果与输入相同），或者如果流的元素与给定谓词匹配，则没有元素被采取（结果是一个空的流）。

        这是一个short-circuiting stateful intermediate operation 。

        API Note:
        虽然takeWhile()通常是顺序流管线上的廉价操作，但是在有序并行流水线上可能相当昂贵，因为操作被限制为不仅返回任何有效的前缀，而且返回遇到顺序中的元素的最长前缀。 使用无序流源（例如generate(Supplier) ）或去除所述排序约束与BaseStream.unordered()可能导致显著加速比takeWhile()在并行管线，如果情况许可的语义。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与takeWhile()在并行管线，在切换到的顺序执行与BaseStream.sequential()可以提高性能。
        实现要求：
        默认实现获取此流的spliterator ，包装该分割器，以便在遍历时支持此操作的语义，并返回与包装剪辑器相关联的新流。 返回的流保留此流的执行特性（即按照BaseStream.isParallel()进行并行或顺序执行），但是封装的spliterator可能选择不支持拆分。 当返回的流关闭时，将调用返回的流和此流的关闭处理程序。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于元素，以确定元素的最长前缀。
        结果
        新的流
        从以下版本开始：
        9

      • dropWhile

        default Stream<T> dropWhile​(Predicate<? super T> predicate)
        如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。 否则返回，如果该流是无序的，则在丢弃与给定谓词匹配的元素的子集之后，返回由该流的剩余元素组成的流。

        如果该流被排序，则最长的前缀是与给定谓词匹配的该流的连续的元素序列。 序列的第一个元素是此流的第一个元素，并且紧跟该序列的最后一个元素的元素与给定谓词不匹配。

        如果该流是无序的，并且该流的一些（但不是全部）元素与给定的谓词匹配，则该操作的行为是非确定性的; 可以放置匹配元素的任何子集（包括空集合）。

        独立于该流是否被排序或无序，如果此流的所有元素与给定谓词匹配，则此操作将删除所有元素（结果为空流），或者如果流中的元素与给定谓词匹配，则不会删除元素（结果与输入相同）。

        这是一个stateful intermediate operation 。

        API Note:
        虽然dropWhile()通常是顺序流管线上的便宜操作，但是在有序并行流水线上可能相当昂贵，因为操作被限制为不仅返回任何有效的前缀，而且返回遇到顺序中元素的最长前缀。 如果您的情况允许，则使用无序流源（如generate(Supplier) ）或使用BaseStream.unordered()删除排序约束可能会导致并行流水线显着加速dropWhile() 。 如果具有遭遇顺序的一致性是必须的，并且遇到性能或存储器利用率差与dropWhile()在并行管线，在切换到的顺序执行与BaseStream.sequential()可以提高性能。
        实现要求：
        默认实现获取此流的spliterator ，包装该分隔符，以便在遍历时支持此操作的语义，并返回与包装拼接器相关联的新流。 返回的流保留该流的执行特性（即根据BaseStream.isParallel()并行或顺序执行），但是封装的分割器可能选择不支持拆分。 当返回的流关闭时，将调用返回的流和此流的关闭处理程序。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于元素，以确定元素的最长前缀。
        结果
        新的流
        从以下版本开始：
        9

      • forEach

        void forEach​(Consumer<? super T> action)
        对此流的每个元素执行操作。

        这是一个terminal operation 。

        这个操作的行为显然是不确定的。 对于并行流管道，此操作不能保证遵守流的遇到顺序，因为这样做会牺牲并行性的好处。 对于任何给定的元素，动作可以在图书馆选择的任何时间和任何线索中执行。 如果操作访问共享状态，则负责提供所需的同步。

        参数
        action - 要对元素执行的 non-interfering操作

      • forEachOrdered

        void forEachOrdered​(Consumer<? super T> action)
        如果流具有定义的遇到顺序，则以流的遇到顺序对该流的每个元素执行操作。

        这是一个terminal operation 。

        此操作一次处理元素，如果存在，则按照遇到的顺序进行处理。 执行该动作为一个元件happens-before执行用于后续元素的动作，但对于任何给定的元素，动作可以以任何线程库选择来执行。

        参数
        action - 要对元素执行的 non-interfering操作
        另请参见：
        forEach(Consumer)

      • toArray

        Object[] toArray​()
        返回一个包含此流的元素的数组。

        这是一个terminal operation 。

        结果
        一个包含此流的元素的数组

      • toArray

        <A> A[] toArray​(IntFunction<A[]> generator)
        使用提供的generator函数返回一个包含此流的元素的数组，以分配返回的数组，以及分区执行或调整大小可能需要的任何其他数组。

        这是一个terminal operation 。

        API Note:
        发生器函数采用一个整数，它是所需数组的大小，并产生一个所需大小的数组。 这可以用数组构造函数引用简明扼要地表达：
           Person[] men = people.stream() .filter(p -> p.getGender() == MALE) .toArray(Person[]::new);
        参数类型
        A - 结果数组的元素类型
        参数
        generator - 产生所需类型和所提供长度的新数组的函数
        结果
        一个包含此流中的元素的数组
        异常
        ArrayStoreException - 如果从数组生成器返回的数组的运行时类型不是此流中每个元素的运行时类型的超类型

      • reduce

        T reduce​(T identity,
         BinaryOperator<T> accumulator)
        使用提供的身份值和associative累积功能对此流的元素执行reduction ，并返回减小的值。 这相当于：
           T result = identity; for (T element : this stream) result = accumulator.apply(result, element) return result;
        但不限于顺序执行。

        identity值必须是累加器函数的标识。 这意味着，对于所有t ， accumulator.apply(identity, t)等于t 。 accumulator功能必须是associative功能。

        这是一个terminal operation 。

        API Note:
        总和，最小，最大，平均和字符串连接都是减少的特殊情况。 一个数字流可以表示为：
           Integer sum = integers.reduce(0, (a, b) -> a+b);
        要么：
           Integer sum = integers.reduce(0, Integer::sum);

        尽管与简单地将循环中的总体变量相比，这可能看起来更为迂回的方式进行，但减少操作更平稳地并行化，而不需要额外的同步，并大大降低了数据竞争的风险。

        参数
        identity - 累积函数的身份值
        accumulator -一个 associative ， non-interfering ， stateless功能组合两个值
        结果
        减少的结果

      • reduce

        Optional<T> reduce​(BinaryOperator<T> accumulator)
        使用associative累积函数对此流的元素执行reduction ，并返回描述减小值（如果有）的Optional 。 这相当于：
           boolean foundAny = false; T result = null; for (T element : this stream) { if (!foundAny) { foundAny = true; result = element; } else result = accumulator.apply(result, element); } return foundAny ? Optional.of(result) : Optional.empty();
        但不限于顺序执行。

        accumulator功能必须是associative功能。

        这是一个terminal operation 。

        参数
        accumulator -一个 associative ， non-interfering ， stateless功能组合两个值
        结果
        一个Optional描述了减少的结果
        异常
        NullPointerException - 如果减少的结果为空
        另请参见：
        reduce(Object, BinaryOperator) ， min(Comparator) ， max(Comparator)

      • reduce

        <U> U reduce​(U identity,
             BiFunction<U,? super T,U> accumulator,
             BinaryOperator<U> combiner)
        使用提供的身份，积累和组合功能，对此流的元素执行reduction 。 这相当于：
           U result = identity; for (T element : this stream) result = accumulator.apply(result, element) return result;
        但不限于顺序执行。

        identity值必须是组合器功能的标识。 这意味着，对于所有u ， combiner(identity, u)等于u 。 此外， combiner功能必须兼容accumulator功能; 对于所有u和t ，以下必须持有：

           combiner.apply(u, accumulator.apply(identity, t)) == accumulator.apply(u, t)

        这是一个terminal operation 。

        API Note:
        使用这种形式的许多减少可以通过map和reduce操作的显式组合来更简单地表示。 accumulator函数充当融合映射器和累加器，这有时比单独的映射和缩减更有效，例如当知道先前减小的值允许您避免某些计算时。
        参数类型
        U - 结果的类型
        参数
        identity - 组合器功能的标识值
        accumulator -一个 associative ， non-interfering ， stateless功能用于将一个额外的元件到结果
        combiner -一个 associative ， non-interfering ， stateless功能用于组合两个值，它必须与蓄能器功能兼容
        结果
        减少的结果
        另请参见：
        reduce(BinaryOperator) ， reduce(Object, BinaryOperator)

      • collect

        <R> R collect​(Supplier<R> supplier,
              BiConsumer<R,? super T> accumulator,
              BiConsumer<R,R> combiner)
        对此流的元素执行mutable reduction操作。 可变减少是减少值是可变结果容器的缩减值，例如ArrayList ，并且通过更新结果的状态而不是通过替换结果来合并元素。 这产生的结果相当于：
           R result = supplier.get(); for (T element : this stream) accumulator.accept(result, element); return result;

        像reduce(Object, BinaryOperator)一样， collect操作可以并行化，无需额外的同步。

        这是一个terminal operation 。

        API Note:
        JDK中有很多现有的类，其签名非常适合与方法引用一起使用，作为collect()参数。 例如，以下将会将字符串累加到一个ArrayList ：
           List<String> asList = stringStream.collect(ArrayList::new, ArrayList::add, ArrayList::addAll);

        以下将使用一串字符串并将它们连接成一个字符串：

           String concat = stringStream.collect(StringBuilder::new, StringBuilder::append, StringBuilder::append) .toString();
        参数类型
        R - 可变结果容器的类型
        参数
        supplier - 创建一个新的可变结果容器的函数。 对于并行执行，可以多次调用此函数，并且每次都必须返回一个新的值。
        accumulator -一个 associative ， non-interfering ， stateless功能必须的元件折叠成的结果容器。
        combiner -一个associative ， non-interfering ， stateless函数接受两个部分结果的容器和将它们合并，这必须与累加器功能兼容。 组合器功能必须将第二个结果容器中的元素折叠到第一个结果容器中。
        结果
        减少的结果

      • collect

        <R,A> R collect​(Collector<? super T,A,R> collector)
        使用Collector对此流的元素执行mutable reduction操作。 A Collector将用作参数的函数封装为collect(Supplier, BiConsumer, BiConsumer) ，从而允许重用集合策略和组合收集操作（如多级分组或分区）。

        如果流是并行的，并且Collector是concurrent ，并且流是无序的或收集器是unordered ，则将执行并发减少（有关并发减少的细节，请参阅Collector ）。

        这是一个terminal operation 。

        当并行执行时，可以实例化，填充和合并多个中间结果，以便保持可变数据结构的隔离。 因此，即使与非线程安全的数据结构（例如ArrayList ）并行执行，并行还原也不需要额外的同步。

        API Note:
        以下将将字符串累加到一个ArrayList中：
           List<String> asList = stringStream.collect(Collectors.toList());

        以下将按城市分类Person对象：

           Map<String, List<Person>> peopleByCity = personStream.collect(Collectors.groupingBy(Person::getCity));

        以下将按状态和城市分类Person对象，将两个Collector连接在一起：

           Map<String, Map<String, List<Person>>> peopleByStateAndCity = personStream.collect(Collectors.groupingBy(Person::getState, Collectors.groupingBy(Person::getCity)));
        参数类型
        R - 结果的类型
        A -所述的中间累积型 Collector
        参数
        collector - 描述减少的 Collector
        结果
        减少的结果
        另请参见：
        collect(Supplier, BiConsumer, BiConsumer) ， Collectors

      • min

        Optional<T> min​(Comparator<? super T> comparator)
        根据提供的Comparator返回此流的最小元素。 这是一个reduction的特例 。

        这是一个terminal operation 。

        参数
        comparator -一个 non-interfering ， stateless Comparator比较该流的元素
        结果
        一个 Optional描述该流的一个空的最小元件，或 Optional如果流是空
        异常
        NullPointerException - 如果最小元素为空

      • max

        Optional<T> max​(Comparator<? super T> comparator)
        根据提供的Comparator返回此流的最大元素。 这是一个reduction的特例 。

        这是一个terminal operation 。

        参数
        comparator -一个 non-interfering ， stateless Comparator比较该流的元素
        结果
        一个 Optional描述此流的最大元素，或空 Optional如果流是空
        异常
        NullPointerException - 如果最大元素为空

      • count

        long count​()
        返回此流中的元素数。 这是一个reduction的特殊情况，相当于：
           return mapToLong(e -> 1L).sum();

        这是一个terminal operation 。

        API Note:
        如果能够直接从流源计算计数，则实现可以选择不执行流管线（顺序地或并行地）。 在这种情况下，不会遍历源元素，并且不会评估中间操作。 除了无害的情况（如调试），强烈不鼓励具有副作用的行为参数可能会受到影响。 例如，考虑以下流：
           List<String> l = Arrays.asList("A", "B", "C", "D"); long count = l.stream().peek(System.out::println).count();
        流源（ List覆盖的元素数量是已知的，中间操作（ peek ）不会从流中注入或移除元素（如flatMap或filter操作的情况）。 因此，计数是List的大小，并且不需要执行管道，并且作为副作用，打印列表元素。
        结果
        这个流中元素的数量

      • anyMatch

        boolean anyMatch​(Predicate<? super T> predicate)
        返回此流的任何元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回false ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于某些x P（x））的谓词的 存在量化 。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的任何元素匹配提供的谓词，否则为 false

      • allMatch

        boolean allMatch​(Predicate<? super T> predicate)
        返回此流的所有元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回true ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于所有x P（x））的谓词的通用量化 。 如果流是空的，量化据说是空洞地满意 ，始终是true （不管的P（X））。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流的所有元素匹配提供的谓词或流为空，否则为 false

      • noneMatch

        boolean noneMatch​(Predicate<? super T> predicate)
        返回此流的元素是否与提供的谓词匹配。 如果不需要确定结果，则不能评估所有元素上的谓词。 如果流为空，则返回true ，并且不评估谓词。

        这是一个short-circuiting terminal operation 。

        API Note:
        该方法评估了流的元素（对于所有x〜P（x））的否定谓词的通用量化 。 如果流是空的，那么量化被认为是空虚的，并且始终是true ，不论P（x）如何。
        参数
        predicate -一个 non-interfering ， stateless谓词适用于该流的元素
        结果
        true如果流中没有元素匹配提供的谓词或流为空，否则为 false

      • findFirst

        Optional<T> findFirst​()
        返回Optional描述此流的第一个元素，或空Optional如果流是空的。 如果流没有遇到顺序，则可能会返回任何元素。

        这是一个short-circuiting terminal operation 。

        结果
        一个 Optional描述此流的第一个元素，或空 Optional如果流是空
        异常
        NullPointerException - 如果选择的元素为空

      • findAny

        Optional<T> findAny​()
        返回Optional描述流的一些元件，或一个空Optional如果流是空的。

        这是一个short-circuiting terminal operation 。

        这个操作的行为显然是不确定的; 可以自由选择流中的任何元素。 这是为了允许并行操作中的最大性能; 成本是同一来源上的多次调用可能不会返回相同的结果。 （如果需要稳定的结果，请改用findFirst()。 ）

        结果
        一个 Optional描述该流的一些元件，或一个空 Optional如果流是空
        异常
        NullPointerException - 如果选择的元素为空
        另请参见：
        findFirst()

      • builder

        static <T> Stream.Builder<T> builder​()
        返回一个 Stream的构建器。
        参数类型
        T - 元素的类型
        结果
        流构建器

      • empty

        static <T> Stream<T> empty​()
        返回空序列 Stream 。
        参数类型
        T - 流元素的类型
        结果
        一个空的顺序流

      • of

        static <T> Stream<T> of​(T t)
        返回包含单个元素的序列 Stream 。
        参数类型
        T - 流元素的类型
        参数
        t - 单个元素
        结果
        单例顺序流

      • ofNullable

        static <T> Stream<T> ofNullable​(T t)
        返回包含单个元素的序列 Stream ，如果非空，则返回一个空的 Stream 。
        参数类型
        T - 流元素的类型
        参数
        t - 单一元素
        结果
        如果指定的元素为非空，则具有单个元素的流，否则为空流
        从以下版本开始：
        9

      • of

        @SafeVarargs
static <T> Stream<T> of​(T... values)
        返回其元素是指定值的顺序排序流。
        参数类型
        T - 流元素的类型
        参数
        values - 新流的元素
        结果
        新的流

      • iterate

        static <T> Stream<T> iterate​(T seed,
                             UnaryOperator<T> f)
        返回有序无限连续Stream由函数的迭代应用产生f到初始元素seed ，产生Stream由seed ， f(seed) ， f(f(seed))等

        第一元件（位置0在） Stream将是提供seed 。 对于n > 0 ，位置n处的元素将是将函数f应用于位置n - 1的元素的n - 1 。

        施加的作用f为一个元件happens-before施加的作用f用于随后的元件。 对于任何给定的元素，动作可以在库选择的任何线程中执行。

        参数类型
        T - 流元素的类型
        参数
        seed - 初始元素
        f - 要应用于前一个元素以生成新元素的函数
        结果
        一个新的顺序 Stream

      • iterate

        static <T> Stream<T> iterate​(T seed,
                             Predicate<? super T> hasNext,
                             UnaryOperator<T> next)
        返回通过将给定的next函数迭代应用于初始元素Stream产生的顺序Stream ，其条件是满足给定的hasNext谓词。 一旦hasNext谓词返回false，流即终止。

        Stream.iterate应该产生与相应的for-loop相同的元素序列：

           for (T index=seed; hasNext.test(index); index = next.apply(index)) { ... }

        如果hasNext谓词不持有种子值，则结果序列可能为空。 否则第一个元素将是提供的seed值，下一个元素（如果存在）将是将next函数应用于seed值的结果，等等，直到hasNext谓词指示流应该终止。

        将hasNext谓词应用于元素happens-before next功能应用于该元素的动作。 在为一个元素应用next函数的动作发生在为后续元素应用hasNext谓词的动作之前 。 对于任何给定的元素，可以在库选择的任何线程中执行一个动作。

        参数类型
        T - 流元素的类型
        参数
        seed - 初始元素
        hasNext - 应用于元素以确定流何时终止的谓词。
        next - 要应用于前一个元素以生成新元素的函数
        结果
        一个新的顺序 Stream
        从以下版本开始：
        9

      • generate

        static <T> Stream<T> generate​(Supplier<? extends T> s)
        返回无限顺序无序流，其中每个元素由提供的Supplier生成。 这适合于产生恒定流，随机元素流等
        参数类型
        T - 流元素的类型
        参数
        s - Supplier的生成元素
        结果
        一个新的无限顺序无序 Stream

      • concat

        static <T> Stream<T> concat​(Stream<? extends T> a,
                            Stream<? extends T> b)
        创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。 如果两个输入流都被排序，则生成的流被排序，并且如果任何一个输入流是并行的，则并行。 当结果流关闭时，调用两个输入流的关闭处理程序。
        Implementation Note:
        在重复连接构建流时要小心。 访问深层级流的元素可能导致深度的调用链，甚至可能导致StackOverflowError 。

        对返回流的顺序/并行执行模式的后续更改不能保证传播到输入流。

        参数类型
        T - 流元素的类型
        参数
        a - 第一个流
        b - 第二个流
        结果
        两个输入流的并置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Stream.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Interface Stream.Builder<T>

  • 参数类型
    T - 流元素的类型
    All Superinterfaces:
    Consumer<T>
    Enclosing interface:
    Stream < T >

    public static interface Stream.Builder<T>
extends Consumer<T>
    一个可变的构建器，用于Stream 。 这允许创建的Stream通过单独发电元件，并将它们添加到Builder （而没有来自使用复制的开销ArrayList作为临时缓冲器）。

    流构建器具有生命周期，其从构建阶段开始，在该阶段期间可以添加元素，然后转换到内置阶段，之后可能不添加元素。 内建阶段从调用build()方法开始，它创建一个有序的Stream其元素是添加到流构建器的元素，按照它们的添加顺序。

    从以下版本开始：
    1.8
    另请参见：
    Stream.builder()

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void accept​(T t)
      向要构建的流添加元素。
      default Stream.Builder<T> add​(T t)
      向要构建的流添加元素。
      Stream<T> build​()
      构建流，将此构建器转换为内置状态。

      • Methods inherited from interface java.util.function.Consumer

        andThen

    • 方法详细信息

      • accept

        void accept​(T t)
        向要构建的流添加元素。
        Specified by:
        accept在接口 Consumer<T>
        参数
        t - 输入参数
        异常
        IllegalStateException - 如果构建器已经转换到内置状态

      • add

        default Stream.Builder<T> add​(T t)
        向要构建的流添加元素。
        实现要求：
        默认实现的行为如下：
           accept(t) return this;
        参数
        t - 要添加的元素
        结果
        this建设者
        异常
        IllegalStateException - 如果构建器已经转换到内置状态

      • build

        Stream<T> build​()
        构建流，将此构建器转换为内置状态。 如果在构建器进入内置状态后进一步尝试对构建器进行操作，则抛出一个IllegalStateException 。
        结果
        内建流
        异常
        IllegalStateException - 如果构建器已经转换到内置状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StreamSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.stream

Class StreamSupport

  • java.lang.Object
    • java.util.stream.StreamSupport

  • public final class StreamSupport
extends Object
    用于创建和操纵流的低级实用程序方法。

    这个类主要用于呈现数据结构流视图的图书馆作家; 大多数针对最终用户的静态流方法都在各种Stream类中。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static DoubleStream doubleStream​(Supplier<? extends Spliterator.OfDouble> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 DoubleStream从 Supplier的 Spliterator.OfDouble 。
      static DoubleStream doubleStream​(Spliterator.OfDouble spliterator, boolean parallel)
      创建一个新的串行或并行 DoubleStream从 Spliterator.OfDouble 。
      static IntStream intStream​(Supplier<? extends Spliterator.OfInt> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 IntStream从 Supplier的 Spliterator.OfInt 。
      static IntStream intStream​(Spliterator.OfInt spliterator, boolean parallel)
      创建一个新的串行或并行 IntStream从 Spliterator.OfInt 。
      static LongStream longStream​(Supplier<? extends Spliterator.OfLong> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 LongStream从 Supplier的 Spliterator.OfLong 。
      static LongStream longStream​(Spliterator.OfLong spliterator, boolean parallel)
      创建一个新的串行或并行 LongStream从 Spliterator.OfLong 。
      static <T> Stream<T> stream​(Supplier<? extends Spliterator<T>> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 Stream从 Supplier的 Spliterator 。
      static <T> Stream<T> stream​(Spliterator<T> spliterator, boolean parallel)
      创建一个新的串行或并行 Stream从 Spliterator 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • stream

        public static <T> Stream<T> stream​(Spliterator<T> spliterator,
                                   boolean parallel)
        创建一个新的串行或并行Stream从Spliterator 。

        在流量管道的终端运行开始后，拼接器仅被遍历，分割或查询估计大小。

        强烈建议拼接器报告IMMUTABLE或CONCURRENT的特征，或late-binding 。 否则，应使用stream(java.util.function.Supplier, int, boolean)来减少与源的潜在干扰的范围。 有关详细信息，请参阅Non-Interference 。

        参数类型
        T - 流元素的类型
        参数
        spliterator - 描述流元素的 Spliterator
        parallel - 如果是true则返回的流是并行流; 如果false返回的流是顺序流。
        结果
        一个新的顺序或并行 Stream

      • stream

        public static <T> Stream<T> stream​(Supplier<? extends Spliterator<T>> supplier,
                                   int characteristics,
                                   boolean parallel)
        创建一个新的顺序或并行Stream从Supplier的Spliterator 。

        Supplier.get()方法将在供应商上调用不超过一次，并且只有在流管道的终端运行开始之后。

        该报告的特性spliterators IMMUTABLE或者CONCURRENT ，或者是late-binding ，很可能更有效地使用stream(java.util.Spliterator, boolean)代替。

        以这种形式使用Supplier提供了一种间接级别，可以减少与源的潜在干扰的范围。 由于供应商仅在终端操作开始后被调用，所以在终端操作开始时对源的任何修改都反映在流结果中。 详见Non-Interference 。

        参数类型
        T - 流元素的类型
        参数
        supplier - a Supplier的 Spliterator
        characteristics - 所提供的Spliterator特性Spliterator 。 特性必须等于supplier.get().characteristics() ，否则当终端操作开始时可能会发生未定义的行为。
        parallel - 如果是true则返回的流是并行流; 如果false返回的流是顺序流。
        结果
        一个新的顺序或并行 Stream
        另请参见：
        stream(java.util.Spliterator, boolean)

      • intStream

        public static IntStream intStream​(Spliterator.OfInt spliterator,
                                  boolean parallel)
        创建一个新的串行或并行IntStream从Spliterator.OfInt 。

        在流量管道的终端运行开始后，拼接器仅被遍历，分割或查询估计大小。

        强烈建议拼接器报告IMMUTABLE或CONCURRENT的特征，或late-binding 。 否则，应使用intStream(java.util.function.Supplier, int, boolean)来减少与源的潜在干扰的范围。 详情请参阅Non-Interference 。

        参数
        spliterator - 描述流元素的 Spliterator.OfInt
        parallel - 如果是true则返回的流是并行流; 如果false返回的流是顺序流。
        结果
        一个新的顺序或并行 IntStream

      • intStream

        public static IntStream intStream​(Supplier<? extends Spliterator.OfInt> supplier,
                                  int characteristics,
                                  boolean parallel)
        创建一个新的顺序或并行IntStream从Supplier的Spliterator.OfInt 。

        Supplier.get()方法将在供应商上调用不超过一次，只有在流管道的终端运行开始之后。

        该报告的特性spliterators IMMUTABLE或者CONCURRENT ，或者是late-binding ，很可能更有效地使用intStream(java.util.Spliterator.OfInt, boolean)代替。

        以这种形式使用Supplier提供了一种间接级别，可以减少与源的潜在干扰的范围。 由于供应商仅在终端操作开始后被调用，所以在终端操作开始时对源的任何修改都反映在流结果中。 详见Non-Interference 。

        参数
        supplier - a Supplier的 Spliterator.OfInt
        characteristics - 提供的Spliterator特性Spliterator.OfInt 。 特性必须等于supplier.get().characteristics() ，否则当终端操作开始时可能会发生未定义的行为。
        parallel - 如果是true则返回的流是并行流; 如果false返回的流是顺序流。
        结果
        一个新的顺序或并行 IntStream
        另请参见：
        intStream(java.util.Spliterator.OfInt, boolean)

      • longStream

        public static LongStream longStream​(Spliterator.OfLong spliterator,
                                    boolean parallel)
        创建一个新的串行或并行LongStream从Spliterator.OfLong 。

        在流量管道的终端运行开始后，拼接器仅被遍历，分割或查询估计大小。

        强烈建议拼接器报告IMMUTABLE或CONCURRENT的特征，或late-binding 。 否则，应使用longStream(java.util.function.Supplier, int, boolean)来减少与源的潜在干扰的范围。 详见Non-Interference 。

        参数
        spliterator - 描述流元素的 Spliterator.OfLong
        parallel - 如果是true则返回的流是并行流; 如果false返回的流是顺序流。
        结果
        一个新的顺序或并行 LongStream

      • longStream

        public static LongStream longStream​(Supplier<? extends Spliterator.OfLong> supplier,
                                    int characteristics,
                                    boolean parallel)
        创建一个新的顺序或并行LongStream从Supplier的Spliterator.OfLong 。

        Supplier.get()方法将在供应商上调用不超过一次，并且只有在流管道的终端运行开始之后。

        该报告的特性spliterators IMMUTABLE或者CONCURRENT ，或者是late-binding ，很可能更有效地使用longStream(java.util.Spliterator.OfLong, boolean)代替。

        以这种形式使用Supplier提供了一种间接级别，可以减少与源的潜在干扰的范围。 由于供应商仅在终端操作开始后被调用，所以在终端操作开始时对源的任何修改都反映在流结果中。 详情请参阅Non-Interference 。

        参数
        supplier - a Supplier的 Spliterator.OfLong
        characteristics - 所提供的Spliterator.OfLong特性Spliterator.OfLong 。 特性必须等于supplier.get().characteristics() ，否则当终端操作开始时可能会发生未定义的行为。
        parallel - 如果是true则返回的流是并行流; 如果false返回的流是顺序流。
        结果
        一个新的顺序或并行 LongStream
        另请参见：
        longStream(java.util.Spliterator.OfLong, boolean)

      • doubleStream

        public static DoubleStream doubleStream​(Spliterator.OfDouble spliterator,
                                        boolean parallel)
        创建一个新的串行或并行DoubleStream从Spliterator.OfDouble 。

        在流量管道的终端运行开始后，拼接器仅被遍历，分割或查询估计大小。

        强烈建议拼接器报告IMMUTABLE或CONCURRENT的特征，或late-binding 。 否则，应使用doubleStream(java.util.function.Supplier, int, boolean)来减少与源的潜在干扰的范围。 详情请参阅Non-Interference 。

        参数
        spliterator - 描述流元素的 Spliterator.OfDouble
        parallel - 如果是true则返回的流是并行流; 如果false返回的流是顺序流。
        结果
        一个新的顺序或并行 DoubleStream

      • doubleStream

        public static DoubleStream doubleStream​(Supplier<? extends Spliterator.OfDouble> supplier,
                                        int characteristics,
                                        boolean parallel)
        创建一个新的顺序或并行DoubleStream从Supplier的Spliterator.OfDouble 。

        Supplier.get()方法将在供应商上调用不超过一次，并且只有在流管道的终端运行开始之后。

        该报告的特性spliterators IMMUTABLE或者CONCURRENT ，或者是late-binding ，很可能更有效地使用doubleStream(java.util.Spliterator.OfDouble, boolean)代替。

        以这种形式使用Supplier提供了一种间接级别，可以减少与源的潜在干扰的范围。 由于供应商仅在终端操作开始后被调用，所以在终端操作开始时对源的任何修改都反映在流结果中。 详情请参阅Non-Interference 。

        参数
        supplier - A Supplier的 Spliterator.OfDouble
        characteristics - 所提供的Spliterator.OfDouble特性Spliterator.OfDouble 。 特性必须等于supplier.get().characteristics() ，否则当终端操作开始时可能会发生未定义的行为。
        parallel - 如果是true则返回的流是并行流; 如果false返回的流是顺序流。
        结果
        一个新的顺序或并行 DoubleStream
        另请参见：
        doubleStream(java.util.Spliterator.OfDouble, boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package java.util.stream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.stream

  • Packages that use java.util.stream
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.security
    提供安全框架的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
  • Classes in java.util.stream used by java.io
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.lang
    Class 描述
    IntStream
    支持顺序和并行聚合操作的原始int值元素序列。
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.lang.module
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.net
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.nio
    Class 描述
    IntStream
    支持顺序和并行聚合操作的原始int值元素序列。
  • Classes in java.util.stream used by java.nio.file
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.security
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.sql
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.time
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.util
    Class 描述
    DoubleStream
    支持顺序和并行聚合操作的原始双值元素序列。
    IntStream
    支持顺序和并行聚合操作的原始int值元素序列。
    LongStream
    支持顺序和并行聚合操作的原始长值元素序列。
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.util.concurrent
    Class 描述
    DoubleStream
    支持顺序和并行聚合操作的原始双值元素序列。
    IntStream
    支持顺序和并行聚合操作的原始int值元素序列。
    LongStream
    支持顺序和并行聚合操作的原始长值元素序列。
  • Classes in java.util.stream used by java.util.jar
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.util.regex
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by java.util.stream
    Class 描述
    BaseStream
    流的基本界面，它们是支持顺序和并行聚合操作的元素序列。
    Collector
    A mutable reduction operation将输入元素累加到可变结果容器中，可选地在所有输入元素被处理之后将累积结果转换成最终表示。
    Collector.Characteristics
    指示 Collector属性的特性，可用于优化还原实现。
    DoubleStream
    支持顺序和并行聚合操作的原始双值元素序列。
    DoubleStream.Builder
    一个可变的构建器，用于 DoubleStream 。
    IntStream
    支持顺序和并行聚合操作的原始int值元素序列。
    IntStream.Builder
    一个可变的构建器为 IntStream 。
    LongStream
    支持顺序和并行聚合操作的原始长值元素序列。
    LongStream.Builder
    一个可变的构建器，用于 LongStream 。
    Stream
    支持顺序和并行聚合操作的一系列元素。
    Stream.Builder
    一个可变的构建器为 Stream 。
  • Classes in java.util.stream used by java.util.zip
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by javax.xml.catalog
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
  • Classes in java.util.stream used by jdk.jshell
    Class 描述
    Stream
    支持顺序和并行聚合操作的一系列元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.stream.Collector.Characteristics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.stream.Collector.Characteristics

  • Packages that use Collector.Characteristics
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of Collector.Characteristics in java.util.stream

      Methods in java.util.stream that return Collector.Characteristics
      Modifier and Type 方法 描述
      static Collector.Characteristics Collector.Characteristics.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Collector.Characteristics[] Collector.Characteristics.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.util.stream that return types with arguments of type Collector.Characteristics
      Modifier and Type 方法 描述
      Set<Collector.Characteristics> Collector.characteristics​()
      返回 Set的 Collector.Characteristics表明该收藏家的特征。
      Methods in java.util.stream with parameters of type Collector.Characteristics
      Modifier and Type 方法 描述
      static <T,A,R> Collector<T,A,R> Collector.of​(Supplier<A> supplier, BiConsumer<A,T> accumulator, BinaryOperator<A> combiner, Function<A,R> finisher, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ， combiner ，并 finisher功能。
      static <T,R> Collector<T,R,R> Collector.of​(Supplier<R> supplier, BiConsumer<R,T> accumulator, BinaryOperator<R> combiner, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ，并 combiner功能。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.stream.Collectors (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.stream.Collectors

No usage of java.util.stream.Collectors
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.stream.StreamSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.stream.StreamSupport

No usage of java.util.stream.StreamSupport
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.BaseStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.BaseStream

  • Packages that use BaseStream
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of BaseStream in java.util.stream

      Classes in java.util.stream with type parameters of type BaseStream
      Modifier and Type 接口 描述
      interface  BaseStream<T,S extends BaseStream<T,S>>
      流的基本界面，它们是支持顺序和并行聚合操作的元素序列。
      Subinterfaces of BaseStream in java.util.stream
      Modifier and Type 接口 描述
      interface  DoubleStream
      支持顺序和并行聚合操作的原始双值元素序列。
      interface  IntStream
      支持顺序和并行聚合操作的原始int值元素序列。
      interface  LongStream
      支持顺序和并行聚合操作的原始长值元素序列。
      interface  Stream<T>
      支持顺序和并行聚合操作的一系列元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.Collector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.Collector

  • Packages that use Collector
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of Collector in java.util.stream

      Methods in java.util.stream that return Collector
      Modifier and Type 方法 描述
      static <T> Collector<T,?,Double> Collectors.averagingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 Collector ，它产生应用于输入元素的双值函数的算术平均值。
      static <T> Collector<T,?,Double> Collectors.averagingInt​(ToIntFunction<? super T> mapper)
      返回一个产生应用于输入元素的整数值函数的算术平均值的 Collector 。
      static <T> Collector<T,?,Double> Collectors.averagingLong​(ToLongFunction<? super T> mapper)
      返回产生应用于输入元素的长值函数的算术平均值的 Collector 。
      static <T,A,R,RR> Collector<T,A,RR> Collectors.collectingAndThen​(Collector<T,A,R> downstream, Function<R,RR> finisher)
      适应 Collector执行额外的完成转换。
      static <T> Collector<T,?,Long> Collectors.counting​()
      返回 Collector类型的接受元件 T计数输入元件的数量。
      static <T,A,R> Collector<T,?,R> Collectors.filtering​(Predicate<? super T> predicate, Collector<? super T,A,R> downstream)
      适应一个 Collector相同类型的一个接受元件 T通过将谓词给每个输入元素并且如果所述谓词仅返回累积 true 。
      static <T,U,A,R> Collector<T,?,R> Collectors.flatMapping​(Function<? super T,? extends Stream<? extends U>> mapper, Collector<? super U,A,R> downstream)
      适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累之前施加平坦映射函数应用于每个输入元件。
      static <T,K> Collector<T,?,Map<K,List<T>>> Collectors.groupingBy​(Function<? super T,? extends K> classifier)
      返回一个 Collector对 T类型的输入元素进行“按组”操作，根据分类功能对元素进行分组，并将结果返回到 Map 。
      static <T,K,D,A,M extends Map<K,D>>
      Collector<T,?,M>             		Collectors.groupingBy​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定与给定键相关联的值进行还原操作 Collector 。
      static <T,K,A,D> Collector<T,?,Map<K,D>> Collectors.groupingBy​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回一个 Collector对类型为 T输入元素执行级联“分组”操作，根据分类功能分组元素，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K> Collector<T,?,ConcurrentMap<K,List<T>>> Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier)
      返回一个并发 Collector “由基团”上的类型的输入元件操作实现 T ，根据分类功能分组元素。
      static <T,K,A,D,M extends ConcurrentMap<K,D>>
      Collector<T,?,M>             		Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回并行的 Collector ，对 T类型的输入元素进行级联“按组”操作，根据分类功能分组元素，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K,A,D> Collector<T,?,ConcurrentMap<K,D>> Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回一个并发的 Collector ，对 T类型的输入元素执行级联“按组”操作，根据分类功能分组元素，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static Collector<CharSequence,?,String> Collectors.joining​()
      返回一个 Collector ，将输入元素连接到一个 String ，按照顺序。
      static Collector<CharSequence,?,String> Collectors.joining​(CharSequence delimiter)
      返回一个 Collector ，按照遇到的顺序连接由指定的分隔符分隔的输入元素。
      static Collector<CharSequence,?,String> Collectors.joining​(CharSequence delimiter, CharSequence prefix, CharSequence suffix)
      返回一个 Collector ，它将按照指定的分隔符分隔的输入元素与指定的前缀和后缀 Collector 。
      static <T,U,A,R> Collector<T,?,R> Collectors.mapping​(Function<? super T,? extends U> mapper, Collector<? super U,A,R> downstream)
      适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累前应用映射函数到每个输入元素。
      static <T> Collector<T,?,Optional<T>> Collectors.maxBy​(Comparator<? super T> comparator)
      返回一个 Collector ，根据给出的 Comparator产生最大元素，描述为 Optional<T> 。
      static <T> Collector<T,?,Optional<T>> Collectors.minBy​(Comparator<? super T> comparator)
      返回一个 Collector ，它根据给定的 Comparator生成最小元素，描述为 Optional<T> 。
      static <T,A,R> Collector<T,A,R> Collector.of​(Supplier<A> supplier, BiConsumer<A,T> accumulator, BinaryOperator<A> combiner, Function<A,R> finisher, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ， combiner ，并 finisher功能。
      static <T,R> Collector<T,R,R> Collector.of​(Supplier<R> supplier, BiConsumer<R,T> accumulator, BinaryOperator<R> combiner, Collector.Characteristics... characteristics)
      返回一个新 Collector由给定的描述 supplier ， accumulator ，并 combiner功能。
      static <T> Collector<T,?,Map<Boolean,List<T>>> Collectors.partitioningBy​(Predicate<? super T> predicate)
      返回 Collector由划分根据所述输入元件 Predicate ，并且将它们组织到一个 Map<Boolean, List<T>> 。
      static <T,D,A> Collector<T,?,Map<Boolean,D>> Collectors.partitioningBy​(Predicate<? super T> predicate, Collector<? super T,A,D> downstream)
      返回 Collector由划分根据所述输入元件 Predicate ，减少了在根据另一每个分区中的值 Collector ，并且将它们组织到一个 Map<Boolean, D>其值是下游减少的结果。
      static <T> Collector<T,?,Optional<T>> Collectors.reducing​(BinaryOperator<T> op)
      返回一个 Collector ，它在指定的 BinaryOperator下执行其输入元素的减少。
      static <T> Collector<T,?,T> Collectors.reducing​(T identity, BinaryOperator<T> op)
      返回一个 Collector ，它使用提供的身份在指定的 BinaryOperator下执行其输入元素的减少。
      static <T,U> Collector<T,?,U> Collectors.reducing​(U identity, Function<? super T,? extends U> mapper, BinaryOperator<U> op)
      返回一个 Collector ，它在指定的映射函数和 BinaryOperator下执行其输入元素的减少。
      static <T> Collector<T,?,DoubleSummaryStatistics> Collectors.summarizingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 Collector ， double生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
      static <T> Collector<T,?,IntSummaryStatistics> Collectors.summarizingInt​(ToIntFunction<? super T> mapper)
      返回一个 Collector ， int生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
      static <T> Collector<T,?,LongSummaryStatistics> Collectors.summarizingLong​(ToLongFunction<? super T> mapper)
      返回一个 Collector ， long生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。
      static <T> Collector<T,?,Double> Collectors.summingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 Collector ，它产生应用于输入元素的双值函数的和。
      static <T> Collector<T,?,Integer> Collectors.summingInt​(ToIntFunction<? super T> mapper)
      返回一个产生应用于输入元素的整数值函数的和的 Collector 。
      static <T> Collector<T,?,Long> Collectors.summingLong​(ToLongFunction<? super T> mapper)
      返回一个 Collector ，它产生应用于输入元素的长值函数的和。
      static <T,C extends Collection<T>>
      Collector<T,?,C>             		Collectors.toCollection​(Supplier<C> collectionFactory)
      返回一个 Collector ，按照遇到的顺序将输入元素累加到新的 Collection中。
      static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,ConcurrentMap<K,U>> Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。
      static <T,K,U,M extends ConcurrentMap<K,U>>
      Collector<T,?,M>             		Collectors.toConcurrentMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。
      static <T> Collector<T,?,List<T>> Collectors.toList​()
      返回一个 Collector ，将输入元素累加到一个新的 List 。
      static <T,K,U> Collector<T,?,Map<K,U>> Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U> Collector<T,?,Map<K,U>> Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T,K,U,M extends Map<K,U>>
      Collector<T,?,M>             		Collectors.toMap​(Function<? super T,? extends K> keyMapper, Function<? super T,? extends U> valueMapper, BinaryOperator<U> mergeFunction, Supplier<M> mapFactory)
      返回一个 Collector ，它将元素累加到 Map其键和值是将提供的映射函数应用于输入元素的结果。
      static <T> Collector<T,?,Set<T>> Collectors.toSet​()
      返回一个 Collector ，将输入元素累加到一个新的 Set 。
      Methods in java.util.stream with parameters of type Collector
      Modifier and Type 方法 描述
      <R,A> R Stream.collect​(Collector<? super T,A,R> collector)
      使用 Collector对此流的元素执行 mutable reduction操作。
      static <T,A,R,RR> Collector<T,A,RR> Collectors.collectingAndThen​(Collector<T,A,R> downstream, Function<R,RR> finisher)
      适应 Collector进行额外的整理转换。
      static <T,A,R> Collector<T,?,R> Collectors.filtering​(Predicate<? super T> predicate, Collector<? super T,A,R> downstream)
      适应一个 Collector相同类型的一个接受元件 T通过将谓词给每个输入元素并且如果所述谓词仅返回累积 true 。
      static <T,U,A,R> Collector<T,?,R> Collectors.flatMapping​(Function<? super T,? extends Stream<? extends U>> mapper, Collector<? super U,A,R> downstream)
      适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累之前施加平坦映射函数应用于每个输入元件。
      static <T,K,D,A,M extends Map<K,D>>
      Collector<T,?,M>             		Collectors.groupingBy​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回一个 Collector对类型为 T输入元素进行级联“分组”操作，根据分类功能对元素进行分组，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K,A,D> Collector<T,?,Map<K,D>> Collectors.groupingBy​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回一个 Collector对类型为 T输入元素进行级联“分组”操作，根据分类功能对元素进行分组，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K,A,D,M extends ConcurrentMap<K,D>>
      Collector<T,?,M>             		Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier, Supplier<M> mapFactory, Collector<? super T,A,D> downstream)
      返回并行执行 Collector的并行 Collector ，对 T类型的输入元素进行级联“分组”操作，根据分类功能对元素进行分组，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。
      static <T,K,A,D> Collector<T,?,ConcurrentMap<K,D>> Collectors.groupingByConcurrent​(Function<? super T,? extends K> classifier, Collector<? super T,A,D> downstream)
      返回一个并发 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定执行与给定键相关联的值的归约运算 Collector 。
      static <T,U,A,R> Collector<T,?,R> Collectors.mapping​(Function<? super T,? extends U> mapper, Collector<? super U,A,R> downstream)
      适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累前应用映射函数到每个输入元素。
      static <T,D,A> Collector<T,?,Map<Boolean,D>> Collectors.partitioningBy​(Predicate<? super T> predicate, Collector<? super T,A,D> downstream)
      返回 Collector由划分根据所述输入元件 Predicate ，减少了在根据另一每个分区中的值 Collector ，并且将它们组织到一个 Map<Boolean, D>其值是下游减少的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.DoubleStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.DoubleStream

  • Packages that use DoubleStream
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleStream in java.util

      Methods in java.util that return DoubleStream
      Modifier and Type 方法 描述
      DoubleStream Random.doubles​()
      返回一个有效的无限流的伪随机数 double ，每个值在零（包括）和一（独占）之间。
      DoubleStream Random.doubles​(double randomNumberOrigin, double randomNumberBound)
      返回一个有效的无限流伪随机数 double值，每个符合给定的起始（包括）和绑定（排除）。
      DoubleStream Random.doubles​(long streamSize)
      返回一个流，产生给定的 streamSize伪随机数 double数值，每个值在零（包括）和一（独占）之间。
      DoubleStream Random.doubles​(long streamSize, double randomNumberOrigin, double randomNumberBound)
      返回一个流，产生给定的 streamSize伪随机数 double值，每个值符合给定的起始（包括）和绑定（排他）。
      DoubleStream SplittableRandom.doubles​()
      返回一个有效的无限流的伪随机数double来自该生成器和/或一个从它分割的值; 每个值在零（包括）和一（独占）之间。
      DoubleStream SplittableRandom.doubles​(double randomNumberOrigin, double randomNumberBound)
      从这个发生器返回一个有效的无限流的伪随机数double值，和/或从它分离一个; 每个值符合给定的起始（包括）和绑定（排他）。
      DoubleStream SplittableRandom.doubles​(long streamSize)
      返回一个流，产生给定的streamSize数量的伪随机数double值来自该生成器和/或一个从它分割; 每个值在零（包括）和一（独占）之间。
      DoubleStream SplittableRandom.doubles​(long streamSize, double randomNumberOrigin, double randomNumberBound)
      返回一个流，从该生成器生成给定的streamSize个伪随机数double值，和/或从该生成器分离出一个值; 每个值符合给定的起始（包括）和绑定（排他）。
      static DoubleStream Arrays.stream​(double[] array)
      返回具有指定数组的序列DoubleStream作为其源。
      static DoubleStream Arrays.stream​(double[] array, int startInclusive, int endExclusive)
      返回指定数组的指定范围作为源的顺序DoubleStream 。
      DoubleStream OptionalDouble.stream​()
      如果存在值，则返回仅包含该值的序列DoubleStream ，否则返回空DoubleStream 。

    • Uses of DoubleStream in java.util.concurrent

      Methods in java.util.concurrent that return DoubleStream
      Modifier and Type 方法 描述
      DoubleStream ThreadLocalRandom.doubles​()
      返回一个有效的无限流的伪随机数 double值，每个值在零（包括）和一（独占）之间。
      DoubleStream ThreadLocalRandom.doubles​(double randomNumberOrigin, double randomNumberBound)
      返回一个有效的无限流伪随机 double ，每个符合给定的起始（包括）和绑定（排他）。
      DoubleStream ThreadLocalRandom.doubles​(long streamSize)
      返回一个流，产生给定的 streamSize伪随机数 double值，每个值在零（包括）和一（独占）之间。
      DoubleStream ThreadLocalRandom.doubles​(long streamSize, double randomNumberOrigin, double randomNumberBound)
      返回一个流，产生给定的 streamSize伪随机数 double值，每个符合给定的起始（包括）和绑定（排他）。

    • Uses of DoubleStream in java.util.stream

      Methods in java.util.stream that return DoubleStream
      Modifier and Type | 方法 | 描述
      DoubleStream IntStream.asDoubleStream​()
      返回一个由该流的元素组成的 DoubleStream ，转换为 double 。
      DoubleStream LongStream.asDoubleStream​()
      返回一个由该流的元素组成的 DoubleStream ，转换为 double 。
      DoubleStream DoubleStream.Builder.build​()
      构建流，将此构建器转换为内置状态。
      static DoubleStream DoubleStream.concat​(DoubleStream a, DoubleStream b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      DoubleStream DoubleStream.distinct​()
      返回由该流的不同元素组成的流。
      static DoubleStream StreamSupport.doubleStream​(Supplier<? extends Spliterator.OfDouble> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 DoubleStream从 Supplier的 Spliterator.OfDouble 。
      static DoubleStream StreamSupport.doubleStream​(Spliterator.OfDouble spliterator, boolean parallel)
      创建一个新的串行或并行 DoubleStream从 Spliterator.OfDouble 。
      default DoubleStream DoubleStream.dropWhile​(DoublePredicate predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      static DoubleStream DoubleStream.empty​()
      返回空序列 DoubleStream 。
      DoubleStream DoubleStream.filter​(DoublePredicate predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      DoubleStream DoubleStream.flatMap​(DoubleFunction<? extends DoubleStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      DoubleStream Stream.flatMapToDouble​(Function<? super T,? extends DoubleStream> mapper)
      返回一个 DoubleStream ，其结果是将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容。
      static DoubleStream DoubleStream.generate​(DoubleSupplier s)
      返回无限顺序无序流，其中每个元素由提供的 DoubleSupplier生成。
      static DoubleStream DoubleStream.iterate​(double seed, DoublePredicate hasNext, DoubleUnaryOperator next)
      返回通过将给定的 next函数迭代应用于初始元素产生的顺序 DoubleStream ，其条件是满足给定的 hasNext谓词。
      static DoubleStream DoubleStream.iterate​(double seed, DoubleUnaryOperator f)
      返回有序无限连续 DoubleStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      DoubleStream DoubleStream.limit​(long maxSize)
      返回由此流的元素组成的流，截短长度不能超过 maxSize 。
      DoubleStream DoubleStream.map​(DoubleUnaryOperator mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
      DoubleStream IntStream.mapToDouble​(IntToDoubleFunction mapper)
      返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
      DoubleStream LongStream.mapToDouble​(LongToDoubleFunction mapper)
      返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
      DoubleStream Stream.mapToDouble​(ToDoubleFunction<? super T> mapper)
      返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
      static DoubleStream DoubleStream.of​(double t)
      返回包含单个元素的序列 DoubleStream 。
      static DoubleStream DoubleStream.of​(double... values)
      返回其元素是指定值的顺序排序流。
      DoubleStream | DoubleStream.parallel​()
      DoubleStream DoubleStream.peek​(DoubleConsumer action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
      DoubleStream | DoubleStream.sequential​()
      DoubleStream DoubleStream.skip​(long n)
      在丢弃流的第一个 n元素后，返回由该流的其余元素组成的流。
      DoubleStream DoubleStream.sorted​()
      以排序顺序返回由该流的元素组成的流。
      default DoubleStream DoubleStream.takeWhile​(DoublePredicate predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
      Methods in java.util.stream with parameters of type DoubleStream
      Modifier and Type 方法 描述
      static DoubleStream DoubleStream.concat​(DoubleStream a, DoubleStream b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      Method parameters in java.util.stream with type arguments of type DoubleStream
      Modifier and Type 方法 描述
      DoubleStream DoubleStream.flatMap​(DoubleFunction<? extends DoubleStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      DoubleStream Stream.flatMapToDouble​(Function<? super T,? extends DoubleStream> mapper)
      返回一个 DoubleStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.DoubleStream.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.DoubleStream.Builder

  • Packages that use DoubleStream.Builder
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of DoubleStream.Builder in java.util.stream

      Methods in java.util.stream that return DoubleStream.Builder
      Modifier and Type 方法 描述
      default DoubleStream.Builder DoubleStream.Builder.add​(double t)
      向要构建的流添加元素。
      static DoubleStream.Builder DoubleStream.builder​()
      返回一个 DoubleStream生成器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.IntStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.IntStream

  • Packages that use IntStream
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntStream in java.lang

      Methods in java.lang that return IntStream
      Modifier and Type 方法 描述
      default IntStream CharSequence.chars​()
      返回一个 int的数据流，从这个序列中扩展 char值。
      IntStream String.chars​()
      返回一个 int的数据流，从这个序列中扩展 char值。
      default IntStream CharSequence.codePoints​()
      从此序列返回码流值。
      IntStream String.codePoints​()
      从此序列返回码流值。

    • Uses of IntStream in java.nio

      Methods in java.nio that return IntStream
      Modifier and Type | 方法 | 描述
      IntStream | CharBuffer.chars​()

    • Uses of IntStream in java.util

      Methods in java.util that return IntStream
      Modifier and Type 方法 描述
      IntStream Random.ints​()
      返回一个有效的无限流的伪随机数 int值。
      IntStream Random.ints​(int randomNumberOrigin, int randomNumberBound)
      返回一个有效的无限流伪随机数 int值，每个符合给定的起始（包括）和绑定（排他）。
      IntStream Random.ints​(long streamSize)
      返回一个流，产生给定的 streamSize伪随机数 int值。
      IntStream Random.ints​(long streamSize, int randomNumberOrigin, int randomNumberBound)
      返回产生给定的 streamSize伪随机数 int值的流，每个值符合给定的起始（包括）和绑定（排除）。
      IntStream SplittableRandom.ints​()
      返回一个有效的无限流的伪随机数 int来自该生成器和/或从它的一个分割。
      IntStream SplittableRandom.ints​(int randomNumberOrigin, int randomNumberBound)
      从该生成器返回有效的无限流的伪随机数int ，和/或从其中分离出一个值; 每个值符合给定的起始（包括）和绑定（排他）。
      IntStream SplittableRandom.ints​(long streamSize)
      返回一个流，从该生成器生成给定的 streamSize个伪随机数 int值，和/或从其中分离一个。
      IntStream SplittableRandom.ints​(long streamSize, int randomNumberOrigin, int randomNumberBound)
      返回一个流，产生给定的streamSize伪随机数int值，该值来自该生成器和/或从其分离; 每个值符合给定的起始（包括）和绑定（排他）。
      static IntStream Arrays.stream​(int[] array)
      返回具有指定数组的序列IntStream作为其源。
      static IntStream Arrays.stream​(int[] array, int startInclusive, int endExclusive)
      返回指定数组的指定范围作为源的顺序IntStream 。
      IntStream BitSet.stream​()
      返回此 BitSet包含设置状态位的索引流。
      IntStream OptionalInt.stream​()
      如果存在值，则返回仅包含该值的顺序IntStream ，否则返回空IntStream 。

    • Uses of IntStream in java.util.concurrent

      Methods in java.util.concurrent that return IntStream
      Modifier and Type 方法 描述
      IntStream ThreadLocalRandom.ints​()
      返回一个有效的无限流的伪随机数 int值。
      IntStream ThreadLocalRandom.ints​(int randomNumberOrigin, int randomNumberBound)
      返回一个有效无限流的伪随机 int ，每个符合给定的起始（包括）和绑定（排他）。
      IntStream ThreadLocalRandom.ints​(long streamSize)
      返回一个流，产生给定的 streamSize个伪随机数 int数值。
      IntStream ThreadLocalRandom.ints​(long streamSize, int randomNumberOrigin, int randomNumberBound)
      返回一个流，产生给定的 streamSize伪随机数 int数值，每个值符合给定的起始（包括）和绑定（排他）。

    • Uses of IntStream in java.util.stream

      Methods in java.util.stream that return IntStream
      Modifier and Type | 方法 | 描述
      IntStream IntStream.Builder.build​()
      构建流，将此构建器转换为内置状态。
      static IntStream IntStream.concat​(IntStream a, IntStream b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      IntStream IntStream.distinct​()
      返回由该流的不同元素组成的流。
      default IntStream IntStream.dropWhile​(IntPredicate predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      static IntStream IntStream.empty​()
      返回一个空的序列 IntStream 。
      IntStream IntStream.filter​(IntPredicate predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      IntStream IntStream.flatMap​(IntFunction<? extends IntStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      IntStream Stream.flatMapToInt​(Function<? super T,? extends IntStream> mapper)
      返回一个 IntStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
      static IntStream IntStream.generate​(IntSupplier s)
      返回无限顺序无序流，其中每个元素由提供的 IntSupplier生成。
      static IntStream StreamSupport.intStream​(Supplier<? extends Spliterator.OfInt> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 IntStream从 Supplier的 Spliterator.OfInt 。
      static IntStream StreamSupport.intStream​(Spliterator.OfInt spliterator, boolean parallel)
      创建一个新的串行或并行 IntStream从 Spliterator.OfInt 。
      static IntStream IntStream.iterate​(int seed, IntPredicate hasNext, IntUnaryOperator next)
      返回通过将给定的 next函数的迭代应用到初始元素产生的顺序的 IntStream ，其条件是满足给定的 hasNext谓词。
      static IntStream IntStream.iterate​(int seed, IntUnaryOperator f)
      返回有序无限连续 IntStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      IntStream IntStream.limit​(long maxSize)
      返回由该流的元素组成的流，截短长度不能超过 maxSize 。
      IntStream IntStream.map​(IntUnaryOperator mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
      IntStream DoubleStream.mapToInt​(DoubleToIntFunction mapper)
      返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
      IntStream LongStream.mapToInt​(LongToIntFunction mapper)
      返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
      IntStream Stream.mapToInt​(ToIntFunction<? super T> mapper)
      返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
      static IntStream IntStream.of​(int t)
      返回包含单个元素的序列 IntStream 。
      static IntStream IntStream.of​(int... values)
      返回其元素是指定值的顺序排序流。
      IntStream | IntStream.parallel​()
      IntStream IntStream.peek​(IntConsumer action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
      static IntStream IntStream.range​(int startInclusive, int endExclusive)
      返回有序的顺序 IntStream从 startInclusive （含）至 endExclusive由增量步骤（独家） 1 。
      static IntStream IntStream.rangeClosed​(int startInclusive, int endInclusive)
      返回有序顺序 IntStream从 startInclusive （含）至 endInclusive通过的递增步长（含） 1 。
      IntStream | IntStream.sequential​()
      IntStream IntStream.skip​(long n)
      在丢弃流的第一个 n元素后，返回由该流的剩余元素组成的流。
      IntStream IntStream.sorted​()
      以排序顺序返回由该流的元素组成的流。
      default IntStream IntStream.takeWhile​(IntPredicate predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
      Methods in java.util.stream with parameters of type IntStream
      Modifier and Type 方法 描述
      static IntStream IntStream.concat​(IntStream a, IntStream b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      Method parameters in java.util.stream with type arguments of type IntStream
      Modifier and Type 方法 描述
      IntStream IntStream.flatMap​(IntFunction<? extends IntStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      IntStream Stream.flatMapToInt​(Function<? super T,? extends IntStream> mapper)
      返回一个 IntStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.IntStream.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.IntStream.Builder

  • Packages that use IntStream.Builder
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of IntStream.Builder in java.util.stream

      Methods in java.util.stream that return IntStream.Builder
      Modifier and Type 方法 描述
      default IntStream.Builder IntStream.Builder.add​(int t)
      向要构建的流添加元素。
      static IntStream.Builder IntStream.builder​()
      返回一个 IntStream生成器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.LongStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.LongStream

  • Packages that use LongStream
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongStream in java.util

      Methods in java.util that return LongStream
      Modifier and Type 方法 描述
      LongStream Random.longs​()
      返回一个有效的无限流的伪随机数 long值。
      LongStream Random.longs​(long streamSize)
      返回一个流，产生给定的 streamSize数量的伪随机数 long值。
      LongStream Random.longs​(long randomNumberOrigin, long randomNumberBound)
      返回一个有效的无限流伪随机数 long ，每个符合给定的起始（包括）和绑定（排他）。
      LongStream Random.longs​(long streamSize, long randomNumberOrigin, long randomNumberBound)
      返回产生所述给定流 streamSize数的伪随机的 long ，每个符合给定的原点（含）和结合（不包括）。
      LongStream SplittableRandom.longs​()
      从此生成器返回有效的无限流伪随机数 long和/或从其中分离出一个值。
      LongStream SplittableRandom.longs​(long streamSize)
      返回一个流，从该生成器生成给定的 streamSize伪随机数 long数值，和/或从该生成器中分离出一个值。
      LongStream SplittableRandom.longs​(long randomNumberOrigin, long randomNumberBound)
      返回一个有效的无限流的伪随机数long从这个发生器和/或一个从它的分裂值; 每个值符合给定的起始（包括）和绑定（排他）。
      LongStream SplittableRandom.longs​(long streamSize, long randomNumberOrigin, long randomNumberBound)
      返回产生所述给定流streamSize数的伪随机的long从该发电机和/或从它一个分割值; 每个值符合给定的起始（包括）和绑定（排他）。
      static LongStream Arrays.stream​(long[] array)
      返回具有指定数组的序列LongStream作为其源。
      static LongStream Arrays.stream​(long[] array, int startInclusive, int endExclusive)
      返回指定数组的指定范围作为源的顺序LongStream 。
      LongStream OptionalLong.stream​()
      如果存在值，则返回仅包含该值的序列LongStream ，否则返回空LongStream 。

    • Uses of LongStream in java.util.concurrent

      Methods in java.util.concurrent that return LongStream
      Modifier and Type 方法 描述
      LongStream ThreadLocalRandom.longs​()
      返回一个有效的无限流的伪随机数 long值。
      LongStream ThreadLocalRandom.longs​(long streamSize)
      返回产生给定的 streamSize数量的伪随机数 long值的流。
      LongStream ThreadLocalRandom.longs​(long randomNumberOrigin, long randomNumberBound)
      返回一个有效的无限流伪随机数 long值，每个符合给定的起始（包括）和绑定（排他）。
      LongStream ThreadLocalRandom.longs​(long streamSize, long randomNumberOrigin, long randomNumberBound)
      返回一个流，产生给定的 streamSize伪随机数 long ，每个符合给定的起始（包括）和绑定（排他）。

    • Uses of LongStream in java.util.stream

      Methods in java.util.stream that return LongStream
      Modifier and Type | 方法 | 描述
      LongStream IntStream.asLongStream​()
      返回一个由该流的元素组成的 LongStream ，转换为 long 。
      LongStream LongStream.Builder.build​()
      构建流，将此构建器转换为内置状态。
      static LongStream LongStream.concat​(LongStream a, LongStream b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      LongStream LongStream.distinct​()
      返回由该流的不同元素组成的流。
      default LongStream LongStream.dropWhile​(LongPredicate predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      static LongStream LongStream.empty​()
      返回一个空的序列 LongStream 。
      LongStream LongStream.filter​(LongPredicate predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      LongStream LongStream.flatMap​(LongFunction<? extends LongStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      LongStream Stream.flatMapToLong​(Function<? super T,? extends LongStream> mapper)
      返回一个 LongStream其中包含通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果。
      static LongStream LongStream.generate​(LongSupplier s)
      返回无限顺序无序流，其中每个元素由提供的 LongSupplier生成。
      static LongStream LongStream.iterate​(long seed, LongPredicate hasNext, LongUnaryOperator next)
      返回通过将给定的 next函数的迭代应用到初始元素产生的顺序排列的 LongStream ，其条件是满足给定的 hasNext谓词。
      static LongStream LongStream.iterate​(long seed, LongUnaryOperator f)
      返回有序无限连续 LongStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      LongStream LongStream.limit​(long maxSize)
      返回由此流的元素组成的流，截短长度不能超过 maxSize 。
      static LongStream StreamSupport.longStream​(Supplier<? extends Spliterator.OfLong> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 LongStream从 Supplier的 Spliterator.OfLong 。
      static LongStream StreamSupport.longStream​(Spliterator.OfLong spliterator, boolean parallel)
      创建一个新的串行或并行 LongStream从 Spliterator.OfLong 。
      LongStream LongStream.map​(LongUnaryOperator mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
      LongStream DoubleStream.mapToLong​(DoubleToLongFunction mapper)
      返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
      LongStream IntStream.mapToLong​(IntToLongFunction mapper)
      返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
      LongStream Stream.mapToLong​(ToLongFunction<? super T> mapper)
      返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
      static LongStream LongStream.of​(long t)
      返回包含单个元素的序列 LongStream 。
      static LongStream LongStream.of​(long... values)
      返回其元素是指定值的顺序排序流。
      LongStream | LongStream.parallel​()
      LongStream LongStream.peek​(LongConsumer action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
      static LongStream LongStream.range​(long startInclusive, long endExclusive)
      通过 startInclusive的增量步骤将 1 （含）的顺序 LongStream返回到 endExclusive （排除）。
      static LongStream LongStream.rangeClosed​(long startInclusive, long endInclusive)
      返回有序顺序 LongStream从 startInclusive （含）至 endInclusive通过的递增步长（含） 1 。
      LongStream | LongStream.sequential​()
      LongStream LongStream.skip​(long n)
      在丢弃流的第一个 n元素后，返回由该流的剩余元素组成的流。
      LongStream LongStream.sorted​()
      以排序顺序返回由该流的元素组成的流。
      default LongStream LongStream.takeWhile​(LongPredicate predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
      Methods in java.util.stream with parameters of type LongStream
      Modifier and Type 方法 描述
      static LongStream LongStream.concat​(LongStream a, LongStream b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      Method parameters in java.util.stream with type arguments of type LongStream
      Modifier and Type 方法 描述
      LongStream LongStream.flatMap​(LongFunction<? extends LongStream> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      LongStream Stream.flatMapToLong​(Function<? super T,? extends LongStream> mapper)
      返回一个 LongStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.LongStream.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.LongStream.Builder

  • Packages that use LongStream.Builder
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of LongStream.Builder in java.util.stream

      Methods in java.util.stream that return LongStream.Builder
      Modifier and Type 方法 描述
      default LongStream.Builder LongStream.Builder.add​(long t)
      向要构建的流添加元素。
      static LongStream.Builder LongStream.builder​()
      返回一个 LongStream生成器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.Stream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.Stream

  • Packages that use Stream
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.security
    提供安全框架的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。

    • Uses of Stream in java.io

      Methods in java.io that return Stream
      Modifier and Type 方法 描述
      Stream<String> BufferedReader.lines​()
      返回一个 Stream ，其元素是从这个 BufferedReader读取的行。

    • Uses of Stream in java.lang

      Methods in java.lang that return Stream
      Modifier and Type 方法 描述
      static Stream<ProcessHandle> ProcessHandle.allProcesses​()
      返回当前进程可见的所有进程的快照。
      Stream<ProcessHandle> Process.children​()
      返回进程的直接子节点的快照。
      Stream<ProcessHandle> ProcessHandle.children​()
      返回进程当前直接子节点的快照。
      Stream<ProcessHandle> Process.descendants​()
      返回进程后代的快照。
      Stream<ProcessHandle> ProcessHandle.descendants​()
      返回进程后代的快照。
      Stream<URL> ClassLoader.resources​(String name)
      返回一个流，其元素是具有给定名称的所有资源的URL。
      Method parameters in java.lang with type arguments of type Stream
      Modifier and Type 方法 描述
      <T> T StackWalker.walk​(Function<? super Stream<StackWalker.StackFrame>,? extends T> function)
      将给定的函数应用于当前线程的 StackFrame的流，从堆栈的顶部框架遍历，这是调用此 walk方法的方法。

    • Uses of Stream in java.lang.module

      Methods in java.lang.module that return Stream
      Modifier and Type 方法 描述
      Stream<String> ModuleReader.list​()
      列出模块的内容，返回作为模块中所有资源名称的元素流。

    • Uses of Stream in java.net

      Methods in java.net that return Stream
      Modifier and Type 方法 描述
      Stream<InetAddress> NetworkInterface.inetAddresses​()
      获取绑定到此网络接口的InetAddresses的全部或一部分子流。
      static Stream<NetworkInterface> NetworkInterface.networkInterfaces​()
      返回此机器上所有接口的 Stream 。
      Stream<NetworkInterface> NetworkInterface.subInterfaces​()
      获取附加到此网络接口的所有子接口（也称为虚拟接口）的流。

    • Uses of Stream in java.nio.file

      Methods in java.nio.file that return Stream
      Modifier and Type 方法 描述
      static Stream<Path> Files.find​(Path start, int maxDepth, BiPredicate<Path,BasicFileAttributes> matcher, FileVisitOption... options)
      返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件来懒惰地填充 Path 。
      static Stream<String> Files.lines​(Path path)
      从文件中读取所有行作为 Stream 。
      static Stream<String> Files.lines​(Path path, Charset cs)
      从文件读取所有行作为 Stream 。
      static Stream<Path> Files.list​(Path dir)
      返回一个懒惰的 Stream ，其中的元素是目录中的条目。
      static Stream<Path> Files.walk​(Path start, int maxDepth, FileVisitOption... options)
      返回一个 Stream ，它是通过走在一个给定的起始文件的根文件树上，以 Path懒惰地填充。
      static Stream<Path> Files.walk​(Path start, FileVisitOption... options)
      返回一个 Stream ，它是通过走在一个给定的起始文件的根文件树上的，被惰性地填充 Path 。

    • Uses of Stream in java.security

      Methods in java.security that return Stream
      Modifier and Type 方法 描述
      Stream<Permission> PermissionCollection.elementsAsStream​()
      返回集合中所有权限对象的流。

    • Uses of Stream in java.sql

      Methods in java.sql that return Stream
      Modifier and Type 方法 描述
      static Stream<Driver> DriverManager.drivers​()
      使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索流。

    • Uses of Stream in java.time

      Methods in java.time that return Stream
      Modifier and Type 方法 描述
      Stream<LocalDate> LocalDate.datesUntil​(LocalDate endExclusive)
      返回顺序排列的日期流。
      Stream<LocalDate> LocalDate.datesUntil​(LocalDate endExclusive, Period step)
      通过给定的增量步骤返回日期的顺序排序流。

    • Uses of Stream in java.util

      Methods in java.util that return Stream
      Modifier and Type 方法 描述
      Stream<MatchResult> Scanner.findAll​(String patString)
      返回与提供的模式字符串相匹配的匹配结果流。
      Stream<MatchResult> Scanner.findAll​(Pattern pattern)
      返回此扫描仪的匹配结果流。
      default Stream<E> Collection.parallelStream​()
      返回可能并行的 Stream与此集合作为其来源。
      static <T> Stream<T> Arrays.stream​(T[] array)
      返回具有指定数组的序列Stream作为其源。
      static <T> Stream<T> Arrays.stream​(T[] array, int startInclusive, int endExclusive)
      返回具有指定数组的指定范围作为其源的顺序Stream 。
      default Stream<E> Collection.stream​()
      返回一个序列 Stream与此集合作为其来源。
      Stream<T> Optional.stream​()
      如果存在值，则返回仅包含该值的序列Stream ，否则返回空Stream 。
      Stream<ServiceLoader.Provider<S>> ServiceLoader.stream​()
      返回一个流，以延迟加载此加载程序服务的可用提供程序。
      Stream<String> Scanner.tokens​()
      从此扫描仪返回一个分隔符的分隔符号流。

    • Uses of Stream in java.util.jar

      Methods in java.util.jar that return Stream
      Modifier and Type 方法 描述
      Stream<JarEntry> JarFile.stream​()
      返回一个有序的 Stream超过jar文件条目。

    • Uses of Stream in java.util.regex

      Methods in java.util.regex that return Stream
      Modifier and Type 方法 描述
      Stream<MatchResult> Matcher.results​()
      返回与模式匹配的输入序列的每个子序列的匹配结果流。
      Stream<String> Pattern.splitAsStream​(CharSequence input)
      根据给定的输入序列创建一个流，该流与该模式匹配。

    • Uses of Stream in java.util.stream

      Methods in java.util.stream that return Stream
      Modifier and Type 方法 描述
      Stream<Double> DoubleStream.boxed​()
      返回一个 Stream组成的这个流的元素，装箱到 Double 。
      Stream<Integer> IntStream.boxed​()
      返回一个由这个流的元素组成的 Stream ，每个都包含一个 Integer 。
      Stream<Long> LongStream.boxed​()
      返回一个由这个流的元素组成的 Stream ，每个都包含一个 Long 。
      Stream<T> Stream.Builder.build​()
      构建流，将此构建器转换为内置状态。
      static <T> Stream<T> Stream.concat​(Stream<? extends T> a, Stream<? extends T> b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      Stream<T> Stream.distinct​()
      返回由该流的不同元素（根据 Object.equals(Object) ）组成的流。
      default Stream<T> Stream.dropWhile​(Predicate<? super T> predicate)
      如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
      static <T> Stream<T> Stream.empty​()
      返回空序列 Stream 。
      Stream<T> Stream.filter​(Predicate<? super T> predicate)
      返回由与此给定谓词匹配的此流的元素组成的流。
      <R> Stream<R> Stream.flatMap​(Function<? super T,? extends Stream<? extends R>> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      static <T> Stream<T> Stream.generate​(Supplier<? extends T> s)
      返回无限顺序无序流，其中每个元素由提供的 Supplier生成。
      static <T> Stream<T> Stream.iterate​(T seed, Predicate<? super T> hasNext, UnaryOperator<T> next)
      返回由给定的 next函数的迭代应用到初始元素产生的顺序 Stream ，条件是满足给定的 hasNext谓词。
      static <T> Stream<T> Stream.iterate​(T seed, UnaryOperator<T> f)
      返回有序无限连续 Stream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等
      Stream<T> Stream.limit​(long maxSize)
      返回由此流的元素组成的流，截断长度不能超过 maxSize 。
      <R> Stream<R> Stream.map​(Function<? super T,? extends R> mapper)
      返回由给定函数应用于此流的元素的结果组成的流。
      <U> Stream<U> DoubleStream.mapToObj​(DoubleFunction<? extends U> mapper)
      返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
      <U> Stream<U> IntStream.mapToObj​(IntFunction<? extends U> mapper)
      返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
      <U> Stream<U> LongStream.mapToObj​(LongFunction<? extends U> mapper)
      返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
      static <T> Stream<T> Stream.of​(T t)
      返回包含单个元素的序列 Stream 。
      static <T> Stream<T> Stream.of​(T... values)
      返回其元素是指定值的顺序排序流。
      static <T> Stream<T> Stream.ofNullable​(T t)
      返回包含单个元素的序列 Stream ，如果非空，则返回一个空的 Stream 。
      Stream<T> Stream.peek​(Consumer<? super T> action)
      返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
      Stream<T> Stream.skip​(long n)
      在丢弃流的第一个 n元素后，返回由该流的剩余元素组成的流。
      Stream<T> Stream.sorted​()
      返回由此流的元素组成的流，根据自然顺序排序。
      Stream<T> Stream.sorted​(Comparator<? super T> comparator)
      返回由该流的元素组成的流，根据提供的 Comparator进行排序。
      static <T> Stream<T> StreamSupport.stream​(Supplier<? extends Spliterator<T>> supplier, int characteristics, boolean parallel)
      创建一个新的顺序或并行 Stream从 Supplier的 Spliterator 。
      static <T> Stream<T> StreamSupport.stream​(Spliterator<T> spliterator, boolean parallel)
      创建一个新的串行或并行 Stream从 Spliterator 。
      default Stream<T> Stream.takeWhile​(Predicate<? super T> predicate)
      如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。
      Methods in java.util.stream with parameters of type Stream
      Modifier and Type 方法 描述
      static <T> Stream<T> Stream.concat​(Stream<? extends T> a, Stream<? extends T> b)
      创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。
      Method parameters in java.util.stream with type arguments of type Stream
      Modifier and Type 方法 描述
      <R> Stream<R> Stream.flatMap​(Function<? super T,? extends Stream<? extends R>> mapper)
      返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
      static <T,U,A,R> Collector<T,?,R> Collectors.flatMapping​(Function<? super T,? extends Stream<? extends U>> mapper, Collector<? super U,A,R> downstream)
      适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累之前施加平坦映射函数应用于每个输入元件。

    • Uses of Stream in java.util.zip

      Methods in java.util.zip that return Stream
      Modifier and Type 方法 描述
      Stream<? extends ZipEntry> ZipFile.stream​()
      在ZIP文件条目上返回一个有序的 Stream 。

    • Uses of Stream in javax.xml.catalog

      Methods in javax.xml.catalog that return Stream
      Modifier and Type 方法 描述
      Stream<Catalog> Catalog.catalogs​()
      返回使用当前目录中的nextCatalog条目指定的替代目录的顺序流，以及由CatalogManager创建目录对象时，不包括当前目录（即输入列表中的第一个）的目录文件的输入。

    • Uses of Stream in jdk.jshell

      Methods in jdk.jshell that return Stream
      Modifier and Type 方法 描述
      Stream<Diag> JShell.diagnostics​(Snippet snippet)
      返回片段最近评估的诊断。
      Stream<ImportSnippet> JShell.imports​()
      返回活动的导入片段。
      Stream<MethodSnippet> JShell.methods​()
      返回活动方法代码段。
      Stream<Snippet> JShell.snippets​()
      返回所有片段。
      Stream<TypeDeclSnippet> JShell.types​()
      返回活动类型声明（类，接口，注释类型和枚举）片段。
      Stream<String> JShell.unresolvedDependencies​(DeclarationSnippet snippet)
      对于 RECOVERABLE_DEFINED或 RECOVERABLE_NOT_DEFINED声明，代码片段的当前未解析的依赖关系的名称。
      Stream<VarSnippet> JShell.variables​()
      返回活动变量片段。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.stream.Stream.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.stream.Stream.Builder

  • Packages that use Stream.Builder
    软件包 描述
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。

    • Uses of Stream.Builder in java.util.stream

      Methods in java.util.stream that return Stream.Builder
      Modifier and Type 方法 描述
      default Stream.Builder<T> Stream.Builder.add​(T t)
      向要构建的流添加元素。
      static <T> Stream.Builder<T> Stream.builder​()
      返回一个 Stream生成器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Adler32 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class Adler32

  • java.lang.Object
    • java.util.zip.Adler32
  • All Implemented Interfaces:
    Checksum

    public class Adler32
extends Object
implements Checksum
    可用于计算数据流的Adler-32校验和的类。 Adler-32校验和几乎与CRC-32一样可靠，但可以计算得更快。

    将null参数传递给null中的方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      Adler32​()
      创建一个新的Adler32对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      long getValue​()
      返回校验和值。
      void reset​()
      将校验和重置为初始值。
      void update​(byte[] b, int off, int len)
      用指定的字节数组更新校验和。
      void update​(int b)
      用指定的字节更新校验和（参数b的低8位）。
      void update​(ByteBuffer buffer)
      使用指定缓冲区的字节更新校验和。

      • Methods inherited from interface java.util.zip.Checksum

        update

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Adler32

        public Adler32​()
        创建一个新的Adler32对象。

    • 方法详细信息

      • update

        public void update​(int b)
        用指定的字节更新校验和（参数b的低8位）。
        Specified by:
        update在接口 Checksum
        参数
        b - 用于更新校验和的字节

      • update

        public void update​(byte[] b,
                   int off,
                   int len)
        用指定的字节数组更新校验和。
        Specified by:
        update在接口 Checksum
        参数
        b - 用于更新校验和的字节数组
        off - 数据的起始偏移量
        len - 用于更新的字节数
        异常
        ArrayIndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off+len为负数或大于数组长度 b 。

      • update

        public void update​(ByteBuffer buffer)
        使用指定缓冲区的字节更新校验和。 校验和用缓冲区中的剩余字节更新，从缓冲区的位置开始。 返回时，缓冲区的位置将更新到其极限; 其限制将不会改变。
        Specified by:
        update接口 Checksum
        参数
        buffer - ByteBuffer更新校验和
        从以下版本开始：
        1.8

      • reset

        public void reset​()
        将校验和重置为初始值。
        Specified by:
        reset在接口 Checksum

      • getValue

        public long getValue​()
        返回校验和值。
        Specified by:
        getValue在接口 Checksum
        结果
        当前的校验和值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CheckedInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class CheckedInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.util.zip.CheckedInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class CheckedInputStream
extends FilterInputStream
    也保持正在读取的数据的校验和的输入流。 然后可以使用校验和来验证输入数据的完整性。
    从以下版本开始：
    1.1
    另请参见：
    Checksum

    • Field Summary

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckedInputStream​(InputStream in, Checksum cksum)
      使用指定的校验和创建输入流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Checksum getChecksum​()
      返回此输入流的校验和。
      int read​()
      读一个字节。
      int read​(byte[] buf, int off, int len)
      读入一个字节数组。
      long skip​(long n)
      跳过指定的输入字节数。

      • Methods inherited from class java.io.FilterInputStream

        available, close, mark, markSupported, read, reset

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CheckedInputStream

        public CheckedInputStream​(InputStream in,
                          Checksum cksum)
        使用指定的校验和创建输入流。
        参数
        in - 输入流
        cksum - 校验和

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        读一个字节。 如果没有输入可用，将阻止。
        重写：
        read在 FilterInputStream
        结果
        读取字节，如果达到流的结尾，则返回-1。
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterInputStream.in

      • read

        public int read​(byte[] buf,
                int off,
                int len)
         throws IOException
        读入一个字节数组。 如果len不为零，则该方法将阻塞，直到有些输入可用; 否则，不会读取字节，并返回0 。
        重写：
        read在 FilterInputStream
        参数
        buf - 读取数据的缓冲区
        off - 目标阵列中的起始偏移量 b
        len - 读取的最大字节数
        结果
        读取的实际字节数，如果达到流的末尾，则为-1。
        异常
        NullPointerException - 如果 buf是 null 。
        IndexOutOfBoundsException - 如果 off为负数， len为负数，或 len为大于 buf.length - off
        IOException - 如果发生I / O错误
        另请参见：
        FilterInputStream.in

      • skip

        public long skip​(long n)
          throws IOException
        跳过指定的输入字节数。
        重写：
        skip在 FilterInputStream
        参数
        n - 要跳过的字节数
        结果
        实际跳过的字节数
        异常
        IOException - 如果发生I / O错误

      • getChecksum

        public Checksum getChecksum​()
        返回此输入流的校验和。
        结果
        校验和值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CheckedOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class CheckedOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.util.zip.CheckedOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class CheckedOutputStream
extends FilterOutputStream
    一个输出流，它还维护正在写入的数据的校验和。 然后可以使用校验和来验证输出数据的完整性。
    从以下版本开始：
    1.1
    另请参见：
    Checksum

    • Field Summary

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckedOutputStream​(OutputStream out, Checksum cksum)
      使用指定的校验和创建输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Checksum getChecksum​()
      返回此输出流的校验和。
      void write​(byte[] b, int off, int len)
      写入一个字节数组。
      void write​(int b)
      写一个字节。

      • Methods inherited from class java.io.FilterOutputStream

        close, flush, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CheckedOutputStream

        public CheckedOutputStream​(OutputStream out,
                           Checksum cksum)
        使用指定的校验和创建输出流。
        参数
        out - 输出流
        cksum - 校验和

    • 方法详细信息

      • write

        public void write​(int b)
           throws IOException
        写一个字节。 将阻塞直到字节实际写入。
        重写：
        write在 FilterOutputStream
        参数
        b - 要写入的字节
        异常
        IOException - 如果发生I / O错误

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        写入一个字节数组。 将阻塞直到字节实际写入。
        重写：
        write在 FilterOutputStream
        参数
        b - 要写入的数据
        off - 数据的起始偏移量
        len - 要写入的字节数
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterOutputStream.write(int)

      • getChecksum

        public Checksum getChecksum​()
        返回此输出流的校验和。
        结果
        校验和
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Checksum (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Interface Checksum

  • 所有已知实现类：
    Adler32 ， CRC32 ， CRC32C

    public interface Checksum
    表示数据校验和的接口。
    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      long getValue​()
      返回当前的校验和值。
      void reset​()
      将校验和重置为初始值。
      default void update​(byte[] b)
      使用指定的字节数组更新当前的校验和。
      void update​(byte[] b, int off, int len)
      使用指定的字节数组更新当前的校验和。
      void update​(int b)
      用指定的字节更新当前的校验和。
      default void update​(ByteBuffer buffer)
      使用指定缓冲区的字节更新当前校验和。

    • 方法详细信息

      • update

        void update​(int b)
        用指定的字节更新当前的校验和。
        参数
        b - 用于更新校验和的字节

      • update

        default void update​(byte[] b)
        使用指定的字节数组更新当前的校验和。
        实现要求：
        此默认实现等于调用 update(b, 0, b.length) 。
        参数
        b - 用于更新校验和的字节数组
        异常
        NullPointerException - 如果 b是 null
        从以下版本开始：
        9

      • update

        void update​(byte[] b,
            int off,
            int len)
        使用指定的字节数组更新当前的校验和。
        参数
        b - 用于更新校验和的字节数组
        off - 数据的起始偏移量
        len - 用于更新的字节数

      • update

        default void update​(ByteBuffer buffer)
        使用指定缓冲区的字节更新当前校验和。 校验和用缓冲区中的剩余字节更新，从缓冲区的位置开始。 返回时，缓冲区的位置将更新到其极限; 其限制将不会改变。
        API Note:
        为了获得最佳性能，DirectByteBuffer和其他ByteBuffer实现没有后台阵列，该接口的实现者应该覆盖此方法。
        实现要求：
        默认实现具有以下行为。
        对于由可访问字节数组支持的ByteBuffers。
           update(buffer.array(), buffer.position() + buffer.arrayOffset(), buffer.remaining());
        对于没有可访问字节数组支持的ByteBuffers。
           byte[] b = new byte[Math.min(buffer.remaining(), 4096)]; while (buffer.hasRemaining()) { int length = Math.min(buffer.remaining(), b.length); buffer.get(b, 0, length); update(b, 0, length); }
        参数
        buffer - ByteBuffer更新校验和
        异常
        NullPointerException - 如果 buffer是 null
        从以下版本开始：
        9

      • getValue

        long getValue​()
        返回当前的校验和值。
        结果
        当前的校验和值

      • reset

        void reset​()
        将校验和重置为初始值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CRC32 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class CRC32

  • java.lang.Object
    • java.util.zip.CRC32
  • All Implemented Interfaces:
    Checksum

    public class CRC32
extends Object
implements Checksum
    可用于计算数据流的CRC-32的类。

    将null参数传递给null中的方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      CRC32​()
      创建一个新的CRC32对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      long getValue​()
      返回CRC-32值。
      void reset​()
      将CRC-32复位为初始值。
      void update​(byte[] b, int off, int len)
      用指定的字节数组更新CRC-32校验和。
      void update​(int b)
      用指定的字节（参数b的低8位）更新CRC-32校验和。
      void update​(ByteBuffer buffer)
      用指定缓冲区的字节更新CRC-32校验和。

      • Methods inherited from interface java.util.zip.Checksum

        update

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CRC32

        public CRC32​()
        创建一个新的CRC32对象。

    • 方法详细信息

      • update

        public void update​(int b)
        用指定的字节（参数b的低8位）更新CRC-32校验和。
        Specified by:
        update在接口 Checksum
        参数
        b - 用于更新校验和的字节

      • update

        public void update​(byte[] b,
                   int off,
                   int len)
        用指定的字节数组更新CRC-32校验和。
        Specified by:
        update在接口 Checksum
        参数
        b - 用于更新校验和的字节数组
        off - 数据的起始偏移量
        len - 用于更新的字节数
        异常
        ArrayIndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off+len为负数或大于数组 b的长度。

      • update

        public void update​(ByteBuffer buffer)
        用指定缓冲区的字节更新CRC-32校验和。 校验和用缓冲区中的剩余字节更新，从缓冲区的位置开始。 返回时，缓冲区的位置将更新到其极限; 其限制将不会改变。
        Specified by:
        update在接口 Checksum
        参数
        buffer - ByteBuffer更新校验和
        从以下版本开始：
        1.8

      • reset

        public void reset​()
        将CRC-32复位为初始值。
        Specified by:
        reset在接口 Checksum

      • getValue

        public long getValue​()
        返回CRC-32值。
        Specified by:
        getValue在接口 Checksum
        结果
        当前的校验和值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CRC32C (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class CRC32C

  • java.lang.Object
    • java.util.zip.CRC32C
  • All Implemented Interfaces:
    Checksum

    public final class CRC32C
extends Object
implements Checksum
    可用于计算数据流的CRC-32C的类。

    CRC-32C在RFC 3720 ：互联网小型计算机系统接口（iSCSI）中定义。

    将null参数传递给null中的方法将导致抛出NullPointerException 。

    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Constructor 描述
      CRC32C​()
      创建一个新的CRC32C对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      long getValue​()
      返回CRC-32C值。
      void reset​()
      将CRC-32C复位为初始值。
      void update​(byte[] b, int off, int len)
      用指定的字节数组更新CRC-32C校验和。
      void update​(int b)
      用指定的字节（参数b的低8位）更新CRC-32C校验和。
      void update​(ByteBuffer buffer)
      用指定缓冲区的字节更新CRC-32C校验和。

      • Methods inherited from interface java.util.zip.Checksum

        update

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CRC32C

        public CRC32C​()
        创建一个新的CRC32C对象。

    • 方法详细信息

      • update

        public void update​(int b)
        用指定的字节（参数b的低8位）更新CRC-32C校验和。
        Specified by:
        update在接口 Checksum
        参数
        b - 用于更新校验和的字节

      • update

        public void update​(byte[] b,
                   int off,
                   int len)
        用指定的字节数组更新CRC-32C校验和。
        Specified by:
        update在接口 Checksum
        参数
        b - 用于更新校验和的字节数组
        off - 数据的起始偏移量
        len - 用于更新的字节数
        异常
        ArrayIndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off+len为负数或大于数组 b的长度。

      • update

        public void update​(ByteBuffer buffer)
        用指定缓冲区的字节更新CRC-32C校验和。 校验和用缓冲区中的剩余字节更新，从缓冲区的位置开始。 返回时，缓冲区的位置将更新到其极限; 其限制将不会改变。
        Specified by:
        update在接口 Checksum
        参数
        buffer - ByteBuffer更新校验和

      • reset

        public void reset​()
        将CRC-32C复位为初始值。
        Specified by:
        reset在接口 Checksum

      • getValue

        public long getValue​()
        返回CRC-32C值。
        Specified by:
        getValue在接口 Checksum
        结果
        当前的校验和值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DataFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class DataFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.util.zip.DataFormatException
  • All Implemented Interfaces:
    Serializable

    public class DataFormatException
extends 异常
    发出数据格式错误的信号。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataFormatException​()
      构造一个没有详细消息的DataFormatException。
      DataFormatException​(String s)
      构造具有指定详细消息的DataFormatException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • DataFormatException

        public DataFormatException​()
        构造一个没有详细消息的DataFormatException。

      • DataFormatException

        public DataFormatException​(String s)
        构造具有指定详细消息的DataFormatException。 详细消息是描述此特定异常的字符串。
        参数
        s - 包含详细消息的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Deflater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class Deflater

  • java.lang.Object
    • java.util.zip.Deflater

  • public class Deflater
extends Object
    该类支持通用压缩使用流行的ZLIB压缩库。 ZLIB压缩库最初是作为PNG图形标准的一部分开发的，不受专利保护。 详细描述在java.util.zip package description的规格。

    以下代码片段使用Deflater和Inflater演示了对字符串的简单压缩和解压缩。

     try {
     // Encode a String into bytes
     String inputString = "blahblahblah";
     byte[] input = inputString.getBytes("UTF-8");

     // Compress the bytes
     byte[] output = new byte[100];
     Deflater compresser = new Deflater();
     compresser.setInput(input);
     compresser.finish();
     int compressedDataLength = compresser.deflate(output);
     compresser.end();

     // Decompress the bytes
     Inflater decompresser = new Inflater();
     decompresser.setInput(output, 0, compressedDataLength);
     byte[] result = new byte[100];
     int resultLength = decompresser.inflate(result);
     decompresser.end();

     // Decode the bytes into a String
     String outputString = new String(result, 0, resultLength, "UTF-8");
 } catch(java.io.UnsupportedEncodingException ex) {
     // handle
 } catch (java.util.zip.DataFormatException ex) {
     // handle
 }
    从以下版本开始：
    1.1
    另请参见：
    Inflater

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BEST_COMPRESSION
      最佳压缩压缩级别。
      static int BEST_SPEED
      压缩级别最快的压缩。
      static int DEFAULT_COMPRESSION
      默认压缩级别。
      static int DEFAULT_STRATEGY
      默认压缩策略。
      static int DEFLATED
      减压算法的压缩方法（目前唯一支持的）。
      static int FILTERED
      压缩策略最适用于主要由具有随机分布的小值组成的数据。
      static int FULL_FLUSH
      压缩冲洗模式用于清除所有待处理输出并重置放气器。
      static int HUFFMAN_ONLY
      仅用于霍夫曼编码的压缩策略。
      static int NO_COMPRESSION
      压缩等级为无压缩。
      static int NO_FLUSH
      压缩冲洗模式用于实现最佳压缩效果。
      static int SYNC_FLUSH
      压缩冲洗模式用于清除所有挂起的输出; 可能会降低某些压缩算法的压缩率。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Deflater​()
      创建一个具有默认压缩级别的新压缩器。
      Deflater​(int level)
      使用指定的压缩级别创建新的压缩器。
      Deflater​(int level, boolean nowrap)
      使用指定的压缩级别创建新的压缩器。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int deflate​(byte[] b)
      压缩输入数据，并用压缩数据填充指定的缓冲区。
      int deflate​(byte[] b, int off, int len)
      压缩输入数据，并用压缩数据填充指定的缓冲区。
      int deflate​(byte[] b, int off, int len, int flush)
      压缩输入数据，并用压缩数据填充指定的缓冲区。
      void end​()
      关闭压缩器并丢弃任何未处理的输入。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      void finish​()
      当被调用时，表示压缩应以输入缓冲区的当前内容结束。
      boolean finished​()
      如果达到压缩数据输出流的结尾，则返回true。
      int getAdler​()
      返回未压缩数据的ADLER-32值。
      long getBytesRead​()
      返回到目前为止输入的未压缩字节的总数。
      long getBytesWritten​()
      返回到目前为止输出的压缩字节总数。
      int getTotalIn​()
      返回到目前为止输入的未压缩字节的总数。
      int getTotalOut​()
      返回到目前为止输出的压缩字节总数。
      boolean needsInput​()
      如果输入数据缓冲区为空，则返回true，并调用setInput（）以提供更多的输入。
      void reset​()
      重置deflater，以便可以处理一组新的输入数据。
      void setDictionary​(byte[] b)
      设置压缩预设字典。
      void setDictionary​(byte[] b, int off, int len)
      设置压缩预设字典。
      void setInput​(byte[] b)
      设置压缩输入数据。
      void setInput​(byte[] b, int off, int len)
      设置压缩输入数据。
      void setLevel​(int level)
      将压缩级别设置为指定的值。
      void setStrategy​(int strategy)
      将压缩策略设置为指定值。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFLATED

        public static final int DEFLATED
        减压算法的压缩方法（目前唯一支持的）。
        另请参见：
        Constant Field Values

      • NO_COMPRESSION

        public static final int NO_COMPRESSION
        压缩等级为无压缩。
        另请参见：
        Constant Field Values

      • BEST_SPEED

        public static final int BEST_SPEED
        压缩级别最快的压缩。
        另请参见：
        Constant Field Values

      • BEST_COMPRESSION

        public static final int BEST_COMPRESSION
        最佳压缩压缩级别。
        另请参见：
        Constant Field Values

      • DEFAULT_COMPRESSION

        public static final int DEFAULT_COMPRESSION
        默认压缩级别。
        另请参见：
        Constant Field Values

      • FILTERED

        public static final int FILTERED
        压缩策略最适用于主要由具有随机分布的小值组成的数据。 强制更多的霍夫曼编码和较少的字符串匹配。
        另请参见：
        Constant Field Values

      • HUFFMAN_ONLY

        public static final int HUFFMAN_ONLY
        仅用于霍夫曼编码的压缩策略。
        另请参见：
        Constant Field Values

      • DEFAULT_STRATEGY

        public static final int DEFAULT_STRATEGY
        默认压缩策略。
        另请参见：
        Constant Field Values

      • NO_FLUSH

        public static final int NO_FLUSH
        压缩冲洗模式用于实现最佳压缩效果。
        从以下版本开始：
        1.7
        另请参见：
        deflate(byte[], int, int, int) ， Constant Field Values

      • SYNC_FLUSH

        public static final int SYNC_FLUSH
        压缩冲洗模式用于清除所有挂起的输出; 可能会降低某些压缩算法的压缩率。
        从以下版本开始：
        1.7
        另请参见：
        deflate(byte[], int, int, int) ， Constant Field Values

      • FULL_FLUSH

        public static final int FULL_FLUSH
        压缩冲洗模式用于清除所有待处理输出并重置放气器。 使用此模式太频繁可能会严重降低压缩。
        从以下版本开始：
        1.7
        另请参见：
        deflate(byte[], int, int, int) ， Constant Field Values

    • 构造方法详细信息

      • Deflater

        public Deflater​(int level,
                boolean nowrap)
        使用指定的压缩级别创建新的压缩器。 如果'nowrap'为真，那么ZLIB头和校验和字段将不被使用以支持GZIP和PKZIP中使用的压缩格式。
        参数
        level - 压缩级别（0-9）
        nowrap - 如果为true，则使用GZIP兼容压缩

      • Deflater

        public Deflater​(int level)
        使用指定的压缩级别创建新的压缩器。 压缩数据将以ZLIB格式生成。
        参数
        level - 压缩级别（0-9）

      • Deflater

        public Deflater​()
        创建一个具有默认压缩级别的新压缩器。 压缩数据将以ZLIB格式生成。

    • 方法详细信息

      • setInput

        public void setInput​(byte[] b,
                     int off,
                     int len)
        设置压缩输入数据。 当needInput（）返回true表示需要更多输入数据时，应该调用此值。
        参数
        b - 输入数据字节
        off - 数据的起始偏移量
        len - 数据的长度
        另请参见：
        needsInput()

      • setInput

        public void setInput​(byte[] b)
        设置压缩输入数据。 当needInput（）返回true表示需要更多输入数据时，应该调用此值。
        参数
        b - 输入数据字节
        另请参见：
        needsInput()

      • setDictionary

        public void setDictionary​(byte[] b,
                          int off,
                          int len)
        设置压缩预设字典。 当可以预定历史缓冲区时，使用预设字典。 当数据随后用Inflater.inflate（）解压缩时，可以调用Inflater.getAdler（），以获得解压缩所需的字典的Adler-32值。
        参数
        b - 字典数据字节
        off - 数据的起始偏移量
        len - 数据的长度
        另请参见：
        Inflater.inflate(byte[], int, int) ， Inflater.getAdler()

      • setDictionary

        public void setDictionary​(byte[] b)
        设置压缩预设字典。 当可以预定历史缓冲区时，使用预设字典。 当数据随后用Inflater.inflate（）解压缩时，可以调用Inflater.getAdler（），以获得解压缩所需的字典的Adler-32值。
        参数
        b - 字典数据字节
        另请参见：
        Inflater.inflate(byte[], int, int) ， Inflater.getAdler()

      • setStrategy

        public void setStrategy​(int strategy)
        将压缩策略设置为指定值。

        如果压缩策略发生变化，下一次调用deflate将压缩目前为止可用的旧策略（并可能被刷新）; 新策略只有在该调用之后才会生效。

        参数
        strategy - 新的压缩策略
        异常
        IllegalArgumentException - 如果压缩策略无效

      • setLevel

        public void setLevel​(int level)
        将压缩级别设置为指定的值。

        如果压缩级别改变，下一次调用deflate将压缩到目前为止可用的输入为旧级别（并可能被刷新）; 新的级别只有在该调用之后才会生效。

        参数
        level - 新的压缩级别（0-9）
        异常
        IllegalArgumentException - 如果压缩级别无效

      • needsInput

        public boolean needsInput​()
        如果输入数据缓冲区为空，则返回true，并调用setInput（）以提供更多的输入。
        结果
        如果输入数据缓冲区为空，并且应该调用setInput（）以提供更多的输入，则为true

      • finish

        public void finish​()
        当被调用时，表示压缩应以输入缓冲区的当前内容结束。

      • finished

        public boolean finished​()
        如果达到压缩数据输出流的结尾，则返回true。
        结果
        如果已经达到压缩数据输出流的结束，则为真

      • deflate

        public int deflate​(byte[] b,
                   int off,
                   int len)
        压缩输入数据，并用压缩数据填充指定的缓冲区。 返回压缩数据的实际字节数。 返回值为0表示应该调用needsInput ，以确定是否需要更多的输入数据。

        此方法使用NO_FLUSH作为其压缩刷新模式。 调用deflater.deflate(b, off, len)形式的此方法产生与调用deflater.deflate(b, off, len, Deflater.NO_FLUSH)相同的结果。

        参数
        b - 压缩数据的缓冲区
        off - 数据的起始偏移量
        len - 压缩数据的最大字节数
        结果
        压缩数据的实际字节数写入输出缓冲区

      • deflate

        public int deflate​(byte[] b)
        压缩输入数据，并用压缩数据填充指定的缓冲区。 返回压缩数据的实际字节数。 返回值为0表示应该调用needsInput ，以确定是否需要更多的输入数据。

        此方法使用NO_FLUSH作为其压缩刷新模式。 调用deflater.deflate(b)形式的deflater.deflate(b)产生与调用deflater.deflate(b, 0, b.length, Deflater.NO_FLUSH)相同的结果。

        参数
        b - 压缩数据的缓冲区
        结果
        压缩数据的实际字节数写入输出缓冲区

      • deflate

        public int deflate​(byte[] b,
                   int off,
                   int len,
                   int flush)
        压缩输入数据，并用压缩数据填充指定的缓冲区。 返回压缩的实际数据字节数。

        压缩冲洗模式是以下三种模式之一：

        • NO_FLUSH ：为了达到最佳压缩（在正常使用情况下应该使用），允许放样器决定在产生输出之前累积多少数据。 此刷新模式中的返回值为0表示应该调用needsInput() ，以确定是否需要更多的输入数据。
        • SYNC_FLUSH ：在deflater所有悬而未决的输出被刷新，到指定的输出缓冲器，使该对压缩数据的工作吹气可以得到可到目前为止，所有输入数据（尤其是needsInput()个回报true这个调用后，如果提供足够的输出空间）。 用SYNC_FLUSH冲洗可能会降低某些压缩算法的压缩，因此只有在必要时才能使用。
        • FULL_FLUSH ：所有待处理输出都将与SYNC_FLUSH一起刷新 。 压缩状态被重置，使得如果先前的压缩数据已被损坏或者需要随机访问，则从压缩输出数据起作用的充气机可以从该点重新启动。 使用FULL_FLUSH也经常会严重降级压缩。

        在FULL_FLUSH或SYNC_FLUSH的情况下，如果返回值为len ，输出缓冲区b可用的空间，此方法应再次调用相同的flush参数和更多的输出空间。 确保len大于6，以避免在每次调用此方法时将冲洗标记（5字节）重复输出到输出缓冲区。

        参数
        b - 压缩数据的缓冲区
        off - 数据的起始偏移量
        len - 压缩数据的最大字节数
        flush - 压缩冲洗模式
        结果
        压缩数据的实际字节数写入输出缓冲区
        异常
        IllegalArgumentException - 如果刷新模式无效
        从以下版本开始：
        1.7

      • getAdler

        public int getAdler​()
        返回未压缩数据的ADLER-32值。
        结果
        未压缩数据的ADLER-32值

      • getTotalIn

        public int getTotalIn​()
        返回到目前为止输入的未压缩字节的总数。

        由于字节数可能大于Integer.MAX_VALUE，因此getBytesRead()方法现在是获取此信息的首选方法。

        结果
        到目前为止输入的未压缩字节的总数

      • getBytesRead

        public long getBytesRead​()
        返回到目前为止输入的未压缩字节的总数。
        结果
        到目前为止输入的未压缩字节的总数（非负数）
        从以下版本开始：
        1.5

      • getTotalOut

        public int getTotalOut​()
        返回到目前为止输出的压缩字节总数。

        由于字节数可能大于Integer.MAX_VALUE，因此getBytesWritten()方法现在是获取此信息的首选方法。

        结果
        到目前为止输出的压缩字节总数

      • getBytesWritten

        public long getBytesWritten​()
        返回到目前为止输出的压缩字节总数。
        结果
        到目前为止输出的压缩字节数（非负数）
        从以下版本开始：
        1.5

      • reset

        public void reset​()
        重置deflater，以便可以处理一组新的输入数据。 保持当前的压缩级别和策略设置。

      • end

        public void end​()
        关闭压缩器并丢弃任何未处理的输入。 当压缩机不再使用时，应该调用此方法，但也可以通过finalize（）方法自动调用该方法。 调用此方法后，Deflater对象的行为是未定义的。

      • finalize

        @Deprecated(since="9")
protected void finalize​()
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        收集垃圾时关闭压缩机。
        重写：
        finalize在 Object
        另请参见：
        WeakReference ， PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DeflaterInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class DeflaterInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.util.zip.DeflaterInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class DeflaterInputStream
extends FilterInputStream
    实现用于压缩“放气”压缩格式的数据的输入流过滤器。
    从以下版本开始：
    1.6
    另请参见：
    DeflaterOutputStream ， InflaterOutputStream ， InflaterInputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buf
      用于读取压缩数据的输入缓冲区
      protected Deflater def
      此流的压缩器。

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      构造方法
      Constructor 描述
      DeflaterInputStream​(InputStream in)
      创建一个具有默认压缩器和缓冲区大小的新输入流。
      DeflaterInputStream​(InputStream in, Deflater defl)
      使用指定的压缩器和默认缓冲区大小创建新的输入流。
      DeflaterInputStream​(InputStream in, Deflater defl, int bufLen)
      创建具有指定压缩器和缓冲区大小的新输入流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      到达EOF后返回0，否则总是返回1。
      void close​()
      关闭此输入流及其底层输入流，丢弃任何待处理的未压缩数据。
      void mark​(int limit)
      不支持此操作 。
      boolean markSupported​()
      始终返回 false因为此输入流不支持 mark()和 reset()方法。
      int read​()
      从输入流读取一个字节的压缩数据。
      int read​(byte[] b, int off, int len)
      将压缩数据读入字节数组。
      void reset​()
      不支持此操作 。
      long skip​(long n)
      跳过并丢弃输入流中的数据。

      • Methods inherited from class java.io.FilterInputStream

        read

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • def

        protected final Deflater def
        此流的压缩器。

      • buf

        protected final byte[] buf
        用于读取压缩数据的输入缓冲区

    • 构造方法详细信息

      • DeflaterInputStream

        public DeflaterInputStream​(InputStream in)
        创建一个具有默认压缩器和缓冲区大小的新输入流。
        参数
        in - 用于读取未压缩数据的输入流
        异常
        NullPointerException - 如果 in为空

      • DeflaterInputStream

        public DeflaterInputStream​(InputStream in,
                           Deflater defl)
        使用指定的压缩器和默认缓冲区大小创建新的输入流。
        参数
        in - 读取未压缩数据的输入流
        defl - 此流的压缩器（“deflater”）
        异常
        NullPointerException - 如果 in或 defl为空

      • DeflaterInputStream

        public DeflaterInputStream​(InputStream in,
                           Deflater defl,
                           int bufLen)
        创建具有指定压缩器和缓冲区大小的新输入流。
        参数
        in - 输入流以读取未压缩数据
        defl - 此流的压缩器（“deflater”）
        bufLen - 压缩缓冲区大小
        异常
        IllegalArgumentException - 如果是 bufLen <= 0
        NullPointerException - 如果 in或 defl为空

    • 方法详细信息

      • close

        public void close​()
           throws IOException
        关闭此输入流及其底层输入流，丢弃任何待处理的未压缩数据。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 FilterInputStream
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterInputStream.in

      • read

        public int read​()
         throws IOException
        从输入流读取一个字节的压缩数据。 该方法将阻塞，直到可以读取和压缩一些输入。
        重写：
        read在 FilterInputStream
        结果
        单个字节的压缩数据，如果达到未压缩输入流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误或者该流已经关闭
        另请参见：
        FilterInputStream.in

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        将压缩数据读入字节数组。 该方法将阻塞，直到可以读取和压缩一些输入。
        重写：
        read在 FilterInputStream
        参数
        b - 读取数据的缓冲区
        off - b内数据的起始偏移量
        len - 要读取的最大压缩字节数 b
        结果
        读取的实际字节数，如果达到未压缩输入流的结尾，则为-1
        异常
        IndexOutOfBoundsException - 如果是 len > b.length - off
        IOException - 如果发生I / O错误或输入流已经关闭
        另请参见：
        FilterInputStream.in

      • skip

        public long skip​(long n)
          throws IOException
        跳过并丢弃输入流中的数据。 该方法可能会阻塞，直到读取和跳过指定的字节数为止。 注： n为long ，可跳过的最大字节数为Integer.MAX_VALUE 。
        重写：
        skip在 FilterInputStream
        参数
        n - 要跳过的字节数
        结果
        实际跳过的字节数
        异常
        IOException - 如果发生I / O错误或者该流已经关闭

      • available

        public int available​()
              throws IOException
        到达EOF后返回0，否则总是返回1。

        程序不应该依赖此方法来返回可以读取而不阻止的实际字节数

        重写：
        available在 FilterInputStream
        结果
        底层输入流结束后零，否则总是返回1
        异常
        IOException - 如果发生I / O错误或者该流已经关闭

      • markSupported

        public boolean markSupported​()
        始终返回 false因为此输入流不支持 mark()和 reset()方法。
        重写：
        markSupported在 FilterInputStream
        结果
        假，永远
        另请参见：
        FilterInputStream.in ， InputStream.mark(int) ， InputStream.reset()

      • mark

        public void mark​(int limit)
        不支持此操作 。
        重写：
        mark在 FilterInputStream
        参数
        limit - 在使位置标记无效之前可以读取的最大字节数
        另请参见：
        FilterInputStream.in ， FilterInputStream.reset()

      • reset

        public void reset​()
           throws IOException
        不支持此操作 。
        重写：
        reset在 FilterInputStream
        异常
        IOException - 总是抛出
        另请参见：
        FilterInputStream.in, FilterInputStream.mark(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DeflaterOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class DeflaterOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.util.zip.DeflaterOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable
    已知直接子类：
    GZIPOutputStream ， ZipOutputStream

    public class DeflaterOutputStream
extends FilterOutputStream
    该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。 它也被用作其他类型压缩滤波器的基础，如GZIPOutputStream。
    从以下版本开始：
    1.1
    另请参见：
    Deflater

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buf
      用于写入压缩数据的输出缓冲区
      protected Deflater def
      此流的压缩器。

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Constructor 描述
      DeflaterOutputStream​(OutputStream out)
      创建具有默认压缩器和缓冲区大小的新输出流。
      DeflaterOutputStream​(OutputStream out, boolean syncFlush)
      使用默认压缩器，默认缓冲区大小和指定的刷新模式创建新的输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def)
      使用指定的压缩器和默认缓冲区大小创建新的输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def, boolean syncFlush)
      使用指定的压缩器，刷新模式和默认缓冲区大小创建新的输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def, int size)
      创建具有指定压缩器和缓冲区大小的新输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def, int size, boolean syncFlush)
      创建具有指定压缩器，缓冲区大小和冲洗模式的新输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      将剩余的压缩数据写入输出流并关闭底层流。
      protected void deflate​()
      将下一个压缩数据块写入输出流。
      void finish​()
      完成将压缩数据写入输出流，而不关闭底层流。
      void flush​()
      刷新压缩的输出流。
      void write​(byte[] b, int off, int len)
      将一个字节数组写入压缩的输出流。
      void write​(int b)
      将一个字节写入压缩的输出流。

      • Methods inherited from class java.io.FilterOutputStream

        write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • def

        protected Deflater def
        此流的压缩器。

      • buf

        protected byte[] buf
        用于写入压缩数据的输出缓冲区

    • 构造方法详细信息

      • DeflaterOutputStream

        public DeflaterOutputStream​(OutputStream out,
                            Deflater def,
                            int size,
                            boolean syncFlush)
        创建具有指定压缩器，缓冲区大小和冲洗模式的新输出流。
        参数
        out - 输出流
        def - 压缩机（“deflater”）
        size - 输出缓冲区大小
        syncFlush - 如果 true这个实例的 flush()方法在刷新输出流之前用冲洗模式 Deflater.SYNC_FLUSH刷新压缩器，否则仅刷新输出流
        异常
        IllegalArgumentException - 如果是 size <= 0
        从以下版本开始：
        1.7

      • DeflaterOutputStream

        public DeflaterOutputStream​(OutputStream out,
                            Deflater def,
                            int size)
        创建具有指定压缩器和缓冲区大小的新输出流。

        通过调用4参数构造函数DeflaterOutputStream（out，def，size，false）创建新的输出流实例。

        参数
        out - 输出流
        def - 压缩机（“deflater”）
        size - 输出缓冲区大小
        异常
        IllegalArgumentException - 如果是 size <= 0

      • DeflaterOutputStream

        public DeflaterOutputStream​(OutputStream out,
                            Deflater def,
                            boolean syncFlush)
        使用指定的压缩器，刷新模式和默认缓冲区大小创建新的输出流。
        参数
        out - 输出流
        def - 压缩机（“deflater”）
        syncFlush - 如果 true ，此实例的 flush()方法在刷新输出流之前用冲洗模式 Deflater.SYNC_FLUSH刷新压缩器，否则仅刷新输出流
        从以下版本开始：
        1.7

      • DeflaterOutputStream

        public DeflaterOutputStream​(OutputStream out,
                            Deflater def)
        使用指定的压缩器和默认缓冲区大小创建新的输出流。

        通过调用3参数构造函数DeflaterOutputStream（out，def，false）创建新的输出流实例。

        参数
        out - 输出流
        def - 压缩机（“deflater”）

      • DeflaterOutputStream

        public DeflaterOutputStream​(OutputStream out,
                            boolean syncFlush)
        使用默认压缩器，默认缓冲区大小和指定的刷新模式创建新的输出流。
        参数
        out - 输出流
        syncFlush - 如果 true此实例的 flush()方法在刷新输出流之前用冲洗模式 Deflater.SYNC_FLUSH刷新压缩器，否则仅刷新输出流
        从以下版本开始：
        1.7

      • DeflaterOutputStream

        public DeflaterOutputStream​(OutputStream out)
        创建具有默认压缩器和缓冲区大小的新输出流。

        通过调用2参数构造函数DeflaterOutputStream（out，false），创建新的输出流实例。

        参数
        out - 输出流

    • 方法详细信息

      • write

        public void write​(int b)
           throws IOException
        将一个字节写入压缩的输出流。 该方法将阻塞直到该字节被写入。
        重写：
        write FilterOutputStream
        参数
        b - 要写入的字节
        异常
        IOException - 如果发生I / O错误

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        将一个字节数组写入压缩的输出流。 该方法将阻塞，直到写入所有字节为止。
        重写：
        write在 FilterOutputStream
        参数
        b - 要写入的数据
        off - 数据的起始偏移量
        len - 数据的长度
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterOutputStream.write(int)

      • finish

        public void finish​()
            throws IOException
        完成将压缩数据写入输出流，而不关闭底层流。 在连续使用多个过滤器到相同的输出流时使用此方法。
        异常
        IOException - 如果发生I / O错误

      • close

        public void close​()
           throws IOException
        将剩余的压缩数据写入输出流并关闭底层流。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 FilterOutputStream
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterOutputStream.flush() ， FilterOutputStream.out

      • deflate

        protected void deflate​()
                throws IOException
        将下一个压缩数据块写入输出流。
        异常
        IOException - 如果发生I / O错误

      • flush

        public void flush​()
           throws IOException
        刷新压缩的输出流。 如果syncFlush是true当此压缩输出流被构造时，该方法首先用冲洗模式Deflater.SYNC_FLUSH刷新底层compressor ，以迫使所有挂起的数据被刷新到输出流，然后刷新输出流。 否则，此方法仅刷新输出流，而不刷新compressor 。
        Specified by:
        flush在接口 Flushable
        重写：
        flush在 FilterOutputStream
        异常
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.7
        另请参见：
        FilterOutputStream.out
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


GZIPInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class GZIPInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.GZIPInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class GZIPInputStream
extends InflaterInputStream
    该类实现了一个流过滤器，用于读取GZIP文件格式的压缩数据。
    从以下版本开始：
    1.1
    另请参见：
    InflaterInputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected CRC32 crc
      CRC-32用于未压缩数据。
      protected boolean eos
      表示输入流结束。
      static int GZIP_MAGIC
      GZIP标题魔数。

      • Fields inherited from class java.io.FilterInputStream

        in

      • Fields inherited from class java.util.zip.InflaterInputStream

        buf, inf, len

    • 构造方法摘要

      构造方法
      Constructor 描述
      GZIPInputStream​(InputStream in)
      创建一个默认缓冲区大小的新输入流。
      GZIPInputStream​(InputStream in, int size)
      创建具有指定缓冲区大小的新输入流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      int read​(byte[] buf, int off, int len)
      将未压缩的数据读入字节数组。

      • Methods inherited from class java.io.FilterInputStream

        read

      • Methods inherited from class java.util.zip.InflaterInputStream

        available, fill, mark, markSupported, read, reset, skip

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • crc

        protected CRC32 crc
        CRC-32用于未压缩数据。

      • eos

        protected boolean eos
        表示输入流结束。

      • GZIP_MAGIC

        public static final int GZIP_MAGIC
        GZIP标题魔数。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • GZIPInputStream

        public GZIPInputStream​(InputStream in,
                       int size)
                throws IOException
        创建具有指定缓冲区大小的新输入流。
        参数
        in - 输入流
        size - 输入缓冲区大小
        异常
        ZipException - 如果发生GZIP格式错误或不支持使用压缩方法
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果是 size <= 0

      • GZIPInputStream

        public GZIPInputStream​(InputStream in)
                throws IOException
        创建一个默认缓冲区大小的新输入流。
        参数
        in - 输入流
        异常
        ZipException - 如果发生GZIP格式错误或不支持使用压缩方法
        IOException - 如果发生I / O错误

    • 方法详细信息

      • read

        public int read​(byte[] buf,
                int off,
                int len)
         throws IOException
        将未压缩的数据读入字节数组。 如果len不为零，则该方法将阻塞，直到可以解压缩某些输入; 否则，不会读取字节，并返回0 。
        重写：
        read在 InflaterInputStream
        参数
        buf - 读取数据的缓冲区
        off - 目标阵列 b的起始偏移量
        len - 读取的最大字节数
        结果
        读取的实际字节数，如果达到压缩输入流的结尾，则为-1
        异常
        NullPointerException - 如果 buf是 null 。
        IndexOutOfBoundsException - 如果 off为负数，则 len为负数，或 len大于 buf.length - off
        ZipException - 如果压缩输入数据已损坏。
        IOException - 如果发生I / O错误。
        另请参见：
        FilterInputStream.in

      • close

        public void close​()
           throws IOException
        关闭此输入流并释放与流相关联的任何系统资源。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 InflaterInputStream
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterInputStream.in
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


GZIPOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class GZIPOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.GZIPOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class GZIPOutputStream
extends DeflaterOutputStream
    该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected CRC32 crc
      未压缩数据的CRC-32。

      • Fields inherited from class java.util.zip.DeflaterOutputStream

        buf, def

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Constructor 描述
      GZIPOutputStream​(OutputStream out)
      创建一个具有默认缓冲区大小的新输出流。
      GZIPOutputStream​(OutputStream out, boolean syncFlush)
      创建具有默认缓冲区大小和指定刷新模式的新输出流。
      GZIPOutputStream​(OutputStream out, int size)
      创建具有指定缓冲区大小的新输出流。
      GZIPOutputStream​(OutputStream out, int size, boolean syncFlush)
      创建具有指定缓冲区大小和刷新模式的新输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void finish​()
      完成将压缩数据写入输出流，而不关闭底层流。
      void write​(byte[] buf, int off, int len)
      将字节数组写入压缩输出流。

      • Methods inherited from class java.util.zip.DeflaterOutputStream

        close, deflate, flush, write

      • Methods inherited from class java.io.FilterOutputStream

        write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • crc

        protected CRC32 crc
        未压缩数据的CRC-32。

    • 构造方法详细信息

      • GZIPOutputStream

        public GZIPOutputStream​(OutputStream out,
                        int size)
                 throws IOException
        创建具有指定缓冲区大小的新输出流。

        通过调用3参数构造函数GZIPOutputStream（out，size，false）创建新的输出流实例。

        参数
        out - 输出流
        size - 输出缓冲区大小
        异常
        IOException - 如果发生I / O错误。
        IllegalArgumentException - 如果是 size <= 0

      • GZIPOutputStream

        public GZIPOutputStream​(OutputStream out,
                        int size,
                        boolean syncFlush)
                 throws IOException
        创建具有指定缓冲区大小和刷新模式的新输出流。
        参数
        out - 输出流
        size - 输出缓冲区大小
        syncFlush - 如果 true的继承的 flush()方法的调用方式在刷新输出流之前用冲洗模式 Deflater.SYNC_FLUSH刷新压缩器，否则仅刷新输出流
        异常
        IOException - 如果发生I / O错误。
        IllegalArgumentException - 如果是 size <= 0
        从以下版本开始：
        1.7

      • GZIPOutputStream

        public GZIPOutputStream​(OutputStream out)
                 throws IOException
        创建一个具有默认缓冲区大小的新输出流。

        创建新的输出流实例就好像通过调用2参数构造函数GZIPOutputStream（out，false）一样。

        参数
        out - 输出流
        异常
        IOException - 如果发生I / O错误。

      • GZIPOutputStream

        public GZIPOutputStream​(OutputStream out,
                        boolean syncFlush)
                 throws IOException
        创建具有默认缓冲区大小和指定刷新模式的新输出流。
        参数
        out - 输出流
        syncFlush - 如果 true这个实例的继承的 flush()方法的调用在刷新输出流之前用冲洗模式 Deflater.SYNC_FLUSH刷新压缩器，否则仅刷新输出流
        异常
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.7

    • 方法详细信息

      • write

        public void write​(byte[] buf,
                  int off,
                  int len)
           throws IOException
        将字节数组写入压缩输出流。 该方法将阻塞，直到写入所有字节为止。
        重写：
        write在 DeflaterOutputStream
        参数
        buf - 要写入的数据
        off - 数据的起始偏移量
        len - 数据的长度
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.write(int)

      • finish

        public void finish​()
            throws IOException
        完成将压缩数据写入输出流，而不关闭底层流。 在连续使用多个过滤器到相同的输出流时使用此方法。
        重写：
        finish在 DeflaterOutputStream
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Inflater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class Inflater

  • java.lang.Object
    • java.util.zip.Inflater

  • public class Inflater
extends Object
    此类提供对使用流行的ZLIB压缩库的通用解压缩的支持。 ZLIB压缩库最初是作为PNG图形标准的一部分开发的，不受专利保护。 详细描述在java.util.zip package description的规格。

    以下代码片段使用Deflater和Inflater演示了对字符串的简单压缩和解压缩。

     try {
     // Encode a String into bytes
     String inputString = "blahblahblah??";
     byte[] input = inputString.getBytes("UTF-8");

     // Compress the bytes
     byte[] output = new byte[100];
     Deflater compresser = new Deflater();
     compresser.setInput(input);
     compresser.finish();
     int compressedDataLength = compresser.deflate(output);

     // Decompress the bytes
     Inflater decompresser = new Inflater();
     decompresser.setInput(output, 0, compressedDataLength);
     byte[] result = new byte[100];
     int resultLength = decompresser.inflate(result);
     decompresser.end();

     // Decode the bytes into a String
     String outputString = new String(result, 0, resultLength, "UTF-8");
 } catch(java.io.UnsupportedEncodingException ex) {
     // handle
 } catch (java.util.zip.DataFormatException ex) {
     // handle
 }
    从以下版本开始：
    1.1
    另请参见：
    Deflater

    • 构造方法摘要

      构造方法
      Constructor 描述
      Inflater​()
      创建一个新的解压缩程序。
      Inflater​(boolean nowrap)
      创建一个新的解压缩程序。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void end​()
      关闭解压缩程序并丢弃任何未处理的输入。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      boolean finished​()
      如果达到压缩数据流的结尾，则返回true。
      int getAdler​()
      返回未压缩数据的ADLER-32值。
      long getBytesRead​()
      返回到目前为止输入的压缩字节的总数。
      long getBytesWritten​()
      返回到目前为止输出的未压缩字节的总数。
      int getRemaining​()
      返回输入缓冲区中剩余的总字节数。
      int getTotalIn​()
      返回到目前为止输入的压缩字节的总数。
      int getTotalOut​()
      返回到目前为止输出的未压缩字节的总数。
      int inflate​(byte[] b)
      将字节解压缩到指定的缓冲区。
      int inflate​(byte[] b, int off, int len)
      将字节解压缩到指定的缓冲区。
      boolean needsDictionary​()
      如果需要预设字典进行解压缩，则返回true。
      boolean needsInput​()
      如果输入缓冲区中没有数据，则返回true。
      void reset​()
      重新设置充气器，以便可以处理一组新的输入数据。
      void setDictionary​(byte[] b)
      将预设字典设置为给定的字节数组。
      void setDictionary​(byte[] b, int off, int len)
      将预设字典设置为给定的字节数组。
      void setInput​(byte[] b)
      设置解压缩的输入数据。
      void setInput​(byte[] b, int off, int len)
      设置解压缩的输入数据。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Inflater

        public Inflater​(boolean nowrap)
        创建一个新的解压缩程序。 如果参数“nowrap”为真，则不会使用ZLIB头和校验和字段。 这提供了与GZIP和PKZIP两者使用的压缩格式的兼容性。

        注意：当使用'nowrap'选项时，还需要提供一个额外的“dummy”字节作为输入。 为了支持某些优化，这是ZLIB本机库所必需的。

        参数
        nowrap - 如果为true，则支持GZIP兼容压缩

      • Inflater

        public Inflater​()
        创建一个新的解压缩程序。

    • 方法详细信息

      • setInput

        public void setInput​(byte[] b,
                     int off,
                     int len)
        设置解压缩的输入数据。 每当needInput（）返回true时都应调用，表示需要输入更多的数据。
        参数
        b - 输入数据字节
        off - 输入数据的起始偏移量
        len - 输入数据的长度
        另请参见：
        needsInput()

      • setInput

        public void setInput​(byte[] b)
        设置解压缩的输入数据。 每当needInput（）返回true时都应调用，表示需要输入更多的数据。
        参数
        b - 输入数据字节
        另请参见：
        needsInput()

      • setDictionary

        public void setDictionary​(byte[] b,
                          int off,
                          int len)
        将预设字典设置为给定的字节数组。 当inflate（）返回0并且needsDictionary（）返回true时，应该调用，表示需要预设的字典。 方法getAdler（）可用于获取所需字典的Adler-32值。
        参数
        b - 字典数据字节
        off - 数据的起始偏移量
        len - 数据的长度
        另请参见：
        needsDictionary() ， getAdler()

      • setDictionary

        public void setDictionary​(byte[] b)
        将预设字典设置为给定的字节数组。 当inflate（）返回0并且needsDictionary（）返回true时，应该调用，表示需要预设的字典。 方法getAdler（）可用于获取所需字典的Adler-32值。
        参数
        b - 字典数据字节
        另请参见：
        needsDictionary() ， getAdler()

      • getRemaining

        public int getRemaining​()
        返回输入缓冲区中剩余的总字节数。 这可以用于查找在解压缩完成后仍然保留在输入缓冲区中的字节。
        结果
        输入缓冲区中剩余的总字节数

      • needsInput

        public boolean needsInput​()
        如果输入缓冲区中没有数据，则返回true。 这可以用来确定是否应该调用#setInput以便提供更多的输入。
        结果
        如果输入缓冲区中没有数据，则为true

      • needsDictionary

        public boolean needsDictionary​()
        如果需要预设字典进行解压缩，则返回true。
        结果
        如果需要预设字典进行解压缩，则为true
        另请参见：
        setDictionary(byte[], int, int)

      • finished

        public boolean finished​()
        如果达到压缩数据流的结尾，则返回true。
        结果
        如果已经达到压缩数据流的结束，则为true

      • inflate

        public int inflate​(byte[] b,
                   int off,
                   int len)
            throws DataFormatException
        将字节解压缩到指定的缓冲区。 返回实际的未压缩字节数。 返回值为0表示需要调用needsInput（）或needsDictionary（），以确定是否需要更多输入数据或预设字典。 在后一种情况下，getAdler（）可用于获取所需字典的Adler-32值。
        参数
        b - 未压缩数据的缓冲区
        off - 数据的起始偏移量
        len - 未压缩字节的最大数量
        结果
        实际的未压缩字节数
        异常
        DataFormatException - 如果压缩数据格式无效
        另请参见：
        needsInput() ， needsDictionary()

      • inflate

        public int inflate​(byte[] b)
            throws DataFormatException
        将字节解压缩到指定的缓冲区。 返回实际的未压缩字节数。 返回值为0表示需要调用needsInput（）或needsDictionary（），以确定是否需要更多输入数据或预设字典。 在后一种情况下，getAdler（）可用于获取所需字典的Adler-32值。
        参数
        b - 未压缩数据的缓冲区
        结果
        实际的未压缩字节数
        异常
        DataFormatException - 如果压缩数据格式无效
        另请参见：
        needsInput() ， needsDictionary()

      • getAdler

        public int getAdler​()
        返回未压缩数据的ADLER-32值。
        结果
        未压缩数据的ADLER-32值

      • getTotalIn

        public int getTotalIn​()
        返回到目前为止输入的压缩字节的总数。

        由于字节数可能大于Integer.MAX_VALUE，因此getBytesRead()方法现在是获取此信息的首选方法。

        结果
        到目前为止输入的压缩字节总数

      • getBytesRead

        public long getBytesRead​()
        返回到目前为止输入的压缩字节的总数。
        结果
        到目前为止输入的压缩字节数（非负数）
        从以下版本开始：
        1.5

      • getTotalOut

        public int getTotalOut​()
        返回到目前为止输出的未压缩字节的总数。

        由于字节数可能大于Integer.MAX_VALUE，因此getBytesWritten()方法现在是获取此信息的首选方法。

        结果
        到目前为止，未压缩字节输出的总数

      • getBytesWritten

        public long getBytesWritten​()
        返回到目前为止输出的未压缩字节的总数。
        结果
        迄今为止输出的未压缩字节数（非负数）
        从以下版本开始：
        1.5

      • reset

        public void reset​()
        重新设置充气器，以便可以处理一组新的输入数据。

      • end

        public void end​()
        关闭解压缩程序并丢弃任何未处理的输入。 当解压缩程序不再被使用时，应该调用此方法，也可以通过finalize（）方法自动调用该方法。 一旦调用此方法，Inflater对象的行为是未定义的。

      • finalize

        @Deprecated(since="9")
protected void finalize​()
        已过时。 finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中的描述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        收集垃圾时关闭解压缩程序。
        重写：
        finalize在 Object
        另请参见：
        WeakReference ， PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InflaterInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class InflaterInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.util.zip.InflaterInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    GZIPInputStream ， ZipInputStream

    public class InflaterInputStream
extends FilterInputStream
    该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。 它也被用作其他减压滤波器的基础，如GZIPInputStream。
    从以下版本开始：
    1.1
    另请参见：
    Inflater

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buf
      用于解压缩的输入缓冲区。
      protected Inflater inf
      解压缩此流。
      protected int len
      输入缓冲区的长度。

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      构造方法
      Constructor 描述
      InflaterInputStream​(InputStream in)
      使用默认解压缩器和缓冲区大小创建新的输入流。
      InflaterInputStream​(InputStream in, Inflater inf)
      使用指定的解压缩器和默认缓冲区大小创建新的输入流。
      InflaterInputStream​(InputStream in, Inflater inf, int size)
      使用指定的解压缩器和缓冲区大小创建新的输入流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      到达EOF后返回0，否则总是返回1。
      void close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      protected void fill​()
      填写输入缓冲区以获得更多的数据解压缩。
      void mark​(int readlimit)
      标记此输入流中的当前位置。
      boolean markSupported​()
      测试此输入流是否支持 mark和 reset方法。
      int read​()
      读取一个字节的未压缩数据。
      int read​(byte[] b, int off, int len)
      将未压缩的数据读入字节数组。
      void reset​()
      将此流重新定位到最后在此输入流上调用 mark方法时的位置。
      long skip​(long n)
      跳过未压缩数据的指定字节数。

      • Methods inherited from class java.io.FilterInputStream

        read

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • inf

        protected Inflater inf
        解压缩此流。

      • buf

        protected byte[] buf
        用于解压缩的输入缓冲区。

      • len

        protected int len
        输入缓冲区的长度。

    • 构造方法详细信息

      • InflaterInputStream

        public InflaterInputStream​(InputStream in,
                           Inflater inf,
                           int size)
        使用指定的解压缩器和缓冲区大小创建新的输入流。
        参数
        in - 输入流
        inf - 解压缩器（“inflater”）
        size - 输入缓冲区大小
        异常
        IllegalArgumentException - 如果是 size <= 0

      • InflaterInputStream

        public InflaterInputStream​(InputStream in,
                           Inflater inf)
        使用指定的解压缩器和默认缓冲区大小创建新的输入流。
        参数
        in - 输入流
        inf - 解压缩器（“inflater”）

      • InflaterInputStream

        public InflaterInputStream​(InputStream in)
        使用默认解压缩器和缓冲区大小创建新的输入流。
        参数
        in - 输入流

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        读取一个字节的未压缩数据。 该方法将阻塞，直到有足够的输入可用于解压缩。
        重写：
        read在 FilterInputStream
        结果
        读取字节，如果达到压缩输入结束，则返回-1
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterInputStream.in

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        将未压缩的数据读入字节数组。 如果len不为零，则该方法将阻塞，直到可以解压缩某些输入; 否则，不会读取字节，并返回0 。
        重写：
        read在 FilterInputStream
        参数
        b - 读取数据的缓冲区
        off - 目标数组 b的起始偏移量
        len - 读取的最大字节数
        结果
        读取的实际字节数，如果达到压缩输入的结尾或需要预设字典，则为-1
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负，则 len为负数，或 len大于 b.length - off
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生I / O错误
        另请参见：
        FilterInputStream.in

      • available

        public int available​()
              throws IOException
        到达EOF后返回0，否则总是返回1。

        程序不应该依赖此方法来返回可以读取而不阻止的实际字节数。

        重写：
        available在 FilterInputStream
        结果
        EOF前为1，EOF为0。
        异常
        IOException - 如果发生I / O错误。

      • skip

        public long skip​(long n)
          throws IOException
        跳过未压缩数据的指定字节数。
        重写：
        skip在 FilterInputStream
        参数
        n - 要跳过的字节数
        结果
        实际跳过的字节数。
        异常
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果是 n < 0

      • close

        public void close​()
           throws IOException
        关闭此输入流并释放与流相关联的任何系统资源。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 FilterInputStream
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterInputStream.in

      • fill

        protected void fill​()
             throws IOException
        填写输入缓冲区以获得更多的数据解压缩。
        异常
        IOException - 如果发生I / O错误

      • markSupported

        public boolean markSupported​()
        测试此输入流是否支持mark和reset方法。 该markSupported方法InflaterInputStream回报false 。
        重写：
        markSupported在 FilterInputStream
        结果
        一个 boolean指示这种流类型是否支持 mark和 reset方法。
        另请参见：
        InputStream.mark(int) ， InputStream.reset()

      • mark

        public void mark​(int readlimit)
        标记此输入流中的当前位置。

        该mark的方法InflaterInputStream什么都不做。

        重写：
        mark在 FilterInputStream
        参数
        readlimit - 在标记位置无效之前可以读取的最大字节数限制。
        另请参见：
        InputStream.reset()

      • reset

        public void reset​()
           throws IOException
        将此流重新定位到上次在此输入流上调用mark方法时的位置。

        该方法reset类InflaterInputStream什么也不做只是抛出一个IOException 。

        重写：
        reset在 FilterInputStream
        异常
        IOException - 如果这个方法被调用。
        另请参见：
        InputStream.mark(int), IOException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


InflaterOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class InflaterOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.util.zip.InflaterOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class InflaterOutputStream
extends FilterOutputStream
    实现输出流过滤器，用于解压缩以“放气”压缩格式存储的数据。
    从以下版本开始：
    1.6
    另请参见：
    InflaterInputStream ， DeflaterInputStream ， DeflaterOutputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buf
      用于写入未压缩数据的输出缓冲区。
      protected Inflater inf
      解压缩此流。

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Constructor 描述
      InflaterOutputStream​(OutputStream out)
      使用默认解压缩器和缓冲区大小创建新的输出流。
      InflaterOutputStream​(OutputStream out, Inflater infl)
      使用指定的解压缩器和默认缓冲区大小创建新的输出流。
      InflaterOutputStream​(OutputStream out, Inflater infl, int bufLen)
      使用指定的解压缩器和缓冲区大小创建新的输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      将任何剩余的未压缩数据写入输出流并关闭底层输出流。
      void finish​()
      完成将未压缩数据写入输出流，而不关闭底层流。
      void flush​()
      刷新此输出流，强制任何待处理的缓冲输出字节被写入。
      void write​(byte[] b, int off, int len)
      将一组字节写入未压缩的输出流。
      void write​(int b)
      将一个字节写入未压缩的输出流。

      • Methods inherited from class java.io.FilterOutputStream

        write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • inf

        protected final Inflater inf
        解压缩此流。

      • buf

        protected final byte[] buf
        用于写入未压缩数据的输出缓冲区。

    • 构造方法详细信息

      • InflaterOutputStream

        public InflaterOutputStream​(OutputStream out)
        使用默认解压缩器和缓冲区大小创建新的输出流。
        参数
        out - 将未压缩数据写入的输出流
        异常
        NullPointerException - 如果 out为空

      • InflaterOutputStream

        public InflaterOutputStream​(OutputStream out,
                            Inflater infl)
        使用指定的解压缩器和默认缓冲区大小创建新的输出流。
        参数
        out - 将未压缩数据写入的输出流
        infl - 此流的解压缩程序（“inflater”）
        异常
        NullPointerException - 如果 out或 infl为空

      • InflaterOutputStream

        public InflaterOutputStream​(OutputStream out,
                            Inflater infl,
                            int bufLen)
        使用指定的解压缩器和缓冲区大小创建新的输出流。
        参数
        out - 将未压缩数据写入的输出流
        infl - 此流的解压缩程序（“inflater”）
        bufLen - 解压缩缓冲区大小
        异常
        IllegalArgumentException - 如果是 bufLen <= 0
        NullPointerException - 如果 out或 infl为null

    • 方法详细信息

      • close

        public void close​()
           throws IOException
        将任何剩余的未压缩数据写入输出流并关闭底层输出流。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 FilterOutputStream
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterOutputStream.flush() ， FilterOutputStream.out

      • flush

        public void flush​()
           throws IOException
        刷新此输出流，强制任何待处理的缓冲输出字节被写入。
        Specified by:
        flush在接口 Flushable
        重写：
        flush在 FilterOutputStream
        异常
        IOException - 如果发生I / O错误或该流已经关闭
        另请参见：
        FilterOutputStream.out

      • finish

        public void finish​()
            throws IOException
        完成将未压缩数据写入输出流，而不关闭底层流。 在连续使用多个过滤器到相同的输出流时使用此方法。
        异常
        IOException - 如果发生I / O错误或该流已经关闭

      • write

        public void write​(int b)
           throws IOException
        将一个字节写入未压缩的输出流。
        重写：
        write在 FilterOutputStream
        参数
        b - 压缩数据的单字节解压缩并写入输出流
        异常
        IOException - 如果发生I / O错误或该流已经关闭
        ZipException - 如果发生压缩（ZIP）格式错误

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        将一组字节写入未压缩的输出流。
        重写：
        write在 FilterOutputStream
        参数
        b - 包含压缩数据以缓冲和写入输出流的缓冲区
        off - b内压缩数据的起始偏移量
        len - 从 b解压缩的字节数
        异常
        IndexOutOfBoundsException - 如果是 off < 0 ，或者如果是 len < 0 ，或者如果是 len > b.length - off
        IOException - 如果发生I / O错误或该流已经关闭
        NullPointerException - 如果 b为空
        ZipException - 如果发生压缩（ZIP）格式错误
        另请参见：
        FilterOutputStream.write(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


java.util.zip (Java SE 9 & JDK 9 )

java.util.zip

Interfaces

  • Checksum

Classes

  • Adler32
  • CheckedInputStream
  • CheckedOutputStream
  • CRC32
  • CRC32C
  • Deflater
  • DeflaterInputStream
  • DeflaterOutputStream
  • GZIPInputStream
  • GZIPOutputStream
  • Inflater
  • InflaterInputStream
  • InflaterOutputStream
  • ZipEntry
  • ZipFile
  • ZipInputStream
  • ZipOutputStream

Exceptions

  • DataFormatException
  • ZipException

Errors

  • ZipError


java.util.zip (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.util.zip

提供读写标准ZIP和GZIP文件格式的类。 还包括使用由ZIP和GZIP文件格式使用的DEFLATE压缩算法压缩和解压缩数据的类。 另外，还有用于计算任意输入流的CRC-32，CRC-32C和Adler-32校验和的实用程序类。

包装规格

  • Info-ZIP Application Note 970311 - java.util.zip类基于Info-ZIP格式的详细说明。
  • An implementation may optionally support the ZIP64(tm) format extensions defined by the PKWARE ZIP File Format Specification 。 ZIP64（tm）格式扩展用于克服原始ZIP格式的大小限制。
  • APPENDIX D of PKWARE ZIP File Format Specification - 使用UTF-8对ZIP条目文件名和注释字段进行编码的语言编码标志（EFS）。
  • ZLIB Compressed Data Format Specification version 3.3 (pdf) （RFC 1950）
  • DEFLATE Compressed Data Format Specification version 1.3 (pdf) （RFC 1951）
  • GZIP file format specification version 4.3 (pdf) （RFC 1952）
  • CRC-32校验和在RFC 1952（以上）
  • CRC-32C校验和描述于Internet Small Computer Systems Interface (iSCSI) (pdf) （RFC 3720）
  • Adler-32校验和在RFC 1950（上文）
从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    Checksum
    表示数据校验和的接口。
  • 类摘要
    Class 描述
    Adler32
    可用于计算数据流的Adler-32校验和的类。
    CheckedInputStream
    也保持正在读取的数据的校验和的输入流。
    CheckedOutputStream
    一个输出流，它还维护正在写入的数据的校验和。
    CRC32
    可用于计算数据流的CRC-32的类。
    CRC32C
    可用于计算数据流的CRC-32C的类。
    Deflater
    该类支持通用压缩使用流行的ZLIB压缩库。
    DeflaterInputStream
    实现用于压缩“放气”压缩格式的数据的输入流过滤器。
    DeflaterOutputStream
    该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。
    GZIPInputStream
    该类实现了一个流过滤器，用于读取GZIP文件格式的压缩数据。
    GZIPOutputStream
    该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。
    Inflater
    此类提供对使用流行的ZLIB压缩库的通用解压缩的支持。
    InflaterInputStream
    该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。
    InflaterOutputStream
    实现输出流过滤器，用于解压缩以“放气”压缩格式存储的数据。
    ZipEntry
    此类用于表示ZIP文件条目。
    ZipFile
    此类用于从zip文件读取条目。
    ZipInputStream
    该类实现了以ZIP文件格式读取文件的输入流过滤器。
    ZipOutputStream
    该类实现了以ZIP文件格式写入文件的输出流过滤器。
  • 异常摘要
    异常 描述
    DataFormatException
    发出数据格式错误的信号。
    ZipException
    表示发生了某种类型的Zip异常。
  • Error Summary
    Error 描述
    ZipError
    表示发生了不可恢复的错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


java.util.zip Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.util.zip

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.zip.Adler32 (implements java.util.zip.Checksum)
    • java.util.zip.CRC32 (implements java.util.zip.Checksum)
    • java.util.zip.CRC32C (implements java.util.zip.Checksum)
    • java.util.zip.Deflater
    • java.util.zip.Inflater
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • java.util.zip.CheckedInputStream
        • java.util.zip.DeflaterInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.GZIPInputStream
          • java.util.zip.ZipInputStream
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • java.util.zip.CheckedOutputStream
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.GZIPOutputStream
          • java.util.zip.ZipOutputStream
        • java.util.zip.InflaterOutputStream
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.VirtualMachineError
          • java.lang.InternalError
            • java.util.zip.ZipError
      • java.lang.异常
        • java.util.zip.DataFormatException
        • java.io.IOException
          • java.util.zip.ZipException
    • java.util.zip.ZipEntry (implements java.lang.Cloneable)
    • java.util.zip.ZipFile (implements java.io.Closeable)

Interface Hierarchy

  • java.util.zip.Checksum
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package java.util.zip (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.util.zip

  • Packages that use java.util.zip
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    jdk.security.jarsigner
  • Classes in java.util.zip used by com.sun.jarsigner
    Class 描述
    ZipFile
    此类用于从zip文件读取条目。
  • Classes in java.util.zip used by java.util.jar
    Class 描述
    DeflaterOutputStream
    该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。
    InflaterInputStream
    该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。
    ZipEntry
    此类用于表示ZIP文件条目。
    ZipException
    表示发生了某种类型的Zip异常。
    ZipFile
    此类用于从zip文件读取条目。
    ZipInputStream
    该类实现了以ZIP文件格式读取文件的输入流过滤器。
    ZipOutputStream
    该类实现了以ZIP文件格式写入文件的输出流过滤器。
  • Classes in java.util.zip used by java.util.zip
    Class 描述
    Checksum
    表示数据校验和的接口。
    CRC32
    可用于计算数据流的CRC-32的类。
    DataFormatException
    发出数据格式错误的信号。
    Deflater
    该类支持通用压缩使用流行的ZLIB压缩库。
    DeflaterOutputStream
    该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。
    Inflater
    此类提供对使用流行的ZLIB压缩库的通用解压缩的支持。
    InflaterInputStream
    该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。
    ZipEntry
    此类用于表示ZIP文件条目。
    ZipException
    表示发生了某种类型的Zip异常。
  • Classes in java.util.zip used by jdk.security.jarsigner
    Class 描述
    ZipFile
    此类用于从zip文件读取条目。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ZipEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class ZipEntry

  • java.lang.Object
    • java.util.zip.ZipEntry
  • All Implemented Interfaces:
    Cloneable
    已知直接子类：
    JarEntry

    public class ZipEntry
extends Object
implements Cloneable
    此类用于表示ZIP文件条目。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static int | CENATT
      static int | CENATX
      static int | CENCOM
      static int | CENCRC
      static int | CENDSK
      static int | CENEXT
      static int | CENFLG
      static int | CENHDR
      static int | CENHOW
      static int | CENLEN
      static int | CENNAM
      static int | CENOFF
      static long | CENSIG
      static int | CENSIZ
      static int | CENTIM
      static int | CENVEM
      static int | CENVER
      static int DEFLATED
      压缩（缩小）条目的压缩方法。
      static int | ENDCOM
      static int | ENDHDR
      static int | ENDOFF
      static long | ENDSIG
      static int | ENDSIZ
      static int | ENDSUB
      static int | ENDTOT
      static int | EXTCRC
      static int | EXTHDR
      static int | EXTLEN
      static long | EXTSIG
      static int | EXTSIZ
      static int | LOCCRC
      static int | LOCEXT
      static int | LOCFLG
      static int | LOCHDR
      static int | LOCHOW
      static int | LOCLEN
      static int | LOCNAM
      static long | LOCSIG
      static int | LOCSIZ
      static int | LOCTIM
      static int | LOCVER
      static int STORED
      未压缩条目的压缩方法。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ZipEntry​(String name)
      创建具有指定名称的新的zip条目。
      ZipEntry​(ZipEntry e)
      创建一个新的zip条目，其中的字段从指定的zip条目中取出。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      返回此条目的副本。
      String getComment​()
      返回条目的注释字符串。
      long getCompressedSize​()
      返回压缩条目数据的大小。
      long getCrc​()
      返回未压缩条目数据的CRC-32校验和。
      FileTime getCreationTime​()
      返回条目的创建时间。
      byte[] getExtra​()
      返回条目的额外字段数据。
      FileTime getLastAccessTime​()
      返回条目的最后访问时间。
      FileTime getLastModifiedTime​()
      返回条目的最后修改时间。
      int getMethod​()
      返回条目的压缩方法。
      String getName​()
      返回条目的名称。
      long getSize​()
      返回条目数据的未压缩大小。
      long getTime​()
      返回条目的最后修改时间。
      LocalDateTime getTimeLocal​()
      返回本地日期时间的条目的最后修改时间。
      int hashCode​()
      返回此条目的哈希码值。
      boolean isDirectory​()
      如果这是目录条目，则返回true。
      void setComment​(String comment)
      设置条目的可选注释字符串。
      void setCompressedSize​(long csize)
      设置压缩条目数据的大小。
      void setCrc​(long crc)
      设置未压缩条目数据的CRC-32校验和。
      ZipEntry setCreationTime​(FileTime time)
      设置条目的创建时间。
      void setExtra​(byte[] extra)
      为条目设置可选的额外字段数据。
      ZipEntry setLastAccessTime​(FileTime time)
      设置条目的最后访问时间。
      ZipEntry setLastModifiedTime​(FileTime time)
      设置条目的最后修改时间。
      void setMethod​(int method)
      设置条目的压缩方法。
      void setSize​(long size)
      设置条目数据的未压缩大小。
      void setTime​(long time)
      设置条目的最后修改时间。
      void setTimeLocal​(LocalDateTime time)
      设置本地日期时间的条目的最后修改时间。
      String toString​()
      返回ZIP条目的字符串表示形式。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • STORED

        public static final int STORED
        未压缩条目的压缩方法。
        另请参见：
        Constant Field Values

      • DEFLATED

        public static final int DEFLATED
        压缩（缩小）条目的压缩方法。
        另请参见：
        Constant Field Values

      • LOCSIG

        public static final long LOCSIG
        另请参见：
        Constant Field Values

      • EXTSIG

        public static final long EXTSIG
        另请参见：
        Constant Field Values

      • CENSIG

        public static final long CENSIG
        另请参见：
        Constant Field Values

      • ENDSIG

        public static final long ENDSIG
        另请参见：
        Constant Field Values

      • LOCHDR

        public static final int LOCHDR
        另请参见：
        Constant Field Values

      • EXTHDR

        public static final int EXTHDR
        另请参见：
        Constant Field Values

      • CENHDR

        public static final int CENHDR
        另请参见：
        Constant Field Values

      • ENDHDR

        public static final int ENDHDR
        另请参见：
        Constant Field Values

      • LOCVER

        public static final int LOCVER
        另请参见：
        Constant Field Values

      • LOCFLG

        public static final int LOCFLG
        另请参见：
        Constant Field Values

      • LOCHOW

        public static final int LOCHOW
        另请参见：
        Constant Field Values

      • LOCTIM

        public static final int LOCTIM
        另请参见：
        Constant Field Values

      • LOCCRC

        public static final int LOCCRC
        另请参见：
        Constant Field Values

      • LOCSIZ

        public static final int LOCSIZ
        另请参见：
        Constant Field Values

      • LOCLEN

        public static final int LOCLEN
        另请参见：
        Constant Field Values

      • LOCNAM

        public static final int LOCNAM
        另请参见：
        Constant Field Values

      • LOCEXT

        public static final int LOCEXT
        另请参见：
        Constant Field Values

      • EXTCRC

        public static final int EXTCRC
        另请参见：
        Constant Field Values

      • EXTSIZ

        public static final int EXTSIZ
        另请参见：
        Constant Field Values

      • EXTLEN

        public static final int EXTLEN
        另请参见：
        Constant Field Values

      • CENVEM

        public static final int CENVEM
        另请参见：
        Constant Field Values

      • CENVER

        public static final int CENVER
        另请参见：
        Constant Field Values

      • CENFLG

        public static final int CENFLG
        另请参见：
        Constant Field Values

      • CENHOW

        public static final int CENHOW
        另请参见：
        Constant Field Values

      • CENTIM

        public static final int CENTIM
        另请参见：
        Constant Field Values

      • CENCRC

        public static final int CENCRC
        另请参见：
        Constant Field Values

      • CENSIZ

        public static final int CENSIZ
        另请参见：
        Constant Field Values

      • CENLEN

        public static final int CENLEN
        另请参见：
        Constant Field Values

      • CENNAM

        public static final int CENNAM
        另请参见：
        Constant Field Values

      • CENEXT

        public static final int CENEXT
        另请参见：
        Constant Field Values

      • CENCOM

        public static final int CENCOM
        另请参见：
        Constant Field Values

      • CENDSK

        public static final int CENDSK
        另请参见：
        Constant Field Values

      • CENATT

        public static final int CENATT
        另请参见：
        Constant Field Values

      • CENATX

        public static final int CENATX
        另请参见：
        Constant Field Values

      • CENOFF

        public static final int CENOFF
        另请参见：
        Constant Field Values

      • ENDSUB

        public static final int ENDSUB
        另请参见：
        Constant Field Values

      • ENDTOT

        public static final int ENDTOT
        另请参见：
        Constant Field Values

      • ENDSIZ

        public static final int ENDSIZ
        另请参见：
        Constant Field Values

      • ENDOFF

        public static final int ENDOFF
        另请参见：
        Constant Field Values

      • ENDCOM

        public static final int ENDCOM
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ZipEntry

        public ZipEntry​(String name)
        创建具有指定名称的新的zip条目。
        参数
        name - 条目名称
        异常
        NullPointerException - 如果条目名称为空
        IllegalArgumentException - 如果条目名称长于0xFFFF字节

      • ZipEntry

        public ZipEntry​(ZipEntry e)
        创建一个新的zip条目，其中的字段从指定的zip条目中取出。
        参数
        e - 一个zip条目对象
        异常
        NullPointerException - 如果条目对象为空

    • 方法详细信息

      • getName

        public String getName​()
        返回条目的名称。
        结果
        条目的名称

      • setTime

        public void setTime​(long time)
        设置条目的最后修改时间。

        如果条目输出到ZIP文件或ZIP文件格式化的输出流，则此方法设置的最后修改时间将被存储到zip文件条目的date and time fields中，并以标准MS-DOS date and time format编码。 default TimeZone用于将时代时间转换为MS-DOS数据和时间。

        参数
        time - 自纪元以来，输入的最后修改时间（以毫秒为单位）
        另请参见：
        getTime() ， getLastModifiedTime()

      • getTime

        public long getTime​()
        返回条目的最后修改时间。

        如果从ZIP文件或ZIP文件格式化的输入流中读取该条目，则这是从zip文件条目的date and time fields的最后修改时间。 default TimeZone用于将标准MS-DOS格式的日期和时间转换为时代。

        结果
        最后修改时间（以毫秒为单位），或-1（如果未指定）
        另请参见：
        setTime(long) ， setLastModifiedTime(FileTime)

      • setTimeLocal

        public void setTimeLocal​(LocalDateTime time)
        设置本地日期时间的条目的最后修改时间。

        如果条目输出到ZIP文件或ZIP文件格式化的输出流，则此方法设置的最后修改时间将存储在zip文件条目的date and time fields中，并以标准MS-DOS date and time format编码。 如果日期时间设置超出标准MS-DOS date and time format的范围，则时间也将存储在UTC时间的optional extra data zip文件条目的扩展时间戳记字段中。 system default TimeZone用于将本地日期时间转换为UTC时间。

        LocalDateTime使用毫微秒的精度，而这个类使用毫秒的精度。 转换将截断任何超量精度信息，就好像以毫秒为单位的整数除以一百万。

        参数
        time - 本地日期时间的最后修改时间
        从以下版本开始：
        9
        另请参见：
        getTimeLocal()

      • getTimeLocal

        public LocalDateTime getTimeLocal​()
        返回本地日期时间的条目的最后修改时间。

        如果条目是从ZIP文件或ZIP文件格式的输入流中optional extra data则如果扩展时间戳字段存在，则是zip文件条目的optional extra data的最后修改时间。 否则，最后修改时间从条目的标准MS-DOS格式化的date and time fields 。

        system default TimeZone用于将UTC时间转换为本地日期时间。

        结果
        在本地日期时间输入的最后修改时间
        从以下版本开始：
        9
        另请参见：
        setTimeLocal(LocalDateTime)

      • setLastModifiedTime

        public ZipEntry setLastModifiedTime​(FileTime time)
        设置条目的最后修改时间。

        当输出到ZIP文件或ZIP文件格式化的输出流时，此方法设置的最后修改时间将被存储到date and time fields中的zip文件条目的standard MS-DOS date and time format ）以及UTC时间的optional extra data中的扩展时间戳记字段。

        参数
        time - 条目的最后修改时间
        结果
        这个zip条目
        异常
        NullPointerException - 如果 time为空
        从以下版本开始：
        1.8
        另请参见：
        getLastModifiedTime()

      • getLastModifiedTime

        public FileTime getLastModifiedTime​()
        返回条目的最后修改时间。

        如果从ZIP文件或ZIP文件格式化的输入流中读取条目，则如果扩展时间戳字段存在，则是zip文件条目optional extra data的最后修改时间。 否则，最后修改时间是从条目date and time fields读取的， default TimeZone用于将标准MS-DOS格式的日期和时间转换为时代。

        结果
        条目的最后修改时间，如果未指定，则为null
        从以下版本开始：
        1.8
        另请参见：
        setLastModifiedTime(FileTime)

      • setLastAccessTime

        public ZipEntry setLastAccessTime​(FileTime time)
        设置条目的最后访问时间。

        如果设置，最后访问时间将被存储到条目optional extra data的扩展时间戳字段中，当输出到ZIP文件或ZIP文件格式化的流时。

        参数
        time - 条目的最后访问时间
        结果
        这个zip条目
        异常
        NullPointerException - 如果 time为空
        从以下版本开始：
        1.8
        另请参见：
        getLastAccessTime()

      • getLastAccessTime

        public FileTime getLastAccessTime​()
        返回条目的最后访问时间。

        最后一次访问时间来自条目optional extra data的扩展时间戳记字段，从ZIP文件或ZIP文件格式化的流中读取。

        结果
        条目的最后访问时间，如果未指定则为null
        从以下版本开始：
        1.8
        另请参见：
        setLastAccessTime(FileTime)

      • setCreationTime

        public ZipEntry setCreationTime​(FileTime time)
        设置条目的创建时间。

        如果设置，创建时间将被存储到条目optional extra data的扩展时间戳字段中，当输出到ZIP文件或ZIP文件格式化的流时。

        参数
        time - 条目的创建时间
        结果
        这个zip条目
        异常
        NullPointerException - 如果 time为空
        从以下版本开始：
        1.8
        另请参见：
        getCreationTime()

      • getCreationTime

        public FileTime getCreationTime​()
        返回条目的创建时间。

        创建时间来自条目optional extra data的扩展时间戳字段，从ZIP文件或ZIP文件格式化的流中读取。

        结果
        条目的创建时间，如果未指定则为null
        从以下版本开始：
        1.8
        另请参见：
        setCreationTime(FileTime)

      • setSize

        public void setSize​(long size)
        设置条目数据的未压缩大小。
        参数
        size - 未压缩大小（以字节为单位）
        异常
        IllegalArgumentException - 如果指定的大小小于0，则当不支持 ZIP64 format时大于0xFFFFFFFF，或者在支持 ZIP64时小于0
        另请参见：
        getSize()

      • getSize

        public long getSize​()
        返回条目数据的未压缩大小。
        结果
        条目数据的未压缩大小，如果不知道则为-1
        另请参见：
        setSize(long)

      • getCompressedSize

        public long getCompressedSize​()
        返回压缩条目数据的大小。

        在存储条目的情况下，压缩大小将与条目的未压缩大小相同。

        结果
        压缩条目数据的大小，如果不知道则为-1
        另请参见：
        setCompressedSize(long)

      • setCompressedSize

        public void setCompressedSize​(long csize)
        设置压缩条目数据的大小。
        参数
        csize - 要设置的压缩大小
        另请参见：
        getCompressedSize()

      • setCrc

        public void setCrc​(long crc)
        设置未压缩条目数据的CRC-32校验和。
        参数
        crc - CRC-32值
        异常
        IllegalArgumentException - 如果指定的CRC-32值小于0或大于0xFFFFFFFF
        另请参见：
        getCrc()

      • getCrc

        public long getCrc​()
        返回未压缩条目数据的CRC-32校验和。
        结果
        未压缩条目数据的CRC-32校验和，如果不知道则为-1
        另请参见：
        setCrc(long)

      • setMethod

        public void setMethod​(int method)
        设置条目的压缩方法。
        参数
        method - 压缩方法，可以是STORED还是DEFLATED
        异常
        IllegalArgumentException - 如果指定的压缩方法无效
        另请参见：
        getMethod()

      • getMethod

        public int getMethod​()
        返回条目的压缩方法。
        结果
        条目的压缩方法，如果未指定，则为-1
        另请参见：
        setMethod(int)

      • setExtra

        public void setExtra​(byte[] extra)
        为条目设置可选的额外字段数据。

        调用此方法可能会改变这种条目的最后修改时间，最后访问时间和创建时间，如果extra场数据包括可延展的时间戳字段，例如NTFS tag 0x0001或Info-ZIP Extended Timestamp ，如在指定Info-ZIP Application Note 970311 。

        参数
        extra - 额外的字段数据字节
        异常
        IllegalArgumentException - 如果指定的额外字段数据的长度大于0xFFFF个字节
        另请参见：
        getExtra()

      • getExtra

        public byte[] getExtra​()
        返回条目的额外字段数据。
        结果
        条目的额外字段数据，如果没有则为null
        另请参见：
        setExtra(byte[])

      • setComment

        public void setComment​(String comment)
        设置条目的可选注释字符串。

        ZIP条目注释的最大长度为0xffff。 如果指定的注释字符串的长度在编码后大于0xFFFF个字节，则只有第一个0xFFFF字节输出到ZIP文件条目。

        参数
        comment - 注释字符串
        另请参见：
        getComment()

      • getComment

        public String getComment​()
        返回条目的注释字符串。
        结果
        条目的注释字符串，如果没有则为null
        另请参见：
        setComment(String)

      • isDirectory

        public boolean isDirectory​()
        如果这是目录条目，则返回true。 目录条目被定义为一个名称以'/'结尾的条目。
        结果
        如果这是目录条目，则为true

      • toString

        public String toString​()
        返回ZIP条目的字符串表示形式。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • hashCode

        public int hashCode​()
        返回此条目的哈希码值。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • clone

        public Object clone​()
        返回此条目的副本。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ZipError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class ZipError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.VirtualMachineError
          • java.lang.InternalError
            • java.util.zip.ZipError
  • All Implemented Interfaces:
    Serializable

    public class ZipError
extends InternalError
    表示发生了不可恢复的错误。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ZipError​(String s)
      使用给定的详细消息构造ZipError。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ZipError

        public ZipError​(String s)
        使用给定的详细消息构造ZipError。
        参数
        s - the String containing a detail message
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ZipException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class ZipException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.util.zip.ZipException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    JarException

    public class ZipException
extends IOException
    表示发生了某种类型的Zip异常。
    从以下版本开始：
    1.1
    另请参见：
    IOException ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ZipException​()
      构造一个 ZipException与 null作为错误详细信息。
      ZipException​(String s)
      构造具有指定详细消息的 ZipException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ZipException

        public ZipException​()
        构造一个 ZipException与 null作为其错误详细消息。

      • ZipException

        public ZipException​(String s)
        构造具有指定详细消息的 ZipException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ZipFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class ZipFile

  • java.lang.Object
    • java.util.zip.ZipFile
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    JarFile

    public class ZipFile
extends Object
implements Closeable
    此类用于从zip文件读取条目。

    除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static int | CENATT
      static int | CENATX
      static int | CENCOM
      static int | CENCRC
      static int | CENDSK
      static int | CENEXT
      static int | CENFLG
      static int | CENHDR
      static int | CENHOW
      static int | CENLEN
      static int | CENNAM
      static int | CENOFF
      static long | CENSIG
      static int | CENSIZ
      static int | CENTIM
      static int | CENVEM
      static int | CENVER
      static int | ENDCOM
      static int | ENDHDR
      static int | ENDOFF
      static long | ENDSIG
      static int | ENDSIZ
      static int | ENDSUB
      static int | ENDTOT
      static int | EXTCRC
      static int | EXTHDR
      static int | EXTLEN
      static long | EXTSIG
      static int | EXTSIZ
      static int | LOCCRC
      static int | LOCEXT
      static int | LOCFLG
      static int | LOCHDR
      static int | LOCHOW
      static int | LOCLEN
      static int | LOCNAM
      static long | LOCSIG
      static int | LOCSIZ
      static int | LOCTIM
      static int | LOCVER
      static int OPEN_DELETE
      模式标志打开一个zip文件并标记为删除。
      static int OPEN_READ
      模式标志打开一个zip文件进行阅读。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ZipFile​(File file)
      打开一个ZIP文件，读取指定的File对象。
      ZipFile​(File file, int mode)
      打开一个新的 ZipFile以指定的方式读取指定的 File对象。
      ZipFile​(File file, int mode, Charset charset)
      打开一个新的 ZipFile以指定的方式读取指定的 File对象。
      ZipFile​(File file, Charset charset)
      打开一个ZIP文件，读取指定的File对象。
      ZipFile​(String name)
      打开一个zip文件进行阅读。
      ZipFile​(String name, Charset charset)
      打开一个zip文件进行阅读。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void close​()
      关闭ZIP文件。
      Enumeration<? extends ZipEntry> entries​()
      返回ZIP文件条目的枚举。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      String getComment​()
      返回zip文件注释，否则返回null。
      ZipEntry getEntry​(String name)
      返回指定名称的zip文件条目，如果找不到则返回null。
      InputStream getInputStream​(ZipEntry entry)
      返回用于读取指定zip文件条目内容的输入流。
      String getName​()
      返回ZIP文件的路径名。
      int size​()
      返回ZIP文件中的条目数。
      Stream<? extends ZipEntry> stream​()
      在ZIP文件条目上返回有序的 Stream 。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OPEN_READ

        public static final int OPEN_READ
        模式标志打开一个zip文件进行阅读。
        另请参见：
        Constant Field Values

      • OPEN_DELETE

        public static final int OPEN_DELETE
        模式标志打开一个zip文件并标记为删除。 该文件将在打开时刻和关闭时间之间被删除，但其内容将仍然可以通过ZipFile对象访问，直到关闭方法被调用或虚拟机退出。
        另请参见：
        Constant Field Values

      • LOCSIG

        public static final long LOCSIG
        另请参见：
        Constant Field Values

      • EXTSIG

        public static final long EXTSIG
        另请参见：
        Constant Field Values

      • CENSIG

        public static final long CENSIG
        另请参见：
        Constant Field Values

      • ENDSIG

        public static final long ENDSIG
        另请参见：
        Constant Field Values

      • LOCHDR

        public static final int LOCHDR
        另请参见：
        Constant Field Values

      • EXTHDR

        public static final int EXTHDR
        另请参见：
        Constant Field Values

      • CENHDR

        public static final int CENHDR
        另请参见：
        Constant Field Values

      • ENDHDR

        public static final int ENDHDR
        另请参见：
        Constant Field Values

      • LOCVER

        public static final int LOCVER
        另请参见：
        Constant Field Values

      • LOCFLG

        public static final int LOCFLG
        另请参见：
        Constant Field Values

      • LOCHOW

        public static final int LOCHOW
        另请参见：
        Constant Field Values

      • LOCTIM

        public static final int LOCTIM
        另请参见：
        Constant Field Values

      • LOCCRC

        public static final int LOCCRC
        另请参见：
        Constant Field Values

      • LOCSIZ

        public static final int LOCSIZ
        另请参见：
        Constant Field Values

      • LOCLEN

        public static final int LOCLEN
        另请参见：
        Constant Field Values

      • LOCNAM

        public static final int LOCNAM
        另请参见：
        Constant Field Values

      • LOCEXT

        public static final int LOCEXT
        另请参见：
        Constant Field Values

      • EXTCRC

        public static final int EXTCRC
        另请参见：
        Constant Field Values

      • EXTSIZ

        public static final int EXTSIZ
        另请参见：
        Constant Field Values

      • EXTLEN

        public static final int EXTLEN
        另请参见：
        Constant Field Values

      • CENVEM

        public static final int CENVEM
        另请参见：
        Constant Field Values

      • CENVER

        public static final int CENVER
        另请参见：
        Constant Field Values

      • CENFLG

        public static final int CENFLG
        另请参见：
        Constant Field Values

      • CENHOW

        public static final int CENHOW
        另请参见：
        Constant Field Values

      • CENTIM

        public static final int CENTIM
        另请参见：
        Constant Field Values

      • CENCRC

        public static final int CENCRC
        另请参见：
        Constant Field Values

      • CENSIZ

        public static final int CENSIZ
        另请参见：
        Constant Field Values

      • CENLEN

        public static final int CENLEN
        另请参见：
        Constant Field Values

      • CENNAM

        public static final int CENNAM
        另请参见：
        Constant Field Values

      • CENEXT

        public static final int CENEXT
        另请参见：
        Constant Field Values

      • CENCOM

        public static final int CENCOM
        另请参见：
        Constant Field Values

      • CENDSK

        public static final int CENDSK
        另请参见：
        Constant Field Values

      • CENATT

        public static final int CENATT
        另请参见：
        Constant Field Values

      • CENATX

        public static final int CENATX
        另请参见：
        Constant Field Values

      • CENOFF

        public static final int CENOFF
        另请参见：
        Constant Field Values

      • ENDSUB

        public static final int ENDSUB
        另请参见：
        Constant Field Values

      • ENDTOT

        public static final int ENDTOT
        另请参见：
        Constant Field Values

      • ENDSIZ

        public static final int ENDSIZ
        另请参见：
        Constant Field Values

      • ENDOFF

        public static final int ENDOFF
        另请参见：
        Constant Field Values

      • ENDCOM

        public static final int ENDCOM
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ZipFile

        public ZipFile​(String name)
        throws IOException
        打开一个zip文件进行阅读。

        首先，如果有一个安全管理器，它的checkRead方法是以name参数作为参数来调用，以确保读取被允许。

        UTF-8 charset用于解码条目名称和注释。

        参数
        name - zip文件的名称
        异常
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生I / O错误
        SecurityException - 如果存在安全管理员，并且其 checkRead方法不允许对该文件的读取访问。
        另请参见：
        SecurityManager.checkRead(java.lang.String)

      • ZipFile

        public ZipFile​(File file,
               int mode)
        throws IOException
        打开一个新的ZipFile以指定的方式读取指定的File对象。 mode参数必须是OPEN_READ或OPEN_READ | OPEN_DELETE 。

        首先，如果有一个安全管理器，它的checkRead方法被调用，以name参数作为参数，以确保读取被允许。

        UTF-8 charset用于解码条目名称和注释

        参数
        file - 要打开阅读的ZIP文件
        mode - 要打开文件的模式
        异常
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生I / O错误
        SecurityException - 如果存在安全管理员，并且其 checkRead方法不允许对该文件进行读取访问，或者 checkDelete方法不允许在设置 OPEN_DELETE标志时删除该文件。
        IllegalArgumentException - 如果 mode参数无效
        从以下版本开始：
        1.3
        另请参见：
        SecurityManager.checkRead(java.lang.String)

      • ZipFile

        public ZipFile​(File file)
        throws ZipException,
               IOException
        打开一个ZIP文件，读取指定的File对象。

        UTF-8 charset用于对条目名称和注释进行解码。

        参数
        file - 要打开阅读的ZIP文件
        异常
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生I / O错误

      • ZipFile

        public ZipFile​(File file,
               int mode,
               Charset charset)
        throws IOException
        打开一个新的ZipFile以指定的方式读取指定的File对象。 mode参数必须是OPEN_READ或OPEN_READ | OPEN_DELETE 。

        首先，如果有一个安全管理器，它的checkRead方法被调用，其中name参数作为参数，以确保读取被允许。

        参数
        file - 要打开阅读的ZIP文件
        mode - 要打开文件的模式
        charset - 用于解码不使用UTF-8编码（由条目的通用标志指示）编码的ZIP条目名称和注释的charset 。
        异常
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生I / O错误
        SecurityException - 如果存在安全管理员，并且其 checkRead方法不允许对该文件进行读取访问，或者其 checkDelete方法不允许在设置 OPEN_DELETE标志时删除该文件
        IllegalArgumentException - 如果 mode参数无效
        从以下版本开始：
        1.7
        另请参见：
        SecurityManager.checkRead(java.lang.String)

      • ZipFile

        public ZipFile​(String name,
               Charset charset)
        throws IOException
        打开一个zip文件进行阅读。

        首先，如果有一个安全管理器，它的checkRead方法是以name参数作为参数来调用，以确保读取被允许。

        参数
        name - zip文件的名称
        charset - 用于解码不使用UTF-8编码（由条目的通用标志指示）编码的ZIP条目名称和注释的charset 。
        异常
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生了I / O错误
        SecurityException - 如果存在安全管理员，并且其 checkRead方法不允许对文件进行读取访问
        从以下版本开始：
        1.7
        另请参见：
        SecurityManager.checkRead(java.lang.String)

      • ZipFile

        public ZipFile​(File file,
               Charset charset)
        throws IOException
        打开一个ZIP文件，读取指定的File对象。
        参数
        file - 要打开阅读的ZIP文件
        charset -该charset被用来ZIP条目名称和注释（忽略，如果解码language encoding bit ZIP条目的通用位标志的设置）。
        异常
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.7

    • 方法详细信息

      • getComment

        public String getComment​()
        返回zip文件注释，否则返回null。
        结果
        zip文件的注释字符串，否则为null
        异常
        IllegalStateException - 如果zip文件已关闭
        从以下版本开始：
        1.7

      • getEntry

        public ZipEntry getEntry​(String name)
        返回指定名称的zip文件条目，如果找不到则返回null。
        参数
        name - 条目的名称
        结果
        zip文件条目，如果没有找到，则为null
        异常
        IllegalStateException - 如果zip文件已关闭

      • getInputStream

        public InputStream getInputStream​(ZipEntry entry)
                           throws IOException
        返回用于读取指定zip文件条目内容的输入流。

        关闭此ZIP文件将反过来关闭通过此方法的调用返回的所有输入流。

        参数
        entry - zip文件条目
        结果
        用于读取指定zip文件条目内容的输入流。
        异常
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生I / O错误
        IllegalStateException - 如果zip文件已关闭

      • getName

        public String getName​()
        返回ZIP文件的路径名。
        结果
        ZIP文件的路径名称

      • entries

        public Enumeration<? extends ZipEntry> entries​()
        返回ZIP文件条目的枚举。
        结果
        枚举ZIP文件条目
        异常
        IllegalStateException - 如果zip文件已关闭

      • stream

        public Stream<? extends ZipEntry> stream​()
        在ZIP文件条目上返回有序的Stream 。 条目按照它们出现在ZIP文件的中央目录中的顺序出现在Stream中。
        结果
        该ZIP文件中的条目已订购 Stream
        异常
        IllegalStateException - 如果zip文件已关闭
        从以下版本开始：
        1.8

      • size

        public int size​()
        返回ZIP文件中的条目数。
        结果
        ZIP文件中的条目数
        异常
        IllegalStateException - 如果zip文件已关闭

      • close

        public void close​()
           throws IOException
        关闭ZIP文件。

        关闭此ZIP文件将关闭getInputStream方法调用之前返回的所有输入流。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生了I / O错误

      • finalize

        @Deprecated(since="9")
protected void finalize​()
                 throws IOException
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        确保在不再有引用该ZipFile对象时，系统资源被释放。

        由于GC调用此方法的时间尚未确定，因此强烈建议应用程序在完成ZipFile访问后立即调用close方法。 这将阻止系统资源保持不确定的时间长短。

        重写：
        finalize在 Object
        异常
        IOException - 如果发生I / O错误
        另请参见：
        close()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ZipInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class ZipInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.ZipInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    JarInputStream

    public class ZipInputStream
extends InflaterInputStream
    该类实现了以ZIP文件格式读取文件的输入流过滤器。 包括对压缩和未压缩条目的支持。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static int | CENATT
      static int | CENATX
      static int | CENCOM
      static int | CENCRC
      static int | CENDSK
      static int | CENEXT
      static int | CENFLG
      static int | CENHDR
      static int | CENHOW
      static int | CENLEN
      static int | CENNAM
      static int | CENOFF
      static long | CENSIG
      static int | CENSIZ
      static int | CENTIM
      static int | CENVEM
      static int | CENVER
      static int | ENDCOM
      static int | ENDHDR
      static int | ENDOFF
      static long | ENDSIG
      static int | ENDSIZ
      static int | ENDSUB
      static int | ENDTOT
      static int | EXTCRC
      static int | EXTHDR
      static int | EXTLEN
      static long | EXTSIG
      static int | EXTSIZ
      static int | LOCCRC
      static int | LOCEXT
      static int | LOCFLG
      static int | LOCHDR
      static int | LOCHOW
      static int | LOCLEN
      static int | LOCNAM
      static long | LOCSIG
      static int | LOCSIZ
      static int | LOCTIM
      static int | LOCVER

      • Fields inherited from class java.io.FilterInputStream

        in

      • Fields inherited from class java.util.zip.InflaterInputStream

        buf, inf, len

    • 构造方法摘要

      构造方法
      Constructor 描述
      ZipInputStream​(InputStream in)
      创建一个新的ZIP输入流。
      ZipInputStream​(InputStream in, Charset charset)
      创建一个新的ZIP输入流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      EOF到达当前条目数据后返回0，否则返回1。
      void close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void closeEntry​()
      关闭当前的ZIP条目，并定位流以读取下一个条目。
      protected ZipEntry createZipEntry​(String name)
      为指定的条目名称创建一个新的 ZipEntry对象。
      ZipEntry getNextEntry​()
      读取下一个ZIP文件条目，并将流定位在条目数据的开头。
      int read​(byte[] b, int off, int len)
      从当前ZIP条目读取到字节数组。
      long skip​(long n)
      跳过当前ZIP条目中指定的字节数。

      • Methods inherited from class java.io.FilterInputStream

        read

      • Methods inherited from class java.util.zip.InflaterInputStream

        fill, mark, markSupported, read, reset

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • LOCSIG

        public static final long LOCSIG
        另请参见：
        Constant Field Values

      • EXTSIG

        public static final long EXTSIG
        另请参见：
        Constant Field Values

      • CENSIG

        public static final long CENSIG
        另请参见：
        Constant Field Values

      • ENDSIG

        public static final long ENDSIG
        另请参见：
        Constant Field Values

      • LOCHDR

        public static final int LOCHDR
        另请参见：
        Constant Field Values

      • EXTHDR

        public static final int EXTHDR
        另请参见：
        Constant Field Values

      • CENHDR

        public static final int CENHDR
        另请参见：
        Constant Field Values

      • ENDHDR

        public static final int ENDHDR
        另请参见：
        Constant Field Values

      • LOCVER

        public static final int LOCVER
        另请参见：
        Constant Field Values

      • LOCFLG

        public static final int LOCFLG
        另请参见：
        Constant Field Values

      • LOCHOW

        public static final int LOCHOW
        另请参见：
        Constant Field Values

      • LOCTIM

        public static final int LOCTIM
        另请参见：
        Constant Field Values

      • LOCCRC

        public static final int LOCCRC
        另请参见：
        Constant Field Values

      • LOCSIZ

        public static final int LOCSIZ
        另请参见：
        Constant Field Values

      • LOCLEN

        public static final int LOCLEN
        另请参见：
        Constant Field Values

      • LOCNAM

        public static final int LOCNAM
        另请参见：
        Constant Field Values

      • LOCEXT

        public static final int LOCEXT
        另请参见：
        Constant Field Values

      • EXTCRC

        public static final int EXTCRC
        另请参见：
        Constant Field Values

      • EXTSIZ

        public static final int EXTSIZ
        另请参见：
        Constant Field Values

      • EXTLEN

        public static final int EXTLEN
        另请参见：
        Constant Field Values

      • CENVEM

        public static final int CENVEM
        另请参见：
        Constant Field Values

      • CENVER

        public static final int CENVER
        另请参见：
        Constant Field Values

      • CENFLG

        public static final int CENFLG
        另请参见：
        Constant Field Values

      • CENHOW

        public static final int CENHOW
        另请参见：
        Constant Field Values

      • CENTIM

        public static final int CENTIM
        另请参见：
        Constant Field Values

      • CENCRC

        public static final int CENCRC
        另请参见：
        Constant Field Values

      • CENSIZ

        public static final int CENSIZ
        另请参见：
        Constant Field Values

      • CENLEN

        public static final int CENLEN
        另请参见：
        Constant Field Values

      • CENNAM

        public static final int CENNAM
        另请参见：
        Constant Field Values

      • CENEXT

        public static final int CENEXT
        另请参见：
        Constant Field Values

      • CENCOM

        public static final int CENCOM
        另请参见：
        Constant Field Values

      • CENDSK

        public static final int CENDSK
        另请参见：
        Constant Field Values

      • CENATT

        public static final int CENATT
        另请参见：
        Constant Field Values

      • CENATX

        public static final int CENATX
        另请参见：
        Constant Field Values

      • CENOFF

        public static final int CENOFF
        另请参见：
        Constant Field Values

      • ENDSUB

        public static final int ENDSUB
        另请参见：
        Constant Field Values

      • ENDTOT

        public static final int ENDTOT
        另请参见：
        Constant Field Values

      • ENDSIZ

        public static final int ENDSIZ
        另请参见：
        Constant Field Values

      • ENDOFF

        public static final int ENDOFF
        另请参见：
        Constant Field Values

      • ENDCOM

        public static final int ENDCOM
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ZipInputStream

        public ZipInputStream​(InputStream in)
        创建一个新的ZIP输入流。

        UTF-8 charset用于解码条目名称。

        参数
        in - 实际的输入流

      • ZipInputStream

        public ZipInputStream​(InputStream in,
                      Charset charset)
        创建一个新的ZIP输入流。
        参数
        in - 实际的输入流
        charset -该charset被用来ZIP条目名称（如果忽略解码language encoding bit ZIP条目的通用位标志的设置）。
        从以下版本开始：
        1.7

    • 方法详细信息

      • getNextEntry

        public ZipEntry getNextEntry​()
                      throws IOException
        读取下一个ZIP文件条目，并将流定位在条目数据的开头。
        结果
        下一个ZIP文件条目，如果没有更多条目，则为null
        异常
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O错误

      • closeEntry

        public void closeEntry​()
                throws IOException
        关闭当前的ZIP条目，并定位流以读取下一个条目。
        异常
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O错误

      • available

        public int available​()
              throws IOException
        EOF到达当前条目数据后返回0，否则返回1。

        程序不应该依赖此方法来返回可以读取而不阻止的实际字节数。

        重写：
        available在 InflaterInputStream
        结果
        EOF前为1，EOF达到当前输入后为0。
        异常
        IOException - 如果发生I / O错误。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从当前ZIP条目读取到字节数组。 如果len不为零，则该方法将阻塞，直到有些输入可用; 否则，不会读取字节，并返回0 。
        重写：
        read在 InflaterInputStream
        参数
        b - 读取数据的缓冲区
        off - 目标数组 b的起始偏移量
        len - 读取的最大字节数
        结果
        读取的实际字节数，如果达到条目结束，则为-1
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负，则 len为负数，或 len大于 b.length - off
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O错误
        另请参见：
        FilterInputStream.in

      • skip

        public long skip​(long n)
          throws IOException
        跳过当前ZIP条目中指定的字节数。
        重写：
        skip在 InflaterInputStream
        参数
        n - 要跳过的字节数
        结果
        实际跳过的字节数
        异常
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果是 n < 0

      • close

        public void close​()
           throws IOException
        关闭此输入流并释放与流相关联的任何系统资源。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 InflaterInputStream
        异常
        IOException - 如果发生I / O错误
        另请参见：
        FilterInputStream.in

      • createZipEntry

        protected ZipEntry createZipEntry​(String name)
        为指定的条目名称创建一个新的 ZipEntry对象。
        参数
        name - ZIP文件条目名称
        结果
        the ZipEntry just created
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ZipOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.util.zip

Class ZipOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.ZipOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable
    已知直接子类：
    JarOutputStream

    public class ZipOutputStream
extends DeflaterOutputStream
    该类实现了以ZIP文件格式写入文件的输出流过滤器。 包括对压缩和未压缩条目的支持。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static int | CENATT
      static int | CENATX
      static int | CENCOM
      static int | CENCRC
      static int | CENDSK
      static int | CENEXT
      static int | CENFLG
      static int | CENHDR
      static int | CENHOW
      static int | CENLEN
      static int | CENNAM
      static int | CENOFF
      static long | CENSIG
      static int | CENSIZ
      static int | CENTIM
      static int | CENVEM
      static int | CENVER
      static int DEFLATED
      压缩（DEFLATED）条目的压缩方法。
      static int | ENDCOM
      static int | ENDHDR
      static int | ENDOFF
      static long | ENDSIG
      static int | ENDSIZ
      static int | ENDSUB
      static int | ENDTOT
      static int | EXTCRC
      static int | EXTHDR
      static int | EXTLEN
      static long | EXTSIG
      static int | EXTSIZ
      static int | LOCCRC
      static int | LOCEXT
      static int | LOCFLG
      static int | LOCHDR
      static int | LOCHOW
      static int | LOCLEN
      static int | LOCNAM
      static long | LOCSIG
      static int | LOCSIZ
      static int | LOCTIM
      static int | LOCVER
      static int STORED
      未压缩（STORED）条目的压缩方法。

      • Fields inherited from class java.util.zip.DeflaterOutputStream

        buf, def

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Constructor 描述
      ZipOutputStream​(OutputStream out)
      创建一个新的ZIP输出流。
      ZipOutputStream​(OutputStream out, Charset charset)
      创建一个新的ZIP输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭ZIP输出流以及正在过滤的流。
      void closeEntry​()
      关闭当前的ZIP条目，并定位流以写入下一个条目。
      void finish​()
      完成编写ZIP输出流的内容，而不关闭底层流。
      void putNextEntry​(ZipEntry e)
      开始编写新的ZIP文件条目，并将流定位到条目数据的开头。
      void setComment​(String comment)
      设置ZIP文件注释。
      void setLevel​(int level)
      设置DEFLATED的后续条目的压缩级别。
      void setMethod​(int method)
      设置后续条目的默认压缩方法。
      void write​(byte[] b, int off, int len)
      将一个字节数组写入当前的ZIP条目数据。

      • Methods inherited from class java.util.zip.DeflaterOutputStream

        deflate, flush, write

      • Methods inherited from class java.io.FilterOutputStream

        write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • STORED

        public static final int STORED
        未压缩（STORED）条目的压缩方法。
        另请参见：
        Constant Field Values

      • DEFLATED

        public static final int DEFLATED
        压缩（DEFLATED）条目的压缩方法。
        另请参见：
        Constant Field Values

      • LOCSIG

        public static final long LOCSIG
        另请参见：
        Constant Field Values

      • EXTSIG

        public static final long EXTSIG
        另请参见：
        Constant Field Values

      • CENSIG

        public static final long CENSIG
        另请参见：
        Constant Field Values

      • ENDSIG

        public static final long ENDSIG
        另请参见：
        Constant Field Values

      • LOCHDR

        public static final int LOCHDR
        另请参见：
        Constant Field Values

      • EXTHDR

        public static final int EXTHDR
        另请参见：
        Constant Field Values

      • CENHDR

        public static final int CENHDR
        另请参见：
        Constant Field Values

      • ENDHDR

        public static final int ENDHDR
        另请参见：
        Constant Field Values

      • LOCVER

        public static final int LOCVER
        另请参见：
        Constant Field Values

      • LOCFLG

        public static final int LOCFLG
        另请参见：
        Constant Field Values

      • LOCHOW

        public static final int LOCHOW
        另请参见：
        Constant Field Values

      • LOCTIM

        public static final int LOCTIM
        另请参见：
        Constant Field Values

      • LOCCRC

        public static final int LOCCRC
        另请参见：
        Constant Field Values

      • LOCSIZ

        public static final int LOCSIZ
        另请参见：
        Constant Field Values

      • LOCLEN

        public static final int LOCLEN
        另请参见：
        Constant Field Values

      • LOCNAM

        public static final int LOCNAM
        另请参见：
        Constant Field Values

      • LOCEXT

        public static final int LOCEXT
        另请参见：
        Constant Field Values

      • EXTCRC

        public static final int EXTCRC
        另请参见：
        Constant Field Values

      • EXTSIZ

        public static final int EXTSIZ
        另请参见：
        Constant Field Values

      • EXTLEN

        public static final int EXTLEN
        另请参见：
        Constant Field Values

      • CENVEM

        public static final int CENVEM
        另请参见：
        Constant Field Values

      • CENVER

        public static final int CENVER
        另请参见：
        Constant Field Values

      • CENFLG

        public static final int CENFLG
        另请参见：
        Constant Field Values

      • CENHOW

        public static final int CENHOW
        另请参见：
        Constant Field Values

      • CENTIM

        public static final int CENTIM
        另请参见：
        Constant Field Values

      • CENCRC

        public static final int CENCRC
        另请参见：
        Constant Field Values

      • CENSIZ

        public static final int CENSIZ
        另请参见：
        Constant Field Values

      • CENLEN

        public static final int CENLEN
        另请参见：
        Constant Field Values

      • CENNAM

        public static final int CENNAM
        另请参见：
        Constant Field Values

      • CENEXT

        public static final int CENEXT
        另请参见：
        Constant Field Values

      • CENCOM

        public static final int CENCOM
        另请参见：
        Constant Field Values

      • CENDSK

        public static final int CENDSK
        另请参见：
        Constant Field Values

      • CENATT

        public static final int CENATT
        另请参见：
        Constant Field Values

      • CENATX

        public static final int CENATX
        另请参见：
        Constant Field Values

      • CENOFF

        public static final int CENOFF
        另请参见：
        Constant Field Values

      • ENDSUB

        public static final int ENDSUB
        另请参见：
        Constant Field Values

      • ENDTOT

        public static final int ENDTOT
        另请参见：
        Constant Field Values

      • ENDSIZ

        public static final int ENDSIZ
        另请参见：
        Constant Field Values

      • ENDOFF

        public static final int ENDOFF
        另请参见：
        Constant Field Values

      • ENDCOM

        public static final int ENDCOM
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ZipOutputStream

        public ZipOutputStream​(OutputStream out)
        创建一个新的ZIP输出流。

        UTF-8 charset用于对条目名称和注释进行编码。

        参数
        out - 实际的输出流

      • ZipOutputStream

        public ZipOutputStream​(OutputStream out,
                       Charset charset)
        创建一个新的ZIP输出流。
        参数
        out - 实际的输出流
        charset - 用于对条目名称和注释进行编码的charset
        从以下版本开始：
        1.7

    • 方法详细信息

      • setComment

        public void setComment​(String comment)
        设置ZIP文件注释。
        参数
        comment - 注释字符串
        异常
        IllegalArgumentException - 如果指定的ZIP文件注释的长度大于0xFFFF个字节

      • setMethod

        public void setMethod​(int method)
        设置后续条目的默认压缩方法。 当不为每个ZIP文件条目指定压缩方法，并且最初设置为DEFLATED时，将使用此默认值。
        参数
        method - 默认的压缩方法
        异常
        IllegalArgumentException - 如果指定的压缩方法无效

      • setLevel

        public void setLevel​(int level)
        设置DEFLATED的后续条目的压缩级别。 默认设置为DEFAULT_COMPRESSION。
        参数
        level - 压缩级别（0-9）
        异常
        IllegalArgumentException - 如果压缩级别无效

      • putNextEntry

        public void putNextEntry​(ZipEntry e)
                  throws IOException
        开始编写新的ZIP文件条目，并将流定位到条目数据的开头。 关闭当前条目，如果仍然有效。 如果没有为条目指定压缩方法，将使用默认压缩方法，如果条目没有设置修改时间，将使用当前时间。
        参数
        e - 要写入的ZIP条目
        异常
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生I / O错误

      • closeEntry

        public void closeEntry​()
                throws IOException
        关闭当前的ZIP条目，并定位流以写入下一个条目。
        异常
        ZipException - 如果发生ZIP格式错误
        IOException - 如果发生I / O错误

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        将一个字节数组写入当前的ZIP条目数据。 该方法将阻塞，直到写入所有字节为止。
        重写：
        write在 DeflaterOutputStream
        参数
        b - 要写入的数据
        off - 数据中的起始偏移量
        len - 写入的字节数
        异常
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O错误
        另请参见：
        FilterOutputStream.write(int)

      • finish

        public void finish​()
            throws IOException
        完成编写ZIP输出流的内容，而不关闭底层流。 在连续使用多个过滤器到相同的输出流时使用此方法。
        重写：
        finish在 DeflaterOutputStream
        异常
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O异常

      • close

        public void close​()
           throws IOException
        关闭ZIP输出流以及正在过滤的流。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 DeflaterOutputStream
        异常
        ZipException - 如果发生ZIP文件错误
        IOException - 如果发生I / O错误
        另请参见：
        FilterOutputStream.flush() ， FilterOutputStream.out
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Class java.util.zip.Adler32 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.Adler32

No usage of java.util.zip.Adler32
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.CheckedInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.CheckedInputStream

No usage of java.util.zip.CheckedInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.CheckedOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.CheckedOutputStream

No usage of java.util.zip.CheckedOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.CRC32 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.CRC32

  • Packages that use CRC32
    软件包 描述
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of CRC32 in java.util.zip

      Fields in java.util.zip declared as CRC32
      Modifier and Type Field 描述
      protected CRC32 GZIPInputStream.crc
      CRC-32用于未压缩数据。
      protected CRC32 GZIPOutputStream.crc
      未压缩数据的CRC-32。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.CRC32C (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.CRC32C

No usage of java.util.zip.CRC32C
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.DataFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.DataFormatException

  • Packages that use DataFormatException
    软件包 描述
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of DataFormatException in java.util.zip

      Methods in java.util.zip that throw DataFormatException
      Modifier and Type 方法 描述
      int Inflater.inflate​(byte[] b)
      将字节解压缩到指定的缓冲区。
      int Inflater.inflate​(byte[] b, int off, int len)
      将字节解压缩到指定的缓冲区。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.Deflater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.Deflater

  • Packages that use Deflater
    软件包 描述
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of Deflater in java.util.zip

      Fields in java.util.zip declared as Deflater
      Modifier and Type Field 描述
      protected Deflater DeflaterInputStream.def
      此流的压缩器。
      protected Deflater DeflaterOutputStream.def
      此流的压缩器。
      Constructors in java.util.zip with parameters of type Deflater
      Constructor 描述
      DeflaterInputStream​(InputStream in, Deflater defl)
      使用指定的压缩器和默认缓冲区大小创建新的输入流。
      DeflaterInputStream​(InputStream in, Deflater defl, int bufLen)
      创建具有指定压缩器和缓冲区大小的新输入流。
      DeflaterOutputStream​(OutputStream out, Deflater def)
      使用指定的压缩器和默认缓冲区大小创建新的输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def, boolean syncFlush)
      使用指定的压缩器，刷新模式和默认缓冲区大小创建新的输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def, int size)
      创建具有指定压缩器和缓冲区大小的新输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def, int size, boolean syncFlush)
      创建具有指定压缩器，缓冲区大小和冲洗模式的新输出流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.DeflaterInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.DeflaterInputStream

No usage of java.util.zip.DeflaterInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.DeflaterOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.DeflaterOutputStream

  • Packages that use DeflaterOutputStream
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of DeflaterOutputStream in java.util.jar

      Subclasses of DeflaterOutputStream in java.util.jar
      Modifier and Type Class 描述
      class  JarOutputStream
      JarOutputStream类用于将JAR文件的内容写入任何输出流。

    • Uses of DeflaterOutputStream in java.util.zip

      Subclasses of DeflaterOutputStream in java.util.zip
      Modifier and Type Class 描述
      class  GZIPOutputStream
      该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。
      class  ZipOutputStream
      该类实现了以ZIP文件格式写入文件的输出流过滤器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.GZIPInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.GZIPInputStream

No usage of java.util.zip.GZIPInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.GZIPOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.GZIPOutputStream

No usage of java.util.zip.GZIPOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.Inflater (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.Inflater

  • Packages that use Inflater
    软件包 描述
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of Inflater in java.util.zip

      Fields in java.util.zip declared as Inflater
      Modifier and Type Field 描述
      protected Inflater InflaterInputStream.inf
      解压缩此流。
      protected Inflater InflaterOutputStream.inf
      解压缩此流。
      Constructors in java.util.zip with parameters of type Inflater
      Constructor 描述
      InflaterInputStream​(InputStream in, Inflater inf)
      使用指定的解压缩器和默认缓冲区大小创建新的输入流。
      InflaterInputStream​(InputStream in, Inflater inf, int size)
      使用指定的解压缩器和缓冲区大小创建新的输入流。
      InflaterOutputStream​(OutputStream out, Inflater infl)
      使用指定的解压缩器和默认缓冲区大小创建新的输出流。
      InflaterOutputStream​(OutputStream out, Inflater infl, int bufLen)
      Creates a new output stream with the specified decompressor and buffer size.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.InflaterInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.InflaterInputStream

  • Packages that use InflaterInputStream
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of InflaterInputStream in java.util.jar

      Subclasses of InflaterInputStream in java.util.jar
      Modifier and Type Class 描述
      class  JarInputStream
      JarInputStream类用于从任何输入流读取JAR文件的内容。

    • Uses of InflaterInputStream in java.util.zip

      Subclasses of InflaterInputStream in java.util.zip
      Modifier and Type Class 描述
      class  GZIPInputStream
      该类实现了一个流过滤器，用于读取GZIP文件格式的压缩数据。
      class  ZipInputStream
      该类实现了以ZIP文件格式读取文件的输入流过滤器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.InflaterOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.InflaterOutputStream

No usage of java.util.zip.InflaterOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.ZipEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.ZipEntry

  • Packages that use ZipEntry
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of ZipEntry in java.util.jar

      Subclasses of ZipEntry in java.util.jar
      Modifier and Type Class 描述
      class  JarEntry
      此类用于表示JAR文件条目。
      Methods in java.util.jar that return ZipEntry
      Modifier and Type 方法 描述
      protected ZipEntry JarInputStream.createZipEntry​(String name)
      为指定的JAR文件条目名称创建一个新的 JarEntry （ ZipEntry ）。
      ZipEntry JarFile.getEntry​(String name)
      返回 ZipEntry用于给定基本条目名称 null如果没有找到。
      ZipEntry JarInputStream.getNextEntry​()
      读取下一个ZIP文件条目，并将流定位在条目数据的开头。
      Methods in java.util.jar with parameters of type ZipEntry
      Modifier and Type 方法 描述
      InputStream JarFile.getInputStream​(ZipEntry ze)
      返回用于读取指定zip文件条目内容的输入流。
      void JarOutputStream.putNextEntry​(ZipEntry ze)
      开始编写一个新的JAR文件条目，并将流定位到入口数据的开头。
      Constructors in java.util.jar with parameters of type ZipEntry
      Constructor 描述
      JarEntry​(ZipEntry ze)
      创建一个新的 JarEntry其中的字段取自指定的 ZipEntry对象。

    • Uses of ZipEntry in java.util.zip

      Methods in java.util.zip that return ZipEntry
      Modifier and Type 方法 描述
      protected ZipEntry ZipInputStream.createZipEntry​(String name)
      为指定的条目名称创建一个新的 ZipEntry对象。
      ZipEntry ZipFile.getEntry​(String name)
      返回指定名称的zip文件条目，如果找不到则返回null。
      ZipEntry ZipInputStream.getNextEntry​()
      读取下一个ZIP文件条目，并将流定位在条目数据的开头。
      ZipEntry ZipEntry.setCreationTime​(FileTime time)
      设置条目的创建时间。
      ZipEntry ZipEntry.setLastAccessTime​(FileTime time)
      设置条目的最后访问时间。
      ZipEntry ZipEntry.setLastModifiedTime​(FileTime time)
      设置条目的最后修改时间。
      Methods in java.util.zip that return types with arguments of type ZipEntry
      Modifier and Type 方法 描述
      Enumeration<? extends ZipEntry> ZipFile.entries​()
      返回ZIP文件条目的枚举。
      Stream<? extends ZipEntry> ZipFile.stream​()
      在ZIP文件条目上返回有序的 Stream 。
      Methods in java.util.zip with parameters of type ZipEntry
      Modifier and Type 方法 描述
      InputStream ZipFile.getInputStream​(ZipEntry entry)
      返回用于读取指定zip文件条目内容的输入流。
      void ZipOutputStream.putNextEntry​(ZipEntry e)
      开始编写新的ZIP文件条目，并将流定位到条目数据的开头。
      Constructors in java.util.zip with parameters of type ZipEntry
      Constructor 描述
      ZipEntry​(ZipEntry e)
      创建一个新的zip条目，其中的字段从指定的zip条目中取出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.ZipError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.ZipError

No usage of java.util.zip.ZipError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.ZipException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.ZipException

  • Packages that use ZipException
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of ZipException in java.util.jar

      Subclasses of ZipException in java.util.jar
      Modifier and Type Class 描述
      class  JarException
      表示在读取或写入JAR文件时发生了某种错误。

    • Uses of ZipException in java.util.zip

      Constructors in java.util.zip that throw ZipException
      Constructor 描述
      ZipFile​(File file)
      打开一个ZIP文件，读取指定的File对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.ZipFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.ZipFile

  • Packages that use ZipFile
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    jdk.security.jarsigner

    • Uses of ZipFile in com.sun.jarsigner

      Methods in com.sun.jarsigner that return ZipFile
      Modifier and Type 方法 描述
      ZipFile ContentSignerParameters.getSource​()
      已过时。
      在签署之前检索原始的ZIP文件。

    • Uses of ZipFile in java.util.jar

      Subclasses of ZipFile in java.util.jar
      Modifier and Type Class 描述
      class  JarFile
      JarFile类用于从可以使用 java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。

    • Uses of ZipFile in jdk.security.jarsigner

      Methods in jdk.security.jarsigner with parameters of type ZipFile
      Modifier and Type 方法 描述
      void JarSigner.sign​(ZipFile file, OutputStream os)
      将文件标记为OutputStream 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.ZipInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.ZipInputStream

  • Packages that use ZipInputStream
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of ZipInputStream in java.util.jar

      Subclasses of ZipInputStream in java.util.jar
      Modifier and Type Class 描述
      class  JarInputStream
      JarInputStream类用于从任何输入流读取JAR文件的内容。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class java.util.zip.ZipOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.util.zip.ZipOutputStream

  • Packages that use ZipOutputStream
    软件包 描述
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of ZipOutputStream in java.util.jar

      Subclasses of ZipOutputStream in java.util.jar
      Modifier and Type Class 描述
      class  JarOutputStream
      JarOutputStream类用于将JAR文件的内容写入任何输出流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface java.util.zip.Checksum (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.util.zip.Checksum

  • Packages that use Checksum
    软件包 描述
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of Checksum in java.util.zip

      Classes in java.util.zip that implement Checksum
      Modifier and Type Class 描述
      class  Adler32
      可用于计算数据流的Adler-32校验和的类。
      class  CRC32
      可用于计算数据流的CRC-32的类。
      class  CRC32C
      可用于计算数据流的CRC-32C的类。
      Methods in java.util.zip that return Checksum
      Modifier and Type 方法 描述
      Checksum CheckedInputStream.getChecksum​()
      返回此输入流的校验和。
      Checksum CheckedOutputStream.getChecksum​()
      返回此输出流的校验和。
      Constructors in java.util.zip with parameters of type Checksum
      Constructor 描述
      CheckedInputStream​(InputStream in, Checksum cksum)
      使用指定的校验和创建输入流。
      CheckedOutputStream​(OutputStream out, Checksum cksum)
      使用指定的校验和创建输出流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Animation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class Animation

  • java.lang.Object
    • javafx.animation.Animation
  • 已知直接子类：
    Timeline ， Transition

    public abstract class Animation
extends Object
    Animation提供了JavaFX运行时使用的所有动画的核心功能。

    动画可以通过设置cycleCount循环运行。 要使循环播放动画时，请设置autoReverse -flag。

    致电play()或playFromStart()播放Animation 。 所述Animation进展中所指定的方向和速度rate ，并且当它的持续时间经过停止。 一个Animation持续时间（ 270653606162376的INDEFINITE ），直到stop()方法被显式调用，这将停止运行Animation并将其播放头重置到初始位置。

    一个Animation可以通过致电pause()暂停，而下一个play()呼叫将从其暂停的Animation恢复Animation 。

    一个Animation的游戏头可以随机定位，无论是否运行。 如果Animation正在运行，则播放头立即跳转到指定位置，并继续从新位置播放。 如果Animation没有运行，下一个play()将从指定的位置启动Animation 。

    反转rate的值切换播放方向。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Timeline ， Transition

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty autoReverse
      定义 Animation是否在交替循环中反转方向。
      ReadOnlyDoubleProperty currentRate
      只读变量，用于指示正在播放 Animation当前方向/速度。
      ReadOnlyObjectProperty<Duration> currentTime
      定义 Animation的播放头位置。
      IntegerProperty cycleCount
      定义此动画中的循环次数。
      ReadOnlyObjectProperty<Duration> cycleDuration
      只读变量指示 Animation的一个周期的持续时间：从时间0到动画结束所需的时间（默认为 rate为1.0）。
      ObjectProperty<Duration> delay
      延迟动画的开始。
      ObjectProperty<EventHandler<ActionEvent>> onFinished
      在这个 Animation结束时执行的行动。
      DoubleProperty rate
      定义 Animation预计播放的方向/速度。
      ReadOnlyObjectProperty<Animation.Status> status
      的状态 Animation 。
      ReadOnlyObjectProperty<Duration> totalDuration
      只读变量来指示这个 Animation的总持续时间，包括重复。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Animation.Status
      可能的状态为 status 。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int INDEFINITE
      用于指定无限期重复的动画，直到调用 stop()方法。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Animation​()
      构造函数为 Animation 。
      protected Animation​(double targetFramerate)
      构造函数为 Animation 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanProperty autoReverseProperty​()
      定义 Animation是否在交替循环中反转方向。
      ReadOnlyDoubleProperty currentRateProperty​()
      只读变量，用于指示正在播放 Animation当前方向/速度。
      ReadOnlyObjectProperty<Duration> currentTimeProperty​()
      定义 Animation的播放位置。
      IntegerProperty cycleCountProperty​()
      定义此动画中的循环次数。
      ReadOnlyObjectProperty<Duration> cycleDurationProperty​()
      用于指示 Animation的一个周期持续时间的只读变量：从时间0到动画结束所需的时间（默认为 rate为1.0）。
      ObjectProperty<Duration> delayProperty​()
      延迟动画的开始。
      ObservableMap<String,Duration> getCuePoints​()
      提示点可用于标记 Animation重要位置。
      double getCurrentRate​()
      获取属性currentRate的值。
      Duration getCurrentTime​()
      获取属性currentTime的值。
      int getCycleCount​()
      获取属性cycleCount的值。
      Duration getCycleDuration​()
      获取属性cycleDuration的值。
      Duration getDelay​()
      获取属性延迟的值。
      EventHandler<ActionEvent> getOnFinished​()
      获取属性onFinished的值。
      double getRate​()
      获取房价的价值。
      Animation.Status getStatus​()
      获取属性状态的值。
      double getTargetFramerate​()
      目标帧率是 Animation将以每秒帧数运行的最大帧速率。
      Duration getTotalDuration​()
      获取属性totalDuration的值。
      boolean isAutoReverse​()
      获取属性autoReverse的值。
      void jumpTo​(String cuePoint)
      Animation这个 Animation的预定义位置。
      void jumpTo​(Duration time)
      Animation这个 Animation的给定位置。
      ObjectProperty<EventHandler<ActionEvent>> onFinishedProperty​()
      在这个 Animation的结尾执行的行动。
      void pause​()
      暂停动画。
      void play​()
      起着 Animation从在所指示的方向当前位置 rate 。
      void playFrom​(String cuePoint)
      从预定位置播放 Animation方便方法。
      void playFrom​(Duration time)
      从一个特定的位置播放这个 Animation一个方便的方法。
      void playFromStart​()
      从正向起始位置播放 Animation 。
      DoubleProperty rateProperty​()
      定义 Animation预计播放的方向/速度。
      void setAutoReverse​(boolean value)
      设置属性autoReverse的值。
      void setCycleCount​(int value)
      设置属性cycleCount的值。
      protected void setCycleDuration​(Duration value)
      设置属性cycleDuration的值。
      void setDelay​(Duration value)
      设置属性延迟的值。
      void setOnFinished​(EventHandler<ActionEvent> value)
      设置属性onFinished的值。
      void setRate​(double value)
      设置属性率的值。
      protected void setStatus​(Animation.Status value)
      设置属性状态的值。
      ReadOnlyObjectProperty<Animation.Status> statusProperty​()
      的状态 Animation 。
      void stop​()
      停止动画并将播放头重置到其初始位置。
      ReadOnlyObjectProperty<Duration> totalDurationProperty​()
      只读变量，用于指示此 Animation的总持续时间，包括重复。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • rate

        public final DoubleProperty rateProperty
        定义Animation预计播放的方向/速度。

        的绝对值rate指示哪个速度Animation要被播放，而符号rate指示的方向。 正值rate表示正向播放，负值表示反向播放， 0.0停止运行Animation 。

        价格1.0是正常播放， 2.0是2次正常， -1.0是倒退等...

        反转运行速度Animation将导致Animation反转方向，并播放已经过去的部分Animation 。

        Default value:
        1.0
        另请参见：
        getRate() ， setRate(double)

      • currentRate

        public final ReadOnlyDoubleProperty currentRateProperty
        只读变量来指示正在播放Animation当前方向/速度。

        currentRate不需要等于rate 。 currentRate设置为0.0当动画暂停或停止。 currentRate也可能在反向循环期间指向不同的方向，当autoReverse为true

        Default value:
        0.0
        另请参见：
        getCurrentRate()

      • cycleDuration

        public final ReadOnlyObjectProperty<Duration> cycleDurationProperty
        用于指示 Animation的一个周期持续时间的只读变量：从时间0到动画结束所需的时间（默认为 rate为1.0）。
        Default value:
        0毫秒
        另请参见：
        getCycleDuration() ， setCycleDuration(Duration)

      • totalDuration

        public final ReadOnlyObjectProperty<Duration> totalDurationProperty
        只读变量来表示这个Animation的总持续时间，包括重复。 A Animation与cycleCount的Animation.INDEFINITE将有一个totalDuration的Duration.INDEFINITE 。

        这被设置为cycleDuration * cycleCount。

        Default value:
        0毫秒
        另请参见：
        getTotalDuration()

      • currentTime

        public final ReadOnlyObjectProperty<Duration> currentTimeProperty
        定义 Animation的播放位置。
        Default value:
        0毫秒
        另请参见：
        getCurrentTime()

      • delay

        public final ObjectProperty<Duration> delayProperty
        延迟动画的开始。 不能是负面的 设置为负数将导致IllegalArgumentException 。
        Default value:
        0毫秒
        另请参见：
        getDelay() ， setDelay(Duration)

      • cycleCount

        public final IntegerProperty cycleCountProperty
        定义此动画中的循环次数。 对于无限期重复的动画， cycleCount可能为INDEFINITE ，否则为> 0。

        不可能更改cycleCount的一个正在运行的Animation 。 如果值cycleCount改变正在运行的Animation ，动画必须停止并重新开始拿起新的价值。

        Default value:
        1.0
        另请参见：
        getCycleCount() ， setCycleCount(int)

      • autoReverse

        public final BooleanProperty autoReverseProperty
        定义Animation是否在交替循环中反转方向。 如果true ，该Animation将继续推进在第一个周期，然后反转的第二个周期，依此类推。 否则，动画将循环，使得每个循环从一开始就向前推进。 不可能更改autoReverse标志的一个正在运行的Animation 。 如果值autoReverse改变正在运行的Animation ，动画必须停止并重新开始拿起新的价值。
        Default value:
        假
        另请参见：
        isAutoReverse() ， setAutoReverse(boolean)

      • status

        public final ReadOnlyObjectProperty<Animation.Status> statusProperty
        状态为Animation 。 在Animation可以在三种状态之一： Animation.Status.STOPPED ， Animation.Status.PAUSED或者Animation.Status.RUNNING 。
        另请参见：
        getStatus() ， setStatus(Animation.Status)

      • onFinished

        public final ObjectProperty<EventHandler<ActionEvent>> onFinishedProperty
        在这个 Animation结束时执行的行动。
        Default value:
        空值
        另请参见：
        getOnFinished() ， setOnFinished(EventHandler)

    • 字段详细信息

      • INDEFINITE

        public static final int INDEFINITE
        用于指定无限期重复的动画，直到调用 stop()方法。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Animation

        protected Animation​(double targetFramerate)
        构造函数为Animation 。 此构造函数允许定义目标帧率。
        参数
        targetFramerate -自定义的目标帧速率此 Animation
        另请参见：
        getTargetFramerate()

      • Animation

        protected Animation​()
        构造函数为 Animation 。

    • 方法详细信息

      • setRate

        public final void setRate​(double value)
        设置属性率的值。
        Property description:
        定义Animation预计播放的方向/速度。

        的绝对值rate指示哪个速度Animation要被播放，而符号rate指示的方向。 正值rate表示正向播放，负值表示反向播放， 0.0停止运行Animation 。

        价格1.0是正常播放， 2.0是2次正常， -1.0是倒退等...

        反转运行速度Animation将导致Animation反转方向，并播放已经过去的部分Animation 。

        Default value:
        1.0

      • getRate

        public final double getRate​()
        获取房价的价值。
        Property description:
        定义Animation预计播放的方向/速度。

        的绝对值rate指示哪个速度Animation要被播放，而符号rate指示的方向。 正值rate表示正向播放，负值表示反向播放， 0.0停止运行Animation 。

        价格1.0是正常播放， 2.0是2次正常， -1.0是倒退等等...

        反转运行速率Animation将导致Animation反转方向，并播放已经过去的Animation部分。

        Default value:
        1.0

      • rateProperty

        public final DoubleProperty rateProperty​()
        定义Animation预计播放的方向/速度。

        的绝对值rate指示哪个速度Animation要被播放，而符号rate指示的方向。 正值rate表示正向播放，负值表示反向播放， 0.0停止运行Animation 。

        价格1.0是正常播放， 2.0是2次正常， -1.0是倒退等等...

        反转运行速度Animation将导致Animation反转方向，并播放已经过去的部分Animation 。

        Default value:
        1.0
        另请参见：
        getRate() ， setRate(double)

      • getCurrentRate

        public final double getCurrentRate​()
        获取属性currentRate的值。
        Property description:
        只读变量来指示正在播放Animation当前方向/速度。

        currentRate不需要等于rate 。 currentRate设置为0.0当动画暂停或停止。 currentRate也可能在反向循环期间指向不同的方向，当autoReverse为true

        Default value:
        0.0

      • currentRateProperty

        public final ReadOnlyDoubleProperty currentRateProperty​()
        只读变量来指示正在播放Animation当前方向/速度。

        currentRate不需要等于rate 。 currentRate设置为0.0当动画暂停或停止。 currentRate也可以在反向循环期间指向不同的方向，当autoReverse为true

        Default value:
        0.0
        另请参见：
        getCurrentRate()

      • setCycleDuration

        protected final void setCycleDuration​(Duration value)
        设置属性cycleDuration的值。
        Property description:
        用于指示 Animation的一个周期持续时间的只读变量：从时间0到动画结束所需的时间（默认为 rate为1.0）。
        Default value:
        0毫秒

      • getCycleDuration

        public final Duration getCycleDuration​()
        获取属性cycleDuration的值。
        Property description:
        用于指示 Animation的一个周期持续时间的只读变量：从时间0到动画结束所需的时间（默认为 rate为1.0）。
        Default value:
        0毫秒

      • cycleDurationProperty

        public final ReadOnlyObjectProperty<Duration> cycleDurationProperty​()
        用于指示 Animation的一个周期持续时间的只读变量：从时间0到动画结束所需的时间（默认为 rate为1.0）。
        Default value:
        0毫秒
        另请参见：
        getCycleDuration() ， setCycleDuration(Duration)

      • getTotalDuration

        public final Duration getTotalDuration​()
        获取属性totalDuration的值。
        Property description:
        只读变量，用于指示此Animation的总持续时间，包括重复。 A Animation与cycleCount的Animation.INDEFINITE将有一个totalDuration的Duration.INDEFINITE 。

        这被设置为cycleDuration * cycleCount。

        Default value:
        0毫秒

      • totalDurationProperty

        public final ReadOnlyObjectProperty<Duration> totalDurationProperty​()
        只读变量，用于指示此Animation的总持续时间，包括重复。 A Animation与cycleCount的Animation.INDEFINITE将有一个totalDuration的Duration.INDEFINITE 。

        这被设置为cycleDuration * cycleCount。

        Default value:
        0毫秒
        另请参见：
        getTotalDuration()

      • getCurrentTime

        public final Duration getCurrentTime​()
        获取属性currentTime的值。
        Property description:
        定义 Animation的播放位置。
        Default value:
        0毫秒

      • currentTimeProperty

        public final ReadOnlyObjectProperty<Duration> currentTimeProperty​()
        定义 Animation的播放位置。
        Default value:
        0毫秒
        另请参见：
        getCurrentTime()

      • setDelay

        public final void setDelay​(Duration value)
        设置属性延迟的值。
        Property description:
        延迟动画的开始。 不能是负面的 设置为负数将导致IllegalArgumentException 。
        Default value:
        0毫秒

      • getDelay

        public final Duration getDelay​()
        获取属性延迟的值。
        Property description:
        延迟动画的开始。 不能是负面的 设置为负数将导致IllegalArgumentException 。
        Default value:
        0毫秒

      • delayProperty

        public final ObjectProperty<Duration> delayProperty​()
        延迟动画的开始。 不能是负面的 设置为负数将导致IllegalArgumentException 。
        Default value:
        0毫秒
        另请参见：
        getDelay() ， setDelay(Duration)

      • setCycleCount

        public final void setCycleCount​(int value)
        设置属性cycleCount的值。
        Property description:
        定义此动画中的循环次数。 对于无限期重复的动画， cycleCount可能为INDEFINITE ，否则为> 0。

        不可能更改cycleCount的运行中的Animation 。 如果值cycleCount改变正在运行的Animation ，动画必须停止并重新开始拿起新的价值。

        Default value:
        1.0

      • getCycleCount

        public final int getCycleCount​()
        获取属性cycleCount的值。
        Property description:
        定义此动画中的循环次数。 cycleCount可能是INDEFINITE无限期重复的动画，但必须为> 0。

        无法更改cycleCount的Animation 。 如果值cycleCount改变正在运行的Animation ，动画必须停止并重新开始拿起新的价值。

        Default value:
        1.0

      • cycleCountProperty

        public final IntegerProperty cycleCountProperty​()
        定义此动画中的循环次数。 对于无限期重复的动画， cycleCount可能为INDEFINITE ，否则为> 0。

        不可能更改cycleCount的Animation 。 如果值cycleCount改变正在运行的Animation ，动画必须停止并重新开始拿起新的价值。

        Default value:
        1.0
        另请参见：
        getCycleCount() ， setCycleCount(int)

      • setAutoReverse

        public final void setAutoReverse​(boolean value)
        设置属性autoReverse的值。
        Property description:
        定义Animation是否在交替循环中反转方向。 如果true ，该Animation将继续推进在第一个周期，然后反转的第二个周期，依此类推。 否则，动画将循环，使得每个循环从一开始就向前推进。 不可能更改autoReverse标志运行的Animation 。 如果值autoReverse改变正在运行的Animation ，动画必须停止并重新开始拿起新的价值。
        Default value:
        假

      • isAutoReverse

        public final boolean isAutoReverse​()
        获取属性autoReverse的值。
        Property description:
        定义Animation是否在交替循环中反转方向。 如果true ，该Animation将继续推进在第一个周期，然后反转的第二个周期，依此类推。 否则，动画将循环，使得每个循环从一开始就向前推进。 不可能更改autoReverse标志运行的Animation 。 如果值autoReverse改变正在运行的Animation ，动画必须停止并重新开始拿起新的价值。
        Default value:
        假

      • autoReverseProperty

        public final BooleanProperty autoReverseProperty​()
        定义Animation是否在交替循环中反转方向。 如果true ，该Animation将继续推进在第一个周期，然后反转的第二个周期，依此类推。 否则，动画将循环，使得每个循环从一开始就向前推进。 不能更改正在运行的autoReverse标志的Animation 。 如果autoReverse的值更改为Animation ，则动画必须停止并重新开始以获取新值。
        Default value:
        假
        另请参见：
        isAutoReverse() ， setAutoReverse(boolean)

      • setStatus

        protected final void setStatus​(Animation.Status value)
        设置属性状态的值。
        Property description:
        的状态Animation 。 在Animation可以在三种状态之一： Animation.Status.STOPPED ， Animation.Status.PAUSED或者Animation.Status.RUNNING 。

      • getStatus

        public final Animation.Status getStatus​()
        获取属性状态的值。
        Property description:
        的状态Animation 。 在Animation可以在三种状态之一： Animation.Status.STOPPED ， Animation.Status.PAUSED或者Animation.Status.RUNNING 。

      • statusProperty

        public final ReadOnlyObjectProperty<Animation.Status> statusProperty​()
        状态为Animation 。 在Animation可以在三种状态之一： Animation.Status.STOPPED ， Animation.Status.PAUSED或者Animation.Status.RUNNING 。
        另请参见：
        getStatus() ， setStatus(Animation.Status)

      • getTargetFramerate

        public final double getTargetFramerate​()
        目标帧率是Animation运行的最大帧率，以帧/秒为单位。 例如，这可以用于保持特别复杂的Animations免受过度消耗的系统资源的影响。 默认情况下， Animation的帧速率没有明确限制，这意味着Animation将以底层平台的最佳帧速率运行。
        结果
        目标帧速率

      • setOnFinished

        public final void setOnFinished​(EventHandler<ActionEvent> value)
        设置属性onFinished的值。
        Property description:
        在这个 Animation的结论执行的行动。
        Default value:
        空值

      • getOnFinished

        public final EventHandler<ActionEvent> getOnFinished​()
        获取属性onFinished的值。
        Property description:
        在这个 Animation的结论执行的行动。
        Default value:
        空值

      • onFinishedProperty

        public final ObjectProperty<EventHandler<ActionEvent>> onFinishedProperty​()
        在这个 Animation的结尾执行的行动。
        Default value:
        空值
        另请参见：
        getOnFinished() ， setOnFinished(EventHandler)

      • getCuePoints

        public final ObservableMap<String,Duration> getCuePoints​()
        提示点可用于标记Animation重要位置。 一旦提示点被定义，它可以用作jumpTo()和playFrom()的参数来快速移动到关联位置。

        每个Animation都有两个预定义的提示点"start"和"end" ，分别设置在Animation的结尾Animation 。 预定义的点对点不会出现在地图中，尝试覆盖它们没有任何效果。

        在定义一个提示点的另一种选择Animation是设置KeyFrame.name一个财产KeyFrame 。

        结果
        提示点ObservableMap

      • jumpTo

        public void jumpTo​(Duration time)
        Animation这个Animation的给定位置。 如果给定的时间小于Duration.ZERO ，此方法将跳转到动画的开头。 如果给定的时间大于Animation的持续时间，则此方法将跳到最后。
        参数
        time - 新职位
        异常
        NullPointerException - 如果 time是 null
        IllegalArgumentException - 如果 time是 Duration.UNKNOWN
        IllegalStateException - 如果嵌入另一个动画，如SequentialTransition或ParallelTransition

      • jumpTo

        public void jumpTo​(String cuePoint)
        Animation这个Animation的预定义位置。 该方法查找提示点中的条目并跳转到关联位置（如果找到）。

        如果提示点在这个Animation ，调用jumpTo会导致跳转到最后。 如果提示点的负数为Duration ，则会跳转到开头。 如果提示点的值为Duration.UNKNOWN，调用jumpTo将对此提示点没有影响。

        有两个预定义的提示点"start"和"end" ，分别被定义为在这个Animation的结尾Animation 。

        参数
        cuePoint - 提示点的名称
        异常
        NullPointerException - 如果 cuePoint是 null
        IllegalStateException - 如果嵌入另一个动画，如SequentialTransition或ParallelTransition
        另请参见：
        getCuePoints()

      • playFrom

        public void playFrom​(String cuePoint)
        从预定义的位置播放这个Animation一种方便的方法。 该位置必须在提示点中预定义。 调用此方法相当于
           animation.jumpTo(cuePoint); animation.play();
        注意，不像playFromStart()调用这个方法不会改变这个Animation的播放方向。
        参数
        cuePoint - 提示点的名称
        异常
        NullPointerException - 如果 cuePoint是 null
        IllegalStateException - 如果嵌入另一个动画，如SequentialTransition或ParallelTransition
        另请参见：
        getCuePoints()

      • playFrom

        public void playFrom​(Duration time)
        从一个特定的位置播放这个Animation一个方便的方法。 调用此方法相当于
           animation.jumpTo(time); animation.play();
        注意，不像playFromStart()调用这个方法不会改变这个Animation的播放方向。
        参数
        time - 从哪里玩的位置
        异常
        NullPointerException - 如果 time是 null
        IllegalArgumentException -如果 time为 Duration.UNKNOWN
        IllegalStateException - 如果嵌入另一个动画，如SequentialTransition或ParallelTransition

      • play

        public void play​()
        起着Animation从在所指示的方向当前位置rate 。 如果Animation正在运行，则不起作用。

        当rate > 0（前进播放）时，如果一个Animation已经定位在最后，第一个周期将不被播放，它被认为已经完成。 如果一个Animation位于开头，这也适用于后退（ rate <0）周期。 但是，如果Animation具有cycleCount > 1，则cycleCount周期将像往常一样播放。

        当Animation到达结束时， Animation停止，播放头保持结束。

        从后端播放Animation ：
        animation.setRate(negative rate);
        animation.jumpTo(overall duration of animation);
        animation.play();

        注意：

        • play()是异步调用， Animation可能无法立即启动。
        异常
        IllegalStateException - 如果嵌入另一个动画，如SequentialTransition或ParallelTransition

      • playFromStart

        public void playFromStart​()
        从正向起始位置播放Animation 。

        相当于

        animation.stop();
        animation.setRate = setRate(Math.abs(animation.getRate()));
        animation.jumpTo(Duration.ZERO);
        animation.play();

        注意：

        • playFromStart()是异步调用， Animation可能无法立即启动。

        异常
        IllegalStateException - 如果嵌入另一个动画，如SequentialTransition或ParallelTransition

      • stop

        public void stop​()
        停止动画并将播放头重置到其初始位置。 如果动画当前没有运行，则此方法无效。

        注意：

        • stop()是异步调用， Animation可能不会立即停止。
        异常
        IllegalStateException - 如果嵌入另一个动画，如SequentialTransition或ParallelTransition

      • pause

        public void pause​()
        暂停动画。 如果动画当前没有运行，则此方法无效。

        注意：

        • pause()是一个异步调用， Animation可能不会立即暂停。
        异常
        IllegalStateException - 如果嵌入另一个动画，如SequentialTransition或ParallelTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Animation.Status (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Enum Animation.Status

  • java.lang.Object
    • java.lang.Enum<Animation.Status>
      • javafx.animation.Animation.Status
  • All Implemented Interfaces:
    Serializable ， Comparable<Animation.Status>
    Enclosing class:
    Animation

    public static enum Animation.Status
extends Enum<Animation.Status>
    可能的状态为 status 。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      PAUSED
      暂停状态。
      RUNNING
      运行状态。
      STOPPED
      停止状态。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Animation.Status valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Animation.Status[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PAUSED

        public static final Animation.Status PAUSED
        暂停状态。

      • RUNNING

        public static final Animation.Status RUNNING
        运行状态。

      • STOPPED

        public static final Animation.Status STOPPED
        停止状态。

    • 方法详细信息

      • values

        public static Animation.Status[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Animation.Status c : Animation.Status.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Animation.Status valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


AnimationTimer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class AnimationTimer

  • java.lang.Object
    • javafx.animation.AnimationTimer

  • public abstract class AnimationTimer
extends Object
    AnimationTimer类允许创建一个定时器，它在每个帧处于活动状态时被调用。 扩展类必须覆盖将在每个帧中调用的方法handle(long) 。 方法start()和stop()允许启动和停止定时器。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      AnimationTimer​()
      创建一个新的计时器。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void handle​(long now)
      这个方法需要被扩展类覆盖。
      void start​()
      启动 AnimationTimer 。
      void stop​()
      停止 AnimationTimer 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AnimationTimer

        public AnimationTimer​()
        创建一个新的计时器。

    • 方法详细信息

      • handle

        public abstract void handle​(long now)
        这个方法需要被扩展类覆盖。 它将在AnimationTimer活动时在每个帧中被调用。
        参数
        now - 以now为单位给出的当前帧的时间戳。 对于在一帧期间调用的所有AnimationTimers该值将是相同的。

      • start

        public void start​()
        开始AnimationTimer 。 一旦启动， handle(long)这种方法AnimationTimer将在每帧中调用。 AnimationTimer可以通过拨打stop()停止。

      • stop

        public void stop​()
        停止AnimationTimer 。 可以通过拨打start()再次激活。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FadeTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class FadeTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.FadeTransition

  • public final class FadeTransition
extends Transition
    这个Transition创建了一个跨越其duration的褪色效果动画。 这是通过更新完成opacity的可变node在固定时间间隔。

    它从fromValue开始，如果提供的其他使用node的opacity值。

    它停止在toValue值，如果提供其他，它将使用起始值加byValue 。

    如果指定了toValue和byValue则toValue优先。

    代码段示例：

       import javafx.scene.shape.*; import javafx.animation.*; ... Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); rect.setFill(Color.VIOLET); FadeTransition ft = new FadeTransition(Duration.millis(3000), rect); ft.setFromValue(1.0); ft.setToValue(0.3); ft.setCycleCount(4); ft.setAutoReverse(true); ft.play(); ...
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty byValue
      指定从这个 FadeTransition开始的递增的停止不透明度值。
      ObjectProperty<Duration> duration
      这个 FadeTransition的持续时间。
      DoubleProperty fromValue
      指定此 FadeTransition的起始不透明度值。
      ObjectProperty<Node> node
      这个 Transition的目标节点。
      DoubleProperty toValue
      指定此 FadeTransition的停止不透明度值。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      FadeTransition​()
      构造函数为 FadeTransition
      FadeTransition​(Duration duration)
      构造函数为 FadeTransition
      FadeTransition​(Duration duration, Node node)
      构造函数为 FadeTransition

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty byValueProperty​()
      指定从这个 FadeTransition开始的递增停止不透明度值。
      ObjectProperty<Duration> durationProperty​()
      这个 FadeTransition的持续时间。
      DoubleProperty fromValueProperty​()
      指定此 FadeTransition的起始不透明度值。
      double getByValue​()
      通过值获取属性的值。
      Duration getDuration​()
      获取属性持续时间的值。
      double getFromValue​()
      获取属性fromValue的值。
      Node getNode​()
      获取属性节点的值。
      double getToValue​()
      获取属性值到值。
      protected void interpolate​(double frac)
      该方法 interpolate()必须通过的实现来提供 Transition 。
      ObjectProperty<Node> nodeProperty​()
      这个 Transition的目标节点。
      void setByValue​(double value)
      通过值设置属性的值。
      void setDuration​(Duration value)
      设置属性持续时间的值。
      void setFromValue​(double value)
      设置属性fromValue的值。
      void setNode​(Node value)
      设置属性节点的值。
      void setToValue​(double value)
      将属性的值设置为Value。
      DoubleProperty toValueProperty​()
      指定此 FadeTransition的停止不透明度值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, getParentTargetNode, interpolatorProperty, setInterpolator

    • Property Detail

      • node

        public final ObjectProperty<Node> nodeProperty
        这个Transition的目标节点。

        这是不可能改变目标node正在运行的FadeTransition 。 如果值node改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • duration

        public final ObjectProperty<Duration> durationProperty
        这个FadeTransition的持续时间。

        无法更改duration的FadeTransition 。 如果值duration改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层的操作系统，一般会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • fromValue

        public final DoubleProperty fromValueProperty
        指定此FadeTransition的起始不透明度值。

        无法更改fromValue的一个正在运行的FadeTransition 。 如果值fromValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromValue() ， setFromValue(double)

      • toValue

        public final DoubleProperty toValueProperty
        指定此FadeTransition的停止不透明度值。

        不可能更改toValue的一个正在运行的FadeTransition 。 如果toValue的值更改为运行中的FadeTransition ，则必须停止动画并重新启动以获取新值。

        Default value:
        Double.NaN
        另请参见：
        getToValue() ， setToValue(double)

      • byValue

        public final DoubleProperty byValueProperty
        指定从这个FadeTransition开始的递增停止不透明度值。

        无法更改byValue的一个正在运行的FadeTransition 。 如果值byValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByValue() ， setByValue(double)

    • 构造方法详细信息

      • FadeTransition

        public FadeTransition​(Duration duration,
                      Node node)
        构造函数为 FadeTransition
        参数
        duration - 持续时间 FadeTransition
        node - node哪些不透明度将被动画

      • FadeTransition

        public FadeTransition​(Duration duration)
        构造函数为 FadeTransition
        参数
        duration - 持续时间 FadeTransition

      • FadeTransition

        public FadeTransition​()
        构造函数为 FadeTransition

    • 方法详细信息

      • setNode

        public final void setNode​(Node value)
        设置属性节点的值。
        Property description:
        这个Transition的目标节点。

        无法更改目标node运行的FadeTransition 。 如果node的值更改为FadeTransition ，则必须停止动画并重新启动以获取新值。

      • getNode

        public final Node getNode​()
        获取属性节点的值。
        Property description:
        该目标节点为Transition 。

        这是不可能改变目标node正在运行的FadeTransition 。 如果值node改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

      • nodeProperty

        public final ObjectProperty<Node> nodeProperty​()
        这个Transition的目标节点。

        这是不可能改变目标node正在运行的FadeTransition 。 如果值node改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • setDuration

        public final void setDuration​(Duration value)
        设置属性持续时间的值。
        Property description:
        这个FadeTransition的持续时间。

        不可能更改duration的一个正在运行的FadeTransition 。 如果值duration改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层操作系统，通常会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • getDuration

        public final Duration getDuration​()
        获取属性持续时间的值。
        Property description:
        持续时间FadeTransition 。

        无法更改duration的FadeTransition 。 如果值duration改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层的操作系统，一般会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • durationProperty

        public final ObjectProperty<Duration> durationProperty​()
        这个FadeTransition的持续时间。

        无法更改duration的FadeTransition 。 如果值duration改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层的操作系统，一般会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • setFromValue

        public final void setFromValue​(double value)
        设置属性fromValue的值。
        Property description:
        指定此FadeTransition的起始不透明度值。

        无法更改fromValue的一个正在运行的FadeTransition 。 如果值fromValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getFromValue

        public final double getFromValue​()
        获取属性fromValue的值。
        Property description:
        指定此FadeTransition的起始不透明度值。

        无法更改fromValue的一个正在运行的FadeTransition 。 如果值fromValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • fromValueProperty

        public final DoubleProperty fromValueProperty​()
        指定此FadeTransition的起始不透明度值。

        不可能更改fromValue的一个正在运行的FadeTransition 。 如果值fromValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromValue() ， setFromValue(double)

      • setToValue

        public final void setToValue​(double value)
        将属性的值设置为Value。
        Property description:
        指定此FadeTransition的停止不透明度值。

        不可能更改toValue的一个正在运行的FadeTransition 。 如果值toValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getToValue

        public final double getToValue​()
        获取属性值到值。
        Property description:
        指定此FadeTransition的停止不透明度值。

        无法更改toValue的FadeTransition 。 如果值toValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • toValueProperty

        public final DoubleProperty toValueProperty​()
        指定此FadeTransition的停止不透明度值。

        不可能更改toValue的一个正在运行的FadeTransition 。 如果值toValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToValue() ， setToValue(double)

      • setByValue

        public final void setByValue​(double value)
        通过值设置属性的值。
        Property description:
        指定从这个FadeTransition开始的递增停止不透明度值。

        无法更改byValue的一个正在运行的FadeTransition 。 如果值byValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

      • getByValue

        public final double getByValue​()
        通过值获取属性的值。
        Property description:
        指定从这个FadeTransition开始的递增停止不透明度值。

        不可能更改byValue的一个正在运行的FadeTransition 。 如果byValue的值更改为FadeTransition ，则必须停止动画并重新启动以获取新值。

      • byValueProperty

        public final DoubleProperty byValueProperty​()
        指定从这个FadeTransition开始的递增停止不透明度值。

        无法更改byValue的一个正在运行的FadeTransition 。 如果值byValue改变正在运行的FadeTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByValue() ， setByValue(double)

      • interpolate

        protected void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如如果interpolator是Interpolator.LINEAR ，则分数会增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FillTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class FillTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.FillTransition

  • public final class FillTransition
extends Transition
    此Transition创建一个动画，可以更改duration中的形状填充。 这是通过更新完成fill的可变shape定期。

    它从fromValue开始，如果提供的其他使用shape的fill值。 （在这种情况下， stroke值必须是Color ）。

    它停在toValue价值。

    代码段示例：

       import javafx.scene.shape.*; import javafx.animation.*; ... Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); FillTransition ft = new FillTransition(Duration.millis(3000), rect, Color.RED, Color.BLUE); ft.setCycleCount(4); ft.setAutoReverse(true); ft.play(); ...
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Duration> duration
      这个 FillTransition的持续时间。
      ObjectProperty<Color> fromValue
      指定此 FillTransition的起始颜色值。
      ObjectProperty<Shape> shape
      目标形状为 FillTransition 。
      ObjectProperty<Color> toValue
      指定此 FillTransition的停止颜色值。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      FillTransition​()
      构造函数为 FillTransition
      FillTransition​(Duration duration)
      构造函数为 FillTransition
      FillTransition​(Duration duration, Color fromValue, Color toValue)
      构造函数为 FillTransition
      FillTransition​(Duration duration, Shape shape)
      构造函数为 FillTransition
      FillTransition​(Duration duration, Shape shape, Color fromValue, Color toValue)
      构造函数为 FillTransition

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Duration> durationProperty​()
      这个 FillTransition的持续时间。
      ObjectProperty<Color> fromValueProperty​()
      指定此 FillTransition的起始颜色值。
      Duration getDuration​()
      获取属性持续时间的值。
      Color getFromValue​()
      获取属性fromValue的值。
      Shape getShape​()
      获取属性形状的值。
      Color getToValue​()
      获取属性值到值。
      protected void interpolate​(double frac)
      方法 interpolate()必须由 Transition的实现来提供。
      void setDuration​(Duration value)
      设置属性持续时间的值。
      void setFromValue​(Color value)
      设置属性fromValue的值。
      void setShape​(Shape value)
      设置属性形状的值。
      void setToValue​(Color value)
      将属性的值设置为Value。
      ObjectProperty<Shape> shapeProperty​()
      目标形状为 FillTransition 。
      ObjectProperty<Color> toValueProperty​()
      指定此 FillTransition的停止颜色值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, getParentTargetNode, interpolatorProperty, setInterpolator

    • Property Detail

      • shape

        public final ObjectProperty<Shape> shapeProperty
        目标形状为FillTransition 。

        这是不可能改变目标shape正在运行的FillTransition 。 如果值shape改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getShape() ， setShape(Shape)

      • duration

        public final ObjectProperty<Duration> durationProperty
        这个FillTransition的持续时间。

        无法更改duration的一个正在运行的FillTransition 。 如果值duration改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层的操作系统，一般会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • fromValue

        public final ObjectProperty<Color> fromValueProperty
        指定此FillTransition的起始颜色值。

        无法更改fromValue的正在运行的FillTransition 。 如果值fromValue改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null
        另请参见：
        getFromValue() ， setFromValue(Color)

      • toValue

        public final ObjectProperty<Color> toValueProperty
        指定此FillTransition的停止颜色值。

        无法更改toValue的FillTransition 。 如果值toValue改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null
        另请参见：
        getToValue() ， setToValue(Color)

    • 构造方法详细信息

      • FillTransition

        public FillTransition​(Duration duration,
                      Shape shape,
                      Color fromValue,
                      Color toValue)
        构造函数为 FillTransition
        参数
        duration - 持续时间 FillTransition
        shape - shape哪个填充将被动画
        fromValue - 颜色动画的起始值
        toValue - 颜色动画的最终值

      • FillTransition

        public FillTransition​(Duration duration,
                      Color fromValue,
                      Color toValue)
        构造函数为 FillTransition
        参数
        duration - 持续时间 FillTransition
        fromValue - 颜色动画的起始值
        toValue - 颜色动画的结束值

      • FillTransition

        public FillTransition​(Duration duration,
                      Shape shape)
        构造函数为 FillTransition
        参数
        duration - 持续时间 FillTransition
        shape - shape哪个填充将被动画

      • FillTransition

        public FillTransition​(Duration duration)
        构造函数为 FillTransition
        参数
        duration - 持续时间 FadeTransition

      • FillTransition

        public FillTransition​()
        构造函数为 FillTransition

    • 方法详细信息

      • setShape

        public final void setShape​(Shape value)
        设置属性形状的值。
        Property description:
        目标形状为FillTransition 。

        这是不可能改变目标shape正在运行的FillTransition 。 如果值shape改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

      • getShape

        public final Shape getShape​()
        获取属性形状的值。
        Property description:
        目标形状为FillTransition 。

        这是不可能改变目标shape正在运行的FillTransition 。 如果值shape改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

      • shapeProperty

        public final ObjectProperty<Shape> shapeProperty​()
        目标形状为FillTransition 。

        这是不可能改变目标shape正在运行的FillTransition 。 如果shape的值更改为运行中的FillTransition ，则必须停止动画并重新启动以获取新值。

        另请参见：
        getShape() ， setShape(Shape)

      • setDuration

        public final void setDuration​(Duration value)
        设置属性持续时间的值。
        Property description:
        这个FillTransition的持续时间。

        无法更改duration的FillTransition 。 如果值duration改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层的操作系统，一般会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • getDuration

        public final Duration getDuration​()
        获取属性持续时间的值。
        Property description:
        这个FillTransition的持续时间。

        不可能更改duration的一个正在运行的FillTransition 。 如果值duration改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层操作系统，通常会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • durationProperty

        public final ObjectProperty<Duration> durationProperty​()
        这个FillTransition的持续时间。

        不可能更改duration的一个正在运行的FillTransition 。 如果值duration改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层操作系统，通常会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • setFromValue

        public final void setFromValue​(Color value)
        设置属性fromValue的值。
        Property description:
        指定此FillTransition的起始颜色值。

        不可能更改fromValue运行的FillTransition 。 如果fromValue的值更改为运行中的FillTransition ，则必须停止动画并重新启动以获取新值。

        Default value:
        null

      • getFromValue

        public final Color getFromValue​()
        获取属性fromValue的值。
        Property description:
        指定此FillTransition的起始颜色值。

        无法更改fromValue的正在运行的FillTransition 。 如果fromValue的值更改为正在运行的FillTransition ，则动画必须停止并重新开始以获取新值。

        Default value:
        null

      • fromValueProperty

        public final ObjectProperty<Color> fromValueProperty​()
        指定此FillTransition的起始颜色值。

        无法更改fromValue的FillTransition 。 如果fromValue的值更改为运行中的FillTransition ，则动画必须停止并再次启动以接收新值。

        Default value:
        null
        另请参见：
        getFromValue() ， setFromValue(Color)

      • setToValue

        public final void setToValue​(Color value)
        将属性的值设置为Value。
        Property description:
        指定此FillTransition的停止颜色值。

        无法更改toValue的正在运行的FillTransition 。 如果值toValue改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null

      • getToValue

        public final Color getToValue​()
        获取属性值到值。
        Property description:
        指定此FillTransition的停止颜色值。

        不可能更改toValue的一个正在运行的FillTransition 。 如果值toValue改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null

      • toValueProperty

        public final ObjectProperty<Color> toValueProperty​()
        指定此FillTransition的停止颜色值。

        无法更改toValue的一个正在运行的FillTransition 。 如果值toValue改变正在运行的FillTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null
        另请参见：
        getToValue() ， setToValue(Color)

      • interpolate

        protected void interpolate​(double frac)
        该方法interpolate()必须通过的实现来提供Transition 。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如，如果interpolator为Interpolator.LINEAR ，则分数将增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Interpolatable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Interface Interpolatable<T>

  • 所有已知实现类：
    Color
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Interpolatable<T>
    可以插值的值。 它定义单个interpolate(Object, double)方法，它返回给定分数的内插值。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      T interpolate​(T endValue, double t)
      该函数计算 0.0和 1.0之间的分数 t的内插值。

    • 方法详细信息

      • interpolate

        T interpolate​(T endValue,
              double t)
        该函数计算0.0与1.0之间的分数t的内插值。 当t = 1.0时，返回endVal 。
        参数
        endValue - 目标值
        t - 0.0和 1.0之间的分数
        结果
        内插值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Interpolator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class Interpolator

  • java.lang.Object
    • javafx.animation.Interpolator

  • public abstract class Interpolator
extends Object
    抽象类定义了几个interpolate方法，用于计算内插值。 提供了这个类的各种内置实现。 应用程序可以选择实现自己的Interpolator来获得自定义插补行为。

    必须根据“ curve() ”定义自定义Interpolator 。

    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Interpolator DISCRETE
      内置插值器，提供离散时间插值。
      static Interpolator EASE_BOTH
      内置插件器实例，提供简单的输入/输出行为。
      static Interpolator EASE_IN
      内置插件器实例，提供行为方便。
      static Interpolator EASE_OUT
      内置interpolator实例，提供轻松的行为。
      static Interpolator LINEAR
      内置插值器，提供线性时间插值。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Interpolator​()
      构造函数为 Interpolator 。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract double curve​(double t)
      从[0.0..1.0]映射到本身。
      boolean interpolate​(boolean startValue, boolean endValue, double fraction)
      这个方法有两个 boolean与沿值 fraction之间 0.0和 1.0并返回插补值。
      double interpolate​(double startValue, double endValue, double fraction)
      这个方法有两个 double与沿值 fraction之间 0.0和 1.0并返回插补值。
      int interpolate​(int startValue, int endValue, double fraction)
      这个方法有两个 int与沿值 fraction之间 0.0和 1.0并返回插补值。
      long interpolate​(long startValue, long endValue, double fraction)
      这个方法有两个 int与沿值 fraction之间 0.0和 1.0并返回插补值。
      Object interpolate​(Object startValue, Object endValue, double fraction)
      这个方法有两个 Objects与沿 fraction之间 0.0和 1.0并返回插补值。
      static Interpolator SPLINE​(double x1, double y1, double x2, double y2)
      创建一个 Interpolator ，其 curve()使用由（定义样条控制点状 x1 ， y1 ）和（ x2 ， y2 ）。
      static Interpolator TANGENT​(Duration t, double v)
      创建切线内插器，切线和切线相同。
      static Interpolator TANGENT​(Duration t1, double v1, Duration t2, double v2)
      创建切线插值器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DISCRETE

        public static final Interpolator DISCRETE
        内置插值器，提供离散时间插值。 的返回值interpolate()是endValue仅当输入fraction是1.0，和startValue否则。

      • LINEAR

        public static final Interpolator LINEAR
        内置插值器，提供线性时间插值。 interpolate()的回报值为startValue +（ endValue - startValue ）* fraction 。

      • EASE_BOTH

        public static final Interpolator EASE_BOTH
        内置插件器实例，提供简单的输入/输出行为。

        一个容易的插件将使一个动画开始缓慢，然后加速和再次减速到最后，一切顺利的方式。

        该实现使用SMIL 3.0中定义的缓和算法，加速和减速因子分别为0.2。

      • EASE_IN

        public static final Interpolator EASE_IN
        内置插件器实例，提供行为方便。

        一个易于插入的插件将使动画开始缓慢，然后平滑加速。

        该实现使用SMIL 3.0中定义的缓动算法，加速因子为0.2。

      • EASE_OUT

        public static final Interpolator EASE_OUT
        内置interpolator实例，提供轻松的行为。

        一个易于使用的内插器将使动画慢慢向下缓慢向前。

        实现使用SMIL 3.0中定义的减速算法，减速系数为0.2。

    • 构造方法详细信息

      • Interpolator

        protected Interpolator​()
        构造函数为 Interpolator 。

    • 方法详细信息

      • SPLINE

        public static Interpolator SPLINE​(double x1,
                                  double y1,
                                  double x2,
                                  double y2)
        创建一个Interpolator ，其curve()使用由（定义样条控制点状x1 ， y1 ）和（ x2 ， y2 ）。 样条曲线的锚点被隐含地定义为（ 0.0 ， 0.0 ）和（ 1.0 ， 1.0 ）。
        参数
        x1 - 第一个控制点的x坐标
        y1 - 第一个控制点的y坐标
        x2 - 第二个控制点的x坐标
        y2 - 第二个控制点的y坐标
        结果
        样条插值器

      • TANGENT

        public static Interpolator TANGENT​(Duration t1,
                                   double v1,
                                   Duration t2,
                                   double v2)
        创建切线插值器。 切线插补器允许通过定义靠近关键帧的切线来非常精确地定义动画曲线的行为。 切线插补器定义关键帧左侧和右侧的行为，因此仅在Timeline中有用。 如果在具有不同插值器的KeyFrame之后的KeyFrame中使用，则将其视为与该KeyFrame中的正切相等于KeyFrame中的值。

        参数定义切线（关键帧之前）和切线（关键帧之后）的动画曲线的切线。 每个切线用一对指定，到关键帧的距离和此刻的切线值。

        插值然后遵循贝塞尔曲线，其中2个控制点由指定的切线定义，并位于第二个键盘框之前或第一个键盘框之后的持续时间的1/3。 见上图。

        参数
        t1 - 相对于KeyFrame的正切值的delta时间
        v1 - 正切值
        t2 - 相对于KeyFrame的外切的delta时间
        v2 - 外切值的值
        结果
        新的切线插值器

      • TANGENT

        public static Interpolator TANGENT​(Duration t,
                                   double v)
        创建切线内插器，切线和切线相同。 这对于Timeline的第一个和最后一个关键帧特别有用，因为对于这些关键帧，仅使用一个切线。
        参数
        t - 切线的delta时间
        v - 切线的值
        结果
        新的切线插补器
        另请参见：
        TANGENT(Duration, double, Duration, double)

      • interpolate

        public Object interpolate​(Object startValue,
                          Object endValue,
                          double fraction)
        这个方法有两个Objects与沿fraction之间0.0和1.0并返回插补值。

        如果Objects实现Number ，则它们的值被内插。 如果startValue器具Interpolatable中定义的计算interpolate()被使用。 如果这两个条件都满足，离散插值的方法，即endValue返回当且仅当fraction为1.0 ，否则startValue返回。

        在计算内插值之前，根据curve()中定义的函数改变分数。

        参数
        startValue - 起始值
        endValue - 终值
        fraction - 介于0.0和1.0之间的值
        结果
        内插值

      • interpolate

        public boolean interpolate​(boolean startValue,
                           boolean endValue,
                           double fraction)
        这个方法有两个boolean与沿值fraction之间0.0和1.0并返回插补值。

        在计算内插值之前，根据curve()中定义的函数改变分数。

        参数
        startValue - 第一个数据点
        endValue - 第二个数据点
        fraction - 分数在 [0.0...1.0]
        结果
        内插值

      • interpolate

        public double interpolate​(double startValue,
                          double endValue,
                          double fraction)
        这个方法有两个double与沿值fraction之间0.0和1.0并返回插补值。

        在计算内插值之前，根据curve()中定义的函数改变分数。

        参数
        startValue - 第一个数据点
        endValue - 第二个数据点
        fraction - 分数在 [0.0...1.0]
        结果
        内插值

      • interpolate

        public int interpolate​(int startValue,
                       int endValue,
                       double fraction)
        这个方法有两个int与沿值fraction之间0.0和1.0并返回插补值。

        在计算内插值之前，根据curve()中定义的函数改变分数。

        参数
        startValue - 第一个数据点
        endValue - 第二个数据点
        fraction - 分数在 [0.0...1.0]
        结果
        内插值

      • interpolate

        public long interpolate​(long startValue,
                        long endValue,
                        double fraction)
        此方法需要两个int值， fraction之间的0.0和1.0之间返回内插值。

        在计算内插值之前，根据curve()中定义的函数改变分数。

        参数
        startValue - 第一个数据点
        endValue - 第二个数据点
        fraction - 分数在 [0.0...1.0]
        结果
        内插值

      • curve

        protected abstract double curve​(double t)
        从[0.0..1.0]映射到本身。
        参数
        t - 时间，但归一化到范围[0.0..1.0]，其中0.0是当前间隔的开始，而1.0是当前间隔的结束。 通常是单调递增的函数。
        结果
        曲线值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javafx.animation (Java SE 9 & JDK 9 )

javafx.animation

Interfaces

  • Interpolatable

Classes

  • Animation
  • AnimationTimer
  • FadeTransition
  • FillTransition
  • Interpolator
  • KeyFrame
  • KeyValue
  • ParallelTransition
  • PathTransition
  • PauseTransition
  • RotateTransition
  • ScaleTransition
  • SequentialTransition
  • StrokeTransition
  • Timeline
  • Transition
  • TranslateTransition

Enums

  • Animation.Status
  • PathTransition.OrientationType


javafx.animation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.animation

提供一组类，便于使用基于过渡的动画。

它提供了一个简单的框架，将动画结合到内部Timeline 。 它还提供高级构造来构成多个动画的效果。

  • 接口摘要
    接口 描述
    Interpolatable<T>
    可以插值的值。
  • 类摘要
    Class 描述
    Animation
    Animation提供了JavaFX运行时使用的所有动画的核心功能。
    AnimationTimer
    AnimationTimer类允许创建一个定时器，它在每个帧处于活动状态时被调用。
    FadeTransition
    这个 Transition创建了一个跨越其 duration的褪色效果动画。
    FillTransition
    这个 Transition创建一个动画，可以改变 duration的形状填充。
    Interpolator
    抽象类定义了几个 interpolate方法，用于计算内插值。
    KeyFrame
    在指定的时间点定义一组在Timeline内插的变量的目标值 。
    KeyValue
    定义要在动画中的特定间隔内插的键值。
    ParallelTransition
    这Transition剧目Animations并行。
    PathTransition
    这个 Transition创建了一个跨越其 PathTransition.duration的路径动画。
    PauseTransition
    这 Transition在其 PauseTransition.duration的末尾执行一个 Animation.onFinished 。
    RotateTransition
    这个 Transition创建一个旋转动画，跨越其 duration 。
    ScaleTransition
    这个 Transition创建了一个尺度动画，涵盖其 ScaleTransition.duration 。
    SequentialTransition
    这Transition剧目Animations顺序排列。
    StrokeTransition
    这个 Transition创建一个动画，可以改变 duration形状的笔触颜色。
    Timeline
    A Timeline可用于定义任何WritableValue的自由形式动画，例如，全部为JavaFX Properties 。
    Transition
    一个抽象类，其中包含所有基于Transition的动画所需的基本功能，如PathTransition和RotateTransition 。
    TranslateTransition
    这个 Transition创建了一个跨越其 TranslateTransition.duration的移动/翻译动画。
  • 枚举摘要
    Enum 描述
    Animation.Status
    可能状态为 status 。
    PathTransition.OrientationType
    指定 node沿 path的直立方向。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.animation Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.animation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Timeline
      • javafx.animation.Transition
        • javafx.animation.FadeTransition
        • javafx.animation.FillTransition
        • javafx.animation.ParallelTransition
        • javafx.animation.PathTransition
        • javafx.animation.PauseTransition
        • javafx.animation.RotateTransition
        • javafx.animation.ScaleTransition
        • javafx.animation.SequentialTransition
        • javafx.animation.StrokeTransition
        • javafx.animation.TranslateTransition
    • javafx.animation.AnimationTimer
    • javafx.animation.Interpolator
    • javafx.animation.KeyFrame
    • javafx.animation.KeyValue

Interface Hierarchy

  • javafx.animation.Interpolatable<T>

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.animation.Animation.Status
      • javafx.animation.PathTransition.OrientationType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


KeyFrame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class KeyFrame

  • java.lang.Object
    • javafx.animation.KeyFrame

  • public final class KeyFrame
extends Object
    在指定的时间点定义一组沿Timeline内插的变量的目标值 。

    开发者通过提供目标值来控制连续关键帧之间的间隔的一组变量的插值和与每个变量相关联的Interpolator 。 这些变量被内插，使得它们将在指定的时间达到其目标值。 一个onFinished函数对每个调用KeyFrame如果提供一个。 A KeyFrame可以选择有一个name ，这将导致一个自动添加到Timeline 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Timeline ， KeyValue ， Interpolator

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyFrame​(Duration time, String name, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      String getName​()
      返回这个 name的 KeyFrame 。
      EventHandler<ActionEvent> getOnFinished​()
      返回 onFinished此事件处理 KeyFrame 。
      Duration getTime​()
      返回此 KeyFrame的时间偏移量。
      Set<KeyValue> getValues​()
      返回一个不可变Set的KeyValue实例。
      int hashCode​()
      返回此 KeyFrame对象的哈希码。
      String toString​()
      返回此 KeyFrame对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • KeyFrame

        public KeyFrame​(Duration time,
                String name,
                EventHandler<ActionEvent> onFinished,
                Collection<KeyValue> values)
        构造函数KeyFrame

        如果在KeyValue传递的是null或重复，则将被忽略。

        参数
        time - time
        name - name
        onFinished - onFinished
        values - 一个ObservableList的KeyValue实例
        异常
        NullPointerException - 如果 time为空
        IllegalArgumentException - 如果 time无效（见 time ）

      • KeyFrame

        public KeyFrame​(Duration time,
                String name,
                EventHandler<ActionEvent> onFinished,
                KeyValue... values)
        构造函数KeyFrame

        如果在KeyValue传递的是null或重复，则将被忽略。

        参数
        time - time
        name - name
        onFinished - onFinished
        values - KeyValue实例
        异常
        NullPointerException - 如果 time为空
        IllegalArgumentException - 如果 time无效（见 time ）

      • KeyFrame

        public KeyFrame​(Duration time,
                EventHandler<ActionEvent> onFinished,
                KeyValue... values)
        构造函数 KeyFrame
        参数
        time - time
        onFinished - onFinished
        values - KeyValue实例
        异常
        NullPointerException - 如果 time为空
        IllegalArgumentException - 如果 time无效（见 time ）

      • KeyFrame

        public KeyFrame​(Duration time,
                String name,
                KeyValue... values)
        构造函数 KeyFrame
        参数
        time - time
        name - name
        values - KeyValue实例
        异常
        NullPointerException - 如果 time为空
        IllegalArgumentException - 如果 time无效（见 time ）

      • KeyFrame

        public KeyFrame​(Duration time,
                KeyValue... values)
        构造函数 KeyFrame
        参数
        time - time
        values - KeyValue实例
        异常
        NullPointerException - 如果 time为空
        IllegalArgumentException - 如果 time无效（见 time ）

    • 方法详细信息

      • getTime

        public Duration getTime​()
        返回此KeyFrame的时间偏移量。 返回Duration定义了一个时间的单个周期内的偏移Timeline在该KeyValues将被设置，并在该onFinished函数的变量将被调用。

        所述time一个的KeyFrame必须是大于或等于Duration.ZERO ，它不能是Duration.UNKNOWN 。 注意： time的单位是毫秒，粒度取决于底层的操作系统，一般会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。

        结果
        时间偏移

      • getValues

        public Set<KeyValue> getValues​()
        返回Set个不可变的Set实例。 A KeyValue定义了一个目标和在该KeyFrame的指定时间内插的KeyFrame 。
        结果
        一个不可变的Set的KeyValue实例

      • getOnFinished

        public EventHandler<ActionEvent> getOnFinished​()
        返回onFinished此事件处理KeyFrame 。 onFinished事件处理程序是一个函数，当循环的经过时间通过此KeyFrame的指定时间时KeyFrame 。 如果经过时间经过指定值，则onFinished函数变量将被调用，即使它不会完全等于时间值。
        结果
        onFinished事件处理程序

      • getName

        public String getName​()
        返回name这个KeyFrame 。 如果将KeyFrame添加到Timeline中 ，则将自动添加name和time的KeyFrame 。 如果KeyFrame被删除，那么该点也将被删除。
        结果
        name

      • toString

        public String toString​()
        返回此 KeyFrame对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        字符串表示

      • hashCode

        public int hashCode​()
        返回此 KeyFrame对象的哈希码。
        重写：
        hashCode在 Object
        结果
        哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。 两个KeyFrames被认为是平等的，如果他们的time ， onFinished ，并values相等。
        重写：
        equals在 Object
        参数
        obj - 用于比较的参考对象。
        结果
        true如果这与obj相同，否则为 false
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class KeyValue

  • java.lang.Object
    • javafx.animation.KeyValue

  • public final class KeyValue
extends Object
    定义要在动画中的特定间隔内插的键值。 A KeyFrame ，其定义了时间轴上的特定点，可以容纳多个KeyValues 。 KeyValue是一个不可变的课。

    A KeyValue由目标定义，目标是WritableValue的实现，结束值和Interpolator 。

    大多数内插器定义了两个KeyFrames之间的内插。 （唯一的例外是相切内插。）的KeyValue的第二KeyFrame （正向）指定的时间间隔中使用的内插器。

    切线插补器定义KeyFrame左侧和右侧的KeyFrame （见Interpolator.TANGENT ）。

    默认情况下， 间隔中使用Interpolator.LINEAR 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Timeline ， KeyFrame ， Interpolator

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyValue​(WritableValue<T> target, T endValue)
      创建一个 KeyValue ，使用 Interpolator.LINEAR 。
      KeyValue​(WritableValue<T> target, T endValue, Interpolator interpolator)
      创建一个 KeyValue 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      Object getEndValue​()
      返回此 KeyValue的结束值
      Interpolator getInterpolator​()
      Interpolator用于计算沿特定间隔的键值。
      WritableValue<?> getTarget​()
      返回此 KeyValue的目标
      int hashCode​()
      返回此 KeyValue对象的哈希码。
      String toString​()
      返回此 KeyValue对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • KeyValue

        public KeyValue​(WritableValue<T> target,
                T endValue,
                Interpolator interpolator)
        创建一个 KeyValue 。
        参数类型
        T -该类型 KeyValue
        参数
        target - 目标
        endValue - 结束值
        interpolator - Interpolator
        异常
        NullPointerException - 如果是 target或 interpolator是 null

      • KeyValue

        public KeyValue​(WritableValue<T> target,
                T endValue)
        创建一个 KeyValue ，使用 Interpolator.LINEAR 。
        参数类型
        T -该类型 KeyValue
        参数
        target - 目标
        endValue - 结束值
        异常
        NullPointerException - 如果是 target或 interpolator是 null

    • 方法详细信息

      • getTarget

        public WritableValue<?> getTarget​()
        返回此 KeyValue的目标
        结果
        目标

      • getEndValue

        public Object getEndValue​()
        返回此 KeyValue的结束值
        结果
        最终值

      • getInterpolator

        public Interpolator getInterpolator​()
        Interpolator用于计算特定间隔的键值。 默认情况下，使用Interpolator.LINEAR 。
        结果
        用于沿特定间隔计算键值的插值器

      • toString

        public String toString​()
        返回此 KeyValue对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        字符串表示

      • hashCode

        public int hashCode​()
        返回此 KeyValue对象的哈希码。
        重写：
        hashCode在 Object
        结果
        哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。 两个KeyValues被认为是平等的，如果他们的target ， endValue ，并interpolator相等。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ParallelTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class ParallelTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.ParallelTransition

  • public final class ParallelTransition
extends Transition
    这Transition剧目Animations并行。

    这个Transition孩子继承了node ，如果他们的node属性没有指定。

    代码段示例：

       Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); rect.setFill(Color.VIOLET); final Duration SEC_2 = Duration.millis(2000); final Duration SEC_3 = Duration.millis(3000); FadeTransition ft = new FadeTransition(SEC_3); ft.setFromValue(1.0f); ft.setToValue(0.3f); ft.setCycleCount(2f); ft.setAutoReverse(true); TranslateTransition tt = new TranslateTransition(SEC_2); tt.setFromX(-100f); tt.setToX(100f); tt.setCycleCount(2f); tt.setAutoReverse(true); RotateTransition rt = new RotateTransition(SEC_3); rt.setByAngle(180f); rt.setCycleCount(4f); rt.setAutoReverse(true); ScaleTransition st = new ScaleTransition(SEC_2); st.setByX(1.5f); st.setByY(1.5f); st.setCycleCount(2f); st.setAutoReverse(true); ParallelTransition pt = new ParallelTransition(rect, ft, tt, rt, st); pt.play();
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Node> node
      这个Node是在所有的小孩Transitions中使用的 ，没有定义一个目标Node本身。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ParallelTransition​()
      构造函数为 ParallelTransition 。
      ParallelTransition​(Animation... children)
      构造函数为 ParallelTransition 。
      ParallelTransition​(Node node)
      构造函数为 ParallelTransition 。
      ParallelTransition​(Node node, Animation... children)
      构造函数为 ParallelTransition 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<Animation> getChildren​()
      将按顺序播放Animations的列表。
      Node getNode​()
      获取属性节点的值。
      protected Node getParentTargetNode​()
      返回此Transition的动画的目标Transition 。
      protected void interpolate​(double frac)
      方法 interpolate()必须由 Transition的实现来提供。
      ObjectProperty<Node> nodeProperty​()
      这个Node用于所有的孩子Transitions ，它们不定义目标Node本身。
      void setNode​(Node value)
      设置属性节点的值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, interpolatorProperty, setInterpolator

    • Property Detail

      • node

        public final ObjectProperty<Node> nodeProperty
        这个Node用于所有的小孩Transitions ，它们不定义一个目标Node本身。 如果一个Transitions应该应用到一个Node这可以使用。

        这是不可能改变目标node正在运行的Transition 。 如果值node改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

    • 构造方法详细信息

      • ParallelTransition

        public ParallelTransition​(Node node,
                          Animation... children)
        构造函数为 ParallelTransition 。
        参数
        node - 目标Node将用于没有Node指定自己的小孩Transitions
        children - 该Animations的这个ParallelTransition

      • ParallelTransition

        public ParallelTransition​(Animation... children)
        构造函数为 ParallelTransition 。
        参数
        children -孩子Animations如此ParallelTransition

      • ParallelTransition

        public ParallelTransition​(Node node)
        构造函数为 ParallelTransition 。
        参数
        node - 目标Node将用于没有Node指定自己的小孩Transitions

      • ParallelTransition

        public ParallelTransition​()
        构造函数为 ParallelTransition 。

    • 方法详细信息

      • setNode

        public final void setNode​(Node value)
        设置属性节点的值。
        Property description:
        这个Node用于所有的孩子Transitions ，它们没有定义一个目标Node本身。 如果一个Transitions应该应用到一个Node这可以使用。

        这是不可能改变目标node正在运行的Transition 。 如果node的值更改为Transition ，则必须停止动画并重新启动以获取新值。

      • getNode

        public final Node getNode​()
        获取属性节点的值。
        Property description:
        这个Node用于所有的孩子Transitions ，它们不定义目标Node本身。 如果一个Transitions应该应用到一个Node这可以使用。

        无法更改目标node的正在运行的Transition 。 如果值node改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

      • nodeProperty

        public final ObjectProperty<Node> nodeProperty​()
        这个Node用于所有的孩子Transitions ，它们没有定义一个目标Node本身。 如果一个Transitions应该应用到单个Node这可以使用。

        这是不可能改变目标node正在运行的Transition 。 如果值node改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • getChildren

        public final ObservableList<Animation> getChildren​()
        将按顺序播放Animations的列表。

        不可能改变一个正在运行的ParallelTransition的孩子。 如果孩子们为了运行ParallelTransition而改变了，那么动画必须被停止并重新开始以获取新的值。

        结果
        列表Animations

      • getParentTargetNode

        protected Node getParentTargetNode​()
        返回此Transition的动画的目标Transition 。 该方法返回node ，否则返回parent.getTargetNode()否则为null。
        重写：
        getParentTargetNode在 Transition
        结果
        目标 Node

      • interpolate

        protected void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如，如果interpolator是Interpolator.LINEAR ，分数会增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PathTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class PathTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.PathTransition

  • public final class PathTransition
extends Transition
    这个Transition创建了一个跨越其duration的路径动画。 沿着路径的翻译是通过更新translateX和translateY变量来node ，如果orientation以规则间隔设置为OrientationType.ORTHOGONAL_TO_TANGENT ，则rotate变量将被更新。

    动画路径由形状的轮廓定义。

    代码段示例：

       import javafx.scene.shape.*; import javafx.animation.*; ... Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); rect.setFill(Color.VIOLET); Path path = new Path(); path.getElements().add (new MoveTo (0f, 50f)); path.getElements().add (new CubicCurveTo (40f, 10f, 390f, 240f, 1904, 50f)); pathTransition.setDuration(Duration.millis(10000)); pathTransition.setNode(rect); pathTransition.setPath(path); pathTransition.setOrientation(OrientationType.ORTHOGONAL_TO_TANGENT); pathTransition.setCycleCount(4f); pathTransition.setAutoReverse(true); pathTransition.play(); ...
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Duration> duration
      持续时间 Transition 。
      ObjectProperty<Node> node
      该目标节点为 PathTransition 。
      ObjectProperty<PathTransition.OrientationType> orientation
      指定 node沿 path的直立方向。
      ObjectProperty<Shape> path
      大纲节点应该被动画的形状。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  PathTransition.OrientationType
      指定 node沿 path的直立方向。

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      PathTransition​()
      构造函数为 PathTransition 。
      PathTransition​(Duration duration, Shape path)
      构造函数为 PathTransition 。
      PathTransition​(Duration duration, Shape path, Node node)
      构造函数为 PathTransition 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Duration> durationProperty​()
      这个 Transition的持续时间。
      Duration getDuration​()
      获取属性持续时间的值。
      Node getNode​()
      获取属性节点的值。
      PathTransition.OrientationType getOrientation​()
      获取属性方向的值。
      Shape getPath​()
      获取属性路径的值。
      void interpolate​(double frac)
      该方法 interpolate()必须通过的实现来提供 Transition 。
      ObjectProperty<Node> nodeProperty​()
      这个 PathTransition的目标节点。
      ObjectProperty<PathTransition.OrientationType> orientationProperty​()
      指定 node的直立方向 path 。
      ObjectProperty<Shape> pathProperty​()
      大纲节点应该被动画的形状。
      void setDuration​(Duration value)
      设置属性持续时间的值。
      void setNode​(Node value)
      设置属性节点的值。
      void setOrientation​(PathTransition.OrientationType value)
      设置属性方向的值。
      void setPath​(Shape value)
      设置属性路径的值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, getParentTargetNode, interpolatorProperty, setInterpolator

    • Property Detail

      • node

        public final ObjectProperty<Node> nodeProperty
        这个PathTransition的目标节点。

        无法更改目标node的一个正在运行的PathTransition 。 如果node的值更改为运行中的PathTransition ，则动画必须停止并再次启动以接收新值。

        另请参见：
        getNode() ， setNode(Node)

      • duration

        public final ObjectProperty<Duration> durationProperty
        这个Transition的持续时间。

        不可能更改duration的一个正在运行的PathTransition 。 如果值duration改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒，粒度取决于底层的操作系统，一般会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • path

        public final ObjectProperty<Shape> pathProperty
        大纲节点应该被动画的形状。

        这是不可能改变path正在运行的PathTransition 。 如果值path改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        空值
        另请参见：
        getPath() ， setPath(Shape)

      • orientation

        public final ObjectProperty<PathTransition.OrientationType> orientationProperty
        指定node沿path的直立方向。 默认方向设置为PathTransition.OrientationType.NONE 。

        这是不可能改变orientation正在运行的PathTransition 。 如果值orientation改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        没有
        另请参见：
        getOrientation() ， setOrientation(PathTransition.OrientationType)

    • 构造方法详细信息

      • PathTransition

        public PathTransition​(Duration duration,
                      Shape path,
                      Node node)
        构造函数为 PathTransition 。
        参数
        duration - 这个 PathTransition的 PathTransition
        path - 该 path的 PathTransition
        node - node的这个 PathTransition

      • PathTransition

        public PathTransition​(Duration duration,
                      Shape path)
        构造函数为 PathTransition 。
        参数
        duration - 该 PathTransition的 PathTransition
        path - 这个 PathTransition的 PathTransition

      • PathTransition

        public PathTransition​()
        构造函数为 PathTransition 。

    • 方法详细信息

      • setNode

        public final void setNode​(Node value)
        设置属性节点的值。
        Property description:
        这个PathTransition的目标节点。

        无法更改目标node运行的PathTransition 。 如果值node改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

      • getNode

        public final Node getNode​()
        获取属性节点的值。
        Property description:
        这个PathTransition的目标节点。

        无法更改目标node的运行中的PathTransition 。 如果值node改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

      • nodeProperty

        public final ObjectProperty<Node> nodeProperty​()
        这个PathTransition的目标节点。

        这是不可能改变目标node正在运行的PathTransition 。 如果值node改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • setDuration

        public final void setDuration​(Duration value)
        设置属性持续时间的值。
        Property description:
        这个Transition的持续时间。

        无法更改duration的一个正在运行的PathTransition 。 如果值duration改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        注意：虽然duration的单位为毫秒，但粒度取决于底层的操作系统，通常会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • getDuration

        public final Duration getDuration​()
        获取属性持续时间的值。
        Property description:
        这个Transition的持续时间。

        无法更改duration的运行中的PathTransition 。 如果值duration改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒，粒度取决于底层的操作系统，一般来说会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 设定持续时间低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • durationProperty

        public final ObjectProperty<Duration> durationProperty​()
        这个Transition的持续时间。

        无法更改duration的PathTransition 。 如果值duration改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒，粒度取决于底层的操作系统，一般来说会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 设定持续时间低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • setPath

        public final void setPath​(Shape value)
        设置属性路径的值。
        Property description:
        大纲节点应该被动画的形状。

        不可能更改path的PathTransition 。 如果值path改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        空值

      • getPath

        public final Shape getPath​()
        获取属性路径的值。
        Property description:
        大纲节点应该被动画的形状。

        无法更改path的PathTransition 。 如果值path改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        空值

      • pathProperty

        public final ObjectProperty<Shape> pathProperty​()
        大纲节点应该被动画的形状。

        不可能更改path的PathTransition 。 如果值path改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        空值
        另请参见：
        getPath() ， setPath(Shape)

      • setOrientation

        public final void setOrientation​(PathTransition.OrientationType value)
        设置属性方向的值。
        Property description:
        指定node沿path的直立方向。 默认方向设置为PathTransition.OrientationType.NONE 。

        无法更改orientation的PathTransition 。 如果值orientation改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        没有

      • getOrientation

        public final PathTransition.OrientationType getOrientation​()
        获取属性方向的值。
        Property description:
        指定node沿path的直立方向。 默认方向设置为PathTransition.OrientationType.NONE 。

        无法更改orientation的PathTransition 。 如果值orientation改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        没有

      • orientationProperty

        public final ObjectProperty<PathTransition.OrientationType> orientationProperty​()
        指定node沿path的直立方向。 默认方向设置为PathTransition.OrientationType.NONE 。

        不可能更改orientation的一个正在运行的PathTransition 。 如果值orientation改变正在运行的PathTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        没有
        另请参见：
        getOrientation() ， setOrientation(PathTransition.OrientationType)

      • interpolate

        public void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如，如果interpolator是Interpolator.LINEAR ，则分数会增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - The relative position
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PathTransition.OrientationType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Enum PathTransition.OrientationType

  • java.lang.Object
    • java.lang.Enum<PathTransition.OrientationType>
      • javafx.animation.PathTransition.OrientationType
  • All Implemented Interfaces:
    Serializable ， Comparable<PathTransition.OrientationType>
    Enclosing class:
    PathTransition

    public static enum PathTransition.OrientationType
extends Enum<PathTransition.OrientationType>
    指定 node沿 path的直立方向。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NONE
      目标 node的旋转矩阵沿几何路径保持不变。
      ORTHOGONAL_TO_TANGENT
      目标节点的旋转矩阵设置为保持 node垂直于沿几何路径的路径切线。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PathTransition.OrientationType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PathTransition.OrientationType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NONE

        public static final PathTransition.OrientationType NONE
        目标 node的旋转矩阵沿着几何路径保持不变。

      • ORTHOGONAL_TO_TANGENT

        public static final PathTransition.OrientationType ORTHOGONAL_TO_TANGENT
        目标节点的旋转矩阵设置为保持 node垂直于沿着几何路径的路径切线。

    • 方法详细信息

      • values

        public static PathTransition.OrientationType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PathTransition.OrientationType c : PathTransition.OrientationType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PathTransition.OrientationType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PauseTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class PauseTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.PauseTransition

  • public final class PauseTransition
extends Transition
    这Transition在其duration的最后执行一个Animation.onFinished 。

    代码段示例：

       import javafx.scene.shape.*; import javafx.animation.*; ... Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); rect.setFill(Color.VIOLET); RotateTransition rt = new RotateTransition(Duration.millis(3000), rect); rt.setByAngle(180); rt.setCycleCount(4f); rt.setAutoReverse(true); SequentialTransition seqTransition = new SequentialTransition ( new PauseTransition(Duration.millis(1000)), // wait a second rt ); seqTransition.play(); ...
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Duration> duration
      这个 Transition的持续时间。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      PauseTransition​()
      构造函数为 PauseTransition
      PauseTransition​(Duration duration)
      构造函数为 PauseTransition 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Duration> durationProperty​()
      这个 Transition的持续时间。
      Duration getDuration​()
      获取属性持续时间的值。
      void interpolate​(double frac)
      方法 interpolate()必须由 Transition的实现来提供。
      void setDuration​(Duration value)
      设置属性持续时间的值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, getParentTargetNode, interpolatorProperty, setInterpolator

    • Property Detail

      • duration

        public final ObjectProperty<Duration> durationProperty
        这个Transition的持续时间。

        不可能更改duration的一个正在运行的PauseTransition 。 如果值duration改变正在运行的PauseTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒，粒度取决于底层的操作系统，一般会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 设定持续时间低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

    • 构造方法详细信息

      • PauseTransition

        public PauseTransition​(Duration duration)
        构造函数为 PauseTransition 。
        参数
        duration - 持续时间 PauseTransition

      • PauseTransition

        public PauseTransition​()
        构造函数为 PauseTransition

    • 方法详细信息

      • setDuration

        public final void setDuration​(Duration value)
        设置属性持续时间的值。
        Property description:
        这个Transition的持续时间。

        这是不可能改变duration正在运行的PauseTransition 。 如果值duration改变正在运行的PauseTransition ，动画必须停止并重新开始拿起新的价值。

        注意：虽然duration的单位是毫秒，但粒度取决于底层的操作系统，通常会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • getDuration

        public final Duration getDuration​()
        获取属性持续时间的值。
        Property description:
        这个Transition的持续时间。

        无法更改duration的PauseTransition 。 如果值duration改变正在运行的PauseTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层的操作系统，通常会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 设定持续时间低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • durationProperty

        public final ObjectProperty<Duration> durationProperty​()
        这个Transition的持续时间。

        无法更改duration的PauseTransition 。 如果值duration改变正在运行的PauseTransition ，动画必须停止并重新开始拿起新的价值。

        注意：虽然duration的单位为毫秒，但粒度取决于底层操作系统，通常会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • interpolate

        public void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如，如果interpolator是Interpolator.LINEAR ，则分数会增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RotateTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class RotateTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.RotateTransition

  • public final class RotateTransition
extends Transition
    这Transition创建一个旋转动画，跨越其duration 。 这是通过更新完成rotate的可变node在固定时间间隔。 角度值以度为单位。

    它从fromAngle开始，如果提供的其他使用node的rotate值。

    如果提供的话，它将停止在toAngle值，否则将使用起始值加上byAngle 。

    如果指定了toAngle和byAngle则toAngle将优先。

    代码段示例：

       import javafx.scene.shape.*; import javafx.animation.*; ... Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); rect.setFill(Color.VIOLET); RotateTransition rt = new RotateTransition(Duration.millis(3000), rect); rt.setByAngle(180); rt.setCycleCount(4); rt.setAutoReverse(true); rt.play(); ...
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Point3D> axis
      指定 RotateTransition的旋转轴。
      DoubleProperty byAngle
      指定从这个 RotateTransition开始的递增停止角度值。
      ObjectProperty<Duration> duration
      这个 RotateTransition的持续时间。
      DoubleProperty fromAngle
      指定此 RotateTransition的起始角度值。
      ObjectProperty<Node> node
      这个 RotateTransition的目标节点。
      DoubleProperty toAngle
      指定此 RotateTransition的停止角度值。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      RotateTransition​()
      构造函数为 RotateTransition
      RotateTransition​(Duration duration)
      构造函数为 RotateTransition
      RotateTransition​(Duration duration, Node node)
      构造函数为 RotateTransition

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Point3D> axisProperty​()
      指定 RotateTransition的旋转轴。
      DoubleProperty byAngleProperty​()
      指定从这个 RotateTransition开始的递增停止角度值。
      ObjectProperty<Duration> durationProperty​()
      这个 RotateTransition的持续时间。
      DoubleProperty fromAngleProperty​()
      指定此 RotateTransition的起始角度值。
      Point3D getAxis​()
      获取属性轴的值。
      double getByAngle​()
      获取属性的值byAngle。
      Duration getDuration​()
      获取属性持续时间的值。
      double getFromAngle​()
      获取属性fromAngle的值。
      Node getNode​()
      获取属性节点的值。
      double getToAngle​()
      获取属性的值为Agle。
      protected void interpolate​(double frac)
      方法 interpolate()必须由 Transition的实现来提供。
      ObjectProperty<Node> nodeProperty​()
      这个 RotateTransition的目标节点。
      void setAxis​(Point3D value)
      设置属性轴的值。
      void setByAngle​(double value)
      设置属性的值byAngle。
      void setDuration​(Duration value)
      设置属性持续时间的值。
      void setFromAngle​(double value)
      设置属性fromAngle的值。
      void setNode​(Node value)
      设置属性节点的值。
      void setToAngle​(double value)
      将属性的值设置为Agle。
      DoubleProperty toAngleProperty​()
      指定此 RotateTransition的停止角度值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, getParentTargetNode, interpolatorProperty, setInterpolator

    • Property Detail

      • node

        public final ObjectProperty<Node> nodeProperty
        该目标节点为RotateTransition 。

        这是不可能改变目标node正在运行的RotateTransition 。 如果node的值更改为运行中的RotateTransition ，则动画必须停止并重新开始以获取新值。

        另请参见：
        getNode() ， setNode(Node)

      • duration

        public final ObjectProperty<Duration> durationProperty
        这个RotateTransition的持续时间。

        无法更改duration的运行中的RotateTransition 。 如果值duration改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层操作系统，通常会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 设定持续时间低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • axis

        public final ObjectProperty<Point3D> axisProperty
        指定RotateTransition的旋转轴。 如果这个axis为空，请使用node.rotationAxis作为旋转轴。

        不可能更改axis的一个正在运行的RotateTransition 。 如果值axis改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        空值
        另请参见：
        getAxis() ， setAxis(Point3D)

      • fromAngle

        public final DoubleProperty fromAngleProperty
        指定此RotateTransition的起始角度值。

        无法更改fromAngle的一个正在运行的RotateTransition 。 如果值fromAngle改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromAngle() ， setFromAngle(double)

      • toAngle

        public final DoubleProperty toAngleProperty
        指定RotateTransition的停止角度值。

        不可能更改toAngle的一个正在运行的RotateTransition 。 如果值toAngle改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToAngle() ， setToAngle(double)

      • byAngle

        public final DoubleProperty byAngleProperty
        从这个RotateTransition开始指定递增的停止角度值。

        无法更改byAngle的正在运行的RotateTransition 。 如果byAngle的值更改为运行中的RotateTransition ，则动画必须停止并重新开始以获取新值。

        另请参见：
        getByAngle() ， setByAngle(double)

    • 构造方法详细信息

      • RotateTransition

        public RotateTransition​(Duration duration,
                        Node node)
        构造函数为 RotateTransition
        参数
        duration - 持续时间 RotateTransition
        node - 将旋转 node

      • RotateTransition

        public RotateTransition​(Duration duration)
        构造函数为 RotateTransition
        参数
        duration - 持续时间 RotateTransition

      • RotateTransition

        public RotateTransition​()
        构造函数为 RotateTransition

    • 方法详细信息

      • setNode

        public final void setNode​(Node value)
        设置属性节点的值。
        Property description:
        这个RotateTransition的目标节点。

        这是不可能改变目标node正在运行的RotateTransition 。 如果为运行的RotateTransition更改了node的值，则必须停止动画并重新启动以获取新值。

      • getNode

        public final Node getNode​()
        获取属性节点的值。
        Property description:
        这个RotateTransition的目标节点。

        这是不可能改变目标node正在运行的RotateTransition 。 如果值node改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

      • nodeProperty

        public final ObjectProperty<Node> nodeProperty​()
        这个RotateTransition的目标节点。

        这是不可能改变目标node正在运行的RotateTransition 。 如果值node改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • setDuration

        public final void setDuration​(Duration value)
        设置属性持续时间的值。
        Property description:
        持续时间RotateTransition 。

        不可能更改duration的一个正在运行的RotateTransition 。 如果值duration改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒，粒度取决于底层的操作系统，一般会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 设定持续时间低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • getDuration

        public final Duration getDuration​()
        获取属性持续时间的值。
        Property description:
        这个RotateTransition的持续时间。

        这是不可能改变duration正在运行的RotateTransition 。 如果值duration改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层的操作系统，一般会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • durationProperty

        public final ObjectProperty<Duration> durationProperty​()
        这个RotateTransition的持续时间。

        不可能更改duration运行的RotateTransition 。 如果duration的值更改为运行中的RotateTransition ，则动画必须停止并再次启动才能获取新值。

        注意： duration的单位是毫秒级，粒度取决于底层的操作系统，通常会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 设定持续时间低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • setAxis

        public final void setAxis​(Point3D value)
        设置属性轴的值。
        Property description:
        指定此RotateTransition的旋转轴。 如果axis为空，则使用node.rotationAxis作为旋转轴。

        不可能更改axis的一个正在运行的RotateTransition 。 如果值axis改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        空值

      • getAxis

        public final Point3D getAxis​()
        获取属性轴的值。
        Property description:
        指定此RotateTransition的旋转轴。 如果这个axis为空，请使用node.rotationAxis作为旋转轴。

        这是不可能改变axis正在运行的RotateTransition 。 如果axis的值更改为运行中的RotateTransition ，则必须停止动画并再次启动以获取新值。

        Default value:
        空值

      • axisProperty

        public final ObjectProperty<Point3D> axisProperty​()
        指定RotateTransition的旋转轴。 如果axis为空，则使用node.rotationAxis作为旋转轴。

        无法更改axis运行的RotateTransition 。 如果值axis改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        空值
        另请参见：
        getAxis() ， setAxis(Point3D)

      • setFromAngle

        public final void setFromAngle​(double value)
        设置属性fromAngle的值。
        Property description:
        指定此RotateTransition的起始角度值。

        不可能更改fromAngle的一个正在运行的RotateTransition 。 如果为运行的RotateTransition更改了fromAngle的值，则必须停止动画并重新启动以获取新值。

        Default value:
        Double.NaN

      • getFromAngle

        public final double getFromAngle​()
        获取属性fromAngle的值。
        Property description:
        指定此RotateTransition的起始角度值。

        无法更改fromAngle的运行中的RotateTransition 。 如果fromAngle的值更改为RotateTransition ，则动画必须停止并重新开始以获取新值。

        Default value:
        Double.NaN

      • fromAngleProperty

        public final DoubleProperty fromAngleProperty​()
        指定此RotateTransition的起始角度值。

        不可能更改fromAngle的一个正在运行的RotateTransition 。 如果值fromAngle改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromAngle() ， setFromAngle(double)

      • setToAngle

        public final void setToAngle​(double value)
        将属性的值设置为Agle。
        Property description:
        指定此RotateTransition的停止角度值。

        不可能更改toAngle的一个正在运行的RotateTransition 。 如果值toAngle改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getToAngle

        public final double getToAngle​()
        获取属性的值为Agle。
        Property description:
        指定RotateTransition的停止角度值。

        无法更改toAngle的一个正在运行的RotateTransition 。 如果值toAngle改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • toAngleProperty

        public final DoubleProperty toAngleProperty​()
        指定此RotateTransition的停止角度值。

        无法更改toAngle的一个正在运行的RotateTransition 。 如果值toAngle改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToAngle() ， setToAngle(double)

      • setByAngle

        public final void setByAngle​(double value)
        设置属性的值byAngle。
        Property description:
        从这个RotateTransition开始指定递增的停止角度值。

        无法更改byAngle的一个正在运行的RotateTransition 。 如果值byAngle改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

      • getByAngle

        public final double getByAngle​()
        获取属性的值byAngle。
        Property description:
        指定从这个RotateTransition开始的递增停止角度值。

        无法更改byAngle的一个正在运行的RotateTransition 。 如果值byAngle改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

      • byAngleProperty

        public final DoubleProperty byAngleProperty​()
        指定从这个RotateTransition开始的递增停止角度值。

        无法更改byAngle的一个正在运行的RotateTransition 。 如果值byAngle改变正在运行的RotateTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByAngle() ， setByAngle(double)

      • interpolate

        protected void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如如果interpolator是Interpolator.LINEAR ，则分数会增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScaleTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class ScaleTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.ScaleTransition

  • public final class ScaleTransition
extends Transition
    这个Transition创建了一个尺度动画，涵盖其duration 。 这是通过更新完成scaleX ， scaleY和scaleZ的变量node在固定时间间隔。

    它从（开始fromX ， fromY ， fromZ如果提供其他人使用的）值node的（ scaleX ， scaleY ， scaleZ ）值。

    它停在（ toX ， toY ， toZ如果提供否则将使用起始值加（）值byX ， byY ， byZ ）值。

    的（ toX ， toY ， toZ如果两个（）值优先toX ， toY ， toZ ）和（ byX ， byY ， byZ指定）值。

    代码段示例：

       import javafx.scene.shape.*; import javafx.animation.*; ... Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); rect.setFill(Color.VIOLET); ScaleTransition st = new ScaleTransition(Duration.millis(2000), rect); st.setByX(1.5f); st.setByY(1.5f); st.setCycleCount(4f); st.setAutoReverse(true); st.play(); ...
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty byX
      指定从这个 ScaleTransition开始的递增的停止X比例值。
      DoubleProperty byY
      指定从这个 ScaleTransition开始的递增的停止Y比例值。
      DoubleProperty byZ
      从这个 ScaleTransition开始指定递增的停止Z比例值。
      ObjectProperty<Duration> duration
      这个 ScaleTransition的持续时间。
      DoubleProperty fromX
      指定这个 ScaleTransition的起始X比例值。
      DoubleProperty fromY
      指定这个 ScaleTransition的起始Y比例值。
      DoubleProperty fromZ
      指定这个 ScaleTransition的起始Z刻度值。
      ObjectProperty<Node> node
      这个 ScaleTransition的目标节点。
      DoubleProperty toX
      指定此 ScaleTransition的停止X比例值。
      DoubleProperty toY
      这个停止Y刻度值这个 ScaleTransition 。
      DoubleProperty toZ
      这个停止Z刻度值这个 ScaleTransition 。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScaleTransition​()
      构造函数为 ScaleTransition
      ScaleTransition​(Duration duration)
      构造函数为 ScaleTransition
      ScaleTransition​(Duration duration, Node node)
      构造函数为 ScaleTransition

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty byXProperty​()
      指定从这个 ScaleTransition开始的递增的停止X比例值。
      DoubleProperty byYProperty​()
      指定从这个 ScaleTransition开始的递增的停止Y比例值。
      DoubleProperty byZProperty​()
      指定从这个 ScaleTransition开始的递增的停止Z刻度值。
      ObjectProperty<Duration> durationProperty​()
      这个 ScaleTransition的持续时间。
      DoubleProperty fromXProperty​()
      指定此 ScaleTransition的起始X比例值。
      DoubleProperty fromYProperty​()
      指定这个 ScaleTransition的起始Y比例值。
      DoubleProperty fromZProperty​()
      指定此 ScaleTransition的起始Z刻度值。
      double getByX​()
      通过X获取属性的值。
      double getByY​()
      通过Y获取属性的值。
      double getByZ​()
      通过Z获取属性的值。
      Duration getDuration​()
      获取属性持续时间的值。
      double getFromX​()
      从X获取属性的值。
      double getFromY​()
      从Y获取属性的值。
      double getFromZ​()
      从Z获取属性的值。
      Node getNode​()
      获取属性节点的值。
      double getToX​()
      获取属性toX的值。
      double getToY​()
      获取属性的值为Y。
      double getToZ​()
      获取属性到Z的值。
      void interpolate​(double frac)
      方法 interpolate()必须由 Transition的实现来提供。
      ObjectProperty<Node> nodeProperty​()
      这个 ScaleTransition的目标节点。
      void setByX​(double value)
      设置属性的值byX。
      void setByY​(double value)
      设置属性的值byY。
      void setByZ​(double value)
      设置属性的值byZ。
      void setDuration​(Duration value)
      设置属性持续时间的值。
      void setFromX​(double value)
      设置属性fromX的值。
      void setFromY​(double value)
      设置属性fromY的值。
      void setFromZ​(double value)
      设置属性的值Z。
      void setNode​(Node value)
      设置属性节点的值。
      void setToX​(double value)
      将属性的值设置为X。
      void setToY​(double value)
      将属性的值设置为Y。
      void setToZ​(double value)
      将属性的值设置为Z。
      DoubleProperty toXProperty​()
      指定此 ScaleTransition的停止X比例值。
      DoubleProperty toYProperty​()
      这个停止Y刻度值这个 ScaleTransition 。
      DoubleProperty toZProperty​()
      这个停止Z比例值这个 ScaleTransition 。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, getParentTargetNode, interpolatorProperty, setInterpolator

    • Property Detail

      • node

        public final ObjectProperty<Node> nodeProperty
        这个ScaleTransition的目标节点。

        这是不可能改变目标node正在运行的ScaleTransition 。 如果值node改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • duration

        public final ObjectProperty<Duration> durationProperty
        这个ScaleTransition的持续时间。

        不可能更改duration的ScaleTransition 。 如果值duration改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        注意：虽然duration的单位是毫秒，但粒度取决于底层的操作系统，通常会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 设定持续时间低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • fromX

        public final DoubleProperty fromXProperty
        指定此ScaleTransition的起始X比例值。

        不可能更改fromX的一个正在运行的ScaleTransition 。 如果值fromX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromX() ， setFromX(double)

      • fromY

        public final DoubleProperty fromYProperty
        指定这个ScaleTransition的起始Y比例值。

        不可能更改fromY的一个正在运行的ScaleTransition 。 如果值fromY改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromY() ， setFromY(double)

      • fromZ

        public final DoubleProperty fromZProperty
        指定此ScaleTransition的起始Z刻度值。

        不可能更改fromZ的一个正在运行的ScaleTransition 。 如果值fromZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromZ() ， setFromZ(double)

      • toX

        public final DoubleProperty toXProperty
        指定此ScaleTransition的停止X比例值。

        无法更改toX的ScaleTransition 。 如果值toX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToX() ， setToX(double)

      • toY

        public final DoubleProperty toYProperty
        这个停止Y刻度值这个ScaleTransition 。

        无法更改toY的一个正在运行的ScaleTransition 。 如果值toY改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToY() ， setToY(double)

      • toZ

        public final DoubleProperty toZProperty
        停止Z刻度值ScaleTransition 。

        无法更改toZ的一个正在运行的ScaleTransition 。 如果值toZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToZ() ， setToZ(double)

      • byX

        public final DoubleProperty byXProperty
        指定从这个ScaleTransition开始的递增的停止X比例值。

        无法更改byX的正在运行的ScaleTransition 。 如果值byX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByX() ， setByX(double)

      • byY

        public final DoubleProperty byYProperty
        从这个ScaleTransition开始指定递增的停止Y比例值。

        无法更改byY的一个正在运行的ScaleTransition 。 如果值byY改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByY() ， setByY(double)

      • byZ

        public final DoubleProperty byZProperty
        指定从这个ScaleTransition开始的递增的停止Z刻度值。

        无法更改byZ的一个正在运行的ScaleTransition 。 如果值byZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByZ() ， setByZ(double)

    • 构造方法详细信息

      • ScaleTransition

        public ScaleTransition​(Duration duration,
                       Node node)
        构造函数为 ScaleTransition
        参数
        duration - 持续时间 ScaleTransition
        node - 将缩放的 node

      • ScaleTransition

        public ScaleTransition​(Duration duration)
        构造函数为 ScaleTransition
        参数
        duration - 持续时间 ScaleTransition

      • ScaleTransition

        public ScaleTransition​()
        构造函数为 ScaleTransition

    • 方法详细信息

      • setNode

        public final void setNode​(Node value)
        设置属性节点的值。
        Property description:
        这个ScaleTransition的目标节点。

        这是不可能改变目标node正在运行的ScaleTransition 。 如果node的值更改为运行中的ScaleTransition ，则动画必须停止并重新开始以获取新值。

      • getNode

        public final Node getNode​()
        获取属性节点的值。
        Property description:
        这个ScaleTransition的目标节点。

        这是不可能改变目标node正在运行的ScaleTransition 。 如果值node改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

      • nodeProperty

        public final ObjectProperty<Node> nodeProperty​()
        这个ScaleTransition的目标节点。

        这是不可能改变目标node正在运行的ScaleTransition 。 如果值node改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • setDuration

        public final void setDuration​(Duration value)
        设置属性持续时间的值。
        Property description:
        这个ScaleTransition的持续时间。

        无法更改duration的ScaleTransition 。 如果值duration改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒，粒度取决于底层的操作系统，一般会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 设定持续时间低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • getDuration

        public final Duration getDuration​()
        获取属性持续时间的值。
        Property description:
        这个ScaleTransition的持续时间。

        无法更改duration的ScaleTransition 。 如果值duration改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层操作系统，通常会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • durationProperty

        public final ObjectProperty<Duration> durationProperty​()
        这个ScaleTransition的持续时间。

        不可能更改duration的一个正在运行的ScaleTransition 。 如果值duration改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        注意：虽然duration的单位是毫秒，粒度取决于底层的操作系统，但通常会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • setFromX

        public final void setFromX​(double value)
        设置属性fromX的值。
        Property description:
        指定这个ScaleTransition的起始X比例值。

        无法更改fromX的一个正在运行的ScaleTransition 。 如果值fromX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getFromX

        public final double getFromX​()
        从X获取属性的值。
        Property description:
        指定这个ScaleTransition的起始X比例值。

        无法更改fromX的一个正在运行的ScaleTransition 。 如果fromX的值更改为正在运行的ScaleTransition ，动画必须停止并重新启动以获取新值。

        Default value:
        Double.NaN

      • fromXProperty

        public final DoubleProperty fromXProperty​()
        指定此ScaleTransition的起始X比例值。

        无法更改fromX的ScaleTransition 。 如果值fromX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromX() ， setFromX(double)

      • setFromY

        public final void setFromY​(double value)
        设置属性fromY的值。
        Property description:
        指定这个ScaleTransition的起始Y比例值。

        不可能更改fromY的ScaleTransition 。 如果值fromY改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getFromY

        public final double getFromY​()
        从Y获取属性的值。
        Property description:
        指定此ScaleTransition的起始Y比例值。

        不可能更改fromY的一个正在运行的ScaleTransition 。 如果值fromY改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • fromYProperty

        public final DoubleProperty fromYProperty​()
        指定这个ScaleTransition的起始Y比例值。

        无法更改fromY的一个正在运行的ScaleTransition 。 如果值fromY改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromY() ， setFromY(double)

      • setFromZ

        public final void setFromZ​(double value)
        设置属性的值Z。
        Property description:
        指定此ScaleTransition的起始Z刻度值。

        不可能更改fromZ的运行中的ScaleTransition 。 如果值fromZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getFromZ

        public final double getFromZ​()
        从Z获取属性的值。
        Property description:
        指定此ScaleTransition的起始Z刻度值。

        无法更改fromZ的运行中的ScaleTransition 。 如果值fromZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • fromZProperty

        public final DoubleProperty fromZProperty​()
        指定此ScaleTransition的起始Z刻度值。

        无法更改fromZ的一个正在运行的ScaleTransition 。 如果值fromZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromZ() ， setFromZ(double)

      • setToX

        public final void setToX​(double value)
        将属性的值设置为X。
        Property description:
        指定此ScaleTransition的停止X比例值。

        无法更改toX的一个正在运行的ScaleTransition 。 如果值toX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getToX

        public final double getToX​()
        获取属性toX的值。
        Property description:
        指定此ScaleTransition的停止X比例值。

        不可能更改toX的一个正在运行的ScaleTransition 。 如果值toX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • toXProperty

        public final DoubleProperty toXProperty​()
        指定此ScaleTransition的停止X比例值。

        不可能更改toX的一个正在运行的ScaleTransition 。 如果值toX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToX() ， setToX(double)

      • setToY

        public final void setToY​(double value)
        将属性的值设置为Y。
        Property description:
        这个停止Y刻度值这个ScaleTransition 。

        无法更改toY的ScaleTransition 。 如果toY的值更改为运行中的ScaleTransition ，则必须停止动画并重新启动以获取新值。

        Default value:
        Double.NaN

      • getToY

        public final double getToY​()
        获取属性的值为Y。
        Property description:
        这个停止Y刻度值这个ScaleTransition 。

        不可能更改toY的一个正在运行的ScaleTransition 。 如果toY的值更改为ScaleTransition ，则必须停止动画并重新启动以获取新值。

        Default value:
        Double.NaN

      • toYProperty

        public final DoubleProperty toYProperty​()
        这个停止Y刻度值这个ScaleTransition 。

        无法更改toY的一个正在运行的ScaleTransition 。 如果值toY改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToY() ， setToY(double)

      • setToZ

        public final void setToZ​(double value)
        将属性的值设置为Z。
        Property description:
        这个停止Z刻度值这个ScaleTransition 。

        无法更改toZ的一个正在运行的ScaleTransition 。 如果值toZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getToZ

        public final double getToZ​()
        获取属性到Z的值。
        Property description:
        停止Z刻度值ScaleTransition 。

        不可能更改toZ的一个正在运行的ScaleTransition 。 如果值toZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • toZProperty

        public final DoubleProperty toZProperty​()
        停止Z刻度值ScaleTransition 。

        不可能更改toZ的一个正在运行的ScaleTransition 。 如果值toZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToZ() ， setToZ(double)

      • setByX

        public final void setByX​(double value)
        设置属性的值byX。
        Property description:
        指定从这个ScaleTransition开始的递增的停止X比例值。

        不可能更改byX的一个正在运行的ScaleTransition 。 如果值byX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

      • getByX

        public final double getByX​()
        通过X获取属性的值。
        Property description:
        指定从这个ScaleTransition开始的递增的停止X比例值。

        无法更改byX的运行中的ScaleTransition 。 如果值byX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

      • byXProperty

        public final DoubleProperty byXProperty​()
        指定从这个ScaleTransition开始的递增的停止X比例值。

        不可能更改byX的一个正在运行的ScaleTransition 。 如果值byX改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByX() ， setByX(double)

      • setByY

        public final void setByY​(double value)
        设置属性的值byY。
        Property description:
        指定从这个ScaleTransition开始的递增的停止Y比例值。

        不可能更改byY的一个正在运行的ScaleTransition 。 如果值byY改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

      • getByY

        public final double getByY​()
        通过Y获取属性的值。
        Property description:
        从这个ScaleTransition开始指定递增的停止Y比例值。

        无法更改byY的ScaleTransition 。 如果值byY改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

      • byYProperty

        public final DoubleProperty byYProperty​()
        指定从这个ScaleTransition开始的递增的停止Y比例值。

        无法更改byY的一个正在运行的ScaleTransition 。 如果byY的值更改为ScaleTransition ，则必须停止动画并重新启动才能拾取新值。

        另请参见：
        getByY() ， setByY(double)

      • setByZ

        public final void setByZ​(double value)
        设置属性的值byZ。
        Property description:
        从这个ScaleTransition开始指定递增的停止Z比例值。

        无法更改byZ的运行中的ScaleTransition 。 如果值byZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

      • getByZ

        public final double getByZ​()
        通过Z获取属性的值。
        Property description:
        从这个ScaleTransition开始指定递增的停止Z比例值。

        无法更改byZ的ScaleTransition 。 如果值byZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

      • byZProperty

        public final DoubleProperty byZProperty​()
        从这个ScaleTransition开始指定递增的停止Z刻度值。

        不可能更改byZ的一个正在运行的ScaleTransition 。 如果值byZ改变正在运行的ScaleTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByZ() ， setByZ(double)

      • interpolate

        public void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如如果interpolator是Interpolator.LINEAR ，则分数会增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SequentialTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class SequentialTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.SequentialTransition

  • public final class SequentialTransition
extends Transition
    这Transition剧目Animations顺序排列。

    这个Transition孩子继承了node ，如果他们的node属性没有指定。

    代码段示例：

       Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); rect.setFill(Color.VIOLET); final Duration SEC_2 = Duration.millis(2000); final Duration SEC_3 = Duration.millis(3000); PauseTransition pt = new PauseTransition(Duration.millis(1000)); FadeTransition ft = new FadeTransition(SEC_3); ft.setFromValue(1.0f); ft.setToValue(0.3f); ft.setCycleCount(2f); ft.setAutoReverse(true); TranslateTransition tt = new TranslateTransition(SEC_2); tt.setFromX(-100f); tt.setToX(100f); tt.setCycleCount(2f); tt.setAutoReverse(true); RotateTransition rt = new RotateTransition(SEC_3); rt.setByAngle(180f); rt.setCycleCount(4f); rt.setAutoReverse(true); ScaleTransition st = new ScaleTransition(SEC_2); st.setByX(1.5f); st.setByY(1.5f); st.setCycleCount(2f); st.setAutoReverse(true); SequentialTransition seqT = new SequentialTransition (rect, pt, ft, tt, rt, st); seqT.play();
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Node> node
      这个Node是在所有的孩子Transitions中使用的 ，没有定义一个目标Node本身。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      SequentialTransition​()
      构造函数为 SequentialTransition 。
      SequentialTransition​(Animation... children)
      构造函数为 SequentialTransition 。
      SequentialTransition​(Node node)
      构造函数 SequentialTransition 。
      SequentialTransition​(Node node, Animation... children)
      构造函数为 SequentialTransition 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<Animation> getChildren​()
      将按顺序播放的Animations的列表。
      Node getNode​()
      获取属性节点的值。
      protected Node getParentTargetNode​()
      返回Transition的动画目标Transition 。
      protected void interpolate​(double frac)
      方法 interpolate()必须由 Transition的实现来提供。
      ObjectProperty<Node> nodeProperty​()
      这个Node用于所有的孩子Transitions ，它们没有定义目标Node本身。
      void setNode​(Node value)
      设置属性节点的值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, interpolatorProperty, setInterpolator

    • Property Detail

      • node

        public final ObjectProperty<Node> nodeProperty
        这个Node用于所有的孩子Transitions ，它们没有定义目标Node本身。 如果一个Transitions应该应用到一个Node这可以使用。

        这是不可能改变目标node正在运行的Transition 。 如果node的值更改为运行中的Transition ，则动画必须停止并重新开始以接收新值。

        另请参见：
        getNode() ， setNode(Node)

    • 构造方法详细信息

      • SequentialTransition

        public SequentialTransition​(Node node,
                            Animation... children)
        构造函数为 SequentialTransition 。
        参数
        node - 目标Node将用于没有Node指定自己的小孩Transitions
        children -孩子Animations如此SequentialTransition

      • SequentialTransition

        public SequentialTransition​(Animation... children)
        构造函数为 SequentialTransition 。
        参数
        children -孩子Animations如此SequentialTransition

      • SequentialTransition

        public SequentialTransition​(Node node)
        构造函数为 SequentialTransition 。
        参数
        node - 目标Node将用于没有Node指定自己的小孩Transitions

      • SequentialTransition

        public SequentialTransition​()
        构造函数为 SequentialTransition 。

    • 方法详细信息

      • setNode

        public final void setNode​(Node value)
        设置属性节点的值。
        Property description:
        这个Node用于所有的孩子Transitions ，它们不定义自己的目标Node 。 如果一个Transitions应该应用到一个Node这可以使用。

        这是不可能改变目标node正在运行的Transition 。 如果值node改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

      • getNode

        public final Node getNode​()
        获取属性节点的值。
        Property description:
        这个Node用于所有的孩子Transitions ，它们不定义目标Node本身。 如果一个Transitions应该应用到一个Node这可以使用。

        这是不可能改变目标node正在运行的Transition 。 如果值node改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

      • nodeProperty

        public final ObjectProperty<Node> nodeProperty​()
        这个Node用于所有的孩子Transitions ，它们不定义目标Node本身。 如果一个Transitions应该应用到一个Node这可以使用。

        这是不可能改变目标node正在运行的Transition 。 如果值node改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • getChildren

        public final ObservableList<Animation> getChildren​()
        将按顺序播放Animations的列表。

        不可能改变一个正在运行的SequentialTransition的孩子。 如果孩子们为一个正在运行的SequentialTransition而改变，那么动画必须被停止并重新开始以获取新的值。

        结果
        将按顺序播放的动画列表

      • getParentTargetNode

        protected Node getParentTargetNode​()
        返回目标Node这个动画Transition 。 该方法返回node ，否则返回parent.getTargetNode() ，否则返回null。
        重写：
        getParentTargetNode在 Transition
        结果
        目标 Node

      • interpolate

        protected void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如如果interpolator是Interpolator.LINEAR ，分数会增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StrokeTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class StrokeTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.StrokeTransition

  • public final class StrokeTransition
extends Transition
    此Transition创建一个动画，可以更改duration中的形状的笔触颜色。 这是通过更新完成stroke的可变shape定期。

    它从fromValue开始，如果提供的其他使用shape的stroke值。 （在这种情况下， stroke值必须是Color ）。

    它停止在toValue价值。

    代码段示例：

       import javafx.scene.shape.*; import javafx.animation.*; ... Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); rect.setFill(null); StrokeTransition st = new StrokeTransition(Duration.millis(3000), rect, Color.RED, Color.BLUE); st.setCycleCount(4); st.setAutoReverse(true); st.play(); ...
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Duration> duration
      这个 StrokeTransition的持续时间。
      ObjectProperty<Color> fromValue
      指定此 StrokeTransition的起始颜色值。
      ObjectProperty<Shape> shape
      目标形状为 StrokeTransition 。
      ObjectProperty<Color> toValue
      指定此 StrokeTransition的停止颜色值。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      StrokeTransition​()
      构造函数为 StrokeTransition
      StrokeTransition​(Duration duration)
      构造函数为 StrokeTransition
      StrokeTransition​(Duration duration, Color fromValue, Color toValue)
      构造函数为 StrokeTransition
      StrokeTransition​(Duration duration, Shape shape)
      构造函数为 StrokeTransition
      StrokeTransition​(Duration duration, Shape shape, Color fromValue, Color toValue)
      构造函数为 StrokeTransition

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Duration> durationProperty​()
      这个 StrokeTransition的持续时间。
      ObjectProperty<Color> fromValueProperty​()
      指定此 StrokeTransition的起始颜色值。
      Duration getDuration​()
      获取属性持续时间的值。
      Color getFromValue​()
      获取属性fromValue的值。
      Shape getShape​()
      获取属性形状的值。
      Color getToValue​()
      获取属性值到值。
      protected void interpolate​(double frac)
      方法 interpolate()必须由 Transition的实现来提供。
      void setDuration​(Duration value)
      设置属性持续时间的值。
      void setFromValue​(Color value)
      设置属性fromValue的值。
      void setShape​(Shape value)
      设置属性形状的值。
      void setToValue​(Color value)
      将属性的值设置为Value。
      ObjectProperty<Shape> shapeProperty​()
      目标形状为 StrokeTransition 。
      ObjectProperty<Color> toValueProperty​()
      指定此 StrokeTransition的停止颜色值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, getParentTargetNode, interpolatorProperty, setInterpolator

    • Property Detail

      • shape

        public final ObjectProperty<Shape> shapeProperty
        目标形状为StrokeTransition 。

        这是不可能改变目标shape正在运行的StrokeTransition 。 如果值shape改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getShape() ， setShape(Shape)

      • duration

        public final ObjectProperty<Duration> durationProperty
        这个StrokeTransition的持续时间。

        这是不可能改变duration正在运行的StrokeTransition 。 如果值duration改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒级，粒度取决于底层的操作系统，通常会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • fromValue

        public final ObjectProperty<Color> fromValueProperty
        指定此StrokeTransition的起始颜色值。

        无法更改fromValue的运行中的StrokeTransition 。 如果值fromValue改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null
        另请参见：
        getFromValue() ， setFromValue(Color)

      • toValue

        public final ObjectProperty<Color> toValueProperty
        指定此StrokeTransition的停止颜色值。

        不可能更改toValue的一个正在运行的StrokeTransition 。 如果值toValue改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null
        另请参见：
        getToValue() ， setToValue(Color)

    • 构造方法详细信息

      • StrokeTransition

        public StrokeTransition​(Duration duration,
                        Shape shape,
                        Color fromValue,
                        Color toValue)
        构造函数为 StrokeTransition
        参数
        duration - 持续时间 StrokeTransition
        shape - shape哪些填充将被动画
        fromValue - 颜色动画的起始值
        toValue - 颜色动画的结束值

      • StrokeTransition

        public StrokeTransition​(Duration duration,
                        Color fromValue,
                        Color toValue)
        构造函数为 StrokeTransition
        参数
        duration - 持续时间 StrokeTransition
        fromValue - 颜色动画的起始值
        toValue - 颜色动画的最终值

      • StrokeTransition

        public StrokeTransition​(Duration duration,
                        Shape shape)
        构造函数为 StrokeTransition
        参数
        duration - 持续时间 StrokeTransition
        shape - shape这个笔画将被动画化

      • StrokeTransition

        public StrokeTransition​(Duration duration)
        构造函数为 StrokeTransition
        参数
        duration - 持续时间 StrokeTransition

      • StrokeTransition

        public StrokeTransition​()
        构造函数为 StrokeTransition

    • 方法详细信息

      • setShape

        public final void setShape​(Shape value)
        设置属性形状的值。
        Property description:
        目标形状为StrokeTransition 。

        这是不可能改变目标shape正在运行的StrokeTransition 。 如果值shape改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

      • getShape

        public final Shape getShape​()
        获取属性形状的值。
        Property description:
        目标形状为StrokeTransition 。

        这是不可能改变目标shape正在运行的StrokeTransition 。 如果值shape改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

      • shapeProperty

        public final ObjectProperty<Shape> shapeProperty​()
        目标形状为StrokeTransition 。

        无法更改目标shape的一个正在运行的StrokeTransition 。 如果值shape改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getShape() ， setShape(Shape)

      • setDuration

        public final void setDuration​(Duration value)
        设置属性持续时间的值。
        Property description:
        持续时间StrokeTransition 。

        不可能更改duration的一个正在运行的StrokeTransition 。 如果值duration改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒，粒度取决于底层的操作系统，一般会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • getDuration

        public final Duration getDuration​()
        获取属性持续时间的值。
        Property description:
        这个StrokeTransition的持续时间。

        不可能更改duration的运行中的StrokeTransition 。 如果值duration改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒，粒度取决于底层的操作系统，一般会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • durationProperty

        public final ObjectProperty<Duration> durationProperty​()
        这个StrokeTransition的持续时间。

        不可能更改duration的一个正在运行的StrokeTransition 。 如果值duration改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        注意：虽然duration的单位是毫秒，但粒度取决于底层的操作系统，通常会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • setFromValue

        public final void setFromValue​(Color value)
        设置属性fromValue的值。
        Property description:
        指定此StrokeTransition的起始颜色值。

        不可能更改fromValue的一个正在运行的StrokeTransition 。 如果值fromValue改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null

      • getFromValue

        public final Color getFromValue​()
        获取属性fromValue的值。
        Property description:
        指定此StrokeTransition的起始颜色值。

        无法更改fromValue的一个正在运行的StrokeTransition 。 如果fromValue的值更改为运行StrokeTransition ，则必须停止动画并再次启动以接收新值。

        Default value:
        null

      • fromValueProperty

        public final ObjectProperty<Color> fromValueProperty​()
        指定此StrokeTransition的起始颜色值。

        不可能更改fromValue的一个正在运行的StrokeTransition 。 如果fromValue的值更改为运行StrokeTransition ，则动画必须停止并再次启动以获取新值。

        Default value:
        null
        另请参见：
        getFromValue() ， setFromValue(Color)

      • setToValue

        public final void setToValue​(Color value)
        将属性的值设置为Value。
        Property description:
        指定此StrokeTransition的停止颜色值。

        不可能更改toValue的一个正在运行的StrokeTransition 。 如果值toValue改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null

      • getToValue

        public final Color getToValue​()
        获取属性值到值。
        Property description:
        指定此StrokeTransition的停止颜色值。

        无法更改toValue的一个正在运行的StrokeTransition 。 如果值toValue改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null

      • toValueProperty

        public final ObjectProperty<Color> toValueProperty​()
        指定此StrokeTransition的停止颜色值。

        不可能更改toValue的一个正在运行的StrokeTransition 。 如果值toValue改变正在运行的StrokeTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        null
        另请参见：
        getToValue() ， setToValue(Color)

      • interpolate

        protected void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，每个帧都调用这个方法。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如如果interpolator是Interpolator.LINEAR ，分数会增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Timeline (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class Timeline

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Timeline

  • public final class Timeline
extends Animation
    A Timeline可以用于定义任何WritableValue的自由格式动画，例如，全部为JavaFX Properties 。

    甲Timeline ，由一个或多个所定义KeyFrame S，处理从个人KeyFrame顺序，在由指定的顺序KeyFrame.time 。 定义为KeyFrame.values键值的动画属性在KeyFrame至Timeline的初始位置的指定时间内插入目标键值，取决于Timeline的方向。

    Timeline在指定时间间隔内或之后处理个人KeyFrame ，不保证KeyFrame处理时的时间。

    Animation.cycleDurationProperty()将被设置为Timeline的keyFrames的最大时间值。

    如果KeyFrame为不设置time==0s瞬间，人会使用在当时的电流的目标值进行合成Animation.play()或Animation.playFromStart()被调用。

    无法更改keyFrames的Timeline 。 如果值keyFrames变更为运行Timeline ，它必须停止并再次开始拿起新的价值。

    一个简单的时间线可以这样创建：

       final Timeline timeline = new Timeline(); timeline.setCycleCount(2); timeline.setAutoReverse(true); timeline.getKeyFrames().add(new KeyFrame(Duration.millis(5000), new KeyValue (node.translateXProperty(), 25))); timeline.play();

    该时间轴将运行10秒，将节点由x轴设为25，然后在第二个周期返回到0。

    警告：正在从FX运行时引用正在运行的时间轴。 如果没有正确停止，无限时间线可能会导致内存泄漏。 所有具有动画属性的对象都不会被垃圾回收。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Animation ， KeyFrame ， KeyValue

    • Property Summary

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Timeline​()
      构造函数为 Timeline 。
      Timeline​(double targetFramerate)
      构造函数为 Timeline 。
      Timeline​(double targetFramerate, KeyFrame... keyFrames)
      构造函数为 Timeline 。
      Timeline​(KeyFrame... keyFrames)
      构造函数为 Timeline 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<KeyFrame> getKeyFrames​()
      返回此Timeline的Timeline 。
      void stop​()
      停止动画并将播放头重置到其初始位置。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Timeline

        public Timeline​(double targetFramerate,
                KeyFrame... keyFrames)
        构造函数为Timeline 。 这个构造函数允许定义一个Animation.targetFramerate 。
        参数
        targetFramerate -自定义的目标帧速率此 Timeline
        keyFrames - 这个 Timeline的关键帧

      • Timeline

        public Timeline​(KeyFrame... keyFrames)
        构造函数为 Timeline 。
        参数
        keyFrames - 这个 Timeline的关键帧

      • Timeline

        public Timeline​(double targetFramerate)
        构造函数为Timeline 。 这个构造函数允许定义一个Animation.targetFramerate 。
        参数
        targetFramerate -自定义的目标帧速率此 Timeline

      • Timeline

        public Timeline​()
        构造函数为 Timeline 。

    • 方法详细信息

      • getKeyFrames

        public final ObservableList<KeyFrame> getKeyFrames​()
        返回此Timeline的Timeline 。
        结果
        KeyFrames

      • stop

        public void stop​()
        停止动画并将播放头重置到其初始位置。 如果动画当前没有运行，则此方法无效。

        注意：

        • stop()是一个异步调用， Animation可能不会立即停止。
        重写：
        stop在 Animation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Transition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class Transition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
  • 已知直接子类：
    FadeTransition ， FillTransition ， ParallelTransition ， PathTransition ， PauseTransition ， RotateTransition ， ScaleTransition ， SequentialTransition ， StrokeTransition ， TranslateTransition

    public abstract class Transition
extends Animation
    一个抽象类，其中包含所有基于Transition的动画所需的基本功能，如PathTransition和RotateTransition 。

    这个类提供了一个简单的框架来定义动画。 它提供了Animation中定义的所有基本功能。 Transition需要执行方法interpolate(double) ，这是每帧中调用的，而Transition正在运行。

    此外，扩展类需要设置一个单个周期的持续时间为Animation.setCycleDuration(javafx.util.Duration) 。 此持续时间通常由用户通过持续时间属性设置（例如，如FadeTransition.duration ）。 但是也可以通过扩展类来计算，如ParallelTransition和FadeTransition中所述 。

    以下是一个简单的例子。 它创建一个小型动画，更新Text节点的text属性。 它从一个空的String开始， String增加，直到完成String完成。

       final String content = "Lorem ipsum"; final Text text = new Text(10, 20, ""); final Animation animation = new Transition() { { setCycleDuration(Duration.millis(2000)); } protected void interpolate(double frac) { final int length = content.length(); final int n = Math.round(length * (float) frac); text.setText(content.substring(0, n)); } }; animation.play();
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Animation

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Interpolator> interpolator
      控制每个 Transition循环的加速和减速时序。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Transition​()
      构造函数为 Transition 。
      Transition​(double targetFramerate)
      构造函数为 Transition 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected Interpolator getCachedInterpolator​()
      返回Interpolator ，当Transition启动时设置。
      Interpolator getInterpolator​()
      获取属性interpolator的值。
      protected Node getParentTargetNode​()
      返回Transition的动画的目标Transition 。
      protected abstract void interpolate​(double frac)
      方法 interpolate()必须由 Transition的实现来提供。
      ObjectProperty<Interpolator> interpolatorProperty​()
      控制每个 Transition周期的加速和减速时序。
      void setInterpolator​(Interpolator value)
      设置属性interpolator的值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • interpolator

        public final ObjectProperty<Interpolator> interpolatorProperty
        控制每个Transition周期的加速和减速时序。

        这只能在开始转换之前或转换结束之后更改。 如果值interpolator改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

        默认内插器设置为Interpolator.EASE_BOTH 。

        Default value:
        EASE_BOTH
        另请参见：
        getInterpolator() ， setInterpolator(Interpolator)

    • 构造方法详细信息

      • Transition

        public Transition​(double targetFramerate)
        构造函数为Transition 。 这个构造函数允许定义一个Animation.targetFramerate 。
        参数
        targetFramerate -自定义的目标帧速率此 Transition

      • Transition

        public Transition​()
        构造函数为 Transition 。

    • 方法详细信息

      • setInterpolator

        public final void setInterpolator​(Interpolator value)
        设置属性interpolator的值。
        Property description:
        控制每个Transition周期的加速和减速时序。

        这只能在开始转换之前或转换结束之后更改。 如果值interpolator改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

        默认内插器设置为Interpolator.EASE_BOTH 。

        Default value:
        EASE_BOTH

      • getInterpolator

        public final Interpolator getInterpolator​()
        获取属性interpolator的值。
        Property description:
        控制每个Transition循环的加速和减速时序。

        这只能在开始转换之前或转换结束之后更改。 如果值interpolator改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

        默认内插器设置为Interpolator.EASE_BOTH 。

        Default value:
        EASE_BOTH

      • interpolatorProperty

        public final ObjectProperty<Interpolator> interpolatorProperty​()
        控制每个Transition周期的加速和减速时序。

        这只能在开始转换之前或转换结束之后更改。 如果值interpolator改变正在运行的Transition ，动画必须停止并重新开始拿起新的价值。

        默认插值器设置为Interpolator.EASE_BOTH 。

        Default value:
        EASE_BOTH
        另请参见：
        getInterpolator() ， setInterpolator(Interpolator)

      • getCachedInterpolator

        protected Interpolator getCachedInterpolator​()
        返回Interpolator ，当Transition启动时设置。 更改interpolator运行的Transition应该没有立竿见影的效果。 相反，运行Transition应该继续使用原来的Interpolator直到它停止并再次启动。
        结果
        在 Interpolator当这所设定 Transition开始

      • getParentTargetNode

        protected Node getParentTargetNode​()
        返回此Transition的动画的目标Transition 。 如果设置了此方法，则返回node ，否则返回其parent.getTargetNode() 。
        结果
        目标 Node

      • interpolate

        protected abstract void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如如果interpolator是Interpolator.LINEAR ，分数会增加线性。 该方法不能直接由用户调用。
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TranslateTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.animation

Class TranslateTransition

  • java.lang.Object
    • javafx.animation.Animation
      • javafx.animation.Transition
        • javafx.animation.TranslateTransition

  • public final class TranslateTransition
extends Transition
    这个Transition创建了一个跨越其duration的移动/翻译动画。 这是通过更新完成translateX ， translateY和translateZ的变量node在固定时间间隔。

    它从（开始fromX ， fromY ， fromZ如果提供其他人使用的）值node的（ translateX ， translateY ， translateZ ）值。

    它停在（ toX ， toY ， toZ如果提供否则将使用起始值加（）值byX ， byY ， byZ ）值。

    的（ toX ， toY ， toZ如果两个（）值优先toX ， toY ， toZ ）和（ byX ， byY ， byZ指定）值。

    代码段示例：

       import javafx.scene.shape.*; import javafx.animation.*; ... Rectangle rect = new Rectangle (100, 40, 100, 100); rect.setArcHeight(50); rect.setArcWidth(50); rect.setFill(Color.VIOLET); TranslateTransition tt = new TranslateTransition(Duration.millis(2000), rect); tt.setByX(200f); tt.setCycleCount(4f); tt.setAutoReverse(true); tt.play(); ...
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Transition ， Animation

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty byX
      指定从这个 TranslateTransition开始的递增的停止X坐标值。
      DoubleProperty byY
      指定从这个 TranslateTransition开始的递增的停止Y坐标值。
      DoubleProperty byZ
      指定从这个 TranslateTransition开始的递增的停止Z坐标值。
      ObjectProperty<Duration> duration
      这个 TranslateTransition的持续时间。
      DoubleProperty fromX
      指定这个 TranslateTransition的起始X坐标值。
      DoubleProperty fromY
      指定这个 TranslateTransition的起始Y坐标值。
      DoubleProperty fromZ
      指定此 TranslateTransition的起始Z坐标值。
      ObjectProperty<Node> node
      这个 TranslateTransition的目标节点。
      DoubleProperty toX
      指定此 TranslateTransition的停止X坐标值。
      DoubleProperty toY
      指定此 TranslateTransition的停止Y坐标值。
      DoubleProperty toZ
      指定这个 TranslateTransition的停止Z坐标值。

      • Properties inherited from class javafx.animation.Animation

        autoReverse, currentRate, currentTime, cycleCount, cycleDuration, delay, onFinished, rate, status, totalDuration

      • Properties inherited from class javafx.animation.Transition

        interpolator

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.animation.Animation

        Animation.Status

    • Field Summary

      • Fields inherited from class javafx.animation.Animation

        INDEFINITE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TranslateTransition​()
      构造函数为 TranslateTransition
      TranslateTransition​(Duration duration)
      构造函数为 TranslateTransition
      TranslateTransition​(Duration duration, Node node)
      构造函数为 TranslateTransition

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty byXProperty​()
      指定从这个 TranslateTransition开始的递增的停止X坐标值。
      DoubleProperty byYProperty​()
      指定从这个 TranslateTransition开始的递增的停止Y坐标值。
      DoubleProperty byZProperty​()
      指定从这个 TranslateTransition开始的递增的停止Z坐标值。
      ObjectProperty<Duration> durationProperty​()
      这个持续时间 TranslateTransition 。
      DoubleProperty fromXProperty​()
      指定此 TranslateTransition的起始X坐标值。
      DoubleProperty fromYProperty​()
      指定这个 TranslateTransition的起始Y坐标值。
      DoubleProperty fromZProperty​()
      指定此 TranslateTransition的起始Z坐标值。
      double getByX​()
      通过X获取属性的值。
      double getByY​()
      通过Y获取属性的值。
      double getByZ​()
      通过Z获取属性的值。
      Duration getDuration​()
      获取属性持续时间的值。
      double getFromX​()
      从X获取属性的值。
      double getFromY​()
      从Y获取属性的值。
      double getFromZ​()
      从Z获取属性的值。
      Node getNode​()
      获取属性节点的值。
      double getToX​()
      获取属性toX的值。
      double getToY​()
      获取属性的值为Y。
      double getToZ​()
      获取属性到Z的值。
      void interpolate​(double frac)
      方法 interpolate()必须由 Transition的实现来提供。
      ObjectProperty<Node> nodeProperty​()
      这个 TranslateTransition的目标节点。
      void setByX​(double value)
      设置属性的值byX。
      void setByY​(double value)
      设置属性的值byY。
      void setByZ​(double value)
      设置属性的值byZ。
      void setDuration​(Duration value)
      设置属性持续时间的值。
      void setFromX​(double value)
      设置属性fromX的值。
      void setFromY​(double value)
      设置属性fromY的值。
      void setFromZ​(double value)
      设置属性的值Z。
      void setNode​(Node value)
      设置属性节点的值。
      void setToX​(double value)
      将属性的值设置为X。
      void setToY​(double value)
      将属性的值设置为Y。
      void setToZ​(double value)
      将属性的值设置为Z。
      DoubleProperty toXProperty​()
      指定此 TranslateTransition的停止X坐标值。
      DoubleProperty toYProperty​()
      指定这个 TranslateTransition的停止Y坐标值。
      DoubleProperty toZProperty​()
      指定此 TranslateTransition的停止Z坐标值。

      • Methods inherited from class javafx.animation.Animation

        autoReverseProperty, currentRateProperty, currentTimeProperty, cycleCountProperty, cycleDurationProperty, delayProperty, getCuePoints, getCurrentRate, getCurrentTime, getCycleCount, getCycleDuration, getDelay, getOnFinished, getRate, getStatus, getTargetFramerate, getTotalDuration, isAutoReverse, jumpTo, jumpTo, onFinishedProperty, pause, play, playFrom, playFrom, playFromStart, rateProperty, setAutoReverse, setCycleCount, setCycleDuration, setDelay, setOnFinished, setRate, setStatus, statusProperty, stop, totalDurationProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.animation.Transition

        getCachedInterpolator, getInterpolator, getParentTargetNode, interpolatorProperty, setInterpolator

    • Property Detail

      • node

        public final ObjectProperty<Node> nodeProperty
        这个TranslateTransition的目标节点。

        无法更改目标node的一个正在运行的TranslateTransition 。 如果值node改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • duration

        public final ObjectProperty<Duration> durationProperty
        这个TranslateTransition的持续时间。

        不可能更改duration的一个正在运行的TranslateTransition 。 如果值duration改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层的操作系统，一般会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • fromX

        public final DoubleProperty fromXProperty
        指定此TranslateTransition的起始X坐标值。

        不可能更改fromX的一个正在运行的TranslateTransition 。 如果值fromX改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromX() ， setFromX(double)

      • fromY

        public final DoubleProperty fromYProperty
        指定此TranslateTransition的起始Y坐标值。

        无法更改fromY的一个正在运行的TranslateTransition 。 如果值fromY改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromY() ， setFromY(double)

      • fromZ

        public final DoubleProperty fromZProperty
        指定此TranslateTransition的起始Z坐标值。

        无法更改fromZ的TranslateTransition 。 如果fromZ的值更改为TranslateTransition ，则必须停止动画并重新启动以获取新值。

        Default value:
        Double.NaN
        另请参见：
        getFromZ() ， setFromZ(double)

      • toX

        public final DoubleProperty toXProperty
        指定这个TranslateTransition的停止X坐标值。

        无法更改toX的运行中的TranslateTransition 。 如果toX的值更改为运行中的TranslateTransition ，则必须停止动画并重新启动以获取新值。

        Default value:
        Double.NaN
        另请参见：
        getToX() ， setToX(double)

      • toY

        public final DoubleProperty toYProperty
        指定这个TranslateTransition的停止Y坐标值。

        不可能更改toY的一个正在运行的TranslateTransition 。 如果值toY改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToY() ， setToY(double)

      • toZ

        public final DoubleProperty toZProperty
        指定此TranslateTransition的停止Z坐标值。

        不可能更改toZ的一个正在运行的TranslateTransition 。 如果值toZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToZ() ， setToZ(double)

      • byX

        public final DoubleProperty byXProperty
        指定从这个TranslateTransition开始的递增的停止X坐标值。

        不可能更改byX的一个正在运行的TranslateTransition 。 如果byX的值更改为TranslateTransition ，则必须停止动画并重新启动以获取新值。

        另请参见：
        getByX() ， setByX(double)

      • byY

        public final DoubleProperty byYProperty
        指定从这个TranslateTransition开始的递增的停止Y坐标值。

        无法更改byY的一个正在运行的TranslateTransition 。 如果byY的值更改为TranslateTransition ，则必须停止动画并重新启动以获取新值。

        另请参见：
        getByY() ， setByY(double)

      • byZ

        public final DoubleProperty byZProperty
        指定从这个TranslateTransition开始的递增的停止Z坐标值。

        不可能更改byZ的一个正在运行的TranslateTransition 。 如果值byZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByZ() ， setByZ(double)

    • 构造方法详细信息

      • TranslateTransition

        public TranslateTransition​(Duration duration,
                           Node node)
        构造函数为 TranslateTransition
        参数
        duration - 持续时间 TranslateTransition
        node - 将翻译的 node

      • TranslateTransition

        public TranslateTransition​(Duration duration)
        构造函数为 TranslateTransition
        参数
        duration - 持续时间 TranslateTransition

      • TranslateTransition

        public TranslateTransition​()
        构造函数为 TranslateTransition

    • 方法详细信息

      • setNode

        public final void setNode​(Node value)
        设置属性节点的值。
        Property description:
        这个TranslateTransition的目标节点。

        无法更改目标node的一个正在运行的TranslateTransition 。 如果值node改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

      • getNode

        public final Node getNode​()
        获取属性节点的值。
        Property description:
        该目标节点为TranslateTransition 。

        这是不可能改变目标node正在运行的TranslateTransition 。 如果值node改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

      • nodeProperty

        public final ObjectProperty<Node> nodeProperty​()
        这个TranslateTransition的目标节点。

        这是不可能改变目标node正在运行的TranslateTransition 。 如果值node改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getNode() ， setNode(Node)

      • setDuration

        public final void setDuration​(Duration value)
        设置属性持续时间的值。
        Property description:
        这个TranslateTransition的持续时间。

        无法更改duration的TranslateTransition 。 如果duration的值更改为TranslateTransition ，则必须停止动画并重新启动以获取新值。

        注意： duration的单位是毫秒，粒度取决于底层操作系统，一般来说会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • getDuration

        public final Duration getDuration​()
        获取属性持续时间的值。
        Property description:
        这个TranslateTransition的持续时间。

        这是不可能改变duration正在运行的TranslateTransition 。 如果值duration改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位为毫秒，粒度取决于底层操作系统，通常会较大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒

      • durationProperty

        public final ObjectProperty<Duration> durationProperty​()
        这个TranslateTransition的持续时间。

        无法更改duration的TranslateTransition 。 如果值duration改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        注意： duration的单位是毫秒，粒度取决于底层的操作系统，一般来说会更大。 例如，桌面系统上的动画通常运行时间最多为60fps，粒度为〜17 ms。 将持续时间设置为低于Duration.ZERO将导致IllegalArgumentException 。

        Default value:
        400毫秒
        另请参见：
        getDuration() ， setDuration(Duration)

      • setFromX

        public final void setFromX​(double value)
        设置属性fromX的值。
        Property description:
        指定TranslateTransition的起始X坐标值。

        无法更改fromX的TranslateTransition 。 如果值fromX改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getFromX

        public final double getFromX​()
        从X获取属性的值。
        Property description:
        指定此TranslateTransition的起始X坐标值。

        无法更改fromX的正在运行的TranslateTransition 。 如果fromX的值更改为TranslateTransition ，则必须停止动画并重新启动以接收新值。

        Default value:
        Double.NaN

      • fromXProperty

        public final DoubleProperty fromXProperty​()
        指定这个TranslateTransition的起始X坐标值。

        无法更改fromX的TranslateTransition 。 如果值fromX改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromX() ， setFromX(double)

      • setFromY

        public final void setFromY​(double value)
        设置属性fromY的值。
        Property description:
        指定这个TranslateTransition的起始Y坐标值。

        不可能更改fromY的一个正在运行的TranslateTransition 。 如果值fromY改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getFromY

        public final double getFromY​()
        从Y获取属性的值。
        Property description:
        指定这个TranslateTransition的起始Y坐标值。

        无法更改fromY的TranslateTransition 。 如果值fromY改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • fromYProperty

        public final DoubleProperty fromYProperty​()
        指定TranslateTransition的起始Y坐标值。

        无法更改fromY的TranslateTransition 。 如果值fromY改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromY() ， setFromY(double)

      • setFromZ

        public final void setFromZ​(double value)
        设置属性的值Z。
        Property description:
        指定这个TranslateTransition的起始Z坐标值。

        不可能更改fromZ的一个正在运行的TranslateTransition 。 如果值fromZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getFromZ

        public final double getFromZ​()
        从Z获取属性的值。
        Property description:
        指定此TranslateTransition的起始Z坐标值。

        不可能更改fromZ的一个正在运行的TranslateTransition 。 如果值fromZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • fromZProperty

        public final DoubleProperty fromZProperty​()
        指定此TranslateTransition的起始Z坐标值。

        不可能更改fromZ的一个正在运行的TranslateTransition 。 如果值fromZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getFromZ() ， setFromZ(double)

      • setToX

        public final void setToX​(double value)
        将属性的值设置为X。
        Property description:
        指定此TranslateTransition的停止X坐标值。

        无法更改toX的TranslateTransition 。 如果toX的值更改为TranslateTransition ，则必须停止动画并再次启动以获取新值。

        Default value:
        Double.NaN

      • getToX

        public final double getToX​()
        获取属性toX的值。
        Property description:
        指定此TranslateTransition的停止X坐标值。

        不可能更改toX的一个正在运行的TranslateTransition 。 如果值toX改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • toXProperty

        public final DoubleProperty toXProperty​()
        指定该TranslateTransition的停止X坐标值。

        无法更改toX的一个正在运行的TranslateTransition 。 如果值toX改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToX() ， setToX(double)

      • setToY

        public final void setToY​(double value)
        将属性的值设置为Y。
        Property description:
        指定此TranslateTransition的停止Y坐标值。

        无法更改toY的运行中的TranslateTransition 。 如果toY的值更改为TranslateTransition ，则必须停止动画并重新启动以获取新值。

        Default value:
        Double.NaN

      • getToY

        public final double getToY​()
        获取属性的值为Y。
        Property description:
        指定此TranslateTransition的停止Y坐标值。

        不可能更改toY的一个正在运行的TranslateTransition 。 如果值toY改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • toYProperty

        public final DoubleProperty toYProperty​()
        指定此TranslateTransition的停止Y坐标值。

        不可能更改toY的一个正在运行的TranslateTransition 。 如果值toY改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN
        另请参见：
        getToY() ， setToY(double)

      • setToZ

        public final void setToZ​(double value)
        将属性的值设置为Z。
        Property description:
        指定此TranslateTransition的停止Z坐标值。

        无法更改toZ的运行中的TranslateTransition 。 如果值toZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • getToZ

        public final double getToZ​()
        获取属性到Z的值。
        Property description:
        指定此TranslateTransition的停止Z坐标值。

        不可能更改toZ的一个正在运行的TranslateTransition 。 如果值toZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        Default value:
        Double.NaN

      • toZProperty

        public final DoubleProperty toZProperty​()
        指定此TranslateTransition的停止Z坐标值。

        无法更改toZ的一个正在运行的TranslateTransition 。 如果toZ的值更改为TranslateTransition ，则必须停止动画并重新启动以获取新值。

        Default value:
        Double.NaN
        另请参见：
        getToZ() ， setToZ(double)

      • setByX

        public final void setByX​(double value)
        设置属性的值byX。
        Property description:
        指定从这个TranslateTransition开始的递增的停止X坐标值。

        无法更改byX的运行中的TranslateTransition 。 如果值byX改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

      • getByX

        public final double getByX​()
        通过X获取属性的值。
        Property description:
        指定从这个TranslateTransition开始的递增的停止X坐标值。

        不可能更改byX的一个正在运行的TranslateTransition 。 如果值byX改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

      • byXProperty

        public final DoubleProperty byXProperty​()
        指定从这个TranslateTransition开始的递增的停止X坐标值。

        不可能更改byX的一个正在运行的TranslateTransition 。 如果值byX改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByX() ， setByX(double)

      • setByY

        public final void setByY​(double value)
        设置属性的值byY。
        Property description:
        指定从这个TranslateTransition开始的递增的停止Y坐标值。

        不可能更改byY的一个正在运行的TranslateTransition 。 如果byY的值更改为TranslateTransition ，则必须停止动画并重新启动以获取新值。

      • getByY

        public final double getByY​()
        通过Y获取属性的值。
        Property description:
        指定从这个TranslateTransition开始的递增的停止Y坐标值。

        不可能更改byY的一个正在运行的TranslateTransition 。 如果值byY改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

      • byYProperty

        public final DoubleProperty byYProperty​()
        指定从这个TranslateTransition开始的递增的停止Y坐标值。

        不可能更改byY的一个正在运行的TranslateTransition 。 如果值byY改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByY() ， setByY(double)

      • setByZ

        public final void setByZ​(double value)
        设置属性的值byZ。
        Property description:
        指定从这个TranslateTransition开始的递增的停止Z坐标值。

        不可能更改byZ的一个正在运行的TranslateTransition 。 如果值byZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

      • getByZ

        public final double getByZ​()
        通过Z获取属性的值。
        Property description:
        指定从这个TranslateTransition开始的递增的停止Z坐标值。

        不可能更改byZ的一个正在运行的TranslateTransition 。 如果值byZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

      • byZProperty

        public final DoubleProperty byZProperty​()
        指定从这个TranslateTransition开始的递增的停止Z坐标值。

        不可能更改byZ的一个正在运行的TranslateTransition 。 如果值byZ改变正在运行的TranslateTransition ，动画必须停止并重新开始拿起新的价值。

        另请参见：
        getByZ() ， setByZ(double)

      • interpolate

        public void interpolate​(double frac)
        方法interpolate()必须由Transition的实现来提供。 当一个Transition正在运行时，这个方法在每个帧中被调用。 该参数用动画定义当前位置。 一开始，分数将为0.0 ，最终将为1.0 。 参数如何增加，取决于interpolator ，例如如果interpolator是Interpolator.LINEAR ，则分数会增加线性。 该方法不能直接由用户调用。
        Specified by:
        interpolate在 Transition
        参数
        frac - 相对位置
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.animation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.animation

  • Packages that use javafx.animation
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
  • Classes in javafx.animation used by javafx.animation
    Class 描述
    Animation
    Animation提供了JavaFX运行时使用的所有动画的核心功能。
    Animation.Status
    可能的状态为 status 。
    Interpolator
    抽象类定义了多个 interpolate方法，用于计算内插值。
    KeyFrame
    在指定的时间点定义一组沿Timeline内插的变量的目标值 。
    KeyValue
    定义要在动画中的特定间隔内插的键值。
    PathTransition.OrientationType
    指定 node沿 path的直立方向。
    Transition
    一个抽象类，其中包含所有基于Transition的动画所需的基本功能，如PathTransition和RotateTransition 。
  • Classes in javafx.animation used by javafx.scene.chart
    Class 描述
    Animation
    Animation提供了JavaFX运行时使用的所有动画的核心功能。
  • Classes in javafx.animation used by javafx.scene.paint
    Class 描述
    Interpolatable
    可以插值的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.Animation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.Animation

  • Packages that use Animation
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of Animation in javafx.animation

      Subclasses of Animation in javafx.animation
      Modifier and Type Class 描述
      class  FadeTransition
      这个 Transition创建了一个跨越其 duration的褪色效果动画。
      class  FillTransition
      此 Transition创建一个动画，可以更改 duration中的形状填充。
      class  ParallelTransition
      这Transition剧目Animations并行。
      class  PathTransition
      这个 Transition创建了一个跨越其 PathTransition.duration的路径动画。
      class  PauseTransition
      这 Transition在其 PauseTransition.duration的末尾执行一个 onFinished 。
      class  RotateTransition
      这个 Transition创建一个旋转动画，覆盖其 duration 。
      class  ScaleTransition
      这个 Transition创建了一个尺度动画，涵盖其 ScaleTransition.duration 。
      class  SequentialTransition
      这Transition剧目Animations顺序排列。
      class  StrokeTransition
      这个 Transition创建一个动画，可以改变 duration中的形状的笔触颜色。
      class  Timeline
      A Timeline可用于定义任何WritableValue的自由格式动画，例如，全部为JavaFX Properties 。
      class  Transition
      一个抽象类，其中包含所有基于Transition的动画所需的基本功能，如PathTransition和RotateTransition 。
      class  TranslateTransition
      这个 Transition创建了一个跨越其 TranslateTransition.duration的移动/翻译动画。
      Methods in javafx.animation that return types with arguments of type Animation
      Modifier and Type 方法 描述
      ObservableList<Animation> ParallelTransition.getChildren​()
      将按顺序播放的Animations的列表。
      ObservableList<Animation> SequentialTransition.getChildren​()
      将按顺序播放Animations的列表。
      Constructors in javafx.animation with parameters of type Animation
      Constructor 描述
      ParallelTransition​(Animation... children)
      构造函数为 ParallelTransition 。
      ParallelTransition​(Node node, Animation... children)
      构造函数为 ParallelTransition 。
      SequentialTransition​(Animation... children)
      构造函数为 SequentialTransition 。
      SequentialTransition​(Node node, Animation... children)
      构造函数为 SequentialTransition 。

    • Uses of Animation in javafx.scene.chart

      Methods in javafx.scene.chart with parameters of type Animation
      Modifier and Type 方法 描述
      protected void Chart.animate​(Animation animation)
      在动画完成后，在图形的每一帧上播放给定的动画图表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.Animation.Status (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.Animation.Status

  • Packages that use Animation.Status
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。

    • Uses of Animation.Status in javafx.animation

      Methods in javafx.animation that return Animation.Status
      Modifier and Type 方法 描述
      Animation.Status Animation.getStatus​()
      获取属性状态的值。
      static Animation.Status Animation.Status.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Animation.Status[] Animation.Status.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.animation that return types with arguments of type Animation.Status
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Animation.Status> Animation.statusProperty​()
      的状态 Animation 。
      Methods in javafx.animation with parameters of type Animation.Status
      Modifier and Type 方法 描述
      protected void Animation.setStatus​(Animation.Status value)
      设置属性状态的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.AnimationTimer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.AnimationTimer

No usage of javafx.animation.AnimationTimer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.FadeTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.FadeTransition

No usage of javafx.animation.FadeTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.FillTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.FillTransition

No usage of javafx.animation.FillTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.Interpolator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.Interpolator

  • Packages that use Interpolator
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。

    • Uses of Interpolator in javafx.animation

      Fields in javafx.animation declared as Interpolator
      Modifier and Type Field 描述
      static Interpolator Interpolator.DISCRETE
      内置插值器，提供离散时间插值。
      static Interpolator Interpolator.EASE_BOTH
      内置插件器实例，提供简单的输入/输出行为。
      static Interpolator Interpolator.EASE_IN
      内置插件器实例，提供行为方便。
      static Interpolator Interpolator.EASE_OUT
      内置interpolator实例，提供轻松的行为。
      static Interpolator Interpolator.LINEAR
      内置插值器，提供线性时间插值。
      Methods in javafx.animation that return Interpolator
      Modifier and Type 方法 描述
      protected Interpolator Transition.getCachedInterpolator​()
      返回Interpolator ，当Transition启动时设置。
      Interpolator KeyValue.getInterpolator​()
      Interpolator用于计算沿特定间隔的键值。
      Interpolator Transition.getInterpolator​()
      获取属性interpolator的值。
      static Interpolator Interpolator.SPLINE​(double x1, double y1, double x2, double y2)
      创建一个 Interpolator ，其 curve()使用由（定义样条控制点状 x1 ， y1 ）和（ x2 ， y2 ）。
      static Interpolator Interpolator.TANGENT​(Duration t, double v)
      创建切线内插器，切线和切线相同。
      static Interpolator Interpolator.TANGENT​(Duration t1, double v1, Duration t2, double v2)
      创建切线插值器。
      Methods in javafx.animation that return types with arguments of type Interpolator
      Modifier and Type 方法 描述
      ObjectProperty<Interpolator> Transition.interpolatorProperty​()
      控制每个 Transition循环的加速和减速时序。
      Methods in javafx.animation with parameters of type Interpolator
      Modifier and Type 方法 描述
      void Transition.setInterpolator​(Interpolator value)
      设置属性interpolator的值。
      Constructors in javafx.animation with parameters of type Interpolator
      Constructor 描述
      KeyValue​(WritableValue<T> target, T endValue, Interpolator interpolator)
      创建一个 KeyValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.KeyFrame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.KeyFrame

  • Packages that use KeyFrame
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。

    • Uses of KeyFrame in javafx.animation

      Methods in javafx.animation that return types with arguments of type KeyFrame
      Modifier and Type 方法 描述
      ObservableList<KeyFrame> Timeline.getKeyFrames​()
      返回此Timeline的Timeline 。
      Constructors in javafx.animation with parameters of type KeyFrame
      Constructor 描述
      Timeline​(double targetFramerate, KeyFrame... keyFrames)
      构造函数为 Timeline 。
      Timeline​(KeyFrame... keyFrames)
      构造函数为 Timeline 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.KeyValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.KeyValue

  • Packages that use KeyValue
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。

    • Uses of KeyValue in javafx.animation

      Methods in javafx.animation that return types with arguments of type KeyValue
      Modifier and Type 方法 描述
      Set<KeyValue> KeyFrame.getValues​()
      返回一个不可变Set的KeyValue实例。
      Constructors in javafx.animation with parameters of type KeyValue
      Constructor 描述
      KeyFrame​(Duration time, String name, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      Constructor parameters in javafx.animation with type arguments of type KeyValue
      Constructor 描述
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      Constructor of KeyFrame
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.ParallelTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.ParallelTransition

No usage of javafx.animation.ParallelTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.PathTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.PathTransition

No usage of javafx.animation.PathTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.PathTransition.OrientationType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.PathTransition.OrientationType

  • Packages that use PathTransition.OrientationType
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。

    • Uses of PathTransition.OrientationType in javafx.animation

      Methods in javafx.animation that return PathTransition.OrientationType
      Modifier and Type 方法 描述
      PathTransition.OrientationType PathTransition.getOrientation​()
      获取属性方向的值。
      static PathTransition.OrientationType PathTransition.OrientationType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PathTransition.OrientationType[] PathTransition.OrientationType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.animation that return types with arguments of type PathTransition.OrientationType
      Modifier and Type 方法 描述
      ObjectProperty<PathTransition.OrientationType> PathTransition.orientationProperty​()
      指定 node沿 path的直立方向。
      Methods in javafx.animation with parameters of type PathTransition.OrientationType
      Modifier and Type 方法 描述
      void PathTransition.setOrientation​(PathTransition.OrientationType value)
      设置属性方向的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.PauseTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.PauseTransition

No usage of javafx.animation.PauseTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.RotateTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.RotateTransition

No usage of javafx.animation.RotateTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.ScaleTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.ScaleTransition

No usage of javafx.animation.ScaleTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.SequentialTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.SequentialTransition

No usage of javafx.animation.SequentialTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.StrokeTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.StrokeTransition

No usage of javafx.animation.StrokeTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.Timeline (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.Timeline

No usage of javafx.animation.Timeline
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.Transition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.Transition

  • Packages that use Transition
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。

    • Uses of Transition in javafx.animation

      Subclasses of Transition in javafx.animation
      Modifier and Type Class 描述
      class  FadeTransition
      这个 Transition创建了一个跨越其 duration的褪色效果动画。
      class  FillTransition
      此 Transition创建一个动画，可以更改 duration中的形状填充。
      class  ParallelTransition
      这Transition剧目Animations并行。
      class  PathTransition
      这个 Transition创建了一个跨越其 PathTransition.duration的路径动画。
      class  PauseTransition
      这 Transition在其 PauseTransition.duration的末尾执行一个 Animation.onFinished 。
      class  RotateTransition
      此 Transition创建一个旋转动画，涵盖其 duration 。
      class  ScaleTransition
      这个 Transition创建了一个尺度动画，涵盖其 ScaleTransition.duration 。
      class  SequentialTransition
      这Transition剧目Animations顺序排列。
      class  StrokeTransition
      此 Transition创建一个动画，可以更改 duration中的形状的笔触颜色。
      class  TranslateTransition
      这个 Transition创建了一个跨越其 TranslateTransition.duration的移动/翻译动画。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.animation.TranslateTransition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.animation.TranslateTransition

No usage of javafx.animation.TranslateTransition
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.animation.Interpolatable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.animation.Interpolatable

  • Packages that use Interpolatable
    软件包 描述
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

    • Uses of Interpolatable in javafx.scene.paint

      Classes in javafx.scene.paint that implement Interpolatable
      Modifier and Type Class 描述
      class  Color
      Color类用于将颜色封装在默认的sRGB颜色空间中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Application (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Class Application

  • java.lang.Object
    • javafx.application.Application
  • 已知直接子类：
    Preloader

    public abstract class Application
extends Object
    JavaFX应用程序扩展的应用程序类。

    生命周期

    JavaFX应用程序的入口点是Application类。 无论何时启动应用程序，JavaFX运行时都会按顺序执行以下操作：

    1. 启动JavaFX运行时，如果尚未启动（有关详细信息，请参阅Platform.startup(Runnable) ）
    2. 构造指定的Application类的实例
    3. 调用init()方法
    4. 调用start(javafx.stage.Stage)方法
    5. 等待应用程序完成，发生以下任一情况时：
      • 应用程序调用Platform.exit()
      • 最后一个窗口已关闭， implicitExit属性为Platform
    6. 调用stop()方法

    请注意， start方法是抽象的，必须被覆盖。 init和stop方法具有不做任何事情的具体实现。

    Application子类必须声明为public，并且必须有一个public no-argument构造函数。

    调用Platform.exit()是明确终止JavaFX应用程序的首选方式。 直接拨打System.exit(int)是可以接受的替代方案，但不允许应用程序运行stop() 。

    在FX工具包终止或ShutdownHook之后，即在stop()方法返回或调用System.exit(int)之后，JavaFX应用程序不应尝试使用JavaFX。

    将应用程序部署为模块

    如果Application子类在命名模块中，则该类必须可以访问javafx.graphics模块。 否则，在启动应用程序时将抛出异常。 这意味着除了该类本身被声明为公开外，该模块必须至少包含javafx.graphics模块的export （或open ）包含的包。

    例如，如果com.foo.MyApplication在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { exports com.foo to javafx.graphics; }

    参数

    应用参数都可以通过调用getParameters()从方法init()方法，或之后的任何时间init方法被调用。

    穿线

    JavaFX创建一个应用程序线程，用于运行应用程序启动方法，处理输入事件和运行动画时间轴。 必须在JavaFX应用程序线程上创建JavaFX Scene和Stage对象以及将场景图操作修改为活动对象（已连接到场景的对象）。

    Java启动器在JavaFX应用程序线程上加载并初始化指定的应用程序类。 如果Application类中没有主方法，或者主方法调用Application.launch（）方法，则在JavaFX Application Thread上构建Application的实例。

    在启动器线程上调用init方法，而不是在JavaFX应用程序线程上。 这意味着，应用程序必须不能构建一个Scene或Stage在init方法。 应用程序可以在init方法中构建其他JavaFX对象。

    在事件分派，运行动画时间轴或任何其他代码中发生的JavaFX应用程序线程上的所有未处理的异常都将转发到线程的uncaught exception handler 。

    例

    以下示例将说明一个简单的JavaFX应用程序。

       import javafx.application.Application; import javafx.scene.Group; import javafx.scene.Scene; import javafx.scene.shape.Circle; import javafx.stage.Stage; public class MyApp extends Application { public void start(Stage stage) { Circle circ = new Circle(40, 40, 30); Group root = new Group(circ); Scene scene = new Scene(root, 400, 300); stage.setTitle("My JavaFX Application"); stage.setScene(scene); stage.show(); } }

    以上示例将产生以下内容：

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Platform

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Application.Parameters
      封装一组应用程序的参数。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String STYLESHEET_CASPIAN
      用于“Caspian”主题的用户代理样式表的常量。
      static String STYLESHEET_MODENA
      用于“Modena”主题的用户代理样式表的常量。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Application​()
      构造一个新的 Application实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      HostServices getHostServices​()
      获取此应用程序的HostServices提供程序。
      Application.Parameters getParameters​()
      检索此应用程序的参数，包括在命令行上传递的任何参数以及Applet或WebStart应用程序的JNLP文件中指定的任何参数。
      static String getUserAgentStylesheet​()
      获取整个应用程序使用的用户代理样式表。
      void init​()
      应用程序初始化方法。
      static void launch​(Class<? extends Application> appClass, String... args)
      启动独立应用程序。
      static void launch​(String... args)
      启动独立应用程序。
      void notifyPreloader​(Preloader.PreloaderNotification info)
      通过应用程序生成的通知通知预加载器。
      static void setUserAgentStylesheet​(String url)
      设置整个应用程序使用的用户代理样式表。
      abstract void start​(Stage primaryStage)
      所有JavaFX应用程序的主要入口点。
      void stop​()
      当应用程序停止时，调用此方法，并为应用程序退出和销毁资源提供了便利的场所。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • STYLESHEET_CASPIAN

        public static final String STYLESHEET_CASPIAN
        用于“Caspian”主题的用户代理样式表的常量。 Caspian是JavaFX 2.x中默认发行的主题。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Constant Field Values

      • STYLESHEET_MODENA

        public static final String STYLESHEET_MODENA
        用于“Modena”主题的用户代理样式表的常量。 Modena是JavaFX 8.x的默认主题。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Application

        public Application​()
        构造一个新的 Application实例。

    • 方法详细信息

      • launch

        public static void launch​(Class<? extends Application> appClass,
                          String... args)
        启动独立应用程序。 这个方法通常从main（）方法调用。 它不能多次被调用，或者抛出异常。

        通过调用Platform.exit或所有应用程序窗口都已关闭，启动方法不会返回，直到应用程序退出。 由指定的类appClass参数必须是一个公共子类Application与公共无参数构造，在一个包，是exported （或open ）到至少javafx.graphics模块，或一个RuntimeException将被抛出。

        典型用途是：

          public static void main(String[] args) {
         Application.launch(MyApp.class, args);
     }
        其中MyApp是Application的子类。
        参数
        appClass - 由启动器构建和执行的应用程序类。
        args - 传递给应用程序的命令行参数。 应用程序可以使用getParameters()方法获取这些参数。
        异常
        IllegalStateException - 如果这个方法被调用不止一次。
        IllegalArgumentException -如果 appClass不是一个子类 Application 。
        RuntimeException - 如果启动JavaFX运行时出现错误，或者无法构造应用程序类（例如，如果类不是公开的或不在导出的包中），或者由Application构造函数抛出异常或错误，init方法，start方法或stop方法。

      • launch

        public static void launch​(String... args)
        启动独立应用程序。 这个方法通常从main（）方法调用。 它不能多次被调用，或者抛出异常。 这相当于launch(TheClass.class, args) ，其中TheClass是即时封闭类的方法，称为启动。 它必须是Application的公共子类， Application包含公开无参数构造函数，至少为javafx.graphics模块的包为exported （或open ），否则将抛出RuntimeException。

        通过调用Platform.exit或所有应用程序窗口都已关闭，启动方法不会返回，直到应用程序退出。

        典型用途是：

          public static void main(String[] args) {
         Application.launch(args);
     }
        参数
        args - 传递给应用程序的命令行参数。 应用程序可以使用getParameters()方法获取这些参数。
        异常
        IllegalStateException - 如果这种方法被多次调用。
        RuntimeException - 如果启动JavaFX运行时出错，或者无法构造应用程序类（例如，如果类不是公开的或不在导出的包中），或者由Application构造函数抛出异常或错误，init方法，start方法或stop方法。

      • init

        public void init​()
          throws 异常
        应用程序初始化方法。 在加载和构造Application类之后立即调用此方法。 应用程序可能会覆盖此方法，以在实际启动应用程序之前执行初始化。

        应用程序类提供的这种方法的实现什么都不做。

        注意：此方法不在JavaFX应用程序线程上调用。 应用程序不得在此方法中构造场景或舞台。 应用程序可以在此方法中构建其他JavaFX对象。

        异常
        异常 - 如果出现问题

      • start

        public abstract void start​(Stage primaryStage)
                    throws 异常
        所有JavaFX应用程序的主要入口点。 在init方法返回后，系统准备好应用程序开始运行之后调用start方法。

        注意：此方法在JavaFX应用程序线程上调用。

        参数
        primaryStage - 此应用程序的主要阶段，可以设置应用程序场景。 如果应用程序作为一个小程序启动，主阶段将嵌入到浏览器中。 如果需要，应用程序可能会创建其他阶段，但不会成为主要阶段，也不会嵌入在浏览器中。
        异常
        异常 - 如果出现问题

      • stop

        public void stop​()
          throws 异常
        当应用程序停止时，调用此方法，并为应用程序退出和销毁资源提供了便利的场所。

        应用程序类提供的这种方法的实现什么都不做。

        注意：此方法在JavaFX应用程序线程上调用。

        异常
        异常 - 如果出现问题

      • getHostServices

        public final HostServices getHostServices​()
        获取此应用程序的HostServices提供程序。 这提供了获取此应用程序的代码库和文档库以及访问封闭网页的功能。
        结果
        HostServices提供商

      • getParameters

        public final Application.Parameters getParameters​()
        检索此应用程序的参数，包括在命令行上传递的任何参数以及Applet或WebStart应用程序的JNLP文件中指定的任何参数。

        注意：该方法不应该从Application构造函数调用，因为它将返回null。 它可以在init（）方法中或之后的任何时间调用。

        结果
        此应用程序的参数，如果从构造函数调用，则为null。

      • notifyPreloader

        public final void notifyPreloader​(Preloader.PreloaderNotification info)
        通过应用程序生成的通知通知预加载器。 应用程序代码使用PreloaderNotification调用此方法，并将其传递给Preloader.handleApplicationNotification方法。 这对于应用程序希望预加载程序在长应用程序初始化步骤期间显示进度的情况主要有用。

        注意：通知只会传递给预加载器的handleApplicationNotification（）方法; 这意味着，例如，如果使用ProgressNotification调用此方法，该通知将不会传递到Preloader.handleProgressNotification方法。

        参数
        info - 应用程序生成的预加载程序通知

      • getUserAgentStylesheet

        public static String getUserAgentStylesheet​()
        获取整个应用程序使用的用户代理样式表。 这用于为所有ui控件和其他节点提供默认样式。 值为null表示正在使用平台默认样式表。

        注意：必须在JavaFX应用程序线程上调用此方法。

        结果
        作为字符串的样式表的URL。
        从以下版本开始：
        JavaFX 8.0

      • setUserAgentStylesheet

        public static void setUserAgentStylesheet​(String url)
        设置整个应用程序使用的用户代理样式表。 这用于为所有ui控件和其他节点提供默认样式。 每个版本的JavaFX可能都有一个新的默认值，所以如果你需要保证一致性，你需要调用这个方法，并选择你想要的应用程序的默认值。 null值将恢复平台默认样式表。 也可以在命令行上设置此属性，其中-Djavafx.userAgentStylesheetUrl=[URL]在命令行中设置它将覆盖在代码中使用此方法设置的任何内容。

        注意：必须在JavaFX应用程序线程上调用此方法。

        参数
        url - 样式表的URL作为字符串。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Application.Parameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Class Application.Parameters

  • java.lang.Object
    • javafx.application.Application.Parameters
  • Enclosing class:
    Application

    public abstract static class Application.Parameters
extends Object
    封装一组应用程序的参数。 这包括在命令行上传递的参数，JNLP文件中指定的未命名参数以及JNLP文件中指定的<name，value>对。

    请注意，应用程序和预加载程序都为应用程序的给定运行获得相同的参数集。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      Parameters​()
      构造一个新的 Parameters实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Map<String,String> getNamed​()
      检索命名参数的只读映射。
      abstract List<String> getRaw​()
      检索原始参数的只读列表。
      abstract List<String> getUnnamed​()
      检索未命名参数的只读列表。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Parameters

        public Parameters​()
        构造一个新的 Parameters实例。

    • 方法详细信息

      • getRaw

        public abstract List<String> getRaw​()
        检索原始参数的只读列表。 此列表可能为空，但从不为空。 在独立应用程序的情况下，它是在命令行中指定的参数的有序列表。 在applet或WebStart应用程序的情况下，它包括未命名参数以及命名参数。 对于命名参数，每个<name，value>对表示为以下形式的单个参数：“--name = value”。
        结果
        原始应用程序参数的只读列表

      • getUnnamed

        public abstract List<String> getUnnamed​()
        检索未命名参数的只读列表。 此列表可能为空，但从不为空。 命名参数，即表示为<name，value>对的参数被过滤掉。
        结果
        一个未命名参数的只读列表。

      • getNamed

        public abstract Map<String,String> getNamed​()
        检索命名参数的只读映射。 它可能是空的，但从不为空。 命名参数包括在JNLP文件中明确指定的那些<name，value>对。 它还包括以下形式的任何命令行参数：“--name = value”。
        结果
        一个名为参数的只读地图。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConditionalFeature (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Enum ConditionalFeature

  • java.lang.Object
    • java.lang.Enum<ConditionalFeature>
      • javafx.application.ConditionalFeature
  • All Implemented Interfaces:
    Serializable ， Comparable<ConditionalFeature>

    public enum ConditionalFeature
extends Enum<ConditionalFeature>
    定义一组条件（可选）功能。 这些功能可能在所有平台上都不可用。 想知道特定功能是否可用的应用程序可以使用Platform.isSupported()函数查询。 在不支持它的平台上使用条件功能不会引起异常。 一般来说，条件特征将被忽略。 有关详细信息，请参阅每个功能的文档。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CONTROLS
      表示在此平台上提供了提供UI控件的JavaFX类。
      EFFECT
      表示平台上可以使用过滤效果。
      FXML
      表示XML库存在于JRE中，FXML API在平台上可用。
      GRAPHICS
      表示在此平台上提供了提供图形功能的JavaFX类。
      INPUT_METHOD
      表示文本输入法在平台上可用。
      INPUT_MULTITOUCH
      指示提供多点触摸输入的触摸屏是否连接到运行JavaFX的设备上。
      INPUT_POINTER
      指示是否附加了诸如鼠标，触控板或轨迹球的相对运动指针装置。
      INPUT_TOUCH
      指示触摸屏是否连接到运行JavaFX的设备上。
      MEDIA
      表示javafx.scene.media包在此平台上可用。
      SCENE3D
      表示3D在平台上可用。
      SHAPE_CLIP
      表示在平台上可以使用任意形状的剪辑。
      SWING
      表示Swing库存在于Java运行时环境中，并且Swing与JavaFX的集成在该平台上可用。
      SWT
      表示SWT集成在平台上可用。
      TRANSPARENT_WINDOW
      表示系统支持完整的窗口透明度。
      TWO_LEVEL_FOCUS
      指示控件是否应使用两级焦点。
      UNIFIED_WINDOW
      表示系统支持 StageStyle.UNIFIED
      VIRTUAL_KEYBOARD
      指示是否使用屏幕上的虚拟键盘进行文本输入。
      WEB
      表示此平台上可用的javafx.scene.web软件包。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ConditionalFeature valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ConditionalFeature[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • GRAPHICS

        public static final ConditionalFeature GRAPHICS
        表示在此平台上提供了提供图形功能的JavaFX类。
        从以下版本开始：
        JavaFX 8.0

      • CONTROLS

        public static final ConditionalFeature CONTROLS
        表示在此平台上提供了提供UI控件的JavaFX类。
        从以下版本开始：
        JavaFX 8.0

      • MEDIA

        public static final ConditionalFeature MEDIA
        表示javafx.scene.media包在此平台上可用。
        从以下版本开始：
        JavaFX 8.0

      • WEB

        public static final ConditionalFeature WEB
        表示此平台上可用的javafx.scene.web软件包。
        从以下版本开始：
        JavaFX 8.0

      • SWT

        public static final ConditionalFeature SWT
        表示SWT集成在平台上可用。 这测试SWT与JavaFX集成，但不测试是否存在完整的SWT库。
        从以下版本开始：
        JavaFX 8.0

      • SWING

        public static final ConditionalFeature SWING
        表示Swing库存在于Java运行时环境中，并且Swing与JavaFX的集成在该平台上可用。
        从以下版本开始：
        JavaFX 8.0

      • FXML

        public static final ConditionalFeature FXML
        表示XML库存在于JRE中，FXML API在平台上可用。 请注意，如果基础Java运行时环境没有XML支持，FXML API可能存在但不可用。 在这种情况下，Platform.isSupported（ConditionalFeature.FXML）将返回false。
        从以下版本开始：
        JavaFX 8.0

      • SCENE3D

        public static final ConditionalFeature SCENE3D
        表示3D在平台上可用。 如果应用程序尝试在不支持3D的平台上使用3D转换或3D相机，则忽略变换或相机; 它有效地成为身份转换。

      • EFFECT

        public static final ConditionalFeature EFFECT
        表示平台上可以使用过滤效果。 如果应用程序对不支持它的平台使用效果，该效果将被忽略。

      • SHAPE_CLIP

        public static final ConditionalFeature SHAPE_CLIP
        表示在平台上可以使用任意形状的剪辑。 如果应用程序在不支持任意形状的剪切的平台上指定剪辑节点，则节点将被剪裁到指定剪辑节点的边界，而不是其几何形状。

      • INPUT_METHOD

        public static final ConditionalFeature INPUT_METHOD
        表示文本输入法在平台上可用。 如果应用程序在不支持它的平台上指定输入法，那么输入法将被忽略。

      • TRANSPARENT_WINDOW

        public static final ConditionalFeature TRANSPARENT_WINDOW
        表示系统支持完整的窗口透明度。 在不支持透明窗口的平台上，透明窗口只能有限或没有功能。

        目前，除了没有XComposite扩展名的Linux系统之外，所有桌面平台都支持此支持。 在这种情况下使用XShape扩展，因此窗口边缘是混叠的。

        如果存在安全管理员，应用程序必须具有FXPermission “createTransparentWindow”才能创建一个透明窗口。 如果应用程序没有所需的权限，则无法使用此功能; 它将显示为平台不支持透明窗口，而Platform.isSupported(TRANSPARENT_WINDOW)将返回false 。

        从以下版本开始：
        JavaFX 2.2

      • UNIFIED_WINDOW

        public static final ConditionalFeature UNIFIED_WINDOW
        表示系统支持StageStyle.UNIFIED

        注意：目前支持：

        • Windows Vista +：一个窗口完全充满了冻结的玻璃效果
        • Mac OS X：一个窗口有拉丝金属纹理的背景
        从以下版本开始：
        JavaFX 8.0

      • TWO_LEVEL_FOCUS

        public static final ConditionalFeature TWO_LEVEL_FOCUS
        指示控件是否应使用两级焦点。 两级重点是在某些控件中需要单独的操作以首先输入控件，然后对控件执行操作。 在提供方向箭头键和选择键但不提供用于在一个控件和另一个控件之间导航的键的设备上需要两级焦点。 在这些设备上，集中的控制可能是内部聚焦的 - 在这种情况下，箭头键可以在控制上进行操作，也可以在外部进行对焦，在这种情况下，箭头键用于将焦点导向其他控件。

        在嵌入式平台上，JavaFX尝试根据附加的外设进行初始化此条件特征。 在桌面平台上，ConditionalFeature通常默认为false。

        从以下版本开始：
        JavaFX 8.0

      • VIRTUAL_KEYBOARD

        public static final ConditionalFeature VIRTUAL_KEYBOARD
        指示是否使用屏幕上的虚拟键盘进行文本输入。

        在嵌入式平台上，JavaFX尝试根据附加的外设进行初始化此条件特征。 在桌面平台上，ConditionalFeature通常默认为false。

        从以下版本开始：
        JavaFX 8.0

      • INPUT_TOUCH

        public static final ConditionalFeature INPUT_TOUCH
        指示触摸屏是否连接到运行JavaFX的设备上。

        在嵌入式平台上，JavaFX尝试根据附加的外设进行初始化此条件特征。 在桌面平台上，ConditionalFeature通常默认为false。

        从以下版本开始：
        JavaFX 8.0

      • INPUT_MULTITOUCH

        public static final ConditionalFeature INPUT_MULTITOUCH
        指示提供多点触摸输入的触摸屏是否连接到运行JavaFX的设备上。

        在嵌入式平台上，JavaFX尝试根据附加的外设进行初始化此条件特征。 在桌面平台上，ConditionalFeature通常默认为false。

        如果INPUT_MULTITOUCH可用，则INPUT_TOUCH也可用。

        从以下版本开始：
        JavaFX 8.0

      • INPUT_POINTER

        public static final ConditionalFeature INPUT_POINTER
        指示是否附加了诸如鼠标，触控板或轨迹球的相对运动指针装置。

        在嵌入式平台上，JavaFX尝试根据附加的外设进行初始化此条件特征。 在桌面平台上，ConditionalFeature通常默认为true。

        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • values

        public static ConditionalFeature[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ConditionalFeature c : ConditionalFeature.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ConditionalFeature valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


HostServices (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Class HostServices

  • java.lang.Object
    • javafx.application.HostServices

  • public final class HostServices
extends Object
    此类为应用程序提供HostServices。 这包括获取应用程序的代码库和文档库，在浏览器中显示网页以及如果应用程序在浏览器中运行时使用JavaScript与封闭网页进行通信的方法。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      String getCodeBase​()
      获取此应用程序的代码库URI。
      String getDocumentBase​()
      获取此应用程序的文档基础URI。
      JSObject getWebContext​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此方法自JDK 9起已被弃用，因为不推荐使用Applet API。
      String resolveURI​(String base, String rel)
      根据基本URI解析指定的相对URI并返回已解析的URI。
      void showDocument​(String uri)
      在新的浏览器窗口或选项卡中打开指定的URI。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getCodeBase

        public final String getCodeBase​()
        获取此应用程序的代码库URI。 如果应用程序是通过JNLP文件启动的，则此方法返回JNLP文件中指定的代码库参数。 如果应用程序是以独立模式启动的，则此方法返回包含应用程序jar文件的目录。 如果应用程序未打包在jar文件中，则此方法返回空字符串。
        结果
        该应用程序的代码库URI。

      • getDocumentBase

        public final String getDocumentBase​()
        获取此应用程序的文档基础URI。 如果应用程序嵌入在浏览器中，则此方法返回包含应用程序的网页的URI。 如果应用程序是以webstart模式启动的，则该方法返回JNLP文件中指定的代码库参数（文档基础和代码库在此模式下相同）。 如果应用程序以独立模式启动，则此方法返回当前目录的URI。
        结果
        该应用程序的文档基础URI。

      • resolveURI

        public final String resolveURI​(String base,
                               String rel)
        根据基本URI解析指定的相对URI并返回已解析的URI。

        例：

          HostServices services = getHostServices();
     String myImage = services.resolveURI(services.getDocumentBase(),
                                          "image.jpg");
     Image image = new Image(myImage);
        参数
        base - 解析相对URI的基本URI
        rel - 要解析的相对URI
        结果
        完全解析的URI。
        异常
        NullPointerException - 如果 base或 rel字符串为空。
        IllegalArgumentException - 如果解析 base或 rel URI字符串时出现错误，或者解析URI时是否存在其他错误。

      • showDocument

        public final void showDocument​(String uri)
        在新的浏览器窗口或选项卡中打开指定的URI。 浏览器首选项将决定是否是新浏览器窗口或现有浏览器窗口中的选项卡。 请注意，这将尊重默认浏览器的弹出窗口阻止程序设置; 它不会试图规避他们。
        参数
        uri - 将在浏览器中打开的网页的URI。

      • getWebContext

        @Deprecated(since="9",
            forRemoval=true)
public final JSObject getWebContext​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 自JDK 9 以来，此方法已被弃用，因为不推荐使用27065609772816 API。
        返回包含此应用程序的网页的封闭DOM窗口的JavaScript句柄。 该句柄用于通过从Java调用JavaScript来访问网页。 如果应用程序未嵌入到网页中，则此方法返回null。

        例：

           JSObject jsWin = getHostServices().getWebContext(); if (jsWin != null) { jsWin.eval("var b = document.body;" + "var newdiv = document.createElement('div');" + "newdiv.innerHTML = '<br>Hello from JavaScript!';" + "b.appendChild(newdiv);"); }
        结果
        包含此应用程序的网页的封闭DOM窗口的句柄
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.application (Java SE 9 & JDK 9 )

javafx.application

Interfaces

  • Preloader.PreloaderNotification

Classes

  • Application
  • Application.Parameters
  • HostServices
  • Platform
  • Preloader
  • Preloader.ErrorNotification
  • Preloader.ProgressNotification
  • Preloader.StateChangeNotification

Enums

  • ConditionalFeature
  • Preloader.StateChangeNotification.Type


javafx.application (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.application

提供应用程序生命周期类。

Application类是JavaFX应用程序扩展的主要类。

  • 接口摘要
    接口 描述
    Preloader.PreloaderNotification
    所有Preloader通知的标记界面。
  • 类摘要
    Class 描述
    Application
    JavaFX应用程序扩展的应用程序类。
    Application.Parameters
    封装一组应用程序的参数。
    HostServices
    此类为应用程序提供HostServices。
    Platform
    应用平台支持类。
    Preloader
    扩展定义JavaFX应用程序的可选预加载器的类。
    Preloader.ErrorNotification
    报告错误的预加载程序通知。
    Preloader.ProgressNotification
    报告进度的预加载程序通知。
    Preloader.StateChangeNotification
    发出申明状态更改的通知。
  • 枚举摘要
    Enum 描述
    ConditionalFeature
    定义一组条件（可选）功能。
    Preloader.StateChangeNotification.Type
    枚举，定义与此通知相关联的更改类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.application Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.application

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.application.Application
      • javafx.application.Preloader
    • javafx.application.Application.Parameters
    • javafx.application.HostServices
    • javafx.application.Platform
    • javafx.application.Preloader.ErrorNotification (implements javafx.application.Preloader.PreloaderNotification)
    • javafx.application.Preloader.ProgressNotification (implements javafx.application.Preloader.PreloaderNotification)
    • javafx.application.Preloader.StateChangeNotification (implements javafx.application.Preloader.PreloaderNotification)

Interface Hierarchy

  • javafx.application.Preloader.PreloaderNotification

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.application.ConditionalFeature
      • javafx.application.Preloader.StateChangeNotification.Type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Platform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Class Platform

  • java.lang.Object
    • javafx.application.Platform

  • public final class Platform
extends Object
    应用平台支持类。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      static ReadOnlyBooleanProperty accessibilityActive
      指示辅助功能是否处于活动状态。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ReadOnlyBooleanProperty accessibilityActiveProperty​()
      指示辅助功能是否处于活动状态。
      static Object enterNestedEventLoop​(Object key)
      输入嵌套事件循环并阻塞，直到相应的exitNestedEventLoop调用被创建为止。
      static void exit​()
      导致JavaFX应用程序终止。
      static void exitNestedEventLoop​(Object key, Object rval)
      退出一个嵌套事件循环并解除对应的enterNestedEventLoop的调用者的阻塞。
      static boolean isAccessibilityActive​()
      获取属性accessibilityActive的值。
      static boolean isFxApplicationThread​()
      如果调用线程是JavaFX应用程序线程，则返回true。
      static boolean isImplicitExit​()
      获取implicitExit属性的值。
      static boolean isNestedLoopRunning​()
      检查嵌套事件循环是否正在运行，如果没有嵌套事件循环当前正在运行，则返回true以指示一个为true;如果为false。
      static boolean isSupported​(ConditionalFeature feature)
      查询平台是否支持特定条件功能。
      static void requestNextPulse​()
      请求Java运行时执行脉冲。
      static void runLater​(Runnable runnable)
      在将来某些未指定的时间运行JavaFX应用程序线程上指定的Runnable。
      static void setImplicitExit​(boolean implicitExit)
      将implicitExit属性设置为指定的值。
      static void startup​(Runnable runnable)
      此方法启动JavaFX运行时。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • accessibilityActive

        public static ReadOnlyBooleanProperty accessibilityActiveProperty
        指示辅助功能是否处于活动状态。 该属性通常在第一次辅助技术（如屏幕阅读器）请求关于任何JavaFX窗口或其子项的信息时设置为true。

        可以从任何线程调用此方法。

        从以下版本开始：
        JavaFX 8u40
        另请参见：
        isAccessibilityActive()

    • 方法详细信息

      • startup

        public static void startup​(Runnable runnable)
        此方法启动JavaFX运行时。 然后在JavaFX应用程序线程上调用指定的Runnable。 一般来说，没有必要显式调用此方法，因为它是由于大多数JavaFX应用程序的构建而被调用的。 但是有直接调用此方法的有效用例。 因为这种方法启动JavaFX运行时，所以还没有任何JavaFX应用程序线程，所以这个方法直接在应用程序的主线程上被调用是很正常的。

        在调用指定的Runnable的run方法之前，此方法可能也可能不会返回给调用者。 无论如何，一旦该方法返回，您可以使用附加的Runnables来调用runLater(Runnable) 。 那些Runnables将被调用，也在JavaFX应用程序线程上，Runnable传入这个方法后被调用。

        如上所述，通常情况下JavaFX应用程序线程将自动启动。 只有当JavaFX运行时尚未初始化时，才能调用此方法。 自动启动JavaFX运行时的情况包括：

        • 对于扩展Application的标准JavaFX应用程序，并且使用Java启动器或Application类中的启动方法之一启动应用程序，FX运行时将在加载Application类之前由启动器自动初始化。
        • 对于使用JFXPanel显示FX内容的Swing应用程序，当构建第一个JFXPanel实例时，FX运行时将被初始化。
        • 对于使用FXCanvas显示FX内容的SWT应用程序，当构建第一个FXCanvas实例时，FX运行时将被初始化。

        当应用程序不遵循这些常见方法时，开发人员有责任通过调用此启动方法手动启动JavaFX运行时。

        当JavaFX运行时已经在运行时调用此方法将导致抛出一个IllegalStateException - 仅仅要求JavaFX运行时启动一次才有效。

        参数
        runnable - 运行方法将在JavaFX应用程序主题一旦被启动后执行的Runnable
        异常
        IllegalStateException - 如果JavaFX运行时已经在运行
        从以下版本开始：
        9
        另请参见：
        Application

      • runLater

        public static void runLater​(Runnable runnable)
        在将来某些未指定的时间运行JavaFX应用程序线程上指定的Runnable。 可以从任何线程调用此方法，将Runnable发布到事件队列，然后立即返回给调用者。 Runnables按照它们发布的顺序执行。 传递给runLater方法的runnable将在任何Runnable传递给随后的runLater调用之前执行。 如果在JavaFX运行时关闭后调用此方法，则调用将被忽略：Runnable将不会被执行，也不会抛出任何异常。

        注意：应用程序应避免泛滥JavaFX与太多待处理的Runnables。 否则，应用程序可能无响应。 鼓励应用程序将多个操作批量更少的runLater调用。 另外，长时间运行的操作应该在可能的后台线程上完成，释放JavaFX应用程序线程进行GUI操作。

        在FX运行时初始化之前，不能调用此方法。 对于扩展Application的标准JavaFX应用程序，并使用Java启动器或Application类中的启动方法之一启动应用程序，FX运行时将在启动应用程序类之前由启动程序初始化。 对于使用JFXPanel显示FX内容的Swing应用程序，在构建第一个JFXPanel实例时，会初始化FX运行时。 对于使用FXCanvas显示FX内容的SWT应用程序，当构建第一个FXCanvas实例时，FX运行时将被初始化。 对于不遵循这些方法的应用程序，则需要通过调用startup(Runnable)一次手动启动JavaFX运行时。

        参数
        runnable - 运行方法将在JavaFX应用程序线程上执行的Runnable
        异常
        IllegalStateException - 如果FX运行时尚未初始化
        另请参见：
        Application

      • requestNextPulse

        public static void requestNextPulse​()
        请求Java运行时执行脉冲。 即使没有动画定时器，场景图修改或否则会导致脉冲运行的窗口事件，这将运行一个脉冲。 如果没有脉冲正在进行，则下一次脉冲定时器触发时，将调度一个脉冲。 如果已经有脉冲运行，那么在当前脉冲之后至少再有一个脉冲将被调度。 可以在任何线程上调用此方法。
        从以下版本开始：
        9

      • isFxApplicationThread

        public static boolean isFxApplicationThread​()
        如果调用线程是JavaFX应用程序线程，则返回true。 使用此调用确保在JavaFX应用程序线程上执行（或未执行）给定的任务。
        结果
        如果在JavaFX应用程序主题上运行，则为true

      • exit

        public static void exit​()
        导致JavaFX应用程序终止。 如果在调用Application start方法后调用此方法，则JavaFX启动程序将调用Application stop方法并终止JavaFX应用程序线程。 然后启动线程将关闭。 如果没有其他非守护进程线程正在运行，Java VM将退出。 如果从Preloader或Application init方法调用此方法，则可能无法调用Application stop方法。

        可以从任何线程调用此方法。

        注意：如果应用程序嵌入在浏览器中，则此方法可能不起作用。

      • setImplicitExit

        public static void setImplicitExit​(boolean implicitExit)
        将implicitExit属性设置为指定的值。 如果此属性为true，则JavaFX运行时将在最后一个窗口关闭时隐式关闭; JavaFX启动器将调用Application.stop()方法并终止JavaFX应用程序线程。 如果此属性为false，即使在最后一个窗口关闭后，应用程序仍将继续运行，直到应用程序调用exit() 。 默认值为true。

        可以从任何线程调用此方法。

        参数
        implicitExit - 指示当最后一个窗口关闭时是否隐式退出的标志。
        从以下版本开始：
        JavaFX 2.2

      • isImplicitExit

        public static boolean isImplicitExit​()
        获取implicitExit属性的值。

        可以从任何线程调用此方法。

        结果
        implicitExit属性
        从以下版本开始：
        JavaFX 2.2

      • isSupported

        public static boolean isSupported​(ConditionalFeature feature)
        查询平台是否支持特定条件功能。

        例如：

          // Query whether filter effects are supported
 if (Platform.isSupported(ConditionalFeature.EFFECT)) {
    // use effects
 }
        参数
        feature - 有问题的条件特征。
        结果
        如果平台支持特定条件功能，则为true，否则为false

      • enterNestedEventLoop

        public static Object enterNestedEventLoop​(Object key)
        输入嵌套事件循环并阻塞，直到相应的exitNestedEventLoop调用被创建为止。 传入此方法的密钥用于唯一标识匹配的输入/退出对。 此方法创建一个新的嵌套事件循环并阻塞，直到使用相同的键调用相应的exitNestedEventLoop方法。 此方法的返回值将是提供给exitNestedEventLoop方法调用的rval对象，该方法调用将解除阻塞。

        必须从输入事件处理程序或从Runnable的run方法传递给Platform.runLater调用此方法。 在动画或布局处理过程中不得调用它。

        参数
        key - 标识嵌套事件循环的对象，不能为null
        结果
        该值传递给对应的调用exitEventLoop
        异常
        IllegalArgumentException - 如果指定的键与尚未返回的嵌套事件循环相关联
        NullPointerException - 如果密钥为空
        IllegalStateException - 如果在动画或布局处理期间调用此方法。
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        从以下版本开始：
        9

      • exitNestedEventLoop

        public static void exitNestedEventLoop​(Object key,
                                       Object rval)
        退出一个嵌套事件循环并解除对应的enterNestedEventLoop的调用者的阻塞。 传入此方法的密钥用于唯一标识匹配的输入/退出对。 此方法导致先前使用键创建的嵌套事件循环退出并将控制权返回给调用者。 如果指定的嵌套事件循环不是最里面的循环，那么它将不会返回，直到所有其他内部循环也退出。
        参数
        key - 标识嵌套事件循环的对象，不能为null
        rval - 返回给相应enterNestedEventLoop的调用者的对象。 这可能是空的。
        异常
        IllegalArgumentException - 如果指定的键不与活动的嵌套事件循环相关联
        NullPointerException - 如果密钥为空
        IllegalStateException - 如果在除FX应用程序线程之外的线程上调用此方法
        从以下版本开始：
        9

      • isNestedLoopRunning

        public static boolean isNestedLoopRunning​()
        检查嵌套事件循环是否正在运行，如果没有嵌套事件循环当前正在运行，则返回true以指示一个为true;如果为false。 必须在JavaFX应用程序线程上调用此方法。
        结果
        如果有嵌套事件循环运行，则为true，否则为false。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        从以下版本开始：
        9

      • isAccessibilityActive

        public static boolean isAccessibilityActive​()
        获取属性accessibilityActive的值。
        Property description:
        指示辅助功能是否处于活动状态。 该属性通常在第一次辅助技术（如屏幕阅读器）请求关于任何JavaFX窗口或其子项的信息时设置为true。

        可以从任何线程调用此方法。

        从以下版本开始：
        JavaFX 8u40

      • accessibilityActiveProperty

        public static ReadOnlyBooleanProperty accessibilityActiveProperty​()
        指示辅助功能是否处于活动状态。 该属性通常在第一次辅助技术（如屏幕阅读器）请求关于任何JavaFX窗口或其子项的信息时设置为true。

        可以从任何线程调用此方法。

        从以下版本开始：
        JavaFX 8u40
        另请参见：
        isAccessibilityActive()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Preloader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Class Preloader

  • java.lang.Object
    • javafx.application.Application
      • javafx.application.Preloader

  • public abstract class Preloader
extends Application
    扩展定义JavaFX应用程序的可选预加载器的类。 应用程序可能包含预加载器，用于改进应用程序加载体验，特别是嵌入在浏览器中或在Web启动执行模式下启动的应用程序。

    预加载器是在主应用程序之前启动的一个小应用程序，用于定制启动体验。 预加载器：

    • 获取加载应用资源的进度通知
    • 获取错误通知
    • 获取应用程序初始化和启动的通知
    • 决定何时应用程序可见

    默认的预加载器显示在应用程序Stage的顶部，在预加载器可见之前，它不可见。 预加载器需要隐藏自身才能使应用程序可见。 好的做法是不要早于application.start（）被调用，否则应用程序本身不可见。

    预加载器还可以与应用协作以实现高级视觉效果或共享数据（例如，实现登录屏幕）。 预加载器获得对应用程序的引用，并且如果应用程序实现预加载程序知道并依赖的接口，则可以从应用程序中提取需要进行协作的数据。 通常不建议以这样的方式设计预加载器，使得应用程序可以直接调用它们，因为如果应用程序被签名并且预加载程序没有，这将导致糟糕的用户体验。

    如果应用程序没有指定预加载器，则使用默认的预加载器。 默认预加载器外观可以自定义（参数设置为TBD）。

    自定义预加载器实现应遵循以下规则：

    1. 应该有类扩展Preloader
    2. 预加载器所需的类需要打包在单独的jar中。 我们建议这个jar是无符号的。
    3. JNLP部署描述符应该具有预加载器类属性，该类的全名为javafx-desc元素中的值，进程需要的jar需要具有“进度”类型

    应用程序还可以使用notifyPreloader方法向预加载程序发送自定义通知。 这样一个预加载器也可以显示应用程序的初始化进度。

    请注意，预加载器受到与其他JavaFX应用程序相同的规则，包括FX线程规则。 特别是，在非FX线程上调用类构造函数和init（）方法，并且在FX应用程序线程上执行start（）。 这也意味着应用程序构造函数/ init（）将与preloader start（）同时运行。

    预加载器通知的回调将在FX应用程序线程上传递。

    关机（包括stop（）被调用）是TBD。

    从以下版本开始：
    JavaFX 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Preloader.ErrorNotification
      报告错误的预加载程序通知。
      static interface  Preloader.PreloaderNotification
      所有Preloader通知的标记界面。
      static class  Preloader.ProgressNotification
      报告进度的预加载程序通知。
      static class  Preloader.StateChangeNotification
      发出申明状态更改的通知。

      • Nested classes/interfaces inherited from class javafx.application.Application

        Application.Parameters

    • Field Summary

      • Fields inherited from class javafx.application.Application

        STYLESHEET_CASPIAN, STYLESHEET_MODENA

    • 构造方法摘要

      构造方法
      Constructor 描述
      Preloader​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void handleApplicationNotification​(Preloader.PreloaderNotification info)
      表示应用程序生成的通知。
      boolean handleErrorNotification​(Preloader.ErrorNotification info)
      发生错误时调用。
      void handleProgressNotification​(Preloader.ProgressNotification info)
      表示下载进度。
      void handleStateChangeNotification​(Preloader.StateChangeNotification info)
      表示应用程序状态发生变化。

      • Methods inherited from class javafx.application.Application

        getHostServices, getParameters, getUserAgentStylesheet, init, launch, launch, notifyPreloader, setUserAgentStylesheet, start, stop

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Preloader

        public Preloader​()

    • 方法详细信息

      • handleProgressNotification

        public void handleProgressNotification​(Preloader.ProgressNotification info)
        表示下载进度。 该方法由FX运行时调用，以在加载应用程序资源时指示进度。 不会调用发送到notifyPreloader的ProgressNotification。

        Preloader类提供的这种方法的实现什么都不做。

        参数
        info - 进度通知

      • handleStateChangeNotification

        public void handleStateChangeNotification​(Preloader.StateChangeNotification info)
        表示应用程序状态发生变化。 该方法作为应用程序生命周期的一部分由FX运行时调用。

        Preloader类提供的这种方法的实现什么都不做。

        参数
        info - 状态变更通知

      • handleApplicationNotification

        public void handleApplicationNotification​(Preloader.PreloaderNotification info)
        表示应用程序生成的通知。 FX运行时调用此方法传递通过notifyPreloader发送的通知。

        应用程序不应该直接调用此方法，而应该使用notifyPreloader来避免混合代码对话框的问题。

        Preloader类提供的这种方法的实现什么都不做。

        参数
        info - 应用程序生成的通知

      • handleErrorNotification

        public boolean handleErrorNotification​(Preloader.ErrorNotification info)
        发生错误时调用。

        Preloader类提供的此方法的实现返回false，表示默认错误处理程序应向用户显示消息。

        参数
        info - 描述此错误原因的错误通知
        结果
        true if error was shown to the user by preloader and no additional visualization is needed; otherwise, false.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Preloader.ErrorNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Class Preloader.ErrorNotification

  • java.lang.Object
    • javafx.application.Preloader.ErrorNotification
  • All Implemented Interfaces:
    Preloader.PreloaderNotification
    Enclosing class:
    Preloader

    public static class Preloader.ErrorNotification
extends Object
implements Preloader.PreloaderNotification
    报告错误的预加载程序通知。 如果applet启动出现问题，这将传递给预加载器。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ErrorNotification​(String location, String details, Throwable cause)
      构造错误通知。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      检索与此错误通知相关联的异常或错误（如果有）。
      String getDetails​()
      检索错误的描述。
      String getLocation​()
      检索与此错误相关联的URL（如果有）。
      String toString​()
      返回此 ErrorNotification对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ErrorNotification

        public ErrorNotification​(String location,
                         String details,
                         Throwable cause)
        构造错误通知。
        参数
        location - 与错误相关联的URL（如果有）; 可能为null
        details - 描述错误的字符串 必须非空
        cause - 错误的原因; 可能为null

    • 方法详细信息

      • getLocation

        public String getLocation​()
        检索与此错误相关联的URL（如果有）。 例如，如果有下载或歌唱检查错误，这将是有问题的jar文件的URL。 它可能为null。
        结果
        位置，或null

      • getDetails

        public String getDetails​()
        检索错误的描述。 它可能是空字符串，但总是非空。
        结果
        错误的描述

      • getCause

        public Throwable getCause​()
        检索与此错误通知相关联的异常或错误（如果有）。 它可能为null。
        结果
        错误的原因，或null

      • toString

        public String toString​()
        返回此 ErrorNotification对象的字符串表示形式。
        重写：
        toString类 Object
        结果
        这个 ErrorNotification对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Preloader.PreloaderNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Interface Preloader.PreloaderNotification

  • 所有已知实现类：
    Preloader.ErrorNotification ， Preloader.ProgressNotification ， Preloader.StateChangeNotification
    Enclosing class:
    Preloader

    public static interface Preloader.PreloaderNotification
    所有Preloader通知的标记界面。
    从以下版本开始：
    JavaFX 2.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Preloader.ProgressNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Class Preloader.ProgressNotification

  • java.lang.Object
    • javafx.application.Preloader.ProgressNotification
  • All Implemented Interfaces:
    Preloader.PreloaderNotification
    Enclosing class:
    Preloader

    public static class Preloader.ProgressNotification
extends Object
implements Preloader.PreloaderNotification
    报告进度的预加载程序通知。 这通常用于在下载和初始化应用程序时报告进度。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProgressNotification​(double progress)
      构建进度通知。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getProgress​()
      检索此通知的进度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ProgressNotification

        public ProgressNotification​(double progress)
        构建进度通知。
        参数
        progress - 表示进度的值。 进度的负值表示进度是不确定的。 0到1之间的值表示进度。 任何大于1的值都被解释为1。

    • 方法详细信息

      • getProgress

        public double getProgress​()
        检索此通知的进度。 进度在0到1的范围内，或者对于不确定的进展是负的。
        结果
        进度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Preloader.StateChangeNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Class Preloader.StateChangeNotification

  • java.lang.Object
    • javafx.application.Preloader.StateChangeNotification
  • All Implemented Interfaces:
    Preloader.PreloaderNotification
    Enclosing class:
    Preloader

    public static class Preloader.StateChangeNotification
extends Object
implements Preloader.PreloaderNotification
    发出申明状态更改的通知。 在加载应用程序类（并构造实例），调用应用程序init方法或调用应用程序启动方法之前，将立即将状态更改通知发送到预加载程序。
    从以下版本开始：
    JavaFX 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Preloader.StateChangeNotification.Type
      枚举，定义与此通知相关联的更改类型

    • 构造方法摘要

      构造方法
      Constructor 描述
      StateChangeNotification​(Preloader.StateChangeNotification.Type notificationType)
      构造指定类型的StateChangeNotification。
      StateChangeNotification​(Preloader.StateChangeNotification.Type notificationType, Application application)
      为指定的应用程序构造指定类型的StateChangeNotification。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Application getApplication​()
      返回与此通知关联的应用程序实例。
      Preloader.StateChangeNotification.Type getType​()
      返回通知的类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StateChangeNotification

        public StateChangeNotification​(Preloader.StateChangeNotification.Type notificationType)
        构造指定类型的StateChangeNotification。
        参数
        notificationType - 此通知的类型。

      • StateChangeNotification

        public StateChangeNotification​(Preloader.StateChangeNotification.Type notificationType,
                               Application application)
        为指定的应用程序构造指定类型的StateChangeNotification。
        参数
        notificationType - 此通知的类型。
        application - 与此通知关联的应用程序实例。

    • 方法详细信息

      • getType

        public Preloader.StateChangeNotification.Type getType​()
        返回通知的类型。
        结果
        其中之一：BEFORE_LOAD，BEFORE_INIT，BEFORE_START

      • getApplication

        public Application getApplication​()
        返回与此通知关联的应用程序实例。 对于BEFORE_LOAD通知为null，其他通知类型为非空。
        结果
        应用程序实例或null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Preloader.StateChangeNotification.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.application

Enum Preloader.StateChangeNotification.Type

  • java.lang.Object
    • java.lang.Enum<Preloader.StateChangeNotification.Type>
      • javafx.application.Preloader.StateChangeNotification.Type
  • All Implemented Interfaces:
    Serializable ， Comparable<Preloader.StateChangeNotification.Type>
    Enclosing class:
    Preloader.StateChangeNotification

    public static enum Preloader.StateChangeNotification.Type
extends Enum<Preloader.StateChangeNotification.Type>
    枚举，定义与此通知相关联的更改类型
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BEFORE_INIT
      表示应用程序的init方法即将被调用。
      BEFORE_LOAD
      表示应用程序类即将被加载和构造。
      BEFORE_START
      表示应用程序的start方法即将被调用。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Preloader.StateChangeNotification.Type valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Preloader.StateChangeNotification.Type[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BEFORE_LOAD

        public static final Preloader.StateChangeNotification.Type BEFORE_LOAD
        表示应用程序类即将被加载和构造。

      • BEFORE_INIT

        public static final Preloader.StateChangeNotification.Type BEFORE_INIT
        表示应用程序的init方法即将被调用。

      • BEFORE_START

        public static final Preloader.StateChangeNotification.Type BEFORE_START
        表示应用程序的start方法即将被调用。

    • 方法详细信息

      • values

        public static Preloader.StateChangeNotification.Type[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Preloader.StateChangeNotification.Type c : Preloader.StateChangeNotification.Type.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Preloader.StateChangeNotification.Type valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Uses of Package javafx.application (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.application

  • Packages that use javafx.application
    软件包 描述
    javafx.application
    提供应用程序生命周期类。
  • Classes in javafx.application used by javafx.application
    Class 描述
    Application
    JavaFX应用程序扩展的应用程序类。
    Application.Parameters
    封装一组应用程序的参数。
    ConditionalFeature
    定义一组条件（可选）功能。
    HostServices
    此类为应用程序提供HostServices。
    Preloader.ErrorNotification
    报告错误的预加载程序通知。
    Preloader.PreloaderNotification
    所有Preloader通知的标记界面。
    Preloader.ProgressNotification
    报告进度的预加载程序通知。
    Preloader.StateChangeNotification
    发出申明状态更改的通知。
    Preloader.StateChangeNotification.Type
    枚举，定义与此通知相关联的更改类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.Application (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.Application

  • Packages that use Application
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of Application in javafx.application

      Subclasses of Application in javafx.application
      Modifier and Type Class 描述
      class  Preloader
      扩展定义JavaFX应用程序的可选预加载器的类。
      Methods in javafx.application that return Application
      Modifier and Type 方法 描述
      Application Preloader.StateChangeNotification.getApplication​()
      返回与此通知关联的应用程序实例。
      Method parameters in javafx.application with type arguments of type Application
      Modifier and Type 方法 描述
      static void Application.launch​(Class<? extends Application> appClass, String... args)
      启动独立应用程序。
      Constructors in javafx.application with parameters of type Application
      Constructor 描述
      StateChangeNotification​(Preloader.StateChangeNotification.Type notificationType, Application application)
      为指定的应用程序构造指定类型的StateChangeNotification。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.Application.Parameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.Application.Parameters

  • Packages that use Application.Parameters
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of Application.Parameters in javafx.application

      Methods in javafx.application that return Application.Parameters
      Modifier and Type 方法 描述
      Application.Parameters Application.getParameters​()
      检索此应用程序的参数，包括在命令行上传递的任何参数以及Applet或WebStart应用程序的JNLP文件中指定的任何参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.ConditionalFeature (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.ConditionalFeature

  • Packages that use ConditionalFeature
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of ConditionalFeature in javafx.application

      Methods in javafx.application that return ConditionalFeature
      Modifier and Type 方法 描述
      static ConditionalFeature ConditionalFeature.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ConditionalFeature[] ConditionalFeature.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.application with parameters of type ConditionalFeature
      Modifier and Type 方法 描述
      static boolean Platform.isSupported​(ConditionalFeature feature)
      查询平台是否支持特定条件功能。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.HostServices (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.HostServices

  • Packages that use HostServices
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of HostServices in javafx.application

      Methods in javafx.application that return HostServices
      Modifier and Type 方法 描述
      HostServices Application.getHostServices​()
      获取此应用程序的HostServices提供程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.Platform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.Platform

No usage of javafx.application.Platform
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.Preloader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.Preloader

No usage of javafx.application.Preloader
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.Preloader.ErrorNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.Preloader.ErrorNotification

  • Packages that use Preloader.ErrorNotification
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of Preloader.ErrorNotification in javafx.application

      Methods in javafx.application with parameters of type Preloader.ErrorNotification
      Modifier and Type 方法 描述
      boolean Preloader.handleErrorNotification​(Preloader.ErrorNotification info)
      发生错误时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.Preloader.ProgressNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.Preloader.ProgressNotification

  • Packages that use Preloader.ProgressNotification
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of Preloader.ProgressNotification in javafx.application

      Methods in javafx.application with parameters of type Preloader.ProgressNotification
      Modifier and Type 方法 描述
      void Preloader.handleProgressNotification​(Preloader.ProgressNotification info)
      表示下载进度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.Preloader.StateChangeNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.Preloader.StateChangeNotification

  • Packages that use Preloader.StateChangeNotification
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of Preloader.StateChangeNotification in javafx.application

      Methods in javafx.application with parameters of type Preloader.StateChangeNotification
      Modifier and Type 方法 描述
      void Preloader.handleStateChangeNotification​(Preloader.StateChangeNotification info)
      表示应用程序状态发生变化。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.application.Preloader.StateChangeNotification.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.application.Preloader.StateChangeNotification.Type

  • Packages that use Preloader.StateChangeNotification.Type
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of Preloader.StateChangeNotification.Type in javafx.application

      Methods in javafx.application that return Preloader.StateChangeNotification.Type
      Modifier and Type 方法 描述
      Preloader.StateChangeNotification.Type Preloader.StateChangeNotification.getType​()
      返回通知的类型。
      static Preloader.StateChangeNotification.Type Preloader.StateChangeNotification.Type.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Preloader.StateChangeNotification.Type[] Preloader.StateChangeNotification.Type.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.application with parameters of type Preloader.StateChangeNotification.Type
      Constructor 描述
      StateChangeNotification​(Preloader.StateChangeNotification.Type notificationType)
      构造指定类型的StateChangeNotification。
      StateChangeNotification​(Preloader.StateChangeNotification.Type notificationType, Application application)
      为指定的应用程序构造指定类型的StateChangeNotification。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.application.Preloader.PreloaderNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.application.Preloader.PreloaderNotification

  • Packages that use Preloader.PreloaderNotification
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of Preloader.PreloaderNotification in javafx.application

      Classes in javafx.application that implement Preloader.PreloaderNotification
      Modifier and Type Class 描述
      static class  Preloader.ErrorNotification
      报告错误的预加载程序通知。
      static class  Preloader.ProgressNotification
      报告进度的预加载程序通知。
      static class  Preloader.StateChangeNotification
      发出申明状态更改的通知。
      Methods in javafx.application with parameters of type Preloader.PreloaderNotification
      Modifier and Type 方法 描述
      void Preloader.handleApplicationNotification​(Preloader.PreloaderNotification info)
      表示应用程序生成的通知。
      void Application.notifyPreloader​(Preloader.PreloaderNotification info)
      通过应用程序生成的通知通知预加载器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


DefaultProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module javafx.base
软件包 javafx.beans

Annotation Type DefaultProperty

  • @Inherited
@Documented
@Retention(RUNTIME)
@Target(TYPE)
public @interface DefaultProperty
    指定未指定显式属性时将添加或设置子元素的属性。
    从以下版本开始：
    JavaFX 2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String value
      默认属性的名称。

    • Element Detail

      • value

        String value
        默认属性的名称。
        结果
        物业的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


InvalidationListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans

Interface InvalidationListener

  • 所有已知实现类：
    WeakInvalidationListener
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface InvalidationListener
    一个InvalidationListener每当被通知Observable变为无效。 它可以注册和取消注册Observable.addListener(InvalidationListener)分别Observable.removeListener(InvalidationListener)

    有关无效事件的深入解释及其与变更事件的区别，请参阅ObservableValue的文档。

    InvalidationListener的同一个实例可以注册多个Observables 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Observable ， ObservableValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void invalidated​(Observable observable)
      该方法需要通过 InvalidationListener的实现来提供。

    • 方法详细信息

      • invalidated

        void invalidated​(Observable observable)
        该方法需要由InvalidationListener的实现提供。 如果一个Observable变得无效，它被称为。

        一般认为在这种方法中修改观察值的不良做法。

        参数
        observable - 无效的 Observable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.beans (Java SE 9 & JDK 9 )

javafx.beans

Interfaces

  • InvalidationListener
  • Observable
  • WeakListener

Classes

  • WeakInvalidationListener

注解类型

  • DefaultProperty
  • NamedArg


javafx.beans (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.beans

包javafx.beans包含定义最通用形式的可观察性的接口。 JavaFX库中的所有可以观察到的类扩展了Observable接口。

一个Observable的实现允许附加一个InvalidationListener 。 每次Observable可能更改时，contentBinding都会收到通知。 Observable典型实现是所有属性，所有绑定， ObservableList和ObservableMap 。

一个InvalidationListener将不会获得进一步的信息，例如它不会获得旧的和新的属性的价值。 如果您需要了解更多信息请考虑使用ChangeListener的属性和绑定， ListChangeListener为ObservableLists或者MapChangeListener为ObservableMap代替。

  • 接口摘要
    接口 描述
    InvalidationListener
    一个InvalidationListener每当被通知Observable变为无效。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
    WeakListener
    WeakListener是JavaFX API中所有弱监听器实现的超级界面。
  • 类摘要
    Class 描述
    WeakInvalidationListener
    A WeakInvalidationListener可以使用，如果一个Observable应该只保留一个弱参考的监听器。
  • 注解类型摘要
    Annotation Type 描述
    DefaultProperty
    指定未指定显式属性时将添加或设置子元素的属性。
    NamedArg
    Annotation that provides information about argument's name.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.beans Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.beans

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.beans.WeakInvalidationListener (implements javafx.beans.InvalidationListener, javafx.beans.WeakListener)

Interface Hierarchy

  • javafx.beans.InvalidationListener
  • javafx.beans.Observable
  • javafx.beans.WeakListener

Annotation Type Hierarchy

  • javafx.beans.DefaultProperty (implements java.lang.annotation.Annotation)
  • javafx.beans.NamedArg (implements java.lang.annotation.Annotation)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


NamedArg (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module javafx.base
软件包 javafx.beans

Annotation Type NamedArg

  • @Retention(RUNTIME)
@Target(PARAMETER)
public @interface NamedArg
    提供参数名称信息的注释。
    从以下版本开始：
    JavaFX 8.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String value
      注释参数的名称。

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      String defaultValue
      注释参数的默认值。

    • Element Detail

      • value

        String value
        注释参数的名称。
        结果
        注释参数的名称

      • defaultValue

        String defaultValue
        注释参数的默认值。
        结果
        注释参数的默认值
        Default:
        “”
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


Observable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans

Interface Observable

  • All Known Subinterfaces:
    Binding<T> ， JavaBeanProperty<T> ， NumberBinding ， NumberExpression ， ObservableArray<T> ， ObservableBooleanValue ， ObservableDoubleValue ， ObservableFaceArray ， ObservableFloatArray ， ObservableFloatValue ， ObservableIntegerArray ， ObservableIntegerValue ， ObservableList<E> ， ObservableListValue<E> ， ObservableLongValue ， ObservableMap<K,V> ， ObservableMapValue<K,V> ， ObservableNumberValue ， ObservableObjectValue<T> ， ObservableSet<E> ， ObservableSetValue<E> ， ObservableStringValue ， ObservableValue<T> ， Property<T> ， ReadOnlyJavaBeanProperty<T> ， ReadOnlyProperty<T> ， TextInputControl.Content ， WritableListValue<E> ， WritableMapValue<K,V> ， WritableSetValue<E>
    所有已知实现类：
    BooleanBinding ， BooleanExpression ， BooleanProperty ， BooleanPropertyBase ， DoubleBinding ， DoubleExpression ， DoubleProperty ， DoublePropertyBase ， FilteredList ， FloatBinding ， FloatExpression ， FloatProperty ， FloatPropertyBase ， IntegerBinding ， IntegerExpression ， IntegerProperty ， IntegerPropertyBase ， JavaBeanBooleanProperty ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， JavaBeanObjectProperty ， JavaBeanStringProperty ， ListBinding ， ListExpression ， ListProperty ， ListPropertyBase ， LongBinding ， LongExpression ， LongProperty ， LongPropertyBase ， MapBinding ， MapExpression ， MapProperty ， MapPropertyBase ， ModifiableObservableListBase ， NumberExpressionBase ， ObjectBinding ， ObjectExpression ， ObjectProperty ， ObjectPropertyBase ， ObservableArrayBase ， ObservableListBase ， ObservableValueBase ， ReadOnlyBooleanProperty ， ReadOnlyBooleanPropertyBase ， ReadOnlyBooleanWrapper ， ReadOnlyDoubleProperty ， ReadOnlyDoublePropertyBase ， ReadOnlyDoubleWrapper ， ReadOnlyFloatProperty ， ReadOnlyFloatPropertyBase ， ReadOnlyFloatWrapper ， ReadOnlyIntegerProperty ， ReadOnlyIntegerPropertyBase ReadOnlyIntegerPropertyBase ， ReadOnlyIntegerWrapper ， ReadOnlyJavaBeanBooleanProperty ， ReadOnlyJavaBeanDoubleProperty ， ReadOnlyJavaBeanFloatProperty ， ReadOnlyJavaBeanIntegerProperty ， ReadOnlyJavaBeanLongProperty ， ReadOnlyJavaBeanObjectProperty ， ReadOnlyJavaBeanStringProperty ， ReadOnlyListProperty ， ReadOnlyListPropertyBase ， ReadOnlyListWrapper ， ReadOnlyLongProperty ， ReadOnlyLongPropertyBase ， ReadOnlyLongWrapper ， ReadOnlyMapProperty ， ReadOnlyMapPropertyBase ， ReadOnlyMapWrapper ， ReadOnlyObjectProperty ， ReadOnlyObjectPropertyBase ， ReadOnlyObjectWrapper ， ReadOnlySetProperty ， ReadOnlySetPropertyBase ， ReadOnlySetWrapper ， ReadOnlyStringProperty ， ReadOnlyStringPropertyBase ， ReadOnlyStringWrapper ， SetBinding ， SetExpression ， SetProperty ， SetPropertyBase ， SimpleBooleanProperty ， SimpleDoubleProperty ， SimpleFloatProperty ， SimpleIntegerProperty ， SimpleListProperty ， SimpleLongProperty ， SimpleMapProperty ， SimpleObjectProperty ， SimpleSetProperty ， SimpleStringProperty ， SimpleStyleableBooleanProperty ， SimpleStyleableDoubleProperty ， SimpleStyleableFloatProperty ， SimpleStyleableIntegerProperty ， SimpleStyleableLongProperty ， SimpleStyleableObjectProperty ， SimpleStyleableStringProperty ， SortedList ， StringBinding ， StringExpression ， StringProperty ， StringPropertyBase ， StyleableBooleanProperty ， StyleableDoubleProperty ， StyleableFloatProperty ， StyleableIntegerProperty StyleableIntegerProperty ， StyleableLongProperty ， StyleableObjectProperty ， StyleableStringProperty ， TransformationList

    public interface Observable
    一个Observable是一个包含内容并允许观察内容无效的实体。

    Observable的实现可能支持懒惰评估，这意味着内容在更改后不会立即重新计算，而是在下次请求时懒惰。 此库中的所有绑定和属性都支持懒惰评估。

    该类的实现应该尽可能地生成尽可能少的事件，以避免在事件处理程序中浪费太多时间。 当第一个无效事件发生时，此库中的实现将自身标记为无效。 它们在重新计算并重新生效之前不再生成无效事件。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableValue ， ObservableList ， ObservableMap

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。

    • 方法详细信息

      • addListener

        void addListener​(InvalidationListener listener)
        添加一个InvalidationListener ，当Observable变为无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        异常
        NullPointerException - 如果监听器为空
        另请参见：
        removeListener(InvalidationListener)

      • removeListener

        void removeListener​(InvalidationListener listener)
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        异常
        NullPointerException - 如果侦听器为空
        另请参见：
        addListener(InvalidationListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.beans (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.beans

  • Packages that use javafx.beans
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javafx.util
    包含各种实用程序和助手类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
  • Classes in javafx.beans used by javafx.animation
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.beans
    Class 描述
    InvalidationListener
    一个InvalidationListener每当被通知Observable变为无效。
    NamedArg
    提供参数名称信息的注释。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
    WeakListener
    WeakListener是JavaFX API中所有弱监听器实现的超级界面。
  • Classes in javafx.beans used by javafx.beans.binding
    Class 描述
    InvalidationListener
    一个InvalidationListener每当被通知Observable变为无效。
    NamedArg
    提供参数名称信息的注释。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
  • Classes in javafx.beans used by javafx.beans.property
    Class 描述
    InvalidationListener
    一个InvalidationListener每当被通知Observable变为无效。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
  • Classes in javafx.beans used by javafx.beans.property.adapter
    Class 描述
    InvalidationListener
    一个InvalidationListener每当被通知Observable变为无效。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
  • Classes in javafx.beans used by javafx.beans.value
    Class 描述
    InvalidationListener
    一个InvalidationListener每当被通知Observable变为无效。
    NamedArg
    提供参数名称信息的注释。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
    WeakListener
    WeakListener是JavaFX API中所有弱监听器实现的超级界面。
  • Classes in javafx.beans used by javafx.collections
    Class 描述
    InvalidationListener
    一个InvalidationListener每当被通知Observable变为无效。
    NamedArg
    提供参数名称信息的注释。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
    WeakListener
    WeakListener是JavaFX API中所有弱监听器实现的超级界面。
  • Classes in javafx.beans used by javafx.collections.transformation
    Class 描述
    NamedArg
    提供参数名称信息的注释。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
  • Classes in javafx.beans used by javafx.concurrent
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.css
    Class 描述
    NamedArg
    提供参数名称信息的注释。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
  • Classes in javafx.beans used by javafx.event
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.geometry
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.print
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene
    Class 描述
    DefaultProperty
    指定未指定显式属性时将添加或设置子元素的属性。
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.chart
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.control
    Class 描述
    DefaultProperty
    指定未指定显式属性时将添加或设置子元素的属性。
    NamedArg
    提供参数名称信息的注释。
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
  • Classes in javafx.beans used by javafx.scene.control.cell
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.image
    Class 描述
    DefaultProperty
    指定未指定显式属性时将添加或设置子元素的属性。
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.input
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.layout
    Class 描述
    DefaultProperty
    指定未指定显式属性时将添加或设置子元素的属性。
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.media
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.paint
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.shape
    Class 描述
    Observable
    一个 Observable是一个包含内容并允许观察内容无效的实体。
  • Classes in javafx.beans used by javafx.scene.text
    Class 描述
    DefaultProperty
    指定未指定显式属性时将添加或设置子元素的属性。
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.transform
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.scene.web
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.stage
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.util
    Class 描述
    NamedArg
    提供参数名称信息的注释。
  • Classes in javafx.beans used by javafx.util.converter
    Class 描述
    NamedArg
    Annotation that provides information about argument's name.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


WeakInvalidationListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans

Class WeakInvalidationListener

  • java.lang.Object
    • javafx.beans.WeakInvalidationListener
  • All Implemented Interfaces:
    InvalidationListener ， WeakListener

    public final class WeakInvalidationListener
extends Object
implements InvalidationListener, WeakListener
    A WeakInvalidationListener可以使用，如果一个Observable应该只保留对监听器的弱引用。 这有助于避免内存泄漏，如果观察者在使用后未注册观察对象，则可能会发生这种情况。

    WeakInvalidationListener是通过传递原来的InvalidationListener创建的。 然后应注册WeakInvalidationListener以监听观察对象的更改。

    注意：你必须保留对InvalidationListener的引用，只要它在使用中被传递，否则将很快被垃圾收集。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    InvalidationListener ， Observable

    • 构造方法摘要

      构造方法
      Constructor 描述
      WeakInvalidationListener​(InvalidationListener listener)
      构造函数为 WeakInvalidationListener 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void invalidated​(Observable observable)
      该方法需要通过 InvalidationListener的实现来提供。
      boolean wasGarbageCollected​()
      如果链接的侦听器被垃圾回收，则返回 true 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WeakInvalidationListener

        public WeakInvalidationListener​(InvalidationListener listener)
        构造函数为 WeakInvalidationListener 。
        参数
        listener - 应该通知的原始听众

    • 方法详细信息

      • wasGarbageCollected

        public boolean wasGarbageCollected​()
        如果链接的侦听器被垃圾回收，则返回true 。 在这种情况下，可以从observable中移除侦听器。
        Specified by:
        wasGarbageCollected在接口 WeakListener
        结果
        true如果链接的侦听器是垃圾回收的。

      • invalidated

        public void invalidated​(Observable observable)
        该方法需要通过InvalidationListener的实现来提供。 如果一个Observable变为无效，则调用它。

        一般认为在这种方法中修改观察值的不良做法。

        Specified by:
        invalidated在接口 InvalidationListener
        参数
        observable - 无效的 Observable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WeakListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans

Interface WeakListener

  • 所有已知实现类：
    WeakChangeListener ， WeakInvalidationListener ， WeakListChangeListener ， WeakMapChangeListener ， WeakSetChangeListener

    public interface WeakListener
    WeakListener是JavaFX API中所有弱侦听器实现的超级界面。 通常不应该直接使用，而是使用一个子接口。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    WeakInvalidationListener ， WeakChangeListener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean wasGarbageCollected​()
      如果链接的侦听器被垃圾回收，则返回 true 。

    • 方法详细信息

      • wasGarbageCollected

        boolean wasGarbageCollected​()
        如果链接的侦听器被垃圾回收，则返回true 。 在这种情况下，可以从observable中移除侦听器。
        结果
        true if the linked listener was garbage-collected.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Binding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Interface Binding<T>

  • 参数类型
    T - 包装值的类型
    All Superinterfaces:
    Observable ， ObservableValue<T>
    All Known Subinterfaces:
    NumberBinding
    所有已知实现类：
    BooleanBinding ， DoubleBinding ， FloatBinding ， IntegerBinding ， ListBinding ， LongBinding ， MapBinding ， ObjectBinding ， SetBinding ， StringBinding

    public interface Binding<T>
extends ObservableValue<T>
    A Binding计算取决于一个或多个来源的值。 源通常被称为绑定的依赖。 绑定观察其依赖关系进行更改，并自动更新其值。

    虽然绑定的依赖可以是任何东西，但它几乎总是执行ObservableValue 。 Binding实现ObservableValue允许在另一个绑定中使用它。 由此可以通过简单的绑定来组合非常复杂的绑定。

    JavaFX运行时间中的所有绑定都是懒惰的计算。 这意味着，如果依赖关系更改，绑定的结果不会立即重新计算，而是被标记为无效。 下次无效绑定的值被请求时，重新计算。

    建议使用此包中定义的基类之一（例如DoubleBinding ）来定义自定义绑定，因为这些类已经提供了大部分所需的功能。 参见DoubleBinding的一个例子。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    DoubleBinding

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dispose​()
      信号到 Binding ，它将不再被使用，任何引用都可以被删除。
      ObservableList<?> getDependencies​()
      返回不可修改的绑定的依赖关系ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • isValid

        boolean isValid​()
        检查绑定是否有效。
        结果
        true如果 Binding有效，则 false否则

      • invalidate

        void invalidate​()
        将绑定标记为无效。 这迫使重新计算Binding下一次请求的值。

      • getDependencies

        ObservableList<?> getDependencies​()
        返回绑定在不可修改的依赖关系ObservableList 。 实施是可选的。 这种方法的主要目的是在开发过程中支持开发人员。 它允许在运行时期间探索和监视绑定的依赖关系。

        因为这种方法不应该在生产代码中使用，所以建议将此功能尽可能稀疏化。 例如，如果依赖关系不变，每个调用都可以生成新的ObservableList ，避免存储结果的必要性。

        结果
        一个不可修改的ObservableList依赖关系

      • dispose

        void dispose​()
        信号到Binding它将不再被使用，任何引用可以被删除。 这种方法的调用通常导致绑定停止以通过取消注册其监听器来观察其依赖关系。 实施是可选的。

        我们实现中的所有绑定使用WeakInvalidationListener的实例，这意味着通常不需要处理绑定。 但是，如果您打算在不支持WeakReferences环境中使用应用程序，则必须处理未使用的Bindings以避免内存泄漏。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Bindings (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class Bindings

  • java.lang.Object
    • javafx.beans.binding.Bindings

  • public final class Bindings
extends Object
    绑定是一个帮助类，具有很多实用功能来创建简单的绑定。

    通常有两种可能性来定义相同的操作：Fluent API和此类中的工厂方法。 这允许开发人员以最容易理解的方式定义复杂的表达式。 例如表达式result = a*b + c*d可以仅使用Fluent API定义：

    DoubleBinding result = a.multiply(b).add(c.multiply(d));

    或者在捆绑中仅使用工厂方法：

    NumberBinding result = add (multiply(a, b), multiply(c,d));

    或混合两种可能性：

    NumberBinding result = add (a.multiply(b), c.multiply(d));

    使用Fluent API和在此类中使用工厂方法的主要区别是Fluent API要求至少有一个操作数是一个表达式（见javafx.beans.binding ）。 （每个表达式都包含一个从ObservableValue生成表达式的静态方法。）

    此外，如果您仔细观察，您可能已经注意到，上述示例中Fluent API的返回类型不同。 在很多情况下，Fluent API可以更具体地说明返回的类型（有关隐式转换的更多详细信息，请参阅NumberExpression） 。

    将应用程序部署为模块

    如果在选择绑定中使用任何类（请参阅各种select*方法）在命名模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens将包含的包至少为javafx.base模块，则可以反射访问类。

    例如，如果com.foo.MyClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包装，则可以反射地访问类。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Binding ， NumberBinding

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static DoubleBinding add​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding add​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding add​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding add​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static DoubleBinding add​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding add​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding add​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding add​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding add​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding计算的两个实例的值的总和ObservableNumberValue 。
      static BooleanBinding and​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个BooleanBinding ，它为ObservableBooleanValue的两个实例的值计算条件AND操作。
      static void bindBidirectional​(Property<String> stringProperty, Property<?> otherProperty, Format format)
      在String - Property和另一个Property使用指定的Format生成双向绑定（或“反向绑定”）进行转换。
      static <T> void bindBidirectional​(Property<String> stringProperty, Property<T> otherProperty, StringConverter<T> converter)
      在String - Property和另一个Property使用指定的StringConverter生成双向绑定（或“反向绑定”）进行转换。
      static <T> void bindBidirectional​(Property<T> property1, Property<T> property2)
      在Property的两个实例之间生成双向绑定（或“绑定”）。
      static <E> void bindContent​(List<E> list1, ObservableList<? extends E> list2)
      生成ObservableList和List之间的内容绑定。
      static <K,V> void bindContent​(Map<K,V> map1, ObservableMap<? extends K,? extends V> map2)
      生成ObservableMap和Map之间的内容绑定。
      static <E> void bindContent​(Set<E> set1, ObservableSet<? extends E> set2)
      生成ObservableSet和Set之间的内容绑定。
      static <E> void bindContentBidirectional​(ObservableList<E> list1, ObservableList<E> list2)
      在ObservableList的两个实例之间生成双向绑定（或“反向绑定”）。
      static <K,V> void bindContentBidirectional​(ObservableMap<K,V> map1, ObservableMap<K,V> map2)
      在ObservableMap的两个实例之间生成双向绑定（或“绑定”）。
      static <E> void bindContentBidirectional​(ObservableSet<E> set1, ObservableSet<E> set2)
      在ObservableSet的两个实例之间生成双向绑定（或“绑定”）。
      static BooleanBinding booleanValueAt​(ObservableList<Boolean> op, int index)
      创建一个新的BooleanBinding ，其中包含ObservableList在指定位置的元素。
      static BooleanBinding booleanValueAt​(ObservableList<Boolean> op, ObservableIntegerValue index)
      创建一个新的BooleanBinding ，其中包含指定位置的ObservableList的元素。
      static BooleanBinding booleanValueAt​(ObservableList<Boolean> op, ObservableNumberValue index)
      创建一个新的BooleanBinding ，其中包含指定位置的ObservableList的元素。
      static <K> BooleanBinding booleanValueAt​(ObservableMap<K,Boolean> op, ObservableValue<? extends K> key)
      创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> BooleanBinding booleanValueAt​(ObservableMap<K,Boolean> op, K key)
      创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
      static StringExpression concat​(Object... args)
      返回一个StringExpression ，它保持多个Objects的并置值。
      static StringExpression convert​(ObservableValue<?> observableValue)
      返回一个StringExpression ，其中包含一个ObservableValue 。
      static BooleanBinding createBooleanBinding​(Callable<Boolean> func, Observable... dependencies)
      助手功能创建自定义BooleanBinding 。
      static DoubleBinding createDoubleBinding​(Callable<Double> func, Observable... dependencies)
      助手功能创建自定义DoubleBinding 。
      static FloatBinding createFloatBinding​(Callable<Float> func, Observable... dependencies)
      助手功能创建一个自定义FloatBinding 。
      static IntegerBinding createIntegerBinding​(Callable<Integer> func, Observable... dependencies)
      助手功能创建自定义IntegerBinding 。
      static LongBinding createLongBinding​(Callable<Long> func, Observable... dependencies)
      助手功能创建自定义LongBinding 。
      static <T> ObjectBinding<T> createObjectBinding​(Callable<T> func, Observable... dependencies)
      助手功能创建一个自定义ObjectBinding 。
      static StringBinding createStringBinding​(Callable<String> func, Observable... dependencies)
      助手功能创建自定义StringBinding 。
      static DoubleBinding divide​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算一个常数值的除法和一个ObservableNumberValue的值。
      static NumberBinding divide​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算一个常数值的除法和ObservableNumberValue的值。
      static NumberBinding divide​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算一个常数值和ObservableNumberValue的值的除法 。
      static NumberBinding divide​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算一个常数值的除法和一个ObservableNumberValue的值。
      static DoubleBinding divide​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值除数和常数值。
      static NumberBinding divide​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值除以恒定值。
      static NumberBinding divide​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值除以恒定值。
      static NumberBinding divide​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值除数和常数值。
      static NumberBinding divide​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的值的除法 。
      static DoubleBinding doubleValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的DoubleBinding ，其中包含指定位置的元素ObservableList 。
      static DoubleBinding doubleValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的DoubleBinding ，其中包含指定位置的元素ObservableList 。
      static DoubleBinding doubleValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。
      static <K> DoubleBinding doubleValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> DoubleBinding doubleValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
      static BooleanBinding equal​(double op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。
      static BooleanBinding equal​(float op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值（具有公差）。
      static BooleanBinding equal​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。
      static BooleanBinding equal​(int op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值（具有公差），则保留true 。
      static BooleanBinding equal​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。
      static BooleanBinding equal​(long op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。
      static BooleanBinding equal​(Object op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值等于一个恒定值，则保留true 。
      static BooleanBinding equal​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue等于恒定值。
      static BooleanBinding equal​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue相等。
      static BooleanBinding equal​(ObservableNumberValue op1, double op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
      static BooleanBinding equal​(ObservableNumberValue op1, float op2, double epsilon)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值（具有公差）。
      static BooleanBinding equal​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值。
      static BooleanBinding equal​(ObservableNumberValue op1, int op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。
      static BooleanBinding equal​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值。
      static BooleanBinding equal​(ObservableNumberValue op1, long op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
      static BooleanBinding equal​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等。
      static BooleanBinding equal​(ObservableNumberValue op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等（与公差）。
      static BooleanBinding equal​(ObservableObjectValue<?> op1, Object op2)
      创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值等于一个恒定值，则保留true 。
      static BooleanBinding equal​(ObservableObjectValue<?> op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue相等。
      static BooleanBinding equal​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。
      static BooleanBinding equal​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等。
      static BooleanBinding equalIgnoreCase​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值忽略的情况，则保留true 。
      static BooleanBinding equalIgnoreCase​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值忽略大小写，则保留true 。
      static BooleanBinding equalIgnoreCase​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等忽略大小写。
      static FloatBinding floatValueAt​(ObservableFloatArray op, int index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableArray的元素。
      static FloatBinding floatValueAt​(ObservableFloatArray op, ObservableIntegerValue index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableArray的元素。
      static FloatBinding floatValueAt​(ObservableFloatArray op, ObservableNumberValue index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableArray元素。
      static FloatBinding floatValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableList元素。
      static FloatBinding floatValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的FloatBinding ，其中包含ObservableList在指定位置的元素。
      static FloatBinding floatValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableList的元素。
      static <K> FloatBinding floatValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的FloatBinding ，其中包含ObservableMap中的特定键的映射 。
      static <K> FloatBinding floatValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
      static StringExpression format​(String format, Object... args)
      创建StringExpression保持多个值Objects根据格式格式化String 。
      static StringExpression format​(Locale locale, String format, Object... args)
      创建一个StringExpression ，其中保存Objects格式的Objects格式，格式为String和指定的Locale
      static BooleanBinding greaterThan​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding greaterThan​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding greaterThan​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding greaterThan​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding greaterThan​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值的值比的值越大ObservableStringValue 。
      static BooleanBinding greaterThan​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding greaterThan​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding greaterThan​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding greaterThan​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding greaterThan​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建新的BooleanBinding ，如果第一个ObservableNumberValue的值大于第二个值，则保留true 。
      static BooleanBinding greaterThan​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue比恒定值。
      static BooleanBinding greaterThan​(ObservableStringValue op1, ObservableStringValue op2)
      创建新的BooleanBinding ，如果第一个ObservableStringValue的值大于第二个值，则保留true 。
      static BooleanBinding greaterThanOrEqual​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding greaterThanOrEqual​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding greaterThanOrEqual​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding greaterThanOrEqual​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding greaterThanOrEqual​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableStringValue 。
      static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建新的BooleanBinding ，如果第一个ObservableNumberValue的值大于或等于第二个值，则保留true 。
      static BooleanBinding greaterThanOrEqual​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue大于或等于恒定值。
      static BooleanBinding greaterThanOrEqual​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果第一个ObservableStringValue的值大于或等于第二个值，则保留true 。
      static IntegerBinding integerValueAt​(ObservableIntegerArray op, int index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableArray的元素。
      static IntegerBinding integerValueAt​(ObservableIntegerArray op, ObservableIntegerValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableArray的元素。
      static IntegerBinding integerValueAt​(ObservableIntegerArray op, ObservableNumberValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableArray的元素。
      static IntegerBinding integerValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableList元素。
      static IntegerBinding integerValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。
      static IntegerBinding integerValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。
      static <K> IntegerBinding integerValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> IntegerBinding integerValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。
      static BooleanBinding isEmpty​(ObservableStringValue op)
      创建一个新的BooleanBinding ，如果ObservableStringValue的值为空，则保留true 。
      static <E> BooleanBinding isEmpty​(ObservableList<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableList为空，则保留true 。
      static <K,V> BooleanBinding isEmpty​(ObservableMap<K,V> op)
      创建一个新的BooleanBinding ，如果给定的ObservableMap为空，则保留true 。
      static <E> BooleanBinding isEmpty​(ObservableSet<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableSet为空，则保留true 。
      static BooleanBinding isNotEmpty​(ObservableStringValue op)
      创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不是空的。
      static <E> BooleanBinding isNotEmpty​(ObservableList<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableList不为空，则保留true 。
      static <K,V> BooleanBinding isNotEmpty​(ObservableMap<K,V> op)
      创建一个新的BooleanBinding ，如果给定的ObservableMap不为空，则保留true 。
      static <E> BooleanBinding isNotEmpty​(ObservableSet<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableSet不为空，则保留true 。
      static BooleanBinding isNotNull​(ObservableObjectValue<?> op)
      创建一个新的BooleanBinding持有true如果一个价值ObservableObjectValue不null 。
      static BooleanBinding isNull​(ObservableObjectValue<?> op)
      创建一个新的BooleanBinding ，如果true的值为null，则null 。
      static IntegerBinding length​(ObservableStringValue op)
      创建一个新的IntegerBinding ，其长度为ObservableStringValue 。
      static BooleanBinding lessThan​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding lessThan​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding lessThan​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding lessThan​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding lessThan​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableStringValue 。
      static BooleanBinding lessThan​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding lessThan​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding lessThan​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding lessThan​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding lessThan​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建新的BooleanBinding ，如果第一个ObservableNumberValue的值小于第二个值，则保留true 。
      static BooleanBinding lessThan​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableStringValue小于一个恒定值。
      static BooleanBinding lessThan​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果第一个ObservableStringValue的值小于第二个值，则保留true 。
      static BooleanBinding lessThanOrEqual​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding lessThanOrEqual​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding lessThanOrEqual​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding lessThanOrEqual​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding lessThanOrEqual​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableStringValue 。
      static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建新的BooleanBinding ，如果第一个ObservableNumberValue的值小于或等于第二个值，则保留true 。
      static BooleanBinding lessThanOrEqual​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue小于或等于恒定值。
      static BooleanBinding lessThanOrEqual​(ObservableStringValue op1, ObservableStringValue op2)
      创建新的BooleanBinding ，如果第一个ObservableStringValue的值小于或等于第二个值，则保留true 。
      static LongBinding longValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的LongBinding ，其中包含ObservableList在指定位置的元素。
      static LongBinding longValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的LongBinding ，其中包含ObservableList在指定位置的元素。
      static LongBinding longValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的LongBinding ，其中包含指定位置的ObservableList元素。
      static <K> LongBinding longValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> LongBinding longValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
      static DoubleBinding max​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding max​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最大值和一个恒定值。
      static NumberBinding max​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding max​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static DoubleBinding max​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding max​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding max​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding max​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding max​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue两个实例的值的最大值 。
      static DoubleBinding min​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding min​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding min​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding min​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static DoubleBinding min​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding min​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding min​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding min​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding min​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的最小值 。
      static DoubleBinding multiply​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding multiply​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding multiply​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding multiply​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static DoubleBinding multiply​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding multiply​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding multiply​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值和一个恒定值的乘积 。
      static NumberBinding multiply​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding multiply​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue两个实例的值的乘积 。
      static NumberBinding negate​(ObservableNumberValue value)
      创建一个新的NumberBinding ，计算一个ObservableNumberValue的否定。
      static BooleanBinding not​(ObservableBooleanValue op)
      创建一个BooleanBinding ，计算ObservableBooleanValue的值的倒数 。
      static BooleanBinding notEqual​(double op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding notEqual​(float op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding notEqual​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值。
      static BooleanBinding notEqual​(int op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding notEqual​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值。
      static BooleanBinding notEqual​(long op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding notEqual​(Object op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值不等于一个常量值，则保留true 。
      static BooleanBinding notEqual​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding notEqual​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue不相等。
      static BooleanBinding notEqual​(ObservableNumberValue op1, double op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常量（容差），则保留true 。
      static BooleanBinding notEqual​(ObservableNumberValue op1, float op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding notEqual​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值。
      static BooleanBinding notEqual​(ObservableNumberValue op1, int op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding notEqual​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值。
      static BooleanBinding notEqual​(ObservableNumberValue op1, long op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding notEqual​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等。
      static BooleanBinding notEqual​(ObservableNumberValue op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等（与公差）。
      static BooleanBinding notEqual​(ObservableObjectValue<?> op1, Object op2)
      创建一个新的BooleanBinding保持true如果一个的值ObservableObjectValue不等于恒定值。
      static BooleanBinding notEqual​(ObservableObjectValue<?> op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue不相等。
      static BooleanBinding notEqual​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不等于一个恒定值。
      static BooleanBinding notEqual​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不相等。
      static BooleanBinding notEqualIgnoreCase​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。
      static BooleanBinding notEqualIgnoreCase​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。
      static BooleanBinding notEqualIgnoreCase​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不等于忽略大小写。
      static BooleanBinding or​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个BooleanBinding ，它为ObservableBooleanValue的两个实例的值计算条件OR运算。
      static <T> ObjectBinding<T> select​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static <T> ObjectBinding<T> select​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static BooleanBinding selectBoolean​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static BooleanBinding selectBoolean​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static DoubleBinding selectDouble​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static DoubleBinding selectDouble​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static FloatBinding selectFloat​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static FloatBinding selectFloat​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static IntegerBinding selectInteger​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static IntegerBinding selectInteger​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static LongBinding selectLong​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static LongBinding selectLong​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static StringBinding selectString​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static StringBinding selectString​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，例如 a.b.c 。
      static IntegerBinding size​(ObservableArray op)
      创建一个新的IntegerBinding ，其大小为ObservableArray 。
      static <E> IntegerBinding size​(ObservableList<E> op)
      创建一个新的IntegerBinding ，其大小包含ObservableList 。
      static <K,V> IntegerBinding size​(ObservableMap<K,V> op)
      创建一个新的IntegerBinding ，其大小为ObservableMap 。
      static <E> IntegerBinding size​(ObservableSet<E> op)
      创建一个新的IntegerBinding ，其大小为ObservableSet 。
      static StringBinding stringValueAt​(ObservableList<String> op, int index)
      创建一个新的StringBinding ，其中包含指定位置的ObservableList的元素。
      static StringBinding stringValueAt​(ObservableList<String> op, ObservableIntegerValue index)
      创建一个新的StringBinding ，其中包含指定位置的ObservableList元素。
      static StringBinding stringValueAt​(ObservableList<String> op, ObservableNumberValue index)
      创建一个新的StringBinding ，其中包含指定位置的ObservableList元素。
      static <K> StringBinding stringValueAt​(ObservableMap<K,String> op, ObservableValue<? extends K> key)
      创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> StringBinding stringValueAt​(ObservableMap<K,String> op, K key)
      创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。
      static DoubleBinding subtract​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算一个常数值和一个ObservableNumberValue的值的差异 。
      static NumberBinding subtract​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
      static NumberBinding subtract​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
      static NumberBinding subtract​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
      static DoubleBinding subtract​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding subtract​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算一个ObservableNumberValue的值和一个恒定值的差值。
      static NumberBinding subtract​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding subtract​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding subtract​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的值的差异 。
      static void unbindBidirectional​(Object property1, Object property2)
      删除先前使用 bindBidirectional(Property, Property)或 bindBidirectional(javafx.beans.property.Property, javafx.beans.property.Property, java.text.Format)定义的双向绑定。
      static <T> void unbindBidirectional​(Property<T> property1, Property<T> property2)
      删除先前使用 bindBidirectional(Property, Property)定义的双向绑定。
      static void unbindContent​(Object obj1, Object obj2)
      删除内容绑定。
      static void unbindContentBidirectional​(Object obj1, Object obj2)
      删除双向内容绑定。
      static <E> ObjectBinding<E> valueAt​(ObservableList<E> op, int index)
      创建一个新的ObjectBinding ，其中包含指定位置的ObservableList元素。
      static <E> ObjectBinding<E> valueAt​(ObservableList<E> op, ObservableIntegerValue index)
      创建一个新的ObjectBinding ，其中包含指定位置的ObservableList元素。
      static <E> ObjectBinding<E> valueAt​(ObservableList<E> op, ObservableNumberValue index)
      创建一个新的ObjectBinding ，其中包含ObservableList在指定位置的元素。
      static <K,V> ObjectBinding<V> valueAt​(ObservableMap<K,V> op, ObservableValue<? extends K> key)
      创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
      static <K,V> ObjectBinding<V> valueAt​(ObservableMap<K,V> op, K key)
      创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
      static When when​(ObservableBooleanValue condition)
      创建一个计算三元表达式结果的绑定。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • createBooleanBinding

        public static BooleanBinding createBooleanBinding​(Callable<Boolean> func,
                                                  Observable... dependencies)
        助手功能创建自定义BooleanBinding 。
        参数
        func - 计算此绑定值的函数
        dependencies - 此绑定的依赖关系
        结果
        生成的绑定
        从以下版本开始：
        JavaFX 2.1

      • createDoubleBinding

        public static DoubleBinding createDoubleBinding​(Callable<Double> func,
                                                Observable... dependencies)
        助手功能创建自定义DoubleBinding 。
        参数
        func - 计算此绑定值的函数
        dependencies - 此绑定的依赖关系
        结果
        生成的绑定
        从以下版本开始：
        JavaFX 2.1

      • createFloatBinding

        public static FloatBinding createFloatBinding​(Callable<Float> func,
                                              Observable... dependencies)
        助手功能创建自定义FloatBinding 。
        参数
        func - 计算此绑定值的函数
        dependencies - 此绑定的依赖关系
        结果
        生成的绑定
        从以下版本开始：
        JavaFX 2.1

      • createIntegerBinding

        public static IntegerBinding createIntegerBinding​(Callable<Integer> func,
                                                  Observable... dependencies)
        助手功能创建自定义IntegerBinding 。
        参数
        func - 计算此绑定值的函数
        dependencies - 此绑定的依赖关系
        结果
        生成的绑定
        从以下版本开始：
        JavaFX 2.1

      • createLongBinding

        public static LongBinding createLongBinding​(Callable<Long> func,
                                            Observable... dependencies)
        助手功能创建自定义LongBinding 。
        参数
        func - 计算此绑定值的函数
        dependencies - 这个绑定的依赖
        结果
        生成的绑定
        从以下版本开始：
        JavaFX 2.1

      • createObjectBinding

        public static <T> ObjectBinding<T> createObjectBinding​(Callable<T> func,
                                                       Observable... dependencies)
        助手功能创建自定义ObjectBinding 。
        参数类型
        T - 绑定的类型 Object
        参数
        func - 计算此绑定值的函数
        dependencies - 这个绑定的依赖
        结果
        生成的绑定
        从以下版本开始：
        JavaFX 2.1

      • createStringBinding

        public static StringBinding createStringBinding​(Callable<String> func,
                                                Observable... dependencies)
        助手功能创建自定义StringBinding 。
        参数
        func - 计算此绑定值的函数
        dependencies - 此绑定的依赖关系
        结果
        生成的绑定
        从以下版本开始：
        JavaFX 2.1

      • select

        public static <T> ObjectBinding<T> select​(ObservableValue<?> root,
                                          String... steps)
        创建用于获取成员的绑定，例如a.b.c 。 结合的值将是c ，或null如果c无法达成（由于b不具有c属性， b是null ，或c不是正确的类型等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须是可反映访问的（请参阅Deploying an Application as a Module ）。

        注意：自8.0以来，支持JavaBeans属性，可能位于链中。

        参数类型
        T - 包装的类型 Object
        参数
        root - 根ObservableValue
        steps - 到达最终财产的财产名称
        结果
        创建的ObjectBinding

      • selectDouble

        public static DoubleBinding selectDouble​(ObservableValue<?> root,
                                         String... steps)
        创建用于获取成员的绑定，如a.b.c 。 结合的值将是c ，或0.0如果c无法达成（由于b不具有c属性， b是null ，或c不是一个Number等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（参见Deploying an Application as a Module ）。

        注意：自8.0以来，支持JavaBeans属性，可能位于链中。

        参数
        root - 根ObservableValue
        steps - 到达最终财产的财产名称
        结果
        创建的DoubleBinding

      • selectFloat

        public static FloatBinding selectFloat​(ObservableValue<?> root,
                                       String... steps)
        创建用于获取成员的绑定，如a.b.c 。 绑定的值为c ，如果无法达到c ， 0.0f c （由于b不具有c属性， b为null或c不为Number等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须是可反映访问的（请参阅Deploying an Application as a Module ）。

        注意：自8.0以来，支持JavaBeans属性，可能位于链中。

        参数
        root - 根ObservableValue
        steps - 到达最终财产的财产名称
        结果
        创建FloatBinding

      • selectInteger

        public static IntegerBinding selectInteger​(ObservableValue<?> root,
                                           String... steps)
        创建用于获取成员的绑定，如a.b.c 。 结合的值将是c ，或0如果c无法达成（由于b不具有c属性， b是null ，或c不是一个Number等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（参见Deploying an Application as a Module ）。

        注意：自8.0以来，支持JavaBeans属性，可能位于链中。

        参数
        root - 根ObservableValue
        steps - 到达最终财产的财产名称
        结果
        创建的IntegerBinding

      • selectLong

        public static LongBinding selectLong​(ObservableValue<?> root,
                                     String... steps)
        创建用于获取成员的绑定，例如a.b.c 。 结合的值将是c ，或0L如果c无法达成（由于b不具有c属性， b是null ，或c不是一个Number等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（见Deploying an Application as a Module ）。

        注意：自8.0以来，支持JavaBeans属性，可能位于链中。

        参数
        root - 根ObservableValue
        steps - 要达到最终财产的财产名称
        结果
        创建的LongBinding

      • selectBoolean

        public static BooleanBinding selectBoolean​(ObservableValue<?> root,
                                           String... steps)
        创建用于获取成员的绑定，如a.b.c 。 结合的值将是c ，或false如果c无法达成（由于b不具有c属性， b是null ，或c不是一个boolean等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（见Deploying an Application as a Module ）。

        注意：自8.0以来，支持JavaBeans属性，可能位于链中。

        参数
        root - 根ObservableValue
        steps - 到达最终财产的财产名称
        结果
        创建ObjectBinding

      • selectString

        public static StringBinding selectString​(ObservableValue<?> root,
                                         String... steps)
        创建用于获取成员的绑定，如a.b.c 。 结合的值将是c ，或""如果c无法达成（由于b不具有c属性， b是null ，或c不是一个String等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（见Deploying an Application as a Module ）。

        注意：自8.0以来，支持JavaBeans属性，可能位于链中。

        参数
        root - 根ObservableValue
        steps - 到达最终财产的财产名称
        结果
        创建ObjectBinding

      • select

        public static <T> ObjectBinding<T> select​(Object root,
                                          String... steps)
        创建用于获取成员的绑定，如a.b.c 。 结合的值将是c ，或null如果c无法达成（由于b不具有c属性， b是null ，或c不是正确的类型等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（见Deploying an Application as a Module ）。

        如果root具有JavaFX属性，则此调用等同于select(javafx.beans.value.ObservableValue, java.lang.String[]) ，其中root和step[0]被替换为相关属性对象。

        参数类型
        T - 包装的类型 Object
        参数
        root - 根豆。
        steps - 要达到最终财产的财产名称。 必须指定第一步，因为它标记根bean的属性。
        结果
        创建ObjectBinding
        从以下版本开始：
        JavaFX 8.0

      • selectDouble

        public static DoubleBinding selectDouble​(Object root,
                                         String... steps)
        创建用于获取成员的绑定，例如a.b.c 。 结合的值将是c ，或0.0如果c无法达成（由于b不具有c属性， b是null ，或c不是一个Number等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在命名模块中，那么javafx.base模块必须能反映访问（参见Deploying an Application as a Module ）。

        如果root具有JavaFX属性，则此调用等同于selectDouble(javafx.beans.value.ObservableValue, java.lang.String[]) ，其中root和step[0]被替换为相关属性对象。

        参数
        root - 根豆。
        steps - 到达最终财产的财产名称。 必须指定第一步，因为它标记根bean的属性。
        结果
        创建DoubleBinding
        从以下版本开始：
        JavaFX 8.0

      • selectFloat

        public static FloatBinding selectFloat​(Object root,
                                       String... steps)
        创建用于获取成员的绑定，如a.b.c 。 结合的值将是c ，或0.0f如果c无法达成（由于b不具有c属性， b是null ，或c不是一个Number等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（参见Deploying an Application as a Module ）。

        如果root具有JavaFX属性，则此调用等同于selectFloat(javafx.beans.value.ObservableValue, java.lang.String[]) ，其中root和step[0]被相关属性对象替代。

        参数
        root - 根豆。
        steps - 到达最终财产的财产名称。 必须指定第一步，因为它标记根bean的属性。
        结果
        创建的FloatBinding
        从以下版本开始：
        JavaFX 8.0

      • selectInteger

        public static IntegerBinding selectInteger​(Object root,
                                           String... steps)
        创建用于获取成员的绑定，如a.b.c 。 结合的值将是c ，或0如果c无法达成（由于b不具有c属性， b是null ，或c不是一个Number等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（参见Deploying an Application as a Module ）。

        如果root具有JavaFX属性，则此调用等同于selectInteger(javafx.beans.value.ObservableValue, java.lang.String[]) ，其中root和step[0]被相关属性对象替代。

        参数
        root - 根豆。
        steps - 到达最终财产的财产名称。 必须指定第一步，因为它标记根bean的属性。
        结果
        创建的IntegerBinding
        从以下版本开始：
        JavaFX 8.0

      • selectLong

        public static LongBinding selectLong​(Object root,
                                     String... steps)
        创建用于获取成员的绑定，如a.b.c 。 结合的值将是c ，或0L如果c无法达成（由于b不具有c属性， b是null ，或c不是一个Number等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（见Deploying an Application as a Module ）。

        如果root具有JavaFX属性，则此调用等同于selectLong(javafx.beans.value.ObservableValue, java.lang.String[]) ，其中root和step[0]被相关属性对象替代。

        参数
        root - 根豆。
        steps - 到达最终财产的财产名称。 必须指定第一步，因为它标记根bean的属性。
        结果
        创建的LongBinding
        从以下版本开始：
        JavaFX 8.0

      • selectBoolean

        public static BooleanBinding selectBoolean​(Object root,
                                           String... steps)
        创建用于获取成员的绑定，例如a.b.c 。 结合的值将是c ，或false如果c无法达成（由于b不具有c属性， b是null ，或c不是一个boolean等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（参见Deploying an Application as a Module ）。

        如果root具有JavaFX属性，则此调用等效于selectBoolean(javafx.beans.value.ObservableValue, java.lang.String[]) ，其中root和step[0]被相关属性对象替代。

        参数
        root - 根豆。
        steps - 到达最终财产的财产名称。 必须指定第一步，因为它标记根bean的属性。
        结果
        创建ObjectBinding
        从以下版本开始：
        JavaFX 8.0

      • selectString

        public static StringBinding selectString​(Object root,
                                         String... steps)
        创建用于获取成员的绑定，如a.b.c 。 结合的值将是c ，或""如果c无法达成（由于b不具有c属性， b是null ，或c不是一个String等）。

        select-binding中使用的所有类和属性都必须被声明为public。 另外，如果任何类在一个命名的模块中，那么javafx.base模块必须反映可访问（见Deploying an Application as a Module ）。

        如果root具有JavaFX属性，则此调用等同于selectString(javafx.beans.value.ObservableValue, java.lang.String[]) ，其中root和step[0]被替换为相关属性对象。

        参数
        root - 根豆。
        steps - 到达最终财产的财产名称。 必须指定第一步，因为它标记根bean的属性。
        结果
        创建ObjectBinding
        从以下版本开始：
        JavaFX 8.0

      • when

        public static When when​(ObservableBooleanValue condition)
        创建一个计算三元表达式结果的绑定。 详见When的说明。
        参数
        condition - 三元表达的条件
        结果
        一个中间类来构建完整的绑定
        另请参见：
        When

      • bindBidirectional

        public static <T> void bindBidirectional​(Property<T> property1,
                                         Property<T> property2)
        在Property的两个实例之间生成双向绑定（或“反向绑定”）。

        双向绑定是在两个方向上工作的绑定。 如果两个属性a和b与双向结合和的值链接a变化， b自动设置为相同的值。 反之亦然，如果b发生变化，则a设置为相同的值。

        双向绑定可以用unbindBidirectional(Property, Property)删除。

        注意：双向绑定的这种实现与两个重要方面的所有其他绑定的行为不同。 链接到具有双向绑定的另一个属性的属性仍然可以设置（通常绑定会抛出异常）。 其次，热切地计算双向绑定，即立即更新绑定属性。

        参数类型
        T - 属性的类型
        参数
        property1 - 第一个 Property<T>
        property2 - 第二个 Property<T>
        异常
        NullPointerException - 如果其中一个属性是 null
        IllegalArgumentException - 如果两个属性都相等

      • unbindBidirectional

        public static <T> void unbindBidirectional​(Property<T> property1,
                                           Property<T> property2)
        删除先前使用 bindBidirectional(Property, Property)定义的双向绑定。
        参数类型
        T - 属性的类型
        参数
        property1 - 第一个 Property<T>
        property2 - 第二个 Property<T>
        异常
        NullPointerException - 如果其中一个属性是 null
        IllegalArgumentException - 如果两个属性都相等

      • unbindBidirectional

        public static void unbindBidirectional​(Object property1,
                                       Object property2)
        删除先前使用 bindBidirectional(Property, Property)或 bindBidirectional(javafx.beans.property.Property, javafx.beans.property.Property, java.text.Format)定义的双向绑定。
        参数
        property1 - 第一个 Property<T>
        property2 - 第二个 Property<T>
        异常
        NullPointerException - 如果其中一个属性是 null
        IllegalArgumentException - 如果两个属性都相等
        从以下版本开始：
        JavaFX 2.1

      • bindBidirectional

        public static void bindBidirectional​(Property<String> stringProperty,
                                     Property<?> otherProperty,
                                     Format format)
        在String - Property和另一个Property使用指定的Format生成双向绑定（或“反向绑定”）进行转换。

        双向绑定是在两个方向上工作的绑定。 如果两个属性a和b与双向结合和的值链接a变化， b自动设置为相同的值。 反之亦然，如果b发生变化， a设置为相同的值。

        双向绑定可以用unbindBidirectional(Object, Object)删除。

        注意：双向绑定的这种实现与两个重要方面的所有其他绑定的行为不同。 链接到具有双向绑定的另一个属性的属性仍然可以设置（通常绑定会抛出异常）。 其次，热切地计算双向绑定，即立即更新绑定属性。

        参数
        stringProperty - String Property
        otherProperty - 其他（非 String ） Property
        format - Format用于转换属性之间
        异常
        NullPointerException - 如果其中一个属性或 format是 null
        IllegalArgumentException - 如果两个属性都相等
        从以下版本开始：
        JavaFX 2.1

      • bindBidirectional

        public static <T> void bindBidirectional​(Property<String> stringProperty,
                                         Property<T> otherProperty,
                                         StringConverter<T> converter)
        在String - Property和另一个Property使用指定的StringConverter生成双向绑定（或“反向绑定”）进行转换。

        双向绑定是在两个方向上工作的绑定。 如果两个属性a和b与双向结合和的值链接a变化， b自动设置为相同的值。 反之亦然，如果b发生变化， a设置为相同的值。

        双向绑定可以用unbindBidirectional(Object, Object)删除。

        注意：双向绑定的这种实现与两个重要方面的所有其他绑定的行为不同。 链接到具有双向绑定的另一个属性的属性仍然可以设置（通常绑定会抛出异常）。 其次，热切地计算双向绑定，即立即更新绑定属性。

        参数类型
        T - 包装的类型 Object
        参数
        stringProperty - String Property
        otherProperty - 其他（非 String ） Property
        converter - StringConverter用于转换属性之间
        异常
        NullPointerException - 如果其中一个属性或 converter是 null
        IllegalArgumentException - 如果两个属性都相等
        从以下版本开始：
        JavaFX 2.1

      • bindContentBidirectional

        public static <E> void bindContentBidirectional​(ObservableList<E> list1,
                                                ObservableList<E> list2)
        在ObservableList的两个实例之间生成双向绑定（或“反向绑定”）。

        双向绑定是在两个方向上工作的绑定。 如果两个属性a和b与双向结合和的值链接a变化， b自动设置为相同的值。 反之亦然，如果b发生变化，则a设置为相同的值。

        只有两个列表的内容是同步的，这意味着两个列表都不同，但它们包含相同的元素。

        可以使用unbindContentBidirectional(Object, Object)删除双向内容绑定。

        注意：双向绑定的这种实现与两个重要方面的所有其他绑定的行为不同。 链接到具有双向绑定的另一个属性的属性仍然可以设置（通常绑定会抛出异常）。 其次，热切地计算双向绑定，即立即更新绑定属性。

        参数类型
        E - 列表元素的类型
        参数
        list1 - 第一个 ObservableList<E>
        list2 - 第二个 ObservableList<E>
        异常
        NullPointerException - 如果其中一个列表是 null
        IllegalArgumentException - 如果是 list1 == list2
        从以下版本开始：
        JavaFX 2.1

      • bindContentBidirectional

        public static <E> void bindContentBidirectional​(ObservableSet<E> set1,
                                                ObservableSet<E> set2)
        在ObservableSet的两个实例之间生成双向绑定（或“绑定”）。

        双向绑定是在两个方向上工作的绑定。 如果两个属性a和b与双向结合和的值链接a变化， b自动设置为相同的值。 反之亦然，如果b发生变化，则a设置为相同的值。

        只有两个集合的内容是同步的，这意味着两个集合是不同的，但它们包含相同的元素。

        可以使用unbindContentBidirectional(Object, Object)删除双向内容绑定。

        注意：双向绑定的这种实现与两个重要方面的所有其他绑定的行为不同。 链接到具有双向绑定的另一个属性的属性仍然可以设置（通常绑定会抛出异常）。 其次，热切地计算双向绑定，即立即更新绑定属性。

        参数类型
        E - 集合元素的类型
        参数
        set1 - 第一个 ObservableSet<E>
        set2 - 第二个 ObservableSet<E>
        异常
        NullPointerException - 如果其中一个集合是 null
        IllegalArgumentException - 如果是 set1 == set2
        从以下版本开始：
        JavaFX 2.1

      • bindContentBidirectional

        public static <K,V> void bindContentBidirectional​(ObservableMap<K,V> map1,
                                                  ObservableMap<K,V> map2)
        在ObservableMap的两个实例之间生成双向绑定（或“绑定”）。

        双向绑定是在两个方向上工作的绑定。 如果两个属性a和b与双向结合和的值链接a变化， b自动设置为相同的值。 反之亦然，如果b发生变化， a设置为相同的值。

        只有两个地图的内容是同步的，这意味着两个地图是不同的，但它们包含相同的元素。

        可以使用unbindContentBidirectional(Object, Object)删除双向内容绑定。

        注意：双向绑定的这种实现与两个重要方面的所有其他绑定的行为不同。 链接到具有双向绑定的另一个属性的属性仍然可以设置（通常绑定会抛出异常）。 其次，热切地计算双向绑定，即立即更新绑定属性。

        参数类型
        K - 关键元素的类型
        V - 值元素的类型
        参数
        map1 - 第一个 ObservableMap<K, V>
        map2 - 第二个 ObservableMap<K, V>
        从以下版本开始：
        JavaFX 2.1

      • unbindContentBidirectional

        public static void unbindContentBidirectional​(Object obj1,
                                              Object obj2)
        删除双向内容绑定。
        参数
        obj1 - 第一个 Object
        obj2 - 第二个 Object
        从以下版本开始：
        JavaFX 2.1

      • bindContent

        public static <E> void bindContent​(List<E> list1,
                                   ObservableList<? extends E> list2)
        生成ObservableList和List之间的内容绑定。

        一种内容结合确保了List包含相同的元件作为ObservableList 。 如果ObservableList的内容发生变化， List将自动更新。

        一旦List绑定到ObservableList ，该List不能直接再修改。 这样做会导致意想不到的结果。

        内容绑定可以用unbindContent(Object, Object)删除。

        参数类型
        E - List元素的类型
        参数
        list1 - List
        list2 - ObservableList
        从以下版本开始：
        JavaFX 2.1

      • bindContent

        public static <E> void bindContent​(Set<E> set1,
                                   ObservableSet<? extends E> set2)
        生成ObservableSet和Set之间的内容绑定。

        一种内容结合确保了Set包含相同的元件作为ObservableSet 。 如果ObservableSet的内容发生变化， Set将自动更新。

        一旦Set绑定到ObservableSet ，该Set不能直接再修改。 这样做会导致意想不到的结果。

        内容绑定可以用unbindContent(Object, Object)删除。

        参数类型
        E - Set元素的类型
        参数
        set1 - Set
        set2 - ObservableSet
        异常
        NullPointerException - 如果其中一个集合是 null
        IllegalArgumentException - 如果是 set1 == set2
        从以下版本开始：
        JavaFX 2.1

      • bindContent

        public static <K,V> void bindContent​(Map<K,V> map1,
                                     ObservableMap<? extends K,? extends V> map2)
        生成ObservableMap和Map之间的内容绑定。

        一种内容结合确保了Map包含相同的元件作为ObservableMap 。 如果ObservableMap的内容发生变化， Map将自动更新。

        一旦Map绑定到ObservableMap ，该Map不能直接再修改。 这样做会导致意想不到的结果。

        内容绑定可以用unbindContent(Object, Object)删除。

        参数类型
        K - K的关键元素的 Map
        V - V的值元素的 Map
        参数
        map1 - Map
        map2 - ObservableMap
        异常
        NullPointerException - 如果其中一张地图是 null
        IllegalArgumentException - 如果是 map1 == map2
        从以下版本开始：
        JavaFX 2.1

      • unbindContent

        public static void unbindContent​(Object obj1,
                                 Object obj2)
        删除内容绑定。
        参数
        obj1 - 第一个 Object
        obj2 - 第二个 Object
        异常
        NullPointerException - 如果 Objects是 null
        IllegalArgumentException - 如果是 obj1 == obj2
        从以下版本开始：
        JavaFX 2.1

      • negate

        public static NumberBinding negate​(ObservableNumberValue value)
        创建一个新的NumberBinding ，计算一个ObservableNumberValue的否定。
        参数
        value - 操作数
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果值是 null

      • add

        public static NumberBinding add​(ObservableNumberValue op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding计算的两个实例的值的总和ObservableNumberValue 。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • add

        public static DoubleBinding add​(ObservableNumberValue op1,
                                double op2)
        创建一个新的DoubleBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • add

        public static DoubleBinding add​(double op1,
                                ObservableNumberValue op2)
        创建一个新的DoubleBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • add

        public static NumberBinding add​(ObservableNumberValue op1,
                                float op2)
        创建一个新的NumberBinding ，计算一个ObservableNumberValue的值和一个恒定值的总和。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • add

        public static NumberBinding add​(float op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • add

        public static NumberBinding add​(ObservableNumberValue op1,
                                long op2)
        创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • add

        public static NumberBinding add​(long op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • add

        public static NumberBinding add​(ObservableNumberValue op1,
                                int op2)
        创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • add

        public static NumberBinding add​(int op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • subtract

        public static NumberBinding subtract​(ObservableNumberValue op1,
                                     ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算两个实例的值的差异ObservableNumberValue 。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • subtract

        public static DoubleBinding subtract​(ObservableNumberValue op1,
                                     double op2)
        创建一个新的DoubleBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • subtract

        public static DoubleBinding subtract​(double op1,
                                     ObservableNumberValue op2)
        创建一个新的DoubleBinding ，计算常数值和ObservableNumberValue的值的差异 。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • subtract

        public static NumberBinding subtract​(ObservableNumberValue op1,
                                     float op2)
        创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • subtract

        public static NumberBinding subtract​(float op1,
                                     ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • subtract

        public static NumberBinding subtract​(ObservableNumberValue op1,
                                     long op2)
        创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • subtract

        public static NumberBinding subtract​(long op1,
                                     ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算一个常数值和一个ObservableNumberValue的值的差异 。
        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • subtract

        public static NumberBinding subtract​(ObservableNumberValue op1,
                                     int op2)
        创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • subtract

        public static NumberBinding subtract​(int op1,
                                     ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • multiply

        public static NumberBinding multiply​(ObservableNumberValue op1,
                                     ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue两个实例的值的乘积 。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • multiply

        public static DoubleBinding multiply​(ObservableNumberValue op1,
                                     double op2)
        创建一个新的DoubleBinding ，计算ObservableNumberValue的值和常数值的乘积 。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • multiply

        public static DoubleBinding multiply​(double op1,
                                     ObservableNumberValue op2)
        创建一个新的DoubleBinding ，计算ObservableNumberValue的值和常数值的乘积 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • multiply

        public static NumberBinding multiply​(ObservableNumberValue op1,
                                     float op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • multiply

        public static NumberBinding multiply​(float op1,
                                     ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • multiply

        public static NumberBinding multiply​(ObservableNumberValue op1,
                                     long op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • multiply

        public static NumberBinding multiply​(long op1,
                                     ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • multiply

        public static NumberBinding multiply​(ObservableNumberValue op1,
                                     int op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • multiply

        public static NumberBinding multiply​(int op1,
                                     ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • divide

        public static NumberBinding divide​(ObservableNumberValue op1,
                                   ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的值的除法 。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果一个操作数是 null

      • divide

        public static DoubleBinding divide​(ObservableNumberValue op1,
                                   double op2)
        创建一个新的DoubleBinding ，计算ObservableNumberValue的值除数和常数值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • divide

        public static DoubleBinding divide​(double op1,
                                   ObservableNumberValue op2)
        创建一个新的DoubleBinding ，计算一个常数值的除法和一个ObservableNumberValue的值。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • divide

        public static NumberBinding divide​(ObservableNumberValue op1,
                                   float op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值除数和常数值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • divide

        public static NumberBinding divide​(float op1,
                                   ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算一个常数值的除法和一个ObservableNumberValue的值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • divide

        public static NumberBinding divide​(ObservableNumberValue op1,
                                   long op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值除数和常数值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • divide

        public static NumberBinding divide​(long op1,
                                   ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算一个常数值和ObservableNumberValue的值的除法 。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • divide

        public static NumberBinding divide​(ObservableNumberValue op1,
                                   int op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值除以恒定值。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • divide

        public static NumberBinding divide​(int op1,
                                   ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算一个常数值的除法和一个ObservableNumberValue的值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(ObservableNumberValue op1,
                                   ObservableNumberValue op2,
                                   double epsilon)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等（与公差）。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • equal

        public static BooleanBinding equal​(ObservableNumberValue op1,
                                   ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等。

        当比较浮点数时，建议使用允许较小容差的equal()方法。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • equal

        public static BooleanBinding equal​(ObservableNumberValue op1,
                                   double op2,
                                   double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(double op1,
                                   ObservableNumberValue op2,
                                   double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(ObservableNumberValue op1,
                                   float op2,
                                   double epsilon)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值（具有公差）。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(float op1,
                                   ObservableNumberValue op2,
                                   double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(ObservableNumberValue op1,
                                   long op2,
                                   double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(ObservableNumberValue op1,
                                   long op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值。

        当比较浮点数时，建议使用允许较小容差的equal()方法。

        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(long op1,
                                   ObservableNumberValue op2,
                                   double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(long op1,
                                   ObservableNumberValue op2)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许较小容差的equal()方法。

        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(ObservableNumberValue op1,
                                   int op2,
                                   double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。

        如果Math.abs(a-b) <= epsilon两个操作数a和b被认为是相等的。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(ObservableNumberValue op1,
                                   int op2)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许较小容差的equal()方法。

        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(int op1,
                                   ObservableNumberValue op2,
                                   double epsilon)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值（具有公差）。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • equal

        public static BooleanBinding equal​(int op1,
                                   ObservableNumberValue op2)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许较小容差的equal()方法。

        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableNumberValue op1,
                                      ObservableNumberValue op2,
                                      double epsilon)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等（与公差）。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 其中一个操作数是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableNumberValue op1,
                                      ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等。

        当比较浮点数时，建议使用允许较小容差的notEqual()方法。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果一个操作数是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableNumberValue op1,
                                      double op2,
                                      double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(double op1,
                                      ObservableNumberValue op2,
                                      double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableNumberValue op1,
                                      float op2,
                                      double epsilon)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(float op1,
                                      ObservableNumberValue op2,
                                      double epsilon)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableNumberValue op1,
                                      long op2,
                                      double epsilon)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableNumberValue op1,
                                      long op2)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许小容差的notEqual()方法。

        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(long op1,
                                      ObservableNumberValue op2,
                                      double epsilon)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。

        如果Math.abs(a-b) <= epsilon两个操作数a和b被认为是相等的。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(long op1,
                                      ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值。

        当比较浮点数时，建议使用允许较小容差的notEqual()方法。

        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableNumberValue op1,
                                      int op2,
                                      double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。

        如果Math.abs(a-b) <= epsilon两个操作数a和b被认为是相等的。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableNumberValue op1,
                                      int op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值。

        当比较浮点数时，建议使用允许较小容差的notEqual()方法。

        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(int op1,
                                      ObservableNumberValue op2,
                                      double epsilon)
        创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • notEqual

        public static BooleanBinding notEqual​(int op1,
                                      ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值。

        当比较浮点数时，建议使用允许小容差的notEqual()方法。

        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(ObservableNumberValue op1,
                                         ObservableNumberValue op2)
        创建一个新的BooleanBinding ，如果第一个ObservableNumberValue的值大于第二个值，则保留true 。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • greaterThan

        public static BooleanBinding greaterThan​(ObservableNumberValue op1,
                                         double op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(double op1,
                                         ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(ObservableNumberValue op1,
                                         float op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(float op1,
                                         ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(ObservableNumberValue op1,
                                         long op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(long op1,
                                         ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(ObservableNumberValue op1,
                                         int op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(int op1,
                                         ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThan

        public static BooleanBinding lessThan​(ObservableNumberValue op1,
                                      ObservableNumberValue op2)
        创建新的BooleanBinding ，如果第一个ObservableNumberValue的值小于第二个值，则保留true 。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • lessThan

        public static BooleanBinding lessThan​(ObservableNumberValue op1,
                                      double op2)
        创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThan

        public static BooleanBinding lessThan​(double op1,
                                      ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThan

        public static BooleanBinding lessThan​(ObservableNumberValue op1,
                                      float op2)
        创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThan

        public static BooleanBinding lessThan​(float op1,
                                      ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThan

        public static BooleanBinding lessThan​(ObservableNumberValue op1,
                                      long op2)
        创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThan

        public static BooleanBinding lessThan​(long op1,
                                      ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThan

        public static BooleanBinding lessThan​(ObservableNumberValue op1,
                                      int op2)
        创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThan

        public static BooleanBinding lessThan​(int op1,
                                      ObservableNumberValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1,
                                                ObservableNumberValue op2)
        创建新的BooleanBinding ，如果第一个ObservableNumberValue的值大于或等于第二个值，则保留true 。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1,
                                                double op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(double op1,
                                                ObservableNumberValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1,
                                                float op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(float op1,
                                                ObservableNumberValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1,
                                                long op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(long op1,
                                                ObservableNumberValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(ObservableNumberValue op1,
                                                int op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 常数值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(int op1,
                                                ObservableNumberValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
        参数
        op1 - 常数值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1,
                                             ObservableNumberValue op2)
        创建新的BooleanBinding ，如果第一个ObservableNumberValue的值小于或等于第二个值，则保留true 。
        参数
        op1 - op1 - op1 - op1 - op1 - op1 - op1
        op2 - op2 - op2 - op2 - op2
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1,
                                             double op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(double op1,
                                             ObservableNumberValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1,
                                             float op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(float op1,
                                             ObservableNumberValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1,
                                             long op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(long op1,
                                             ObservableNumberValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(ObservableNumberValue op1,
                                             int op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(int op1,
                                             ObservableNumberValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • min

        public static NumberBinding min​(ObservableNumberValue op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的最小值 。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • min

        public static DoubleBinding min​(ObservableNumberValue op1,
                                double op2)
        创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最小值和常数值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • min

        public static DoubleBinding min​(double op1,
                                ObservableNumberValue op2)
        创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最小值和常数值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • min

        public static NumberBinding min​(ObservableNumberValue op1,
                                float op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • min

        public static NumberBinding min​(float op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • min

        public static NumberBinding min​(ObservableNumberValue op1,
                                long op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • min

        public static NumberBinding min​(long op1,
                                ObservableNumberValue op2)
        创建新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • min

        public static NumberBinding min​(ObservableNumberValue op1,
                                int op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • min

        public static NumberBinding min​(int op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • max

        public static NumberBinding max​(ObservableNumberValue op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue两个实例的最大值 。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • max

        public static DoubleBinding max​(ObservableNumberValue op1,
                                double op2)
        创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最大值和常数值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • max

        public static DoubleBinding max​(double op1,
                                ObservableNumberValue op2)
        创建一个新的DoubleBinding ，计算一个ObservableNumberValue的值的最大值和一个常量值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • max

        public static NumberBinding max​(ObservableNumberValue op1,
                                float op2)
        创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最大值和一个恒定值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • max

        public static NumberBinding max​(float op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • max

        public static NumberBinding max​(ObservableNumberValue op1,
                                long op2)
        创建一个新的NumberBinding ，计算一个ObservableNumberValue的值的最大值和一个常量值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • max

        public static NumberBinding max​(long op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • max

        public static NumberBinding max​(ObservableNumberValue op1,
                                int op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
        参数
        op1 - ObservableNumberValue
        op2 - 恒定值
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • max

        public static NumberBinding max​(int op1,
                                ObservableNumberValue op2)
        创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
        参数
        op1 - 恒定值
        op2 - ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果 ObservableNumberValue是 null

      • and

        public static BooleanBinding and​(ObservableBooleanValue op1,
                                 ObservableBooleanValue op2)
        创建一个BooleanBinding ，它为ObservableBooleanValue的两个实例的值计算条件AND操作。
        参数
        op1 - 第 ObservableBooleanValue
        op2 - 第二 ObservableBooleanValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • or

        public static BooleanBinding or​(ObservableBooleanValue op1,
                                ObservableBooleanValue op2)
        创建一个BooleanBinding ，它为ObservableBooleanValue的两个实例的值计算条件OR操作。
        参数
        op1 - 第 ObservableBooleanValue
        op2 - 第二 ObservableBooleanValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • not

        public static BooleanBinding not​(ObservableBooleanValue op)
        创建一个BooleanBinding ，计算一个ObservableBooleanValue的值的倒数 。
        参数
        op - ObservableBooleanValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果操作数是 null

      • equal

        public static BooleanBinding equal​(ObservableBooleanValue op1,
                                   ObservableBooleanValue op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue相等。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 其中一个操作数是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableBooleanValue op1,
                                      ObservableBooleanValue op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue不相等。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 其中一个操作数是 null

      • convert

        public static StringExpression convert​(ObservableValue<?> observableValue)
        返回一个ObservableValue ，其中包含一个ObservableValue 。 如果ObservableValue已经是StringExpression ，它将被返回。 否则，将创建一个新的StringBinding ，将ObservableValue的值转换为String 。
        参数
        observableValue - 来源 ObservableValue
        结果
        一个 StringExpression包装了 ObservableValue如果有必要
        异常
        NullPointerException - 如果 observableValue是 null

      • concat

        public static StringExpression concat​(Object... args)
        返回一个StringExpression ，它保持多个连接的值Objects 。

        如果其中一个参数实现ObservableValue，并且这个ObservableValue的值发生变化，这个变化将自动反映在StringExpression 。

        如果null或空数组传递给该方法， StringExpression包含一个空String返回

        参数
        args - 应该连接的 Objects
        结果
        新的 StringExpression

      • format

        public static StringExpression format​(String format,
                                      Object... args)
        创建StringExpression保持多个值Objects根据格式格式化String 。

        如果其中一个参数实现了ObservableValue，并且这个ObservableValue的值发生变化，这个变化将自动反映在StringExpression 。

        有关格式规则，请参阅java.util.Formatter 。

        参数
        format - 格式 String
        args - Objects应该插入格式 String
        结果
        新的 StringExpression

      • format

        public static StringExpression format​(Locale locale,
                                      String format,
                                      Object... args)
        创建StringExpression保持多个值Objects根据格式格式化String和指定Locale

        如果其中一个参数实现了ObservableValue ，而这个ObservableValue的值改变了，这个变化会自动反映在StringExpression 。

        有关格式规则，请参阅java.util.Formatter 。 见java.util.Locale的细节Locale 。

        参数
        locale - 在格式化期间使用的 Locale
        format - 格式 String
        args - Objects应该插入格式 String
        结果
        新的 StringExpression

      • equal

        public static BooleanBinding equal​(ObservableStringValue op1,
                                   ObservableStringValue op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • equal

        public static BooleanBinding equal​(ObservableStringValue op1,
                                   String op2)
        创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - ObservableStringValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • equal

        public static BooleanBinding equal​(String op1,
                                   ObservableStringValue op2)
        创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 恒定值
        op2 - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableStringValue op1,
                                      ObservableStringValue op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不相等。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableStringValue op1,
                                      String op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不等于一个恒定值。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - ObservableStringValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • notEqual

        public static BooleanBinding notEqual​(String op1,
                                      ObservableStringValue op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不等于一个恒定值。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 恒定值
        op2 - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • equalIgnoreCase

        public static BooleanBinding equalIgnoreCase​(ObservableStringValue op1,
                                             ObservableStringValue op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等忽略大小写。

        注意：在这个比较中，一个String是null被认为等于一个空的String 。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • equalIgnoreCase

        public static BooleanBinding equalIgnoreCase​(ObservableStringValue op1,
                                             String op2)
        创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个常数值忽略大小写，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - ObservableStringValue
        op2 - 常数值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • equalIgnoreCase

        public static BooleanBinding equalIgnoreCase​(String op1,
                                             ObservableStringValue op2)
        创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值忽略大小写，则保留true 。

        注意：在这个比较中，一个String是null被认为等于一个空的String 。

        参数
        op1 - 恒定值
        op2 - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • notEqualIgnoreCase

        public static BooleanBinding notEqualIgnoreCase​(ObservableStringValue op1,
                                                ObservableStringValue op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不等于忽略大小写。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 其中一个操作数是 null

      • notEqualIgnoreCase

        public static BooleanBinding notEqualIgnoreCase​(ObservableStringValue op1,
                                                String op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - ObservableStringValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • notEqualIgnoreCase

        public static BooleanBinding notEqualIgnoreCase​(String op1,
                                                ObservableStringValue op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 恒定值
        op2 - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(ObservableStringValue op1,
                                         ObservableStringValue op2)
        创建新的BooleanBinding ，如果第一个ObservableStringValue的值大于第二个值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • greaterThan

        public static BooleanBinding greaterThan​(ObservableStringValue op1,
                                         String op2)
        创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue比恒定值。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - ObservableStringValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • greaterThan

        public static BooleanBinding greaterThan​(String op1,
                                         ObservableStringValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值的值比的值越大ObservableStringValue 。

        注意：在这个比较中， String为null被认为等于一个空的String 。

        参数
        op1 - 恒定值
        op2 - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • lessThan

        public static BooleanBinding lessThan​(ObservableStringValue op1,
                                      ObservableStringValue op2)
        创建新的BooleanBinding ，如果第一个ObservableStringValue的值小于第二个值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • lessThan

        public static BooleanBinding lessThan​(ObservableStringValue op1,
                                      String op2)
        创建一个新的BooleanBinding持有true如果一个值ObservableStringValue小于一个恒定值。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - ObservableStringValue
        op2 - 常数值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • lessThan

        public static BooleanBinding lessThan​(String op1,
                                      ObservableStringValue op2)
        创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableStringValue 。

        注意：在这个比较中， String即null被认为等于一个空的String 。

        参数
        op1 - 恒定值
        op2 - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(ObservableStringValue op1,
                                                ObservableStringValue op2)
        创建新的BooleanBinding ，如果第一个ObservableStringValue的值大于或等于第二个值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(ObservableStringValue op1,
                                                String op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableStringValue大于或等于恒定值。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - ObservableStringValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • greaterThanOrEqual

        public static BooleanBinding greaterThanOrEqual​(String op1,
                                                ObservableStringValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableStringValue 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 恒定值
        op2 - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(ObservableStringValue op1,
                                             ObservableStringValue op2)
        创建一个新的BooleanBinding ，如果第一个ObservableStringValue的值小于或等于第二个值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(ObservableStringValue op1,
                                             String op2)
        创建一个新的BooleanBinding保持true如果a的值ObservableStringValue小于或等于恒定值。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - ObservableStringValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • lessThanOrEqual

        public static BooleanBinding lessThanOrEqual​(String op1,
                                             ObservableStringValue op2)
        创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableStringValue 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        op1 - 恒定值
        op2 - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null

      • length

        public static IntegerBinding length​(ObservableStringValue op)
        创建一个新的IntegerBinding ，其长度为ObservableStringValue 。

        注意：在这个比较中， String是null被认为是长度为0 。

        参数
        op - ObservableStringValue
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null
        从以下版本开始：
        JavaFX 8.0

      • isEmpty

        public static BooleanBinding isEmpty​(ObservableStringValue op)
        创建一个新的BooleanBinding ，如果ObservableStringValue的值为空，则保留true 。

        注意：在这个比较中， String是null被认为是空的。

        参数
        op - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null
        从以下版本开始：
        JavaFX 8.0

      • isNotEmpty

        public static BooleanBinding isNotEmpty​(ObservableStringValue op)
        创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不是空的。

        注意：在这个比较中， String是null被认为是空的。

        参数
        op - ObservableStringValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableStringValue是 null
        从以下版本开始：
        JavaFX 8.0

      • equal

        public static BooleanBinding equal​(ObservableObjectValue<?> op1,
                                   ObservableObjectValue<?> op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue相等。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • equal

        public static BooleanBinding equal​(ObservableObjectValue<?> op1,
                                   Object op2)
        创建一个新的BooleanBinding保持true如果一个的值ObservableObjectValue等于恒定值。
        参数
        op1 - ObservableCharacterValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableCharacterValue是 null

      • equal

        public static BooleanBinding equal​(Object op1,
                                   ObservableObjectValue<?> op2)
        创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值等于一个恒定值，则保存true 。
        参数
        op1 - 恒定值
        op2 - ObservableCharacterValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableCharacterValue是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableObjectValue<?> op1,
                                      ObservableObjectValue<?> op2)
        创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue不相等。
        参数
        op1 - 第一个操作数
        op2 - 第二个操作数
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其中一个操作数是 null

      • notEqual

        public static BooleanBinding notEqual​(ObservableObjectValue<?> op1,
                                      Object op2)
        创建一个新的BooleanBinding保持true如果一个的值ObservableObjectValue不等于恒定值。
        参数
        op1 - ObservableObjectValue
        op2 - 恒定值
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableObjectValue是 null

      • notEqual

        public static BooleanBinding notEqual​(Object op1,
                                      ObservableObjectValue<?> op2)
        创建一个新的BooleanBinding保持true如果一个的值ObservableObjectValue不等于恒定值。
        参数
        op1 - 恒定值
        op2 - ObservableObjectValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableObjectValue是 null

      • isNull

        public static BooleanBinding isNull​(ObservableObjectValue<?> op)
        创建一个新的BooleanBinding ，如果true的值为null，则null 。
        参数
        op - ObservableObjectValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableObjectValue是 null

      • isNotNull

        public static BooleanBinding isNotNull​(ObservableObjectValue<?> op)
        创建一个新的BooleanBinding持有true如果一个价值ObservableObjectValue不null 。
        参数
        op - ObservableObjectValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableObjectValue是 null

      • size

        public static <E> IntegerBinding size​(ObservableList<E> op)
        创建一个新的IntegerBinding ，其大小包含ObservableList 。
        参数类型
        E - List元素的类型
        参数
        op - ObservableList
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        从以下版本开始：
        JavaFX 2.1

      • isEmpty

        public static <E> BooleanBinding isEmpty​(ObservableList<E> op)
        创建一个新的BooleanBinding ，如果给定的ObservableList为空，则保留true 。
        参数类型
        E - List元素的类型
        参数
        op - ObservableList
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        从以下版本开始：
        JavaFX 2.1

      • isNotEmpty

        public static <E> BooleanBinding isNotEmpty​(ObservableList<E> op)
        创建一个新的BooleanBinding ，如果给定的ObservableList不为空，则保留true 。
        参数类型
        E - List元素的类型
        参数
        op - ObservableList
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        从以下版本开始：
        JavaFX 8.0

      • valueAt

        public static <E> ObjectBinding<E> valueAt​(ObservableList<E> op,
                                           int index)
        创建一个新的ObjectBinding ，其中包含ObservableList在指定位置的元素。 ObjectBinding将包含null ，如果index点落后于ObservableList 。
        参数类型
        E - List元素的类型
        参数
        op - ObservableList
        index - 位置在 List
        结果
        新的 ObjectBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        IllegalArgumentException - if（@code index <0）
        从以下版本开始：
        JavaFX 2.1

      • valueAt

        public static <E> ObjectBinding<E> valueAt​(ObservableList<E> op,
                                           ObservableIntegerValue index)
        创建一个新的ObjectBinding ，其中包含指定位置的ObservableList的元素。 该ObjectBinding将包含null ，如果index是外ObservableList 。
        参数类型
        E - List元素的类型
        参数
        op - ObservableList
        index - 位置在 List
        结果
        新的 ObjectBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 2.1

      • valueAt

        public static <E> ObjectBinding<E> valueAt​(ObservableList<E> op,
                                           ObservableNumberValue index)
        创建一个新的ObjectBinding ，其中包含ObservableList在指定位置的元素。 该ObjectBinding将包含null ，如果index是外ObservableList 。
        参数类型
        E - List元素的类型
        参数
        op - ObservableList
        index - 位置在 List ，转换为int
        结果
        新的 ObjectBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • booleanValueAt

        public static BooleanBinding booleanValueAt​(ObservableList<Boolean> op,
                                            int index)
        创建一个新的BooleanBinding ，其中包含指定位置的ObservableList元素。 BooleanBinding将持有false ，若index点落后ObservableList 。
        参数
        op - ObservableList
        index -在位置 List
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        IllegalArgumentException - if（@code index <0）
        从以下版本开始：
        JavaFX 2.1

      • booleanValueAt

        public static BooleanBinding booleanValueAt​(ObservableList<Boolean> op,
                                            ObservableIntegerValue index)
        创建一个新的BooleanBinding ，其中包含ObservableList在指定位置的元素。 该BooleanBinding将举行false ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 2.1

      • booleanValueAt

        public static BooleanBinding booleanValueAt​(ObservableList<Boolean> op,
                                            ObservableNumberValue index)
        创建一个新的BooleanBinding ，其中包含指定位置的ObservableList的元素。 该BooleanBinding将举行false ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List ，转换为int
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • doubleValueAt

        public static DoubleBinding doubleValueAt​(ObservableList<? extends Number> op,
                                          int index)
        创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。 DoubleBinding将持有0.0 ，如果index点落后于ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        IllegalArgumentException - if（@code index <0）
        从以下版本开始：
        JavaFX 2.1

      • doubleValueAt

        public static DoubleBinding doubleValueAt​(ObservableList<? extends Number> op,
                                          ObservableIntegerValue index)
        创建一个新的DoubleBinding ，其中包含ObservableList在指定位置的元素。 该DoubleBinding将举行0.0 ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index -在位置 List
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 2.1

      • doubleValueAt

        public static DoubleBinding doubleValueAt​(ObservableList<? extends Number> op,
                                          ObservableNumberValue index)
        创建一个新的DoubleBinding ，其中包含指定位置的ObservableList元素。 该DoubleBinding将举行0.0 ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List ，转换为int
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • floatValueAt

        public static FloatBinding floatValueAt​(ObservableList<? extends Number> op,
                                        int index)
        创建一个新的FloatBinding ，其中包含指定位置的ObservableList的元素。 FloatBinding将持有0.0f ，如果index点落后于ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List
        结果
        新的 FloatBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        IllegalArgumentException - if（@code index <0）
        从以下版本开始：
        JavaFX 2.1

      • floatValueAt

        public static FloatBinding floatValueAt​(ObservableList<? extends Number> op,
                                        ObservableIntegerValue index)
        创建一个新的FloatBinding ，其中包含指定位置的ObservableList的元素。 该FloatBinding将举行0.0f ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List
        结果
        新的 FloatBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 2.1

      • floatValueAt

        public static FloatBinding floatValueAt​(ObservableList<? extends Number> op,
                                        ObservableNumberValue index)
        创建一个新的FloatBinding ，其中包含ObservableList在指定位置的元素。 该FloatBinding将举行0.0f ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List ，转换为int
        结果
        新的 FloatBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • integerValueAt

        public static IntegerBinding integerValueAt​(ObservableList<? extends Number> op,
                                            int index)
        创建一个新的IntegerBinding ，其中包含指定位置的ObservableList元素。 IntegerBinding将持有0 ，如果index点落后于ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        IllegalArgumentException - if（@code index <0）
        从以下版本开始：
        JavaFX 2.1

      • integerValueAt

        public static IntegerBinding integerValueAt​(ObservableList<? extends Number> op,
                                            ObservableIntegerValue index)
        创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。 该IntegerBinding将举行0 ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 2.1

      • integerValueAt

        public static IntegerBinding integerValueAt​(ObservableList<? extends Number> op,
                                            ObservableNumberValue index)
        创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。 该IntegerBinding将举行0 ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List ，转换为int
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • longValueAt

        public static LongBinding longValueAt​(ObservableList<? extends Number> op,
                                      int index)
        创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。 LongBinding将持有0L ，如果index点落后于ObservableList 。
        参数
        op - ObservableList
        index -在位置 List
        结果
        新的 LongBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        IllegalArgumentException - if（@code index <0）
        从以下版本开始：
        JavaFX 2.1

      • longValueAt

        public static LongBinding longValueAt​(ObservableList<? extends Number> op,
                                      ObservableIntegerValue index)
        创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。 该LongBinding将举行0L ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index -在位置 List
        结果
        新的 LongBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 2.1

      • longValueAt

        public static LongBinding longValueAt​(ObservableList<? extends Number> op,
                                      ObservableNumberValue index)
        创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。 该LongBinding将举行0L ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List ，转换为int
        结果
        新的 LongBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • stringValueAt

        public static StringBinding stringValueAt​(ObservableList<String> op,
                                          int index)
        创建一个新的StringBinding ，其中包含ObservableList在指定位置的元素。 StringBinding将持有null ，如果index点落后于ObservableList 。
        参数
        op - ObservableList
        index -在位置 List
        结果
        新的 StringBinding
        异常
        NullPointerException - 如果 ObservableList是 null
        IllegalArgumentException - if（@code index <0）
        从以下版本开始：
        JavaFX 2.1

      • stringValueAt

        public static StringBinding stringValueAt​(ObservableList<String> op,
                                          ObservableIntegerValue index)
        创建一个新的StringBinding ，其中包含指定位置的ObservableList元素。 该StringBinding将举行"" ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index - 位置在 List
        结果
        新的 StringBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 2.1

      • stringValueAt

        public static StringBinding stringValueAt​(ObservableList<String> op,
                                          ObservableNumberValue index)
        创建一个新的StringBinding ，其中包含指定位置的ObservableList的元素。 该StringBinding将举行"" ，如果index是外ObservableList 。
        参数
        op - ObservableList
        index -在位置 List ，转换为int
        结果
        新的 StringBinding
        异常
        NullPointerException - 如果 ObservableList或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • size

        public static <E> IntegerBinding size​(ObservableSet<E> op)
        创建一个新的IntegerBinding ，其大小包含ObservableSet 。
        参数类型
        E - Set元素的类型
        参数
        op - ObservableSet
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableSet是 null
        从以下版本开始：
        JavaFX 2.1

      • isEmpty

        public static <E> BooleanBinding isEmpty​(ObservableSet<E> op)
        创建一个新的BooleanBinding ，如果给定的ObservableSet为空，则保留true 。
        参数类型
        E - Set元素的类型
        参数
        op - ObservableSet
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableSet是 null
        从以下版本开始：
        JavaFX 2.1

      • isNotEmpty

        public static <E> BooleanBinding isNotEmpty​(ObservableSet<E> op)
        创建一个新的BooleanBinding ，如果给定的ObservableSet不为空，则保留true 。
        参数类型
        E - Set元素的类型
        参数
        op - ObservableSet
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableSet是 null
        从以下版本开始：
        JavaFX 8.0

      • size

        public static IntegerBinding size​(ObservableArray op)
        创建一个新的IntegerBinding ，其大小为ObservableArray 。
        参数
        op - ObservableArray
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableArray是 null
        从以下版本开始：
        JavaFX 8.0

      • floatValueAt

        public static FloatBinding floatValueAt​(ObservableFloatArray op,
                                        int index)
        创建一个新的FloatBinding ，其中包含ObservableArray在指定位置的元素。 FloatBinding将持有0.0f ，如果index点落后于ObservableArray 。
        参数
        op - ObservableArray
        index - 位置在 ObservableArray
        结果
        新的 FloatBinding
        异常
        NullPointerException - 如果 ObservableArray是 null
        IllegalArgumentException - if（@code index <0）
        从以下版本开始：
        JavaFX 8.0

      • floatValueAt

        public static FloatBinding floatValueAt​(ObservableFloatArray op,
                                        ObservableIntegerValue index)
        创建一个新的FloatBinding ，其中包含ObservableArray在指定位置的元素。 该FloatBinding将举行0.0f ，如果index是外ObservableArray 。
        参数
        op - ObservableArray
        index -在位置 ObservableArray
        结果
        新的 FloatBinding
        异常
        NullPointerException - 如果 ObservableArray或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • floatValueAt

        public static FloatBinding floatValueAt​(ObservableFloatArray op,
                                        ObservableNumberValue index)
        创建一个新的FloatBinding ，其中包含指定位置的ObservableArray的元素。 该FloatBinding将举行0.0f ，如果index是外ObservableArray 。
        参数
        op - ObservableArray
        index - 位置在 ObservableArray ，转换为int
        结果
        新的 FloatBinding
        异常
        NullPointerException - 如果 ObservableArray或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • integerValueAt

        public static IntegerBinding integerValueAt​(ObservableIntegerArray op,
                                            int index)
        创建一个新的IntegerBinding ，其中包含指定位置的ObservableArray的元素。 IntegerBinding将持有0 ，如果index点落后于ObservableArray 。
        参数
        op - ObservableArray
        index -在位置 ObservableArray
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableArray是 null
        IllegalArgumentException - if（@code index <0）
        从以下版本开始：
        JavaFX 8.0

      • integerValueAt

        public static IntegerBinding integerValueAt​(ObservableIntegerArray op,
                                            ObservableIntegerValue index)
        创建一个新的IntegerBinding ，其中包含ObservableArray在指定位置的元素。 该IntegerBinding将举行0 ，如果index是外ObservableArray 。
        参数
        op - ObservableArray
        index -在位置 ObservableArray
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableArray或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • integerValueAt

        public static IntegerBinding integerValueAt​(ObservableIntegerArray op,
                                            ObservableNumberValue index)
        创建一个新的IntegerBinding ，其中包含ObservableArray在指定位置的元素。 该IntegerBinding将举行0 ，如果index是外ObservableArray 。
        参数
        op - ObservableArray
        index -在位置 ObservableArray ，转换为int
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableArray或 index是 null
        从以下版本开始：
        JavaFX 8.0

      • size

        public static <K,V> IntegerBinding size​(ObservableMap<K,V> op)
        创建一个新的IntegerBinding ，其大小为ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        V - V的值元素的 Map
        参数
        op - ObservableMap
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 2.1

      • isEmpty

        public static <K,V> BooleanBinding isEmpty​(ObservableMap<K,V> op)
        创建一个新的BooleanBinding ，如果给定的ObservableMap为空，则保留true 。
        参数类型
        K - K的关键元素的 Map
        V - V的值元素的 Map
        参数
        op - ObservableMap
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 2.1

      • isNotEmpty

        public static <K,V> BooleanBinding isNotEmpty​(ObservableMap<K,V> op)
        创建一个新的BooleanBinding ，如果给定的ObservableMap不为空，则保留true 。
        参数类型
        K - K的关键元素的 Map
        V - V的值元素的 Map
        参数
        op - ObservableMap
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 8.0

      • valueAt

        public static <K,V> ObjectBinding<V> valueAt​(ObservableMap<K,V> op,
                                             K key)
        创建一个新的ObjectBinding ，其中包含ObservableMap中的特定键的映射 。
        参数类型
        K - K的关键元素的 Map
        V - V的值元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 ObjectBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 2.1

      • valueAt

        public static <K,V> ObjectBinding<V> valueAt​(ObservableMap<K,V> op,
                                             ObservableValue<? extends K> key)
        创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
        参数类型
        K - K的关键元素的 Map
        V - V的值元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 ObjectBinding
        异常
        NullPointerException - 如果 ObservableMap或 key是 null
        从以下版本开始：
        JavaFX 2.1

      • booleanValueAt

        public static <K> BooleanBinding booleanValueAt​(ObservableMap<K,Boolean> op,
                                                K key)
        创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。 BooleanBinding将持有false ，如果在key中找不到ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 2.1

      • booleanValueAt

        public static <K> BooleanBinding booleanValueAt​(ObservableMap<K,Boolean> op,
                                                ObservableValue<? extends K> key)
        创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。 BooleanBinding将持有false ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 ObservableMap或 key是 null
        从以下版本开始：
        JavaFX 2.1

      • doubleValueAt

        public static <K> DoubleBinding doubleValueAt​(ObservableMap<K,? extends Number> op,
                                              K key)
        创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。 DoubleBinding将持有0.0 ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 2.1

      • doubleValueAt

        public static <K> DoubleBinding doubleValueAt​(ObservableMap<K,? extends Number> op,
                                              ObservableValue<? extends K> key)
        创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。 DoubleBinding将持有0.0 ，如果在key中找不到ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 DoubleBinding
        异常
        NullPointerException - 如果 ObservableMap或 key是 null
        从以下版本开始：
        JavaFX 2.1

      • floatValueAt

        public static <K> FloatBinding floatValueAt​(ObservableMap<K,? extends Number> op,
                                            K key)
        创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。 FloatBinding将持有0.0f ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 FloatBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 2.1

      • floatValueAt

        public static <K> FloatBinding floatValueAt​(ObservableMap<K,? extends Number> op,
                                            ObservableValue<? extends K> key)
        创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。 FloatBinding将持有0.0f ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 FloatBinding
        异常
        NullPointerException - 如果 ObservableMap或 key是 null
        从以下版本开始：
        JavaFX 2.1

      • integerValueAt

        public static <K> IntegerBinding integerValueAt​(ObservableMap<K,? extends Number> op,
                                                K key)
        创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。 IntegerBinding将持有0 ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 2.1

      • integerValueAt

        public static <K> IntegerBinding integerValueAt​(ObservableMap<K,? extends Number> op,
                                                ObservableValue<? extends K> key)
        创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。 IntegerBinding将持有0 ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 IntegerBinding
        异常
        NullPointerException - 如果 ObservableMap或 key是 null
        从以下版本开始：
        JavaFX 2.1

      • longValueAt

        public static <K> LongBinding longValueAt​(ObservableMap<K,? extends Number> op,
                                          K key)
        创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。 LongBinding将持有0L ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 LongBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 2.1

      • longValueAt

        public static <K> LongBinding longValueAt​(ObservableMap<K,? extends Number> op,
                                          ObservableValue<? extends K> key)
        创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。 LongBinding将持有0L ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 LongBinding
        异常
        NullPointerException - 如果 ObservableMap或 key是 null
        从以下版本开始：
        JavaFX 2.1

      • stringValueAt

        public static <K> StringBinding stringValueAt​(ObservableMap<K,String> op,
                                              K key)
        创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。 StringBinding将持有null ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 StringBinding
        异常
        NullPointerException - 如果 ObservableMap是 null
        从以下版本开始：
        JavaFX 2.1

      • stringValueAt

        public static <K> StringBinding stringValueAt​(ObservableMap<K,String> op,
                                              ObservableValue<? extends K> key)
        创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。 StringBinding将持有"" ，如果key在ObservableMap 。
        参数类型
        K - K的关键元素的 Map
        参数
        op - ObservableMap
        key - 关键在 Map
        结果
        新的 StringBinding
        异常
        NullPointerException - 如果 ObservableMap或 key是 null
        从以下版本开始：
        JavaFX 2.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BooleanBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class BooleanBinding

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.binding.BooleanBinding
  • All Implemented Interfaces:
    Binding<Boolean> ， Observable ， ObservableBooleanValue ， ObservableValue<Boolean>

    public abstract class BooleanBinding
extends BooleanExpression
implements Binding<Boolean>
    提供实现boolean值Binding所需的大部分功能的基类。

    BooleanBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果其中一个注册的依赖关系无效，则此BooleanBinding被标记为无效。 用unbind(Observable...)监听依赖关系可以停止。

    为了提供这个类的具体实现，必须实现方法computeValue() ，以根据依赖关系的当前状态来计算该绑定的值。 调用get()调用无效绑定时调用。

    参见DoubleBinding ，了解如何扩展这个基类。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Binding ， BooleanExpression

    • 构造方法摘要

      构造方法
      Constructor 描述
      BooleanBinding​()
      唯一的构造函数

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变为无效时，它将被通知。
      void addListener​(ChangeListener<? super Boolean> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract boolean computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose()为空。
      boolean get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，每当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Boolean> listener)
      从监听器列表中删除给定的侦听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      String toString​()
      返回此 BooleanBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asObject, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

    • 构造方法详细信息

      • BooleanBinding

        public BooleanBinding​()
        唯一的构造函数

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销侦听器，或者使用WeakInvalidationListener的实例来避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时，它们将被通知。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Boolean> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 ObservableValue<Boolean>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Boolean> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，每当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener接口 ObservableValue<Boolean>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        默认实现为 dispose() ，为空。
        Specified by:
        dispose在接口 Binding<Boolean>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies在接口 Binding<Boolean>
        结果
        一个空的 ObservableList

      • get

        public final boolean get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果自上次调用get()以来绑定没有变为无效，结果将被缓存并返回。
        Specified by:
        get在接口 ObservableBooleanValue
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        描述从接口Binding复制
        将绑定标记为无效。 这迫使重新计算Binding下次请求时的值。
        Specified by:
        invalidate在接口 Binding<Boolean>

      • isValid

        public final boolean isValid​()
        说明从接口Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<Boolean>
        结果
        true如果 Binding有效，则 false否则

      • computeValue

        protected abstract boolean computeValue​()
        计算此绑定的当前值。

        扩展BooleanBinding类必须提供computeValue的实现。

        结果
        当前值

      • toString

        public String toString​()
        返回此 BooleanBinding对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 BooleanBinding对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BooleanExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class BooleanExpression

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
  • All Implemented Interfaces:
    Observable ， ObservableBooleanValue ， ObservableValue<Boolean>
    已知直接子类：
    BooleanBinding ， ReadOnlyBooleanProperty

    public abstract class BooleanExpression
extends Object
implements ObservableBooleanValue
    BooleanExpression是一个ObservableBooleanValue，另外还有一种方便的方法来生成流畅的绑定。

    BooleanExpression具体子类必须实现方法ObservableBooleanValue.get() ，该方法提供该表达式的实际值。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      BooleanExpression​()
      唯一的构造函数

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanBinding and​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，在这个BooleanExpression和一个ObservableBooleanValue执行条件AND操作。
      ObjectExpression<Boolean> asObject​()
      创建一个ObjectExpression ，其值为BooleanExpression 。
      StringBinding asString​()
      创建一个StringBinding ，保持该值BooleanExpression变成String 。
      static BooleanExpression booleanExpression​(ObservableBooleanValue value)
      返回一个BooleanExpression ，其中包含一个ObservableBooleanValue 。
      static BooleanExpression booleanExpression​(ObservableValue<Boolean> value)
      返回一个BooleanExpression ，其中包含一个ObservableValue 。
      Boolean getValue​()
      返回此 ObservableValue的当前值
      BooleanBinding isEqualTo​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。
      BooleanBinding isNotEqualTo​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。
      BooleanBinding not​()
      创建一个新的 BooleanExpression ，计算这个 BooleanExpression的否定。
      BooleanBinding or​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，执行BooleanExpression和ObservableBooleanValue的条件OR操作。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableBooleanValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

    • 构造方法详细信息

      • BooleanExpression

        public BooleanExpression​()
        唯一的构造函数

    • 方法详细信息

      • getValue

        public Boolean getValue​()
        说明从接口ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<Boolean>
        结果
        当前值

      • booleanExpression

        public static BooleanExpression booleanExpression​(ObservableBooleanValue value)
        返回一个BooleanExpression ，其中包含一个ObservableBooleanValue 。 如果ObservableBooleanValue已经是BooleanExpression ，它将被返回。 否则将创建一个新的BooleanBinding绑定到ObservableBooleanValue 。
        参数
        value - 来源 ObservableBooleanValue
        结果
        一个 BooleanExpression包装了 ObservableBooleanValue如果有必要
        异常
        NullPointerException - 如果 value是 null

      • booleanExpression

        public static BooleanExpression booleanExpression​(ObservableValue<Boolean> value)
        返回一个BooleanExpression ，其中包含一个ObservableValue 。 如果ObservableValue已经是BooleanExpression ，它将被退回。 否则将创建一个新的BooleanBinding ，绑定到ObservableValue 。 注意：空值将被解释为“false”。
        参数
        value - 来源 ObservableValue
        结果
        一个 BooleanExpression包装了 ObservableValue如果有必要
        异常
        NullPointerException - 如果 value是 null
        从以下版本开始：
        JavaFX 8.0

      • and

        public BooleanBinding and​(ObservableBooleanValue other)
        创建一个新的BooleanExpression ，在这个BooleanExpression和ObservableBooleanValue执行条件AND操作。
        参数
        other - 其他 ObservableBooleanValue
        结果
        新的 BooleanExpression
        异常
        NullPointerException - 如果 other是 null

      • or

        public BooleanBinding or​(ObservableBooleanValue other)
        创建一个新的BooleanExpression执行这一条件或操作BooleanExpression和ObservableBooleanValue 。
        参数
        other - 其他 ObservableBooleanValue
        结果
        新的 BooleanExpression
        异常
        NullPointerException - 如果 other是 null

      • not

        public BooleanBinding not​()
        创建一个新的 BooleanExpression ，计算这个 BooleanExpression的否定。
        结果
        新的 BooleanExpression

      • isEqualTo

        public BooleanBinding isEqualTo​(ObservableBooleanValue other)
        创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。
        参数
        other - 其他 ObservableBooleanValue
        结果
        新的 BooleanExpression
        异常
        NullPointerException - 如果 other是 null

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(ObservableBooleanValue other)
        创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。
        参数
        other - 其他 ObservableBooleanValue
        结果
        新的 BooleanExpression
        异常
        NullPointerException - 如果 other是 null

      • asString

        public StringBinding asString​()
        创建一个StringBinding ，将该值BooleanExpression变成String 。 如果这个值BooleanExpression的变化，价值StringBinding将自动更新。
        结果
        新的 StringBinding

      • asObject

        public ObjectExpression<Boolean> asObject​()
        创建一个ObjectExpression ，其值为BooleanExpression 。 如果这个值BooleanExpression的变化，价值ObjectExpression将自动更新。
        结果
        新的 ObjectExpression
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class DoubleBinding

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.binding.DoubleBinding
  • All Implemented Interfaces:
    Binding<Number> ， NumberBinding ， NumberExpression ， Observable ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number>

    public abstract class DoubleBinding
extends DoubleExpression
implements NumberBinding
    提供实现double的double所需的大部分功能的基类。

    DoubleBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果其中一个注册的依赖关系无效，则此DoubleBinding被标记为无效。 用unbind(Observable...)监听依赖可以停止。

    为了提供该类的具体实现，必须实现方法computeValue()以基于依赖关系的当前状态来计算该绑定的值。 当调用get()进行无效绑定时调用。

    以下是一个DoubleBinding计算ObservableNumberValue moo平方根的简单示例。

       final ObservableDoubleValue moo = ...; DoubleBinding foo = new DoubleBinding() { { super.bind(moo); } @Override protected double computeValue() { return Math.sqrt(moo.getValue()); } };
    以下是与可选方法Binding.getDependencies()和Binding.dispose()的实现相同的示例。
       final ObservableDoubleValue moo = ...; DoubleBinding foo = new DoubleBinding() { { super.bind(moo); } @Override protected double computeValue() { return Math.sqrt(moo.getValue()); } @Override public ObservableList<?> getDependencies() { return FXCollections.singletonObservableList(moo); } @Override public void dispose() { super.unbind(moo); } };
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Binding ， NumberBinding ， DoubleExpression

    • 构造方法摘要

      构造方法
      Constructor 描述
      DoubleBinding​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变为无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract double computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose() ，为空。
      double get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      String toString​()
      返回此 DoubleBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, asObject, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from interface javafx.beans.binding.NumberExpression

        add, add, add, add, add, asString, asString, asString, divide, divide, divide, divide, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

    • 构造方法详细信息

      • DoubleBinding

        public DoubleBinding​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        说明从界面ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<Number>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从界面ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<Number>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        默认实现为 dispose() ，为空。
        Specified by:
        dispose接口 Binding<Number>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies在接口 Binding<Number>
        结果
        一个空的 ObservableList

      • get

        public final double get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果绑定从上一次调用get()无效，则缓存并返回结果。
        Specified by:
        get在接口 ObservableDoubleValue
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        描述从接口Binding复制
        将绑定标记为无效。 这迫使重新计算Binding下一次请求的值。
        Specified by:
        invalidate在接口 Binding<Number>

      • isValid

        public final boolean isValid​()
        说明从界面Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<Number>
        结果
        true如果 Binding有效，否则为 false

      • computeValue

        protected abstract double computeValue​()
        计算此绑定的当前值。

        扩展DoubleBinding必须提供computeValue的实现。

        结果
        当前值

      • toString

        public String toString​()
        返回此 DoubleBinding对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 DoubleBinding对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class DoubleExpression

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    DoubleBinding ， ReadOnlyDoubleProperty

    public abstract class DoubleExpression
extends NumberExpressionBase
implements ObservableDoubleValue
    DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。

    一个具体的子类DoubleExpression必须实现方法ObservableDoubleValue.get() ，它提供了这个表达式的实际值。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      DoubleExpression​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleBinding add​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      DoubleBinding add​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      DoubleBinding add​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的总和。
      DoubleBinding add​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的总和。
      DoubleBinding add​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的总和。
      ObjectExpression<Double> asObject​()
      创建一个ObjectExpression ，其值为DoubleExpression 。
      DoubleBinding divide​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      DoubleBinding divide​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值。
      DoubleBinding divide​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值。
      DoubleBinding divide​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      DoubleBinding divide​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的划分 。
      static DoubleExpression doubleExpression​(ObservableDoubleValue value)
      返回一个DoubleExpression的DoubleExpression 。
      static <T extends Number>
      DoubleExpression             		doubleExpression​(ObservableValue<T> value)
      返回一个DoubleExpression的DoubleExpression 。
      double doubleValue​()
      将 ObservableNumberValue的值作为 double 。
      float floatValue​()
      将此 ObservableNumberValue的值作为 float 。
      Double getValue​()
      返回此 ObservableValue的当前值
      int intValue​()
      将此 ObservableNumberValue的值作为 int 。
      long longValue​()
      将该 ObservableNumberValue的值作为 long 。
      DoubleBinding multiply​(double other)
      创建一个新的NumberBinding ，计算此NumberExpression的产品和恒定值。
      DoubleBinding multiply​(float other)
      创建一个新的NumberBinding ，计算此NumberExpression和恒定值。
      DoubleBinding multiply​(int other)
      创建一个新的NumberBinding ，计算此NumberExpression和恒定值。
      DoubleBinding multiply​(long other)
      创建一个新的NumberBinding ，计算此NumberExpression和恒定值。
      DoubleBinding multiply​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算该NumberExpression的产品和另一个ObservableNumberValue 。
      DoubleBinding negate​()
      创建一个新的NumberBinding ，计算否定为NumberExpression 。
      DoubleBinding subtract​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。
      DoubleBinding subtract​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
      DoubleBinding subtract​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      DoubleBinding subtract​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的差异。
      DoubleBinding subtract​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的差异 。

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableDoubleValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

    • 构造方法详细信息

      • DoubleExpression

        public DoubleExpression​()

    • 方法详细信息

      • intValue

        public int intValue​()
        说明从界面ObservableNumberValue复制
        将该ObservableNumberValue的值作为int 。 如果该值不是int ，则执行标准转换。
        Specified by:
        intValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 int

      • longValue

        public long longValue​()
        说明从界面ObservableNumberValue复制
        返回ObservableNumberValue的值作为long 。 如果该值不是long ，则执行标准转换。
        Specified by:
        longValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 long

      • floatValue

        public float floatValue​()
        说明从接口ObservableNumberValue复制
        将ObservableNumberValue的值作为float 。 如果该值不是float ，则执行标准转换。
        Specified by:
        floatValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 float

      • doubleValue

        public double doubleValue​()
        说明从界面ObservableNumberValue复制
        将此ObservableNumberValue的值作为double 。 如果该值不是double ，则执行标准转换。
        Specified by:
        doubleValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 double

      • getValue

        public Double getValue​()
        说明从界面ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<Number>
        结果
        当前值

      • doubleExpression

        public static DoubleExpression doubleExpression​(ObservableDoubleValue value)
        返回一个DoubleExpression ，其中包含一个ObservableDoubleValue 。 如果ObservableDoubleValue已经是DoubleExpression ，它将被返回。 否则，新的DoubleBinding被创建绑定到ObservableDoubleValue 。
        参数
        value - 来源 ObservableDoubleValue
        结果
        一个 DoubleExpression包装了 ObservableDoubleValue如果有必要
        异常
        NullPointerException - 如果 value是 null

      • doubleExpression

        public static <T extends Number> DoubleExpression doubleExpression​(ObservableValue<T> value)
        返回一个DoubleExpression ，其中包含一个ObservableValue 。 如果ObservableValue已经是一个DoubleExpression ，它将被返回。 否则将创建一个新的DoubleBinding ，绑定到ObservableValue 。

        注意：此方法可用于将特定数字类型的ObjectExpression或ObjectProperty转换为DoubleExpression，这基本上是一个ObservableValue<Number> 。 参见下面的示例。

           DoubleProperty doubleProperty = new SimpleDoubleProperty(1.0);
   ObjectProperty<Double> objectProperty = new SimpleObjectProperty<>(2.0);
   BooleanBinding binding = doubleProperty.greaterThan(DoubleExpression.doubleExpression(objectProperty));
        注意：空值将被解释为0.0
        参数类型
        T - 要包装的数字的类型
        参数
        value - 来源 ObservableValue
        结果
        一个 DoubleExpression包装了 ObservableValue如果有必要
        异常
        NullPointerException - 如果 value是 null
        从以下版本开始：
        JavaFX 8.0

      • negate

        public DoubleBinding negate​()
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算的否定为NumberExpression 。
        Specified by:
        negate在接口 NumberExpression
        结果
        新的 NumberBinding

      • add

        public DoubleBinding add​(ObservableNumberValue other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的总和。
        Specified by:
        add在接口 NumberExpression
        重写：
        add在 NumberExpressionBase
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding

      • add

        public DoubleBinding add​(double other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public DoubleBinding add​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public DoubleBinding add​(long other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public DoubleBinding add​(int other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 常数值
        结果
        新的 NumberBinding

      • subtract

        public DoubleBinding subtract​(ObservableNumberValue other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的差异 。
        Specified by:
        subtract在接口 NumberExpression
        重写：
        subtract在 NumberExpressionBase
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding

      • subtract

        public DoubleBinding subtract​(double other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public DoubleBinding subtract​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public DoubleBinding subtract​(long other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public DoubleBinding subtract​(int other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public DoubleBinding multiply​(ObservableNumberValue other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的产品 。
        Specified by:
        multiply在接口 NumberExpression
        重写：
        multiply在 NumberExpressionBase
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding

      • multiply

        public DoubleBinding multiply​(double other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和一个恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public DoubleBinding multiply​(float other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算此NumberExpression和恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public DoubleBinding multiply​(long other)
        说明从界面复制NumberExpression
        创建一个新的NumberBinding ，计算此NumberExpression和一个常数值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public DoubleBinding multiply​(int other)
        描述从界面NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和一个恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public DoubleBinding divide​(ObservableNumberValue other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的划分 。
        Specified by:
        divide在接口 NumberExpression
        重写：
        divide在 NumberExpressionBase
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding

      • divide

        public DoubleBinding divide​(double other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算此NumberExpression和常数值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public DoubleBinding divide​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 常数值
        结果
        新的 NumberBinding

      • divide

        public DoubleBinding divide​(long other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值。
        Specified by:
        divide接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public DoubleBinding divide​(int other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • asObject

        public ObjectExpression<Double> asObject​()
        创建一个ObjectExpression ，其值为DoubleExpression 。 如果这个值DoubleExpression的变化，价值ObjectExpression将自动更新。
        结果
        新的 ObjectExpression
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FloatBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class FloatBinding

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.binding.FloatBinding
  • All Implemented Interfaces:
    Binding<Number> ， NumberBinding ， NumberExpression ， Observable ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number>

    public abstract class FloatBinding
extends FloatExpression
implements NumberBinding
    提供实现float值Binding所需的大部分功能的基类。

    FloatBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果其中一个已注册的依赖项无效，则此FloatBinding被标记为无效。 用unbind(Observable...)听取依赖关系可以停止。

    为了提供该类的具体实现，必须实现方法computeValue() ，以基于依赖关系的当前状态来计算该绑定的值。 当调用get()作为无效绑定时调用它。

    有关可以扩展该基类的示例，请参阅DoubleBinding 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Binding ， NumberBinding ， FloatExpression

    • 构造方法摘要

      构造方法
      Constructor 描述
      FloatBinding​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract float computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose() ，为空。
      float get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从侦听器列表中删除给定的侦听器，每当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      String toString​()
      返回此 FloatBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, asObject, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from interface javafx.beans.binding.NumberExpression

        add, add, add, add, add, asString, asString, asString, divide, divide, divide, divide, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

    • 构造方法详细信息

      • FloatBinding

        public FloatBinding​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从界面Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或者使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        说明从界面ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<Number>
        参数
        listener - 要注册的听众
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从界面ObservableValue复制
        从监听器列表中删除给定的监听器，每当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<Number>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        默认实现为 dispose()为空。
        Specified by:
        dispose在接口 Binding<Number>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies在接口 Binding<Number>
        结果
        一个空的 ObservableList

      • get

        public final float get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果自上次调用getValue以来绑定没有变为无效，结果将被缓存并返回。
        Specified by:
        get在接口 ObservableFloatValue
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        描述从接口Binding复制
        将绑定标记为无效。 这迫使重新计算Binding下次请求的值。
        Specified by:
        invalidate在接口 Binding<Number>

      • isValid

        public final boolean isValid​()
        说明从接口Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<Number>
        结果
        true如果 Binding有效，否则为 false

      • computeValue

        protected abstract float computeValue​()
        计算此绑定的当前值。

        扩展FloatBinding类必须提供computeValue的实现。

        结果
        当前值

      • toString

        public String toString​()
        返回此 FloatBinding对象的字符串表示形式。
        重写：
        toString类 Object
        结果
        这个 FloatBinding对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FloatExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class FloatExpression

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    FloatBinding ， ReadOnlyFloatProperty

    public abstract class FloatExpression
extends NumberExpressionBase
implements ObservableFloatValue
    FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。

    一个具体的子类FloatExpression必须实现方法ObservableFloatValue.get() ，它提供了这个表达式的实际值。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      FloatExpression​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleBinding add​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      FloatBinding add​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      FloatBinding add​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      FloatBinding add​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
      ObjectExpression<Float> asObject​()
      创建一个ObjectExpression ，其值为FloatExpression 。
      DoubleBinding divide​(double other)
      创建一个新的NumberBinding ，计算该NumberExpression和常数值。
      FloatBinding divide​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值。
      FloatBinding divide​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值。
      FloatBinding divide​(long other)
      创建一个新的NumberBinding ，计算该NumberExpression和常数值。
      double doubleValue​()
      将此 ObservableNumberValue的值作为 double 。
      static FloatExpression floatExpression​(ObservableFloatValue value)
      返回一个FloatExpression的FloatExpression 。
      static <T extends Number>
      FloatExpression             		floatExpression​(ObservableValue<T> value)
      返回一个FloatExpression ，其中包含一个ObservableValue 。
      float floatValue​()
      将此 ObservableNumberValue的值作为 float 。
      Float getValue​()
      返回此 ObservableValue的当前值
      int intValue​()
      将该 ObservableNumberValue的值作为 int 。
      long longValue​()
      将该 ObservableNumberValue的值作为 long 。
      DoubleBinding multiply​(double other)
      创建一个新的NumberBinding ，计算该NumberExpression和一个常数值。
      FloatBinding multiply​(float other)
      创建一个新的NumberBinding ，计算此NumberExpression和常数值。
      FloatBinding multiply​(int other)
      创建一个新的NumberBinding ，计算此NumberExpression的产品和常数值。
      FloatBinding multiply​(long other)
      创建一个新的NumberBinding ，计算该NumberExpression和一个恒定值。
      FloatBinding negate​()
      创建一个新的NumberBinding ，计算否定为NumberExpression 。
      DoubleBinding subtract​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的差异。
      FloatBinding subtract​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。
      FloatBinding subtract​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
      FloatBinding subtract​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableFloatValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

    • 构造方法详细信息

      • FloatExpression

        public FloatExpression​()

    • 方法详细信息

      • intValue

        public int intValue​()
        说明从界面ObservableNumberValue复制
        将该ObservableNumberValue的值作为int 。 如果该值不是int ，则执行标准转换。
        Specified by:
        intValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 int

      • longValue

        public long longValue​()
        说明从界面ObservableNumberValue复制
        将ObservableNumberValue的值作为long 。 如果该值不是long ，则执行标准转换。
        Specified by:
        longValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 long

      • floatValue

        public float floatValue​()
        说明从接口ObservableNumberValue复制
        返回ObservableNumberValue的值作为float 。 如果该值不是float ，则执行标准转换。
        Specified by:
        floatValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 float

      • doubleValue

        public double doubleValue​()
        说明从接口ObservableNumberValue复制
        将ObservableNumberValue的值作为double 。 如果该值不是double ，则执行标准转换。
        Specified by:
        doubleValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 double

      • getValue

        public Float getValue​()
        描述从接口ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<Number>
        结果
        当前值

      • floatExpression

        public static FloatExpression floatExpression​(ObservableFloatValue value)
        返回一个FloatExpression ，其中包含一个ObservableFloatValue 。 如果ObservableFloatValue已经是一个FloatExpression ，它将被返回。 否则，将创建一个新的FloatBinding绑定到ObservableFloatValue 。
        参数
        value - 来源 ObservableFloatValue
        结果
        一个 FloatExpression包装了 ObservableFloatValue如果有必要
        异常
        NullPointerException - 如果 value是 null

      • floatExpression

        public static <T extends Number> FloatExpression floatExpression​(ObservableValue<T> value)
        返回一个FloatExpression的FloatExpression 。 如果ObservableValue已经是一个FloatExpression ，它将被返回。 否则将创建一个新的FloatBinding ，绑定到ObservableValue 。

        注意：此方法可用于将特定数字类型的ObjectExpression或ObjectProperty转换为FloatExpression，这基本上是一个ObservableValue<Number> 。 参见下面的示例。

           FloatProperty floatProperty = new SimpleFloatProperty(1.0f);
   ObjectProperty<Float> objectProperty = new SimpleObjectProperty<>(2.0f);
   BooleanBinding binding = floatProperty.greaterThan(FloatExpression.floatExpression(objectProperty));
        注意：空值将被解释为0f
        参数类型
        T - 要包装的号码的类型
        参数
        value - 来源 ObservableValue
        结果
        一个 FloatExpression包装了 ObservableValue如果有必要
        异常
        NullPointerException - 如果 value是 null
        从以下版本开始：
        JavaFX 8.0

      • negate

        public FloatBinding negate​()
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算否定为NumberExpression 。
        Specified by:
        negate在接口 NumberExpression
        结果
        新的 NumberBinding

      • add

        public DoubleBinding add​(double other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public FloatBinding add​(float other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public FloatBinding add​(long other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 常数值
        结果
        新的 NumberBinding

      • add

        public FloatBinding add​(int other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public DoubleBinding subtract​(double other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public FloatBinding subtract​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public FloatBinding subtract​(long other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public FloatBinding subtract​(int other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public DoubleBinding multiply​(double other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算此NumberExpression和常数值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public FloatBinding multiply​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和一个常数值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public FloatBinding multiply​(long other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression的产品和一个恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public FloatBinding multiply​(int other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression的产品和一个常数值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public DoubleBinding divide​(double other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public FloatBinding divide​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public FloatBinding divide​(long other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和常数值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public FloatBinding divide​(int other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • asObject

        public ObjectExpression<Float> asObject​()
        创建一个ObjectExpression ，其值为FloatExpression 。 如果这个值FloatExpression的变化，价值ObjectExpression将自动更新。
        结果
        新的 ObjectExpression
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntegerBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class IntegerBinding

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.binding.IntegerBinding
  • All Implemented Interfaces:
    Binding<Number> ， NumberBinding ， NumberExpression ， Observable ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number>

    public abstract class IntegerBinding
extends IntegerExpression
implements NumberBinding
    提供实现int值Binding所需的大部分功能的基类。

    IntegerBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果其中一个已注册的依赖关系无效，则该IntegerBinding被标记为无效。 用unbind(Observable...)监听依赖可以停止。

    为了提供这个类的具体实现，必须实现方法computeValue() ，以便根据依赖关系的当前状态来计算该绑定的值。 当为无效绑定调用get()时调用。

    参见DoubleBinding ，了解如何扩展这个基类。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Binding ， NumberBinding ， IntegerExpression

    • 构造方法摘要

      构造方法
      Constructor 描述
      IntegerBinding​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract int computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose() ，为空。
      int get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      String toString​()
      返回此 IntegerBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, asObject, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from interface javafx.beans.binding.NumberExpression

        add, add, add, add, add, asString, asString, asString, divide, divide, divide, divide, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

    • 构造方法详细信息

      • IntegerBinding

        public IntegerBinding​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，不同的Observables可能会安全注册相同的实际InvalidationListener实例。

        Observable存储对侦听器的强引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或者使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的侦听器，每当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        说明从界面ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，将通知它。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakChangeListener的实例来避免此情况。

        Specified by:
        addListener在接口 ObservableValue<Number>
        参数
        listener - 要注册的听众
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从界面ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<Number>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        默认实现为 dispose()为空。
        Specified by:
        dispose在接口 Binding<Number>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies接口 Binding<Number>
        结果
        一个空的 ObservableList

      • get

        public final int get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果自上次调用get()以来绑定没有变为无效，结果将被缓存并返回。
        Specified by:
        get在接口 ObservableIntegerValue
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        说明从界面Binding复制
        将绑定标记为无效。 这迫使重新计算Binding下一次请求的值。
        Specified by:
        invalidate在接口 Binding<Number>

      • isValid

        public final boolean isValid​()
        说明从界面Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<Number>
        结果
        true如果 Binding有效，否则为 false

      • computeValue

        protected abstract int computeValue​()
        计算此绑定的当前值。

        扩展IntegerBinding必须提供computeValue的实现。

        结果
        当前值

      • toString

        public String toString​()
        返回此 IntegerBinding对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 IntegerBinding对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntegerExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class IntegerExpression

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    IntegerBinding ， ReadOnlyIntegerProperty

    public abstract class IntegerExpression
extends NumberExpressionBase
implements ObservableIntegerValue
    IntegerExpression是一个ObservableIntegerValue加上额外的便利方法，以流利的风格生成绑定。

    一个具体的子类IntegerExpression必须实现方法ObservableIntegerValue.get() ，它提供了这个表达式的实际值。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      IntegerExpression​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleBinding add​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      FloatBinding add​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的总和。
      IntegerBinding add​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的总和。
      LongBinding add​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的总和。
      ObjectExpression<Integer> asObject​()
      创建一个ObjectExpression ，其值为IntegerExpression 。
      DoubleBinding divide​(double other)
      创建一个新的NumberBinding ，计算此NumberExpression和常数值。
      FloatBinding divide​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      IntegerBinding divide​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      LongBinding divide​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      double doubleValue​()
      返回此值 ObservableNumberValue为 double 。
      float floatValue​()
      返回 ObservableNumberValue的值作为 float 。
      Integer getValue​()
      返回此 ObservableValue的当前值
      static IntegerExpression integerExpression​(ObservableIntegerValue value)
      返回一个IntegerExpression ，其中包含一个ObservableIntegerValue 。
      static <T extends Number>
      IntegerExpression             		integerExpression​(ObservableValue<T> value)
      返回一个IntegerExpression ，其中包含一个ObservableValue 。
      int intValue​()
      返回 ObservableNumberValue的值作为 int 。
      long longValue​()
      将此 ObservableNumberValue的值作为 long 。
      DoubleBinding multiply​(double other)
      创建一个新的NumberBinding ，计算该NumberExpression和一个恒定值。
      FloatBinding multiply​(float other)
      创建一个新的NumberBinding ，计算该NumberExpression和一个常数值。
      IntegerBinding multiply​(int other)
      创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
      LongBinding multiply​(long other)
      创建一个新的NumberBinding ，计算此NumberExpression和常数值。
      IntegerBinding negate​()
      创建一个新的NumberBinding ，计算的否定为NumberExpression 。
      DoubleBinding subtract​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
      FloatBinding subtract​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
      IntegerBinding subtract​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的差异。
      LongBinding subtract​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableIntegerValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

    • 构造方法详细信息

      • IntegerExpression

        public IntegerExpression​()

    • 方法详细信息

      • intValue

        public int intValue​()
        说明从界面ObservableNumberValue复制
        将此ObservableNumberValue的值作为int 。 如果该值不是int ，则执行标准转换。
        Specified by:
        intValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 int

      • longValue

        public long longValue​()
        说明从界面ObservableNumberValue复制
        返回ObservableNumberValue的值作为long 。 如果该值不是long ，则执行标准转换。
        Specified by:
        longValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 long

      • floatValue

        public float floatValue​()
        说明从界面ObservableNumberValue复制
        返回ObservableNumberValue的值作为float 。 如果该值不是float ，则执行标准转换。
        Specified by:
        floatValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 float

      • doubleValue

        public double doubleValue​()
        说明从界面ObservableNumberValue复制
        返回ObservableNumberValue的值作为double 。 如果该值不是double ，则执行标准转换。
        Specified by:
        doubleValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 double

      • getValue

        public Integer getValue​()
        说明从界面ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<Number>
        结果
        当前值

      • integerExpression

        public static IntegerExpression integerExpression​(ObservableIntegerValue value)
        返回一个IntegerExpression ，其中包含一个ObservableIntegerValue 。 如果ObservableIntegerValue已经是IntegerExpression ，它将被返回。 否则将创建一个新的IntegerBinding ，绑定到ObservableIntegerValue 。
        参数
        value - 来源 ObservableIntegerValue
        结果
        一个 IntegerExpression包装了 ObservableIntegerValue如果有必要
        异常
        NullPointerException - 如果 value是 null

      • integerExpression

        public static <T extends Number> IntegerExpression integerExpression​(ObservableValue<T> value)
        返回一个IntegerExpression的IntegerExpression 。 如果ObservableValue已经是IntegerExpression ，它将被返回。 否则，将创建一个新的IntegerBinding ，绑定到ObservableValue 。

        注意：该方法可用于将特定数字类型的ObjectExpression或ObjectProperty转换为IntegerExpression，这本质上是一个ObservableValue<Number> 。 参见下面的示例。

           IntegerProperty integerProperty = new SimpleIntegerProperty(1);
   ObjectProperty<Integer> objectProperty = new SimpleObjectProperty<>(2);
   BooleanBinding binding = integerProperty.greaterThan(IntegerExpression.integerExpression(objectProperty));
        注意：空值将被解释为0
        参数类型
        T - 要包装的号码的类型
        参数
        value - 来源 ObservableValue
        结果
        一个 IntegerExpression包装了 ObservableValue如果有必要
        异常
        NullPointerException - 如果 value是 null
        从以下版本开始：
        JavaFX 8.0

      • negate

        public IntegerBinding negate​()
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算的否定为NumberExpression 。
        Specified by:
        negate接口 NumberExpression
        结果
        新的 NumberBinding

      • add

        public DoubleBinding add​(double other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public FloatBinding add​(float other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public LongBinding add​(long other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public IntegerBinding add​(int other)
        描述从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public DoubleBinding subtract​(double other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算出这个NumberExpression和恒定值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public FloatBinding subtract​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression的差异和一个恒定值。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public LongBinding subtract​(long other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算出这个NumberExpression的差异和恒定值。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public IntegerBinding subtract​(int other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public DoubleBinding multiply​(double other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算此NumberExpression和恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public FloatBinding multiply​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public LongBinding multiply​(long other)
        说明从界面复制： NumberExpression
        创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public IntegerBinding multiply​(int other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和一个常数值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public DoubleBinding divide​(double other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public FloatBinding divide​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public LongBinding divide​(long other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public IntegerBinding divide​(int other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • asObject

        public ObjectExpression<Integer> asObject​()
        创建一个ObjectExpression ，其值为IntegerExpression 。 如果这个值IntegerExpression的变化，价值ObjectExpression将自动更新。
        结果
        新的 ObjectExpression
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.beans.binding (Java SE 9 & JDK 9 )

javafx.beans.binding

Interfaces

  • Binding
  • NumberBinding
  • NumberExpression

Classes

  • Bindings
  • BooleanBinding
  • BooleanExpression
  • DoubleBinding
  • DoubleExpression
  • FloatBinding
  • FloatExpression
  • IntegerBinding
  • IntegerExpression
  • ListBinding
  • ListExpression
  • LongBinding
  • LongExpression
  • MapBinding
  • MapExpression
  • NumberExpressionBase
  • ObjectBinding
  • ObjectExpression
  • SetBinding
  • SetExpression
  • StringBinding
  • StringExpression
  • When


javafx.beans.binding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.beans.binding

提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。

绑定的特点

绑定从一个或多个源组合，通常称为依赖关系。 绑定会根据更改依赖关系来观察其依赖关系，并根据依赖关系的更改来更新自己的值。

本库中定义的几乎所有绑定都需要为其依赖实现Observable 。 已经提供了两种类型的实现，包javafx.beans.property和可观察集合（ ObservableList和ObservableMap ）中的属性。 绑定还实现Observable并且可以再次作为其他绑定的源，从而构建非常复杂的绑定。

我们执行中的绑定总是很懒惰地计算。 这意味着，如果依赖关系更改，绑定的结果不会立即重新计算，而是被标记为无效。 下次无效绑定的值被请求时，重新计算。

高级API和低级API

Binding API大致分为两部分：高级绑定API和低级绑定API。 高级绑定API允许以易于使用的方式构建简单的绑定。 使用高级API定义绑定应该很简单，特别是在提供代码完成的IDE中使用时。 不幸的是它有其局限性，在这一点上，低级别的API就起作用了。 经验丰富的Java开发人员可以使用低级别API来定义绑定，如果高级API的功能不足或提高性能。 低级API的主要目标是快速执行和小内存占用。

以下是如何使用两个API的示例。 假设我们有四个实例DoubleProperty a ， b ， c ，并d ，我们可以定义一个绑定计算a*b + c*d与高级别API例如是这样的：

NumberBinding result = Bindings.add (a.multiply(b), c.multiply(d));

使用低级API定义相同的绑定可以这样完成：

   DoubleBinding foo = new DoubleBinding() { { super.bind(a, b, c, d); } @Override protected double computeValue() { return a.getValue() * b.getValue() + c.getValue() * d.getValue(); } };
  • 接口摘要
    接口 描述
    Binding<T>
    A Binding计算取决于一个或多个来源的值。
    NumberBinding
    标记界面，用于标记所有绑定数字值的绑定。
    NumberExpression
    NumberExpression是一个ObservableNumberValue加上额外的便利方法，以流利的风格生成绑定。
  • 类摘要
    Class 描述
    Bindings
    绑定是一个帮助类，具有很多实用功能来创建简单的绑定。
    BooleanBinding
    基础类提供实现270659602452550的boolean所需的大部分功能。
    BooleanExpression
    BooleanExpression是一个ObservableBooleanValue，另外还有一个方便的方法来生成流畅的绑定。
    DoubleBinding
    提供实现270659602489735的double所需的大部分功能的基类。
    DoubleExpression
    DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
    FloatBinding
    提供实现Binding的float值所需的大部分功能的基类。
    FloatExpression
    FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。
    IntegerBinding
    提供实现270659602613290的int所需的大部分功能的基类。
    IntegerExpression
    IntegerExpression是一个ObservableIntegerValue加上额外的便利方法，以流利的风格生成绑定。
    ListBinding<E>
    提供实现ObservableList的Binding所需的大部分功能的基类。
    ListExpression<E>
    ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。
    LongBinding
    提供实现long的long所需的大部分功能的基类。
    LongExpression
    LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。
    MapBinding<K,V>
    提供实现ObservableMap的Binding所需的大部分功能的基类。
    MapExpression<K,V>
    MapExpression是一个ObservableMapValue加上额外的便利方法，以流利的风格生成绑定。
    NumberExpressionBase
    NumberExpressionBase包含了以流畅样式生成绑定的方便方法，这是所有NumberExpression子类所共有的。
    ObjectBinding<T>
    基类提供了实现Object的Object所需的大部分功能。
    ObjectExpression<T>
    ObjectExpression是一个ObservableObjectValue，另外还有一个方便的方法来生成流畅的绑定。
    SetBinding<E>
    提供实现ObservableSet的Binding所需的大部分功能的基类。
    SetExpression<E>
    SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的风格生成绑定。
    StringBinding
    提供实现String的String所需的大部分功能的基类。
    StringExpression
    StringExpression是一个ObservableStringValue加上额外的便利方法，以流利的风格生成绑定。
    When
    计算三元表达式的绑定的起始点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.beans.binding Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.beans.binding

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.beans.binding.Bindings
    • javafx.beans.binding.BooleanExpression (implements javafx.beans.value.ObservableBooleanValue)
      • javafx.beans.binding.BooleanBinding (implements javafx.beans.binding.Binding<T>)
    • javafx.beans.binding.ListExpression<E> (implements javafx.beans.value.ObservableListValue<E>)
      • javafx.beans.binding.ListBinding<E> (implements javafx.beans.binding.Binding<T>)
    • javafx.beans.binding.MapExpression<K,V> (implements javafx.beans.value.ObservableMapValue<K,V>)
      • javafx.beans.binding.MapBinding<K,V> (implements javafx.beans.binding.Binding<T>)
    • javafx.beans.binding.NumberExpressionBase (implements javafx.beans.binding.NumberExpression)
      • javafx.beans.binding.DoubleExpression (implements javafx.beans.value.ObservableDoubleValue)
        • javafx.beans.binding.DoubleBinding (implements javafx.beans.binding.NumberBinding)
      • javafx.beans.binding.FloatExpression (implements javafx.beans.value.ObservableFloatValue)
        • javafx.beans.binding.FloatBinding (implements javafx.beans.binding.NumberBinding)
      • javafx.beans.binding.IntegerExpression (implements javafx.beans.value.ObservableIntegerValue)
        • javafx.beans.binding.IntegerBinding (implements javafx.beans.binding.NumberBinding)
      • javafx.beans.binding.LongExpression (implements javafx.beans.value.ObservableLongValue)
        • javafx.beans.binding.LongBinding (implements javafx.beans.binding.NumberBinding)
    • javafx.beans.binding.ObjectExpression<T> (implements javafx.beans.value.ObservableObjectValue<T>)
      • javafx.beans.binding.ObjectBinding<T> (implements javafx.beans.binding.Binding<T>)
    • javafx.beans.binding.SetExpression<E> (implements javafx.beans.value.ObservableSetValue<E>)
      • javafx.beans.binding.SetBinding<E> (implements javafx.beans.binding.Binding<T>)
    • javafx.beans.binding.StringExpression (implements javafx.beans.value.ObservableStringValue)
      • javafx.beans.binding.StringBinding (implements javafx.beans.binding.Binding<T>)
    • javafx.beans.binding.When
    • javafx.beans.binding.When.BooleanConditionBuilder
    • javafx.beans.binding.When.NumberConditionBuilder
    • javafx.beans.binding.When.ObjectConditionBuilder<T>
    • javafx.beans.binding.When.StringConditionBuilder

Interface Hierarchy

  • javafx.beans.Observable
    • javafx.beans.value.ObservableValue<T>
      • javafx.beans.binding.Binding<T>
        • javafx.beans.binding.NumberBinding (also extends javafx.beans.binding.NumberExpression)
      • javafx.beans.value.ObservableNumberValue
        • javafx.beans.binding.NumberExpression
          • javafx.beans.binding.NumberBinding (also extends javafx.beans.binding.Binding<T>)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ListBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class ListBinding<E>

  • java.lang.Object
    • javafx.beans.binding.ListExpression<E>
      • javafx.beans.binding.ListBinding<E>
  • 参数类型
    E - List元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Binding<ObservableList<E>> ， Observable ， ObservableListValue<E> ， ObservableObjectValue<E> ， ObservableValue<E> ， ObservableList<E>

    public abstract class ListBinding<E>
extends ListExpression<E>
implements Binding<ObservableList<E>>
    提供实现ObservableList的Binding所需的大部分功能的基类。

    ListBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果其中一个已注册的依赖关系无效，则此ListBinding被标记为无效。 用unbind(Observable...)监听依赖关系可以停止。

    为了提供该类的具体实现，必须实现方法computeValue() ，以基于依赖关系的当前状态计算该绑定的值。 当调用get()无效绑定时调用。

    参见DoubleBinding ，了解如何扩展这个基类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    Binding ， ListExpression

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty empty
      一个布尔属性，如果列表为空，则为 true 。
      ReadOnlyIntegerProperty size
      表示列表大小的整数属性。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListBinding​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super ObservableList<E>> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void addListener​(ListChangeListener<? super E> listener)
      将侦听器添加到此可观察列表中。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract ObservableList<E> computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose() ，为空。
      ReadOnlyBooleanProperty emptyProperty​()
      一个布尔属性，如果列表为空，则为 true 。
      ObservableList<E> get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时，它们将被通知。
      void removeListener​(ChangeListener<? super ObservableList<E>> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      void removeListener​(ListChangeListener<? super E> listener)
      尝试从此可观察列表中删除侦听器。
      ReadOnlyIntegerProperty sizeProperty​()
      表示列表大小的整数属性。
      String toString​()
      返回此 ListBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        equals, hashCode, of, of, of, of, of, of, of, of, of, of, of, of, replaceAll, sort, spliterator

      • Methods inherited from class javafx.beans.binding.ListExpression

        add, add, addAll, addAll, addAll, asString, clear, contains, containsAll, get, getSize, getValue, indexOf, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, lastIndexOf, listExpression, listIterator, listIterator, remove, remove, remove, removeAll, removeAll, retainAll, retainAll, set, setAll, setAll, size, subList, toArray, toArray, valueAt, valueAt

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.collections.ObservableList

        filtered, sorted, sorted

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

    • Property Detail

      • size

        public ReadOnlyIntegerProperty sizeProperty
        Specified by:
        sizeProperty在 ListExpression<E>
        另请参见：
        ListExpression.getSize()

      • empty

        public ReadOnlyBooleanProperty emptyProperty
        Specified by:
        emptyProperty在 ListExpression<E>
        另请参见：
        ListExpression.isEmpty()

    • 构造方法详细信息

      • ListBinding

        public ListBinding​()

    • 方法详细信息

      • sizeProperty

        public ReadOnlyIntegerProperty sizeProperty​()
        描述从类别复制ListExpression
        表示列表大小的整数属性。
        Specified by:
        sizeProperty中的 ListExpression<E>
        另请参见：
        ListExpression.getSize()

      • emptyProperty

        public ReadOnlyBooleanProperty emptyProperty​()
        描述从类别复制ListExpression
        一个布尔属性是 true ，如果列表为空。
        Specified by:
        emptyProperty在 ListExpression<E>
        另请参见：
        ListExpression.isEmpty()

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变为无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super ObservableList<E>> listener)
        说明从界面ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过致电removeListener注销收听者，或使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<E>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super ObservableList<E>> listener)
        说明从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener接口 ObservableValue<E>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(ListChangeListener<? super E> listener)
        说明从接口ObservableList复制
        将侦听器添加到此可观察列表中。
        Specified by:
        addListener在接口 ObservableList<E>
        参数
        listener - 用于监听列表更改的侦听器

      • removeListener

        public void removeListener​(ListChangeListener<? super E> listener)
        说明从接口ObservableList复制
        尝试从此可观察列表中删除侦听器。 如果监听者没有附加到此列表中，则不会发生任何事情。
        Specified by:
        removeListener在接口 ObservableList<E>
        参数
        listener - 要删除的侦听器

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        一个空的默认实现为 dispose() 。
        Specified by:
        dispose在接口 Binding<E>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies在接口 Binding<E>
        结果
        一个空的 ObservableList

      • get

        public final ObservableList<E> get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果从上一次调用get()起，绑定没有变为无效，结果将被缓存并返回。
        Specified by:
        get在接口 ObservableObjectValue<E>
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        说明从界面Binding复制
        将绑定标记为无效。 这迫使下次再次计算Binding请求。
        Specified by:
        invalidate接口 Binding<E>

      • isValid

        public final boolean isValid​()
        描述从接口Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<E>
        结果
        true如果 Binding有效， false另有 false

      • computeValue

        protected abstract ObservableList<E> computeValue​()
        计算此绑定的当前值。

        扩展ListBinding必须提供computeValue的实现。

        结果
        当前值

      • toString

        public String toString​()
        返回此 ListBinding对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ListBinding对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class ListExpression<E>

  • java.lang.Object
    • javafx.beans.binding.ListExpression<E>
  • 参数类型
    E - List元素的类型。
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， ObservableListValue<E> ， ObservableObjectValue<E> ， ObservableValue<E> ， ObservableList<E>
    已知直接子类：
    ListBinding ， ReadOnlyListProperty

    public abstract class ListExpression<E>
extends Object
implements ObservableListValue<E>
    ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。

    一个具体的子类ListExpression必须实现方法ObservableObjectValue.get() ，它提供了这个表达式的实际值。

    如果ListExpression的包装列表为null ，则实现List接口的所有方法将表现为将其应用于不可变的空列表。

    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      Properties
      Type Property 描述
      abstract ReadOnlyBooleanProperty empty
      一个布尔属性，如果列表为空，则为 true 。
      abstract ReadOnlyIntegerProperty size
      表示列表大小的整数属性。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListExpression​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void add​(int i, E element)
      将指定的元素插入此列表中的指定位置（可选操作）。
      boolean add​(E element)
      将指定的元素追加到此列表的末尾（可选操作）。
      boolean addAll​(int i, Collection<? extends E> elements)
      将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
      boolean addAll​(E... elements)
      用于var-arg添加元素的方便方法。
      boolean addAll​(Collection<? extends E> elements)
      按指定集合的迭代器（可选操作）返回的顺序将指定集合中的所有元素附加到此列表的末尾。
      StringBinding asString​()
      创建一个StringBinding ，其价值ListExpression变成String 。
      void clear​()
      从此列表中删除所有元素（可选操作）。
      boolean contains​(Object obj)
      如果此列表包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> objects)
      如果此列表包含指定集合的所有元素，则返回 true 。
      abstract ReadOnlyBooleanProperty emptyProperty​()
      一个布尔属性，如果列表为空，则为 true 。
      E get​(int i)
      返回此列表中指定位置的元素。
      int getSize​()
      列表的大小
      ObservableList<E> getValue​()
      返回此 ObservableValue的当前值
      int indexOf​(Object obj)
      返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。
      boolean isEmpty​()
      获取属性的值为空。
      BooleanBinding isEqualTo​(ObservableList<?> other)
      创建一个新的BooleanBinding持有true如果此列表等于另一个ObservableList 。
      BooleanBinding isNotEqualTo​(ObservableList<?> other)
      创建一个新的BooleanBinding持有true如果此列表不等于另一个ObservableList 。
      BooleanBinding isNotNull​()
      创建一个新的BooleanBinding持有true如果包装列表不null 。
      BooleanBinding isNull​()
      创建一个新的BooleanBinding持有true如果包装列表为null 。
      Iterator<E> iterator​()
      以正确的顺序返回该列表中的元素的迭代器。
      int lastIndexOf​(Object obj)
      返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
      static <E> ListExpression<E> listExpression​(ObservableListValue<E> value)
      返回一个ListExpression的ListExpression 。
      ListIterator<E> listIterator​()
      返回列表中的列表迭代器（按适当的顺序）。
      ListIterator<E> listIterator​(int i)
      从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
      E remove​(int i)
      删除该列表中指定位置的元素（可选操作）。
      void remove​(int from, int to)
      一种调用 sublist(from, to).clear()简化方法。
      boolean remove​(Object obj)
      从列表中删除指定元素的第一个出现（如果存在）（可选操作）。
      boolean removeAll​(E... elements)
      一种方便的方法，用于var-arg使用的 removeAll方法。
      boolean removeAll​(Collection<?> objects)
      从此列表中删除包含在指定集合中的所有元素（可选操作）。
      boolean retainAll​(E... elements)
      使用 retainAll方法的var-arg使用的 方便方法。
      boolean retainAll​(Collection<?> objects)
      仅保留此列表中包含在指定集合中的元素（可选操作）。
      E set​(int i, E element)
      用指定的元素（可选操作）替换此列表中指定位置的元素。
      boolean setAll​(E... elements)
      清除ObservableList并添加所有传递给var-args的元素。
      boolean setAll​(Collection<? extends E> elements)
      清除ObservableList并添加集合中的所有元素。
      int size​()
      返回此列表中的元素数。
      abstract ReadOnlyIntegerProperty sizeProperty​()
      表示列表大小的整数属性。
      List<E> subList​(int from, int to)
      返回指定的 fromIndex （包括）和 toIndex之间的列表部分的视图。
      Object[] toArray​()
      以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。
      <T> T[] toArray​(T[] array)
      以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。
      ObjectBinding<E> valueAt​(int index)
      创建一个新的ObjectBinding ，其中包含指定位置的元素。
      ObjectBinding<E> valueAt​(ObservableIntegerValue index)
      创建一个新的ObjectBinding ，其中包含指定位置的元素。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        equals, hashCode, of, of, of, of, of, of, of, of, of, of, of, of, replaceAll, sort, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableList

        addListener, filtered, removeListener, sorted, sorted

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

    • Property Detail

      • size

        public abstract ReadOnlyIntegerProperty sizeProperty
        表示列表大小的整数属性。
        另请参见：
        getSize()

      • empty

        public abstract ReadOnlyBooleanProperty emptyProperty
        一个布尔属性，如果列表为空，则为 true 。
        另请参见：
        isEmpty()

    • 构造方法详细信息

      • ListExpression

        public ListExpression​()

    • 方法详细信息

      • getValue

        public ObservableList<E> getValue​()
        说明从接口ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<E>
        结果
        当前值

      • listExpression

        public static <E> ListExpression<E> listExpression​(ObservableListValue<E> value)
        返回一个ListExpression的ListExpression 。 如果ObservableListValue已经是ListExpression ，它将被退回。 否则，新的ListBinding被创建，绑定到ObservableListValue 。
        参数类型
        E - 包装的类型 List
        参数
        value - 来源 ObservableListValue
        结果
        一个 ListExpression包装了 ObservableListValue如果有必要
        异常
        NullPointerException - 如果 value是 null

      • getSize

        public int getSize​()
        列表的大小
        结果
        尺寸

      • sizeProperty

        public abstract ReadOnlyIntegerProperty sizeProperty​()
        表示列表大小的整数属性。
        另请参见：
        getSize()

      • emptyProperty

        public abstract ReadOnlyBooleanProperty emptyProperty​()
        一个布尔属性，如果列表为空，则为 true 。
        另请参见：
        isEmpty()

      • valueAt

        public ObjectBinding<E> valueAt​(int index)
        创建一个新的ObjectBinding ，其中包含指定位置的元素。 如果index点在后面， ObjectBinding包含null 。
        参数
        index - 元素的索引
        结果
        ObjectBinding
        异常
        IllegalArgumentException - 如果是 index < 0

      • valueAt

        public ObjectBinding<E> valueAt​(ObservableIntegerValue index)
        创建一个新的ObjectBinding ，其中包含指定位置的元素。 如果index点以外的列表中， ObjectBinding包含null 。
        参数
        index - 元素的索引
        结果
        ObjectBinding
        异常
        NullPointerException - 如果 index是 null

      • isEqualTo

        public BooleanBinding isEqualTo​(ObservableList<?> other)
        创建一个新的BooleanBinding持有true如果此列表等于另一个ObservableList 。
        参数
        other - 其他 ObservableList
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 other是 null

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(ObservableList<?> other)
        创建一个新的BooleanBinding持有true如果此列表不等于另一个ObservableList 。
        参数
        other - 其他 ObservableList
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 other是 null

      • isNull

        public BooleanBinding isNull​()
        创建一个新的BooleanBinding持有true如果包装列表为null 。
        结果
        新的 BooleanBinding

      • isNotNull

        public BooleanBinding isNotNull​()
        创建一个新的BooleanBinding持有true如果包装列表不null 。
        结果
        新的 BooleanBinding

      • asString

        public StringBinding asString​()
        创建一个StringBinding持有的价值ListExpression变成了String 。 如果这个值ListExpression的变化，价值StringBinding将自动更新。
        结果
        新的 StringBinding

      • size

        public int size​()
        说明从接口List复制
        返回此列表中的元素数。 如果此列表包含超过Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 List<E>
        结果
        此列表中的元素数

      • isEmpty

        public boolean isEmpty​()
        获取属性的值为空。
        Specified by:
        isEmpty在接口 Collection<E>
        Specified by:
        isEmpty在接口 List<E>
        Property description:
        一个布尔属性，如果列表为空，则为 true 。
        结果
        true如果此列表不包含元素

      • contains

        public boolean contains​(Object obj)
        描述从界面List复制
        如果此列表包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此列表包含至少一个元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 List<E>
        参数
        obj - 要在此列表中存在的元素要进行测试
        结果
        true如果此列表包含指定的元素

      • iterator

        public Iterator<E> iterator​()
        描述从接口List复制
        以正确的顺序返回该列表中的元素的迭代器。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 List<E>
        结果
        在这个列表中的元素以适当的顺序迭代

      • toArray

        public Object[] toArray​()
        说明从接口List复制
        以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

        返回的数组将是“安全的”，因为该列表不保留对它的引用。 （换句话说，即使这个列表被数组支持，这个方法也必须分配一个新的数组）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 List<E>
        结果
        一个包含该列表中所有元素的数组的数组
        另请参见：
        Arrays.asList(Object[])

      • toArray

        public <T> T[] toArray​(T[] array)
        说明从接口List复制
        以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。 如果列表适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此列表的大小分配一个新数组。

        如果列表适用于指定的数组， null空间（即，该数组具有比该列表更多的元素），那么紧随该列表结尾的数组中的元素将设置为null 。 （这仅在调用者知道列表不包含任何空元素的情况下才能确定列表的长度。）

        像List.toArray()方法一样，此方法充当基于阵列和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的列表。 以下代码可用于将列表转储到新分配的String数组中：

           String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 List<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        array - 要存储此列表的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此列表元素的数组

      • add

        public boolean add​(E element)
        说明从界面List复制
        将指定的元素追加到此列表的末尾（可选操作）。

        支持此操作的列表可能会限制可能添加到此列表中的元素。 特别地，一些列表将拒绝添加null元素，而其他列表将对可能添加的元素的类型施加限制。 列表类应在其文档中明确指定可能添加哪些元素的限制。

        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 List<E>
        参数
        element - 要附加到此列表的元素
        结果
        true （由 Collection.add(E)指定）

      • remove

        public boolean remove​(Object obj)
        说明从界面List复制
        从列表中删除指定元素的第一个出现（如果存在）（可选操作）。 如果此列表不包含该元素，则它将保持不变。 更正式地，删除具有最低索引i的元素，使得Objects.equals(o, get(i)) （如果这样的元素存在）。 如果此列表包含指定的元素（或等效地，如果此列表作为调用的结果而更改），则返回true 。
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 List<E>
        参数
        obj - 要从此列表中删除的元素（如果存在）
        结果
        true如果此列表包含指定的元素

      • containsAll

        public boolean containsAll​(Collection<?> objects)
        说明从界面List复制
        如果此列表包含指定集合的所有元素，则返回 true 。
        Specified by:
        containsAll在接口 Collection<E>
        Specified by:
        containsAll在接口 List<E>
        参数
        objects - 要在此列表中检查遏制的集合
        结果
        true如果此列表包含指定集合的所有元素
        另请参见：
        List.contains(Object)

      • addAll

        public boolean addAll​(Collection<? extends E> elements)
        描述从接口List复制
        按指定集合的迭代器（可选操作）返回的顺序将指定集合中的所有元素附加到此列表的末尾。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （注意，如果指定的集合是此列表，并且它是非空的，则会发生这种情况。）
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 List<E>
        参数
        elements - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改
        另请参见：
        List.add(Object)

      • addAll

        public boolean addAll​(int i,
                      Collection<? extends E> elements)
        说明从界面List复制
        将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。 将当前位于该位置（如果有的话）的元素和随后的任何元素移动到右边（增加其索引）。 新元素将按照指定集合的迭代器返回的顺序显示在此列表中。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （注意，如果指定的集合是此列表，并且它是非空的，则会发生这种情况。）
        Specified by:
        addAll在接口 List<E>
        参数
        i - 从中指定集合插入第一个元素的索引
        elements - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改

      • removeAll

        public boolean removeAll​(Collection<?> objects)
        说明从界面List复制
        从此列表中删除包含在指定集合中的所有元素（可选操作）。
        Specified by:
        removeAll在接口 Collection<E>
        Specified by:
        removeAll在接口 List<E>
        参数
        objects - 包含要从此列表中删除的元素的集合
        结果
        true如果此列表因呼叫而更改
        另请参见：
        List.remove(Object) ， List.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> objects)
        描述从接口List复制
        仅保留此列表中包含在指定集合中的元素（可选操作）。 换句话说，从此列表中删除其中不包含在指定集合中的所有元素。
        Specified by:
        retainAll在接口 Collection<E>
        Specified by:
        retainAll在接口 List<E>
        参数
        objects - 包含要保留在此列表中的元素的集合
        结果
        true如果此列表因呼叫而更改
        另请参见：
        List.remove(Object) ， List.contains(Object)

      • clear

        public void clear​()
        说明从接口List复制
        从此列表中删除所有元素（可选操作）。 此呼叫返回后，列表将为空。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 List<E>

      • get

        public E get​(int i)
        说明从接口List复制
        返回此列表中指定位置的元素。
        Specified by:
        get在接口 List<E>
        参数
        i - 要返回的元素的索引
        结果
        该列表中指定位置的元素

      • set

        public E set​(int i,
             E element)
        说明从接口List复制
        用指定的元素（可选操作）替换此列表中指定位置的元素。
        Specified by:
        set在接口 List<E>
        参数
        i - 要替换的元素的索引
        element - 要存储在指定位置的元素
        结果
        该元素以前在指定的位置

      • add

        public void add​(int i,
                E element)
        说明从界面List复制
        将指定的元素插入此列表中的指定位置（可选操作）。 将当前位于该位置的元素（如果有）和任何后续元素（向其索引添加一个）移动。
        Specified by:
        add在接口 List<E>
        参数
        i - 要在其中插入指定元素的索引
        element - 要插入的元素

      • remove

        public E remove​(int i)
        说明从接口List复制
        删除该列表中指定位置的元素（可选操作）。 将任何后续元素移动到左侧（从其索引中减去一个元素）。 返回从列表中删除的元素。
        Specified by:
        remove在接口 List<E>
        参数
        i - 要删除的元素的索引
        结果
        该元素以前在指定的位置

      • indexOf

        public int indexOf​(Object obj)
        说明从接口List复制
        返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地，返回最低指数i如Objects.equals(o, get(i)) ，或-1如果没有这样的指数。
        Specified by:
        indexOf在接口 List<E>
        参数
        obj - 要搜索的元素
        结果
        此列表中指定元素的首次出现的索引，如果此列表不包含元素，则为-1

      • lastIndexOf

        public int lastIndexOf​(Object obj)
        描述从接口List复制
        返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。 更正式地说，返回满足i这样Objects.equals(o, get(i)) ，或-1，如果没有这样的指标。
        Specified by:
        lastIndexOf在接口 List<E>
        参数
        obj - 要搜索的元素
        结果
        此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则为-1

      • listIterator

        public ListIterator<E> listIterator​()
        说明从接口List复制
        返回列表中的列表迭代器（按适当的顺序）。
        Specified by:
        listIterator在接口 List<E>
        结果
        在列表中的元素的列表迭代器（按适当的顺序）

      • listIterator

        public ListIterator<E> listIterator​(int i)
        说明从界面List复制
        从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。 指定的索引指示由初始调用next返回的第一个元素。 初始调用previous将返回指定索引减1的元素。
        Specified by:
        listIterator在接口 List<E>
        参数
        i - 要从列表迭代器返回的第一个元素的索引（通过调用 next ）
        结果
        在列表中的元素（按正确顺序）的列表迭代器，从列表中的指定位置开始

      • subList

        public List<E> subList​(int from,
                       int to)
        说明从接口List复制
        返回指定的fromIndex （含）和toIndex之间的列表部分的视图。 （如果fromIndex和toIndex相等，返回的列表为空。）返回的列表由此列表支持，因此返回列表中的非结构性更改将反映在此列表中，反之亦然。 返回的列表支持此列表支持的所有可选列表操作。

        该方法消除了对显式范围操作（对于数组通常存在的排序）的需要。 任何期望列表的操作都可以通过传递一个子列表视图而不是整个列表来用作范围操作。 例如，以下成语从列表中移除了一系列元素：

           list.subList(from, to).clear();
        可以为indexOf和lastIndexOf构造类似的成语，并且可以将Collections类中的所有算法应用于子列表。

        如果支持列表（即，此列表）以除了通过返回的列表之外的任何方式进行结构修改 ，则此方法返回的列表的语义将变为未定义。 （结构修改是那些改变此列表的大小，或以其他方式扰乱它，使得正在进行的迭代可能产生不正确的结果）。

        Specified by:
        subList在接口 List<E>
        参数
        from - 子列表的低端点（含）
        to - 子列表的高端点（排他性）
        结果
        该列表中指定范围的视图

      • addAll

        public boolean addAll​(E... elements)
        说明从接口ObservableList复制
        用于var-arg添加元素的方便方法。
        Specified by:
        addAll在接口 ObservableList<E>
        参数
        elements - 要添加的元素
        结果
        true（由Collection.add（E）指定）

      • setAll

        public boolean setAll​(E... elements)
        说明从界面ObservableList复制
        清除ObservableList并添加所有传递给var-args的元素。
        Specified by:
        setAll在接口 ObservableList<E>
        参数
        elements - 要设置的元素
        结果
        true（由Collection.add（E）指定）

      • setAll

        public boolean setAll​(Collection<? extends E> elements)
        说明从界面ObservableList复制
        清除ObservableList并添加集合中的所有元素。
        Specified by:
        setAll在接口 ObservableList<E>
        参数
        elements - 将添加到此observableArrayList的元素的集合
        结果
        true（由Collection.add（E）指定）

      • removeAll

        public boolean removeAll​(E... elements)
        说明从接口ObservableList复制
        一个方便的方法，用于var-arg使用的 removeAll方法。
        Specified by:
        removeAll在接口 ObservableList<E>
        参数
        elements - 要删除的元素
        结果
        如果列表因此调用而更改，则为true

      • retainAll

        public boolean retainAll​(E... elements)
        说明从界面ObservableList复制
        对于 retainAll方法的var-arg使用的 方便方法。
        Specified by:
        retainAll在接口 ObservableList<E>
        参数
        elements - 要保留的元素
        结果
        如果列表因此调用而更改，则为true

      • remove

        public void remove​(int from,
                   int to)
        说明从界面ObservableList复制
        一种调用sublist(from, to).clear()简化方法。 由于这是一个常见的操作，ObservableList具有方便使用的方法。
        Specified by:
        remove在接口 ObservableList<E>
        参数
        from - 要移除的范围的开始（含）
        to - 要移除的范围的结束（排他）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class LongBinding

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.binding.LongBinding
  • All Implemented Interfaces:
    Binding<Number> ， NumberBinding ， NumberExpression ， Observable ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number>

    public abstract class LongBinding
extends LongExpression
implements NumberBinding
    基类提供实现long值Binding所需的大部分功能。

    LongBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果其中一个注册的依赖项无效，则此LongBinding被标记为无效。 用unbind(Observable...)监听依赖关系可以停止。

    为了提供该类的具体实现，必须实现方法computeValue()以基于依赖关系的当前状态来计算该绑定的值。 当get()被调用无效绑定时调用。

    参见DoubleBinding ，了解如何扩展这个基类。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Binding ， NumberBinding ， LongExpression

    • 构造方法摘要

      构造方法
      Constructor 描述
      LongBinding​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract long computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose() ，为空。
      long get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      String toString​()
      返回此 LongBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, asObject, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from interface javafx.beans.binding.NumberExpression

        add, add, add, add, add, asString, asString, asString, divide, divide, divide, divide, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

    • 构造方法详细信息

      • LongBinding

        public LongBinding​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对监听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过拨打removeListener取消注册监听器，或者使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        说明从界面复制： ObservableValue
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<Number>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从界面ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<Number>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        默认实现为 dispose()为空。
        Specified by:
        dispose在接口 Binding<Number>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies在接口 Binding<Number>
        结果
        一个空的 ObservableList

      • get

        public final long get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果绑定从上一次调用get()后没有变为无效，则结果将被缓存并返回。
        Specified by:
        get在接口 ObservableLongValue
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        描述从接口Binding复制
        将绑定标记为无效。 这迫使重新计算Binding下一次请求的值。
        Specified by:
        invalidate在接口 Binding<Number>

      • isValid

        public final boolean isValid​()
        说明从界面Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<Number>
        结果
        true如果 Binding有效， false另有 false

      • computeValue

        protected abstract long computeValue​()
        计算此绑定的当前值。

        延长LongBinding必须提供computeValue的实施。

        结果
        当前值

      • toString

        public String toString​()
        返回此 LongBinding对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 LongBinding对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class LongExpression

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    LongBinding ， ReadOnlyLongProperty

    public abstract class LongExpression
extends NumberExpressionBase
implements ObservableLongValue
    LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。

    一个具体的子类LongExpression必须实现方法ObservableLongValue.get() ，它提供了这个表达式的实际值。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      LongExpression​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleBinding add​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      FloatBinding add​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      LongBinding add​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
      LongBinding add​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
      ObjectExpression<Long> asObject​()
      创建一个ObjectExpression ，其值为LongExpression 。
      DoubleBinding divide​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      FloatBinding divide​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值。
      LongBinding divide​(int other)
      创建一个新的NumberBinding ，计算该NumberExpression和常数值。
      LongBinding divide​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      double doubleValue​()
      返回 ObservableNumberValue的值作为 double 。
      float floatValue​()
      返回 ObservableNumberValue的值作为 float 。
      Long getValue​()
      返回此 ObservableValue的当前值
      int intValue​()
      返回 ObservableNumberValue的值作为 int 。
      static LongExpression longExpression​(ObservableLongValue value)
      返回一个LongExpression ，其中包含一个ObservableLongValue 。
      static <T extends Number>
      LongExpression             		longExpression​(ObservableValue<T> value)
      返回一个LongExpression的LongExpression 。
      long longValue​()
      将 ObservableNumberValue的值作为 long 。
      DoubleBinding multiply​(double other)
      创建一个新的NumberBinding ，计算此NumberExpression和常数值。
      FloatBinding multiply​(float other)
      创建一个新的NumberBinding ，计算此NumberExpression和常数值。
      LongBinding multiply​(int other)
      创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
      LongBinding multiply​(long other)
      创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
      LongBinding negate​()
      创建一个新的NumberBinding计算的否定NumberExpression 。
      DoubleBinding subtract​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
      FloatBinding subtract​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
      LongBinding subtract​(int other)
      创建一个新的NumberBinding ，计算该NumberExpression的差异和恒定值。
      LongBinding subtract​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableLongValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

    • 构造方法详细信息

      • LongExpression

        public LongExpression​()

    • 方法详细信息

      • intValue

        public int intValue​()
        描述从接口ObservableNumberValue复制
        将ObservableNumberValue的值作为int 。 如果该值不是int ，则执行标准转换。
        Specified by:
        intValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 int

      • longValue

        public long longValue​()
        说明从接口ObservableNumberValue复制
        返回ObservableNumberValue的值作为long 。 如果值不是long ，则执行标准转换。
        Specified by:
        longValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 long

      • floatValue

        public float floatValue​()
        描述从接口ObservableNumberValue复制
        将该ObservableNumberValue的值作为float 。 如果该值不是float ，则执行标准转换。
        Specified by:
        floatValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 float

      • doubleValue

        public double doubleValue​()
        说明从接口ObservableNumberValue复制
        将ObservableNumberValue的值作为double 。 如果该值不是double ，则执行标准转换。
        Specified by:
        doubleValue在接口 ObservableNumberValue
        结果
        该值 ObservableNumberValue为 double

      • getValue

        public Long getValue​()
        说明从界面ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<Number>
        结果
        当前值

      • longExpression

        public static LongExpression longExpression​(ObservableLongValue value)
        返回一个LongExpression的LongExpression 。 如果ObservableLongValue已经是LongExpression ，它将被退回。 否则，将创建一个新的LongBinding ，绑定到ObservableLongValue 。
        参数
        value - 来源 ObservableLongValue
        结果
        一个 LongExpression包装了 ObservableLongValue如果有必要
        异常
        NullPointerException - 如果 value是 null

      • longExpression

        public static <T extends Number> LongExpression longExpression​(ObservableValue<T> value)
        返回一个LongExpression包裹一个ObservableValue 。 如果ObservableValue已经是一个LongExpression ，它将被返回。 否则将创建一个新的LongBinding ，绑定到ObservableValue 。

        注意：该方法可用于将特定数字类型的ObjectExpression或ObjectProperty转换为LongExpression，这实质上是一个ObservableValue<Number> 。 参见下面的示例。

           LongProperty longProperty = new SimpleLongProperty(1L);
   ObjectProperty<Long> objectProperty = new SimpleObjectProperty<>(2L);
   BooleanBinding binding = longProperty.greaterThan(LongExpression.longExpression(objectProperty));
        注意：空值将被解释为0L
        参数类型
        T - 要包装的号码的类型
        参数
        value - 来源 ObservableValue
        结果
        一个 LongExpression包装了 ObservableValue如果有必要
        异常
        NullPointerException - 如果 value是 null
        从以下版本开始：
        JavaFX 8.0

      • negate

        public LongBinding negate​()
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算的否定为NumberExpression 。
        Specified by:
        negate在接口 NumberExpression
        结果
        新的 NumberBinding

      • add

        public DoubleBinding add​(double other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public FloatBinding add​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public LongBinding add​(long other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        public LongBinding add​(int other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public DoubleBinding subtract​(double other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public FloatBinding subtract​(float other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public LongBinding subtract​(long other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        public LongBinding subtract​(int other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public DoubleBinding multiply​(double other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算此NumberExpression和恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public FloatBinding multiply​(float other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和一个恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public LongBinding multiply​(long other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算此NumberExpression和恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        public LongBinding multiply​(int other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算此NumberExpression和恒定值。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public DoubleBinding divide​(double other)
        描述从接口NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public FloatBinding divide​(float other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public LongBinding divide​(long other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        public LongBinding divide​(int other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • asObject

        public ObjectExpression<Long> asObject​()
        创建一个ObjectExpression ，其值为LongExpression 。 如果这个值LongExpression的变化，价值ObjectExpression将自动更新。
        结果
        新的 ObjectExpression
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MapBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class MapBinding<K,V>

  • java.lang.Object
    • javafx.beans.binding.MapExpression<K,V>
      • javafx.beans.binding.MapBinding<K,V>
  • 参数类型
    K - 关键元素的类型
    V - 值元素的类型
    All Implemented Interfaces:
    Map<K,V> ， Binding<ObservableMap<K,V>> ， Observable ， ObservableMapValue<K,V> ， ObservableObjectValue<K> ， ObservableValue<K> ， ObservableMap<K,V>

    public abstract class MapBinding<K,V>
extends MapExpression<K,V>
implements Binding<ObservableMap<K,V>>
    基类，提供大多数的实现所需的功能Binding的的ObservableMap 。

    MapBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果其中一个注册的依赖关系无效，则此MapBinding被标记为无效。 用unbind(Observable...)听取依赖关系可以停止。

    为了提供这个类的具体实现，必须实现方法computeValue() ，以便根据依赖关系的当前状态计算该绑定的值。 当get()被调用无效绑定时调用。

    有关可以扩展该基类的示例，请参阅DoubleBinding 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    Binding ， MapExpression

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty empty
      一个布尔属性是 true ，如果地图是空的。
      ReadOnlyIntegerProperty size
      表示地图大小的整数属性。

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      MapBinding​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void addListener​(MapChangeListener<? super K,? super V> listener)
      添加一个监听器到这个可观察的地图。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract ObservableMap<K,V> computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose() ，为空。
      ReadOnlyBooleanProperty emptyProperty​()
      一个布尔属性是 true ，如果地图是空的。
      ObservableMap<K,V> get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，每当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void removeListener​(MapChangeListener<? super K,? super V> listener)
      试图从这个可观察的地图中删除一个听众。
      ReadOnlyIntegerProperty sizeProperty​()
      表示地图大小的整数属性。
      String toString​()
      返回此 MapBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, equals, forEach, getOrDefault, hashCode, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from class javafx.beans.binding.MapExpression

        asString, clear, containsKey, containsValue, entrySet, get, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, keySet, mapExpression, put, putAll, remove, size, valueAt, valueAt, values

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

    • Property Detail

      • size

        public ReadOnlyIntegerProperty sizeProperty
        Specified by:
        sizeProperty在 MapExpression<K,V>
        另请参见：
        MapExpression.getSize()

      • empty

        public ReadOnlyBooleanProperty emptyProperty
        Specified by:
        emptyProperty在 MapExpression<K,V>
        另请参见：
        MapExpression.isEmpty()

    • 构造方法详细信息

      • MapBinding

        public MapBinding​()

    • 方法详细信息

      • sizeProperty

        public ReadOnlyIntegerProperty sizeProperty​()
        描述从类别复制： MapExpression
        表示地图大小的整数属性。
        Specified by:
        sizeProperty在 MapExpression<K,V>
        另请参见：
        MapExpression.getSize()

      • emptyProperty

        public ReadOnlyBooleanProperty emptyProperty​()
        描述从类复制： MapExpression
        一个布尔属性是 true ，如果地图是空的。
        Specified by:
        emptyProperty在 MapExpression<K,V>
        另请参见：
        MapExpression.isEmpty()

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变为无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的实例来避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
        说明从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<K>
        参数
        listener - 要注册的听众
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<K>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(MapChangeListener<? super K,? super V> listener)
        说明从界面ObservableMap复制
        添加一个监听器到这个可观察的地图。
        Specified by:
        addListener在接口 ObservableMap<K,V>
        参数
        listener - 用于监听列表更改的监听器

      • removeListener

        public void removeListener​(MapChangeListener<? super K,? super V> listener)
        说明从接口ObservableMap复制
        试图从这个可观察的地图中删除一个听众。 如果听众没有附加到这个地图，没有任何反应。
        Specified by:
        removeListener在接口 ObservableMap<K,V>
        参数
        listener - 要删除的侦听器

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        默认实现为 dispose() ，为空。
        Specified by:
        dispose在接口 Binding<K>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies在接口 Binding<K>
        结果
        一个空的 ObservableList

      • get

        public final ObservableMap<K,V> get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果绑定从上一次调用get()以来没有变为无效，结果将被缓存并返回。
        Specified by:
        get在接口 ObservableObjectValue<K>
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        描述从接口Binding复制
        将绑定标记为无效。 这迫使重新计算Binding下一次请求的值。
        Specified by:
        invalidate在接口 Binding<K>

      • isValid

        public final boolean isValid​()
        说明从接口Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<K>
        结果
        true如果 Binding有效，否则为 false

      • computeValue

        protected abstract ObservableMap<K,V> computeValue​()
        计算此绑定的当前值。

        扩展MapBinding必须提供computeValue的实现。

        结果
        当前值

      • toString

        public String toString​()
        返回此 MapBinding对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of this MapBinding object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MapExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class MapExpression<K,V>

  • java.lang.Object
    • javafx.beans.binding.MapExpression<K,V>
  • 参数类型
    K - 关键元素的类型
    V - 值元素的类型
    All Implemented Interfaces:
    Map<K,V> ， Observable ， ObservableMapValue<K,V> ， ObservableObjectValue<K> ， ObservableValue<K> ， ObservableMap<K,V>
    已知直接子类：
    MapBinding ， ReadOnlyMapProperty

    public abstract class MapExpression<K,V>
extends Object
implements ObservableMapValue<K,V>
    MapExpression是一个ObservableMapValue加上额外的便利方法，以流利的风格生成绑定。

    一个具体的子类MapExpression必须实现方法ObservableObjectValue.get() ，它提供了这个表达式的实际值。

    如果MapExpression的包装列表为null ，则实现Map界面的所有方法将表现为将其应用于不可变的空列表。

    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      Properties
      Type Property 描述
      abstract ReadOnlyBooleanProperty empty
      一个布尔属性是 true ，如果地图是空的。
      abstract ReadOnlyIntegerProperty size
      表示地图大小的整数属性。

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      MapExpression​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      StringBinding asString​()
      创建一个StringBinding持有的价值MapExpression变成了String 。
      void clear​()
      从该地图中删除所有的映射（可选操作）。
      boolean containsKey​(Object obj)
      如果此映射包含指定键的映射，则返回 true 。
      boolean containsValue​(Object obj)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      abstract ReadOnlyBooleanProperty emptyProperty​()
      一个布尔属性是 true ，如果地图是空的。
      Set<Map.Entry<K,V>> entrySet​()
      返回此地图中包含的映射的Set视图。
      V get​(Object key)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。
      int getSize​()
      地图的大小
      ObservableMap<K,V> getValue​()
      返回此 ObservableValue的当前值
      boolean isEmpty​()
      获取属性的值为空。
      BooleanBinding isEqualTo​(ObservableMap<?,?> other)
      创建一个新的BooleanBinding持有true如果此映射等于另一个ObservableMap 。
      BooleanBinding isNotEqualTo​(ObservableMap<?,?> other)
      创建一个新的BooleanBinding持有true如果此映射不等于另一个ObservableMap 。
      BooleanBinding isNotNull​()
      创建一个新的BooleanBinding持有true如果包装地图不是null 。
      BooleanBinding isNull​()
      创建一个新的BooleanBinding持有true如果包装映射为null 。
      Set<K> keySet​()
      返回此地图中包含的键的Set视图。
      static <K,V> MapExpression<K,V> mapExpression​(ObservableMapValue<K,V> value)
      返回一个MapExpression的MapExpression 。
      V put​(K key, V value)
      将指定的值与该映射中的指定键相关联（可选操作）。
      void putAll​(Map<? extends K,? extends V> elements)
      将指定地图的所有映射复制到此映射（可选操作）。
      V remove​(Object obj)
      如果存在（从可选的操作），从该地图中删除一个键的映射。
      int size​()
      返回此地图中键值映射的数量。
      abstract ReadOnlyIntegerProperty sizeProperty​()
      表示地图大小的整数属性。
      ObjectBinding<V> valueAt​(ObservableValue<K> key)
      创建一个包含指定键的映射的新的ObjectBinding 。
      ObjectBinding<V> valueAt​(K key)
      创建一个新的ObjectBinding ，其中包含指定键的映射。
      Collection<V> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, equals, forEach, getOrDefault, hashCode, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableMap

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

    • Property Detail

      • size

        public abstract ReadOnlyIntegerProperty sizeProperty
        表示地图大小的整数属性。
        另请参见：
        getSize()

      • empty

        public abstract ReadOnlyBooleanProperty emptyProperty
        一个布尔属性是 true ，如果地图是空的。
        另请参见：
        isEmpty()

    • 构造方法详细信息

      • MapExpression

        public MapExpression​()

    • 方法详细信息

      • getValue

        public ObservableMap<K,V> getValue​()
        说明从界面ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<K>
        结果
        当前值

      • mapExpression

        public static <K,V> MapExpression<K,V> mapExpression​(ObservableMapValue<K,V> value)
        返回一个MapExpression ，其中包含一个ObservableMapValue 。 如果ObservableMapValue已经是MapExpression ，它将被返回。 否则，一个新的MapBinding被创建绑定到ObservableMapValue 。
        参数类型
        K - 关键元素的类型
        V - 值元素的类型
        参数
        value - 来源 ObservableMapValue
        结果
        一个 MapExpression包装了 ObservableMapValue如果有必要
        异常
        NullPointerException - 如果 value是 null

      • getSize

        public int getSize​()
        地图的大小
        结果
        尺寸

      • sizeProperty

        public abstract ReadOnlyIntegerProperty sizeProperty​()
        表示地图大小的整数属性。
        另请参见：
        getSize()

      • emptyProperty

        public abstract ReadOnlyBooleanProperty emptyProperty​()
        一个布尔属性是 true ，如果地图是空的。
        另请参见：
        isEmpty()

      • valueAt

        public ObjectBinding<V> valueAt​(K key)
        创建一个新的ObjectBinding ，其中包含指定键的映射。
        参数
        key - 映射的关键
        结果
        ObjectBinding

      • valueAt

        public ObjectBinding<V> valueAt​(ObservableValue<K> key)
        创建一个新的ObjectBinding ，其中包含指定键的映射。
        参数
        key - 映射的关键
        结果
        ObjectBinding
        异常
        NullPointerException - 如果 key是 null

      • isEqualTo

        public BooleanBinding isEqualTo​(ObservableMap<?,?> other)
        创建一个新的BooleanBinding持有true如果此映射等于另一个ObservableMap 。
        参数
        other - 其他 ObservableMap
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 other是 null

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(ObservableMap<?,?> other)
        创建一个新的BooleanBinding持有true如果此映射不等于另一个ObservableMap 。
        参数
        other - 其他 ObservableMap
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 other是 null

      • isNull

        public BooleanBinding isNull​()
        创建一个新的BooleanBinding持有true如果包装映射为null 。
        结果
        新的 BooleanBinding

      • isNotNull

        public BooleanBinding isNotNull​()
        创建一个新的BooleanBinding持有true如果包装地图不是null 。
        结果
        新的 BooleanBinding

      • asString

        public StringBinding asString​()
        创建一个StringBinding持有的价值MapExpression变成了String 。 如果这个值MapExpression的变化，价值StringBinding将自动更新。
        结果
        新的 StringBinding

      • size

        public int size​()
        说明从接口Map复制
        返回此地图中键值映射的数量。 如果地图包含Integer.MAX_VALUE元素，则返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Map<K,V>
        结果
        该地图中键值映射的数量

      • isEmpty

        public boolean isEmpty​()
        获取属性的值为空。
        Specified by:
        isEmpty在接口 Map<K,V>
        Property description:
        一个布尔属性是 true ，如果地图是空的。
        结果
        true如果此映射不包含键值映射

      • containsKey

        public boolean containsKey​(Object obj)
        说明从界面Map复制
        如果此映射包含指定键的映射，则返回true 。 更正式地说，返回true当且仅当此映射包含一个键的映射关系k这样Objects.equals(key, k) 。 （最多可以有一个这样的映射。）
        Specified by:
        containsKey在接口 Map<K,V>
        参数
        obj - 要在此地图中存在的密钥要进行测试
        结果
        true如果此映射包含指定键的映射

      • containsValue

        public boolean containsValue​(Object obj)
        说明从接口Map复制
        如果此映射将一个或多个键映射到指定的值，则返回true 。 更正式地，返回true当且仅当此映射包含的至少一个映射到一个值v使得Objects.equals(value, v) 。 对于Map接口的大多数实现，此操作可能需要在地图大小的时间线性。
        Specified by:
        containsValue在接口 Map<K,V>
        参数
        obj - 要在此地图中存在的值要进行测试
        结果
        true如果该地图将一个或多个键映射到指定的值

      • put

        public V put​(K key,
             V value)
        说明从界面Map复制
        将指定的值与该映射中的指定键相关联（可选操作）。 如果映射先前包含了密钥的映射，则旧值将被指定的值替换。 （如果且仅当m.containsKey(k)将返回true则映射m被称为包含关键字k的映射。）
        Specified by:
        put在接口 Map<K,V>
        参数
        key - 指定值与之关联的键
        value - 与指定键相关联的值
        结果
        先前的值相关联key ，或null如果没有映射key 。 （A null返回也可以表示该地图以前关联的null与key ，如果实现支持null值）。

      • remove

        public V remove​(Object obj)
        说明从界面Map复制
        如果存在（从可选的操作），从该地图中删除一个键的映射。 更正式地，如果此映射包含从k键到值v的映射，使得Objects.equals(key, k)删除该映射。 （地图最多可以包含一个这样的映射。）

        返回此映射先前关联密钥的值，或null如果映射不包含关键字的映射。

        如果此映射允许空值，则返回值为null并不一定表示该映射不包含该键的映射; 地图也可能将密钥显式映射到null 。

        一旦呼叫返回，该映射将不包含指定键的映射。

        Specified by:
        remove在接口 Map<K,V>
        参数
        obj - 要从地图中删除其映射的密钥
        结果
        先前的值相关联 key ，或 null如果没有映射 key 。

      • putAll

        public void putAll​(Map<? extends K,? extends V> elements)
        描述从接口Map复制
        将指定地图的所有映射复制到此映射（可选操作）。 此呼叫的效果等同于在此地图上调用put(k, v)一次，从按键k到指定地图中的值v 。 如果在操作进行中修改了指定的地图，则此操作的行为是未定义的。
        Specified by:
        putAll在接口 Map<K,V>
        参数
        elements - 要存储在此地图中的映射

      • clear

        public void clear​()
        说明从界面Map复制
        从该地图中删除所有的映射（可选操作）。 此呼叫返回后，地图将为空。
        Specified by:
        clear在接口 Map<K,V>

      • keySet

        public Set<K> keySet​()
        说明从界面Map复制
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        keySet在接口 Map<K,V>
        结果
        该地图中包含的键的集合视图

      • values

        public Collection<V> values​()
        描述从界面Map复制
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        values在接口 Map<K,V>
        结果
        该地图中包含的值的集合视图

      • entrySet

        public Set<Map.Entry<K,V>> entrySet​()
        描述从接口Map复制
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        entrySet在接口 Map<K,V>
        结果
        该地图中包含的映射的集合视图

      • get

        public V get​(Object key)
        描述从接口Map复制
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回null 。

        更正式地，如果此映射包含从密钥映射k到值v使得Objects.equals(key, k) ，则此方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        如果此映射允许空值，则返回值为null并不一定表示该映射不包含该键的映射; 地图也可能显式地将密钥映射到null 。 可以使用containsKey操作来区分这两种情况。

        Specified by:
        get在接口 Map<K,V>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含键的映射， null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NumberBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Interface NumberBinding

  • All Superinterfaces:
    Binding<Number> ， NumberExpression ， Observable ， ObservableNumberValue ， ObservableValue<Number>
    所有已知实现类：
    DoubleBinding ， FloatBinding ， IntegerBinding ， LongBinding

    public interface NumberBinding
extends Binding<Number>, NumberExpression
    标记界面，用于标记所有绑定数字值的绑定。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Binding ， NumberExpression

    • 方法摘要

      • Methods inherited from interface javafx.beans.binding.Binding

        dispose, getDependencies, invalidate, isValid

      • Methods inherited from interface javafx.beans.binding.NumberExpression

        add, add, add, add, add, asString, asString, asString, divide, divide, divide, divide, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NumberExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Interface NumberExpression

  • All Superinterfaces:
    Observable ， ObservableNumberValue ， ObservableValue<Number>
    All Known Subinterfaces:
    NumberBinding
    所有已知实现类：
    DoubleBinding ， DoubleExpression ， DoubleProperty ， DoublePropertyBase ， FloatBinding ， FloatExpression ， FloatProperty ， FloatPropertyBase ， IntegerBinding ， IntegerExpression ， IntegerProperty ， IntegerPropertyBase ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， LongBinding ， LongExpression ， LongProperty ， LongPropertyBase ， NumberExpressionBase ， ReadOnlyDoubleProperty ， ReadOnlyDoublePropertyBase ， ReadOnlyDoubleWrapper ， ReadOnlyFloatProperty ， ReadOnlyFloatPropertyBase ， ReadOnlyFloatWrapper ， ReadOnlyIntegerProperty ， ReadOnlyIntegerPropertyBase ， ReadOnlyIntegerWrapper ， ReadOnlyJavaBeanDoubleProperty ， ReadOnlyJavaBeanFloatProperty ， ReadOnlyJavaBeanIntegerProperty ， ReadOnlyJavaBeanLongProperty ， ReadOnlyLongProperty ， ReadOnlyLongPropertyBase ， ReadOnlyLongWrapper ， SimpleDoubleProperty ， SimpleFloatProperty ， SimpleIntegerProperty ， SimpleLongProperty ， SimpleStyleableDoubleProperty ， SimpleStyleableFloatProperty ， SimpleStyleableIntegerProperty ， SimpleStyleableLongProperty ， StyleableDoubleProperty ， StyleableFloatProperty ， StyleableIntegerProperty ， StyleableLongProperty

    public interface NumberExpression
extends ObservableNumberValue
    NumberExpression是一个ObservableNumberValue加上额外的便利方法，以流利的风格生成绑定。

    该API允许在定义算术运算时混合类型。 结果的类型由与Java语言相同的规则定义。

    1. 如果其中一个操作数是双倍，结果是一个双倍。
    2. 如果不是，其中一个操作数是一个浮点数，结果是一个浮点数。
    3. 如果不是，其中一个操作数是长的，结果是很长的。
    4. 否则结果是一个整数。

    为了能够处理未指定的返回类型，引入了两个接口NumberExpression及其对应的NumberBinding 。 这意味着，如果返回类型被指定为NumberBinding ，该方法将要么返回DoubleBinding ， FloatBinding ， LongBinding或IntegerBinding ，取决于类型的操作数。

    API尝试尽力确定正确的返回类型，例如将ObservableNumberValue与原始double组合将总是导致一个DoubleBinding 。 在API不知道返回类型的情况下，开发人员有责任调用正确的吸气剂（ ObservableNumberValue.intValue()等）。 如果内部表示与吸气剂的类型不匹配，则完成标准铸件。

    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      NumberBinding add​(double other)
      创建一个新的NumberBinding ，计算该NumberExpression和一个常数值的总和。
      NumberBinding add​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      NumberBinding add​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常量值的总和。
      NumberBinding add​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      NumberBinding add​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的总和。
      StringBinding asString​()
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      StringBinding asString​(String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      StringBinding asString​(Locale locale, String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      NumberBinding divide​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      NumberBinding divide​(float other)
      创建一个新的NumberBinding ，计算该NumberExpression和常数值。
      NumberBinding divide​(int other)
      创建一个新的NumberBinding ，计算该NumberExpression和常数值。
      NumberBinding divide​(long other)
      创建一个新的NumberBinding ，计算该NumberExpression和常数值。
      NumberBinding divide​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的划分 。
      BooleanBinding greaterThan​(double other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding greaterThan​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding greaterThan​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding greaterThan​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding greaterThan​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，其持有true如果这NumberExpression大于另一个ObservableNumberValue 。
      BooleanBinding greaterThanOrEqualTo​(double other)
      创建一个新的BooleanBinding ，如果该NumberExpression大于或等于常量值，则保留true 。
      BooleanBinding greaterThanOrEqualTo​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding greaterThanOrEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding greaterThanOrEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding greaterThanOrEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding持有true如果NumberExpression大于或等于另一个ObservableNumberValue 。
      BooleanBinding isEqualTo​(double other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值（具有公差），则保留true 。
      BooleanBinding isEqualTo​(float other, double epsilon)
      创建一个新的BooleanBinding ，其持有true如果该NumberExpression等于常数值（具有公差）。
      BooleanBinding isEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。
      BooleanBinding isEqualTo​(int other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个常数值（具有公差），则保留true 。
      BooleanBinding isEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。
      BooleanBinding isEqualTo​(long other, double epsilon)
      创建一个新的BooleanBinding ，如果该NumberExpression等于一个常数值（具有公差），则保留true 。
      BooleanBinding isEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等，则保留true 。
      BooleanBinding isEqualTo​(ObservableNumberValue other, double epsilon)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等（具有公差），则保留true 。
      BooleanBinding isNotEqualTo​(double other, double epsilon)
      创建一个新的BooleanBinding ，其持有true如果该NumberExpression不等于常数值（具有公差）。
      BooleanBinding isNotEqualTo​(float other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数值（具有公差），则保留true 。
      BooleanBinding isNotEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。
      BooleanBinding isNotEqualTo​(int other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数（容差），则保留true 。
      BooleanBinding isNotEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。
      BooleanBinding isNotEqualTo​(long other, double epsilon)
      创建一个新的BooleanBinding ，如果该NumberExpression不等于一个常量值（具有公差），则保留true 。
      BooleanBinding isNotEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等，则保留true 。
      BooleanBinding isNotEqualTo​(ObservableNumberValue other, double epsilon)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等（具有公差），则保留true 。
      BooleanBinding lessThan​(double other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
      BooleanBinding lessThan​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
      BooleanBinding lessThan​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
      BooleanBinding lessThan​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
      BooleanBinding lessThan​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，其持有true如果这NumberExpression小于另一个ObservableNumberValue 。
      BooleanBinding lessThanOrEqualTo​(double other)
      创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常量值，则保留true 。
      BooleanBinding lessThanOrEqualTo​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于常数值，则保留true 。
      BooleanBinding lessThanOrEqualTo​(int other)
      创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常数值，则保留true 。
      BooleanBinding lessThanOrEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于一个恒定值，则保留true 。
      BooleanBinding lessThanOrEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding持有true如果NumberExpression小于或等于另一个ObservableNumberValue 。
      NumberBinding multiply​(double other)
      创建一个新的NumberBinding ，计算此NumberExpression和恒定值。
      NumberBinding multiply​(float other)
      创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
      NumberBinding multiply​(int other)
      创建一个新的NumberBinding ，计算该NumberExpression和一个恒定值。
      NumberBinding multiply​(long other)
      创建一个新的NumberBinding ，计算此NumberExpression和常数值。
      NumberBinding multiply​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的产品 。
      NumberBinding negate​()
      创建一个新的NumberBinding ，计算否定为NumberExpression 。
      NumberBinding subtract​(double other)
      创建一个新的NumberBinding ，计算该NumberExpression的差异和恒定值。
      NumberBinding subtract​(float other)
      创建一个新的NumberBinding ，计算该NumberExpression的差异和恒定值。
      NumberBinding subtract​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。
      NumberBinding subtract​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值。
      NumberBinding subtract​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的差异 。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • negate

        NumberBinding negate​()
        创建一个新的NumberBinding ，计算否定为NumberExpression 。
        结果
        新的 NumberBinding

      • add

        NumberBinding add​(ObservableNumberValue other)
        创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的总和。
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • add

        NumberBinding add​(double other)
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        NumberBinding add​(float other)
        创建一个新的NumberBinding ，计算此NumberExpression的总和和常数值。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        NumberBinding add​(long other)
        创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • add

        NumberBinding add​(int other)
        创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        NumberBinding subtract​(ObservableNumberValue other)
        创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的差异 。
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • subtract

        NumberBinding subtract​(double other)
        创建一个新的NumberBinding ，计算这个NumberExpression的差异和一个恒定值。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        NumberBinding subtract​(float other)
        创建一个新的NumberBinding ，计算该NumberExpression的差异和恒定值。
        参数
        other - 常数值
        结果
        新的 NumberBinding

      • subtract

        NumberBinding subtract​(long other)
        创建一个新的NumberBinding ，计算该NumberExpression的差异和恒定值。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • subtract

        NumberBinding subtract​(int other)
        创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        NumberBinding multiply​(ObservableNumberValue other)
        创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的产品 。
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • multiply

        NumberBinding multiply​(double other)
        创建一个新的NumberBinding ，它计算该NumberExpression和一个恒定值。
        参数
        other - 常数值
        结果
        新的 NumberBinding

      • multiply

        NumberBinding multiply​(float other)
        创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • multiply

        NumberBinding multiply​(long other)
        创建一个新的NumberBinding ，计算该NumberExpression和一个恒定值。
        参数
        other - 常数值
        结果
        新的 NumberBinding

      • multiply

        NumberBinding multiply​(int other)
        创建一个新的NumberBinding ，计算该NumberExpression和一个常数值。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        NumberBinding divide​(ObservableNumberValue other)
        创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的划分 。
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • divide

        NumberBinding divide​(double other)
        创建一个新的NumberBinding ，计算该NumberExpression和常数值。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        NumberBinding divide​(float other)
        创建一个新的NumberBinding ，计算该NumberExpression和常数值。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        NumberBinding divide​(long other)
        创建一个新的NumberBinding ，计算该NumberExpression和常数值。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • divide

        NumberBinding divide​(int other)
        创建一个新的NumberBinding ，计算该NumberExpression和常数值。
        参数
        other - 恒定值
        结果
        新的 NumberBinding

      • isEqualTo

        BooleanBinding isEqualTo​(ObservableNumberValue other)
        创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等，则保留true 。

        当比较浮点数时，建议使用允许小容差的isEqualTo()方法。

        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • isEqualTo

        BooleanBinding isEqualTo​(ObservableNumberValue other,
                         double epsilon)
        创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等（具有公差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        other - 第二个 ObservableNumberValue
        epsilon - 公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • isEqualTo

        BooleanBinding isEqualTo​(double other,
                         double epsilon)
        创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值（具有公差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isEqualTo

        BooleanBinding isEqualTo​(float other,
                         double epsilon)
        创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值（具有公差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isEqualTo

        BooleanBinding isEqualTo​(long other)
        创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许较小容差的isEqualTo()方法。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isEqualTo

        BooleanBinding isEqualTo​(long other,
                         double epsilon)
        创建一个新的BooleanBinding ，如果这个NumberExpression等于一个常数（容差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isEqualTo

        BooleanBinding isEqualTo​(int other)
        创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许较小容差的isEqualTo()方法。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isEqualTo

        BooleanBinding isEqualTo​(int other,
                         double epsilon)
        创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值（容差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        比较浮点数时，建议使用小容差。

        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isNotEqualTo

        BooleanBinding isNotEqualTo​(ObservableNumberValue other)
        创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等，则保留true 。

        当比较浮点数时，建议使用允许较小容差的isNotEqualTo()方法。

        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • isNotEqualTo

        BooleanBinding isNotEqualTo​(ObservableNumberValue other,
                            double epsilon)
        创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等（容差），则保留true 。

        两个操作数a和b被认为是如果不相等Math.abs(a-b) > epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        参数
        other - 第二个 ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • isNotEqualTo

        BooleanBinding isNotEqualTo​(double other,
                            double epsilon)
        创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数（容差），则保留true 。

        如果Math.abs(a-b) > epsilon则两个操作数a和b被认为不相等。

        比较浮点数时，建议使用小容差。

        参数
        other - 常数值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isNotEqualTo

        BooleanBinding isNotEqualTo​(float other,
                            double epsilon)
        创建一个新的BooleanBinding ，如果该NumberExpression不等于一个常数值（容差），则保留true 。

        如果Math.abs(a-b) > epsilon则两个操作数a和b被认为不相等。

        比较浮点数时，建议使用小容差。

        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isNotEqualTo

        BooleanBinding isNotEqualTo​(long other)
        创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许小容差的isNotEqualTo()方法。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isNotEqualTo

        BooleanBinding isNotEqualTo​(long other,
                            double epsilon)
        创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数值（具有公差），则保留true 。

        如果Math.abs(a-b) > epsilon则两个操作数a和b被认为不相等。

        比较浮点数时，建议使用小容差。

        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isNotEqualTo

        BooleanBinding isNotEqualTo​(int other)
        创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许较小容差的isNotEqualTo()方法。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isNotEqualTo

        BooleanBinding isNotEqualTo​(int other,
                            double epsilon)
        创建一个新的BooleanBinding ，其持有true如果该NumberExpression不等于常数值（具有公差）。

        如果Math.abs(a-b) > epsilon则两个操作数a和b被认为不相等。

        比较浮点数时，建议使用小容差。

        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • greaterThan

        BooleanBinding greaterThan​(ObservableNumberValue other)
        创建一个新的BooleanBinding持有true如果NumberExpression大于另一个ObservableNumberValue 。
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • greaterThan

        BooleanBinding greaterThan​(double other)
        创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • greaterThan

        BooleanBinding greaterThan​(float other)
        创建一个新的BooleanBinding ，如果该NumberExpression大于恒定值，则保留true 。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThan

        BooleanBinding greaterThan​(long other)
        创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • greaterThan

        BooleanBinding greaterThan​(int other)
        创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • lessThan

        BooleanBinding lessThan​(ObservableNumberValue other)
        创建一个新的BooleanBinding ，其持有true如果这个NumberExpression小于另一个ObservableNumberValue 。
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • lessThan

        BooleanBinding lessThan​(double other)
        创建一个新的BooleanBinding ，如果这个NumberExpression比恒定值小，则保留true 。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThan

        BooleanBinding lessThan​(float other)
        创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThan

        BooleanBinding lessThan​(long other)
        创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThan

        BooleanBinding lessThan​(int other)
        创建一个新的BooleanBinding ，其持有true如果这个NumberExpression小于恒定值。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        BooleanBinding greaterThanOrEqualTo​(ObservableNumberValue other)
        创建一个新的BooleanBinding持有true如果NumberExpression大于或等于另一个ObservableNumberValue 。
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • greaterThanOrEqualTo

        BooleanBinding greaterThanOrEqualTo​(double other)
        创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个常量值，则保留true 。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        BooleanBinding greaterThanOrEqualTo​(float other)
        创建一个新的BooleanBinding ，如果该NumberExpression大于或等于常量值，则保留true 。
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        BooleanBinding greaterThanOrEqualTo​(long other)
        创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        BooleanBinding greaterThanOrEqualTo​(int other)
        创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        BooleanBinding lessThanOrEqualTo​(ObservableNumberValue other)
        创建一个新的BooleanBinding持有true如果NumberExpression小于或等于另一个ObservableNumberValue 。
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果其他 ObservableNumberValue是 null

      • lessThanOrEqualTo

        BooleanBinding lessThanOrEqualTo​(double other)
        创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常量值，则保留true 。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        BooleanBinding lessThanOrEqualTo​(float other)
        创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常数值，则保留true 。
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        BooleanBinding lessThanOrEqualTo​(long other)
        创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于一个恒定值，则保留true 。
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        BooleanBinding lessThanOrEqualTo​(int other)
        创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常数值，则保留true 。
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • asString

        StringBinding asString​()
        创建一个StringBinding持有的价值NumberExpression变成了String 。 如果这个值NumberExpression的变化，价值StringBinding将自动更新。

        转换完成，而不应用任何格式。

        结果
        新的 StringBinding

      • asString

        StringBinding asString​(String format)
        创建一个StringBinding持有的价值NumberExpression变成了String 。 如果这个值NumberExpression的变化，价值StringBinding将自动更新。

        结果根据格式String进行格式化。 有关格式规则，请参阅java.util.Formatter 。

        参数
        format - 格式 String
        结果
        新的 StringBinding

      • asString

        StringBinding asString​(Locale locale,
                       String format)
        创建一个StringBinding持有的价值NumberExpression变成了String 。 如果这个值NumberExpression的变化，价值StringBinding将自动更新。

        结果根据格式String进行格式化，并通过Locale 。 有关格式规则，请参阅java.util.Formatter 。 有关java.util.Locale的详细信息，请参阅Locale 。

        参数
        locale - 要使用的区域设置
        format - 格式 String
        结果
        新的 StringBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NumberExpressionBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class NumberExpressionBase

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    DoubleExpression ， FloatExpression ， IntegerExpression ， LongExpression

    public abstract class NumberExpressionBase
extends Object
implements NumberExpression
    NumberExpressionBase包含了以流畅样式生成绑定的方便方法，这对于所有NumberExpression子类都是常见的。

    NumberExpressionBase作为特定数字类型的特定NumberExpression子类的通用代码的位置。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    IntegerExpression ， LongExpression ， FloatExpression ， DoubleExpression

    • 构造方法摘要

      构造方法
      Constructor 描述
      NumberExpressionBase​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      NumberBinding add​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的总和。
      StringBinding asString​()
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      StringBinding asString​(String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      StringBinding asString​(Locale locale, String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      NumberBinding divide​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的划分 。
      BooleanBinding greaterThan​(double other)
      创建一个新的BooleanBinding ，如果NumberExpression大于恒定值，则保留true 。
      BooleanBinding greaterThan​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding greaterThan​(int other)
      创建一个新的BooleanBinding ，如果该NumberExpression大于恒定值，则保留true 。
      BooleanBinding greaterThan​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding greaterThan​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，其持有true如果这NumberExpression大于另一个ObservableNumberValue 。
      BooleanBinding greaterThanOrEqualTo​(double other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding greaterThanOrEqualTo​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding greaterThanOrEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding greaterThanOrEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding greaterThanOrEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding持有true如果NumberExpression大于或等于另一个ObservableNumberValue 。
      BooleanBinding isEqualTo​(double other, double epsilon)
      创建一个新的BooleanBinding ，其持有true如果该NumberExpression等于常数值（具有公差）。
      BooleanBinding isEqualTo​(float other, double epsilon)
      创建一个新的BooleanBinding ，其持有true如果该NumberExpression等于常数值（具有公差）。
      BooleanBinding isEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。
      BooleanBinding isEqualTo​(int other, double epsilon)
      创建一个新的BooleanBinding ，其持有true如果该NumberExpression等于常数值（具有公差）。
      BooleanBinding isEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。
      BooleanBinding isEqualTo​(long other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个常数值（具有公差），则保留true 。
      BooleanBinding isEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等，则持有true 。
      BooleanBinding isEqualTo​(ObservableNumberValue other, double epsilon)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等（具有公差），则保留true 。
      BooleanBinding isNotEqualTo​(double other, double epsilon)
      创建一个新的BooleanBinding ，其持有true如果该NumberExpression不等于常数值（具有公差））。
      BooleanBinding isNotEqualTo​(float other, double epsilon)
      创建一个新的BooleanBinding ，其持有true如果该NumberExpression不等于常数值（具有公差）。
      BooleanBinding isNotEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。
      BooleanBinding isNotEqualTo​(int other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常量值（具有公差），则保留true 。
      BooleanBinding isNotEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。
      BooleanBinding isNotEqualTo​(long other, double epsilon)
      创建一个新的BooleanBinding ，其持有true如果该NumberExpression不等于常数值（具有公差）。
      BooleanBinding isNotEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等，则保留true 。
      BooleanBinding isNotEqualTo​(ObservableNumberValue other, double epsilon)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等（容差），则保留true 。
      BooleanBinding lessThan​(double other)
      创建一个新的BooleanBinding ，其持有true如果该NumberExpression小于恒定值。
      BooleanBinding lessThan​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
      BooleanBinding lessThan​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
      BooleanBinding lessThan​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
      BooleanBinding lessThan​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，其持有true如果这NumberExpression小于另一个ObservableNumberValue 。
      BooleanBinding lessThanOrEqualTo​(double other)
      创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常数值，则保留true 。
      BooleanBinding lessThanOrEqualTo​(float other)
      创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常数值，则保留true 。
      BooleanBinding lessThanOrEqualTo​(int other)
      创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常数值，则保留true 。
      BooleanBinding lessThanOrEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于常数值，则保留true 。
      BooleanBinding lessThanOrEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding持有true如果NumberExpression小于或等于另一个ObservableNumberValue 。
      NumberBinding multiply​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的产品 。
      static <S extends Number>
      NumberExpressionBase             		numberExpression​(ObservableNumberValue value)
      返回一个NumberExpressionBase ，其中包含一个ObservableNumberValue 。
      NumberBinding subtract​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的差异 。

      • Methods inherited from interface javafx.beans.binding.NumberExpression

        add, add, add, add, divide, divide, divide, divide, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 构造方法详细信息

      • NumberExpressionBase

        public NumberExpressionBase​()

    • 方法详细信息

      • numberExpression

        public static <S extends Number> NumberExpressionBase numberExpression​(ObservableNumberValue value)
        返回一个NumberExpressionBase的NumberExpressionBase 。 如果ObservableNumberValue已经是一个实例NumberExpressionBase ，它会被退回。 否则将创建一个新的NumberBinding ，绑定到ObservableNumberValue 。
        参数类型
        S - 要包装的数字的类型
        参数
        value - 来源 ObservableNumberValue
        结果
        一个 NumberExpressionBase ，如果需要的话包装 ObservableNumberValue
        异常
        NullPointerException - 如果 value是 null

      • add

        public NumberBinding add​(ObservableNumberValue other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的总和。
        Specified by:
        add在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding

      • subtract

        public NumberBinding subtract​(ObservableNumberValue other)
        说明从接口NumberExpression复制
        创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的差异 。
        Specified by:
        subtract在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding

      • multiply

        public NumberBinding multiply​(ObservableNumberValue other)
        描述从界面NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression的产品和另一个ObservableNumberValue 。
        Specified by:
        multiply在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding

      • divide

        public NumberBinding divide​(ObservableNumberValue other)
        说明从界面NumberExpression复制
        创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的划分 。
        Specified by:
        divide在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 NumberBinding

      • isEqualTo

        public BooleanBinding isEqualTo​(ObservableNumberValue other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等，则持有true 。

        当比较浮点数时，建议使用允许较小容差的isEqualTo()方法。

        Specified by:
        isEqualTo在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding

      • isEqualTo

        public BooleanBinding isEqualTo​(ObservableNumberValue other,
                                double epsilon)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等（具有公差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        Specified by:
        isEqualTo在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        epsilon - 公差
        结果
        新的 BooleanBinding

      • isEqualTo

        public BooleanBinding isEqualTo​(double other,
                                double epsilon)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression等于一个常数值（具有公差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        Specified by:
        isEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isEqualTo

        public BooleanBinding isEqualTo​(float other,
                                double epsilon)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，其持有true如果该NumberExpression等于常数值（具有公差）。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        Specified by:
        isEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isEqualTo

        public BooleanBinding isEqualTo​(long other)
        说明从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许较小容差的isEqualTo()方法。

        Specified by:
        isEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isEqualTo

        public BooleanBinding isEqualTo​(long other,
                                double epsilon)
        说明从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值（具有公差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        由于舍入误差，比较浮点数时，建议使用小容差。

        Specified by:
        isEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isEqualTo

        public BooleanBinding isEqualTo​(int other)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，其持有true如果这个NumberExpression等于一个恒定值。

        当比较浮点数时，建议使用允许较小容差的isEqualTo()方法。

        Specified by:
        isEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isEqualTo

        public BooleanBinding isEqualTo​(int other,
                                double epsilon)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果该NumberExpression等于一个常数值（具有公差），则保留true 。

        两个操作数a和b被认为是如果相等Math.abs(a-b) <= epsilon 。

        比较浮点数时，建议使用小容差。

        Specified by:
        isEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(ObservableNumberValue other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等，则保留true 。

        当比较浮点数时，建议使用允许较小容差的isNotEqualTo()方法。

        Specified by:
        isNotEqualTo在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(ObservableNumberValue other,
                                   double epsilon)
        说明从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等（容差），则保留true 。

        如果Math.abs(a-b) > epsilon两个操作数a和b被认为不相等。

        由于舍入误差，比较浮点数时，建议使用小容差。

        Specified by:
        isNotEqualTo接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(double other,
                                   double epsilon)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数（容差），则保留true 。

        如果Math.abs(a-b) > epsilon两个操作数a和b被认为不相等。

        比较浮点数时，建议使用小容差。

        Specified by:
        isNotEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(float other,
                                   double epsilon)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果该NumberExpression不等于一个常量值（具有公差），则保留true 。

        如果Math.abs(a-b) > epsilon两个操作数a和b被认为不相等。

        比较浮点数时，建议使用小容差。

        Specified by:
        isNotEqualTo在接口 NumberExpression
        参数
        other - 常数值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(long other)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许较小容差的isNotEqualTo()方法。

        Specified by:
        isNotEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(long other,
                                   double epsilon)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，其持有true如果该NumberExpression不等于常数值（具有公差）。

        如果Math.abs(a-b) > epsilon则两个操作数a和b被认为不相等。

        比较浮点数时，建议使用小容差。

        Specified by:
        isNotEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(int other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。

        当比较浮点数时，建议使用允许较小容差的isNotEqualTo()方法。

        Specified by:
        isNotEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(int other,
                                   double epsilon)
        说明从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值（带有公差），则保留true 。

        如果Math.abs(a-b) > epsilon则两个操作数a和b被认为不相等。

        比较浮点数时，建议使用小容差。

        Specified by:
        isNotEqualTo在接口 NumberExpression
        参数
        other - 常数值
        epsilon - 允许的公差
        结果
        新的 BooleanBinding

      • greaterThan

        public BooleanBinding greaterThan​(ObservableNumberValue other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，持有true如果这个NumberExpression大于另一个ObservableNumberValue 。
        Specified by:
        greaterThan在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding

      • greaterThan

        public BooleanBinding greaterThan​(double other)
        说明从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
        Specified by:
        greaterThan在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThan

        public BooleanBinding greaterThan​(float other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
        Specified by:
        greaterThan在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThan

        public BooleanBinding greaterThan​(long other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
        Specified by:
        greaterThan在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThan

        public BooleanBinding greaterThan​(int other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
        Specified by:
        greaterThan在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThan

        public BooleanBinding lessThan​(ObservableNumberValue other)
        说明从接口NumberExpression复制
        创建一个新的BooleanBinding ，其持有true如果这NumberExpression是小于另一个ObservableNumberValue 。
        Specified by:
        lessThan在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding

      • lessThan

        public BooleanBinding lessThan​(double other)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
        Specified by:
        lessThan在接口 NumberExpression
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • lessThan

        public BooleanBinding lessThan​(float other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
        Specified by:
        lessThan在接口 NumberExpression
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • lessThan

        public BooleanBinding lessThan​(long other)
        说明从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
        Specified by:
        lessThan在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThan

        public BooleanBinding lessThan​(int other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
        Specified by:
        lessThan在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        public BooleanBinding greaterThanOrEqualTo​(ObservableNumberValue other)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，持有true如果这个NumberExpression大于或等于另一个ObservableNumberValue 。
        Specified by:
        greaterThanOrEqualTo在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        public BooleanBinding greaterThanOrEqualTo​(double other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
        Specified by:
        greaterThanOrEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        public BooleanBinding greaterThanOrEqualTo​(float other)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
        Specified by:
        greaterThanOrEqualTo在接口 NumberExpression
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        public BooleanBinding greaterThanOrEqualTo​(long other)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果NumberExpression大于或等于常数值，则保留true 。
        Specified by:
        greaterThanOrEqualTo在接口 NumberExpression
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        public BooleanBinding greaterThanOrEqualTo​(int other)
        说明从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
        Specified by:
        greaterThanOrEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        public BooleanBinding lessThanOrEqualTo​(ObservableNumberValue other)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding持有true如果NumberExpression小于或等于另一个ObservableNumberValue 。
        Specified by:
        lessThanOrEqualTo在接口 NumberExpression
        参数
        other - 第二个 ObservableNumberValue
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        public BooleanBinding lessThanOrEqualTo​(double other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常数值，则保留true 。
        Specified by:
        lessThanOrEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        public BooleanBinding lessThanOrEqualTo​(float other)
        描述从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常数值，则保留true 。
        Specified by:
        lessThanOrEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        public BooleanBinding lessThanOrEqualTo​(long other)
        说明从接口NumberExpression复制
        创建一个新的BooleanBinding ，如果该NumberExpression小于或等于常数值，则保留true 。
        Specified by:
        lessThanOrEqualTo在接口 NumberExpression
        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        public BooleanBinding lessThanOrEqualTo​(int other)
        说明从界面NumberExpression复制
        创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于常数值，则保留true 。
        Specified by:
        lessThanOrEqualTo在接口 NumberExpression
        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • asString

        public StringBinding asString​()
        说明从界面NumberExpression复制
        创建一个StringBinding持有的价值NumberExpression变成了String 。 如果这个值NumberExpression的变化，价值StringBinding将自动更新。

        转换完成，而不应用任何格式。

        Specified by:
        asString在接口 NumberExpression
        结果
        新的 StringBinding

      • asString

        public StringBinding asString​(String format)
        说明从界面NumberExpression复制
        创建一个StringBinding持有的价值NumberExpression变成了String 。 如果这个值NumberExpression的变化，价值StringBinding将自动更新。

        结果格式化为格式String 。 有关格式规则，请参阅java.util.Formatter 。

        Specified by:
        asString在接口 NumberExpression
        参数
        format - 格式 String
        结果
        新的 StringBinding

      • asString

        public StringBinding asString​(Locale locale,
                              String format)
        说明从界面NumberExpression复制
        创建一个StringBinding持有的价值NumberExpression变成了String 。 如果这个值NumberExpression的变化，价值StringBinding将自动更新。

        结果根据格式String进行格式化，并通过Locale 。 有关格式规则，请参阅java.util.Formatter 。 有关java.util.Locale的详细信息，请参阅Locale 。

        Specified by:
        asString在接口 NumberExpression
        参数
        locale - 要使用的区域设置
        format - 格式 String
        结果
        新的 StringBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObjectBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class ObjectBinding<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.binding.ObjectBinding<T>
  • 参数类型
    T - 包装的类型 Object
    All Implemented Interfaces:
    Binding<T> ， Observable ， ObservableObjectValue<T> ， ObservableValue<T>

    public abstract class ObjectBinding<T>
extends ObjectExpression<T>
implements Binding<T>
    提供实现Object的Object所需的大部分功能的基类。

    ObjectBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果注册的依赖关系中的一个变为无效，则该ObjectBinding被标记为无效。 用unbind(Observable...)听取依赖关系可以停止。

    为了提供该类的具体实现，必须实现方法computeValue() ，以基于依赖关系的当前状态来计算该绑定的值。 当get()被调用无效绑定时被调用。

    有关可以扩展这个基类的示例，请参阅DoubleBinding 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Binding ， ObjectExpression

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObjectBinding​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super T> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract T computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose() ，为空。
      T get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      默认执行getDependencies() ，返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super T> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      String toString​()
      返回此 ObjectBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

    • 构造方法详细信息

      • ObjectBinding

        public ObjectBinding​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从界面Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销侦听器，或使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从界面Observable复制
        从监听器列表中删除给定的监听器，每当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super T> listener)
        说明从界面ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对监听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<T>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super T> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<T>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        默认实现为 dispose() ，为空。
        Specified by:
        dispose在接口 Binding<T>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies在接口 Binding<T>
        结果
        一个空的 ObservableList

      • get

        public final T get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果绑定从上一次调用get()以来没有变为无效，结果将被缓存并返回。
        Specified by:
        get在接口 ObservableObjectValue<T>
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        说明从界面Binding复制
        将绑定标记为无效。 这迫使重新计算Binding下次请求时的值。
        Specified by:
        invalidate在接口 Binding<T>

      • isValid

        public final boolean isValid​()
        说明从界面Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<T>
        结果
        true如果 Binding有效，否则为 false

      • computeValue

        protected abstract T computeValue​()
        计算此绑定的当前值。

        扩展ObjectBinding类必须提供computeValue的实现。

        结果
        当前值

      • toString

        public String toString​()
        返回此 ObjectBinding对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ObjectBinding对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObjectExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class ObjectExpression<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
  • All Implemented Interfaces:
    Observable ， ObservableObjectValue<T> ， ObservableValue<T>
    已知直接子类：
    ObjectBinding ， ReadOnlyObjectProperty

    public abstract class ObjectExpression<T>
extends Object
implements ObservableObjectValue<T>
    ObjectExpression是一个ObservableObjectValue加上额外的便利方法，以流利的风格生成绑定。

    一个具体的子类ObjectExpression必须实现方法ObservableObjectValue.get() ，它提供了这个表达式的实际值。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObjectExpression​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      StringBinding asString​()
      创建一个StringBinding ，将该值ObjectExpression变成String 。
      StringBinding asString​(String format)
      创建一个StringBinding持有的价值ObjectExpression变成了String 。
      StringBinding asString​(Locale locale, String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      T getValue​()
      返回此 ObservableValue的当前值
      BooleanBinding isEqualTo​(Object other)
      创建一个新的 BooleanExpression ，如果这个 ObjectExpression等于一个恒定值，则保留 true 。
      BooleanBinding isEqualTo​(ObservableObjectValue<?> other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue相等，则持有true 。
      BooleanBinding isNotEqualTo​(Object other)
      创建一个新的 BooleanExpression ，如果这个 ObjectExpression不等于一个恒定值，则保留 true 。
      BooleanBinding isNotEqualTo​(ObservableObjectValue<?> other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue不相等，则持有true 。
      BooleanBinding isNotNull​()
      创建一个新的BooleanBinding持有true如果ObjectExpression不null 。
      BooleanBinding isNull​()
      创建一个新的BooleanBinding ，持有true如果这个ObjectExpression是null 。
      static <T> ObjectExpression<T> objectExpression​(ObservableObjectValue<T> value)
      返回一个ObjectExpression的ObjectExpression 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

    • 构造方法详细信息

      • ObjectExpression

        public ObjectExpression​()

    • 方法详细信息

      • getValue

        public T getValue​()
        说明从接口ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<T>
        结果
        当前值

      • objectExpression

        public static <T> ObjectExpression<T> objectExpression​(ObservableObjectValue<T> value)
        返回一个ObjectExpression的ObjectExpression 。 如果ObservableObjectValue已经是一个ObjectExpression ，它将被返回。 否则将创建一个新的ObjectBinding ，绑定到ObservableObjectValue 。
        参数类型
        T - 包装的类型 Object
        参数
        value - 来源 ObservableObjectValue
        结果
        一个 ObjectExpression包装了 ObservableObjectValue如果有必要
        异常
        NullPointerException - 如果 value是 null

      • isEqualTo

        public BooleanBinding isEqualTo​(ObservableObjectValue<?> other)
        创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue相等，则保留true 。
        参数
        other - 其他 ObservableObjectValue
        结果
        新的 BooleanExpression
        异常
        NullPointerException - 如果 other是 null

      • isEqualTo

        public BooleanBinding isEqualTo​(Object other)
        创建一个新的 BooleanExpression ，如果这个 ObjectExpression等于一个恒定值，则保留 true 。
        参数
        other - 恒定值
        结果
        新的 BooleanExpression

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(ObservableObjectValue<?> other)
        创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue不相等，则保留true 。
        参数
        other - 其他 ObservableObjectValue
        结果
        新的 BooleanExpression
        异常
        NullPointerException - 如果 other是 null

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(Object other)
        创建一个新的 BooleanExpression ，如果这个 ObjectExpression不等于一个恒定值，则保留 true 。
        参数
        other - 恒定值
        结果
        新的 BooleanExpression

      • isNull

        public BooleanBinding isNull​()
        创建一个新的BooleanBinding ，持有true如果这个ObjectExpression是null 。
        结果
        新的 BooleanBinding

      • isNotNull

        public BooleanBinding isNotNull​()
        创建一个新的BooleanBinding ，其持有true如果这个ObjectExpression不是null 。
        结果
        新的 BooleanBinding

      • asString

        public StringBinding asString​()
        创建一个StringBinding ，将该值ObjectExpression变成String 。 如果这个值ObjectExpression的变化，价值StringBinding将自动更新。
        结果
        新的 StringBinding
        从以下版本开始：
        JavaFX 8.0

      • asString

        public StringBinding asString​(String format)
        创建一个StringBinding持有的价值ObjectExpression变成了String 。 如果这个值ObjectExpression的变化，价值StringBinding将自动更新。

        结果根据格式String进行格式化。 有关格式规则，请参阅java.util.Formatter 。

        参数
        format - 格式 String
        结果
        新的 StringBinding
        从以下版本开始：
        JavaFX 8.0

      • asString

        public StringBinding asString​(Locale locale,
                              String format)
        创建一个StringBinding持有的价值NumberExpression变成了String 。 如果这个值NumberExpression的变化，价值StringBinding将自动更新。

        结果按格式String进行格式化，并通过Locale 。 有关格式规则，请参阅java.util.Formatter 。 有关java.util.Locale的详细信息，请参阅Locale 。

        参数
        locale - 要使用的区域设置
        format - 格式 String
        结果
        新的 StringBinding
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SetBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class SetBinding<E>

  • java.lang.Object
    • javafx.beans.binding.SetExpression<E>
      • javafx.beans.binding.SetBinding<E>
  • 参数类型
    E - Set元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Set<E> ， Binding<ObservableSet<E>> ， Observable ， ObservableObjectValue<E> ， ObservableSetValue<E> ， ObservableValue<E> ， ObservableSet<E>

    public abstract class SetBinding<E>
extends SetExpression<E>
implements Binding<ObservableSet<E>>
    提供实现ObservableSet的Binding所需的大部分功能的基类。

    SetBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果其中一个注册的依赖关系无效，则此SetBinding被标记为无效。 用unbind(Observable...)监听依赖关系可以停止。

    为了提供这个类的具体实现，必须实现方法computeValue() ，以便根据依赖关系的当前状态来计算该绑定的值。 当get()被调用无效绑定时被调用。

    有关可以扩展这个基类的示例，请参阅DoubleBinding 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    Binding ， SetExpression

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty empty
      一个布尔属性是 true ，如果该集合是空的。
      ReadOnlyIntegerProperty size
      表示集合大小的整数属性。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SetBinding​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super ObservableSet<E>> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void addListener​(SetChangeListener<? super E> listener)
      添加一个监听器到这个可观察的集合。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract ObservableSet<E> computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose() ，为空。
      ReadOnlyBooleanProperty emptyProperty​()
      一个布尔属性是 true ，如果该集合是空的。
      ObservableSet<E> get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super ObservableSet<E>> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void removeListener​(SetChangeListener<? super E> listener)
      试图从这个可观察的集合中删除一个监听器。
      ReadOnlyIntegerProperty sizeProperty​()
      表示集合大小的整数属性。
      String toString​()
      返回此 SetBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface java.util.Set

        equals, hashCode, of, of, of, of, of, of, of, of, of, of, of, of, spliterator

      • Methods inherited from class javafx.beans.binding.SetExpression

        add, addAll, asString, clear, contains, containsAll, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, remove, removeAll, retainAll, setExpression, size, toArray, toArray

    • Property Detail

      • size

        public ReadOnlyIntegerProperty sizeProperty
        Specified by:
        sizeProperty在 SetExpression<E>
        另请参见：
        SetExpression.getSize()

      • empty

        public ReadOnlyBooleanProperty emptyProperty
        Specified by:
        emptyProperty在 SetExpression<E>
        另请参见：
        SetExpression.isEmpty()

    • 构造方法详细信息

      • SetBinding

        public SetBinding​()

    • 方法详细信息

      • sizeProperty

        public ReadOnlyIntegerProperty sizeProperty​()
        描述从类别复制SetExpression
        表示集合大小的整数属性。
        Specified by:
        sizeProperty在 SetExpression<E>
        另请参见：
        SetExpression.getSize()

      • emptyProperty

        public ReadOnlyBooleanProperty emptyProperty​()
        描述从类复制： SetExpression
        一个布尔属性是 true ，如果该集合是空的。
        Specified by:
        emptyProperty在 SetExpression<E>
        另请参见：
        SetExpression.isEmpty()

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable变为无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后拨打removeListener注销一个侦听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super ObservableSet<E>> listener)
        说明从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后拨打removeListener注销一个侦听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 ObservableValue<E>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super ObservableSet<E>> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<E>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(SetChangeListener<? super E> listener)
        说明从接口ObservableSet复制
        添加一个监听器到这个可观察的集合。
        Specified by:
        addListener在接口 ObservableSet<E>
        参数
        listener - 用于监听设置更改的侦听器

      • removeListener

        public void removeListener​(SetChangeListener<? super E> listener)
        说明从界面复制： ObservableSet
        试图从这个可观察的集合中删除一个监听器。 如果监听者没有附加到此列表中，则不会发生任何事情。
        Specified by:
        removeListener在接口 ObservableSet<E>
        参数
        listener - 要删除的侦听器

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        默认实现为 dispose()为空。
        Specified by:
        dispose在接口 Binding<E>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies在接口 Binding<E>
        结果
        一个空的 ObservableList

      • get

        public final ObservableSet<E> get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果自上次调用get()以来，绑定没有变为无效，结果将被缓存并返回。
        Specified by:
        get在接口 ObservableObjectValue<E>
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        说明从接口Binding复制
        将绑定标记为无效。 这迫使下次再次计算Binding请求。
        Specified by:
        invalidate在接口 Binding<E>

      • isValid

        public final boolean isValid​()
        描述从接口Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<E>
        结果
        true如果 Binding有效，否则为 false

      • computeValue

        protected abstract ObservableSet<E> computeValue​()
        计算此绑定的当前值。

        扩展SetBinding必须提供computeValue的实施。

        结果
        当前值

      • toString

        public String toString​()
        返回此 SetBinding对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 SetBinding对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SetExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class SetExpression<E>

  • java.lang.Object
    • javafx.beans.binding.SetExpression<E>
  • 参数类型
    E - Set元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Set<E> ， Observable ， ObservableObjectValue<E> ， ObservableSetValue<E> ， ObservableValue<E> ， ObservableSet<E>
    已知直接子类：
    ReadOnlySetProperty ， SetBinding

    public abstract class SetExpression<E>
extends Object
implements ObservableSetValue<E>
    SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的风格生成绑定。

    SetExpression具体子类必须实现方法ObservableObjectValue.get() ，它提供了这个表达式的实际值。

    如果SetExpression的包装列表是null ，那么实现Set接口的所有方法将表现得像应用于不可变的空集。

    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      Properties
      Type Property 描述
      abstract ReadOnlyBooleanProperty empty
      一个布尔属性，如果该集合为空，则为 true 。
      abstract ReadOnlyIntegerProperty size
      表示集合大小的整数属性。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SetExpression​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(E element)
      如果指定的元素不存在，则将其指定的元素添加（可选操作）。
      boolean addAll​(Collection<? extends E> elements)
      将指定集合中的所有元素添加到此集合（如果尚未存在）（可选操作）。
      StringBinding asString​()
      创建一个StringBinding持有的价值SetExpression变成了String 。
      void clear​()
      从此集合中删除所有元素（可选操作）。
      boolean contains​(Object obj)
      如果此集合包含指定的元素，则返回 true 。
      boolean containsAll​(Collection<?> objects)
      如果此集合包含指定集合的所有元素，则返回 true 。
      abstract ReadOnlyBooleanProperty emptyProperty​()
      一个布尔属性是 true ，如果该集合是空的。
      int getSize​()
      集合的大小
      ObservableSet<E> getValue​()
      返回此 ObservableValue的当前值
      boolean isEmpty​()
      获取属性的值为空。
      BooleanBinding isEqualTo​(ObservableSet<?> other)
      创建一个新的BooleanBinding持有true如果此集合等于另一个ObservableSet 。
      BooleanBinding isNotEqualTo​(ObservableSet<?> other)
      创建一个新的BooleanBinding持有true如果此集合不等于另一个ObservableSet 。
      BooleanBinding isNotNull​()
      创建一个新的BooleanBinding持有true如果包装集不是null 。
      BooleanBinding isNull​()
      创建一个新的BooleanBinding持有true如果包装集为null 。
      Iterator<E> iterator​()
      返回此集合中元素的迭代器。
      boolean remove​(Object obj)
      如果存在，则从该集合中删除指定的元素（可选操作）。
      boolean removeAll​(Collection<?> objects)
      从此集合中删除指定集合中包含的所有元素（可选操作）。
      boolean retainAll​(Collection<?> objects)
      仅保留该集合中包含在指定集合中的元素（可选操作）。
      static <E> SetExpression<E> setExpression​(ObservableSetValue<E> value)
      返回一个SetExpression ，其中包含一个ObservableSetValue 。
      int size​()
      返回此集合中的元素数（其基数）。
      abstract ReadOnlyIntegerProperty sizeProperty​()
      表示集合大小的整数属性。
      Object[] toArray​()
      返回一个包含此集合中所有元素的数组。
      <T> T[] toArray​(T[] array)
      返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.collections.ObservableSet

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

      • Methods inherited from interface java.util.Set

        equals, hashCode, of, of, of, of, of, of, of, of, of, of, of, of, spliterator

    • Property Detail

      • size

        public abstract ReadOnlyIntegerProperty sizeProperty
        表示集合大小的整数属性。
        另请参见：
        getSize()

      • empty

        public abstract ReadOnlyBooleanProperty emptyProperty
        一个布尔属性是 true ，如果该集合是空的。
        另请参见：
        isEmpty()

    • 构造方法详细信息

      • SetExpression

        public SetExpression​()

    • 方法详细信息

      • getValue

        public ObservableSet<E> getValue​()
        说明从接口ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<E>
        结果
        当前值

      • setExpression

        public static <E> SetExpression<E> setExpression​(ObservableSetValue<E> value)
        返回一个SetExpression ，其中包含一个ObservableSetValue 。 如果ObservableSetValue已经是SetExpression ，它将被返回。 否则，新的SetBinding被创建绑定到ObservableSetValue 。
        参数类型
        E - Set元素的类型
        参数
        value - 来源 ObservableSetValue
        结果
        A SetExpression ，如果需要，则包装 ObservableSetValue
        异常
        NullPointerException - 如果 value是 null

      • getSize

        public int getSize​()
        集合的大小
        结果
        尺寸

      • sizeProperty

        public abstract ReadOnlyIntegerProperty sizeProperty​()
        表示集合大小的整数属性。
        另请参见：
        getSize()

      • emptyProperty

        public abstract ReadOnlyBooleanProperty emptyProperty​()
        一个布尔属性，即 true ，如果该集合是空的。
        另请参见：
        isEmpty()

      • isEqualTo

        public BooleanBinding isEqualTo​(ObservableSet<?> other)
        创建一个新的BooleanBinding持有true如果此集合等于另一个ObservableSet 。
        参数
        other - 其他 ObservableSet
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 other是 null

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(ObservableSet<?> other)
        创建一个新的BooleanBinding持有true如果此集合不等于另一个ObservableSet 。
        参数
        other - 其他 ObservableSet
        结果
        新的 BooleanBinding
        异常
        NullPointerException - 如果 other是 null

      • isNull

        public BooleanBinding isNull​()
        创建一个新的BooleanBinding持有true如果包装集为null 。
        结果
        新的 BooleanBinding

      • isNotNull

        public BooleanBinding isNotNull​()
        创建一个新的BooleanBinding持有true如果包装集不是null 。
        结果
        新的 BooleanBinding

      • asString

        public StringBinding asString​()
        创建一个StringBinding持有的价值SetExpression变成了String 。 如果这个值SetExpression的变化，价值StringBinding将自动更新。
        结果
        新的 StringBinding

      • size

        public int size​()
        描述从接口Set复制
        返回此集合中的元素数（其基数）。 如果这个集合包含Integer.MAX_VALUE元素，返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 Set<E>
        结果
        该集合中的元素数（其基数）

      • isEmpty

        public boolean isEmpty​()
        获取属性的值为空。
        Specified by:
        isEmpty在接口 Collection<E>
        Specified by:
        isEmpty在接口 Set<E>
        Property description:
        一个布尔属性是 true ，如果该集合是空的。
        结果
        true如果此集合不包含元素

      • contains

        public boolean contains​(Object obj)
        描述从接口Set复制
        如果此集合包含指定的元素，则返回true 。 更正式地说，返回true当且仅当此set包含的元素e这样Objects.equals(o, e) 。
        Specified by:
        contains在接口 Collection<E>
        Specified by:
        contains在接口 Set<E>
        参数
        obj - 要在此集合中存在的元素将被测试
        结果
        true如果此集合包含指定的元素

      • iterator

        public Iterator<E> iterator​()
        描述从接口Set复制
        返回此集合中元素的迭代器。 元素没有特定的顺序返回（除非此集合是提供保证的某个类的实例）。
        Specified by:
        iterator在接口 Collection<E>
        Specified by:
        iterator在接口 Iterable<E>
        Specified by:
        iterator在接口 Set<E>
        结果
        这个集合中的元素的迭代器

      • toArray

        public Object[] toArray​()
        描述从接口Set复制
        返回一个包含此集合中所有元素的数组。 如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        返回的数组将是“安全的”，因为该集合不保留对它的引用。 （换句话说，这个方法必须分配一个新的数组，即使这个数组是由数组支持的）。 因此，调用者可以自由地修改返回的数组。

        此方法充当基于阵列和基于集合的API之间的桥梁。

        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 Set<E>
        结果
        一个包含此集合中所有元素的数组

      • toArray

        public <T> T[] toArray​(T[] array)
        描述从接口Set复制
        返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。 如果集合适合指定的数组，则返回其中。 否则，将为指定数组的运行时类型和此集合的大小分配一个新数组。

        如果这个集合适合指定的数组，有空余的空间（即，该数组的元素比此集更多），紧接着该集合结束后的数组中的元素设置为null 。 （这仅在调用者知道此集合不包含任何空元素时才可用于确定此集合的长度。）

        如果此集合对其迭代器返回的元素的顺序做出任何保证，则此方法必须以相同的顺序返回元素。

        像Set.toArray()方法一样，此方法充当基于数组和基于集合的API之间的桥梁。 此外，该方法允许精确地控制输出阵列的运行时类型，并且在某些情况下可以用于节省分配成本。

        假设x是一个已知只包含字符串的集合。 以下代码可用于将集合转储到新分配的String数组中：

          String[] y = x.toArray(new String[0]);
        请注意， toArray(new Object[0])功能与toArray()相同。
        Specified by:
        toArray在接口 Collection<E>
        Specified by:
        toArray在接口 Set<E>
        参数类型
        T - 包含集合的数组的运行时类型
        参数
        array - 要存储此集合的元素的数组，如果它足够大; 否则，为此目的分配相同运行时类型的新数组。
        结果
        一个包含此集合中所有元素的数组

      • add

        public boolean add​(E element)
        说明从接口Set复制
        如果指定的元素不存在，则将其指定的元素添加（可选操作）。 更正式地，将指定的元素e这一套如果集合不包含元素e2这样Objects.equals(e, e2) 。 如果该集合已经包含该元素，则该呼叫将保持不变，并返回false 。 结合对构造函数的限制，这样可以确保集合不会包含重复的元素。

        上述规定并不意味着集合必须接受所有要素; 集合可以拒绝添加任何特定元素，包括null ，并抛出异常，如Collection.add的规范中所述 。 单个集合实现应清楚地记录对它们可能包含的元素的任何限制。

        Specified by:
        add在接口 Collection<E>
        Specified by:
        add在接口 Set<E>
        参数
        element - 要添加到此集合的元素
        结果
        true如果此集合尚未包含指定的元素

      • remove

        public boolean remove​(Object obj)
        描述从接口Set复制
        如果存在，则从该集合中删除指定的元素（可选操作）。 更正式地，删除元素e使Objects.equals(o, e) ，如果这个集合包含这样的元素。 如果此集合包含元素（或等效地，如果此集合作为调用的结果而更改），则返回true 。 （一旦调用返回，此集合将不包含该元素。）
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 Set<E>
        参数
        obj - 要从此集合中删除的对象（如果存在）
        结果
        true如果这个集合包含指定的元素

      • containsAll

        public boolean containsAll​(Collection<?> objects)
        描述从接口Set复制
        如果此集合包含指定集合的所有元素，则返回true 。 如果指定的集合也是一个集合，则该方法返回true如果它是该集合的子集）。
        Specified by:
        containsAll在接口 Collection<E>
        Specified by:
        containsAll在接口 Set<E>
        参数
        objects - 要在此集合中检查遏制的集合
        结果
        true如果此集合包含指定集合的所有元素
        另请参见：
        Set.contains(Object)

      • addAll

        public boolean addAll​(Collection<? extends E> elements)
        描述从接口Set复制
        将指定集合中的所有元素添加到此集合（如果尚未存在）（可选操作）。 如果指定的集合也是集合，则addAll操作有效地修改该集合，使其值是两个集合的并集。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 Set<E>
        参数
        elements - 包含要添加到此集合的元素的集合
        结果
        true如果此设置由于呼叫而更改
        另请参见：
        Set.add(Object)

      • removeAll

        public boolean removeAll​(Collection<?> objects)
        描述从接口Set复制
        从此集合中删除指定集合中包含的所有元素（可选操作）。 如果指定的集合也是集合，则该操作有效地修改该集合，使其值是两组的非对称集合差异 。
        Specified by:
        removeAll在接口 Collection<E>
        Specified by:
        removeAll在接口 Set<E>
        参数
        objects - 包含要 objects集合中删除的元素的集合
        结果
        true如果此设置由于呼叫而更改
        另请参见：
        Set.remove(Object) ， Set.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> objects)
        说明从界面Set复制
        仅保留该集合中包含在指定集合中的元素（可选操作）。 换句话说，从这个集合中删除它不包含在指定集合中的所有元素。 如果指定的集合也是一个集合，则此操作有效地修改该集合，使其值是两组的交集 。
        Specified by:
        retainAll在接口 Collection<E>
        Specified by:
        retainAll在接口 Set<E>
        参数
        objects - 包含要保留在此集合中的元素的集合
        结果
        true如果此设置由于呼叫而更改
        另请参见：
        Set.remove(Object)

      • clear

        public void clear​()
        说明从接口Set复制
        从此集合中删除所有元素（可选操作）。 此呼叫返回后，该组将为空。
        Specified by:
        clear在接口 Collection<E>
        Specified by:
        clear在接口 Set<E>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class StringBinding

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.binding.StringBinding
  • All Implemented Interfaces:
    Binding<String> ， Observable ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String>

    public abstract class StringBinding
extends StringExpression
implements Binding<String>
    基类，提供大多数的实现所需的功能Binding一个的String 。

    StringBinding提供了一个简单的无效方案。 扩展类可以通过调用bind(Observable...)来注册依赖关系。 如果注册的依赖关系中的一个变为无效，则该StringBinding被标记为无效。 用unbind(Observable...)监听依赖关系可以停止。

    为了提供该类的具体实现，必须实现方法computeValue() ，以基于依赖关系的当前状态来计算该绑定的值。 当get()被调用无效绑定时被调用。

    参见DoubleBinding ，了解如何扩展这个基类。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Binding ， StringExpression

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringBinding​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super String> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，将通知它。
      protected void bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected abstract String computeValue​()
      计算此绑定的当前值。
      void dispose​()
      默认实现为 dispose() ，为空。
      String get​()
      返回 computeValue()的结果。
      ObservableList<?> getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      void invalidate​()
      将绑定标记为无效。
      boolean isValid​()
      检查绑定是否有效。
      protected void onInvalidating​()
      如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super String> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      String toString​()
      返回此 StringBinding对象的字符串表示形式。
      protected void unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

    • 构造方法详细信息

      • StringBinding

        public StringBinding​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从界面Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从接口Observable复制
        从监听器列表中删除给定的侦听器，每当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super String> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<String>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super String> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<String>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • bind

        protected final void bind​(Observable... dependencies)
        开始观察更改的依赖关系。 如果其中一个依赖关系的值发生变化，则绑定被标记为无效。
        参数
        dependencies - 依赖关系观察

      • unbind

        protected final void unbind​(Observable... dependencies)
        停止观察更改的依赖关系。
        参数
        dependencies - 停止观察的依赖关系

      • dispose

        public void dispose​()
        默认实现为 dispose()为空。
        Specified by:
        dispose在接口 Binding<String>

      • getDependencies

        public ObservableList<?> getDependencies​()
        getDependencies()的默认实现返回一个空的ObservableList 。
        Specified by:
        getDependencies在接口 Binding<String>
        结果
        一个空的 ObservableList

      • get

        public final String get​()
        返回computeValue()的结果。 仅当绑定无效时才调用方法computeValue() 。 如果从上一次调用get()以来绑定没有变为无效，结果将被缓存并返回。
        Specified by:
        get在接口 ObservableObjectValue<String>
        结果
        当前值

      • onInvalidating

        protected void onInvalidating​()
        如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。 默认实现为空。

      • invalidate

        public final void invalidate​()
        描述从接口Binding复制
        将绑定标记为无效。 这迫使重新计算下一次请求的Binding的值。
        Specified by:
        invalidate在接口 Binding<String>

      • isValid

        public final boolean isValid​()
        描述从接口Binding复制
        检查绑定是否有效。
        Specified by:
        isValid在接口 Binding<String>
        结果
        true如果 Binding有效，则 false否则

      • computeValue

        protected abstract String computeValue​()
        计算此绑定的当前值。

        StringBinding必须提供computeValue的实施。

        结果
        当前值

      • toString

        public String toString​()
        返回此 StringBinding对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 StringBinding对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class StringExpression

  • java.lang.Object
    • javafx.beans.binding.StringExpression
  • All Implemented Interfaces:
    Observable ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String>
    已知直接子类：
    ReadOnlyStringProperty ， StringBinding

    public abstract class StringExpression
extends Object
implements ObservableStringValue
    StringExpression是一个ObservableStringValue加上额外的便利方法，以流利的风格生成绑定。

    一个具体的子类StringExpression必须实现方法ObservableObjectValue.get() ，它提供了这个表达式的实际值。

    注意：所有执行BooleanBinding通过比较返回的这个类考虑一个String是null等于一个空的String 。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringExpression​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      StringExpression concat​(Object other)
      返回 StringExpression保留此值 StringExpression与另一级联 Object 。
      String getValue​()
      返回此 ObservableValue的当前值
      String getValueSafe​()
      通常返回这个 StringExpression的值。
      BooleanBinding greaterThan​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression大于恒定值，则保留true 。
      BooleanBinding greaterThan​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression大于另一个ObservableStringValue 。
      BooleanBinding greaterThanOrEqualTo​(String other)
      创建一个新的BooleanBinding ，如果该StringExpression大于或等于常数值，则保留true 。
      BooleanBinding greaterThanOrEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression大于或等于另一个ObservableStringValue 。
      BooleanBinding isEmpty​()
      创建一个新的BooleanBinding ，如果这个StringExpression为空，则保留true 。
      BooleanBinding isEqualTo​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression等于一个恒定值，则保留true 。
      BooleanBinding isEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue是相等的，则保留true 。
      BooleanBinding isEqualToIgnoreCase​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression等于恒定值忽略大小 ，则保留true 。
      BooleanBinding isEqualToIgnoreCase​(ObservableStringValue other)
      创建一个新的BooleanBinding ，持有true如果这和另一个ObservableStringValue是相等的无视情况。
      BooleanBinding isNotEmpty​()
      创建一个新的BooleanBinding ，如果这个StringExpression不为空，则保留true 。
      BooleanBinding isNotEqualTo​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression不等于一个恒定值，则保留true 。
      BooleanBinding isNotEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue不相等，则保留true 。
      BooleanBinding isNotEqualToIgnoreCase​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression不等于恒定值忽略大小 ，则保留true 。
      BooleanBinding isNotEqualToIgnoreCase​(ObservableStringValue other)
      创建一个新的BooleanBinding ，持有true如果这个和另一个ObservableStringValue不等于忽略的情况。
      BooleanBinding isNotNull​()
      创建一个新的BooleanBinding ，其持有true如果这StringExpression不是null 。
      BooleanBinding isNull​()
      创建一个新的BooleanBinding ，持有true如果这StringExpression是null 。
      IntegerBinding length​()
      创建一个新的IntegerBinding ，其长度为StringExpression 。
      BooleanBinding lessThan​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression小于恒定值，则保留true 。
      BooleanBinding lessThan​(ObservableStringValue other)
      创建一个新的BooleanBinding ，其持有true如果这StringExpression小于另一个ObservableStringValue 。
      BooleanBinding lessThanOrEqualTo​(String other)
      创建一个新的BooleanBinding ，如果该StringExpression小于或等于常数值，则保留true 。
      BooleanBinding lessThanOrEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression小于或等于另一个ObservableStringValue 。
      static StringExpression stringExpression​(ObservableValue<?> value)
      返回一个StringExpression ，其中包含一个ObservableValue 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, removeListener

    • 构造方法详细信息

      • StringExpression

        public StringExpression​()

    • 方法详细信息

      • getValue

        public String getValue​()
        说明从接口ObservableValue复制
        返回此 ObservableValue的当前值
        Specified by:
        getValue在接口 ObservableValue<String>
        结果
        当前值

      • getValueSafe

        public final String getValueSafe​()
        通常返回这个StringExpression的值。 只有当值为null ， String返回一个空的String 。
        结果
        该值为 StringExpression或空 String

      • stringExpression

        public static StringExpression stringExpression​(ObservableValue<?> value)
        返回一个StringExpression的StringExpression 。 如果ObservableValue已经是一个StringExpression ，它将被返回。 否则，将创建一个新的StringBinding ，将ObservableValue的值转换为String 。
        参数
        value - 来源 ObservableValue
        结果
        一个 StringExpression包装了 ObservableValue如果有必要
        异常
        NullPointerException - 如果 value是 null

      • concat

        public StringExpression concat​(Object other)
        返回一个StringExpression ，该值保持StringExpression与另一个Object连接的值。

        如果此StringExpression的值发生变化，则自动更新生成的StringExpression的值。 此外，如果其他Object是的实施ObservableValue ，在其他变化Object自动在所得反射StringExpression 。

        参数
        other - 其他 Object
        结果
        新的 StringExpression

      • isEqualTo

        public BooleanBinding isEqualTo​(ObservableStringValue other)
        创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue相等，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isEqualTo

        public BooleanBinding isEqualTo​(String other)
        创建一个新的BooleanBinding ，如果这个StringExpression等于一个恒定值，则保存true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(ObservableStringValue other)
        创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue不相等，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isNotEqualTo

        public BooleanBinding isNotEqualTo​(String other)
        创建一个新的BooleanBinding ，如果这个StringExpression不等于一个恒定值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isEqualToIgnoreCase

        public BooleanBinding isEqualToIgnoreCase​(ObservableStringValue other)
        创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue是相等的忽略大小持有true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 第二个 ObservableStringValue
        结果
        新的 BooleanBinding

      • isEqualToIgnoreCase

        public BooleanBinding isEqualToIgnoreCase​(String other)
        创建一个新的BooleanBinding ，如果这个StringExpression等于恒定值忽略大小 ，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • isNotEqualToIgnoreCase

        public BooleanBinding isNotEqualToIgnoreCase​(ObservableStringValue other)
        创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue不相等忽略的情况下保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 第二个 ObservableStringValue
        结果
        新的 BooleanBinding

      • isNotEqualToIgnoreCase

        public BooleanBinding isNotEqualToIgnoreCase​(String other)
        创建一个新的BooleanBinding ，如果这个StringExpression不等于一个恒定值忽略大小写，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThan

        public BooleanBinding greaterThan​(ObservableStringValue other)
        创建一个新的BooleanBinding ，其持有true如果这StringExpression大于另一个ObservableStringValue 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 第 ObservableStringValue
        结果
        新的 BooleanBinding

      • greaterThan

        public BooleanBinding greaterThan​(String other)
        创建一个新的BooleanBinding ，如果这个StringExpression大于恒定值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • lessThan

        public BooleanBinding lessThan​(ObservableStringValue other)
        创建一个新的BooleanBinding持有true如果StringExpression小于另一个ObservableStringValue 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 第二个 ObservableStringValue
        结果
        新的 BooleanBinding

      • lessThan

        public BooleanBinding lessThan​(String other)
        创建一个新的BooleanBinding ，如果这个StringExpression小于恒定值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 恒定值
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        public BooleanBinding greaterThanOrEqualTo​(ObservableStringValue other)
        创建一个新的BooleanBinding持有true如果StringExpression大于或等于另一个ObservableStringValue 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 第二个 ObservableStringValue
        结果
        新的 BooleanBinding

      • greaterThanOrEqualTo

        public BooleanBinding greaterThanOrEqualTo​(String other)
        创建一个新的BooleanBinding ，如果这个StringExpression大于或等于一个恒定值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        public BooleanBinding lessThanOrEqualTo​(ObservableStringValue other)
        创建一个新的BooleanBinding ，其持有true如果这StringExpression小于或等于另一个ObservableStringValue 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 第二个 ObservableStringValue
        结果
        新的 BooleanBinding

      • lessThanOrEqualTo

        public BooleanBinding lessThanOrEqualTo​(String other)
        创建一个新的BooleanBinding ，如果该StringExpression小于或等于常数值，则保留true 。

        注意：在这个比较中， String是null被认为等于一个空的String 。

        参数
        other - 常数值
        结果
        新的 BooleanBinding

      • isNull

        public BooleanBinding isNull​()
        创建一个新的BooleanBinding ，其持有true如果这StringExpression是null 。
        结果
        新的 BooleanBinding

      • isNotNull

        public BooleanBinding isNotNull​()
        创建一个新的BooleanBinding ，其持有true如果这StringExpression不是null 。
        结果
        新的 BooleanBinding

      • length

        public IntegerBinding length​()
        创建一个新的IntegerBinding ，其长度为StringExpression 。

        注意：如果该StringExpression值为null ，则该长度被认为是0 。

        结果
        新的 IntegerBinding
        从以下版本开始：
        JavaFX 8.0

      • isEmpty

        public BooleanBinding isEmpty​()
        创建一个新的BooleanBinding ，如果该StringExpression为空，则保留true 。

        注意：如果此StringExpression值为null ，则认为为空。

        结果
        新的 BooleanBinding
        从以下版本开始：
        JavaFX 8.0

      • isNotEmpty

        public BooleanBinding isNotEmpty​()
        创建一个新的BooleanBinding ，如果这个StringExpression不为空，则保留true 。

        注意：如果此StringExpression值为null ，则认为为空。

        结果
        新的 BooleanBinding
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.beans.binding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.beans.binding

  • Packages that use javafx.beans.binding
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
  • Classes in javafx.beans.binding used by javafx.beans.binding
    Class 描述
    Binding
    A Binding计算取决于一个或多个来源的值。
    BooleanBinding
    提供实现boolean值Binding所需的大部分功能的基类。
    BooleanExpression
    BooleanExpression是一个ObservableBooleanValue加上额外的便利方法，以流利的风格生成绑定。
    DoubleBinding
    提供实现double的double所需的大部分功能的基类。
    DoubleExpression
    DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
    FloatBinding
    基类提供实现float值的Binding所需的大部分功能。
    FloatExpression
    FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。
    IntegerBinding
    提供实现int值Binding所需的大部分功能的基类。
    IntegerExpression
    IntegerExpression是一个ObservableIntegerValue加上额外的便利方法，以流利的风格生成绑定。
    ListExpression
    ListExpression是一个ObservableListValue，另外还有一种方便的方法来生成流畅的绑定。
    LongBinding
    提供实现long值Binding所需的大部分功能的基类。
    LongExpression
    LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。
    MapExpression
    MapExpression是一个ObservableMapValue加上其他便利方法，以流利的方式生成绑定。
    NumberBinding
    标记界面，用于标记所有绑定数字值的绑定。
    NumberExpression
    NumberExpression是一个ObservableNumberValue加上额外的便利方法，以流利的风格生成绑定。
    NumberExpressionBase
    NumberExpressionBase包含以流畅样式生成绑定的方便方法，这是所有NumberExpression子类所共有的。
    ObjectBinding
    提供实现Object的Object所需的大部分功能的基类。
    ObjectExpression
    ObjectExpression是一个ObservableObjectValue加上额外的便利方法，以流利的风格生成绑定。
    SetExpression
    SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的风格生成绑定。
    StringBinding
    提供实现270659931976940的String所需的大部分功能的基类。
    StringExpression
    StringExpression是一个ObservableStringValue加上额外的便利方法，以流利的风格生成绑定。
    When
    计算三元表达式的绑定的起始点。
    When.BooleanConditionBuilder
    组装三元表达时需要一个中间类。
    When.NumberConditionBuilder
    if-then-else表达式返回一个数字。
    When.ObjectConditionBuilder
    组装三元表达时需要一个中间类。
    When.StringConditionBuilder
    组装三元表达时需要一个中间类。
  • Classes in javafx.beans.binding used by javafx.beans.property
    Class 描述
    BooleanExpression
    BooleanExpression是一个ObservableBooleanValue，另外还有一个方便的方法来生成流畅的绑定。
    DoubleExpression
    DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
    FloatExpression
    FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。
    IntegerExpression
    IntegerExpression是一个ObservableIntegerValue加上额外的便利方法，以流利的风格生成绑定。
    ListExpression
    ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。
    LongExpression
    LongExpression是一个ObservableLongValue，另外还有一个方便的方法来生成流畅的绑定。
    MapExpression
    MapExpression是一个ObservableMapValue加上额外的便利方法，以流利的风格生成绑定。
    NumberExpression
    NumberExpression是一个ObservableNumberValue加上额外的便利方法来生成流畅的风格的绑定。
    NumberExpressionBase
    NumberExpressionBase包含方便的方法来生成流畅样式的绑定，这是所有NumberExpression子类的共同之处。
    ObjectExpression
    ObjectExpression是一个ObservableObjectValue加上额外的便利方法，以流利的风格生成绑定。
    SetExpression
    SetExpression是一个ObservableSetValue，另外还有一个方便的方法来生成流畅的绑定。
    StringExpression
    StringExpression是一个ObservableStringValue加上额外的便利方法，以流利的风格生成绑定。
  • Classes in javafx.beans.binding used by javafx.beans.property.adapter
    Class 描述
    BooleanExpression
    BooleanExpression是一个ObservableBooleanValue加上额外的便利方法，以流利的风格生成绑定。
    DoubleExpression
    DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
    FloatExpression
    FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。
    IntegerExpression
    IntegerExpression是一个ObservableIntegerValue，另外还有一个方便的方法来生成流畅的绑定。
    LongExpression
    LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。
    NumberExpression
    NumberExpression是一个ObservableNumberValue加上额外的便利方法，以流利的风格生成绑定。
    NumberExpressionBase
    NumberExpressionBase包含方便的方法来生成流畅样式的绑定，这是所有NumberExpression子类所共有的。
    ObjectExpression
    ObjectExpression是一个ObservableObjectValue，另外还有一个方便的方法来生成流畅的绑定。
    StringExpression
    StringExpression是一个ObservableStringValue加上额外的便利方法来生成流畅的风格的绑定。
  • Classes in javafx.beans.binding used by javafx.css
    Class 描述
    BooleanExpression
    BooleanExpression是一个ObservableBooleanValue加上额外的便利方法，以流利的风格生成绑定。
    DoubleExpression
    DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
    FloatExpression
    FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。
    IntegerExpression
    IntegerExpression是一个ObservableIntegerValue加上额外的便利方法，以流畅的风格生成绑定。
    LongExpression
    LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。
    NumberExpression
    NumberExpression是一个ObservableNumberValue加上额外的便利方法，以流利的风格生成绑定。
    NumberExpressionBase
    NumberExpressionBase包含方便的方法来生成流畅样式的绑定，这对所有NumberExpression子类是常见的。
    ObjectExpression
    ObjectExpression是一个ObservableObjectValue加上额外的便利方法，以流利的风格生成绑定。
    StringExpression
    StringExpression是一个ObservableStringValue加上额外的便利方法，以流利的风格生成绑定。
  • Classes in javafx.beans.binding used by javafx.scene.chart
    Class 描述
    DoubleExpression
    DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
    ObjectExpression
    ObjectExpression是一个ObservableObjectValue加上额外的便利方法，以流利的风格生成绑定。
    StringExpression
    StringExpression是一个ObservableStringValue，另外还有一个方便的方法来生成流畅的绑定。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


When (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class When

  • java.lang.Object
    • javafx.beans.binding.When

  • public class When
extends Object
    计算三元表达式的绑定的起始点。

    三元表达式具有new When(cond).then(value1).otherwise(value2);的基本形式。 表达式cond需要是一个ObservableBooleanValue 。 根据cond的值，该值包含value1 （如果为cond.getValue() == true ）或value2 （如果为cond.getValue() == false ）的值。 值value1和value2必须是相同的类型。 它们可以是常数值或ObservableValue的实现。

    从以下版本开始：
    JavaFX 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      class  When.BooleanConditionBuilder
      组装三元表达时需要一个中间类。
      class  When.NumberConditionBuilder
      if-then-else表达式返回一个数字。
      class  When.ObjectConditionBuilder<T>
      组装三元表达时需要一个中间类。
      class  When.StringConditionBuilder
      组装三元表达时需要一个中间类。

    • 构造方法摘要

      构造方法
      Constructor 描述
      When​(ObservableBooleanValue condition)
      构造函数为 When 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      When.BooleanConditionBuilder then​(boolean thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
      When.NumberConditionBuilder then​(double thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
      When.NumberConditionBuilder then​(float thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
      When.NumberConditionBuilder then​(int thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
      When.NumberConditionBuilder then​(long thenValue)
      定义三元表达式的常量值，如果条件为 true ，则返回该 true 。
      When.StringConditionBuilder then​(String thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
      When.BooleanConditionBuilder then​(ObservableBooleanValue thenValue)
      定义ObservableBooleanValue如果条件为true则由三元表达式返回哪个值。
      When.NumberConditionBuilder then​(ObservableNumberValue thenValue)
      定义ObservableNumberValue ，如果条件为true ，那么三元表达式返回哪个值。
      <T> When.ObjectConditionBuilder<T> then​(ObservableObjectValue<T> thenValue)
      定义ObservableObjectValue如果条件为true ， 则该值由三元表达式返回。
      When.StringConditionBuilder then​(ObservableStringValue thenValue)
      定义ObservableStringValue如果条件为true ， 则该值由三元表达式返回。
      <T> When.ObjectConditionBuilder<T> then​(T thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • When

        public When​(ObservableBooleanValue condition)
        构造函数为 When 。
        参数
        condition - 三元表达的条件

    • 方法详细信息

      • then

        public When.NumberConditionBuilder then​(ObservableNumberValue thenValue)
        定义ObservableNumberValue如果条件为true则由三元表达式返回哪个值。
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public When.NumberConditionBuilder then​(double thenValue)
        定义三元表达式的常量值，如果条件为 true则返回。
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public When.NumberConditionBuilder then​(float thenValue)
        定义三元表达式的常量值，如果条件为 true则返回。
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public When.NumberConditionBuilder then​(long thenValue)
        定义三元表达式的常量值，如果条件为 true则返回。
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public When.NumberConditionBuilder then​(int thenValue)
        定义三元表达式的常量值，如果条件为 true ，则返回该 true 。
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public When.BooleanConditionBuilder then​(ObservableBooleanValue thenValue)
        定义ObservableBooleanValue如果条件为true则由三元表达式返回该值。
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public When.BooleanConditionBuilder then​(boolean thenValue)
        定义三元表达式的常量值，如果条件为 true则返回。
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public When.StringConditionBuilder then​(ObservableStringValue thenValue)
        定义ObservableStringValue如果条件为true ， 则该值由三元表达式返回。
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public When.StringConditionBuilder then​(String thenValue)
        定义三元表达式的常量值，如果条件为 true则返回。
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public <T> When.ObjectConditionBuilder<T> then​(ObservableObjectValue<T> thenValue)
        定义ObservableObjectValue如果条件为true ， 则该值由三元表达式返回。
        参数类型
        T - 中间结果的类型
        参数
        thenValue - 值
        结果
        中间结果仍然需要否则分支

      • then

        public <T> When.ObjectConditionBuilder<T> then​(T thenValue)
        定义三元表达式的常量值，如果条件为 true则返回。
        参数类型
        T - 中间结果的类型
        参数
        thenValue - 值
        结果
        the intermediate result which still requires the otherwise-branch
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


When.BooleanConditionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class When.BooleanConditionBuilder

  • java.lang.Object
    • javafx.beans.binding.When.BooleanConditionBuilder
  • Enclosing class:
    When

    public class When.BooleanConditionBuilder
extends Object
    组装三元表达时需要一个中间类。 它不应该在另一个上下文中使用。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanBinding otherwise​(boolean otherwiseValue)
      定义三元表达式的常量值，如果条件为 false则返回。
      BooleanBinding otherwise​(ObservableBooleanValue otherwiseValue)
      定义ObservableBooleanValue如果条件为false ， 则该值由三元表达式返回。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • otherwise

        public BooleanBinding otherwise​(ObservableBooleanValue otherwiseValue)
        定义ObservableBooleanValue如果条件为false ，那么三元表达式返回哪个值。
        参数
        otherwiseValue - 值
        结果
        完整的BooleanBinding

      • otherwise

        public BooleanBinding otherwise​(boolean otherwiseValue)
        定义三元表达式的常量值，如果条件为 false则返回。
        参数
        otherwiseValue - 值
        结果
        完整的BooleanBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


When.NumberConditionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class When.NumberConditionBuilder

  • java.lang.Object
    • javafx.beans.binding.When.NumberConditionBuilder
  • Enclosing class:
    When

    public class When.NumberConditionBuilder
extends Object
    if-then-else表达式返回一个数字。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleBinding otherwise​(double otherwiseValue)
      定义三元表达式的常量值，如果条件为 false ，则返回该 false 。
      NumberBinding otherwise​(float otherwiseValue)
      定义三元表达式的常量值，如果条件为 false则返回。
      NumberBinding otherwise​(int otherwiseValue)
      定义三进制表达式的常量值，如果条件为 false则返回。
      NumberBinding otherwise​(long otherwiseValue)
      定义三元表达式的常量值，如果条件为 false则返回。
      NumberBinding otherwise​(ObservableNumberValue otherwiseValue)
      定义ObservableNumberValue如果条件为false则由三元表达式返回哪个值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • otherwise

        public NumberBinding otherwise​(ObservableNumberValue otherwiseValue)
        定义ObservableNumberValue如果条件为false ， 则该值由三元表达式返回。
        参数
        otherwiseValue - 值
        结果
        完成DoubleBinding

      • otherwise

        public DoubleBinding otherwise​(double otherwiseValue)
        定义三元表达式的常量值，如果条件为 false ，则返回该 false 。
        参数
        otherwiseValue - 值
        结果
        完整的DoubleBinding

      • otherwise

        public NumberBinding otherwise​(float otherwiseValue)
        定义三元表达式的常量值，如果条件为 false ，则返回该 false 。
        参数
        otherwiseValue - 值
        结果
        完成NumberBinding

      • otherwise

        public NumberBinding otherwise​(long otherwiseValue)
        定义三元表达式的常量值，如果条件为 false则返回。
        参数
        otherwiseValue - 值
        结果
        完整的NumberBinding

      • otherwise

        public NumberBinding otherwise​(int otherwiseValue)
        定义三元表达式的常量值，如果条件为 false则返回。
        参数
        otherwiseValue - 值
        结果
        完成NumberBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


When.ObjectConditionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class When.ObjectConditionBuilder<T>

  • java.lang.Object
    • javafx.beans.binding.When.ObjectConditionBuilder<T>
  • Enclosing class:
    When

    public class When.ObjectConditionBuilder<T>
extends Object
    组装三元表达时需要一个中间类。 它不应该在另一个上下文中使用。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectBinding<T> otherwise​(ObservableObjectValue<T> otherwiseValue)
      定义ObservableObjectValue如果条件为false ， 则该值由三元表达式返回。
      ObjectBinding<T> otherwise​(T otherwiseValue)
      定义三元表达式的常量值，如果条件为 false ，则返回。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • otherwise

        public ObjectBinding<T> otherwise​(ObservableObjectValue<T> otherwiseValue)
        定义ObservableObjectValue如果条件为false ， 则该值由三元表达式返回。
        参数
        otherwiseValue - 值
        结果
        完整的ObjectBinding

      • otherwise

        public ObjectBinding<T> otherwise​(T otherwiseValue)
        定义三元表达式的常量值，如果条件为 false ，则返回该 false 。
        参数
        otherwiseValue - 值
        结果
        完整的ObjectBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


When.StringConditionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.binding

Class When.StringConditionBuilder

  • java.lang.Object
    • javafx.beans.binding.When.StringConditionBuilder
  • Enclosing class:
    When

    public class When.StringConditionBuilder
extends Object
    组装三元表达时需要一个中间类。 它不应该在另一个上下文中使用。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      StringBinding otherwise​(String otherwiseValue)
      定义三元表达式的常量值，如果条件为 false ，则返回该 false 。
      StringBinding otherwise​(ObservableStringValue otherwiseValue)
      定义ObservableStringValue如果条件为false ，则三元表达式返回哪个值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • otherwise

        public StringBinding otherwise​(ObservableStringValue otherwiseValue)
        定义ObservableStringValue如果条件为false ， 则该值由三元表达式返回。
        参数
        otherwiseValue - 值
        结果
        完整的StringBinding

      • otherwise

        public StringBinding otherwise​(String otherwiseValue)
        定义三元表达式的常量值，如果条件为 false ，则返回该 false 。
        参数
        otherwiseValue - 值
        结果
        完整的StringBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.beans.binding.Bindings (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.Bindings

No usage of javafx.beans.binding.Bindings
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.BooleanBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.BooleanBinding

  • Packages that use BooleanBinding
    软件包 描述
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。

    • Uses of BooleanBinding in javafx.beans.binding

      Methods in javafx.beans.binding that return BooleanBinding
      Modifier and Type | 方法 | 描述
      static BooleanBinding Bindings.and​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个BooleanBinding计算的两个实例值条件与运算ObservableBooleanValue 。
      BooleanBinding BooleanExpression.and​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，执行条件AND操作在这个BooleanExpression和一个ObservableBooleanValue 。
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, int index)
      创建一个新的BooleanBinding ，其中包含指定位置的ObservableList元素。
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, ObservableIntegerValue index)
      创建一个新的BooleanBinding ，其中包含ObservableList在指定位置的元素。
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, ObservableNumberValue index)
      创建一个新的BooleanBinding ，其中包含指定位置的ObservableList的元素。
      static <K> BooleanBinding Bindings.booleanValueAt​(ObservableMap<K,Boolean> op, ObservableValue<? extends K> key)
      创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> BooleanBinding Bindings.booleanValueAt​(ObservableMap<K,Boolean> op, K key)
      创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
      static BooleanBinding Bindings.createBooleanBinding​(Callable<Boolean> func, Observable... dependencies)
      助手功能创建自定义BooleanBinding 。
      static BooleanBinding Bindings.equal​(double op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常量值（具有公差），则保留true 。
      static BooleanBinding Bindings.equal​(float op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.equal​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，那么它将保持true 。
      static BooleanBinding Bindings.equal​(int op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.equal​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(long op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常量值（具有公差），则保留true 。
      static BooleanBinding Bindings.equal​(Object op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding保持true如果一个的值ObservableObjectValue等于恒定值。
      static BooleanBinding Bindings.equal​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue相等。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, double op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, float op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常量值，则保留true 。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, int op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, long op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常量值（容差），则保留true 。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等（与公差）。
      static BooleanBinding Bindings.equal​(ObservableObjectValue<?> op1, Object op2)
      创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(ObservableObjectValue<?> op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue相等。
      static BooleanBinding Bindings.equal​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等。
      static BooleanBinding Bindings.equalIgnoreCase​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue等于恒定值忽略大小写。
      static BooleanBinding Bindings.equalIgnoreCase​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue等于恒定值忽略大小写。
      static BooleanBinding Bindings.equalIgnoreCase​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等忽略大小写。
      static BooleanBinding Bindings.greaterThan​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThan​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThan​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThan​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThan​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值的值比的值越大ObservableStringValue 。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, long op2)
      如果一个ObservableNumberValue的值大于恒定值，则创建一个新的BooleanBinding ，保留true 。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建新的BooleanBinding ，如果第一个ObservableNumberValue的值大于第二个值，则保留true 。
      static BooleanBinding Bindings.greaterThan​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue比恒定值。
      static BooleanBinding Bindings.greaterThan​(ObservableStringValue op1, ObservableStringValue op2)
      创建新的BooleanBinding ，如果第一个ObservableStringValue的值大于第二个值，则保留true 。
      BooleanBinding NumberExpression.greaterThan​(double other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding NumberExpression.greaterThan​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding NumberExpression.greaterThan​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding NumberExpression.greaterThan​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。
      BooleanBinding NumberExpression.greaterThan​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，其持有true如果这NumberExpression大于另一个ObservableNumberValue 。
      BooleanBinding | NumberExpressionBase.greaterThan​(double other)
      BooleanBinding | NumberExpressionBase.greaterThan​(float other)
      BooleanBinding | NumberExpressionBase.greaterThan​(int other)
      BooleanBinding | NumberExpressionBase.greaterThan​(long other)
      BooleanBinding | NumberExpressionBase.greaterThan​(ObservableNumberValue other)
      BooleanBinding StringExpression.greaterThan​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression大于恒定值，则保留true 。
      BooleanBinding StringExpression.greaterThan​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression大于另一个ObservableStringValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableStringValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建新的BooleanBinding ，如果第一个ObservableNumberValue的值大于或等于第二个值，则保留true 。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue大于或等于恒定值。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableStringValue op1, ObservableStringValue op2)
      创建新的BooleanBinding ，如果第一个ObservableStringValue的值大于或等于第二个值，则保留true 。
      BooleanBinding NumberExpression.greaterThanOrEqualTo​(double other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个常量值，则保留true 。
      BooleanBinding NumberExpression.greaterThanOrEqualTo​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding NumberExpression.greaterThanOrEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding NumberExpression.greaterThanOrEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。
      BooleanBinding NumberExpression.greaterThanOrEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，其持有true如果这个NumberExpression大于或等于另一个ObservableNumberValue 。
      BooleanBinding | NumberExpressionBase.greaterThanOrEqualTo​(double other)
      BooleanBinding | NumberExpressionBase.greaterThanOrEqualTo​(float other)
      BooleanBinding | NumberExpressionBase.greaterThanOrEqualTo​(int other)
      BooleanBinding | NumberExpressionBase.greaterThanOrEqualTo​(long other)
      BooleanBinding | NumberExpressionBase.greaterThanOrEqualTo​(ObservableNumberValue other)
      BooleanBinding StringExpression.greaterThanOrEqualTo​(String other)
      创建一个新的BooleanBinding ，如果StringExpression大于或等于常数值，则保留true 。
      BooleanBinding StringExpression.greaterThanOrEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression大于或等于另一个ObservableStringValue 。
      static BooleanBinding Bindings.isEmpty​(ObservableStringValue op)
      创建一个新的BooleanBinding ，如果ObservableStringValue的值为空，则保留true 。
      static <E> BooleanBinding Bindings.isEmpty​(ObservableList<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableList为空，则保留true 。
      static <K,V> BooleanBinding Bindings.isEmpty​(ObservableMap<K,V> op)
      创建一个新的BooleanBinding ，如果给定的ObservableMap为空，则保留true 。
      static <E> BooleanBinding Bindings.isEmpty​(ObservableSet<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableSet为空，则保留true 。
      BooleanBinding StringExpression.isEmpty​()
      创建一个新的BooleanBinding ，如果这个StringExpression为空，则保留true 。
      BooleanBinding BooleanExpression.isEqualTo​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。
      BooleanBinding ListExpression.isEqualTo​(ObservableList<?> other)
      创建一个新的BooleanBinding持有true如果此列表等于另一个ObservableList 。
      BooleanBinding MapExpression.isEqualTo​(ObservableMap<?,?> other)
      创建一个新的BooleanBinding持有true如果此映射等于另一个ObservableMap 。
      BooleanBinding NumberExpression.isEqualTo​(double other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个常数（容差），则保留true 。
      BooleanBinding NumberExpression.isEqualTo​(float other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个常数（容差），则保留true 。
      BooleanBinding NumberExpression.isEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。
      BooleanBinding NumberExpression.isEqualTo​(int other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值（具有公差），则保留true 。
      BooleanBinding NumberExpression.isEqualTo​(long other)
      创建一个新的BooleanBinding ，如果该NumberExpression等于一个恒定值，则保留true 。
      BooleanBinding NumberExpression.isEqualTo​(long other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值（具有公差），则保留true 。
      BooleanBinding NumberExpression.isEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等，则保留true 。
      BooleanBinding NumberExpression.isEqualTo​(ObservableNumberValue other, double epsilon)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等（具有公差），则保持true 。
      BooleanBinding | NumberExpressionBase.isEqualTo​(double other, double epsilon)
      BooleanBinding | NumberExpressionBase.isEqualTo​(float other, double epsilon)
      BooleanBinding | NumberExpressionBase.isEqualTo​(int other)
      BooleanBinding | NumberExpressionBase.isEqualTo​(int other, double epsilon)
      BooleanBinding | NumberExpressionBase.isEqualTo​(long other)
      BooleanBinding | NumberExpressionBase.isEqualTo​(long other, double epsilon)
      BooleanBinding | NumberExpressionBase.isEqualTo​(ObservableNumberValue other)
      BooleanBinding | NumberExpressionBase.isEqualTo​(ObservableNumberValue other, double epsilon)
      BooleanBinding ObjectExpression.isEqualTo​(Object other)
      创建一个新的 BooleanExpression ，如果这个 ObjectExpression等于一个恒定值，则保留 true 。
      BooleanBinding ObjectExpression.isEqualTo​(ObservableObjectValue<?> other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue相等，则保留true 。
      BooleanBinding SetExpression.isEqualTo​(ObservableSet<?> other)
      创建一个新的BooleanBinding ，其持有true如果该集合等于另一个ObservableSet 。
      BooleanBinding StringExpression.isEqualTo​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression等于一个恒定值，则保留true 。
      BooleanBinding StringExpression.isEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue相等，则保留true 。
      BooleanBinding StringExpression.isEqualToIgnoreCase​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression等于恒定值忽略大小写，则保留true 。
      BooleanBinding StringExpression.isEqualToIgnoreCase​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue是相等忽略的情况下持有true 。
      static BooleanBinding Bindings.isNotEmpty​(ObservableStringValue op)
      创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不是空的。
      static <E> BooleanBinding Bindings.isNotEmpty​(ObservableList<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableList不为空，则保留true 。
      static <K,V> BooleanBinding Bindings.isNotEmpty​(ObservableMap<K,V> op)
      创建一个新的BooleanBinding ，如果给定的ObservableMap不为空，则保留true 。
      static <E> BooleanBinding Bindings.isNotEmpty​(ObservableSet<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableSet不为空，则保留true 。
      BooleanBinding StringExpression.isNotEmpty​()
      创建一个新的BooleanBinding ，如果这个StringExpression不为空，则保留true 。
      BooleanBinding BooleanExpression.isNotEqualTo​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。
      BooleanBinding ListExpression.isNotEqualTo​(ObservableList<?> other)
      创建一个新的BooleanBinding持有true如果此列表不等于另一个ObservableList 。
      BooleanBinding MapExpression.isNotEqualTo​(ObservableMap<?,?> other)
      创建一个新的BooleanBinding持有true如果此映射不等于另一个ObservableMap 。
      BooleanBinding NumberExpression.isNotEqualTo​(double other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数（容差），则保留true 。
      BooleanBinding NumberExpression.isNotEqualTo​(float other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数（容差），则保留true 。
      BooleanBinding NumberExpression.isNotEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。
      BooleanBinding NumberExpression.isNotEqualTo​(int other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于常数值（具有公差），则保留true 。
      BooleanBinding NumberExpression.isNotEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于恒定值，则保留true 。
      BooleanBinding NumberExpression.isNotEqualTo​(long other, double epsilon)
      创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数（容差），则保留true 。
      BooleanBinding NumberExpression.isNotEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等，则持有true 。
      BooleanBinding NumberExpression.isNotEqualTo​(ObservableNumberValue other, double epsilon)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等（容差），则保留true 。
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(double other, double epsilon)
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(float other, double epsilon)
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(int other)
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(int other, double epsilon)
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(long other)
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(long other, double epsilon)
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(ObservableNumberValue other)
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(ObservableNumberValue other, double epsilon)
      BooleanBinding ObjectExpression.isNotEqualTo​(Object other)
      创建一个新的 BooleanExpression ，如果这个 ObjectExpression不等于一个恒定值，则保留 true 。
      BooleanBinding ObjectExpression.isNotEqualTo​(ObservableObjectValue<?> other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue不相等，则保留true 。
      BooleanBinding SetExpression.isNotEqualTo​(ObservableSet<?> other)
      创建一个新的BooleanBinding持有true如果此集合不等于另一个ObservableSet 。
      BooleanBinding StringExpression.isNotEqualTo​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression不等于一个恒定值，则保留true 。
      BooleanBinding StringExpression.isNotEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue不相等，则保留true 。
      BooleanBinding StringExpression.isNotEqualToIgnoreCase​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression不等于一个恒定值忽略大小写，则保留true 。
      BooleanBinding StringExpression.isNotEqualToIgnoreCase​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue不相等忽略的情况下保留true 。
      static BooleanBinding Bindings.isNotNull​(ObservableObjectValue<?> op)
      创建一个新的BooleanBinding持有true如果一个价值ObservableObjectValue不null 。
      BooleanBinding ListExpression.isNotNull​()
      创建一个新的BooleanBinding持有true如果包装列表不null 。
      BooleanBinding MapExpression.isNotNull​()
      创建一个新的BooleanBinding持有true如果包装地图不是null 。
      BooleanBinding ObjectExpression.isNotNull​()
      创建一个新的BooleanBinding ，其持有true如果这ObjectExpression不是null 。
      BooleanBinding SetExpression.isNotNull​()
      创建一个新的BooleanBinding持有true如果包装集不是null 。
      BooleanBinding StringExpression.isNotNull​()
      创建一个新的BooleanBinding持有true如果StringExpression不null 。
      static BooleanBinding Bindings.isNull​(ObservableObjectValue<?> op)
      创建一个新的BooleanBinding ，如果true的值为null，则null 。
      BooleanBinding ListExpression.isNull​()
      创建一个新的BooleanBinding持有true如果包装列表为null 。
      BooleanBinding MapExpression.isNull​()
      创建一个新的BooleanBinding持有true如果包装映射为null 。
      BooleanBinding ObjectExpression.isNull​()
      创建一个新的BooleanBinding ，其持有true如果这ObjectExpression是null 。
      BooleanBinding SetExpression.isNull​()
      创建一个新的BooleanBinding持有true如果包装集为null 。
      BooleanBinding StringExpression.isNull​()
      创建一个新的BooleanBinding ，其持有true如果这StringExpression是null 。
      static BooleanBinding Bindings.lessThan​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThan​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThan​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThan​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThan​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableStringValue 。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果第一个ObservableNumberValue的值小于第二个值，则保留true 。
      static BooleanBinding Bindings.lessThan​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableStringValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果第一个ObservableStringValue的值小于第二个值，则保留true 。
      BooleanBinding NumberExpression.lessThan​(double other)
      创建一个新的BooleanBinding ，如果这个NumberExpression比恒定值小，则保留true 。
      BooleanBinding NumberExpression.lessThan​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
      BooleanBinding NumberExpression.lessThan​(int other)
      创建一个新的BooleanBinding ，其持有true如果这个NumberExpression小于恒定值。
      BooleanBinding NumberExpression.lessThan​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression比一个常数值小的话，那么它将持有true 。
      BooleanBinding NumberExpression.lessThan​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，其持有true如果这NumberExpression比另一个ObservableNumberValue小 。
      BooleanBinding | NumberExpressionBase.lessThan​(double other)
      BooleanBinding | NumberExpressionBase.lessThan​(float other)
      BooleanBinding | NumberExpressionBase.lessThan​(int other)
      BooleanBinding | NumberExpressionBase.lessThan​(long other)
      BooleanBinding | NumberExpressionBase.lessThan​(ObservableNumberValue other)
      BooleanBinding StringExpression.lessThan​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression小于恒定值，则保留true 。
      BooleanBinding StringExpression.lessThan​(ObservableStringValue other)
      创建一个新的BooleanBinding ，其持有true如果这StringExpression小于另一个ObservableStringValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableStringValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建新的BooleanBinding ，如果第一个ObservableNumberValue的值小于或等于第二个值，则保留true 。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableStringValue op1, ObservableStringValue op2)
      创建新的BooleanBinding ，如果第一个ObservableStringValue的值小于或等于第二个值，则保留true 。
      BooleanBinding NumberExpression.lessThanOrEqualTo​(double other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于常量值，则保留true 。
      BooleanBinding NumberExpression.lessThanOrEqualTo​(float other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于一个恒定值，则保留true 。
      BooleanBinding NumberExpression.lessThanOrEqualTo​(int other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于常数值，则保留true 。
      BooleanBinding NumberExpression.lessThanOrEqualTo​(long other)
      创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于常数值，则保留true 。
      BooleanBinding NumberExpression.lessThanOrEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding持有true如果NumberExpression小于或等于另一个ObservableNumberValue 。
      BooleanBinding | NumberExpressionBase.lessThanOrEqualTo​(double other)
      BooleanBinding | NumberExpressionBase.lessThanOrEqualTo​(float other)
      BooleanBinding | NumberExpressionBase.lessThanOrEqualTo​(int other)
      BooleanBinding | NumberExpressionBase.lessThanOrEqualTo​(long other)
      BooleanBinding | NumberExpressionBase.lessThanOrEqualTo​(ObservableNumberValue other)
      BooleanBinding StringExpression.lessThanOrEqualTo​(String other)
      创建一个新的BooleanBinding ，如果这个StringExpression小于或等于一个恒定值，则保留true 。
      BooleanBinding StringExpression.lessThanOrEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression小于或等于另一个ObservableStringValue 。
      static BooleanBinding Bindings.not​(ObservableBooleanValue op)
      创建一个BooleanBinding ，计算ObservableBooleanValue的值的倒数 。
      BooleanBinding BooleanExpression.not​()
      创建一个新的 BooleanExpression ，计算这个 BooleanExpression的否定。
      static BooleanBinding Bindings.notEqual​(double op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding Bindings.notEqual​(float op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.notEqual​(int op1, ObservableNumberValue op2)
      如果一个ObservableNumberValue的值不等于一个恒定值，则创建一个新的BooleanBinding ，保留true 。
      static BooleanBinding Bindings.notEqual​(int op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding Bindings.notEqual​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值。
      static BooleanBinding Bindings.notEqual​(long op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.notEqual​(Object op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding保持true如果一个的值ObservableObjectValue不等于恒定值。
      static BooleanBinding Bindings.notEqual​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不等于一个恒定值。
      static BooleanBinding Bindings.notEqual​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue不相等。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, double op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, float op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, int op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, long op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等（与公差）。
      static BooleanBinding Bindings.notEqual​(ObservableObjectValue<?> op1, Object op2)
      创建一个新的BooleanBinding保持true如果一个的值ObservableObjectValue不等于恒定值。
      static BooleanBinding Bindings.notEqual​(ObservableObjectValue<?> op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue不相等。
      static BooleanBinding Bindings.notEqual​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不相等。
      static BooleanBinding Bindings.notEqualIgnoreCase​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。
      static BooleanBinding Bindings.notEqualIgnoreCase​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。
      static BooleanBinding Bindings.notEqualIgnoreCase​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不等于忽略大小写。
      static BooleanBinding Bindings.or​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个BooleanBinding ，它为ObservableBooleanValue的两个实例的值计算条件OR操作。
      BooleanBinding BooleanExpression.or​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，执行条件OR操作在这BooleanExpression和一个ObservableBooleanValue 。
      BooleanBinding When.BooleanConditionBuilder.otherwise​(boolean otherwiseValue)
      定义三元表达式的常量值，如果条件为 false则返回。
      BooleanBinding When.BooleanConditionBuilder.otherwise​(ObservableBooleanValue otherwiseValue)
      定义ObservableBooleanValue ，如果条件为false ， 则该值由三元表达式返回。
      static BooleanBinding Bindings.selectBoolean​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static BooleanBinding Bindings.selectBoolean​(ObservableValue<?> root, String... steps)
      Creates a binding used to get a member, such as a.b.c.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.BooleanExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.BooleanExpression

  • Packages that use BooleanExpression
    软件包 描述
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及许多实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of BooleanExpression in javafx.beans.binding

      Subclasses of BooleanExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  BooleanBinding
      提供实现boolean值Binding所需的大部分功能的基类。
      Methods in javafx.beans.binding that return BooleanExpression
      Modifier and Type 方法 描述
      static BooleanExpression BooleanExpression.booleanExpression​(ObservableBooleanValue value)
      返回一个BooleanExpression的BooleanExpression 。
      static BooleanExpression BooleanExpression.booleanExpression​(ObservableValue<Boolean> value)
      返回一个BooleanExpression ，其中包含一个ObservableValue 。

    • Uses of BooleanExpression in javafx.beans.property

      Subclasses of BooleanExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  BooleanProperty
      该类提供了一个包含 boolean值的Property的完整实现。
      class  BooleanPropertyBase
      BooleanPropertyBase类是包含 boolean值的属性的基类。
      class  ReadOnlyBooleanProperty
      超类为所有只读属性包装一个 boolean 。
      class  ReadOnlyBooleanPropertyBase
      所有只读属性的基类包装一个 boolean 。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleBooleanProperty
      这个类提供了一个Property包装一个boolean值的完整实现。

    • Uses of BooleanExpression in javafx.beans.property.adapter

      Subclasses of BooleanExpression in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanBooleanProperty
      A ReadOnlyJavaBeanBooleanProperty在 boolean或 Boolean之间的常规只读Java Bean属性和JavaFX ReadOnlyBooleanProperty之间提供了一个适配器。

    • Uses of BooleanExpression in javafx.css

      Subclasses of BooleanExpression in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      这个类扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.DoubleBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.DoubleBinding

  • Packages that use DoubleBinding
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。

    • Uses of DoubleBinding in javafx.beans.binding

      Methods in javafx.beans.binding that return DoubleBinding
      Modifier and Type | 方法 | 描述
      static DoubleBinding Bindings.add​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static DoubleBinding Bindings.add​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      DoubleBinding | DoubleExpression.add​(double other)
      DoubleBinding | DoubleExpression.add​(float other)
      DoubleBinding | DoubleExpression.add​(int other)
      DoubleBinding | DoubleExpression.add​(long other)
      DoubleBinding | DoubleExpression.add​(ObservableNumberValue other)
      DoubleBinding | FloatExpression.add​(double other)
      DoubleBinding | IntegerExpression.add​(double other)
      DoubleBinding | LongExpression.add​(double other)
      static DoubleBinding Bindings.createDoubleBinding​(Callable<Double> func, Observable... dependencies)
      助手功能创建一个自定义的DoubleBinding 。
      static DoubleBinding Bindings.divide​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，它计算一个常数值的除法和一个ObservableNumberValue的值。
      static DoubleBinding Bindings.divide​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值除以恒定值。
      DoubleBinding | DoubleExpression.divide​(double other)
      DoubleBinding | DoubleExpression.divide​(float other)
      DoubleBinding | DoubleExpression.divide​(int other)
      DoubleBinding | DoubleExpression.divide​(long other)
      DoubleBinding | DoubleExpression.divide​(ObservableNumberValue other)
      DoubleBinding | FloatExpression.divide​(double other)
      DoubleBinding | IntegerExpression.divide​(double other)
      DoubleBinding | LongExpression.divide​(double other)
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。
      static <K> DoubleBinding Bindings.doubleValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> DoubleBinding Bindings.doubleValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
      static DoubleBinding Bindings.max​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static DoubleBinding Bindings.max​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static DoubleBinding Bindings.min​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static DoubleBinding Bindings.min​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static DoubleBinding Bindings.multiply​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static DoubleBinding Bindings.multiply​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      DoubleBinding | DoubleExpression.multiply​(double other)
      DoubleBinding | DoubleExpression.multiply​(float other)
      DoubleBinding | DoubleExpression.multiply​(int other)
      DoubleBinding | DoubleExpression.multiply​(long other)
      DoubleBinding | DoubleExpression.multiply​(ObservableNumberValue other)
      DoubleBinding | FloatExpression.multiply​(double other)
      DoubleBinding | IntegerExpression.multiply​(double other)
      DoubleBinding | LongExpression.multiply​(double other)
      DoubleBinding | DoubleExpression.negate​()
      DoubleBinding When.NumberConditionBuilder.otherwise​(double otherwiseValue)
      定义三元表达式的常量值，如果条件为 false则返回。
      static DoubleBinding Bindings.selectDouble​(Object root, String... steps)
      创建用于获取成员的绑定，例如 a.b.c 。
      static DoubleBinding Bindings.selectDouble​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static DoubleBinding Bindings.subtract​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算常数值和ObservableNumberValue的值的差值 。
      static DoubleBinding Bindings.subtract​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算一个ObservableNumberValue的值和一个恒定值的差值。
      DoubleBinding | DoubleExpression.subtract​(double other)
      DoubleBinding | DoubleExpression.subtract​(float other)
      DoubleBinding | DoubleExpression.subtract​(int other)
      DoubleBinding | DoubleExpression.subtract​(long other)
      DoubleBinding | DoubleExpression.subtract​(ObservableNumberValue other)
      DoubleBinding | FloatExpression.subtract​(double other)
      DoubleBinding | IntegerExpression.subtract​(double other)
      DoubleBinding | LongExpression.subtract​(double other)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.DoubleExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.DoubleExpression

  • Packages that use DoubleExpression
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of DoubleExpression in javafx.beans.binding

      Subclasses of DoubleExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  DoubleBinding
      提供实现double值Binding所需的大部分功能的基类。
      Methods in javafx.beans.binding that return DoubleExpression
      Modifier and Type 方法 描述
      static DoubleExpression DoubleExpression.doubleExpression​(ObservableDoubleValue value)
      返回一个DoubleExpression ，其中包含一个ObservableDoubleValue 。
      static <T extends Number>
      DoubleExpression             		DoubleExpression.doubleExpression​(ObservableValue<T> value)
      返回一个DoubleExpression ，其中包含一个ObservableValue 。

    • Uses of DoubleExpression in javafx.beans.property

      Subclasses of DoubleExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  DoubleProperty
      这个类定义了一个Property包裹一个double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  ReadOnlyDoubleProperty
      超类为所有只读属性包装一个 double 。
      class  ReadOnlyDoublePropertyBase
      所有只读属性的基类包装一个 double 。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      这个类提供了一个包含 double值的Property的完整实现。

    • Uses of DoubleExpression in javafx.beans.property.adapter

      Subclasses of DoubleExpression in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在 double或 Double的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。

    • Uses of DoubleExpression in javafx.css

      Subclasses of DoubleExpression in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of DoubleExpression in javafx.scene.chart

      Methods in javafx.scene.chart that return DoubleExpression
      Modifier and Type 方法 描述
      DoubleExpression Axis.TickMark.positionProperty​()
      The display position along the axis from axis origin in display units
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.FloatBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.FloatBinding

  • Packages that use FloatBinding
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。

    • Uses of FloatBinding in javafx.beans.binding

      Methods in javafx.beans.binding that return FloatBinding
      Modifier and Type | 方法 | 描述
      FloatBinding | FloatExpression.add​(float other)
      FloatBinding | FloatExpression.add​(int other)
      FloatBinding | FloatExpression.add​(long other)
      FloatBinding | IntegerExpression.add​(float other)
      FloatBinding | LongExpression.add​(float other)
      static FloatBinding Bindings.createFloatBinding​(Callable<Float> func, Observable... dependencies)
      助手功能创建一个自定义FloatBinding 。
      FloatBinding | FloatExpression.divide​(float other)
      FloatBinding | FloatExpression.divide​(int other)
      FloatBinding | FloatExpression.divide​(long other)
      FloatBinding | IntegerExpression.divide​(float other)
      FloatBinding | LongExpression.divide​(float other)
      static FloatBinding Bindings.floatValueAt​(ObservableFloatArray op, int index)
      创建一个新的FloatBinding ，其中包含ObservableArray在指定位置的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableFloatArray op, ObservableIntegerValue index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableArray的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableFloatArray op, ObservableNumberValue index)
      创建一个新的FloatBinding ，其中包含ObservableArray在指定位置的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableList的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的FloatBinding ，其中包含ObservableList在指定位置的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableList的元素。
      static <K> FloatBinding Bindings.floatValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> FloatBinding Bindings.floatValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
      FloatBinding | FloatExpression.multiply​(float other)
      FloatBinding | FloatExpression.multiply​(int other)
      FloatBinding | FloatExpression.multiply​(long other)
      FloatBinding | IntegerExpression.multiply​(float other)
      FloatBinding | LongExpression.multiply​(float other)
      FloatBinding | FloatExpression.negate​()
      static FloatBinding Bindings.selectFloat​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static FloatBinding Bindings.selectFloat​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      FloatBinding | FloatExpression.subtract​(float other)
      FloatBinding | FloatExpression.subtract​(int other)
      FloatBinding | FloatExpression.subtract​(long other)
      FloatBinding | IntegerExpression.subtract​(float other)
      FloatBinding | LongExpression.subtract​(float other)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.FloatExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.FloatExpression

  • Packages that use FloatExpression
    软件包 描述
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上许多实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of FloatExpression in javafx.beans.binding

      Subclasses of FloatExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  FloatBinding
      提供实现float值Binding所需的大部分功能的基类。
      Methods in javafx.beans.binding that return FloatExpression
      Modifier and Type 方法 描述
      static FloatExpression FloatExpression.floatExpression​(ObservableFloatValue value)
      返回一个FloatExpression ，其中包含一个ObservableFloatValue 。
      static <T extends Number>
      FloatExpression             		FloatExpression.floatExpression​(ObservableValue<T> value)
      返回一个FloatExpression ，其中包含一个ObservableValue 。

    • Uses of FloatExpression in javafx.beans.property

      Subclasses of FloatExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  FloatProperty
      这个类定义了一个Property包裹一个float值。
      class  FloatPropertyBase
      类 FloatPropertyBase是包含 float值的属性的基类。
      class  ReadOnlyFloatProperty
      超类为所有只读属性包装一个 float 。
      class  ReadOnlyFloatPropertyBase
      所有只读属性的基类包装一个 float 。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleFloatProperty
      这个类提供了一个270656830975971的全面实现，包含一个float值。

    • Uses of FloatExpression in javafx.beans.property.adapter

      Subclasses of FloatExpression in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在 float或 Float之间的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。

    • Uses of FloatExpression in javafx.css

      Subclasses of FloatExpression in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableFloatProperty
      这个类扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.IntegerBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.IntegerBinding

  • Packages that use IntegerBinding
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。

    • Uses of IntegerBinding in javafx.beans.binding

      Methods in javafx.beans.binding that return IntegerBinding
      Modifier and Type | 方法 | 描述
      IntegerBinding | IntegerExpression.add​(int other)
      static IntegerBinding Bindings.createIntegerBinding​(Callable<Integer> func, Observable... dependencies)
      助手功能创建自定义IntegerBinding 。
      IntegerBinding | IntegerExpression.divide​(int other)
      static IntegerBinding Bindings.integerValueAt​(ObservableIntegerArray op, int index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableArray的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableIntegerArray op, ObservableIntegerValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableArray的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableIntegerArray op, ObservableNumberValue index)
      创建一个新的IntegerBinding ，其中包含ObservableArray在指定位置的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。
      static <K> IntegerBinding Bindings.integerValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> IntegerBinding Bindings.integerValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。
      static IntegerBinding Bindings.length​(ObservableStringValue op)
      创建一个新的IntegerBinding ，其长度为ObservableStringValue 。
      IntegerBinding StringExpression.length​()
      创建一个新的IntegerBinding ，其长度为StringExpression 。
      IntegerBinding | IntegerExpression.multiply​(int other)
      IntegerBinding | IntegerExpression.negate​()
      static IntegerBinding Bindings.selectInteger​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static IntegerBinding Bindings.selectInteger​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static IntegerBinding Bindings.size​(ObservableArray op)
      创建一个新的IntegerBinding ，其大小为ObservableArray 。
      static <E> IntegerBinding Bindings.size​(ObservableList<E> op)
      创建一个新的IntegerBinding ，其大小为ObservableList 。
      static <K,V> IntegerBinding Bindings.size​(ObservableMap<K,V> op)
      创建一个新的IntegerBinding ，其大小为ObservableMap 。
      static <E> IntegerBinding Bindings.size​(ObservableSet<E> op)
      创建一个新的IntegerBinding ，其大小为ObservableSet 。
      IntegerBinding | IntegerExpression.subtract​(int other)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.IntegerExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.IntegerExpression

  • Packages that use IntegerExpression
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of IntegerExpression in javafx.beans.binding

      Subclasses of IntegerExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  IntegerBinding
      提供实现int的int所需的大部分功能的基类。
      Methods in javafx.beans.binding that return IntegerExpression
      Modifier and Type 方法 描述
      static IntegerExpression IntegerExpression.integerExpression​(ObservableIntegerValue value)
      返回一个IntegerExpression ，其中包含一个ObservableIntegerValue 。
      static <T extends Number>
      IntegerExpression             		IntegerExpression.integerExpression​(ObservableValue<T> value)
      返回一个IntegerExpression的IntegerExpression 。

    • Uses of IntegerExpression in javafx.beans.property

      Subclasses of IntegerExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  IntegerProperty
      这个类定义了一个Property包装int值。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  ReadOnlyIntegerProperty
      超类为所有只读属性包装一个 int 。
      class  ReadOnlyIntegerPropertyBase
      所有只读属性的基类包装一个 int 。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleIntegerProperty
      该类提供了一个包含 int值的Property的完整实现。

    • Uses of IntegerExpression in javafx.beans.property.adapter

      Subclasses of IntegerExpression in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在常规的只读Java Bean属性类型为 int或 Integer和JavaFX ReadOnlyIntegerProperty之间提供了适配器。

    • Uses of IntegerExpression in javafx.css

      Subclasses of IntegerExpression in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableIntegerProperty
      这个类扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.ListBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.ListBinding

No usage of javafx.beans.binding.ListBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.ListExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.ListExpression

  • Packages that use ListExpression
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of ListExpression in javafx.beans.binding

      Subclasses of ListExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      Methods in javafx.beans.binding that return ListExpression
      Modifier and Type 方法 描述
      static <E> ListExpression<E> ListExpression.listExpression​(ObservableListValue<E> value)
      返回一个ListExpression ，其中包含一个ObservableListValue 。

    • Uses of ListExpression in javafx.beans.property

      Subclasses of ListExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个Property包装一个ObservableList的完整实现。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  ReadOnlyListProperty<E>
      所有readonly属性的超类包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleListProperty<E>
      这个类提供了一个Property包装一个ObservableList的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.LongBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.LongBinding

  • Packages that use LongBinding
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。

    • Uses of LongBinding in javafx.beans.binding

      Methods in javafx.beans.binding that return LongBinding
      Modifier and Type | 方法 | 描述
      LongBinding | IntegerExpression.add​(long other)
      LongBinding | LongExpression.add​(int other)
      LongBinding | LongExpression.add​(long other)
      static LongBinding Bindings.createLongBinding​(Callable<Long> func, Observable... dependencies)
      助手功能创建一个自定义LongBinding 。
      LongBinding | IntegerExpression.divide​(long other)
      LongBinding | LongExpression.divide​(int other)
      LongBinding | LongExpression.divide​(long other)
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。
      static <K> LongBinding Bindings.longValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> LongBinding Bindings.longValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
      LongBinding | IntegerExpression.multiply​(long other)
      LongBinding | LongExpression.multiply​(int other)
      LongBinding | LongExpression.multiply​(long other)
      LongBinding | LongExpression.negate​()
      static LongBinding Bindings.selectLong​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static LongBinding Bindings.selectLong​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      LongBinding | IntegerExpression.subtract​(long other)
      LongBinding | LongExpression.subtract​(int other)
      LongBinding | LongExpression.subtract​(long other)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.LongExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.LongExpression

  • Packages that use LongExpression
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of LongExpression in javafx.beans.binding

      Subclasses of LongExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  LongBinding
      提供实现long的long所需的大部分功能的基类。
      Methods in javafx.beans.binding that return LongExpression
      Modifier and Type 方法 描述
      static LongExpression LongExpression.longExpression​(ObservableLongValue value)
      返回一个LongExpression ，它包装一个ObservableLongValue 。
      static <T extends Number>
      LongExpression             		LongExpression.longExpression​(ObservableValue<T> value)
      返回一个LongExpression ，其中包含一个ObservableValue 。

    • Uses of LongExpression in javafx.beans.property

      Subclasses of LongExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  LongProperty
      这个类定义了一个27065723917850包装一个long值。
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  ReadOnlyLongProperty
      所有readonly属性的超类包装一个 long 。
      class  ReadOnlyLongPropertyBase
      所有只读属性的基类包装一个 long 。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleLongProperty
      这个类提供了一个包含 long值的Property的完整实现。

    • Uses of LongExpression in javafx.beans.property.adapter

      Subclasses of LongExpression in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanLongProperty
      A JavaBeanLongProperty提供了类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间的适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在类型为 long或 Long的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty之间提供了适配器。

    • Uses of LongExpression in javafx.css

      Subclasses of LongExpression in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableLongProperty
      该课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.MapBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.MapBinding

No usage of javafx.beans.binding.MapBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.MapExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.MapExpression

  • Packages that use MapExpression
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。

    • Uses of MapExpression in javafx.beans.binding

      Subclasses of MapExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  MapBinding<K,V>
      提供实现ObservableMap的Binding所需的大部分功能的基类。
      Methods in javafx.beans.binding that return MapExpression
      Modifier and Type 方法 描述
      static <K,V> MapExpression<K,V> MapExpression.mapExpression​(ObservableMapValue<K,V> value)
      返回一个MapExpression ，其中包含一个ObservableMapValue 。

    • Uses of MapExpression in javafx.beans.property

      Subclasses of MapExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  MapProperty<K,V>
      这个课程提供了一个Property包装一个ObservableMap的完整实现。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装ObservableMap的属性的基类。
      class  ReadOnlyMapProperty<K,V>
      所有readonly属性的超类包装一个ObservableMap 。
      class  ReadOnlyMapPropertyBase<K,V>
      所有只读属性的基类包装一个ObservableMap 。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.NumberExpressionBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.NumberExpressionBase

  • Packages that use NumberExpressionBase
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of NumberExpressionBase in javafx.beans.binding

      Subclasses of NumberExpressionBase in javafx.beans.binding
      Modifier and Type Class 描述
      class  DoubleBinding
      提供实现double值Binding所需的大部分功能的基类。
      class  DoubleExpression
      DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
      class  FloatBinding
      提供实现float值Binding所需的大部分功能的基类。
      class  FloatExpression
      FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。
      class  IntegerBinding
      提供实现int值的Binding所需的大部分功能的基类。
      class  IntegerExpression
      IntegerExpression是一个ObservableIntegerValue加上额外的便利方法，以流畅的风格生成绑定。
      class  LongBinding
      提供实现long值Binding所需的大部分功能的基类。
      class  LongExpression
      LongExpression是一个ObservableLongValue，另外还有一个方便的方法来生成流畅的绑定。
      Methods in javafx.beans.binding that return NumberExpressionBase
      Modifier and Type 方法 描述
      static <S extends Number>
      NumberExpressionBase             		NumberExpressionBase.numberExpression​(ObservableNumberValue value)
      返回一个NumberExpressionBase ，其中包含一个ObservableNumberValue 。

    • Uses of NumberExpressionBase in javafx.beans.property

      Subclasses of NumberExpressionBase in javafx.beans.property
      Modifier and Type Class 描述
      class  DoubleProperty
      这个类定义一个Property包裹一个double值。
      class  DoublePropertyBase
      类 DoublePropertyBase是包含 double值的属性的基类。
      class  FloatProperty
      这个类定义了一个float包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  IntegerProperty
      这个类定义了一个int值， 包含一个int值。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  LongProperty
      这个类定义了一个270657811584362包装long值。
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  ReadOnlyDoubleProperty
      超类为所有只读属性包装一个 double 。
      class  ReadOnlyDoublePropertyBase
      所有只读属性的基类包装一个 double 。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyFloatProperty
      超类为所有只读属性包装一个 float 。
      class  ReadOnlyFloatPropertyBase
      所有只读属性的基类包装一个 float 。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyIntegerProperty
      超类为所有只读属性包装一个 int 。
      class  ReadOnlyIntegerPropertyBase
      所有只读属性的基类包装一个 int 。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyLongProperty
      超类为所有只读属性包装一个 long 。
      class  ReadOnlyLongPropertyBase
      所有只读属性的基类包装一个 long 。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      该类提供了一个包含 double值的Property的全面实现。
      class  SimpleFloatProperty
      这个类提供了一个包含 float值的Property的完整实现。
      class  SimpleIntegerProperty
      这个类提供了一个包含 int值的Property的全面实现。
      class  SimpleLongProperty
      该类提供了一个包含 long值的Property的完整实现。

    • Uses of NumberExpressionBase in javafx.beans.property.adapter

      Subclasses of NumberExpressionBase in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在类型为 double或 Double的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在常规的只读Java Bean属性类型为 double或 Double和JavaFX ReadOnlyDoubleProperty之间提供了适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在 float或 Float之间的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty提供了一个适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在 int或 Integer之间的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在类型为 long或 Long的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty之间提供了一个适配器。

    • Uses of NumberExpressionBase in javafx.css

      Subclasses of NumberExpressionBase in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      该课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的全面实现。
      class  SimpleStyleableIntegerProperty
      这个课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableLongProperty
      该课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      该课程扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      该课程扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      该课程扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      该课程扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.ObjectBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.ObjectBinding

  • Packages that use ObjectBinding
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。

    • Uses of ObjectBinding in javafx.beans.binding

      Methods in javafx.beans.binding that return ObjectBinding
      Modifier and Type 方法 描述
      static <T> ObjectBinding<T> Bindings.createObjectBinding​(Callable<T> func, Observable... dependencies)
      助手功能创建自定义ObjectBinding 。
      ObjectBinding<T> When.ObjectConditionBuilder.otherwise​(ObservableObjectValue<T> otherwiseValue)
      定义ObservableObjectValue如果条件是false ，那么三元表达式返回哪个值。
      ObjectBinding<T> When.ObjectConditionBuilder.otherwise​(T otherwiseValue)
      定义三元表达式的常量值，如果条件为 false ，则返回该 false 。
      static <T> ObjectBinding<T> Bindings.select​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static <T> ObjectBinding<T> Bindings.select​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，例如 a.b.c 。
      static <E> ObjectBinding<E> Bindings.valueAt​(ObservableList<E> op, int index)
      创建一个新的ObjectBinding ，其中包含指定位置的ObservableList的元素。
      static <E> ObjectBinding<E> Bindings.valueAt​(ObservableList<E> op, ObservableIntegerValue index)
      创建一个新的ObjectBinding ，其中包含指定位置的ObservableList的元素。
      static <E> ObjectBinding<E> Bindings.valueAt​(ObservableList<E> op, ObservableNumberValue index)
      创建一个新的ObjectBinding ，其中包含指定位置的ObservableList元素。
      static <K,V> ObjectBinding<V> Bindings.valueAt​(ObservableMap<K,V> op, ObservableValue<? extends K> key)
      创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
      static <K,V> ObjectBinding<V> Bindings.valueAt​(ObservableMap<K,V> op, K key)
      创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
      ObjectBinding<E> ListExpression.valueAt​(int index)
      创建一个新的ObjectBinding ，其中包含指定位置的元素。
      ObjectBinding<E> ListExpression.valueAt​(ObservableIntegerValue index)
      创建一个新的ObjectBinding ，其中包含指定位置的元素。
      ObjectBinding<V> MapExpression.valueAt​(ObservableValue<K> key)
      创建一个新的ObjectBinding ，其中包含指定键的映射。
      ObjectBinding<V> MapExpression.valueAt​(K key)
      创建一个新的ObjectBinding ，其中包含指定键的映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.ObjectExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.ObjectExpression

  • Packages that use ObjectExpression
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of ObjectExpression in javafx.beans.binding

      Subclasses of ObjectExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  ObjectBinding<T>
      提供实现Object的Object所需的大部分功能的基类。
      Methods in javafx.beans.binding that return ObjectExpression
      Modifier and Type 方法 描述
      ObjectExpression<Boolean> BooleanExpression.asObject​()
      创建一个ObjectExpression ，其值为BooleanExpression 。
      ObjectExpression<Double> DoubleExpression.asObject​()
      创建一个ObjectExpression ，其值为DoubleExpression 。
      ObjectExpression<Float> FloatExpression.asObject​()
      创建一个ObjectExpression ，其值为FloatExpression 。
      ObjectExpression<Integer> IntegerExpression.asObject​()
      创建一个ObjectExpression ，其值为IntegerExpression 。
      ObjectExpression<Long> LongExpression.asObject​()
      创建一个ObjectExpression ，其值为LongExpression 。
      static <T> ObjectExpression<T> ObjectExpression.objectExpression​(ObservableObjectValue<T> value)
      返回一个ObjectExpression ，其中包含一个ObservableObjectValue 。

    • Uses of ObjectExpression in javafx.beans.property

      Subclasses of ObjectExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  ObjectProperty<T>
      这个类提供了一个Property包装任意的Object的完整实现。
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyObjectProperty<T>
      超类为所有只读属性包装任意 Object 。
      class  ReadOnlyObjectPropertyBase<T>
      所有只读属性的基类包装任意 Object 。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleObjectProperty<T>
      这个类提供了一个Property的全面实现，包装任意的Object 。

    • Uses of ObjectExpression in javafx.beans.property.adapter

      Subclasses of ObjectExpression in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
      class  ReadOnlyJavaBeanObjectProperty<T>
      A ReadOnlyJavaBeanObjectProperty提供了常规的只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间的适配器。

    • Uses of ObjectExpression in javafx.css

      Subclasses of ObjectExpression in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableObjectProperty<T>
      该课程扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of ObjectExpression in javafx.scene.chart

      Methods in javafx.scene.chart that return ObjectExpression
      Modifier and Type 方法 描述
      ObjectExpression<T> Axis.TickMark.valueProperty​()
      数据单位中该刻度线的值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.SetBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.SetBinding

No usage of javafx.beans.binding.SetBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.SetExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.SetExpression

  • Packages that use SetExpression
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of SetExpression in javafx.beans.binding

      Subclasses of SetExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  SetBinding<E>
      提供实现ObservableSet的Binding所需的大部分功能的基类。
      Methods in javafx.beans.binding that return SetExpression
      Modifier and Type 方法 描述
      static <E> SetExpression<E> SetExpression.setExpression​(ObservableSetValue<E> value)
      返回一个SetExpression ，包装一个ObservableSetValue 。

    • Uses of SetExpression in javafx.beans.property

      Subclasses of SetExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlySetProperty<E>
      超类为所有只读属性包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleSetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.StringBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.StringBinding

  • Packages that use StringBinding
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。

    • Uses of StringBinding in javafx.beans.binding

      Methods in javafx.beans.binding that return StringBinding
      Modifier and Type | 方法 | 描述
      StringBinding BooleanExpression.asString​()
      创建一个StringBinding ，将该值BooleanExpression变成String 。
      StringBinding ListExpression.asString​()
      创建一个StringBinding持有的价值ListExpression变成了String 。
      StringBinding MapExpression.asString​()
      创建一个StringBinding持有的价值MapExpression变成了String 。
      StringBinding NumberExpression.asString​()
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      StringBinding NumberExpression.asString​(String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      StringBinding NumberExpression.asString​(Locale locale, String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      StringBinding | NumberExpressionBase.asString​()
      StringBinding | NumberExpressionBase.asString​(String format)
      StringBinding | NumberExpressionBase.asString​(Locale locale, String format)
      StringBinding ObjectExpression.asString​()
      创建一个StringBinding ，将该值ObjectExpression变成String 。
      StringBinding ObjectExpression.asString​(String format)
      创建一个StringBinding持有的价值ObjectExpression变成了String 。
      StringBinding ObjectExpression.asString​(Locale locale, String format)
      创建一个StringBinding持有的价值NumberExpression变成了String 。
      StringBinding SetExpression.asString​()
      创建一个StringBinding持有的价值SetExpression变成了String 。
      static StringBinding Bindings.createStringBinding​(Callable<String> func, Observable... dependencies)
      助手功能创建一个自定义StringBinding 。
      StringBinding When.StringConditionBuilder.otherwise​(String otherwiseValue)
      定义三元表达式的常量值，如果条件为 false ，则返回该 false 。
      StringBinding When.StringConditionBuilder.otherwise​(ObservableStringValue otherwiseValue)
      定义ObservableStringValue如果条件为false则由三元表达式返回哪个值。
      static StringBinding Bindings.selectString​(Object root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static StringBinding Bindings.selectString​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static StringBinding Bindings.stringValueAt​(ObservableList<String> op, int index)
      创建一个新的StringBinding ，其中包含指定位置的ObservableList的元素。
      static StringBinding Bindings.stringValueAt​(ObservableList<String> op, ObservableIntegerValue index)
      创建一个新的StringBinding ，其中包含指定位置的ObservableList的元素。
      static StringBinding Bindings.stringValueAt​(ObservableList<String> op, ObservableNumberValue index)
      创建一个新的StringBinding ，其中包含指定位置的ObservableList的元素。
      static <K> StringBinding Bindings.stringValueAt​(ObservableMap<K,String> op, ObservableValue<? extends K> key)
      创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> StringBinding Bindings.stringValueAt​(ObservableMap<K,String> op, K key)
      创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.StringExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.StringExpression

  • Packages that use StringExpression
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，其计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of StringExpression in javafx.beans.binding

      Subclasses of StringExpression in javafx.beans.binding
      Modifier and Type Class 描述
      class  StringBinding
      基类，提供大多数的实现所需的功能Binding一个的String 。
      Methods in javafx.beans.binding that return StringExpression
      Modifier and Type 方法 描述
      static StringExpression Bindings.concat​(Object... args)
      返回一个StringExpression ，它保持多个Objects连接的值。
      StringExpression StringExpression.concat​(Object other)
      返回一个 StringExpression ，其值为 StringExpression与另一个 Object连接。
      static StringExpression Bindings.convert​(ObservableValue<?> observableValue)
      返回一个StringExpression ，其中包含一个ObservableValue 。
      static StringExpression Bindings.format​(String format, Object... args)
      创建一个StringExpression ，该值保存Objects格式，格式为String格式。
      static StringExpression Bindings.format​(Locale locale, String format, Object... args)
      创建StringExpression保持多个值Objects根据格式格式化String和指定Locale
      static StringExpression StringExpression.stringExpression​(ObservableValue<?> value)
      返回一个StringExpression ，其中包含一个ObservableValue 。

    • Uses of StringExpression in javafx.beans.property

      Subclasses of StringExpression in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyStringProperty
      超类为所有只读属性包装一个 String 。
      class  ReadOnlyStringPropertyBase
      所有只读属性的基类包装一个 String 。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleStringProperty
      这个类提供了一个包含 String值的Property的完整实现。
      class  StringProperty
      该类提供了一个包含 String值的Property的完整实现。
      class  StringPropertyBase
      StringPropertyBase类是包含一个 String值的属性的基类。

    • Uses of StringExpression in javafx.beans.property.adapter

      Subclasses of StringExpression in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanStringProperty
      一个 JavaBeanStringProperty提供类型的普通的Java Bean属性之间的适配器 String和一个JavaFX StringProperty 。
      class  ReadOnlyJavaBeanStringProperty
      A ReadOnlyJavaBeanStringProperty在 String类型的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。

    • Uses of StringExpression in javafx.css

      Subclasses of StringExpression in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of StringExpression in javafx.scene.chart

      Methods in javafx.scene.chart that return StringExpression
      Modifier and Type 方法 描述
      StringExpression Axis.TickMark.labelProperty​()
      刻度线的显示文字
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.When (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.When

  • Packages that use When
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。

    • Uses of When in javafx.beans.binding

      Methods in javafx.beans.binding that return When
      Modifier and Type 方法 描述
      static When Bindings.when​(ObservableBooleanValue condition)
      创建一个计算三元表达式结果的绑定。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.When.BooleanConditionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.When.BooleanConditionBuilder

  • Packages that use When.BooleanConditionBuilder
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。

    • Uses of When.BooleanConditionBuilder in javafx.beans.binding

      Methods in javafx.beans.binding that return When.BooleanConditionBuilder
      Modifier and Type 方法 描述
      When.BooleanConditionBuilder When.then​(boolean thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
      When.BooleanConditionBuilder When.then​(ObservableBooleanValue thenValue)
      定义ObservableBooleanValue如果条件为true则由三元表达式返回哪个值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.When.NumberConditionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.When.NumberConditionBuilder

  • Packages that use When.NumberConditionBuilder
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。

    • Uses of When.NumberConditionBuilder in javafx.beans.binding

      Methods in javafx.beans.binding that return When.NumberConditionBuilder
      Modifier and Type 方法 描述
      When.NumberConditionBuilder When.then​(double thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
      When.NumberConditionBuilder When.then​(float thenValue)
      定义三元表达式的常量值，如果条件为 true ，则返回该 true 。
      When.NumberConditionBuilder When.then​(int thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
      When.NumberConditionBuilder When.then​(long thenValue)
      定义三元表达式的常量值，如果条件为 true ，则返回该 true 。
      When.NumberConditionBuilder When.then​(ObservableNumberValue thenValue)
      定义ObservableNumberValue如果条件为true则由三元表达式返回哪个值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.When.ObjectConditionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.When.ObjectConditionBuilder

  • Packages that use When.ObjectConditionBuilder
    软件包 描述
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。

    • Uses of When.ObjectConditionBuilder in javafx.beans.binding

      Methods in javafx.beans.binding that return When.ObjectConditionBuilder
      Modifier and Type 方法 描述
      <T> When.ObjectConditionBuilder<T> When.then​(ObservableObjectValue<T> thenValue)
      定义ObservableObjectValue如果条件为true ，则三元表达式返回哪个值。
      <T> When.ObjectConditionBuilder<T> When.then​(T thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.binding.When.StringConditionBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.binding.When.StringConditionBuilder

  • Packages that use When.StringConditionBuilder
    软件包 描述
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。

    • Uses of When.StringConditionBuilder in javafx.beans.binding

      Methods in javafx.beans.binding that return When.StringConditionBuilder
      Modifier and Type 方法 描述
      When.StringConditionBuilder When.then​(String thenValue)
      定义三元表达式的常量值，如果条件为 true则返回。
      When.StringConditionBuilder When.then​(ObservableStringValue thenValue)
      定义ObservableStringValue如果条件为true则由三元表达式返回哪个值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.binding.Binding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.binding.Binding

  • Packages that use Binding
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。

    • Uses of Binding in javafx.beans.binding

      Subinterfaces of Binding in javafx.beans.binding
      Modifier and Type 接口 描述
      interface  NumberBinding
      标记界面，用于标记所有绑定数字值的绑定。
      Classes in javafx.beans.binding that implement Binding
      Modifier and Type Class 描述
      class  BooleanBinding
      提供实现boolean值Binding所需的大部分功能的基类。
      class  DoubleBinding
      提供实现27065660088857的double所需的大部分功能的基类。
      class  FloatBinding
      提供实现float的float所需的大部分功能的基类。
      class  IntegerBinding
      提供实现int的int所需的大部分功能的基类。
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      class  LongBinding
      提供实现long值Binding所需的大部分功能的基类。
      class  MapBinding<K,V>
      基类，提供大多数的实现所需的功能Binding的的ObservableMap 。
      class  ObjectBinding<T>
      提供实现27065660101239的Object所需的大部分功能的基类。
      class  SetBinding<E>
      基类，提供大多数的实现所需的功能Binding的的ObservableSet 。
      class  StringBinding
      基类，提供大多数的实现所需的功能Binding一个的String 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.binding.NumberBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.binding.NumberBinding

  • Packages that use NumberBinding
    软件包 描述
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。

    • Uses of NumberBinding in javafx.beans.binding

      Classes in javafx.beans.binding that implement NumberBinding
      Modifier and Type Class 描述
      class  DoubleBinding
      提供实现270657600046319的double所需的大部分功能的基类。
      class  FloatBinding
      提供实现float值Binding所需的大部分功能的基类。
      class  IntegerBinding
      提供实现int值Binding所需的大部分功能的基类。
      class  LongBinding
      提供实现long值Binding所需的大部分功能的基类。
      Methods in javafx.beans.binding that return NumberBinding
      Modifier and Type | 方法 | 描述
      static NumberBinding Bindings.add​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding Bindings.add​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值和一个恒定值的总和。
      static NumberBinding Bindings.add​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding Bindings.add​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding Bindings.add​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding Bindings.add​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding Bindings.add​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding计算的两个实例的值的总和ObservableNumberValue 。
      NumberBinding NumberExpression.add​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
      NumberBinding NumberExpression.add​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
      NumberBinding NumberExpression.add​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
      NumberBinding NumberExpression.add​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的总和。
      NumberBinding NumberExpression.add​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的总和。
      NumberBinding | NumberExpressionBase.add​(ObservableNumberValue other)
      static NumberBinding Bindings.divide​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算一个常数值和ObservableNumberValue的值的除法 。
      static NumberBinding Bindings.divide​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，它计算一个常数值的除法和一个ObservableNumberValue的值。
      static NumberBinding Bindings.divide​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算一个常数值的除法和一个ObservableNumberValue的值。
      static NumberBinding Bindings.divide​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值除以恒定值。
      static NumberBinding Bindings.divide​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值除数和常数值。
      static NumberBinding Bindings.divide​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的除数和一个恒定值。
      static NumberBinding Bindings.divide​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的值的除法 。
      NumberBinding NumberExpression.divide​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值。
      NumberBinding NumberExpression.divide​(float other)
      创建一个新的NumberBinding ，计算该NumberExpression和常数值。
      NumberBinding NumberExpression.divide​(int other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值。
      NumberBinding NumberExpression.divide​(long other)
      创建一个新的NumberBinding ，计算此NumberExpression和常数值。
      NumberBinding NumberExpression.divide​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的划分 。
      NumberBinding | NumberExpressionBase.divide​(ObservableNumberValue other)
      static NumberBinding Bindings.max​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding Bindings.max​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding Bindings.max​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding Bindings.max​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding Bindings.max​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding Bindings.max​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding Bindings.max​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的值的最大值 。
      static NumberBinding Bindings.min​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和恒定值。
      static NumberBinding Bindings.min​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的最小值 。
      static NumberBinding Bindings.multiply​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和恒定值的乘积 。
      static NumberBinding Bindings.multiply​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的值的乘积 。
      NumberBinding NumberExpression.multiply​(double other)
      创建一个新的NumberBinding ，计算此NumberExpression的产品和恒定值。
      NumberBinding NumberExpression.multiply​(float other)
      创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
      NumberBinding NumberExpression.multiply​(int other)
      创建一个新的NumberBinding ，计算该NumberExpression和恒定值。
      NumberBinding NumberExpression.multiply​(long other)
      创建一个新的NumberBinding ，计算该NumberExpression和一个恒定值。
      NumberBinding NumberExpression.multiply​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的产品 。
      NumberBinding | NumberExpressionBase.multiply​(ObservableNumberValue other)
      static NumberBinding Bindings.negate​(ObservableNumberValue value)
      创建一个新的NumberBinding ，计算一个ObservableNumberValue的否定。
      NumberBinding NumberExpression.negate​()
      创建一个新的NumberBinding ，计算的否定为NumberExpression 。
      NumberBinding When.NumberConditionBuilder.otherwise​(float otherwiseValue)
      定义三元表达式的常量值，如果条件为 false则返回。
      NumberBinding When.NumberConditionBuilder.otherwise​(int otherwiseValue)
      定义三元表达式的常量值，如果条件为 false则返回。
      NumberBinding When.NumberConditionBuilder.otherwise​(long otherwiseValue)
      定义三元表达式的常量值，如果条件为 false则返回。
      NumberBinding When.NumberConditionBuilder.otherwise​(ObservableNumberValue otherwiseValue)
      定义ObservableNumberValue如果条件为false ，则三元表达式返回哪个值。
      static NumberBinding Bindings.subtract​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
      static NumberBinding Bindings.subtract​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
      static NumberBinding Bindings.subtract​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
      static NumberBinding Bindings.subtract​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding Bindings.subtract​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding Bindings.subtract​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding Bindings.subtract​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算两个实例的值的差异ObservableNumberValue 。
      NumberBinding NumberExpression.subtract​(double other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
      NumberBinding NumberExpression.subtract​(float other)
      创建一个新的NumberBinding ，计算这个NumberExpression的差异和一个恒定值。
      NumberBinding NumberExpression.subtract​(int other)
      创建一个新的NumberBinding ，计算该NumberExpression和恒定值的差异。
      NumberBinding NumberExpression.subtract​(long other)
      创建一个新的NumberBinding ，计算这个NumberExpression和恒定值的差异。
      NumberBinding NumberExpression.subtract​(ObservableNumberValue other)
      Creates a new NumberBinding that calculates the difference of this NumberExpression and another ObservableNumberValue.
      NumberBinding | NumberExpressionBase.subtract​(ObservableNumberValue other)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.binding.NumberExpression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.binding.NumberExpression

  • Packages that use NumberExpression
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of NumberExpression in javafx.beans.binding

      Subinterfaces of NumberExpression in javafx.beans.binding
      Modifier and Type 接口 描述
      interface  NumberBinding
      标记界面，用于标记所有绑定数字值的绑定。
      Classes in javafx.beans.binding that implement NumberExpression
      Modifier and Type Class 描述
      class  DoubleBinding
      提供实现double的double所需的大部分功能的基类。
      class  DoubleExpression
      DoubleExpression是一个ObservableDoubleValue加上额外的方便的方式来生成流畅的风格的绑定。
      class  FloatBinding
      提供实现float的float所需的大部分功能的基类。
      class  FloatExpression
      FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。
      class  IntegerBinding
      提供实现int的int所需的大部分功能的基类。
      class  IntegerExpression
      IntegerExpression是一个ObservableIntegerValue加上另外方便的方法，以流利的方式生成绑定。
      class  LongBinding
      提供实现long值Binding所需的大部分功能的基类。
      class  LongExpression
      LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。
      class  NumberExpressionBase
      NumberExpressionBase包含以流畅样式生成绑定的方便方法，这是所有NumberExpression子类所共有的。

    • Uses of NumberExpression in javafx.beans.property

      Classes in javafx.beans.property that implement NumberExpression
      Modifier and Type Class 描述
      class  DoubleProperty
      这个类定义了一个Property包装double值。
      class  DoublePropertyBase
      类 DoublePropertyBase是包含 double值的属性的基类。
      class  FloatProperty
      这个类定义了一个Property包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  IntegerProperty
      这个类定义了一个Property包裹的int值。
      class  IntegerPropertyBase
      类 IntegerPropertyBase是包含 int值的属性的基类。
      class  LongProperty
      这个类定义了一个Property包裹一个long值。
      class  LongPropertyBase
      类 LongPropertyBase是一个包含 long值的属性的基类。
      class  ReadOnlyDoubleProperty
      超类为所有只读属性包装一个 double 。
      class  ReadOnlyDoublePropertyBase
      所有只读属性的基类包装一个 double 。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyFloatProperty
      超类为所有只读属性包装一个 float 。
      class  ReadOnlyFloatPropertyBase
      所有只读属性的基类包装一个 float 。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyIntegerProperty
      所有readonly属性的超类包装一个 int 。
      class  ReadOnlyIntegerPropertyBase
      所有只读属性的基类包装一个 int 。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyLongProperty
      所有readonly属性的超类包装一个 long 。
      class  ReadOnlyLongPropertyBase
      所有只读属性的基类包装一个 long 。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      这个类提供了一个包含 double值的Property的完整实现。
      class  SimpleFloatProperty
      这个类提供了一个Property包装一个float值的完整实现。
      class  SimpleIntegerProperty
      这个类提供了一个包含 int值的Property的完整实现。
      class  SimpleLongProperty
      这个类提供了一个270657646015079包装一个long值的完整实现。

    • Uses of NumberExpression in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement NumberExpression
      Modifier and Type Class 描述
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在类型为 double或 Double的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在类型为 float或 Float的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在类型为 int或 Integer的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在类型为 double或 Double的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在常规的只读Java Bean属性类型为 float或 Float和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在类型为 int或 Integer的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在类型为 long或 Long的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty之间提供了一个适配器。

    • Uses of NumberExpression in javafx.css

      Classes in javafx.css that implement NumberExpression
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      该课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableIntegerProperty
      该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableLongProperty
      该课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.DefaultProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.DefaultProperty

  • Packages that use DefaultProperty
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of DefaultProperty in javafx.scene

      Classes in javafx.scene with annotations of type DefaultProperty
      Modifier and Type Class 描述
      class  Group
      一个 Group节点包含一个可观察列表的子节点，每当该节点呈现时按顺序渲染。
      class  Scene
      JavaFX Scene类是场景图中所有内容的容器。

    • Uses of DefaultProperty in javafx.scene.control

      Classes in javafx.scene.control with annotations of type DefaultProperty
      Modifier and Type Class 描述
      class  ChoiceBox<T>
      ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
      class  DialogPane
      DialogPane应该被认为是在Dialog实例中显示的根节点 。
      class  Labeled
      标签的Control是与其用户界面的一部分相关联的文本内容。
      class  ListView<T>
      ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
      class  Menu
      可触发的项目的弹出菜单，仅根据请求向用户显示。
      class  MenuBar
      MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。
      class  Pagination
      分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
      class  ScrollPane
      提供其内容的滚动，剪切视口的控件。
      class  SplitPane
      具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
      class  Tab
      标签放置在TabPane中 ，其中每个标签代表单个“页面”。
      class  TableView<S>
      TableView控件旨在可视化无限数量的数据行，分为列。
      class  TabPane
      允许在一组Tabs之间切换的控件 。
      class  TextInputControl
      文本输入控件的抽象基类。
      class  TitledPane
      TitledPane是一个可以打开和关闭的标题的面板。
      class  ToolBar
      ToolBar是一个可以水平或垂直显示项目的控件。
      class  TreeTableView<S>
      TreeTableView控件旨在可视化无限数量的数据行，分为列。
      class  TreeView<T>
      TreeView控件提供了一个到根的视图（类型为TreeItem ）。

    • Uses of DefaultProperty in javafx.scene.image

      Classes in javafx.scene.image with annotations of type DefaultProperty
      Modifier and Type Class 描述
      class  ImageView
      ImageView是一个Node用于绘画图像加载Image类。

    • Uses of DefaultProperty in javafx.scene.layout

      Classes in javafx.scene.layout with annotations of type DefaultProperty
      Modifier and Type Class 描述
      class  Pane
      布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。

    • Uses of DefaultProperty in javafx.scene.text

      Classes in javafx.scene.text with annotations of type DefaultProperty
      Modifier and Type Class 描述
      class  Text
      Text类定义了一个显示文本的节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.NamedArg (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.NamedArg

  • Packages that use NamedArg
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javafx.util
    包含各种实用程序和助手类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of NamedArg in javafx.animation

      Constructor parameters in javafx.animation with annotations of type NamedArg
      Constructor 描述
      KeyFrame​(Duration time, String name, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyValue​(WritableValue<T> target, T endValue)
      创建一个 KeyValue ，使用 Interpolator.LINEAR 。
      KeyValue​(WritableValue<T> target, T endValue)
      创建一个 KeyValue使用 Interpolator.LINEAR 。
      KeyValue​(WritableValue<T> target, T endValue, Interpolator interpolator)
      创建一个 KeyValue 。
      KeyValue​(WritableValue<T> target, T endValue, Interpolator interpolator)
      创建一个 KeyValue 。
      KeyValue​(WritableValue<T> target, T endValue, Interpolator interpolator)
      创建一个 KeyValue 。

    • Uses of NamedArg in javafx.beans

      Constructor parameters in javafx.beans with annotations of type NamedArg
      Constructor 描述
      WeakInvalidationListener​(InvalidationListener listener)
      构造函数为 WeakInvalidationListener 。

    • Uses of NamedArg in javafx.beans.binding

      Constructor parameters in javafx.beans.binding with annotations of type NamedArg
      Constructor 描述
      When​(ObservableBooleanValue condition)
      构造函数为 When 。

    • Uses of NamedArg in javafx.beans.value

      Constructor parameters in javafx.beans.value with annotations of type NamedArg
      Constructor 描述
      WeakChangeListener​(ChangeListener<T> listener)
      构造函数为 WeakChangeListener 。

    • Uses of NamedArg in javafx.collections

      Constructor parameters in javafx.collections with annotations of type NamedArg
      Constructor 描述
      WeakListChangeListener​(ListChangeListener<E> listener)
      构造函数为 WeakListChangeListener 。
      WeakMapChangeListener​(MapChangeListener<K,V> listener)
      构造函数为 WeakMapChangeListener 。
      WeakSetChangeListener​(SetChangeListener<E> listener)
      构造函数为 WeakSetChangeListener 。

    • Uses of NamedArg in javafx.collections.transformation

      Constructor parameters in javafx.collections.transformation with annotations of type NamedArg
      Constructor 描述
      FilteredList​(ObservableList<E> source)
      在源列表周围构造一个新的FilteredList包装器。
      FilteredList​(ObservableList<E> source, Predicate<? super E> predicate)
      在源列表周围构造一个新的FilteredList包装器。
      FilteredList​(ObservableList<E> source, Predicate<? super E> predicate)
      在源列表周围构造一个新的FilteredList包装器。
      SortedList​(ObservableList<? extends E> source)
      在源列表周围构造一个新的无序SortedList包装器。
      SortedList​(ObservableList<? extends E> source, Comparator<? super E> comparator)
      创建一个围绕源列表的新SortedList。
      SortedList​(ObservableList<? extends E> source, Comparator<? super E> comparator)
      创建一个围绕源列表的新SortedList。

    • Uses of NamedArg in javafx.concurrent

      Constructor parameters in javafx.concurrent with annotations of type NamedArg
      Constructor 描述
      WorkerStateEvent​(Worker worker, EventType<? extends WorkerStateEvent> eventType)
      创建一个新的WorkerStateEvent。
      WorkerStateEvent​(Worker worker, EventType<? extends WorkerStateEvent> eventType)
      创建一个新的WorkerStateEvent。

    • Uses of NamedArg in javafx.css

      Constructor parameters in javafx.css with annotations of type NamedArg
      Constructor 描述
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, boolean initialValue)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, boolean initialValue)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)
      SimpleStyleableBooleanProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Double initialValue)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Double initialValue)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)
      SimpleStyleableDoubleProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Float initialValue)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Float initialValue)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)
      SimpleStyleableFloatProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Integer initialValue)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Integer initialValue)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)
      SimpleStyleableIntegerProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Long initialValue)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Long initialValue)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)
      SimpleStyleableLongProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name, T initialValue)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name, T initialValue)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name, T initialValue)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name, T initialValue)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, T initialValue)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, T initialValue)
      SimpleStyleableObjectProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData)
      SimpleStyleableStringProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name)
      SimpleStyleableStringProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name)
      SimpleStyleableStringProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name)
      SimpleStyleableStringProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)
      SimpleStyleableStringProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)
      SimpleStyleableStringProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)
      SimpleStyleableStringProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)
      SimpleStyleableStringProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, String initialValue)
      SimpleStyleableStringProperty的构造函数。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, String initialValue)
      SimpleStyleableStringProperty的构造函数。

    • Uses of NamedArg in javafx.event

      Constructor parameters in javafx.event with annotations of type NamedArg
      Constructor 描述
      Event​(Object source, EventTarget target, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。
      Event​(Object source, EventTarget target, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。
      Event​(Object source, EventTarget target, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。
      Event​(EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件类型。
      WeakEventHandler​(EventHandler<T> eventHandler)
      创建一个新的实例 WeakEventHandler 。

    • Uses of NamedArg in javafx.geometry

      Constructor parameters in javafx.geometry with annotations of type NamedArg
      Constructor 描述
      BoundingBox​(double minX, double minY, double width, double height)
      创建一个新的2D实例 BoundingBox 。
      BoundingBox​(double minX, double minY, double width, double height)
      创建一个新的2D实例 BoundingBox 。
      BoundingBox​(double minX, double minY, double width, double height)
      创建一个新的2D实例 BoundingBox 。
      BoundingBox​(double minX, double minY, double width, double height)
      创建一个新的2D实例 BoundingBox 。
      BoundingBox​(double minX, double minY, double minZ, double width, double height, double depth)
      创建一个新的3D实例 BoundingBox 。
      BoundingBox​(double minX, double minY, double minZ, double width, double height, double depth)
      创建一个新的3D实例 BoundingBox 。
      BoundingBox​(double minX, double minY, double minZ, double width, double height, double depth)
      创建一个新的3D实例 BoundingBox 。
      BoundingBox​(double minX, double minY, double minZ, double width, double height, double depth)
      创建一个新的3D实例 BoundingBox 。
      BoundingBox​(double minX, double minY, double minZ, double width, double height, double depth)
      创建一个新的3D实例 BoundingBox 。
      BoundingBox​(double minX, double minY, double minZ, double width, double height, double depth)
      创建一个新的3D实例 BoundingBox 。
      Dimension2D​(double width, double height)
      构造具有指定宽度和高度的 Dimension2D 。
      Dimension2D​(double width, double height)
      构造具有指定宽度和高度的 Dimension2D 。
      Insets​(double topRightBottomLeft)
      为所有四个偏移量构造一个新的Insets实例，具有相同的值。
      Insets​(double top, double right, double bottom, double left)
      构造一个具有四个不同偏移量的新Insets实例。
      Insets​(double top, double right, double bottom, double left)
      构造一个具有四个不同偏移量的新Insets实例。
      Insets​(double top, double right, double bottom, double left)
      构造一个具有四个不同偏移量的新Insets实例。
      Insets​(double top, double right, double bottom, double left)
      构造一个具有四个不同偏移量的新Insets实例。
      Point2D​(double x, double y)
      创建一个新的实例 Point2D 。
      Point2D​(double x, double y)
      创建一个新的实例 Point2D 。
      Point3D​(double x, double y, double z)
      创建一个新的实例 Point3D 。
      Point3D​(double x, double y, double z)
      创建一个新的实例 Point3D 。
      Point3D​(double x, double y, double z)
      创建一个新的实例 Point3D 。
      Rectangle2D​(double minX, double minY, double width, double height)
      创建一个新的实例 Rectangle2D 。
      Rectangle2D​(double minX, double minY, double width, double height)
      创建一个新的实例 Rectangle2D 。
      Rectangle2D​(double minX, double minY, double width, double height)
      创建一个新的实例 Rectangle2D 。
      Rectangle2D​(double minX, double minY, double width, double height)
      创建一个新的实例 Rectangle2D 。

    • Uses of NamedArg in javafx.print

      Constructor parameters in javafx.print with annotations of type NamedArg
      Constructor 描述
      PageRange​(int startPage, int endPage)
      使用指定的开始和结束页码创建一个新的PageRange。
      PageRange​(int startPage, int endPage)
      使用指定的开始和结束页码创建一个新的PageRange。

    • Uses of NamedArg in javafx.scene

      Constructor parameters in javafx.scene with annotations of type NamedArg
      Constructor 描述
      ImageCursor​(Image image)
      从指定的图像构造一个 ImageCursor 。
      ImageCursor​(Image image, double hotspotX, double hotspotY)
      从指定的图像和热点坐标构造一个 ImageCursor 。
      ImageCursor​(Image image, double hotspotX, double hotspotY)
      从指定的图像和热点坐标构造一个 ImageCursor 。
      ImageCursor​(Image image, double hotspotX, double hotspotY)
      从指定的图像和热点坐标构造一个 ImageCursor 。
      Scene​(Parent root)
      为特定根节点创建场景。
      Scene​(Parent root, double width, double height)
      为特定大小的特定根节点创建场景。
      Scene​(Parent root, double width, double height)
      为特定大小的特定根节点创建场景。
      Scene​(Parent root, double width, double height)
      为特定大小的特定根节点创建场景。
      Scene​(Parent root, double width, double height, boolean depthBuffer)
      构造一个由根组成的场景，宽度和高度的尺寸，并指定是否为此场景创建深度缓冲区。
      Scene​(Parent root, double width, double height, boolean depthBuffer)
      构造一个由根组成的场景，宽度和高度的尺寸，并指定是否为此场景创建深度缓冲区。
      Scene​(Parent root, double width, double height, boolean depthBuffer)
      构造一个由根组成的场景，宽度和高度的尺寸，并指定是否为此场景创建深度缓冲区。
      Scene​(Parent root, double width, double height, boolean depthBuffer)
      构造一个由根组成的场景，宽度和高度的尺寸，并指定是否为此场景创建深度缓冲区。
      Scene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      Scene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      Scene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      Scene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      Scene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      Scene​(Parent root, double width, double height, Paint fill)
      创建具有特定大小和填充的特定根节点的场景。
      Scene​(Parent root, double width, double height, Paint fill)
      创建具有特定大小和填充的特定根节点的场景。
      Scene​(Parent root, double width, double height, Paint fill)
      创建具有特定大小和填充的特定根节点的场景。
      Scene​(Parent root, double width, double height, Paint fill)
      创建具有特定大小和填充的特定根节点的场景。
      Scene​(Parent root, Paint fill)
      为具有填充的特定根节点创建场景。
      Scene​(Parent root, Paint fill)
      为具有填充的特定根节点创建场景。
      SubScene​(Parent root, double width, double height)
      为特定大小的特定根节点创建一个 SubScene 。
      SubScene​(Parent root, double width, double height)
      为特定大小的特定根节点创建一个 SubScene 。
      SubScene​(Parent root, double width, double height)
      为特定大小的特定根节点创建一个 SubScene 。
      SubScene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造一个由根组成的 SubScene ，其宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      SubScene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造一个由根组成的 SubScene ，具有宽度和高度的尺寸，指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      SubScene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造一个 SubScene其中包括宽度和高度的根，指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      SubScene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造一个由根组成的 SubScene ，具有宽度和高度的维度，指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      SubScene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造一个 SubScene由根的，具有宽度和高度的尺寸，指定是否为这个场景中创建一个深度缓冲器，并指定抗锯齿是否被请求。

    • Uses of NamedArg in javafx.scene.chart

      Constructor parameters in javafx.scene.chart with annotations of type NamedArg
      Constructor 描述
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定轴构建新的区域图
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定轴构建新的区域图
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定的轴构建一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定的轴构建一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      用给定的轴和数据构造一个新的BarChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴构建一个新的BubbleChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴构建一个新的BubbleChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的BubbleChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的BubbleChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的BubbleChart。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定的轴构造一个新的LineChart。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定的轴构造一个新的LineChart。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的LineChart。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的LineChart。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的LineChart。
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴和数据构造新的ScatterChart。
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴和数据构造新的ScatterChart。
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造新的ScatterChart。
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造新的ScatterChart。
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造新的ScatterChart。
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定轴构建新的区域图
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定轴构建新的区域图
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图。
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图。
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴构建一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴构建一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      使用给定的轴和数据构造一个新的StackedBarChart。

    • Uses of NamedArg in javafx.scene.control

      Constructor parameters in javafx.scene.control with annotations of type NamedArg
      Constructor 描述
      Alert​(Alert.AlertType alertType)
      使用给定的AlertType创建警报（请参阅Alert.AlertType文档，了解哪一个是最合适的）。
      Alert​(Alert.AlertType alertType, String contentText, ButtonType... buttons)
      使用给定的contentText，ButtonTypes和AlertType创建警报（参考Alert.AlertType文档，了解哪一个是最合适的）。
      Alert​(Alert.AlertType alertType, String contentText, ButtonType... buttons)
      使用给定的contentText，ButtonTypes和AlertType创建警报（请参阅Alert.AlertType文档以了解哪一个是最合适的）。
      Alert​(Alert.AlertType alertType, String contentText, ButtonType... buttons)
      使用给定的contentText，ButtonTypes和AlertType创建警报（参考Alert.AlertType文档了解哪一个是最合适的）。
      ButtonType​(String text)
      使用给定的文本创建一个ButtonType实例，并将ButtonData设置为 ButtonBar.ButtonData.OTHER 。
      ButtonType​(String text, ButtonBar.ButtonData buttonData)
      创建一个带有给定文本的ButtonType实例，并按指定的方式设置ButtonData。
      ButtonType​(String text, ButtonBar.ButtonData buttonData)
      创建一个带有给定文本的ButtonType实例，并按指定的方式设置ButtonData。
      DialogEvent​(Dialog<?> source, EventType<? extends Event> eventType)
      使用指定的事件源，目标和类型构造新的 Event 。
      DialogEvent​(Dialog<?> source, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。
      DoubleSpinnerValueFactory​(double min, double max)
      构造一个新的DoubleSpinnerValueFactory，将初始值设置为等于最小值，默认值为 amountToStepBy 。
      DoubleSpinnerValueFactory​(double min, double max)
      构造一个新的DoubleSpinnerValueFactory，将初始值设置为等于最小值，默认值为 amountToStepBy 。
      DoubleSpinnerValueFactory​(double min, double max, double initialValue)
      构造一个新的DoubleSpinnerValueFactory，其默认值为 amountToStepBy 。
      DoubleSpinnerValueFactory​(double min, double max, double initialValue)
      构造一个新的DoubleSpinnerValueFactory，默认值为 amountToStepBy 。
      DoubleSpinnerValueFactory​(double min, double max, double initialValue)
      构造一个新的DoubleSpinnerValueFactory，默认值为 amountToStepBy 。
      DoubleSpinnerValueFactory​(double min, double max, double initialValue, double amountToStepBy)
      构造一个新的DoubleSpinnerValueFactory。
      DoubleSpinnerValueFactory​(double min, double max, double initialValue, double amountToStepBy)
      构造一个新的DoubleSpinnerValueFactory。
      DoubleSpinnerValueFactory​(double min, double max, double initialValue, double amountToStepBy)
      构造一个新的DoubleSpinnerValueFactory。
      DoubleSpinnerValueFactory​(double min, double max, double initialValue, double amountToStepBy)
      构造一个新的DoubleSpinnerValueFactory。
      IndexRange​(int start, int end)
      创建一个IndexRange的实例，表示 start和 end之间的范围。
      IndexRange​(int start, int end)
      创建一个IndexRange的实例，表示 start和 end之间的范围。
      IndexRange​(IndexRange range)
      通过复制给定的IndexRange对象的值来创建IndexRange的实例。
      IntegerSpinnerValueFactory​(int min, int max)
      构造一个新的IntegerSpinnerValueFactory，将初始值设置为等于最小值，默认值为 amountToStepBy 。
      IntegerSpinnerValueFactory​(int min, int max)
      构造一个新的IntegerSpinnerValueFactory，将初始值设置为等于最小值，默认值为 amountToStepBy 。
      IntegerSpinnerValueFactory​(int min, int max, int initialValue)
      构造一个新的IntegerSpinnerValueFactory，默认值为 amountToStepBy 。
      IntegerSpinnerValueFactory​(int min, int max, int initialValue)
      构造一个新的IntegerSpinnerValueFactory，默认值为 amountToStepBy 。
      IntegerSpinnerValueFactory​(int min, int max, int initialValue)
      构造一个新的IntegerSpinnerValueFactory，默认值为 amountToStepBy 。
      IntegerSpinnerValueFactory​(int min, int max, int initialValue, int amountToStepBy)
      构造一个新的IntegerSpinnerValueFactory。
      IntegerSpinnerValueFactory​(int min, int max, int initialValue, int amountToStepBy)
      构造一个新的IntegerSpinnerValueFactory。
      IntegerSpinnerValueFactory​(int min, int max, int initialValue, int amountToStepBy)
      构造一个新的IntegerSpinnerValueFactory。
      IntegerSpinnerValueFactory​(int min, int max, int initialValue, int amountToStepBy)
      构造一个新的IntegerSpinnerValueFactory。
      ListSpinnerValueFactory​(ObservableList<T> items)
      创建一个ListSpinnerValueFactory的新实例，其中给定的列表用作列表以逐步完成。
      ResizeFeaturesBase​(TableColumnBase<S,?> column, Double delta)
      创建此类的实例，其中提供的TableColumnBase和delta值被设置并存储在此不可变实例中。
      ResizeFeaturesBase​(TableColumnBase<S,?> column, Double delta)
      创建此类的实例，其中提供的TableColumnBase和delta值被设置并存储在此不可变实例中。
      ScrollToEvent​(Object source, EventTarget target, EventType<ScrollToEvent<T>> type, T scrollTarget)
      构造一个新的 Event与指定的事件源，目标和类型。
      ScrollToEvent​(Object source, EventTarget target, EventType<ScrollToEvent<T>> type, T scrollTarget)
      构造一个新的 Event与指定的事件源，目标和类型。
      ScrollToEvent​(Object source, EventTarget target, EventType<ScrollToEvent<T>> type, T scrollTarget)
      构造一个新的 Event与指定的事件源，目标和类型。
      ScrollToEvent​(Object source, EventTarget target, EventType<ScrollToEvent<T>> type, T scrollTarget)
      构造一个新的 Event与指定的事件源，目标和类型。
      SortEvent​(C source, EventTarget target)
      SortEvent​(C source, EventTarget target)
      Spinner​(double min, double max, double initialValue)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。
      Spinner​(double min, double max, double initialValue)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。
      Spinner​(double min, double max, double initialValue)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。
      Spinner​(double min, double max, double initialValue, double amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。
      Spinner​(double min, double max, double initialValue, double amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。
      Spinner​(double min, double max, double initialValue, double amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。
      Spinner​(double min, double max, double initialValue, double amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。
      Spinner​(int min, int max, int initialValue)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。
      Spinner​(int min, int max, int initialValue)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。
      Spinner​(int min, int max, int initialValue)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。
      Spinner​(int min, int max, int initialValue, int amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。
      Spinner​(int min, int max, int initialValue, int amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。
      Spinner​(int min, int max, int initialValue, int amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。
      Spinner​(int min, int max, int initialValue, int amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。
      Spinner​(ObservableList<T> items)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.ListSpinnerValueFactory 。
      Spinner​(SpinnerValueFactory<T> valueFactory)
      使用给定值出厂设置创建一个Spinner实例。
      TablePosition​(TableView<S> tableView, int row, TableColumn<S,T> tableColumn)
      构造一个TablePosition实例来表示给定TableView实例中给定的行/列位置。
      TablePosition​(TableView<S> tableView, int row, TableColumn<S,T> tableColumn)
      构造一个TablePosition实例来表示给定TableView实例中给定的行/列位置。
      TablePosition​(TableView<S> tableView, int row, TableColumn<S,T> tableColumn)
      构造一个TablePosition实例来表示给定TableView实例中给定的行/列位置。
      TextFormatter​(UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器创建一个新的Formatter。
      TextFormatter​(StringConverter<V> valueConverter)
      使用提供的值转换器创建一个新的格式化器。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue)
      使用提供的值转换器和默认值创建一个新的格式化器。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue)
      使用提供的值转换器和默认值创建一个新的格式化器。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue, UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器，值转换器和默认值创建一个新的格式化器。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue, UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器，值转换器和默认值创建一个新的格式化器。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue, UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器，值转换器和默认值创建一个新的格式化器。
      TextInputDialog​(String defaultValue)
      创建一个新的TextInputDialog，其中默认值输入到对话框TextField中 。
      TreeTablePosition​(TreeTableView<S> treeTableView, int row, TreeTableColumn<S,T> tableColumn)
      构造一个TreeTablePosition实例来表示给定TreeTableView实例中给定的行/列位置。
      TreeTablePosition​(TreeTableView<S> treeTableView, int row, TreeTableColumn<S,T> tableColumn)
      构造一个TreeTablePosition实例来表示给定TreeTableView实例中给定的行/列位置。
      TreeTablePosition​(TreeTableView<S> treeTableView, int row, TreeTableColumn<S,T> tableColumn)
      构造一个TreeTablePosition实例来表示给定TreeTableView实例中给定的行/列位置。

    • Uses of NamedArg in javafx.scene.control.cell

      Constructor parameters in javafx.scene.control.cell with annotations of type NamedArg
      Constructor 描述
      MapValueFactory​(Object key)
      创建默认的MapValueFactory，它将使用提供的键来查找安装此MapValueFactory的TableColumn中的单元格值（通过cell value factory属性）。
      PropertyValueFactory​(String property)
      创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。
      TreeItemPropertyValueFactory​(String property)
      创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。

    • Uses of NamedArg in javafx.scene.image

      Constructor parameters in javafx.scene.image with annotations of type NamedArg
      Constructor 描述
      Image​(InputStream is)
      构造一个 Image并从指定的输入流中加载内容。
      Image​(InputStream is, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造新的 Image 。
      Image​(InputStream is, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造一个新的 Image 。
      Image​(InputStream is, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造新的 Image 。
      Image​(InputStream is, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造新的 Image 。
      Image​(InputStream is, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造新的 Image 。
      Image​(String url)
      构造一个 Image ，内容从指定的URL载入。
      Image​(String url, boolean backgroundLoading)
      使用指定的参数构造新的 Image 。
      Image​(String url, boolean backgroundLoading)
      使用指定的参数构建新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造一个新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth, boolean backgroundLoading)
      使用指定的参数构造新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth, boolean backgroundLoading)
      使用指定的参数构造一个新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth, boolean backgroundLoading)
      使用指定的参数构造一个新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth, boolean backgroundLoading)
      使用指定的参数构造新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth, boolean backgroundLoading)
      使用指定的参数构造新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth, boolean backgroundLoading)
      使用指定的参数构建新的 Image 。
      WritableImage​(int width, int height)
      构造指定尺寸的空图像。
      WritableImage​(int width, int height)
      构造指定尺寸的空图像。
      WritableImage​(PixelReader reader, int width, int height)
      构建指定尺寸的图像，从指定的PixelReader初始化。
      WritableImage​(PixelReader reader, int width, int height)
      构造指定尺寸的图像，从指定的PixelReader初始化。
      WritableImage​(PixelReader reader, int width, int height)
      构造指定尺寸的图像，从指定的PixelReader初始化。
      WritableImage​(PixelReader reader, int x, int y, int width, int height)
      构造指定尺寸的图像，从PixelReader的指定区域初始化。
      WritableImage​(PixelReader reader, int x, int y, int width, int height)
      构建指定尺寸的图像，从PixelReader的指定区域初始化。
      WritableImage​(PixelReader reader, int x, int y, int width, int height)
      构造指定尺寸的图像，从PixelReader的指定区域初始化。
      WritableImage​(PixelReader reader, int x, int y, int width, int height)
      构造指定尺寸的图像，从PixelReader的指定区域初始化。
      WritableImage​(PixelReader reader, int x, int y, int width, int height)
      构造指定尺寸的图像，从PixelReader的指定区域初始化。

    • Uses of NamedArg in javafx.scene.input

      Constructor parameters in javafx.scene.input with annotations of type NamedArg
      Constructor 描述
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
      DataFormat​(String... ids)
      创建一个新的DataFormat，指定与此数据格式相关联的ids集。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      InputEvent​(Object source, EventTarget target, EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
      InputEvent​(Object source, EventTarget target, EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
      InputEvent​(Object source, EventTarget target, EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
      InputEvent​(EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造具有空源和目标的新的InputMethodEvent事件。
      InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造具有空源和目标的新的InputMethodEvent事件。
      InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造具有空源和目标的新的InputMethodEvent事件。
      InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造具有空源和目标的新的InputMethodEvent事件。
      InputMethodTextRun​(String text, InputMethodHighlight highlight)
      构造输入法的单个文本运行。
      InputMethodTextRun​(String text, InputMethodHighlight highlight)
      构造输入法的单个文本运行。
      KeyCharacterCombination​(String character, KeyCombination.Modifier... modifiers)
      为指定的主键字符和指定的修饰符列表构造一个 KeyCharacterCombination 。
      KeyCharacterCombination​(String character, KeyCombination.Modifier... modifiers)
      为指定的主键字符和指定的修饰符列表构造一个 KeyCharacterCombination 。
      KeyCharacterCombination​(String character, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键字符构造一个 KeyCharacterCombination ，并显式指定所有修改键。
      KeyCharacterCombination​(String character, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键字符构建一个 KeyCharacterCombination ，并显式指定所有修改键。
      KeyCharacterCombination​(String character, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键字符构建一个 KeyCharacterCombination ，并对所有修改键进行明确指定。
      KeyCharacterCombination​(String character, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键字符构建一个 KeyCharacterCombination ，并显式指定所有修改键。
      KeyCharacterCombination​(String character, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键字符构造一个 KeyCharacterCombination ，并显式指定所有修改键。
      KeyCharacterCombination​(String character, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键字符构建一个 KeyCharacterCombination ，并显式指定所有修改键。
      KeyCodeCombination​(KeyCode code, KeyCombination.Modifier... modifiers)
      为指定的主键和指定的修饰符列表构造一个 KeyCodeCombination 。
      KeyCodeCombination​(KeyCode code, KeyCombination.Modifier... modifiers)
      为指定的主键和指定的修饰符列表构造一个 KeyCodeCombination 。
      KeyCodeCombination​(KeyCode code, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。
      KeyCodeCombination​(KeyCode code, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。
      KeyCodeCombination​(KeyCode code, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。
      KeyCodeCombination​(KeyCode code, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。
      KeyCodeCombination​(KeyCode code, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。
      KeyCodeCombination​(KeyCode code, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      根据指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件，其中一个源为 null 。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
      Mnemonic​(Node node, KeyCombination keyCombination)
      构造一个Mnemonic与指定的目标Node和触发器KeyCombination 。
      Mnemonic​(Node node, KeyCombination keyCombination)
      构造一个Mnemonic与指定的目标Node和触发器KeyCombination 。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      PickResult​(EventTarget target, double sceneX, double sceneY)
      为不需要额外信息的2D情况创建选择结果。
      PickResult​(EventTarget target, double sceneX, double sceneY)
      为不需要额外信息的2D情况创建选择结果。
      PickResult​(EventTarget target, double sceneX, double sceneY)
      为不需要额外信息的2D情况创建选择结果。
      PickResult​(Node node, Point3D point, double distance)
      为非3d形状的目标创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance)
      为非3d形状的目标创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance)
      为非3d形状的目标创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。

    • Uses of NamedArg in javafx.scene.layout

      Constructor parameters in javafx.scene.layout with annotations of type NamedArg
      Constructor 描述
      Background​(List<BackgroundFill> fills, List<BackgroundImage> images)
      创建一个新的背景提供两个列表，一个用于背景填充，一个用于背景图像。
      Background​(List<BackgroundFill> fills, List<BackgroundImage> images)
      创建一个新的背景提供两个列表，一个用于背景填充，一个用于背景图像。
      Background​(BackgroundFill... fills)
      通过提供一个BackgroundFill数组创建一个新的背景。
      Background​(BackgroundFill[] fills, BackgroundImage[] images)
      通过提供两个阵列创建一个新的背景，一个用于背景填充，另一个用于背景图像。
      Background​(BackgroundFill[] fills, BackgroundImage[] images)
      通过提供两个阵列创建一个新的背景，一个用于背景填充，另一个用于背景图像。
      Background​(BackgroundImage... images)
      通过提供一个BackgroundImages数组创建一个新的背景。
      BackgroundFill​(Paint fill, CornerRadii radii, Insets insets)
      使用指定的填充，半径和插入创建一个新的BackgroundFill。
      BackgroundFill​(Paint fill, CornerRadii radii, Insets insets)
      使用指定的填充，半径和插入创建一个新的BackgroundFill。
      BackgroundFill​(Paint fill, CornerRadii radii, Insets insets)
      使用指定的填充，半径和插入创建一个新的BackgroundFill。
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。
      BackgroundPosition​(Side horizontalSide, double horizontalPosition, boolean horizontalAsPercentage, Side verticalSide, double verticalPosition, boolean verticalAsPercentage)
      创建一个新的BackgroundPosition。
      BackgroundPosition​(Side horizontalSide, double horizontalPosition, boolean horizontalAsPercentage, Side verticalSide, double verticalPosition, boolean verticalAsPercentage)
      创建一个新的BackgroundPosition。
      BackgroundPosition​(Side horizontalSide, double horizontalPosition, boolean horizontalAsPercentage, Side verticalSide, double verticalPosition, boolean verticalAsPercentage)
      创建一个新的BackgroundPosition。
      BackgroundPosition​(Side horizontalSide, double horizontalPosition, boolean horizontalAsPercentage, Side verticalSide, double verticalPosition, boolean verticalAsPercentage)
      创建一个新的BackgroundPosition。
      BackgroundPosition​(Side horizontalSide, double horizontalPosition, boolean horizontalAsPercentage, Side verticalSide, double verticalPosition, boolean verticalAsPercentage)
      创建一个新的BackgroundPosition。
      BackgroundPosition​(Side horizontalSide, double horizontalPosition, boolean horizontalAsPercentage, Side verticalSide, double verticalPosition, boolean verticalAsPercentage)
      创建一个新的BackgroundPosition。
      BackgroundSize​(double width, double height, boolean widthAsPercentage, boolean heightAsPercentage, boolean contain, boolean cover)
      创建一个新的BackgroundSize。
      BackgroundSize​(double width, double height, boolean widthAsPercentage, boolean heightAsPercentage, boolean contain, boolean cover)
      创建一个新的BackgroundSize。
      BackgroundSize​(double width, double height, boolean widthAsPercentage, boolean heightAsPercentage, boolean contain, boolean cover)
      创建一个新的BackgroundSize。
      BackgroundSize​(double width, double height, boolean widthAsPercentage, boolean heightAsPercentage, boolean contain, boolean cover)
      创建一个新的BackgroundSize。
      BackgroundSize​(double width, double height, boolean widthAsPercentage, boolean heightAsPercentage, boolean contain, boolean cover)
      创建一个新的BackgroundSize。
      BackgroundSize​(double width, double height, boolean widthAsPercentage, boolean heightAsPercentage, boolean contain, boolean cover)
      创建一个新的BackgroundSize。
      Border​(List<BorderStroke> strokes, List<BorderImage> images)
      通过提供BorderStrokes和BorderImages列表创建一个新的边框。
      Border​(List<BorderStroke> strokes, List<BorderImage> images)
      通过提供BorderStrokes和BorderImages列表创建一个新的边框。
      Border​(BorderImage... images)
      通过提供一个BorderImages数组创建一个新的边框。
      Border​(BorderStroke... strokes)
      通过提供一个BorderStrokes数组创建一个新的边框。
      Border​(BorderStroke[] strokes, BorderImage[] images)
      通过提供一系列BorderStrokes和BorderImages创建一个新的边框。
      Border​(BorderStroke[] strokes, BorderImage[] images)
      通过提供一系列BorderStrokes和BorderImages创建一个新的边框。
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。
      BorderWidths​(double width)
      使用所有四个边框的给定宽度创建一个新的BorderWidth，并将此宽度视为文字值，而不是百分比。
      BorderWidths​(double top, double right, double bottom, double left)
      创建一个新的BorderWidths，具有指定的顶部，右侧，底部和左侧的宽度。
      BorderWidths​(double top, double right, double bottom, double left)
      创建一个新的BorderWidths，具有指定的顶部，右侧，底部和左侧的宽度。
      BorderWidths​(double top, double right, double bottom, double left)
      创建一个新的BorderWidths，具有指定的顶部，右侧，底部和左侧的宽度。
      BorderWidths​(double top, double right, double bottom, double left)
      创建一个新的BorderWidths，具有指定的顶部，右侧，底部和左侧的宽度。
      BorderWidths​(double top, double right, double bottom, double left, boolean topAsPercentage, boolean rightAsPercentage, boolean bottomAsPercentage, boolean leftAsPercentage)
      创建一个新的BorderWidths。
      BorderWidths​(double top, double right, double bottom, double left, boolean topAsPercentage, boolean rightAsPercentage, boolean bottomAsPercentage, boolean leftAsPercentage)
      创建一个新的BorderWidths。
      BorderWidths​(double top, double right, double bottom, double left, boolean topAsPercentage, boolean rightAsPercentage, boolean bottomAsPercentage, boolean leftAsPercentage)
      创建一个新的BorderWidths。
      BorderWidths​(double top, double right, double bottom, double left, boolean topAsPercentage, boolean rightAsPercentage, boolean bottomAsPercentage, boolean leftAsPercentage)
      创建一个新的BorderWidths。
      BorderWidths​(double top, double right, double bottom, double left, boolean topAsPercentage, boolean rightAsPercentage, boolean bottomAsPercentage, boolean leftAsPercentage)
      创建一个新的BorderWidths。
      BorderWidths​(double top, double right, double bottom, double left, boolean topAsPercentage, boolean rightAsPercentage, boolean bottomAsPercentage, boolean leftAsPercentage)
      创建一个新的BorderWidths。
      BorderWidths​(double top, double right, double bottom, double left, boolean topAsPercentage, boolean rightAsPercentage, boolean bottomAsPercentage, boolean leftAsPercentage)
      创建一个新的BorderWidths。
      BorderWidths​(double top, double right, double bottom, double left, boolean topAsPercentage, boolean rightAsPercentage, boolean bottomAsPercentage, boolean leftAsPercentage)
      创建一个新的BorderWidths。
      CornerRadii​(double radius)
      为所有角落的所有组件创建一个具有单个均匀半径值的新CornerRadii。
      CornerRadii​(double radius, boolean asPercent)
      为每个角创建一个具有给定半径的新CornerRadii。
      CornerRadii​(double radius, boolean asPercent)
      为每个角创建一个具有给定半径的新CornerRadii。
      CornerRadii​(double topLeft, double topRight, double bottomRight, double bottomLeft, boolean asPercent)
      为每个角落创建一个均匀而独立的半径的新CornerRadii。
      CornerRadii​(double topLeft, double topRight, double bottomRight, double bottomLeft, boolean asPercent)
      为每个角落创建一个均匀而独立的半径的新CornerRadii。
      CornerRadii​(double topLeft, double topRight, double bottomRight, double bottomLeft, boolean asPercent)
      为每个角落创建一个均匀而独立的半径的新CornerRadii。
      CornerRadii​(double topLeft, double topRight, double bottomRight, double bottomLeft, boolean asPercent)
      为每个角落创建一个均匀而独立的半径的新CornerRadii。
      CornerRadii​(double topLeft, double topRight, double bottomRight, double bottomLeft, boolean asPercent)
      为每个角落创建一个均匀而独立的半径的新CornerRadii。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。

    • Uses of NamedArg in javafx.scene.media

      Constructor parameters in javafx.scene.media with annotations of type NamedArg
      Constructor 描述
      AudioClip​(String source)
      从提供的源URL创建一个 AudioClip 。
      Media​(String source)
      构造一个 Media实例。
      MediaPlayer​(Media media)
      为特定媒体创建播放器。

    • Uses of NamedArg in javafx.scene.paint

      Constructor parameters in javafx.scene.paint with annotations of type NamedArg
      Constructor 描述
      Color​(double red, double green, double blue, double opacity)
      创建一个新的颜色实例
      Color​(double red, double green, double blue, double opacity)
      创建一个新的颜色实例
      Color​(double red, double green, double blue, double opacity)
      创建一个新的颜色实例
      Color​(double red, double green, double blue, double opacity)
      创建一个新的颜色实例
      ImagePattern​(Image image)
      从指定的图像创建一个新的ImagePattern实例。
      ImagePattern​(Image image, double x, double y, double width, double height, boolean proportional)
      创建一个新的ImagePattern实例。
      ImagePattern​(Image image, double x, double y, double width, double height, boolean proportional)
      创建一个新的ImagePattern实例。
      ImagePattern​(Image image, double x, double y, double width, double height, boolean proportional)
      创建一个新的ImagePattern实例。
      ImagePattern​(Image image, double x, double y, double width, double height, boolean proportional)
      创建一个新的ImagePattern实例。
      ImagePattern​(Image image, double x, double y, double width, double height, boolean proportional)
      创建一个新的ImagePattern实例。
      ImagePattern​(Image image, double x, double y, double width, double height, boolean proportional)
      创建一个新的ImagePattern实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
      Stop​(double offset, Color color)
      创建一个新的Stop实例。
      Stop​(double offset, Color color)
      创建一个新的Stop实例。

    • Uses of NamedArg in javafx.scene.text

      Constructor parameters in javafx.scene.text with annotations of type NamedArg
      Constructor 描述
      Font​(double size)
      使用默认面“System”构造一个字体。
      Font​(String name, double size)
      使用指定的正面名称和大小构造字体
      Font​(String name, double size)
      使用指定的正面名称和大小构造字体

    • Uses of NamedArg in javafx.scene.transform

      Constructor parameters in javafx.scene.transform with annotations of type NamedArg
      Constructor 描述
      NonInvertibleTransformException​(String message)
      使用指定的详细消息创建一个新的 NonInvertibleTransformException实例。

    • Uses of NamedArg in javafx.scene.web

      Constructor parameters in javafx.scene.web with annotations of type NamedArg
      Constructor 描述
      PopupFeatures​(boolean menu, boolean status, boolean toolbar, boolean resizable)
      创建一个新的实例。
      PopupFeatures​(boolean menu, boolean status, boolean toolbar, boolean resizable)
      创建一个新的实例。
      PopupFeatures​(boolean menu, boolean status, boolean toolbar, boolean resizable)
      创建一个新的实例。
      PopupFeatures​(boolean menu, boolean status, boolean toolbar, boolean resizable)
      创建一个新的实例。
      PromptData​(String message, String defaultValue)
      创建一个新的实例。
      PromptData​(String message, String defaultValue)
      创建一个新的实例。
      WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)
      创建一个新的 WebErrorEvent 。
      WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)
      创建一个新的 WebErrorEvent 。
      WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)
      创建一个新的 WebErrorEvent 。
      WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)
      创建一个新的 WebErrorEvent 。
      WebEvent​(Object source, EventType<WebEvent> type, T data)
      创建一个新的事件对象。
      WebEvent​(Object source, EventType<WebEvent> type, T data)
      创建一个新的事件对象。
      WebEvent​(Object source, EventType<WebEvent> type, T data)
      创建一个新的事件对象。

    • Uses of NamedArg in javafx.stage

      Constructor parameters in javafx.stage with annotations of type NamedArg
      Constructor 描述
      Stage​(StageStyle style)
      创建一个新的实例 Stage 。
      WindowEvent​(Window source, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。
      WindowEvent​(Window source, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。

    • Uses of NamedArg in javafx.util

      Constructor parameters in javafx.util with annotations of type NamedArg
      Constructor 描述
      Duration​(double millis)
      创建一个新的持续时间，具有潜在的分数毫秒分辨率。
      Pair​(K key, V value)
      创建一个新的对
      Pair​(K key, V value)
      创建一个新的对

    • Uses of NamedArg in javafx.util.converter

      Constructor parameters in javafx.util.converter with annotations of type NamedArg
      Constructor 描述
      FormatStringConverter​(Format format)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.WeakInvalidationListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.WeakInvalidationListener

No usage of javafx.beans.WeakInvalidationListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.InvalidationListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.InvalidationListener

  • Packages that use InvalidationListener
    软件包 描述
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of InvalidationListener in javafx.beans

      Classes in javafx.beans that implement InvalidationListener
      Modifier and Type Class 描述
      class  WeakInvalidationListener
      A WeakInvalidationListener可以使用，如果一个Observable应该只保留对监听器的弱引用。
      Methods in javafx.beans with parameters of type InvalidationListener
      Modifier and Type 方法 描述
      void Observable.addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变为无效时，它将被通知。
      void Observable.removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      Constructors in javafx.beans with parameters of type InvalidationListener
      Constructor 描述
      WeakInvalidationListener​(InvalidationListener listener)
      构造函数 WeakInvalidationListener 。

    • Uses of InvalidationListener in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type InvalidationListener
      Modifier and Type | 方法 | 描述
      void | BooleanBinding.addListener​(InvalidationListener listener)
      void | DoubleBinding.addListener​(InvalidationListener listener)
      void | FloatBinding.addListener​(InvalidationListener listener)
      void | IntegerBinding.addListener​(InvalidationListener listener)
      void | ListBinding.addListener​(InvalidationListener listener)
      void | LongBinding.addListener​(InvalidationListener listener)
      void | MapBinding.addListener​(InvalidationListener listener)
      void | ObjectBinding.addListener​(InvalidationListener listener)
      void | SetBinding.addListener​(InvalidationListener listener)
      void | StringBinding.addListener​(InvalidationListener listener)
      void | BooleanBinding.removeListener​(InvalidationListener listener)
      void | DoubleBinding.removeListener​(InvalidationListener listener)
      void | FloatBinding.removeListener​(InvalidationListener listener)
      void | IntegerBinding.removeListener​(InvalidationListener listener)
      void | ListBinding.removeListener​(InvalidationListener listener)
      void | LongBinding.removeListener​(InvalidationListener listener)
      void | MapBinding.removeListener​(InvalidationListener listener)
      void | ObjectBinding.removeListener​(InvalidationListener listener)
      void | SetBinding.removeListener​(InvalidationListener listener)
      void | StringBinding.removeListener​(InvalidationListener listener)

    • Uses of InvalidationListener in javafx.beans.property

      Methods in javafx.beans.property with parameters of type InvalidationListener
      Modifier and Type | 方法 | 描述
      void | BooleanPropertyBase.addListener​(InvalidationListener listener)
      void | DoublePropertyBase.addListener​(InvalidationListener listener)
      void | FloatPropertyBase.addListener​(InvalidationListener listener)
      void | IntegerPropertyBase.addListener​(InvalidationListener listener)
      void | ListPropertyBase.addListener​(InvalidationListener listener)
      void | LongPropertyBase.addListener​(InvalidationListener listener)
      void | MapPropertyBase.addListener​(InvalidationListener listener)
      void | ObjectPropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlyBooleanPropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlyDoublePropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlyFloatPropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlyIntegerPropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlyListPropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlyLongPropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlyMapPropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlyObjectPropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlySetPropertyBase.addListener​(InvalidationListener listener)
      void | ReadOnlyStringPropertyBase.addListener​(InvalidationListener listener)
      void | SetPropertyBase.addListener​(InvalidationListener listener)
      void | StringPropertyBase.addListener​(InvalidationListener listener)
      void | BooleanPropertyBase.removeListener​(InvalidationListener listener)
      void | DoublePropertyBase.removeListener​(InvalidationListener listener)
      void | FloatPropertyBase.removeListener​(InvalidationListener listener)
      void | IntegerPropertyBase.removeListener​(InvalidationListener listener)
      void | ListPropertyBase.removeListener​(InvalidationListener listener)
      void | LongPropertyBase.removeListener​(InvalidationListener listener)
      void | MapPropertyBase.removeListener​(InvalidationListener listener)
      void | ObjectPropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlyBooleanPropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlyDoublePropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlyFloatPropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlyIntegerPropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlyListPropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlyLongPropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlyMapPropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlyObjectPropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlySetPropertyBase.removeListener​(InvalidationListener listener)
      void | ReadOnlyStringPropertyBase.removeListener​(InvalidationListener listener)
      void | SetPropertyBase.removeListener​(InvalidationListener listener)
      void | StringPropertyBase.removeListener​(InvalidationListener listener)

    • Uses of InvalidationListener in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter with parameters of type InvalidationListener
      Modifier and Type 方法 描述
      void JavaBeanBooleanProperty.addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void JavaBeanDoubleProperty.addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void JavaBeanFloatProperty.addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void JavaBeanIntegerProperty.addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void JavaBeanLongProperty.addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void JavaBeanObjectProperty.addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void JavaBeanStringProperty.addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void JavaBeanBooleanProperty.removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void JavaBeanDoubleProperty.removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void JavaBeanFloatProperty.removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void JavaBeanIntegerProperty.removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void JavaBeanLongProperty.removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void JavaBeanObjectProperty.removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void JavaBeanStringProperty.removeListener​(InvalidationListener listener)
      从侦听器列表中删除给定的侦听器，每当 Observable的值变为无效时通知 Observable 。

    • Uses of InvalidationListener in javafx.beans.value

      Methods in javafx.beans.value with parameters of type InvalidationListener
      Modifier and Type 方法 描述
      void ObservableValueBase.addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void ObservableValueBase.removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。

    • Uses of InvalidationListener in javafx.collections

      Methods in javafx.collections with parameters of type InvalidationListener
      Modifier and Type | 方法 | 描述
      void | ObservableArrayBase.addListener​(InvalidationListener listener)
      void | ObservableListBase.addListener​(InvalidationListener listener)
      void | ObservableArrayBase.removeListener​(InvalidationListener listener)
      void | ObservableListBase.removeListener​(InvalidationListener listener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.Observable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.Observable

  • Packages that use Observable
    软件包 描述
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.beans.binding
    提供在Binding上创建和操作的类，其计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of Observable in javafx.beans

      Methods in javafx.beans with parameters of type Observable
      Modifier and Type 方法 描述
      void InvalidationListener.invalidated​(Observable observable)
      该方法需要由 InvalidationListener的实现来提供。
      void WeakInvalidationListener.invalidated​(Observable observable)
      该方法需要通过 InvalidationListener的实现来提供。

    • Uses of Observable in javafx.beans.binding

      Subinterfaces of Observable in javafx.beans.binding
      Modifier and Type 接口 描述
      interface  Binding<T>
      A Binding计算取决于一个或多个来源的值。
      interface  NumberBinding
      标记界面，用于标记所有绑定数字值的绑定。
      interface  NumberExpression
      NumberExpression是一个ObservableNumberValue，另外还有一个便利的方法来生成流畅的绑定。
      Classes in javafx.beans.binding that implement Observable
      Modifier and Type Class 描述
      class  BooleanBinding
      提供实现boolean值Binding所需的大部分功能的基类。
      class  BooleanExpression
      BooleanExpression是一个ObservableBooleanValue加上额外的便利方法，以流利的风格生成绑定。
      class  DoubleBinding
      提供实现double值Binding所需的大部分功能的基类。
      class  DoubleExpression
      DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
      class  FloatBinding
      基类提供实现float值的Binding所需的大部分功能。
      class  FloatExpression
      FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。
      class  IntegerBinding
      提供实现int的int所需的大部分功能的基类。
      class  IntegerExpression
      IntegerExpression是一个ObservableIntegerValue，另外还有一个方便的方法来生成流畅的绑定。
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      class  ListExpression<E>
      ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。
      class  LongBinding
      提供实现long值Binding所需的大部分功能的基类。
      class  LongExpression
      LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。
      class  MapBinding<K,V>
      提供实现ObservableMap的Binding所需的大部分功能的基类。
      class  MapExpression<K,V>
      MapExpression是一个ObservableMapValue加上额外的便利方法，以流利的风格生成绑定。
      class  NumberExpressionBase
      NumberExpressionBase包含方便的方法来生成流畅样式的绑定，这是所有NumberExpression子类所共有的。
      class  ObjectBinding<T>
      提供实现Object的Object所需的大部分功能的基类。
      class  ObjectExpression<T>
      ObjectExpression是一个ObservableObjectValue加上额外的便利方法，以流利的风格生成绑定。
      class  SetBinding<E>
      提供实现ObservableSet的Binding所需的大部分功能的基类。
      class  SetExpression<E>
      SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的风格生成绑定。
      class  StringBinding
      提供实现String的String所需的大部分功能的基类。
      class  StringExpression
      StringExpression是一个ObservableStringValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding with parameters of type Observable
      Modifier and Type 方法 描述
      protected void BooleanBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected void DoubleBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected void FloatBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected void IntegerBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected void ListBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected void LongBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected void MapBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected void ObjectBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected void SetBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      protected void StringBinding.bind​(Observable... dependencies)
      开始观察更改的依赖关系。
      static BooleanBinding Bindings.createBooleanBinding​(Callable<Boolean> func, Observable... dependencies)
      助手功能创建一个自定义的BooleanBinding 。
      static DoubleBinding Bindings.createDoubleBinding​(Callable<Double> func, Observable... dependencies)
      助手功能创建一个自定义的DoubleBinding 。
      static FloatBinding Bindings.createFloatBinding​(Callable<Float> func, Observable... dependencies)
      助手功能创建自定义FloatBinding 。
      static IntegerBinding Bindings.createIntegerBinding​(Callable<Integer> func, Observable... dependencies)
      助手功能创建一个自定义的IntegerBinding 。
      static LongBinding Bindings.createLongBinding​(Callable<Long> func, Observable... dependencies)
      助手功能创建自定义LongBinding 。
      static <T> ObjectBinding<T> Bindings.createObjectBinding​(Callable<T> func, Observable... dependencies)
      助手功能创建自定义ObjectBinding 。
      static StringBinding Bindings.createStringBinding​(Callable<String> func, Observable... dependencies)
      助手功能创建自定义StringBinding 。
      protected void BooleanBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。
      protected void DoubleBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。
      protected void FloatBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。
      protected void IntegerBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。
      protected void ListBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。
      protected void LongBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。
      protected void MapBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。
      protected void ObjectBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。
      protected void SetBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。
      protected void StringBinding.unbind​(Observable... dependencies)
      停止观察更改的依赖关系。

    • Uses of Observable in javafx.beans.property

      Subinterfaces of Observable in javafx.beans.property
      Modifier and Type 接口 描述
      interface  Property<T>
      通用接口，定义所有（可写）属性共有的方法，与其类型无关。
      interface  ReadOnlyProperty<T>
      通用接口，用于定义独立于其类型的所有可读属性通用的方法。
      Classes in javafx.beans.property that implement Observable
      Modifier and Type Class 描述
      class  BooleanProperty
      这个类提供了一个包含 boolean值的Property的全面实现。
      class  BooleanPropertyBase
      BooleanPropertyBase类是包含 boolean值的属性的基类。
      class  DoubleProperty
      这个类定义了一个Property包装double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  FloatProperty
      这个类定义了一个Property包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  IntegerProperty
      这个类定义了一个包含 int值的int 。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  ListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  LongProperty
      这个类定义了一个Property包装long值。
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  MapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装ObservableMap的属性的基类。
      class  ObjectProperty<T>
      这个类提供了一个Property的全面实现，包装一个任意的Object 。
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyBooleanProperty
      所有readonly属性的超类包装一个 boolean 。
      class  ReadOnlyBooleanPropertyBase
      所有只读属性的基类包装一个 boolean 。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyDoubleProperty
      超类为所有只读属性包装一个 double 。
      class  ReadOnlyDoublePropertyBase
      所有只读属性的基类包装一个 double 。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyFloatProperty
      超类为所有只读属性包装一个 float 。
      class  ReadOnlyFloatPropertyBase
      所有只读属性的基类包装一个 float 。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyIntegerProperty
      超类为所有只读属性包装一个 int 。
      class  ReadOnlyIntegerPropertyBase
      所有只读属性的基类包装一个 int 。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyListProperty<E>
      所有readonly属性的超类包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyLongProperty
      超类为所有只读属性包装一个 long 。
      class  ReadOnlyLongPropertyBase
      所有只读属性的基类包装一个 long 。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyMapProperty<K,V>
      超类为所有只读属性包装一个ObservableMap 。
      class  ReadOnlyMapPropertyBase<K,V>
      所有只读属性的基类包装一个ObservableMap 。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyObjectProperty<T>
      超类为所有只读属性包装任意 Object 。
      class  ReadOnlyObjectPropertyBase<T>
      所有只读属性的基类包装任意 Object 。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlySetProperty<E>
      超类为所有只读属性包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyStringProperty
      超类为所有只读属性包装一个 String 。
      class  ReadOnlyStringPropertyBase
      所有只读属性的基类包装一个 String 。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleBooleanProperty
      该类提供了一个包含 boolean值的Property的全面实现。
      class  SimpleDoubleProperty
      这个类提供了一个包含 double值的Property的全面实现。
      class  SimpleFloatProperty
      该类提供了一个包含 float值的Property的完整实现。
      class  SimpleIntegerProperty
      这个类提供了一个包含 int值的Property的全面实现。
      class  SimpleListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  SimpleLongProperty
      这个类提供了一个包含 long值的Property的全面实现。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
      class  SimpleObjectProperty<T>
      该类提供了一个Property的全面实现，包装任意的Object 。
      class  SimpleSetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
      class  SimpleStringProperty
      这个类提供了一个包含 String值的Property的完整实现。
      class  StringProperty
      这个类提供了一个包含 String值的Property的全面实现。
      class  StringPropertyBase
      StringPropertyBase类是包含 String值的属性的基类。

    • Uses of Observable in javafx.beans.property.adapter

      Subinterfaces of Observable in javafx.beans.property.adapter
      Modifier and Type 接口 描述
      interface  JavaBeanProperty<T>
      JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
      interface  ReadOnlyJavaBeanProperty<T>
      JavaBeanProperty是只读Java Bean属性和JavaFX属性之间的所有适配器的超级界面。
      Classes in javafx.beans.property.adapter that implement Observable
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在 long或 Long之间的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty在 T类型的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
      class  JavaBeanStringProperty
      一个 JavaBeanStringProperty提供类型的普通的Java Bean属性之间的适配器 String和一个JavaFX StringProperty 。
      class  ReadOnlyJavaBeanBooleanProperty
      A ReadOnlyJavaBeanBooleanProperty在类型为 boolean或 Boolean的常规只读Java Bean属性和JavaFX ReadOnlyBooleanProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在 double或 Double之间的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty提供了一个适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在 float或 Float之间的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在 int或 Integer之间的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty提供了一个适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在 long或 Long的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanObjectProperty<T>
      A ReadOnlyJavaBeanObjectProperty在常规的只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanStringProperty
      A ReadOnlyJavaBeanStringProperty在 String类型的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。

    • Uses of Observable in javafx.beans.value

      Subinterfaces of Observable in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableBooleanValue
      一个可观察的布尔值。
      interface  ObservableDoubleValue
      一个可观察到的双重值。
      interface  ObservableFloatValue
      一个可观察的浮点值。
      interface  ObservableIntegerValue
      一个可观察的整数值。
      interface  ObservableListValue<E>
      一个可观察的参考ObservableList 。
      interface  ObservableLongValue
      一个可观察的长期价值。
      interface  ObservableMapValue<K,V>
      一个可观察的参考ObservableMap 。
      interface  ObservableNumberValue
      ObservableValue的所有子接口的通用接口包装一个数字。
      interface  ObservableObjectValue<T>
      一个可观察的类型的 Object值。
      interface  ObservableSetValue<E>
      一个可观察的参考ObservableSet 。
      interface  ObservableStringValue
      一个可观察的字符串值。
      interface  ObservableValue<T>
      一个 ObservableValue是一个包含值并允许观察变化值的实体。
      interface  WritableListValue<E>
      可写参考一个ObservableList 。
      interface  WritableMapValue<K,V>
      一个可写的参考ObservableMap 。
      interface  WritableSetValue<E>
      可写参考一个ObservableSet 。
      Classes in javafx.beans.value that implement Observable
      Modifier and Type Class 描述
      class  ObservableValueBase<T>
      用于创建ObservableValue的实现的便利类。

    • Uses of Observable in javafx.collections

      Subinterfaces of Observable in javafx.collections
      Modifier and Type 接口 描述
      interface  ObservableArray<T extends ObservableArray<T>>
      ObservableArray是一个数组，允许监听器在发生变化时跟踪它们。
      interface  ObservableFloatArray
      ObservableFloatArray是一个 float[]数组，允许监听器在发生变化时跟踪它们。
      interface  ObservableIntegerArray
      ObservableIntegerArray是一个 int[]数组，允许侦听器在发生变化时跟踪它们。
      interface  ObservableList<E>
      允许侦听器发生变化的列表。
      interface  ObservableMap<K,V>
      一个允许观察者跟踪发生变化的地图。
      interface  ObservableSet<E>
      一组允许观察者跟踪变化发生时的变化。
      Classes in javafx.collections that implement Observable
      Modifier and Type Class 描述
      class  ModifiableObservableListBase<E>
      抽象类作为可修改的ObservableList实现的基类。
      class  ObservableArrayBase<T extends ObservableArray<T>>
      抽象类，用作ObservableArray实现的基类。
      class  ObservableListBase<E>
      抽象类，用作ObservableList实现的基类。

    • Uses of Observable in javafx.collections.transformation

      Classes in javafx.collections.transformation that implement Observable
      Modifier and Type Class 描述
      class  FilteredList<E>
      包装一个ObservableList并使用提供的谓词过滤其内容。
      class  SortedList<E>
      包装一个ObservableList并对其内容进行排序。
      class  TransformationList<E,F>
      所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。

    • Uses of Observable in javafx.css

      Classes in javafx.css that implement Observable
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      该课程扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      这个课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableIntegerProperty
      这个类扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableLongProperty
      该课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableObjectProperty<T>
      这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of Observable in javafx.scene.control

      Subinterfaces of Observable in javafx.scene.control
      Modifier and Type 接口 描述
      protected static interface  TextInputControl.Content
      界面表示文本输入的内容。

    • Uses of Observable in javafx.scene.shape

      Subinterfaces of Observable in javafx.scene.shape
      Modifier and Type 接口 描述
      interface  ObservableFaceArray
      ObservableFaceArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.WeakListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.WeakListener

  • Packages that use WeakListener
    软件包 描述
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of WeakListener in javafx.beans

      Classes in javafx.beans that implement WeakListener
      Modifier and Type Class 描述
      class  WeakInvalidationListener
      A WeakInvalidationListener可以使用，如果一个Observable应该只保留对监听器的弱引用。

    • Uses of WeakListener in javafx.beans.value

      Classes in javafx.beans.value that implement WeakListener
      Modifier and Type Class 描述
      class  WeakChangeListener<T>
      A WeakChangeListener可以使用，如果一个ObservableValue应该只保留对监听器的弱引用。

    • Uses of WeakListener in javafx.collections

      Classes in javafx.collections that implement WeakListener
      Modifier and Type Class 描述
      class  WeakListChangeListener<E>
      A WeakListChangeListener可以使用，如果一个ObservableList应该只保留一个弱的参考侦听器。
      class  WeakMapChangeListener<K,V>
      A WeakMapChangeListener可以使用，如果一个ObservableMap应该只保留一个对监听器的弱引用。
      class  WeakSetChangeListener<E>
      A WeakSetChangeListener可以使用，如果一个ObservableSet应该只保留一个对监听器的弱引用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


BooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class BooleanProperty

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
        • javafx.beans.property.BooleanProperty
  • All Implemented Interfaces:
    Observable ， Property<Boolean> ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean> ， WritableBooleanValue ， WritableValue<Boolean>
    已知直接子类：
    BooleanPropertyBase ， JavaBeanBooleanProperty

    public abstract class BooleanProperty
extends ReadOnlyBooleanProperty
implements Property<Boolean>, WritableBooleanValue
    此类提供了一个包含 boolean值的Property的完整实现。

    a的值BooleanProperty可以获取和设置ObservableBooleanValue.get() ， BooleanExpression.getValue() ， WritableBooleanValue.set(boolean) ，并setValue(Boolean) 。

    可以使用Property.bind(ObservableValue)和Property.unbind()绑定和绑定一个属性。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建双向绑定。

    BooleanProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。

    注意：将此属性设置或绑定为空值将将属性设置为“false”。 见setValue(java.lang.Boolean) 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableBooleanValue ， WritableBooleanValue ， ReadOnlyBooleanProperty ， Property

    • 构造方法摘要

      构造方法
      Constructor 描述
      BooleanProperty​()
      唯一的构造函数

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Boolean> asObject​()
      创建一个ObjectProperty ，其值为BooleanProperty 。
      void bindBidirectional​(Property<Boolean> other)
      在这个 Property之间创建一个双向绑定。
      static BooleanProperty booleanProperty​(Property<Boolean> property)
      返回一个BooleanProperty ，其中包含一个Property 。
      void setValue​(Boolean v)
      设置包装的值。
      String toString​()
      返回此 BooleanProperty对象的字符串表示形式。
      void unbindBidirectional​(Property<Boolean> other)
      删除此 Property和另一个之间的双向绑定。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableBooleanValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanProperty

        readOnlyBooleanProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableBooleanValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • BooleanProperty

        public BooleanProperty​()
        唯一的构造函数

    • 方法详细信息

      • setValue

        public void setValue​(Boolean v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableBooleanValue
        Specified by:
        setValue在接口 WritableValue<Boolean>
        参数
        v - 新的价值

      • bindBidirectional

        public void bindBidirectional​(Property<Boolean> other)
        在这个Property之间创建一个双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<Boolean>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Property<Boolean> other)
        删除此Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional在接口 Property<Boolean>
        参数
        other - 其他 Property

      • toString

        public String toString​()
        返回此 BooleanProperty对象的字符串表示形式。
        重写：
        toString在 ReadOnlyBooleanProperty
        结果
        这个 BooleanProperty对象的字符串表示形式。

      • booleanProperty

        public static BooleanProperty booleanProperty​(Property<Boolean> property)
        返回一个BooleanProperty ，其中包含一个Property 。 如果Property已经是BooleanProperty ，它将被返回。 否则，将创建一个新的BooleanProperty ，绑定到Property 。 注意：source属性中的null值将被解释为“false”
        参数
        property - 来源 Property
        结果
        A BooleanProperty ，如果需要，则包装 Property
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0

      • asObject

        public ObjectProperty<Boolean> asObject​()
        创建一个ObjectProperty ，其值为BooleanProperty 。 如果这个值BooleanProperty的变化，价值ObjectProperty将自动更新。
        重写：
        asObject在 ReadOnlyBooleanProperty
        结果
        新的 ObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BooleanPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class BooleanPropertyBase

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
        • javafx.beans.property.BooleanProperty
          • javafx.beans.property.BooleanPropertyBase
  • All Implemented Interfaces:
    Observable ， Property<Boolean> ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean> ， WritableBooleanValue ， WritableValue<Boolean>
    已知直接子类：
    SimpleBooleanProperty ， StyleableBooleanProperty

    public abstract class BooleanPropertyBase
extends BooleanProperty
    BooleanPropertyBase类是包含boolean值的属性的基类。 它提供除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    BooleanProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      BooleanPropertyBase​()
      BooleanPropertyBase的构造 BooleanPropertyBase 。
      BooleanPropertyBase​(boolean initialValue)
      的构造器的 BooleanPropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ChangeListener<? super Boolean> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void bind​(ObservableValue<? extends Boolean> rawObservable)
      为此创建一个单向绑定 Property 。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      boolean get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的侦听器，每当 Observable的值变为无效时通知它。
      void removeListener​(ChangeListener<? super Boolean> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(boolean newValue)
      设置包装的值。
      String toString​()
      返回此 BooleanPropertyBase对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class javafx.beans.property.BooleanProperty

        asObject, bindBidirectional, booleanProperty, setValue, unbindBidirectional

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanProperty

        readOnlyBooleanProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • BooleanPropertyBase

        public BooleanPropertyBase​()
        BooleanPropertyBase的构造 BooleanPropertyBase 。

      • BooleanPropertyBase

        public BooleanPropertyBase​(boolean initialValue)
        的构造函数为 BooleanPropertyBase 。
        参数
        initialValue - 包装值的初始值

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的实例来避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Boolean> listener)
        说明从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Boolean> listener)
        说明从界面ObservableValue复制
        从监听器列表中删除给定的监听器，每当ObservableValue的值发生变化时通知该ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果绑定变为无效，则通过调用set(boolean)或绑定属性来手动调用该值时调用此方法。

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public boolean get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始布尔值。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        public void set​(boolean newValue)
        设置包装的值。 与WritableBooleanValue.setValue(java.lang.Boolean)不同，此方法使用原始布尔。
        参数
        newValue - 新值

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property是绑定的，则 false否则
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends Boolean> rawObservable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。 注意：

        参数
        rawObservable - 可观察到这个 Property应该绑定。

      • unbind

        public void unbind​()
        删除此Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 BooleanPropertyBase对象的字符串表示形式。
        重写：
        toString在 BooleanProperty
        结果
        这是 BooleanPropertyBase对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class DoubleProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
          • javafx.beans.property.DoubleProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableDoubleValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    DoublePropertyBase ， JavaBeanDoubleProperty

    public abstract class DoubleProperty
extends ReadOnlyDoubleProperty
implements Property<Number>, WritableDoubleValue
    这个类定义一个Property包裹一个double值。

    a的值DoubleProperty可以获取和设置ObservableDoubleValue.get() ， DoubleExpression.getValue() ， WritableDoubleValue.set(double) ，并setValue(Number) 。

    一个属性可以绑定和单向绑定， Property.bind(ObservableValue)和Property.unbind() 。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建和删除双向绑定。

    一个DoubleProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。

    注意：将此属性设置或绑定为空值将将属性设置为“0.0”。 见setValue(java.lang.Number) 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableDoubleValue ， WritableDoubleValue ， ReadOnlyDoubleProperty ， Property

    • 构造方法摘要

      构造方法
      Constructor 描述
      DoubleProperty​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Double> asObject​()
      创建一个ObjectProperty双向绑定到这个DoubleProperty 。
      void bindBidirectional​(Property<Number> other)
      在这个 Property和另一个之间创建双向绑定。
      static DoubleProperty doubleProperty​(Property<Double> property)
      返回一个DoubleProperty ，它包装一个Property并双向绑定到它。
      void setValue​(Number v)
      设置包装的值。
      String toString​()
      返回此 DoubleProperty对象的字符串表示形式。
      void unbindBidirectional​(Property<Number> other)
      删除这个 Property和另一个之间的双向绑定。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableDoubleValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from class javafx.beans.property.ReadOnlyDoubleProperty

        readOnlyDoubleProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableDoubleValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • DoubleProperty

        public DoubleProperty​()

    • 方法详细信息

      • setValue

        public void setValue​(Number v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableDoubleValue
        Specified by:
        setValue在接口 WritableValue<Number>
        参数
        v - 新值

      • bindBidirectional

        public void bindBidirectional​(Property<Number> other)
        在这个Property之间创建一个双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<Number>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Property<Number> other)
        删除此Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional在接口 Property<Number>
        参数
        other - 其他 Property

      • toString

        public String toString​()
        返回此 DoubleProperty对象的字符串表示形式。
        重写：
        toString在 ReadOnlyDoubleProperty
        结果
        这个 DoubleProperty对象的字符串表示形式。

      • doubleProperty

        public static DoubleProperty doubleProperty​(Property<Double> property)
        返回一个DoubleProperty ，其中包含一个Property并双向绑定到它。 更改此属性将导致原始属性更改。

        当双向绑定ObjectProperty <Double>和DoubleProperty时，这是非常有用的。

           DoubleProperty doubleProperty = new SimpleDoubleProperty(1.0);
   ObjectProperty<Double> objectProperty = new SimpleObjectProperty<>(2.0);

   // Need to keep the reference as bidirectional binding uses weak references
   DoubleProperty objectAsDouble = DoubleProperty.doubleProperty(objectProperty);

   doubleProperty.bindBidirectional(objectAsDouble);
        另一种方法是使用asObject()方法将DoubleProperty转换为ObjectProperty。

        注意：source属性中的null值将被解释为0.0

        参数
        property - 来源 Property
        结果
        A DoubleProperty包裹了 Property
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        asObject()

      • asObject

        public ObjectProperty<Double> asObject​()
        创建一个ObjectProperty双向绑定到这个DoubleProperty 。 如果这个值DoubleProperty的变化，价值ObjectProperty将自动更新，反之亦然。

        可用于将ObjectProperty绑定到DoubleProperty。

           DoubleProperty doubleProperty = new SimpleDoubleProperty(1.0);
   ObjectProperty<Double> objectProperty = new SimpleObjectProperty<>(2.0);

   objectProperty.bind(doubleProperty.asObject());
        重写：
        asObject在 ReadOnlyDoubleProperty
        结果
        新的 ObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoublePropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class DoublePropertyBase

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
          • javafx.beans.property.DoubleProperty
            • javafx.beans.property.DoublePropertyBase
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableDoubleValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    SimpleDoubleProperty ， StyleableDoubleProperty

    public abstract class DoublePropertyBase
extends DoubleProperty
    DoublePropertyBase类是包含double值的属性的基类。 它提供除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    DoubleProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      DoublePropertyBase​()
      DoublePropertyBase的构造 DoublePropertyBase 。
      DoublePropertyBase​(double initialValue)
      DoublePropertyBase的构造 DoublePropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void bind​(ObservableValue<? extends Number> rawObservable)
      为此 Property创建一个单向绑定。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      double get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从侦听器列表中删除给定的侦听器，当 ObservableValue的值更改时通知 ObservableValue 。
      void set​(double newValue)
      设置包装的值。
      String toString​()
      返回此 DoublePropertyBase对象的字符串表示形式。
      void unbind​()
      删除这个 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.DoubleProperty

        asObject, bindBidirectional, doubleProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyDoubleProperty

        readOnlyDoubleProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • DoublePropertyBase

        public DoublePropertyBase​()
        DoublePropertyBase的构造 DoublePropertyBase 。

      • DoublePropertyBase

        public DoublePropertyBase​(double initialValue)
        DoublePropertyBase的构造 DoublePropertyBase 。
        参数
        initialValue - 包装值的初始值

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakInvalidationListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储了一个强烈的对监听器的引用，这将阻止监听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果绑定变为无效，则通过调用set(double)或绑定属性来手动更改值时调用此方法。

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public double get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始double。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        public void set​(double newValue)
        设置包装的值。 与WritableDoubleValue.setValue(java.lang.Number)不同，此方法使用原始双。
        参数
        newValue - 新的价值

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property是绑定的， false否则
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends Number> rawObservable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        rawObservable - 可观察这个 Property应该绑定。

      • unbind

        public void unbind​()
        删除此Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 DoublePropertyBase对象的字符串表示形式。
        重写：
        toString在 DoubleProperty
        结果
        这个 DoublePropertyBase对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class FloatProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
          • javafx.beans.property.FloatProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableFloatValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    FloatPropertyBase ， JavaBeanFloatProperty

    public abstract class FloatProperty
extends ReadOnlyFloatProperty
implements Property<Number>, WritableFloatValue
    这个类定义了一个Property包装float值。

    a的值FloatProperty可以获取和设置ObservableFloatValue.get() ， FloatExpression.getValue() ， WritableFloatValue.set(float) ，并setValue(Number) 。

    一个属性可以绑定和绑定单向与Property.bind(ObservableValue)和Property.unbind() 。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建和删除双向绑定。

    FloatProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。

    注意：将此属性设置或绑定为空值将将属性设置为“0.0”。 见setValue(java.lang.Number) 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableFloatValue ， WritableFloatValue ， ReadOnlyFloatProperty ， Property

    • 构造方法摘要

      构造方法
      Constructor 描述
      FloatProperty​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Float> asObject​()
      创建一个ObjectProperty双向绑定到这个FloatProperty 。
      void bindBidirectional​(Property<Number> other)
      在这个 Property之间创建一个双向绑定。
      static FloatProperty floatProperty​(Property<Float> property)
      返回一个FloatProperty ，它包裹一个Property并双向绑定到它。
      void setValue​(Number v)
      设置包装的值。
      String toString​()
      返回此 FloatProperty对象的字符串表示形式。
      void unbindBidirectional​(Property<Number> other)
      删除此 Property和另一个之间的双向绑定。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableFloatValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatProperty

        readOnlyFloatProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableFloatValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • FloatProperty

        public FloatProperty​()

    • 方法详细信息

      • setValue

        public void setValue​(Number v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableFloatValue
        Specified by:
        setValue在接口 WritableValue<Number>
        参数
        v - 新值

      • bindBidirectional

        public void bindBidirectional​(Property<Number> other)
        在这个Property和另一个之间创建双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<Number>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Property<Number> other)
        删除此Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional接口 Property<Number>
        参数
        other - 其他 Property

      • toString

        public String toString​()
        返回此 FloatProperty对象的字符串表示形式。
        重写：
        toString在 ReadOnlyFloatProperty
        结果
        这个 FloatProperty对象的字符串表示形式。

      • floatProperty

        public static FloatProperty floatProperty​(Property<Float> property)
        返回一个FloatProperty ，其中包含一个Property并双向绑定到它。 更改此属性将导致原始属性更改。

        当双向绑定ObjectProperty <Float>和FloatProperty时，这是非常有用的。

           FloatProperty floatProperty = new SimpleFloatProperty(1.0f);
   ObjectProperty<Float> objectProperty = new SimpleObjectProperty<>(2.0f);

   // Need to keep the reference as bidirectional binding uses weak references
   FloatProperty objectAsFloat = FloatProperty.floatProperty(objectProperty);

   floatProperty.bindBidirectional(objectAsFloat);
        另一种方法是使用asObject()方法将FloatProperty转换为ObjectProperty。

        注意：source属性中的null值将被解释为0f

        参数
        property - 来源 Property
        结果
        A FloatProperty包装 Property
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        asObject()

      • asObject

        public ObjectProperty<Float> asObject​()
        创建一个ObjectProperty双向绑定到这个FloatProperty 。 如果这个值FloatProperty的变化，价值ObjectProperty将自动更新，反之亦然。

        可用于将ObjectProperty绑定到FloatProperty。

           FloatProperty floatProperty = new SimpleFloatProperty(1.0f);
   ObjectProperty<Float> objectProperty = new SimpleObjectProperty<>(2.0f);

   objectProperty.bind(floatProperty.asObject());
        重写：
        asObject在 ReadOnlyFloatProperty
        结果
        新的 ObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FloatPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class FloatPropertyBase

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
          • javafx.beans.property.FloatProperty
            • javafx.beans.property.FloatPropertyBase
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableFloatValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    SimpleFloatProperty ， StyleableFloatProperty

    public abstract class FloatPropertyBase
extends FloatProperty
    类FloatPropertyBase是包含float值的属性的基类。 它提供除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    FloatProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      FloatPropertyBase​()
      FloatPropertyBase的构造 FloatPropertyBase 。
      FloatPropertyBase​(float initialValue)
      FloatPropertyBase的构造 FloatPropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      float get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(float newValue)
      设置包装的值。
      String toString​()
      返回此 FloatPropertyBase对象的字符串表示形式。
      void unbind​()
      删除这个 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.FloatProperty

        asObject, bindBidirectional, floatProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatProperty

        readOnlyFloatProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • FloatPropertyBase

        public FloatPropertyBase​()
        FloatPropertyBase的构造 FloatPropertyBase 。

      • FloatPropertyBase

        public FloatPropertyBase​(float initialValue)
        FloatPropertyBase的构造 FloatPropertyBase 。
        参数
        initialValue - 包装值的初始值

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的侦听器，每当Observable的值变为无效时通知它。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        说明从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，每当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果绑定变为无效，则通过调用set(float)或绑定属性来手动更改该值时调用此方法。

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public float get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始浮点数。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        public void set​(float newValue)
        设置包装的值。 与WritableFloatValue.setValue(java.lang.Number)不同，此方法使用原始浮点数。
        参数
        newValue - 新的价值

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果是 Property绑定，否则 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends Number> rawObservable)
        为此Property创建一个单向绑定。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        rawObservable - 可观察这 Property应该绑定。

      • unbind

        public void unbind​()
        删除这个Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 FloatPropertyBase对象的字符串表示形式。
        重写：
        toString在 FloatProperty
        结果
        这个 FloatPropertyBase对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class IntegerProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
          • javafx.beans.property.IntegerProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableIntegerValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    IntegerPropertyBase ， JavaBeanIntegerProperty

    public abstract class IntegerProperty
extends ReadOnlyIntegerProperty
implements Property<Number>, WritableIntegerValue
    此类定义了一个包含 int值的int 。

    一个值IntegerProperty可以获取和设置ObservableIntegerValue.get() ， IntegerExpression.getValue() ， WritableIntegerValue.set(int) ，并setValue(Number) 。

    一个属性可以绑定和绑定单向， Property.bind(ObservableValue)和Property.unbind() 。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建和删除双向绑定。

    IntegerProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。

    注意：将此属性设置或绑定为空值将将属性设置为“0.0”。 见setValue(java.lang.Number) 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableIntegerValue ， WritableIntegerValue ， ReadOnlyIntegerProperty ， Property

    • 构造方法摘要

      构造方法
      Constructor 描述
      IntegerProperty​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Integer> asObject​()
      创建一个ObjectProperty双向绑定到这个IntegerProperty 。
      void bindBidirectional​(Property<Number> other)
      在这个 Property和另一个之间创建双向绑定。
      static IntegerProperty integerProperty​(Property<Integer> property)
      返回一个IntegerProperty ，其中包含一个Property并双向绑定到它。
      void setValue​(Number v)
      设置包装的值。
      String toString​()
      返回此 IntegerProperty对象的字符串表示形式。
      void unbindBidirectional​(Property<Number> other)
      删除此 Property和另一个之间的双向绑定。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableIntegerValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerProperty

        readOnlyIntegerProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableIntegerValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • IntegerProperty

        public IntegerProperty​()

    • 方法详细信息

      • setValue

        public void setValue​(Number v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableIntegerValue
        Specified by:
        setValue在接口 WritableValue<Number>
        参数
        v - 新值

      • bindBidirectional

        public void bindBidirectional​(Property<Number> other)
        在这个Property和另一个之间创建双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<Number>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Property<Number> other)
        删除此Property之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional在接口 Property<Number>
        参数
        other - 其他 Property

      • toString

        public String toString​()
        返回此 IntegerProperty对象的字符串表示形式。
        重写：
        toString在 ReadOnlyIntegerProperty
        结果
        这个 IntegerProperty对象的字符串表示形式。

      • integerProperty

        public static IntegerProperty integerProperty​(Property<Integer> property)
        返回一个IntegerProperty ，其中包含一个Property并双向绑定到它。 更改此属性将导致原始属性更改。

        当双向绑定ObjectProperty <Integer>和IntegerProperty时，这是非常有用的。

           IntegerProperty integerProperty = new SimpleIntegerProperty(1);
   ObjectProperty<Integer> objectProperty = new SimpleObjectProperty<>(2);

   // Need to keep the reference as bidirectional binding uses weak references
   IntegerProperty objectAsInteger = IntegerProperty.integerProperty(objectProperty);

   integerProperty.bindBidirectional(objectAsInteger);
        另一种方法是使用asObject()方法将IntegerProperty转换为ObjectProperty。

        注意：source属性中的null值将被解释为0

        参数
        property - 来源 Property
        结果
        A IntegerProperty包裹了 Property
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        asObject()

      • asObject

        public ObjectProperty<Integer> asObject​()
        创建一个ObjectProperty双向绑定到这个IntegerProperty 。 如果这个值IntegerProperty的变化，价值ObjectProperty将自动更新，反之亦然。

        可以将ObjectProperty绑定到IntegerProperty。

           IntegerProperty integerProperty = new SimpleIntegerProperty(1);
   ObjectProperty<Integer> objectProperty = new SimpleObjectProperty<>(2);

   objectProperty.bind(integerProperty.asObject());
        重写：
        asObject在 ReadOnlyIntegerProperty
        结果
        新的 ObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntegerPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class IntegerPropertyBase

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
          • javafx.beans.property.IntegerProperty
            • javafx.beans.property.IntegerPropertyBase
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableIntegerValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    SimpleIntegerProperty ， StyleableIntegerProperty

    public abstract class IntegerPropertyBase
extends IntegerProperty
    IntegerPropertyBase类是包含int值的属性的基类。 它提供除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    IntegerProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      IntegerPropertyBase​()
      IntegerPropertyBase的构造 IntegerPropertyBase 。
      IntegerPropertyBase​(int initialValue)
      IntegerPropertyBase的构造 IntegerPropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      int get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(int newValue)
      设置包装的值。
      String toString​()
      返回此 IntegerPropertyBase对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.IntegerProperty

        asObject, bindBidirectional, integerProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerProperty

        readOnlyIntegerProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • IntegerPropertyBase

        public IntegerPropertyBase​()
        IntegerPropertyBase的构造 IntegerPropertyBase 。

      • IntegerPropertyBase

        public IntegerPropertyBase​(int initialValue)
        IntegerPropertyBase的构造 IntegerPropertyBase 。
        参数
        initialValue - 包装值的初始值

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        说明从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果绑定变为无效，则通过调用set(int)或绑定属性来手动更改该值时调用此方法。

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public int get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始int。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        public void set​(int newValue)
        设置包装的值。 与WritableIntegerValue.setValue(java.lang.Number)不同，此方法使用原语int。
        参数
        newValue - 新值

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property是绑定的， false否则
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends Number> rawObservable)
        为此Property创建一个单向绑定。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        rawObservable - 可观察到这个 Property应该绑定。

      • unbind

        public void unbind​()
        删除这个Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 IntegerPropertyBase对象的字符串表示形式。
        重写：
        toString在 IntegerProperty
        结果
        这个 IntegerPropertyBase对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.beans.property (Java SE 9 & JDK 9 )

javafx.beans.property

Interfaces

  • Property
  • ReadOnlyProperty

Classes

  • BooleanProperty
  • BooleanPropertyBase
  • DoubleProperty
  • DoublePropertyBase
  • FloatProperty
  • FloatPropertyBase
  • IntegerProperty
  • IntegerPropertyBase
  • ListProperty
  • ListPropertyBase
  • LongProperty
  • LongPropertyBase
  • MapProperty
  • MapPropertyBase
  • ObjectProperty
  • ObjectPropertyBase
  • ReadOnlyBooleanProperty
  • ReadOnlyBooleanPropertyBase
  • ReadOnlyBooleanWrapper
  • ReadOnlyDoubleProperty
  • ReadOnlyDoublePropertyBase
  • ReadOnlyDoubleWrapper
  • ReadOnlyFloatProperty
  • ReadOnlyFloatPropertyBase
  • ReadOnlyFloatWrapper
  • ReadOnlyIntegerProperty
  • ReadOnlyIntegerPropertyBase
  • ReadOnlyIntegerWrapper
  • ReadOnlyListProperty
  • ReadOnlyListPropertyBase
  • ReadOnlyListWrapper
  • ReadOnlyLongProperty
  • ReadOnlyLongPropertyBase
  • ReadOnlyLongWrapper
  • ReadOnlyMapProperty
  • ReadOnlyMapPropertyBase
  • ReadOnlyMapWrapper
  • ReadOnlyObjectProperty
  • ReadOnlyObjectPropertyBase
  • ReadOnlyObjectWrapper
  • ReadOnlySetProperty
  • ReadOnlySetPropertyBase
  • ReadOnlySetWrapper
  • ReadOnlyStringProperty
  • ReadOnlyStringPropertyBase
  • ReadOnlyStringWrapper
  • SetProperty
  • SetPropertyBase
  • SimpleBooleanProperty
  • SimpleDoubleProperty
  • SimpleFloatProperty
  • SimpleIntegerProperty
  • SimpleListProperty
  • SimpleLongProperty
  • SimpleMapProperty
  • SimpleObjectProperty
  • SimpleSetProperty
  • SimpleStringProperty
  • StringProperty
  • StringPropertyBase


javafx.beans.property (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.beans.property

程序包javafx.beans.property定义只读属性和可写属性，以及一些实现。

只读属性

只读属性有两个getter， get()返回原始值， getValue()返回boxed值。

可以观察只读属性以进行更改。 他们定义了添加和删除InvalidationListeners和ChangeListeners的方法 。

为了获得只读属性的上下文，定义了两个方法getBean()和getName() 。 他们返回包含bean和属性的名称。

可写性

除了为只读属性定义的功能之外，可写属性包含以下方法。

除了为只读属性定义的getter之外，可写属性定义了两个setter。 设置者set()获取原始值，第二设置器setValue()获取盒装值。

所有属性都可以绑定到同一类型的ObservableValues ，这意味着该属性将始终包含与绑定的值相同的值ObservableValue 。 也可以在两个属性之间定义双向绑定，以使两个属性始终包含相同的值。 如果其中一个属性更改，另一个将被更新。

  • 接口摘要
    接口 描述
    Property<T>
    通用接口，定义所有（可写）属性共有的方法，与其类型无关。
    ReadOnlyProperty<T>
    通用接口，用于定义独立于其类型的所有可读属性通用的方法。
  • 类摘要
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的完整实现。
    BooleanPropertyBase
    BooleanPropertyBase类是包含 boolean值的属性的基类。
    DoubleProperty
    这个类定义了一个Property包装double值。
    DoublePropertyBase
    类 DoublePropertyBase是包含 double值的属性的基类。
    FloatProperty
    这个类定义了一个Property包裹一个float值。
    FloatPropertyBase
    FloatPropertyBase类是包含 float值的属性的基类。
    IntegerProperty
    这个类定义了一个Property包装int值。
    IntegerPropertyBase
    IntegerPropertyBase类是包含 int值的属性的基类。
    ListProperty<E>
    这个类提供了一个Property的全面实现，包装了一个ObservableList 。
    ListPropertyBase<E>
    ListPropertyBase类是包装ObservableList的属性的基类。
    LongProperty
    这个类定义了一个Property包装long值。
    LongPropertyBase
    类 LongPropertyBase是包含 long值的属性的基类。
    MapProperty<K,V>
    这个类提供了一个包含ObservableMap的Property的全面实现。
    MapPropertyBase<K,V>
    MapPropertyBase类是包装ObservableMap的属性的基类。
    ObjectProperty<T>
    这个类提供了一个包含任意Object的Property的完整实现。
    ObjectPropertyBase<T>
    ObjectPropertyBase类是包含任意 Object的属性的基类。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyBooleanPropertyBase
    所有只读属性的基类包装一个 boolean 。
    ReadOnlyBooleanWrapper
    该类提供了一个方便的类来定义只读属性。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyDoublePropertyBase
    所有只读属性的基类包装一个 double 。
    ReadOnlyDoubleWrapper
    该类提供了一个方便的类来定义只读属性。
    ReadOnlyFloatProperty
    超类为所有只读属性包装一个 float 。
    ReadOnlyFloatPropertyBase
    所有只读属性的基类包装一个 float 。
    ReadOnlyFloatWrapper
    该类提供了一个方便的类来定义只读属性。
    ReadOnlyIntegerProperty
    超类为所有只读属性包装一个 int 。
    ReadOnlyIntegerPropertyBase
    所有只读属性的基类包装一个 int 。
    ReadOnlyIntegerWrapper
    该类提供了一个方便的类来定义只读属性。
    ReadOnlyListProperty<E>
    超类为所有只读属性包装一个ObservableList 。
    ReadOnlyListPropertyBase<E>
    所有只读属性的基类包装一个ObservableList 。
    ReadOnlyListWrapper<E>
    该类提供了一个方便的类来定义只读属性。
    ReadOnlyLongProperty
    超类为所有只读属性包装一个 long 。
    ReadOnlyLongPropertyBase
    所有只读属性的基类包装一个 long 。
    ReadOnlyLongWrapper
    该类提供了一个方便的类来定义只读属性。
    ReadOnlyMapProperty<K,V>
    所有readonly属性的超类包装一个ObservableMap 。
    ReadOnlyMapPropertyBase<K,V>
    所有只读属性的基类包装一个ObservableMap 。
    ReadOnlyMapWrapper<K,V>
    该类提供了一个方便的类来定义只读属性。
    ReadOnlyObjectProperty<T>
    超类为所有只读属性包装任意 Object 。
    ReadOnlyObjectPropertyBase<T>
    所有只读属性的基类包装任意 Object 。
    ReadOnlyObjectWrapper<T>
    该类提供了一个方便的类来定义只读属性。
    ReadOnlySetProperty<E>
    超类为所有只读属性包装一个ObservableSet 。
    ReadOnlySetPropertyBase<E>
    所有只读属性的基类包装一个ObservableSet 。
    ReadOnlySetWrapper<E>
    该类提供了一个方便的类来定义只读属性。
    ReadOnlyStringProperty
    超类为所有只读属性包装一个 String 。
    ReadOnlyStringPropertyBase
    所有只读属性的基类包装一个 String 。
    ReadOnlyStringWrapper
    该类提供了一个方便的类来定义只读属性。
    SetProperty<E>
    这个类提供了一个Property的全面实现，包含一个ObservableSet 。
    SetPropertyBase<E>
    SetPropertyBase类是包装ObservableSet的属性的基类。
    SimpleBooleanProperty
    这个类提供了一个包含 boolean值的Property的完整实现。
    SimpleDoubleProperty
    这个类提供了一个包含 double值的Property的全面实现。
    SimpleFloatProperty
    这个类提供了一个包含 float值的Property的全面实现。
    SimpleIntegerProperty
    这个类提供了一个包含 int值的Property的完整实现。
    SimpleListProperty<E>
    这个课程提供了一个Property包装一个ObservableList的完整实现。
    SimpleLongProperty
    这个类提供了一个包含 long值的Property的完整实现。
    SimpleMapProperty<K,V>
    这个类提供了一个包含ObservableMap的ObservableMap的完整实现。
    SimpleObjectProperty<T>
    这个类提供了一个包含任意Object的Property的完整实现。
    SimpleSetProperty<E>
    这个类提供了一个包含ObservableSet的ObservableSet的全面实现。
    SimpleStringProperty
    这个类提供了一个包含 String值的Property的完整实现。
    StringProperty
    该类提供了一个包含 String值的Property的完整实现。
    StringPropertyBase
    StringPropertyBase类是包含 String值的属性的基类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.beans.property Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.beans.property

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression (implements javafx.beans.value.ObservableBooleanValue)
      • javafx.beans.property.ReadOnlyBooleanProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.BooleanProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableBooleanValue)
          • javafx.beans.property.BooleanPropertyBase
            • javafx.beans.property.SimpleBooleanProperty
              • javafx.beans.property.ReadOnlyBooleanWrapper
        • javafx.beans.property.ReadOnlyBooleanPropertyBase
    • javafx.beans.binding.ListExpression<E> (implements javafx.beans.value.ObservableListValue<E>)
      • javafx.beans.property.ReadOnlyListProperty<E> (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.ListProperty<E> (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableListValue<E>)
          • javafx.beans.property.ListPropertyBase<E>
            • javafx.beans.property.SimpleListProperty<E>
              • javafx.beans.property.ReadOnlyListWrapper<E>
        • javafx.beans.property.ReadOnlyListPropertyBase<E>
    • javafx.beans.binding.MapExpression<K,V> (implements javafx.beans.value.ObservableMapValue<K,V>)
      • javafx.beans.property.ReadOnlyMapProperty<K,V> (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.MapProperty<K,V> (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableMapValue<K,V>)
          • javafx.beans.property.MapPropertyBase<K,V>
            • javafx.beans.property.SimpleMapProperty<K,V>
              • javafx.beans.property.ReadOnlyMapWrapper<K,V>
        • javafx.beans.property.ReadOnlyMapPropertyBase<K,V>
    • javafx.beans.binding.NumberExpressionBase (implements javafx.beans.binding.NumberExpression)
      • javafx.beans.binding.DoubleExpression (implements javafx.beans.value.ObservableDoubleValue)
        • javafx.beans.property.ReadOnlyDoubleProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.DoubleProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableDoubleValue)
            • javafx.beans.property.DoublePropertyBase
              • javafx.beans.property.SimpleDoubleProperty
                • javafx.beans.property.ReadOnlyDoubleWrapper
          • javafx.beans.property.ReadOnlyDoublePropertyBase
      • javafx.beans.binding.FloatExpression (implements javafx.beans.value.ObservableFloatValue)
        • javafx.beans.property.ReadOnlyFloatProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.FloatProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableFloatValue)
            • javafx.beans.property.FloatPropertyBase
              • javafx.beans.property.SimpleFloatProperty
                • javafx.beans.property.ReadOnlyFloatWrapper
          • javafx.beans.property.ReadOnlyFloatPropertyBase
      • javafx.beans.binding.IntegerExpression (implements javafx.beans.value.ObservableIntegerValue)
        • javafx.beans.property.ReadOnlyIntegerProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.IntegerProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableIntegerValue)
            • javafx.beans.property.IntegerPropertyBase
              • javafx.beans.property.SimpleIntegerProperty
                • javafx.beans.property.ReadOnlyIntegerWrapper
          • javafx.beans.property.ReadOnlyIntegerPropertyBase
      • javafx.beans.binding.LongExpression (implements javafx.beans.value.ObservableLongValue)
        • javafx.beans.property.ReadOnlyLongProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.LongProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableLongValue)
            • javafx.beans.property.LongPropertyBase
              • javafx.beans.property.SimpleLongProperty
                • javafx.beans.property.ReadOnlyLongWrapper
          • javafx.beans.property.ReadOnlyLongPropertyBase
    • javafx.beans.binding.ObjectExpression<T> (implements javafx.beans.value.ObservableObjectValue<T>)
      • javafx.beans.property.ReadOnlyObjectProperty<T> (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.ObjectProperty<T> (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableObjectValue<T>)
          • javafx.beans.property.ObjectPropertyBase<T>
            • javafx.beans.property.SimpleObjectProperty<T>
              • javafx.beans.property.ReadOnlyObjectWrapper<T>
        • javafx.beans.property.ReadOnlyObjectPropertyBase<T>
    • javafx.beans.binding.SetExpression<E> (implements javafx.beans.value.ObservableSetValue<E>)
      • javafx.beans.property.ReadOnlySetProperty<E> (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.ReadOnlySetPropertyBase<E>
        • javafx.beans.property.SetProperty<E> (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableSetValue<E>)
          • javafx.beans.property.SetPropertyBase<E>
            • javafx.beans.property.SimpleSetProperty<E>
              • javafx.beans.property.ReadOnlySetWrapper<E>
    • javafx.beans.binding.StringExpression (implements javafx.beans.value.ObservableStringValue)
      • javafx.beans.property.ReadOnlyStringProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.ReadOnlyStringPropertyBase
        • javafx.beans.property.StringProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableStringValue)
          • javafx.beans.property.StringPropertyBase
            • javafx.beans.property.SimpleStringProperty
              • javafx.beans.property.ReadOnlyStringWrapper

Interface Hierarchy

  • javafx.beans.Observable
    • javafx.beans.value.ObservableValue<T>
      • javafx.beans.property.ReadOnlyProperty<T>
        • javafx.beans.property.Property<T> (also extends javafx.beans.value.WritableValue<T>)
  • javafx.beans.value.WritableValue<T>
    • javafx.beans.property.Property<T> (also extends javafx.beans.property.ReadOnlyProperty<T>)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ListProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ListProperty<E>

  • java.lang.Object
    • javafx.beans.binding.ListExpression<E>
      • javafx.beans.property.ReadOnlyListProperty<E>
        • javafx.beans.property.ListProperty<E>
  • 参数类型
    E - List元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， Property<ObservableList<E>> ， ReadOnlyProperty<E> ， ObservableListValue<E> ， ObservableObjectValue<E> ， ObservableValue<E> ， WritableListValue<E> ， WritableObjectValue<E> ， WritableValue<E> ， ObservableList<E>
    已知直接子类：
    ListPropertyBase

    public abstract class ListProperty<E>
extends ReadOnlyListProperty<E>
implements Property<ObservableList<E>>, WritableListValue<E>
    这个类提供了一个Property包装一个ObservableList的完整实现。 a的值ListProperty可以获取和设置ObservableObjectValue.get() ， ListExpression.getValue() ， WritableObjectValue.set(Object) ，并setValue(ObservableList) 。 可以使用Property.bind(javafx.beans.value.ObservableValue)和Property.unbind()绑定和绑定一个属性。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建和删除双向绑定。 ListProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableList ， ObservableListValue ， WritableListValue ， ReadOnlyListProperty ， Property

    • Property Summary

      • Properties inherited from class javafx.beans.binding.ListExpression

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListProperty​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bindBidirectional​(Property<ObservableList<E>> other)
      在这个 Property和另一个之间创建双向绑定。
      void setValue​(ObservableList<E> v)
      设置包装的值。
      String toString​()
      返回此 ListProperty对象的字符串表示形式。
      void unbindBidirectional​(Property<ObservableList<E>> other)
      删除此 Property之间的双向绑定。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, size, sort, spliterator, subList, toArray, toArray

      • Methods inherited from class javafx.beans.binding.ListExpression

        add, add, addAll, addAll, addAll, asString, clear, contains, containsAll, emptyProperty, get, getSize, getValue, indexOf, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, lastIndexOf, listExpression, listIterator, listIterator, remove, remove, remove, removeAll, removeAll, retainAll, retainAll, set, setAll, setAll, size, sizeProperty, subList, toArray, toArray, valueAt, valueAt

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableList

        addAll, addListener, filtered, remove, removeAll, removeListener, retainAll, setAll, setAll, sorted, sorted

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from class javafx.beans.property.ReadOnlyListProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableObjectValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ListProperty

        public ListProperty​()

    • 方法详细信息

      • setValue

        public void setValue​(ObservableList<E> v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableValue<E>
        参数
        v - 新值

      • bindBidirectional

        public void bindBidirectional​(Property<ObservableList<E>> other)
        在这个Property和另一个之间创建双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<E>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Property<ObservableList<E>> other)
        删除此Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional在接口 Property<E>
        参数
        other - 其他 Property

      • toString

        public String toString​()
        返回此 ListProperty对象的字符串表示形式。
        重写：
        toString在 ReadOnlyListProperty<E>
        结果
        这个 ListProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ListPropertyBase<E>

  • java.lang.Object
    • javafx.beans.binding.ListExpression<E>
      • javafx.beans.property.ReadOnlyListProperty<E>
        • javafx.beans.property.ListProperty<E>
          • javafx.beans.property.ListPropertyBase<E>
  • 参数类型
    E - List元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， Property<E> ， ReadOnlyProperty<E> ， ObservableListValue<E> ， ObservableObjectValue<E> ， ObservableValue<E> ， WritableListValue<E> ， WritableObjectValue<E> ， WritableValue<E> ， ObservableList<E>
    已知直接子类：
    SimpleListProperty

    public abstract class ListPropertyBase<E>
extends ListProperty<E>
    ListPropertyBase类是包装ObservableList的属性的基类。 它提供除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableList ， ListProperty

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty empty
      一个布尔属性是 true ，如果列表为空。
      ReadOnlyIntegerProperty size
      表示列表大小的整数属性。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListPropertyBase​()
      构造函数 ListPropertyBase
      ListPropertyBase​(ObservableList<E> initialValue)
      ListPropertyBase的构造 ListPropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ChangeListener<? super ObservableList<E>> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void addListener​(ListChangeListener<? super E> listener)
      将侦听器添加到此可观察列表中。
      void bind​(ObservableValue<? extends ObservableList<E>> newObservable)
      为此 Property创建一个单向绑定。
      ReadOnlyBooleanProperty emptyProperty​()
      一个布尔属性，如果列表为空，则为 true 。
      protected void fireValueChangedEvent​()
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。
      protected void fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。
      ObservableList<E> get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super ObservableList<E>> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void removeListener​(ListChangeListener<? super E> listener)
      尝试从此可观察列表中删除侦听器。
      void set​(ObservableList<E> newValue)
      设置包装的值。
      ReadOnlyIntegerProperty sizeProperty​()
      表示列表大小的整数属性。
      String toString​()
      返回此 ListPropertyBase对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, size, sort, spliterator, subList, toArray, toArray

      • Methods inherited from class javafx.beans.binding.ListExpression

        add, add, addAll, addAll, addAll, asString, clear, contains, containsAll, get, getSize, getValue, indexOf, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, lastIndexOf, listExpression, listIterator, listIterator, remove, remove, remove, removeAll, removeAll, retainAll, retainAll, set, setAll, setAll, size, subList, toArray, toArray, valueAt, valueAt

      • Methods inherited from class javafx.beans.property.ListProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.collections.ObservableList

        addAll, filtered, remove, removeAll, retainAll, setAll, setAll, sorted, sorted

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyListProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • Property Detail

      • size

        public ReadOnlyIntegerProperty sizeProperty
        Specified by:
        sizeProperty在 ListExpression<E>
        另请参见：
        ListExpression.getSize()

      • empty

        public ReadOnlyBooleanProperty emptyProperty
        Specified by:
        emptyProperty在 ListExpression<E>
        另请参见：
        ListExpression.isEmpty()

    • 构造方法详细信息

      • ListPropertyBase

        public ListPropertyBase​()
        构造函数 ListPropertyBase

      • ListPropertyBase

        public ListPropertyBase​(ObservableList<E> initialValue)
        ListPropertyBase的构造 ListPropertyBase 。
        参数
        initialValue - 包装值的初始值

    • 方法详细信息

      • sizeProperty

        public ReadOnlyIntegerProperty sizeProperty​()
        描述从类复制： ListExpression
        表示列表大小的整数属性。
        Specified by:
        sizeProperty在 ListExpression<E>
        另请参见：
        ListExpression.getSize()

      • emptyProperty

        public ReadOnlyBooleanProperty emptyProperty​()
        描述从类复制： ListExpression
        一个布尔属性是 true ，如果列表为空。
        Specified by:
        emptyProperty在 ListExpression<E>
        另请参见：
        ListExpression.isEmpty()

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后拨打removeListener或使用WeakInvalidationListener的实例取消注册监听器，以避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super ObservableList<E>> listener)
        说明从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super ObservableList<E>> listener)
        说明从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(ListChangeListener<? super E> listener)
        说明从接口ObservableList复制
        将侦听器添加到此可观察列表中。
        参数
        listener - 用于监听列表的监听器更改

      • removeListener

        public void removeListener​(ListChangeListener<? super E> listener)
        说明从接口ObservableList复制
        尝试从此可观察列表中删除侦听器。 如果监听者没有附加到此列表中，则不会发生任何事情。
        参数
        listener - 要删除的侦听器

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。 如果绑定变为无效，则通过调用set(ObservableList)或绑定属性来手动调用该值时调用此方法。

      • fireValueChangedEvent

        protected void fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。 当列表的内容更改时调用此方法。
        参数
        change - 需要传播的更改

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public ObservableList<E> get​()
        说明从接口WritableObjectValue复制
        获取包装的值。 这必须与从WritableValue.getValue()返回的值相同。

        此方法仅存在于将WritableObjectValue API与WritableBooleanValue和子类WritableNumberValue对齐

        结果
        当前值

      • set

        public void set​(ObservableList<E> newValue)
        说明从界面WritableObjectValue复制
        设置包装的值。 应相当于WritableValue.setValue(java.lang.Object)
        参数
        newValue - 新的价值
        另请参见：
        WritableObjectValue.get()

      • isBound

        public boolean isBound​()
        描述从接口Property复制
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property是绑定的，否则 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends ObservableList<E>> newObservable)
        说明从界面： Property复制
        为此Property创建一个单向绑定。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        newObservable - 可观察到这个 Property应该绑定到。

      • unbind

        public void unbind​()
        说明从接口Property复制
        删除此Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 ListPropertyBase对象的字符串表示形式。
        重写：
        toString在 ListProperty<E>
        结果
        这个 ListPropertyBase对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class LongProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
          • javafx.beans.property.LongProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableLongValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    JavaBeanLongProperty ， LongPropertyBase

    public abstract class LongProperty
extends ReadOnlyLongProperty
implements Property<Number>, WritableLongValue
    此类定义了一个27066779921669包装long值。

    a的值LongProperty可以获取和设置ObservableLongValue.get() ， LongExpression.getValue() ， WritableLongValue.set(long) ，并setValue(Number) 。

    一个属性可以绑定和绑定单向与Property.bind(ObservableValue)和Property.unbind() 。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建和删除双向绑定。

    LongProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。

    注意：将此属性设置或绑定为空值将将属性设置为“0.0”。 见setValue(java.lang.Number) 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableLongValue ， WritableLongValue ， ReadOnlyLongProperty ， Property

    • 构造方法摘要

      构造方法
      Constructor 描述
      LongProperty​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Long> asObject​()
      创建一个ObjectProperty双向绑定到这个LongProperty 。
      void bindBidirectional​(Property<Number> other)
      在这个 Property和另一个之间创建双向绑定。
      static LongProperty longProperty​(Property<Long> property)
      返回一个LongProperty ，其中包含一个Property并双向绑定到它。
      void setValue​(Number v)
      设置包装的值。
      String toString​()
      返回此 LongProperty对象的字符串表示形式。
      void unbindBidirectional​(Property<Number> other)
      删除这个 Property和另一个之间的双向绑定。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableLongValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from class javafx.beans.property.ReadOnlyLongProperty

        readOnlyLongProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableLongValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • LongProperty

        public LongProperty​()

    • 方法详细信息

      • setValue

        public void setValue​(Number v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableLongValue
        Specified by:
        setValue在接口 WritableValue<Number>
        参数
        v - 新的价值

      • bindBidirectional

        public void bindBidirectional​(Property<Number> other)
        在这个Property和另一个之间创建双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<Number>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Property<Number> other)
        删除此Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional在接口 Property<Number>
        参数
        other - 其他 Property

      • toString

        public String toString​()
        返回此 LongProperty对象的字符串表示形式。
        重写：
        toString在 ReadOnlyLongProperty
        结果
        这个 LongProperty对象的字符串表示形式。

      • longProperty

        public static LongProperty longProperty​(Property<Long> property)
        返回一个LongProperty ，其中包含一个Property并双向绑定到它。 更改此属性将导致原始属性更改。

        当双向绑定ObjectProperty <Long>和LongProperty时，这是非常有用的。

           LongProperty longProperty = new SimpleLongProperty(1L);
   ObjectProperty<Long> objectProperty = new SimpleObjectProperty<>(2L);

   // Need to keep the reference as bidirectional binding uses weak references
   LongProperty objectAsLong = LongProperty.longProperty(objectProperty);

   longProperty.bindBidirectional(objectAsLong);
        另一种方法是使用asObject()方法将LongProperty转换为ObjectProperty。

        注意：source属性中的null值将被解释为0L

        参数
        property - 来源 Property
        结果
        A LongProperty包裹了 Property
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        asObject()

      • asObject

        public ObjectProperty<Long> asObject​()
        创建一个ObjectProperty双向绑定到这个LongProperty 。 如果这个值LongProperty的变化，价值ObjectProperty将自动更新，反之亦然。

        可以将ObjectProperty绑定到LongProperty。

           LongProperty longProperty = new SimpleLongProperty(1L);
   ObjectProperty<Long> objectProperty = new SimpleObjectProperty<>(2L);

   objectProperty.bind(longProperty.asObject());
        重写：
        asObject在 ReadOnlyLongProperty
        结果
        新的 ObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class LongPropertyBase

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
          • javafx.beans.property.LongProperty
            • javafx.beans.property.LongPropertyBase
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableLongValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    SimpleLongProperty ， StyleableLongProperty

    public abstract class LongPropertyBase
extends LongProperty
    LongPropertyBase类是包含long值的属性的基类。 它提供除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    LongProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      LongPropertyBase​()
      LongPropertyBase的构造 LongPropertyBase 。
      LongPropertyBase​(long initialValue)
      LongPropertyBase的构造 LongPropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      long get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(long newValue)
      设置包装的值。
      String toString​()
      返回此 LongPropertyBase对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.LongProperty

        asObject, bindBidirectional, longProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyLongProperty

        readOnlyLongProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • LongPropertyBase

        public LongPropertyBase​()
        的构造函数为 LongPropertyBase 。

      • LongPropertyBase

        public LongPropertyBase​(long initialValue)
        的构造函数 LongPropertyBase 。
        参数
        initialValue - 包装值的初始值

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对监听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的侦听器，每当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从接口ObservableValue复制
        从监听器列表中删除给定的监听器，每当ObservableValue的值发生变化时通知该ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果绑定变为无效，则通过调用set(long)或绑定属性来手动调用该值时调用此方法。

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public long get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始long。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        public void set​(long newValue)
        设置包装的值。 不像WritableLongValue.setValue(java.lang.Number) ，这种方法使用原始长。
        参数
        newValue - 新的价值

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property绑定，否则为 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends Number> rawObservable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        rawObservable - 可观察到这个 Property应该绑定到。

      • unbind

        public void unbind​()
        删除这个Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 LongPropertyBase对象的字符串表示形式。
        重写：
        toString在 LongProperty
        结果
        这个 LongPropertyBase对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MapProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class MapProperty<K,V>

  • java.lang.Object
    • javafx.beans.binding.MapExpression<K,V>
      • javafx.beans.property.ReadOnlyMapProperty<K,V>
        • javafx.beans.property.MapProperty<K,V>
  • 参数类型
    K - K的关键元素的 Map
    V - V的值元素的 Map
    All Implemented Interfaces:
    Map<K,V> ， Observable ， Property<ObservableMap<K,V>> ， ReadOnlyProperty<K> ， ObservableMapValue<K,V> ， ObservableObjectValue<K> ， ObservableValue<K> ， WritableMapValue<K,V> ， WritableObjectValue<K> ， WritableValue<K> ， ObservableMap<K,V>
    已知直接子类：
    MapPropertyBase

    public abstract class MapProperty<K,V>
extends ReadOnlyMapProperty<K,V>
implements Property<ObservableMap<K,V>>, WritableMapValue<K,V>
    这个类提供了一个Property的全面实现，包含一个ObservableMap 。 a的值MapProperty可以获取和设置ObservableObjectValue.get() ， MapExpression.getValue() ， WritableObjectValue.set(Object) ，并setValue(javafx.collections.ObservableMap) 。 一个属性可以绑定和绑定单向与Property.bind(javafx.beans.value.ObservableValue)和Property.unbind() 。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建双向绑定。 MapProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableMap ， ObservableMapValue ， WritableMapValue ， ReadOnlyMapProperty ， Property

    • Property Summary

      • Properties inherited from class javafx.beans.binding.MapExpression

        empty, size

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      MapProperty​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bindBidirectional​(Property<ObservableMap<K,V>> other)
      在这个 Property和另一个之间创建双向绑定。
      void setValue​(ObservableMap<K,V> v)
      设置包装的值。
      String toString​()
      返回此 MapProperty对象的字符串表示形式。
      void unbindBidirectional​(Property<ObservableMap<K,V>> other)
      删除此 Property和另一个之间的双向绑定。

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entry, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

      • Methods inherited from class javafx.beans.binding.MapExpression

        asString, clear, containsKey, containsValue, emptyProperty, entrySet, get, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, keySet, mapExpression, put, putAll, remove, size, sizeProperty, valueAt, valueAt, values

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableMap

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from class javafx.beans.property.ReadOnlyMapProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableObjectValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • MapProperty

        public MapProperty​()

    • 方法详细信息

      • setValue

        public void setValue​(ObservableMap<K,V> v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableValue<K>
        参数
        v - 新的价值

      • bindBidirectional

        public void bindBidirectional​(Property<ObservableMap<K,V>> other)
        在这个Property和另一个之间创建双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<K>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Property<ObservableMap<K,V>> other)
        删除这个Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional在接口 Property<K>
        参数
        other - 其他 Property

      • toString

        public String toString​()
        返回此 MapProperty对象的字符串表示形式。
        重写：
        toString在 ReadOnlyMapProperty<K,V>
        结果
        这个 MapProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MapPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class MapPropertyBase<K,V>

  • java.lang.Object
    • javafx.beans.binding.MapExpression<K,V>
      • javafx.beans.property.ReadOnlyMapProperty<K,V>
        • javafx.beans.property.MapProperty<K,V>
          • javafx.beans.property.MapPropertyBase<K,V>
  • 参数类型
    K - K的关键元素的 Map
    V - V的值元素的 Map
    All Implemented Interfaces:
    Map<K,V> ， Observable ， Property<K> ， ReadOnlyProperty<K> ， ObservableMapValue<K,V> ， ObservableObjectValue<K> ， ObservableValue<K> ， WritableMapValue<K,V> ， WritableObjectValue<K> ， WritableValue<K> ， ObservableMap<K,V>
    已知直接子类：
    SimpleMapProperty

    public abstract class MapPropertyBase<K,V>
extends MapProperty<K,V>
    MapPropertyBase类是包装ObservableMap的属性的基类。 它提供除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，这些方法必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableMap ， MapProperty

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty empty
      一个布尔属性是 true ，如果地图是空的。
      ReadOnlyIntegerProperty size
      表示地图大小的整数属性。

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      MapPropertyBase​()
      构造器 MapPropertyBase
      MapPropertyBase​(ObservableMap<K,V> initialValue)
      MapPropertyBase的构造 MapPropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void addListener​(MapChangeListener<? super K,? super V> listener)
      添加一个监听器到这个可观察的地图。
      void bind​(ObservableValue<? extends ObservableMap<K,V>> newObservable)
      为此创建一个单向绑定 Property 。
      ReadOnlyBooleanProperty emptyProperty​()
      一个布尔属性是 true ，如果地图是空的。
      protected void fireValueChangedEvent​()
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。
      protected void fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。
      ObservableMap<K,V> get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知该 ObservableValue 。
      void removeListener​(MapChangeListener<? super K,? super V> listener)
      试图从这个可观察的地图中删除一个听众。
      void set​(ObservableMap<K,V> newValue)
      设置包装的值。
      ReadOnlyIntegerProperty sizeProperty​()
      表示地图大小的整数属性。
      String toString​()
      返回此 MapPropertyBase对象的字符串表示形式。
      void unbind​()
      删除这个 Property的单向绑定。

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entry, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

      • Methods inherited from class javafx.beans.binding.MapExpression

        asString, clear, containsKey, containsValue, entrySet, get, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, keySet, mapExpression, put, putAll, remove, size, valueAt, valueAt, values

      • Methods inherited from class javafx.beans.property.MapProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyMapProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • Property Detail

      • size

        public ReadOnlyIntegerProperty sizeProperty
        Specified by:
        sizeProperty在 MapExpression<K,V>
        另请参见：
        MapExpression.getSize()

      • empty

        public ReadOnlyBooleanProperty emptyProperty
        Specified by:
        emptyProperty MapExpression<K,V>
        另请参见：
        MapExpression.isEmpty()

    • 构造方法详细信息

      • MapPropertyBase

        public MapPropertyBase​()
        构造函数 MapPropertyBase

      • MapPropertyBase

        public MapPropertyBase​(ObservableMap<K,V> initialValue)
        MapPropertyBase的构造 MapPropertyBase 。
        参数
        initialValue - 包装值的初始值

    • 方法详细信息

      • sizeProperty

        public ReadOnlyIntegerProperty sizeProperty​()
        描述从类复制： MapExpression
        表示地图大小的整数属性。
        Specified by:
        sizeProperty在 MapExpression<K,V>
        另请参见：
        MapExpression.getSize()

      • emptyProperty

        public ReadOnlyBooleanProperty emptyProperty​()
        描述从类复制： MapExpression
        一个布尔属性是 true ，如果地图是空的。
        Specified by:
        emptyProperty在 MapExpression<K,V>
        另请参见：
        MapExpression.isEmpty()

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对监听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(MapChangeListener<? super K,? super V> listener)
        描述从接口ObservableMap复制
        添加一个监听器到这个可观察的地图。
        参数
        listener - 用于监听列表的监听器更改

      • removeListener

        public void removeListener​(MapChangeListener<? super K,? super V> listener)
        描述从接口ObservableMap复制
        试图从这个可观察的地图中删除一个听众。 如果听众没有附加到这个地图，没有任何反应。
        参数
        listener - 要删除的侦听器

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。 通过调用set(javafx.collections.ObservableMap)手动或绑定属性的情况下，如果绑定变为无效，则调用此方法。

      • fireValueChangedEvent

        protected void fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。 当列表的内容更改时调用此方法。
        参数
        change - 需要传播的更改

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public ObservableMap<K,V> get​()
        描述从接口WritableObjectValue复制
        获取包装的值。 这必须与从WritableValue.getValue()返回的值相同。

        此方法仅存在于将WritableObjectValue API与WritableBooleanValue和WritableNumberValue的子类对齐

        结果
        当前值

      • set

        public void set​(ObservableMap<K,V> newValue)
        描述从接口WritableObjectValue复制
        设置包装的值。 应相当于WritableValue.setValue(java.lang.Object)
        参数
        newValue - 新的价值
        另请参见：
        WritableObjectValue.get()

      • isBound

        public boolean isBound​()
        描述从接口Property复制
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property是绑定的，另外 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends ObservableMap<K,V>> newObservable)
        说明从界面： Property复制
        为此Property创建一个单向绑定。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        newObservable - 可观察这 Property应该绑定。

      • unbind

        public void unbind​()
        描述从接口Property复制
        删除此Property的单向绑定。 如果Property没有绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 MapPropertyBase对象的字符串表示形式。
        重写：
        toString在 MapProperty<K,V>
        结果
        这个 MapPropertyBase对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ObjectProperty<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
        • javafx.beans.property.ObjectProperty<T>
  • 参数类型
    T - 包装的类型 Object
    All Implemented Interfaces:
    Observable ， Property<T> ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T> ， WritableObjectValue<T> ， WritableValue<T>
    已知直接子类：
    JavaBeanObjectProperty ， ObjectPropertyBase

    public abstract class ObjectProperty<T>
extends ReadOnlyObjectProperty<T>
implements Property<T>, WritableObjectValue<T>
    这个类提供了一个Property的全面实现，包含一个任意的Object 。 a的值ObjectProperty可以获取和设置ObservableObjectValue.get() ， ObjectExpression.getValue() ， WritableObjectValue.set(Object) ，并setValue(Object) 。 一个属性可以绑定和绑定单向与Property.bind(ObservableValue)和Property.unbind() 。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建和删除双向绑定。 ObjectProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。 对于专门的实现ObservableList ， ObservableSet和ObservableMap也报告集合内的变化，看到ListProperty ， SetProperty和MapProperty分别。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableObjectValue ， WritableObjectValue ， ReadOnlyObjectProperty ， Property

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObjectProperty​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bindBidirectional​(Property<T> other)
      在这个 Property和另一个之间创建双向绑定。
      void setValue​(T v)
      设置包装的值。
      String toString​()
      返回此 ObjectProperty对象的字符串表示形式。
      void unbindBidirectional​(Property<T> other)
      删除此 Property之间的双向绑定。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableObjectValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ObjectProperty

        public ObjectProperty​()

    • 方法详细信息

      • setValue

        public void setValue​(T v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableValue<T>
        参数
        v - 新的价值

      • bindBidirectional

        public void bindBidirectional​(Property<T> other)
        在这个Property之间创建一个双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<T>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Property<T> other)
        删除此Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional在接口 Property<T>
        参数
        other - 其他 Property

      • toString

        public String toString​()
        返回此 ObjectProperty对象的字符串表示形式。
        重写：
        toString在 ReadOnlyObjectProperty<T>
        结果
        这个 ObjectProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObjectPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ObjectPropertyBase<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
        • javafx.beans.property.ObjectProperty<T>
          • javafx.beans.property.ObjectPropertyBase<T>
  • 参数类型
    T - 包装值的类型
    All Implemented Interfaces:
    Observable ， Property<T> ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T> ， WritableObjectValue<T> ， WritableValue<T>
    已知直接子类：
    SimpleObjectProperty ， StyleableObjectProperty

    public abstract class ObjectPropertyBase<T>
extends ObjectProperty<T>
    ObjectPropertyBase类是包含任意Object的属性的基类。 它提供除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObjectProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObjectPropertyBase​()
      ObjectPropertyBase的构造 ObjectPropertyBase 。
      ObjectPropertyBase​(T initialValue)
      的构造函数为 ObjectPropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super T> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void bind​(ObservableValue<? extends T> newObservable)
      为此创建一个单向绑定 Property 。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      T get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super T> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生更改时通知 ObservableValue 。
      void set​(T newValue)
      设置包装的值。
      String toString​()
      返回此 ObjectPropertyBase对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from class javafx.beans.property.ObjectProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ObjectPropertyBase

        public ObjectPropertyBase​()
        ObjectPropertyBase的构造 ObjectPropertyBase 。

      • ObjectPropertyBase

        public ObjectPropertyBase​(T initialValue)
        ObjectPropertyBase的构造 ObjectPropertyBase 。
        参数
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储强烈的对监听器的引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或者使用WeakInvalidationListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super T> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super T> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果绑定变为无效，则通过调用set(T)或绑定属性来手动调用该值时调用此方法。

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public T get​()
        获取包装的值。 这必须与从WritableValue.getValue()返回的值相同。

        此方法只能将WritableObjectValue API与WritableBooleanValue和WritableNumberValue的子类对齐

        结果
        当前值

      • set

        public void set​(T newValue)
        设置包装的值。 应相当于WritableValue.setValue(java.lang.Object)
        参数
        newValue - 新的价值
        另请参见：
        WritableObjectValue.get()

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property是绑定的， false否则
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends T> newObservable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        newObservable - 可观察到这个 Property应该绑定。

      • unbind

        public void unbind​()
        删除这个Property的单向绑定。 如果Property没有绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 ObjectPropertyBase对象的字符串表示形式。
        重写：
        toString在 ObjectProperty<T>
        结果
        这个 ObjectPropertyBase对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Property (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Interface Property<T>

  • 参数类型
    T - 包装值的类型
    All Superinterfaces:
    Observable ， ObservableValue<T> ， ReadOnlyProperty<T> ， WritableValue<T>
    All Known Subinterfaces:
    JavaBeanProperty<T>
    所有已知实现类：
    BooleanProperty ， BooleanPropertyBase ， DoubleProperty ， DoublePropertyBase ， FloatProperty ， FloatPropertyBase ， IntegerProperty ， IntegerPropertyBase ， JavaBeanBooleanProperty ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， JavaBeanObjectProperty ， JavaBeanStringProperty ， ListProperty ， ListPropertyBase ， LongProperty ， LongPropertyBase ， MapProperty ， MapPropertyBase ， ObjectProperty ， ObjectPropertyBase ， ReadOnlyBooleanWrapper ， ReadOnlyDoubleWrapper ， ReadOnlyFloatWrapper ， ReadOnlyIntegerWrapper ， ReadOnlyListWrapper ， ReadOnlyLongWrapper ， ReadOnlyMapWrapper ， ReadOnlyObjectWrapper ， ReadOnlySetWrapper ， ReadOnlyStringWrapper ， SetProperty ， SetPropertyBase ， SimpleBooleanProperty ， SimpleDoubleProperty ， SimpleFloatProperty ， SimpleIntegerProperty ， SimpleListProperty ， SimpleLongProperty ， SimpleMapProperty ， SimpleObjectProperty ， SimpleSetProperty ， SimpleStringProperty ， SimpleStyleableBooleanProperty ， SimpleStyleableDoubleProperty ， SimpleStyleableFloatProperty ， SimpleStyleableIntegerProperty ， SimpleStyleableLongProperty ， SimpleStyleableObjectProperty ， SimpleStyleableStringProperty ， StringProperty ， StringPropertyBase ， StyleableBooleanProperty ， StyleableDoubleProperty StyleableDoubleProperty ， StyleableFloatProperty ， StyleableIntegerProperty ， StyleableLongProperty ， StyleableObjectProperty ， StyleableStringProperty

    public interface Property<T>
extends ReadOnlyProperty<T>, WritableValue<T>
    通用接口，定义所有（可写）属性共有的方法，与其类型无关。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void bind​(ObservableValue<? extends T> observable)
      为此创建一个单向绑定 Property 。
      void bindBidirectional​(Property<T> other)
      在这个 Property和另一个之间创建双向绑定。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void unbind​()
      删除此 Property的单向绑定。
      void unbindBidirectional​(Property<T> other)
      删除此 Property和另一个之间的双向绑定。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • bind

        void bind​(ObservableValue<? extends T> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        observable - 可观察这 Property应该绑定。
        异常
        NullPointerException - 如果 observable是 null

      • unbind

        void unbind​()
        删除此Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        另请参见：
        bind(javafx.beans.value.ObservableValue)

      • isBound

        boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property是绑定的， false否则
        另请参见：
        bind(javafx.beans.value.ObservableValue)

      • bindBidirectional

        void bindBidirectional​(Property<T> other)
        在这个Property和另一个之间创建双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        参数
        other - 其他 Property
        异常
        NullPointerException - 如果 other是 null
        IllegalArgumentException - 如果 other是 this

      • unbindBidirectional

        void unbindBidirectional​(Property<T> other)
        删除此Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        参数
        other - 其他 Property
        异常
        NullPointerException - 如果 other是 null
        IllegalArgumentException - 如果 other是 this
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyBooleanProperty

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
  • All Implemented Interfaces:
    Observable ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean>
    已知直接子类：
    BooleanProperty ， ReadOnlyBooleanPropertyBase

    public abstract class ReadOnlyBooleanProperty
extends BooleanExpression
implements ReadOnlyProperty<Boolean>
    超类为所有只读属性包装一个 boolean 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableBooleanValue ， BooleanExpression ， ReadOnlyProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyBooleanProperty​()
      构造函数为 ReadOnlyBooleanProperty 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Boolean> asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyBooleanProperty 。
      static ReadOnlyBooleanProperty readOnlyBooleanProperty​(ReadOnlyProperty<Boolean> property)
      返回一个ReadOnlyBooleanProperty的ReadOnlyBooleanProperty 。
      String toString​()
      返回此 ReadOnlyBooleanProperty对象的字符串表示形式。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableBooleanValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyBooleanProperty

        public ReadOnlyBooleanProperty​()
        构造函数为 ReadOnlyBooleanProperty 。

    • 方法详细信息

      • toString

        public String toString​()
        返回此 ReadOnlyBooleanProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ReadOnlyBooleanProperty对象的字符串表示形式。

      • readOnlyBooleanProperty

        public static ReadOnlyBooleanProperty readOnlyBooleanProperty​(ReadOnlyProperty<Boolean> property)
        返回一个ReadOnlyBooleanProperty的ReadOnlyBooleanProperty 。 如果ReadOnlyProperty已经是ReadOnlyBooleanProperty ，它将被返回。 否则，创建一个新的ReadOnlyBooleanProperty绑定到ReadOnlyProperty 。 注意：空值将被解释为“false”
        参数
        property - 来源 ReadOnlyProperty
        结果
        一个 ReadOnlyBooleanProperty包装了 ReadOnlyProperty如果有必要
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0

      • asObject

        public ReadOnlyObjectProperty<Boolean> asObject​()
        创建一个ReadOnlyObjectProperty ，其值为ReadOnlyBooleanProperty 。 如果这个值ReadOnlyBooleanProperty的变化，价值ReadOnlyObjectProperty将自动更新。
        重写：
        asObject在 BooleanExpression
        结果
        新的 ReadOnlyObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyBooleanPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyBooleanPropertyBase

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
        • javafx.beans.property.ReadOnlyBooleanPropertyBase
  • All Implemented Interfaces:
    Observable ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean>
    已知直接子类：
    ReadOnlyJavaBeanBooleanProperty

    public abstract class ReadOnlyBooleanPropertyBase
extends ReadOnlyBooleanProperty
    所有只读属性的基类包装一个boolean 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ReadOnlyBooleanProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyBooleanPropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Boolean> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时，它们将被通知。
      void removeListener​(ChangeListener<? super Boolean> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableBooleanValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanProperty

        asObject, readOnlyBooleanProperty, toString

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyBooleanPropertyBase

        public ReadOnlyBooleanPropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或使用WeakInvalidationListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Boolean> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Boolean> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的侦听器，每当ObservableValue的值更改时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyBooleanWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyBooleanWrapper

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
        • javafx.beans.property.BooleanProperty
          • javafx.beans.property.BooleanPropertyBase
            • javafx.beans.property.SimpleBooleanProperty
              • javafx.beans.property.ReadOnlyBooleanWrapper
  • All Implemented Interfaces:
    Observable ， Property<Boolean> ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean> ， WritableBooleanValue ， WritableValue<Boolean>

    public class ReadOnlyBooleanWrapper
extends SimpleBooleanProperty
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyBooleanWrapper​()
      构造函数为 ReadOnlyBooleanWrapper
      ReadOnlyBooleanWrapper​(boolean initialValue)
      构造函数为 ReadOnlyBooleanWrapper
      ReadOnlyBooleanWrapper​(Object bean, String name)
      构造函数为 ReadOnlyBooleanWrapper
      ReadOnlyBooleanWrapper​(Object bean, String name, boolean initialValue)
      构造函数为 ReadOnlyBooleanWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      ReadOnlyBooleanProperty getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyBooleanWrapper同步。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class javafx.beans.property.BooleanProperty

        asObject, bindBidirectional, booleanProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.BooleanPropertyBase

        addListener, addListener, bind, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanProperty

        readOnlyBooleanProperty

      • Methods inherited from class javafx.beans.property.SimpleBooleanProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlyBooleanWrapper

        public ReadOnlyBooleanWrapper​()
        构造函数为 ReadOnlyBooleanWrapper

      • ReadOnlyBooleanWrapper

        public ReadOnlyBooleanWrapper​(boolean initialValue)
        构造函数为 ReadOnlyBooleanWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlyBooleanWrapper

        public ReadOnlyBooleanWrapper​(Object bean,
                              String name)
        构造函数为 ReadOnlyBooleanWrapper
        参数
        bean - 这个 ReadOnlyBooleanProperty的豆
        name - 这个名字 ReadOnlyBooleanProperty

      • ReadOnlyBooleanWrapper

        public ReadOnlyBooleanWrapper​(Object bean,
                              String name,
                              boolean initialValue)
        构造函数为 ReadOnlyBooleanWrapper
        参数
        bean - 这个 ReadOnlyBooleanProperty的豆
        name - 这个 ReadOnlyBooleanProperty的名字
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlyBooleanProperty getReadOnlyProperty​()
        返回readonly属性，该属性与此 ReadOnlyBooleanWrapper同步。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果绑定变为无效，则通过调用BooleanPropertyBase.set(boolean)或绑定属性来手动更改该值时调用此方法。
        重写：
        fireValueChangedEvent在 BooleanPropertyBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyDoubleProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    DoubleProperty ， ReadOnlyDoublePropertyBase

    public abstract class ReadOnlyDoubleProperty
extends DoubleExpression
implements ReadOnlyProperty<Number>
    超类为所有只读属性包装一个 double 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableDoubleValue ， DoubleExpression ， ReadOnlyProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyDoubleProperty​()
      构造函数为 ReadOnlyDoubleProperty 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Double> asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyDoubleProperty 。
      static <T extends Number>
      ReadOnlyDoubleProperty             		readOnlyDoubleProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyDoubleProperty ，其中包含一个ReadOnlyProperty 。
      String toString​()
      返回此 ReadOnlyDoubleProperty对象的字符串表示形式。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableDoubleValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyDoubleProperty

        public ReadOnlyDoubleProperty​()
        构造函数为 ReadOnlyDoubleProperty 。

    • 方法详细信息

      • toString

        public String toString​()
        返回此 ReadOnlyDoubleProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ReadOnlyDoubleProperty对象的字符串表示形式。

      • readOnlyDoubleProperty

        public static <T extends Number> ReadOnlyDoubleProperty readOnlyDoubleProperty​(ReadOnlyProperty<T> property)
        返回一个ReadOnlyDoubleProperty ，其中包含一个ReadOnlyProperty 。 如果ReadOnlyProperty已经是ReadOnlyDoubleProperty ，它将被退回。 否则，将创建一个新的ReadOnlyDoubleProperty ，绑定到ReadOnlyProperty 。 注意：空值将被解释为0.0
        参数类型
        T - 要包装的号码的类型
        参数
        property - 来源 ReadOnlyProperty
        结果
        一个 ReadOnlyDoubleProperty包装了 ReadOnlyProperty如果有必要
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0

      • asObject

        public ReadOnlyObjectProperty<Double> asObject​()
        创建一个ReadOnlyObjectProperty ，其值为ReadOnlyDoubleProperty 。 如果这个值ReadOnlyDoubleProperty的变化，价值ReadOnlyObjectProperty将自动更新。
        重写：
        asObject在 DoubleExpression
        结果
        新的 ReadOnlyObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyDoublePropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyDoublePropertyBase

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
          • javafx.beans.property.ReadOnlyDoublePropertyBase
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    ReadOnlyJavaBeanDoubleProperty

    public abstract class ReadOnlyDoublePropertyBase
extends ReadOnlyDoubleProperty
    所有只读属性的基类包装一个double 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ReadOnlyDoubleProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyDoublePropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableDoubleValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyDoubleProperty

        asObject, readOnlyDoubleProperty, toString

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyDoublePropertyBase

        public ReadOnlyDoublePropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakInvalidationListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyDoubleWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyDoubleWrapper

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
          • javafx.beans.property.DoubleProperty
            • javafx.beans.property.DoublePropertyBase
              • javafx.beans.property.SimpleDoubleProperty
                • javafx.beans.property.ReadOnlyDoubleWrapper
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableDoubleValue ， WritableNumberValue ， WritableValue<Number>

    public class ReadOnlyDoubleWrapper
extends SimpleDoubleProperty
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyDoubleWrapper​()
      构造函数为 ReadOnlyDoubleWrapper
      ReadOnlyDoubleWrapper​(double initialValue)
      构造函数为 ReadOnlyDoubleWrapper
      ReadOnlyDoubleWrapper​(Object bean, String name)
      构造函数为 ReadOnlyDoubleWrapper
      ReadOnlyDoubleWrapper​(Object bean, String name, double initialValue)
      构造函数为 ReadOnlyDoubleWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      ReadOnlyDoubleProperty getReadOnlyProperty​()
      返回与此 ReadOnlyDoubleWrapper同步的只读属性。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.DoubleProperty

        asObject, bindBidirectional, doubleProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.DoublePropertyBase

        addListener, addListener, bind, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyDoubleProperty

        readOnlyDoubleProperty

      • Methods inherited from class javafx.beans.property.SimpleDoubleProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlyDoubleWrapper

        public ReadOnlyDoubleWrapper​()
        构造函数为 ReadOnlyDoubleWrapper

      • ReadOnlyDoubleWrapper

        public ReadOnlyDoubleWrapper​(double initialValue)
        构造函数为 ReadOnlyDoubleWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlyDoubleWrapper

        public ReadOnlyDoubleWrapper​(Object bean,
                             String name)
        构造函数为 ReadOnlyDoubleWrapper
        参数
        bean - 这个 ReadOnlyDoubleProperty的豆
        name - 这个名字 ReadOnlyDoubleProperty

      • ReadOnlyDoubleWrapper

        public ReadOnlyDoubleWrapper​(Object bean,
                             String name,
                             double initialValue)
        构造函数为 ReadOnlyDoubleWrapper
        参数
        bean - 这个 ReadOnlyDoubleProperty的豆
        name - 这个 ReadOnlyDoubleProperty的名字
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlyDoubleProperty getReadOnlyProperty​()
        返回与此 ReadOnlyDoubleWrapper同步的只读属性。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 通过调用DoublePropertyBase.set(double)手动或绑定属性的情况下，如果绑定变为无效，则调用此方法。
        重写：
        fireValueChangedEvent中的 DoublePropertyBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyFloatProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    FloatProperty ， ReadOnlyFloatPropertyBase

    public abstract class ReadOnlyFloatProperty
extends FloatExpression
implements ReadOnlyProperty<Number>
    超类为所有只读属性包装一个 float 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableFloatValue ， FloatExpression ， ReadOnlyProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyFloatProperty​()
      构造函数为 ReadOnlyFloatProperty 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Float> asObject​()
      创建一个持有ReadOnlyFloatProperty的值的ReadOnlyFloatProperty 。
      static <T extends Number>
      ReadOnlyFloatProperty             		readOnlyFloatProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyFloatProperty的ReadOnlyFloatProperty 。
      String toString​()
      返回此 ReadOnlyFloatProperty对象的字符串表示形式。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableFloatValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyFloatProperty

        public ReadOnlyFloatProperty​()
        构造函数为 ReadOnlyFloatProperty 。

    • 方法详细信息

      • toString

        public String toString​()
        返回此 ReadOnlyFloatProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ReadOnlyFloatProperty对象的字符串表示形式。

      • readOnlyFloatProperty

        public static <T extends Number> ReadOnlyFloatProperty readOnlyFloatProperty​(ReadOnlyProperty<T> property)
        返回一个ReadOnlyFloatProperty的ReadOnlyFloatProperty 。 如果ReadOnlyProperty已经是一个ReadOnlyFloatProperty ，它将被返回。 否则创建一个新的ReadOnlyFloatProperty绑定到ReadOnlyProperty 。 注意：空值将被解释为0f
        参数类型
        T - 要包装的号码的类型
        参数
        property - 来源 ReadOnlyProperty
        结果
        一个 ReadOnlyFloatProperty包装了 ReadOnlyProperty如果有必要
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0

      • asObject

        public ReadOnlyObjectProperty<Float> asObject​()
        创建一个ReadOnlyObjectProperty保留此值ReadOnlyFloatProperty 。 如果这个值ReadOnlyFloatProperty的变化，价值ReadOnlyObjectProperty将自动更新。
        重写：
        asObject在 FloatExpression
        结果
        新的 ReadOnlyObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyFloatPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyFloatPropertyBase

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
          • javafx.beans.property.ReadOnlyFloatPropertyBase
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    ReadOnlyJavaBeanFloatProperty

    public abstract class ReadOnlyFloatPropertyBase
extends ReadOnlyFloatProperty
    所有只读属性的基类包装一个float 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ReadOnlyFloatProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyFloatPropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableFloatValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatProperty

        asObject, readOnlyFloatProperty, toString

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyFloatPropertyBase

        public ReadOnlyFloatPropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或使用WeakInvalidationListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        说明从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从接口ObservableValue复制
        从监听器列表中删除给定的侦听器，每当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyFloatWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyFloatWrapper

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
          • javafx.beans.property.FloatProperty
            • javafx.beans.property.FloatPropertyBase
              • javafx.beans.property.SimpleFloatProperty
                • javafx.beans.property.ReadOnlyFloatWrapper
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableFloatValue ， WritableNumberValue ， WritableValue<Number>

    public class ReadOnlyFloatWrapper
extends SimpleFloatProperty
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyFloatWrapper​()
      构造函数为 ReadOnlyFloatWrapper
      ReadOnlyFloatWrapper​(float initialValue)
      构造函数为 ReadOnlyFloatWrapper
      ReadOnlyFloatWrapper​(Object bean, String name)
      构造函数为 ReadOnlyFloatWrapper
      ReadOnlyFloatWrapper​(Object bean, String name, float initialValue)
      构造函数为 ReadOnlyFloatWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      ReadOnlyFloatProperty getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyFloatWrapper同步。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.FloatProperty

        asObject, bindBidirectional, floatProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.FloatPropertyBase

        addListener, addListener, bind, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatProperty

        readOnlyFloatProperty

      • Methods inherited from class javafx.beans.property.SimpleFloatProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlyFloatWrapper

        public ReadOnlyFloatWrapper​()
        构造函数为 ReadOnlyFloatWrapper

      • ReadOnlyFloatWrapper

        public ReadOnlyFloatWrapper​(float initialValue)
        构造函数为 ReadOnlyFloatWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlyFloatWrapper

        public ReadOnlyFloatWrapper​(Object bean,
                            String name)
        构造函数为 ReadOnlyFloatWrapper
        参数
        bean - 这个 ReadOnlyFloatProperty的豆
        name - 这个名字 ReadOnlyFloatProperty

      • ReadOnlyFloatWrapper

        public ReadOnlyFloatWrapper​(Object bean,
                            String name,
                            float initialValue)
        构造函数为 ReadOnlyFloatWrapper
        参数
        bean - 这个 ReadOnlyFloatProperty的豆
        name - 这个 ReadOnlyFloatProperty的名字
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlyFloatProperty getReadOnlyProperty​()
        返回readonly属性，该属性与此 ReadOnlyFloatWrapper同步。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 通过调用FloatPropertyBase.set(float)手动或绑定属性的情况下，如果绑定变为无效，则调用此方法。
        重写：
        fireValueChangedEvent在 FloatPropertyBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyIntegerProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    IntegerProperty ， ReadOnlyIntegerPropertyBase

    public abstract class ReadOnlyIntegerProperty
extends IntegerExpression
implements ReadOnlyProperty<Number>
    所有readonly属性的超类包装一个 int 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableIntegerValue ， IntegerExpression ， ReadOnlyProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyIntegerProperty​()
      构造函数为 ReadOnlyIntegerProperty 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Integer> asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyIntegerProperty 。
      static <T extends Number>
      ReadOnlyIntegerProperty             		readOnlyIntegerProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyIntegerProperty ，其中包含一个ReadOnlyProperty 。
      String toString​()
      返回此 ReadOnlyIntegerProperty对象的字符串表示形式。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableIntegerValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyIntegerProperty

        public ReadOnlyIntegerProperty​()
        构造函数为 ReadOnlyIntegerProperty 。

    • 方法详细信息

      • toString

        public String toString​()
        返回此 ReadOnlyIntegerProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ReadOnlyIntegerProperty对象的字符串表示形式。

      • readOnlyIntegerProperty

        public static <T extends Number> ReadOnlyIntegerProperty readOnlyIntegerProperty​(ReadOnlyProperty<T> property)
        返回一个ReadOnlyIntegerProperty ，其中包含一个ReadOnlyProperty 。 如果ReadOnlyProperty已经是ReadOnlyIntegerProperty ，它将被返回。 否则将创建一个新的ReadOnlyIntegerProperty绑定到ReadOnlyProperty 。 注意：空值将被解释为0
        参数类型
        T - 要包装的数字的类型
        参数
        property - 来源 ReadOnlyProperty
        结果
        一个 ReadOnlyIntegerProperty包装了 ReadOnlyProperty如果有必要
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0

      • asObject

        public ReadOnlyObjectProperty<Integer> asObject​()
        创建一个ReadOnlyObjectProperty ，其值为ReadOnlyIntegerProperty 。 如果这个值ReadOnlyIntegerProperty的变化，价值ReadOnlyObjectProperty将自动更新。
        重写：
        asObject在 IntegerExpression
        结果
        新的 ReadOnlyObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyIntegerPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyIntegerPropertyBase

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
          • javafx.beans.property.ReadOnlyIntegerPropertyBase
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    ReadOnlyJavaBeanIntegerProperty

    public abstract class ReadOnlyIntegerPropertyBase
extends ReadOnlyIntegerProperty
    所有只读属性的基类包装一个int 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ReadOnlyIntegerProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyIntegerPropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableIntegerValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerProperty

        asObject, readOnlyIntegerProperty, toString

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyIntegerPropertyBase

        public ReadOnlyIntegerPropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyIntegerWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyIntegerWrapper

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
          • javafx.beans.property.IntegerProperty
            • javafx.beans.property.IntegerPropertyBase
              • javafx.beans.property.SimpleIntegerProperty
                • javafx.beans.property.ReadOnlyIntegerWrapper
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableIntegerValue ， WritableNumberValue ， WritableValue<Number>

    public class ReadOnlyIntegerWrapper
extends SimpleIntegerProperty
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyIntegerWrapper​()
      构造函数为 ReadOnlyIntegerWrapper
      ReadOnlyIntegerWrapper​(int initialValue)
      构造函数为 ReadOnlyIntegerWrapper
      ReadOnlyIntegerWrapper​(Object bean, String name)
      构造函数为 ReadOnlyIntegerWrapper
      ReadOnlyIntegerWrapper​(Object bean, String name, int initialValue)
      构造函数为 ReadOnlyIntegerWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      ReadOnlyIntegerProperty getReadOnlyProperty​()
      返回readonly属性，与该 ReadOnlyIntegerWrapper同步。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.IntegerProperty

        asObject, bindBidirectional, integerProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.IntegerPropertyBase

        addListener, addListener, bind, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerProperty

        readOnlyIntegerProperty

      • Methods inherited from class javafx.beans.property.SimpleIntegerProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlyIntegerWrapper

        public ReadOnlyIntegerWrapper​()
        构造函数为 ReadOnlyIntegerWrapper

      • ReadOnlyIntegerWrapper

        public ReadOnlyIntegerWrapper​(int initialValue)
        构造函数为 ReadOnlyIntegerWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlyIntegerWrapper

        public ReadOnlyIntegerWrapper​(Object bean,
                              String name)
        构造函数为 ReadOnlyIntegerWrapper
        参数
        bean - 这个 ReadOnlyIntegerProperty的豆
        name - 这个名字 ReadOnlyIntegerProperty

      • ReadOnlyIntegerWrapper

        public ReadOnlyIntegerWrapper​(Object bean,
                              String name,
                              int initialValue)
        构造函数为 ReadOnlyIntegerWrapper
        参数
        bean - 这个 ReadOnlyIntegerProperty的豆
        name - 这个名字 ReadOnlyIntegerProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlyIntegerProperty getReadOnlyProperty​()
        返回readonly属性，该属性与此 ReadOnlyIntegerWrapper同步。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 通过调用IntegerPropertyBase.set(int)手动或绑定属性的情况下，如果绑定变为无效，则调用此方法。
        重写：
        fireValueChangedEvent中的 IntegerPropertyBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyListProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyListProperty<E>

  • java.lang.Object
    • javafx.beans.binding.ListExpression<E>
      • javafx.beans.property.ReadOnlyListProperty<E>
  • 参数类型
    E - List元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， ReadOnlyProperty<ObservableList<E>> ， ObservableListValue<E> ， ObservableObjectValue<E> ， ObservableValue<E> ， ObservableList<E>
    已知直接子类：
    ListProperty ， ReadOnlyListPropertyBase

    public abstract class ReadOnlyListProperty<E>
extends ListExpression<E>
implements ReadOnlyProperty<ObservableList<E>>
    超类为所有只读属性包装一个ObservableList 。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableList ， ObservableListValue ， ListExpression ， ReadOnlyProperty

    • Property Summary

      • Properties inherited from class javafx.beans.binding.ListExpression

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyListProperty​()
      构造函数为 ReadOnlyListProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bindContent​(ObservableList<E> list)
      在ObservableList之间创建一个内容绑定，这是包装在这个ReadOnlyListProperty和另一个ObservableList 。
      void bindContentBidirectional​(ObservableList<E> list)
      创建一个双向内容绑定的ObservableList ，即包装在这个ReadOnlyListProperty ，另外ObservableList 。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回此 ReadOnlyListProperty对象的字符串表示形式。
      void unbindContent​(Object object)
      删除ObservableList之间的内容绑定，即包含在这个ReadOnlyListProperty ，另外Object 。
      void unbindContentBidirectional​(Object object)
      删除ObservableList之间的双向内容绑定，即包含在这个ReadOnlyListProperty ，另外Object 。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        of, of, of, of, of, of, of, of, of, of, of, of, replaceAll, sort, spliterator

      • Methods inherited from class javafx.beans.binding.ListExpression

        add, add, addAll, addAll, addAll, asString, clear, contains, containsAll, emptyProperty, get, getSize, getValue, indexOf, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, lastIndexOf, listExpression, listIterator, listIterator, remove, remove, remove, removeAll, removeAll, retainAll, retainAll, set, setAll, setAll, size, sizeProperty, subList, toArray, toArray, valueAt, valueAt

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableList

        addListener, filtered, removeListener, sorted, sorted

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyListProperty

        public ReadOnlyListProperty​()
        构造函数为 ReadOnlyListProperty 。

    • 方法详细信息

      • bindContentBidirectional

        public void bindContentBidirectional​(ObservableList<E> list)
        创建ObservableList的双向内容绑定，即包含在这个ReadOnlyListProperty ，另外ObservableList 。

        双向内容绑定确保两个ObservableLists的内容相同。 如果其中一个列表的内容发生变化，另一个列表的内容将自动更新。

        参数
        list - 这个属性应该绑定到 ObservableList
        异常
        NullPointerException - 如果 list是 null
        IllegalArgumentException - 如果 list是这个 ReadOnlyListProperty指向的同一个列表

      • unbindContentBidirectional

        public void unbindContentBidirectional​(Object object)
        删除ObservableList之间的双向内容绑定，即包含在这个ReadOnlyListProperty ，另外Object 。
        参数
        object - 应删除双向绑定的 Object
        异常
        NullPointerException - 如果 object是 null
        IllegalArgumentException - 如果 object是这个 ReadOnlyListProperty指向的同一个列表

      • bindContent

        public void bindContent​(ObservableList<E> list)
        创建ObservableList之间的内容绑定，即包含在这个ReadOnlyListProperty ，另外ObservableList 。

        内容绑定确保包装ObservableLists的内容与其他列表的内容相同。 如果其他列表的内容更改，包装列表将自动更新。 一旦封装的列表绑定到另一个列表，您不能直接更改它。

        参数
        list - 这个属性应该绑定到 ObservableList
        异常
        NullPointerException - 如果 list是 null
        IllegalArgumentException - 如果 list是这个 ReadOnlyListProperty指向的同一个列表

      • unbindContent

        public void unbindContent​(Object object)
        删除ObservableList之间的内容绑定，即包含在这个ReadOnlyListProperty ，另外Object 。
        参数
        object - 应该删除绑定的 Object
        异常
        NullPointerException - 如果 object是 null
        IllegalArgumentException - 如果 object是这个 ReadOnlyListProperty指向的同一个列表

      • equals

        public boolean equals​(Object obj)
        描述从类复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用同一对象（ x == y具有值true ）时，此方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        Specified by:
        equals接口 Collection<E>
        Specified by:
        equals在接口 List<E>
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如由HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每一个上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        Specified by:
        hashCode在接口 Collection<E>
        Specified by:
        hashCode在接口 List<E>
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此 ReadOnlyListProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of this ReadOnlyListProperty object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyListPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyListPropertyBase<E>

  • java.lang.Object
    • javafx.beans.binding.ListExpression<E>
      • javafx.beans.property.ReadOnlyListProperty<E>
        • javafx.beans.property.ReadOnlyListPropertyBase<E>
  • All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， ReadOnlyProperty<E> ， ObservableListValue<E> ， ObservableObjectValue<E> ， ObservableValue<E> ， ObservableList<E>

    public abstract class ReadOnlyListPropertyBase<E>
extends ReadOnlyListProperty<E>
    所有只读属性的基类包装一个ObservableList 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyListProperty

    • Property Summary

      • Properties inherited from class javafx.beans.binding.ListExpression

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyListPropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ChangeListener<? super ObservableList<E>> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void addListener​(ListChangeListener<? super E> listener)
      将侦听器添加到此可观察列表中。
      protected void fireValueChangedEvent​()
      如果对ObservableList的引用发生变化，则需要调用此方法。
      protected void fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)
      如果参考ObservableList的内容发生变化，则需要调用此方法。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super ObservableList<E>> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void removeListener​(ListChangeListener<? super E> listener)
      尝试从此可观察列表中删除侦听器。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        of, of, of, of, of, of, of, of, of, of, of, of, replaceAll, sort, spliterator

      • Methods inherited from class javafx.beans.binding.ListExpression

        add, add, addAll, addAll, addAll, asString, clear, contains, containsAll, emptyProperty, get, getSize, getValue, indexOf, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, lastIndexOf, listExpression, listIterator, listIterator, remove, remove, remove, removeAll, removeAll, retainAll, retainAll, set, setAll, setAll, size, sizeProperty, subList, toArray, toArray, valueAt, valueAt

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.collections.ObservableList

        filtered, sorted, sorted

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyListProperty

        bindContent, bindContentBidirectional, equals, hashCode, toString, unbindContent, unbindContentBidirectional

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyListPropertyBase

        public ReadOnlyListPropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从界面Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super ObservableList<E>> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后拨打removeListener或使用WeakChangeListener的实例取消注册监听器，以避免此情况。

        参数
        listener - 要注册的听众
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super ObservableList<E>> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值更改时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(ListChangeListener<? super E> listener)
        描述从接口ObservableList复制
        将侦听器添加到此可观察列表中。
        参数
        listener - 用于监听列表更改的监听器

      • removeListener

        public void removeListener​(ListChangeListener<? super E> listener)
        说明从接口ObservableList复制
        尝试从此可观察列表中删除侦听器。 如果监听者没有附加到此列表中，则不会发生任何事情。
        参数
        listener - 要删除的侦听器

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        如果对ObservableList的引用发生变化，则需要调用此方法。 它发出通知所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。 如果此属性的值更改，则需要调用此方法。

      • fireValueChangedEvent

        protected void fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)
        如果引用的内容ObservableList的内容发生变化，则需要调用此方法。 发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。 当列表的内容更改时调用此方法。
        参数
        change - the change that needs to be propagated
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyListWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyListWrapper<E>

  • java.lang.Object
    • javafx.beans.binding.ListExpression<E>
      • javafx.beans.property.ReadOnlyListProperty<E>
        • javafx.beans.property.ListProperty<E>
          • javafx.beans.property.ListPropertyBase<E>
            • javafx.beans.property.SimpleListProperty<E>
              • javafx.beans.property.ReadOnlyListWrapper<E>
  • All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， Property<E> ， ReadOnlyProperty<E> ， ObservableListValue<E> ， ObservableObjectValue<E> ， ObservableValue<E> ， WritableListValue<E> ， WritableObjectValue<E> ， WritableValue<E> ， ObservableList<E>

    public class ReadOnlyListWrapper<E>
extends SimpleListProperty<E>
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      • Properties inherited from class javafx.beans.property.ListPropertyBase

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyListWrapper​()
      构造函数为 ReadOnlyListWrapper
      ReadOnlyListWrapper​(Object bean, String name)
      构造函数为 ReadOnlyListWrapper
      ReadOnlyListWrapper​(Object bean, String name, ObservableList<E> initialValue)
      构造函数为 ReadOnlyListWrapper
      ReadOnlyListWrapper​(ObservableList<E> initialValue)
      构造函数为 ReadOnlyListWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。
      protected void fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。
      ReadOnlyListProperty<E> getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyListWrapper同步。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, size, sort, spliterator, subList, toArray, toArray

      • Methods inherited from class javafx.beans.binding.ListExpression

        add, add, addAll, addAll, addAll, asString, clear, contains, containsAll, get, getSize, getValue, indexOf, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, lastIndexOf, listExpression, listIterator, listIterator, remove, remove, remove, removeAll, removeAll, retainAll, retainAll, set, setAll, setAll, size, subList, toArray, toArray, valueAt, valueAt

      • Methods inherited from class javafx.beans.property.ListProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ListPropertyBase

        addListener, addListener, addListener, bind, emptyProperty, get, invalidated, isBound, removeListener, removeListener, removeListener, set, sizeProperty, toString, unbind

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.collections.ObservableList

        addAll, filtered, remove, removeAll, retainAll, setAll, setAll, sorted, sorted

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyListProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from class javafx.beans.property.SimpleListProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlyListWrapper

        public ReadOnlyListWrapper​()
        构造函数为 ReadOnlyListWrapper

      • ReadOnlyListWrapper

        public ReadOnlyListWrapper​(ObservableList<E> initialValue)
        构造函数为 ReadOnlyListWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlyListWrapper

        public ReadOnlyListWrapper​(Object bean,
                           String name)
        构造函数为 ReadOnlyListWrapper
        参数
        bean - 这个 ReadOnlyListWrapper的豆
        name - 这个名字 ReadOnlyListWrapper

      • ReadOnlyListWrapper

        public ReadOnlyListWrapper​(Object bean,
                           String name,
                           ObservableList<E> initialValue)
        构造函数为 ReadOnlyListWrapper
        参数
        bean - 这个 ReadOnlyListWrapper的豆
        name - 这个名字 ReadOnlyListWrapper
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlyListProperty<E> getReadOnlyProperty​()
        返回readonly属性，该属性与此 ReadOnlyListWrapper同步。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。 通过调用ListPropertyBase.set(ObservableList)手动或绑定属性的情况下，如果绑定变为无效，则调用此方法。
        重写：
        fireValueChangedEvent中的 ListPropertyBase<E>

      • fireValueChangedEvent

        protected void fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。 当列表的内容更改时调用此方法。
        重写：
        fireValueChangedEvent在 ListPropertyBase<E>
        参数
        change - 需要传播的更改
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyLongProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    LongProperty ， ReadOnlyLongPropertyBase

    public abstract class ReadOnlyLongProperty
extends LongExpression
implements ReadOnlyProperty<Number>
    超类为所有只读属性包装一个 long 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableLongValue ， LongExpression ， ReadOnlyProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyLongProperty​()
      构造函数为 ReadOnlyLongProperty 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Long> asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyLongProperty 。
      static <T extends Number>
      ReadOnlyLongProperty             		readOnlyLongProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyLongProperty的ReadOnlyLongProperty 。
      String toString​()
      返回此 ReadOnlyLongProperty对象的字符串表示形式。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableLongValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyLongProperty

        public ReadOnlyLongProperty​()
        构造函数为 ReadOnlyLongProperty 。

    • 方法详细信息

      • toString

        public String toString​()
        返回此 ReadOnlyLongProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ReadOnlyLongProperty对象的字符串表示形式。

      • readOnlyLongProperty

        public static <T extends Number> ReadOnlyLongProperty readOnlyLongProperty​(ReadOnlyProperty<T> property)
        返回一个ReadOnlyLongProperty的ReadOnlyLongProperty 。 如果ReadOnlyProperty已经是ReadOnlyLongProperty ，它将被返回。 否则将创建一个新的ReadOnlyLongProperty绑定到ReadOnlyProperty 。 注意：空值将被解释为0L
        参数类型
        T - 要包装的数字的类型
        参数
        property - 来源 ReadOnlyProperty
        结果
        一个 ReadOnlyLongProperty包装了 ReadOnlyProperty如果有必要
        异常
        NullPointerException - 如果 property是 null
        从以下版本开始：
        JavaFX 8.0

      • asObject

        public ReadOnlyObjectProperty<Long> asObject​()
        创建一个ReadOnlyObjectProperty ，其值为ReadOnlyLongProperty 。 如果这个值ReadOnlyLongProperty的变化，价值ReadOnlyObjectProperty将自动更新。
        重写：
        asObject在 LongExpression
        结果
        新的 ReadOnlyObjectProperty
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyLongPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyLongPropertyBase

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
          • javafx.beans.property.ReadOnlyLongPropertyBase
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number>
    已知直接子类：
    ReadOnlyJavaBeanLongProperty

    public abstract class ReadOnlyLongPropertyBase
extends ReadOnlyLongProperty
    所有只读属性的基类包装一个long 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ReadOnlyLongProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyLongPropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableLongValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyLongProperty

        asObject, readOnlyLongProperty, toString

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyLongPropertyBase

        public ReadOnlyLongPropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对监听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或使用WeakInvalidationListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时，它们将被通知。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        说明从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyLongWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyLongWrapper

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
          • javafx.beans.property.LongProperty
            • javafx.beans.property.LongPropertyBase
              • javafx.beans.property.SimpleLongProperty
                • javafx.beans.property.ReadOnlyLongWrapper
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableLongValue ， WritableNumberValue ， WritableValue<Number>

    public class ReadOnlyLongWrapper
extends SimpleLongProperty
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyLongWrapper​()
      构造函数为 ReadOnlyLongWrapper
      ReadOnlyLongWrapper​(long initialValue)
      构造函数为 ReadOnlyLongWrapper
      ReadOnlyLongWrapper​(Object bean, String name)
      构造函数为 ReadOnlyLongWrapper
      ReadOnlyLongWrapper​(Object bean, String name, long initialValue)
      构造函数为 ReadOnlyLongWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      ReadOnlyLongProperty getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyLongWrapper同步。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.LongProperty

        asObject, bindBidirectional, longProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.LongPropertyBase

        addListener, addListener, bind, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyLongProperty

        readOnlyLongProperty

      • Methods inherited from class javafx.beans.property.SimpleLongProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlyLongWrapper

        public ReadOnlyLongWrapper​()
        构造函数为 ReadOnlyLongWrapper

      • ReadOnlyLongWrapper

        public ReadOnlyLongWrapper​(long initialValue)
        构造函数 ReadOnlyLongWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlyLongWrapper

        public ReadOnlyLongWrapper​(Object bean,
                           String name)
        构造函数为 ReadOnlyLongWrapper
        参数
        bean - 这个 ReadOnlyLongProperty的豆
        name - 这个 ReadOnlyLongProperty的名字

      • ReadOnlyLongWrapper

        public ReadOnlyLongWrapper​(Object bean,
                           String name,
                           long initialValue)
        构造函数为 ReadOnlyLongWrapper
        参数
        bean - 这个 ReadOnlyLongProperty的豆
        name - 这个 ReadOnlyLongProperty的名字
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlyLongProperty getReadOnlyProperty​()
        返回readonly属性，该属性与此 ReadOnlyLongWrapper同步。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 通过调用LongPropertyBase.set(long)手动或绑定属性的情况下，如果绑定变为无效，则调用此方法。
        重写：
        fireValueChangedEvent在 LongPropertyBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyMapProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyMapProperty<K,V>

  • java.lang.Object
    • javafx.beans.binding.MapExpression<K,V>
      • javafx.beans.property.ReadOnlyMapProperty<K,V>
  • 参数类型
    K - 地图的关键元素的类型
    V - 地图值元素的类型
    All Implemented Interfaces:
    Map<K,V> ， Observable ， ReadOnlyProperty<ObservableMap<K,V>> ， ObservableMapValue<K,V> ， ObservableObjectValue<K> ， ObservableValue<K> ， ObservableMap<K,V>
    已知直接子类：
    MapProperty ， ReadOnlyMapPropertyBase

    public abstract class ReadOnlyMapProperty<K,V>
extends MapExpression<K,V>
implements ReadOnlyProperty<ObservableMap<K,V>>
    超类为所有只读属性包装一个ObservableMap 。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableMap ， ObservableMapValue ， MapExpression ， ReadOnlyProperty

    • Property Summary

      • Properties inherited from class javafx.beans.binding.MapExpression

        empty, size

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyMapProperty​()
      构造函数为 ReadOnlyMapProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bindContent​(ObservableMap<K,V> map)
      在ObservableMap之间创建一个内容绑定，即包含在这个ReadOnlyMapProperty ，另一个是ObservableMap 。
      void bindContentBidirectional​(ObservableMap<K,V> map)
      创建ObservableMap的双向内容绑定，即包含在这个ReadOnlyMapProperty ，另外ObservableMap 。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      int hashCode​()
      返回此 ReadOnlyMapProperty对象的哈希码。
      String toString​()
      返回此 ReadOnlyMapProperty对象的字符串表示形式。
      void unbindContent​(Object object)
      删除ObservableMap之间的内容绑定，即包含在这个ReadOnlyMapProperty ，另外Object 。
      void unbindContentBidirectional​(Object object)
      删除ObservableMap之间的双向内容绑定，即包含在此ReadOnlyMapProperty ，另外Object 。

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, forEach, getOrDefault, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from class javafx.beans.binding.MapExpression

        asString, clear, containsKey, containsValue, emptyProperty, entrySet, get, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, keySet, mapExpression, put, putAll, remove, size, sizeProperty, valueAt, valueAt, values

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableMap

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyMapProperty

        public ReadOnlyMapProperty​()
        构造函数为 ReadOnlyMapProperty 。

    • 方法详细信息

      • bindContentBidirectional

        public void bindContentBidirectional​(ObservableMap<K,V> map)
        创建ObservableMap的双向内容绑定，即包含在这个ReadOnlyMapProperty ，另一个是ObservableMap 。

        双向内容绑定确保两个ObservableMaps的内容相同。 如果其中一个地图的内容发生变化，另一个内容会自动更新。

        参数
        map - 该属性应该绑定到 ObservableMap
        异常
        NullPointerException - 如果 map是 null
        IllegalArgumentException - 如果 map是相同的地图，这 ReadOnlyMapProperty指向

      • unbindContentBidirectional

        public void unbindContentBidirectional​(Object object)
        删除ObservableMap之间的双向内容绑定，即包含在这个ReadOnlyMapProperty ，另外Object 。
        参数
        object - 应删除双向绑定的 Object
        异常
        NullPointerException - 如果 object是 null
        IllegalArgumentException - 如果 object是相同的地图，这 ReadOnlyMapProperty指向

      • bindContent

        public void bindContent​(ObservableMap<K,V> map)
        创建一个内容绑定在ObservableMap之间，即包装在这个ReadOnlyMapProperty ，另外ObservableMap 。

        内容绑定确保包装ObservableMaps的内容与其他地图的内容相同。 如果其他地图的内容发生变化，包装地图将自动更新。 一旦绑定的列表被绑定到另一个地图，你不能直接改变它。

        参数
        map - ObservableMap这个属性应该绑定
        异常
        NullPointerException - 如果 map是 null
        IllegalArgumentException - 如果 map是相同的地图，这 ReadOnlyMapProperty指向

      • unbindContent

        public void unbindContent​(Object object)
        删除ObservableMap之间的内容绑定，即包含在这个ReadOnlyMapProperty ，另外Object 。
        参数
        object - 应该删除绑定的 Object
        异常
        NullPointerException - 如果 object是 null
        IllegalArgumentException - 如果 object是相同的地图，这 ReadOnlyMapProperty指向

      • equals

        public boolean equals​(Object obj)
        描述从类复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，其中规定相等的对象必须具有相等的哈希码。

        Specified by:
        equals在接口 Map<K,V>
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 ReadOnlyMapProperty对象的哈希码。
        Specified by:
        hashCode在接口 Map<K,V>
        重写：
        hashCode在 Object
        结果
        这个 ReadOnlyMapProperty对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此 ReadOnlyMapProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ReadOnlyMapProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyMapPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyMapPropertyBase<K,V>

  • java.lang.Object
    • javafx.beans.binding.MapExpression<K,V>
      • javafx.beans.property.ReadOnlyMapProperty<K,V>
        • javafx.beans.property.ReadOnlyMapPropertyBase<K,V>
  • All Implemented Interfaces:
    Map<K,V> ， Observable ， ReadOnlyProperty<K> ， ObservableMapValue<K,V> ， ObservableObjectValue<K> ， ObservableValue<K> ， ObservableMap<K,V>

    public abstract class ReadOnlyMapPropertyBase<K,V>
extends ReadOnlyMapProperty<K,V>
    所有只读属性的基类包装一个ObservableMap 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyMapProperty

    • Property Summary

      • Properties inherited from class javafx.beans.binding.MapExpression

        empty, size

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyMapPropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void addListener​(MapChangeListener<? super K,? super V> listener)
      添加一个监听器到这个可观察的地图。
      protected void fireValueChangedEvent​()
      如果对ObservableList的引用发生变化，则需要调用此方法。
      protected void fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)
      如果参考的ObservableList的内容发生变化，则需要调用此方法。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void removeListener​(MapChangeListener<? super K,? super V> listener)
      试图从这个可观察的地图中删除一个听众。

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, forEach, getOrDefault, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from class javafx.beans.binding.MapExpression

        asString, clear, containsKey, containsValue, emptyProperty, entrySet, get, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, keySet, mapExpression, put, putAll, remove, size, sizeProperty, valueAt, valueAt, values

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyMapProperty

        bindContent, bindContentBidirectional, equals, hashCode, toString, unbindContent, unbindContentBidirectional

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyMapPropertyBase

        public ReadOnlyMapPropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakInvalidationListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
        说明从界面ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
        说明从界面ObservableValue复制
        从监听器列表中删除给定的监听器，每当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(MapChangeListener<? super K,? super V> listener)
        说明从接口ObservableMap复制
        添加一个监听器到这个可观察的地图。
        参数
        listener - 用于监听列表更改的侦听器

      • removeListener

        public void removeListener​(MapChangeListener<? super K,? super V> listener)
        说明从接口ObservableMap复制
        试图从这个可观察的地图中删除一个听众。 如果听众没有附加到这个地图，没有任何反应。
        参数
        listener - 要删除的侦听器

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        如果对ObservableList的引用发生变化，则需要调用此方法。 它发出通知所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。 如果此属性的值更改，则需要调用此方法。

      • fireValueChangedEvent

        protected void fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)
        如果参考ObservableList的内容发生变化，则需要调用此方法。 发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。 当列表的内容更改时调用此方法。
        参数
        change - the change that needs to be propagated
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyMapWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyMapWrapper<K,V>

  • java.lang.Object
    • javafx.beans.binding.MapExpression<K,V>
      • javafx.beans.property.ReadOnlyMapProperty<K,V>
        • javafx.beans.property.MapProperty<K,V>
          • javafx.beans.property.MapPropertyBase<K,V>
            • javafx.beans.property.SimpleMapProperty<K,V>
              • javafx.beans.property.ReadOnlyMapWrapper<K,V>
  • All Implemented Interfaces:
    Map<K,V> ， Observable ， Property<K> ， ReadOnlyProperty<K> ， ObservableMapValue<K,V> ， ObservableObjectValue<K> ， ObservableValue<K> ， WritableMapValue<K,V> ， WritableObjectValue<K> ， WritableValue<K> ， ObservableMap<K,V>

    public class ReadOnlyMapWrapper<K,V>
extends SimpleMapProperty<K,V>
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      • Properties inherited from class javafx.beans.property.MapPropertyBase

        empty, size

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyMapWrapper​()
      构造函数为 ReadOnlyMapWrapper
      ReadOnlyMapWrapper​(Object bean, String name)
      构造函数为 ReadOnlyMapWrapper
      ReadOnlyMapWrapper​(Object bean, String name, ObservableMap<K,V> initialValue)
      构造函数为 ReadOnlyMapWrapper
      ReadOnlyMapWrapper​(ObservableMap<K,V> initialValue)
      构造函数为 ReadOnlyMapWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。
      protected void fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。
      ReadOnlyMapProperty<K,V> getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyMapWrapper同步。

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entry, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

      • Methods inherited from class javafx.beans.binding.MapExpression

        asString, clear, containsKey, containsValue, entrySet, get, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, keySet, mapExpression, put, putAll, remove, size, valueAt, valueAt, values

      • Methods inherited from class javafx.beans.property.MapProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.MapPropertyBase

        addListener, addListener, addListener, bind, emptyProperty, get, invalidated, isBound, removeListener, removeListener, removeListener, set, sizeProperty, toString, unbind

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyMapProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from class javafx.beans.property.SimpleMapProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlyMapWrapper

        public ReadOnlyMapWrapper​()
        构造函数为 ReadOnlyMapWrapper

      • ReadOnlyMapWrapper

        public ReadOnlyMapWrapper​(ObservableMap<K,V> initialValue)
        构造函数为 ReadOnlyMapWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlyMapWrapper

        public ReadOnlyMapWrapper​(Object bean,
                          String name)
        构造函数为 ReadOnlyMapWrapper
        参数
        bean - 这个 ReadOnlyMapWrapper的豆
        name - 这个名字 ReadOnlyMapWrapper

      • ReadOnlyMapWrapper

        public ReadOnlyMapWrapper​(Object bean,
                          String name,
                          ObservableMap<K,V> initialValue)
        构造函数为 ReadOnlyMapWrapper
        参数
        bean - 这个 ReadOnlyMapWrapper的豆
        name - 这个名字 ReadOnlyMapWrapper
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlyMapProperty<K,V> getReadOnlyProperty​()
        返回readonly属性，该属性与此 ReadOnlyMapWrapper同步。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。 如果绑定变为无效，则通过调用MapPropertyBase.set(javafx.collections.ObservableMap)手动或绑定属性的情况下，调用该方法。
        重写：
        fireValueChangedEvent在 MapPropertyBase<K,V>

      • fireValueChangedEvent

        protected void fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。 当列表的内容更改时调用此方法。
        重写：
        fireValueChangedEvent在 MapPropertyBase<K,V>
        参数
        change - 需要传播的变化
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyObjectProperty<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
  • 参数类型
    T - 包装的类型 Object
    All Implemented Interfaces:
    Observable ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T>
    已知直接子类：
    ObjectProperty ， ReadOnlyObjectPropertyBase

    public abstract class ReadOnlyObjectProperty<T>
extends ObjectExpression<T>
implements ReadOnlyProperty<T>
    超类为所有只读属性包装任意Object 。 对于专门的实现ObservableList ， ObservableSet和ObservableMap也报告集合内的变化，看到ReadOnlyListProperty ， ReadOnlySetProperty和ReadOnlyMapProperty分别。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableObjectValue ， ObjectExpression ， ReadOnlyProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyObjectProperty​()
      构造函数为 ReadOnlyObjectProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回此 ReadOnlyObjectProperty对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyObjectProperty

        public ReadOnlyObjectProperty​()
        构造函数为 ReadOnlyObjectProperty 。

    • 方法详细信息

      • toString

        public String toString​()
        返回此 ReadOnlyObjectProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ReadOnlyObjectProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyObjectPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyObjectPropertyBase<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
        • javafx.beans.property.ReadOnlyObjectPropertyBase<T>
  • 参数类型
    T - 包装的类型 Object
    All Implemented Interfaces:
    Observable ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T>
    已知直接子类：
    ReadOnlyJavaBeanObjectProperty

    public abstract class ReadOnlyObjectPropertyBase<T>
extends ReadOnlyObjectProperty<T>
    所有只读属性的基类包装任意Object 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ReadOnlyObjectProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyObjectPropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super T> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的侦听器，每当 Observable的值变为无效时通知它。
      void removeListener​(ChangeListener<? super T> listener)
      从监听器列表中删除给定的侦听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyObjectProperty

        toString

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 构造方法详细信息

      • ReadOnlyObjectPropertyBase

        public ReadOnlyObjectPropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super T> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super T> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，每当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyObjectWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyObjectWrapper<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
        • javafx.beans.property.ObjectProperty<T>
          • javafx.beans.property.ObjectPropertyBase<T>
            • javafx.beans.property.SimpleObjectProperty<T>
              • javafx.beans.property.ReadOnlyObjectWrapper<T>
  • All Implemented Interfaces:
    Observable ， Property<T> ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T> ， WritableObjectValue<T> ， WritableValue<T>

    public class ReadOnlyObjectWrapper<T>
extends SimpleObjectProperty<T>
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyObjectWrapper​()
      构造函数为 ReadOnlyObjectWrapper
      ReadOnlyObjectWrapper​(Object bean, String name)
      构造函数为 ReadOnlyObjectWrapper
      ReadOnlyObjectWrapper​(Object bean, String name, T initialValue)
      构造函数为 ReadOnlyObjectWrapper
      ReadOnlyObjectWrapper​(T initialValue)
      构造函数为 ReadOnlyObjectWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      ReadOnlyObjectProperty<T> getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyObjectWrapper同步。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from class javafx.beans.property.ObjectProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ObjectPropertyBase

        addListener, addListener, bind, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.SimpleObjectProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlyObjectWrapper

        public ReadOnlyObjectWrapper​()
        构造函数为 ReadOnlyObjectWrapper

      • ReadOnlyObjectWrapper

        public ReadOnlyObjectWrapper​(T initialValue)
        构造函数为 ReadOnlyObjectWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlyObjectWrapper

        public ReadOnlyObjectWrapper​(Object bean,
                             String name)
        构造函数为 ReadOnlyObjectWrapper
        参数
        bean - 这个 ReadOnlyObjectProperty的豆
        name - 这个 ReadOnlyObjectProperty的名字

      • ReadOnlyObjectWrapper

        public ReadOnlyObjectWrapper​(Object bean,
                             String name,
                             T initialValue)
        构造函数为 ReadOnlyObjectWrapper
        参数
        bean - 这个 ReadOnlyObjectProperty的豆
        name - 这个名字 ReadOnlyObjectProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlyObjectProperty<T> getReadOnlyProperty​()
        返回readonly属性，该属性与此 ReadOnlyObjectWrapper同步。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 当该值被更改时，通过调用ObjectPropertyBase.set(T)手动调用该方法，或者如果绑定变为无效，则调用该绑定属性。
        重写：
        fireValueChangedEvent在 ObjectPropertyBase<T>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Interface ReadOnlyProperty<T>

  • 参数类型
    T - 包装值的类型
    All Superinterfaces:
    Observable ， ObservableValue<T>
    All Known Subinterfaces:
    JavaBeanProperty<T> ， Property<T> ， ReadOnlyJavaBeanProperty<T>
    所有已知实现类：
    BooleanProperty ， BooleanPropertyBase ， DoubleProperty ， DoublePropertyBase ， FloatProperty ， FloatPropertyBase ， IntegerProperty ， IntegerPropertyBase ， JavaBeanBooleanProperty ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， JavaBeanObjectProperty ， JavaBeanStringProperty ， ListProperty ， ListPropertyBase ， LongProperty ， LongPropertyBase ， MapProperty ， MapPropertyBase ， ObjectProperty ， ObjectPropertyBase ， ReadOnlyBooleanProperty ， ReadOnlyBooleanPropertyBase ， ReadOnlyBooleanWrapper ， ReadOnlyDoubleProperty ， ReadOnlyDoublePropertyBase ， ReadOnlyDoubleWrapper ， ReadOnlyFloatProperty ， ReadOnlyFloatPropertyBase ， ReadOnlyFloatWrapper ， ReadOnlyIntegerProperty ， ReadOnlyIntegerPropertyBase ， ReadOnlyIntegerWrapper ， ReadOnlyJavaBeanBooleanProperty ， ReadOnlyJavaBeanDoubleProperty ， ReadOnlyJavaBeanFloatProperty ， ReadOnlyJavaBeanIntegerProperty ， ReadOnlyJavaBeanLongProperty ， ReadOnlyJavaBeanObjectProperty ， ReadOnlyJavaBeanStringProperty ， ReadOnlyListProperty ， ReadOnlyListPropertyBase ， ReadOnlyListWrapper ， ReadOnlyLongProperty ， ReadOnlyLongPropertyBase ， ReadOnlyLongWrapper ， ReadOnlyMapProperty ， ReadOnlyMapPropertyBase ， ReadOnlyMapWrapper ， ReadOnlyObjectProperty ， ReadOnlyObjectPropertyBase ， ReadOnlyObjectWrapper ， ReadOnlySetProperty ， ReadOnlySetPropertyBase ReadOnlySetPropertyBase ， ReadOnlySetWrapper ， ReadOnlyStringProperty ， ReadOnlyStringPropertyBase ， ReadOnlyStringWrapper ， SetProperty ， SetPropertyBase ， SimpleBooleanProperty ， SimpleDoubleProperty ， SimpleFloatProperty ， SimpleIntegerProperty ， SimpleListProperty ， SimpleLongProperty ， SimpleMapProperty ， SimpleObjectProperty ， SimpleSetProperty ， SimpleStringProperty ， SimpleStyleableBooleanProperty ， SimpleStyleableDoubleProperty ， SimpleStyleableFloatProperty ， SimpleStyleableIntegerProperty ， SimpleStyleableLongProperty ， SimpleStyleableObjectProperty ， SimpleStyleableStringProperty ， StringProperty ， StringPropertyBase ， StyleableBooleanProperty ， StyleableDoubleProperty ， StyleableFloatProperty ， StyleableIntegerProperty ， StyleableLongProperty ， StyleableObjectProperty ， StyleableStringProperty

    public interface ReadOnlyProperty<T>
extends ObservableValue<T>
    通用接口，用于定义独立于其类型的所有可读属性通用的方法。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • getBean

        Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        结果
        该名称或空的 String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlySetProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlySetProperty<E>

  • java.lang.Object
    • javafx.beans.binding.SetExpression<E>
      • javafx.beans.property.ReadOnlySetProperty<E>
  • 参数类型
    E - Set元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Set<E> ， Observable ， ReadOnlyProperty<ObservableSet<E>> ， ObservableObjectValue<E> ， ObservableSetValue<E> ， ObservableValue<E> ， ObservableSet<E>
    已知直接子类：
    ReadOnlySetPropertyBase ， SetProperty

    public abstract class ReadOnlySetProperty<E>
extends SetExpression<E>
implements ReadOnlyProperty<ObservableSet<E>>
    所有readonly属性的超类包装一个ObservableSet 。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableSet ， ObservableSetValue ， SetExpression ， ReadOnlyProperty

    • Property Summary

      • Properties inherited from class javafx.beans.binding.SetExpression

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlySetProperty​()
      构造函数为 ReadOnlySetProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bindContent​(ObservableSet<E> set)
      创建ObservableSet之间的内容绑定，即包装在这个ReadOnlySetProperty ，另外ObservableSet 。
      void bindContentBidirectional​(ObservableSet<E> set)
      创建一个双向内容绑定的ObservableSet ，即包装在这个ReadOnlySetProperty和另一个ObservableSet 。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      int hashCode​()
      返回此 ReadOnlySetProperty对象的哈希码。
      String toString​()
      返回此 ReadOnlySetProperty对象的字符串表示形式。
      void unbindContent​(Object object)
      删除ObservableSet之间的内容绑定，即包含在这个ReadOnlySetProperty和另一个Object 。
      void unbindContentBidirectional​(Object object)
      删除ObservableSet之间的双向内容绑定，即包含在此ReadOnlySetProperty和另一个Object 。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.collections.ObservableSet

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface java.util.Set

        of, of, of, of, of, of, of, of, of, of, of, of, spliterator

      • Methods inherited from class javafx.beans.binding.SetExpression

        add, addAll, asString, clear, contains, containsAll, emptyProperty, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, remove, removeAll, retainAll, setExpression, size, sizeProperty, toArray, toArray

    • 构造方法详细信息

      • ReadOnlySetProperty

        public ReadOnlySetProperty​()
        构造函数为 ReadOnlySetProperty 。

    • 方法详细信息

      • bindContentBidirectional

        public void bindContentBidirectional​(ObservableSet<E> set)
        创建一个双向内容绑定的ObservableSet ，即包装在这个ReadOnlySetProperty ，另外ObservableSet 。

        双向内容绑定确保两个ObservableSets的内容相同。 如果其中一个集合的内容更改，另一个内容将自动更新。

        参数
        set - ObservableSet这个属性应该绑定
        异常
        NullPointerException - 如果 set是 null
        IllegalArgumentException - 如果 set是相同的集合，这 ReadOnlySetProperty指向

      • unbindContentBidirectional

        public void unbindContentBidirectional​(Object object)
        删除ObservableSet之间的双向内容绑定，即包含在此ReadOnlySetProperty ，另一个Object 。
        参数
        object - 应删除双向绑定的 Object
        异常
        NullPointerException - 如果 object是 null
        IllegalArgumentException - 如果 object是相同的集合，这 ReadOnlySetProperty指向

      • bindContent

        public void bindContent​(ObservableSet<E> set)
        创建ObservableSet之间的内容绑定，即包含在这个ReadOnlySetProperty和另一个ObservableSet 。

        内容绑定确保包装的内容ObservableSets与其他集合的内容相同。 如果其他集合的内容更改，包装集将自动更新。 一旦包装的集合绑定到另一个集合，您不能直接更改它。

        参数
        set - ObservableSet这个属性应该绑定
        异常
        NullPointerException - 如果 set是 null
        IllegalArgumentException - 如果 set是这个 ReadOnlySetProperty指向的相同集合

      • unbindContent

        public void unbindContent​(Object object)
        删除ObservableSet之间的内容绑定，即包含在此ReadOnlySetProperty和另一个Object 。
        参数
        object - 应该删除绑定的 Object
        异常
        NullPointerException - 如果 object是 null
        IllegalArgumentException - 如果 object是相同的集合，这 ReadOnlySetProperty指向

      • equals

        public boolean equals​(Object obj)
        描述从类复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        Specified by:
        equals在接口 Collection<E>
        Specified by:
        equals在接口 Set<E>
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 ReadOnlySetProperty对象的哈希码。
        Specified by:
        hashCode在接口 Collection<E>
        Specified by:
        hashCode在接口 Set<E>
        重写：
        hashCode在 Object
        结果
        这个 ReadOnlySetProperty对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此 ReadOnlySetProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ReadOnlySetProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlySetPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlySetPropertyBase<E>

  • java.lang.Object
    • javafx.beans.binding.SetExpression<E>
      • javafx.beans.property.ReadOnlySetProperty<E>
        • javafx.beans.property.ReadOnlySetPropertyBase<E>
  • 参数类型
    E - Set元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Set<E> ， Observable ， ReadOnlyProperty<E> ， ObservableObjectValue<E> ， ObservableSetValue<E> ， ObservableValue<E> ， ObservableSet<E>

    public abstract class ReadOnlySetPropertyBase<E>
extends ReadOnlySetProperty<E>
    所有只读属性的基类包装一个ObservableSet 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlySetProperty

    • Property Summary

      • Properties inherited from class javafx.beans.binding.SetExpression

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlySetPropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super ObservableSet<E>> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void addListener​(SetChangeListener<? super E> listener)
      添加一个监听器到这个可观察的集合。
      protected void fireValueChangedEvent​()
      如果对ObservableSet的引用发生变化，则需要调用此方法。
      protected void fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)
      如果引用的内容ObservableSet的内容发生变化，则需要调用此方法。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super ObservableSet<E>> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void removeListener​(SetChangeListener<? super E> listener)
      试图从这个可观察的集合中删除一个监听器。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from class javafx.beans.property.ReadOnlySetProperty

        bindContent, bindContentBidirectional, equals, hashCode, toString, unbindContent, unbindContentBidirectional

      • Methods inherited from interface java.util.Set

        of, of, of, of, of, of, of, of, of, of, of, of, spliterator

      • Methods inherited from class javafx.beans.binding.SetExpression

        add, addAll, asString, clear, contains, containsAll, emptyProperty, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, remove, removeAll, retainAll, setExpression, size, sizeProperty, toArray, toArray

    • 构造方法详细信息

      • ReadOnlySetPropertyBase

        public ReadOnlySetPropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        说明从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对监听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或者使用WeakInvalidationListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super ObservableSet<E>> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对监听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super ObservableSet<E>> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的侦听器，每当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(SetChangeListener<? super E> listener)
        描述从接口ObservableSet复制
        添加一个监听器到这个可观察的集合。
        参数
        listener - 收听设置更改的收听者

      • removeListener

        public void removeListener​(SetChangeListener<? super E> listener)
        说明从接口ObservableSet复制
        试图从这个可观察的集合中删除一个监听器。 如果监听者没有附加到此列表中，则不会发生任何事情。
        参数
        listener - 要删除的侦听器

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        如果对ObservableSet的引用发生变化，则需要调用此方法。 它发出通知所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。 如果此属性的值更改，则需要调用此方法。

      • fireValueChangedEvent

        protected void fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)
        如果引用的内容ObservableSet的内容发生变化，则需要调用此方法。 发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。 当列表的内容更改时调用此方法。
        参数
        change - 需要传播的变化
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlySetWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlySetWrapper<E>

  • java.lang.Object
    • javafx.beans.binding.SetExpression<E>
      • javafx.beans.property.ReadOnlySetProperty<E>
        • javafx.beans.property.SetProperty<E>
          • javafx.beans.property.SetPropertyBase<E>
            • javafx.beans.property.SimpleSetProperty<E>
              • javafx.beans.property.ReadOnlySetWrapper<E>
  • All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Set<E> ， Observable ， Property<E> ， ReadOnlyProperty<E> ， ObservableObjectValue<E> ， ObservableSetValue<E> ， ObservableValue<E> ， WritableObjectValue<E> ， WritableSetValue<E> ， WritableValue<E> ， ObservableSet<E>

    public class ReadOnlySetWrapper<E>
extends SimpleSetProperty<E>
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      • Properties inherited from class javafx.beans.property.SetPropertyBase

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlySetWrapper​()
      构造函数为 ReadOnlySetWrapper
      ReadOnlySetWrapper​(Object bean, String name)
      构造函数为 ReadOnlySetWrapper
      ReadOnlySetWrapper​(Object bean, String name, ObservableSet<E> initialValue)
      构造函数为 ReadOnlySetWrapper
      ReadOnlySetWrapper​(ObservableSet<E> initialValue)
      构造函数为 ReadOnlySetWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。
      protected void fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。
      ReadOnlySetProperty<E> getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlySetWrapper同步。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlySetProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, spliterator, toArray, toArray

      • Methods inherited from class javafx.beans.binding.SetExpression

        add, addAll, asString, clear, contains, containsAll, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, remove, removeAll, retainAll, setExpression, size, toArray, toArray

      • Methods inherited from class javafx.beans.property.SetProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.SetPropertyBase

        addListener, addListener, addListener, bind, emptyProperty, get, invalidated, isBound, removeListener, removeListener, removeListener, set, sizeProperty, toString, unbind

      • Methods inherited from class javafx.beans.property.SimpleSetProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlySetWrapper

        public ReadOnlySetWrapper​()
        构造函数为 ReadOnlySetWrapper

      • ReadOnlySetWrapper

        public ReadOnlySetWrapper​(ObservableSet<E> initialValue)
        构造函数为 ReadOnlySetWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlySetWrapper

        public ReadOnlySetWrapper​(Object bean,
                          String name)
        构造函数为 ReadOnlySetWrapper
        参数
        bean - 这个 ReadOnlySetWrapper的豆
        name - 这个名字 ReadOnlySetWrapper

      • ReadOnlySetWrapper

        public ReadOnlySetWrapper​(Object bean,
                          String name,
                          ObservableSet<E> initialValue)
        构造函数为 ReadOnlySetWrapper
        参数
        bean - 这个 ReadOnlySetWrapper的豆
        name - 这个名字 ReadOnlySetWrapper
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlySetProperty<E> getReadOnlyProperty​()
        返回readonly属性，与该 ReadOnlySetWrapper同步。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。 通过调用SetPropertyBase.set(javafx.collections.ObservableSet)手动或绑定属性的情况下，如果绑定变为无效，则调用此方法。
        重写：
        fireValueChangedEvent在 SetPropertyBase<E>

      • fireValueChangedEvent

        protected void fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。 当列表的内容更改时调用此方法。
        重写：
        fireValueChangedEvent在 SetPropertyBase<E>
        参数
        change - 需要传播的更改
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyStringProperty

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
  • All Implemented Interfaces:
    Observable ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String>
    已知直接子类：
    ReadOnlyStringPropertyBase ， StringProperty

    public abstract class ReadOnlyStringProperty
extends StringExpression
implements ReadOnlyProperty<String>
    超类为所有只读属性包装一个 String 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableStringValue ， StringExpression ， ReadOnlyProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyStringProperty​()
      构造函数为 ReadOnlyStringProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回此 ReadOnlyStringProperty对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

    • 构造方法详细信息

      • ReadOnlyStringProperty

        public ReadOnlyStringProperty​()
        构造函数为 ReadOnlyStringProperty 。

    • 方法详细信息

      • toString

        public String toString​()
        返回此 ReadOnlyStringProperty对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ReadOnlyStringProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyStringPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyStringPropertyBase

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
        • javafx.beans.property.ReadOnlyStringPropertyBase
  • All Implemented Interfaces:
    Observable ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String>
    已知直接子类：
    ReadOnlyJavaBeanStringProperty

    public abstract class ReadOnlyStringPropertyBase
extends ReadOnlyStringProperty
    所有只读属性的基类包装一个String 。 此类提供了一个默认实现来附加侦听器。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ReadOnlyStringProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyStringPropertyBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super String> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的侦听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super String> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from class javafx.beans.property.ReadOnlyStringProperty

        toString

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

    • 构造方法详细信息

      • ReadOnlyStringPropertyBase

        public ReadOnlyStringPropertyBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变为无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super String> listener)
        说明从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super String> listener)
        说明从界面ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生更改时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyStringWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class ReadOnlyStringWrapper

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
        • javafx.beans.property.StringProperty
          • javafx.beans.property.StringPropertyBase
            • javafx.beans.property.SimpleStringProperty
              • javafx.beans.property.ReadOnlyStringWrapper
  • All Implemented Interfaces:
    Observable ， Property<String> ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String> ， WritableObjectValue<String> ， WritableStringValue ， WritableValue<String>

    public class ReadOnlyStringWrapper
extends SimpleStringProperty
    该类提供了一个方便的类来定义只读属性。 它创建两个同步的属性。 一个属性是只读的，可以传递给外部用户。 另一个属性是可读写的，只能在内部使用。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyStringWrapper​()
      构造函数为 ReadOnlyStringWrapper
      ReadOnlyStringWrapper​(Object bean, String name)
      构造函数为 ReadOnlyStringWrapper
      ReadOnlyStringWrapper​(Object bean, String name, String initialValue)
      构造函数为 ReadOnlyStringWrapper
      ReadOnlyStringWrapper​(String initialValue)
      构造函数为 ReadOnlyStringWrapper

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      ReadOnlyStringProperty getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyStringWrapper同步。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.SimpleStringProperty

        getBean, getName

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

      • Methods inherited from class javafx.beans.property.StringProperty

        bindBidirectional, bindBidirectional, bindBidirectional, setValue, unbindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.property.StringPropertyBase

        addListener, addListener, bind, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • ReadOnlyStringWrapper

        public ReadOnlyStringWrapper​()
        构造函数为 ReadOnlyStringWrapper

      • ReadOnlyStringWrapper

        public ReadOnlyStringWrapper​(String initialValue)
        构造函数为 ReadOnlyStringWrapper
        参数
        initialValue - 包装值的初始值

      • ReadOnlyStringWrapper

        public ReadOnlyStringWrapper​(Object bean,
                             String name)
        构造函数为 ReadOnlyStringWrapper
        参数
        bean - 这个 ReadOnlyStringProperty的豆
        name - 这个名字 ReadOnlyStringProperty

      • ReadOnlyStringWrapper

        public ReadOnlyStringWrapper​(Object bean,
                             String name,
                             String initialValue)
        构造函数为 ReadOnlyStringWrapper
        参数
        bean - 这个 ReadOnlyStringProperty的豆
        name - 这个名字 ReadOnlyStringProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getReadOnlyProperty

        public ReadOnlyStringProperty getReadOnlyProperty​()
        返回readonly属性，该属性与此 ReadOnlyStringWrapper同步。
        结果
        只读属性

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 通过调用StringPropertyBase.set(java.lang.String)手动调用该值，或者如果绑定变为无效，则调用该方法或绑定属性的情况下调用此方法。
        重写：
        fireValueChangedEvent在 StringPropertyBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SetProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SetProperty<E>

  • java.lang.Object
    • javafx.beans.binding.SetExpression<E>
      • javafx.beans.property.ReadOnlySetProperty<E>
        • javafx.beans.property.SetProperty<E>
  • 参数类型
    E - Set元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Set<E> ， Observable ， Property<ObservableSet<E>> ， ReadOnlyProperty<E> ， ObservableObjectValue<E> ， ObservableSetValue<E> ， ObservableValue<E> ， WritableObjectValue<E> ， WritableSetValue<E> ， WritableValue<E> ， ObservableSet<E>
    已知直接子类：
    SetPropertyBase

    public abstract class SetProperty<E>
extends ReadOnlySetProperty<E>
implements Property<ObservableSet<E>>, WritableSetValue<E>
    这个类提供了一个Property的全面实现，包装了一个ObservableSet 。 a的值SetProperty可以获取和设置ObservableObjectValue.get() ， SetExpression.getValue() ， WritableObjectValue.set(Object) ，并setValue(ObservableSet) 。 可以使用Property.bind(javafx.beans.value.ObservableValue)和Property.unbind()绑定和取消绑定一个属性。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建和删除双向绑定。 SetProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableSet ， ObservableSetValue ， WritableSetValue ， ReadOnlySetProperty ， Property

    • Property Summary

      • Properties inherited from class javafx.beans.binding.SetExpression

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      SetProperty​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bindBidirectional​(Property<ObservableSet<E>> other)
      在这个 Property之间创建一个双向绑定。
      void setValue​(ObservableSet<E> v)
      设置包装的值。
      String toString​()
      返回此 SetProperty对象的字符串表示形式。
      void unbindBidirectional​(Property<ObservableSet<E>> other)
      删除此 Property和另一个之间的双向绑定。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.collections.ObservableSet

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from class javafx.beans.property.ReadOnlySetProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, spliterator, toArray, toArray

      • Methods inherited from class javafx.beans.binding.SetExpression

        add, addAll, asString, clear, contains, containsAll, emptyProperty, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, remove, removeAll, retainAll, setExpression, size, sizeProperty, toArray, toArray

      • Methods inherited from interface javafx.beans.value.WritableObjectValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SetProperty

        public SetProperty​()

    • 方法详细信息

      • setValue

        public void setValue​(ObservableSet<E> v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableValue<E>
        参数
        v - 新的价值

      • bindBidirectional

        public void bindBidirectional​(Property<ObservableSet<E>> other)
        在这个Property和另一个之间创建双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<E>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Property<ObservableSet<E>> other)
        删除此Property与另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional在接口 Property<E>
        参数
        other - 其他 Property

      • toString

        public String toString​()
        返回此 SetProperty对象的字符串表示形式。
        重写：
        toString类 ReadOnlySetProperty<E>
        结果
        这个 SetProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SetPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SetPropertyBase<E>

  • java.lang.Object
    • javafx.beans.binding.SetExpression<E>
      • javafx.beans.property.ReadOnlySetProperty<E>
        • javafx.beans.property.SetProperty<E>
          • javafx.beans.property.SetPropertyBase<E>
  • 参数类型
    E - Set元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Set<E> ， Observable ， Property<E> ， ReadOnlyProperty<E> ， ObservableObjectValue<E> ， ObservableSetValue<E> ， ObservableValue<E> ， WritableObjectValue<E> ， WritableSetValue<E> ， WritableValue<E> ， ObservableSet<E>
    已知直接子类：
    SimpleSetProperty

    public abstract class SetPropertyBase<E>
extends SetProperty<E>
    SetPropertyBase类是包装ObservableSet的属性的基类。 它提供除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableSet ， SetProperty

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty empty
      一个布尔属性是 true ，如果该集合是空的。
      ReadOnlyIntegerProperty size
      表示集合大小的整数属性。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SetPropertyBase​()
      构造函数 SetPropertyBase
      SetPropertyBase​(ObservableSet<E> initialValue)
      SetPropertyBase的构造 SetPropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加InvalidationListener ，当Observable无效时，将通知它。
      void addListener​(ChangeListener<? super ObservableSet<E>> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，将通知它。
      void addListener​(SetChangeListener<? super E> listener)
      添加一个监听器到这个可观察的集合。
      void bind​(ObservableValue<? extends ObservableSet<E>> newObservable)
      为此创建一个单向绑定 Property 。
      ReadOnlyBooleanProperty emptyProperty​()
      一个布尔属性是 true ，如果该集合是空的。
      protected void fireValueChangedEvent​()
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。
      protected void fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。
      ObservableSet<E> get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时，它们将被通知。
      void removeListener​(ChangeListener<? super ObservableSet<E>> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      void removeListener​(SetChangeListener<? super E> listener)
      试图从这个可观察的集合中删除一个监听器。
      void set​(ObservableSet<E> newValue)
      设置包装的值。
      ReadOnlyIntegerProperty sizeProperty​()
      表示集合大小的整数属性。
      String toString​()
      返回此 SetPropertyBase对象的字符串表示形式。
      void unbind​()
      删除这个 Property的单向绑定。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from class javafx.beans.property.ReadOnlySetProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, spliterator, toArray, toArray

      • Methods inherited from class javafx.beans.binding.SetExpression

        add, addAll, asString, clear, contains, containsAll, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, remove, removeAll, retainAll, setExpression, size, toArray, toArray

      • Methods inherited from class javafx.beans.property.SetProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • Property Detail

      • size

        public ReadOnlyIntegerProperty sizeProperty
        Specified by:
        sizeProperty在 SetExpression<E>
        另请参见：
        SetExpression.getSize()

      • empty

        public ReadOnlyBooleanProperty emptyProperty
        Specified by:
        emptyProperty在 SetExpression<E>
        另请参见：
        SetExpression.isEmpty()

    • 构造方法详细信息

      • SetPropertyBase

        public SetPropertyBase​()
        构造函数 SetPropertyBase

      • SetPropertyBase

        public SetPropertyBase​(ObservableSet<E> initialValue)
        SetPropertyBase的构造 SetPropertyBase 。
        参数
        initialValue - 包装值的初始值

    • 方法详细信息

      • sizeProperty

        public ReadOnlyIntegerProperty sizeProperty​()
        描述从类复制： SetExpression
        表示集合大小的整数属性。
        Specified by:
        sizeProperty在 SetExpression<E>
        另请参见：
        SetExpression.getSize()

      • emptyProperty

        public ReadOnlyBooleanProperty emptyProperty​()
        描述从类复制： SetExpression
        一个布尔属性是 true ，如果该集合是空的。
        Specified by:
        emptyProperty在 SetExpression<E>
        另请参见：
        SetExpression.isEmpty()

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变为无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super ObservableSet<E>> listener)
        说明从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或者使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super ObservableSet<E>> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(SetChangeListener<? super E> listener)
        说明从界面： ObservableSet复制
        添加一个监听器到这个可观察的集合。
        参数
        listener - 用于收听设置更改的收听者

      • removeListener

        public void removeListener​(SetChangeListener<? super E> listener)
        说明从界面： ObservableSet复制
        试图从这个可观察的集合中删除一个监听器。 如果监听者没有附加到此列表中，则不会发生任何事情。
        参数
        listener - 要删除的侦听器

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。 通过调用set(javafx.collections.ObservableSet)手动或绑定属性的情况下，如果绑定变为无效，则调用此方法。

      • fireValueChangedEvent

        protected void fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)
        发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。 当列表的内容更改时调用此方法。
        参数
        change - 需要传播的更改

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public ObservableSet<E> get​()
        描述从接口WritableObjectValue复制
        获取包装的值。 这必须与从WritableValue.getValue()返回的值相同。

        此方法仅存在于将WritableObjectValue API与WritableBooleanValue和WritableNumberValue的子类对齐

        结果
        当前值

      • set

        public void set​(ObservableSet<E> newValue)
        描述从接口WritableObjectValue复制
        设置包装的值。 应相当于WritableValue.setValue(java.lang.Object)
        参数
        newValue - 新的价值
        另请参见：
        WritableObjectValue.get()

      • isBound

        public boolean isBound​()
        描述从接口Property复制
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property是绑定的， false否则
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends ObservableSet<E>> newObservable)
        描述从接口Property复制
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        newObservable - 可观察到这个 Property应该绑定到。

      • unbind

        public void unbind​()
        说明从接口Property复制
        删除这个Property的单向绑定。 如果Property没有绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 SetPropertyBase对象的字符串表示形式。
        重写：
        toString在 SetProperty<E>
        结果
        这个 SetPropertyBase对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleBooleanProperty

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
        • javafx.beans.property.BooleanProperty
          • javafx.beans.property.BooleanPropertyBase
            • javafx.beans.property.SimpleBooleanProperty
  • All Implemented Interfaces:
    Observable ， Property<Boolean> ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean> ， WritableBooleanValue ， WritableValue<Boolean>
    已知直接子类：
    ReadOnlyBooleanWrapper

    public class SimpleBooleanProperty
extends BooleanPropertyBase
    这个类提供了一个包含 boolean值的Property的全面实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    BooleanPropertyBase

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleBooleanProperty​()
      构造函数为 BooleanProperty
      SimpleBooleanProperty​(boolean initialValue)
      构造函数为 BooleanProperty
      SimpleBooleanProperty​(Object bean, String name)
      构造函数为 BooleanProperty
      SimpleBooleanProperty​(Object bean, String name, boolean initialValue)
      构造函数为 BooleanProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class javafx.beans.property.BooleanProperty

        asObject, bindBidirectional, booleanProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.BooleanPropertyBase

        addListener, addListener, bind, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanProperty

        readOnlyBooleanProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleBooleanProperty

        public SimpleBooleanProperty​()
        构造函数为 BooleanProperty

      • SimpleBooleanProperty

        public SimpleBooleanProperty​(boolean initialValue)
        构造函数为 BooleanProperty
        参数
        initialValue - 包装值的初始值

      • SimpleBooleanProperty

        public SimpleBooleanProperty​(Object bean,
                             String name)
        构造函数为 BooleanProperty
        参数
        bean - 这个 BooleanProperty的豆
        name - 这个名字 BooleanProperty

      • SimpleBooleanProperty

        public SimpleBooleanProperty​(Object bean,
                             String name,
                             boolean initialValue)
        构造函数为 BooleanProperty
        参数
        bean - 这个 BooleanProperty的豆
        name - 这个名字 BooleanProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        结果
        the name or an empty String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleDoubleProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
          • javafx.beans.property.DoubleProperty
            • javafx.beans.property.DoublePropertyBase
              • javafx.beans.property.SimpleDoubleProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableDoubleValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    ReadOnlyDoubleWrapper

    public class SimpleDoubleProperty
extends DoublePropertyBase
    该类提供了一个包含 double值的Property的全面实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    DoublePropertyBase

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleDoubleProperty​()
      构造函数为 DoubleProperty
      SimpleDoubleProperty​(double initialValue)
      构造函数为 DoubleProperty
      SimpleDoubleProperty​(Object bean, String name)
      构造函数为 DoubleProperty
      SimpleDoubleProperty​(Object bean, String name, double initialValue)
      构造函数为 DoubleProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.DoubleProperty

        asObject, bindBidirectional, doubleProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.DoublePropertyBase

        addListener, addListener, bind, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyDoubleProperty

        readOnlyDoubleProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleDoubleProperty

        public SimpleDoubleProperty​()
        构造函数为 DoubleProperty

      • SimpleDoubleProperty

        public SimpleDoubleProperty​(double initialValue)
        构造函数为 DoubleProperty
        参数
        initialValue - 包装值的初始值

      • SimpleDoubleProperty

        public SimpleDoubleProperty​(Object bean,
                            String name)
        构造函数为 DoubleProperty
        参数
        bean - 这个 DoubleProperty的豆
        name - 这个名字 DoubleProperty

      • SimpleDoubleProperty

        public SimpleDoubleProperty​(Object bean,
                            String name,
                            double initialValue)
        构造函数为 DoubleProperty
        参数
        bean - 这个 DoubleProperty的豆
        name - 这个名字 DoubleProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        结果
        the name or an empty String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleFloatProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
          • javafx.beans.property.FloatProperty
            • javafx.beans.property.FloatPropertyBase
              • javafx.beans.property.SimpleFloatProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableFloatValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    ReadOnlyFloatWrapper

    public class SimpleFloatProperty
extends FloatPropertyBase
    该类提供了一个包含 float值的Property的完整实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    FloatPropertyBase

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleFloatProperty​()
      构造函数为 FloatProperty
      SimpleFloatProperty​(float initialValue)
      构造函数为 FloatProperty
      SimpleFloatProperty​(Object bean, String name)
      构造函数为 FloatProperty
      SimpleFloatProperty​(Object bean, String name, float initialValue)
      构造函数为 FloatProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.FloatProperty

        asObject, bindBidirectional, floatProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.FloatPropertyBase

        addListener, addListener, bind, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatProperty

        readOnlyFloatProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleFloatProperty

        public SimpleFloatProperty​()
        构造函数为 FloatProperty

      • SimpleFloatProperty

        public SimpleFloatProperty​(float initialValue)
        构造函数为 FloatProperty
        参数
        initialValue - 包装值的初始值

      • SimpleFloatProperty

        public SimpleFloatProperty​(Object bean,
                           String name)
        构造函数为 FloatProperty
        参数
        bean - 这个 FloatProperty的豆
        name - 这个名字 FloatProperty

      • SimpleFloatProperty

        public SimpleFloatProperty​(Object bean,
                           String name,
                           float initialValue)
        构造函数为 FloatProperty
        参数
        bean - 这个 FloatProperty的豆
        name - 这个名字 FloatProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        结果
        the name or an empty String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleIntegerProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
          • javafx.beans.property.IntegerProperty
            • javafx.beans.property.IntegerPropertyBase
              • javafx.beans.property.SimpleIntegerProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableIntegerValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    ReadOnlyIntegerWrapper

    public class SimpleIntegerProperty
extends IntegerPropertyBase
    该类提供了一个包含 int值的Property的完整实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    IntegerPropertyBase

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleIntegerProperty​()
      构造函数为 IntegerProperty
      SimpleIntegerProperty​(int initialValue)
      构造函数为 IntegerProperty
      SimpleIntegerProperty​(Object bean, String name)
      构造函数为 IntegerProperty
      SimpleIntegerProperty​(Object bean, String name, int initialValue)
      构造函数为 IntegerProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.IntegerProperty

        asObject, bindBidirectional, integerProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.IntegerPropertyBase

        addListener, addListener, bind, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerProperty

        readOnlyIntegerProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleIntegerProperty

        public SimpleIntegerProperty​()
        构造函数为 IntegerProperty

      • SimpleIntegerProperty

        public SimpleIntegerProperty​(int initialValue)
        构造函数为 IntegerProperty
        参数
        initialValue - 包装值的初始值

      • SimpleIntegerProperty

        public SimpleIntegerProperty​(Object bean,
                             String name)
        构造函数为 IntegerProperty
        参数
        bean - 这个 IntegerProperty的豆
        name - 这个名字 IntegerProperty

      • SimpleIntegerProperty

        public SimpleIntegerProperty​(Object bean,
                             String name,
                             int initialValue)
        构造函数为 IntegerProperty
        参数
        bean - 这个 IntegerProperty的豆
        name - 这个名字 IntegerProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        结果
        the name or an empty String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleListProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleListProperty<E>

  • java.lang.Object
    • javafx.beans.binding.ListExpression<E>
      • javafx.beans.property.ReadOnlyListProperty<E>
        • javafx.beans.property.ListProperty<E>
          • javafx.beans.property.ListPropertyBase<E>
            • javafx.beans.property.SimpleListProperty<E>
  • 参数类型
    E - List元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， Property<E> ， ReadOnlyProperty<E> ， ObservableListValue<E> ， ObservableObjectValue<E> ， ObservableValue<E> ， WritableListValue<E> ， WritableObjectValue<E> ， WritableValue<E> ， ObservableList<E>
    已知直接子类：
    ReadOnlyListWrapper

    public class SimpleListProperty<E>
extends ListPropertyBase<E>
    这个类提供了一个包含ObservableList的ObservableList的完整实现。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ListPropertyBase

    • Property Summary

      • Properties inherited from class javafx.beans.property.ListPropertyBase

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleListProperty​()
      构造函数为 SimpleListProperty
      SimpleListProperty​(Object bean, String name)
      构造函数为 SimpleListProperty
      SimpleListProperty​(Object bean, String name, ObservableList<E> initialValue)
      构造函数为 SimpleListProperty
      SimpleListProperty​(ObservableList<E> initialValue)
      构造函数为 SimpleListProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, size, sort, spliterator, subList, toArray, toArray

      • Methods inherited from class javafx.beans.binding.ListExpression

        add, add, addAll, addAll, addAll, asString, clear, contains, containsAll, get, getSize, getValue, indexOf, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, lastIndexOf, listExpression, listIterator, listIterator, remove, remove, remove, removeAll, removeAll, retainAll, retainAll, set, setAll, setAll, size, subList, toArray, toArray, valueAt, valueAt

      • Methods inherited from class javafx.beans.property.ListProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ListPropertyBase

        addListener, addListener, addListener, bind, emptyProperty, fireValueChangedEvent, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, removeListener, set, sizeProperty, toString, unbind

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.collections.ObservableList

        addAll, filtered, remove, removeAll, retainAll, setAll, setAll, sorted, sorted

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyListProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleListProperty

        public SimpleListProperty​()
        构造函数为 SimpleListProperty

      • SimpleListProperty

        public SimpleListProperty​(ObservableList<E> initialValue)
        构造函数为 SimpleListProperty
        参数
        initialValue - 包装值的初始值

      • SimpleListProperty

        public SimpleListProperty​(Object bean,
                          String name)
        构造函数为 SimpleListProperty
        参数
        bean - 这个 SetProperty的豆
        name - 这个名字 SetProperty

      • SimpleListProperty

        public SimpleListProperty​(Object bean,
                          String name,
                          ObservableList<E> initialValue)
        构造函数为 SimpleListProperty
        参数
        bean - 这个 ListProperty的豆
        name - 这个名字 ListProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        结果
        该名称或空的 String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleLongProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
          • javafx.beans.property.LongProperty
            • javafx.beans.property.LongPropertyBase
              • javafx.beans.property.SimpleLongProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableLongValue ， WritableNumberValue ， WritableValue<Number>
    已知直接子类：
    ReadOnlyLongWrapper

    public class SimpleLongProperty
extends LongPropertyBase
    这个类提供了一个包含 long值的Property的全面实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    LongPropertyBase

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleLongProperty​()
      构造函数为 LongProperty
      SimpleLongProperty​(long initialValue)
      构造函数为 LongProperty
      SimpleLongProperty​(Object bean, String name)
      构造函数为 LongProperty
      SimpleLongProperty​(Object bean, String name, long initialValue)
      构造函数为 LongProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.LongProperty

        asObject, bindBidirectional, longProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.LongPropertyBase

        addListener, addListener, bind, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyLongProperty

        readOnlyLongProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleLongProperty

        public SimpleLongProperty​()
        构造函数为 LongProperty

      • SimpleLongProperty

        public SimpleLongProperty​(long initialValue)
        构造函数为 LongProperty
        参数
        initialValue - 包装值的初始值

      • SimpleLongProperty

        public SimpleLongProperty​(Object bean,
                          String name)
        构造函数为 LongProperty
        参数
        bean - 这个 LongProperty的豆
        name - 这个名字 LongProperty

      • SimpleLongProperty

        public SimpleLongProperty​(Object bean,
                          String name,
                          long initialValue)
        构造函数为 LongProperty
        参数
        bean - 这个 LongProperty的豆
        name - 这个名字 LongProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        结果
        the name or an empty String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleMapProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleMapProperty<K,V>

  • java.lang.Object
    • javafx.beans.binding.MapExpression<K,V>
      • javafx.beans.property.ReadOnlyMapProperty<K,V>
        • javafx.beans.property.MapProperty<K,V>
          • javafx.beans.property.MapPropertyBase<K,V>
            • javafx.beans.property.SimpleMapProperty<K,V>
  • 参数类型
    K - K的关键元素的 Map
    V - V的值元素的 Map
    All Implemented Interfaces:
    Map<K,V> ， Observable ， Property<K> ， ReadOnlyProperty<K> ， ObservableMapValue<K,V> ， ObservableObjectValue<K> ， ObservableValue<K> ， WritableMapValue<K,V> ， WritableObjectValue<K> ， WritableValue<K> ， ObservableMap<K,V>
    已知直接子类：
    ReadOnlyMapWrapper

    public class SimpleMapProperty<K,V>
extends MapPropertyBase<K,V>
    这个类提供了一个Property包装一个ObservableMap的完整实现。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    MapPropertyBase

    • Property Summary

      • Properties inherited from class javafx.beans.property.MapPropertyBase

        empty, size

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleMapProperty​()
      构造函数为 SimpleMapProperty
      SimpleMapProperty​(Object bean, String name)
      构造函数为 SimpleMapProperty
      SimpleMapProperty​(Object bean, String name, ObservableMap<K,V> initialValue)
      构造函数为 SimpleMapProperty
      SimpleMapProperty​(ObservableMap<K,V> initialValue)
      构造函数为 SimpleMapProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entry, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

      • Methods inherited from class javafx.beans.binding.MapExpression

        asString, clear, containsKey, containsValue, entrySet, get, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, keySet, mapExpression, put, putAll, remove, size, valueAt, valueAt, values

      • Methods inherited from class javafx.beans.property.MapProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.MapPropertyBase

        addListener, addListener, addListener, bind, emptyProperty, fireValueChangedEvent, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, removeListener, set, sizeProperty, toString, unbind

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyMapProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleMapProperty

        public SimpleMapProperty​()
        构造函数为 SimpleMapProperty

      • SimpleMapProperty

        public SimpleMapProperty​(ObservableMap<K,V> initialValue)
        构造函数为 SimpleMapProperty
        参数
        initialValue - 包装值的初始值

      • SimpleMapProperty

        public SimpleMapProperty​(Object bean,
                         String name)
        构造函数为 SimpleMapProperty
        参数
        bean - 这个 MapProperty的bean
        name - 这个名字 MapProperty

      • SimpleMapProperty

        public SimpleMapProperty​(Object bean,
                         String name,
                         ObservableMap<K,V> initialValue)
        构造函数为 SimpleMapProperty
        参数
        bean - 这个 MapProperty的豆
        name - 这个名字 MapProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性不包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        结果
        的名字或一个空的 String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleObjectProperty<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
        • javafx.beans.property.ObjectProperty<T>
          • javafx.beans.property.ObjectPropertyBase<T>
            • javafx.beans.property.SimpleObjectProperty<T>
  • 参数类型
    T - 包装的类型 Object
    All Implemented Interfaces:
    Observable ， Property<T> ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T> ， WritableObjectValue<T> ， WritableValue<T>
    已知直接子类：
    ReadOnlyObjectWrapper

    public class SimpleObjectProperty<T>
extends ObjectPropertyBase<T>
    这个类提供了一个Property的全面实现，包装任意的Object 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObjectPropertyBase

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleObjectProperty​()
      构造函数为 ObjectProperty
      SimpleObjectProperty​(Object bean, String name)
      构造函数为 ObjectProperty
      SimpleObjectProperty​(Object bean, String name, T initialValue)
      构造函数为 ObjectProperty
      SimpleObjectProperty​(T initialValue)
      构造函数为 ObjectProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from class javafx.beans.property.ObjectProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ObjectPropertyBase

        addListener, addListener, bind, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleObjectProperty

        public SimpleObjectProperty​()
        构造函数为 ObjectProperty

      • SimpleObjectProperty

        public SimpleObjectProperty​(T initialValue)
        构造函数为 ObjectProperty
        参数
        initialValue - 包装值的初始值

      • SimpleObjectProperty

        public SimpleObjectProperty​(Object bean,
                            String name)
        构造函数为 ObjectProperty
        参数
        bean - 这个 ObjectProperty的豆
        name - 这个名字 ObjectProperty

      • SimpleObjectProperty

        public SimpleObjectProperty​(Object bean,
                            String name,
                            T initialValue)
        构造函数为 ObjectProperty
        参数
        bean - 这个 ObjectProperty的豆
        name - 这个名字 ObjectProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        结果
        该名称或空的 String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleSetProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleSetProperty<E>

  • java.lang.Object
    • javafx.beans.binding.SetExpression<E>
      • javafx.beans.property.ReadOnlySetProperty<E>
        • javafx.beans.property.SetProperty<E>
          • javafx.beans.property.SetPropertyBase<E>
            • javafx.beans.property.SimpleSetProperty<E>
  • 参数类型
    E - Set元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， Set<E> ， Observable ， Property<E> ， ReadOnlyProperty<E> ， ObservableObjectValue<E> ， ObservableSetValue<E> ， ObservableValue<E> ， WritableObjectValue<E> ， WritableSetValue<E> ， WritableValue<E> ， ObservableSet<E>
    已知直接子类：
    ReadOnlySetWrapper

    public class SimpleSetProperty<E>
extends SetPropertyBase<E>
    这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    SetPropertyBase

    • Property Summary

      • Properties inherited from class javafx.beans.property.SetPropertyBase

        empty, size

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleSetProperty​()
      构造函数为 SimpleSetProperty
      SimpleSetProperty​(Object bean, String name)
      构造函数为 SimpleSetProperty
      SimpleSetProperty​(Object bean, String name, ObservableSet<E> initialValue)
      构造函数为 SimpleSetProperty
      SimpleSetProperty​(ObservableSet<E> initialValue)
      构造函数为 SimpleSetProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlySetProperty

        bindContent, bindContentBidirectional, equals, hashCode, unbindContent, unbindContentBidirectional

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, spliterator, toArray, toArray

      • Methods inherited from class javafx.beans.binding.SetExpression

        add, addAll, asString, clear, contains, containsAll, getSize, getValue, isEmpty, isEqualTo, isNotEqualTo, isNotNull, isNull, iterator, remove, removeAll, retainAll, setExpression, size, toArray, toArray

      • Methods inherited from class javafx.beans.property.SetProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.SetPropertyBase

        addListener, addListener, addListener, bind, emptyProperty, fireValueChangedEvent, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, removeListener, set, sizeProperty, toString, unbind

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleSetProperty

        public SimpleSetProperty​()
        构造函数为 SimpleSetProperty

      • SimpleSetProperty

        public SimpleSetProperty​(ObservableSet<E> initialValue)
        构造函数为 SimpleSetProperty
        参数
        initialValue - 包装值的初始值

      • SimpleSetProperty

        public SimpleSetProperty​(Object bean,
                         String name)
        构造函数为 SimpleSetProperty
        参数
        bean - 这个 SetProperty的豆
        name - 这个名字 SetProperty

      • SimpleSetProperty

        public SimpleSetProperty​(Object bean,
                         String name,
                         ObservableSet<E> initialValue)
        构造函数为 SimpleSetProperty
        参数
        bean - 这个 SetProperty的豆
        name - 这个名字 SetProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性不包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        结果
        的名字或一个空的 String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class SimpleStringProperty

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
        • javafx.beans.property.StringProperty
          • javafx.beans.property.StringPropertyBase
            • javafx.beans.property.SimpleStringProperty
  • All Implemented Interfaces:
    Observable ， Property<String> ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String> ， WritableObjectValue<String> ， WritableStringValue ， WritableValue<String>
    已知直接子类：
    ReadOnlyStringWrapper

    public class SimpleStringProperty
extends StringPropertyBase
    该类提供了一个包含 String值的Property的全面实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    StringPropertyBase

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleStringProperty​()
      构造函数为 StringProperty
      SimpleStringProperty​(Object bean, String name)
      构造函数为 StringProperty
      SimpleStringProperty​(Object bean, String name, String initialValue)
      构造函数为 StringProperty
      SimpleStringProperty​(String initialValue)
      构造函数为 StringProperty

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

      • Methods inherited from class javafx.beans.property.StringProperty

        bindBidirectional, bindBidirectional, bindBidirectional, setValue, unbindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.property.StringPropertyBase

        addListener, addListener, bind, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, set, toString, unbind

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • SimpleStringProperty

        public SimpleStringProperty​()
        构造函数为 StringProperty

      • SimpleStringProperty

        public SimpleStringProperty​(String initialValue)
        构造函数为 StringProperty
        参数
        initialValue - 包装值的初始值

      • SimpleStringProperty

        public SimpleStringProperty​(Object bean,
                            String name)
        构造函数为 StringProperty
        参数
        bean - 这个 StringProperty的豆
        name - 这个名字 StringProperty

      • SimpleStringProperty

        public SimpleStringProperty​(Object bean,
                            String name,
                            String initialValue)
        构造函数为 StringProperty
        参数
        bean - 这个 StringProperty的豆
        name - 这个名字 StringProperty
        initialValue - 包装值的初始值

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法将返回一个空的String 。
        结果
        the name or an empty String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class StringProperty

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
        • javafx.beans.property.StringProperty
  • All Implemented Interfaces:
    Observable ， Property<String> ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String> ， WritableObjectValue<String> ， WritableStringValue ， WritableValue<String>
    已知直接子类：
    JavaBeanStringProperty ， StringPropertyBase

    public abstract class StringProperty
extends ReadOnlyStringProperty
implements Property<String>, WritableStringValue
    该类提供了一个包含 String值的Property的完整实现。 a的值StringProperty可以获取和设置ObservableObjectValue.get() ， StringExpression.getValue() ， WritableObjectValue.set(Object) ，并setValue(String) 。 可以使用Property.bind(ObservableValue)和Property.unbind()绑定和绑定一个属性。 可以使用bindBidirectional(Property)和unbindBidirectional(Property)创建和删除双向绑定。 StringProperty的上下文可以用ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()读取。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableStringValue ， WritableStringValue ， ReadOnlyStringProperty ， Property

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringProperty​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bindBidirectional​(Property<?> other, Format format)
      在这个 StringProperty和另一个任意属性之间创建双向绑定。
      void bindBidirectional​(Property<String> other)
      在这个 Property之间创建一个双向绑定。
      <T> void bindBidirectional​(Property<T> other, StringConverter<T> converter)
      在这个 StringProperty和另一个任意属性之间创建双向绑定。
      void setValue​(String v)
      设置包装的值。
      String toString​()
      返回此 StringProperty对象的字符串表示形式。
      void unbindBidirectional​(Object other)
      删除此 Property和另一个之间的双向绑定。
      void unbindBidirectional​(Property<String> other)
      删除此 Property和另一个之间的双向绑定。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, isBound, unbind

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

      • Methods inherited from interface javafx.beans.value.WritableObjectValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • StringProperty

        public StringProperty​()

    • 方法详细信息

      • setValue

        public void setValue​(String v)
        设置包装的值。
        Specified by:
        setValue在接口 WritableValue<String>
        参数
        v - 新值

      • bindBidirectional

        public void bindBidirectional​(Property<String> other)
        在这个Property和另一个之间创建双向绑定。 双向绑定与单向绑定无关。 因此，可以向具有双向绑定的属性添加单向绑定，反之亦然。 但是，这种做法是不鼓励的。

        可以有一个属性的多个双向绑定。

        JavaFX双向绑定实现使用弱侦听器。 这意味着双向绑定不会阻止属性被垃圾回收。

        Specified by:
        bindBidirectional在接口 Property<String>
        参数
        other - 其他 Property

      • bindBidirectional

        public void bindBidirectional​(Property<?> other,
                              Format format)
        在这个StringProperty和另一个任意属性之间创建双向绑定。 依赖于实现Format进行转换。
        参数
        other - 其他 Property
        format - Format用于转换此 StringProperty和其他 Property
        异常
        NullPointerException - 如果 other或 format是 null
        IllegalArgumentException - 如果 other是 this
        从以下版本开始：
        JavaFX 2.1

      • bindBidirectional

        public <T> void bindBidirectional​(Property<T> other,
                                  StringConverter<T> converter)
        在这个StringProperty和另一个任意属性之间创建双向绑定。 依赖于实现StringConverter进行转换。
        参数类型
        T - 包装的类型 Object
        参数
        other - 其他 Property
        converter - StringConverter用于转换此 StringProperty和其他 Property
        异常
        NullPointerException - 如果 other或 converter是 null
        IllegalArgumentException - 如果 other是 this
        从以下版本开始：
        JavaFX 2.1

      • unbindBidirectional

        public void unbindBidirectional​(Property<String> other)
        删除此Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。 可以通过第二个属性的调用解除绑定。 此代码将工作：
             property1.bindBirectional(property2);
     property2.unbindBidirectional(property1);
        Specified by:
        unbindBidirectional在接口 Property<String>
        参数
        other - 其他 Property

      • unbindBidirectional

        public void unbindBidirectional​(Object other)
        删除此Property和另一个之间的双向绑定。 如果不存在属性之间的双向绑定，则调用此方法不起作用。
        参数
        other - 其他 Property
        异常
        NullPointerException - 如果 other是 null
        IllegalArgumentException - 如果 other是 this
        从以下版本开始：
        JavaFX 2.1

      • toString

        public String toString​()
        返回此 StringProperty对象的字符串表示形式。
        重写：
        toString中的 ReadOnlyStringProperty
        结果
        这个 StringProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property

Class StringPropertyBase

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
        • javafx.beans.property.StringProperty
          • javafx.beans.property.StringPropertyBase
  • All Implemented Interfaces:
    Observable ， Property<String> ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String> ， WritableObjectValue<String> ， WritableStringValue ， WritableValue<String>
    已知直接子类：
    SimpleStringProperty ， StyleableStringProperty

    public abstract class StringPropertyBase
extends StringProperty
    StringPropertyBase类是包含String值的属性的基类。 它提供了除了ReadOnlyProperty.getBean()和ReadOnlyProperty.getName()方法之外的属性所需的所有功能，必须通过扩展类来实现。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    StringProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringPropertyBase​()
      StringPropertyBase的构造 StringPropertyBase 。
      StringPropertyBase​(String initialValue)
      StringPropertyBase的构造 StringPropertyBase 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super String> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void bind​(ObservableValue<? extends String> newObservable)
      为此 Property创建一个单向绑定。
      protected void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      String get​()
      获取包装的值。
      protected void invalidated​()
      可以覆盖方法 invalidated()以接收无效通知。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super String> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(String newValue)
      设置包装的值。
      String toString​()
      返回此 StringPropertyBase对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

      • Methods inherited from class javafx.beans.property.StringProperty

        bindBidirectional, bindBidirectional, bindBidirectional, setValue, unbindBidirectional, unbindBidirectional

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 构造方法详细信息

      • StringPropertyBase

        public StringPropertyBase​()
        StringPropertyBase的构造 StringPropertyBase 。

      • StringPropertyBase

        public StringPropertyBase​(String initialValue)
        StringPropertyBase的构造 StringPropertyBase 。
        参数
        initialValue - 包装的初始值 String

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        描述从接口Observable复制
        从监听器列表中删除给定的侦听器，每当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super String> listener)
        描述从接口ObservableValue复制
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super String> listener)
        描述从接口ObservableValue复制
        从监听器列表中删除给定的侦听器，每当ObservableValue的值发生更改时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 当该值被更改时，如果绑定变为无效，则通过调用set(java.lang.String)手动调用该方法，或者在绑定属性的情况下调用该方法。

      • invalidated

        protected void invalidated​()
        可以覆盖方法invalidated()以接收无效通知。 这是Objects定义属性的首选选项，因为它需要更少的内存。 默认实现为空。

      • get

        public String get​()
        获取包装的值。 这必须与从WritableValue.getValue()返回的值相同。

        此方法仅存在于将WritableObjectValue API与WritableBooleanValue和WritableNumberValue的子类对齐

        结果
        当前值

      • set

        public void set​(String newValue)
        设置包装的值。 应相当于WritableValue.setValue(java.lang.Object)
        参数
        newValue - 新的价值
        另请参见：
        WritableObjectValue.get()

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        结果
        true如果 Property绑定，否则为 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • bind

        public void bind​(ObservableValue<? extends String> newObservable)
        为此Property创建一个单向绑定。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        参数
        newObservable - 可观察到这个 Property应该绑定到。

      • unbind

        public void unbind​()
        删除此Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • toString

        public String toString​()
        返回此 StringPropertyBase对象的字符串表示形式。
        重写：
        toString在 StringProperty
        结果
        a string representation of this StringPropertyBase object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.beans.property (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.beans.property

  • Packages that use javafx.beans.property
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.application
    提供应用程序生命周期类。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
  • Classes in javafx.beans.property used by javafx.animation
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    DoubleProperty
    这个类定义了一个Property包裹一个double值。
    IntegerProperty
    这个类定义了一个Property包装int值。
    ObjectProperty
    这个类提供了一个Property的全面实现，包含任意的Object 。
    ReadOnlyDoubleProperty
    所有readonly属性的超类包装一个 double 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
  • Classes in javafx.beans.property used by javafx.application
    Class 描述
    ReadOnlyBooleanProperty
    所有readonly属性的超类包装一个 boolean 。
  • Classes in javafx.beans.property used by javafx.beans.binding
    Class 描述
    Property
    通用接口，定义所有（可写）属性共有的方法，与其类型无关。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyIntegerProperty
    超类为所有只读属性包装一个 int 。
  • Classes in javafx.beans.property used by javafx.beans.property
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    BooleanPropertyBase
    BooleanPropertyBase类是包含 boolean值的属性的基类。
    DoubleProperty
    这个类定义了一个Property包装double值。
    DoublePropertyBase
    DoublePropertyBase类是包含 double值的属性的基类。
    FloatProperty
    这个类定义了一个Property包装float值。
    FloatPropertyBase
    FloatPropertyBase类是包含 float值的属性的基类。
    IntegerProperty
    这个类定义了一个包含 int值的int 。
    IntegerPropertyBase
    IntegerPropertyBase类是包含 int值的属性的基类。
    ListProperty
    这个课程提供了一个Property包装一个ObservableList的完整实现。
    ListPropertyBase
    ListPropertyBase类是包装ObservableList的属性的基类。
    LongProperty
    这个类定义了一个Property包装long值。
    LongPropertyBase
    LongPropertyBase类是包含 long值的属性的基类。
    MapProperty
    这个课程提供了一个包含ObservableMap的Property的完整实现。
    MapPropertyBase
    MapPropertyBase类是包装ObservableMap的属性的基类。
    ObjectProperty
    该类提供了一个Property的全面实现，包含任意的Object 。
    ObjectPropertyBase
    ObjectPropertyBase类是包含任意 Object的属性的基类。
    Property
    通用接口，定义所有（可写）属性共有的方法，与其类型无关。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyDoubleProperty
    所有readonly属性的超类包装一个 double 。
    ReadOnlyFloatProperty
    超类为所有只读属性包装一个 float 。
    ReadOnlyIntegerProperty
    所有readonly属性的超类包装一个 int 。
    ReadOnlyListProperty
    超类为所有只读属性包装一个ObservableList 。
    ReadOnlyLongProperty
    超类为所有只读属性包装一个 long 。
    ReadOnlyMapProperty
    所有readonly属性的超类包装一个ObservableMap 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    ReadOnlyProperty
    通用接口，用于定义独立于其类型的所有可读属性通用的方法。
    ReadOnlySetProperty
    超类为所有只读属性包装一个ObservableSet 。
    ReadOnlyStringProperty
    所有readonly属性的超类包装一个 String 。
    SetProperty
    这个类提供了一个Property包装一个ObservableSet的全面实现。
    SetPropertyBase
    SetPropertyBase类是包装ObservableSet的属性的基类。
    SimpleBooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    SimpleDoubleProperty
    这个类提供了一个包含 double值的Property的完整实现。
    SimpleFloatProperty
    这个类提供了一个Property的全面实现，包含一个float值。
    SimpleIntegerProperty
    该类提供了一个包含 int值的Property的完整实现。
    SimpleListProperty
    这个类提供了一个Property的全面实现，包装了一个ObservableList 。
    SimpleLongProperty
    这个类提供了一个包含 long值的Property的全面实现。
    SimpleMapProperty
    这个课程提供了一个Property包装一个ObservableMap的完整实现。
    SimpleObjectProperty
    这个类提供了一个Property的全面实现，包含一个任意的Object 。
    SimpleSetProperty
    这个类提供了一个包含ObservableSet的ObservableSet的完整实现。
    SimpleStringProperty
    该类提供了一个包含 String值的Property的完整实现。
    StringProperty
    这个类提供了一个包含 String值的Property的全面实现。
    StringPropertyBase
    StringPropertyBase类是包含 String值的属性的基类。
  • Classes in javafx.beans.property used by javafx.beans.property.adapter
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的完整实现。
    DoubleProperty
    这个类定义了一个Property包装double值。
    FloatProperty
    这个类定义了一个Property包装float值。
    IntegerProperty
    这个类定义了一个Property包装int值。
    LongProperty
    这个类定义了一个Property包装long值。
    ObjectProperty
    这个类提供了一个包含任意的Object的Property的完整实现。
    Property
    通用接口，定义所有（可写）属性共有的方法，与其类型无关。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyBooleanPropertyBase
    所有只读属性的基类包装一个 boolean 。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyDoublePropertyBase
    所有只读属性的基类包装一个 double 。
    ReadOnlyFloatProperty
    超类为所有只读属性包装一个 float 。
    ReadOnlyFloatPropertyBase
    所有只读属性的基类包装一个 float 。
    ReadOnlyIntegerProperty
    超类为所有只读属性包装一个 int 。
    ReadOnlyIntegerPropertyBase
    所有只读属性的基类包装一个 int 。
    ReadOnlyLongProperty
    超类为所有只读属性包装一个 long 。
    ReadOnlyLongPropertyBase
    所有只读属性的基类包装一个 long 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    ReadOnlyObjectPropertyBase
    所有只读属性的基类包装任意 Object 。
    ReadOnlyProperty
    通用接口，用于定义独立于其类型的所有可读属性通用的方法。
    ReadOnlyStringProperty
    超类为所有只读属性包装一个 String 。
    ReadOnlyStringPropertyBase
    所有只读属性的基类包装一个 String 。
    StringProperty
    该类提供了一个包含 String值的Property的完整实现。
  • Classes in javafx.beans.property used by javafx.collections.transformation
    Class 描述
    ObjectProperty
    这个类提供了一个Property的全面实现，包含任意的Object 。
  • Classes in javafx.beans.property used by javafx.concurrent
    Class 描述
    BooleanProperty
    该类提供了一个包含 boolean值的Property的完整实现。
    IntegerProperty
    这个类定义了一个Property包装int值。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyIntegerProperty
    所有readonly属性的超类包装一个 int 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    ReadOnlyStringProperty
    超类为所有只读属性包装一个 String 。
  • Classes in javafx.beans.property used by javafx.css
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的完整实现。
    BooleanPropertyBase
    BooleanPropertyBase类是包含 boolean值的属性的基类。
    DoubleProperty
    这个类定义了一个Property包装double值。
    DoublePropertyBase
    DoublePropertyBase类是包含 double值的属性的基类。
    FloatProperty
    这个类定义了一个Property包装float值。
    FloatPropertyBase
    FloatPropertyBase类是包含 float值的属性的基类。
    IntegerProperty
    这个类定义了一个Property包装int值。
    IntegerPropertyBase
    IntegerPropertyBase类是包含 int值的属性的基类。
    LongProperty
    这个类定义了一个Property包装long值。
    LongPropertyBase
    LongPropertyBase类是包含 long值的属性的基类。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    ObjectPropertyBase
    ObjectPropertyBase类是包含任意 Object的属性的基类。
    Property
    通用接口，定义所有（可写）属性共有的方法，与其类型无关。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyFloatProperty
    所有readonly属性的超类包装一个 float 。
    ReadOnlyIntegerProperty
    超类为所有只读属性包装一个 int 。
    ReadOnlyLongProperty
    超类为所有只读属性包装一个 long 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    ReadOnlyProperty
    通用接口，用于定义独立于其类型的所有可读属性通用的方法。
    ReadOnlyStringProperty
    超类为所有只读属性包装一个 String 。
    StringProperty
    该类提供了一个包含 String值的Property的全面实现。
    StringPropertyBase
    StringPropertyBase类是包含 String值的属性的基类。
  • Classes in javafx.beans.property used by javafx.print
    Class 描述
    IntegerProperty
    这个类定义了一个包含 int值的int 。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    ReadOnlyIntegerProperty
    所有readonly属性的超类包装一个 int 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    StringProperty
    这个类提供了一个包含 String值的Property的完整实现。
  • Classes in javafx.beans.property used by javafx.scene
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的完整实现。
    DoubleProperty
    这个类定义了一个Property包裹一个double值。
    ObjectProperty
    这个类提供了一个Property的完整实现，包含一个任意的Object 。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    StringProperty
    该类提供了一个包含 String值的Property的完整实现。
  • Classes in javafx.beans.property used by javafx.scene.canvas
    Class 描述
    DoubleProperty
    这个类定义了一个Property包装double值。
  • Classes in javafx.beans.property used by javafx.scene.chart
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    DoubleProperty
    这个类定义了一个Property包装double值。
    IntegerProperty
    这个类定义了一个Property包装int值。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    StringProperty
    这个类提供了一个包含 String值的Property的全面实现。
  • Classes in javafx.beans.property used by javafx.scene.control
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    DoubleProperty
    这个类定义了一个Property包裹一个double值。
    IntegerProperty
    这个类定义了一个包含 int值的int 。
    ObjectProperty
    这个类提供了一个Property的全面实现，包含任意的Object 。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyIntegerProperty
    超类为所有只读属性包装一个 int 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    ReadOnlyStringProperty
    所有readonly属性的超类包装一个 String 。
    StringProperty
    这个类提供了一个包含 String值的Property的全面实现。
  • Classes in javafx.beans.property used by javafx.scene.control.cell
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    ObjectProperty
    这个类提供了一个Property的全面实现，包装任意的Object 。
  • Classes in javafx.beans.property used by javafx.scene.control.skin
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的完整实现。
    DoubleProperty
    这个类定义了一个Property包裹一个double值。
    IntegerProperty
    这个类定义了一个包含 int值的int 。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    ReadOnlyDoubleProperty
    所有readonly属性的超类包装一个 double 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
  • Classes in javafx.beans.property used by javafx.scene.effect
    Class 描述
    BooleanProperty
    该类提供了一个包含 boolean值的Property的完整实现。
    DoubleProperty
    这个类定义了一个Property包装一个double值。
    IntegerProperty
    这个类定义了一个包含 int值的int 。
    ObjectProperty
    这个类提供了一个Property的全面实现，包装任意的Object 。
  • Classes in javafx.beans.property used by javafx.scene.image
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    DoubleProperty
    这个类定义了一个Property包装double值。
    ObjectProperty
    这个类提供了一个Property的全面实现，包含一个任意的Object 。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
  • Classes in javafx.beans.property used by javafx.scene.layout
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的完整实现。
    DoubleProperty
    这个类定义了一个Property包裹一个double值。
    IntegerProperty
    这个类定义了一个包含 int值的int 。
    ObjectProperty
    该类提供了一个包含任意Object的Property的完整实现。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
  • Classes in javafx.beans.property used by javafx.scene.media
    Class 描述
    BooleanProperty
    该类提供了一个包含 boolean值的Property的全面实现。
    DoubleProperty
    这个类定义了一个Property包裹一个double值。
    IntegerProperty
    这个类定义了一个包含 int值的int 。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyIntegerProperty
    超类为所有只读属性包装一个 int 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
  • Classes in javafx.beans.property used by javafx.scene.paint
    Class 描述
    DoubleProperty
    这个类定义了一个Property包裹一个double值。
    ObjectProperty
    这个类提供了一个Property的全面实现，包含任意的Object 。
  • Classes in javafx.beans.property used by javafx.scene.shape
    Class 描述
    BooleanProperty
    该类提供了一个包含 boolean值的Property的完整实现。
    DoubleProperty
    这个类定义了一个Property包装double值。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    StringProperty
    这个类提供了一个包含 String值的Property的全面实现。
  • Classes in javafx.beans.property used by javafx.scene.text
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    DoubleProperty
    这个类定义了一个Property包裹一个double值。
    IntegerProperty
    这个类定义了一个包含 int值的int 。
    ObjectProperty
    这个类提供了一个Property的全面实现，包装任意的Object 。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    StringProperty
    这个类提供了一个包含 String值的Property的完整实现。
  • Classes in javafx.beans.property used by javafx.scene.transform
    Class 描述
    DoubleProperty
    这个类定义了一个Property包装double值。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
  • Classes in javafx.beans.property used by javafx.scene.web
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    DoubleProperty
    这个类定义了一个Property包装double值。
    IntegerProperty
    这个类定义了一个Property包装int值。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyIntegerProperty
    超类为所有只读属性包装一个 int 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    ReadOnlyStringProperty
    所有readonly属性的超类包装一个 String 。
    StringProperty
    这个类提供了一个包含 String值的Property的完整实现。
  • Classes in javafx.beans.property used by javafx.stage
    Class 描述
    BooleanProperty
    这个类提供了一个包含 boolean值的Property的全面实现。
    DoubleProperty
    这个类定义了一个Property包装double值。
    ObjectProperty
    这个类提供了一个包含任意Object的Property的完整实现。
    ReadOnlyBooleanProperty
    超类为所有只读属性包装一个 boolean 。
    ReadOnlyDoubleProperty
    超类为所有只读属性包装一个 double 。
    ReadOnlyObjectProperty
    超类为所有只读属性包装任意 Object 。
    StringProperty
    这个类提供了一个包含 String值的Property的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


JavaBeanBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanBooleanProperty

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
        • javafx.beans.property.BooleanProperty
          • javafx.beans.property.adapter.JavaBeanBooleanProperty
  • All Implemented Interfaces:
    Observable ， JavaBeanProperty<Boolean> ， ReadOnlyJavaBeanProperty<Boolean> ， Property<Boolean> ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean> ， WritableBooleanValue ， WritableValue<Boolean>

    public final class JavaBeanBooleanProperty
extends BooleanProperty
implements JavaBeanProperty<Boolean>
    A JavaBeanBooleanProperty在boolean或Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。 它不能直接创建，但必须使用JavaBeanBooleanPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter和一个setter。 该类，以及getter和setter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果调用setter，该值将被传递给Java Bean属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个JavaBeanBooleanProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。 如果Java Bean属性也受到约束（即它支持VetoableChangeListeners）， JavaBeanBooleanProperty将拒绝更改，如果它绑定到一个ObservableValue<Boolean> 。

    将应用程序部署为模块

    如果Java Bean类在一个命名的模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens包含至少包含javafx.base模块，则类可以反射访问。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包装，则可以反射地访问该类 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    BooleanProperty ， JavaBeanBooleanPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ChangeListener<? super Boolean> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void bind​(ObservableValue<? extends Boolean> observable)
      为此创建一个单向绑定 Property 。
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
      boolean get​()
      获取包装的值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Boolean> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(boolean value)
      设置包装的值。
      String toString​()
      返回此 JavaBeanBooleanProperty对象的字符串表示形式。
      void unbind​()
      删除这个 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class javafx.beans.property.BooleanProperty

        asObject, bindBidirectional, booleanProperty, setValue, unbindBidirectional

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.Property

        bindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanProperty

        readOnlyBooleanProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • get

        public boolean get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始布尔值。 需要与WritableValue.getValue()相同。
        Specified by:
        get在接口 ObservableBooleanValue
        Specified by:
        get在接口 WritableBooleanValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • set

        public void set​(boolean value)
        设置包装的值。 与WritableBooleanValue.setValue(java.lang.Boolean)不同，此方法使用原始布尔。
        Specified by:
        set在接口 WritableBooleanValue
        参数
        value - 新的价值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • bind

        public void bind​(ObservableValue<? extends Boolean> observable)
        为此Property创建一个单向绑定。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<Boolean>
        参数
        observable - 可观察到这个 Property应该绑定到。

      • unbind

        public void unbind​()
        删除这个Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        Specified by:
        unbind在接口 Property<Boolean>
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        Specified by:
        isBound在接口 Property<Boolean>
        结果
        true如果 Property是绑定的， false否则
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性不包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<Boolean>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Boolean>
        结果
        的名字或一个空的 String

      • addListener

        public void addListener​(ChangeListener<? super Boolean> listener)
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 ObservableValue<Boolean>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Boolean> listener)
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener接口 ObservableValue<Boolean>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(InvalidationListener listener)
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对监听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
        Specified by:
        fireValueChangedEvent中的 ReadOnlyJavaBeanProperty<Boolean>

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Boolean>

      • toString

        public String toString​()
        返回此 JavaBeanBooleanProperty对象的字符串表示形式。
        重写：
        toString在 BooleanProperty
        结果
        这个 JavaBeanBooleanProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanBooleanPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanBooleanPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.JavaBeanBooleanPropertyBuilder

  • public final class JavaBeanBooleanPropertyBuilder
extends Object
    A JavaBeanBooleanPropertyBuilder可以用来创建JavaBeanBooleanProperties 。 要创建一个JavaBeanBooleanProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的财产和bean(java.lang.Object)必须指定。 如果getter和setter的名称遵循约定，这就足够了。 否则可以直接指定吸气剂和设定器（ getter(java.lang.String)和setter(java.lang.String) ）或吸气剂和设定器Methods的替代名称（ getter(java.lang.reflect.Method)和setter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的几个实例的同一属性生成适配器，则可以重新使用JavaBeanBooleanPropertyBuilder 。 通过切换Java Bean实例（ bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    JavaBeanBooleanProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      JavaBeanBooleanPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JavaBeanBooleanPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanBooleanPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanBooleanProperty build​()
      使用当前设置生成新的JavaBeanBooleanProperty 。
      static JavaBeanBooleanPropertyBuilder create​()
      创建一个新的实例 JavaBeanBooleanPropertyBuilder
      JavaBeanBooleanPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      JavaBeanBooleanPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanBooleanPropertyBuilder name​(String name)
      设置属性的名称
      JavaBeanBooleanPropertyBuilder setter​(方法 setter)
      直接设置setter方法。
      JavaBeanBooleanPropertyBuilder setter​(String setter)
      为设定者设置一个替代名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JavaBeanBooleanPropertyBuilder

        public JavaBeanBooleanPropertyBuilder​()

    • 方法详细信息

      • create

        public static JavaBeanBooleanPropertyBuilder create​()
        创建一个新的实例 JavaBeanBooleanPropertyBuilder
        结果
        新的 JavaBeanBooleanPropertyBuilder

      • build

        public JavaBeanBooleanProperty build​()
                              throws NoSuchMethodException
        使用当前设置生成新的JavaBeanBooleanProperty 。
        结果
        新的 JavaBeanBooleanProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter和setter
        IllegalArgumentException - 如果Java Bean属性不是类型 boolean或 Boolean

      • name

        public JavaBeanBooleanPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 物业的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public JavaBeanBooleanPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public JavaBeanBooleanPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter和setter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanBooleanPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanBooleanPropertyBuilder setter​(String setter)
        为设定者设置一个替代名称。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设置者的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanBooleanPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanBooleanPropertyBuilder setter​(方法 setter)
        直接设置setter方法。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设定者
        结果
        引用此构建器来启用方法链接
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanDoubleProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
          • javafx.beans.property.DoubleProperty
            • javafx.beans.property.adapter.JavaBeanDoubleProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， JavaBeanProperty<Number> ， ReadOnlyJavaBeanProperty<Number> ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableDoubleValue ， WritableNumberValue ， WritableValue<Number>

    public final class JavaBeanDoubleProperty
extends DoubleProperty
implements JavaBeanProperty<Number>
    A JavaBeanDoubleProperty在类型为double或Double的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。 它不能直接创建，但必须使用JavaBeanDoublePropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter和一个setter。 该类，以及getter和setter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果调用setter，该值将被传递给Java Bean属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个JavaBeanDoubleProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。 如果Java Bean属性也受到约束（即它支持VetoableChangeListeners），则JavaBeanDoubleProperty将拒绝更改，如果它绑定到一个ObservableValue<Double> 。

    将应用程序部署为模块

    如果Java Bean类在一个命名模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens将包含的包至少为javafx.base模块，则可以反射访问类。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    DoubleProperty ， JavaBeanDoublePropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
      double get​()
      获取包装的值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(double value)
      设置包装的值。
      String toString​()
      返回此 JavaBeanDoubleProperty对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.DoubleProperty

        asObject, bindBidirectional, doubleProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.Property

        bindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ReadOnlyDoubleProperty

        readOnlyDoubleProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • get

        public double get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始double。 需要与WritableValue.getValue()相同。
        Specified by:
        get在接口 ObservableDoubleValue
        Specified by:
        get在接口 WritableDoubleValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • set

        public void set​(double value)
        设置包装的值。 与WritableDoubleValue.setValue(java.lang.Number)不同，此方法使用原语双。
        Specified by:
        set在接口 WritableDoubleValue
        参数
        value - 新的价值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • bind

        public void bind​(ObservableValue<? extends Number> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<Number>
        参数
        observable - 可观察到这个 Property应该绑定到。

      • unbind

        public void unbind​()
        删除这个Property的单向绑定。 如果Property没有绑定，则调用此方法没有任何作用。
        Specified by:
        unbind在接口 Property<Number>
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property绑定。
        Specified by:
        isBound在接口 Property<Number>
        结果
        true如果 Property是绑定的，否则 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<Number>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Number>
        结果
        名称或空的 String

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过拨打removeListener取消注册监听器，或使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<Number>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<Number>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(InvalidationListener listener)
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<Number>

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Number>

      • toString

        public String toString​()
        返回此 JavaBeanDoubleProperty对象的字符串表示形式。
        重写：
        toString DoubleProperty
        结果
        这个 JavaBeanDoubleProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanDoublePropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanDoublePropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.JavaBeanDoublePropertyBuilder

  • public final class JavaBeanDoublePropertyBuilder
extends Object
    A JavaBeanDoublePropertyBuilder可以用来创建JavaBeanDoubleProperties 。 要创建一个JavaBeanDoubleProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()来生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的财产和bean(java.lang.Object)必须指定。 如果getter和setter的名称遵循约定，这就足够了。 否则可以直接指定吸气剂和设定器（ getter(java.lang.String)和setter(java.lang.String) ）或吸气剂和设定器Methods的替代名称（ getter(java.lang.reflect.Method)和setter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的几个实例的同一属性生成适配器，则可以重新使用JavaBeanDoublePropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    JavaBeanDoubleProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      JavaBeanDoublePropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JavaBeanDoublePropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanDoublePropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanDoubleProperty build​()
      使用当前设置生成新的JavaBeanDoubleProperty 。
      static JavaBeanDoublePropertyBuilder create​()
      创建一个新的实例 JavaBeanDoublePropertyBuilder
      JavaBeanDoublePropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      JavaBeanDoublePropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanDoublePropertyBuilder name​(String name)
      设置属性的名称
      JavaBeanDoublePropertyBuilder setter​(方法 setter)
      直接设置setter方法。
      JavaBeanDoublePropertyBuilder setter​(String setter)
      为设定者设置一个替代名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JavaBeanDoublePropertyBuilder

        public JavaBeanDoublePropertyBuilder​()

    • 方法详细信息

      • create

        public static JavaBeanDoublePropertyBuilder create​()
        创建一个新的实例 JavaBeanDoublePropertyBuilder
        结果
        新的 JavaBeanDoublePropertyBuilder

      • build

        public JavaBeanDoubleProperty build​()
                             throws NoSuchMethodException
        使用当前设置生成新的JavaBeanDoubleProperty 。
        结果
        新的 JavaBeanDoubleProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter和setter
        IllegalArgumentException - 如果Java Bean属性不是类型 double或 Double

      • name

        public JavaBeanDoublePropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public JavaBeanDoublePropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public JavaBeanDoublePropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter和setter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanDoublePropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanDoublePropertyBuilder setter​(String setter)
        为设定者设置一个替代名称。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设置者的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanDoublePropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanDoublePropertyBuilder setter​(方法 setter)
        直接设置setter方法。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设定者
        结果
        引用此构建器来启用方法链接
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanFloatProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
          • javafx.beans.property.FloatProperty
            • javafx.beans.property.adapter.JavaBeanFloatProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， JavaBeanProperty<Number> ， ReadOnlyJavaBeanProperty<Number> ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableFloatValue ， WritableNumberValue ， WritableValue<Number>

    public final class JavaBeanFloatProperty
extends FloatProperty
implements JavaBeanProperty<Number>
    A JavaBeanFloatProperty在float或Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。 它不能直接创建，但必须使用JavaBeanFloatPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter和一个setter。 该类，以及getter和setter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果调用setter，该值将被传递给Java Bean属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个JavaBeanFloatProperty将会意识到Java Bean中的更改。 否则可通过致电fireValueChangedEvent()通知有关更改。 如果Java Bean属性也受到约束（即它支持VetoableChangeListeners），则JavaBeanFloatProperty将拒绝更改，如果它绑定到一个ObservableValue<Float> 。

    将应用程序部署为模块

    如果Java Bean类在一个命名的模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens将包含的包至少为javafx.base模块，则可以反射访问类。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    FloatProperty ， JavaBeanFloatPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
      float get​()
      获取包装的值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。
      boolean isBound​()
      可以用来检查，如果一个 Property被绑定。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，每当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(float value)
      设置包装的值。
      String toString​()
      返回此 JavaBeanFloatProperty对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.FloatProperty

        asObject, bindBidirectional, floatProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.Property

        bindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatProperty

        readOnlyFloatProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • get

        public float get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始浮点数。 需要与WritableValue.getValue()相同。
        Specified by:
        get在接口 ObservableFloatValue
        Specified by:
        get在接口 WritableFloatValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • set

        public void set​(float value)
        设置包装的值。 与WritableFloatValue.setValue(java.lang.Number)不同，该方法使用原始浮点数。
        Specified by:
        set在接口 WritableFloatValue
        参数
        value - 新值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • bind

        public void bind​(ObservableValue<? extends Number> observable)
        为此Property创建一个单向绑定。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<Number>
        参数
        observable - 可观察这 Property应该绑定。

      • unbind

        public void unbind​()
        删除这个Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        Specified by:
        unbind在接口 Property<Number>
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        Specified by:
        isBound在接口 Property<Number>
        结果
        true如果 Property是绑定的，另外 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<Number>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法将返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Number>
        结果
        该名称或空的 String

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 ObservableValue<Number>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        从监听器列表中删除给定的监听器，每当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<Number>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(InvalidationListener listener)
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销侦听器，或者使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<Number>

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Number>

      • toString

        public String toString​()
        返回此 JavaBeanFloatProperty对象的字符串表示形式。
        重写：
        toString在 FloatProperty
        结果
        这个 JavaBeanFloatProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanFloatPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanFloatPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.JavaBeanFloatPropertyBuilder

  • public final class JavaBeanFloatPropertyBuilder
extends Object
    A JavaBeanFloatPropertyBuilder可以用来创建JavaBeanFloatProperties 。 要创建一个JavaBeanFloatProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的财产和bean(java.lang.Object)必须指定。 如果getter和setter的名称遵循约定，这就足够了。 否则可以直接指定吸气剂和设定器（ getter(java.lang.String)和setter(java.lang.String) ）或吸气剂和设定器Methods的替代名称（ getter(java.lang.reflect.Method)和setter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的几个实例的同一属性生成适配器，则可以重新使用JavaBeanFloatPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    JavaBeanFloatProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      JavaBeanFloatPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JavaBeanFloatPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanFloatPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanFloatProperty build​()
      使用当前设置生成新的JavaBeanFloatProperty 。
      static JavaBeanFloatPropertyBuilder create​()
      创建一个新的实例 JavaBeanFloatPropertyBuilder
      JavaBeanFloatPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      JavaBeanFloatPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanFloatPropertyBuilder name​(String name)
      设置属性的名称
      JavaBeanFloatPropertyBuilder setter​(方法 setter)
      直接设置setter方法。
      JavaBeanFloatPropertyBuilder setter​(String setter)
      为设定者设置一个替代名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JavaBeanFloatPropertyBuilder

        public JavaBeanFloatPropertyBuilder​()

    • 方法详细信息

      • create

        public static JavaBeanFloatPropertyBuilder create​()
        创建一个新的实例 JavaBeanFloatPropertyBuilder
        结果
        新的 JavaBeanFloatPropertyBuilder

      • build

        public JavaBeanFloatProperty build​()
                            throws NoSuchMethodException
        使用当前设置生成新的JavaBeanFloatProperty 。
        结果
        新的 JavaBeanFloatProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter和setter
        IllegalArgumentException - 如果Java Bean属性不是类型 float或 Float

      • name

        public JavaBeanFloatPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public JavaBeanFloatPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public JavaBeanFloatPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter和setter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanFloatPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanFloatPropertyBuilder setter​(String setter)
        为设定者设置一个替代名称。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设置者的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanFloatPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanFloatPropertyBuilder setter​(方法 setter)
        直接设置setter方法。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设定者
        结果
        引用此构建器来启用方法链接
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanIntegerProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
          • javafx.beans.property.IntegerProperty
            • javafx.beans.property.adapter.JavaBeanIntegerProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， JavaBeanProperty<Number> ， ReadOnlyJavaBeanProperty<Number> ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableIntegerValue ， WritableNumberValue ， WritableValue<Number>

    public final class JavaBeanIntegerProperty
extends IntegerProperty
implements JavaBeanProperty<Number>
    A JavaBeanIntegerProperty在int或Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。 它不能直接创建，但必须使用JavaBeanIntegerPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter和一个setter。 该类，以及getter和setter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果调用setter，该值将被传递给Java Bean属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个JavaBeanIntegerProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。 如果Java Bean属性也受到约束（即它支持VetoableChangeListeners），则JavaBeanIntegerProperty将拒绝更改，如果它绑定到一个ObservableValue<Integer> 。

    将应用程序部署为模块

    如果Java Bean类在一个命名的模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens包含至少包含javafx.base模块的一个类，则可以反射访问。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包装，则可以反射地访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    IntegerProperty ， JavaBeanIntegerPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
      int get​()
      获取包装的值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(int value)
      设置包装的值。
      String toString​()
      返回此 JavaBeanIntegerProperty对象的字符串表示形式。
      void unbind​()
      删除这个 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.IntegerProperty

        asObject, bindBidirectional, integerProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.Property

        bindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerProperty

        readOnlyIntegerProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • get

        public int get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始int。 需要与WritableValue.getValue()相同。
        Specified by:
        get在接口 ObservableIntegerValue
        Specified by:
        get在接口 WritableIntegerValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • set

        public void set​(int value)
        设置包装的值。 与WritableIntegerValue.setValue(java.lang.Number)不同，此方法使用原语int。
        Specified by:
        set在接口 WritableIntegerValue
        参数
        value - 新的价值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • bind

        public void bind​(ObservableValue<? extends Number> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<Number>
        参数
        observable - 可观察这个 Property应该绑定。

      • unbind

        public void unbind​()
        删除这个Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        Specified by:
        unbind在接口 Property<Number>
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        Specified by:
        isBound在接口 Property<Number>
        结果
        true如果 Property绑定，否则为 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean接口 ReadOnlyProperty<Number>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Number>
        结果
        名称或空 String

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 ObservableValue<Number>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<Number>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(InvalidationListener listener)
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<Number>

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Number>

      • toString

        public String toString​()
        返回此 JavaBeanIntegerProperty对象的字符串表示形式。
        重写：
        toString IntegerProperty
        结果
        这个 JavaBeanIntegerProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanIntegerPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanIntegerPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.JavaBeanIntegerPropertyBuilder

  • public final class JavaBeanIntegerPropertyBuilder
extends Object
    A JavaBeanIntegerPropertyBuilder可以用来创建JavaBeanIntegerProperties 。 要创建一个JavaBeanIntegerProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的财产和bean(java.lang.Object)必须被指定。 如果getter和setter的名称遵循约定，这就足够了。 否则可以直接指定吸气剂和设定器（ getter(java.lang.String)和setter(java.lang.String) ）或吸气剂和设定器Methods的替代名称（ getter(java.lang.reflect.Method)和setter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的多个实例生成适配器，则可以重新使用JavaBeanIntegerPropertyBuilder 。 通过切换Java Bean实例（与bean(java.lang.Object)并调用build() 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    JavaBeanIntegerProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      JavaBeanIntegerPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JavaBeanIntegerPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanIntegerPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanIntegerProperty build​()
      使用当前设置生成新的JavaBeanIntegerProperty 。
      static JavaBeanIntegerPropertyBuilder create​()
      创建一个新的实例 JavaBeanIntegerPropertyBuilder
      JavaBeanIntegerPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      JavaBeanIntegerPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanIntegerPropertyBuilder name​(String name)
      设置属性的名称
      JavaBeanIntegerPropertyBuilder setter​(方法 setter)
      直接设置setter方法。
      JavaBeanIntegerPropertyBuilder setter​(String setter)
      为设定者设置一个替代名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JavaBeanIntegerPropertyBuilder

        public JavaBeanIntegerPropertyBuilder​()

    • 方法详细信息

      • create

        public static JavaBeanIntegerPropertyBuilder create​()
        创建一个新的实例 JavaBeanIntegerPropertyBuilder
        结果
        新的 JavaBeanIntegerPropertyBuilder

      • build

        public JavaBeanIntegerProperty build​()
                              throws NoSuchMethodException
        使用当前设置生成新的JavaBeanIntegerProperty 。
        结果
        新的 JavaBeanIntegerProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter和setter
        IllegalArgumentException - 如果Java Bean属性不是类型 int或 Integer

      • name

        public JavaBeanIntegerPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 该物业的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public JavaBeanIntegerPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public JavaBeanIntegerPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter和setter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanIntegerPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanIntegerPropertyBuilder setter​(String setter)
        为设定者设置一个替代名称。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设置者的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanIntegerPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanIntegerPropertyBuilder setter​(方法 setter)
        直接设置setter方法。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设定者
        结果
        引用此构建器来启用方法链接
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanLongProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
          • javafx.beans.property.LongProperty
            • javafx.beans.property.adapter.JavaBeanLongProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， JavaBeanProperty<Number> ， ReadOnlyJavaBeanProperty<Number> ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableLongValue ， WritableNumberValue ， WritableValue<Number>

    public final class JavaBeanLongProperty
extends LongProperty
implements JavaBeanProperty<Number>
    A JavaBeanLongProperty在类型为long或Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。 它不能直接创建，但必须使用JavaBeanLongPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter和一个setter。 该类，以及getter和setter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果调用setter，该值将被传递给Java Bean属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个JavaBeanLongProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。 如果Java Bean属性也受到约束（即它支持VetoableChangeListeners）， JavaBeanLongProperty将拒绝更改，如果它绑定到一个ObservableValue<Long> 。

    将应用程序部署为模块

    如果Java Bean类在一个命名的模块中，那么它必须能反映出javafx.base模块的可访问性。 如果模块opens包含至少包含javafx.base模块，则可以反射访问类。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包装，则可以反射地访问该类 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    LongProperty ， JavaBeanLongPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
      long get​()
      获取包装的值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void set​(long value)
      设置包装的值。
      String toString​()
      返回此 JavaBeanLongProperty对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.LongProperty

        asObject, bindBidirectional, longProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.Property

        bindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ReadOnlyLongProperty

        readOnlyLongProperty

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • get

        public long get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始long。 需要与WritableValue.getValue()相同。
        Specified by:
        get在接口 ObservableLongValue
        Specified by:
        get在接口 WritableLongValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • set

        public void set​(long value)
        设置包装的值。 与WritableLongValue.setValue(java.lang.Number)不同，此方法使用原始长。
        Specified by:
        set在接口 WritableLongValue
        参数
        value - 新的价值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • bind

        public void bind​(ObservableValue<? extends Number> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<Number>
        参数
        observable - 可观察到这个 Property应该绑定。

      • unbind

        public void unbind​()
        删除此Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        Specified by:
        unbind在接口 Property<Number>
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        Specified by:
        isBound在接口 Property<Number>
        结果
        true如果 Property绑定，否则 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<Number>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Number>
        结果
        的名字或一个空的 String

      • addListener

        public void addListener​(ChangeListener<? super Number> listener)
        添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakChangeListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 ObservableValue<Number>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super Number> listener)
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener接口 ObservableValue<Number>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(InvalidationListener listener)
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销一个监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<Number>

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Number>

      • toString

        public String toString​()
        返回此 JavaBeanLongProperty对象的字符串表示形式。
        重写：
        toString在 LongProperty
        结果
        这个 JavaBeanLongProperty对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanLongPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanLongPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.JavaBeanLongPropertyBuilder

  • public final class JavaBeanLongPropertyBuilder
extends Object
    A JavaBeanLongPropertyBuilder可以用来创建JavaBeanLongProperties 。 要创建一个JavaBeanLongProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的财产和bean(java.lang.Object)必须指定。 如果getter和setter的名称遵循约定，这就足够了。 否则可以直接指定吸气剂和设定器（ getter(java.lang.String)和setter(java.lang.String) ）或吸气剂和设定器Methods的备用名称（ getter(java.lang.reflect.Method)和setter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果您必须为同一类的几个实例的同一属性生成适配器，则可以重新使用JavaBeanLongPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    JavaBeanLongProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      JavaBeanLongPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JavaBeanLongPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanLongPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanLongProperty build​()
      使用当前设置生成新的JavaBeanLongProperty 。
      static JavaBeanLongPropertyBuilder create​()
      创建一个新的实例 JavaBeanLongPropertyBuilder
      JavaBeanLongPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      JavaBeanLongPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanLongPropertyBuilder name​(String name)
      设置属性的名称
      JavaBeanLongPropertyBuilder setter​(方法 setter)
      直接设置setter方法。
      JavaBeanLongPropertyBuilder setter​(String setter)
      为设定者设置一个替代名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JavaBeanLongPropertyBuilder

        public JavaBeanLongPropertyBuilder​()

    • 方法详细信息

      • create

        public static JavaBeanLongPropertyBuilder create​()
        创建一个新的实例 JavaBeanLongPropertyBuilder
        结果
        新的 JavaBeanLongPropertyBuilder

      • build

        public JavaBeanLongProperty build​()
                           throws NoSuchMethodException
        使用当前设置生成新的JavaBeanLongProperty 。
        结果
        新的 JavaBeanLongProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter和setter
        IllegalArgumentException - 如果Java Bean属性不是类型 long或 Long

      • name

        public JavaBeanLongPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 物业的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public JavaBeanLongPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public JavaBeanLongPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter和setter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanLongPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanLongPropertyBuilder setter​(String setter)
        为设定者设置一个替代名称。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设置者的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanLongPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanLongPropertyBuilder setter​(方法 setter)
        直接设置setter方法。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设定者
        结果
        引用此构建器来启用方法链接
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanObjectProperty<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
        • javafx.beans.property.ObjectProperty<T>
          • javafx.beans.property.adapter.JavaBeanObjectProperty<T>
  • All Implemented Interfaces:
    Observable ， JavaBeanProperty<T> ， ReadOnlyJavaBeanProperty<T> ， Property<T> ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T> ， WritableObjectValue<T> ， WritableValue<T>

    public final class JavaBeanObjectProperty<T>
extends ObjectProperty<T>
implements JavaBeanProperty<T>
    一个JavaBeanObjectProperty提供类型的普通的Java Bean属性之间的适配器T和一个JavaFX ObjectProperty<T> 。 它不能直接创建，但必须使用JavaBeanObjectPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter和一个setter。 该类，以及getter和setter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果调用setter，该值将被传递给Java Bean属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个JavaBeanObjectProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。 如果Java Bean属性也受到约束（即它支持VetoableChangeListeners），则JavaBeanObjectProperty将拒绝更改，如果它绑定到一个ObservableValue<Object> 。

    将应用程序部署为模块

    如果Java Bean类在一个命名模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens将包含的包至少为javafx.base模块，则可以反射访问类。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射地访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObjectProperty ， JavaBeanObjectPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super T> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void bind​(ObservableValue<? extends T> observable)
      为此创建一个单向绑定 Property 。
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
      T get​()
      获取包装的值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super T> listener)
      从监听器列表中删除给定的侦听器，每当 ObservableValue的值发生更改时通知 ObservableValue 。
      void set​(T value)
      设置包装的值。
      String toString​()
      返回此 JavaBeanObjectProperty对象的字符串表示形式。
      void unbind​()
      删除此 Property的单向绑定。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from class javafx.beans.property.ObjectProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.Property

        bindBidirectional, unbindBidirectional

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • get

        public T get​()
        获取包装的值。 这必须与从WritableValue.getValue()返回的值相同。

        此方法仅存在于将WritableObjectValue API与WritableBooleanValue和WritableNumberValue的子类对齐

        Specified by:
        get在接口 ObservableObjectValue<T>
        Specified by:
        get在接口 WritableObjectValue<T>
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • set

        public void set​(T value)
        设置包装的值。 应该相当于WritableValue.setValue(java.lang.Object)
        Specified by:
        set在接口 WritableObjectValue<T>
        参数
        value - 新价值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。
        另请参见：
        WritableObjectValue.get()

      • bind

        public void bind​(ObservableValue<? extends T> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<T>
        参数
        observable - 可观察到的这个 Property应该绑定到。

      • unbind

        public void unbind​()
        删除此Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        Specified by:
        unbind在接口 Property<T>
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        Specified by:
        isBound在接口 Property<T>
        结果
        true如果 Property被绑定，否则为 false
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性不包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<T>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<T>
        结果
        该名称或空的 String

      • addListener

        public void addListener​(ChangeListener<? super T> listener)
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<T>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super T> listener)
        从监听器列表中删除给定的监听器，当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<T>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(InvalidationListener listener)
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的实例来避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<T>

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<T>

      • toString

        public String toString​()
        返回此 JavaBeanObjectProperty对象的字符串表示形式。
        重写：
        toString在 ObjectProperty<T>
        结果
        a string representation of this JavaBeanObjectProperty object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanObjectPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanObjectPropertyBuilder<T>

  • java.lang.Object
    • javafx.beans.property.adapter.JavaBeanObjectPropertyBuilder<T>

  • public final class JavaBeanObjectPropertyBuilder<T>
extends Object
    A JavaBeanObjectPropertyBuilder可以用来创建JavaBeanObjectProperties 。 要创建一个JavaBeanObjectProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的属性和bean(java.lang.Object)必须被指定。 如果getter和setter的名称遵循约定，这就足够了。 否则可以直接指定吸气剂和设定器（ getter(java.lang.String)和setter(java.lang.String) ）或吸气剂和设定器Methods的替代名称（ getter(java.lang.reflect.Method)和setter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的多个实例的同一属性生成适配器，则可以重新使用JavaBeanObjectPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    JavaBeanObjectProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      JavaBeanObjectPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JavaBeanObjectPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanObjectPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanObjectProperty<T> build​()
      使用当前设置生成新的JavaBeanObjectProperty 。
      static JavaBeanObjectPropertyBuilder create​()
      创建一个新的实例 JavaBeanObjectPropertyBuilder
      JavaBeanObjectPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      JavaBeanObjectPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanObjectPropertyBuilder name​(String name)
      设置属性的名称
      JavaBeanObjectPropertyBuilder setter​(方法 setter)
      直接设置setter方法。
      JavaBeanObjectPropertyBuilder setter​(String setter)
      为设定者设置一个替代名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JavaBeanObjectPropertyBuilder

        public JavaBeanObjectPropertyBuilder​()

    • 方法详细信息

      • create

        public static JavaBeanObjectPropertyBuilder create​()
        创建一个新的实例 JavaBeanObjectPropertyBuilder
        结果
        新的 JavaBeanObjectPropertyBuilder

      • build

        public JavaBeanObjectProperty<T> build​()
                                throws NoSuchMethodException
        使用当前设置生成新的JavaBeanObjectProperty 。
        结果
        新的 JavaBeanObjectProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter和setter

      • name

        public JavaBeanObjectPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public JavaBeanObjectPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public JavaBeanObjectPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter和setter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanObjectPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanObjectPropertyBuilder setter​(String setter)
        为设定者设置一个替代名称。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设置者的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanObjectPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanObjectPropertyBuilder setter​(方法 setter)
        直接设置setter方法。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设定者
        结果
        引用此构建器来启用方法链接
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Interface JavaBeanProperty<T>

  • 参数类型
    T - 包装属性的类型
    All Superinterfaces:
    Observable ， ObservableValue<T> ， Property<T> ， ReadOnlyJavaBeanProperty<T> ， ReadOnlyProperty<T> ， WritableValue<T>
    所有已知实现类：
    JavaBeanBooleanProperty ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， JavaBeanObjectProperty ， JavaBeanStringProperty

    public interface JavaBeanProperty<T>
extends ReadOnlyJavaBeanProperty<T>, Property<T>
    JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
    从以下版本开始：
    JavaFX 2.1

    • 方法摘要

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.Property

        bind, bindBidirectional, isBound, unbind, unbindBidirectional

      • Methods inherited from interface javafx.beans.property.adapter.ReadOnlyJavaBeanProperty

        dispose, fireValueChangedEvent

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanStringProperty

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
        • javafx.beans.property.StringProperty
          • javafx.beans.property.adapter.JavaBeanStringProperty
  • All Implemented Interfaces:
    Observable ， JavaBeanProperty<String> ， ReadOnlyJavaBeanProperty<String> ， Property<String> ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String> ， WritableObjectValue<String> ， WritableStringValue ， WritableValue<String>

    public final class JavaBeanStringProperty
extends StringProperty
implements JavaBeanProperty<String>
    A JavaBeanStringProperty在类型为String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。 它不能直接创建，但必须使用JavaBeanStringPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter和一个setter。 该类，以及getter和setter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果调用setter，该值将被传递给Java Bean属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个JavaBeanStringProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。 如果Java Bean属性也受到约束（即它支持VetoableChangeListeners），则JavaBeanStringProperty将拒绝更改，如果它绑定到一个ObservableValue<String> 。

    将应用程序部署为模块

    如果Java Bean类在命名模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens包含至少包含javafx.base模块，则类可以反射访问。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    StringProperty ， JavaBeanStringPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super String> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void bind​(ObservableValue<? extends String> observable)
      为此创建一个单向绑定 Property 。
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
      String get​()
      获取包装的值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。
      boolean isBound​()
      可以用来检查，如果一个 Property是绑定的。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super String> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知该 ObservableValue 。
      void set​(String value)
      设置包装的值。
      void unbind​()
      删除这个 Property的单向绑定。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.Property

        bindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

      • Methods inherited from class javafx.beans.property.StringProperty

        bindBidirectional, bindBidirectional, bindBidirectional, setValue, toString, unbindBidirectional, unbindBidirectional

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • get

        public String get​()
        获取包装的值。 这必须与从WritableValue.getValue()返回的值相同。

        此方法仅存在于将WritableObjectValue API与WritableBooleanValue和WritableNumberValue的子类对齐

        Specified by:
        get在接口 ObservableObjectValue<String>
        Specified by:
        get在接口 WritableObjectValue<String>
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • set

        public void set​(String value)
        设置包装的值。 应相当于WritableValue.setValue(java.lang.Object)
        Specified by:
        set在接口 WritableObjectValue<String>
        参数
        value - 新值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。
        另请参见：
        WritableObjectValue.get()

      • bind

        public void bind​(ObservableValue<? extends String> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<String>
        参数
        observable - 可观察到这个 Property应该绑定到。

      • unbind

        public void unbind​()
        删除此Property的单向绑定。 如果Property未绑定，则调用此方法没有任何作用。
        Specified by:
        unbind在接口 Property<String>
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • isBound

        public boolean isBound​()
        可以用来检查，如果一个 Property是绑定的。
        Specified by:
        isBound在接口 Property<String>
        结果
        true如果 Property是绑定的， false否则
        另请参见：
        Property.bind(javafx.beans.value.ObservableValue)

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<String>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<String>
        结果
        该名称或空的 String

      • addListener

        public void addListener​(ChangeListener<? super String> listener)
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或者使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<String>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(ChangeListener<? super String> listener)
        从监听器列表中删除给定的侦听器，每当ObservableValue的值更改时都会通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<String>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • addListener

        public void addListener​(InvalidationListener listener)
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        从监听器列表中删除给定的侦听器，当Observable的值变为无效时，它们将被通知。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<String>

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<String>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JavaBeanStringPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class JavaBeanStringPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.JavaBeanStringPropertyBuilder

  • public final class JavaBeanStringPropertyBuilder
extends Object
    A JavaBeanStringPropertyBuilder可以用来创建JavaBeanStringProperties 。 要创建一个JavaBeanStringProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的属性和bean(java.lang.Object)必须被指定。 如果getter和setter的名称遵循约定，这就足够了。 否则可以直接指定吸气剂和设定器（ getter(java.lang.String)和setter(java.lang.String) ）或吸气剂和设定器Methods的替代名称（ getter(java.lang.reflect.Method)和setter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的几个实例的同一属性生成适配器，则可以重新使用JavaBeanStringPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    JavaBeanStringProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      JavaBeanStringPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JavaBeanStringPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanStringPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanStringProperty build​()
      使用当前设置生成新的JavaBeanStringProperty 。
      static JavaBeanStringPropertyBuilder create​()
      创建一个新的实例 JavaBeanStringPropertyBuilder
      JavaBeanStringPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      JavaBeanStringPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanStringPropertyBuilder name​(String name)
      设置属性的名称
      JavaBeanStringPropertyBuilder setter​(方法 setter)
      直接设置setter方法。
      JavaBeanStringPropertyBuilder setter​(String setter)
      为设定者设置一个替代名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JavaBeanStringPropertyBuilder

        public JavaBeanStringPropertyBuilder​()

    • 方法详细信息

      • create

        public static JavaBeanStringPropertyBuilder create​()
        创建一个新的实例 JavaBeanStringPropertyBuilder
        结果
        新的 JavaBeanStringPropertyBuilder

      • build

        public JavaBeanStringProperty build​()
                             throws NoSuchMethodException
        使用当前设置生成新的JavaBeanStringProperty 。
        结果
        新的 JavaBeanStringProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter和setter
        IllegalArgumentException - 如果Java Bean属性不是类型 String

      • name

        public JavaBeanStringPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public JavaBeanStringPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public JavaBeanStringPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter和setter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanStringPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanStringPropertyBuilder setter​(String setter)
        为设定者设置一个替代名称。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - setter的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public JavaBeanStringPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        引用此构建器来启用方法链接

      • setter

        public JavaBeanStringPropertyBuilder setter​(方法 setter)
        直接设置setter方法。 如果setter的名称遵循Java Bean命名约定，可以省略这一点。
        参数
        setter - 设定者
        结果
        引用此构建器来启用方法链接
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.beans.property.adapter (Java SE 9 & JDK 9 )

javafx.beans.property.adapter

Interfaces

  • JavaBeanProperty
  • ReadOnlyJavaBeanProperty

Classes

  • JavaBeanBooleanProperty
  • JavaBeanBooleanPropertyBuilder
  • JavaBeanDoubleProperty
  • JavaBeanDoublePropertyBuilder
  • JavaBeanFloatProperty
  • JavaBeanFloatPropertyBuilder
  • JavaBeanIntegerProperty
  • JavaBeanIntegerPropertyBuilder
  • JavaBeanLongProperty
  • JavaBeanLongPropertyBuilder
  • JavaBeanObjectProperty
  • JavaBeanObjectPropertyBuilder
  • JavaBeanStringProperty
  • JavaBeanStringPropertyBuilder
  • ReadOnlyJavaBeanBooleanProperty
  • ReadOnlyJavaBeanBooleanPropertyBuilder
  • ReadOnlyJavaBeanDoubleProperty
  • ReadOnlyJavaBeanDoublePropertyBuilder
  • ReadOnlyJavaBeanFloatProperty
  • ReadOnlyJavaBeanFloatPropertyBuilder
  • ReadOnlyJavaBeanIntegerProperty
  • ReadOnlyJavaBeanIntegerPropertyBuilder
  • ReadOnlyJavaBeanLongProperty
  • ReadOnlyJavaBeanLongPropertyBuilder
  • ReadOnlyJavaBeanObjectProperty
  • ReadOnlyJavaBeanObjectPropertyBuilder
  • ReadOnlyJavaBeanStringProperty
  • ReadOnlyJavaBeanStringPropertyBuilder


javafx.beans.property.adapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.beans.property.adapter

提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

  • 接口摘要
    接口 描述
    JavaBeanProperty<T>
    JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
    ReadOnlyJavaBeanProperty<T>
    JavaBeanProperty是只读Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
  • 类摘要
    Class 描述
    JavaBeanBooleanProperty
    A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
    JavaBeanBooleanPropertyBuilder
    A JavaBeanBooleanPropertyBuilder可用于创建JavaBeanBooleanProperties 。
    JavaBeanDoubleProperty
    A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
    JavaBeanDoublePropertyBuilder
    A JavaBeanDoublePropertyBuilder可以用来创建JavaBeanDoubleProperties 。
    JavaBeanFloatProperty
    A JavaBeanFloatProperty提供了一个 float或 Float的常规Java Bean属性和JavaFX FloatProperty之间的适配器。
    JavaBeanFloatPropertyBuilder
    A JavaBeanFloatPropertyBuilder可以用来创建JavaBeanFloatProperties 。
    JavaBeanIntegerProperty
    A JavaBeanIntegerProperty在 int或 Integer的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
    JavaBeanIntegerPropertyBuilder
    A JavaBeanIntegerPropertyBuilder可用于创建JavaBeanIntegerProperties 。
    JavaBeanLongProperty
    A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
    JavaBeanLongPropertyBuilder
    A JavaBeanLongPropertyBuilder可用于创建JavaBeanLongProperties 。
    JavaBeanObjectProperty<T>
    A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
    JavaBeanObjectPropertyBuilder<T>
    A JavaBeanObjectPropertyBuilder可以用来创建JavaBeanObjectProperties 。
    JavaBeanStringProperty
    A JavaBeanStringProperty在类型为 String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。
    JavaBeanStringPropertyBuilder
    A JavaBeanStringPropertyBuilder可以用来创建JavaBeanStringProperties 。
    ReadOnlyJavaBeanBooleanProperty
    A ReadOnlyJavaBeanBooleanProperty在 boolean或 Boolean之间的常规只读Java Bean属性和JavaFX ReadOnlyBooleanProperty提供了一个适配器。
    ReadOnlyJavaBeanBooleanPropertyBuilder
    A ReadOnlyJavaBeanBooleanPropertyBuilder可用于创建ReadOnlyJavaBeanBooleanProperties 。
    ReadOnlyJavaBeanDoubleProperty
    A ReadOnlyJavaBeanDoubleProperty在常规的只读Java Bean属性类型为 double或 Double和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。
    ReadOnlyJavaBeanDoublePropertyBuilder
    A ReadOnlyJavaBeanDoublePropertyBuilder可以用来创建ReadOnlyJavaBeanDoubleProperties 。
    ReadOnlyJavaBeanFloatProperty
    A ReadOnlyJavaBeanFloatProperty在常规的只读Java Bean属性类型为 float或 Float和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。
    ReadOnlyJavaBeanFloatPropertyBuilder
    A ReadOnlyJavaBeanFloatPropertyBuilder可以用来创建ReadOnlyJavaBeanFloatProperties 。
    ReadOnlyJavaBeanIntegerProperty
    A ReadOnlyJavaBeanIntegerProperty在类型为 int或 Integer的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty之间提供了一个适配器。
    ReadOnlyJavaBeanIntegerPropertyBuilder
    A ReadOnlyJavaBeanIntegerPropertyBuilder可以用来创建ReadOnlyJavaBeanIntegerProperties 。
    ReadOnlyJavaBeanLongProperty
    A ReadOnlyJavaBeanLongProperty在 long或 Long的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty之间提供了一个适配器。
    ReadOnlyJavaBeanLongPropertyBuilder
    A ReadOnlyJavaBeanLongPropertyBuilder可用于创建ReadOnlyJavaBeanLongProperties 。
    ReadOnlyJavaBeanObjectProperty<T>
    A ReadOnlyJavaBeanObjectProperty在常规的只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间提供了一个适配器。
    ReadOnlyJavaBeanObjectPropertyBuilder<T>
    A ReadOnlyJavaBeanObjectPropertyBuilder可以用来创建ReadOnlyJavaBeanObjectProperties 。
    ReadOnlyJavaBeanStringProperty
    A ReadOnlyJavaBeanStringProperty在常规的只读Java Bean属性类型为 String和JavaFX ReadOnlyStringProperty之间提供了一个适配器。
    ReadOnlyJavaBeanStringPropertyBuilder
    A ReadOnlyJavaBeanStringPropertyBuilder can be used to create ReadOnlyJavaBeanStringProperties.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.beans.property.adapter Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.beans.property.adapter

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression (implements javafx.beans.value.ObservableBooleanValue)
      • javafx.beans.property.ReadOnlyBooleanProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.BooleanProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableBooleanValue)
          • javafx.beans.property.adapter.JavaBeanBooleanProperty (implements javafx.beans.property.adapter.JavaBeanProperty<T>)
        • javafx.beans.property.ReadOnlyBooleanPropertyBase
          • javafx.beans.property.adapter.ReadOnlyJavaBeanBooleanProperty (implements javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>)
    • javafx.beans.property.adapter.JavaBeanBooleanPropertyBuilder
    • javafx.beans.property.adapter.JavaBeanDoublePropertyBuilder
    • javafx.beans.property.adapter.JavaBeanFloatPropertyBuilder
    • javafx.beans.property.adapter.JavaBeanIntegerPropertyBuilder
    • javafx.beans.property.adapter.JavaBeanLongPropertyBuilder
    • javafx.beans.property.adapter.JavaBeanObjectPropertyBuilder<T>
    • javafx.beans.property.adapter.JavaBeanStringPropertyBuilder
    • javafx.beans.binding.NumberExpressionBase (implements javafx.beans.binding.NumberExpression)
      • javafx.beans.binding.DoubleExpression (implements javafx.beans.value.ObservableDoubleValue)
        • javafx.beans.property.ReadOnlyDoubleProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.DoubleProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableDoubleValue)
            • javafx.beans.property.adapter.JavaBeanDoubleProperty (implements javafx.beans.property.adapter.JavaBeanProperty<T>)
          • javafx.beans.property.ReadOnlyDoublePropertyBase
            • javafx.beans.property.adapter.ReadOnlyJavaBeanDoubleProperty (implements javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>)
      • javafx.beans.binding.FloatExpression (implements javafx.beans.value.ObservableFloatValue)
        • javafx.beans.property.ReadOnlyFloatProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.FloatProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableFloatValue)
            • javafx.beans.property.adapter.JavaBeanFloatProperty (implements javafx.beans.property.adapter.JavaBeanProperty<T>)
          • javafx.beans.property.ReadOnlyFloatPropertyBase
            • javafx.beans.property.adapter.ReadOnlyJavaBeanFloatProperty (implements javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>)
      • javafx.beans.binding.IntegerExpression (implements javafx.beans.value.ObservableIntegerValue)
        • javafx.beans.property.ReadOnlyIntegerProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.IntegerProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableIntegerValue)
            • javafx.beans.property.adapter.JavaBeanIntegerProperty (implements javafx.beans.property.adapter.JavaBeanProperty<T>)
          • javafx.beans.property.ReadOnlyIntegerPropertyBase
            • javafx.beans.property.adapter.ReadOnlyJavaBeanIntegerProperty (implements javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>)
      • javafx.beans.binding.LongExpression (implements javafx.beans.value.ObservableLongValue)
        • javafx.beans.property.ReadOnlyLongProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.LongProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableLongValue)
            • javafx.beans.property.adapter.JavaBeanLongProperty (implements javafx.beans.property.adapter.JavaBeanProperty<T>)
          • javafx.beans.property.ReadOnlyLongPropertyBase
            • javafx.beans.property.adapter.ReadOnlyJavaBeanLongProperty (implements javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>)
    • javafx.beans.binding.ObjectExpression<T> (implements javafx.beans.value.ObservableObjectValue<T>)
      • javafx.beans.property.ReadOnlyObjectProperty<T> (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.ObjectProperty<T> (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableObjectValue<T>)
          • javafx.beans.property.adapter.JavaBeanObjectProperty<T> (implements javafx.beans.property.adapter.JavaBeanProperty<T>)
        • javafx.beans.property.ReadOnlyObjectPropertyBase<T>
          • javafx.beans.property.adapter.ReadOnlyJavaBeanObjectProperty<T> (implements javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>)
    • javafx.beans.property.adapter.ReadOnlyJavaBeanBooleanPropertyBuilder
    • javafx.beans.property.adapter.ReadOnlyJavaBeanDoublePropertyBuilder
    • javafx.beans.property.adapter.ReadOnlyJavaBeanFloatPropertyBuilder
    • javafx.beans.property.adapter.ReadOnlyJavaBeanIntegerPropertyBuilder
    • javafx.beans.property.adapter.ReadOnlyJavaBeanLongPropertyBuilder
    • javafx.beans.property.adapter.ReadOnlyJavaBeanObjectPropertyBuilder<T>
    • javafx.beans.property.adapter.ReadOnlyJavaBeanStringPropertyBuilder
    • javafx.beans.binding.StringExpression (implements javafx.beans.value.ObservableStringValue)
      • javafx.beans.property.ReadOnlyStringProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.ReadOnlyStringPropertyBase
          • javafx.beans.property.adapter.ReadOnlyJavaBeanStringProperty (implements javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>)
        • javafx.beans.property.StringProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableStringValue)
          • javafx.beans.property.adapter.JavaBeanStringProperty (implements javafx.beans.property.adapter.JavaBeanProperty<T>)

Interface Hierarchy

  • javafx.beans.Observable
    • javafx.beans.value.ObservableValue<T>
      • javafx.beans.property.ReadOnlyProperty<T>
        • javafx.beans.property.Property<T> (also extends javafx.beans.value.WritableValue<T>)
          • javafx.beans.property.adapter.JavaBeanProperty<T> (also extends javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>)
        • javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>
          • javafx.beans.property.adapter.JavaBeanProperty<T> (also extends javafx.beans.property.Property<T>)
  • javafx.beans.value.WritableValue<T>
    • javafx.beans.property.Property<T> (also extends javafx.beans.property.ReadOnlyProperty<T>)
      • javafx.beans.property.adapter.JavaBeanProperty<T> (also extends javafx.beans.property.adapter.ReadOnlyJavaBeanProperty<T>)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ReadOnlyJavaBeanBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanBooleanProperty

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
        • javafx.beans.property.ReadOnlyBooleanPropertyBase
          • javafx.beans.property.adapter.ReadOnlyJavaBeanBooleanProperty
  • All Implemented Interfaces:
    Observable ， ReadOnlyJavaBeanProperty<Boolean> ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean>

    public final class ReadOnlyJavaBeanBooleanProperty
extends ReadOnlyBooleanPropertyBase
implements ReadOnlyJavaBeanProperty<Boolean>
    A ReadOnlyJavaBeanBooleanProperty提供了一个boolean或Boolean的常规只读Java Bean属性和JavaFX ReadOnlyBooleanProperty 。 它不能直接创建，但必须使用ReadOnlyJavaBeanBooleanPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter。 该类以及getter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个ReadOnlyJavaBeanBooleanProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。

    将应用程序部署为模块

    如果Java Bean类在一个命名的模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens将包含的包至少为javafx.base模块，则可以反射访问类。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包装，则可以反射地访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyBooleanProperty ， ReadOnlyJavaBeanBooleanPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      boolean get​()
      返回此 ObservableBooleanValue的当前值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanProperty

        asObject, readOnlyBooleanProperty, toString

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanPropertyBase

        addListener, addListener, removeListener, removeListener

    • 方法详细信息

      • get

        public boolean get​()
        返回此 ObservableBooleanValue的当前值。
        Specified by:
        get在接口 ObservableBooleanValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<Boolean>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Boolean>
        结果
        的名字或一个空的 String

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<Boolean>
        重写：
        fireValueChangedEvent在 ReadOnlyBooleanPropertyBase

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Boolean>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanBooleanPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanBooleanPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.ReadOnlyJavaBeanBooleanPropertyBuilder

  • public final class ReadOnlyJavaBeanBooleanPropertyBuilder
extends Object
    A ReadOnlyJavaBeanBooleanPropertyBuilder可以用来创建ReadOnlyJavaBeanBooleanProperties 。 要创建一个ReadOnlyJavaBeanBooleanProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的财产和bean(java.lang.Object)必须指定。 如果吸气剂的名称符合惯例，这就足够了。 否则可以直接指定吸气剂（ getter(java.lang.String) ）或吸气剂Methods的替代名称（ getter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的几个实例的同一属性生成适配器，则可以重新使用ReadOnlyJavaBeanBooleanPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyJavaBeanBooleanProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyJavaBeanBooleanPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanBooleanPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanBooleanPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanBooleanProperty build​()
      使用当前设置生成新的ReadOnlyJavaBeanBooleanProperty 。
      static ReadOnlyJavaBeanBooleanPropertyBuilder create​()
      创建一个新的实例 ReadOnlyJavaBeanBooleanPropertyBuilder
      ReadOnlyJavaBeanBooleanPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanBooleanPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanBooleanPropertyBuilder name​(String name)
      设置属性的名称

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ReadOnlyJavaBeanBooleanPropertyBuilder

        public ReadOnlyJavaBeanBooleanPropertyBuilder​()

    • 方法详细信息

      • create

        public static ReadOnlyJavaBeanBooleanPropertyBuilder create​()
        创建一个新的实例 ReadOnlyJavaBeanBooleanPropertyBuilder
        结果
        新的 ReadOnlyJavaBeanBooleanPropertyBuilder

      • build

        public ReadOnlyJavaBeanBooleanProperty build​()
                                      throws NoSuchMethodException
        使用当前设置生成新的ReadOnlyJavaBeanBooleanProperty 。
        结果
        新的 ReadOnlyJavaBeanBooleanProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter
        IllegalArgumentException - 如果Java Bean属性不是类型 boolean或 Boolean

      • name

        public ReadOnlyJavaBeanBooleanPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public ReadOnlyJavaBeanBooleanPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public ReadOnlyJavaBeanBooleanPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanBooleanPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanBooleanPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        a reference to this builder to enable method chaining
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanDoubleProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
          • javafx.beans.property.ReadOnlyDoublePropertyBase
            • javafx.beans.property.adapter.ReadOnlyJavaBeanDoubleProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyJavaBeanProperty<Number> ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number>

    public final class ReadOnlyJavaBeanDoubleProperty
extends ReadOnlyDoublePropertyBase
implements ReadOnlyJavaBeanProperty<Number>
    A ReadOnlyJavaBeanDoubleProperty在double或Double的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。 它不能直接创建，但必须使用ReadOnlyJavaBeanDoublePropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter。 该类以及getter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个ReadOnlyJavaBeanDoubleProperty将会意识到Java Bean中的更改。 否则可通过致电fireValueChangedEvent()通知有关更改。

    将应用程序部署为模块

    如果Java Bean类在命名模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens包含至少包含javafx.base模块，则类可以反射访问。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射地访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyDoubleProperty ， ReadOnlyJavaBeanDoublePropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      double get​()
      返回此 ObservableDoubleValue的当前值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from class javafx.beans.property.ReadOnlyDoubleProperty

        asObject, readOnlyDoubleProperty, toString

      • Methods inherited from class javafx.beans.property.ReadOnlyDoublePropertyBase

        addListener, addListener, removeListener, removeListener

    • 方法详细信息

      • get

        public double get​()
        返回此 ObservableDoubleValue的当前值。
        Specified by:
        get在接口 ObservableDoubleValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<Number>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Number>
        结果
        名称或空的 String

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<Number>
        重写：
        fireValueChangedEvent在 ReadOnlyDoublePropertyBase

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Number>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanDoublePropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanDoublePropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.ReadOnlyJavaBeanDoublePropertyBuilder

  • public final class ReadOnlyJavaBeanDoublePropertyBuilder
extends Object
    A ReadOnlyJavaBeanDoublePropertyBuilder可以用来创建ReadOnlyJavaBeanDoubleProperties 。 要创建一个ReadOnlyJavaBeanDoubleProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的财产和bean(java.lang.Object)必须被指定。 如果吸气剂的名称符合惯例，这就足够了。 否则可以直接指定吸气剂（ getter(java.lang.String) ）或吸气剂Methods的替代名称（ getter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的几个实例的同一属性生成适配器，则可以重新使用ReadOnlyJavaBeanDoublePropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyJavaBeanDoubleProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyJavaBeanDoublePropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanDoublePropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanDoublePropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanDoubleProperty build​()
      使用当前设置生成新的ReadOnlyJavaBeanDoubleProperty 。
      static ReadOnlyJavaBeanDoublePropertyBuilder create​()
      创建一个新的实例 ReadOnlyJavaBeanDoublePropertyBuilder
      ReadOnlyJavaBeanDoublePropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanDoublePropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanDoublePropertyBuilder name​(String name)
      设置属性的名称

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ReadOnlyJavaBeanDoublePropertyBuilder

        public ReadOnlyJavaBeanDoublePropertyBuilder​()

    • 方法详细信息

      • create

        public static ReadOnlyJavaBeanDoublePropertyBuilder create​()
        创建一个新的实例 ReadOnlyJavaBeanDoublePropertyBuilder
        结果
        新的 ReadOnlyJavaBeanDoublePropertyBuilder

      • build

        public ReadOnlyJavaBeanDoubleProperty build​()
                                     throws NoSuchMethodException
        使用当前设置生成新的ReadOnlyJavaBeanDoubleProperty 。
        结果
        新的 ReadOnlyJavaBeanDoubleProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter
        IllegalArgumentException - 如果Java Bean属性不是类型 double或 Double

      • name

        public ReadOnlyJavaBeanDoublePropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public ReadOnlyJavaBeanDoublePropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public ReadOnlyJavaBeanDoublePropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanDoublePropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanDoublePropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        a reference to this builder to enable method chaining
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanFloatProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
          • javafx.beans.property.ReadOnlyFloatPropertyBase
            • javafx.beans.property.adapter.ReadOnlyJavaBeanFloatProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyJavaBeanProperty<Number> ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number>

    public final class ReadOnlyJavaBeanFloatProperty
extends ReadOnlyFloatPropertyBase
implements ReadOnlyJavaBeanProperty<Number>
    A ReadOnlyJavaBeanFloatProperty在常规的只读Java Bean属性类型为float或Float和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。 它不能直接创建，但必须使用ReadOnlyJavaBeanFloatPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter。 该类以及getter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果Java Bean属性被绑定（即它支持PropertyChangeListeners），那么这个ReadOnlyJavaBeanFloatProperty将会意识到Java Bean中的更改。 否则可通过致电fireValueChangedEvent()通知有关更改。

    将应用程序部署为模块

    如果Java Bean类在命名模块中，那么javafx.base模块必须反映可访问。 如果模块opens包含至少包含javafx.base模块，则类可以反射访问。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射地访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyFloatProperty ， ReadOnlyJavaBeanFloatPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      float get​()
      返回此 ObservableFloatValue的当前值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatProperty

        asObject, readOnlyFloatProperty, toString

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatPropertyBase

        addListener, addListener, removeListener, removeListener

    • 方法详细信息

      • get

        public float get​()
        返回此 ObservableFloatValue的当前值。
        Specified by:
        get在接口 ObservableFloatValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<Number>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Number>
        结果
        该名称或空的 String

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<Number>
        重写：
        fireValueChangedEvent在 ReadOnlyFloatPropertyBase

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Number>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanFloatPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanFloatPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.ReadOnlyJavaBeanFloatPropertyBuilder

  • public final class ReadOnlyJavaBeanFloatPropertyBuilder
extends Object
    A ReadOnlyJavaBeanFloatPropertyBuilder可以用来创建ReadOnlyJavaBeanFloatProperties 。 要创建一个ReadOnlyJavaBeanFloatProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的属性和bean(java.lang.Object)必须被指定。 如果吸气剂的名称符合惯例，这就足够了。 否则可以直接指定吸气剂（ getter(java.lang.String) ）或吸气剂Methods的替代名称（ getter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的几个实例的同一属性生成适配器，则可以重新使用ReadOnlyJavaBeanFloatPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyJavaBeanFloatProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyJavaBeanFloatPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanFloatPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanFloatPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanFloatProperty build​()
      使用当前设置生成新的ReadOnlyJavaBeanFloatProperty 。
      static ReadOnlyJavaBeanFloatPropertyBuilder create​()
      创建一个新的实例 ReadOnlyJavaBeanFloatPropertyBuilder
      ReadOnlyJavaBeanFloatPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanFloatPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanFloatPropertyBuilder name​(String name)
      设置属性的名称

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ReadOnlyJavaBeanFloatPropertyBuilder

        public ReadOnlyJavaBeanFloatPropertyBuilder​()

    • 方法详细信息

      • create

        public static ReadOnlyJavaBeanFloatPropertyBuilder create​()
        创建一个新的实例 ReadOnlyJavaBeanFloatPropertyBuilder
        结果
        新的 ReadOnlyJavaBeanFloatPropertyBuilder

      • build

        public ReadOnlyJavaBeanFloatProperty build​()
                                    throws NoSuchMethodException
        使用当前设置生成新的ReadOnlyJavaBeanFloatProperty 。
        结果
        新的 ReadOnlyJavaBeanFloatProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter
        IllegalArgumentException - 如果Java Bean属性不是类型 float或 Float

      • name

        public ReadOnlyJavaBeanFloatPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public ReadOnlyJavaBeanFloatPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public ReadOnlyJavaBeanFloatPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanFloatPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanFloatPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        a reference to this builder to enable method chaining
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanIntegerProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
          • javafx.beans.property.ReadOnlyIntegerPropertyBase
            • javafx.beans.property.adapter.ReadOnlyJavaBeanIntegerProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyJavaBeanProperty<Number> ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number>

    public final class ReadOnlyJavaBeanIntegerProperty
extends ReadOnlyIntegerPropertyBase
implements ReadOnlyJavaBeanProperty<Number>
    A ReadOnlyJavaBeanIntegerProperty在常规的只读Java Bean属性类型为int或Integer和JavaFX ReadOnlyIntegerProperty之间提供了一个适配器。 它不能直接创建，但必须使用ReadOnlyJavaBeanIntegerPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter。 该类以及getter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果Java Bean属性被绑定（即它支持PropertyChangeListeners），那么这个ReadOnlyJavaBeanIntegerProperty将会意识到Java Bean中的更改。 否则可通过致电fireValueChangedEvent()通知有关更改。

    将应用程序部署为模块

    如果Java Bean类在一个命名模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens包含至少包含javafx.base模块，则类可以反射访问。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包装，则可以反射地访问该类 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyIntegerProperty ， ReadOnlyJavaBeanIntegerPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      int get​()
      返回此 ObservableIntegerValue的当前值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerProperty

        asObject, readOnlyIntegerProperty, toString

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerPropertyBase

        addListener, addListener, removeListener, removeListener

    • 方法详细信息

      • get

        public int get​()
        返回此 ObservableIntegerValue的当前值。
        Specified by:
        get在接口 ObservableIntegerValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性不包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<Number>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Number>
        结果
        的名字或一个空的 String

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<Number>
        重写：
        fireValueChangedEvent在 ReadOnlyIntegerPropertyBase

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Number>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanIntegerPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanIntegerPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.ReadOnlyJavaBeanIntegerPropertyBuilder

  • public final class ReadOnlyJavaBeanIntegerPropertyBuilder
extends Object
    A ReadOnlyJavaBeanIntegerPropertyBuilder可用于创建ReadOnlyJavaBeanIntegerProperties 。 要创建一个ReadOnlyJavaBeanIntegerProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的属性和bean(java.lang.Object)必须被指定。 如果吸气剂的名称符合惯例，这就足够了。 否则可以直接指定吸气剂（ getter(java.lang.String) ）或吸气剂Methods的替代名称（ getter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的多个实例生成适配器，则可以重新使用ReadOnlyJavaBeanIntegerPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyJavaBeanIntegerProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyJavaBeanIntegerPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanIntegerPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanIntegerPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanIntegerProperty build​()
      使用当前设置生成新的ReadOnlyJavaBeanIntegerProperty 。
      static ReadOnlyJavaBeanIntegerPropertyBuilder create​()
      创建一个新的实例 ReadOnlyJavaBeanIntegerPropertyBuilder
      ReadOnlyJavaBeanIntegerPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanIntegerPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanIntegerPropertyBuilder name​(String name)
      设置属性的名称

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ReadOnlyJavaBeanIntegerPropertyBuilder

        public ReadOnlyJavaBeanIntegerPropertyBuilder​()

    • 方法详细信息

      • create

        public static ReadOnlyJavaBeanIntegerPropertyBuilder create​()
        创建一个新的实例 ReadOnlyJavaBeanIntegerPropertyBuilder
        结果
        新的 ReadOnlyJavaBeanIntegerPropertyBuilder

      • build

        public ReadOnlyJavaBeanIntegerProperty build​()
                                      throws NoSuchMethodException
        使用当前设置生成新的ReadOnlyJavaBeanIntegerProperty 。
        结果
        新的 ReadOnlyJavaBeanIntegerProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter
        IllegalArgumentException - 如果Java Bean属性不是类型 int或 Integer

      • name

        public ReadOnlyJavaBeanIntegerPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public ReadOnlyJavaBeanIntegerPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public ReadOnlyJavaBeanIntegerPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanIntegerPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanIntegerPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        a reference to this builder to enable method chaining
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanLongProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
          • javafx.beans.property.ReadOnlyLongPropertyBase
            • javafx.beans.property.adapter.ReadOnlyJavaBeanLongProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， ReadOnlyJavaBeanProperty<Number> ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number>

    public final class ReadOnlyJavaBeanLongProperty
extends ReadOnlyLongPropertyBase
implements ReadOnlyJavaBeanProperty<Number>
    A ReadOnlyJavaBeanLongProperty在long或Long之间的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty提供了一个适配器。 它不能直接创建，但必须使用ReadOnlyJavaBeanLongPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter。 该类以及getter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个ReadOnlyJavaBeanLongProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。

    将应用程序部署为模块

    如果Java Bean类在命名模块中，那么javafx.base模块必须能够反映javafx.base 。 如果模块opens包含至少包含javafx.base模块，则类可以反射访问。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射地访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyLongProperty ， ReadOnlyJavaBeanLongPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      long get​()
      返回此 ObservableLongValue的当前值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from class javafx.beans.property.ReadOnlyLongProperty

        asObject, readOnlyLongProperty, toString

      • Methods inherited from class javafx.beans.property.ReadOnlyLongPropertyBase

        addListener, addListener, removeListener, removeListener

    • 方法详细信息

      • get

        public long get​()
        返回此 ObservableLongValue的当前值。
        Specified by:
        get在接口 ObservableLongValue
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<Number>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<Number>
        结果
        的名字或一个空的 String

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<Number>
        重写：
        fireValueChangedEvent在 ReadOnlyLongPropertyBase

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<Number>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanLongPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanLongPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.ReadOnlyJavaBeanLongPropertyBuilder

  • public final class ReadOnlyJavaBeanLongPropertyBuilder
extends Object
    A ReadOnlyJavaBeanLongPropertyBuilder可用于创建ReadOnlyJavaBeanLongProperties 。 要创建一个ReadOnlyJavaBeanLongProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的财产和bean(java.lang.Object)必须被指定。 如果吸气剂的名称符合惯例，这就足够了。 否则可以直接指定吸气剂（ getter(java.lang.String) ）或吸气剂Methods的替代名称（ getter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的几个实例的同一属性生成适配器，则可以重新使用ReadOnlyJavaBeanLongPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyJavaBeanLongProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyJavaBeanLongPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanLongPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanLongPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanLongProperty build​()
      使用当前设置生成新的ReadOnlyJavaBeanLongProperty 。
      static ReadOnlyJavaBeanLongPropertyBuilder create​()
      创建一个新的实例 ReadOnlyJavaBeanLongPropertyBuilder
      ReadOnlyJavaBeanLongPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanLongPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanLongPropertyBuilder name​(String name)
      设置属性的名称

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ReadOnlyJavaBeanLongPropertyBuilder

        public ReadOnlyJavaBeanLongPropertyBuilder​()

    • 方法详细信息

      • create

        public static ReadOnlyJavaBeanLongPropertyBuilder create​()
        创建一个新的实例 ReadOnlyJavaBeanLongPropertyBuilder
        结果
        新的 ReadOnlyJavaBeanLongPropertyBuilder

      • build

        public ReadOnlyJavaBeanLongProperty build​()
                                   throws NoSuchMethodException
        使用当前设置生成新的ReadOnlyJavaBeanLongProperty 。
        结果
        新的 ReadOnlyJavaBeanLongProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter
        IllegalArgumentException - 如果Java Bean属性不是类型 long或 Long

      • name

        public ReadOnlyJavaBeanLongPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public ReadOnlyJavaBeanLongPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public ReadOnlyJavaBeanLongPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanLongPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanLongPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        吸气剂 getter
        结果
        a reference to this builder to enable method chaining
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanObjectProperty<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
        • javafx.beans.property.ReadOnlyObjectPropertyBase<T>
          • javafx.beans.property.adapter.ReadOnlyJavaBeanObjectProperty<T>
  • All Implemented Interfaces:
    Observable ， ReadOnlyJavaBeanProperty<T> ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T>

    public final class ReadOnlyJavaBeanObjectProperty<T>
extends ReadOnlyObjectPropertyBase<T>
implements ReadOnlyJavaBeanProperty<T>
    A ReadOnlyJavaBeanObjectProperty在常规的只读Java Bean属性T和JavaFX ReadOnlyObjectProperty之间提供了一个适配器。 它不能直接创建，但必须使用ReadOnlyJavaBeanObjectPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter。 该类以及getter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果Java Bean属性被绑定（即它支持PropertyChangeListeners），那么这个ReadOnlyJavaBeanObjectProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。

    将应用程序部署为模块

    如果Java Bean类在一个命名的模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens包含至少包含javafx.base模块，则类可以反射访问。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyObjectProperty ， ReadOnlyJavaBeanObjectPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      T get​()
      返回此 ObservableObjectValue<T>的当前值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from class javafx.beans.property.ReadOnlyObjectProperty

        toString

      • Methods inherited from class javafx.beans.property.ReadOnlyObjectPropertyBase

        addListener, addListener, removeListener, removeListener

    • 方法详细信息

      • get

        public T get​()
        返回此 ObservableObjectValue<T>的当前值。
        Specified by:
        get在接口 ObservableObjectValue<T>
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<T>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<T>
        结果
        该名称或空的 String

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<T>
        重写：
        fireValueChangedEvent在 ReadOnlyObjectPropertyBase<T>

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<T>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanObjectPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanObjectPropertyBuilder<T>

  • java.lang.Object
    • javafx.beans.property.adapter.ReadOnlyJavaBeanObjectPropertyBuilder<T>

  • public final class ReadOnlyJavaBeanObjectPropertyBuilder<T>
extends Object
    A ReadOnlyJavaBeanObjectPropertyBuilder可以用来创建ReadOnlyJavaBeanObjectProperties 。 要创建一个ReadOnlyJavaBeanObjectProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的属性和bean(java.lang.Object)必须被指定。 如果吸气剂的名称符合惯例，这就足够了。 否则可以直接指定吸气剂（ getter(java.lang.String) ）或吸气剂Methods的替代名称（ getter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的多个实例的同一属性生成适配器，则可以重新使用ReadOnlyJavaBeanObjectPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyJavaBeanObjectProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyJavaBeanObjectPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanObjectPropertyBuilder<T> bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanObjectPropertyBuilder<T> beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanObjectProperty<T> build​()
      使用当前设置生成新的ReadOnlyJavaBeanObjectProperty 。
      static <T> ReadOnlyJavaBeanObjectPropertyBuilder<T> create​()
      创建一个新的实例 ReadOnlyJavaBeanObjectPropertyBuilder
      ReadOnlyJavaBeanObjectPropertyBuilder<T> getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanObjectPropertyBuilder<T> getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanObjectPropertyBuilder<T> name​(String name)
      设置属性的名称

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ReadOnlyJavaBeanObjectPropertyBuilder

        public ReadOnlyJavaBeanObjectPropertyBuilder​()

    • 方法详细信息

      • create

        public static <T> ReadOnlyJavaBeanObjectPropertyBuilder<T> create​()
        创建一个新的实例 ReadOnlyJavaBeanObjectPropertyBuilder
        参数类型
        T - 包装的类型 Object
        结果
        新的 ReadOnlyJavaBeanObjectPropertyBuilder

      • build

        public ReadOnlyJavaBeanObjectProperty<T> build​()
                                        throws NoSuchMethodException
        使用当前设置生成新的ReadOnlyJavaBeanObjectProperty 。
        结果
        新的 ReadOnlyJavaBeanObjectProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter

      • name

        public ReadOnlyJavaBeanObjectPropertyBuilder<T> name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public ReadOnlyJavaBeanObjectPropertyBuilder<T> bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public ReadOnlyJavaBeanObjectPropertyBuilder<T> beanClass​(Class<?> beanClass)
        设置要在其中搜索getter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanObjectPropertyBuilder<T> getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanObjectPropertyBuilder<T> getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        a reference to this builder to enable method chaining
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Interface ReadOnlyJavaBeanProperty<T>

  • 参数类型
    T - 包装属性的类型
    All Superinterfaces:
    Observable ， ObservableValue<T> ， ReadOnlyProperty<T>
    All Known Subinterfaces:
    JavaBeanProperty<T>
    所有已知实现类：
    JavaBeanBooleanProperty ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， JavaBeanObjectProperty ， JavaBeanStringProperty ， ReadOnlyJavaBeanBooleanProperty ， ReadOnlyJavaBeanDoubleProperty ， ReadOnlyJavaBeanFloatProperty ， ReadOnlyJavaBeanIntegerProperty ， ReadOnlyJavaBeanLongProperty ， ReadOnlyJavaBeanObjectProperty ， ReadOnlyJavaBeanStringProperty

    public interface ReadOnlyJavaBeanProperty<T>
extends ReadOnlyProperty<T>
    JavaBeanProperty是只读Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
    从以下版本开始：
    JavaFX 2.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

    • 方法详细信息

      • fireValueChangedEvent

        void fireValueChangedEvent​()
        如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。

      • dispose

        void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanStringProperty

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
        • javafx.beans.property.ReadOnlyStringPropertyBase
          • javafx.beans.property.adapter.ReadOnlyJavaBeanStringProperty
  • All Implemented Interfaces:
    Observable ， ReadOnlyJavaBeanProperty<String> ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String>

    public final class ReadOnlyJavaBeanStringProperty
extends ReadOnlyStringPropertyBase
implements ReadOnlyJavaBeanProperty<String>
    A ReadOnlyJavaBeanStringProperty在String类型的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。 它不能直接创建，但必须使用ReadOnlyJavaBeanStringPropertyBuilder 。

    至少Java Bean类必须为该属性实现一个getter。 该类以及getter方法必须被声明为public。 如果调用此类的实例的getter，则返回Java Bean的属性。 如果Java Bean属性是绑定的（即它支持PropertyChangeListeners），那么这个ReadOnlyJavaBeanStringProperty将会意识到Java Bean中的更改。 否则可以通过致电fireValueChangedEvent()通知有关更改。

    将应用程序部署为模块

    如果Java Bean类在一个命名的模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens包含至少包含javafx.base模块，则类可以反射访问。

    例如，如果com.foo.MyBeanClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射地访问类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyStringProperty ， ReadOnlyJavaBeanStringPropertyBuilder

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
      void fireValueChangedEvent​()
      发送所有附件的通知InvalidationListeners和ChangeListeners 。
      String get​()
      返回此 ObservableObjectValue<T>的当前值。
      Object getBean​()
      返回包含此属性的 Object 。
      String getName​()
      返回此属性的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from class javafx.beans.property.ReadOnlyStringProperty

        toString

      • Methods inherited from class javafx.beans.property.ReadOnlyStringPropertyBase

        addListener, addListener, removeListener, removeListener

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

    • 方法详细信息

      • get

        public String get​()
        返回此 ObservableObjectValue<T>的当前值。
        Specified by:
        get在接口 ObservableObjectValue<String>
        结果
        当前值
        异常
        UndeclaredThrowableException - 如果调用Java Bean属性的getter抛出一个 IllegalAccessException或一个 InvocationTargetException 。

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        Specified by:
        getBean在接口 ReadOnlyProperty<String>
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        Specified by:
        getName在接口 ReadOnlyProperty<String>
        结果
        名称或空的 String

      • fireValueChangedEvent

        public void fireValueChangedEvent​()
        发送所有附件的通知InvalidationListeners和ChangeListeners 。 如果此属性的值更改，则需要调用此方法。
        Specified by:
        fireValueChangedEvent在接口 ReadOnlyJavaBeanProperty<String>
        重写：
        fireValueChangedEvent在 ReadOnlyStringPropertyBase

      • dispose

        public void dispose​()
        信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。 此方法的调用通常导致属性停止通过注销其监听器来观察Java Bean属性。
        Specified by:
        dispose在接口 ReadOnlyJavaBeanProperty<String>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ReadOnlyJavaBeanStringPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.property.adapter

Class ReadOnlyJavaBeanStringPropertyBuilder

  • java.lang.Object
    • javafx.beans.property.adapter.ReadOnlyJavaBeanStringPropertyBuilder

  • public final class ReadOnlyJavaBeanStringPropertyBuilder
extends Object
    A ReadOnlyJavaBeanStringPropertyBuilder可以用来创建ReadOnlyJavaBeanStringProperties 。 要创建一个ReadOnlyJavaBeanStringProperty首先必须调用create()生成一个构建器，设置所需的属性，然后可以调用build()生成该属性。

    不是所有的构建器的属性都必须指定，可能有几种组合。 至少name(java.lang.String)的财产和bean(java.lang.Object)必须被指定。 如果吸气剂的名称符合惯例，这就足够了。 否则可以直接指定吸气剂（ getter(java.lang.String) ）或吸气剂Methods的替代名称（ getter(java.lang.reflect.Method) ）。

    所有更改属性的方法返回对此构建器的引用，以启用方法链接。

    如果必须为同一类的几个实例的同一属性生成适配器，则可以重新使用ReadOnlyJavaBeanStringPropertyBuilder 。 通过切换Java Bean实例（使用bean(java.lang.Object)并调用build()） 。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ReadOnlyJavaBeanStringProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReadOnlyJavaBeanStringPropertyBuilder​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanStringPropertyBuilder bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanStringPropertyBuilder beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanStringProperty build​()
      使用当前设置生成新的ReadOnlyJavaBeanStringProperty 。
      static ReadOnlyJavaBeanStringPropertyBuilder create​()
      创建一个新的实例 ReadOnlyJavaBeanStringPropertyBuilder
      ReadOnlyJavaBeanStringPropertyBuilder getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanStringPropertyBuilder getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanStringPropertyBuilder name​(String name)
      设置属性的名称

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ReadOnlyJavaBeanStringPropertyBuilder

        public ReadOnlyJavaBeanStringPropertyBuilder​()

    • 方法详细信息

      • create

        public static ReadOnlyJavaBeanStringPropertyBuilder create​()
        创建一个新的实例 ReadOnlyJavaBeanStringPropertyBuilder
        结果
        新的 ReadOnlyJavaBeanStringPropertyBuilder

      • build

        public ReadOnlyJavaBeanStringProperty build​()
                                     throws NoSuchMethodException
        使用当前设置生成新的ReadOnlyJavaBeanStringProperty 。
        结果
        新的 ReadOnlyJavaBeanStringProperty
        异常
        NoSuchMethodException - 如果设置不足以找到Java Bean属性的getter
        IllegalArgumentException - 如果Java Bean属性不是类型 String

      • name

        public ReadOnlyJavaBeanStringPropertyBuilder name​(String name)
        设置属性的名称
        参数
        name - 属性的名称
        结果
        引用此构建器来启用方法链接

      • bean

        public ReadOnlyJavaBeanStringPropertyBuilder bean​(Object bean)
        设置适配器应该连接的Java Bean实例
        参数
        bean - Java Bean实例
        结果
        引用此构建器来启用方法链接

      • beanClass

        public ReadOnlyJavaBeanStringPropertyBuilder beanClass​(Class<?> beanClass)
        设置要在其中搜索getter的Java Bean类。 如果构建器应为不同类型的Java Bean生成适配器，则这可能很有用。
        参数
        beanClass - Java Bean类
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanStringPropertyBuilder getter​(String getter)
        设置吸气剂的替代名称。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂的替代名称
        结果
        引用此构建器来启用方法链接

      • getter

        public ReadOnlyJavaBeanStringPropertyBuilder getter​(方法 getter)
        直接设置getter方法。 如果getter的名称遵循Java Bean命名约定，那么这可以省略。
        参数
        getter - 吸气剂
        结果
        a reference to this builder to enable method chaining
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.beans.property.adapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.beans.property.adapter

  • Packages that use javafx.beans.property.adapter
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
  • Classes in javafx.beans.property.adapter used by javafx.beans.property.adapter
    Class 描述
    JavaBeanBooleanProperty
    A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
    JavaBeanBooleanPropertyBuilder
    A JavaBeanBooleanPropertyBuilder可以用来创建JavaBeanBooleanProperties 。
    JavaBeanDoubleProperty
    A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
    JavaBeanDoublePropertyBuilder
    A JavaBeanDoublePropertyBuilder可以用来创建JavaBeanDoubleProperties 。
    JavaBeanFloatProperty
    A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
    JavaBeanFloatPropertyBuilder
    A JavaBeanFloatPropertyBuilder可以用来创建JavaBeanFloatProperties 。
    JavaBeanIntegerProperty
    A JavaBeanIntegerProperty在类型为 int或 Integer的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
    JavaBeanIntegerPropertyBuilder
    A JavaBeanIntegerPropertyBuilder可以用来创建JavaBeanIntegerProperties 。
    JavaBeanLongProperty
    A JavaBeanLongProperty在 long或 Long之间的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
    JavaBeanLongPropertyBuilder
    A JavaBeanLongPropertyBuilder可用于创建JavaBeanLongProperties 。
    JavaBeanObjectProperty
    一个 JavaBeanObjectProperty提供类型的普通的Java Bean属性之间的适配器 T和一个JavaFX ObjectProperty<T> 。
    JavaBeanObjectPropertyBuilder
    A JavaBeanObjectPropertyBuilder可以用来创建JavaBeanObjectProperties 。
    JavaBeanProperty
    JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
    JavaBeanStringProperty
    A JavaBeanStringProperty在类型为 String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。
    JavaBeanStringPropertyBuilder
    A JavaBeanStringPropertyBuilder可以用来创建JavaBeanStringProperties 。
    ReadOnlyJavaBeanBooleanProperty
    A ReadOnlyJavaBeanBooleanProperty在常规的只读Java Bean属性类型为 boolean或 Boolean和JavaFX ReadOnlyBooleanProperty之间提供了适配器。
    ReadOnlyJavaBeanBooleanPropertyBuilder
    A ReadOnlyJavaBeanBooleanPropertyBuilder可以用来创建ReadOnlyJavaBeanBooleanProperties 。
    ReadOnlyJavaBeanDoubleProperty
    A ReadOnlyJavaBeanDoubleProperty在 double或 Double之间的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。
    ReadOnlyJavaBeanDoublePropertyBuilder
    A ReadOnlyJavaBeanDoublePropertyBuilder可以用来创建ReadOnlyJavaBeanDoubleProperties 。
    ReadOnlyJavaBeanFloatProperty
    A ReadOnlyJavaBeanFloatProperty在 float或 Float的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。
    ReadOnlyJavaBeanFloatPropertyBuilder
    A ReadOnlyJavaBeanFloatPropertyBuilder可以用来创建ReadOnlyJavaBeanFloatProperties 。
    ReadOnlyJavaBeanIntegerProperty
    A ReadOnlyJavaBeanIntegerProperty在 int或 Integer之间的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty提供了一个适配器。
    ReadOnlyJavaBeanIntegerPropertyBuilder
    A ReadOnlyJavaBeanIntegerPropertyBuilder可以用来创建ReadOnlyJavaBeanIntegerProperties 。
    ReadOnlyJavaBeanLongProperty
    A ReadOnlyJavaBeanLongProperty在常规的只读Java Bean属性类型为 long或 Long和JavaFX ReadOnlyLongProperty之间提供了一个适配器。
    ReadOnlyJavaBeanLongPropertyBuilder
    A ReadOnlyJavaBeanLongPropertyBuilder可以用来创建ReadOnlyJavaBeanLongProperties 。
    ReadOnlyJavaBeanObjectProperty
    A ReadOnlyJavaBeanObjectProperty提供了常规的只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间的适配器。
    ReadOnlyJavaBeanObjectPropertyBuilder
    A ReadOnlyJavaBeanObjectPropertyBuilder可用于创建ReadOnlyJavaBeanObjectProperties 。
    ReadOnlyJavaBeanProperty
    JavaBeanProperty是只读Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
    ReadOnlyJavaBeanStringProperty
    A ReadOnlyJavaBeanStringProperty在 String类型的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。
    ReadOnlyJavaBeanStringPropertyBuilder
    A ReadOnlyJavaBeanStringPropertyBuilder can be used to create ReadOnlyJavaBeanStringProperties.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanBooleanProperty

  • Packages that use JavaBeanBooleanProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanBooleanProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanBooleanProperty
      Modifier and Type 方法 描述
      JavaBeanBooleanProperty JavaBeanBooleanPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanBooleanProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanBooleanPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanBooleanPropertyBuilder

  • Packages that use JavaBeanBooleanPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanBooleanPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanBooleanPropertyBuilder
      Modifier and Type 方法 描述
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      static JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.create​()
      创建一个新的实例 JavaBeanBooleanPropertyBuilder
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.name​(String name)
      设置属性的名称
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.setter​(String setter)
      为设定者设置一个替代名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanDoubleProperty

  • Packages that use JavaBeanDoubleProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanDoubleProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanDoubleProperty
      Modifier and Type 方法 描述
      JavaBeanDoubleProperty JavaBeanDoublePropertyBuilder.build​()
      使用当前设置生成新的JavaBeanDoubleProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanDoublePropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanDoublePropertyBuilder

  • Packages that use JavaBeanDoublePropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanDoublePropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanDoublePropertyBuilder
      Modifier and Type 方法 描述
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      static JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.create​()
      创建一个新的实例 JavaBeanDoublePropertyBuilder
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.name​(String name)
      设置属性的名称
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.setter​(String setter)
      为设定者设置一个替代名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanFloatProperty

  • Packages that use JavaBeanFloatProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanFloatProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanFloatProperty
      Modifier and Type 方法 描述
      JavaBeanFloatProperty JavaBeanFloatPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanFloatProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanFloatPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanFloatPropertyBuilder

  • Packages that use JavaBeanFloatPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanFloatPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanFloatPropertyBuilder
      Modifier and Type 方法 描述
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      static JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.create​()
      创建一个新的实例 JavaBeanFloatPropertyBuilder
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.name​(String name)
      设置属性的名称
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.setter​(String setter)
      为设定者设置一个替代名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanIntegerProperty

  • Packages that use JavaBeanIntegerProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanIntegerProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanIntegerProperty
      Modifier and Type 方法 描述
      JavaBeanIntegerProperty JavaBeanIntegerPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanIntegerProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanIntegerPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanIntegerPropertyBuilder

  • Packages that use JavaBeanIntegerPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanIntegerPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanIntegerPropertyBuilder
      Modifier and Type 方法 描述
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      static JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.create​()
      创建一个新的实例 JavaBeanIntegerPropertyBuilder
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.name​(String name)
      设置属性的名称
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.setter​(String setter)
      为设定者设置一个替代名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanLongProperty

  • Packages that use JavaBeanLongProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanLongProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanLongProperty
      Modifier and Type 方法 描述
      JavaBeanLongProperty JavaBeanLongPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanLongProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanLongPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanLongPropertyBuilder

  • Packages that use JavaBeanLongPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanLongPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanLongPropertyBuilder
      Modifier and Type 方法 描述
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      static JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.create​()
      创建一个新的实例 JavaBeanLongPropertyBuilder
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.name​(String name)
      设置属性的名称
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.setter​(String setter)
      为设定者设置一个替代名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanObjectProperty

  • Packages that use JavaBeanObjectProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanObjectProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanObjectProperty
      Modifier and Type 方法 描述
      JavaBeanObjectProperty<T> JavaBeanObjectPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanObjectProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanObjectPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanObjectPropertyBuilder

  • Packages that use JavaBeanObjectPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanObjectPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanObjectPropertyBuilder
      Modifier and Type 方法 描述
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      static JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.create​()
      创建一个新的实例 JavaBeanObjectPropertyBuilder
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.name​(String name)
      设置属性的名称
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.setter​(String setter)
      为设定者设置一个替代名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanStringProperty

  • Packages that use JavaBeanStringProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanStringProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanStringProperty
      Modifier and Type 方法 描述
      JavaBeanStringProperty JavaBeanStringPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanStringProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.JavaBeanStringPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.JavaBeanStringPropertyBuilder

  • Packages that use JavaBeanStringPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanStringPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return JavaBeanStringPropertyBuilder
      Modifier and Type 方法 描述
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      static JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.create​()
      创建一个新的实例 JavaBeanStringPropertyBuilder
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.name​(String name)
      设置属性的名称
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.setter​(String setter)
      为设定者设置一个替代名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanBooleanProperty

  • Packages that use ReadOnlyJavaBeanBooleanProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanBooleanProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanBooleanProperty
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanBooleanProperty ReadOnlyJavaBeanBooleanPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanBooleanProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanBooleanPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanBooleanPropertyBuilder

  • Packages that use ReadOnlyJavaBeanBooleanPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanBooleanPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanBooleanPropertyBuilder
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanBooleanPropertyBuilder ReadOnlyJavaBeanBooleanPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanBooleanPropertyBuilder ReadOnlyJavaBeanBooleanPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      static ReadOnlyJavaBeanBooleanPropertyBuilder ReadOnlyJavaBeanBooleanPropertyBuilder.create​()
      创建一个新的实例 ReadOnlyJavaBeanBooleanPropertyBuilder
      ReadOnlyJavaBeanBooleanPropertyBuilder ReadOnlyJavaBeanBooleanPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanBooleanPropertyBuilder ReadOnlyJavaBeanBooleanPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanBooleanPropertyBuilder ReadOnlyJavaBeanBooleanPropertyBuilder.name​(String name)
      Set the name of the property
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanDoubleProperty

  • Packages that use ReadOnlyJavaBeanDoubleProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanDoubleProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanDoubleProperty ReadOnlyJavaBeanDoublePropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanDoubleProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanDoublePropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanDoublePropertyBuilder

  • Packages that use ReadOnlyJavaBeanDoublePropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanDoublePropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanDoublePropertyBuilder
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanDoublePropertyBuilder ReadOnlyJavaBeanDoublePropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanDoublePropertyBuilder ReadOnlyJavaBeanDoublePropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      static ReadOnlyJavaBeanDoublePropertyBuilder ReadOnlyJavaBeanDoublePropertyBuilder.create​()
      创建一个新的实例 ReadOnlyJavaBeanDoublePropertyBuilder
      ReadOnlyJavaBeanDoublePropertyBuilder ReadOnlyJavaBeanDoublePropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanDoublePropertyBuilder ReadOnlyJavaBeanDoublePropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanDoublePropertyBuilder ReadOnlyJavaBeanDoublePropertyBuilder.name​(String name)
      Set the name of the property
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanFloatProperty

  • Packages that use ReadOnlyJavaBeanFloatProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanFloatProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanFloatProperty
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanFloatProperty ReadOnlyJavaBeanFloatPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanFloatProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanFloatPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanFloatPropertyBuilder

  • Packages that use ReadOnlyJavaBeanFloatPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanFloatPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanFloatPropertyBuilder
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanFloatPropertyBuilder ReadOnlyJavaBeanFloatPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanFloatPropertyBuilder ReadOnlyJavaBeanFloatPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      static ReadOnlyJavaBeanFloatPropertyBuilder ReadOnlyJavaBeanFloatPropertyBuilder.create​()
      创建一个新的实例 ReadOnlyJavaBeanFloatPropertyBuilder
      ReadOnlyJavaBeanFloatPropertyBuilder ReadOnlyJavaBeanFloatPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanFloatPropertyBuilder ReadOnlyJavaBeanFloatPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanFloatPropertyBuilder ReadOnlyJavaBeanFloatPropertyBuilder.name​(String name)
      Set the name of the property
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanIntegerProperty

  • Packages that use ReadOnlyJavaBeanIntegerProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanIntegerProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanIntegerProperty
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanIntegerProperty ReadOnlyJavaBeanIntegerPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanIntegerProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanIntegerPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanIntegerPropertyBuilder

  • Packages that use ReadOnlyJavaBeanIntegerPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanIntegerPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanIntegerPropertyBuilder
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanIntegerPropertyBuilder ReadOnlyJavaBeanIntegerPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanIntegerPropertyBuilder ReadOnlyJavaBeanIntegerPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      static ReadOnlyJavaBeanIntegerPropertyBuilder ReadOnlyJavaBeanIntegerPropertyBuilder.create​()
      创建一个新的实例 ReadOnlyJavaBeanIntegerPropertyBuilder
      ReadOnlyJavaBeanIntegerPropertyBuilder ReadOnlyJavaBeanIntegerPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanIntegerPropertyBuilder ReadOnlyJavaBeanIntegerPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanIntegerPropertyBuilder ReadOnlyJavaBeanIntegerPropertyBuilder.name​(String name)
      Set the name of the property
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanLongProperty

  • Packages that use ReadOnlyJavaBeanLongProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanLongProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanLongProperty
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanLongProperty ReadOnlyJavaBeanLongPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanLongProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanLongPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanLongPropertyBuilder

  • Packages that use ReadOnlyJavaBeanLongPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanLongPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanLongPropertyBuilder
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanLongPropertyBuilder ReadOnlyJavaBeanLongPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanLongPropertyBuilder ReadOnlyJavaBeanLongPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      static ReadOnlyJavaBeanLongPropertyBuilder ReadOnlyJavaBeanLongPropertyBuilder.create​()
      创建一个新的实例 ReadOnlyJavaBeanLongPropertyBuilder
      ReadOnlyJavaBeanLongPropertyBuilder ReadOnlyJavaBeanLongPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanLongPropertyBuilder ReadOnlyJavaBeanLongPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanLongPropertyBuilder ReadOnlyJavaBeanLongPropertyBuilder.name​(String name)
      Set the name of the property
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanObjectProperty

  • Packages that use ReadOnlyJavaBeanObjectProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanObjectProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanObjectProperty<T> ReadOnlyJavaBeanObjectPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanObjectProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanObjectPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanObjectPropertyBuilder

  • Packages that use ReadOnlyJavaBeanObjectPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanObjectPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanObjectPropertyBuilder
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanObjectPropertyBuilder<T> ReadOnlyJavaBeanObjectPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanObjectPropertyBuilder<T> ReadOnlyJavaBeanObjectPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      static <T> ReadOnlyJavaBeanObjectPropertyBuilder<T> ReadOnlyJavaBeanObjectPropertyBuilder.create​()
      创建一个新的实例 ReadOnlyJavaBeanObjectPropertyBuilder
      ReadOnlyJavaBeanObjectPropertyBuilder<T> ReadOnlyJavaBeanObjectPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanObjectPropertyBuilder<T> ReadOnlyJavaBeanObjectPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanObjectPropertyBuilder<T> ReadOnlyJavaBeanObjectPropertyBuilder.name​(String name)
      Set the name of the property
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanStringProperty

  • Packages that use ReadOnlyJavaBeanStringProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanStringProperty in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanStringProperty
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanStringProperty ReadOnlyJavaBeanStringPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanStringProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.adapter.ReadOnlyJavaBeanStringPropertyBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.adapter.ReadOnlyJavaBeanStringPropertyBuilder

  • Packages that use ReadOnlyJavaBeanStringPropertyBuilder
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanStringPropertyBuilder in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that return ReadOnlyJavaBeanStringPropertyBuilder
      Modifier and Type 方法 描述
      ReadOnlyJavaBeanStringPropertyBuilder ReadOnlyJavaBeanStringPropertyBuilder.bean​(Object bean)
      设置适配器应该连接的Java Bean实例
      ReadOnlyJavaBeanStringPropertyBuilder ReadOnlyJavaBeanStringPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      static ReadOnlyJavaBeanStringPropertyBuilder ReadOnlyJavaBeanStringPropertyBuilder.create​()
      创建一个新的实例 ReadOnlyJavaBeanStringPropertyBuilder
      ReadOnlyJavaBeanStringPropertyBuilder ReadOnlyJavaBeanStringPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanStringPropertyBuilder ReadOnlyJavaBeanStringPropertyBuilder.getter​(String getter)
      设置吸气剂的替代名称。
      ReadOnlyJavaBeanStringPropertyBuilder ReadOnlyJavaBeanStringPropertyBuilder.name​(String name)
      Set the name of the property
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.property.adapter.JavaBeanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.property.adapter.JavaBeanProperty

  • Packages that use JavaBeanProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of JavaBeanProperty in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement JavaBeanProperty
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty提供了一个 double或 Double的常规Java Bean属性和JavaFX DoubleProperty之间的适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在类型为 float或 Float的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
      class  JavaBeanStringProperty
      一个 JavaBeanStringProperty提供类型的普通的Java Bean属性之间的适配器 String和一个JavaFX StringProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.property.adapter.ReadOnlyJavaBeanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.property.adapter.ReadOnlyJavaBeanProperty

  • Packages that use ReadOnlyJavaBeanProperty
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyJavaBeanProperty in javafx.beans.property.adapter

      Subinterfaces of ReadOnlyJavaBeanProperty in javafx.beans.property.adapter
      Modifier and Type 接口 描述
      interface  JavaBeanProperty<T>
      JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
      Classes in javafx.beans.property.adapter that implement ReadOnlyJavaBeanProperty
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在类型为 boolean或 Boolean的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在类型为 int或 Integer的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
      class  JavaBeanStringProperty
      A JavaBeanStringProperty在类型为 String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanBooleanProperty
      A ReadOnlyJavaBeanBooleanProperty在 boolean或 Boolean之间的常规只读Java Bean属性和JavaFX ReadOnlyBooleanProperty提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在类型为 double或 Double的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在常规的只读Java Bean属性类型为 float或 Float和JavaFX ReadOnlyFloatProperty之间提供了适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在类型为 int或 Integer的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在 long或 Long之间的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanObjectProperty<T>
      A ReadOnlyJavaBeanObjectProperty在常规的只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanStringProperty
      A ReadOnlyJavaBeanStringProperty在类型为 String的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.BooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.BooleanProperty

  • Packages that use BooleanProperty
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of BooleanProperty in javafx.animation

      Methods in javafx.animation that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty Animation.autoReverseProperty​()
      定义 Animation是否在交替循环中反转方向。

    • Uses of BooleanProperty in javafx.beans.property

      Subclasses of BooleanProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  BooleanPropertyBase
      BooleanPropertyBase类是包含 boolean值的属性的基类。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleBooleanProperty
      该类提供了一个包含 boolean值的Property的全面实现。
      Methods in javafx.beans.property that return BooleanProperty
      Modifier and Type 方法 描述
      static BooleanProperty BooleanProperty.booleanProperty​(Property<Boolean> property)
      返回一个BooleanProperty的BooleanProperty 。

    • Uses of BooleanProperty in javafx.beans.property.adapter

      Subclasses of BooleanProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。

    • Uses of BooleanProperty in javafx.concurrent

      Methods in javafx.concurrent that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty ScheduledService.restartOnFailureProperty​()
      指示在Task中出现故障时，ScheduledService是否应自动重新启动。

    • Uses of BooleanProperty in javafx.css

      Subclasses of BooleanProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      该课程扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of BooleanProperty in javafx.scene

      Methods in javafx.scene that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty Group.autoSizeChildrenProperty​()
      控制这个 Group是否会在布局过程中自动将任何受管理的可调整大小的孩子调整为首选大小。
      BooleanProperty Node.cacheProperty​()
      系统的性能提示表明这个 Node应该被缓存为一个位图。
      BooleanProperty Node.disableProperty​()
      定义此 Node的个人禁用状态。
      BooleanProperty Node.focusTraversableProperty​()
      指定此 Node应该是聚焦遍历周期的一部分。
      BooleanProperty LightBase.lightOnProperty​()
      定义灯亮或熄灭。
      BooleanProperty Node.managedProperty​()
      定义该节点的布局是否由父节点管理。
      BooleanProperty Node.mouseTransparentProperty​()
      如果是 true ，这个节点（和它所有的孩子一起）对于鼠标事件是完全透明的。
      BooleanProperty Node.pickOnBoundsProperty​()
      定义当由 MouseEvent或 contains函数调用触发时，如何为此节点完成拣选计算。
      BooleanProperty PerspectiveCamera.verticalFieldOfViewProperty​()
      定义 fieldOfView属性是否适用于投影的垂直维度。
      BooleanProperty Node.visibleProperty​()
      指定此 Node和任何子节点是否应呈现为场景图的一部分。

    • Uses of BooleanProperty in javafx.scene.chart

      Methods in javafx.scene.chart that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty XYChart.alternativeColumnFillVisibleProperty​()
      如果为真，则替代垂直列将填充
      BooleanProperty XYChart.alternativeRowFillVisibleProperty​()
      如果为真，则替代的水平行将填充
      BooleanProperty Axis.animatedProperty​()
      当真实时，轴和其范围的任何更改将被动画化。
      BooleanProperty Chart.animatedProperty​()
      当真的任何数据变化将被动画。
      BooleanProperty Axis.autoRangingProperty​()
      当轴自动从数据中确定其范围时，这一点是正确的
      BooleanProperty PieChart.clockwiseProperty​()
      如果真的，我们从startAngle开始顺时针放置切片
      BooleanProperty AreaChart.createSymbolsProperty​()
      当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
      BooleanProperty LineChart.createSymbolsProperty​()
      当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
      BooleanProperty StackedAreaChart.createSymbolsProperty​()
      当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
      BooleanProperty NumberAxis.forceZeroInRangeProperty​()
      当真实零值始终包含在可见范围内时。
      BooleanProperty CategoryAxis.gapStartAndEndProperty​()
      如果这是真的，那么刻度之间的一半空格留在开始和结束
      BooleanProperty XYChart.horizontalGridLinesVisibleProperty​()
      如果水平网格线应绘制，则为真
      BooleanProperty XYChart.horizontalZeroLineVisibleProperty​()
      如果这是真的并且横轴具有正值和负值，则在零点处将绘制另外的轴线
      BooleanProperty PieChart.labelsVisibleProperty​()
      当绘制真实的饼图切片标签时
      BooleanProperty Chart.legendVisibleProperty​()
      当为true时，如果图表实现支持图例，图表将显示图例。
      BooleanProperty ValueAxis.minorTickVisibleProperty​()
      如果显示较小的刻度线，则为真
      BooleanProperty Axis.tickLabelsVisibleProperty​()
      如果显示标记标签，则为true
      BooleanProperty Axis.tickMarkVisibleProperty​()
      如果显示刻度线，则为真
      BooleanProperty XYChart.verticalGridLinesVisibleProperty​()
      如果绘制垂直网格线，则为真
      BooleanProperty XYChart.verticalZeroLineVisibleProperty​()
      如果这是真的并且垂直轴具有正值和负值，则在零点处将绘制另外的轴线

    • Uses of BooleanProperty in javafx.scene.control

      Methods in javafx.scene.control that return BooleanProperty
      Modifier and Type | 方法 | 描述
      BooleanProperty CheckBox.allowIndeterminateProperty​()
      确定用户是否切换复选框应该循环遍历所有三个状态：已 选中 ， 未选中和 未定义 。
      BooleanProperty TitledPane.animatedProperty​()
      TitledPane的动画状态。
      BooleanProperty ComboBoxBase.armedProperty​()
      表示ComboBox已经“布防”，使得鼠标释放将导致ComboBox ComboBoxBase.show()方法被调用。
      BooleanProperty Button.cancelButtonProperty​()
      取消按钮是接收键盘VK_ESC的按钮，如果场景中没有其他节点消耗它。
      BooleanProperty TableSelectionModel.cellSelectionEnabledProperty​()
      一个布尔属性，用于表示表是行还是单元格选择模式。
      BooleanProperty Tab.closableProperty​()
      此选项卡的可关闭状态。
      BooleanProperty TitledPane.collapsibleProperty​()
      TitledPane的可折叠状态。
      BooleanProperty Button.defaultButtonProperty​()
      默认按钮是接收键盘VK_ENTER的按钮，如果场景中没有其他节点消耗它。
      BooleanProperty MenuItem.disableProperty​()
      设置此MenuItem的单独禁用状态。
      BooleanProperty Tab.disableProperty​()
      设置此选项卡的禁用状态。
      BooleanProperty Cell.editableProperty​()
      表示该单元是否被允许进入编辑状态的属性。
      BooleanProperty ComboBoxBase.editableProperty​()
      指定ComboBox是否允许用户输入。
      BooleanProperty ListView.editableProperty​()
      指定此ListView是否可编辑 - 只有当ListView和ListCells都可编辑时，ListCell才能进入编辑状态。
      BooleanProperty Spinner.editableProperty​()
      可编辑属性用于指定用户输入是否可以输入到Spinner editor中 。
      BooleanProperty TableColumnBase.editableProperty​()
      指定此表列是否允许编辑。
      BooleanProperty TableView.editableProperty​()
      指定此TableView是否可编辑 - 只有TableView，TableColumn（如果适用）和TableCells中的TableCells都可以编辑，TableCell才能进入编辑状态。
      BooleanProperty TextInputControl.editableProperty​()
      指示该TextInputControl是否可以由用户编辑。
      BooleanProperty TreeTableView.editableProperty​()
      指定此TreeTableView是否可编辑 - 只有当TreeTableView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
      BooleanProperty TreeView.editableProperty​()
      指定此TreeView是否可编辑 - 只有当TreeView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
      BooleanProperty DialogPane.expandedProperty​()
      表示是否扩展了dialogPane。
      BooleanProperty TitledPane.expandedProperty​()
      TitledPane的扩展状态。
      BooleanProperty TreeItem.expandedProperty​()
      这个TreeItem的扩展状态。
      BooleanProperty ScrollPane.fitToHeightProperty​()
      如果为true，并且如果包含的节点是可调整大小，则节点将被保持调整大小以匹配ScrollPane视口的高度。
      BooleanProperty ScrollPane.fitToWidthProperty​()
      如果为true，并且如果包含的节点是可调整大小，那么该节点将保持调整大小以匹配ScrollPane视口的宽度。
      BooleanProperty CustomMenuItem.hideOnClickProperty​()
      如果为真，则在单击此菜单项时，将隐藏此菜单项和所有可见菜单。
      BooleanProperty CheckBoxTreeItem.independentProperty​()
      A BooleanProperty用于表示此CheckBoxTreeItem的独立状态。
      BooleanProperty CheckBox.indeterminateProperty​()
      确定复选框是否处于不确定状态。
      BooleanProperty CheckBoxTreeItem.indeterminateProperty​()
      A BooleanProperty用于表示此CheckBoxTreeItem的不确定状态。
      BooleanProperty Labeled.mnemonicParsingProperty​()
      助记符属性启用/禁用文本解析。
      BooleanProperty MenuItem.mnemonicParsingProperty​()
      助记符属性启用/禁用文本解析。
      BooleanProperty ScrollPane.pannableProperty​()
      指定用户是否应该能够使用鼠标平移视口。
      BooleanProperty TableColumnBase.reorderableProperty​()
      一个布尔属性可以打开和关闭此列的“可重新排序”（通过修改适当的 columns列表进行拖放 - 重新排序）始终是允许的）。
      BooleanProperty Dialog.resizableProperty​()
      表示对话框是否可调整大小。
      BooleanProperty TableColumnBase.resizableProperty​()
      用于指示此列的宽度是否可以更改。
      BooleanProperty TabPane.rotateGraphicProperty​()
      TabPane中选项卡的rotateGraphic状态。
      BooleanProperty CheckBox.selectedProperty​()
      指示是否选中此复选框。
      BooleanProperty CheckBoxTreeItem.selectedProperty​()
      A BooleanProperty用于表示此CheckBoxTreeItem的选定状态。
      BooleanProperty CheckMenuItem.selectedProperty​()
      表示此CheckMenuItem的当前状态。
      BooleanProperty | RadioMenuItem.selectedProperty​()
      BooleanProperty Toggle.selectedProperty​()
      该选择状态为此 Toggle 。
      BooleanProperty ToggleButton.selectedProperty​()
      指示是否选择此切换按钮。
      BooleanProperty TreeTableView.showRootProperty​()
      表示TreeTableView根节点是否可见的属性。
      BooleanProperty TreeView.showRootProperty​()
      表示TreeView根节点是否可见的属性。
      BooleanProperty Slider.showTickLabelsProperty​()
      表示应该显示刻度线的标签。
      BooleanProperty Slider.showTickMarksProperty​()
      指定Skin实现是否应显示刻度线。
      BooleanProperty DatePicker.showWeekNumbersProperty​()
      DatePicker弹出窗口是否应显示显示周数的列。
      BooleanProperty Slider.snapToTicksProperty​()
      指示 Slider的 Slider是否应始终与刻度线对齐。
      BooleanProperty TableColumnBase.sortableProperty​()
      用于打开和关闭此列的“可排序性”的布尔属性。
      BooleanProperty TableView.tableMenuButtonVisibleProperty​()
      当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TableColumn的无线菜单项。
      BooleanProperty TreeTableView.tableMenuButtonVisibleProperty​()
      当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TreeTableColumn的无线菜单项。
      BooleanProperty Labeled.underlineProperty​()
      是否所有文本都应加下划线。
      BooleanProperty MenuBar.useSystemMenuBarProperty​()
      如果当前平台支持，请使用系统菜单栏。
      BooleanProperty Slider.valueChangingProperty​()
      当为true时，表示此滑块的当前值正在更改。
      BooleanProperty MenuItem.visibleProperty​()
      指定此MenuItem是否应呈现为场景图的一部分。
      BooleanProperty TableColumnBase.visibleProperty​()
      切换此项将立即切换此列和所有子列的可见性。
      BooleanProperty Hyperlink.visitedProperty​()
      指示此链接是否已被“访问”。
      BooleanProperty SpinnerValueFactory.wrapAroundProperty​()
      wrapAround属性用于指定值factory是圆形的。
      BooleanProperty Labeled.wrapTextProperty​()
      如果文本运行超过了标签的宽度，则该变量指示文本是否应该包装到另一行。
      BooleanProperty TextArea.wrapTextProperty​()
      如果文本运行超出了 TextArea的宽度，则该变量指示文本是否应该包装到另一行。
      BooleanProperty Tooltip.wrapTextProperty​()
      如果文本运行超过工具提示的宽度，则该变量指示文本是否应该包装到另一行。

    • Uses of BooleanProperty in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty ComboBoxListCell.comboBoxEditableProperty​()
      表示ComboBox在向用户显示时是否可编辑的属性。
      BooleanProperty ComboBoxTableCell.comboBoxEditableProperty​()
      表示ComboBox在向用户显示时是否可编辑的属性。
      BooleanProperty ComboBoxTreeCell.comboBoxEditableProperty​()
      表示ComboBox在向用户显示时是否可编辑的属性。
      BooleanProperty ComboBoxTreeTableCell.comboBoxEditableProperty​()
      表示ComboBox在向用户显示时是否可编辑的属性。

    • Uses of BooleanProperty in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return BooleanProperty
      Modifier and Type 方法 描述
      protected BooleanProperty TextInputControlSkin.forwardBiasProperty​()
      插入偏倚的内容。 真正意味着对前进角色的偏见（true = leading / false = trailing）
      BooleanProperty ComboBoxListViewSkin.hideOnClickProperty​()
      默认情况下，只要点击ListView，该皮肤就会隐藏弹出窗口。
      BooleanProperty VirtualFlow.pannableProperty​()
      指示VirtualFlow视口是否能够被用户平移（通过鼠标或触摸事件）。
      BooleanProperty VirtualFlow.verticalProperty​()
      表明虚拟化的主要方向。

    • Uses of BooleanProperty in javafx.scene.effect

      Methods in javafx.scene.effect that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty DisplacementMap.wrapProperty​()
      是否定义从地图边缘外部获取的值是否“绕回”。

    • Uses of BooleanProperty in javafx.scene.image

      Methods in javafx.scene.image that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty ImageView.preserveRatioProperty​()
      指示当缩放以适应拟合边界框内的图像时是否保留源图像的宽高比。
      BooleanProperty ImageView.smoothProperty​()
      指示当转换或缩放源图像以适应 fitWidth和 fitHeight提供的边界框内时是否使用更好的质量过滤算法或更快的过滤算法。

    • Uses of BooleanProperty in javafx.scene.layout

      Methods in javafx.scene.layout that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty Region.cacheShapeProperty​()
      定义对系统的提示，指出用于定义区域背景的Shape是稳定的，可以从缓存中受益。
      BooleanProperty Region.centerShapeProperty​()
      定义形状是否位于区域的宽度或高度内。
      BooleanProperty HBox.fillHeightProperty​()
      是否调整大小的小孩将被调整大小以填补hbox的全部高度，或者按照 alignment vpos值进行调整，以调整其首选高度。
      BooleanProperty RowConstraints.fillHeightProperty​()
      行的垂直填充策略。
      BooleanProperty ColumnConstraints.fillWidthProperty​()
      列的横向填充策略。
      BooleanProperty VBox.fillWidthProperty​()
      是否调整大小的小孩将被调整大小以填满vbox的全部宽度，或者根据 alignment hpos值将其调整为首选宽度并对齐。
      BooleanProperty GridPane.gridLinesVisibleProperty​()
      仅用于调试目的：控制是否显示行是否显示网格板的行和列。
      BooleanProperty Region.scaleShapeProperty​()
      指定是否将形状（如果已定义）缩放以匹配“区域”的大小。
      BooleanProperty Region.snapToPixelProperty​()
      定义此区域是否将其子项的位置，间距和大小值调整为像素边界。

    • Uses of BooleanProperty in javafx.scene.media

      Methods in javafx.scene.media that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty MediaPlayer.autoPlayProperty​()
      是否应尽快开始播放。
      BooleanProperty AudioEqualizer.enabledProperty​()
      启用或禁用 AudioEqualizer 。
      BooleanProperty MediaPlayer.muteProperty​()
      播放器音频是否静音
      BooleanProperty MediaView.preserveRatioProperty​()
      是否在将其缩放以适应节点时保留介质的宽高比（宽/高）。
      BooleanProperty MediaView.smoothProperty​()
      如果设置为 true则在将此视频缩放以适应 fitWidth和 fitHeight提供的边界框内或当转换时，将使用更好的质量过滤算法。

    • Uses of BooleanProperty in javafx.scene.shape

      Methods in javafx.scene.shape that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty PathElement.absoluteProperty​()
      指示路径坐标是绝对还是相对的标志。
      BooleanProperty ArcTo.largeArcFlagProperty​()
      大弧标志。
      BooleanProperty Shape.smoothProperty​()
      定义 Shape是否使用抗锯齿提示。
      BooleanProperty ArcTo.sweepFlagProperty​()
      扫旗

    • Uses of BooleanProperty in javafx.scene.text

      Methods in javafx.scene.text that return BooleanProperty
      Modifier and Type | 方法 | 描述
      BooleanProperty | Text.caretBiasProperty​()
      BooleanProperty Text.strikethroughProperty​()
      定义每行文本是否应该有一行。
      BooleanProperty Text.underlineProperty​()
      定义每行文本是否应在其下方有一行。

    • Uses of BooleanProperty in javafx.scene.web

      Methods in javafx.scene.web that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty WebView.contextMenuEnabledProperty​()
      指定是否启用了上下文菜单。
      BooleanProperty WebEngine.javaScriptEnabledProperty​()
      指定是否启用JavaScript执行。

    • Uses of BooleanProperty in javafx.stage

      Methods in javafx.stage that return BooleanProperty
      Modifier and Type 方法 描述
      BooleanProperty PopupWindow.autoFixProperty​()
      这个便利变量指示当显示弹出窗口时，是否应自动更正其位置，使其不会最终定位在屏幕外。
      BooleanProperty PopupWindow.autoHideProperty​()
      指定弹出窗口是否应该自动隐藏。
      BooleanProperty PopupWindow.consumeAutoHidingEventsProperty​()
      指定是否应该使用引起Popup隐藏的事件。
      BooleanProperty Window.forceIntegerRenderScaleProperty​()
      当相关的输出比例有变化时，控制系统默认情况下是否设置整数渲染比例的布尔属性。
      BooleanProperty PopupWindow.hideOnEscapeProperty​()
      指定在弹出对焦时按下未处理的转义键时是否应该隐藏PopupWindow。
      BooleanProperty Stage.resizableProperty​()
      定义 Stage是否可由用户调整大小。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.BooleanPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.BooleanPropertyBase

  • Packages that use BooleanPropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of BooleanPropertyBase in javafx.beans.property

      Subclasses of BooleanPropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleBooleanProperty
      这个类提供了一个包含 boolean值的Property的完整实现。

    • Uses of BooleanPropertyBase in javafx.css

      Subclasses of BooleanPropertyBase in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      这个类扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.DoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.DoubleProperty

  • Packages that use DoubleProperty
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of DoubleProperty in javafx.animation

      Methods in javafx.animation that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty RotateTransition.byAngleProperty​()
      从这个 RotateTransition开始指定递增的停止角度值。
      DoubleProperty FadeTransition.byValueProperty​()
      指定从这个 FadeTransition开始的递增停止不透明度值。
      DoubleProperty ScaleTransition.byXProperty​()
      从这个 ScaleTransition开始指定递增的停止X比例值。
      DoubleProperty TranslateTransition.byXProperty​()
      指定从这个 TranslateTransition开始的递增的停止X坐标值。
      DoubleProperty ScaleTransition.byYProperty​()
      指定从这个 ScaleTransition开始的递增的停止Y比例值。
      DoubleProperty TranslateTransition.byYProperty​()
      指定从这个 TranslateTransition开始的递增的停止Y坐标值。
      DoubleProperty ScaleTransition.byZProperty​()
      从这个 ScaleTransition开始指定递增的停止Z比例值。
      DoubleProperty TranslateTransition.byZProperty​()
      指定从这个 TranslateTransition开始的递增的停止Z坐标值。
      DoubleProperty RotateTransition.fromAngleProperty​()
      指定此 RotateTransition的起始角度值。
      DoubleProperty FadeTransition.fromValueProperty​()
      指定此 FadeTransition的启动不透明度值。
      DoubleProperty ScaleTransition.fromXProperty​()
      指定此 ScaleTransition的起始X比例值。
      DoubleProperty TranslateTransition.fromXProperty​()
      指定此 TranslateTransition的起始X坐标值。
      DoubleProperty ScaleTransition.fromYProperty​()
      指定此 ScaleTransition的起始Y比例值。
      DoubleProperty TranslateTransition.fromYProperty​()
      指定此 TranslateTransition的起始Y坐标值。
      DoubleProperty ScaleTransition.fromZProperty​()
      指定此 ScaleTransition的起始Z刻度值。
      DoubleProperty TranslateTransition.fromZProperty​()
      指定此 TranslateTransition的起始Z坐标值。
      DoubleProperty Animation.rateProperty​()
      定义 Animation预计播放的方向/速度。
      DoubleProperty RotateTransition.toAngleProperty​()
      指定此 RotateTransition的停止角度值。
      DoubleProperty FadeTransition.toValueProperty​()
      指定此 FadeTransition的停止不透明度值。
      DoubleProperty ScaleTransition.toXProperty​()
      指定此 ScaleTransition的停止X比例值。
      DoubleProperty TranslateTransition.toXProperty​()
      指定此 TranslateTransition的停止X坐标值。
      DoubleProperty ScaleTransition.toYProperty​()
      这个停止Y刻度值这个 ScaleTransition 。
      DoubleProperty TranslateTransition.toYProperty​()
      指定此 TranslateTransition的停止Y坐标值。
      DoubleProperty ScaleTransition.toZProperty​()
      停止Z刻度值 ScaleTransition 。
      DoubleProperty TranslateTransition.toZProperty​()
      指定此 TranslateTransition的停止Z坐标值。

    • Uses of DoubleProperty in javafx.beans.property

      Subclasses of DoubleProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      该类提供了一个包含 double值的Property的完整实现。
      Methods in javafx.beans.property that return DoubleProperty
      Modifier and Type 方法 描述
      static DoubleProperty DoubleProperty.doubleProperty​(Property<Double> property)
      返回一个DoubleProperty ，其中包含一个Property并双向绑定到它。

    • Uses of DoubleProperty in javafx.beans.property.adapter

      Subclasses of DoubleProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在类型为 double或 Double的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。

    • Uses of DoubleProperty in javafx.css

      Subclasses of DoubleProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of DoubleProperty in javafx.scene

      Methods in javafx.scene that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty Camera.farClipProperty​()
      指定眼坐标空间中该 Camera的远剪裁平面的距离。
      DoubleProperty PerspectiveCamera.fieldOfViewProperty​()
      指定相机投影的视野角度，以度为单位。
      DoubleProperty SubScene.heightProperty​()
      定义这个 SubScene的高度
      DoubleProperty Node.layoutXProperty​()
      定义添加到此 Node的转换中用于布局目的的转换的x坐标。
      DoubleProperty Node.layoutYProperty​()
      定义添加到此 Node的转换中用于布局目的的转换的y坐标。
      DoubleProperty Camera.nearClipProperty​()
      指定眼睛坐标空间中 Camera的近剪取平面眼睛的距离。
      DoubleProperty Node.opacityProperty​()
      指定 Node出现的不透明（即固体）。
      DoubleProperty Node.rotateProperty​()
      定义关于 Node的中心的旋转角度，以度为单位。
      DoubleProperty Node.scaleXProperty​()
      定义坐标按照该 Node的X轴的对象中心进行缩放的因子。
      DoubleProperty Node.scaleYProperty​()
      定义坐标按照该 Node的Y轴的对象中心进行缩放的因子。
      DoubleProperty Node.scaleZProperty​()
      定义坐标按照该 Node的Z轴的对象中心进行缩放的因子。
      DoubleProperty Node.translateXProperty​()
      定义添加到此 Node的转换中的转换的x坐标。
      DoubleProperty Node.translateYProperty​()
      定义添加到此 Node的转换中的转换的y坐标。
      DoubleProperty Node.translateZProperty​()
      定义添加到该 Node的变换坐标中的平移的Z坐标。
      DoubleProperty Node.viewOrderProperty​()
      定义其父母中 Node的呈现和拣选顺序。
      DoubleProperty SubScene.widthProperty​()
      定义这个 SubScene的宽度

    • Uses of DoubleProperty in javafx.scene.canvas

      Methods in javafx.scene.canvas that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty Canvas.heightProperty​()
      定义画布的高度。
      DoubleProperty Canvas.widthProperty​()
      定义画布的宽度。

    • Uses of DoubleProperty in javafx.scene.chart

      Fields in javafx.scene.chart declared as DoubleProperty
      Modifier and Type Field 描述
      protected DoubleProperty ValueAxis.currentLowerBound
      该轴的lowerBound的当前值（最小值）。
      Methods in javafx.scene.chart that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty BarChart.barGapProperty​()
      在同一类别的酒吧之间留下的差距
      DoubleProperty BarChart.categoryGapProperty​()
      在不同类别的酒吧之间留下的差距
      DoubleProperty StackedBarChart.categoryGapProperty​()
      在不同类别的酒吧之间留下的差距
      DoubleProperty CategoryAxis.endMarginProperty​()
      最后一个刻度线与轴端之间的余量
      DoubleProperty PieChart.labelLineLengthProperty​()
      从饼图的外部到切片标签的线的长度。
      DoubleProperty ValueAxis.lowerBoundProperty​()
      该轴下限值（最小值）。
      DoubleProperty ValueAxis.minorTickLengthProperty​()
      小刻度线的长度。
      DoubleProperty PieChart.Data.pieValueProperty​()
      饼图的值
      DoubleProperty PieChart.startAngleProperty​()
      开始第一个饼切片的角度
      DoubleProperty CategoryAxis.startMarginProperty​()
      轴开始和第一个刻度线之间的余量
      DoubleProperty Axis.tickLabelGapProperty​()
      刻度标签和刻度线之间的差距
      DoubleProperty Axis.tickLabelRotationProperty​()
      刻度标记以其正常水平旋转。
      DoubleProperty Axis.tickLengthProperty​()
      刻度线的长度
      DoubleProperty NumberAxis.tickUnitProperty​()
      数据单位中每个主要刻度线之间的值。
      DoubleProperty ValueAxis.upperBoundProperty​()
      该轴上限值（最大值）。

    • Uses of DoubleProperty in javafx.scene.control

      Methods in javafx.scene.control that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty SpinnerValueFactory.DoubleSpinnerValueFactory.amountToStepByProperty​()
      设置每步增加或减少的量。
      DoubleProperty ScrollBar.blockIncrementProperty​()
      如果点击栏的轨道，调整滚动条的量。
      DoubleProperty Slider.blockIncrementProperty​()
      如果点击滑块的轨道，则调整滑块的量。
      DoubleProperty ButtonBar.buttonMinWidthProperty​()
      指定放置在此按钮栏中的所有按钮的最小宽度。
      DoubleProperty ListView.fixedCellSizeProperty​()
      指定此控件是否具有固定高度（指定值）的单元格。
      DoubleProperty TableView.fixedCellSizeProperty​()
      指定此控件是否具有固定高度（指定值）的单元格。
      DoubleProperty TreeTableView.fixedCellSizeProperty​()
      指定此控件是否具有固定高度（指定值）的单元格。
      DoubleProperty TreeView.fixedCellSizeProperty​()
      指定此控件是否具有固定高度（指定值）的单元格。
      DoubleProperty Labeled.graphicTextGapProperty​()
      图形和文字之间的空间量
      DoubleProperty Tooltip.graphicTextGapProperty​()
      图形和文字之间的空间量
      DoubleProperty ScrollPane.hmaxProperty​()
      此ScrollPane的最大允许 数为 hvalue 。
      DoubleProperty ScrollPane.hminProperty​()
      该ScrollPane的最小允许 值为hvalue 。
      DoubleProperty ScrollPane.hvalueProperty​()
      ScrollPane的当前水平滚动位置。
      DoubleProperty Labeled.lineSpacingProperty​()
      指定行之间的像素间距。
      DoubleProperty Slider.majorTickUnitProperty​()
      主要刻度线之间的单位距离。
      DoubleProperty PopupControl.maxHeightProperty​()
      覆盖控制计算最大高度的属性。
      DoubleProperty ScrollBar.maxProperty​()
      由该 ScrollBar表示的 ScrollBar 。
      DoubleProperty Slider.maxProperty​()
      由此滑块表示的最大值。
      DoubleProperty SpinnerValueFactory.DoubleSpinnerValueFactory.maxProperty​()
      设置该值工厂的最大允许值
      DoubleProperty PopupControl.maxWidthProperty​()
      覆盖控件计算出的最大宽度的属性。
      DoubleProperty TableColumnBase.maxWidthProperty​()
      表列允许调整大小的最大宽度。
      DoubleProperty PopupControl.minHeightProperty​()
      超越控制计算的最小高度的属性。
      DoubleProperty ScrollBar.minProperty​()
      由该 ScrollBar表示的 ScrollBar 。
      DoubleProperty Slider.minProperty​()
      由此滑块表示的最小值。
      DoubleProperty SpinnerValueFactory.DoubleSpinnerValueFactory.minProperty​()
      设置该值工厂的最小允许值
      DoubleProperty ScrollPane.minViewportHeightProperty​()
      指定ScrollPane视口的最小高度。
      DoubleProperty ScrollPane.minViewportWidthProperty​()
      指定ScrollPane视口的最小宽度。
      DoubleProperty PopupControl.minWidthProperty​()
      覆盖控制计算最小宽度的属性。
      DoubleProperty TableColumnBase.minWidthProperty​()
      允许表列调整大小的最小宽度。
      DoubleProperty SplitPane.Divider.positionProperty​()
      代表分隔符理想位置的位置，介于0.0和1.0（含）之间。 0.0表示最左侧或最上方，1.0表示右下角（取决于水平属性）。
      DoubleProperty PopupControl.prefHeightProperty​()
      用于覆盖控件计算的首选高度的属性。
      DoubleProperty ScrollPane.prefViewportHeightProperty​()
      指定ScrollPane视口的首选高度。
      DoubleProperty ScrollPane.prefViewportWidthProperty​()
      指定ScrollPane视口的首选宽度。
      DoubleProperty PopupControl.prefWidthProperty​()
      覆盖控件计算的首选宽度的属性。
      DoubleProperty TableColumnBase.prefWidthProperty​()
      TableColumn的首选宽度。
      DoubleProperty ProgressIndicator.progressProperty​()
      ProgressIndicator的实际进展。
      DoubleProperty TextArea.scrollLeftProperty​()
      内容水平滚动的像素数。
      DoubleProperty TextArea.scrollTopProperty​()
      垂直滚动内容的像素数。
      DoubleProperty TabPane.tabMaxHeightProperty​()
      TabPane中选项卡的最大高度。
      DoubleProperty TabPane.tabMaxWidthProperty​()
      TabPane中选项卡的最大宽度。
      DoubleProperty TabPane.tabMinHeightProperty​()
      标签的最小高度。
      DoubleProperty TabPane.tabMinWidthProperty​()
      TabPane中选项卡的最小宽度。
      DoubleProperty ScrollBar.unitIncrementProperty​()
      当 调用increment或 decrement方法时调整ScrollBar的量。
      DoubleProperty ScrollBar.valueProperty​()
      由此 ScrollBar表示的当前值。
      DoubleProperty Slider.valueProperty​()
      由此滑块表示的当前值。
      DoubleProperty ScrollBar.visibleAmountProperty​()
      滚动条的范围可见，通常由滚动条的大小表示。
      DoubleProperty ScrollPane.vmaxProperty​()
      此ScrollPane的最大允许 数为 vvalue 。
      DoubleProperty ScrollPane.vminProperty​()
      该ScrollPane的最小允许 值为vvalue 。
      DoubleProperty ScrollPane.vvalueProperty​()
      ScrollPane的当前垂直滚动位置。

    • Uses of DoubleProperty in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty VirtualFlow.fixedCellSizeProperty​()
      为了优化目的，一些用例可以交换动态单元格的速度 - 如果fixedCellSize大于零，我们将使用它，而不是通过查询单元本身来确定它。
      DoubleProperty TreeCellSkin.indentProperty​()
      要获取树形单元格的左边距的树形空间乘以的空间量。
      DoubleProperty TreeTableRowSkin.indentProperty​()
      要获取树形单元格的左边距的树形空间乘以的空间量。
      DoubleProperty VirtualFlow.positionProperty​()
      VirtualFlow在其单元格列表中的位置。
      DoubleProperty MenuBarSkin.spacingProperty​()
      指定MenuBar上的菜单按钮之间的间距。

    • Uses of DoubleProperty in javafx.scene.effect

      Methods in javafx.scene.effect that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty MotionBlur.angleProperty​()
      运动效果的角度，以度为单位。
      DoubleProperty Light.Distant.azimuthProperty​()
      光的方位角。
      DoubleProperty Reflection.bottomOpacityProperty​()
      底部的不透明度值，它是底部极端反射的不透明度。
      DoubleProperty ColorAdjust.brightnessProperty​()
      亮度调节值。
      DoubleProperty InnerShadow.chokeProperty​()
      阴影的cho子。
      DoubleProperty ColorAdjust.contrastProperty​()
      对比度调整值。
      DoubleProperty Lighting.diffuseConstantProperty​()
      漫反射常数。
      DoubleProperty Light.Distant.elevationProperty​()
      光的高度。
      DoubleProperty Reflection.fractionProperty​()
      在反射中可见的输入分数。
      DoubleProperty BoxBlur.heightProperty​()
      模糊效果的垂直尺寸。
      DoubleProperty ColorInput.heightProperty​()
      相对于内容 Node的局部坐标空间设置要淹没的区域的高度。
      DoubleProperty DropShadow.heightProperty​()
      阴影模糊内核的垂直尺寸。
      DoubleProperty InnerShadow.heightProperty​()
      阴影模糊内核的垂直尺寸。
      DoubleProperty Shadow.heightProperty​()
      阴影模糊内核的垂直尺寸。
      DoubleProperty ColorAdjust.hueProperty​()
      色调调整值。
      DoubleProperty Glow.levelProperty​()
      水平值，用于控制发光效果的强度。
      DoubleProperty SepiaTone.levelProperty​()
      水平值，其控制棕褐色效果的强度。
      DoubleProperty PerspectiveTransform.llxProperty​()
      源的左下角映射到的输出位置的x坐标。
      DoubleProperty PerspectiveTransform.llyProperty​()
      源的左下角映射到的输出位置的y坐标。
      DoubleProperty PerspectiveTransform.lrxProperty​()
      源映射到其右下角的输出位置的x坐标。
      DoubleProperty PerspectiveTransform.lryProperty​()
      映射源的右下角的输出位置的y坐标。
      DoubleProperty DisplacementMap.offsetXProperty​()
      FloatMap中的所有x坐标偏移值在被缩放之后被移位的偏移量。
      DoubleProperty DropShadow.offsetXProperty​()
      x方向的阴影偏移量，以像素为单位。
      DoubleProperty InnerShadow.offsetXProperty​()
      x方向的阴影偏移量，以像素为单位。
      DoubleProperty DisplacementMap.offsetYProperty​()
      FloatMap中的所有y坐标偏移值在被缩放之后被偏移的位移。
      DoubleProperty DropShadow.offsetYProperty​()
      y方向的阴影偏移，以像素为单位。
      DoubleProperty InnerShadow.offsetYProperty​()
      y方向的阴影偏移，以像素为单位。
      DoubleProperty Blend.opacityProperty​()
      不透明度值，它在混合前用顶部输入进行调制。
      DoubleProperty Light.Spot.pointsAtXProperty​()
      该光的方向矢量的x坐标。
      DoubleProperty Light.Spot.pointsAtYProperty​()
      该光的方向矢量的y坐标。
      DoubleProperty Light.Spot.pointsAtZProperty​()
      该光的方向矢量的z坐标。
      DoubleProperty DropShadow.radiusProperty​()
      阴影模糊内核的半径。
      DoubleProperty GaussianBlur.radiusProperty​()
      模糊内核的半径。
      DoubleProperty InnerShadow.radiusProperty​()
      阴影模糊内核的半径。
      DoubleProperty MotionBlur.radiusProperty​()
      模糊内核的半径。
      DoubleProperty Shadow.radiusProperty​()
      阴影模糊内核的半径。
      DoubleProperty ColorAdjust.saturationProperty​()
      饱和度调整值。
      DoubleProperty DisplacementMap.scaleXProperty​()
      FloatMap中所有x坐标偏移值的比例因子相乘。
      DoubleProperty DisplacementMap.scaleYProperty​()
      FloatMap中所有y坐标偏移值的比例因子相乘。
      DoubleProperty Lighting.specularConstantProperty​()
      镜面常数。
      DoubleProperty Light.Spot.specularExponentProperty​()
      镜面指数，控制这个光源的焦点。
      DoubleProperty Lighting.specularExponentProperty​()
      镜面指数。
      DoubleProperty DropShadow.spreadProperty​()
      阴影的传播。
      DoubleProperty Lighting.surfaceScaleProperty​()
      表面比例因子。
      DoubleProperty Bloom.thresholdProperty​()
      阈值控制将被发光的像素的最小亮度值。
      DoubleProperty Reflection.topOffsetProperty​()
      顶部偏移调整，即输入底部与反射顶部之间的距离。
      DoubleProperty Reflection.topOpacityProperty​()
      最高的不透明度值是反射在其顶端极端的不透明度。
      DoubleProperty PerspectiveTransform.ulxProperty​()
      源的左上角映射到的输出位置的x坐标。
      DoubleProperty PerspectiveTransform.ulyProperty​()
      源的左上角映射到的输出位置的y坐标。
      DoubleProperty PerspectiveTransform.urxProperty​()
      源映射到其右上角的输出位置的x坐标。
      DoubleProperty PerspectiveTransform.uryProperty​()
      映射源的右上角的输出位置的y坐标。
      DoubleProperty BoxBlur.widthProperty​()
      模糊效果的水平维度。
      DoubleProperty ColorInput.widthProperty​()
      相对于内容 Node的局部坐标空间设置要淹没的区域的宽度。
      DoubleProperty DropShadow.widthProperty​()
      阴影模糊内核的水平尺寸。
      DoubleProperty InnerShadow.widthProperty​()
      阴影模糊内核的水平尺寸。
      DoubleProperty Shadow.widthProperty​()
      阴影模糊内核的水平尺寸。
      DoubleProperty ColorInput.xProperty​()
      相对于内容 Node的本地坐标空间设置要淹没的区域的x位置。
      DoubleProperty ImageInput.xProperty​()
      相对于内容 Node的本地坐标空间设置源图像的x位置。
      DoubleProperty Light.Point.xProperty​()
      光位置的x坐标。
      DoubleProperty ColorInput.yProperty​()
      相对于内容 Node的本地坐标空间设置要淹没的区域的y位置。
      DoubleProperty ImageInput.yProperty​()
      设置源图像的y位置，相对于内容 Node的局部坐标空间。
      DoubleProperty Light.Point.yProperty​()
      光位置的y坐标。
      DoubleProperty Light.Point.zProperty​()
      光位置的z坐标。

    • Uses of DoubleProperty in javafx.scene.image

      Methods in javafx.scene.image that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty ImageView.fitHeightProperty​()
      根据需要调整大小的源图像的边界框的高度。
      DoubleProperty ImageView.fitWidthProperty​()
      根据需要调整源图像大小的边框的宽度。
      DoubleProperty ImageView.xProperty​()
      当前的x坐标 ImageView起源。
      DoubleProperty ImageView.yProperty​()
      当前y坐标的 ImageView起源。

    • Uses of DoubleProperty in javafx.scene.layout

      Methods in javafx.scene.layout that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty FlowPane.hgapProperty​()
      水平流图中每个节点之间的水平空间量或垂直流动叶片中的列间空间量。
      DoubleProperty GridPane.hgapProperty​()
      列之间的水平间隙的宽度。
      DoubleProperty TilePane.hgapProperty​()
      一行中每个图块之间的水平空间量。
      DoubleProperty Region.maxHeightProperty​()
      覆盖该地区计算出的最大高度的属性。
      DoubleProperty RowConstraints.maxHeightProperty​()
      行的最大高度。
      DoubleProperty ColumnConstraints.maxWidthProperty​()
      列的最大宽度。
      DoubleProperty Region.maxWidthProperty​()
      覆盖该地区计算出的最大宽度的属性。
      DoubleProperty Region.minHeightProperty​()
      覆盖该地区计算最小高度的属性。
      DoubleProperty RowConstraints.minHeightProperty​()
      行的最小高度。
      DoubleProperty ColumnConstraints.minWidthProperty​()
      列的最小宽度。
      DoubleProperty Region.minWidthProperty​()
      覆盖该地区计算出的最小宽度的属性。
      DoubleProperty RowConstraints.percentHeightProperty​()
      行的高度百分比。
      DoubleProperty ColumnConstraints.percentWidthProperty​()
      列的宽度百分比。
      DoubleProperty Region.prefHeightProperty​()
      覆盖该地区计算的首选高度的属性。
      DoubleProperty RowConstraints.prefHeightProperty​()
      行的首选高度。
      DoubleProperty TilePane.prefTileHeightProperty​()
      每个瓷砖的首选高度。
      DoubleProperty TilePane.prefTileWidthProperty​()
      每个瓷砖的首选宽度。
      DoubleProperty ColumnConstraints.prefWidthProperty​()
      列的首选宽度。
      DoubleProperty Region.prefWidthProperty​()
      覆盖该地区计算的首选宽度的属性。
      DoubleProperty FlowPane.prefWrapLengthProperty​()
      其中内容应包装在水平花式板中的优选宽度或其中内容应包装在垂直透光板中的优选高度。
      DoubleProperty HBox.spacingProperty​()
      hbox中每个孩子之间的水平空间量。
      DoubleProperty VBox.spacingProperty​()
      vbox中每个孩子之间的垂直空间量。
      DoubleProperty FlowPane.vgapProperty​()
      垂直花式板中每个节点之间的垂直空间量或水平流动叶片中的行间距。
      DoubleProperty GridPane.vgapProperty​()
      行之间的垂直间隙的高度。
      DoubleProperty TilePane.vgapProperty​()
      列中每个图块之间的垂直空间量。

    • Uses of DoubleProperty in javafx.scene.media

      Methods in javafx.scene.media that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty MediaPlayer.audioSpectrumIntervalProperty​()
      频谱更新之间的间隔（秒）。
      DoubleProperty AudioClip.balanceProperty​()
      剪辑的相对左右音量级别。
      DoubleProperty MediaPlayer.balanceProperty​()
      音频输出的平衡或左右设置。
      DoubleProperty EqualizerBand.bandwidthProperty​()
      带的带宽以赫兹为单位。
      DoubleProperty EqualizerBand.centerFrequencyProperty​()
      乐队的中心频率为赫兹。
      DoubleProperty MediaView.fitHeightProperty​()
      确定必要时调整大小的源介质的边界框的高度。
      DoubleProperty MediaView.fitWidthProperty​()
      确定根据需要调整大小的源介质的边界框的宽度。
      DoubleProperty EqualizerBand.gainProperty​()
      应用于该频带的频率的增益。
      DoubleProperty AudioClip.panProperty​()
      剪辑的相对“中心”。
      DoubleProperty AudioClip.rateProperty​()
      剪辑播放的相对速率。
      DoubleProperty MediaPlayer.rateProperty​()
      要播放媒体的速度。
      DoubleProperty AudioClip.volumeProperty​()
      剪辑播放的相对音量级别。
      DoubleProperty MediaPlayer.volumeProperty​()
      要播放媒体的音量。
      DoubleProperty MediaView.xProperty​()
      定义 MediaView原点的当前x坐标。
      DoubleProperty MediaView.yProperty​()
      定义 MediaView原点的当前y坐标。

    • Uses of DoubleProperty in javafx.scene.paint

      Methods in javafx.scene.paint that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty PhongMaterial.specularPowerProperty​()
      这镜子的力量 PhongMaterial 。

    • Uses of DoubleProperty in javafx.scene.shape

      Methods in javafx.scene.shape that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty Rectangle.arcHeightProperty​()
      定义矩形四角的圆弧的垂直直径。
      DoubleProperty Rectangle.arcWidthProperty​()
      定义矩形四角的圆弧的水平直径。
      DoubleProperty Arc.centerXProperty​()
      定义圆弧中心点的X坐标。
      DoubleProperty Circle.centerXProperty​()
      以像素为单位定义圆心的水平位置。
      DoubleProperty Ellipse.centerXProperty​()
      定义椭圆中心的水平位置（以像素为单位）。
      DoubleProperty Arc.centerYProperty​()
      定义圆弧中心点的Y坐标。
      DoubleProperty Circle.centerYProperty​()
      定义圆心的垂直位置，以像素为单位。
      DoubleProperty Ellipse.centerYProperty​()
      定义椭圆中心的垂直位置（以像素为单位）。
      DoubleProperty CubicCurve.controlX1Property​()
      定义三次曲线段的第一个控制点的X坐标。
      DoubleProperty CubicCurveTo.controlX1Property​()
      定义第一个Bézier控制点的X坐标。
      DoubleProperty CubicCurve.controlX2Property​()
      定义三次曲线段的第二个控制点的X坐标。
      DoubleProperty CubicCurveTo.controlX2Property​()
      定义第二个Bézier控制点的X坐标。
      DoubleProperty QuadCurve.controlXProperty​()
      定义二次曲线段的控制点的X坐标。
      DoubleProperty QuadCurveTo.controlXProperty​()
      定义二次控制点的X坐标。
      DoubleProperty CubicCurve.controlY1Property​()
      定义三次曲线段的第一个控制点的Y坐标。
      DoubleProperty CubicCurveTo.controlY1Property​()
      定义第一个Bézier控制点的Y坐标。
      DoubleProperty CubicCurve.controlY2Property​()
      定义三次曲线段的第二个控制点的Y坐标。
      DoubleProperty CubicCurveTo.controlY2Property​()
      定义第二个Bézier控制点的Y坐标。
      DoubleProperty QuadCurve.controlYProperty​()
      定义二次曲线段控制点的Y坐标。
      DoubleProperty QuadCurveTo.controlYProperty​()
      定义二次控制点的Y坐标。
      DoubleProperty Box.depthProperty​()
      定义Box的深度或Z尺寸。
      DoubleProperty CubicCurve.endXProperty​()
      定义三次曲线段终点的X坐标。
      DoubleProperty Line.endXProperty​()
      线段终点的X坐标。
      DoubleProperty QuadCurve.endXProperty​()
      定义二次曲线段终点的X坐标。
      DoubleProperty CubicCurve.endYProperty​()
      定义三次曲线段终点的Y坐标。
      DoubleProperty Line.endYProperty​()
      线段终点的Y坐标。
      DoubleProperty QuadCurve.endYProperty​()
      定义二次曲线段终点的Y坐标。
      DoubleProperty Box.heightProperty​()
      定义Box的高度或Y尺寸。
      DoubleProperty Cylinder.heightProperty​()
      定义气缸的高度或Y尺寸。
      DoubleProperty Rectangle.heightProperty​()
      定义矩形的高度。
      DoubleProperty Arc.lengthProperty​()
      以弧度定义弧的角度范围。
      DoubleProperty Circle.radiusProperty​()
      定义圆的半径，以像素为单位。
      DoubleProperty Cylinder.radiusProperty​()
      定义圆柱体Z平面中的半径。
      DoubleProperty Sphere.radiusProperty​()
      定义球体的半径。
      DoubleProperty Arc.radiusXProperty​()
      定义整个椭圆的整体宽度（水平半径），其中该弧是部分截面。
      DoubleProperty ArcTo.radiusXProperty​()
      用于电弧的水平半径。
      DoubleProperty Ellipse.radiusXProperty​()
      定义椭圆的宽度（以像素为单位）。
      DoubleProperty Arc.radiusYProperty​()
      定义整个椭圆的整体高度（垂直半径），其中该弧是部分截面。
      DoubleProperty ArcTo.radiusYProperty​()
      用于电弧的垂直半径。
      DoubleProperty Ellipse.radiusYProperty​()
      以像素为单位定义椭圆的高度。
      DoubleProperty Arc.startAngleProperty​()
      以弧度定义圆弧的起始角度。
      DoubleProperty CubicCurve.startXProperty​()
      定义三次曲线段起始点的X坐标。
      DoubleProperty Line.startXProperty​()
      线段起始点的X坐标。
      DoubleProperty QuadCurve.startXProperty​()
      定义二次曲线段起始点的X坐标。
      DoubleProperty CubicCurve.startYProperty​()
      定义三次曲线段起始点的Y坐标。
      DoubleProperty Line.startYProperty​()
      线段起始点的Y坐标。
      DoubleProperty QuadCurve.startYProperty​()
      定义二次曲线段起始点的Y坐标。
      DoubleProperty Shape.strokeDashOffsetProperty​()
      定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。
      DoubleProperty Shape.strokeMiterLimitProperty​()
      定义 StrokeLineJoin.MITER线连接样式的限制。
      DoubleProperty Shape.strokeWidthProperty​()
      定义方形笔线宽度。
      DoubleProperty Box.widthProperty​()
      定义Box的宽度或X尺寸。
      DoubleProperty Rectangle.widthProperty​()
      定义矩形的宽度。
      DoubleProperty ArcTo.XAxisRotationProperty​()
      x轴旋转度。
      DoubleProperty ArcTo.xProperty​()
      x坐标到弧。
      DoubleProperty CubicCurveTo.xProperty​()
      定义最终终点的X坐标。
      DoubleProperty HLineTo.xProperty​()
      定义X坐标。
      DoubleProperty LineTo.xProperty​()
      定义X坐标。
      DoubleProperty MoveTo.xProperty​()
      定义指定的X坐标。
      DoubleProperty QuadCurveTo.xProperty​()
      定义最终终点的X坐标。
      DoubleProperty Rectangle.xProperty​()
      定义矩形左上角的X坐标。
      DoubleProperty ArcTo.yProperty​()
      y坐标到弧。
      DoubleProperty CubicCurveTo.yProperty​()
      定义最终终点的Y坐标。
      DoubleProperty LineTo.yProperty​()
      定义Y坐标。
      DoubleProperty MoveTo.yProperty​()
      定义指定的Y坐标。
      DoubleProperty QuadCurveTo.yProperty​()
      定义最终终点的Y坐标。
      DoubleProperty Rectangle.yProperty​()
      定义矩形左上角的Y坐标。
      DoubleProperty VLineTo.yProperty​()
      定义Y坐标。

    • Uses of DoubleProperty in javafx.scene.text

      Methods in javafx.scene.text that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty Text.lineSpacingProperty​()
      定义行之间像素的垂直空间。
      DoubleProperty TextFlow.lineSpacingProperty​()
      定义行之间像素的垂直空间。
      DoubleProperty Text.wrappingWidthProperty​()
      定义用户空间坐标中文本的宽度约束，例如像素，而不是字形或字符数。
      DoubleProperty Text.xProperty​()
      定义文本原点的X坐标。
      DoubleProperty Text.yProperty​()
      定义文本原点的Y坐标。

    • Uses of DoubleProperty in javafx.scene.transform

      Methods in javafx.scene.transform that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty Rotate.angleProperty​()
      定义以度为单位的旋转角度。
      DoubleProperty Affine.mxxProperty​()
      定义3x4矩阵的X坐标缩放元素。
      DoubleProperty Affine.mxyProperty​()
      定义3x4矩阵的XY坐标元素。
      DoubleProperty Affine.mxzProperty​()
      定义3x4矩阵的XZ坐标元素。
      DoubleProperty Affine.myxProperty​()
      定义3x4矩阵的YX坐标元素。
      DoubleProperty Affine.myyProperty​()
      定义3x4矩阵的Y坐标缩放元素。
      DoubleProperty Affine.myzProperty​()
      定义3x4矩阵的YZ坐标元素。
      DoubleProperty Affine.mzxProperty​()
      定义3x4矩阵的ZX坐标元素。
      DoubleProperty Affine.mzyProperty​()
      定义3x4矩阵的ZY坐标元素。
      DoubleProperty Affine.mzzProperty​()
      定义3x4矩阵的Z坐标缩放元素。
      DoubleProperty Rotate.pivotXProperty​()
      定义旋转枢轴点的X坐标。
      DoubleProperty Scale.pivotXProperty​()
      定义刻度出现点的X坐标。
      DoubleProperty Shear.pivotXProperty​()
      定义剪切枢轴点的X坐标。
      DoubleProperty Rotate.pivotYProperty​()
      定义旋转枢轴点的Y坐标。
      DoubleProperty Scale.pivotYProperty​()
      定义关于刻度出现点的Y坐标。
      DoubleProperty Shear.pivotYProperty​()
      定义剪切枢轴点的Y坐标。
      DoubleProperty Rotate.pivotZProperty​()
      定义旋转枢轴点的Z坐标。
      DoubleProperty Scale.pivotZProperty​()
      定义刻度出现点的Z坐标。
      DoubleProperty Affine.txProperty​()
      定义3x4矩阵的X坐标转换元素。
      DoubleProperty Affine.tyProperty​()
      定义3x4矩阵的Y坐标转换元素。
      DoubleProperty Affine.tzProperty​()
      定义3x4矩阵的Z坐标转换元素。
      DoubleProperty Scale.xProperty​()
      定义坐标沿X轴方向缩放的因子。
      DoubleProperty Shear.xProperty​()
      定义坐标沿正X轴方向移动的乘数，作为其Y坐标系数。
      DoubleProperty Translate.xProperty​()
      定义坐标在X轴方向上平移的距离
      DoubleProperty Scale.yProperty​()
      定义坐标沿Y轴方向缩放的因子。
      DoubleProperty Shear.yProperty​()
      定义坐标在正Y轴的方向上作为其X坐标系数的乘数。
      DoubleProperty Translate.yProperty​()
      定义坐标在Y轴方向上平移的距离
      DoubleProperty Scale.zProperty​()
      定义坐标沿Z轴方向缩放的因子。
      DoubleProperty Translate.zProperty​()
      定义坐标在Z轴方向上平移的距离

    • Uses of DoubleProperty in javafx.scene.web

      Methods in javafx.scene.web that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty WebView.fontScaleProperty​()
      指定应用于字体的比例因子。
      DoubleProperty WebView.maxHeightProperty​()
      最大高度属性。
      DoubleProperty WebView.maxWidthProperty​()
      最大宽度属性。
      DoubleProperty WebView.minHeightProperty​()
      最小高度属性。
      DoubleProperty WebView.minWidthProperty​()
      最小宽度属性。
      DoubleProperty WebView.prefHeightProperty​()
      首选高度属性。
      DoubleProperty WebView.prefWidthProperty​()
      首选宽度属性。
      DoubleProperty WebView.zoomProperty​()
      当前缩放因子应用于整个页面内容。

    • Uses of DoubleProperty in javafx.stage

      Methods in javafx.stage that return DoubleProperty
      Modifier and Type 方法 描述
      DoubleProperty Stage.maxHeightProperty​()
      定义 Stage的最大高度。
      DoubleProperty Stage.maxWidthProperty​()
      定义 Stage的最大宽度。
      DoubleProperty Stage.minHeightProperty​()
      定义 Stage的最小高度。
      DoubleProperty Stage.minWidthProperty​()
      定义此 Stage的最小宽度。
      DoubleProperty Window.opacityProperty​()
      将 Window的不透明度定义为0.0和1.0之间的值。
      DoubleProperty Window.renderScaleXProperty​()
      Window将其 Scene渲染到渲染缓冲区时将使用的水平刻度。
      DoubleProperty Window.renderScaleYProperty​()
      当将 Scene渲染到渲染缓冲区时， Window将使用的垂直刻度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.DoublePropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.DoublePropertyBase

  • Packages that use DoublePropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of DoublePropertyBase in javafx.beans.property

      Subclasses of DoublePropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      这个类提供了一个包含 double值的Property的完整实现。

    • Uses of DoublePropertyBase in javafx.css

      Subclasses of DoublePropertyBase in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.FloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.FloatProperty

  • Packages that use FloatProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of FloatProperty in javafx.beans.property

      Subclasses of FloatProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleFloatProperty
      这个类提供了一个全面实施的Property包装一float值。
      Methods in javafx.beans.property that return FloatProperty
      Modifier and Type 方法 描述
      static FloatProperty FloatProperty.floatProperty​(Property<Float> property)
      返回一个FloatProperty ，其中包含一个Property并双向绑定到它。

    • Uses of FloatProperty in javafx.beans.property.adapter

      Subclasses of FloatProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty提供了一种 float或 Float的常规Java Bean属性和JavaFX FloatProperty之间的适配器。

    • Uses of FloatProperty in javafx.css

      Subclasses of FloatProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableFloatProperty
      这个类扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.FloatPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.FloatPropertyBase

  • Packages that use FloatPropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of FloatPropertyBase in javafx.beans.property

      Subclasses of FloatPropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleFloatProperty
      这个类提供了一个包含 float值的Property的完整实现。

    • Uses of FloatPropertyBase in javafx.css

      Subclasses of FloatPropertyBase in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableFloatProperty
      该课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.IntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.IntegerProperty

  • Packages that use IntegerProperty
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of IntegerProperty in javafx.animation

      Methods in javafx.animation that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty Animation.cycleCountProperty​()
      定义此动画中的循环次数。

    • Uses of IntegerProperty in javafx.beans.property

      Subclasses of IntegerProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  IntegerPropertyBase
      类 IntegerPropertyBase是包含 int值的属性的基类。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleIntegerProperty
      这个类提供了一个包含 int值的Property的全面实现。
      Methods in javafx.beans.property that return IntegerProperty
      Modifier and Type 方法 描述
      static IntegerProperty IntegerProperty.integerProperty​(Property<Integer> property)
      返回一个IntegerProperty ，它包装一个Property ，并双向绑定到它。

    • Uses of IntegerProperty in javafx.beans.property.adapter

      Subclasses of IntegerProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在类型为 int或 Integer的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。

    • Uses of IntegerProperty in javafx.concurrent

      Methods in javafx.concurrent that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty ScheduledService.maximumFailureCountProperty​()
      在完成FAILED状态之前，ScheduledService可以失败的最大次数。

    • Uses of IntegerProperty in javafx.css

      Subclasses of IntegerProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableIntegerProperty
      该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of IntegerProperty in javafx.print

      Methods in javafx.print that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty JobSettings.copiesProperty​()
      IntegerProperty表示要打印的作业的份数。

    • Uses of IntegerProperty in javafx.scene.chart

      Methods in javafx.scene.chart that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty ValueAxis.minorTickCountProperty​()
      每个主要刻度线之间显示的小刻度分割数。

    • Uses of IntegerProperty in javafx.scene.control

      Methods in javafx.scene.control that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty SpinnerValueFactory.IntegerSpinnerValueFactory.amountToStepByProperty​()
      设置每步增加或减少的量。
      IntegerProperty Pagination.currentPageIndexProperty​()
      要为此分页控件显示的当前页面索引。
      IntegerProperty Pagination.maxPageIndicatorCountProperty​()
      用于此分页控件的页面指示符的最大数量。
      IntegerProperty SpinnerValueFactory.IntegerSpinnerValueFactory.maxProperty​()
      设置该值工厂的最大允许值
      IntegerProperty Slider.minorTickCountProperty​()
      任何两个主要蜱之间的次要蜱的数量。
      IntegerProperty SpinnerValueFactory.IntegerSpinnerValueFactory.minProperty​()
      设置该值工厂的最小允许值
      IntegerProperty Pagination.pageCountProperty​()
      此分页控件的页数。
      IntegerProperty TextArea.prefColumnCountProperty​()
      文本列的首选数量。
      IntegerProperty TextField.prefColumnCountProperty​()
      文本列的首选数量。
      IntegerProperty TextArea.prefRowCountProperty​()
      文本行的首选数量。
      IntegerProperty ComboBox.visibleRowCountProperty​()
      ComboBox弹出窗口中显示的最大行数。

    • Uses of IntegerProperty in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty VirtualFlow.cellCountProperty​()
      表示流中应该有的单元格数。

    • Uses of IntegerProperty in javafx.scene.effect

      Methods in javafx.scene.effect that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty FloatMap.heightProperty​()
      地图的高度，以像素为单位。
      IntegerProperty BoxBlur.iterationsProperty​()
      迭代模糊效果以提高其“质量”或“平滑度”的次数。
      IntegerProperty FloatMap.widthProperty​()
      地图的宽度，以像素为单位。

    • Uses of IntegerProperty in javafx.scene.layout

      Methods in javafx.scene.layout that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty TilePane.prefColumnsProperty​()
      水平瓦片的首选列数。
      IntegerProperty TilePane.prefRowsProperty​()
      垂直瓦片的首选行数。

    • Uses of IntegerProperty in javafx.scene.media

      Methods in javafx.scene.media that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty MediaPlayer.audioSpectrumNumBandsProperty​()
      音频频谱中的频带数。
      IntegerProperty MediaPlayer.audioSpectrumThresholdProperty​()
      灵敏度阈值以分贝为单位; 必须是非积极的。
      IntegerProperty AudioClip.cycleCountProperty​()
      当 调用AudioClip.play()时剪辑的播放 次数 。
      IntegerProperty MediaPlayer.cycleCountProperty​()
      媒体播放的次数。
      IntegerProperty AudioClip.priorityProperty​()
      剪辑相对于其他剪辑的相对优先级。

    • Uses of IntegerProperty in javafx.scene.text

      Methods in javafx.scene.text that return IntegerProperty
      Modifier and Type | 方法 | 描述
      IntegerProperty | Text.caretPositionProperty​()
      IntegerProperty | Text.selectionEndProperty​()
      IntegerProperty | Text.selectionStartProperty​()

    • Uses of IntegerProperty in javafx.scene.web

      Methods in javafx.scene.web that return IntegerProperty
      Modifier and Type 方法 描述
      IntegerProperty WebHistory.maxSizeProperty​()
      定义历史记录列表的最大大小。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.IntegerPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.IntegerPropertyBase

  • Packages that use IntegerPropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of IntegerPropertyBase in javafx.beans.property

      Subclasses of IntegerPropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleIntegerProperty
      这个类提供了一个包含 int值的Property的完整实现。

    • Uses of IntegerPropertyBase in javafx.css

      Subclasses of IntegerPropertyBase in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableIntegerProperty
      这个类扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ListProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ListProperty

  • Packages that use ListProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of ListProperty in javafx.beans.property

      Subclasses of ListProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ListPropertyBase<E>
      ListPropertyBase类是一个包装ObservableList的属性的基类。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleListProperty<E>
      这个类提供了一个Property的全面实现，包括一个ObservableList 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ListPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ListPropertyBase

  • Packages that use ListPropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of ListPropertyBase in javafx.beans.property

      Subclasses of ListPropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleListProperty<E>
      这个类提供了一个包含ObservableList的ObservableList的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.LongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.LongProperty

  • Packages that use LongProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of LongProperty in javafx.beans.property

      Subclasses of LongProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleLongProperty
      此类提供了一个包含 long值的Property的完整实现。
      Methods in javafx.beans.property that return LongProperty
      Modifier and Type 方法 描述
      static LongProperty LongProperty.longProperty​(Property<Long> property)
      返回一个LongProperty ，它包装一个Property ，并且双向绑定到它。

    • Uses of LongProperty in javafx.beans.property.adapter

      Subclasses of LongProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了适配器。

    • Uses of LongProperty in javafx.css

      Subclasses of LongProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableLongProperty
      该类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.LongPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.LongPropertyBase

  • Packages that use LongPropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of LongPropertyBase in javafx.beans.property

      Subclasses of LongPropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleLongProperty
      这个类提供了一个包含 long值的Property的全面实现。

    • Uses of LongPropertyBase in javafx.css

      Subclasses of LongPropertyBase in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableLongProperty
      这个课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.MapProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.MapProperty

  • Packages that use MapProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。

    • Uses of MapProperty in javafx.beans.property

      Subclasses of MapProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装一个ObservableMap的属性的基类。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.MapPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.MapPropertyBase

  • Packages that use MapPropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of MapPropertyBase in javafx.beans.property

      Subclasses of MapPropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ObjectProperty

  • Packages that use ObjectProperty
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of ObjectProperty in javafx.animation

      Methods in javafx.animation that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Point3D> RotateTransition.axisProperty​()
      指定此 RotateTransition的旋转轴。
      ObjectProperty<Duration> Animation.delayProperty​()
      延迟动画的开始。
      ObjectProperty<Duration> FadeTransition.durationProperty​()
      持续时间 FadeTransition 。
      ObjectProperty<Duration> FillTransition.durationProperty​()
      这个 FillTransition的持续时间。
      ObjectProperty<Duration> PathTransition.durationProperty​()
      持续时间 Transition 。
      ObjectProperty<Duration> PauseTransition.durationProperty​()
      这个 Transition的持续时间。
      ObjectProperty<Duration> RotateTransition.durationProperty​()
      这个 RotateTransition的持续时间。
      ObjectProperty<Duration> ScaleTransition.durationProperty​()
      这个 ScaleTransition的持续时间。
      ObjectProperty<Duration> StrokeTransition.durationProperty​()
      持续时间 StrokeTransition 。
      ObjectProperty<Duration> TranslateTransition.durationProperty​()
      这个 TranslateTransition的持续时间。
      ObjectProperty<Color> FillTransition.fromValueProperty​()
      指定此 FillTransition的起始颜色值。
      ObjectProperty<Color> StrokeTransition.fromValueProperty​()
      指定此 StrokeTransition的起始颜色值。
      ObjectProperty<Interpolator> Transition.interpolatorProperty​()
      控制每个 Transition循环的加速和减速时序。
      ObjectProperty<Node> FadeTransition.nodeProperty​()
      这个 Transition的目标节点。
      ObjectProperty<Node> ParallelTransition.nodeProperty​()
      这个Node用于所有的孩子Transitions ，它们不定义目标Node本身。
      ObjectProperty<Node> PathTransition.nodeProperty​()
      这个 PathTransition的目标节点。
      ObjectProperty<Node> RotateTransition.nodeProperty​()
      这个 RotateTransition的目标节点。
      ObjectProperty<Node> ScaleTransition.nodeProperty​()
      这个 ScaleTransition的目标节点。
      ObjectProperty<Node> SequentialTransition.nodeProperty​()
      这个Node用于所有的孩子Transitions ，它们不定义一个目标Node本身。
      ObjectProperty<Node> TranslateTransition.nodeProperty​()
      这个 TranslateTransition的目标节点。
      ObjectProperty<EventHandler<ActionEvent>> Animation.onFinishedProperty​()
      在这个 Animation的结论执行的行动。
      ObjectProperty<PathTransition.OrientationType> PathTransition.orientationProperty​()
      指定 node沿 path的直立方向。
      ObjectProperty<Shape> PathTransition.pathProperty​()
      大纲节点应该被动画的形状。
      ObjectProperty<Shape> FillTransition.shapeProperty​()
      目标形状为 FillTransition 。
      ObjectProperty<Shape> StrokeTransition.shapeProperty​()
      目标形状为 StrokeTransition 。
      ObjectProperty<Color> FillTransition.toValueProperty​()
      指定此 FillTransition的停止颜色值。
      ObjectProperty<Color> StrokeTransition.toValueProperty​()
      指定此 StrokeTransition的停止颜色值。

    • Uses of ObjectProperty in javafx.beans.property

      Subclasses of ObjectProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleObjectProperty<T>
      这个类提供了一个包含任意Object的Property的完整实现。
      Methods in javafx.beans.property that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Boolean> BooleanProperty.asObject​()
      创建一个持有BooleanProperty的值的BooleanProperty 。
      ObjectProperty<Double> DoubleProperty.asObject​()
      创建一个ObjectProperty双向绑定到这个DoubleProperty 。
      ObjectProperty<Float> FloatProperty.asObject​()
      创建一个ObjectProperty双向绑定到这个FloatProperty 。
      ObjectProperty<Integer> IntegerProperty.asObject​()
      创建一个ObjectProperty双向绑定到这个IntegerProperty 。
      ObjectProperty<Long> LongProperty.asObject​()
      创建一个ObjectProperty双向绑定到这个LongProperty 。

    • Uses of ObjectProperty in javafx.beans.property.adapter

      Subclasses of ObjectProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanObjectProperty<T>
      一个 JavaBeanObjectProperty提供类型的普通的Java Bean属性之间的适配器 T和一个JavaFX ObjectProperty<T> 。

    • Uses of ObjectProperty in javafx.collections.transformation

      Methods in javafx.collections.transformation that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Comparator<? super E>> SortedList.comparatorProperty​()
      比较器，表示此SortedList的顺序。
      ObjectProperty<Predicate<? super E>> FilteredList.predicateProperty​()
      该谓词将匹配此FilteredList中的元素。

    • Uses of ObjectProperty in javafx.concurrent

      Methods in javafx.concurrent that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Callback<ScheduledService<?>,Duration>> ScheduledService.backoffStrategyProperty​()
      计算在每次故障时添加到期间的时间量。
      ObjectProperty<Duration> ScheduledService.delayProperty​()
      首次启动ScheduledService之间的初始延迟，以及何时开始运行。
      ObjectProperty<Executor> Service.executorProperty​()
      执行者用于运行此服务。
      ObjectProperty<Duration> ScheduledService.maximumCumulativePeriodProperty​()
      累积百分比的最大允许值。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onCancelledProperty​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onCancelledProperty​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onFailedProperty​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onFailedProperty​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onReadyProperty​()
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onRunningProperty​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onRunningProperty​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onScheduledProperty​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onScheduledProperty​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onSucceededProperty​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onSucceededProperty​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ObjectProperty<Duration> ScheduledService.periodProperty​()
      允许在最后一次运行开始和下次运行开始之间的最短时间。

    • Uses of ObjectProperty in javafx.css

      Subclasses of ObjectProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableObjectProperty<T>
      该课程扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of ObjectProperty in javafx.print

      Methods in javafx.print that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Collation> JobSettings.collationProperty​()
      属性代表 Collation一个实例。
      ObjectProperty<PageLayout> JobSettings.pageLayoutProperty​()
      属性代表 PageLayout一个实例。
      ObjectProperty JobSettings.pageRangesProperty​()
      一个 ObjectProperty其值表示作为PageRange数组打印的作业页面。
      ObjectProperty<PaperSource> JobSettings.paperSourceProperty​()
      属性代表 PaperSource一个实例。
      ObjectProperty<PrintColor> JobSettings.printColorProperty​()
      属性代表 PrintColor一个实例。
      ObjectProperty<Printer> PrinterJob.printerProperty​()
      代表这项工作的 Printer财产。
      ObjectProperty<PrintQuality> JobSettings.printQualityProperty​()
      属性代表 PrintQuality一个实例。
      ObjectProperty<PrintResolution> JobSettings.printResolutionProperty​()
      属性代表 PrintResolution一个实例。
      ObjectProperty<PrintSides> JobSettings.printSidesProperty​()
      属性代表 PrintSides一个实例。

    • Uses of ObjectProperty in javafx.scene

      Methods in javafx.scene that return ObjectProperty
      Modifier and Type | 方法 | 描述
      ObjectProperty<String> Node.accessibleHelpProperty​()
      该 Node可访问的帮助文本。
      ObjectProperty<String> Node.accessibleRoleDescriptionProperty​()
      这个角色描述 Node 。
      ObjectProperty<AccessibleRole> Node.accessibleRoleProperty​()
      这个 Node的可访问角色。
      ObjectProperty<String> Node.accessibleTextProperty​()
      这个 Node的可访问文本。
      ObjectProperty<BlendMode> Node.blendModeProperty​()
      BlendMode用于将这个单独的节点混合到其后面的场景中。
      ObjectProperty<CacheHint> Node.cacheHintProperty​()
      控制位图缓存的其他提示。
      ObjectProperty<Camera> Scene.cameraProperty​()
      指定用于渲染此 Scene的相机使用类型。
      ObjectProperty<Camera> SubScene.cameraProperty​()
      指定用于渲染 SubScene的相机使用类型。
      ObjectProperty<Node> Node.clipProperty​()
      指定用于定义此节点的剪切形状的 Node 。
      ObjectProperty<Color> LightBase.colorProperty​()
      指定光源的颜色。
      ObjectProperty<Cursor> Node.cursorProperty​()
      为此 Node和子节点定义鼠标光标。
      ObjectProperty<Cursor> Scene.cursorProperty​()
      为此 Scene定义鼠标光标。
      ObjectProperty<DepthTest> Node.depthTestProperty​()
      指示在渲染此节点时是否使用深度测试。
      ObjectProperty<Effect> Node.effectProperty​()
      指定应用于此 Node的效果。
      ObjectProperty<EventDispatcher> Node.eventDispatcherProperty​()
      指定此节点的事件分派器。
      ObjectProperty<EventDispatcher> Scene.eventDispatcherProperty​()
      指定此场景的事件调度程序。
      ObjectProperty<Paint> Scene.fillProperty​()
      定义此 Scene的背景填充。
      ObjectProperty<Paint> SubScene.fillProperty​()
      定义此 SubScene的背景填充。
      ObjectProperty<InputMethodRequests> Node.inputMethodRequestsProperty​()
      属性保存InputMethodRequests。
      ObjectProperty<NodeOrientation> Node.nodeOrientationProperty​()
      属性保存NodeOrientation。
      ObjectProperty<NodeOrientation> Scene.nodeOrientationProperty​()
      属性保存NodeOrientation。
      ObjectProperty<EventHandler<? super ContextMenuEvent>> Node.onContextMenuRequestedProperty​()
      定义在 Node上请求上下文菜单时要调用的函数。
      ObjectProperty<EventHandler<? super ContextMenuEvent>> Scene.onContextMenuRequestedProperty​()
      定义在这个 Scene上点击（按下并释放）鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onDragDetectedProperty​()
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onDragDetectedProperty​()
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragDoneProperty​()
      定义当这个 Node在其数据放在放置目标上之后是拖放手势源时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragDoneProperty​()
      当这个 Scene是一个拖放手势源，它的数据被放在放置目标上之后，定义要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragDroppedProperty​()
      定义当在拖放手势时释放 Node鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragDroppedProperty​()
      定义在拖放手势时，在此 Scene上释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragEnteredProperty​()
      定义当拖动手势进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragEnteredProperty​()
      定义当拖动手势进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragExitedProperty​()
      定义当拖动手势退出 Node时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragExitedProperty​()
      定义当拖动手势退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragOverProperty​()
      定义当这个 Node拖动手势进度时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragOverProperty​()
      定义当这个 Scene拖动手势进度时要调用的函数。
      ObjectProperty<EventHandler<? super InputMethodEvent>> Node.onInputMethodTextChangedProperty​()
      定义当这个 Node具有输入焦点并且输入法文本已更改时要调用的函数。
      ObjectProperty<EventHandler<? super InputMethodEvent>> Scene.onInputMethodTextChangedProperty​()
      定义当这个 Node具有输入焦点并且输入法文本已更改时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Node.onKeyPressedProperty​()
      定义当这个 Node或其子项 Node具有输入焦点并按下一个键时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Scene.onKeyPressedProperty​()
      定义要调用的函数，当一些 Node如此 Scene具有输入焦点和键被按下。
      ObjectProperty<EventHandler<? super KeyEvent>> Node.onKeyReleasedProperty​()
      定义当这个 Node或其子代 Node具有输入焦点并且键已被释放时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Scene.onKeyReleasedProperty​()
      定义要调用的函数，当一些 Node如此 Scene具有输入焦点和重点已经释放。
      ObjectProperty<EventHandler<? super KeyEvent>> Node.onKeyTypedProperty​()
      定义当这个 Node或其子项 Node具有输入焦点并键入键时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Scene.onKeyTypedProperty​()
      当 Node的 Scene具有输入焦点并键入一个键时，定义要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseClickedProperty​()
      定义在这个 Node上点击（按下并释放）鼠标按钮时调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseClickedProperty​()
      定义当这个 Scene点击（按下和释放）鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragEnteredProperty​()
      定义当全按压拖动手势进入这个 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragEnteredProperty​()
      定义当完全按下 - 拖动释放手势进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragExitedProperty​()
      定义当完全按下 - 拖动释放手势离开这个 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragExitedProperty​()
      定义当完全按下 - 拖动释放手势退出 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseDraggedProperty​()
      定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseDraggedProperty​()
      定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragOverProperty​()
      定义当这个 Node的全按压拖动手势进行时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragOverProperty​()
      定义当这个 Scene完全按下 - 拖动释放手势进行时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragReleasedProperty​()
      定义当完全按下 - 拖动释放手势结束（通过释放鼠标按钮）在该 Node内时 Node 。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragReleasedProperty​()
      定义当完全按下 - 拖动释放手势在此 Scene内结束时调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseEnteredProperty​()
      定义当鼠标进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseEnteredProperty​()
      定义当鼠标进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseExitedProperty​()
      定义当鼠标退出 Node时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseExitedProperty​()
      定义当鼠标退出 Scene时调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseMovedProperty​()
      定义当这个 Node鼠标光标移动时调用的功能，但没有按钮被按下。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseMovedProperty​()
      定义当这个 Scene鼠标光标移动时调用的功能，但没有按钮被按下。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMousePressedProperty​()
      定义当这个 Node上按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMousePressedProperty​()
      定义当这个 Scene上按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseReleasedProperty​()
      定义在 Node上释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseReleasedProperty​()
      定义当这个 Scene上释放鼠标按钮时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> Node.onRotateProperty​()
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> Scene.onRotateProperty​()
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> Node.onRotationFinishedProperty​()
      定义旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Scene.onRotationFinishedProperty​()
      定义当旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Node.onRotationStartedProperty​()
      定义检测到旋转手势时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Scene.onRotationStartedProperty​()
      定义检测到旋转手势时要调用的功能。
      ObjectProperty<EventHandler<? super ScrollEvent>> Node.onScrollFinishedProperty​()
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Scene.onScrollFinishedProperty​()
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Node.onScrollProperty​()
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Scene.onScrollProperty​()
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Node.onScrollStartedProperty​()
      定义检测到滚动手势时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Scene.onScrollStartedProperty​()
      定义检测到滚动手势时要调用的函数。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeDownProperty​()
      定义当在该节点上居中的向下滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeDownProperty​()
      定义当在此场景中发生向下滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeLeftProperty​()
      定义当以该节点为中心的向左滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeLeftProperty​()
      定义当在此场景中发生向左滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeRightProperty​()
      定义当以该节点为中心的向右滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeRightProperty​()
      定义当在此场景中发生向右滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeUpProperty​()
      定义当在该节点上居中的向上滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeUpProperty​()
      定义当在此场景中发生向上滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchMovedProperty​()
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchMovedProperty​()
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchPressedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchPressedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchReleasedProperty​()
      定义触发点释放时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchReleasedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchStationaryProperty​()
      定义当触摸点保持按下并静止时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchStationaryProperty​()
      定义当触摸点保持按下并静止时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Node.onZoomFinishedProperty​()
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Scene.onZoomFinishedProperty​()
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Node.onZoomProperty​()
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> Scene.onZoomProperty​()
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> Node.onZoomStartedProperty​()
      定义检测到缩放手势时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Scene.onZoomStartedProperty​()
      定义检测到缩放手势时要调用的功能。
      ObjectProperty<Parent> Scene.rootProperty​()
      定义场景图的根 Node 。
      ObjectProperty<Parent> SubScene.rootProperty​()
      定义 SubScene场景图的根 Node 。
      ObjectProperty<Point3D> Node.rotationAxisProperty​()
      定义 Node的旋转轴。
      ObjectProperty<String> | Scene.userAgentStylesheetProperty​()
      ObjectProperty<String> | SubScene.userAgentStylesheetProperty​()

    • Uses of ObjectProperty in javafx.scene.chart

      Methods in javafx.scene.chart that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<LineChart.SortingPolicy> LineChart.axisSortingPolicyProperty​()
      指示传递给LineChart的数据是否应按其中一个轴的自然顺序进行排序。
      protected ObjectProperty<Object> XYChart.currentDisplayedExtraValueProperty​(XYChart.Data<X,Y> item)
      当前显示的额外值属性。
      protected ObjectProperty<X> XYChart.currentDisplayedXValueProperty​(XYChart.Data<X,Y> item)
      在X轴上绘制的当前显示的数据值属性。
      protected ObjectProperty<Y> XYChart.currentDisplayedYValueProperty​(XYChart.Data<X,Y> item)
      在Y轴上绘制的当前显示的数据值属性。
      ObjectProperty<ObservableList<PieChart.Data>> PieChart.dataProperty​()
      PieCharts数据
      ObjectProperty<ObservableList<XYChart.Series<X,Y>>> XYChart.dataProperty​()
      XYCharts数据
      ObjectProperty<ObservableList<XYChart.Data<X,Y>>> XYChart.Series.dataProperty​()
      ObservableList组成本系列的数据项
      ObjectProperty<Object> XYChart.Data.extraValueProperty​()
      以图表所需的任何方式绘制的通用数据值。
      ObjectProperty<String> Axis.labelProperty​()
      轴标签
      protected ObjectProperty<Node> Chart.legendProperty​()
      该节点显示为Legend。
      ObjectProperty<Side> Chart.legendSideProperty​()
      图表侧面应显示图例
      ObjectProperty<Node> XYChart.Data.nodeProperty​()
      要显示此数据项的节点。
      ObjectProperty<Node> XYChart.Series.nodeProperty​()
      该系列显示的节点。
      ObjectProperty<Side> Axis.sideProperty​()
      该轴正在绘制的曲线的一侧
      ObjectProperty<Paint> Axis.tickLabelFillProperty​()
      填写所有刻度标签
      ObjectProperty<Font> Axis.tickLabelFontProperty​()
      所有刻度标签的字体
      ObjectProperty<StringConverter<T>> ValueAxis.tickLabelFormatterProperty​()
      StringConverter用于格式化刻度线标签。
      ObjectProperty<Side> Chart.titleSideProperty​()
      显示标题的图表侧
      ObjectProperty<X> XYChart.Data.XValueProperty​()
      要在X轴上绘制的通用数据值。
      ObjectProperty<Y> XYChart.Data.YValueProperty​()
      在Y轴上绘制的通用数据值。

    • Uses of ObjectProperty in javafx.scene.control

      Methods in javafx.scene.control that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<KeyCombination> MenuItem.acceleratorProperty​()
      加速器属性使得能够在一个击键中访问关联的动作。
      ObjectProperty<Alert.AlertType> Alert.alertTypeProperty​()
      创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。
      ObjectProperty<Pos> Labeled.alignmentProperty​()
      指定Labeled内的空格时如何对齐Labeled中的文本和图形。
      ObjectProperty<Pos> TextField.alignmentProperty​()
      指定当TextField中有空格时如何对齐文本。
      ObjectProperty<ListCell<T>> ComboBox.buttonCellProperty​()
      按钮单元格用于渲染ComboBox“按钮”区域中显示的内容。
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> ComboBox.cellFactoryProperty​()
      提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> ListView.cellFactoryProperty​()
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      ObjectProperty<Callback<TableColumn<S,T>,TableCell<S,T>>> TableColumn.cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      ObjectProperty<Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>> TreeTableColumn.cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      ObjectProperty<Callback<TreeView<T>,TreeCell<T>>> TreeView.cellFactoryProperty​()
      表示将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
      ObjectProperty<Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> TableColumn.cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。
      ObjectProperty<Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> TreeTableColumn.cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。
      ObjectProperty<Chronology> DatePicker.chronologyProperty​()
      用于在DatePicker控件中解析，显示和选择日期的日历系统。
      ObjectProperty<Callback<TableView.ResizeFeatures,Boolean>> TableView.columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      ObjectProperty<Callback<TreeTableView.ResizeFeatures,Boolean>> TreeTableView.columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      ObjectProperty<Comparator<T>> TableColumnBase.comparatorProperty​()
      排序此表列时使用的比较器功能。
      ObjectProperty<ContentDisplay> Labeled.contentDisplayProperty​()
      指定图形相对于文本的位置。
      ObjectProperty<ContentDisplay> Tooltip.contentDisplayProperty​()
      指定图形相对于文本的位置。
      ObjectProperty<Node> CustomMenuItem.contentProperty​()
      在此CustomMenuItem中显示的节点。
      ObjectProperty<Node> DialogPane.contentProperty​()
      表示对话框的内容区域的属性。
      ObjectProperty<Node> ScrollPane.contentProperty​()
      该节点用作此ScrollPane的内容。
      ObjectProperty<Node> Tab.contentProperty​()
      与标签相关的内容。
      ObjectProperty<Node> TitledPane.contentProperty​()
      TitledPane的内容。
      ObjectProperty<ContextMenu> Control.contextMenuProperty​()
      为此控件显示的ContextMenu。
      ObjectProperty<ContextMenu> Tab.contextMenuProperty​()
      与选项卡关联的上下文菜单。
      ObjectProperty<ContextMenu> TableColumnBase.contextMenuProperty​()
      当用户右键单击此TableColumnBase的标题区域时，将显示此菜单。
      ObjectProperty<StringConverter<T>> ChoiceBox.converterProperty​()
      允许一种方式来指定如何表示项目列表中的对象。
      ObjectProperty<StringConverter<T>> ComboBox.converterProperty​()
      将用户输入的输入（ComboBox为 editable ）转换为类型T的对象，以便可以通过 value属性检索输入。
      ObjectProperty<StringConverter<LocalDate>> DatePicker.converterProperty​()
      将输入文本转换为类型为LocalDate的对象，反之亦然。
      ObjectProperty<StringConverter<T>> SpinnerValueFactory.converterProperty​()
      将用户输入的输入（当微调器为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。
      ObjectProperty<Callback<DatePicker,DateCell>> DatePicker.dayCellFactoryProperty​()
      可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。
      ObjectProperty<DialogPane> Dialog.dialogPaneProperty​()
      对话框的根节点 ， DialogPane包含对话框中显示的所有可视元素。
      ObjectProperty<Node> TreeCell.disclosureNodeProperty​()
      公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
      ObjectProperty<Node> TreeTableRow.disclosureNodeProperty​()
      公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
      ObjectProperty<Node> DialogPane.expandableContentProperty​()
      表示对话框可扩展内容区域的属性。
      ObjectProperty<TitledPane> Accordion.expandedPaneProperty​()
      手风琴中扩大的TitledPane。
      ObjectProperty<FocusModel<T>> ListView.focusModelProperty​()
      FocusModel提供了API，通过它可以获得并设置ListView中单个项目的焦点。
      ObjectProperty<TableView.TableViewFocusModel<S>> TableView.focusModelProperty​()
      代表当前安装的TableView.TableViewFocusModel此TableView。
      ObjectProperty<TreeTableView.TreeTableViewFocusModel<S>> TreeTableView.focusModelProperty​()
      FocusModel提供API，通过它可以将焦点控制在零或一行TreeTableView上。
      ObjectProperty<FocusModel<TreeItem<T>>> TreeView.focusModelProperty​()
      FocusModel提供API，通过它可以将焦点控制在零行或一行TreeView。
      ObjectProperty<Font> Labeled.fontProperty​()
      用于标签中文本的默认字体。
      ObjectProperty<Font> TextInputControl.fontProperty​()
      TextInputControl中用于文本的默认字体。
      ObjectProperty<Font> Tooltip.fontProperty​()
      工具提示中用于文本的默认字体。
      ObjectProperty<Node> Dialog.graphicProperty​()
      对话图形，在标题中显示，如果显示，或 content的左侧。
      ObjectProperty<Node> DialogPane.graphicProperty​()
      对话图形，在标题中显示，如果显示，或 content的左侧。
      ObjectProperty<Node> Labeled.graphicProperty​()
      标签的可选图标。
      ObjectProperty<Node> MenuItem.graphicProperty​()
      MenuItem的可选图形。
      ObjectProperty<Node> Tab.graphicProperty​()
      选项卡中的图形。
      ObjectProperty<Node> TableColumnBase.graphicProperty​()
      在表列中显示的图形，以允许用户以图形方式指示列中的内容。
      ObjectProperty<Node> Tooltip.graphicProperty​()
      工具提示的可选图标。
      ObjectProperty<Node> TreeItem.graphicProperty​()
      通常显示在value属性左侧的节点。
      ObjectProperty<HPos> Separator.halignmentProperty​()
      对于垂直分隔符，指定分隔线在空间中的水平位置。
      ObjectProperty<ScrollPane.ScrollBarPolicy> ScrollPane.hbarPolicyProperty​()
      指定显示水平滚动条的策略。
      ObjectProperty<Node> DialogPane.headerProperty​()
      表示对话框窗格的标题区域的属性。
      ObjectProperty<Duration> Tooltip.hideDelayProperty​()
      在鼠标离开节点后继续显示工具提示的持续时间。
      ObjectProperty<T> Cell.itemProperty​()
      与该单元格相关联的数据值。
      ObjectProperty<ObservableList<T>> ChoiceBox.itemsProperty​()
      要在选框中显示的项目。
      ObjectProperty<ObservableList<T>> ComboBox.itemsProperty​()
      在ComboBox弹出窗口中显示的项目列表。
      ObjectProperty<ObservableList<T>> ListView.itemsProperty​()
      ListView的底层数据模型。
      ObjectProperty<ObservableList<T>> SpinnerValueFactory.ListSpinnerValueFactory.itemsProperty​()
      ListView的底层数据模型。
      ObjectProperty<ObservableList<S>> TableView.itemsProperty​()
      TableView的基础数据模型。
      ObjectProperty<StringConverter<Double>> Slider.labelFormatterProperty​()
      用于格式化主要刻度的标签的功能。
      ObjectProperty<Node> Label.labelForProperty​()
      标签可以作为不同控件或节点的标签。
      ObjectProperty<EventHandler<ActionEvent>> ButtonBase.onActionProperty​()
      按钮的动作，当按钮被触发时被调用。
      ObjectProperty<EventHandler<ActionEvent>> ChoiceBox.onActionProperty​()
      ChoiceBox操作，每当更改ChoiceBox value属性时调用。
      ObjectProperty<EventHandler<ActionEvent>> ComboBoxBase.onActionProperty​()
      ComboBox操作，当ComboBox value属性更改时调用。
      ObjectProperty<EventHandler<ActionEvent>> ContextMenu.onActionProperty​()
      当该 ContextMenu包含的项目已被激活时，通知回调功能。
      ObjectProperty<EventHandler<ActionEvent>> MenuItem.onActionProperty​()
      每当MenuItem被触发时调用该动作。
      ObjectProperty<EventHandler<ActionEvent>> TextField.onActionProperty​()
      与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。
      ObjectProperty<EventHandler<Event>> Tab.onClosedProperty​()
      当选项卡关闭时与选项卡关联的事件处理程序。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onCloseRequestProperty​()
      当有外部请求关闭此 Dialog 。
      ObjectProperty<EventHandler<Event>> Tab.onCloseRequestProperty​()
      当有外部请求关闭此 Tab 。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> ListView.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> TableColumn.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> TreeTableColumn.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> TreeView.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> ListView.onEditCommitProperty​()
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> TableColumn.onEditCommitProperty​()
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> TreeTableColumn.onEditCommitProperty​()
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> TreeView.onEditCommitProperty​()
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> ListView.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> TableColumn.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> TreeTableColumn.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> TreeView.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onHiddenProperty​()
      在ChoiceBox弹出窗口之后刚刚被隐藏。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onHiddenProperty​()
      在ComboBoxBase弹出/显示已被隐藏之后调用。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onHiddenProperty​()
      Dialog已被隐藏之后调用。
      ObjectProperty<EventHandler<Event>> Menu.onHiddenProperty​()
      在ContextMenu之后刚刚被隐藏。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onHidingProperty​()
      在ChoiceBox弹出窗口被隐藏之前。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onHidingProperty​()
      在ComboBox弹出/显示被隐藏之前调用。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onHidingProperty​()
      在对话框被隐藏之前调用。
      ObjectProperty<EventHandler<Event>> Menu.onHidingProperty​()
      被称为在ContextMenu被隐藏之前。
      ObjectProperty<EventHandler<Event>> MenuItem.onMenuValidationProperty​()
      与调用MenuItem的加速器相关联的事件处理程序。
      ObjectProperty<EventHandler<ScrollToEvent<TableColumn<S,?>>>> TableView.onScrollToColumnProperty​()
      当有请求使用 TableView.scrollToColumn(TableColumn)或 TableView.scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<TreeTableColumn<S,?>>>> TreeTableView.onScrollToColumnProperty​()
      当有请求使用 TreeTableView.scrollToColumn(TreeTableColumn)或 TreeTableView.scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> ListView.onScrollToProperty​()
      当有请求使用 ListView.scrollTo(int)或 ListView.scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TableView.onScrollToProperty​()
      当有请求使用 TableView.scrollTo(int)或 TableView.scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TreeTableView.onScrollToProperty​()
      当有请求使用 TreeTableView.scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TreeView.onScrollToProperty​()
      当有请求使用 TreeView.scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<Event>> Tab.onSelectionChangedProperty​()
      与选项卡上的选择相关联的事件处理程序。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onShowingProperty​()
      在 ChoiceBox弹出窗口之前调用。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onShowingProperty​()
      在 ComboBoxBase弹出/显示之前打电话。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onShowingProperty​()
      在对话框显示之前调用。
      ObjectProperty<EventHandler<Event>> Menu.onShowingProperty​()
      ContextMenu显示 ContextMenu之前即使菜单没有显示项目。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onShownProperty​()
      在ChoiceBox弹出窗口之后调用。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onShownProperty​()
      在ComboBoxBase弹出/显示后显示。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onShownProperty​()
      在对话框显示之后调用。
      ObjectProperty<EventHandler<Event>> Menu.onShownProperty​()
      紧随ContextMenu显示。
      ObjectProperty<EventHandler<SortEvent<TableView<S>>>> TableView.onSortProperty​()
      当有请求排序控件时调用。
      ObjectProperty<EventHandler<SortEvent<TreeTableView<S>>>> TreeTableView.onSortProperty​()
      当有请求排序控件时调用。
      ObjectProperty<Orientation> ListView.orientationProperty​()
      ListView的方向 - 这可以是水平还是垂直。
      ObjectProperty<Orientation> ScrollBar.orientationProperty​()
      ScrollBar的方向可以是 HORIZONTAL或 VERTICAL 。
      ObjectProperty<Orientation> Separator.orientationProperty​()
      Separator的方向可以是水平还是垂直。
      ObjectProperty<Orientation> Slider.orientationProperty​()
      Slider的方向可以是水平还是垂直。
      ObjectProperty<Orientation> SplitPane.orientationProperty​()
      SplitPane的方向。
      ObjectProperty<Orientation> ToolBar.orientationProperty​()
      ToolBar的方向 - 这可以是水平还是垂直。
      ObjectProperty<Callback<Integer,Node>> Pagination.pageFactoryProperty​()
      当应用程序或用户选择页面时调用的pageFactory回调函数。
      ObjectProperty<Node> ComboBox.placeholderProperty​()
      当ComboBox没有内容显示时，该节点将显示给用户。
      ObjectProperty<Node> ListView.placeholderProperty​()
      当列表视图没有显示的内容时，向用户显示该节点。
      ObjectProperty<Node> TableView.placeholderProperty​()
      当表没有显示的内容时，向用户显示该节点。
      ObjectProperty<Node> TreeTableView.placeholderProperty​()
      当表没有显示的内容时，向用户显示该节点。
      ObjectProperty<Side> MenuButton.popupSideProperty​()
      表示ContextMenu应该在哪一面打开与MenuButton相关的方面。
      ObjectProperty<Callback<ButtonType,R>> Dialog.resultConverterProperty​()
      API将用户点击的ButtonType转换为可以通过result属性返回的结果。
      ObjectProperty<R> Dialog.resultProperty​()
      表示从对话框返回的属性的属性。
      ObjectProperty<TreeItem<S>> TreeTableView.rootProperty​()
      表示TreeTableView根节点的属性。
      ObjectProperty<TreeItem<T>> TreeView.rootProperty​()
      表示TreeView根节点的属性。
      ObjectProperty<Callback<TableView<S>,TableRow<S>>> TableView.rowFactoryProperty​()
      一个产生TableRow的函数。
      ObjectProperty<Callback<TreeTableView<S>,TreeTableRow<S>>> TreeTableView.rowFactoryProperty​()
      一个生成TreeTableRow的函数。
      ObjectProperty<SingleSelectionModel<T>> ChoiceBox.selectionModelProperty​()
      ChoiceBox的选择模型。
      ObjectProperty<SingleSelectionModel<T>> ComboBox.selectionModelProperty​()
      ComboBox的选择模型。
      ObjectProperty<MultipleSelectionModel<T>> ListView.selectionModelProperty​()
      SelectionModel提供了可以在ListView中选择单个或多个项目的API，以及检查用户选择了哪些项目。
      ObjectProperty<TableView.TableViewSelectionModel<S>> TableView.selectionModelProperty​()
      SelectionModel提供了可以在TableView中选择单个或多个项目的API，以及检查用户选择了哪些项目。
      ObjectProperty<SingleSelectionModel<Tab>> TabPane.selectionModelProperty​()
      用于选择标签的选择模型。
      ObjectProperty<TreeTableView.TreeTableViewSelectionModel<S>> TreeTableView.selectionModelProperty​()
      SelectionModel提供了可以在TreeTableView中选择单个或多个项目的API，以及检查用户选择了哪些行。
      ObjectProperty<MultipleSelectionModel<TreeItem<T>>> TreeView.selectionModelProperty​()
      SelectionModel提供了可以在TreeView中选择单个或多个项目的API，以及检查用户选择了哪些行。
      ObjectProperty<SelectionMode> MultipleSelectionModel.selectionModeProperty​()
      指定在此选择模型中使用的选择模式。
      ObjectProperty<Duration> Tooltip.showDelayProperty​()
      进入悬停节点的鼠标与相关联的工具提示之间的延迟将显示给用户。
      ObjectProperty<Duration> Tooltip.showDurationProperty​()
      工具提示应保持显示的持续时间，直到用户不再可见。
      ObjectProperty<Side> TabPane.sideProperty​()
      TabPane中选项卡的位置。
      ObjectProperty<Skin<?>> Control.skinProperty​()
      皮肤负责渲染这个 Control 。
      ObjectProperty<Skin<?>> PopupControl.skinProperty​()
      皮肤负责渲染这个 PopupControl 。
      ObjectProperty<Skin<?>> Skinnable.skinProperty​()
      皮肤负责渲染这个 Control 。
      ObjectProperty<TreeSortMode> TreeTableView.sortModeProperty​()
      指定在排序此TreeTableView的内容时使用的排序模式，如果在 sort order列表中指定任何列。
      ObjectProperty<Node> TableColumnBase.sortNodeProperty​()
      用作“排序箭头”的节点，在表列是排序顺序的一部分的情况下向用户显示。
      ObjectProperty<Callback<TableView<S>,Boolean>> TableView.sortPolicyProperty​()
      排序策略指定如何执行此TableView中的排序。
      ObjectProperty<Callback<TreeTableView<S>,Boolean>> TreeTableView.sortPolicyProperty​()
      排序策略指定如何执行此TreeTableView中的排序。
      ObjectProperty<TableColumn.SortType> TableColumn.sortTypeProperty​()
      用于说明该列是否是排序顺序的一部分（更多详细信息，请参阅 TableView.getSortOrder() ），应按升序或降序排列。
      ObjectProperty<TreeTableColumn.SortType> TreeTableColumn.sortTypeProperty​()
      用于说明此列是否是排序顺序的一部分（更多详细信息，请参阅 TreeTableView.getSortOrder() ），应按升序或降序排列。
      ObjectProperty<TabPane.TabClosingPolicy> TabPane.tabClosingPolicyProperty​()
      选项卡的关闭策略。
      ObjectProperty<TextAlignment> Labeled.textAlignmentProperty​()
      指定 文本行多 行时的行为行 Labeled.contentDisplayProperty()影响图形和文本，此设置仅影响文本边界的多行文本。
      ObjectProperty<TextAlignment> Tooltip.textAlignmentProperty​()
      指定 文本行多行时的行为。
      ObjectProperty<Paint> Labeled.textFillProperty​()
      Paint用于填写文字。
      ObjectProperty<TextFormatter<?>> TextInputControl.textFormatterProperty​()
      该物业包含目前附件TextFormatter 。
      ObjectProperty<OverrunStyle> Labeled.textOverrunProperty​()
      指定 Labeled的文本超过可用空间来呈现文本时要使用的行为。
      ObjectProperty<OverrunStyle> Tooltip.textOverrunProperty​()
      指定 Tooltip的文本超过可用空间进行渲染时使用的行为。
      ObjectProperty<ToggleGroup> RadioMenuItem.toggleGroupProperty​()
      代表这个RadioMenuItem所属的ToggleGroup 。
      ObjectProperty<ToggleGroup> Toggle.toggleGroupProperty​()
      该ToggleGroup到这个Toggle所属。
      ObjectProperty<ToggleGroup> ToggleButton.toggleGroupProperty​()
      该ToggleGroup到这个ToggleButton所属。
      ObjectProperty<Tooltip> Control.tooltipProperty​()
      用于此控件的工具提示。
      ObjectProperty<Tooltip> Tab.tooltipProperty​()
      与此选项卡关联的工具提示。
      ObjectProperty<TreeTableColumn<S,?>> TreeTableView.treeColumnProperty​()
      表示哪个列应该在其中显示披露节点的属性（即带有箭头的列）。
      ObjectProperty<VPos> Separator.valignmentProperty​()
      对于水平分隔符，指定分隔符控件空间内的分隔线的垂直对齐方式。
      ObjectProperty<SpinnerValueFactory<T>> Spinner.valueFactoryProperty​()
      价值工厂是JavaFX Spinner控件背后的模型 - 没有工厂安装的Spinner不可用的值。
      ObjectProperty<T> ChoiceBox.valueProperty​()
      此ChoiceBox的值被定义为ChoiceBox选择模型中选定的项目。
      ObjectProperty<T> ComboBoxBase.valueProperty​()
      如果输入不可编辑，或者如果可编辑，则该组合框的值被定义为所选项，最近的用户操作：用户输入的值或最后选择的项。
      ObjectProperty<T> SpinnerValueFactory.valueProperty​()
      表示SpinnerValueFactory的当前值，如果未设置值，则为null。
      ObjectProperty<V> TextFormatter.valueProperty​()
      该格式化程序的当前值。
      ObjectProperty<T> TreeItem.valueProperty​()
      表示此TreeItem中包含的特定于应用程序的数据的属性。
      ObjectProperty<ScrollPane.ScrollBarPolicy> ScrollPane.vbarPolicyProperty​()
      指定显示垂直滚动条的策略。
      ObjectProperty<Bounds> ScrollPane.viewportBoundsProperty​()
      ScrollPane视口的实际边界。

    • Uses of ObjectProperty in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<T>> CheckBoxListCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> CheckBoxTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<TreeItem<T>>> CheckBoxTreeCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> CheckBoxTreeTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ChoiceBoxListCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ChoiceBoxTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ChoiceBoxTreeCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ChoiceBoxTreeTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ComboBoxListCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ComboBoxTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ComboBoxTreeCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ComboBoxTreeTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> TextFieldListCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> TextFieldTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> TextFieldTreeCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> TextFieldTreeTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<Callback<T,ObservableValue<Boolean>>> CheckBoxListCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<TreeItem<T>,ObservableValue<Boolean>>> CheckBoxTreeCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTreeTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。

    • Uses of ObjectProperty in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return ObjectProperty
      Modifier and Type | 方法 | 描述
      ObjectProperty<Callback<VirtualFlow<T>,T>> VirtualFlow.cellFactoryProperty​()
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      ObjectProperty<Pos> MenuBarSkin.containerAlignmentProperty​()
      指定MenuBar中菜单按钮的对齐方式（默认为Pos.TOP_LEFT）。
      protected ObjectProperty<Node> TableRowSkinBase.graphicProperty​()
      返回在公开节点内部绘制的图形。
      protected ObjectProperty<Node> TreeTableRowSkin.graphicProperty​()
      返回在公开节点内部绘制的图形。
      protected ObjectProperty<Paint> TextInputControlSkin.highlightFillProperty​()
      突出显示时用于文本的填充。
      protected ObjectProperty<Paint> | TextInputControlSkin.highlightTextFillProperty​()
      protected ObjectProperty<Paint> | TextInputControlSkin.promptTextFillProperty​()
      protected ObjectProperty<Paint> TextInputControlSkin.textFillProperty​()
      在正常条件下用于文本的填充

    • Uses of ObjectProperty in javafx.scene.effect

      Methods in javafx.scene.effect that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<BlurType> DropShadow.blurTypeProperty​()
      用于模糊阴影的算法。
      ObjectProperty<BlurType> InnerShadow.blurTypeProperty​()
      用于模糊阴影的算法。
      ObjectProperty<BlurType> Shadow.blurTypeProperty​()
      用于模糊阴影的算法。
      ObjectProperty<Effect> Blend.bottomInputProperty​()
      这个 Blend操作的底部输入。
      ObjectProperty<Effect> Lighting.bumpInputProperty​()
      可选的凹凸贴图输入。
      ObjectProperty<Color> DropShadow.colorProperty​()
      阴影 Color 。
      ObjectProperty<Color> InnerShadow.colorProperty​()
      阴影 Color 。
      ObjectProperty<Color> Light.colorProperty​()
      光源的颜色。
      ObjectProperty<Color> Shadow.colorProperty​()
      阴影 Color 。
      ObjectProperty<Effect> Lighting.contentInputProperty​()
      内容输入为 Effect 。
      ObjectProperty<Effect> Bloom.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> BoxBlur.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> ColorAdjust.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> DisplacementMap.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> DropShadow.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> GaussianBlur.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> Glow.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> InnerShadow.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> MotionBlur.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> PerspectiveTransform.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> Reflection.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> SepiaTone.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> Shadow.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Light> Lighting.lightProperty​()
      这个光源为这个 Lighting效果。
      ObjectProperty<FloatMap> DisplacementMap.mapDataProperty​()
      这个 Effect的地图数据。
      ObjectProperty<BlendMode> Blend.modeProperty​()
      BlendMode用于将两个输入混合在一起。
      ObjectProperty<Paint> ColorInput.paintProperty​()
      Paint用于洪水地区。
      ObjectProperty<Image> ImageInput.sourceProperty​()
      来源 Image 。
      ObjectProperty<Effect> Blend.topInputProperty​()
      这个 Blend操作的顶部输入。

    • Uses of ObjectProperty in javafx.scene.image

      Methods in javafx.scene.image that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Image> ImageView.imageProperty​()
      Image要画ImageView 。
      ObjectProperty<Rectangle2D> ImageView.viewportProperty​()
      矩形视口进入图像。

    • Uses of ObjectProperty in javafx.scene.layout

      Methods in javafx.scene.layout that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Pos> FlowPane.alignmentProperty​()
      Flowpane的内容在其宽度和高度之间的整体对齐。
      ObjectProperty<Pos> GridPane.alignmentProperty​()
      格栅在格栅宽度和高度内的对齐方式。
      ObjectProperty<Pos> HBox.alignmentProperty​()
      孩子们在hbox的宽度和高度之间的整体对齐。
      ObjectProperty<Pos> StackPane.alignmentProperty​()
      在stackpane的宽度和高度内的子项的默认对齐方式。
      ObjectProperty<Pos> TilePane.alignmentProperty​()
      瓦楞纸板内容在其宽度和高度之间的整体对齐。
      ObjectProperty<Pos> VBox.alignmentProperty​()
      孩子们在vbox的宽度和高度之间的整体对齐。
      ObjectProperty<Background> Region.backgroundProperty​()
      该区域的背景由零个或多个BackgroundFill组成，以及零个或多个BackgroundImages。
      ObjectProperty<Border> Region.borderProperty​()
      该区域的边界由零个或多个BorderStrokes组成，零个或多个BorderImages。
      ObjectProperty<Node> BorderPane.bottomProperty​()
      节点放置在此边框的底部边缘。
      ObjectProperty<Node> BorderPane.centerProperty​()
      节点放置在此边框窗格的中心。
      ObjectProperty<HPos> FlowPane.columnHalignmentProperty​()
      垂直花式板的每列内的节点的水平对齐。
      ObjectProperty<HPos> ColumnConstraints.halignmentProperty​()
      列的水平对齐。
      ObjectProperty<Priority> ColumnConstraints.hgrowProperty​()
      该列的横向增长优先级。
      ObjectProperty<Node> BorderPane.leftProperty​()
      节点位于此边框的左边缘。
      ObjectProperty<Insets> Region.opaqueInsetsProperty​()
      定义绘制完全不透明像素的区域的面积。
      ObjectProperty<Orientation> FlowPane.orientationProperty​()
      这个流面的方向。
      ObjectProperty<Orientation> TilePane.orientationProperty​()
      这个瓦片的方向。
      ObjectProperty<Insets> Region.paddingProperty​()
      顶部，右侧，底部和左侧填充该区域的内容。
      ObjectProperty<Node> BorderPane.rightProperty​()
      放置在该边框窗格右边缘的节点。
      ObjectProperty<VPos> FlowPane.rowValignmentProperty​()
      水平流花线每行内的节点垂直对齐。
      ObjectProperty<Shape> Region.shapeProperty​()
      指定时， Shape将使区域呈现为指定的形状而不是圆角矩形。
      ObjectProperty<Pos> TilePane.tileAlignmentProperty​()
      每个孩子在其图块中的默认对齐方式。
      ObjectProperty<Node> BorderPane.topProperty​()
      节点放置在此边框的顶部边缘。
      ObjectProperty<VPos> RowConstraints.valignmentProperty​()
      行的垂直对齐方式。
      ObjectProperty<Priority> RowConstraints.vgrowProperty​()
      该行的垂直成长优先级。

    • Uses of ObjectProperty in javafx.scene.media

      Methods in javafx.scene.media that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<AudioSpectrumListener> MediaPlayer.audioSpectrumListenerProperty​()
      用于音频频谱更新的监听器。
      ObjectProperty<MediaPlayer> MediaView.mediaPlayerProperty​()
      mediaPlayer的输出将由此视图处理。
      ObjectProperty<Runnable> MediaPlayer.onEndOfMediaProperty​()
      当播放器 currentTime达到 stopTime时调用事件处理程序。
      ObjectProperty<Runnable> Media.onErrorProperty​()
      发生错误时调用事件处理程序。
      ObjectProperty<Runnable> MediaPlayer.onErrorProperty​()
      发生错误时调用事件处理程序。
      ObjectProperty<EventHandler<MediaErrorEvent>> MediaView.onErrorProperty​()
      当这个 MediaView发生错误时调用事件处理程序。
      ObjectProperty<Runnable> MediaPlayer.onHaltedProperty​()
      当状态更改为 HALTED时调用事件处理程序。
      ObjectProperty<EventHandler<MediaMarkerEvent>> MediaPlayer.onMarkerProperty​()
      播放器 currentTime到达媒体标记时调用事件处理程序。
      ObjectProperty<Runnable> MediaPlayer.onPausedProperty​()
      事件处理程序在状态更改为 PAUSED时调用。
      ObjectProperty<Runnable> MediaPlayer.onPlayingProperty​()
      事件处理程序在状态更改为 PLAYING时调用。
      ObjectProperty<Runnable> MediaPlayer.onReadyProperty​()
      事件处理程序在状态更改为 READY时调用。
      ObjectProperty<Runnable> MediaPlayer.onRepeatProperty​()
      当玩家的事件处理函数调用 currentTime达到 stopTime ， 将被重复。
      ObjectProperty<Runnable> MediaPlayer.onStalledProperty​()
      事件处理程序在状态更改为 STALLED时调用。
      ObjectProperty<Runnable> MediaPlayer.onStoppedProperty​()
      事件处理程序在状态更改为 STOPPED时调用。
      ObjectProperty<Duration> MediaPlayer.startTimeProperty​()
      媒体应该开始播放的时间偏移，或重复播放时重新启动。
      ObjectProperty<Duration> MediaPlayer.stopTimeProperty​()
      重播时媒体应停止播放或重新启动的时间偏移。
      ObjectProperty<Rectangle2D> MediaView.viewportProperty​()
      指定一个矩形视口到媒体框架。

    • Uses of ObjectProperty in javafx.scene.paint

      Methods in javafx.scene.paint that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Image> PhongMaterial.bumpMapProperty​()
      这个PhongMaterial的凹凸贴图，这是一个正常的地图，存储为RGB Image 。
      ObjectProperty<Color> PhongMaterial.diffuseColorProperty​()
      这个漫反射颜色 PhongMaterial 。
      ObjectProperty<Image> PhongMaterial.diffuseMapProperty​()
      这个漫反射图 PhongMaterial 。
      ObjectProperty<Image> PhongMaterial.selfIlluminationMapProperty​()
      这个 PhongMaterial的自我照明地图。
      ObjectProperty<Color> PhongMaterial.specularColorProperty​()
      这镜子的颜色 PhongMaterial 。
      ObjectProperty<Image> PhongMaterial.specularMapProperty​()
      这个 PhongMaterial的镜面图。

    • Uses of ObjectProperty in javafx.scene.shape

      Methods in javafx.scene.shape that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<CullFace> Shape3D.cullFaceProperty​()
      定义cullFace这个 Shape3D 。
      ObjectProperty<DrawMode> Shape3D.drawModeProperty​()
      定义用于渲染 Shape3D的绘制模式。
      ObjectProperty<Paint> Shape.fillProperty​()
      使用 Paint上下文的设置定义填充 Shape内部的参数。
      ObjectProperty<FillRule> Path.fillRuleProperty​()
      定义用于确定路径内部的填充规则常数。
      ObjectProperty<FillRule> SVGPath.fillRuleProperty​()
      定义用于确定路径内部的填充规则常数。
      ObjectProperty<Material> Shape3D.materialProperty​()
      定义材料 Shape3D 。
      ObjectProperty<Mesh> MeshView.meshProperty​()
      指定此 MeshView的3D网格数据。
      ObjectProperty<StrokeLineCap> Shape.strokeLineCapProperty​()
      如此端盖风格 Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并 StrokeLineCap.SQUARE 。
      ObjectProperty<StrokeLineJoin> Shape.strokeLineJoinProperty​()
      定义路径段相遇时应用的装饰。
      ObjectProperty<Paint> Shape.strokeProperty​()
      使用指定的 Paint的设置定义围绕 Shape轮廓绘制的笔触的参数。
      ObjectProperty<StrokeType> Shape.strokeTypeProperty​()
      定义将strokeWidth应用于形状边界的方向（内部，中心或外部）。
      ObjectProperty<ArcType> Arc.typeProperty​()
      定义闭合类型弧： ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND 。
      ObjectProperty<VertexFormat> TriangleMesh.vertexFormatProperty​()
      指定 TriangleMesh的顶点格式， VertexFormat.POINT_TEXCOORD或 VertexFormat.POINT_NORMAL_TEXCOORD 。

    • Uses of ObjectProperty in javafx.scene.text

      Methods in javafx.scene.text that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<TextBoundsType> Text.boundsTypeProperty​()
      确定如何计算文本节点的边界。
      ObjectProperty<Font> Text.fontProperty​()
      定义文本的字体。
      ObjectProperty<FontSmoothingType> Text.fontSmoothingTypeProperty​()
      指定所请求的字体平滑类型：灰色或LCD。
      ObjectProperty<Paint> Text.selectionFillProperty​()
      所选文字的填充颜色。
      ObjectProperty<TextAlignment> Text.textAlignmentProperty​()
      在边界框中定义水平文本对齐。
      ObjectProperty<TextAlignment> TextFlow.textAlignmentProperty​()
      定义水平文本对齐。
      ObjectProperty<VPos> Text.textOriginProperty​()
      以局部坐标定义文本坐标系的起点。

    • Uses of ObjectProperty in javafx.scene.transform

      Methods in javafx.scene.transform that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Point3D> Rotate.axisProperty​()
      定义枢轴点的旋转轴。
      ObjectProperty<EventHandler<? super TransformChangedEvent>> Transform.onTransformChangedProperty​()
      只要变换改变其任何参数，就调用onTransformChanged事件处理程序。

    • Uses of ObjectProperty in javafx.scene.web

      Methods in javafx.scene.web that return ObjectProperty
      Modifier and Type 方法 描述
      ObjectProperty<Callback<String,Boolean>> WebEngine.confirmHandlerProperty​()
      JavaScript confirm处理程序属性。
      ObjectProperty<Callback<PopupFeatures,WebEngine>> WebEngine.createPopupHandlerProperty​()
      JavaScript弹出窗口处理程序属性。
      ObjectProperty<FontSmoothingType> WebView.fontSmoothingTypeProperty​()
      指定所请求的字体平滑类型：灰色或LCD。
      ObjectProperty<EventHandler<WebEvent<String>>> WebEngine.onAlertProperty​()
      JavaScript alert处理程序属性。
      ObjectProperty<EventHandler<WebErrorEvent>> WebEngine.onErrorProperty​()
      当发生错误时调用事件处理程序。
      ObjectProperty<EventHandler<WebEvent<Rectangle2D>>> WebEngine.onResizedProperty​()
      JavaScript窗口调整大小处理程序属性。
      ObjectProperty<EventHandler<WebEvent<String>>> WebEngine.onStatusChangedProperty​()
      JavaScript状态处理程序属性。
      ObjectProperty<EventHandler<WebEvent<Boolean>>> WebEngine.onVisibilityChangedProperty​()
      JavaScript窗口可见性处理器属性。
      ObjectProperty<Callback<PromptData,String>> WebEngine.promptHandlerProperty​()
      JavaScript prompt处理程序属性。
      ObjectProperty<File> WebEngine.userDataDirectoryProperty​()
      指定此 WebEngine要用于存储本地用户数据的目录。

    • Uses of ObjectProperty in javafx.stage

      Methods in javafx.stage that return ObjectProperty
      Modifier and Type | 方法 | 描述
      ObjectProperty<PopupWindow.AnchorLocation> PopupWindow.anchorLocationProperty​()
      指定弹出式定位中使用的弹出式锚点。
      ObjectProperty<EventDispatcher> Window.eventDispatcherProperty​()
      指定此节点的事件分派器。
      ObjectProperty<String> | Stage.fullScreenExitHintProperty​()
      ObjectProperty<KeyCombination> Stage.fullScreenExitKeyProperty​()
      获取全屏幕退出组合键的属性。
      ObjectProperty<File> DirectoryChooser.initialDirectoryProperty​()
      显示对话框的初始目录。
      ObjectProperty<File> FileChooser.initialDirectoryProperty​()
      显示文件对话框的初始目录。
      ObjectProperty<String> FileChooser.initialFileNameProperty​()
      显示对话框的初始文件名。
      ObjectProperty<EventHandler<Event>> PopupWindow.onAutoHideProperty​()
      autoHide运行后调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onCloseRequestProperty​()
      当有外部请求关闭此 Window 。
      ObjectProperty<EventHandler<WindowEvent>> Window.onHiddenProperty​()
      在窗口被隐藏之后调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onHidingProperty​()
      在Window被隐藏之前调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onShowingProperty​()
      在窗口显示之前调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onShownProperty​()
      在窗口显示之后调用。
      ObjectProperty<FileChooser.ExtensionFilter> FileChooser.selectedExtensionFilterProperty​()
      This property is used to pre-select the extension filter for the next displayed dialog and to read the user-selected extension filter from the dismissed dialog.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ObjectPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ObjectPropertyBase

  • Packages that use ObjectPropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ObjectPropertyBase in javafx.beans.property

      Subclasses of ObjectPropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleObjectProperty<T>
      这个类提供了一个包含任意Object的Property的完整实现。

    • Uses of ObjectPropertyBase in javafx.css

      Subclasses of ObjectPropertyBase in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableObjectProperty<T>
      该课程扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyBooleanProperty

  • Packages that use ReadOnlyBooleanProperty
    软件包 描述
    javafx.application
    提供应用程序生命周期类。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of ReadOnlyBooleanProperty in javafx.application

      Methods in javafx.application that return ReadOnlyBooleanProperty
      Modifier and Type 方法 描述
      static ReadOnlyBooleanProperty Platform.accessibilityActiveProperty​()
      指示辅助功能是否处于活动状态。

    • Uses of ReadOnlyBooleanProperty in javafx.beans.binding

      Methods in javafx.beans.binding that return ReadOnlyBooleanProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyBooleanProperty | ListBinding.emptyProperty​()
      abstract ReadOnlyBooleanProperty ListExpression.emptyProperty​()
      一个布尔属性，如果列表为空，则为 true 。
      ReadOnlyBooleanProperty | MapBinding.emptyProperty​()
      abstract ReadOnlyBooleanProperty MapExpression.emptyProperty​()
      一个布尔属性是 true ，如果地图是空的。
      ReadOnlyBooleanProperty | SetBinding.emptyProperty​()
      abstract ReadOnlyBooleanProperty SetExpression.emptyProperty​()
      一个布尔属性是 true ，如果该集合是空的。

    • Uses of ReadOnlyBooleanProperty in javafx.beans.property

      Subclasses of ReadOnlyBooleanProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  BooleanProperty
      该类提供了一个包含 boolean值的Property的完整实现。
      class  BooleanPropertyBase
      BooleanPropertyBase类是包含 boolean值的属性的基类。
      class  ReadOnlyBooleanPropertyBase
      所有只读属性的基类包装一个 boolean 。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleBooleanProperty
      这个类提供了一个包含 boolean值的Property的全面实现。
      Methods in javafx.beans.property that return ReadOnlyBooleanProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyBooleanProperty | ListPropertyBase.emptyProperty​()
      ReadOnlyBooleanProperty | MapPropertyBase.emptyProperty​()
      ReadOnlyBooleanProperty | SetPropertyBase.emptyProperty​()
      ReadOnlyBooleanProperty ReadOnlyBooleanWrapper.getReadOnlyProperty​()
      返回readonly属性，与该 ReadOnlyBooleanWrapper同步。
      static ReadOnlyBooleanProperty ReadOnlyBooleanProperty.readOnlyBooleanProperty​(ReadOnlyProperty<Boolean> property)
      返回一个ReadOnlyBooleanProperty的ReadOnlyBooleanProperty 。

    • Uses of ReadOnlyBooleanProperty in javafx.beans.property.adapter

      Subclasses of ReadOnlyBooleanProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanBooleanProperty
      A ReadOnlyJavaBeanBooleanProperty在常规的只读Java Bean属性类型为 boolean或 Boolean和JavaFX ReadOnlyBooleanProperty之间提供了一个适配器。

    • Uses of ReadOnlyBooleanProperty in javafx.concurrent

      Methods in javafx.concurrent that return ReadOnlyBooleanProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyBooleanProperty | Service.runningProperty​()
      ReadOnlyBooleanProperty | Task.runningProperty​()
      ReadOnlyBooleanProperty Worker.runningProperty​()
      获取表示Worker正在运行的ReadOnlyBooleanProperty。

    • Uses of ReadOnlyBooleanProperty in javafx.css

      Subclasses of ReadOnlyBooleanProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      该课程扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of ReadOnlyBooleanProperty in javafx.scene

      Methods in javafx.scene that return ReadOnlyBooleanProperty
      Modifier and Type 方法 描述
      ReadOnlyBooleanProperty Node.disabledProperty​()
      指示此 Node是否被禁用。
      ReadOnlyBooleanProperty Node.focusedProperty​()
      指示此 Node当前是否具有输入焦点。
      ReadOnlyBooleanProperty Node.hoverProperty​()
      这个 Node是否被徘徊。
      ReadOnlyBooleanProperty Parent.needsLayoutProperty​()
      表示此节点及其子节点需要对下一个脉冲进行布局传递。
      ReadOnlyBooleanProperty Node.pressedProperty​()
      是否按 Node 。

    • Uses of ReadOnlyBooleanProperty in javafx.scene.control

      Methods in javafx.scene.control that return ReadOnlyBooleanProperty
      Modifier and Type 方法 描述
      ReadOnlyBooleanProperty Tooltip.activatedProperty​()
      通常，当鼠标移动到控件上时，工具提示被“激活”。
      ReadOnlyBooleanProperty ButtonBase.armedProperty​()
      表示该按钮已被“布防”，使得鼠标释放将导致按钮的动作被调用。
      ReadOnlyBooleanProperty Tab.disabledProperty​()
      表示是否禁用 Tab 。
      ReadOnlyBooleanProperty Cell.editingProperty​()
      表示该单元格当前处于编辑状态的属性。
      ReadOnlyBooleanProperty Cell.emptyProperty​()
      用于表示单元格是否具有任何内容的属性。
      ReadOnlyBooleanProperty ProgressIndicator.indeterminateProperty​()
      指示是否可以确定ProgressIndicator的进度的标志。
      ReadOnlyBooleanProperty TreeItem.leafProperty​()
      表示TreeItem leaf属性，如果TreeItem没有子节点，则属性为true。
      ReadOnlyBooleanProperty TextInputControl.redoableProperty​()
      该属性描述如果现在可以重做已撤销的内容的最新更改。
      ReadOnlyBooleanProperty Cell.selectedProperty​()
      指示此单元格是否已被选中。
      ReadOnlyBooleanProperty Tab.selectedProperty​()
      当前选中的选项卡。
      ReadOnlyBooleanProperty ChoiceBox.showingProperty​()
      指示下拉列表是否向用户显示选择列表。
      ReadOnlyBooleanProperty ComboBoxBase.showingProperty​()
      表示ComboBox弹出窗口的当前状态，以及当前是否在屏幕上可见（尽管可能隐藏在其他窗口后面）。
      ReadOnlyBooleanProperty Dialog.showingProperty​()
      表示对话框当前是否显示。
      ReadOnlyBooleanProperty Menu.showingProperty​()
      指示ContextMenu当前是否可见。
      ReadOnlyBooleanProperty MenuButton.showingProperty​()
      指示ContextMenu当前是否可见。
      ReadOnlyBooleanProperty TextInputControl.undoableProperty​()
      该属性描述如果目前可以撤消已完成的内容的最新更改。

    • Uses of ReadOnlyBooleanProperty in javafx.scene.image

      Methods in javafx.scene.image that return ReadOnlyBooleanProperty
      Modifier and Type 方法 描述
      ReadOnlyBooleanProperty Image.errorProperty​()
      指示在加载图像时是否检测到错误。

    • Uses of ReadOnlyBooleanProperty in javafx.scene.transform

      Methods in javafx.scene.transform that return ReadOnlyBooleanProperty
      Modifier and Type 方法 描述
      ReadOnlyBooleanProperty Transform.identityProperty​()
      确定这是否是当前的身份转换。
      ReadOnlyBooleanProperty Transform.type2DProperty​()
      确定这是否是2D变换。

    • Uses of ReadOnlyBooleanProperty in javafx.stage

      Methods in javafx.stage that return ReadOnlyBooleanProperty
      Modifier and Type 方法 描述
      ReadOnlyBooleanProperty Stage.alwaysOnTopProperty​()
      定义这个 Stage是否保持在其他窗口的顶部。
      ReadOnlyBooleanProperty Window.focusedProperty​()
      该 Window是否具有键盘或输入焦点。
      ReadOnlyBooleanProperty Stage.fullScreenProperty​()
      指定这个 Stage应该是一个全屏，未装饰的窗口。
      ReadOnlyBooleanProperty Stage.iconifiedProperty​()
      定义 Stage是否被图标化。
      ReadOnlyBooleanProperty Stage.maximizedProperty​()
      定义 Stage是否最大化。
      ReadOnlyBooleanProperty Window.showingProperty​()
      该 Window是否显示（即，在用户系统上打开）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyBooleanPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyBooleanPropertyBase

  • Packages that use ReadOnlyBooleanPropertyBase
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyBooleanPropertyBase in javafx.beans.property.adapter

      Subclasses of ReadOnlyBooleanPropertyBase in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  ReadOnlyJavaBeanBooleanProperty
      A ReadOnlyJavaBeanBooleanProperty在常规的只读Java Bean属性类型为 boolean或 Boolean和JavaFX ReadOnlyBooleanProperty之间提供了适配器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyBooleanWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyBooleanWrapper

No usage of javafx.beans.property.ReadOnlyBooleanWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyDoubleProperty

  • Packages that use ReadOnlyDoubleProperty
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of ReadOnlyDoubleProperty in javafx.animation

      Methods in javafx.animation that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty Animation.currentRateProperty​()
      只读变量来指示正在播放 Animation当前方向/速度。

    • Uses of ReadOnlyDoubleProperty in javafx.beans.property

      Subclasses of ReadOnlyDoubleProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  DoubleProperty
      这个类定义了一个Property包裹一个double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  ReadOnlyDoublePropertyBase
      所有只读属性的基类包装一个 double 。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      该类提供了一个包含 double值的Property的完整实现。
      Methods in javafx.beans.property that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty ReadOnlyDoubleWrapper.getReadOnlyProperty​()
      返回与此 ReadOnlyDoubleWrapper同步的只读属性。
      static <T extends Number>
      ReadOnlyDoubleProperty             		ReadOnlyDoubleProperty.readOnlyDoubleProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyDoubleProperty的ReadOnlyDoubleProperty 。

    • Uses of ReadOnlyDoubleProperty in javafx.beans.property.adapter

      Subclasses of ReadOnlyDoubleProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在 double或 Double类型的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。

    • Uses of ReadOnlyDoubleProperty in javafx.concurrent

      Methods in javafx.concurrent that return ReadOnlyDoubleProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyDoubleProperty | Service.progressProperty​()
      ReadOnlyDoubleProperty | Task.progressProperty​()
      ReadOnlyDoubleProperty Worker.progressProperty​()
      获取表示进度的ReadOnlyDoubleProperty。
      ReadOnlyDoubleProperty | Service.totalWorkProperty​()
      ReadOnlyDoubleProperty | Task.totalWorkProperty​()
      ReadOnlyDoubleProperty Worker.totalWorkProperty​()
      获取ReadOnlyDoubleProperty代表需要完成的最大工作量。
      ReadOnlyDoubleProperty | Service.workDoneProperty​()
      ReadOnlyDoubleProperty | Task.workDoneProperty​()
      ReadOnlyDoubleProperty Worker.workDoneProperty​()
      获取表示当前进度的ReadOnlyDoubleProperty。

    • Uses of ReadOnlyDoubleProperty in javafx.css

      Subclasses of ReadOnlyDoubleProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of ReadOnlyDoubleProperty in javafx.scene

      Methods in javafx.scene that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty Scene.heightProperty​()
      这个 Scene的高度
      ReadOnlyDoubleProperty ImageCursor.hotspotXProperty​()
      光标热点的X坐标。
      ReadOnlyDoubleProperty ImageCursor.hotspotYProperty​()
      光标热点的Y坐标。
      ReadOnlyDoubleProperty Scene.widthProperty​()
      这个宽度 Scene
      ReadOnlyDoubleProperty Scene.xProperty​()
      这个 Scene的水平位置在 Window 。
      ReadOnlyDoubleProperty Scene.yProperty​()
      这个 Scene的垂直位置在 Window 。

    • Uses of ReadOnlyDoubleProperty in javafx.scene.chart

      Methods in javafx.scene.chart that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty CategoryAxis.categorySpacingProperty​()
      这是沿着这个轴线的一个类别和下一个类别之间的差距
      ReadOnlyDoubleProperty ValueAxis.scaleProperty​()
      从数据单位到视觉单位的比例因子

    • Uses of ReadOnlyDoubleProperty in javafx.scene.control

      Methods in javafx.scene.control that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty Dialog.heightProperty​()
      表示对话框高度的属性。
      ReadOnlyDoubleProperty Dialog.widthProperty​()
      表示对话框宽度的属性。
      ReadOnlyDoubleProperty TableColumnBase.widthProperty​()
      此列的宽度。
      ReadOnlyDoubleProperty Dialog.xProperty​()
      这个水平位置这个 Dialog 。
      ReadOnlyDoubleProperty Dialog.yProperty​()
      这个 Dialog的垂直位置。

    • Uses of ReadOnlyDoubleProperty in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty CellSkinBase.cellSizeProperty​()
      默认单元格大小。

    • Uses of ReadOnlyDoubleProperty in javafx.scene.image

      Methods in javafx.scene.image that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty Image.heightProperty​()
      图像高度或 0如果图像加载失败。
      ReadOnlyDoubleProperty Image.progressProperty​()
      已完成图像加载的大致百分比。
      ReadOnlyDoubleProperty Image.widthProperty​()
      图像宽度或 0如果图像加载失败。

    • Uses of ReadOnlyDoubleProperty in javafx.scene.layout

      Methods in javafx.scene.layout that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty Region.heightProperty​()
      这个可调节大小的节点的高度。
      ReadOnlyDoubleProperty TilePane.tileHeightProperty​()
      每个瓷砖的实际高度。
      ReadOnlyDoubleProperty TilePane.tileWidthProperty​()
      每个瓷砖的实际宽度。
      ReadOnlyDoubleProperty Region.widthProperty​()
      这个可调节大小的节点的宽度。

    • Uses of ReadOnlyDoubleProperty in javafx.scene.media

      Methods in javafx.scene.media that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty MediaPlayer.currentRateProperty​()
      当前的播放速度，无论设置如何。

    • Uses of ReadOnlyDoubleProperty in javafx.scene.text

      Methods in javafx.scene.text that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty Text.baselineOffsetProperty​()
      “文字”（或罗马）基线偏离了文本节点的layoutBounds.minY位置。

    • Uses of ReadOnlyDoubleProperty in javafx.scene.web

      Methods in javafx.scene.web that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty WebView.heightProperty​()
      身高 WebView 。
      ReadOnlyDoubleProperty WebView.widthProperty​()
      此宽度 WebView 。

    • Uses of ReadOnlyDoubleProperty in javafx.stage

      Methods in javafx.stage that return ReadOnlyDoubleProperty
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty PopupWindow.anchorXProperty​()
      指定屏幕上弹出锚点的x坐标。
      ReadOnlyDoubleProperty PopupWindow.anchorYProperty​()
      指定屏幕上弹出锚点的y坐标。
      ReadOnlyDoubleProperty Window.heightProperty​()
      这个 Window的高度。
      ReadOnlyDoubleProperty Window.outputScaleXProperty​()
      Window将在渲染和将输出合成到屏幕或其他目标设备的所有阶段中应用于水平场景坐标的比例。
      ReadOnlyDoubleProperty Window.outputScaleYProperty​()
      Window将适用于垂直场景坐标在渲染和合成输出到屏幕或其他目标设备的所有阶段的规模。
      ReadOnlyDoubleProperty Window.widthProperty​()
      这个宽度 Window 。
      ReadOnlyDoubleProperty Window.xProperty​()
      这个 Window在屏幕上的水平位置。
      ReadOnlyDoubleProperty Window.yProperty​()
      这个 Window在屏幕上的垂直位置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyDoublePropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyDoublePropertyBase

  • Packages that use ReadOnlyDoublePropertyBase
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyDoublePropertyBase in javafx.beans.property.adapter

      Subclasses of ReadOnlyDoublePropertyBase in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在常规的只读Java Bean属性类型为 double或 Double和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyDoubleWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyDoubleWrapper

No usage of javafx.beans.property.ReadOnlyDoubleWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyFloatProperty

  • Packages that use ReadOnlyFloatProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ReadOnlyFloatProperty in javafx.beans.property

      Subclasses of ReadOnlyFloatProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  FloatProperty
      这个类定义了一个Property包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  ReadOnlyFloatPropertyBase
      所有只读属性的基类包装一个 float 。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleFloatProperty
      这个类提供了一个包含 float值的Property的完整实现。
      Methods in javafx.beans.property that return ReadOnlyFloatProperty
      Modifier and Type 方法 描述
      ReadOnlyFloatProperty ReadOnlyFloatWrapper.getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyFloatWrapper同步。
      static <T extends Number>
      ReadOnlyFloatProperty             		ReadOnlyFloatProperty.readOnlyFloatProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyFloatProperty的ReadOnlyFloatProperty 。

    • Uses of ReadOnlyFloatProperty in javafx.beans.property.adapter

      Subclasses of ReadOnlyFloatProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在类型为 float或 Float的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。

    • Uses of ReadOnlyFloatProperty in javafx.css

      Subclasses of ReadOnlyFloatProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableFloatProperty
      该课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyFloatPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyFloatPropertyBase

  • Packages that use ReadOnlyFloatPropertyBase
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyFloatPropertyBase in javafx.beans.property.adapter

      Subclasses of ReadOnlyFloatPropertyBase in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在 float或 Float之间的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty提供了一个适配器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyFloatWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyFloatWrapper

No usage of javafx.beans.property.ReadOnlyFloatWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyIntegerProperty

  • Packages that use ReadOnlyIntegerProperty
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of ReadOnlyIntegerProperty in javafx.beans.binding

      Methods in javafx.beans.binding that return ReadOnlyIntegerProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyIntegerProperty | ListBinding.sizeProperty​()
      abstract ReadOnlyIntegerProperty ListExpression.sizeProperty​()
      表示列表大小的整数属性。
      ReadOnlyIntegerProperty | MapBinding.sizeProperty​()
      abstract ReadOnlyIntegerProperty MapExpression.sizeProperty​()
      表示地图大小的整数属性。
      ReadOnlyIntegerProperty | SetBinding.sizeProperty​()
      abstract ReadOnlyIntegerProperty SetExpression.sizeProperty​()
      表示集合大小的整数属性。

    • Uses of ReadOnlyIntegerProperty in javafx.beans.property

      Subclasses of ReadOnlyIntegerProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  IntegerProperty
      这个类定义了一个int包含一个int值。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  ReadOnlyIntegerPropertyBase
      所有只读属性的基类包装一个 int 。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleIntegerProperty
      这个类提供了一个包含 int值的Property的完整实现。
      Methods in javafx.beans.property that return ReadOnlyIntegerProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyIntegerProperty ReadOnlyIntegerWrapper.getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyIntegerWrapper同步。
      static <T extends Number>
      ReadOnlyIntegerProperty             		ReadOnlyIntegerProperty.readOnlyIntegerProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyIntegerProperty的ReadOnlyIntegerProperty 。
      ReadOnlyIntegerProperty | ListPropertyBase.sizeProperty​()
      ReadOnlyIntegerProperty | MapPropertyBase.sizeProperty​()
      ReadOnlyIntegerProperty | SetPropertyBase.sizeProperty​()

    • Uses of ReadOnlyIntegerProperty in javafx.beans.property.adapter

      Subclasses of ReadOnlyIntegerProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在 int或 Integer之间的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty提供了一个适配器。

    • Uses of ReadOnlyIntegerProperty in javafx.concurrent

      Methods in javafx.concurrent that return ReadOnlyIntegerProperty
      Modifier and Type 方法 描述
      ReadOnlyIntegerProperty ScheduledService.currentFailureCountProperty​()
      当前ScheduledService失败的次数。

    • Uses of ReadOnlyIntegerProperty in javafx.css

      Subclasses of ReadOnlyIntegerProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableIntegerProperty
      该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of ReadOnlyIntegerProperty in javafx.print

      Methods in javafx.print that return ReadOnlyIntegerProperty
      Modifier and Type 方法 描述
      ReadOnlyIntegerProperty PageRange.endPageProperty​()
      IntegerProperty表示范围的结束页码。
      ReadOnlyIntegerProperty PageRange.startPageProperty​()
      IntegerProperty表示范围的起始页码。

    • Uses of ReadOnlyIntegerProperty in javafx.scene.control

      Methods in javafx.scene.control that return ReadOnlyIntegerProperty
      Modifier and Type 方法 描述
      ReadOnlyIntegerProperty TextInputControl.anchorProperty​()
      anchor的文字选择。
      ReadOnlyIntegerProperty TextInputControl.caretPositionProperty​()
      文本中插入符号的当前位置。
      ReadOnlyIntegerProperty ListView.editingIndexProperty​()
      用于表示当前在ListView中编辑的项目的索引的属性（如果正在进行编辑），如果没有编辑任何项目，则用于表示-1。
      ReadOnlyIntegerProperty TreeTableView.expandedItemCountProperty​()
      表示当前能够在TreeTableView中可见的树节点数。
      ReadOnlyIntegerProperty TreeView.expandedItemCountProperty​()
      表示当前能够在TreeView中可见的树节点数。
      ReadOnlyIntegerProperty FocusModel.focusedIndexProperty​()
      FocusModel中具有焦点的当前项目的索引。
      ReadOnlyIntegerProperty IndexedCell.indexProperty​()
      （：例如，在虚拟化控制这个小区的位置ListView ， TreeView ， TableView等）。
      ReadOnlyIntegerProperty TextInputControl.lengthProperty​()
      文本输入中的字符数。
      ReadOnlyIntegerProperty SelectionModel.selectedIndexProperty​()
      指所选索引属性，用于指示选择模型中当前选定的索引值。

    • Uses of ReadOnlyIntegerProperty in javafx.scene.media

      Methods in javafx.scene.media that return ReadOnlyIntegerProperty
      Modifier and Type 方法 描述
      ReadOnlyIntegerProperty MediaPlayer.currentCountProperty​()
      完成播放周期的次数。
      ReadOnlyIntegerProperty Media.heightProperty​()
      源媒体的像素高度。
      ReadOnlyIntegerProperty Media.widthProperty​()
      源媒体的像素宽度。

    • Uses of ReadOnlyIntegerProperty in javafx.scene.web

      Methods in javafx.scene.web that return ReadOnlyIntegerProperty
      Modifier and Type 方法 描述
      ReadOnlyIntegerProperty WebHistory.currentIndexProperty​()
      定义历史上当前 Entry的指数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyIntegerPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyIntegerPropertyBase

  • Packages that use ReadOnlyIntegerPropertyBase
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyIntegerPropertyBase in javafx.beans.property.adapter

      Subclasses of ReadOnlyIntegerPropertyBase in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty提供了一个 int或 Integer的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyIntegerWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyIntegerWrapper

No usage of javafx.beans.property.ReadOnlyIntegerWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyListProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyListProperty

  • Packages that use ReadOnlyListProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of ReadOnlyListProperty in javafx.beans.property

      Subclasses of ReadOnlyListProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleListProperty<E>
      这个类提供了一个Property包装一个ObservableList的完整实现。
      Methods in javafx.beans.property that return ReadOnlyListProperty
      Modifier and Type 方法 描述
      ReadOnlyListProperty<E> ReadOnlyListWrapper.getReadOnlyProperty​()
      Returns the readonly property, that is synchronized with this ReadOnlyListWrapper.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyListPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyListPropertyBase

No usage of javafx.beans.property.ReadOnlyListPropertyBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyListWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyListWrapper

No usage of javafx.beans.property.ReadOnlyListWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyLongProperty

  • Packages that use ReadOnlyLongProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ReadOnlyLongProperty in javafx.beans.property

      Subclasses of ReadOnlyLongProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  LongProperty
      这个类定义了一个Property包裹一个long值。
      class  LongPropertyBase
      类 LongPropertyBase是包含 long值的属性的基类。
      class  ReadOnlyLongPropertyBase
      所有只读属性的基类包装一个 long 。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleLongProperty
      该类提供了一个包含 long值的Property的完整实现。
      Methods in javafx.beans.property that return ReadOnlyLongProperty
      Modifier and Type 方法 描述
      ReadOnlyLongProperty ReadOnlyLongWrapper.getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyLongWrapper同步。
      static <T extends Number>
      ReadOnlyLongProperty             		ReadOnlyLongProperty.readOnlyLongProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyLongProperty的ReadOnlyLongProperty 。

    • Uses of ReadOnlyLongProperty in javafx.beans.property.adapter

      Subclasses of ReadOnlyLongProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在 long或 Long之间的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在 long或 Long之间的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty提供了一个适配器。

    • Uses of ReadOnlyLongProperty in javafx.css

      Subclasses of ReadOnlyLongProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableLongProperty
      这个类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyLongPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyLongPropertyBase

  • Packages that use ReadOnlyLongPropertyBase
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyLongPropertyBase in javafx.beans.property.adapter

      Subclasses of ReadOnlyLongPropertyBase in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在 long或 Long之间的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty提供了一个适配器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyLongWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyLongWrapper

No usage of javafx.beans.property.ReadOnlyLongWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyMapProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyMapProperty

  • Packages that use ReadOnlyMapProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of ReadOnlyMapProperty in javafx.beans.property

      Subclasses of ReadOnlyMapProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  MapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装ObservableMap的属性的基类。
      class  ReadOnlyMapPropertyBase<K,V>
      所有只读属性的基类包装一个ObservableMap 。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
      Methods in javafx.beans.property that return ReadOnlyMapProperty
      Modifier and Type 方法 描述
      ReadOnlyMapProperty<K,V> ReadOnlyMapWrapper.getReadOnlyProperty​()
      Returns the readonly property, that is synchronized with this ReadOnlyMapWrapper.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyMapPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyMapPropertyBase

No usage of javafx.beans.property.ReadOnlyMapPropertyBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyMapWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyMapWrapper

No usage of javafx.beans.property.ReadOnlyMapWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyObjectProperty

  • Packages that use ReadOnlyObjectProperty
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of ReadOnlyObjectProperty in javafx.animation

      Methods in javafx.animation that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Duration> Animation.currentTimeProperty​()
      定义 Animation的播放头位置。
      ReadOnlyObjectProperty<Duration> Animation.cycleDurationProperty​()
      只读变量，用于指示 Animation的一个周期的持续时间：从时间0到动画结束所需的时间（默认为 rate为1.0）。
      ReadOnlyObjectProperty<Animation.Status> Animation.statusProperty​()
      的状态 Animation 。
      ReadOnlyObjectProperty<Duration> Animation.totalDurationProperty​()
      只读变量，用于指示此 Animation的总持续时间，包括重复。

    • Uses of ReadOnlyObjectProperty in javafx.beans.property

      Subclasses of ReadOnlyObjectProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ObjectProperty<T>
      这个类提供了一个包含任意Object的Property的完整实现。
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyObjectPropertyBase<T>
      所有只读属性的基类包装任意 Object 。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleObjectProperty<T>
      这个类提供了一个Property的完整实现，包装任意的Object 。
      Methods in javafx.beans.property that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Boolean> ReadOnlyBooleanProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyBooleanProperty 。
      ReadOnlyObjectProperty<Double> ReadOnlyDoubleProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyDoubleProperty 。
      ReadOnlyObjectProperty<Float> ReadOnlyFloatProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyFloatProperty 。
      ReadOnlyObjectProperty<Integer> ReadOnlyIntegerProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyIntegerProperty 。
      ReadOnlyObjectProperty<Long> ReadOnlyLongProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyLongProperty 。
      ReadOnlyObjectProperty<T> ReadOnlyObjectWrapper.getReadOnlyProperty​()
      返回readonly属性，与该 ReadOnlyObjectWrapper同步。

    • Uses of ReadOnlyObjectProperty in javafx.beans.property.adapter

      Subclasses of ReadOnlyObjectProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
      class  ReadOnlyJavaBeanObjectProperty<T>
      A ReadOnlyJavaBeanObjectProperty在常规只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间提供了一个适配器。

    • Uses of ReadOnlyObjectProperty in javafx.concurrent

      Methods in javafx.concurrent that return ReadOnlyObjectProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyObjectProperty<Duration> ScheduledService.cumulativePeriodProperty​()
      迭代之间使用的当前累积周期。
      ReadOnlyObjectProperty<Throwable> | Service.exceptionProperty​()
      ReadOnlyObjectProperty<Throwable> | Task.exceptionProperty​()
      ReadOnlyObjectProperty<Throwable> Worker.exceptionProperty​()
      获取表示发生的任何异常的ReadOnlyObjectProperty。
      ReadOnlyObjectProperty<V> ScheduledService.lastValueProperty​()
      最后成功计算的值。
      ReadOnlyObjectProperty<Worker.State> | Service.stateProperty​()
      ReadOnlyObjectProperty<Worker.State> | Task.stateProperty​()
      ReadOnlyObjectProperty<Worker.State> Worker.stateProperty​()
      获取表示当前状态的ReadOnlyObjectProperty。
      ReadOnlyObjectProperty<V> | Service.valueProperty​()
      ReadOnlyObjectProperty<V> | Task.valueProperty​()
      ReadOnlyObjectProperty<V> Worker.valueProperty​()
      获取表示值的ReadOnlyObjectProperty。

    • Uses of ReadOnlyObjectProperty in javafx.css

      Subclasses of ReadOnlyObjectProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableObjectProperty<T>
      这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of ReadOnlyObjectProperty in javafx.print

      Methods in javafx.print that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      static ReadOnlyObjectProperty<Printer> Printer.defaultPrinterProperty​()
      表示当前默认打印机的只读对象属性。
      ReadOnlyObjectProperty<PrinterJob.JobStatus> PrinterJob.jobStatusProperty​()
      一个只读对象属性，代表当前的 JobStatus

    • Uses of ReadOnlyObjectProperty in javafx.scene

      Methods in javafx.scene that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Bounds> Node.boundsInLocalProperty​()
      该节点未转换的局部坐标空间中的 Node的矩形边界。
      ReadOnlyObjectProperty<Bounds> Node.boundsInParentProperty​()
      这个 Node的矩形边界包括它的变换。
      ReadOnlyObjectProperty<NodeOrientation> Node.effectiveNodeOrientationProperty​()
      节点的有效方向解决节点方向的继承，从左到右或从右到左返回。
      ReadOnlyObjectProperty<NodeOrientation> Scene.effectiveNodeOrientationProperty​()
      场景的有效节点方向解决节点方向的继承，从左到右或从右到左返回。
      ReadOnlyObjectProperty<Node> Scene.focusOwnerProperty​()
      场景当前焦点所有者节点。
      ReadOnlyObjectProperty<Image> ImageCursor.imageProperty​()
      光标激活时显示的图像。
      ReadOnlyObjectProperty<Bounds> Node.layoutBoundsProperty​()
      应该用于此节点的布局计算的矩形边界。
      ReadOnlyObjectProperty<Transform> Node.localToParentTransformProperty​()
      保存计算的本地到父变换的仿射变换。
      ReadOnlyObjectProperty<Transform> Node.localToSceneTransformProperty​()
      拥有计算的局部到场景变换的仿射变换。
      ReadOnlyObjectProperty<Parent> Node.parentProperty​()
      这是 Node的父母。
      ReadOnlyObjectProperty<Scene> Node.sceneProperty​()
      Scene这个Node是其中的一部分。
      ReadOnlyObjectProperty<Window> Scene.windowProperty​()
      Window为这 Scene

    • Uses of ReadOnlyObjectProperty in javafx.scene.chart

      Methods in javafx.scene.chart that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<PieChart> PieChart.Data.chartProperty​()
      该数据所属的图表。
      ReadOnlyObjectProperty<XYChart<X,Y>> XYChart.Series.chartProperty​()
      参考本系列所属的图表
      ReadOnlyObjectProperty<Node> PieChart.Data.nodeProperty​()
      访问表示饼图切片的节点。

    • Uses of ReadOnlyObjectProperty in javafx.scene.control

      Methods in javafx.scene.control that return ReadOnlyObjectProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyObjectProperty<Comparator<S>> TableView.comparatorProperty​()
      比较器属性是一个只读属性，代表 sort order列表的当前状态。
      ReadOnlyObjectProperty<Comparator<TreeItem<S>>> TreeTableView.comparatorProperty​()
      比较器属性是一个只读属性，代表 sort order列表的当前状态。
      ReadOnlyObjectProperty<TablePosition<S,?>> TableView.editingCellProperty​()
      表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
      ReadOnlyObjectProperty<TreeTablePosition<S,?>> TreeTableView.editingCellProperty​()
      表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
      ReadOnlyObjectProperty<TreeItem<T>> TreeView.editingItemProperty​()
      用于表示当前在TreeView中编辑的TreeItem的属性，如果正在进行编辑，或者如果没有编辑任何项目，则为null。
      ReadOnlyObjectProperty<TextField> ComboBox.editorProperty​()
      ComboBox的编辑器。
      ReadOnlyObjectProperty<TextField> DatePicker.editorProperty​()
      DatePicker的编辑器。
      ReadOnlyObjectProperty<TextField> Spinner.editorProperty​()
      Spinner控件使用的编辑器。
      ReadOnlyObjectProperty<TablePosition> TableView.TableViewFocusModel.focusedCellProperty​()
      当前项目在TableView中的位置具有重点。
      ReadOnlyObjectProperty<TreeTablePosition<S,?>> TreeTableView.TreeTableViewFocusModel.focusedCellProperty​()
      当前项目在TableView中的位置具有重点。
      ReadOnlyObjectProperty<T> FocusModel.focusedItemProperty​()
      FocusModel中的当前项目具有重点。
      ReadOnlyObjectProperty<Insets> Labeled.labelPaddingProperty​()
      标签周围的文字和图形内容。
      ReadOnlyObjectProperty<ListView<T>> ListCell.listViewProperty​()
      与此单元格关联的ListView。
      ReadOnlyObjectProperty<TableColumnBase<S,?>> TableColumnBase.parentColumnProperty​()
      在使用嵌套列的情况下，此只读属性将始终引用此列的父级。
      ReadOnlyObjectProperty<Menu> MenuItem.parentMenuProperty​()
      这是Menu ，其中MenuItem存在。
      ReadOnlyObjectProperty<ContextMenu> MenuItem.parentPopupProperty​()
      这是ContextMenu ，其中MenuItem存在。
      ReadOnlyObjectProperty<TreeItem<T>> TreeItem.parentProperty​()
      表示此TreeItem父项的属性。
      ReadOnlyObjectProperty<T> ChoiceDialog.selectedItemProperty​()
      返回表示对话框中当前选定项目的属性。
      ReadOnlyObjectProperty<T> SelectionModel.selectedItemProperty​()
      指所选项目属性，用于指示选择模型中当前选定的项目。
      ReadOnlyObjectProperty<Toggle> ToggleGroup.selectedToggleProperty​()
      所选的切换。
      ReadOnlyObjectProperty<IndexRange> TextInputControl.selectionProperty​()
      当前选择。
      ReadOnlyObjectProperty<TableColumn<S,T>> TableCell.tableColumnProperty​()
      支持此TableCell的TableColumn实例。
      ReadOnlyObjectProperty<TreeTableColumn<S,T>> | TreeTableCell.tableColumnProperty​()
      ReadOnlyObjectProperty<TableRow<S>> TableCell.tableRowProperty​()
      该TableCow目前发现自己位于的TableRow。
      ReadOnlyObjectProperty<TreeTableRow<S>> | TreeTableCell.tableRowProperty​()
      ReadOnlyObjectProperty<TableView<S>> TableCell.tableViewProperty​()
      TableView与此TableCell关联。
      ReadOnlyObjectProperty<TableView<S>> TableColumn.tableViewProperty​()
      TableView这个TableColumn属于。
      ReadOnlyObjectProperty<TableView<T>> TableRow.tableViewProperty​()
      与此Cell关联的TableView。
      ReadOnlyObjectProperty<TabPane> Tab.tabPaneProperty​()
      包含此选项卡的TabPane。
      ReadOnlyObjectProperty<TreeItem<T>> TreeCell.treeItemProperty​()
      每个TreeCell最多代表一个TreeItem ，由该属性表示。
      ReadOnlyObjectProperty<TreeItem<T>> TreeTableRow.treeItemProperty​()
      每个TreeTableCell最多表示一个TreeItem ，由该属性表示。
      ReadOnlyObjectProperty<TreeTableView<S>> TreeTableCell.treeTableViewProperty​()
      与此TreeTableCell关联的TreeTableView。
      ReadOnlyObjectProperty<TreeTableView<S>> TreeTableColumn.treeTableViewProperty​()
      TreeTableColumn属于的TreeTableView。
      ReadOnlyObjectProperty<TreeTableView<T>> TreeTableRow.treeTableViewProperty​()
      TreeTableCell显式链接到一个TreeTableView实例，由该属性表示。
      ReadOnlyObjectProperty<TreeView<T>> TreeCell.treeViewProperty​()
      TreeCell显式链接到一个TreeView实例，由该属性表示。
      ReadOnlyObjectProperty<T> Spinner.valueProperty​()
      Spinner上的value属性是只读属性，因为它绑定到SpinnerValueFactory value property 。

    • Uses of ReadOnlyObjectProperty in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<TableColumn<S,T>> TableCellSkin.tableColumnProperty​()
      负责此单元格的TableColumnBase实例。
      abstract ReadOnlyObjectProperty<? extends TableColumnBase<S,T>> TableCellSkinBase.tableColumnProperty​()
      负责此单元格的TableColumnBase实例。
      ReadOnlyObjectProperty<TableColumnBase<?,?>> TableColumnHeader.tableColumnProperty​()
      引用此头部视觉表示的TableColumnBase实例的属性。
      ReadOnlyObjectProperty<TreeTableColumn<S,T>> TreeTableCellSkin.tableColumnProperty​()
      负责此单元格的TableColumnBase实例。

    • Uses of ReadOnlyObjectProperty in javafx.scene.image

      Methods in javafx.scene.image that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<异常> Image.exceptionProperty​()
      导致图像加载失败的异常。

    • Uses of ReadOnlyObjectProperty in javafx.scene.layout

      Methods in javafx.scene.layout that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Insets> Region.insetsProperty​()
      区域的插图定义从区域边缘（其布局边界，或（0,0，宽度，高度））到内容区域边缘的距离。

    • Uses of ReadOnlyObjectProperty in javafx.scene.media

      Methods in javafx.scene.media that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Duration> MediaPlayer.bufferProgressTimeProperty​()
      当前的缓冲位置指示可以播放多少媒体，而不会停止 MediaPlayer 。
      ReadOnlyObjectProperty<Duration> MediaPlayer.currentTimeProperty​()
      当前媒体播放时间。
      ReadOnlyObjectProperty<Duration> MediaPlayer.cycleDurationProperty​()
      这个玩家的 startTime和 stopTime之间的时间量。
      ReadOnlyObjectProperty<Duration> Media.durationProperty​()
      源介质的持续时间（以秒为单位）。
      ReadOnlyObjectProperty<MediaException> Media.errorProperty​()
      发生错误时将属性设置为MediaException值。
      ReadOnlyObjectProperty<MediaException> MediaPlayer.errorProperty​()
      如果发生错误，Observable属性设置为 MediaException 。
      ReadOnlyObjectProperty<MediaPlayer.Status> MediaPlayer.statusProperty​()
      MediaPlayer的当前状态。
      ReadOnlyObjectProperty<Duration> MediaPlayer.totalDurationProperty​()
      播放时间的总量，如果允许玩，直到完成。

    • Uses of ReadOnlyObjectProperty in javafx.scene.text

      Methods in javafx.scene.text that return ReadOnlyObjectProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyObjectProperty<PathElement[]> | Text.caretShapeProperty​()
      ReadOnlyObjectProperty<PathElement[]> | Text.selectionShapeProperty​()

    • Uses of ReadOnlyObjectProperty in javafx.scene.web

      Methods in javafx.scene.web that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Document> WebEngine.documentProperty​()
      当前网页的文档对象。
      ReadOnlyObjectProperty<Date> WebHistory.Entry.lastVisitedDateProperty​()
      定义页面最后访问的Date 。
      ReadOnlyObjectProperty<String> WebHistory.Entry.titleProperty​()
      定义页面的标题。

    • Uses of ReadOnlyObjectProperty in javafx.stage

      Methods in javafx.stage that return ReadOnlyObjectProperty
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Node> PopupWindow.ownerNodeProperty​()
      该弹出窗口的所有者的节点。
      ReadOnlyObjectProperty<Window> PopupWindow.ownerWindowProperty​()
      作为此弹出窗口的父窗口。
      ReadOnlyObjectProperty<Scene> Window.sceneProperty​()
      Scene要在这个 Window上呈现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyObjectPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyObjectPropertyBase

  • Packages that use ReadOnlyObjectPropertyBase
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyObjectPropertyBase in javafx.beans.property.adapter

      Subclasses of ReadOnlyObjectPropertyBase in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  ReadOnlyJavaBeanObjectProperty<T>
      A ReadOnlyJavaBeanObjectProperty在常规只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间提供了一个适配器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyObjectWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyObjectWrapper

No usage of javafx.beans.property.ReadOnlyObjectWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlySetProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlySetProperty

  • Packages that use ReadOnlySetProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of ReadOnlySetProperty in javafx.beans.property

      Subclasses of ReadOnlySetProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleSetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
      Methods in javafx.beans.property that return ReadOnlySetProperty
      Modifier and Type 方法 描述
      ReadOnlySetProperty<E> ReadOnlySetWrapper.getReadOnlyProperty​()
      Returns the readonly property, that is synchronized with this ReadOnlySetWrapper.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlySetPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlySetPropertyBase

No usage of javafx.beans.property.ReadOnlySetPropertyBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlySetWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlySetWrapper

No usage of javafx.beans.property.ReadOnlySetWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyStringProperty

  • Packages that use ReadOnlyStringProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of ReadOnlyStringProperty in javafx.beans.property

      Subclasses of ReadOnlyStringProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyStringPropertyBase
      所有只读属性的基类包装一个 String 。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleStringProperty
      这个类提供了一个包含 String值的Property的完整实现。
      class  StringProperty
      这个类提供了一个270667215663590包装一个String值的完整实现。
      class  StringPropertyBase
      StringPropertyBase类是包含 String值的属性的基类。
      Methods in javafx.beans.property that return ReadOnlyStringProperty
      Modifier and Type 方法 描述
      ReadOnlyStringProperty ReadOnlyStringWrapper.getReadOnlyProperty​()
      返回readonly属性，该属性与此 ReadOnlyStringWrapper同步。

    • Uses of ReadOnlyStringProperty in javafx.beans.property.adapter

      Subclasses of ReadOnlyStringProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanStringProperty
      一个 JavaBeanStringProperty提供类型的普通的Java Bean属性之间的适配器 String和一个JavaFX StringProperty 。
      class  ReadOnlyJavaBeanStringProperty
      一个 ReadOnlyJavaBeanStringProperty提供了一个常规的只读型的Java Bean的属性之间的适配器 String和一个JavaFX ReadOnlyStringProperty 。

    • Uses of ReadOnlyStringProperty in javafx.concurrent

      Methods in javafx.concurrent that return ReadOnlyStringProperty
      Modifier and Type | 方法 | 描述
      ReadOnlyStringProperty | Service.messageProperty​()
      ReadOnlyStringProperty | Task.messageProperty​()
      ReadOnlyStringProperty Worker.messageProperty​()
      获取表示消息的ReadOnlyStringProperty。
      ReadOnlyStringProperty | Service.titleProperty​()
      ReadOnlyStringProperty | Task.titleProperty​()
      ReadOnlyStringProperty Worker.titleProperty​()
      获取表示标题的ReadOnlyStringProperty。

    • Uses of ReadOnlyStringProperty in javafx.css

      Subclasses of ReadOnlyStringProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableStringProperty
      这个类扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of ReadOnlyStringProperty in javafx.scene.control

      Methods in javafx.scene.control that return ReadOnlyStringProperty
      Modifier and Type 方法 描述
      ReadOnlyStringProperty TextInputControl.selectedTextProperty​()
      定义所选文本输入控件中的字符

    • Uses of ReadOnlyStringProperty in javafx.scene.web

      Methods in javafx.scene.web that return ReadOnlyStringProperty
      Modifier and Type 方法 描述
      ReadOnlyStringProperty WebEngine.locationProperty​()
      当前网页的URL。
      ReadOnlyStringProperty WebEngine.titleProperty​()
      当前网页的标题。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyStringPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyStringPropertyBase

  • Packages that use ReadOnlyStringPropertyBase
    软件包 描述
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

    • Uses of ReadOnlyStringPropertyBase in javafx.beans.property.adapter

      Subclasses of ReadOnlyStringPropertyBase in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  ReadOnlyJavaBeanStringProperty
      A ReadOnlyJavaBeanStringProperty在类型为 String的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.ReadOnlyStringWrapper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.ReadOnlyStringWrapper

No usage of javafx.beans.property.ReadOnlyStringWrapper
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SetProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SetProperty

  • Packages that use SetProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of SetProperty in javafx.beans.property

      Subclasses of SetProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleSetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SetPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SetPropertyBase

  • Packages that use SetPropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of SetPropertyBase in javafx.beans.property

      Subclasses of SetPropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleSetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleBooleanProperty

  • Packages that use SimpleBooleanProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of SimpleBooleanProperty in javafx.beans.property

      Subclasses of SimpleBooleanProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleDoubleProperty

  • Packages that use SimpleDoubleProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of SimpleDoubleProperty in javafx.beans.property

      Subclasses of SimpleDoubleProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleFloatProperty

  • Packages that use SimpleFloatProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。

    • Uses of SimpleFloatProperty in javafx.beans.property

      Subclasses of SimpleFloatProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleIntegerProperty

  • Packages that use SimpleIntegerProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of SimpleIntegerProperty in javafx.beans.property

      Subclasses of SimpleIntegerProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleListProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleListProperty

  • Packages that use SimpleListProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of SimpleListProperty in javafx.beans.property

      Subclasses of SimpleListProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleLongProperty

  • Packages that use SimpleLongProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。

    • Uses of SimpleLongProperty in javafx.beans.property

      Subclasses of SimpleLongProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleMapProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleMapProperty

  • Packages that use SimpleMapProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of SimpleMapProperty in javafx.beans.property

      Subclasses of SimpleMapProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleObjectProperty

  • Packages that use SimpleObjectProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of SimpleObjectProperty in javafx.beans.property

      Subclasses of SimpleObjectProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleSetProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleSetProperty

  • Packages that use SimpleSetProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。

    • Uses of SimpleSetProperty in javafx.beans.property

      Subclasses of SimpleSetProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.SimpleStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.SimpleStringProperty

  • Packages that use SimpleStringProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of SimpleStringProperty in javafx.beans.property

      Subclasses of SimpleStringProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.StringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.StringProperty

  • Packages that use StringProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of StringProperty in javafx.beans.property

      Subclasses of StringProperty in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleStringProperty
      这个类提供了一个包含 String值的Property的全面实现。
      class  StringPropertyBase
      StringPropertyBase类是包含 String值的属性的基类。

    • Uses of StringProperty in javafx.beans.property.adapter

      Subclasses of StringProperty in javafx.beans.property.adapter
      Modifier and Type Class 描述
      class  JavaBeanStringProperty
      A JavaBeanStringProperty在 String类型的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。

    • Uses of StringProperty in javafx.css

      Subclasses of StringProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableStringProperty
      这个类扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of StringProperty in javafx.print

      Methods in javafx.print that return StringProperty
      Modifier and Type 方法 描述
      StringProperty JobSettings.jobNameProperty​()
      StringProperty表示作业的名称。

    • Uses of StringProperty in javafx.scene

      Methods in javafx.scene that return StringProperty
      Modifier and Type 方法 描述
      StringProperty Node.idProperty​()
      该 Node的id。
      StringProperty Node.styleProperty​()
      与此特定 Node相关联的CSS样式的字符串表示 Node 。

    • Uses of StringProperty in javafx.scene.chart

      Methods in javafx.scene.chart that return StringProperty
      Modifier and Type 方法 描述
      StringProperty PieChart.Data.nameProperty​()
      饼图的名称
      StringProperty XYChart.Series.nameProperty​()
      该系列的用户可显示的名称
      StringProperty Chart.titleProperty​()
      图表标题

    • Uses of StringProperty in javafx.scene.control

      Methods in javafx.scene.control that return StringProperty
      Modifier and Type | 方法 | 描述
      StringProperty ButtonBar.buttonOrderProperty​()
      标准按钮栏中典型按钮的顺序。
      StringProperty Dialog.contentTextProperty​()
      表示对话窗格的内容文本的属性。
      StringProperty DialogPane.contentTextProperty​()
      表示对话窗格的内容文本的属性。
      StringProperty Labeled.ellipsisStringProperty​()
      指定在文本被截断时为省略号显示的字符串。
      StringProperty Dialog.headerTextProperty​()
      表示对话框窗格的标题文本的属性。
      StringProperty DialogPane.headerTextProperty​()
      表示对话框窗格的标题文本的属性。
      StringProperty MenuItem.idProperty​()
      该MenuItem的ID。
      StringProperty PopupControl.idProperty​()
      该 PopupControl的id。
      StringProperty Tab.idProperty​()
      此选项卡的ID。
      StringProperty TableColumnBase.idProperty​()
      此TableColumnBase的ID。
      StringProperty ComboBoxBase.promptTextProperty​()
      ComboBox提示文本显示，或 null如果没有显示提示文字。
      StringProperty Spinner.promptTextProperty​()
      在 Spinner显示的提示文本，如果没有显示提示文本，则显示 null 。
      StringProperty TextInputControl.promptTextProperty​()
      提示文字显示在 TextInputControl 。
      StringProperty MenuItem.styleProperty​()
      与此特定MenuItem相关联的CSS样式的字符串表示形式。
      StringProperty | PopupControl.styleProperty​()
      StringProperty Tab.styleProperty​()
      与此选项卡关联的CSS样式字符串。
      StringProperty TableColumnBase.styleProperty​()
      与此TableColumnBase实例相关联的CSS样式的字符串表示形式。
      StringProperty Labeled.textProperty​()
      要在标签中显示的文字。
      StringProperty MenuItem.textProperty​()
      要显示的文字在 MenuItem 。
      StringProperty Tab.textProperty​()
      选项卡中显示的文本。
      StringProperty TableColumnBase.textProperty​()
      这是此列的标题中显示的文本。
      StringProperty TextInputControl.textProperty​()
      TextInputControl的文本内容。
      StringProperty Tooltip.textProperty​()
      要在工具提示中显示的文字。
      StringProperty Dialog.titleProperty​()
      返回对话框的titleProperty。

    • Uses of StringProperty in javafx.scene.shape

      Methods in javafx.scene.shape that return StringProperty
      Modifier and Type 方法 描述
      StringProperty SVGPath.contentProperty​()
      定义SVG路径编码字符串，如下所示： http://www.w3.org/TR/SVG/paths.html 。

    • Uses of StringProperty in javafx.scene.text

      Methods in javafx.scene.text that return StringProperty
      Modifier and Type 方法 描述
      StringProperty Text.textProperty​()
      定义要显示的文本字符串。

    • Uses of StringProperty in javafx.scene.web

      Methods in javafx.scene.web that return StringProperty
      Modifier and Type 方法 描述
      StringProperty WebEngine.userAgentProperty​()
      指定用户代理ID字符串。
      StringProperty WebEngine.userStyleSheetLocationProperty​()
      用户样式表的位置为字符串URL。

    • Uses of StringProperty in javafx.stage

      Methods in javafx.stage that return StringProperty
      Modifier and Type 方法 描述
      StringProperty DirectoryChooser.titleProperty​()
      显示对话框的标题。
      StringProperty FileChooser.titleProperty​()
      显示文件对话框的标题。
      StringProperty Stage.titleProperty​()
      定义 Stage的标题。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.property.StringPropertyBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.property.StringPropertyBase

  • Packages that use StringPropertyBase
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StringPropertyBase in javafx.beans.property

      Subclasses of StringPropertyBase in javafx.beans.property
      Modifier and Type Class 描述
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleStringProperty
      该类提供了一个包含 String值的Property的全面实现。

    • Uses of StringPropertyBase in javafx.css

      Subclasses of StringPropertyBase in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.property.Property (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.property.Property

  • Packages that use Property
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of Property in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type Property
      Modifier and Type 方法 描述
      static void Bindings.bindBidirectional​(Property<String> stringProperty, Property<?> otherProperty, Format format)
      在String - Property和另一个Property使用指定的Format生成双向绑定（或“反向绑定”）进行转换。
      static <T> void Bindings.bindBidirectional​(Property<String> stringProperty, Property<T> otherProperty, StringConverter<T> converter)
      在String - Property和另一个Property使用指定的StringConverter生成双向绑定（或“反向绑定”）进行转换。
      static <T> void Bindings.bindBidirectional​(Property<T> property1, Property<T> property2)
      在Property的两个实例之间生成双向绑定（或“绑定反向”）。
      static <T> void Bindings.unbindBidirectional​(Property<T> property1, Property<T> property2)
      删除先前使用 Bindings.bindBidirectional(Property, Property)定义的双向绑定。

    • Uses of Property in javafx.beans.property

      Classes in javafx.beans.property that implement Property
      Modifier and Type Class 描述
      class  BooleanProperty
      该类提供了一个包含 boolean值的Property的全面实现。
      class  BooleanPropertyBase
      BooleanPropertyBase类是包含 boolean值的属性的基类。
      class  DoubleProperty
      这个类定义了一个Property包装double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  FloatProperty
      这个类定义了一个Property包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  IntegerProperty
      这个类定义了一个Property包装int值。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  ListProperty<E>
      这个类提供了一个Property包装一个ObservableList的完整实现。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  LongProperty
      这个类定义了一个Property包装long值。
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  MapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装ObservableMap的属性的基类。
      class  ObjectProperty<T>
      这个类提供了一个Property的全面实现，包含任意的Object 。
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleBooleanProperty
      这个类提供了一个包含 boolean值的Property的完整实现。
      class  SimpleDoubleProperty
      这个类提供了一个包含 double值的Property的全面实现。
      class  SimpleFloatProperty
      这个类提供了一个包含 float值的Property的全面实现。
      class  SimpleIntegerProperty
      这个类提供了一个包含 int值的Property的完整实现。
      class  SimpleListProperty<E>
      这个类提供了一个Property包装一个ObservableList的完整实现。
      class  SimpleLongProperty
      这个类提供了一个包含 long值的Property的完整实现。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
      class  SimpleObjectProperty<T>
      这个类提供了一个包含任意Object的Property的完整实现。
      class  SimpleSetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的全面实现。
      class  SimpleStringProperty
      这个类提供了一个包含 String值的Property的完整实现。
      class  StringProperty
      这个类提供了一个包含 String值的Property的全面实现。
      class  StringPropertyBase
      StringPropertyBase类是包含 String值的属性的基类。
      Methods in javafx.beans.property with parameters of type Property
      Modifier and Type 方法 描述
      void BooleanProperty.bindBidirectional​(Property<Boolean> other)
      在这个 Property和另一个之间创建双向绑定。
      void DoubleProperty.bindBidirectional​(Property<Number> other)
      在这个 Property和另一个之间创建双向绑定。
      void FloatProperty.bindBidirectional​(Property<Number> other)
      在这个 Property和另一个之间创建双向绑定。
      void IntegerProperty.bindBidirectional​(Property<Number> other)
      在这个 Property之间创建一个双向绑定。
      void ListProperty.bindBidirectional​(Property<ObservableList<E>> other)
      在这个 Property和另一个之间创建双向绑定。
      void LongProperty.bindBidirectional​(Property<Number> other)
      在这个 Property和另一个之间创建双向绑定。
      void MapProperty.bindBidirectional​(Property<ObservableMap<K,V>> other)
      在这个 Property和另一个之间创建双向绑定。
      void ObjectProperty.bindBidirectional​(Property<T> other)
      在这个 Property和另一个之间创建双向绑定。
      void Property.bindBidirectional​(Property<T> other)
      在这个 Property和另一个之间创建双向绑定。
      void SetProperty.bindBidirectional​(Property<ObservableSet<E>> other)
      在这个 Property和另一个之间创建双向绑定。
      void StringProperty.bindBidirectional​(Property<?> other, Format format)
      在这个 StringProperty和另一个任意属性之间创建双向绑定。
      void StringProperty.bindBidirectional​(Property<String> other)
      在这个 Property和另一个之间创建双向绑定。
      <T> void StringProperty.bindBidirectional​(Property<T> other, StringConverter<T> converter)
      在这个 StringProperty和另一个任意属性之间创建双向绑定。
      static BooleanProperty BooleanProperty.booleanProperty​(Property<Boolean> property)
      返回一个BooleanProperty ，其中包含一个Property 。
      static DoubleProperty DoubleProperty.doubleProperty​(Property<Double> property)
      返回一个DoubleProperty ，它包装一个Property ，并且双向绑定到它。
      static FloatProperty FloatProperty.floatProperty​(Property<Float> property)
      返回一个FloatProperty ，它包裹一个Property并双向绑定到它。
      static IntegerProperty IntegerProperty.integerProperty​(Property<Integer> property)
      返回一个IntegerProperty ，其中包含一个Property并双向绑定到它。
      static LongProperty LongProperty.longProperty​(Property<Long> property)
      返回一个LongProperty ，它包装一个Property并双向绑定到它。
      void BooleanProperty.unbindBidirectional​(Property<Boolean> other)
      删除这个 Property和另一个之间的双向绑定。
      void DoubleProperty.unbindBidirectional​(Property<Number> other)
      删除此 Property和另一个之间的双向绑定。
      void FloatProperty.unbindBidirectional​(Property<Number> other)
      删除这个 Property和另一个之间的双向绑定。
      void IntegerProperty.unbindBidirectional​(Property<Number> other)
      删除此 Property和另一个之间的双向绑定。
      void ListProperty.unbindBidirectional​(Property<ObservableList<E>> other)
      删除这个 Property和另一个之间的双向绑定。
      void LongProperty.unbindBidirectional​(Property<Number> other)
      删除此 Property和另一个之间的双向绑定。
      void MapProperty.unbindBidirectional​(Property<ObservableMap<K,V>> other)
      删除这个 Property和另一个之间的双向绑定。
      void ObjectProperty.unbindBidirectional​(Property<T> other)
      删除这个 Property和另一个之间的双向绑定。
      void Property.unbindBidirectional​(Property<T> other)
      删除此 Property和另一个之间的双向绑定。
      void SetProperty.unbindBidirectional​(Property<ObservableSet<E>> other)
      删除这个 Property和另一个之间的双向绑定。
      void StringProperty.unbindBidirectional​(Property<String> other)
      删除此 Property和另一个之间的双向绑定。

    • Uses of Property in javafx.beans.property.adapter

      Subinterfaces of Property in javafx.beans.property.adapter
      Modifier and Type 接口 描述
      interface  JavaBeanProperty<T>
      JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
      Classes in javafx.beans.property.adapter that implement Property
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在 long或 Long之间的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
      class  JavaBeanStringProperty
      A JavaBeanStringProperty在类型为 String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。

    • Uses of Property in javafx.css

      Classes in javafx.css that implement Property
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      这个类扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      该课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableIntegerProperty
      该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的全面实现。
      class  SimpleStyleableLongProperty
      这个类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableObjectProperty<T>
      这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的全面实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.property.ReadOnlyProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.property.ReadOnlyProperty

  • Packages that use ReadOnlyProperty
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ReadOnlyProperty in javafx.beans.property

      Subinterfaces of ReadOnlyProperty in javafx.beans.property
      Modifier and Type 接口 描述
      interface  Property<T>
      通用接口，定义所有（可写）属性共有的方法，与其类型无关。
      Classes in javafx.beans.property that implement ReadOnlyProperty
      Modifier and Type Class 描述
      class  BooleanProperty
      这个类提供了一个包含 boolean值的Property的完整实现。
      class  BooleanPropertyBase
      类 BooleanPropertyBase是包含 boolean值的属性的基类。
      class  DoubleProperty
      这个类定义了一个Property包裹一个double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  FloatProperty
      这个类定义了一个27066718889657包装float值。
      class  FloatPropertyBase
      类 FloatPropertyBase是包含 float值的属性的基类。
      class  IntegerProperty
      这个类定义了一个Property包装int值。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含一个 int值的属性的基类。
      class  ListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  LongProperty
      这个类定义了一个Property包裹一个long值。
      class  LongPropertyBase
      类 LongPropertyBase是包含 long值的属性的基类。
      class  MapProperty<K,V>
      这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装一个ObservableMap的属性的基类。
      class  ObjectProperty<T>
      这个类提供了一个完全实现一个Property包装任意的Object 。
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyBooleanProperty
      超类为所有只读属性包装一个 boolean 。
      class  ReadOnlyBooleanPropertyBase
      所有只读属性的基类包装一个 boolean 。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyDoubleProperty
      超类为所有只读属性包装一个 double 。
      class  ReadOnlyDoublePropertyBase
      所有只读属性的基类包装一个 double 。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyFloatProperty
      超类为所有只读属性包装一个 float 。
      class  ReadOnlyFloatPropertyBase
      所有只读属性的基类包装一个 float 。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyIntegerProperty
      超类为所有只读属性包装一个 int 。
      class  ReadOnlyIntegerPropertyBase
      所有只读属性的基类包装一个 int 。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyListProperty<E>
      超类为所有只读属性包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyLongProperty
      超类为所有只读属性包装一个 long 。
      class  ReadOnlyLongPropertyBase
      所有只读属性的基类包装一个 long 。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyMapProperty<K,V>
      超类为所有只读属性包装一个ObservableMap 。
      class  ReadOnlyMapPropertyBase<K,V>
      所有只读属性的基类包装一个ObservableMap 。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyObjectProperty<T>
      超类为所有只读属性包装任意 Object 。
      class  ReadOnlyObjectPropertyBase<T>
      所有只读属性的基类包装任意 Object 。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlySetProperty<E>
      所有readonly属性的超类包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyStringProperty
      超类为所有只读属性包装一个 String 。
      class  ReadOnlyStringPropertyBase
      所有只读属性的基类包装一个 String 。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleBooleanProperty
      这个类提供了一个包含 boolean值的Property的完整实现。
      class  SimpleDoubleProperty
      这个类提供了一个Property包装一个double值的完整实现。
      class  SimpleFloatProperty
      这个类提供了一个包含 float值的Property的完整实现。
      class  SimpleIntegerProperty
      该类提供了一个包含 int值的Property的全面实现。
      class  SimpleListProperty<E>
      这个类提供了一个Property包装一个ObservableList的完整实现。
      class  SimpleLongProperty
      该类提供了一个包含 long值的Property的完整实现。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
      class  SimpleObjectProperty<T>
      这个类提供了一个Property的完整实现，包装了一个任意的Object 。
      class  SimpleSetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
      class  SimpleStringProperty
      新新新新新新新新新新旗新新 String
      class  StringProperty
      200新 String
      class  StringPropertyBase
      新新新新新新 StringPropertyBase String
      Methods in javafx.beans.property with parameters of type ReadOnlyProperty
      Modifier and Type 方法 描述
      static ReadOnlyBooleanProperty ReadOnlyBooleanProperty.readOnlyBooleanProperty​(ReadOnlyProperty<Boolean> property)
      返回一个ReadOnlyBooleanProperty ，其中包含一个ReadOnlyProperty 。
      static <T extends Number>
      ReadOnlyDoubleProperty             		ReadOnlyDoubleProperty.readOnlyDoubleProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyDoubleProperty ，其中包含一个ReadOnlyProperty 。
      static <T extends Number>
      ReadOnlyFloatProperty             		ReadOnlyFloatProperty.readOnlyFloatProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyFloatProperty ，其中包含一个ReadOnlyProperty 。
      static <T extends Number>
      ReadOnlyIntegerProperty             		ReadOnlyIntegerProperty.readOnlyIntegerProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyIntegerProperty ，其中包含一个ReadOnlyProperty 。
      static <T extends Number>
      ReadOnlyLongProperty             		ReadOnlyLongProperty.readOnlyLongProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyLongProperty ，其中包含一个ReadOnlyProperty 。

    • Uses of ReadOnlyProperty in javafx.beans.property.adapter

      Subinterfaces of ReadOnlyProperty in javafx.beans.property.adapter
      Modifier and Type 接口 描述
      interface  JavaBeanProperty<T>
      JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
      interface  ReadOnlyJavaBeanProperty<T>
      JavaBeanProperty是只读Java Bean属性和JavaFX属性之间的所有适配器的超级界面。
      Classes in javafx.beans.property.adapter that implement ReadOnlyProperty
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在类型为 double或 Double的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
      class  JavaBeanStringProperty
      一个 JavaBeanStringProperty提供类型的普通的Java Bean属性之间的适配器 String和一个JavaFX StringProperty 。
      class  ReadOnlyJavaBeanBooleanProperty
      A ReadOnlyJavaBeanBooleanProperty在类型为 boolean或 Boolean的常规只读Java Bean属性和JavaFX ReadOnlyBooleanProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在类型为 double或 Double的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty之间提供了适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在类型为 float或 Float的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在常规的只读Java Bean属性类型为 int或 Integer和JavaFX ReadOnlyIntegerProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在 long或 Long之间的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty提供了一个适配器。
      class  ReadOnlyJavaBeanObjectProperty<T>
      A ReadOnlyJavaBeanObjectProperty提供了常规的只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间的适配器。
      class  ReadOnlyJavaBeanStringProperty
      A ReadOnlyJavaBeanStringProperty在常规的只读Java Bean属性类型为 String和JavaFX ReadOnlyStringProperty之间提供了一个适配器。

    • Uses of ReadOnlyProperty in javafx.css

      Classes in javafx.css that implement ReadOnlyProperty
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      该课程扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableDoubleProperty
      这个类扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      该课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableIntegerProperty
      这个课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableLongProperty
      这个类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableObjectProperty<T>
      这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableStringProperty
      这个类扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ChangeListener<T>

  • 所有已知实现类：
    WeakChangeListener
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ChangeListener<T>
    甲ChangeListener通知每当的值ObservableValue种变化。 可以注册和注销ObservableValue.addListener(ChangeListener)分别为ObservableValue.removeListener(ChangeListener)

    有关更改事件的详细说明及其与无效事件的区别，请参阅ObservableValue的文档。

    ChangeListener的同一个实例可以注册多个ObservableValues 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void changed​(ObservableValue<? extends T> observable, T oldValue, T newValue)
      该方法需要通过 ChangeListener的实现来提供。

    • 方法详细信息

      • changed

        void changed​(ObservableValue<? extends T> observable,
             T oldValue,
             T newValue)
        该方法需要由ChangeListener的实现提供。 如果一个ObservableValue的值发生变化，则调用它。

        一般认为在这种方法中修改观察值的不良做法。

        参数
        observable - 该值改变了 ObservableValue
        oldValue - 旧的价值
        newValue - 新的价值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.beans.value (Java SE 9 & JDK 9 )

javafx.beans.value

Interfaces

  • ChangeListener
  • ObservableBooleanValue
  • ObservableDoubleValue
  • ObservableFloatValue
  • ObservableIntegerValue
  • ObservableListValue
  • ObservableLongValue
  • ObservableMapValue
  • ObservableNumberValue
  • ObservableObjectValue
  • ObservableSetValue
  • ObservableStringValue
  • ObservableValue
  • WritableBooleanValue
  • WritableDoubleValue
  • WritableFloatValue
  • WritableIntegerValue
  • WritableListValue
  • WritableLongValue
  • WritableMapValue
  • WritableNumberValue
  • WritableObjectValue
  • WritableSetValue
  • WritableStringValue
  • WritableValue

Classes

  • ObservableValueBase
  • WeakChangeListener


javafx.beans.value (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.beans.value

包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。

ObservableValue

一个ObservableValue包装一个值，可以读取和观察到无效和更改。 听众必须实现InvalidationListener或ChangeListener 。 为了允许直接使用原始类型，定义了许多子接口。 ObservableValue Table Type Sub-interface of ObservableValue boolean ObservableBooleanValue double ObservableDoubleValue float ObservableFloatValue int ObservableIntegerValue long ObservableLongValue double, float, int, long ObservableNumberValue Object ObservableObjectValue String ObservableStringValue

一个WritableValue

WritableValue包装一个可以读取和设置的值。 与ObservableValues ，定义了多个子接口直接与原始类型一起工作。 WritableValue Table Type Sub-interface of WritableValue boolean WritableBooleanValue double WritableDoubleValue float WritableFloatValue int WritableIntegerValue long WritableLongValue double, float, int, long WritableNumberValue Object WritableObjectValue String WritableStringValue
  • 接口摘要
    接口 描述
    ChangeListener<T>
    ChangeListener的值发生变化，通知ChangeListener 。
    ObservableBooleanValue
    一个可观察的布尔值。
    ObservableDoubleValue
    一个可观察到的双重值。
    ObservableFloatValue
    一个可观察的浮点值。
    ObservableIntegerValue
    一个可观察的整数值。
    ObservableListValue<E>
    一个可观察的参考一个ObservableList 。
    ObservableLongValue
    一个可观察的长期价值。
    ObservableMapValue<K,V>
    可以参考一个ObservableMap 。
    ObservableNumberValue
    所有子接口的公共接口为ObservableValue ，其中包含一个数字。
    ObservableObjectValue<T>
    一个可观察的类型的 Object值。
    ObservableSetValue<E>
    可以参考一个ObservableSet 。
    ObservableStringValue
    一个可观察的字符串值。
    ObservableValue<T>
    一个 ObservableValue是一个包含值并允许观察变化值的实体。
    WritableBooleanValue
    一个可写布尔值。
    WritableDoubleValue
    一个可写的双重值。
    WritableFloatValue
    可写浮点值。
    WritableIntegerValue
    一个可写的int值。
    WritableListValue<E>
    对ObservableList的可写参考。
    WritableLongValue
    一个可写的长期价值。
    WritableMapValue<K,V>
    对ObservableMap的可写参考。
    WritableNumberValue
    标记接口，标记包含数字的所有子接口WritableValue 。
    WritableObjectValue<T>
    可写类型值。
    WritableSetValue<E>
    一个可写的参考ObservableSet 。
    WritableStringValue
    一个可写的字符串。
    WritableValue<T>
    A WritableValue是一个包含可读取和设置的值的实体。
  • 类摘要
    Class 描述
    ObservableValueBase<T>
    用于创建ObservableValue的实现的方便类。
    WeakChangeListener<T>
    A WeakChangeListener可以使用，如果一个ObservableValue应该只保留对该监听器的弱引用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.beans.value Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.beans.value

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.beans.value.ObservableValueBase<T> (implements javafx.beans.value.ObservableValue<T>)
    • javafx.beans.value.WeakChangeListener<T> (implements javafx.beans.value.ChangeListener<T>, javafx.beans.WeakListener)

Interface Hierarchy

  • javafx.beans.value.ChangeListener<T>
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
        • javafx.collections.ObservableList<E> (also extends javafx.beans.Observable)
          • javafx.beans.value.ObservableListValue<E> (also extends javafx.beans.value.ObservableObjectValue<T>)
          • javafx.beans.value.WritableListValue<E> (also extends javafx.beans.value.WritableObjectValue<T>)
      • java.util.Set<E>
        • javafx.collections.ObservableSet<E> (also extends javafx.beans.Observable)
          • javafx.beans.value.ObservableSetValue<E> (also extends javafx.beans.value.ObservableObjectValue<T>)
          • javafx.beans.value.WritableSetValue<E> (also extends javafx.beans.value.WritableObjectValue<T>)
  • java.util.Map<K,V>
    • javafx.collections.ObservableMap<K,V> (also extends javafx.beans.Observable)
      • javafx.beans.value.ObservableMapValue<K,V> (also extends javafx.beans.value.ObservableObjectValue<T>)
      • javafx.beans.value.WritableMapValue<K,V> (also extends javafx.beans.value.WritableObjectValue<T>)
  • javafx.beans.Observable
    • javafx.collections.ObservableList<E> (also extends java.util.List<E>)
      • javafx.beans.value.ObservableListValue<E> (also extends javafx.beans.value.ObservableObjectValue<T>)
      • javafx.beans.value.WritableListValue<E> (also extends javafx.beans.value.WritableObjectValue<T>)
    • javafx.collections.ObservableMap<K,V> (also extends java.util.Map<K,V>)
      • javafx.beans.value.ObservableMapValue<K,V> (also extends javafx.beans.value.ObservableObjectValue<T>)
      • javafx.beans.value.WritableMapValue<K,V> (also extends javafx.beans.value.WritableObjectValue<T>)
    • javafx.collections.ObservableSet<E> (also extends java.util.Set<E>)
      • javafx.beans.value.ObservableSetValue<E> (also extends javafx.beans.value.ObservableObjectValue<T>)
      • javafx.beans.value.WritableSetValue<E> (also extends javafx.beans.value.WritableObjectValue<T>)
    • javafx.beans.value.ObservableValue<T>
      • javafx.beans.value.ObservableBooleanValue
      • javafx.beans.value.ObservableNumberValue
        • javafx.beans.value.ObservableDoubleValue
        • javafx.beans.value.ObservableFloatValue
        • javafx.beans.value.ObservableIntegerValue
        • javafx.beans.value.ObservableLongValue
      • javafx.beans.value.ObservableObjectValue<T>
        • javafx.beans.value.ObservableListValue<E> (also extends javafx.collections.ObservableList<E>)
        • javafx.beans.value.ObservableMapValue<K,V> (also extends javafx.collections.ObservableMap<K,V>)
        • javafx.beans.value.ObservableSetValue<E> (also extends javafx.collections.ObservableSet<E>)
        • javafx.beans.value.ObservableStringValue
  • javafx.beans.value.WritableValue<T>
    • javafx.beans.value.WritableBooleanValue
    • javafx.beans.value.WritableNumberValue
      • javafx.beans.value.WritableDoubleValue
      • javafx.beans.value.WritableFloatValue
      • javafx.beans.value.WritableIntegerValue
      • javafx.beans.value.WritableLongValue
    • javafx.beans.value.WritableObjectValue<T>
      • javafx.beans.value.WritableListValue<E> (also extends javafx.collections.ObservableList<E>)
      • javafx.beans.value.WritableMapValue<K,V> (also extends javafx.collections.ObservableMap<K,V>)
      • javafx.beans.value.WritableSetValue<E> (also extends javafx.collections.ObservableSet<E>)
      • javafx.beans.value.WritableStringValue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ObservableBooleanValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableBooleanValue

  • All Superinterfaces:
    Observable ， ObservableValue<Boolean>
    所有已知实现类：
    BooleanBinding ， BooleanExpression ， BooleanProperty ， BooleanPropertyBase ， JavaBeanBooleanProperty ， ReadOnlyBooleanProperty ， ReadOnlyBooleanPropertyBase ， ReadOnlyBooleanWrapper ， ReadOnlyJavaBeanBooleanProperty ， SimpleBooleanProperty ， SimpleStyleableBooleanProperty ， StyleableBooleanProperty

    public interface ObservableBooleanValue
extends ObservableValue<Boolean>
    一个可观察的布尔值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean get​()
      返回此 ObservableBooleanValue的当前值。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • get

        boolean get​()
        返回此 ObservableBooleanValue的当前值。
        结果
        当前值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableDoubleValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableDoubleValue

  • All Superinterfaces:
    Observable ， ObservableNumberValue ， ObservableValue<Number>
    所有已知实现类：
    DoubleBinding ， DoubleExpression ， DoubleProperty ， DoublePropertyBase ， JavaBeanDoubleProperty ， ReadOnlyDoubleProperty ， ReadOnlyDoublePropertyBase ， ReadOnlyDoubleWrapper ， ReadOnlyJavaBeanDoubleProperty ， SimpleDoubleProperty ， SimpleStyleableDoubleProperty ， StyleableDoubleProperty

    public interface ObservableDoubleValue
extends ObservableNumberValue
    一个可观察到的双重值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableValue ， ObservableNumberValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      double get​()
      返回此 ObservableDoubleValue的当前值。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • get

        double get​()
        返回此 ObservableDoubleValue的当前值。
        结果
        当前值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableFloatValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableFloatValue

  • All Superinterfaces:
    Observable ， ObservableNumberValue ， ObservableValue<Number>
    所有已知实现类：
    FloatBinding ， FloatExpression ， FloatProperty ， FloatPropertyBase ， JavaBeanFloatProperty ， ReadOnlyFloatProperty ， ReadOnlyFloatPropertyBase ， ReadOnlyFloatWrapper ， ReadOnlyJavaBeanFloatProperty ， SimpleFloatProperty ， SimpleStyleableFloatProperty ， StyleableFloatProperty

    public interface ObservableFloatValue
extends ObservableNumberValue
    一个可观察的浮点值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableValue ， ObservableNumberValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      float get​()
      返回此 ObservableFloatValue的当前值。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • get

        float get​()
        返回此 ObservableFloatValue的当前值。
        结果
        当前值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableIntegerValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableIntegerValue

  • All Superinterfaces:
    Observable ， ObservableNumberValue ， ObservableValue<Number>
    所有已知实现类：
    IntegerBinding ， IntegerExpression ， IntegerProperty ， IntegerPropertyBase ， JavaBeanIntegerProperty ， ReadOnlyIntegerProperty ， ReadOnlyIntegerPropertyBase ， ReadOnlyIntegerWrapper ， ReadOnlyJavaBeanIntegerProperty ， SimpleIntegerProperty ， SimpleStyleableIntegerProperty ， StyleableIntegerProperty

    public interface ObservableIntegerValue
extends ObservableNumberValue
    一个可观察的整数值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableValue ， ObservableNumberValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int get​()
      返回此 ObservableIntegerValue的当前值。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • get

        int get​()
        返回此 ObservableIntegerValue的当前值。
        结果
        当前值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableListValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableListValue<E>

  • 参数类型
    E - List元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E> ， List<E> ， Observable ， ObservableList<E> ， ObservableObjectValue<ObservableList<E>> ， ObservableValue<E>
    所有已知实现类：
    ListBinding ， ListExpression ， ListProperty ， ListPropertyBase ， ReadOnlyListProperty ， ReadOnlyListPropertyBase ， ReadOnlyListWrapper ， SimpleListProperty

    public interface ObservableListValue<E>
extends ObservableObjectValue<ObservableList<E>>, ObservableList<E>
    一个可观察的参考，一个ObservableList 。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableList ， ObservableObjectValue ， ObservableValue

    • 方法摘要

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, size, sort, spliterator, subList, toArray, toArray

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableList

        addAll, addListener, filtered, remove, removeAll, removeListener, retainAll, setAll, setAll, sorted, sorted

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableLongValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableLongValue

  • All Superinterfaces:
    Observable ， ObservableNumberValue ， ObservableValue<Number>
    所有已知实现类：
    JavaBeanLongProperty ， LongBinding ， LongExpression ， LongProperty ， LongPropertyBase ， ReadOnlyJavaBeanLongProperty ， ReadOnlyLongProperty ， ReadOnlyLongPropertyBase ， ReadOnlyLongWrapper ， SimpleLongProperty ， SimpleStyleableLongProperty ， StyleableLongProperty

    public interface ObservableLongValue
extends ObservableNumberValue
    一个可观察的长期价值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableValue ， ObservableNumberValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long get​()
      返回此 ObservableLongValue的当前值。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableNumberValue

        doubleValue, floatValue, intValue, longValue

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • get

        long get​()
        返回此 ObservableLongValue的当前值。
        结果
        当前值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableMapValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableMapValue<K,V>

  • 参数类型
    K - K的关键元素的 Map
    V - V的值元素的 Map
    All Superinterfaces:
    Map<K,V> ， Observable ， ObservableMap<K,V> ， ObservableObjectValue<ObservableMap<K,V>> ， ObservableValue<K>
    所有已知实现类：
    MapBinding ， MapExpression ， MapProperty ， MapPropertyBase ， ReadOnlyMapProperty ， ReadOnlyMapPropertyBase ， ReadOnlyMapWrapper ， SimpleMapProperty

    public interface ObservableMapValue<K,V>
extends ObservableObjectValue<ObservableMap<K,V>>, ObservableMap<K,V>
    可以参考一个ObservableMap 。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableMap, ObservableObjectValue, ObservableValue

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 方法摘要

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entry, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableMap

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableNumberValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableNumberValue

  • All Superinterfaces:
    Observable ， ObservableValue<Number>
    All Known Subinterfaces:
    NumberBinding ， NumberExpression ， ObservableDoubleValue ， ObservableFloatValue ， ObservableIntegerValue ， ObservableLongValue
    所有已知实现类：
    DoubleBinding ， DoubleExpression ， DoubleProperty ， DoublePropertyBase ， FloatBinding ， FloatExpression ， FloatProperty ， FloatPropertyBase ， IntegerBinding ， IntegerExpression ， IntegerProperty ， IntegerPropertyBase ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， LongBinding ， LongExpression ， LongProperty ， LongPropertyBase ， NumberExpressionBase ， ReadOnlyDoubleProperty ， ReadOnlyDoublePropertyBase ， ReadOnlyDoubleWrapper ， ReadOnlyFloatProperty ， ReadOnlyFloatPropertyBase ， ReadOnlyFloatWrapper ， ReadOnlyIntegerProperty ， ReadOnlyIntegerPropertyBase ， ReadOnlyIntegerWrapper ， ReadOnlyJavaBeanDoubleProperty ， ReadOnlyJavaBeanFloatProperty ， ReadOnlyJavaBeanIntegerProperty ， ReadOnlyJavaBeanLongProperty ， ReadOnlyLongProperty ， ReadOnlyLongPropertyBase ， ReadOnlyLongWrapper ， SimpleDoubleProperty ， SimpleFloatProperty ， SimpleIntegerProperty ， SimpleLongProperty ， SimpleStyleableDoubleProperty ， SimpleStyleableFloatProperty ， SimpleStyleableIntegerProperty ， SimpleStyleableLongProperty ， StyleableDoubleProperty ， StyleableFloatProperty ， StyleableIntegerProperty ， StyleableLongProperty

    public interface ObservableNumberValue
extends ObservableValue<Number>
    所有子接口的公共接口为ObservableValue ，其中包含一个数字。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableValue ， ObservableDoubleValue ， ObservableFloatValue ， ObservableIntegerValue ， ObservableLongValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      double doubleValue​()
      返回 ObservableNumberValue的值作为 double 。
      float floatValue​()
      返回 ObservableNumberValue的值作为 float 。
      int intValue​()
      将 ObservableNumberValue的值作为 int 。
      long longValue​()
      将 ObservableNumberValue的值作为 long 。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • intValue

        int intValue​()
        返回ObservableNumberValue的值作为int 。 如果该值不是int ，则执行标准转换。
        结果
        该值 ObservableNumberValue为 int

      • longValue

        long longValue​()
        返回ObservableNumberValue的值作为long 。 如果该值不是long ，则执行标准转换。
        结果
        该值 ObservableNumberValue为 long

      • floatValue

        float floatValue​()
        将ObservableNumberValue的值作为float 。 如果值不是float ，则执行标准转换。
        结果
        该值 ObservableNumberValue为 float

      • doubleValue

        double doubleValue​()
        将ObservableNumberValue的值作为double 。 如果该值不是double ，则执行标准转换。
        结果
        该值 ObservableNumberValue为 double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableObjectValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableObjectValue<T>

  • All Superinterfaces:
    Observable ， ObservableValue<T>
    All Known Subinterfaces:
    ObservableListValue<E> ， ObservableMapValue<K,V> ， ObservableSetValue<E> ， ObservableStringValue ， TextInputControl.Content
    所有已知实现类：
    JavaBeanObjectProperty ， JavaBeanStringProperty ， ListBinding ， ListExpression ， ListProperty ， ListPropertyBase ， MapBinding ， MapExpression ， MapProperty ， MapPropertyBase ， ObjectBinding ， ObjectExpression ， ObjectProperty ， ObjectPropertyBase ， ReadOnlyJavaBeanObjectProperty ， ReadOnlyJavaBeanStringProperty ， ReadOnlyListProperty ， ReadOnlyListPropertyBase ， ReadOnlyListWrapper ， ReadOnlyMapProperty ， ReadOnlyMapPropertyBase ， ReadOnlyMapWrapper ， ReadOnlyObjectProperty ， ReadOnlyObjectPropertyBase ， ReadOnlyObjectWrapper ， ReadOnlySetProperty ， ReadOnlySetPropertyBase ， ReadOnlySetWrapper ， ReadOnlyStringProperty ， ReadOnlyStringPropertyBase ， ReadOnlyStringWrapper ， SetBinding ， SetExpression ， SetProperty ， SetPropertyBase ， SimpleListProperty ， SimpleMapProperty ， SimpleObjectProperty ， SimpleSetProperty ， SimpleStringProperty ， SimpleStyleableObjectProperty ， SimpleStyleableStringProperty ， StringBinding ， StringExpression ， StringProperty ， StringPropertyBase ， StyleableObjectProperty ， StyleableStringProperty

    public interface ObservableObjectValue<T>
extends ObservableValue<T>
    一个可观察的类型的 Object值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      T get​()
      返回此 ObservableObjectValue<T>的当前值。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • get

        T get​()
        返回此 ObservableObjectValue<T>的当前值。
        结果
        当前值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableSetValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableSetValue<E>

  • 参数类型
    E - Set元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E> ， Observable ， ObservableObjectValue<ObservableSet<E>> ， ObservableSet<E> ， ObservableValue<E> ， Set<E>
    所有已知实现类：
    ReadOnlySetProperty ， ReadOnlySetPropertyBase ， ReadOnlySetWrapper ， SetBinding ， SetExpression ， SetProperty ， SetPropertyBase ， SimpleSetProperty

    public interface ObservableSetValue<E>
extends ObservableObjectValue<ObservableSet<E>>, ObservableSet<E>
    可以参考一个ObservableSet 。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableSet ， ObservableObjectValue ， ObservableValue

    • 方法摘要

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.collections.ObservableSet

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, spliterator, toArray, toArray
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableStringValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableStringValue

  • All Superinterfaces:
    Observable ， ObservableObjectValue<String> ， ObservableValue<String>
    All Known Subinterfaces:
    TextInputControl.Content
    所有已知实现类：
    JavaBeanStringProperty ， ReadOnlyJavaBeanStringProperty ， ReadOnlyStringProperty ， ReadOnlyStringPropertyBase ， ReadOnlyStringWrapper ， SimpleStringProperty ， SimpleStyleableStringProperty ， StringBinding ， StringExpression ， StringProperty ， StringPropertyBase ， StyleableStringProperty

    public interface ObservableStringValue
extends ObservableObjectValue<String>
    一个可观察的字符串值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableObjectValue ， ObservableValue

    • 方法摘要

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface ObservableValue<T>

  • 参数类型
    T - 包装值的类型。
    All Superinterfaces:
    Observable
    All Known Subinterfaces:
    Binding<T> ， JavaBeanProperty<T> ， NumberBinding ， NumberExpression ， ObservableBooleanValue ， ObservableDoubleValue ， ObservableFloatValue ， ObservableIntegerValue ， ObservableListValue<E> ， ObservableLongValue ， ObservableMapValue<K,V> ， ObservableNumberValue ， ObservableObjectValue<T> ， ObservableSetValue<E> ， ObservableStringValue ， Property<T> ， ReadOnlyJavaBeanProperty<T> ， ReadOnlyProperty<T> ， TextInputControl.Content
    所有已知实现类：
    BooleanBinding ， BooleanExpression ， BooleanProperty ， BooleanPropertyBase ， DoubleBinding ， DoubleExpression ， DoubleProperty ， DoublePropertyBase ， FloatBinding ， FloatExpression ， FloatProperty ， FloatPropertyBase ， IntegerBinding ， IntegerExpression ， IntegerProperty ， IntegerPropertyBase ， JavaBeanBooleanProperty ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， JavaBeanObjectProperty ， JavaBeanStringProperty ， ListBinding ， ListExpression ， ListProperty ， ListPropertyBase ， LongBinding ， LongExpression ， LongProperty ， LongPropertyBase ， MapBinding ， MapExpression ， MapProperty ， MapPropertyBase ， NumberExpressionBase ， ObjectBinding ， ObjectExpression ， ObjectProperty ， ObjectPropertyBase ， ObservableValueBase ， ReadOnlyBooleanProperty ， ReadOnlyBooleanPropertyBase ， ReadOnlyBooleanWrapper ， ReadOnlyDoubleProperty ， ReadOnlyDoublePropertyBase ， ReadOnlyDoubleWrapper ， ReadOnlyFloatProperty ， ReadOnlyFloatPropertyBase ， ReadOnlyFloatWrapper ， ReadOnlyIntegerProperty ， ReadOnlyIntegerPropertyBase ， ReadOnlyIntegerWrapper ， ReadOnlyJavaBeanBooleanProperty ， ReadOnlyJavaBeanDoubleProperty ， ReadOnlyJavaBeanFloatProperty ReadOnlyJavaBeanFloatProperty ， ReadOnlyJavaBeanIntegerProperty ， ReadOnlyJavaBeanLongProperty ， ReadOnlyJavaBeanObjectProperty ， ReadOnlyJavaBeanStringProperty ， ReadOnlyListProperty ， ReadOnlyListPropertyBase ， ReadOnlyListWrapper ， ReadOnlyLongProperty ， ReadOnlyLongPropertyBase ， ReadOnlyLongWrapper ， ReadOnlyMapProperty ， ReadOnlyMapPropertyBase ， ReadOnlyMapWrapper ， ReadOnlyObjectProperty ， ReadOnlyObjectPropertyBase ， ReadOnlyObjectWrapper ， ReadOnlySetProperty ， ReadOnlySetPropertyBase ， ReadOnlySetWrapper ， ReadOnlyStringProperty ， ReadOnlyStringPropertyBase ， ReadOnlyStringWrapper ， SetBinding ， SetExpression ， SetProperty ， SetPropertyBase ， SimpleBooleanProperty ， SimpleDoubleProperty ， SimpleFloatProperty ， SimpleIntegerProperty ， SimpleListProperty ， SimpleLongProperty ， SimpleMapProperty ， SimpleObjectProperty ， SimpleSetProperty ， SimpleStringProperty ， SimpleStyleableBooleanProperty ， SimpleStyleableDoubleProperty ， SimpleStyleableFloatProperty ， SimpleStyleableIntegerProperty ， SimpleStyleableLongProperty ， SimpleStyleableObjectProperty ， SimpleStyleableStringProperty ， StringBinding ， StringExpression ， StringProperty ， StringPropertyBase ， StyleableBooleanProperty ， StyleableDoubleProperty ， StyleableFloatProperty ， StyleableIntegerProperty ， StyleableLongProperty ， StyleableObjectProperty ， StyleableStringProperty

    public interface ObservableValue<T>
extends Observable
    一个ObservableValue是一个包含值并允许观察变化值的实体。 通常这个接口不应该直接实现，而是其子接口之一（ ObservableBooleanValue等）。

    该值ObservableValue可以要求与getValue() 。

    ObservableValue的实现可能支持懒惰评估，这意味着值不会在更改后立即重新计算，而是在下次请求值时懒惰。 此库中的所有绑定和属性都支持懒惰评估。

    一个ObservableValue生成两种类型的事件：更改事件和无效事件。 更改事件表示该值已更改。 如果当前值不再有效，则生成无效事件。 这个区别是重要的，如果ObservableValue支持懒惰评估，因为对于一个懒惰的评估值，一个人不知道一个无效值是否真的改变，直到它被重新计算。 因此，生成更改事件需要热切的评估，同时可以为渴望和懒惰的实现生成无效化事件。

    该类的实现应该尽可能地生成尽可能少的事件，以避免在事件处理程序中浪费太多时间。 当第一个无效事件发生时，此库中的实现将自身标记为无效。 它们在重新计算并重新生效之前不再生成无效事件。

    两种类型的监听器可以附加到ObservableValue ： InvalidationListener以收听无效事件和ChangeListener来监听更改事件。

    重要提示：附加一个ChangeListener强制计算即使执行ObservableValue支持懒惰评估。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ObservableBooleanValue ， ObservableDoubleValue ， ObservableFloatValue ， ObservableIntegerValue ， ObservableLongValue ， ObservableNumberValue ， ObservableObjectValue ， ObservableStringValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addListener​(ChangeListener<? super T> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      T getValue​()
      返回此 ObservableValue的当前值
      void removeListener​(ChangeListener<? super T> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

    • 方法详细信息

      • addListener

        void addListener​(ChangeListener<? super T> listener)
        添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可能会安全注册为不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或使用WeakChangeListener的实例避免此情况。

        参数
        listener - listener注册
        异常
        NullPointerException - 如果侦听器为空
        另请参见：
        removeListener(ChangeListener)

      • removeListener

        void removeListener​(ChangeListener<? super T> listener)
        从监听器列表中删除给定的监听器，当ObservableValue的值发生更改时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        参数
        listener - 要删除的侦听器
        异常
        NullPointerException - 如果侦听器为空
        另请参见：
        addListener(ChangeListener)

      • getValue

        T getValue​()
        返回此 ObservableValue的当前值
        结果
        当前值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableValueBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Class ObservableValueBase<T>

  • java.lang.Object
    • javafx.beans.value.ObservableValueBase<T>
  • All Implemented Interfaces:
    Observable ， ObservableValue<T>

    public abstract class ObservableValueBase<T>
extends Object
implements ObservableValue<T>
    创建ObservableValue的实现方便类。 它包含对价值无效和更改事件通知的所有基础架构支持。 该实现可以在观察者被通知时处理添加和删除侦听器，但不是线程安全的。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObservableValueBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ChangeListener<? super T> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      protected void fireValueChangedEvent​()
      通知目前注册的观察员的价值变动。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ChangeListener<? super T> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

    • 构造方法详细信息

      • ObservableValueBase

        public ObservableValueBase​()

    • 方法详细信息

      • addListener

        public void addListener​(InvalidationListener listener)
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener取消注册监听器，或者使用WeakInvalidationListener的实例避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • addListener

        public void addListener​(ChangeListener<? super T> listener)
        添加一个ChangeListener ，当ObservableValue的值发生变化时，将通知它。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际ChangeListener实例可以安全地注册到不同的ObservableValues 。

        ObservableValue存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或使用WeakChangeListener的实例避免此情况。

        Specified by:
        addListener在接口 ObservableValue<T>
        参数
        listener - listener注册
        另请参见：
        ObservableValue.removeListener(ChangeListener)

      • removeListener

        public void removeListener​(InvalidationListener listener)
        从监听器列表中删除给定的监听器，当Observable的值变为无效时，它们将被通知。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • removeListener

        public void removeListener​(ChangeListener<? super T> listener)
        从监听器列表中删除给定的监听器，每当ObservableValue的值发生变化时通知ObservableValue 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 ObservableValue<T>
        参数
        listener - 要删除的侦听器
        另请参见：
        ObservableValue.addListener(ChangeListener)

      • fireValueChangedEvent

        protected void fireValueChangedEvent​()
        Notify the currently registered observers of a value change. This implementation will ignore all adds and removes of observers that are done while a notification is processed. The changes take effect in the following call to fireValueChangedEvent.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.beans.value (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.beans.value

  • Packages that use javafx.beans.value
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
  • Classes in javafx.beans.value used by javafx.animation
    Class 描述
    WritableValue
    A WritableValue是一个包含可以读取和设置的值的实体。
  • Classes in javafx.beans.value used by javafx.beans.binding
    Class 描述
    ChangeListener
    甲ChangeListener通知每当的值ObservableValue种变化。
    ObservableBooleanValue
    一个可观察的布尔值。
    ObservableDoubleValue
    一个可观察到的双重值。
    ObservableFloatValue
    一个可观察的浮点值。
    ObservableIntegerValue
    一个可观察的整数值。
    ObservableListValue
    可以参考一个ObservableList 。
    ObservableLongValue
    一个可观察的长期价值。
    ObservableMapValue
    可以参考一个ObservableMap 。
    ObservableNumberValue
    一个ObservableValue的所有子接口的公共接口包装一个数字。
    ObservableObjectValue
    一个可观察的类型 Object价值。
    ObservableSetValue
    可以参考一个ObservableSet 。
    ObservableStringValue
    一个可观察的字符串值。
    ObservableValue
    一个 ObservableValue是一个包含值并允许观察变化值的实体。
  • Classes in javafx.beans.value used by javafx.beans.property
    Class 描述
    ChangeListener
    甲ChangeListener通知每当的值ObservableValue种变化。
    ObservableBooleanValue
    一个可观察的布尔值。
    ObservableDoubleValue
    一个可观察到的双重值。
    ObservableFloatValue
    一个可观察的浮点值。
    ObservableIntegerValue
    一个可观察的整数值。
    ObservableListValue
    可以参考一个ObservableList 。
    ObservableLongValue
    一个可观察的长期价值。
    ObservableMapValue
    可以参考一个ObservableMap 。
    ObservableNumberValue
    所有子接口的公共接口为ObservableValue ，其中包含一个数字。
    ObservableObjectValue
    一个可观察到的类型的 Object值。
    ObservableSetValue
    可以参考一个ObservableSet 。
    ObservableStringValue
    一个可观察的字符串值。
    ObservableValue
    一个 ObservableValue是一个包装一个值并允许观察变化值的实体。
    WritableBooleanValue
    一个可写布尔值。
    WritableDoubleValue
    一个可写的双重值。
    WritableFloatValue
    可写浮点值。
    WritableIntegerValue
    一个可写的int值。
    WritableListValue
    可写参考一个ObservableList 。
    WritableLongValue
    一个可写的长期价值。
    WritableMapValue
    可写参考一个ObservableMap 。
    WritableNumberValue
    标记接口，标记包含数字的所有子接口WritableValue 。
    WritableObjectValue
    可写类型值。
    WritableSetValue
    可写参考一个ObservableSet 。
    WritableStringValue
    一个可写的字符串。
    WritableValue
    A WritableValue是一个包含可以读取和设置的值的实体。
  • Classes in javafx.beans.value used by javafx.beans.property.adapter
    Class 描述
    ChangeListener
    甲ChangeListener通知每当的值ObservableValue种变化。
    ObservableBooleanValue
    一个可观察的布尔值。
    ObservableDoubleValue
    一个可观察到的双重值。
    ObservableFloatValue
    一个可观察的浮点值。
    ObservableIntegerValue
    一个可观察的整数值。
    ObservableLongValue
    一个可观察的长期价值。
    ObservableNumberValue
    所有子接口的公共接口ObservableValue包裹一个数字。
    ObservableObjectValue
    一个可观察的类型 Object价值。
    ObservableStringValue
    一个可观察的字符串值。
    ObservableValue
    一个 ObservableValue是一个包含值并允许观察变化值的实体。
    WritableBooleanValue
    一个可写布尔值。
    WritableDoubleValue
    一个可写的双重值。
    WritableFloatValue
    可写浮点值。
    WritableIntegerValue
    一个可写的int值。
    WritableLongValue
    一个可写的长期价值。
    WritableNumberValue
    标记接口，标记所有包含数字的子接口WritableValue 。
    WritableObjectValue
    可写类型值。
    WritableStringValue
    一个可写的字符串。
    WritableValue
    A WritableValue是一个包含可读取和设置的值的实体。
  • Classes in javafx.beans.value used by javafx.beans.value
    Class 描述
    ChangeListener
    甲ChangeListener通知每当的值ObservableValue种变化。
    ObservableNumberValue
    所有子接口的公共接口为ObservableValue ，其中包含一个数字。
    ObservableObjectValue
    一个可观察的类型 Object价值。
    ObservableValue
    一个 ObservableValue是一个包装一个值并允许观察变化值的实体。
    WritableNumberValue
    标记接口，标记包含数字的所有子接口WritableValue 。
    WritableObjectValue
    可写类型值。
    WritableValue
    A WritableValue是一个包含可读取和设置的值的实体。
  • Classes in javafx.beans.value used by javafx.css
    Class 描述
    ObservableBooleanValue
    一个可观察的布尔值。
    ObservableDoubleValue
    一个可观察到的双重值。
    ObservableFloatValue
    一个可观察的浮点值。
    ObservableIntegerValue
    一个可观察的整数值。
    ObservableLongValue
    一个可观察的长期价值。
    ObservableNumberValue
    ObservableValue的所有子接口的通用接口包装一个数字。
    ObservableObjectValue
    一个可观察的类型的 Object值。
    ObservableStringValue
    一个可观察的字符串值。
    ObservableValue
    一个 ObservableValue是一个包含值并允许观察变化值的实体。
    WritableBooleanValue
    一个可写布尔值。
    WritableDoubleValue
    一个可写的双重值。
    WritableFloatValue
    可写浮点值。
    WritableIntegerValue
    一个可写的int值。
    WritableLongValue
    一个可写的长期价值。
    WritableNumberValue
    标记接口，用于标记包含数字的所有子接口WritableValue 。
    WritableObjectValue
    可写类型值。
    WritableStringValue
    一个可写的字符串。
    WritableValue
    A WritableValue是一个包含可读取和设置的值的实体。
  • Classes in javafx.beans.value used by javafx.scene.control
    Class 描述
    ObservableObjectValue
    一个可观察的类型 Object价值。
    ObservableStringValue
    一个可观察的字符串值。
    ObservableValue
    一个 ObservableValue是一个包含值并允许观察变化值的实体。
  • Classes in javafx.beans.value used by javafx.scene.control.cell
    Class 描述
    ObservableValue
    一个 ObservableValue是一个包含值并允许观察变化值的实体。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


WeakChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Class WeakChangeListener<T>

  • java.lang.Object
    • javafx.beans.value.WeakChangeListener<T>
  • 参数类型
    T - 观测值的类型
    All Implemented Interfaces:
    ChangeListener<T> ， WeakListener

    public final class WeakChangeListener<T>
extends Object
implements ChangeListener<T>, WeakListener
    A WeakChangeListener可以使用，如果一个ObservableValue应该只保留一个对监听器的弱引用。 这有助于避免内存泄漏，如果观察者在使用后未注册观察对象，则可能会发生这种情况。

    WeakChangeListener是通过传递原来的ChangeListener创建的。 然后应注册WeakChangeListener以监听观察对象的更改。

    注意：您必须保留对ChangeListener的引用，只要它在使用中传递，否则将很快收集垃圾。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ChangeListener ， ObservableValue

    • 构造方法摘要

      构造方法
      Constructor 描述
      WeakChangeListener​(ChangeListener<T> listener)
      构造函数为 WeakChangeListener 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void changed​(ObservableValue<? extends T> observable, T oldValue, T newValue)
      该方法需要通过 ChangeListener的实现来提供。
      boolean wasGarbageCollected​()
      如果链接的侦听器被垃圾回收，则返回 true 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WeakChangeListener

        public WeakChangeListener​(ChangeListener<T> listener)
        构造函数为 WeakChangeListener 。
        参数
        listener - 应该通知的原始听众

    • 方法详细信息

      • wasGarbageCollected

        public boolean wasGarbageCollected​()
        如果链接的侦听器被垃圾回收，则返回true 。 在这种情况下，可以从observable中移除侦听器。
        Specified by:
        wasGarbageCollected接口 WeakListener
        结果
        true如果链接的侦听器是垃圾回收的。

      • changed

        public void changed​(ObservableValue<? extends T> observable,
                    T oldValue,
                    T newValue)
        该方法需要通过ChangeListener的实现来提供。 如果一个ObservableValue的值发生变化，则调用它。

        一般认为在这种方法中修改观察值的不良做法。

        Specified by:
        changed在接口 ChangeListener<T>
        参数
        observable - 该值改变了 ObservableValue
        oldValue - 旧值
        newValue - 新的价值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableBooleanValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableBooleanValue

  • All Superinterfaces:
    WritableValue<Boolean>
    所有已知实现类：
    BooleanProperty ， BooleanPropertyBase ， JavaBeanBooleanProperty ， ReadOnlyBooleanWrapper ， SimpleBooleanProperty ， SimpleStyleableBooleanProperty ， StyleableBooleanProperty

    public interface WritableBooleanValue
extends WritableValue<Boolean>
    一个可写布尔值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WritableValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean get​()
      获取包装的值。
      void set​(boolean value)
      设置包装的值。
      void setValue​(Boolean value)
      设置包装的值。

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 方法详细信息

      • get

        boolean get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始布尔值。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        void set​(boolean value)
        设置包装的值。 与setValue(java.lang.Boolean)不同，该方法使用原始布尔。
        参数
        value - 新的价值

      • setValue

        void setValue​(Boolean value)
        设置包装的值。

        注意：此方法应该接受null而不抛出异常，而是设置“false”。

        Specified by:
        setValue在接口 WritableValue<Boolean>
        参数
        value - 新的价值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableDoubleValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableDoubleValue

  • All Superinterfaces:
    WritableNumberValue ， WritableValue<Number>
    所有已知实现类：
    DoubleProperty ， DoublePropertyBase ， JavaBeanDoubleProperty ， ReadOnlyDoubleWrapper ， SimpleDoubleProperty ， SimpleStyleableDoubleProperty ， StyleableDoubleProperty

    public interface WritableDoubleValue
extends WritableNumberValue
    一个可写的双重值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WritableValue ， WritableNumberValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      double get​()
      获取包装的值。
      void set​(double value)
      设置包装的值。
      void setValue​(Number value)
      设置包装的值。

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 方法详细信息

      • get

        double get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始double。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        void set​(double value)
        设置包装的值。 与setValue(java.lang.Number)不同，此方法使用原语双。
        参数
        value - 新价值

      • setValue

        void setValue​(Number value)
        设置包装的值。

        注意：该方法应该接受null而不抛出异常，而是设置“0.0”。

        Specified by:
        setValue在接口 WritableValue<Number>
        参数
        value - 新的价值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableFloatValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableFloatValue

  • All Superinterfaces:
    WritableNumberValue ， WritableValue<Number>
    所有已知实现类：
    FloatProperty ， FloatPropertyBase ， JavaBeanFloatProperty ， ReadOnlyFloatWrapper ， SimpleFloatProperty ， SimpleStyleableFloatProperty ， StyleableFloatProperty

    public interface WritableFloatValue
extends WritableNumberValue
    可写浮点值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WritableValue ， WritableNumberValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      float get​()
      获取包装的值。
      void set​(float value)
      设置包装的值。
      void setValue​(Number value)
      设置包装的值。

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 方法详细信息

      • get

        float get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始浮点数。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        void set​(float value)
        设置包装的值。 与setValue(java.lang.Number)不同，此方法使用原始浮点数。
        参数
        value - 新值

      • setValue

        void setValue​(Number value)
        设置包装的值。

        注意：该方法应该接受null而不抛出异常，而是设置“0.0”。

        Specified by:
        setValue在接口 WritableValue<Number>
        参数
        value - 新值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableIntegerValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableIntegerValue

  • All Superinterfaces:
    WritableNumberValue ， WritableValue<Number>
    所有已知实现类：
    IntegerProperty ， IntegerPropertyBase ， JavaBeanIntegerProperty ， ReadOnlyIntegerWrapper ， SimpleIntegerProperty ， SimpleStyleableIntegerProperty ， StyleableIntegerProperty

    public interface WritableIntegerValue
extends WritableNumberValue
    一个可写的int值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WritableValue ， WritableNumberValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int get​()
      获取包装的值。
      void set​(int value)
      设置包装的值。
      void setValue​(Number value)
      设置包装的值。

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 方法详细信息

      • get

        int get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始int。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        void set​(int value)
        设置包装的值。 与setValue(java.lang.Number)不同，该方法使用原语int。
        参数
        value - 新的价值

      • setValue

        void setValue​(Number value)
        设置包装的值。

        注意：此方法应该接受null而不会抛出异常，而是设置“0”。

        Specified by:
        setValue在接口 WritableValue<Number>
        参数
        value - 新的价值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableListValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableListValue<E>

  • 参数类型
    E - List元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E> ， List<E> ， Observable ， ObservableList<E> ， WritableObjectValue<ObservableList<E>> ， WritableValue<E>
    所有已知实现类：
    ListProperty ， ListPropertyBase ， ReadOnlyListWrapper ， SimpleListProperty

    public interface WritableListValue<E>
extends WritableObjectValue<ObservableList<E>>, ObservableList<E>
    可写参考一个ObservableList 。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableList ， WritableObjectValue ， WritableListValue

    • 方法摘要

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, size, sort, spliterator, subList, toArray, toArray

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableList

        addAll, addListener, filtered, remove, removeAll, removeListener, retainAll, setAll, setAll, sorted, sorted

      • Methods inherited from interface javafx.beans.value.WritableObjectValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableLongValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableLongValue

  • All Superinterfaces:
    WritableNumberValue ， WritableValue<Number>
    所有已知实现类：
    JavaBeanLongProperty ， LongProperty ， LongPropertyBase ， ReadOnlyLongWrapper ， SimpleLongProperty ， SimpleStyleableLongProperty ， StyleableLongProperty

    public interface WritableLongValue
extends WritableNumberValue
    一个可写的长期价值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WritableValue ， WritableNumberValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long get​()
      获取包装的值。
      void set​(long value)
      设置包装的值。
      void setValue​(Number value)
      设置包装的值。

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue

    • 方法详细信息

      • get

        long get​()
        获取包装的值。 与WritableValue.getValue()不同，此方法返回原始long。 需要与WritableValue.getValue()相同。
        结果
        当前值

      • set

        void set​(long value)
        设置包装的值。 与setValue(java.lang.Number)不同，此方法使用原始长。
        参数
        value - 新的价值

      • setValue

        void setValue​(Number value)
        设置包装的值。

        注意：此方法应该接受null而不会抛出异常，而是设置“0”。

        Specified by:
        setValue在接口 WritableValue<Number>
        参数
        value - 新的价值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableMapValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableMapValue<K,V>

  • 参数类型
    K - K的关键元素的 Map
    V - V的值元素的 Map
    All Superinterfaces:
    Map<K,V> ， Observable ， ObservableMap<K,V> ， WritableObjectValue<ObservableMap<K,V>> ， WritableValue<K>
    所有已知实现类：
    MapProperty ， MapPropertyBase ， ReadOnlyMapWrapper ， SimpleMapProperty

    public interface WritableMapValue<K,V>
extends WritableObjectValue<ObservableMap<K,V>>, ObservableMap<K,V>
    对ObservableMap的可写参考。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableMap, WritableObjectValue, WritableMapValue

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 方法摘要

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entry, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableMap

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.WritableObjectValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableNumberValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableNumberValue

  • All Superinterfaces:
    WritableValue<Number>
    All Known Subinterfaces:
    WritableDoubleValue ， WritableFloatValue ， WritableIntegerValue ， WritableLongValue
    所有已知实现类：
    DoubleProperty ， DoublePropertyBase ， FloatProperty ， FloatPropertyBase ， IntegerProperty ， IntegerPropertyBase ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， LongProperty ， LongPropertyBase ， ReadOnlyDoubleWrapper ， ReadOnlyFloatWrapper ， ReadOnlyIntegerWrapper ， ReadOnlyLongWrapper ， SimpleDoubleProperty ， SimpleFloatProperty ， SimpleIntegerProperty ， SimpleLongProperty ， SimpleStyleableDoubleProperty ， SimpleStyleableFloatProperty ， SimpleStyleableIntegerProperty ， SimpleStyleableLongProperty ， StyleableDoubleProperty ， StyleableFloatProperty ， StyleableIntegerProperty ， StyleableLongProperty

    public interface WritableNumberValue
extends WritableValue<Number>
    标记接口，标记包含数字的所有子接口WritableValue 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WritableValue ， WritableDoubleValue ， WritableFloatValue ， WritableIntegerValue ， WritableLongValue

    • 方法摘要

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableObjectValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableObjectValue<T>

  • All Superinterfaces:
    WritableValue<T>
    All Known Subinterfaces:
    WritableListValue<E> ， WritableMapValue<K,V> ， WritableSetValue<E> ， WritableStringValue
    所有已知实现类：
    JavaBeanObjectProperty ， JavaBeanStringProperty ， ListProperty ， ListPropertyBase ， MapProperty ， MapPropertyBase ， ObjectProperty ， ObjectPropertyBase ， ReadOnlyListWrapper ， ReadOnlyMapWrapper ， ReadOnlyObjectWrapper ， ReadOnlySetWrapper ， ReadOnlyStringWrapper ， SetProperty ， SetPropertyBase ， SimpleListProperty ， SimpleMapProperty ， SimpleObjectProperty ， SimpleSetProperty ， SimpleStringProperty ， SimpleStyleableObjectProperty ， SimpleStyleableStringProperty ， StringProperty ， StringPropertyBase ， StyleableObjectProperty ， StyleableStringProperty

    public interface WritableObjectValue<T>
extends WritableValue<T>
    可写类型值。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WritableValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      T get​()
      获取包装的值。
      void set​(T value)
      设置包装的值。

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • get

        T get​()
        获取包装的值。 这必须与从WritableValue.getValue()返回的值相同。

        此方法仅存在于将WritableObjectValue API与WritableBooleanValue和子类WritableNumberValue对齐

        结果
        当前值

      • set

        void set​(T value)
        设置包装的值。 应相当于WritableValue.setValue(java.lang.Object)
        参数
        value - 新的价值
        另请参见：
        get()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableSetValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableSetValue<E>

  • 参数类型
    E - Set元素的类型
    All Superinterfaces:
    Collection<E> ， Iterable<E> ， Observable ， ObservableSet<E> ， Set<E> ， WritableObjectValue<ObservableSet<E>> ， WritableValue<E>
    所有已知实现类：
    ReadOnlySetWrapper ， SetProperty ， SetPropertyBase ， SimpleSetProperty

    public interface WritableSetValue<E>
extends WritableObjectValue<ObservableSet<E>>, ObservableSet<E>
    一个可写参考的一个ObservableSet 。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ObservableSet ， WritableObjectValue ， WritableSetValue

    • 方法摘要

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableSet

        addListener, removeListener

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, spliterator, toArray, toArray

      • Methods inherited from interface javafx.beans.value.WritableObjectValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableStringValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableStringValue

  • All Superinterfaces:
    WritableObjectValue<String> ， WritableValue<String>
    所有已知实现类：
    JavaBeanStringProperty ， ReadOnlyStringWrapper ， SimpleStringProperty ， SimpleStyleableStringProperty ， StringProperty ， StringPropertyBase ， StyleableStringProperty

    public interface WritableStringValue
extends WritableObjectValue<String>
    一个可写的字符串。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WritableValue ， WritableObjectValue

    • 方法摘要

      • Methods inherited from interface javafx.beans.value.WritableObjectValue

        get, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritableValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.beans.value

Interface WritableValue<T>

  • 参数类型
    T - 包装值的类型
    All Known Subinterfaces:
    JavaBeanProperty<T> ， Property<T> ， StyleableProperty<T> ， WritableBooleanValue ， WritableDoubleValue ， WritableFloatValue ， WritableIntegerValue ， WritableListValue<E> ， WritableLongValue ， WritableMapValue<K,V> ， WritableNumberValue ， WritableObjectValue<T> ， WritableSetValue<E> ， WritableStringValue
    所有已知实现类：
    BooleanProperty ， BooleanPropertyBase ， DoubleProperty ， DoublePropertyBase ， FloatProperty ， FloatPropertyBase ， IntegerProperty ， IntegerPropertyBase ， JavaBeanBooleanProperty ， JavaBeanDoubleProperty ， JavaBeanFloatProperty ， JavaBeanIntegerProperty ， JavaBeanLongProperty ， JavaBeanObjectProperty ， JavaBeanStringProperty ， ListProperty ， ListPropertyBase ， LongProperty ， LongPropertyBase ， MapProperty ， MapPropertyBase ， ObjectProperty ， ObjectPropertyBase ， ReadOnlyBooleanWrapper ， ReadOnlyDoubleWrapper ， ReadOnlyFloatWrapper ， ReadOnlyIntegerWrapper ， ReadOnlyListWrapper ， ReadOnlyLongWrapper ， ReadOnlyMapWrapper ， ReadOnlyObjectWrapper ， ReadOnlySetWrapper ， ReadOnlyStringWrapper ， SetProperty ， SetPropertyBase ， SimpleBooleanProperty ， SimpleDoubleProperty ， SimpleFloatProperty ， SimpleIntegerProperty ， SimpleListProperty ， SimpleLongProperty ， SimpleMapProperty ， SimpleObjectProperty ， SimpleSetProperty ， SimpleStringProperty ， SimpleStyleableBooleanProperty ， SimpleStyleableDoubleProperty ， SimpleStyleableFloatProperty ， SimpleStyleableIntegerProperty ， SimpleStyleableLongProperty ， SimpleStyleableObjectProperty ， SimpleStyleableStringProperty ， StringProperty ， StringPropertyBase ， StyleableBooleanProperty ， StyleableDoubleProperty StyleableDoubleProperty ， StyleableFloatProperty ， StyleableIntegerProperty ， StyleableLongProperty ， StyleableObjectProperty ， StyleableStringProperty

    public interface WritableValue<T>
    A WritableValue是一个包含可读取和设置的值的实体。 通常这个接口不应该直接实现，而是其子接口之一（ WritableBooleanValue等）。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WritableBooleanValue ， WritableDoubleValue ， WritableFloatValue ， WritableIntegerValue ， WritableLongValue ， WritableNumberValue ， WritableObjectValue ， WritableStringValue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      T getValue​()
      获取包装的值。
      void setValue​(T value)
      设置包装的值。

    • 方法详细信息

      • getValue

        T getValue​()
        获取包装的值。
        结果
        当前值

      • setValue

        void setValue​(T value)
        设置包装的值。
        参数
        value - 新的价值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.beans.value.ObservableValueBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.value.ObservableValueBase

No usage of javafx.beans.value.ObservableValueBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.beans.value.WeakChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.beans.value.WeakChangeListener

No usage of javafx.beans.value.WeakChangeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ChangeListener

  • Packages that use ChangeListener
    软件包 描述
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。

    • Uses of ChangeListener in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type ChangeListener
      Modifier and Type | 方法 | 描述
      void | BooleanBinding.addListener​(ChangeListener<? super Boolean> listener)
      void | DoubleBinding.addListener​(ChangeListener<? super Number> listener)
      void | FloatBinding.addListener​(ChangeListener<? super Number> listener)
      void | IntegerBinding.addListener​(ChangeListener<? super Number> listener)
      void | ListBinding.addListener​(ChangeListener<? super ObservableList<E>> listener)
      void | LongBinding.addListener​(ChangeListener<? super Number> listener)
      void | MapBinding.addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | ObjectBinding.addListener​(ChangeListener<? super T> listener)
      void | SetBinding.addListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | StringBinding.addListener​(ChangeListener<? super String> listener)
      void | BooleanBinding.removeListener​(ChangeListener<? super Boolean> listener)
      void | DoubleBinding.removeListener​(ChangeListener<? super Number> listener)
      void | FloatBinding.removeListener​(ChangeListener<? super Number> listener)
      void | IntegerBinding.removeListener​(ChangeListener<? super Number> listener)
      void | ListBinding.removeListener​(ChangeListener<? super ObservableList<E>> listener)
      void | LongBinding.removeListener​(ChangeListener<? super Number> listener)
      void | MapBinding.removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | ObjectBinding.removeListener​(ChangeListener<? super T> listener)
      void | SetBinding.removeListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | StringBinding.removeListener​(ChangeListener<? super String> listener)

    • Uses of ChangeListener in javafx.beans.property

      Methods in javafx.beans.property with parameters of type ChangeListener
      Modifier and Type | 方法 | 描述
      void | BooleanPropertyBase.addListener​(ChangeListener<? super Boolean> listener)
      void | DoublePropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | FloatPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | IntegerPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | ListPropertyBase.addListener​(ChangeListener<? super ObservableList<E>> listener)
      void | LongPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | MapPropertyBase.addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | ObjectPropertyBase.addListener​(ChangeListener<? super T> listener)
      void | ReadOnlyBooleanPropertyBase.addListener​(ChangeListener<? super Boolean> listener)
      void | ReadOnlyDoublePropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyFloatPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyIntegerPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyListPropertyBase.addListener​(ChangeListener<? super ObservableList<E>> listener)
      void | ReadOnlyLongPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyMapPropertyBase.addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | ReadOnlyObjectPropertyBase.addListener​(ChangeListener<? super T> listener)
      void | ReadOnlySetPropertyBase.addListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | ReadOnlyStringPropertyBase.addListener​(ChangeListener<? super String> listener)
      void | SetPropertyBase.addListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | StringPropertyBase.addListener​(ChangeListener<? super String> listener)
      void | BooleanPropertyBase.removeListener​(ChangeListener<? super Boolean> listener)
      void | DoublePropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | FloatPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | IntegerPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | ListPropertyBase.removeListener​(ChangeListener<? super ObservableList<E>> listener)
      void | LongPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | MapPropertyBase.removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | ObjectPropertyBase.removeListener​(ChangeListener<? super T> listener)
      void | ReadOnlyBooleanPropertyBase.removeListener​(ChangeListener<? super Boolean> listener)
      void | ReadOnlyDoublePropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyFloatPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyIntegerPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyListPropertyBase.removeListener​(ChangeListener<? super ObservableList<E>> listener)
      void | ReadOnlyLongPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyMapPropertyBase.removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | ReadOnlyObjectPropertyBase.removeListener​(ChangeListener<? super T> listener)
      void | ReadOnlySetPropertyBase.removeListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | ReadOnlyStringPropertyBase.removeListener​(ChangeListener<? super String> listener)
      void | SetPropertyBase.removeListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | StringPropertyBase.removeListener​(ChangeListener<? super String> listener)

    • Uses of ChangeListener in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter with parameters of type ChangeListener
      Modifier and Type 方法 描述
      void JavaBeanBooleanProperty.addListener​(ChangeListener<? super Boolean> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void JavaBeanDoubleProperty.addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void JavaBeanFloatProperty.addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void JavaBeanIntegerProperty.addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void JavaBeanLongProperty.addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void JavaBeanObjectProperty.addListener​(ChangeListener<? super T> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void JavaBeanStringProperty.addListener​(ChangeListener<? super String> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void JavaBeanBooleanProperty.removeListener​(ChangeListener<? super Boolean> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void JavaBeanDoubleProperty.removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      void JavaBeanFloatProperty.removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void JavaBeanIntegerProperty.removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生更改时通知 ObservableValue 。
      void JavaBeanLongProperty.removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void JavaBeanObjectProperty.removeListener​(ChangeListener<? super T> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void JavaBeanStringProperty.removeListener​(ChangeListener<? super String> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

    • Uses of ChangeListener in javafx.beans.value

      Classes in javafx.beans.value that implement ChangeListener
      Modifier and Type Class 描述
      class  WeakChangeListener<T>
      A WeakChangeListener可以使用，如果一个ObservableValue应该只保留对监听者的弱引用。
      Methods in javafx.beans.value with parameters of type ChangeListener
      Modifier and Type 方法 描述
      void ObservableValue.addListener​(ChangeListener<? super T> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void ObservableValueBase.addListener​(ChangeListener<? super T> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void ObservableValue.removeListener​(ChangeListener<? super T> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void ObservableValueBase.removeListener​(ChangeListener<? super T> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      Constructors in javafx.beans.value with parameters of type ChangeListener
      Constructor 描述
      WeakChangeListener​(ChangeListener<T> listener)
      构造函数为 WeakChangeListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableBooleanValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableBooleanValue

  • Packages that use ObservableBooleanValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ObservableBooleanValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableBooleanValue
      Modifier and Type Class 描述
      class  BooleanBinding
      提供实现boolean的boolean所需的大部分功能的基类。
      class  BooleanExpression
      BooleanExpression是一个ObservableBooleanValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding with parameters of type ObservableBooleanValue
      Modifier and Type 方法 描述
      static BooleanBinding Bindings.and​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个BooleanBinding计算的两个实例值条件与运算ObservableBooleanValue 。
      BooleanBinding BooleanExpression.and​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，在这个BooleanExpression和一个ObservableBooleanValue执行条件AND操作。
      static BooleanExpression BooleanExpression.booleanExpression​(ObservableBooleanValue value)
      返回一个BooleanExpression ，其中包含一个ObservableBooleanValue 。
      static BooleanBinding Bindings.equal​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue相等。
      BooleanBinding BooleanExpression.isEqualTo​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。
      BooleanBinding BooleanExpression.isNotEqualTo​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。
      static BooleanBinding Bindings.not​(ObservableBooleanValue op)
      创建一个BooleanBinding ，计算一个ObservableBooleanValue的值的倒数 。
      static BooleanBinding Bindings.notEqual​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue不相等。
      static BooleanBinding Bindings.or​(ObservableBooleanValue op1, ObservableBooleanValue op2)
      创建一个BooleanBinding ，它为ObservableBooleanValue的两个实例的值计算条件OR操作。
      BooleanBinding BooleanExpression.or​(ObservableBooleanValue other)
      创建一个新的BooleanExpression ，在这个BooleanExpression和一个ObservableBooleanValue执行条件OR操作。
      BooleanBinding When.BooleanConditionBuilder.otherwise​(ObservableBooleanValue otherwiseValue)
      定义ObservableBooleanValue如果条件为false ，那么三元表达式返回哪个值。
      When.BooleanConditionBuilder When.then​(ObservableBooleanValue thenValue)
      定义ObservableBooleanValue如果条件为true ， 则该值由三元表达式返回。
      static When Bindings.when​(ObservableBooleanValue condition)
      创建一个计算三元表达式结果的绑定。
      Constructors in javafx.beans.binding with parameters of type ObservableBooleanValue
      Constructor 描述
      When​(ObservableBooleanValue condition)
      构造函数为 When 。

    • Uses of ObservableBooleanValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableBooleanValue
      Modifier and Type Class 描述
      class  BooleanProperty
      该类提供了一个包含 boolean值的Property的完整实现。
      class  BooleanPropertyBase
      BooleanPropertyBase类是包装一个 boolean值的属性的基类。
      class  ReadOnlyBooleanProperty
      超类为所有只读属性包装一个 boolean 。
      class  ReadOnlyBooleanPropertyBase
      所有只读属性的基类包装一个 boolean 。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleBooleanProperty
      该类提供了一个包含 boolean值的Property的全面实现。

    • Uses of ObservableBooleanValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement ObservableBooleanValue
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在类型为 boolean或 Boolean的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanBooleanProperty
      A ReadOnlyJavaBeanBooleanProperty在常规的只读Java Bean属性类型为 boolean或 Boolean和JavaFX ReadOnlyBooleanProperty之间提供了一个适配器。

    • Uses of ObservableBooleanValue in javafx.css

      Classes in javafx.css that implement ObservableBooleanValue
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      这个类扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableDoubleValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableDoubleValue

  • Packages that use ObservableDoubleValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ObservableDoubleValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableDoubleValue
      Modifier and Type Class 描述
      class  DoubleBinding
      提供实现double值Binding所需的大部分功能的基类。
      class  DoubleExpression
      DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding with parameters of type ObservableDoubleValue
      Modifier and Type 方法 描述
      static DoubleExpression DoubleExpression.doubleExpression​(ObservableDoubleValue value)
      返回一个DoubleExpression的DoubleExpression 。

    • Uses of ObservableDoubleValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableDoubleValue
      Modifier and Type Class 描述
      class  DoubleProperty
      此类定义了一个Property包装double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  ReadOnlyDoubleProperty
      超类为所有只读属性包装一个 double 。
      class  ReadOnlyDoublePropertyBase
      所有只读属性的基类包装一个 double 。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      该类提供了一个包含 double值的Property的全面实现。

    • Uses of ObservableDoubleValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement ObservableDoubleValue
      Modifier and Type Class 描述
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在 double或 Double之间的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty提供了一个适配器。

    • Uses of ObservableDoubleValue in javafx.css

      Classes in javafx.css that implement ObservableDoubleValue
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableFloatValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableFloatValue

  • Packages that use ObservableFloatValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ObservableFloatValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableFloatValue
      Modifier and Type Class 描述
      class  FloatBinding
      提供实现float值Binding所需的大部分功能的基类。
      class  FloatExpression
      FloatExpression是一个ObservableFloatValue，另外还有一个方便的方法来生成流畅的绑定。
      Methods in javafx.beans.binding with parameters of type ObservableFloatValue
      Modifier and Type 方法 描述
      static FloatExpression FloatExpression.floatExpression​(ObservableFloatValue value)
      返回一个FloatExpression ，其中包含一个ObservableFloatValue 。

    • Uses of ObservableFloatValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableFloatValue
      Modifier and Type Class 描述
      class  FloatProperty
      这个类定义了一个Property包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  ReadOnlyFloatProperty
      超类为所有只读属性包装一个 float 。
      class  ReadOnlyFloatPropertyBase
      所有只读属性的基类包装一个 float 。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleFloatProperty
      这个类提供了一个Property的全面实现，包装了一个float值。

    • Uses of ObservableFloatValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement ObservableFloatValue
      Modifier and Type Class 描述
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在类型为 float或 Float的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。

    • Uses of ObservableFloatValue in javafx.css

      Classes in javafx.css that implement ObservableFloatValue
      Modifier and Type Class 描述
      class  SimpleStyleableFloatProperty
      该课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableIntegerValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableIntegerValue

  • Packages that use ObservableIntegerValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ObservableIntegerValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableIntegerValue
      Modifier and Type Class 描述
      class  IntegerBinding
      提供实现int值Binding所需的大部分功能的基类。
      class  IntegerExpression
      IntegerExpression是一个ObservableIntegerValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding with parameters of type ObservableIntegerValue
      Modifier and Type 方法 描述
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, ObservableIntegerValue index)
      创建一个新的BooleanBinding ，其中包含指定位置的ObservableList的元素。
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableFloatArray op, ObservableIntegerValue index)
      创建一个新的FloatBinding ，其中包含指定位置的元素ObservableArray 。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableList的元素。
      static IntegerExpression IntegerExpression.integerExpression​(ObservableIntegerValue value)
      返回一个IntegerExpression ，其中包含一个ObservableIntegerValue 。
      static IntegerBinding Bindings.integerValueAt​(ObservableIntegerArray op, ObservableIntegerValue index)
      创建一个新的IntegerBinding ，其中包含ObservableArray在指定位置的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的LongBinding ，其中包含ObservableList在指定位置的元素。
      static StringBinding Bindings.stringValueAt​(ObservableList<String> op, ObservableIntegerValue index)
      创建一个新的StringBinding ，其中包含ObservableList在指定位置的元素。
      static <E> ObjectBinding<E> Bindings.valueAt​(ObservableList<E> op, ObservableIntegerValue index)
      创建一个新的ObjectBinding ，其中包含指定位置的元素ObservableList 。
      ObjectBinding<E> ListExpression.valueAt​(ObservableIntegerValue index)
      创建一个新的ObjectBinding ，其中包含指定位置的元素。

    • Uses of ObservableIntegerValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableIntegerValue
      Modifier and Type Class 描述
      class  IntegerProperty
      该类定义了一个Property包装int值。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  ReadOnlyIntegerProperty
      所有readonly属性的超类包装一个 int 。
      class  ReadOnlyIntegerPropertyBase
      所有只读属性的基类包装一个 int 。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleIntegerProperty
      该类提供了一个包含 int值的Property的完整实现。

    • Uses of ObservableIntegerValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement ObservableIntegerValue
      Modifier and Type Class 描述
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在类型为 int或 Integer的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在类型为 int或 Integer的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty之间提供了一个适配器。

    • Uses of ObservableIntegerValue in javafx.css

      Classes in javafx.css that implement ObservableIntegerValue
      Modifier and Type Class 描述
      class  SimpleStyleableIntegerProperty
      这个类扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableListValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableListValue

  • Packages that use ObservableListValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of ObservableListValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableListValue
      Modifier and Type Class 描述
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      class  ListExpression<E>
      ListExpression是一个ObservableListValue，另外还有一个方便的方法来生成流畅的绑定。
      Methods in javafx.beans.binding with parameters of type ObservableListValue
      Modifier and Type 方法 描述
      static <E> ListExpression<E> ListExpression.listExpression​(ObservableListValue<E> value)
      返回一个ListExpression ，其中包含一个ObservableListValue 。

    • Uses of ObservableListValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableListValue
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个包含ObservableList的Property的完整实现。
      class  ListPropertyBase<E>
      ListPropertyBase类是用于包装ObservableList的属性的基类。
      class  ReadOnlyListProperty<E>
      超类为所有只读属性包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleListProperty<E>
      这个类提供了一个包含ObservableList的ObservableList的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableLongValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableLongValue

  • Packages that use ObservableLongValue
    软件包 描述
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ObservableLongValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableLongValue
      Modifier and Type Class 描述
      class  LongBinding
      提供实现long值Binding所需的大部分功能的基类。
      class  LongExpression
      LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding with parameters of type ObservableLongValue
      Modifier and Type 方法 描述
      static LongExpression LongExpression.longExpression​(ObservableLongValue value)
      返回一个LongExpression ，其中包含一个ObservableLongValue 。

    • Uses of ObservableLongValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableLongValue
      Modifier and Type Class 描述
      class  LongProperty
      这个类定义了一个270672253982472包装long值。
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  ReadOnlyLongProperty
      所有readonly属性的超类包装一个 long 。
      class  ReadOnlyLongPropertyBase
      所有只读属性的基类包装一个 long 。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleLongProperty
      该类提供了一个包含 long值的Property的完整实现。

    • Uses of ObservableLongValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement ObservableLongValue
      Modifier and Type Class 描述
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在类型为 long或 Long的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty之间提供了一个适配器。

    • Uses of ObservableLongValue in javafx.css

      Classes in javafx.css that implement ObservableLongValue
      Modifier and Type Class 描述
      class  SimpleStyleableLongProperty
      该课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableMapValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableMapValue

  • Packages that use ObservableMapValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。

    • Uses of ObservableMapValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableMapValue
      Modifier and Type Class 描述
      class  MapBinding<K,V>
      提供实现ObservableMap的Binding所需的大部分功能的基类。
      class  MapExpression<K,V>
      MapExpression是一个ObservableMapValue，另外还有一个方便的方法来生成流畅的绑定。
      Methods in javafx.beans.binding with parameters of type ObservableMapValue
      Modifier and Type 方法 描述
      static <K,V> MapExpression<K,V> MapExpression.mapExpression​(ObservableMapValue<K,V> value)
      返回一个MapExpression ，其中包含一个ObservableMapValue 。

    • Uses of ObservableMapValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableMapValue
      Modifier and Type Class 描述
      class  MapProperty<K,V>
      这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装ObservableMap的属性的基类。
      class  ReadOnlyMapProperty<K,V>
      所有readonly属性的超类包装一个ObservableMap 。
      class  ReadOnlyMapPropertyBase<K,V>
      所有只读属性的基类包装一个ObservableMap 。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableNumberValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableNumberValue

  • Packages that use ObservableNumberValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of ObservableNumberValue in javafx.beans.binding

      Subinterfaces of ObservableNumberValue in javafx.beans.binding
      Modifier and Type 接口 描述
      interface  NumberBinding
      标记界面，用于标记所有绑定数字值的绑定。
      interface  NumberExpression
      NumberExpression是一个ObservableNumberValue，另外还有一个方便的方法来生成流畅的绑定。
      Classes in javafx.beans.binding that implement ObservableNumberValue
      Modifier and Type Class 描述
      class  DoubleBinding
      提供实现double值Binding所需的大部分功能的基类。
      class  DoubleExpression
      DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
      class  FloatBinding
      提供实现float的float所需的大部分功能的基类。
      class  FloatExpression
      FloatExpression是一个ObservableFloatValue，另外还有一个方便的方法来生成流畅的绑定。
      class  IntegerBinding
      提供实现int的int所需的大部分功能的基类。
      class  IntegerExpression
      IntegerExpression是一个ObservableIntegerValue加上额外的便利方法，以流利的风格生成绑定。
      class  LongBinding
      提供实现long值Binding所需的大部分功能的基类。
      class  LongExpression
      LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。
      class  NumberExpressionBase
      NumberExpressionBase包含方便的方法来生成流畅样式的绑定，这对所有的NumberExpression子类都是常见的。
      Methods in javafx.beans.binding with parameters of type ObservableNumberValue
      Modifier and Type | 方法 | 描述
      static DoubleBinding Bindings.add​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，它计算一个ObservableNumberValue的值和一个恒定值的总和。
      static NumberBinding Bindings.add​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding Bindings.add​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding Bindings.add​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值和一个恒定值的总和。
      static DoubleBinding Bindings.add​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding Bindings.add​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
      static NumberBinding Bindings.add​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值和一个恒定值的总和。
      static NumberBinding Bindings.add​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值和一个恒定值的总和。
      static NumberBinding Bindings.add​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding计算的两个实例的值的总和ObservableNumberValue 。
      DoubleBinding | DoubleExpression.add​(ObservableNumberValue other)
      NumberBinding NumberExpression.add​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的总和。
      NumberBinding | NumberExpressionBase.add​(ObservableNumberValue other)
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, ObservableNumberValue index)
      创建一个新的BooleanBinding ，其中包含指定位置的ObservableList的元素。
      static DoubleBinding Bindings.divide​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，它计算一个常数值的除数和一个ObservableNumberValue的值。
      static NumberBinding Bindings.divide​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算一个常数值的除法和一个ObservableNumberValue的值。
      static NumberBinding Bindings.divide​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，它计算一个常数值的除法和一个ObservableNumberValue的值。
      static NumberBinding Bindings.divide​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，它计算一个常数值的除法和一个ObservableNumberValue的值。
      static DoubleBinding Bindings.divide​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，它计算ObservableNumberValue的值除数和常数值。
      static NumberBinding Bindings.divide​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值除数和常数值。
      static NumberBinding Bindings.divide​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的除数和一个恒定值。
      static NumberBinding Bindings.divide​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值除以恒定值。
      static NumberBinding Bindings.divide​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的值的除法 。
      DoubleBinding | DoubleExpression.divide​(ObservableNumberValue other)
      NumberBinding NumberExpression.divide​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的除法 。
      NumberBinding | NumberExpressionBase.divide​(ObservableNumberValue other)
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。
      static BooleanBinding Bindings.equal​(double op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.equal​(float op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
      static BooleanBinding Bindings.equal​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(int op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
      static BooleanBinding Bindings.equal​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值。
      static BooleanBinding Bindings.equal​(long op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值（具有公差）。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, double op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, float op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, int op2, double epsilon)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值（具有公差）。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, long op2, double epsilon)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值（具有公差）。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等。
      static BooleanBinding Bindings.equal​(ObservableNumberValue op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等（与公差）。
      static FloatBinding Bindings.floatValueAt​(ObservableFloatArray op, ObservableNumberValue index)
      创建一个新的FloatBinding ，其中包含指定位置的元素ObservableArray 。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的FloatBinding ，其中包含指定位置的元素ObservableList 。
      static BooleanBinding Bindings.greaterThan​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThan​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThan​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果常数值大于true的值，则该值保留true 。
      static BooleanBinding Bindings.greaterThan​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。
      static BooleanBinding Bindings.greaterThan​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果第一个ObservableNumberValue的值大于第二个值，则保留true 。
      BooleanBinding NumberExpression.greaterThan​(ObservableNumberValue other)
      创建一个新的BooleanBinding持有true如果NumberExpression大于另一个ObservableNumberValue 。
      BooleanBinding | NumberExpressionBase.greaterThan​(ObservableNumberValue other)
      static BooleanBinding Bindings.greaterThanOrEqual​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值大于或等于一个常量值，则保留true 。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果第一个ObservableNumberValue的值大于或等于第二个值，则保留true 。
      BooleanBinding NumberExpression.greaterThanOrEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding持有true如果NumberExpression大于或等于另一个ObservableNumberValue 。
      BooleanBinding | NumberExpressionBase.greaterThanOrEqualTo​(ObservableNumberValue other)
      static IntegerBinding Bindings.integerValueAt​(ObservableIntegerArray op, ObservableNumberValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的元素ObservableArray 。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的元素ObservableList 。
      BooleanBinding NumberExpression.isEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等，则保留true 。
      BooleanBinding NumberExpression.isEqualTo​(ObservableNumberValue other, double epsilon)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等（具有公差），则保留true 。
      BooleanBinding | NumberExpressionBase.isEqualTo​(ObservableNumberValue other)
      BooleanBinding | NumberExpressionBase.isEqualTo​(ObservableNumberValue other, double epsilon)
      BooleanBinding NumberExpression.isNotEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等，则保留true 。
      BooleanBinding NumberExpression.isNotEqualTo​(ObservableNumberValue other, double epsilon)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等（容差），则保留true 。
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(ObservableNumberValue other)
      BooleanBinding | NumberExpressionBase.isNotEqualTo​(ObservableNumberValue other, double epsilon)
      static BooleanBinding Bindings.lessThan​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThan​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThan​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThan​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果第一个ObservableNumberValue的值小于第二个值，则保留true 。
      BooleanBinding NumberExpression.lessThan​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，其持有true如果这NumberExpression小于另一个ObservableNumberValue 。
      BooleanBinding | NumberExpressionBase.lessThan​(ObservableNumberValue other)
      static BooleanBinding Bindings.lessThanOrEqual​(double op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(float op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, double op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, float op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建新的BooleanBinding ，如果第一个ObservableNumberValue的值小于或等于第二个值，则保留true 。
      BooleanBinding NumberExpression.lessThanOrEqualTo​(ObservableNumberValue other)
      创建一个新的BooleanBinding ，其持有true如果这NumberExpression小于或等于另一个ObservableNumberValue 。
      BooleanBinding | NumberExpressionBase.lessThanOrEqualTo​(ObservableNumberValue other)
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的LongBinding ，其中包含ObservableList在指定位置的元素。
      static DoubleBinding Bindings.max​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，它计算一个ObservableNumberValue的值的最大值和一个常量值。
      static NumberBinding Bindings.max​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
      static NumberBinding Bindings.max​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最大值和一个常量值。
      static NumberBinding Bindings.max​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最大值和一个常量值。
      static DoubleBinding Bindings.max​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，它计算一个ObservableNumberValue的值的最大值和一个常量值。
      static NumberBinding Bindings.max​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算一个ObservableNumberValue的值的最大值和一个常量值。
      static NumberBinding Bindings.max​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最大值和一个常量值。
      static NumberBinding Bindings.max​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最大值和一个常量值。
      static NumberBinding Bindings.max​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的最大值 。
      static DoubleBinding Bindings.min​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static DoubleBinding Bindings.min​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，计算一个ObservableNumberValue的值的最小值和一个恒定值。
      static NumberBinding Bindings.min​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
      static NumberBinding Bindings.min​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的2706723712316443 ，计算ObservableNumberValue的两个实例的值的最小值 。
      static DoubleBinding Bindings.multiply​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，它计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static DoubleBinding Bindings.multiply​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，它计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，它计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，它计算ObservableNumberValue的值和常数值的乘积 。
      static NumberBinding Bindings.multiply​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的值的乘积 。
      DoubleBinding | DoubleExpression.multiply​(ObservableNumberValue other)
      NumberBinding NumberExpression.multiply​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的产品 。
      NumberBinding | NumberExpressionBase.multiply​(ObservableNumberValue other)
      static NumberBinding Bindings.negate​(ObservableNumberValue value)
      创建一个新的NumberBinding ，计算一个ObservableNumberValue的否定。
      static BooleanBinding Bindings.notEqual​(double op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.notEqual​(float op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding Bindings.notEqual​(int op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.notEqual​(int op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
      static BooleanBinding Bindings.notEqual​(long op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.notEqual​(long op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, double op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, float op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常量值（具有公差），则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, int op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, int op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常量值（具有公差），则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, long op2)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, long op2, double epsilon)
      创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等。
      static BooleanBinding Bindings.notEqual​(ObservableNumberValue op1, ObservableNumberValue op2, double epsilon)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等（与公差）。
      static <S extends Number>
      NumberExpressionBase             		NumberExpressionBase.numberExpression​(ObservableNumberValue value)
      返回一个NumberExpressionBase的NumberExpressionBase 。
      NumberBinding When.NumberConditionBuilder.otherwise​(ObservableNumberValue otherwiseValue)
      定义ObservableNumberValue如果条件为false ，则三元表达式返回哪个值。
      static StringBinding Bindings.stringValueAt​(ObservableList<String> op, ObservableNumberValue index)
      创建一个新的StringBinding ，其中包含ObservableList在指定位置的元素。
      static DoubleBinding Bindings.subtract​(double op1, ObservableNumberValue op2)
      创建一个新的DoubleBinding ，计算常数值和ObservableNumberValue的值的差异 。
      static NumberBinding Bindings.subtract​(float op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算一个常数值和一个ObservableNumberValue的值的差异 。
      static NumberBinding Bindings.subtract​(int op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
      static NumberBinding Bindings.subtract​(long op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算常数值和ObservableNumberValue的值的差异 。
      static DoubleBinding Bindings.subtract​(ObservableNumberValue op1, double op2)
      创建一个新的DoubleBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding Bindings.subtract​(ObservableNumberValue op1, float op2)
      创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding Bindings.subtract​(ObservableNumberValue op1, int op2)
      创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding Bindings.subtract​(ObservableNumberValue op1, long op2)
      创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。
      static NumberBinding Bindings.subtract​(ObservableNumberValue op1, ObservableNumberValue op2)
      创建一个新的NumberBinding ，计算两个实例的值的差异ObservableNumberValue 。
      DoubleBinding | DoubleExpression.subtract​(ObservableNumberValue other)
      NumberBinding NumberExpression.subtract​(ObservableNumberValue other)
      创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的差异 。
      NumberBinding | NumberExpressionBase.subtract​(ObservableNumberValue other)
      When.NumberConditionBuilder When.then​(ObservableNumberValue thenValue)
      定义ObservableNumberValue如果条件为true ， 则该值由三元表达式返回。
      static <E> ObjectBinding<E> Bindings.valueAt​(ObservableList<E> op, ObservableNumberValue index)
      创建一个新的ObjectBinding ，其中包含ObservableList在指定位置的元素。

    • Uses of ObservableNumberValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableNumberValue
      Modifier and Type Class 描述
      class  DoubleProperty
      这个类定义了一个Property包装double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  FloatProperty
      这个类定义了一个Property包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  IntegerProperty
      这个类定义了一个包含 int值的int 。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  LongProperty
      这个类定义了一个Property包裹一个long值。
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  ReadOnlyDoubleProperty
      超类为所有只读属性包装一个 double 。
      class  ReadOnlyDoublePropertyBase
      所有只读属性的基类包装一个 double 。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyFloatProperty
      超类为所有只读属性包装一个 float 。
      class  ReadOnlyFloatPropertyBase
      所有只读属性的基类包装一个 float 。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyIntegerProperty
      超类为所有只读属性包装一个 int 。
      class  ReadOnlyIntegerPropertyBase
      所有只读属性的基类包装一个 int 。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyLongProperty
      超类为所有只读属性包装一个 long 。
      class  ReadOnlyLongPropertyBase
      所有只读属性的基类包装一个 long 。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      这个类提供了一个包含 double值的Property的完整实现。
      class  SimpleFloatProperty
      这个类提供了一个包含 float值的Property的全面实现。
      class  SimpleIntegerProperty
      该类提供了一个包含 int值的Property的完整实现。
      class  SimpleLongProperty
      该类提供了一个包含 long值的Property的完整实现。

    • Uses of ObservableNumberValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement ObservableNumberValue
      Modifier and Type Class 描述
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty提供了一个 double或 Double的常规Java Bean属性和JavaFX DoubleProperty之间的适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在 long或 Long之间的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在 double或 Double之间的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty提供了一个适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在常规的只读Java Bean属性类型为 float或 Float和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在类型为 int或 Integer的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在 long或 Long的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty之间提供了一个适配器。

    • Uses of ObservableNumberValue in javafx.beans.value

      Subinterfaces of ObservableNumberValue in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableDoubleValue
      一个可观察到的双重值。
      interface  ObservableFloatValue
      一个可观察的浮点值。
      interface  ObservableIntegerValue
      一个可观察的整数值。
      interface  ObservableLongValue
      一个可观察的长期价值。

    • Uses of ObservableNumberValue in javafx.css

      Classes in javafx.css that implement ObservableNumberValue
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      这个类扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      该课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableIntegerProperty
      这个类扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableLongProperty
      这个类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableObjectValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableObjectValue

  • Packages that use ObservableObjectValue
    软件包 描述
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ObservableObjectValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableObjectValue
      Modifier and Type Class 描述
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      class  ListExpression<E>
      ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。
      class  MapBinding<K,V>
      提供实现ObservableMap的Binding所需的大部分功能的基类。
      class  MapExpression<K,V>
      MapExpression是一个ObservableMapValue加上其他便利方法来生成流畅的风格的绑定。
      class  ObjectBinding<T>
      提供实现270672428794036的Object所需的大部分功能的基类。
      class  ObjectExpression<T>
      ObjectExpression是一个ObservableObjectValue加上另外方便的方法来生成流畅的风格绑定。
      class  SetBinding<E>
      提供实现ObservableSet的Binding所需的大部分功能的基类。
      class  SetExpression<E>
      SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的风格生成绑定。
      class  StringBinding
      提供实现String的String所需的大部分功能的基类。
      class  StringExpression
      StringExpression是一个ObservableStringValue，另外还有一种方便的方法来生成流畅的绑定。
      Methods in javafx.beans.binding with parameters of type ObservableObjectValue
      Modifier and Type 方法 描述
      static BooleanBinding Bindings.equal​(Object op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(ObservableObjectValue<?> op1, Object op2)
      创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(ObservableObjectValue<?> op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue相等。
      BooleanBinding ObjectExpression.isEqualTo​(ObservableObjectValue<?> other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue相等，则保留true 。
      BooleanBinding ObjectExpression.isNotEqualTo​(ObservableObjectValue<?> other)
      创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue不相等，则保留true 。
      static BooleanBinding Bindings.isNotNull​(ObservableObjectValue<?> op)
      创建一个新的BooleanBinding持有true如果一个价值ObservableObjectValue不null 。
      static BooleanBinding Bindings.isNull​(ObservableObjectValue<?> op)
      创建一个新的BooleanBinding ，如果true的值为null，则null 。
      static BooleanBinding Bindings.notEqual​(Object op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableObjectValue<?> op1, Object op2)
      创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值不等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableObjectValue<?> op1, ObservableObjectValue<?> op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue不相等。
      static <T> ObjectExpression<T> ObjectExpression.objectExpression​(ObservableObjectValue<T> value)
      返回一个ObjectExpression ，其中包含一个ObservableObjectValue 。
      ObjectBinding<T> When.ObjectConditionBuilder.otherwise​(ObservableObjectValue<T> otherwiseValue)
      定义ObservableObjectValue如果条件为false ， 则该值由三元表达式返回。
      <T> When.ObjectConditionBuilder<T> When.then​(ObservableObjectValue<T> thenValue)
      定义ObservableObjectValue如果条件为true则由三元表达式返回该值。

    • Uses of ObservableObjectValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableObjectValue
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  MapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装ObservableMap的属性的基类。
      class  ObjectProperty<T>
      这个类提供了一个包含任意Object的Property的完整实现。
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyListProperty<E>
      所有readonly属性的超类包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyMapProperty<K,V>
      超类为所有只读属性包装一个ObservableMap 。
      class  ReadOnlyMapPropertyBase<K,V>
      所有只读属性的基类包装一个ObservableMap 。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyObjectProperty<T>
      超类为所有只读属性包装任意 Object 。
      class  ReadOnlyObjectPropertyBase<T>
      所有只读属性的基类包装任意 Object 。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlySetProperty<E>
      超类为所有只读属性包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyStringProperty
      所有只读属性的超类包装一个 String 。
      class  ReadOnlyStringPropertyBase
      所有只读属性的基类包装一个 String 。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个包含ObservableSet的Property的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
      class  SimpleObjectProperty<T>
      该类提供了一个包含任意Object的Property的完整实现。
      class  SimpleSetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
      class  SimpleStringProperty
      这个类提供了一个Property的全面实现，包装了一个String值。
      class  StringProperty
      该类提供了一个包含 String值的Property的全面实现。
      class  StringPropertyBase
      StringPropertyBase类是一个包含 String值的属性的基类。

    • Uses of ObservableObjectValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement ObservableObjectValue
      Modifier and Type Class 描述
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty提供了类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间的适配器。
      class  JavaBeanStringProperty
      一个 JavaBeanStringProperty提供类型的普通的Java Bean属性之间的适配器 String和一个JavaFX StringProperty 。
      class  ReadOnlyJavaBeanObjectProperty<T>
      A ReadOnlyJavaBeanObjectProperty在常规的只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanStringProperty
      A ReadOnlyJavaBeanStringProperty在类型为 String的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。

    • Uses of ObservableObjectValue in javafx.beans.value

      Subinterfaces of ObservableObjectValue in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableListValue<E>
      一个可观察的参考ObservableList 。
      interface  ObservableMapValue<K,V>
      一个可观察的参考一个ObservableMap 。
      interface  ObservableSetValue<E>
      一个可观察的参考ObservableSet 。
      interface  ObservableStringValue
      一个可观察的字符串值。

    • Uses of ObservableObjectValue in javafx.css

      Classes in javafx.css that implement ObservableObjectValue
      Modifier and Type Class 描述
      class  SimpleStyleableObjectProperty<T>
      该课程扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of ObservableObjectValue in javafx.scene.control

      Subinterfaces of ObservableObjectValue in javafx.scene.control
      Modifier and Type 接口 描述
      protected static interface  TextInputControl.Content
      界面表示文本输入的内容。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableSetValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableSetValue

  • Packages that use ObservableSetValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of ObservableSetValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableSetValue
      Modifier and Type Class 描述
      class  SetBinding<E>
      提供实现ObservableSet的Binding所需的大部分功能的基类。
      class  SetExpression<E>
      SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding with parameters of type ObservableSetValue
      Modifier and Type 方法 描述
      static <E> SetExpression<E> SetExpression.setExpression​(ObservableSetValue<E> value)
      返回一个SetExpression的SetExpression 。

    • Uses of ObservableSetValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableSetValue
      Modifier and Type Class 描述
      class  ReadOnlySetProperty<E>
      所有readonly属性的超类包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleSetProperty<E>
      该类提供了一个Property的全面实现，包装了一个ObservableSet 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableStringValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableStringValue

  • Packages that use ObservableStringValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ObservableStringValue in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableStringValue
      Modifier and Type Class 描述
      class  StringBinding
      提供实现String的String所需的大部分功能的基类。
      class  StringExpression
      StringExpression是一个ObservableStringValue加上额外的便利方法来生成流畅的风格的绑定。
      Methods in javafx.beans.binding with parameters of type ObservableStringValue
      Modifier and Type 方法 描述
      static BooleanBinding Bindings.equal​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。
      static BooleanBinding Bindings.equal​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等。
      static BooleanBinding Bindings.equalIgnoreCase​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue等于恒定值忽略大小写。
      static BooleanBinding Bindings.equalIgnoreCase​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值忽略大小写，则保留true 。
      static BooleanBinding Bindings.equalIgnoreCase​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等忽略大小写。
      static BooleanBinding Bindings.greaterThan​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果一个常量值的值大于true的值，则该值保持为true 。
      static BooleanBinding Bindings.greaterThan​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue比恒定值。
      static BooleanBinding Bindings.greaterThan​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果第一个ObservableStringValue的值大于第二个值，则保留true 。
      BooleanBinding StringExpression.greaterThan​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression大于另一个ObservableStringValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableStringValue 。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue大于或等于恒定值。
      static BooleanBinding Bindings.greaterThanOrEqual​(ObservableStringValue op1, ObservableStringValue op2)
      创建新的BooleanBinding ，如果第一个ObservableStringValue的值大于或等于第二个值，则保留true 。
      BooleanBinding StringExpression.greaterThanOrEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression大于或等于另一个ObservableStringValue 。
      static BooleanBinding Bindings.isEmpty​(ObservableStringValue op)
      创建一个新的BooleanBinding ，如果ObservableStringValue的值为空，则保留true 。
      BooleanBinding StringExpression.isEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue相等，则保留true 。
      BooleanBinding StringExpression.isEqualToIgnoreCase​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue是相等的忽略大小写，则保留true 。
      static BooleanBinding Bindings.isNotEmpty​(ObservableStringValue op)
      创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不是空的。
      BooleanBinding StringExpression.isNotEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue不相等，则保留true 。
      BooleanBinding StringExpression.isNotEqualToIgnoreCase​(ObservableStringValue other)
      创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue不等于忽略大小写，则保留true 。
      static IntegerBinding Bindings.length​(ObservableStringValue op)
      创建一个新的IntegerBinding ，其长度为ObservableStringValue 。
      static BooleanBinding Bindings.lessThan​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableStringValue 。
      static BooleanBinding Bindings.lessThan​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding持有true如果一个值ObservableStringValue小于一个恒定值。
      static BooleanBinding Bindings.lessThan​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果第一个ObservableStringValue的值小于第二个值，则保留true 。
      BooleanBinding StringExpression.lessThan​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression小于另一个ObservableStringValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableStringValue 。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding保持true如果a的值ObservableStringValue小于或等于恒定值。
      static BooleanBinding Bindings.lessThanOrEqual​(ObservableStringValue op1, ObservableStringValue op2)
      创建新的BooleanBinding ，如果第一个ObservableStringValue的值小于或等于第二个值，则保留true 。
      BooleanBinding StringExpression.lessThanOrEqualTo​(ObservableStringValue other)
      创建一个新的BooleanBinding持有true如果StringExpression小于或等于另一个ObservableStringValue 。
      static BooleanBinding Bindings.notEqual​(String op1, ObservableStringValue op2)
      如果一个ObservableStringValue的值不等于一个恒定值，则创建一个新的BooleanBinding ，其中包含true 。
      static BooleanBinding Bindings.notEqual​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值不等于一个常量值，则保留true 。
      static BooleanBinding Bindings.notEqual​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不相等。
      static BooleanBinding Bindings.notEqualIgnoreCase​(String op1, ObservableStringValue op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值不等于一个恒定值忽略大小写，则保留true 。
      static BooleanBinding Bindings.notEqualIgnoreCase​(ObservableStringValue op1, String op2)
      创建一个新的BooleanBinding ，如果一个ObservableStringValue的值不等于一个恒定值忽略大小写，则保留true 。
      static BooleanBinding Bindings.notEqualIgnoreCase​(ObservableStringValue op1, ObservableStringValue op2)
      创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不等于忽略大小写。
      StringBinding When.StringConditionBuilder.otherwise​(ObservableStringValue otherwiseValue)
      定义ObservableStringValue如果条件为false ，则三元表达式返回哪个值。
      When.StringConditionBuilder When.then​(ObservableStringValue thenValue)
      定义ObservableStringValue如果条件为true则由三元表达式返回哪个值。

    • Uses of ObservableStringValue in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableStringValue
      Modifier and Type Class 描述
      class  ReadOnlyStringProperty
      超类为所有只读属性包装一个 String 。
      class  ReadOnlyStringPropertyBase
      所有只读属性的基类包装一个 String 。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleStringProperty
      该类提供了一个包含 String值的Property的完整实现。
      class  StringProperty
      这个类提供了一个Property包装一个String值的全面实现。
      class  StringPropertyBase
      StringPropertyBase类是包装一个 String值的属性的基类。

    • Uses of ObservableStringValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement ObservableStringValue
      Modifier and Type Class 描述
      class  JavaBeanStringProperty
      A JavaBeanStringProperty在类型为 String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanStringProperty
      A ReadOnlyJavaBeanStringProperty在类型为 String的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。

    • Uses of ObservableStringValue in javafx.css

      Classes in javafx.css that implement ObservableStringValue
      Modifier and Type Class 描述
      class  SimpleStyleableStringProperty
      这个类扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。

    • Uses of ObservableStringValue in javafx.scene.control

      Subinterfaces of ObservableStringValue in javafx.scene.control
      Modifier and Type 接口 描述
      protected static interface  TextInputControl.Content
      Interface representing a text input's content.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.ObservableValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.ObservableValue

  • Packages that use ObservableValue
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及许多实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。

    • Uses of ObservableValue in javafx.beans.binding

      Subinterfaces of ObservableValue in javafx.beans.binding
      Modifier and Type 接口 描述
      interface  Binding<T>
      A Binding计算取决于一个或多个来源的值。
      interface  NumberBinding
      标记界面，用于标记所有绑定数字值的绑定。
      interface  NumberExpression
      NumberExpression是一个ObservableNumberValue加上额外的便利方法，以流利的风格生成绑定。
      Classes in javafx.beans.binding that implement ObservableValue
      Modifier and Type Class 描述
      class  BooleanBinding
      提供实现boolean的boolean所需的大部分功能的基类。
      class  BooleanExpression
      BooleanExpression是一个ObservableBooleanValue加上额外的便利方法，以流利的风格生成绑定。
      class  DoubleBinding
      提供实现double值Binding所需的大部分功能的基类。
      class  DoubleExpression
      DoubleExpression是一个ObservableDoubleValue加上额外的便利方法，以流利的风格生成绑定。
      class  FloatBinding
      基类提供实现float的float所需的大部分功能。
      class  FloatExpression
      FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。
      class  IntegerBinding
      提供了实现int的int所需的大部分功能的基类。
      class  IntegerExpression
      IntegerExpression是一个ObservableIntegerValue，另外还有一种方便的方法来生成流畅的绑定。
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      class  ListExpression<E>
      ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。
      class  LongBinding
      提供实现long的long所需的大部分功能的基类。
      class  LongExpression
      LongExpression是一个ObservableLongValue加上其他便利方法，以流利的方式生成绑定。
      class  MapBinding<K,V>
      提供实现ObservableMap的Binding所需的大部分功能的基类。
      class  MapExpression<K,V>
      MapExpression是一个ObservableMapValue加上额外的便利方法，以流利的风格生成绑定。
      class  NumberExpressionBase
      NumberExpressionBase包含以流畅样式生成绑定的方便方法，这对于所有NumberExpression子类都是常见的。
      class  ObjectBinding<T>
      提供实现Object的Object所需的大部分功能的基类。
      class  ObjectExpression<T>
      ObjectExpression是一个ObservableObjectValue加上其他便利方法，以流利的风格生成绑定。
      class  SetBinding<E>
      提供实现ObservableSet的Binding所需的大部分功能的基类。
      class  SetExpression<E>
      SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的方式生成绑定。
      class  StringBinding
      提供实现String的String所需的大部分功能的基类。
      class  StringExpression
      StringExpression是一个ObservableStringValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding with parameters of type ObservableValue
      Modifier and Type 方法 描述
      static BooleanExpression BooleanExpression.booleanExpression​(ObservableValue<Boolean> value)
      返回一个BooleanExpression的BooleanExpression 。
      static <K> BooleanBinding Bindings.booleanValueAt​(ObservableMap<K,Boolean> op, ObservableValue<? extends K> key)
      创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
      static StringExpression Bindings.convert​(ObservableValue<?> observableValue)
      返回一个StringExpression ，其中包含一个ObservableValue 。
      static <T extends Number>
      DoubleExpression             		DoubleExpression.doubleExpression​(ObservableValue<T> value)
      返回一个DoubleExpression ，其中包含一个ObservableValue 。
      static <K> DoubleBinding Bindings.doubleValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
      static <T extends Number>
      FloatExpression             		FloatExpression.floatExpression​(ObservableValue<T> value)
      返回一个FloatExpression ，其中包含一个ObservableValue 。
      static <K> FloatBinding Bindings.floatValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
      static <T extends Number>
      IntegerExpression             		IntegerExpression.integerExpression​(ObservableValue<T> value)
      返回一个IntegerExpression的IntegerExpression 。
      static <K> IntegerBinding Bindings.integerValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。
      static <T extends Number>
      LongExpression             		LongExpression.longExpression​(ObservableValue<T> value)
      返回一个LongExpression的LongExpression 。
      static <K> LongBinding Bindings.longValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的LongBinding ，其中包含ObservableMap中的特定键的映射 。
      static <T> ObjectBinding<T> Bindings.select​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static BooleanBinding Bindings.selectBoolean​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static DoubleBinding Bindings.selectDouble​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static FloatBinding Bindings.selectFloat​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static IntegerBinding Bindings.selectInteger​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static LongBinding Bindings.selectLong​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static StringBinding Bindings.selectString​(ObservableValue<?> root, String... steps)
      创建用于获取成员的绑定，如 a.b.c 。
      static StringExpression StringExpression.stringExpression​(ObservableValue<?> value)
      返回一个StringExpression ，其中包含一个ObservableValue 。
      static <K> StringBinding Bindings.stringValueAt​(ObservableMap<K,String> op, ObservableValue<? extends K> key)
      创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。
      static <K,V> ObjectBinding<V> Bindings.valueAt​(ObservableMap<K,V> op, ObservableValue<? extends K> key)
      创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
      ObjectBinding<V> MapExpression.valueAt​(ObservableValue<K> key)
      创建一个包含指定键的映射的新的ObjectBinding 。

    • Uses of ObservableValue in javafx.beans.property

      Subinterfaces of ObservableValue in javafx.beans.property
      Modifier and Type 接口 描述
      interface  Property<T>
      通用接口，定义所有（可写）属性共有的方法，与其类型无关。
      interface  ReadOnlyProperty<T>
      通用接口，用于定义独立于其类型的所有可读属性通用的方法。
      Classes in javafx.beans.property that implement ObservableValue
      Modifier and Type Class 描述
      class  BooleanProperty
      该类提供了一个包含 boolean值的Property的完整实现。
      class  BooleanPropertyBase
      BooleanPropertyBase类是包含 boolean值的属性的基类。
      class  DoubleProperty
      该类定义了一个double包装double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  FloatProperty
      这个类定义了一个Property包裹一个float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  IntegerProperty
      这个类定义了一个包含 int值的int 。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  ListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装一个ObservableList的属性的基类。
      class  LongProperty
      此类定义了一个Property包装long值。
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  MapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装一个ObservableMap的属性的基类。
      class  ObjectProperty<T>
      这个类提供了一个包含任意Object的Property的完整实现。
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyBooleanProperty
      超类为所有只读属性包装一个 boolean 。
      class  ReadOnlyBooleanPropertyBase
      所有只读属性的基类包装一个 boolean 。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyDoubleProperty
      超类为所有只读属性包装一个 double 。
      class  ReadOnlyDoublePropertyBase
      所有只读属性的基类包装一个 double 。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyFloatProperty
      超类为所有只读属性包装一个 float 。
      class  ReadOnlyFloatPropertyBase
      所有只读属性的基类包装一个 float 。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyIntegerProperty
      超类为所有只读属性包装一个 int 。
      class  ReadOnlyIntegerPropertyBase
      所有只读属性的基类包装一个 int 。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyListProperty<E>
      所有readonly属性的超类包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyLongProperty
      超类为所有只读属性包装一个 long 。
      class  ReadOnlyLongPropertyBase
      所有只读属性的基类包装一个 long 。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyMapProperty<K,V>
      所有readonly属性的超类包装一个ObservableMap 。
      class  ReadOnlyMapPropertyBase<K,V>
      所有只读属性的基类包装一个ObservableMap 。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyObjectProperty<T>
      超类为所有只读属性包装任意 Object 。
      class  ReadOnlyObjectPropertyBase<T>
      所有只读属性的基类包装任意 Object 。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlySetProperty<E>
      超类为所有只读属性包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyStringProperty
      超类为所有只读属性包装一个 String 。
      class  ReadOnlyStringPropertyBase
      所有只读属性的基类包装一个 String 。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleBooleanProperty
      该类提供了一个包含 boolean值的Property的完整实现。
      class  SimpleDoubleProperty
      该类提供了一个包含 double值的Property的完整实现。
      class  SimpleFloatProperty
      该类提供了一个包含 float值的Property的完整实现。
      class  SimpleIntegerProperty
      该类提供了一个包含 int值的Property的完整实现。
      class  SimpleListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  SimpleLongProperty
      该类提供了一个包含 long值的Property的完整实现。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
      class  SimpleObjectProperty<T>
      该类提供了一个包含任意Object的Property的完整实现。
      class  SimpleSetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
      class  SimpleStringProperty
      该类提供了一个包含 String值的Property的完整实现。
      class  StringProperty
      该类提供了一个包含 String值的Property的完整实现。
      class  StringPropertyBase
      StringPropertyBase类是包含 String值的属性的基类。
      Methods in javafx.beans.property with parameters of type ObservableValue
      Modifier and Type | 方法 | 描述
      void BooleanPropertyBase.bind​(ObservableValue<? extends Boolean> rawObservable)
      为此创建一个单向绑定 Property 。
      void DoublePropertyBase.bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      void FloatPropertyBase.bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      void IntegerPropertyBase.bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      void | ListPropertyBase.bind​(ObservableValue<? extends ObservableList<E>> newObservable)
      void LongPropertyBase.bind​(ObservableValue<? extends Number> rawObservable)
      为此 Property创建一个单向绑定。
      void | MapPropertyBase.bind​(ObservableValue<? extends ObservableMap<K,V>> newObservable)
      void ObjectPropertyBase.bind​(ObservableValue<? extends T> newObservable)
      为此创建一个单向绑定 Property 。
      void Property.bind​(ObservableValue<? extends T> observable)
      为此 Property创建一个单向绑定。
      void | SetPropertyBase.bind​(ObservableValue<? extends ObservableSet<E>> newObservable)
      void StringPropertyBase.bind​(ObservableValue<? extends String> newObservable)
      为此 Property创建一个单向绑定。

    • Uses of ObservableValue in javafx.beans.property.adapter

      Subinterfaces of ObservableValue in javafx.beans.property.adapter
      Modifier and Type 接口 描述
      interface  JavaBeanProperty<T>
      JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
      interface  ReadOnlyJavaBeanProperty<T>
      JavaBeanProperty是只读Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
      Classes in javafx.beans.property.adapter that implement ObservableValue
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在 boolean或 Boolean的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在 long或 Long之间的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  JavaBeanObjectProperty<T>
      一个 JavaBeanObjectProperty提供类型的普通的Java Bean属性之间的适配器 T和一个JavaFX ObjectProperty<T> 。
      class  JavaBeanStringProperty
      A JavaBeanStringProperty在类型为 String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanBooleanProperty
      A ReadOnlyJavaBeanBooleanProperty在 boolean或 Boolean之间的常规只读Java Bean属性和JavaFX ReadOnlyBooleanProperty提供了一个适配器。
      class  ReadOnlyJavaBeanDoubleProperty
      A ReadOnlyJavaBeanDoubleProperty在 double或 Double之间的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanFloatProperty
      A ReadOnlyJavaBeanFloatProperty在 float或 Float之间的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanIntegerProperty
      A ReadOnlyJavaBeanIntegerProperty在 int或 Integer之间的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty提供了一个适配器。
      class  ReadOnlyJavaBeanLongProperty
      A ReadOnlyJavaBeanLongProperty在常规的只读Java Bean属性类型为 long或 Long和JavaFX ReadOnlyLongProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanObjectProperty<T>
      A ReadOnlyJavaBeanObjectProperty在常规的只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间提供了一个适配器。
      class  ReadOnlyJavaBeanStringProperty
      A ReadOnlyJavaBeanStringProperty在类型为 String的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。
      Methods in javafx.beans.property.adapter with parameters of type ObservableValue
      Modifier and Type 方法 描述
      void JavaBeanBooleanProperty.bind​(ObservableValue<? extends Boolean> observable)
      为此创建一个单向绑定 Property 。
      void JavaBeanDoubleProperty.bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      void JavaBeanFloatProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void JavaBeanIntegerProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void JavaBeanLongProperty.bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      void JavaBeanObjectProperty.bind​(ObservableValue<? extends T> observable)
      为此创建一个单向绑定 Property 。
      void JavaBeanStringProperty.bind​(ObservableValue<? extends String> observable)
      为此 Property创建一个单向绑定。

    • Uses of ObservableValue in javafx.beans.value

      Subinterfaces of ObservableValue in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableBooleanValue
      一个可观察的布尔值。
      interface  ObservableDoubleValue
      一个可观察到的双重值。
      interface  ObservableFloatValue
      一个可观察的浮点值。
      interface  ObservableIntegerValue
      一个可观察的整数值。
      interface  ObservableListValue<E>
      可以参考一个ObservableList 。
      interface  ObservableLongValue
      一个可观察的长期价值。
      interface  ObservableMapValue<K,V>
      可以参考一个ObservableMap 。
      interface  ObservableNumberValue
      所有子接口的公共接口为ObservableValue ，其中包含一个数字。
      interface  ObservableObjectValue<T>
      一个可观察的类型的 Object值。
      interface  ObservableSetValue<E>
      一个可观察的参考ObservableSet 。
      interface  ObservableStringValue
      一个可观察的字符串值。
      Classes in javafx.beans.value that implement ObservableValue
      Modifier and Type Class 描述
      class  ObservableValueBase<T>
      一个方便类创建ObservableValue的实现。
      Methods in javafx.beans.value with parameters of type ObservableValue
      Modifier and Type 方法 描述
      void ChangeListener.changed​(ObservableValue<? extends T> observable, T oldValue, T newValue)
      该方法需要通过 ChangeListener的实现来提供。
      void WeakChangeListener.changed​(ObservableValue<? extends T> observable, T oldValue, T newValue)
      该方法需要通过 ChangeListener的实现来提供。

    • Uses of ObservableValue in javafx.css

      Classes in javafx.css that implement ObservableValue
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      这个类扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableDoubleProperty
      这个类扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      这个类扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableIntegerProperty
      这个类扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableLongProperty
      这个类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableObjectProperty<T>
      这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
      Methods in javafx.css with parameters of type ObservableValue
      Modifier and Type 方法 描述
      void StyleableBooleanProperty.bind​(ObservableValue<? extends Boolean> observable)
      为此 Property创建一个单向绑定。
      void StyleableDoubleProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void StyleableFloatProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void StyleableIntegerProperty.bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      void StyleableLongProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void StyleableObjectProperty.bind​(ObservableValue<? extends T> observable)
      为此创建一个单向绑定 Property 。
      void StyleableStringProperty.bind​(ObservableValue<? extends String> observable)
      为此创建一个单向绑定 Property 。

    • Uses of ObservableValue in javafx.scene.control

      Subinterfaces of ObservableValue in javafx.scene.control
      Modifier and Type 接口 描述
      protected static interface  TextInputControl.Content
      界面表示文本输入的内容。
      Methods in javafx.scene.control that return ObservableValue
      Modifier and Type 方法 描述
      ObservableValue<T> TableColumn.getCellObservableValue​(int index)
      尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。
      ObservableValue<T> TableColumn.getCellObservableValue​(S item)
      尝试返回给定项目（其类型为S）的ObservableValue <T>。
      abstract ObservableValue<T> TableColumnBase.getCellObservableValue​(int index)
      尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。
      abstract ObservableValue<T> TableColumnBase.getCellObservableValue​(S item)
      尝试返回给定项目（其类型为S）的ObservableValue <T>。
      ObservableValue<T> TreeTableColumn.getCellObservableValue​(int index)
      尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。
      ObservableValue<T> TreeTableColumn.getCellObservableValue​(TreeItem<S> item)
      尝试返回给定项目（其类型为S）的ObservableValue <T>。
      Methods in javafx.scene.control that return types with arguments of type ObservableValue
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> TableColumn.cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。
      ObjectProperty<Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> TreeTableColumn.cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。
      Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> TableColumn.getCellValueFactory​()
      获取属性cellValueFactory的值。
      Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> TreeTableColumn.getCellValueFactory​()
      获取属性cellValueFactory的值。
      protected Consumer<ObservableValue<?>> SkinBase.unregisterChangeListeners​(ObservableValue<?> property)
      取消注册已使用 SkinBase.registerChangeListener(ObservableValue, Consumer)注册的所有更改侦听器的给定属性。
      Methods in javafx.scene.control with parameters of type ObservableValue
      Modifier and Type 方法 描述
      protected void SkinBase.registerChangeListener​(ObservableValue<?> property, Consumer<ObservableValue<?>> consumer)
      子类可以调用此方法来注册他们想要监听给定属性的属性更改事件。
      protected Consumer<ObservableValue<?>> SkinBase.unregisterChangeListeners​(ObservableValue<?> property)
      取消注册已使用 SkinBase.registerChangeListener(ObservableValue, Consumer)注册的所有更改侦听器的给定属性。
      Method parameters in javafx.scene.control with type arguments of type ObservableValue
      Modifier and Type 方法 描述
      protected void SkinBase.registerChangeListener​(ObservableValue<?> property, Consumer<ObservableValue<?>> consumer)
      子类可以调用此方法来注册他们想要监听给定属性的属性更改事件。
      void TableColumn.setCellValueFactory​(Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
      设置属性cellValueFactory的值。
      void TreeTableColumn.setCellValueFactory​(Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
      设置属性cellValueFactory的值。

    • Uses of ObservableValue in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return ObservableValue
      Modifier and Type | 方法 | 描述
      ObservableValue<T> | MapValueFactory.call​(TableColumn.CellDataFeatures<Map,T> cdf)
      ObservableValue<T> PropertyValueFactory.call​(TableColumn.CellDataFeatures<S,T> param)
      call方法在需要时被调用，并且被赋予类型为P的单个参数，需要返回类型为R的对象。
      ObservableValue<T> TreeItemPropertyValueFactory.call​(TreeTableColumn.CellDataFeatures<S,T> param)
      call方法在需要时被调用，并且被赋予类型为P的单个参数，并且要求返回类型为R的对象。
      Methods in javafx.scene.control.cell that return types with arguments of type ObservableValue
      Modifier and Type 方法 描述
      Callback<T,ObservableValue<Boolean>> CheckBoxListCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<Integer,ObservableValue<Boolean>> CheckBoxTableCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<TreeItem<T>,ObservableValue<Boolean>> CheckBoxTreeCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<Integer,ObservableValue<Boolean>> CheckBoxTreeTableCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<T,ObservableValue<Boolean>>> CheckBoxListCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<TreeItem<T>,ObservableValue<Boolean>>> CheckBoxTreeCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTreeTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      Method parameters in javafx.scene.control.cell with type arguments of type ObservableValue
      Modifier and Type 方法 描述
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建用于ListView控件的单元格工厂。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TableColumn电池厂的电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      void CheckBoxListCell.setSelectedStateCallback​(Callback<T,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTableCell.setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTreeCell.setSelectedStateCallback​(Callback<TreeItem<T>,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTreeTableCell.setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      Constructor parameters in javafx.scene.control.cell with type arguments of type ObservableValue
      Constructor 描述
      CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxListCell。
      CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxListCell。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxTableCell与自定义Callback检索给定单元格索引的ObservableValue。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个带有自定义字符串转换器的CheckBoxTableCell。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个CheckBoxTreeCell用于通过单元格工厂的TreeView控件。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个CheckBoxTreeCell用于通过单元格工厂的TreeView控件。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      使用自定义的Callback创建一个默认的CheckBoxTreeTableCell，以检索给定单元格索引的ObservableValue。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxTreeTableCell。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableBooleanValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableBooleanValue

  • Packages that use WritableBooleanValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of WritableBooleanValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableBooleanValue
      Modifier and Type Class 描述
      class  BooleanProperty
      该类提供了一个包含 boolean值的Property的完整实现。
      class  BooleanPropertyBase
      BooleanPropertyBase类是包含 boolean值的属性的基类。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleBooleanProperty
      该类提供了一个包含 boolean值的Property的完整实现。

    • Uses of WritableBooleanValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement WritableBooleanValue
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。

    • Uses of WritableBooleanValue in javafx.css

      Classes in javafx.css that implement WritableBooleanValue
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      该课程扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableDoubleValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableDoubleValue

  • Packages that use WritableDoubleValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of WritableDoubleValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableDoubleValue
      Modifier and Type Class 描述
      class  DoubleProperty
      这个类定义了一个Property包装double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含一个 double值的属性的基类。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      这个类提供了一个包含 double值的Property的全面实现。

    • Uses of WritableDoubleValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement WritableDoubleValue
      Modifier and Type Class 描述
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在类型为 double或 Double的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。

    • Uses of WritableDoubleValue in javafx.css

      Classes in javafx.css that implement WritableDoubleValue
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableFloatValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableFloatValue

  • Packages that use WritableFloatValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of WritableFloatValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableFloatValue
      Modifier and Type Class 描述
      class  FloatProperty
      此类定义了一个Property包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleFloatProperty
      这个类提供了一个包含 float值的Property的全面实现。

    • Uses of WritableFloatValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement WritableFloatValue
      Modifier and Type Class 描述
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。

    • Uses of WritableFloatValue in javafx.css

      Classes in javafx.css that implement WritableFloatValue
      Modifier and Type Class 描述
      class  SimpleStyleableFloatProperty
      这个类扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableIntegerValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableIntegerValue

  • Packages that use WritableIntegerValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of WritableIntegerValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableIntegerValue
      Modifier and Type Class 描述
      class  IntegerProperty
      该类定义了一个Property包装int值。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含一个 int值的属性的基类。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleIntegerProperty
      该类提供了一个包含 int值的Property的完整实现。

    • Uses of WritableIntegerValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement WritableIntegerValue
      Modifier and Type Class 描述
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。

    • Uses of WritableIntegerValue in javafx.css

      Classes in javafx.css that implement WritableIntegerValue
      Modifier and Type Class 描述
      class  SimpleStyleableIntegerProperty
      这个类扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableListValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableListValue

  • Packages that use WritableListValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of WritableListValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableListValue
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个包含ObservableList的Property的完整实现。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleListProperty<E>
      这个类提供了一个包含ObservableList的ObservableList的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableLongValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableLongValue

  • Packages that use WritableLongValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of WritableLongValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableLongValue
      Modifier and Type Class 描述
      class  LongProperty
      这个类定义了一个Property包装long值。
      class  LongPropertyBase
      LongPropertyBase类是包含一个 long值的属性的基类。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleLongProperty
      该类提供了一个包含 long值的Property的全面实现。

    • Uses of WritableLongValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement WritableLongValue
      Modifier and Type Class 描述
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。

    • Uses of WritableLongValue in javafx.css

      Classes in javafx.css that implement WritableLongValue
      Modifier and Type Class 描述
      class  SimpleStyleableLongProperty
      这个类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableMapValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableMapValue

  • Packages that use WritableMapValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。

    • Uses of WritableMapValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableMapValue
      Modifier and Type Class 描述
      class  MapProperty<K,V>
      这个类提供了一个Property包装一个ObservableMap的完整实现。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装ObservableMap的属性的基类。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleMapProperty<K,V>
      这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableNumberValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableNumberValue

  • Packages that use WritableNumberValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of WritableNumberValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableNumberValue
      Modifier and Type Class 描述
      class  DoubleProperty
      这个类定义了一个Property包装double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  FloatProperty
      这个类定义了一个Property包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  IntegerProperty
      这个类定义了一个Property包装int值。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  LongProperty
      此类定义了一个Property包装long值。
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleDoubleProperty
      该类提供了一个包含 double值的Property的全面实现。
      class  SimpleFloatProperty
      这个类提供了一个包含 float值的Property的完整实现。
      class  SimpleIntegerProperty
      该类提供了一个包含 int值的Property的完整实现。
      class  SimpleLongProperty
      该类提供了一个包含 long值的Property的完整实现。

    • Uses of WritableNumberValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement WritableNumberValue
      Modifier and Type Class 描述
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在类型为 double或 Double的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在 float或 Float之间的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在 long或 Long之间的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。

    • Uses of WritableNumberValue in javafx.beans.value

      Subinterfaces of WritableNumberValue in javafx.beans.value
      Modifier and Type 接口 描述
      interface  WritableDoubleValue
      一个可写的双重值。
      interface  WritableFloatValue
      可写浮点值。
      interface  WritableIntegerValue
      一个可写的int值。
      interface  WritableLongValue
      一个可写的长期价值。

    • Uses of WritableNumberValue in javafx.css

      Classes in javafx.css that implement WritableNumberValue
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      这个类扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      这个类扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableIntegerProperty
      该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableLongProperty
      这个类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableObjectValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableObjectValue

  • Packages that use WritableObjectValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义了只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of WritableObjectValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableObjectValue
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  MapProperty<K,V>
      这个类提供了一个包含ObservableMap的Property的全面实现。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包含ObservableMap的属性的基类。
      class  ObjectProperty<T>
      该类提供了一个包含任意Object的Property的完整实现。
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleListProperty<E>
      这个类提供了一个Property包装一个ObservableList的完整实现。
      class  SimpleMapProperty<K,V>
      该类提供了一个Property包装ObservableMap的完整实现。
      class  SimpleObjectProperty<T>
      该类提供了一个包含任意Object的Property的完整实现。
      class  SimpleSetProperty<E>
      这个类提供了一个包含ObservableSet的ObservableSet的完整实现。
      class  SimpleStringProperty
      该类提供了一个包含 String值的Property的完整实现。
      class  StringProperty
      该类提供了一个包含 String值的Property的完整实现。
      class  StringPropertyBase
      StringPropertyBase类是包含 String值的属性的基类。

    • Uses of WritableObjectValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement WritableObjectValue
      Modifier and Type Class 描述
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
      class  JavaBeanStringProperty
      一个 JavaBeanStringProperty提供类型的普通的Java Bean属性之间的适配器 String和一个JavaFX StringProperty 。

    • Uses of WritableObjectValue in javafx.beans.value

      Subinterfaces of WritableObjectValue in javafx.beans.value
      Modifier and Type 接口 描述
      interface  WritableListValue<E>
      可写参考一个ObservableList 。
      interface  WritableMapValue<K,V>
      可写参考一个ObservableMap 。
      interface  WritableSetValue<E>
      可写参考一个ObservableSet 。
      interface  WritableStringValue
      一个可写的字符串。

    • Uses of WritableObjectValue in javafx.css

      Classes in javafx.css that implement WritableObjectValue
      Modifier and Type Class 描述
      class  SimpleStyleableObjectProperty<T>
      这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableSetValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableSetValue

  • Packages that use WritableSetValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

    • Uses of WritableSetValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableSetValue
      Modifier and Type Class 描述
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      该类提供了一个包含ObservableSet的Property的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleSetProperty<E>
      这个类提供了一个包含ObservableSet的ObservableSet的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableStringValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableStringValue

  • Packages that use WritableStringValue
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of WritableStringValue in javafx.beans.property

      Classes in javafx.beans.property that implement WritableStringValue
      Modifier and Type Class 描述
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SimpleStringProperty
      该类提供了一个包含 String值的Property的全面实现。
      class  StringProperty
      该类提供了一个包含 String值的Property的完整实现。
      class  StringPropertyBase
      StringPropertyBase类是包含 String值的属性的基类。

    • Uses of WritableStringValue in javafx.beans.property.adapter

      Classes in javafx.beans.property.adapter that implement WritableStringValue
      Modifier and Type Class 描述
      class  JavaBeanStringProperty
      A JavaBeanStringProperty在类型为 String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。

    • Uses of WritableStringValue in javafx.css

      Classes in javafx.css that implement WritableStringValue
      Modifier and Type Class 描述
      class  SimpleStyleableStringProperty
      这个类扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.beans.value.WritableValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.beans.value.WritableValue

  • Packages that use WritableValue
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of WritableValue in javafx.animation

      Methods in javafx.animation that return WritableValue
      Modifier and Type 方法 描述
      WritableValue<?> KeyValue.getTarget​()
      返回此 KeyValue的目标
      Constructors in javafx.animation with parameters of type WritableValue
      Constructor 描述
      KeyValue​(WritableValue<T> target, T endValue)
      创建一个 KeyValue ，使用 Interpolator.LINEAR 。
      KeyValue​(WritableValue<T> target, T endValue, Interpolator interpolator)
      创建一个 KeyValue 。

    • Uses of WritableValue in javafx.beans.property

      Subinterfaces of WritableValue in javafx.beans.property
      Modifier and Type 接口 描述
      interface  Property<T>
      通用接口，定义所有（可写）属性共有的方法，与其类型无关。
      Classes in javafx.beans.property that implement WritableValue
      Modifier and Type Class 描述
      class  BooleanProperty
      该类提供了一个包含 boolean值的Property的完整实现。
      class  BooleanPropertyBase
      BooleanPropertyBase类是包含 boolean值的属性的基类。
      class  DoubleProperty
      这个类定义了一个Property包裹一个double值。
      class  DoublePropertyBase
      DoublePropertyBase类是包含 double值的属性的基类。
      class  FloatProperty
      这个类定义了一个Property包装float值。
      class  FloatPropertyBase
      FloatPropertyBase类是包含 float值的属性的基类。
      class  IntegerProperty
      这个类定义了一个包含 int值的int 。
      class  IntegerPropertyBase
      IntegerPropertyBase类是包含 int值的属性的基类。
      class  ListProperty<E>
      这个类提供了一个包含ObservableList的Property的完整实现。
      class  ListPropertyBase<E>
      ListPropertyBase类是一个包装ObservableList的属性的基类。
      class  LongProperty
      这个类定义了一个Property包裹一个long值。
      class  LongPropertyBase
      LongPropertyBase类是包含 long值的属性的基类。
      class  MapProperty<K,V>
      这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装ObservableMap的属性的基类。
      class  ObjectProperty<T>
      这个类提供了一个包含任意Object的Property的完整实现。
      class  ObjectPropertyBase<T>
      ObjectPropertyBase类是包含任意 Object的属性的基类。
      class  ReadOnlyBooleanWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyDoubleWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyFloatWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyIntegerWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyLongWrapper
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyObjectWrapper<T>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlyStringWrapper
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个包含ObservableSet的Property的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleBooleanProperty
      该类提供了一个包含 boolean值的Property的完整实现。
      class  SimpleDoubleProperty
      该类提供了一个包含 double值的Property的完整实现。
      class  SimpleFloatProperty
      这个类提供了一个包含 float值的Property的完整实现。
      class  SimpleIntegerProperty
      该类提供了一个包含 int值的Property的全面实现。
      class  SimpleListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  SimpleLongProperty
      这个类提供了一个包含 long值的Property的全面实现。
      class  SimpleMapProperty<K,V>
      这个类提供了一个包含ObservableMap的ObservableMap的完整实现。
      class  SimpleObjectProperty<T>
      这个类提供了一个Property的全面实现，包装任意的Object 。
      class  SimpleSetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
      class  SimpleStringProperty
      该类提供了一个包含 String值的Property的完整实现。
      class  StringProperty
      该类提供了一个包含 String值的Property的全面实现。
      class  StringPropertyBase
      StringPropertyBase类是包含 String值的属性的基类。

    • Uses of WritableValue in javafx.beans.property.adapter

      Subinterfaces of WritableValue in javafx.beans.property.adapter
      Modifier and Type 接口 描述
      interface  JavaBeanProperty<T>
      JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
      Classes in javafx.beans.property.adapter that implement WritableValue
      Modifier and Type Class 描述
      class  JavaBeanBooleanProperty
      A JavaBeanBooleanProperty在类型为 boolean或 Boolean的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。
      class  JavaBeanDoubleProperty
      A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。
      class  JavaBeanFloatProperty
      A JavaBeanFloatProperty在类型为 float或 Float的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。
      class  JavaBeanIntegerProperty
      A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
      class  JavaBeanLongProperty
      A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
      class  JavaBeanObjectProperty<T>
      A JavaBeanObjectProperty在 T类型的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。
      class  JavaBeanStringProperty
      A JavaBeanStringProperty在类型为 String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。

    • Uses of WritableValue in javafx.beans.value

      Subinterfaces of WritableValue in javafx.beans.value
      Modifier and Type 接口 描述
      interface  WritableBooleanValue
      一个可写布尔值。
      interface  WritableDoubleValue
      一个可写的双重值。
      interface  WritableFloatValue
      可写浮点值。
      interface  WritableIntegerValue
      一个可写的int值。
      interface  WritableListValue<E>
      对ObservableList的可写参考。
      interface  WritableLongValue
      一个可写的长期价值。
      interface  WritableMapValue<K,V>
      可写参考一个ObservableMap 。
      interface  WritableNumberValue
      标记接口，标记包含数字的所有子接口WritableValue 。
      interface  WritableObjectValue<T>
      可写类型值。
      interface  WritableSetValue<E>
      可写参考一个ObservableSet 。
      interface  WritableStringValue
      一个可写的字符串。

    • Uses of WritableValue in javafx.css

      Subinterfaces of WritableValue in javafx.css
      Modifier and Type 接口 描述
      interface  StyleableProperty<T>
      StyleableProperty允许一个 javafx.beans.property从CSS样式。
      Classes in javafx.css that implement WritableValue
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      该课程扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableDoubleProperty
      这个类扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      该课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableIntegerProperty
      该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableLongProperty
      该课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableObjectProperty<T>
      该课程扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableObjectProperty<T>
      该类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ArrayChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface ArrayChangeListener<T extends ObservableArray<T>>

  • public interface ArrayChangeListener<T extends ObservableArray<T>>
    接收ObservableArray更改通知的接口。
    从以下版本开始：
    JavaFX 8.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void onChanged​(T observableArray, boolean sizeChanged, int from, int to)
      在对ObservableArray进行了更改后调用。

    • 方法详细信息

      • onChanged

        void onChanged​(T observableArray,
               boolean sizeChanged,
               int from,
               int to)
        在对ObservableArray进行了更改后调用。
        参数
        observableArray - 更改的数组
        sizeChanged - 表示数组的大小已更改
        from - 与变更相关的间隔的开始（包括）
        to - 与变更相关的间隔的结束（排他）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FXCollections (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class FXCollections

  • java.lang.Object
    • javafx.collections.FXCollections

  • public class FXCollections
extends Object
    由静态方法组成的实用程序类，它们是java.util.Collections方法的1：1。

    包装方法（如synchronizedObservableList或emptyObservableList）与Collections中的方法具有完全相同的功能，除了它们返回ObservableList，因此适用于在输入上需要ObservableList的方法。

    这里的效用方法主要是出于性能原因。 所有方法的优化方式是仅产生有限数量的通知。 另一方面，java.util.Collections方法可能会多次在ObservableList上调用“修改方法”，从而产生一些通知。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static <E> ObservableList<E> checkedObservableList​(ObservableList<E> list, Class<E> type)
      在提供的可观察列表之上创建并返回一个类型安全的包装器。
      static <K,V> ObservableMap<K,V> checkedObservableMap​(ObservableMap<K,V> map, Class<K> keyType, Class<V> valueType)
      在提供的可观察地图的顶部创建并返回类型安全的包装器。
      static <E> ObservableSet<E> checkedObservableSet​(ObservableSet<E> set, Class<E> type)
      在提供的可观察集之上创建并返回一个类型安全的包装器。
      static <E> ObservableList<E> concat​(ObservableList<E>... lists)
      将更多可观察的列表连接成一个。
      static <T> void copy​(ObservableList<? super T> dest, List<? extends T> src)
      将元素从src复制到dest。
      static <E> ObservableList<E> emptyObservableList​()
      创建和清空不可修改的可观察列表。
      static <K,V> ObservableMap<K,V> emptyObservableMap​()
      创建和清空不可修改的可观测地图。
      static <E> ObservableSet<E> emptyObservableSet​()
      创建和清空不可修改的可观察集。
      static <T> void fill​(ObservableList<? super T> list, T obj)
      用obj填写提供的列表。
      static <E> ObservableList<E> observableArrayList​()
      创建一个由数组列表支持的新的可观察列表。
      static <E> ObservableList<E> observableArrayList​(E... items)
      创建一个新的可观察数组列表， items添加了 items 。
      static <E> ObservableList<E> observableArrayList​(Collection<? extends E> col)
      创建一个新的可观察数组列表，并向其添加一个集合 col的内容。
      static <E> ObservableList<E> observableArrayList​(Callback<E,Observable[]> extractor)
      创建一个由arraylist支持的新的可观察列表。
      static ObservableFloatArray observableFloatArray​()
      创建一个新的空可观察浮点数组。
      static ObservableFloatArray observableFloatArray​(float... values)
      创建一个新的可观察浮点数组， values设置了 values 。
      static ObservableFloatArray observableFloatArray​(ObservableFloatArray array)
      在给定的 array创建一个新的可观察浮点数列，其中包含元素的副本。
      static <K,V> ObservableMap<K,V> observableHashMap​()
      创建一个由HashMap支持的新的可观察的地图。
      static ObservableIntegerArray observableIntegerArray​()
      创建一个新的空可观察整数数组。
      static ObservableIntegerArray observableIntegerArray​(int... values)
      创建一个新的可观察整数数组，设置 values 。
      static ObservableIntegerArray observableIntegerArray​(ObservableIntegerArray array)
      使用给定的 array的元素副本创建一个新的可观察整数数组。
      static <E> ObservableList<E> observableList​(List<E> list)
      构造由指定列表支持的ObservableList。
      static <E> ObservableList<E> observableList​(List<E> list, Callback<E,Observable[]> extractor)
      构造由指定列表支持的ObservableList。
      static <K,V> ObservableMap<K,V> observableMap​(Map<K,V> map)
      构造由指定地图支持的ObservableMap。
      static <E> ObservableSet<E> observableSet​(E... elements)
      构造一个由包含所有指定元素的HashSet支持的ObservableSet。
      static <E> ObservableSet<E> observableSet​(Set<E> set)
      构造由指定集合支持的ObservableSet。
      static <T> boolean replaceAll​(ObservableList<T> list, T oldVal, T newVal)
      用newVal元素替换列表中的所有oldVal元素。
      static void reverse​(ObservableList list)
      反转列表中的顺序列表中仅发送 一个更改通知。
      static void rotate​(ObservableList list, int distance)
      按距离旋转列表。
      static void shuffle​(ObservableList<?> list)
      随机播放可观察列表中的所有元素。
      static void shuffle​(ObservableList list, Random rnd)
      随机播放可观察列表中的所有元素。
      static <E> ObservableList<E> singletonObservableList​(E e)
      使用单个元素创建一个不可修改的可观察列表。
      static <T extends Comparable<? super T>>
      void             		sort​(ObservableList<T> list)
      对提供的可观察列表进行排序。
      static <T> void sort​(ObservableList<T> list, Comparator<? super T> c)
      使用c比较器对提供的可观察列表进行排序。
      static <E> ObservableList<E> synchronizedObservableList​(ObservableList<E> list)
      在提供的可观察列表之上创建并返回一个同步的包装器。
      static <K,V> ObservableMap<K,V> synchronizedObservableMap​(ObservableMap<K,V> map)
      在提供的可观察地图的顶部创建并返回同步的包装器。
      static <E> ObservableSet<E> synchronizedObservableSet​(ObservableSet<E> set)
      在提供的可观察集合之上创建并返回同步的包装器。
      static <E> ObservableList<E> unmodifiableObservableList​(ObservableList<E> list)
      在提供的可观察列表之上创建并返回不可修改的包装器列表。
      static <K,V> ObservableMap<K,V> unmodifiableObservableMap​(ObservableMap<K,V> map)
      构造一个只读接口到指定的ObservableMap。
      static <E> ObservableSet<E> unmodifiableObservableSet​(ObservableSet<E> set)
      在提供的可观察集合之上创建并返回不可修改的包装器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • observableList

        public static <E> ObservableList<E> observableList​(List<E> list)
        构造由指定列表支持的ObservableList。 ObservableList实例上的突变操作将被报告给在该实例上注册的观察者。
        请注意，直接对基础列表进行的变异操作不会报告给包含它的任何ObservableList的观察者。
        参数类型
        E - 要包装的列表的类型
        参数
        list - 一个具体的List，支持这个ObservableList
        结果
        一个新创建的ObservableList

      • observableList

        public static <E> ObservableList<E> observableList​(List<E> list,
                                                   Callback<E,Observable[]> extractor)
        构造由指定列表支持的ObservableList。 ObservableList实例上的突变操作将被报告给在该实例上注册的观察者。
        请注意，直接对基础列表进行的变异操作不会报告给包含它的任何ObservableList的观察者。
        该列表还通过使用extractor报告其中的元素的突变。 提取器返回的可观察对象（应用于每个列表元素）将被收听以进行更改，并转换为ListChangeListener的“更新”更新。
        参数类型
        E - 要包装的列表的类型
        参数
        list - 一个具体的List，支持这个ObservableList
        extractor - 元素到Observable []转换器
        结果
        一个新创建的ObservableList
        从以下版本开始：
        JavaFX 2.1

      • observableMap

        public static <K,V> ObservableMap<K,V> observableMap​(Map<K,V> map)
        构造由指定地图支持的ObservableMap。 ObservableMap实例上的突变操作将被报告给在该实例上注册的观察者。
        请注意，直接对底层地图进行的变异操作不会报告给包装它的任何ObservableMap的观察者。
        参数类型
        K - 包装密钥的类型
        V - 包装值的类型
        参数
        map - 一个支持该ObservableMap的地图
        结果
        一个新创建的ObservableMap

      • observableSet

        public static <E> ObservableSet<E> observableSet​(Set<E> set)
        构造由指定集合支持的ObservableSet。 ObservableSet实例上的突变操作将被报告给在该实例上注册的观察者。
        请注意，直接对基础集进行的变异操作不会报告给包含它的任何ObservableSet的观察者。
        参数类型
        E - 要包装的列表的类型
        参数
        set - 一个支持此ObservableSet的Set
        结果
        一个新创建的ObservableSet
        从以下版本开始：
        JavaFX 2.1

      • observableSet

        public static <E> ObservableSet<E> observableSet​(E... elements)
        构造一个由包含所有指定元素的HashSet支持的ObservableSet。
        参数类型
        E - 要包装的列表的类型
        参数
        elements - 将添加到返回的ObservableSet中的元素
        结果
        一个新创建的ObservableSet
        从以下版本开始：
        JavaFX 2.1

      • unmodifiableObservableMap

        public static <K,V> ObservableMap<K,V> unmodifiableObservableMap​(ObservableMap<K,V> map)
        构造一个只读接口到指定的ObservableMap。 只有对基础的ObservableMap进行的变异操作才会被报告给在不可修改的实例上注册的观察者。 这允许客户端跟踪地图中的更改，但不允许修改它。
        参数类型
        K - 包装密钥的类型
        V - 包装值的类型
        参数
        map - 要由此接口监视的ObservableMap
        结果
        一个新创建的UnmodifiableObservableMap

      • checkedObservableMap

        public static <K,V> ObservableMap<K,V> checkedObservableMap​(ObservableMap<K,V> map,
                                                            Class<K> keyType,
                                                            Class<V> valueType)
        在提供的可观察地图的顶部创建并返回类型安全的包装器。
        参数类型
        K - 包装密钥的类型
        V - 包装值的类型
        参数
        map - 要包装的可观测地图
        keyType - map允许的密钥的类型
        valueType - map允许持有的值的类型
        结果
        指定地图的动态类型安全视图
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Collections.checkedMap(java.util.Map, java.lang.Class, java.lang.Class)

      • synchronizedObservableMap

        public static <K,V> ObservableMap<K,V> synchronizedObservableMap​(ObservableMap<K,V> map)
        在提供的可观察地图的顶部创建并返回同步的包装器。
        参数类型
        K - 包装密钥的类型
        V - 包装值的类型
        参数
        map - 要在同步的地图中“包裹”的地图。
        结果
        可观测地图的同步版本
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Collections.synchronizedMap(java.util.Map)

      • emptyObservableMap

        public static <K,V> ObservableMap<K,V> emptyObservableMap​()
        创建和清空不可修改的可观测地图。
        参数类型
        K - 包装密钥的类型
        V - 包装值的类型
        结果
        一个空的不可修改的可观测地图
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Collections.emptyMap()

      • observableIntegerArray

        public static ObservableIntegerArray observableIntegerArray​()
        创建一个新的空可观察整数数组。
        结果
        一个新创建的ObservableIntegerArray
        从以下版本开始：
        JavaFX 8.0

      • observableIntegerArray

        public static ObservableIntegerArray observableIntegerArray​(int... values)
        创建一个新的可观察整数数组， values设置了 values 。
        参数
        values - 将在新的可观察整数数组中的值
        结果
        一个新创建的ObservableIntegerArray
        从以下版本开始：
        JavaFX 8.0

      • observableIntegerArray

        public static ObservableIntegerArray observableIntegerArray​(ObservableIntegerArray array)
        使用给定的 array的元素副本创建一个新的可观察整数数组。
        参数
        array - 可复制的整数数组
        结果
        一个新创建的ObservableIntegerArray
        从以下版本开始：
        JavaFX 8.0

      • observableFloatArray

        public static ObservableFloatArray observableFloatArray​()
        创建一个新的空可观察浮点数组。
        结果
        一个新创建的ObservableFloatArray
        从以下版本开始：
        JavaFX 8.0

      • observableFloatArray

        public static ObservableFloatArray observableFloatArray​(float... values)
        创建一个新的可观察的浮点数组， values设置了 values 。
        参数
        values - 将在新的可观察浮点数组中的值
        结果
        一个新创建的ObservableFloatArray
        从以下版本开始：
        JavaFX 8.0

      • observableFloatArray

        public static ObservableFloatArray observableFloatArray​(ObservableFloatArray array)
        在给定的 array创建一个新的可观察浮点数组，其中包含元素的副本。
        参数
        array - 可观察的浮点数组复制
        结果
        一个新创建的ObservableFloatArray
        从以下版本开始：
        JavaFX 8.0

      • observableArrayList

        public static <E> ObservableList<E> observableArrayList​()
        创建一个由数组列表支持的新的可观察列表。
        参数类型
        E - 要包装的列表的类型
        结果
        一个新创建的ObservableList
        另请参见：
        observableList(java.util.List)

      • observableArrayList

        public static <E> ObservableList<E> observableArrayList​(Callback<E,Observable[]> extractor)
        创建一个由arraylist支持的新的可观察列表。 此列表报告元素更新。
        参数类型
        E - 要包装的列表的类型
        参数
        extractor - 元素到Observable []转换器。 监听可观察的对象以查看元素上的变化。
        结果
        一个新创建的ObservableList
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        observableList(java.util.List, javafx.util.Callback)

      • observableArrayList

        public static <E> ObservableList<E> observableArrayList​(E... items)
        创建一个新的可观察数组列表， items添加了 items 。
        参数类型
        E - 要包装的列表的类型
        参数
        items - 将在新的可观察的ArrayList中的项目
        结果
        一个新创建的observableArrayList
        另请参见：
        observableArrayList()

      • observableArrayList

        public static <E> ObservableList<E> observableArrayList​(Collection<? extends E> col)
        创建一个新的可观察数组列表，并向其添加一个集合 col的内容。
        参数类型
        E - 要包装的列表的类型
        参数
        col - 应该将哪些内容添加到observableArrayList的集合
        结果
        一个新创建的observableArrayList

      • observableHashMap

        public static <K,V> ObservableMap<K,V> observableHashMap​()
        创建一个由HashMap支持的新的可观察的地图。
        参数类型
        K - 包装密钥的类型
        V - 包装值的类型
        结果
        一个新创建的可观察的HashMap

      • concat

        public static <E> ObservableList<E> concat​(ObservableList<E>... lists)
        将更多可观察的列表连接成一个。 结果列表将由数组列表支持。
        参数类型
        E - 要包装的列表的类型
        参数
        lists - 列表连接
        结果
        新的可观察数组列表从参数中连接起来

      • unmodifiableObservableList

        public static <E> ObservableList<E> unmodifiableObservableList​(ObservableList<E> list)
        在提供的可观察列表之上创建并返回不可修改的包装器列表。
        参数类型
        E - 要包装的列表的类型
        参数
        list - 要包装的ObservableList
        结果
        一个不可修改的ObserableList包装器
        另请参见：
        Collections.unmodifiableList(java.util.List)

      • checkedObservableList

        public static <E> ObservableList<E> checkedObservableList​(ObservableList<E> list,
                                                          Class<E> type)
        在提供的可观察列表之上创建并返回一个类型安全的包装器。
        参数类型
        E - 要包装的列表的类型
        参数
        list - 要包装的可观察列表
        type - list允许持有的元素的类型
        结果
        指定列表的动态类型安全视图
        另请参见：
        Collections.checkedList(java.util.List, java.lang.Class)

      • synchronizedObservableList

        public static <E> ObservableList<E> synchronizedObservableList​(ObservableList<E> list)
        在提供的可观察列表之上创建并返回一个同步的包装器。
        参数类型
        E - 要包装的列表的类型
        参数
        list - 要在同步列表中“包装”的列表。
        结果
        可观察列表的同步版本
        另请参见：
        Collections.synchronizedList(java.util.List)

      • emptyObservableList

        public static <E> ObservableList<E> emptyObservableList​()
        创建和清空不可修改的可观察列表。
        参数类型
        E - 要包装的列表的类型
        结果
        一个空的不可修改的可观察列表
        另请参见：
        Collections.emptyList()

      • singletonObservableList

        public static <E> ObservableList<E> singletonObservableList​(E e)
        使用单个元素创建一个不可修改的可观察列表。
        参数类型
        E - 要包装的列表的类型
        参数
        e - 这个单例可观察列表中唯一的元素
        结果
        单身可见列表
        另请参见：
        Collections.singletonList(java.lang.Object)

      • unmodifiableObservableSet

        public static <E> ObservableSet<E> unmodifiableObservableSet​(ObservableSet<E> set)
        在提供的可观察集合之上创建并返回不可修改的包装器。
        参数类型
        E - 要包装的列表的类型
        参数
        set - 要包装的ObservableSet
        结果
        一个不可修改的ObserableSet包装器
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Collections.unmodifiableSet(java.util.Set)

      • checkedObservableSet

        public static <E> ObservableSet<E> checkedObservableSet​(ObservableSet<E> set,
                                                        Class<E> type)
        在提供的可观察集之上创建并返回一个类型安全的包装器。
        参数类型
        E - 要包装的列表的类型
        参数
        set - 要包装的可观察组
        type - set允许持有的元素的类型
        结果
        指定集合的动态类型安全视图
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Collections.checkedSet(java.util.Set, java.lang.Class)

      • synchronizedObservableSet

        public static <E> ObservableSet<E> synchronizedObservableSet​(ObservableSet<E> set)
        在提供的可观察集合之上创建并返回同步的包装器。
        参数类型
        E - 要包装的列表的类型
        参数
        set - 要在同步集中“包装”的集合。
        结果
        可观察集合的同步版本
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Collections.synchronizedSet(java.util.Set)

      • emptyObservableSet

        public static <E> ObservableSet<E> emptyObservableSet​()
        创建和清空不可修改的可观察集。
        参数类型
        E - 要包装的列表的类型
        结果
        一个空的不可修改的可观察集
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Collections.emptySet()

      • copy

        public static <T> void copy​(ObservableList<? super T> dest,
                            List<? extends T> src)
        将元素从src复制到dest。 仅对Dest发出一个更改通知。
        参数类型
        T - 要包装的列表的类型
        参数
        dest - 目的地可见列表
        src - 源列表
        另请参见：
        Collections.copy(java.util.List, java.util.List)

      • fill

        public static <T> void fill​(ObservableList<? super T> list,
                            T obj)
        用obj填写提供的列表。 在列表中只发出一个更改通知。
        参数类型
        T - 要包装的列表的类型
        参数
        list - 要填写的列表
        obj - 用来填写列表的对象
        另请参见：
        Collections.fill(java.util.List, java.lang.Object)

      • replaceAll

        public static <T> boolean replaceAll​(ObservableList<T> list,
                                     T oldVal,
                                     T newVal)
        用newVal元素替换列表中的所有oldVal元素。 在列表中只发出一个更改通知。
        参数类型
        T - 要包装的列表的类型
        参数
        list - 将更换其元素的列表
        oldVal - 要替换的元素
        newVal - 替换
        结果
        如果列表被修改，则为true
        另请参见：
        Collections.replaceAll(java.util.List, java.lang.Object, java.lang.Object)

      • reverse

        public static void reverse​(ObservableList list)
        反转列表中的顺序列表中仅发送 一个更改通知。
        参数
        list - 要反转的列表
        另请参见：
        Collections.reverse(java.util.List)

      • rotate

        public static void rotate​(ObservableList list,
                          int distance)
        按距离旋转列表。 在列表中只发出一个更改通知。
        参数
        list - 要旋转的列表
        distance - 旋转距离
        另请参见：
        Collections.rotate(java.util.List, int)

      • shuffle

        public static void shuffle​(ObservableList<?> list)
        随机播放可观察列表中的所有元素。 在列表中只发出一个更改通知。
        参数
        list - 要洗牌的列表
        另请参见：
        Collections.shuffle(java.util.List)

      • shuffle

        public static void shuffle​(ObservableList list,
                           Random rnd)
        随机播放可观察列表中的所有元素。 在列表中只发出一个更改通知。
        参数
        list - 要洗牌的列表
        rnd - 用于混洗的随机生成器
        另请参见：
        Collections.shuffle(java.util.List, java.util.Random)

      • sort

        public static <T extends Comparable<? super T>> void sort​(ObservableList<T> list)
        对提供的可观察列表进行排序。 在列表中只发出一个更改通知。
        参数类型
        T - 要包装的列表的类型
        参数
        list - 要排序的列表
        另请参见：
        Collections.sort(java.util.List)

      • sort

        public static <T> void sort​(ObservableList<T> list,
                            Comparator<? super T> c)
        使用c比较器对提供的可观察列表进行排序。 在列表中只发出一个更改通知。
        参数类型
        T - 要包装的列表的类型
        参数
        list - 要排序的列表
        c - 用于排序的比较器。 如果需要自然排序，则为空。
        另请参见：
        Collections.sort(java.util.List, java.util.Comparator)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.collections (Java SE 9 & JDK 9 )

javafx.collections

Interfaces

  • ArrayChangeListener
  • ListChangeListener
  • MapChangeListener
  • ObservableArray
  • ObservableFloatArray
  • ObservableIntegerArray
  • ObservableList
  • ObservableMap
  • ObservableSet
  • SetChangeListener

Classes

  • FXCollections
  • ListChangeListener.Change
  • MapChangeListener.Change
  • ModifiableObservableListBase
  • ObservableArrayBase
  • ObservableListBase
  • SetChangeListener.Change
  • WeakListChangeListener
  • WeakMapChangeListener
  • WeakSetChangeListener


javafx.collections (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.collections

包含基本的JavaFX集合和集合实用程序

  • 接口摘要
    接口 描述
    ArrayChangeListener<T extends ObservableArray<T>>
    接收ObservableArray更改通知的接口。
    ListChangeListener<E>
    接收ObservableList更改通知的接口。
    MapChangeListener<K,V>
    接收到ObservableMap更改通知的接口。
    ObservableArray<T extends ObservableArray<T>>
    ObservableArray是一个数组，允许监听器在发生变化时跟踪变化。
    ObservableFloatArray
    ObservableFloatArray是一个 float[]数组，允许监听器在发生变化时跟踪变化。
    ObservableIntegerArray
    ObservableIntegerArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
    ObservableList<E>
    允许侦听器发生变化的列表。
    ObservableMap<K,V>
    一个允许观察者跟踪发生变化的地图。
    ObservableSet<E>
    一组允许观察者跟踪变化发生时的变化。
    SetChangeListener<E>
    接收ObservableSet更改通知的接口。
  • 类摘要
    Class 描述
    FXCollections
    由静态方法组成的实用程序类，它们是java.util.Collections方法的1：1。
    ListChangeListener.Change<E>
    表示对Observablelist进行的更改的报告。
    MapChangeListener.Change<K,V>
    对ObservableMap做一个基本的改动。
    ModifiableObservableListBase<E>
    抽象类作为可修改的ObservableList实现的基类。
    ObservableArrayBase<T extends ObservableArray<T>>
    抽象类作为ObservableArray实现的基类。
    ObservableListBase<E>
    抽象类作为ObservableList实现的基类。
    SetChangeListener.Change<E>
    对ObservableSet进行基本更改。
    WeakListChangeListener<E>
    A WeakListChangeListener可以使用，如果一个ObservableList应该只保留一个对监听器的弱引用。
    WeakMapChangeListener<K,V>
    A WeakMapChangeListener可以使用，如果一个ObservableMap应该只保留一个对监听者的弱引用。
    WeakSetChangeListener<E>
    A WeakSetChangeListener可以使用，如果一个ObservableSet应该只保留一个对监听器的弱引用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.collections Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.collections

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • javafx.collections.ObservableListBase<E> (implements javafx.collections.ObservableList<E>)
          • javafx.collections.ModifiableObservableListBase<E>
    • javafx.collections.FXCollections
    • javafx.collections.ListChangeListener.Change<E>
    • javafx.collections.MapChangeListener.Change<K,V>
    • javafx.collections.ObservableArrayBase<T> (implements javafx.collections.ObservableArray<T>)
    • javafx.collections.SetChangeListener.Change<E>
    • javafx.collections.WeakListChangeListener<E> (implements javafx.collections.ListChangeListener<E>, javafx.beans.WeakListener)
    • javafx.collections.WeakMapChangeListener<K,V> (implements javafx.collections.MapChangeListener<K,V>, javafx.beans.WeakListener)
    • javafx.collections.WeakSetChangeListener<E> (implements javafx.collections.SetChangeListener<E>, javafx.beans.WeakListener)

Interface Hierarchy

  • javafx.collections.ArrayChangeListener<T>
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
        • javafx.collections.ObservableList<E> (also extends javafx.beans.Observable)
      • java.util.Set<E>
        • javafx.collections.ObservableSet<E> (also extends javafx.beans.Observable)
  • javafx.collections.ListChangeListener<E>
  • java.util.Map<K,V>
    • javafx.collections.ObservableMap<K,V> (also extends javafx.beans.Observable)
  • javafx.collections.MapChangeListener<K,V>
  • javafx.beans.Observable
    • javafx.collections.ObservableArray<T>
      • javafx.collections.ObservableFloatArray
      • javafx.collections.ObservableIntegerArray
    • javafx.collections.ObservableList<E> (also extends java.util.List<E>)
    • javafx.collections.ObservableMap<K,V> (also extends java.util.Map<K,V>)
    • javafx.collections.ObservableSet<E> (also extends java.util.Set<E>)
  • javafx.collections.SetChangeListener<E>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ListChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface ListChangeListener<E>

  • 参数类型
    E - 列表元素类型
    所有已知实现类：
    WeakListChangeListener
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ListChangeListener<E>
    接收ObservableList更改通知的接口。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ListChangeListener.Change

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  ListChangeListener.Change<E>
      表示对Observablelist进行的更改的报告。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void onChanged​(ListChangeListener.Change<? extends E> c)
      在对ObservableList进行了更改后调用。

    • 方法详细信息

      • onChanged

        void onChanged​(ListChangeListener.Change<? extends E> c)
        在对ObservableList进行了更改后调用。
        参数
        c - 表示所做更改的对象
        另请参见：
        ListChangeListener.Change
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListChangeListener.Change (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class ListChangeListener.Change<E>

  • java.lang.Object
    • javafx.collections.ListChangeListener.Change<E>
  • 参数类型
    E - 列表元素类型
    Enclosing interface:
    ListChangeListener < E >

    public abstract static class ListChangeListener.Change<E>
extends Object
    表示对Observablelist进行的更改的报告。 更改可能包含一个或多个实际更改，并且必须由next()方法迭代。 每个更改必须是以下之一：
    • 在这种情况下， 排列变化 ： wasPermutated()返回true。 排列发生在from （含）和to （独家）之间，可通过拨打getPermutation(int)查询。
    • 添加或删除的变化 ：在这种情况下，至少一个wasAdded() ， wasRemoved()返回true。 如果两个方法都返回true， 那么wasReplaced()也将返回true。

      getRemoved()方法返回已从列表中替换或删除的元素列表。

      from （含）和to （独占）之间的范围表示包含新元素的列表的子列表。 请注意，这是一个半开的间隔，因此如果没有添加元素，则getFrom()等于getTo() 。

      可以通过调用getAddedSubList（）获取添加元素的列表。

      请注意，为了保持单独添加/删除更改的正确索引，这些更改必须按照其from索引进行排序。

    • 更新更改 ： wasUpdated()在更新更改时返回true。 from （含）和to （独家）之间的所有元素已更新。
    重要提示：这是需要调用next()调用其他任何方法之前方法Change 。 调用reset()后也一样 。 唯一可以随时使用的方法是getList() 。

    典型的用法是观察ObservableList上的变化，以便挂钩或取消挂起（或添加或删除侦听器）或为了在该ObservableList中的每个元素上维护一些不变量。 这样做的常见代码模式如下所示：

     ObservableList<Item> theList = ...;

 theList.addListener(new ListChangeListener<Item>() {
     public void onChanged(Change<tem> c) {
         while (c.next()) {
             if (c.wasPermutated()) {
                     for (int i = c.getFrom(); i < c.getTo(); ++i) {
                          //permutate
                     }
                 } else if (c.wasUpdated()) {
                          //update item
                 } else {
                     for (Item remitem : c.getRemoved()) {
                         remitem.remove(Outer.this);
                     }
                     for (Item additem : c.getAddedSubList()) {
                         additem.add(Outer.this);
                     }
                 }
             }
         }
     });

 }

    警告：此类直接访问源列表以获取有关更改的信息。
    当列表中发生另一个更改时，这会使“更改”对象无效。
    因此， 在不同的线程上使用这个类是不安全的 。
    这也意味着不能在监听器内修改源列表，因为这将使所有后续监听器的此Change对象无效。

    注意：如果更改包含不同类型的多个更改，则这些更改必须按照以下顺序排列 ： 排列更改，添加或删除更改，更新更改这是因为在添加/删除更改后排除更改不会如下改变添加元素的位置。 另一方面，更新更改必须在添加/删除更改后执行，因为它们将其索引引用到列表的当前状态，这意味着应用所有添加/删除更改。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      Change​(ObservableList<E> list)
      构造一个新的列表更改。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      int getAddedSize​()
      添加的间隔的大小
      List<E> getAddedSubList​()
      要获取仅包含元素的列表的子列表视图，请使用getAddedSubList（）方法。
      abstract int getFrom​()
      如果wasAdded为true，则间隔包含所有添加的值。
      ObservableList<E> getList​()
      源列表的更改。
      protected abstract int[] getPermutation​()
      如果这个改变是一个排列，它返回一个描述排列的整数数组。
      int getPermutation​(int i)
      通过调用这些方法，可以观察发生的排列。
      abstract List<E> getRemoved​()
      已删除/替换元素的不可变列表。
      int getRemovedSize​()
      getRemoved（）列表的大小。
      abstract int getTo​()
      更改间隔的结束。
      abstract boolean next​()
      转到下一个变化。
      abstract void reset​()
      重置到初始阶段。
      boolean wasAdded​()
      指示在此更改期间是否添加元素
      boolean wasPermutated​()
      指示更改是否只是一个排列。
      boolean wasRemoved​()
      表示在此更改期间元素是否被删除。
      boolean wasReplaced​()
      表示在此更改期间是否更换了元素。
      boolean wasUpdated​()
      表示getFrom（）（包括）到getTo（）的独占元素已更改。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Change

        public Change​(ObservableList<E> list)
        构造一个新的列表更改。
        参数
        list - 那是改变了

    • 方法详细信息

      • next

        public abstract boolean next​()
        转到下一个变化。 初始状态的变化是无效的，在调用其他方法之前需要调用next（）。 第一个next（）调用将使该对象代表第一个更改。
        结果
        如果切换到下一个更改，则为true，如果最后一次更改则为false。

      • reset

        public abstract void reset​()
        重置到初始阶段。 在这个调用之后，在使用第一个更改之前必须调用next（）。

      • getList

        public ObservableList<E> getList​()
        源列表的更改。
        结果
        已更改的列表

      • getFrom

        public abstract int getFrom​()
        如果wasAdded为true，则间隔包含所有添加的值。 如果wasPermutated为true，则间隔标记被排列的值。 如果wasRemoved为true并且wasAdded为false，则getFrom（）和getTo（）应返回相同的数字 - 删除的元素位于列表中的位置。
        结果
        与变化相关的间隔的开始（包括）
        异常
        IllegalStateException - 如果此更改处于初始状态

      • getTo

        public abstract int getTo​()
        更改间隔的结束。
        结果
        与更改相关的间隔的结束（排他）。
        异常
        IllegalStateException - 如果此更改处于初始状态
        另请参见：
        getFrom()

      • getRemoved

        public abstract List<E> getRemoved​()
        已删除/替换元素的不可变列表。 如果没有从列表中删除元素，则返回一个空列表。
        结果
        包含所有已删除元素的列表
        异常
        IllegalStateException - 如果此更改处于初始状态

      • wasPermutated

        public boolean wasPermutated​()
        指示更改是否只是一个排列。
        结果
        如果变化只是一个排列，则为真。
        异常
        IllegalStateException - 如果此更改处于初始状态

      • wasAdded

        public boolean wasAdded​()
        指示在此更改期间是否添加元素
        结果
        如果有人添加到列表中，则为true
        异常
        IllegalStateException - 如果此更改处于初始状态

      • wasRemoved

        public boolean wasRemoved​()
        表示在此更改期间元素是否被删除。 请注意，使用set也会产生一个更改，wasRemoved（）返回true。 见wasReplaced() 。
        结果
        如果从列表中删除某些内容，则为true
        异常
        IllegalStateException - 如果此更改处于初始状态

      • wasReplaced

        public boolean wasReplaced​()
        表示在此更改期间是否更换了元素。 在列表中调用set时通常为true。 设置操作将同时执行删除和添加操作。

        通常没有必要直接使用这种方法。 处理删除操作然后添加操作，如上例ListChangeListener.Change所示，将有效处理也可以设置操作。

        结果
        与 wasAdded() && wasRemoved()相同
        异常
        IllegalStateException - 如果此更改处于初始状态

      • wasUpdated

        public boolean wasUpdated​()
        表示getFrom（）（包括）到getTo（）的独占元素已更改。 这是唯一的可选事件类型，可能不会被所有ObservableLists触发。
        结果
        如果当前更改是更新更改，则为true。
        从以下版本开始：
        JavaFX 2.1

      • getAddedSubList

        public List<E> getAddedSubList​()
        要获取仅包含元素的列表的子列表视图，请使用getAddedSubList（）方法。 这实际上是一个c.getList().subList(c.getFrom(), c.getTo());的快捷方式
           for (Node n : change.getAddedSubList()) { // do something }
        结果
        新创建的包含所有添加元素的子列表视图。
        异常
        IllegalStateException - 如果此更改处于初始状态

      • getRemovedSize

        public int getRemovedSize​()
        getRemoved（）列表的大小。
        结果
        删除的项目的数量
        异常
        IllegalStateException - 如果此更改处于初始状态

      • getAddedSize

        public int getAddedSize​()
        添加的间隔的大小
        结果
        添加项目的数量
        异常
        IllegalStateException - 如果此更改处于初始状态

      • getPermutation

        protected abstract int[] getPermutation​()
        如果这个改变是一个排列，它返回一个描述排列的整数数组。 这个数组直接从以前的索引映射到新的索引。 此方法不可公开访问，因此可以安全地返回数组。 数组的0索引对应于列表的索引getFrom() 。 最后一个索引和getTo()也是一样 。 该方法由wasPermutated()和getPermutation(int)方法使用。
        结果
        如果这不是置换的空数组或包含置换的整数数组
        异常
        IllegalStateException - 如果此更改处于初始状态

      • getPermutation

        public int getPermutation​(int i)
        通过调用这些方法，可以观察发生的排列。 为了获得元素的新位置，您必须调用：
          change.getPermutation(oldIndex);
        注意：此方法的默认实现采用getPermutation()方法的信息。 您不必重写此方法。
        参数
        i - 包含此更改之前的元素的旧索引
        结果
        新索引的元素相同
        异常
        IndexOutOfBoundsException - 如果我超出了列表的边界
        IllegalStateException - 如果这不是排列变化
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MapChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface MapChangeListener<K,V>

  • 参数类型
    K - 关键元素类型
    V - 值元素类型
    所有已知实现类：
    WeakMapChangeListener
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface MapChangeListener<K,V>
    接收到ObservableMap更改通知的接口。
    从以下版本开始：
    JavaFX 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  MapChangeListener.Change<K,V>
      对ObservableMap做一个基本的改动。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void onChanged​(MapChangeListener.Change<? extends K,? extends V> change)
      在对ObservableMap进行了更改后调用。

    • 方法详细信息

      • onChanged

        void onChanged​(MapChangeListener.Change<? extends K,? extends V> change)
        在对ObservableMap进行了更改后调用。 每个基本变化（put / remove）一次调用此方法。 这意味着，像keySet（）。removeAll（Collection）或clear（）这样的复杂变化可能导致多次调用onChanged方法。
        参数
        change - 所做的更改
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MapChangeListener.Change (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class MapChangeListener.Change<K,V>

  • java.lang.Object
    • javafx.collections.MapChangeListener.Change<K,V>
  • 参数类型
    K - 键类型
    V - 值类型
    Enclosing interface:
    MapChangeListener < K ， V >

    public abstract static class MapChangeListener.Change<K,V>
extends Object
    对ObservableMap做一个基本的改动。 更改包含有关放置或删除操作的信息。 请注意，如果已经存在与相同键相关联的值，则put操作可能会删除该元素。 在这种情况下，hasAdded（）和wasRemoved（）都将返回true。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      Change​(ObservableMap<K,V> map)
      构造与地图关联的更改。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract K getKey​()
      与变更有关的一个关键。
      ObservableMap<K,V> getMap​()
      与变化相关联的可观察的地图。
      abstract V getValueAdded​()
      获取密钥的新值。
      abstract V getValueRemoved​()
      获取密钥的旧值。
      abstract boolean wasAdded​()
      如果此更改是添加操作的结果。
      abstract boolean wasRemoved​()
      如果此更改是删除操作的结果。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Change

        public Change​(ObservableMap<K,V> map)
        构造与地图关联的更改。
        参数
        map - 变更的根源

    • 方法详细信息

      • getMap

        public ObservableMap<K,V> getMap​()
        与变化相关联的可观察的地图。
        结果
        源地图

      • wasAdded

        public abstract boolean wasAdded​()
        如果此更改是添加操作的结果。
        结果
        如果将新值（或键值）条目添加到地图，则为true

      • wasRemoved

        public abstract boolean wasRemoved​()
        如果此更改是删除操作的结果。 请注意，即使由于put操作，元素也可能会被删除。
        结果
        如果从地图中删除旧值（或键值）条目，则为true

      • getKey

        public abstract K getKey​()
        与变更有关的一个关键。 如果更改是删除更改，则该密钥不再存在于地图中。 否则，密钥设置为新值。
        结果
        改变的关键

      • getValueAdded

        public abstract V getValueAdded​()
        获取密钥的新值。 如果这是一个删除，则返回null。
        结果
        现在与密钥相关联的值

      • getValueRemoved

        public abstract V getValueRemoved​()
        获取密钥的旧值。 当且仅当将值添加到以前不在映射中的键时，该值为null。
        结果
        以前与密钥相关联的值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ModifiableObservableListBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class ModifiableObservableListBase<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • javafx.collections.ObservableListBase<E>
          • javafx.collections.ModifiableObservableListBase<E>
  • 参数类型
    E - 列表中包含的元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， ObservableList<E>

    public abstract class ModifiableObservableListBase<E>
extends ObservableListBase<E>
    抽象类，可作为可修改的ObservableList实现的基类。 要实现一个可修改的ObservableList类，您只需要实现以下一组方法：
    • get(int)
    • size()
    • doAdd(int, Object)
    • doRemove(int)
    • doSet(int, Object)
    和通知，并为您自动建立和发射。

    一个简单的ObservableList委托给另一个List将如下所示：

      public class ArrayObservableList<E> extends ModifiableObservableList<E> {

   private final List<E> delegate = new ArrayList<>();

   public E get(int index) {
       return delegate.get(index);
   }

   public int size() {
       return delegate.size();
   }

   protected void doAdd(int index, E element) {
       delegate.add(index, element);
   }

   protected E doSet(int index, E element) {
       return delegate.set(index, element);
   }

   protected E doRemove(int index) {
       return delegate.remove(index);
   }
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    ObservableListBase

    • Field Summary

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      构造方法
      Constructor 描述
      ModifiableObservableListBase​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void add​(int index, E element)
      将指定的元素插入此列表中的指定位置（可选操作）。
      boolean addAll​(int index, Collection<? extends E> c)
      将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
      boolean addAll​(Collection<? extends E> c)
      将指定集合中的所有元素添加到此集合（可选操作）。
      protected abstract void doAdd​(int index, E element)
      将 element添加到列表中，位置为 index 。
      protected abstract E doRemove​(int index)
      删除 index位置的 index 。
      protected abstract E doSet​(int index, E element)
      设置 element在的位置的列表 index 。
      abstract E get​(int index)
      返回此列表中指定位置的元素。
      E remove​(int index)
      删除该列表中指定位置的元素（可选操作）。
      boolean remove​(Object o)
      从该集合中删除指定元素的单个实例（如果存在）（可选操作）。
      boolean removeAll​(Collection<?> c)
      删除指定集合中包含的所有此集合的元素（可选操作）。
      protected void removeRange​(int fromIndex, int toIndex)
      从此列表中删除索引为 fromIndex （含）和 toIndex之间的所有元素。
      boolean retainAll​(Collection<?> c)
      仅保留此集合中包含在指定集合中的元素（可选操作）。
      E set​(int index, E element)
      用指定的元素（可选操作）替换此列表中指定位置的元素。
      boolean setAll​(Collection<? extends E> col)
      清除ObservableList并添加集合中的所有元素。
      abstract int size​()
      返回此集合中的元素数。
      List<E> subList​(int fromIndex, int toIndex)
      返回指定的 fromIndex （含）和 toIndex之间的列表部分的视图。

      • Methods inherited from class java.util.AbstractCollection

        contains, containsAll, isEmpty, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractList

        add, clear, equals, hashCode, indexOf, iterator, lastIndexOf, listIterator, listIterator

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, clear, contains, containsAll, equals, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, replaceAll, sort, spliterator, toArray, toArray

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.collections.ObservableList

        filtered, sorted, sorted

      • Methods inherited from class javafx.collections.ObservableListBase

        addAll, addListener, addListener, beginChange, endChange, fireChange, hasListeners, nextAdd, nextPermutation, nextRemove, nextRemove, nextReplace, nextSet, nextUpdate, remove, removeAll, removeListener, removeListener, retainAll, setAll

    • 构造方法详细信息

      • ModifiableObservableListBase

        public ModifiableObservableListBase​()

    • 方法详细信息

      • setAll

        public boolean setAll​(Collection<? extends E> col)
        描述从接口ObservableList复制
        清除ObservableList并添加集合中的所有元素。
        Specified by:
        setAll在接口 ObservableList<E>
        重写：
        setAll在 ObservableListBase<E>
        参数
        col - 将添加到此observableArrayList的元素的集合
        结果
        true（由Collection.add（E）指定）

      • addAll

        public boolean addAll​(Collection<? extends E> c)
        描述从类别复制： AbstractCollection
        将指定集合中的所有元素添加到此集合（可选操作）。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （这意味着如果指定的集合是此集合，此调用的行为是未定义的，并且此集合是非空的。）
        Specified by:
        addAll在接口 Collection<E>
        Specified by:
        addAll在接口 List<E>
        重写：
        addAll在 AbstractCollection<E>
        参数
        c - 包含要添加到此集合的元素的集合
        结果
        true如果该收集因呼叫而更改
        另请参见：
        AbstractCollection.add(Object)

      • addAll

        public boolean addAll​(int index,
                      Collection<? extends E> c)
        描述从类别复制： AbstractList
        将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。 将当前位于该位置（如果有的话）的元素和随后的任何元素移动到右边（增加其索引）。 新元素将按照指定集合的迭代器返回的顺序显示在此列表中。 如果在操作进行中修改了指定的集合，则此操作的行为是未定义的。 （注意，如果指定的集合是此列表，并且它是非空的，则会发生这种情况。）
        Specified by:
        addAll在接口 List<E>
        重写：
        addAll在 AbstractList<E>
        参数
        index - 从中指定集合插入第一个元素的索引
        c - 包含要添加到此列表的元素的集合
        结果
        true如果此列表因呼叫而更改

      • removeRange

        protected void removeRange​(int fromIndex,
                           int toIndex)
        描述从类别复制： AbstractList
        从此列表中删除所有索引为fromIndex （包括）和toIndex之间的元素。 将任何后续元素移动到左侧（减少其索引）。 这个电话缩小了(toIndex - fromIndex)元素的列表。 （如果是toIndex==fromIndex ，这个操作没有效果）

        此方法由该列表及其子列表中的clear操作调用。 覆盖此方法以利用列表实现的内部结构可以大大提高此列表及其子列表中的clear操作的性能。

        重写：
        removeRange在 AbstractList<E>
        参数
        fromIndex - 要删除的第一个元素的索引
        toIndex - 要删除的最后一个元素后的索引

      • removeAll

        public boolean removeAll​(Collection<?> c)
        说明从类别复制： AbstractCollection
        删除指定集合中包含的所有此集合的元素（可选操作）。 此调用返回后，此集合将不包含与指定集合相同的元素。
        Specified by:
        removeAll在接口 Collection<E>
        Specified by:
        removeAll在接口 List<E>
        重写：
        removeAll在 AbstractCollection<E>
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        true如果该收集因呼叫而更改
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection<?> c)
        描述从类复制： AbstractCollection
        仅保留此集合中包含在指定集合中的元素（可选操作）。 换句话说，从该集合中删除所有不包含在指定集合中的元素。
        Specified by:
        retainAll在接口 Collection<E>
        Specified by:
        retainAll接口 List<E>
        重写：
        retainAll在 AbstractCollection<E>
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        true如果此集合由于调用而更改
        另请参见：
        AbstractCollection.remove(Object) ， AbstractCollection.contains(Object)

      • add

        public void add​(int index,
                E element)
        描述从类别复制： AbstractList
        将指定的元素插入此列表中的指定位置（可选操作）。 将当前位于该位置的元素（如果有）和任何后续元素（向其索引添加一个）移动。
        Specified by:
        add在接口 List<E>
        重写：
        add在 AbstractList<E>
        参数
        index - 要在其中插入指定元素的索引
        element - 要插入的元素

      • set

        public E set​(int index,
             E element)
        描述从类复制： AbstractList
        用指定的元素（可选操作）替换此列表中指定位置的元素。
        Specified by:
        set在接口 List<E>
        重写：
        set在 AbstractList<E>
        参数
        index - 要替换的元素的索引
        element - 要存储在指定位置的元素
        结果
        该元素以前在指定的位置

      • remove

        public boolean remove​(Object o)
        描述从类复制： AbstractCollection
        从该集合中删除指定元素的单个实例（如果存在）（可选操作）。 更正式地，删除元素e ，使得Objects.equals(o, e) ，如果该集合包含一个或多个这样的元素。 如果此集合包含指定的元素（或等效地，如果此集合由于调用而更改），则返回true 。
        Specified by:
        remove在接口 Collection<E>
        Specified by:
        remove在接口 List<E>
        重写：
        remove在 AbstractCollection<E>
        参数
        o - 要从此集合中删除的元素（如果存在）
        结果
        true如果元素被删除作为此调用的结果

      • remove

        public E remove​(int index)
        描述从类复制： AbstractList
        删除该列表中指定位置的元素（可选操作）。 将任何后续元素移动到左侧（从其索引中减去一个元素）。 返回从列表中删除的元素。
        Specified by:
        remove在接口 List<E>
        重写：
        remove在 AbstractList<E>
        参数
        index - 要删除的元素的索引
        结果
        该元素以前在指定的位置

      • subList

        public List<E> subList​(int fromIndex,
                       int toIndex)
        说明从类别复制： AbstractList
        返回指定的fromIndex （含）和toIndex之间的列表部分的视图。 （如果fromIndex和toIndex相等，返回的列表为空。）返回的列表由此列表支持，因此返回列表中的非结构性更改将反映在此列表中，反之亦然。 返回的列表支持此列表支持的所有可选列表操作。

        该方法消除了对显式范围操作（对于数组通常存在的排序）的需要。 任何期望列表的操作都可以通过传递一个子列表视图而不是整个列表来用作范围操作。 例如，以下成语从列表中移除了一系列元素：

           list.subList(from, to).clear();
        可以为indexOf和lastIndexOf构造类似的成语，并且Collections类中的所有算法都可以应用于子列表。

        如果支持列表（即，此列表）以除了通过返回的列表之外的任何方式进行结构修改 ，则此方法返回的列表的语义将变为未定义。 （结构修改是那些改变此列表的大小，或以其他方式扰乱它，使得正在进行的迭代可能产生不正确的结果）。

        Specified by:
        subList在接口 List<E>
        重写：
        subList中的 AbstractList<E>
        参数
        fromIndex - 子列表的低端点（含）
        toIndex - 子列表的高端点（独占）
        结果
        该列表中指定范围的视图

      • get

        public abstract E get​(int index)
        描述从类复制： AbstractList
        返回此列表中指定位置的元素。
        Specified by:
        get在接口 List<E>
        Specified by:
        get在 AbstractList<E>
        参数
        index - 要返回的元素的索引
        结果
        该列表中指定位置的元素

      • size

        public abstract int size​()
        说明从接口Collection复制
        返回此集合中的元素数。 如果这个集合包含Integer.MAX_VALUE元素，返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 List<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此集合中的元素数

      • doAdd

        protected abstract void doAdd​(int index,
                              E element)
        将element添加到列表中，位置为index 。

        有关可能的例外的描述，请参阅AbstractList.add(java.lang.Object)方法的文档。

        参数
        index - 添加元素的位置
        element - 要添加的元素
        异常
        ClassCastException - 如果指定的元素的类型与此列表不兼容
        NullPointerException - 如果指定的参数包含一个或多个空元素
        IllegalArgumentException - 如果此元素的某些属性阻止将其添加到此列表
        IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

      • doSet

        protected abstract E doSet​(int index,
                           E element)
        设置element在的位置的列表index 。

        有关可能的异常的描述，请参阅set(int, java.lang.Object)方法的文档。

        参数
        index - 设置元素的位置
        element - 将在指定位置设置的元素
        结果
        老元素在指定位置
        异常
        ClassCastException - 如果指定的元素的类型与此列表不兼容
        NullPointerException - 如果指定的参数包含一个或多个空元素
        IllegalArgumentException - 如果此元素的某些属性阻止将其添加到此列表
        IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

      • doRemove

        protected abstract E doRemove​(int index)
        删除 index位置的 index 。
        参数
        index - 已删除元素的索引
        结果
        删除的元素
        异常
        IndexOutOfBoundsException - if the index is out of range (index < 0 || index >= size())
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface ObservableArray<T extends ObservableArray<T>>

  • 参数类型
    T - 实际的数组实例类型
    All Superinterfaces:
    Observable
    All Known Subinterfaces:
    ObservableFaceArray ， ObservableFloatArray ， ObservableIntegerArray
    所有已知实现类：
    ObservableArrayBase

    public interface ObservableArray<T extends ObservableArray<T>>
extends Observable
    ObservableArray是一个数组，允许侦听器在发生变化时跟踪它们。 为了跟踪更改，内部阵列被封装，并且没有从外部可用的直接访问。 支持批量操作，但它们总是执行数据范围的副本。 当它们直接处理原始数组时，您可以在子类中找到它们。

    实现具有capacity ，这是内部数组长度，和size 。 如果尺寸需要增加超过容量，容量将增加以匹配新尺寸。 使用trimToSize()方法来缩小它。

    从以下版本开始：
    JavaFX 8.0
    另请参见：
    ArrayChangeListener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addListener​(ArrayChangeListener<T> listener)
      添加一个监听器到这个可观察的数组。
      void clear​()
      通过将其调整为0来清空数组。
      void ensureCapacity​(int capacity)
      如果当前容量小于 capacity ，则增加该阵列的容量，如果已经超过了 capacity则 capacity 。
      void removeListener​(ArrayChangeListener<T> listener)
      尝试从这个可观察数组中删除一个监听器。
      void resize​(int size)
      在此数组中设置新的数据长度。
      int size​()
      检索此数组中的数据长度。
      void trimToSize​()
      缩小阵列中当前数据大小的容量。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

    • 方法详细信息

      • addListener

        void addListener​(ArrayChangeListener<T> listener)
        添加一个监听器到这个可观察的数组。
        参数
        listener - 用于监听数组更改的侦听器
        异常
        NullPointerException -如果 listener为 null

      • removeListener

        void removeListener​(ArrayChangeListener<T> listener)
        尝试从这个可观察数组中删除一个监听器。 如果侦听器没有附加到这个数组，没有任何反应。
        参数
        listener - 要删除的侦听器
        异常
        NullPointerException - 如果 listener是 null

      • resize

        void resize​(int size)
        在此数组中设置新的数据长度。 这种方法在必要时增加容量，但不会缩小容量。 结果数组将包含小于当前大小的索引的现有数据，并且对于大于当前大小的索引，将包含零。
        参数
        size - 这个数组的新长度的数据
        异常
        NegativeArraySizeException - 如果大小为负数

      • ensureCapacity

        void ensureCapacity​(int capacity)
        如果当前容量小于给定的 capacity ，则增加该阵列的容量，如果已经超过了 capacity则 capacity 。
        参数
        capacity - 这个数组的容量

      • trimToSize

        void trimToSize​()
        缩小阵列中当前数据大小的容量。

      • clear

        void clear​()
        通过将其调整为0来清空数组。容量不变。
        另请参见：
        trimToSize()

      • size

        int size​()
        检索此数组中的数据长度。
        结果
        此数组中的数据长度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableArrayBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class ObservableArrayBase<T extends ObservableArray<T>>

  • java.lang.Object
    • javafx.collections.ObservableArrayBase<T>
  • 参数类型
    T - 实际的数组实例类型
    All Implemented Interfaces:
    Observable ， ObservableArray<T>

    public abstract class ObservableArrayBase<T extends ObservableArray<T>>
extends Object
implements ObservableArray<T>
    抽象类，用作ObservableArray实现的基类。 基类通过实现addListener和removeListener方法提供监听器处理功能。 提供fireChange(boolean, int, int)通知听众的方法。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    ObservableArray ， ArrayChangeListener

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObservableArrayBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable无效时，它将被通知。
      void addListener​(ArrayChangeListener<T> listener)
      添加一个监听器到这个可观察的数组。
      protected void fireChange​(boolean sizeChanged, int from, int to)
      通知所有听众的变化
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的侦听器，每当 Observable的值变为无效时通知它。
      void removeListener​(ArrayChangeListener<T> listener)
      尝试从这个可观察数组中删除一个监听器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.collections.ObservableArray

        clear, ensureCapacity, resize, size, trimToSize

    • 构造方法详细信息

      • ObservableArrayBase

        public ObservableArrayBase​()

    • 方法详细信息

      • addListener

        public final void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable变得无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可以安全地注册到不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的实例来避免此情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public final void removeListener​(InvalidationListener listener)
        说明从接口Observable复制
        从监听器列表中删除给定的监听器，每当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public final void addListener​(ArrayChangeListener<T> listener)
        描述从接口ObservableArray复制
        添加一个监听器到这个可观察的数组。
        Specified by:
        addListener在接口 ObservableArray<T extends ObservableArray<T>>
        参数
        listener - 用于侦听数组更改的侦听器

      • removeListener

        public final void removeListener​(ArrayChangeListener<T> listener)
        描述从接口ObservableArray复制
        尝试从这个可观察数组中删除一个监听器。 如果侦听器没有附加到这个数组，没有任何反应。
        Specified by:
        removeListener在接口 ObservableArray<T extends ObservableArray<T>>
        参数
        listener - 要删除的侦听器

      • fireChange

        protected final void fireChange​(boolean sizeChanged,
                                int from,
                                int to)
        通知所有听众的变化
        参数
        sizeChanged - 表示阵列的大小已更改
        from - 与变更相关的间隔的开始（包括）
        to - 与更改相关的间隔的结束（排他）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableFloatArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface ObservableFloatArray

  • All Superinterfaces:
    Observable ， ObservableArray<ObservableFloatArray>

    public interface ObservableFloatArray
extends ObservableArray<ObservableFloatArray>
    ObservableFloatArray是一个float[]数组，允许侦听器在发生变化时跟踪它们。 为了跟踪更改，内部阵列被封装，并且没有从外部可用的直接访问。 支持批量操作，但它们总是执行数据范围的副本。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    ArrayChangeListener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addAll​(float... elements)
      附加给这个数组的结尾的 elements 。
      void addAll​(float[] src, int srcIndex, int length)
      将给定数组的一部分附加到该数组的末尾。
      void addAll​(ObservableFloatArray src)
      将给定的可观察数组的内容附加到此数组的末尾。
      void addAll​(ObservableFloatArray src, int srcIndex, int length)
      将给定的可观察数组的一部分附加到该数组的末尾。
      void copyTo​(int srcIndex, float[] dest, int destIndex, int length)
      将数组的指定部分复制到 dest数组中。
      void copyTo​(int srcIndex, ObservableFloatArray dest, int destIndex, int length)
      将数组的指定部分复制到可观察数组 dest 。
      float get​(int index)
      获取数组的单个值。
      void set​(int index, float value)
      在数组中设置单个值。
      void set​(int destIndex, float[] src, int srcIndex, int length)
      将指定数组的一部分复制到此observable数组中。
      void set​(int destIndex, ObservableFloatArray src, int srcIndex, int length)
      将指定的可观察数组的一部分复制到此可观察数组中。
      void setAll​(float... elements)
      用给定的元素替换这个可观察的数组内容。
      void setAll​(float[] src, int srcIndex, int length)
      用给定数组的一部分的副本替换这个可观察的数组内容。
      void setAll​(ObservableFloatArray src)
      用给定的observable数组的副本替换这个可观察的数组内容。
      void setAll​(ObservableFloatArray src, int srcIndex, int length)
      用给定的observable数组的一部分替换这个可观察的数组内容。
      float[] toArray​(float[] dest)
      返回包含observable数组的副本的数组。
      float[] toArray​(int srcIndex, float[] dest, int length)
      返回包含observable数组的指定部分的数组的数组。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableArray

        addListener, clear, ensureCapacity, removeListener, resize, size, trimToSize

    • 方法详细信息

      • copyTo

        void copyTo​(int srcIndex,
            float[] dest,
            int destIndex,
            int length)
        将数组的指定部分复制到dest数组中。 抛出与System.arraycopy()方法相同的异常。
        参数
        srcIndex - 可观察数组中的起始位置
        dest - 目的地阵列
        destIndex - 目标数组中的起始位置
        length - 要复制的部分的长度

      • copyTo

        void copyTo​(int srcIndex,
            ObservableFloatArray dest,
            int destIndex,
            int length)
        将数组的指定部分复制到可观察数组dest 。 抛出与System.arraycopy()方法相同的异常。
        参数
        srcIndex - 可观察数组中的起始位置
        dest - 目的可见数组
        destIndex - 目的地可观察数组的起始位置
        length - 要复制的部分的长度

      • get

        float get​(int index)
        获取数组的单个值。 这通常与直接访问阵列一样快，并且消除了制作阵列副本的必要性。
        参数
        index - 要获取的元素的索引
        结果
        给定指数值
        异常
        ArrayIndexOutOfBoundsException - 如果 index在数组边界之外

      • addAll

        void addAll​(float... elements)
        附加给这个数组的最后的elements 。 如果需要增加容量以匹配新的数据大小。
        参数
        elements - 要追加的元素

      • addAll

        void addAll​(ObservableFloatArray src)
        将给定的可观察数组的内容附加到此数组的末尾。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 具有附加元素的observable数组

      • addAll

        void addAll​(float[] src,
            int srcIndex,
            int length)
        将给定数组的一部分附加到该数组的末尾。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 源数组
        srcIndex - 源数组中的起始位置
        length - 要追加的部分的长度

      • addAll

        void addAll​(ObservableFloatArray src,
            int srcIndex,
            int length)
        将给定的可观察数组的一部分附加到该数组的末尾。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 源可观察数组
        srcIndex - 源数组中的起始位置
        length - 要追加的部分的长度

      • setAll

        void setAll​(float... elements)
        用给定的元素替换这个可观察的数组内容。 如果需要增加容量以匹配新的数据大小。
        参数
        elements - 要放入数组内容的元素
        异常
        NullPointerException - 如果 src为空

      • setAll

        void setAll​(float[] src,
            int srcIndex,
            int length)
        用给定数组的一部分的副本替换这个可观察的数组内容。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 要复制的源数组。
        srcIndex - 源可见数组中的起始位置
        length - 要复制的部分的长度
        异常
        NullPointerException - 如果 src为空

      • setAll

        void setAll​(ObservableFloatArray src)
        用给定的observable数组的副本替换这个可观察的数组内容。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 源可观察数组复制。
        异常
        NullPointerException - 如果 src为空

      • setAll

        void setAll​(ObservableFloatArray src,
            int srcIndex,
            int length)
        用给定的observable数组的一部分替换这个可观察的数组内容。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 源可观察数组复制。
        srcIndex - 源可见数组中的起始位置
        length - 要复制的部分的长度
        异常
        NullPointerException - 如果 src为空

      • set

        void set​(int destIndex,
         float[] src,
         int srcIndex,
         int length)
        将指定数组的一部分复制到此observable数组中。 抛出与System.arraycopy()方法相同的异常。
        参数
        destIndex - 此可观察数组中的起始目标位置
        src - 要复制的源数组
        srcIndex - 源数组中的起始位置
        length - 要复制的部分的长度

      • set

        void set​(int destIndex,
         ObservableFloatArray src,
         int srcIndex,
         int length)
        将指定的可观察数组的一部分复制到此可观察数组中。 抛出与System.arraycopy()方法相同的例外。
        参数
        destIndex - 此可观察数组中的起始目标位置
        src - 要复制的源可观察数组
        srcIndex - 源数组中的起始位置
        length - 要复制的部分的长度

      • set

        void set​(int index,
         float value)
        在数组中设置单个值。 如果更新了许多值，请避免使用此方法，而应尽可能使用set(int, float[], int, int)更新方法作为最小调用次数。
        参数
        index - 要设置的值的索引
        value - 给定索引的新值
        异常
        ArrayIndexOutOfBoundsException - 如果 index在数组边界之外

      • toArray

        float[] toArray​(float[] dest)
        返回包含observable数组的副本的数组。 如果可观察数组适合指定的数组，则将其复制到其中。 否则，将使用observable数组的大小分配一个新数组。
        参数
        dest - 要复制的observable数组的数组，如果它足够大; 否则，将分配一个新的浮点数组。 忽略，如果为空。
        结果
        一个包含observable数组的副本的float数组

      • toArray

        float[] toArray​(int srcIndex,
                float[] dest,
                int length)
        返回包含observable数组的指定部分的数组的数组。 如果可观察数组的指定部分适合指定的数组，则会在其中复制。 否则，分配给定长度的新数组。
        参数
        srcIndex - 可观察数组中的起始位置
        dest - 要复制的observable数组的指定部分的数组，如果它足够大; 否则，将分配一个新的浮点数组。 忽略，如果为空。
        length - 要复制的部分的长度
        结果
        一个float数组，其中包含可观察数组的指定部分的副本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableIntegerArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface ObservableIntegerArray

  • All Superinterfaces:
    Observable ， ObservableArray<ObservableIntegerArray>
    All Known Subinterfaces:
    ObservableFaceArray

    public interface ObservableIntegerArray
extends ObservableArray<ObservableIntegerArray>
    ObservableIntegerArray是一个int[]数组，允许监听器跟踪发生变化时。 为了跟踪更改，内部阵列被封装，并且没有从外部可用的直接访问。 支持批量操作，但它们总是执行数据范围的副本。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    ArrayChangeListener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addAll​(int... elements)
      附加给这个数组的最后的 elements 。
      void addAll​(int[] src, int srcIndex, int length)
      将给定数组的一部分附加到该数组的末尾。
      void addAll​(ObservableIntegerArray src)
      将给定的可观察数组的内容附加到此数组的末尾。
      void addAll​(ObservableIntegerArray src, int srcIndex, int length)
      将给定的可观察数组的一部分附加到该数组的末尾。
      void copyTo​(int srcIndex, int[] dest, int destIndex, int length)
      将数组的指定部分复制到 dest数组中。
      void copyTo​(int srcIndex, ObservableIntegerArray dest, int destIndex, int length)
      将数组的指定部分复制到 dest可观察数组中。
      int get​(int index)
      获取数组的单个值。
      void set​(int index, int value)
      在数组中设置单个值。
      void set​(int destIndex, int[] src, int srcIndex, int length)
      将指定数组的一部分复制到此observable数组中。
      void set​(int destIndex, ObservableIntegerArray src, int srcIndex, int length)
      将指定的可观察数组的一部分复制到此可观察数组中。
      void setAll​(int... elements)
      用给定的元素替换这个可观察的数组内容。
      void setAll​(int[] src, int srcIndex, int length)
      用给定数组的一部分的副本替换这个可观察的数组内容。
      void setAll​(ObservableIntegerArray src)
      用给定的observable数组的副本替换这个可观察的数组内容。
      void setAll​(ObservableIntegerArray src, int srcIndex, int length)
      用给定的observable数组的一部分替换这个可观察的数组内容。
      int[] toArray​(int[] dest)
      返回包含observable数组的副本的数组。
      int[] toArray​(int srcIndex, int[] dest, int length)
      返回包含observable数组的指定部分的数组的数组。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableArray

        addListener, clear, ensureCapacity, removeListener, resize, size, trimToSize

    • 方法详细信息

      • copyTo

        void copyTo​(int srcIndex,
            int[] dest,
            int destIndex,
            int length)
        将数组的指定部分复制到dest数组中。 抛出与System.arraycopy()方法相同的异常。
        参数
        srcIndex - 可观察数组中的起始位置
        dest - 目的地阵列
        destIndex - 目标数组中的起始位置
        length - 要复制的部分的长度

      • copyTo

        void copyTo​(int srcIndex,
            ObservableIntegerArray dest,
            int destIndex,
            int length)
        将数组的指定部分复制到可观察数组dest 。 抛出与System.arraycopy()方法相同的异常。
        参数
        srcIndex - 可观察数组中的起始位置
        dest - 目的可见数组
        destIndex - 目的地可观察数组中的起始位置
        length - 要复制的部分的长度

      • get

        int get​(int index)
        获取数组的单个值。 这通常与直接访问阵列一样快，并且消除了制作阵列副本的必要性。
        参数
        index - 要获取的元素的索引
        结果
        给定指数值
        异常
        ArrayIndexOutOfBoundsException - 如果 index在数组边界之外

      • addAll

        void addAll​(int... elements)
        附加给这个数组的结尾的elements 。 如果需要增加容量以匹配新的数据大小。
        参数
        elements - 要追加的元素

      • addAll

        void addAll​(ObservableIntegerArray src)
        将给定的可观察数组的内容附加到此数组的末尾。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 具有附加元素的observable数组

      • addAll

        void addAll​(int[] src,
            int srcIndex,
            int length)
        将给定数组的一部分附加到该数组的末尾。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 源数组
        srcIndex - 源数组中的起始位置
        length - 要追加的部分的长度

      • addAll

        void addAll​(ObservableIntegerArray src,
            int srcIndex,
            int length)
        将给定的可观察数组的一部分附加到该数组的末尾。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 源可观察数组
        srcIndex - 源数组中的起始位置
        length - 要追加的部分的长度

      • setAll

        void setAll​(int... elements)
        用给定的元素替换这个可观察的数组内容。 如果需要增加容量以匹配新的数据大小。
        参数
        elements - 要放入数组内容的元素
        异常
        NullPointerException - 如果 src为空

      • setAll

        void setAll​(int[] src,
            int srcIndex,
            int length)
        用给定数组的一部分的副本替换这个可观察的数组内容。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 要复制的源数组。
        srcIndex - 源可见数组中的起始位置
        length - 要复制的部分的长度
        异常
        NullPointerException - 如果 src为空

      • setAll

        void setAll​(ObservableIntegerArray src)
        用给定的observable数组的副本替换这个可观察的数组内容。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 源可观察数组复制。
        异常
        NullPointerException - 如果 src为空

      • setAll

        void setAll​(ObservableIntegerArray src,
            int srcIndex,
            int length)
        用给定的observable数组的一部分替换这个可观察的数组内容。 如果需要增加容量以匹配新的数据大小。
        参数
        src - 源可观察数组复制。
        srcIndex - 源可见数组中的起始位置
        length - 要复制的部分的长度
        异常
        NullPointerException - 如果 src为空

      • set

        void set​(int destIndex,
         int[] src,
         int srcIndex,
         int length)
        将指定数组的一部分复制到此observable数组中。 抛出与System.arraycopy()方法相同的异常。
        参数
        destIndex - 此可观察数组中的起始目标位置
        src - 要复制的源数组
        srcIndex - 源数组中的起始位置
        length - 要复制的部分的长度

      • set

        void set​(int destIndex,
         ObservableIntegerArray src,
         int srcIndex,
         int length)
        将指定的可观察数组的一部分复制到此可观察数组中。 抛出与System.arraycopy()方法相同的异常。
        参数
        destIndex - 此可观察数组中的起始目标位置
        src - 源可观察数组复制
        srcIndex - 源数组中的起始位置
        length - 要复制的部分的长度

      • set

        void set​(int index,
         int value)
        在数组中设置单个值。 避免使用这种方法，如果更新了许多值，请使用set(int, int[], int, int)更新方法，而不是尽可能少的调用。
        参数
        index - 要设置的值的索引
        value - 给定索引的新值
        异常
        ArrayIndexOutOfBoundsException - 如果 index在数组边界之外

      • toArray

        int[] toArray​(int[] dest)
        返回包含observable数组的副本的数组。 如果可观察数组适合指定的数组，则将其复制到其中。 否则，将使用observable数组的大小分配一个新数组。
        参数
        dest - 要复制的observable数组的数组，如果它足够大; 否则，将分配一个新的int数组。 忽略，如果为空。
        结果
        一个包含observable数组的副本的int数组

      • toArray

        int[] toArray​(int srcIndex,
              int[] dest,
              int length)
        返回包含observable数组的指定部分的数组的数组。 如果可观察数组的指定部分适合指定的数组，则会在其中复制。 否则，分配给定长度的新数组。
        参数
        srcIndex - 可观察数组中的起始位置
        dest - 要复制的observable数组的指定部分的数组，如果它足够大; 否则，将分配一个新的int数组。 忽略，如果为空。
        length - 要复制的部分的长度
        结果
        an int array containing the copy of specified portion the observable array
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface ObservableList<E>

  • 参数类型
    E - 列表元素类型
    All Superinterfaces:
    Collection<E> ， Iterable<E> ， List<E> ， Observable
    All Known Subinterfaces:
    ObservableListValue<E> ， WritableListValue<E>
    所有已知实现类：
    FilteredList ， ListBinding ， ListExpression ， ListProperty ， ListPropertyBase ， ModifiableObservableListBase ， ObservableListBase ， ReadOnlyListProperty ， ReadOnlyListPropertyBase ， ReadOnlyListWrapper ， SimpleListProperty ， SortedList ， TransformationList

    public interface ObservableList<E>
extends List<E>, Observable
    允许侦听器发生变化的列表。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ListChangeListener ， ListChangeListener.Change

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean addAll​(E... elements)
      用于var-arg添加元素的方便方法。
      void addListener​(ListChangeListener<? super E> listener)
      将侦听器添加到此可观察列表中。
      default FilteredList<E> filtered​(Predicate<E> predicate)
      使用指定的谓词创建此列表的FilteredList包装器。
      void remove​(int from, int to)
      调用 sublist(from, to).clear()简化方法。
      boolean removeAll​(E... elements)
      一个方便的方法，用于var-arg使用的 removeAll方法。
      void removeListener​(ListChangeListener<? super E> listener)
      尝试从此可观察列表中删除侦听器。
      boolean retainAll​(E... elements)
      对于 retainAll方法的var-arg使用的 方便方法。
      boolean setAll​(E... elements)
      清除ObservableList并添加所有传递给var-args的元素。
      boolean setAll​(Collection<? extends E> col)
      清除ObservableList并添加集合中的所有元素。
      default SortedList<E> sorted​()
      用自然排序创建一个SortedList这个列表的包装器。
      default SortedList<E> sorted​(Comparator<E> comparator)
      使用指定的比较器创建此列表的SortedList包装器。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, size, sort, spliterator, subList, toArray, toArray

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

    • 方法详细信息

      • addListener

        void addListener​(ListChangeListener<? super E> listener)
        将侦听器添加到此可观察列表中。
        参数
        listener - 用于监听列表更改的监听器

      • removeListener

        void removeListener​(ListChangeListener<? super E> listener)
        尝试从此可观察列表中删除侦听器。 如果监听者没有附加到此列表中，则不会发生任何事情。
        参数
        listener - 要删除的侦听器

      • addAll

        boolean addAll​(E... elements)
        用于var-arg添加元素的方便方法。
        参数
        elements - 要添加的元素
        结果
        true（由Collection.add（E）指定）

      • setAll

        boolean setAll​(E... elements)
        清除ObservableList并添加所有传递给var-args的元素。
        参数
        elements - 要设置的元素
        结果
        true（由Collection.add（E）指定）
        异常
        NullPointerException - 如果指定的参数包含一个或多个空元素

      • setAll

        boolean setAll​(Collection<? extends E> col)
        清除ObservableList并添加集合中的所有元素。
        参数
        col - 将添加到此observableArrayList的元素的集合
        结果
        true（由Collection.add（E）指定）
        异常
        NullPointerException - 如果指定的集合包含一个或多个空元素

      • removeAll

        boolean removeAll​(E... elements)
        一种方便的方法，用于var-arg使用的 removeAll方法。
        参数
        elements - 要删除的元素
        结果
        如果列表因此调用而更改，则为true

      • retainAll

        boolean retainAll​(E... elements)
        一个方便的方法，用于var-arg使用的 retainAll方法。
        参数
        elements - 要保留的元素
        结果
        如果列表因此调用而更改，则为true

      • remove

        void remove​(int from,
            int to)
        一种调用sublist(from, to).clear()简化方法。 由于这是一个常见的操作，ObservableList具有方便使用的方法。
        参数
        from - 要移除的范围的开始（含）
        to - 删除范围的结束（排他）
        异常
        IndexOutOfBoundsException - 如果提供了非法范围

      • filtered

        default FilteredList<E> filtered​(Predicate<E> predicate)
        使用指定的谓词创建此列表的FilteredList包装器。
        参数
        predicate - 要使用的谓词
        结果
        新 FilteredList
        从以下版本开始：
        JavaFX 8.0

      • sorted

        default SortedList<E> sorted​(Comparator<E> comparator)
        使用指定的比较器创建此列表的SortedList包装器。
        参数
        comparator - 使用的比较器或无序列表的空值
        结果
        新 SortedList
        从以下版本开始：
        JavaFX 8.0

      • sorted

        default SortedList<E> sorted​()
        用自然排序创建一个SortedList这个列表的包装器。
        结果
        新 SortedList
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableListBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class ObservableListBase<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • javafx.collections.ObservableListBase<E>
  • 参数类型
    E - 列表中包含的元素的类型
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， ObservableList<E>
    已知直接子类：
    ModifiableObservableListBase ， TransformationList

    public abstract class ObservableListBase<E>
extends AbstractList<E>
implements ObservableList<E>
    抽象类作为ObservableList实现的基类。 基类为实现类提供了两个功能。
    • 听众处理通过实现addListener和removeListener方法。 提供fireChange(javafx.collections.ListChangeListener.Change)方法用于通知Change对象的收听者。
    • 建立ListChangeListener.Change对象的方法。 有各种各样的方法叫做next* ，像nextAdd(int, int)的列表中的新项目，或nextRemove(int, java.lang.Object)一个项目从列表中删除。

      这些方法必须始终包含在beginChange()和endChange()中 。

      参见下面的例子。

    以下示例显示了更改构建的工作原理：
      public void removeOddIndexes() {
      beginChange();
      try {
          for (int i = 1; i < size(); ++i) {
              remove(i);
          }
      } finally {
          endChange();
      }
  }

  public void remove(int i) {
      beginChange();
      try {
          E removed = ... //do some stuff that will actually remove the element at index i
          nextRemove(i, removed);
      } finally {
          endChange();
      }
  }
    所述try / finally在示例块仅需要，如果有一个内发生异常的可能性beginChange() / endChange()块

    注意：如果要创建可修改的ObservableList实现，请考虑使用ModifiableObservableListBase作为超类。

    注意：为了创建具有顺序访问列表，你应该重写AbstractList.listIterator() ， AbstractList.iterator()方法和使用它们AbstractList.get(int) ， AbstractCollection.size()等方法相应。

    从以下版本开始：
    JavaFX 8.0
    另请参见：
    ObservableList ， ListChangeListener.Change ， ModifiableObservableListBase

    • Field Summary

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObservableListBase​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean addAll​(E... elements)
      用于var-arg添加元素的方便方法。
      void addListener​(InvalidationListener listener)
      添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
      void addListener​(ListChangeListener<? super E> listener)
      将侦听器添加到此可观察列表中。
      protected void beginChange​()
      开始改变块
      protected void endChange​()
      结束更改块。
      protected void fireChange​(ListChangeListener.Change<? extends E> change)
      通知所有听众的变化
      protected boolean hasListeners​()
      如果为此列表注册了一些监听器，则返回true。
      protected void nextAdd​(int from, int to)
      对更改添加新的添加操作。
      protected void nextPermutation​(int from, int to, int[] perm)
      为更改添加新的置换操作。
      protected void nextRemove​(int idx, E removed)
      在删除单个项目的情况下，添加新的删除操作。
      protected void nextRemove​(int idx, List<? extends E> removed)
      在更改中添加一个新的删除操作，删除多个项目。
      protected void nextReplace​(int from, int to, List<? extends E> removed)
      为更改添加新的替换操作。
      protected void nextSet​(int idx, E old)
      为更改添加新的集合操作。
      protected void nextUpdate​(int pos)
      对更改添加新的更新操作。
      void remove​(int from, int to)
      一种调用 sublist(from, to).clear()简化方法。
      boolean removeAll​(E... elements)
      对于 removeAll方法的var-arg使用的 方便方法。
      void removeListener​(InvalidationListener listener)
      从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
      void removeListener​(ListChangeListener<? super E> listener)
      尝试从此可观察列表中删除侦听器。
      boolean retainAll​(E... elements)
      对于 retainAll方法的var-arg使用的 方便方法。
      boolean setAll​(E... elements)
      清除ObservableList并添加所有传递给var-args的元素。
      boolean setAll​(Collection<? extends E> col)
      清除ObservableList并添加集合中的所有元素。

      • Methods inherited from class java.util.AbstractCollection

        addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, size, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractList

        add, add, addAll, clear, equals, get, hashCode, indexOf, iterator, lastIndexOf, listIterator, listIterator, remove, removeRange, set, subList

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, size, sort, spliterator, subList, toArray, toArray

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.collections.ObservableList

        filtered, sorted, sorted

    • 构造方法详细信息

      • ObservableListBase

        public ObservableListBase​()

    • 方法详细信息

      • nextUpdate

        protected final void nextUpdate​(int pos)
        对更改添加新的更新操作。

        注意 ：需要在endChange()块内beginChange() 。

        注意 ：需要反映列表的当前状态。

        参数
        pos - 更新元素所在列表中的位置。

      • nextSet

        protected final void nextSet​(int idx,
                             E old)
        为更改添加新的集合操作。 相当于nextRemove(idx); nextAdd(idx, idx + 1); 。

        注意 ：需要在内部beginChange() endChange()块。

        注意 ：需要反映列表的当前状态。

        参数
        idx - 设置的项目的索引
        old - 旧值在 idx位置。

      • nextReplace

        protected final void nextReplace​(int from,
                                 int to,
                                 List<? extends E> removed)
        为更改添加新的替换操作。 相当于nextRemove(from, removed); nextAdd(from, to);

        注 ：需要内部被称为beginChange() / endChange()块。

        注意 ：需要反映列表的当前状态。

        参数
        from - 项目被替换的索引
        to - 新项目所在范围的最终索引（独占）
        removed - 已删除的项目列表

      • nextRemove

        protected final void nextRemove​(int idx,
                                List<? extends E> removed)
        在更改中添加一个新的删除操作，删除多个项目。

        注意 ：需要在内部beginChange() endChange()块。

        注意 ：需要反映列表的当前状态。

        参数
        idx - 删除项目的索引
        removed - 已删除的项目列表

      • nextRemove

        protected final void nextRemove​(int idx,
                                E removed)
        在删除单个项目的情况下，添加新的删除操作。

        注 ：需要内部被称为beginChange() / endChange()块。

        注意 ：需要反映列表的当前状态。

        参数
        idx - 删除项目的索引
        removed - 已删除的项目

      • nextPermutation

        protected final void nextPermutation​(int from,
                                     int to,
                                     int[] perm)
        为更改添加新的置换操作。 索引"i"上的排列包含索引，其中来自索引"i"的项目被移动。

        没有必要提供可能的最小排列。 始终使用nextPermutation(0, size(), permutation);调用此方法是nextPermutation(0, size(), permutation);

        注意 ：需要在内部beginChange() endChange()块。

        注意 ：需要反映列表的当前状态。

        参数
        from - 标记被 from的范围的开始（包括）
        to - 标记排列的范围的结束（排他）
        perm - 该范围内的排列。 即使是from != 0 ，数组也应该包含列表的索引。 因此，这种排列不包含范围(0, from)索引

      • nextAdd

        protected final void nextAdd​(int from,
                             int to)
        对更改添加新的添加操作。 没有必要提供添加项目的列表，因为它们可以直接在指定索引下的列表中找到。

        注意 ：需要在endChange()块内beginChange() 。

        注意 ：需要反映列表的当前状态。

        参数
        from - 标记添加的范围的开始（含）
        to - 标记添加的范围的结束（排他）

      • beginChange

        protected final void beginChange​()
        开始改变块 必须先调用next*方法之前调用。 对于每个beginChange() ，必须有一个对应的endChange()调用。

        beginChange()呼叫可以被嵌套在beginChange() / endChange()块。

        另请参见：
        endChange()

      • endChange

        protected final void endChange​()
        结束更改块。 如果块是ObservableList的最外部块，则构建Change并通知所有监听器。

        结束嵌套块不会触发通知。

        另请参见：
        beginChange()

      • addListener

        public final void addListener​(InvalidationListener listener)
        描述从接口Observable复制
        添加一个InvalidationListener ，当Observable无效时，它将被通知。 如果同一个监听器被多次添加，那么它将被多次通知。 也就是说，没有检查确保唯一性。

        请注意，相同的实际InvalidationListener实例可能会安全注册为不同的Observables 。

        Observable存储对侦听器的强烈引用，这将阻止侦听器被垃圾回收，并可能导致内存泄漏。 建议您在使用后通过调用removeListener注销监听器，或者使用WeakInvalidationListener的一个实例来避免这种情况。

        Specified by:
        addListener在接口 Observable
        参数
        listener - listener注册
        另请参见：
        Observable.removeListener(InvalidationListener)

      • removeListener

        public final void removeListener​(InvalidationListener listener)
        说明从界面Observable复制
        从监听器列表中删除给定的监听器，当Observable的值变为无效时通知Observable 。

        如果给定的侦听器以前没有被注册过（即它从未被添加过），那么这个方法调用是一个无操作的。 如果以前已经添加，那么它将被删除。 如果多次添加，那么只有第一次出现将被删除。

        Specified by:
        removeListener在接口 Observable
        参数
        listener - 要删除的侦听器
        另请参见：
        Observable.addListener(InvalidationListener)

      • addListener

        public final void addListener​(ListChangeListener<? super E> listener)
        说明从界面ObservableList复制
        将侦听器添加到此可观察列表中。
        Specified by:
        addListener在接口 ObservableList<E>
        参数
        listener - 用于监听列表更改的监听器

      • removeListener

        public final void removeListener​(ListChangeListener<? super E> listener)
        说明从接口ObservableList复制
        尝试从此可观察列表中删除侦听器。 如果监听者没有附加到此列表中，则不会发生任何事情。
        Specified by:
        removeListener在接口 ObservableList<E>
        参数
        listener - 要删除的侦听器

      • fireChange

        protected final void fireChange​(ListChangeListener.Change<? extends E> change)
        通知所有听众的变化
        参数
        change - 表示所做更改的对象

      • hasListeners

        protected final boolean hasListeners​()
        如果为此列表注册了一些监听器，则返回true。
        结果
        如果有这个列表的侦听器，则为true

      • addAll

        public boolean addAll​(E... elements)
        说明从界面ObservableList复制
        用于var-arg添加元素的方便方法。
        Specified by:
        addAll在接口 ObservableList<E>
        参数
        elements - 要添加的元素
        结果
        true（由Collection.add（E）指定）

      • setAll

        public boolean setAll​(E... elements)
        说明从接口ObservableList复制
        清除ObservableList并添加所有传递给var-args的元素。
        Specified by:
        setAll在接口 ObservableList<E>
        参数
        elements - 要设置的元素
        结果
        true（由Collection.add（E）指定）

      • setAll

        public boolean setAll​(Collection<? extends E> col)
        描述从接口ObservableList复制
        清除ObservableList并添加集合中的所有元素。
        Specified by:
        setAll在接口 ObservableList<E>
        参数
        col - 将添加到此observableArrayList的元素的集合
        结果
        true（由Collection.add（E）指定）

      • removeAll

        public boolean removeAll​(E... elements)
        说明从接口ObservableList复制
        对于 removeAll方法的var-arg使用的 方便方法。
        Specified by:
        removeAll在接口 ObservableList<E>
        参数
        elements - 要删除的元素
        结果
        如果列表因此调用而更改，则为true

      • retainAll

        public boolean retainAll​(E... elements)
        描述从接口ObservableList复制
        对于 retainAll方法的var-arg使用的 方便方法。
        Specified by:
        retainAll在接口 ObservableList<E>
        参数
        elements - 要保留的元素
        结果
        如果列表因此调用而更改，则为true

      • remove

        public void remove​(int from,
                   int to)
        描述从接口ObservableList复制
        一种调用sublist(from, to).clear()简化方法。 由于这是一个常见的操作，ObservableList具有方便使用的方法。
        Specified by:
        remove在接口 ObservableList<E>
        参数
        from - 要删除的范围的开始（含）
        to - 删除的范围的结束（排他）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface ObservableMap<K,V>

  • All Superinterfaces:
    Map<K,V> ， Observable
    All Known Subinterfaces:
    ObservableMapValue<K,V> ， WritableMapValue<K,V>
    所有已知实现类：
    MapBinding ， MapExpression ， MapProperty ， MapPropertyBase ， ReadOnlyMapProperty ， ReadOnlyMapPropertyBase ， ReadOnlyMapWrapper ， SimpleMapProperty

    public interface ObservableMap<K,V>
extends Map<K,V>, Observable
    一个允许观察者跟踪发生变化的地图。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MapChangeListener ， MapChangeListener.Change

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addListener​(MapChangeListener<? super K,? super V> listener)
      添加一个监听器到这个可观察的地图。
      void removeListener​(MapChangeListener<? super K,? super V> listener)
      试图从这个可观察的地图中删除一个听众。

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entry, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

    • 方法详细信息

      • addListener

        void addListener​(MapChangeListener<? super K,? super V> listener)
        添加一个监听器到这个可观察的地图。
        参数
        listener - 用于监听列表更改的侦听器

      • removeListener

        void removeListener​(MapChangeListener<? super K,? super V> listener)
        试图从这个可观察的地图中删除一个听众。 如果听众没有附加到这个地图，没有任何反应。
        参数
        listener - 要删除的侦听器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface ObservableSet<E>

  • All Superinterfaces:
    Collection<E> ， Iterable<E> ， Observable ， Set<E>
    All Known Subinterfaces:
    ObservableSetValue<E> ， WritableSetValue<E>
    所有已知实现类：
    ReadOnlySetProperty ， ReadOnlySetPropertyBase ， ReadOnlySetWrapper ， SetBinding ， SetExpression ， SetProperty ， SetPropertyBase ， SimpleSetProperty

    public interface ObservableSet<E>
extends Set<E>, Observable
    一组允许观察者跟踪变化发生时的变化。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    SetChangeListener ， SetChangeListener.Change

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addListener​(SetChangeListener<? super E> listener)
      添加一个监听器到这个可观察的集合。
      void removeListener​(SetChangeListener<? super E> listener)
      试图从这个可观察的集合中删除一个监听器。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, spliterator, toArray, toArray

    • 方法详细信息

      • addListener

        void addListener​(SetChangeListener<? super E> listener)
        添加一个监听器到这个可观察的集合。
        参数
        listener - 用于收听设置更改的收听者

      • removeListener

        void removeListener​(SetChangeListener<? super E> listener)
        试图从这个可观察的集合中删除一个监听器。 如果监听者没有附加到此列表中，则不会发生任何事情。
        参数
        listener - 要删除的侦听器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SetChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Interface SetChangeListener<E>

  • 参数类型
    E - 元素类型
    所有已知实现类：
    WeakSetChangeListener
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface SetChangeListener<E>
    接收ObservableSet更改通知的接口。
    从以下版本开始：
    JavaFX 2.1

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  SetChangeListener.Change<E>
      对ObservableSet进行基本更改。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void onChanged​(SetChangeListener.Change<? extends E> change)
      在对ObservableSet进行了更改后调用。

    • 方法详细信息

      • onChanged

        void onChanged​(SetChangeListener.Change<? extends E> change)
        在对ObservableSet进行了更改后调用。 每个基本变化（添加/删除）一次调用此方法。 这意味着，复杂的更改，如removeAll（Collection）或clear（）可能会导致多次调用onChanged方法。
        参数
        change - 所做的更改
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SetChangeListener.Change (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class SetChangeListener.Change<E>

  • java.lang.Object
    • javafx.collections.SetChangeListener.Change<E>
  • 参数类型
    E - 元素类型
    Enclosing interface:
    SetChangeListener < E >

    public abstract static class SetChangeListener.Change<E>
extends Object
    对ObservableSet进行基本更改。 更改包含有关添加或删除操作的信息。 请注意，添加已经在集合中的元素不会修改集合，因此不会生成任何更改。
    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      Change​(ObservableSet<E> set)
      构造与集相关联的更改。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract E getElementAdded​()
      获取新的元素。
      abstract E getElementRemoved​()
      获取旧元素。
      ObservableSet<E> getSet​()
      与变化相关联的可观察集合。
      abstract boolean wasAdded​()
      如果此更改是添加操作的结果。
      abstract boolean wasRemoved​()
      如果此更改是删除操作的结果。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Change

        public Change​(ObservableSet<E> set)
        构造与集相关联的更改。
        参数
        set - 更改的来源

    • 方法详细信息

      • getSet

        public ObservableSet<E> getSet​()
        与变化相关联的可观察集合。
        结果
        源集

      • wasAdded

        public abstract boolean wasAdded​()
        如果此更改是添加操作的结果。
        结果
        如果将一个新元素添加到集合中，则为true

      • wasRemoved

        public abstract boolean wasRemoved​()
        如果此更改是删除操作的结果。
        结果
        如果旧的元素从集合中删除，则为true

      • getElementAdded

        public abstract E getElementAdded​()
        获取新的元素。 如果这是一个删除，则返回null。
        结果
        刚添加的元素

      • getElementRemoved

        public abstract E getElementRemoved​()
        获取旧元素。 如果这是一个加法则返回null。
        结果
        刚刚删除的元素
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.collections (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.collections

  • Packages that use javafx.collections
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
  • Classes in javafx.collections used by javafx.animation
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
    ObservableMap
    一个允许观察者跟踪发生变化的地图。
  • Classes in javafx.collections used by javafx.beans.binding
    Class 描述
    ListChangeListener
    接收ObservableList更改通知的接口。
    MapChangeListener
    接收到ObservableMap更改通知的接口。
    ObservableArray
    ObservableArray是一个数组，允许监听器在发生变化时跟踪它们。
    ObservableFloatArray
    ObservableFloatArray是一个 float[]数组，允许侦听器在发生变化时跟踪它们。
    ObservableIntegerArray
    ObservableIntegerArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
    ObservableList
    允许侦听器发生变化的列表。
    ObservableMap
    一个允许观察者跟踪发生变化的地图。
    ObservableSet
    一组允许观察者跟踪变化发生时的变化。
    SetChangeListener
    接收ObservableSet更改通知的接口。
  • Classes in javafx.collections used by javafx.beans.property
    Class 描述
    ListChangeListener
    接收ObservableList更改通知的接口。
    ListChangeListener.Change
    表示对Observablelist进行的更改的报告。
    MapChangeListener
    接收到ObservableMap更改通知的接口。
    MapChangeListener.Change
    对ObservableMap做一个基本的改动。
    ObservableList
    允许侦听器发生变化的列表。
    ObservableMap
    一个允许观察者跟踪发生变化的地图。
    ObservableSet
    一组允许观察者跟踪变化发生时的变化。
    SetChangeListener
    接收ObservableSet更改通知的接口。
    SetChangeListener.Change
    对ObservableSet进行基本更改。
  • Classes in javafx.collections used by javafx.beans.value
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
    ObservableMap
    一个允许观察者跟踪发生变化的地图。
    ObservableSet
    一组允许观察者跟踪变化发生时的变化。
  • Classes in javafx.collections used by javafx.collections
    Class 描述
    ArrayChangeListener
    接收ObservableArray更改通知的接口。
    ListChangeListener
    接收ObservableList更改通知的接口。
    ListChangeListener.Change
    表示对Observablelist进行的更改的报告。
    MapChangeListener
    接收到ObservableMap更改通知的接口。
    MapChangeListener.Change
    对ObservableMap做一个基本的改动。
    ObservableArray
    ObservableArray是一个数组，允许侦听器在发生变化时跟踪它们。
    ObservableFloatArray
    ObservableFloatArray是一个 float[]数组，允许监听器在发生变化时跟踪变化。
    ObservableIntegerArray
    ObservableIntegerArray是一个 int[]数组，允许监听者在发生变化时跟踪变化。
    ObservableList
    允许侦听器发生变化的列表。
    ObservableListBase
    抽象类作为ObservableList实现的基类。
    ObservableMap
    一个允许观察者跟踪发生变化的地图。
    ObservableSet
    一组允许观察者跟踪变化发生时的变化。
    SetChangeListener
    接收ObservableSet更改通知的接口。
    SetChangeListener.Change
    对ObservableSet进行基本更改。
  • Classes in javafx.collections used by javafx.collections.transformation
    Class 描述
    ListChangeListener.Change
    表示对Observablelist进行的更改的报告。
    ObservableList
    允许侦听器发生变化的列表。
    ObservableListBase
    抽象类作为ObservableList实现的基类。
  • Classes in javafx.collections used by javafx.css
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
    ObservableSet
    一组允许观察者跟踪变化发生时的变化。
  • Classes in javafx.collections used by javafx.fxml
    Class 描述
    ObservableMap
    一个允许观察者跟踪发生变化的地图。
  • Classes in javafx.collections used by javafx.print
    Class 描述
    ObservableSet
    一组允许观察者跟踪变化发生时的变化。
  • Classes in javafx.collections used by javafx.scene
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
    ObservableMap
    一个允许观察者跟踪发生变化的地图。
    ObservableSet
    一组允许观察者跟踪变化发生时的变化。
  • Classes in javafx.collections used by javafx.scene.chart
    Class 描述
    ListChangeListener.Change
    表示对Observablelist进行的更改的报告。
    ObservableList
    允许侦听器发生变化的列表。
  • Classes in javafx.collections used by javafx.scene.control
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
    ObservableMap
    一个允许观察者跟踪发生变化的地图。
    ObservableSet
    一组允许观察者跟踪变化发生时的变化。
  • Classes in javafx.collections used by javafx.scene.control.cell
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
  • Classes in javafx.collections used by javafx.scene.control.skin
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
  • Classes in javafx.collections used by javafx.scene.input
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
  • Classes in javafx.collections used by javafx.scene.layout
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
  • Classes in javafx.collections used by javafx.scene.media
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
    ObservableMap
    一个允许观察者跟踪发生变化的地图。
  • Classes in javafx.collections used by javafx.scene.shape
    Class 描述
    ObservableArray
    ObservableArray是一个数组，允许侦听器在发生变化时跟踪它们。
    ObservableFloatArray
    ObservableFloatArray是一个 float[]数组，允许监听器在发生变化时跟踪变化。
    ObservableIntegerArray
    ObservableIntegerArray是一个 int[]数组，允许监听器在发生变化时跟踪变化。
    ObservableList
    允许侦听器发生变化的列表。
  • Classes in javafx.collections used by javafx.scene.web
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
  • Classes in javafx.collections used by javafx.stage
    Class 描述
    ObservableList
    允许侦听器发生变化的列表。
    ObservableMap
    A map that allows observers to track changes when they occur.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


WeakListChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class WeakListChangeListener<E>

  • java.lang.Object
    • javafx.collections.WeakListChangeListener<E>
  • 参数类型
    E - 观察值的类型
    All Implemented Interfaces:
    WeakListener ， ListChangeListener<E>

    public final class WeakListChangeListener<E>
extends Object
implements ListChangeListener<E>, WeakListener
    A WeakListChangeListener可以使用，如果一个ObservableList应该只保留一个弱参考的监听器。 这有助于避免内存泄漏，如果观察者在使用后未注册观察对象，则可能会发生这种情况。

    WeakListChangeListener是通过传入原来的ListChangeListener创建的。 然后应该注册WeakListChangeListener来监听观察对象的更改。

    注意：您必须保留对ListChangeListener的引用，只要它在使用中传递，否则将很快收集垃圾。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ListChangeListener ， ObservableList ， WeakListener

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javafx.collections.ListChangeListener

        ListChangeListener.Change<E>

    • 构造方法摘要

      构造方法
      Constructor 描述
      WeakListChangeListener​(ListChangeListener<E> listener)
      构造函数为 WeakListChangeListener 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void onChanged​(ListChangeListener.Change<? extends E> change)
      在对ObservableList进行了更改后调用。
      boolean wasGarbageCollected​()
      如果链接的侦听器被垃圾回收，则返回 true 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WeakListChangeListener

        public WeakListChangeListener​(ListChangeListener<E> listener)
        构造函数为 WeakListChangeListener 。
        参数
        listener - 应该通知的原始听众

    • 方法详细信息

      • wasGarbageCollected

        public boolean wasGarbageCollected​()
        如果链接的侦听器被垃圾回收，则返回true 。 在这种情况下，可以从observable中移除侦听器。
        Specified by:
        wasGarbageCollected在接口 WeakListener
        结果
        true如果链接的侦听器是垃圾回收的。

      • onChanged

        public void onChanged​(ListChangeListener.Change<? extends E> change)
        在对ObservableList进行了更改后调用。
        Specified by:
        onChanged在接口 ListChangeListener<E>
        参数
        change - 表示所做更改的对象
        另请参见：
        ListChangeListener.Change
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WeakMapChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class WeakMapChangeListener<K,V>

  • java.lang.Object
    • javafx.collections.WeakMapChangeListener<K,V>
  • 参数类型
    K - 关键元素类型
    V - 值元素类型
    All Implemented Interfaces:
    WeakListener ， MapChangeListener<K,V>

    public final class WeakMapChangeListener<K,V>
extends Object
implements MapChangeListener<K,V>, WeakListener
    A WeakMapChangeListener可以使用，如果一个ObservableMap应该只保留一个弱的参考侦听器。 这有助于避免内存泄漏，如果观察者在使用后未注册观察对象，则可能会发生这种情况。

    WeakMapChangeListener是通过传入原来的MapChangeListener创建的。 然后应该注册WeakMapChangeListener来监听被观察对象的变化。

    注意：你必须保留对MapChangeListener的引用，只要它在使用中被传递，否则将很快被垃圾收集。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    MapChangeListener ， ObservableMap ， WeakListener

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javafx.collections.MapChangeListener

        MapChangeListener.Change<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      WeakMapChangeListener​(MapChangeListener<K,V> listener)
      构造函数为 WeakMapChangeListener 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void onChanged​(MapChangeListener.Change<? extends K,? extends V> change)
      在对ObservableMap进行了更改后调用。
      boolean wasGarbageCollected​()
      如果链接的侦听器被垃圾回收，则返回 true 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WeakMapChangeListener

        public WeakMapChangeListener​(MapChangeListener<K,V> listener)
        构造函数为 WeakMapChangeListener 。
        参数
        listener - 应该通知的原始听众

    • 方法详细信息

      • wasGarbageCollected

        public boolean wasGarbageCollected​()
        如果链接的侦听器被垃圾回收，则返回true 。 在这种情况下，可以从observable中移除侦听器。
        Specified by:
        wasGarbageCollected在接口 WeakListener
        结果
        true如果链接的侦听器是垃圾回收的。

      • onChanged

        public void onChanged​(MapChangeListener.Change<? extends K,? extends V> change)
        在对ObservableMap进行了更改后调用。 每个基本变化（put / remove）一次调用此方法。 这意味着，像keySet（）。removeAll（Collection）或clear（）这样的复杂变化可能导致多次调用onChanged方法。
        Specified by:
        onChanged在接口 MapChangeListener<K,V>
        参数
        change - 所做的更改
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WeakSetChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections

Class WeakSetChangeListener<E>

  • java.lang.Object
    • javafx.collections.WeakSetChangeListener<E>
  • 参数类型
    E - 观察值的类型
    All Implemented Interfaces:
    WeakListener ， SetChangeListener<E>

    public final class WeakSetChangeListener<E>
extends Object
implements SetChangeListener<E>, WeakListener
    A WeakSetChangeListener可以使用，如果一个ObservableSet应该只保留一个对监听者的弱引用。 这有助于避免内存泄漏，如果观察者在使用后未注册观察对象，则可能会发生这种情况。

    WeakSetChangeListener是通过传入原来的SetChangeListener创建的。 然后应该注册WeakSetChangeListener来监听观察对象的更改。

    注意：你必须保留对SetChangeListener的引用，只要它在使用中被传递，否则将很快被垃圾收集。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    SetChangeListener ， ObservableSet ， WeakListener

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javafx.collections.SetChangeListener

        SetChangeListener.Change<E>

    • 构造方法摘要

      构造方法
      Constructor 描述
      WeakSetChangeListener​(SetChangeListener<E> listener)
      构造函数为 WeakSetChangeListener 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void onChanged​(SetChangeListener.Change<? extends E> change)
      在对ObservableSet进行了更改后调用。
      boolean wasGarbageCollected​()
      如果链接的侦听器被垃圾回收，则返回 true 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WeakSetChangeListener

        public WeakSetChangeListener​(SetChangeListener<E> listener)
        构造函数为 WeakSetChangeListener 。
        参数
        listener - 应该通知的原始听众

    • 方法详细信息

      • wasGarbageCollected

        public boolean wasGarbageCollected​()
        如果链接的侦听器被垃圾回收，则返回true 。 在这种情况下，可以从observable中移除侦听器。
        Specified by:
        wasGarbageCollected在接口 WeakListener
        结果
        true如果链接的侦听器是垃圾回收的。

      • onChanged

        public void onChanged​(SetChangeListener.Change<? extends E> change)
        在对ObservableSet进行了更改后调用。 每个基本变化（添加/删除）一次调用此方法。 这意味着，复杂的更改，如removeAll（Collection）或clear（）可能会导致多次调用onChanged方法。
        Specified by:
        onChanged在接口 SetChangeListener<E>
        参数
        change - 所做的更改
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.collections.FXCollections (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.FXCollections

No usage of javafx.collections.FXCollections
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.ListChangeListener.Change (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.ListChangeListener.Change

  • Packages that use ListChangeListener.Change
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of ListChangeListener.Change in javafx.beans.property

      Methods in javafx.beans.property with parameters of type ListChangeListener.Change
      Modifier and Type 方法 描述
      protected void ListPropertyBase.fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。
      protected void ReadOnlyListPropertyBase.fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)
      如果引用的内容ObservableList发生变化，则需要调用此方法。
      protected void ReadOnlyListWrapper.fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。

    • Uses of ListChangeListener.Change in javafx.collections

      Methods in javafx.collections with parameters of type ListChangeListener.Change
      Modifier and Type 方法 描述
      protected void ObservableListBase.fireChange​(ListChangeListener.Change<? extends E> change)
      通知所有听众的变化
      void ListChangeListener.onChanged​(ListChangeListener.Change<? extends E> c)
      在对ObservableList进行了更改后调用。
      void WeakListChangeListener.onChanged​(ListChangeListener.Change<? extends E> change)
      在对ObservableList进行了更改后调用。

    • Uses of ListChangeListener.Change in javafx.collections.transformation

      Methods in javafx.collections.transformation with parameters of type ListChangeListener.Change
      Modifier and Type | 方法 | 描述
      protected void | FilteredList.sourceChanged​(ListChangeListener.Change<? extends E> c)
      protected void | SortedList.sourceChanged​(ListChangeListener.Change<? extends E> c)
      protected abstract void TransformationList.sourceChanged​(ListChangeListener.Change<? extends F> c)
      当来自源的更改被触发时调用。

    • Uses of ListChangeListener.Change in javafx.scene.chart

      Methods in javafx.scene.chart with parameters of type ListChangeListener.Change
      Modifier and Type | 方法 | 描述
      protected void | AreaChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void | BarChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void | LineChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void | StackedAreaChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void | StackedBarChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void XYChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      当将每个原子更改作为此图表的系列列表时调用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.MapChangeListener.Change (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.MapChangeListener.Change

  • Packages that use MapChangeListener.Change
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of MapChangeListener.Change in javafx.beans.property

      Methods in javafx.beans.property with parameters of type MapChangeListener.Change
      Modifier and Type 方法 描述
      protected void MapPropertyBase.fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。
      protected void ReadOnlyMapPropertyBase.fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)
      如果引用的内容ObservableList发生变化，则需要调用此方法。
      protected void ReadOnlyMapWrapper.fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。

    • Uses of MapChangeListener.Change in javafx.collections

      Methods in javafx.collections with parameters of type MapChangeListener.Change
      Modifier and Type 方法 描述
      void MapChangeListener.onChanged​(MapChangeListener.Change<? extends K,? extends V> change)
      在对ObservableMap进行了更改后调用。
      void WeakMapChangeListener.onChanged​(MapChangeListener.Change<? extends K,? extends V> change)
      Called after a change has been made to an ObservableMap.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.ModifiableObservableListBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.ModifiableObservableListBase

No usage of javafx.collections.ModifiableObservableListBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.ObservableArrayBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.ObservableArrayBase

No usage of javafx.collections.ObservableArrayBase
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.ObservableListBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.ObservableListBase

  • Packages that use ObservableListBase
    软件包 描述
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。

    • Uses of ObservableListBase in javafx.collections

      Subclasses of ObservableListBase in javafx.collections
      Modifier and Type Class 描述
      class  ModifiableObservableListBase<E>
      抽象类，作为可修改的ObservableList实现的基类。

    • Uses of ObservableListBase in javafx.collections.transformation

      Subclasses of ObservableListBase in javafx.collections.transformation
      Modifier and Type Class 描述
      class  FilteredList<E>
      包装一个ObservableList并使用提供的谓词过滤其内容。
      class  SortedList<E>
      包装一个ObservableList并对其内容进行排序。
      class  TransformationList<E,F>
      所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.SetChangeListener.Change (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.SetChangeListener.Change

  • Packages that use SetChangeListener.Change
    软件包 描述
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of SetChangeListener.Change in javafx.beans.property

      Methods in javafx.beans.property with parameters of type SetChangeListener.Change
      Modifier and Type 方法 描述
      protected void ReadOnlySetPropertyBase.fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)
      如果引用的内容ObservableSet的内容发生变化，则需要调用此方法。
      protected void ReadOnlySetWrapper.fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。
      protected void SetPropertyBase.fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)
      发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。

    • Uses of SetChangeListener.Change in javafx.collections

      Methods in javafx.collections with parameters of type SetChangeListener.Change
      Modifier and Type 方法 描述
      void SetChangeListener.onChanged​(SetChangeListener.Change<? extends E> change)
      在对ObservableSet进行了更改后调用。
      void WeakSetChangeListener.onChanged​(SetChangeListener.Change<? extends E> change)
      Called after a change has been made to an ObservableSet.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.WeakListChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.WeakListChangeListener

No usage of javafx.collections.WeakListChangeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.WeakMapChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.WeakMapChangeListener

No usage of javafx.collections.WeakMapChangeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.WeakSetChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.WeakSetChangeListener

No usage of javafx.collections.WeakSetChangeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.ArrayChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.ArrayChangeListener

  • Packages that use ArrayChangeListener
    软件包 描述
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of ArrayChangeListener in javafx.collections

      Methods in javafx.collections with parameters of type ArrayChangeListener
      Modifier and Type | 方法 | 描述
      void ObservableArray.addListener​(ArrayChangeListener<T> listener)
      添加一个监听器到这个可观察的数组。
      void | ObservableArrayBase.addListener​(ArrayChangeListener<T> listener)
      void ObservableArray.removeListener​(ArrayChangeListener<T> listener)
      尝试从这个可观察数组中删除一个监听器。
      void | ObservableArrayBase.removeListener​(ArrayChangeListener<T> listener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.ListChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.ListChangeListener

  • Packages that use ListChangeListener
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of ListChangeListener in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type ListChangeListener
      Modifier and Type | 方法 | 描述
      void | ListBinding.addListener​(ListChangeListener<? super E> listener)
      void | ListBinding.removeListener​(ListChangeListener<? super E> listener)

    • Uses of ListChangeListener in javafx.beans.property

      Methods in javafx.beans.property with parameters of type ListChangeListener
      Modifier and Type | 方法 | 描述
      void | ListPropertyBase.addListener​(ListChangeListener<? super E> listener)
      void | ReadOnlyListPropertyBase.addListener​(ListChangeListener<? super E> listener)
      void | ListPropertyBase.removeListener​(ListChangeListener<? super E> listener)
      void | ReadOnlyListPropertyBase.removeListener​(ListChangeListener<? super E> listener)

    • Uses of ListChangeListener in javafx.collections

      Classes in javafx.collections that implement ListChangeListener
      Modifier and Type Class 描述
      class  WeakListChangeListener<E>
      A WeakListChangeListener可以使用，如果一个ObservableList应该只保留一个弱的参考侦听器。
      Methods in javafx.collections with parameters of type ListChangeListener
      Modifier and Type | 方法 | 描述
      void ObservableList.addListener​(ListChangeListener<? super E> listener)
      将侦听器添加到此可观察列表中。
      void | ObservableListBase.addListener​(ListChangeListener<? super E> listener)
      void ObservableList.removeListener​(ListChangeListener<? super E> listener)
      尝试从此可观察列表中删除侦听器。
      void | ObservableListBase.removeListener​(ListChangeListener<? super E> listener)
      Constructors in javafx.collections with parameters of type ListChangeListener
      Constructor 描述
      WeakListChangeListener​(ListChangeListener<E> listener)
      The constructor of WeakListChangeListener.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.MapChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.MapChangeListener

  • Packages that use MapChangeListener
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of MapChangeListener in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type MapChangeListener
      Modifier and Type | 方法 | 描述
      void | MapBinding.addListener​(MapChangeListener<? super K,? super V> listener)
      void | MapBinding.removeListener​(MapChangeListener<? super K,? super V> listener)

    • Uses of MapChangeListener in javafx.beans.property

      Methods in javafx.beans.property with parameters of type MapChangeListener
      Modifier and Type | 方法 | 描述
      void | MapPropertyBase.addListener​(MapChangeListener<? super K,? super V> listener)
      void | ReadOnlyMapPropertyBase.addListener​(MapChangeListener<? super K,? super V> listener)
      void | MapPropertyBase.removeListener​(MapChangeListener<? super K,? super V> listener)
      void | ReadOnlyMapPropertyBase.removeListener​(MapChangeListener<? super K,? super V> listener)

    • Uses of MapChangeListener in javafx.collections

      Classes in javafx.collections that implement MapChangeListener
      Modifier and Type Class 描述
      class  WeakMapChangeListener<K,V>
      A WeakMapChangeListener可以使用，如果一个ObservableMap应该只保留一个弱的参考侦听器。
      Methods in javafx.collections with parameters of type MapChangeListener
      Modifier and Type 方法 描述
      void ObservableMap.addListener​(MapChangeListener<? super K,? super V> listener)
      添加一个监听器到这个可观察的地图。
      void ObservableMap.removeListener​(MapChangeListener<? super K,? super V> listener)
      试图从这个可观察的地图中删除一个听众。
      Constructors in javafx.collections with parameters of type MapChangeListener
      Constructor 描述
      WeakMapChangeListener​(MapChangeListener<K,V> listener)
      The constructor of WeakMapChangeListener.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.ObservableArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.ObservableArray

  • Packages that use ObservableArray
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of ObservableArray in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type ObservableArray
      Modifier and Type 方法 描述
      static IntegerBinding Bindings.size​(ObservableArray op)
      创建一个新的IntegerBinding ，其大小为ObservableArray 。

    • Uses of ObservableArray in javafx.collections

      Classes in javafx.collections with type parameters of type ObservableArray
      Modifier and Type 接口 描述
      interface  ArrayChangeListener<T extends ObservableArray<T>>
      接收ObservableArray更改通知的接口。
      interface  ObservableArray<T extends ObservableArray<T>>
      ObservableArray是一个数组，允许监听器在发生变化时跟踪它们。
      class  ObservableArrayBase<T extends ObservableArray<T>>
      抽象类作为ObservableArray实现的基类。
      Subinterfaces of ObservableArray in javafx.collections
      Modifier and Type 接口 描述
      interface  ObservableFloatArray
      ObservableFloatArray是一个 float[]数组，允许监听器跟踪发生变化时。
      interface  ObservableIntegerArray
      ObservableIntegerArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
      Classes in javafx.collections that implement ObservableArray
      Modifier and Type Class 描述
      class  ObservableArrayBase<T extends ObservableArray<T>>
      抽象类作为ObservableArray实现的基类。

    • Uses of ObservableArray in javafx.scene.shape

      Subinterfaces of ObservableArray in javafx.scene.shape
      Modifier and Type 接口 描述
      interface  ObservableFaceArray
      ObservableFaceArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.ObservableFloatArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.ObservableFloatArray

  • Packages that use ObservableFloatArray
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of ObservableFloatArray in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type ObservableFloatArray
      Modifier and Type 方法 描述
      static FloatBinding Bindings.floatValueAt​(ObservableFloatArray op, int index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableArray的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableFloatArray op, ObservableIntegerValue index)
      创建一个新的FloatBinding ，其中包含指定位置的ObservableArray的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableFloatArray op, ObservableNumberValue index)
      创建一个新的FloatBinding ，其中包含ObservableArray在指定位置的元素。

    • Uses of ObservableFloatArray in javafx.collections

      Methods in javafx.collections that return ObservableFloatArray
      Modifier and Type 方法 描述
      static ObservableFloatArray FXCollections.observableFloatArray​()
      创建一个新的空可观察浮点数组。
      static ObservableFloatArray FXCollections.observableFloatArray​(float... values)
      创建一个新的可观察的浮点数组， values设置了 values 。
      static ObservableFloatArray FXCollections.observableFloatArray​(ObservableFloatArray array)
      在给定的 array创建一个新的可观察浮点数组，其中包含元素的副本。
      Methods in javafx.collections with parameters of type ObservableFloatArray
      Modifier and Type 方法 描述
      void ObservableFloatArray.addAll​(ObservableFloatArray src)
      将给定的可观察数组的内容附加到此数组的末尾。
      void ObservableFloatArray.addAll​(ObservableFloatArray src, int srcIndex, int length)
      将给定的可观察数组的一部分附加到该数组的末尾。
      void ObservableFloatArray.copyTo​(int srcIndex, ObservableFloatArray dest, int destIndex, int length)
      将数组的指定部分复制到 dest可观察数组。
      static ObservableFloatArray FXCollections.observableFloatArray​(ObservableFloatArray array)
      在给定的 array创建一个新的可观察浮点数组，其中包含元素的副本。
      void ObservableFloatArray.set​(int destIndex, ObservableFloatArray src, int srcIndex, int length)
      将指定的可观察数组的一部分复制到此可观察数组中。
      void ObservableFloatArray.setAll​(ObservableFloatArray src)
      用给定的observable数组的副本替换这个可观察的数组内容。
      void ObservableFloatArray.setAll​(ObservableFloatArray src, int srcIndex, int length)
      用给定的observable数组的一部分替换这个可观察的数组内容。

    • Uses of ObservableFloatArray in javafx.scene.shape

      Methods in javafx.scene.shape that return ObservableFloatArray
      Modifier and Type 方法 描述
      ObservableFloatArray TriangleMesh.getNormals​()
      获取 normals阵列如此 TriangleMesh 。
      ObservableFloatArray TriangleMesh.getPoints​()
      获取 points阵列如此 TriangleMesh 。
      ObservableFloatArray TriangleMesh.getTexCoords​()
      Gets the texCoords array of this TriangleMesh.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.ObservableIntegerArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.ObservableIntegerArray

  • Packages that use ObservableIntegerArray
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of ObservableIntegerArray in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type ObservableIntegerArray
      Modifier and Type 方法 描述
      static IntegerBinding Bindings.integerValueAt​(ObservableIntegerArray op, int index)
      创建一个新的IntegerBinding ，其中包含指定位置的元素ObservableArray 。
      static IntegerBinding Bindings.integerValueAt​(ObservableIntegerArray op, ObservableIntegerValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的元素ObservableArray 。
      static IntegerBinding Bindings.integerValueAt​(ObservableIntegerArray op, ObservableNumberValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的元素ObservableArray 。

    • Uses of ObservableIntegerArray in javafx.collections

      Methods in javafx.collections that return ObservableIntegerArray
      Modifier and Type 方法 描述
      static ObservableIntegerArray FXCollections.observableIntegerArray​()
      创建一个新的空可观察整数数组。
      static ObservableIntegerArray FXCollections.observableIntegerArray​(int... values)
      创建一个新的可观察整数数组， values设置了 values 。
      static ObservableIntegerArray FXCollections.observableIntegerArray​(ObservableIntegerArray array)
      使用给定的 array的元素副本创建一个新的可观察整数数组。
      Methods in javafx.collections with parameters of type ObservableIntegerArray
      Modifier and Type 方法 描述
      void ObservableIntegerArray.addAll​(ObservableIntegerArray src)
      将给定的可观察数组的内容附加到此数组的末尾。
      void ObservableIntegerArray.addAll​(ObservableIntegerArray src, int srcIndex, int length)
      将给定的可观察数组的一部分附加到该数组的末尾。
      void ObservableIntegerArray.copyTo​(int srcIndex, ObservableIntegerArray dest, int destIndex, int length)
      将数组的指定部分复制到 dest可观察数组中。
      static ObservableIntegerArray FXCollections.observableIntegerArray​(ObservableIntegerArray array)
      使用给定的 array的元素副本创建一个新的可观察整数数组。
      void ObservableIntegerArray.set​(int destIndex, ObservableIntegerArray src, int srcIndex, int length)
      将指定的可观察数组的一部分复制到此可观察数组中。
      void ObservableIntegerArray.setAll​(ObservableIntegerArray src)
      用给定的observable数组的副本替换这个可观察的数组内容。
      void ObservableIntegerArray.setAll​(ObservableIntegerArray src, int srcIndex, int length)
      用给定的observable数组的一部分替换这个可观察的数组内容。

    • Uses of ObservableIntegerArray in javafx.scene.shape

      Subinterfaces of ObservableIntegerArray in javafx.scene.shape
      Modifier and Type 接口 描述
      interface  ObservableFaceArray
      ObservableFaceArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
      Methods in javafx.scene.shape that return ObservableIntegerArray
      Modifier and Type 方法 描述
      ObservableIntegerArray TriangleMesh.getFaceSmoothingGroups​()
      获取 faceSmoothingGroups阵列如此 TriangleMesh 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.ObservableList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.ObservableList

  • Packages that use ObservableList
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.binding
    提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of ObservableList in javafx.animation

      Methods in javafx.animation that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<Animation> ParallelTransition.getChildren​()
      将按顺序播放的Animations的列表。
      ObservableList<Animation> SequentialTransition.getChildren​()
      将按顺序播放的Animations的列表。
      ObservableList<KeyFrame> Timeline.getKeyFrames​()
      返回KeyFrames的Timeline 。

    • Uses of ObservableList in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableList
      Modifier and Type Class 描述
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      class  ListExpression<E>
      ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding that return ObservableList
      Modifier and Type | 方法 | 描述
      protected abstract ObservableList<E> ListBinding.computeValue​()
      计算此绑定的当前值。
      ObservableList<E> ListBinding.get​()
      返回 ListBinding.computeValue()的结果。
      ObservableList<?> Binding.getDependencies​()
      返回绑定在不可修改的依赖关系ObservableList 。
      ObservableList<?> BooleanBinding.getDependencies​()
      默认执行getDependencies() ，返回一个空的ObservableList 。
      ObservableList<?> DoubleBinding.getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      ObservableList<?> FloatBinding.getDependencies​()
      默认实现getDependencies() ，返回一个空的ObservableList 。
      ObservableList<?> IntegerBinding.getDependencies​()
      默认实现getDependencies()返回一个空的ObservableList 。
      ObservableList<?> ListBinding.getDependencies​()
      默认实现getDependencies() ，返回一个空的ObservableList 。
      ObservableList<?> LongBinding.getDependencies​()
      默认实现getDependencies() ，返回一个空的ObservableList 。
      ObservableList<?> MapBinding.getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      ObservableList<?> ObjectBinding.getDependencies​()
      默认执行getDependencies() ，返回一个空的ObservableList 。
      ObservableList<?> SetBinding.getDependencies​()
      getDependencies()的默认实现返回一个空的ObservableList 。
      ObservableList<?> StringBinding.getDependencies​()
      默认执行getDependencies() ，返回一个空的ObservableList 。
      ObservableList<E> | ListExpression.getValue​()
      Methods in javafx.beans.binding with parameters of type ObservableList
      Modifier and Type 方法 描述
      static <E> void Bindings.bindContent​(List<E> list1, ObservableList<? extends E> list2)
      生成ObservableList和List之间的内容绑定。
      static <E> void Bindings.bindContentBidirectional​(ObservableList<E> list1, ObservableList<E> list2)
      在ObservableList的两个实例之间生成双向绑定（或“反向绑定”）。
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, int index)
      创建一个新的BooleanBinding ，其中包含ObservableList在指定位置的元素。
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, ObservableIntegerValue index)
      创建一个新的BooleanBinding ，其中包含指定位置的ObservableList元素。
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, ObservableNumberValue index)
      创建一个新的BooleanBinding ，其中包含指定位置的元素ObservableList 。
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的DoubleBinding ，其中包含在指定位置的ObservableList的元素。
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的DoubleBinding ，其中包含ObservableList在指定位置的元素。
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的DoubleBinding ，其中包含ObservableList在指定位置的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的FloatBinding ，其中包含ObservableList在指定位置的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的FloatBinding ，其中包含ObservableList在指定位置的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的FloatBinding ，其中包含在指定位置的ObservableList的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的IntegerBinding ，其中包含指定位置的元素ObservableList 。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的IntegerBinding ，其中包含ObservableList在指定位置的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的IntegerBinding ，其中包含在指定位置的ObservableList元素。
      static <E> BooleanBinding Bindings.isEmpty​(ObservableList<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableList为空，则保留true 。
      BooleanBinding ListExpression.isEqualTo​(ObservableList<?> other)
      创建一个新的BooleanBinding持有true如果此列表等于另一个ObservableList 。
      static <E> BooleanBinding Bindings.isNotEmpty​(ObservableList<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableList不为空，则保留true 。
      BooleanBinding ListExpression.isNotEqualTo​(ObservableList<?> other)
      创建一个新的BooleanBinding持有true如果此列表不等于另一个ObservableList 。
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的LongBinding ，其中包含指定位置的元素ObservableList 。
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的LongBinding ，其中包含指定位置的元素ObservableList 。
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的LongBinding ，其中包含ObservableList在指定位置的元素。
      static <E> IntegerBinding Bindings.size​(ObservableList<E> op)
      创建一个新的IntegerBinding ，其大小为ObservableList 。
      static StringBinding Bindings.stringValueAt​(ObservableList<String> op, int index)
      创建一个新的StringBinding ，其中包含指定位置的元素ObservableList 。
      static StringBinding Bindings.stringValueAt​(ObservableList<String> op, ObservableIntegerValue index)
      创建一个新的StringBinding ，其中包含指定位置的ObservableList的元素。
      static StringBinding Bindings.stringValueAt​(ObservableList<String> op, ObservableNumberValue index)
      创建一个新的StringBinding ，其中包含指定位置的元素ObservableList 。
      static <E> ObjectBinding<E> Bindings.valueAt​(ObservableList<E> op, int index)
      创建一个新的ObjectBinding ，其中包含指定位置的元素ObservableList 。
      static <E> ObjectBinding<E> Bindings.valueAt​(ObservableList<E> op, ObservableIntegerValue index)
      创建一个新的ObjectBinding ，其中包含指定位置的元素ObservableList 。
      static <E> ObjectBinding<E> Bindings.valueAt​(ObservableList<E> op, ObservableNumberValue index)
      创建一个新的ObjectBinding ，其中包含指定位置的ObservableList元素。
      Method parameters in javafx.beans.binding with type arguments of type ObservableList
      Modifier and Type | 方法 | 描述
      void | ListBinding.addListener​(ChangeListener<? super ObservableList<E>> listener)
      void | ListBinding.removeListener​(ChangeListener<? super ObservableList<E>> listener)

    • Uses of ObservableList in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableList
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  ReadOnlyListProperty<E>
      超类为所有只读属性包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleListProperty<E>
      这个类提供了一个Property包装一个ObservableList的完整实现。
      Methods in javafx.beans.property that return ObservableList
      Modifier and Type | 方法 | 描述
      ObservableList<E> | ListPropertyBase.get​()
      Methods in javafx.beans.property with parameters of type ObservableList
      Modifier and Type | 方法 | 描述
      void ReadOnlyListProperty.bindContent​(ObservableList<E> list)
      在ObservableList之间创建一个内容绑定，这是包裹在这个ReadOnlyListProperty和另一个ObservableList 。
      void ReadOnlyListProperty.bindContentBidirectional​(ObservableList<E> list)
      创建一个双向内容绑定的ObservableList ，即包装在这个ReadOnlyListProperty和另一个ObservableList 。
      void | ListPropertyBase.set​(ObservableList<E> newValue)
      void ListProperty.setValue​(ObservableList<E> v)
      设置包装的值。
      Method parameters in javafx.beans.property with type arguments of type ObservableList
      Modifier and Type | 方法 | 描述
      void | ListPropertyBase.addListener​(ChangeListener<? super ObservableList<E>> listener)
      void | ReadOnlyListPropertyBase.addListener​(ChangeListener<? super ObservableList<E>> listener)
      void | ListPropertyBase.bind​(ObservableValue<? extends ObservableList<E>> newObservable)
      void ListProperty.bindBidirectional​(Property<ObservableList<E>> other)
      在这个 Property和另一个之间创建双向绑定。
      void | ListPropertyBase.removeListener​(ChangeListener<? super ObservableList<E>> listener)
      void | ReadOnlyListPropertyBase.removeListener​(ChangeListener<? super ObservableList<E>> listener)
      void ListProperty.unbindBidirectional​(Property<ObservableList<E>> other)
      删除此 Property和另一个之间的双向绑定。
      Constructors in javafx.beans.property with parameters of type ObservableList
      Constructor 描述
      ListPropertyBase​(ObservableList<E> initialValue)
      ListPropertyBase的构造 ListPropertyBase 。
      ReadOnlyListWrapper​(Object bean, String name, ObservableList<E> initialValue)
      构造函数为 ReadOnlyListWrapper
      ReadOnlyListWrapper​(ObservableList<E> initialValue)
      构造函数为 ReadOnlyListWrapper
      SimpleListProperty​(Object bean, String name, ObservableList<E> initialValue)
      构造函数为 SimpleListProperty
      SimpleListProperty​(ObservableList<E> initialValue)
      构造函数为 SimpleListProperty

    • Uses of ObservableList in javafx.beans.value

      Subinterfaces of ObservableList in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableListValue<E>
      一个可观察的参考一个ObservableList 。
      interface  WritableListValue<E>
      可写参考一个ObservableList 。

    • Uses of ObservableList in javafx.collections

      Classes in javafx.collections that implement ObservableList
      Modifier and Type Class 描述
      class  ModifiableObservableListBase<E>
      抽象类作为可修改的ObservableList实现的基类。
      class  ObservableListBase<E>
      抽象类，用作ObservableList实现的基类。
      Methods in javafx.collections that return ObservableList
      Modifier and Type 方法 描述
      static <E> ObservableList<E> FXCollections.checkedObservableList​(ObservableList<E> list, Class<E> type)
      在提供的可观察列表之上创建并返回一个类型安全的包装器。
      static <E> ObservableList<E> FXCollections.concat​(ObservableList<E>... lists)
      将更多可观察的列表连接成一个。
      static <E> ObservableList<E> FXCollections.emptyObservableList​()
      创建和清空不可修改的可观察列表。
      ObservableList<E> ListChangeListener.Change.getList​()
      源列表的更改。
      static <E> ObservableList<E> FXCollections.observableArrayList​()
      创建一个由数组列表支持的新的可观察列表。
      static <E> ObservableList<E> FXCollections.observableArrayList​(E... items)
      创建一个新的可观察数组列表， items添加了 items 。
      static <E> ObservableList<E> FXCollections.observableArrayList​(Collection<? extends E> col)
      创建一个新的可观察数组列表，并向其添加一个集合 col的内容。
      static <E> ObservableList<E> FXCollections.observableArrayList​(Callback<E,Observable[]> extractor)
      创建一个由arraylist支持的新的可观察列表。
      static <E> ObservableList<E> FXCollections.observableList​(List<E> list)
      构造由指定列表支持的ObservableList。
      static <E> ObservableList<E> FXCollections.observableList​(List<E> list, Callback<E,Observable[]> extractor)
      构造由指定列表支持的ObservableList。
      static <E> ObservableList<E> FXCollections.singletonObservableList​(E e)
      使用单个元素创建一个不可修改的可观察列表。
      static <E> ObservableList<E> FXCollections.synchronizedObservableList​(ObservableList<E> list)
      在提供的可观察列表之上创建并返回一个同步的包装器。
      static <E> ObservableList<E> FXCollections.unmodifiableObservableList​(ObservableList<E> list)
      在提供的可观察列表之上创建并返回不可修改的包装器列表。
      Methods in javafx.collections with parameters of type ObservableList
      Modifier and Type 方法 描述
      static <E> ObservableList<E> FXCollections.checkedObservableList​(ObservableList<E> list, Class<E> type)
      在提供的可观察列表之上创建并返回一个类型安全的包装器。
      static <E> ObservableList<E> FXCollections.concat​(ObservableList<E>... lists)
      将更多可观察的列表连接成一个。
      static <T> void FXCollections.copy​(ObservableList<? super T> dest, List<? extends T> src)
      将元素从src复制到dest。
      static <T> void FXCollections.fill​(ObservableList<? super T> list, T obj)
      用obj填写提供的列表。
      static <T> boolean FXCollections.replaceAll​(ObservableList<T> list, T oldVal, T newVal)
      用newVal元素替换列表中的所有oldVal元素。
      static void FXCollections.reverse​(ObservableList list)
      反转列表中的顺序列表中仅发送 一个更改通知。
      static void FXCollections.rotate​(ObservableList list, int distance)
      按距离旋转列表。
      static void FXCollections.shuffle​(ObservableList<?> list)
      随机播放可观察列表中的所有元素。
      static void FXCollections.shuffle​(ObservableList list, Random rnd)
      随机播放可观察列表中的所有元素。
      static <T extends Comparable<? super T>>
      void             		FXCollections.sort​(ObservableList<T> list)
      对提供的可观察列表进行排序。
      static <T> void FXCollections.sort​(ObservableList<T> list, Comparator<? super T> c)
      使用c比较器对提供的可观察列表进行排序。
      static <E> ObservableList<E> FXCollections.synchronizedObservableList​(ObservableList<E> list)
      在提供的可观察列表之上创建并返回一个同步的包装器。
      static <E> ObservableList<E> FXCollections.unmodifiableObservableList​(ObservableList<E> list)
      在提供的可观察列表之上创建并返回不可修改的包装器列表。
      Constructors in javafx.collections with parameters of type ObservableList
      Constructor 描述
      Change​(ObservableList<E> list)
      构造一个新的列表更改。

    • Uses of ObservableList in javafx.collections.transformation

      Classes in javafx.collections.transformation that implement ObservableList
      Modifier and Type Class 描述
      class  FilteredList<E>
      包装一个ObservableList并使用提供的谓词过滤其内容。
      class  SortedList<E>
      包装一个ObservableList并对其内容进行排序。
      class  TransformationList<E,F>
      所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。
      Methods in javafx.collections.transformation that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<? extends F> TransformationList.getSource​()
      在此转换列表的构造函数中指定的源列表。
      Methods in javafx.collections.transformation with parameters of type ObservableList
      Modifier and Type 方法 描述
      int TransformationList.getSourceIndexFor​(ObservableList<?> list, int index)
      将此列表元素的索引映射到所提供的 list的索引。
      boolean TransformationList.isInTransformationChain​(ObservableList<?> list)
      检查提供的列表是否在此 TransformationList下的链中。
      Constructors in javafx.collections.transformation with parameters of type ObservableList
      Constructor 描述
      FilteredList​(ObservableList<E> source)
      在源列表周围构造一个新的FilteredList包装器。
      FilteredList​(ObservableList<E> source, Predicate<? super E> predicate)
      在源列表周围构造一个新的FilteredList包装器。
      SortedList​(ObservableList<? extends E> source)
      在源列表周围构造一个新的无序SortedList包装器。
      SortedList​(ObservableList<? extends E> source, Comparator<? super E> comparator)
      创建一个围绕源列表的新SortedList。
      TransformationList​(ObservableList<? extends F> source)
      创建一个围绕源列表的新的Transformation列表。

    • Uses of ObservableList in javafx.css

      Methods in javafx.css that return ObservableList
      Modifier and Type | 方法 | 描述
      static ObservableList<CssParser.ParseError> | CssParser.errorsProperty​()
      ObservableList<Declaration> Rule.getDeclarations​()
      此方法是支持可能希望从规则添加声明或从规则中删除声明的工具。
      ObservableList<Selector> Rule.getSelectors​()
      此方法是支持可能希望从Rule添加选择器或从Rule中删除选择器的工具。
      ObservableList<String> Styleable.getStyleClass​()
      可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。

    • Uses of ObservableList in javafx.scene

      Methods in javafx.scene that return ObservableList
      Modifier and Type | 方法 | 描述
      ObservableList<Node> Group.getChildren​()
      获取此 Group的孩子列表。
      protected ObservableList<Node> Parent.getChildren​()
      获取此 Parent的孩子列表。
      ObservableList<Node> Parent.getChildrenUnmodifiable​()
      获取此 Parent的子项列表作为只读列表。
      ObservableList<Node> LightBase.getScope​()
      获取指定此Light的分层范围的节点列表。
      ObservableList<String> | Node.getStyleClass​()
      ObservableList<String> Parent.getStylesheets​()
      获取链接到此父项内容使用的样式表的字符串URL的可观察列表。
      ObservableList<String> Scene.getStylesheets​()
      获取链接到与场景内容一起使用的样式表的字符串URL的可观察列表。
      ObservableList<Transform> Node.getTransforms​()
      定义的ObservableList Transform个对象被应用到这个Node 。
      Methods in javafx.scene that return types with arguments of type ObservableList
      Modifier and Type 方法 描述
      ObservableMap<KeyCombination,ObservableList<Mnemonic>> Scene.getMnemonics​()
      获取 Scene的助记符列表。

    • Uses of ObservableList in javafx.scene.chart

      Methods in javafx.scene.chart that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<String> CategoryAxis.getCategories​()
      返回在该轴上绘制的类别中的ObservableList 。
      protected ObservableList<Node> Chart.getChartChildren​()
      图表中所有内容的可修改和可观察的列表。
      ObservableList<PieChart.Data> PieChart.getData​()
      获取属性数据的值。
      ObservableList<XYChart.Series<X,Y>> XYChart.getData​()
      获取属性数据的值。
      ObservableList<XYChart.Data<X,Y>> XYChart.Series.getData​()
      获取属性数据的值。
      protected ObservableList<Node> XYChart.getPlotChildren​()
      情节中所有内容的可修改和可观察的列表。
      ObservableList<Axis.TickMark<T>> Axis.getTickMarks​()
      不可修改的可观察的刻度表列表，每个TickMark在此轴上直接表示一个刻度。
      Methods in javafx.scene.chart that return types with arguments of type ObservableList
      Modifier and Type 方法 描述
      ObjectProperty<ObservableList<PieChart.Data>> PieChart.dataProperty​()
      PieCharts数据
      ObjectProperty<ObservableList<XYChart.Series<X,Y>>> XYChart.dataProperty​()
      XYCharts数据
      ObjectProperty<ObservableList<XYChart.Data<X,Y>>> XYChart.Series.dataProperty​()
      ObservableList组成本系列的数据项
      Methods in javafx.scene.chart with parameters of type ObservableList
      Modifier and Type 方法 描述
      void CategoryAxis.setCategories​(ObservableList<String> value)
      在此轴上绘制的类别的有序列表。
      void PieChart.setData​(ObservableList<PieChart.Data> value)
      设置属性数据的值。
      void XYChart.Series.setData​(ObservableList<XYChart.Data<X,Y>> value)
      设置属性数据的值。
      void XYChart.setData​(ObservableList<XYChart.Series<X,Y>> value)
      设置属性数据的值。
      Constructors in javafx.scene.chart with parameters of type ObservableList
      Constructor 描述
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      用给定的轴和数据构造一个新的BarChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的BubbleChart。
      CategoryAxis​(ObservableList<String> categories)
      创建具有给定类别的类别轴。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的LineChart。
      PieChart​(ObservableList<PieChart.Data> data)
      用给定的数据构建一个新的PieChart
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造新的ScatterChart。
      Series​(String name, ObservableList<XYChart.Data<X,Y>> data)
      构造一个命名的系列，并使用给定的ObservableList数据填充它。
      Series​(ObservableList<XYChart.Data<X,Y>> data)
      构造一个系列，并使用给定的ObservableList数据填充它。
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      使用给定的轴和数据构造一个新的StackedBarChart。

    • Uses of ObservableList in javafx.scene.control

      Methods in javafx.scene.control that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<Node> ButtonBar.getButtons​()
      在此ObservableList内放置按钮将指示ButtonBar根据其指定的ButtonBar.ButtonData相对于彼此定位 。
      ObservableList<ButtonType> Alert.getButtonTypes​()
      返回此警报实例中当前设置的所有ButtonType个实例中的ObservableList 。
      ObservableList<ButtonType> DialogPane.getButtonTypes​()
      用于对话框按钮栏区域的按钮类型的可观察列表（通过 DialogPane.createButtonBar()方法创建）。
      ObservableList<Node> SkinBase.getChildren​()
      返回皮肤的孩子。
      ObservableList<TreeItem<T>> TreeItem.getChildren​()
      这个TreeItem的孩子。
      ObservableList<TableColumn<S,?>> TableColumn.getColumns​()
      这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。
      abstract ObservableList<? extends TableColumnBase<S,?>> TableColumnBase.getColumns​()
      这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。
      ObservableList<TableColumn<S,?>> TableView.getColumns​()
      TableColumns是TableView的一部分。
      ObservableList<TreeTableColumn<S,?>> TreeTableColumn.getColumns​()
      这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。
      ObservableList<TreeTableColumn<S,?>> TreeTableView.getColumns​()
      作为TableView的一部分的TreeTableColumns。
      ObservableList<Color> ColorPicker.getCustomColors​()
      获取用户添加到调色板的自定义颜色列表。
      ObservableList<SplitPane.Divider> SplitPane.getDividers​()
      返回此SplitPane中所有分隔符的不可修改列表。
      ObservableList<T> ChoiceBox.getItems​()
      获取属性项的值。
      ObservableList<T> ChoiceDialog.getItems​()
      返回将显示给用户的所有项目的列表。
      ObservableList<T> ComboBox.getItems​()
      获取属性项的值。
      ObservableList<MenuItem> ContextMenu.getItems​()
      上下文菜单中的菜单项。
      ObservableList<T> ListView.getItems​()
      返回一个ObservableList ，其中包含当前显示给用户的项目。
      ObservableList<MenuItem> Menu.getItems​()
      在此菜单中显示的项目。
      ObservableList<MenuItem> MenuButton.getItems​()
      在此按钮菜单中显示的项目。
      ObservableList<T> SpinnerValueFactory.ListSpinnerValueFactory.getItems​()
      返回一个ObservableList ，其中包含当前用户可以迭代的项目。
      ObservableList<Node> SplitPane.getItems​()
      返回一个ObservableList，可用于修改SplitPane的内容。
      ObservableList<S> TableView.getItems​()
      获取属性项的值。
      ObservableList<Node> ToolBar.getItems​()
      ToolBar包含的项目。
      ObservableList<Menu> MenuBar.getMenus​()
      在MenuBar中显示的菜单。
      ObservableList<TitledPane> Accordion.getPanes​()
      获得此手风琴中的TitledPane的列表。
      ObservableList<CharSequence> TextArea.getParagraphs​()
      返回返回文本区域内容的字符序列的不可修改列表。
      abstract ObservableList<TablePosition> TableView.TableViewSelectionModel.getSelectedCells​()
      一个只读ObservableList，表示此TableView中当前选定的单元格。
      abstract ObservableList<TreeTablePosition<S,?>> TreeTableView.TreeTableViewSelectionModel.getSelectedCells​()
      一个只读ObservableList，表示此TreeTableView中当前选定的单元格。
      abstract ObservableList<Integer> MultipleSelectionModel.getSelectedIndices​()
      返回所有选定索引的 只读 ObservableList。
      abstract ObservableList<T> MultipleSelectionModel.getSelectedItems​()
      返回所有选定项目的 只读 ObservableList。
      ObservableList<TableColumn<S,?>> TableView.getSortOrder​()
      sortOrder列表定义TableColumn实例的排序顺序。
      ObservableList<TreeTableColumn<S,?>> TreeTableView.getSortOrder​()
      sortOrder列表定义TreeTableColumn实例进行排序的顺序。
      ObservableList<String> MenuItem.getStyleClass​()
      *公开API * *
      ObservableList<String> PopupControl.getStyleClass​()
      返回构成此PopupControl的styleClass的String标识符列表。
      ObservableList<String> Tab.getStyleClass​()
      可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。
      ObservableList<String> TableColumnBase.getStyleClass​()
      可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。
      ObservableList<Tab> TabPane.getTabs​()
      要在此TabPane中显示的选项卡。
      ObservableList<Toggle> ToggleGroup.getToggles​()
      ToggleGroup中的切换列表。
      ObservableList<TableColumn<S,?>> TableView.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      ObservableList<TreeTableColumn<S,?>> TreeTableView.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      Methods in javafx.scene.control that return types with arguments of type ObservableList
      Modifier and Type 方法 描述
      ObjectProperty<ObservableList<T>> ChoiceBox.itemsProperty​()
      要在选框中显示的项目。
      ObjectProperty<ObservableList<T>> ComboBox.itemsProperty​()
      在ComboBox弹出窗口中显示的项目列表。
      ObjectProperty<ObservableList<T>> ListView.itemsProperty​()
      ListView的底层数据模型。
      ObjectProperty<ObservableList<T>> SpinnerValueFactory.ListSpinnerValueFactory.itemsProperty​()
      ListView的底层数据模型。
      ObjectProperty<ObservableList<S>> TableView.itemsProperty​()
      TableView的基础数据模型。
      Methods in javafx.scene.control with parameters of type ObservableList
      Modifier and Type 方法 描述
      void ChoiceBox.setItems​(ObservableList<T> value)
      设置属性项的值。
      void ComboBox.setItems​(ObservableList<T> value)
      设置属性项的值。
      void ListView.setItems​(ObservableList<T> value)
      设置ListView的底层数据模型。
      void SpinnerValueFactory.ListSpinnerValueFactory.setItems​(ObservableList<T> value)
      设置ListSpinnerValueFactory的底层数据模型。
      void TableView.setItems​(ObservableList<S> value)
      设置属性项的值。
      Constructors in javafx.scene.control with parameters of type ObservableList
      Constructor 描述
      ChoiceBox​(ObservableList<T> items)
      使用给定的项目创建一个新的ChoiceBox。
      ComboBox​(ObservableList<T> items)
      使用提供的项目列表和默认的 selection model创建一个默认的ComboBox实例。
      ListSpinnerValueFactory​(ObservableList<T> items)
      创建一个ListSpinnerValueFactory的新实例，其中给定的列表用作列表以逐步完成。
      ListView​(ObservableList<T> items)
      创建一个默认的ListView，它将堆叠从垂直提供的ObservableList检索的内容。
      Spinner​(ObservableList<T> items)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.ListSpinnerValueFactory 。
      TableView​(ObservableList<S> items)
      使用ObservableList项中提供的内容创建TableView。

    • Uses of ObservableList in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<T> ChoiceBoxListCell.getItems​()
      返回要显示在ChoiceBox中的项目。
      ObservableList<T> ChoiceBoxTableCell.getItems​()
      返回要显示在ChoiceBox中的项目。
      ObservableList<T> ChoiceBoxTreeCell.getItems​()
      返回要显示在ChoiceBox中的项目。
      ObservableList<T> ChoiceBoxTreeTableCell.getItems​()
      返回要显示在ChoiceBox中的项目。
      ObservableList<T> ComboBoxListCell.getItems​()
      返回要显示在ChoiceBox中的项目。
      ObservableList<T> ComboBoxTableCell.getItems​()
      返回要显示在ComboBox中的项目。
      ObservableList<T> ComboBoxTreeCell.getItems​()
      返回要显示在ComboBox中的项目。
      ObservableList<T> ComboBoxTreeTableCell.getItems​()
      返回要显示在ComboBox中的项目。
      Methods in javafx.scene.control.cell with parameters of type ObservableList
      Modifier and Type 方法 描述
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于ListView控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeView控件。
      Constructors in javafx.scene.control.cell with parameters of type ObservableList
      Constructor 描述
      ChoiceBoxListCell​(ObservableList<T> items)
      创建默认的ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxListCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxListCell实例，给定的项目用于填充ChoiceBox ，并显示StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTableCell​(ObservableList<T> items)
      创建默认的ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeCell​(ObservableList<T> items)
      创建默认的ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxTreeCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxTreeCell实例，给定的项目用于填充ChoiceBox ，并显示StringConverter用于将项目转换为用户可读的表单。
      ChoiceBoxTreeTableCell​(ObservableList<T> items)
      创建默认的ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxTreeTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时显示ChoiceBox ，而StringConverter用于将项目转换为用户可读的表单。
      ComboBoxListCell​(ObservableList<T> items)
      创建默认的ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxListCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxListCell实例，给出的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的表单。
      ComboBoxTableCell​(ObservableList<T> items)
      创建默认的ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxTableCell实例，给定的项目用于填充ComboBox ，并显示StringConverter用于将该项目转换为用户可读的表单。
      ComboBoxTreeCell​(ObservableList<T> items)
      创建默认的ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxTreeCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeTableCell​(ObservableList<T> items)
      创建默认的ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxTreeTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxTreeTableCell实例，给定的项目用于填充ComboBox ，并显示StringConverter用于将该项目转换为用户可读的形式。

    • Uses of ObservableList in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<TableColumnHeader> NestedTableColumnHeader.getColumnHeaders​()
      返回这个NestedTableColumnHeader的子代的TableColumnHeader实例的不可修改列表。
      protected ObservableList<TableColumn<T,?>> TableRowSkin.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      protected abstract ObservableList<? extends TableColumnBase> TableRowSkinBase.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      protected ObservableList<TreeTableColumn<T,?>> TreeTableRowSkin.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。

    • Uses of ObservableList in javafx.scene.input

      Methods in javafx.scene.input that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<InputMethodTextRun> InputMethodEvent.getComposed​()
      获取组合下的文本。

    • Uses of ObservableList in javafx.scene.layout

      Methods in javafx.scene.layout that return ObservableList
      Modifier and Type | 方法 | 描述
      ObservableList<Node> | Pane.getChildren​()
      ObservableList<ColumnConstraints> GridPane.getColumnConstraints​()
      返回列约束列表。
      ObservableList<RowConstraints> GridPane.getRowConstraints​()
      返回行约束列表。

    • Uses of ObservableList in javafx.scene.media

      Methods in javafx.scene.media that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<EqualizerBand> AudioEqualizer.getBands​()
      ObservableList包含EqualizerBand个元素。
      ObservableList<Track> Media.getTracks​()
      检索此媒体源中包含的曲目。

    • Uses of ObservableList in javafx.scene.shape

      Methods in javafx.scene.shape that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<PathElement> Path.getElements​()
      获取此路径的路径元素的可观察列表。
      ObservableList<Double> Polygon.getPoints​()
      获取 Polygon顶点的坐标。
      ObservableList<Double> Polyline.getPoints​()
      获取 PolyLine段的坐标。
      ObservableList<Double> Shape.getStrokeDashArray​()
      定义表示短划线段长度的数组。

    • Uses of ObservableList in javafx.scene.web

      Methods in javafx.scene.web that return ObservableList
      Modifier and Type | 方法 | 描述
      protected ObservableList<Node> | WebView.getChildren​()
      ObservableList<WebHistory.Entry> WebHistory.getEntries​()
      返回历史记录中所有条目的不可修改的可观察列表。

    • Uses of ObservableList in javafx.stage

      Methods in javafx.stage that return ObservableList
      Modifier and Type 方法 描述
      ObservableList<Node> Popup.getContent​()
      Node的ObservableList将在此 Popup上呈现。
      ObservableList<FileChooser.ExtensionFilter> FileChooser.getExtensionFilters​()
      获取显示文件对话框中使用的扩展过滤器。
      ObservableList<Image> Stage.getIcons​()
      获取窗口装饰中使用的图标图像和最小化时。
      static ObservableList<Screen> Screen.getScreens​()
      当前可用的可观察列表 Screens 。
      static ObservableList<Screen> Screen.getScreensForRectangle​(double x, double y, double width, double height)
      返回与所提供的矩形相交的ObservableList为 Screens 。
      static ObservableList<Screen> Screen.getScreensForRectangle​(Rectangle2D r)
      返回与所提供的矩形相交的ObservableList为 Screens 。
      static ObservableList<Window> Window.getWindows​()
      Returns a list containing a reference to the currently showing JavaFX windows.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.ObservableMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.ObservableMap

  • Packages that use ObservableMap
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of ObservableMap in javafx.animation

      Methods in javafx.animation that return ObservableMap
      Modifier and Type 方法 描述
      ObservableMap<String,Duration> Animation.getCuePoints​()
      提示点可用于标记 Animation重要位置。

    • Uses of ObservableMap in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableMap
      Modifier and Type Class 描述
      class  MapBinding<K,V>
      提供实现ObservableMap的Binding所需的大部分功能的基类。
      class  MapExpression<K,V>
      MapExpression是一个ObservableMapValue加上额外的便利方法，以流利的风格生成绑定。
      Methods in javafx.beans.binding that return ObservableMap
      Modifier and Type | 方法 | 描述
      protected abstract ObservableMap<K,V> MapBinding.computeValue​()
      计算此绑定的当前值。
      ObservableMap<K,V> MapBinding.get​()
      返回 MapBinding.computeValue()的结果。
      ObservableMap<K,V> | MapExpression.getValue​()
      Methods in javafx.beans.binding with parameters of type ObservableMap
      Modifier and Type 方法 描述
      static <K,V> void Bindings.bindContent​(Map<K,V> map1, ObservableMap<? extends K,? extends V> map2)
      生成ObservableMap和Map之间的内容绑定。
      static <K,V> void Bindings.bindContentBidirectional​(ObservableMap<K,V> map1, ObservableMap<K,V> map2)
      在ObservableMap的两个实例之间生成双向绑定（或“绑定”）。
      static <K> BooleanBinding Bindings.booleanValueAt​(ObservableMap<K,Boolean> op, ObservableValue<? extends K> key)
      创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> BooleanBinding Bindings.booleanValueAt​(ObservableMap<K,Boolean> op, K key)
      创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> DoubleBinding Bindings.doubleValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> DoubleBinding Bindings.doubleValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> FloatBinding Bindings.floatValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> FloatBinding Bindings.floatValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> IntegerBinding Bindings.integerValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> IntegerBinding Bindings.integerValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。
      static <K,V> BooleanBinding Bindings.isEmpty​(ObservableMap<K,V> op)
      创建一个新的BooleanBinding ，如果一个给定的ObservableMap是空的，那么它将持有true 。
      BooleanBinding MapExpression.isEqualTo​(ObservableMap<?,?> other)
      创建一个新的BooleanBinding持有true如果此映射等于另一个ObservableMap 。
      static <K,V> BooleanBinding Bindings.isNotEmpty​(ObservableMap<K,V> op)
      创建一个新的BooleanBinding ，如果给定的ObservableMap不为空，则保留true 。
      BooleanBinding MapExpression.isNotEqualTo​(ObservableMap<?,?> other)
      创建一个新的BooleanBinding持有true如果此映射不等于另一个ObservableMap 。
      static <K> LongBinding Bindings.longValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> LongBinding Bindings.longValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
      static <K,V> IntegerBinding Bindings.size​(ObservableMap<K,V> op)
      创建一个新的IntegerBinding ，其大小为ObservableMap 。
      static <K> StringBinding Bindings.stringValueAt​(ObservableMap<K,String> op, ObservableValue<? extends K> key)
      创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> StringBinding Bindings.stringValueAt​(ObservableMap<K,String> op, K key)
      创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。
      static <K,V> ObjectBinding<V> Bindings.valueAt​(ObservableMap<K,V> op, ObservableValue<? extends K> key)
      创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
      static <K,V> ObjectBinding<V> Bindings.valueAt​(ObservableMap<K,V> op, K key)
      创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
      Method parameters in javafx.beans.binding with type arguments of type ObservableMap
      Modifier and Type | 方法 | 描述
      void | MapBinding.addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | MapBinding.removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)

    • Uses of ObservableMap in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableMap
      Modifier and Type Class 描述
      class  MapProperty<K,V>
      这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
      class  MapPropertyBase<K,V>
      MapPropertyBase类是包装一个ObservableMap的属性的基类。
      class  ReadOnlyMapProperty<K,V>
      超类为所有只读属性包装一个ObservableMap 。
      class  ReadOnlyMapPropertyBase<K,V>
      所有只读属性的基类包装一个ObservableMap 。
      class  ReadOnlyMapWrapper<K,V>
      该类提供了一个方便的类来定义只读属性。
      class  SimpleMapProperty<K,V>
      这个类提供了一个包含ObservableMap的ObservableMap的完整实现。
      Methods in javafx.beans.property that return ObservableMap
      Modifier and Type | 方法 | 描述
      ObservableMap<K,V> | MapPropertyBase.get​()
      Methods in javafx.beans.property with parameters of type ObservableMap
      Modifier and Type | 方法 | 描述
      void ReadOnlyMapProperty.bindContent​(ObservableMap<K,V> map)
      创建ObservableMap之间的内容绑定，即包含在这个ReadOnlyMapProperty ，另一个是ObservableMap 。
      void ReadOnlyMapProperty.bindContentBidirectional​(ObservableMap<K,V> map)
      创建一个双向内容绑定的ObservableMap ，即包装在这个ReadOnlyMapProperty和另一个ObservableMap 。
      void | MapPropertyBase.set​(ObservableMap<K,V> newValue)
      void MapProperty.setValue​(ObservableMap<K,V> v)
      设置包装的值。
      Method parameters in javafx.beans.property with type arguments of type ObservableMap
      Modifier and Type | 方法 | 描述
      void | MapPropertyBase.addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | ReadOnlyMapPropertyBase.addListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | MapPropertyBase.bind​(ObservableValue<? extends ObservableMap<K,V>> newObservable)
      void MapProperty.bindBidirectional​(Property<ObservableMap<K,V>> other)
      在这个 Property之间创建一个双向绑定。
      void | MapPropertyBase.removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void | ReadOnlyMapPropertyBase.removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)
      void MapProperty.unbindBidirectional​(Property<ObservableMap<K,V>> other)
      删除此 Property和另一个之间的双向绑定。
      Constructors in javafx.beans.property with parameters of type ObservableMap
      Constructor 描述
      MapPropertyBase​(ObservableMap<K,V> initialValue)
      MapPropertyBase的构造 MapPropertyBase 。
      ReadOnlyMapWrapper​(Object bean, String name, ObservableMap<K,V> initialValue)
      构造函数为 ReadOnlyMapWrapper
      ReadOnlyMapWrapper​(ObservableMap<K,V> initialValue)
      构造函数为 ReadOnlyMapWrapper
      SimpleMapProperty​(Object bean, String name, ObservableMap<K,V> initialValue)
      构造函数为 SimpleMapProperty
      SimpleMapProperty​(ObservableMap<K,V> initialValue)
      构造函数为 SimpleMapProperty

    • Uses of ObservableMap in javafx.beans.value

      Subinterfaces of ObservableMap in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableMapValue<K,V>
      一个可观察的参考ObservableMap 。
      interface  WritableMapValue<K,V>
      一个可写参考的一个ObservableMap 。

    • Uses of ObservableMap in javafx.collections

      Methods in javafx.collections that return ObservableMap
      Modifier and Type 方法 描述
      static <K,V> ObservableMap<K,V> FXCollections.checkedObservableMap​(ObservableMap<K,V> map, Class<K> keyType, Class<V> valueType)
      在提供的可观察地图的顶部创建并返回类型安全的包装器。
      static <K,V> ObservableMap<K,V> FXCollections.emptyObservableMap​()
      创建和清空不可修改的可观测地图。
      ObservableMap<K,V> MapChangeListener.Change.getMap​()
      与变化相关联的可观察的地图。
      static <K,V> ObservableMap<K,V> FXCollections.observableHashMap​()
      创建一个由HashMap支持的新的可观察的地图。
      static <K,V> ObservableMap<K,V> FXCollections.observableMap​(Map<K,V> map)
      构造由指定地图支持的ObservableMap。
      static <K,V> ObservableMap<K,V> FXCollections.synchronizedObservableMap​(ObservableMap<K,V> map)
      在提供的可观察地图的顶部创建并返回同步的包装器。
      static <K,V> ObservableMap<K,V> FXCollections.unmodifiableObservableMap​(ObservableMap<K,V> map)
      构造一个只读接口到指定的ObservableMap。
      Methods in javafx.collections with parameters of type ObservableMap
      Modifier and Type 方法 描述
      static <K,V> ObservableMap<K,V> FXCollections.checkedObservableMap​(ObservableMap<K,V> map, Class<K> keyType, Class<V> valueType)
      在提供的可观察地图的顶部创建并返回类型安全的包装器。
      static <K,V> ObservableMap<K,V> FXCollections.synchronizedObservableMap​(ObservableMap<K,V> map)
      在提供的可观察地图的顶部创建并返回同步的包装器。
      static <K,V> ObservableMap<K,V> FXCollections.unmodifiableObservableMap​(ObservableMap<K,V> map)
      构造一个只读接口到指定的ObservableMap。
      Constructors in javafx.collections with parameters of type ObservableMap
      Constructor 描述
      Change​(ObservableMap<K,V> map)
      构造与地图关联的更改。

    • Uses of ObservableMap in javafx.fxml

      Methods in javafx.fxml that return ObservableMap
      Modifier and Type 方法 描述
      ObservableMap<String,Object> FXMLLoader.getNamespace​()
      返回此装载器使用的命名空间。

    • Uses of ObservableMap in javafx.scene

      Methods in javafx.scene that return ObservableMap
      Modifier and Type 方法 描述
      ObservableMap<KeyCombination,Runnable> Scene.getAccelerators​()
      获取此 Scene的加速器列表。
      ObservableMap<KeyCombination,ObservableList<Mnemonic>> Scene.getMnemonics​()
      获取 Scene的助记符列表。
      ObservableMap<Object,Object> Node.getProperties​()
      返回此节点上属性的可观察图，主要由应用程序开发人员使用。
      ObservableMap<Object,Object> Scene.getProperties​()
      返回此节点上属性的可观察图，主要由应用程序开发人员使用。

    • Uses of ObservableMap in javafx.scene.control

      Methods in javafx.scene.control that return ObservableMap
      Modifier and Type 方法 描述
      ObservableMap<Object,Object> MenuItem.getProperties​()
      返回此菜单项上可观察到的属性映射，主要由应用程序开发人员使用。
      ObservableMap<Object,Object> Tab.getProperties​()
      返回此选项卡上属性的可观察图，主要由应用程序开发人员使用。
      ObservableMap<Object,Object> TableColumnBase.getProperties​()
      返回此表列上属性的可观察图，主要由应用程序开发人员使用。
      ObservableMap<Object,Object> Toggle.getProperties​()
      返回此切换上属性的可观察地图，主要由应用程序开发人员使用。
      ObservableMap<Object,Object> ToggleGroup.getProperties​()
      返回此节点上属性的可观察图，主要由应用程序开发人员使用。

    • Uses of ObservableMap in javafx.scene.media

      Methods in javafx.scene.media that return ObservableMap
      Modifier and Type 方法 描述
      ObservableMap<String,Duration> Media.getMarkers​()
      检索此 Media实例上定义的标记。
      ObservableMap<String,Object> Media.getMetadata​()
      检索此媒体源中包含的元数据。

    • Uses of ObservableMap in javafx.stage

      Methods in javafx.stage that return ObservableMap
      Modifier and Type 方法 描述
      ObservableMap<Object,Object> Window.getProperties​()
      返回此节点上属性的可观察图，主要由应用程序开发人员使用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.ObservableSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.ObservableSet

  • Packages that use ObservableSet
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ObservableSet in javafx.beans.binding

      Classes in javafx.beans.binding that implement ObservableSet
      Modifier and Type Class 描述
      class  SetBinding<E>
      提供实现ObservableSet的Binding所需的大部分功能的基类。
      class  SetExpression<E>
      SetExpression是一个ObservableSetValue，另外还有一个方便的方法来生成流畅的绑定。
      Methods in javafx.beans.binding that return ObservableSet
      Modifier and Type | 方法 | 描述
      protected abstract ObservableSet<E> SetBinding.computeValue​()
      计算此绑定的当前值。
      ObservableSet<E> SetBinding.get​()
      返回 SetBinding.computeValue()的结果。
      ObservableSet<E> | SetExpression.getValue​()
      Methods in javafx.beans.binding with parameters of type ObservableSet
      Modifier and Type 方法 描述
      static <E> void Bindings.bindContent​(Set<E> set1, ObservableSet<? extends E> set2)
      生成ObservableSet和Set之间的内容绑定。
      static <E> void Bindings.bindContentBidirectional​(ObservableSet<E> set1, ObservableSet<E> set2)
      在ObservableSet的两个实例之间生成双向绑定（或“反向绑定”）。
      static <E> BooleanBinding Bindings.isEmpty​(ObservableSet<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableSet为空，则保留true 。
      BooleanBinding SetExpression.isEqualTo​(ObservableSet<?> other)
      创建一个新的BooleanBinding持有true如果此集合等于另一个ObservableSet 。
      static <E> BooleanBinding Bindings.isNotEmpty​(ObservableSet<E> op)
      创建一个新的BooleanBinding ，如果给定的ObservableSet不为空，则保留true 。
      BooleanBinding SetExpression.isNotEqualTo​(ObservableSet<?> other)
      创建一个新的BooleanBinding持有true如果此集合不等于另一个ObservableSet 。
      static <E> IntegerBinding Bindings.size​(ObservableSet<E> op)
      创建一个新的IntegerBinding ，其大小为ObservableSet 。
      Method parameters in javafx.beans.binding with type arguments of type ObservableSet
      Modifier and Type | 方法 | 描述
      void | SetBinding.addListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | SetBinding.removeListener​(ChangeListener<? super ObservableSet<E>> listener)

    • Uses of ObservableSet in javafx.beans.property

      Classes in javafx.beans.property that implement ObservableSet
      Modifier and Type Class 描述
      class  ReadOnlySetProperty<E>
      超类为所有只读属性包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装ObservableSet的属性的基类。
      class  SimpleSetProperty<E>
      这个类提供了一个Property包装一个ObservableSet的完整实现。
      Methods in javafx.beans.property that return ObservableSet
      Modifier and Type | 方法 | 描述
      ObservableSet<E> | SetPropertyBase.get​()
      Methods in javafx.beans.property with parameters of type ObservableSet
      Modifier and Type | 方法 | 描述
      void ReadOnlySetProperty.bindContent​(ObservableSet<E> set)
      在ObservableSet之间创建一个内容绑定，即包含在这个ReadOnlySetProperty ，另一个是ObservableSet 。
      void ReadOnlySetProperty.bindContentBidirectional​(ObservableSet<E> set)
      创建一个双向内容绑定的ObservableSet ，即包装在这个ReadOnlySetProperty ，另外ObservableSet 。
      void | SetPropertyBase.set​(ObservableSet<E> newValue)
      void SetProperty.setValue​(ObservableSet<E> v)
      设置包装的值。
      Method parameters in javafx.beans.property with type arguments of type ObservableSet
      Modifier and Type | 方法 | 描述
      void | ReadOnlySetPropertyBase.addListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | SetPropertyBase.addListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | SetPropertyBase.bind​(ObservableValue<? extends ObservableSet<E>> newObservable)
      void SetProperty.bindBidirectional​(Property<ObservableSet<E>> other)
      在这个 Property和另一个之间创建双向绑定。
      void | ReadOnlySetPropertyBase.removeListener​(ChangeListener<? super ObservableSet<E>> listener)
      void | SetPropertyBase.removeListener​(ChangeListener<? super ObservableSet<E>> listener)
      void SetProperty.unbindBidirectional​(Property<ObservableSet<E>> other)
      删除此 Property和另一个之间的双向绑定。
      Constructors in javafx.beans.property with parameters of type ObservableSet
      Constructor 描述
      ReadOnlySetWrapper​(Object bean, String name, ObservableSet<E> initialValue)
      构造函数为 ReadOnlySetWrapper
      ReadOnlySetWrapper​(ObservableSet<E> initialValue)
      构造函数为 ReadOnlySetWrapper
      SetPropertyBase​(ObservableSet<E> initialValue)
      SetPropertyBase的构造 SetPropertyBase 。
      SimpleSetProperty​(Object bean, String name, ObservableSet<E> initialValue)
      构造函数为 SimpleSetProperty
      SimpleSetProperty​(ObservableSet<E> initialValue)
      构造函数为 SimpleSetProperty

    • Uses of ObservableSet in javafx.beans.value

      Subinterfaces of ObservableSet in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableSetValue<E>
      可以参考一个ObservableSet 。
      interface  WritableSetValue<E>
      对ObservableSet的可写参考。

    • Uses of ObservableSet in javafx.collections

      Methods in javafx.collections that return ObservableSet
      Modifier and Type 方法 描述
      static <E> ObservableSet<E> FXCollections.checkedObservableSet​(ObservableSet<E> set, Class<E> type)
      在提供的可观察集之上创建并返回一个类型安全的包装器。
      static <E> ObservableSet<E> FXCollections.emptyObservableSet​()
      创建和清空不可修改的可观察集。
      ObservableSet<E> SetChangeListener.Change.getSet​()
      与变化相关联的可观察集合。
      static <E> ObservableSet<E> FXCollections.observableSet​(E... elements)
      构造一个由包含所有指定元素的HashSet支持的ObservableSet。
      static <E> ObservableSet<E> FXCollections.observableSet​(Set<E> set)
      构造由指定集合支持的ObservableSet。
      static <E> ObservableSet<E> FXCollections.synchronizedObservableSet​(ObservableSet<E> set)
      在提供的可观察集合之上创建并返回同步的包装器。
      static <E> ObservableSet<E> FXCollections.unmodifiableObservableSet​(ObservableSet<E> set)
      在提供的可观察集合之上创建并返回不可修改的包装器。
      Methods in javafx.collections with parameters of type ObservableSet
      Modifier and Type 方法 描述
      static <E> ObservableSet<E> FXCollections.checkedObservableSet​(ObservableSet<E> set, Class<E> type)
      在提供的可观察集之上创建并返回一个类型安全的包装器。
      static <E> ObservableSet<E> FXCollections.synchronizedObservableSet​(ObservableSet<E> set)
      在提供的可观察集合之上创建并返回同步的包装器。
      static <E> ObservableSet<E> FXCollections.unmodifiableObservableSet​(ObservableSet<E> set)
      在提供的可观察集合之上创建并返回不可修改的包装器。
      Constructors in javafx.collections with parameters of type ObservableSet
      Constructor 描述
      Change​(ObservableSet<E> set)
      构造与集相关联的更改。

    • Uses of ObservableSet in javafx.css

      Methods in javafx.css that return ObservableSet
      Modifier and Type 方法 描述
      ObservableSet<PseudoClass> Styleable.getPseudoClassStates​()
      返回此Styleable的伪类状态。

    • Uses of ObservableSet in javafx.print

      Methods in javafx.print that return ObservableSet
      Modifier and Type 方法 描述
      static ObservableSet<Printer> Printer.getAllPrinters​()
      检索已安装的打印机。

    • Uses of ObservableSet in javafx.scene

      Methods in javafx.scene that return ObservableSet
      Modifier and Type | 方法 | 描述
      ObservableSet<PseudoClass> | Node.getPseudoClassStates​()

    • Uses of ObservableSet in javafx.scene.control

      Methods in javafx.scene.control that return ObservableSet
      Modifier and Type 方法 描述
      ObservableSet<PseudoClass> MenuItem.getPseudoClassStates​()
      返回此Styleable的伪类状态。
      ObservableSet<PseudoClass> PopupControl.getPseudoClassStates​()
      返回此Styleable的伪类状态。
      ObservableSet<PseudoClass> Tab.getPseudoClassStates​()
      返回此Styleable的伪类状态。
      ObservableSet<PseudoClass> TableColumnBase.getPseudoClassStates​()
      返回此Styleable的伪类状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.collections.SetChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.collections.SetChangeListener

  • Packages that use SetChangeListener
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of SetChangeListener in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type SetChangeListener
      Modifier and Type | 方法 | 描述
      void | SetBinding.addListener​(SetChangeListener<? super E> listener)
      void | SetBinding.removeListener​(SetChangeListener<? super E> listener)

    • Uses of SetChangeListener in javafx.beans.property

      Methods in javafx.beans.property with parameters of type SetChangeListener
      Modifier and Type | 方法 | 描述
      void | ReadOnlySetPropertyBase.addListener​(SetChangeListener<? super E> listener)
      void | SetPropertyBase.addListener​(SetChangeListener<? super E> listener)
      void | ReadOnlySetPropertyBase.removeListener​(SetChangeListener<? super E> listener)
      void | SetPropertyBase.removeListener​(SetChangeListener<? super E> listener)

    • Uses of SetChangeListener in javafx.collections

      Classes in javafx.collections that implement SetChangeListener
      Modifier and Type Class 描述
      class  WeakSetChangeListener<E>
      A WeakSetChangeListener可以使用，如果一个ObservableSet应该只保留一个弱的参考侦听器。
      Methods in javafx.collections with parameters of type SetChangeListener
      Modifier and Type 方法 描述
      void ObservableSet.addListener​(SetChangeListener<? super E> listener)
      添加一个监听器到这个可观察的集合。
      void ObservableSet.removeListener​(SetChangeListener<? super E> listener)
      试图从这个可观察的集合中删除一个监听器。
      Constructors in javafx.collections with parameters of type SetChangeListener
      Constructor 描述
      WeakSetChangeListener​(SetChangeListener<E> listener)
      The constructor of WeakSetChangeListener.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


FilteredList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections.transformation

Class FilteredList<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • javafx.collections.ObservableListBase<E>
          • javafx.collections.transformation.TransformationList<E,E>
            • javafx.collections.transformation.FilteredList<E>
  • All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， ObservableList<E>

    public final class FilteredList<E>
extends TransformationList<E,E>
    包装一个ObservableList并使用提供的谓词过滤其内容。 ObservableList中的所有更改都会立即传播到FilteredList。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TransformationList

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Predicate<? super E>> predicate
      该谓词将匹配此FilteredList中的元素。

    • Field Summary

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      构造方法
      Constructor 描述
      FilteredList​(ObservableList<E> source)
      在源列表周围构造一个新的FilteredList包装器。
      FilteredList​(ObservableList<E> source, Predicate<? super E> predicate)
      在源列表周围构造一个新的FilteredList包装器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      E get​(int index)
      返回此列表中指定位置的元素。
      Predicate<? super E> getPredicate​()
      获取属性谓词的值。
      int getSourceIndex​(int index)
      将此列表元素的索引映射到直接源列表中的索引。
      int getViewIndex​(int index)
      将直接源列表的元素的索引映射到此列表中的索引。
      ObjectProperty<Predicate<? super E>> predicateProperty​()
      该谓词将匹配此FilteredList中的元素。
      void setPredicate​(Predicate<? super E> predicate)
      设置属性谓词的值。
      int size​()
      返回此列表中的元素数。
      protected void sourceChanged​(ListChangeListener.Change<? extends E> c)
      当来自源的更改被触发时调用。

      • Methods inherited from class java.util.AbstractCollection

        addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractList

        add, add, addAll, clear, equals, hashCode, indexOf, iterator, lastIndexOf, listIterator, listIterator, remove, removeRange, set, subList

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, sort, spliterator, subList, toArray, toArray

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableList

        addAll, addListener, filtered, remove, removeAll, removeListener, retainAll, setAll, setAll, sorted, sorted

      • Methods inherited from class javafx.collections.ObservableListBase

        addAll, addListener, addListener, beginChange, endChange, fireChange, hasListeners, nextAdd, nextPermutation, nextRemove, nextRemove, nextReplace, nextSet, nextUpdate, remove, removeAll, removeListener, removeListener, retainAll, setAll, setAll

      • Methods inherited from class javafx.collections.transformation.TransformationList

        getSource, getSourceIndexFor, isInTransformationChain

    • Property Detail

      • predicate

        public final ObjectProperty<Predicate<? super E>> predicateProperty
        该谓词将匹配此FilteredList中的元素。 不符合谓词的元素将被过滤掉。 Null谓词表示“always true”谓词，所有元素都将匹配。
        另请参见：
        getPredicate() ， setPredicate(Predicate)

    • 构造方法详细信息

      • FilteredList

        public FilteredList​(ObservableList<E> source,
                    Predicate<? super E> predicate)
        在源列表周围构造一个新的FilteredList包装器。 提供的谓词将匹配源列表中可见的元素。 如果谓词为空，则所有元素都将匹配，列表等于源列表。
        参数
        source - 源列表
        predicate - 匹配元素的谓词或null以匹配所有元素。

      • FilteredList

        public FilteredList​(ObservableList<E> source)
        在源列表周围构造一个新的FilteredList包装器。 该列表具有“始终为真”的谓词，其中包含源列表的所有元素。

        如果要绑定此列表的predicateProperty() ，此构造函数可能很有用。

        参数
        source - 源列表

    • 方法详细信息

      • predicateProperty

        public final ObjectProperty<Predicate<? super E>> predicateProperty​()
        该谓词将匹配此FilteredList中的元素。 不符合谓词的元素将被过滤掉。 Null谓词表示“always true”谓词，所有元素都将匹配。
        另请参见：
        getPredicate() ， setPredicate(Predicate)

      • getPredicate

        public final Predicate<? super E> getPredicate​()
        获取属性谓词的值。
        Property description:
        该谓词将匹配此FilteredList中的元素。 不符合谓词的元素将被过滤掉。 Null谓词表示“always true”谓词，所有元素都将匹配。

      • setPredicate

        public final void setPredicate​(Predicate<? super E> predicate)
        设置属性谓词的值。
        Property description:
        该谓词将匹配此FilteredList中的元素。 不符合谓词的元素将被过滤掉。 Null谓词表示“always true”谓词，所有元素都将匹配。

      • sourceChanged

        protected void sourceChanged​(ListChangeListener.Change<? extends E> c)
        描述从类复制： TransformationList
        当来自源的更改被触发时调用。
        Specified by:
        sourceChanged在 TransformationList<E,E>
        参数
        c - 变化

      • size

        public int size​()
        返回此列表中的元素数。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 List<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此列表中的元素数

      • get

        public E get​(int index)
        返回此列表中指定位置的元素。
        Specified by:
        get在接口 List<E>
        Specified by:
        get在 AbstractList<E>
        参数
        index - 要返回的元素的索引
        结果
        该列表中指定位置的元素
        异常
        IndexOutOfBoundsException - 如果指数超出范围（ index < 0 || index >= size() ）

      • getSourceIndex

        public int getSourceIndex​(int index)
        描述从类别复制： TransformationList
        将此列表元素的索引映射到直接源列表中的索引。
        Specified by:
        getSourceIndex在 TransformationList<E,E>
        参数
        index - 此列表中的索引
        结果
        源列表中元素的起始索引
        另请参见：
        TransformationList.getSource()

      • getViewIndex

        public int getViewIndex​(int index)
        描述从类复制： TransformationList
        将直接源列表的元素的索引映射到此列表中的索引。
        Specified by:
        getViewIndex在 TransformationList<E,E>
        参数
        index - 源列表中的索引
        结果
        如果列表中包含该元素的索引，否则为负值
        另请参见：
        TransformationList.getSource(), TransformationList.getSourceIndex(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.collections.transformation (Java SE 9 & JDK 9 )

javafx.collections.transformation

Classes

  • FilteredList
  • SortedList
  • TransformationList


javafx.collections.transformation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.collections.transformation

提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。

  • 类摘要
    Class 描述
    FilteredList<E>
    包装一个ObservableList并使用提供的谓词过滤其内容。
    SortedList<E>
    包装一个ObservableList并对其内容进行排序。
    TransformationList<E,F>
    所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.collections.transformation Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.collections.transformation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • javafx.collections.ObservableListBase<E> (implements javafx.collections.ObservableList<E>)
          • javafx.collections.transformation.TransformationList<E,F> (implements javafx.collections.ObservableList<E>)
            • javafx.collections.transformation.FilteredList<E>
            • javafx.collections.transformation.SortedList<E>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


SortedList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections.transformation

Class SortedList<E>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • javafx.collections.ObservableListBase<E>
          • javafx.collections.transformation.TransformationList<E,E>
            • javafx.collections.transformation.SortedList<E>
  • All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， ObservableList<E>

    public final class SortedList<E>
extends TransformationList<E,E>
    包装一个ObservableList并对其内容进行排序。 ObservableList中的所有更改都会立即传播到SortedList。 注意：无效的SortedList（由于比较结果不合格）不会再向通知发送任何通知。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TransformationList

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Comparator<? super E>> comparator
      比较器，表示此SortedList的顺序。

    • Field Summary

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      构造方法
      Constructor 描述
      SortedList​(ObservableList<? extends E> source)
      在源列表周围构造一个新的无序SortedList包装器。
      SortedList​(ObservableList<? extends E> source, Comparator<? super E> comparator)
      创建一个围绕源列表的新SortedList。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Comparator<? super E>> comparatorProperty​()
      比较器，表示此SortedList的顺序。
      E get​(int index)
      返回此列表中指定位置的元素。
      Comparator<? super E> getComparator​()
      获取属性比较器的值。
      int getSourceIndex​(int index)
      将此列表元素的索引映射到直接源列表中的索引。
      int getViewIndex​(int index)
      将直接源列表的元素的索引映射到此列表中的索引。
      void setComparator​(Comparator<? super E> comparator)
      设置属性比较器的值。
      int size​()
      返回此列表中的元素数。
      protected void sourceChanged​(ListChangeListener.Change<? extends E> c)
      当来自源的更改被触发时调用。

      • Methods inherited from class java.util.AbstractCollection

        addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractList

        add, add, addAll, clear, equals, hashCode, indexOf, iterator, lastIndexOf, listIterator, listIterator, remove, removeRange, set, subList

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, sort, spliterator, subList, toArray, toArray

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableList

        addAll, addListener, filtered, remove, removeAll, removeListener, retainAll, setAll, setAll, sorted, sorted

      • Methods inherited from class javafx.collections.ObservableListBase

        addAll, addListener, addListener, beginChange, endChange, fireChange, hasListeners, nextAdd, nextPermutation, nextRemove, nextRemove, nextReplace, nextSet, nextUpdate, remove, removeAll, removeListener, removeListener, retainAll, setAll, setAll

      • Methods inherited from class javafx.collections.transformation.TransformationList

        getSource, getSourceIndexFor, isInTransformationChain

    • Property Detail

      • comparator

        public final ObjectProperty<Comparator<? super E>> comparatorProperty
        比较器，表示此SortedList的顺序。 空的无序SortedList。
        另请参见：
        getComparator() ， setComparator(Comparator)

    • 构造方法详细信息

      • SortedList

        public SortedList​(ObservableList<? extends E> source,
                  Comparator<? super E> comparator)
        创建一个围绕源列表的新SortedList。 源列表将使用提供的比较器进行排序。 如果提供null，则列表保持无序，并且等于源列表。
        参数
        source - 要包装的列表
        comparator - 用于无序列表的比较器或null

      • SortedList

        public SortedList​(ObservableList<? extends E> source)
        在源列表周围构造一个新的无序SortedList包装器。
        参数
        source - 源列表
        另请参见：
        SortedList(javafx.collections.ObservableList, java.util.Comparator)

    • 方法详细信息

      • sourceChanged

        protected void sourceChanged​(ListChangeListener.Change<? extends E> c)
        描述从类别复制： TransformationList
        当来自源的更改被触发时调用。
        Specified by:
        sourceChanged在 TransformationList<E,E>
        参数
        c - 更改

      • comparatorProperty

        public final ObjectProperty<Comparator<? super E>> comparatorProperty​()
        比较器，表示此SortedList的顺序。 空的无序SortedList。
        另请参见：
        getComparator() ， setComparator(Comparator)

      • getComparator

        public final Comparator<? super E> getComparator​()
        获取属性比较器的值。
        Property description:
        比较器，表示此SortedList的顺序。 空的无序SortedList。

      • setComparator

        public final void setComparator​(Comparator<? super E> comparator)
        设置属性比较器的值。
        Property description:
        比较器，表示此SortedList的顺序。 空的无序SortedList。

      • get

        public E get​(int index)
        返回此列表中指定位置的元素。
        Specified by:
        get在接口 List<E>
        Specified by:
        get在 AbstractList<E>
        参数
        index - 要返回的元素的索引
        结果
        该列表中指定位置的元素
        异常
        IndexOutOfBoundsException - 如果索引超出范围（ index < 0 || index >= size() ）

      • size

        public int size​()
        返回此列表中的元素数。
        Specified by:
        size在接口 Collection<E>
        Specified by:
        size在接口 List<E>
        Specified by:
        size在 AbstractCollection<E>
        结果
        此列表中的元素数

      • getSourceIndex

        public int getSourceIndex​(int index)
        说明从类别复制： TransformationList
        将此列表元素的索引映射到直接源列表中的索引。
        Specified by:
        getSourceIndex在 TransformationList<E,E>
        参数
        index - 此列表中的索引
        结果
        源列表中元素的起始索引
        另请参见：
        TransformationList.getSource()

      • getViewIndex

        public int getViewIndex​(int index)
        描述从类别复制： TransformationList
        将直接源列表的元素的索引映射到此列表中的索引。
        Specified by:
        getViewIndex在 TransformationList<E,E>
        参数
        index - 源列表中的索引
        结果
        如果列表中包含该元素的索引，否则为负值
        另请参见：
        TransformationList.getSource() ， TransformationList.getSourceIndex(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TransformationList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.collections.transformation

Class TransformationList<E,F>

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • javafx.collections.ObservableListBase<E>
          • javafx.collections.transformation.TransformationList<E,F>
  • 参数类型
    E - 此列表的类型参数
    F - 源列表类型的上限
    All Implemented Interfaces:
    Iterable<E> ， Collection<E> ， List<E> ， Observable ， ObservableList<E>
    已知直接子类：
    FilteredList ， SortedList

    public abstract class TransformationList<E,F>
extends ObservableListBase<E>
implements ObservableList<E>
    所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。 如果源列表是可观察的，则会自动添加一个监听器，并将事件委托给sourceChanged(javafx.collections.ListChangeListener.Change)
    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected TransformationList​(ObservableList<? extends F> source)
      创建一个围绕源列表的新的Transformation列表。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<? extends F> getSource​()
      在此转换列表的构造函数中指定的源列表。
      abstract int getSourceIndex​(int index)
      将此列表元素的索引映射到直接源列表中的索引。
      int getSourceIndexFor​(ObservableList<?> list, int index)
      将此列表元素的索引映射到所提供的 list的索引。
      abstract int getViewIndex​(int index)
      将直接源列表的元素的索引映射到此列表中的索引。
      boolean isInTransformationChain​(ObservableList<?> list)
      检查提供的列表是否在此 TransformationList下的链中。
      protected abstract void sourceChanged​(ListChangeListener.Change<? extends F> c)
      当来自源的更改被触发时调用。

      • Methods inherited from class java.util.AbstractCollection

        addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, size, toArray, toArray, toString

      • Methods inherited from class java.util.AbstractList

        add, add, addAll, clear, equals, get, hashCode, indexOf, iterator, lastIndexOf, listIterator, listIterator, remove, removeRange, set, subList

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, remove, removeAll, replaceAll, retainAll, set, size, sort, spliterator, subList, toArray, toArray

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableList

        addAll, addListener, filtered, remove, removeAll, removeListener, retainAll, setAll, setAll, sorted, sorted

      • Methods inherited from class javafx.collections.ObservableListBase

        addAll, addListener, addListener, beginChange, endChange, fireChange, hasListeners, nextAdd, nextPermutation, nextRemove, nextRemove, nextReplace, nextSet, nextUpdate, remove, removeAll, removeListener, removeListener, retainAll, setAll, setAll

    • 构造方法详细信息

      • TransformationList

        protected TransformationList​(ObservableList<? extends F> source)
        创建一个围绕源列表的新的Transformation列表。
        参数
        source - 包装清单

    • 方法详细信息

      • getSource

        public final ObservableList<? extends F> getSource​()
        在此转换列表的构造函数中指定的源列表。
        结果
        由TransformationList直接包装的列表

      • isInTransformationChain

        public final boolean isInTransformationChain​(ObservableList<?> list)
        检查提供的列表是否在此TransformationList下的链中。 这意味着该列表是由getSource()返回的直接源，或者直接源是一个TransformationList ，并且该列表在其转换链中。
        参数
        list - 要检查的列表
        结果
        如果列表在上面指定的转换链中，则为true。

      • sourceChanged

        protected abstract void sourceChanged​(ListChangeListener.Change<? extends F> c)
        当来自源的更改被触发时调用。
        参数
        c - 改变

      • getSourceIndex

        public abstract int getSourceIndex​(int index)
        将此列表元素的索引映射到直接源列表中的索引。
        参数
        index - 此列表中的索引
        结果
        源列表中元素的起始索引
        另请参见：
        getSource()

      • getSourceIndexFor

        public final int getSourceIndexFor​(ObservableList<?> list,
                                   int index)
        将此列表元素的索引映射到所提供的list的索引。 list必须在转型链中。
        参数
        list - 转型链中的列表
        index - 此列表中元素的索引
        结果
        元素起源于提供的列表中的索引
        另请参见：
        isInTransformationChain(javafx.collections.ObservableList)

      • getViewIndex

        public abstract int getViewIndex​(int index)
        将直接源列表的元素的索引映射到此列表中的索引。
        参数
        index - 源列表中的索引
        结果
        如果列表中包含该元素的索引，否则为负值
        从以下版本开始：
        9
        另请参见：
        getSource() ， getSourceIndex(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.collections.transformation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.collections.transformation

  • Packages that use javafx.collections.transformation
    软件包 描述
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
  • Classes in javafx.collections.transformation used by javafx.collections
    Class 描述
    FilteredList
    包装一个ObservableList并使用提供的谓词过滤其内容。
    SortedList
    包装一个ObservableList并对其内容进行排序。
  • Classes in javafx.collections.transformation used by javafx.collections.transformation
    Class 描述
    TransformationList
    所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.transformation.FilteredList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.transformation.FilteredList

  • Packages that use FilteredList
    软件包 描述
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of FilteredList in javafx.collections

      Methods in javafx.collections that return FilteredList
      Modifier and Type 方法 描述
      default FilteredList<E> ObservableList.filtered​(Predicate<E> predicate)
      使用指定的谓词创建此列表的FilteredList包装器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.transformation.SortedList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.transformation.SortedList

  • Packages that use SortedList
    软件包 描述
    javafx.collections
    包含基本的JavaFX集合和集合实用程序

    • Uses of SortedList in javafx.collections

      Methods in javafx.collections that return SortedList
      Modifier and Type 方法 描述
      default SortedList<E> ObservableList.sorted​()
      用自然排序创建一个SortedList这个列表的包装器。
      default SortedList<E> ObservableList.sorted​(Comparator<E> comparator)
      使用指定的比较器创建此列表的SortedList包装器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.collections.transformation.TransformationList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.collections.transformation.TransformationList

  • Packages that use TransformationList
    软件包 描述
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。

    • Uses of TransformationList in javafx.collections.transformation

      Subclasses of TransformationList in javafx.collections.transformation
      Modifier and Type Class 描述
      class  FilteredList<E>
      包装一个ObservableList并使用提供的谓词过滤其内容。
      class  SortedList<E>
      包装一个ObservableList并对其内容进行排序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


javafx.concurrent (Java SE 9 & JDK 9 )

javafx.concurrent

Interfaces

  • Worker

Classes

  • ScheduledService
  • Service
  • Task
  • WorkerStateEvent

Enums

  • Worker.State


javafx.concurrent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.concurrent

提供javafx.task的一组类。

该包提供了在JavaFX事件分派线程之外的线程上运行应用程序代码的功能。 还提供了控制执行和跟踪应用程序代码进度的能力。

  • 接口摘要
    接口 描述
    Worker<V>
    工作者是在一个或多个后台线程中执行某些工作的对象，其状态是可观察的并且可用于JavaFX应用程序，并且可从主JavaFX应用程序线程中使用。
  • 类摘要
    Class 描述
    ScheduledService<V>
    ScheduledService是一个Service ，它将在成功执行后自动重新启动，并且在某些情况下即使发生故障也将重新启动。
    Service<V>
    服务是一个非可视化组件，封装了在一个或多个后台线程上执行某些工作所需的信息。
    Task<V>
    一个完全可观察到的一个FutureTask的实现。
    WorkerStateEvent
    当一个工人状态发生变化时发生的事件。
  • 枚举摘要
    Enum 描述
    Worker.State
    The state of a Worker.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.concurrent Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.concurrent

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javafx.event.Event (implements java.lang.Cloneable)
        • javafx.concurrent.WorkerStateEvent
    • java.util.concurrent.FutureTask<V> (implements java.util.concurrent.RunnableFuture<V>)
      • javafx.concurrent.Task<V> (implements javafx.event.EventTarget, javafx.concurrent.Worker<V>)
    • javafx.concurrent.Service<V> (implements javafx.event.EventTarget, javafx.concurrent.Worker<V>)
      • javafx.concurrent.ScheduledService<V>

Interface Hierarchy

  • javafx.concurrent.Worker<V>

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.concurrent.Worker.State
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ScheduledService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.concurrent

Class ScheduledService<V>

  • java.lang.Object
    • javafx.concurrent.Service<V>
      • javafx.concurrent.ScheduledService<V>
  • 参数类型
    V - 计算的ScheduledService值
    All Implemented Interfaces:
    Worker<V> ， EventTarget

    public abstract class ScheduledService<V>
extends Service<V>

    ScheduledService是一个Service ，它将在成功执行后自动重新启动，并且在某些情况下即使发生故障也将重新启动。 一个新的ScheduledService开始于READY状态，就像普通的Service一样。 调用start或restart ，ScheduledService将在delay指定的时间内进入SCHEDULED状态。

    一旦运行，ScheduledService将执行其任务。 成功完成后，ScheduledService将转换到SUCCEEDED状态，然后进入READY状态并返回到SCHEDULED状态。 计划服务将保持在此状态的时间取决于最后一次状态转换到运行时间与当前时间之间的时间量，以及period 。 简而言之， period定义了从一次运行开始和下一个运行开始的最短时间。 如果之前的执行在period之前完成，则ScheduledService将保持在SCHEDULED状态，直到期限到期。 另一方面，如果执行时间比指定的时间长，则ScheduledService将立即转换回运行。

    如果，在运行时，ScheduledService的任务将引发错误或以其他方式结束了过渡失败，那么ScheduledService要么重新启动或退出，这取决于值backoffStrategy ， restartOnFailure ，并maximumFailureCount 。

    如果发生故障，并且restartOnFailure为假，则ScheduledService将转换到FAILED并停止。 要重新启动失败的ScheduledService，您必须手动调用重新启动。

    如果发生故障，并且restartOnFailure为真，则ScheduledService 可能会自动重新启动。 首先，调用backoffStrategy的结果将成为新的cumulativePeriod 。 以这种方式，在每次故障之后，您可以使服务等待更长时间更长的时间，然后再重新启动。 一旦任务成功完成，cumulativePeriod将重置为period的值。

    ScheduledService定义了静态EXPONENTIAL_BACKOFF_STRATEGY和LOGARITHMIC_BACKOFF_STRATEGY实现，其中LOGARITHMIC_BACKOFF_STRATEGY是backoffStrategy的默认值。 在达到maximumFailureCount之后，ScheduledService将以与错误restartOnFailure完全相同的方式转换为FAILED。

    如果在ScheduledService运行时更改了period或delay ，则在下一次迭代时将考虑新值。 例如，如果period增加，则下次ScheduledService进入SCHEDULED状态时，将使用新的period 。 同样，如果更改了delay ，则新值将在下次重新启动或重置/启动时保持。

    ScheduledService通常用于涉及轮询的用例。 例如，您可能需要定期ping服务器，以查看是否有任何更新。 如ScheduledService可能会像这样实现：
       ScheduledService<Document> svc = new ScheduledService<Document>() { protected Task<Document> createTask() { return new Task<Document>() { protected Document call() { // Connect to a Server // Get the XML document // Parse it into a document return document; } }; } }; svc.setPeriod(Duration.seconds(1));
    该示例将每隔1秒ping远程服务器。

    这个班的时间并不是绝对可靠的。 一个非常忙碌的事件线程可能会在执行后台任务的开始时引入一些时间滞后，因此周期或延迟的非常小的值可能不准确。 延迟或数百毫秒或更长的时间段应该是相当可靠的。

    默认配置中的ScheduledService的默认period ，默认delay为0.这将导致ScheduledService在Service.start()上立即执行任务，并在成功完成后立即重新执行。

    为了这个课程的目的，任何答案为Duration.isUnknown()的任何持续时间将视为持续时间。 同样，任何对Duration.isIndefinite()回答的持续时间将被视为Double.MAX_VALUE毫秒的持续时间。 任何null持续时间被视为Duration.ZERO。 必须准备退避策略回调的任何自定义实现来处理这些不同的潜在值。

    ScheduledService引入了一个名为lastValue的新属性。 lastValue是最后一次成功计算的值。 因为服务在每次运行时清除其value属性，并且由于ScheduledService将在完成后立即重新计划运行（除非进入已取消或失败的状态），所以value属性对于ScheduledService不是太有用。 在大多数情况下，您将要使用lastValue返回的值。

    实施者注： Service.ready() ， Service.scheduled() ， Service.running() ， succeeded() ， Service.cancelled() ，并failed()方法在这个类中实现。 也覆盖这些方法的子类必须注意调用超级实现。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Callback<ScheduledService<?>,Duration>> backoffStrategy
      计算在每次故障时添加到期间的时间量。
      ReadOnlyObjectProperty<Duration> cumulativePeriod
      迭代之间使用的当前累积周期。
      ReadOnlyIntegerProperty currentFailureCount
      当前ScheduledService失败的次数。
      ObjectProperty<Duration> delay
      首次启动ScheduledService之间的初始延迟，以及何时开始运行。
      ReadOnlyObjectProperty<V> lastValue
      最后成功计算的值。
      ObjectProperty<Duration> maximumCumulativePeriod
      累积百分比的最大允许值。
      IntegerProperty maximumFailureCount
      在完成FAILED状态之前，ScheduledService可以失败的最大次数。
      ObjectProperty<Duration> period
      允许在最后一次运行开始和下次运行开始之间的最短时间。
      BooleanProperty restartOnFailure
      指示在Task中出现故障时，ScheduledService是否应自动重新启动。

      • Properties inherited from class javafx.concurrent.Service

        exception, executor, message, onCancelled, onFailed, onReady, onRunning, onScheduled, onSucceeded, progress, running, state, title, totalWork, value, workDone

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javafx.concurrent.Worker

        Worker.State

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Callback<ScheduledService<?>,Duration> EXPONENTIAL_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况下以指数方式 backoffStrategy重新执行之间的时间段。
      static Callback<ScheduledService<?>,Duration> LINEAR_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况 backoffStrategy性地回退重新执行之间的时间段。
      static Callback<ScheduledService<?>,Duration> LOGARITHMIC_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况下对数地退避重新执行之间的期间。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScheduledService​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Callback<ScheduledService<?>,Duration>> backoffStrategyProperty​()
      计算在每次故障时添加到期间的时间量。
      boolean cancel​()
      取消任何当前正在运行的任务并停止此计划的服务，这样就不会发生额外的迭代。
      ReadOnlyObjectProperty<Duration> cumulativePeriodProperty​()
      迭代之间使用的当前累积周期。
      ReadOnlyIntegerProperty currentFailureCountProperty​()
      当前ScheduledService失败的次数。
      ObjectProperty<Duration> delayProperty​()
      首次启动ScheduledService之间的初始延迟，以及何时开始运行。
      protected void executeTask​(Task<V> task)
      使用此服务上定义的 executor执行给定的任务。
      protected void failed​()
      对于子类的受保护的便利方法，只要服务状态已经转换到FAILED状态。
      Callback<ScheduledService<?>,Duration> getBackoffStrategy​()
      获取属性backoffStrategy的值。
      Duration getCumulativePeriod​()
      获取属性cumulativePeriod的值。
      int getCurrentFailureCount​()
      获取属性currentFailureCount的值。
      Duration getDelay​()
      获取属性延迟的值。
      V getLastValue​()
      获取属性lastValue的值。
      Duration getMaximumCumulativePeriod​()
      获取属性maximumCumulativePeriod的值。
      int getMaximumFailureCount​()
      获取属性maximumFailureCount的值。
      Duration getPeriod​()
      获取属性期间的值。
      boolean getRestartOnFailure​()
      获取属性restartOnFailure的值。
      ReadOnlyObjectProperty<V> lastValueProperty​()
      最后成功计算的值。
      ObjectProperty<Duration> maximumCumulativePeriodProperty​()
      累积百分比的最大允许值。
      IntegerProperty maximumFailureCountProperty​()
      在完成FAILED状态之前，ScheduledService可以失败的最大次数。
      ObjectProperty<Duration> periodProperty​()
      允许在最后一次运行开始和下次运行开始之间的最短时间。
      void reset​()
      重置服务。
      BooleanProperty restartOnFailureProperty​()
      指示在Task中出现故障时，ScheduledService是否应自动重新启动。
      void setBackoffStrategy​(Callback<ScheduledService<?>,Duration> value)
      设置属性backoffStrategy的值。
      void setDelay​(Duration value)
      设置属性延迟的值。
      void setMaximumCumulativePeriod​(Duration value)
      设置属性maximumCumulativePeriod的值。
      void setMaximumFailureCount​(int value)
      设置属性maximumFailureCount的值。
      void setPeriod​(Duration value)
      设置属性周期的值。
      void setRestartOnFailure​(boolean value)
      设置属性restartOnFailure的值。
      protected void succeeded​()
      对于子类的受保护的便利方法，当服务状态已转换到SUCCEEDED状态时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.concurrent.Service

        addEventFilter, addEventHandler, buildEventDispatchChain, cancelled, createTask, exceptionProperty, executorProperty, fireEvent, getException, getExecutor, getMessage, getOnCancelled, getOnFailed, getOnReady, getOnRunning, getOnScheduled, getOnSucceeded, getProgress, getState, getTitle, getTotalWork, getValue, getWorkDone, isRunning, messageProperty, onCancelledProperty, onFailedProperty, onReadyProperty, onRunningProperty, onScheduledProperty, onSucceededProperty, progressProperty, ready, removeEventFilter, removeEventHandler, restart, running, runningProperty, scheduled, setEventHandler, setExecutor, setOnCancelled, setOnFailed, setOnReady, setOnRunning, setOnScheduled, setOnSucceeded, start, stateProperty, titleProperty, totalWorkProperty, valueProperty, workDoneProperty

    • Property Detail

      • delay

        public final ObjectProperty<Duration> delayProperty
        首次启动ScheduledService之间的初始延迟，以及何时开始运行。 这是在新的调用Service.start()或Service.restart()之后，在进入RUNNING状态之前，ScheduledService将保持在SCHEDULED状态的时间。
        另请参见：
        getDelay() ， setDelay(Duration)

      • period

        public final ObjectProperty<Duration> periodProperty
        允许在最后一次运行开始和下次运行开始之间的最短时间。 实际期间（也称为cumulativePeriod ）将取决于此属性以及backoffStrategy和故障次数。
        另请参见：
        getPeriod() ， setPeriod(Duration)

      • backoffStrategy

        public final ObjectProperty<Callback<ScheduledService<?>,Duration>> backoffStrategyProperty
        计算在每次故障时添加到期间的时间量。 每当手动重新启动ScheduledService时，这个累积金额将被重置。
        另请参见：
        getBackoffStrategy() ， setBackoffStrategy(Callback)

      • restartOnFailure

        public final BooleanProperty restartOnFailureProperty
        指示在Task中出现故障时，ScheduledService是否应自动重新启动。
        另请参见：
        getRestartOnFailure() ， setRestartOnFailure(boolean)

      • maximumFailureCount

        public final IntegerProperty maximumFailureCountProperty
        在完成FAILED状态之前，ScheduledService可以失败的最大次数。 您当然可以手动重新启动ScheduledService，这将导致当前计数被重置。
        另请参见：
        getMaximumFailureCount() ， setMaximumFailureCount(int)

      • currentFailureCount

        public final ReadOnlyIntegerProperty currentFailureCountProperty
        当前ScheduledService失败的次数。 每当手动重新启动ScheduledService时，都会重新启动。
        另请参见：
        getCurrentFailureCount()

      • cumulativePeriod

        public final ReadOnlyObjectProperty<Duration> cumulativePeriodProperty
        迭代之间使用的当前累积周期。 这将与period相同，除了失败之后，在这种情况下，backoffStrategy的结果将被用作每个故障后的累积周期。 每当手动重新启动ScheduledService或迭代成功时，都会重新设置。 当ScheduledService进入计划状态时，累积周期被修改。 累积maximumCumulativePeriod可以通过设置maximumCumulativePeriod加以限制。
        另请参见：
        getCumulativePeriod()

      • maximumCumulativePeriod

        public final ObjectProperty<Duration> maximumCumulativePeriodProperty
        累积百分比的最大允许值。 设置此值将有助于确保在重复故障的情况下，退避算法不会最终在累积周期内产生不合理的较大值。 累积期限不得大于该值。 如果maximumCumulativePeriod为负，那么cumulativePeriod将被限制为0.如果maximumCumulativePeriod为NaN或为null，则不会影响累积周期。
        另请参见：
        getMaximumCumulativePeriod() ， setMaximumCumulativePeriod(Duration)

      • lastValue

        public final ReadOnlyObjectProperty<V> lastValueProperty
        最后成功计算的值。 在每次迭代期间，与任何其他服务一样，ScheduledService的“值”将重置为null。 然而，“lastValue”将被设置为最近成功计算的值，甚至跨越迭代。 无论何时手动调用重置或重新启动，它都会被重置。
        另请参见：
        getLastValue()

    • 字段详细信息

      • EXPONENTIAL_BACKOFF_STRATEGY

        public static final Callback<ScheduledService<?>,Duration> EXPONENTIAL_BACKOFF_STRATEGY
        backoffStrategy属性的回调实现将在失败的情况下以指数方式backoffStrategy重新执行之间的时间段。 该计算采用原始周期和连续故障的数量，并从该信息计算退避量。

        如果service为空，则返回Duration.ZERO。 如果期限为0，则此方法的结果将为Math.exp(currentFailureCount) 。 在所有其他情况下，返回值与period + (period * Math.exp(currentFailureCount))相同。

      • LOGARITHMIC_BACKOFF_STRATEGY

        public static final Callback<ScheduledService<?>,Duration> LOGARITHMIC_BACKOFF_STRATEGY
        backoffStrategy属性的回调实现将在失败的情况下对数地backoffStrategy重新执行之间的时间段。 该计算采用原始周期和连续故障的数量，并从该信息计算退避量。

        如果service为空，则返回Duration.ZERO。 如果期间为0，则该方法的结果将为Math.log1p(currentFailureCount) 。 在所有其他情况下，返回值与period + (period * Math.log1p(currentFailureCount))相同。

      • LINEAR_BACKOFF_STRATEGY

        public static final Callback<ScheduledService<?>,Duration> LINEAR_BACKOFF_STRATEGY
        backoffStrategy属性的回调实现将在失败的情况backoffStrategy性地回退重新执行之间的时间段。 该计算采用原始周期和连续故障的数量，并从该信息计算退避量。

        如果service为空，则返回Duration.ZERO。 如果期限为0，则此方法的结果将为currentFailureCount 。 在所有其他情况下，返回值与period + (period * currentFailureCount)相同。

    • 构造方法详细信息

      • ScheduledService

        public ScheduledService​()

    • 方法详细信息

      • getDelay

        public final Duration getDelay​()
        获取属性延迟的值。
        Property description:
        首次启动ScheduledService之间的初始延迟，以及何时开始运行。 这是在新的调用Service.start()或Service.restart()之后，在进入RUNNING状态之前，ScheduledService将保持在SCHEDULED状态的时间。

      • setDelay

        public final void setDelay​(Duration value)
        设置属性延迟的值。
        Property description:
        首次启动ScheduledService之间的初始延迟，以及何时开始运行。 这是在新的调用Service.start()或Service.restart()之后，在进入RUNNING状态之前，ScheduledService将保持在SCHEDULED状态的时间。

      • delayProperty

        public final ObjectProperty<Duration> delayProperty​()
        首次启动ScheduledService之间的初始延迟，以及何时开始运行。 这是在新的调用Service.start()或Service.restart()之后，在进入RUNNING状态之前，ScheduledService将保持在SCHEDULED状态的时间。
        另请参见：
        getDelay() ， setDelay(Duration)

      • getPeriod

        public final Duration getPeriod​()
        获取属性期间的值。
        Property description:
        允许在最后一次运行开始和下次运行开始之间的最短时间。 实际期间（也称为cumulativePeriod ）将取决于此属性以及backoffStrategy和故障次数。

      • setPeriod

        public final void setPeriod​(Duration value)
        设置属性周期的值。
        Property description:
        允许在最后一次运行开始和下次运行开始之间的最短时间。 实际期间（也称为cumulativePeriod ）将取决于此属性以及backoffStrategy和故障次数。

      • periodProperty

        public final ObjectProperty<Duration> periodProperty​()
        允许在最后一次运行开始和下次运行开始之间的最短时间。 实际期间（也称为cumulativePeriod ）将取决于此属性以及backoffStrategy和故障次数。
        另请参见：
        getPeriod() ， setPeriod(Duration)

      • getBackoffStrategy

        public final Callback<ScheduledService<?>,Duration> getBackoffStrategy​()
        获取属性backoffStrategy的值。
        Property description:
        计算在每次故障时添加到期间的时间量。 每当手动重新启动ScheduledService时，这个累积金额将被重置。

      • setBackoffStrategy

        public final void setBackoffStrategy​(Callback<ScheduledService<?>,Duration> value)
        设置属性backoffStrategy的值。
        Property description:
        计算在每次故障时添加到期间的时间量。 每当手动重新启动ScheduledService时，这个累积金额将被重置。

      • backoffStrategyProperty

        public final ObjectProperty<Callback<ScheduledService<?>,Duration>> backoffStrategyProperty​()
        计算在每次故障时添加到期间的时间量。 每当手动重新启动ScheduledService时，这个累积金额将被重置。
        另请参见：
        getBackoffStrategy() ， setBackoffStrategy(Callback)

      • getRestartOnFailure

        public final boolean getRestartOnFailure​()
        获取属性restartOnFailure的值。
        Property description:
        指示在Task中出现故障时，ScheduledService是否应自动重新启动。

      • setRestartOnFailure

        public final void setRestartOnFailure​(boolean value)
        设置属性restartOnFailure的值。
        Property description:
        指示在Task中出现故障时，ScheduledService是否应自动重新启动。

      • restartOnFailureProperty

        public final BooleanProperty restartOnFailureProperty​()
        指示在Task中出现故障时，ScheduledService是否应自动重新启动。
        另请参见：
        getRestartOnFailure() ， setRestartOnFailure(boolean)

      • getMaximumFailureCount

        public final int getMaximumFailureCount​()
        获取属性maximumFailureCount的值。
        Property description:
        在完成FAILED状态之前，ScheduledService可以失败的最大次数。 您当然可以手动重新启动ScheduledService，这将导致当前计数被重置。

      • setMaximumFailureCount

        public final void setMaximumFailureCount​(int value)
        设置属性maximumFailureCount的值。
        Property description:
        在完成FAILED状态之前，ScheduledService可以失败的最大次数。 您当然可以手动重新启动ScheduledService，这将导致当前计数被重置。

      • maximumFailureCountProperty

        public final IntegerProperty maximumFailureCountProperty​()
        在完成FAILED状态之前，ScheduledService可以失败的最大次数。 您当然可以手动重新启动ScheduledService，这将导致当前计数被重置。
        另请参见：
        getMaximumFailureCount() ， setMaximumFailureCount(int)

      • getCurrentFailureCount

        public final int getCurrentFailureCount​()
        获取属性currentFailureCount的值。
        Property description:
        当前ScheduledService失败的次数。 每当手动重新启动ScheduledService时，都会重新启动。

      • currentFailureCountProperty

        public final ReadOnlyIntegerProperty currentFailureCountProperty​()
        当前ScheduledService失败的次数。 每当手动重新启动ScheduledService时，都会重新启动。
        另请参见：
        getCurrentFailureCount()

      • getCumulativePeriod

        public final Duration getCumulativePeriod​()
        获取属性cumulativePeriod的值。
        Property description:
        迭代之间使用的当前累积周期。 这将与period相同，除了失败之后，在这种情况下，backoffStrategy的结果将被用作每次故障后的累积周期。 每当手动重新启动ScheduledService或迭代成功时，都会重新设置。 当ScheduledService进入计划状态时，累积周期被修改。 累积maximumCumulativePeriod可以通过设置maximumCumulativePeriod加以限制。

      • cumulativePeriodProperty

        public final ReadOnlyObjectProperty<Duration> cumulativePeriodProperty​()
        迭代之间使用的当前累积周期。 这将与period相同，除了失败之后，在这种情况下，backoffStrategy的结果将被用作每次故障后的累积周期。 每当手动重新启动ScheduledService或迭代成功时，都会重新设置。 当ScheduledService进入计划状态时，累积周期被修改。 累积maximumCumulativePeriod可以通过设置maximumCumulativePeriod加以限制。
        另请参见：
        getCumulativePeriod()

      • getMaximumCumulativePeriod

        public final Duration getMaximumCumulativePeriod​()
        获取属性maximumCumulativePeriod的值。
        Property description:
        累积百分比的最大允许值。 设置此值将有助于确保在重复故障的情况下，退避算法不会最终在累积周期内产生不合理的较大值。 累积期限不得大于该值。 如果maximumCumulativePeriod为负，那么cumulativePeriod将被限制为0.如果maximumCumulativePeriod为NaN或为null，则不会影响累积周期。

      • setMaximumCumulativePeriod

        public final void setMaximumCumulativePeriod​(Duration value)
        设置属性maximumCumulativePeriod的值。
        Property description:
        累积百分比的最大允许值。 设置此值将有助于确保在重复故障的情况下，退避算法不会最终在累积周期内产生不合理的较大值。 累积期限不得大于该值。 如果maximumCumulativePeriod为负，那么cumulativePeriod将被限制为0.如果maximumCumulativePeriod为NaN或为null，则不会影响累积周期。

      • maximumCumulativePeriodProperty

        public final ObjectProperty<Duration> maximumCumulativePeriodProperty​()
        累积百分比的最大允许值。 设置此值将有助于确保在重复故障的情况下，退避算法不会最终在累积周期内产生不合理的较大值。 累积期限不得大于该值。 如果maximumCumulativePeriod为负，那么cumulativePeriod将被限制为0.如果maximumCumulativePeriod为NaN或为null，则不会影响累积周期。
        另请参见：
        getMaximumCumulativePeriod() ， setMaximumCumulativePeriod(Duration)

      • getLastValue

        public final V getLastValue​()
        获取属性lastValue的值。
        Property description:
        最后成功计算的值。 在每次迭代期间，与任何其他服务一样，ScheduledService的“值”将重置为null。 然而，“lastValue”将被设置为最近成功计算的值，甚至跨越迭代。 无论何时手动调用重置或重新启动，它都会被重置。

      • lastValueProperty

        public final ReadOnlyObjectProperty<V> lastValueProperty​()
        最后成功计算的值。 在每次迭代期间，与任何其他服务一样，ScheduledService的“值”将重置为null。 然而，“lastValue”将被设置为最近成功计算的值，甚至跨越迭代。 无论何时手动调用重置或重新启动，它都会被重置。
        另请参见：
        getLastValue()

      • executeTask

        protected void executeTask​(Task<V> task)
        描述从类别复制： Service

        使用此服务上定义的executor执行给定的任务。 如果executor为空，则使用默认执行程序，它将创建一个新的守护程序线程，执行此任务。

        此方法仅用于由Service实现调用。

        重写：
        executeTask在 Service<V>
        参数
        task - 要执行的非空任务

      • succeeded

        protected void succeeded​()
        对于子类的受保护的便利方法，当服务状态已转换到SUCCEEDED状态时调用。 该方法在服务完全转换到新状态后被调用。 实现注意：覆盖此方法的子类必须调用此超级实现。
        重写：
        succeeded在 Service<V>

      • failed

        protected void failed​()
        对于子类的受保护的便利方法，只要服务状态已经转换到FAILED状态。 该方法在服务完全转换到新状态后被调用。 实现注意：覆盖此方法的子类必须调用此超级实现。
        重写：
        failed在 Service<V>

      • reset

        public void reset​()
        重置服务。 只能在其中一个完成状态（即，已成功，失败或已取消）或READY时被调用。 该方法只能在FX应用程序线程上调用。 实现注意：覆盖此方法的子类必须调用此超级实现。
        重写：
        reset在 Service<V>

      • cancel

        public boolean cancel​()
        取消任何当前正在运行的任务并停止此计划的服务，这样就不会发生额外的迭代。
        Specified by:
        cancel在接口 Worker<V>
        重写：
        cancel在 Service<V>
        结果
        任何运行任务是否被取消，如果没有任务被取消，则为false。 在任何情况下，ScheduledService将停止迭代。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Service (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.concurrent

Class Service<V>

  • java.lang.Object
    • javafx.concurrent.Service<V>
  • 参数类型
    V - 服务返回的对象的类型
    All Implemented Interfaces:
    Worker<V> ， EventTarget
    已知直接子类：
    ScheduledService

    public abstract class Service<V>
extends Object
implements Worker<V>, EventTarget

    服务是一个非可视化组件，封装了在一个或多个后台线程上执行某些工作所需的信息。 作为JavaFX UI库的一部分，该服务了解JavaFX应用程序线程，旨在缓解应用程序开发人员处理与用户界面交互的多线程代码的负担。 因此，服务上的所有方法和状态都将专门从JavaFX应用程序线程调用。 唯一的例外是初始配置一个可以从任何线程安全地完成的服务，最初启动一个服务，这也可以从任何线程安全地完成。 但是，一旦服务已被初始化和启动，它可能只能在FX线程之后使用。

    一个服务创建并管理一个执行后台线程工作的Task 。 服务实施Worker 。 因此，您可以观察后台任务的状态，并可以取消它。 服务是一个可重用的工作者，这意味着它可以重置并重新启动。 由于这一点，服务可以声明性地构造并按需重新启动。 一旦服务启动，它将安排其任务并监听任务状态的更改。 任务不支持启动它的服务的引用，这意味着正在运行的任务不会阻止服务被垃圾回收。

    如果在服务上指定了Executor ，则将用于实际执行该服务。 否则，将创建并执行守护线程。 如果要创建非守护进程线程，请指定自定义的Executor（例如，您可以使用ThreadPoolExecutor和自定义的ThreadFactory ）。

    因为一个服务旨在简化声明性用例，子类应该将工作的输入参数作为属性公开。 例如，假设我想写一个从任何URL读取第一行的服务，并将其作为String返回。 这样的服务可以被定义，使得它具有单个属性url 。 它可能被实现为：

       public static class FirstLineService extends Service<String> { private StringProperty url = new SimpleStringProperty(this, "url"); public final void setUrl(String value) { url.set(value); } public final String getUrl() { return url.get(); } public final StringProperty urlProperty() { return url; } protected Task createTask() { final String _url = getUrl(); return new Task<String>() { protected String call() throws Exception { URL u = new URL(_url); BufferedReader in = new BufferedReader( new InputStreamReader(u.openStream())); String result = in.readLine(); in.close(); return result; } }; } }

    默认情况下，服务使用具有某些未指定的默认或最大线程池大小的线程池执行程序。 这样做是为了使天真的代码不会完全通过创建数千个线程来扩展系统。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<Throwable> exception
      获取表示发生的任何异常的ReadOnlyObjectProperty。
      ObjectProperty<Executor> executor
      执行者用于运行此服务。
      ReadOnlyStringProperty message
      获取表示消息的ReadOnlyStringProperty。
      ObjectProperty<EventHandler<WorkerStateEvent>> onCancelled
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onFailed
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onReady
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onRunning
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onScheduled
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onSucceeded
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ReadOnlyDoubleProperty progress
      获取表示进度的ReadOnlyDoubleProperty。
      ReadOnlyBooleanProperty running
      获取表示Worker正在运行的ReadOnlyBooleanProperty。
      ReadOnlyObjectProperty<Worker.State> state
      获取表示当前状态的ReadOnlyObjectProperty。
      ReadOnlyStringProperty title
      获取表示标题的ReadOnlyStringProperty。
      ReadOnlyDoubleProperty totalWork
      获取ReadOnlyDoubleProperty代表需要完成的最大工作量。
      ReadOnlyObjectProperty<V> value
      获取表示值的ReadOnlyObjectProperty。
      ReadOnlyDoubleProperty workDone
      获取表示当前进度的ReadOnlyDoubleProperty。

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javafx.concurrent.Worker

        Worker.State

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Service​()
      创建一个新的服务。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      <T extends Event>
      void             		addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      将事件过滤器注册到此任务。
      <T extends Event>
      void             		addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个任务。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      boolean cancel​()
      取消任何当前正在运行的任务（如果有）。
      protected void cancelled​()
      对于子类的受保护的便利方法，只要服务状态已经转换到CANCELED状态就调用。
      protected abstract Task<V> createTask​()
      在JavaFX应用程序主题上启动服务后调用。
      ReadOnlyObjectProperty<Throwable> exceptionProperty​()
      获取表示发生的任何异常的ReadOnlyObjectProperty。
      protected void executeTask​(Task<V> task)
      使用此服务上定义的 executor执行给定的任务。
      ObjectProperty<Executor> executorProperty​()
      执行者用于运行此服务。
      protected void failed​()
      对于子类的受保护的便利方法，只要服务状态已经转换到FAILED状态。
      protected void fireEvent​(Event event)
      触发指定的事件。
      Throwable getException​()
      获取属性异常的值。
      Executor getExecutor​()
      获取属性执行器的值。
      String getMessage​()
      获取属性消息的值。
      EventHandler<WorkerStateEvent> getOnCancelled​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      EventHandler<WorkerStateEvent> getOnFailed​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      EventHandler<WorkerStateEvent> getOnReady​()
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      EventHandler<WorkerStateEvent> getOnRunning​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      EventHandler<WorkerStateEvent> getOnScheduled​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      EventHandler<WorkerStateEvent> getOnSucceeded​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      double getProgress​()
      获取属性进度的值。
      Worker.State getState​()
      获取属性状态的值。
      String getTitle​()
      获取属性标题的值。
      double getTotalWork​()
      获取属性totalWork的值。
      V getValue​()
      获取属性值的值。
      double getWorkDone​()
      获取属性workDone的值。
      boolean isRunning​()
      获取运行的属性的值。
      ReadOnlyStringProperty messageProperty​()
      获取表示消息的ReadOnlyStringProperty。
      ObjectProperty<EventHandler<WorkerStateEvent>> onCancelledProperty​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onFailedProperty​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onReadyProperty​()
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onRunningProperty​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onScheduledProperty​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onSucceededProperty​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ReadOnlyDoubleProperty progressProperty​()
      获取表示进度的ReadOnlyDoubleProperty。
      protected void ready​()
      对于子类的受保护的便利方法，在服务状态已转换到READY状态时调用。
      <T extends Event>
      void             		removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此任务中注销先前注册的事件过滤器。
      <T extends Event>
      void             		removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此任务中注销先前注册的事件处理程序。
      void reset​()
      重置服务。
      void restart​()
      取消任何当前正在运行的任务（如果有），并重新启动此服务。
      protected void running​()
      每当该服务的状态已经转换到RUNNING状态时，调用子类的受保护的便利方法。
      ReadOnlyBooleanProperty runningProperty​()
      获取表示Worker正在运行的ReadOnlyBooleanProperty。
      protected void scheduled​()
      每当该服务的状态已转换到SCHEDULED状态时调用的子类的受保护的便利方法。
      protected <T extends Event>
      void             		setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      void setExecutor​(Executor value)
      设置属性执行器的值。
      void setOnCancelled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      void setOnFailed​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      void setOnReady​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      void setOnRunning​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      void setOnScheduled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      void setOnSucceeded​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      void start​()
      启动此服务。
      ReadOnlyObjectProperty<Worker.State> stateProperty​()
      获取表示当前状态的ReadOnlyObjectProperty。
      protected void succeeded​()
      对于子类的受保护的便利方法，当服务状态已转换到SUCCEEDED状态时调用。
      ReadOnlyStringProperty titleProperty​()
      获取表示标题的ReadOnlyStringProperty。
      ReadOnlyDoubleProperty totalWorkProperty​()
      获取ReadOnlyDoubleProperty代表需要完成的最大工作量。
      ReadOnlyObjectProperty<V> valueProperty​()
      获取表示值的ReadOnlyObjectProperty。
      ReadOnlyDoubleProperty workDoneProperty​()
      获取表示当前进度的ReadOnlyDoubleProperty。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • state

        public final ReadOnlyObjectProperty<Worker.State> stateProperty
        Specified by:
        stateProperty在接口 Worker<V>
        另请参见：
        getState()

      • value

        public final ReadOnlyObjectProperty<V> valueProperty
        Specified by:
        valueProperty在接口 Worker<V>
        另请参见：
        getValue()

      • exception

        public final ReadOnlyObjectProperty<Throwable> exceptionProperty
        Specified by:
        exceptionProperty在接口 Worker<V>
        另请参见：
        getException()

      • workDone

        public final ReadOnlyDoubleProperty workDoneProperty
        Specified by:
        workDoneProperty在接口 Worker<V>
        另请参见：
        getWorkDone()

      • totalWork

        public final ReadOnlyDoubleProperty totalWorkProperty
        Specified by:
        totalWorkProperty在接口 Worker<V>
        另请参见：
        getTotalWork()

      • progress

        public final ReadOnlyDoubleProperty progressProperty
        Specified by:
        progressProperty在接口 Worker<V>
        另请参见：
        getProgress()

      • running

        public final ReadOnlyBooleanProperty runningProperty
        Specified by:
        runningProperty在接口 Worker<V>
        另请参见：
        isRunning()

      • message

        public final ReadOnlyStringProperty messageProperty
        Specified by:
        messageProperty在接口 Worker<V>
        另请参见：
        getMessage()

      • title

        public final ReadOnlyStringProperty titleProperty
        Specified by:
        titleProperty在接口 Worker<V>
        另请参见：
        getTitle()

      • executor

        public final ObjectProperty<Executor> executorProperty
        执行者用于运行此服务。 如果没有指定执行程序，则将创建一个新的守护程序线程，并使用一些默认执行程序运行该服务。
        另请参见：
        getExecutor() ， setExecutor(Executor)

      • onReady

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onReadyProperty
        每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnReady() ， setOnReady(EventHandler)

      • onScheduled

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onScheduledProperty
        每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnScheduled() ， setOnScheduled(EventHandler)

      • onRunning

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onRunningProperty
        每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnRunning() ， setOnRunning(EventHandler)

      • onSucceeded

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onSucceededProperty
        每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnSucceeded() ， setOnSucceeded(EventHandler)

      • onCancelled

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onCancelledProperty
        每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnCancelled() ， setOnCancelled(EventHandler)

      • onFailed

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onFailedProperty
        每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnFailed() ， setOnFailed(EventHandler)

    • 构造方法详细信息

      • Service

        protected Service​()
        创建一个新的服务。

    • 方法详细信息

      • getState

        public final Worker.State getState​()
        获取属性状态的值。
        Specified by:
        getState在接口 Worker<V>
        Property description:
        结果
        这个工人的现状

      • stateProperty

        public final ReadOnlyObjectProperty<Worker.State> stateProperty​()
        说明从界面Worker复制
        获取表示当前状态的ReadOnlyObjectProperty。
        Specified by:
        stateProperty在接口 Worker<V>
        另请参见：
        getState()

      • getValue

        public final V getValue​()
        获取属性值的值。
        Specified by:
        getValue接口 Worker<V>
        Property description:
        结果
        这个工人的当前值

      • valueProperty

        public final ReadOnlyObjectProperty<V> valueProperty​()
        说明从界面Worker复制
        获取表示值的ReadOnlyObjectProperty。
        Specified by:
        valueProperty在接口 Worker<V>
        另请参见：
        getValue()

      • getException

        public final Throwable getException​()
        获取属性异常的值。
        Specified by:
        getException在接口 Worker<V>
        Property description:
        结果
        例外，如果发生

      • exceptionProperty

        public final ReadOnlyObjectProperty<Throwable> exceptionProperty​()
        描述从接口Worker复制
        获取表示发生的任何异常的ReadOnlyObjectProperty。
        Specified by:
        exceptionProperty接口 Worker<V>
        另请参见：
        getException()

      • getWorkDone

        public final double getWorkDone​()
        获取属性workDone的值。
        Specified by:
        getWorkDone在接口 Worker<V>
        Property description:
        结果
        完成的工作量
        另请参见：
        Worker.totalWorkProperty() ， Worker.progressProperty()

      • workDoneProperty

        public final ReadOnlyDoubleProperty workDoneProperty​()
        描述从接口Worker复制
        获取表示当前进度的ReadOnlyDoubleProperty。
        Specified by:
        workDoneProperty在接口 Worker<V>
        另请参见：
        getWorkDone()

      • getTotalWork

        public final double getTotalWork​()
        获取属性totalWork的值。
        Specified by:
        getTotalWork在接口 Worker<V>
        Property description:
        结果
        要完成的工作
        另请参见：
        Worker.workDoneProperty() ， Worker.progressProperty()

      • totalWorkProperty

        public final ReadOnlyDoubleProperty totalWorkProperty​()
        说明从界面Worker复制
        获取ReadOnlyDoubleProperty代表需要完成的最大工作量。 这些“工作单位”对Worker实现有意义，例如需要下载的字节数或要处理的图像数量或某种其他此类度量。
        Specified by:
        totalWorkProperty在接口 Worker<V>
        另请参见：
        getTotalWork()

      • getProgress

        public final double getProgress​()
        获取属性进度的值。
        Specified by:
        getProgress在接口 Worker<V>
        Property description:
        结果
        当前进展
        另请参见：
        Worker.workDoneProperty() ， Worker.totalWorkProperty()

      • progressProperty

        public final ReadOnlyDoubleProperty progressProperty​()
        描述从接口Worker复制
        获取表示进度的ReadOnlyDoubleProperty。
        Specified by:
        progressProperty在接口 Worker<V>
        另请参见：
        getProgress()

      • isRunning

        public final boolean isRunning​()
        获取运行的属性的值。
        Specified by:
        isRunning在接口 Worker<V>
        Property description:
        结果
        如果此Worker正在运行，则为true

      • runningProperty

        public final ReadOnlyBooleanProperty runningProperty​()
        描述从接口Worker复制
        获取表示Worker正在运行的ReadOnlyBooleanProperty。
        Specified by:
        runningProperty在接口 Worker<V>
        另请参见：
        isRunning()

      • getMessage

        public final String getMessage​()
        获取属性消息的值。
        Specified by:
        getMessage在接口 Worker<V>
        Property description:
        结果
        当前的消息

      • messageProperty

        public final ReadOnlyStringProperty messageProperty​()
        说明从接口Worker复制
        获取表示消息的ReadOnlyStringProperty。
        Specified by:
        messageProperty在接口 Worker<V>
        另请参见：
        getMessage()

      • getTitle

        public final String getTitle​()
        获取属性标题的值。
        Specified by:
        getTitle在接口 Worker<V>
        Property description:
        结果
        当前标题

      • titleProperty

        public final ReadOnlyStringProperty titleProperty​()
        说明从接口Worker复制
        获取表示标题的ReadOnlyStringProperty。
        Specified by:
        titleProperty在接口 Worker<V>
        另请参见：
        getTitle()

      • setExecutor

        public final void setExecutor​(Executor value)
        设置属性执行器的值。
        Property description:
        执行者用于运行此服务。 如果没有指定执行程序，则将创建一个新的守护程序线程，并使用一些默认执行程序运行该服务。

      • getExecutor

        public final Executor getExecutor​()
        获取属性执行器的值。
        Property description:
        执行者用于运行此服务。 如果没有指定执行程序，则将创建一个新的守护程序线程，并使用一些默认执行程序运行该服务。

      • executorProperty

        public final ObjectProperty<Executor> executorProperty​()
        执行者用于运行此服务。 如果没有指定执行程序，则将创建一个新的守护程序线程，并使用一些默认执行程序运行该服务。
        另请参见：
        getExecutor() ， setExecutor(Executor)

      • onReadyProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onReadyProperty​()
        每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnReady() ， setOnReady(EventHandler)

      • getOnReady

        public final EventHandler<WorkerStateEvent> getOnReady​()
        每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
        结果
        onReady事件处理程序（如果有）
        从以下版本开始：
        JavaFX 2.1

      • setOnReady

        public final void setOnReady​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
        参数
        value - 事件处理程序可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • ready

        protected void ready​()
        对于子类的受保护的便利方法，在服务状态已转换到READY状态时调用。 该方法在服务完全转换到新状态后被调用。
        从以下版本开始：
        JavaFX 2.1

      • onScheduledProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onScheduledProperty​()
        每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnScheduled() ， setOnScheduled(EventHandler)

      • getOnScheduled

        public final EventHandler<WorkerStateEvent> getOnScheduled​()
        每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
        结果
        onScheduled事件处理程序（如果有的话）
        从以下版本开始：
        JavaFX 2.1

      • setOnScheduled

        public final void setOnScheduled​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
        参数
        value - 事件处理程序，可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • scheduled

        protected void scheduled​()
        每当该服务的状态已转换到SCHEDULED状态时调用的子类的受保护的便利方法。 该方法在服务完全转换到新状态后被调用。
        从以下版本开始：
        JavaFX 2.1

      • onRunningProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onRunningProperty​()
        每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnRunning() ， setOnRunning(EventHandler)

      • getOnRunning

        public final EventHandler<WorkerStateEvent> getOnRunning​()
        每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
        结果
        onRunning事件处理程序（如果有的话）
        从以下版本开始：
        JavaFX 2.1

      • setOnRunning

        public final void setOnRunning​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
        参数
        value - 事件处理程序，可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • running

        protected void running​()
        每当该服务的状态已经转换到RUNNING状态时，调用子类的受保护的便利方法。 该方法在服务完全转换到新状态后被调用。
        从以下版本开始：
        JavaFX 2.1

      • onSucceededProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onSucceededProperty​()
        每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnSucceeded() ， setOnSucceeded(EventHandler)

      • getOnSucceeded

        public final EventHandler<WorkerStateEvent> getOnSucceeded​()
        每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
        结果
        onSucceeded事件处理程序（如果有）
        从以下版本开始：
        JavaFX 2.1

      • setOnSucceeded

        public final void setOnSucceeded​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
        参数
        value - 事件处理程序，可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • succeeded

        protected void succeeded​()
        对于子类的受保护的便利方法，当服务状态已转换到SUCCEEDED状态时调用。 该方法在服务完全转换到新状态后被调用。
        从以下版本开始：
        JavaFX 2.1

      • onCancelledProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onCancelledProperty​()
        每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnCancelled() ， setOnCancelled(EventHandler)

      • getOnCancelled

        public final EventHandler<WorkerStateEvent> getOnCancelled​()
        每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
        结果
        onCancelled事件处理程序（如果有）
        从以下版本开始：
        JavaFX 2.1

      • setOnCancelled

        public final void setOnCancelled​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
        参数
        value - 事件处理程序，可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • cancelled

        protected void cancelled​()
        对于子类的受保护的便利方法，只要服务状态已经转换到CANCELED状态就调用。 该方法在服务完全转换到新状态后被调用。
        从以下版本开始：
        JavaFX 2.1

      • onFailedProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onFailedProperty​()
        每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnFailed() ， setOnFailed(EventHandler)

      • getOnFailed

        public final EventHandler<WorkerStateEvent> getOnFailed​()
        每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
        结果
        onFailed事件处理程序（如果有）
        从以下版本开始：
        JavaFX 2.1

      • setOnFailed

        public final void setOnFailed​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
        参数
        value - 事件处理程序，可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • failed

        protected void failed​()
        对于子类的受保护的便利方法，只要服务状态已经转换到FAILED状态。 该方法在服务完全转换到新状态后被调用。
        从以下版本开始：
        JavaFX 2.1

      • cancel

        public boolean cancel​()
        取消任何当前正在运行的任务（如果有）。 状态将被设置为CANCELED。
        Specified by:
        cancel在接口 Worker<V>
        结果
        如果取消成功，则返回true

      • restart

        public void restart​()
        取消任何当前正在运行的任务（如果有），并重新启动此服务。 执行前状态将重置为READY。 该方法只能在FX应用程序线程上调用。

      • reset

        public void reset​()
        重置服务。 只能在其中一个完成状态（即，已成功，失败或已取消）或READY时被调用。 该方法只能在FX应用程序线程上调用。

      • start

        public void start​()
        启动此服务。 该服务必须处于就绪状态才能在此呼叫中成功。 该方法只能在FX应用程序线程上调用。

      • executeTask

        protected void executeTask​(Task<V> task)

        使用此服务上定义的executor执行给定的任务。 如果executor为空，则使用默认执行程序，该执行程序将创建一个新的守护程序线程，以执行此任务。

        此方法仅用于由Service实现调用。

        参数
        task - 要执行的非空任务
        从以下版本开始：
        JavaFX 2.1

      • addEventHandler

        public final <T extends Event> void addEventHandler​(EventType<T> eventType,
                                                    EventHandler<? super T> eventHandler)
        注册一个事件处理程序到这个任务。 首先处理任何事件过滤器，然后处理指定的onFoo事件处理程序，最后处理通过此方法注册的任何事件处理程序。 与场景图中的其他事件一样，如果事件被消耗，则不会继续调度。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 处理程序接收的事件的类型
        eventHandler - 要注册的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空
        从以下版本开始：
        JavaFX 2.1

      • removeEventHandler

        public final <T extends Event> void removeEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        从此任务中注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空
        从以下版本开始：
        JavaFX 2.1

      • addEventFilter

        public final <T extends Event> void addEventFilter​(EventType<T> eventType,
                                                   EventHandler<? super T> eventFilter)
        将事件过滤器注册到此任务。 注册事件过滤器在任何关联的事件处理程序之前获取事件。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 过滤器接收的事件的类型
        eventFilter - 要注册的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空
        从以下版本开始：
        JavaFX 2.1

      • removeEventFilter

        public final <T extends Event> void removeEventFilter​(EventType<T> eventType,
                                                      EventHandler<? super T> eventFilter)
        从此任务中注销先前注册的事件过滤器。 一个过滤器可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销过滤器。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 要注销的事件类型
        eventFilter - 要注销的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空
        从以下版本开始：
        JavaFX 2.1

      • setEventHandler

        protected final <T extends Event> void setEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        设置要用于此事件类型的处理程序。 一次只能有一个这样的处理程序。 这个处理程序被保证被首先调用。 这用于注册用户定义的onFoo事件处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 与给定eventHandler关联的事件类型
        eventHandler - 要注册的处理程序，或者取消注册为null
        异常
        NullPointerException - 如果事件类型为空
        从以下版本开始：
        JavaFX 2.1

      • fireEvent

        protected final void fireEvent​(Event event)
        触发指定的事件。 遇到的任何事件过滤器将被通知并可以使用该事件。 如果没有被过滤器使用，则会通知此任务上的事件处理程序。 如果这些也不消耗事件，那么所有事件处理程序都被调用，并且可以使用该事件。

        必须在FX用户线程上调用此方法。

        参数
        event - 事件发生
        从以下版本开始：
        JavaFX 2.1

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        描述从接口EventTarget复制
        为此目标构建事件调度链。 事件调度链包含可能对处理针对EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要为链接添加一个EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 从...建立的初始链
        结果
        此目标的结果事件调度链

      • createTask

        protected abstract Task<V> createTask​()
        在JavaFX应用程序主题上启动服务后调用。 实现应该在创建任务之前将任何状态保存到最终变量中，因为在任务的后台线程代码中访问服务上定义的属性将导致异常。 例如：
           protected Task createTask() { final String url = myService.getUrl(); return new Task<String>() { protected String call() { URL u = new URL("http://www.oracle.com"); BufferedReader in = new BufferedReader( new InputStreamReader(u.openStream())); String result = in.readLine(); in.close(); return result; } } }

        如果Task是一个预定义的类（而不是匿名类），并且如果遵循推荐的最佳实践，那么在构建Task之前不需要保存状态，因为它的状态是完全提供的它的构造函数。

           protected Task createTask() { // This is safe because getUrl is called on the FX Application // Thread and the FirstLineReaderTasks stores it as an // immutable property return new FirstLineReaderTask(myService.getUrl()); }
        结果
        执行任务
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Task (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.concurrent

Class Task<V>

  • java.lang.Object
    • java.util.concurrent.FutureTask<V>
      • javafx.concurrent.Task<V>
  • All Implemented Interfaces:
    Runnable ， Future<V> ， RunnableFuture<V> ， Worker<V> ， EventTarget

    public abstract class Task<V>
extends FutureTask<V>
implements Worker<V>, EventTarget

    一个完全可观察到的一个FutureTask的实现。 Task暴露了额外的状态和可观察属性，可用于在JavaFX中编程异步任务，如Worker界面中所定义。 任务的实现必须覆盖call()方法。 这个方法在后台线程上被调用。 在此方法中使用的任何状态必须能够安全地从后台线程读写。 例如，从此方法处理实时场景图是不安全的，并将导致运行时异常。

    任务灵活，对于“工作”的封装非常有用。 因为Service被设计为执行任务，所以应用程序或库代码定义的任何任务都可以轻松地与服务一起使用。 同样，由于Task从FutureTask扩展，使用Java并发Executor API的Task是非常简单和自然的。 由于任务是可运行的，您还可以从另一个后台线程直接调用（通过调用FutureTask.run()方法）。 这允许组合工作，或将其传递给手动构造和执行的新线程。 最后，由于您可以手动创建一个新的线程，传递一个Runnable，可以使用以下成语：

       Thread th = new Thread(task); th.setDaemon(true); th.start();

    请注意，此代码将线程的守护程序标志设置为true。 如果你想要一个后台线程来防止在最后一个阶段关闭之后退出VM，那么你希望守护进程是假的。 但是，如果您希望后台线程在所有阶段关闭后立即终止，那么您必须将守护程序设置为true。

    虽然ExecutorService定义了几个方法，这需要一个Runnable，你通常应该限制自己使用execute从继承的方法Executor 。

    与FutureTask一样，任务是一个单一的类，不能重复使用。 见Service的可重复使用的Worker 。

    由于该任务旨在与JavaFX GUI应用程序一起使用，因此可确保对其公共属性进行的每次更改以及更改状态，错误和事件处理程序的通知都会发生在主要的JavaFX应用程序线程上。 从后台线程（包括call()方法）访问这些属性将导致运行时异常被引发。 唯一的例外是初始配置任务时，可以从任何线程安全地完成。 但是，一旦Task已被初始化和启动，它可能只能在FX线程之外被使用（除了清楚地标记为适合子类从后台线程调用的那些方法之外）。

    强烈建议所有的Tasks都将用Task进行操作的不可变状态进行初始化。 这应该通过提供一个Task构造函数来完成，该构造函数需要执行Task所需的参数。 不变状态使得使用任何线程变得容易和安全，并确保在多个线程的存在下的正确性。

    在Java中没有可靠的方法来“杀死”一个进程中的线程。 但是，当对任务调用cancel时，重要的是任务停止处理。 “任务”任务即使在任务被取消之后也可能继续处理和更新消息，文本和进度属性！ 在Java中，取消任务是一个合作的努力。 任务的用户将要求其被取消，并且任务的作者必须检查是否已经在call方法的主体内被取消。 有两种方法可以完成。 首先，Task作者可以检查isCancelled方法，继承自FutureTask ，看看Task是否被取消。 第二，如果Task实现使用任何阻塞调用（例如NIO InterruptibleChannels或Thread.sleep），并且在这种阻塞调用中任务被取消，则抛出InterruptedException。 具有阻塞调用的任务实现应该认识到，被中断的线程可能是被取消任务的信号，并且应该仔细检查isCancelled方法，以确保由于取消任务而导致InterruptedException异常。

    例子

    以下一组示例演示了Tasks最常用的一些用途。

    一个简单的循环

    第一个例子是一个简单的循环，没有什么特别有用的，但是演示了正确编写任务的基本方面。 该示例将简单地循环并打印到每个循环迭代的标准输出。 当它完成时，它返回它重复的次数。

       Task<Integer> task = new Task<Integer>() { @Override protected Integer call() throws Exception { int iterations; for (iterations = 0; iterations < 100000; iterations++) { if (isCancelled()) { break; } System.out.println("Iteration " + iterations); } return iterations; } };

    首先，我们定义从此任务返回的值的类型。 在这种情况下，我们要返回我们迭代的次数，所以我们将使用泛型指定Task类型为Integer。 然后，在call方法的实现中，我们从0到100000迭代。在每次迭代中，我们检查这个任务是否被取消。 如果已经存在，那么我们就会跳出循环并返回我们迭代的次数。 否则，会将消息打印到控制台，并且迭代计数增加，我们继续循环。

    检查循环体中的isCancelled（）是至关重要的，否则开发者可能会取消任务，但任务将继续运行并更新进度，并从call方法结束返回错误的结果。 任务的正确实施将始终检查取消。

    具有进度通知的简单循环

    与前面的例子相似，除了这一次我们将在每次迭代中修改Task的进度。 请注意，我们可以选择取消订单。 当任务被取消时，是否要将进度设置为-1（不确定），还是要将进度保留在哪里？ 在这种情况下，让我们单独离开进度，只有在取消消息时更新消息，尽管在取消之后更新进度是完全有效的选择。

       Task<Integer> task = new Task<Integer>() { @Override protected Integer call() throws Exception { int iterations; for (iterations = 0; iterations < 10000000; iterations++) { if (isCancelled()) { updateMessage("Cancelled"); break; } updateMessage("Iteration " + iterations); updateProgress(iterations, 10000000); } return iterations; } };

    像以前一样，在for循环中，我们检查Task是否被取消。 如果已被取消，我们将更新该任务的消息，表示已被取消，然后如前所述那样断开。 如果任务尚未被取消，那么我们将更新其消息以指示当前的迭代，然后更新进度以指示当前进度。

    具有进度通知和阻塞呼叫的简单循环

    此示例将前面的示例添加一个阻止调用。 因为阻塞调用可能会引发InterruptedException，并且由于任务被取消的结果可能会发生InterruptedException，所以我们需要确保处理InterruptedException并检查取消状态。

       Task<Integer> task = new Task<Integer>() { @Override protected Integer call() throws Exception { int iterations; for (iterations = 0; iterations < 1000; iterations++) { if (isCancelled()) { updateMessage("Cancelled"); break; } updateMessage("Iteration " + iterations); updateProgress(iterations, 1000); // Now block the thread for a short time, but be sure // to check the interrupted exception for cancellation! try { Thread.sleep(100); } catch (InterruptedException interrupted) { if (isCancelled()) { updateMessage("Cancelled"); break; } } } return iterations; } };

    这里我们加了一个循环的一个Thread.sleep调用。 由于这是一个阻塞调用，我必须处理潜在的InterruptedException。 在catch块内，我将检查Task是否已经被取消，如果是这样，请相应地更新该消息并从循环中跳出。

    获取参数的任务

    大多数任务需要一些参数才能做有用的工作。 例如，DeleteRecordTask需要从数据库中删除的对象或主键。 ReadFileTask需要读取文件的URI。 由于任务在后台线程上运行，因此必须注意确保call方法的正文不会读取或修改任何共享状态。 有两种最有用的技巧：使用最终变量，并在构建过程中将变量传递给任务。

    当使用Task作为匿名类时，将参数传递给Task的最自然的方法是使用最终变量。 在这个例子中，我们传递任务要迭代的总次数。

       final int totalIterations = 9000000; Task<Integer> task = new Task<Integer>() { @Override protected Integer call() throws Exception { int iterations; for (iterations = 0; iterations < totalIterations; iterations++) { if (isCancelled()) { updateMessage("Cancelled"); break; } updateMessage("Iteration " + iterations); updateProgress(iterations, totalIterations); } return iterations; } };

    由于totalIterations是最终的，因此call方法可以安全地读取它，并从后台线程中引用它。

    当写任务库（与特定用途实现相反）时，我们需要使用不同的技术。 在这种情况下，我将创建一个执行与上述相同工作的IteratingTask。 这一次，因为IteratingTask是在自己的文件中定义的，所以它需要在其构造函数中传递参数。 这些参数分配给最终变量。

       public class IteratingTask extends Task<Integer> { private final int totalIterations; public IteratingTask(int totalIterations) { this.totalIterations = totalIterations; } @Override protected Integer call() throws Exception { int iterations = 0; for (iterations = 0; iterations < totalIterations; iterations++) { if (isCancelled()) { updateMessage("Cancelled"); break; } updateMessage("Iteration " + iterations); updateProgress(iterations, totalIterations); } return iterations; } }

    然后使用时：

       IteratingTask task = new IteratingTask(8000000);

    以这种方式，参数以安全的方式传递给IteratingTask，并且再次是final。 因此， call方法可以从后台线程安全地读取此状态。

    警告：不要将可变状态传递给任务，然后从后台线程中进行操作。 这样做可能会引入种族条件。 特别是，假设您有一个SaveCustomerTask，它在其构造函数中占用了一个客户端。 尽管SaveCustomerTask可能对客户有最终的引用，但如果Customer对象是可变的，那么SaveCustomerTask和其他一些应用程序代码可能会从不同的线程读取或修改Customer的状态。 在这种情况下，要非常小心，因为从后台线程使用诸如此客户端的可变对象时，它不会被另一个线程使用。 特别是，如果后台线程从数据库读取数据并更新Customer对象，并且Customer对象绑定到场景图形节点（如UI控件），那么可能会违反线程规则！ 对于这种情况，请从FX应用程序主题而不是后台线程修改Customer对象。

       public class UpdateCustomerTask extends Task<Customer> { private final Customer customer; public UpdateCustomerTask(Customer customer) { this.customer = customer; } @Override protected Customer call() throws Exception { // pseudo-code: // query the database // read the values // Now update the customer Platform.runLater(new Runnable() { @Override public void run() { customer.setFirstName(rs.getString("FirstName")); // etc } }); return customer; } }

    一个没有价值的任务

    许多（如果不是大多数）任务应该在完成后返回一个值。 对于CRUD任务，可以预期“创建”任务将返回新创建的对象或主键，“读取”任务将返回读取对象，“更新”任务将返回更新的记录数，并且“删除“任务将返回删除的记录数。

    但是有时候只是没有任何真正有用的回报。 例如，我可能有一个写入文件的任务。 任务已经内置了一个机制，用于指示它是否成功或失败，以及写入的字节数（进度），因此我没有什么真正的返回。 在这种情况下，您可以使用Void类型。 这是Java语言中的一种特殊类型，只能分配null的值。 你会使用它如下：

       final String filePath = "/foo.txt"; final String contents = "Some contents"; Task<Void> task = new Task<Void>() { @Override protected Void call() throws Exception { File file = new File(filePath); FileOutputStream out = new FileOutputStream(file); // ... and other code to write the contents ... // Return null at the end of a Task of type Void return null; } };

    一个返回一个ObservableList的任务

    因为ListView，TableView和其他UI控件和场景图形节点使用了ObservableList，所以通常要从任务创建并返回一个ObservableList。 当您不关心显示中间值时，正确编写此类任务的最简单方法是在call方法中构造一个ObservableList，然后在任务结束时返回。

       Task<ObservableList<Rectangle>> task = new Task<ObservableList<Rectangle>>() { @Override protected ObservableList<Rectangle> call() throws Exception { updateMessage("Creating Rectangles"); ObservableList<Rectangle> results = FXCollections.observableArrayList(); for (int i=0; i<100; i++) { if (isCancelled()) break; Rectangle r = new Rectangle(10, 10); r.setX(10 * i); results.add(r); updateProgress(i, 100); } return results; } };

    在上面的例子中，我们要创建100个矩形，并从这个任务返回它们。 在call方法中创建一个ObservableList，填充，然后返回。

    返回部分结果的任务

    有时你想创建一个任务将返回部分结果。 也许您正在构建一个复杂的场景图，并希望在构建场景图时显示场景图。 或者您正在通过网络读取大量数据，并希望在数据到达时在TableView中显示条目。 在这种情况下，FX应用程序线程和后台线程都有一些共享状态。 必须非常小心， 永远不要从外汇应用程序主题以外的任何线程更新共享状态 。

    最简单的方法是利用updateValue(Object)方法。 该方法可以从后台线程重复调用。 更新合并以防止FX事件队列的饱和。 这意味着您可以根据需要从后台线程中频繁地调用它，但只能最后设置。

       Task<Long> task = new Task<Long>() { @Override protected Long call() throws Exception { long a = 0; long b = 1; for (long i = 0; i < Long.MAX_VALUE; i++) { updateValue(a); a += b; b = a - b; } return a; } };

    另一种方法是在任务上公开一个新属性，这将表示部分结果。 然后在更新部分结果时确保使用Platform.runLater 。

       Task<Long> task = new Task<Long>() { @Override protected Long call() throws Exception { long a = 0; long b = 1; for (long i = 0; i < Long.MAX_VALUE; i++) { final long v = a; Platform.runLater(new Runnable() { @Override public void run() { updateValue(v); } } a += b; b = a - b; } return a; } };

    假设不是更新单个值，而是要在获取结果时填充一个ObservableList。 一种方法是在任务上公开一个新属性，这将表示部分结果。 然后在部分结果中添加新项目时，请确保使用Platform.runLater 。

       public class PartialResultsTask extends Task<ObservableList<Rectangle>> { // Uses Java 7 diamond operator private ReadOnlyObjectWrapper<ObservableList<Rectangle>> partialResults = new ReadOnlyObjectWrapper<>(this, "partialResults", FXCollections.observableArrayList(new ArrayList<Rectangle>())); public final ObservableList<Rectangle> getPartialResults() { return partialResults.get(); } public final ReadOnlyObjectProperty<ObservableList<Rectangle>> partialResultsProperty() { return partialResults.getReadOnlyProperty(); } @Override protected ObservableList<Rectangle> call() throws Exception { updateMessage("Creating Rectangles..."); for (int i=0; i<100; i++) { if (isCancelled()) break; final Rectangle r = new Rectangle(10, 10); r.setX(10 * i); Platform.runLater(new Runnable() { @Override public void run() { partialResults.get().add(r); } }); updateProgress(i, 100); } return partialResults.get(); } }

    修改场景图的任务

    通常，任务不应该直接与UI交互。 这样做会在特定的Task实现和UI的特定部分之间产生紧密的耦合。 但是，当您想要创建此类耦合时，您必须确保使用Platform.runLater以便在FX应用程序线程上进行场景图形的任何修改。

       final Group group = new Group(); Task<Void> task = new Task<Void>() { @Override protected Void call() throws Exception { for (int i=0; i<100; i++) { if (isCancelled()) break; final Rectangle r = new Rectangle(10, 10); r.setX(10 * i); Platform.runLater(new Runnable() { @Override public void run() { group.getChildren().add(r); } }); } return null; } };

    反应一般状态变化

    有时候，您可能想编写一个任务来更新其进度，消息，文本，或者以某种其他方式对任务发生状态更改时做出反应。 例如，您可能希望在失败，成功，运行或取消状态更改任务上更改状态消息。

       Task<Integer> task = new Task<Integer>() { @Override protected Integer call() throws Exception { int iterations = 0; for (iterations = 0; iterations < 100000; iterations++) { if (isCancelled()) { break; } System.out.println("Iteration " + iterations); } return iterations; } @Override protected void succeeded() { super.succeeded(); updateMessage("Done!"); } @Override protected void cancelled() { super.cancelled(); updateMessage("Cancelled!"); } @Override protected void failed() { super.failed(); updateMessage("Failed!"); } };
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<Throwable> exception
      获取表示发生的任何异常的ReadOnlyObjectProperty。
      ReadOnlyStringProperty message
      获取表示消息的ReadOnlyStringProperty。
      ObjectProperty<EventHandler<WorkerStateEvent>> onCancelled
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onFailed
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onRunning
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onScheduled
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onSucceeded
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ReadOnlyDoubleProperty progress
      获取表示进度的ReadOnlyDoubleProperty。
      ReadOnlyBooleanProperty running
      获取表示Worker正在运行的ReadOnlyBooleanProperty。
      ReadOnlyObjectProperty<Worker.State> state
      获取表示当前状态的ReadOnlyObjectProperty。
      ReadOnlyStringProperty title
      获取表示标题的ReadOnlyStringProperty。
      ReadOnlyDoubleProperty totalWork
      获取ReadOnlyDoubleProperty代表需要完成的最大工作量。
      ReadOnlyObjectProperty<V> value
      获取表示值的ReadOnlyObjectProperty。
      ReadOnlyDoubleProperty workDone
      获取表示当前进度的ReadOnlyDoubleProperty。

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javafx.concurrent.Worker

        Worker.State

    • 构造方法摘要

      构造方法
      Constructor 描述
      Task​()
      创建一个新的任务。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      <T extends Event>
      void             		addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      将事件过滤器注册到此任务。
      <T extends Event>
      void             		addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个任务。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      protected abstract V call​()
      在执行任务时调用，调用方法必须被子类覆盖并实现。
      boolean cancel​()
      终止执行这个工人。
      boolean cancel​(boolean mayInterruptIfRunning)
      尝试取消执行此任务。
      protected void cancelled​()
      每当任务的状态已经转换到CANCELED状态时，调用子类的受保护的便利方法。
      ReadOnlyObjectProperty<Throwable> exceptionProperty​()
      获取表示发生的任何异常的ReadOnlyObjectProperty。
      protected void failed​()
      每当任务的状态已转换到FAILED状态时调用的子类的受保护的便利方法。
      void fireEvent​(Event event)
      触发指定的事件。
      Throwable getException​()
      获取属性异常的值。
      String getMessage​()
      获取属性消息的值。
      EventHandler<WorkerStateEvent> getOnCancelled​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      EventHandler<WorkerStateEvent> getOnFailed​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      EventHandler<WorkerStateEvent> getOnRunning​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      EventHandler<WorkerStateEvent> getOnScheduled​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      EventHandler<WorkerStateEvent> getOnSucceeded​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      double getProgress​()
      获取属性进度的值。
      Worker.State getState​()
      获取属性状态的值。
      String getTitle​()
      获取属性标题的值。
      double getTotalWork​()
      获取属性totalWork的值。
      V getValue​()
      获取属性值的值。
      double getWorkDone​()
      获取属性workDone的值。
      boolean isRunning​()
      获取运行的属性的值。
      ReadOnlyStringProperty messageProperty​()
      获取表示消息的ReadOnlyStringProperty。
      ObjectProperty<EventHandler<WorkerStateEvent>> onCancelledProperty​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onFailedProperty​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onRunningProperty​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onScheduledProperty​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> onSucceededProperty​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ReadOnlyDoubleProperty progressProperty​()
      获取表示进度的ReadOnlyDoubleProperty。
      <T extends Event>
      void             		removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此任务中注销先前注册的事件过滤器。
      <T extends Event>
      void             		removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此任务中注销先前注册的事件处理程序。
      protected void running​()
      每当任务的状态已经转换到RUNNING状态时调用的子类的受保护的便利方法。
      ReadOnlyBooleanProperty runningProperty​()
      获取表示Worker正在运行的ReadOnlyBooleanProperty。
      protected void scheduled​()
      每当任务的状态已经转换到SCHEDULED状态时调用的子类的受保护的便利方法。
      protected <T extends Event>
      void             		setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      void setOnCancelled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      void setOnFailed​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      void setOnRunning​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      void setOnScheduled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      void setOnSucceeded​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ReadOnlyObjectProperty<Worker.State> stateProperty​()
      获取表示当前状态的ReadOnlyObjectProperty。
      protected void succeeded​()
      每当任务的状态已经转换到SUCCEEDED状态时调用的子类的受保护的便利方法。
      ReadOnlyStringProperty titleProperty​()
      获取表示标题的ReadOnlyStringProperty。
      ReadOnlyDoubleProperty totalWorkProperty​()
      获取ReadOnlyDoubleProperty代表需要完成的最大工作量。
      protected void updateMessage​(String message)
      更新 message属性。
      protected void updateProgress​(double workDone, double max)
      更新 workDone ， totalWork ，并 progress性能。
      protected void updateProgress​(long workDone, long max)
      更新 workDone ， totalWork ，并 progress性能。
      protected void updateTitle​(String title)
      更新 title属性。
      protected void updateValue​(V value)
      更新 value属性。
      ReadOnlyObjectProperty<V> valueProperty​()
      获取表示值的ReadOnlyObjectProperty。
      ReadOnlyDoubleProperty workDoneProperty​()
      获取表示当前进度的ReadOnlyDoubleProperty。

      • Methods inherited from class java.util.concurrent.FutureTask

        done, get, get, isCancelled, isDone, run, runAndReset, set, setException

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • state

        public final ReadOnlyObjectProperty<Worker.State> stateProperty
        Specified by:
        stateProperty在接口 Worker<V>
        另请参见：
        getState()

      • onScheduled

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onScheduledProperty
        每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnScheduled() ， setOnScheduled(EventHandler)

      • onRunning

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onRunningProperty
        每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnRunning() ， setOnRunning(EventHandler)

      • onSucceeded

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onSucceededProperty
        每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnSucceeded() ， setOnSucceeded(EventHandler)

      • onCancelled

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onCancelledProperty
        每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnCancelled() ， setOnCancelled(EventHandler)

      • onFailed

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onFailedProperty
        每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnFailed() ， setOnFailed(EventHandler)

      • value

        public final ReadOnlyObjectProperty<V> valueProperty
        Specified by:
        valueProperty在接口 Worker<V>
        另请参见：
        getValue()

      • exception

        public final ReadOnlyObjectProperty<Throwable> exceptionProperty
        Specified by:
        exceptionProperty在接口 Worker<V>
        另请参见：
        getException()

      • workDone

        public final ReadOnlyDoubleProperty workDoneProperty
        Specified by:
        workDoneProperty在接口 Worker<V>
        另请参见：
        getWorkDone()

      • totalWork

        public final ReadOnlyDoubleProperty totalWorkProperty
        Specified by:
        totalWorkProperty在接口 Worker<V>
        另请参见：
        getTotalWork()

      • progress

        public final ReadOnlyDoubleProperty progressProperty
        Specified by:
        progressProperty在接口 Worker<V>
        另请参见：
        getProgress()

      • running

        public final ReadOnlyBooleanProperty runningProperty
        Specified by:
        runningProperty接口 Worker<V>
        另请参见：
        isRunning()

      • message

        public final ReadOnlyStringProperty messageProperty
        Specified by:
        messageProperty在接口 Worker<V>
        另请参见：
        getMessage()

      • title

        public final ReadOnlyStringProperty titleProperty
        Specified by:
        titleProperty在接口 Worker<V>
        另请参见：
        getTitle()

    • 构造方法详细信息

      • Task

        public Task​()
        创建一个新的任务。

    • 方法详细信息

      • call

        protected abstract V call​()
                   throws 异常
        在执行任务时调用，调用方法必须被子类覆盖并实现。 调用方法实际上执行后台线程逻辑。 只能使用该方法中的代码来调用Task的updateProgress，updateMessage，updateValue和updateTitle方法。 与后台线程任务的任何其他交互将导致运行时异常。
        结果
        后台工作的结果，如果有的话。
        异常
        异常 - 在后台操作期间发生的未处理的异常

      • getState

        public final Worker.State getState​()
        获取属性状态的值。
        Specified by:
        getState接口 Worker<V>
        Property description:
        结果
        这个工人的现状

      • stateProperty

        public final ReadOnlyObjectProperty<Worker.State> stateProperty​()
        说明从界面Worker复制
        获取表示当前状态的ReadOnlyObjectProperty。
        Specified by:
        stateProperty在接口 Worker<V>
        另请参见：
        getState()

      • onScheduledProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onScheduledProperty​()
        每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnScheduled() ， setOnScheduled(EventHandler)

      • getOnScheduled

        public final EventHandler<WorkerStateEvent> getOnScheduled​()
        每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
        结果
        onScheduled事件处理程序（如果有的话）
        从以下版本开始：
        JavaFX 2.1

      • setOnScheduled

        public final void setOnScheduled​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
        参数
        value - 事件处理程序可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • scheduled

        protected void scheduled​()
        每当任务的状态已经转换到SCHEDULED状态时调用的子类的受保护的便利方法。 在任务完全转换到新状态之后，FX应用程序线程调用此方法。
        从以下版本开始：
        JavaFX 2.1

      • onRunningProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onRunningProperty​()
        每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnRunning() ， setOnRunning(EventHandler)

      • getOnRunning

        public final EventHandler<WorkerStateEvent> getOnRunning​()
        每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
        结果
        onRunning事件处理程序（如果有的话）
        从以下版本开始：
        JavaFX 2.1

      • setOnRunning

        public final void setOnRunning​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
        参数
        value - 事件处理程序可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • running

        protected void running​()
        每当任务的状态已经转换到RUNNING状态时调用的子类的受保护的便利方法。 在任务完全转换到新状态之后，FX应用程序线程调用此方法。
        从以下版本开始：
        JavaFX 2.1

      • onSucceededProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onSucceededProperty​()
        每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnSucceeded() ， setOnSucceeded(EventHandler)

      • getOnSucceeded

        public final EventHandler<WorkerStateEvent> getOnSucceeded​()
        每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
        结果
        onSucceeded事件处理程序（如果有）
        从以下版本开始：
        JavaFX 2.1

      • setOnSucceeded

        public final void setOnSucceeded​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
        参数
        value - 事件处理程序可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • succeeded

        protected void succeeded​()
        每当任务的状态已经转换到SUCCEEDED状态时调用的子类的受保护的便利方法。 在任务完全转换到新状态之后，FX应用程序线程调用此方法。
        从以下版本开始：
        JavaFX 2.1

      • onCancelledProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onCancelledProperty​()
        每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnCancelled() ， setOnCancelled(EventHandler)

      • getOnCancelled

        public final EventHandler<WorkerStateEvent> getOnCancelled​()
        每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
        结果
        onCancelled事件处理程序（如果有）
        从以下版本开始：
        JavaFX 2.1

      • setOnCancelled

        public final void setOnCancelled​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
        参数
        value - 事件处理程序可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • cancelled

        protected void cancelled​()
        每当任务的状态已经转换到CANCELED状态时，调用子类的受保护的便利方法。 在任务完全转换到新状态之后，FX应用程序线程调用此方法。
        从以下版本开始：
        JavaFX 2.1

      • onFailedProperty

        public final ObjectProperty<EventHandler<WorkerStateEvent>> onFailedProperty​()
        每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnFailed() ， setOnFailed(EventHandler)

      • getOnFailed

        public final EventHandler<WorkerStateEvent> getOnFailed​()
        每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
        结果
        onFailed事件处理程序（如果有）
        从以下版本开始：
        JavaFX 2.1

      • setOnFailed

        public final void setOnFailed​(EventHandler<WorkerStateEvent> value)
        每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
        参数
        value - 事件处理程序可以为空清除它
        从以下版本开始：
        JavaFX 2.1

      • failed

        protected void failed​()
        每当任务的状态已转换到FAILED状态时调用的子类的受保护的便利方法。 在任务完全转换到新状态之后，FX应用程序线程调用此方法。
        从以下版本开始：
        JavaFX 2.1

      • getValue

        public final V getValue​()
        获取属性值的值。
        Specified by:
        getValue在接口 Worker<V>
        Property description:
        结果
        这个工人的当前值

      • valueProperty

        public final ReadOnlyObjectProperty<V> valueProperty​()
        描述从接口Worker复制
        获取表示值的ReadOnlyObjectProperty。
        Specified by:
        valueProperty在接口 Worker<V>
        另请参见：
        getValue()

      • getException

        public final Throwable getException​()
        获取属性异常的值。
        Specified by:
        getException在接口 Worker<V>
        Property description:
        结果
        例外，如果发生

      • exceptionProperty

        public final ReadOnlyObjectProperty<Throwable> exceptionProperty​()
        说明从接口Worker复制
        获取表示发生的任何异常的ReadOnlyObjectProperty。
        Specified by:
        exceptionProperty在接口 Worker<V>
        另请参见：
        getException()

      • getWorkDone

        public final double getWorkDone​()
        获取属性workDone的值。
        Specified by:
        getWorkDone在接口 Worker<V>
        Property description:
        结果
        完成的工作量
        另请参见：
        Worker.totalWorkProperty() ， Worker.progressProperty()

      • workDoneProperty

        public final ReadOnlyDoubleProperty workDoneProperty​()
        描述从接口Worker复制
        获取表示当前进度的ReadOnlyDoubleProperty。
        Specified by:
        workDoneProperty在接口 Worker<V>
        另请参见：
        getWorkDone()

      • getTotalWork

        public final double getTotalWork​()
        获取属性totalWork的值。
        Specified by:
        getTotalWork在接口 Worker<V>
        Property description:
        结果
        要完成的工作
        另请参见：
        Worker.workDoneProperty() ， Worker.progressProperty()

      • totalWorkProperty

        public final ReadOnlyDoubleProperty totalWorkProperty​()
        描述从接口Worker复制
        获取ReadOnlyDoubleProperty代表需要完成的最大工作量。 这些“工作单位”对Worker实现有意义，例如需要下载的字节数或要处理的图像数量或某种其他此类度量。
        Specified by:
        totalWorkProperty在接口 Worker<V>
        另请参见：
        getTotalWork()

      • getProgress

        public final double getProgress​()
        获取属性进度的值。
        Specified by:
        getProgress接口 Worker<V>
        Property description:
        结果
        当前进展
        另请参见：
        Worker.workDoneProperty() ， Worker.totalWorkProperty()

      • progressProperty

        public final ReadOnlyDoubleProperty progressProperty​()
        描述从接口Worker复制
        获取表示进度的ReadOnlyDoubleProperty。
        Specified by:
        progressProperty在接口 Worker<V>
        另请参见：
        getProgress()

      • isRunning

        public final boolean isRunning​()
        获取运行的属性的值。
        Specified by:
        isRunning在接口 Worker<V>
        Property description:
        结果
        如果此Worker正在运行，则为true

      • runningProperty

        public final ReadOnlyBooleanProperty runningProperty​()
        说明从接口Worker复制
        获取表示Worker正在运行的ReadOnlyBooleanProperty。
        Specified by:
        runningProperty在接口 Worker<V>
        另请参见：
        isRunning()

      • getMessage

        public final String getMessage​()
        获取属性消息的值。
        Specified by:
        getMessage接口 Worker<V>
        Property description:
        结果
        当前的消息

      • messageProperty

        public final ReadOnlyStringProperty messageProperty​()
        说明从接口Worker复制
        获取表示消息的ReadOnlyStringProperty。
        Specified by:
        messageProperty在接口 Worker<V>
        另请参见：
        getMessage()

      • getTitle

        public final String getTitle​()
        获取属性标题的值。
        Specified by:
        getTitle在接口 Worker<V>
        Property description:
        结果
        当前标题

      • titleProperty

        public final ReadOnlyStringProperty titleProperty​()
        说明从接口Worker复制
        获取表示标题的ReadOnlyStringProperty。
        Specified by:
        titleProperty在接口 Worker<V>
        另请参见：
        getTitle()

      • cancel

        public final boolean cancel​()
        描述从接口Worker复制
        终止执行这个工人。 调用此方法将从执行队列中删除此Worker或停止执行。
        Specified by:
        cancel在接口 Worker<V>
        结果
        如果取消成功，则返回true

      • cancel

        public boolean cancel​(boolean mayInterruptIfRunning)
        说明从接口Future复制
        尝试取消执行此任务。 如果任务已经完成，已经被取消或由于某种其他原因而无法取消，则此尝试将失败。 如果成功，并且当cancel时此任务尚未启动，则此任务不应运行。 如果任务已经开始，那么mayInterruptIfRunning参数确定执行此任务的线程是否应该中断以试图停止任务。

        此方法返回后，对Future.isDone()的后续调用将始终返回true 。 对后续调用Future.isCancelled()总是返回true如果此方法返回true 。

        Specified by:
        cancel在接口 Future<V>
        重写：
        cancel在 FutureTask<V>
        参数
        mayInterruptIfRunning - true如果执行该任务的线程应该被中断; 否则，正在进行的任务被允许完成
        结果
        false如果任务无法取消，通常是因为它已经正常完成; 否则为true

      • updateProgress

        protected void updateProgress​(long workDone,
                              long max)
        更新workDone ， totalWork ，并progress性能。 对updateProgress的调用在FX应用程序线程上合并并运行，即使从FX应用程序线程调用updateProgress也不一定会立即更新这些属性，并且可以将中间的workDone值合并以保存事件通知。 max成为新的价值totalWork 。

        这种方法可以安全地从任何线程调用。

        参数
        workDone - 从Long.MIN_VALUE到最大值的值 如果该值大于max，则将被钳位在最大值。 如果传递的值为负值，则所得到的完成百分比将为-1（因此，不确定）。
        max - 从Long.MIN_VALUE到Long.MAX_VALUE的值。
        另请参见：
        updateProgress(double, double)

      • updateProgress

        protected void updateProgress​(double workDone,
                              double max)
        更新workDone ， totalWork ，并progress性能。 对updateProgress的调用在FX应用程序线程上合并并运行，即使从FX应用程序线程调用updateProgress也不一定会立即更新这些属性，并且可以将中间的workDone值合并以保存事件通知。 max成为新的价值totalWork 。

        这种方法可以安全地从任何线程调用。

        参数
        workDone - 从Double.MIN_VALUE到最大值的值 如果该值大于max，则将被钳位在最大值。 如果传递的值为负数，则为无穷大或NaN，则所得到的percentDone将为-1（因此，不确定）。
        max - 从Double.MIN_VALUE到Double.MAX_VALUE的值。 无穷大和NaN处理为-1。
        从以下版本开始：
        JavaFX 2.2

      • updateMessage

        protected void updateMessage​(String message)
        更新message属性。 对updateMessage的调用在FX应用程序线程上合并并运行，因此甚至从FX应用程序线程调用updateMessage可能不一定会立即更新此属性，并且可以将中间消息值合并以保存事件通知。

        这种方法可以安全地从任何线程调用。

        参数
        message - 新消息

      • updateTitle

        protected void updateTitle​(String title)
        更新title属性。 对updateTitle的调用在FX应用程序线程上合并并运行，因此甚至从FX应用程序线程调用updateTitle可能不一定会立即更新此属性，并且中间标题值可能会合并以保存事件通知。

        这种方法可以安全地从任何线程调用。

        参数
        title - 新标题

      • updateValue

        protected void updateValue​(V value)
        更新value属性。 对updateValue的调用在FX应用程序线程上合并并运行，因此甚至从FX应用程序线程调用updateValue可能不一定会立即更新此属性，并且可以将中间值合并以保存事件通知。

        这种方法可以安全地从任何线程调用。

        参数
        value - 新值
        从以下版本开始：
        JavaFX 8.0

      • addEventHandler

        public final <T extends Event> void addEventHandler​(EventType<T> eventType,
                                                    EventHandler<? super T> eventHandler)
        注册一个事件处理程序到这个任务。 首先处理任何事件过滤器，然后处理指定的onFoo事件处理程序，最后处理通过此方法注册的任何事件处理程序。 与场景图中的其他事件一样，如果事件被消耗，则不会继续调度。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 由处理程序接收的事件的类型
        eventHandler - 要注册的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空
        从以下版本开始：
        JavaFX 2.1

      • removeEventHandler

        public final <T extends Event> void removeEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        从此任务中注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空
        从以下版本开始：
        JavaFX 2.1

      • addEventFilter

        public final <T extends Event> void addEventFilter​(EventType<T> eventType,
                                                   EventHandler<? super T> eventFilter)
        将事件过滤器注册到此任务。 注册事件过滤器在任何关联的事件处理程序之前获取事件。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 过滤器接收的事件的类型
        eventFilter - 要注册的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空
        从以下版本开始：
        JavaFX 2.1

      • removeEventFilter

        public final <T extends Event> void removeEventFilter​(EventType<T> eventType,
                                                      EventHandler<? super T> eventFilter)
        从此任务中注销先前注册的事件过滤器。 一个过滤器可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销过滤器。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 要注销的事件类型
        eventFilter - 要注销的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空
        从以下版本开始：
        JavaFX 2.1

      • setEventHandler

        protected final <T extends Event> void setEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        设置要用于此事件类型的处理程序。 一次只能有一个这样的处理程序。 这个处理程序被保证被首先调用。 这用于注册用户定义的onFoo事件处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 与给定eventHandler关联的事件类型
        eventHandler - 要注册的处理程序，或者取消注册为null
        异常
        NullPointerException - 如果事件类型为空
        从以下版本开始：
        JavaFX 2.1

      • fireEvent

        public final void fireEvent​(Event event)
        触发指定的事件。 遇到的任何事件过滤器将被通知并可以使用该事件。 如果没有被过滤器使用，则会通知此任务上的事件处理程序。 如果这些也不消耗事件，那么所有事件处理程序都被调用，并且可以使用该事件。

        必须在FX用户线程上调用此方法。

        参数
        event - 事件发生
        从以下版本开始：
        JavaFX 2.1

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        描述从接口EventTarget复制
        为此目标构建事件调度链。 事件调度链包含可能对处理针对EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要为链接添加一个EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 建立起来的初始链
        结果
        此目标的结果事件调度链
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.concurrent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.concurrent

  • Packages that use javafx.concurrent
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
  • Classes in javafx.concurrent used by javafx.concurrent
    Class 描述
    ScheduledService
    ScheduledService是一个Service ，它将在成功执行后自动重新启动，并且在某些情况下即使发生故障也将重新启动。
    Service
    服务是一个非可视化组件，封装了在一个或多个后台线程上执行某些工作所需的信息。
    Task
    一个完全可观察到的一个FutureTask的实现。
    Worker
    工作者是在一个或多个后台线程中执行某些工作的对象，其状态是可观察的并且可用于JavaFX应用程序，并且可从主JavaFX应用程序线程中使用。
    Worker.State
    工人的状态。
    WorkerStateEvent
    当一个工人状态发生变化时发生的事件。
  • Classes in javafx.concurrent used by javafx.scene.web
    Class 描述
    Worker
    工作者是在一个或多个后台线程中执行某些工作的对象，其状态是可观察的并且可用于JavaFX应用程序，并且可从主JavaFX应用程序线程中使用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Worker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.concurrent

Interface Worker<V>

  • 所有已知实现类：
    ScheduledService ， Service ， Task

    public interface Worker<V>

    工作者是在一个或多个后台线程中执行某些工作的对象，其状态是可观察的并且可用于JavaFX应用程序，并且可从主JavaFX应用程序线程中使用。 该接口主要由Task和Service实现 ，在两个类之间提供通用API，这使得库和框架更容易地为开发用户界面时工作良好的工作人员提供便利。

    根据实施情况，工人可能会也可能不会重复使用。 A Task ，例如，在Service是不可重用的。

    工人有一个明确的生命周期。 每个工人都从Worker.State.READY开始。 当工作人员被安排工作时（例如，当一个服务的Service.start()方法被调用时），它被转换为Worker.State.SCHEDULED 。 即使没有技术安排但是立即启动的工人（如FutureTask.run() ）也将通过Worker.State.SCHEDULED转到Worker.State.RUNNING状态。

    当工作人员正在进行工作时，国家将转为Worker.State.RUNNING 。 如果工作人员正常完成，则将以Worker.State.SUCCEEDED状态结束，并将Worker的结果设置为value属性。 然而，如果在执行Worker时出现异常，那么状态将被设置为Worker.State.FAILED ，而exception属性将被设置为发生的异常。

    在工人结束之前的任何时间（即，如果状态尚不是Worker.State.SUCCEEDED或Worker.State.FAILED ），开发人员可能会调用cancel()方法。 如果被调用，工作者将停止执行（如果可能，包括使用Thread.interrupt），状态更改为Worker.State.CANCELLED 。

    对于工人的唯一有效开始状态是Worker.State.READY ，以及有效的结束状态是Worker.State.CANCELLED ， Worker.State.SUCCEEDED ，并Worker.State.FAILED 。 当状态为Worker.State.SCHEDULED或Worker.State.RUNNING时， running属性设置为true。

    工人的进程可以通过三种不同的特性，被监测totalWork ， workDone ，并progress 。 这些属性由Worker接口的实际实现设置，但是可以被任何人观察到。 workDone是-1（意思是不确定进度）和totalWork （含）之间的数字。 当workDone == totalWork progress将为100％（或1）。 totalWork将是-1和Long.MAX_VALUE之间的数字，包括。 进度将是-1（意思是不确定），或0到1之间的值，包括0到100％。

    在Worker.State.READY或Worker.State.SCHEDULED状态的工作人员将始终有workDone和progress设置为-1。 处于Worker.State.SUCCEEDED状态的工作人员将始终有workDone == totalWork和progress == 1 。 在任何其他状态下，这些属性的值可以是其各自有效范围内的任何值。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<Throwable> exception
      获取表示发生的任何异常的ReadOnlyObjectProperty。
      ReadOnlyStringProperty message
      获取表示消息的ReadOnlyStringProperty。
      ReadOnlyDoubleProperty progress
      获取表示进度的ReadOnlyDoubleProperty。
      ReadOnlyBooleanProperty running
      获取表示Worker正在运行的ReadOnlyBooleanProperty。
      ReadOnlyObjectProperty<Worker.State> state
      获取表示当前状态的ReadOnlyObjectProperty。
      ReadOnlyStringProperty title
      获取表示标题的ReadOnlyStringProperty。
      ReadOnlyDoubleProperty totalWork
      获取ReadOnlyDoubleProperty代表需要完成的最大工作量。
      ReadOnlyObjectProperty<V> value
      获取表示值的ReadOnlyObjectProperty。
      ReadOnlyDoubleProperty workDone
      获取表示当前进度的ReadOnlyDoubleProperty。

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  Worker.State
      工人的状态。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean cancel​()
      终止执行这个工人。
      ReadOnlyObjectProperty<Throwable> exceptionProperty​()
      获取表示发生的任何异常的ReadOnlyObjectProperty。
      Throwable getException​()
      表示工人运行时发生的异常（如果有）。
      String getMessage​()
      获取与此Worker的当前状态相关联的消息。
      double getProgress​()
      表示该工作人员目前在完成百分比方面的进度。
      Worker.State getState​()
      指定此Worker的当前状态。
      String getTitle​()
      应该与此Worker关联的可选标题。
      double getTotalWork​()
      表示 workDoneProperty()属性的最大值。
      V getValue​()
      指定此Worker的值或结果。
      double getWorkDone​()
      表示已完成的当前工作量。
      boolean isRunning​()
      如果状态为SCHEDULED或RUNNING，则为真。
      ReadOnlyStringProperty messageProperty​()
      获取表示消息的ReadOnlyStringProperty。
      ReadOnlyDoubleProperty progressProperty​()
      获取表示进度的ReadOnlyDoubleProperty。
      ReadOnlyBooleanProperty runningProperty​()
      获取表示Worker正在运行的ReadOnlyBooleanProperty。
      ReadOnlyObjectProperty<Worker.State> stateProperty​()
      获取表示当前状态的ReadOnlyObjectProperty。
      ReadOnlyStringProperty titleProperty​()
      获取表示标题的ReadOnlyStringProperty。
      ReadOnlyDoubleProperty totalWorkProperty​()
      获取ReadOnlyDoubleProperty代表需要完成的最大工作量。
      ReadOnlyObjectProperty<V> valueProperty​()
      获取表示值的ReadOnlyObjectProperty。
      ReadOnlyDoubleProperty workDoneProperty​()
      获取表示当前进度的ReadOnlyDoubleProperty。

    • Property Detail

      • state

        ReadOnlyObjectProperty<Worker.State> stateProperty
        获取表示当前状态的ReadOnlyObjectProperty。
        另请参见：
        getState()

      • value

        ReadOnlyObjectProperty<V> valueProperty
        获取表示值的ReadOnlyObjectProperty。
        另请参见：
        getValue()

      • exception

        ReadOnlyObjectProperty<Throwable> exceptionProperty
        获取表示发生的任何异常的ReadOnlyObjectProperty。
        另请参见：
        getException()

      • workDone

        ReadOnlyDoubleProperty workDoneProperty
        获取表示当前进度的ReadOnlyDoubleProperty。
        另请参见：
        getWorkDone()

      • totalWork

        ReadOnlyDoubleProperty totalWorkProperty
        获取ReadOnlyDoubleProperty代表需要完成的最大工作量。 这些“工作单位”对Worker实现有意义，例如需要下载的字节数或要处理的图像数量或某种其他此类度量。
        另请参见：
        getTotalWork()

      • progress

        ReadOnlyDoubleProperty progressProperty
        获取表示进度的ReadOnlyDoubleProperty。
        另请参见：
        getProgress()

      • running

        ReadOnlyBooleanProperty runningProperty
        获取表示Worker正在运行的ReadOnlyBooleanProperty。
        另请参见：
        isRunning()

      • message

        ReadOnlyStringProperty messageProperty
        获取表示消息的ReadOnlyStringProperty。
        另请参见：
        getMessage()

      • title

        ReadOnlyStringProperty titleProperty
        获取表示标题的ReadOnlyStringProperty。
        另请参见：
        getTitle()

    • 方法详细信息

      • getState

        Worker.State getState​()
        指定此Worker的当前状态。 初始值为State.READY。 任务可能会重新启动，在这种情况下，它将从其中一个终止状态（SUCCEEDED，CANCELED或FAILED）进入READY状态，然后立即进入SCHEDULED并运行。 这些状态转换可能会一个接一个地发生，但将始终以规定的顺序发生。
        结果
        这个工人的现状

      • stateProperty

        ReadOnlyObjectProperty<Worker.State> stateProperty​()
        获取表示当前状态的ReadOnlyObjectProperty。
        另请参见：
        getState()

      • getValue

        V getValue​()
        指定此Worker的值或结果。 这是在进入SUCCEEDED状态后设置的，并且如果Worker被重新初始化（即，如果Worker是可重用的Worker并被重置或重新启动），则清除（设置为null）。
        结果
        这个工人的当前值

      • valueProperty

        ReadOnlyObjectProperty<V> valueProperty​()
        获取表示值的ReadOnlyObjectProperty。
        另请参见：
        getValue()

      • getException

        Throwable getException​()
        表示工人运行时发生的异常（如果有）。 如果此属性值为null ，即使状态为FAILED，也没有已知的异常。 如果此属性不是null ，它很可能包含描述失败原因的异常。
        结果
        例外，如果发生

      • exceptionProperty

        ReadOnlyObjectProperty<Throwable> exceptionProperty​()
        获取表示发生的任何异常的ReadOnlyObjectProperty。
        另请参见：
        getException()

      • getWorkDone

        double getWorkDone​()
        表示已完成的当前工作量。 零或正值表示要完成的进度。 此变量值可能或可能不会从其默认值更改，具体取决于具体的Worker实现。 值-1表示当前完成的工作量无法确定（即：不确定）。 该属性的值始终小于或等于totalWork。
        结果
        完成的工作量
        另请参见：
        totalWorkProperty() ， progressProperty()

      • workDoneProperty

        ReadOnlyDoubleProperty workDoneProperty​()
        获取表示当前进度的ReadOnlyDoubleProperty。
        另请参见：
        getWorkDone()

      • getTotalWork

        double getTotalWork​()
        表示workDoneProperty()属性的最大值。 totalWork将为-1（表示要做的工作量是不确定的），或者它将是小于或等于Double.MAX_VALUE的非零值。
        结果
        要完成的工作
        另请参见：
        workDoneProperty() ， progressProperty()

      • totalWorkProperty

        ReadOnlyDoubleProperty totalWorkProperty​()
        获取ReadOnlyDoubleProperty代表需要完成的最大工作量。 这些“工作单位”对Worker实现有意义，例如需要下载的字节数或要处理的图像数量或某种其他此类度量。
        另请参见：
        getTotalWork()

      • getProgress

        double getProgress​()
        表示该工作人员目前在完成百分比方面的进度。 0到1之间的值表示要完成的进度。 值-1表示当前进度无法确定（即不确定）。 此属性的默认值为-1，取决于具体的Worker实现。
        结果
        当前进展
        另请参见：
        workDoneProperty() ， totalWorkProperty()

      • progressProperty

        ReadOnlyDoubleProperty progressProperty​()
        获取表示进度的ReadOnlyDoubleProperty。
        另请参见：
        getProgress()

      • isRunning

        boolean isRunning​()
        如果状态为SCHEDULED或RUNNING，则为真。 当将Worker绑定到一个ProgressIndicator时 ，通常会将ProgressIndicator的可见性绑定到Worker的running属性，并将ProgressIndicator的进度绑定到Worker的progress属性。
        结果
        如果此Worker正在运行，则为true

      • runningProperty

        ReadOnlyBooleanProperty runningProperty​()
        获取表示Worker正在运行的ReadOnlyBooleanProperty。
        另请参见：
        isRunning()

      • getMessage

        String getMessage​()
        获取与此Worker的当前状态相关联的消息。 这可能是例如“处理3的图像”之类的东西。
        结果
        当前的消息

      • messageProperty

        ReadOnlyStringProperty messageProperty​()
        获取表示消息的ReadOnlyStringProperty。
        另请参见：
        getMessage()

      • getTitle

        String getTitle​()
        应该与此Worker关联的可选标题。 这可能是“修改图像”。
        结果
        当前标题

      • titleProperty

        ReadOnlyStringProperty titleProperty​()
        获取表示标题的ReadOnlyStringProperty。
        另请参见：
        getTitle()

      • cancel

        boolean cancel​()
        终止执行这个工人。 调用此方法将从执行队列中删除此Worker或停止执行。
        结果
        returns true if the cancel was successful
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Worker.State (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.concurrent

Enum Worker.State

  • java.lang.Object
    • java.lang.Enum<Worker.State>
      • javafx.concurrent.Worker.State
  • All Implemented Interfaces:
    Serializable ， Comparable<Worker.State>
    Enclosing interface:
    Worker < V >

    public static enum Worker.State
extends Enum<Worker.State>

    工人的状态。 工人的状态转换定义非常明确。 所有工人都处于就绪状态。 在某些情况下，在实际执行之前，工作人员可能被安排执行。 在这种情况下，有时有用的是知道工作人员什么时候与运行时间分开计划。 然而，即使在立即执行“工作”的情况下，在进入运行状态之前，“工作人员”将暂时进入“调度”状态。 也就是说，过渡总是从READY到SCHEDULED到RUNNING（除非工人被取消）。

    运行但未被取消的工人只能在两个状态中的一个状态中完成，即成功或失败。 如果在执行Worker时抛出异常，它只会进入FAILED。 工作人员可以在READY，SCHEDULED或RUNNING时被取消，在这种情况下，最终状态将被取消。 当工人在其中一个情况下被取消时，它将立即转换到已取消状态。

    一个可重用的工作者将从CANCELED，SUCCEEDED或FAILED转换回READY。 从那时起，再次遵循正常状态转换。

    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CANCELLED
      表示此工人已通过 Worker.cancel()方法取消。
      FAILED
      表示此工作人员失败，通常是由于某些意外情况发生。
      READY
      表示Worker尚未被执行并准备执行，或者已被重新初始化。
      RUNNING
      表示此Worker正在运行。
      SCHEDULED
      表示工作人员已被安排执行，但它当前没有运行。
      SUCCEEDED
      表示此Worker已成功完成，并且有一个有效的结果准备从 value属性读取。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Worker.State valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Worker.State[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • READY

        public static final Worker.State READY
        表示Worker尚未被执行并准备执行，或者已被重新初始化。 这是Worker的默认初始状态。

      • SCHEDULED

        public static final Worker.State SCHEDULED
        表示工作人员已被安排执行，但它当前没有运行。 这可能是因为Worker在等待线程池中的线程才能开始运行。

      • RUNNING

        public static final Worker.State RUNNING
        表示此Worker正在运行。 这是刚刚在工人实际上做了第一工作之前。

      • SUCCEEDED

        public static final Worker.State SUCCEEDED
        表示此Worker已成功完成，并且有一个有效的结果准备从 value属性读取。

      • CANCELLED

        public static final Worker.State CANCELLED
        表示此工人已通过 Worker.cancel()方法取消。

      • FAILED

        public static final Worker.State FAILED
        表示此工作人员失败，通常是由于某些意外情况发生。 可以从exception属性中检索异常。

    • 方法详细信息

      • values

        public static Worker.State[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Worker.State c : Worker.State.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Worker.State valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


WorkerStateEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.concurrent

Class WorkerStateEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.concurrent.WorkerStateEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class WorkerStateEvent
extends Event
    当一个工人状态发生变化时发生的事件。 Task和Service都支持监听状态事件。
    从以下版本开始：
    JavaFX 2.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<WorkerStateEvent> ANY
      所有工作状态事件类型的常用超类型。
      static EventType<WorkerStateEvent> WORKER_STATE_CANCELLED
      当Worker实现的状态转换到CANCELED状态时，会发生此事件。
      static EventType<WorkerStateEvent> WORKER_STATE_FAILED
      当Worker实现的状态已转换到FAILED状态时，会发生此事件。
      static EventType<WorkerStateEvent> WORKER_STATE_READY
      当Worker实现的状态已转换到READY状态时，会发生此事件。
      static EventType<WorkerStateEvent> WORKER_STATE_RUNNING
      当Worker实现的状态已转换到RUNNING状态时，会发生此事件。
      static EventType<WorkerStateEvent> WORKER_STATE_SCHEDULED
      当Worker实现的状态已转换到SCHEDULED状态时，会发生此事件。
      static EventType<WorkerStateEvent> WORKER_STATE_SUCCEEDED
      当Worker实现的状态已转换到SUCCEEDED状态时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      WorkerStateEvent​(Worker worker, EventType<? extends WorkerStateEvent> eventType)
      创建一个新的WorkerStateEvent。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Worker getSource​()
      事件最初发生的工人。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<WorkerStateEvent> ANY
        所有工作状态事件类型的常用超类型。

      • WORKER_STATE_READY

        public static final EventType<WorkerStateEvent> WORKER_STATE_READY
        当Worker实现的状态已转换到READY状态时，会发生此事件。

      • WORKER_STATE_SCHEDULED

        public static final EventType<WorkerStateEvent> WORKER_STATE_SCHEDULED
        当Worker实现的状态已转换到SCHEDULED状态时，会发生此事件。

      • WORKER_STATE_RUNNING

        public static final EventType<WorkerStateEvent> WORKER_STATE_RUNNING
        当Worker实现的状态已转换到RUNNING状态时，会发生此事件。

      • WORKER_STATE_SUCCEEDED

        public static final EventType<WorkerStateEvent> WORKER_STATE_SUCCEEDED
        当Worker实现的状态已转换到SUCCEEDED状态时，会发生此事件。

      • WORKER_STATE_CANCELLED

        public static final EventType<WorkerStateEvent> WORKER_STATE_CANCELLED
        当Worker实现的状态转换到CANCELED状态时，会发生此事件。

      • WORKER_STATE_FAILED

        public static final EventType<WorkerStateEvent> WORKER_STATE_FAILED
        当Worker实现的状态已转换到FAILED状态时，会发生此事件。

    • 构造方法详细信息

      • WorkerStateEvent

        public WorkerStateEvent​(Worker worker,
                        EventType<? extends WorkerStateEvent> eventType)
        创建一个新的WorkerStateEvent。 指定工作人员和事件类型。
        参数
        worker - 正在触发事件的工人。 工人真的应该是一个EventTarget，否则事件的EventTarget将为null。
        eventType - 事件的类型。 这不应该为空。

    • 方法详细信息

      • getSource

        public Worker getSource​()
        事件最初发生的工人。
        重写：
        getSource在 EventObject
        结果
        事件最初发生的工人。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Class javafx.concurrent.ScheduledService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.concurrent.ScheduledService

  • Packages that use ScheduledService
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。

    • Uses of ScheduledService in javafx.concurrent

      Fields in javafx.concurrent with type parameters of type ScheduledService
      Modifier and Type Field 描述
      static Callback<ScheduledService<?>,Duration> ScheduledService.EXPONENTIAL_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况下以指数方式 backoffStrategy重新执行之间的时间段。
      static Callback<ScheduledService<?>,Duration> ScheduledService.LINEAR_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况 backoffStrategy性地回退重新执行之间的时间段。
      static Callback<ScheduledService<?>,Duration> ScheduledService.LOGARITHMIC_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况下对数地退避重新执行之间的时间间隔。
      Methods in javafx.concurrent that return types with arguments of type ScheduledService
      Modifier and Type 方法 描述
      ObjectProperty<Callback<ScheduledService<?>,Duration>> ScheduledService.backoffStrategyProperty​()
      计算在每次故障时添加到期间的时间量。
      Callback<ScheduledService<?>,Duration> ScheduledService.getBackoffStrategy​()
      获取属性backoffStrategy的值。
      Method parameters in javafx.concurrent with type arguments of type ScheduledService
      Modifier and Type 方法 描述
      void ScheduledService.setBackoffStrategy​(Callback<ScheduledService<?>,Duration> value)
      Sets the value of the property backoffStrategy.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.concurrent.Service (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.concurrent.Service

  • Packages that use Service
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。

    • Uses of Service in javafx.concurrent

      Subclasses of Service in javafx.concurrent
      Modifier and Type Class 描述
      class  ScheduledService<V>
      ScheduledService是一个Service ，它将在成功执行后自动重新启动，并且在某些情况下即使发生故障也将重新启动。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.concurrent.Task (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.concurrent.Task

  • Packages that use Task
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。

    • Uses of Task in javafx.concurrent

      Methods in javafx.concurrent that return Task
      Modifier and Type 方法 描述
      protected abstract Task<V> Service.createTask​()
      在JavaFX应用程序主题上启动服务后调用。
      Methods in javafx.concurrent with parameters of type Task
      Modifier and Type | 方法 | 描述
      protected void | ScheduledService.executeTask​(Task<V> task)
      protected void Service.executeTask​(Task<V> task)
      使用此服务上定义的 executor执行给定的任务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.concurrent.Worker.State (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.concurrent.Worker.State

  • Packages that use Worker.State
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。

    • Uses of Worker.State in javafx.concurrent

      Methods in javafx.concurrent that return Worker.State
      Modifier and Type 方法 描述
      Worker.State Service.getState​()
      获取属性状态的值。
      Worker.State Task.getState​()
      获取属性状态的值。
      Worker.State Worker.getState​()
      指定此Worker的当前状态。
      static Worker.State Worker.State.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Worker.State[] Worker.State.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.concurrent that return types with arguments of type Worker.State
      Modifier and Type | 方法 | 描述
      ReadOnlyObjectProperty<Worker.State> | Service.stateProperty​()
      ReadOnlyObjectProperty<Worker.State> | Task.stateProperty​()
      ReadOnlyObjectProperty<Worker.State> Worker.stateProperty​()
      Gets the ReadOnlyObjectProperty representing the current state.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.concurrent.WorkerStateEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.concurrent.WorkerStateEvent

  • Packages that use WorkerStateEvent
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。

    • Uses of WorkerStateEvent in javafx.concurrent

      Fields in javafx.concurrent with type parameters of type WorkerStateEvent
      Modifier and Type Field 描述
      static EventType<WorkerStateEvent> WorkerStateEvent.ANY
      所有工作状态事件类型的常用超类型。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_CANCELLED
      当Worker实现的状态转换到CANCELED状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_FAILED
      当Worker实现的状态已转换到FAILED状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_READY
      当Worker实现的状态已转换到READY状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_RUNNING
      当Worker实现的状态已转换到RUNNING状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_SCHEDULED
      当Worker实现的状态已转换到SCHEDULED状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_SUCCEEDED
      当Worker实现的状态已转换到SUCCEEDED状态时，会发生此事件。
      Methods in javafx.concurrent that return types with arguments of type WorkerStateEvent
      Modifier and Type 方法 描述
      EventHandler<WorkerStateEvent> Service.getOnCancelled​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnCancelled​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnFailed​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnFailed​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnReady​()
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnRunning​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnRunning​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnScheduled​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnScheduled​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnSucceeded​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnSucceeded​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onCancelledProperty​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onCancelledProperty​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onFailedProperty​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onFailedProperty​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onReadyProperty​()
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onRunningProperty​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onRunningProperty​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onScheduledProperty​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onScheduledProperty​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onSucceededProperty​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onSucceededProperty​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      Method parameters in javafx.concurrent with type arguments of type WorkerStateEvent
      Modifier and Type 方法 描述
      void Service.setOnCancelled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      void Task.setOnCancelled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      void Service.setOnFailed​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      void Task.setOnFailed​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      void Service.setOnReady​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      void Service.setOnRunning​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      void Task.setOnRunning​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      void Service.setOnScheduled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      void Task.setOnScheduled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      void Service.setOnSucceeded​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      void Task.setOnSucceeded​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      Constructor parameters in javafx.concurrent with type arguments of type WorkerStateEvent
      Constructor 描述
      WorkerStateEvent​(Worker worker, EventType<? extends WorkerStateEvent> eventType)
      创建一个新的WorkerStateEvent。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.concurrent.Worker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.concurrent.Worker

  • Packages that use Worker
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of Worker in javafx.concurrent

      Classes in javafx.concurrent that implement Worker
      Modifier and Type Class 描述
      class  ScheduledService<V>
      ScheduledService是一个Service ，它将在成功执行后自动重新启动，并且在某些情况下即使发生故障也将重新启动。
      class  Service<V>
      服务是一个非可视化组件，封装了在一个或多个后台线程上执行某些工作所需的信息。
      class  Task<V>
      一个完全可观察到的一个FutureTask的实现。
      Methods in javafx.concurrent that return Worker
      Modifier and Type 方法 描述
      Worker WorkerStateEvent.getSource​()
      事件最初发生的工人。
      Constructors in javafx.concurrent with parameters of type Worker
      Constructor 描述
      WorkerStateEvent​(Worker worker, EventType<? extends WorkerStateEvent> eventType)
      创建一个新的WorkerStateEvent。

    • Uses of Worker in javafx.scene.web

      Methods in javafx.scene.web that return Worker
      Modifier and Type 方法 描述
      Worker<Void> WebEngine.getLoadWorker​()
      返回可用于跟踪加载进度的Worker对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


CompoundSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class CompoundSelector

  • java.lang.Object
    • javafx.css.Selector
      • javafx.css.CompoundSelector

  • public final class CompoundSelector
extends Selector
    根据CSS标准行事的复合选择器。 选择器是由一个或一个以上的Selectors ，与阵列沿着CompoundSelectorRelationships指示在每个阶段所需要的关系。 一定要少于Combinator比选择器少。

    例如，当所有以下条件成立时，参数[selector1, selector2, selector3]和[Combinator.CHILD, Combinator.DESCENDANT]将匹配组件：

    1. 组件本身与selector3匹配
    2. 该组件具有与selector2匹配的祖先
    3. 在步骤2匹配的祖先是由selector1匹配的组件的直接CHILD
    换句话说，上面指定的复合选择器是（在CSS语法中） selector1 > selector2 selector3 。 selector1和selector2之间的大于（>）指定一个直接CHILD，而selector2和selector3之间的空格对应于Combinator.DESCENDANT 。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      boolean | applies​(Styleable styleable)
      boolean | applies​(Styleable styleable, Set<PseudoClass>[] triggerStates, int depth)
      Match createMatch​()
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      List<SimpleSelector> getSelectors​()
      组合此复合选择器的选择器
      int hashCode​()
      返回对象的哈希码值。
      boolean stateMatches​(Styleable styleable, Set<PseudoClass> states)
      确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。
      String toString​()
      返回对象的字符串表示形式。
      protected void | writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.Selector

        createSelector, getOrdinal, getRule, setOrdinal

    • 方法详细信息

      • getSelectors

        public List<SimpleSelector> getSelectors​()
        组合此复合选择器的选择器
        结果
        不可变列表<SimpleSelector>

      • createMatch

        public Match createMatch​()
        Specified by:
        createMatch在 Selector

      • applies

        public boolean applies​(Styleable styleable)
        Specified by:
        applies在 Selector

      • applies

        public boolean applies​(Styleable styleable,
                       Set<PseudoClass>[] triggerStates,
                       int depth)
        Specified by:
        applies在 Selector

      • stateMatches

        public boolean stateMatches​(Styleable styleable,
                            Set<PseudoClass> states)
        描述从类复制： Selector
        确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。
        Specified by:
        stateMatches在 Selector
        参数
        styleable - 风格
        states - 状态
        结果
        true如果节点及其父节点的当前状态与此选择器定义的伪类匹配（如果有）

      • hashCode

        public int hashCode​()
        说明从类别复制Object
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 只要在执行Java应用程序时多次在同一个对象上调用该方法，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        描述从类复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        描述从类： Object复制
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • writeBinary

        protected final void writeBinary​(DataOutputStream os,
                                 StyleConverter.StringStore stringStore)
                          throws IOException
        重写：
        writeBinary在 Selector
        异常
        IOException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CssMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class CssMetaData<S extends Styleable,V>

  • java.lang.Object
    • javafx.css.CssMetaData<S,V>
  • 参数类型
    S - S的类型
    V - 转换解析值的类型。
    已知直接子类：
    FontCssMetaData

    public abstract class CssMetaData<S extends Styleable,V>
extends Object
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。 它封装了CSS属性名称，转换CSS值的类型和属性的默认值。

    CssMetaData是可以在.css文件中语法表示的值之间的桥梁，以及一个StyleableProperty 。 CssMetaData和StyleableProperty之间有一对一的对应关系。 通常，节点的CssMetaData将包含其祖先的CssMetaData。 例如，Rectangle的CssMetaData包括Shape的CssMetaData和Node。 在CSS处理过程中，CSS引擎遍历节点的CssMetaData，查找每个property的解析值，转换已解析的值，并设置StyleableProperty上的值。

    调用方法Node.getCssMetaData()以获得List <CssMetaData>。 此方法被频繁调用，谨慎地返回一个静态列表，而不是每次调用创建列表。 按照惯例，具有CssMetaData的节点类将实现一个静态方法getClassCssMetaData() ，通常只有getCssMetaData()返回getClassCssMetaData() 。 getClassCssMetaData()的目的是允许子类容易地包含一些祖先的CssMetaData。

    StyleablePropertyFactory大大简化了创建一个StyleableProperty及其相应的CssMetaData。

    这个例子是一个典型的实现。

       private DoubleProperty gapProperty = new StyleableDoubleProperty(0) { @Override public CssMetaData<MyWidget,Number> getCssMetaData() { return GAP_META_DATA; } @Override public Object getBean() { return MyWidget.this; } @Override public String getName() { return "gap"; } }; private static final CssMetaData GAP_META_DATA = new CssMetaData<MyWidget,Number>("-my-gap", StyleConverter.getSizeConverter(), 0d) { @Override public boolean isSettable(MyWidget node) { return node.gapProperty == null || !node.gapProperty.isBound(); } @Override public StyleableProperty<Number> getStyleableProperty(MyWidget node) { return (StyleableProperty<Number>)node.gapProperty; } }; private static final List<CssMetaData<? extends Node, ?>> cssMetaDataList; static { List<CssMetaData<? extends Node, ?>> temp = new ArrayList<CssMetaData<? extends Node, ?>>(Control.getClassCssMetaData()); temp.add(GAP_META_DATA); cssMetaDataList = Collections.unmodifiableList(temp); } public static List<CssMetaData<? extends Node, ?>> getClassCssMetaData() { return cssMetaDataList; } @Override public List<CssMetaData<? extends Node, ?>> getCssMetaData() { return getClassCssMetaData(); }
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    StyleablePropertyFactory

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CssMetaData​(String property, StyleConverter<?,V> converter)
      使用给定的参数构造一个CssMetaData，initialValue为null，inherit设置为false，没有子属性。
      protected CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue)
      使用给定的参数构造一个CssMetaData，继承设置为false并且没有子属性。
      protected CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue, boolean inherits)
      用给定的参数构造一个CssMetaData，没有子属性。
      protected CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue, boolean inherits, List<CssMetaData<? extends Styleable,?>> subProperties)
      用给定的参数构造一个CssMetaData，没有子属性。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      如果两个CssMetaData对象的 property值相等，则认为它们是相等的。
      StyleConverter<?,V> getConverter​()
      V getInitialValue​(S styleable)
      CssMetaData的初始值对应于代码中StyleableProperty的默认值。
      String getProperty​()
      abstract StyleableProperty<V> getStyleableProperty​(S styleable)
      返回给定节点的相应StyleableProperty 。
      List<CssMetaData<? extends Styleable,?>> getSubProperties​()
      子属性是指该属性的组成属性（如果有）。
      int hashCode​()
      返回对象的哈希码值。
      boolean isInherits​()
      如果为true，则此属性的值与父属的此属性的计算值相同。
      abstract boolean isSettable​(S styleable)
      检查给定节点上的相应属性是否可设置。
      void set​(S styleable, V value, StyleOrigin origin)
      已过时。
      此方法不再从CSS代码调用。 使用StyleableProperty.applyStyle(javafx.css.StyleOrigin, java.lang.Object)
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CssMetaData

        protected CssMetaData​(String property,
                      StyleConverter<?,V> converter,
                      V initialValue,
                      boolean inherits,
                      List<CssMetaData<? extends Styleable,?>> subProperties)
        用给定的参数构造一个CssMetaData，没有子属性。
        参数
        property - CSS属性
        converter - StyleConverter用于将CSS解析的值转换为Java对象。
        initialValue - 相应StyleableProperty的初始值或默认值
        inherits - 如果此属性使用CSS继承， inherits true
        subProperties - 此属性的子属性。 例如，-fx-font属性具有子属性-fx-font-family，-fx-font-size，-fx-font-weight和-fx-font-style。

      • CssMetaData

        protected CssMetaData​(String property,
                      StyleConverter<?,V> converter,
                      V initialValue,
                      boolean inherits)
        用给定的参数构造一个CssMetaData，没有子属性。
        参数
        property - CSS属性
        converter - 用于将CSS解析的值转换为Java对象的StyleConverter。
        initialValue - 相应StyleableProperty的初始值或默认值
        inherits - 如果此属性使用CSS继承， inherits true

      • CssMetaData

        protected CssMetaData​(String property,
                      StyleConverter<?,V> converter,
                      V initialValue)
        使用给定的参数构造一个CssMetaData，继承设置为false并且没有子属性。
        参数
        property - CSS属性
        converter - 用于将CSS解析值转换为Java对象的StyleConverter。
        initialValue - 相应StyleableProperty的初始值或默认值

      • CssMetaData

        protected CssMetaData​(String property,
                      StyleConverter<?,V> converter)
        使用给定的参数构造一个CssMetaData，initialValue为null，inherit设置为false，没有子属性。
        参数
        property - CSS属性
        converter - 用于将CSS解析值转换为Java对象的StyleConverter。

    • 方法详细信息

      • set

        @Deprecated(since="8")
public void set​(S styleable,
                V value,
                StyleOrigin origin)
        已过时。 此方法不再从CSS代码调用。 使用StyleableProperty.applyStyle(javafx.css.StyleOrigin, java.lang.Object)
        设置给定节点上相应属性的值。
        参数
        styleable - 要设置属性值的样式
        value - 设置属性的值
        origin - 起源

      • isSettable

        public abstract boolean isSettable​(S styleable)
        检查给定节点上的相应属性是否可设置。 在给定属性查找任何样式之前调用此方法。 它是抽象的，以便代码可以检查属性是否可以设置，而不扩展属性。 一般而言，如果属性不为空或不受约束，则该属性是可设置的。
        参数
        styleable - 要设置属性值的样式
        结果
        如果可以设置属性，则为true。

      • getStyleableProperty

        public abstract StyleableProperty<V> getStyleableProperty​(S styleable)
        返回给定节点的相应StyleableProperty 。 请注意，调用此方法将导致扩展属性。
        参数
        styleable - 返回属性的样式
        结果
        与给定Styleable的此CssMetaData相对应的StyleableProperty

      • getProperty

        public final String getProperty​()
        结果
        CSS属性名称

      • getConverter

        public final StyleConverter<?,V> getConverter​()
        结果
        处理从CSS值到Java对象的转换的CSS转换器

      • getInitialValue

        public V getInitialValue​(S styleable)
        CssMetaData的初始值对应于代码中StyleableProperty的默认值。 例如，Shape.fill的默认值为Color.BLACK，Shape.StyleableProperties.FILL的initialValue也是Color.BLACK。

        然而，这可能是例外。 initialValue可能取决于Node的状态。 ScrollBar具有水平的默认方向。 但是，如果ScrollBar是垂直的，则此方法应返回Orientation.VERTICAL。 否则，当应用初始值时，垂直ScrollBar将被错误地设置为水平ScrollBar。

        参数
        styleable - 风格
        结果
        属性的初始值，可能为null

      • getSubProperties

        public final List<CssMetaData<? extends Styleable,?>> getSubProperties​()
        子属性是指该属性的组成属性（如果有）。 例如，“-fx-font-weight”是“-fx-font”的子属性。
        结果
        子属性列表

      • isInherits

        public final boolean isInherits​()
        如果为true，则此属性的值与父属的此属性的计算值相同。
        结果
        默认情况下为false，除非inherits为true
        另请参见：
        CSS Inheritance

      • equals

        public boolean equals​(Object obj)
        如果两个CssMetaData对象的 property值相等，则认为它们相等。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果obj相等，则为true，否则为false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的一般合同是：

        • 在执行Java应用程序时，无论何时在同一对象上多次调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals对比中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CssParser (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class CssParser

  • java.lang.Object
    • javafx.css.CssParser

  • public final class CssParser
extends Object
    从以下版本开始：
    9

    • Property Summary

      Properties
      Type | Property | 描述
      static ObservableList<CssParser.ParseError> | errors

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  CssParser.ParseError
      封装关于解析CSS或将样式应用于节点时遇到的错误的来源和性质的信息。

    • 构造方法摘要

      构造方法
      Constructor 描述
      CssParser​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      static ObservableList<CssParser.ParseError> | errorsProperty​()
      Stylesheet parse​(String stylesheetText)
      从CSS文档字符串创建样式表。
      Stylesheet parse​(String docbase, String stylesheetText)
      使用docbase作为解析样式表中的引用的基本URL从CSS文档字符串创建样式表。
      Stylesheet parse​(URL url)
      通过从URL读取CSS文档来更新给定的样式表，假设UTF-8编码。
      Stylesheet parseInlineStyle​(Styleable node)
      从节点解析一个在线样式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • errors

        public static ObservableList<CssParser.ParseError> errorsProperty

    • 构造方法详细信息

      • CssParser

        public CssParser​()

    • 方法详细信息

      • parse

        public Stylesheet parse​(String stylesheetText)
        从CSS文档字符串创建样式表。
        参数
        stylesheetText - 要解析的CSS文档
        结果
        样式表

      • parse

        public Stylesheet parse​(String docbase,
                        String stylesheetText)
                 throws IOException
        使用docbase作为解析样式表中的引用的基本URL从CSS文档字符串创建样式表。
        参数
        docbase - 用于解析URL引用的文档库
        stylesheetText - 要解析的CSS文档
        结果
        样式表
        异常
        IOException - 例外

      • parse

        public Stylesheet parse​(URL url)
                 throws IOException
        通过从URL读取CSS文档来更新给定的样式表，假设UTF-8编码。
        参数
        url - 要解析的样式表的URL
        结果
        样式表
        异常
        IOException - 例外

      • parseInlineStyle

        public Stylesheet parseInlineStyle​(Styleable node)
        从节点解析一个在线样式。
        参数
        node - 风格的节点
        结果
        样式表

      • errorsProperty

        public static ObservableList<CssParser.ParseError> errorsProperty​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CssParser.ParseError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class CssParser.ParseError

  • java.lang.Object
    • javafx.css.CssParser.ParseError
  • 已知直接子类：
    CssParser.ParseError.InlineStyleParsingError ， CssParser.ParseError.PropertySetError ， CssParser.ParseError.StringParsingError ， CssParser.ParseError.StylesheetParsingError
    Enclosing class:
    CssParser

    public static class CssParser.ParseError
extends Object
    封装关于解析CSS或将样式应用于节点时遇到的错误的来源和性质的信息。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  CssParser.ParseError.InlineStyleParsingError
      封装从节点样式属性解析引起的错误
      static class  CssParser.ParseError.PropertySetError
      封装将风格应用于节点所产生的错误。
      static class  CssParser.ParseError.StringParsingError
      当样式不是内联样式时，也不会从样式表中选择样式，从而解析解析时出现的错误。
      static class  CssParser.ParseError.StylesheetParsingError
      封装解析样式表文件时产生的错误

    • 构造方法摘要

      构造方法
      Constructor 描述
      ParseError​(String message)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getMessage​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ParseError

        public ParseError​(String message)

    • 方法详细信息

      • getMessage

        public final String getMessage​()
        结果
        来自CSS代码的错误消息。

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CssParser.ParseError.InlineStyleParsingError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class CssParser.ParseError.InlineStyleParsingError

  • java.lang.Object
    • javafx.css.CssParser.ParseError
      • javafx.css.CssParser.ParseError.InlineStyleParsingError
  • Enclosing class:
    CssParser.ParseError

    public static final class CssParser.ParseError.InlineStyleParsingError
extends CssParser.ParseError
    封装从节点样式属性解析引起的错误

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.CssParser.ParseError

        CssParser.ParseError.InlineStyleParsingError, CssParser.ParseError.PropertySetError, CssParser.ParseError.StringParsingError, CssParser.ParseError.StylesheetParsingError

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class javafx.css.CssParser.ParseError

        getMessage

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本上表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 CssParser.ParseError
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CssParser.ParseError.PropertySetError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class CssParser.ParseError.PropertySetError

  • java.lang.Object
    • javafx.css.CssParser.ParseError
      • javafx.css.CssParser.ParseError.PropertySetError
  • Enclosing class:
    CssParser.ParseError

    public static final class CssParser.ParseError.PropertySetError
extends CssParser.ParseError
    封装将风格应用于节点所产生的错误。

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.CssParser.ParseError

        CssParser.ParseError.InlineStyleParsingError, CssParser.ParseError.PropertySetError, CssParser.ParseError.StringParsingError, CssParser.ParseError.StylesheetParsingError

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertySetError​(CssMetaData styleableProperty, Styleable styleable, String message)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class javafx.css.CssParser.ParseError

        getMessage

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PropertySetError

        public PropertySetError​(CssMetaData styleableProperty,
                        Styleable styleable,
                        String message)

    • 方法详细信息

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 CssParser.ParseError
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CssParser.ParseError.StringParsingError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class CssParser.ParseError.StringParsingError

  • java.lang.Object
    • javafx.css.CssParser.ParseError
      • javafx.css.CssParser.ParseError.StringParsingError
  • Enclosing class:
    CssParser.ParseError

    public static final class CssParser.ParseError.StringParsingError
extends CssParser.ParseError
    当样式不是内联样式时，也不会从样式表中选择样式，从而解析解析时出现的错误。 主要用于支持单元测试。

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.CssParser.ParseError

        CssParser.ParseError.InlineStyleParsingError, CssParser.ParseError.PropertySetError, CssParser.ParseError.StringParsingError, CssParser.ParseError.StylesheetParsingError

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class javafx.css.CssParser.ParseError

        getMessage

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般情况下， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 CssParser.ParseError
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CssParser.ParseError.StylesheetParsingError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class CssParser.ParseError.StylesheetParsingError

  • java.lang.Object
    • javafx.css.CssParser.ParseError
      • javafx.css.CssParser.ParseError.StylesheetParsingError
  • Enclosing class:
    CssParser.ParseError

    public static final class CssParser.ParseError.StylesheetParsingError
extends CssParser.ParseError
    封装解析样式表文件时产生的错误

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.CssParser.ParseError

        CssParser.ParseError.InlineStyleParsingError, CssParser.ParseError.PropertySetError, CssParser.ParseError.StringParsingError, CssParser.ParseError.StylesheetParsingError

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class javafx.css.CssParser.ParseError

        getMessage

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 CssParser.ParseError
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Declaration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class Declaration

  • java.lang.Object
    • javafx.css.Declaration

  • public final class Declaration
extends Object
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      boolean equals​(Object obj)
      无论宣言所属的规则如何，一个宣言是相等的。
      ParsedValue getParsedValue​()
      String getProperty​()
      Rule getRule​()
      int hashCode​()
      返回对象的哈希码值。
      boolean | isImportant​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getParsedValue

        public ParsedValue getParsedValue​()
        结果
        ParsedValue包含已解析的声明。

      • getProperty

        public String getProperty​()
        结果
        CSS属性名称

      • getRule

        public Rule getRule​()
        结果
        本宣言所属的规则。

      • isImportant

        public final boolean isImportant​()

      • equals

        public boolean equals​(Object obj)
        无论宣言所属的规则如何，一个宣言是相等的。 只考虑财产，价值和重要性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的一般合同是：

        • 只要在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每一个上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        说明从类别复制Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FontCssMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class FontCssMetaData<S extends Styleable>

  • java.lang.Object
    • javafx.css.CssMetaData<S,Font>
      • javafx.css.FontCssMetaData<S>
  • 参数类型
    S - S的类型

    public abstract class FontCssMetaData<S extends Styleable>
extends CssMetaData<S,Font>
    CssMetaData部分实现Font属性，其中包含字体子属性：weight，style，family和size。
    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      FontCssMetaData​(String property, Font initial)
      从指定的属性和初始字体构造一个FontCSSMetaData对象。

    • 方法摘要

      • Methods inherited from class javafx.css.CssMetaData

        equals, getConverter, getInitialValue, getProperty, getStyleableProperty, getSubProperties, hashCode, isInherits, isSettable, set, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FontCssMetaData

        public FontCssMetaData​(String property,
                       Font initial)
        从指定的属性和初始字体构造一个FontCSSMetaData对象。 属性名称与“-weight”，“-style”，“-family”和“-size”连接以创建子属性。 例如， new FontCssMetaData<Text>("-fx-font", Font.getDefault());将为具有子属性的“-fx-font”创建一个CssMetaData：“-fx-font-weight”，“-fx-font-style”，“-fx-font-family”和“-fx -字体大小”
        参数
        property - 属性名称
        initial - the initial font
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FontFace (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class FontFace

  • java.lang.Object
    • javafx.css.FontFace

  • public abstract class FontFace
extends Object
    FontFace是一个来自CSS文件的@ font-face定义
    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FontFace​()
      仅用于私有实现类的构造方法。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FontFace

        protected FontFace​()
        仅用于私有实现类的构造方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.css (Java SE 9 & JDK 9 )

javafx.css

Interfaces

  • Styleable
  • StyleableProperty

Classes

  • CompoundSelector
  • CssMetaData
  • CssParser
  • CssParser.ParseError
  • CssParser.ParseError.InlineStyleParsingError
  • CssParser.ParseError.PropertySetError
  • CssParser.ParseError.StringParsingError
  • CssParser.ParseError.StylesheetParsingError
  • Declaration
  • FontCssMetaData
  • FontFace
  • Match
  • ParsedValue
  • PseudoClass
  • Rule
  • Selector
  • SimpleSelector
  • SimpleStyleableBooleanProperty
  • SimpleStyleableDoubleProperty
  • SimpleStyleableFloatProperty
  • SimpleStyleableIntegerProperty
  • SimpleStyleableLongProperty
  • SimpleStyleableObjectProperty
  • SimpleStyleableStringProperty
  • Size
  • Style
  • StyleableBooleanProperty
  • StyleableDoubleProperty
  • StyleableFloatProperty
  • StyleableIntegerProperty
  • StyleableLongProperty
  • StyleableObjectProperty
  • StyleablePropertyFactory
  • StyleableStringProperty
  • StyleClass
  • StyleConverter
  • StyleConverter.StringStore
  • Stylesheet

Enums

  • SizeUnits
  • StyleOrigin


javafx.css (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.css

提供API，通过CSS使属性变得风格，并支持伪类状态。

JavaFX Scene Graph提供了使用CSS（级联样式表）对节点进行风格化的功能。 该Node类包含id ， styleClass和style这是使用CSS选择器找到哪些样式应该应用于节点变量。 Scene类和Parent类包含一个stylesheets变量，它是引用要应用于该场景或父节点中的节点的CSS样式表的URL列表。

此包中的主要类别有：

CssMetaData
定义CSS属性并提供回到StyleableProperty的链接。 按照惯例，具有CssMetaData的类实现了一个public static List<CssMetaData<? extends Styleable>> getClassCssMetaData()方法，允许其他类从继承的类中包含CssMetaData。 应该覆盖方法getCssMetaData()以返回getClassCssMetaData() 。 CSS实现经常调用getCssMetaData() 。 强烈建议返回的列表为final static 。
StyleableProperty
定义CSS实现用于在属性上设置值的接口，并提供一个链接回到对应于该属性的CssMetaData 。 StyleablePropertyFactory大大简化了创建一个StyleableProperty及其相应的CssMetaData。
PseudoClass
定义可以通过方法pseudoClassStateChanged设置或清除的伪类。

有关CSS的更多信息，如何将CSS样式应用于节点，以及什么属性可用于样式，请参阅CSS Reference Guide 。

  • 接口摘要
    接口 描述
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
    StyleableProperty<T>
    StyleableProperty允许一个 javafx.beans.property从CSS样式。
  • 类摘要
    Class 描述
    CompoundSelector
    根据CSS标准行事的复合选择器。
    CssMetaData<S extends Styleable,V>
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    CssParser
    CssParser.ParseError
    封装关于解析CSS或将样式应用于节点时遇到的错误的来源和性质的信息。
    CssParser.ParseError.InlineStyleParsingError
    封装从节点样式属性解析引起的错误
    CssParser.ParseError.PropertySetError
    封装将风格应用于节点所产生的错误。
    CssParser.ParseError.StringParsingError
    当样式不是内联样式时，也不会从样式表中选择样式，从而解析解析时出现的错误。
    CssParser.ParseError.StylesheetParsingError
    封装解析样式表文件时产生的错误
    Declaration
    FontCssMetaData<S extends Styleable>
    CssMetaData部分实现Font属性，其中包含字体子属性：weight，style，family和size。
    FontFace
    FontFace是一个来自CSS文件的@ font-face定义
    Match
    由Rule用于确定选择器是否适用于给定的对象。
    ParsedValue<V,T>
    解析的CSS值的表示。
    PseudoClass
    伪类代表一个唯一的伪类状态。
    Rule
    Selector
    由CSSRule用于确定选择器是否适用于给定的对象。
    SimpleSelector
    一个根据CSS标准行事的简单选择器。
    SimpleStyleableBooleanProperty
    这个类扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
    SimpleStyleableDoubleProperty
    这个课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
    SimpleStyleableFloatProperty
    这个课程扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
    SimpleStyleableIntegerProperty
    这个课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
    SimpleStyleableLongProperty
    这个类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
    SimpleStyleableObjectProperty<T>
    这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
    SimpleStyleableStringProperty
    该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
    Size
    表示特定单位中指定的大小，例如14px或0.2em。
    Style
    风格只是一个规则的选择器和声明。
    StyleableBooleanProperty
    这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableDoubleProperty
    这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableFloatProperty
    这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableIntegerProperty
    这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableLongProperty
    这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableObjectProperty<T>
    这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleablePropertyFactory<S extends Styleable>
    使用相应的CssMetaData创建StyleableProperty实例的方法。
    StyleableStringProperty
    这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleClass
    StyleConverter<F,T>
    StyleConverter转换 ParsedValue<F,T>从类型 F键入 T 。
    StyleConverter.StringStore
    StringStore类
    Stylesheet
    可以将属性应用于对象树的样式表。
  • 枚举摘要
    Enum 描述
    SizeUnits
    表示特定单位中指定的大小，例如14px或0.2em。
    StyleOrigin
    枚举样式表和样式的可能来源或来源。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.css Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.css

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression (implements javafx.beans.value.ObservableBooleanValue)
      • javafx.beans.property.ReadOnlyBooleanProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.BooleanProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableBooleanValue)
          • javafx.beans.property.BooleanPropertyBase
            • javafx.css.StyleableBooleanProperty (implements javafx.css.StyleableProperty<T>)
              • javafx.css.SimpleStyleableBooleanProperty
    • javafx.css.CssMetaData<S,V>
      • javafx.css.FontCssMetaData<S>
    • javafx.css.CssParser
    • javafx.css.CssParser.ParseError
      • javafx.css.CssParser.ParseError.InlineStyleParsingError
      • javafx.css.CssParser.ParseError.PropertySetError
      • javafx.css.CssParser.ParseError.StringParsingError
      • javafx.css.CssParser.ParseError.StylesheetParsingError
    • javafx.css.Declaration
    • javafx.css.FontFace
    • javafx.css.Match (implements java.lang.Comparable<T>)
    • javafx.beans.binding.NumberExpressionBase (implements javafx.beans.binding.NumberExpression)
      • javafx.beans.binding.DoubleExpression (implements javafx.beans.value.ObservableDoubleValue)
        • javafx.beans.property.ReadOnlyDoubleProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.DoubleProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableDoubleValue)
            • javafx.beans.property.DoublePropertyBase
              • javafx.css.StyleableDoubleProperty (implements javafx.css.StyleableProperty<T>)
                • javafx.css.SimpleStyleableDoubleProperty
      • javafx.beans.binding.FloatExpression (implements javafx.beans.value.ObservableFloatValue)
        • javafx.beans.property.ReadOnlyFloatProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.FloatProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableFloatValue)
            • javafx.beans.property.FloatPropertyBase
              • javafx.css.StyleableFloatProperty (implements javafx.css.StyleableProperty<T>)
                • javafx.css.SimpleStyleableFloatProperty
      • javafx.beans.binding.IntegerExpression (implements javafx.beans.value.ObservableIntegerValue)
        • javafx.beans.property.ReadOnlyIntegerProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.IntegerProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableIntegerValue)
            • javafx.beans.property.IntegerPropertyBase
              • javafx.css.StyleableIntegerProperty (implements javafx.css.StyleableProperty<T>)
                • javafx.css.SimpleStyleableIntegerProperty
      • javafx.beans.binding.LongExpression (implements javafx.beans.value.ObservableLongValue)
        • javafx.beans.property.ReadOnlyLongProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
          • javafx.beans.property.LongProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableLongValue)
            • javafx.beans.property.LongPropertyBase
              • javafx.css.StyleableLongProperty (implements javafx.css.StyleableProperty<T>)
                • javafx.css.SimpleStyleableLongProperty
    • javafx.beans.binding.ObjectExpression<T> (implements javafx.beans.value.ObservableObjectValue<T>)
      • javafx.beans.property.ReadOnlyObjectProperty<T> (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.ObjectProperty<T> (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableObjectValue<T>)
          • javafx.beans.property.ObjectPropertyBase<T>
            • javafx.css.StyleableObjectProperty<T> (implements javafx.css.StyleableProperty<T>)
              • javafx.css.SimpleStyleableObjectProperty<T>
    • javafx.css.ParsedValue<V,T>
    • javafx.css.PseudoClass
    • javafx.css.Rule
    • javafx.css.Selector
      • javafx.css.CompoundSelector
      • javafx.css.SimpleSelector
    • javafx.css.Size
    • javafx.beans.binding.StringExpression (implements javafx.beans.value.ObservableStringValue)
      • javafx.beans.property.ReadOnlyStringProperty (implements javafx.beans.property.ReadOnlyProperty<T>)
        • javafx.beans.property.StringProperty (implements javafx.beans.property.Property<T>, javafx.beans.value.WritableStringValue)
          • javafx.beans.property.StringPropertyBase
            • javafx.css.StyleableStringProperty (implements javafx.css.StyleableProperty<T>)
              • javafx.css.SimpleStyleableStringProperty
    • javafx.css.Style
    • javafx.css.StyleablePropertyFactory<S>
    • javafx.css.StyleClass
    • javafx.css.StyleConverter<F,T>
    • javafx.css.StyleConverter.StringStore
    • javafx.css.Stylesheet

Interface Hierarchy

  • javafx.css.Styleable
  • javafx.beans.value.WritableValue<T>
    • javafx.css.StyleableProperty<T>

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.css.SizeUnits
      • javafx.css.StyleOrigin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Match (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class Match

  • java.lang.Object
    • javafx.css.Match
  • All Implemented Interfaces:
    Comparable<Match>

    public final class Match
extends Object
implements Comparable<Match>
    由Rule用于确定选择器是否适用于给定的对象。 如果匹配，则返回Selector比赛。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      int compareTo​(Match o)
      将此对象与指定的对象进行比较以进行排序。
      com.sun.javafx.css.PseudoClassState | getPseudoClasses​()
      Selector getSelector​()
      int | getSpecificity​()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getSelector

        public Selector getSelector​()

      • getPseudoClasses

        public com.sun.javafx.css.PseudoClassState getPseudoClasses​()

      • getSpecificity

        public int getSpecificity​()

      • compareTo

        public int compareTo​(Match o)
        描述从接口Comparable复制
        将此对象与指定的对象进行比较以进行排序。 返回一个负整数，零或正整数，因为该对象小于，等于或大于指定对象。

        实现程序必须确保sgn(x.compareTo(y)) == -sgn(y.compareTo(x))所有x和y 。 （这意味着x.compareTo(y)必须抛出异常iff y.compareTo(x)引发异常。）

        实施者还必须确保关系是可传递的： (x.compareTo(y) > 0 && y.compareTo(z) > 0)意味着x.compareTo(z) > 0 。

        最后，实施者必须确保x.compareTo(y)==0意味着sgn(x.compareTo(z)) == sgn(y.compareTo(z)) ，全部为z 。

        强烈建议，但不要严格要求(x.compareTo(y)==0) == (x.equals(y)) 。 一般来说，任何实现Comparable接口并违反这种情况的类应清楚地表明这一点。 推荐的语言是“注意：此类具有与equals不一致的自然排序”。

        在前面的描述中，符号sgn( 表达 )表示数学符号函数，其被定义为返回之一-1 ， 0 ，或1分别根据表达式的值是否为负，零或正。

        Specified by:
        compareTo在接口 Comparable<Match>
        参数
        o - 要比较的对象。
        结果
        负整数，零或正整数，因为该对象小于，等于或大于指定对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ParsedValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class ParsedValue<V,T>

  • java.lang.Object
    • javafx.css.ParsedValue<V,T>

  • public class ParsedValue<V,T>
extends Object
    解析的CSS值的表示。 V是解析值的类型， T是StyleableProperty类型的转换值。 ParsedValue实例由CSS解析器创建。 例如，解析器在分析Web Color时创建一个ParsedValue<String,Color> 。

    ParsedValue对于从解析的CSS值计算实际值的代码是有意义的。 在其他地方， getValue()返回的价值可能是模糊，粗暴和令人困惑的。

    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected StyleConverter<V,T> converter
      所述StyleConverter其中被分析的值转换为的类型StyleableProperty 。
      protected V value
      由解析器创建的CSS属性值。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ParsedValue​(V value, StyleConverter<V,T> converter)
      创建ParsedValue的实例，其中使用给定的转换器将值类型V转换为目标类型T.

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T convert​(Font font)
      致电 convert的方便方法 ParsedValue 。
      StyleConverter<V,T> getConverter​()
      甲StyleConverter转换分析得到的值到的类型StyleableProperty 。
      V getValue​()
      boolean isContainsLookups​()
      如果值本身是ParsedValue或值序列，并且应该查找任何这些值，则会设置此标志。
      boolean isLookup​()
      如果值引用另一个属性，则需要查找实际值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        protected final V value
        由解析器创建的CSS属性值。

      • converter

        protected final StyleConverter<V,T> converter
        所述StyleConverter其中被分析的值转换为的类型StyleableProperty 。 这可能是null，在这种情况下， convert将返回getValue()

    • 构造方法详细信息

      • ParsedValue

        protected ParsedValue​(V value,
                      StyleConverter<V,T> converter)
        创建ParsedValue的实例，其中使用给定的转换器将值类型V转换为目标类型T. 如果converter为空，则假定值类型V和目标类型T相同并且不需要转换。
        参数
        value - 要转换的值
        converter - 转换器

    • 方法详细信息

      • getValue

        public final V getValue​()
        结果
        由解析器创建的CSS属性值，可能为null或其他方式不可理解。

      • getConverter

        public final StyleConverter<V,T> getConverter​()
        甲StyleConverter转换分析得到的值到的类型StyleableProperty 。 如果StyleConverter为空，则convert(javafx.scene.text.Font)将返回getValue()
        结果
        所述StyleConverter其中被分析的值转换为的类型StyleableProperty 。 可能返回null。

      • convert

        public T convert​(Font font)
        在这个 ParsedValue上调用 convert的方便方法。
        参数
        font - 转换relative时使用的Font 。
        结果
        该值转换为StyleableProperty的类型
        另请参见：
        getConverter()

      • isContainsLookups

        public boolean isContainsLookups​()
        如果值本身是ParsedValue或值序列，并且应该查找任何这些值，则会设置此标志。 这并不意味着需要查找这个特定的值，而是包含一个需要查找的值。
        结果
        如果此值包含需要查找的值，则为true，否则为false
        从以下版本开始：
        9

      • isLookup

        public boolean isLookup​()
        如果值引用另一个属性，则需要查找实际值。
        结果
        如果值引用另一个属性，则为true，否则为false
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PseudoClass (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class PseudoClass

  • java.lang.Object
    • javafx.css.PseudoClass

  • public abstract class PseudoClass
extends Object
    伪类代表一个唯一的伪类状态。 在JavaFX类中引入伪类只需要在伪类状态更改时调用方法Node.pseudoClassStateChanged(javafx.css.PseudoClass, boolean) 。 典型地，该pseudoClassStateChanged方法从被呼叫protected void invalidated()在属性基类中的一个的方法javafx.beans.property包。

    请注意，如果节点具有默认伪类状态，则应从构造函数调用水平方向（例如pseudoClassStateChanged以设置初始状态。

    以下示例将允许“xyzzy”作为CSS选择器中的伪类。

       public boolean isMagic() { return magic.get(); } public BooleanProperty magicProperty() { return magic; } public BooleanProperty magic = new BooleanPropertyBase(false) { @Override protected void invalidated() { pseudoClassStateChanged(MAGIC_PSEUDO_CLASS. get()); } @Override public Object getBean() { return MyControl.this; } @Override public String getName() { return "magic"; } } private static final PseudoClass MAGIC_PSEUDO_CLASS = PseudoClass.getPseudoClass("xyzzy");
    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      PseudoClass​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      static PseudoClass getPseudoClass​(String pseudoClass)
      给定的pseudoClass只有一个PseudoClass实例。
      abstract String | getPseudoClassName​()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PseudoClass

        public PseudoClass​()

    • 方法详细信息

      • getPseudoClass

        public static PseudoClass getPseudoClass​(String pseudoClass)
        给定的pseudoClass只有一个PseudoClass实例。
        参数
        pseudoClass - 伪类
        结果
        给定的pseudoClass的PseudoClass。 不会返回null。
        异常
        IllegalArgumentException - 如果pseudoClass参数为空或空字符串

      • getPseudoClassName

        public abstract String getPseudoClassName​()
        结果
        伪类状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Rule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class Rule

  • java.lang.Object
    • javafx.css.Rule

  • public final class Rule
extends Object

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<Declaration> getDeclarations​()
      此方法是支持可能希望从规则添加声明或从规则中删除声明的工具。
      StyleOrigin getOrigin​()
      ObservableList<Selector> getSelectors​()
      此方法是支持可能希望从Rule添加选择器或从Rule中删除选择器的工具。
      Stylesheet getStylesheet​()
      String toString​()
      将此对象转换为字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getDeclarations

        public final ObservableList<Declaration> getDeclarations​()
        此方法是支持可能希望从规则添加声明或从规则中删除声明的工具。 跟踪对列表的更改，以便添加的声明被标记为属于此规则，并且已删除的声明的规则将被清空。 如果列表不被修改，那么调用getUnobservedDeclarationList()更有效，但返回的列表必须被视为不可修改的。
        结果
        一个可观察的声明列表

      • getSelectors

        public final ObservableList<Selector> getSelectors​()
        此方法是支持可能希望从Rule添加选择器或从Rule中删除选择器的工具。 跟踪对列表的更改，以便添加的选择器被标记为属于此规则，并且删除的选择器的规则被清空。 如果列表不被修改，那么调用getUnobservedSelectorList()更有效，但返回的列表必须被视为不可修改的。
        结果
        一个可观察的选择器列表

      • getStylesheet

        public Stylesheet getStylesheet​()

      • getOrigin

        public StyleOrigin getOrigin​()

      • toString

        public String toString​()
        将此对象转换为字符串。
        重写：
        toString在 Object
        结果
        转换的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Selector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class Selector

  • java.lang.Object
    • javafx.css.Selector
  • 已知直接子类：
    CompoundSelector ， SimpleSelector

    public abstract class Selector
extends Object
    由CSSRule用于确定选择器是否适用于给定的对象。
    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Constructor 描述
      Selector​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      abstract boolean | applies​(Styleable styleable)
      abstract boolean | applies​(Styleable styleable, Set<PseudoClass>[] triggerStates, int bit)
      abstract Match | createMatch​()
      static Selector | createSelector​(String cssSelector)
      int | getOrdinal​()
      Rule getRule​()
      void | setOrdinal​(int ordinal)
      abstract boolean stateMatches​(Styleable styleable, Set<PseudoClass> state)
      确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。
      protected void | writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Selector

        public Selector​()

    • 方法详细信息

      • getRule

        public Rule getRule​()

      • setOrdinal

        public void setOrdinal​(int ordinal)

      • getOrdinal

        public int getOrdinal​()

      • createMatch

        public abstract Match createMatch​()

      • applies

        public abstract boolean applies​(Styleable styleable)

      • applies

        public abstract boolean applies​(Styleable styleable,
                                Set<PseudoClass>[] triggerStates,
                                int bit)

      • stateMatches

        public abstract boolean stateMatches​(Styleable styleable,
                                     Set<PseudoClass> state)
        确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。
        参数
        styleable - 风格
        state - 状态
        结果
        true如果节点及其父节点的当前状态与此选择器定义的伪类（如果有）匹配

      • writeBinary

        protected void writeBinary​(DataOutputStream os,
                           StyleConverter.StringStore stringStore)
                    throws IOException
        异常
        IOException

      • createSelector

        public static Selector createSelector​(String cssSelector)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class SimpleSelector

  • java.lang.Object
    • javafx.css.Selector
      • javafx.css.SimpleSelector

  • public final class SimpleSelector
extends Selector
    一个根据CSS标准行事的简单选择器。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      boolean | applies​(Styleable styleable)
      boolean | applies​(Styleable styleable, Set<PseudoClass>[] pseudoClasses, int depth)
      Match createMatch​()
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      String getId​()
      String getName​()
      NodeOrientation getNodeOrientation​()
      List<String> getStyleClasses​()
      Set<StyleClass> getStyleClassSet​()
      int hashCode​()
      返回对象的哈希码值。
      boolean stateMatches​(Styleable styleable, Set<PseudoClass> states)
      确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。
      String toString​()
      将此对象转换为字符串。
      protected void | writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.Selector

        createSelector, getOrdinal, getRule, setOrdinal

    • 方法详细信息

      • getName

        public String getName​()
        结果
        应用此选择器的java类的名称，或*。

      • getStyleClasses

        public List<String> getStyleClasses​()
        结果
        不可变列表<String>选择器的样式类

      • getStyleClassSet

        public Set<StyleClass> getStyleClassSet​()

      • getId

        public String getId​()

      • getNodeOrientation

        public NodeOrientation getNodeOrientation​()

      • createMatch

        public Match createMatch​()
        Specified by:
        createMatch中的 Selector

      • applies

        public boolean applies​(Styleable styleable)
        Specified by:
        applies中的 Selector

      • applies

        public boolean applies​(Styleable styleable,
                       Set<PseudoClass>[] pseudoClasses,
                       int depth)
        Specified by:
        applies在 Selector

      • stateMatches

        public boolean stateMatches​(Styleable styleable,
                            Set<PseudoClass> states)
        描述从类别复制： Selector
        确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。
        Specified by:
        stateMatches在 Selector
        参数
        styleable - 风格
        states - 状态
        结果
        true如果节点及其父节点的当前状态与此选择器定义的伪类（如果有）匹配

      • equals

        public boolean equals​(Object obj)
        描述从类别复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 一致 ：对于任何非空参考值x和y ，多个调用x.equals(y)一致返回true或一致返回false ，前提是在equals对对象使用的信息进行了修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 在执行Java应用程序时，无论何时在同一对象上多次调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每一个上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode中的 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        将此对象转换为字符串。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • writeBinary

        protected final void writeBinary​(DataOutputStream os,
                                 StyleConverter.StringStore stringStore)
                          throws IOException
        重写：
        writeBinary在 Selector
        异常
        IOException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleStyleableBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class SimpleStyleableBooleanProperty

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
        • javafx.beans.property.BooleanProperty
          • javafx.beans.property.BooleanPropertyBase
            • javafx.css.StyleableBooleanProperty
              • javafx.css.SimpleStyleableBooleanProperty
  • All Implemented Interfaces:
    Observable ， Property<Boolean> ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean> ， WritableBooleanValue ， WritableValue<Boolean> ， StyleableProperty<Boolean>

    public class SimpleStyleableBooleanProperty
extends StyleableBooleanProperty
    这个课程扩展了SimpleBooleanProperty并提供了一个StyleableProperty的完整实现。 这个类用于制作一个BooleanProperty ，否则将被实现为一个SimpleBooleanProperty ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    SimpleBooleanProperty ， CssMetaData ， StyleableProperty ， StyleableBooleanProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, boolean initialValue)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      CssMetaData<? extends Styleable,Boolean> getCssMetaData​()
      反映对应于这个 javafx.beans.property.StyleableProperty
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class javafx.beans.property.BooleanProperty

        asObject, bindBidirectional, booleanProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.BooleanPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanProperty

        readOnlyBooleanProperty

      • Methods inherited from class javafx.css.StyleableBooleanProperty

        applyStyle, bind, getStyleOrigin, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • SimpleStyleableBooleanProperty

        public SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData)
        SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty

      • SimpleStyleableBooleanProperty

        public SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData,
                                      boolean initialValue)
        SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        initialValue - 包装的初始值 Object

      • SimpleStyleableBooleanProperty

        public SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData,
                                      Object bean,
                                      String name)
        SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty
        bean - 这个 BooleanProperty的豆
        name - 这个名字 BooleanProperty

      • SimpleStyleableBooleanProperty

        public SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData,
                                      Object bean,
                                      String name,
                                      boolean initialValue)
        SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        bean - 这个 BooleanProperty的豆
        name - 这个名字 BooleanProperty
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性不包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        结果
        该名称或空的 String

      • getCssMetaData

        public final CssMetaData<? extends Styleable,Boolean> getCssMetaData​()
        反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
        结果
        the corresponding CssMetaData
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleStyleableDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class SimpleStyleableDoubleProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
          • javafx.beans.property.DoubleProperty
            • javafx.beans.property.DoublePropertyBase
              • javafx.css.StyleableDoubleProperty
                • javafx.css.SimpleStyleableDoubleProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableDoubleValue ， WritableNumberValue ， WritableValue<Number> ， StyleableProperty<Number>

    public class SimpleStyleableDoubleProperty
extends StyleableDoubleProperty
    这个类扩展了SimpleDoubleProperty并提供了一个StyleableProperty的完整实现。 这个类用于制作一个DoubleProperty ，否则将被实现为一个SimpleDoubleProperty ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    SimpleDoubleProperty ， CssMetaData ， StyleableProperty ， StyleableDoubleProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Double initialValue)
      的构造函数为 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      CssMetaData<? extends Styleable,Number> getCssMetaData​()
      反映对应于这个 javafx.beans.property.StyleableProperty
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.DoubleProperty

        asObject, bindBidirectional, doubleProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.DoublePropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyDoubleProperty

        readOnlyDoubleProperty

      • Methods inherited from class javafx.css.StyleableDoubleProperty

        applyStyle, bind, getStyleOrigin, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • SimpleStyleableDoubleProperty

        public SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
        SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty

      • SimpleStyleableDoubleProperty

        public SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                     Double initialValue)
        SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        initialValue - 包装的初始值 Object

      • SimpleStyleableDoubleProperty

        public SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                     Object bean,
                                     String name)
        的构造函数为 SimpleStyleableDoubleProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        bean - 这个 DoubleProperty的豆
        name - 这个名字 DoubleProperty

      • SimpleStyleableDoubleProperty

        public SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                     Object bean,
                                     String name,
                                     Double initialValue)
        SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        bean - 这个 DoubleProperty的豆
        name - 这个名字 DoubleProperty
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        结果
        该名称或空的 String

      • getCssMetaData

        public final CssMetaData<? extends Styleable,Number> getCssMetaData​()
        反映了对应于这个 javafx.beans.property.StyleableProperty
        结果
        the corresponding CssMetaData
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleStyleableFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class SimpleStyleableFloatProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
          • javafx.beans.property.FloatProperty
            • javafx.beans.property.FloatPropertyBase
              • javafx.css.StyleableFloatProperty
                • javafx.css.SimpleStyleableFloatProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableFloatValue ， WritableNumberValue ， WritableValue<Number> ， StyleableProperty<Number>

    public class SimpleStyleableFloatProperty
extends StyleableFloatProperty
    该课程扩展了SimpleFloatProperty并提供了一个StyleableProperty的完整实现。 这个类用于制作一个FloatProperty ，否则将被实现为一个SimpleFloatProperty ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    SimpleFloatProperty ， CssMetaData ， StyleableProperty ， StyleableFloatProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Float initialValue)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      CssMetaData<? extends Styleable,Number> getCssMetaData​()
      反映对应于这个 javafx.beans.property.StyleableProperty
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.FloatProperty

        asObject, bindBidirectional, floatProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.FloatPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatProperty

        readOnlyFloatProperty

      • Methods inherited from class javafx.css.StyleableFloatProperty

        applyStyle, bind, getStyleOrigin, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • SimpleStyleableFloatProperty

        public SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
        SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty

      • SimpleStyleableFloatProperty

        public SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                    Float initialValue)
        SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        initialValue - 包装的初始值 Object

      • SimpleStyleableFloatProperty

        public SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                    Object bean,
                                    String name)
        SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        bean - 这个 FloatProperty的豆
        name - 这个名字 FloatProperty

      • SimpleStyleableFloatProperty

        public SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                    Object bean,
                                    String name,
                                    Float initialValue)
        SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        bean - 这个 FloatProperty的豆
        name - 这个名字 FloatProperty
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性不包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        结果
        名称或空的 String

      • getCssMetaData

        public final CssMetaData<? extends Styleable,Number> getCssMetaData​()
        反映对应于这个 javafx.beans.property.StyleableProperty
        结果
        the corresponding CssMetaData
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleStyleableIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class SimpleStyleableIntegerProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
          • javafx.beans.property.IntegerProperty
            • javafx.beans.property.IntegerPropertyBase
              • javafx.css.StyleableIntegerProperty
                • javafx.css.SimpleStyleableIntegerProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableIntegerValue ， WritableNumberValue ， WritableValue<Number> ， StyleableProperty<Number>

    public class SimpleStyleableIntegerProperty
extends StyleableIntegerProperty
    该课程扩展了SimpleIntegerProperty并提供了一个StyleableProperty的完整实现。 这个类用于制作一个IntegerProperty ，否则将被实现为一个SimpleIntegerProperty ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    SimpleIntegerProperty ， CssMetaData ， StyleableProperty ， StyleableIntegerProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      CssMetaData<? extends Styleable,Number> getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.IntegerProperty

        asObject, bindBidirectional, integerProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.IntegerPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerProperty

        readOnlyIntegerProperty

      • Methods inherited from class javafx.css.StyleableIntegerProperty

        applyStyle, bind, getStyleOrigin, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • SimpleStyleableIntegerProperty

        public SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
        SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty

      • SimpleStyleableIntegerProperty

        public SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                      Integer initialValue)
        SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        initialValue - 包装的初始值 Object

      • SimpleStyleableIntegerProperty

        public SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                      Object bean,
                                      String name)
        SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        bean - 这个 IntegerProperty的豆
        name - 这个名字 IntegerProperty

      • SimpleStyleableIntegerProperty

        public SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                      Object bean,
                                      String name,
                                      Integer initialValue)
        SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        bean - 这个 IntegerProperty的bean
        name - 这个名字 IntegerProperty
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法将返回一个空的String 。
        结果
        名称或空的 String

      • getCssMetaData

        public final CssMetaData<? extends Styleable,Number> getCssMetaData​()
        反映了对应于这个 javafx.beans.property.StyleableProperty
        结果
        the corresponding CssMetaData
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleStyleableLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class SimpleStyleableLongProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
          • javafx.beans.property.LongProperty
            • javafx.beans.property.LongPropertyBase
              • javafx.css.StyleableLongProperty
                • javafx.css.SimpleStyleableLongProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableLongValue ， WritableNumberValue ， WritableValue<Number> ， StyleableProperty<Number>

    public class SimpleStyleableLongProperty
extends StyleableLongProperty
    该课程扩展了SimpleLongProperty并提供了一个StyleableProperty的完整实现。 这个类用于制作一个LongProperty ，否则将被实现为一个SimpleLongProperty ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    SimpleLongProperty ， CssMetaData ， StyleableProperty ， StyleableLongProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      CssMetaData<? extends Styleable,Number> getCssMetaData​()
      反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
      String getName​()
      返回此属性的名称。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.LongProperty

        asObject, bindBidirectional, longProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.LongPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyLongProperty

        readOnlyLongProperty

      • Methods inherited from class javafx.css.StyleableLongProperty

        applyStyle, bind, getStyleOrigin, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • SimpleStyleableLongProperty

        public SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
        SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty

      • SimpleStyleableLongProperty

        public SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                   Long initialValue)
        SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        initialValue - 包装的初始值 Object

      • SimpleStyleableLongProperty

        public SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                   Object bean,
                                   String name)
        SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty
        bean - 这个 LongProperty的豆
        name - 这个名字 LongProperty

      • SimpleStyleableLongProperty

        public SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData,
                                   Object bean,
                                   String name,
                                   Long initialValue)
        SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty
        bean - 这个 LongProperty的豆
        name - 这个名字 LongProperty
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        结果
        该名称或空的 String

      • getCssMetaData

        public final CssMetaData<? extends Styleable,Number> getCssMetaData​()
        反映了对应于这个 javafx.beans.property.StyleableProperty
        结果
        the corresponding CssMetaData
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleStyleableObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class SimpleStyleableObjectProperty<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
        • javafx.beans.property.ObjectProperty<T>
          • javafx.beans.property.ObjectPropertyBase<T>
            • javafx.css.StyleableObjectProperty<T>
              • javafx.css.SimpleStyleableObjectProperty<T>
  • All Implemented Interfaces:
    Observable ， Property<T> ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T> ， WritableObjectValue<T> ， WritableValue<T> ， StyleableProperty<T>

    public class SimpleStyleableObjectProperty<T>
extends StyleableObjectProperty<T>
    这个类扩展了SimpleObjectProperty并提供了一个StyleableProperty的完整实现。 这个类用于制作一个ObjectProperty ，否则将被实现为一个SimpleObjectProperty ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    SimpleObjectProperty ， CssMetaData ， StyleableProperty ， StyleableObjectProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name, T initialValue)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, T initialValue)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      CssMetaData<? extends Styleable,T> getCssMetaData​()
      反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
      String getName​()
      返回此属性的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from class javafx.beans.property.ObjectProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ObjectPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.css.StyleableObjectProperty

        applyStyle, bind, getStyleOrigin, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • SimpleStyleableObjectProperty

        public SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData)
        SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty

      • SimpleStyleableObjectProperty

        public SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData,
                                     T initialValue)
        SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty
        initialValue - 包裹的初始值 Object

      • SimpleStyleableObjectProperty

        public SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData,
                                     Object bean,
                                     String name)
        SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        bean - 这个 ObjectProperty的豆
        name - 该名称 ObjectProperty

      • SimpleStyleableObjectProperty

        public SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData,
                                     Object bean,
                                     String name,
                                     T initialValue)
        SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty
        bean - 这个 ObjectProperty的豆
        name - 这个名字 ObjectProperty
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，此方法返回一个空的String 。
        结果
        名称或空的 String

      • getCssMetaData

        public final CssMetaData<? extends Styleable,T> getCssMetaData​()
        反映了对应于这个 javafx.beans.property.StyleableProperty
        结果
        the corresponding CssMetaData
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleStyleableStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class SimpleStyleableStringProperty

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
        • javafx.beans.property.StringProperty
          • javafx.beans.property.StringPropertyBase
            • javafx.css.StyleableStringProperty
              • javafx.css.SimpleStyleableStringProperty
  • All Implemented Interfaces:
    Observable ， Property<String> ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String> ， WritableObjectValue<String> ， WritableStringValue ， WritableValue<String> ， StyleableProperty<String>

    public class SimpleStyleableStringProperty
extends StyleableStringProperty
    该课程扩展了SimpleStringProperty并提供了一个StyleableProperty的完整实现。 这个类用于制作一个StringProperty ，否则将被实现为一个SimpleStringProperty ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    SimpleStringProperty ， CssMetaData ， StyleableProperty ， StyleableStringProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, String initialValue)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getBean​()
      返回包含此属性的 Object 。
      CssMetaData<? extends Styleable,String> getCssMetaData​()
      反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
      String getName​()
      返回此属性的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

      • Methods inherited from class javafx.beans.property.StringProperty

        bindBidirectional, bindBidirectional, bindBidirectional, setValue, unbindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.property.StringPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class javafx.css.StyleableStringProperty

        applyStyle, bind, getStyleOrigin, set

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • SimpleStyleableStringProperty

        public SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData)
        SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty

      • SimpleStyleableStringProperty

        public SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData,
                                     String initialValue)
        SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        initialValue - 包装的初始值 Object

      • SimpleStyleableStringProperty

        public SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData,
                                     Object bean,
                                     String name)
        SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
        参数
        cssMetaData - 与此 StyleableProperty关联的 StyleableProperty
        bean - 这个 StringProperty的豆
        name - 这个名字 StringProperty

      • SimpleStyleableStringProperty

        public SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData,
                                     Object bean,
                                     String name,
                                     String initialValue)
        SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
        参数
        cssMetaData - 与此 StyleableProperty相关联的 StyleableProperty
        bean - 这个 StringProperty的豆
        name - 这个名字 StringProperty
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • getBean

        public Object getBean​()
        返回包含此属性的Object 。 如果此属性未包含在Object ，则返回null 。
        结果
        包含 Object或 null

      • getName

        public String getName​()
        返回此属性的名称。 如果该属性没有名称，则此方法返回一个空的String 。
        结果
        名称或空 String

      • getCssMetaData

        public final CssMetaData<? extends Styleable,String> getCssMetaData​()
        反映了对应于这个 javafx.beans.property.StyleableProperty
        结果
        the corresponding CssMetaData
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Size (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class Size

  • java.lang.Object
    • javafx.css.Size

  • public final class Size
extends Object
    表示特定单位中指定的大小，例如14px或0.2em。
    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Constructor 描述
      Size​(double value, SizeUnits units)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      SizeUnits getUnits​()
      返回单位
      double getValue​()
      返回值
      int hashCode​()
      返回对象的哈希码值。
      boolean isAbsolute​()
      返回此Size是否为绝对值或相对值。
      double pixels​()
      调用 pixels(1)方便方法
      double pixels​(double multiplier, Font font)
      将此大小转换为像素
      double pixels​(Font font)
      如果尺寸不是绝对尺寸，请返回字体大小的乘积，以像素和值为单位。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Size

        public Size​(double value,
            SizeUnits units)

    • 方法详细信息

      • getValue

        public double getValue​()
        返回值
        结果
        价值

      • getUnits

        public SizeUnits getUnits​()
        返回单位
        结果
        单位

      • isAbsolute

        public boolean isAbsolute​()
        返回此Size是否为绝对值或相对值。
        结果
        如果是绝对的，则为true，否则为false

      • pixels

        public double pixels​(double multiplier,
                     Font font)
        将此大小转换为像素
        参数
        multiplier - PERCENTAGE大小的乘数
        font - EM尺寸的字体
        结果
        大小（以像素为单位）

      • pixels

        public double pixels​(Font font)
        如果尺寸不是绝对尺寸，请返回字体大小的乘积，以像素和值为单位。 否则返回绝对值。
        参数
        font - 字体
        结果
        像素的大小

      • pixels

        public double pixels​()
        调用 pixels(1)方便方法
        结果
        大小（以像素为单位）

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中的equals比较中没有使用的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode中的 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        描述从类复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空引用值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SizeUnits (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Enum SizeUnits

  • java.lang.Object
    • java.lang.Enum<SizeUnits>
      • javafx.css.SizeUnits
  • All Implemented Interfaces:
    Serializable ， Comparable<SizeUnits>

    public enum SizeUnits
extends Enum<SizeUnits>
    表示特定单位中指定的大小，例如14px或0.2em。
    从以下版本开始：
    9

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CM
      DEG
      EM
      EX
      GRAD
      IN
      MM
      MS
      PC
      PERCENT
      PT
      PX
      RAD
      S
      TURN

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      boolean | isAbsolute​()
      abstract double | pixels​(double value, double multiplier, Font font)
      abstract double | points​(double value, double multiplier, Font font)
      static SizeUnits valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SizeUnits[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PERCENT

        public static final SizeUnits PERCENT

      • IN

        public static final SizeUnits IN

      • CM

        public static final SizeUnits CM

      • MM

        public static final SizeUnits MM

      • EM

        public static final SizeUnits EM

      • EX

        public static final SizeUnits EX

      • PT

        public static final SizeUnits PT

      • PC

        public static final SizeUnits PC

      • PX

        public static final SizeUnits PX

      • DEG

        public static final SizeUnits DEG

      • GRAD

        public static final SizeUnits GRAD

      • RAD

        public static final SizeUnits RAD

      • TURN

        public static final SizeUnits TURN

      • S

        public static final SizeUnits S

      • MS

        public static final SizeUnits MS

    • 方法详细信息

      • values

        public static SizeUnits[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (SizeUnits c : SizeUnits.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static SizeUnits valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • points

        public abstract double points​(double value,
                              double multiplier,
                              Font font)

      • pixels

        public abstract double pixels​(double value,
                              double multiplier,
                              Font font)

      • isAbsolute

        public boolean isAbsolute​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Style (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class Style

  • java.lang.Object
    • javafx.css.Style

  • public final class Style
extends Object
    风格只是一个规则的选择器和声明。
    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Constructor 描述
      Style​(Selector selector, Declaration declaration)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      Declaration getDeclaration​()
      “宣言”是即将应用或刚刚应用的风格的来源。
      Selector getSelector​()
      选择器可能有多个选择器。
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Style

        public Style​(Selector selector,
             Declaration declaration)

    • 方法详细信息

      • getSelector

        public Selector getSelector​()
        选择器可能有多个选择器。 这是匹配的。
        结果
        匹配的选择器

      • getDeclaration

        public Declaration getDeclaration​()
        “宣言”是即将应用或刚刚应用的风格的来源。 如果值来自CSSProperty的初始（默认）值，则可以为null。
        结果
        声明

      • equals

        public boolean equals​(Object obj)
        说明从类别复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        equals方法对Object实现了最可区别的可能的等价关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals中的 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求，如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每一个上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Styleable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Interface Styleable

  • 所有已知实现类：
    Accordion ， AmbientLight ， AnchorPane ， Arc ， AreaChart ， Axis ， BarChart ， BorderPane ， Box ， BubbleChart ， Button ， ButtonBar ， ButtonBase ， Camera ， Canvas ， CategoryAxis ， Cell ， Chart ， CheckBox ， CheckBoxListCell ， CheckBoxTableCell ， CheckBoxTreeCell ， CheckBoxTreeTableCell ， CheckMenuItem ， ChoiceBox ， ChoiceBoxListCell ， ChoiceBoxTableCell ， ChoiceBoxTreeCell ， ChoiceBoxTreeTableCell ， Circle ， ColorPicker ， ComboBox ， ComboBoxBase ， ComboBoxListCell ， ComboBoxTableCell ， ComboBoxTreeCell ， ComboBoxTreeTableCell ， ContextMenu ， Control ， CubicCurve ， CustomMenuItem ， Cylinder ， DateCell ， DatePicker ， DialogPane ， Ellipse ， FlowPane ， GridPane ， Group ， HBox ， HTMLEditor ， Hyperlink ， ImageView ， IndexedCell ， Label ， Labeled Labeled ， LightBase ， Line ， LineChart ， ListCell ， ListView ， MediaView ， Menu ， MenuBar ， MenuButton ， MenuItem ， MeshView ， NestedTableColumnHeader ， Node ， NumberAxis ， Pagination ， Pane ， ParallelCamera ， Parent ， PasswordField ， Path ， PerspectiveCamera ， PieChart ， PointLight ， Polygon ， Polyline ， PopupControl ， PopupControl.CSSBridge ， ProgressBar ， ProgressBarTableCell ， ProgressBarTreeTableCell ， ProgressIndicator ， QuadCurve ， RadioButton ， RadioMenuItem ， Rectangle ， Region ， ScatterChart ， ScrollBar ， ScrollPane ， Separator ， SeparatorMenuItem ， Shape ， Shape3D ， Slider ， Sphere ， Spinner ， SplitMenuButton ， SplitPane ， StackedAreaChart ， StackedBarChart ， StackPane ， SubScene ， SVGPath ， SwingNode ， Tab ， TableCell TableCell ， TableColumn ， TableColumnBase ， TableColumnHeader ， TableHeaderRow ， TableRow ， TableView ， TabPane ， Text ， TextArea ， TextField ， TextFieldListCell ， TextFieldTableCell ， TextFieldTreeCell ， TextFieldTreeTableCell ， TextFlow ， TextInputControl ， TilePane ， TitledPane ， ToggleButton ， ToolBar ， Tooltip ， TreeCell ， TreeTableCell ， TreeTableColumn ， TreeTableRow ， TreeTableView ， TreeView ， ValueAxis ， VBox ， VirtualFlow ， WebView ， XYChart

    public interface Styleable
    Styleable包含对象被CSS样式所需的最小界面。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    CSS Reference Guide

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      这个样式的CssMetaData。
      String getId​()
      该 Styleable为 Styleable 。
      ObservableSet<PseudoClass> getPseudoClassStates​()
      返回此Styleable的伪类状态。
      String getStyle​()
      与此特定的 Node相关联的CSS样式的字符串表示 Node 。
      default Node getStyleableNode​()
      返回表示此Styleable对象的Node。
      Styleable getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      ObservableList<String> getStyleClass​()
      可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。
      String getTypeSelector​()
      这种 Styleable的类型用于选择器匹配。

    • 方法详细信息

      • getTypeSelector

        String getTypeSelector​()
        这种Styleable的类型用于选择器匹配。 这类似于HTML中的“元素”。 （ CSS Type Selector ）。
        结果
        这种类型的 Styleable

      • getId

        String getId​()
        该Styleable为Styleable 。 这个简单的字符串标识符可用于在场景图中查找特定的节点。 虽然节点的ID在场景图中应该是唯一的，但是这种唯一性不会被强制执行。 这类似于HTML元素（ CSS ID Specification ）上的“id”属性。

        例如，如果节点的ID为“myId”，则可以使用查找方法来查找此节点，如下所示： scene.lookup("#myId"); 。

        结果
        该 Styleable为 Styleable

      • getStyleClass

        ObservableList<String> getStyleClass​()
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。 该变量类似于HTML元素上的“类”属性，因此列表的每个元素都是此节点所属的样式类。
        结果
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎
        另请参见：
        CSS3 class selectors

      • getStyle

        String getStyle​()
        与此特定的Node相关联的CSS样式的字符串表示Node 。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        结果
        与此特定的 Node相关联的CSS样式的字符串表示 Node

      • getCssMetaData

        List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        这个样式的CssMetaData。 这可以作为不可修改的列表返回。
        结果
        CssMetaData

      • getStyleableParent

        Styleable getStyleableParent​()
        返回此Styleable的父项，如果没有父项则返回null。
        结果
        此样式的父项，如果没有父项则为null

      • getPseudoClassStates

        ObservableSet<PseudoClass> getPseudoClassStates​()
        返回此Styleable的伪类状态。 CSS假定此集是只读的。
        结果
        伪类状态

      • getStyleableNode

        default Node getStyleableNode​()
        返回表示此Styleable对象的Node。 在Styleable本身不是Node的情况下，应该覆盖此方法，以便它可以可选地返回其本身的相关根节点表示。 默认情况下，此方法返回null，这可能意味着Styleable本身是一个Node，如果不是这种情况，则Styleable在请求时没有可用的节点表示。
        结果
        表示此Styleable对象的节点
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleableBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleableBooleanProperty

  • java.lang.Object
    • javafx.beans.binding.BooleanExpression
      • javafx.beans.property.ReadOnlyBooleanProperty
        • javafx.beans.property.BooleanProperty
          • javafx.beans.property.BooleanPropertyBase
            • javafx.css.StyleableBooleanProperty
  • All Implemented Interfaces:
    Observable ， Property<Boolean> ， ReadOnlyProperty<Boolean> ， ObservableBooleanValue ， ObservableValue<Boolean> ， WritableBooleanValue ， WritableValue<Boolean> ， StyleableProperty<Boolean>
    已知直接子类：
    SimpleStyleableBooleanProperty

    public abstract class StyleableBooleanProperty
extends BooleanPropertyBase
implements StyleableProperty<Boolean>
    这个类扩展了BooleanPropertyBase并提供了一个StyleableProperty的部分实现。 方法StyleableProperty.getCssMetaData()未被实现。 这个类用于制作一个BooleanProperty ，否则将被实现为一个BooleanPropertyBase ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    BooleanPropertyBase ， CssMetaData ， StyleableProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleableBooleanProperty​()
      StyleableBooleanProperty的构造 StyleableBooleanProperty 。
      StyleableBooleanProperty​(boolean initialValue)
      StyleableBooleanProperty的构造 StyleableBooleanProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyStyle​(StyleOrigin origin, Boolean v)
      这个方法从CSS代码调用来设置属性的值。
      void bind​(ObservableValue<? extends Boolean> observable)
      为此创建一个单向绑定 Property 。
      StyleOrigin getStyleOrigin​()
      告诉物业的价值的起源。
      void set​(boolean v)
      设置包装的值。

      • Methods inherited from class javafx.beans.binding.BooleanExpression

        and, asString, booleanExpression, booleanExpression, getValue, isEqualTo, isNotEqualTo, not, or

      • Methods inherited from class javafx.beans.property.BooleanProperty

        asObject, bindBidirectional, booleanProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.BooleanPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyBooleanProperty

        readOnlyBooleanProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.css.StyleableProperty

        getCssMetaData

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • StyleableBooleanProperty

        public StyleableBooleanProperty​()
        StyleableBooleanProperty的构造 StyleableBooleanProperty 。

      • StyleableBooleanProperty

        public StyleableBooleanProperty​(boolean initialValue)
        StyleableBooleanProperty
        参数
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • applyStyle

        public void applyStyle​(StyleOrigin origin,
                       Boolean v)
        这个方法从CSS代码调用来设置属性的值。
        Specified by:
        applyStyle在接口 StyleableProperty<Boolean>
        参数
        origin - 起源
        v

      • bind

        public void bind​(ObservableValue<? extends Boolean> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。 注意：

        Specified by:
        bind在接口 Property<Boolean>
        重写：
        bind在 BooleanPropertyBase
        参数
        observable - 可观察到这个 Property应该绑定到。

      • set

        public void set​(boolean v)
        设置包装的值。 与WritableBooleanValue.setValue(java.lang.Boolean)不同，此方法使用原始布尔。
        Specified by:
        set在接口 WritableBooleanValue
        重写：
        set在 BooleanPropertyBase
        参数
        v - 新的价值

      • getStyleOrigin

        public StyleOrigin getStyleOrigin​()
        告诉物业的价值的起源。 这是需要确定CSS是否可以覆盖该值。
        Specified by:
        getStyleOrigin在接口 StyleableProperty<Boolean>
        结果
        风格起源
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleableDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleableDoubleProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.DoubleExpression
        • javafx.beans.property.ReadOnlyDoubleProperty
          • javafx.beans.property.DoubleProperty
            • javafx.beans.property.DoublePropertyBase
              • javafx.css.StyleableDoubleProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableDoubleValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableDoubleValue ， WritableNumberValue ， WritableValue<Number> ， StyleableProperty<Number>
    已知直接子类：
    SimpleStyleableDoubleProperty

    public abstract class StyleableDoubleProperty
extends DoublePropertyBase
implements StyleableProperty<Number>
    这个类扩展了DoublePropertyBase并提供了一个StyleableProperty的部分实现。 方法StyleableProperty.getCssMetaData()未被实现。 这个类用于制作一个DoubleProperty ，否则将被实现为一个DoublePropertyBase ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    DoublePropertyBase ， CssMetaData ， StyleableProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleableDoubleProperty​()
      StyleableDoubleProperty的构造 StyleableDoubleProperty 。
      StyleableDoubleProperty​(double initialValue)
      StyleableDoubleProperty的构造 StyleableDoubleProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      StyleOrigin getStyleOrigin​()
      告诉物业的价值的起源。
      void set​(double v)
      设置包装的值。

      • Methods inherited from class javafx.beans.binding.DoubleExpression

        add, add, add, add, add, divide, divide, divide, divide, divide, doubleExpression, doubleExpression, doubleValue, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.DoubleProperty

        asObject, bindBidirectional, doubleProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.DoublePropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        asString, asString, asString, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, numberExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyDoubleProperty

        readOnlyDoubleProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.css.StyleableProperty

        getCssMetaData

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • StyleableDoubleProperty

        public StyleableDoubleProperty​()
        StyleableDoubleProperty的构造 StyleableDoubleProperty 。

      • StyleableDoubleProperty

        public StyleableDoubleProperty​(double initialValue)
        StyleableDoubleProperty的构造 StyleableDoubleProperty 。
        参数
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • applyStyle

        public void applyStyle​(StyleOrigin origin,
                       Number v)
        这个方法从CSS代码调用来设置属性的值。
        Specified by:
        applyStyle在接口 StyleableProperty<Number>
        参数
        origin - 起源
        v - 值

      • bind

        public void bind​(ObservableValue<? extends Number> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<Number>
        重写：
        bind在 DoublePropertyBase
        参数
        observable - 可观察到这个 Property应该绑定到。

      • set

        public void set​(double v)
        设置包装的值。 与WritableDoubleValue.setValue(java.lang.Number)不同，此方法使用原语双。
        Specified by:
        set在接口 WritableDoubleValue
        重写：
        set在 DoublePropertyBase
        参数
        v - 新值

      • getStyleOrigin

        public StyleOrigin getStyleOrigin​()
        告诉物业的价值的起源。 这是需要确定CSS是否可以覆盖该值。
        Specified by:
        getStyleOrigin在接口 StyleableProperty<Number>
        结果
        风格起源
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleableFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleableFloatProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.FloatExpression
        • javafx.beans.property.ReadOnlyFloatProperty
          • javafx.beans.property.FloatProperty
            • javafx.beans.property.FloatPropertyBase
              • javafx.css.StyleableFloatProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableFloatValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableFloatValue ， WritableNumberValue ， WritableValue<Number> ， StyleableProperty<Number>
    已知直接子类：
    SimpleStyleableFloatProperty

    public abstract class StyleableFloatProperty
extends FloatPropertyBase
implements StyleableProperty<Number>
    这个类扩展了FloatPropertyBase并提供了一个StyleableProperty的部分实现。 方法StyleableProperty.getCssMetaData()未被实现。 这个类用于制作一个FloatProperty ，否则将被实现为一个FloatPropertyBase ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    FloatPropertyBase ， CssMetaData ， StyleableProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleableFloatProperty​()
      StyleableFloatProperty的构造 StyleableFloatProperty 。
      StyleableFloatProperty​(float initialValue)
      StyleableFloatProperty的构造 StyleableFloatProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      StyleOrigin getStyleOrigin​()
      告诉物业的价值的起源。
      void set​(float v)
      设置包装的值。

      • Methods inherited from class javafx.beans.binding.FloatExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatExpression, floatExpression, floatValue, getValue, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.FloatProperty

        asObject, bindBidirectional, floatProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.FloatPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyFloatProperty

        readOnlyFloatProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.css.StyleableProperty

        getCssMetaData

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • StyleableFloatProperty

        public StyleableFloatProperty​()
        StyleableFloatProperty的构造 StyleableFloatProperty 。

      • StyleableFloatProperty

        public StyleableFloatProperty​(float initialValue)
        StyleableFloatProperty的构造 StyleableFloatProperty 。
        参数
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • applyStyle

        public void applyStyle​(StyleOrigin origin,
                       Number v)
        这个方法从CSS代码调用来设置属性的值。
        Specified by:
        applyStyle接口 StyleableProperty<Number>
        参数
        origin - 起源
        v - 值

      • bind

        public void bind​(ObservableValue<? extends Number> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<Number>
        重写：
        bind在 FloatPropertyBase
        参数
        observable - 可观察到的这个 Property应该被绑定。

      • set

        public void set​(float v)
        设置包装的值。 与WritableFloatValue.setValue(java.lang.Number)不同，此方法使用原始浮点数。
        Specified by:
        set在接口 WritableFloatValue
        重写：
        set在 FloatPropertyBase
        参数
        v - 新值

      • getStyleOrigin

        public StyleOrigin getStyleOrigin​()
        告诉物业的价值的起源。 这是需要确定CSS是否可以覆盖该值。
        Specified by:
        getStyleOrigin在接口 StyleableProperty<Number>
        结果
        风格起源
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleableIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleableIntegerProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.IntegerExpression
        • javafx.beans.property.ReadOnlyIntegerProperty
          • javafx.beans.property.IntegerProperty
            • javafx.beans.property.IntegerPropertyBase
              • javafx.css.StyleableIntegerProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableIntegerValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableIntegerValue ， WritableNumberValue ， WritableValue<Number> ， StyleableProperty<Number>
    已知直接子类：
    SimpleStyleableIntegerProperty

    public abstract class StyleableIntegerProperty
extends IntegerPropertyBase
implements StyleableProperty<Number>
    这个类扩展了IntegerPropertyBase并提供了一个StyleableProperty的部分实现。 方法StyleableProperty.getCssMetaData()未被实现。 这个类用于制作一个IntegerProperty ，否则将被实现为一个IntegerPropertyBase ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    IntegerPropertyBase ， CssMetaData ， StyleableProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleableIntegerProperty​()
      StyleableIntegerProperty的构造 StyleableIntegerProperty 。
      StyleableIntegerProperty​(int initialValue)
      StyleableIntegerProperty的构造 StyleableIntegerProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      StyleOrigin getStyleOrigin​()
      告诉物业的价值的起源。
      void set​(int v)
      设置包装的值。

      • Methods inherited from class javafx.beans.binding.IntegerExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, integerExpression, integerExpression, intValue, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.IntegerProperty

        asObject, bindBidirectional, integerProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.IntegerPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyIntegerProperty

        readOnlyIntegerProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.css.StyleableProperty

        getCssMetaData

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • StyleableIntegerProperty

        public StyleableIntegerProperty​()
        StyleableIntegerProperty的构造 StyleableIntegerProperty 。

      • StyleableIntegerProperty

        public StyleableIntegerProperty​(int initialValue)
        StyleableIntegerProperty的构造 StyleableIntegerProperty 。
        参数
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • applyStyle

        public void applyStyle​(StyleOrigin origin,
                       Number v)
        这个方法从CSS代码调用来设置属性的值。
        Specified by:
        applyStyle在接口 StyleableProperty<Number>
        参数
        origin - 起源
        v - 值

      • bind

        public void bind​(ObservableValue<? extends Number> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<Number>
        重写：
        bind在 IntegerPropertyBase
        参数
        observable - 可观察到这个 Property应该绑定。

      • set

        public void set​(int v)
        设置包装的值。 与WritableIntegerValue.setValue(java.lang.Number)不同，此方法使用原语int。
        Specified by:
        set接口 WritableIntegerValue
        重写：
        set在 IntegerPropertyBase
        参数
        v - 新值

      • getStyleOrigin

        public StyleOrigin getStyleOrigin​()
        告诉物业的价值的起源。 这是需要确定CSS是否可以覆盖该值。
        Specified by:
        getStyleOrigin在接口 StyleableProperty<Number>
        结果
        风格起源
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleableLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleableLongProperty

  • java.lang.Object
    • javafx.beans.binding.NumberExpressionBase
      • javafx.beans.binding.LongExpression
        • javafx.beans.property.ReadOnlyLongProperty
          • javafx.beans.property.LongProperty
            • javafx.beans.property.LongPropertyBase
              • javafx.css.StyleableLongProperty
  • All Implemented Interfaces:
    NumberExpression ， Observable ， Property<Number> ， ReadOnlyProperty<Number> ， ObservableLongValue ， ObservableNumberValue ， ObservableValue<Number> ， WritableLongValue ， WritableNumberValue ， WritableValue<Number> ， StyleableProperty<Number>
    已知直接子类：
    SimpleStyleableLongProperty

    public abstract class StyleableLongProperty
extends LongPropertyBase
implements StyleableProperty<Number>
    这个类扩展了LongPropertyBase并提供了一个StyleableProperty的部分实现。 方法StyleableProperty.getCssMetaData()未被实现。 这个类用于制作一个LongProperty ，否则将被实现为一个LongPropertyBase ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    LongPropertyBase ， CssMetaData ， StyleableProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleableLongProperty​()
      StyleableLongProperty的构造 StyleableLongProperty 。
      StyleableLongProperty​(long initialValue)
      StyleableLongProperty的构造 StyleableLongProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      StyleOrigin getStyleOrigin​()
      告诉物业的价值的起源。
      void set​(long v)
      设置包装的值。

      • Methods inherited from class javafx.beans.binding.LongExpression

        add, add, add, add, divide, divide, divide, divide, doubleValue, floatValue, getValue, intValue, longExpression, longExpression, longValue, multiply, multiply, multiply, multiply, negate, subtract, subtract, subtract, subtract

      • Methods inherited from class javafx.beans.property.LongProperty

        asObject, bindBidirectional, longProperty, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.LongPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from class javafx.beans.binding.NumberExpressionBase

        add, asString, asString, asString, divide, greaterThan, greaterThan, greaterThan, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, greaterThanOrEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, isNotEqualTo, lessThan, lessThan, lessThan, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, lessThanOrEqualTo, multiply, numberExpression, subtract

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from class javafx.beans.property.ReadOnlyLongProperty

        readOnlyLongProperty

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.css.StyleableProperty

        getCssMetaData

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • StyleableLongProperty

        public StyleableLongProperty​()
        StyleableLongProperty的构造 StyleableLongProperty 。

      • StyleableLongProperty

        public StyleableLongProperty​(long initialValue)
        StyleableLongProperty的构造 StyleableLongProperty 。
        参数
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • applyStyle

        public void applyStyle​(StyleOrigin origin,
                       Number v)
        这个方法从CSS代码调用来设置属性的值。
        Specified by:
        applyStyle在接口 StyleableProperty<Number>
        参数
        origin - 起源
        v - 值

      • bind

        public void bind​(ObservableValue<? extends Number> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<Number>
        重写：
        bind在 LongPropertyBase
        参数
        observable - 可观察这 Property应该绑定。

      • set

        public void set​(long v)
        设置包装的值。 与WritableLongValue.setValue(java.lang.Number)不同，此方法使用原始long。
        Specified by:
        set在接口 WritableLongValue
        重写：
        set在 LongPropertyBase
        参数
        v - 新值

      • getStyleOrigin

        public StyleOrigin getStyleOrigin​()
        告诉物业的价值的起源。 这是需要确定CSS是否可以覆盖该值。
        Specified by:
        getStyleOrigin在接口 StyleableProperty<Number>
        结果
        风格起源
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleableObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleableObjectProperty<T>

  • java.lang.Object
    • javafx.beans.binding.ObjectExpression<T>
      • javafx.beans.property.ReadOnlyObjectProperty<T>
        • javafx.beans.property.ObjectProperty<T>
          • javafx.beans.property.ObjectPropertyBase<T>
            • javafx.css.StyleableObjectProperty<T>
  • All Implemented Interfaces:
    Observable ， Property<T> ， ReadOnlyProperty<T> ， ObservableObjectValue<T> ， ObservableValue<T> ， WritableObjectValue<T> ， WritableValue<T> ， StyleableProperty<T>
    已知直接子类：
    SimpleStyleableObjectProperty

    public abstract class StyleableObjectProperty<T>
extends ObjectPropertyBase<T>
implements StyleableProperty<T>
    这个类扩展了ObjectPropertyBase并提供了一个StyleableProperty的部分实现。 方法StyleableProperty.getCssMetaData()未被实现。 这个类用于制作一个ObjectProperty ，否则将被实现为一个ObjectPropertyBase ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    ObjectPropertyBase ， CssMetaData ， StyleableProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleableObjectProperty​()
      StyleableObjectProperty的构造 StyleableObjectProperty 。
      StyleableObjectProperty​(T initialValue)
      StyleableObjectProperty的构造 StyleableObjectProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyStyle​(StyleOrigin origin, T v)
      这个方法从CSS代码调用来设置属性的值。
      void bind​(ObservableValue<? extends T> observable)
      为此创建一个单向绑定 Property 。
      StyleOrigin getStyleOrigin​()
      告诉物业的价值的起源。
      void set​(T v)
      设置包装的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.beans.binding.ObjectExpression

        asString, asString, asString, getValue, isEqualTo, isEqualTo, isNotEqualTo, isNotEqualTo, isNotNull, isNull, objectExpression

      • Methods inherited from class javafx.beans.property.ObjectProperty

        bindBidirectional, setValue, unbindBidirectional

      • Methods inherited from class javafx.beans.property.ObjectPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from interface javafx.css.StyleableProperty

        getCssMetaData

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • StyleableObjectProperty

        public StyleableObjectProperty​()
        StyleableObjectProperty的构造 StyleableObjectProperty 。

      • StyleableObjectProperty

        public StyleableObjectProperty​(T initialValue)
        StyleableObjectProperty的构造 StyleableObjectProperty 。
        参数
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • applyStyle

        public void applyStyle​(StyleOrigin origin,
                       T v)
        这个方法从CSS代码调用来设置属性的值。
        Specified by:
        applyStyle在接口 StyleableProperty<T>
        参数
        origin - 起源
        v - 值

      • bind

        public void bind​(ObservableValue<? extends T> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<T>
        重写：
        bind在 ObjectPropertyBase<T>
        参数
        observable - 可观察到这个 Property应该绑定。

      • set

        public void set​(T v)
        设置包装的值。 应该相当于WritableValue.setValue(java.lang.Object)
        Specified by:
        set在接口 WritableObjectValue<T>
        重写：
        set在 ObjectPropertyBase<T>
        参数
        v - 新的价值
        另请参见：
        WritableObjectValue.get()

      • getStyleOrigin

        public StyleOrigin getStyleOrigin​()
        告诉物业的价值的起源。 这是需要确定CSS是否可以覆盖该值。
        Specified by:
        getStyleOrigin在接口 StyleableProperty<T>
        结果
        风格起源
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleableProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Interface StyleableProperty<T>

  • 参数类型
    T - 具体属性
    All Superinterfaces:
    WritableValue<T>
    所有已知实现类：
    SimpleStyleableBooleanProperty ， SimpleStyleableDoubleProperty ， SimpleStyleableFloatProperty ， SimpleStyleableIntegerProperty ， SimpleStyleableLongProperty ， SimpleStyleableObjectProperty ， SimpleStyleableStringProperty ， StyleableBooleanProperty ， StyleableDoubleProperty ， StyleableFloatProperty ， StyleableIntegerProperty ， StyleableLongProperty ， StyleableObjectProperty ， StyleableStringProperty

    public interface StyleableProperty<T>
extends WritableValue<T>
    StyleableProperty允许一个javafx.beans.property从CSS样式。

    此接口允许CSS处理和javafx.beans.property之间的协调。 实施确保设置值的优先级按照增加的顺序并承担相同的重要性：

    1. 来自Application.setUserAgentStylesheet(java.lang.String)中的用户代理样式表的样式
    2. 值从代码设置，例如调用Node.setOpacity(double)
    3. 一个来自作者样式的样式在Scene.getStylesheets()或Parent.getStylesheets()
    4. 一种风格从Node.setStyle(java.lang.String)

    StyleablePropertyFactory大大简化了创建一个StyleableProperty及其相应的CssMetaData。

    从以下版本开始：
    JavaFX 8.0
    另请参见：
    StyleablePropertyFactory

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void applyStyle​(StyleOrigin origin, T value)
      这个方法从CSS代码调用来设置属性的值。
      CssMetaData<? extends Styleable,T> getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      StyleOrigin getStyleOrigin​()
      告诉物业的价值的起源。

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 方法详细信息

      • applyStyle

        void applyStyle​(StyleOrigin origin,
                T value)
        这个方法从CSS代码调用来设置属性的值。
        参数
        origin - 起源
        value - 值

      • getStyleOrigin

        StyleOrigin getStyleOrigin​()
        告诉物业的价值的起源。 这是需要确定CSS是否可以覆盖该值。
        结果
        风格起源

      • getCssMetaData

        CssMetaData<? extends Styleable,T> getCssMetaData​()
        反映了对应于这个 javafx.beans.property.StyleableProperty
        结果
        相应的CssMetaData
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleablePropertyFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleablePropertyFactory<S extends Styleable>

  • java.lang.Object
    • javafx.css.StyleablePropertyFactory<S>
  • 参数类型
    S - S的类型

    public class StyleablePropertyFactory<S extends Styleable>
extends Object
    使用相应的CssMetaData创建StyleableProperty实例的方法。 这些方法大大减少了实现StyleableProperty和CssMetaData所需的锅炉代码的数量。 这些方法采用函数<？ 扩展Styleable，StyleableProperty <？>>，返回对属性本身的引用。 参见下面的例子。 请注意，为了有效利用内存和更好的CSS性能，建议使用StyleablePropertyFactory作为静态成员，如下所示。
       public final class MyButton extends Button { private static final StyleablePropertyFactory<MyButton> FACTORY = new StyleablePropertyFactory<>(Button.getClassCssMetaData()); MyButton(String labelText) { super(labelText); getStyleClass().add("my-button"); } // Typical JavaFX property implementation public ObservableValue<Boolean> selectedProperty() { return (ObservableValue<Boolean>)selected; } public final boolean isSelected() { return selected.getValue(); } public final void setSelected(boolean isSelected) { selected.setValue(isSelected); } // StyleableProperty implementation reduced to one line private final StyleableProperty<Boolean> selected = FACTORY.createStyleableBooleanProperty(this, "selected", "-my-selected", s -> s.selected); @Override public List<CssMetaData<? extends Styleable, ?>> getControlCssMetaData() { return FACTORY.getCssMetaData(); } }

    上面的例子是StyleablePropertyFactory的最简单的StyleablePropertyFactory 。 但是，此用法不提供对于getClassCssMetaData()有用的静态getClassCssMetaData() ，这在CssMetaData的javadoc中有描述。 然而，静态CssMetaData可以通过StyleablePropertyFactory方法创建，并且将由创建StyleableProperty实例的方法返回，如下面的示例所示。 请注意，静态方法getClassCssMetaData()是在整个JavaFX代码库中使用的约定，但是getClassCssMetaData()方法本身不在运行时使用。

       public final class MyButton extends Button { private static final StyleablePropertyFactory<MyButton> FACTORY = new StyleablePropertyFactory<>(Button.getClassCssMetaData()); private static final CssMetaData<MyButton, Boolean> SELECTED = FACTORY.createBooleanCssMetaData("-my-selected", s -> s.selected, false, false); MyButton(String labelText) { super(labelText); getStyleClass().add("my-button"); } // Typical JavaFX property implementation public ObservableValue<Boolean> selectedProperty() { return (ObservableValue<Boolean>)selected; } public final boolean isSelected() { return selected.getValue(); } public final void setSelected(boolean isSelected) { selected.setValue(isSelected); } // StyleableProperty implementation reduced to one line private final StyleableProperty<Boolean> selected = new SimpleStyleableBooleanProperty(SELECTED, this, "selected"); public static List<CssMetaData<? extends Styleable, ?>> getClassCssMetaData() { return FACTORY.getCssMetaData(); } @Override public List<CssMetaData<? extends Styleable, ?>> getControlCssMetaData() { return FACTORY.getCssMetaData(); } }

    同样的内容可以通过内部类来实现。 前面的例子叫做new SimpleStyleableBooleanProperty来创建selected属性。 此示例使用工厂来访问与匿名内部类一起创建的CssMetaData 。 对于所有意图和目的，这两个例子是一样的。

       public final class MyButton extends Button { private static final StyleablePropertyFactory<MyButton> FACTORY = new StyleablePropertyFactory<>(Button.getClassCssMetaData()) { { createBooleanCssMetaData("-my-selected", s -> s.selected, false, false); } } MyButton(String labelText) { super(labelText); getStyleClass().add("my-button"); } // Typical JavaFX property implementation public ObservableValue<Boolean> selectedProperty() { return (ObservableValue<Boolean>)selected; } public final boolean isSelected() { return selected.getValue(); } public final void setSelected(boolean isSelected) { selected.setValue(isSelected); } // StyleableProperty implementation reduced to one line private final StyleableProperty<Boolean> selected = new SimpleStyleableBooleanProperty(this, "selected", "my-selected"); public static List<CssMetaData<? extends Styleable, ?>> getClassCssMetaData() { return FACTORY.getCssMetaData(); } @Override public List<CssMetaData<? extends Styleable, ?>> getControlCssMetaData() { return FACTORY.getCssMetaData(); } }

    注意事项：

    创建具有数字值的StyleableProperty的唯一选项是创建一个StyleableProperty <Number>。 getValue()方法的返回值是一个数字。 因此，JavaFX属性的get方法需要为返回类型调用正确的value方法。 例如，
       public ObservableValue<Double> offsetProperty() { return (ObservableValue<Double>)offset; } public Double getOffset() { return offset.getValue().doubleValue(); } public void setOffset(Double value) { offset.setValue(value); } private final StyleableProperty<Number> offset = FACTORY.createStyleableNumberProperty(this, "offset", "-my-offset", s -> ((MyButton)s).offset);
    从以下版本开始：
    JavaFX 8u40

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleablePropertyFactory​(List<CssMetaData<? extends Styleable,?>> parentCssMetaData)
      构造方法通过父类的父类CssMetaData传递，通常是通过调用父类的静态方法 getClassCssMetaData() 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CssMetaData<S,Boolean> createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function)
      创建一个具有初始值的CssMetaData <S，Boolean>，并继承标志，两者都默认为false。
      CssMetaData<S,Boolean> createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建具有初始值的CssMetaData <S，Boolean>，并将标志默认为false。
      CssMetaData<S,Boolean> createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Boolean>，并继承标志。
      CssMetaData<S,Color> createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function)
      创建一个CssMetaData <S，Color>，初始值为Color.BLACK，并继承标志默认为false。
      CssMetaData<S,Color> createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。
      CssMetaData<S,Color> createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Color>并继承标志。
      CssMetaData<S,Duration> createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function)
      创建一个具有Duration.BLACK的初始值的CssMetaData <S，Duration>，并将标志默认为false。
      CssMetaData<S,Duration> createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。
      CssMetaData<S,Duration> createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Duration>并继承标志。
      <E extends Effect>
      CssMetaData<S,E>             		createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，Effect>，初始值为null，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，Effect>，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Effect>并继承标志。
      <E extends Enum<E>>
      CssMetaData<S,E>             		createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，枚举>，并继承标志。
      CssMetaData<S,Font> createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function)
      创建CssMetaData <S，Font>，初始值为 Font.getDefault() ，并将标志默认为true。
      CssMetaData<S,Font> createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。
      CssMetaData<S,Font> createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的CssMetaData <S，Font>并继承标志。
      CssMetaData<S,Insets> createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function)
      创建CssMetaData <S，Insets>，初始值为 Insets.EMPTY ，并将标志默认为false。
      CssMetaData<S,Insets> createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。
      CssMetaData<S,Insets> createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Insets>并继承标志。
      CssMetaData<S,Paint> createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function)
      使用Color.BLACK的初始值创建一个CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Paint>并继承标志。
      CssMetaData<S,Number> createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function)
      创建CssMetaData <S，Number>，初始值为 0d ，并将标志默认为false。
      CssMetaData<S,Number> createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。
      CssMetaData<S,Number> createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Number>，并继承标志。
      CssMetaData<S,String> createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function)
      创建CssMetaData <S，String>，初始值为null，并将标志默认为false。
      CssMetaData<S,String> createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)
      创建具有初始值的CssMetaData <S，String>，并将标志默认为false。
      CssMetaData<S,String> createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，String>并继承标志。
      StyleableProperty<Boolean> createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty)
      创建一个StyleableProperty <Boolean>，使用先前创建的给定的 cssProperty 。
      StyleableProperty<Boolean> createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function)
      创建一个StyleableProperty <Boolean>。
      StyleableProperty<Boolean> createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建一个具有初始值的StyleableProperty <Boolean>。
      StyleableProperty<Boolean> createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Boolean>并继承标志。
      StyleableProperty<Color> createStyleableColorProperty​(S styleable, String propertyName, String cssProperty)
      创建一个StyleableProperty <Color>使用以前创建的CssMetaData为给定的 cssProperty 。
      StyleableProperty<Color> createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function)
      创建一个StyleableProperty <Color>。
      StyleableProperty<Color> createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建一个具有初始值的StyleableProperty <Color>。
      StyleableProperty<Color> createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Color>并继承标志。
      StyleableProperty<Duration> createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty)
      创建一个StyleableProperty <Duration>使用先前创建的CssMetaData给定的 cssProperty 。
      StyleableProperty<Duration> createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function)
      创建一个StyleableProperty <Duration>。
      StyleableProperty<Duration> createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建一个具有初始值的StyleableProperty <Duration>。
      StyleableProperty<Duration> createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Duration>并继承标志。
      StyleableProperty<Effect> createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty)
      创建一个StyleableProperty <Effect>使用以前创建的CssMetaData为给定的 cssProperty 。
      <E extends Enum<E>>
      StyleableProperty<E>             		createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Class<E> enumClass)
      创建一个StyleableProperty <E扩展枚举<E >>，使用之前创建的CssMetaData给定的 cssProperty 。
      <E extends Effect>
      StyleableProperty<E>             		createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function)
      创建一个StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue)
      创建一个具有初始值的StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Effect>并继承标志。
      <E extends Enum<E>>
      StyleableProperty<E>             		createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass)
      创建一个StyleableProperty <E extends Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue)
      创建一个StyleableProperty <E使用初始值扩展Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue, boolean inherits)
      创建一个StyleableProperty <E使用初始值扩展枚举<E >>并继承标志。
      StyleableProperty<Font> createStyleableFontProperty​(S styleable, String propertyName, String cssProperty)
      创建一个StyleableProperty <Font>使用以前创建的CssMetaData为给定的 cssProperty 。
      StyleableProperty<Font> createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function)
      创建一个StyleableProperty <Font>。
      StyleableProperty<Font> createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建一个具有初始值的StyleableProperty <Font>。
      StyleableProperty<Font> createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Font>并继承标志。
      StyleableProperty<Insets> createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty)
      创建一个StyleableProperty <Insets>使用以前创建的CssMetaData为给定的 cssProperty 。
      StyleableProperty<Insets> createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function)
      创建一个StyleableProperty <Inset>。
      StyleableProperty<Insets> createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建一个具有初始值的StyleableProperty <Inset>。
      StyleableProperty<Insets> createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Inset>并继承标志。
      StyleableProperty<Number> createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty)
      使用之前创建的CssMetaData为给定的 cssProperty创建一个StyleableProperty <Number>。
      StyleableProperty<Number> createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function)
      创建一个StyleableProperty <Number>。
      StyleableProperty<Number> createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建一个具有初始值的StyleableProperty <Number>。
      StyleableProperty<Number> createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Number>并继承标志。
      StyleableProperty<Paint> createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty)
      使用之前创建的CssMetaData为给定的 cssProperty创建一个StyleableProperty <Paint>。
      StyleableProperty<Paint> createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function)
      创建一个StyleableProperty <Paint>。
      StyleableProperty<Paint> createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建一个具有初始值的StyleableProperty <Paint>。
      StyleableProperty<Paint> createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Paint>并继承标志。
      StyleableProperty<String> createStyleableStringProperty​(S styleable, String propertyName, String cssProperty)
      创建一个StyleableProperty <String>使用先前创建的CssMetaData为给定的 cssProperty 。
      StyleableProperty<String> createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)
      创建一个StyleableProperty <String>。
      StyleableProperty<String> createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <String>并继承标志。
      StyleableProperty<String> createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty)
      创建一个StyleableProperty <String>，使用以前创建的给定的 cssProperty 。
      StyleableProperty<String> createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <String>并继承标志。
      CssMetaData<S,String> createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function)
      创建CssMetaData <S，String>，初始值为null，并将标志默认为false。
      CssMetaData<S,String> createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)
      创建具有初始值的CssMetaData <S，String>，并将标志默认为false。
      CssMetaData<S,String> createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，String>并继承标志。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      获取给定Styleable的CssMetaData。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyleablePropertyFactory

        public StyleablePropertyFactory​(List<CssMetaData<? extends Styleable,?>> parentCssMetaData)
        构造函数通过父类的CssMetaData传递，通常通过调用父类的静态方法 getClassCssMetaData() 。
        参数
        parentCssMetaData - <S>的父类的CssMetaData，或null。

    • 方法详细信息

      • getCssMetaData

        public final List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        获取给定Styleable的CssMetaData。 对于除控件之外的节点，此方法应从Styleable.getCssMetaData()方法调用。 对于控件，此方法应从Control.getControlCssMetaData()方法调用。
        结果
        给定Style的CssMetaData

      • createStyleableBooleanProperty

        public final StyleableProperty<Boolean> createStyleableBooleanProperty​(S styleable,
                                                                       String propertyName,
                                                                       String cssProperty,
                                                                       Function<S,StyleableProperty<Boolean>> function,
                                                                       boolean initialValue,
                                                                       boolean inherits)
        创建一个具有初始值的StyleableProperty <Boolean>并继承标志。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Boolean>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Boolean>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableBooleanProperty

        public final StyleableProperty<Boolean> createStyleableBooleanProperty​(S styleable,
                                                                       String propertyName,
                                                                       String cssProperty,
                                                                       Function<S,StyleableProperty<Boolean>> function,
                                                                       boolean initialValue)
        创建一个具有初始值的StyleableProperty <Boolean>。 inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Boolean>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Boolean>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty

      • createStyleableBooleanProperty

        public final StyleableProperty<Boolean> createStyleableBooleanProperty​(S styleable,
                                                                       String propertyName,
                                                                       String cssProperty,
                                                                       Function<S,StyleableProperty<Boolean>> function)
        创建一个StyleableProperty <Boolean>。 initialValue和inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Boolean>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Boolean>的函数。
        结果
        使用默认的initialValue和inherit标志创建的StyleableProperty

      • createStyleableBooleanProperty

        public final StyleableProperty<Boolean> createStyleableBooleanProperty​(S styleable,
                                                                       String propertyName,
                                                                       String cssProperty)
        创建一个StyleableProperty <Boolean>使用先前创建的给定的 cssProperty 。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Boolean>的字段名称
        cssProperty - CSS属性名称
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前没有创建cssProperty的 cssProperty

      • createStyleableColorProperty

        public final StyleableProperty<Color> createStyleableColorProperty​(S styleable,
                                                                   String propertyName,
                                                                   String cssProperty,
                                                                   Function<S,StyleableProperty<Color>> function,
                                                                   Color initialValue,
                                                                   boolean inherits)
        创建一个具有初始值的StyleableProperty <Color>并继承标志。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Color>的字段名称
        cssProperty - CSS属性名称
        function - 返回通过此方法调用创建的StyleableProperty <Color>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableColorProperty

        public final StyleableProperty<Color> createStyleableColorProperty​(S styleable,
                                                                   String propertyName,
                                                                   String cssProperty,
                                                                   Function<S,StyleableProperty<Color>> function,
                                                                   Color initialValue)
        创建一个具有初始值的StyleableProperty <Color>。 inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Color>的字段名称
        cssProperty - CSS属性名称
        function - 返回通过此方法调用创建的StyleableProperty <Color>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty

      • createStyleableColorProperty

        public final StyleableProperty<Color> createStyleableColorProperty​(S styleable,
                                                                   String propertyName,
                                                                   String cssProperty,
                                                                   Function<S,StyleableProperty<Color>> function)
        创建一个StyleableProperty <Color>。 初始值默认为Color.BLACK，并且inherit标志默认为false。
        参数
        styleable - 返回属性的this参考。 这也是属性bean。
        propertyName - StyleableProperty <Color>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Color>的函数。
        结果
        使用默认初始值创建的StyleableProperty并继承标志

      • createStyleableColorProperty

        public final StyleableProperty<Color> createStyleableColorProperty​(S styleable,
                                                                   String propertyName,
                                                                   String cssProperty)
        使用之前创建的CssMetaData为给定的 cssProperty创建一个StyleableProperty <Color>。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Color>的字段名称
        cssProperty - CSS属性名称
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前没有创建cssProperty的 cssProperty

      • createStyleableDurationProperty

        public final StyleableProperty<Duration> createStyleableDurationProperty​(S styleable,
                                                                         String propertyName,
                                                                         String cssProperty,
                                                                         Function<S,StyleableProperty<Duration>> function,
                                                                         Duration initialValue,
                                                                         boolean inherits)
        创建一个具有初始值的StyleableProperty <Duration>并继承标志。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Duration>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Duration>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableDurationProperty

        public final StyleableProperty<Duration> createStyleableDurationProperty​(S styleable,
                                                                         String propertyName,
                                                                         String cssProperty,
                                                                         Function<S,StyleableProperty<Duration>> function,
                                                                         Duration initialValue)
        创建一个具有初始值的StyleableProperty <Duration>。 inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Duration>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Duration>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleableDurationProperty

        public final StyleableProperty<Duration> createStyleableDurationProperty​(S styleable,
                                                                         String propertyName,
                                                                         String cssProperty,
                                                                         Function<S,StyleableProperty<Duration>> function)
        创建一个StyleableProperty <Duration>。 初始值默认为Duration.BLACK，并且inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Duration>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Duration>的函数。
        结果
        使用默认初始值创建的StyleableProperty和false inherit标志

      • createStyleableDurationProperty

        public final StyleableProperty<Duration> createStyleableDurationProperty​(S styleable,
                                                                         String propertyName,
                                                                         String cssProperty)
        创建一个StyleableProperty <Duration>使用之前创建的CssMetaData给定的 cssProperty 。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Duration>的字段名称
        cssProperty - CSS属性名称
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前未创建cssProperty的 cssProperty

      • createStyleableEffectProperty

        public final <E extends Effect> StyleableProperty<E> createStyleableEffectProperty​(S styleable,
                                                                                String propertyName,
                                                                                String cssProperty,
                                                                                Function<S,StyleableProperty<E>> function,
                                                                                E initialValue,
                                                                                boolean inherits)
        创建一个具有初始值的StyleableProperty <Effect>并继承标志。
        参数类型
        E - E的类型
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Effect>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Effect>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableEffectProperty

        public final <E extends Effect> StyleableProperty<E> createStyleableEffectProperty​(S styleable,
                                                                                String propertyName,
                                                                                String cssProperty,
                                                                                Function<S,StyleableProperty<E>> function,
                                                                                E initialValue)
        创建一个具有初始值的StyleableProperty <Effect>。 inherit标志默认为false。
        参数类型
        E - 使用初始值创建的StyleableProperty和false inherit标志
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Effect>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Effect>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleableEffectProperty

        public final <E extends Effect> StyleableProperty<E> createStyleableEffectProperty​(S styleable,
                                                                                String propertyName,
                                                                                String cssProperty,
                                                                                Function<S,StyleableProperty<E>> function)
        创建一个StyleableProperty <Effect>。 初始值为null，继承标志默认为false。
        参数类型
        E - 使用null初始值创建的StyleableProperty和false inherit标志
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Effect>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Effect>的函数。
        结果
        使用null初始值和false inherit标志创建的StyleableProperty

      • createStyleableEffectProperty

        public final StyleableProperty<Effect> createStyleableEffectProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty)
        创建一个StyleableProperty <Effect>使用以前创建的CssMetaData为给定的 cssProperty 。
        参数
        styleable - 返回属性的this参考。 这也是属性bean。
        propertyName - StyleableProperty <Effect>的字段名称
        cssProperty - CSS属性名称
        结果
        StyleableProperty创建使用以前创建的CssMetaData为给定的 cssProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前未创建cssProperty的 cssProperty

      • createStyleableEnumProperty

        public final <E extends Enum<E>> StyleableProperty<E> createStyleableEnumProperty​(S styleable,
                                                                                String propertyName,
                                                                                String cssProperty,
                                                                                Function<S,StyleableProperty<E>> function,
                                                                                Class<E> enumClass,
                                                                                E initialValue,
                                                                                boolean inherits)
        创建一个StyleableProperty <E使用初始值扩展枚举<E >>并继承标志。 enumClass参数是属性的值的枚举类。 例如，
           private static final StyleablePropertyFactory<MyControl> FACTORY = new StyleablePropertyFactory<>(); StyleableProperty<Orientation> orientation = FACTORY.createStyleableEnumProperty( this, "orientation", "-my-orientation", s -> ((MyControl)s).orientation, Orientation.class, Orientation.HORIZONTAL, false);
        参数类型
        E - 使用初始值创建的StyleableProperty并继承标志
        参数
        styleable - 返回属性的this参考。 这也是属性bean。
        propertyName - StyleableProperty <E的字段名称扩展枚举<E >>
        cssProperty - CSS属性名称
        function - 返回StyleableProperty <E的函数扩展通过此方法调用创建的枚举<E >>。
        enumClass - 作为StyleableProperty <E的类型的枚举类扩展枚举<E >>。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableEnumProperty

        public final <E extends Enum<E>> StyleableProperty<E> createStyleableEnumProperty​(S styleable,
                                                                                String propertyName,
                                                                                String cssProperty,
                                                                                Function<S,StyleableProperty<E>> function,
                                                                                Class<E> enumClass,
                                                                                E initialValue)
        创建一个StyleableProperty <E使用初始值扩展Enum <E >>。 inherit标志默认为false。 enumClass参数是属性的值的枚举类。 例如，
           private static final StyleablePropertyFactory<MyControl> FACTORY = new StyleablePropertyFactory<>(); StyleableProperty<Orientation> orientation = FACTORY.createStyleableEnumProperty( this, "orientation", "-my-orientation", s -> ((MyControl)s).orientation, Orientation.class, Orientation.HORIZONTAL);
        参数类型
        E - 使用初始值创建的StyleableProperty和false inherit标志
        参数
        styleable - 返回的属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <E扩展枚举<E >>的字段名称
        cssProperty - CSS属性名称
        function - 返回StyleableProperty <E的函数扩展通过此方法调用创建的枚举<E >>。
        enumClass - 作为StyleableProperty <E的类型的枚举类扩展枚举<E >>。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleableEnumProperty

        public final <E extends Enum<E>> StyleableProperty<E> createStyleableEnumProperty​(S styleable,
                                                                                String propertyName,
                                                                                String cssProperty,
                                                                                Function<S,StyleableProperty<E>> function,
                                                                                Class<E> enumClass)
        创建一个StyleableProperty <E extends Enum <E >>。 初始值为null，继承标志默认为false。 enumClass参数是属性的值的枚举类。 例如，
           private static final StyleablePropertyFactory<MyControl> FACTORY = new StyleablePropertyFactory<>(); StyleableProperty<Orientation> orientation = FACTORY.createStyleableEnumProperty( this, "orientation", "-my-orientation", s -> ((MyControl)s).orientation, Orientation.class);
        参数类型
        E - 使用null初始值创建的StyleableProperty和false inherit标志
        参数
        styleable - 返回的属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <E的字段名称扩展枚举<E >>
        cssProperty - CSS属性名称
        function - 返回StyleableProperty <E的函数扩展通过此方法调用创建的枚举<E >>。
        enumClass - 作为StyleableProperty <E的类型的枚举类扩展枚举<E >>。
        结果
        使用null初始值和false inherit标志创建的StyleableProperty

      • createStyleableEffectProperty

        public final <E extends Enum<E>> StyleableProperty<E> createStyleableEffectProperty​(S styleable,
                                                                                String propertyName,
                                                                                String cssProperty,
                                                                                Class<E> enumClass)
        创建一个StyleableProperty <E扩展枚举<E >>，使用先前创建的CssMetaData为给定的 cssProperty 。
        参数类型
        E - 使用先前创建的CssMetaData创建的StyleableProperty
        参数
        styleable - 返回的属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <E的字段名扩展枚举<E >>
        cssProperty - CSS属性名称
        enumClass - 作为StyleableProperty <E的类型的枚举类扩展枚举<E >>。
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前没有创建cssProperty的 cssProperty

      • createStyleableFontProperty

        public final StyleableProperty<Font> createStyleableFontProperty​(S styleable,
                                                                 String propertyName,
                                                                 String cssProperty,
                                                                 Function<S,StyleableProperty<Font>> function,
                                                                 Font initialValue,
                                                                 boolean inherits)
        创建一个具有初始值的StyleableProperty <Font>并继承标志。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Font>的字段名称
        cssProperty - CSS属性名称
        function - 返回通过此方法调用创建的StyleableProperty <Font>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableFontProperty

        public final StyleableProperty<Font> createStyleableFontProperty​(S styleable,
                                                                 String propertyName,
                                                                 String cssProperty,
                                                                 Function<S,StyleableProperty<Font>> function,
                                                                 Font initialValue)
        创建一个具有初始值的StyleableProperty <Font>。 inherit标志默认为true。
        参数
        styleable - 返回的属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Font>的字段名称
        cssProperty - CSS属性名称
        function - 返回通过此方法调用创建的StyleableProperty <Font>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty和true inherit标志

      • createStyleableFontProperty

        public final StyleableProperty<Font> createStyleableFontProperty​(S styleable,
                                                                 String propertyName,
                                                                 String cssProperty,
                                                                 Function<S,StyleableProperty<Font>> function)
        创建一个StyleableProperty <Font>。 初始值默认为Font.getDefault() ，继承标志默认为true。
        参数
        styleable - 返回的属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Font>的字段名称
        cssProperty - CSS属性名称
        function - 返回通过此方法调用创建的StyleableProperty <Font>的函数。
        结果
        使用默认字体初始值和true inherit标志创建的StyleableProperty

      • createStyleableFontProperty

        public final StyleableProperty<Font> createStyleableFontProperty​(S styleable,
                                                                 String propertyName,
                                                                 String cssProperty)
        创建一个StyleableProperty <Font>使用以前创建的CssMetaData为给定的 cssProperty 。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Font>的字段名称
        cssProperty - CSS属性名称
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前未创建cssProperty的 cssProperty

      • createStyleableInsetsProperty

        public final StyleableProperty<Insets> createStyleableInsetsProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty,
                                                                     Function<S,StyleableProperty<Insets>> function,
                                                                     Insets initialValue,
                                                                     boolean inherits)
        创建一个具有初始值的StyleableProperty <Inset>并继承标志。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Inset>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Inset>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableInsetsProperty

        public final StyleableProperty<Insets> createStyleableInsetsProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty,
                                                                     Function<S,StyleableProperty<Insets>> function,
                                                                     Insets initialValue)
        创建一个具有初始值的StyleableProperty <Inset>。 inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Inset>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Inset>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleableInsetsProperty

        public final StyleableProperty<Insets> createStyleableInsetsProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty,
                                                                     Function<S,StyleableProperty<Insets>> function)
        创建一个StyleableProperty <Inset>。 初始值为Insets.EMPTY ，继承标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Inset>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Inset>的函数。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleableInsetsProperty

        public final StyleableProperty<Insets> createStyleableInsetsProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty)
        使用先前创建的给定的 cssProperty创建一个StyleableProperty <Insets>。
        参数
        styleable - 返回属性的this参考。 这也是属性bean。
        propertyName - StyleableProperty <Insets>的字段名称
        cssProperty - CSS属性名称
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前没有创建cssProperty的 cssProperty

      • createStyleablePaintProperty

        public final StyleableProperty<Paint> createStyleablePaintProperty​(S styleable,
                                                                   String propertyName,
                                                                   String cssProperty,
                                                                   Function<S,StyleableProperty<Paint>> function,
                                                                   Paint initialValue,
                                                                   boolean inherits)
        创建一个具有初始值的StyleableProperty <Paint>并继承标志。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Paint>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Paint>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleablePaintProperty

        public final StyleableProperty<Paint> createStyleablePaintProperty​(S styleable,
                                                                   String propertyName,
                                                                   String cssProperty,
                                                                   Function<S,StyleableProperty<Paint>> function,
                                                                   Paint initialValue)
        创建一个具有初始值的StyleableProperty <Paint>。 inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Paint>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Paint>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleablePaintProperty

        public final StyleableProperty<Paint> createStyleablePaintProperty​(S styleable,
                                                                   String propertyName,
                                                                   String cssProperty,
                                                                   Function<S,StyleableProperty<Paint>> function)
        创建一个StyleableProperty <Paint>。 初始值与Color.BLACK对应，并且inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Paint>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Paint>的函数。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleablePaintProperty

        public final StyleableProperty<Paint> createStyleablePaintProperty​(S styleable,
                                                                   String propertyName,
                                                                   String cssProperty)
        使用先前创建的给定的 cssProperty创建一个StyleableProperty <Paint>。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Paint>的字段名称
        cssProperty - CSS属性名称
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前没有创建cssProperty的 cssProperty

      • createStyleableNumberProperty

        public final StyleableProperty<Number> createStyleableNumberProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty,
                                                                     Function<S,StyleableProperty<Number>> function,
                                                                     Number initialValue,
                                                                     boolean inherits)
        创建一个具有初始值的StyleableProperty <Number>并继承标志。
        参数
        styleable - 返回的属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Number>的字段名称
        cssProperty - CSS属性名称
        function - 返回通过此方法调用创建的StyleableProperty <Number>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableNumberProperty

        public final StyleableProperty<Number> createStyleableNumberProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty,
                                                                     Function<S,StyleableProperty<Number>> function,
                                                                     Number initialValue)
        创建一个具有初始值的StyleableProperty <Number>。 inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Number>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Number>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleableNumberProperty

        public final StyleableProperty<Number> createStyleableNumberProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty,
                                                                     Function<S,StyleableProperty<Number>> function)
        创建一个StyleableProperty <Number>。 初始值默认为零。 inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Number>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <Number>的函数。
        结果
        一个使用零初始值创建的StyleableProperty和false inherit标志

      • createStyleableNumberProperty

        public final StyleableProperty<Number> createStyleableNumberProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty)
        使用先前创建的给定的 cssProperty创建一个StyleableProperty <Number>。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <Number>的字段名称
        cssProperty - CSS属性名称
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前没有创建cssProperty的 cssProperty

      • createStyleableStringProperty

        public final StyleableProperty<String> createStyleableStringProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty,
                                                                     Function<S,StyleableProperty<String>> function,
                                                                     String initialValue,
                                                                     boolean inherits)
        创建一个具有初始值的StyleableProperty <String>并继承标志。
        参数
        styleable - 返回属性的this参考。 这也是属性bean。
        propertyName - StyleableProperty <String>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <String>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableStringProperty

        public final StyleableProperty<String> createStyleableStringProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty,
                                                                     Function<S,StyleableProperty<String>> function,
                                                                     String initialValue)
        创建一个具有初始值的StyleableProperty <String>。 inherit标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <String>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <String>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleableStringProperty

        public final StyleableProperty<String> createStyleableStringProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty,
                                                                     Function<S,StyleableProperty<String>> function)
        创建一个StyleableProperty <String>。 初始值默认为null，继承标志默认为false。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <String>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <String>的函数。
        结果
        使用null初始值和false inherit标志创建的StyleableProperty

      • createStyleableStringProperty

        public final StyleableProperty<String> createStyleableStringProperty​(S styleable,
                                                                     String propertyName,
                                                                     String cssProperty)
        使用先前创建的给定的 cssProperty创建一个StyleableProperty <String>。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <String>的字段名称
        cssProperty - CSS属性名称
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前未创建cssProperty的 cssProperty

      • createStyleableUrlProperty

        public final StyleableProperty<String> createStyleableUrlProperty​(S styleable,
                                                                  String propertyName,
                                                                  String cssProperty,
                                                                  Function<S,StyleableProperty<String>> function,
                                                                  String initialValue,
                                                                  boolean inherits)
        创建一个具有初始值的StyleableProperty <String>并继承标志。 这里，String值表示从CSS url（“<path>”）转换的URL。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <String>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <String>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        使用初始值创建的StyleableProperty并继承标志

      • createStyleableUrlProperty

        public final StyleableProperty<String> createStyleableUrlProperty​(S styleable,
                                                                  String propertyName,
                                                                  String cssProperty,
                                                                  Function<S,StyleableProperty<String>> function,
                                                                  String initialValue)
        创建一个具有初始值的StyleableProperty <String>。 inherit标志默认为false。 这里，String值表示从CSS url（“<path>”）转换的URL。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <String>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <String>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleableUrlProperty

        public final StyleableProperty<String> createStyleableUrlProperty​(S styleable,
                                                                  String propertyName,
                                                                  String cssProperty,
                                                                  Function<S,StyleableProperty<String>> function)
        创建一个具有初始值的StyleableProperty <String>。 inherit标志默认为false。 这里，String值表示从CSS url（“<path>”）转换的URL。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <String>的字段名称
        cssProperty - CSS属性名称
        function - 返回由此方法调用创建的StyleableProperty <String>的函数。
        结果
        使用初始值创建的StyleableProperty和false inherit标志

      • createStyleableUrlProperty

        public final StyleableProperty<String> createStyleableUrlProperty​(S styleable,
                                                                  String propertyName,
                                                                  String cssProperty)
        创建一个StyleableProperty <String>使用先前创建的CssMetaData为给定的 cssProperty 。
        参数
        styleable - 返回属性的this引用。 这也是属性bean。
        propertyName - StyleableProperty <String>的字段名称
        cssProperty - CSS属性名称
        结果
        使用先前创建的CssMetaData创建的StyleableProperty
        异常
        IllegalArgumentException - 如果 cssProperty为空或为空
        NoSuchElementException - 如果在此方法调用之前未创建cssProperty的 cssProperty

      • createBooleanCssMetaData

        public final CssMetaData<S,Boolean> createBooleanCssMetaData​(String property,
                                                             Function<S,StyleableProperty<Boolean>> function,
                                                             boolean initialValue,
                                                             boolean inherits)
        创建具有初始值的CssMetaData <S，Boolean>，并继承标志。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Boolean>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createBooleanCssMetaData

        public final CssMetaData<S,Boolean> createBooleanCssMetaData​(String property,
                                                             Function<S,StyleableProperty<Boolean>> function,
                                                             boolean initialValue)
        创建具有初始值的CssMetaData <S，Boolean>，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Boolean>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createBooleanCssMetaData

        public final CssMetaData<S,Boolean> createBooleanCssMetaData​(String property,
                                                             Function<S,StyleableProperty<Boolean>> function)
        创建一个具有初始值的CssMetaData <S，Boolean>，并继承标志，两者都默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Boolean>的函数。
        结果
        用false初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createColorCssMetaData

        public final CssMetaData<S,Color> createColorCssMetaData​(String property,
                                                         Function<S,StyleableProperty<Color>> function,
                                                         Color initialValue,
                                                         boolean inherits)
        创建具有初始值的CssMetaData <S，Color>并继承标志。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Color>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createColorCssMetaData

        public final CssMetaData<S,Color> createColorCssMetaData​(String property,
                                                         Function<S,StyleableProperty<Color>> function,
                                                         Color initialValue)
        创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Color>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createColorCssMetaData

        public final CssMetaData<S,Color> createColorCssMetaData​(String property,
                                                         Function<S,StyleableProperty<Color>> function)
        创建一个CssMetaData <S，Color>，初始值为Color.BLACK，并继承标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Color>的函数。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createDurationCssMetaData

        public final CssMetaData<S,Duration> createDurationCssMetaData​(String property,
                                                               Function<S,StyleableProperty<Duration>> function,
                                                               Duration initialValue,
                                                               boolean inherits)
        创建具有初始值的CssMetaData <S，Duration>并继承标志。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Duration>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createDurationCssMetaData

        public final CssMetaData<S,Duration> createDurationCssMetaData​(String property,
                                                               Function<S,StyleableProperty<Duration>> function,
                                                               Duration initialValue)
        创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Duration>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createDurationCssMetaData

        public final CssMetaData<S,Duration> createDurationCssMetaData​(String property,
                                                               Function<S,StyleableProperty<Duration>> function)
        创建一个具有Duration.BLACK的初始值的CssMetaData <S，Duration>，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Duration>的函数。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createEffectCssMetaData

        public final <E extends Effect> CssMetaData<S,E> createEffectCssMetaData​(String property,
                                                                         Function<S,StyleableProperty<E>> function,
                                                                         E initialValue,
                                                                         boolean inherits)
        用初始值创建一个CssMetaData <S，Effect>并继承标志。
        参数类型
        E - 使用初始值创建的CssMetaData和继承标志
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Effect>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createEffectCssMetaData

        public final <E extends Effect> CssMetaData<S,E> createEffectCssMetaData​(String property,
                                                                         Function<S,StyleableProperty<E>> function,
                                                                         E initialValue)
        创建具有初始值的CssMetaData <S，Effect>，并将标志默认为false。
        参数类型
        E - 使用初始值和false继承标志创建的CssMetaData
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Effect>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createEffectCssMetaData

        public final <E extends Effect> CssMetaData<S,E> createEffectCssMetaData​(String property,
                                                                         Function<S,StyleableProperty<E>> function)
        创建CssMetaData <S，Effect>，初始值为null，并将标志默认为false。
        参数类型
        E - 使用null初始值和false inherit标志创建的CssMetaData
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Effect>的函数。
        结果
        用null初始值创建的CssMetaData和false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createEnumCssMetaData

        public final <E extends Enum<E>> CssMetaData<S,E> createEnumCssMetaData​(Class<? extends Enum> enumClass,
                                                                        String property,
                                                                        Function<S,StyleableProperty<E>> function,
                                                                        E initialValue,
                                                                        boolean inherits)
        创建具有初始值的CssMetaData <S，枚举>，并继承标志。
        参数类型
        E - 使用初始值创建的CssMetaData继承标志
        参数
        enumClass - 枚举类是CssMetaData的类型E扩展枚举<E >>。
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Enum>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createEnumCssMetaData

        public final <E extends Enum<E>> CssMetaData<S,E> createEnumCssMetaData​(Class<? extends Enum> enumClass,
                                                                        String property,
                                                                        Function<S,StyleableProperty<E>> function,
                                                                        E initialValue)
        创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。
        参数类型
        E - 使用初始值和false继承标志创建的CssMetaData
        参数
        enumClass - 枚举类是CssMetaData的类型E扩展枚举<E >>。
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Enum>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createEnumCssMetaData

        public final <E extends Enum<E>> CssMetaData<S,E> createEnumCssMetaData​(Class<? extends Enum> enumClass,
                                                                        String property,
                                                                        Function<S,StyleableProperty<E>> function)
        创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。
        参数类型
        E - 使用null初始值和false inherit标志创建的CssMetaData
        参数
        enumClass - 枚举类是CssMetaData的类型E扩展枚举<E >>。
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Enum>的函数。
        结果
        用null初始值创建的CssMetaData和false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createFontCssMetaData

        public final CssMetaData<S,Font> createFontCssMetaData​(String property,
                                                       Function<S,StyleableProperty<Font>> function,
                                                       Font initialValue,
                                                       boolean inherits)
        创建一个具有初始值的CssMetaData <S，Font>并继承标志。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Font>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createFontCssMetaData

        public final CssMetaData<S,Font> createFontCssMetaData​(String property,
                                                       Function<S,StyleableProperty<Font>> function,
                                                       Font initialValue)
        创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Font>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData和true inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createFontCssMetaData

        public final CssMetaData<S,Font> createFontCssMetaData​(String property,
                                                       Function<S,StyleableProperty<Font>> function)
        创建一个CssMetaData <S，Font>，初始值为 Font.getDefault() ，并将标志默认为true。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Font>的函数。
        结果
        用初始值创建的CssMetaData和true inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createInsetsCssMetaData

        public final CssMetaData<S,Insets> createInsetsCssMetaData​(String property,
                                                           Function<S,StyleableProperty<Insets>> function,
                                                           Insets initialValue,
                                                           boolean inherits)
        创建具有初始值的CssMetaData <S，Insets>并继承标志。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Insets>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createInsetsCssMetaData

        public final CssMetaData<S,Insets> createInsetsCssMetaData​(String property,
                                                           Function<S,StyleableProperty<Insets>> function,
                                                           Insets initialValue)
        创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Insets>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createInsetsCssMetaData

        public final CssMetaData<S,Insets> createInsetsCssMetaData​(String property,
                                                           Function<S,StyleableProperty<Insets>> function)
        创建CssMetaData <S，Insets>，初始值为 Insets.EMPTY ，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Insets>的函数。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createPaintCssMetaData

        public final CssMetaData<S,Paint> createPaintCssMetaData​(String property,
                                                         Function<S,StyleableProperty<Paint>> function,
                                                         Paint initialValue,
                                                         boolean inherits)
        用初始值创建一个CssMetaData <S，Paint>并继承标志。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Paint>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createPaintCssMetaData

        public final CssMetaData<S,Paint> createPaintCssMetaData​(String property,
                                                         Function<S,StyleableProperty<Paint>> function,
                                                         Paint initialValue)
        创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Paint>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createPaintCssMetaData

        public final CssMetaData<S,Paint> createPaintCssMetaData​(String property,
                                                         Function<S,StyleableProperty<Paint>> function)
        使用Color.BLACK的初始值创建一个CssMetaData <S，Paint>，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Paint>的函数。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createSizeCssMetaData

        public final CssMetaData<S,Number> createSizeCssMetaData​(String property,
                                                         Function<S,StyleableProperty<Number>> function,
                                                         Number initialValue,
                                                         boolean inherits)
        创建具有初始值的CssMetaData <S，Number>，并继承标志。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Number>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createSizeCssMetaData

        public final CssMetaData<S,Number> createSizeCssMetaData​(String property,
                                                         Function<S,StyleableProperty<Number>> function,
                                                         Number initialValue)
        创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Number>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createSizeCssMetaData

        public final CssMetaData<S,Number> createSizeCssMetaData​(String property,
                                                         Function<S,StyleableProperty<Number>> function)
        创建CssMetaData <S，Number>，初始值为 0d ，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <Number>的函数。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createStringCssMetaData

        public final CssMetaData<S,String> createStringCssMetaData​(String property,
                                                           Function<S,StyleableProperty<String>> function,
                                                           String initialValue,
                                                           boolean inherits)
        创建具有初始值的CssMetaData <S，String>并继承标志。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <String>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createStringCssMetaData

        public final CssMetaData<S,String> createStringCssMetaData​(String property,
                                                           Function<S,StyleableProperty<String>> function,
                                                           String initialValue)
        创建具有初始值的CssMetaData <S，String>，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <String>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createStringCssMetaData

        public final CssMetaData<S,String> createStringCssMetaData​(String property,
                                                           Function<S,StyleableProperty<String>> function)
        创建CssMetaData <S，String>，初始值为null，并将标志默认为false。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <String>的函数。
        结果
        用null初始值创建的CssMetaData和false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createUrlCssMetaData

        public final CssMetaData<S,String> createUrlCssMetaData​(String property,
                                                        Function<S,StyleableProperty<String>> function,
                                                        String initialValue,
                                                        boolean inherits)
        创建具有初始值的CssMetaData <S，String>并继承标志。 这里，String值表示从CSS url（“<path>”）转换的URL。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <String>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        inherits - CSS样式是否可以由子节点继承
        结果
        用初始值创建的CssMetaData，并继承标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createUrlCssMetaData

        public final CssMetaData<S,String> createUrlCssMetaData​(String property,
                                                        Function<S,StyleableProperty<String>> function,
                                                        String initialValue)
        创建具有初始值的CssMetaData <S，String>，并将标志默认为false。 这里，String值表示从CSS url（“<path>”）转换的URL。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <String>的函数。
        initialValue - 属性的初始值。 CSS可能会将该属性重置为此值。
        结果
        用初始值创建的CssMetaData，以及false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。

      • createUrlCssMetaData

        public final CssMetaData<S,String> createUrlCssMetaData​(String property,
                                                        Function<S,StyleableProperty<String>> function)
        创建CssMetaData <S，String>，初始值为null，并将标志默认为false。 这里，String值表示从CSS url（“<path>”）转换的URL。
        参数
        property - CSS属性名称。
        function - 返回与此CssMetaData对应的StyleableProperty <String>的函数。
        结果
        用null初始值创建的CssMetaData和false inherit标志
        异常
        IllegalArgumentException - 如果 property为空或空字符串，或 function为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleableStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleableStringProperty

  • java.lang.Object
    • javafx.beans.binding.StringExpression
      • javafx.beans.property.ReadOnlyStringProperty
        • javafx.beans.property.StringProperty
          • javafx.beans.property.StringPropertyBase
            • javafx.css.StyleableStringProperty
  • All Implemented Interfaces:
    Observable ， Property<String> ， ReadOnlyProperty<String> ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String> ， WritableObjectValue<String> ， WritableStringValue ， WritableValue<String> ， StyleableProperty<String>
    已知直接子类：
    SimpleStyleableStringProperty

    public abstract class StyleableStringProperty
extends StringPropertyBase
implements StyleableProperty<String>
    这个类扩展了StringPropertyBase并提供了一个StyleableProperty的部分实现。 方法StyleableProperty.getCssMetaData()未被实现。 这个类用于制作一个StringProperty ，否则将被实现为一个StringPropertyBase ，由CSS风格化。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    StringPropertyBase ， CssMetaData ， StyleableProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleableStringProperty​()
      StyleableStringProperty的构造 StyleableStringProperty 。
      StyleableStringProperty​(String initialValue)
      StyleableStringProperty的构造 StyleableStringProperty 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void applyStyle​(StyleOrigin origin, String v)
      这个方法从CSS代码调用来设置属性的值。
      void bind​(ObservableValue<? extends String> observable)
      为此 Property创建一个单向绑定。
      StyleOrigin getStyleOrigin​()
      告诉物业的价值的起源。
      void set​(String v)
      设置包装的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.beans.value.ObservableValue

        getValue

      • Methods inherited from interface javafx.beans.property.ReadOnlyProperty

        getBean, getName

      • Methods inherited from class javafx.beans.binding.StringExpression

        concat, getValue, getValueSafe, greaterThan, greaterThan, greaterThanOrEqualTo, greaterThanOrEqualTo, isEmpty, isEqualTo, isEqualTo, isEqualToIgnoreCase, isEqualToIgnoreCase, isNotEmpty, isNotEqualTo, isNotEqualTo, isNotEqualToIgnoreCase, isNotEqualToIgnoreCase, isNotNull, isNull, length, lessThan, lessThan, lessThanOrEqualTo, lessThanOrEqualTo, stringExpression

      • Methods inherited from class javafx.beans.property.StringProperty

        bindBidirectional, bindBidirectional, bindBidirectional, setValue, unbindBidirectional, unbindBidirectional

      • Methods inherited from class javafx.beans.property.StringPropertyBase

        addListener, addListener, fireValueChangedEvent, get, invalidated, isBound, removeListener, removeListener, toString, unbind

      • Methods inherited from interface javafx.css.StyleableProperty

        getCssMetaData

      • Methods inherited from interface javafx.beans.value.WritableValue

        getValue, setValue

    • 构造方法详细信息

      • StyleableStringProperty

        public StyleableStringProperty​()
        StyleableStringProperty的构造 StyleableStringProperty 。

      • StyleableStringProperty

        public StyleableStringProperty​(String initialValue)
        StyleableStringProperty的构造 StyleableStringProperty 。
        参数
        initialValue - 包装的初始值 Object

    • 方法详细信息

      • applyStyle

        public void applyStyle​(StyleOrigin origin,
                       String v)
        这个方法从CSS代码调用来设置属性的值。
        Specified by:
        applyStyle在接口 StyleableProperty<String>
        参数
        origin - 原产地
        v - 值

      • bind

        public void bind​(ObservableValue<? extends String> observable)
        为此创建一个单向绑定Property 。

        请注意，JavaFX具有通过弱侦听器实现的所有绑定调用。 这意味着bound属性可以被垃圾回收并停止更新。

        Specified by:
        bind在接口 Property<String>
        重写：
        bind在 StringPropertyBase
        参数
        observable - 可观察到这个 Property应该绑定到。

      • set

        public void set​(String v)
        设置包装的值。 应相当于WritableValue.setValue(java.lang.Object)
        Specified by:
        set在接口 WritableObjectValue<String>
        重写：
        set在 StringPropertyBase
        参数
        v - 新的价值
        另请参见：
        WritableObjectValue.get()

      • getStyleOrigin

        public StyleOrigin getStyleOrigin​()
        告诉物业的价值的起源。 这是需要确定CSS是否可以覆盖该值。
        Specified by:
        getStyleOrigin在接口 StyleableProperty<String>
        结果
        风格起源
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleClass (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleClass

  • java.lang.Object
    • javafx.css.StyleClass

  • public final class StyleClass
extends Object
    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleClass​(String styleClassName, int index)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      int | getIndex​()
      String getStyleClassName​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StyleClass

        public StyleClass​(String styleClassName,
                  int index)

    • 方法详细信息

      • getStyleClassName

        public String getStyleClassName​()
        结果
        风格级

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString中的 Object
        结果
        the style-class

      • getIndex

        public int getIndex​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleConverter<F,T>

  • java.lang.Object
    • javafx.css.StyleConverter<F,T>
  • 参数类型
    F - 解析值的类型
    T - T的转换类型
    已知直接子类：
    BooleanConverter ， ColorConverter ， CursorConverter ， DeriveColorConverter ， DeriveSizeConverter ， DurationConverter ， EffectConverter ， EnumConverter ， FontConverter ， FontConverter.FontSizeConverter ， FontConverter.FontStyleConverter ， FontConverter.FontWeightConverter ， InsetsConverter ， InsetsConverter.SequenceConverter ， LadderConverter ， PaintConverter ， PaintConverter.ImagePatternConverter ， PaintConverter.LinearGradientConverter ， PaintConverter.RadialGradientConverter ， PaintConverter.RepeatingImagePatternConverter ， PaintConverter.SequenceConverter ， ShapeConverter ， SizeConverter ， SizeConverter.SequenceConverter ， StopConverter ， StringConverter ， StringConverter.SequenceConverter ， URLConverter ， URLConverter.SequenceConverter

    public class StyleConverter<F,T>
extends Object
    StyleConverter转换ParsedValue<F,T>从类型F键入T 。 所述CssMetaData API需要StyleConverter ，其计算所述值时使用StyleableProperty 。 有许多预定义的转换器可以通过此类的静态方法访问。 F是解析值的类型，而T是T的转换类型。 例如，将声明从String到Color的转换器

    public Color convert(ParsedValueImpl<String,Color> value, Font font)

    从以下版本开始：
    JavaFX 8.0
    另请参见：
    ParsedValue ， StyleableProperty

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  StyleConverter.StringStore
      StringStore类

    • 构造方法摘要

      构造方法
      Constructor 描述
      StyleConverter​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void cacheValue​(ParsedValue key, Object value)
      缓存指定键的值。
      static void clearCache​()
      清除缓存。
      T convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)
      从成分值转换为目标属性类型。
      T convert​(ParsedValue<F,T> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<String,Boolean> getBooleanConverter​()
      返回一个 StyleConverter ，其将“真”或“假”到 Boolean 。
      protected T getCachedValue​(ParsedValue key)
      获取指定键的缓存值。
      static StyleConverter<String,Color> getColorConverter​()
      返回一个 StyleConverter ，它将Web颜色的String表示形式转换为 Color 。
      static StyleConverter<?,Duration> getDurationConverter​()
      返回一个StyleConverter ，将持续时间的字符串表示形式转换为Duration 。
      static StyleConverter<ParsedValue[],Effect> getEffectConverter​()
      返回一个 StyleConverter ，一个解析后的表示转换 Effect至 Effect
      static <E extends Enum<E>>
      StyleConverter<String,? extends Enum<?>>             		getEnumConverter​(Class<E> enumClass)
      返回一个 StyleConverter一种转换的String表示 Enum至 Enum 。
      static StyleConverter<ParsedValue[],Font> getFontConverter​()
      返回一个 StyleConverter ，其转换解析后的表示 Font至 Font 。
      static StyleConverter<ParsedValue[],Insets> getInsetsConverter​()
      返回一个StyleConverter ，转换一个[<length> | <百分比>] {1,4}到一个Insets 。
      static StyleConverter<ParsedValue<?,Paint>,Paint> getPaintConverter​()
      返回一个 StyleConverter ，其转换解析后的表示 Paint为 Paint 。
      static StyleConverter<?,Number> getSizeConverter​()
      将CSS长度和数值解析为Size对象，该对象在应用该值之前转换为Number。
      static StyleConverter<String,String> getStringConverter​()
      用于引用的字符串的转换器，可以嵌入unicode字符。
      static StyleConverter<ParsedValue[],String> getUrlConverter​()
      用于URL字符串的转换器。
      static StyleConverter<?,?> readBinary​(DataInputStream is, String[] strings)
      读取二进制数据流。
      void writeBinary​(DataOutputStream os, StyleConverter.StringStore sstore)
      写二进制数据。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyleConverter

        public StyleConverter​()

    • 方法详细信息

      • convert

        public T convert​(ParsedValue<F,T> value,
                 Font font)
        从解析的CSS值转换为目标属性类型。
        参数
        value - 要转换的ParsedValue
        font - 转换relative时使用的Font 。
        结果
        转换的目标属性类型

      • getBooleanConverter

        public static StyleConverter<String,Boolean> getBooleanConverter​()
        返回一个 StyleConverter ，将“true”或“false”转换为 Boolean 。
        结果
        A StyleConverter将“true”或“false”转换为 Boolean
        另请参见：
        Boolean.valueOf(java.lang.String)

      • getDurationConverter

        public static StyleConverter<?,Duration> getDurationConverter​()
        返回一个StyleConverter ，将持续时间的字符串表示形式转换为Duration 。
        结果
        A StyleConverter将持续时间的字符串表示形式转换为Duration
        从以下版本开始：
        JavaFX 8u40

      • getColorConverter

        public static StyleConverter<String,Color> getColorConverter​()
        返回一个 StyleConverter ，它将Web颜色的String表示形式转换为 Color 。
        结果
        A StyleConverter将Web颜色的String表示形式转换为 Color
        另请参见：
        Color.web(java.lang.String)

      • getEffectConverter

        public static StyleConverter<ParsedValue[],Effect> getEffectConverter​()
        返回一个 StyleConverter ，一个解析后的表示转换 Effect至 Effect
        结果
        甲 StyleConverter ，一个解析后的表示转换 Effect到 Effect
        另请参见：
        Effect

      • getEnumConverter

        public static <E extends Enum<E>> StyleConverter<String,? extends Enum<?>> getEnumConverter​(Class<E> enumClass)
        返回一个 StyleConverter一种转换的String表示 Enum至 Enum 。
        参数类型
        E -该类型 Enum
        参数
        enumClass - 枚举类
        结果
        甲 StyleConverter ，一个的String表示转换 Enum到 Enum
        另请参见：
        Enum.valueOf(java.lang.Class, java.lang.String)

      • getFontConverter

        public static StyleConverter<ParsedValue[],Font> getFontConverter​()
        返回一个 StyleConverter ，其转换解析后的表示 Font至 Font 。
        结果
        甲 StyleConverter一个解析后的表示转换 Font到 Font
        另请参见：
        Font.font(java.lang.String, javafx.scene.text.FontWeight, javafx.scene.text.FontPosture, double)

      • getInsetsConverter

        public static StyleConverter<ParsedValue[],Insets> getInsetsConverter​()
        返回一个转换[<length> |的StyleConverter <百分比>] {1,4}到一个Insets 。
        结果
        A StyleConverter转换[<length> | <百分比>] {1,4}至Insets

      • getPaintConverter

        public static StyleConverter<ParsedValue<?,Paint>,Paint> getPaintConverter​()
        返回一个 StyleConverter ，其转换解析后的表示 Paint为 Paint 。
        结果
        甲 StyleConverter一个解析后的表示转换 Paint为 Paint

      • getSizeConverter

        public static StyleConverter<?,Number> getSizeConverter​()
        将CSS长度和数值解析为Size对象，该对象在应用该值之前转换为Number。 如果该属性是一个Number类型，而不是Double ，则可以覆盖（ CssMetaData的设置方法将Number转换为正确的类型，例如，如果该属性是IntegerProperty ：
           @Override public void set(MyNode node, Number value, Origin origin) { if (value != null) { super.set(node, value.intValue(), origin); } else { super.set(node, value, origin); } }
        结果
        甲 StyleConverter ，其转换CSS长度或数字值与解析后的表示 Number即实例 Double

      • getStringConverter

        public static StyleConverter<String,String> getStringConverter​()
        用于引用的字符串的转换器，可以嵌入unicode字符。
        结果
        A StyleConverter将CSS字符串值的表示转换为 String

      • getUrlConverter

        public static StyleConverter<ParsedValue[],String> getUrlConverter​()
        用于URL字符串的转换器。
        结果
        A StyleConverter将CSS URL值的表示转换为 String

      • convert

        public T convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)
        从成分值转换为目标属性类型。 由具有子键的键类型实现。
        参数
        convertedValues - 组成价值
        结果
        目标属性类型
        从以下版本开始：
        9

      • writeBinary

        public void writeBinary​(DataOutputStream os,
                        StyleConverter.StringStore sstore)
                 throws IOException
        写二进制数据。
        参数
        os - 数据输出流
        sstore - 字符串存储
        异常
        IOException - 例外
        从以下版本开始：
        9

      • clearCache

        public static void clearCache​()
        清除缓存。
        从以下版本开始：
        9

      • getCachedValue

        protected T getCachedValue​(ParsedValue key)
        获取指定键的缓存值。
        参数
        key - 关键
        结果
        缓存值
        从以下版本开始：
        9

      • cacheValue

        protected void cacheValue​(ParsedValue key,
                          Object value)
        缓存指定键的值。
        参数
        key - 关键
        value - 的价值
        从以下版本开始：
        9

      • readBinary

        public static StyleConverter<?,?> readBinary​(DataInputStream is,
                                             String[] strings)
                                      throws IOException
        读取二进制数据流。
        参数
        is - 数据输入流
        strings - 字符串
        结果
        风格转换器
        异常
        IOException - 例外
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleConverter.StringStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class StyleConverter.StringStore

  • java.lang.Object
    • javafx.css.StyleConverter.StringStore
  • Enclosing class:
    StyleConverter < F ， T >

    public static class StyleConverter.StringStore
extends Object
    StringStore类
    从以下版本开始：
    9

    • Field Summary

      Fields
      Modifier and Type Field 描述
      List<String> strings

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringStore​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      int | addString​(String s)
      static String[] | readBinary​(DataInputStream is)
      void | writeBinary​(DataOutputStream os)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • strings

        public final List<String> strings

    • 构造方法详细信息

      • StringStore

        public StringStore​()

    • 方法详细信息

      • addString

        public int addString​(String s)

      • writeBinary

        public void writeBinary​(DataOutputStream os)
                 throws IOException
        异常
        IOException

      • readBinary

        public static String[] readBinary​(DataInputStream is)
                           throws IOException
        异常
        IOException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


StyleOrigin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Enum StyleOrigin

  • java.lang.Object
    • java.lang.Enum<StyleOrigin>
      • javafx.css.StyleOrigin
  • All Implemented Interfaces:
    Serializable ， Comparable<StyleOrigin>

    public enum StyleOrigin
extends Enum<StyleOrigin>
    枚举样式表和样式的可能来源或来源。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      AUTHOR
      样式表是一个外部文件
      INLINE
      样式是从Node通过setStyle
      USER
      属性的值由用户通过调用set方法设置
      USER_AGENT
      样式表是用户代理样式表

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static StyleOrigin valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StyleOrigin[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • USER_AGENT

        public static final StyleOrigin USER_AGENT
        样式表是用户代理样式表

      • USER

        public static final StyleOrigin USER
        属性的值由用户通过调用set方法设置

      • AUTHOR

        public static final StyleOrigin AUTHOR
        样式表是一个外部文件

      • INLINE

        public static final StyleOrigin INLINE
        样式是从Node通过setStyle

    • 方法详细信息

      • values

        public static StyleOrigin[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (StyleOrigin c : StyleOrigin.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static StyleOrigin valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Stylesheet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css

Class Stylesheet

  • java.lang.Object
    • javafx.css.Stylesheet

  • public class Stylesheet
extends Object
    可以将属性应用于对象树的样式表。 样式表是零或多于Rules的集合 ，每个应用于树中的每个对象。 通常，选择器将检查对象以确定其是否适用，如果是，则将对该对象应用某些属性值。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      static void convertToBinary​(File source, File destination)
      将urlIn引用的.css文件转换为二进制格式并写入urlOut。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      List<FontFace> getFontFaces​()
      StyleOrigin getOrigin​()
      List<Rule> getRules​()
      String getUrl​()
      加载样式表的URL。
      int hashCode​()
      返回对象的哈希码值。
      static Stylesheet loadBinary​(URL url)
      从输入流加载二进制样式表文件。
      void | setOrigin​(StyleOrigin origin)
      String toString​()
      返回此对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getUrl

        public String getUrl​()
        加载样式表的URL。
        结果
        加载样式表的URL，如果样式表是从内联样式创建的，则为null。

      • getOrigin

        public StyleOrigin getOrigin​()

      • setOrigin

        public void setOrigin​(StyleOrigin origin)

      • getRules

        public List<Rule> getRules​()

      • getFontFaces

        public List<FontFace> getFontFaces​()

      • equals

        public boolean equals​(Object obj)
        描述从类： Object复制
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        说明从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每一个上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • loadBinary

        public static Stylesheet loadBinary​(URL url)
                             throws IOException
        从输入流加载二进制样式表文件。
        参数
        url - 从中载入样式表的URL
        结果
        构造的样式表
        异常
        IOException - 例外

      • convertToBinary

        public static void convertToBinary​(File source,
                                   File destination)
                            throws IOException
        将urlIn引用的.css文件转换为二进制格式并写入urlOut。
        参数
        source - 是要转换的JavaFX .css文件
        destination - 是写入二进制转换的文件
        异常
        IOException - 例外
        IllegalArgumentException - 如果任一参数为空，如果源和目标相同，则无法读取源，或者无法写入目的地。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.css (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.css

  • Packages that use javafx.css
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
  • Classes in javafx.css used by javafx.css
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    CssParser.ParseError
    封装关于解析CSS或将样式应用于节点时遇到的错误的来源和性质的信息。
    Declaration
    FontFace
    FontFace是一个来自CSS文件的@ font-face定义
    Match
    由Rule使用，以确定选择器是否适用于给定的对象。
    ParsedValue
    解析的CSS值的表示。
    PseudoClass
    伪类代表一个唯一的伪类状态。
    Rule
    Selector
    由CSSRule用于确定选择器是否适用于给定的对象。
    SimpleSelector
    一个根据CSS标准行事的简单选择器。
    SizeUnits
    表示特定单位中指定的大小，例如14px或0.2em。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
    StyleableBooleanProperty
    这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableDoubleProperty
    这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableFloatProperty
    这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableIntegerProperty
    这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableLongProperty
    这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableObjectProperty
    这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleableProperty
    StyleableProperty允许一个 javafx.beans.property从CSS样式。
    StyleableStringProperty
    这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
    StyleClass
    StyleConverter
    StyleConverter转换 ParsedValue<F,T>从类型 F键入 T 。
    StyleConverter.StringStore
    StringStore类
    StyleOrigin
    枚举样式表和样式的可能来源或来源。
    Stylesheet
    可以将属性应用于对象树的样式表。
  • Classes in javafx.css used by javafx.css.converter
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    ParsedValue
    解析的CSS值的表示。
    Size
    表示特定单位中指定的大小，例如14px或0.2em。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
    StyleConverter
    StyleConverter转换 ParsedValue<F,T>从类型 F键入 T 。
    StyleConverter.StringStore
    StringStore类
  • Classes in javafx.css used by javafx.embed.swing
    Class 描述
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    PseudoClass
    伪类代表一个唯一的伪类状态。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.canvas
    Class 描述
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.chart
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.control
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    PseudoClass
    伪类代表一个唯一的伪类状态。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.control.cell
    Class 描述
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.control.skin
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.image
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.layout
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.media
    Class 描述
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.shape
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.text
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    Styleable
    Styleable包含对象被CSS样式所需的最小界面。
  • Classes in javafx.css used by javafx.scene.web
    Class 描述
    CssMetaData
    CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
    Styleable
    Styleable comprises the minimal interface required for an object to be styled by CSS.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.CompoundSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.CompoundSelector

No usage of javafx.css.CompoundSelector
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.CssMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.CssMetaData

  • Packages that use CssMetaData
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of CssMetaData in javafx.css

      Subclasses of CssMetaData in javafx.css
      Modifier and Type Class 描述
      class  FontCssMetaData<S extends Styleable>
      CssMetaData部分实现Font属性，其中包含字体子属性：weight，style，family和size。
      Methods in javafx.css that return CssMetaData
      Modifier and Type 方法 描述
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function)
      创建一个具有初始值的CssMetaData <S，Boolean>，并继承标志，两者都默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建具有初始值的CssMetaData <S，Boolean>，并将标志默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Boolean>，并继承标志。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function)
      创建一个CssMetaData <S，Color>，初始值为Color.BLACK，并继承标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Color>并继承标志。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function)
      创建一个具有Duration.BLACK的初始值的CssMetaData <S，Duration>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Duration>并继承标志。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，Effect>，初始值为null，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，Effect>，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Effect>并继承标志。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，枚举>，并继承标志。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function)
      创建CssMetaData <S，Font>，初始值为 Font.getDefault() ，并将标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的CssMetaData <S，Font>并继承标志。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function)
      创建CssMetaData <S，Insets>，初始值为 Insets.EMPTY ，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Insets>并继承标志。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function)
      使用Color.BLACK的初始值创建一个CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Paint>并继承标志。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function)
      创建CssMetaData <S，Number>，初始值为 0d ，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Number>，并继承标志。
      CssMetaData<S,String> StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function)
      创建CssMetaData <S，String>，初始值为null，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)
      创建具有初始值的CssMetaData <S，String>，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，String>并继承标志。
      CssMetaData<S,String> StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function)
      创建CssMetaData <S，String>，初始值为null，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)
      创建具有初始值的CssMetaData <S，String>，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，String>并继承标志。
      CssMetaData<? extends Styleable,Boolean> SimpleStyleableBooleanProperty.getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableDoubleProperty.getCssMetaData​()
      反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableFloatProperty.getCssMetaData​()
      反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableIntegerProperty.getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableLongProperty.getCssMetaData​()
      反映对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,T> SimpleStyleableObjectProperty.getCssMetaData​()
      反映出对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,String> SimpleStyleableStringProperty.getCssMetaData​()
      反映对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,T> StyleableProperty.getCssMetaData​()
      反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
      Methods in javafx.css that return types with arguments of type CssMetaData
      Modifier and Type 方法 描述
      List<CssMetaData<? extends Styleable,?>> Styleable.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> StyleablePropertyFactory.getCssMetaData​()
      获取给定Styleable的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> CssMetaData.getSubProperties​()
      子属性是指该属性的组成属性（如果有）。
      Method parameters in javafx.css with type arguments of type CssMetaData
      Modifier and Type 方法 描述
      T StyleConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)
      从成分值转换为目标属性类型。
      Constructors in javafx.css with parameters of type CssMetaData
      Constructor 描述
      PropertySetError​(CssMetaData styleableProperty, Styleable styleable, String message)
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, boolean initialValue)
      的构造函数 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Double initialValue)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      的构造函数为 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Float initialValue)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)
      的构造函数 SimpleStyleableFloatProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name, T initialValue)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, T initialValue)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, String initialValue)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      Constructor parameters in javafx.css with type arguments of type CssMetaData
      Constructor 描述
      CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue, boolean inherits, List<CssMetaData<? extends Styleable,?>> subProperties)
      用给定的参数构造一个CssMetaData，没有子属性。
      StyleablePropertyFactory​(List<CssMetaData<? extends Styleable,?>> parentCssMetaData)
      构造函数通过父类的父类的CssMetaData传递，通常通过调用父类的静态方法 getClassCssMetaData() 。

    • Uses of CssMetaData in javafx.css.converter

      Method parameters in javafx.css.converter with type arguments of type CssMetaData
      Modifier and Type | 方法 | 描述
      Font | FontConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)

    • Uses of CssMetaData in javafx.scene

      Methods in javafx.scene that return types with arguments of type CssMetaData
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Node.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Node.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of CssMetaData in javafx.scene.chart

      Methods in javafx.scene.chart that return types with arguments of type CssMetaData
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | AreaChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Axis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | BarChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | CategoryAxis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Chart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | LineChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | NumberAxis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | PieChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | StackedAreaChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | StackedBarChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ValueAxis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | XYChart.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> AreaChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Axis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> BarChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> CategoryAxis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Chart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> LineChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> NumberAxis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> PieChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> StackedAreaChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> StackedBarChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ValueAxis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> XYChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

    • Uses of CssMetaData in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type CssMetaData
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Control.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | DatePicker.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | DialogPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Labeled.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ListView.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | MenuBar.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Pagination.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | PopupControl.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ScrollBar.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ScrollPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Separator.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> SkinBase.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> | Slider.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | SplitPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Tab.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TableColumn.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TableView.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TabPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextArea.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextField.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextInputControl.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TitledPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ToolBar.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Tooltip.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TreeTableColumn.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TreeTableView.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TreeView.getClassCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | Control.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | DatePicker.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | Labeled.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ListView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | MenuBar.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | Pagination.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ScrollBar.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ScrollPane.getControlCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | Separator.getControlCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | Slider.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | SplitPane.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TableView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TabPane.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TextArea.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TextField.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TextInputControl.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TitledPane.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ToolBar.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TreeTableView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TreeView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Control.getCssMetaData​()
      此方法返回List包含所有CssMetaData两个这种控制（从返回Control.getControlCssMetaData()及其Skin ，假设skin property为SkinBase 。
      List<CssMetaData<? extends Styleable,?>> DialogPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> | MenuItem.getCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | PopupControl.CSSBridge.getCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> PopupControl.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> SkinBase.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Tab.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> TableColumn.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> Tooltip.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> TreeTableColumn.getCssMetaData​()
      这个样式的CssMetaData。

    • Uses of CssMetaData in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return types with arguments of type CssMetaData
      Modifier and Type 方法 描述
      static List<CssMetaData<? extends Styleable,?>> CellSkinBase.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ColorPickerSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> MenuBarSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> PaginationSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ProgressBarSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ProgressIndicatorSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TableColumnHeader.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TabPaneSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TextInputControlSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ToolBarSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TreeCellSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TreeTableRowSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> CellSkinBase.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ColorPickerSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> MenuBarSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> PaginationSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ProgressBarSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ProgressIndicatorSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TableColumnHeader.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TabPaneSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TextInputControlSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ToolBarSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TreeCellSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TreeTableRowSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of CssMetaData in javafx.scene.image

      Methods in javafx.scene.image that return types with arguments of type CssMetaData
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | ImageView.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> ImageView.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of CssMetaData in javafx.scene.layout

      Methods in javafx.scene.layout that return types with arguments of type CssMetaData
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Background.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Border.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | FlowPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | GridPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | HBox.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Region.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | StackPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TilePane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | VBox.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> FlowPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> GridPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> HBox.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Region.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> StackPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TilePane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> VBox.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of CssMetaData in javafx.scene.shape

      Methods in javafx.scene.shape that return types with arguments of type CssMetaData
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Rectangle.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Shape.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Rectangle.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Shape.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of CssMetaData in javafx.scene.text

      Methods in javafx.scene.text that return types with arguments of type CssMetaData
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Text.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextFlow.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Text.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> | TextFlow.getCssMetaData​()

    • Uses of CssMetaData in javafx.scene.web

      Methods in javafx.scene.web that return types with arguments of type CssMetaData
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | WebView.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> WebView.getCssMetaData​()
      This method should delegate to Node.getClassCssMetaData() so that a Node's CssMetaData can be accessed without the need for reflection.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.CssParser (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.CssParser

No usage of javafx.css.CssParser
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.CssParser.ParseError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.CssParser.ParseError

  • Packages that use CssParser.ParseError
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of CssParser.ParseError in javafx.css

      Subclasses of CssParser.ParseError in javafx.css
      Modifier and Type Class 描述
      static class  CssParser.ParseError.InlineStyleParsingError
      封装从节点样式属性解析引起的错误
      static class  CssParser.ParseError.PropertySetError
      封装将风格应用于节点所产生的错误。
      static class  CssParser.ParseError.StringParsingError
      当样式不是内联样式时，也不会从样式表中选择样式，从而解析解析时出现的错误。
      static class  CssParser.ParseError.StylesheetParsingError
      封装解析样式表文件时产生的错误
      Methods in javafx.css that return types with arguments of type CssParser.ParseError
      Modifier and Type | 方法 | 描述
      static ObservableList<CssParser.ParseError> | CssParser.errorsProperty​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.CssParser.ParseError.InlineStyleParsingError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.CssParser.ParseError.InlineStyleParsingError

No usage of javafx.css.CssParser.ParseError.InlineStyleParsingError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.CssParser.ParseError.PropertySetError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.CssParser.ParseError.PropertySetError

No usage of javafx.css.CssParser.ParseError.PropertySetError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.CssParser.ParseError.StringParsingError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.CssParser.ParseError.StringParsingError

No usage of javafx.css.CssParser.ParseError.StringParsingError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.CssParser.ParseError.StylesheetParsingError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.CssParser.ParseError.StylesheetParsingError

No usage of javafx.css.CssParser.ParseError.StylesheetParsingError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.Declaration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.Declaration

  • Packages that use Declaration
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of Declaration in javafx.css

      Methods in javafx.css that return Declaration
      Modifier and Type 方法 描述
      Declaration Style.getDeclaration​()
      “宣言”是即将应用或刚刚应用的风格的来源。
      Methods in javafx.css that return types with arguments of type Declaration
      Modifier and Type 方法 描述
      ObservableList<Declaration> Rule.getDeclarations​()
      此方法是支持可能希望从规则添加声明或从规则中删除声明的工具。
      Constructors in javafx.css with parameters of type Declaration
      Constructor 描述
      Style​(Selector selector, Declaration declaration)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.FontCssMetaData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.FontCssMetaData

No usage of javafx.css.FontCssMetaData
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.FontFace (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.FontFace

  • Packages that use FontFace
    软件包 描述
    javafx.css
    Provides API for making properties styleable via CSS and for supporting pseudo-class state.

    • Uses of FontFace in javafx.css

      Methods in javafx.css that return types with arguments of type FontFace
      Modifier and Type | 方法 | 描述
      List<FontFace> | Stylesheet.getFontFaces​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.Match (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.Match

  • Packages that use Match
    软件包 描述
    javafx.css
    Provides API for making properties styleable via CSS and for supporting pseudo-class state.

    • Uses of Match in javafx.css

      Methods in javafx.css that return Match
      Modifier and Type | 方法 | 描述
      Match | CompoundSelector.createMatch​()
      abstract Match | Selector.createMatch​()
      Match | SimpleSelector.createMatch​()
      Methods in javafx.css with parameters of type Match
      Modifier and Type | 方法 | 描述
      int | Match.compareTo​(Match o)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.ParsedValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.ParsedValue

  • Packages that use ParsedValue
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。

    • Uses of ParsedValue in javafx.css

      Methods in javafx.css that return ParsedValue
      Modifier and Type | 方法 | 描述
      ParsedValue | Declaration.getParsedValue​()
      Methods in javafx.css that return types with arguments of type ParsedValue
      Modifier and Type 方法 描述
      static StyleConverter<ParsedValue<?,Paint>,Paint> StyleConverter.getPaintConverter​()
      返回一个 StyleConverter ，其转换解析后的表示 Paint为 Paint 。
      Methods in javafx.css with parameters of type ParsedValue
      Modifier and Type 方法 描述
      protected void StyleConverter.cacheValue​(ParsedValue key, Object value)
      缓存指定键的值。
      T StyleConverter.convert​(ParsedValue<F,T> value, Font font)
      从解析的CSS值转换为目标属性类型。
      protected T StyleConverter.getCachedValue​(ParsedValue key)
      获取指定键的缓存值。

    • Uses of ParsedValue in javafx.css.converter

      Methods in javafx.css.converter that return types with arguments of type ParsedValue
      Modifier and Type | 方法 | 描述
      static StyleConverter<ParsedValue<?,Size>,Duration> | DurationConverter.getInstance​()
      static StyleConverter<ParsedValue<?,Paint>,Paint> | PaintConverter.getInstance​()
      static StyleConverter<ParsedValue<?,Size>,Number> | SizeConverter.getInstance​()
      Methods in javafx.css.converter with parameters of type ParsedValue
      Modifier and Type | 方法 | 描述
      Boolean | BooleanConverter.convert​(ParsedValue<String,Boolean> value, Font not_used)
      Color | ColorConverter.convert​(ParsedValue<String,Color> value, Font font)
      Cursor | CursorConverter.convert​(ParsedValue<String,Cursor> value, Font not_used)
      Color | DeriveColorConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)
      Size | DeriveSizeConverter.convert​(ParsedValue<ParsedValue<Size,Size>[],Size> value, Font font)
      Duration | DurationConverter.convert​(ParsedValue<ParsedValue<?,Size>,Duration> value, Font font)
      Effect | EffectConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      Effect | EffectConverter.DropShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      Effect | EffectConverter.InnerShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      E | EnumConverter.convert​(ParsedValue<String,E> value, Font not_used)
      Font | FontConverter.convert​(ParsedValue<ParsedValue[],Font> value, Font font)
      Number | FontConverter.FontSizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      FontPosture | FontConverter.FontStyleConverter.convert​(ParsedValue<String,FontPosture> value, Font font)
      FontWeight | FontConverter.FontWeightConverter.convert​(ParsedValue<String,FontWeight> value, Font font)
      Insets | InsetsConverter.convert​(ParsedValue<ParsedValue[],Insets> value, Font font)
      Insets[] | InsetsConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<ParsedValue[],Insets>[],Insets[]> value, Font font)
      Color | LadderConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)
      Paint | PaintConverter.convert​(ParsedValue<ParsedValue<?,Paint>,Paint> value, Font font)
      Paint | PaintConverter.ImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.LinearGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.RadialGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.RepeatingImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint[] | PaintConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<?,Paint>[],Paint[]> value, Font font)
      Shape | ShapeConverter.convert​(ParsedValue<String,Shape> value, Font font)
      Number | SizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      Number[] | SizeConverter.SequenceConverter.convert​(ParsedValue<ParsedValue[],Number[]> value, Font font)
      Stop | StopConverter.convert​(ParsedValue<ParsedValue[],Stop> value, Font font)
      String | StringConverter.convert​(ParsedValue<String,String> value, Font font)
      String[] | StringConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<String,String>[],String[]> value, Font font)
      String | URLConverter.convert​(ParsedValue<ParsedValue[],String> value, Font font)
      String[] | URLConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<ParsedValue[],String>[],String[]> value, Font font)
      Method parameters in javafx.css.converter with type arguments of type ParsedValue
      Modifier and Type | 方法 | 描述
      Duration | DurationConverter.convert​(ParsedValue<ParsedValue<?,Size>,Duration> value, Font font)
      Number | FontConverter.FontSizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      Paint | PaintConverter.convert​(ParsedValue<ParsedValue<?,Paint>,Paint> value, Font font)
      Number | SizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.PseudoClass (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.PseudoClass

  • Packages that use PseudoClass
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of PseudoClass in javafx.css

      Methods in javafx.css that return PseudoClass
      Modifier and Type 方法 描述
      static PseudoClass PseudoClass.getPseudoClass​(String pseudoClass)
      给定的pseudoClass只有一个PseudoClass实例。
      Methods in javafx.css that return types with arguments of type PseudoClass
      Modifier and Type 方法 描述
      ObservableSet<PseudoClass> Styleable.getPseudoClassStates​()
      返回此Styleable的伪类状态。
      Method parameters in javafx.css with type arguments of type PseudoClass
      Modifier and Type | 方法 | 描述
      boolean | CompoundSelector.stateMatches​(Styleable styleable, Set<PseudoClass> states)
      abstract boolean Selector.stateMatches​(Styleable styleable, Set<PseudoClass> state)
      确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。
      boolean | SimpleSelector.stateMatches​(Styleable styleable, Set<PseudoClass> states)

    • Uses of PseudoClass in javafx.scene

      Methods in javafx.scene that return types with arguments of type PseudoClass
      Modifier and Type | 方法 | 描述
      ObservableSet<PseudoClass> | Node.getPseudoClassStates​()
      Methods in javafx.scene with parameters of type PseudoClass
      Modifier and Type 方法 描述
      void Node.pseudoClassStateChanged​(PseudoClass pseudoClass, boolean active)
      用于指定此节点的伪类已更改。

    • Uses of PseudoClass in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type PseudoClass
      Modifier and Type 方法 描述
      ObservableSet<PseudoClass> MenuItem.getPseudoClassStates​()
      返回此Styleable的伪类状态。
      ObservableSet<PseudoClass> PopupControl.getPseudoClassStates​()
      返回此Styleable的伪类状态。
      ObservableSet<PseudoClass> Tab.getPseudoClassStates​()
      返回此Styleable的伪类状态。
      ObservableSet<PseudoClass> TableColumnBase.getPseudoClassStates​()
      返回此Styleable的伪类状态。
      Methods in javafx.scene.control with parameters of type PseudoClass
      Modifier and Type | 方法 | 描述
      void | PopupControl.pseudoClassStateChanged​(PseudoClass pseudoClass, boolean active)
      void SkinBase.pseudoClassStateChanged​(PseudoClass pseudoClass, boolean active)
      用于指定此节点的伪类已更改。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.Rule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.Rule

  • Packages that use Rule
    软件包 描述
    javafx.css
    Provides API for making properties styleable via CSS and for supporting pseudo-class state.

    • Uses of Rule in javafx.css

      Methods in javafx.css that return Rule
      Modifier and Type | 方法 | 描述
      Rule | Declaration.getRule​()
      Rule | Selector.getRule​()
      Methods in javafx.css that return types with arguments of type Rule
      Modifier and Type | 方法 | 描述
      List<Rule> | Stylesheet.getRules​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.Selector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.Selector

  • Packages that use Selector
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of Selector in javafx.css

      Subclasses of Selector in javafx.css
      Modifier and Type Class 描述
      class  CompoundSelector
      根据CSS标准行事的复合选择器。
      class  SimpleSelector
      一个根据CSS标准行事的简单选择器。
      Methods in javafx.css that return Selector
      Modifier and Type | 方法 | 描述
      static Selector | Selector.createSelector​(String cssSelector)
      Selector | Match.getSelector​()
      Selector Style.getSelector​()
      选择器可能有多个选择器。
      Methods in javafx.css that return types with arguments of type Selector
      Modifier and Type 方法 描述
      ObservableList<Selector> Rule.getSelectors​()
      此方法是支持可能希望从Rule添加选择器或从Rule中删除选择器的工具。
      Constructors in javafx.css with parameters of type Selector
      Constructor 描述
      Style​(Selector selector, Declaration declaration)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.SimpleSelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.SimpleSelector

  • Packages that use SimpleSelector
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of SimpleSelector in javafx.css

      Methods in javafx.css that return types with arguments of type SimpleSelector
      Modifier and Type 方法 描述
      List<SimpleSelector> CompoundSelector.getSelectors​()
      组合此复合选择器的选择器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.SimpleStyleableBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.SimpleStyleableBooleanProperty

No usage of javafx.css.SimpleStyleableBooleanProperty
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.SimpleStyleableDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.SimpleStyleableDoubleProperty

No usage of javafx.css.SimpleStyleableDoubleProperty
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.SimpleStyleableFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.SimpleStyleableFloatProperty

No usage of javafx.css.SimpleStyleableFloatProperty
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.SimpleStyleableIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.SimpleStyleableIntegerProperty

No usage of javafx.css.SimpleStyleableIntegerProperty
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.SimpleStyleableLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.SimpleStyleableLongProperty

No usage of javafx.css.SimpleStyleableLongProperty
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.SimpleStyleableObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.SimpleStyleableObjectProperty

No usage of javafx.css.SimpleStyleableObjectProperty
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.SimpleStyleableStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.SimpleStyleableStringProperty

No usage of javafx.css.SimpleStyleableStringProperty
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.Size (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.Size

  • Packages that use Size
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of Size in javafx.css.converter

      Methods in javafx.css.converter that return Size
      Modifier and Type | 方法 | 描述
      Size | DeriveSizeConverter.convert​(ParsedValue<ParsedValue<Size,Size>[],Size> value, Font font)
      Methods in javafx.css.converter that return types with arguments of type Size
      Modifier and Type | 方法 | 描述
      static StyleConverter<ParsedValue<?,Size>,Duration> | DurationConverter.getInstance​()
      static StyleConverter<ParsedValue<?,Size>,Number> | SizeConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Size
      Modifier and Type | 方法 | 描述
      Size | DeriveSizeConverter.convert​(ParsedValue<ParsedValue<Size,Size>[],Size> value, Font font)
      Duration | DurationConverter.convert​(ParsedValue<ParsedValue<?,Size>,Duration> value, Font font)
      Number | FontConverter.FontSizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      Number | SizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.SizeUnits (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.SizeUnits

  • Packages that use SizeUnits
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of SizeUnits in javafx.css

      Methods in javafx.css that return SizeUnits
      Modifier and Type 方法 描述
      SizeUnits Size.getUnits​()
      返回单位
      static SizeUnits SizeUnits.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SizeUnits[] SizeUnits.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.css with parameters of type SizeUnits
      Constructor 描述
      Size​(double value, SizeUnits units)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.Style (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.Style

No usage of javafx.css.Style
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleableBooleanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleableBooleanProperty

  • Packages that use StyleableBooleanProperty
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StyleableBooleanProperty in javafx.css

      Subclasses of StyleableBooleanProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      这个类扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleableDoubleProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleableDoubleProperty

  • Packages that use StyleableDoubleProperty
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StyleableDoubleProperty in javafx.css

      Subclasses of StyleableDoubleProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableDoubleProperty
      该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleableFloatProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleableFloatProperty

  • Packages that use StyleableFloatProperty
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StyleableFloatProperty in javafx.css

      Subclasses of StyleableFloatProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableFloatProperty
      这个类扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleableIntegerProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleableIntegerProperty

  • Packages that use StyleableIntegerProperty
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StyleableIntegerProperty in javafx.css

      Subclasses of StyleableIntegerProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableIntegerProperty
      该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleableLongProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleableLongProperty

  • Packages that use StyleableLongProperty
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StyleableLongProperty in javafx.css

      Subclasses of StyleableLongProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableLongProperty
      该课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleableObjectProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleableObjectProperty

  • Packages that use StyleableObjectProperty
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StyleableObjectProperty in javafx.css

      Subclasses of StyleableObjectProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableObjectProperty<T>
      该课程扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleablePropertyFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleablePropertyFactory

No usage of javafx.css.StyleablePropertyFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleableStringProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleableStringProperty

  • Packages that use StyleableStringProperty
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StyleableStringProperty in javafx.css

      Subclasses of StyleableStringProperty in javafx.css
      Modifier and Type Class 描述
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleClass (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleClass

  • Packages that use StyleClass
    软件包 描述
    javafx.css
    Provides API for making properties styleable via CSS and for supporting pseudo-class state.

    • Uses of StyleClass in javafx.css

      Methods in javafx.css that return types with arguments of type StyleClass
      Modifier and Type | 方法 | 描述
      Set<StyleClass> | SimpleSelector.getStyleClassSet​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleConverter

  • Packages that use StyleConverter
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。

    • Uses of StyleConverter in javafx.css

      Fields in javafx.css declared as StyleConverter
      Modifier and Type Field 描述
      protected StyleConverter<V,T> ParsedValue.converter
      所述StyleConverter其中被分析的值转换为的类型StyleableProperty 。
      Methods in javafx.css that return StyleConverter
      Modifier and Type | 方法 | 描述
      static StyleConverter<String,Boolean> StyleConverter.getBooleanConverter​()
      返回一个 StyleConverter ，其将“真”或“假”到 Boolean 。
      static StyleConverter<String,Color> StyleConverter.getColorConverter​()
      返回一个 StyleConverter ，将Web颜色的String表示形式转换为 Color 。
      StyleConverter<?,V> | CssMetaData.getConverter​()
      StyleConverter<V,T> ParsedValue.getConverter​()
      甲StyleConverter转换分析得到的值到的类型StyleableProperty 。
      static StyleConverter<?,Duration> StyleConverter.getDurationConverter​()
      返回一个StyleConverter ，将持续时间的字符串表示形式转换为Duration 。
      static StyleConverter<ParsedValue[],Effect> StyleConverter.getEffectConverter​()
      返回一个 StyleConverter ，一个解析后的表示转换 Effect至 Effect
      static <E extends Enum<E>>
      StyleConverter<String,? extends Enum<?>>             		StyleConverter.getEnumConverter​(Class<E> enumClass)
      返回一个 StyleConverter一种转换的String表示 Enum至 Enum 。
      static StyleConverter<ParsedValue[],Font> StyleConverter.getFontConverter​()
      返回一个 StyleConverter ，其转换解析后的表示 Font至 Font 。
      static StyleConverter<ParsedValue[],Insets> StyleConverter.getInsetsConverter​()
      返回一个转换[<length> |的StyleConverter <percentage>] {1,4}到Insets 。
      static StyleConverter<ParsedValue<?,Paint>,Paint> StyleConverter.getPaintConverter​()
      返回一个 StyleConverter ，其转换解析后的表示 Paint为 Paint 。
      static StyleConverter<?,Number> StyleConverter.getSizeConverter​()
      将CSS长度和数值解析为Size对象，该对象在应用该值之前转换为Number。
      static StyleConverter<String,String> StyleConverter.getStringConverter​()
      用于引用的字符串的转换器，可以嵌入unicode字符。
      static StyleConverter<ParsedValue[],String> StyleConverter.getUrlConverter​()
      用于URL字符串的转换器。
      static StyleConverter<?,?> StyleConverter.readBinary​(DataInputStream is, String[] strings)
      读取二进制数据流。
      Constructors in javafx.css with parameters of type StyleConverter
      Constructor 描述
      CssMetaData​(String property, StyleConverter<?,V> converter)
      使用给定的参数构造一个CssMetaData，initialValue为null，inherit设置为false，没有子属性。
      CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue)
      使用给定的参数构造一个CssMetaData，继承设置为false并且没有子属性。
      CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue, boolean inherits)
      用给定的参数构造一个CssMetaData，没有子属性。
      CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue, boolean inherits, List<CssMetaData<? extends Styleable,?>> subProperties)
      用给定的参数构造一个CssMetaData，没有子属性。
      ParsedValue​(V value, StyleConverter<V,T> converter)
      创建ParsedValue的实例，其中使用给定的转换器将值类型V转换为目标类型T.

    • Uses of StyleConverter in javafx.css.converter

      Subclasses of StyleConverter in javafx.css.converter
      Modifier and Type | Class | 描述
      class  | BooleanConverter
      class  | ColorConverter
      class  | CursorConverter
      class  DeriveColorConverter
      从颜色和亮度值导出颜色
      class  DeriveSizeConverter
      一种组合两个Size值的类型。
      class  DurationConverter
      将大小转换为持续时间
      class  | EffectConverter
      static class  | EffectConverter.DropShadowConverter
      static class  | EffectConverter.InnerShadowConverter
      class  | EnumConverter<E extends Enum<E>>
      class  | FontConverter
      static class  | FontConverter.FontSizeConverter
      static class  | FontConverter.FontStyleConverter
      static class  | FontConverter.FontWeightConverter
      class  InsetsConverter
      将1到4个大小组件的解析值数组转换为Insets。
      static class  InsetsConverter.SequenceConverter
      将一组解析的值转换为Insets对象数组，每个值都是1到4个大小的数组。
      class  | LadderConverter
      class  | PaintConverter
      static class  | PaintConverter.ImagePatternConverter
      static class  | PaintConverter.LinearGradientConverter
      static class  | PaintConverter.RadialGradientConverter
      static class  | PaintConverter.RepeatingImagePatternConverter
      static class  PaintConverter.SequenceConverter
      将解析值数组转换为Paint对象数组。
      class  ShapeConverter
      将SVG形状字符串转换为Shape对象。
      class  SizeConverter
      将大小转换为数字
      static class  | SizeConverter.SequenceConverter
      class  StopConverter
      从一个大小和一个颜色转换一个停止
      class  StringConverter
      字符串类型转换嵌入式unicode字符
      static class  | StringConverter.SequenceConverter
      class  URLConverter
      将表示URL的解析值转换为相对于样式表位置解析的URL字符串。
      static class  | URLConverter.SequenceConverter
      Methods in javafx.css.converter that return StyleConverter
      Modifier and Type | 方法 | 描述
      static StyleConverter<String,Boolean> | BooleanConverter.getInstance​()
      static StyleConverter<String,Color> | ColorConverter.getInstance​()
      static StyleConverter<String,Cursor> | CursorConverter.getInstance​()
      static StyleConverter<ParsedValue<?,Size>,Duration> | DurationConverter.getInstance​()
      static StyleConverter<ParsedValue[],Effect> | EffectConverter.getInstance​()
      static StyleConverter<?,?> | EnumConverter.getInstance​(String ename)
      static StyleConverter<ParsedValue[],Font> | FontConverter.getInstance​()
      static StyleConverter<ParsedValue[],Insets> | InsetsConverter.getInstance​()
      static StyleConverter<ParsedValue<?,Paint>,Paint> | PaintConverter.getInstance​()
      static StyleConverter<String,Shape> | ShapeConverter.getInstance​()
      static StyleConverter<ParsedValue<?,Size>,Number> | SizeConverter.getInstance​()
      static StyleConverter<String,String> | StringConverter.getInstance​()
      static StyleConverter<ParsedValue[],String> | URLConverter.getInstance​()
      static StyleConverter<?,?> | EnumConverter.readBinary​(DataInputStream is, String[] strings)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleConverter.StringStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleConverter.StringStore

  • Packages that use StyleConverter.StringStore
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。

    • Uses of StyleConverter.StringStore in javafx.css

      Methods in javafx.css with parameters of type StyleConverter.StringStore
      Modifier and Type | 方法 | 描述
      protected void | CompoundSelector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)
      protected void | Selector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)
      protected void | SimpleSelector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)
      void StyleConverter.writeBinary​(DataOutputStream os, StyleConverter.StringStore sstore)
      写二进制数据。

    • Uses of StyleConverter.StringStore in javafx.css.converter

      Methods in javafx.css.converter with parameters of type StyleConverter.StringStore
      Modifier and Type | 方法 | 描述
      void | EnumConverter.writeBinary​(DataOutputStream os, StyleConverter.StringStore sstore)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.StyleOrigin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.StyleOrigin

  • Packages that use StyleOrigin
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StyleOrigin in javafx.css

      Methods in javafx.css that return StyleOrigin
      Modifier and Type | 方法 | 描述
      StyleOrigin | Rule.getOrigin​()
      StyleOrigin | Stylesheet.getOrigin​()
      StyleOrigin StyleableBooleanProperty.getStyleOrigin​()
      告诉物业的价值的起源。
      StyleOrigin StyleableDoubleProperty.getStyleOrigin​()
      告诉物业的价值的起源。
      StyleOrigin StyleableFloatProperty.getStyleOrigin​()
      告诉物业的价值的起源。
      StyleOrigin StyleableIntegerProperty.getStyleOrigin​()
      告诉物业的价值的起源。
      StyleOrigin StyleableLongProperty.getStyleOrigin​()
      告诉物业的价值的起源。
      StyleOrigin StyleableObjectProperty.getStyleOrigin​()
      告诉物业的价值的起源。
      StyleOrigin StyleableProperty.getStyleOrigin​()
      告诉物业的价值的起源。
      StyleOrigin StyleableStringProperty.getStyleOrigin​()
      告诉物业的价值的起源。
      static StyleOrigin StyleOrigin.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StyleOrigin[] StyleOrigin.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.css with parameters of type StyleOrigin
      Modifier and Type | 方法 | 描述
      void StyleableBooleanProperty.applyStyle​(StyleOrigin origin, Boolean v)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableDoubleProperty.applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableFloatProperty.applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableIntegerProperty.applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableLongProperty.applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableObjectProperty.applyStyle​(StyleOrigin origin, T v)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableProperty.applyStyle​(StyleOrigin origin, T value)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableStringProperty.applyStyle​(StyleOrigin origin, String v)
      这个方法从CSS代码调用来设置属性的值。
      void CssMetaData.set​(S styleable, V value, StyleOrigin origin)
      已过时。
      此方法不再从CSS代码调用。 使用StyleableProperty.applyStyle(javafx.css.StyleOrigin, java.lang.Object)
      void | Stylesheet.setOrigin​(StyleOrigin origin)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.Stylesheet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.Stylesheet

  • Packages that use Stylesheet
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of Stylesheet in javafx.css

      Methods in javafx.css that return Stylesheet
      Modifier and Type | 方法 | 描述
      Stylesheet | Rule.getStylesheet​()
      static Stylesheet Stylesheet.loadBinary​(URL url)
      从输入流加载二进制样式表文件。
      Stylesheet CssParser.parse​(String stylesheetText)
      从CSS文档字符串创建样式表。
      Stylesheet CssParser.parse​(String docbase, String stylesheetText)
      使用docbase作为解析样式表中的引用的基本URL从CSS文档字符串创建样式表。
      Stylesheet CssParser.parse​(URL url)
      通过从URL读取CSS文档来更新给定的样式表，假设UTF-8编码。
      Stylesheet CssParser.parseInlineStyle​(Styleable node)
      从节点解析一个在线样式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.css.Styleable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.css.Styleable

  • Packages that use Styleable
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of Styleable in javafx.css

      Classes in javafx.css with type parameters of type Styleable
      Modifier and Type Class 描述
      class  CssMetaData<S extends Styleable,V>
      CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。
      class  FontCssMetaData<S extends Styleable>
      CssMetaData部分实现Font属性，其中包含字体子属性：weight，style，family和size。
      class  StyleablePropertyFactory<S extends Styleable>
      使用相应的CssMetaData创建StyleableProperty实例的方法。
      Methods in javafx.css that return Styleable
      Modifier and Type 方法 描述
      Styleable Styleable.getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      Methods in javafx.css that return types with arguments of type Styleable
      Modifier and Type 方法 描述
      CssMetaData<? extends Styleable,Boolean> SimpleStyleableBooleanProperty.getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableDoubleProperty.getCssMetaData​()
      反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableFloatProperty.getCssMetaData​()
      反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableIntegerProperty.getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableLongProperty.getCssMetaData​()
      反映出对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,T> SimpleStyleableObjectProperty.getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,String> SimpleStyleableStringProperty.getCssMetaData​()
      反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty
      List<CssMetaData<? extends Styleable,?>> Styleable.getCssMetaData​()
      这个样式的CssMetaData。
      CssMetaData<? extends Styleable,T> StyleableProperty.getCssMetaData​()
      反映对应于这个 javafx.beans.property.StyleableProperty
      List<CssMetaData<? extends Styleable,?>> StyleablePropertyFactory.getCssMetaData​()
      获取给定Styleable的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> CssMetaData.getSubProperties​()
      子属性是指该属性的组成属性（如果有）。
      Methods in javafx.css with parameters of type Styleable
      Modifier and Type | 方法 | 描述
      boolean | CompoundSelector.applies​(Styleable styleable)
      boolean | CompoundSelector.applies​(Styleable styleable, Set<PseudoClass>[] triggerStates, int depth)
      abstract boolean | Selector.applies​(Styleable styleable)
      abstract boolean | Selector.applies​(Styleable styleable, Set<PseudoClass>[] triggerStates, int bit)
      boolean | SimpleSelector.applies​(Styleable styleable)
      boolean | SimpleSelector.applies​(Styleable styleable, Set<PseudoClass>[] pseudoClasses, int depth)
      Stylesheet CssParser.parseInlineStyle​(Styleable node)
      从节点解析一个在线样式。
      boolean | CompoundSelector.stateMatches​(Styleable styleable, Set<PseudoClass> states)
      abstract boolean Selector.stateMatches​(Styleable styleable, Set<PseudoClass> state)
      确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。
      boolean | SimpleSelector.stateMatches​(Styleable styleable, Set<PseudoClass> states)
      Method parameters in javafx.css with type arguments of type Styleable
      Modifier and Type 方法 描述
      T StyleConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)
      从成分值转换为目标属性类型。
      Constructors in javafx.css with parameters of type Styleable
      Constructor 描述
      PropertySetError​(CssMetaData styleableProperty, Styleable styleable, String message)
      Constructor parameters in javafx.css with type arguments of type Styleable
      Constructor 描述
      CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue, boolean inherits, List<CssMetaData<? extends Styleable,?>> subProperties)
      用给定的参数构造一个CssMetaData，没有子属性。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, boolean initialValue)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Double initialValue)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Float initialValue)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData)
      的构造函数为 SimpleStyleableObjectProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name, T initialValue)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, T initialValue)
      SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, String initialValue)
      SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。
      StyleablePropertyFactory​(List<CssMetaData<? extends Styleable,?>> parentCssMetaData)
      构造函数通过父类的CssMetaData传递，通常通过调用父 getClassCssMetaData()的静态方法 getClassCssMetaData() 。

    • Uses of Styleable in javafx.css.converter

      Method parameters in javafx.css.converter with type arguments of type Styleable
      Modifier and Type | 方法 | 描述
      Font | FontConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)

    • Uses of Styleable in javafx.embed.swing

      Classes in javafx.embed.swing that implement Styleable
      Modifier and Type Class 描述
      class  SwingNode
      此类用于将Swing内容嵌入到JavaFX应用程序中。

    • Uses of Styleable in javafx.scene

      Classes in javafx.scene that implement Styleable
      Modifier and Type Class 描述
      class  AmbientLight
      定义环境光源对象。
      class  Camera
      用于渲染场景的相机的基类。
      class  Group
      一个 Group节点包含一个可观察的子节点列表，每当呈现该节点时，它们按顺序渲染。
      class  LightBase
      LightBase类提供了表示光源形式的对象的常用属性的定义。
      class  Node
      场景图节点的基类。
      class  ParallelCamera
      指定用于渲染场景而不进行透视校正的并行相机。
      class  Parent
      在场景图中有子节点的所有节点的基类。
      class  PerspectiveCamera
      指定用于渲染场景的透视相机。
      class  PointLight
      定义点光源对象。
      class  SubScene
      SubScene类是场景图中内容的容器。
      Methods in javafx.scene that return Styleable
      Modifier and Type 方法 描述
      Styleable Node.getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      Methods in javafx.scene that return types with arguments of type Styleable
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Node.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Node.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

    • Uses of Styleable in javafx.scene.canvas

      Classes in javafx.scene.canvas that implement Styleable
      Modifier and Type Class 描述
      class  Canvas
      Canvas是可以使用由GraphicsContext提供的一组图形命令绘制的图像。

    • Uses of Styleable in javafx.scene.chart

      Classes in javafx.scene.chart that implement Styleable
      Modifier and Type Class 描述
      class  AreaChart<X,Y>
      AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
      class  Axis<T>
      JavaFX中所有轴的基类，表示在图表区域上绘制的轴。
      class  BarChart<X,Y>
      绘制一个指示类别数据值的条形图。
      class  BubbleChart<X,Y>
      为一系列数据点绘制气泡的图表类型。
      class  CategoryAxis
      一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。
      class  Chart
      所有图表的基础类。
      class  LineChart<X,Y>
      线图绘制了连接数据点的行。
      class  NumberAxis
      一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
      class  PieChart
      显示PieChart。
      class  ScatterChart<X,Y>
      绘制一系列数据点符号的图表类型。
      class  StackedAreaChart<X,Y>
      StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。
      class  StackedBarChart<X,Y>
      StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。
      class  ValueAxis<T extends Number>
      数据定义为数字的轴。
      class  XYChart<X,Y>
      所有2轴图的图表基类。
      Methods in javafx.scene.chart that return types with arguments of type Styleable
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | AreaChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Axis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | BarChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | CategoryAxis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Chart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | LineChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | NumberAxis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | PieChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | StackedAreaChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | StackedBarChart.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ValueAxis.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | XYChart.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> AreaChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Axis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> BarChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> CategoryAxis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Chart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> LineChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> NumberAxis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> PieChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> StackedAreaChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> StackedBarChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ValueAxis.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> XYChart.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

    • Uses of Styleable in javafx.scene.control

      Classes in javafx.scene.control that implement Styleable
      Modifier and Type Class 描述
      class  Accordion
      手风琴是一组TitlePanes 。
      class  Button
      一个简单的按钮控件。
      class  ButtonBar
      ButtonBar本质上是一个HBox ，具有用于操作系统特定按钮放置的附加功能。
      class  ButtonBase
      按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
      class  Cell<T>
      细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
      class  CheckBox
      三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
      class  CheckMenuItem
      A MenuItem可以在选定状态和未选择状态之间切换。
      class  ChoiceBox<T>
      ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
      class  ColorPicker
      ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
      class  ComboBox<T>
      针对最常见的ComboBox形式的ComboBoxBase抽象类的实现，向用户提供一个弹出列表，为他们提供可以选择的选项。
      class  ComboBoxBase<T>
      ComboBox类控件的抽象基类。
      class  ContextMenu
      一个包含菜单项的ObservableList的弹出控件。
      class  Control
      所有用户界面控件的基类。
      class  CustomMenuItem
      A MenuItem允许通过将Node分配给content属性来嵌入其中的任意节点。
      class  DateCell
      DateCell由DatePicker用于在日历月中呈现单个网格单元格。
      class  DatePicker
      DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
      class  DialogPane
      DialogPane应该被认为是在Dialog实例中显示的根节点 。
      class  Hyperlink
      一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
      class  IndexedCell<T>
      一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。
      class  Label
      标签是不可编辑的文本控件。
      class  Labeled
      A标签的Control是其用户界面的一部分，与其相关联的文本内容。
      class  ListCell<T>
      Cell类型在ListView实例中使用。
      class  ListView<T>
      ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
      class  Menu
      可触发的项目的弹出菜单，仅根据请求向用户显示。
      class  MenuBar
      MenuBar控件传统上放置在用户界面的最上方，嵌入在其中是Menus 。
      class  MenuButton
      MenuButton是一个按钮，当点击或按下时，将显示一个ContextMenu 。
      class  MenuItem
      MenuItem旨在与Menu结合使用，为用户提供选项。
      class  Pagination
      分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
      class  PasswordField
      掩码输入字符的文本字段。
      class  PopupControl
      PopupWindow的扩展，允许CSS样式。
      protected class  PopupControl.CSSBridge
      弹出窗口和场景图之间的链接。
      class  ProgressBar
      ProgressIndator的专业化表示为横杠。
      class  ProgressIndicator
      用于指示进度的循环控制，无限（也称为不确定）或有限。
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  RadioMenuItem
      一个RadioMenuItem是一个MenuItem可以切换（它使用Toggle mixin）。
      class  ScrollBar
      具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。
      class  ScrollPane
      提供其内容的滚动，剪切视口的控件。
      class  Separator
      水平或垂直分隔线。
      class  SeparatorMenuItem
      甲MenuItem该顾名思义允许的水平隔板将要被嵌入在其内，通过分配一个Separator到content所述的属性CustomMenuItem这提供了方便作为基menuitems可以通过分离器进行分离。
      class  Slider
      滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。
      class  Spinner<T>
      单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。
      class  SplitMenuButton
      SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。
      class  SplitPane
      具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
      class  Tab
      标签放置在TabPane中 ，其中每个标签代表单个“页面”。
      class  TableCell<S,T>
      在TableView中表示单行/列交集。
      class  TableColumn<S,T>
      A TableView由多个TableColumn实例组成。
      class  TableColumnBase<S,T>
      台状控件（如TableView和TreeTableView ）是由一个具体的子类TableColumnBase（零个或多个实例的TableColumn和TreeTableColumn ，分别地）。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TableView<S>
      TableView控件旨在可视化无限数量的数据行，分为列。
      class  TabPane
      允许在一组Tabs之间切换的控件 。
      class  TextArea
      文本输入组件，允许用户输入多行纯文本。
      class  TextField
      文本输入组件，允许用户输入一行未格式化的文本。
      class  TextInputControl
      文本输入控件的抽象基类。
      class  TitledPane
      TitledPane是一个可以打开和关闭的标题的面板。
      class  ToggleButton
      A ToggleButton是具有选择能力的专业控制。
      class  ToolBar
      ToolBar是一个可以水平或垂直显示项目的控件。
      class  Tooltip
      工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableColumn<S,T>
      A TreeTableView由多个TreeTableColumn实例组成。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
      class  TreeTableView<S>
      TreeTableView控件旨在可视化无限数量的数据行，分为列。
      class  TreeView<T>
      TreeView控件提供了一个到根的视图（类型为TreeItem ）。
      Methods in javafx.scene.control that return Styleable
      Modifier and Type | 方法 | 描述
      Styleable MenuItem.getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      Styleable PopupControl.CSSBridge.getStyleableParent​()
      该方法应被视为最终方法，不应被CSSBridge的任何子类覆盖。
      Styleable PopupControl.getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      Styleable Tab.getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      Styleable TableColumn.getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      Styleable | Tooltip.getStyleableParent​()
      Styleable TreeTableColumn.getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      Methods in javafx.scene.control that return types with arguments of type Styleable
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Control.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | DatePicker.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | DialogPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Labeled.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ListView.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | MenuBar.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Pagination.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | PopupControl.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ScrollBar.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ScrollPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Separator.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> SkinBase.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> | Slider.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | SplitPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Tab.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TableColumn.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TableView.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TabPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextArea.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextField.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextInputControl.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TitledPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | ToolBar.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Tooltip.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TreeTableColumn.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TreeTableView.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TreeView.getClassCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | Control.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | DatePicker.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | Labeled.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ListView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | MenuBar.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | Pagination.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ScrollBar.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ScrollPane.getControlCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | Separator.getControlCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | Slider.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | SplitPane.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TableView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TabPane.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TextArea.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TextField.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TextInputControl.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TitledPane.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | ToolBar.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TreeTableView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | TreeView.getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Control.getCssMetaData​()
      此方法返回一个List，其中包含所有CssMetaData（用于此控件）（从Control.getControlCssMetaData()返回）及其Skin ，假设skin property为SkinBase 。
      List<CssMetaData<? extends Styleable,?>> DialogPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> | MenuItem.getCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | PopupControl.CSSBridge.getCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> PopupControl.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> SkinBase.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Tab.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> TableColumn.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> Tooltip.getCssMetaData​()
      这个样式的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> TreeTableColumn.getCssMetaData​()
      这个样式的CssMetaData。

    • Uses of Styleable in javafx.scene.control.cell

      Classes in javafx.scene.control.cell that implement Styleable
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含ListCell实现的类，可以在单元格内绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含TableCell实现的类，可以在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格内绘制一个CheckBox节点，同时支持常见的交互（ 稍后更详细地讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，它在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，它在单元格中绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含TableCell实现的类，在单元格内绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含一个TreeTableCell实现的类，它在单元格内绘制一个ProgressBar节点。
      class  TextFieldListCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格内绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个类包含一个TreeCell实现，在单元格内绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含TableCell实现的类，它在单元格内绘制一个TextField节点。

    • Uses of Styleable in javafx.scene.control.skin

      Classes in javafx.scene.control.skin that implement Styleable
      Modifier and Type Class 描述
      class  NestedTableColumnHeader
      此类用于构造TableView的头。
      class  TableColumnHeader
      负责绘制单列标题的区域。
      class  TableHeaderRow
      负责绘制整列列标题的区域。
      class  VirtualFlow<T extends IndexedCell>
      使用基于单元的机制实现虚拟化容器。
      Methods in javafx.scene.control.skin that return types with arguments of type Styleable
      Modifier and Type 方法 描述
      static List<CssMetaData<? extends Styleable,?>> CellSkinBase.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ColorPickerSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> MenuBarSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> PaginationSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ProgressBarSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ProgressIndicatorSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TableColumnHeader.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TabPaneSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TextInputControlSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> ToolBarSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TreeCellSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      static List<CssMetaData<? extends Styleable,?>> TreeTableRowSkin.getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> CellSkinBase.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ColorPickerSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> MenuBarSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> PaginationSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ProgressBarSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ProgressIndicatorSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TableColumnHeader.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TabPaneSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TextInputControlSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> ToolBarSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TreeCellSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TreeTableRowSkin.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

    • Uses of Styleable in javafx.scene.image

      Classes in javafx.scene.image that implement Styleable
      Modifier and Type Class 描述
      class  ImageView
      ImageView是一个Node用于绘制加载Image类的图像。
      Methods in javafx.scene.image that return types with arguments of type Styleable
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | ImageView.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> ImageView.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of Styleable in javafx.scene.layout

      Classes in javafx.scene.layout that implement Styleable
      Modifier and Type Class 描述
      class  AnchorPane
      AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。
      class  BorderPane
      BorderPane在上，左，右，底部和中间位置摆放孩子。
      class  FlowPane
      FlowPane将其孩子摆放在流过玻璃边界的流中。
      class  GridPane
      GridPane将其孩子放在一个灵活的行和列格网中。
      class  HBox
      HBox将孩子放在一排水平排列中。
      class  Pane
      布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
      class  Region
      Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
      class  StackPane
      StackPane将它的孩子放在一个靠前的堆叠中。
      class  TilePane
      TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。
      class  VBox
      VBox把孩子放在一个垂直的立柱上。
      Methods in javafx.scene.layout that return types with arguments of type Styleable
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Background.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Border.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | FlowPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | GridPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | HBox.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Region.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | StackPane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TilePane.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | VBox.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> FlowPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> GridPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> HBox.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Region.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> StackPane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> TilePane.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> VBox.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

    • Uses of Styleable in javafx.scene.media

      Classes in javafx.scene.media that implement Styleable
      Modifier and Type Class 描述
      class  MediaView
      甲Node提供的视图Media由正在播放MediaPlayer 。

    • Uses of Styleable in javafx.scene.shape

      Classes in javafx.scene.shape that implement Styleable
      Modifier and Type Class 描述
      class  Arc
      所述 Arc类表示2D弧对象，由中心点限定的，起始角度（度），角度范围（以度数表示的弧的长度），和一弧型（ ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND ）。
      class  Box
      Box类定义了具有指定大小的3维框。
      class  Circle
      Circle类创建一个新的圆，其中指定的半径和中心位置以像素为单位。
      class  CubicCurve
      CubiCurve类定义了（x，y）坐标空间中的三次Bézier参数曲线段。
      class  Cylinder
      Cylinder类定义了具有指定大小的3维圆柱体。
      class  Ellipse
      Ellipse类创建一个具有指定大小和位置（以像素为单位）的新椭圆
      class  Line
      此行代表 (x,y)坐标空间中的线段。
      class  MeshView
      MeshView类定义了一个具有指定3D网格数据的曲面。
      class  Path
      Path类代表一个简单的形状，并提供了几何路径的基本构造和管理所需的设施。
      class  Polygon
      创建由x，y坐标数组定义的多边形。
      class  Polyline
      创建折线，由分段点数组定义。
      class  QuadCurve
      Quadcurve类定义了（x，y）坐标空间中的二次Bézier参数曲线段。
      class  Rectangle
      Rectangle类定义了一个具有指定大小和位置的矩形。
      class  Shape
      Shape类为表示某种形状的几何形状的对象提供了常见属性的定义。
      class  Shape3D
      Shape3D基类为表示某种形式的3D几何形状的对象提供了常用属性的定义。
      class  Sphere
      Sphere类定义了具有指定大小的三维球体。
      class  SVGPath
      SVGPath类表示通过从String解析SVG路径数据构造的简单形状。
      Methods in javafx.scene.shape that return types with arguments of type Styleable
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Rectangle.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | Shape.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Rectangle.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> Shape.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

    • Uses of Styleable in javafx.scene.text

      Classes in javafx.scene.text that implement Styleable
      Modifier and Type Class 描述
      class  Text
      Text类定义了一个显示文本的节点。
      class  TextFlow
      TextFlow是设计用于布置富文本的特殊布局。
      Methods in javafx.scene.text that return types with arguments of type Styleable
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | Text.getClassCssMetaData​()
      static List<CssMetaData<? extends Styleable,?>> | TextFlow.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> Text.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      List<CssMetaData<? extends Styleable,?>> | TextFlow.getCssMetaData​()

    • Uses of Styleable in javafx.scene.web

      Classes in javafx.scene.web that implement Styleable
      Modifier and Type Class 描述
      class  HTMLEditor
      允许用户编辑文本并将样式应用于此文本的控件。
      class  WebView
      WebView是一个Node ，它管理一个WebEngine并显示其内容。
      Methods in javafx.scene.web that return types with arguments of type Styleable
      Modifier and Type | 方法 | 描述
      static List<CssMetaData<? extends Styleable,?>> | WebView.getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> WebView.getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.css.StyleableProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.css.StyleableProperty

  • Packages that use StyleableProperty
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。

    • Uses of StyleableProperty in javafx.css

      Classes in javafx.css that implement StyleableProperty
      Modifier and Type Class 描述
      class  SimpleStyleableBooleanProperty
      这个类扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableDoubleProperty
      这个课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableFloatProperty
      这个类扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableIntegerProperty
      该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableLongProperty
      该课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableObjectProperty<T>
      这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。
      class  SimpleStyleableStringProperty
      该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。
      class  StyleableBooleanProperty
      这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableDoubleProperty
      这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableFloatProperty
      这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableIntegerProperty
      这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableLongProperty
      这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableObjectProperty<T>
      这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。
      class  StyleableStringProperty
      这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。
      Methods in javafx.css that return StyleableProperty
      Modifier and Type 方法 描述
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function)
      创建一个StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建一个具有初始值的StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Boolean>并继承标志。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty)
      使用之前创建的CssMetaData为给定的 cssProperty创建一个StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function)
      创建一个StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建一个具有初始值的StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Color>并继承标志。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function)
      创建一个StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建一个具有初始值的StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Duration>并继承标志。
      StyleableProperty<Effect> StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Effect>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Class<E> enumClass)
      创建一个StyleableProperty <E使用以前创建的CssMetaData为给定的 cssProperty扩展枚举<E >>。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function)
      创建一个StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue)
      创建一个具有初始值的StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Effect>并继承标志。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass)
      创建一个StyleableProperty <E extends Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue)
      创建一个StyleableProperty <E使用初始值扩展Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue, boolean inherits)
      创建一个StyleableProperty <E使用初始值扩展枚举<E >>并继承标志。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function)
      创建一个StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建一个具有初始值的StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Font>并继承标志。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Insets>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function)
      创建一个StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建一个具有初始值的StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Inset>并继承标志。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty)
      使用之前创建的CssMetaData为给定的 cssProperty创建一个StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function)
      创建一个StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建一个具有初始值的StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Number>并继承标志。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function)
      创建一个StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建一个具有初始值的StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Paint>并继承标志。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)
      创建一个StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <String>并继承标志。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <String>并继承标志。
      abstract StyleableProperty<V> CssMetaData.getStyleableProperty​(S styleable)
      返回给定节点的相应StyleableProperty 。
      Method parameters in javafx.css with type arguments of type StyleableProperty
      Modifier and Type 方法 描述
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function)
      创建一个具有初始值的CssMetaData <S，Boolean>，并继承标志，两者都默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建具有初始值的CssMetaData <S，Boolean>，并将标志默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Boolean>，并继承标志。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function)
      创建一个CssMetaData <S，Color>，初始值为Color.BLACK，并继承标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Color>并继承标志。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function)
      创建一个具有Duration.BLACK的初始值的CssMetaData <S，Duration>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Duration>并继承标志。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，Effect>，初始值为null，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，Effect>，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Effect>并继承标志。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，枚举>，并继承标志。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function)
      创建CssMetaData <S，Font>，初始值为 Font.getDefault() ，并将标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的CssMetaData <S，Font>并继承标志。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function)
      创建CssMetaData <S，Insets>，初始值为 Insets.EMPTY ，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Insets>并继承标志。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function)
      使用Color.BLACK的初始值创建一个CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Paint>并继承标志。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function)
      创建CssMetaData <S，Number>，初始值为 0d ，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Number>，并继承标志。
      CssMetaData<S,String> StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function)
      创建CssMetaData <S，String>，初始值为null，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)
      创建具有初始值的CssMetaData <S，String>，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，String>并继承标志。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function)
      创建一个StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建一个具有初始值的StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Boolean>并继承标志。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function)
      创建一个StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建一个具有初始值的StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Color>并继承标志。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function)
      创建一个StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建一个具有初始值的StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Duration>并继承标志。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function)
      创建一个StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue)
      创建一个具有初始值的StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Effect>并继承标志。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass)
      创建一个StyleableProperty <E extends Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue)
      创建一个StyleableProperty <E使用初始值扩展Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue, boolean inherits)
      创建一个StyleableProperty <E使用初始值扩展枚举<E >>并继承标志。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function)
      创建一个StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建一个具有初始值的StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Font>并继承标志。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function)
      创建一个StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建一个具有初始值的StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Inset>并继承标志。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function)
      创建一个StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建一个具有初始值的StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Number>并继承标志。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function)
      创建一个StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建一个具有初始值的StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Paint>并继承标志。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)
      创建一个StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <String>并继承标志。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)
      创建一个具有初始值的StyleableProperty <String>。
      StyleableProperty<String> StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <String>并继承标志。
      CssMetaData<S,String> StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function)
      创建CssMetaData <S，String>，初始值为null，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)
      创建具有初始值的CssMetaData <S，String>，并将标志默认为false。
      CssMetaData<S,String> StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，String>并继承标志。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


BooleanConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class BooleanConverter

  • java.lang.Object
    • javafx.css.StyleConverter<String,Boolean>
      • javafx.css.converter.BooleanConverter

  • public final class BooleanConverter
extends StyleConverter<String,Boolean>
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Boolean convert​(ParsedValue<String,Boolean> value, Font not_used)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<String,Boolean> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<String,Boolean> getInstance​()

      • convert

        public Boolean convert​(ParsedValue<String,Boolean> value,
                       Font not_used)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<String,Boolean>
        参数
        value - 要转换的ParsedValue
        not_used -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ColorConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class ColorConverter

  • java.lang.Object
    • javafx.css.StyleConverter<String,Color>
      • javafx.css.converter.ColorConverter

  • public final class ColorConverter
extends StyleConverter<String,Color>
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Color convert​(ParsedValue<String,Color> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<String,Color> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<String,Color> getInstance​()

      • convert

        public Color convert​(ParsedValue<String,Color> value,
                     Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<String,Color>
        参数
        value - ParsedValue转换
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CursorConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class CursorConverter

  • java.lang.Object
    • javafx.css.StyleConverter<String,Cursor>
      • javafx.css.converter.CursorConverter

  • public final class CursorConverter
extends StyleConverter<String,Cursor>
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Cursor convert​(ParsedValue<String,Cursor> value, Font not_used)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<String,Cursor> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<String,Cursor> getInstance​()

      • convert

        public Cursor convert​(ParsedValue<String,Cursor> value,
                      Font not_used)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert中的 StyleConverter<String,Cursor>
        参数
        value - 要转换的ParsedValue
        not_used -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DeriveColorConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class DeriveColorConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Color>
      • javafx.css.converter.DeriveColorConverter

  • public final class DeriveColorConverter
extends StyleConverter<ParsedValue[],Color>
    从颜色和亮度值导出颜色

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Color convert​(ParsedValue<ParsedValue[],Color> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static DeriveColorConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static DeriveColorConverter getInstance​()

      • convert

        public Color convert​(ParsedValue<ParsedValue[],Color> value,
                     Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Color>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DeriveSizeConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class DeriveSizeConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue<Size,Size>[],Size>
      • javafx.css.converter.DeriveSizeConverter

  • public final class DeriveSizeConverter
extends StyleConverter<ParsedValue<Size,Size>[],Size>
    一种组合两个Size值的类型。 这种类型的主要目的是处理CSS中的“convert（size1，size2）”表达式。

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Size convert​(ParsedValue<ParsedValue<Size,Size>[],Size> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static DeriveSizeConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static DeriveSizeConverter getInstance​()

      • convert

        public Size convert​(ParsedValue<ParsedValue<Size,Size>[],Size> value,
                    Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue<Size,Size>[],Size>
        参数
        value - 要转换的ParsedValue
        font - 转换relative时使用的Font 。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DurationConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class DurationConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue<?,Size>,Duration>
      • javafx.css.converter.DurationConverter

  • public final class DurationConverter
extends StyleConverter<ParsedValue<?,Size>,Duration>
    将大小转换为持续时间
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Duration convert​(ParsedValue<ParsedValue<?,Size>,Duration> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<ParsedValue<?,Size>,Duration> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<ParsedValue<?,Size>,Duration> getInstance​()

      • convert

        public Duration convert​(ParsedValue<ParsedValue<?,Size>,Duration> value,
                        Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue<?,Size>,Duration>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般情况下， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EffectConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class EffectConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Effect>
      • javafx.css.converter.EffectConverter
  • 已知直接子类：
    EffectConverter.DropShadowConverter ， EffectConverter.InnerShadowConverter

    public class EffectConverter
extends StyleConverter<ParsedValue[],Effect>
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class | 描述
      static class  | EffectConverter.DropShadowConverter
      static class  | EffectConverter.InnerShadowConverter

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | EffectConverter​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      static void | clearCache​()
      Effect convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<ParsedValue[],Effect> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 构造方法详细信息

      • EffectConverter

        protected EffectConverter​()

    • 方法详细信息

      • getInstance

        public static StyleConverter<ParsedValue[],Effect> getInstance​()

      • convert

        public Effect convert​(ParsedValue<ParsedValue[],Effect> value,
                      Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Effect>
        参数
        value - 转换ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • clearCache

        public static void clearCache​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EffectConverter.DropShadowConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class EffectConverter.DropShadowConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Effect>
      • javafx.css.converter.EffectConverter
        • javafx.css.converter.EffectConverter.DropShadowConverter
  • Enclosing class:
    EffectConverter

    public static final class EffectConverter.DropShadowConverter
extends EffectConverter

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.converter.EffectConverter

        EffectConverter.DropShadowConverter, EffectConverter.InnerShadowConverter

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Effect convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static EffectConverter.DropShadowConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class javafx.css.converter.EffectConverter

        clearCache

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static EffectConverter.DropShadowConverter getInstance​()

      • convert

        public Effect convert​(ParsedValue<ParsedValue[],Effect> value,
                      Font font)
        说明从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 EffectConverter
        参数
        value - ParsedValue转换
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 EffectConverter
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EffectConverter.InnerShadowConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class EffectConverter.InnerShadowConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Effect>
      • javafx.css.converter.EffectConverter
        • javafx.css.converter.EffectConverter.InnerShadowConverter
  • Enclosing class:
    EffectConverter

    public static final class EffectConverter.InnerShadowConverter
extends EffectConverter

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.converter.EffectConverter

        EffectConverter.DropShadowConverter, EffectConverter.InnerShadowConverter

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Effect convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static EffectConverter.InnerShadowConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class javafx.css.converter.EffectConverter

        clearCache

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static EffectConverter.InnerShadowConverter getInstance​()

      • convert

        public Effect convert​(ParsedValue<ParsedValue[],Effect> value,
                      Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 EffectConverter
        参数
        value - 转换ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般情况下， toString方法返回一个字符串“ toString代表”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 EffectConverter
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EnumConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class EnumConverter<E extends Enum<E>>

  • java.lang.Object
    • javafx.css.StyleConverter<String,E>
      • javafx.css.converter.EnumConverter<E>

  • public final class EnumConverter<E extends Enum<E>>
extends StyleConverter<String,E>
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 构造方法摘要

      构造方法
      Constructor 描述
      EnumConverter​(Class<E> enumClass)

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      E convert​(ParsedValue<String,E> value, Font not_used)
      从解析的CSS值转换为目标属性类型。
      boolean equals​(Object other)
      指示一些其他对象是否等于此。
      static StyleConverter<?,?> | getInstance​(String ename)
      int hashCode​()
      返回对象的哈希码值。
      static StyleConverter<?,?> | readBinary​(DataInputStream is, String[] strings)
      String toString​()
      返回对象的字符串表示形式。
      void writeBinary​(DataOutputStream os, StyleConverter.StringStore sstore)
      写二进制数据。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter

    • 构造方法详细信息

      • EnumConverter

        public EnumConverter​(Class<E> enumClass)

    • 方法详细信息

      • convert

        public E convert​(ParsedValue<String,E> value,
                 Font not_used)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<String,E extends Enum<E>>
        参数
        value - 要转换的ParsedValue
        not_used -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • writeBinary

        public void writeBinary​(DataOutputStream os,
                        StyleConverter.StringStore sstore)
                 throws IOException
        描述从类复制： StyleConverter
        写二进制数据。
        重写：
        writeBinary在 StyleConverter<String,E extends Enum<E>>
        参数
        os - 数据输出流
        sstore - 字符串存储
        异常
        IOException - 例外

      • readBinary

        public static StyleConverter<?,?> readBinary​(DataInputStream is,
                                             String[] strings)
                                      throws IOException
        异常
        IOException

      • getInstance

        public static StyleConverter<?,?> getInstance​(String ename)

      • equals

        public boolean equals​(Object other)
        描述从类别复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖该方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        other - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FontConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class FontConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Font>
      • javafx.css.converter.FontConverter

  • public final class FontConverter
extends StyleConverter<ParsedValue[],Font>
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class | 描述
      static class  | FontConverter.FontSizeConverter
      static class  | FontConverter.FontStyleConverter
      static class  | FontConverter.FontWeightConverter

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Font convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)
      从成分值转换为目标属性类型。
      Font convert​(ParsedValue<ParsedValue[],Font> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<ParsedValue[],Font> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<ParsedValue[],Font> getInstance​()

      • convert

        public Font convert​(ParsedValue<ParsedValue[],Font> value,
                    Font font)
        描述从类复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Font>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • convert

        public Font convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)
        描述从类别复制： StyleConverter
        从成分值转换为目标属性类型。 由具有子键的键类型实现。
        重写：
        convert在 StyleConverter<ParsedValue[],Font>
        参数
        convertedValues - 组成价值
        结果
        目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般情况下， toString方法返回一个字符串“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FontConverter.FontSizeConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class FontConverter.FontSizeConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue<?,Size>,Number>
      • javafx.css.converter.FontConverter.FontSizeConverter
  • Enclosing class:
    FontConverter

    public static final class FontConverter.FontSizeConverter
extends StyleConverter<ParsedValue<?,Size>,Number>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Number convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static FontConverter.FontSizeConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static FontConverter.FontSizeConverter getInstance​()

      • convert

        public Number convert​(ParsedValue<ParsedValue<?,Size>,Number> value,
                      Font font)
        描述从类复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert中的 StyleConverter<ParsedValue<?,Size>,Number>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般情况下， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FontConverter.FontStyleConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class FontConverter.FontStyleConverter

  • java.lang.Object
    • javafx.css.StyleConverter<String,FontPosture>
      • javafx.css.converter.FontConverter.FontStyleConverter
  • Enclosing class:
    FontConverter

    public static final class FontConverter.FontStyleConverter
extends StyleConverter<String,FontPosture>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      FontPosture convert​(ParsedValue<String,FontPosture> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static FontConverter.FontStyleConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static FontConverter.FontStyleConverter getInstance​()

      • convert

        public FontPosture convert​(ParsedValue<String,FontPosture> value,
                           Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<String,FontPosture>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FontConverter.FontWeightConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class FontConverter.FontWeightConverter

  • java.lang.Object
    • javafx.css.StyleConverter<String,FontWeight>
      • javafx.css.converter.FontConverter.FontWeightConverter
  • Enclosing class:
    FontConverter

    public static final class FontConverter.FontWeightConverter
extends StyleConverter<String,FontWeight>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      FontWeight convert​(ParsedValue<String,FontWeight> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static FontConverter.FontWeightConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static FontConverter.FontWeightConverter getInstance​()

      • convert

        public FontWeight convert​(ParsedValue<String,FontWeight> value,
                          Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<String,FontWeight>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InsetsConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class InsetsConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Insets>
      • javafx.css.converter.InsetsConverter

  • public final class InsetsConverter
extends StyleConverter<ParsedValue[],Insets>
    将1到4个大小组件的解析值数组转换为Insets。 大小值被解释为顶部，右侧，底部，左侧。 如果只给出顶部，那么这个值就被用在所有方面。 如果只有顶部和右侧，则底部设置为上部，左侧设置为右侧。 如果给出顶部，右侧和底部，则左侧设置为右侧。
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  InsetsConverter.SequenceConverter
      将一组解析的值转换为Insets对象数组，每个值都是1到4个大小的数组。

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Insets convert​(ParsedValue<ParsedValue[],Insets> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<ParsedValue[],Insets> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<ParsedValue[],Insets> getInstance​()

      • convert

        public Insets convert​(ParsedValue<ParsedValue[],Insets> value,
                      Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert类 StyleConverter<ParsedValue[],Insets>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InsetsConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class InsetsConverter.SequenceConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue<ParsedValue[],Insets>[],Insets[]>
      • javafx.css.converter.InsetsConverter.SequenceConverter
  • Enclosing class:
    InsetsConverter

    public static final class InsetsConverter.SequenceConverter
extends StyleConverter<ParsedValue<ParsedValue[],Insets>[],Insets[]>
    将一组解析的值转换为Insets对象数组，每个值都是1到4个大小的数组。

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Insets[] convert​(ParsedValue<ParsedValue<ParsedValue[],Insets>[],Insets[]> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static InsetsConverter.SequenceConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static InsetsConverter.SequenceConverter getInstance​()

      • convert

        public Insets[] convert​(ParsedValue<ParsedValue<ParsedValue[],Insets>[],Insets[]> value,
                        Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue<ParsedValue[],Insets>[],Insets[]>
        参数
        value - 要转换的ParsedValue
        font - 转换relative时使用的Font 。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.css.converter (Java SE 9 & JDK 9 )

javafx.css.converter

Classes

  • BooleanConverter
  • ColorConverter
  • CursorConverter
  • DeriveColorConverter
  • DeriveSizeConverter
  • DurationConverter
  • EffectConverter
  • EffectConverter.DropShadowConverter
  • EffectConverter.InnerShadowConverter
  • EnumConverter
  • FontConverter
  • FontConverter.FontSizeConverter
  • FontConverter.FontStyleConverter
  • FontConverter.FontWeightConverter
  • InsetsConverter
  • InsetsConverter.SequenceConverter
  • LadderConverter
  • PaintConverter
  • PaintConverter.ImagePatternConverter
  • PaintConverter.LinearGradientConverter
  • PaintConverter.RadialGradientConverter
  • PaintConverter.RepeatingImagePatternConverter
  • PaintConverter.SequenceConverter
  • ShapeConverter
  • SizeConverter
  • SizeConverter.SequenceConverter
  • StopConverter
  • StringConverter
  • StringConverter.SequenceConverter
  • URLConverter
  • URLConverter.SequenceConverter


javafx.css.converter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.css.converter

提供各种转换CSS解析值的StyleConverter类。

  • 类摘要
    Class 描述
    BooleanConverter
    ColorConverter
    CursorConverter
    DeriveColorConverter
    从颜色和亮度值导出颜色
    DeriveSizeConverter
    一种组合两个Size值的类型。
    DurationConverter
    将大小转换为持续时间
    EffectConverter
    EffectConverter.DropShadowConverter
    EffectConverter.InnerShadowConverter
    EnumConverter<E extends Enum<E>>
    FontConverter
    FontConverter.FontSizeConverter
    FontConverter.FontStyleConverter
    FontConverter.FontWeightConverter
    InsetsConverter
    将1到4个大小组件的解析值数组转换为Insets。
    InsetsConverter.SequenceConverter
    将一组解析的值转换为Insets对象数组，每个值都是1到4个大小的数组。
    LadderConverter
    PaintConverter
    PaintConverter.ImagePatternConverter
    PaintConverter.LinearGradientConverter
    PaintConverter.RadialGradientConverter
    PaintConverter.RepeatingImagePatternConverter
    PaintConverter.SequenceConverter
    将解析值数组转换为Paint对象数组。
    ShapeConverter
    将SVG形状字符串转换为Shape对象。
    SizeConverter
    将大小转换为数字
    SizeConverter.SequenceConverter
    StopConverter
    从一个大小和一个颜色转换一个停止
    StringConverter
    字符串类型转换嵌入式unicode字符
    StringConverter.SequenceConverter
    URLConverter
    将表示URL的解析值转换为相对于样式表位置解析的URL字符串。
    URLConverter.SequenceConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.css.converter Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.css.converter

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.css.StyleConverter<F,T>
      • javafx.css.converter.BooleanConverter
      • javafx.css.converter.ColorConverter
      • javafx.css.converter.CursorConverter
      • javafx.css.converter.DeriveColorConverter
      • javafx.css.converter.DeriveSizeConverter
      • javafx.css.converter.DurationConverter
      • javafx.css.converter.EffectConverter
        • javafx.css.converter.EffectConverter.DropShadowConverter
        • javafx.css.converter.EffectConverter.InnerShadowConverter
      • javafx.css.converter.EnumConverter<E>
      • javafx.css.converter.FontConverter
      • javafx.css.converter.FontConverter.FontSizeConverter
      • javafx.css.converter.FontConverter.FontStyleConverter
      • javafx.css.converter.FontConverter.FontWeightConverter
      • javafx.css.converter.InsetsConverter
      • javafx.css.converter.InsetsConverter.SequenceConverter
      • javafx.css.converter.LadderConverter
      • javafx.css.converter.PaintConverter
      • javafx.css.converter.PaintConverter.ImagePatternConverter
      • javafx.css.converter.PaintConverter.LinearGradientConverter
      • javafx.css.converter.PaintConverter.RadialGradientConverter
      • javafx.css.converter.PaintConverter.RepeatingImagePatternConverter
      • javafx.css.converter.PaintConverter.SequenceConverter
      • javafx.css.converter.ShapeConverter
      • javafx.css.converter.SizeConverter
      • javafx.css.converter.SizeConverter.SequenceConverter
      • javafx.css.converter.StopConverter
      • javafx.css.converter.StringConverter
      • javafx.css.converter.StringConverter.SequenceConverter
      • javafx.css.converter.URLConverter
      • javafx.css.converter.URLConverter.SequenceConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LadderConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class LadderConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Color>
      • javafx.css.converter.LadderConverter

  • public final class LadderConverter
extends StyleConverter<ParsedValue[],Color>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Color convert​(ParsedValue<ParsedValue[],Color> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static LadderConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static LadderConverter getInstance​()

      • convert

        public Color convert​(ParsedValue<ParsedValue[],Color> value,
                     Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Color>
        参数
        value - 转换ParsedValue
        font - 转换relative时使用的Font 。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PaintConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class PaintConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue<?,Paint>,Paint>
      • javafx.css.converter.PaintConverter

  • public final class PaintConverter
extends StyleConverter<ParsedValue<?,Paint>,Paint>
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class | 描述
      static class  | PaintConverter.ImagePatternConverter
      static class  | PaintConverter.LinearGradientConverter
      static class  | PaintConverter.RadialGradientConverter
      static class  | PaintConverter.RepeatingImagePatternConverter
      static class  PaintConverter.SequenceConverter
      将解析值数组转换为Paint对象数组。

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Paint convert​(ParsedValue<ParsedValue<?,Paint>,Paint> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<ParsedValue<?,Paint>,Paint> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<ParsedValue<?,Paint>,Paint> getInstance​()

      • convert

        public Paint convert​(ParsedValue<ParsedValue<?,Paint>,Paint> value,
                     Font font)
        说明从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue<?,Paint>,Paint>
        参数
        value - 转换ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PaintConverter.ImagePatternConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class PaintConverter.ImagePatternConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Paint>
      • javafx.css.converter.PaintConverter.ImagePatternConverter
  • Enclosing class:
    PaintConverter

    public static final class PaintConverter.ImagePatternConverter
extends StyleConverter<ParsedValue[],Paint>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Paint convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static PaintConverter.ImagePatternConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static PaintConverter.ImagePatternConverter getInstance​()

      • convert

        public Paint convert​(ParsedValue<ParsedValue[],Paint> value,
                     Font font)
        说明从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Paint>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PaintConverter.LinearGradientConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class PaintConverter.LinearGradientConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Paint>
      • javafx.css.converter.PaintConverter.LinearGradientConverter
  • Enclosing class:
    PaintConverter

    public static final class PaintConverter.LinearGradientConverter
extends StyleConverter<ParsedValue[],Paint>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Paint convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static PaintConverter.LinearGradientConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static PaintConverter.LinearGradientConverter getInstance​()

      • convert

        public Paint convert​(ParsedValue<ParsedValue[],Paint> value,
                     Font font)
        说明从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Paint>
        参数
        value - 要转换的ParsedValue
        font - 转换relative时使用的Font 。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般情况下， toString方法返回一个字符串“ toString代表”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PaintConverter.RadialGradientConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class PaintConverter.RadialGradientConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Paint>
      • javafx.css.converter.PaintConverter.RadialGradientConverter
  • Enclosing class:
    PaintConverter

    public static final class PaintConverter.RadialGradientConverter
extends StyleConverter<ParsedValue[],Paint>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Paint convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static PaintConverter.RadialGradientConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static PaintConverter.RadialGradientConverter getInstance​()

      • convert

        public Paint convert​(ParsedValue<ParsedValue[],Paint> value,
                     Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Paint>
        参数
        value - 转换ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PaintConverter.RepeatingImagePatternConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class PaintConverter.RepeatingImagePatternConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Paint>
      • javafx.css.converter.PaintConverter.RepeatingImagePatternConverter
  • Enclosing class:
    PaintConverter

    public static final class PaintConverter.RepeatingImagePatternConverter
extends StyleConverter<ParsedValue[],Paint>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Paint convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static PaintConverter.RepeatingImagePatternConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static PaintConverter.RepeatingImagePatternConverter getInstance​()

      • convert

        public Paint convert​(ParsedValue<ParsedValue[],Paint> value,
                     Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Paint>
        参数
        value - 转换ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本上表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PaintConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class PaintConverter.SequenceConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue<?,Paint>[],Paint[]>
      • javafx.css.converter.PaintConverter.SequenceConverter
  • Enclosing class:
    PaintConverter

    public static final class PaintConverter.SequenceConverter
extends StyleConverter<ParsedValue<?,Paint>[],Paint[]>
    将解析值数组转换为Paint对象数组。

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Paint[] convert​(ParsedValue<ParsedValue<?,Paint>[],Paint[]> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static PaintConverter.SequenceConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static PaintConverter.SequenceConverter getInstance​()

      • convert

        public Paint[] convert​(ParsedValue<ParsedValue<?,Paint>[],Paint[]> value,
                       Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue<?,Paint>[],Paint[]>
        参数
        value - 转换ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ShapeConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class ShapeConverter

  • java.lang.Object
    • javafx.css.StyleConverter<String,Shape>
      • javafx.css.converter.ShapeConverter

  • public class ShapeConverter
extends StyleConverter<String,Shape>
    将SVG形状字符串转换为Shape对象。
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 构造方法摘要

      构造方法
      Constructor 描述
      ShapeConverter​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      static void | clearCache​()
      Shape convert​(ParsedValue<String,Shape> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<String,Shape> | getInstance​()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 构造方法详细信息

      • ShapeConverter

        public ShapeConverter​()

    • 方法详细信息

      • getInstance

        public static StyleConverter<String,Shape> getInstance​()

      • convert

        public Shape convert​(ParsedValue<String,Shape> value,
                     Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<String,Shape>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • clearCache

        public static void clearCache​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SizeConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class SizeConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue<?,Size>,Number>
      • javafx.css.converter.SizeConverter

  • public final class SizeConverter
extends StyleConverter<ParsedValue<?,Size>,Number>
    将大小转换为数字
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class | 描述
      static class  | SizeConverter.SequenceConverter

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Number convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<ParsedValue<?,Size>,Number> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<ParsedValue<?,Size>,Number> getInstance​()

      • convert

        public Number convert​(ParsedValue<ParsedValue<?,Size>,Number> value,
                      Font font)
        描述从类复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue<?,Size>,Number>
        参数
        value - 转换ParsedValue
        font - 转换relative时使用的Font 。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本上代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SizeConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class SizeConverter.SequenceConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Number[]>
      • javafx.css.converter.SizeConverter.SequenceConverter
  • Enclosing class:
    SizeConverter

    public static final class SizeConverter.SequenceConverter
extends StyleConverter<ParsedValue[],Number[]>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Number[] convert​(ParsedValue<ParsedValue[],Number[]> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static SizeConverter.SequenceConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static SizeConverter.SequenceConverter getInstance​()

      • convert

        public Number[] convert​(ParsedValue<ParsedValue[],Number[]> value,
                        Font font)
        描述从类复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Number[]>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StopConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class StopConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],Stop>
      • javafx.css.converter.StopConverter

  • public final class StopConverter
extends StyleConverter<ParsedValue[],Stop>
    从一个大小和一个颜色转换一个停止

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Stop convert​(ParsedValue<ParsedValue[],Stop> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StopConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StopConverter getInstance​()

      • convert

        public Stop convert​(ParsedValue<ParsedValue[],Stop> value,
                    Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],Stop>
        参数
        value - 转换ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class StringConverter

  • java.lang.Object
    • javafx.css.StyleConverter<String,String>
      • javafx.css.converter.StringConverter

  • public final class StringConverter
extends StyleConverter<String,String>
    字符串类型转换嵌入式unicode字符
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class | 描述
      static class  | StringConverter.SequenceConverter

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      String convert​(ParsedValue<String,String> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<String,String> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<String,String> getInstance​()

      • convert

        public String convert​(ParsedValue<String,String> value,
                      Font font)
        说明从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<String,String>
        参数
        value - 要转换的ParsedValue
        font - 转换relative时使用的Font 。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class StringConverter.SequenceConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue<String,String>[],String[]>
      • javafx.css.converter.StringConverter.SequenceConverter
  • Enclosing class:
    StringConverter

    public static final class StringConverter.SequenceConverter
extends StyleConverter<ParsedValue<String,String>[],String[]>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      String[] convert​(ParsedValue<ParsedValue<String,String>[],String[]> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StringConverter.SequenceConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StringConverter.SequenceConverter getInstance​()

      • convert

        public String[] convert​(ParsedValue<ParsedValue<String,String>[],String[]> value,
                        Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue<String,String>[],String[]>
        参数
        value - 要转换的ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般情况下， toString方法返回一个字符串“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


URLConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class URLConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue[],String>
      • javafx.css.converter.URLConverter

  • public final class URLConverter
extends StyleConverter<ParsedValue[],String>
    将表示URL的解析值转换为相对于样式表位置解析的URL字符串。 输入的值为： url("<path>") 。
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class | 描述
      static class  | URLConverter.SequenceConverter

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      String convert​(ParsedValue<ParsedValue[],String> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<ParsedValue[],String> | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static StyleConverter<ParsedValue[],String> getInstance​()

      • convert

        public String convert​(ParsedValue<ParsedValue[],String> value,
                      Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue[],String>
        参数
        value - 转换ParsedValue
        font -该Font到转换时使用relative值。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


URLConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.css.converter

Class URLConverter.SequenceConverter

  • java.lang.Object
    • javafx.css.StyleConverter<ParsedValue<ParsedValue[],String>[],String[]>
      • javafx.css.converter.URLConverter.SequenceConverter
  • Enclosing class:
    URLConverter

    public static final class URLConverter.SequenceConverter
extends StyleConverter<ParsedValue<ParsedValue[],String>[],String[]>

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.css.StyleConverter

        StyleConverter.StringStore

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      String[] convert​(ParsedValue<ParsedValue<ParsedValue[],String>[],String[]> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static URLConverter.SequenceConverter | getInstance​()
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.css.StyleConverter

        cacheValue, clearCache, convert, getBooleanConverter, getCachedValue, getColorConverter, getDurationConverter, getEffectConverter, getEnumConverter, getFontConverter, getInsetsConverter, getPaintConverter, getSizeConverter, getStringConverter, getUrlConverter, readBinary, writeBinary

    • 方法详细信息

      • getInstance

        public static URLConverter.SequenceConverter getInstance​()

      • convert

        public String[] convert​(ParsedValue<ParsedValue<ParsedValue[],String>[],String[]> value,
                        Font font)
        描述从类别复制： StyleConverter
        从解析的CSS值转换为目标属性类型。
        重写：
        convert在 StyleConverter<ParsedValue<ParsedValue[],String>[],String[]>
        参数
        value - 要转换的ParsedValue
        font - 转换relative时使用的Font 。
        结果
        转换的目标属性类型

      • toString

        public String toString​()
        说明从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.css.converter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.css.converter

  • Packages that use javafx.css.converter
    软件包 描述
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
  • Classes in javafx.css.converter used by javafx.css.converter
    Class 描述
    DeriveColorConverter
    从颜色和亮度值导出颜色
    DeriveSizeConverter
    一种组合两个Size值的类型。
    EffectConverter
    EffectConverter.DropShadowConverter
    EffectConverter.InnerShadowConverter
    FontConverter.FontSizeConverter
    FontConverter.FontStyleConverter
    FontConverter.FontWeightConverter
    InsetsConverter.SequenceConverter
    将一组解析的值转换为Insets对象数组，每个值都是1到4个大小的数组。
    LadderConverter
    PaintConverter.ImagePatternConverter
    PaintConverter.LinearGradientConverter
    PaintConverter.RadialGradientConverter
    PaintConverter.RepeatingImagePatternConverter
    PaintConverter.SequenceConverter
    将解析值数组转换为Paint对象数组。
    SizeConverter.SequenceConverter
    StopConverter
    从一个大小和一个颜色转换一个停止
    StringConverter.SequenceConverter
    URLConverter.SequenceConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.BooleanConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.BooleanConverter

No usage of javafx.css.converter.BooleanConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.ColorConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.ColorConverter

No usage of javafx.css.converter.ColorConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.CursorConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.CursorConverter

No usage of javafx.css.converter.CursorConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.DeriveColorConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.DeriveColorConverter

  • Packages that use DeriveColorConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of DeriveColorConverter in javafx.css.converter

      Methods in javafx.css.converter that return DeriveColorConverter
      Modifier and Type | 方法 | 描述
      static DeriveColorConverter | DeriveColorConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.DeriveSizeConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.DeriveSizeConverter

  • Packages that use DeriveSizeConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of DeriveSizeConverter in javafx.css.converter

      Methods in javafx.css.converter that return DeriveSizeConverter
      Modifier and Type | 方法 | 描述
      static DeriveSizeConverter | DeriveSizeConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.DurationConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.DurationConverter

No usage of javafx.css.converter.DurationConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.EffectConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.EffectConverter

  • Packages that use EffectConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of EffectConverter in javafx.css.converter

      Subclasses of EffectConverter in javafx.css.converter
      Modifier and Type | Class | 描述
      static class  | EffectConverter.DropShadowConverter
      static class  | EffectConverter.InnerShadowConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.EffectConverter.DropShadowConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.EffectConverter.DropShadowConverter

  • Packages that use EffectConverter.DropShadowConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of EffectConverter.DropShadowConverter in javafx.css.converter

      Methods in javafx.css.converter that return EffectConverter.DropShadowConverter
      Modifier and Type | 方法 | 描述
      static EffectConverter.DropShadowConverter | EffectConverter.DropShadowConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.EffectConverter.InnerShadowConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.EffectConverter.InnerShadowConverter

  • Packages that use EffectConverter.InnerShadowConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of EffectConverter.InnerShadowConverter in javafx.css.converter

      Methods in javafx.css.converter that return EffectConverter.InnerShadowConverter
      Modifier and Type | 方法 | 描述
      static EffectConverter.InnerShadowConverter | EffectConverter.InnerShadowConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.EnumConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.EnumConverter

No usage of javafx.css.converter.EnumConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.FontConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.FontConverter

No usage of javafx.css.converter.FontConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.FontConverter.FontSizeConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.FontConverter.FontSizeConverter

  • Packages that use FontConverter.FontSizeConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of FontConverter.FontSizeConverter in javafx.css.converter

      Methods in javafx.css.converter that return FontConverter.FontSizeConverter
      Modifier and Type | 方法 | 描述
      static FontConverter.FontSizeConverter | FontConverter.FontSizeConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.FontConverter.FontStyleConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.FontConverter.FontStyleConverter

  • Packages that use FontConverter.FontStyleConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of FontConverter.FontStyleConverter in javafx.css.converter

      Methods in javafx.css.converter that return FontConverter.FontStyleConverter
      Modifier and Type | 方法 | 描述
      static FontConverter.FontStyleConverter | FontConverter.FontStyleConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.FontConverter.FontWeightConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.FontConverter.FontWeightConverter

  • Packages that use FontConverter.FontWeightConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of FontConverter.FontWeightConverter in javafx.css.converter

      Methods in javafx.css.converter that return FontConverter.FontWeightConverter
      Modifier and Type | 方法 | 描述
      static FontConverter.FontWeightConverter | FontConverter.FontWeightConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.InsetsConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.InsetsConverter

No usage of javafx.css.converter.InsetsConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.InsetsConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.InsetsConverter.SequenceConverter

  • Packages that use InsetsConverter.SequenceConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of InsetsConverter.SequenceConverter in javafx.css.converter

      Methods in javafx.css.converter that return InsetsConverter.SequenceConverter
      Modifier and Type | 方法 | 描述
      static InsetsConverter.SequenceConverter | InsetsConverter.SequenceConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.LadderConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.LadderConverter

  • Packages that use LadderConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of LadderConverter in javafx.css.converter

      Methods in javafx.css.converter that return LadderConverter
      Modifier and Type | 方法 | 描述
      static LadderConverter | LadderConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.PaintConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.PaintConverter

No usage of javafx.css.converter.PaintConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.PaintConverter.ImagePatternConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.PaintConverter.ImagePatternConverter

  • Packages that use PaintConverter.ImagePatternConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of PaintConverter.ImagePatternConverter in javafx.css.converter

      Methods in javafx.css.converter that return PaintConverter.ImagePatternConverter
      Modifier and Type | 方法 | 描述
      static PaintConverter.ImagePatternConverter | PaintConverter.ImagePatternConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.PaintConverter.LinearGradientConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.PaintConverter.LinearGradientConverter

  • Packages that use PaintConverter.LinearGradientConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of PaintConverter.LinearGradientConverter in javafx.css.converter

      Methods in javafx.css.converter that return PaintConverter.LinearGradientConverter
      Modifier and Type | 方法 | 描述
      static PaintConverter.LinearGradientConverter | PaintConverter.LinearGradientConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.PaintConverter.RadialGradientConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.PaintConverter.RadialGradientConverter

  • Packages that use PaintConverter.RadialGradientConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of PaintConverter.RadialGradientConverter in javafx.css.converter

      Methods in javafx.css.converter that return PaintConverter.RadialGradientConverter
      Modifier and Type | 方法 | 描述
      static PaintConverter.RadialGradientConverter | PaintConverter.RadialGradientConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.PaintConverter.RepeatingImagePatternConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.PaintConverter.RepeatingImagePatternConverter

  • Packages that use PaintConverter.RepeatingImagePatternConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of PaintConverter.RepeatingImagePatternConverter in javafx.css.converter

      Methods in javafx.css.converter that return PaintConverter.RepeatingImagePatternConverter
      Modifier and Type | 方法 | 描述
      static PaintConverter.RepeatingImagePatternConverter | PaintConverter.RepeatingImagePatternConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.PaintConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.PaintConverter.SequenceConverter

  • Packages that use PaintConverter.SequenceConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of PaintConverter.SequenceConverter in javafx.css.converter

      Methods in javafx.css.converter that return PaintConverter.SequenceConverter
      Modifier and Type | 方法 | 描述
      static PaintConverter.SequenceConverter | PaintConverter.SequenceConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.ShapeConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.ShapeConverter

No usage of javafx.css.converter.ShapeConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.SizeConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.SizeConverter

No usage of javafx.css.converter.SizeConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.SizeConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.SizeConverter.SequenceConverter

  • Packages that use SizeConverter.SequenceConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of SizeConverter.SequenceConverter in javafx.css.converter

      Methods in javafx.css.converter that return SizeConverter.SequenceConverter
      Modifier and Type | 方法 | 描述
      static SizeConverter.SequenceConverter | SizeConverter.SequenceConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.StopConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.StopConverter

  • Packages that use StopConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of StopConverter in javafx.css.converter

      Methods in javafx.css.converter that return StopConverter
      Modifier and Type | 方法 | 描述
      static StopConverter | StopConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.StringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.StringConverter

No usage of javafx.css.converter.StringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.StringConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.StringConverter.SequenceConverter

  • Packages that use StringConverter.SequenceConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of StringConverter.SequenceConverter in javafx.css.converter

      Methods in javafx.css.converter that return StringConverter.SequenceConverter
      Modifier and Type | 方法 | 描述
      static StringConverter.SequenceConverter | StringConverter.SequenceConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.URLConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.URLConverter

No usage of javafx.css.converter.URLConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.css.converter.URLConverter.SequenceConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.css.converter.URLConverter.SequenceConverter

  • Packages that use URLConverter.SequenceConverter
    软件包 描述
    javafx.css.converter
    Provides various StyleConverter classes that convert CSS parsed values.

    • Uses of URLConverter.SequenceConverter in javafx.css.converter

      Methods in javafx.css.converter that return URLConverter.SequenceConverter
      Modifier and Type | 方法 | 描述
      static URLConverter.SequenceConverter | URLConverter.SequenceConverter.getInstance​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


javafx.embed.swing (Java SE 9 & JDK 9 )

javafx.embed.swing

Classes

  • JFXPanel
  • SwingFXUtils
  • SwingNode


javafx.embed.swing (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.swing

Package javafx.embed.swing

提供一组在Swing应用程序中使用JavaFX的类。

JFXPanel类是提供JavaFX和Swing互操作性的基类。 该类定义了一个轻量级的Swing组件，它接受并呈现一个Scene的实例，并将所有输入事件从Swing转发到附加的JavaFX场景。

  • 类摘要
    Class 描述
    JFXPanel
    JFXPanel是将JavaFX内容嵌入到Swing应用程序中的组件。
    SwingFXUtils
    该类提供了用于在Swing / AWT和JavaFX格式之间转换数据类型的实用方法。
    SwingNode
    此类用于将Swing内容嵌入到JavaFX应用程序中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.embed.swing Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.embed.swing

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javafx.embed.swing.JFXPanel
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.embed.swing.SwingNode
    • javafx.embed.swing.SwingFXUtils
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


JFXPanel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.swing
软件包 javafx.embed.swing

Class JFXPanel

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javafx.embed.swing.JFXPanel
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable

    public class JFXPanel
extends JComponent
    JFXPanel是将JavaFX内容嵌入到Swing应用程序中的组件。 要显示的内容使用接受JavaFX Scene实例的setScene(javafx.scene.Scene)方法指定。 场景分配后，会自动重画。 所有输入和焦点事件都将透明地转发给开发人员。

    与JFXPanel有一些限制。 作为Swing组件，只能从事件分派线程访问，除了可以在事件分派线程或JavaFX应用程序线程上调用的setScene(javafx.scene.Scene)方法。

    这是一个典型的模式如何使用JFXPanel ：

      public class Test {

         private static void initAndShowGUI() {
             // This method is invoked on Swing thread
             JFrame frame = new JFrame("FX");
             final JFXPanel fxPanel = new JFXPanel();
             frame.add(fxPanel);
             frame.setVisible(true);

             Platform.runLater(new Runnable() {
                 @Override
                 public void run() {
                     initFX(fxPanel);
                 }
             });
         }

         private static void initFX(JFXPanel fxPanel) {
             // This method is invoked on JavaFX thread
             Scene scene = createScene();
             fxPanel.setScene(scene);
         }

         public static void main(String[] args) {
             SwingUtilities.invokeLater(new Runnable() {
                 @Override
                 public void run() {
                     initAndShowGUI();
                 }
             });
         }
     }
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

      • Fields inherited from class javax.swing.JComponent

        listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

    • 构造方法摘要

      构造方法
      Constructor 描述
      JFXPanel​()
      创建一个新的 JFXPanel对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addNotify​()
      通知此组件它现在有一个父组件。
      InputMethodRequests getInputMethodRequests​()
      获取支持该组件输入法的请求的输入法请求处理程序。
      Dimension getPreferredSize​()
      返回此 JFXPanel的首选大小，以前设置为 JComponent.setPreferredSize(Dimension)或根据连接到此 JFXPanel的JavaFX场景的内容。
      Scene getScene​()
      返回附加到该 JFXPanel的JavaFX场景。
      boolean isOpaque​()
      JFXPanel的不透明度由在此组件中显示的JavaFX内容控制，因此此方法将覆盖 JComponent.isOpaque()以始终返回 false值。
      protected void paintComponent​(Graphics g)
      覆盖 JComponent.paintComponent(Graphics)方法来绘制附加到此 JFXpanel的JavaFX场景的内容。
      protected void processComponentEvent​(ComponentEvent e)
      覆盖 Component.processComponentEvent(ComponentEvent)方法将 ComponentEvent.COMPONENT_RESIZED事件发送到连接到此 JFXPanel的JavaFX场景。
      protected void processFocusEvent​(FocusEvent e)
      覆盖 Component.processFocusEvent(FocusEvent)方法来将焦点事件分派给附加到此 JFXPanel的JavaFX场景。
      protected void processHierarchyBoundsEvent​(HierarchyEvent e)
      覆盖 Component.processHierarchyBoundsEvent(HierarchyEvent)方法来处理 HierarchyEvent.ANCESTOR_MOVED事件，并更新JavaFX场景位置以匹配屏幕上的 JFXPanel位置。
      protected void processHierarchyEvent​(HierarchyEvent e)
      通过将此组件发送到任何已注册的 HierarchyListener对象来处理此组件上发生的层次结构事件。
      protected void processInputMethodEvent​(InputMethodEvent e)
      通过将此组件发送到任何已注册的 InputMethodListener对象来处理在此组件上发生的输入方法事件。
      protected void processKeyEvent​(KeyEvent e)
      覆盖 Component.processKeyEvent(KeyEvent)方法将键事件分配到连接到此 JFXPanel的JavaFX场景。
      protected void processMouseEvent​(MouseEvent e)
      覆盖 Component.processMouseEvent(MouseEvent)方法将鼠标事件发送到连接到此 JFXPanel的JavaFX场景。
      protected void processMouseMotionEvent​(MouseEvent e)
      覆盖 Component.processMouseMotionEvent(MouseEvent)方法将鼠标移动事件发送到连接到此 JFXPanel的JavaFX场景。
      protected void processMouseWheelEvent​(MouseWheelEvent e)
      覆盖 Component.processMouseWheelEvent(MouseWheelEvent)方法将鼠标滚轮事件发送到连接到此 JFXPanel的JavaFX场景。
      void removeNotify​()
      通知此组件它不再具有父组件。
      void setOpaque​(boolean opaque)
      JFXPanel的不透明度由此组件中显示的JavaFX内容控制，因此此方法将覆盖 JComponent.setOpaque(boolean)以仅接受 false值。
      void setScene​(Scene newScene)
      附加一个 Scene对象显示在这个 JFXPanel 。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setMixingCutoutShape, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • Methods inherited from class javax.swing.JComponent

        addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUI, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, hide, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JFXPanel

        public JFXPanel​()
        创建一个新的JFXPanel对象。

        实现注意事项 ：当创建第一个JFXPanel对象时，它会隐式地初始化JavaFX运行时。 这是在Swing中初始化JavaFX的首选方法。

    • 方法详细信息

      • getScene

        public Scene getScene​()
        返回附加到该 JFXPanel的JavaFX场景。
        结果
        该 Scene附于此 JFXPanel

      • setScene

        public void setScene​(Scene newScene)
        附加一个Scene对象显示在这个JFXPanel 。 可以在事件分派线程或JavaFX应用程序线程上调用此方法。
        参数
        newScene - 在这个 JFXpanel显示的场景
        另请参见：
        EventQueue.isDispatchThread() ， Platform.isFxApplicationThread()

      • setOpaque

        public final void setOpaque​(boolean opaque)
        JFXPanel的不透明度由该组件中显示的JavaFX内容控制，因此此方法将覆盖JComponent.setOpaque(boolean)以仅接受false值。 如果使用true值调用此方法，则不执行任何操作。
        重写：
        setOpaque在 JComponent
        参数
        opaque - 必须是 false
        另请参见：
        JComponent.isOpaque()

      • isOpaque

        public final boolean isOpaque​()
        JFXPanel的不透明度由此组件中显示的JavaFX内容控制，因此此方法将覆盖 JComponent.isOpaque()以始终返回 false值。
        重写：
        isOpaque在 JComponent
        结果
        一个 false价值
        另请参见：
        JComponent.setOpaque(boolean)

      • processMouseEvent

        protected void processMouseEvent​(MouseEvent e)
        覆盖 Component.processMouseEvent(MouseEvent)方法将鼠标事件分配到连接到此 JFXPanel的JavaFX场景。
        重写：
        processMouseEvent JComponent
        参数
        e - 要发送到JavaFX场景的鼠标事件
        另请参见：
        Component.processMouseEvent(java.awt.event.MouseEvent)

      • processMouseMotionEvent

        protected void processMouseMotionEvent​(MouseEvent e)
        覆盖 Component.processMouseMotionEvent(MouseEvent)方法将鼠标移动事件发送到连接到此 JFXPanel的JavaFX场景。
        重写：
        processMouseMotionEvent在 JComponent
        参数
        e - 将鼠标移动事件发送到JavaFX场景
        另请参见：
        MouseEvent

      • processMouseWheelEvent

        protected void processMouseWheelEvent​(MouseWheelEvent e)
        覆盖 Component.processMouseWheelEvent(MouseWheelEvent)方法将鼠标滚轮事件发送到连接到此 JFXPanel的JavaFX场景。
        重写：
        processMouseWheelEvent在 Component
        参数
        e - 将鼠标滚轮事件发送到JavaFX场景
        另请参见：
        MouseWheelEvent ， MouseWheelListener ， Component.addMouseWheelListener(java.awt.event.MouseWheelListener) ， Component.enableEvents(long)

      • processKeyEvent

        protected void processKeyEvent​(KeyEvent e)
        覆盖 Component.processKeyEvent(KeyEvent)方法将键事件发送到连接到此 JFXPanel的JavaFX场景。
        重写：
        processKeyEvent在 JComponent
        参数
        e - 发送到JavaFX场景的关键事件
        另请参见：
        KeyEvent ， KeyListener ， KeyboardFocusManager ， DefaultKeyboardFocusManager ， Component.processEvent(java.awt.AWTEvent) ， Component.dispatchEvent(java.awt.AWTEvent) ， Component.addKeyListener(java.awt.event.KeyListener) ， Component.enableEvents(long) ， Component.isShowing()

      • processComponentEvent

        protected void processComponentEvent​(ComponentEvent e)
        覆盖Component.processComponentEvent(ComponentEvent)方法将ComponentEvent.COMPONENT_RESIZED事件发送到附加到此JFXPanel的JavaFX场景。 然后调整JavaFX场景对象的大小以匹配JFXPanel大小。
        重写：
        processComponentEvent Component
        参数
        e - 要发送到JavaFX场景的组件事件
        另请参见：
        ComponentEvent ， ComponentListener ， Component.addComponentListener(java.awt.event.ComponentListener) ， Component.enableEvents(long)

      • processHierarchyBoundsEvent

        protected void processHierarchyBoundsEvent​(HierarchyEvent e)
        覆盖 Component.processHierarchyBoundsEvent(HierarchyEvent)处理 HierarchyEvent.ANCESTOR_MOVED事件的方法，并更新JavaFX场景位置以匹配屏幕上的 JFXPanel位置。
        重写：
        processHierarchyBoundsEvent在 Component
        参数
        e - 层次结构限制要处理的事件
        另请参见：
        HierarchyEvent ， HierarchyBoundsListener ， Component.addHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener) ， Component.enableEvents(long)

      • processHierarchyEvent

        protected void processHierarchyEvent​(HierarchyEvent e)
        描述从类复制： Component
        通过将此组件分派到任何已注册的HierarchyListener对象来处理层次结构事件。

        除非为此组件启用层次结构事件，否则不调用此方法。 当发生以下情况之一时，启用层次结构事件：

        • 一个HierarchyListener对象通过addHierarchyListener注册。
        • 层次结构事件通过enableEvents启用。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        重写：
        processHierarchyEvent中的 Component
        参数
        e - 层次结构事件
        另请参见：
        HierarchyEvent ， HierarchyListener ， Component.addHierarchyListener(java.awt.event.HierarchyListener) ， Component.enableEvents(long)

      • processFocusEvent

        protected void processFocusEvent​(FocusEvent e)
        覆盖 Component.processFocusEvent(FocusEvent)方法来将焦点事件分派到连接到此 JFXPanel的JavaFX场景。
        重写：
        processFocusEvent在 Component
        参数
        e - 发送到JavaFX场景的焦点事件
        另请参见：
        FocusEvent ， FocusListener ， KeyboardFocusManager ， Component.addFocusListener(java.awt.event.FocusListener) ， Component.enableEvents(long) ， Component.dispatchEvent(java.awt.AWTEvent)

      • processInputMethodEvent

        protected void processInputMethodEvent​(InputMethodEvent e)
        描述从类复制： Component
        通过将此组件发送到任何已注册的InputMethodListener对象来处理在此组件上发生的输入方法事件。

        除非为此组件启用输入方法事件，否则不调用此方法。 当发生以下其中一种情况时，将启用输入法事件：

        • 一个InputMethodListener对象通过addInputMethodListener注册。
        • 通过enableEvents启用输入法事件。

        请注意，如果事件参数是null ，行为是未指定的，可能会导致异常。

        重写：
        processInputMethodEvent在 Component
        参数
        e - 输入法事件
        另请参见：
        InputMethodEvent ， InputMethodListener ， Component.addInputMethodListener(java.awt.event.InputMethodListener) ， Component.enableEvents(long)

      • paintComponent

        protected void paintComponent​(Graphics g)
        覆盖 JComponent.paintComponent(Graphics)方法来绘制附加到此 JFXpanel的JavaFX场景的内容。
        重写：
        paintComponent在 JComponent
        参数
        g - 要绘制的图形上下文
        另请参见：
        isOpaque()

      • getPreferredSize

        public Dimension getPreferredSize​()
        返回此 JFXPanel的首选大小，先前使用 JComponent.setPreferredSize(Dimension)设置，或基于附加到此 JFXPanel的JavaFX场景的内容。
        重写：
        getPreferredSize中的 JComponent
        结果
        prefSize这个 JFXPanel首选大小
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension) ， ComponentUI

      • addNotify

        public void addNotify​()
        通知此组件它现在有一个父组件。 当调用此方法时，将使用KeyboardAction事件侦听器设置父组件链。
        重写：
        addNotify在 JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • getInputMethodRequests

        public InputMethodRequests getInputMethodRequests​()
        描述从类别复制Component
        获取支持该组件输入法的请求的输入法请求处理程序。 支持现场文本输入的组件必须覆盖此方法以返回InputMethodRequests实例。 同时，它也必须处理输入法事件。
        重写：
        getInputMethodRequests在 Component
        结果
        该组件的输入法请求处理程序默认为 null
        另请参见：
        Component.addInputMethodListener(java.awt.event.InputMethodListener)

      • removeNotify

        public void removeNotify​()
        通知此组件它不再具有父组件。 调用此方法时，将删除在父组件链中设置的任何KeyboardActions。
        重写：
        removeNotify在 JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SwingFXUtils (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.swing
软件包 javafx.embed.swing

Class SwingFXUtils

  • java.lang.Object
    • javafx.embed.swing.SwingFXUtils

  • public class SwingFXUtils
extends Object
    该类提供了用于在Swing / AWT和JavaFX格式之间转换数据类型的实用方法。
    从以下版本开始：
    JavaFX 2.2

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static BufferedImage fromFXImage​(Image img, BufferedImage bimg)
      快照指定的JavaFX Image对象，并将其像素的副本存储到一个BufferedImage对象中，如果需要创建一个新对象。
      static WritableImage toFXImage​(BufferedImage bimg, WritableImage wimg)
      快照指定的BufferedImage并将其像素的副本存储到JavaFX Image对象中，如果需要，创建一个新对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • toFXImage

        public static WritableImage toFXImage​(BufferedImage bimg,
                                      WritableImage wimg)
        快照指定的BufferedImage并将其像素的副本存储到JavaFX Image对象中，如果需要，创建一个新对象。 返回的Image将是方法完成时BufferedImage中像素状态的静态快照。 BufferedImage进一步变化将不会反映在Image 。

        可选的JavaFX WritableImage参数可能会重新用于存储像素的副本。 如果提供的对象为空，太小或图像像素不能轻易转换的类型，则将创建一个新的Image 。

        参数
        bimg - 要转换的 BufferedImage对象
        wimg - 可用于存储返回的像素数据的可选的 WritableImage对象
        结果
        一个 Image对象，代表 Image中当前像素的 BufferedImage 。
        从以下版本开始：
        JavaFX 2.2

      • fromFXImage

        public static BufferedImage fromFXImage​(Image img,
                                        BufferedImage bimg)
        快照指定的JavaFX Image对象，并将其像素的副本存储到一个BufferedImage对象中，如果需要创建一个新对象。 该方法将仅转换可根据Image.getPixelReader()方法的条件读取的JavaFX Image 。 如果Image不可读，由其getPixelReader()方法确定，则此方法将返回null。 如果Image是可写的或其他动态图像，则BufferedImage将仅被设置为由其PixelReader确定的图像中的像素的当前状态。 Image的像素的进一步更改将不会反映在返回的BufferedImage 。

        可选的BufferedImage参数可能被重新用于存储像素的副本。 如果提供的对象为空，太小或图像像素不能轻易转换的类型，将创建一个新的BufferedImage 。

        参数
        img - 要转换的JavaFX Image
        bimg - 可用于存储返回的像素数据的可选的 BufferedImage对象
        结果
        一个 BufferedImage含有的JavaFX的快照 Image或null如果 Image不可读。
        从以下版本开始：
        JavaFX 2.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SwingNode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.swing
软件包 javafx.embed.swing

Class SwingNode

  • java.lang.Object
    • javafx.scene.Node
      • javafx.embed.swing.SwingNode
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class SwingNode
extends Node
    此类用于将Swing内容嵌入到JavaFX应用程序中。 要显示的内容使用接受Swing JComponent实例的setContent(javax.swing.JComponent)方法指定。 组件中包含的层次结构JComponent实例不应包含任何重量级组件，否则SwingNode可能无法绘制它。 内容自动重画。 所有的输入和焦点事件都将透明地转发给开发人员的JComponent实例。

    这是一个典型的模式，演示如何使用SwingNode ：

      public class SwingFx extends Application {

         @Override
         public void start(Stage stage) {
             final SwingNode swingNode = new SwingNode();
             createAndSetSwingContent(swingNode);

             StackPane pane = new StackPane();
             pane.getChildren().add(swingNode);

             stage.setScene(new Scene(pane, 100, 50));
             stage.show();
         }

         private void createAndSetSwingContent(final SwingNode swingNode) {
             SwingUtilities.invokeLater(new Runnable() {
                 @Override
                 public void run() {
                     swingNode.setContent(new JButton("Click me!"));
                 }
             });
         }

         public static void main(String[] args) {
             launch(args);
         }
     }
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      SwingNode​()
      构造一个新的实例 SwingNode 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JComponent getContent​()
      返回附加到此 SwingNode的 JComponent实例。
      boolean isResizable​()
      指示该节点是否可以由父节点调整大小。
      double maxHeight​(double width)
      返回 SwingNode用于布局计算的最大高度。
      double maxWidth​(double height)
      返回 SwingNode用于布局计算的最大宽度。
      double minHeight​(double width)
      返回 SwingNode用于布局计算的最小高度。
      double minWidth​(double height)
      返回 SwingNode用于布局计算的最小宽度。
      double prefHeight​(double width)
      返回 SwingNode用于布局计算的首选高度。
      double prefWidth​(double height)
      返回用于布局计算的 SwingNode的首选宽度。
      void resize​(double width, double height)
      由 SwingNode的父母在布局期间调用 SwingNode的宽度和高度。
      void setContent​(JComponent content)
      附 JComponent实例显示在这个 SwingNode 。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • SwingNode

        public SwingNode​()
        构造一个新的实例 SwingNode 。

    • 方法详细信息

      • setContent

        public void setContent​(JComponent content)
        附JComponent实例显示在这个SwingNode 。

        该方法可以在JavaFX应用程序线程或事件调度线程上调用。 但是请注意，对于Swing组件的访问必须根据Swing线程限制从事件调度线程发生。

        参数
        content - 显示在这个 SwingNode的Swing组件
        另请参见：
        EventQueue.isDispatchThread() ， Platform.isFxApplicationThread()

      • getContent

        public JComponent getContent​()
        返回附加到此SwingNode的JComponent实例。

        该方法可以在JavaFX应用程序线程或事件调度线程上调用。 但是请注意，对于Swing组件的访问必须根据Swing线程限制从事件调度线程发生。

        结果
        Swing组件附加到这个 SwingNode
        另请参见：
        EventQueue.isDispatchThread() ， Platform.isFxApplicationThread()

      • isResizable

        public boolean isResizable​()
        描述从类复制： Node
        指示该节点是否可以由父节点调整大小。 如果此方法返回true，那么在布局过程中，父节点将通过调用node.resize（width，height）来调整节点的大小（理想情况下在其大小范围内）。 所有区域，控件和WebView都是可调整大小的类，它们在应用所有尺寸和CSS样式信息后，依赖于他们的父母在布局期间调整大小。

        如果此方法返回false，那么在布局期间父（）不能调整它大小（resize（）是一个no-op），并且它应该返回其layoutBounds的最小，首选和最大大小。 组，文本和所有形状都不能调整大小，因此通过设置适当的属性（例如矩形的宽度/高度，文本上的文本等），依赖于应用程序来建立其大小。 在布局期间，仍然可以重新定位不可调整大小的节点。

        重写：
        isResizable在 Node
        结果
        该布局期间该节点类型是否可以由其父节点调整大小
        另请参见：
        Node.getContentBias() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double) ，
Node.resize(double, double) ，
Node.getLayoutBounds()

      • resize

        public void resize​(double width,
                   double height)
        SwingNode的父亲在布局期间调用SwingNode的宽度和高度。 应用程序不应直接调用此方法 。 如果应用程序需要直接设置SwingNode的大小，则应该设置Swing组件的最小/首选/最大大小约束，这些约束将相应地传播到SwingNode并且它的父级将在布局期间遵守这些设置。
        重写：
        resize在 Node
        参数
        width - 目标布局的边界宽度
        height - 目标布局界定高度
        另请参见：
        Node.isResizable() ，
Node.getContentBias() ，
Node.autosize() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double) ，
Node.getLayoutBounds()

      • prefWidth

        public double prefWidth​(double height)
        返回SwingNode用于布局计算的首选宽度。 该值对应于Swing组件的首选宽度。
        重写：
        prefWidth在 Node
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        在布局期间，节点应该调整大小的首选宽度
        另请参见：
        Node.isResizable() ，
Node.getContentBias() ，
Node.autosize()

      • prefHeight

        public double prefHeight​(double width)
        返回SwingNode用于布局计算的首选高度。 该值对应于Swing组件的首选高度。
        重写：
        prefHeight中的 Node
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        在布局期间，节点应该调整大小的首选高度
        另请参见：
        Node.getContentBias() ， Node.autosize()

      • maxWidth

        public double maxWidth​(double height)
        返回SwingNode的最大宽度，用于布局计算。 该值对应于Swing组件的最大宽度。
        重写：
        maxWidth在 Node
        参数
        height - 如果最大宽度取决于应该使用的高度
        结果
        布局期间节点应调整大小的最大宽度
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • maxHeight

        public double maxHeight​(double width)
        返回SwingNode用于布局计算的最大高度。 该值对应于Swing组件的最大高度。
        重写：
        maxHeight在 Node
        参数
        width - 如果最大高度取决于应该使用的宽度
        结果
        节点在布局期间应该调整大小的最大高度
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • minWidth

        public double minWidth​(double height)
        返回SwingNode用于布局计算的最小宽度。 该值对应于Swing组件的最小宽度。
        重写：
        minWidth在 Node
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        布局期间节点应该调整大小的最小宽度
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • minHeight

        public double minHeight​(double width)
        返回SwingNode的最小高度用于布局计算。 该值对应于Swing组件的最小高度。
        重写：
        minHeight在 Node
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        节点在布局期间应调整大小的最小高度
        另请参见：
        Node.isResizable(), Node.getContentBias()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.embed.swing (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.embed.swing

No usage of javafx.embed.swing
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.embed.swing.JFXPanel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.embed.swing.JFXPanel

No usage of javafx.embed.swing.JFXPanel
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.embed.swing.SwingFXUtils (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.embed.swing.SwingFXUtils

No usage of javafx.embed.swing.SwingFXUtils
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.embed.swing.SwingNode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.embed.swing.SwingNode

No usage of javafx.embed.swing.SwingNode
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ActionEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.event

Class ActionEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.event.ActionEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    MediaMarkerEvent

    public class ActionEvent
extends Event
    一个Event代表某种类型的动作。 此事件类型被广泛用于表示各种事物，诸如当Button已经发射，当KeyFrame已完成，和其它这样的用法。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<ActionEvent> ACTION
      ActionEvent唯一有效的EventType。
      static EventType<ActionEvent> ANY
      所有动作事件类型的公共超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActionEvent​()
      创建一个新的 ActionEvent事件类型为 ACTION 。
      ActionEvent​(Object source, EventTarget target)
      构造一个新的 ActionEvent与指定的事件源和目标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ActionEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      EventType<? extends ActionEvent> getEventType​()
      获取此事件的事件类型。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ACTION

        public static final EventType<ActionEvent> ACTION
        ActionEvent唯一有效的EventType。

      • ANY

        public static final EventType<ActionEvent> ANY
        所有动作事件类型的公共超类型。
        从以下版本开始：
        JavaFX 8.0

    • 构造方法详细信息

      • ActionEvent

        public ActionEvent​()
        创建一个新的ActionEvent ，事件类型为ACTION 。 事件的源和目标设置为NULL_SOURCE_TARGET 。

      • ActionEvent

        public ActionEvent​(Object source,
                   EventTarget target)
        构造一个新的ActionEvent与指定的事件源和目标。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。 所有ActionEvent的类型设置为ACTION 。
        参数
        source - 发送事件的事件源
        target - 与事件关联的事件目标

    • 方法详细信息

      • copyFor

        public ActionEvent copyFor​(Object newSource,
                           EventTarget newTarget)
        说明从类别复制： Event
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • getEventType

        public EventType<? extends ActionEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 相同的对象Event类可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType中的 Event
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.event

Class Event

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    ActionEvent ， CheckBoxTreeItem.TreeModificationEvent ， DialogEvent ， InputEvent ， ListView.EditEvent ， MediaErrorEvent ， ScrollToEvent ， SortEvent ， TableColumn.CellEditEvent ， TransformChangedEvent ， TreeItem.TreeModificationEvent ， TreeTableColumn.CellEditEvent ， TreeTableView.EditEvent ， TreeView.EditEvent ， WebErrorEvent ， WebEvent ， WindowEvent ， WorkerStateEvent

    public class Event
extends EventObject
implements Cloneable
    FX事件的基础类。 每个FX事件都与事件源，事件目标和事件类型相关联。 事件源为事件处理程序指定已处理该处理程序的对象以及向其发送事件的事件源。 事件目标定义了事件在发布时将行进的路径。 事件类型为同一个Event类的事件提供了额外的分类。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<Event> ANY
      所有事件类型的公共超类型。
      protected boolean consumed
      此事件是否已被任何过滤器或处理程序使用。
      protected EventType<? extends Event> eventType
      事件的类型。
      static EventTarget NULL_SOURCE_TARGET
      表示未知事件源/目标的常数。
      protected EventTarget target
      事件目标定义事件在发布时将通过的路径。

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      Event​(Object source, EventTarget target, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。
      Event​(EventType<? extends Event> eventType)
      构造具有指定事件类型的新的 Event 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建并返回此 Event的副本。
      void consume​()
      标记为 Event消费。
      Event copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      static void fireEvent​(EventTarget eventTarget, Event event)
      触发指定的事件。
      EventType<? extends Event> getEventType​()
      获取此事件的事件类型。
      EventTarget getTarget​()
      返回此事件的事件目标。
      boolean isConsumed​()
      指示此 Event是否已被任何过滤器或处理程序使用。

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NULL_SOURCE_TARGET

        public static final EventTarget NULL_SOURCE_TARGET
        表示未知事件源/目标的常数。

      • ANY

        public static final EventType<Event> ANY
        所有事件类型的公共超类型。

      • eventType

        protected EventType<? extends Event> eventType
        事件的类型。

      • target

        protected transient EventTarget target
        事件目标定义事件在发布时将通过的路径。

      • consumed

        protected boolean consumed
        此事件是否已被任何过滤器或处理程序使用。

    • 构造方法详细信息

      • Event

        public Event​(EventType<? extends Event> eventType)
        构造一个具有指定事件类型的新的Event 。 事件的来源和目标设置为NULL_SOURCE_TARGET 。
        参数
        eventType - 事件类型

      • Event

        public Event​(Object source,
             EventTarget target,
             EventType<? extends Event> eventType)
        使用指定的事件源，目标和类型构造新的Event 。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        参数
        source - 发送事件的事件源
        target - 与事件关联的事件目标
        eventType - 事件类型

    • 方法详细信息

      • getTarget

        public EventTarget getTarget​()
        返回此事件的事件目标。 事件目标指定事件在发布时将行进的路径。
        结果
        事件目标

      • getEventType

        public EventType<? extends Event> getEventType​()
        获取此事件的事件类型。 相同的对象Event类可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        结果
        事件类型

      • copyFor

        public Event copyFor​(Object newSource,
                     EventTarget newTarget)
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • isConsumed

        public boolean isConsumed​()
        指示此 Event是否已被任何过滤器或处理程序使用。
        结果
        true如果这个 Event已经消费了，其他的则是 false

      • consume

        public void consume​()
        标记为Event消耗。 这样可以阻止它的进一步传播

      • clone

        public Object clone​()
        创建并返回此 Event的副本。
        重写：
        clone在 Object
        结果
        一个 Event的新实例，其中所有值都从该 Event复制。
        另请参见：
        Cloneable

      • fireEvent

        public static void fireEvent​(EventTarget eventTarget,
                             Event event)
        触发指定的事件。 给定的事件目标指定事件将通过的路径。
        参数
        eventTarget - 事件的目标
        event - 事件发生
        异常
        NullPointerException - if eventTarget or event is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


EventDispatchChain (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.event

Interface EventDispatchChain

  • public interface EventDispatchChain
    代表EventDispatcher对象的链，可以发送一个Event 。 该事件通过将其从一个EventDispatcher传递到链中的下一个EventDispatcher发送，直到到达链的末尾。 链中的每个EventDispatcher都可以影响事件路径和事件本身。 链通常通过从根到事件目标跟随一些父 - 子层次结构EventDispatcher遇到的所有EventDispatcher对象附加到链来形成。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      EventDispatchChain append​(EventDispatcher eventDispatcher)
      将指定的 EventDispatcher附加到此链。
      Event dispatchEvent​(Event event)
      通过此 EventDispatchChain调度指定的事件。
      EventDispatchChain prepend​(EventDispatcher eventDispatcher)
      为此链条预先指定了 EventDispatcher 。

    • 方法详细信息

      • append

        EventDispatchChain append​(EventDispatcher eventDispatcher)
        将指定的EventDispatcher追加到此链。 返回对带有附加元素的链的引用。

        呼叫者不应该假设这个EventDispatchChain保持不变，也不应该返回的值将引用一个不同的链接。 这一切都取决于EventDispatchChain实现。

        所以呼叫应该始终如下进行： chain = chain.append(eventDispatcher);

        参数
        eventDispatcher - EventDispatcher附加到链
        结果
        链附加事件调度程序

      • prepend

        EventDispatchChain prepend​(EventDispatcher eventDispatcher)
        将指定的EventDispatcher到此链。 返回对带有前缀元素的链的引用。

        呼叫者不应该假设这个EventDispatchChain保持不变，也不应该在通话后返回值引用不同的链。 这一切都取决于EventDispatchChain实现。

        所以呼叫应该始终如下进行： chain = chain.prepend(eventDispatcher);

        参数
        eventDispatcher - EventDispatcher ，以前链接
        结果
        该链与前置事件调度程序

      • dispatchEvent

        Event dispatchEvent​(Event event)
        通过此EventDispatchChain调度指定的事件。 返回值表示链的处理完成后的事件。 如果在调用后要进行进一步处理，那么应该使用返回值引用的事件而不是原始事件。 在事件在链中完全处理/消耗的情况下，返回值为null并且不应对该事件进行进一步的处理。
        参数
        event - 发送的事件
        结果
        处理的事件或 null如果事件已被完全处理/消耗
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EventDispatcher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.event

Interface EventDispatcher

  • public interface EventDispatcher
    一个EventDispatcher代表一个事件调度和处理实体。 当它用于Event需要被分派给相关的EventTarget通过EventDispatchChain由目标指定。 链中的每个EventDispatcher都可以影响事件路径和事件本身。 一个EventDispatcher可以出现在多个链。

    系统定义事件传递的两个连续阶段。 第一阶段称为捕获阶段，当事件从与事件目标相关联的EventDispatchChain的第一个元素移动到其最后一个元素时发生。 如果事件目标是某些层次结构的一部分，则此阶段中事件的方向通常与从层次结构的根元素到目标的方向相对应。 第二阶段称为起泡阶段，并以与第一阶段相反的顺序进行。 所以事件从这个阶段的EventDispatchChain的最后一个元素返回到第一个元素。 通常这对应于事件目标的层次结构中从事件目标回到根的方向。

    每个EventDispatcher在EventDispatchChain负责事件分派期间转发事件到该链的其余部分。 这种转发发生在dispatchEvent方法中，并形成一系列嵌套呼叫，允许一个EventDispatcher在一个dispatchEvent调用中的两个调度阶段中查看事件。

    模板为dispatchEvent实现。

      public Event dispatchEvent(Event event, EventDispatchChain tail) {
    // capturing phase, can handle / modify / substitute / divert the event

    if (notHandledYet) {
        // forward the event to the rest of the chain
        event = tail.dispatchEvent(event);

        if (event != null) {
            // bubbling phase, can handle / modify / substitute / divert
            // the event
        }
    }

    return notHandledYet ? event : null;
    }
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Event dispatchEvent​(Event event, EventDispatchChain tail)
      通过这个 EventDispatcher调度指定的事件。

    • 方法详细信息

      • dispatchEvent

        Event dispatchEvent​(Event event,
                    EventDispatchChain tail)
        通过这个EventDispatcher调度指定的事件。 是否需要事件处理。 事件及其进一步的路径都可以通过这种方法修改。 如果事件在捕获阶段未处理/消耗，则应将其发送到链的其余部分（ event = tail.dispatch(event); ）。
        参数
        event - 事件发送
        tail - 链条的其余部分发送到
        结果
        the return event or null if the event has been handled / consumed
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EventHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.event

Interface EventHandler<T extends Event>

  • 参数类型
    T - 这个处理程序可以处理的事件类
    All Superinterfaces:
    EventListener
    所有已知实现类：
    WeakEventHandler
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface EventHandler<T extends Event>
extends EventListener
    处理程序用于特定类/类型的事件。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void handle​(T event)
      当注册此处理程序的类型的特定事件发生时调用。

    • 方法详细信息

      • handle

        void handle​(T event)
        当注册此处理程序的类型的特定事件发生时调用。
        参数
        event - 发生的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EventTarget (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.event

Interface EventTarget

  • 所有已知实现类：
    Accordion ， Affine ， Alert ， AmbientLight ， AnchorPane ， Arc ， AreaChart ， Axis ， BarChart ， BorderPane ， Box ， BubbleChart ， Button ， ButtonBar ， ButtonBase ， Camera ， Canvas ， CategoryAxis ， Cell ， Chart ， CheckBox ， CheckBoxListCell ， CheckBoxTableCell ， CheckBoxTreeCell ， CheckBoxTreeItem ， CheckBoxTreeTableCell ， CheckMenuItem ， ChoiceBox ， ChoiceBoxListCell ， ChoiceBoxTableCell ， ChoiceBoxTreeCell ， ChoiceBoxTreeTableCell ， ChoiceDialog ， Circle ， ColorPicker ， ComboBox ， ComboBoxBase ， ComboBoxListCell ， ComboBoxTableCell ， ComboBoxTreeCell ， ComboBoxTreeTableCell ， ContextMenu ， Control ， CubicCurve ， CustomMenuItem ， Cylinder ， DateCell ， DatePicker ， Dialog ， DialogPane ， Ellipse ， FlowPane ， GridPane ， Group ， HBox ， HTMLEditor HTMLEditor ， Hyperlink ， ImageView ， IndexedCell ， Label ， Labeled ， LightBase ， Line ， LineChart ， ListCell ， ListView ， MediaView ， Menu ， MenuBar ， MenuButton ， MenuItem ， MeshView ， NestedTableColumnHeader ， Node ， NumberAxis ， Pagination ， Pane ， ParallelCamera ， Parent ， PasswordField ， Path ， PerspectiveCamera ， PieChart ， PointLight ， Polygon ， Polyline ， Popup ， PopupControl ， PopupControl.CSSBridge ， PopupWindow ， ProgressBar ， ProgressBarTableCell ， ProgressBarTreeTableCell ， ProgressIndicator ， QuadCurve ， RadioButton ， RadioMenuItem ， Rectangle ， Region ， Rotate ， Scale ， ScatterChart ， Scene ， ScheduledService ， ScrollBar ， ScrollPane ， Separator ， SeparatorMenuItem ， Service ， Shape ， Shape3D ， Shear Shear ， Slider ， Sphere ， Spinner ， SplitMenuButton ， SplitPane ， StackedAreaChart ， StackedBarChart ， StackPane ， Stage ， SubScene ， SVGPath ， SwingNode ， Tab ， TableCell ， TableColumn ， TableColumnBase ， TableColumnHeader ， TableHeaderRow ， TableRow ， TableView ， TabPane ， Task ， Text ， TextArea ， TextField ， TextFieldListCell ， TextFieldTableCell ， TextFieldTreeCell ， TextFieldTreeTableCell ， TextFlow ， TextInputControl ， TextInputDialog ， TilePane ， TitledPane ， ToggleButton ， ToolBar ， Tooltip ， Transform ， Translate ， TreeCell ， TreeItem ， TreeTableCell ， TreeTableColumn ， TreeTableRow ， TreeTableView ， TreeView ， ValueAxis ， VBox ， VirtualFlow ， WebView ， Window ， XYChart

    public interface EventTarget
    表示事件目标。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。

    • 方法详细信息

      • buildEventDispatchChain

        EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此目标构建事件调度链。 事件调度链包含可能对处理针对EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要向链中添加一个EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        参数
        tail - 从...建立的初始链
        结果
        the resulting event dispatch chain for this target
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EventType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.event

Class EventType<T extends Event>

  • java.lang.Object
    • javafx.event.EventType<T>
  • 参数类型
    T - 此类型适用的事件类
    All Implemented Interfaces:
    Serializable

    public final class EventType<T extends Event>
extends Object
implements Serializable
    该类表示与Event相关联的特定事件类型。

    事件类型形成一个层次结构，其基数为ROOT （等于Event.ANY ）。 这在事件过滤器/处理程序注册中是有用的，其中可以将单个事件过滤器/处理程序注册到超级事件类型，并且还将接收其子类型事件。 请注意，您不能使用相同的名称和父构造两个不同的EventType对象。

    关于反序列化的注意事项 ：所有要反序列化的EventTypes（例如作为Event反序列化的一部分）需要在反序列化时存在。 EventType的反序列化不会创建新的EventType对象。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<Event> ROOT
      根事件类型。

    • 构造方法摘要

      构造方法
      Constructor 描述
      EventType​()
      已过时。
      不要使用这个构造函数，因为只有一个这样的EventType可以存在
      EventType​(String name)
      构造一个新的 EventType具有指定的名称，而 EventType.ROOT作为其超类型。
      EventType​(EventType<? super T> superType)
      构造一个新的 EventType具有指定的超级类型，名称设置为 null 。
      EventType​(EventType<? super T> superType, String name)
      构造一个具有指定的超类型和名称的新的 EventType 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getName​()
      获取此事件类型的名称。
      EventType<? super T> getSuperType​()
      获取此类型的超级类型。
      String toString​()
      返回此 EventType对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ROOT

        public static final EventType<Event> ROOT
        根事件类型。 所有其他事件类型都是直接或间接子类型。 它也是唯一的事件类型，其超级事件类型设置为null 。

    • 构造方法详细信息

      • EventType

        @Deprecated
public EventType​()
        已过时。 不要使用这个构造函数，因为只有一个这样的EventType可以存在
        构造一个新的 EventType ，其中 EventType.ROOT为超级类型，名称设置为 null 。

      • EventType

        public EventType​(String name)
        构造一个新的 EventType具有指定的名称和 EventType.ROOT作为其超类型。
        参数
        name - 的名字
        异常
        IllegalArgumentException -如果具有相同名称的事件类型和 二七零六八零四三九五九一四二五 / 二百七十零万六千八百零四亿三千九百六十万四千零五十八父

      • EventType

        public EventType​(EventType<? super T> superType)
        构造一个新的 EventType具有指定的超类型，名称设置为 null 。
        参数
        superType - 事件超类型
        异常
        IllegalArgumentException - 如果存在具有“null”名称和此超类型的EventType

      • EventType

        public EventType​(EventType<? super T> superType,
                 String name)
        构造具有指定的超类型和名称的新的 EventType 。
        参数
        superType - 事件超类型
        name - 的名字
        异常
        IllegalArgumentException - 如果存在具有相同名称和超类型的EventType

    • 方法详细信息

      • getSuperType

        public final EventType<? super T> getSuperType​()
        获取此类型的超级类型。 返回值为null仅供EventType.ROOT 。
        结果
        超级类型

      • getName

        public final String getName​()
        获取此事件类型的名称。
        结果
        名字

      • toString

        public String toString​()
        返回此 EventType对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 EventType对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javafx.event (Java SE 9 & JDK 9 )

javafx.event

Interfaces

  • EventDispatchChain
  • EventDispatcher
  • EventHandler
  • EventTarget

Classes

  • ActionEvent
  • Event
  • EventType
  • WeakEventHandler


javafx.event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.event

为FX事件，交付和处理提供基本框架。

  • 接口摘要
    接口 描述
    EventDispatchChain
    代表 EventDispatcher对象的链，可以发送一个 Event 。
    EventDispatcher
    一个 EventDispatcher代表一个事件调度和处理实体。
    EventHandler<T extends Event>
    处理程序用于特定类/类型的事件。
    EventTarget
    表示事件目标。
  • 类摘要
    Class 描述
    ActionEvent
    一个Event代表一些类型的动作。
    Event
    FX事件的基础类。
    EventType<T extends Event>
    该类表示与 Event相关联的特定事件类型。
    WeakEventHandler<T extends Event>
    用于事件处理程序注册代替其关联的事件处理程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.event Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.event

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javafx.event.Event (implements java.lang.Cloneable)
        • javafx.event.ActionEvent
    • javafx.event.EventType<T> (implements java.io.Serializable)
    • javafx.event.WeakEventHandler<T> (implements javafx.event.EventHandler<T>)

Interface Hierarchy

  • javafx.event.EventDispatchChain
  • javafx.event.EventDispatcher
  • java.util.EventListener
    • javafx.event.EventHandler<T>
  • javafx.event.EventTarget
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package javafx.event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.event

  • Packages that use javafx.event
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
  • Classes in javafx.event used by javafx.animation
    Class 描述
    ActionEvent
    一个Event代表一些类型的动作。
    EventHandler
    处理程序用于特定类/类型的事件。
  • Classes in javafx.event used by javafx.concurrent
    Class 描述
    Event
    FX事件的基础类。
    EventDispatchChain
    代表 EventDispatcher对象的链，可以发送一个 Event 。
    EventHandler
    处理程序用于特定类/类型的事件。
    EventTarget
    表示事件目标。
    EventType
    此类表示与 Event相关联的特定事件类型。
  • Classes in javafx.event used by javafx.embed.swing
    Class 描述
    EventTarget
    表示事件目标。
  • Classes in javafx.event used by javafx.event
    Class 描述
    ActionEvent
    代表某种类型的动作的Event 。
    Event
    FX事件的基础类。
    EventDispatchChain
    代表 EventDispatcher对象的链，可以发送一个 Event 。
    EventDispatcher
    一个 EventDispatcher代表一个事件调度和处理实体。
    EventHandler
    处理程序用于特定类/类型的事件。
    EventTarget
    表示事件目标。
    EventType
    该类表示与 Event相关联的特定事件类型。
  • Classes in javafx.event used by javafx.scene
    Class 描述
    Event
    FX事件的基础类。
    EventDispatchChain
    代表 EventDispatcher对象的链，可以发送 Event 。
    EventDispatcher
    一个 EventDispatcher代表事件调度和处理实体。
    EventHandler
    处理程序用于特定类/类型的事件。
    EventTarget
    表示事件目标。
    EventType
    此类表示与 Event相关联的特定事件类型。
  • Classes in javafx.event used by javafx.scene.canvas
    Class 描述
    EventTarget
    表示事件目标。
  • Classes in javafx.event used by javafx.scene.chart
    Class 描述
    EventTarget
    表示事件目标。
  • Classes in javafx.event used by javafx.scene.control
    Class 描述
    ActionEvent
    一个Event代表一些类型的动作。
    Event
    FX事件的基础类。
    EventDispatchChain
    代表 EventDispatcher对象的链，可以发送 Event 。
    EventHandler
    处理程序用于特定类/类型的事件。
    EventTarget
    表示事件目标。
    EventType
    该类表示与 Event相关联的特定事件类型。
  • Classes in javafx.event used by javafx.scene.control.cell
    Class 描述
    EventTarget
    表示事件目标。
  • Classes in javafx.event used by javafx.scene.control.skin
    Class 描述
    EventTarget
    表示事件目标。
  • Classes in javafx.event used by javafx.scene.image
    Class 描述
    EventTarget
    表示事件目标。
  • Classes in javafx.event used by javafx.scene.input
    Class 描述
    Event
    FX事件的基础类。
    EventTarget
    表示事件目标。
    EventType
    该类表示与 Event相关联的特定事件类型。
  • Classes in javafx.event used by javafx.scene.layout
    Class 描述
    EventTarget
    表示事件目标。
  • Classes in javafx.event used by javafx.scene.media
    Class 描述
    ActionEvent
    一个Event代表一些类型的动作。
    Event
    FX事件的基础类。
    EventHandler
    处理程序用于特定类/类型的事件。
    EventTarget
    表示事件目标。
    EventType
    此类表示与 Event相关联的特定事件类型。
  • Classes in javafx.event used by javafx.scene.shape
    Class 描述
    EventTarget
    表示事件目标。
  • Classes in javafx.event used by javafx.scene.text
    Class 描述
    EventTarget
    表示事件目标。
  • Classes in javafx.event used by javafx.scene.transform
    Class 描述
    Event
    FX事件的基础类。
    EventDispatchChain
    代表 EventDispatcher对象的链，可以发送一个 Event 。
    EventHandler
    处理程序用于特定类/类型的事件。
    EventTarget
    表示事件目标。
    EventType
    该类表示与 Event相关联的特定事件类型。
  • Classes in javafx.event used by javafx.scene.web
    Class 描述
    Event
    FX事件的基础类。
    EventHandler
    处理程序用于特定类/类型的事件。
    EventTarget
    表示事件目标。
    EventType
    此类表示与 Event相关联的特定事件类型。
  • Classes in javafx.event used by javafx.stage
    Class 描述
    Event
    FX事件的基础类。
    EventDispatchChain
    代表 EventDispatcher对象的链，可以发送一个 Event 。
    EventDispatcher
    一个 EventDispatcher代表事件调度和处理实体。
    EventHandler
    处理程序用于特定类/类型的事件。
    EventTarget
    表示事件目标。
    EventType
    此类表示与 Event相关联的特定事件类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


WeakEventHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.event

Class WeakEventHandler<T extends Event>

  • java.lang.Object
    • javafx.event.WeakEventHandler<T>
  • 参数类型
    T - 这个处理程序可以处理的事件类
    All Implemented Interfaces:
    EventListener ， EventHandler<T>

    public final class WeakEventHandler<T extends Event>
extends Object
implements EventHandler<T>
    用于事件处理程序注册代替其关联的事件处理程序。 其唯一目的是打破事件处理程序容器及其关联事件处理程序之间的其他强引用。 虽然容器仍然强有力地引用了注册的WeakEventHandler代理，但是代理本身只是很弱地引用原来的处理程序，所以不会阻止它被垃圾回收。 在这个弱引用被破坏之前，由代理接收的任何事件通知都转发给原始处理程序。
    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      WeakEventHandler​(EventHandler<T> eventHandler)
      创建一个新的实例 WeakEventHandler 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void handle​(T event)
      向相关事件处理程序发送事件通知。
      boolean wasGarbageCollected​()
      指示关联的事件处理程序是否已被垃圾回收。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WeakEventHandler

        public WeakEventHandler​(EventHandler<T> eventHandler)
        创建一个新的实例 WeakEventHandler 。
        参数
        eventHandler - 转发事件通知的原始事件处理程序

    • 方法详细信息

      • wasGarbageCollected

        public boolean wasGarbageCollected​()
        指示关联的事件处理程序是否已被垃圾回收。 由容器用于检测何时不再需要存储对此引用的WeakEventHandler 。
        结果
        true如果相关联的处理程序已被垃圾回收，否则为 false

      • handle

        public void handle​(T event)
        向相关事件处理程序发送事件通知。
        Specified by:
        handle在接口 EventHandler<T extends Event>
        参数
        event - 发生的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.event.ActionEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.event.ActionEvent

  • Packages that use ActionEvent
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of ActionEvent in javafx.animation

      Methods in javafx.animation that return types with arguments of type ActionEvent
      Modifier and Type 方法 描述
      EventHandler<ActionEvent> Animation.getOnFinished​()
      获取属性onFinished的值。
      EventHandler<ActionEvent> KeyFrame.getOnFinished​()
      返回 onFinished此事件处理 KeyFrame 。
      ObjectProperty<EventHandler<ActionEvent>> Animation.onFinishedProperty​()
      在这个 Animation的结论中执行的行动。
      Method parameters in javafx.animation with type arguments of type ActionEvent
      Modifier and Type 方法 描述
      void Animation.setOnFinished​(EventHandler<ActionEvent> value)
      设置属性onFinished的值。
      Constructor parameters in javafx.animation with type arguments of type ActionEvent
      Constructor 描述
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame

    • Uses of ActionEvent in javafx.event

      Fields in javafx.event with type parameters of type ActionEvent
      Modifier and Type Field 描述
      static EventType<ActionEvent> ActionEvent.ACTION
      ActionEvent唯一有效的EventType。
      static EventType<ActionEvent> ActionEvent.ANY
      所有动作事件类型的公共超类型。
      Methods in javafx.event that return ActionEvent
      Modifier and Type | 方法 | 描述
      ActionEvent | ActionEvent.copyFor​(Object newSource, EventTarget newTarget)
      Methods in javafx.event that return types with arguments of type ActionEvent
      Modifier and Type | 方法 | 描述
      EventType<? extends ActionEvent> | ActionEvent.getEventType​()

    • Uses of ActionEvent in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type ActionEvent
      Modifier and Type 方法 描述
      EventHandler<ActionEvent> ButtonBase.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> ChoiceBox.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> ComboBoxBase.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> ContextMenu.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> MenuItem.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> TextField.getOnAction​()
      获取属性onAction的值。
      ObjectProperty<EventHandler<ActionEvent>> ButtonBase.onActionProperty​()
      按钮的动作，当按钮被触发时被调用。
      ObjectProperty<EventHandler<ActionEvent>> ChoiceBox.onActionProperty​()
      ChoiceBox操作，每当更改ChoiceBox value属性时调用。
      ObjectProperty<EventHandler<ActionEvent>> ComboBoxBase.onActionProperty​()
      ComboBox操作，当ComboBox value属性更改时调用。
      ObjectProperty<EventHandler<ActionEvent>> ContextMenu.onActionProperty​()
      当这个 ContextMenu包含的项目被激活时，通知回调函数。
      ObjectProperty<EventHandler<ActionEvent>> MenuItem.onActionProperty​()
      每当MenuItem被触发时调用该动作。
      ObjectProperty<EventHandler<ActionEvent>> TextField.onActionProperty​()
      与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。
      Method parameters in javafx.scene.control with type arguments of type ActionEvent
      Modifier and Type 方法 描述
      void ButtonBase.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void ChoiceBox.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void ComboBoxBase.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void ContextMenu.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void MenuItem.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void TextField.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。

    • Uses of ActionEvent in javafx.scene.media

      Subclasses of ActionEvent in javafx.scene.media
      Modifier and Type Class 描述
      class  MediaMarkerEvent
      代表媒体标记的ActionEvent 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.event.Event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.event.Event

  • Packages that use Event
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of Event in javafx.concurrent

      Subclasses of Event in javafx.concurrent
      Modifier and Type Class 描述
      class  WorkerStateEvent
      当一个工人状态发生变化时发生的事件。
      Methods in javafx.concurrent with type parameters of type Event
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Service.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      将事件过滤器注册到此任务。
      <T extends Event>
      void             		Task.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      将事件过滤器注册到此任务。
      <T extends Event>
      void             		Service.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个任务。
      <T extends Event>
      void             		Task.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个任务。
      <T extends Event>
      void             		Service.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此任务中注销先前注册的事件过滤器。
      <T extends Event>
      void             		Task.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此任务中注销先前注册的事件过滤器。
      <T extends Event>
      void             		Service.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此任务中注销先前注册的事件处理程序。
      <T extends Event>
      void             		Task.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此任务中注销先前注册的事件处理程序。
      protected <T extends Event>
      void             		Service.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      protected <T extends Event>
      void             		Task.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      Methods in javafx.concurrent with parameters of type Event
      Modifier and Type 方法 描述
      protected void Service.fireEvent​(Event event)
      触发指定的事件。
      void Task.fireEvent​(Event event)
      触发指定的事件。

    • Uses of Event in javafx.event

      Classes in javafx.event with type parameters of type Event
      Modifier and Type 接口 描述
      interface  EventHandler<T extends Event>
      处理程序用于特定类/类型的事件。
      class  EventType<T extends Event>
      此类表示与 Event相关联的特定事件类型。
      class  WeakEventHandler<T extends Event>
      用于事件处理程序注册代替其关联的事件处理程序。
      Subclasses of Event in javafx.event
      Modifier and Type Class 描述
      class  ActionEvent
      一个Event代表某种类型的动作。
      Fields in javafx.event with type parameters of type Event
      Modifier and Type Field 描述
      static EventType<Event> Event.ANY
      所有事件类型的公共超类型。
      protected EventType<? extends Event> Event.eventType
      事件的类型。
      static EventType<Event> EventType.ROOT
      根事件类型。
      Methods in javafx.event that return Event
      Modifier and Type 方法 描述
      Event Event.copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      Event EventDispatchChain.dispatchEvent​(Event event)
      通过此 EventDispatchChain调度指定的事件。
      Event EventDispatcher.dispatchEvent​(Event event, EventDispatchChain tail)
      通过此 EventDispatcher调度指定的事件。
      Methods in javafx.event that return types with arguments of type Event
      Modifier and Type 方法 描述
      EventType<? extends Event> Event.getEventType​()
      获取此事件的事件类型。
      Methods in javafx.event with parameters of type Event
      Modifier and Type 方法 描述
      Event EventDispatchChain.dispatchEvent​(Event event)
      通过此 EventDispatchChain调度指定的事件。
      Event EventDispatcher.dispatchEvent​(Event event, EventDispatchChain tail)
      通过此 EventDispatcher调度指定的事件。
      static void Event.fireEvent​(EventTarget eventTarget, Event event)
      触发指定的事件。
      Constructor parameters in javafx.event with type arguments of type Event
      Constructor 描述
      Event​(Object source, EventTarget target, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。
      Event​(EventType<? extends Event> eventType)
      构造具有指定事件类型的新的 Event 。

    • Uses of Event in javafx.scene

      Methods in javafx.scene with type parameters of type Event
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Node.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      向此节点注册事件过滤器。
      <T extends Event>
      void             		Scene.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      注册一个事件过滤器到这个场景。
      <T extends Event>
      void             		Node.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      向此节点注册事件处理程序。
      <T extends Event>
      void             		Scene.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个场景。
      <T extends Event>
      void             		Node.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此节点注销先前注册的事件过滤器。
      <T extends Event>
      void             		Scene.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此场景注销先前注册的事件过滤器。
      <T extends Event>
      void             		Node.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此节点注销先前注册的事件处理程序。
      <T extends Event>
      void             		Scene.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此场景注销先前注册的事件处理程序。
      protected <T extends Event>
      void             		Node.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      protected <T extends Event>
      void             		Scene.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      Methods in javafx.scene with parameters of type Event
      Modifier and Type 方法 描述
      void Node.fireEvent​(Event event)
      触发指定的事件。

    • Uses of Event in javafx.scene.control

      Subclasses of Event in javafx.scene.control
      Modifier and Type Class 描述
      static class  CheckBoxTreeItem.TreeModificationEvent<T>
      一个TreeModificationEvent类，与类似于TreeItem.TreeModificationEvent的类工作，因为这个事件会引发 CheckBoxTreeItem层次结构，直到父节点为空。
      class  DialogEvent
      与对话框显示/隐藏操作相关的事件。
      static class  ListView.EditEvent<T>
      一个用于表示编辑相关事件的ListView中特别使用的一个Event子类。
      class  ScrollToEvent<T>
      事件相关ScrollPane所虚拟化控制，比如ListView ， TableView ， TreeView和TreeTableView 。
      class  SortEvent<C>
      事件涉及TableView和TreeTableView排序。
      static class  TableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TreeItem.TreeModificationEvent<T>
      一个Event ，其中包含所有形式的TreeItem修改的相关信息。
      static class  TreeTableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TreeTableView.EditEvent<S>
      一个Event在TreeTableView中专门用于表示编辑相关事件的子类。
      static class  TreeView.EditEvent<T>
      一个Event子类，专门用于TreeView中用于表示编辑相关事件。
      Fields in javafx.scene.control with type parameters of type Event
      Modifier and Type Field 描述
      static EventType<Event> CheckBoxTreeItem.TreeModificationEvent.ANY
      所有树修改事件类型的常用超类型。
      static EventType<Event> Tab.CLOSED_EVENT
      当用户关闭此选项卡时调用。
      static EventType<Event> MenuItem.MENU_VALIDATION_EVENT
      当调用Menuitem的加速器时调用
      static EventType<Event> ChoiceBox.ON_HIDDEN
      当ChoiceBox弹出窗口被隐藏时调用。
      static EventType<Event> ComboBoxBase.ON_HIDDEN
      当ComboBox弹出/显示已被隐藏时调用。
      static EventType<Event> Menu.ON_HIDDEN
      当此菜单的contextMenu隐藏时调用。
      static EventType<Event> MenuButton.ON_HIDDEN
      当MenuButton弹出窗口被隐藏时调用。
      static EventType<Event> ChoiceBox.ON_HIDING
      调用的时候ChoiceBox弹出窗口 将被隐藏。
      static EventType<Event> ComboBoxBase.ON_HIDING
      当ComboBox弹出/显示 将被隐藏时调用。
      static EventType<Event> Menu.ON_HIDING
      当该菜单的contextMenu 将被隐藏时调用。
      static EventType<Event> MenuButton.ON_HIDING
      调用的时候，菜单按钮弹出 将被隐藏。
      static EventType<Event> ChoiceBox.ON_SHOWING
      在选择框之前调用，在用户单击或以其他方式与ChoiceBox进行交互之后显示弹出窗口。
      static EventType<Event> ComboBoxBase.ON_SHOWING
      在ComboBox之前调用，在用户单击或以其他方式与ComboBox进行交互之后显示弹出/显示。
      static EventType<Event> Menu.ON_SHOWING
      当此菜单的contextMenu 将被显示时调用。
      static EventType<Event> MenuButton.ON_SHOWING
      在MenuButton显示弹出窗口之前，在用户单击或以其他方式与MenuButton进行交互之后调用。
      static EventType<Event> ChoiceBox.ON_SHOWN
      在ChoiceBox显示弹出窗口后调用。
      static EventType<Event> ComboBoxBase.ON_SHOWN
      在ComboBox显示弹出/显示后调用。
      static EventType<Event> Menu.ON_SHOWN
      当此菜单的contextMenu显示时调用。
      static EventType<Event> MenuButton.ON_SHOWN
      在MenuButton显示弹出窗口后调用。
      static EventType<Event> Tab.SELECTION_CHANGED_EVENT
      当选项卡被选中或未选择时调用。
      static EventType<Event> Tab.TAB_CLOSE_REQUEST_EVENT
      当有外部请求关闭此 Tab 。
      Methods in javafx.scene.control with type parameters of type Event
      Modifier and Type 方法 描述
      <E extends Event>
      void             		Menu.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此MenuItem中注册一个事件处理程序。
      <E extends Event>
      void             		MenuItem.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此MenuItem中注册一个事件处理程序。
      <E extends Event>
      void             		TableColumnBase.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此表列中注册一个事件处理程序。
      <E extends Event>
      void             		TreeItem.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      将一个事件处理程序注册到此TreeItem。
      <E extends Event>
      void             		Menu.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此MenuItem中注销先前注册的事件处理程序。
      <E extends Event>
      void             		MenuItem.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此MenuItem中注销先前注册的事件处理程序。
      <E extends Event>
      void             		TableColumnBase.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此表列中注销先前注册的事件处理程序。
      <E extends Event>
      void             		TreeItem.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此TreeItem中注销先前注册的事件处理程序。
      Methods in javafx.scene.control that return types with arguments of type Event
      Modifier and Type 方法 描述
      EventHandler<Event> Tab.getOnClosed​()
      当选项卡关闭时与选项卡关联的事件处理程序。
      EventHandler<Event> Tab.getOnCloseRequest​()
      获取属性onCloseRequest的值。
      EventHandler<Event> ChoiceBox.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<Event> ComboBoxBase.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<Event> Menu.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<Event> ChoiceBox.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<Event> ComboBoxBase.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<Event> Menu.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<Event> MenuItem.getOnMenuValidation​()
      获取属性onMenuValidation的值。
      EventHandler<Event> Tab.getOnSelectionChanged​()
      与选项卡上的选择相关联的事件处理程序。
      EventHandler<Event> ChoiceBox.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<Event> ComboBoxBase.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<Event> Menu.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<Event> ChoiceBox.getOnShown​()
      获取onShown属性的值。
      EventHandler<Event> ComboBoxBase.getOnShown​()
      获取onShown属性的值。
      EventHandler<Event> Menu.getOnShown​()
      获取onShown属性的值。
      ObjectProperty<EventHandler<Event>> Tab.onClosedProperty​()
      当选项卡关闭时与选项卡关联的事件处理程序。
      ObjectProperty<EventHandler<Event>> Tab.onCloseRequestProperty​()
      当有外部请求关闭此 Tab 。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onHiddenProperty​()
      在ChoiceBox弹出窗口之后刚刚被隐藏。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onHiddenProperty​()
      在ComboBoxBase弹出/显示已被隐藏之后调用。
      ObjectProperty<EventHandler<Event>> Menu.onHiddenProperty​()
      在ContextMenu之后刚刚被隐藏。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onHidingProperty​()
      在ChoiceBox弹出窗口被隐藏之前调用。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onHidingProperty​()
      在ComboBox弹出/显示被隐藏之前调用。
      ObjectProperty<EventHandler<Event>> Menu.onHidingProperty​()
      被称为在ContextMenu被隐藏之前。
      ObjectProperty<EventHandler<Event>> MenuItem.onMenuValidationProperty​()
      与调用MenuItem的加速器相关联的事件处理程序。
      ObjectProperty<EventHandler<Event>> Tab.onSelectionChangedProperty​()
      与选项卡上的选择相关联的事件处理程序。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onShowingProperty​()
      在 ChoiceBox弹出窗口之前调用。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onShowingProperty​()
      在显示 ComboBoxBase弹出/显示之前调用。
      ObjectProperty<EventHandler<Event>> Menu.onShowingProperty​()
      在 ContextMenu被显示之前，即使菜单没有显示项目。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onShownProperty​()
      在ChoiceBox弹出窗口之后调用。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onShownProperty​()
      在ComboBoxBase弹出/显示后显示。
      ObjectProperty<EventHandler<Event>> Menu.onShownProperty​()
      刚刚显示ContextMenu之后。
      Method parameters in javafx.scene.control with type arguments of type Event
      Modifier and Type 方法 描述
      void Tab.setOnClosed​(EventHandler<Event> value)
      定义标签关闭时要调用的函数。
      void Tab.setOnCloseRequest​(EventHandler<Event> value)
      设置属性onCloseRequest的值。
      void ChoiceBox.setOnHidden​(EventHandler<Event> value)
      设置属性onHidden的值。
      void ComboBoxBase.setOnHidden​(EventHandler<Event> value)
      设置属性onHidden的值。
      void Menu.setOnHidden​(EventHandler<Event> value)
      设置属性onHidden的值。
      void ChoiceBox.setOnHiding​(EventHandler<Event> value)
      设置属性onHiding的值。
      void ComboBoxBase.setOnHiding​(EventHandler<Event> value)
      设置属性onHiding的值。
      void Menu.setOnHiding​(EventHandler<Event> value)
      设置属性onHiding的值。
      void MenuItem.setOnMenuValidation​(EventHandler<Event> value)
      设置属性onMenuValidation的值。
      void Tab.setOnSelectionChanged​(EventHandler<Event> value)
      定义在选项卡上发生选择更改时要调用的函数。
      void ChoiceBox.setOnShowing​(EventHandler<Event> value)
      设置属性onShowing的值。
      void ComboBoxBase.setOnShowing​(EventHandler<Event> value)
      设置属性onShowing的值。
      void Menu.setOnShowing​(EventHandler<Event> value)
      设置属性onShowing的值。
      void ChoiceBox.setOnShown​(EventHandler<Event> value)
      设置属性onShown的值。
      void ComboBoxBase.setOnShown​(EventHandler<Event> value)
      设置属性onShown的值。
      void Menu.setOnShown​(EventHandler<Event> value)
      设置属性onShown的值。
      Constructor parameters in javafx.scene.control with type arguments of type Event
      Constructor 描述
      DialogEvent​(Dialog<?> source, EventType<? extends Event> eventType)
      使用指定的事件源，目标和类型构造新的 Event 。
      TreeModificationEvent​(EventType<? extends Event> eventType, CheckBoxTreeItem<T> treeItem, boolean selectionChanged)
      创建一个默认的TreeModificationEvent实例来表示给定的CheckBoxTreeItem实例的选择/不确定状态的变化。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem)
      构建一个基本的TreeModificationEvent - 这在树项目没有收到新值，扩展/折叠状态之间没有变化，并且其子项没有更改的情况下很有用。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, boolean expanded)
      构建一个TreeModificationEvent，当TreeItem的 TreeItem.expandedProperty()更改时。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, List<? extends TreeItem<T>> added, List<? extends TreeItem<T>> removed)
      构造一个TreeModificationEvent，当TreeItem的子项列表更改时。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, T newValue)
      构造一个TreeModificationEvent，当TreeItem已经更改了 TreeItem.valueProperty()时 。

    • Uses of Event in javafx.scene.input

      Subclasses of Event in javafx.scene.input
      Modifier and Type Class 描述
      class  ContextMenuEvent
      当用户请求上下文菜单时，会发生此事件。
      class  DragEvent
      拖动事件在拖放手势时替换鼠标事件。
      class  GestureEvent
      表示手势输入的事件。
      class  InputEvent
      指示用户输入的事件。
      class  InputMethodEvent
      一个表示底层输入法在Node中通知其文本更改的事件 。
      class  KeyEvent
      一个事件，表示击键发生在一个Node 。
      class  MouseDragEvent
      鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
      class  MouseEvent
      当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。
      class  RotateEvent
      旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
      class  ScrollEvent
      滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。
      class  SwipeEvent
      滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。
      class  TouchEvent
      触摸事件表示触摸屏操作。
      class  ZoomEvent
      缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。

    • Uses of Event in javafx.scene.media

      Subclasses of Event in javafx.scene.media
      Modifier and Type Class 描述
      class  MediaErrorEvent
      一个Event表示处理媒体时发生错误。
      class  MediaMarkerEvent
      代表媒体标记的ActionEvent 。

    • Uses of Event in javafx.scene.transform

      Subclasses of Event in javafx.scene.transform
      Modifier and Type Class 描述
      class  TransformChangedEvent
      当它的任何属性发生变化时，这个事件被触发。
      Methods in javafx.scene.transform with type parameters of type Event
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Transform.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      为此转换注册事件过滤器。
      <T extends Event>
      void             		Transform.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个变换。
      <T extends Event>
      void             		Transform.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此转换中注销先前注册的事件过滤器。
      <T extends Event>
      void             		Transform.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此转换中注销先前注册的事件处理程序。

    • Uses of Event in javafx.scene.web

      Subclasses of Event in javafx.scene.web
      Modifier and Type Class 描述
      class  WebErrorEvent
      一个事件指示WebEngine错误。
      class  WebEvent<T>
      WebEvent实例被传递到EventHandler ，注册小号WebEngine由JavaScript的网页上运行。

    • Uses of Event in javafx.stage

      Subclasses of Event in javafx.stage
      Modifier and Type Class 描述
      class  WindowEvent
      与窗口显示/隐藏操作相关的事件。
      Methods in javafx.stage with type parameters of type Event
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Window.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      向此节点注册事件过滤器。
      <T extends Event>
      void             		Window.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      向此节点注册事件处理程序。
      <T extends Event>
      void             		Window.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此节点注销先前注册的事件过滤器。
      <T extends Event>
      void             		Window.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此节点注销先前注册的事件处理程序。
      protected <T extends Event>
      void             		Window.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      Methods in javafx.stage that return types with arguments of type Event
      Modifier and Type 方法 描述
      EventHandler<Event> PopupWindow.getOnAutoHide​()
      获取属性onAutoHide的值。
      ObjectProperty<EventHandler<Event>> PopupWindow.onAutoHideProperty​()
      autoHide运行后调用。
      Methods in javafx.stage with parameters of type Event
      Modifier and Type 方法 描述
      void Window.fireEvent​(Event event)
      触发指定的事件。
      Method parameters in javafx.stage with type arguments of type Event
      Modifier and Type 方法 描述
      void PopupWindow.setOnAutoHide​(EventHandler<Event> value)
      设置属性onAtotoHide的值。
      Constructor parameters in javafx.stage with type arguments of type Event
      Constructor 描述
      WindowEvent​(Window source, EventType<? extends Event> eventType)
      Construct a new Event with the specified event source, target and type.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.event.EventType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.event.EventType

  • Packages that use EventType
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of EventType in javafx.concurrent

      Fields in javafx.concurrent declared as EventType
      Modifier and Type Field 描述
      static EventType<WorkerStateEvent> WorkerStateEvent.ANY
      所有工作状态事件类型的常用超类型。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_CANCELLED
      当Worker实现的状态转换到CANCELED状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_FAILED
      当Worker实现的状态已转换到FAILED状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_READY
      当Worker实现的状态已转换到READY状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_RUNNING
      当Worker实现的状态已转换到RUNNING状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_SCHEDULED
      当Worker实现的状态已转换到SCHEDULED状态时，会发生此事件。
      static EventType<WorkerStateEvent> WorkerStateEvent.WORKER_STATE_SUCCEEDED
      当Worker实现的状态已转换到SUCCEEDED状态时，会发生此事件。
      Methods in javafx.concurrent with parameters of type EventType
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Service.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      将事件过滤器注册到此任务。
      <T extends Event>
      void             		Task.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      将事件过滤器注册到此任务。
      <T extends Event>
      void             		Service.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个任务。
      <T extends Event>
      void             		Task.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个任务。
      <T extends Event>
      void             		Service.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此任务中注销先前注册的事件过滤器。
      <T extends Event>
      void             		Task.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此任务中注销先前注册的事件过滤器。
      <T extends Event>
      void             		Service.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此任务中注销先前注册的事件处理程序。
      <T extends Event>
      void             		Task.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此任务中注销先前注册的事件处理程序。
      protected <T extends Event>
      void             		Service.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      protected <T extends Event>
      void             		Task.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      Constructors in javafx.concurrent with parameters of type EventType
      Constructor 描述
      WorkerStateEvent​(Worker worker, EventType<? extends WorkerStateEvent> eventType)
      创建一个新的WorkerStateEvent。

    • Uses of EventType in javafx.event

      Fields in javafx.event declared as EventType
      Modifier and Type Field 描述
      static EventType<ActionEvent> ActionEvent.ACTION
      ActionEvent唯一有效的EventType。
      static EventType<ActionEvent> ActionEvent.ANY
      所有动作事件类型的公共超类型。
      static EventType<Event> Event.ANY
      所有事件类型的公共超类型。
      protected EventType<? extends Event> Event.eventType
      事件的类型。
      static EventType<Event> EventType.ROOT
      根事件类型。
      Methods in javafx.event that return EventType
      Modifier and Type | 方法 | 描述
      EventType<? extends ActionEvent> | ActionEvent.getEventType​()
      EventType<? extends Event> Event.getEventType​()
      获取此事件的事件类型。
      EventType<? super T> EventType.getSuperType​()
      获取此类型的超级类型。
      Constructors in javafx.event with parameters of type EventType
      Constructor 描述
      Event​(Object source, EventTarget target, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。
      Event​(EventType<? extends Event> eventType)
      构造具有指定事件类型的新的 Event 。
      EventType​(EventType<? super T> superType)
      构造一个新的 EventType具有指定的超类型，名称设置为 null 。
      EventType​(EventType<? super T> superType, String name)
      构造一个新的 EventType具有指定的超类型和名称。

    • Uses of EventType in javafx.scene

      Methods in javafx.scene with parameters of type EventType
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Node.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      向此节点注册事件过滤器。
      <T extends Event>
      void             		Scene.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      注册一个事件过滤器到这个场景。
      <T extends Event>
      void             		Node.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      向此节点注册事件处理程序。
      <T extends Event>
      void             		Scene.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个场景。
      <T extends Event>
      void             		Node.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此节点注销先前注册的事件过滤器。
      <T extends Event>
      void             		Scene.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此场景注销先前注册的事件过滤器。
      <T extends Event>
      void             		Node.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此节点注销先前注册的事件处理程序。
      <T extends Event>
      void             		Scene.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此场景注销先前注册的事件处理程序。
      protected <T extends Event>
      void             		Node.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      protected <T extends Event>
      void             		Scene.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。

    • Uses of EventType in javafx.scene.control

      Fields in javafx.scene.control declared as EventType
      Modifier and Type Field 描述
      static EventType<Event> CheckBoxTreeItem.TreeModificationEvent.ANY
      所有树修改事件类型的常用超类型。
      static EventType<DialogEvent> DialogEvent.ANY
      所有对话事件类型的常用超类型。
      static EventType<?> ListView.EditEvent.ANY
      所有编辑事件类型的公共超类型。
      static EventType<ScrollToEvent> ScrollToEvent.ANY
      所有滚动到事件类型的常用超类型。
      static EventType<SortEvent> SortEvent.ANY
      所有排序事件类型的常用超类型。
      static EventType<?> TableColumn.CellEditEvent.ANY
      所有单元格编辑事件类型的公共超类型。
      static EventType<?> TreeItem.TreeModificationEvent.ANY
      所有树修改事件类型的常用超类型。
      static EventType<?> TreeTableColumn.CellEditEvent.ANY
      所有单元格编辑事件类型的公共超类型。
      static EventType<?> TreeTableView.EditEvent.ANY
      所有编辑事件类型的公共超类型。
      static EventType<?> TreeView.EditEvent.ANY
      所有编辑事件类型的公共超类型。
      static EventType<Event> Tab.CLOSED_EVENT
      当用户关闭此选项卡时调用。
      static EventType<DialogEvent> DialogEvent.DIALOG_CLOSE_REQUEST
      当有外部请求关闭该对话框时，此事件将传递到对话框。
      static EventType<DialogEvent> DialogEvent.DIALOG_HIDDEN
      此事件发生在隐藏后的对话框上。
      static EventType<DialogEvent> DialogEvent.DIALOG_HIDING
      此事件发生在隐藏之前的对话框上。
      static EventType<DialogEvent> DialogEvent.DIALOG_SHOWING
      此事件发生在显示之前的对话框上。
      static EventType<DialogEvent> DialogEvent.DIALOG_SHOWN
      此事件发生在显示之后的对话框上。
      static EventType<Event> MenuItem.MENU_VALIDATION_EVENT
      当调用Menuitem的加速器时调用
      static EventType<Event> ChoiceBox.ON_HIDDEN
      当ChoiceBox弹出窗口被隐藏时调用。
      static EventType<Event> ComboBoxBase.ON_HIDDEN
      当ComboBox弹出/显示已被隐藏时调用。
      static EventType<Event> Menu.ON_HIDDEN
      当此菜单的contextMenu隐藏时调用。
      static EventType<Event> MenuButton.ON_HIDDEN
      当MenuButton弹出窗口被隐藏时调用。
      static EventType<Event> ChoiceBox.ON_HIDING
      调用的时候ChoiceBox弹出窗口 将被隐藏。
      static EventType<Event> ComboBoxBase.ON_HIDING
      当ComboBox弹出/显示 将被隐藏时调用。
      static EventType<Event> Menu.ON_HIDING
      当该菜单的contextMenu 将被隐藏时调用。
      static EventType<Event> MenuButton.ON_HIDING
      调用的时候，菜单按钮弹出 将被隐藏。
      static EventType<Event> ChoiceBox.ON_SHOWING
      在选择框之前调用，在用户单击或以其他方式与ChoiceBox进行交互之后显示弹出窗口。
      static EventType<Event> ComboBoxBase.ON_SHOWING
      在ComboBox之前调用，在用户单击或以其他方式与ComboBox进行交互之后显示弹出/显示。
      static EventType<Event> Menu.ON_SHOWING
      当此菜单的contextMenu 将被显示时调用。
      static EventType<Event> MenuButton.ON_SHOWING
      在MenuButton显示弹出窗口之前，在用户单击或以其他方式与MenuButton进行交互之后调用。
      static EventType<Event> ChoiceBox.ON_SHOWN
      在ChoiceBox显示弹出窗口后调用。
      static EventType<Event> ComboBoxBase.ON_SHOWN
      在ComboBox显示弹出/显示后调用。
      static EventType<Event> Menu.ON_SHOWN
      当此菜单的contextMenu显示时调用。
      static EventType<Event> MenuButton.ON_SHOWN
      在MenuButton显示弹出窗口后调用。
      static EventType<Event> Tab.SELECTION_CHANGED_EVENT
      当选项卡被选中或未选择时调用。
      static EventType<Event> Tab.TAB_CLOSE_REQUEST_EVENT
      当有外部请求关闭这个 Tab 。
      Methods in javafx.scene.control that return EventType
      Modifier and Type | 方法 | 描述
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.branchCollapsedEvent​()
      当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于折叠状态。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.branchExpandedEvent​()
      当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于展开状态。
      static <T> EventType<CheckBoxTreeItem.TreeModificationEvent<T>> CheckBoxTreeItem.checkBoxSelectionChangedEvent​()
      当CheckBoxTreeItem选择/不确定状态改变时使用的EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.childrenModificationEvent​()
      当TreeItem接收到对其子列表的直接修改时使用的EventType。
      static <T> EventType<ListView.EditEvent<T>> ListView.editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editAnyEvent​()
      任何TableColumn编辑事件的父事件。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editAnyEvent​()
      任何TreeTableColumn编辑事件的父事件。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <T> EventType<ListView.EditEvent<T>> ListView.editCancelEvent​()
      一个EventType，用于指示在事件触发的ListView中刚刚取消了编辑事件。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editCancelEvent​()
      表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editCancelEvent​()
      表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editCancelEvent​()
      EventType用于指示事件被触发的TreeTableView中刚刚取消了编辑事件。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editCancelEvent​()
      EventType用于指示事件被触发的TreeView中刚刚取消了编辑事件。
      static <T> EventType<ListView.EditEvent<T>> ListView.editCommitEvent​()
      EventType用于指示已在触发事件的ListView中提交了编辑事件。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editCommitEvent​()
      表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editCommitEvent​()
      表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editCommitEvent​()
      用于指示TreeTableView中的编辑已提交的EventType。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editCommitEvent​()
      用于指示TreeView中的编辑已提交的EventType。
      static <T> EventType<ListView.EditEvent<T>> ListView.editStartEvent​()
      EventType用于指示在事件被触发的ListView中启动编辑事件。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editStartEvent​()
      表示用户已经执行了一些交互来启动编辑事件，或者 TableView.edit(int, javafx.scene.control.TableColumn)方法已被调用。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editStartEvent​()
      表示用户执行了一些交互以启动编辑事件，或者已经调用了 TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)方法。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editStartEvent​()
      EventType用于指示在触发事件的TreeTableView中启动了编辑事件。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editStartEvent​()
      EventType用于指示在事件触发的TreeView中启动了编辑事件。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.expandedItemCountChangeEvent​()
      当TreeItem接收到一个修改，导致孩子数目可见的更改时使用的常规EventType。
      EventType<DialogEvent> | DialogEvent.getEventType​()
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.graphicChangedEvent​()
      当TreeItem接收到其图形属性的修改时使用的EventType。
      static <T extends TableColumnBase<?,?>>
      EventType<ScrollToEvent<T>>             		ScrollToEvent.scrollToColumn​()
      如果用户请求滚动一个TableColumnBase （即
      static EventType<ScrollToEvent<Integer>> ScrollToEvent.scrollToTopIndex​()
      如果用户请求将给定索引滚动到视图中，则会发生此事件。
      static <C> EventType<SortEvent<C>> | SortEvent.sortEvent​()
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.treeNotificationEvent​()
      用于指示事件在TreeItem中发生的基本EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.valueChangedEvent​()
      当TreeItem接收到对其value属性的修改时使用的EventType。
      Methods in javafx.scene.control with parameters of type EventType
      Modifier and Type 方法 描述
      <E extends Event>
      void             		Menu.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此MenuItem中注册一个事件处理程序。
      <E extends Event>
      void             		MenuItem.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此MenuItem中注册一个事件处理程序。
      <E extends Event>
      void             		TableColumnBase.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此表列中注册一个事件处理程序。
      <E extends Event>
      void             		TreeItem.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      将一个事件处理程序注册到此TreeItem。
      DialogEvent DialogEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<DialogEvent> type)
      用给定的字段替换给定事件的副本。
      <E extends Event>
      void             		Menu.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此MenuItem中注销先前注册的事件处理程序。
      <E extends Event>
      void             		MenuItem.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此MenuItem中注销先前注册的事件处理程序。
      <E extends Event>
      void             		TableColumnBase.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此表列中注销先前注册的事件处理程序。
      <E extends Event>
      void             		TreeItem.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此TreeItem中注销先前注册的事件处理程序。
      Constructors in javafx.scene.control with parameters of type EventType
      Constructor 描述
      CellEditEvent​(TableView<S> table, TablePosition<S,T> pos, EventType<TableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。
      CellEditEvent​(TreeTableView<S> table, TreeTablePosition<S,T> pos, EventType<TreeTableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。
      DialogEvent​(Dialog<?> source, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。
      EditEvent​(ListView<T> source, EventType<? extends ListView.EditEvent<T>> eventType, T newValue, int editIndex)
      创建一个新的EditEvent实例来表示编辑事件。
      EditEvent​(TreeTableView<S> source, EventType<? extends TreeTableView.EditEvent> eventType, TreeItem<S> treeItem, S oldValue, S newValue)
      创建一个新的EditEvent实例来表示编辑事件。
      EditEvent​(TreeView<T> source, EventType<? extends TreeView.EditEvent> eventType, TreeItem<T> treeItem, T oldValue, T newValue)
      创建一个新的EditEvent实例来表示编辑事件。
      ScrollToEvent​(Object source, EventTarget target, EventType<ScrollToEvent<T>> type, T scrollTarget)
      构造一个新的 Event与指定的事件源，目标和类型。
      TreeModificationEvent​(EventType<? extends Event> eventType, CheckBoxTreeItem<T> treeItem, boolean selectionChanged)
      创建一个默认的TreeModificationEvent实例来表示给定的CheckBoxTreeItem实例的选择/不确定状态的变化。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem)
      构建一个基本的TreeModificationEvent - 这在树项目没有收到新值，扩展/折叠状态之间没有变化，并且其子项没有更改的情况下很有用。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, boolean expanded)
      构建一个TreeModificationEvent，当TreeItem已经更改了 TreeItem.expandedProperty()时 。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, List<? extends TreeItem<T>> added, List<? extends TreeItem<T>> removed)
      构造一个TreeModificationEvent，当TreeItem的子项列表更改时。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, T newValue)
      构建TreeModificationEvent，当TreeItem已经更改了它的 TreeItem.valueProperty()时 。

    • Uses of EventType in javafx.scene.input

      Fields in javafx.scene.input declared as EventType
      Modifier and Type Field 描述
      static EventType<ContextMenuEvent> ContextMenuEvent.ANY
      所有上下文菜单事件类型的常用超类型。
      static EventType<DragEvent> DragEvent.ANY
      所有拖动事件类型的常用超类型。
      static EventType<GestureEvent> GestureEvent.ANY
      所有手势的常用超类型。
      static EventType<InputEvent> InputEvent.ANY
      所有输入事件类型的常用超类型。
      static EventType<InputMethodEvent> InputMethodEvent.ANY
      所有输入法事件类型的公共超类型。
      static EventType<KeyEvent> KeyEvent.ANY
      所有关键事件类型的常用超类型。
      static EventType<MouseDragEvent> MouseDragEvent.ANY
      所有鼠标事件类型的常用超类型。
      static EventType<MouseEvent> MouseEvent.ANY
      所有鼠标事件类型的常用超类型。
      static EventType<RotateEvent> RotateEvent.ANY
      所有旋转事件类型的公共超类型。
      static EventType<ScrollEvent> ScrollEvent.ANY
      所有滚动事件类型的常用超类型。
      static EventType<SwipeEvent> SwipeEvent.ANY
      所有滑动事件类型的常用超类型。
      static EventType<TouchEvent> TouchEvent.ANY
      所有触摸事件类型的常用超类型。
      static EventType<ZoomEvent> ZoomEvent.ANY
      所有缩放事件类型的常用超类型。
      static EventType<ContextMenuEvent> ContextMenuEvent.CONTEXT_MENU_REQUESTED
      当请求上下文菜单时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.DRAG_DETECTED
      该事件被传递到被识别为拖动手势的源的节点。
      static EventType<DragEvent> DragEvent.DRAG_DONE
      数据丢弃在放置目标上之后，这种事件就发生在拖放手势源上。
      static EventType<DragEvent> DragEvent.DRAG_DROPPED
      当在拖放目标上拖放手势时释放鼠标按钮时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_ENTERED
      当拖动手势进入节点时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_ENTERED_TARGET
      当拖动手势进入节点时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_EXITED
      当拖动手势退出节点时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_EXITED_TARGET
      当拖动手势退出节点时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_OVER
      当拖动手势在该节点内进行时，会发生此事件。
      static EventType<InputMethodEvent> InputMethodEvent.INPUT_METHOD_TEXT_CHANGED
      InputMethodEvent唯一有效的EventType。
      static EventType<KeyEvent> KeyEvent.KEY_PRESSED
      当按下键时，会发生此事件。
      static EventType<KeyEvent> KeyEvent.KEY_RELEASED
      当一个键被释放时，会发生这种情况。
      static EventType<KeyEvent> KeyEvent.KEY_TYPED
      当字符生成键被键入（按下并释放）时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_CLICKED
      当单击鼠标按钮（在同一节点上按下并释放）时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_ENTERED
      当手势进入节点时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_ENTERED_TARGET
      当手势进入节点时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_EXITED
      当手势退出节点时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_EXITED_TARGET
      当手势退出节点时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_OVER
      当该节点内的手势进行时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_RELEASED
      当手势在该节点上结束（通过释放鼠标按钮）时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_DRAGGED
      当鼠标按下按钮移动时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_ENTERED
      当鼠标进入节点时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_ENTERED_TARGET
      当鼠标进入节点时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_EXITED
      当鼠标退出节点时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_EXITED_TARGET
      当鼠标退出节点时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_MOVED
      当鼠标在节点内移动并且没有按钮被按下时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_PRESSED
      当按下鼠标按钮时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_RELEASED
      当鼠标按钮被释放时，会发生此事件。
      static EventType<RotateEvent> RotateEvent.ROTATE
      当用户执行旋转手势（例如将两个手指彼此拖动时）发生此事件。
      static EventType<RotateEvent> RotateEvent.ROTATION_FINISHED
      当旋转手势结束时，会发生此事件。
      static EventType<RotateEvent> RotateEvent.ROTATION_STARTED
      当检测到旋转手势时，会发生此事件。
      static EventType<ScrollEvent> ScrollEvent.SCROLL
      当用户执行滚动操作（例如旋转鼠标滚轮或在触摸屏上拖动手指）时，会发生此事件。
      static EventType<ScrollEvent> ScrollEvent.SCROLL_FINISHED
      当滚动手势结束时，会发生此事件。
      static EventType<ScrollEvent> ScrollEvent.SCROLL_STARTED
      当检测到滚动手势时，会发生此事件。
      static EventType<SwipeEvent> SwipeEvent.SWIPE_DOWN
      当用户执行向下滑动手势时，会发生此事件。
      static EventType<SwipeEvent> SwipeEvent.SWIPE_LEFT
      当用户执行向左滑动手势时，会发生此事件。
      static EventType<SwipeEvent> SwipeEvent.SWIPE_RIGHT
      当用户执行向右滑动手势时，会发生此事件。
      static EventType<SwipeEvent> SwipeEvent.SWIPE_UP
      当用户执行向上滑动手势时，会发生此事件。
      static EventType<TouchEvent> TouchEvent.TOUCH_MOVED
      触摸点移动时会发生此事件。
      static EventType<TouchEvent> TouchEvent.TOUCH_PRESSED
      当按下触摸点（第一次触摸）时，会发生此事件。
      static EventType<TouchEvent> TouchEvent.TOUCH_RELEASED
      当触发点被释放时，会发生此事件。
      static EventType<TouchEvent> TouchEvent.TOUCH_STATIONARY
      当按住触摸点并静止（不移动）时，会发生此事件。
      static EventType<ZoomEvent> ZoomEvent.ZOOM
      当用户执行缩放手势（例如拖动两根手指）时，会发生此事件。
      static EventType<ZoomEvent> ZoomEvent.ZOOM_FINISHED
      当缩放手势结束时，会发生此事件。
      static EventType<ZoomEvent> ZoomEvent.ZOOM_STARTED
      当检测到缩放手势时，会发生此事件。
      Methods in javafx.scene.input that return EventType
      Modifier and Type | 方法 | 描述
      EventType<ContextMenuEvent> | ContextMenuEvent.getEventType​()
      EventType<DragEvent> | DragEvent.getEventType​()
      EventType<? extends GestureEvent> | GestureEvent.getEventType​()
      EventType<? extends InputEvent> | InputEvent.getEventType​()
      EventType<InputMethodEvent> | InputMethodEvent.getEventType​()
      EventType<KeyEvent> | KeyEvent.getEventType​()
      EventType<MouseDragEvent> | MouseDragEvent.getEventType​()
      EventType<? extends MouseEvent> | MouseEvent.getEventType​()
      EventType<RotateEvent> | RotateEvent.getEventType​()
      EventType<ScrollEvent> | ScrollEvent.getEventType​()
      EventType<SwipeEvent> | SwipeEvent.getEventType​()
      EventType<TouchEvent> | TouchEvent.getEventType​()
      EventType<ZoomEvent> | ZoomEvent.getEventType​()
      Methods in javafx.scene.input with parameters of type EventType
      Modifier and Type | 方法 | 描述
      DragEvent DragEvent.copyFor​(Object source, EventTarget target, Object gestureSource, Object gestureTarget, EventType<DragEvent> eventType)
      创建给定字段替换的给定拖动事件的副本。
      DragEvent DragEvent.copyFor​(Object source, EventTarget target, EventType<DragEvent> type)
      创建给定字段替换的给定拖动事件的副本。
      KeyEvent KeyEvent.copyFor​(Object source, EventTarget target, EventType<KeyEvent> type)
      用给定的字段替换给定事件的副本。
      MouseDragEvent | MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> type)
      MouseEvent MouseEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> eventType)
      用给定的字段替换给定事件的副本。
      RotateEvent RotateEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<RotateEvent> type)
      用给定的字段替换给定事件的副本。
      ScrollEvent ScrollEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ScrollEvent> type)
      用给定的字段替换给定事件的副本。
      SwipeEvent SwipeEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<SwipeEvent> type)
      用给定的字段替换给定事件的副本。
      TouchEvent TouchEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<TouchEvent> type)
      用给定的字段替换给定事件的副本。
      ZoomEvent ZoomEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ZoomEvent> type)
      用给定的字段替换给定事件的副本。
      static MouseDragEvent MouseEvent.copyForMouseDragEvent​(MouseEvent e, Object source, EventTarget target, EventType<MouseDragEvent> type, Object gestureSource, PickResult pickResult)
      创建MouseDragEvent类型的鼠标事件的副本
      Constructors in javafx.scene.input with parameters of type EventType
      Constructor 描述
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType)
      已过时。
      不要使用这个构造函数。 构造空事件。
      GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)
      构建新的GestureEvent事件。
      GestureEvent​(EventType<? extends GestureEvent> eventType)
      已过时。
      不要使用这个构造函数。 构造空事件。
      GestureEvent​(EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)
      构造新的GestureEvent事件，具有空源和目标
      InputEvent​(Object source, EventTarget target, EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
      InputEvent​(EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造具有空源和目标的新的InputMethodEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      根据指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。

    • Uses of EventType in javafx.scene.media

      Fields in javafx.scene.media declared as EventType
      Modifier and Type Field 描述
      static EventType<MediaErrorEvent> MediaErrorEvent.MEDIA_ERROR
      唯一有效的事件类型为 MediaErrorEvent 。
      Methods in javafx.scene.media that return EventType
      Modifier and Type | 方法 | 描述
      EventType<MediaErrorEvent> | MediaErrorEvent.getEventType​()

    • Uses of EventType in javafx.scene.transform

      Fields in javafx.scene.transform declared as EventType
      Modifier and Type Field 描述
      static EventType<TransformChangedEvent> TransformChangedEvent.ANY
      所有变换事件类型的公共超类型。
      static EventType<TransformChangedEvent> TransformChangedEvent.TRANSFORM_CHANGED
      TransformChangedEvent唯一有效的EventType。
      Methods in javafx.scene.transform with parameters of type EventType
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Transform.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      为此转换注册事件过滤器。
      <T extends Event>
      void             		Transform.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个变换。
      <T extends Event>
      void             		Transform.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此转换中注销先前注册的事件过滤器。
      <T extends Event>
      void             		Transform.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此转换中注销先前注册的事件处理程序。

    • Uses of EventType in javafx.scene.web

      Fields in javafx.scene.web declared as EventType
      Modifier and Type Field 描述
      static EventType<WebEvent> WebEvent.ALERT
      当脚本调用JavaScript alert函数时，会发生此事件。
      static EventType<WebErrorEvent> WebErrorEvent.ANY
      所有 WebErrorEvent类型的常用超类型。
      static EventType<WebEvent> WebEvent.ANY
      所有Web事件类型的常用超类型。
      static EventType<WebEvent> WebEvent.RESIZED
      当脚本更改JavaScript window对象的位置时，会发生此事件。
      static EventType<WebEvent> WebEvent.STATUS_CHANGED
      当脚本更改状态行文本时，会发生此事件。
      static EventType<WebErrorEvent> WebErrorEvent.USER_DATA_DIRECTORY_ALREADY_IN_USE
      当WebEngine检测到其用户数据目录已在不同VM中运行的WebEngine已被使用时，会发生此事件。
      static EventType<WebErrorEvent> WebErrorEvent.USER_DATA_DIRECTORY_IO_ERROR
      当WebEngine在尝试创建或访问用户数据目录时遇到I / O错误时，会发生此事件。
      static EventType<WebErrorEvent> WebErrorEvent.USER_DATA_DIRECTORY_SECURITY_ERROR
      当WebEngine在尝试创建或访问用户数据目录时遇到安全错误时，会发生此事件。
      static EventType<WebEvent> WebEvent.VISIBILITY_CHANGED
      当脚本更改JavaScript window对象的可见性时，会发生此事件。
      Constructors in javafx.scene.web with parameters of type EventType
      Constructor 描述
      WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)
      创建一个新的 WebErrorEvent 。
      WebEvent​(Object source, EventType<WebEvent> type, T data)
      创建一个新的事件对象。

    • Uses of EventType in javafx.stage

      Fields in javafx.stage declared as EventType
      Modifier and Type Field 描述
      static EventType<WindowEvent> WindowEvent.ANY
      所有窗口事件类型的常用超类型。
      static EventType<WindowEvent> WindowEvent.WINDOW_CLOSE_REQUEST
      当有外部请求关闭该窗口时，此事件将传递到窗口。
      static EventType<WindowEvent> WindowEvent.WINDOW_HIDDEN
      此事件发生在隐藏后的窗口上。
      static EventType<WindowEvent> WindowEvent.WINDOW_HIDING
      此事件发生在隐藏之前的窗口上。
      static EventType<WindowEvent> WindowEvent.WINDOW_SHOWING
      此事件发生在显示之前的窗口上。
      static EventType<WindowEvent> WindowEvent.WINDOW_SHOWN
      此事件发生在显示之后的窗口上。
      Methods in javafx.stage that return EventType
      Modifier and Type | 方法 | 描述
      EventType<WindowEvent> | WindowEvent.getEventType​()
      Methods in javafx.stage with parameters of type EventType
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Window.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      向此节点注册事件过滤器。
      <T extends Event>
      void             		Window.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      向此节点注册事件处理程序。
      WindowEvent WindowEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<WindowEvent> type)
      用给定的字段替换给定事件的副本。
      <T extends Event>
      void             		Window.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此节点注销先前注册的事件过滤器。
      <T extends Event>
      void             		Window.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此节点注销先前注册的事件处理程序。
      protected <T extends Event>
      void             		Window.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      Constructors in javafx.stage with parameters of type EventType
      Constructor 描述
      WindowEvent​(Window source, EventType<? extends Event> eventType)
      构造新的 Event与指定的事件源，目标和类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.event.WeakEventHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.event.WeakEventHandler

No usage of javafx.event.WeakEventHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.event.EventDispatchChain (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.event.EventDispatchChain

  • Packages that use EventDispatchChain
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of EventDispatchChain in javafx.concurrent

      Methods in javafx.concurrent that return EventDispatchChain
      Modifier and Type | 方法 | 描述
      EventDispatchChain | Service.buildEventDispatchChain​(EventDispatchChain tail)
      EventDispatchChain | Task.buildEventDispatchChain​(EventDispatchChain tail)
      Methods in javafx.concurrent with parameters of type EventDispatchChain
      Modifier and Type | 方法 | 描述
      EventDispatchChain | Service.buildEventDispatchChain​(EventDispatchChain tail)
      EventDispatchChain | Task.buildEventDispatchChain​(EventDispatchChain tail)

    • Uses of EventDispatchChain in javafx.event

      Methods in javafx.event that return EventDispatchChain
      Modifier and Type 方法 描述
      EventDispatchChain EventDispatchChain.append​(EventDispatcher eventDispatcher)
      将指定的 EventDispatcher追加到此链。
      EventDispatchChain EventTarget.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain EventDispatchChain.prepend​(EventDispatcher eventDispatcher)
      为此链条预先指定了 EventDispatcher 。
      Methods in javafx.event with parameters of type EventDispatchChain
      Modifier and Type 方法 描述
      EventDispatchChain EventTarget.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      Event EventDispatcher.dispatchEvent​(Event event, EventDispatchChain tail)
      通过此 EventDispatcher调度指定的事件。

    • Uses of EventDispatchChain in javafx.scene

      Methods in javafx.scene that return EventDispatchChain
      Modifier and Type 方法 描述
      EventDispatchChain Node.buildEventDispatchChain​(EventDispatchChain tail)
      为此节点构造事件调度链。
      EventDispatchChain Scene.buildEventDispatchChain​(EventDispatchChain tail)
      为此场景构建事件调度链。
      Methods in javafx.scene with parameters of type EventDispatchChain
      Modifier and Type 方法 描述
      EventDispatchChain Node.buildEventDispatchChain​(EventDispatchChain tail)
      为此节点构造事件调度链。
      EventDispatchChain Scene.buildEventDispatchChain​(EventDispatchChain tail)
      为此场景构建事件调度链。

    • Uses of EventDispatchChain in javafx.scene.control

      Methods in javafx.scene.control that return EventDispatchChain
      Modifier and Type 方法 描述
      EventDispatchChain Dialog.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain Menu.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain MenuItem.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain Tab.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain TableColumnBase.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain TreeItem.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      Methods in javafx.scene.control with parameters of type EventDispatchChain
      Modifier and Type 方法 描述
      EventDispatchChain Dialog.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain Menu.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain MenuItem.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain Tab.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain TableColumnBase.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      EventDispatchChain TreeItem.buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。

    • Uses of EventDispatchChain in javafx.scene.transform

      Methods in javafx.scene.transform that return EventDispatchChain
      Modifier and Type | 方法 | 描述
      EventDispatchChain | Transform.buildEventDispatchChain​(EventDispatchChain tail)
      Methods in javafx.scene.transform with parameters of type EventDispatchChain
      Modifier and Type | 方法 | 描述
      EventDispatchChain | Transform.buildEventDispatchChain​(EventDispatchChain tail)

    • Uses of EventDispatchChain in javafx.stage

      Methods in javafx.stage that return EventDispatchChain
      Modifier and Type 方法 描述
      EventDispatchChain Window.buildEventDispatchChain​(EventDispatchChain tail)
      为此窗口构建事件调度链。
      Methods in javafx.stage with parameters of type EventDispatchChain
      Modifier and Type 方法 描述
      EventDispatchChain Window.buildEventDispatchChain​(EventDispatchChain tail)
      为此窗口构建事件调度链。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.event.EventDispatcher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.event.EventDispatcher

  • Packages that use EventDispatcher
    软件包 描述
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of EventDispatcher in javafx.event

      Methods in javafx.event with parameters of type EventDispatcher
      Modifier and Type 方法 描述
      EventDispatchChain EventDispatchChain.append​(EventDispatcher eventDispatcher)
      将指定的 EventDispatcher追加到此链。
      EventDispatchChain EventDispatchChain.prepend​(EventDispatcher eventDispatcher)
      为此链条预先指定了 EventDispatcher 。

    • Uses of EventDispatcher in javafx.scene

      Methods in javafx.scene that return EventDispatcher
      Modifier and Type 方法 描述
      EventDispatcher Node.getEventDispatcher​()
      获取属性eventDispatcher的值。
      EventDispatcher Scene.getEventDispatcher​()
      获取属性eventDispatcher的值。
      Methods in javafx.scene that return types with arguments of type EventDispatcher
      Modifier and Type 方法 描述
      ObjectProperty<EventDispatcher> Node.eventDispatcherProperty​()
      指定此节点的事件分派器。
      ObjectProperty<EventDispatcher> Scene.eventDispatcherProperty​()
      指定此场景的事件调度程序。
      Methods in javafx.scene with parameters of type EventDispatcher
      Modifier and Type 方法 描述
      void Node.setEventDispatcher​(EventDispatcher value)
      设置属性eventDispatcher的值。
      void Scene.setEventDispatcher​(EventDispatcher value)
      设置属性eventDispatcher的值。

    • Uses of EventDispatcher in javafx.stage

      Methods in javafx.stage that return EventDispatcher
      Modifier and Type 方法 描述
      EventDispatcher Window.getEventDispatcher​()
      获取属性eventDispatcher的值。
      Methods in javafx.stage that return types with arguments of type EventDispatcher
      Modifier and Type 方法 描述
      ObjectProperty<EventDispatcher> Window.eventDispatcherProperty​()
      指定此节点的事件分派器。
      Methods in javafx.stage with parameters of type EventDispatcher
      Modifier and Type 方法 描述
      void Window.setEventDispatcher​(EventDispatcher value)
      设置属性eventDispatcher的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.event.EventHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.event.EventHandler

  • Packages that use EventHandler
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of EventHandler in javafx.animation

      Methods in javafx.animation that return EventHandler
      Modifier and Type 方法 描述
      EventHandler<ActionEvent> Animation.getOnFinished​()
      获取属性onFinished的值。
      EventHandler<ActionEvent> KeyFrame.getOnFinished​()
      返回 onFinished此事件处理 KeyFrame 。
      Methods in javafx.animation that return types with arguments of type EventHandler
      Modifier and Type 方法 描述
      ObjectProperty<EventHandler<ActionEvent>> Animation.onFinishedProperty​()
      在这个 Animation的结论执行的行动。
      Methods in javafx.animation with parameters of type EventHandler
      Modifier and Type 方法 描述
      void Animation.setOnFinished​(EventHandler<ActionEvent> value)
      设置属性onFinished的值。
      Constructors in javafx.animation with parameters of type EventHandler
      Constructor 描述
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame

    • Uses of EventHandler in javafx.concurrent

      Methods in javafx.concurrent that return EventHandler
      Modifier and Type 方法 描述
      EventHandler<WorkerStateEvent> Service.getOnCancelled​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnCancelled​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnFailed​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnFailed​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnReady​()
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnRunning​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnRunning​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnScheduled​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnScheduled​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      EventHandler<WorkerStateEvent> Service.getOnSucceeded​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      EventHandler<WorkerStateEvent> Task.getOnSucceeded​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      Methods in javafx.concurrent that return types with arguments of type EventHandler
      Modifier and Type 方法 描述
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onCancelledProperty​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onCancelledProperty​()
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onFailedProperty​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onFailedProperty​()
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onReadyProperty​()
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onRunningProperty​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onRunningProperty​()
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onScheduledProperty​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onScheduledProperty​()
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Service.onSucceededProperty​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      ObjectProperty<EventHandler<WorkerStateEvent>> Task.onSucceededProperty​()
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      Methods in javafx.concurrent with parameters of type EventHandler
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Service.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      将事件过滤器注册到此任务。
      <T extends Event>
      void             		Task.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      将事件过滤器注册到此任务。
      <T extends Event>
      void             		Service.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个任务。
      <T extends Event>
      void             		Task.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个任务。
      <T extends Event>
      void             		Service.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此任务中注销先前注册的事件过滤器。
      <T extends Event>
      void             		Task.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此任务中注销先前注册的事件过滤器。
      <T extends Event>
      void             		Service.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此任务中注销先前注册的事件处理程序。
      <T extends Event>
      void             		Task.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此任务中注销先前注册的事件处理程序。
      protected <T extends Event>
      void             		Service.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      protected <T extends Event>
      void             		Task.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      void Service.setOnCancelled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      void Task.setOnCancelled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
      void Service.setOnFailed​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      void Task.setOnFailed​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
      void Service.setOnReady​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
      void Service.setOnRunning​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      void Task.setOnRunning​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
      void Service.setOnScheduled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      void Task.setOnScheduled​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
      void Service.setOnSucceeded​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
      void Task.setOnSucceeded​(EventHandler<WorkerStateEvent> value)
      每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。

    • Uses of EventHandler in javafx.event

      Classes in javafx.event that implement EventHandler
      Modifier and Type Class 描述
      class  WeakEventHandler<T extends Event>
      用于事件处理程序注册代替其关联的事件处理程序。
      Constructors in javafx.event with parameters of type EventHandler
      Constructor 描述
      WeakEventHandler​(EventHandler<T> eventHandler)
      创建一个新的实例 WeakEventHandler 。

    • Uses of EventHandler in javafx.scene

      Methods in javafx.scene that return EventHandler
      Modifier and Type 方法 描述
      EventHandler<? super ContextMenuEvent> Node.getOnContextMenuRequested​()
      获取属性onContextMenuRequested的值。
      EventHandler<? super ContextMenuEvent> Scene.getOnContextMenuRequested​()
      获取属性onContextMenuRequested的值。
      EventHandler<? super MouseEvent> Node.getOnDragDetected​()
      获取属性onDragDetected的值。
      EventHandler<? super MouseEvent> Scene.getOnDragDetected​()
      获取属性onDragDetected的值。
      EventHandler<? super DragEvent> Node.getOnDragDone​()
      获取属性onDragDone的值。
      EventHandler<? super DragEvent> Scene.getOnDragDone​()
      获取属性onDragDone的值。
      EventHandler<? super DragEvent> Node.getOnDragDropped​()
      获取属性onDragDropped的值。
      EventHandler<? super DragEvent> Scene.getOnDragDropped​()
      获取属性onDragDropped的值。
      EventHandler<? super DragEvent> Node.getOnDragEntered​()
      获取属性onDragEntered的值。
      EventHandler<? super DragEvent> Scene.getOnDragEntered​()
      获取属性onDragEntered的值。
      EventHandler<? super DragEvent> Node.getOnDragExited​()
      获取属性onDragExited的值。
      EventHandler<? super DragEvent> Scene.getOnDragExited​()
      获取属性onDragExited的值。
      EventHandler<? super DragEvent> Node.getOnDragOver​()
      获取属性onDragOver的值。
      EventHandler<? super DragEvent> Scene.getOnDragOver​()
      获取属性onDragOver的值。
      EventHandler<? super InputMethodEvent> Node.getOnInputMethodTextChanged​()
      获取onInputMethodTextChanged属性的值。
      EventHandler<? super InputMethodEvent> Scene.getOnInputMethodTextChanged​()
      获取onInputMethodTextChanged属性的值。
      EventHandler<? super KeyEvent> Node.getOnKeyPressed​()
      获取属性onKeyPressed的值。
      EventHandler<? super KeyEvent> Scene.getOnKeyPressed​()
      获取属性onKeyPressed的值。
      EventHandler<? super KeyEvent> Node.getOnKeyReleased​()
      获取属性onKeyReleased的值。
      EventHandler<? super KeyEvent> Scene.getOnKeyReleased​()
      获取属性onKeyReleased的值。
      EventHandler<? super KeyEvent> Node.getOnKeyTyped​()
      获取属性onKeyTyped的值。
      EventHandler<? super KeyEvent> Scene.getOnKeyTyped​()
      获取属性onKeyTyped的值。
      EventHandler<? super MouseEvent> Node.getOnMouseClicked​()
      获取属性onMouseClicked的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseClicked​()
      获取属性onMouseClicked的值。
      EventHandler<? super MouseDragEvent> Node.getOnMouseDragEntered​()
      获取属性onMouseDragEntered的值。
      EventHandler<? super MouseDragEvent> Scene.getOnMouseDragEntered​()
      获取属性onMouseDragEntered的值。
      EventHandler<? super MouseDragEvent> Node.getOnMouseDragExited​()
      获取属性onMouseDragExited的值。
      EventHandler<? super MouseDragEvent> Scene.getOnMouseDragExited​()
      获取属性onMouseDragExited的值。
      EventHandler<? super MouseEvent> Node.getOnMouseDragged​()
      获取属性onMouseDragged的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseDragged​()
      获取属性onMouseDragged的值。
      EventHandler<? super MouseDragEvent> Node.getOnMouseDragOver​()
      获取属性onMouseDragOver的值。
      EventHandler<? super MouseDragEvent> Scene.getOnMouseDragOver​()
      获取属性onMouseDragOver的值。
      EventHandler<? super MouseDragEvent> Node.getOnMouseDragReleased​()
      获取属性onMouseDragReleased的值。
      EventHandler<? super MouseDragEvent> Scene.getOnMouseDragReleased​()
      获取属性onMouseDragReleased的值。
      EventHandler<? super MouseEvent> Node.getOnMouseEntered​()
      获取属性onMouseEntered的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseEntered​()
      获取属性onMouseEntered的值。
      EventHandler<? super MouseEvent> Node.getOnMouseExited​()
      获取属性onMouseExited的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseExited​()
      获取属性onMouseExited的值。
      EventHandler<? super MouseEvent> Node.getOnMouseMoved​()
      获取属性onMouseMoved的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseMoved​()
      获取属性onMouseMoved的值。
      EventHandler<? super MouseEvent> Node.getOnMousePressed​()
      获取属性onMousePressed的值。
      EventHandler<? super MouseEvent> Scene.getOnMousePressed​()
      获取属性onMousePressed的值。
      EventHandler<? super MouseEvent> Node.getOnMouseReleased​()
      获取属性onMouseReleased的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseReleased​()
      获取属性onMouseReleased的值。
      EventHandler<? super RotateEvent> Node.getOnRotate​()
      获取属性onRotate的值。
      EventHandler<? super RotateEvent> Scene.getOnRotate​()
      获取属性onRotate的值。
      EventHandler<? super RotateEvent> Node.getOnRotationFinished​()
      获取属性onRotationFinished的值。
      EventHandler<? super RotateEvent> Scene.getOnRotationFinished​()
      获取属性onRotationFinished的值。
      EventHandler<? super RotateEvent> Node.getOnRotationStarted​()
      获取属性onRotationStarted的值。
      EventHandler<? super RotateEvent> Scene.getOnRotationStarted​()
      获取属性onRotationStarted的值。
      EventHandler<? super ScrollEvent> Node.getOnScroll​()
      获取属性onScroll的值。
      EventHandler<? super ScrollEvent> Scene.getOnScroll​()
      获取属性onScroll的值。
      EventHandler<? super ScrollEvent> Node.getOnScrollFinished​()
      获取属性onScrollFinished的值。
      EventHandler<? super ScrollEvent> Scene.getOnScrollFinished​()
      获取属性onScrollFinished的值。
      EventHandler<? super ScrollEvent> Node.getOnScrollStarted​()
      获取属性onScrollStarted的值。
      EventHandler<? super ScrollEvent> Scene.getOnScrollStarted​()
      获取属性onScrollStarted的值。
      EventHandler<? super SwipeEvent> Node.getOnSwipeDown​()
      获取属性onSwipeDown的值。
      EventHandler<? super SwipeEvent> Scene.getOnSwipeDown​()
      获取属性onSwipeDown的值。
      EventHandler<? super SwipeEvent> Node.getOnSwipeLeft​()
      获取属性onSwipeLeft的值。
      EventHandler<? super SwipeEvent> Scene.getOnSwipeLeft​()
      获取属性onSwipeLeft的值。
      EventHandler<? super SwipeEvent> Node.getOnSwipeRight​()
      获取属性onSwipeRight的值。
      EventHandler<? super SwipeEvent> Scene.getOnSwipeRight​()
      获取属性onSwipeRight的值。
      EventHandler<? super SwipeEvent> Node.getOnSwipeUp​()
      获取属性onSwipeUp的值。
      EventHandler<? super SwipeEvent> Scene.getOnSwipeUp​()
      获取属性onSwipeUp的值。
      EventHandler<? super TouchEvent> Node.getOnTouchMoved​()
      获取onTouchMoved属性的值。
      EventHandler<? super TouchEvent> Scene.getOnTouchMoved​()
      获取onTouchMoved属性的值。
      EventHandler<? super TouchEvent> Node.getOnTouchPressed​()
      获取onTouchPressed属性的值。
      EventHandler<? super TouchEvent> Scene.getOnTouchPressed​()
      获取onTouchPressed属性的值。
      EventHandler<? super TouchEvent> Node.getOnTouchReleased​()
      获取onTouchReleased属性的值。
      EventHandler<? super TouchEvent> Scene.getOnTouchReleased​()
      获取onTouchReleased属性的值。
      EventHandler<? super TouchEvent> Node.getOnTouchStationary​()
      获取属性onTouchStationary的值。
      EventHandler<? super TouchEvent> Scene.getOnTouchStationary​()
      获取属性onTouchStationary的值。
      EventHandler<? super ZoomEvent> Node.getOnZoom​()
      获取属性onZoom的值。
      EventHandler<? super ZoomEvent> Scene.getOnZoom​()
      获取属性onZoom的值。
      EventHandler<? super ZoomEvent> Node.getOnZoomFinished​()
      获取属性onZoomFinished的值。
      EventHandler<? super ZoomEvent> Scene.getOnZoomFinished​()
      获取属性onZoomFinished的值。
      EventHandler<? super ZoomEvent> Node.getOnZoomStarted​()
      获取属性onZoomStarted的值。
      EventHandler<? super ZoomEvent> Scene.getOnZoomStarted​()
      获取属性onZoomStarted的值。
      Methods in javafx.scene that return types with arguments of type EventHandler
      Modifier and Type 方法 描述
      ObjectProperty<EventHandler<? super ContextMenuEvent>> Node.onContextMenuRequestedProperty​()
      定义在 Node上请求上下文菜单时要调用的函数。
      ObjectProperty<EventHandler<? super ContextMenuEvent>> Scene.onContextMenuRequestedProperty​()
      定义当这个 Scene点击（按下并释放）鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onDragDetectedProperty​()
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onDragDetectedProperty​()
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragDoneProperty​()
      当这个 Node是一个拖放手势源，它的数据被丢弃在放置目标上之后，定义要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragDoneProperty​()
      定义当这个 Scene在数据放在放置目标上之后是拖放手势源时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragDroppedProperty​()
      定义当在拖放手势时释放 Node鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragDroppedProperty​()
      定义当在拖放手势时释放 Scene鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragEnteredProperty​()
      定义当拖动手势进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragEnteredProperty​()
      定义当拖动手势进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragExitedProperty​()
      定义当拖动手势退出 Node时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragExitedProperty​()
      定义当拖动手势退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragOverProperty​()
      定义当这个 Node拖动手势进行时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragOverProperty​()
      定义在 Scene拖动手势进度时要调用的功能。
      ObjectProperty<EventHandler<? super InputMethodEvent>> Node.onInputMethodTextChangedProperty​()
      定义当这个 Node具有输入焦点并且输入法文本已更改时要调用的函数。
      ObjectProperty<EventHandler<? super InputMethodEvent>> Scene.onInputMethodTextChangedProperty​()
      定义当这个 Node具有输入焦点并且输入法文本已更改时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Node.onKeyPressedProperty​()
      定义当此 Node或其子项 Node具有输入焦点并按下键时要调用的功能。
      ObjectProperty<EventHandler<? super KeyEvent>> Scene.onKeyPressedProperty​()
      当 Node的 Scene具有输入焦点并按下一个键时，定义要调用的功能。
      ObjectProperty<EventHandler<? super KeyEvent>> Node.onKeyReleasedProperty​()
      定义当此 Node或其子项 Node具有输入焦点并且已释放密钥时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Scene.onKeyReleasedProperty​()
      定义要调用的函数，当一些 Node如此 Scene具有输入焦点和重点已经释放。
      ObjectProperty<EventHandler<? super KeyEvent>> Node.onKeyTypedProperty​()
      定义当此 Node或其子项 Node具有输入焦点并键入键时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Scene.onKeyTypedProperty​()
      定义要调用的函数，当一些 Node如此 Scene具有输入焦点和重点已经输入。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseClickedProperty​()
      定义当在此 Node上单击（按下并释放）鼠标按钮时调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseClickedProperty​()
      定义当这个 Scene上点击（按下并释放）鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragEnteredProperty​()
      定义当全按压拖动手势进入此 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragEnteredProperty​()
      定义当全按压拖动手势进入此 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragExitedProperty​()
      定义当完全按下 - 拖动释放手势离开这个 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragExitedProperty​()
      定义当完全按下 - 拖动释放手势退出此 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseDraggedProperty​()
      定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseDraggedProperty​()
      定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragOverProperty​()
      定义当这个 Node的全按压拖动手势进行时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragOverProperty​()
      定义当完全按下 - 拖动释放手势在该 Scene内进行时调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragReleasedProperty​()
      定义当完全按下 - 拖动释放手势结束（通过释放鼠标按钮）在此 Node内时 Node 。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragReleasedProperty​()
      定义当完全按下 - 拖动释放手势在此 Scene内结束时调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseEnteredProperty​()
      定义当鼠标进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseEnteredProperty​()
      定义当鼠标进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseExitedProperty​()
      定义当鼠标退出 Node时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseExitedProperty​()
      定义当鼠标退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseMovedProperty​()
      定义当这个 Node鼠标光标移动时调用的功能，但没有按钮被按下。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseMovedProperty​()
      定义当这个 Scene鼠标光标移动时调用的功能，但没有按钮被按下。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMousePressedProperty​()
      定义在 Node上按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMousePressedProperty​()
      定义当这个 Scene上按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseReleasedProperty​()
      定义当这个 Node上释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseReleasedProperty​()
      定义当这个 Scene释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Node.onRotateProperty​()
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> Scene.onRotateProperty​()
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> Node.onRotationFinishedProperty​()
      定义旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Scene.onRotationFinishedProperty​()
      定义当旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Node.onRotationStartedProperty​()
      定义检测到旋转手势时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Scene.onRotationStartedProperty​()
      定义检测到旋转手势时要调用的功能。
      ObjectProperty<EventHandler<? super ScrollEvent>> Node.onScrollFinishedProperty​()
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Scene.onScrollFinishedProperty​()
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Node.onScrollProperty​()
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Scene.onScrollProperty​()
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Node.onScrollStartedProperty​()
      定义检测到滚动手势时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Scene.onScrollStartedProperty​()
      定义检测到滚动手势时要调用的函数。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeDownProperty​()
      定义当在该节点上居中的向下滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeDownProperty​()
      定义当在此场景中发生向下滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeLeftProperty​()
      定义当以该节点为中心的向左滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeLeftProperty​()
      定义当在此场景中发生向左滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeRightProperty​()
      定义当以该节点为中心的向右滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeRightProperty​()
      定义当在此场景中发生向右滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeUpProperty​()
      定义当在该节点上居中的向上滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeUpProperty​()
      定义当在此场景中发生向上滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchMovedProperty​()
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchMovedProperty​()
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchPressedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchPressedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchReleasedProperty​()
      定义触发点释放时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchReleasedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchStationaryProperty​()
      定义当触摸点保持按下并静止时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchStationaryProperty​()
      定义当触摸点保持按下并静止时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Node.onZoomFinishedProperty​()
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Scene.onZoomFinishedProperty​()
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Node.onZoomProperty​()
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> Scene.onZoomProperty​()
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> Node.onZoomStartedProperty​()
      定义检测到缩放手势时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Scene.onZoomStartedProperty​()
      定义检测到缩放手势时要调用的功能。
      Methods in javafx.scene with parameters of type EventHandler
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Node.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      向此节点注册事件过滤器。
      <T extends Event>
      void             		Scene.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      注册一个事件过滤器到这个场景。
      <T extends Event>
      void             		Node.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      向此节点注册事件处理程序。
      <T extends Event>
      void             		Scene.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个场景。
      <T extends Event>
      void             		Node.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此节点注销先前注册的事件过滤器。
      <T extends Event>
      void             		Scene.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此场景注销先前注册的事件过滤器。
      <T extends Event>
      void             		Node.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此节点注销先前注册的事件处理程序。
      <T extends Event>
      void             		Scene.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此场景注销先前注册的事件处理程序。
      protected <T extends Event>
      void             		Node.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      protected <T extends Event>
      void             		Scene.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      void Node.setOnContextMenuRequested​(EventHandler<? super ContextMenuEvent> value)
      设置属性onContextMenuRequested的值。
      void Scene.setOnContextMenuRequested​(EventHandler<? super ContextMenuEvent> value)
      设置属性onContextMenuRequested的值。
      void Node.setOnDragDetected​(EventHandler<? super MouseEvent> value)
      设置属性onDragDetected的值。
      void Scene.setOnDragDetected​(EventHandler<? super MouseEvent> value)
      设置属性onDragDetected的值。
      void Node.setOnDragDone​(EventHandler<? super DragEvent> value)
      设置属性onDragDone的值。
      void Scene.setOnDragDone​(EventHandler<? super DragEvent> value)
      设置属性onDragDone的值。
      void Node.setOnDragDropped​(EventHandler<? super DragEvent> value)
      设置属性onDragDropped的值。
      void Scene.setOnDragDropped​(EventHandler<? super DragEvent> value)
      设置属性onDragDropped的值。
      void Node.setOnDragEntered​(EventHandler<? super DragEvent> value)
      设置属性onDragEntered的值。
      void Scene.setOnDragEntered​(EventHandler<? super DragEvent> value)
      设置属性onDragEntered的值。
      void Node.setOnDragExited​(EventHandler<? super DragEvent> value)
      设置属性onDragExited的值。
      void Scene.setOnDragExited​(EventHandler<? super DragEvent> value)
      设置属性onDragExited的值。
      void Node.setOnDragOver​(EventHandler<? super DragEvent> value)
      设置属性onDragOver的值。
      void Scene.setOnDragOver​(EventHandler<? super DragEvent> value)
      设置属性onDragOver的值。
      void Node.setOnInputMethodTextChanged​(EventHandler<? super InputMethodEvent> value)
      设置属性onInputMethodTextChanged的值。
      void Scene.setOnInputMethodTextChanged​(EventHandler<? super InputMethodEvent> value)
      设置属性onInputMethodTextChanged的值。
      void Node.setOnKeyPressed​(EventHandler<? super KeyEvent> value)
      设置属性onKeyPressed的值。
      void Scene.setOnKeyPressed​(EventHandler<? super KeyEvent> value)
      设置属性onKeyPressed的值。
      void Node.setOnKeyReleased​(EventHandler<? super KeyEvent> value)
      设置属性onKeyReleased的值。
      void Scene.setOnKeyReleased​(EventHandler<? super KeyEvent> value)
      设置属性onKeyReleased的值。
      void Node.setOnKeyTyped​(EventHandler<? super KeyEvent> value)
      设置属性onKeyTyped的值。
      void Scene.setOnKeyTyped​(EventHandler<? super KeyEvent> value)
      设置属性onKeyTyped的值。
      void Node.setOnMouseClicked​(EventHandler<? super MouseEvent> value)
      设置属性onMouseClicked的值。
      void Scene.setOnMouseClicked​(EventHandler<? super MouseEvent> value)
      设置属性onMouseClicked的值。
      void Node.setOnMouseDragEntered​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragEntered的值。
      void Scene.setOnMouseDragEntered​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragEntered的值。
      void Node.setOnMouseDragExited​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragExited的值。
      void Scene.setOnMouseDragExited​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragExited的值。
      void Node.setOnMouseDragged​(EventHandler<? super MouseEvent> value)
      设置属性onMouseDragged的值。
      void Scene.setOnMouseDragged​(EventHandler<? super MouseEvent> value)
      设置属性onMouseDragged的值。
      void Node.setOnMouseDragOver​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragOver的值。
      void Scene.setOnMouseDragOver​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragOver的值。
      void Node.setOnMouseDragReleased​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragReleased的值。
      void Scene.setOnMouseDragReleased​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragReleased的值。
      void Node.setOnMouseEntered​(EventHandler<? super MouseEvent> value)
      设置属性onMouseEntered的值。
      void Scene.setOnMouseEntered​(EventHandler<? super MouseEvent> value)
      设置属性onMouseEntered的值。
      void Node.setOnMouseExited​(EventHandler<? super MouseEvent> value)
      设置属性onMouseExited的值。
      void Scene.setOnMouseExited​(EventHandler<? super MouseEvent> value)
      设置属性onMouseExited的值。
      void Node.setOnMouseMoved​(EventHandler<? super MouseEvent> value)
      设置属性onMouseMoved的值。
      void Scene.setOnMouseMoved​(EventHandler<? super MouseEvent> value)
      设置属性onMouseMoved的值。
      void Node.setOnMousePressed​(EventHandler<? super MouseEvent> value)
      设置属性onMousePressed的值。
      void Scene.setOnMousePressed​(EventHandler<? super MouseEvent> value)
      设置属性onMousePressed的值。
      void Node.setOnMouseReleased​(EventHandler<? super MouseEvent> value)
      设置属性onMouseReleased的值。
      void Scene.setOnMouseReleased​(EventHandler<? super MouseEvent> value)
      设置属性onMouseReleased的值。
      void Node.setOnRotate​(EventHandler<? super RotateEvent> value)
      设置属性onRotate的值。
      void Scene.setOnRotate​(EventHandler<? super RotateEvent> value)
      设置属性onRotate的值。
      void Node.setOnRotationFinished​(EventHandler<? super RotateEvent> value)
      设置属性onRotationFinished的值。
      void Scene.setOnRotationFinished​(EventHandler<? super RotateEvent> value)
      设置属性onRotationFinished的值。
      void Node.setOnRotationStarted​(EventHandler<? super RotateEvent> value)
      设置属性onRotationStarted的值。
      void Scene.setOnRotationStarted​(EventHandler<? super RotateEvent> value)
      设置属性onRotationStarted的值。
      void Node.setOnScroll​(EventHandler<? super ScrollEvent> value)
      设置属性onScroll的值。
      void Scene.setOnScroll​(EventHandler<? super ScrollEvent> value)
      设置属性onScroll的值。
      void Node.setOnScrollFinished​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollFinished的值。
      void Scene.setOnScrollFinished​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollFinished的值。
      void Node.setOnScrollStarted​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollStarted的值。
      void Scene.setOnScrollStarted​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollStarted的值。
      void Node.setOnSwipeDown​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeDown的值。
      void Scene.setOnSwipeDown​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeDown的值。
      void Node.setOnSwipeLeft​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeLeft的值。
      void Scene.setOnSwipeLeft​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeLeft的值。
      void Node.setOnSwipeRight​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeRight的值。
      void Scene.setOnSwipeRight​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeRight的值。
      void Node.setOnSwipeUp​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeUp的值。
      void Scene.setOnSwipeUp​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeUp的值。
      void Node.setOnTouchMoved​(EventHandler<? super TouchEvent> value)
      设置属性onTouchMoved的值。
      void Scene.setOnTouchMoved​(EventHandler<? super TouchEvent> value)
      设置属性onTouchMoved的值。
      void Node.setOnTouchPressed​(EventHandler<? super TouchEvent> value)
      设置属性onTouchPressed的值。
      void Scene.setOnTouchPressed​(EventHandler<? super TouchEvent> value)
      设置属性onTouchPressed的值。
      void Node.setOnTouchReleased​(EventHandler<? super TouchEvent> value)
      设置属性onTouchReleased的值。
      void Scene.setOnTouchReleased​(EventHandler<? super TouchEvent> value)
      设置属性onTouchReleased的值。
      void Node.setOnTouchStationary​(EventHandler<? super TouchEvent> value)
      设置属性onTouchStationary的值。
      void Scene.setOnTouchStationary​(EventHandler<? super TouchEvent> value)
      设置属性onTouchStationary的值。
      void Node.setOnZoom​(EventHandler<? super ZoomEvent> value)
      设置Zoom上的属性值。
      void Scene.setOnZoom​(EventHandler<? super ZoomEvent> value)
      设置Zoom上的属性值。
      void Node.setOnZoomFinished​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomFinished的值。
      void Scene.setOnZoomFinished​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomFinished的值。
      void Node.setOnZoomStarted​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomStarted的值。
      void Scene.setOnZoomStarted​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomStarted的值。

    • Uses of EventHandler in javafx.scene.control

      Methods in javafx.scene.control that return EventHandler
      Modifier and Type 方法 描述
      EventHandler<ActionEvent> ButtonBase.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> ChoiceBox.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> ComboBoxBase.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> ContextMenu.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> MenuItem.getOnAction​()
      获取属性onAction的值。
      EventHandler<ActionEvent> TextField.getOnAction​()
      获取属性onAction的值。
      EventHandler<Event> Tab.getOnClosed​()
      当选项卡关闭时与选项卡关联的事件处理程序。
      EventHandler<DialogEvent> Dialog.getOnCloseRequest​()
      获取属性onCloseRequest的值。
      EventHandler<Event> Tab.getOnCloseRequest​()
      获取属性onCloseRequest的值。
      EventHandler<ListView.EditEvent<T>> ListView.getOnEditCancel​()
      返回当用户取消编辑时将被调用的EventHandler 。
      EventHandler<TableColumn.CellEditEvent<S,T>> TableColumn.getOnEditCancel​()
      获取属性onEditCancel的值。
      EventHandler<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.getOnEditCancel​()
      获取属性onEditCancel的值。
      EventHandler<TreeView.EditEvent<T>> TreeView.getOnEditCancel​()
      返回当用户取消编辑时将被调用的EventHandler 。
      EventHandler<ListView.EditEvent<T>> ListView.getOnEditCommit​()
      返回当用户提交编辑时将被调用的EventHandler 。
      EventHandler<TableColumn.CellEditEvent<S,T>> TableColumn.getOnEditCommit​()
      获取属性onEditCommit的值。
      EventHandler<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.getOnEditCommit​()
      获取属性onEditCommit的值。
      EventHandler<TreeView.EditEvent<T>> TreeView.getOnEditCommit​()
      返回当用户提交编辑时将被调用的EventHandler 。
      EventHandler<ListView.EditEvent<T>> ListView.getOnEditStart​()
      返回当用户开始编辑时将被调用的EventHandler 。
      EventHandler<TableColumn.CellEditEvent<S,T>> TableColumn.getOnEditStart​()
      获取onEditStart上的属性的值。
      EventHandler<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.getOnEditStart​()
      获取onEditStart上的属性的值。
      EventHandler<TreeView.EditEvent<T>> TreeView.getOnEditStart​()
      返回当用户开始编辑时将被调用的EventHandler 。
      EventHandler<Event> ChoiceBox.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<Event> ComboBoxBase.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<DialogEvent> Dialog.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<Event> Menu.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<Event> ChoiceBox.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<Event> ComboBoxBase.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<DialogEvent> Dialog.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<Event> Menu.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<Event> MenuItem.getOnMenuValidation​()
      获取属性onMenuValidation的值。
      EventHandler<ScrollToEvent<Integer>> ListView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<Integer>> TableView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<Integer>> TreeTableView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<Integer>> TreeView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<TableColumn<S,?>>> TableView.getOnScrollToColumn​()
      获取属性onScrollToColumn的值。
      EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> TreeTableView.getOnScrollToColumn​()
      获取属性onScrollToColumn的值。
      EventHandler<Event> Tab.getOnSelectionChanged​()
      与选项卡上的选择相关联的事件处理程序。
      EventHandler<Event> ChoiceBox.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<Event> ComboBoxBase.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<DialogEvent> Dialog.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<Event> Menu.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<Event> ChoiceBox.getOnShown​()
      获取onShown属性的值。
      EventHandler<Event> ComboBoxBase.getOnShown​()
      获取onShown属性的值。
      EventHandler<DialogEvent> Dialog.getOnShown​()
      获取onShown属性的值。
      EventHandler<Event> Menu.getOnShown​()
      获取onShown属性的值。
      EventHandler<SortEvent<TableView<S>>> TableView.getOnSort​()
      获取属性onSort的值。
      EventHandler<SortEvent<TreeTableView<S>>> TreeTableView.getOnSort​()
      获取属性onSort的值。
      Methods in javafx.scene.control that return types with arguments of type EventHandler
      Modifier and Type 方法 描述
      ObjectProperty<EventHandler<ActionEvent>> ButtonBase.onActionProperty​()
      按钮的动作，当按钮被触发时被调用。
      ObjectProperty<EventHandler<ActionEvent>> ChoiceBox.onActionProperty​()
      ChoiceBox操作，每当更改ChoiceBox value属性时调用。
      ObjectProperty<EventHandler<ActionEvent>> ComboBoxBase.onActionProperty​()
      ComboBox操作，当ComboBox value属性更改时调用。
      ObjectProperty<EventHandler<ActionEvent>> ContextMenu.onActionProperty​()
      当这个 ContextMenu包含的项目被激活时，回调功能被通知。
      ObjectProperty<EventHandler<ActionEvent>> MenuItem.onActionProperty​()
      每当MenuItem被触发时调用该动作。
      ObjectProperty<EventHandler<ActionEvent>> TextField.onActionProperty​()
      与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。
      ObjectProperty<EventHandler<Event>> Tab.onClosedProperty​()
      当选项卡关闭时与选项卡关联的事件处理程序。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onCloseRequestProperty​()
      当有外部请求关闭此 Dialog 。
      ObjectProperty<EventHandler<Event>> Tab.onCloseRequestProperty​()
      当有外部请求关闭此 Tab 。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> ListView.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> TableColumn.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> TreeTableColumn.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> TreeView.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> ListView.onEditCommitProperty​()
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> TableColumn.onEditCommitProperty​()
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> TreeTableColumn.onEditCommitProperty​()
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> TreeView.onEditCommitProperty​()
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> ListView.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> TableColumn.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> TreeTableColumn.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> TreeView.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onHiddenProperty​()
      在ChoiceBox弹出窗口之后刚刚被隐藏。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onHiddenProperty​()
      在ComboBoxBase弹出/显示已被隐藏之后调用。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onHiddenProperty​()
      Dialog已被隐藏之后调用。
      ObjectProperty<EventHandler<Event>> Menu.onHiddenProperty​()
      被称为ContextMenu之后被隐藏。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onHidingProperty​()
      在ChoiceBox弹出窗口之前被称为隐藏。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onHidingProperty​()
      在ComboBox弹出/显示被隐藏之前调用。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onHidingProperty​()
      在对话框被隐藏之前调用。
      ObjectProperty<EventHandler<Event>> Menu.onHidingProperty​()
      被称为在ContextMenu之前被隐藏。
      ObjectProperty<EventHandler<Event>> MenuItem.onMenuValidationProperty​()
      与调用MenuItem的加速器相关联的事件处理程序。
      ObjectProperty<EventHandler<ScrollToEvent<TableColumn<S,?>>>> TableView.onScrollToColumnProperty​()
      当有请求使用 TableView.scrollToColumn(TableColumn)或 TableView.scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<TreeTableColumn<S,?>>>> TreeTableView.onScrollToColumnProperty​()
      当有请求使用 TreeTableView.scrollToColumn(TreeTableColumn)或 TreeTableView.scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> ListView.onScrollToProperty​()
      当有请求使用 ListView.scrollTo(int)或 ListView.scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TableView.onScrollToProperty​()
      当有请求使用 TableView.scrollTo(int)或 TableView.scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TreeTableView.onScrollToProperty​()
      当有请求使用 TreeTableView.scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TreeView.onScrollToProperty​()
      当有请求使用 TreeView.scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<Event>> Tab.onSelectionChangedProperty​()
      与选项卡上的选择相关联的事件处理程序。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onShowingProperty​()
      在 ChoiceBox弹出窗口之前调用。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onShowingProperty​()
      在刚刚显示的 ComboBoxBase弹出/显示之前调用。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onShowingProperty​()
      在对话框显示之前调用。
      ObjectProperty<EventHandler<Event>> Menu.onShowingProperty​()
      在 ContextMenu被显示之前，即使菜单没有显示项目。
      ObjectProperty<EventHandler<Event>> ChoiceBox.onShownProperty​()
      在ChoiceBox弹出窗口之后调用。
      ObjectProperty<EventHandler<Event>> ComboBoxBase.onShownProperty​()
      在显示ComboBoxBase弹出/显示之后调用。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onShownProperty​()
      在对话框显示之后调用。
      ObjectProperty<EventHandler<Event>> Menu.onShownProperty​()
      在紧接ContextMenu后显示。
      ObjectProperty<EventHandler<SortEvent<TableView<S>>>> TableView.onSortProperty​()
      当有请求排序控件时调用。
      ObjectProperty<EventHandler<SortEvent<TreeTableView<S>>>> TreeTableView.onSortProperty​()
      当有请求排序控件时调用。
      Methods in javafx.scene.control with parameters of type EventHandler
      Modifier and Type 方法 描述
      <E extends Event>
      void             		Menu.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此MenuItem中注册一个事件处理程序。
      <E extends Event>
      void             		MenuItem.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此MenuItem中注册一个事件处理程序。
      <E extends Event>
      void             		TableColumnBase.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此表列中注册一个事件处理程序。
      <E extends Event>
      void             		TreeItem.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      将一个事件处理程序注册到此TreeItem。
      <E extends Event>
      void             		Menu.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此MenuItem中注销先前注册的事件处理程序。
      <E extends Event>
      void             		MenuItem.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此MenuItem中注销先前注册的事件处理程序。
      <E extends Event>
      void             		TableColumnBase.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此表列中注销先前注册的事件处理程序。
      <E extends Event>
      void             		TreeItem.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此TreeItem中注销先前注册的事件处理程序。
      void ButtonBase.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void ChoiceBox.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void ComboBoxBase.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void ContextMenu.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void MenuItem.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void TextField.setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void Tab.setOnClosed​(EventHandler<Event> value)
      定义标签关闭时要调用的函数。
      void Dialog.setOnCloseRequest​(EventHandler<DialogEvent> value)
      设置属性onCloseRequest的值。
      void Tab.setOnCloseRequest​(EventHandler<Event> value)
      设置属性onCloseRequest的值。
      void ListView.setOnEditCancel​(EventHandler<ListView.EditEvent<T>> value)
      设置当用户取消编辑时将被调用的EventHandler 。
      void TableColumn.setOnEditCancel​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCancel的值。
      void TreeTableColumn.setOnEditCancel​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCancel的值。
      void TreeView.setOnEditCancel​(EventHandler<TreeView.EditEvent<T>> value)
      设置当用户取消编辑时将被调用的EventHandler 。
      void ListView.setOnEditCommit​(EventHandler<ListView.EditEvent<T>> value)
      设置当用户完成编辑时将被调用的EventHandler 。
      void TableColumn.setOnEditCommit​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCommit的值。
      void TreeTableColumn.setOnEditCommit​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCommit的值。
      void TreeView.setOnEditCommit​(EventHandler<TreeView.EditEvent<T>> value)
      设置当用户提交编辑时将被调用的EventHandler 。
      void ListView.setOnEditStart​(EventHandler<ListView.EditEvent<T>> value)
      设置当用户开始编辑时将被调用的EventHandler 。
      void TableColumn.setOnEditStart​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
      设置属性onEditStart的值。
      void TreeTableColumn.setOnEditStart​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
      设置属性onEditStart的值。
      void TreeView.setOnEditStart​(EventHandler<TreeView.EditEvent<T>> value)
      设置当用户开始编辑时将被调用的EventHandler 。
      void ChoiceBox.setOnHidden​(EventHandler<Event> value)
      设置属性onHidden的值。
      void ComboBoxBase.setOnHidden​(EventHandler<Event> value)
      设置属性onHidden的值。
      void Dialog.setOnHidden​(EventHandler<DialogEvent> value)
      设置属性onHidden的值。
      void Menu.setOnHidden​(EventHandler<Event> value)
      设置属性onHidden的值。
      void ChoiceBox.setOnHiding​(EventHandler<Event> value)
      设置属性onHiding的值。
      void ComboBoxBase.setOnHiding​(EventHandler<Event> value)
      设置属性onHiding的值。
      void Dialog.setOnHiding​(EventHandler<DialogEvent> value)
      设置属性onHiding的值。
      void Menu.setOnHiding​(EventHandler<Event> value)
      设置属性onHiding的值。
      void MenuItem.setOnMenuValidation​(EventHandler<Event> value)
      设置属性onMenuValidation的值。
      void ListView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TableView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TreeTableView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TreeView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TableView.setOnScrollToColumn​(EventHandler<ScrollToEvent<TableColumn<S,?>>> value)
      设置属性onScrollToColumn的值。
      void TreeTableView.setOnScrollToColumn​(EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> value)
      设置属性onScrollToColumn的值。
      void Tab.setOnSelectionChanged​(EventHandler<Event> value)
      定义在选项卡上发生选择更改时要调用的函数。
      void ChoiceBox.setOnShowing​(EventHandler<Event> value)
      设置属性onShowing的值。
      void ComboBoxBase.setOnShowing​(EventHandler<Event> value)
      设置属性onShowing的值。
      void Dialog.setOnShowing​(EventHandler<DialogEvent> value)
      设置属性onShowing的值。
      void Menu.setOnShowing​(EventHandler<Event> value)
      设置属性onShowing的值。
      void ChoiceBox.setOnShown​(EventHandler<Event> value)
      设置属性onShown的值。
      void ComboBoxBase.setOnShown​(EventHandler<Event> value)
      设置属性onShown的值。
      void Dialog.setOnShown​(EventHandler<DialogEvent> value)
      设置属性onShown的值。
      void Menu.setOnShown​(EventHandler<Event> value)
      设置属性onShown的值。
      void TableView.setOnSort​(EventHandler<SortEvent<TableView<S>>> value)
      设置属性onSort的值。
      void TreeTableView.setOnSort​(EventHandler<SortEvent<TreeTableView<S>>> value)
      设置属性onSort的值。

    • Uses of EventHandler in javafx.scene.media

      Methods in javafx.scene.media that return EventHandler
      Modifier and Type 方法 描述
      EventHandler<MediaErrorEvent> MediaView.getOnError​()
      检索错误事件处理程序。
      EventHandler<MediaMarkerEvent> MediaPlayer.getOnMarker​()
      检索标记事件处理程序。
      Methods in javafx.scene.media that return types with arguments of type EventHandler
      Modifier and Type 方法 描述
      ObjectProperty<EventHandler<MediaErrorEvent>> MediaView.onErrorProperty​()
      当这个 MediaView发生错误时调用事件处理程序。
      ObjectProperty<EventHandler<MediaMarkerEvent>> MediaPlayer.onMarkerProperty​()
      当播放器 currentTime到达媒体标记时调用事件处理程序。
      Methods in javafx.scene.media with parameters of type EventHandler
      Modifier and Type 方法 描述
      void MediaView.setOnError​(EventHandler<MediaErrorEvent> value)
      设置错误事件处理程序。
      void MediaPlayer.setOnMarker​(EventHandler<MediaMarkerEvent> onMarker)
      设置标记事件处理程序。

    • Uses of EventHandler in javafx.scene.transform

      Methods in javafx.scene.transform that return EventHandler
      Modifier and Type 方法 描述
      EventHandler<? super TransformChangedEvent> Transform.getOnTransformChanged​()
      获取onTransformChanged事件处理程序。
      Methods in javafx.scene.transform that return types with arguments of type EventHandler
      Modifier and Type 方法 描述
      ObjectProperty<EventHandler<? super TransformChangedEvent>> Transform.onTransformChangedProperty​()
      只要变换改变其任何参数，就调用onTransformChanged事件处理程序。
      Methods in javafx.scene.transform with parameters of type EventHandler
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Transform.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      为此转换注册事件过滤器。
      <T extends Event>
      void             		Transform.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个变换。
      <T extends Event>
      void             		Transform.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此转换中注销先前注册的事件过滤器。
      <T extends Event>
      void             		Transform.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此转换中注销先前注册的事件处理程序。
      void Transform.setOnTransformChanged​(EventHandler<? super TransformChangedEvent> value)
      设置onTransformChanged事件处理程序，当变换改变其任何参数时，调用它。

    • Uses of EventHandler in javafx.scene.web

      Methods in javafx.scene.web that return EventHandler
      Modifier and Type 方法 描述
      EventHandler<WebEvent<String>> WebEngine.getOnAlert​()
      获取属性onAlert的值。
      EventHandler<WebErrorEvent> WebEngine.getOnError​()
      获取属性onError的值。
      EventHandler<WebEvent<Rectangle2D>> WebEngine.getOnResized​()
      获取属性onResized的值。
      EventHandler<WebEvent<String>> WebEngine.getOnStatusChanged​()
      获取属性onStatusChanged的值。
      EventHandler<WebEvent<Boolean>> WebEngine.getOnVisibilityChanged​()
      获取属性onVisibilityChanged的值。
      Methods in javafx.scene.web that return types with arguments of type EventHandler
      Modifier and Type 方法 描述
      ObjectProperty<EventHandler<WebEvent<String>>> WebEngine.onAlertProperty​()
      JavaScript alert处理程序属性。
      ObjectProperty<EventHandler<WebErrorEvent>> WebEngine.onErrorProperty​()
      当发生错误时调用事件处理程序。
      ObjectProperty<EventHandler<WebEvent<Rectangle2D>>> WebEngine.onResizedProperty​()
      JavaScript窗口调整大小处理程序属性。
      ObjectProperty<EventHandler<WebEvent<String>>> WebEngine.onStatusChangedProperty​()
      JavaScript状态处理程序属性。
      ObjectProperty<EventHandler<WebEvent<Boolean>>> WebEngine.onVisibilityChangedProperty​()
      JavaScript窗口可见性处理器属性。
      Methods in javafx.scene.web with parameters of type EventHandler
      Modifier and Type 方法 描述
      void WebEngine.setOnAlert​(EventHandler<WebEvent<String>> handler)
      设置属性onAlert的值。
      void WebEngine.setOnError​(EventHandler<WebErrorEvent> handler)
      设置属性onError的值。
      void WebEngine.setOnResized​(EventHandler<WebEvent<Rectangle2D>> handler)
      设置属性onResized的值。
      void WebEngine.setOnStatusChanged​(EventHandler<WebEvent<String>> handler)
      设置属性onStatusChanged的值。
      void WebEngine.setOnVisibilityChanged​(EventHandler<WebEvent<Boolean>> handler)
      设置属性onVisibilityChanged的值。

    • Uses of EventHandler in javafx.stage

      Methods in javafx.stage that return EventHandler
      Modifier and Type 方法 描述
      EventHandler<Event> PopupWindow.getOnAutoHide​()
      获取属性onAutoHide的值。
      EventHandler<WindowEvent> Window.getOnCloseRequest​()
      获取属性onCloseRequest的值。
      EventHandler<WindowEvent> Window.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<WindowEvent> Window.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<WindowEvent> Window.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<WindowEvent> Window.getOnShown​()
      获取onShown属性的值。
      Methods in javafx.stage that return types with arguments of type EventHandler
      Modifier and Type 方法 描述
      ObjectProperty<EventHandler<Event>> PopupWindow.onAutoHideProperty​()
      autoHide运行后调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onCloseRequestProperty​()
      当有外部请求关闭此 Window 。
      ObjectProperty<EventHandler<WindowEvent>> Window.onHiddenProperty​()
      在窗口被隐藏之后调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onHidingProperty​()
      在Window被隐藏之前调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onShowingProperty​()
      在窗口显示之前调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onShownProperty​()
      在窗口显示之后调用。
      Methods in javafx.stage with parameters of type EventHandler
      Modifier and Type 方法 描述
      <T extends Event>
      void             		Window.addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      向此节点注册事件过滤器。
      <T extends Event>
      void             		Window.addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      向此节点注册事件处理程序。
      <T extends Event>
      void             		Window.removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此节点注销先前注册的事件过滤器。
      <T extends Event>
      void             		Window.removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此节点注销先前注册的事件处理程序。
      protected <T extends Event>
      void             		Window.setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      void PopupWindow.setOnAutoHide​(EventHandler<Event> value)
      设置属性onAtotoHide的值。
      void Window.setOnCloseRequest​(EventHandler<WindowEvent> value)
      设置属性onCloseRequest的值。
      void Window.setOnHidden​(EventHandler<WindowEvent> value)
      设置属性onHidden的值。
      void Window.setOnHiding​(EventHandler<WindowEvent> value)
      设置属性onHiding的值。
      void Window.setOnShowing​(EventHandler<WindowEvent> value)
      设置属性onShowing的值。
      void Window.setOnShown​(EventHandler<WindowEvent> value)
      Sets the value of the property onShown.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.event.EventTarget (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.event.EventTarget

  • Packages that use EventTarget
    软件包 描述
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of EventTarget in javafx.concurrent

      Classes in javafx.concurrent that implement EventTarget
      Modifier and Type Class 描述
      class  ScheduledService<V>
      ScheduledService是一个Service ，它将在成功执行后自动重新启动，并且在某些情况下即使发生故障也将重新启动。
      class  Service<V>
      服务是一个非可视化组件，封装了在一个或多个后台线程上执行某些工作所需的信息。
      class  Task<V>
      一个完全可观察到的一个FutureTask的实现。

    • Uses of EventTarget in javafx.embed.swing

      Classes in javafx.embed.swing that implement EventTarget
      Modifier and Type Class 描述
      class  SwingNode
      此类用于将Swing内容嵌入到JavaFX应用程序中。

    • Uses of EventTarget in javafx.event

      Fields in javafx.event declared as EventTarget
      Modifier and Type Field 描述
      static EventTarget Event.NULL_SOURCE_TARGET
      表示未知事件源/目标的常数。
      protected EventTarget Event.target
      事件目标定义事件在发布时将通过的路径。
      Methods in javafx.event that return EventTarget
      Modifier and Type 方法 描述
      EventTarget Event.getTarget​()
      返回此事件的事件目标。
      Methods in javafx.event with parameters of type EventTarget
      Modifier and Type | 方法 | 描述
      ActionEvent | ActionEvent.copyFor​(Object newSource, EventTarget newTarget)
      Event Event.copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      static void Event.fireEvent​(EventTarget eventTarget, Event event)
      触发指定的事件。
      Constructors in javafx.event with parameters of type EventTarget
      Constructor 描述
      ActionEvent​(Object source, EventTarget target)
      构造一个新的 ActionEvent与指定的事件源和目标。
      Event​(Object source, EventTarget target, EventType<? extends Event> eventType)
      使用指定的事件源，目标和类型构造新的 Event 。

    • Uses of EventTarget in javafx.scene

      Classes in javafx.scene that implement EventTarget
      Modifier and Type Class 描述
      class  AmbientLight
      定义环境光源对象。
      class  Camera
      用于渲染场景的相机的基类。
      class  Group
      一个 Group节点包含一个可观察的子节点列表，每当呈现该节点时，该节点被依次呈现。
      class  LightBase
      LightBase类提供了表示光源形式的对象的常用属性的定义。
      class  Node
      场景图节点的基类。
      class  ParallelCamera
      指定用于渲染场景而不进行透视校正的并行相机。
      class  Parent
      在场景图中有子节点的所有节点的基类。
      class  PerspectiveCamera
      指定用于渲染场景的透视相机。
      class  PointLight
      定义点光源对象。
      class  Scene
      JavaFX Scene类是场景图中所有内容的容器。
      class  SubScene
      SubScene类是场景图中内容的容器。

    • Uses of EventTarget in javafx.scene.canvas

      Classes in javafx.scene.canvas that implement EventTarget
      Modifier and Type Class 描述
      class  Canvas
      Canvas是可以使用由GraphicsContext提供的一组图形命令绘制的图像。

    • Uses of EventTarget in javafx.scene.chart

      Classes in javafx.scene.chart that implement EventTarget
      Modifier and Type Class 描述
      class  AreaChart<X,Y>
      AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
      class  Axis<T>
      JavaFX中所有轴的基类，表示在图表区域上绘制的轴。
      class  BarChart<X,Y>
      绘制一个指示类别数据值的条形图。
      class  BubbleChart<X,Y>
      为一系列数据点绘制气泡的图表类型。
      class  CategoryAxis
      一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。
      class  Chart
      所有图表的基础类。
      class  LineChart<X,Y>
      线图绘制了连接数据点的行。
      class  NumberAxis
      一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
      class  PieChart
      显示PieChart。
      class  ScatterChart<X,Y>
      绘制一系列数据点符号的图表类型。
      class  StackedAreaChart<X,Y>
      StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。
      class  StackedBarChart<X,Y>
      StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。
      class  ValueAxis<T extends Number>
      数据定义为数字的轴。
      class  XYChart<X,Y>
      所有2轴图的图表基类。

    • Uses of EventTarget in javafx.scene.control

      Classes in javafx.scene.control that implement EventTarget
      Modifier and Type Class 描述
      class  Accordion
      手风琴是一组TitlePanes 。
      class  Alert
      Alert类对Dialog类进行子类化，并提供对许多预构建的对话框类型的支持，可以轻松向用户显示提示响应。
      class  Button
      一个简单的按钮控件。
      class  ButtonBar
      ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。
      class  ButtonBase
      按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
      class  Cell<T>
      细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
      class  CheckBox
      三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
      class  CheckBoxTreeItem<T>
      TreeItem子类增加了在选定的，未选择的和不确定的状态中的支持。
      class  CheckMenuItem
      A MenuItem可以在选定状态和未选择状态之间切换。
      class  ChoiceBox<T>
      ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
      class  ChoiceDialog<T>
      一个对话框，向用户显示选择列表，最多可以从中选择一个项目。
      class  ColorPicker
      ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
      class  ComboBox<T>
      针对ComboBox最常见形式的ComboBoxBase抽象类的实现，其中向用户提供弹出列表以提供他们可以选择的选项。
      class  ComboBoxBase<T>
      ComboBox类控件的抽象基类。
      class  ContextMenu
      一个包含菜单项的ObservableList的弹出控件。
      class  Control
      所有用户界面控件的基类。
      class  CustomMenuItem
      A MenuItem允许通过为content属性分配Node来嵌入任意节点。
      class  DateCell
      DateCell由DatePicker用于在日历月中呈现单个网格单元格。
      class  DatePicker
      DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
      class  Dialog<R>
      JavaFX中的Dialog包装了一个DialogPane，并提供了必要的API来将其呈现给最终用户。
      class  DialogPane
      DialogPane应该被认为是在一个Dialog实例中显示的根节点 。
      class  Hyperlink
      一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
      class  IndexedCell<T>
      一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。
      class  Label
      标签是不可编辑的文本控件。
      class  Labeled
      标签Control是与其用户界面的一部分相关联的文本内容。
      class  ListCell<T>
      Cell类型在ListView中使用。
      class  ListView<T>
      ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
      class  Menu
      可触发的项目的弹出菜单，仅根据请求向用户显示。
      class  MenuBar
      MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。
      class  MenuButton
      MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
      class  MenuItem
      MenuItem旨在与Menu结合使用，为用户提供选项。
      class  Pagination
      分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
      class  PasswordField
      掩码输入字符的文本字段。
      class  PopupControl
      PopupWindow的扩展，允许CSS样式。
      protected class  PopupControl.CSSBridge
      弹出窗口和场景图之间的链接。
      class  ProgressBar
      ProgressIndator的专业化表示为横杠。
      class  ProgressIndicator
      用于指示进度的循环控制，无限（也称为不确定）或有限。
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  RadioMenuItem
      RadioMenuItem是一个MenuItem可以切换（它使用Toggle mixin）。
      class  ScrollBar
      具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。
      class  ScrollPane
      提供其内容的滚动，剪切视口的控件。
      class  Separator
      水平或垂直分隔线。
      class  SeparatorMenuItem
      A MenuItem ，如名称所示，允许将水平分隔符嵌入其中，通过为CustomMenuItem分配content属性提供Separator。为方便起见， menuitems可以由分隔符分隔。
      class  Slider
      滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。
      class  Spinner<T>
      单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。
      class  SplitMenuButton
      SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。
      class  SplitPane
      具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
      class  Tab
      标签放置在TabPane中 ，其中每个标签代表单个“页面”。
      class  TableCell<S,T>
      表示TableView中的单行 /列交集。
      class  TableColumn<S,T>
      A TableView由多个TableColumn实例组成。
      class  TableColumnBase<S,T>
      表类控件（例如TableView和TreeTableView ）由零个或多个具体TableColumnBase子类的实例组成（分别为TableColumn和TreeTableColumn ）。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TableView<S>
      TableView控件旨在可视化无限数量的数据行，分为列。
      class  TabPane
      允许在一组Tabs之间切换的控件 。
      class  TextArea
      文本输入组件，允许用户输入多行纯文本。
      class  TextField
      文本输入组件，允许用户输入一行未格式化的文本。
      class  TextInputControl
      文本输入控件的抽象基类。
      class  TextInputDialog
      显示给用户的文本输入控件的对话框。
      class  TitledPane
      TitledPane是一个可以打开和关闭的标题的面板。
      class  ToggleButton
      A ToggleButton是一种具有选择能力的专业控制。
      class  ToolBar
      ToolBar是一个可以水平或垂直显示项目的控件。
      class  Tooltip
      工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeItem<T>
      单个节点的模型为诸如TreeView之类的控件提供值的层次结构。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableColumn<S,T>
      A TreeTableView由多个TreeTableColumn实例组成。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
      class  TreeTableView<S>
      TreeTableView控件旨在可视化无限数量的数据行，分为列。
      class  TreeView<T>
      TreeView控件提供了一个树根视图（ TreeItem型）。
      Methods in javafx.scene.control with parameters of type EventTarget
      Modifier and Type | 方法 | 描述
      DialogEvent | DialogEvent.copyFor​(Object newSource, EventTarget newTarget)
      DialogEvent DialogEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<DialogEvent> type)
      用给定的字段替换给定事件的副本。
      Constructors in javafx.scene.control with parameters of type EventTarget
      Constructor 描述
      ScrollToEvent​(Object source, EventTarget target, EventType<ScrollToEvent<T>> type, T scrollTarget)
      构造一个新的 Event与指定的事件源，目标和类型。
      SortEvent​(C source, EventTarget target)

    • Uses of EventTarget in javafx.scene.control.cell

      Classes in javafx.scene.control.cell that implement EventTarget
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含ListCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个包含一个TreeCell实现的类，在单元内绘制一个CheckBox节点，同时支持常见的交互（ 稍后更详细地讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，可以在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，它在单元格中绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含ListCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeCell<T>
      一个包含TreeCell实现的类，它在单元格中绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含TableCell实现的类，该单元在单元格内绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含TreeTableCell实现的类，它在单元格内绘制一个ProgressBar节点。
      class  TextFieldListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格中绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格中绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格中绘制一个TextField节点。

    • Uses of EventTarget in javafx.scene.control.skin

      Classes in javafx.scene.control.skin that implement EventTarget
      Modifier and Type Class 描述
      class  NestedTableColumnHeader
      此类用于构造TableView的头。
      class  TableColumnHeader
      负责绘制单列标题的区域。
      class  TableHeaderRow
      负责绘制整列列标题的区域。
      class  VirtualFlow<T extends IndexedCell>
      使用基于单元的机制实现虚拟化容器。

    • Uses of EventTarget in javafx.scene.image

      Classes in javafx.scene.image that implement EventTarget
      Modifier and Type Class 描述
      class  ImageView
      ImageView是一个Node用于绘制图像加载Image类。

    • Uses of EventTarget in javafx.scene.input

      Methods in javafx.scene.input that return EventTarget
      Modifier and Type 方法 描述
      EventTarget TouchPoint.getGrabbed​()
      获得抓住这个接触点的事件目标。
      EventTarget TouchPoint.getTarget​()
      获取触发此触摸点触发事件的事件目标。
      Methods in javafx.scene.input with parameters of type EventTarget
      Modifier and Type | 方法 | 描述
      boolean TouchPoint.belongsTo​(EventTarget target)
      区分目标在给定节点或其某些孩子的触摸点之间的接触点，指向其他地方。
      ContextMenuEvent | ContextMenuEvent.copyFor​(Object newSource, EventTarget newTarget)
      DragEvent | DragEvent.copyFor​(Object newSource, EventTarget newTarget)
      DragEvent DragEvent.copyFor​(Object source, EventTarget target, Object gestureSource, Object gestureTarget, EventType<DragEvent> eventType)
      创建给定字段替换的给定拖动事件的副本。
      DragEvent DragEvent.copyFor​(Object source, EventTarget target, EventType<DragEvent> type)
      创建给定字段替换的给定拖动事件的副本。
      GestureEvent GestureEvent.copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      InputMethodEvent | InputMethodEvent.copyFor​(Object newSource, EventTarget newTarget)
      KeyEvent | KeyEvent.copyFor​(Object newSource, EventTarget newTarget)
      KeyEvent KeyEvent.copyFor​(Object source, EventTarget target, EventType<KeyEvent> type)
      用给定的字段替换给定事件的副本。
      MouseDragEvent | MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget)
      MouseDragEvent | MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> type)
      MouseEvent MouseEvent.copyFor​(Object newSource, EventTarget newTarget)
      将此事件复制到不同的来源和目标。
      MouseEvent MouseEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> eventType)
      用给定的字段替换给定事件的副本。
      RotateEvent | RotateEvent.copyFor​(Object newSource, EventTarget newTarget)
      RotateEvent RotateEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<RotateEvent> type)
      用给定的字段替换给定事件的副本。
      ScrollEvent | ScrollEvent.copyFor​(Object newSource, EventTarget newTarget)
      ScrollEvent ScrollEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ScrollEvent> type)
      用给定的字段替换给定事件的副本。
      SwipeEvent | SwipeEvent.copyFor​(Object newSource, EventTarget newTarget)
      SwipeEvent SwipeEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<SwipeEvent> type)
      用给定的字段替换给定事件的副本。
      TouchEvent TouchEvent.copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      TouchEvent TouchEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<TouchEvent> type)
      用给定的字段替换给定事件的副本。
      ZoomEvent | ZoomEvent.copyFor​(Object newSource, EventTarget newTarget)
      ZoomEvent ZoomEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ZoomEvent> type)
      用给定的字段替换给定事件的副本。
      static MouseDragEvent MouseEvent.copyForMouseDragEvent​(MouseEvent e, Object source, EventTarget target, EventType<MouseDragEvent> type, Object gestureSource, PickResult pickResult)
      创建MouseDragEvent类型的鼠标事件的副本
      void TouchPoint.grab​(EventTarget target)
      按照给定的目标抓住这个接触点。
      Constructors in javafx.scene.input with parameters of type EventTarget
      Constructor 描述
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType)
      已过时。
      不要使用这个构造函数。 构造空事件。
      GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)
      构建新的GestureEvent事件。
      InputEvent​(Object source, EventTarget target, EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      PickResult​(EventTarget target, double sceneX, double sceneY)
      为不需要额外信息的2D情况创建选择结果。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。

    • Uses of EventTarget in javafx.scene.layout

      Classes in javafx.scene.layout that implement EventTarget
      Modifier and Type Class 描述
      class  AnchorPane
      AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。
      class  BorderPane
      BorderPane在上，左，右，底部和中间位置摆放孩子。
      class  FlowPane
      FlowPane将其孩子摆放在流过玻璃边界的流中。
      class  GridPane
      GridPane将其孩子放在一个灵活的行和列格网中。
      class  HBox
      HBox将孩子放在一排水平排列中。
      class  Pane
      布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
      class  Region
      Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
      class  StackPane
      StackPane将它的孩子放在一个靠前的堆叠中。
      class  TilePane
      TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。
      class  VBox
      VBox把孩子放在一个垂直的立柱上。

    • Uses of EventTarget in javafx.scene.media

      Classes in javafx.scene.media that implement EventTarget
      Modifier and Type Class 描述
      class  MediaView
      甲Node提供的视图Media由正在播放MediaPlayer 。
      Methods in javafx.scene.media with parameters of type EventTarget
      Modifier and Type | 方法 | 描述
      MediaErrorEvent | MediaErrorEvent.copyFor​(Object newSource, EventTarget newTarget)

    • Uses of EventTarget in javafx.scene.shape

      Classes in javafx.scene.shape that implement EventTarget
      Modifier and Type Class 描述
      class  Arc
      所述 Arc类表示2D弧对象，由中心点限定的，起始角度（度），角度范围（以度数表示的弧的长度），和一弧型（ ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND ）。
      class  Box
      Box类定义了具有指定大小的3维框。
      class  Circle
      Circle类创建一个新圆圈，其中指定的半径和中心位置以像素为单位。
      class  CubicCurve
      CubiCurve类定义了（x，y）坐标空间中的三次Bézier参数曲线段。
      class  Cylinder
      Cylinder类定义了具有指定大小的3维圆柱体。
      class  Ellipse
      Ellipse类创建一个新的椭圆，具有指定的大小和位置（以像素为单位）
      class  Line
      此行代表 (x,y)坐标空间中的一个线段。
      class  MeshView
      MeshView类定义了具有指定3D网格数据的曲面。
      class  Path
      Path类代表了一个简单的形状，提供了几何路径的基本构造和管理所需的设施。
      class  Polygon
      创建由x，y坐标数组定义的多边形。
      class  Polyline
      创建折线，由分段点数组定义。
      class  QuadCurve
      Quadcurve类定义了（x，y）坐标空间中的二次Bézier参数曲线段。
      class  Rectangle
      Rectangle类定义了一个具有指定大小和位置的矩形。
      class  Shape
      Shape类为表示某种形式的几何形状的对象提供了常见属性的定义。
      class  Shape3D
      Shape3D基类为代表某种形式的3D几何形状的对象提供了常用属性的定义。
      class  Sphere
      Sphere类定义了具有指定大小的三维球体。
      class  SVGPath
      SVGPath类表示通过从String解析SVG路径数据构建的简单形状。

    • Uses of EventTarget in javafx.scene.text

      Classes in javafx.scene.text that implement EventTarget
      Modifier and Type Class 描述
      class  Text
      Text类定义了一个显示文本的节点。
      class  TextFlow
      TextFlow是设计用于布置富文本的特殊布局。

    • Uses of EventTarget in javafx.scene.transform

      Classes in javafx.scene.transform that implement EventTarget
      Modifier and Type Class 描述
      class  Affine
      Affine类代表一般的仿射变换。
      class  Rotate
      该类表示一个 Affine对象，它绕坐标点旋转坐标。
      class  Scale
      此类表示一个 Affine对象，可根据指定的因素缩放坐标。
      class  Shear
      该类代表一个 Affine对象，它通过指定的乘数来剪切坐标。
      class  Transform
      这个类是不同仿射变换的基类。
      class  Translate
      该类表示一个 Affine对象，它根据指定的因素转换坐标。
      Constructors in javafx.scene.transform with parameters of type EventTarget
      Constructor 描述
      TransformChangedEvent​(Object source, EventTarget target)
      构造一个新的 TransformChangedEvent与指定的事件源和目标。

    • Uses of EventTarget in javafx.scene.web

      Classes in javafx.scene.web that implement EventTarget
      Modifier and Type Class 描述
      class  HTMLEditor
      允许用户编辑文本并将样式应用于此文本的控件。
      class  WebView
      WebView是一个Node ，管理一个WebEngine并显示其内容。

    • Uses of EventTarget in javafx.stage

      Classes in javafx.stage that implement EventTarget
      Modifier and Type Class 描述
      class  Popup
      弹出窗口是用于场景图形的特殊的类似窗口的容器。
      class  PopupWindow
      PopupWindow是各种不同类型的基于弹出窗口的窗口的父级，包括Popup和Tooltip和ContextMenu 。
      class  Stage
      JavaFX Stage类是顶级的JavaFX容器。
      class  Window
      托管场景的顶层窗口，用户与之交互的顶级窗口。
      Methods in javafx.stage with parameters of type EventTarget
      Modifier and Type | 方法 | 描述
      WindowEvent | WindowEvent.copyFor​(Object newSource, EventTarget newTarget)
      WindowEvent WindowEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<WindowEvent> type)
      用给定的字段替换给定事件的副本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


FXML (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module javafx.fxml
软件包 javafx.fxml

Annotation Type FXML

  • @Retention(RUNTIME)
@Target({字段,METHOD})
public @interface FXML
    将字段或方法标记为可用于标记的注释。

    将应用程序部署为模块

    如果被注释的对象在一个命名的模块中，则它必须反映可访问javafx.fxml模块。 否则，当尝试修改注释元素时， FXMLLoader将失败，并显示InaccessibleObjectException 。 如果包含该对象的模块的目的是反射性访问opens含包到至少javafx.fxml模块。

    例如，如果要注释的对象在foo.app模块中的com.foo软件包中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.fxml; }

    可替代地，一个目的是，如果它被声明为公用部件反射性访问，是在一个公共类，以及包含该类模块exports含包无条件。

    从以下版本开始：
    JavaFX 2.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


FXMLLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.fxml
软件包 javafx.fxml

Class FXMLLoader

  • java.lang.Object
    • javafx.fxml.FXMLLoader

  • public class FXMLLoader
extends Object
    从XML文档加载对象层次结构。 有关详细信息，请参阅Introduction to FXML文档。
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String ARRAY_COMPONENT_DELIMITER
      数组的分隔符作为值。
      static String BI_DIRECTIONAL_BINDING_PREFIX
      前缀用于双向绑定表达式解析。
      static String BI_DIRECTIONAL_BINDING_SUFFIX
      双向绑定表达式解析的后缀。
      static String BINDING_EXPRESSION_PREFIX
      用于表达式解析的前缀。
      static String BINDING_EXPRESSION_SUFFIX
      绑定表达式分辨率的后缀
      static String CHANGE_EVENT_HANDLER_SUFFIX
      财产更改/无效处理程序的后缀。
      static String CONTROLLER_KEYWORD
      控制器在命名空间映射中的关键。
      static String CONTROLLER_METHOD_PREFIX
      控制器方法分辨率前缀。
      static String CONTROLLER_SUFFIX
      包含fxml文件的控制器的后缀。
      static String COPY_SOURCE_ATTRIBUTE
      <fx：copy>'source'属性。
      static String COPY_TAG
      标签名称为<fx：copy>。
      static String DEFAULT_CHARSET_NAME
      字符集未被明确指定时使用的字符集。
      static String DEFINE_TAG
      标签名称为<fx：define>。
      static String ESCAPE_PREFIX
      转义属性值内的特殊字符的转义前缀。
      static String EVENT_HANDLER_PREFIX
      事件处理程序属性的前缀。
      static String EVENT_KEY
      事件处理程序脚本中Event对象的名称。
      static String EXPRESSION_PREFIX
      （变量）表达式分辨率的前缀。
      static String FX_CONSTANT_ATTRIBUTE
      标签名为'fx：constant'。
      static String FX_CONTROLLER_ATTRIBUTE
      根的fx：controller属性的名称。
      static String FX_FACTORY_ATTRIBUTE
      “fx：factory”属性的名称。
      static String FX_ID_ATTRIBUTE
      fx：id属性的名称。
      static String FX_NAMESPACE_PREFIX
      'fx'命名空间的前缀。
      static String FX_NAMESPACE_VERSION
      包含当前的fx namepsace版本。
      static String FX_VALUE_ATTRIBUTE
      fx：value属性的名称。
      static String IMPORT_PROCESSING_INSTRUCTION
      导入处理指令的标签名称。
      static String INCLUDE_CHARSET_ATTRIBUTE
      <fx：include>'charset'属性。
      static String INCLUDE_RESOURCES_ATTRIBUTE
      <fx：include>'资源'属性。
      static String INCLUDE_SOURCE_ATTRIBUTE
      <fx：include>'source'属性。
      static String INCLUDE_TAG
      标签名称为<fx：include>。
      static String INITIALIZE_METHOD_NAME
      初始化方法的名称。
      static String JAVAFX_VERSION
      包含当前的javafx版本。
      static String LANGUAGE_PROCESSING_INSTRUCTION
      语言处理指令的标签名称。
      static String LOCATION_KEY
      命名空间地图中位置URL的键。
      static String NULL_KEYWORD
      代表'null'的值。
      static String REFERENCE_SOURCE_ATTRIBUTE
      <fx：reference>'source'属性。
      static String REFERENCE_TAG
      标签名称为<fx：reference>。
      static String RELATIVE_PATH_PREFIX
      前缀相对位置解析。
      static String RESOURCE_KEY_PREFIX
      前缀用于资源解析。
      static String RESOURCES_KEY
      ResourceBundle在命名空间映射中的关键。
      static String ROOT_TAG
      标签名称为<fx：root>。
      static String ROOT_TYPE_ATTRIBUTE
      <fx：root>'type'属性。
      static String SCRIPT_CHARSET_ATTRIBUTE
      <fx：script>'charset'属性。
      static String SCRIPT_SOURCE_ATTRIBUTE
      <fx：script>'source'属性。
      static String SCRIPT_TAG
      标签名称为<fx：script>。

    • 构造方法摘要

      构造方法
      Constructor 描述
      FXMLLoader​()
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(Charset charset)
      创建一个新的FXMLLoader实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      BuilderFactory getBuilderFactory​()
      返回此装载器使用的构建器工厂。
      Charset getCharset​()
      返回此装载器使用的字符集。
      ClassLoader getClassLoader​()
      返回此加载器使用的类加载器。
      <T> T getController​()
      返回与根对象关联的控制器。
      Callback<Class<?>,Object> getControllerFactory​()
      返回此装载器使用的控制器工厂。
      static ClassLoader getDefaultClassLoader​()
      返回默认的类加载器。
      LoadListener getLoadListener​()
      返回此加载器的负载侦听器。
      URL getLocation​()
      返回用于解析相对路径属性值的位置。
      ObservableMap<String,Object> getNamespace​()
      返回此装载器使用的命名空间。
      ResourceBundle getResources​()
      返回用于解析资源密钥属性值的资源。
      <T> T getRoot​()
      返回对象层次结构的根。
      <T> T load​()
      从FXML文档加载对象层次结构。
      <T> T load​(InputStream inputStream)
      从FXML文档加载对象层次结构。
      static <T> T load​(URL location)
      从FXML文档加载对象层次结构。
      static <T> T load​(URL location, ResourceBundle resources)
      从FXML文档加载对象层次结构。
      static <T> T load​(URL location, ResourceBundle resources, BuilderFactory builderFactory)
      从FXML文档加载对象层次结构。
      static <T> T load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      从FXML文档加载对象层次结构。
      static <T> T load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      从FXML文档加载对象层次结构。
      static Class<?> loadType​(String className)
      已过时。
      此方法现在委托给getDefaultClassLoader() 。
      static Class<?> loadType​(String packageName, String className)
      已过时。
      此方法现在委托给getDefaultClassLoader() 。
      void setBuilderFactory​(BuilderFactory builderFactory)
      设置此装载器使用的构建器工厂。
      void setCharset​(Charset charset)
      设置此装载器使用的字符集。
      void setClassLoader​(ClassLoader classLoader)
      设置此装载器使用的类加载器，并清除任何现有的导入。
      void setController​(Object controller)
      设置与根对象关联的控制器。
      void setControllerFactory​(Callback<Class<?>,Object> controllerFactory)
      设置此装载机使用的控制器工厂。
      static void setDefaultClassLoader​(ClassLoader defaultClassLoader)
      设置默认的类加载器。
      void setLoadListener​(LoadListener loadListener)
      设置此加载器的负载侦听器。
      void setLocation​(URL location)
      设置用于解析相对路径属性值的位置。
      void setResources​(ResourceBundle resources)
      设置用于解析资源密钥属性值的资源。
      void setRoot​(Object root)
      设置对象层次结构的根。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT_CHARSET_NAME

        public static final String DEFAULT_CHARSET_NAME
        字符集未被明确指定时使用的字符集。
        另请参见：
        Constant Field Values

      • LANGUAGE_PROCESSING_INSTRUCTION

        public static final String LANGUAGE_PROCESSING_INSTRUCTION
        语言处理指令的标签名称。
        另请参见：
        Constant Field Values

      • IMPORT_PROCESSING_INSTRUCTION

        public static final String IMPORT_PROCESSING_INSTRUCTION
        导入处理指令的标签名称。
        另请参见：
        Constant Field Values

      • FX_NAMESPACE_PREFIX

        public static final String FX_NAMESPACE_PREFIX
        'fx'命名空间的前缀。
        另请参见：
        Constant Field Values

      • FX_CONTROLLER_ATTRIBUTE

        public static final String FX_CONTROLLER_ATTRIBUTE
        根的fx：controller属性的名称。
        另请参见：
        Constant Field Values

      • FX_ID_ATTRIBUTE

        public static final String FX_ID_ATTRIBUTE
        fx：id属性的名称。
        另请参见：
        Constant Field Values

      • FX_VALUE_ATTRIBUTE

        public static final String FX_VALUE_ATTRIBUTE
        fx：value属性的名称。
        另请参见：
        Constant Field Values

      • FX_CONSTANT_ATTRIBUTE

        public static final String FX_CONSTANT_ATTRIBUTE
        标签名为'fx：constant'。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        Constant Field Values

      • FX_FACTORY_ATTRIBUTE

        public static final String FX_FACTORY_ATTRIBUTE
        “fx：factory”属性的名称。
        另请参见：
        Constant Field Values

      • INCLUDE_TAG

        public static final String INCLUDE_TAG
        标签名称为<fx：include>。
        另请参见：
        Constant Field Values

      • INCLUDE_SOURCE_ATTRIBUTE

        public static final String INCLUDE_SOURCE_ATTRIBUTE
        <fx：include>'source'属性。
        另请参见：
        Constant Field Values

      • INCLUDE_RESOURCES_ATTRIBUTE

        public static final String INCLUDE_RESOURCES_ATTRIBUTE
        <fx：include>'资源'属性。
        另请参见：
        Constant Field Values

      • INCLUDE_CHARSET_ATTRIBUTE

        public static final String INCLUDE_CHARSET_ATTRIBUTE
        <fx：include>'charset'属性。
        另请参见：
        Constant Field Values

      • SCRIPT_TAG

        public static final String SCRIPT_TAG
        标签名称为<fx：script>。
        另请参见：
        Constant Field Values

      • SCRIPT_SOURCE_ATTRIBUTE

        public static final String SCRIPT_SOURCE_ATTRIBUTE
        <fx：script>'source'属性。
        另请参见：
        Constant Field Values

      • SCRIPT_CHARSET_ATTRIBUTE

        public static final String SCRIPT_CHARSET_ATTRIBUTE
        <fx：script>'charset'属性。
        另请参见：
        Constant Field Values

      • DEFINE_TAG

        public static final String DEFINE_TAG
        标签名称为<fx：define>。
        另请参见：
        Constant Field Values

      • REFERENCE_TAG

        public static final String REFERENCE_TAG
        标签名称为<fx：reference>。
        另请参见：
        Constant Field Values

      • REFERENCE_SOURCE_ATTRIBUTE

        public static final String REFERENCE_SOURCE_ATTRIBUTE
        <fx：reference>'source'属性。
        另请参见：
        Constant Field Values

      • ROOT_TAG

        public static final String ROOT_TAG
        标签名称为<fx：root>。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        Constant Field Values

      • ROOT_TYPE_ATTRIBUTE

        public static final String ROOT_TYPE_ATTRIBUTE
        <fx：root>'type'属性。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        Constant Field Values

      • COPY_TAG

        public static final String COPY_TAG
        标签名称为<fx：copy>。
        另请参见：
        Constant Field Values

      • COPY_SOURCE_ATTRIBUTE

        public static final String COPY_SOURCE_ATTRIBUTE
        <fx：copy>'source'属性。
        另请参见：
        Constant Field Values

      • EVENT_HANDLER_PREFIX

        public static final String EVENT_HANDLER_PREFIX
        事件处理程序属性的前缀。
        另请参见：
        Constant Field Values

      • EVENT_KEY

        public static final String EVENT_KEY
        事件处理程序脚本中Event对象的名称。
        另请参见：
        Constant Field Values

      • CHANGE_EVENT_HANDLER_SUFFIX

        public static final String CHANGE_EVENT_HANDLER_SUFFIX
        财产更改/无效处理程序的后缀。
        另请参见：
        Constant Field Values

      • NULL_KEYWORD

        public static final String NULL_KEYWORD
        代表'null'的值。
        另请参见：
        Constant Field Values

      • ESCAPE_PREFIX

        public static final String ESCAPE_PREFIX
        转义属性值内的特殊字符的转义前缀。 用作逃生ESCAPE_PREFIX ， RELATIVE_PATH_PREFIX ， RESOURCE_KEY_PREFIX ， EXPRESSION_PREFIX ， BI_DIRECTIONAL_BINDING_PREFIX
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        Constant Field Values

      • RELATIVE_PATH_PREFIX

        public static final String RELATIVE_PATH_PREFIX
        前缀相对位置解析。
        另请参见：
        Constant Field Values

      • RESOURCE_KEY_PREFIX

        public static final String RESOURCE_KEY_PREFIX
        前缀用于资源解析。
        另请参见：
        Constant Field Values

      • EXPRESSION_PREFIX

        public static final String EXPRESSION_PREFIX
        （变量）表达式分辨率的前缀。
        另请参见：
        Constant Field Values

      • BINDING_EXPRESSION_PREFIX

        public static final String BINDING_EXPRESSION_PREFIX
        用于表达式解析的前缀。
        另请参见：
        Constant Field Values

      • BINDING_EXPRESSION_SUFFIX

        public static final String BINDING_EXPRESSION_SUFFIX
        绑定表达式分辨率的后缀
        另请参见：
        Constant Field Values

      • BI_DIRECTIONAL_BINDING_PREFIX

        public static final String BI_DIRECTIONAL_BINDING_PREFIX
        前缀用于双向绑定表达式解析。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        Constant Field Values

      • BI_DIRECTIONAL_BINDING_SUFFIX

        public static final String BI_DIRECTIONAL_BINDING_SUFFIX
        双向绑定表达式解析的后缀。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        Constant Field Values

      • ARRAY_COMPONENT_DELIMITER

        public static final String ARRAY_COMPONENT_DELIMITER
        数组的分隔符作为值。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        Constant Field Values

      • LOCATION_KEY

        public static final String LOCATION_KEY
        命名空间地图中位置URL的键。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getNamespace() ， Constant Field Values

      • RESOURCES_KEY

        public static final String RESOURCES_KEY
        ResourceBundle在命名空间映射中的关键。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getNamespace() ， Constant Field Values

      • CONTROLLER_METHOD_PREFIX

        public static final String CONTROLLER_METHOD_PREFIX
        控制器方法分辨率前缀。
        另请参见：
        Constant Field Values

      • CONTROLLER_KEYWORD

        public static final String CONTROLLER_KEYWORD
        控制器在命名空间映射中的关键。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getNamespace() ， Constant Field Values

      • CONTROLLER_SUFFIX

        public static final String CONTROLLER_SUFFIX
        包含fxml文件的控制器的后缀。 全键存储在命名空间映射中。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getNamespace() ， Constant Field Values

      • INITIALIZE_METHOD_NAME

        public static final String INITIALIZE_METHOD_NAME
        初始化方法的名称。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        Constant Field Values

      • JAVAFX_VERSION

        public static final String JAVAFX_VERSION
        包含当前的javafx版本。
        从以下版本开始：
        JavaFX 8.0

      • FX_NAMESPACE_VERSION

        public static final String FX_NAMESPACE_VERSION
        包含当前的fx namepsace版本。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • FXMLLoader

        public FXMLLoader​()
        创建一个新的FXMLLoader实例。

      • FXMLLoader

        public FXMLLoader​(URL location)
        创建一个新的FXMLLoader实例。
        参数
        location - 用于解析相对路径属性值的位置
        从以下版本开始：
        JavaFX 2.1

      • FXMLLoader

        public FXMLLoader​(URL location,
                  ResourceBundle resources)
        创建一个新的FXMLLoader实例。
        参数
        location - 用于解析相对路径属性值的位置
        resources - 用于解析资源密钥属性值的资源
        从以下版本开始：
        JavaFX 2.1

      • FXMLLoader

        public FXMLLoader​(URL location,
                  ResourceBundle resources,
                  BuilderFactory builderFactory)
        创建一个新的FXMLLoader实例。
        参数
        location - 用于解析相对路径属性值的位置
        resources - 用于解析资源密钥属性值的资源
        builderFactory - 这个装载机使用的生成工厂
        从以下版本开始：
        JavaFX 2.1

      • FXMLLoader

        public FXMLLoader​(URL location,
                  ResourceBundle resources,
                  BuilderFactory builderFactory,
                  Callback<Class<?>,Object> controllerFactory)
        创建一个新的FXMLLoader实例。
        参数
        location - 用于解析相对路径属性值的位置
        resources - 用于解析资源密钥属性值的资源
        builderFactory - 这个装载机使用的生成工厂
        controllerFactory - 这个装载机使用的控制器工厂
        从以下版本开始：
        JavaFX 2.1

      • FXMLLoader

        public FXMLLoader​(Charset charset)
        创建一个新的FXMLLoader实例。
        参数
        charset - 这个装载器使用的字符集

      • FXMLLoader

        public FXMLLoader​(URL location,
                  ResourceBundle resources,
                  BuilderFactory builderFactory,
                  Callback<Class<?>,Object> controllerFactory,
                  Charset charset)
        创建一个新的FXMLLoader实例。
        参数
        location - 用于解析相对路径属性值的位置
        resources - 用于解析资源密钥属性值的资源
        builderFactory - 这个装载机使用的生成工厂
        controllerFactory - 这个装载机使用的控制器工厂
        charset - 这个装载器使用的字符集
        从以下版本开始：
        JavaFX 2.1

      • FXMLLoader

        public FXMLLoader​(URL location,
                  ResourceBundle resources,
                  BuilderFactory builderFactory,
                  Callback<Class<?>,Object> controllerFactory,
                  Charset charset,
                  LinkedList<FXMLLoader> loaders)
        创建一个新的FXMLLoader实例。
        参数
        location - 用于解析相对路径属性值的位置
        resources - 用于解析资源密钥属性值的资源
        builderFactory - 这个装载机使用的生成工厂
        controllerFactory - 这个装载机使用的控制器工厂
        charset - 这个装载器使用的字符集
        loaders - 装载机列表
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • getLocation

        public URL getLocation​()
        返回用于解析相对路径属性值的位置。
        结果
        用于解析相对路径属性值的位置

      • setLocation

        public void setLocation​(URL location)
        设置用于解析相对路径属性值的位置。
        参数
        location - 的位置

      • getResources

        public ResourceBundle getResources​()
        返回用于解析资源密钥属性值的资源。
        结果
        用于解析资源密钥属性值的资源

      • setResources

        public void setResources​(ResourceBundle resources)
        设置用于解析资源密钥属性值的资源。
        参数
        resources - 资源

      • getNamespace

        public ObservableMap<String,Object> getNamespace​()
        返回此装载器使用的命名空间。
        结果
        命名空间

      • getRoot

        public <T> T getRoot​()
        返回对象层次结构的根。
        参数类型
        T - 根对象的类型
        结果
        对象层次结构的根

      • setRoot

        public void setRoot​(Object root)
        设置对象层次结构的根。 传递给此方法的值用作<fx:root>标记的值。 在使用<fx:root>之前，必须先调用此方法。
        参数
        root - 对象层次结构的根
        从以下版本开始：
        JavaFX 2.2

      • equals

        public boolean equals​(Object obj)
        描述从类别复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同的对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        obj - 用于比较的参考对象。
        结果
        true如果该对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • getController

        public <T> T getController​()
        返回与根对象关联的控制器。
        参数类型
        T - 控制器的类型
        结果
        控制器与根对象相关联

      • setController

        public void setController​(Object controller)
        设置与根对象关联的控制器。 传递给此方法的值用作fx:controller属性的值。 当在文档中未指定fx:controller属性时，在使用控制器事件处理程序时，必须先调用此方法。
        参数
        controller - 控制器与根对象关联
        从以下版本开始：
        JavaFX 2.2

      • getBuilderFactory

        public BuilderFactory getBuilderFactory​()
        返回此装载器使用的构建器工厂。
        结果
        建筑工厂

      • setBuilderFactory

        public void setBuilderFactory​(BuilderFactory builderFactory)
        设置此装载器使用的构建器工厂。
        参数
        builderFactory - 建筑工厂

      • getControllerFactory

        public Callback<Class<?>,Object> getControllerFactory​()
        返回此装载器使用的控制器工厂。
        结果
        控制器厂
        从以下版本开始：
        JavaFX 2.1

      • setControllerFactory

        public void setControllerFactory​(Callback<Class<?>,Object> controllerFactory)
        设置此装载机使用的控制器工厂。
        参数
        controllerFactory - 控制器厂
        从以下版本开始：
        JavaFX 2.1

      • getCharset

        public Charset getCharset​()
        返回此装载器使用的字符集。
        结果
        字符集

      • setCharset

        public void setCharset​(Charset charset)
        设置此装载器使用的字符集。
        参数
        charset - 字符集
        从以下版本开始：
        JavaFX 2.1

      • getClassLoader

        public ClassLoader getClassLoader​()
        返回此加载器使用的类加载器。
        结果
        类加载器
        从以下版本开始：
        JavaFX 2.1

      • setClassLoader

        public void setClassLoader​(ClassLoader classLoader)
        设置此装载器使用的类加载器，并清除任何现有的导入。
        参数
        classLoader - 类加载器
        从以下版本开始：
        JavaFX 2.1

      • getLoadListener

        public LoadListener getLoadListener​()
        返回此加载器的负载侦听器。
        结果
        负载侦听器
        从以下版本开始：
        9

      • setLoadListener

        public final void setLoadListener​(LoadListener loadListener)
        设置此加载器的负载侦听器。
        参数
        loadListener - 负载监听器
        从以下版本开始：
        9

      • load

        public <T> T load​()
           throws IOException
        从FXML文档加载对象层次结构。 文件载入的位置必须先通过电话setLocation(URL)设定 。
        参数类型
        T - 根对象的类型
        结果
        加载的对象层次结构
        异常
        IOException - 加载过程中是否发生错误
        从以下版本开始：
        JavaFX 2.1

      • load

        public <T> T load​(InputStream inputStream)
           throws IOException
        从FXML文档加载对象层次结构。
        参数类型
        T - 根对象的类型
        参数
        inputStream - 包含要加载的FXML数据的输入流
        结果
        加载的对象层次结构
        异常
        IOException - 加载过程中是否发生错误

      • loadType

        @Deprecated
public static Class<?> loadType​(String packageName,
                                String className)
                         throws ClassNotFoundException
        已过时。 此方法现在委托给getDefaultClassLoader() 。
        使用默认的类加载器加载类型。
        参数
        packageName - 要加载的类的包名称
        className - 要加载的类的名称
        结果
        班上
        异常
        ClassNotFoundException - 如果找不到指定的类

      • loadType

        @Deprecated
public static Class<?> loadType​(String className)
                         throws ClassNotFoundException
        已过时。 此方法现在委托给getDefaultClassLoader() 。
        使用默认的类加载器加载类型。
        参数
        className - 要加载的类的名称
        结果
        班上
        异常
        ClassNotFoundException - 如果找不到指定的类

      • getDefaultClassLoader

        public static ClassLoader getDefaultClassLoader​()
        返回默认的类加载器。
        结果
        默认的类加载器
        从以下版本开始：
        JavaFX 2.1

      • setDefaultClassLoader

        public static void setDefaultClassLoader​(ClassLoader defaultClassLoader)
        设置默认的类加载器。
        参数
        defaultClassLoader - 加载类时要使用的默认类加载器。
        从以下版本开始：
        JavaFX 2.1

      • load

        public static <T> T load​(URL location)
                  throws IOException
        从FXML文档加载对象层次结构。
        参数类型
        T - 根对象的类型
        参数
        location - 用于解析相对路径属性值的位置
        结果
        加载的对象层次结构
        异常
        IOException - 加载过程中是否发生错误

      • load

        public static <T> T load​(URL location,
                         ResourceBundle resources)
                  throws IOException
        从FXML文档加载对象层次结构。
        参数类型
        T - 根对象的类型
        参数
        location - 用于解析相对路径属性值的位置
        resources - 用于解析资源密钥属性值的资源
        结果
        加载的对象层次结构
        异常
        IOException - 加载过程中是否发生错误

      • load

        public static <T> T load​(URL location,
                         ResourceBundle resources,
                         BuilderFactory builderFactory)
                  throws IOException
        从FXML文档加载对象层次结构。
        参数类型
        T - 根对象的类型
        参数
        location - 用于解析相对路径属性值的位置
        resources - 用于解析资源密钥属性值的资源
        builderFactory - 用于加载文档的构建器工厂
        结果
        加载的对象层次结构
        异常
        IOException - 加载过程中是否发生错误

      • load

        public static <T> T load​(URL location,
                         ResourceBundle resources,
                         BuilderFactory builderFactory,
                         Callback<Class<?>,Object> controllerFactory)
                  throws IOException
        从FXML文档加载对象层次结构。
        参数类型
        T - 根对象的类型
        参数
        location - 用于解析相对路径属性值的位置
        resources - 用于解析资源密钥属性值的资源
        builderFactory - 加载文档时使用的构建工厂
        controllerFactory - 加载文档时使用的控制器工厂
        结果
        加载的对象层次结构
        异常
        IOException - 加载过程中是否发生错误
        从以下版本开始：
        JavaFX 2.1

      • load

        public static <T> T load​(URL location,
                         ResourceBundle resources,
                         BuilderFactory builderFactory,
                         Callback<Class<?>,Object> controllerFactory,
                         Charset charset)
                  throws IOException
        从FXML文档加载对象层次结构。
        参数类型
        T - 根对象的类型
        参数
        location - 用于解析相对路径属性值的位置
        resources - 用于解析资源密钥属性值的资源
        builderFactory - 加载文档时使用的构建器工厂
        controllerFactory - 加载文档时使用的控制器工厂
        charset - 加载文档时使用的字符集
        结果
        加载的对象层次结构
        异常
        IOException - 加载过程中是否发生错误
        从以下版本开始：
        JavaFX 2.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Initializable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.fxml
软件包 javafx.fxml

Interface Initializable

  • public interface Initializable
    控制器初始化界面

    注意该接口已被控制器自动注入location和resources属性所取代。 FXMLLoader现在将自动调用由控制器定义的任何适当注释的非参数initialize()方法。 建议尽可能使用注射方法。

    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void initialize​(URL location, ResourceBundle resources)
      被调用以在其根元素被完全处理之后初始化控制器。

    • 方法详细信息

      • initialize

        void initialize​(URL location,
                ResourceBundle resources)
        被调用以在其根元素被完全处理之后初始化控制器。
        参数
        location - 用于解决根对象的相对路径的位置，如果位置不知道， null 。
        resources - 用于本地化根对象的资源，如果根对象未本地化， null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.fxml (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.fxml

Package javafx.fxml

包含用于从标记加载对象层次结构的类。 有关详细信息，请参阅Introduction to FXML文档。

  • 接口摘要
    接口 描述
    Initializable
    控制器初始化界面
    LoadListener
    加载侦听器界面。
  • 类摘要
    Class 描述
    FXMLLoader
    从XML文档加载对象层次结构。
    JavaFXBuilderFactory
    JavaFX构建工厂。
  • 异常摘要
    异常 描述
    LoadException
    在加载操作期间遇到错误时抛出。
  • 注解类型摘要
    Annotation Type 描述
    FXML
    Annotation that tags a field or method as accessible to markup.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.fxml Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.fxml

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.fxml.FXMLLoader
    • javafx.fxml.JavaFXBuilderFactory (implements javafx.util.BuilderFactory)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • javafx.fxml.LoadException

Interface Hierarchy

  • javafx.fxml.Initializable
  • javafx.fxml.LoadListener

Annotation Type Hierarchy

  • javafx.fxml.FXML (implements java.lang.annotation.Annotation)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


JavaFXBuilderFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.fxml
软件包 javafx.fxml

Class JavaFXBuilderFactory

  • java.lang.Object
    • javafx.fxml.JavaFXBuilderFactory
  • All Implemented Interfaces:
    BuilderFactory

    public final class JavaFXBuilderFactory
extends Object
implements BuilderFactory
    JavaFX构建工厂。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      JavaFXBuilderFactory​()
      默认构造函数。
      JavaFXBuilderFactory​(ClassLoader classLoader)
      构造器接收类加载器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Builder<?> getBuilder​(Class<?> type)
      返回指定类型的构建器，如果不使用构建器，则返回null。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JavaFXBuilderFactory

        public JavaFXBuilderFactory​()
        默认构造函数。

      • JavaFXBuilderFactory

        public JavaFXBuilderFactory​(ClassLoader classLoader)
        构造器接收类加载器。
        参数
        classLoader - 加载类时要使用的类加载器
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • getBuilder

        public Builder<?> getBuilder​(Class<?> type)
        返回指定类型的构建器，如果不使用构建器，则返回null。 大多数类将注意到使用构建器。
        Specified by:
        getBuilder在接口 BuilderFactory
        参数
        type - 正在抬头上课
        结果
        该类的构建器，如果不使用构建器，则为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LoadException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.fxml
软件包 javafx.fxml

Class LoadException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javafx.fxml.LoadException
  • All Implemented Interfaces:
    Serializable

    public class LoadException
extends IOException
    在加载操作期间遇到错误时抛出。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LoadException​()
      LoadException​(String message)
      LoadException​(String message, Throwable cause)
      LoadException​(Throwable cause)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • LoadException

        public LoadException​()

      • LoadException

        public LoadException​(String message)

      • LoadException

        public LoadException​(Throwable cause)

      • LoadException

        public LoadException​(String message,
                     Throwable cause)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LoadListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.fxml
软件包 javafx.fxml

Interface LoadListener

  • public interface LoadListener
    加载侦听器界面。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void beginCopyElement​()
      当加载程序开始读取复制元素时调用。
      void beginDefineElement​()
      当加载程序已经开始阅读define元素时被调用。
      void beginIncludeElement​()
      当加载程序开始读取包含元素时调用。
      void beginInstanceDeclarationElement​(Class<?> type)
      当加载程序开始读取实例声明元素时调用。
      void beginPropertyElement​(String name, Class<?> sourceType)
      当加载程序开始读取属性元素时调用。
      void beginReferenceElement​()
      当加载程序开始读取参考元素时调用。
      void beginRootElement​()
      当加载程序开始读取根元素时调用。
      void beginScriptElement​()
      当加载程序开始读取脚本元素时调用。
      void beginUnknownStaticPropertyElement​(String name)
      当加载程序开始读取由未知类型定义的静态属性元素时调用。
      void beginUnknownTypeElement​(String name)
      当加载程序已经开始读取未知类型的实例声明元素时调用。
      void endElement​(Object value)
      加载程序完成读取元素后调用。
      void readComment​(String comment)
      当加载程序读取注释时调用。
      void readEventHandlerAttribute​(String name, String value)
      当加载程序读取事件处理程序属性时调用。
      void readImportProcessingInstruction​(String target)
      当加载程序读取导入处理指令时调用。
      void readInternalAttribute​(String name, String value)
      加载程序读取内部属性时调用。
      void readLanguageProcessingInstruction​(String language)
      当加载程序读取语言处理指令时调用。
      void readPropertyAttribute​(String name, Class<?> sourceType, String value)
      加载程序读取属性属性时调用。
      void readUnknownStaticPropertyAttribute​(String name, String value)
      当加载程序读取未知的静态属性属性时调用。

    • 方法详细信息

      • readImportProcessingInstruction

        void readImportProcessingInstruction​(String target)
        当加载程序读取导入处理指令时调用。
        参数
        target - 进口目标

      • readLanguageProcessingInstruction

        void readLanguageProcessingInstruction​(String language)
        当加载程序读取语言处理指令时调用。
        参数
        language - 语言教学

      • readComment

        void readComment​(String comment)
        当加载程序读取注释时调用。
        参数
        comment - 评论

      • beginInstanceDeclarationElement

        void beginInstanceDeclarationElement​(Class<?> type)
        当加载程序开始读取实例声明元素时调用。
        参数
        type - 元素的类型

      • beginUnknownTypeElement

        void beginUnknownTypeElement​(String name)
        当加载程序已经开始读取未知类型的实例声明元素时调用。
        参数
        name - 未知类型的名称

      • beginIncludeElement

        void beginIncludeElement​()
        当加载程序开始读取包含元素时调用。

      • beginReferenceElement

        void beginReferenceElement​()
        当加载程序开始读取参考元素时调用。

      • beginCopyElement

        void beginCopyElement​()
        当加载程序开始读取复制元素时调用。

      • beginRootElement

        void beginRootElement​()
        当加载程序开始读取根元素时调用。

      • beginPropertyElement

        void beginPropertyElement​(String name,
                          Class<?> sourceType)
        当加载程序开始读取属性元素时调用。
        参数
        name - 物业的名称
        sourceType - 属性的类型

      • beginUnknownStaticPropertyElement

        void beginUnknownStaticPropertyElement​(String name)
        当加载程序开始读取由未知类型定义的静态属性元素时调用。
        参数
        name - 未知类型的名称

      • beginScriptElement

        void beginScriptElement​()
        当加载程序开始读取脚本元素时调用。

      • beginDefineElement

        void beginDefineElement​()
        当加载程序已经开始阅读define元素时被调用。

      • readInternalAttribute

        void readInternalAttribute​(String name,
                           String value)
        加载程序读取内部属性时调用。
        参数
        name - 属性的名称
        value - 属性的值

      • readPropertyAttribute

        void readPropertyAttribute​(String name,
                           Class<?> sourceType,
                           String value)
        加载程序读取属性属性时调用。
        参数
        name - 属性的名称
        sourceType - 属性的类型
        value - 属性的值

      • readUnknownStaticPropertyAttribute

        void readUnknownStaticPropertyAttribute​(String name,
                                        String value)
        当加载程序读取未知的静态属性属性时调用。
        参数
        name - 属性的名称
        value - 属性的值

      • readEventHandlerAttribute

        void readEventHandlerAttribute​(String name,
                               String value)
        当加载程序读取事件处理程序属性时调用。
        参数
        name - 属性的名称
        value - 属性的值

      • endElement

        void endElement​(Object value)
        加载程序完成读取元素后调用。
        参数
        value - 元素的值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.fxml (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.fxml

  • Packages that use javafx.fxml
    软件包 描述
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
  • Classes in javafx.fxml used by javafx.fxml
    Class 描述
    FXMLLoader
    从XML文档加载对象层次结构。
    LoadListener
    加载侦听器界面。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.fxml.FXML (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.fxml.FXML

No usage of javafx.fxml.FXML
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.fxml.FXMLLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.fxml.FXMLLoader

  • Packages that use FXMLLoader
    软件包 描述
    javafx.fxml
    包含用于从标记加载对象层次结构的类。

    • Uses of FXMLLoader in javafx.fxml

      Constructor parameters in javafx.fxml with type arguments of type FXMLLoader
      Constructor 描述
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)
      创建一个新的FXMLLoader实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.fxml.JavaFXBuilderFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.fxml.JavaFXBuilderFactory

No usage of javafx.fxml.JavaFXBuilderFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.fxml.LoadException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.fxml.LoadException

No usage of javafx.fxml.LoadException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.fxml.Initializable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.fxml.Initializable

No usage of javafx.fxml.Initializable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.fxml.LoadListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.fxml.LoadListener

  • Packages that use LoadListener
    软件包 描述
    javafx.fxml
    包含用于从标记加载对象层次结构的类。

    • Uses of LoadListener in javafx.fxml

      Methods in javafx.fxml that return LoadListener
      Modifier and Type 方法 描述
      LoadListener FXMLLoader.getLoadListener​()
      返回此加载器的负载侦听器。
      Methods in javafx.fxml with parameters of type LoadListener
      Modifier and Type 方法 描述
      void FXMLLoader.setLoadListener​(LoadListener loadListener)
      设置此加载器的负载侦听器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Introduction to FXML | JavaFX 9

Release: JavaFX 9

Introduction to FXML

Last updated: 01 May 2017

Contents

  • 概述
  • Elements
    • Class Instance Elements
      • Instance Declarations
      • <fx:include>
      • <fx:constant>
      • <fx:reference>
      • <fx:copy>
      • <fx:root>
    • Property Elements
      • Property Setters
      • Read-Only List Properties
      • Read-Only Map Properties
      • Default Properties
    • Static Properties
    • Define Blocks
  • Attributes
    • Instance Properties
      • Location Resolution
      • Resource Resolution
      • Variable Resolution
      • Escape Sequences
      • Expression Binding
    • Static Properties
    • Event Handlers
      • Script Event Handlers
      • Controller Method Event Handlers
      • Event handlers from expressions
      • Special handlers for collections and properties
  • Scripting
  • Controllers
    • @FXML
    • Nested Controllers
  • FXMLLoader
    • Custom Components
  • Deploying an Application as a Module

概述

FXML is a scriptable, XML-based markup language for constructing Java object graphs. It provides a convenient alternative to constructing such graphs in procedural code, and is ideally suited to defining the user interface of a JavaFX application, since the hierarchical structure of an XML document closely parallels the structure of the JavaFX scene graph.

This document introduces the FXML markup language and explains how it can be used to simplify development of JavaFX applications.

Elements

In FXML, an XML element represents one of the following:

  • A class instance
  • A property of a class instance
  • A "static" property
  • A "define" block
  • A block of script code

Class instances, instance properties, static properties, and define blocks are discussed in this section below. Scripting is discussed in a later section.

Class Instance Elements

Class instances can be constructed in FXML in several ways. The most common is via instance declaration elements, which simply create a new instance of a class by name. Other ways of creating class instances include referencing existing values, copying existing values, and including external FXML files. Each is discussed in more detail below.

Instance Declarations

If an element's tag is considered an instance declaration if the tag begins with uppercase letter (and the class is imported) or, as in Java, it denotes a fully-qualified (including the package name) name of a class. When the FXML loader (also introduced later) encounters such an element, it creates an instance of that class.

Importing a class is done using the "import" processing instruction (PI). For example, the following PI imports the javafx.scene.control.Label class into the current FXML document’s namespace:

<?import javafx.scene.control.Label?>

This PI imports all classes from the javafx.scene.control package into the current namespace:

<?import javafx.scene.control.*?>

Any class that adheres to JavaBean constructor and property naming conventions can be readily instantiated and configured using FXML. The following is a simple but complete example that creates an instance of javafx.scene.control.Label and sets its "text" property to "Hello, World!":

<?import javafx.scene.control.Label?>
<Label text="Hello, World!"/>

Note that the Label’s "text" property in this example is set using an XML attribute. Properties can also be set using nested property elements. Property elements are discussed in more detail later in this section. Property attributes are discussed in a later section.

Classes that don't conform to Bean conventions can also be constructed in FXML, using an object called a "builder". Builders are discussed in more detail later.

Maps

Internally, the FXML loader uses an instance of com.sun.javafx.fxml.BeanAdapter to wrap an instantiated object and invoke its setter methods. This (currently) private class implements the java.util.Map interface and allows a caller to get and set Bean property values as key/value pairs.

If an element represents a type that already implements Map (such as java.util.HashMap), it is not wrapped and its get() and put() methods are invoked directly. For example, the following FXML creates an instance of HashMap and sets its "foo" and "bar" values to "123" and "456", respectively:

<HashMap foo="123" bar="456"/>
fx:value

The fx:value attribute can be used to initialize an instance of a type that does not have a default constructor but provides a static valueOf(String) method. For example, java.lang.String as well as each of the primitive wrapper types define a valueOf() method and can be constructed in FXML as follows:

<String fx:value="Hello, World!"/>
<Double fx:value="1.0"/>
<Boolean fx:value="false"/>

Custom classes that define a static valueOf(String) method can also be constructed this way.

fx:factory

The fx:factory attribute is another means of creating objects whose classes do not have a default constructor. The value of the attribute is the name of a static, no-arg factory method for producing class instances. For example, the following markup creates an instance of an observable array list, populated with three string values:

<FXCollections fx:factory="observableArrayList">
    <String fx:value="A"/>
    <String fx:value="B"/>
    <String fx:value="C"/>
</FXCollections>
Builders

A third means of creating instances of classes that do not conform to Bean conventions (such as those representing immutable values) is a "builder". The builder design pattern delegates object construction to a mutable helper class (called a "builder") that is responsible for manufacturing instances of the immutable type.

Builder support in FXML is provided by two interfaces. The javafx.util.Builder interface defines a single method named build() which is responsible for constructing the actual object:

public interface Builder<T> {
    public T build();
}

A javafx.util.BuilderFactory is responsible for producing builders that are capable of instantiating a given type:

public interface BuilderFactory {
    public Builder<?> getBuilder(Class<?> type);
}

A default builder factory, JavaFXBuilderFactory, is provided in the javafx.fxml package. This factory is capable of creating and configuring most immutable JavaFX types. For example, the following markup uses the default builder to create an instance of the immutable javafx.scene.paint.Color class:

<Color red="1.0" green="0.0" blue="0.0"/>

Note that, unlike Bean types, which are constructed when the element's start tag is processed, objects constructed by a builder are not instantiated until the element's closing tag is reached. This is because all of the required arguments may not be available until the element has been fully processed. For example, the Color object in the preceding example could also be written as:

<Color>
    <red>1.0</red>
    <green>0.0</green>
    <blue>0.0</blue>
</Color>

The Color instance cannot be fully constructed until all three of the color components are known.

When processing markup for an object that will be constructed by a builder, the Builder instances are treated like value objects - if a Builder implements the Map interface, the put() method is used to set the builder's attribute values. Otherwise, the builder is wrapped in a BeanAdapter and its properties are assumed to be exposed via standard Bean setters.

<fx:include>

The <fx:include> tag creates an object from FXML markup defined in another file. It is used as follows:

<fx:include source="filename"/>

where filename is the name of the FXML file to include. Values that begin with a leading slash character are treated as relative to the classpath. Values with no leading slash are considered relative to the path of the current document.

For example, given the following markup:

<?import javafx.scene.control.*?>
<?import javafx.scene.layout.*?>
<VBox xmlns:fx="http://javafx.com/fxml">
    <children>
        <fx:include source="my_button.fxml"/>
    </children>
</VBox>

If my_button.fxml contains the following:

<?import javafx.scene.control.*?>
<Button text="My Button"/>

the resulting scene graph would contain a VBox as a root object with a single Button as a child node.

Note the use of the "fx" namespace prefix. This is a reserved prefix that defines a number of elements and attributes that are used for internal processing of an FXML source file. It is generally declared on the root element of a FXML document. Other features provided by the "fx" namespace are described in the following sections.

<fx:include> also supports attributes for specifying the name of the resource bundle that should be used to localize the included content, as well as the character set used to encode the source file. Resource resolution is discussed in a later section.

<fx:include source="filename" resources="resource_file" charset="utf-8"/>

<fx:constant>

The <fx:constant> element creates a reference to a class constant. For example, the following markup sets the value of the "minWidth" property of aButton instance to the value of the NEGATIVE_INFINITY constant defined by the java.lang.Double class:

<Button>
    <minHeight><Double fx:constant="NEGATIVE_INFINITY"/></minHeight>
</Button>

<fx:reference>

The <fx:reference> element creates a new reference to an existing element. Wherever this tag appears, it will effectively be replaced by the value of the named element. It is used in conjunction with either the fx:id attribute or with a script variables, both of which are discussed in more detail in later sections. The "source" attribute of the <fx:reference> element specifies the name of the object to which the new element will refer.

For example, the following markup assigns a previously-defined Image instance named "myImage" to the "image" property of an ImageView control:

<ImageView>
    <image>
        <fx:reference source="myImage"/>
    </image>
</ImageView>

Note that, since it is also possible to dereference a variable using the attribute variable resolution operator (discussed later in the Attributes section), fx:reference is generally only used when a reference value must be specified as an element, such as when adding the reference to a collection:

<ArrayList>
    <fx:reference source="element1"/>
    <fx:reference source="element2"/>
    <fx:reference source="element3"/>
</ArrayList>

For most other cases, using an attribute is simpler and more concise.

<fx:copy>

The <fx:copy> element creates a copy of an existing element. Like <fx:reference>, it is used with the fx:id attribute or a script variable. The element's "source" attribute specifies the name of the object that will be copied. The source type must define a copy constructor that will be used to construct the copy from the source value.

At the moment, no JavaFX platform classes provide such a copy constructor, so this element is provided primarily for use by application developers. This may change in a future release.

<fx:root>

The <fx:root> element creates a reference to a previously defined root element. It is only valid as the root node of an FXML document. <fx:root> is used primarily when creating custom controls that are backed by FXML markup. This is discussed in more detail in the FXMLLoader section.

Property Elements

Elements whose tag names begin with a lowercase letter represent object properties. A property element may represent one of the following:

  • A property setter
  • A read-only list property
  • A read-only map property

Property Setters

If an element represents a property setter, the contents of the element (which must be either a text node or a nested class instance element) are passed as the value to the setter for the property.

For example, the following FXML creates an instance of the Label class and sets the value of the label's "text" property to "Hello, World!":

<?import javafx.scene.control.Label?>
<Label>
    <text>Hello, World!</text>
</Label>

This produces the same result as the earlier example which used an attribute to set the "text" property:

<?import javafx.scene.control.Label?>
<Label text="Hello, World!"/>

Property elements are generally used when the property value is a complex type that can't be represented using a simple string-based attribute value, or when the character length of the value is so long that specifying it as an attribute would have a negative impact on readability.

Type Coercion

FXML uses "type coercion" to convert property values to the appropriate type as needed. Type coercion is required because the only data types supported by XML are elements, text, and attributes (whose values are also text). However, Java supports a number of different data types including built-in primitive value types as well as extensible reference types.

The FXML loader uses the coerce() method of BeanAdapter to perform any required type conversions. This method is capable of performing basic primitive type conversions such as String to boolean or int to double, and will also convert String to Class or String to Enum. Additional conversions can be implemented by defining a static valueOf() method on the target type.

Read-Only List Properties

A read-only list property is a Bean property whose getter returns an instance of java.util.List and has no corresponding setter method. The contents of a read-only list element are automatically added to the list as they are processed.

For example, the "children" property of javafx.scene.Group is a read-only list property representing the group's child nodes:

<?import javafx.scene.*?>
<?import javafx.scene.shape.*?>
<Group xmlns:fx="http://javafx.com/fxml">
    <children>
        <Rectangle fx:id="rectangle" x="10" y="10" width="320" height="240"
            fill="#ff0000"/>
        ...
    </children>
</Group>

As each sub-element of the <children> element is read, it is added to the list returned by Group#getChildren().

Read-Only Map Properties

A read-only map property is a bean property whose getter returns an instance of java.util.Map and has no corresponding setter method. The attributes of a read-only map element are applied to the map when the closing tag is processed.

The "properties" property of javafx.scene.Node is an example of a read-only map property. The following markup sets the "foo" and "bar" properties of a Label instance to "123" and "456", respectively:

<?import javafx.scene.control.*?>
<Button>
    <properties foo="123" bar="456"/>
</Button>

Note that a read-only property whose type is neither a List nor a Map will be treated as if it were a read-only map. The return value of the getter method will be wrapped in a BeanAdapter and can be used in the same way as any other read-only map.

Default Properties

A class may define a "default property" using the @DefaultProperty annotation defined in the javafx.beans package. If present, the sub-element representing the default property can be omitted from the markup.

For example, since javafx.scene.layout.Pane (the superclass of javafx.scene.layout.VBox) defines a default property of "children", a <children> element is not required; the loader will automatically add the sub-elements of the VBox to the container's "children" collection:

<?import javafx.scene.*?>
<?import javafx.scene.shape.*?>
<VBox xmlns:fx="http://javafx.com/fxml">
    <Button text="Click Me!"/>
    ...
</VBox>

Note that default properties are not limited to collections. If an element's default property refers to a scalar value, any sub-element of that element will be set as the value of the property.

For example, since javafx.scene.control.ScrollPane defines a default property of "content", a scroll pane containing a TextArea as its content can be specified as follows:

<ScrollPane>
    <TextArea text="Once upon a time..."/>
</ScrollPane>

Taking advantage of default properties can significantly reduce the verbosity of FXML markup.

Static Properties

An element may also represent a "static" property (sometimes called an "attached property"). Static properties are properties that only make sense in a particular context. They are not intrinsic to the class to which they are applied, but are defined by another class (often, the parent container of a control).

Static properties are prefixed with the name of class that defines them. For example, The following FXML invokes the static setter for GridPane's "rowIndex" and "columnIndex" properties:

<GridPane>
    <children>
        <Label text="My Label">
            <GridPane.rowIndex>0</GridPane.rowIndex>
       <GridPane.columnIndex>0</GridPane.columnIndex>
        </Label>
    </children>
</TabPane>

This translates roughly to the following in Java:

GridPane gridPane = new GridPane();

Label label = new Label();
label.setText("My Label");

GridPane.setRowIndex(label, 0);
GridPane.setColumnIndex(label, 0);

gridPane.getChildren().add(label);

The calls to GridPane#setRowIndex() and GridPane#setColumnIndex() "attach" the index data to the Label instance. GridPane then uses these during layout to arrange its children appropriately. Other containers, including AnchorPane, BorderPane, and StackPane, define similar properties.

As with instance properties, static property elements are generally used when the property value cannot be efficiently represented by an attribute value. Otherwise, static property attributes (discussed in a later section) will generally produce more concise and readable markup.

Define Blocks

The <fx:define> element is used to create objects that exist outside of the object hierarchy but may need to be referred to elsewhere.

For example, when working with radio buttons, it is common to define a ToggleGroup that will manage the buttons' selection state. This group is not part of the scene graph itself, so should not be added to the buttons' parent. A define block can be used to create the button group without interfering with the overall structure of the document:

<VBox>
    <fx:define>
        <ToggleGroup fx:id="myToggleGroup"/>
    </fx:define>
    <children>
        <RadioButton text="A" toggleGroup="$myToggleGroup"/>
        <RadioButton text="B" toggleGroup="$myToggleGroup"/>
        <RadioButton text="C" toggleGroup="$myToggleGroup"/>
    </children>
</VBox>

Elements in define blocks are usually assigned an ID that can be used to refer to the element's value later. IDs are discussed in more detail in later sections.

Attributes

An attribute in FXML may represent one of the following:

  • A property of a class instance
  • A "static" property
  • An event handler

Each are discussed in more detail in the following sections.

Instance Properties

Like property elements, attributes can also be used to configure the properties of a class instance. For example, the following markup creates a Button whose text reads "Click Me!":

<?import javafx.scene.control.*?>
<Button text="Click Me!"/>

As with property elements, property attributes support type coercion. When the following markup is processed, the "x", "y", "width", and "height" values will be converted to doubles, and the "fill" value will be converted to a Color:

<Rectangle fx:id="rectangle" x="10" y="10" width="320" height="240"
    fill="#ff0000"/>

Unlike property elements, which are applied as they are processed, property attributes are not applied until the closing tag of their respective element is reached. This is done primarily to facilitate the case where an attribute value depends on some information that won't be available until after the element's content has been completely processed (for example, the selected index of a TabPane control, which can't be set until all of the tabs have been added).

Another key difference between property attributes and property elements in FXML is that attributes support a number of "resolution operators" that extend their functionality. The following operators are supported and are discussed in more detail below:

  • Location resolution
  • Resource resolution
  • Variable resolution

Location Resolution

As strings, XML attributes cannot natively represent typed location information such as a URL. However, it is often necessary to specify such locations in markup; for example, the source of an image resource. The location resolution operator (represented by an "@" prefix to the attribute value) is used to specify that an attribute value should be treated as a location relative to the current file rather than a simple string.

For example, the following markup creates an ImageView and populates it with image data from my_image.png, which is assumed to be located at a path relative to the current FXML file:

<ImageView>
    <image>
        <Image url="@my_image.png"/>
    </image>
</ImageView>

Since Image is an immutable object, a builder is required to construct it. Alternatively, if Image were to define a valueOf(URL) factory method, the image view could be populated as follows:

<ImageView image="@my_image.png"/>

The value of the "image" attribute would be converted to a URL by the FXML loader, then coerced to an Image using the valueOf() method.

Note that whitespace values in the URL must be encoded; for example, to refer to a file named "My Image.png", the FXML document should contain the following:

<Image url="@My%20Image.png"/>

rather than:

<Image url="@My Image.png"/>

Resource Resolution

In FXML, resource substitution can be performed at load time for localization purposes. When provided with an instance of java.util.ResourceBundle, the FXML loader will replace instances of resource names with their locale-specific values. Resource names are identified by a "%" prefix, as shown below:

<Label text="%myText"/>

If the loader is given a resource bundle defined as follows:

myText = This is the text!

the output of the FXML loader would be a Label instance containing the text "This is the text!".

Variable Resolution

An FXML document defines a variable namespace in which named elements and script variables may be uniquely identified. The variable resolution operator allows a caller to replace an attribute value with an instance of a named object before the corresponding setter method is invoked. Variable references are identified by a "$" prefix, as shown below:

<fx:define>
    <ToggleGroup fx:id="myToggleGroup"/>
</fx:define>
...
<RadioButton text="A" toggleGroup="$myToggleGroup"/>
<RadioButton text="B" toggleGroup="$myToggleGroup"/>
<RadioButton text="C" toggleGroup="$myToggleGroup"/>

Assigning an fx:id value to an element creates a variable in the document's namespace that can later be referred to by variable dereference attributes, such as the "toggleGroup" attribute shown above, or in script code, discussed in a later section. Additionally, if the object's type defines an "id" property, this value will also be passed to the objects setId() method.

Escape Sequences

If the value of an attribute begins with one of the resource resolution prefixes, the character can be escaped by prepending it with a leading backslash ("\") character. For example, the following markup creates a Label instance whose text reads "$10.00":

<Label text="\$10.00"/>

Expression Binding

Attribute variables as shown above are resolved once at load time. Later updates to the variables value are not automatically reflected in any properties to which the value was assigned. In many cases, this is sufficient; however, it is often convenient to "bind" a property value to a variable or expression such that changes to the variable are automatically propagated to the target property. Expression bindings can be used for this purpose.

An expression binding also begins with the variable resolution operator, but is followed by a set of curly braces which wrap the expression value. For example, the following markup binds the value of a text input's "text" property to the "text" property of a Label instance:

<TextField fx:id="textField"/>
<Label text="${textField.text}"/>

As the user types in the text input, the label's text content will be automatically updated.

More complex expression are also supported. A list of supported constants and operators follows:

Constants and Operators Table
"string" 'string' | A string constant
true false | A boolean constant
null | A constant representing the null value
50.0 3e5 42 | A numerical constant
- (unary operator) | Unary minus operator, applied on a number
! (unary operator) | Unary negation of a boolean
+ - * / % | Numerical binary operators
&& || | Boolean binary operators
> >= < <= == != | Binary operators of comparison. Both arguments must be of type Comparable

Static Properties

Attributes representing static properties are handled similarly to static property elements and use a similar syntax. For example, the earlier GridPane markup shown earlier to demonstrate static property elements could be rewritten as follows:

<GridPane>
    <children>
        <Label text="My Label" GridPane.rowIndex="0" GridPane.columnIndex="0"/>
    </children>
</TabPane>

In addition to being more concise, static property attributes, like instance property attributes, support location, resource, and variable resolution operators, the only limitation being that it is not possible to create an expression binding to a static property.

Event Handlers

Event handler attributes are a convenient means of attaching behaviors to document elements. Any class that defines a setOnEvent() method can be assigned an event handler in markup.

FXML supports three types of event handler attributes: script event handlers, controller method event handlers and expressions. Each are discussed below.

Script Event Handlers

A script event handler is an event handler that executes script code when the event is fired, similar to event handlers in HTML. For example, the following script-based handler for the button's "onAction" event uses JavaScript to write the text "You clicked me!" to the console when the user presses the button:

<?language javascript?>
...

<VBox>
    <children>
        <Button text="Click Me!"
            onAction="java.lang.System.out.println('You clicked me!');"/>
    </children>
</VBox>

Note the use of the language processing instruction at the beginning of the code snippet. This PI tells the FXML loader which scripting language should be used to execute the event handler. A page language must be specified whenever inline script is used in an FXML document, and can only be specified once per document. However, this does not apply to external scripts, which may be implemented using any number of supported scripting languages. Scripting is discussed in more detail in the next section.

Controller Method Event Handlers

A controller method event handler is a method defined by a document's "controller". A controller is an object that is associated with the deserialized contents of an FXML document and is responsible for coordinating the behaviors of the objects (often user interface elements) defined by the document.

A controller method event handler is specified by a leading hash symbol followed by the name of the handler method. For example:

<VBox fx:controller="com.foo.MyController"
    xmlns:fx="http://javafx.com/fxml">
    <children>
        <Button text="Click Me!" onAction="#handleButtonAction"/>
    </children>
</VBox>

Note the use of the fx:controller attribute on the root element. This attribute is used to associate a controller class with the document. If MyController is defined as follows:

package com.foo;

public class MyController {
    public void handleButtonAction(ActionEvent event) {
        System.out.println("You clicked me!");
    }
}

the handleButtonAction() will be called when the user presses the button, and the text "You clicked me!" will be written to the console.

In general, a handler method should conform to the signature of a standard event handler; that is, it should take a single argument of a type that extends javafx.event.Event and should return void (similar to an event delegate in C#). The event argument often carries important and useful information about the nature of the event; however, it is optional and may be omitted if desired. So this is also a valid handler:

package com.foo;

public class MyController {
    public void handleButtonAction() {
        System.out.println("You clicked me!");
    }
}

Controllers are discussed in more detail in a later section.

Event handlers from expressions

Any expression that point to a variable of javafx.event.EventHandler type can be used as an expression handler.

Previous example using an expression handler:

<VBox fx:controller="com.foo.MyController"
    xmlns:fx="http://javafx.com/fxml">
    <children>
        <Button text="Click Me!" onAction="$controller.onActionHandler"/>
    </children>
</VBox>

With the controller that contains a field like this

public class MyController {

    @FXML
    public EventHandler<ActionEvent> onActionHandler = new EventHandler<>() { ... }

    ...
}

Note that other kinds of expressions, like binding expressions are not supported in this context.

Special handlers for collections and properties

Collections and object properties cannot be listen to using setOnEvent() methods. For these reason, special handler methods need to be used. ObservableList, ObservableMap or ObservableSet uses a special onChange attribute that points to a handler method with a ListChangeListner.Change, MapChangeListener.Change or SetChangeListener.Change parameter respectively.

<VBox fx:controller="com.foo.MyController"
    xmlns:fx="http://javafx.com/fxml">
    <children onChange="#handleChildrenChange"/>
</VBox>
where the handler method looks like this:
package com.foo;

import javafx.collections.ListChangeListener.Change;

public class MyController {
    public void handleChildrenChange(ListChangeListener.Change c) {
        System.out.println("Children changed!");
    }
}

Similarly, the property handlers are methods that have the same parameters as changed method of ChangeListener :

changed(ObservableValue<? extends T> observable, T oldValue, T newValue)

A handler for parent property would look like this

public class MyController {
    public void handleParentChange(ObservableValue value, Parent oldValue, Parent newValue) {
        System.out.println("Parent changed!");
    }
}

For convenience, the first parameter can be a subclass of ObservableValue, e.g. Property

For registering to a property, a special on<propertyName>Change attribute must be used.

<VBox fx:controller="com.foo.MyController"
    xmlns:fx="http://javafx.com/fxml" onParentChange="#handleParentChange"/>

Note that collections and properties do not currently support scripting handlers.

Scripting

The <fx:script> tag allows a caller to import scripting code into or embed script within a FXML file. Any JVM scripting language can be used, including JavaScript, Groovy, and Clojure, among others. Script code is often used to define event handlers directly in markup or in an associated source file, since event handlers can often be written more concisely in more loosely-typed scripting languages than they can in a statically-typed language such as Java.

For example, the following markup defines a function called handleButtonAction() that is called by the action handler attached to the Button element:

<?language javascript?>

<?import javafx.scene.control.*?>
<?import javafx.scene.layout.*?>

<VBox xmlns:fx="http://javafx.com/fxml">
    <fx:script>

    function handleButtonAction(event) {
       java.lang.System.out.println('You clicked me!');
    }
    </fx:script>

    <children>
        <Button text="Click Me!" onAction="handleButtonAction(event);"/>
    </children>
</VBox>

Clicking the button triggers the event handler, which invokes the function, producing output identical to the previous examples.

Script code may also be defined in external files. The previous example could be split into an FXML file and a JavaScript source file with no difference in functionality:

example.fxml
<?import javafx.scene.control.*?>
<?import javafx.scene.layout.*?>

<VBox xmlns:fx="http://javafx.com/fxml">
    <fx:script source="example.js" charset="cp1252"/>

    <children>
        <Button text="Click Me!" onAction="handleButtonAction(event);"/>
    </children>
</VBox>
example.js

function handleButtonAction(event) {
   java.lang.System.out.println('You clicked me!');
}

It is often preferable to separate code from markup in this way, since many text editors support syntax highlighting for the various scripting languages supported by the JVM. It can also help improve readability of the source code and markup.

Note that script blocks are not limited to defining event handler functions. Script code is executed as it is processed, so it can also be used to dynamically configure the structure of the resulting output. As a simple example, the following FXML includes a script block that defines a variable named "labelText". The value of this variable is used to populate the text property of a Label instance:

<fx:script>
var myText = "This is the text of my label.";
</fx:script>

...

<Label text="$myText"/>

Warning:As of JavaFX 8, importClass() javascript function is no longer supported. You have to use fully qualified names as in the example above or load a nashorn compatibility script.

load("nashorn:mozilla_compat.js");
importClass(java.lang.System);

function handleButtonAction(event) {
   System.out.println('You clicked me!');
}

Controllers

While it can be convenient to write simple event handlers in script, either inline or defined in external files, it is often preferable to define more complex application logic in a compiled, strongly-typed language such as Java. As discussed earlier, the fx:controller attribute allows a caller to associate a "controller" class with an FXML document. A controller is a compiled class that implements the "code behind" the object hierarchy defined by the document.

As shown earlier, controllers are often used to implement event handlers for user interface elements defined in markup:

<VBox fx:controller="com.foo.MyController"
    xmlns:fx="http://javafx.com/fxml">
    <children>
        <Button text="Click Me!" onAction="#handleButtonAction"/>
    </children>
</VBox>

package com.foo;

public class MyController {
    public void handleButtonAction(ActionEvent event) {
        System.out.println("You clicked me!");
    }
}

In many cases, it is sufficient to simply declare event handlers in this manner. However, when more control over the behavior of the controller and the elements it manages is required, the controller can define an initialize() method, which will be called once on an implementing controller when the contents of its associated document have been completely loaded:

public void initialize();

This allows the implementing class to perform any necessary post-processing on the content. It also provides the controller with access to the resources that were used to load the document and the location that was used to resolve relative paths within the document (commonly equivalent to the location of the document itself).

For example, the following code defines an initialize() method that attaches an action handler to a button in code rather than via an event handler attribute, as was done in the previous example. The button instance variable is injected by the loader as the document is read. The resulting application behavior is identical:

<VBox fx:controller="com.foo.MyController"
    xmlns:fx="http://javafx.com/fxml">
    <children>
        <Button fx:id="button" text="Click Me!"/>
    </children>
</VBox>

package com.foo;

public class MyController implements Initializable {
    public Button button;

    @Override
    public void initialize(URL location, Resources resources)
        button.setOnAction(new EventHandler<ActionEvent>() {
            @Override
            public void handle(ActionEvent event) {
                System.out.println("You clicked me!");
            }
        });
    }
}

@FXML

Note that, in the previous examples, the controller member fields and event handler methods were declared as public so they can be set or invoked by the loader. In practice, this is not often an issue, since a controller is generally only visible to the FXML loader that creates it. However, for developers who prefer more restricted visibility for controller fields or handler methods, the javafx.fxml.FXML annotation can be used. This annotation marks a protected or private class member as accessible to FXML. If the class being annotated is in a named module, the module containing that class must open the containing package to at least the javafx.fxml module.

For example, the controllers from the previous examples could be rewritten as follows:

package com.foo;

public class MyController {
    @FXML
    private void handleButtonAction(ActionEvent event) {
        System.out.println("You clicked me!");
    }
}

package com.foo;

public class MyController implements Initializable {
    @FXML private Button button;

    @FXML
    protected void initialize()
        button.setOnAction(new EventHandler<ActionEvent>() {
            @Override
            public void handle(ActionEvent event) {
                System.out.println("You clicked me!");
            }
        });
    }
}

In the first version, the handleButtonAction() is tagged with @FXML to allow markup defined in the controller's document to invoke it. In the second example, the button field is annotated to allow the loader to set its value. The initialize() method is similarly annotated.

Nested Controllers

Controller instances for nested FXML documents loaded via the <fx:include> element are mapped directly to member fields of the including controller. This allows a developer to easily access functionality defined by an include (such as a dialog window presented by an application's main window controller). For example, given the following code:

main_window_content.fxml
<VBox fx:controller="com.foo.MainController">
   <fx:define>
      <fx:include fx:id="dialog" source="dialog.fxml"/>
   </fx:define>
   ...
</VBox>
MainController.java
public class MainController extends Controller {
    @FXML private Window dialog;
    @FXML private DialogController dialogController;

    ...
}

when the controller's initialize() method is called, the dialog field will contain the root element loaded from the "dialog.fxml" include, and the dialogController field will contain the include's controller. The main controller can then invoke methods on the included controller, to populate and show the dialog, for example. Note that as the content of the file referenced by fx:include otherwise would become part of the scene graph spanned from main_window_content.fxml, it is necessary to wrap fx:include by fx:define to separate the scene graphs of both windows.

FXMLLoader

The FXMLLoader class is responsible for actually loading an FXML source file and returning the resulting object graph. For example, the following code loads an FXML file from a location on the classpath relative to the loading class and localizes it with a resource bundle named "com.foo.example". The type of the root element is assumed to be a subclass of javafx.scene.layout.Pane, and the document is assumed to define a controller of type MyController:

URL location = getClass().getResource("example.fxml");
ResourceBundle resources = ResourceBundle.getBundle("com.foo.example");
FXMLLoader fxmlLoader = new FXMLLoader(location, resources);

Pane root = (Pane)fxmlLoader.load();
MyController controller = (MyController)fxmlLoader.getController();

Note that the output of an FXMLLoader#load() operation is an instance hierarchy that reflects the actual named classes in the document, not org.w3c.dom nodes representing those classes. Internally, FXMLLoader uses the javax.xml.stream API (also known as the Streaming API for XML, or StAX) to load an FXML document. StAX is an extremely efficient event-based XML parsing API that is conceptually similar to its W3C predecessor, SAX. It allows an FXML document to be processed in a single pass, rather than loaded into an intermediate DOM structure and then post-processed.

Custom Components

The setRoot() and setController() methods of FXMLLoader allow a caller to inject document root and controller values, respectively, into the document namespace, rather than delegating creation of these values to FXMLLoader itself. This allows a developer to easily create reusable controls that are internally implemented using markup, but (from an API perspective) appear identically to controls implemented programmatically.

For example, the following markup defines the structure of a simple custom control containing a TextField and a Button instance. The root container is defined as an instance of javafx.scene.layout.VBox:

<?import javafx.scene.*?>
<?import javafx.scene.control.*?>
<?import javafx.scene.layout.*?>

<fx:root type="javafx.scene.layout.VBox" xmlns:fx="http://javafx.com/fxml">
    <TextField fx:id="textField"/>
    <Button text="Click Me" onAction="#doSomething"/>
</fx:root>

As mentioned earlier, the <fx:root> tag creates a reference to a previously defined root element. The value of this element is obtained by calling the getRoot() method of FXMLLoader. Prior to calling load(), the caller must specify this value via a call to setRoot(). The caller may similarly provide a value for the document's controller by calling setController(), which sets the value that will be used as the document's controller when the document is read. These two methods are commonly used together when creating custom FXML-based components.

In the following example, the CustomControl class extends VBox (the type declared by the <fx:root> element), and sets itself as both the root and controller of the FXML document in its constructor. When the document is loaded, the contents of CustomControl will be populated with the contents of the previous FXML document:

package fxml;

import java.io.IOException;

import javafx.beans.property.StringProperty;
import javafx.fxml.FXML;
import javafx.fxml.FXMLLoader;
import javafx.scene.control.TextField;
import javafx.scene.layout.VBox;

public class CustomControl extends VBox {
    @FXML private TextField textField;

    public CustomControl() {
        FXMLLoader fxmlLoader = new FXMLLoader(getClass().getResource("custom_control.fxml"));
        fxmlLoader.setRoot(this);
        fxmlLoader.setController(this);

        try {
            fxmlLoader.load();
        } catch (IOException exception) {
            throw new RuntimeException(exception);
        }
    }

    public String getText() {
        return textProperty().get();
    }

    public void setText(String value) {
        textProperty().set(value);
    }

    public StringProperty textProperty() {
        return textField.textProperty();
    }

    @FXML
    protected void doSomething() {
        System.out.println("The button was clicked!");
    }
}

Now, callers can use instances of this control in code or in markup, just like any other control; e.g.:

Java
HBox hbox = new HBox();
CustomControl customControl = new CustomControl();
customControl.setText("Hello World!");
hbox.getChildren().add(customControl);
FXML
<HBox>
    <CustomControl text="Hello World!"/>
</HBox>

Deploying an Application as a Module

If FXMLLoader is used to load types in a named module, the application must ensure that all types that are referenced in the FXML files, including the controller class and any custom Node classes, are reflectively accessible to the javafx.fxml module. A type is reflectively accessible if the module opens the containing package to at least the javafx.fxml module.

For example, if com.foo.MyController is in the foo.app module, the module-info.java might look like this:

module foo.app {
    opens com.foo to javafx.fxml;
}

Alternatively, a type is reflectively accessible if the module exports the containing package unconditionally.

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 2008, 2017, Oracle and/or its affiliates. All rights reserved.
DRAFT 9-ea


BoundingBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Class BoundingBox

  • java.lang.Object
    • javafx.geometry.Bounds
      • javafx.geometry.BoundingBox

  • public class BoundingBox
extends Bounds
    一个矩形边框，用于描述节点或其他场景图对象的界限。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      BoundingBox​(double minX, double minY, double width, double height)
      创建一个新的2D BoundingBox实例。
      BoundingBox​(double minX, double minY, double minZ, double width, double height, double depth)
      创建一个新的3D实例 BoundingBox 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean contains​(double x, double y)
      测试指定的 (x, y)坐标是否在 Bounds的边界内。
      boolean contains​(double x, double y, double z)
      测试指定的 (x, y, z)坐标是否在 Bounds的边界内。
      boolean contains​(double x, double y, double w, double h)
      测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。
      boolean contains​(double x, double y, double z, double w, double h, double d)
      测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。
      boolean contains​(Bounds b)
      测试这个 Bounds的内部 Bounds完全包含指定的边界， b 。
      boolean contains​(Point2D p)
      测试指定点是否在 Bounds的边界内。
      boolean contains​(Point3D p)
      测试指定点是否在 Bounds的边界内。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      int hashCode​()
      返回对象的哈希码值。
      boolean intersects​(double x, double y, double w, double h)
      测试此 Bounds的内部是否与指定矩形区域的内部相交。
      boolean intersects​(double x, double y, double z, double w, double h, double d)
      测试这个 Bounds的内部是否与指定的矩形区域的内部相交。
      boolean intersects​(Bounds b)
      测试这个 Bounds的内部是否与指定的边界 b的内部相交。
      boolean isEmpty​()
      指示此边界的任何尺寸（宽度，高度或深度）是否小于零。
      String toString​()
      返回此 BoundingBox的字符串表示 BoundingBox 。

      • Methods inherited from class javafx.geometry.Bounds

        getDepth, getHeight, getMaxX, getMaxY, getMaxZ, getMinX, getMinY, getMinZ, getWidth

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BoundingBox

        public BoundingBox​(double minX,
                   double minY,
                   double minZ,
                   double width,
                   double height,
                   double depth)
        创建一个新的3D实例 BoundingBox 。
        参数
        minX - 左上角的X坐标
        minY - 左上角的Y坐标
        minZ -最小的Z坐标 BoundingBox
        width - 宽度为 BoundingBox
        height - 高度的 BoundingBox
        depth - 深度的 BoundingBox

      • BoundingBox

        public BoundingBox​(double minX,
                   double minY,
                   double width,
                   double height)
        创建一个新的2D BoundingBox实例。
        参数
        minX - 左上角的X坐标
        minY - 左上角的Y坐标
        width - 宽度为 BoundingBox
        height -的高度 BoundingBox

    • 方法详细信息

      • isEmpty

        public boolean isEmpty​()
        指示此边界的任何尺寸（宽度，高度或深度）是否小于零。
        Specified by:
        isEmpty在 Bounds
        结果
        如果此边界的任何尺寸（宽度，高度或深度）小于零，则为真

      • contains

        public boolean contains​(Point2D p)
        测试指定点是否在Bounds的边界内。 边界上的点被认为在BoundingBox 。
        Specified by:
        contains在 Bounds
        参数
        p - 要测试的指定点
        结果
        如果指定点在该Bounds的边界内， Bounds ; 否则为假

      • contains

        public boolean contains​(Point3D p)
        测试指定点是否在Bounds的边界内。 边界上的点被认为在BoundingBox 。
        Specified by:
        contains在 Bounds
        参数
        p - 要测试的指定3D点
        结果
        如果指定点在该Bounds的边界内， Bounds ; 否则为假

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的(x, y)坐标是否在Bounds的边界内。 边界上的点被认为在BoundingBox 。
        Specified by:
        contains在 Bounds
        参数
        x - 要测试的指定x坐标
        y - 要测试的指定y坐标
        结果
        如果指定的(x, y)坐标在这个Bounds的边界内， Bounds ; 否则为假

      • contains

        public boolean contains​(double x,
                        double y,
                        double z)
        测试指定的(x, y, z)坐标是否在Bounds的边界内。 边界上的点被认为在BoundingBox 。
        Specified by:
        contains在 Bounds
        参数
        x - 要测试的指定x坐标
        y - 要测试的指定y坐标
        z - 要测试的指定的z坐标
        结果
        如果指定的(x, y)坐标在这个Bounds的边界内， Bounds ; 否则为假

      • contains

        public boolean contains​(Bounds b)
        测试这个Bounds的内部Bounds完全包含指定的边界， b 。 边界上的点被认为在BoundingBox 。
        Specified by:
        contains在 Bounds
        参数
        b - 指定的边界
        结果
        如果指定的边界（ b ）在该Bounds的边界内， Bounds ; 否则为假

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试这个Bounds的内部Bounds完全包含指定的矩形区域。 边界上的点被认为在BoundingBox 。
        Specified by:
        contains在 Bounds
        参数
        x - 指定矩形区域左上角的x坐标
        y - 指定矩形区域左上角的y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        如果这个Bounds的内部完全包含指定的矩形区域， Bounds true; 否则为假

      • contains

        public boolean contains​(double x,
                        double y,
                        double z,
                        double w,
                        double h,
                        double d)
        测试这个Bounds的内部Bounds完全包含指定的矩形区域。 边界上的点被认为在BoundingBox 。
        Specified by:
        contains在 Bounds
        参数
        x - 指定矩形体积左上角的x坐标
        y - 指定矩形体积左上角的y坐标
        z - 指定矩形体积左上角的z坐标
        w - 指定矩形体的宽度
        h - 指定矩形体的高度
        d - 指定矩形体积的深度
        结果
        如果这个Bounds的内部完全包含指定的矩形区域， Bounds true; 否则为假

      • intersects

        public boolean intersects​(Bounds b)
        测试这个 Bounds的内部是否与指定的边界（ b的内部相交。
        Specified by:
        intersects在 Bounds
        参数
        b - 指定的边界
        结果
        如果这个 Bounds的内部和指定的边界的内部， b相交， b

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试这个 Bounds的内部是否与指定的矩形区域的内部相交。
        Specified by:
        intersects在 Bounds
        参数
        x - 指定矩形区域左上角的x坐标
        y - 指定矩形区域左上角的y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        如果这个 Bounds的内部和矩形区域的内部相交， Bounds true

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double z,
                          double w,
                          double h,
                          double d)
        测试这个 Bounds的内部是否与指定的矩形区域的内部相交。
        Specified by:
        intersects在 Bounds
        参数
        x - 指定矩形体积左上角的x坐标
        y - 指定矩形体积左上角的y坐标
        z - 指定矩形体积左上角的z坐标
        w - 指定矩形体的宽度
        h - 指定矩形体的高度
        d - 指定矩形体积的深度
        结果
        如果这个 Bounds的内部和矩形区域的内部相交， Bounds true

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象
        结果
        如果此对象与obj参数相同，则为true; 否则为假
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。
        重写：
        hashCode在 Object
        结果
        对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此BoundingBox的字符串表示BoundingBox 。 此方法仅用于信息目的。 返回的字符串的内容和格式可能在实现之间getMary。 返回的字符串可能为空，但不能为null 。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Bounds (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Class Bounds

  • java.lang.Object
    • javafx.geometry.Bounds
  • 已知直接子类：
    BoundingBox

    public abstract class Bounds
extends Object
    用于描述节点或其他场景图形对象边界的对象的基类。 Bounds对象的一个有趣特征是它可能具有负宽度，高度或深度。 任何一个的负值表示边界是“空”。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Bounds​(double minX, double minY, double minZ, double width, double height, double depth)
      创建一个新的 Bounds课程。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract boolean contains​(double x, double y)
      测试指定的 (x, y)坐标是否在 Bounds的边界内。
      abstract boolean contains​(double x, double y, double z)
      测试指定的 (x, y, z)坐标是否在 Bounds的边界内。
      abstract boolean contains​(double x, double y, double w, double h)
      测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。
      abstract boolean contains​(double x, double y, double z, double w, double h, double d)
      测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。
      abstract boolean contains​(Bounds b)
      测试这个 Bounds的内部 Bounds完全包含指定的边界， b 。
      abstract boolean contains​(Point2D p)
      测试指定点是否在 Bounds的边界内。
      abstract boolean contains​(Point3D p)
      测试指定点是否在 Bounds的边界内。
      double getDepth​()
      这个深度 Bounds 。
      double getHeight​()
      这个高度这个 Bounds 。
      double getMaxX​()
      这个 Bounds右下角的x坐标。
      double getMaxY​()
      这个 Bounds右下角的y坐标。
      double getMaxZ​()
      该最大z坐标为 Bounds 。
      double getMinX​()
      这个 Bounds左上角的x坐标。
      double getMinY​()
      这个 Bounds左上角的y坐标。
      double getMinZ​()
      这个 Bounds的最小z坐标。
      double getWidth​()
      该宽度为 Bounds 。
      abstract boolean intersects​(double x, double y, double w, double h)
      测试这个 Bounds的内部是否与指定的矩形区域的内部相交。
      abstract boolean intersects​(double x, double y, double z, double w, double h, double d)
      测试这个 Bounds的内部是否与指定的矩形区域的内部相交。
      abstract boolean intersects​(Bounds b)
      测试这个 Bounds的内部是否与指定边界的内部相交， b 。
      abstract boolean isEmpty​()
      指示此边界的任何尺寸（宽度，高度或深度）是否小于零。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Bounds

        protected Bounds​(double minX,
                 double minY,
                 double minZ,
                 double width,
                 double height,
                 double depth)
        创建一个新的 Bounds类的实例。
        参数
        minX - 左上角的X坐标
        minY - 左上角的Y坐标
        minZ -最小的Z坐标 Bounds
        width - 宽度为 Bounds
        height -的高度 Bounds
        depth - 深度的 Bounds

    • 方法详细信息

      • getMinX

        public final double getMinX​()
        这个 Bounds左上角的x坐标。
        Default value:
        0.0
        结果
        左上角的x坐标

      • getMinY

        public final double getMinY​()
        这个 Bounds左上角的y坐标。
        Default value:
        0.0
        结果
        左上角的y坐标

      • getMinZ

        public final double getMinZ​()
        这个 Bounds的最小z坐标。
        Default value:
        0.0
        结果
        最小z坐标

      • getWidth

        public final double getWidth​()
        这个宽度 Bounds 。
        Default value:
        0.0
        结果
        宽度

      • getHeight

        public final double getHeight​()
        这个高度这个 Bounds 。
        Default value:
        0.0
        结果
        高度

      • getDepth

        public final double getDepth​()
        这个深度 Bounds 。
        Default value:
        0.0
        结果
        深度

      • getMaxX

        public final double getMaxX​()
        这个 Bounds右下角的x坐标。
        Default value:
        minX + width
        结果
        右下角的x坐标

      • getMaxY

        public final double getMaxY​()
        这个 Bounds右下角的y坐标。
        Default value:
        minY + height
        结果
        右下角的y坐标

      • getMaxZ

        public final double getMaxZ​()
        这个 Bounds的最大z坐标。
        Default value:
        minZ + depth
        结果
        最大z坐标

      • isEmpty

        public abstract boolean isEmpty​()
        指示此边界的任何尺寸（宽度，高度或深度）是否小于零。
        结果
        如果此边界的任何尺寸（宽度，高度或深度）小于零，则为真

      • contains

        public abstract boolean contains​(Point2D p)
        测试指定点是否在 Bounds的边界内。
        参数
        p - 要测试的指定点
        结果
        如果指定点在此Bounds的边界内， Bounds ; 否则为假

      • contains

        public abstract boolean contains​(Point3D p)
        测试指定点是否在 Bounds的边界内。
        参数
        p - 要测试的指定3D点
        结果
        如果指定点在此Bounds的边界内， Bounds ; 否则为假

      • contains

        public abstract boolean contains​(double x,
                                 double y)
        测试指定的 (x, y)坐标是否在 Bounds的边界内。
        参数
        x - 要测试的指定x坐标
        y - 要测试的指定的y坐标
        结果
        如果指定的(x, y)坐标在这个Bounds的边界内， Bounds ; 否则为假

      • contains

        public abstract boolean contains​(double x,
                                 double y,
                                 double z)
        测试指定的 (x, y, z)坐标是否在 Bounds的边界内。
        参数
        x - 要测试的指定x坐标
        y - 要测试的指定y坐标
        z - 要测试的指定z坐标
        结果
        如果指定的(x, y)坐标在这个Bounds的边界内， Bounds ; 否则为假

      • contains

        public abstract boolean contains​(Bounds b)
        测试这个 Bounds的内部 Bounds完全包含指定的边界， b 。
        参数
        b - 指定的边界
        结果
        如果指定的边界（ b ）在该Bounds的边界内， Bounds ; 否则为假

      • contains

        public abstract boolean contains​(double x,
                                 double y,
                                 double w,
                                 double h)
        测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。
        参数
        x - 指定矩形区域左上角的x坐标
        y - 指定矩形区域左上角的y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        如果内部这个Bounds完全包含指定的矩形区域， Bounds true; 否则为假

      • contains

        public abstract boolean contains​(double x,
                                 double y,
                                 double z,
                                 double w,
                                 double h,
                                 double d)
        测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。
        参数
        x - 指定矩形体积左上角的x坐标
        y - 指定矩形体积左上角的y坐标
        z - 指定矩形体积左上角的z坐标
        w - 指定矩形体的宽度
        h - 指定矩形体的高度
        d - 指定矩形体积的深度
        结果
        如果这个Bounds的内部完全包含指定的矩形区域， Bounds true; 否则为假

      • intersects

        public abstract boolean intersects​(Bounds b)
        测试这个 Bounds的内部是否与指定的边界（ b的内部相交。
        参数
        b - 指定的边界
        结果
        如果这个 Bounds的内部和指定的边界的内部， b相交， b

      • intersects

        public abstract boolean intersects​(double x,
                                   double y,
                                   double w,
                                   double h)
        测试这个 Bounds的内部是否与指定的矩形区域的内部相交。
        参数
        x - 指定矩形区域左上角的x坐标
        y - 指定矩形区域左上角的y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        如果这个 Bounds的内部和矩形区域的内部相交， Bounds true

      • intersects

        public abstract boolean intersects​(double x,
                                   double y,
                                   double z,
                                   double w,
                                   double h,
                                   double d)
        测试这个 Bounds的内部是否与指定的矩形区域的内部相交。
        参数
        x - 指定矩形体积左上角的x坐标
        y - 指定矩形体积左上角的y坐标
        z - 指定矩形体积左上角的z坐标
        w - 指定矩形体的宽度
        h - 指定矩形体的高度
        d - 指定矩形体积的深度
        结果
        true if the interior of this Bounds and the interior of the rectangular area intersect
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Dimension2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Class Dimension2D

  • java.lang.Object
    • javafx.geometry.Dimension2D

  • public class Dimension2D
extends Object
    包含宽度和高度的2D维度对象。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      Dimension2D​(double width, double height)
      构造具有指定宽度和高度的 Dimension2D 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      double getHeight​()
      尺寸的高度。
      double getWidth​()
      尺寸的宽度。
      int hashCode​()
      返回Dimension2D对象的哈希码值。
      String toString​()
      返回此 Dimension2D的字符串表示 Dimension2D 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Dimension2D

        public Dimension2D​(double width,
                   double height)
        构造具有指定宽度和高度的 Dimension2D 。
        参数
        width - 宽度
        height - 高度

    • 方法详细信息

      • getWidth

        public final double getWidth​()
        尺寸的宽度。
        结果
        尺寸的宽度

      • getHeight

        public final double getHeight​()
        尺寸的高度。
        结果
        尺寸的高度

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象
        结果
        如果此Dimension2D实例与obj参数相同，则为true; 否则为假
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回Dimension2D对象的哈希码值。
        重写：
        hashCode在 Object
        结果
        Dimension2D对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此Dimension2D的字符串表示Dimension2D 。 此方法仅用于信息目的。 返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但不能为null 。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HorizontalDirection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Enum HorizontalDirection

  • java.lang.Object
    • java.lang.Enum<HorizontalDirection>
      • javafx.geometry.HorizontalDirection
  • All Implemented Interfaces:
    Serializable ， Comparable<HorizontalDirection>

    public enum HorizontalDirection
extends Enum<HorizontalDirection>
    表示水平方向的枚举。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      LEFT
      向左的方向
      RIGHT
      向右的方向

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static HorizontalDirection valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HorizontalDirection[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LEFT

        public static final HorizontalDirection LEFT
        向左的方向

      • RIGHT

        public static final HorizontalDirection RIGHT
        向右的方向

    • 方法详细信息

      • values

        public static HorizontalDirection[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (HorizontalDirection c : HorizontalDirection.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static HorizontalDirection valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


HPos (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Enum HPos

  • java.lang.Object
    • java.lang.Enum<HPos>
      • javafx.geometry.HPos
  • All Implemented Interfaces:
    Serializable ， Comparable<HPos>

    public enum HPos
extends Enum<HPos>
    用于描述水平定位和对齐的一组值。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CENTER
      表示居中的水平位置。
      LEFT
      表示左侧水平位置。
      RIGHT
      表示正确的水平位置。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static HPos valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HPos[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LEFT

        public static final HPos LEFT
        表示左侧水平位置。

      • CENTER

        public static final HPos CENTER
        表示居中的水平位置。

      • RIGHT

        public static final HPos RIGHT
        表示正确的水平位置。

    • 方法详细信息

      • values

        public static HPos[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (HPos c : HPos.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static HPos valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Insets (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Class Insets

  • java.lang.Object
    • javafx.geometry.Insets

  • public class Insets
extends Object
    一组矩形区域的4边的内部偏移量
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Insets EMPTY
      空插图。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Insets​(double topRightBottomLeft)
      为所有四个偏移量构造一个新的Insets实例，具有相同的值。
      Insets​(double top, double right, double bottom, double left)
      构造一个具有四个不同偏移量的新Insets实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      double getBottom​()
      底部的插图
      double getLeft​()
      左侧的插图
      double getRight​()
      右侧的插图
      double getTop​()
      顶端的插图
      int hashCode​()
      返回插值的哈希码值。
      String toString​()
      返回插值的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • EMPTY

        public static final Insets EMPTY
        空插图。 一个Insets实例，所有偏移量都等于零。

    • 构造方法详细信息

      • Insets

        public Insets​(double top,
              double right,
              double bottom,
              double left)
        构造一个具有四个不同偏移量的新Insets实例。
        参数
        top - 顶部偏移
        right - 正确的偏移
        bottom - 底部偏移
        left - 左偏移

      • Insets

        public Insets​(double topRightBottomLeft)
        为所有四个偏移量构造一个新的Insets实例，具有相同的值。
        参数
        topRightBottomLeft - 用于顶部，底部，右侧和左侧偏移量的值

    • 方法详细信息

      • getTop

        public final double getTop​()
        顶端的插图
        结果
        插在顶端

      • getRight

        public final double getRight​()
        右侧的插图
        结果
        右侧的插图

      • getBottom

        public final double getBottom​()
        底部的插图
        结果
        底部的插图

      • getLeft

        public final double getLeft​()
        左侧的插图
        结果
        插在左侧

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象
        结果
        如果此对象与obj参数相同，则为true; 否则为假
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回插值的哈希码值。
        重写：
        hashCode在 Object
        结果
        插值的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回插值的字符串表示形式。
        重写：
        toString在 Object
        结果
        插入的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javafx.geometry (Java SE 9 & JDK 9 )

javafx.geometry

Classes

  • BoundingBox
  • Bounds
  • Dimension2D
  • Insets
  • Point2D
  • Point3D
  • Rectangle2D

Enums

  • HorizontalDirection
  • HPos
  • NodeOrientation
  • Orientation
  • Pos
  • Side
  • VerticalDirection
  • VPos


javafx.geometry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.geometry

提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

  • 类摘要
    Class 描述
    BoundingBox
    一个矩形边框，用于描述节点或其他场景图对象的界限。
    Bounds
    用于描述节点或其他场景图形对象边界的对象的基类。
    Dimension2D
    包含宽度和高度的2D维度对象。
    Insets
    一组矩形区域的4边的内部偏移量
    Point2D
    通常代表x，y坐标的二维几何点。
    Point3D
    通常表示x，y，z坐标的3D几何点。
    Rectangle2D
    用于描述对象边界的2D矩形。
  • 枚举摘要
    Enum 描述
    HorizontalDirection
    表示水平方向的枚举。
    HPos
    用于描述水平定位和对齐的一组值。
    NodeOrientation
    一组用于描述节点视觉数据流的值。
    Orientation
    方向
    Pos
    一组用于描述垂直和水平定位和对齐的值。
    Side
    枚举哪个方面应该是一个矩形。
    VerticalDirection
    表示垂直方向的枚举。
    VPos
    一组用于描述垂直定位和对齐的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.geometry Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.geometry

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.geometry.Bounds
      • javafx.geometry.BoundingBox
    • javafx.geometry.Dimension2D
    • javafx.geometry.Insets
    • javafx.geometry.Point2D
    • javafx.geometry.Point3D
    • javafx.geometry.Rectangle2D

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.geometry.HorizontalDirection
      • javafx.geometry.HPos
      • javafx.geometry.NodeOrientation
      • javafx.geometry.Orientation
      • javafx.geometry.Pos
      • javafx.geometry.Side
      • javafx.geometry.VerticalDirection
      • javafx.geometry.VPos
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


NodeOrientation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Enum NodeOrientation

  • java.lang.Object
    • java.lang.Enum<NodeOrientation>
      • javafx.geometry.NodeOrientation
  • All Implemented Interfaces:
    Serializable ， Comparable<NodeOrientation>

    public enum NodeOrientation
extends Enum<NodeOrientation>
    一组用于描述节点视觉数据流的值。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      INHERIT
      表示节点从父节点继承方向。
      LEFT_TO_RIGHT
      表示节点从左到右绘制。
      RIGHT_TO_LEFT
      表示节点从右到左绘制。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static NodeOrientation valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static NodeOrientation[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LEFT_TO_RIGHT

        public static final NodeOrientation LEFT_TO_RIGHT
        表示节点从左到右绘制。

      • RIGHT_TO_LEFT

        public static final NodeOrientation RIGHT_TO_LEFT
        表示节点从右到左绘制。

      • INHERIT

        public static final NodeOrientation INHERIT
        表示节点从父节点继承方向。

    • 方法详细信息

      • values

        public static NodeOrientation[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (NodeOrientation c : NodeOrientation.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static NodeOrientation valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Orientation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Enum Orientation

  • java.lang.Object
    • java.lang.Enum<Orientation>
      • javafx.geometry.Orientation
  • All Implemented Interfaces:
    Serializable ， Comparable<Orientation>

    public enum Orientation
extends Enum<Orientation>
    方向
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      HORIZONTAL
      横向（右< - >左）方向
      VERTICAL
      垂直（顶部< - >底部）方向

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Orientation valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Orientation[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • HORIZONTAL

        public static final Orientation HORIZONTAL
        横向（右< - >左）方向

      • VERTICAL

        public static final Orientation VERTICAL
        垂直（顶部< - >底部）方向

    • 方法详细信息

      • values

        public static Orientation[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Orientation c : Orientation.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Orientation valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Point2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Class Point2D

  • java.lang.Object
    • javafx.geometry.Point2D

  • public class Point2D
extends Object
    通常代表x，y坐标的二维几何点。 它也可以表示相对幅度矢量的x，y幅度。
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Point2D ZERO
      两个坐标设置为0的点或向量。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Point2D​(double x, double y)
      创建一个新的实例 Point2D 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Point2D add​(double x, double y)
      返回具有指定坐标的点添加到此点的坐标。
      Point2D add​(Point2D point)
      返回一个点，其中指定点的坐标添加到此点的坐标。
      double angle​(double x, double y)
      计算由该点表示的矢量与指定矢量之间的角度（以度为单位）。
      double angle​(Point2D point)
      计算由该点表示的向量与由指定点表示的向量之间的角度（以度为单位）。
      double angle​(Point2D p1, Point2D p2)
      计算三点之间的角度（以度为单位），此点作为顶点。
      Point3D crossProduct​(double x, double y)
      计算由该实例表示的向量与指定向量的交叉乘积。
      Point3D crossProduct​(Point2D vector)
      计算由该实例表示的向量与指定向量的交叉乘积。
      double distance​(double x1, double y1)
      计算此点与点 (x1, y1)之间的距离。
      double distance​(Point2D point)
      计算此点与指定的距离 point 。
      double dotProduct​(double x, double y)
      计算由该实例表示的向量的点（标量）乘积和指定的向量。
      double dotProduct​(Point2D vector)
      计算由该实例表示的向量的点（标量）乘积和指定的向量。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      double getX​()
      x坐标。
      double getY​()
      y坐标。
      int hashCode​()
      返回该点的哈希码值。
      double magnitude​()
      计算由该实例表示的相对幅度向量的幅度（长度）。
      Point2D midpoint​(double x, double y)
      返回位于该点与指定坐标之间的中间点。
      Point2D midpoint​(Point2D point)
      返回位于该点与指定点之间的中点。
      Point2D multiply​(double factor)
      返回一个点，其点坐标乘以指定因子
      Point2D normalize​()
      归一化由该实例表示的相对幅度向量。
      Point2D subtract​(double x, double y)
      从该点的坐标中减去指定坐标的点。
      Point2D subtract​(Point2D point)
      返回从该点的坐标中减去指定点的坐标的点。
      String toString​()
      返回此 Point2D的字符串表示 Point2D 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ZERO

        public static final Point2D ZERO
        两个坐标设置为0的点或向量。

    • 构造方法详细信息

      • Point2D

        public Point2D​(double x,
               double y)
        创建一个新的实例 Point2D 。
        参数
        x - 点的x坐标
        y - 点的y坐标

    • 方法详细信息

      • getX

        public final double getX​()
        x坐标。
        结果
        x坐标

      • getY

        public final double getY​()
        y坐标。
        结果
        y坐标

      • distance

        public double distance​(double x1,
                       double y1)
        计算此点与点 (x1, y1)之间的距离。
        参数
        x1 - 其他点的x坐标
        y1 - 其他点的y坐标
        结果
        该点与点之间的距离为 (x1, y1) 。

      • distance

        public double distance​(Point2D point)
        计算此点与指定的距离 point 。
        参数
        point - 另一点
        结果
        此点与指定的距离为 point 。
        异常
        NullPointerException - 如果指定的 point为空

      • add

        public Point2D add​(double x,
                   double y)
        返回具有指定坐标的点添加到此点的坐标。
        参数
        x - X坐标加法
        y - Y坐标加法
        结果
        点添加坐标
        从以下版本开始：
        JavaFX 8.0

      • add

        public Point2D add​(Point2D point)
        返回一个点，其中指定点的坐标添加到此点的坐标。
        参数
        point - 要添加坐标的点
        结果
        点添加坐标
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • subtract

        public Point2D subtract​(double x,
                        double y)
        从该点的坐标中减去指定坐标的点。
        参数
        x - X坐标减法
        y - Y坐标减法
        结果
        减去坐标的点
        从以下版本开始：
        JavaFX 8.0

      • multiply

        public Point2D multiply​(double factor)
        返回一个点，其点坐标乘以指定因子
        参数
        factor - 乘以坐标的因子
        结果
        具有乘坐坐标的点
        从以下版本开始：
        JavaFX 8.0

      • subtract

        public Point2D subtract​(Point2D point)
        返回从该点的坐标中减去指定点的坐标的点。
        参数
        point - 要减去坐标的点
        结果
        减去坐标的点
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • normalize

        public Point2D normalize​()
        归一化由该实例表示的相对幅度向量。 返回相同方向和幅度等于1的向量。如果这是零向量，则返回零向量。
        结果
        由 Point2D实例表示的归一化向量
        从以下版本开始：
        JavaFX 8.0

      • midpoint

        public Point2D midpoint​(double x,
                        double y)
        返回位于该点与指定坐标之间的中间点。
        参数
        x - 第二个端点的X坐标
        y - 第二个端点的Y坐标
        结果
        中间点
        从以下版本开始：
        JavaFX 8.0

      • midpoint

        public Point2D midpoint​(Point2D point)
        返回位于该点与指定点之间的中点。
        参数
        point - 另一个端点
        结果
        中间点
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • angle

        public double angle​(double x,
                    double y)
        计算由该点表示的矢量与指定矢量之间的角度（以度为单位）。
        参数
        x - 另一个向量的X大小
        y - 另一个向量的Y值
        结果
        两个矢量之间的角度以度为单位
        从以下版本开始：
        JavaFX 8.0

      • angle

        public double angle​(Point2D point)
        计算由该点表示的向量与由指定点表示的向量之间的角度（以度为单位）。
        参数
        point - 另一个向量
        结果
        两个向量之间的角度以度为单位测量，如果两个向量中的任一个是零向量， NaN
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • angle

        public double angle​(Point2D p1,
                    Point2D p2)
        计算三点之间的角度（以度为单位），此点作为顶点。
        参数
        p1 - 一点
        p2 - 其他点
        结果
        矢量之间的角度（这个，p1）和（这个，p2）以度为单位， NaN如果三个点之间没有差别
        异常
        NullPointerException - 如果 p1或 p2为空
        从以下版本开始：
        JavaFX 8.0

      • magnitude

        public double magnitude​()
        计算由该实例表示的相对幅度向量的幅度（长度）。
        结果
        载体的大小
        从以下版本开始：
        JavaFX 8.0

      • dotProduct

        public double dotProduct​(double x,
                         double y)
        计算由该实例表示的向量的点（标量）乘积和指定的向量。
        参数
        x - 另一个向量的X大小
        y - 另一个向量的Y值
        结果
        两个向量的点积
        从以下版本开始：
        JavaFX 8.0

      • dotProduct

        public double dotProduct​(Point2D vector)
        计算由该实例表示的向量的点（标量）乘积和指定的向量。
        参数
        vector - 另一个向量
        结果
        两个向量的点积
        异常
        NullPointerException - 如果指定的 vector为空
        从以下版本开始：
        JavaFX 8.0

      • crossProduct

        public Point3D crossProduct​(double x,
                            double y)
        计算由该实例表示的向量与指定向量的交叉乘积。
        参数
        x - 另一个向量的X大小
        y - 另一个向量的Y值
        结果
        两个向量的十字积
        从以下版本开始：
        JavaFX 8.0

      • crossProduct

        public Point3D crossProduct​(Point2D vector)
        计算由该实例表示的向量与指定向量的交叉乘积。
        参数
        vector - 另一个向量
        结果
        两个向量的十字积
        异常
        NullPointerException - 如果指定的 vector为空
        从以下版本开始：
        JavaFX 8.0

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象
        结果
        如果这一点与obj参数相同，则为true; 否则为假
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回该点的哈希码值。
        重写：
        hashCode在 Object
        结果
        该点的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此Point2D的字符串表示Point2D 。 此方法仅用于信息目的。 返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但不能为null 。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Point3D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Class Point3D

  • java.lang.Object
    • javafx.geometry.Point3D

  • public class Point3D
extends Object
    通常表示x，y，z坐标的3D几何点。 它也可以表示相对幅度向量的x，y，z幅度。
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Point3D ZERO
      所有三个坐标设置为0的点或向量。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Point3D​(double x, double y, double z)
      创建一个新的实例 Point3D 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Point3D add​(double x, double y, double z)
      返回具有指定坐标的点添加到此点的坐标。
      Point3D add​(Point3D point)
      返回一个点，其中指定点的坐标添加到此点的坐标。
      double angle​(double x, double y, double z)
      计算由该点表示的矢量与指定矢量之间的角度（以度为单位）。
      double angle​(Point3D point)
      计算由该点表示的向量与由指定点表示的向量之间的角度（以度为单位）。
      double angle​(Point3D p1, Point3D p2)
      计算三点之间的角度（以度为单位），此点作为顶点。
      Point3D crossProduct​(double x, double y, double z)
      计算由该实例表示的向量与指定向量的交叉乘积。
      Point3D crossProduct​(Point3D vector)
      计算由该实例表示的向量与指定向量的交叉乘积。
      double distance​(double x1, double y1, double z1)
      计算此点与点 (x1, y1, z1)之间的距离。
      double distance​(Point3D point)
      计算此点与指定的距离 point 。
      double dotProduct​(double x, double y, double z)
      计算由该实例表示的向量的点（标量）乘积和指定的向量。
      double dotProduct​(Point3D vector)
      计算由该实例表示的向量的点（标量）乘积和指定的向量。
      boolean equals​(Object obj)
      返回该点的哈希码值。
      double getX​()
      x坐标。
      double getY​()
      y坐标。
      double getZ​()
      z坐标。
      int hashCode​()
      返回此 Point3D对象的哈希码。
      double magnitude​()
      计算由该实例表示的相对幅度向量的幅度（长度）。
      Point3D midpoint​(double x, double y, double z)
      返回位于该点与指定坐标之间的中间点。
      Point3D midpoint​(Point3D point)
      返回位于该点与指定点之间的中点。
      Point3D multiply​(double factor)
      返回一个点，其点坐标乘以指定因子
      Point3D normalize​()
      归一化由该实例表示的相对幅度向量。
      Point3D subtract​(double x, double y, double z)
      从该点的坐标中减去指定坐标的点。
      Point3D subtract​(Point3D point)
      返回从该点的坐标中减去指定点的坐标的点。
      String toString​()
      返回此 Point3D的字符串表示 Point3D 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ZERO

        public static final Point3D ZERO
        所有三个坐标设置为0的点或向量。

    • 构造方法详细信息

      • Point3D

        public Point3D​(double x,
               double y,
               double z)
        创建一个新的实例 Point3D 。
        参数
        x -的x坐标 Point3D
        y -的Y坐标 Point3D
        z -将z轴的坐标 Point3D

    • 方法详细信息

      • getX

        public final double getX​()
        x坐标。
        结果
        x坐标

      • getY

        public final double getY​()
        y坐标。
        结果
        y坐标

      • getZ

        public final double getZ​()
        z坐标。
        结果
        z坐标

      • distance

        public double distance​(double x1,
                       double y1,
                       double z1)
        计算此点与点 (x1, y1, z1)之间的距离。
        参数
        x1 - 其他点的x坐标
        y1 - 其他点的y坐标
        z1 - 其他点的z坐标
        结果
        该点与点之间的距离为 (x1, y1, z1) 。

      • distance

        public double distance​(Point3D point)
        计算此点与指定的距离 point 。
        参数
        point - 另一点
        结果
        该点与指定的距离 point 。
        异常
        NullPointerException - 如果指定的 point为空

      • add

        public Point3D add​(double x,
                   double y,
                   double z)
        返回具有指定坐标的点添加到此点的坐标。
        参数
        x - X坐标加法
        y - Y坐标加法
        z - Z坐标加法
        结果
        点添加坐标
        从以下版本开始：
        JavaFX 8.0

      • add

        public Point3D add​(Point3D point)
        返回一个点，其中指定点的坐标添加到此点的坐标。
        参数
        point - 要添加坐标的点
        结果
        点添加坐标
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • subtract

        public Point3D subtract​(double x,
                        double y,
                        double z)
        从该点的坐标中减去指定坐标的点。
        参数
        x - X坐标减法
        y - Y坐标减法
        z - Z坐标减法
        结果
        减去坐标的点
        从以下版本开始：
        JavaFX 8.0

      • subtract

        public Point3D subtract​(Point3D point)
        返回从该点的坐标中减去指定点的坐标的点。
        参数
        point - 要减去坐标的点
        结果
        减去坐标的点
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • multiply

        public Point3D multiply​(double factor)
        返回一个点，其点坐标乘以指定因子
        参数
        factor - 乘以坐标的因子
        结果
        具有乘坐坐标的点
        从以下版本开始：
        JavaFX 8.0

      • normalize

        public Point3D normalize​()
        归一化由该实例表示的相对幅度向量。 返回相同方向和幅度等于1的向量。如果这是零向量，则返回零向量。
        结果
        由 Point3D实例表示的归一化向量
        从以下版本开始：
        JavaFX 8.0

      • midpoint

        public Point3D midpoint​(double x,
                        double y,
                        double z)
        返回位于该点与指定坐标之间的中间点。
        参数
        x - 第二个端点的X坐标
        y - 第二个端点的Y坐标
        z - 第二个端点的Z坐标
        结果
        中间点
        从以下版本开始：
        JavaFX 8.0

      • midpoint

        public Point3D midpoint​(Point3D point)
        返回位于该点与指定点之间的中点。
        参数
        point - 另一个端点
        结果
        中间点
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • angle

        public double angle​(double x,
                    double y,
                    double z)
        计算由该点表示的矢量与指定矢量之间的角度（以度为单位）。
        参数
        x - 另一个向量的X大小
        y - 另一个向量的Y值
        z - 另一个向量的Z幅度
        结果
        两个矢量之间的角度以度为单位
        从以下版本开始：
        JavaFX 8.0

      • angle

        public double angle​(Point3D point)
        计算由该点表示的向量与由指定点表示的向量之间的角度（以度为单位）。
        参数
        point - 另一个向量
        结果
        两个向量之间的角度以度为单位测量，如果两个矢量中的任一个是零矢量， NaN
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • angle

        public double angle​(Point3D p1,
                    Point3D p2)
        计算三点之间的角度（以度为单位），此点作为顶点。
        参数
        p1 - 一点
        p2 - 其他一点
        结果
        矢量之间的角度（这个，p1）和（这个，p2）以度为单位， NaN如果三个点没有不同
        异常
        NullPointerException - 如果 p1或 p2为空
        从以下版本开始：
        JavaFX 8.0

      • magnitude

        public double magnitude​()
        计算由该实例表示的相对幅度向量的幅度（长度）。
        结果
        载体的大小
        从以下版本开始：
        JavaFX 8.0

      • dotProduct

        public double dotProduct​(double x,
                         double y,
                         double z)
        计算由该实例表示的向量的点（标量）乘积和指定的向量。
        参数
        x - 另一个向量的X大小
        y - 另一个向量的Y值
        z - 另一个向量的Z大小
        结果
        两个向量的点积
        从以下版本开始：
        JavaFX 8.0

      • dotProduct

        public double dotProduct​(Point3D vector)
        计算由该实例表示的向量的点（标量）乘积和指定的向量。
        参数
        vector - 另一个向量
        结果
        两个向量的点积
        异常
        NullPointerException - 如果指定的 vector为空
        从以下版本开始：
        JavaFX 8.0

      • crossProduct

        public Point3D crossProduct​(double x,
                            double y,
                            double z)
        计算由该实例表示的向量与指定向量的交叉乘积。
        参数
        x - 另一个向量的X大小
        y - 另一个向量的Y值
        z - 另一个向量的Z大小
        结果
        两个向量的十字积
        从以下版本开始：
        JavaFX 8.0

      • crossProduct

        public Point3D crossProduct​(Point3D vector)
        计算由该实例表示的向量与指定向量的交叉乘积。
        参数
        vector - 另一个向量
        结果
        两个向量的十字积
        异常
        NullPointerException - 如果指定的 vector为空
        从以下版本开始：
        JavaFX 8.0

      • equals

        public boolean equals​(Object obj)
        返回该点的哈希码值。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        该点的哈希码值。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 Point3D对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 Point3D对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此Point3D的字符串表示Point3D 。 此方法仅用于信息目的。 返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但不能为null 。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Pos (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Enum Pos

  • java.lang.Object
    • java.lang.Enum<Pos>
      • javafx.geometry.Pos
  • All Implemented Interfaces:
    Serializable ， Comparable<Pos>

    public enum Pos
extends Enum<Pos>
    一组用于描述垂直和水平定位和对齐的值。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BASELINE_CENTER
      在垂直方向和中心水平方向上表示基线的位置。
      BASELINE_LEFT
      表示垂直方向和左侧水平位置。
      BASELINE_RIGHT
      在垂直方向和右侧的水平位置表示基线的位置。
      BOTTOM_CENTER
      水平定位在垂直方向和中心位置。
      BOTTOM_LEFT
      表示垂直和左侧水平位置。
      BOTTOM_RIGHT
      在垂直方向和右侧水平定位。
      CENTER
      在垂直和水平方向上表示中心的定位。
      CENTER_LEFT
      表示垂直方向和左侧水平位置。
      CENTER_RIGHT
      垂直方向和水平位置在中心位置。
      TOP_CENTER
      水平定位在垂直方向和中心位置。
      TOP_LEFT
      表示垂直和左上水平定位。
      TOP_RIGHT
      表示垂直和右侧水平位置。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      HPos getHpos​()
      返回水平定位/对齐。
      VPos getVpos​()
      返回垂直定位/对齐。
      static Pos valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Pos[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • TOP_LEFT

        public static final Pos TOP_LEFT
        表示垂直和左上水平定位。

      • TOP_CENTER

        public static final Pos TOP_CENTER
        水平定位在垂直方向和中心位置。

      • TOP_RIGHT

        public static final Pos TOP_RIGHT
        表示垂直和右侧水平位置。

      • CENTER_LEFT

        public static final Pos CENTER_LEFT
        表示垂直方向和左侧水平位置。

      • CENTER

        public static final Pos CENTER
        在垂直和水平方向上表示中心的定位。

      • CENTER_RIGHT

        public static final Pos CENTER_RIGHT
        垂直方向和水平位置在中心位置。

      • BOTTOM_LEFT

        public static final Pos BOTTOM_LEFT
        表示垂直和左侧水平位置。

      • BOTTOM_CENTER

        public static final Pos BOTTOM_CENTER
        水平定位在垂直方向和中心位置。

      • BOTTOM_RIGHT

        public static final Pos BOTTOM_RIGHT
        在垂直方向和右侧水平定位。

      • BASELINE_LEFT

        public static final Pos BASELINE_LEFT
        表示垂直方向和左侧水平位置。

      • BASELINE_CENTER

        public static final Pos BASELINE_CENTER
        在垂直方向和中心水平方向上表示基线的位置。

      • BASELINE_RIGHT

        public static final Pos BASELINE_RIGHT
        在垂直方向和右侧的水平位置表示基线的位置。

    • 方法详细信息

      • values

        public static Pos[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Pos c : Pos.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Pos valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • getVpos

        public VPos getVpos​()
        返回垂直定位/对齐。
        结果
        垂直定位/对齐。

      • getHpos

        public HPos getHpos​()
        返回水平定位/对齐。
        结果
        水平定位/对准。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Rectangle2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Class Rectangle2D

  • java.lang.Object
    • javafx.geometry.Rectangle2D

  • public class Rectangle2D
extends Object
    用于描述对象边界的2D矩形。 它由一个位置（minX，minY）和尺寸（宽x高）定义。
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Rectangle2D EMPTY
      一个空的 Rectangle2D实例（所有坐标等于零）。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Rectangle2D​(double minX, double minY, double width, double height)
      创建一个新的实例 Rectangle2D 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean contains​(double x, double y)
      测试指定的 (x, y)坐标是否在 Rectangle2D的边界内。
      boolean contains​(double x, double y, double w, double h)
      测试这个 Rectangle2D的内部 Rectangle2D完全包含指定的矩形区域。
      boolean contains​(Point2D p)
      测试指定点是否在 Rectangle2D的边界内。
      boolean contains​(Rectangle2D r)
      测试这个 Rectangle2D的内部 Rectangle2D完全包含指定的Rectangle2D， r 。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      double getHeight​()
      该高度为 Rectangle2D 。
      double getMaxX​()
      这个 Rectangle2D右下角的x坐标。
      double getMaxY​()
      这个 Rectangle2D右下角的y坐标。
      double getMinX​()
      这个 Rectangle2D左上角的x坐标。
      double getMinY​()
      这个 Rectangle2D左上角的y坐标。
      double getWidth​()
      该宽度为 Rectangle2D 。
      int hashCode​()
      返回此 Rectangle2D对象的哈希码。
      boolean intersects​(double x, double y, double w, double h)
      测试这个 Rectangle2D的内部是否与指定矩形区域的内部相交。
      boolean intersects​(Rectangle2D r)
      测试这个 Rectangle2D的内部是否与指定的Rectangle2D， r的内部相交。
      String toString​()
      返回此 Rectangle2D的字符串表示 Rectangle2D 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • EMPTY

        public static final Rectangle2D EMPTY
        一个空的 Rectangle2D实例（所有坐标等于零）。

    • 构造方法详细信息

      • Rectangle2D

        public Rectangle2D​(double minX,
                   double minY,
                   double width,
                   double height)
        创建一个新的实例 Rectangle2D 。
        参数
        minX -的x的左上角坐标 Rectangle2D
        minY -的y的左上角坐标 Rectangle2D
        width - 宽度的 Rectangle2D
        height -的高度 Rectangle2D

    • 方法详细信息

      • getMinX

        public double getMinX​()
        这个 Rectangle2D左上角的x坐标。
        Default value:
        0.0
        结果
        左上角的x坐标

      • getMinY

        public double getMinY​()
        这个 Rectangle2D左上角的y坐标。
        Default value:
        0.0
        结果
        左上角的y坐标

      • getWidth

        public double getWidth​()
        这个宽度 Rectangle2D 。
        Default value:
        0.0
        结果
        宽度

      • getHeight

        public double getHeight​()
        这个高度 Rectangle2D 。
        Default value:
        0.0
        结果
        高度

      • getMaxX

        public double getMaxX​()
        该 Rectangle2D右下角的x坐标。
        Default value:
        minX + width
        结果
        右下角的x坐标

      • getMaxY

        public double getMaxY​()
        这个 Rectangle2D右下角的y坐标。
        Default value:
        minY + height
        结果
        右下角的y坐标

      • contains

        public boolean contains​(Point2D p)
        测试指定点是否在 Rectangle2D的边界内。
        参数
        p - 要测试的指定点
        结果
        如果指定点在该Rectangle2D的边界内， Rectangle2D ; 否则为假

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的 (x, y)坐标是否在 Rectangle2D的边界内。
        参数
        x - 要测试的指定x坐标
        y - 要测试的指定y坐标
        结果
        如果指定的(x, y)坐标在这个Rectangle2D的边界内， Rectangle2D ; 否则为假

      • contains

        public boolean contains​(Rectangle2D r)
        测试这个 Rectangle2D的内部 Rectangle2D完全包含指定的Rectangle2D， r 。
        参数
        r - 指定的Rectangle2D
        结果
        如果指定的Rectangle2D， r ，在该Rectangle2D的边界内， Rectangle2D ; 否则为假

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试这个 Rectangle2D的内部 Rectangle2D完全包含指定的矩形区域。
        参数
        x - 指定矩形区域左上角的x坐标
        y - 指定矩形区域左上角的y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        如果这个Rectangle2D的内部完全包含指定的矩形区域， Rectangle2D true; 否则为假

      • intersects

        public boolean intersects​(Rectangle2D r)
        测试这个 Rectangle2D的内部是否与指定的Rectangle2D， r的内部相交。
        参数
        r - 指定的Rectangle2D
        结果
        如果这个 Rectangle2D的内部和指定的Rectangle2D的内部， r相交， r

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试此 Rectangle2D的内部是否与指定矩形区域的内部相交。
        参数
        x - 指定矩形区域左上角的x坐标
        y - 指定矩形区域左上角的y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        如果这个 Rectangle2D的内部和矩形区域的内部相交， Rectangle2D true

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象等于obj参数; 否则为false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 Rectangle2D对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 Rectangle2D对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此Rectangle2D的字符串表示Rectangle2D 。 此方法仅用于信息目的。 返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但不能为null 。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Side (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Enum Side

  • java.lang.Object
    • java.lang.Enum<Side>
      • javafx.geometry.Side
  • All Implemented Interfaces:
    Serializable ， Comparable<Side>

    public enum Side
extends Enum<Side>
    枚举哪个方面应该是一个矩形。 用于图表标题，轴等。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BOTTOM
      表示矩形的底部。
      LEFT
      表示矩形的左侧。
      RIGHT
      表示矩形的右侧。
      TOP
      代表矩形的顶端。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean isHorizontal​()
      指示这是否是一个矩形的水平侧（返回 true为 TOP和 BOTTOM 。
      boolean isVertical​()
      指示这是矩形的垂直边（ true为 LEFT和 RIGHT 。
      static Side valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Side[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • TOP

        public static final Side TOP
        代表矩形的顶端。

      • BOTTOM

        public static final Side BOTTOM
        表示矩形的底部。

      • LEFT

        public static final Side LEFT
        表示矩形的左侧。

      • RIGHT

        public static final Side RIGHT
        表示矩形的右侧。

    • 方法详细信息

      • values

        public static Side[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Side c : Side.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Side valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • isVertical

        public boolean isVertical​()
        表示这是一个矩形的垂直边（ true为 LEFT和 RIGHT 。
        结果
        true如果这代表一个矩形的垂直边

      • isHorizontal

        public boolean isHorizontal​()
        指示这是否是一个矩形的水平侧（返回 true为 TOP和 BOTTOM 。
        结果
        true如果这代表一个矩形的水平面
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Uses of Package javafx.geometry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.geometry

  • Packages that use javafx.geometry
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
  • Classes in javafx.geometry used by javafx.animation
    Class 描述
    Point3D
    通常表示x，y，z坐标的3D几何点。
  • Classes in javafx.geometry used by javafx.css
    Class 描述
    Insets
    一组矩形区域的4边的内部偏移量
    NodeOrientation
    一组用于描述节点视觉数据流的值。
  • Classes in javafx.geometry used by javafx.css.converter
    Class 描述
    Insets
    一组矩形区域的4边的内部偏移量
  • Classes in javafx.geometry used by javafx.geometry
    Class 描述
    Bounds
    用于描述节点或其他场景图形对象边界的对象的基类。
    HorizontalDirection
    表示水平方向的枚举。
    HPos
    用于描述水平定位和对齐的一组值。
    Insets
    一组矩形区域的4边的内部偏移量
    NodeOrientation
    一组用于描述节点视觉数据流的值。
    Orientation
    方向
    Point2D
    通常代表x，y坐标的二维几何点。
    Point3D
    通常表示x，y，z坐标的3D几何点。
    Pos
    一组用于描述垂直和水平定位和对齐的值。
    Rectangle2D
    用于描述对象边界的2D矩形。
    Side
    枚举哪个方面应该是一个矩形。
    VerticalDirection
    表示垂直方向的枚举。
    VPos
    一组用于描述垂直定位和对齐的值。
  • Classes in javafx.geometry used by javafx.scene
    Class 描述
    Bounds
    用于描述节点或其他场景图形对象边界的对象的基类。
    Dimension2D
    包含宽度和高度的2D维度对象。
    NodeOrientation
    一组用于描述节点视觉数据流的值。
    Orientation
    方向
    Point2D
    通常代表x，y坐标的二维几何点。
    Point3D
    通常表示x，y，z坐标的3D几何点。
    Rectangle2D
    用于描述对象边界的2D矩形。
  • Classes in javafx.geometry used by javafx.scene.canvas
    Class 描述
    VPos
    一组用于描述垂直定位和对齐的值。
  • Classes in javafx.geometry used by javafx.scene.chart
    Class 描述
    Dimension2D
    包含宽度和高度的2D维度对象。
    Side
    枚举哪个方面应该是一个矩形。
  • Classes in javafx.geometry used by javafx.scene.control
    Class 描述
    Bounds
    用于描述节点或其他场景图形对象边界的对象的基类。
    HPos
    用于描述水平定位和对齐的一组值。
    Insets
    一组矩形区域的4边的内部偏移量
    Orientation
    方向
    Pos
    一组用于描述垂直和水平定位和对齐的值。
    Side
    枚举哪个方面应该是一个矩形。
    VPos
    一组用于描述垂直定位和对齐的值。
  • Classes in javafx.geometry used by javafx.scene.control.skin
    Class 描述
    Bounds
    用于描述节点或其他场景图形对象边界的对象的基类。
    Point2D
    通常代表x，y坐标的二维几何点。
    Pos
    一组用于描述垂直和水平定位和对齐的值。
    Rectangle2D
    用于描述对象边界的2D矩形。
  • Classes in javafx.geometry used by javafx.scene.image
    Class 描述
    Rectangle2D
    用于描述对象边界的2D矩形。
  • Classes in javafx.geometry used by javafx.scene.input
    Class 描述
    Point2D
    通常代表x，y坐标的二维几何点。
    Point3D
    通常表示x，y，z坐标的3D几何点。
  • Classes in javafx.geometry used by javafx.scene.layout
    Class 描述
    Bounds
    用于描述节点或其他场景图形对象边界的对象的基类。
    HPos
    用于描述水平定位和对齐的一组值。
    Insets
    一组矩形区域的4边的内部偏移量
    Orientation
    方向
    Pos
    一组用于描述垂直和水平定位和对齐的值。
    Side
    枚举哪个方面应该是一个矩形。
    VPos
    一组用于描述垂直定位和对齐的值。
  • Classes in javafx.geometry used by javafx.scene.media
    Class 描述
    Rectangle2D
    用于描述对象边界的2D矩形。
  • Classes in javafx.geometry used by javafx.scene.text
    Class 描述
    Orientation
    方向
    Point2D
    通常代表x，y坐标的二维几何点。
    VPos
    一组用于描述垂直定位和对齐的值。
  • Classes in javafx.geometry used by javafx.scene.transform
    Class 描述
    Bounds
    用于描述节点或其他场景图形对象边界的对象的基类。
    Point2D
    通常代表x，y坐标的二维几何点。
    Point3D
    通常表示x，y，z坐标的3D几何点。
  • Classes in javafx.geometry used by javafx.scene.web
    Class 描述
    Rectangle2D
    用于描述对象边界的2D矩形。
  • Classes in javafx.geometry used by javafx.stage
    Class 描述
    Rectangle2D
    用于描述对象边界的2D矩形。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


VerticalDirection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Enum VerticalDirection

  • java.lang.Object
    • java.lang.Enum<VerticalDirection>
      • javafx.geometry.VerticalDirection
  • All Implemented Interfaces:
    Serializable ， Comparable<VerticalDirection>

    public enum VerticalDirection
extends Enum<VerticalDirection>
    表示垂直方向的枚举。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DOWN
      向下的方向
      UP
      向上的方向

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static VerticalDirection valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static VerticalDirection[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UP

        public static final VerticalDirection UP
        向上的方向

      • DOWN

        public static final VerticalDirection DOWN
        向下的方向

    • 方法详细信息

      • values

        public static VerticalDirection[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (VerticalDirection c : VerticalDirection.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static VerticalDirection valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


VPos (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.geometry

Enum VPos

  • java.lang.Object
    • java.lang.Enum<VPos>
      • javafx.geometry.VPos
  • All Implemented Interfaces:
    Serializable ， Comparable<VPos>

    public enum VPos
extends Enum<VPos>
    一组用于描述垂直定位和对齐的值。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BASELINE
      表示基线垂直位置。
      BOTTOM
      表示底部垂直位置。
      CENTER
      表示居中垂直位置。
      TOP
      表示垂直位置。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static VPos valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static VPos[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • TOP

        public static final VPos TOP
        表示垂直位置。

      • CENTER

        public static final VPos CENTER
        表示居中垂直位置。

      • BASELINE

        public static final VPos BASELINE
        表示基线垂直位置。

      • BOTTOM

        public static final VPos BOTTOM
        表示底部垂直位置。

    • 方法详细信息

      • values

        public static VPos[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (VPos c : VPos.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static VPos valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Uses of Class javafx.geometry.BoundingBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.BoundingBox

No usage of javafx.geometry.BoundingBox
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.Bounds (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.Bounds

  • Packages that use Bounds
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。

    • Uses of Bounds in javafx.geometry

      Subclasses of Bounds in javafx.geometry
      Modifier and Type Class 描述
      class  BoundingBox
      一个矩形边框，用于描述节点或其他场景图对象的界限。
      Methods in javafx.geometry with parameters of type Bounds
      Modifier and Type 方法 描述
      boolean BoundingBox.contains​(Bounds b)
      测试这个 Bounds的内部 Bounds完全包含指定的边界， b 。
      abstract boolean Bounds.contains​(Bounds b)
      测试这个 Bounds的内部 Bounds完全包含指定的边界， b 。
      boolean BoundingBox.intersects​(Bounds b)
      测试这个 Bounds的内部是否与指定边界的内部相交， b 。
      abstract boolean Bounds.intersects​(Bounds b)
      测试这个 Bounds的内部是否与指定的边界 b的内部相交。

    • Uses of Bounds in javafx.scene

      Methods in javafx.scene that return Bounds
      Modifier and Type 方法 描述
      Bounds Node.getBoundsInLocal​()
      获取属性boundsInLocal的值。
      Bounds Node.getBoundsInParent​()
      获取属性boundsInParent的值。
      Bounds Node.getLayoutBounds​()
      获取属性layoutBounds的值。
      Bounds Node.localToParent​(Bounds localBounds)
      将此 Node的局部坐标空间的 Node转换为其父级的坐标空间。
      Bounds Node.localToScene​(Bounds localBounds)
      将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
      Bounds Node.localToScene​(Bounds localBounds, boolean rootScene)
      将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
      Bounds Node.localToScreen​(Bounds localBounds)
      将此Node的局部坐标空间的Node转换为其Screen的坐标空间。
      Bounds Node.parentToLocal​(Bounds parentBounds)
      将矩形从母体的坐标空间转换为此 Node的局部坐标空间。
      Bounds Node.sceneToLocal​(Bounds sceneBounds)
      将矩形从场景的坐标空间转换为此 Node的局部坐标空间。
      Bounds Node.sceneToLocal​(Bounds bounds, boolean rootScene)
      将场景坐标空间的边界变换为 Node的局部坐标空间。
      Bounds Node.screenToLocal​(Bounds screenBounds)
      将矩形从Screen的坐标空间转换为此Node的本地坐标空间。
      Methods in javafx.scene that return types with arguments of type Bounds
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Bounds> Node.boundsInLocalProperty​()
      该节点未转换的局部坐标空间中的 Node的矩形边界。
      ReadOnlyObjectProperty<Bounds> Node.boundsInParentProperty​()
      这个 Node的矩形边界包括它的变换。
      ReadOnlyObjectProperty<Bounds> Node.layoutBoundsProperty​()
      应该用于此节点的布局计算的矩形边界。
      Methods in javafx.scene with parameters of type Bounds
      Modifier and Type 方法 描述
      boolean Node.intersects​(Bounds localBounds)
      返回 true如果给定的范围（在当地指定的坐标这个空间 Node ）相交这个形状 Node 。
      Bounds Node.localToParent​(Bounds localBounds)
      将此 Node的局部坐标空间的 Node转换为其父级的坐标空间。
      Bounds Node.localToScene​(Bounds localBounds)
      将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
      Bounds Node.localToScene​(Bounds localBounds, boolean rootScene)
      将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
      Bounds Node.localToScreen​(Bounds localBounds)
      将此Node的局部坐标空间的Node转换为其Screen的坐标空间。
      Bounds Node.parentToLocal​(Bounds parentBounds)
      将矩形从母体的坐标空间转换为此 Node的局部坐标空间。
      Bounds Node.sceneToLocal​(Bounds sceneBounds)
      将矩形从场景的坐标空间转换为此 Node的局部坐标空间。
      Bounds Node.sceneToLocal​(Bounds bounds, boolean rootScene)
      将场景坐标空间的边界变换为 Node的局部坐标空间。
      Bounds Node.screenToLocal​(Bounds screenBounds)
      将矩形从Screen的坐标空间转换为此Node的本地坐标空间。

    • Uses of Bounds in javafx.scene.control

      Methods in javafx.scene.control that return Bounds
      Modifier and Type 方法 描述
      Bounds ScrollPane.getViewportBounds​()
      获取属性viewportBounds的值。
      Methods in javafx.scene.control that return types with arguments of type Bounds
      Modifier and Type 方法 描述
      ObjectProperty<Bounds> ScrollPane.viewportBoundsProperty​()
      ScrollPane视口的实际边界。
      Methods in javafx.scene.control with parameters of type Bounds
      Modifier and Type 方法 描述
      void ScrollPane.setViewportBounds​(Bounds value)
      设置属性viewportBounds的值。

    • Uses of Bounds in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return Bounds
      Modifier and Type | 方法 | 描述
      Bounds | TextAreaSkin.getCaretBounds​()

    • Uses of Bounds in javafx.scene.layout

      Methods in javafx.scene.layout that return Bounds
      Modifier and Type 方法 描述
      Bounds GridPane.getCellBounds​(int columnIndex, int rowIndex)
      返回指定列和行位置的单元格的边界。

    • Uses of Bounds in javafx.scene.transform

      Methods in javafx.scene.transform that return Bounds
      Modifier and Type 方法 描述
      Bounds Transform.inverseTransform​(Bounds bounds)
      通过该变换的倒数转换指定的边界。
      Bounds Transform.transform​(Bounds bounds)
      通过此转换转换指定的边界。
      Methods in javafx.scene.transform with parameters of type Bounds
      Modifier and Type 方法 描述
      Bounds Transform.inverseTransform​(Bounds bounds)
      通过该变换的倒数转换指定的边界。
      boolean Transform.similarTo​(Transform transform, Bounds range, double maxDelta)
      检查这个变换是否类似于指定的变换。
      Bounds Transform.transform​(Bounds bounds)
      Transforms the specified bounds by this transform.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.Dimension2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.Dimension2D

  • Packages that use Dimension2D
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of Dimension2D in javafx.scene

      Methods in javafx.scene that return Dimension2D
      Modifier and Type 方法 描述
      static Dimension2D ImageCursor.getBestSize​(double preferredWidth, double preferredHeight)
      获取最接近指定的首选大小的支持的光标大小。

    • Uses of Dimension2D in javafx.scene.chart

      Methods in javafx.scene.chart that return Dimension2D
      Modifier and Type 方法 描述
      protected Dimension2D Axis.measureTickMarkLabelSize​(String labelText, double rotation)
      测量给定刻度标记值的标签尺寸。
      protected Dimension2D Axis.measureTickMarkSize​(T value, double rotation)
      测量给定刻度标记值的标签尺寸。
      protected Dimension2D Axis.measureTickMarkSize​(T value, Object range)
      测量给定刻度标记值的标签尺寸。
      protected Dimension2D CategoryAxis.measureTickMarkSize​(String value, Object range)
      测量给定刻度标记值的标签尺寸。
      protected Dimension2D NumberAxis.measureTickMarkSize​(Number value, Object range)
      测量给定刻度标记值的标签尺寸。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.HorizontalDirection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.HorizontalDirection

  • Packages that use HorizontalDirection
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of HorizontalDirection in javafx.geometry

      Methods in javafx.geometry that return HorizontalDirection
      Modifier and Type 方法 描述
      static HorizontalDirection HorizontalDirection.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HorizontalDirection[] HorizontalDirection.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.HPos (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.HPos

  • Packages that use HPos
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of HPos in javafx.geometry

      Methods in javafx.geometry that return HPos
      Modifier and Type 方法 描述
      HPos Pos.getHpos​()
      返回水平定位/对齐。
      static HPos HPos.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HPos[] HPos.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of HPos in javafx.scene.control

      Methods in javafx.scene.control that return HPos
      Modifier and Type 方法 描述
      HPos Separator.getHalignment​()
      获取属性暂停的值。
      Methods in javafx.scene.control that return types with arguments of type HPos
      Modifier and Type 方法 描述
      ObjectProperty<HPos> Separator.halignmentProperty​()
      对于垂直分隔符，指定分隔线在空间中的水平位置。
      Methods in javafx.scene.control with parameters of type HPos
      Modifier and Type 方法 描述
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      void Separator.setHalignment​(HPos value)
      设置属性暂停的值。

    • Uses of HPos in javafx.scene.layout

      Methods in javafx.scene.layout that return HPos
      Modifier and Type 方法 描述
      HPos FlowPane.getColumnHalignment​()
      获取属性columnHalignment的值。
      HPos ColumnConstraints.getHalignment​()
      获取属性暂停的值。
      static HPos GridPane.getHalignment​(Node child)
      如果设置，返回小孩的暂停约束。
      Methods in javafx.scene.layout that return types with arguments of type HPos
      Modifier and Type 方法 描述
      ObjectProperty<HPos> FlowPane.columnHalignmentProperty​()
      垂直花式板的每列内的节点的水平对齐。
      ObjectProperty<HPos> ColumnConstraints.halignmentProperty​()
      列的水平对齐。
      Methods in javafx.scene.layout with parameters of type HPos
      Modifier and Type 方法 描述
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment, boolean isSnapToPixel)
      其中规定了儿童的它的区域内的工具方法的父通过定义 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void Region.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment, boolean isSnapToPixel)
      通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      void FlowPane.setColumnHalignment​(HPos value)
      设置属性columnHalignment的值。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment)
      设置网格位置，跨度和子对齐方式。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow)
      设置网格位置，跨度和子对齐方式。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow, Insets margin)
      设置网格位置，跨度，对齐方式，增加优先级，以及子窗格包含在网格中时的边距。
      void ColumnConstraints.setHalignment​(HPos value)
      设置属性暂停的值。
      static void GridPane.setHalignment​(Node child, HPos value)
      设置子窗格的水平对齐方式。
      Constructors in javafx.scene.layout with parameters of type HPos
      Constructor 描述
      ColumnConstraints​(double minWidth, double prefWidth, double maxWidth, Priority hgrow, HPos halignment, boolean fillWidth)
      创建具有固定大小范围，水平增长优先级，水平对齐和水平填充行为的列约束对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.Insets (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.Insets

  • Packages that use Insets
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of Insets in javafx.css

      Methods in javafx.css that return types with arguments of type Insets
      Modifier and Type 方法 描述
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function)
      创建CssMetaData <S，Insets>，初始值为 EMPTY ，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Insets>并继承标志。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Insets>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function)
      创建一个StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建一个具有初始值的StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Inset>并继承标志。
      static StyleConverter<ParsedValue[],Insets> StyleConverter.getInsetsConverter​()
      返回一个转换[<length> |的StyleConverter <percentage>] {1,4}至Insets 。
      Methods in javafx.css with parameters of type Insets
      Modifier and Type 方法 描述
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Insets>并继承标志。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建一个具有初始值的StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Inset>并继承标志。
      Method parameters in javafx.css with type arguments of type Insets
      Modifier and Type 方法 描述
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function)
      创建一个CssMetaData <S，Insets>，初始值为 EMPTY ，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。
      CssMetaData<S,Insets> StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Insets>并继承标志。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function)
      创建一个StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue)
      创建一个具有初始值的StyleableProperty <Inset>。
      StyleableProperty<Insets> StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Inset>并继承标志。

    • Uses of Insets in javafx.css.converter

      Methods in javafx.css.converter that return Insets
      Modifier and Type | 方法 | 描述
      Insets | InsetsConverter.convert​(ParsedValue<ParsedValue[],Insets> value, Font font)
      Insets[] | InsetsConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<ParsedValue[],Insets>[],Insets[]> value, Font font)
      Methods in javafx.css.converter that return types with arguments of type Insets
      Modifier and Type | 方法 | 描述
      static StyleConverter<ParsedValue[],Insets> | InsetsConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Insets
      Modifier and Type | 方法 | 描述
      Insets | InsetsConverter.convert​(ParsedValue<ParsedValue[],Insets> value, Font font)

    • Uses of Insets in javafx.geometry

      Fields in javafx.geometry declared as Insets
      Modifier and Type Field 描述
      static Insets Insets.EMPTY
      空插图。

    • Uses of Insets in javafx.scene.control

      Methods in javafx.scene.control that return Insets
      Modifier and Type 方法 描述
      Insets Labeled.getLabelPadding​()
      获取属性labelPadding的值。
      Methods in javafx.scene.control that return types with arguments of type Insets
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Insets> Labeled.labelPaddingProperty​()
      标签周围的文字和图形内容。
      Methods in javafx.scene.control with parameters of type Insets
      Modifier and Type 方法 描述
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

    • Uses of Insets in javafx.scene.layout

      Methods in javafx.scene.layout that return Insets
      Modifier and Type 方法 描述
      Insets BackgroundFill.getInsets​()
      Insets用于填充。
      Insets Border.getInsets​()
      插图定义从区域边缘到边框最里边缘的距离，如果该距离是非负的。
      Insets BorderImage.getInsets​()
      BorderImage的内容定义边框相对于区域边缘的位置。
      Insets BorderStroke.getInsets​()
      定义BorderStroke的每一边的插图。
      Insets Region.getInsets​()
      获取属性插值的值。
      static Insets BorderPane.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets FlowPane.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets GridPane.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets HBox.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets StackPane.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets TilePane.getMargin​(Node node)
      如果设置，返回小孩的边距约束。
      static Insets VBox.getMargin​(Node child)
      如果设置，返回小孩的边距属性。
      Insets Region.getOpaqueInsets​()
      获取属性opaqueInsets的值。
      Insets Background.getOutsets​()
      这个背景的外在。
      Insets Border.getOutsets​()
      边框外部定义要绘制的边框的最外边缘。
      Insets Region.getPadding​()
      获取属性填充的值。
      Methods in javafx.scene.layout that return types with arguments of type Insets
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Insets> Region.insetsProperty​()
      区域的插图定义从区域边缘（其布局边界，或（0,0，宽度，高度））到内容区域边缘的距离。
      ObjectProperty<Insets> Region.opaqueInsetsProperty​()
      定义绘制完全不透明像素的区域的面积。
      ObjectProperty<Insets> Region.paddingProperty​()
      顶部，右侧，底部和左侧填充该区域的内容。
      Methods in javafx.scene.layout with parameters of type Insets
      Modifier and Type 方法 描述
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment, boolean isSnapToPixel)
      其中规定了儿童的它的区域内的工具方法的父通过定义 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void Region.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment, boolean isSnapToPixel)
      通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow, Insets margin)
      设置网格位置，跨度，对齐方式，增加优先级，以及子窗格包含在网格中时的边距。
      static void BorderPane.setMargin​(Node child, Insets value)
      设置由边框窗格包含的小孩的边距。
      static void FlowPane.setMargin​(Node child, Insets value)
      设置一个flowpane包含的孩子的边距。
      static void GridPane.setMargin​(Node child, Insets value)
      设置子窗格包含的格子的边距。
      static void HBox.setMargin​(Node child, Insets value)
      设置hbox包含的小孩的边距。
      static void StackPane.setMargin​(Node child, Insets value)
      设置一个堆栈包含的小孩的边距。
      static void TilePane.setMargin​(Node node, Insets value)
      设置小孩的边框，当包含一个瓦楞纸板时。
      static void VBox.setMargin​(Node child, Insets value)
      设置由vbox包含的小孩的边距。
      void Region.setOpaqueInsets​(Insets value)
      设置属性opaqueInsets的值。
      void Region.setPadding​(Insets value)
      设置属性填充的值。
      Constructors in javafx.scene.layout with parameters of type Insets
      Constructor 描述
      BackgroundFill​(Paint fill, CornerRadii radii, Insets insets)
      使用指定的填充，半径和插入创建一个新的BackgroundFill。
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.NodeOrientation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.NodeOrientation

  • Packages that use NodeOrientation
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of NodeOrientation in javafx.css

      Methods in javafx.css that return NodeOrientation
      Modifier and Type | 方法 | 描述
      NodeOrientation | SimpleSelector.getNodeOrientation​()

    • Uses of NodeOrientation in javafx.geometry

      Methods in javafx.geometry that return NodeOrientation
      Modifier and Type 方法 描述
      static NodeOrientation NodeOrientation.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static NodeOrientation[] NodeOrientation.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of NodeOrientation in javafx.scene

      Methods in javafx.scene that return NodeOrientation
      Modifier and Type 方法 描述
      NodeOrientation Node.getEffectiveNodeOrientation​()
      获取属性effectiveNodeOrientation的值。
      NodeOrientation Scene.getEffectiveNodeOrientation​()
      获取属性effectiveNodeOrientation的值。
      NodeOrientation Node.getNodeOrientation​()
      获取属性nodeOrientation的值。
      NodeOrientation Scene.getNodeOrientation​()
      获取属性nodeOrientation的值。
      Methods in javafx.scene that return types with arguments of type NodeOrientation
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<NodeOrientation> Node.effectiveNodeOrientationProperty​()
      节点的有效方向解决节点方向的继承，从左到右或从右到左返回。
      ReadOnlyObjectProperty<NodeOrientation> Scene.effectiveNodeOrientationProperty​()
      场景的有效节点方向解决节点方向的继承，从左到右或从右到左返回。
      ObjectProperty<NodeOrientation> Node.nodeOrientationProperty​()
      属性保存NodeOrientation。
      ObjectProperty<NodeOrientation> Scene.nodeOrientationProperty​()
      属性保存NodeOrientation。
      Methods in javafx.scene with parameters of type NodeOrientation
      Modifier and Type 方法 描述
      void Node.setNodeOrientation​(NodeOrientation orientation)
      设置属性nodeOrientation的值。
      void Scene.setNodeOrientation​(NodeOrientation orientation)
      设置属性nodeOrientation的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.Orientation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.Orientation

  • Packages that use Orientation
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of Orientation in javafx.geometry

      Methods in javafx.geometry that return Orientation
      Modifier and Type 方法 描述
      static Orientation Orientation.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Orientation[] Orientation.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of Orientation in javafx.scene

      Methods in javafx.scene that return Orientation
      Modifier and Type 方法 描述
      Orientation Node.getContentBias​()
      返回节点调整大小偏置的方向以进行布局。

    • Uses of Orientation in javafx.scene.control

      Methods in javafx.scene.control that return Orientation
      Modifier and Type | 方法 | 描述
      Orientation Accordion.getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      Orientation Labeled.getContentBias​()
      如果wrapText为true，则contentBias将为HORIZONTAL，否则为null。
      Orientation | TitledPane.getContentBias​()
      Orientation ListView.getOrientation​()
      返回ListView的当前方向，它决定了它是垂直滚动还是水平滚动。
      Orientation ScrollBar.getOrientation​()
      获取属性方向的值。
      Orientation Separator.getOrientation​()
      获取属性方向的值。
      Orientation Slider.getOrientation​()
      获取属性方向的值。
      Orientation SplitPane.getOrientation​()
      SplitPane的方向。
      Orientation ToolBar.getOrientation​()
      获取属性方向的值。
      Methods in javafx.scene.control that return types with arguments of type Orientation
      Modifier and Type 方法 描述
      ObjectProperty<Orientation> ListView.orientationProperty​()
      ListView的方向 - 这可以是水平还是垂直。
      ObjectProperty<Orientation> ScrollBar.orientationProperty​()
      ScrollBar的方向可以是 HORIZONTAL或 VERTICAL 。
      ObjectProperty<Orientation> Separator.orientationProperty​()
      Separator的方向可以是水平还是垂直。
      ObjectProperty<Orientation> Slider.orientationProperty​()
      Slider的方向可以是水平还是垂直。
      ObjectProperty<Orientation> SplitPane.orientationProperty​()
      SplitPane的方向。
      ObjectProperty<Orientation> ToolBar.orientationProperty​()
      ToolBar的方向 - 这可以是水平还是垂直。
      Methods in javafx.scene.control with parameters of type Orientation
      Modifier and Type 方法 描述
      void ListView.setOrientation​(Orientation value)
      设置ListView的方向，它决定它是垂直滚动还是水平滚动。
      void ScrollBar.setOrientation​(Orientation value)
      设置属性方向的值。
      void Separator.setOrientation​(Orientation value)
      设置属性方向的值。
      void Slider.setOrientation​(Orientation value)
      设置属性方向的值。
      void SplitPane.setOrientation​(Orientation value)
      此属性控制如何向用户显示SplitPane。
      void ToolBar.setOrientation​(Orientation value)
      设置属性方向的值。
      Constructors in javafx.scene.control with parameters of type Orientation
      Constructor 描述
      Separator​(Orientation orientation)
      创建一个新的分隔符，其中的对齐和赋值设置为它们各自的CENTER值。

    • Uses of Orientation in javafx.scene.layout

      Methods in javafx.scene.layout that return Orientation
      Modifier and Type | 方法 | 描述
      Orientation | BorderPane.getContentBias​()
      Orientation | FlowPane.getContentBias​()
      Orientation | GridPane.getContentBias​()
      Orientation | HBox.getContentBias​()
      Orientation | StackPane.getContentBias​()
      Orientation | TilePane.getContentBias​()
      Orientation | VBox.getContentBias​()
      Orientation FlowPane.getOrientation​()
      获取属性方向的值。
      Orientation TilePane.getOrientation​()
      获取属性方向的值。
      Methods in javafx.scene.layout that return types with arguments of type Orientation
      Modifier and Type 方法 描述
      ObjectProperty<Orientation> FlowPane.orientationProperty​()
      这个流面的方向。
      ObjectProperty<Orientation> TilePane.orientationProperty​()
      这个瓦片的方向。
      Methods in javafx.scene.layout with parameters of type Orientation
      Modifier and Type 方法 描述
      void FlowPane.setOrientation​(Orientation value)
      设置属性方向的值。
      void TilePane.setOrientation​(Orientation value)
      设置属性方向的值。
      Constructors in javafx.scene.layout with parameters of type Orientation
      Constructor 描述
      FlowPane​(Orientation orientation)
      使用指定的方向创建一个FlowPane布局，并创建hgap / vgap = 0。
      FlowPane​(Orientation orientation, double hgap, double vgap)
      使用指定的方向和hgap / vgap创建FlowPane布局。
      FlowPane​(Orientation orientation, double hgap, double vgap, Node... children)
      使用指定的方向和hgap / vgap创建FlowPane布局。
      FlowPane​(Orientation orientation, Node... children)
      使用指定的方向创建一个FlowPane布局，并创建hgap / vgap = 0。
      TilePane​(Orientation orientation)
      创建具有指定方向的TilePane布局，prefColumn / prefRows = 5和hgap / vgap = 0。
      TilePane​(Orientation orientation, double hgap, double vgap)
      使用指定的方向hgap / vgap和prefRows / prefColumns = 5创建TilePane布局。
      TilePane​(Orientation orientation, double hgap, double vgap, Node... children)
      使用指定的方向hgap / vgap和prefRows / prefColumns = 5创建TilePane布局。
      TilePane​(Orientation orientation, Node... children)
      Creates a TilePane layout with the specified orientation, prefColumn/prefRows = 5 and hgap/vgap = 0.

    • Uses of Orientation in javafx.scene.text

      Methods in javafx.scene.text that return Orientation
      Modifier and Type | 方法 | 描述
      Orientation | TextFlow.getContentBias​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.Point2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.Point2D

  • Packages that use Point2D
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

    • Uses of Point2D in javafx.geometry

      Fields in javafx.geometry declared as Point2D
      Modifier and Type Field 描述
      static Point2D Point2D.ZERO
      两个坐标设置为0的点或向量。
      Methods in javafx.geometry that return Point2D
      Modifier and Type 方法 描述
      Point2D Point2D.add​(double x, double y)
      返回具有指定坐标的点添加到此点的坐标。
      Point2D Point2D.add​(Point2D point)
      返回一个点，其中指定点的坐标添加到此点的坐标。
      Point2D Point2D.midpoint​(double x, double y)
      返回位于该点与指定坐标之间的中间点。
      Point2D Point2D.midpoint​(Point2D point)
      返回位于该点与指定点之间的中点。
      Point2D Point2D.multiply​(double factor)
      返回一个点，其点坐标乘以指定因子
      Point2D Point2D.normalize​()
      归一化由该实例表示的相对幅度向量。
      Point2D Point2D.subtract​(double x, double y)
      从该点的坐标中减去指定坐标的点。
      Point2D Point2D.subtract​(Point2D point)
      返回从该点的坐标中减去指定点的坐标的点。
      Methods in javafx.geometry with parameters of type Point2D
      Modifier and Type 方法 描述
      Point2D Point2D.add​(Point2D point)
      返回一个点，其中指定点的坐标添加到此点的坐标。
      double Point2D.angle​(Point2D point)
      计算由该点表示的向量与由指定点表示的向量之间的角度（以度为单位）。
      double Point2D.angle​(Point2D p1, Point2D p2)
      计算三点之间的角度（以度为单位），此点作为顶点。
      boolean BoundingBox.contains​(Point2D p)
      测试指定点是否在 Bounds的边界内。
      abstract boolean Bounds.contains​(Point2D p)
      测试指定点是否在 Bounds的边界内。
      boolean Rectangle2D.contains​(Point2D p)
      测试指定点是否在 Rectangle2D的边界内。
      Point3D Point2D.crossProduct​(Point2D vector)
      计算由该实例表示的向量与指定向量的交叉乘积。
      double Point2D.distance​(Point2D point)
      计算此点与指定的距离 point 。
      double Point2D.dotProduct​(Point2D vector)
      计算由该实例表示的向量的点（标量）乘积和指定的向量。
      Point2D Point2D.midpoint​(Point2D point)
      返回位于该点与指定点之间的中点。
      Point2D Point2D.subtract​(Point2D point)
      返回从该点的坐标中减去指定点的坐标的点。

    • Uses of Point2D in javafx.scene

      Methods in javafx.scene that return Point2D
      Modifier and Type 方法 描述
      Point2D Node.localToParent​(double localX, double localY)
      将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
      Point2D Node.localToParent​(Point2D localPoint)
      将一个点从该 Node的本地坐标空间转换为其父节点的坐标空间。
      Point2D Node.localToScene​(double localX, double localY)
      将一个点从该 Node的局部坐标空间 Node到其场景的坐标空间。
      Point2D Node.localToScene​(double x, double y, boolean rootScene)
      将一个点从该 Node的局部坐标空间转换为其场景的坐标空间。
      Point2D Node.localToScene​(Point2D localPoint)
      将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
      Point2D Node.localToScene​(Point2D localPoint, boolean rootScene)
      将这个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
      Point2D Node.localToScreen​(double localX, double localY)
      将一个点从该Node的本地坐标空间转换为其Screen的坐标空间。
      Point2D Node.localToScreen​(double localX, double localY, double localZ)
      将一个点从该Node的局部坐标空间转换为其Screen的坐标空间。
      Point2D Node.localToScreen​(Point2D localPoint)
      将一个点从该Node的局部坐标空间转换为其Screen的坐标空间。
      Point2D Node.localToScreen​(Point3D localPoint)
      将此Node的局部坐标空间的Node转换为其Screen的坐标空间。
      Point2D Node.parentToLocal​(double parentX, double parentY)
      将一个点从父节点的坐标空间转换为此 Node的局部坐标空间。
      Point2D Node.parentToLocal​(Point2D parentPoint)
      将一个点从父母的坐标空间转换为此 Node的局部坐标空间。
      Point2D Node.sceneToLocal​(double sceneX, double sceneY)
      将一个点从场景的坐标空间转换为 Node的局部坐标空间。
      Point2D Node.sceneToLocal​(double x, double y, boolean rootScene)
      将一个点从场景的坐标空间转换为这个 Node的局部坐标空间。
      Point2D Node.sceneToLocal​(Point2D scenePoint)
      将一个点从场景的坐标空间转换为这个 Node的局部坐标空间。
      Point2D Node.sceneToLocal​(Point2D point, boolean rootScene)
      将一个点从场景的坐标空间转换为这个 Node的局部坐标空间。
      Point2D Node.screenToLocal​(double screenX, double screenY)
      将来自该坐标空间中的点Screen这个局部坐标空间Node 。
      Point2D Node.screenToLocal​(Point2D screenPoint)
      将来自该坐标空间中的点Screen这个局部坐标空间Node 。
      Methods in javafx.scene with parameters of type Point2D
      Modifier and Type 方法 描述
      boolean Node.contains​(Point2D localPoint)
      返回 true如果给定的点（指定在局部坐标的此空间 Node ）包含在此的形状内 Node 。
      Point2D Node.localToParent​(Point2D localPoint)
      将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
      Point2D Node.localToScene​(Point2D localPoint)
      将这个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
      Point2D Node.localToScene​(Point2D localPoint, boolean rootScene)
      将一个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
      Point2D Node.localToScreen​(Point2D localPoint)
      将一个点从该Node的本地坐标空间转换为其Screen的坐标空间。
      Point2D Node.parentToLocal​(Point2D parentPoint)
      将一个点从父母的坐标空间转换为这个 Node的局部坐标空间。
      Point2D Node.sceneToLocal​(Point2D scenePoint)
      将点从场景的坐标空间转换为此 Node的局部坐标空间。
      Point2D Node.sceneToLocal​(Point2D point, boolean rootScene)
      将一个点从场景的坐标空间转换为这个 Node的局部坐标空间。
      Point2D Node.screenToLocal​(Point2D screenPoint)
      将来自该坐标空间中的点Screen这个局部坐标空间Node 。

    • Uses of Point2D in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return Point2D
      Modifier and Type 方法 描述
      Point2D TextAreaSkin.getMenuPosition​()
      根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。
      Point2D TextFieldSkin.getMenuPosition​()
      根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。
      Point2D TextInputControlSkin.getMenuPosition​()
      根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。

    • Uses of Point2D in javafx.scene.input

      Methods in javafx.scene.input that return Point2D
      Modifier and Type 方法 描述
      Point2D PickResult.getIntersectedTexCoord​()
      返回所选3D形状的相交纹理坐标。
      Point2D InputMethodRequests.getTextLocation​(int offset)
      获取当前组合文本中指定偏移量的位置，或者在提交文本中获取选择的位置。
      Constructors in javafx.scene.input with parameters of type Point2D
      Constructor 描述
      PickResult​(Node node, Point3D point, double distance, int face, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。

    • Uses of Point2D in javafx.scene.text

      Methods in javafx.scene.text with parameters of type Point2D
      Modifier and Type 方法 描述
      HitInfo Text.hitTest​(Point2D point)
      将本地点映射到内容中的索引。
      HitInfo TextFlow.hitTest​(Point2D point)
      将本地点映射到内容中的索引。

    • Uses of Point2D in javafx.scene.transform

      Methods in javafx.scene.transform that return Point2D
      Modifier and Type | 方法 | 描述
      Point2D | Affine.deltaTransform​(double x, double y)
      Point2D | Rotate.deltaTransform​(double x, double y)
      Point2D | Scale.deltaTransform​(double x, double y)
      Point2D | Shear.deltaTransform​(double x, double y)
      Point2D Transform.deltaTransform​(double x, double y)
      通过该变换来变换相对幅度矢量。
      Point2D Transform.deltaTransform​(Point2D point)
      通过此变换转换由指定的 Point2D实例表示的相对幅度向量。
      Point2D | Translate.deltaTransform​(double x, double y)
      Point2D | Translate.deltaTransform​(Point2D point)
      Point2D | Affine.inverseDeltaTransform​(double x, double y)
      Point2D | Rotate.inverseDeltaTransform​(double x, double y)
      Point2D | Scale.inverseDeltaTransform​(double x, double y)
      Point2D | Shear.inverseDeltaTransform​(double x, double y)
      Point2D Transform.inverseDeltaTransform​(double x, double y)
      通过该变换的逆变换相对幅度矢量。
      Point2D Transform.inverseDeltaTransform​(Point2D point)
      将由指定的 Point2D实例表示的相对幅度向量转换为该变换的倒数。
      Point2D | Translate.inverseDeltaTransform​(double x, double y)
      Point2D | Translate.inverseDeltaTransform​(Point2D point)
      Point2D | Affine.inverseTransform​(double x, double y)
      Point2D | Rotate.inverseTransform​(double x, double y)
      Point2D | Scale.inverseTransform​(double x, double y)
      Point2D | Shear.inverseTransform​(double x, double y)
      Point2D Transform.inverseTransform​(double x, double y)
      通过该变换的逆变换指定点。
      Point2D Transform.inverseTransform​(Point2D point)
      通过该变换的逆变换指定点。
      Point2D | Translate.inverseTransform​(double x, double y)
      Point2D | Affine.transform​(double x, double y)
      Point2D | Rotate.transform​(double x, double y)
      Point2D | Scale.transform​(double x, double y)
      Point2D | Shear.transform​(double x, double y)
      Point2D Transform.transform​(double x, double y)
      通过此转换来转换指定的点。
      Point2D Transform.transform​(Point2D point)
      通过此转换来转换指定的点。
      Point2D | Translate.transform​(double x, double y)
      Methods in javafx.scene.transform with parameters of type Point2D
      Modifier and Type | 方法 | 描述
      void Affine.appendRotation​(double angle, Point2D pivot)
      使用枢轴将2D旋转附加到此实例。
      void Affine.appendScale​(double sx, double sy, Point2D pivot)
      将具有枢轴的2D刻度附加到此实例。
      void Affine.appendShear​(double shx, double shy, Point2D pivot)
      用枢轴附加剪切到这个实例。
      Point2D Transform.deltaTransform​(Point2D point)
      通过此变换转换由指定的 Point2D实例表示的相对幅度向量。
      Point2D | Translate.deltaTransform​(Point2D point)
      Point2D Transform.inverseDeltaTransform​(Point2D point)
      将由指定的 Point2D实例表示的相对幅度向量转换为该变换的倒数。
      Point2D | Translate.inverseDeltaTransform​(Point2D point)
      Point2D Transform.inverseTransform​(Point2D point)
      通过该变换的逆变换指定点。
      void Affine.prependRotation​(double angle, Point2D pivot)
      使用枢轴将2D旋转预加到此实例。
      void Affine.prependScale​(double sx, double sy, Point2D pivot)
      使用这个实例的枢轴来预处理二维刻度。
      void Affine.prependShear​(double shx, double shy, Point2D pivot)
      在这种情况下用枢轴预先剪切。
      Point2D Transform.transform​(Point2D point)
      通过此转换来转换指定的点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.Point3D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.Point3D

  • Packages that use Point3D
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

    • Uses of Point3D in javafx.animation

      Methods in javafx.animation that return Point3D
      Modifier and Type 方法 描述
      Point3D RotateTransition.getAxis​()
      获取属性轴的值。
      Methods in javafx.animation that return types with arguments of type Point3D
      Modifier and Type 方法 描述
      ObjectProperty<Point3D> RotateTransition.axisProperty​()
      指定此 RotateTransition的旋转轴。
      Methods in javafx.animation with parameters of type Point3D
      Modifier and Type 方法 描述
      void RotateTransition.setAxis​(Point3D value)
      设置属性轴的值。

    • Uses of Point3D in javafx.geometry

      Fields in javafx.geometry declared as Point3D
      Modifier and Type Field 描述
      static Point3D Point3D.ZERO
      所有三个坐标设置为0的点或向量。
      Methods in javafx.geometry that return Point3D
      Modifier and Type 方法 描述
      Point3D Point3D.add​(double x, double y, double z)
      返回具有指定坐标的点添加到此点的坐标。
      Point3D Point3D.add​(Point3D point)
      返回一个点，其中指定点的坐标添加到此点的坐标。
      Point3D Point2D.crossProduct​(double x, double y)
      计算由该实例表示的向量与指定向量的交叉乘积。
      Point3D Point2D.crossProduct​(Point2D vector)
      计算由该实例表示的向量与指定向量的交叉乘积。
      Point3D Point3D.crossProduct​(double x, double y, double z)
      计算由该实例表示的向量与指定向量的交叉乘积。
      Point3D Point3D.crossProduct​(Point3D vector)
      计算由该实例表示的向量与指定向量的交叉乘积。
      Point3D Point3D.midpoint​(double x, double y, double z)
      返回位于该点与指定坐标之间的中间点。
      Point3D Point3D.midpoint​(Point3D point)
      返回位于该点与指定点之间的中点。
      Point3D Point3D.multiply​(double factor)
      返回一个点，其点坐标乘以指定因子
      Point3D Point3D.normalize​()
      归一化由该实例表示的相对幅度向量。
      Point3D Point3D.subtract​(double x, double y, double z)
      从该点的坐标中减去指定坐标的点。
      Point3D Point3D.subtract​(Point3D point)
      返回从该点的坐标中减去指定点的坐标的点。
      Methods in javafx.geometry with parameters of type Point3D
      Modifier and Type 方法 描述
      Point3D Point3D.add​(Point3D point)
      返回一个点，其中指定点的坐标添加到此点的坐标。
      double Point3D.angle​(Point3D point)
      计算由该点表示的向量与由指定点表示的向量之间的角度（以度为单位）。
      double Point3D.angle​(Point3D p1, Point3D p2)
      计算三点之间的角度（以度为单位），此点作为顶点。
      boolean BoundingBox.contains​(Point3D p)
      测试指定点是否在 Bounds的边界内。
      abstract boolean Bounds.contains​(Point3D p)
      测试指定点是否在 Bounds的边界内。
      Point3D Point3D.crossProduct​(Point3D vector)
      计算由该实例表示的向量与指定向量的交叉乘积。
      double Point3D.distance​(Point3D point)
      计算此点与指定的距离 point 。
      double Point3D.dotProduct​(Point3D vector)
      计算由该实例表示的向量的点（标量）乘积和指定的向量。
      Point3D Point3D.midpoint​(Point3D point)
      返回位于该点与指定点之间的中点。
      Point3D Point3D.subtract​(Point3D point)
      返回从该点的坐标中减去指定点的坐标的点。

    • Uses of Point3D in javafx.scene

      Methods in javafx.scene that return Point3D
      Modifier and Type 方法 描述
      Point3D Node.getRotationAxis​()
      获取属性rotateAxis的值。
      Point3D Node.localToParent​(double x, double y, double z)
      将一个点从该 Node的本地坐标空间转换为其父节点的坐标空间。
      Point3D Node.localToParent​(Point3D localPoint)
      将一个点从该 Node的本地坐标空间转换为其父节点的坐标空间。
      Point3D Node.localToScene​(double x, double y, double z)
      将这个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
      Point3D Node.localToScene​(double x, double y, double z, boolean rootScene)
      将一个点从该 Node的局部坐标空间转换为其场景的坐标空间。
      Point3D Node.localToScene​(Point3D localPoint)
      将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
      Point3D Node.localToScene​(Point3D localPoint, boolean rootScene)
      将此 Node的本地坐标空间的 Node转换为其场景的坐标空间。
      Point3D Node.parentToLocal​(double parentX, double parentY, double parentZ)
      将一个点从母体的坐标空间转换为该 Node的局部坐标空间。
      Point3D Node.parentToLocal​(Point3D parentPoint)
      将一个点从母体的坐标空间转换为此 Node的局部坐标空间。
      Point3D Node.sceneToLocal​(double sceneX, double sceneY, double sceneZ)
      将点从场景的坐标空间转换为此 Node的局部坐标空间。
      Point3D Node.sceneToLocal​(Point3D scenePoint)
      将点从场景的坐标空间转换为 Node的局部坐标空间。
      Methods in javafx.scene that return types with arguments of type Point3D
      Modifier and Type 方法 描述
      ObjectProperty<Point3D> Node.rotationAxisProperty​()
      定义 Node的旋转轴。
      Methods in javafx.scene with parameters of type Point3D
      Modifier and Type 方法 描述
      Point3D Node.localToParent​(Point3D localPoint)
      将一个点从该 Node的局部坐标空间转换为其父级的坐标空间。
      Point3D Node.localToScene​(Point3D localPoint)
      将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
      Point3D Node.localToScene​(Point3D localPoint, boolean rootScene)
      将一个点从该 Node的本地坐标空间转换为其场景的坐标空间。
      Point2D Node.localToScreen​(Point3D localPoint)
      将一个点从该Node的局部坐标空间转换为其Screen的坐标空间。
      Point3D Node.parentToLocal​(Point3D parentPoint)
      将一个点从母体的坐标空间转换为该 Node的局部坐标空间。
      Point3D Node.sceneToLocal​(Point3D scenePoint)
      将一个点从场景的坐标空间转换为该 Node的局部坐标空间。
      void Node.setRotationAxis​(Point3D value)
      设置属性rotateAxis的值。

    • Uses of Point3D in javafx.scene.input

      Methods in javafx.scene.input that return Point3D
      Modifier and Type 方法 描述
      Point3D PickResult.getIntersectedNormal​()
      返回所选择的3D形状的相交法线。
      Point3D PickResult.getIntersectedPoint​()
      返回所选节点的局部坐标中的相交点。
      Constructors in javafx.scene.input with parameters of type Point3D
      Constructor 描述
      PickResult​(Node node, Point3D point, double distance)
      为非3d形状的目标创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。

    • Uses of Point3D in javafx.scene.transform

      Fields in javafx.scene.transform declared as Point3D
      Modifier and Type Field 描述
      static Point3D Rotate.X_AXIS
      指定X轴作为旋转轴。
      static Point3D Rotate.Y_AXIS
      指定Y轴作为旋转轴。
      static Point3D Rotate.Z_AXIS
      指定Z轴作为旋转轴。
      Methods in javafx.scene.transform that return Point3D
      Modifier and Type | 方法 | 描述
      Point3D | Affine.deltaTransform​(double x, double y, double z)
      Point3D | Rotate.deltaTransform​(double x, double y, double z)
      Point3D | Scale.deltaTransform​(double x, double y, double z)
      Point3D | Shear.deltaTransform​(double x, double y, double z)
      Point3D Transform.deltaTransform​(double x, double y, double z)
      通过该变换来变换相对幅度矢量。
      Point3D Transform.deltaTransform​(Point3D point)
      通过此变换转换由指定的 Point3D实例表示的相对幅度向量。
      Point3D | Translate.deltaTransform​(double x, double y, double z)
      Point3D | Translate.deltaTransform​(Point3D point)
      Point3D Rotate.getAxis​()
      获取属性轴的值。
      Point3D | Affine.inverseDeltaTransform​(double x, double y, double z)
      Point3D | Rotate.inverseDeltaTransform​(double x, double y, double z)
      Point3D | Scale.inverseDeltaTransform​(double x, double y, double z)
      Point3D | Shear.inverseDeltaTransform​(double x, double y, double z)
      Point3D Transform.inverseDeltaTransform​(double x, double y, double z)
      通过该变换的逆变换相对幅度矢量。
      Point3D Transform.inverseDeltaTransform​(Point3D point)
      将由指定的 Point3D实例表示的相对幅度向量转换为该变换的倒数。
      Point3D | Translate.inverseDeltaTransform​(double x, double y, double z)
      Point3D | Translate.inverseDeltaTransform​(Point3D point)
      Point3D | Affine.inverseTransform​(double x, double y, double z)
      Point3D | Rotate.inverseTransform​(double x, double y, double z)
      Point3D | Scale.inverseTransform​(double x, double y, double z)
      Point3D | Shear.inverseTransform​(double x, double y, double z)
      Point3D Transform.inverseTransform​(double x, double y, double z)
      通过该变换的逆变换指定点。
      Point3D Transform.inverseTransform​(Point3D point)
      通过该变换的逆变换指定点。
      Point3D | Translate.inverseTransform​(double x, double y, double z)
      Point3D | Affine.transform​(double x, double y, double z)
      Point3D | Rotate.transform​(double x, double y, double z)
      Point3D | Scale.transform​(double x, double y, double z)
      Point3D | Shear.transform​(double x, double y, double z)
      Point3D Transform.transform​(double x, double y, double z)
      通过此转换来转换指定的点。
      Point3D Transform.transform​(Point3D point)
      通过此转换来转换指定的点。
      Point3D | Translate.transform​(double x, double y, double z)
      Methods in javafx.scene.transform that return types with arguments of type Point3D
      Modifier and Type 方法 描述
      ObjectProperty<Point3D> Rotate.axisProperty​()
      定义枢轴点的旋转轴。
      Methods in javafx.scene.transform with parameters of type Point3D
      Modifier and Type | 方法 | 描述
      void Affine.appendRotation​(double angle, double pivotX, double pivotY, double pivotZ, Point3D axis)
      将旋转追加到此实例。
      void Affine.appendRotation​(double angle, Point3D pivot, Point3D axis)
      将旋转追加到此实例。
      void Affine.appendScale​(double sx, double sy, double sz, Point3D pivot)
      使用pivot附加到此实例的缩放。
      Point3D Transform.deltaTransform​(Point3D point)
      通过此变换转换由指定的 Point3D实例表示的相对幅度向量。
      Point3D | Translate.deltaTransform​(Point3D point)
      Point3D Transform.inverseDeltaTransform​(Point3D point)
      将由指定的 Point3D实例表示的相对幅度向量转换为该变换的倒数。
      Point3D | Translate.inverseDeltaTransform​(Point3D point)
      Point3D Transform.inverseTransform​(Point3D point)
      通过该变换的逆变换指定点。
      void Affine.prependRotation​(double angle, double pivotX, double pivotY, double pivotZ, Point3D axis)
      预先轮换到这个实例。
      void Affine.prependRotation​(double angle, Point3D pivot, Point3D axis)
      预先轮换到这个实例。
      void Affine.prependScale​(double sx, double sy, double sz, Point3D pivot)
      使用这个实例的pivot来预览缩放比例。
      void Rotate.setAxis​(Point3D value)
      设置属性轴的值。
      Point3D Transform.transform​(Point3D point)
      通过此转换来转换指定的点。
      Constructors in javafx.scene.transform with parameters of type Point3D
      Constructor 描述
      Rotate​(double angle, double pivotX, double pivotY, double pivotZ, Point3D axis)
      用枢轴创建三维旋转变换。
      Rotate​(double angle, Point3D axis)
      创建一个三维旋转变换。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.Pos (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.Pos

  • Packages that use Pos
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of Pos in javafx.geometry

      Methods in javafx.geometry that return Pos
      Modifier and Type 方法 描述
      static Pos Pos.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Pos[] Pos.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of Pos in javafx.scene.control

      Methods in javafx.scene.control that return Pos
      Modifier and Type 方法 描述
      Pos Labeled.getAlignment​()
      获取属性对齐的值。
      Pos TextField.getAlignment​()
      获取属性对齐的值。
      protected Pos Labeled.getInitialAlignment​()
      返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。
      protected Pos RadioButton.getInitialAlignment​()
      返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。
      protected Pos ToggleButton.getInitialAlignment​()
      返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。
      Methods in javafx.scene.control that return types with arguments of type Pos
      Modifier and Type 方法 描述
      ObjectProperty<Pos> Labeled.alignmentProperty​()
      指定Labeled内的空格时如何对齐Labeled中的文本和图形。
      ObjectProperty<Pos> TextField.alignmentProperty​()
      指定当TextField中有空格时如何对齐文本。
      Methods in javafx.scene.control with parameters of type Pos
      Modifier and Type 方法 描述
      void Labeled.setAlignment​(Pos value)
      设置属性对齐的值。
      void TextField.setAlignment​(Pos value)
      设置属性对齐的值。

    • Uses of Pos in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return Pos
      Modifier and Type 方法 描述
      Pos MenuBarSkin.getContainerAlignment​()
      获取属性containerAlignment的值。
      Methods in javafx.scene.control.skin that return types with arguments of type Pos
      Modifier and Type 方法 描述
      ObjectProperty<Pos> MenuBarSkin.containerAlignmentProperty​()
      指定MenuBar中菜单按钮的对齐方式（默认为Pos.TOP_LEFT）。
      Methods in javafx.scene.control.skin with parameters of type Pos
      Modifier and Type 方法 描述
      protected void LabeledSkinBase.layoutLabelInArea​(double x, double y, double w, double h, Pos alignment)
      在给定的区域内执行标签内容的实际布局。
      void MenuBarSkin.setContainerAlignment​(Pos value)
      设置属性containerAlignment的值。

    • Uses of Pos in javafx.scene.layout

      Methods in javafx.scene.layout that return Pos
      Modifier and Type 方法 描述
      static Pos BorderPane.getAlignment​(Node child)
      如果设置，返回小孩的对齐约束。
      Pos FlowPane.getAlignment​()
      获取属性对齐的值。
      Pos GridPane.getAlignment​()
      获取属性对齐的值。
      Pos HBox.getAlignment​()
      获取属性对齐的值。
      Pos StackPane.getAlignment​()
      获取属性对齐的值。
      static Pos StackPane.getAlignment​(Node child)
      如果设置，返回小孩的对齐约束。
      Pos TilePane.getAlignment​()
      获取属性对齐的值。
      static Pos TilePane.getAlignment​(Node node)
      如果设置，返回小孩的对齐约束。
      Pos VBox.getAlignment​()
      获取属性对齐的值。
      Pos TilePane.getTileAlignment​()
      获取属性tileAlignment的值。
      Methods in javafx.scene.layout that return types with arguments of type Pos
      Modifier and Type 方法 描述
      ObjectProperty<Pos> FlowPane.alignmentProperty​()
      Flowpane的内容在其宽度和高度之间的整体对齐。
      ObjectProperty<Pos> GridPane.alignmentProperty​()
      格栅在格栅宽度和高度内的对齐方式。
      ObjectProperty<Pos> HBox.alignmentProperty​()
      孩子们在hbox的宽度和高度之间的整体对齐。
      ObjectProperty<Pos> StackPane.alignmentProperty​()
      在stackpane的宽度和高度内的子项的默认对齐方式。
      ObjectProperty<Pos> TilePane.alignmentProperty​()
      瓦楞纸板内容在其宽度和高度之间的整体对齐。
      ObjectProperty<Pos> VBox.alignmentProperty​()
      孩子们在vbox的宽度和高度之间的整体对齐。
      ObjectProperty<Pos> TilePane.tileAlignmentProperty​()
      每个孩子在其图块中的默认对齐方式。
      Methods in javafx.scene.layout with parameters of type Pos
      Modifier and Type 方法 描述
      static void BorderPane.setAlignment​(Node child, Pos value)
      设置边框窗格中包含的子对象。
      void FlowPane.setAlignment​(Pos value)
      设置属性对齐的值。
      void GridPane.setAlignment​(Pos value)
      设置属性对齐的值。
      void HBox.setAlignment​(Pos value)
      设置属性对齐的值。
      void StackPane.setAlignment​(Pos value)
      设置属性对齐的值。
      static void StackPane.setAlignment​(Node child, Pos value)
      设置子堆栈的对齐方式。
      void TilePane.setAlignment​(Pos value)
      设置属性对齐的值。
      static void TilePane.setAlignment​(Node node, Pos value)
      设置小屋的对齐方式，包含在tilepane中。
      void VBox.setAlignment​(Pos value)
      设置属性对齐的值。
      void TilePane.setTileAlignment​(Pos value)
      设置属性tileAlignment的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.Rectangle2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.Rectangle2D

  • Packages that use Rectangle2D
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of Rectangle2D in javafx.geometry

      Fields in javafx.geometry declared as Rectangle2D
      Modifier and Type Field 描述
      static Rectangle2D Rectangle2D.EMPTY
      一个空的 Rectangle2D实例（所有坐标等于零）。
      Methods in javafx.geometry with parameters of type Rectangle2D
      Modifier and Type 方法 描述
      boolean Rectangle2D.contains​(Rectangle2D r)
      测试这个 Rectangle2D的内部 Rectangle2D完全包含指定的Rectangle2D， r 。
      boolean Rectangle2D.intersects​(Rectangle2D r)
      测试这个 Rectangle2D的内部是否与指定的Rectangle2D， r的内部相交。

    • Uses of Rectangle2D in javafx.scene

      Methods in javafx.scene that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D SnapshotParameters.getViewport​()
      获取当前视口
      Methods in javafx.scene with parameters of type Rectangle2D
      Modifier and Type 方法 描述
      void SnapshotParameters.setViewport​(Rectangle2D viewport)
      设置用于渲染的视口。

    • Uses of Rectangle2D in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D TextAreaSkin.getCharacterBounds​(int index)
      返回给定索引处字符的边界。
      Rectangle2D TextFieldSkin.getCharacterBounds​(int index)
      返回给定索引处字符的边界。
      Rectangle2D TextInputControlSkin.getCharacterBounds​(int index)
      返回给定索引处字符的边界。

    • Uses of Rectangle2D in javafx.scene.image

      Methods in javafx.scene.image that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D ImageView.getViewport​()
      获取属性视口的值。
      Methods in javafx.scene.image that return types with arguments of type Rectangle2D
      Modifier and Type 方法 描述
      ObjectProperty<Rectangle2D> ImageView.viewportProperty​()
      矩形视口进入图像。
      Methods in javafx.scene.image with parameters of type Rectangle2D
      Modifier and Type 方法 描述
      void ImageView.setViewport​(Rectangle2D value)
      设置属性视口的值。

    • Uses of Rectangle2D in javafx.scene.media

      Methods in javafx.scene.media that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D MediaView.getViewport​()
      将矩形视口检索到媒体框架中。
      Methods in javafx.scene.media that return types with arguments of type Rectangle2D
      Modifier and Type 方法 描述
      ObjectProperty<Rectangle2D> MediaView.viewportProperty​()
      指定一个矩形视口到媒体框架。
      Methods in javafx.scene.media with parameters of type Rectangle2D
      Modifier and Type 方法 描述
      void MediaView.setViewport​(Rectangle2D value)
      将矩形视口设置到媒体框架中。

    • Uses of Rectangle2D in javafx.scene.web

      Methods in javafx.scene.web that return types with arguments of type Rectangle2D
      Modifier and Type 方法 描述
      EventHandler<WebEvent<Rectangle2D>> WebEngine.getOnResized​()
      获取属性onResized的值。
      ObjectProperty<EventHandler<WebEvent<Rectangle2D>>> WebEngine.onResizedProperty​()
      JavaScript窗口调整大小处理程序属性。
      Method parameters in javafx.scene.web with type arguments of type Rectangle2D
      Modifier and Type 方法 描述
      void WebEngine.setOnResized​(EventHandler<WebEvent<Rectangle2D>> handler)
      设置属性onResized的值。

    • Uses of Rectangle2D in javafx.stage

      Methods in javafx.stage that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D Screen.getBounds​()
      获得这个 Screen的界限。
      Rectangle2D Screen.getVisualBounds​()
      获得这个 Screen的视觉界限。
      Methods in javafx.stage with parameters of type Rectangle2D
      Modifier and Type 方法 描述
      static ObservableList<Screen> Screen.getScreensForRectangle​(Rectangle2D r)
      返回与所提供的矩形相交的ObservableList Screens 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.Side (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.Side

  • Packages that use Side
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of Side in javafx.geometry

      Methods in javafx.geometry that return Side
      Modifier and Type 方法 描述
      static Side Side.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Side[] Side.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of Side in javafx.scene.chart

      Methods in javafx.scene.chart that return Side
      Modifier and Type 方法 描述
      Side Chart.getLegendSide​()
      获取属性legendSide的值。
      Side Axis.getSide​()
      获取属性侧的值。
      Side Chart.getTitleSide​()
      获取属性titleSide的值。
      Methods in javafx.scene.chart that return types with arguments of type Side
      Modifier and Type 方法 描述
      ObjectProperty<Side> Chart.legendSideProperty​()
      图表侧面应显示图例
      ObjectProperty<Side> Axis.sideProperty​()
      该轴正在绘制的曲线的一侧
      ObjectProperty<Side> Chart.titleSideProperty​()
      显示标题的图表侧
      Methods in javafx.scene.chart with parameters of type Side
      Modifier and Type 方法 描述
      void Chart.setLegendSide​(Side value)
      设置属性legendSide的值。
      void Axis.setSide​(Side value)
      设置属性侧的值。
      void Chart.setTitleSide​(Side value)
      设置属性titleSide的值。

    • Uses of Side in javafx.scene.control

      Methods in javafx.scene.control that return Side
      Modifier and Type 方法 描述
      Side MenuButton.getPopupSide​()
      获取属性popupSide的值。
      Side TabPane.getSide​()
      TabPane中选项卡的当前位置。
      Methods in javafx.scene.control that return types with arguments of type Side
      Modifier and Type 方法 描述
      ObjectProperty<Side> MenuButton.popupSideProperty​()
      表示ContextMenu应该在哪一边打开与MenuButton相关的方面。
      ObjectProperty<Side> TabPane.sideProperty​()
      TabPane中选项卡的位置。
      Methods in javafx.scene.control with parameters of type Side
      Modifier and Type 方法 描述
      void MenuButton.setPopupSide​(Side value)
      设置属性popupSide的值。
      void TabPane.setSide​(Side value)
      将标签放置在此TabPane中的位置。
      void ContextMenu.show​(Node anchor, Side side, double dx, double dy)
      示出了 ContextMenu相对于给定锚节点，在由指定的侧 hpos个 vpos参数，并且由给定的偏移 dx倍 dy分别用于x轴和y轴，的值。

    • Uses of Side in javafx.scene.layout

      Methods in javafx.scene.layout that return Side
      Modifier and Type 方法 描述
      Side BackgroundPosition.getHorizontalSide​()
      背景图像被锚定在水平轴的一侧。
      Side BackgroundPosition.getVerticalSide​()
      沿着垂直轴的SideMap背景。
      Constructors in javafx.scene.layout with parameters of type Side
      Constructor 描述
      BackgroundPosition​(Side horizontalSide, double horizontalPosition, boolean horizontalAsPercentage, Side verticalSide, double verticalPosition, boolean verticalAsPercentage)
      Creates a new BackgroundPosition.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.VerticalDirection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.VerticalDirection

  • Packages that use VerticalDirection
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of VerticalDirection in javafx.geometry

      Methods in javafx.geometry that return VerticalDirection
      Modifier and Type 方法 描述
      static VerticalDirection VerticalDirection.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static VerticalDirection[] VerticalDirection.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.geometry.VPos (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.geometry.VPos

  • Packages that use VPos
    软件包 描述
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of VPos in javafx.geometry

      Methods in javafx.geometry that return VPos
      Modifier and Type 方法 描述
      VPos Pos.getVpos​()
      返回垂直定位/对齐。
      static VPos VPos.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static VPos[] VPos.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of VPos in javafx.scene.canvas

      Methods in javafx.scene.canvas that return VPos
      Modifier and Type 方法 描述
      VPos GraphicsContext.getTextBaseline​()
      获取当前的文本基线。
      Methods in javafx.scene.canvas with parameters of type VPos
      Modifier and Type 方法 描述
      void GraphicsContext.setTextBaseline​(VPos baseline)
      设置当前的文本基线。

    • Uses of VPos in javafx.scene.control

      Methods in javafx.scene.control that return VPos
      Modifier and Type 方法 描述
      VPos Separator.getValignment​()
      获取属性对齐的值。
      Methods in javafx.scene.control that return types with arguments of type VPos
      Modifier and Type 方法 描述
      ObjectProperty<VPos> Separator.valignmentProperty​()
      对于水平分隔符，指定分隔符控件空间内的分隔线的垂直对齐方式。
      Methods in javafx.scene.control with parameters of type VPos
      Modifier and Type 方法 描述
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      void Separator.setValignment​(VPos value)
      设置属性对齐的值。

    • Uses of VPos in javafx.scene.layout

      Methods in javafx.scene.layout that return VPos
      Modifier and Type 方法 描述
      VPos FlowPane.getRowValignment​()
      获取属性rowValignment的值。
      static VPos GridPane.getValignment​(Node child)
      如果设置，则返回小孩的对齐约束。
      VPos RowConstraints.getValignment​()
      获取属性对齐的值。
      Methods in javafx.scene.layout that return types with arguments of type VPos
      Modifier and Type 方法 描述
      ObjectProperty<VPos> FlowPane.rowValignmentProperty​()
      水平流花线每行内的节点垂直对齐。
      ObjectProperty<VPos> RowConstraints.valignmentProperty​()
      行的垂直对齐方式。
      Methods in javafx.scene.layout with parameters of type VPos
      Modifier and Type 方法 描述
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment, boolean isSnapToPixel)
      其中规定了儿童的它的区域内的工具方法的父通过定义 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void Region.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment, boolean isSnapToPixel)
      通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment)
      设置网格位置，跨度和子对齐方式。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow)
      设置网格位置，跨度和子对齐方式。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow, Insets margin)
      设置网格位置，跨度，对齐方式，增加优先级，以及子窗格包含在网格中时的边距。
      void FlowPane.setRowValignment​(VPos value)
      设置属性rowValignment的值。
      static void GridPane.setValignment​(Node child, VPos value)
      设置子窗格的垂直对齐方式。
      void RowConstraints.setValignment​(VPos value)
      设置属性对齐的值。
      Constructors in javafx.scene.layout with parameters of type VPos
      Constructor 描述
      RowConstraints​(double minHeight, double prefHeight, double maxHeight, Priority vgrow, VPos valignment, boolean fillHeight)
      创建具有固定大小范围，垂直增长优先级，垂直对齐和垂直填充行为的行约束对象。

    • Uses of VPos in javafx.scene.text

      Methods in javafx.scene.text that return VPos
      Modifier and Type 方法 描述
      VPos Text.getTextOrigin​()
      获取属性textOrigin的值。
      Methods in javafx.scene.text that return types with arguments of type VPos
      Modifier and Type 方法 描述
      ObjectProperty<VPos> Text.textOriginProperty​()
      以局部坐标定义文本坐标系的起点。
      Methods in javafx.scene.text with parameters of type VPos
      Modifier and Type 方法 描述
      void Text.setTextOrigin​(VPos value)
      设置属性textOrigin的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Collation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Enum Collation

  • java.lang.Object
    • java.lang.Enum<Collation>
      • javafx.print.Collation
  • All Implemented Interfaces:
    Serializable ， Comparable<Collation>

    public enum Collation
extends Enum<Collation>
    排序规则指定作业中打印文档的每个副本的介质页是否是顺序的。 它没有任何效果或相关性，除非打印多个作业副本。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      COLLATED
      文档的每个副本都打印在一起。
      UNCOLLATED
      相同编号的页面在输出中是连续的，例如：打印2页的2页的文件：第1页，第1页，第2页，第2页。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Collation valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Collation[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNCOLLATED

        public static final Collation UNCOLLATED
        相同编号的页面在输出中是连续的，例如：打印2页的2页的文件：第1页，第1页，第2页，第2页。

      • COLLATED

        public static final Collation COLLATED
        文档的每个副本都打印在一起。 FOr示例：打印2页的2页的文件：第1页，第2页，第1页，第2页。

    • 方法详细信息

      • values

        public static Collation[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Collation c : Collation.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Collation valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


javafx.print (Java SE 9 & JDK 9 )

javafx.print

Classes

  • JobSettings
  • PageLayout
  • PageRange
  • Paper
  • PaperSource
  • Printer
  • PrinterAttributes
  • PrinterJob
  • PrintResolution

Enums

  • Collation
  • PageOrientation
  • PrintColor
  • Printer.MarginType
  • PrinterJob.JobStatus
  • PrintQuality
  • PrintSides


javafx.print (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.print

提供JavaFX Printing API的公共类。

  • 类摘要
    Class 描述
    JobSettings
    JobSettings类封装了打印作业的大部分配置。
    PageLayout
    PageLayout封装了布局内容所需的信息。
    PageRange
    A PageRange用于选择或约束要打印的作业打印流页面。
    Paper
    封装打印机使用的纸介质尺寸的类。
    PaperSource
    PaperSource是用于纸张的进纸盘。
    Printer
    打印机实例表示打印作业的目的地。
    PrinterAttributes
    该类封装了与其作业打印功能和其他属性相关的打印机的属性。
    PrinterJob
    PrinterJob是JavaFX场景打印的起点。
    PrintResolution
    类别表示打印机在进给和交叉进给方向上的支持的设备分辨率，单位英寸（DPI）。
  • 枚举摘要
    Enum 描述
    Collation
    排序规则指定作业中打印文档的每个副本的介质页是否是顺序的。
    PageOrientation
    指定打印页面的介质页的方向。
    PrintColor
    描述打印是单色还是彩色的类。
    Printer.MarginType
    MarginType用于确定PageLayout的可打印区域。
    PrinterJob.JobStatus
    用于报告打印作业状态的枚举类。
    PrintQuality
    分类打印质量设置。
    PrintSides
    列举可能的双面（双面）打印模式的类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.print Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.print

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.print.JobSettings
    • javafx.print.PageLayout
    • javafx.print.PageRange
    • javafx.print.Paper
    • javafx.print.PaperSource
    • javafx.print.Printer
    • javafx.print.PrinterAttributes
    • javafx.print.PrinterJob
    • javafx.print.PrintResolution

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.print.Collation
      • javafx.print.PageOrientation
      • javafx.print.PrintColor
      • javafx.print.Printer.MarginType
      • javafx.print.PrinterJob.JobStatus
      • javafx.print.PrintQuality
      • javafx.print.PrintSides
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


JobSettings (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Class JobSettings

  • java.lang.Object
    • javafx.print.JobSettings

  • public final class JobSettings
extends Object
    JobSettings类封装了打印作业的大部分配置。 应用程序不 - 也不能 - 直接创建或设置JobSettings实例。 打印作业创建后已经安装了一个。

    如PrinterJob上所述，安装在该作业上的JobSettings将初始反映该作业最初关联的打印机的当前默认设置。

    JobSettings代表在作业的整个生命周期中保持不变，并且将其更新的成员属性与工作中的Printer中的更改兼容。 例如，作为通过平台对话框进行用户交互的结果。 不兼容的设置通常会导致设置恢复为新打印机的默认设置。

    一旦用户通过使用“接受”选项关闭对话框来批准设置，对用户与对话框交互产生的设置的任何隐式或显式更新将被传播并可见。

    对于大多数打印应用程序，让用户设置所需的选项并将其传播到作业可能就足够了。 对于需要它们的应用程序，有各种选项的setter和getter方法，也可以作为属性使用，并且可以通过这些属性监视和更新设置值的更改。

    并非所有打印机都提供所有设置值。 例如，打印机可能不支持双面打印。 有关如何确定支持的设置，请参阅Printer课程。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Collation> collation
      属性代表 Collation一个实例。
      IntegerProperty copies
      IntegerProperty表示要打印的作业的份数。
      StringProperty jobName
      StringProperty代表作业的名称。
      ObjectProperty<PageLayout> pageLayout
      属性代表 PageLayout一个实例。
      ObjectProperty pageRanges
      一个 ObjectProperty其值表示作为PageRange数组打印的作业页面。
      ObjectProperty<PaperSource> paperSource
      属性代表 PaperSource一个实例。
      ObjectProperty<PrintColor> printColor
      属性代表 PrintColor一个实例。
      ObjectProperty<PrintQuality> printQuality
      属性代表 PrintQuality一个实例。
      ObjectProperty<PrintResolution> printResolution
      属性代表 PrintResolution一个实例。
      ObjectProperty<PrintSides> printSides
      属性代表 PrintSides一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Collation> collationProperty​()
      属性代表 Collation 。
      IntegerProperty copiesProperty​()
      IntegerProperty代表要打印的作业的份数。
      Collation getCollation​()
      排序规则确定打印文档的多个副本时如何排序纸张。
      int getCopies​()
      获取要打印的份数。
      String getJobName​()
      获取工作的名称。
      PageLayout getPageLayout​()
      获取此作业的当前页面布局。
      PageRange[] getPageRanges​()
      要打印的页面范围。 null始终表示所有页面。
      PaperSource getPaperSource​()
      获取属性paperSource的值。
      PrintColor getPrintColor​()
      获取属性printColor的值。
      PrintQuality getPrintQuality​()
      获取属性printQuality的值。
      PrintResolution getPrintResolution​()
      PrintSides getPrintSides​()
      如果打印机支持它，则可以在介质（纸张）的两面上打印作业，即双面打印。
      StringProperty jobNameProperty​()
      StringProperty代表作业的名称。
      ObjectProperty<PageLayout> pageLayoutProperty​()
      属性代表 PageLayout一个实例。
      ObjectProperty pageRangesProperty​()
      一个 ObjectProperty其值表示作为PageRange数组打印的作业页面。
      ObjectProperty<PaperSource> paperSourceProperty​()
      属性代表 PaperSource 。
      ObjectProperty<PrintColor> printColorProperty​()
      属性代表 PrintColor一个实例。
      ObjectProperty<PrintQuality> printQualityProperty​()
      属性代表 PrintQuality 。
      ObjectProperty<PrintResolution> printResolutionProperty​()
      属性代表 PrintResolution一个实例。
      ObjectProperty<PrintSides> printSidesProperty​()
      属性代表 PrintSides 。
      void setCollation​(Collation collation)
      设置 Collation属性。
      void setCopies​(int nCopies)
      设置要打印的份数。
      void setJobName​(String name)
      设置工作的名称。
      void setPageLayout​(PageLayout pageLayout)
      将PageLayout设置为使用。
      void setPageRanges​(PageRange... pages)
      要打印为PageRange数组的页面范围。
      void setPaperSource​(PaperSource value)
      设置属性paperSource的值。
      void setPrintColor​(PrintColor color)
      设置 PrintColor属性。
      void setPrintQuality​(PrintQuality quality)
      设置 PrintQuality属性。
      void setPrintResolution​(PrintResolution resolution)
      设置 PrintResolution属性。
      void setPrintSides​(PrintSides sides)
      设置控制双面打印的 PrintSides属性。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • jobName

        public final StringProperty jobNameProperty
        StringProperty表示作业的名称。
        另请参见：
        getJobName() ， setJobName(String)

      • copies

        public final IntegerProperty copiesProperty
        IntegerProperty表示要打印的作业的份数。
        另请参见：
        getCopies() ， setCopies(int)

      • pageRanges

        public final ObjectProperty pageRangesProperty
        一个ObjectProperty其值表示作为PageRange数组打印的作业页面。 空值表示打印所有页面。 否则，它必须是一个不重叠的PageRange实例数组，按增加页码排序。 页数从1（一）开始。 空数组被认为等同于一个空数组。

        非法或不支持（由打印机）设置的页面范围将被忽略。

        超过在打印期间由作业成像的页数超过的范围不会引起任何错误。

        另请参见：
        getPageRanges() ， setPageRanges(PageRange[])

      • printSides

        public final ObjectProperty<PrintSides> printSidesProperty
        属性代表 PrintSides一个实例。
        另请参见：
        getPrintSides() ， setPrintSides(PrintSides)

      • collation

        public final ObjectProperty<Collation> collationProperty
        属性代表 Collation一个实例。
        另请参见：
        getCollation() ， setCollation(Collation)

      • printColor

        public final ObjectProperty<PrintColor> printColorProperty
        属性代表 PrintColor一个实例。
        另请参见：
        getPrintColor() ， setPrintColor(PrintColor)

      • printQuality

        public final ObjectProperty<PrintQuality> printQualityProperty
        属性代表 PrintQuality 。
        另请参见：
        getPrintQuality() ， setPrintQuality(PrintQuality)

      • printResolution

        public final ObjectProperty<PrintResolution> printResolutionProperty
        属性代表 PrintResolution一个实例。
        另请参见：
        getPrintResolution() ， setPrintResolution(PrintResolution)

      • paperSource

        public final ObjectProperty<PaperSource> paperSourceProperty
        属性代表 PaperSource一个实例。
        另请参见：
        getPaperSource() ， setPaperSource(PaperSource)

      • pageLayout

        public final ObjectProperty<PageLayout> pageLayoutProperty
        属性代表 PageLayout一个实例。
        另请参见：
        getPageLayout() ， setPageLayout(PageLayout)

    • 方法详细信息

      • jobNameProperty

        public final StringProperty jobNameProperty​()
        StringProperty代表作业的名称。
        另请参见：
        getJobName() ， setJobName(String)

      • getJobName

        public String getJobName​()
        获取工作的名称。
        结果
        一个表示作业名称的字符串

      • setJobName

        public void setJobName​(String name)
        设置工作的名称。
        参数
        name - 表示作业名称的字符串

      • copiesProperty

        public final IntegerProperty copiesProperty​()
        IntegerProperty表示要打印的作业的份数。
        另请参见：
        getCopies() ， setCopies(int)

      • getCopies

        public int getCopies​()
        获取要打印的份数。
        结果
        要打印的份数

      • setCopies

        public final void setCopies​(int nCopies)
        设置要打印的份数。
        参数
        nCopies - 要打印的份数

      • pageRangesProperty

        public final ObjectProperty pageRangesProperty​()
        一个ObjectProperty其值表示作为PageRange数组打印的作业页面。 空值表示打印所有页面。 否则，它必须是一个不重叠的PageRange实例数组，按增加页码排序。 页数从1（一）开始。 空数组被认为等同于一个空数组。

        非法或不支持（由打印机）设置的页面范围将被忽略。

        超过在打印期间由作业成像的页数超过的范围不会引起任何错误。

        另请参见：
        getPageRanges() ， setPageRanges(PageRange[])

      • getPageRanges

        public PageRange[] getPageRanges​()
        要打印的页面范围。 null始终表示所有页面。 详见pageRangesProperty() 。
        结果
        null或上面指定的数组

      • setPageRanges

        public void setPageRanges​(PageRange... pages)
        要打印为PageRange数组的页面范围。 使用varargs意味着一个单一范围的常见情况可以自动装箱。 ((PageRange[])null)总是意味着所有页面，因为这是默认值，它不太可能被使用。 详见pageRangesProperty() 。
        参数
        pages - null或上面指定的varargs数组

      • printSidesProperty

        public final ObjectProperty<PrintSides> printSidesProperty​()
        属性代表 PrintSides 。
        另请参见：
        getPrintSides() ， setPrintSides(PrintSides)

      • getPrintSides

        public PrintSides getPrintSides​()
        如果打印机支持它，则可以在介质（纸张）的两面上打印作业，即双面打印。 此方法返回所选设置。
        结果
        双面（侧）设置。

      • setPrintSides

        public void setPrintSides​(PrintSides sides)
        设置控制双面打印的PrintSides属性。 将忽略空值。
        参数
        sides - 双面数量的新设置。

      • collationProperty

        public final ObjectProperty<Collation> collationProperty​()
        属性代表 Collation一个实例。
        另请参见：
        getCollation() ， setCollation(Collation)

      • getCollation

        public Collation getCollation​()
        排序规则确定打印文档的多个副本时如何排序纸张。 因此，如果打印了2张以上的两张以上的文件副本，则仅有相关性。 一张纸是物理介质，所以打印为N页或双面的2页的文档可能仍然只有一张。 整理的打印作业将生成具有按顺序排列的文档的文档的文档。 未分类的工作一起收集同一张纸的多份副本。 未分类（ false ）是典型的默认值。
        结果
        整理

      • setCollation

        public void setCollation​(Collation collation)
        设置Collation属性。 将忽略空值。
        参数
        collation - 排序 collation新设置

      • printColorProperty

        public final ObjectProperty<PrintColor> printColorProperty​()
        属性代表 PrintColor一个实例。
        另请参见：
        getPrintColor() ， setPrintColor(PrintColor)

      • getPrintColor

        public PrintColor getPrintColor​()
        获取属性printColor的值。
        Property description:
        属性代表 PrintColor一个实例。

      • setPrintColor

        public void setPrintColor​(PrintColor color)
        设置PrintColor属性。 将忽略空值。

        参数
        color - 打印颜色的新设置。

      • printQualityProperty

        public final ObjectProperty<PrintQuality> printQualityProperty​()
        物业代表 PrintQuality 。
        另请参见：
        getPrintQuality() ， setPrintQuality(PrintQuality)

      • getPrintQuality

        public PrintQuality getPrintQuality​()
        获取属性printQuality的值。
        Property description:
        属性代表 PrintQuality一个实例。

      • setPrintQuality

        public void setPrintQuality​(PrintQuality quality)
        设置PrintQuality属性。 将忽略空值。

        注意质量和分辨率重叠的概念。 因此，打印机可以支持设置一个或另一个但不是两者。 以编程方式设置的应用程序应该查询两个属性，并从支持的值中进行适当的选择。 如果打印机支持非标准值，则代码可能无法区分打印机对这些值的解释，并且最符合选择符合要求的标准值。

        参数
        quality - 打印质量的新设置。

      • printResolutionProperty

        public final ObjectProperty<PrintResolution> printResolutionProperty​()
        属性代表 PrintResolution一个实例。
        另请参见：
        getPrintResolution() ， setPrintResolution(PrintResolution)

      • getPrintResolution

        public PrintResolution getPrintResolution​()
        结果
        打印分辨率

      • setPrintResolution

        public void setPrintResolution​(PrintResolution resolution)
        设置PrintResolution属性。 将忽略空值。

        注意质量和分辨率重叠的概念。 因此，打印机可以支持设置一个或另一个但不是两者。 以编程方式设置的应用程序应该查询两个属性，并从支持的值中进行适当的选择。 如果打印机支持非标准值，则代码可能无法区分打印机对这些值的解释，并且最符合选择符合要求的标准值。

        参数
        resolution - 打印分辨率的新设置。

      • paperSourceProperty

        public final ObjectProperty<PaperSource> paperSourceProperty​()
        属性代表 PaperSource一个实例。
        另请参见：
        getPaperSource() ， setPaperSource(PaperSource)

      • getPaperSource

        public PaperSource getPaperSource​()
        获取属性paperSource的值。
        Property description:
        属性代表 PaperSource一个实例。

      • setPaperSource

        public void setPaperSource​(PaperSource value)
        设置属性paperSource的值。
        Property description:
        属性代表 PaperSource一个实例。

      • pageLayoutProperty

        public final ObjectProperty<PageLayout> pageLayoutProperty​()
        属性代表 PageLayout一个实例。
        另请参见：
        getPageLayout() ， setPageLayout(PageLayout)

      • getPageLayout

        public PageLayout getPageLayout​()
        获取此作业的当前页面布局。
        结果
        页面布局用于作业。

      • setPageLayout

        public void setPageLayout​(PageLayout pageLayout)
        将PageLayout设置为使用。
        参数
        pageLayout - 要使用的页面布局。

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PageLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Class PageLayout

  • java.lang.Object
    • javafx.print.PageLayout

  • public final class PageLayout
extends Object
    PageLayout封装了布局内容所需的信息。 报告的宽度和高度可以被认为等同于Window执行的剪辑。 获取PageLayout实例的应用程序将需要检查宽度和高度来执行布局和分页。 页面呈现不需要其他信息，如方向和正在使用的纸张以及该区域之外的边距。

    打印机通常具有无法打印的硬件边距。 在特定打印机的上下文中从PrinterJob获取的PageLayout实例将被正确地设置为在整个区域打印。 如果应用程序调整此边界之外的可打印区域，那么这些区域的渲染将被设备剪切。

    在这些硬件利润范围内，应用程序可能会定义其所需的任何可打印区域。 所得到的可打印区域将在打印时定义应用程序可用的页面的有效尺寸。

    将基于一台打印机配置的PageLayout应用到其他打印机上的作业可能无法正常工作，因为第二台打印机可能不支持相同的边距，甚至可能不支持同一纸张。 在这种情况下，必须对新的打印机验证PageLayout。

    PageLayout是不可变的。

    从以下版本开始：
    JavaFX 8.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      double getBottomMargin​()
      以点为单位返回页面布局的底部边距。
      double getLeftMargin​()
      以点为单位返回页面布局的左边距。
      PageOrientation getPageOrientation​()
      Paper getPaper​()
      用纸。
      double getPrintableHeight​()
      考虑到方向，返回页面可打印区域的高度尺寸，以1/72英寸为单位。
      double getPrintableWidth​()
      考虑到方向，返回页面可打印区域的宽度尺寸，以1/72英寸为单位。
      double getRightMargin​()
      以分数返回页面布局的右边距。
      double getTopMargin​()
      以分数返回页面布局的上边距。
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getPageOrientation

        public PageOrientation getPageOrientation​()

      • getPaper

        public Paper getPaper​()
        用纸。
        结果
        该纸用于此 PageLayout 。

      • getPrintableWidth

        public double getPrintableWidth​()
        考虑到方向，返回页面可打印区域的宽度尺寸，以1/72英寸为单位。

        可打印区域是宽度或高度减少每边所请求的边距。 如果请求的边距小于硬件边距，则可能会由设备削减渲染。

        由于返回的值表示方向，这意味着如果方向为LANDSCAPE或REVERSE_LANDSCAPE，则从底层纸张的高度减去左右边距，因为它旋转了90度。

        结果
        可打印宽度的点数。

      • getPrintableHeight

        public double getPrintableHeight​()
        考虑到方向，返回页面可打印区域的高度尺寸，以1/72英寸为单位。

        可打印区域是宽度或高度减少每边所请求的边距。 如果请求的边距小于硬件边距，则可能会由设备削减渲染。

        由于返回的值表示方向，这意味着如果方向为LANDSCAPE或REVERSE_LANDSCAPE，则从底层纸张的高度减去顶部和底部边距，因为它旋转了90度。

        结果
        可印刷高度分。

      • getLeftMargin

        public double getLeftMargin​()
        以点为单位返回页面布局的左边距。 该值位于PageLayout的方向。
        结果
        左边距点。

      • getRightMargin

        public double getRightMargin​()
        以分数返回页面布局的右边距。 该值位于PageLayout的方向。
        结果
        右边的点数。

      • getTopMargin

        public double getTopMargin​()
        以分数返回页面布局的上边距。 该值位于PageLayout的方向。
        结果
        顶点保证金。

      • getBottomMargin

        public double getBottomMargin​()
        以点为单位返回页面布局的底部边距。 该值位于PageLayout的方向。
        结果
        底边点数。

      • equals

        public boolean equals​(Object o)
        说明从类别复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，其中声明相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap所提供的那样 。

        hashCode的总合同是：

        • 只要在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中没有使用的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PageOrientation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Enum PageOrientation

  • java.lang.Object
    • java.lang.Enum<PageOrientation>
      • javafx.print.PageOrientation
  • All Implemented Interfaces:
    Serializable ， Comparable<PageOrientation>

    public enum PageOrientation
extends Enum<PageOrientation>
    指定打印页面的介质页的方向。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      LANDSCAPE
      可打印区域的起点位于纸张的左下方。
      PORTRAIT
      可打印区域的起点位于纸张的左上方。
      REVERSE_LANDSCAPE
      可打印区域的起点位于纸张的右上方。
      REVERSE_PORTRAIT
      可打印区域的起点位于纸张的右下方。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PageOrientation valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PageOrientation[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PORTRAIT

        public static final PageOrientation PORTRAIT
        可打印区域的起点位于纸张的左上方。 X坐标将越过纸张的短边。 Y坐标沿纸张的长边将会增加。

      • LANDSCAPE

        public static final PageOrientation LANDSCAPE
        可打印区域的起点位于纸张的左下方。 X坐标将沿纸张的长边增加。 Y坐标将沿着纸张的短边增加。

      • REVERSE_PORTRAIT

        public static final PageOrientation REVERSE_PORTRAIT
        可打印区域的起点位于纸张的右下方。 X坐标将越过纸张的短边。 Y坐标沿纸张的长边将会增加。 即从PORTRAIT旋转180度。

      • REVERSE_LANDSCAPE

        public static final PageOrientation REVERSE_LANDSCAPE
        可打印区域的起点位于纸张的右上方。 X坐标将沿纸张的长边增加。 Y坐标将沿着纸张的短边增加。 即从LANDSCAPE旋转180度。

    • 方法详细信息

      • values

        public static PageOrientation[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PageOrientation c : PageOrientation.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PageOrientation valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PageRange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Class PageRange

  • java.lang.Object
    • javafx.print.PageRange

  • public final class PageRange
extends Object
    A PageRange用于选择或约束作业打印流页面进行打印。 页面编号从1开始，以符合用户的期望。 起始页面必须大于零且小于或等于结束页面。 如果开始和结束相等，范围是指单个页面。 超出作业页数的值在打印过程中被无害化地忽略。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyIntegerProperty endPage
      IntegerProperty表示范围的结束页码。
      ReadOnlyIntegerProperty startPage
      IntegerProperty表示范围的起始页码。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PageRange​(int startPage, int endPage)
      使用指定的开始和结束页码创建一个新的PageRange。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ReadOnlyIntegerProperty endPageProperty​()
      IntegerProperty表示范围的结束页码。
      int | getEndPage​()
      int | getStartPage​()
      ReadOnlyIntegerProperty startPageProperty​()
      IntegerProperty表示范围的起始页码。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • startPage

        public ReadOnlyIntegerProperty startPageProperty
        IntegerProperty表示范围的起始页码。 详情请见getStartPage() 。
        另请参见：
        getStartPage()

      • endPage

        public ReadOnlyIntegerProperty endPageProperty
        IntegerProperty表示范围的结束页码。 详见getEndPage() 。
        另请参见：
        getEndPage()

    • 构造方法详细信息

      • PageRange

        public PageRange​(int startPage,
                 int endPage)
        使用指定的开始和结束页码创建一个新的PageRange。
        参数
        startPage - 范围内的第一页。
        endPage - 范围内的最后一页。
        异常
        IllegalArgumentException - 如果页面范围无效

    • 方法详细信息

      • startPageProperty

        public ReadOnlyIntegerProperty startPageProperty​()
        IntegerProperty表示范围的起始页码。 有关详细信息，请参阅getStartPage() 。
        另请参见：
        getStartPage()

      • getStartPage

        public int getStartPage​()
        结果
        范围的起始页。

      • endPageProperty

        public ReadOnlyIntegerProperty endPageProperty​()
        IntegerProperty表示范围的结束页码。 有关详细信息，请参阅getEndPage() 。
        另请参见：
        getEndPage()

      • getEndPage

        public int getEndPage​()
        结果
        范围的结束页。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Paper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Class Paper

  • java.lang.Object
    • javafx.print.Paper

  • public final class Paper
extends Object
    封装打印机使用的纸介质尺寸的类。

    打印机枚举的纸张尺寸是可以选择用于在该打印机上打印的纸张尺寸的权威来源。

    但是为方便起见，该类预先定义了一些最常见的纸张尺寸，以便应用程序可以轻松地从代码设置默认参数，例如参考Paper.A4

    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Paper A0
      指定ISO A0尺寸，841 mm×1189 mm。
      static Paper A1
      指定ISO A1尺寸，594 mm×841 mm。
      static Paper A2
      指定ISO A2尺寸，420 mm×594 mm。
      static Paper A3
      指定ISO A3尺寸，297 mm x 420 mm。
      static Paper A4
      指定ISO A4尺寸，210 mm×297 mm。
      static Paper A5
      指定ISO A5尺寸，148 mm×210 mm。
      static Paper A6
      指定ISO A6尺寸，105 mm×148 mm。
      static Paper C
      指定工程C尺寸，17英寸×22英寸。
      static Paper DESIGNATED_LONG
      指定ISO指定长尺寸，110 mm×220 mm。
      static Paper EXECUTIVE
      指定行政大小，7.25英寸×10.5英寸。
      static Paper JAPANESE_POSTCARD
      指定日本明信片大小，100毫米×148毫米。
      static Paper JIS_B4
      指定JIS B4尺寸，257 mm×364 mm。
      static Paper JIS_B5
      指定JIS B5尺寸，182 mm×257 mm。
      static Paper JIS_B6
      指定JIS B6尺寸，128 mm×182 mm。
      static Paper LEGAL
      指定北美合法尺寸，8.5英寸×14英寸。
      static Paper MONARCH_ENVELOPE
      指定Monarch信封尺寸，3.87英寸×7.5英寸。
      static Paper NA_8X10
      指定北美8寸×10英寸的纸。
      static Paper NA_LETTER
      指定北美字母大小，8.5英寸×11英寸
      static Paper NA_NUMBER_10_ENVELOPE
      指定北美10号商业信封尺寸，4.125英寸×9.5英寸。
      static Paper TABLOID
      指定小时大小，11英寸×17英寸。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      double getHeight​()
      以磅数（1/72英寸）获取纸张的高度
      String getName​()
      获取论文名称。
      double getWidth​()
      以磅数（1/72英寸）获取纸张的宽度
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • A0

        public static final Paper A0
        指定ISO A0尺寸，841 mm×1189 mm。

      • A1

        public static final Paper A1
        指定ISO A1尺寸，594 mm×841 mm。

      • A2

        public static final Paper A2
        指定ISO A2尺寸，420 mm×594 mm。

      • A3

        public static final Paper A3
        指定ISO A3尺寸，297 mm x 420 mm。

      • A4

        public static final Paper A4
        指定ISO A4尺寸，210 mm×297 mm。

      • A5

        public static final Paper A5
        指定ISO A5尺寸，148 mm×210 mm。

      • A6

        public static final Paper A6
        指定ISO A6尺寸，105 mm×148 mm。

      • DESIGNATED_LONG

        public static final Paper DESIGNATED_LONG
        指定ISO指定长尺寸，110 mm×220 mm。

      • NA_LETTER

        public static final Paper NA_LETTER
        指定北美字母大小，8.5英寸×11英寸

      • LEGAL

        public static final Paper LEGAL
        指定北美合法尺寸，8.5英寸×14英寸。

      • TABLOID

        public static final Paper TABLOID
        指定小时大小，11英寸×17英寸。

      • EXECUTIVE

        public static final Paper EXECUTIVE
        指定行政大小，7.25英寸×10.5英寸。

      • NA_8X10

        public static final Paper NA_8X10
        指定北美8寸×10英寸的纸。

      • MONARCH_ENVELOPE

        public static final Paper MONARCH_ENVELOPE
        指定Monarch信封尺寸，3.87英寸×7.5英寸。

      • NA_NUMBER_10_ENVELOPE

        public static final Paper NA_NUMBER_10_ENVELOPE
        指定北美10号商业信封尺寸，4.125英寸×9.5英寸。

      • C

        public static final Paper C
        指定工程C尺寸，17英寸×22英寸。

      • JIS_B4

        public static final Paper JIS_B4
        指定JIS B4尺寸，257 mm×364 mm。

      • JIS_B5

        public static final Paper JIS_B5
        指定JIS B5尺寸，182 mm×257 mm。

      • JIS_B6

        public static final Paper JIS_B6
        指定JIS B6尺寸，128 mm×182 mm。

      • JAPANESE_POSTCARD

        public static final Paper JAPANESE_POSTCARD
        指定日本明信片大小，100毫米×148毫米。

    • 方法详细信息

      • getName

        public final String getName​()
        获取论文名称。 这可能不是直接用于用户显示，因为它不是本地化的。
        结果
        论文名称

      • getWidth

        public final double getWidth​()
        以磅数（1/72英寸）获取纸张的宽度
        结果
        纸张的宽度（1/72英寸）

      • getHeight

        public final double getHeight​()
        以磅数（1/72英寸）获取纸张的高度
        结果
        纸的高度（1/72英寸）

      • hashCode

        public final int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如由HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public final boolean equals​(Object o)
        描述从类别复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        如果此对象与obj参数相同， true ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public final String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般情况下， toString方法返回一个“ toString代表”此对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PaperSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Class PaperSource

  • java.lang.Object
    • javafx.print.PaperSource

  • public final class PaperSource
extends Object
    PaperSource是用于纸张的进纸盘。 这里列举的值涵盖许多最常见的来源，可能映射到平台ID。 但是也有打印机特定的托盘名称可能正在使用。 因此，支持的纸张来源的查询可能包括其他值。
    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PaperSource AUTOMATIC
      指定自动选择纸盘。
      static PaperSource BOTTOM
      指定选择底部托盘。
      static PaperSource ENVELOPE
      指定选择ENVELOPE纸盘。
      static PaperSource LARGE_CAPACITY
      指定选择LARGE_CAPACITY托盘。
      static PaperSource MAIN
      指定选择MAIN纸盘。
      static PaperSource MANUAL
      指定选择手动纸盘。
      static PaperSource MIDDLE
      指定选择MIDDLE纸盘。
      static PaperSource SIDE
      指定选择SIDE托盘。
      static PaperSource TOP
      指定选择TOP托盘。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getName​()
      返回此纸张来源的名称。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • AUTOMATIC

        public static final PaperSource AUTOMATIC
        指定自动选择纸盘。

      • MAIN

        public static final PaperSource MAIN
        指定选择MAIN纸盘。

      • MANUAL

        public static final PaperSource MANUAL
        指定选择手动纸盘。

      • BOTTOM

        public static final PaperSource BOTTOM
        指定选择底部托盘。

      • MIDDLE

        public static final PaperSource MIDDLE
        指定选择MIDDLE纸盘。

      • TOP

        public static final PaperSource TOP
        指定选择TOP托盘。

      • SIDE

        public static final PaperSource SIDE
        指定选择SIDE托盘。

      • ENVELOPE

        public static final PaperSource ENVELOPE
        指定选择ENVELOPE纸盘。

      • LARGE_CAPACITY

        public static final PaperSource LARGE_CAPACITY
        指定选择LARGE_CAPACITY托盘。

    • 方法详细信息

      • getName

        public String getName​()
        返回此纸张来源的名称。
        结果
        纸源名称。

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PrintColor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Enum PrintColor

  • java.lang.Object
    • java.lang.Enum<PrintColor>
      • javafx.print.PrintColor
  • All Implemented Interfaces:
    Serializable ， Comparable<PrintColor>

    public enum PrintColor
extends Enum<PrintColor>
    描述打印是单色还是彩色的类。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      COLOR
      指定彩色打印。
      MONOCHROME
      指定单色或灰阶打印。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PrintColor valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PrintColor[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • COLOR

        public static final PrintColor COLOR
        指定彩色打印。

      • MONOCHROME

        public static final PrintColor MONOCHROME
        指定单色或灰阶打印。

    • 方法详细信息

      • values

        public static PrintColor[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PrintColor c : PrintColor.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PrintColor valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Printer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Class Printer

  • java.lang.Object
    • javafx.print.Printer

  • public final class Printer
extends Object
    打印机实例表示打印作业的目的地。

    打印机可能被枚举并选择用于打印作业。

    打印机默认设置的配置然后用于填充作业的初始设置。

    由于在执行程序期间打印机的可用性可能由于管理动作而改变，所以长时间运行的程序已经缓存已经脱机的打印机，可以使用该实例创建一个作业，但是打印将失败。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      static ReadOnlyObjectProperty<Printer> defaultPrinter
      表示当前默认打印机的只读对象属性。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Printer.MarginType
      MarginType用于确定PageLayout的可打印区域。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PageLayout createPageLayout​(Paper paper, PageOrientation orient, double lMargin, double rMargin, double tMargin, double bMargin)
      使用指定的参数获取此打印机的新PageLayout。
      PageLayout createPageLayout​(Paper paper, PageOrientation orient, Printer.MarginType mType)
      使用指定的参数获取此打印机的新PageLayout实例。
      static ReadOnlyObjectProperty<Printer> defaultPrinterProperty​()
      表示当前默认打印机的只读对象属性。
      static ObservableSet<Printer> getAllPrinters​()
      检索已安装的打印机。
      PageLayout getDefaultPageLayout​()
      返回此打印机的默认页面布局。
      static Printer getDefaultPrinter​()
      检索默认打印机。
      String getName​()
      返回基础系统使用的名称，以便向用户和/或应用程序标识打印机。
      PrinterAttributes getPrinterAttributes​()
      检索封装打印机属性和功能的委托对象。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • defaultPrinter

        public static ReadOnlyObjectProperty<Printer> defaultPrinterProperty
        表示当前默认打印机的只读对象属性。 如果没有安装的打印机，包装的值将为空。
        另请参见：
        getDefaultPrinter()

    • 方法详细信息

      • getAllPrinters

        public static ObservableSet<Printer> getAllPrinters​()
        检索已安装的打印机。 该组打印机可能是动态的。 因此，不能保证结果在调用到调用时是相同的，而是应该仅在应用程序环境中的默认更改的情况下进行更改。

        注意：由于打印机可能已安装，而是离线，则应用程序可能希望在使用打印机之前查询打印机的状态。

        结果
        如果没有打印机，可能为null。
        异常
        SecurityException - 如果应用程序没有浏览打印机的权限。

      • defaultPrinterProperty

        public static ReadOnlyObjectProperty<Printer> defaultPrinterProperty​()
        表示当前默认打印机的只读对象属性。 如果没有安装的打印机，包装的值将为空。
        另请参见：
        getDefaultPrinter()

      • getDefaultPrinter

        public static Printer getDefaultPrinter​()
        检索默认打印机。 如果没有安装打印机，可能返回null。

        可用打印机的配置可能是动态的。 因此，不能保证结果在调用到调用时是相同的，而是应该仅在应用程序环境中的默认更改的情况下进行更改。

        结果
        默认打印机或null。
        异常
        SecurityException - 如果应用程序没有浏览打印机的权限。

      • getName

        public String getName​()
        返回基础系统使用的名称，以便向用户和/或应用程序标识打印机。
        结果
        打印机名称。

      • getPrinterAttributes

        public PrinterAttributes getPrinterAttributes​()
        检索封装打印机属性和功能的委托对象。
        结果
        打印机属性。

      • getDefaultPageLayout

        public PageLayout getDefaultPageLayout​()
        返回此打印机的默认页面布局。
        结果
        默认页面布局。

      • createPageLayout

        public PageLayout createPageLayout​(Paper paper,
                                   PageOrientation orient,
                                   Printer.MarginType mType)
        使用指定的参数获取此打印机的新PageLayout实例。 论文应该是受支持的论文之一，而且方向应该是一个支持的方向。 如果打印机不能按照指定的方式支持布局，则会将返回的布局调整为受支持的配置
        参数
        paper - 使用的纸
        orient - 使用的方向
        mType - 要使用的保证金类型
        结果
        PageLayout基于指定的参数。
        异常
        NullPointerException - 如果任何参数为空。

      • createPageLayout

        public PageLayout createPageLayout​(Paper paper,
                                   PageOrientation orient,
                                   double lMargin,
                                   double rMargin,
                                   double tMargin,
                                   double bMargin)
        使用指定的参数获取此打印机的新PageLayout。 论文应该是受支持的论文之一，而且方向应该是一个支持的方向。

        边距值以1/72英寸为单位。 边距将根据打印机支持的边距进行验证，并在必要时进行调整。 这种方法对于希望与默认边距不同（例如更宽）的边距的客户端通常是有用的，例如左上角和右边的顶部和底部为“1”。

        需要知道什么边际值合法的客户应首先使用HARDWARE_MINIMUM利润来获取PageLayout。

        如果打印机不能按照指定的方式支持布局，则会将返回的布局调整为受支持的配置

        参数
        paper - 使用的纸张
        orient - 使用的方向
        lMargin - 左边距用于pts。
        rMargin - 在pts中使用的正确保证金。
        tMargin - 在pts中使用的 tMargin 。
        bMargin - 在pts中使用的底部边距。
        结果
        PageLayout基于指定的参数。
        异常
        NullPointerException - 如果纸或东方为空。
        IllegalArgumentException - 如果任何边距值小于零。

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Printer.MarginType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Enum Printer.MarginType

  • java.lang.Object
    • java.lang.Enum<Printer.MarginType>
      • javafx.print.Printer.MarginType
  • All Implemented Interfaces:
    Serializable ， Comparable<Printer.MarginType>
    Enclosing class:
    Printer

    public static enum Printer.MarginType
extends Enum<Printer.MarginType>
    MarginType用于确定PageLayout的可打印区域。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DEFAULT
      这要求所有方面的默认0.75英寸的边距。
      EQUAL
      选择最大的四个硬件边距，并将其用于所有的边距，以使边框在所有方面相等。
      EQUAL_OPPOSITES
      类似于 EQUAL ，但它分别选择左/右硬件边距和顶部/底部硬件边距中较大的一个，以使顶部和底部边距相等，左右边距相等。
      HARDWARE_MINIMUM
      请求边距设置为硬件允许的每一侧最小。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Printer.MarginType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Printer.MarginType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DEFAULT

        public static final Printer.MarginType DEFAULT
        这要求所有方面的默认0.75英寸的边距。 这被认为是一个常见的默认值，并且由所有已知的打印机支持。 但是，如果纸张太小，可能会调整，以确保边距不超过较小尺寸的50％。 期望处理这种小型媒体的应用程序可能会明确指定所需的边距。 在不太可能发生的情况下，硬件边距大于0.75“，它将被调整到与所有方面相同的硬件最小值。

      • HARDWARE_MINIMUM

        public static final Printer.MarginType HARDWARE_MINIMUM
        请求边距设置为硬件允许的每一侧最小。 这创造了最大的可打印区域，但是如果纸张太小，或者纸张的不同侧面存在显着变化，则边缘可能不是美观的。

        这对于想要知道这一点的应用程序也是有用的，因此它可以构建一个适合这些边距的新的PageLayout。

      • EQUAL

        public static final Printer.MarginType EQUAL
        选择最大的四个硬件边距，并将其用于所有的边距，以使边框在所有方面相等。

      • EQUAL_OPPOSITES

        public static final Printer.MarginType EQUAL_OPPOSITES
        类似于 EQUAL ，但是它分别选择较大的左/右硬件边距和顶部/底部硬件边距，以使顶部和底部边距相等，左右边距相等。

    • 方法详细信息

      • values

        public static Printer.MarginType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Printer.MarginType c : Printer.MarginType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Printer.MarginType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PrinterAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Class PrinterAttributes

  • java.lang.Object
    • javafx.print.PrinterAttributes

  • public final class PrinterAttributes
extends Object
    该类封装了与其作业打印功能和其他属性相关的打印机的属性。

    有适当的方法检索默认值或当前值，以及支持值的集合或范围。

    该类的实例是Printer代表，必须从打印机获取。 当打印机的更改设置超出此API的范围时，它们不能被应用程序所突变。

    从以下版本开始：
    JavaFX 8.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Collation getDefaultCollation​()
      默认的排序规则设置。
      int getDefaultCopies​()
      要打印的默认份数。
      PageOrientation getDefaultPageOrientation​()
      返回此打印机上纸张的默认方向。
      Paper getDefaultPaper​()
      返回此打印机使用的默认纸张尺寸。
      PaperSource getDefaultPaperSource​()
      返回默认纸张输入源/纸盘/
      PrintColor getDefaultPrintColor​()
      获取默认颜色设置：灰度或颜色
      PrintQuality getDefaultPrintQuality​()
      返回默认质量设置
      PrintResolution getDefaultPrintResolution​()
      返回此打印机上纸张的默认打印分辨率。
      PrintSides getDefaultPrintSides​()
      返回双工设置的默认值。
      int getMaxCopies​()
      最多支持的份数。
      Set<Collation> getSupportedCollations​()
      返回此打印机支持的归类设置的不可修改的集合。
      Set<PageOrientation> getSupportedPageOrientations​()
      返回此打印机支持的方向的不可修改的一组。
      Set<Paper> getSupportedPapers​()
      返回此打印机支持的纸张尺寸不可修改的集合。
      Set<PaperSource> getSupportedPaperSources​()
      返回此打印机支持的纸张来源（即输入纸盒或纸盘）的不可修改的一组。
      Set<PrintColor> getSupportedPrintColors​()
      返回此打印机支持的颜色设置的不可修改的集合。
      Set<PrintQuality> getSupportedPrintQuality​()
      返回此打印机支持的质量设置的一组不可修改的集合。
      Set<PrintResolution> getSupportedPrintResolutions​()
      返回此打印机支持的打印分辨率的一组不可修改的集合。
      Set<PrintSides> getSupportedPrintSides​()
      返回此打印机支持的双面设置的不可修改的一组。
      boolean supportsPageRanges​()
      报告是否支持页面范围。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getDefaultCopies

        public int getDefaultCopies​()
        要打印的默认份数。
        结果
        默认份数

      • getMaxCopies

        public int getMaxCopies​()
        最多支持的份数。
        结果
        最大支持的份数

      • supportsPageRanges

        public boolean supportsPageRanges​()
        报告是否支持页面范围。
        结果
        如果页面范围支持，则为true

      • getDefaultCollation

        public Collation getDefaultCollation​()
        默认的排序规则设置。
        结果
        默认值为 Collation

      • getSupportedCollations

        public Set<Collation> getSupportedCollations​()
        返回此打印机支持的归类设置的不可修改的集合。
        结果
        支持值为 Collation

      • getDefaultPrintSides

        public PrintSides getDefaultPrintSides​()
        返回双工设置的默认值。
        结果
        默认值为 PrintSides

      • getSupportedPrintSides

        public Set<PrintSides> getSupportedPrintSides​()
        返回此打印机支持的双面设置的不可修改的一组。
        结果
        支持的值为 PrintSides

      • getDefaultPrintColor

        public PrintColor getDefaultPrintColor​()
        获取默认颜色设置：灰度或颜色
        结果
        默认打印颜色设置。

      • getSupportedPrintColors

        public Set<PrintColor> getSupportedPrintColors​()
        返回此打印机支持的颜色设置的不可修改的集合。
        结果
        支持的值为 PrintColor

      • getDefaultPrintQuality

        public PrintQuality getDefaultPrintQuality​()
        返回默认质量设置
        结果
        默认打印质量设置。

      • getSupportedPrintQuality

        public Set<PrintQuality> getSupportedPrintQuality​()
        返回此打印机支持的质量设置的一组不可修改的集合。
        结果
        支持的值为 PrintQuality

      • getDefaultPrintResolution

        public PrintResolution getDefaultPrintResolution​()
        返回此打印机上纸张的默认打印分辨率。
        结果
        默认纸张分辨率

      • getSupportedPrintResolutions

        public Set<PrintResolution> getSupportedPrintResolutions​()
        返回此打印机支持的打印分辨率的一组不可修改的集合。
        结果
        支持的值为 PrintResolution

      • getDefaultPageOrientation

        public PageOrientation getDefaultPageOrientation​()
        返回此打印机上纸张的默认方向。
        结果
        默认纸张方向

      • getSupportedPageOrientations

        public Set<PageOrientation> getSupportedPageOrientations​()
        返回此打印机支持的方向的不可修改的一组。
        结果
        支持值为 PageOrientation

      • getDefaultPaper

        public Paper getDefaultPaper​()
        返回此打印机使用的默认纸张尺寸。
        结果
        默认纸张

      • getSupportedPapers

        public Set<Paper> getSupportedPapers​()
        返回此打印机支持的纸张尺寸不可修改的集合。
        结果
        支持的值为 Paper

      • getDefaultPaperSource

        public PaperSource getDefaultPaperSource​()
        返回默认纸张输入源/纸盘/
        结果
        默认纸张输入源。

      • getSupportedPaperSources

        public Set<PaperSource> getSupportedPaperSources​()
        返回此打印机支持的纸张来源（即输入纸盒或纸盘）的不可修改的一组。
        结果
        支持的纸张输入源
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrinterJob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Class PrinterJob

  • java.lang.Object
    • javafx.print.PrinterJob

  • public final class PrinterJob
extends Object
    PrinterJob是JavaFX场景打印的起点。

    这包括

    • 打印机发现
    • 创造就业机会
    • 基于支持打印机功能的作业配置
    • 页面设置
    • 将节点层叠渲染到页面。

    这里是一个很简单的例子，它打印出一个单一的节点。

      Node node = new Circle(100, 200, 200);
 PrinterJob job = PrinterJob.createPrinterJob();
 if (job != null) {
    boolean success = job.printPage(node);
    if (success) {
        job.endJob();
    }
 }
    注意点

    在上面的示例中，节点未添加到场景。 由于大多数打印方案都是打印完全不显示的内容，或者必须准备和格式不同，这是完全可以接受的。

    如果目前是场景的一部分并正在显示的内容被打印出来，那么由于打印作业或甚至单个页面的作业可能跨越多个屏幕“脉冲”或帧，因此应用程序必须确保正在打印的节点在打印过程中不被更新，否则部分或模糊渲染是可能的。

    应该显而易见的是，即使是不显示的节点也是如此 - 更新它们同时打印它们不是一个好主意。

    没有要求在FX应用程序线程上进行打印。 节点可以准备在任何线程上打印，可以在任何线程上调用该作业。 然而，最小化在FX应用程序线程上完成的工作量通常是可取的，以免影响应用程序UI的响应性。 因此，建议在新线程上执行打印，并让内部调度任何需要在FX线程上执行的任务，以便在该线程上运行。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<PrinterJob.JobStatus> jobStatus
      一个只读对象属性，代表当前的 JobStatus
      ObjectProperty<Printer> printer
      属性代表此工作的 Printer 。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  PrinterJob.JobStatus
      用于报告打印作业状态的枚举类。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelJob​()
      最早取消底层打印作业。
      static PrinterJob createPrinterJob​()
      创建工作的工厂方法。
      static PrinterJob createPrinterJob​(Printer printer)
      为指定的打印机创建作业的工厂方法。
      boolean endJob​()
      如果作业可以成功地假脱机到打印机队列，这将返回true。
      JobSettings getJobSettings​()
      JobSettings封装了所有API支持的作业配置选项，如份数，归类选项，双工选项等。
      PrinterJob.JobStatus getJobStatus​()
      获取工作的当前状态。
      Printer getPrinter​()
      获取当前与此作业相关联的打印机。
      ReadOnlyObjectProperty<PrinterJob.JobStatus> jobStatusProperty​()
      一个只读对象属性，代表当前的 JobStatus
      ObjectProperty<Printer> printerProperty​()
      代表这项工作的 Printer财产。
      boolean printPage​(PageLayout pageLayout, Node node)
      使用指定的页面布局打印指定的节点。
      boolean printPage​(Node node)
      打印指定的节点。
      void setPrinter​(Printer printer)
      更改此作业的打印机。
      boolean showPageSetupDialog​(Window owner)
      显示页面设置对话框。
      boolean showPrintDialog​(Window owner)
      显示打印对话框。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • printer

        public final ObjectProperty<Printer> printerProperty
        Printer该工作的 Printer财产。
        另请参见：
        getPrinter() ， setPrinter(Printer)

      • jobStatus

        public ReadOnlyObjectProperty<PrinterJob.JobStatus> jobStatusProperty
        一个只读对象属性，代表当前的 JobStatus
        另请参见：
        getJobStatus()

    • 方法详细信息

      • createPrinterJob

        public static final PrinterJob createPrinterJob​()
        创建工作的工厂方法。 如果没有可用的打印机，这将返回null。 一些平台可以提供伪打印机，其创建文档。 这些将在这里列举，只要平台也列举他们，就像他们是打印机。
        结果
        一个新的PrinterJob实例，或null。
        异常
        SecurityException - 如果作业没有启动打印机作业的权限。

      • createPrinterJob

        public static final PrinterJob createPrinterJob​(Printer printer)
        为指定的打印机创建作业的工厂方法。

        printer参数确定初始打印机

        参数
        printer - 用于工作。 如果打印机当前不可用（例如脱机），则可能返回null。
        结果
        一个新的PrinterJob，或null。
        异常
        SecurityException - 如果作业没有启动打印机作业的权限。

      • printerProperty

        public final ObjectProperty<Printer> printerProperty​()
        代表此职位的 Printer财产。
        另请参见：
        getPrinter() ， setPrinter(Printer)

      • getPrinter

        public Printer getPrinter​()
        获取当前与此作业相关联的打印机。
        结果
        打印机的工作。

      • setPrinter

        public void setPrinter​(Printer printer)
        更改此作业的打印机。 如果新的打印机不支持当前的作业设置（例如，如果请求了DUPLEX打印但是新的打印机不支持此功能），那么这些值将重新设置为新打印机的默认值，或者在某些情况下将重置为类似的值。 例如，这可能意味着REVERSE_LANDSCAPE更新为LANDSCAPE，但是这种实现优化是允许的，但不是必需的。

        无论打印机是通过直接调用此方法进行更改还是作为用户与打印对话框进行交互的副作用，都适用上述内容。

        为打印机设置空值将安装默认打印机。 设置当前打印机没有任何效果。

        参数
        printer - 用于此打印作业。

      • getJobSettings

        public JobSettings getJobSettings​()
        JobSettings封装了所有API支持的作业配置选项，例如份数，归类选项，双面选项等。初始值基于初始打印机的当前设置。
        结果
        当前作业设置。

      • showPrintDialog

        public boolean showPrintDialog​(Window owner)
        显示打印对话框。 允许用户更新打印机和设置等作业状态。 打印对话框返回后，这些更改将在适当的属性中可用。 打印对话框通常也用于确认用户想继续打印。 这对应用程序没有约束力，但通常应该遵循。

        在没有UI可用的情况下，该方法返回true，没有更改任何选项，就像用户已确认继续打印一样。

        如果作业未处于显示对话框的状态，例如已经打印，取消或完成，则对话框将不会显示，方法将返回false。

        窗口owner可以是空的，但是如果它是可视窗口，它将被用作父级。

        可以从任何线程调用此方法。 如果从JavaFX应用程序线程调用，则必须从输入事件处理程序或从Runnable的run方法调用传递给Platform.runLater 。 在动画或布局处理过程中不得调用它。

        参数
        owner - 要阻止输入，或为空。
        结果
        如果用户选择取消打印，或作业不处于新状态，则为false。 那就是如果它已经开始，已经失败，或者已被取消或已经结束。
        异常
        IllegalStateException - 如果在动画或布局处理期间调用此方法。

      • showPageSetupDialog

        public boolean showPageSetupDialog​(Window owner)
        显示页面设置对话框。 页面设置对话框主要是允许最终用户配置页面的布局。 纸张尺寸和方向是最常见和最重要的组成部分。

        为此，将显示最合适的可用对话框。 但是，仍然可以访问其他设置，包括更改当前打印机。 因此，此对话框显示方法的副作用可能是更新该任何其他当前作业设置。 如果用户确认对话是否进行任何更改，该方法将返回true。

        如果作业未处于显示对话框的状态，例如已经打印，取消或完成，则对话框将不会显示，方法将返回false。

        窗口owner可以是空的，但是如果它是可视窗口，它将被用作父。

        可以从任何线程调用此方法。 如果从FX应用程序线程调用，则必须从输入事件处理程序或Runnable的run方法调用传递给Platform.runLater 。 在动画或布局处理过程中不得调用它。

        参数
        owner - 阻止输入，或为空。
        结果
        如果用户选择取消对话框，或作业未处于新状态，则为false。 那就是如果它已经开始，已经失败，或者已被取消或已经结束。
        异常
        IllegalStateException - 如果在动画或布局处理期间调用此方法。

      • printPage

        public boolean printPage​(PageLayout pageLayout,
                         Node node)
        使用指定的页面布局打印指定的节点。 页面布局将仅覆盖此页面的作业默认值。 如果作业状态为CANCELED，ERROR或DONE，则此方法将返回false。

        可以从任何线程调用此方法。 如果从FX应用程序线程调用，则必须从输入事件处理程序或Runnable的run方法调用传递给Platform.runLater 。 在动画或布局处理过程中不得调用它。

        参数
        pageLayout - 此页面的布局。
        node - 要打印的节点。
        结果
        渲染是否成功
        异常
        NullPointerException - 如果任一参数为空。
        IllegalStateException - 如果在动画或布局处理期间调用此方法。

      • printPage

        public boolean printPage​(Node node)
        打印指定的节点。 页面布局是作业默认值。 如果作业状态为CANCELED，ERROR或DONE，则此方法将返回false。
        参数
        node - 要打印的节点。
        结果
        渲染是否成功
        异常
        NullPointerException - 如果节点参数为空。

      • jobStatusProperty

        public ReadOnlyObjectProperty<PrinterJob.JobStatus> jobStatusProperty​()
        一个只读对象属性，代表当前的 JobStatus
        另请参见：
        getJobStatus()

      • getJobStatus

        public PrinterJob.JobStatus getJobStatus​()
        获取工作的当前状态。
        结果
        目前为 JobStatus

      • cancelJob

        public void cancelJob​()
        最早取消底层打印作业。 如果这样会阻止FX用户线程持续一段时间，它可能会立即返回而不等待作业取消完成。 如果打印正在进行中，那么通常这意味着取消当前页面。 作业状态仅在发生一次后更新为已取消。 因此，确定作业已取消需要监视作业状态。

        如果作业已被请求取消，或处于ERROR或DONE状态，则该呼叫不起作用。 例如，它不会从打印机中排除已经假脱机打印的作业。 一旦作业被取消，调用任何渲染新内容或更改作业状态的方法是无效的。

      • endJob

        public boolean endJob​()
        如果作业可以成功地假脱机到打印机队列，这将返回true。 注意：这并不意味着已经打印的作业可能需要等待几分钟或更长时间，即使可实施。

        返回值为false表示作业无法假脱机或已完成。

        成功的完成也会将作业状态更新为DONE ，此时该作业将无法再使用。

        在没有打印页面的作业上调用endJob（）等效于调用{code cancelJob（）}。

        结果
        如果作业被假脱机，则为true，否则为false，或者该作业已经处于完成状态。

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrinterJob.JobStatus (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Enum PrinterJob.JobStatus

  • java.lang.Object
    • java.lang.Enum<PrinterJob.JobStatus>
      • javafx.print.PrinterJob.JobStatus
  • All Implemented Interfaces:
    Serializable ， Comparable<PrinterJob.JobStatus>
    Enclosing class:
    PrinterJob

    public static enum PrinterJob.JobStatus
extends Enum<PrinterJob.JobStatus>
    用于报告打印作业状态的枚举类。 应用程序可以通过jobStatus属性监听作业状态，或者可以使用getJobStatus()直接查询。

    工作的典型生命周期如下：

    • 将创建状态为NOT_STARTED并通过对话框等在配置过程中保留。
    • 当打印第一页时，作业将进入状态PRINTING 。
    • 一旦作业成功完成，作业将进入状态DONE ，而不被取消或遇到错误。 该工作现已完成。
    • 遇到ERROR或CANCELED的工作也被视为完成。

    作业在其生命周期中可能不会恢复到较早的状态，而当前作业状态会影响可能执行的操作。 例如，如果作业先前已经通过该状态并输入任何终止状态，则作业可能不会再次开始打印。

    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CANCELED
      该作业已被应用程序取消。
      DONE
      该工作启动了打印，后来被称为endJob（），报告成功。
      ERROR
      工作遇到错误。
      NOT_STARTED
      新工作状态。
      PRINTING
      该作业已经要求打印至少一个页面，并且还没有终止打印。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PrinterJob.JobStatus valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PrinterJob.JobStatus[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NOT_STARTED

        public static final PrinterJob.JobStatus NOT_STARTED
        新工作状态。 可以显示打印对话框并配置作业并开始打印。

      • PRINTING

        public static final PrinterJob.JobStatus PRINTING
        该作业已经要求打印至少一个页面，并且还没有终止打印。 可能不再显示打印对话框。

      • CANCELED

        public static final PrinterJob.JobStatus CANCELED
        该作业已被应用程序取消。 可能不显示对话框或启动打印。 工作应该被丢弃。 没有必要调用endJob（）。

      • ERROR

        public static final PrinterJob.JobStatus ERROR
        工作遇到错误。 工作应该被丢弃。 没有必要调用endJob（）。

      • DONE

        public static final PrinterJob.JobStatus DONE
        该工作启动了打印，后来被称为endJob（），报告成功。 该作业可以被丢弃，因为它不能重新使用。

    • 方法详细信息

      • values

        public static PrinterJob.JobStatus[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PrinterJob.JobStatus c : PrinterJob.JobStatus.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PrinterJob.JobStatus valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PrintQuality (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Enum PrintQuality

  • java.lang.Object
    • java.lang.Enum<PrintQuality>
      • javafx.print.PrintQuality
  • All Implemented Interfaces:
    Serializable ， Comparable<PrintQuality>

    public enum PrintQuality
extends Enum<PrintQuality>
    分类打印质量设置。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DRAFT
      指定DRAFT质量打印。
      HIGH
      指定高质量打印。
      LOW
      指定低质量打印。
      NORMAL
      指定NORMAL质量打印。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PrintQuality valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PrintQuality[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DRAFT

        public static final PrintQuality DRAFT
        指定DRAFT质量打印。

      • LOW

        public static final PrintQuality LOW
        指定低质量打印。

      • NORMAL

        public static final PrintQuality NORMAL
        指定NORMAL质量打印。 这通常是中等质量和/或打印机默认值。

      • HIGH

        public static final PrintQuality HIGH
        指定高质量打印。

    • 方法详细信息

      • values

        public static PrintQuality[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PrintQuality c : PrintQuality.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PrintQuality valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PrintResolution (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Class PrintResolution

  • java.lang.Object
    • javafx.print.PrintResolution

  • public final class PrintResolution
extends Object
    类别表示打印机在进给和交叉进给方向上的支持的设备分辨率，单位英寸（DPI）。 横向进给方向的纵向打印通常为x /水平分辨率，进给方向通常为y /水平分辨率。 在大多数打印机上，这些是相同的价值，但它们可能是不同的。
    从以下版本开始：
    JavaFX 8.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      int getCrossFeedResolution​()
      以dpi返回分辨率。 穿过送纸方向。
      int getFeedResolution​()
      以dpi返回分辨率。 在送纸方向。
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getCrossFeedResolution

        public int getCrossFeedResolution​()
        以dpi返回分辨率。 穿过送纸方向。
        结果
        交叉进给分辨率。

      • getFeedResolution

        public int getFeedResolution​()
        以dpi返回分辨率。 在送纸方向。
        结果
        进纸分辨率。

      • equals

        public boolean equals​(Object o)
        描述从类别复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，其中声明相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        如果此对象与obj参数相同， true ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每一个上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本上表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrintSides (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.print

Enum PrintSides

  • java.lang.Object
    • java.lang.Enum<PrintSides>
      • javafx.print.PrintSides
  • All Implemented Interfaces:
    Serializable ， Comparable<PrintSides>

    public enum PrintSides
extends Enum<PrintSides>
    列举可能的双面（双面）打印模式的类。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DUPLEX
      纸张的垂直边缘用于装订的双面打印，如书中。
      ONE_SIDED
      单面打印
      TUMBLE
      双面打印，纸张的水平边缘将用于装订，如记事本。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PrintSides valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PrintSides[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ONE_SIDED

        public static final PrintSides ONE_SIDED
        单面打印 双面打印关闭。

      • DUPLEX

        public static final PrintSides DUPLEX
        纸张的垂直边缘用于装订的双面打印，如书中。 在PORTAIT模式打印中，垂直边缘通常是长边，但如果要求LANDSCAPE打印，则会相反

      • TUMBLE

        public static final PrintSides TUMBLE
        双面打印，纸张的水平边缘将用于装订，如记事本。 在PORTAIT模式打印中，水平边缘通常是短边，但如果要求LANDSCAPE打印，则会相反

    • 方法详细信息

      • values

        public static PrintSides[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PrintSides c : PrintSides.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PrintSides valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Uses of Package javafx.print (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.print

  • Packages that use javafx.print
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
  • Classes in javafx.print used by javafx.print
    Class 描述
    Collation
    排序规则指定作业中打印文档的每个副本的介质页是否是顺序的。
    JobSettings
    JobSettings类封装了打印作业的大部分配置。
    PageLayout
    PageLayout封装了布局内容所需的信息。
    PageOrientation
    指定打印页面的介质页的方向。
    PageRange
    A PageRange用于选择或约束作业打印流页面进行打印。
    Paper
    封装打印机使用的纸介质尺寸的类。
    PaperSource
    PaperSource是用于纸张的进纸盘。
    PrintColor
    描述打印是单色还是彩色的类。
    Printer
    打印机实例表示打印作业的目的地。
    Printer.MarginType
    MarginType用于确定PageLayout的可打印区域。
    PrinterAttributes
    该类封装了与其作业打印功能和其他属性相关的打印机的属性。
    PrinterJob
    PrinterJob是JavaFX场景打印的起点。
    PrinterJob.JobStatus
    用于报告打印作业状态的枚举类。
    PrintQuality
    分类打印质量设置。
    PrintResolution
    类别表示打印机在进给和交叉进给方向上的支持的设备分辨率，单位英寸（DPI）。
    PrintSides
    列举可能的双面（双面）打印模式的类。
  • Classes in javafx.print used by javafx.scene.web
    Class 描述
    PrinterJob
    PrinterJob is the starting place for JavaFX scenegraph printing.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.Collation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.Collation

  • Packages that use Collation
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of Collation in javafx.print

      Methods in javafx.print that return Collation
      Modifier and Type 方法 描述
      Collation JobSettings.getCollation​()
      排序规则确定打印文档的多个副本时如何排序纸张。
      Collation PrinterAttributes.getDefaultCollation​()
      默认的排序规则设置。
      static Collation Collation.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Collation[] Collation.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.print that return types with arguments of type Collation
      Modifier and Type 方法 描述
      ObjectProperty<Collation> JobSettings.collationProperty​()
      属性代表 Collation一个实例。
      Set<Collation> PrinterAttributes.getSupportedCollations​()
      返回此打印机支持的归类设置的不可修改的集合。
      Methods in javafx.print with parameters of type Collation
      Modifier and Type 方法 描述
      void JobSettings.setCollation​(Collation collation)
      设置 Collation属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.JobSettings (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.JobSettings

  • Packages that use JobSettings
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of JobSettings in javafx.print

      Methods in javafx.print that return JobSettings
      Modifier and Type 方法 描述
      JobSettings PrinterJob.getJobSettings​()
      JobSettings封装了所有API支持的作业配置选项，例如份数，归类选项，双工选项等。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PageLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PageLayout

  • Packages that use PageLayout
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PageLayout in javafx.print

      Methods in javafx.print that return PageLayout
      Modifier and Type 方法 描述
      PageLayout Printer.createPageLayout​(Paper paper, PageOrientation orient, double lMargin, double rMargin, double tMargin, double bMargin)
      使用指定的参数获取此打印机的新PageLayout。
      PageLayout Printer.createPageLayout​(Paper paper, PageOrientation orient, Printer.MarginType mType)
      使用指定的参数获取此打印机的新PageLayout实例。
      PageLayout Printer.getDefaultPageLayout​()
      返回此打印机的默认页面布局。
      PageLayout JobSettings.getPageLayout​()
      获取此作业的当前页面布局。
      Methods in javafx.print that return types with arguments of type PageLayout
      Modifier and Type 方法 描述
      ObjectProperty<PageLayout> JobSettings.pageLayoutProperty​()
      属性代表 PageLayout一个实例。
      Methods in javafx.print with parameters of type PageLayout
      Modifier and Type 方法 描述
      boolean PrinterJob.printPage​(PageLayout pageLayout, Node node)
      使用指定的页面布局打印指定的节点。
      void JobSettings.setPageLayout​(PageLayout pageLayout)
      将PageLayout设置为使用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PageOrientation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PageOrientation

  • Packages that use PageOrientation
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PageOrientation in javafx.print

      Methods in javafx.print that return PageOrientation
      Modifier and Type | 方法 | 描述
      PageOrientation PrinterAttributes.getDefaultPageOrientation​()
      返回此打印机上纸张的默认方向。
      PageOrientation | PageLayout.getPageOrientation​()
      static PageOrientation PageOrientation.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PageOrientation[] PageOrientation.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.print that return types with arguments of type PageOrientation
      Modifier and Type 方法 描述
      Set<PageOrientation> PrinterAttributes.getSupportedPageOrientations​()
      返回此打印机支持的方向的不可修改的一组。
      Methods in javafx.print with parameters of type PageOrientation
      Modifier and Type 方法 描述
      PageLayout Printer.createPageLayout​(Paper paper, PageOrientation orient, double lMargin, double rMargin, double tMargin, double bMargin)
      使用指定的参数获取此打印机的新PageLayout。
      PageLayout Printer.createPageLayout​(Paper paper, PageOrientation orient, Printer.MarginType mType)
      Obtain a new PageLayout instance for this printer using the specified parameters.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PageRange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PageRange

  • Packages that use PageRange
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PageRange in javafx.print

      Methods in javafx.print that return PageRange
      Modifier and Type 方法 描述
      PageRange[] JobSettings.getPageRanges​()
      要打印的页面范围。 null始终表示所有页面。
      Methods in javafx.print with parameters of type PageRange
      Modifier and Type 方法 描述
      void JobSettings.setPageRanges​(PageRange... pages)
      要打印为PageRange数组的页面范围。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.Paper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.Paper

  • Packages that use Paper
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of Paper in javafx.print

      Fields in javafx.print declared as Paper
      Modifier and Type Field 描述
      static Paper Paper.A0
      指定ISO A0尺寸，841 mm×1189 mm。
      static Paper Paper.A1
      指定ISO A1尺寸，594 mm×841 mm。
      static Paper Paper.A2
      指定ISO A2尺寸，420 mm×594 mm。
      static Paper Paper.A3
      指定ISO A3尺寸，297 mm x 420 mm。
      static Paper Paper.A4
      指定ISO A4尺寸，210 mm×297 mm。
      static Paper Paper.A5
      指定ISO A5尺寸，148 mm×210 mm。
      static Paper Paper.A6
      指定ISO A6尺寸，105 mm×148 mm。
      static Paper Paper.C
      指定工程C尺寸，17英寸×22英寸。
      static Paper Paper.DESIGNATED_LONG
      指定ISO指定长尺寸，110 mm×220 mm。
      static Paper Paper.EXECUTIVE
      指定行政大小，7.25英寸×10.5英寸。
      static Paper Paper.JAPANESE_POSTCARD
      指定日本明信片大小，100毫米×148毫米。
      static Paper Paper.JIS_B4
      指定JIS B4尺寸，257 mm×364 mm。
      static Paper Paper.JIS_B5
      指定JIS B5尺寸，182 mm×257 mm。
      static Paper Paper.JIS_B6
      指定JIS B6尺寸，128 mm×182 mm。
      static Paper Paper.LEGAL
      指定北美合法尺寸，8.5英寸×14英寸。
      static Paper Paper.MONARCH_ENVELOPE
      指定Monarch信封尺寸，3.87英寸×7.5英寸。
      static Paper Paper.NA_8X10
      指定北美8寸×10英寸的纸。
      static Paper Paper.NA_LETTER
      指定北美字母大小，8.5英寸×11英寸
      static Paper Paper.NA_NUMBER_10_ENVELOPE
      指定北美10号商业信封尺寸，4.125英寸×9.5英寸。
      static Paper Paper.TABLOID
      指定小时大小，11英寸×17英寸。
      Methods in javafx.print that return Paper
      Modifier and Type 方法 描述
      Paper PrinterAttributes.getDefaultPaper​()
      返回此打印机使用的默认纸张尺寸。
      Paper PageLayout.getPaper​()
      用纸。
      Methods in javafx.print that return types with arguments of type Paper
      Modifier and Type 方法 描述
      Set<Paper> PrinterAttributes.getSupportedPapers​()
      返回此打印机支持的纸张尺寸不可修改的集合。
      Methods in javafx.print with parameters of type Paper
      Modifier and Type 方法 描述
      PageLayout Printer.createPageLayout​(Paper paper, PageOrientation orient, double lMargin, double rMargin, double tMargin, double bMargin)
      使用指定的参数获取此打印机的新PageLayout。
      PageLayout Printer.createPageLayout​(Paper paper, PageOrientation orient, Printer.MarginType mType)
      使用指定的参数获取此打印机的新PageLayout实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PaperSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PaperSource

  • Packages that use PaperSource
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PaperSource in javafx.print

      Fields in javafx.print declared as PaperSource
      Modifier and Type Field 描述
      static PaperSource PaperSource.AUTOMATIC
      指定自动选择纸盘。
      static PaperSource PaperSource.BOTTOM
      指定选择底部托盘。
      static PaperSource PaperSource.ENVELOPE
      指定选择ENVELOPE纸盘。
      static PaperSource PaperSource.LARGE_CAPACITY
      指定选择LARGE_CAPACITY托盘。
      static PaperSource PaperSource.MAIN
      指定选择MAIN纸盘。
      static PaperSource PaperSource.MANUAL
      指定选择手动纸盘。
      static PaperSource PaperSource.MIDDLE
      指定选择MIDDLE纸盘。
      static PaperSource PaperSource.SIDE
      指定选择SIDE托盘。
      static PaperSource PaperSource.TOP
      指定选择TOP托盘。
      Methods in javafx.print that return PaperSource
      Modifier and Type 方法 描述
      PaperSource PrinterAttributes.getDefaultPaperSource​()
      返回默认纸张输入源/纸盘/
      PaperSource JobSettings.getPaperSource​()
      获取属性paperSource的值。
      Methods in javafx.print that return types with arguments of type PaperSource
      Modifier and Type 方法 描述
      Set<PaperSource> PrinterAttributes.getSupportedPaperSources​()
      返回此打印机支持的纸张来源（即输入纸盒或纸盘）的不可修改的一组。
      ObjectProperty<PaperSource> JobSettings.paperSourceProperty​()
      属性代表 PaperSource一个实例。
      Methods in javafx.print with parameters of type PaperSource
      Modifier and Type 方法 描述
      void JobSettings.setPaperSource​(PaperSource value)
      设置属性paperSource的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PrintColor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PrintColor

  • Packages that use PrintColor
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PrintColor in javafx.print

      Methods in javafx.print that return PrintColor
      Modifier and Type 方法 描述
      PrintColor PrinterAttributes.getDefaultPrintColor​()
      获取默认颜色设置：灰度或颜色
      PrintColor JobSettings.getPrintColor​()
      获取属性printColor的值。
      static PrintColor PrintColor.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PrintColor[] PrintColor.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.print that return types with arguments of type PrintColor
      Modifier and Type 方法 描述
      Set<PrintColor> PrinterAttributes.getSupportedPrintColors​()
      返回此打印机支持的颜色设置的不可修改的集合。
      ObjectProperty<PrintColor> JobSettings.printColorProperty​()
      属性代表 PrintColor一个实例。
      Methods in javafx.print with parameters of type PrintColor
      Modifier and Type 方法 描述
      void JobSettings.setPrintColor​(PrintColor color)
      设置 PrintColor属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.Printer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.Printer

  • Packages that use Printer
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of Printer in javafx.print

      Methods in javafx.print that return Printer
      Modifier and Type 方法 描述
      static Printer Printer.getDefaultPrinter​()
      检索默认打印机。
      Printer PrinterJob.getPrinter​()
      获取当前与此作业相关联的打印机。
      Methods in javafx.print that return types with arguments of type Printer
      Modifier and Type 方法 描述
      static ReadOnlyObjectProperty<Printer> Printer.defaultPrinterProperty​()
      表示当前默认打印机的只读对象属性。
      static ObservableSet<Printer> Printer.getAllPrinters​()
      检索已安装的打印机。
      ObjectProperty<Printer> PrinterJob.printerProperty​()
      代表此工作的 Printer财产。
      Methods in javafx.print with parameters of type Printer
      Modifier and Type 方法 描述
      static PrinterJob PrinterJob.createPrinterJob​(Printer printer)
      为指定的打印机创建作业的工厂方法。
      void PrinterJob.setPrinter​(Printer printer)
      更改此作业的打印机。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.Printer.MarginType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.Printer.MarginType

  • Packages that use Printer.MarginType
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of Printer.MarginType in javafx.print

      Methods in javafx.print that return Printer.MarginType
      Modifier and Type 方法 描述
      static Printer.MarginType Printer.MarginType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Printer.MarginType[] Printer.MarginType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.print with parameters of type Printer.MarginType
      Modifier and Type 方法 描述
      PageLayout Printer.createPageLayout​(Paper paper, PageOrientation orient, Printer.MarginType mType)
      使用指定的参数获取此打印机的新PageLayout实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PrinterAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PrinterAttributes

  • Packages that use PrinterAttributes
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PrinterAttributes in javafx.print

      Methods in javafx.print that return PrinterAttributes
      Modifier and Type 方法 描述
      PrinterAttributes Printer.getPrinterAttributes​()
      检索封装打印机属性和功能的委托对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PrinterJob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PrinterJob

  • Packages that use PrinterJob
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of PrinterJob in javafx.print

      Methods in javafx.print that return PrinterJob
      Modifier and Type 方法 描述
      static PrinterJob PrinterJob.createPrinterJob​()
      创建工作的工厂方法。
      static PrinterJob PrinterJob.createPrinterJob​(Printer printer)
      为指定的打印机创建作业的工厂方法。

    • Uses of PrinterJob in javafx.scene.web

      Methods in javafx.scene.web with parameters of type PrinterJob
      Modifier and Type 方法 描述
      void HTMLEditor.print​(PrinterJob job)
      使用给定的打印机作业打印编辑器的内容。
      void WebEngine.print​(PrinterJob job)
      使用给定的打印机作业打印当前网页。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PrinterJob.JobStatus (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PrinterJob.JobStatus

  • Packages that use PrinterJob.JobStatus
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PrinterJob.JobStatus in javafx.print

      Methods in javafx.print that return PrinterJob.JobStatus
      Modifier and Type 方法 描述
      PrinterJob.JobStatus PrinterJob.getJobStatus​()
      获取工作的当前状态。
      static PrinterJob.JobStatus PrinterJob.JobStatus.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PrinterJob.JobStatus[] PrinterJob.JobStatus.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.print that return types with arguments of type PrinterJob.JobStatus
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<PrinterJob.JobStatus> PrinterJob.jobStatusProperty​()
      一个只读对象属性，代表当前的 JobStatus
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PrintQuality (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PrintQuality

  • Packages that use PrintQuality
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PrintQuality in javafx.print

      Methods in javafx.print that return PrintQuality
      Modifier and Type 方法 描述
      PrintQuality PrinterAttributes.getDefaultPrintQuality​()
      返回默认质量设置
      PrintQuality JobSettings.getPrintQuality​()
      获取属性printQuality的值。
      static PrintQuality PrintQuality.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PrintQuality[] PrintQuality.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.print that return types with arguments of type PrintQuality
      Modifier and Type 方法 描述
      Set<PrintQuality> PrinterAttributes.getSupportedPrintQuality​()
      返回此打印机支持的质量设置的一组不可修改的集合。
      ObjectProperty<PrintQuality> JobSettings.printQualityProperty​()
      代表 PrintQuality的实例的 PrintQuality 。
      Methods in javafx.print with parameters of type PrintQuality
      Modifier and Type 方法 描述
      void JobSettings.setPrintQuality​(PrintQuality quality)
      设置 PrintQuality属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PrintResolution (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PrintResolution

  • Packages that use PrintResolution
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PrintResolution in javafx.print

      Methods in javafx.print that return PrintResolution
      Modifier and Type | 方法 | 描述
      PrintResolution PrinterAttributes.getDefaultPrintResolution​()
      返回此打印机上纸张的默认打印分辨率。
      PrintResolution | JobSettings.getPrintResolution​()
      Methods in javafx.print that return types with arguments of type PrintResolution
      Modifier and Type 方法 描述
      Set<PrintResolution> PrinterAttributes.getSupportedPrintResolutions​()
      返回此打印机支持的打印分辨率的一组不可修改的集合。
      ObjectProperty<PrintResolution> JobSettings.printResolutionProperty​()
      属性代表 PrintResolution一个实例。
      Methods in javafx.print with parameters of type PrintResolution
      Modifier and Type 方法 描述
      void JobSettings.setPrintResolution​(PrintResolution resolution)
      设置 PrintResolution属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.print.PrintSides (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.print.PrintSides

  • Packages that use PrintSides
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。

    • Uses of PrintSides in javafx.print

      Methods in javafx.print that return PrintSides
      Modifier and Type 方法 描述
      PrintSides PrinterAttributes.getDefaultPrintSides​()
      返回双工设置的默认值。
      PrintSides JobSettings.getPrintSides​()
      如果打印机支持它，则可以在介质（纸张）的两面上打印作业，即双面打印。
      static PrintSides PrintSides.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PrintSides[] PrintSides.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.print that return types with arguments of type PrintSides
      Modifier and Type 方法 描述
      Set<PrintSides> PrinterAttributes.getSupportedPrintSides​()
      返回此打印机支持的双面设置的不可修改的一组。
      ObjectProperty<PrintSides> JobSettings.printSidesProperty​()
      属性代表 PrintSides一个实例。
      Methods in javafx.print with parameters of type PrintSides
      Modifier and Type 方法 描述
      void JobSettings.setPrintSides​(PrintSides sides)
      设置控制双面打印的 PrintSides属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AccessibleAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Enum AccessibleAction

  • java.lang.Object
    • java.lang.Enum<AccessibleAction>
      • javafx.scene.AccessibleAction
  • All Implemented Interfaces:
    Serializable ， Comparable<AccessibleAction>

    public enum AccessibleAction
extends Enum<AccessibleAction>
    该枚举描述了屏幕阅读器等辅助技术可以从场景图中请求的动作。 AccessibleRole规定了屏幕阅读器将对特定控件请求的一组操作。 例如，按钮通常会触发一个事件以指示它是响应于FIRE动作被按下的。

    取决于具体的动作，动作可以有任意数量的参数。

    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Node.executeAccessibleAction(AccessibleAction, Object...) ， AccessibleRole ， AccessibleAttribute.ROLE

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BLOCK_DECREMENT
      请求节点递减一个较大的值。
      BLOCK_INCREMENT
      请求节点递增一个较大的值。
      COLLAPSE
      请求节点应该折叠。
      DECREMENT
      请求节点递减一个小的值。
      EXPAND
      请求节点应该扩展。
      FIRE
      触发该节点的主要操作。
      INCREMENT
      请求节点递增一个较小的值。
      REQUEST_FOCUS
      请求节点采取焦点。
      SET_SELECTED_ITEMS
      请求节点将选择设置为项目列表。
      SET_TEXT
      请求节点设置当前文本。
      SET_TEXT_SELECTION
      请求节点将选择设置为文本范围。
      SET_VALUE
      请求节点设置当前值。
      SHOW_ITEM
      请求节点显示一个项目，如果需要，滚动。
      SHOW_MENU
      请求节点显示菜单。
      SHOW_TEXT_RANGE
      请求节点显示文本范围，如果需要，滚动。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static AccessibleAction valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AccessibleAction[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BLOCK_DECREMENT

        public static final AccessibleAction BLOCK_DECREMENT
        请求节点递减一个较大的值。 使用DECREMENT请求较小的减量。

        由Slider，ScrollBar等使用

      • BLOCK_INCREMENT

        public static final AccessibleAction BLOCK_INCREMENT
        请求节点递增一个较大的值。 使用INCREMENT请求一个较小的增量。

        由Slider，ScrollBar等使用

      • COLLAPSE

        public static final AccessibleAction COLLAPSE
        请求节点应该折叠。

        由TreeItem，TitledPane等使用

      • DECREMENT

        public static final AccessibleAction DECREMENT
        请求节点递减一个小的值。 使用BLOCK_DECREMENT要求更大的减量。

        由Slider，ScrollBar等使用

      • EXPAND

        public static final AccessibleAction EXPAND
        请求节点应该扩展。

        由TreeItem，TitledPane等使用

      • FIRE

        public static final AccessibleAction FIRE
        触发该节点的主要操作。 例如，按钮通常会发送一个动作事件来通知被激活的监听器。

        由Button，Hyperlink等使用

      • INCREMENT

        public static final AccessibleAction INCREMENT
        请求节点递增一个较小的值。 使用BLOCK_INCREMENT请求更大的增量。

        由Slider，ScrollBar等使用

      • REQUEST_FOCUS

        public static final AccessibleAction REQUEST_FOCUS
        请求节点采取焦点。 默认情况下，节点将使用Node.requestFocus()请求焦点。 JavaFX和Assisteve技术都具有焦点节点的概念，大多数时候它们是一样的。 在某些情况下，控件可能希望将JavaFX焦点保留在父级，而辅助技术的重点在于孩子。 例如，在允许默认运行之前，表可以通过将焦点设置到表中的单元格来响应该请求。

        由Node，TabItem，TableCell等使用

      • SHOW_ITEM

        public static final AccessibleAction SHOW_ITEM
        请求节点显示一个项目，如果需要，滚动。

        由ListView，TreeView等使用

        参数：
        • Node要显示的项目

      • SHOW_TEXT_RANGE

        public static final AccessibleAction SHOW_TEXT_RANGE
        请求节点显示文本范围，如果需要，滚动。

        由TextField和TextArea使用。

        参数：
        • Integer起始偏移量
        • Integer结束偏移

      • SET_SELECTED_ITEMS

        public static final AccessibleAction SET_SELECTED_ITEMS
        请求节点将选择设置为项目列表。

        由ListView，TreeView等使用

        参数：
        • ObservableList < Node >要选择的项目

      • SET_TEXT_SELECTION

        public static final AccessibleAction SET_TEXT_SELECTION
        请求节点将选择设置为文本范围。

        由TextField和TextArea使用。

        参数：
        • Integer起始偏移量
        • Integer结束偏移

      • SET_TEXT

        public static final AccessibleAction SET_TEXT
        请求节点设置当前文本。

        由TextField和TextArea使用。

        参数：
        • String新的文字

      • SET_VALUE

        public static final AccessibleAction SET_VALUE
        请求节点设置当前值。

        由滑块，滚动条等使用

        参数：
        • Double新值

      • SHOW_MENU

        public static final AccessibleAction SHOW_MENU
        请求节点显示菜单。 如果节点是控件，则显示控件的上下文菜单。 如果节点是菜单，则显示菜单的子菜单。

        由Node，Menu使用

    • 方法详细信息

      • values

        public static AccessibleAction[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (AccessibleAction c : AccessibleAction.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static AccessibleAction valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


AccessibleAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Enum AccessibleAttribute

  • java.lang.Object
    • java.lang.Enum<AccessibleAttribute>
      • javafx.scene.AccessibleAttribute
  • All Implemented Interfaces:
    Serializable ， Comparable<AccessibleAttribute>

    public enum AccessibleAttribute
extends Enum<AccessibleAttribute>
    该枚举描述了诸如屏幕阅读器之类的辅助技术可以从场景图中请求的属性。 AccessibleRole规定了屏幕阅读器将要求特定控件的一组属性。 例如，预计滑块将返回一个代表当前值的double。

    属性可以具有任何数量的参数，这取决于具体的属性。

    当属性的值被节点改变时，它必须使用Node.notifyAccessibleAttributeChanged(AccessibleAttribute)通知辅助技术。 这将允许屏幕阅读器通知用户值已经改变。 最常见的通知形式是焦点变化。

    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Node.queryAccessibleAttribute(AccessibleAttribute, Object...) ， Node.notifyAccessibleAttributeChanged(AccessibleAttribute) ， AccessibleRole ， ROLE

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ACCELERATOR
      返回节点的加速器。
      BOUNDS
      返回节点的边界。
      BOUNDS_FOR_RANGE
      返回给定字符范围的边界矩形数组。
      CARET_OFFSET
      返回节点的插入偏移。
      CELL_AT_ROW_COLUMN
      返回给定行和列索引处的单元格。
      CHILDREN
      返回节点的子节点。
      COLUMN_AT_INDEX
      返回给定索引处的列。
      COLUMN_COUNT
      返回节点的列计数。
      COLUMN_INDEX
      返回节点的列索引。
      CONTENTS
      返回节点的内容。
      DATE
      返回节点的本地日期。
      DISABLED
      如果节点被禁用则返回true，否则返回false。
      DISCLOSURE_LEVEL
      返回披露层次结构中一行的深度。
      EDITABLE
      如果节点是可编辑的，则返回true，否则返回false。
      EXPANDED
      如果节点被展开，返回true，否则返回false。
      FOCUS_ITEM
      返回焦点项。
      FOCUS_NODE
      返回焦点节点。
      FOCUSED
      如果节点聚焦，则返回true，否则返回false。
      FONT
      返回节点的字体。
      HEADER
      返回节点的头。
      HELP
      返回节点的帮助文本。
      HORIZONTAL_SCROLLBAR
      返回节点的水平滚动条。
      INDETERMINATE
      返回true的节点是indeterminaite，否则为false。
      INDEX
      返回节点的索引。
      ITEM_AT_INDEX
      返回给定索引处的项目。
      ITEM_COUNT
      返回节点的项目计数。
      LABELED_BY
      返回作为该节点的标签的节点。
      LEAF
      如果节点是叶元素，则返回true，否则返回false。
      LINE_END
      返回给定行索引的行末端偏移量。
      LINE_FOR_OFFSET
      返回给定字符偏移量的行索引。
      LINE_START
      返回给定行索引的行开始偏移量。
      MAX_VALUE
      返回节点的最大值。
      MIN_VALUE
      返回节点的最小值。
      MNEMONIC
      返回节点的助记符。
      MULTIPLE_SELECTION
      如果节点允许多个选择，则返回true，否则返回false。
      NODE_AT_POINT
      返回给定位置的节点。
      OFFSET_AT_POINT
      返回给定位置的字符偏移量。
      ORIENTATION
      返回节点的方向。
      OVERFLOW_BUTTON
      返回节点的溢出按钮。
      PARENT
      返回节点的父节点。
      PARENT_MENU
      返回节点的父菜单。
      ROLE
      返回节点的角色。
      ROLE_DESCRIPTION
      返回节点的角色描述。
      ROW_AT_INDEX
      返回给定索引处的行。
      ROW_COUNT
      返回节点的行数。
      ROW_INDEX
      返回节点的行索引。
      SCENE
      返回节点的场景。
      SELECTED
      如果选择了节点，则返回true，否则返回false。
      SELECTED_ITEMS
      返回节点的选定项目列表。
      SELECTION_END
      返回节点的文本选择结束偏移量。
      SELECTION_START
      返回节点的文本选择开始偏移量。
      SUBMENU
      返回节点的子菜单。
      TEXT
      返回节点的文本。
      TREE_ITEM_AT_INDEX
      返回相对于其TREE_ITEM_PARENT的给定索引的树项。
      TREE_ITEM_COUNT
      返回该节点相对于其TREE_ITEM_PARENT的树项计数。
      TREE_ITEM_PARENT
      返回项的父项，如果该项是根，则返回null。
      VALUE
      返回节点的值。
      VERTICAL_SCROLLBAR
      返回节点的垂直滚动条。
      VISIBLE
      如果节点可见，则返回true，否则返回false。
      VISITED
      如果节点被访问，返回true，否则返回false。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Class<?> getReturnType​()
      static AccessibleAttribute valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AccessibleAttribute[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ACCELERATOR

        public static final AccessibleAttribute ACCELERATOR
        返回节点的加速器。
        • 用于：菜单，MenuItem，RadioMenuItem等
        • 需要通知：否
        • 返回类型： KeyCombination
        • 参数：

      • BOUNDS

        public static final AccessibleAttribute BOUNDS
        返回节点的边界。
        • 用途：节点
        • 需要通知：否
        • 返回类型： Bounds
        • 参数：

      • BOUNDS_FOR_RANGE

        public static final AccessibleAttribute BOUNDS_FOR_RANGE
        返回给定字符范围的边界矩形数组。
        • 用于：TextField和TextArea
        • 需要通知：否
        • 返回类型： Bounds []
        • 参数：
          • 起始偏移量为Integer
          • Integer结束偏移

      • CARET_OFFSET

        public static final AccessibleAttribute CARET_OFFSET
        返回节点的插入偏移。
        • 用于：TextField和TextArea
        • 需要通知：否
        • 返回类型： Integer
        • 参数：

      • CHILDREN

        public static final AccessibleAttribute CHILDREN
        返回节点的子节点。
        • 用途：父母
        • 需要通知：否
        • 返回类型： ObservableList < Node >
        • 参数：

      • COLUMN_AT_INDEX

        public static final AccessibleAttribute COLUMN_AT_INDEX
        返回给定索引处的列。
        • 用于：TableView和TreeTableView
        • 需要通知：否
        • 返回类型： Node
        • 参数：
          • Integer指数

      • CELL_AT_ROW_COLUMN

        public static final AccessibleAttribute CELL_AT_ROW_COLUMN
        返回给定行和列索引处的单元格。
        • 用于：TableView和TreeTableView
        • 需要通知：否
        • 返回类型： Node
        • 参数：
          • Integer行索引
          • Integer列索引

      • COLUMN_COUNT

        public static final AccessibleAttribute COLUMN_COUNT
        返回节点的列计数。
        • 用于：TableView和TreeTableView
        • 需要通知：否
        • 返回类型： Integer
        • 参数：

      • COLUMN_INDEX

        public static final AccessibleAttribute COLUMN_INDEX
        返回节点的列索引。
        • 用于：TableCell和TreeTableCell
        • 需要通知：否
        • 返回类型： Integer
        • 参数：

      • CONTENTS

        public static final AccessibleAttribute CONTENTS
        返回节点的内容。
        • 用途：ScrollPane
        • 需要通知：否
        • 返回类型： Node
        • 参数：

      • DISABLED

        public static final AccessibleAttribute DISABLED
        如果节点被禁用则返回true，否则返回false。
        • 用途：节点
        • 需要通知：否
        • 返回类型： Boolean
        • 参数：

      • DISCLOSURE_LEVEL

        public static final AccessibleAttribute DISCLOSURE_LEVEL
        返回披露层次结构中一行的深度。
        • 用于：TreeItem和TreeTableRow
        • 需要通知：否
        • 返回类型： Integer
        • 参数：

      • DATE

        public static final AccessibleAttribute DATE
        返回节点的本地日期。
        • 用途：DatePicker
        • 需要通知：否
        • 返回类型： LocalDate
        • 参数：

      • EDITABLE

        public static final AccessibleAttribute EDITABLE
        如果节点是可编辑的，则返回true，否则返回false。
        • 用于：TextField，ComboBox等
        • 需要通知：否
        • 返回类型： Boolean
        • 参数：

      • EXPANDED

        public static final AccessibleAttribute EXPANDED
        如果节点被展开，返回true，否则返回false。
        • 用途：TreeItem，TitledPane等
        • 需要通知：是的
        • 返回类型： Boolean
        • 参数：

      • FOCUS_ITEM

        public static final AccessibleAttribute FOCUS_ITEM
        返回焦点项。

        用于诸如TabPane，TableView，ListView等控件，辅助技术的重点与普通焦点节点不同。 例如，表控件将具有焦点，而表内的单元格可能具有屏幕阅读器的焦点。

        • 用途：ListView，TabPane等
        • 需要通知：是的
        • 返回类型： Node
        • 参数：

      • FOCUS_NODE

        public static final AccessibleAttribute FOCUS_NODE
        返回焦点节点。 类型：节点

        当从场景请求此属性时，默认实现返回Scene.focusOwnerProperty() 。

        • 用途：场景
        • 需要通知：是的
        • 返回类型： Node
        • 参数：

      • FOCUSED

        public static final AccessibleAttribute FOCUSED
        如果节点聚焦，则返回true，否则返回false。
        • 用途：节点
        • 需要通知：否
        • 返回类型： Boolean
        • 参数：

      • FONT

        public static final AccessibleAttribute FONT
        返回节点的字体。
        • 用于：TextField和TextArea
        • 需要通知：否
        • 返回类型： Font
        • 参数：

      • HEADER

        public static final AccessibleAttribute HEADER
        返回节点的头。
        • 用于：TableView和TreeTableView
        • 需要通知：否
        • 返回类型： Node
        • 参数：

      • HELP

        public static final AccessibleAttribute HELP
        返回节点的帮助文本。
        • 用途：节点
        • 需要通知：否
        • 返回类型： String
        • 参数：

      • HORIZONTAL_SCROLLBAR

        public static final AccessibleAttribute HORIZONTAL_SCROLLBAR
        返回节点的水平滚动条。
        • 用于：ListView，ScrollPane等
        • 需要通知：否
        • 返回类型： Node
        • 参数：

      • INDETERMINATE

        public static final AccessibleAttribute INDETERMINATE
        返回true的节点是indeterminaite，否则为false。
        • 用于：CheckBox和ProgressIndicator
        • 需要通知：是的
        • 返回类型： Boolean
        • 参数：

      • ITEM_AT_INDEX

        public static final AccessibleAttribute ITEM_AT_INDEX
        返回给定索引处的项目。
        • 用途：TabPane，ListView等
        • 需要通知：否
        • 返回类型： Node
        • 参数：
          • Integer指数

      • ITEM_COUNT

        public static final AccessibleAttribute ITEM_COUNT
        返回节点的项目计数。
        • 用途：TabPane，ListView等
        • 需要通知：否
        • 返回类型： Integer
        • 参数：

      • INDEX

        public static final AccessibleAttribute INDEX
        返回节点的索引。
        • 用于：ListItem，TableRow等
        • 需要通知：否
        • 返回类型： Integer
        • 参数：

      • LABELED_BY

        public static final AccessibleAttribute LABELED_BY
        返回作为该节点的标签的节点。

        当设置为LABELED_BY时， LABELED_BY的默认实现使用此关系将适当的节点返回给屏幕阅读器。

        • 用途：节点
        • 需要通知：否
        • 返回类型： Node
        • 参数：

      • LEAF

        public static final AccessibleAttribute LEAF
        如果节点是叶元素，则返回true，否则返回false。
        • 用于：TreeItem和TreeTableRow
        • 需要通知：否
        • 返回类型： Boolean
        • 参数：

      • LINE_END

        public static final AccessibleAttribute LINE_END
        返回给定行索引的行末端偏移量。
        • 用途：TextArea
        • 需要通知：否
        • 返回类型： Integer
        • 参数：
          • Integer行索引

      • LINE_FOR_OFFSET

        public static final AccessibleAttribute LINE_FOR_OFFSET
        返回给定字符偏移量的行索引。
        • 用途：TextArea
        • 需要通知：否
        • 返回类型： Integer
        • 参数：
          • Integer字符偏移

      • LINE_START

        public static final AccessibleAttribute LINE_START
        返回给定行索引的行开始偏移量。
        • 用途：TextArea
        • 需要通知：否
        • 返回类型： Integer
        • 参数：
          • Integer行索引

      • MIN_VALUE

        public static final AccessibleAttribute MIN_VALUE
        返回节点的最小值。
        • 用于：滑块，滚动条和其他
        • 需要通知：否
        • 返回类型： Double
        • 参数：

      • MAX_VALUE

        public static final AccessibleAttribute MAX_VALUE
        返回节点的最大值。
        • 用于：滑块，滚动条和其他
        • 需要通知：否
        • 返回类型： Double
        • 参数：

      • MNEMONIC

        public static final AccessibleAttribute MNEMONIC
        返回节点的助记符。
        • 用于：Menu，MenuItem，CheckMenuItem等
        • 需要通知：否
        • 返回类型： String
        • 参数：

      • MULTIPLE_SELECTION

        public static final AccessibleAttribute MULTIPLE_SELECTION
        如果节点允许多个选择，则返回true，否则返回false。
        • 用于：ListView，TableView等
        • 需要通知：否
        • 返回类型： Boolean
        • 参数：

      • NODE_AT_POINT

        public static final AccessibleAttribute NODE_AT_POINT
        返回给定位置的节点。
        • 用途：场景
        • 需要通知：否
        • 返回类型： Node
        • 参数：
          • Point2D点位置

      • OFFSET_AT_POINT

        public static final AccessibleAttribute OFFSET_AT_POINT
        返回给定位置的字符偏移量。
        • 用于：TextField和TextArea
        • 需要通知：否
        • 返回类型： Integer
        • 参数：
          • Point2D点位置

      • ORIENTATION

        public static final AccessibleAttribute ORIENTATION
        返回节点的方向。
        • 用途：ScrolBar和Slider
        • 需要通知：否
        • 返回类型： Orientation
        • 参数：

      • OVERFLOW_BUTTON

        public static final AccessibleAttribute OVERFLOW_BUTTON
        返回节点的溢出按钮。
        • 用途：工具栏
        • 需要通知：否
        • 返回类型： Node
        • 参数：

      • PARENT

        public static final AccessibleAttribute PARENT
        返回节点的父节点。
        • 用途：节点
        • 需要通知：是的
        • 返回类型： Parent
        • 参数：

      • PARENT_MENU

        public static final AccessibleAttribute PARENT_MENU
        返回节点的父菜单。
        • 用途：ContextMenu
        • 需要通知：否
        • 返回类型： Node
        • 参数：

      • ROLE

        public static final AccessibleAttribute ROLE
        返回节点的角色。
        • 用途：节点
        • 需要通知：否
        • 返回类型： AccessibleRole
        • 参数：

      • ROLE_DESCRIPTION

        public static final AccessibleAttribute ROLE_DESCRIPTION
        返回节点的角色描述。
        • 用途：节点
        • 需要通知：否
        • 返回类型： String
        • 参数：

      • ROW_AT_INDEX

        public static final AccessibleAttribute ROW_AT_INDEX
        返回给定索引处的行。
        • 用于：TableView，TreeView和TreeTableView
        • 需要通知：否
        • 返回类型： Node
        • 参数：
          • Integer行索引

      • ROW_COUNT

        public static final AccessibleAttribute ROW_COUNT
        返回节点的行数。
        • 用于：TableView，TreeView和TreeTableView
        • 需要通知：否
        • 返回类型： Integer
        • 参数：

      • ROW_INDEX

        public static final AccessibleAttribute ROW_INDEX
        返回节点的行索引。
        • 用于：TableCell，TreeItem和TreeTableCell
        • 需要通知：否
        • 返回类型： Integer
        • 参数：

      • SCENE

        public static final AccessibleAttribute SCENE
        返回节点的场景。
        • 用途：节点
        • 需要通知：否
        • 返回类型： Scene
        • 参数：

      • SELECTED

        public static final AccessibleAttribute SELECTED
        如果选择了节点，则返回true，否则返回false。
        • 用于：CheckBox，TreeItem等
        • 需要通知：否
        • 返回类型： Boolean
        • 参数：

      • SELECTED_ITEMS

        public static final AccessibleAttribute SELECTED_ITEMS
        返回节点的选定项目列表。
        • 用于：ListView，TableView等
        • 需要通知：否
        • 返回类型： ObservableList < Node >
        • 参数：

      • SELECTION_END

        public static final AccessibleAttribute SELECTION_END
        返回节点的文本选择结束偏移量。
        • 用于：TextField和TextArea
        • 需要通知：是的
        • 返回类型： Integer
        • 参数：

      • SELECTION_START

        public static final AccessibleAttribute SELECTION_START
        返回节点的文本选择开始偏移量。
        • 用于：TextField和TextArea
        • 需要通知：是的
        • 返回类型： Integer
        • 参数：

      • SUBMENU

        public static final AccessibleAttribute SUBMENU
        返回节点的子菜单。
        • 用途：菜单
        • 需要通知：否
        • 返回类型： Node
        • 参数：

      • TEXT

        public static final AccessibleAttribute TEXT
        返回节点的文本。 例如
        • ComboBox返回当前所选项目的字符串表示形式。
        • TextField返回文本字段的内容。
        • 用途：节点
        • 需要通知：是的
        • 返回类型： String
        • 参数：

      • TREE_ITEM_AT_INDEX

        public static final AccessibleAttribute TREE_ITEM_AT_INDEX
        返回相对于其TREE_ITEM_PARENT的给定索引的树项。
        • 用于：TreeItem和TreeTableRow
        • 需要通知：否
        • 返回类型： Node
        • 参数：
          • Integer索引

      • TREE_ITEM_COUNT

        public static final AccessibleAttribute TREE_ITEM_COUNT
        返回该节点相对于其TREE_ITEM_PARENT的树项计数。
        • 用于：TreeItem和TreeTableRow
        • 需要通知：否
        • 返回类型： Integer
        • 参数：

      • TREE_ITEM_PARENT

        public static final AccessibleAttribute TREE_ITEM_PARENT
        返回项的父项，如果该项是根，则返回null。
        • 用于：TreeItem和TreeTableRow
        • 需要通知：否
        • 返回类型： Node
        • 参数：

      • VALUE

        public static final AccessibleAttribute VALUE
        返回节点的值。
        • 用于：滑块，滚动条，拇指等
        • 需要通知：是的
        • 返回类型： Double
        • 参数：

      • VERTICAL_SCROLLBAR

        public static final AccessibleAttribute VERTICAL_SCROLLBAR
        返回节点的垂直滚动条。
        • 用于：ListView，ScrollPane等
        • 需要通知：否
        • 返回类型： Node
        • 参数：

      • VISIBLE

        public static final AccessibleAttribute VISIBLE
        如果节点可见，则返回true，否则返回false。
        • 用途：Node和ContextMenu
        • 需要通知：是的
        • 返回类型： Boolean
        • 参数：

      • VISITED

        public static final AccessibleAttribute VISITED
        如果节点被访问，返回true，否则返回false。
        • 用途：超链接
        • 需要通知：否
        • 返回类型： Boolean
        • 参数：

    • 方法详细信息

      • values

        public static AccessibleAttribute[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (AccessibleAttribute c : AccessibleAttribute.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static AccessibleAttribute valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null

      • getReturnType

        public Class<?> getReturnType​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


AccessibleRole (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Enum AccessibleRole

  • java.lang.Object
    • java.lang.Enum<AccessibleRole>
      • javafx.scene.AccessibleRole
  • All Implemented Interfaces:
    Serializable ， Comparable<AccessibleRole>

    public enum AccessibleRole
extends Enum<AccessibleRole>
    这个枚举描述了一个Node的可访问角色。 该角色由诸如屏幕阅读器的辅助技术用于决定节点的一组动作和属性。 例如，当屏幕阅读器需要滑块的当前值时，它将使用value属性来请求它。 当屏幕阅读器更改滑块的值时，它将使用动作来设置滑块的当前值。 滑块必须对这两个请求做出适当的响应。
    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Node.setAccessibleRole(AccessibleRole) ， Node.getAccessibleRole() ， AccessibleAttribute.ROLE ， Node.queryAccessibleAttribute(AccessibleAttribute, Object...) ， Node.executeAccessibleAction(AccessibleAction, Object...)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BUTTON
      按钮角色。
      CHECK_BOX
      复选框角色。
      CHECK_MENU_ITEM
      检查菜单项角色。
      COMBO_BOX
      组合框角色。
      CONTEXT_MENU
      上下文菜单角色。
      DATE_PICKER
      日期选择器角色。
      DECREMENT_BUTTON
      递减按钮角色。
      HYPERLINK
      超链接角色。
      IMAGE_VIEW
      图像查看角色。
      INCREMENT_BUTTON
      增量按钮角色。
      LIST_ITEM
      列出项目角色。
      LIST_VIEW
      列表视图角色。
      MENU
      菜单角色。
      MENU_BAR
      菜单栏角色。
      MENU_BUTTON
      菜单按钮角色。
      MENU_ITEM
      菜单项的作用。
      NODE
      节点角色。
      PAGE_ITEM
      页面角色。
      PAGINATION
      分页角色
      PARENT
      家长角色。
      PASSWORD_FIELD
      密码字段角色。
      PROGRESS_INDICATOR
      进度指标的作用
      RADIO_BUTTON
      单选按钮角色。
      RADIO_MENU_ITEM
      收音机菜单项目角色。
      SCROLL_BAR
      滚动栏角色。
      SCROLL_PANE
      滚动窗格角色。
      SLIDER
      滑块角色。
      SPINNER
      旋转角色。
      SPLIT_MENU_BUTTON
      拆分菜单按钮角色。
      TAB_ITEM
      选项卡项目角色。
      TAB_PANE
      Tab窗格角色。
      TABLE_CELL
      表单元格角色。
      TABLE_COLUMN
      表列角色。
      TABLE_ROW
      表行角色。
      TABLE_VIEW
      表视图角色。
      TEXT
      文字角色。
      TEXT_AREA
      文本区角色。
      TEXT_FIELD
      文本字段角色。
      THUMB
      拇指角色。
      TITLED_PANE
      标题窗格角色。
      TOGGLE_BUTTON
      切换按钮角色。
      TOOL_BAR
      工具栏角色。
      TOOLTIP
      工具提示角色。
      TREE_ITEM
      树项目角色。
      TREE_TABLE_CELL
      树表单元角色。
      TREE_TABLE_ROW
      树表行角色。
      TREE_TABLE_VIEW
      树表视图角色。
      TREE_VIEW
      树视图角色。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static AccessibleRole valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AccessibleRole[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BUTTON

        public static final AccessibleRole BUTTON
        按钮角色。

        属性：

        • AccessibleAttribute.TEXT
        操作：
        • AccessibleAction.FIRE

      • CHECK_BOX

        public static final AccessibleRole CHECK_BOX
        复选框角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.SELECTED
        • AccessibleAttribute.INDETERMINATE
        操作：
        • AccessibleAction.FIRE

      • CHECK_MENU_ITEM

        public static final AccessibleRole CHECK_MENU_ITEM
        检查菜单项角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.ACCELERATOR
        • AccessibleAttribute.MNEMONIC
        • AccessibleAttribute.DISABLED
        • AccessibleAttribute.SELECTED
        操作：
        • AccessibleAction.FIRE

      • COMBO_BOX

        public static final AccessibleRole COMBO_BOX
        组合框角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.EXPANDED
        • AccessibleAttribute.EDITABLE
        操作：
        • AccessibleAction.EXPAND
        • AccessibleAction.COLLAPSE

      • CONTEXT_MENU

        public static final AccessibleRole CONTEXT_MENU
        上下文菜单角色。

        属性：

        • AccessibleAttribute.PARENT_MENU
        • AccessibleAttribute.VISIBLE

      • DATE_PICKER

        public static final AccessibleRole DATE_PICKER
        日期选择器角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.DATE

      • DECREMENT_BUTTON

        public static final AccessibleRole DECREMENT_BUTTON
        递减按钮角色。

        属性：

        • AccessibleAttribute.TEXT
        操作：
        • AccessibleAction.FIRE

      • HYPERLINK

        public static final AccessibleRole HYPERLINK
        超链接角色。
        • AccessibleAttribute.TEXT
        • AccessibleAttribute.VISITED
        操作：
        • AccessibleAction.FIRE

      • INCREMENT_BUTTON

        public static final AccessibleRole INCREMENT_BUTTON
        增量按钮角色。

        属性：

        • AccessibleAttribute.TEXT
        操作：
        • AccessibleAction.FIRE

      • IMAGE_VIEW

        public static final AccessibleRole IMAGE_VIEW
        图像查看角色。

        属性：操作：

        强烈建议为每个ImageView提供图像的文本描述。 这可以通过为ImageView设置Node.accessibleTextProperty()或使用AccessibleAttribute.LABELED_BY来完成 。

      • LIST_VIEW

        public static final AccessibleRole LIST_VIEW
        列表视图角色。

        属性：

        • AccessibleAttribute.ITEM_AT_INDEX
        • AccessibleAttribute.ITEM_COUNT
        • AccessibleAttribute.SELECTED_ITEMS
        • AccessibleAttribute.MULTIPLE_SELECTION
        • AccessibleAttribute.VERTICAL_SCROLLBAR
        • AccessibleAttribute.HORIZONTAL_SCROLLBAR
        • AccessibleAttribute.FOCUS_ITEM
        操作：
        • AccessibleAction.SHOW_ITEM
        • AccessibleAction.SET_SELECTED_ITEMS

      • LIST_ITEM

        public static final AccessibleRole LIST_ITEM
        列出项目角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.INDEX
        • AccessibleAttribute.SELECTED
        操作：
        • AccessibleAction.REQUEST_FOCUS

      • MENU

        public static final AccessibleRole MENU
        菜单角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.ACCELERATOR
        • AccessibleAttribute.MNEMONIC
        • AccessibleAttribute.DISABLED
        • AccessibleAttribute.SUBMENU
        操作：
        • AccessibleAction.FIRE

      • MENU_BAR

        public static final AccessibleRole MENU_BAR
        菜单栏角色。

        属性：

        操作：

      • MENU_BUTTON

        public static final AccessibleRole MENU_BUTTON
        菜单按钮角色。

        属性：

        • AccessibleAttribute.TEXT
        操作：
        • AccessibleAction.FIRE

      • MENU_ITEM

        public static final AccessibleRole MENU_ITEM
        菜单项的作用。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.ACCELERATOR
        • AccessibleAttribute.MNEMONIC
        • AccessibleAttribute.DISABLED
        操作：
        • AccessibleAction.FIRE

      • NODE

        public static final AccessibleRole NODE
        节点角色。

        属性：

        • AccessibleAttribute.ROLE
        • AccessibleAttribute.PARENT
        • AccessibleAttribute.SCENE
        • AccessibleAttribute.BOUNDS
        • AccessibleAttribute.DISABLED
        • AccessibleAttribute.FOCUSED
        • AccessibleAttribute.VISIBLE
        操作：
        • AccessibleAction.REQUEST_FOCUS
        可选属性：
        • AccessibleAttribute.TEXT
        • AccessibleAttribute.LABELED_BY
        • AccessibleAttribute.ROLE_DESCRIPTION
        • AccessibleAttribute.HELP
        可选操作：
        • AccessibleAction.SHOW_MENU

      • PAGE_ITEM

        public static final AccessibleRole PAGE_ITEM
        页面角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.SELECTED
        操作：
        • AccessibleAction.REQUEST_FOCUS

      • PAGINATION

        public static final AccessibleRole PAGINATION
        分页角色

        属性：

        • AccessibleAttribute.ITEM_AT_INDEX
        • AccessibleAttribute.ITEM_COUNT
        • AccessibleAttribute.FOCUS_ITEM
        操作：

      • PARENT

        public static final AccessibleRole PARENT
        家长角色。

        属性：

        • AccessibleAttribute.CHILDREN
        操作：

      • PASSWORD_FIELD

        public static final AccessibleRole PASSWORD_FIELD
        密码字段角色。

        属性：

        • AccessibleAttribute.TEXT - 必须返回null或空字符串
        操作：

      • PROGRESS_INDICATOR

        public static final AccessibleRole PROGRESS_INDICATOR
        进度指标的作用

        属性：

        • AccessibleAttribute.VALUE
        • AccessibleAttribute.MIN_VALUE
        • AccessibleAttribute.MAX_VALUE
        • AccessibleAttribute.INDETERMINATE
        操作：

      • RADIO_BUTTON

        public static final AccessibleRole RADIO_BUTTON
        单选按钮角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.SELECTED
        操作：
        • AccessibleAction.FIRE

      • RADIO_MENU_ITEM

        public static final AccessibleRole RADIO_MENU_ITEM
        收音机菜单项目角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.ACCELERATOR
        • AccessibleAttribute.MNEMONIC
        • AccessibleAttribute.DISABLED
        • AccessibleAttribute.SELECTED
        操作：
        • AccessibleAction.FIRE

      • SLIDER

        public static final AccessibleRole SLIDER
        滑块角色。

        属性：

        • AccessibleAttribute.VALUE
        • AccessibleAttribute.MIN_VALUE
        • AccessibleAttribute.MAX_VALUE
        • AccessibleAttribute.ORIENTATION
        操作：
        • AccessibleAction.INCREMENT
        • AccessibleAction.DECREMENT
        • AccessibleAction.SET_VALUE

      • SPINNER

        public static final AccessibleRole SPINNER
        旋转角色。

        属性：

        • AccessibleAttribute.TEXT
        操作：
        • AccessibleAction.INCREMENT
        • AccessibleAction.DECREMENT

      • TEXT

        public static final AccessibleRole TEXT
        文字角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.FONT
        操作：
        • AccessibleAction.SET_TEXT

      • TEXT_AREA

        public static final AccessibleRole TEXT_AREA
        文本区角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.FONT
        • AccessibleAttribute.EDITABLE
        • AccessibleAttribute.SELECTION_START
        • AccessibleAttribute.SELECTION_END
        • AccessibleAttribute.CARET_OFFSET
        • AccessibleAttribute.OFFSET_AT_POINT
        • AccessibleAttribute.LINE_START
        • AccessibleAttribute.LINE_END
        • AccessibleAttribute.LINE_FOR_OFFSET
        • AccessibleAttribute.BOUNDS_FOR_RANGE
        操作：
        • AccessibleAction.SET_TEXT
        • AccessibleAction.SET_TEXT_SELECTION

      • TEXT_FIELD

        public static final AccessibleRole TEXT_FIELD
        文本字段角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.FONT
        • AccessibleAttribute.EDITABLE
        • AccessibleAttribute.SELECTION_START
        • AccessibleAttribute.SELECTION_END
        • AccessibleAttribute.CARET_OFFSET
        • AccessibleAttribute.OFFSET_AT_POINT
        • AccessibleAttribute.BOUNDS_FOR_RANGE
        操作：
        • AccessibleAction.SET_TEXT
        • AccessibleAction.SET_TEXT_SELECTION

      • TOGGLE_BUTTON

        public static final AccessibleRole TOGGLE_BUTTON
        切换按钮角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.SELECTED
        操作：
        • AccessibleAction.FIRE

      • TOOLTIP

        public static final AccessibleRole TOOLTIP
        工具提示角色。

        属性：操作：

      • SCROLL_BAR

        public static final AccessibleRole SCROLL_BAR
        滚动栏角色。

        属性：

        • AccessibleAttribute.VALUE
        • AccessibleAttribute.MAX_VALUE
        • AccessibleAttribute.MIN_VALUE
        • AccessibleAttribute.ORIENTATION
        操作：
        • AccessibleAction.INCREMENT
        • AccessibleAction.DECREMENT
        • AccessibleAction.BLOCK_INCREMENT
        • AccessibleAction.BLOCK_DECREMENT
        • AccessibleAction.SET_VALUE

      • SCROLL_PANE

        public static final AccessibleRole SCROLL_PANE
        滚动窗格角色。

        属性：

        • AccessibleAttribute.CONTENTS
        • AccessibleAttribute.HORIZONTAL_SCROLLBAR
        • AccessibleAttribute.VERTICAL_SCROLLBAR
        操作：

      • SPLIT_MENU_BUTTON

        public static final AccessibleRole SPLIT_MENU_BUTTON
        拆分菜单按钮角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.EXPANDED
        操作：
        • AccessibleAction.FIRE
        • AccessibleAction.EXPAND
        • AccessibleAction.COLLAPSE

      • TAB_ITEM

        public static final AccessibleRole TAB_ITEM
        选项卡项目角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.SELECTED
        操作：
        • AccessibleAction.REQUEST_FOCUS

      • TAB_PANE

        public static final AccessibleRole TAB_PANE
        Tab窗格角色。

        属性：

        • AccessibleAttribute.ITEM_AT_INDEX
        • AccessibleAttribute.ITEM_COUNT
        • AccessibleAttribute.FOCUS_ITEM
        操作：

      • TABLE_CELL

        public static final AccessibleRole TABLE_CELL
        表单元格角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.ROW_INDEX
        • AccessibleAttribute.COLUMN_INDEX
        • AccessibleAttribute.SELECTED
        操作：
        • AccessibleAction.REQUEST_FOCUS

      • TABLE_COLUMN

        public static final AccessibleRole TABLE_COLUMN
        表列角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.INDEX
        操作：

      • TABLE_ROW

        public static final AccessibleRole TABLE_ROW
        表行角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.INDEX
        操作：

      • TABLE_VIEW

        public static final AccessibleRole TABLE_VIEW
        表视图角色。

        属性：

        • AccessibleAttribute.ROW_COUNT
        • AccessibleAttribute.ROW_AT_INDEX
        • AccessibleAttribute.COLUMN_COUNT
        • AccessibleAttribute.COLUMN_AT_INDEX
        • AccessibleAttribute.SELECTED_ITEMS
        • AccessibleAttribute.CELL_AT_ROW_COLUMN
        • AccessibleAttribute.HEADER
        • AccessibleAttribute.MULTIPLE_SELECTION
        • AccessibleAttribute.VERTICAL_SCROLLBAR
        • AccessibleAttribute.HORIZONTAL_SCROLLBAR
        • AccessibleAttribute.FOCUS_ITEM
        操作：
        • AccessibleAction.SHOW_ITEM
        • AccessibleAction.SET_SELECTED_ITEMS

      • THUMB

        public static final AccessibleRole THUMB
        拇指角色。

        属性：

        • AccessibleAttribute.VALUE
        操作：

      • TITLED_PANE

        public static final AccessibleRole TITLED_PANE
        标题窗格角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.EXPANDED
        操作：
        • AccessibleAction.EXPAND
        • AccessibleAction.COLLAPSE

      • TOOL_BAR

        public static final AccessibleRole TOOL_BAR
        工具栏角色。

        属性：

        • AccessibleAttribute.OVERFLOW_BUTTON
        操作：

      • TREE_ITEM

        public static final AccessibleRole TREE_ITEM
        树项目角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.INDEX
        • AccessibleAttribute.SELECTED
        • AccessibleAttribute.EXPANDED
        • AccessibleAttribute.LEAF
        • AccessibleAttribute.DISCLOSURE_LEVEL
        • AccessibleAttribute.TREE_ITEM_COUNT
        • AccessibleAttribute.TREE_ITEM_AT_INDEX
        • AccessibleAttribute.TREE_ITEM_PARENT
        操作：
        • AccessibleAction.EXPAND
        • AccessibleAction.COLLAPSE
        • AccessibleAction.REQUEST_FOCUS

      • TREE_TABLE_CELL

        public static final AccessibleRole TREE_TABLE_CELL
        树表单元角色。

        属性：

        • AccessibleAttribute.TEXT
        • AccessibleAttribute.SELECTED
        • AccessibleAttribute.ROW_INDEX
        • AccessibleAttribute.COLUMN_INDEX
        操作：
        • AccessibleAction.REQUEST_FOCUS

      • TREE_TABLE_ROW

        public static final AccessibleRole TREE_TABLE_ROW
        树表行角色。

        属性：

        • AccessibleAttribute.INDEX
        • AccessibleAttribute.EXPANDED
        • AccessibleAttribute.LEAF
        • AccessibleAttribute.DISCLOSURE_LEVEL
        • AccessibleAttribute.TREE_ITEM_COUNT
        • AccessibleAttribute.TREE_ITEM_AT_INDEX
        • AccessibleAttribute.TREE_ITEM_PARENT
        操作：
        • AccessibleAction.EXPAND
        • AccessibleAction.COLLAPSE

      • TREE_TABLE_VIEW

        public static final AccessibleRole TREE_TABLE_VIEW
        树表视图角色。

        属性：

        • AccessibleAttribute.ROW_COUNT
        • AccessibleAttribute.ROW_AT_INDEX
        • AccessibleAttribute.COLUMN_COUNT
        • AccessibleAttribute.COLUMN_AT_INDEX
        • AccessibleAttribute.SELECTED_ITEMS
        • AccessibleAttribute.CELL_AT_ROW_COLUMN
        • AccessibleAttribute.HEADER
        • AccessibleAttribute.MULTIPLE_SELECTION
        • AccessibleAttribute.VERTICAL_SCROLLBAR
        • AccessibleAttribute.HORIZONTAL_SCROLLBAR
        • AccessibleAttribute.FOCUS_ITEM
        操作：
        • AccessibleAction.SHOW_ITEM
        • AccessibleAction.SET_SELECTED_ITEMS

      • TREE_VIEW

        public static final AccessibleRole TREE_VIEW
        树视图角色。

        属性：

        • AccessibleAttribute.ROW_COUNT
        • AccessibleAttribute.ROW_AT_INDEX
        • AccessibleAttribute.SELECTED_ITEMS
        • AccessibleAttribute.MULTIPLE_SELECTION
        • AccessibleAttribute.VERTICAL_SCROLLBAR
        • AccessibleAttribute.HORIZONTAL_SCROLLBAR
        • AccessibleAttribute.FOCUS_ITEM
        操作：
        • AccessibleAction.SHOW_ITEM
        • AccessibleAction.SET_SELECTED_ITEMS

    • 方法详细信息

      • values

        public static AccessibleRole[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (AccessibleRole c : AccessibleRole.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static AccessibleRole valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


AmbientLight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class AmbientLight

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.LightBase
        • javafx.scene.AmbientLight
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class AmbientLight
extends LightBase
    定义环境光源对象。 环境光是一个似乎来自各个方向的光源。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      • Properties inherited from class javafx.scene.LightBase

        color, lightOn

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      AmbientLight​()
      使用默认的Color.WHITE光源创建一个 AmbientLight类的新实例。
      AmbientLight​(Color color)
      使用指定的颜色创建一个 AmbientLight类的新实例。

    • 方法摘要

      • Methods inherited from class javafx.scene.LightBase

        colorProperty, getColor, getScope, isLightOn, lightOnProperty, setColor, setLightOn

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • AmbientLight

        public AmbientLight​()
        使用默认的Color.WHITE光源创建一个 AmbientLight类的新实例。

      • AmbientLight

        public AmbientLight​(Color color)
        使用指定的颜色创建一个新的 AmbientLight类的实例。
        参数
        color - 光源的颜色
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CacheHint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Enum CacheHint

  • java.lang.Object
    • java.lang.Enum<CacheHint>
      • javafx.scene.CacheHint
  • All Implemented Interfaces:
    Serializable ， Comparable<CacheHint>

    public enum CacheHint
extends Enum<CacheHint>
    缓存提示与 Node.cacheHint一起使用
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Node.cacheHintProperty()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DEFAULT
      没有额外的提示。
      QUALITY
      告诉位图缓存机制，这个节点应该以最高的视觉质量出现在屏幕上。
      ROTATE
      提示说明位图缓存机制，如果节点被旋转，可以通过旋转缓存的位图（而不是重新渲染节点）来绘制它。
      SCALE
      提示说明位图缓存机制，如果节点放大或缩小，可以通过缩放缓存的位图（而不是重新渲染节点）来绘制它。
      SCALE_AND_ROTATE
      提示说明位图缓存机制，如果节点被缩放和/或旋转，可以通过缩放和/或旋转缓存的位图（而不是重新渲染节点）来绘制它。
      SPEED
      告诉位图缓存机制，这个节点是动画，并应该从位图缓存中绘制，以尽可能保持平滑的动画。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static CacheHint valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CacheHint[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DEFAULT

        public static final CacheHint DEFAULT
        没有额外的提示。 系统将确定位图缓存的最佳使用。

      • SPEED

        public static final CacheHint SPEED
        告诉位图缓存机制，这个节点是动画，并应该从位图缓存中绘制，以尽可能保持平滑的动画。 权衡是因为这可能导致视觉质量下降。

      • QUALITY

        public static final CacheHint QUALITY
        告诉位图缓存机制，这个节点应该以最高的视觉质量出现在屏幕上。 缓存的位图只会在屏幕上不会降低节点外观时使用。

        权衡是动画可能会导致节点呈现的方式的微妙变化，因此即使在这样的微妙变化在...中不可见时，也可能需要具有QUALITY的cacheHint的节点来重新呈现节点在动画中间 因此，具有QUALITY的cacheHint的节点将经常受益于在动画期间将其cacheHint替换为更多允许值（例如SPEED ）。

      • SCALE

        public static final CacheHint SCALE
        提示说明位图缓存机制，如果节点放大或缩小，可以通过缩放缓存的位图（而不是重新渲染节点）来绘制它。

      • ROTATE

        public static final CacheHint ROTATE
        提示说明位图缓存机制，如果节点被旋转，可以通过旋转缓存的位图（而不是重新渲染节点）来绘制它。

      • SCALE_AND_ROTATE

        public static final CacheHint SCALE_AND_ROTATE
        提示说明位图缓存机制，如果节点被缩放和/或旋转，可以通过缩放和/或旋转缓存的位图（而不是重新渲染节点）来绘制它。

    • 方法详细信息

      • values

        public static CacheHint[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (CacheHint c : CacheHint.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static CacheHint valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Camera (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class Camera

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Camera
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    ParallelCamera ， PerspectiveCamera

    public abstract class Camera
extends Node
    用于渲染场景的相机的基类。 相机定义了场景坐标空间到窗口的映射。 相机是一个具有两个具体子类的抽象类： ParallelCamera和PerspectiveCamera 。

    默认摄像机位于场景中，使其在场景坐标空间中的投影平面处于Z = 0，并且在正Z方向上观察屏幕。 从相机到投影平面的Z距离width height的场景的width和height及其fieldOfView 。

    本相机的nearClip和farClip在眼睛坐标空间中指定。 该空间被定义为使得眼睛处于其原点并且投影平面在正Z方向上在眼前方的一个单位。

    以下伪代码是用于计算场景坐标空间中近距离和远距离剪辑距离的数学：

      final double tanOfHalfFOV = Math.tan(Math.toRadians(FOV) / 2.0);
 final double halfHeight = HEIGHT / 2;
 final double focalLenght = halfHeight / tanOfHalfFOV;
 final double eyePositionZ = -1.0 * focalLenght;
 final double nearClipDistance = focalLenght * NEAR + eyePositionZ;
 final double farClipDistance = focalLenght * FAR + eyePositionZ;

    其中FOV是fieldOfView度， NEAR是nearClip眼空间指定，并且FAR是farClip在眼空间中指定。

    注意：由于ParallelCamera类没有fieldOfView属性，因此使用30度垂直视野。

    注意：对于PerspectiveCamera，其中fixedEyeAtCameraZero属性为true，场景坐标空间被归一化以适应视锥结构（详见PerspectiveCamera ）。 在此模式下，眼睛坐标空间与该Camera节点的局部坐标空间相同。 因此，不使用上述转化公式。

    应用程序不应该直接扩展Camera类。 否则可能导致抛出UnsupportedOperationException异常。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty farClip
      指定眼睛坐标空间中该 Camera的远剪切平面眼睛的距离。
      DoubleProperty nearClip
      指定眼睛坐标空间中 Camera的近剪裁平面眼睛的距离。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | Camera​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty farClipProperty​()
      指定眼睛坐标空间中该 Camera的远剪切平面的距离。
      double getFarClip​()
      获取属性farClip的值。
      double getNearClip​()
      获取nearClip附近的属性的值。
      DoubleProperty nearClipProperty​()
      指定眼睛坐标空间中 Camera的近剪取平面眼睛的距离。
      void setFarClip​(double value)
      设置属性farClip的值。
      void setNearClip​(double value)
      设置属性nearClip的值。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • nearClip

        public final DoubleProperty nearClipProperty
        指定眼睛坐标空间中该Camera的近剪取平面眼睛的距离。 没有绘制比nearClip更接近眼睛的物体。 nearClip被指定为大于零的值。 小于或等于零的值被视为非常小的正数。
        Default value:
        0.1
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getNearClip() ， setNearClip(double)

      • farClip

        public final DoubleProperty farClipProperty
        指定眼睛坐标空间中该Camera的远剪切平面眼睛的距离。 远离眼睛的物体比farClip没有绘制。 farClip被指定为大于nearClip的值。 小于或等于nearClip值被视为nearClip加上非常小的正数。
        Default value:
        100.0
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFarClip() ， setFarClip(double)

    • 构造方法详细信息

      • Camera

        protected Camera​()

    • 方法详细信息

      • setNearClip

        public final void setNearClip​(double value)
        设置属性nearClip的值。
        Property description:
        指定眼睛坐标空间中该Camera的近剪取平面眼睛的距离。 没有绘制比nearClip更接近眼睛的物体。 nearClip被指定为大于零的值。 小于或等于零的值被视为非常小的正数。
        Default value:
        0.1
        从以下版本开始：
        JavaFX 8.0

      • getNearClip

        public final double getNearClip​()
        获取nearClip附近的属性的值。
        Property description:
        指定眼睛坐标空间中该Camera的近剪裁平面眼睛的距离。 没有画出比nearClip更接近眼睛的物体。 nearClip被指定为大于零的值。 小于或等于零的值被视为非常小的正数。
        Default value:
        0.1
        从以下版本开始：
        JavaFX 8.0

      • nearClipProperty

        public final DoubleProperty nearClipProperty​()
        指定眼睛坐标空间中该Camera的近剪取平面眼睛的距离。 没有绘制比nearClip更接近眼睛的物体。 nearClip被指定为大于零的值。 小于或等于零的值被视为非常小的正数。
        Default value:
        0.1
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getNearClip() ， setNearClip(double)

      • setFarClip

        public final void setFarClip​(double value)
        设置属性farClip的值。
        Property description:
        指定眼睛坐标空间中该Camera的远剪切平面眼睛的距离。 远离眼睛的物体比farClip没有绘制。 farClip被指定为大于nearClip的值。 小于或等于nearClip值被视为nearClip加上非常小的正数。
        Default value:
        100.0
        从以下版本开始：
        JavaFX 8.0

      • getFarClip

        public final double getFarClip​()
        获取属性farClip的值。
        Property description:
        指定眼睛坐标空间中该Camera的远剪切平面的距离。 远离眼睛的物体比farClip没有绘制。 farClip被指定为大于nearClip的值。 小于或等于nearClip值被视为nearClip加上非常小的正数。
        Default value:
        100.0
        从以下版本开始：
        JavaFX 8.0

      • farClipProperty

        public final DoubleProperty farClipProperty​()
        指定眼睛坐标空间中该Camera的远剪取平面的距离。 远离眼睛的物体比farClip没有绘制。 farClip被指定为大于nearClip的值。 小于或等于nearClip值被视为nearClip加上非常小的正数。
        Default value:
        100.0
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFarClip() ， setFarClip(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Cursor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class Cursor

  • java.lang.Object
    • javafx.scene.Cursor
  • 已知直接子类：
    ImageCursor

    public abstract class Cursor
extends Object
    封装鼠标光标位图表示的类。
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Cursor CLOSED_HAND
      用手关闭的光标，通常在“抓取”时使用，例如，当平移时。
      static Cursor CROSSHAIR
      十字准线游标类型。
      static Cursor DEFAULT
      默认游标类型（如果未定义游标，则设置）。
      static Cursor DISAPPEAR
      消失的游标类型。
      static Cursor E_RESIZE
      东调整游标类型。
      static Cursor H_RESIZE
      水平光标类型。
      static Cursor HAND
      手指游标类型，类似于指针，通常用于指示可以点击某些内容，例如超链接。
      static Cursor MOVE
      移动光标类型。
      static Cursor N_RESIZE
      北移大小的游标类型。
      static Cursor NE_RESIZE
      东北调整大小的光标类型。
      static Cursor NONE
      无光标类型。
      static Cursor NW_RESIZE
      西北大小的游标类型。
      static Cursor OPEN_HAND
      用手打开的光标
      static Cursor S_RESIZE
      调整大小的光标类型。
      static Cursor SE_RESIZE
      东南大小的光标类型。
      static Cursor SW_RESIZE
      西南大小的光标类型。
      static Cursor TEXT
      文本光标类型。
      static Cursor V_RESIZE
      垂直光标类型。
      static Cursor W_RESIZE
      西调整游标类型。
      static Cursor WAIT
      等待光标类型。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static Cursor cursor​(String identifier)
      返回指定标识符的游标。
      String toString​()
      返回游标的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DEFAULT

        public static final Cursor DEFAULT
        默认游标类型（如果未定义游标，则设置）。

      • CROSSHAIR

        public static final Cursor CROSSHAIR
        十字准线游标类型。

      • TEXT

        public static final Cursor TEXT
        文本光标类型。

      • WAIT

        public static final Cursor WAIT
        等待光标类型。

      • SW_RESIZE

        public static final Cursor SW_RESIZE
        西南大小的光标类型。

      • SE_RESIZE

        public static final Cursor SE_RESIZE
        东南大小的光标类型。

      • NW_RESIZE

        public static final Cursor NW_RESIZE
        西北大小的游标类型。

      • NE_RESIZE

        public static final Cursor NE_RESIZE
        东北调整大小的光标类型。

      • N_RESIZE

        public static final Cursor N_RESIZE
        北移大小的游标类型。

      • S_RESIZE

        public static final Cursor S_RESIZE
        调整大小的光标类型。

      • W_RESIZE

        public static final Cursor W_RESIZE
        西调整游标类型。

      • E_RESIZE

        public static final Cursor E_RESIZE
        东调整游标类型。

      • OPEN_HAND

        public static final Cursor OPEN_HAND
        用手打开的光标

      • CLOSED_HAND

        public static final Cursor CLOSED_HAND
        用手关闭的光标，通常在“抓取”时使用，例如，当平移时。

      • HAND

        public static final Cursor HAND
        手指游标类型，类似于指针，通常用于指示可以点击某些内容，例如超链接。

      • MOVE

        public static final Cursor MOVE
        移动光标类型。

      • DISAPPEAR

        public static final Cursor DISAPPEAR
        消失的游标类型。 这通常在拖动某些东西时使用，以便在用户释放鼠标时，该项目将消失。 在Mac上，当将项目拖出工具栏或其他此类情况时，会使用此选项。

      • H_RESIZE

        public static final Cursor H_RESIZE
        水平光标类型。

      • V_RESIZE

        public static final Cursor V_RESIZE
        垂直光标类型。

      • NONE

        public static final Cursor NONE
        无光标类型。 在不支持自定义游标的平台上，这将与DEFAULT相同。

    • 方法详细信息

      • toString

        public String toString​()
        返回游标的字符串表示形式。
        重写：
        toString Object
        结果
        光标的字符串表示形式。

      • cursor

        public static Cursor cursor​(String identifier)
        返回指定标识符的游标。 标识符可以是某些标准游标的名称或有效的URL字符串。 如果标识符命名为标准游标，则返回相应的游标。 在URL字符串的情况下，该方法返回为该URL创建的新的ImageCursor 。
        参数
        identifier - 游标标识符
        结果
        标识符的光标
        异常
        IllegalArgumentException - 如果游标标识符不是有效的URL字符串或任何标准游标名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DepthTest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Enum DepthTest

  • java.lang.Object
    • java.lang.Enum<DepthTest>
      • javafx.scene.DepthTest
  • All Implemented Interfaces:
    Serializable ， Comparable<DepthTest>

    public enum DepthTest
extends Enum<DepthTest>
    该枚举定义了节点中depthTest标志的可能状态。 请注意，这是一个条件功能。 详见ConditionalFeature.SCENE3D 。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DISABLE
      指定深度测试被禁用。
      ENABLE
      指定深度测试已启用。
      INHERIT
      指定深度测试状态是从父级继承的。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static DepthTest valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DepthTest[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DISABLE

        public static final DepthTest DISABLE
        指定深度测试被禁用。

      • ENABLE

        public static final DepthTest ENABLE
        指定深度测试已启用。

      • INHERIT

        public static final DepthTest INHERIT
        指定深度测试状态是从父级继承的。

    • 方法详细信息

      • values

        public static DepthTest[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (DepthTest c : DepthTest.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static DepthTest valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Group (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class Group

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.Group
  • All Implemented Interfaces:
    Styleable ， EventTarget

    @DefaultProperty("children")
public class Group
extends Parent
    一个Group节点包含一个可观察的子节点列表，每当呈现该节点时，它们按顺序渲染。

    A Group将承担其子女的集体界限，不能直接调整。

    应用于Group任何转换，效果或状态将应用于该组的所有子项。 这种转变和效果不会被纳入本集团的布局范围，但是如果转换和效果直接针对本集团的子女，那么这些转换和效果将被纳入本集团的布局范围。

    默认情况下， Group将在布局过程中将其托管可调整大小的孩子“自动调整”为其首选大小，以确保“区域”和“控件”的状态发生变化。 如果应用程序需要禁用此自动调整大小的行为，那么应将autoSizeChildren设置为false并了解如果孩子的首选大小更改，则不会自动调整大小（因此请注意！）。

    组示例：

      import javafx.scene.*;
import javafx.scene.paint.*;
import javafx.scene.shape.*;
import java.lang.Math;

Group g = new Group();
for (int i = 0; i < 5; i++) {
    Rectangle r = new Rectangle();
    r.setY(i * 20);
    r.setWidth(100);
    r.setHeight(10);
    r.setFill(Color.RED);
    g.getChildren().add(r);
}
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty autoSizeChildren
      控制此 Group是否会在布局过程中自动将任何受管理的可调整大小的儿童调整为其首选大小。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Group​()
      构建一个组。
      Group​(Collection<Node> children)
      构建由给定的孩子组成的组。
      Group​(Node... children)
      构建一个由儿童组成的小组。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanProperty autoSizeChildrenProperty​()
      控制此 Group是否会在布局过程中自动将任何受管理的可调整大小的儿童调整为首选大小。
      ObservableList<Node> getChildren​()
      获取这个 Group的孩子列表。
      boolean isAutoSizeChildren​()
      获取属性autoSizeChildren的值。
      protected void layoutChildren​()
      组实现layoutChildren，以便每个小孩都调整为首选大小，如果小孩可调整大小。
      double minHeight​(double width)
      返回节点在布局计算中使用的最小高度。
      double minWidth​(double height)
      返回节点在布局计算中使用的最小宽度。
      double prefHeight​(double width)
      组定义优选高度只是其布局界限的高度，反过来只是其所有子项的位置和高度的总和。
      double prefWidth​(double height)
      组将首选宽度定义为其布局边界的宽度，而宽度又是其所有子项的位置和宽度之和。
      void setAutoSizeChildren​(boolean value)
      设置属性autoSizeChildren的值。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, maxHeight, maxWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • autoSizeChildren

        public final BooleanProperty autoSizeChildrenProperty
        控制此Group是否会在布局过程中自动将任何受管理的可调整大小的儿童调整为首选大小。 如果设置为false ，则应用程序负责设置此组可调整大小的子项的大小，否则这样的节点可能会以零宽度/高度结尾，并且将不可见。 该变量对不可调整大小的内容节点（Shape，Text等）没有影响。
        Default value:
        真正
        另请参见：
        isAutoSizeChildren() ， setAutoSizeChildren(boolean)

    • 构造方法详细信息

      • Group

        public Group​()
        构建一个组。

      • Group

        public Group​(Node... children)
        构建一个由儿童组成的小组。
        参数
        children - 儿童。

      • Group

        public Group​(Collection<Node> children)
        构建由给定的孩子组成的组。
        参数
        children - 小组的孩子
        异常
        NullPointerException - 如果指定的集合为空
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setAutoSizeChildren

        public final void setAutoSizeChildren​(boolean value)
        设置属性autoSizeChildren的值。
        Property description:
        控制此Group是否会在布局过程中自动将任何受管理的可调整大小的儿童调整为首选大小。 如果设置为false ，则应用程序负责设置此组可调整大小的子项的大小，否则这样的节点可能会以零宽度/高度结尾，并且将不可见。 该变量对不可调整大小的内容节点（Shape，Text等）没有影响。
        Default value:
        真正

      • isAutoSizeChildren

        public final boolean isAutoSizeChildren​()
        获取属性autoSizeChildren的值。
        Property description:
        控制此Group是否会在布局过程中自动将任何受管理的可调整大小的儿童调整为首选大小。 如果设置为false ，则应用程序负责设置此组可调整大小的子项的大小，否则这样的节点可能会以零宽度/高度结尾，并且将不可见。 该变量对不可调整大小的内容节点（Shape，Text等）没有影响。
        Default value:
        真正

      • autoSizeChildrenProperty

        public final BooleanProperty autoSizeChildrenProperty​()
        控制此Group是否会在布局过程中自动将任何受管理的可调整大小的儿童调整为首选大小。 如果设置为false ，则应用程序负责设置此组可调整大小的子项的大小，否则这样的节点可能会以零宽度/高度结尾，并且将不可见。 该变量对不可调整大小的内容节点（Shape，Text等）没有影响。
        Default value:
        真正
        另请参见：
        isAutoSizeChildren() ， setAutoSizeChildren(boolean)

      • getChildren

        public ObservableList<Node> getChildren​()
        获取此 Group的孩子列表。
        重写：
        getChildren在 Parent
        结果
        这个 Group的孩子列表。

      • prefWidth

        public double prefWidth​(double height)
        组将首选宽度定义为其布局边界的宽度，而宽度又是其所有子项的位置和宽度之和。 也就是说，首选宽度是它所在的宽度，因为不能调整组大小。 注意：由于autosize Group中的布局界限取决于要布局的组，所以如果需要，此调用将执行组的布局。
        重写：
        prefWidth在 Parent
        参数
        height - Group忽略此参数
        结果
        布局边界宽度
        另请参见：
        Node.isResizable() ，
Node.getContentBias() ，
Node.autosize()

      • prefHeight

        public double prefHeight​(double width)
        组定义优选高度只是其布局界限的高度，反过来只是其所有子项的位置和高度的总和。 也就是说，首选高度是它所在的高度，因为一个组无法调整大小。 注意：由于autosize Group中的布局界限取决于要布局的组，所以如果需要，此调用将执行组的布局。
        重写：
        prefHeight在 Parent
        参数
        width - Group忽略此参数
        结果
        布局界定高度
        另请参见：
        Node.getContentBias() ， Node.autosize()

      • minHeight

        public double minHeight​(double width)
        描述从类别复制： Node
        返回节点在布局计算中使用的最小高度。 如果节点可调整大小，则父节点不应该将其高度调整为小于该值的大小。 如果节点不可调整大小，返回其layoutBounds高度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有水平的内容偏置，则呼叫者应该传递最小高度应该基于的宽度值。 如果节点具有垂直或空的内容偏置，则调用者应该传入-1。

        具有水平内容偏置的节点子类应该符合宽度参数，不管是-1还是正值。 所有其他子类可以忽略width参数（这可能是-1）。

        如果节点的Node.maxHeight(double)低于此数字，则minHeight优先。 这意味着Node不应该调整大小低于minHeight 。

        重写：
        minHeight在 Parent
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        在布局期间节点应该调整大小的最小高度结果将不会是NaN，也不会是负数。
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • minWidth

        public double minWidth​(double height)
        描述从类别复制： Node
        返回节点在布局计算中使用的最小宽度。 如果节点可调整大小，则其父值不应该调整其小于此值的宽度。 如果节点不可调整，则返回其layoutBounds宽度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有垂直的内容偏置，则呼叫者应该传入最小宽度应该基于的高度值。 如果节点具有水平或空的内容偏置，则调用者应该传入-1。

        具有垂直内容偏置的节点子类应该尊重height参数，不管是-1还是正值。 所有其他子类可以忽略height参数（这可能是-1）。

        如果节点的Node.maxWidth(double)低于此数，则minWidth优先。 这意味着节点不应该被调整到低于minWidth 。

        重写：
        minWidth在 Parent
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        布局期间节点应该调整大小的最小宽度。 结果永远不会是NaN，也不会是负面的。
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • layoutChildren

        protected void layoutChildren​()
        组实现layoutChildren，以便每个小孩都调整为首选大小，如果小孩可调整大小。 不可调整大小的孩子被遗弃。 如果autoSizeChildren为false，则此方法中Group不执行任何操作。
        重写：
        layoutChildren在 Parent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageCursor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class ImageCursor

  • java.lang.Object
    • javafx.scene.Cursor
      • javafx.scene.ImageCursor

  • public class ImageCursor
extends Cursor
    鼠标光标的自定义图像表示。 在不支持自定义游标的平台上，将使用Cursor.DEFAULT代替指定的ImageCursor。

    例：

      import javafx.scene.*;
import javafx.scene.image.*;

Image image = new Image("mycursor.png");

Scene scene = new Scene(400, 300);
scene.setCursor(new ImageCursor(image,
                                image.getWidth() / 2,
                                image.getHeight() /2));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyDoubleProperty hotspotX
      光标热点的X坐标。
      ReadOnlyDoubleProperty hotspotY
      光标热点的Y坐标。
      ReadOnlyObjectProperty<Image> image
      光标激活时显示的图像。

    • Field Summary

      • Fields inherited from class javafx.scene.Cursor

        CLOSED_HAND, CROSSHAIR, DEFAULT, DISAPPEAR, E_RESIZE, H_RESIZE, HAND, MOVE, N_RESIZE, NE_RESIZE, NONE, NW_RESIZE, OPEN_HAND, S_RESIZE, SE_RESIZE, SW_RESIZE, TEXT, V_RESIZE, W_RESIZE, WAIT

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageCursor​()
      构造一个新的空 ImageCursor ，它将看起来像 Cursor.DEFAULT 。
      ImageCursor​(Image image)
      从指定的图像构造一个 ImageCursor 。
      ImageCursor​(Image image, double hotspotX, double hotspotY)
      从指定的图像和热点坐标构造一个 ImageCursor 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static ImageCursor chooseBestCursor​(Image[] images, double hotspotX, double hotspotY)
      从指定的图像之一创建自定义图像光标。
      static Dimension2D getBestSize​(double preferredWidth, double preferredHeight)
      获取最接近指定的首选大小的支持的光标大小。
      double getHotspotX​()
      获取属性hotspotX的值。
      double getHotspotY​()
      获取属性热点的值。
      Image getImage​()
      获取属性映像的值。
      static int getMaximumColors​()
      返回自定义图像光标调色板中支持的最大颜色数。
      ReadOnlyDoubleProperty hotspotXProperty​()
      光标热点的X坐标。
      ReadOnlyDoubleProperty hotspotYProperty​()
      光标热点的Y坐标。
      ReadOnlyObjectProperty<Image> imageProperty​()
      光标激活时显示的图像。

      • Methods inherited from class javafx.scene.Cursor

        cursor, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • image

        public final ReadOnlyObjectProperty<Image> imageProperty
        光标激活时显示的图像。 如果图像为空，将使用Cursor.DEFAULT 。
        Default value:
        空值
        另请参见：
        getImage()

      • hotspotX

        public final ReadOnlyDoubleProperty hotspotXProperty
        光标热点的X坐标。 该热点表示将在鼠标位置显示的光标图像内的位置。 这必须在[0，image.width-1]的范围内。 小于0的值将设置为0.将大于image.width-1的值设置为image.width-1。
        Default value:
        0
        另请参见：
        getHotspotX()

      • hotspotY

        public final ReadOnlyDoubleProperty hotspotYProperty
        光标热点的Y坐标。 该热点表示将在鼠标位置显示的光标图像内的位置。 这必须在[0，image.height-1]的范围内。 小于0的值将设置为0.将大于image.height-1的值设置为image.height-1。
        Default value:
        0
        另请参见：
        getHotspotY()

    • 构造方法详细信息

      • ImageCursor

        public ImageCursor​()
        构造一个新的空 ImageCursor ，它将看起来像 Cursor.DEFAULT 。

      • ImageCursor

        public ImageCursor​(Image image)
        从指定的图像构造一个ImageCursor 。 光标的热点将默认为左上角。
        参数
        image - 图像

      • ImageCursor

        public ImageCursor​(Image image,
                   double hotspotX,
                   double hotspotY)
        从指定的图像和热点坐标构造一个 ImageCursor 。
        参数
        image - 图像
        hotspotX - 光标热点的X坐标
        hotspotY - 光标热点的Y坐标

    • 方法详细信息

      • getImage

        public final Image getImage​()
        获取属性映像的值。
        Property description:
        光标激活时显示的图像。 如果图像为空，将使用Cursor.DEFAULT 。
        Default value:
        空值

      • imageProperty

        public final ReadOnlyObjectProperty<Image> imageProperty​()
        光标激活时显示的图像。 如果图像为空，将使用Cursor.DEFAULT 。
        Default value:
        空值
        另请参见：
        getImage()

      • getHotspotX

        public final double getHotspotX​()
        获取属性hotspotX的值。
        Property description:
        光标热点的X坐标。 该热点表示将在鼠标位置显示的光标图像内的位置。 这必须在[0，image.width-1]的范围内。 小于0的值将设置为0.将大于image.width-1的值设置为image.width-1。
        Default value:
        0

      • hotspotXProperty

        public final ReadOnlyDoubleProperty hotspotXProperty​()
        光标热点的X坐标。 该热点表示将在鼠标位置显示的光标图像内的位置。 这必须在[0，image.width-1]的范围内。 小于0的值将设置为0.将大于image.width-1的值设置为image.width-1。
        Default value:
        0
        另请参见：
        getHotspotX()

      • getHotspotY

        public final double getHotspotY​()
        获取属性热点的值。
        Property description:
        光标热点的Y坐标。 该热点表示将在鼠标位置显示的光标图像内的位置。 这必须在[0，image.height-1]的范围内。 小于0的值将设置为0.将大于image.height-1的值设置为image.height-1。
        Default value:
        0

      • hotspotYProperty

        public final ReadOnlyDoubleProperty hotspotYProperty​()
        光标热点的Y坐标。 该热点表示将在鼠标位置显示的光标图像内的位置。 这必须在[0，image.height-1]的范围内。 小于0的值将设置为0.将大于image.height-1的值设置为image.height-1。
        Default value:
        0
        另请参见：
        getHotspotY()

      • getBestSize

        public static Dimension2D getBestSize​(double preferredWidth,
                                      double preferredHeight)
        获取最接近指定的首选大小的支持的光标大小。 如果平台不支持自定义游标，则返回值（0,0）。

        注意：如果使用其尺寸与支持的大小不一致的图像（由此方法返回），则实施将将图像的大小调整为受支持的大小。 这可能会导致质量下降。

        注意：这些值可能因操作系统，显卡和屏幕分辨率而异，但在撰写本文时，一个示例的Windows Vista计算机返回32x32所有请求的大小，而示例Mac和Linux机器返回请求的大小最大的64x64。 应用程序应提供一个32x32游标，这将在所有平台上运行良好，并且可能希望为支持该平台的平台提供64x64游标。

        参数
        preferredWidth - 光标的首选宽度
        preferredHeight - 光标的首选高度
        结果
        支持的光标大小

      • getMaximumColors

        public static int getMaximumColors​()
        返回自定义图像光标调色板中支持的最大颜色数。

        注意：如果使用的图像在其调色板中具有比支持的最大值更多的颜色，则实施将尝试将调色板最大化。 这可能会导致质量下降。

        注意：这些值可能因操作系统，显卡和屏幕分辨率而异，但在撰写本文时，一个示例的Windows Vista计算机返回256，一个示例Mac机器返回Integer.MAX_VALUE，表示支持全色光标，以及示例Linux机器返回2.应用程序可能希望将这三个颜色深度定位到每个平台上的最佳光标。

        结果
        自定义图像光标调色板中支持的最大颜色数

      • chooseBestCursor

        public static ImageCursor chooseBestCursor​(Image[] images,
                                           double hotspotX,
                                           double hotspotY)
        从指定的图像之一创建自定义图像光标。 此功能将选择最大尺寸与最佳光标大小匹配的图像。 通过selectedImage.width / images [0] .width来缩放返回的ImageCursor的hotpotX，并通过selectedImage.height / images [0] .height缩放热点。

        在不支持自定义游标的平台上，将使用Cursor.DEFAULT代替返回的ImageCursor。

        参数
        images - 以优先顺序从中选择的图像序列
        hotspotX - 图像序列中第一个图像内热点的X坐标
        hotspotY - 图像序列中第一个图像内热点的Y坐标
        结果
        从最好的图像创建的光标
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene (Java SE 9 & JDK 9 )

javafx.scene

Classes

  • AmbientLight
  • Camera
  • Cursor
  • Group
  • ImageCursor
  • LightBase
  • Node
  • ParallelCamera
  • Parent
  • PerspectiveCamera
  • PointLight
  • Scene
  • SceneAntialiasing
  • SnapshotParameters
  • SnapshotResult
  • SubScene

Enums

  • AccessibleAction
  • AccessibleAttribute
  • AccessibleRole
  • CacheHint
  • DepthTest


javafx.scene (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene

为JavaFX Scene Graph API提供核心的基类集。 场景图是一个树形数据结构，其中树中的每个项目都有零个或一个父项和零个或多个子节点。

这个包中的两个主要类别是：

  • Scene “定义要呈现的场景。 它包含一个fill变量，指定场景，背景width和height变量指定场景的大小，和一个content包含的“根”的列表序列Nodes将被渲染到场景上。 Nodes这个序列是这个Scene的场景图。 A Scene呈现在Stage上 ，它是JavaFX内容的顶级容器。
  • Node -场景图中所有节点的抽象基类。 每个节点是没有子节点的“叶”节点或具有零个或多个子节点的“分支”节点。 树中的每个节点都有零个或一个父节点。 场景图中每个树中只有一个节点将没有父节点，这通常被称为“根”节点。 场景图中可能有几棵树。 一些树可能是Scene的一部分，在这种情况下，它们有资格被显示。 其他树木可能不属于任何Scene的一部分。

分支节点类型为Parent或其子类。

叶节点是类如Rectangle ， Text ， ImageView ， MediaView ，或不能生育其它这种叶类。

场景图中的任何地方最多可能出现节点。 具体而言，节点必须出现不超过一次在子女名单Parent或作为的剪辑Node 。 有关这些限制的更多细节，请参阅Node课程。

例

JavaFX场景图的示例如下所示：

  package example;

import javafx.application.Application;
import javafx.stage.Stage;
import javafx.scene.Scene;
import javafx.scene.Group;
import javafx.scene.paint.Color;
import javafx.scene.shape.Circle;
import javafx.scene.text.Text;
import javafx.scene.text.Font;

public class Example extends Application {

    @Override public void start(Stage stage) {

        Group root = new Group();
        Scene scene = new Scene(root, 200, 150);
        scene.setFill(Color.LIGHTGRAY);

        Circle circle = new Circle(60, 40, 30, Color.GREEN);

        Text text = new Text(10, 90, "JavaFX Scene");
        text.setFill(Color.DARKRED);

        Font font = new Font(20);
        text.setFont(font);

        root.getChildren().add(circle);
        root.getChildren().add(text);
        stage.setScene(scene);
        stage.show();
    }

    public static void main(String[] args) {
        Application.launch(args);
    }
}

以上示例将生成以下图像：

坐标系和转换

Node类定义了传统的计算机图形“局部”坐标系，其中x轴向右增加， y轴向下增加。 形状的具体节点类提供了用于定义该局部坐标空间内形状和位置的变量。 例如， Rectangle提供x ， y ， width ， height变量而Circle提供centerX ， centerY ，和radius 。

任何Node都可以对其进行转换。 这些包括平移，旋转，缩放或剪切变换。 转换将改变坐标系的位置，方向或大小，从已经被转换的节点的父节点看。

有关转换的更多信息，请参阅Node类。

边界矩形

由于每个Node都有变换，所以每个节点的几何边界矩形可以根据转换是否被考虑而不同地描述。

每个Node具有以下属性，指定这些边界矩形：

  • boundsInLocal “指定未转换的局部坐标中的Node的边界。
  • boundsInParent “指定了所有转换之后的Node的边界。 它被称为“boundsInParent”，因为矩形将相对于父协调系统。
  • layoutBounds “指定应用作布局计算基础的Node的矩形边界，并且可能与节点的可视边界不同。 对于shape，Text和ImageView，默认的layoutBounds仅包括形状几何。

有关边界矩形的更多信息，请参阅Node类。

CSS

JavaFX Scene Graph提供了使用CSS（级联样式表）对节点进行风格化的功能。 该Node类包含id ， styleClass ，并style变量由CSS选择器用于查找样式应该应用节点。 Scene类包含stylesheets变量，它是引用要应用于该场景中的节点的CSS样式表的URL序列。

有关CSS的更多信息，如何将CSS样式应用于节点，以及可用于样式的属性，请参阅CSS Reference Guide 。

  • 类摘要
    Class 描述
    AmbientLight
    定义环境光源对象。
    Camera
    用于渲染场景的相机的基类。
    Cursor
    封装鼠标光标位图表示的类。
    Group
    一个 Group节点包含一个可观察列表的子节点，每当该节点呈现时，它们按顺序渲染。
    ImageCursor
    鼠标光标的自定义图像表示。
    LightBase
    LightBase类提供了代表光源形式的对象的常用属性的定义。
    Node
    场景图节点的基类。
    ParallelCamera
    指定用于渲染场景而不进行透视校正的并行相机。
    Parent
    在场景图中有子节点的所有节点的基类。
    PerspectiveCamera
    指定用于渲染场景的透视相机。
    PointLight
    定义点光源对象。
    Scene
    JavaFX Scene类是场景图中所有内容的容器。
    SceneAntialiasing
    JavaFX SceneAntialiasing类指定所需的抗锯齿级别。
    SnapshotParameters
    用于指定节点快照的渲染属性的参数。
    SnapshotResult
    此类保存快照操作的结果。
    SubScene
    SubScene类是场景图中内容的容器。
  • 枚举摘要
    Enum 描述
    AccessibleAction
    该枚举描述了屏幕阅读器等辅助技术可以从场景图中请求的动作。
    AccessibleAttribute
    该枚举描述了诸如屏幕阅读器之类的辅助技术可以从场景图中请求的属性。
    AccessibleRole
    这个枚举描述了一个Node的可访问角色。
    CacheHint
    缓存提示与 Node.cacheHint一起使用
    DepthTest
    该枚举定义了节点中depthTest标志的可能状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.Cursor
      • javafx.scene.ImageCursor
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.Camera
        • javafx.scene.ParallelCamera
        • javafx.scene.PerspectiveCamera
      • javafx.scene.LightBase
        • javafx.scene.AmbientLight
        • javafx.scene.PointLight
      • javafx.scene.Parent
        • javafx.scene.Group
      • javafx.scene.SubScene
    • javafx.scene.Scene (implements javafx.event.EventTarget)
    • javafx.scene.SceneAntialiasing
    • javafx.scene.SnapshotParameters
    • javafx.scene.SnapshotResult

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.AccessibleAction
      • javafx.scene.AccessibleAttribute
      • javafx.scene.AccessibleRole
      • javafx.scene.CacheHint
      • javafx.scene.DepthTest
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LightBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class LightBase

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.LightBase
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    AmbientLight ， PointLight

    public abstract class LightBase
extends Node
    LightBase类为表示光源形式的对象提供了常用属性的定义。 这些属性包括：
    • 定义光源颜色的颜色。
    请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

    应用程序不应该直接扩展LightBase类。 否则可能导致抛出UnsupportedOperationException异常。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Color> color
      指定光源的颜色。
      BooleanProperty lightOn
      定义灯亮或熄灭。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected LightBase​()
      使用默认的Color.WHITE光源创建一个 LightBase类的新实例。
      protected LightBase​(Color color)
      使用指定的颜色创建一个 LightBase类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Color> colorProperty​()
      指定光源的颜色。
      Color getColor​()
      获取属性颜色的值。
      ObservableList<Node> getScope​()
      获取指定此Light的分层范围的节点列表。
      boolean isLightOn​()
      获取属性lightOn的值。
      BooleanProperty lightOnProperty​()
      定义灯亮或熄灭。
      void setColor​(Color value)
      设置属性颜色的值。
      void setLightOn​(boolean value)
      设置属性lightOn的值。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • color

        public final ObjectProperty<Color> colorProperty
        指定光源的颜色。
        Default value:
        空值
        另请参见：
        getColor() ， setColor(Color)

      • lightOn

        public final BooleanProperty lightOnProperty
        定义灯亮或熄灭。
        Default value:
        真正
        另请参见：
        isLightOn() ， setLightOn(boolean)

    • 构造方法详细信息

      • LightBase

        protected LightBase​()
        使用默认的Color.WHITE光源创建一个 LightBase类的新实例。

      • LightBase

        protected LightBase​(Color color)
        使用指定的颜色创建一个 LightBase类的新实例。
        参数
        color - 光源的颜色

    • 方法详细信息

      • setColor

        public final void setColor​(Color value)
        设置属性颜色的值。
        Property description:
        指定光源的颜色。
        Default value:
        空值

      • getColor

        public final Color getColor​()
        获取属性颜色的值。
        Property description:
        指定光源的颜色。
        Default value:
        空值

      • colorProperty

        public final ObjectProperty<Color> colorProperty​()
        指定光源的颜色。
        Default value:
        空值
        另请参见：
        getColor() ， setColor(Color)

      • setLightOn

        public final void setLightOn​(boolean value)
        设置属性lightOn的值。
        Property description:
        定义灯亮或熄灭。
        Default value:
        真正

      • isLightOn

        public final boolean isLightOn​()
        获取属性lightOn的值。
        Property description:
        定义灯亮或熄灭。
        Default value:
        真正

      • lightOnProperty

        public final BooleanProperty lightOnProperty​()
        定义灯亮或熄灭。
        Default value:
        真正
        另请参见：
        isLightOn() ， setLightOn(boolean)

      • getScope

        public ObservableList<Node> getScope​()
        获取指定此Light的分层范围的节点列表。 如果范围列表为空，则Light节点具有Universe范围：其场景下的所有节点都受其影响。 如果范围列表不为空，则范围列表中的3D Shape节点和作用域列表中的Group节点下的那些3D Shape节点将受到此Light节点的影响。
        结果
        指定此Light的分层范围的节点列表
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Node (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class Node

  • java.lang.Object
    • javafx.scene.Node
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    Camera ， Canvas ， ImageView ， LightBase ， MediaView ， Parent ， Shape ， Shape3D ， SubScene ， SwingNode

    @IDProperty("id")
public abstract class Node
extends Object
implements EventTarget, Styleable
    场景图节点的基类。 场景图是一组树数据结构，其中每个项目具有零个或一个父项，并且每个项目是具有零子项的“叶”或具有零个或多个子项的“分支”。

    场景图中的每个项目称为Node 。 分支节点类型的Parent ，其具体的子类是Group ， Region ，和Control ，或它们的亚类。

    叶节点是类如Rectangle ， Text ， ImageView ， MediaView ，或不能生育其它这种叶类。 每个场景图树中只有一个节点将没有父节点，这被称为“根”节点。

    场景图中可能有几棵树。 一些树木可能是Scene的一部分，在这种情况下，它们有资格被展示。 其他树木可能不属于任何Scene的一部分。

    场景图中的任何地方最多可能出现节点。 具体而言，节点必须出现不超过一次在所有以下的：作为的根节点Scene ，一个的儿童ObservableList Parent ，或作为的夹子Node 。

    场景图不能有循环。 如果节点是树中的自身的祖先，则考虑到上述的Group内容ObservableList， Parent children ObservableList和Node剪辑关系，将存在一个循环。

    如果程序将一个子节点添加到父（包括组，区域等），并且该节点已经是不同父级或场景根的子节点，则该节点将自动（并且默认地）从其以前的父项中删除。 如果程序尝试以违反上述规则的任何其他方式修改场景图，则会抛出异常，修改尝试被忽略，场景图恢复到之前的状态。

    可以重新排列场景图的结构，例如，将子树从场景图中的一个位置移动到另一个。 为了做到这一点，通常在将子树插入新位置之前，将其从旧位置移除。 但是，如果应用程序没有明确地删除它，子树将如上所述自动删除。

    节点对象可以在任何线程上构造和修改，只要它们尚未附加到Window中的Window ，即showing 。 应用程序必须将节点附加到这样的场景或在JavaFX应用程序线程上进行修改。

    JavaFX应用程序线程是作为JavaFX运行时启动过程的一部分而创建的。 有关更多信息，请参阅Application类和Platform.startup(Runnable)方法。

    应用程序不应直接扩展Node类。 否则可能导致抛出UnsupportedOperationException异常。

    字符串ID

    场景图中的每个节点都可以给出一个独特的id 。 这个id就像HTML标签的“id”属性一样，由设计师和开发者来确保id在场景图中是唯一的。 可以使用一个名为lookup(String)的方便函数来查找场景图中具有唯一ID的节点，或场景图的子树。 id也可以用于标识节点应用样式; 请参阅下面的CSS部分。

    坐标系

    Node类定义了传统的计算机图形“局部”坐标系，其中x轴向右增加，而y轴向下增加。 形状的具体节点类提供了用于定义该局部坐标空间内形状和位置的变量。 例如， Rectangle提供x ， y ， width ， height变量而Circle提供centerX ， centerY ，和radius 。

    在设备像素级别，整数坐标映射到角上，像素之间的裂纹和像素的中心之间出现在整数像素位置之间的中点处。 因为所有坐标值都用浮点数指定，所以坐标可以精确地指向这些角（浮点值具有精确的整数值）或像素上的任何位置。 例如， (0.5, 0.5)的坐标将指向(0.5, 0.5)上左上角像素的Stage 。 类似地，在一个矩形(0, 0)与尺寸10通过10将从上左上像素的左上角跨越Stage到10号的扫描线的第10像素的右下角。 该矩形内的最后一个像素的像素中心将在坐标(9.5, 9.5) 。

    实际上，如下所述，大多数节点具有应用于其坐标系的变换。 结果，上述描述设备坐标对像素网格的对准的信息是相对于变换的坐标，而不是节点的局部坐标。 Shape类描述了有关坐标映射的一些其他重要的上下文相关信息，以及它如何影响渲染。

    转换

    任何Node都可以对其进行转换。 这些包括翻译，旋转，缩放或剪切。

    平移变换是沿x或y轴移动节点坐标空间的原点的变换。 例如，如果创建一个Rectangle ，它在原点（x = 0，y = 0）绘制，宽度为100，高度为50，然后应用沿着x轴移动10的Translate （ x = 10），则矩形将出现在（x = 10，y = 0）处绘制，并保持100点宽和50高。 请注意，原点已移动，而不是矩形的x变量。

    公共节点变换是整数距离的平移，最常用于在舞台上布置节点。 这样的整数翻译保持设备像素映射，使得整数的局部坐标仍然映射到像素之间的裂缝。

    旋转变换是围绕指定“枢轴”点旋转节点的坐标空间的转换，导致节点出现旋转。 例如，如果创建一个Rectangle其在原点绘制（X = 0，Y = 0）和具有100和30高度的宽度和在应用一个Rotate具有90度旋转（角度= 90）和一个在原点枢轴（pivotX = 0，pivotY = 0），则矩形将被绘制为其x和y为零，但其高度为100，宽度为-30。 也就是说，就好像一个针被卡在左上角，并且矩形围绕该针顺时针旋转90度。 如果将枢轴点放置在矩形的中心（在x = 50，y = 15），则矩形将以其中心为中心旋转。

    请注意，与所有变换一样，矩形的x，y，width和height变量（相对于局部坐标空间保留）没有改变，而是转换改变矩形的整个坐标空间。

    缩放变换导致节点根据缩放因子看起来更大或更小。 缩放改变节点的坐标空间，使得沿着本地坐标轴的距离的每个单位乘以比例因子。 与旋转变换一样，对“枢轴”点应用缩放变换。 您可以将其视为节点周围的“缩放”点。 例如，如果创建Rectangle与strokeWidth 5，宽度和高度的50，和在应用一个Scale在原点（pivotX = 0的比例因子（X = 2.0，Y = 2.0）和枢转， pivotY = 0），整个矩形（包括笔触）的大小将翻倍，从原点向右和向下生长。

    有时称为偏斜的剪切变换有效地旋转一个轴，使得x和y轴不再垂直。

    可以通过指定转换的有序链来将多个变换应用于节点。 变换的应用顺序由transforms变量中指定的ObservableList定义。

    边界矩形

    由于每个Node都有转换，所以每个节点的几何边界矩形可以根据转换是否被考虑而不同地进行描述。

    每个Node都有一个只读的boundsInLocal变量，它指定未转换的局部坐标中的Node的边界矩形。 boundsInLocal包括节点的形状几何，包括可能落在局部位置/大小变量之外的非零行程所需的任何空间及其clip和effect变量。

    每个Node还具有只读boundsInParent变量，用于指定所述的外接矩形Node已应用，包括那些在设置的所有的变换后transforms ， 二百七十○万七千一百五十五亿四千七百四十一万零七百八十四 / 二百七万七千一百五十五亿四千七百四十二万二千二百三十二 ， rotate ， 二百七万七千一百五十五亿四千七百八十六万九千八百八十七 / 二百七十○万七千一百五十五亿四千七百八十八万七千六百五十二 ，和二七�銎咭晃逦逅钠甙司啪虐税司� / 二百七十○万七千一百五十五亿四千七百九十一万零九百四十二 。 它被称为“boundsInParent”，因为矩形将相对于父协调系统。 这是节点的'视觉'边界。

    最后， layoutBounds变量定义了应该用作布局计算基础的Node的矩形边界，并且可能与节点的可视边界不同。 对于形状，文本和ImageView的，默认情况下layoutBounds中仅包括几何形状，其中包括一个非零所需的空间strokeWidth ，但不包括的效果，夹子，或任何变换。 对于可调整大小的类（区域和控件），layoutBounds将始终映射到0,0 width x height 。

    该图像显示一个没有任何转换的节点，它的boundsInLocal ：

    如果我们将图像旋转20度，我们得到以下结果：

    红色矩形在节点的父节点的坐标空间中表示boundsInParent 。 boundsInLocal与第一张图像保持一致，此图像中的绿色矩形表示节点坐标空间中的boundsInLocal 。

    图像显示一个填充和抚摸的矩形及其边界。 第一个矩形[x:10.0 y:10.0 width:100.0 height:100.0 strokeWidth:0]具有以下界限： [x:10.0 y:10.0 width:100.0 height:100.0] 。 第二个矩形[x:10.0 y:10.0 width:100.0 height:100.0 strokeWidth:5]具有以下界限： [x:7.5 y:7.5 width:105 height:105] （笔画以默认为中心，因此只有一半在原始界限之外;也可以创建内部或外部笔画）。 由于两个矩形都不应用任何变换， boundsInParent和boundsInLocal都是相同的。

    CSS

    该Node类包含id ， styleClass ，并style了在造型从CSS这个节点使用的变量。 在CSS样式表中使用id和styleClass变量来标识应用哪些样式的节点。 style变量包含直接应用于此节点的样式属性和值。

    有关CSS的更多信息以及如何将CSS样式应用于节点，请参阅CSS Reference Guide 。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<String> accessibleHelp
      该 Node帮助文本。
      ObjectProperty<String> accessibleRoleDescription
      这个角色描述 Node 。
      ObjectProperty<AccessibleRole> accessibleRole
      这个可访问角色为 Node 。
      ObjectProperty<String> accessibleText
      这个 Node的可访问文本。
      ObjectProperty<BlendMode> blendMode
      BlendMode用于将此单个节点混合到其后面的场景中。
      ReadOnlyObjectProperty<Bounds> boundsInLocal
      该 Node的矩形边界在节点未转换的局部坐标空间中。
      ReadOnlyObjectProperty<Bounds> boundsInParent
      这个 Node的矩形边界包括它的变换。
      ObjectProperty<CacheHint> cacheHint
      控制位图缓存的其他提示。
      BooleanProperty cache
      系统的性能提示表明这个 Node应该被缓存为一个位图。
      ObjectProperty<Node> clip
      指定一个 Node用于定义此节点的剪切形状。
      ObjectProperty<Cursor> cursor
      为此 Node和子节点定义鼠标光标。
      ObjectProperty<DepthTest> depthTest
      指示在渲染此节点时是否使用深度测试。
      ReadOnlyBooleanProperty disabled
      指示此 Node是否被禁用。
      BooleanProperty disable
      定义此 Node的个人禁用状态。
      ReadOnlyObjectProperty<NodeOrientation> effectiveNodeOrientation
      节点的有效方向解决节点方向的继承，从左到右或从右到左返回。
      ObjectProperty<Effect> effect
      指定应用于此 Node的效果。
      ObjectProperty<EventDispatcher> eventDispatcher
      指定此节点的事件分派器。
      ReadOnlyBooleanProperty focused
      指示此 Node当前是否具有输入焦点。
      BooleanProperty focusTraversable
      指定此 Node是否应该是焦点遍历周期的一部分。
      ReadOnlyBooleanProperty hover
      这个 Node是否被徘徊。
      StringProperty id
      该 Node为 Node 。
      ObjectProperty<InputMethodRequests> inputMethodRequests
      属性保存InputMethodRequests。
      ReadOnlyObjectProperty<Bounds> layoutBounds
      应该用于此节点的布局计算的矩形边界。
      DoubleProperty layoutX
      定义为了布局目的而添加到此 Node的变换中的翻译的x坐标。
      DoubleProperty layoutY
      定义添加到此 Node的转换中用于布局目的的转换的y坐标。
      ReadOnlyObjectProperty<Transform> localToParentTransform
      保存计算的本地到父变换的仿射变换。
      ReadOnlyObjectProperty<Transform> localToSceneTransform
      拥有计算的局部到场景变换的仿射变换。
      BooleanProperty managed
      定义该节点的布局是否由父节点管理。
      BooleanProperty mouseTransparent
      如果是 true ，这个节点（和它所有的孩子一起）对鼠标事件是完全透明的。
      ObjectProperty<NodeOrientation> nodeOrientation
      属性保存NodeOrientation。
      ObjectProperty<EventHandler<? super ContextMenuEvent>> onContextMenuRequested
      定义在 Node上请求上下文菜单时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onDragDetected
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragDone
      当这个 Node是一个拖放手势源，它的数据被放在放置目标上之后，定义要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> onDragDropped
      定义在拖放手势时，在此 Node上释放鼠标按钮时调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragEntered
      定义当拖动手势进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragExited
      定义当拖动手势退出 Node时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> onDragOver
      定义在 Node拖动手势进度时要调用的功能。
      ObjectProperty<EventHandler<? super InputMethodEvent>> onInputMethodTextChanged
      定义当这个 Node具有输入焦点并且输入法文本已更改时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyPressed
      定义当这个 Node或其子代 Node具有输入焦点并按下一个键时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyReleased
      定义当这个 Node或其子代 Node具有输入焦点并且键已被释放时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyTyped
      定义当这个 Node或其子代 Node具有输入焦点并键入了一个键时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseClicked
      定义当在此 Node上单击（按下并释放）鼠标按钮时调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragEntered
      定义当完全按下 - 拖动释放手势进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragExited
      定义当完全按下 - 拖动释放手势离开这个 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseDragged
      定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragOver
      定义当这个 Node内完全按下 - 拖动释放手势时，要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragReleased
      定义当完全按下 - 拖动释放手势结束（通过释放鼠标按钮）在该 Node内时 Node 。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseEntered
      定义当鼠标进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseExited
      定义当鼠标退出 Node时调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseMoved
      定义当鼠标光标在此 Node内移动但没有按钮被按下时调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMousePressed
      定义当这个 Node上按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseReleased
      定义在 Node上释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotate
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotationFinished
      定义旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotationStarted
      定义检测到旋转手势时要调用的功能。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollFinished
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScroll
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollStarted
      定义检测到滚动手势时要调用的函数。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeDown
      定义当在该节点上居中的向下滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeLeft
      定义当以该节点为中心的向左滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeRight
      定义当以该节点为中心的向右滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeUp
      定义当在该节点上居中的向上滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchMoved
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchPressed
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchReleased
      定义触发点释放时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchStationary
      定义当触摸点保持按下并静止时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomFinished
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoom
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomStarted
      定义检测到缩放手势时要调用的功能。
      DoubleProperty opacity
      指定 Node不透明（即固体）。
      ReadOnlyObjectProperty<Parent> parent
      这是 Node的父母。
      BooleanProperty pickOnBounds
      定义当由 MouseEvent或 contains函数调用触发时，如何为此节点完成拣选计算。
      ReadOnlyBooleanProperty pressed
      是否按下 Node 。
      DoubleProperty rotate
      定义关于 Node中心的旋转角度，以度为单位。
      ObjectProperty<Point3D> rotationAxis
      定义 Node的旋转轴。
      DoubleProperty scaleX
      定义坐标按照该 Node的X轴的对象中心进行缩放的因子。
      DoubleProperty scaleY
      定义坐标按照该 Node的Y轴的对象中心进行缩放的因子。
      DoubleProperty scaleZ
      定义坐标按照该 Node的Z轴的对象中心进行缩放的因子。
      ReadOnlyObjectProperty<Scene> scene
      Scene这是Node的一部分。
      StringProperty style
      与此特定 Node相关联的CSS样式的字符串表示 Node 。
      DoubleProperty translateX
      定义添加到此 Node的转换中的转换的x坐标。
      DoubleProperty translateY
      定义添加到此 Node的转换中的转换的y坐标。
      DoubleProperty translateZ
      定义添加到此 Node的变换坐标的平移的Z坐标。
      DoubleProperty viewOrder
      定义其父母中的 Node的呈现和拣选顺序。
      BooleanProperty visible
      指定此 Node和任何子节点是否应呈现为场景图的一部分。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double BASELINE_OFFSET_SAME_AS_HEIGHT
      这是 getBaselineOffset()可能返回的特殊值。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Node​()
      创建一个新的Node实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<String> accessibleHelpProperty​()
      该 Node的可访问帮助文本。
      ObjectProperty<String> accessibleRoleDescriptionProperty​()
      这个角色描述 Node 。
      ObjectProperty<AccessibleRole> accessibleRoleProperty​()
      这个 Node的可访问角色。
      ObjectProperty<String> accessibleTextProperty​()
      该 Node的可访问文本。
      <T extends Event>
      void             		addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      向此节点注册事件过滤器。
      <T extends Event>
      void             		addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      向此节点注册事件处理程序。
      void applyCss​()
      如果需要，将样式应用于此节点及其子节点（如果有）。
      void autosize​()
      如果节点可调整大小，则将其布局边界设置为当前优选的宽度和高度。
      ObjectProperty<BlendMode> blendModeProperty​()
      BlendMode用于将此单个节点混合到其后面的场景中。
      ReadOnlyObjectProperty<Bounds> boundsInLocalProperty​()
      该节点未转换的局部坐标空间中的 Node的矩形边界。
      ReadOnlyObjectProperty<Bounds> boundsInParentProperty​()
      这个 Node的矩形边界包括它的变换。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此节点构造事件调度链。
      ObjectProperty<CacheHint> cacheHintProperty​()
      控制位图缓存的其他提示。
      BooleanProperty cacheProperty​()
      系统的性能提示表明，这个 Node应该被缓存为一个位图。
      ObjectProperty<Node> clipProperty​()
      指定一个 Node用于定义此节点的剪切形状。
      double computeAreaInScreen​()
      以像素为单位返回投影到物理屏幕上的 Node的区域。
      boolean contains​(double localX, double localY)
      返回 true如果给定的点（指定在局部坐标的此空间 Node ）包含在此的形状内 Node 。
      boolean contains​(Point2D localPoint)
      返回 true如果给定的点（指定在局部坐标的此空间 Node ）包含在此的形状内 Node 。
      ObjectProperty<Cursor> cursorProperty​()
      为此 Node和子节点定义鼠标光标。
      ObjectProperty<DepthTest> depthTestProperty​()
      指示在渲染此节点时是否使用深度测试。
      ReadOnlyBooleanProperty disabledProperty​()
      指示此 Node是否被禁用。
      BooleanProperty disableProperty​()
      定义此 Node的个人禁用状态。
      ReadOnlyObjectProperty<NodeOrientation> effectiveNodeOrientationProperty​()
      节点的有效方向解决节点方向的继承，从左到右或从右到左返回。
      ObjectProperty<Effect> effectProperty​()
      指定应用于此 Node的效果。
      ObjectProperty<EventDispatcher> eventDispatcherProperty​()
      指定此节点的事件分派器。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void fireEvent​(Event event)
      触发指定的事件。
      ReadOnlyBooleanProperty focusedProperty​()
      指示此 Node当前是否具有输入焦点。
      BooleanProperty focusTraversableProperty​()
      指定此 Node应该是聚焦遍历周期的一部分。
      String getAccessibleHelp​()
      获取属性accessibleHelp的值。
      AccessibleRole getAccessibleRole​()
      获取属性accessibilityRole的值。
      String getAccessibleRoleDescription​()
      获取属性accessibilityRoleDescription的值。
      String getAccessibleText​()
      获取属性accessibleText的值。
      double getBaselineOffset​()
      当基于与其他节点垂直对齐的节点的layoutBounds.minY位置时，“字母”（或“罗马”）基线偏移。
      BlendMode getBlendMode​()
      获取属性blendMode的值。
      Bounds getBoundsInLocal​()
      获取属性boundsInLocal的值。
      Bounds getBoundsInParent​()
      获取属性boundsInParent的值。
      CacheHint getCacheHint​()
      获取属性cacheHint的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Node getClip​()
      获取属性剪辑的值。
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      Cursor getCursor​()
      获取属性游标的值。
      DepthTest getDepthTest​()
      获取属性depthTest的值。
      Effect getEffect​()
      获取属性效果的值。
      NodeOrientation getEffectiveNodeOrientation​()
      获取属性effectiveNodeOrientation的值。
      EventDispatcher getEventDispatcher​()
      获取属性eventDispatcher的值。
      String getId​()
      这个id的这个 Node 。
      protected Cursor getInitialCursor​()
      返回此节点的初始游标状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean getInitialFocusTraversable​()
      返回此节点的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      InputMethodRequests getInputMethodRequests​()
      获取属性inputMethodRequests的值。
      Bounds getLayoutBounds​()
      获取属性layoutBounds的值。
      double getLayoutX​()
      获取属性layoutX的值。
      double getLayoutY​()
      获取属性layoutY的值。
      Transform getLocalToParentTransform​()
      获取属性localToParentTransform的值。
      Transform getLocalToSceneTransform​()
      获取属性localToSceneTransform的值。
      NodeOrientation getNodeOrientation​()
      获取属性nodeOrientation的值。
      EventHandler<? super ContextMenuEvent> getOnContextMenuRequested​()
      获取属性onContextMenuRequested的值。
      EventHandler<? super MouseEvent> getOnDragDetected​()
      获取属性onDragDetected的值。
      EventHandler<? super DragEvent> getOnDragDone​()
      获取属性onDragDone的值。
      EventHandler<? super DragEvent> getOnDragDropped​()
      获取属性onDragDropped的值。
      EventHandler<? super DragEvent> getOnDragEntered​()
      获取属性onDragEntered的值。
      EventHandler<? super DragEvent> getOnDragExited​()
      获取属性onDragExited的值。
      EventHandler<? super DragEvent> getOnDragOver​()
      获取属性onDragOver的值。
      EventHandler<? super InputMethodEvent> getOnInputMethodTextChanged​()
      获取onInputMethodTextChanged属性的值。
      EventHandler<? super KeyEvent> getOnKeyPressed​()
      获取属性onKeyPressed的值。
      EventHandler<? super KeyEvent> getOnKeyReleased​()
      获取属性onKeyReleased的值。
      EventHandler<? super KeyEvent> getOnKeyTyped​()
      获取属性onKeyTyped的值。
      EventHandler<? super MouseEvent> getOnMouseClicked​()
      获取属性onMouseClicked的值。
      EventHandler<? super MouseDragEvent> getOnMouseDragEntered​()
      获取属性onMouseDragEntered的值。
      EventHandler<? super MouseDragEvent> getOnMouseDragExited​()
      获取属性onMouseDragExited的值。
      EventHandler<? super MouseEvent> getOnMouseDragged​()
      获取属性onMouseDragged的值。
      EventHandler<? super MouseDragEvent> getOnMouseDragOver​()
      获取属性onMouseDragOver的值。
      EventHandler<? super MouseDragEvent> getOnMouseDragReleased​()
      获取属性onMouseDragReleased的值。
      EventHandler<? super MouseEvent> getOnMouseEntered​()
      获取属性onMouseEntered的值。
      EventHandler<? super MouseEvent> getOnMouseExited​()
      获取属性onMouseExited的值。
      EventHandler<? super MouseEvent> getOnMouseMoved​()
      获取属性onMouseMoved的值。
      EventHandler<? super MouseEvent> getOnMousePressed​()
      获取属性onMousePressed的值。
      EventHandler<? super MouseEvent> getOnMouseReleased​()
      获取属性onMouseReleased的值。
      EventHandler<? super RotateEvent> getOnRotate​()
      获取属性onRotate的值。
      EventHandler<? super RotateEvent> getOnRotationFinished​()
      获取属性onRotationFinished的值。
      EventHandler<? super RotateEvent> getOnRotationStarted​()
      获取属性onRotationStarted的值。
      EventHandler<? super ScrollEvent> getOnScroll​()
      获取属性onScroll的值。
      EventHandler<? super ScrollEvent> getOnScrollFinished​()
      获取属性onScrollFinished的值。
      EventHandler<? super ScrollEvent> getOnScrollStarted​()
      获取属性onScrollStarted的值。
      EventHandler<? super SwipeEvent> getOnSwipeDown​()
      获取属性onSwipeDown的值。
      EventHandler<? super SwipeEvent> getOnSwipeLeft​()
      获取属性onSwipeLeft的值。
      EventHandler<? super SwipeEvent> getOnSwipeRight​()
      获取属性onSwipeRight的值。
      EventHandler<? super SwipeEvent> getOnSwipeUp​()
      获取属性onSwipeUp的值。
      EventHandler<? super TouchEvent> getOnTouchMoved​()
      获取onTouchMoved属性的值。
      EventHandler<? super TouchEvent> getOnTouchPressed​()
      获取onTouchPressed属性的值。
      EventHandler<? super TouchEvent> getOnTouchReleased​()
      获取onTouchReleased属性的值。
      EventHandler<? super TouchEvent> getOnTouchStationary​()
      获取属性onTouchStationary的值。
      EventHandler<? super ZoomEvent> getOnZoom​()
      获取属性onZoom的值。
      EventHandler<? super ZoomEvent> getOnZoomFinished​()
      获取属性onZoomFinished的值。
      EventHandler<? super ZoomEvent> getOnZoomStarted​()
      获取属性onZoomStarted的值。
      double getOpacity​()
      获取属性不透明度的值。
      Parent getParent​()
      获取属性parent的值。
      ObservableMap<Object,Object> getProperties​()
      返回此节点上属性的可观察图，主要由应用程序开发人员使用。
      ObservableSet<PseudoClass> getPseudoClassStates​()
      返回此Styleable的伪类状态。
      double getRotate​()
      获取属性旋转的值。
      Point3D getRotationAxis​()
      获取属性rotateAxis的值。
      double getScaleX​()
      获取属性scaleX的值。
      double getScaleY​()
      获取属性scaleY的值。
      double getScaleZ​()
      获取属性scaleZ的值。
      Scene getScene​()
      获取属性场景的值。
      String getStyle​()
      与此特定的 Node相关联的CSS样式的字符串表示 Node 。
      Styleable getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      ObservableList<String> getStyleClass​()
      可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。
      ObservableList<Transform> getTransforms​()
      定义的ObservableList Transform个对象被应用到这个Node 。
      double getTranslateX​()
      获取属性translateX的值。
      double getTranslateY​()
      获取属性translateY的值。
      double getTranslateZ​()
      获取属性translateZ的值。
      String getTypeSelector​()
      这种 Styleable的类型用于选择器匹配。
      Object getUserData​()
      返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
      double getViewOrder​()
      获取属性viewOrder的值。
      boolean hasProperties​()
      测试节点是否具有属性。
      ReadOnlyBooleanProperty hoverProperty​()
      这个 Node是否被徘徊。
      StringProperty idProperty​()
      该 Node为 Node 。
      ObjectProperty<InputMethodRequests> inputMethodRequestsProperty​()
      属性保存InputMethodRequests。
      boolean intersects​(double localX, double localY, double localWidth, double localHeight)
      返回 true如果给定的矩形（在指定在局部坐标的此空间 Node ）相交此的形状 Node 。
      boolean intersects​(Bounds localBounds)
      返回 true如果给定的范围（在当地指定的坐标这个空间 Node ）相交这个形状 Node 。
      boolean isCache​()
      获取属性缓存的值。
      boolean isDisable​()
      获取属性禁用的值。
      boolean isDisabled​()
      获取禁用的属性的值。
      boolean isFocused​()
      获取关注的属性的值。
      boolean isFocusTraversable​()
      获取属性focusTraversable的值。
      boolean isHover​()
      获取属性悬停的值。
      boolean isManaged​()
      获取管理的属性的值。
      boolean isMouseTransparent​()
      获取属性mouseTransparent的值。
      boolean isPickOnBounds​()
      获取属性pickOnBounds的值。
      boolean isPressed​()
      获取按下的属性的值。
      boolean isResizable​()
      指示该节点是否可以由父节点调整大小。
      boolean isVisible​()
      获取属性的值可见。
      ReadOnlyObjectProperty<Bounds> layoutBoundsProperty​()
      应该用于此节点的布局计算的矩形边界。
      DoubleProperty layoutXProperty​()
      定义添加到此 Node的转换中用于布局目的的转换的x坐标。
      DoubleProperty layoutYProperty​()
      定义添加到 Node的转换中用于布局目的的转换的y坐标。
      Point2D localToParent​(double localX, double localY)
      将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
      Point3D localToParent​(double x, double y, double z)
      将一个点从该 Node的局部坐标空间转换为其父对象的坐标空间。
      Bounds localToParent​(Bounds localBounds)
      将此 Node的局部坐标空间的 Node转换为其父节点的坐标空间。
      Point2D localToParent​(Point2D localPoint)
      将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
      Point3D localToParent​(Point3D localPoint)
      将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
      ReadOnlyObjectProperty<Transform> localToParentTransformProperty​()
      保存计算的本地到父变换的仿射变换。
      Point2D localToScene​(double localX, double localY)
      将一个点从该 Node的本地坐标空间 Node到其场景的坐标空间。
      Point2D localToScene​(double x, double y, boolean rootScene)
      将一个点从该 Node的局部坐标空间转换为其场景的坐标空间。
      Point3D localToScene​(double x, double y, double z)
      将一个点从该 Node的本地坐标空间 Node到其场景的坐标空间。
      Point3D localToScene​(double x, double y, double z, boolean rootScene)
      将一个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
      Bounds localToScene​(Bounds localBounds)
      将这个 Node的局部坐标空间的 Node转换为其场景的坐标空间。
      Bounds localToScene​(Bounds localBounds, boolean rootScene)
      将这个 Node的局部坐标空间的边界变换到其场景的坐标空间。
      Point2D localToScene​(Point2D localPoint)
      将一个点从该 Node的本地坐标空间转换为其场景的坐标空间。
      Point2D localToScene​(Point2D localPoint, boolean rootScene)
      将一个点从该 Node的局部坐标空间转换为其场景的坐标空间。
      Point3D localToScene​(Point3D localPoint)
      将一个点从该 Node的局部坐标空间转换为其场景的坐标空间。
      Point3D localToScene​(Point3D localPoint, boolean rootScene)
      将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
      ReadOnlyObjectProperty<Transform> localToSceneTransformProperty​()
      拥有计算的局部到场景变换的仿射变换。
      Point2D localToScreen​(double localX, double localY)
      将一个点从该Node的局部坐标空间转换为其Screen的坐标空间。
      Point2D localToScreen​(double localX, double localY, double localZ)
      将一个点从该Node的局部坐标空间转换为其Screen的坐标空间。
      Bounds localToScreen​(Bounds localBounds)
      将这个Node的局部坐标空间的Node转换为其Screen的坐标空间。
      Point2D localToScreen​(Point2D localPoint)
      将一个点从该Node的本地坐标空间转换为其Screen的坐标空间。
      Point2D localToScreen​(Point3D localPoint)
      将一个点从该Node的本地坐标空间转换为其Screen的坐标空间。
      Node lookup​(String selector)
      根据给定的CSS选择器，找到这个 Node或第一个子节点。
      Set<Node> lookupAll​(String selector)
      查找所有 Node s，包括这个和任何孩子，匹配给定的CSS选择器。
      BooleanProperty managedProperty​()
      定义该节点的布局是否由父节点管理。
      double maxHeight​(double width)
      返回节点在布局计算中使用的最大高度。
      double maxWidth​(double height)
      返回节点在布局计算中使用的最大宽度。
      double minHeight​(double width)
      返回节点在布局计算中使用的最小高度。
      double minWidth​(double height)
      返回节点在布局计算中使用的最小宽度。
      BooleanProperty mouseTransparentProperty​()
      如果是 true ，这个节点（与其所有子节点一起）对鼠标事件是完全透明的。
      ObjectProperty<NodeOrientation> nodeOrientationProperty​()
      属性保存NodeOrientation。
      void notifyAccessibleAttributeChanged​(AccessibleAttribute attributes)
      该方法由应用程序调用，以通知辅助技术属性的值已更改。
      ObjectProperty<EventHandler<? super ContextMenuEvent>> onContextMenuRequestedProperty​()
      定义在 Node上请求上下文菜单时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onDragDetectedProperty​()
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragDoneProperty​()
      定义当这个 Node在其数据放在放置目标上之后是拖放手势源时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> onDragDroppedProperty​()
      定义当在拖放手势时释放 Node鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragEnteredProperty​()
      定义拖动手势进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragExitedProperty​()
      定义当拖动手势退出 Node时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> onDragOverProperty​()
      定义当这个 Node拖动手势进度时要调用的函数。
      ObjectProperty<EventHandler<? super InputMethodEvent>> onInputMethodTextChangedProperty​()
      当这个 Node具有输入焦点并且输入法文本已经改变时，定义要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyPressedProperty​()
      定义当 Node或其子项 Node具有输入焦点并按下了一个键时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyReleasedProperty​()
      定义当这个 Node或其子代 Node具有输入焦点并且键已被释放时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyTypedProperty​()
      定义当这个 Node或其子代 Node具有输入焦点并键入了一个键时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseClickedProperty​()
      定义在此 Node上单击（按下并释放）鼠标按钮时调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragEnteredProperty​()
      定义当完全按下 - 释放手势进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragExitedProperty​()
      定义当完全按下 - 拖动释放手势离开这个 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseDraggedProperty​()
      定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragOverProperty​()
      定义当这个 Node内完全按下 - 拖动释放手势时，要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragReleasedProperty​()
      定义当完全按下 - 拖动释放手势结束（通过释放鼠标按钮）在该 Node内时 Node 。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseEnteredProperty​()
      定义当鼠标进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseExitedProperty​()
      定义当鼠标退出 Node时调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseMovedProperty​()
      定义当这个 Node内的鼠标光标移动时调用的功能，但没有按钮被按下。
      ObjectProperty<EventHandler<? super MouseEvent>> onMousePressedProperty​()
      定义当这个 Node按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseReleasedProperty​()
      定义在 Node上释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotateProperty​()
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotationFinishedProperty​()
      定义旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotationStartedProperty​()
      定义检测到旋转手势时要调用的功能。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollFinishedProperty​()
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollProperty​()
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollStartedProperty​()
      定义检测到滚动手势时要调用的函数。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeDownProperty​()
      定义当在该节点上居中的向下滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeLeftProperty​()
      定义当以该节点为中心的向左滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeRightProperty​()
      定义当以该节点为中心的向右滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeUpProperty​()
      定义当在该节点上居中的向上滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchMovedProperty​()
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchPressedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchReleasedProperty​()
      定义触发点释放时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchStationaryProperty​()
      定义当触摸点保持按下并静止时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomFinishedProperty​()
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomProperty​()
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomStartedProperty​()
      定义检测到缩放手势时要调用的功能。
      DoubleProperty opacityProperty​()
      指定 Node不透明（即固体）。
      ReadOnlyObjectProperty<Parent> parentProperty​()
      Node
      Point2D parentToLocal​(double parentX, double parentY)
      将一个点从母体的坐标空间转换为此 Node的局部坐标空间。
      Point3D parentToLocal​(double parentX, double parentY, double parentZ)
      将一个点从母体的坐标空间转换为这个 Node的局部坐标空间。
      Bounds parentToLocal​(Bounds parentBounds)
      将矩形从母体的坐标空间转换为此 Node的局部坐标空间。
      Point2D parentToLocal​(Point2D parentPoint)
      将一个点从母体的坐标空间转换为此 Node的局部坐标空间。
      Point3D parentToLocal​(Point3D parentPoint)
      将一个点从母体的坐标空间转换为 Node的局部坐标空间。
      BooleanProperty pickOnBoundsProperty​()
      定义当由 MouseEvent或 contains函数调用触发时，如何为此节点完成拣选计算。
      double prefHeight​(double width)
      返回节点的首选高度，用于布局计算。
      double prefWidth​(double height)
      返回节点在布局计算中使用的首选宽度。
      ReadOnlyBooleanProperty pressedProperty​()
      是否按下 Node 。
      void pseudoClassStateChanged​(PseudoClass pseudoClass, boolean active)
      用于指定此节点的伪类已更改。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void relocate​(double x, double y)
      设置节点的layoutX和layoutY转换属性，以便将该节点重定位到父节点的x，y位置。
      <T extends Event>
      void             		removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此节点注销先前注册的事件过滤器。
      <T extends Event>
      void             		removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此节点注销先前注册的事件处理程序。
      void requestFocus​()
      要求这个 Node得到输入焦点，而这个 Node的顶级祖先成为焦点窗口。
      void resize​(double width, double height)
      如果节点可调整大小，将其布局边界设置为指定的宽度和高度。
      void resizeRelocate​(double x, double y, double width, double height)
      如果节点可调整大小，将其布局边界设置为指定的宽度和高度。
      DoubleProperty rotateProperty​()
      定义关于 Node中心的旋转角度，以度为单位。
      ObjectProperty<Point3D> rotationAxisProperty​()
      定义 Node的旋转轴。
      DoubleProperty scaleXProperty​()
      定义坐标按照该 Node沿着X轴的对象中心进行缩放的因子。
      DoubleProperty scaleYProperty​()
      定义坐标按照该 Node的Y轴的对象中心进行缩放的因子。
      DoubleProperty scaleZProperty​()
      定义坐标按照该 Node的Z轴的对象中心进行缩放的因子。
      ReadOnlyObjectProperty<Scene> sceneProperty​()
      这Scene是这个Node的一部分。
      Point2D sceneToLocal​(double sceneX, double sceneY)
      将一个点从场景的坐标空间转换为这个 Node的局部坐标空间。
      Point2D sceneToLocal​(double x, double y, boolean rootScene)
      将一个点从场景的坐标空间转换为 Node的局部坐标空间。
      Point3D sceneToLocal​(double sceneX, double sceneY, double sceneZ)
      将一个点从场景的坐标空间转换为 Node的局部坐标空间。
      Bounds sceneToLocal​(Bounds sceneBounds)
      将矩形从场景的坐标空间转换为 Node的局部坐标空间。
      Bounds sceneToLocal​(Bounds bounds, boolean rootScene)
      将场景的坐标空间的边界转换为 Node的局部坐标空间。
      Point2D sceneToLocal​(Point2D scenePoint)
      将一个点从场景的坐标空间转换为此 Node的局部坐标空间。
      Point2D sceneToLocal​(Point2D point, boolean rootScene)
      将点从场景的坐标空间转换为此 Node的局部坐标空间。
      Point3D sceneToLocal​(Point3D scenePoint)
      将一个点从场景的坐标空间转换为 Node的局部坐标空间。
      Point2D screenToLocal​(double screenX, double screenY)
      将一个点从Screen的坐标空间转换为此Node的本地坐标空间。
      Bounds screenToLocal​(Bounds screenBounds)
      将矩形从Screen的坐标空间转换为此Node的局部坐标空间。
      Point2D screenToLocal​(Point2D screenPoint)
      将来自该坐标空间中的点Screen这个局部坐标空间Node 。
      void setAccessibleHelp​(String value)
      设置属性accessibleHelp的值。
      void setAccessibleRole​(AccessibleRole value)
      设置属性accessibilityRole的值。
      void setAccessibleRoleDescription​(String value)
      设置属性accessibilityRoleDescription的值。
      void setAccessibleText​(String value)
      设置属性accessibleText的值。
      void setBlendMode​(BlendMode value)
      设置blendMode属性的值。
      void setCache​(boolean value)
      设置属性缓存的值。
      void setCacheHint​(CacheHint value)
      设置属性cacheHint的值。
      void setClip​(Node value)
      设置属性剪辑的值。
      void setCursor​(Cursor value)
      设置属性游标的值。
      void setDepthTest​(DepthTest value)
      设置属性depthTest的值。
      void setDisable​(boolean value)
      设置属性的值禁用。
      protected void setDisabled​(boolean value)
      设置禁用属性的值。
      void setEffect​(Effect value)
      设置属性效果的值。
      void setEventDispatcher​(EventDispatcher value)
      设置属性eventDispatcher的值。
      protected <T extends Event>
      void             		setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      protected void setFocused​(boolean value)
      设置集中的属性的值。
      void setFocusTraversable​(boolean value)
      设置focusTraversable属性的值。
      protected void setHover​(boolean value)
      设置属性悬停的值。
      void setId​(String value)
      设置属性id的值。
      void setInputMethodRequests​(InputMethodRequests value)
      设置属性inputMethodRequests的值。
      void setLayoutX​(double value)
      设置属性layoutX的值。
      void setLayoutY​(double value)
      设置属性layoutY的值。
      void setManaged​(boolean value)
      设置管理的属性的值。
      void setMouseTransparent​(boolean value)
      设置属性mouseTransparent的值。
      void setNodeOrientation​(NodeOrientation orientation)
      设置属性nodeOrientation的值。
      void setOnContextMenuRequested​(EventHandler<? super ContextMenuEvent> value)
      设置属性onContextMenuRequested的值。
      void setOnDragDetected​(EventHandler<? super MouseEvent> value)
      设置属性onDragDetected的值。
      void setOnDragDone​(EventHandler<? super DragEvent> value)
      设置属性onDragDone的值。
      void setOnDragDropped​(EventHandler<? super DragEvent> value)
      设置属性onDragDropped的值。
      void setOnDragEntered​(EventHandler<? super DragEvent> value)
      设置属性onDragEntered的值。
      void setOnDragExited​(EventHandler<? super DragEvent> value)
      设置属性onDragExited的值。
      void setOnDragOver​(EventHandler<? super DragEvent> value)
      设置属性onDragOver的值。
      void setOnInputMethodTextChanged​(EventHandler<? super InputMethodEvent> value)
      设置属性onInputMethodTextChanged的值。
      void setOnKeyPressed​(EventHandler<? super KeyEvent> value)
      设置属性onKeyPressed的值。
      void setOnKeyReleased​(EventHandler<? super KeyEvent> value)
      设置属性onKeyReleased的值。
      void setOnKeyTyped​(EventHandler<? super KeyEvent> value)
      设置属性onKeyTyped的值。
      void setOnMouseClicked​(EventHandler<? super MouseEvent> value)
      设置属性onMouseClicked的值。
      void setOnMouseDragEntered​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragEntered的值。
      void setOnMouseDragExited​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragExited的值。
      void setOnMouseDragged​(EventHandler<? super MouseEvent> value)
      设置属性onMouseDragged的值。
      void setOnMouseDragOver​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragOver的值。
      void setOnMouseDragReleased​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragReleased的值。
      void setOnMouseEntered​(EventHandler<? super MouseEvent> value)
      设置属性onMouseEntered的值。
      void setOnMouseExited​(EventHandler<? super MouseEvent> value)
      设置属性onMouseExited的值。
      void setOnMouseMoved​(EventHandler<? super MouseEvent> value)
      设置属性onMouseMoved的值。
      void setOnMousePressed​(EventHandler<? super MouseEvent> value)
      设置属性onMousePressed的值。
      void setOnMouseReleased​(EventHandler<? super MouseEvent> value)
      设置属性onMouseReleased的值。
      void setOnRotate​(EventHandler<? super RotateEvent> value)
      设置属性onRotate的值。
      void setOnRotationFinished​(EventHandler<? super RotateEvent> value)
      设置属性onRotationFinished的值。
      void setOnRotationStarted​(EventHandler<? super RotateEvent> value)
      设置属性onRotationStarted的值。
      void setOnScroll​(EventHandler<? super ScrollEvent> value)
      设置属性onScroll的值。
      void setOnScrollFinished​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollFinished的值。
      void setOnScrollStarted​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollStarted的值。
      void setOnSwipeDown​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeDown的值。
      void setOnSwipeLeft​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeLeft的值。
      void setOnSwipeRight​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeRight的值。
      void setOnSwipeUp​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeUp的值。
      void setOnTouchMoved​(EventHandler<? super TouchEvent> value)
      设置属性onTouchMoved的值。
      void setOnTouchPressed​(EventHandler<? super TouchEvent> value)
      设置属性onTouchPressed的值。
      void setOnTouchReleased​(EventHandler<? super TouchEvent> value)
      设置属性onTouchReleased的值。
      void setOnTouchStationary​(EventHandler<? super TouchEvent> value)
      设置属性onTouchStationary的值。
      void setOnZoom​(EventHandler<? super ZoomEvent> value)
      设置Zoom上的属性值。
      void setOnZoomFinished​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomFinished的值。
      void setOnZoomStarted​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomStarted的值。
      void setOpacity​(double value)
      设置属性不透明度的值。
      void setPickOnBounds​(boolean value)
      设置属性pickOnBounds的值。
      protected void setPressed​(boolean value)
      设置按下的属性的值。
      void setRotate​(double value)
      设置属性rotate的值。
      void setRotationAxis​(Point3D value)
      设置属性rotateAxis的值。
      void setScaleX​(double value)
      设置属性scaleX的值。
      void setScaleY​(double value)
      设置属性scaleY的值。
      void setScaleZ​(double value)
      设置属性scaleZ的值。
      void setStyle​(String value)
      与此特定的 Node相关联的CSS样式的字符串表示 Node 。
      void setTranslateX​(double value)
      设置属性translateX的值。
      void setTranslateY​(double value)
      设置属性translateY的值。
      void setTranslateZ​(double value)
      设置属性translateZ的值。
      void setUserData​(Object value)
      用于设置可以在以后检索的单个Object属性的便利方法。
      void setViewOrder​(double value)
      设置属性viewOrder的值。
      void setVisible​(boolean value)
      设置属性的值可见。
      WritableImage snapshot​(SnapshotParameters params, WritableImage image)
      获取该节点的快照，并在渲染图像准备就绪时返回。
      void snapshot​(Callback<SnapshotResult,Void> callback, SnapshotParameters params, WritableImage image)
      在下一帧获取该节点的快照，并在映像准备就绪时调用指定的回调方法。
      Dragboard startDragAndDrop​(TransferMode... transferModes)
      确认一个潜在的拖放手势，在这 Node被认可。
      void startFullDrag​()
      开始一个完整的按下 - 拖动释放手势与该节点作为手势源。
      StringProperty styleProperty​()
      与此特定 Node相关联的CSS样式的字符串表示 Node 。
      void toBack​()
      按照z顺序将此 Node移动到其兄弟节点的后面。
      void toFront​()
      将这个 Node按照z顺序移动到其兄弟节点的前面。
      String toString​()
      返回对象的字符串表示形式。
      DoubleProperty translateXProperty​()
      定义添加到此 Node的转换的转换的x坐标。
      DoubleProperty translateYProperty​()
      定义添加到此 Node的转换中的转换的y坐标。
      DoubleProperty translateZProperty​()
      定义添加到此 Node的转换坐标的转换的Z坐标。
      boolean usesMirroring​()
      确定当节点方向是从右到左时是否应该镜像节点。
      DoubleProperty viewOrderProperty​()
      定义其父项中的 Node的呈现和拣配顺序。
      BooleanProperty visibleProperty​()
      指定此 Node和任何子节点是否应呈现为场景图的一部分。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • parent

        public final ReadOnlyObjectProperty<Parent> parentProperty
        这是Node的父母。 如果此Node尚未添加到场景图中，则父级将为空。
        Default value:
        空值
        另请参见：
        getParent()

      • scene

        public final ReadOnlyObjectProperty<Scene> sceneProperty
        该Scene ，这Node是一部分。 如果节点不是场景的一部分，则该变量将为空。
        Default value:
        空值
        另请参见：
        getScene()

      • id

        public final StringProperty idProperty
        这个id的这个Node 。 这个简单的字符串标识符可用于在场景图中查找特定的节点。 虽然节点的ID在场景图中应该是唯一的，但是这种唯一性不会被强制执行。 这类似于HTML元素（ CSS ID Specification ）上的“id”属性。

        例如，如果节点的ID为“myId”，则可以使用查找方法查找此节点，如下所示： scene.lookup("#myId"); 。

        Default value:
        空值
        另请参见：
        getId() ， setId(String)

      • style

        public final StringProperty styleProperty
        与此特定的Node相关联的CSS样式的字符串表示Node 。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        Default value:
        空字符串
        另请参见：
        getStyle() ， setStyle(String)

      • visible

        public final BooleanProperty visibleProperty
        指定此Node和任何子节点是否应呈现为场景图的一部分。 节点可能是可见的，但是如果例如它离开屏幕或被另一个节点遮蔽，则可以在渲染的场景中显示。 隐形节点永远不会接收鼠标事件或键盘焦点，并且在不可见时不会保持键盘焦点。
        Default value:
        真正
        另请参见：
        isVisible() ， setVisible(boolean)

      • cursor

        public final ObjectProperty<Cursor> cursorProperty
        为此Node和子节点定义鼠标光标。 如果为空，则将使用具有非空游标的第一个父节点的游标。 如果场景图中没有节点定义了游标，则将使用Scene的游标。
        Default value:
        空值
        另请参见：
        getCursor() ， setCursor(Cursor)

      • opacity

        public final DoubleProperty opacityProperty
        指定Node不透明（即固体）。 0％不透明度的节点是完全半透明的。 也就是说，虽然它仍然是visible并呈现，你通常将无法看到它。 此规则的例外情况是当Node与混合模式和混合效果结合使用时，半透明节点可能仍然对渲染有影响。 50％的不透明度将使节点呈现50％的透明度。

        具有任何不透明度设置的visible节点仍然接收鼠标事件并可以接收键盘焦点。 例如，如果要在场景图中有一个大的不可见矩形覆盖所有Node s，以截取鼠标事件，但用户不可见，则可以创建一个不透明度为0％的大型Rectangle 。

        不透明度被指定为介于0和1之间的值。小于0的值被视为0，大于1的值被视为1。

        在某些平台上，ImageView可能不支持opacity变量。

        有一个已知的混合不透明度<1.0与3D变换的限制。 不透明度/混合本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置的不透明度<1.0的结果将导致其孩子被顺序渲染，而不会在这些孩子之间施加Z缓冲。

        Default value:
        1.0
        另请参见：
        getOpacity() ， setOpacity(double)

      • blendMode

        public final ObjectProperty<BlendMode> blendModeProperty
        BlendMode用于将这个单独的节点混合到其后面的场景中。 如果这个节点恰好是一个组，那么所有的子节点都将使用自己的混合模式单独合成一个临时缓冲区，然后临时缓冲区将使用指定的混合模式合成到场景中。 值null被视为通过，虽然这意味着对单个节点等父类（如组）和等效的SRC_OVER无影响。
        Default value:
        空值
        另请参见：
        getBlendMode() ， setBlendMode(BlendMode)

      • clip

        public final ObjectProperty<Node> clipProperty
        指定一个Node用于定义此节点的剪切形状。 这个剪辑节点不是这个Node在场景图形中的一个孩子。 相反，它用于定义此Node的剪辑。

        例如，您可以使用ImageView节点作为掩码来表示剪辑。 或者您可以使用几何形状节点之一，如Rectangle或Circle 。 或者您可以使用Text节点来表示剪辑。

        有关设置剪辑的场景图结构限制，请参阅Node的类文档。 如果对clip变量的更改违反了这些限制，则忽略该更改，并恢复剪辑变量的先前值。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SHAPE_CLIP 。

        将Clip与3D Transform混合存在一个已知的限制。 剪切本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置Clip的结果将导致其孩子被顺序渲染，而不会在这些孩子之间施加Z缓冲。

        Default value:
        空值
        另请参见：
        getClip() ， setClip(Node)

      • cache

        public final BooleanProperty cacheProperty
        系统的性能提示表明，这个Node应该被缓存为一个位图。 在许多情况下，渲染节点的位图表示将比渲染图元更快，特别是在应用了效果的图元的情况下（如模糊）。 但是，它也增加了内存使用量。 这个提示表明这种权衡（增加的性能的内存使用增加）是否值得。 还要注意，在某些平台上，如GPU加速平台，使用模糊和其他效果时，将节点缓存为位图几乎没有什么好处，因为它们在GPU上渲染速度非常快。 cacheHintProperty()变量提供了更多选项来实现更积极的位图缓存。

        对于自身，任何其祖先或其任何后代都有3D变换的任何节点，可能禁用缓存。

        Default value:
        假
        另请参见：
        isCache() ， setCache(boolean)

      • cacheHint

        public final ObjectProperty<CacheHint> cacheHintProperty
        控制位图缓存的其他提示。

        在某些情况下，例如对于呈现非常昂贵的动画节点，希望能够在节点上执行转换而不必重新生成缓存的位图。 在这种情况下，选项是对缓存位图本身进行转换。

        这种技术可以显着提高动画性能，但也可能导致视觉质量下降。 cacheHint变量为系统提供了关于如何以及何时可以接受折衷（动画性能的视觉质量）的提示。

        只有在您的节点动画化的时候才能启用cacheHint。 以这种方式，昂贵的节点可以出现在屏幕上，具有完整的视觉质量，但仍然是平稳的动画。

        例：

           expensiveNode.setCache(true); expensiveNode.setCacheHint(CacheHint.QUALITY); ... // Do an animation expensiveNode.setCacheHint(CacheHint.SPEED); new Timeline( new KeyFrame(Duration.seconds(2), new KeyValue(expensiveNode.scaleXProperty(), 2.0), new KeyValue(expensiveNode.scaleYProperty(), 2.0), new KeyValue(expensiveNode.rotateProperty(), 360), new KeyValue(expensiveNode.cacheHintProperty(), CacheHint.QUALITY) ) ).play();
        请注意， cacheHint只是系统的一个提示。 根据节点或变换的细节，此提示可能会被忽略。

        如果Node.cache为false，则将忽略cacheHint。 对于自身，任何其祖先或其任何后代都有3D变换的任何节点，可能禁用缓存。

        Default value:
        CacheHint.DEFAULT
        另请参见：
        getCacheHint() ， setCacheHint(CacheHint)

      • effect

        public final ObjectProperty<Effect> effectProperty
        指定应用于此Node的效果。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.EFFECT 。

        混合效果与3D变换有一个已知的限制。 效果本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置效果的结果将导致其孩子被顺序呈现，而不会在这些孩子之间施加Z缓冲。

        Default value:
        空值
        另请参见：
        getEffect() ， setEffect(Effect)

      • depthTest

        public final ObjectProperty<DepthTest> depthTestProperty
        指示在渲染此节点时是否使用深度测试。 如果depthTest标志为DepthTest.DISABLE ，则该节点的深度测试被禁用。 如果depthTest标志为DepthTest.ENABLE ，则对该节点启用深度测试。 如果depthTest标志为DepthTest.INHERIT ，则如果为父节点启用了深度测试，则父节点为null。

        所述depthTest标志仅用于当深度缓存中标志为Scene为真（意味着Scene具有相关联的深度缓冲器）

        深度测试比较仅在启用了depthTest的节点之间进行。 禁用depthTest的节点不读取，测试或写入深度缓冲区，也就是说，其Z值不会被考虑用于与其他节点的深度测试。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        使用depthBuffer查看Scene中的构造函数作为其输入参数之一。

        Default value:
        继承
        另请参见：
        getDepthTest() ， setDepthTest(DepthTest)

      • disable

        public final BooleanProperty disableProperty
        定义此Node的个人禁用状态。 将disable设置为true将导致此Node和任何子节点成为禁用。 该属性应仅用于设置禁用状态为Node 。 对于查询的禁用状态Node ，该disabled财产应改为使用，因为它可能是一个Node作为祖先的结果被禁用即使个别被禁用disable在这种状态下Node为false 。
        Default value:
        假
        另请参见：
        isDisable() ， setDisable(boolean)

      • pickOnBounds

        public final BooleanProperty pickOnBoundsProperty
        定义当由MouseEvent或contains函数调用触发时，如何为此节点完成拣选计算。 如果pickOnBounds为真，则通过与该节点的边界相交来计算拾取，否则通过与该节点的几何形状相交来计算拾取。
        Default value:
        假
        另请参见：
        isPickOnBounds() ， setPickOnBounds(boolean)

      • disabled

        public final ReadOnlyBooleanProperty disabledProperty
        指示此Node是否被禁用。 如果disable在其本身或场景图中的其祖先之一上设置为true ，则Node将被禁用。

        禁用的Node应该呈现不同的方式，以指示其对用户的禁用状态。 这种禁用渲染取决于Node的实现。 javafx.scene.shape包含的形状类默认情况下不实现此类渲染，因此使用形状处理输入的应用程序必须实现适当的禁用渲染本身。 然而， javafx.scene.control定义的用户界面控件将实现禁用敏感的渲染。

        禁用的Node不会接收鼠标或键事件。

        Default value:
        假
        另请参见：
        isDisabled() ， setDisabled(boolean)

      • onDragEntered

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragEnteredProperty
        定义当拖动手势进入 Node时要调用的功能。
        另请参见：
        getOnDragEntered() ， setOnDragEntered(EventHandler)

      • onDragExited

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragExitedProperty
        定义当拖动手势退出 Node时要调用的函数。
        另请参见：
        getOnDragExited() ， setOnDragExited(EventHandler)

      • onDragOver

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragOverProperty
        定义当这个 Node拖动手势进度时要调用的函数。
        另请参见：
        getOnDragOver() ， setOnDragOver(EventHandler)

      • onDragDropped

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragDroppedProperty
        定义当在拖放手势时释放鼠标按钮Node时要调用的功能。 在DragEvent的dragboard中传输数据应该发生在此功能中。
        另请参见：
        getOnDragDropped() ， setOnDragDropped(EventHandler)

      • onDragDone

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragDoneProperty
        定义当这个Node是一个拖放手势源后，它的数据被放在放置目标上之后被调用的函数。 该事件的transferMode显示刚刚发生的下降目标。 如果transferMode具有值MOVE ，则源可以清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 甲transferMode具有值NONE指示拖放手势期间没有数据被转移。
        另请参见：
        getOnDragDone() ， setOnDragDone(EventHandler)

      • managed

        public final BooleanProperty managedProperty
        定义该节点的布局是否由父节点管理。 如果节点被管理，那么它的父节点会将节点的几何因子归因于其自己的首选大小和layoutBounds计算，并将在场景的布局过程中进行排列。 如果受管节点的layoutBounds更改，它将自动触发将场景图转发到最近的布局根（通常是场景的根节点）。

        如果节点不受管理，其父级将忽略两个首选大小的计算和布局中的子节点。 layoutBounds中的更改将不会在其上方触发中继。 如果非托管节点的类型为Parent ，它将作为“布局根”，这意味着对其下的Parent.requestLayout()的调用将仅导致由该节点生根的分支被中继，从而将布局更改隔离到该根和下面。 应用程序负责设置非托管节点的大小和位置。

        默认情况下所有节点都被管理。

        另请参见：
        isManaged() ， setManaged(boolean)

      • layoutX

        public final DoubleProperty layoutXProperty
        定义添加到Node的转换中用于布局目的的转换的x坐标。 该值应该计算为将节点的位置从当前的layoutBounds minX位置（可能不为0）调整到所需位置所需的偏移量。

        例如，如果textnode应该位于finalX

           textnode.setLayoutX(finalX - textnode.getLayoutBounds().getMinX());

        不能减去layoutBounds minX可能会导致节点错位。 relocate(x, y)方法将自动进行正确的计算，通常直接用于设置layoutX。

        节点的最终翻译将计算为layoutX + translateX ，其中layoutX建立节点的稳定位置， translateX可选地对该位置进行动态调整。

        如果节点被管理并且以其父节点为Region ，则布局区域将根据自己的布局策略设置layoutX 。 如果节点不是由Group管理或者父母，则应用程序可以直接设置layoutX来定位它。

        另请参见：
        getLayoutX() ， setLayoutX(double)

      • layoutY

        public final DoubleProperty layoutYProperty
        定义为了布局目的而添加到此Node的转换中的转换的y坐标。 该值应该计算为将节点的位置从当前的layoutBounds minY位置（可能不为0）调整到所需位置所需的偏移量。

        例如，如果textnode应该位于finalY

           textnode.setLayoutY(finalY - textnode.getLayoutBounds().getMinY());

        不能减去layoutBounds minY可能会导致节点错位。 relocate(x, y)方法将自动进行正确的计算，通常直接用于设置layoutY。

        节点的最终翻译将计算为layoutY + translateY ，其中layoutY建立节点的稳定位置， translateY可选地对该位置进行动态调整。

        如果节点被管理，并且有一个Region作为其父节点，则该区域将根据其自己的布局策略设置layoutY 。 如果节点不是由Group管理或父节点，则应用程序可以直接设置layoutY来定位它。

        另请参见：
        getLayoutY() ， setLayoutY(double)

      • boundsInParent

        public final ReadOnlyObjectProperty<Bounds> boundsInParentProperty
        这个Node的矩形边界包括它的变换。 boundsInParent是通过采取局部边界（由boundsInLocal定义）并应用通过设置以下附加变量创建的变换来计算的
        1. transforms ObservableList
        2. scaleX ， scaleY
        3. rotate
        4. layoutX ， layoutY
        5. translateX ， translateY

        结果范围将在概念上在Node的父节点的坐标空间中，但是该节点不需要有父代来计算这些边界。

        请注意，此方法不考虑节点的可见性; 该计算仅基于该Node的几何。

        此属性将始终具有非空值。

        请注意，只要节点的几何结构发生更改，或者当以下任何一项更改时，boundsInParent将自动重新计算：转换ObservableList，translateX，translateY，layoutX，layoutY，scaleX，scaleY或rotate变量。 因此，将节点中的任何值绑定到依赖于此变量的表达式是一个错误。 例如，为了定位节点，形状的x或y变量或translateX，translateY不应该被绑定到boundsInParent。

        另请参见：
        getBoundsInParent()

      • boundsInLocal

        public final ReadOnlyObjectProperty<Bounds> boundsInLocalProperty
        该节点未转换的局部坐标空间中的Node的矩形边界。 对于扩展Shape的节点，局部边界还将包括可能落在由位置和大小属性定义的形状几何体之外的非零行程所需的空间。 本地范围还将包括任何剪辑集clip以及设置为effect的效果。

        请注意，此方法不考虑节点的可见性; 该计算仅基于这个Node的几何。

        此属性将始终具有非空值。

        请注意，只要节点的几何结构发生更改，boundsInLocal就会自动重新计算。 因此，将节点中的任何值绑定到依赖于此变量的表达式是一个错误。 例如，为了定位节点，形状的x或y变量不应该被绑定到boundsInLocal。

        另请参见：
        getBoundsInLocal()

      • layoutBounds

        public final ReadOnlyObjectProperty<Bounds> layoutBoundsProperty
        应该用于此节点的布局计算的矩形边界。 layoutBounds可能与节点的可视边界不同，并且根据节点类型而不同地计算。

        如果该节点类型是可调整大小（ Region ， Control ，或WebView ），则layoutBounds中永远是0,0 width x height 。 如果该节点类型是不可调整大小（ Shape ， Text ，或Group ），则layoutBounds中计算基于所述节点的几何性质，并且不包括该节点的剪辑，效果或变换。 有关详细信息，请参阅各类课程文档

        需要注意的是layoutX ， layoutY ， translateX ，并translateY变量没有在layoutBounds。 这很重要，因为布局代码必须首先确定节点的当前大小和位置（使用layoutBounds），然后设置layoutX和layoutY以调整节点的翻译，以使其具有所需的布局位置。

        因为layoutBounds的计算通常与节点的几何变量相关联，所以将这些变量绑定到依赖于layoutBounds的表达式是一个错误。 例如，为了定位节点，不应将形状的x或y变量绑定到layoutBounds。

        layoutBounds永远不会为空。

        另请参见：
        getLayoutBounds()

      • viewOrder

        public final DoubleProperty viewOrderProperty
        定义其父项中的Node的呈现和拣配顺序。

        此属性用于更改其父级中的节点的呈现和拣选顺序，而无需重新排序父级的children列表。 例如，这可以用作实现透明度排序的更有效的方法。 为此，应用程序可以将每个节点的viewOrder值分配给该节点和查看器之间的计算距离。

        父母将通过其children减少viewOrder订单。 这意味着一个较小的viewOrder的孩子将在一个较高的viewOrder的孩子viewOrder 。 如果两个孩子有相同的viewOrder ，父母将按照父母children列表中的顺序遍历它们。

        但是， viewOrder不会在此父节点中更改此节点的布局和重点遍历顺序。 当进行布局或聚焦遍历时，父对象总是按顺序遍历其children列表。

        Default value:
        0.0
        从以下版本开始：
        9
        另请参见：
        getViewOrder() ， setViewOrder(double)

      • translateX

        public final DoubleProperty translateXProperty
        定义添加到此Node的转换中的转换的x坐标。

        节点的最终翻译将计算为layoutX + translateX ，其中layoutX建立节点的稳定位置， translateX可选地对该位置进行动态调整。

        该变量可用于改变节点的位置而不会干扰其layoutBounds ，这使得它有助于动画化节点的位置。

        Default value:
        0
        另请参见：
        getTranslateX() ， setTranslateX(double)

      • translateY

        public final DoubleProperty translateYProperty
        定义添加到此Node的转换中的转换的y坐标。

        节点的最终翻译将计算为layoutY + translateY ，其中layoutY建立节点的稳定位置， translateY可选地对该位置进行动态调整。

        该变量可用于改变节点的位置，而不会干扰其layoutBounds ，这使得它有助于动画化节点的位置。

        Default value:
        0
        另请参见：
        getTranslateY() ， setTranslateY(double)

      • translateZ

        public final DoubleProperty translateZProperty
        定义添加到此Node的转换坐标的平移的Z坐标。 该值将被添加到由transforms ObservableList和layoutZ定义的任何翻译。

        该变量可用于改变节点的位置，而不会影响其布局边界，这使得它有助于动画化节点的位置。

        请注意，这是一个条件功能。 详见ConditionalFeature.SCENE3D 。

        Default value:
        0
        另请参见：
        getTranslateZ() ， setTranslateZ(double)

      • scaleX

        public final DoubleProperty scaleXProperty
        定义坐标按照该Node的X轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，此比例因子不包括在layoutBounds中 ，这使得在考虑了所有效果和转换后，对整个节点进行缩放是非常理想的。

        发生刻度的枢轴点是未转化的layoutBounds的中心。

        Default value:
        1.0
        另请参见：
        getScaleX() ， setScaleX(double)

      • scaleY

        public final DoubleProperty scaleYProperty
        定义坐标按照该Node的Y轴对象对象中心进行比例的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，此比例因子不包括在layoutBounds中 ，这使得它在理想的情况下，在考虑了所有效果和转换后，可以缩放整个节点。

        尺度发生的枢轴点是未转化的layoutBounds的中心。

        Default value:
        1.0
        另请参见：
        getScaleY() ， setScaleY(double)

      • scaleZ

        public final DoubleProperty scaleZProperty
        定义坐标按照该Node的Z轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，该比例因子不包括在layoutBounds中 ，这使得它在理想的情况下，在所有效果和转换都被考虑后，可以缩放整个节点。

        尺度发生的枢轴点是通过采用boundsInLocal形成的矩形边界的中心，并应用transforms ObservableList中的所有变换。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        1.0
        另请参见：
        getScaleZ() ， setScaleZ(double)

      • rotate

        public final DoubleProperty rotateProperty
        定义关于Node中心的旋转角度，以度为单位。 这是用来旋转Node 。

        默认情况下，这个旋转因子不包括在layoutBounds中 ，这使得在考虑了所有效果和变换之后，它是理想的旋转整个节点。

        旋转发生的枢轴点是未转化的layoutBounds的中心。

        请注意，由于枢轴点计算为此Node的布局边界的中心，对布局边界的任何更改将导致枢轴点更改，这可能会移动对象。 对于叶节点，几何的任何更改将导致布局边界更改。 对于组节点，对其任何子项的任何更改（包括对子组的几何，剪辑，效果，位置，方向或比例的更改）都将导致组的布局界限发生更改。 如果不需要枢纽点的这种移动，应用程序应该使用节点的transforms ObservableList，并添加一个Rotate变换，它具有用户可指定的枢轴点。

        Default value:
        0.0
        另请参见：
        getRotate() ， setRotate(double)

      • rotationAxis

        public final ObjectProperty<Point3D> rotationAxisProperty
        定义Node的旋转轴。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        Rotate.Z_AXIS
        另请参见：
        getRotationAxis() ， setRotationAxis(Point3D)

      • localToParentTransform

        public final ReadOnlyObjectProperty<Transform> localToParentTransformProperty
        保存计算的本地到父变换的仿射变换。 这是这个节点中所有变换的并置，包括所有的方便变换。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getLocalToParentTransform()

      • localToSceneTransform

        public final ReadOnlyObjectProperty<Transform> localToSceneTransformProperty
        拥有计算的局部到场景变换的仿射变换。 这是这个节点的父节点和这个节点中的所有变换的并置，包括到根节点的所有方便变换。 如果此节点在一个SubScene中 ，则此属性表示转换为子视图，而不是根节点。

        请注意，当您注册侦听器或绑定到此属性时，它需要监听所有父进程对根节点的无效。 这意味着在许多节点上注册此属性的侦听器可能会对其父母中的转换更改的性能产生负面影响。

        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getLocalToSceneTransform()

      • nodeOrientation

        public final ObjectProperty<NodeOrientation> nodeOrientationProperty
        属性保存NodeOrientation。

        节点方向描述节点内视觉数据的流动。 在英语世界中，视觉数据通常从左到右流动。 在阿拉伯语或希伯来语世界，视觉数据从右到左流动。 这与两个世界的文本阅读顺序一致。 默认值是从左到右。

        结果
        NodeOrientation
        从以下版本开始：
        JavaFX 8.0

      • effectiveNodeOrientation

        public final ReadOnlyObjectProperty<NodeOrientation> effectiveNodeOrientationProperty
        节点的有效方向解决节点方向的继承，从左到右或从右到左返回。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getEffectiveNodeOrientation()

      • mouseTransparent

        public final BooleanProperty mouseTransparentProperty
        如果true ，这个节点（连同它的所有子节点）对于鼠标事件是完全透明的。 当选择鼠标事件的目标时， mouseTransparent设置为true节点及其子树将不被考虑。
        另请参见：
        isMouseTransparent() ， setMouseTransparent(boolean)

      • hover

        public final ReadOnlyBooleanProperty hoverProperty
        这Node是否正在徘徊。 通常这是由于鼠标在节点上，尽管这可能是由于笔悬停在图形输入板或其他形式的输入上。

        请注意，当前实现的悬停依赖于鼠标进入和退出事件来确定此节点是否处于悬停状态; 这意味着目前仅在具有鼠标的系统上支持此功能。 未来的实现可以提供支持悬停的替代方式。

        Default value:
        假
        另请参见：
        isHover() ， setHover(boolean)

      • pressed

        public final ReadOnlyBooleanProperty pressedProperty
        是否按下Node 。 通常，当主鼠标按钮处于关闭状态时，这是正确的，尽管子类可以定义其他鼠标按钮状态或键状态，以使节点“按下”。
        Default value:
        假
        另请参见：
        isPressed() ， setPressed(boolean)

      • onContextMenuRequested

        public final ObjectProperty<EventHandler<? super ContextMenuEvent>> onContextMenuRequestedProperty
        定义在 Node上请求上下文菜单时要调用的函数。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnContextMenuRequested() ， setOnContextMenuRequested(EventHandler)

      • onMouseClicked

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseClickedProperty
        定义当这个 Node点击（按下和释放）鼠标按钮时要调用的功能。
        另请参见：
        getOnMouseClicked() ， setOnMouseClicked(EventHandler)

      • onMouseDragged

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseDraggedProperty
        定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。
        另请参见：
        getOnMouseDragged() ， setOnMouseDragged(EventHandler)

      • onMouseEntered

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseEnteredProperty
        定义当鼠标进入 Node时要调用的功能。
        另请参见：
        getOnMouseEntered() ， setOnMouseEntered(EventHandler)

      • onMouseExited

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseExitedProperty
        定义当鼠标退出 Node时要调用的函数。
        另请参见：
        getOnMouseExited() ， setOnMouseExited(EventHandler)

      • onMouseMoved

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseMovedProperty
        定义当这个 Node鼠标光标移动时调用的功能，但没有按钮被按下。
        另请参见：
        getOnMouseMoved() ， setOnMouseMoved(EventHandler)

      • onMousePressed

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMousePressedProperty
        定义在 Node上按下鼠标按钮时要调用的功能。
        另请参见：
        getOnMousePressed() ， setOnMousePressed(EventHandler)

      • onMouseReleased

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseReleasedProperty
        定义当这个 Node上释放鼠标按钮时要调用的函数。
        另请参见：
        getOnMouseReleased() ， setOnMouseReleased(EventHandler)

      • onDragDetected

        public final ObjectProperty<EventHandler<? super MouseEvent>> onDragDetectedProperty
        定义检测到拖动手势时要调用的功能。 这是开始拖放操作的正确位置。
        另请参见：
        getOnDragDetected() ， setOnDragDetected(EventHandler)

      • onMouseDragOver

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragOverProperty
        定义当这个 Node的全按压拖动手势进行时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragOver() ， setOnMouseDragOver(EventHandler)

      • onMouseDragReleased

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragReleasedProperty
        定义当这个 Node完全按下 - 拖动释放手势结束（通过释放鼠标按钮）时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragReleased() ， setOnMouseDragReleased(EventHandler)

      • onMouseDragEntered

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragEnteredProperty
        定义当全按压拖动手势进入这个 Node时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragEntered() ， setOnMouseDragEntered(EventHandler)

      • onMouseDragExited

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragExitedProperty
        定义当完全按下 - 拖动释放手势离开这个 Node时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragExited() ， setOnMouseDragExited(EventHandler)

      • onScrollStarted

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollStartedProperty
        定义检测到滚动手势时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnScrollStarted() ， setOnScrollStarted(EventHandler)

      • onScroll

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollProperty
        定义当用户执行滚动操作时要调用的函数。
        另请参见：
        getOnScroll() ， setOnScroll(EventHandler)

      • onScrollFinished

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollFinishedProperty
        定义当滚动手势结束时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnScrollFinished() ， setOnScrollFinished(EventHandler)

      • onRotationStarted

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotationStartedProperty
        定义检测到旋转手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotationStarted() ， setOnRotationStarted(EventHandler)

      • onRotate

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotateProperty
        定义当用户执行旋转操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotate() ， setOnRotate(EventHandler)

      • onRotationFinished

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotationFinishedProperty
        定义旋转手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotationFinished() ， setOnRotationFinished(EventHandler)

      • onZoomStarted

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomStartedProperty
        定义检测到缩放手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoomStarted() ， setOnZoomStarted(EventHandler)

      • onZoom

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomProperty
        定义当用户执行缩放操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoom() ， setOnZoom(EventHandler)

      • onZoomFinished

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomFinishedProperty
        定义当缩放手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoomFinished() ， setOnZoomFinished(EventHandler)

      • onSwipeUp

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeUpProperty
        定义当在该节点上居中的向上滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeUp() ， setOnSwipeUp(EventHandler)

      • onSwipeDown

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeDownProperty
        定义当在该节点上居中的向下滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeDown() ， setOnSwipeDown(EventHandler)

      • onSwipeLeft

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeLeftProperty
        定义当以该节点为中心的向左滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeLeft() ， setOnSwipeLeft(EventHandler)

      • onSwipeRight

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeRightProperty
        定义当以该节点为中心的向右滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeRight() ， setOnSwipeRight(EventHandler)

      • onTouchPressed

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchPressedProperty
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchPressed() ， setOnTouchPressed(EventHandler)

      • onTouchMoved

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchMovedProperty
        定义当触摸点移动时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchMoved() ， setOnTouchMoved(EventHandler)

      • onTouchReleased

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchReleasedProperty
        定义触发点释放时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchReleased() ， setOnTouchReleased(EventHandler)

      • onTouchStationary

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchStationaryProperty
        定义当触摸点保持按下并静止时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchStationary() ， setOnTouchStationary(EventHandler)

      • onKeyPressed

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyPressedProperty
        定义当这个Node或其子项Node具有输入焦点并按下一个键时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyPressed() ， setOnKeyPressed(EventHandler)

      • onKeyReleased

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyReleasedProperty
        定义当这个Node或其子代Node具有输入焦点并且键被释放时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyReleased() ， setOnKeyReleased(EventHandler)

      • onKeyTyped

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyTypedProperty
        定义当这个Node或其子代Node具有输入焦点并键入了一个键时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyTyped() ， setOnKeyTyped(EventHandler)

      • onInputMethodTextChanged

        public final ObjectProperty<EventHandler<? super InputMethodEvent>> onInputMethodTextChangedProperty
        定义当这个Node具有输入焦点并且输入法文本已更改时要调用的函数。 如果此功能未在此Node定义，则它会将输入法组合的结果字符串接收为一系列onKeyTyped函数调用。

        当Node丢失输入焦点时，JavaFX运行时自动提交现有的合成文本（如果有）。

        另请参见：
        getOnInputMethodTextChanged() ， setOnInputMethodTextChanged(EventHandler)

      • inputMethodRequests

        public final ObjectProperty<InputMethodRequests> inputMethodRequestsProperty
        属性保存InputMethodRequests。
        另请参见：
        getInputMethodRequests() ， setInputMethodRequests(InputMethodRequests)

      • focused

        public final ReadOnlyBooleanProperty focusedProperty
        指示此Node当前是否具有输入焦点。 要具有输入焦点，节点必须是Scene的焦点所有者，并且场景必须在可见和活动的Stage中。 有关详细信息，请参阅requestFocus() 。
        Default value:
        假
        另请参见：
        isFocused() ， setFocused(boolean)

      • focusTraversable

        public final BooleanProperty focusTraversableProperty
        指定此Node应该是聚焦遍历周期的一部分。 当这个属性是true焦点可以移动到这个Node和从这Node使用常规焦点遍历键。 在桌面上，这样的键通常是TAB用于向前移动焦点和SHIFT+TAB用于向后移动焦点。 当创建Scene ，系统Node焦点放在Node其focusTraversable变量为true，并且有资格接收焦点，除非通过调用requestFocus()显式设置了焦点。
        Default value:
        假
        另请参见：
        isFocusTraversable() ， setFocusTraversable(boolean)

      • eventDispatcher

        public final ObjectProperty<EventDispatcher> eventDispatcherProperty
        指定此节点的事件分派器。 默认事件调度程序将接收的事件发送到已注册的事件处理程序和过滤器。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到已替换的调度程序，以维护节点的默认事件处理行为。
        另请参见：
        getEventDispatcher() ， setEventDispatcher(EventDispatcher)

      • accessibleRole

        public final ObjectProperty<AccessibleRole> accessibleRoleProperty
        这个Node的可访问角色。

        屏幕阅读器使用节点的角色来确定支持的属性和动作。

        Default value:
        AccessibleRole.NODE
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAccessibleRole() ， setAccessibleRole(AccessibleRole)

      • accessibleRoleDescription

        public final ObjectProperty<String> accessibleRoleDescriptionProperty
        这个角色描述Node 。

        可以说，当为节点提供角色时，屏幕阅读器说出节点的作用以及内容。 当设置此值时，可以覆盖默认值。 这是有用的，因为角色集是预定义的。 例如，可以将节点的角色设置为按钮，但将角色描述设置为任意文本。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAccessibleRoleDescription() ， setAccessibleRoleDescription(String)

      • accessibleText

        public final ObjectProperty<String> accessibleTextProperty
        Node的可访问文本。

        此属性用于设置屏幕阅读器将发言的文本。 如果一个节点通常会说文字，那么该文本就会被覆盖。 例如，一个按钮通常使用控件中的文本，但在设置此值时将不再执行此操作。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAccessibleText() ， setAccessibleText(String)

      • accessibleHelp

        public final ObjectProperty<String> accessibleHelpProperty
        该Node的可访问的帮助文本。

        帮助文本提供了节点可访问文本的更详细描述。 默认情况下，如果节点具有工具提示，则使用此文本。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAccessibleHelp() ， setAccessibleHelp(String)

    • 字段详细信息

      • BASELINE_OFFSET_SAME_AS_HEIGHT

        public static final double BASELINE_OFFSET_SAME_AS_HEIGHT
        这是一个可能由getBaselineOffset()返回的特殊值。 这意味着此节点的父（布局窗格）应使用此节点的高度作为基线。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Node

        protected Node​()
        创建一个新的Node实例。

    • 方法详细信息

      • getProperties

        public final ObservableMap<Object,Object> getProperties​()
        返回此节点上属性的可观察图，主要由应用程序开发人员使用。
        结果
        该节点上属性的可观察地图主要由应用程序开发人员使用

      • hasProperties

        public boolean hasProperties​()
        测试节点是否具有属性。
        结果
        如果节点有属性，则为true。

      • setUserData

        public void setUserData​(Object value)
        用于设置可以在以后检索的单个Object属性的便利方法。 这在功能上等同于调用getProperties（）。put（Object key，Object value）方法。 这可以稍后通过调用getUserData()来检索。
        参数
        value - 要存储的值 - 以后可以通过调用 getUserData()来检索。

      • getUserData

        public Object getUserData​()
        返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
        结果
        先前设置的对象，如果没有设置属性或设置为null，则为null。

      • getParent

        public final Parent getParent​()
        获取属性parent的值。
        Property description:
        这是Node的父母。 如果此Node尚未添加到场景图中，则父级将为空。
        Default value:
        空值

      • parentProperty

        public final ReadOnlyObjectProperty<Parent> parentProperty​()
        这是Node的父母。 如果此Node尚未添加到场景图中，则父级将为空。
        Default value:
        空值
        另请参见：
        getParent()

      • getScene

        public final Scene getScene​()
        获取属性场景的值。
        Property description:
        Scene这个Node是其中的一部分。 如果节点不是场景的一部分，则该变量将为空。
        Default value:
        空值

      • sceneProperty

        public final ReadOnlyObjectProperty<Scene> sceneProperty​()
        Scene这个Node是其中的一部分。 如果节点不是场景的一部分，则该变量将为空。
        Default value:
        空值
        另请参见：
        getScene()

      • setId

        public final void setId​(String value)
        设置属性id的值。
        Property description:
        该Node为Node 。 这个简单的字符串标识符可用于在场景图中查找特定的节点。 虽然节点的ID在场景图中应该是唯一的，但是这种唯一性不会被强制执行。 这类似于HTML元素上的“id”属性（ CSS ID Specification ）。

        例如，如果节点的ID为“myId”，则可以使用查找方法来查找此节点，如下所示： scene.lookup("#myId"); 。

        Default value:
        空值

      • getId

        public final String getId​()
        该Node为Node 。 这个简单的字符串标识符可用于在场景图中查找特定的节点。 虽然节点的ID在场景图中应该是唯一的，但是这种唯一性不会被强制执行。 这类似于HTML元素上的“id”属性（ CSS ID Specification ）。
        Specified by:
        getId在接口 Styleable
        Default value:
        空值
        结果
        使用 setId方法或 null分配给此 Node的ID，如果没有分配ID。
        另请参见：
        CSS Reference Guide

      • idProperty

        public final StringProperty idProperty​()
        这个id的这个Node 。 这个简单的字符串标识符可用于在场景图中查找特定的节点。 虽然节点的ID在场景图中应该是唯一的，但是这种唯一性不会被强制执行。 这类似于HTML元素上的“id”属性（ CSS ID Specification ）。

        例如，如果节点的ID为“myId”，则可以使用lookup方法来查找此节点，如下所示： scene.lookup("#myId"); 。

        Default value:
        空值
        另请参见：
        getId() ， setId(String)

      • getStyleClass

        public final ObservableList<String> getStyleClass​()
        描述从接口Styleable复制
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。 该变量类似于HTML元素上的“类”属性，因此列表的每个元素都是此节点所属的样式类。
        Specified by:
        getStyleClass在接口 Styleable
        结果
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎
        另请参见：
        CSS3 class selectors

      • setStyle

        public final void setStyle​(String value)
        与此特定的Node相关联的CSS样式的字符串表示Node 。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        Default value:
        空字符串
        参数
        value - 用于此Node的内联CSS样式。 null隐式转换为空字符串。
        另请参见：
        CSS Reference Guide

      • getStyle

        public final String getStyle​()
        与此特定的Node相关联的CSS样式的字符串表示Node 。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        Specified by:
        getStyle在接口 Styleable
        Default value:
        空字符串
        结果
        与此Node相关联的内联CSS样式。 如果此Node没有内联样式，则返回一个空字符串。
        另请参见：
        CSS Reference Guide

      • styleProperty

        public final StringProperty styleProperty​()
        与此特定的Node相关联的CSS样式的字符串表示Node 。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        Default value:
        空字符串
        另请参见：
        getStyle() ， setStyle(String)

      • setVisible

        public final void setVisible​(boolean value)
        设置属性的值可见。
        Property description:
        指定此Node和任何子节点是否应呈现为场景图的一部分。 节点可能是可见的，但是如果例如它离开屏幕或被另一个节点遮蔽，则可以在渲染的场景中显示。 隐形节点永远不会接收鼠标事件或键盘焦点，并且在不可见时不会保持键盘焦点。
        Default value:
        真正

      • isVisible

        public final boolean isVisible​()
        获取属性的值可见。
        Property description:
        指定此Node和任何子节点是否应呈现为场景图的一部分。 节点可能是可见的，但是如果例如它离开屏幕或被另一个节点遮蔽，则可以在渲染的场景中显示。 隐形节点永远不会接收鼠标事件或键盘焦点，并且在不可见时不会保持键盘焦点。
        Default value:
        真正

      • visibleProperty

        public final BooleanProperty visibleProperty​()
        指定此Node和任何子节点是否应呈现为场景图的一部分。 节点可能是可见的，但是如果例如它离开屏幕或被另一个节点遮蔽，则可以在渲染的场景中显示。 隐形节点永远不会接收鼠标事件或键盘焦点，并且在不可见时不会保持键盘焦点。
        Default value:
        真正
        另请参见：
        isVisible() ， setVisible(boolean)

      • setCursor

        public final void setCursor​(Cursor value)
        设置属性游标的值。
        Property description:
        为此Node和子节点定义鼠标光标。 如果为空，则将使用具有非空游标的第一个父节点的游标。 如果场景图中没有节点定义光标，则将使用Scene的光标。
        Default value:
        空值

      • getCursor

        public final Cursor getCursor​()
        获取属性游标的值。
        Property description:
        为此Node和子节点定义鼠标光标。 如果为空，则将使用具有非空游标的第一个父节点的游标。 如果场景图中没有节点定义了游标，则将使用Scene的光标。
        Default value:
        空值

      • cursorProperty

        public final ObjectProperty<Cursor> cursorProperty​()
        为此Node和子节点定义鼠标光标。 如果为空，则将使用具有非空游标的第一个父节点的游标。 如果场景图中没有节点定义了游标，则将使用Scene的光标。
        Default value:
        空值
        另请参见：
        getCursor() ， setCursor(Cursor)

      • setOpacity

        public final void setOpacity​(double value)
        设置属性不透明度的值。
        Property description:
        指定Node不透明（即固体）。 0％不透明度的节点是完全半透明的。 也就是说，虽然它仍然是visible并呈现，你通常将无法看到它。 这个规则的例外是当Node与混合模式和混合效果相结合时，在这种情况下，半透明节点可能仍然对渲染有影响。 50％的不透明度将使节点呈现50％的透明度。

        具有任何不透明度设置的visible节点仍然接收鼠标事件并可以接收键盘焦点。 例如，如果要在场景图中拥有一个大的不可见矩形覆盖所有Node s，以截取鼠标事件，但用户不可见，则可以创建一个不透明度为0％的大型Rectangle 。

        不透明度被指定为介于0和1之间的值。小于0的值被视为0，大于1的值被视为1。

        在某些平台上，ImageView可能不支持opacity变量。

        有一个已知的混合不透明度<1.0与3D变换的限制。 不透明度/混合本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置的不透明度<1.0的结果将导致其孩子被顺序渲染，而不会在这些孩子之间施加Z缓冲。

        Default value:
        1.0

      • getOpacity

        public final double getOpacity​()
        获取属性不透明度的值。
        Property description:
        指定Node不透明（即固体）。 0％不透明度的节点是完全半透明的。 也就是说，虽然它仍然是visible并且呈现，你通常将无法看到它。 这个规则的例外是当Node与混合模式和混合效果相结合时，在这种情况下，半透明节点可能仍然对渲染有影响。 50％的不透明度将使节点呈现50％的透明度。

        具有任何不透明度设置的visible节点仍然接收鼠标事件并可以接收键盘焦点。 例如，如果要在场景图中有一个大的不可见矩形覆盖所有Node s，以截取鼠标事件，但用户不可见，则可以创建一个不透明度为0％的大型Rectangle 。

        不透明度被指定为介于0和1之间的值。小于0的值被视为0，大于1的值被视为1。

        在某些平台上，ImageView可能不支持opacity变量。

        有一个已知的混合不透明度<1.0与3D变换的限制。 不透明度/混合本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置的不透明度<1.0的结果将导致其孩子被依次渲染，而不会在这些孩子之间施加Z缓冲。

        Default value:
        1.0

      • opacityProperty

        public final DoubleProperty opacityProperty​()
        指定出现Node不透明（即固体）。 0％不透明度的节点是完全半透明的。 也就是说，虽然它仍然是visible并渲染，但你通常将无法看到它。 这个规则的例外是当Node与混合模式和混合效果相结合时，在这种情况下，半透明节点可能仍然对渲染有影响。 50％的不透明度将使节点呈现50％的透明度。

        具有任何不透明度设置的visible节点仍然接收鼠标事件并可以接收键盘焦点。 例如，如果要在场景图中有一个大的不可见的矩形覆盖所有Node ，以拦截鼠标事件，但对用户不可见，则可以创建一个不透明度为0％的大型Rectangle 。

        不透明度被指定为介于0和1之间的值。小于0的值被视为0，大于1的值被视为1。

        在某些平台上，ImageView可能不支持opacity变量。

        有一个已知的混合不透明度<1.0与3D变换的限制。 不透明度/混合本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置的不透明度<1.0的结果将导致其孩子被依次渲染，而不会在这些孩子之间应用Z缓冲。

        Default value:
        1.0
        另请参见：
        getOpacity() ， setOpacity(double)

      • setBlendMode

        public final void setBlendMode​(BlendMode value)
        设置blendMode属性的值。
        Property description:
        BlendMode用于将此单个节点混合到其后面的场景中。 如果这个节点恰好是一个组，那么所有的子节点都将使用自己的混合模式单独合成一个临时缓冲区，然后临时缓冲区将使用指定的混合模式合成到场景中。 值null被视为通过，虽然这意味着对单个节点等父类（例如组）和等效的SRC_OVER没有影响。
        Default value:
        空值

      • getBlendMode

        public final BlendMode getBlendMode​()
        获取属性blendMode的值。
        Property description:
        BlendMode用于将此单个节点混合到其后面的场景中。 如果这个节点恰好是一个组，那么所有的子节点都将使用自己的混合模式单独合成一个临时缓冲区，然后临时缓冲区将使用指定的混合模式合成到场景中。 值null被视为通过，这意味着对单个节点等父类（如组）和等效的SRC_OVER无影响。
        Default value:
        空值

      • blendModeProperty

        public final ObjectProperty<BlendMode> blendModeProperty​()
        BlendMode用于将这个单独的节点混合到其后面的场景中。 如果这个节点恰好是一个组，那么所有的子节点都将使用自己的混合模式单独合成一个临时缓冲区，然后临时缓冲区将使用指定的混合模式合成到场景中。 值null被视为通过，这意味着对单个节点等父类（如组）和等效的SRC_OVER无影响。
        Default value:
        空值
        另请参见：
        getBlendMode() ， setBlendMode(BlendMode)

      • setClip

        public final void setClip​(Node value)
        设置属性剪辑的值。
        Property description:
        指定一个Node用于定义此节点的剪切形状。 这个剪辑节点不是场景图形中Node的小孩。 相反，它用于定义此Node的剪辑。

        例如，您可以使用ImageView节点作为掩码来表示剪辑。 或者您可以使用几何形状节点之一，如Rectangle或Circle 。 或者您可以使用Text节点来表示剪辑。

        有关设置剪辑的场景图结构限制，请参阅Node的类文档。 如果对clip变量的更改违反了这些限制，则忽略该更改，并恢复剪辑变量的先前值。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SHAPE_CLIP 。

        将Clip与3D Transform混合存在一个已知的限制。 剪切本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置的剪辑的结果将导致其孩子被顺序呈现，而不在这些孩子之间施加Z缓冲。

        Default value:
        空值

      • getClip

        public final Node getClip​()
        获取属性剪辑的值。
        Property description:
        指定一个Node用于定义此节点的剪切形状。 这个剪辑节点不是场景图形中Node一个小孩。 相反，它用于定义此Node的剪辑。

        例如，您可以使用ImageView节点作为掩码来表示剪辑。 或者您可以使用几何形状节点之一，如Rectangle或Circle 。 或者您可以使用Text节点来表示剪辑。

        有关设置剪辑的场景图结构限制，请参阅Node的类文档。 如果对clip变量的更改违反了这些限制，则忽略该更改，并恢复剪辑变量的先前值。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SHAPE_CLIP 。

        将Clip与3D Transform混合存在一个已知的限制。 剪切本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置Clip的结果将导致其孩子被依次渲染，而不会在这些孩子之间施加Z缓冲。

        Default value:
        空值

      • clipProperty

        public final ObjectProperty<Node> clipProperty​()
        指定用于定义此节点的剪切形状的Node 。 这个剪辑节点不是场景图形中Node一个小孩。 相反，它用于定义此Node的剪辑。

        例如，您可以使用ImageView节点作为掩码来表示剪辑。 或者您可以使用几何形状节点之一，如Rectangle或Circle 。 或者您可以使用Text节点来表示剪辑。

        有关设置剪辑的场景图结构限制，请参阅Node的类文档。 如果对clip变量的更改违反了这些限制，则忽略该更改，并恢复剪辑变量的先前值。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SHAPE_CLIP 。

        将Clip与3D Transform混合存在一个已知的限制。 剪切本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置Clip的结果将导致其孩子被顺序渲染，而不会在这些孩子之间施加Z缓冲。

        Default value:
        空值
        另请参见：
        getClip() ， setClip(Node)

      • setCache

        public final void setCache​(boolean value)
        设置属性缓存的值。
        Property description:
        系统的性能提示表明这个Node应该被缓存为一个位图。 在许多情况下，渲染节点的位图表示将比渲染图元更快，特别是在应用了效果的图元的情况下（如模糊）。 但是，它也增加了内存使用量。 这个提示表明这种权衡（增加的性能的内存使用增加）是否值得。 还要注意，在某些平台上，如GPU加速平台，使用模糊和其他效果时，将节点缓存为位图几乎没有什么好处，因为它们在GPU上渲染速度非常快。 cacheHintProperty()变量提供了更多选项来实现更积极的位图缓存。

        对于自身，任何其祖先或其任何后代都有3D变换的任何节点，可能禁用缓存。

        Default value:
        假

      • isCache

        public final boolean isCache​()
        获取属性缓存的值。
        Property description:
        系统的性能提示表明这个Node应该被缓存为一个位图。 在许多情况下，渲染节点的位图表示将比渲染图元更快，特别是在应用了效果的图元的情况下（如模糊）。 但是，它也增加了内存使用量。 这个提示表明这种权衡（增加的性能的内存使用增加）是否值得。 还要注意，在某些平台上，如GPU加速平台，使用模糊和其他效果时，将节点缓存为位图几乎没有什么好处，因为它们在GPU上渲染速度非常快。 cacheHintProperty()变量提供了更多选项来实现更积极的位图缓存。

        对于自身，任何其祖先或其任何后代都有3D变换的任何节点，可能禁用缓存。

        Default value:
        假

      • cacheProperty

        public final BooleanProperty cacheProperty​()
        系统的性能提示表明这个Node应该被缓存为一个位图。 在许多情况下，渲染节点的位图表示将比渲染图元更快，特别是在应用了效果的图元的情况下（如模糊）。 但是，它也增加了内存使用量。 这个提示表明这种权衡（增加的性能的内存使用增加）是否值得。 还要注意，在某些平台上，如GPU加速平台，使用模糊和其他效果时，将节点缓存为位图几乎没有什么好处，因为它们在GPU上渲染速度非常快。 cacheHintProperty()变量提供了更多选项来实现更积极的位图缓存。

        对于自身，任何其祖先或其任何后代都有3D变换的任何节点，可能禁用缓存。

        Default value:
        假
        另请参见：
        isCache() ， setCache(boolean)

      • setCacheHint

        public final void setCacheHint​(CacheHint value)
        设置属性cacheHint的值。
        Property description:
        控制位图缓存的其他提示。

        在某些情况下，例如对于呈现非常昂贵的动画节点，希望能够在节点上执行转换而不必重新生成缓存的位图。 在这种情况下，选项是对缓存位图本身进行转换。

        这种技术可以显着提高动画性能，但也可能导致视觉质量下降。 cacheHint变量为系统提供了关于如何以及何时可以接受折衷（动画效果的视觉质量）的提示。

        只有在您的节点动画化的时候才能启用cacheHint。 以这种方式，昂贵的节点可以出现在屏幕上，具有完整的视觉质量，但仍然是平稳的动画。

        例：

           expensiveNode.setCache(true); expensiveNode.setCacheHint(CacheHint.QUALITY); ... // Do an animation expensiveNode.setCacheHint(CacheHint.SPEED); new Timeline( new KeyFrame(Duration.seconds(2), new KeyValue(expensiveNode.scaleXProperty(), 2.0), new KeyValue(expensiveNode.scaleYProperty(), 2.0), new KeyValue(expensiveNode.rotateProperty(), 360), new KeyValue(expensiveNode.cacheHintProperty(), CacheHint.QUALITY) ) ).play();
        请注意， cacheHint只是系统的一个提示。 根据节点或变换的细节，此提示可能会被忽略。

        如果Node.cache为false，则将忽略cacheHint。 对于自身，任何其祖先或其任何后代都有3D变换的任何节点，可能禁用缓存。

        Default value:
        CacheHint.DEFAULT

      • getCacheHint

        public final CacheHint getCacheHint​()
        获取属性cacheHint的值。
        Property description:
        控制位图缓存的其他提示。

        在某些情况下，例如对于呈现非常昂贵的动画节点，希望能够在节点上执行转换而不必重新生成缓存的位图。 在这种情况下，选项是对缓存位图本身进行转换。

        这种技术可以显着提高动画性能，但也可能导致视觉质量下降。 cacheHint变量为系统提供了关于如何以及何时可以接受折衷（动画表现的视觉质量）的提示。

        只有在您的节点动画化的时候才能启用cacheHint。 以这种方式，昂贵的节点可以出现在屏幕上，具有完整的视觉质量，但仍然是平稳的动画。

        例：

           expensiveNode.setCache(true); expensiveNode.setCacheHint(CacheHint.QUALITY); ... // Do an animation expensiveNode.setCacheHint(CacheHint.SPEED); new Timeline( new KeyFrame(Duration.seconds(2), new KeyValue(expensiveNode.scaleXProperty(), 2.0), new KeyValue(expensiveNode.scaleYProperty(), 2.0), new KeyValue(expensiveNode.rotateProperty(), 360), new KeyValue(expensiveNode.cacheHintProperty(), CacheHint.QUALITY) ) ).play();
        请注意， cacheHint只是系统的提示。 根据节点或变换的细节，此提示可能会被忽略。

        如果Node.cache为false，则将忽略cacheHint。 对于自身，任何其祖先或其任何后代都有3D变换的任何节点，可能禁用缓存。

        Default value:
        CacheHint.DEFAULT

      • cacheHintProperty

        public final ObjectProperty<CacheHint> cacheHintProperty​()
        控制位图缓存的其他提示。

        在某些情况下，例如对于呈现非常昂贵的动画节点，希望能够在节点上执行转换而不必重新生成缓存的位图。 在这种情况下，选项是对缓存位图本身进行转换。

        这种技术可以显着提高动画性能，但也可能导致视觉质量下降。 cacheHint变量为系统提供了关于如何以及何时可以接受折衷（动画表现的视觉质量）的提示。

        只有在您的节点动画化的时候才能启用cacheHint。 以这种方式，昂贵的节点可以出现在屏幕上，具有完整的视觉质量，但仍然是平稳的动画。

        例：

           expensiveNode.setCache(true); expensiveNode.setCacheHint(CacheHint.QUALITY); ... // Do an animation expensiveNode.setCacheHint(CacheHint.SPEED); new Timeline( new KeyFrame(Duration.seconds(2), new KeyValue(expensiveNode.scaleXProperty(), 2.0), new KeyValue(expensiveNode.scaleYProperty(), 2.0), new KeyValue(expensiveNode.rotateProperty(), 360), new KeyValue(expensiveNode.cacheHintProperty(), CacheHint.QUALITY) ) ).play();
        请注意， cacheHint只是系统的一个暗示。 根据节点或变换的细节，此提示可能会被忽略。

        如果Node.cache为false，则将忽略cacheHint。 对于自身，任何其祖先或其任何后代都有3D变换的任何节点，可能禁用缓存。

        Default value:
        CacheHint.DEFAULT
        另请参见：
        getCacheHint() ， setCacheHint(CacheHint)

      • setEffect

        public final void setEffect​(Effect value)
        设置属性效果的值。
        Property description:
        指定应用于此Node的效果。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.EFFECT 。

        混合效果与3D变换有一个已知的限制。 效果本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置的效果的结果将导致其孩子被顺序呈现，而不在这些孩子之间施加Z缓冲。

        Default value:
        空值

      • getEffect

        public final Effect getEffect​()
        获取属性效果的值。
        Property description:
        指定应用于此Node的效果。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.EFFECT 。

        混合效果与3D变换有一个已知的限制。 效果本质上是2D图像操作。 在具有3D变换的孩子的Group节点上设置的效果的结果将导致其孩子被顺序渲染，而不会在这些孩子之间施加Z缓冲。

        Default value:
        空值

      • effectProperty

        public final ObjectProperty<Effect> effectProperty​()
        指定应用于此Node的效果。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.EFFECT 。

        混合效果与3D变换有一个已知的限制。 效果本质上是2D图像操作。 效果设置在具有3D变换的孩子的Group节点上的结果将导致其孩子被顺序呈现，而不在这些孩子之间施加Z缓冲。

        Default value:
        空值
        另请参见：
        getEffect() ， setEffect(Effect)

      • setDepthTest

        public final void setDepthTest​(DepthTest value)
        设置属性depthTest的值。
        Property description:
        指示在渲染此节点时是否使用深度测试。 如果depthTest标志为DepthTest.DISABLE ，则该节点的深度测试被禁用。 如果depthTest标志为DepthTest.ENABLE ，则对该节点启用深度测试。 如果depthTest标志为DepthTest.INHERIT ，则如果为父节点启用了深度测试，则该节点将启用深度测试，或者父节点为空。

        所述depthTest标志仅用于当深度缓存中标志为Scene为真（意味着Scene具有相关联的深度缓冲器）

        深度测试比较仅在启用了depthTest的节点之间进行。 禁用depthTest的节点不读取，测试或写入深度缓冲区，也就是说，其Z值不会被考虑用于与其他节点的深度测试。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        使用depthBuffer查看Scene中的构造函数作为其输入参数之一。

        Default value:
        继承

      • getDepthTest

        public final DepthTest getDepthTest​()
        获取属性depthTest的值。
        Property description:
        指示在渲染此节点时是否使用深度测试。 如果depthTest标志是DepthTest.DISABLE ，则该节点的深度测试被禁用。 如果depthTest标志为DepthTest.ENABLE ，则对该节点启用深度测试。 如果depthTest标志为DepthTest.INHERIT ，则如果为父节点启用了深度测试，则父节点为空。

        所述depthTest标志仅用于当深度缓存中标志为Scene为真（意味着Scene具有相关联的深度缓冲器）

        深度测试比较仅在启用了depthTest的节点之间进行。 禁用depthTest的节点不读取，测试或写入深度缓冲区，也就是说，其Z值不会被考虑用于与其他节点的深度测试。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        使用depthBuffer查看Scene中的构造函数作为其输入参数之一。

        Default value:
        继承

      • depthTestProperty

        public final ObjectProperty<DepthTest> depthTestProperty​()
        指示在渲染此节点时是否使用深度测试。 如果depthTest标志为DepthTest.DISABLE ，则该节点的深度测试被禁用。 如果depthTest标志为DepthTest.ENABLE ，则对该节点启用深度测试。 如果depthTest标志为DepthTest.INHERIT ，则如果为父节点启用了深度测试，则该节点启用了深度测试，或者父节点为空。

        所述depthTest标志仅用于当深度缓存中标志为Scene为真（意味着Scene具有相关联的深度缓冲器）

        深度测试比较仅在启用了depthTest的节点之间进行。 禁用depthTest的节点不读取，测试或写入深度缓冲区，也就是说，其Z值不会被考虑用于与其他节点的深度测试。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        使用depthBuffer查看Scene中的构造函数作为其输入参数之一。

        Default value:
        继承
        另请参见：
        getDepthTest() ， setDepthTest(DepthTest)

      • setDisable

        public final void setDisable​(boolean value)
        设置属性的值禁用。
        Property description:
        定义此Node的个人禁用状态。 将disable设置为true将导致此Node和任何子节点被禁用。 该属性应仅用于设置禁用状态为Node 。 为了查询Node的禁用状态，应该使用disabled属性，因为即使disable状态在Node上的disable状态为false ，由于可能禁用了Node ，因为祖先被禁用。
        Default value:
        假

      • isDisable

        public final boolean isDisable​()
        获取属性禁用的值。
        Property description:
        定义此Node的个人禁用状态。 将disable设置为true将导致此Node和任何子节点被禁用。 该属性应仅用于设置禁用状态为Node 。 对于查询的禁用状态Node ，该disabled财产应改为使用，因为它可能是一个Node作为祖先的结果被禁用即使个别被禁用disable在这种状态下Node为false 。
        Default value:
        假

      • disableProperty

        public final BooleanProperty disableProperty​()
        定义此Node的个人禁用状态。 将disable设置为true将导致此Node和任何子节点被禁用。 该属性应仅用于设置禁用状态为Node 。 对于查询的禁用状态Node ，该disabled财产应改为使用，因为它可能是一个Node作为祖先的结果被禁用即使个别被禁用disable在这种状态下Node为false 。
        Default value:
        假
        另请参见：
        isDisable() ， setDisable(boolean)

      • setPickOnBounds

        public final void setPickOnBounds​(boolean value)
        设置属性pickOnBounds的值。
        Property description:
        定义当由MouseEvent或contains函数调用触发时，如何为此节点完成拣选计算。 如果pickOnBounds为真，则通过与该节点的边界相交来计算拾取，否则通过与该节点的几何形状相交来计算拾取。
        Default value:
        假

      • isPickOnBounds

        public final boolean isPickOnBounds​()
        获取属性pickOnBounds的值。
        Property description:
        定义当由MouseEvent或contains函数调用触发时，如何为此节点完成拣选计算。 如果pickOnBounds为真，则通过与该节点的边界相交来计算拾取，否则通过与该节点的几何形状相交来计算拾取。
        Default value:
        假

      • pickOnBoundsProperty

        public final BooleanProperty pickOnBoundsProperty​()
        定义当由MouseEvent或contains函数调用触发时，如何为此节点完成拣选计算。 如果pickOnBounds为真，则通过与该节点的边界相交来计算拾取，否则通过与该节点的几何形状相交来计算拾取。
        Default value:
        假
        另请参见：
        isPickOnBounds() ， setPickOnBounds(boolean)

      • setDisabled

        protected final void setDisabled​(boolean value)
        设置禁用属性的值。
        Property description:
        表示是否禁用此Node 。 如果27071567748263在本身或场景图中的一个祖先设置为true ，则Node将被禁用。

        禁用的Node应该呈现不同的方式，以指示其对用户的禁用状态。 这种禁用渲染取决于Node的实现。 javafx.scene.shape包含的形状类默认情况下不实现此类渲染，因此使用形状处理输入的应用程序必须实现适当的禁用渲染本身。 然而， javafx.scene.control定义的用户界面控件将实现禁用敏感的渲染。

        禁用的Node不接收鼠标或键事件。

        Default value:
        假

      • isDisabled

        public final boolean isDisabled​()
        获取禁用的属性的值。
        Property description:
        指示此Node是否被禁用。 如果disable本身或场景图中的一个祖先设置为true ，则Node将被禁用。

        禁用的Node应该以不同的方式呈现，以指示其对用户的禁用状态。 这种禁用渲染取决于Node的实现。 javafx.scene.shape包含的形状类默认情况下不实现此类渲染，因此使用形状处理输入的应用程序必须实现适当的禁用渲染本身。 然而， javafx.scene.control定义的用户界面控件将实现禁用敏感的渲染。

        禁用的Node不接收鼠标或键事件。

        Default value:
        假

      • disabledProperty

        public final ReadOnlyBooleanProperty disabledProperty​()
        表示是否禁用Node 。 如果27071567777119在场景图中本身或其祖先之一上设置为true ，则Node将被禁用。

        禁用的Node应该呈现不同的方式，以指示其对用户的禁用状态。 这种禁用渲染取决于Node的实现。 javafx.scene.shape包含的形状类默认情况下不实现此类渲染，因此使用形状处理输入的应用程序必须实现适当的禁用渲染本身。 然而， javafx.scene.control定义的用户界面控件将实现禁用敏感的渲染。

        禁用的Node不会接收鼠标或键事件。

        Default value:
        假
        另请参见：
        isDisabled() ， setDisabled(boolean)

      • lookup

        public Node lookup​(String selector)
        根据给定的CSS选择器，找到这个Node或第一个子节点。 如果此节点为Parent ，则该函数将遍历到分支中，直到找到匹配项。 如果多个子节点与指定的选择器匹配，则此函数返回其中的第一个。

        例如，如果节点的ID为“myId”，那么查找方法可以用于查找此节点，如下所示： scene.lookup("#myId"); 。

        参数
        selector - 要查找的节点的css选择器
        结果
        第一个节点，从这个 Node开始，与CSS selector匹配，如果没有找到， selector null。

      • lookupAll

        public Set<Node> lookupAll​(String selector)
        查找所有Node s，包括这个和任何孩子，匹配给定的CSS选择器。 如果没有找到匹配项，则返回一个空的不可修改的集合。 该集合是明确无序的。
        参数
        selector - 要查找的节点的css选择器
        结果
        所有节点，从包括这个Node ，它与CSS selector匹配。 返回的集合始终是无序的，不可修改的，永远不会为空。

      • toBack

        public void toBack​()
        将这个Node移动到它的兄弟节点的z顺序。 这是通过将此Node移动到其父级的content ObservableList中的第一个位置来实现的。 如果该Node不是Node则此功能无效。

      • toFront

        public void toFront​()
        按照z顺序将此Node移动到其兄弟节点的前端。 这是通过将此Node移动到其父代的content ObservableList中的最后一个位置来实现的。 如果此Node不是组的一部分，则此功能无效。

      • snapshot

        public WritableImage snapshot​(SnapshotParameters params,
                              WritableImage image)
        获取该节点的快照，并在渲染图像准备就绪时返回。 在渲染之前，将对节点及其任何子节点进行CSS和布局处理。 整个目标图像被清除为由SnapshotParameters指定的填充Paint 。 然后将该节点呈现给图像。 如果由SnapshotParameters指定的视口为空，则在首次应用由SnapshotParameters指定的变换后，该节点的boundsInParent的左上角像素将映射到图像中的左上角像素（0,0）。 如果指定了非空视口，则视口的左上角像素将映射到图像中的左上角像素（0,0）。 在这两种情况下，图像的映射（0,0）都是用整数转换完成的。 在渲染图像之外的节点部分将被图像剪辑。

        当通过应用程序或隐式（如图表动画）明确地拍摄场景的快照时，将根据快照拍摄时的场景图形的状态渲染快照，并且不会反映任何随后的动画更改。

        注意：为了使CSS和布局正常工作，节点必须是场景的一部分（场景可以附加到舞台，但不需要）。

        参数
        params - 包含将控制渲染的属性的快照参数。 如果SnapshotParameters对象为空，则如果此节点是场景的一部分，则将使用场景的属性，如果此节点不是场景的一部分，则将使用默认属性。
        image - 将用于保存渲染节点的可写映像。 它可能为null，在这种情况下，将构建一个新的WritableImage。 新图像使用从该节点的已变换边界或从SnapShotParameters中指定的视口大小导出的整数宽度和高度值构造。 选择这些整数值使得图像将完全包含此节点或指定视口的边界。 如果图像不为空，则节点将被渲染为现有图像。 在这种情况下，图像的宽度和高度决定了渲染的区域，而不是边界或视口的宽度和高度。
        结果
        渲染图像
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        从以下版本开始：
        JavaFX 2.2

      • snapshot

        public void snapshot​(Callback<SnapshotResult,Void> callback,
                     SnapshotParameters params,
                     WritableImage image)
        在下一帧获取该节点的快照，并在映像准备就绪时调用指定的回调方法。 在渲染之前，将对节点及其任何子节点进行CSS和布局处理。 整个目标图像被清除为由SnapshotParameters指定的填充Paint 。 然后将该节点呈现给图像。 如果由SnapshotParameters指定的视口为空，则在首次应用由SnapshotParameters指定的变换后，该节点的boundsInParent的左上角像素映射到图像中的左上角像素（0,0）。 如果指定了非空视口，则视口的左上角像素将映射到图像中的左上角像素（0,0）。 在这两种情况下，图像的映射（0,0）都是用整数转换完成的。 在渲染图像之外的节点部分将被图像剪辑。

        这是一个异步调用，这意味着在渲染节点之前可能会处理其他事件或动画。 如果任何这样的事件修改节点或其任何子节点，则修改将被反映在渲染图像中（就像它也将反映在渲染到舞台的帧中，如果该节点是实况场景图的一部分） 。

        当通过应用程序或隐式（如图表动画）明确地获取动画节点的快照时，将根据拍摄快照时场景图的状态渲染快照，并且不会反映任何随后的动画更改。

        注意：为了使CSS和布局正常工作，节点必须是场景的一部分（场景可以附加到舞台，但不需要）。

        参数
        callback - 当图像准备好时调用方法的类。 传递到回调的调用方法的SnapshotResult将包含渲染的图像，渲染的源节点以及SnapshotParameters的副本。 回调参数不能为空。
        params - 包含将控制渲染的属性的快照参数。 如果SnapshotParameters对象为空，则如果此节点是场景的一部分，则将使用场景的属性，如果此节点不是场景的一部分，则将使用默认属性。
        image - 将用于保存渲染节点的可写映像。 它可能为null，在这种情况下，将构建一个新的WritableImage。 新图像使用从该节点的已变换边界或从SnapShotParameters中指定的视口大小导出的整数宽度和高度值构造。 选择这些整数值使得图像将完全包含此节点或指定视口的边界。 如果图像不为空，则节点将被渲染为现有图像。 在这种情况下，图像的宽度和高度决定了渲染的区域，而不是边界或视口的宽度和高度。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        NullPointerException - 如果回调参数为空。
        从以下版本开始：
        JavaFX 2.2

      • setOnDragEntered

        public final void setOnDragEntered​(EventHandler<? super DragEvent> value)
        设置属性onDragEntered的值。
        Property description:
        定义当拖动手势进入 Node时要调用的功能。

      • getOnDragEntered

        public final EventHandler<? super DragEvent> getOnDragEntered​()
        获取属性onDragEntered的值。
        Property description:
        定义当拖动手势进入 Node时要调用的功能。

      • onDragEnteredProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragEnteredProperty​()
        定义当拖动手势进入 Node时要调用的功能。
        另请参见：
        getOnDragEntered() ， setOnDragEntered(EventHandler)

      • setOnDragExited

        public final void setOnDragExited​(EventHandler<? super DragEvent> value)
        设置属性onDragExited的值。
        Property description:
        定义当拖动手势退出 Node时要调用的函数。

      • getOnDragExited

        public final EventHandler<? super DragEvent> getOnDragExited​()
        获取属性onDragExited的值。
        Property description:
        定义当拖动手势退出 Node时要调用的函数。

      • onDragExitedProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragExitedProperty​()
        定义当拖动手势退出 Node时要调用的函数。
        另请参见：
        getOnDragExited() ， setOnDragExited(EventHandler)

      • setOnDragOver

        public final void setOnDragOver​(EventHandler<? super DragEvent> value)
        设置属性onDragOver的值。
        Property description:
        定义当这个 Node拖动手势进度时要调用的函数。

      • getOnDragOver

        public final EventHandler<? super DragEvent> getOnDragOver​()
        获取属性onDragOver的值。
        Property description:
        定义当这个 Node拖动手势进度时要调用的函数。

      • onDragOverProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragOverProperty​()
        定义当这个 Node拖动手势进度时要调用的函数。
        另请参见：
        getOnDragOver() ， setOnDragOver(EventHandler)

      • setOnDragDropped

        public final void setOnDragDropped​(EventHandler<? super DragEvent> value)
        设置属性onDragDropped的值。
        Property description:
        定义在拖放手势时，在此Node上释放鼠标按钮时要调用的功能。 在DragEvent的dragboard中传输数据应发生在此功能中。

      • getOnDragDropped

        public final EventHandler<? super DragEvent> getOnDragDropped​()
        获取属性onDragDropped的值。
        Property description:
        定义在拖放手势时，在此Node上释放鼠标按钮时要调用的功能。 在DragEvent的dragboard中的数据传输应该发生在此功能中。

      • onDragDroppedProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragDroppedProperty​()
        定义当在拖放手势时释放鼠标按钮Node时要调用的功能。 在DragEvent的dragboard中的数据传输应该发生在这个功能中。
        另请参见：
        getOnDragDropped() ， setOnDragDropped(EventHandler)

      • setOnDragDone

        public final void setOnDragDone​(EventHandler<? super DragEvent> value)
        设置属性onDragDone的值。
        Property description:
        当这个Node是一个拖放手势源，它的数据被放在放置目标上之后，定义要调用的函数。 该事件的transferMode显示刚刚发生的下降目标。 如果transferMode的值为MOVE ，则源可以清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 甲transferMode具有值NONE指示拖放手势期间没有数据被转移。

      • getOnDragDone

        public final EventHandler<? super DragEvent> getOnDragDone​()
        获取属性onDragDone的值。
        Property description:
        定义当这个Node是数据放在放置目标上之后的拖放手势源时要调用的函数。 事件的transferMode显示刚刚发生的下降目标。 如果transferMode的值为MOVE ，则源可以清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 甲transferMode具有值NONE指示拖放手势期间没有数据被转移。

      • onDragDoneProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragDoneProperty​()
        当这个Node是一个拖放手势源，它的数据被放在放置目标上之后，定义要调用的函数。 该事件的transferMode显示刚刚发生的下降目标。 如果transferMode的值为MOVE ，则源可以清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 甲transferMode具有值NONE指示拖放手势期间没有数据被转移。
        另请参见：
        getOnDragDone() ， setOnDragDone(EventHandler)

      • startDragAndDrop

        public Dragboard startDragAndDrop​(TransferMode... transferModes)
        确认一个潜在的拖放手势，在这Node被认可。 只能从DRAG_DETECTED事件处理程序调用。 返回的Dragboard用于在拖放手势期间传输数据。 将Node的数据放在Dragboard上也可以将此Node标识为拖放手势的来源。 有关拖放手势的更多详细信息，请参见DragEvent 。
        参数
        transferModes - 支持的 TransferMode （ Node
        结果
        A Dragboard将此 Node的数据放在上面
        异常
        IllegalStateException - 如果此时无法启动拖放（在 DRAG_DETECTED事件处理之外调用或此节点不在场景中）。
        另请参见：
        DragEvent

      • startFullDrag

        public void startFullDrag​()
        开始一个完整的按下 - 拖动释放手势与该节点作为手势源。 只能从一个DRAG_DETECTED鼠标事件处理程序调用此方法。 有关拖动手势的更多详细信息，请参见MouseEvent和MouseDragEvent的概述。
        异常
        IllegalStateException - 如果此时无法启动完全按下 - 拖动释放手势（在 DRAG_DETECTED事件处理之外调用或此节点不在场景中）。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        MouseEvent ， MouseDragEvent

      • setManaged

        public final void setManaged​(boolean value)
        设置管理的属性的值。
        Property description:
        定义该节点的布局是否由父节点管理。 如果节点被管理，它的父节点将将节点的几何因子归因于其自己的首选大小和layoutBounds计算，并将在场景的布局过程中进行排列。 如果受管节点的layoutBounds更改，它将自动触发将场景图转发到最近的布局根（通常是场景的根节点）。

        如果节点不受管理，其父级将忽略两个首选大小的计算和布局中的子节点。 layoutBounds中的更改将不会在其上方触发中继。 如果非托管节点类型为Parent ，则它将作为“布局根”，这意味着在其下方调用Parent.requestLayout()将仅导致由节点生根的分支被中继，从而将布局更改隔离到该根和下面。 应用程序负责设置非托管节点的大小和位置。

        默认情况下所有节点都被管理。

      • isManaged

        public final boolean isManaged​()
        获取管理的属性的值。
        Property description:
        定义该节点的布局是否由父节点管理。 如果节点被管理，那么父节点会将节点的几何因子归因于其自己的首选大小和layoutBounds计算，并将在场景布局通过期间进行排列。 如果受管节点的layoutBounds更改，它将自动触发将场景图转发到最近的布局根（通常是场景的根节点）。

        如果节点不受管理，其父级将忽略两个首选大小的计算和布局中的子节点。 layoutBounds中的更改将不会在其上方触发中继。 如果非托管节点的类型为Parent ，则它将作为“布局根”，这意味着在其下方调用Parent.requestLayout()将仅导致由节点生根的分支被中继，从而将布局更改隔离到该根和下面。 应用程序负责设置非托管节点的大小和位置。

        默认情况下所有节点都被管理。

      • managedProperty

        public final BooleanProperty managedProperty​()
        定义该节点的布局是否由父节点管理。 如果节点被管理，那么它的父节点会将节点的几何因子归因于自己的首选大小和layoutBounds计算，并在场景的布局过程中将其排除。 如果受管节点的layoutBounds更改，它将自动触发将场景图转发到最近的布局根（通常是场景的根节点）。

        如果节点不受管理，其父级将忽略两个首选大小的计算和布局中的子节点。 layoutBounds中的更改将不会在其上方触发中继。 如果非托管节点的类型为Parent ，则它将作为“布局根”，这意味着对其下的Parent.requestLayout()的调用将仅导致由节点生根的分支被中继，从而将布局更改隔离到该根和下面。 应用程序负责设置非托管节点的大小和位置。

        默认情况下所有节点都被管理。

        另请参见：
        isManaged() ， setManaged(boolean)

      • setLayoutX

        public final void setLayoutX​(double value)
        设置属性layoutX的值。
        Property description:
        定义添加到此Node的转换中用于布局目的的转换的x坐标。 该值应该计算为将节点的位置从当前的layoutBounds minX位置（可能不为0）调整到所需位置所需的偏移量。

        例如，如果textnode应该位于finalX

           textnode.setLayoutX(finalX - textnode.getLayoutBounds().getMinX());

        不能减去layoutBounds minX可能导致节点错位。 relocate(x, y)方法将自动进行正确的计算，通常直接用于设置layoutX。

        节点的最终翻译将计算为layoutX + translateX ，其中layoutX建立节点的稳定位置， translateX可选地对该位置进行动态调整。

        如果节点被管理并且有一个Region作为其父节点，则布局区域将根据其自己的布局策略设置layoutX 。 如果节点由Group进行非管理或父控 ，则应用程序可以直接设置layoutX来定位它。

      • getLayoutX

        public final double getLayoutX​()
        获取属性layoutX的值。
        Property description:
        定义添加到Node的转换中用于布局目的的转换的x坐标。 该值应该计算为将节点的位置从当前的layoutBounds minX位置（可能不为0）调整到所需位置所需的偏移量。

        例如，如果textnode应该位于finalX

           textnode.setLayoutX(finalX - textnode.getLayoutBounds().getMinX());

        不能减去layoutBounds minX可能导致节点错位。 relocate(x, y)方法将自动进行正确的计算，通常直接用于设置layoutX。

        节点的最终翻译将计算为layoutX + translateX ，其中layoutX建立节点的稳定位置， translateX可选地对该位置进行动态调整。

        如果节点被管理，并且有一个Region作为其父节点，则布局区域将根据其自己的布局策略设置layoutX 。 如果节点不是由Group管理或父节点，那么应用程序可以直接设置layoutX来定位它。

      • layoutXProperty

        public final DoubleProperty layoutXProperty​()
        定义为了布局目的而添加到此Node的转换中的转换的x坐标。 该值应计算为将节点的位置从当前的layoutBounds minX位置（可能不为0）调整到所需位置所需的偏移量。

        例如，如果textnode应该位于finalX

           textnode.setLayoutX(finalX - textnode.getLayoutBounds().getMinX());

        不能减去layoutBounds minX可能会导致节点错位。 relocate(x, y)方法将自动进行正确的计算，通常直接用于设置layoutX。

        节点的最终翻译将计算为layoutX + translateX ，其中layoutX建立节点的稳定位置，并且translateX可选地对该位置进行动态调整。

        如果节点被管理，并以其父节点为Region ，则布局区域将根据自己的布局策略设置layoutX 。 如果节点由Group进行非管理或父控 ，则应用程序可以直接设置layoutX来定位它。

        另请参见：
        getLayoutX() ， setLayoutX(double)

      • setLayoutY

        public final void setLayoutY​(double value)
        设置属性layoutY的值。
        Property description:
        定义添加到此Node的转换中用于布局目的的转换的y坐标。 该值应该计算为将节点的位置从当前的layoutBounds minY位置（可能不为0）调整到所需位置所需的偏移量。

        例如，如果textnode应该位于finalY

           textnode.setLayoutY(finalY - textnode.getLayoutBounds().getMinY());

        不能减去layoutBounds minY可能会导致节点错位。 relocate(x, y)方法将自动进行正确的计算，通常直接用于设置layoutY。

        该节点的最终翻译将计算为layoutY + translateY ，其中layoutY建立节点的稳定位置，而translateY可选地对该位置进行动态调整。

        如果节点被管理，并以其父级为Region ，则该区域将根据其自己的布局策略设置layoutY 。 如果节点由Group进行非管理或父控 ，则应用程序可以直接设置layoutY来定位它。

      • getLayoutY

        public final double getLayoutY​()
        获取属性layoutY的值。
        Property description:
        定义添加到此Node的转换中用于布局目的的转换的y坐标。 该值应该计算为将节点的位置从当前的layoutBounds minY位置（可能不为0）调整到所需位置所需的偏移量。

        例如，如果textnode应该位于finalY

           textnode.setLayoutY(finalY - textnode.getLayoutBounds().getMinY());

        不能减去layoutBounds minY可能导致节点错位。 relocate(x, y)方法将自动进行正确的计算，通常直接用于设置layoutY。

        该节点的最终翻译将计算为layoutY + translateY ，其中layoutY建立节点的稳定位置，而translateY可选地对该位置进行动态调整。

        如果节点被管理，并且有一个Region作为其父节点，则该区域将根据其自己的布局策略设置layoutY 。 如果节点不是由Group管理或父节点，则应用程序可以直接设置layoutY来定位它。

      • layoutYProperty

        public final DoubleProperty layoutYProperty​()
        定义添加到此Node的转换中用于布局目的的转换的y坐标。 该值应该计算为将节点的位置从当前的layoutBounds minY位置（可能不为0）调整到所需位置所需的偏移量。

        例如，如果textnode应该位于finalY

           textnode.setLayoutY(finalY - textnode.getLayoutBounds().getMinY());

        不能减去layoutBounds minY可能导致节点错位。 relocate(x, y)方法将自动进行正确的计算，一般应直接用于设置layoutY。

        节点的最终翻译将计算为layoutY + translateY ，其中layoutY建立节点的稳定位置， translateY可选地对该位置进行动态调整。

        如果节点被管理并且以其父节点为Region ，则该区域将根据其自己的布局策略设置layoutY 。 如果节点是非管理的或由Group父节点，那么应用程序可以直接设置layoutY来定位它。

        另请参见：
        getLayoutY() ， setLayoutY(double)

      • relocate

        public void relocate​(double x,
                     double y)
        设置节点的layoutX和layoutY转换属性，以便将该节点重定位到父节点的x，y位置。

        该方法不会改变translateX或translateY，如果还设置了这个方法，它将被添加到layoutX和layoutY中，根据相应的数量调整最终位置。

        参数
        x - 目标x坐标位置
        y - 目标y坐标位置

      • isResizable

        public boolean isResizable​()
        指示该节点是否可以由父节点调整大小。 如果此方法返回true，那么在布局过程中，父节点将通过调用node.resize（width，height）来调整节点的大小（理想情况下在其大小范围内）。 所有区域，控件和WebView都是可调整大小的类，它们在应用所有尺寸和CSS样式信息后，依赖于他们的父母在布局期间调整大小。

        如果此方法返回false，那么在布局期间父（）不能调整它大小（resize（）是一个no-op），并且它应该返回其layoutBounds的最小，首选和最大大小。 组，文本和所有形状都不能调整大小，因此通过设置适当的属性（例如矩形的宽度/高度，文本上的文本等），依赖于应用程序来建立其大小。 在布局期间，仍然可以重新定位不可调整大小的节点。

        结果
        该布局期间该节点类型是否可以由其父节点调整大小
        另请参见：
        getContentBias() ， minWidth(double) ， minHeight(double) ， prefWidth(double) ， prefHeight(double) ， maxWidth(double) ， maxHeight(double) ， resize(double, double) ， getLayoutBounds()

      • getContentBias

        public Orientation getContentBias​()
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        结果
        width / height依赖的方向，如果没有则为null
        另请参见：
        isResizable() ， minWidth(double) ， minHeight(double) ， prefWidth(double) ， prefHeight(double) ， maxWidth(double) ， maxHeight(double)

      • minWidth

        public double minWidth​(double height)
        返回节点在布局计算中使用的最小宽度。 如果节点可调整大小，则其父值不应该调整其小于此值的宽度。 如果节点不可调整，则返回其layoutBounds宽度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有垂直的内容偏置，则呼叫者应该传入最小宽度应该基于的高度值。 如果节点具有水平或空的内容偏置，则调用者应该传入-1。

        具有垂直内容偏置的节点子类应该尊重height参数，不管是-1还是正值。 所有其他子类可以忽略height参数（这可能是-1）。

        如果节点的maxWidth(double)低于此数字，则优先级为minWidth 。 这意味着Node不应该调整大小以下minWidth 。

        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        布局期间节点应该调整大小的最小宽度。 结果永远不会是NaN，也不会是负面的。
        另请参见：
        isResizable() ， getContentBias()

      • minHeight

        public double minHeight​(double width)
        返回节点在布局计算中使用的最小高度。 如果节点可调整大小，则父节点不应该将其高度调整为小于该值的大小。 如果节点不可调整大小，返回其layoutBounds高度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有水平的内容偏置，则呼叫者应该传递最小高度应该基于的宽度值。 如果节点具有垂直或空的内容偏置，则调用者应该传入-1。

        具有水平内容偏置的节点子类应该符合宽度参数，不管是-1还是正值。 所有其他子类可以忽略width参数（这可能是-1）。

        如果节点的maxHeight(double)低于此数字，则优先级为minHeight 。 这意味着节点不应该被调整至低于minHeight 。

        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        在布局期间节点应该调整大小的最小高度结果将不会是NaN，也不会是负数。
        另请参见：
        isResizable() ， getContentBias()

      • prefWidth

        public double prefWidth​(double height)
        返回节点在布局计算中使用的首选宽度。 如果节点可调整大小，其父级应将该值视为节点在其范围内的理想宽度。 如果节点不可调整，只需返回其layoutBounds宽度，该宽度应该被视为节点的刚性宽度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有垂直的内容偏置，则呼叫者应该传入首选宽度应该基于的高度值。 如果节点具有水平或空的内容偏置，则调用者应该传入-1。

        具有垂直内容偏置的节点子类应该尊重height参数，不管是-1还是正值。 所有其他子类可以忽略height参数（这可能是-1）。

        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        节点在布局期间应该调整大小的首选宽度结果将不会是NaN，也不会是负数。
        另请参见：
        isResizable() ，
getContentBias() ，
autosize()

      • prefHeight

        public double prefHeight​(double width)
        返回节点的首选高度，用于布局计算。 如果节点可调整大小，其父级应该将该值视为节点在其范围内的理想高度。 如果节点不可调整大小，则只返回其layoutBounds高度，该高度应该被视为节点的刚性高度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有水平的内容偏置，则呼叫者应该传入首选高度应该基于的宽度值。 如果节点具有垂直或空的内容偏置，则调用者应该传入-1。

        具有水平内容偏倚的节点子类应该符合高度参数，不管是-1还是正值。 所有其他子类可以忽略height参数（这可能是-1）。

        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        节点在布局期间应该调整大小的首选高度结果将不会是NaN，也不会是负数。
        另请参见：
        getContentBias() ， autosize()

      • maxWidth

        public double maxWidth​(double height)
        返回节点在布局计算中使用的最大宽度。 如果节点可调整大小，其父级不应该调整其大于此值的宽度。 Double.MAX_VALUE的值表示父节点可以将节点的宽度扩展到超出其优先级而不受限制。

        如果节点不可调整，则返回其layoutBounds宽度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有垂直的内容偏置，则呼叫者应该传入最大宽度应该基于的高度值。 如果节点具有水平或空的内容偏置，则调用者应该传入-1。

        具有垂直内容偏置的节点子类应该尊重height参数，不管是-1还是正值。 所有其他子类可以忽略height参数（这可能是-1）。

        如果节点的minWidth(double)较大，则应优先于maxWidth 。 这意味着节点不应该被调整至低于minWidth 。

        参数
        height - 如果最大宽度取决于它应该使用的高度
        结果
        节点在布局期间应该调整大小的最大宽度结果将不会是NaN，也不会是负数。
        另请参见：
        isResizable() ， getContentBias()

      • maxHeight

        public double maxHeight​(double width)
        返回节点在布局计算中使用的最大高度。 如果节点可调整大小，其父级不应该调整其大于此值的任何大小。 Double.MAX_VALUE的值表示父节点可能将节点的高度超出其首选而不受限制。

        如果节点不可调整大小，返回其layoutBounds高度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有水平的内容偏置，则呼叫者应该传入最大高度应该基于的宽度值。 如果节点具有垂直或空的内容偏置，则调用者应该传入-1。

        具有水平内容偏置的节点子类应该符合宽度参数，不管是-1还是正值。 所有其他子类可以忽略width参数（这可能是-1）。

        如果节点的minHeight(double)较大，则应优先于maxHeight 。 这意味着Node不应该调整大小在minHeight以下。

        参数
        width - 如果最大高度取决于应该使用的宽度
        结果
        节点在布局期间应该调整大小的最大高度结果将不会是NaN，也不会是负数。
        另请参见：
        isResizable() ， getContentBias()

      • resize

        public void resize​(double width,
                   double height)
        如果节点可调整大小，将其布局边界设置为指定的宽度和高度。 如果节点不能调整大小，这个方法是无效的。

        这个方法通常只能通过parentChildren（）方法由父节点调用。 所有Parent类将自动调整大小可调整大小的子项，因此应用程序直接进行的调整大小将被节点的父级覆盖，除非子级不受管理。

        父母负责确保宽度和高度值落在可调整大小的节点的首选范围内。 如果父级只需要将节点的大小调整为其首选大小，则可以使用autosize（）方法。

        参数
        width - 目标布局的边界宽度
        height - 目标布局界定高度
        另请参见：
        isResizable() ， getContentBias() ， autosize() ， minWidth(double) ， minHeight(double) ， prefWidth(double) ， prefHeight(double) ， maxWidth(double) ， maxHeight(double) ， getLayoutBounds()

      • autosize

        public final void autosize​()
        如果节点可调整大小，则将其布局边界设置为当前优选的宽度和高度。 如果节点不能调整大小，这个方法是无效的。

        该方法自动查询节点的内容偏倚，如果是水平方向，则会传递节点的首选宽度以获得首选高度; 如果是垂直的，将会通过节点的首选高度来获取宽度，如果为空则将独立计算首选的宽度/高度。

        另请参见：
        isResizable() ， getContentBias()

      • resizeRelocate

        public void resizeRelocate​(double x,
                           double y,
                           double width,
                           double height)
        如果节点可调整大小，将其布局边界设置为指定的宽度和高度。 如果节点不可调整大小，则跳过调整大小步骤。

        一旦节点被调整大小（如果可调整大小），则设置节点的layoutX和layoutY转换属性，以便将其重定位到父坐标空间中的x，y。

        这个方法通常只能通过parentChildren（）方法由父节点调用。 所有Parent类将自动调整大小可调整大小的子项，因此应用程序直接进行的调整大小将被节点的父级覆盖，除非子级不受管理。

        父母负责确保宽度和高度值落在可调整大小的节点的首选范围内。 如果父节点只需要将节点的大小调整为其首选大小并重新定位，则可以使用autosize（）和relocate（）方法。

        参数
        x - 目标x坐标位置
        y - 目标y坐标位置
        width - 目标布局的边界宽度
        height - 目标布局界限高度
        另请参见：
        isResizable() ， getContentBias() ， autosize() ， minWidth(double) ， minHeight(double) ， prefWidth(double) ， prefHeight(double) ， maxWidth(double) ， maxHeight(double)

      • getBaselineOffset

        public double getBaselineOffset​()
        当基于与其他节点垂直对齐的节点的layoutBounds.minY位置时，“字母”（或“罗马”）基线偏移。 默认情况下，这可以返回BASELINE_OFFSET_SAME_AS_HEIGHT用于可调整大小的节点和layoutBounds高度，不可调整大小。 包含文本的子类应该覆盖此方法以返回其实际文本基线偏移量。
        结果
        对于不可调整大小的节点， textBounds.minY的文本基线偏移量为 BASELINE_OFFSET_SAME_AS_HEIGHT

      • computeAreaInScreen

        public double computeAreaInScreen​()
        返回以像素为单位投影到物理屏幕上的 Node区域。
        结果
        这个 Node的区域投影到物理屏幕上
        从以下版本开始：
        JavaFX 8.0

      • getBoundsInParent

        public final Bounds getBoundsInParent​()
        获取属性boundsInParent的值。
        Property description:
        这个Node的矩形边界包括它的变换。 boundsInParent是通过采取局部边界（由boundsInLocal定义）并应用通过设置以下附加变量创建的变换来计算的
        1. transforms ObservableList
        2. scaleX ， scaleY
        3. rotate
        4. layoutX ， layoutY
        5. translateX ， translateY

        结果范围将在概念上在Node的父节点的坐标空间中，但是节点不需要有父代来计算这些边界。

        请注意，此方法不考虑节点的可见性; 计算仅基于这个Node的几何。

        此属性将始终具有非空值。

        请注意，只要节点的几何结构发生更改，或者当以下任何一项更改时，boundsInParent将自动重新计算：转换ObservableList，translateX，translateY，layoutX，layoutY，scaleX，scaleY或rotate变量。 因此，将节点中的任何值绑定到依赖于此变量的表达式是一个错误。 例如，为了定位节点，形状的x或y变量或translateX，translateY不应该被绑定到boundsInParent。

      • boundsInParentProperty

        public final ReadOnlyObjectProperty<Bounds> boundsInParentProperty​()
        这个Node的矩形边界包括它的变换。 boundsInParent是通过采取局部边界（由boundsInLocal定义）并应用通过设置以下附加变量创建的变换来计算的
        1. transforms ObservableList
        2. scaleX ， scaleY
        3. rotate
        4. layoutX ， layoutY
        5. translateX ， translateY

        结果范围将在概念上在Node的父级的坐标空间中，但是该节点不需要有父代来计算这些边界。

        请注意，此方法不考虑节点的可见性; 该计算仅基于该Node的几何形状。

        此属性将始终具有非空值。

        请注意，只要节点的几何结构发生更改，或者当以下任何一项更改时，boundsInParent将自动重新计算：转换ObservableList，translateX，translateY，layoutX，layoutY，scaleX，scaleY或rotate变量。 因此，将节点中的任何值绑定到依赖于此变量的表达式是一个错误。 例如，为了定位节点，形状的x或y变量或translateX，translateY不应该被绑定到boundsInParent。

        另请参见：
        getBoundsInParent()

      • getBoundsInLocal

        public final Bounds getBoundsInLocal​()
        获取属性boundsInLocal的值。
        Property description:
        该节点未转换的局部坐标空间中的Node的矩形边界。 对于扩展Shape的节点，局部边界还将包括可能落在由位置和大小属性定义的形状几何体之外的非零行程所需的空间。 本地范围还将包含任何剪辑集clip以及设置为effect的效果。

        请注意，此方法不考虑节点的可见性; 该计算仅基于该Node的几何形状。

        此属性将始终具有非空值。

        请注意，只要节点的几何结构发生更改，boundsInLocal就会自动重新计算。 因此，将节点中的任何值绑定到依赖于此变量的表达式是一个错误。 例如，为了定位节点，形状的x或y变量不应该被绑定到boundsInLocal。

      • boundsInLocalProperty

        public final ReadOnlyObjectProperty<Bounds> boundsInLocalProperty​()
        该节点未转换的局部坐标空间中的Node的矩形边界。 对于扩展Shape的节点，局部边界还将包括可能落在由位置和大小属性定义的形状几何体之外的非零行程所需的空间。 本地范围还将包括任何剪辑集clip以及设置为effect的效果。

        请注意，此方法不考虑节点的可见性; 该计算仅基于这个Node的几何。

        此属性将始终具有非空值。

        请注意，只要节点的几何结构发生更改，boundsInLocal就会自动重新计算。 因此，将节点中的任何值绑定到依赖于此变量的表达式是一个错误。 例如，为了定位节点，形状的x或y变量不应该被绑定到boundsInLocal。

        另请参见：
        getBoundsInLocal()

      • getLayoutBounds

        public final Bounds getLayoutBounds​()
        获取属性layoutBounds的值。
        Property description:
        应该用于此节点的布局计算的矩形边界。 layoutBounds可能与节点的可视边界不同，并且根据节点类型不同地计算。

        如果该节点类型是可调整大小（ Region ， Control ，或WebView ），则layoutBounds中永远是0,0 width x height 。 如果该节点类型是不可调整大小（ Shape ， Text ，或Group ），则layoutBounds中计算基于所述节点的几何性质，并且不包括该节点的剪辑，效果或变换。 有关详细信息，请参阅各类课程文档

        需要注意的是layoutX ， layoutY ， translateX ，并translateY变量没有在layoutBounds。 这很重要，因为布局代码必须首先确定节点的当前大小和位置（使用layoutBounds），然后设置layoutX和layoutY以调整节点的翻译，以使其具有所需的布局位置。

        由于layoutBounds的计算通常与节点的几何变量相关联，因此将任何此类变量绑定到依赖于layoutBounds的表达式是一个错误。 例如，为了定位节点，不应将形状的x或y变量绑定到layoutBounds。

        layoutBounds永远不会为空。

      • layoutBoundsProperty

        public final ReadOnlyObjectProperty<Bounds> layoutBoundsProperty​()
        应该用于此节点的布局计算的矩形边界。 layoutBounds可能与节点的可视边界不同，并且根据节点类型而不同地计算。

        如果该节点类型是可调整大小（ Region ， Control ，或WebView ），则layoutBounds中永远是0,0 width x height 。 如果该节点类型是不可调整大小（ Shape ， Text ，或Group ），则layoutBounds中计算基于所述节点的几何性质，并且不包括该节点的剪辑，效果或变换。 有关详细信息，请参阅各类课程文档

        需要注意的是layoutX ， layoutY ， translateX ，并translateY变量没有在layoutBounds。 这很重要，因为布局代码必须首先确定节点的当前大小和位置（使用layoutBounds），然后设置layoutX和layoutY以调整节点的翻译，以使其具有所需的布局位置。

        因为layoutBounds的计算通常与节点的几何变量相关联，所以将任何这样的变量绑定到依赖于layoutBounds的表达式是一个错误。 例如，为了定位节点，不应将形状的x或y变量绑定到layoutBounds。

        layoutBounds永远不会为空。

        另请参见：
        getLayoutBounds()

      • contains

        public boolean contains​(double localX,
                        double localY)
        返回true如果给定的点（指定在局部坐标的此空间Node ）包含在此的形状内Node 。 请注意，这种方法不能看清; 测试是基于这个Node的几何。
        参数
        localX - 节点空间中点的x坐标
        localY - 节点空间中点的y坐标
        结果
        包含的结果为这个 Node

      • contains

        public boolean contains​(Point2D localPoint)
        返回true如果给定的点（指定在局部坐标的此空间Node ）包含在此的形状内Node 。 请注意，这种方法不能看清; 该测试仅基于该Node的几何形状。
        参数
        localPoint - 节点空间中的2D点
        结果
        包含的结果为这个 Node

      • intersects

        public boolean intersects​(double localX,
                          double localY,
                          double localWidth,
                          double localHeight)
        返回true如果给定的矩形（在指定在局部坐标的此空间Node ）相交此的形状Node 。 请注意，这种方法不能看清; 该测试仅基于该Node的几何形状。 此函数的默认行为只是检查给定坐标是否与局部边界相交。
        参数
        localX - 节点空间中矩形的x坐标
        localY - 节点空间中矩形的y坐标
        localWidth - 节点空间中矩形的宽度
        localHeight - 节点空间中矩形的高度
        结果
        这个相交结果为 Node

      • intersects

        public boolean intersects​(Bounds localBounds)
        返回true如果给定的范围（在当地指定的坐标这个空间Node ）相交这个形状Node 。 请注意，这种方法不能看清; 测试是基于这个Node的几何形状。 此函数的默认行为只是检查给定坐标是否与局部边界相交。
        参数
        localBounds - 界限
        结果
        这个相交结果为 Node

      • screenToLocal

        public Point2D screenToLocal​(double screenX,
                             double screenY)
        将来自该坐标空间中的点Screen这个局部坐标空间Node 。
        参数
        screenX - 屏幕上某个点的x坐标
        screenY - 屏幕上某个点的y坐标
        结果
        本节点的坐标坐标为null，如果节点不在一个Window 。 如果从本地到场景的转换是不可逆的，则返回空值。
        从以下版本开始：
        JavaFX 8.0

      • screenToLocal

        public Point2D screenToLocal​(Point2D screenPoint)
        将一个点从Screen的坐标空间转换为此Node的本地坐标空间。
        参数
        screenPoint - 屏幕上的一个点
        结果
        本节点的坐标坐标为null，如果节点不在一个Window 。 如果从本地到场景的转换是不可逆的，则返回空值。
        从以下版本开始：
        JavaFX 8.0

      • screenToLocal

        public Bounds screenToLocal​(Bounds screenBounds)
        将矩形从Screen的坐标空间转换为此Node的本地坐标空间。 仅在2D空间中返回合理的结果。
        参数
        screenBounds - 屏幕上的界限
        结果
        如果节点不在一个Window中 ，则在本地节点的空间中为空 。 如果从本地到场景的转换是不可逆的，则返回空值。
        从以下版本开始：
        JavaFX 8.0

      • sceneToLocal

        public Point2D sceneToLocal​(double x,
                            double y,
                            boolean rootScene)
        将一个点从场景的坐标空间转换为Node的局部坐标空间。 如果节点没有任何SubScene或rootScene设置为true，则参数为Scene ，节点返回的坐标为getScene() 。 Othwerwise，使用子序列坐标，这相当于调用sceneToLocal(double, double)
        参数
        x - x坐标
        y - y坐标
        rootScene - 即使节点位于子 rootScene ，是否应使用场景坐标
        结果
        点的本地坐标
        从以下版本开始：
        JavaFX 8u40

      • sceneToLocal

        public Point2D sceneToLocal​(Point2D point,
                            boolean rootScene)
        将一个点从场景的坐标空间转换为该Node的局部坐标空间。 如果节点没有任何SubScene或rootScene设置为true，那么参数是由getScene()返回的节点的Scene坐标。 Othwerwise，使用子序列坐标，这相当于调用sceneToLocal(javafx.geometry.Point2D)
        参数
        point - 关键
        rootScene - 即使节点位于子 rootScene ，是否应使用场景坐标
        结果
        点的本地坐标
        从以下版本开始：
        JavaFX 8u40

      • sceneToLocal

        public Bounds sceneToLocal​(Bounds bounds,
                           boolean rootScene)
        将场景的坐标空间的边界转换为此Node的局部坐标空间。 如果节点没有任何SubScene或rootScene设置为true，则参数在270715818635351的270715818685351坐标中返回getScene() 。 Othwerwise，使用子序列坐标，这相当于调用sceneToLocal(javafx.geometry.Bounds) 。

        由于3D界限无法转换为rootScene设置为true ，尝试转换3D界限将产生null 。

        参数
        bounds - 界限
        rootScene - 即使节点位于子 rootScene ，是否应使用场景坐标
        结果
        边界的局部坐标
        从以下版本开始：
        JavaFX 8u40

      • sceneToLocal

        public Point2D sceneToLocal​(double sceneX,
                            double sceneY)
        将一个点从场景的坐标空间转换为这个Node的局部坐标空间。 请注意，如果此节点位于SubScene中 ，则参数应位于子视图坐标中，而不是Scene 。
        参数
        sceneX - 场景上点的x坐标
        sceneY - 场景上点的y坐标
        结果
        本节点的坐标坐标为null，如果节点不在一个Window中 。 如果从本地到场景的转换是不可逆的，则返回空值。

      • sceneToLocal

        public Point2D sceneToLocal​(Point2D scenePoint)
        将一个点从场景的坐标空间转换为该Node的局部坐标空间。 请注意，如果此节点位于SubScene中 ，则参数应位于子视图坐标中，而不是Scene 。
        参数
        scenePoint - 场景上的一个点
        结果
        本地节点的坐标坐标，如果节点不在一个Window，则为null 。 如果从本地到场景的转换是不可逆的，则返回空值。

      • sceneToLocal

        public Point3D sceneToLocal​(Point3D scenePoint)
        将一个点从场景的坐标空间转换为该Node的局部坐标空间。 请注意，如果此节点位于SubScene中 ，则参数应位于子视图坐标中，而不是Scene 。
        参数
        scenePoint - 场景上的一个点
        结果
        本节点的坐标坐标为null，如果节点不在一个Window中 。 如果从本地到场景的转换是不可逆的，则返回空值。
        从以下版本开始：
        JavaFX 8.0

      • sceneToLocal

        public Point3D sceneToLocal​(double sceneX,
                            double sceneY,
                            double sceneZ)
        将一个点从场景的坐标空间转换为此Node的局部坐标空间。 请注意，如果此节点位于SubScene中 ，则参数应位于子视图坐标中，而不是Scene 。
        参数
        sceneX - 场景上点的x坐标
        sceneY - 场景上点的y坐标
        sceneZ - 场景上某个点的z坐标
        结果
        本节点的坐标坐标为null，如果节点不在一个Window中 。 如果从本地到场景的转换是不可逆的，则返回空值。
        从以下版本开始：
        JavaFX 8.0

      • sceneToLocal

        public Bounds sceneToLocal​(Bounds sceneBounds)
        将矩形从场景的坐标空间转换为Node的局部坐标空间。 请注意，如果此节点位于SubScene中 ，则参数应位于子视图坐标中，而不是Scene 。
        参数
        sceneBounds - 场景上的界限
        结果
        如果节点不在一个Window中 ，则在本地节点的空间中为空 。 如果从本地到场景的转换是不可逆的，则返回空值。

      • localToScreen

        public Point2D localToScreen​(double localX,
                             double localY)
        将一个点从该Node的局部坐标空间转换为其Screen的坐标空间。
        参数
        localX - 节点空间中点的x坐标
        localY - 节点空间中点的y坐标
        结果
        如果节点不在一个Window ，则该点的屏幕坐标为null或null
        从以下版本开始：
        JavaFX 8.0

      • localToScreen

        public Point2D localToScreen​(Point2D localPoint)
        将一个点从该Node的局部坐标空间转换为其Screen的坐标空间。
        参数
        localPoint - 节点空间中的一个点
        结果
        如果节点不在Window中 ，则该点的屏幕坐标为null或null
        从以下版本开始：
        JavaFX 8.0

      • localToScreen

        public Point2D localToScreen​(double localX,
                             double localY,
                             double localZ)
        将一个点从该Node的局部坐标空间转换为其Screen的坐标空间。
        参数
        localX - 节点空间中点的x坐标
        localY - 节点空间中点的y坐标
        localZ - 节点空间中点的z坐标
        结果
        如果节点不在一个Window中 ，则该点的屏幕坐标为null或null
        从以下版本开始：
        JavaFX 8.0

      • localToScreen

        public Point2D localToScreen​(Point3D localPoint)
        将一个点从该Node的局部坐标空间转换为其Screen的坐标空间。
        参数
        localPoint - 节点空间中的一个点
        结果
        如果节点不在Window中 ，则该点的屏幕坐标为null或null
        从以下版本开始：
        JavaFX 8.0

      • localToScreen

        public Bounds localToScreen​(Bounds localBounds)
        将此Node的局部坐标空间的Node转换为其Screen的坐标空间。
        参数
        localBounds - 节点空间中的边界
        结果
        如果节点不在一个Window中 ，屏幕坐标中的边界为null或null
        从以下版本开始：
        JavaFX 8.0

      • localToScene

        public Point2D localToScene​(double localX,
                            double localY)
        将一个点从该Node的局部坐标空间Node到其场景的坐标空间。 请注意，如果此节点在一个SubScene中 ，结果是在二次坐标坐标，而不是Scene 。
        参数
        localX - 节点空间中点的x坐标
        localY - 节点空间中点的y坐标
        结果
        点的场景坐标，如果节点不在Window，则为null

      • localToScene

        public Point2D localToScene​(Point2D localPoint)
        将这个点从这个Node的局部坐标空间Node到其场景的坐标空间。 请注意，如果此节点位于SubScene中 ，则结果位于子视图坐标中，而不是Scene 。
        参数
        localPoint - 节点空间中的一个点
        结果
        点的场景坐标，如果节点不在Window，则为null

      • localToScene

        public Point3D localToScene​(Point3D localPoint)
        将一个点从该Node的局部坐标空间转换为其场景的坐标空间。 请注意，如果此节点在一个SubScene中 ，结果是在二次坐标坐标，而不是Scene 。
        参数
        localPoint - 节点空间中的3D点
        结果
        在场景空间中变换的3D点
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        localToScene(javafx.geometry.Point3D, boolean)

      • localToScene

        public Point3D localToScene​(double x,
                            double y,
                            double z)
        将一个点从这个Node的局部坐标空间Node到其场景的坐标空间。 请注意，如果此节点在一个SubScene中 ，结果是在二次坐标坐标，而不是Scene 。
        参数
        x - 节点空间中点的x坐标
        y - 节点空间中点的y坐标
        z - 节点空间中点的z坐标
        结果
        在场景空间中变换的3D点
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        localToScene(double, double, double, boolean)

      • localToScene

        public Point3D localToScene​(Point3D localPoint,
                            boolean rootScene)
        将一个点从该Node的本地坐标空间转换为其场景的坐标空间。 如果节点没有任何SubScene或rootScene设置为true，则结果点为Scene ，节点返回的坐标为getScene() 。 Othwerwise，使用子序列坐标，这相当于调用localToScene(javafx.geometry.Point3D)
        参数
        localPoint - 局部坐标点
        rootScene - 即使节点在 rootScene ，是否应使用场景坐标
        结果
        转换点
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        localToScene(javafx.geometry.Point3D)

      • localToScene

        public Point3D localToScene​(double x,
                            double y,
                            double z,
                            boolean rootScene)
        将这个点从这个Node的局部坐标空间Node到其场景的坐标空间。 如果节点没有任何SubScene或rootScene设置为true，则结果点为Scene节点返回的坐标为getScene() 。 Othwerwise，使用子序列坐标，这相当于调用localToScene(double, double, double)
        参数
        x - 局部坐标点的x坐标
        y - 本地坐标点的y坐标
        z - 局部坐标点的z坐标
        rootScene - 即使节点位于子 rootScene ，是否应使用场景坐标
        结果
        转换点
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        localToScene(double, double, double)

      • localToScene

        public Point2D localToScene​(Point2D localPoint,
                            boolean rootScene)
        将一个点从该Node的局部坐标空间转换为其场景的坐标空间。 如果节点没有任何SubScene或rootScene设置为true，结果点在Scene的节点返回的坐标为getScene() 。 Othwerwise，使用子序列坐标，这相当于调用localToScene(javafx.geometry.Point2D)
        参数
        localPoint - 局部坐标点
        rootScene - 即使节点位于子 rootScene ，是否应使用场景坐标
        结果
        转换点
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        localToScene(javafx.geometry.Point2D)

      • localToScene

        public Point2D localToScene​(double x,
                            double y,
                            boolean rootScene)
        将一个点从这个Node的局部坐标空间Node到其场景的坐标空间。 如果节点没有任何SubScene或rootScene设置为true，则结果点为Scene节点返回的坐标为getScene() 。 Othwerwise，使用子序列坐标，这相当于调用localToScene(double, double)
        参数
        x - 局部坐标点的x坐标
        y - 本地坐标点的y坐标
        rootScene - 即使节点在 rootScene ，是否应使用场景坐标
        结果
        转换点
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        localToScene(double, double)

      • localToScene

        public Bounds localToScene​(Bounds localBounds,
                           boolean rootScene)
        将这个Node的局部坐标空间的Node转换为其场景的坐标空间。 如果节点没有任何SubScene或rootScene设置为true，结果边界将在Scene的Scene坐标中返回getScene() 。 Othwerwise，使用子序列坐标，这相当于调用localToScene(javafx.geometry.Bounds)
        参数
        localBounds - 局部坐标的边界
        rootScene - 即使节点位于子 rootScene ，是否应使用场景坐标
        结果
        转化界限
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        localToScene(javafx.geometry.Bounds)

      • localToScene

        public Bounds localToScene​(Bounds localBounds)
        将这个Node的局部坐标空间的Node转换为其场景的坐标空间。 请注意，如果此节点位于SubScene中 ，则结果位于子视图坐标中，而不是Scene 。
        参数
        localBounds - 在节点的空间中的边界
        结果
        场景中的边界坐标，如果节点不在Window，则为null
        另请参见：
        localToScene(javafx.geometry.Bounds, boolean)

      • parentToLocal

        public Point2D parentToLocal​(double parentX,
                             double parentY)
        将一个点从母体的坐标空间转换为此 Node的局部坐标空间。
        参数
        parentX - 父级空间中的x坐标
        parentY - 父级空间中的y坐标
        结果
        节点空间中的变换后的2D点

      • parentToLocal

        public Point2D parentToLocal​(Point2D parentPoint)
        将一个点从母体的坐标空间转换为该 Node的局部坐标空间。
        参数
        parentPoint - 父级空间中的2D点
        结果
        节点空间中的变换后的2D点

      • parentToLocal

        public Point3D parentToLocal​(Point3D parentPoint)
        将一个点从母体的坐标空间转换为该 Node的局部坐标空间。
        参数
        parentPoint将3D点放在父的空格中
        结果
        在Node的空间中变换的3D点
        从以下版本开始：
        JavaFX 8.0

      • parentToLocal

        public Point3D parentToLocal​(double parentX,
                             double parentY,
                             double parentZ)
        将一个点从父母的坐标空间转换为这个 Node的局部坐标空间。
        参数
        parentX - 父级空间中的x坐标
        parentY - 父空间中的y坐标
        parentZ - 父级空间中的z坐标
        结果
        在Node的空间中变换的3D点
        从以下版本开始：
        JavaFX 8.0

      • parentToLocal

        public Bounds parentToLocal​(Bounds parentBounds)
        将矩形从母体的坐标空间转换为此 Node的局部坐标空间。
        参数
        parentBounds - 父母空间中的界限
        结果
        节点空间中的变换界限

      • localToParent

        public Point2D localToParent​(double localX,
                             double localY)
        将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
        参数
        localX - 节点空间中点的x坐标
        localY - 节点空间中点的y坐标
        结果
        父母空间中转换的2D点

      • localToParent

        public Point2D localToParent​(Point2D localPoint)
        将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
        参数
        localPoint - 节点空间中的2D点
        结果
        父母空间中转换的2D点

      • localToParent

        public Point3D localToParent​(Point3D localPoint)
        将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
        参数
        localPoint - 节点空间中的3D点
        结果
        在父母的空间中转换的3D点
        从以下版本开始：
        JavaFX 8.0

      • localToParent

        public Point3D localToParent​(double x,
                             double y,
                             double z)
        将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
        参数
        x - 节点空间中点的x坐标
        y - 节点空间中点的y坐标
        z - 节点空间中点的z坐标
        结果
        在父母的空间中转换的3D点
        从以下版本开始：
        JavaFX 8.0

      • localToParent

        public Bounds localToParent​(Bounds localBounds)
        将此 Node的局部坐标空间的 Node转换为其父项的坐标空间。
        参数
        localBounds - 节点空间中的边界
        结果
        父母空间中的变化界限

      • viewOrderProperty

        public final DoubleProperty viewOrderProperty​()
        定义其父母中的Node的呈现和拣选顺序。

        此属性用于更改其父级中节点的呈现和拣选顺序，而无需重新排序父级的children列表。 例如，这可以用作实现透明度排序的更有效的方法。 为此，应用程序可以将每个节点的viewOrder值分配给该节点和查看器之间的计算距离。

        父母将通过其children减少viewOrder订单。 这意味着一个viewOrder较低的viewOrder将在一个较高的viewOrder的孩子viewOrder 。 如果两个孩子有相同的viewOrder ，父母将按照父母children列表中显示的顺序遍历它们。

        但是， viewOrder不会更改此节点在其父级中的布局和聚焦遍历顺序。 当进行布局或聚焦遍历时，父对象总是按顺序遍历其children列表。

        Default value:
        0.0
        从以下版本开始：
        9
        另请参见：
        getViewOrder() ， setViewOrder(double)

      • setViewOrder

        public final void setViewOrder​(double value)
        设置属性viewOrder的值。
        Property description:
        定义其父母中的Node的呈现和拣选顺序。

        此属性用于更改其父级中节点的呈现和拣配顺序，而无需重新排序父级的children列表。 例如，这可以用作实现透明度排序的更有效的方法。 为此，应用程序可以将每个节点的viewOrder值分配给该节点和查看器之间的计算距离。

        父母将通过其children减少viewOrder订单。 这意味着一个viewOrder较低的viewOrder将在一个viewOrder较高的孩子viewOrder 。 如果两个孩子有相同的viewOrder ，父母将按照他们在父母的children列表中显示的顺序遍历它们。

        但是， viewOrder不会在此父节点中更改此节点的布局和聚焦遍历顺序。 当进行布局或聚焦遍历时，父对象总是按顺序遍历其children列表。

        Default value:
        0.0
        从以下版本开始：
        9

      • getViewOrder

        public final double getViewOrder​()
        获取属性viewOrder的值。
        Property description:
        定义其父母中的Node的呈现和拣配顺序。

        此属性用于更改其父级中节点的呈现和拣配顺序，而无需重新排序父级的children列表。 例如，这可以用作实现透明度排序的更有效的方法。 为此，应用程序可以将每个节点的viewOrder值分配给该节点和查看器之间的计算距离。

        父母将通过其children减少viewOrder订单。 这意味着一个较小的viewOrder的孩子将在一个较高的viewOrder的孩子viewOrder 。 如果两个孩子有相同的viewOrder ，父母将按照父母children列表中显示的顺序遍历它们。

        但是， viewOrder不会在此父节点中更改此节点的布局和重点遍历顺序。 当进行布局或聚焦遍历时，父代总是按顺序遍历其children列表。

        Default value:
        0.0
        从以下版本开始：
        9

      • getTransforms

        public final ObservableList<Transform> getTransforms​()
        定义的ObservableList Transform个对象被应用到这个Node 。 变换的这个ObservableList施加之前translateX ， translateY ， scaleX ，和scaleY ， rotate个变换。
        Default value:
        空
        结果
        这个转换为这个 Node

      • setTranslateX

        public final void setTranslateX​(double value)
        设置属性translateX的值。
        Property description:
        定义添加到此Node的转换中的转换的x坐标。

        节点的最终翻译将计算为layoutX + translateX ，其中layoutX建立节点的稳定位置， translateX可选地对该位置进行动态调整。

        该变量可用于改变节点的位置而不会干扰其layoutBounds ，这使得它有助于动画化节点的位置。

        Default value:
        0

      • getTranslateX

        public final double getTranslateX​()
        获取属性translateX的值。
        Property description:
        定义添加到此Node的转换中的转换的x坐标。

        节点的最终翻译将计算为layoutX + translateX ，其中layoutX建立节点的稳定位置，并且translateX可选地对该位置进行动态调整。

        该变量可用于改变节点的位置，而不会影响其节点的位置layoutBounds 。

        Default value:
        0

      • translateXProperty

        public final DoubleProperty translateXProperty​()
        定义添加到此Node变换的转换的x坐标。

        节点的最终翻译将计算为layoutX + translateX ，其中layoutX建立节点的稳定位置， translateX可选地对该位置进行动态调整。

        该变量可用于改变节点的位置，而不会影响其layoutBounds ，这使得它有助于动画化节点的位置。

        Default value:
        0
        另请参见：
        getTranslateX() ， setTranslateX(double)

      • setTranslateY

        public final void setTranslateY​(double value)
        设置属性translateY的值。
        Property description:
        定义添加到此Node的转换中的转换的y坐标。

        节点的最终翻译将计算为layoutY + translateY ，其中layoutY建立节点的稳定位置， translateY可选地对该位置进行动态调整。

        该变量可用于改变节点的位置，而不会干扰其layoutBounds ，这使得它有助于动画化节点的位置。

        Default value:
        0

      • getTranslateY

        public final double getTranslateY​()
        获取属性translateY的值。
        Property description:
        定义添加到此Node的转换中的转换的y坐标。

        节点的最终翻译将计算为layoutY + translateY ，其中layoutY建立节点的稳定位置， translateY可选地对该位置进行动态调整。

        此变量可用于更改节点的位置，而不会影响其节点的位置layoutBounds 。

        Default value:
        0

      • translateYProperty

        public final DoubleProperty translateYProperty​()
        定义添加到此Node的转换中的转换的y坐标。

        该节点的最终翻译将计算为layoutY + translateY ，其中layoutY建立节点的稳定位置，而translateY可选地对该位置进行动态调整。

        该变量可用于改变节点的位置，而不会影响其节点的位置layoutBounds 。

        Default value:
        0
        另请参见：
        getTranslateY() ， setTranslateY(double)

      • setTranslateZ

        public final void setTranslateZ​(double value)
        设置属性translateZ的值。
        Property description:
        定义添加到该Node的变换坐标中的平移的Z坐标。 该值将被添加到由transforms ObservableList和layoutZ定义的任何翻译。

        该变量可用于改变节点的位置，而不会影响其布局边界，这使得它有助于动画化节点的位置。

        请注意，这是一个条件功能。 详见ConditionalFeature.SCENE3D 。

        Default value:
        0

      • getTranslateZ

        public final double getTranslateZ​()
        获取属性translateZ的值。
        Property description:
        定义添加到此Node的变换坐标中的平移的Z坐标。 该值将被添加到由transforms ObservableList和layoutZ定义的任何翻译。

        该变量可用于改变节点的位置，而不会影响其布局边界，这使得它有助于动画化节点的位置。

        请注意，这是一个条件功能。 详情请见ConditionalFeature.SCENE3D 。

        Default value:
        0

      • translateZProperty

        public final DoubleProperty translateZProperty​()
        定义添加到此Node的变换坐标中的平移的Z坐标。 该值将被添加到由transforms ObservableList和layoutZ定义的任何翻译。

        该变量可用于改变节点的位置，而不会影响其布局边界，这使得它有助于动画化节点的位置。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        0
        另请参见：
        getTranslateZ() ， setTranslateZ(double)

      • setScaleX

        public final void setScaleX​(double value)
        设置属性scaleX的值。
        Property description:
        定义坐标按照该Node沿着X轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，此比例因子不包括在layoutBounds中 ，这使得在考虑所有效果和转换后，整个节点的缩放是理想的。

        发生规模的枢轴点是未转化的layoutBounds的中心。

        Default value:
        1.0

      • getScaleX

        public final double getScaleX​()
        获取属性scaleX的值。
        Property description:
        定义坐标按照该Node的X轴对象对象的中心进行比例的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，该比例因子不包括在layoutBounds中 ，这使得它在理想的情况下，在考虑了所有效果和转换后，可以缩放整个节点。

        发生刻度的枢轴点是未转化的layoutBounds的中心。

        Default value:
        1.0

      • scaleXProperty

        public final DoubleProperty scaleXProperty​()
        定义坐标按照该Node的X轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，此比例因子不包括在layoutBounds中 ，这使得在考虑了所有效果和转换后，整个节点的缩放是理想的。

        发生刻度的枢轴点是未转化的layoutBounds的中心。

        Default value:
        1.0
        另请参见：
        getScaleX() ， setScaleX(double)

      • setScaleY

        public final void setScaleY​(double value)
        设置属性scaleY的值。
        Property description:
        定义坐标按照该Node的Y轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，此比例因子不包括在layoutBounds中 ，这使得它在理想的情况下，在考虑了所有效果和转换后，缩放整个节点。

        发生刻度的枢轴点是未转化的layoutBounds的中心。

        Default value:
        1.0

      • getScaleY

        public final double getScaleY​()
        获取属性scaleY的值。
        Property description:
        定义坐标按照该Node的Y轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，此缩放因子不包括在layoutBounds中 ，这使得在考虑所有效果和转换后，整个节点的缩放是理想的。

        发生规模的枢轴点是未转化的layoutBounds的中心。

        Default value:
        1.0

      • scaleYProperty

        public final DoubleProperty scaleYProperty​()
        定义坐标按照该Node的Y轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，该比例因子不包括在layoutBounds中 ，这使得它在所有效果和转换都被考虑之后非常适合缩放整个节点。

        尺度发生的枢轴点是未转化的layoutBounds的中心。

        Default value:
        1.0
        另请参见：
        getScaleY() ， setScaleY(double)

      • setScaleZ

        public final void setScaleZ​(double value)
        设置属性scaleZ的值。
        Property description:
        定义坐标按照该Node的Z轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，该比例因子不包括在layoutBounds中 ，这使得它在理想的情况下，在考虑了所有效果和转换后，可以缩放整个节点。

        发生刻度的枢轴点是通过采用boundsInLocal形成的矩形边界的中心，并应用transforms ObservableList中的所有变换。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        1.0

      • getScaleZ

        public final double getScaleZ​()
        获取属性scaleZ的值。
        Property description:
        定义坐标按照该Node的Z轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，此比例因子不包括在layoutBounds中 ，这使得在考虑了所有效果和转换后，对整个节点进行缩放是非常理想的。

        尺度发生的枢轴点是通过采用boundsInLocal形成的矩形边界的中心，并应用transforms ObservableList中的所有变换。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        1.0

      • scaleZProperty

        public final DoubleProperty scaleZProperty​()
        定义坐标按照该Node的Z轴的对象中心进行缩放的因子。 这用于手动或使用动画来拉伸或动画节点。

        默认情况下，此比例因子不包括在layoutBounds中 ，这使得它在理想的情况下，在考虑了所有效果和转换后，对整个节点进行缩放。

        发生刻度的枢轴点是通过采用boundsInLocal形成的矩形边界的中心，并在transforms ObservableList中应用所有变换。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        1.0
        另请参见：
        getScaleZ() ， setScaleZ(double)

      • setRotate

        public final void setRotate​(double value)
        设置属性rotate的值。
        Property description:
        定义关于Node中心的旋转角度，以度为单位。 这是用来旋转Node 。

        默认情况下，这个旋转因子不包括在layoutBounds中 ，这使得在考虑了所有效果和变换之后，它是理想的旋转整个节点。

        旋转发生的枢轴点是未转换的layoutBounds的中心。

        请注意，由于枢轴点计算为此Node的布局边界的中心，对布局边界的任何更改将导致枢轴点更改，这可能会移动对象。 对于叶节点，几何的任何更改将导致布局边界更改。 对于组节点，对其任何子项的任何更改（包括对子组的几何，剪辑，效果，位置，方向或比例的更改）都将导致组的布局界限发生更改。 如果不需要枢纽点的这种移动，应用程序应改为使用节点的transforms ObservableList，并添加一个具有用户可指定的枢轴点的Rotate变换。

        Default value:
        0.0

      • getRotate

        public final double getRotate​()
        获取属性旋转的值。
        Property description:
        定义关于Node中心的旋转角度，以度为单位。 这是用来旋转Node 。

        默认情况下，这个旋转因子不包括在layoutBounds中 ，这使得在考虑了所有效果和转换后，整个节点的旋转是理想的。

        旋转发生的枢轴点是未转化的layoutBounds的中心。

        请注意，由于枢轴点计算为此Node的布局边界的中心，对布局边界的任何更改将导致枢轴点更改，这可以移动对象。 对于叶节点，几何的任何更改将导致布局边界更改。 对于组节点，对其任何子项的任何更改（包括对子组的几何，剪辑，效果，位置，方向或比例的更改）都将导致组的布局界限发生更改。 如果不需要枢轴点的这种移动，应用程序应改为使用节点的transforms ObservableList，并添加一个Rotate变换，它具有用户指定的枢轴点。

        Default value:
        0.0

      • rotateProperty

        public final DoubleProperty rotateProperty​()
        定义关于Node中心的旋转角度，以度为单位。 这是用来旋转Node 。

        默认情况下，这个旋转因子不包括在layoutBounds中 ，这使得在考虑了所有效果和转换之后，它是理想的旋转整个节点。

        旋转发生的枢轴点是未转化的layoutBounds的中心。

        请注意，由于枢轴点计算为此Node的布局边界的中心，对布局边界的任何更改将导致枢轴点更改，这可能会移动对象。 对于叶节点，几何的任何更改将导致布局边界更改。 对于组节点，对其任何子项的任何更改（包括对子组的几何，剪辑，效果，位置，方向或比例的更改）都将导致组的布局界限发生更改。 如果不需要枢纽点的这种移动，应用程序应该使用节点的transforms ObservableList，并添加一个具有用户可指定的枢轴点的Rotate变换。

        Default value:
        0.0
        另请参见：
        getRotate() ， setRotate(double)

      • setRotationAxis

        public final void setRotationAxis​(Point3D value)
        设置属性rotateAxis的值。
        Property description:
        定义Node的旋转轴。

        请注意，这是一个条件功能。 详见ConditionalFeature.SCENE3D 。

        Default value:
        Rotate.Z_AXIS

      • getRotationAxis

        public final Point3D getRotationAxis​()
        获取属性rotateAxis的值。
        Property description:
        定义Node的旋转轴。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        Rotate.Z_AXIS

      • rotationAxisProperty

        public final ObjectProperty<Point3D> rotationAxisProperty​()
        定义Node的旋转轴。

        请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        Rotate.Z_AXIS
        另请参见：
        getRotationAxis() ， setRotationAxis(Point3D)

      • localToParentTransformProperty

        public final ReadOnlyObjectProperty<Transform> localToParentTransformProperty​()
        保存计算的本地到父变换的仿射变换。 这是这个节点中所有变换的并置，包括所有的方便变换。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getLocalToParentTransform()

      • getLocalToParentTransform

        public final Transform getLocalToParentTransform​()
        获取属性localToParentTransform的值。
        Property description:
        保存计算的本地到父变换的仿射变换。 这是这个节点中所有变换的并置，包括所有的方便变换。
        从以下版本开始：
        JavaFX 2.2

      • localToSceneTransformProperty

        public final ReadOnlyObjectProperty<Transform> localToSceneTransformProperty​()
        拥有计算的局部到场景变换的仿射变换。 这是这个节点的父节点和这个节点中的所有变换的并置，包括到根节点的所有方便变换。 如果此节点在SubScene中 ，则此属性表示转换为subscene，而不是根场景。

        请注意，当您注册侦听器或绑定到此属性时，它需要监听所有父进程对根节点的无效。 这意味着在许多节点上注册此属性的侦听器可能会对其父母中的转换更改的性能产生负面影响。

        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getLocalToSceneTransform()

      • getLocalToSceneTransform

        public final Transform getLocalToSceneTransform​()
        获取属性localToSceneTransform的值。
        Property description:
        拥有计算的局部到场景变换的仿射变换。 这是这个节点的父节点和这个节点中的所有变换的并置，包括到根节点的所有方便变换。 如果此节点位于SubScene中 ，则此属性表示转换为次要素，而不是根场景。

        请注意，当您注册侦听器或绑定到此属性时，它需要监听所有父进程对根节点的无效。 这意味着在许多节点上注册此属性的侦听器可能会对其父母中的转换更改的性能产生负面影响。

        从以下版本开始：
        JavaFX 2.2

      • setNodeOrientation

        public final void setNodeOrientation​(NodeOrientation orientation)
        设置属性nodeOrientation的值。
        Property description:
        *组件方向属性* *

      • getNodeOrientation

        public final NodeOrientation getNodeOrientation​()
        获取属性nodeOrientation的值。
        Property description:
        *组件方向属性* *

      • nodeOrientationProperty

        public final ObjectProperty<NodeOrientation> nodeOrientationProperty​()
        属性保存NodeOrientation。

        节点方向描述节点内视觉数据的流动。 在英语世界中，视觉数据通常从左到右流动。 在阿拉伯语或希伯来语世界，视觉数据从右到左流动。 这与两个世界的文本阅读顺序一致。 默认值是从左到右。

        结果
        NodeOrientation
        从以下版本开始：
        JavaFX 8.0

      • getEffectiveNodeOrientation

        public final NodeOrientation getEffectiveNodeOrientation​()
        获取属性effectiveNodeOrientation的值。
        Property description:
        节点的有效方向解决节点方向的继承，从左到右或从右到左返回。
        从以下版本开始：
        JavaFX 8.0

      • effectiveNodeOrientationProperty

        public final ReadOnlyObjectProperty<NodeOrientation> effectiveNodeOrientationProperty​()
        节点的有效方向解决节点方向的继承，从左到右或从右到左返回。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getEffectiveNodeOrientation()

      • usesMirroring

        public boolean usesMirroring​()
        确定当节点方向是从右到左时是否应该镜像节点。

        当一个节点被镜像时，原点会自动移动到右上角，导致节点布局孩子，并使用镜像转换从右到左绘制。 一些节点可能希望从右到左绘制，而不使用转换。 这些节点将会回复false并且不使用自动转换实现从右到左的方向。

        结果
        如果这个 Node应该镜像， Node true
        从以下版本开始：
        JavaFX 8.0

      • setMouseTransparent

        public final void setMouseTransparent​(boolean value)
        设置属性mouseTransparent的值。
        Property description:
        如果是true ，这个节点（和它的所有子节点）对于鼠标事件是完全透明的。 当选择鼠标事件的目标时， mouseTransparent设置为true节点及其子树将不被考虑。

      • isMouseTransparent

        public final boolean isMouseTransparent​()
        获取属性mouseTransparent的值。
        Property description:
        如果是true ，这个节点（连同所有的子节点）对于鼠标事件是完全透明的。 当选择鼠标事件的目标时， mouseTransparent设置为true节点及其子树将不被考虑。

      • mouseTransparentProperty

        public final BooleanProperty mouseTransparentProperty​()
        如果是true ，这个节点（和它的所有子节点）对于鼠标事件是完全透明的。 当选择鼠标事件的目标时， mouseTransparent设置为true节点及其子树将不被考虑。
        另请参见：
        isMouseTransparent() ， setMouseTransparent(boolean)

      • setHover

        protected final void setHover​(boolean value)
        设置属性悬停的值。
        Property description:
        这个Node是否被徘徊。 通常这是由于鼠标在节点上，尽管这可能是由于笔悬停在图形输入板或其他形式的输入上。

        请注意，当前实现的悬停依赖于鼠标进入和退出事件来确定此节点是否处于悬停状态; 这意味着目前仅在具有鼠标的系统上支持此功能。 未来的实现可以提供支持悬停的替代方式。

        Default value:
        假

      • isHover

        public final boolean isHover​()
        获取属性悬停的值。
        Property description:
        这Node是否正在徘徊。 通常这是由于鼠标在节点上，尽管这可能是由于笔悬停在图形输入板或其他形式的输入上。

        请注意，当前实现的悬停依赖于鼠标进入和退出事件来确定此节点是否处于悬停状态; 这意味着目前仅在具有鼠标的系统上支持此功能。 未来的实现可以提供支持悬停的替代方式。

        Default value:
        假

      • hoverProperty

        public final ReadOnlyBooleanProperty hoverProperty​()
        这个Node是否被徘徊。 通常这是由于鼠标在节点上，尽管这可能是由于笔悬停在图形输入板或其他形式的输入上。

        请注意，当前实现的悬停依赖于鼠标进入和退出事件来确定此节点是否处于悬停状态; 这意味着目前仅在具有鼠标的系统上支持此功能。 未来的实现可以提供支持悬停的替代方式。

        Default value:
        假
        另请参见：
        isHover() ， setHover(boolean)

      • setPressed

        protected final void setPressed​(boolean value)
        设置按下的属性的值。
        Property description:
        是否按下Node 。 通常，当主鼠标按钮处于关闭状态时，这是正确的，尽管子类可以定义其他鼠标按钮状态或键状态，以使节点“按下”。
        Default value:
        假

      • isPressed

        public final boolean isPressed​()
        获取按下的属性的值。
        Property description:
        是否按下Node 。 通常，当主鼠标按钮处于关闭状态时，这是正确的，尽管子类可以定义其他鼠标按钮状态或键状态，以使节点“按下”。
        Default value:
        假

      • pressedProperty

        public final ReadOnlyBooleanProperty pressedProperty​()
        是否按下Node 。 通常，当主鼠标按钮处于关闭状态时，这是正确的，尽管子类可以定义其他鼠标按钮状态或键状态，以使节点“按下”。
        Default value:
        假
        另请参见：
        isPressed() ， setPressed(boolean)

      • setOnContextMenuRequested

        public final void setOnContextMenuRequested​(EventHandler<? super ContextMenuEvent> value)
        设置属性onContextMenuRequested的值。
        Property description:
        定义在 Node上请求上下文菜单时要调用的函数。
        从以下版本开始：
        JavaFX 2.1

      • getOnContextMenuRequested

        public final EventHandler<? super ContextMenuEvent> getOnContextMenuRequested​()
        获取属性onContextMenuRequested的值。
        Property description:
        定义在 Node上请求上下文菜单时要调用的函数。
        从以下版本开始：
        JavaFX 2.1

      • onContextMenuRequestedProperty

        public final ObjectProperty<EventHandler<? super ContextMenuEvent>> onContextMenuRequestedProperty​()
        定义在 Node上请求上下文菜单时要调用的函数。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnContextMenuRequested() ， setOnContextMenuRequested(EventHandler)

      • setOnMouseClicked

        public final void setOnMouseClicked​(EventHandler<? super MouseEvent> value)
        设置属性onMouseClicked的值。
        Property description:
        定义在这个 Node上点击（按下并释放）鼠标按钮时要调用的功能。

      • getOnMouseClicked

        public final EventHandler<? super MouseEvent> getOnMouseClicked​()
        获取属性onMouseClicked的值。
        Property description:
        定义当在此 Node上单击（按下并释放）鼠标按钮时调用的功能。

      • onMouseClickedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseClickedProperty​()
        定义当这个 Node点击（按下并释放）鼠标按钮时要调用的功能。
        另请参见：
        getOnMouseClicked() ， setOnMouseClicked(EventHandler)

      • setOnMouseDragged

        public final void setOnMouseDragged​(EventHandler<? super MouseEvent> value)
        设置属性onMouseDragged的值。
        Property description:
        定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。

      • getOnMouseDragged

        public final EventHandler<? super MouseEvent> getOnMouseDragged​()
        获取属性onMouseDragged的值。
        Property description:
        定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。

      • onMouseDraggedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseDraggedProperty​()
        定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。
        另请参见：
        getOnMouseDragged() ， setOnMouseDragged(EventHandler)

      • setOnMouseEntered

        public final void setOnMouseEntered​(EventHandler<? super MouseEvent> value)
        设置属性onMouseEntered的值。
        Property description:
        定义当鼠标进入 Node时要调用的功能。

      • getOnMouseEntered

        public final EventHandler<? super MouseEvent> getOnMouseEntered​()
        获取属性onMouseEntered的值。
        Property description:
        定义当鼠标进入 Node时要调用的功能。

      • onMouseEnteredProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseEnteredProperty​()
        定义当鼠标进入 Node时要调用的功能。
        另请参见：
        getOnMouseEntered() ， setOnMouseEntered(EventHandler)

      • setOnMouseExited

        public final void setOnMouseExited​(EventHandler<? super MouseEvent> value)
        设置属性onMouseExited的值。
        Property description:
        定义当鼠标退出 Node时调用的函数。

      • getOnMouseExited

        public final EventHandler<? super MouseEvent> getOnMouseExited​()
        获取属性onMouseExited的值。
        Property description:
        定义当鼠标退出 Node时要调用的函数。

      • onMouseExitedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseExitedProperty​()
        定义当鼠标退出 Node时要调用的函数。
        另请参见：
        getOnMouseExited() ， setOnMouseExited(EventHandler)

      • setOnMouseMoved

        public final void setOnMouseMoved​(EventHandler<? super MouseEvent> value)
        设置属性onMouseMoved的值。
        Property description:
        定义当这个 Node鼠标光标移动时调用的功能，但没有按钮被按下。

      • getOnMouseMoved

        public final EventHandler<? super MouseEvent> getOnMouseMoved​()
        获取属性onMouseMoved的值。
        Property description:
        定义当这个 Node内的鼠标光标移动时调用的功能，但没有按钮被按下。

      • onMouseMovedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseMovedProperty​()
        定义当这个 Node内的鼠标光标移动时调用的功能，但没有按钮被按下。
        另请参见：
        getOnMouseMoved() ， setOnMouseMoved(EventHandler)

      • setOnMousePressed

        public final void setOnMousePressed​(EventHandler<? super MouseEvent> value)
        设置属性onMousePressed的值。
        Property description:
        定义在 Node上按下鼠标按钮时要调用的功能。

      • getOnMousePressed

        public final EventHandler<? super MouseEvent> getOnMousePressed​()
        获取属性onMousePressed的值。
        Property description:
        定义当在此 Node上按下鼠标按钮时要调用的功能。

      • onMousePressedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMousePressedProperty​()
        定义在 Node上按下鼠标按钮时要调用的功能。
        另请参见：
        getOnMousePressed() ， setOnMousePressed(EventHandler)

      • setOnMouseReleased

        public final void setOnMouseReleased​(EventHandler<? super MouseEvent> value)
        设置属性onMouseReleased的值。
        Property description:
        定义当这个 Node释放鼠标按钮时要调用的函数。

      • getOnMouseReleased

        public final EventHandler<? super MouseEvent> getOnMouseReleased​()
        获取属性onMouseReleased的值。
        Property description:
        定义当这个 Node释放鼠标按钮时要调用的函数。

      • onMouseReleasedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseReleasedProperty​()
        定义当这个 Node释放鼠标按钮时要调用的功能。
        另请参见：
        getOnMouseReleased() ， setOnMouseReleased(EventHandler)

      • setOnDragDetected

        public final void setOnDragDetected​(EventHandler<? super MouseEvent> value)
        设置属性onDragDetected的值。
        Property description:
        定义检测到拖动手势时要调用的功能。 这是开始拖放操作的正确位置。

      • getOnDragDetected

        public final EventHandler<? super MouseEvent> getOnDragDetected​()
        获取属性onDragDetected的值。
        Property description:
        定义检测到拖动手势时要调用的功能。 这是开始拖放操作的正确位置。

      • onDragDetectedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onDragDetectedProperty​()
        定义检测到拖动手势时要调用的功能。 这是开始拖放操作的正确位置。
        另请参见：
        getOnDragDetected() ， setOnDragDetected(EventHandler)

      • setOnMouseDragOver

        public final void setOnMouseDragOver​(EventHandler<? super MouseDragEvent> value)
        设置属性onMouseDragOver的值。
        Property description:
        定义当这个 Node内完全按下 Node释放手势时，要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • getOnMouseDragOver

        public final EventHandler<? super MouseDragEvent> getOnMouseDragOver​()
        获取属性onMouseDragOver的值。
        Property description:
        定义当这个 Node内完全按下 - 拖动释放手势时，要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • onMouseDragOverProperty

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragOverProperty​()
        定义当这个 Node内完全按下 Node释放手势时，要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragOver() ， setOnMouseDragOver(EventHandler)

      • setOnMouseDragReleased

        public final void setOnMouseDragReleased​(EventHandler<? super MouseDragEvent> value)
        设置属性onMouseDragReleased的值。
        Property description:
        定义当完全按下 - 拖动释放手势结束（通过释放鼠标按钮）在该 Node内时 Node 。
        从以下版本开始：
        JavaFX 2.1

      • getOnMouseDragReleased

        public final EventHandler<? super MouseDragEvent> getOnMouseDragReleased​()
        获取属性onMouseDragReleased的值。
        Property description:
        定义当完全按下 - 拖动释放手势结束（通过释放鼠标按钮）在该 Node内时 Node 。
        从以下版本开始：
        JavaFX 2.1

      • onMouseDragReleasedProperty

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragReleasedProperty​()
        定义当完全按下 - 拖动释放手势结束（通过释放鼠标按钮）在 Node内时 Node 。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragReleased() ， setOnMouseDragReleased(EventHandler)

      • setOnMouseDragEntered

        public final void setOnMouseDragEntered​(EventHandler<? super MouseDragEvent> value)
        设置属性onMouseDragEntered的值。
        Property description:
        定义当全按压拖动手势进入 Node时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • getOnMouseDragEntered

        public final EventHandler<? super MouseDragEvent> getOnMouseDragEntered​()
        获取属性onMouseDragEntered的值。
        Property description:
        定义当全按压拖动手势进入 Node时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • onMouseDragEnteredProperty

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragEnteredProperty​()
        定义当全按压拖动手势进入这个 Node时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragEntered() ， setOnMouseDragEntered(EventHandler)

      • setOnMouseDragExited

        public final void setOnMouseDragExited​(EventHandler<? super MouseDragEvent> value)
        设置属性onMouseDragExited的值。
        Property description:
        定义当完全按下 - 拖动释放手势离开这个 Node时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • getOnMouseDragExited

        public final EventHandler<? super MouseDragEvent> getOnMouseDragExited​()
        获取属性onMouseDragExited的值。
        Property description:
        定义当完全按下 - 拖动释放手势离开这个 Node时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • onMouseDragExitedProperty

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragExitedProperty​()
        定义当完全按下 - 拖动释放手势离开这个 Node时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragExited() ， setOnMouseDragExited(EventHandler)

      • setOnScrollStarted

        public final void setOnScrollStarted​(EventHandler<? super ScrollEvent> value)
        设置属性onScrollStarted的值。
        Property description:
        定义检测到滚动手势时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnScrollStarted

        public final EventHandler<? super ScrollEvent> getOnScrollStarted​()
        获取属性onScrollStarted的值。
        Property description:
        定义检测到滚动手势时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onScrollStartedProperty

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollStartedProperty​()
        定义检测到滚动手势时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnScrollStarted() ， setOnScrollStarted(EventHandler)

      • setOnScroll

        public final void setOnScroll​(EventHandler<? super ScrollEvent> value)
        设置属性onScroll的值。
        Property description:
        定义当用户执行滚动操作时要调用的函数。

      • getOnScroll

        public final EventHandler<? super ScrollEvent> getOnScroll​()
        获取属性onScroll的值。
        Property description:
        定义当用户执行滚动操作时要调用的函数。

      • onScrollProperty

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollProperty​()
        定义当用户执行滚动操作时要调用的函数。
        另请参见：
        getOnScroll() ， setOnScroll(EventHandler)

      • setOnScrollFinished

        public final void setOnScrollFinished​(EventHandler<? super ScrollEvent> value)
        设置属性onScrollFinished的值。
        Property description:
        定义当滚动手势结束时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnScrollFinished

        public final EventHandler<? super ScrollEvent> getOnScrollFinished​()
        获取属性onScrollFinished的值。
        Property description:
        定义当滚动手势结束时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onScrollFinishedProperty

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollFinishedProperty​()
        定义当滚动手势结束时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnScrollFinished() ， setOnScrollFinished(EventHandler)

      • setOnRotationStarted

        public final void setOnRotationStarted​(EventHandler<? super RotateEvent> value)
        设置属性onRotationStarted的值。
        Property description:
        定义检测到旋转手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnRotationStarted

        public final EventHandler<? super RotateEvent> getOnRotationStarted​()
        获取属性onRotationStarted的值。
        Property description:
        定义检测到旋转手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onRotationStartedProperty

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotationStartedProperty​()
        定义检测到旋转手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotationStarted() ， setOnRotationStarted(EventHandler)

      • setOnRotate

        public final void setOnRotate​(EventHandler<? super RotateEvent> value)
        设置属性onRotate的值。
        Property description:
        定义当用户执行旋转操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnRotate

        public final EventHandler<? super RotateEvent> getOnRotate​()
        获取属性onRotate的值。
        Property description:
        定义当用户执行旋转操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onRotateProperty

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotateProperty​()
        定义当用户执行旋转操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotate() ， setOnRotate(EventHandler)

      • setOnRotationFinished

        public final void setOnRotationFinished​(EventHandler<? super RotateEvent> value)
        设置属性onRotationFinished的值。
        Property description:
        定义旋转手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnRotationFinished

        public final EventHandler<? super RotateEvent> getOnRotationFinished​()
        获取属性onRotationFinished的值。
        Property description:
        定义旋转手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onRotationFinishedProperty

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotationFinishedProperty​()
        定义旋转手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotationFinished() ， setOnRotationFinished(EventHandler)

      • setOnZoomStarted

        public final void setOnZoomStarted​(EventHandler<? super ZoomEvent> value)
        设置属性onZoomStarted的值。
        Property description:
        定义检测到缩放手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnZoomStarted

        public final EventHandler<? super ZoomEvent> getOnZoomStarted​()
        获取属性onZoomStarted的值。
        Property description:
        定义检测到缩放手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onZoomStartedProperty

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomStartedProperty​()
        定义检测到缩放手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoomStarted() ， setOnZoomStarted(EventHandler)

      • setOnZoom

        public final void setOnZoom​(EventHandler<? super ZoomEvent> value)
        设置Zoom上的属性值。
        Property description:
        定义当用户执行缩放操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnZoom

        public final EventHandler<? super ZoomEvent> getOnZoom​()
        获取属性onZoom的值。
        Property description:
        定义当用户执行缩放操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onZoomProperty

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomProperty​()
        定义当用户执行缩放操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoom() ， setOnZoom(EventHandler)

      • setOnZoomFinished

        public final void setOnZoomFinished​(EventHandler<? super ZoomEvent> value)
        设置属性onZoomFinished的值。
        Property description:
        定义当缩放手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnZoomFinished

        public final EventHandler<? super ZoomEvent> getOnZoomFinished​()
        获取属性onZoomFinished的值。
        Property description:
        定义当缩放手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onZoomFinishedProperty

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomFinishedProperty​()
        定义当缩放手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoomFinished() ， setOnZoomFinished(EventHandler)

      • setOnSwipeUp

        public final void setOnSwipeUp​(EventHandler<? super SwipeEvent> value)
        设置属性onSwipeUp的值。
        Property description:
        定义当在该节点上居中的向上滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnSwipeUp

        public final EventHandler<? super SwipeEvent> getOnSwipeUp​()
        获取属性onSwipeUp的值。
        Property description:
        定义当在该节点上居中的向上滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onSwipeUpProperty

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeUpProperty​()
        定义当在该节点上居中的向上滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeUp() ， setOnSwipeUp(EventHandler)

      • setOnSwipeDown

        public final void setOnSwipeDown​(EventHandler<? super SwipeEvent> value)
        设置属性onSwipeDown的值。
        Property description:
        定义当在该节点上居中的向下滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnSwipeDown

        public final EventHandler<? super SwipeEvent> getOnSwipeDown​()
        获取属性onSwipeDown的值。
        Property description:
        定义当在该节点上居中的向下滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onSwipeDownProperty

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeDownProperty​()
        定义当在该节点上居中的向下滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeDown() ， setOnSwipeDown(EventHandler)

      • setOnSwipeLeft

        public final void setOnSwipeLeft​(EventHandler<? super SwipeEvent> value)
        设置属性onSwipeLeft的值。
        Property description:
        定义当以该节点为中心的向左滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnSwipeLeft

        public final EventHandler<? super SwipeEvent> getOnSwipeLeft​()
        获取属性onSwipeLeft的值。
        Property description:
        定义当以该节点为中心的向左滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onSwipeLeftProperty

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeLeftProperty​()
        定义当以该节点为中心的向左滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeLeft() ， setOnSwipeLeft(EventHandler)

      • setOnSwipeRight

        public final void setOnSwipeRight​(EventHandler<? super SwipeEvent> value)
        设置属性onSwipeRight的值。
        Property description:
        定义当以该节点为中心的向右滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnSwipeRight

        public final EventHandler<? super SwipeEvent> getOnSwipeRight​()
        获取属性onSwipeRight的值。
        Property description:
        定义当以该节点为中心的向右滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onSwipeRightProperty

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeRightProperty​()
        定义当以该节点为中心的向右滑动手势发生时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeRight() ， setOnSwipeRight(EventHandler)

      • setOnTouchPressed

        public final void setOnTouchPressed​(EventHandler<? super TouchEvent> value)
        设置属性onTouchPressed的值。
        Property description:
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnTouchPressed

        public final EventHandler<? super TouchEvent> getOnTouchPressed​()
        获取onTouchPressed属性的值。
        Property description:
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onTouchPressedProperty

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchPressedProperty​()
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchPressed() ， setOnTouchPressed(EventHandler)

      • setOnTouchMoved

        public final void setOnTouchMoved​(EventHandler<? super TouchEvent> value)
        设置属性onTouchMoved的值。
        Property description:
        定义当触摸点移动时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnTouchMoved

        public final EventHandler<? super TouchEvent> getOnTouchMoved​()
        获取onTouchMoved属性的值。
        Property description:
        定义当触摸点移动时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onTouchMovedProperty

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchMovedProperty​()
        定义当触摸点移动时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchMoved() ， setOnTouchMoved(EventHandler)

      • setOnTouchReleased

        public final void setOnTouchReleased​(EventHandler<? super TouchEvent> value)
        设置属性onTouchReleased的值。
        Property description:
        定义触发点释放时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnTouchReleased

        public final EventHandler<? super TouchEvent> getOnTouchReleased​()
        获取onTouchReleased属性的值。
        Property description:
        定义触发点释放时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onTouchReleasedProperty

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchReleasedProperty​()
        定义触发点释放时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchReleased() ， setOnTouchReleased(EventHandler)

      • setOnTouchStationary

        public final void setOnTouchStationary​(EventHandler<? super TouchEvent> value)
        设置属性onTouchStationary的值。
        Property description:
        定义当触摸点保持按下并静止时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnTouchStationary

        public final EventHandler<? super TouchEvent> getOnTouchStationary​()
        获取属性onTouchStationary的值。
        Property description:
        定义当触摸点保持按下并静止时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onTouchStationaryProperty

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchStationaryProperty​()
        定义当触摸点保持按下并静止时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchStationary() ， setOnTouchStationary(EventHandler)

      • setOnKeyPressed

        public final void setOnKeyPressed​(EventHandler<? super KeyEvent> value)
        设置属性onKeyPressed的值。
        Property description:
        定义当该Node或其子项Node具有输入焦点并按下键时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • getOnKeyPressed

        public final EventHandler<? super KeyEvent> getOnKeyPressed​()
        获取属性onKeyPressed的值。
        Property description:
        定义当此Node或其子代Node具有输入焦点并按下键时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • onKeyPressedProperty

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyPressedProperty​()
        定义当这个Node或其子代Node具有输入焦点并按下一个键时调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyPressed() ， setOnKeyPressed(EventHandler)

      • setOnKeyReleased

        public final void setOnKeyReleased​(EventHandler<? super KeyEvent> value)
        设置属性onKeyReleased的值。
        Property description:
        定义当这个Node或其子代Node具有输入焦点并且键已被释放时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • getOnKeyReleased

        public final EventHandler<? super KeyEvent> getOnKeyReleased​()
        获取属性onKeyReleased的值。
        Property description:
        定义当这个Node或其子代Node具有输入焦点并且键已被释放时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • onKeyReleasedProperty

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyReleasedProperty​()
        定义当这个Node或其子代Node具有输入焦点并且键已被释放时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyReleased() ， setOnKeyReleased(EventHandler)

      • setOnKeyTyped

        public final void setOnKeyTyped​(EventHandler<? super KeyEvent> value)
        设置属性onKeyTyped的值。
        Property description:
        定义当此Node或其子项Node具有输入焦点并键入密钥时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • getOnKeyTyped

        public final EventHandler<? super KeyEvent> getOnKeyTyped​()
        获取属性onKeyTyped的值。
        Property description:
        定义当这个Node或其子代Node具有输入焦点并键入了一个键时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • onKeyTypedProperty

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyTypedProperty​()
        定义当这个Node或其子代Node具有输入焦点并键入了一个键时要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyTyped() ， setOnKeyTyped(EventHandler)

      • setOnInputMethodTextChanged

        public final void setOnInputMethodTextChanged​(EventHandler<? super InputMethodEvent> value)
        设置属性onInputMethodTextChanged的值。
        Property description:
        定义当Node具有输入焦点并且输入法文本已更改时要调用的函数。 如果此功能未在此Node定义，则它会将输入法组合的结果字符串作为一系列onKeyTyped函数调用接收。

        当Node丢失输入焦点时，JavaFX运行时自动提交现有的合成文本（如果有的话）。

      • getOnInputMethodTextChanged

        public final EventHandler<? super InputMethodEvent> getOnInputMethodTextChanged​()
        获取onInputMethodTextChanged属性的值。
        Property description:
        定义当这个Node具有输入焦点并且输入法文本已更改时要调用的函数。 如果此功能未在此Node定义，则会将该输入法组合的结果字符串作为一系列onKeyTyped函数调用。

        当Node丢失输入焦点时，JavaFX运行时自动提交现有的合成文本（如果有的话）。

      • onInputMethodTextChangedProperty

        public final ObjectProperty<EventHandler<? super InputMethodEvent>> onInputMethodTextChangedProperty​()
        定义当Node具有输入焦点并且输入法文本已更改时要调用的函数。 如果此功能未在此Node定义，那么它会将输入法组合的结果字符串作为一系列onKeyTyped函数调用。

        当Node丢失输入焦点时，JavaFX运行时自动提交现有的合成文本（如果有的话）。

        另请参见：
        getOnInputMethodTextChanged() ， setOnInputMethodTextChanged(EventHandler)

      • setInputMethodRequests

        public final void setInputMethodRequests​(InputMethodRequests value)
        设置属性inputMethodRequests的值。
        Property description:
        属性保存InputMethodRequests。

      • getInputMethodRequests

        public final InputMethodRequests getInputMethodRequests​()
        获取属性inputMethodRequests的值。
        Property description:
        属性保存InputMethodRequests。

      • inputMethodRequestsProperty

        public final ObjectProperty<InputMethodRequests> inputMethodRequestsProperty​()
        属性保存InputMethodRequests。
        另请参见：
        getInputMethodRequests() ， setInputMethodRequests(InputMethodRequests)

      • setFocused

        protected final void setFocused​(boolean value)
        设置集中的属性的值。
        Property description:
        指示此Node当前是否具有输入焦点。 要输入焦点，一个节点必须是Scene的焦点所有者，并且场景必须在可见和活动的Stage中。 详见requestFocus() 。
        Default value:
        假

      • isFocused

        public final boolean isFocused​()
        获取关注的属性的值。
        Property description:
        指示此Node当前是否具有输入焦点。 要具有输入焦点，节点必须是Scene的焦点所有者，并且场景必须在可见和活动的Stage中。 有关详细信息，请参阅requestFocus() 。
        Default value:
        假

      • focusedProperty

        public final ReadOnlyBooleanProperty focusedProperty​()
        指示此Node当前是否具有输入焦点。 要具有输入焦点，节点必须是Scene的焦点所有者，并且场景必须在可见和活动的Stage中。 有关详细信息，请参阅requestFocus() 。
        Default value:
        假
        另请参见：
        isFocused() ， setFocused(boolean)

      • setFocusTraversable

        public final void setFocusTraversable​(boolean value)
        设置focusTraversable属性的值。
        Property description:
        指定此Node是否应该是焦点遍历周期的一部分。 当此属性为true可以将焦点移动到此Node并使用常规聚焦遍历键从此Node 。 在桌面上，这样的键通常是TAB用于向前移动焦点和SHIFT+TAB用于向后移动焦点。 当创建Scene ，系统Node焦点放在Node其focusTraversable变量为true，并且有资格接收焦点，除非通过调用requestFocus()显式设置焦点。
        Default value:
        假

      • isFocusTraversable

        public final boolean isFocusTraversable​()
        获取属性focusTraversable的值。
        Property description:
        指定此Node应该是焦点遍历周期的一部分。 当这个属性是true焦点可以移动到这个Node和从这个Node使用常规焦点遍历键。 桌面上这样的键通常是TAB用于向前移动焦点和SHIFT+TAB用于向后移动焦点。 当创建Scene ，系统Node焦点放在Node其focusTraversable变量为真，并且有资格接收焦点，除非通过调用requestFocus()显式设置了焦点。
        Default value:
        假

      • focusTraversableProperty

        public final BooleanProperty focusTraversableProperty​()
        指定此Node是否应该是焦点遍历周期的一部分。 当这个属性是true焦点可以移动到这个Node和从这个Node使用常规焦点遍历键。 在桌面上，这样的键通常为TAB用于向前移动焦点和SHIFT+TAB用于向后移动焦点。 当创建Scene ，系统Node焦点放在Node其focusTraversable变量为true，并且有资格接收焦点，除非通过调用requestFocus()显式设置了焦点。
        Default value:
        假
        另请参见：
        isFocusTraversable() ， setFocusTraversable(boolean)

      • requestFocus

        public void requestFocus​()
        要求这个Node得到输入焦点，而这个Node的顶级祖先成为聚焦窗口。 要有资格获得焦点，节点必须是场景的一部分，它和它的所有祖先必须可见，并且不能被禁用。 如果此节点符合条件，则此功能将使其成为此Scene的“焦点所有者”。 每个场景最多只有一个焦点所有者节点。 焦点所有者实际上不会具有输入焦点，但是，除非场景属于可见和活动的Stage 。

      • toString

        public String toString​()
        返回对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • setEventDispatcher

        public final void setEventDispatcher​(EventDispatcher value)
        设置属性eventDispatcher的值。
        Property description:
        指定此节点的事件分派器。 默认事件调度程序将接收的事件发送到已注册的事件处理程序和过滤器。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到替换的调度程序，以维护节点的默认事件处理行为。

      • getEventDispatcher

        public final EventDispatcher getEventDispatcher​()
        获取属性eventDispatcher的值。
        Property description:
        指定此节点的事件分派器。 默认事件调度程序将接收的事件发送到已注册的事件处理程序和过滤器。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到已替换的调度程序，以维护节点的默认事件处理行为。

      • eventDispatcherProperty

        public final ObjectProperty<EventDispatcher> eventDispatcherProperty​()
        指定此节点的事件分派器。 默认事件调度程序将接收的事件发送到已注册的事件处理程序和过滤器。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到已替换的调度程序，以维护节点的默认事件处理行为。
        另请参见：
        getEventDispatcher() ， setEventDispatcher(EventDispatcher)

      • addEventHandler

        public final <T extends Event> void addEventHandler​(EventType<T> eventType,
                                                    EventHandler<? super T> eventHandler)
        向此节点注册事件处理程序。 当事件传送的冒泡阶段节点收到指定类型的Event时，调用处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 由处理程序接收的事件的类型
        eventHandler - 要注册的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • removeEventHandler

        public final <T extends Event> void removeEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        从此节点注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • addEventFilter

        public final <T extends Event> void addEventFilter​(EventType<T> eventType,
                                                   EventHandler<? super T> eventFilter)
        向此节点注册事件过滤器。 当节点在事件传送的捕获阶段接收到指定类型的Event时，将调用该过滤器。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 过滤器接收的事件的类型
        eventFilter - 要注册的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空

      • removeEventFilter

        public final <T extends Event> void removeEventFilter​(EventType<T> eventType,
                                                      EventHandler<? super T> eventFilter)
        从此节点注销先前注册的事件过滤器。 一个过滤器可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销过滤器。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 要注销的事件类型
        eventFilter - 要注销的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空

      • setEventHandler

        protected final <T extends Event> void setEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        设置要用于此事件类型的处理程序。 一次只能有一个这样的处理程序。 这个处理程序保证被称为最后一个，后处理程序使用addEventHandler(javafx.event.EventType, javafx.event.EventHandler)添加。 这用于注册用户定义的onFoo事件处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 与给定eventHandler关联的事件类型
        eventHandler - 注册的处理程序，或取消注册为null
        异常
        NullPointerException - 如果事件类型为空

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此节点构造事件调度链。 事件调度链包含从舞台到该节点的所有事件调度程序。
        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 从...建立的初始链
        结果
        此节点的结果事件调度链

      • fireEvent

        public final void fireEvent​(Event event)
        触发指定的事件。 默认情况下，事件将从阶段到该节点遍历层次结构。 遇到的任何事件过滤器将被通知并可以使用该事件。 如果不被过滤器使用，则会通知此节点上的事件处理程序。 如果这些也不消耗事件，事件将返回到到达该节点的相同路径。 遇到的所有事件处理程序都被调用，可以使用事件。

        必须在FX用户线程上调用此方法。

        参数
        event - 事件发生

      • getTypeSelector

        public String getTypeSelector​()
        这种Styleable的类型用于选择器匹配。 这类似于HTML中的“元素”。 （ CSS Type Selector ）。
        Specified by:
        getTypeSelector在接口 Styleable
        结果
        getClass().getName()没有包名
        从以下版本开始：
        JavaFX 8.0

      • getStyleableParent

        public Styleable getStyleableParent​()
        返回此Styleable的父项，如果没有父项则返回null。
        Specified by:
        getStyleableParent在接口 Styleable
        结果
        getParent()
        从以下版本开始：
        JavaFX 8.0

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此节点的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 在这种情况下，这个方法可以被子类覆盖，因为这个方法最初应该是true（因为这个方法的默认实现是返回false）。
        结果
        这个 Node的初始聚焦可移动状态。
        从以下版本开始：
        9

      • getInitialCursor

        protected Cursor getInitialCursor​()
        返回此节点的初始游标状态，供JavaFX CSS引擎正确设置其初始值。 这个方法可以在游标应该最初不为空的情况下被子类覆盖（因为这个方法的默认实现是返回null）。
        结果
        这个 Node的初始游标状态。
        从以下版本开始：
        9

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • pseudoClassStateChanged

        public final void pseudoClassStateChanged​(PseudoClass pseudoClass,
                                          boolean active)
        用于指定此节点的伪类已更改。 如果在与CSS相符的CSS选择器中使用伪类，则将重新应用CSS。 通常，该方法是从用作伪类的属性的invalidated方法中调用的。 例如：
           private static final PseudoClass MY_PSEUDO_CLASS_STATE = PseudoClass.getPseudoClass("my-state"); BooleanProperty myPseudoClassState = new BooleanPropertyBase(false) { @Override public void invalidated() { pseudoClassStateChanged(MY_PSEUDO_CLASS_STATE, get()); } @Override public Object getBean() { return MyControl.this; } @Override public String getName() { return "myPseudoClassState"; } };
        参数
        pseudoClass - 已修改状态的伪类
        active - 状态是否处于活动状态
        从以下版本开始：
        JavaFX 8.0

      • getPseudoClassStates

        public final ObservableSet<PseudoClass> getPseudoClassStates​()
        说明从界面Styleable复制
        返回此Styleable的伪类状态。 CSS假定此集是只读的。
        Specified by:
        getPseudoClassStates在接口 Styleable
        结果
        此Node的活动伪类状态，包装在一个不可修改的ObservableSet中
        从以下版本开始：
        JavaFX 8.0

      • applyCss

        public final void applyCss​()
        如果需要，将样式应用于此节点及其子节点（如果有）。 此方法通常不需要直接调用，而是可以结合使用Parent.layout()下一脉冲之前大小节点，或者如果Scene不在Stage 。

        如果节点的Scene不为空，则CSS应用于此节点，而不管此节点的CSS状态是否干净。 CSS样式从此节点的最顶层父节点应用，其CSS状态不是干净的，这可能会影响其他节点的样式。 如果节点不在场景中，则此方法是无效的。 场景不必在舞台上。

        此方法不调用Parent.layout()方法。 通常，调用者将使用以下操作序列。

           parentNode.applyCss(); parentNode.layout();

        作为更完整的示例，以下代码使用applyCss()和layout()在舞台显示之前查找Button的宽度和高度。 如果要么调用applyCss()或调用layout()被注释掉，在两个电话getWidth()和getHeight()将返回零（直到显示在舞台一段时间后）。

           @Override public void start(Stage stage) throws Exception { Group root = new Group(); Scene scene = new Scene(root); Button button = new Button("Hello World"); root.getChildren().add(button); root.applyCss(); root.layout(); double width = button.getWidth(); double height = button.getHeight(); System.out.println(width + ", " + height); stage.setScene(scene); stage.show(); }
        从以下版本开始：
        JavaFX 8.0

      • setAccessibleRole

        public final void setAccessibleRole​(AccessibleRole value)
        设置属性accessibilityRole的值。
        Property description:
        这个Node的可访问角色。

        屏幕阅读器使用节点的角色来确定支持的属性和动作。

        Default value:
        AccessibleRole.NODE
        从以下版本开始：
        JavaFX 8u40

      • getAccessibleRole

        public final AccessibleRole getAccessibleRole​()
        获取属性accessibilityRole的值。
        Property description:
        这个Node的可访问角色。

        屏幕阅读器使用节点的角色来确定支持的属性和动作。

        Default value:
        AccessibleRole.NODE
        从以下版本开始：
        JavaFX 8u40

      • accessibleRoleProperty

        public final ObjectProperty<AccessibleRole> accessibleRoleProperty​()
        这个Node的可访问角色。

        屏幕阅读器使用节点的角色来确定支持的属性和动作。

        Default value:
        AccessibleRole.NODE
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAccessibleRole() ， setAccessibleRole(AccessibleRole)

      • setAccessibleRoleDescription

        public final void setAccessibleRoleDescription​(String value)
        设置属性accessibilityRoleDescription的值。
        Property description:
        这个角色描述Node 。

        可以说，当为节点提供角色时，屏幕阅读器说出节点的作用以及内容。 当设置此值时，可以覆盖默认值。 这是有用的，因为角色集是预定义的。 例如，可以将节点的角色设置为按钮，但将角色描述设置为任意文本。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40

      • getAccessibleRoleDescription

        public final String getAccessibleRoleDescription​()
        获取属性accessibilityRoleDescription的值。
        Property description:
        这个角色描述Node 。

        可以说，当为节点提供角色时，屏幕阅读器说出节点的作用以及内容。 当设置此值时，可以覆盖默认值。 这是有用的，因为角色集是预定义的。 例如，可以将节点的角色设置为按钮，但将角色描述设置为任意文本。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40

      • accessibleRoleDescriptionProperty

        public final ObjectProperty<String> accessibleRoleDescriptionProperty​()
        这个角色描述Node 。

        可以说，当为节点提供角色时，屏幕阅读器说出节点的作用以及内容。 当设置此值时，可以覆盖默认值。 这是有用的，因为角色集是预定义的。 例如，可以将节点的角色设置为按钮，但将角色描述设置为任意文本。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAccessibleRoleDescription() ， setAccessibleRoleDescription(String)

      • setAccessibleText

        public final void setAccessibleText​(String value)
        设置属性accessibleText的值。
        Property description:
        这个Node的可访问文本。

        此属性用于设置屏幕阅读器将发言的文本。 如果一个节点通常会说文字，那么该文本就会被覆盖。 例如，一个按钮通常使用控件中的文本，但在设置此值时将不再执行此操作。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40

      • getAccessibleText

        public final String getAccessibleText​()
        获取属性accessibleText的值。
        Property description:
        这个Node的可访问文本。

        此属性用于设置屏幕阅读器将发言的文本。 如果一个节点通常会说文字，那么该文本就会被覆盖。 例如，一个按钮通常使用控件中的文本，但在设置此值时将不再执行此操作。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40

      • accessibleTextProperty

        public final ObjectProperty<String> accessibleTextProperty​()
        这个Node的可访问文本。

        此属性用于设置屏幕阅读器将发言的文本。 如果一个节点通常会说文字，那么该文本就会被覆盖。 例如，一个按钮通常使用控件中的文本，但在设置此值时将不再执行此操作。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAccessibleText() ， setAccessibleText(String)

      • setAccessibleHelp

        public final void setAccessibleHelp​(String value)
        设置属性accessibleHelp的值。
        Property description:
        该Node的可访问帮助文本。

        帮助文本提供了节点可访问文本的更详细描述。 默认情况下，如果节点具有工具提示，则使用此文本。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40

      • getAccessibleHelp

        public final String getAccessibleHelp​()
        获取属性accessibleHelp的值。
        Property description:
        该Node的可访问的帮助文本。

        帮助文本提供了节点可访问文本的更详细描述。 默认情况下，如果节点具有工具提示，则使用此文本。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40

      • accessibleHelpProperty

        public final ObjectProperty<String> accessibleHelpProperty​()
        该Node的无障碍帮助文本。

        帮助文本提供了节点可访问文本的更详细描述。 默认情况下，如果节点具有工具提示，则使用此文本。

        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAccessibleHelp() ， setAccessibleHelp(String)

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        参数
        action - 要执行的动作
        parameters - 可选参数列表
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        AccessibleAction

      • notifyAccessibleAttributeChanged

        public final void notifyAccessibleAttributeChanged​(AccessibleAttribute attributes)
        该方法由应用程序调用，以通知辅助技术属性的值已更改。
        参数
        attributes - 其值已更改的属性
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ParallelCamera (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class ParallelCamera

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Camera
        • javafx.scene.ParallelCamera
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class ParallelCamera
extends Camera
    指定用于渲染场景而不进行透视校正的并行相机。

    如果场景仅包含2D变换，则以下细节不相关。 该相机定义了用于平行（正投影）投影的观看体积; 一个矩形盒子。 该相机始终位于窗口的中心，并沿z轴正方向看。 由本相机定义的坐标系起源于面板的左上角，Y轴指向下方，Z轴指向观察者（进入屏幕）。 单位是像素坐标。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.Camera

        farClip, nearClip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      ParallelCamera​()
      创建一个空的ParallelCamera实例。

    • 方法摘要

      • Methods inherited from class javafx.scene.Camera

        farClipProperty, getFarClip, getNearClip, nearClipProperty, setFarClip, setNearClip

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • ParallelCamera

        public ParallelCamera​()
        创建一个空的ParallelCamera实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Parent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class Parent

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    Group ， Region ， WebView

    public abstract class Parent
extends Node
    在场景图中有子节点的所有节点的基类。

    该类处理所有分层场景图操作，包括添加/删除子节点，标记用于布局和渲染的分支，采摘，边界计算以及对每个脉冲执行布局传递。

    有两个直接具体的父子类

    • 对应用于子节点集合的效果和变换Group 。
    • Region可以使用CSS和布局子对象的节点类。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty needsLayout
      表示此节点及其子节点需要对下一个脉冲进行布局传递。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Parent​()
      构造新的 Parent 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected double computeMinHeight​(double width)
      计算这个 Parent的最小高度。
      protected double computeMinWidth​(double height)
      计算这个 Parent的最小宽度。
      protected double computePrefHeight​(double width)
      计算这个 Parent的首选高度。
      protected double computePrefWidth​(double height)
      计算此 Parent的首选宽度。
      double getBaselineOffset​()
      基于第一个受管理的子节点计算基线偏移量。
      protected ObservableList<Node> getChildren​()
      获取这个 Parent的孩子列表。
      ObservableList<Node> getChildrenUnmodifiable​()
      获取此 Parent的子项列表作为只读列表。
      protected <E extends Node>
      List<E>             		getManagedChildren​()
      获取此 Parent的所有受管孩子的 Parent 。
      ObservableList<String> getStylesheets​()
      获取链接到此父项内容使用的样式表的字符串URL的可观察列表。
      boolean isNeedsLayout​()
      获取propertyLayout属性的值。
      void layout​()
      在此父项下的场景图上执行自上而下的布局传递。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      Node lookup​(String selector)
      根据给定的CSS选择器找到这个 Node或第一个子节点。
      double minHeight​(double width)
      返回节点在布局计算中使用的最小高度。
      double minWidth​(double height)
      返回节点在布局计算中使用的最小宽度。
      ReadOnlyBooleanProperty needsLayoutProperty​()
      表示此节点及其子节点需要对下一个脉冲进行布局传递。
      double prefHeight​(double width)
      返回节点的首选高度，用于布局计算。
      double prefWidth​(double height)
      返回节点在布局计算中使用的首选宽度。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。
      protected void requestParentLayout​()
      请求在呈现下一个场景之前执行的父级的布局传递。
      protected void setNeedsLayout​(boolean value)
      设置propertyLayout属性的值。
      protected void | updateBounds​()

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, maxHeight, maxWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • needsLayout

        public final ReadOnlyBooleanProperty needsLayoutProperty
        表示此节点及其子节点需要对下一个脉冲进行布局传递。
        另请参见：
        isNeedsLayout() ， setNeedsLayout(boolean)

    • 构造方法详细信息

      • Parent

        protected Parent​()
        构造新的 Parent 。

    • 方法详细信息

      • getChildren

        protected ObservableList<Node> getChildren​()
        获取此Parent的孩子列表。

        有关设置Parent的子列表的场景图结构限制，请参阅Node的课程文档。 如果对子列表的更改违反了这些限制，则忽略该更改，并恢复子列表的先前值。 在这种情况下抛出一个IllegalArgumentException 。

        如果此Parent节点附加到已显示（ Window.isShowing() ）的Window附带的Scene ，那么其子项列表只能在JavaFX应用程序线程上进行修改。 如果违反限制，则抛出IllegalStateException 。

        注意子类：如果您重写此方法，则必须从实现中返回调用此超级方法的结果。 从任何getChildren（）实现返回的实际列表实例必须是由此父项所拥有和管理的列表。 推翻这种方法的唯一典型的目的是推广这种方法。

        结果
        这个 Parent的孩子列表。

      • getChildrenUnmodifiable

        public ObservableList<Node> getChildrenUnmodifiable​()
        获取此 Parent的子项列表作为只读列表。
        结果
        对这个父亲的孩子ObservableList的只读访问

      • getManagedChildren

        protected <E extends Node> List<E> getManagedChildren​()
        获取此 Parent的所有受管孩子的 Parent 。
        参数类型
        E - 子节点的类型
        结果
        此父级中所有受管孩子的列表

      • lookup

        public Node lookup​(String selector)
        描述从类复制： Node
        根据给定的CSS选择器，找到这个Node或第一个子节点。 如果此节点为Parent ，则此函数将遍历到分支中，直到找到匹配项。 如果多个子节点与指定的选择器匹配，则此函数返回其中的第一个。

        例如，如果节点的ID为“myId”，则可以使用查找方法来查找此节点，如下所示： scene.lookup("#myId"); 。

        重写：
        lookup在 Node
        参数
        selector - 要查找的节点的css选择器
        结果
        第一个节点，从这个 Node开始，与CSS selector匹配，如果没有找到， selector null。

      • setNeedsLayout

        protected final void setNeedsLayout​(boolean value)
        设置propertyLayout属性的值。
        Property description:
        表示此节点及其子节点需要对下一个脉冲进行布局传递。

      • isNeedsLayout

        public final boolean isNeedsLayout​()
        获取propertyLayout属性的值。
        Property description:
        表示此节点及其子节点需要对下一个脉冲进行布局传递。

      • needsLayoutProperty

        public final ReadOnlyBooleanProperty needsLayoutProperty​()
        表示此节点及其子节点需要对下一个脉冲进行布局传递。
        另请参见：
        isNeedsLayout() ， setNeedsLayout(boolean)

      • requestLayout

        public void requestLayout​()
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果此父对象是布局根或非托管，则将直接添加到场景的脏布局列表中，否则将调用requestParentLayout。

        从以下版本开始：
        JavaFX 8.0

      • requestParentLayout

        protected final void requestParentLayout​()
        请求在呈现下一个场景之前执行的父级的布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        当目前的父母已经更改了最小/最大/偏好的宽度/高度时，可能会使用这种方法，但是不知道更改是否会导致实际的大小更改。 当它的父重新计算具有新提示的布局时，这将被确定。

      • prefWidth

        public double prefWidth​(double height)
        描述从类复制： Node
        返回节点在布局计算中使用的首选宽度。 如果节点可调整大小，其父级应将该值视为节点在其范围内的理想宽度。 如果节点不可调整，只需返回其layoutBounds宽度，该宽度应该被视为节点的刚性宽度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有垂直的内容偏置，则呼叫者应该传入首选宽度应该基于的高度值。 如果节点具有水平或空的内容偏置，则调用者应该传入-1。

        具有垂直内容偏置的节点子类应该尊重height参数，不管是-1还是正值。 所有其他子类可以忽略height参数（这可能是-1）。

        重写：
        prefWidth在 Node
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        节点在布局期间应该调整大小的首选宽度结果将不会是NaN，也不会是负数。
        另请参见：
        Node.isResizable() ，
Node.getContentBias() ，
Node.autosize()

      • prefHeight

        public double prefHeight​(double width)
        描述从类复制： Node
        返回节点的首选高度，用于布局计算。 如果节点可调整大小，其父级应该将该值视为节点在其范围内的理想高度。 如果节点不可调整大小，则只返回其layoutBounds高度，该高度应该被视为节点的刚性高度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有水平的内容偏置，则呼叫者应该传入首选高度应该基于的宽度值。 如果节点具有垂直或空的内容偏置，则调用者应该传入-1。

        具有水平内容偏倚的节点子类应该符合高度参数，不管是-1还是正值。 所有其他子类可以忽略height参数（这可能是-1）。

        重写：
        prefHeight在 Node
        参数
        width - 如果首选高度取决于应该使用的宽度
        结果
        节点在布局期间应该调整大小的首选高度结果将不会是NaN，也不会是负数。
        另请参见：
        Node.getContentBias() ， Node.autosize()

      • minWidth

        public double minWidth​(double height)
        描述从类复制Node
        返回节点在布局计算中使用的最小宽度。 如果节点可调整大小，则其父值不应该调整其小于此值的宽度。 如果节点不可调整，则返回其layoutBounds宽度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有垂直的内容偏置，则呼叫者应该传入最小宽度应该基于的高度值。 如果节点具有水平或空的内容偏置，则调用者应该传入-1。

        具有垂直内容偏置的节点子类应该尊重height参数，不管是-1还是正值。 所有其他子类可以忽略height参数（这可能是-1）。

        如果节点的Node.maxWidth(double)低于此数字，则优先级为minWidth 。 这意味着节点不应该被调整到minWidth以下。

        重写：
        minWidth在 Node
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        布局期间节点应该调整大小的最小宽度。 结果永远不会是NaN，也不会是负面的。
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • minHeight

        public double minHeight​(double width)
        说明从类别复制Node
        返回节点在布局计算中使用的最小高度。 如果节点可调整大小，则父节点不应该将其高度调整为小于该值的大小。 如果节点不可调整大小，返回其layoutBounds高度。

        调用此方法的布局代码应首先检查节点的内容偏差。 如果节点具有水平的内容偏置，则呼叫者应该传递最小高度应该基于的宽度值。 如果节点具有垂直或空的内容偏置，则调用者应该传入-1。

        具有水平内容偏置的节点子类应该符合宽度参数，不管是-1还是正值。 所有其他子类可以忽略width参数（这可能是-1）。

        如果节点的Node.maxHeight(double)低于此数字，则优先级为minHeight 。 这意味着节点不应该被调整到minHeight以下。

        重写：
        minHeight在 Node
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        在布局期间节点应该调整大小的最小高度结果将不会是NaN，也不会是负数。
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • computePrefWidth

        protected double computePrefWidth​(double height)
        计算这个Parent的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        计算这个Parent的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        计算的优选高度

      • computeMinWidth

        protected double computeMinWidth​(double height)
        计算Parent的最小宽度。 默认实现只是返回pref宽度。
        参数
        height - 如果最小宽度取决于它应该使用的高度
        结果
        计算的最小宽度
        从以下版本开始：
        JavaFX 2.1

      • computeMinHeight

        protected double computeMinHeight​(double width)
        计算这个Parent的最小高度。 默认实现只是返回pref高度;
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算出的最小高度
        从以下版本开始：
        JavaFX 2.1

      • getBaselineOffset

        public double getBaselineOffset​()
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        getBaselineOffset在 Node
        结果
        基线偏移

      • layout

        public final void layout​()
        在此父项下的场景图上执行自上而下的布局传递。 当父进行布局时调用此方法是无操作的。

      • layoutChildren

        protected void layoutChildren​()
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

      • getStylesheets

        public final ObservableList<String> getStylesheets​()
        获取链接到此父项内容使用的样式表的字符串URL的可观察列表。 详见Scene.getStylesheets() 。

        有关使用CSS与场景图的其他信息，请参阅CSS Reference Guide 。

        结果
        要与此Parent一起使用的样式表列表
        从以下版本开始：
        JavaFX 2.1

      • updateBounds

        protected void updateBounds​()

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Node
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PerspectiveCamera (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class PerspectiveCamera

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Camera
        • javafx.scene.PerspectiveCamera
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class PerspectiveCamera
extends Camera
    指定用于渲染场景的透视相机。

    该相机定义了透视投影的观看体积; 一个截断的右金字塔。 fieldOfView值可用于更改观看音量。 默认情况下，本相机位于场景的中心，并沿z轴正方向。 由本相机定义的坐标系起源于面板的左上角，Y轴指向下方，Z轴指向观察者（进入屏幕）。 如果将PerspectiveCamera节点添加到场景图中，则相机的变换位置和方向将定义相机的位置和相机所在的方向。

    在默认摄像机中，如果固定的EyeAtCameraZero为假，则在Z中调整眼睛位置的Z值，使得使用指定的fieldOfView生成的投影矩阵将在与设备无关的像素中产生Z = 0（投影平面）的单位，匹配ParallelCamera的。 当场景调整大小时，投影平面（Z = 0）场景中的物体将保持相同的大小，但是场景的内容更多或更少是可见的。

    如果fixedEyeAtCameraZero为真，则眼睛位置固定在摄像机的本地坐标中的（0,0,0）。 使用指定的fieldOfView生成投影矩阵，并将投影体积映射到视口（窗口），使其在投影平面上的多个或更少的与设备无关的像素上展开。 当场景调整大小时，场景中的对象将按比例缩小或增长，但内容的可见部分不变。

    如果要转换（移动）相机，我们建议将fixedEyeAtCameraZero设置为true。 当固定EyeAtCameraZero设置为false时转换相机可能会导致不直观的结果。

    请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty fieldOfView
      指定相机投影的视野角度，以度为单位。
      BooleanProperty verticalFieldOfView
      定义 fieldOfView属性是否适用于投影的垂直维度。

      • Properties inherited from class javafx.scene.Camera

        farClip, nearClip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      PerspectiveCamera​()
      创建PerspectiveCamera的空实例。
      PerspectiveCamera​(boolean fixedEyeAtCameraZero)
      用指定的fixedEyeAtCameraZero标志构建PerspectiveCamera。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty fieldOfViewProperty​()
      指定相机投影的视野角度，以度为单位。
      double getFieldOfView​()
      获取属性fieldOfView的值。
      boolean isFixedEyeAtCameraZero​()
      返回一个标志，指示本相机是否在相机原点使用固定的眼睛位置。
      boolean isVerticalFieldOfView​()
      获取属性verticalFieldOfView的值。
      void setFieldOfView​(double value)
      设置属性fieldOfView的值。
      void setVerticalFieldOfView​(boolean value)
      设置属性verticalFieldOfView的值。
      BooleanProperty verticalFieldOfViewProperty​()
      定义 fieldOfView属性是否适用于投影的垂直维度。

      • Methods inherited from class javafx.scene.Camera

        farClipProperty, getFarClip, getNearClip, nearClipProperty, setFarClip, setNearClip

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • fieldOfView

        public final DoubleProperty fieldOfViewProperty
        指定相机投影的视野角度，以度为单位。
        Default value:
        30.0
        另请参见：
        getFieldOfView() ， setFieldOfView(double)

      • verticalFieldOfView

        public final BooleanProperty verticalFieldOfViewProperty
        定义fieldOfView属性是否适用于投影的垂直维度。 如果为假，则fieldOfView将适用于投影的水平维度。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isVerticalFieldOfView() ， setVerticalFieldOfView(boolean)

    • 构造方法详细信息

      • PerspectiveCamera

        public PerspectiveCamera​()
        创建PerspectiveCamera的空实例。

      • PerspectiveCamera

        public PerspectiveCamera​(boolean fixedEyeAtCameraZero)
        用指定的fixedEyeAtCameraZero标志构建PerspectiveCamera。

        在默认摄像机中，在固定的EyeAtCameraZero为假的情况下，在Z中调整眼睛位置的Z值，使得使用指定的fieldOfView生成的投影矩阵将在与设备无关的像素中产生Z = 0（投影平面）匹配ParallelCamera的。 当场景调整大小时，投影平面（Z = 0）场景中的物体将保持相同的大小，但是场景的内容更多或更少是可见的。

        如果fixedEyeAtCameraZero为真，则眼睛位置固定在摄像机的本地坐标中的（0,0,0）。 使用指定的fieldOfView生成投影矩阵，并将投影体积映射到视口（窗口），使其在投影平面上的多个或更少的与设备无关的像素上展开。 当场景调整大小时，场景中的对象将按比例缩小或增长，但内容的可见部分不变。

        如果要转换（移动）相机，我们建议将fixedEyeAtCameraZero设置为true。 当固定EyeAtCameraZero设置为false时转换相机可能会导致不直观的结果。

        参数
        fixedEyeAtCameraZero - 如果眼睛位置固定在摄像机的本地坐标中的（0,0,0）， fixedEyeAtCameraZero真。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setFieldOfView

        public final void setFieldOfView​(double value)
        设置属性fieldOfView的值。
        Property description:
        指定相机投影的视野角度，以度为单位。
        Default value:
        30.0

      • getFieldOfView

        public final double getFieldOfView​()
        获取属性fieldOfView的值。
        Property description:
        指定相机投影的视野角度，以度为单位。
        Default value:
        30.0

      • fieldOfViewProperty

        public final DoubleProperty fieldOfViewProperty​()
        指定相机投影的视野角度，以度为单位。
        Default value:
        30.0
        另请参见：
        getFieldOfView() ， setFieldOfView(double)

      • setVerticalFieldOfView

        public final void setVerticalFieldOfView​(boolean value)
        设置属性verticalFieldOfView的值。
        Property description:
        定义fieldOfView属性是否适用于投影的垂直维度。 如果是假的，则fieldOfView将适用于投影的水平维度。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0

      • isVerticalFieldOfView

        public final boolean isVerticalFieldOfView​()
        获取属性verticalFieldOfView的值。
        Property description:
        定义fieldOfView属性是否适用于投影的垂直维度。 如果为假，则fieldOfView将适用于投影的水平尺寸。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0

      • verticalFieldOfViewProperty

        public final BooleanProperty verticalFieldOfViewProperty​()
        定义fieldOfView属性是否适用于投影的垂直维度。 如果为假，则fieldOfView将适用于投影的水平维度。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isVerticalFieldOfView() ， setVerticalFieldOfView(boolean)

      • isFixedEyeAtCameraZero

        public final boolean isFixedEyeAtCameraZero​()
        返回一个标志，指示本相机是否在相机原点使用固定的眼睛位置。 如果fixedEyeAtCameraZero为true ，则在摄像机的本地坐标中，眼睛位置固定为（0,0,0）。 这个属性是不可变的。
        结果
        指示该相机是否在相机原点处使用固定眼睛位置的标志
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PointLight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class PointLight

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.LightBase
        • javafx.scene.PointLight
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class PointLight
extends LightBase
    定义点光源对象。 光源在空间中具有固定点，并在远离本身的所有方向均匀地散发光线。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      • Properties inherited from class javafx.scene.LightBase

        color, lightOn

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      PointLight​()
      使用默认的Color.WHITE光源创建一个 PointLight类的新实例。
      PointLight​(Color color)
      使用指定的颜色创建一个 PointLight类的新实例。

    • 方法摘要

      • Methods inherited from class javafx.scene.LightBase

        colorProperty, getColor, getScope, isLightOn, lightOnProperty, setColor, setLightOn

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • PointLight

        public PointLight​()
        使用默认的Color.WHITE光源创建一个 PointLight类的新实例。

      • PointLight

        public PointLight​(Color color)
        使用指定的颜色创建一个新的 PointLight类的实例。
        参数
        color - 光源的颜色
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Scene (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class Scene

  • java.lang.Object
    • javafx.scene.Scene
  • All Implemented Interfaces:
    EventTarget

    @DefaultProperty("root")
public class Scene
extends Object
implements EventTarget
    JavaFX Scene类是场景图中所有内容的容器。 场景的背景按fill属性指定填写。

    应用程序必须通过设置root属性为场景图指定根Node的根。 如果使用Group作为根，则场景图的内容将被场景的宽度和高度剪辑，并更改为场景的大小（如果用户调整舞台大小）将不会更改场景图的布局。 如果可调整大小的节点（布局Region或Control设置为根，则根的大小将跟踪场景的大小，导致内容在必要时被中继。

    场景的大小可以在施工期间由应用程序初始化。 如果没有指定大小，场景将根据其内容的首选大小自动计算其初始大小。 如果仅指定了一个维度，则使用指定的维度来计算另一个维度，该范围涉及根的内容偏倚。

    应用程序可以在创建Scene请求深度缓冲区支持或场景抗锯齿支持。 只有2D形状和没有任何3D变换的场景不需要深度缓冲区和场景抗锯齿支持。 包含3D形状或具有3D变换的2D形状的场景可以使用深度缓冲区支持来进行适当的深度排序渲染; 为了避免深度战斗（也称为Z战斗），禁止没有3D转换的2D形状的深度测试。 有关详细信息，请参阅depthTest 。 具有3D形状的场景可以实现场景抗锯齿以改善其渲染质量。

    depthBuffer和antiAliasing标志是条件特征。 各自的默认值为：false和SceneAntialiasing.DISABLED 。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

    默认头灯将被添加到包含一个或多个Shape3D节点但不包含轻节点的场景中。 这个光源是一个Color.WHITE PointLight置于相机位置。

    A Scene可以在任何线程上创建和修改，直到它连接到Window为showing 。 之后，它必须仅在JavaFX应用程序线程上进行修改。 请注意， Scene不是线程安全的; Scene在多个线程上修改Scene将导致不可预知的结果，必须避免。

    JavaFX应用程序线程是作为JavaFX运行时启动过程的一部分而创建的。 有关更多信息，请参阅Application类和Platform.startup(Runnable)方法。

    例：

      import javafx.scene.*;
import javafx.scene.paint.*;
import javafx.scene.shape.*;

Group root = new Group();
Scene s = new Scene(root, 300, 300, Color.BLACK);

Rectangle r = new Rectangle(25,25,250,250);
r.setFill(Color.BLUE);

root.getChildren().add(r);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Camera> camera
      指定用于渲染 Scene的相机使用类型。
      ObjectProperty<Cursor> cursor
      为此 Scene定义鼠标光标。
      ReadOnlyObjectProperty<NodeOrientation> effectiveNodeOrientation
      场景的有效节点方向解决节点方向的继承，从左到右或从右到左返回。
      ObjectProperty<EventDispatcher> eventDispatcher
      指定此场景的事件调度程序。
      ObjectProperty<Paint> fill
      定义 Scene的背景填充。
      ReadOnlyObjectProperty<Node> focusOwner
      场景当前焦点所有者节点。
      ReadOnlyDoubleProperty height
      这个高度 Scene
      ObjectProperty<NodeOrientation> nodeOrientation
      属性保存NodeOrientation。
      ObjectProperty<EventHandler<? super ContextMenuEvent>> onContextMenuRequested
      定义当这个 Scene点击（按下和释放）鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onDragDetected
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragDone
      定义当这个 Scene是一个拖放手势源，当它的数据被丢弃在放置目标上之后调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> onDragDropped
      定义在拖放手势时，在此 Scene上释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragEntered
      定义当拖动手势进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragExited
      定义当拖动手势退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> onDragOver
      定义当这个 Scene拖动手势进度时要调用的函数。
      ObjectProperty<EventHandler<? super InputMethodEvent>> onInputMethodTextChanged
      定义当这个 Node具有输入焦点并且输入法文本已更改时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyPressed
      定义要调用的函数，当一些 Node如此 Scene具有输入焦点和键被按下。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyReleased
      定义当 Node的 Scene具有输入焦点并且键被释放时要调用的功能。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyTyped
      定义要调用的函数，当一些 Node如此 Scene具有输入焦点和重点已经输入。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseClicked
      定义当在此 Scene上单击（按下并释放）鼠标按钮时调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragEntered
      定义当全按压拖动手势进入这个 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragExited
      定义当完全按下 - 拖动释放手势退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseDragged
      定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragOver
      定义当这个 Scene内完全按下 Scene释放手势时，要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragReleased
      定义当完全按下 - 拖动释放手势在此 Scene内结束时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseEntered
      定义当鼠标进入 Scene时调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseExited
      定义当鼠标退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseMoved
      定义当这个 Scene鼠标光标移动时调用的功能，但没有按钮被按下。
      ObjectProperty<EventHandler<? super MouseEvent>> onMousePressed
      定义在 Scene上按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseReleased
      定义当这个 Scene上释放鼠标按钮时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotate
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotationFinished
      定义当旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotationStarted
      定义检测到旋转手势时要调用的功能。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollFinished
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScroll
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollStarted
      定义检测到滚动手势时要调用的函数。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeDown
      定义当在此场景中发生向下滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeLeft
      定义当在此场景中发生向左滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeRight
      定义当在此场景中发生向右滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeUp
      定义当在此场景中发生向上滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchMoved
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchPressed
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchReleased
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchStationary
      定义当触摸点保持按下并静止时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomFinished
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoom
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomStarted
      定义检测到缩放手势时要调用的功能。
      ObjectProperty<Parent> root
      定义场景图的根 Node 。
      ObjectProperty<String> userAgentStylesheet
      ReadOnlyDoubleProperty width
      这个宽度 Scene
      ReadOnlyObjectProperty<Window> window
      该 Window为这 Scene
      ReadOnlyDoubleProperty x
      这个 Scene的水平位置在 Window 。
      ReadOnlyDoubleProperty y
      这个 Scene的垂直位置在 Window 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Scene​(Parent root)
      为特定根节点创建场景。
      Scene​(Parent root, double width, double height)
      为特定大小的特定根节点创建场景。
      Scene​(Parent root, double width, double height, boolean depthBuffer)
      构造一个由根组成的场景，宽度和高度的尺寸，并指定是否为此场景创建深度缓冲区。
      Scene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      Scene​(Parent root, double width, double height, Paint fill)
      创建具有特定大小和填充的特定根节点的场景。
      Scene​(Parent root, Paint fill)
      为具有填充的特定根节点创建场景。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      <T extends Event>
      void             		addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      注册一个事件过滤器到这个场景。
      <T extends Event>
      void             		addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个场景。
      void addMnemonic​(Mnemonic m)
      注册指定的助记符。
      void addPostLayoutPulseListener​(Runnable r)
      在这个场景中添加一个新的场景布局脉冲侦听器。
      void addPreLayoutPulseListener​(Runnable r)
      在这个场景中添加一个新的场景预布置脉冲监听器。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此场景构建事件调度链。
      ObjectProperty<Camera> cameraProperty​()
      指定用于渲染 Scene的相机使用类型。
      ObjectProperty<Cursor> cursorProperty​()
      为此 Scene定义鼠标光标。
      void | disposePeer​()
      ReadOnlyObjectProperty<NodeOrientation> effectiveNodeOrientationProperty​()
      场景的有效节点方向解决节点方向的继承，从左到右或从右到左返回。
      void | enableInputMethodEvents​(boolean enable)
      ObjectProperty<EventDispatcher> eventDispatcherProperty​()
      指定此场景的事件调度程序。
      ObjectProperty<Paint> fillProperty​()
      定义此 Scene的背景填充。
      ReadOnlyObjectProperty<Node> focusOwnerProperty​()
      场景当前焦点所有者节点。
      ObservableMap<KeyCombination,Runnable> getAccelerators​()
      获取此 Scene的加速器列表。
      SceneAntialiasing getAntiAliasing​()
      返回 SceneAntialiasing定义的 Scene 。
      Camera getCamera​()
      获取属性摄像机的值。
      Cursor getCursor​()
      获取属性游标的值。
      NodeOrientation getEffectiveNodeOrientation​()
      获取属性effectiveNodeOrientation的值。
      EventDispatcher getEventDispatcher​()
      获取属性eventDispatcher的值。
      Paint getFill​()
      获取属性填充的值。
      Node getFocusOwner​()
      获取focusOwner属性的值。
      double getHeight​()
      获取属性高度的值。
      ObservableMap<KeyCombination,ObservableList<Mnemonic>> getMnemonics​()
      获取 Scene的助记符列表。
      NodeOrientation getNodeOrientation​()
      获取属性nodeOrientation的值。
      EventHandler<? super ContextMenuEvent> getOnContextMenuRequested​()
      获取属性onContextMenuRequested的值。
      EventHandler<? super MouseEvent> getOnDragDetected​()
      获取属性onDragDetected的值。
      EventHandler<? super DragEvent> getOnDragDone​()
      获取属性onDragDone的值。
      EventHandler<? super DragEvent> getOnDragDropped​()
      获取属性onDragDropped的值。
      EventHandler<? super DragEvent> getOnDragEntered​()
      获取属性onDragEntered的值。
      EventHandler<? super DragEvent> getOnDragExited​()
      获取属性onDragExited的值。
      EventHandler<? super DragEvent> getOnDragOver​()
      获取属性onDragOver的值。
      EventHandler<? super InputMethodEvent> getOnInputMethodTextChanged​()
      获取onInputMethodTextChanged属性的值。
      EventHandler<? super KeyEvent> getOnKeyPressed​()
      获取属性onKeyPressed的值。
      EventHandler<? super KeyEvent> getOnKeyReleased​()
      获取属性onKeyReleased的值。
      EventHandler<? super KeyEvent> getOnKeyTyped​()
      获取属性onKeyTyped的值。
      EventHandler<? super MouseEvent> getOnMouseClicked​()
      获取属性onMouseClicked的值。
      EventHandler<? super MouseDragEvent> getOnMouseDragEntered​()
      获取属性onMouseDragEntered的值。
      EventHandler<? super MouseDragEvent> getOnMouseDragExited​()
      获取属性onMouseDragExited的值。
      EventHandler<? super MouseEvent> getOnMouseDragged​()
      获取属性onMouseDragged的值。
      EventHandler<? super MouseDragEvent> getOnMouseDragOver​()
      获取属性onMouseDragOver的值。
      EventHandler<? super MouseDragEvent> getOnMouseDragReleased​()
      获取属性onMouseDragReleased的值。
      EventHandler<? super MouseEvent> getOnMouseEntered​()
      获取属性onMouseEntered的值。
      EventHandler<? super MouseEvent> getOnMouseExited​()
      获取属性onMouseExited的值。
      EventHandler<? super MouseEvent> getOnMouseMoved​()
      获取属性onMouseMoved的值。
      EventHandler<? super MouseEvent> getOnMousePressed​()
      获取属性onMousePressed的值。
      EventHandler<? super MouseEvent> getOnMouseReleased​()
      获取属性onMouseReleased的值。
      EventHandler<? super RotateEvent> getOnRotate​()
      获取属性onRotate的值。
      EventHandler<? super RotateEvent> getOnRotationFinished​()
      获取属性onRotationFinished的值。
      EventHandler<? super RotateEvent> getOnRotationStarted​()
      获取属性onRotationStarted的值。
      EventHandler<? super ScrollEvent> getOnScroll​()
      获取属性onScroll的值。
      EventHandler<? super ScrollEvent> getOnScrollFinished​()
      获取属性onScrollFinished的值。
      EventHandler<? super ScrollEvent> getOnScrollStarted​()
      获取属性onScrollStarted的值。
      EventHandler<? super SwipeEvent> getOnSwipeDown​()
      获取属性onSwipeDown的值。
      EventHandler<? super SwipeEvent> getOnSwipeLeft​()
      获取属性onSwipeLeft的值。
      EventHandler<? super SwipeEvent> getOnSwipeRight​()
      获取属性onSwipeRight的值。
      EventHandler<? super SwipeEvent> getOnSwipeUp​()
      获取属性onSwipeUp的值。
      EventHandler<? super TouchEvent> getOnTouchMoved​()
      获取onTouchMoved属性的值。
      EventHandler<? super TouchEvent> getOnTouchPressed​()
      获取onTouchPressed属性的值。
      EventHandler<? super TouchEvent> getOnTouchReleased​()
      获取onTouchReleased属性的值。
      EventHandler<? super TouchEvent> getOnTouchStationary​()
      获取属性onTouchStationary的值。
      EventHandler<? super ZoomEvent> getOnZoom​()
      获取属性onZoom的值。
      EventHandler<? super ZoomEvent> getOnZoomFinished​()
      获取属性onZoomFinished的值。
      EventHandler<? super ZoomEvent> getOnZoomStarted​()
      获取属性onZoomStarted的值。
      ObservableMap<Object,Object> getProperties​()
      返回此节点上属性的可观察图，主要由应用程序开发人员使用。
      Parent getRoot​()
      获取属性根的值。
      ObservableList<String> getStylesheets​()
      获取链接到与场景内容一起使用的样式表的字符串URL的可观察列表。
      String getUserAgentStylesheet​()
      获取此场景将使用的用户代理样式表的URL。
      Object getUserData​()
      返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
      double getWidth​()
      获取属性宽度的值。
      Window getWindow​()
      获取属性窗口的值。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      boolean hasProperties​()
      测试场景是否具有属性。
      ReadOnlyDoubleProperty heightProperty​()
      这个高度 Scene
      boolean isDepthBuffer​()
      检索此场景的深度缓冲区属性。
      Node lookup​(String selector)
      根据指定的CSS选择器查找场景图中的任何节点。
      ObjectProperty<NodeOrientation> nodeOrientationProperty​()
      属性保存NodeOrientation。
      ObjectProperty<EventHandler<? super ContextMenuEvent>> onContextMenuRequestedProperty​()
      定义在这个 Scene上点击（按下并释放）鼠标按钮时调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onDragDetectedProperty​()
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragDoneProperty​()
      定义当这个 Scene是数据放在放置目标上之后的拖放手势源时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> onDragDroppedProperty​()
      定义在拖放手势时，在此 Scene上释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragEnteredProperty​()
      定义当拖动手势进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> onDragExitedProperty​()
      定义当拖动手势退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> onDragOverProperty​()
      定义当这个 Scene拖动手势进度时要调用的函数。
      ObjectProperty<EventHandler<? super InputMethodEvent>> onInputMethodTextChangedProperty​()
      当这个 Node具有输入焦点并且输入法文本已经改变时，定义要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyPressedProperty​()
      当 Node的 Scene具有输入焦点并按下一个键时，定义要调用的功能。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyReleasedProperty​()
      定义当 Node的 Scene有一个输入焦点和一个键被释放时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> onKeyTypedProperty​()
      定义要调用的函数，当一些 Node如此 Scene具有输入焦点和重点已经输入。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseClickedProperty​()
      定义当这个 Scene点击（按下并释放）鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragEnteredProperty​()
      定义当完全按下 - 拖动释放手势进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragExitedProperty​()
      定义当完全按下 - 拖动释放手势退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseDraggedProperty​()
      定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragOverProperty​()
      定义当这个 Scene内完全按下 Scene释放手势时，要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragReleasedProperty​()
      定义当完全按下 - 拖动释放手势在此 Scene内结束时调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseEnteredProperty​()
      定义当鼠标进入 Scene时调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseExitedProperty​()
      定义当鼠标退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseMovedProperty​()
      定义当这个 Scene鼠标光标移动时调用的功能，但没有按钮被按下。
      ObjectProperty<EventHandler<? super MouseEvent>> onMousePressedProperty​()
      定义在 Scene上按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> onMouseReleasedProperty​()
      定义当这个 Scene释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotateProperty​()
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotationFinishedProperty​()
      定义当旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> onRotationStartedProperty​()
      定义检测到旋转手势时要调用的功能。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollFinishedProperty​()
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollProperty​()
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> onScrollStartedProperty​()
      定义检测到滚动手势时要调用的函数。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeDownProperty​()
      定义当在此场景中发生向下滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeLeftProperty​()
      定义当在此场景中发生向左滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeRightProperty​()
      定义当在此场景中发生向右滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeUpProperty​()
      定义当在此场景中发生向上滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchMovedProperty​()
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchPressedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchReleasedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> onTouchStationaryProperty​()
      定义当触摸点保持按下并静止时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomFinishedProperty​()
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomProperty​()
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> onZoomStartedProperty​()
      定义检测到缩放手势时要调用的功能。
      void | processKeyEvent​(KeyEvent e)
      <T extends Event>
      void             		removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此场景注销先前注册的事件过滤器。
      <T extends Event>
      void             		removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此场景注销先前注册的事件处理程序。
      void removeMnemonic​(Mnemonic m)
      取消注册指定的助记符。
      void removePostLayoutPulseListener​(Runnable r)
      从这个场景中的脉冲中删除先前注册的场景布局脉冲侦听器。
      void removePreLayoutPulseListener​(Runnable r)
      从此场景中的脉冲中删除先前注册的场景预布置脉冲侦听器。
      ObjectProperty<Parent> rootProperty​()
      定义场景图的根 Node 。
      void setCamera​(Camera value)
      设置属性摄像机的值。
      void setCursor​(Cursor value)
      设置属性游标的值。
      void setEventDispatcher​(EventDispatcher value)
      设置属性eventDispatcher的值。
      protected <T extends Event>
      void             		setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      void setFill​(Paint value)
      设置属性填充的值。
      void setNodeOrientation​(NodeOrientation orientation)
      设置属性nodeOrientation的值。
      void setOnContextMenuRequested​(EventHandler<? super ContextMenuEvent> value)
      设置属性onContextMenuRequested的值。
      void setOnDragDetected​(EventHandler<? super MouseEvent> value)
      设置属性onDragDetected的值。
      void setOnDragDone​(EventHandler<? super DragEvent> value)
      设置属性onDragDone的值。
      void setOnDragDropped​(EventHandler<? super DragEvent> value)
      设置属性onDragDropped的值。
      void setOnDragEntered​(EventHandler<? super DragEvent> value)
      设置属性onDragEntered的值。
      void setOnDragExited​(EventHandler<? super DragEvent> value)
      设置属性onDragExited的值。
      void setOnDragOver​(EventHandler<? super DragEvent> value)
      设置属性onDragOver的值。
      void setOnInputMethodTextChanged​(EventHandler<? super InputMethodEvent> value)
      设置属性onInputMethodTextChanged的值。
      void setOnKeyPressed​(EventHandler<? super KeyEvent> value)
      设置属性onKeyPressed的值。
      void setOnKeyReleased​(EventHandler<? super KeyEvent> value)
      设置属性onKeyReleased的值。
      void setOnKeyTyped​(EventHandler<? super KeyEvent> value)
      设置属性onKeyTyped的值。
      void setOnMouseClicked​(EventHandler<? super MouseEvent> value)
      设置属性onMouseClicked的值。
      void setOnMouseDragEntered​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragEntered的值。
      void setOnMouseDragExited​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragExited的值。
      void setOnMouseDragged​(EventHandler<? super MouseEvent> value)
      设置属性onMouseDragged的值。
      void setOnMouseDragOver​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragOver的值。
      void setOnMouseDragReleased​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragReleased的值。
      void setOnMouseEntered​(EventHandler<? super MouseEvent> value)
      设置属性onMouseEntered的值。
      void setOnMouseExited​(EventHandler<? super MouseEvent> value)
      设置属性onMouseExited的值。
      void setOnMouseMoved​(EventHandler<? super MouseEvent> value)
      设置属性onMouseMoved的值。
      void setOnMousePressed​(EventHandler<? super MouseEvent> value)
      设置属性onMousePressed的值。
      void setOnMouseReleased​(EventHandler<? super MouseEvent> value)
      设置属性onMouseReleased的值。
      void setOnRotate​(EventHandler<? super RotateEvent> value)
      设置属性onRotate的值。
      void setOnRotationFinished​(EventHandler<? super RotateEvent> value)
      设置属性onRotationFinished的值。
      void setOnRotationStarted​(EventHandler<? super RotateEvent> value)
      设置属性onRotationStarted的值。
      void setOnScroll​(EventHandler<? super ScrollEvent> value)
      设置属性onScroll的值。
      void setOnScrollFinished​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollFinished的值。
      void setOnScrollStarted​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollStarted的值。
      void setOnSwipeDown​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeDown的值。
      void setOnSwipeLeft​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeLeft的值。
      void setOnSwipeRight​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeRight的值。
      void setOnSwipeUp​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeUp的值。
      void setOnTouchMoved​(EventHandler<? super TouchEvent> value)
      设置属性onTouchMoved的值。
      void setOnTouchPressed​(EventHandler<? super TouchEvent> value)
      设置属性onTouchPressed的值。
      void setOnTouchReleased​(EventHandler<? super TouchEvent> value)
      设置属性onTouchReleased的值。
      void setOnTouchStationary​(EventHandler<? super TouchEvent> value)
      设置属性onTouchStationary的值。
      void setOnZoom​(EventHandler<? super ZoomEvent> value)
      设置Zoom上的属性值。
      void setOnZoomFinished​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomFinished的值。
      void setOnZoomStarted​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomStarted的值。
      void setRoot​(Parent value)
      设置属性根的值。
      void setUserAgentStylesheet​(String url)
      设置此场景将使用的用户代理样式表的URL，而不是platform-default用户代理样式表。
      void setUserData​(Object value)
      用于设置可以在以后检索的单个Object属性的便利方法。
      WritableImage snapshot​(WritableImage image)
      拍摄此场景的快照，并在渲染图像准备就绪时返回。
      void snapshot​(Callback<SnapshotResult,Void> callback, WritableImage image)
      在下一帧拍摄此场景的快照，并在图像准备就绪时调用指定的回调方法。
      Dragboard startDragAndDrop​(TransferMode... transferModes)
      确认一个潜在的拖放手势，这在 Scene被认可。
      void startFullDrag​()
      开始一个完整的按下 - 拖动释放手势与这个场景作为手势源。
      ObjectProperty<String> userAgentStylesheetProperty​()
      ReadOnlyDoubleProperty widthProperty​()
      这个宽度 Scene
      ReadOnlyObjectProperty<Window> windowProperty​()
      该 Window为这 Scene
      ReadOnlyDoubleProperty xProperty​()
      这个 Scene的水平位置在 Window 。
      ReadOnlyDoubleProperty yProperty​()
      该 Scene的垂直位置在 Window 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • window

        public final ReadOnlyObjectProperty<Window> windowProperty
        该 Window为这 Scene
        另请参见：
        getWindow()

      • x

        public final ReadOnlyDoubleProperty xProperty
        这个 Scene的水平位置在 Window 。
        另请参见：
        getX()

      • y

        public final ReadOnlyDoubleProperty yProperty
        这个 Scene的垂直位置在 Window 。
        另请参见：
        getY()

      • width

        public final ReadOnlyDoubleProperty widthProperty
        这个宽度 Scene
        另请参见：
        getWidth()

      • height

        public final ReadOnlyDoubleProperty heightProperty
        这个高度 Scene
        另请参见：
        getHeight()

      • camera

        public final ObjectProperty<Camera> cameraProperty
        指定用于渲染Scene的相机使用类型。 如果camera为空，则使用并行摄像机进行渲染。 设置属于其他Scene或SubScene的相机是非法的。

        注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        空值
        另请参见：
        getCamera() ， setCamera(Camera)

      • fill

        public final ObjectProperty<Paint> fillProperty
        定义此Scene的背景填充。 一个null值意味着“油漆没有背景”和一个Paint与透明度是支持的。 场景的默认填充为Color.WHITE ，但是更常见的情况是，向用户显示的初始颜色是Scene的Scene的背景填充，因为它通常被拉伸以占用Scene中的所有可用空间。 Scene被赋予了CSS样式类“root”，JavaFX（目前的Caspian和Modena）附带的默认用户代理样式表将样式应用于此根风格类。 在Caspian的情况下，这不会影响根节点的背景填充颜色，但是在Modena的情况下，默认填充设置为浅灰色。
        Default value:
        白色
        另请参见：
        getFill() ， setFill(Paint)

      • root

        public final ObjectProperty<Parent> rootProperty
        定义场景图的根Node 。 如果使用Group作为根，则场景图形的内容将被场景的宽度和高度剪辑，并更改为场景的大小（如果用户调整舞台大小）将不会更改场景图的布局。 如果将可调整大小的节点（布局Region或Control ）设置为根，则根的大小将跟踪场景的大小，导致根据需要中继内容。 场景不接受null根。
        另请参见：
        getRoot() ， setRoot(Parent)

      • cursor

        public final ObjectProperty<Cursor> cursorProperty
        为此 Scene定义鼠标光标。
        另请参见：
        getCursor() ， setCursor(Cursor)

      • userAgentStylesheet

        public final ObjectProperty<String> userAgentStylesheetProperty
        从以下版本开始：
        JavaFX 8u20
        另请参见：
        getUserAgentStylesheet() ， setUserAgentStylesheet(String)

      • focusOwner

        public final ReadOnlyObjectProperty<Node> focusOwnerProperty
        场景当前焦点所有者节点。 如果此场景没有窗口，或者窗口处于非活动状态（window.focused == false），则此节点的“focus”变量可能为false。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getFocusOwner()

      • eventDispatcher

        public final ObjectProperty<EventDispatcher> eventDispatcherProperty
        指定此场景的事件调度程序。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到替换的调度程序，以保持场景的默认事件处理行为。
        另请参见：
        getEventDispatcher() ， setEventDispatcher(EventDispatcher)

      • onContextMenuRequested

        public final ObjectProperty<EventHandler<? super ContextMenuEvent>> onContextMenuRequestedProperty
        定义当这个 Scene点击（按下和释放）鼠标按钮时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnContextMenuRequested() ， setOnContextMenuRequested(EventHandler)

      • onMouseClicked

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseClickedProperty
        定义当这个 Scene点击（按下和释放）鼠标按钮时要调用的功能。
        另请参见：
        getOnMouseClicked() ， setOnMouseClicked(EventHandler)

      • onMouseDragged

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseDraggedProperty
        定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。
        另请参见：
        getOnMouseDragged() ， setOnMouseDragged(EventHandler)

      • onMouseEntered

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseEnteredProperty
        定义当鼠标进入 Scene时要调用的功能。
        另请参见：
        getOnMouseEntered() ， setOnMouseEntered(EventHandler)

      • onMouseExited

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseExitedProperty
        定义当鼠标退出 Scene时要调用的函数。
        另请参见：
        getOnMouseExited() ， setOnMouseExited(EventHandler)

      • onMouseMoved

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseMovedProperty
        定义当这个 Scene鼠标光标移动时调用的功能，但没有按钮被按下。
        另请参见：
        getOnMouseMoved() ， setOnMouseMoved(EventHandler)

      • onMousePressed

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMousePressedProperty
        定义在 Scene上按下鼠标按钮时要调用的功能。
        另请参见：
        getOnMousePressed() ， setOnMousePressed(EventHandler)

      • onMouseReleased

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseReleasedProperty
        定义在 Scene上释放鼠标按钮时要调用的功能。
        另请参见：
        getOnMouseReleased() ， setOnMouseReleased(EventHandler)

      • onDragDetected

        public final ObjectProperty<EventHandler<? super MouseEvent>> onDragDetectedProperty
        定义检测到拖动手势时要调用的功能。 这是开始拖放操作的正确位置。
        另请参见：
        getOnDragDetected() ， setOnDragDetected(EventHandler)

      • onMouseDragOver

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragOverProperty
        定义当这个 Scene完全按下 - 拖动释放手势进行时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragOver() ， setOnMouseDragOver(EventHandler)

      • onMouseDragReleased

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragReleasedProperty
        定义当完全按下 - 拖动释放手势在此 Scene内结束时调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragReleased() ， setOnMouseDragReleased(EventHandler)

      • onMouseDragEntered

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragEnteredProperty
        定义当全按压拖动手势进入这个 Scene时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragEntered() ， setOnMouseDragEntered(EventHandler)

      • onMouseDragExited

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragExitedProperty
        定义当完全按下 - 拖动释放手势退出 Scene时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragExited() ， setOnMouseDragExited(EventHandler)

      • onScrollStarted

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollStartedProperty
        定义检测到滚动手势时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnScrollStarted() ， setOnScrollStarted(EventHandler)

      • onScroll

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollProperty
        定义当用户执行滚动操作时要调用的函数。
        另请参见：
        getOnScroll() ， setOnScroll(EventHandler)

      • onScrollFinished

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollFinishedProperty
        定义当滚动手势结束时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnScrollFinished() ， setOnScrollFinished(EventHandler)

      • onRotationStarted

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotationStartedProperty
        定义检测到旋转手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotationStarted() ， setOnRotationStarted(EventHandler)

      • onRotate

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotateProperty
        定义当用户执行旋转操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotate() ， setOnRotate(EventHandler)

      • onRotationFinished

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotationFinishedProperty
        定义当旋转手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotationFinished() ， setOnRotationFinished(EventHandler)

      • onZoomStarted

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomStartedProperty
        定义检测到缩放手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoomStarted() ， setOnZoomStarted(EventHandler)

      • onZoom

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomProperty
        定义当用户执行缩放操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoom() ， setOnZoom(EventHandler)

      • onZoomFinished

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomFinishedProperty
        定义当缩放手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoomFinished() ， setOnZoomFinished(EventHandler)

      • onSwipeUp

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeUpProperty
        定义当在此场景中发生向上滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeUp() ， setOnSwipeUp(EventHandler)

      • onSwipeDown

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeDownProperty
        定义当在此场景中发生向下滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeDown() ， setOnSwipeDown(EventHandler)

      • onSwipeLeft

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeLeftProperty
        定义当在此场景中发生向左滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeLeft() ， setOnSwipeLeft(EventHandler)

      • onSwipeRight

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeRightProperty
        定义当在此场景中发生向右滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeRight() ， setOnSwipeRight(EventHandler)

      • onTouchPressed

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchPressedProperty
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchPressed() ， setOnTouchPressed(EventHandler)

      • onTouchMoved

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchMovedProperty
        定义当触摸点移动时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchMoved() ， setOnTouchMoved(EventHandler)

      • onTouchReleased

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchReleasedProperty
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchReleased() ， setOnTouchReleased(EventHandler)

      • onTouchStationary

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchStationaryProperty
        定义当触摸点保持按下并静止时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchStationary() ， setOnTouchStationary(EventHandler)

      • onDragEntered

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragEnteredProperty
        定义当拖动手势进入 Scene时要调用的功能。
        结果
        当拖动手势进入这个场景时被调用的功能

      • onDragExited

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragExitedProperty
        定义拖动手势退出 Scene时要调用的函数。
        另请参见：
        getOnDragExited() ， setOnDragExited(EventHandler)

      • onDragOver

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragOverProperty
        定义当这个 Scene拖动手势进度时要调用的函数。
        另请参见：
        getOnDragOver() ， setOnDragOver(EventHandler)

      • onDragDropped

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragDroppedProperty
        定义在拖放手势时，在此Scene上释放鼠标按钮时要调用的功能。 在DragEvent的dragboard中的数据传输应该发生在这个功能中。
        另请参见：
        getOnDragDropped() ， setOnDragDropped(EventHandler)

      • onDragDone

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragDoneProperty
        定义当这个Scene是一个拖放手势源，当它的数据已经放在放置目标上之后被调用的函数。 事件的transferMode显示刚刚发生的放下目标。 如果transferMode的值为MOVE ，则源可以清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 甲transferMode具有值NONE指示拖放手势期间没有数据被转移。 DragEvent位置数据无效。 DragEvent有效位置数据显示在onDragDropped事件处理程序中。
        另请参见：
        getOnDragDone() ， setOnDragDone(EventHandler)

      • onKeyPressed

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyPressedProperty
        定义要调用的函数，当一些Node如此Scene具有输入焦点和键被按下。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyPressed() ， setOnKeyPressed(EventHandler)

      • onKeyReleased

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyReleasedProperty
        当Node的Scene具有输入焦点并且键被释放时，定义要调用的功能。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyReleased() ， setOnKeyReleased(EventHandler)

      • onKeyTyped

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyTypedProperty
        当Node的Scene具有输入焦点并键入了一个键时，定义要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyTyped() ， setOnKeyTyped(EventHandler)

      • onInputMethodTextChanged

        public final ObjectProperty<EventHandler<? super InputMethodEvent>> onInputMethodTextChangedProperty
        当这个Node具有输入焦点并且输入法文本已经改变时，定义要调用的函数。 如果此功能未在此Node定义，则会将该输入法组合的结果字符串接收为一系列onKeyTyped函数调用。

        当Node丢失输入焦点时，JavaFX运行时会自动提交现有的合成文本（如果有的话）。

        另请参见：
        getOnInputMethodTextChanged() ， setOnInputMethodTextChanged(EventHandler)

      • nodeOrientation

        public final ObjectProperty<NodeOrientation> nodeOrientationProperty
        属性保存NodeOrientation。

        节点方向描述节点内视觉数据的流动。 在英语世界中，视觉数据通常从左到右流动。 在阿拉伯语或希伯来语世界，视觉数据从右到左流动。 这与两个世界的文本阅读顺序一致。 默认值是从左到右。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getNodeOrientation() ， setNodeOrientation(NodeOrientation)

      • effectiveNodeOrientation

        public final ReadOnlyObjectProperty<NodeOrientation> effectiveNodeOrientationProperty
        场景的有效节点方向解决节点方向的继承，从左到右或从右到左返回。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getEffectiveNodeOrientation()

    • 构造方法详细信息

      • Scene

        public Scene​(Parent root)
        为特定根节点创建场景。
        参数
        root - 场景图的根节点
        异常
        NullPointerException - 如果root为null

      • Scene

        public Scene​(Parent root,
             double width,
             double height)
        为特定大小的特定根节点创建场景。
        参数
        root - 场景图的根节点
        width - 场景的宽度
        height - 场景的高度
        异常
        NullPointerException - 如果root为null

      • Scene

        public Scene​(Parent root,
             Paint fill)
        为具有填充的特定根节点创建场景。
        参数
        root - 父母
        fill - 填写
        异常
        NullPointerException - 如果root为null

      • Scene

        public Scene​(Parent root,
             double width,
             double height,
             Paint fill)
        创建具有特定大小和填充的特定根节点的场景。
        参数
        root - 场景图的根节点
        width - 场景的宽度
        height - 场景的高度
        fill - 填写
        异常
        NullPointerException - 如果root为null

      • Scene

        public Scene​(Parent root,
             double width,
             double height,
             boolean depthBuffer)
        构造一个由根组成的场景，宽度和高度的尺寸，并指定是否为此场景创建深度缓冲区。

        只有2D形状和没有任何3D变换的场景不需要深度缓冲区。 包含3D形状或具有3D变换的2D形状的场景可以使用深度缓冲区支持来进行适当的深度排序渲染; 为了避免深度战斗（也称为Z战斗），禁止没有3D转换的2D形状的深度测试。 有关详细信息，请参阅depthTest 。

        参数
        root - 场景图的根节点
        width - 场景的宽度
        height - 场景的高度
        depthBuffer - 深度缓冲标志

        depthBuffer标志是条件特征，其默认值为false。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        异常
        NullPointerException - 如果root为null
        另请参见：
        Node.setDepthTest(DepthTest)

      • Scene

        public Scene​(Parent root,
             double width,
             double height,
             boolean depthBuffer,
             SceneAntialiasing antiAliasing)
        构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。

        只有2D形状和没有任何3D变换的场景不需要深度缓冲区和场景抗锯齿支持。 包含3D形状或具有3D变换的2D形状的场景可以使用深度缓冲区支持来进行适当的深度排序渲染; 为了避免深度战斗（也称为Z战斗），禁止没有3D转换的2D形状的深度测试。 有关详细信息，请参阅depthTest 。 具有3D形状的场景可以实现场景抗锯齿以改善其渲染质量。

        参数
        root - 场景图的根节点
        width - 场景的宽度
        height - 场景的高度
        depthBuffer - 深度缓冲区标志
        antiAliasing - 场景抗锯齿属性。 值null被视为DISABLED。

        depthBuffer和antiAliasing是条件特征。 使用各自的默认值：false和SceneAntialiasing.DISABLED 。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        异常
        NullPointerException - 如果root为null
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Node.setDepthTest(DepthTest)

    • 方法详细信息

      • addPreLayoutPulseListener

        public final void addPreLayoutPulseListener​(Runnable r)
        在这个场景中添加一个新的场景预布置脉冲监听器。 每次发生脉冲时，这个监听器将在CSS和布局通过之前直接在 JavaFX应用程序线程上调用，并且在此帧完成任何渲染之前。 这种场景脉冲监听器适合于了解场景脉冲何时发生，也适用于修改场景图（如在CSS和布局之前调用的，因此所做的任何更改将被正确设置和定位）。 必须在JavaFX应用程序线程上调用此方法。
        参数
        r - 当脉冲发生时被调用的Runnable。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        NullPointerException - 如果提供的Runnable为空。
        从以下版本开始：
        9

      • removePreLayoutPulseListener

        public final void removePreLayoutPulseListener​(Runnable r)
        从此场景中的脉冲中删除先前注册的场景预布置脉冲侦听器。 如果指定的Runnable不在列表中，此方法将不起作用。 必须在JavaFX应用程序线程上调用此方法。
        参数
        r - 当这个场景发生脉冲时不应再调用的Runnable。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        从以下版本开始：
        9

      • addPostLayoutPulseListener

        public final void addPostLayoutPulseListener​(Runnable r)
        在这个场景中添加一个新的场景布局脉冲侦听器。 每次发生脉冲时，这个监听器将在CSS和布局通过之后直接在 JavaFX应用程序线程上调用，但在此帧完成任何渲染之前。 这种场景脉冲监听器适用于知道场景脉冲何时发生，但不适合使用与修改场景图相关的情况（因为CSS和布局之后调用，所以任何更改都可能不正确，直到下一个脉冲为跑）。 需要进行场景修改的情况的另一种（更好的）解决方案是使用addPreLayoutPulseListener(Runnable) API或AnimationTimer API。 必须在JavaFX应用程序线程上调用此方法。
        参数
        r - 脉冲发生时要调用的Runnable。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        NullPointerException - 如果提供的Runnable为空。
        从以下版本开始：
        9

      • removePostLayoutPulseListener

        public final void removePostLayoutPulseListener​(Runnable r)
        从这个场景中的脉冲中删除先前注册的场景布局脉冲侦听器。 如果指定的Runnable不在列表中，此方法将不起作用。 必须在JavaFX应用程序线程上调用此方法。
        参数
        r - 当此场景发生脉冲时不应再调用的Runnable。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        从以下版本开始：
        9

      • getAntiAliasing

        public final SceneAntialiasing getAntiAliasing​()
        返回SceneAntialiasing的Scene 。

        注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D和SceneAntialiasing 。

        结果
        该场景的SceneAntialiasing
        从以下版本开始：
        JavaFX 8.0

      • getWindow

        public final Window getWindow​()
        获取属性窗口的值。
        Property description:
        该 Window为这 Scene

      • windowProperty

        public final ReadOnlyObjectProperty<Window> windowProperty​()
        该 Window为这 Scene
        另请参见：
        getWindow()

      • disposePeer

        public void disposePeer​()

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        这个 Scene的水平位置在 Window 。

      • xProperty

        public final ReadOnlyDoubleProperty xProperty​()
        这个 Scene的水平位置在 Window 。
        另请参见：
        getX()

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        这个 Scene的垂直位置在 Window 。

      • yProperty

        public final ReadOnlyDoubleProperty yProperty​()
        这个 Scene的垂直位置在 Window 。
        另请参见：
        getY()

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        这个宽度 Scene

      • widthProperty

        public final ReadOnlyDoubleProperty widthProperty​()
        该宽度为 Scene
        另请参见：
        getWidth()

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        这个高度 Scene

      • heightProperty

        public final ReadOnlyDoubleProperty heightProperty​()
        这个高度 Scene
        另请参见：
        getHeight()

      • setCamera

        public final void setCamera​(Camera value)
        设置属性摄像机的值。
        Property description:
        指定用于渲染Scene的相机使用类型。 如果camera为空，则使用并行摄像头进行渲染。 设置属于其他Scene或SubScene的相机是非法的。

        注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        空值

      • getCamera

        public final Camera getCamera​()
        获取属性摄像机的值。
        Property description:
        指定用于渲染Scene的相机使用类型。 如果camera为空，则使用并行摄像机进行渲染。 设置属于其他Scene或SubScene的相机是非法的。

        注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        空值

      • cameraProperty

        public final ObjectProperty<Camera> cameraProperty​()
        指定用于呈现Scene的相机使用类型。 如果camera为空，则使用并行摄像机进行渲染。 设置属于其他Scene或SubScene的相机是非法的。

        注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        空值
        另请参见：
        getCamera() ， setCamera(Camera)

      • setFill

        public final void setFill​(Paint value)
        设置属性填充的值。
        Property description:
        定义此Scene的背景填充。 一个null值意味着“油漆没有背景”和一个Paint与透明度。 场景的默认填充是Color.WHITE ，但是更常见的情况是，向用户显示的初始颜色是Scene的Scene的背景填充，因为它通常被拉伸以占用Scene中的所有可用空间。 Scene被赋予CSS样式类“root”，JavaFX（目前为Caspian和Modena）附带的默认用户代理样式表将样式应用于此根风格类。 在Caspian的情况下，这不会影响根节点的背景填充颜色，但是在Modena的情况下，默认填充设置为浅灰色。
        Default value:
        白色

      • getFill

        public final Paint getFill​()
        获取属性填充的值。
        Property description:
        定义此Scene的背景填充。 一个null值意味着“油漆没有背景”和一个Paint与透明度。 场景的默认填充是Color.WHITE ，但是更常见的情况是，向用户显示的初始颜色是Scene的Scene的背景填充，因为它通常被拉伸以占用Scene中的所有可用空间。 Scene被赋予CSS样式类“root”，JavaFX（目前为Caspian和Modena）附带的默认用户代理样式表将样式应用于此根风格类。 在Caspian的情况下，这不会影响根节点的背景填充颜色，但是在Modena的情况下，默认填充设置为浅灰色。
        Default value:
        白色

      • fillProperty

        public final ObjectProperty<Paint> fillProperty​()
        定义此Scene的背景填充。 一个null值意味着“油漆没有背景”和Paint与透明度是支持的。 场景的默认填充是Color.WHITE ，但是更常见的情况是，向用户显示的初始颜色是Scene的Scene的背景填充，因为它通常被拉伸以占用Scene中的所有可用空间。 Scene被赋予CSS样式类“root”，JavaFX（目前为Caspian和Modena）附带的默认用户代理样式表将样式应用于此根风格类。 在Caspian的情况下，这不会影响根节点的背景填充颜色，但是在Modena的情况下，默认填充设置为浅灰色。
        Default value:
        白色
        另请参见：
        getFill() ， setFill(Paint)

      • setRoot

        public final void setRoot​(Parent value)
        设置属性根的值。
        Property description:
        定义场景图的根Node 。 如果使用Group作为根，则场景图的内容将被场景的宽度和高度剪切，并且改变为场景的大小（如果用户调整舞台大小）将不会改变场景图的布局。 如果将可调节大小的节点（布局Region或Control ）设置为根，则根的大小将跟踪场景的大小，导致根据需要中继内容。 场景不接受null根。

      • getRoot

        public final Parent getRoot​()
        获取属性根的值。
        Property description:
        定义场景图的根Node 。 如果使用Group作为根，则场景图的内容将被场景的宽度和高度剪辑，并且改变为场景的大小（如果用户调整舞台大小）将不会改变场景图的布局。 如果将可调节大小的节点（布局Region或Control ）设置为根，则根的大小将跟踪场景的大小，导致内容根据需要被中继。 场景不接受null根。

      • rootProperty

        public final ObjectProperty<Parent> rootProperty​()
        定义场景图的根Node 。 如果使用Group作为根，则场景图的内容将被场景的宽度和高度剪切，并改变为场景的大小（如果用户调整舞台大小）将不会改变场景图的布局。 如果将可调节大小的节点（布局Region或Control ）设置为根，则根的大小将跟踪场景的大小，导致根据需要中继内容。 场景不接受null根。
        另请参见：
        getRoot() ， setRoot(Parent)

      • snapshot

        public WritableImage snapshot​(WritableImage image)
        拍摄此场景的快照，并在渲染图像准备就绪时返回。 在渲染之前，将对场景进行CSS和布局处理。 使用此场景的填充Paint清除整个目标图像。 然后将场景中的节点呈现给图像。 场景坐标中的点（0,0）映射到图像中的（0,0）。 如果图像小于场景的大小，则渲染将被图像剪辑。

        当通过应用程序或隐式（如图表动画）明确地拍摄场景的快照时，将根据快照拍摄时的场景图形的状态渲染快照，并且不会反映任何随后的动画更改。

        参数
        image - 将用于保存渲染场景的可写图像。 它可能为null，在这种情况下，将构建一个新的WritableImage。 如果图像非空，则场景将呈现为现有图像。 在这种情况下，图像的宽度和高度决定了渲染的区域，而不是场景的宽度和高度。
        结果
        渲染图像
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        从以下版本开始：
        JavaFX 2.2

      • snapshot

        public void snapshot​(Callback<SnapshotResult,Void> callback,
                     WritableImage image)
        在下一帧拍摄此场景的快照，并在图像准备就绪时调用指定的回调方法。 在渲染之前，将对场景进行CSS和布局处理。 使用此场景的填充Paint清除整个目标图像。 然后将场景中的节点呈现给图像。 场景坐标中的点（0,0）映射到图像中的（0,0）。 如果图像小于场景的大小，则渲染将被图像剪辑。

        这是一个异步调用，这意味着可以在呈现场景之前处理其他事件或动画。 如果任何这样的事件修改场景中的修改将在渲染图像中反映出来的节点（因为它也将反映在渲染到舞台的帧中）。

        当通过应用程序或隐式（如图表动画）明确地拍摄场景的快照时，将根据快照拍摄时的场景图形的状态渲染快照，并且不会反映任何随后的动画更改。

        参数
        callback - 当图像准备好时调用方法的类。 传递到回调的调用方法的SnapshotResult将包含渲染的图像和渲染的源场景。 回调参数不能为空。
        image - 将用于保存渲染场景的可写图像。 它可能为null，在这种情况下，将构建一个新的WritableImage。 如果图像非空，则场景将呈现为现有图像。 在这种情况下，图像的宽度和高度决定了渲染的区域，而不是场景的宽度和高度。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        NullPointerException - 如果回调参数为空。
        从以下版本开始：
        JavaFX 2.2

      • setCursor

        public final void setCursor​(Cursor value)
        设置属性游标的值。
        Property description:
        为此 Scene定义鼠标光标。

      • getCursor

        public final Cursor getCursor​()
        获取属性游标的值。
        Property description:
        为此 Scene定义鼠标光标。

      • cursorProperty

        public final ObjectProperty<Cursor> cursorProperty​()
        为此 Scene定义鼠标光标。
        另请参见：
        getCursor() ， setCursor(Cursor)

      • lookup

        public Node lookup​(String selector)
        根据指定的CSS选择器查找场景图中的任何节点。 如果多个节点与指定的选择器匹配，则此函数返回第一个节点。 如果没有使用此id找到节点，则返回null。
        参数
        selector - 要查找的css选择器
        结果
        在 Node的CSS相匹配现场 selector ，或 null如果没有被发现。

      • getStylesheets

        public final ObservableList<String> getStylesheets​()
        获取链接到与场景内容一起使用的样式表的字符串URL的可观察列表。

        URL是[scheme：] [// authority] [path]形式的分层URI。 如果URL没有[scheme：]组件，则该URL仅被认为是[path]组件。 [path]的任何前导的'/'字符被忽略，并且[path]被视为相对于应用程序的类路径的根的路径。

           package com.example.javafx.app; import javafx.application.Application; import javafx.scene.Group; import javafx.scene.Scene; import javafx.stage.Stage; public class MyApp extends Application { @Override public void start(Stage stage) { Scene scene = new Scene(new Group()); scene.getStylesheets().add("/com/example/javafx/app/mystyles.css"); stage.setScene(scene); stage.show(); } public static void main(String[] args) { launch(args); } }
        有关使用CSS与场景图的其他信息，请参阅CSS Reference Guide 。
        结果
        与此场景一起使用的样式表列表

      • userAgentStylesheetProperty

        public final ObjectProperty<String> userAgentStylesheetProperty​()
        从以下版本开始：
        JavaFX 8u20
        另请参见：
        getUserAgentStylesheet() ， setUserAgentStylesheet(String)

      • getUserAgentStylesheet

        public final String getUserAgentStylesheet​()
        获取此场景将使用的用户代理样式表的URL。 如果未设置URL，则将使用平台默认用户代理样式表。

        有关使用CSS与场景图的其他信息，请参阅CSS Reference Guide 。

        结果
        该场景将使用的用户代理样式表的URL，如果尚未设置，则为null。
        从以下版本开始：
        JavaFX 8u20

      • setUserAgentStylesheet

        public final void setUserAgentStylesheet​(String url)
        设置此场景将使用的用户代理样式表的URL，而不是platform-default用户代理样式表。 如果URL无法解析为有效位置，则将使用平台默认用户代理样式表。

        有关使用CSS与场景图的其他信息，请参阅CSS Reference Guide 。

        参数
        url - URL是[scheme：] [// authority] [path]形式的分层URI。 如果URL没有[scheme：]组件，则该URL仅被认为是[path]组件。 [path]的任何前导的'/'字符被忽略，并且[path]被视为相对于应用程序的类路径的根的路径。
        从以下版本开始：
        JavaFX 8u20

      • isDepthBuffer

        public final boolean isDepthBuffer​()
        检索此场景的深度缓冲区属性。
        结果
        深度缓冲区属性。

      • processKeyEvent

        public void processKeyEvent​(KeyEvent e)

      • getFocusOwner

        public final Node getFocusOwner​()
        获取focusOwner属性的值。
        Property description:
        场景当前焦点所有者节点。 如果此场景没有窗口，或者窗口处于非活动状态（window.focused == false），则此节点的“focus”变量可能为false。
        从以下版本开始：
        JavaFX 2.2

      • focusOwnerProperty

        public final ReadOnlyObjectProperty<Node> focusOwnerProperty​()
        场景当前焦点所有者节点。 如果此场景没有窗口，或者窗口处于非活动状态（window.focused == false），则此节点的“focus”变量可能为false。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getFocusOwner()

      • enableInputMethodEvents

        public void enableInputMethodEvents​(boolean enable)

      • setEventDispatcher

        public final void setEventDispatcher​(EventDispatcher value)
        设置属性eventDispatcher的值。
        Property description:
        指定此场景的事件调度程序。 当使用新的EventDispatcher替换值时，新的调度员应将事件转发到已替换的分派器，以保持场景的默认事件处理行为。

      • getEventDispatcher

        public final EventDispatcher getEventDispatcher​()
        获取属性eventDispatcher的值。
        Property description:
        指定此场景的事件调度程序。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到已替换的调度程序，以保持场景的默认事件处理行为。

      • eventDispatcherProperty

        public final ObjectProperty<EventDispatcher> eventDispatcherProperty​()
        指定此场景的事件调度程序。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到已替换的调度程序，以保持场景的默认事件处理行为。
        另请参见：
        getEventDispatcher() ， setEventDispatcher(EventDispatcher)

      • addEventHandler

        public final <T extends Event> void addEventHandler​(EventType<T> eventType,
                                                    EventHandler<? super T> eventHandler)
        注册一个事件处理程序到这个场景。 当场景在事件传送的冒泡阶段接收到指定类型的Event时，调用处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 由处理程序接收的事件的类型
        eventHandler - 要注册的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • removeEventHandler

        public final <T extends Event> void removeEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        从此场景注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • addEventFilter

        public final <T extends Event> void addEventFilter​(EventType<T> eventType,
                                                   EventHandler<? super T> eventFilter)
        注册一个事件过滤器到这个场景。 当场景在事件传送的捕获阶段期间接收到指定类型的Event时，将调用该过滤器。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 过滤器接收的事件的类型
        eventFilter - 要注册的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空

      • removeEventFilter

        public final <T extends Event> void removeEventFilter​(EventType<T> eventType,
                                                      EventHandler<? super T> eventFilter)
        从此场景注销先前注册的事件过滤器。 一个过滤器可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销过滤器。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 要注销的事件类型
        eventFilter - 要注销的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空

      • setEventHandler

        protected final <T extends Event> void setEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        设置要用于此事件类型的处理程序。 一次只能有一个这样的处理程序。 这个处理程序被保证被首先调用。 这用于注册用户定义的onFoo事件处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 与给定eventHandler关联的事件类型
        eventHandler - 要注册的处理程序，或者取消注册为null
        异常
        NullPointerException - 如果事件类型为空

      • addMnemonic

        public void addMnemonic​(Mnemonic m)
        注册指定的助记符。
        参数
        m - 助记符

      • removeMnemonic

        public void removeMnemonic​(Mnemonic m)
        取消注册指定的助记符。
        参数
        m - 助记符

      • getMnemonics

        public ObservableMap<KeyCombination,ObservableList<Mnemonic>> getMnemonics​()
        获取 Scene的助记符列表。
        结果
        助记符列表

      • getAccelerators

        public ObservableMap<KeyCombination,Runnable> getAccelerators​()
        获取 Scene的加速器列表。
        结果
        加速器列表

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此场景构建事件调度链。 事件调度链包含从舞台到这个场景的所有事件调度器。
        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 建立起来的初始链
        结果
        这个场景的结果事件调度链

      • setOnContextMenuRequested

        public final void setOnContextMenuRequested​(EventHandler<? super ContextMenuEvent> value)
        设置属性onContextMenuRequested的值。
        Property description:
        定义当在此 Scene上单击（按下并释放）鼠标按钮时调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • getOnContextMenuRequested

        public final EventHandler<? super ContextMenuEvent> getOnContextMenuRequested​()
        获取属性onContextMenuRequested的值。
        Property description:
        定义当这个 Scene点击（按下和释放）鼠标按钮时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • onContextMenuRequestedProperty

        public final ObjectProperty<EventHandler<? super ContextMenuEvent>> onContextMenuRequestedProperty​()
        定义当在此 Scene上单击（按下并释放）鼠标按钮时调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnContextMenuRequested() ， setOnContextMenuRequested(EventHandler)

      • setOnMouseClicked

        public final void setOnMouseClicked​(EventHandler<? super MouseEvent> value)
        设置属性onMouseClicked的值。
        Property description:
        定义当这个 Scene点击（按下并释放）鼠标按钮时调用的功能。

      • getOnMouseClicked

        public final EventHandler<? super MouseEvent> getOnMouseClicked​()
        获取属性onMouseClicked的值。
        Property description:
        定义当这个 Scene点击（按下和释放）鼠标按钮时要调用的功能。

      • onMouseClickedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseClickedProperty​()
        定义当在此 Scene上单击（按下并释放）鼠标按钮时调用的功能。
        另请参见：
        getOnMouseClicked() ， setOnMouseClicked(EventHandler)

      • setOnMouseDragged

        public final void setOnMouseDragged​(EventHandler<? super MouseEvent> value)
        设置属性onMouseDragged的值。
        Property description:
        定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。

      • getOnMouseDragged

        public final EventHandler<? super MouseEvent> getOnMouseDragged​()
        获取属性onMouseDragged的值。
        Property description:
        定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。

      • onMouseDraggedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseDraggedProperty​()
        定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。
        另请参见：
        getOnMouseDragged() ， setOnMouseDragged(EventHandler)

      • setOnMouseEntered

        public final void setOnMouseEntered​(EventHandler<? super MouseEvent> value)
        设置属性onMouseEntered的值。
        Property description:
        定义当鼠标进入 Scene时调用的功能。

      • getOnMouseEntered

        public final EventHandler<? super MouseEvent> getOnMouseEntered​()
        获取属性onMouseEntered的值。
        Property description:
        定义当鼠标进入 Scene时要调用的功能。

      • onMouseEnteredProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseEnteredProperty​()
        定义当鼠标进入 Scene时调用的功能。
        另请参见：
        getOnMouseEntered() ， setOnMouseEntered(EventHandler)

      • setOnMouseExited

        public final void setOnMouseExited​(EventHandler<? super MouseEvent> value)
        设置属性onMouseExited的值。
        Property description:
        定义当鼠标退出 Scene时要调用的函数。

      • getOnMouseExited

        public final EventHandler<? super MouseEvent> getOnMouseExited​()
        获取属性onMouseExited的值。
        Property description:
        定义当鼠标退出 Scene时调用的函数。

      • onMouseExitedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseExitedProperty​()
        定义当鼠标退出 Scene时调用的函数。
        另请参见：
        getOnMouseExited() ， setOnMouseExited(EventHandler)

      • setOnMouseMoved

        public final void setOnMouseMoved​(EventHandler<? super MouseEvent> value)
        设置属性onMouseMoved的值。
        Property description:
        定义当这个 Scene内的鼠标光标移动时没有按钮被调用的功能。

      • getOnMouseMoved

        public final EventHandler<? super MouseEvent> getOnMouseMoved​()
        获取属性onMouseMoved的值。
        Property description:
        定义当这个 Scene鼠标光标移动时调用的功能，但没有按钮被按下。

      • onMouseMovedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseMovedProperty​()
        定义当这个 Scene鼠标光标移动时调用的功能，但没有按钮被按下。
        另请参见：
        getOnMouseMoved() ， setOnMouseMoved(EventHandler)

      • setOnMousePressed

        public final void setOnMousePressed​(EventHandler<? super MouseEvent> value)
        设置属性onMousePressed的值。
        Property description:
        定义当这个 Scene上按下鼠标按钮时要调用的功能。

      • getOnMousePressed

        public final EventHandler<? super MouseEvent> getOnMousePressed​()
        获取属性onMousePressed的值。
        Property description:
        定义在 Scene上按下鼠标按钮时要调用的功能。

      • onMousePressedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMousePressedProperty​()
        定义在 Scene上按下鼠标按钮时要调用的功能。
        另请参见：
        getOnMousePressed() ， setOnMousePressed(EventHandler)

      • setOnMouseReleased

        public final void setOnMouseReleased​(EventHandler<? super MouseEvent> value)
        设置属性onMouseReleased的值。
        Property description:
        定义当这个 Scene上释放鼠标按钮时要调用的函数。

      • getOnMouseReleased

        public final EventHandler<? super MouseEvent> getOnMouseReleased​()
        获取属性onMouseReleased的值。
        Property description:
        定义在 Scene上释放鼠标按钮时要调用的功能。

      • onMouseReleasedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onMouseReleasedProperty​()
        定义在 Scene上释放鼠标按钮时要调用的功能。
        另请参见：
        getOnMouseReleased() ， setOnMouseReleased(EventHandler)

      • setOnDragDetected

        public final void setOnDragDetected​(EventHandler<? super MouseEvent> value)
        设置属性onDragDetected的值。
        Property description:
        定义检测到拖动手势时要调用的功能。 这是开始拖放操作的正确位置。

      • getOnDragDetected

        public final EventHandler<? super MouseEvent> getOnDragDetected​()
        获取属性onDragDetected的值。
        Property description:
        定义检测到拖动手势时要调用的功能。 这是开始拖放操作的正确位置。

      • onDragDetectedProperty

        public final ObjectProperty<EventHandler<? super MouseEvent>> onDragDetectedProperty​()
        定义检测到拖动手势时要调用的功能。 这是开始拖放操作的正确位置。
        另请参见：
        getOnDragDetected() ， setOnDragDetected(EventHandler)

      • setOnMouseDragOver

        public final void setOnMouseDragOver​(EventHandler<? super MouseDragEvent> value)
        设置属性onMouseDragOver的值。
        Property description:
        定义当这个 Scene内完全按下 Scene释放手势时，要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • getOnMouseDragOver

        public final EventHandler<? super MouseDragEvent> getOnMouseDragOver​()
        获取属性onMouseDragOver的值。
        Property description:
        定义当这个 Scene内完全按下 Scene释放手势时，要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • onMouseDragOverProperty

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragOverProperty​()
        定义当这个 Scene完全按下 - 拖动释放手势进行时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragOver() ， setOnMouseDragOver(EventHandler)

      • setOnMouseDragReleased

        public final void setOnMouseDragReleased​(EventHandler<? super MouseDragEvent> value)
        设置属性onMouseDragReleased的值。
        Property description:
        定义当完全按下 - 拖动释放手势在此 Scene内结束时调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • getOnMouseDragReleased

        public final EventHandler<? super MouseDragEvent> getOnMouseDragReleased​()
        获取属性onMouseDragReleased的值。
        Property description:
        定义当完全按下 - 拖动释放手势在此 Scene内结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • onMouseDragReleasedProperty

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragReleasedProperty​()
        定义当完全按下 - 拖动释放手势在此 Scene内结束时调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragReleased() ， setOnMouseDragReleased(EventHandler)

      • setOnMouseDragEntered

        public final void setOnMouseDragEntered​(EventHandler<? super MouseDragEvent> value)
        设置属性onMouseDragEntered的值。
        Property description:
        定义当全按压拖动手势进入这个 Scene时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • getOnMouseDragEntered

        public final EventHandler<? super MouseDragEvent> getOnMouseDragEntered​()
        获取属性onMouseDragEntered的值。
        Property description:
        定义当全按压拖动手势进入这个 Scene时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • onMouseDragEnteredProperty

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragEnteredProperty​()
        定义当全按压拖动手势进入 Scene时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragEntered() ， setOnMouseDragEntered(EventHandler)

      • setOnMouseDragExited

        public final void setOnMouseDragExited​(EventHandler<? super MouseDragEvent> value)
        设置属性onMouseDragExited的值。
        Property description:
        定义当完全按下 - 拖动释放手势退出 Scene时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • getOnMouseDragExited

        public final EventHandler<? super MouseDragEvent> getOnMouseDragExited​()
        获取属性onMouseDragExited的值。
        Property description:
        定义当完全按下 - 拖动释放手势退出 Scene时要调用的功能。
        从以下版本开始：
        JavaFX 2.1

      • onMouseDragExitedProperty

        public final ObjectProperty<EventHandler<? super MouseDragEvent>> onMouseDragExitedProperty​()
        定义当完全按下 - 拖动释放手势退出 Scene时要调用的功能。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getOnMouseDragExited() ， setOnMouseDragExited(EventHandler)

      • setOnScrollStarted

        public final void setOnScrollStarted​(EventHandler<? super ScrollEvent> value)
        设置属性onScrollStarted的值。
        Property description:
        定义检测到滚动手势时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnScrollStarted

        public final EventHandler<? super ScrollEvent> getOnScrollStarted​()
        获取属性onScrollStarted的值。
        Property description:
        定义检测到滚动手势时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onScrollStartedProperty

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollStartedProperty​()
        定义检测到滚动手势时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnScrollStarted() ， setOnScrollStarted(EventHandler)

      • setOnScroll

        public final void setOnScroll​(EventHandler<? super ScrollEvent> value)
        设置属性onScroll的值。
        Property description:
        定义当用户执行滚动操作时要调用的函数。

      • getOnScroll

        public final EventHandler<? super ScrollEvent> getOnScroll​()
        获取属性onScroll的值。
        Property description:
        定义当用户执行滚动操作时要调用的函数。

      • onScrollProperty

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollProperty​()
        定义当用户执行滚动操作时要调用的函数。
        另请参见：
        getOnScroll() ， setOnScroll(EventHandler)

      • setOnScrollFinished

        public final void setOnScrollFinished​(EventHandler<? super ScrollEvent> value)
        设置属性onScrollFinished的值。
        Property description:
        定义当滚动手势结束时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnScrollFinished

        public final EventHandler<? super ScrollEvent> getOnScrollFinished​()
        获取属性onScrollFinished的值。
        Property description:
        定义当滚动手势结束时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onScrollFinishedProperty

        public final ObjectProperty<EventHandler<? super ScrollEvent>> onScrollFinishedProperty​()
        定义当滚动手势结束时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnScrollFinished() ， setOnScrollFinished(EventHandler)

      • setOnRotationStarted

        public final void setOnRotationStarted​(EventHandler<? super RotateEvent> value)
        设置属性onRotationStarted的值。
        Property description:
        定义检测到旋转手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnRotationStarted

        public final EventHandler<? super RotateEvent> getOnRotationStarted​()
        获取属性onRotationStarted的值。
        Property description:
        定义检测到旋转手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onRotationStartedProperty

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotationStartedProperty​()
        定义检测到旋转手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotationStarted() ， setOnRotationStarted(EventHandler)

      • setOnRotate

        public final void setOnRotate​(EventHandler<? super RotateEvent> value)
        设置属性onRotate的值。
        Property description:
        定义当用户执行旋转操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnRotate

        public final EventHandler<? super RotateEvent> getOnRotate​()
        获取属性onRotate的值。
        Property description:
        定义当用户执行旋转操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onRotateProperty

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotateProperty​()
        定义当用户执行旋转操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotate() ， setOnRotate(EventHandler)

      • setOnRotationFinished

        public final void setOnRotationFinished​(EventHandler<? super RotateEvent> value)
        设置属性onRotationFinished的值。
        Property description:
        定义当旋转手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnRotationFinished

        public final EventHandler<? super RotateEvent> getOnRotationFinished​()
        获取属性onRotationFinished的值。
        Property description:
        定义当旋转手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onRotationFinishedProperty

        public final ObjectProperty<EventHandler<? super RotateEvent>> onRotationFinishedProperty​()
        定义当旋转手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnRotationFinished() ， setOnRotationFinished(EventHandler)

      • setOnZoomStarted

        public final void setOnZoomStarted​(EventHandler<? super ZoomEvent> value)
        设置属性onZoomStarted的值。
        Property description:
        定义检测到缩放手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnZoomStarted

        public final EventHandler<? super ZoomEvent> getOnZoomStarted​()
        获取属性onZoomStarted的值。
        Property description:
        定义检测到缩放手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onZoomStartedProperty

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomStartedProperty​()
        定义检测到缩放手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoomStarted() ， setOnZoomStarted(EventHandler)

      • setOnZoom

        public final void setOnZoom​(EventHandler<? super ZoomEvent> value)
        设置Zoom上的属性值。
        Property description:
        定义当用户执行缩放操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnZoom

        public final EventHandler<? super ZoomEvent> getOnZoom​()
        获取属性onZoom的值。
        Property description:
        定义当用户执行缩放操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onZoomProperty

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomProperty​()
        定义当用户执行缩放操作时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoom() ， setOnZoom(EventHandler)

      • setOnZoomFinished

        public final void setOnZoomFinished​(EventHandler<? super ZoomEvent> value)
        设置属性onZoomFinished的值。
        Property description:
        定义当缩放手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnZoomFinished

        public final EventHandler<? super ZoomEvent> getOnZoomFinished​()
        获取属性onZoomFinished的值。
        Property description:
        定义当缩放手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onZoomFinishedProperty

        public final ObjectProperty<EventHandler<? super ZoomEvent>> onZoomFinishedProperty​()
        定义当缩放手势结束时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnZoomFinished() ， setOnZoomFinished(EventHandler)

      • setOnSwipeUp

        public final void setOnSwipeUp​(EventHandler<? super SwipeEvent> value)
        设置属性onSwipeUp的值。
        Property description:
        定义当在此场景中发生向上滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnSwipeUp

        public final EventHandler<? super SwipeEvent> getOnSwipeUp​()
        获取属性onSwipeUp的值。
        Property description:
        定义当在此场景中发生向上滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onSwipeUpProperty

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeUpProperty​()
        定义当在此场景中发生向上滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeUp() ， setOnSwipeUp(EventHandler)

      • setOnSwipeDown

        public final void setOnSwipeDown​(EventHandler<? super SwipeEvent> value)
        设置属性onSwipeDown的值。
        Property description:
        定义当在此场景中发生向下滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnSwipeDown

        public final EventHandler<? super SwipeEvent> getOnSwipeDown​()
        获取属性onSwipeDown的值。
        Property description:
        定义当在此场景中发生向下滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onSwipeDownProperty

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeDownProperty​()
        定义当在此场景中发生向下滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeDown() ， setOnSwipeDown(EventHandler)

      • setOnSwipeLeft

        public final void setOnSwipeLeft​(EventHandler<? super SwipeEvent> value)
        设置属性onSwipeLeft的值。
        Property description:
        定义当在此场景中发生向左滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnSwipeLeft

        public final EventHandler<? super SwipeEvent> getOnSwipeLeft​()
        获取属性onSwipeLeft的值。
        Property description:
        定义当在此场景中发生向左滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onSwipeLeftProperty

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeLeftProperty​()
        定义当在此场景中发生向左滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeLeft() ， setOnSwipeLeft(EventHandler)

      • setOnSwipeRight

        public final void setOnSwipeRight​(EventHandler<? super SwipeEvent> value)
        设置属性onSwipeRight的值。
        Property description:
        定义当在此场景中发生向右滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnSwipeRight

        public final EventHandler<? super SwipeEvent> getOnSwipeRight​()
        获取属性onSwipeRight的值。
        Property description:
        定义当在此场景中发生向右滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onSwipeRightProperty

        public final ObjectProperty<EventHandler<? super SwipeEvent>> onSwipeRightProperty​()
        定义当在此场景中发生向右滑动手势时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnSwipeRight() ， setOnSwipeRight(EventHandler)

      • setOnTouchPressed

        public final void setOnTouchPressed​(EventHandler<? super TouchEvent> value)
        设置属性onTouchPressed的值。
        Property description:
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnTouchPressed

        public final EventHandler<? super TouchEvent> getOnTouchPressed​()
        获取onTouchPressed属性的值。
        Property description:
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onTouchPressedProperty

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchPressedProperty​()
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchPressed() ， setOnTouchPressed(EventHandler)

      • setOnTouchMoved

        public final void setOnTouchMoved​(EventHandler<? super TouchEvent> value)
        设置属性onTouchMoved的值。
        Property description:
        定义当触摸点移动时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • getOnTouchMoved

        public final EventHandler<? super TouchEvent> getOnTouchMoved​()
        获取onTouchMoved属性的值。
        Property description:
        定义当触摸点移动时要调用的函数。
        从以下版本开始：
        JavaFX 2.2

      • onTouchMovedProperty

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchMovedProperty​()
        定义当触摸点移动时要调用的函数。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchMoved() ， setOnTouchMoved(EventHandler)

      • setOnTouchReleased

        public final void setOnTouchReleased​(EventHandler<? super TouchEvent> value)
        设置属性onTouchReleased的值。
        Property description:
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnTouchReleased

        public final EventHandler<? super TouchEvent> getOnTouchReleased​()
        获取onTouchReleased属性的值。
        Property description:
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onTouchReleasedProperty

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchReleasedProperty​()
        定义当按下新的触摸点时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchReleased() ， setOnTouchReleased(EventHandler)

      • setOnTouchStationary

        public final void setOnTouchStationary​(EventHandler<? super TouchEvent> value)
        设置属性onTouchStationary的值。
        Property description:
        定义当触摸点保持按下并静止时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • getOnTouchStationary

        public final EventHandler<? super TouchEvent> getOnTouchStationary​()
        获取属性onTouchStationary的值。
        Property description:
        定义当触摸点保持按下并静止时要调用的功能。
        从以下版本开始：
        JavaFX 2.2

      • onTouchStationaryProperty

        public final ObjectProperty<EventHandler<? super TouchEvent>> onTouchStationaryProperty​()
        定义当触摸点保持按下并静止时要调用的功能。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnTouchStationary() ， setOnTouchStationary(EventHandler)

      • setOnDragEntered

        public final void setOnDragEntered​(EventHandler<? super DragEvent> value)
        设置属性onDragEntered的值。
        Property description:
        *拖放处理* *

      • getOnDragEntered

        public final EventHandler<? super DragEvent> getOnDragEntered​()
        获取属性onDragEntered的值。
        Property description:
        *拖放处理* *

      • onDragEnteredProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragEnteredProperty​()
        定义当拖动手势进入 Scene时要调用的功能。
        结果
        当拖动手势进入这个场景时被调用的功能

      • setOnDragExited

        public final void setOnDragExited​(EventHandler<? super DragEvent> value)
        设置属性onDragExited的值。
        Property description:
        定义当拖动手势退出 Scene时要调用的函数。

      • getOnDragExited

        public final EventHandler<? super DragEvent> getOnDragExited​()
        获取属性onDragExited的值。
        Property description:
        定义当拖动手势退出 Scene时要调用的函数。

      • onDragExitedProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragExitedProperty​()
        定义当拖动手势退出 Scene时要调用的函数。
        另请参见：
        getOnDragExited() ， setOnDragExited(EventHandler)

      • setOnDragOver

        public final void setOnDragOver​(EventHandler<? super DragEvent> value)
        设置属性onDragOver的值。
        Property description:
        定义当这个 Scene拖动手势进行时要调用的函数。

      • getOnDragOver

        public final EventHandler<? super DragEvent> getOnDragOver​()
        获取属性onDragOver的值。
        Property description:
        定义当这个 Scene拖动手势进行时要调用的函数。

      • onDragOverProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragOverProperty​()
        当在 Scene内拖动手势时，定义要调用的功能。
        另请参见：
        getOnDragOver() ， setOnDragOver(EventHandler)

      • setOnDragDropped

        public final void setOnDragDropped​(EventHandler<? super DragEvent> value)
        设置属性onDragDropped的值。
        Property description:
        定义在拖放手势时，在此Scene上释放鼠标按钮时要调用的功能。 此功能将发生DragEvent的dragboard数据传输。

      • getOnDragDropped

        public final EventHandler<? super DragEvent> getOnDragDropped​()
        获取属性onDragDropped的值。
        Property description:
        定义当在拖放手势时释放鼠标按钮Scene时要调用的功能。 在DragEvent的dragboard中的数据传输应该发生在此功能中。

      • onDragDroppedProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragDroppedProperty​()
        定义当在拖放手势时释放Scene鼠标按钮时要调用的功能。 在DragEvent的dragboard中传输数据应该发生在此功能中。
        另请参见：
        getOnDragDropped() ， setOnDragDropped(EventHandler)

      • setOnDragDone

        public final void setOnDragDone​(EventHandler<? super DragEvent> value)
        设置属性onDragDone的值。
        Property description:
        定义当这个Scene是数据放在放置目标上之后的拖放手势源时要调用的函数。 事件的transferMode显示刚刚发生的放下目标。 如果transferMode具有值MOVE ，则源可以清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 甲transferMode具有值NONE指示拖放手势期间没有数据被转移。 DragEvent位置数据无效。 onDragDropped事件处理程序中提供了DragEvent有效位置数据。

      • getOnDragDone

        public final EventHandler<? super DragEvent> getOnDragDone​()
        获取属性onDragDone的值。
        Property description:
        定义当这个Scene是一个拖放手势源，在其数据被放在放置目标上之后被调用的函数。 事件的transferMode显示刚刚发生的放下目标。 如果transferMode的值为MOVE ，则源可以清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 甲transferMode具有值NONE指示拖放手势期间没有数据被转移。 DragEvent位置数据无效。 DragEvent有效位置数据显示在onDragDropped事件处理程序中。

      • onDragDoneProperty

        public final ObjectProperty<EventHandler<? super DragEvent>> onDragDoneProperty​()
        定义当这个Scene是一个拖放手势源，当它的数据被放在放置目标上之后被调用的函数。 该事件的transferMode显示刚刚发生的下降目标。 如果transferMode的值为MOVE ，则源可以清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 甲transferMode具有值NONE指示拖放手势期间没有数据被转移。 DragEvent位置数据无效。 DragEvent有效位置数据显示在onDragDropped事件处理程序中。
        另请参见：
        getOnDragDone() ， setOnDragDone(EventHandler)

      • startDragAndDrop

        public Dragboard startDragAndDrop​(TransferMode... transferModes)
        确认一个潜在的拖放手势，在这Scene被认可。 只能从DRAG_DETECTED事件处理程序调用。 返回的Dragboard用于在拖放手势期间传输数据。 将此Scene的数据放在Dragboard上也可以将此Scene标识为拖放手势的来源。 约拖放手势更详细的overivew描述DragEvent 。
        参数
        transferModes -支持的 TransferMode的这（一个或多个） Node
        结果
        A Dragboard将此 Scene的数据放在上面
        异常
        IllegalStateException - 如果此时无法启动拖放（在 DRAG_DETECTED事件处理之外调用）。
        另请参见：
        DragEvent

      • startFullDrag

        public void startFullDrag​()
        开始一个完整的按下 - 拖动释放手势与这个场景作为手势源。 此方法只能从DRAG_DETECTED鼠标事件处理程序调用。 有关拖动手势的更多详细信息，请参见MouseEvent和MouseDragEvent的概述。
        异常
        IllegalStateException - 如果此时无法启动完全按下 - 拖动释放手势（它在 DRAG_DETECTED事件处理之外调用）。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        MouseEvent ， MouseDragEvent

      • setOnKeyPressed

        public final void setOnKeyPressed​(EventHandler<? super KeyEvent> value)
        设置属性onKeyPressed的值。
        Property description:
        定义当这个Scene某些Node具有输入焦点并按下一个键时要调用的功能。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • getOnKeyPressed

        public final EventHandler<? super KeyEvent> getOnKeyPressed​()
        获取属性onKeyPressed的值。
        Property description:
        当Node的Scene具有输入焦点并按下一个键时，定义要调用的功能。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • onKeyPressedProperty

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyPressedProperty​()
        定义要调用的函数，当一些Node如此Scene具有输入焦点和键被按下。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyPressed() ， setOnKeyPressed(EventHandler)

      • setOnKeyReleased

        public final void setOnKeyReleased​(EventHandler<? super KeyEvent> value)
        设置属性onKeyReleased的值。
        Property description:
        定义要调用的函数，当一些Node如此Scene具有输入焦点和重点已经释放。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • getOnKeyReleased

        public final EventHandler<? super KeyEvent> getOnKeyReleased​()
        获取属性onKeyReleased的值。
        Property description:
        当Node的Scene具有输入焦点并且键被释放时，定义要调用的功能。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • onKeyReleasedProperty

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyReleasedProperty​()
        定义要调用的函数，当一些Node如此Scene具有输入焦点和重点已经释放。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyReleased() ， setOnKeyReleased(EventHandler)

      • setOnKeyTyped

        public final void setOnKeyTyped​(EventHandler<? super KeyEvent> value)
        设置属性onKeyTyped的值。
        Property description:
        定义要调用的函数，当一些Node如此Scene具有输入焦点和重点已经输入。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • getOnKeyTyped

        public final EventHandler<? super KeyEvent> getOnKeyTyped​()
        获取属性onKeyTyped的值。
        Property description:
        定义要调用的函数，当一些Node如此Scene具有输入焦点和重点已经输入。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。

      • onKeyTypedProperty

        public final ObjectProperty<EventHandler<? super KeyEvent>> onKeyTypedProperty​()
        当Node的Scene具有输入焦点并键入一个键时，定义要调用的函数。 该函数仅在事件在捕获或冒泡期间尚未消耗的情况下被调用。
        另请参见：
        getOnKeyTyped() ， setOnKeyTyped(EventHandler)

      • setOnInputMethodTextChanged

        public final void setOnInputMethodTextChanged​(EventHandler<? super InputMethodEvent> value)
        设置属性onInputMethodTextChanged的值。
        Property description:
        定义当这个Node具有输入焦点并且输入法文本已更改时要调用的函数。 如果此功能未在此Node定义，则将其作为一系列onKeyTyped函数调用接收输入法组合的结果字符串。

        当Node丢失输入焦点时，JavaFX运行时自动提交现有的合成文本（如果有的话）。

      • getOnInputMethodTextChanged

        public final EventHandler<? super InputMethodEvent> getOnInputMethodTextChanged​()
        获取onInputMethodTextChanged属性的值。
        Property description:
        定义当这个Node具有输入焦点并且输入法文本已更改时要调用的函数。 如果此功能未在此Node定义，则会将该输入法组合的结果字符串接收为一系列onKeyTyped函数调用。

        当Node丢失输入焦点时，JavaFX运行时自动提交现有的合成文本（如果有的话）。

      • onInputMethodTextChangedProperty

        public final ObjectProperty<EventHandler<? super InputMethodEvent>> onInputMethodTextChangedProperty​()
        定义当这个Node具有输入焦点并且输入法文本已更改时要调用的函数。 如果此功能未在此Node定义，则它将输入方法组合的结果字符串作为一系列onKeyTyped函数调用。

        当Node丢失输入焦点时，JavaFX运行时会自动提交现有的合成文本（如果有的话）。

        另请参见：
        getOnInputMethodTextChanged() ， setOnInputMethodTextChanged(EventHandler)

      • getProperties

        public final ObservableMap<Object,Object> getProperties​()
        返回此节点上属性的可观察图，主要由应用程序开发人员使用。
        结果
        该节点上属性的可观察地图主要由应用程序开发人员使用
        从以下版本开始：
        JavaFX 8u40

      • hasProperties

        public boolean hasProperties​()
        测试场景是否具有属性。
        结果
        如果节点有属性，则为true。
        从以下版本开始：
        JavaFX 8u40

      • setUserData

        public void setUserData​(Object value)
        用于设置可以在以后检索的单个Object属性的便利方法。 这在功能上等同于调用getProperties（）。put（Object key，Object value）方法。 这可以稍后通过调用getUserData()来检索。
        参数
        value - 要存储的值 - 以后可以通过调用 getUserData()检索。
        从以下版本开始：
        JavaFX 8u40

      • getUserData

        public Object getUserData​()
        返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
        结果
        先前设置的对象，如果没有设置属性或设置为null，则为null。
        从以下版本开始：
        JavaFX 8u40

      • setNodeOrientation

        public final void setNodeOrientation​(NodeOrientation orientation)
        设置属性nodeOrientation的值。
        Property description:
        属性保存NodeOrientation。

        节点方向描述节点内视觉数据的流动。 在英语世界中，视觉数据通常从左到右流动。 在阿拉伯语或希伯来语世界，视觉数据从右到左流动。 这与两个世界的文本阅读顺序一致。 默认值是从左到右。

        从以下版本开始：
        JavaFX 8.0

      • getNodeOrientation

        public final NodeOrientation getNodeOrientation​()
        获取属性nodeOrientation的值。
        Property description:
        属性保存NodeOrientation。

        节点方向描述节点内视觉数据的流动。 在英语世界中，视觉数据通常从左到右流动。 在阿拉伯语或希伯来语世界，视觉数据从右到左流动。 这与两个世界的文本阅读顺序一致。 默认值是从左到右。

        从以下版本开始：
        JavaFX 8.0

      • nodeOrientationProperty

        public final ObjectProperty<NodeOrientation> nodeOrientationProperty​()
        属性保存NodeOrientation。

        节点方向描述节点内视觉数据的流动。 在英语世界中，视觉数据通常从左到右流动。 在阿拉伯语或希伯来语世界，视觉数据从右到左流动。 这与两个世界的文本阅读顺序一致。 默认值是从左到右。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getNodeOrientation() ， setNodeOrientation(NodeOrientation)

      • getEffectiveNodeOrientation

        public final NodeOrientation getEffectiveNodeOrientation​()
        获取属性effectiveNodeOrientation的值。
        Property description:
        场景的有效节点方向解决节点方向的继承，从左到右或从右到左返回。
        从以下版本开始：
        JavaFX 8.0

      • effectiveNodeOrientationProperty

        public final ReadOnlyObjectProperty<NodeOrientation> effectiveNodeOrientationProperty​()
        场景的有效节点方向解决节点方向的继承，从左到右或从右到左返回。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getEffectiveNodeOrientation()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SceneAntialiasing (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class SceneAntialiasing

  • java.lang.Object
    • javafx.scene.SceneAntialiasing

  • public final class SceneAntialiasing
extends Object
    JavaFX SceneAntialiasing类指定所需的抗锯齿级别。 渲染3D原始图像时，主要使用场景抗锯齿功能，否则将会渲染别名。

    SceneAntialiasing与Shape.setSmooth无关。 与Shape.setSmooth不同， SceneAntialiasing影响整个渲染场景的平滑度，而Shape.setSmooth是适用于单个2D Shape的渲染提示。

    注意：为了使SceneAntialiasing有影响，底层系统必须支持： ConditionalFeature.SCENE3D和抗锯齿。

    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static SceneAntialiasing BALANCED
      实现抗锯齿优化，实现质量和性能的平衡
      static SceneAntialiasing DISABLED
      禁用反锯齿

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DISABLED

        public static final SceneAntialiasing DISABLED
        禁用反锯齿

      • BALANCED

        public static final SceneAntialiasing BALANCED
        实现抗锯齿优化，实现质量和性能的平衡

    • 方法详细信息

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


SnapshotParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class SnapshotParameters

  • java.lang.Object
    • javafx.scene.SnapshotParameters

  • public class SnapshotParameters
extends Object
    用于指定节点快照的渲染属性的参数。
    从以下版本开始：
    JavaFX 2.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      SnapshotParameters​()
      构造一个新的SnapshotParameters对象，具有所有渲染属性的默认值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Camera getCamera​()
      获取当前相机。
      Paint getFill​()
      获取当前填充。
      Transform getTransform​()
      获取当前的变换。
      Rectangle2D getViewport​()
      获取当前视口
      boolean isDepthBuffer​()
      获取当前的depthBuffer标志。
      void setCamera​(Camera camera)
      将相机设置为指定值。
      void setDepthBuffer​(boolean depthBuffer)
      将depthBuffer标志设置为指定的值。
      void setFill​(Paint fill)
      将填充设置为指定的值。
      void setTransform​(Transform transform)
      将转换设置为指定的值。
      void setViewport​(Rectangle2D viewport)
      设置用于渲染的视口。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SnapshotParameters

        public SnapshotParameters​()
        构造一个新的SnapshotParameters对象，具有所有渲染属性的默认值。

    • 方法详细信息

      • isDepthBuffer

        public boolean isDepthBuffer​()
        获取当前的depthBuffer标志。
        结果
        depthBuffer标志

      • setDepthBuffer

        public void setDepthBuffer​(boolean depthBuffer)
        将depthBuffer标志设置为指定的值。 默认值为false。 请注意，这是一个条件功能。 见ConditionalFeature.SCENE3D
        参数
        depthBuffer - 要设置的depthBuffer

      • getCamera

        public Camera getCamera​()
        获取当前相机。
        结果
        相机

      • setCamera

        public void setCamera​(Camera camera)
        将相机设置为指定值。 默认值为null，这意味着将使用ParallelCamera。
        参数
        camera - 相机设置

      • getTransform

        public Transform getTransform​()
        获取当前的变换。
        结果
        转型

      • setTransform

        public void setTransform​(Transform transform)
        将转换设置为指定的值。 该变换应用于在应用任何局部变换之前呈现的节点。 值为null表示应该使用身份转换。 默认值为null。
        参数
        transform - 转换设置

      • getFill

        public Paint getFill​()
        获取当前填充。
        结果
        填充

      • setFill

        public void setFill​(Paint fill)
        将填充设置为指定的值。 这用于在渲染节点之前填充正在呈现的整个图像。 值为null表示颜色白色应用于填充。 默认值为null。
        参数
        fill - 填写设置

      • getViewport

        public Rectangle2D getViewport​()
        获取当前视口
        结果
        视口

      • setViewport

        public void setViewport​(Rectangle2D viewport)
        设置用于渲染的视口。 视口是在正在呈现的节点的父坐标系中指定的。 它不会通过该SnapshotParameters的变换进行转换。 如果此视口非空，则使用它而不是正在呈现的节点的边界，并指定将渲染到图像中的源矩形。 在这种情况下，视口的左上角像素将映射到渲染图像中的左上角像素（0,0）。 如果视口为空，则将渲染在首次应用此SnapshotParameters的转换后，由其boundsInParent定义的节点的整个区域。 默认值为null。
        参数
        viewport - 要设置的视口
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SnapshotResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class SnapshotResult

  • java.lang.Object
    • javafx.scene.SnapshotResult

  • public class SnapshotResult
extends Object
    此类保存快照操作的结果。
    从以下版本开始：
    JavaFX 2.2

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      WritableImage getImage​()
      获取快照操作生成的图像。
      SnapshotParameters getSnapshotParameters​()
      获取用于生成快照的SnapshotParameters的副本。
      Object getSource​()
      获取调用快照的源节点或场景。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getImage

        public WritableImage getImage​()
        获取快照操作生成的图像。
        结果
        生成的图像

      • getSource

        public Object getSource​()
        获取调用快照的源节点或场景。
        结果
        快照的来源

      • getSnapshotParameters

        public SnapshotParameters getSnapshotParameters​()
        获取用于生成快照的SnapshotParameters的副本。 在场景中调用快照的情况下，这将为空。
        结果
        用于执行快照的SnapshotParameters的副本，或空值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SubScene (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene

Class SubScene

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.SubScene
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class SubScene
extends Node
    SubScene类是场景图中内容的容器。 SubScene提供场景的不同部分的分离，每个场景可以使用不同的相机，深度缓冲区或场景抗锯齿来渲染。 A SubScene嵌入主场景或其他子场景中。

    应用程序可以在创建SubScene请求深度缓冲区支持或场景抗锯齿支持。 只有2D形状和没有任何3D变换的子场景不需要深度缓冲区和场景抗锯齿支持。 包含3D形状或具有3D变换的2D形状的子场景可以使用深度缓冲器支持来进行适当的深度排序渲染; 为了避免深度战斗（也称为Z战斗），禁止没有3D转换的2D形状的深度测试。 有关详细信息，请参阅depthTest 。 具有3D形状的子场景可以实现场景抗锯齿以提高其渲染质量。

    depthBuffer和antiAliasing标志是条件特征。 各自的默认值为：false和SceneAntialiasing.DISABLED 。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

    可能的用例是：

    • 混合2D和3D内容
    • UI控件的重叠
    • 背景背景
    • 头顶显示

    默认大灯将被添加到一个SubScene包含一个或多个Shape3D节点，但没有光的节点。 这个光源是Color.WHITE PointLight放在相机的位置。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Camera> camera
      指定用于渲染 SubScene的相机使用类型。
      ObjectProperty<Paint> fill
      定义此 SubScene的背景填充。
      DoubleProperty height
      定义这个 SubScene的高度
      ObjectProperty<Parent> root
      定义 SubScene场景图的根 Node 。
      ObjectProperty<String> userAgentStylesheet
      DoubleProperty width
      定义这个 SubScene的宽度

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      SubScene​(Parent root, double width, double height)
      为特定大小的特定根节点创建一个 SubScene 。
      SubScene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造一个包含根，宽度和高度的根的 SubScene ，指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Camera> cameraProperty​()
      指定用于渲染 SubScene的相机使用类型。
      ObjectProperty<Paint> fillProperty​()
      定义此 SubScene的背景填充。
      SceneAntialiasing getAntiAliasing​()
      返回定义 SceneAntialiasing这个 SubScene 。
      Camera getCamera​()
      获取属性摄像机的值。
      Paint getFill​()
      获取属性填充的值。
      double getHeight​()
      获取属性高度的值。
      Parent getRoot​()
      获取属性根的值。
      String getUserAgentStylesheet​()
      获取此SubScene将使用的用户代理样式表的URL。
      double getWidth​()
      获取属性宽度的值。
      DoubleProperty heightProperty​()
      定义这个 SubScene的高度
      boolean isDepthBuffer​()
      检索此 SubScene的深度缓冲区属性。
      ObjectProperty<Parent> rootProperty​()
      定义 SubScene场景图的根 Node 。
      void setCamera​(Camera value)
      设置属性摄像机的值。
      void setFill​(Paint value)
      设置属性填充的值。
      void setHeight​(double value)
      设置属性高度的值。
      void setRoot​(Parent value)
      设置属性根的值。
      void setUserAgentStylesheet​(String url)
      设置此SubScene将使用的用户代理样式表的URL代替platform-default用户代理样式表。
      void setWidth​(double value)
      设置属性宽度的值。
      ObjectProperty<String> userAgentStylesheetProperty​()
      DoubleProperty widthProperty​()
      定义这个 SubScene的宽度

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • root

        public final ObjectProperty<Parent> rootProperty
        定义SubScene场景图的根Node 。 如果使用Group作为根，则场景图的内容将被SubScene的宽度和高度裁剪。 SubScene不接受null根。
        另请参见：
        getRoot() ， setRoot(Parent)

      • camera

        public final ObjectProperty<Camera> cameraProperty
        指定用于渲染SubScene的相机使用类型。 如果camera为空，则使用并行摄像机进行渲染。 设置属于其他Scene或SubScene的相机是非法的。

        注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        空值
        另请参见：
        getCamera() ， setCamera(Camera)

      • width

        public final DoubleProperty widthProperty
        定义这个 SubScene的宽度
        Default value:
        0.0
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final DoubleProperty heightProperty
        定义这个 SubScene的高度
        Default value:
        0.0
        另请参见：
        getHeight() ， setHeight(double)

      • fill

        public final ObjectProperty<Paint> fillProperty
        定义此SubScene的背景填充。 一个null值意味着没有背景和一个Paint与透明度。 默认值为null。
        Default value:
        空值
        另请参见：
        getFill() ， setFill(Paint)

      • userAgentStylesheet

        public final ObjectProperty<String> userAgentStylesheetProperty
        从以下版本开始：
        JavaFX 8u20
        另请参见：
        getUserAgentStylesheet() ， setUserAgentStylesheet(String)

    • 构造方法详细信息

      • SubScene

        public SubScene​(Parent root,
                double width,
                double height)
        为特定大小的特定根节点创建一个 SubScene 。
        参数
        root - 场景图的根节点
        width - 子场景的宽度
        height - 子场景的高度
        异常
        NullPointerException - 如果root为null

      • SubScene

        public SubScene​(Parent root,
                double width,
                double height,
                boolean depthBuffer,
                SceneAntialiasing antiAliasing)
        构造一个SubScene其中包含宽度和高度的根，指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。

        只有2D形状和没有任何3D变换的子场景不需要深度缓冲区和场景抗锯齿支持。 包含3D形状或具有3D变换的2D形状的子场景可以使用深度缓冲器支持来进行适当的深度排序渲染; 为了避免深度战斗（也称为Z战斗），禁止没有3D转换的2D形状的深度测试。 有关详细信息，请参阅depthTest 。 具有3D形状的子场景可以实现场景抗锯齿以提高其渲染质量。

        参数
        root - 场景图的根节点
        width - 子场景的宽度
        height - 子场景的高度
        depthBuffer - 深度缓冲区标志
        antiAliasing - 子场景抗锯齿属性。 值null被视为已禁用。

        depthBuffer和antiAliasing标志是条件特征。 各自的默认值为：false和SceneAntialiasing.DISABLED 。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        异常
        NullPointerException - 如果root为null
        另请参见：
        Node.setDepthTest(DepthTest)

    • 方法详细信息

      • getAntiAliasing

        public final SceneAntialiasing getAntiAliasing​()
        返回定义的SceneAntialiasing为这个SubScene 。

        注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D和SceneAntialiasing 。

        结果
        这个子场景的SceneAntialiasing
        从以下版本开始：
        JavaFX 8.0

      • isDepthBuffer

        public final boolean isDepthBuffer​()
        检索此 SubScene的深度缓冲区属性。
        结果
        深度缓冲区属性。

      • setRoot

        public final void setRoot​(Parent value)
        设置属性根的值。
        Property description:
        定义SubScene场景图的根Node 。 如果使用Group作为根，则场景图的内容将被SubScene的宽度和高度裁剪。 SubScene不接受null根。

      • getRoot

        public final Parent getRoot​()
        获取属性根的值。
        Property description:
        定义SubScene场景图的根Node 。 如果使用Group作为根，则场景图的内容将被SubScene的宽度和高度裁剪。 SubScene不接受null root。

      • rootProperty

        public final ObjectProperty<Parent> rootProperty​()
        定义SubScene场景图的根Node 。 如果使用Group作为根，则场景图的内容将被SubScene的宽度和高度裁剪。 SubScene不接受null根。
        另请参见：
        getRoot() ， setRoot(Parent)

      • setCamera

        public final void setCamera​(Camera value)
        设置属性摄像机的值。
        Property description:
        指定用于渲染此SubScene的相机使用类型。 如果camera为空，则使用并行摄像机进行渲染。 设置属于其他Scene或SubScene的摄像机是非法的。

        注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        空值

      • getCamera

        public final Camera getCamera​()
        获取属性摄像机的值。
        Property description:
        指定用于渲染此SubScene的相机使用类型。 如果camera为空，则使用并行摄像机进行渲染。 设置属于其他Scene或SubScene的相机是非法的。

        注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

        Default value:
        空值

      • cameraProperty

        public final ObjectProperty<Camera> cameraProperty​()
        指定用于渲染SubScene的相机使用类型。 如果camera为空，则使用并行摄像机进行渲染。 设置属于其他Scene或SubScene的相机是非法的。

        注意：这是一个条件功能。 详见ConditionalFeature.SCENE3D 。

        Default value:
        空值
        另请参见：
        getCamera() ， setCamera(Camera)

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        定义这个 SubScene的宽度
        Default value:
        0.0

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        定义此宽度 SubScene
        Default value:
        0.0

      • widthProperty

        public final DoubleProperty widthProperty​()
        定义这个 SubScene的宽度
        Default value:
        0.0
        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        定义这个 SubScene的高度
        Default value:
        0.0

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        定义这个 SubScene的高度
        Default value:
        0.0

      • heightProperty

        public final DoubleProperty heightProperty​()
        定义这个 SubScene的高度
        Default value:
        0.0
        另请参见：
        getHeight() ， setHeight(double)

      • setFill

        public final void setFill​(Paint value)
        设置属性填充的值。
        Property description:
        定义此SubScene的背景填充。 一个null值意味着没有背景和一个Paint与透明度。 默认值为null。
        Default value:
        空值

      • getFill

        public final Paint getFill​()
        获取属性填充的值。
        Property description:
        定义此SubScene的背景填充。 一个null值意味着没有背景和一个Paint具有透明度的支持。 默认值为null。
        Default value:
        空值

      • fillProperty

        public final ObjectProperty<Paint> fillProperty​()
        定义此SubScene的背景填充。 一个null值意味着没有背景和一个Paint与透明度。 默认值为null。
        Default value:
        空值
        另请参见：
        getFill() ， setFill(Paint)

      • userAgentStylesheetProperty

        public final ObjectProperty<String> userAgentStylesheetProperty​()
        从以下版本开始：
        JavaFX 8u20
        另请参见：
        getUserAgentStylesheet() ， setUserAgentStylesheet(String)

      • getUserAgentStylesheet

        public final String getUserAgentStylesheet​()
        获取此SubScene将使用的用户代理样式表的URL。 如果未设置URL，则将使用平台默认用户代理样式表。

        有关使用CSS与场景图的其他信息，请参阅CSS Reference Guide 。

        结果
        该SubScene将使用的用户代理样式表的URL，如果尚未设置，则为null。
        从以下版本开始：
        JavaFX 8u20

      • setUserAgentStylesheet

        public final void setUserAgentStylesheet​(String url)
        设置此SubScene将使用的用户代理样式表的URL代替platform-default用户代理样式表。 如果URL无法解析为有效位置，则将使用平台默认用户代理样式表。

        有关使用CSS与场景图的其他信息，请参阅CSS Reference Guide 。

        参数
        url - URL是[scheme：] [// authority] [path]形式的分层URI。 如果URL没有[scheme：]组件，则该URL仅被认为是[path]组件。 [path]的任何前导的'/'字符被忽略，并且[path]被视为相对于应用程序的类路径的根的路径。
        从以下版本开始：
        JavaFX 8u20
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene

  • Packages that use javafx.scene
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
  • Classes in javafx.scene used by javafx.animation
    Class 描述
    Node
    场景图节点的基类。
  • Classes in javafx.scene used by javafx.css
    Class 描述
    Node
    场景图节点的基类。
  • Classes in javafx.scene used by javafx.css.converter
    Class 描述
    Cursor
    封装鼠标光标位图表示的类。
  • Classes in javafx.scene used by javafx.embed.swing
    Class 描述
    Node
    场景图节点的基类。
    Scene
    JavaFX Scene类是场景图中所有内容的容器。
  • Classes in javafx.scene used by javafx.print
    Class 描述
    Node
    场景图节点的基类。
  • Classes in javafx.scene used by javafx.scene
    Class 描述
    AccessibleAction
    该枚举描述了屏幕阅读器等辅助技术可以从场景图中请求的动作。
    AccessibleAttribute
    该枚举描述了诸如屏幕阅读器之类的辅助技术可以从场景图中请求的属性。
    AccessibleRole
    这个枚举描述了一个Node的可访问角色。
    CacheHint
    缓存提示与 Node.cacheHint一起使用
    Camera
    用于渲染场景的相机的基类。
    Cursor
    封装鼠标光标位图表示的类。
    DepthTest
    该枚举定义了节点中depthTest标志的可能状态。
    ImageCursor
    鼠标光标的自定义图像表示。
    LightBase
    LightBase类提供了表示光源形式的对象的常用属性的定义。
    Node
    场景图节点的基类。
    Parent
    在场景图中有子节点的所有节点的基类。
    Scene
    JavaFX Scene类是场景图中所有内容的容器。
    SceneAntialiasing
    JavaFX SceneAntialiasing类指定所需的抗锯齿级别。
    SnapshotParameters
    用于指定节点快照的渲染属性的参数。
    SnapshotResult
    此类保存快照操作的结果。
  • Classes in javafx.scene used by javafx.scene.canvas
    Class 描述
    Node
    场景图节点的基类。
  • Classes in javafx.scene used by javafx.scene.chart
    Class 描述
    Node
    场景图节点的基类。
    Parent
    在场景图中有子节点的所有节点的基类。
  • Classes in javafx.scene used by javafx.scene.control
    Class 描述
    AccessibleAction
    该枚举描述了屏幕阅读器等辅助技术可以从场景图中请求的动作。
    AccessibleAttribute
    该枚举描述了诸如屏幕阅读器之类的辅助技术可以从场景图中请求的属性。
    Cursor
    封装鼠标光标位图表示的类。
    Node
    场景图节点的基类。
    Parent
    在场景图中有子节点的所有节点的基类。
  • Classes in javafx.scene used by javafx.scene.control.cell
    Class 描述
    Node
    场景图节点的基类。
    Parent
    在场景图中有子节点的所有节点的基类。
  • Classes in javafx.scene used by javafx.scene.control.skin
    Class 描述
    AccessibleAction
    该枚举描述了屏幕阅读器等辅助技术可以从场景图中请求的动作。
    AccessibleAttribute
    该枚举描述了诸如屏幕阅读器之类的辅助技术可以从场景图中请求的属性。
    Node
    场景图节点的基类。
    Parent
    在场景图中有子节点的所有节点的基类。
  • Classes in javafx.scene used by javafx.scene.image
    Class 描述
    Node
    场景图节点的基类。
  • Classes in javafx.scene used by javafx.scene.input
    Class 描述
    Node
    场景图节点的基类。
  • Classes in javafx.scene used by javafx.scene.layout
    Class 描述
    Node
    场景图节点的基类。
    Parent
    在场景图中有子节点的所有节点的基类。
  • Classes in javafx.scene used by javafx.scene.media
    Class 描述
    Node
    场景图节点的基类。
  • Classes in javafx.scene used by javafx.scene.shape
    Class 描述
    Node
    场景图节点的基类。
  • Classes in javafx.scene used by javafx.scene.text
    Class 描述
    AccessibleAttribute
    该枚举描述了诸如屏幕阅读器之类的辅助技术可以从场景图中请求的属性。
    Node
    场景图节点的基类。
    Parent
    在场景图中有子节点的所有节点的基类。
  • Classes in javafx.scene used by javafx.scene.web
    Class 描述
    Node
    场景图节点的基类。
    Parent
    在场景图中有子节点的所有节点的基类。
  • Classes in javafx.scene used by javafx.stage
    Class 描述
    Node
    场景图节点的基类。
    Scene
    The JavaFX Scene class is the container for all content in a scene graph.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Canvas (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.canvas

Class Canvas

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.canvas.Canvas
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Canvas
extends Node
    Canvas是可以使用GraphicsContext提供的一组图形命令绘制的图像。

    一个Canvas节点被构造为具有宽度和高度，该宽度和高度指定绘制画布命令所呈现的图像的大小。 所有绘图操作都剪切到该图像的边界。

    例：

      import javafx.scene.*;
import javafx.scene.paint.*;
import javafx.scene.canvas.*;

Group root = new Group();
Scene s = new Scene(root, 300, 300, Color.BLACK);

final Canvas canvas = new Canvas(250,250);
GraphicsContext gc = canvas.getGraphicsContext2D();

gc.setFill(Color.BLUE);
gc.fillRect(75,75,100,100);

root.getChildren().add(canvas);
    从以下版本开始：
    JavaFX 2.2
    另请参见：
    GraphicsContext

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty height
      定义画布的高度。
      DoubleProperty width
      定义画布的宽度。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Canvas​()
      创建一个空的Canvas实例。
      Canvas​(double width, double height)
      以给定的大小创建一个新的Canvas实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      GraphicsContext getGraphicsContext2D​()
      返回 GraphicsContext与此 Canvas相关联。
      double getHeight​()
      获取属性高度的值。
      double getWidth​()
      获取属性宽度的值。
      DoubleProperty heightProperty​()
      定义画布的高度。
      void setHeight​(double value)
      设置属性高度的值。
      void setWidth​(double value)
      设置属性宽度的值。
      DoubleProperty widthProperty​()
      定义画布的宽度。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • width

        public final DoubleProperty widthProperty
        定义画布的宽度。
        Default value:
        0.0
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final DoubleProperty heightProperty
        定义画布的高度。
        Default value:
        0.0
        另请参见：
        getHeight() ， setHeight(double)

    • 构造方法详细信息

      • Canvas

        public Canvas​()
        创建一个空的Canvas实例。

      • Canvas

        public Canvas​(double width,
              double height)
        以给定的大小创建一个新的Canvas实例。
        参数
        width - 画布的宽度
        height - 画布的高度

    • 方法详细信息

      • getGraphicsContext2D

        public GraphicsContext getGraphicsContext2D​()
        返回 GraphicsContext与此 Canvas相关联。
        结果
        该 GraphicsContext与此 Canvas相关联

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        定义画布的宽度。
        Default value:
        0.0

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        定义画布的宽度。
        Default value:
        0.0

      • widthProperty

        public final DoubleProperty widthProperty​()
        定义画布的宽度。
        Default value:
        0.0
        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        定义画布的高度。
        Default value:
        0.0

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        定义画布的高度。
        Default value:
        0.0

      • heightProperty

        public final DoubleProperty heightProperty​()
        定义画布的高度。
        Default value:
        0.0
        另请参见：
        getHeight() ， setHeight(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GraphicsContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.canvas

Class GraphicsContext

  • java.lang.Object
    • javafx.scene.canvas.GraphicsContext

  • public final class GraphicsContext
extends Object
    该类用于使用缓冲区发出对Canvas的绘制调用。

    每个呼叫将必要的参数推送到缓冲区上，随后它们将在脉冲结束时由渲染线程随后呈现到Canvas节点的图像上。

    A Canvas只包含一个GraphicsContext ，只有一个缓冲区。 如果它不附加到任何场景，那么它可以被任何线程修改，只要它一次只能从一个线程使用。 一旦Canvas节点附加到场景，它必须在JavaFX应用程序线程上进行修改。

    调用GraphicsContext上的任何方法被认为是修改其对应的Canvas ，并受同样的线程规则约束。

    A GraphicsContext还管理可以随时保存或恢复的一堆状态对象。

    GraphicsContext维护以下渲染属性，它们影响渲染方法的各种子集：

    List of Rendering Attributes Attribute Save/Restore? Default value Description Common Rendering Attributes Clip Yes No clipping An anti-aliased intersection of various clip paths to which rendering is restricted. Global Alpha Yes 1.0 An opacity value that controls the visibility or fading of each rendering operation. Global Blend Mode Yes SRC_OVER A BlendMode enum value that controls how pixels from each rendering operation are composited into the existing image. Transform Yes Identity A 3x2 2D affine transformation matrix that controls how coordinates are mapped onto the logical pixels of the canvas image. Effect Yes null An Effect applied individually to each rendering operation. Fill Attributes Fill Paint Yes BLACK The Paint to be applied to the interior of shapes in a fill operation. Stroke Attributes Stroke Paint Yes BLACK The Paint to be applied to the boundary of shapes in a stroke operation. Line Width Yes 1.0 The width of the stroke applied to the boundary of shapes in a stroke operation. Line Cap Yes SQUARE The style of the end caps applied to the beginnings and ends of each dash and/or subpath in a stroke operation. Line Join Yes MITER The style of the joins applied between individual segments in the boundary paths of shapes in a stroke operation. Miter Limit Yes 10.0 The ratio limit of how far a MITER line join may extend in the direction of a sharp corner between segments in the boundary path of a shape, relative to the line width, before it is truncated to a BEVEL join in a stroke operation. Dashes Yes null The array of dash lengths to be applied to the segments in the boundary of shapes in a stroke operation. Dash Offset Yes 0.0 The distance offset into the array of dash lengths at which to start the dashing of the segments in the boundary of shapes in a stroke operation. Text Attributes Font Yes Default Font The font used for all fill and stroke text operations. Text Align Yes LEFT The horizontal alignment of text with respect to the X coordinate specified in the text operation. Text Baseline Yes BASELINE The vertical position of the text relative to the Y coordinate specified in the text operation. Font Smoothing Yes GRAY The type of smoothing (antialiasing) applied to the glyphs in the font for all fill text operations. Path Attributes Current Path No Empty path The path constructed using various path construction methods to be used in various path filling, stroking, or clipping operations. Fill Rule Yes NON_ZERO The method used to determine the interior of paths for a path fill or clip operation.

    The various rendering methods on the GraphicsContext use the following sets of rendering attributes:

    Rendering Attributes Table Method Common Rendering Attributes Fill Attributes Stroke Attributes Text Attributes Path Attributes Basic Shape Rendering fillRect(), fillRoundRect(), fillOval(), fillArc() Yes Yes No No No strokeLine(), strokeRect(), strokeRoundRect(), strokeOval(), strokeArc() Yes No Yes No No clearRect() Yes [1] No No No No fillPolygon() Yes Yes No No Yes [2] strokePolygon(), strokePolyline() Yes No Yes No No [1] Only the Transform, Clip, and Effect apply to clearRect()
    [2] Only the Fill Rule applies to fillPolygon(), the current path is left unchanged Text Rendering fillText(), fillText(with maxWidth) Yes Yes No Yes [3] No strokeText(), strokeText(with maxWidth) Yes No Yes Yes [3] No [3] The Font Smoothing attribute only applies to filled text Path Rendering beginPath(), moveTo(), lineTo(), quadraticCurveTo(), bezierCurveTo(), arc(), arcTo(), appendSVGPath(), closePath(), rect() Yes [4] No No No No fill() Yes [4] Yes No No Yes stroke() Yes [4] No Yes No Yes [5] clip() No No No No Yes [4] Transform applied only during path construction
    [5] Fill Rule only used for fill() and clip() Image Rendering drawImage(all forms) Yes No No No No Miscellaneous applyEffect(), PixelWriter methods No No No No No

    例：

      import javafx.scene.*;
import javafx.scene.paint.*;
import javafx.scene.canvas.*;

Group root = new Group();
Scene s = new Scene(root, 300, 300, Color.BLACK);

final Canvas canvas = new Canvas(250,250);
GraphicsContext gc = canvas.getGraphicsContext2D();

gc.setFill(Color.BLUE);
gc.fillRect(75,75,100,100);

root.getChildren().add(canvas);
    从以下版本开始：
    JavaFX 2.2
    另请参见：
    Canvas

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void appendSVGPath​(String svgpath)
      将SVG路径字符串附加到当前路径。
      void applyEffect​(Effect e)
      将给定的效果应用于画布的整个边界，并将结果存储回同一个画布。
      void arc​(double centerX, double centerY, double radiusX, double radiusY, double startAngle, double length)
      将路径元素添加到当前路径以创建使用欧几里德度数的弧。
      void arcTo​(double x1, double y1, double x2, double y2, double radius)
      将段添加到当前路径以创建弧。
      void beginPath​()
      将当前路径重置为空。
      void bezierCurveTo​(double xc1, double yc1, double xc2, double yc2, double x1, double y1)
      将段添加到当前路径以生成立方贝塞尔曲线。
      void clearRect​(double x, double y, double w, double h)
      用透明颜色值清除画布的一部分。
      void clip​()
      使用当前路径相交当前的剪辑并将其作为抗锯齿掩码应用到后续渲染操作。
      void closePath​()
      关闭路径。
      void drawImage​(Image img, double x, double y)
      使用给定图像的宽度和高度在给定的x，y位置绘制图像。
      void drawImage​(Image img, double x, double y, double w, double h)
      将图像绘制到画布的给定目标矩形中。
      void drawImage​(Image img, double sx, double sy, double sw, double sh, double dx, double dy, double dw, double dh)
      将给定图像的指定源矩形绘制到Canvas的给定目标矩形。
      void fill​()
      填充当前填充油漆的路径。
      void fillArc​(double x, double y, double w, double h, double startAngle, double arcExtent, ArcType closure)
      使用当前的填充油漆填充弧。
      void fillOval​(double x, double y, double w, double h)
      使用当前的填充油漆填充椭圆。
      void fillPolygon​(double[] xPoints, double[] yPoints, int nPoints)
      使用当前设置的填充油漆填充具有给定点的多边形。
      void fillRect​(double x, double y, double w, double h)
      使用当前的填充油漆填充矩形。
      void fillRoundRect​(double x, double y, double w, double h, double arcWidth, double arcHeight)
      使用当前的填充油漆填充圆角矩形。
      void fillText​(String text, double x, double y)
      使用当前的填充颜色属性填充位置x，y处的给定文本字符串。
      void fillText​(String text, double x, double y, double maxWidth)
      填写文本并包含字符串的最大宽度。
      Canvas getCanvas​()
      获取 Canvas的 GraphicsContext发出绘制命令。
      Effect getEffect​(Effect e)
      获取下一次绘图调用后应用的效果的副本。
      Paint getFill​()
      获取当前的填充颜色属性。
      FillRule getFillRule​()
      获取填充规则属性，以确定填充和剪辑操作中路径的内部。
      Font getFont​()
      获取当前字体。
      FontSmoothingType getFontSmoothingType​()
      获取当前的字体平滑类型。
      double getGlobalAlpha​()
      获取当前的全局alpha。
      BlendMode getGlobalBlendMode​()
      获取全局混合模式。
      StrokeLineCap getLineCap​()
      获取当前行程线上限。
      double[] getLineDashes​()
      获取当前线短线阵列的副本。
      double getLineDashOffset​()
      获取当前行的虚线偏移量。
      StrokeLineJoin getLineJoin​()
      获取当前笔划行连接。
      double getLineWidth​()
      获取当前行宽。
      double getMiterLimit​()
      获得当前的斜角限制。
      PixelWriter getPixelWriter​()
      返回一个PixelWriter对象，可用于修改与此GraphicsContext关联的Canvas的像素。
      Paint getStroke​()
      获取当前行程。
      TextAlignment getTextAlign​()
      获得当前的 TextAlignment 。
      VPos getTextBaseline​()
      获取当前的文本基线。
      Affine getTransform​()
      返回当前变换的副本。
      Affine getTransform​(Affine xform)
      将当前变换复制到提供的对象中，创建一个新的Affine对象（如果为null），并返回包含副本的对象。
      boolean isPointInPath​(double x, double y)
      如果给定的x，y点在路径内，则返回true。
      void lineTo​(double x1, double y1)
      将段添加到当前路径，以形成与给定x，y坐标的一条线。
      void moveTo​(double x0, double y0)
      X- 20045 X- 20045 X- 20045 X- 20045 X- 2001-
      void quadraticCurveTo​(double xc, double yc, double x1, double y1)
      将段添加到当前路径以生成二次贝塞尔曲线。
      void rect​(double x, double y, double w, double h)
      将路径元素添加到当前路径以创建一个矩形。
      void restore​()
      将状态从堆栈中弹出，将以下属性设置为将该状态推送到堆栈时的值。
      void rotate​(double degrees)
      以度为单位旋转当前变换。
      void save​()
      将以下属性保存到堆栈中。
      void scale​(double x, double y)
      通过x，y来缩放当前的变换。
      void setEffect​(Effect e)
      设置在下一次绘图调用后应用的效果，或设置为禁用效果的效果。
      void setFill​(Paint p)
      设置当前填充绘图属性。
      void setFillRule​(FillRule fillRule)
      设置填充规则属性以确定填充或剪辑操作中路径的内部。
      void setFont​(Font f)
      设置当前字体。
      void setFontSmoothingType​(FontSmoothingType fontsmoothing)
      设置当前的字体平滑类型。
      void setGlobalAlpha​(double alpha)
      设置当前状态的全局alpha。
      void setGlobalBlendMode​(BlendMode op)
      设置全局混合模式。
      void setLineCap​(StrokeLineCap cap)
      设置当前行程行上限。
      void setLineDashes​(double... dashes)
      将当前笔划线划线模式设置为参数的归一化副本。
      void setLineDashOffset​(double dashOffset)
      设置线破折号偏移。
      void setLineJoin​(StrokeLineJoin join)
      设置当前笔画行连接。
      void setLineWidth​(double lw)
      设置当前行宽。
      void setMiterLimit​(double ml)
      设定当前的斜度限制。
      void setStroke​(Paint p)
      设置当前笔画paint属性。
      void setTextAlign​(TextAlignment align)
      定义水平文本对齐方式，相对于文字 x来源。
      void setTextBaseline​(VPos baseline)
      设置当前的文本基线。
      void setTransform​(double mxx, double myx, double mxy, double myy, double mxt, double myt)
      设置当前变换。
      void setTransform​(Affine xform)
      设置当前变换。
      void stroke​()
      用当前行程画笔来描绘路径。
      void strokeArc​(double x, double y, double w, double h, double startAngle, double arcExtent, ArcType closure)
      使用当前笔画绘制弧。
      void strokeLine​(double x1, double y1, double x2, double y2)
      使用当前笔画绘制线条。
      void strokeOval​(double x, double y, double w, double h)
      使用当前的行程画笔绘制椭圆形。
      void strokePolygon​(double[] xPoints, double[] yPoints, int nPoints)
      使用当前设置的笔画绘制使用给定点绘制多边形。
      void strokePolyline​(double[] xPoints, double[] yPoints, int nPoints)
      使用当前设置的stroke paint属性来绘制具有给定点的折线。
      void strokeRect​(double x, double y, double w, double h)
      使用当前笔画绘制矩形。
      void strokeRoundRect​(double x, double y, double w, double h, double arcWidth, double arcHeight)
      使用当前笔画绘制一个圆角矩形。
      void strokeText​(String text, double x, double y)
      使用当前笔画paint属性绘制位置x，y处的给定文本字符串。
      void strokeText​(String text, double x, double y, double maxWidth)
      用笔画绘制文本，并包含字符串的最大宽度。
      void transform​(double mxx, double myx, double mxy, double myy, double mxt, double myt)
      将输入与当前变换相连。
      void transform​(Affine xform)
      将输入与当前变换相连。
      void translate​(double x, double y)
      将当前变换转换为x，y。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getCanvas

        public Canvas getCanvas​()
        获取Canvas的GraphicsContext发出绘制命令。 对于Canvas ，只有一个GraphicsContext 。
        结果
        画出这个 GraphicsContext发布绘制命令的画布。

      • save

        public void save​()
        将以下属性保存到堆栈中。
        • 全球阿尔法
        • 全球混合操作
        • 转变
        • 填充油漆
        • 中风漆
        • 行宽
        • 线帽
        • 行加入
        • 斜度限制
        • 夹
        • 字形
        • 文本对齐
        • 文本基线
        • 影响
        • 填充规则
        该方法不会以任何方式改变当前状态。 另外请注意，当前路径未保存。

      • restore

        public void restore​()
        将状态从堆栈中弹出，将以下属性设置为将该状态推送到堆栈时的值。 如果堆栈为空，则没有更改。
        • 全球阿尔法
        • 全球混合操作
        • 转变
        • 填充油漆
        • 中风漆
        • 行宽
        • 线帽
        • 行加入
        • 斜度限制
        • 夹
        • 字形
        • 文本对齐
        • 文本基线
        • 影响
        • 填充规则
        请注意，当前路径未恢复。

      • translate

        public void translate​(double x,
                      double y)
        将当前变换转换为x，y。
        参数
        x - 沿x轴平移的值。
        y - 沿y轴平移的值。

      • scale

        public void scale​(double x,
                  double y)
        通过x，y来缩放当前的变换。
        参数
        x - 在x轴上缩放的值。
        y - 在y轴上缩放的值。

      • rotate

        public void rotate​(double degrees)
        以度为单位旋转当前变换。
        参数
        degrees - 以度为单位旋转当前变换的值。

      • transform

        public void transform​(double mxx,
                      double myx,
                      double mxy,
                      double myy,
                      double mxt,
                      double myt)
        将输入与当前变换相连。
        参数
        mxx - - 3x4矩阵的X坐标缩放元素
        myx - - 3x4矩阵的Y坐标剪切元素
        mxy - - 3x4矩阵的X坐标剪切元素
        myy - - 3x4矩阵的Y坐标缩放元素
        mxt - - 3x4矩阵的X坐标转换元素
        myt - - 3x4矩阵的Y坐标转换元素

      • transform

        public void transform​(Affine xform)
        将输入与当前变换相连。 只支持2D转换。 所使用的唯一值是变换的X和Y缩放，平移和剪切分量。 A null值被视为身份。
        参数
        xform - 与当前变换连接的仿射或空值。

      • setTransform

        public void setTransform​(double mxx,
                         double myx,
                         double mxy,
                         double myy,
                         double mxt,
                         double myt)
        设置当前变换。
        参数
        mxx - - 3x4矩阵的X坐标缩放元素
        myx - - 3x4矩阵的Y坐标剪切元素
        mxy - 3x4矩阵的X坐标剪切元素
        myy - - 3x4矩阵的Y坐标缩放元素
        mxt - 3x4矩阵的X坐标转换元素
        myt - - 3x4矩阵的Y坐标转换元素

      • setTransform

        public void setTransform​(Affine xform)
        设置当前变换。 只支持2D转换。 所使用的唯一值是变换的X和Y缩放，平移和剪切分量。
        参数
        xform - 要复制并用作当前变换的仿射。

      • getTransform

        public Affine getTransform​(Affine xform)
        将当前变换复制到提供的对象中，创建一个新的Affine对象（如果为null），并返回包含副本的对象。
        参数
        xform - 将用于保存结果的转换对象。 如果xform为非空，则该方法将将当前变换复制到该对象中。 如果xform为空，则将构建一个新的变换对象。 在任一情况下，返回值都是当前变换的副本。
        结果
        当前变换的副本。

      • getTransform

        public Affine getTransform​()
        返回当前变换的副本。
        结果
        当前状态转换的副本。

      • setGlobalAlpha

        public void setGlobalAlpha​(double alpha)
        设置当前状态的全局alpha。 默认值为1.0 。 可以设置任何有效的双倍，但只有[0.0, 1.0]范围内的值有效，并且该范围中最接近的值将用于呈现。 全球阿尔法是common attribute用于在指定的几乎所有的渲染方法Rendering Attributes Table 。
        参数
        alpha - 新的alpha值，在实际使用中被钳制到 [0.0, 1.0] 。

      • getGlobalAlpha

        public double getGlobalAlpha​()
        获取当前的全局alpha。 默认值为1.0 。 全球阿尔法是common attribute用于在指定的几乎所有的渲染方法Rendering Attributes Table 。
        结果
        当前的全局alpha。

      • setGlobalBlendMode

        public void setGlobalBlendMode​(BlendMode op)
        设置全局混合模式。 默认值为SRC_OVER 。 A null值将被忽略，当前值将保持不变。 混合模式是common attribute用于在指定的几乎所有的渲染方法Rendering Attributes Table 。
        参数
        op - 将被设置或为null的 BlendMode 。

      • getGlobalBlendMode

        public BlendMode getGlobalBlendMode​()
        获取全局混合模式。 默认值为SRC_OVER 。 混合模式是common attribute用于在指定的几乎所有的渲染方法Rendering Attributes Table 。
        结果
        全球 BlendMode目前状态。

      • setFill

        public void setFill​(Paint p)
        设置当前填充绘图属性。 默认值为BLACK 。 填充油漆是用于Rendering Attributes Table中规定的任何填充方法的fill attribute 。 A null值将被忽略，当前值将保持不变。
        参数
        p -该 Paint用作填充 Paint或空。

      • getFill

        public Paint getFill​()
        获取当前的填充颜色属性。 默认值为BLACK 。 填充油漆是用于Rendering Attributes Table中指定的任何填充方法的fill attribute 。
        结果
        p Paint被用作填充 Paint 。

      • setStroke

        public void setStroke​(Paint p)
        设置当前笔画paint属性。 默认值为BLACK 。 中风涂料是用于Rendering Attributes Table中规定的任何冲程方法的stroke attribute 。 A null值将被忽略，当前值将保持不变。
        参数
        p - 用作笔画的油漆或空白。

      • getStroke

        public Paint getStroke​()
        获取当前行程。 默认值为BLACK 。 中风涂料是用于Rendering Attributes Table中规定的任何中风方法的stroke attribute 。
        结果
        Paint被用作笔画 Paint 。

      • setLineWidth

        public void setLineWidth​(double lw)
        设置当前行宽。 默认值为1.0 。 线宽是stroke attribute用于任何的作为规定的冲程方法Rendering Attributes Table 。 超出范围(0, +inf)的无限或非正值将被忽略，当前值将保持不变。
        参数
        lw - 值范围为{0-positive infinity}，任何其他值都被忽略，并保持不变。

      • getLineWidth

        public double getLineWidth​()
        获取当前行宽。 默认值为1.0 。 线宽为Rendering Attributes Table中规定的任何笔画方式的stroke attribute 。
        结果
        值在0和无穷大之间。

      • setLineCap

        public void setLineCap​(StrokeLineCap cap)
        设置当前行程行上限。 默认值为SQUARE 。 线盖是stroke attribute用于任何的作为规定的冲程方法Rendering Attributes Table 。 A null值将被忽略，当前值将保持不变。
        参数
        cap - StrokeLineCap ，其值为Butt，Round或Square或null。

      • getLineCap

        public StrokeLineCap getLineCap​()
        获取当前行程线上限。 默认值为SQUARE 。 线盖是stroke attribute用于任何的作为规定的冲程方法Rendering Attributes Table 。
        结果
        StrokeLineCap ，其值为Butt，Round或Square。

      • setLineJoin

        public void setLineJoin​(StrokeLineJoin join)
        设置当前笔画行连接。 默认值为StrokeLineJoin.MITER 。 线连接是用于Rendering Attributes Table中规定的任何笔画方法的stroke attribute 。 A null值将被忽略，当前值将保持不变。
        参数
        join - StrokeLineJoin ，其值为斜角，斜角或圆形或零。

      • getLineJoin

        public StrokeLineJoin getLineJoin​()
        获取当前笔划行连接。 默认值为StrokeLineJoin.MITER 。 线连接是用于Rendering Attributes Table中指定的任何笔画方法的stroke attribute 。
        结果
        StrokeLineJoin ，其值为斜角，斜角或圆形。

      • setMiterLimit

        public void setMiterLimit​(double ml)
        设定当前的斜度限制。 默认值为10.0 。 转角限制是stroke attribute用于任何的作为规定的冲程方法Rendering Attributes Table 。 超出范围(0, +inf)的无限或非正值将被忽略，当前值将保持不变。
        参数
        ml - 任何其他值被忽略且保持不变的0和正无穷大之间的 ml极限值。

      • getMiterLimit

        public double getMiterLimit​()
        获得当前的斜角限制。 默认值为10.0 。 转角限制是stroke attribute用于任何的作为规定的冲程方法Rendering Attributes Table 。
        结果
        斜角极限值在 0.0-positive infinity范围内

      • setLineDashes

        public void setLineDashes​(double... dashes)
        将当前笔划线划线模式设置为参数的归一化副本。 默认值为null 。 行虚线数组是stroke attribute用于任何的作为规定的冲程方法Rendering Attributes Table 。 如果数组为null或为空或包含所有0元素，则0将被禁用，并且当前的虚线数组将被设置为null 。 如果数组的任何元素是负数，无限或NaN值超出范围[0, +inf)则整个数组将被忽略，并且当前的虚线数组将保持不变。 如果数组是一个奇数长度，那么它将被视为相互附加的数组的两个副本。
        参数
        dashes - 有限非负面短划线的数组
        从以下版本开始：
        JavaFX 8u40

      • getLineDashes

        public double[] getLineDashes​()
        获取当前线短线阵列的副本。 默认值为null 。 可以通过setLineDashes(double...)方法中的验证测试对阵列进行归一化。 行虚线数组是stroke attribute用于任何的作为规定的冲程方法Rendering Attributes Table 。
        结果
        当前线短线阵列的副本。
        从以下版本开始：
        JavaFX 8u40

      • setLineDashOffset

        public void setLineDashOffset​(double dashOffset)
        设置线破折号偏移。 默认值为0.0 。 线破折号偏移是2706838111542770中指定的任何笔画方法的stroke attribute 。 超出范围(-inf, +inf)的无限或NaN值将被忽略，当前值将保持不变。
        参数
        dashOffset - 线破折号在范围 (-inf, +inf)
        从以下版本开始：
        JavaFX 8u40

      • getLineDashOffset

        public double getLineDashOffset​()
        获取当前行的虚线偏移量。 默认值为0.0 。 线冲突偏移是Rendering Attributes Table中指定的任何笔画方法的stroke attribute 。
        结果
        在线破折号偏移范围 (-inf, +inf)
        从以下版本开始：
        JavaFX 8u40

      • setFont

        public void setFont​(Font f)
        设置当前字体。 默认值由Font.getDefault()指定。 该字体是用于Rendering Attributes Table中指定的任何文本方法的text attribute 。 A null值将被忽略，当前值将保持不变。
        参数
        f - 字体或空。

      • getFont

        public Font getFont​()
        获取当前字体。 默认值由Font.getDefault()指定。 该字体是用于Rendering Attributes Table中指定的任何文本方法的text attribute 。
        结果
        字体

      • setFontSmoothingType

        public void setFontSmoothingType​(FontSmoothingType fontsmoothing)
        设置当前的字体平滑类型。 默认值为GRAY 。 字体平滑类型是用于Rendering Attributes Table中指定的任何文本方法的text attribute 。 A null值将被忽略，当前值将保持不变。

        需要注意的是FontSmoothingType的价值LCD仅支持在一个不透明的背景。 LCD文本通常会在透明或部分透明的像素上显示为GRAY文本，在某些实现中，由于对于所有Canvas对象都包含alpha通道的表面，不存在所需的支持，因此Canvas可能不受支持。

        参数
        fontsmoothing - FontSmoothingType或null
        从以下版本开始：
        JavaFX 8u40

      • getFontSmoothingType

        public FontSmoothingType getFontSmoothingType​()
        获取当前的字体平滑类型。 默认值为GRAY 。 字体平滑类型是用于Rendering Attributes Table中指定的任何文本方法的text attribute 。
        结果
        FontSmoothingType
        从以下版本开始：
        JavaFX 8u40

      • setTextAlign

        public void setTextAlign​(TextAlignment align)
        定义水平文本对齐，相对于文本x来源。 默认值为LEFT 。 文本对齐是用于Rendering Attributes Table中指定的任何文本方法的text attribute 。

        让水平边界表示单行文本的逻辑宽度。 每行文本都有一个单独的水平边界。

        然后TextAlignment指定为：

        • 左：水平边界的左边缘将在x 。
        • 中心：中心，左右边缘之间的中间，水平边界将在x 。
        • 右：水平边界的右边缘将在x 。

        注意：画布不支持换行，因此文本对齐对齐对齐与左对齐文本相同。

        A null值将被忽略，当前值将保持不变。

        参数
        align - TextAlignment ，其值为Left，Center，Right或null。

      • getTextAlign

        public TextAlignment getTextAlign​()
        获得当前的TextAlignment 。 默认值为LEFT 。 文本对齐是用于Rendering Attributes Table中指定的任何文本方法的text attribute 。
        结果
        TextAlignment ，其值为左，中，右或对齐。

      • setTextBaseline

        public void setTextBaseline​(VPos baseline)
        设置当前的文本基线。 默认值为BASELINE 。 文本基线是用于Rendering Attributes Table中指定的任何文本方法的text attribute 。 A null值将被忽略，当前值将保持不变。
        参数
        baseline - VPos ，其值为Top，Center，Baseline或Bottom或null。

      • getTextBaseline

        public VPos getTextBaseline​()
        获取当前的文本基线。 默认值为BASELINE 。 文本基准是用于Rendering Attributes Table中指定的任何文本方法的text attribute 。
        结果
        VPos ，其值为Top，Center，Baseline或Bottom

      • fillText

        public void fillText​(String text,
                     double x,
                     double y)
        使用当前的填充颜色属性填充位置x，y处的给定文本字符串。 A null文本值将被忽略。

        此方法将被任何的影响global common ， fill ，或text属性作为指定Rendering Attributes Table 。

        参数
        text - 文本字符串或null。
        x - x轴上的位置。
        y - y轴上的位置。

      • strokeText

        public void strokeText​(String text,
                       double x,
                       double y)
        使用当前笔画paint属性绘制位置x，y处的给定文本字符串。 A null文本值将被忽略。

        此方法将被任何的影响global common ， stroke ，或text属性作为指定Rendering Attributes Table 。

        参数
        text - 文本字符串或null。
        x - x轴上的位置。
        y - y轴上的位置。

      • fillText

        public void fillText​(String text,
                     double x,
                     double y,
                     double maxWidth)
        填写文本并包含字符串的最大宽度。 如果文本的宽度超过最大宽度，则它的大小适合。 A null文本值将被忽略。

        此方法将被任何的影响global common ， fill ，或text属性作为指定Rendering Attributes Table 。

        参数
        text - 文本字符串或null。
        x - x轴上的位置。
        y - y轴上的位置。
        maxWidth - 文本字符串可以具有的最大宽度。

      • strokeText

        public void strokeText​(String text,
                       double x,
                       double y,
                       double maxWidth)
        用笔画绘制文本，并包含字符串的最大宽度。 如果文本的宽度超过最大宽度，则它的大小适合。 一个null文本值将被忽略。

        此方法将被任何的影响global common ， stroke ，或text属性作为指定Rendering Attributes Table 。

        参数
        text - 文本字符串或null。
        x - x轴上的位置。
        y - y轴上的位置。
        maxWidth - 文本字符串可以具有的最大宽度。

      • setFillRule

        public void setFillRule​(FillRule fillRule)
        设置填充规则属性以确定填充或剪辑操作中路径的内部。 默认值为FillRule.NON_ZERO 。 A null值将被忽略，当前值将保持不变。 填充规则是用于Rendering Attributes Table中指定的任何填充或剪辑路径方法的path attribute 。
        参数
        fillRule - FillRule ，其值为Even_odd或Non_zero或null。

      • getFillRule

        public FillRule getFillRule​()
        获取填充规则属性，以确定填充和剪辑操作中路径的内部。 默认值为FillRule.NON_ZERO 。 填充规则是用于Rendering Attributes Table中指定的任何填充或剪辑路径方法的path attribute 。
        结果
        当前填充规则。

      • beginPath

        public void beginPath​()
        将当前路径重置为空。 默认路径为空。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。

      • moveTo

        public void moveTo​(double x0,
                   double y0)
        X- 20045 X- 20045 X- 20045 X- 20045 X- 2001- 当它们被添加到路径中时，坐标被当前变换变换，并且不受变换的后续改变的影响。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。
        参数
        x0 - 移动到命令的X位置。
        y0 - 移动命令的Y位置。

      • lineTo

        public void lineTo​(double x1,
                   double y1)
        将段添加到当前路径，以形成与给定x，y坐标的一条线。 当它们被添加到路径中时，坐标被当前变换变换，并且不受变换的后续改变的影响。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。
        参数
        x1 - 线的终点的X坐标。
        y1 - 线的终点的Y坐标。

      • quadraticCurveTo

        public void quadraticCurveTo​(double xc,
                             double yc,
                             double x1,
                             double y1)
        将段添加到当前路径以生成二次贝塞尔曲线。 当它们被添加到路径中时，坐标被当前变换变换，并且不受变换的后续改变的影响。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。
        参数
        xc - 控制点的X坐标
        yc - 控制点的Y坐标
        x1 - 终点的X坐标
        y1 - 终点的Y坐标

      • bezierCurveTo

        public void bezierCurveTo​(double xc1,
                          double yc1,
                          double xc2,
                          double yc2,
                          double x1,
                          double y1)
        将段添加到当前路径以生成立方贝塞尔曲线。 当它们被添加到路径中时，坐标被当前变换变换，并且不受变换的后续改变的影响。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。
        参数
        xc1 - 第一个贝塞尔控制点的X坐标。
        yc1 - 第一个贝塞尔控制点的Y坐标。
        xc2 - 第二个贝塞尔控制点的X坐标。
        yc2 - 第二个贝塞尔控制点的Y坐标。
        x1 - 终点的X坐标。
        y1 - 终点的Y坐标。

      • arcTo

        public void arcTo​(double x1,
                  double y1,
                  double x2,
                  double y2,
                  double radius)
        将段添加到当前路径以创建弧。 当它们被添加到路径中时，坐标被当前变换变换，并且不受变换的后续改变的影响。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。

        如果p0是路径中的当前点，并且p1是由(x1, y1)指定的点，而p2是由(x2, y2)指定的点，则附加的弧段将沿着指定半径的圆的圆周接触并内接到凸起（内）侧p0->p1->p2 。 路径将包含线段（如果需要）到该圆之间的切点p0->p1接着圆弧段到达圆之间的切点p1->p2 ，并且将与在该切点当前点端（未在p2 ）。 请注意，圆弧段的半径和圆形度将相对于当前变换进行测量或考虑，但是从这些未转换点计算的结果段随后将被添加到路径中进行变换。 由于所有计算都是在未转换的空间中完成的，而是先前存在的路径段都被转换，所以正确执行计算的能力可能隐含地取决于是否能够将当前路径的当前结果逆变换为未转换的坐标。

        如果由于任何原因无法计算和刻录指示的圆圈，那么整个操作将只是附加段来强制线到p1 。 计算可能失败的可能原因包括：

        • 当前路径为空。
        • 段p0->p1->p2是共线的。
        • 当前变换是不可逆的，因此当前路径的当前终点不能被转换以用于计算。
        参数
        x1 - 弧的第一个点的X坐标。
        y1 - 弧的第一个点的Y坐标。
        x2 - 弧的第二个点的X坐标。
        y2 - 弧的第二个点的Y坐标。
        radius - 圆弧的半径范围为{0.0-positive infinity}。

      • arc

        public void arc​(double centerX,
                double centerY,
                double radiusX,
                double radiusY,
                double startAngle,
                double length)
        将路径元素添加到当前路径以创建使用欧几里德度数的弧。 这个欧几里得方向从东到北，然后从西到西，然后是南，再回到东方。 当它们被添加到路径中时，坐标被当前变换变换，并且不受变换的后续改变的影响。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。
        参数
        centerX - 弧的中心x位置。
        centerY - 弧的中心y位置。
        radiusX - 圆弧的x半径。
        radiusY - 圆弧的y半径。
        startAngle - 弧的起始角度在 0-360.0范围内
        length - 弧线基线的长度。

      • rect

        public void rect​(double x,
                 double y,
                 double w,
                 double h)
        将路径元素添加到当前路径以创建一个矩形。 当它们被添加到路径中时，坐标被当前变换变换，并且不受变换的后续改变的影响。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。
        参数
        x - 矩形左上角的x位置。
        y - 矩形左上角的y位置。
        w - 矩形的宽度。
        h - 矩形的高度。

      • appendSVGPath

        public void appendSVGPath​(String svgpath)
        将SVG路径字符串附加到当前路径。 如果没有当前路径，则字符串必须以任一类型的move命令开头。 一个null值或不正确的SVG路径将被忽略。 当它们被添加到路径中时，坐标被当前变换变换，并且不受变换的后续改变的影响。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。
        参数
        svgpath - SVG路径字符串。

      • closePath

        public void closePath​()
        关闭路径。 的电流路径是path attribute用于任何的作为指定的路径的方法Rendering Attributes Table ， 并不受 save()个restore()操作。

      • fill

        public void fill​()
        填充当前填充油漆的路径。

        此方法将被任何的影响global common ， fill ，或path属性作为指定Rendering Attributes Table 。 请注意，路径段原始添加到当前路径中进行转换，因此当前的变换不会再次影响这些路径段，但是在fill()操作时可能会影响其他属性。

      • stroke

        public void stroke​()
        用当前行程画笔来描绘路径。

        此方法将被任何的影响global common ， stroke ，或path属性作为指定Rendering Attributes Table 。 请注意，路径段被原始添加到当前路径中进行转换，因此当前的变换不会再次影响这些路径段，但是在stroke()操作时可能会影响其他属性。

      • clip

        public void clip​()
        使用当前路径相交当前的剪辑并将其作为抗锯齿掩码应用到后续渲染操作。 目前的剪辑是common attribute用于在指定的几乎所有的渲染操作Rendering Attributes Table 。

        此方法本身将仅受Rendering Attributes Table中指定的path属性的影响 。 请注意，路径段最初被添加到当前路径中进行了转换，因此当前的变换不会再次影响这些路径段，但是在stroke()操作时可能会影响其他属性。

      • isPointInPath

        public boolean isPointInPath​(double x,
                             double y)
        如果给定的x，y点在路径内，则返回true。
        参数
        x - 用于检查的X坐标。
        y - 用于检查的Y坐标。
        结果
        如果给定的点在路径内，则为true，否则为false。

      • clearRect

        public void clearRect​(double x,
                      double y,
                      double w,
                      double h)
        用透明颜色值清除画布的一部分。

        此方法将仅受当前的变换，剪辑和效果的影响。

        参数
        x - 矩形左上角的X位置。
        y - 矩形左上角的Y位置。
        w - 矩形的宽度。
        h - 矩形的高度。

      • fillRect

        public void fillRect​(double x,
                     double y,
                     double w,
                     double h)
        使用当前的填充油漆填充矩形。

        该方法将受到Rendering Attributes Table中规定的任何global common或fill属性的影响 。

        参数
        x - 矩形左上角的X位置。
        y - 矩形左上角的Y位置。
        w - 矩形的宽度。
        h - 矩形的高度。

      • strokeRect

        public void strokeRect​(double x,
                       double y,
                       double w,
                       double h)
        使用当前笔画绘制矩形。

        该方法将受到Rendering Attributes Table中规定的任何global common或stroke属性的影响 。

        参数
        x - 矩形左上角的X位置。
        y - 矩形左上角的Y位置。
        w - 矩形的宽度。
        h - 矩形的高度。

      • fillOval

        public void fillOval​(double x,
                     double y,
                     double w,
                     double h)
        使用当前的填充油漆填充椭圆。

        此方法将受到Rendering Attributes Table中规定的任何global common或fill属性的影响 。

        参数
        x - 椭圆的左上界的X坐标。
        y - 椭圆的左上界的Y坐标。
        w - 椭圆中心的宽度。
        h - 椭圆中心的高度。

      • strokeOval

        public void strokeOval​(double x,
                       double y,
                       double w,
                       double h)
        使用当前的行程画笔绘制椭圆形。

        该方法将受到Rendering Attributes Table中规定的任何global common或stroke属性的影响 。

        参数
        x - 椭圆的左上界的X坐标。
        y - 椭圆的左上界的Y坐标。
        w - 椭圆中心的宽度。
        h - 椭圆中心的高度。

      • fillArc

        public void fillArc​(double x,
                    double y,
                    double w,
                    double h,
                    double startAngle,
                    double arcExtent,
                    ArcType closure)
        使用当前的填充油漆填充弧。 A null ArcType或非正的宽度或高度将导致render命令被忽略。

        该方法将受到Rendering Attributes Table中规定的任何global common或fill属性的影响 。

        参数
        x - 弧的X坐标。
        y - 弧的Y坐标。
        w - 弧的宽度。
        h - 弧的高度。
        startAngle - 圆弧的起始角度，以度为单位。
        arcExtent - 弧度的角度范围。
        closure - 封闭类型（Round，Chord，Open）或null。

      • strokeArc

        public void strokeArc​(double x,
                      double y,
                      double w,
                      double h,
                      double startAngle,
                      double arcExtent,
                      ArcType closure)
        使用当前笔画绘制弧。 A null ArcType或非正的宽度或高度将导致render命令被忽略。

        该方法将受到Rendering Attributes Table中规定的任何global common或stroke属性的影响 。

        参数
        x - 弧的X坐标。
        y - 弧的Y坐标。
        w - 弧的宽度。
        h - 弧的高度。
        startAngle - 圆弧的起始角度，以度为单位。
        arcExtent - arcExtent弧的角度范围为度。
        closure - 封闭类型（Round，Chord，Open）或null

      • fillRoundRect

        public void fillRoundRect​(double x,
                          double y,
                          double w,
                          double h,
                          double arcWidth,
                          double arcHeight)
        使用当前的填充油漆填充圆角矩形。

        该方法将受到Rendering Attributes Table中规定的任何global common或fill属性的影响 。

        参数
        x - 椭圆的左上边界的X坐标。
        y - 椭圆的左上界的Y坐标。
        w - 椭圆中心的宽度。
        h - 椭圆中心的高度。
        arcWidth - 矩形角的弧宽。
        arcHeight - 矩形角的弧高。

      • strokeRoundRect

        public void strokeRoundRect​(double x,
                            double y,
                            double w,
                            double h,
                            double arcWidth,
                            double arcHeight)
        使用当前笔画绘制一个圆角矩形。

        该方法将受到Rendering Attributes Table中规定的任何global common或stroke属性的影响 。

        参数
        x - 椭圆的左上界的X坐标。
        y - 椭圆的左上界的Y坐标。
        w - 椭圆中心的宽度。
        h - 椭圆中心的高度。
        arcWidth - 矩形角的弧宽。
        arcHeight - 矩形角的圆弧高度。

      • strokeLine

        public void strokeLine​(double x1,
                       double y1,
                       double x2,
                       double y2)
        使用当前笔画绘制线条。

        该方法将受到Rendering Attributes Table中规定的任何global common或stroke属性的影响 。

        参数
        x1 - 行的起始点的X坐标。
        y1 - 线的起始点的Y坐标。
        x2 - 线的终点的X坐标。
        y2 - 线的终点的Y坐标。

      • fillPolygon

        public void fillPolygon​(double[] xPoints,
                        double[] yPoints,
                        int nPoints)
        使用当前设置的填充油漆填充具有给定点的多边形。 任何数组的值为null将被忽略，不会绘制任何内容。

        此方法将被任何的影响global common ， fill ，或Fill Rule属性作为指定Rendering Attributes Table 。

        参数
        xPoints - 包含多边形点的x坐标的数组或空值。
        yPoints - 包含多边形点的y坐标或空值的数组。
        nPoints - 创建多边形的点数。

      • strokePolygon

        public void strokePolygon​(double[] xPoints,
                          double[] yPoints,
                          int nPoints)
        使用当前设置的笔画绘制使用给定点绘制多边形。 任何数组的值为null将被忽略，不会绘制任何内容。

        该方法将受到Rendering Attributes Table中规定的任何global common或stroke属性的影响 。

        参数
        xPoints - 包含多边形点的x坐标的数组或空值。
        yPoints - 包含多边形点的y坐标或空值的数组。
        nPoints - 使多边形的点数。

      • strokePolyline

        public void strokePolyline​(double[] xPoints,
                           double[] yPoints,
                           int nPoints)
        使用当前设置的stroke paint属性来绘制具有给定点的折线。 任何数组的值为null将被忽略，不会绘制任何内容。

        该方法将受到Rendering Attributes Table中规定的任何global common或stroke属性的影响 。

        参数
        xPoints - 包含折线点的x坐标的数组或空值。
        yPoints - 包含折线点的y坐标或空值的数组。
        nPoints - 使折线的点数。

      • drawImage

        public void drawImage​(Image img,
                      double x,
                      double y)
        使用给定图像的宽度和高度在给定的x，y位置绘制图像。 一个null图像值或仍在进行中的图像将被忽略。

        该方法将受到Rendering Attributes Table中规定的任何global common属性的影响 。

        参数
        img - 要绘制的图像或null。
        x - 图像左上方目的地的X坐标。
        y - 图像左上方目的地的Y坐标。

      • drawImage

        public void drawImage​(Image img,
                      double x,
                      double y,
                      double w,
                      double h)
        将图像绘制到画布的给定目标矩形中。 图像被缩放以适应目的地直角。 A null图像值或仍在进行中的图像将被忽略。

        该方法将受到Rendering Attributes Table中规定的任何global common属性的影响 。

        参数
        img - 要绘制的图像或null。
        x - 图像左上方目的地的X坐标。
        y - 图像左上方目的地的Y坐标。
        w - 目标矩形的宽度。
        h - 目标矩形的高度。

      • drawImage

        public void drawImage​(Image img,
                      double sx,
                      double sy,
                      double sw,
                      double sh,
                      double dx,
                      double dy,
                      double dw,
                      double dh)
        将给定图像的指定源矩形绘制到Canvas的给定目标矩形。 一个null图像值或仍在进行中的图像将被忽略。

        该方法将受到Rendering Attributes Table中规定的任何global common属性的影响 。

        参数
        img - 要绘制的图像或null。
        sx - 源矩形的X坐标位置。
        sy - 源矩形的Y坐标位置。
        sw - 源矩形的宽度。
        sh - 源矩形的高度。
        dx - 目标矩形的X坐标位置。
        dy - 目标矩形的Y坐标位置。
        dw - 目标矩形的宽度。
        dh - 目标矩形的高度。

      • getPixelWriter

        public PixelWriter getPixelWriter​()
        返回一个PixelWriter对象，可用于修改与此GraphicsContext关联的Canvas的像素。 返回对象中的PixelWriter方法中的所有坐标将在设备空间中，因为它们直接引用像素，并且在使用此对象修改像素时不会应用其他渲染属性。
        结果
        用于修改 PixelWriter的像素的 Canvas

      • setEffect

        public void setEffect​(Effect e)
        设置在下一次绘图调用后应用的效果，或设置为禁用效果的效果。 目前的效果是common attribute用于在指定的几乎所有的渲染操作Rendering Attributes Table 。
        参数
        e - 使用的效果，或禁用效果为null

      • getEffect

        public Effect getEffect​(Effect e)
        获取下一次绘图调用后应用的效果的副本。 空返回值意味着在后续呈现调用之后不会应用任何效果。 目前的效果是common attribute用于在指定的几乎所有的渲染操作Rendering Attributes Table 。
        参数
        e - 一个 Effect对象，可用于存储当前效果的副本，如果它是兼容类型
        结果
        用于所有渲染调用的当前效果，如果没有当前效果，则为null

      • applyEffect

        public void applyEffect​(Effect e)
        将给定的效果应用于画布的整个边界，并将结果存储回同一个画布。 A null值将被忽略。 该效果将被应用而没有任何其他渲染属性和身份坐标变换下。 由于效果应用于画布的整个边界，因此某些效果可能会产生令人困惑的结果，例如即使仅将画布的一部分渲染到并且将不可见，除非使用负偏移使反射回到视图。
        参数
        e - 应用于整个目的地的效果或null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.canvas (Java SE 9 & JDK 9 )

javafx.scene.canvas

Classes

  • Canvas
  • GraphicsContext


javafx.scene.canvas (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene.canvas

为canvas提供一组类，即渲染API的立即模式样式。

  • 类摘要
    Class 描述
    Canvas
    Canvas是可以使用由GraphicsContext提供的一组图形命令绘制的图像。
    GraphicsContext
    此类用于使用缓冲区发出对Canvas的绘制调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.canvas Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.canvas

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.canvas.GraphicsContext
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.canvas.Canvas
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package javafx.scene.canvas (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.canvas

  • Packages that use javafx.scene.canvas
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
  • Classes in javafx.scene.canvas used by javafx.scene.canvas
    Class 描述
    Canvas
    Canvas是可以使用由GraphicsContext提供的一组图形命令绘制的图像。
    GraphicsContext
    此类用于使用缓冲区发出对Canvas的绘制调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.canvas.Canvas (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.canvas.Canvas

  • Packages that use Canvas
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。

    • Uses of Canvas in javafx.scene.canvas

      Methods in javafx.scene.canvas that return Canvas
      Modifier and Type 方法 描述
      Canvas GraphicsContext.getCanvas​()
      获取 Canvas的 GraphicsContext的发行平局命令。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.canvas.GraphicsContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.canvas.GraphicsContext

  • Packages that use GraphicsContext
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。

    • Uses of GraphicsContext in javafx.scene.canvas

      Methods in javafx.scene.canvas that return GraphicsContext
      Modifier and Type 方法 描述
      GraphicsContext Canvas.getGraphicsContext2D​()
      返回 GraphicsContext与此 Canvas相关联。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AreaChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class AreaChart<X,Y>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
            • javafx.scene.chart.XYChart<X,Y>
              • javafx.scene.chart.AreaChart<X,Y>
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class AreaChart<X,Y>
extends XYChart<X,Y>
    AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty createSymbols
      当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。

      • Properties inherited from class javafx.scene.chart.Chart

        animated, legend, legendSide, legendVisible, title, titleSide

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisible, alternativeRowFillVisible, data, horizontalGridLinesVisible, horizontalZeroLineVisible, verticalGridLinesVisible, verticalZeroLineVisible

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.chart.XYChart

        XYChart.Data<X,Y>, XYChart.Series<X,Y>

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定轴构建新的区域图
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      BooleanProperty createSymbolsProperty​()
      当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
      protected void dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      boolean getCreateSymbols​()
      指示是否创建数据点的符号。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      protected void layoutPlotChildren​()
      被要求更新和布局情节儿童。
      protected void seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      当将每个原子更改作为此图表的系列列表时调用
      protected void seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。
      void setCreateSymbols​(boolean value)
      设置属性createSymbols的值。
      protected void updateAxisRange​()
      当范围已经无效并且我们需要更新时，这被称为。

      • Methods inherited from class javafx.scene.chart.Chart

        animate, animatedProperty, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getAnimated, getChartChildren, getLegend, getLegendSide, getTitle, getTitleSide, isLegendVisible, layoutChildren, legendProperty, legendSideProperty, legendVisibleProperty, requestChartLayout, setAnimated, setLegend, setLegendSide, setLegendVisible, setTitle, setTitleSide, shouldAnimate, titleProperty, titleSideProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisibleProperty, alternativeRowFillVisibleProperty, currentDisplayedExtraValueProperty, currentDisplayedXValueProperty, currentDisplayedYValueProperty, dataProperty, getCurrentDisplayedExtraValue, getCurrentDisplayedXValue, getCurrentDisplayedYValue, getData, getDisplayedDataIterator, getDisplayedSeriesIterator, getPlotChildren, getVerticalGridLinesVisible, getXAxis, getYAxis, horizontalGridLinesVisibleProperty, horizontalZeroLineVisibleProperty, isAlternativeColumnFillVisible, isAlternativeRowFillVisible, isHorizontalGridLinesVisible, isHorizontalZeroLineVisible, isVerticalZeroLineVisible, layoutChartChildren, removeDataItemFromDisplay, removeSeriesFromDisplay, setAlternativeColumnFillVisible, setAlternativeRowFillVisible, setCurrentDisplayedExtraValue, setCurrentDisplayedXValue, setCurrentDisplayedYValue, setData, setHorizontalGridLinesVisible, setHorizontalZeroLineVisible, setVerticalGridLinesVisible, setVerticalZeroLineVisible, updateLegend, verticalGridLinesVisibleProperty, verticalZeroLineVisibleProperty

    • Property Detail

      • createSymbols

        public final BooleanProperty createSymbolsProperty
        当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getCreateSymbols() ， setCreateSymbols(boolean)

    • 构造方法详细信息

      • AreaChart

        public AreaChart​(Axis<X> xAxis,
                 Axis<Y> yAxis)
        用给定轴构建新的区域图
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴

      • AreaChart

        public AreaChart​(Axis<X> xAxis,
                 Axis<Y> yAxis,
                 ObservableList<XYChart.Series<X,Y>> data)
        使用给定的轴和数据构建新的区域图
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中

    • 方法详细信息

      • getCreateSymbols

        public final boolean getCreateSymbols​()
        指示是否创建数据点的符号。
        结果
        如果将创建数据点的符号，则为true，否则为false。
        从以下版本开始：
        JavaFX 8.0

      • setCreateSymbols

        public final void setCreateSymbols​(boolean value)
        设置属性createSymbols的值。
        Property description:
        当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
        从以下版本开始：
        JavaFX 8.0

      • createSymbolsProperty

        public final BooleanProperty createSymbolsProperty​()
        当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getCreateSymbols() ， setCreateSymbols(boolean)

      • updateAxisRange

        protected void updateAxisRange​()
        当范围已经无效并且我们需要更新时，这被称为。 如果轴是自动测距，那么我们编译给定轴必须绘制的所有数据的列表，并在传递该数据的轴上调用invalidateRange（）。
        重写：
        updateAxisRange在 XYChart<X,Y>

      • dataItemAdded

        protected void dataItemAdded​(XYChart.Series<X,Y> series,
                             int itemIndex,
                             XYChart.Data<X,Y> item)
        说明从类别复制： XYChart
        将数据项添加到系列时调用。 这是XYChart的实现可以创建/添加新节点，以使getPlotChildren表示此数据项。 如果animated = true，他们也可以将数据添加为淡入淡出或相似。
        Specified by:
        dataItemAdded在 XYChart<X,Y>
        参数
        series - 数据项被添加到的系列
        itemIndex - 系列中新项目的索引
        item - 添加的新数据项

      • dataItemRemoved

        protected void dataItemRemoved​(XYChart.Data<X,Y> item,
                               XYChart.Series<X,Y> series)
        说明从类别复制： XYChart
        当数据项已从数据模型中删除但在图表上仍然可见时调用。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeDataItemFromDisplay（）来删除项目节点不显示在图表上。
        Specified by:
        dataItemRemoved在 XYChart<X,Y>
        参数
        item - 从系列中删除的项目
        series - 该项目已被删除

      • dataItemChanged

        protected void dataItemChanged​(XYChart.Data<X,Y> item)
        数据项已更改时调用，即其xValue，yValue或extraValue已更改。
        Specified by:
        dataItemChanged在 XYChart<X,Y>
        参数
        item - 已更改的数据项

      • seriesChanged

        protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
        描述从类别复制： XYChart
        当将每个原子更改作为此图表的系列列表时调用
        重写：
        seriesChanged在 XYChart<X,Y>
        参数
        c - 表示系列更改的更改实例

      • seriesAdded

        protected void seriesAdded​(XYChart.Series<X,Y> series,
                           int seriesIndex)
        描述从类别复制： XYChart
        一系列已经添加到图表数据模型中。 这是XYChart的实现可以创建/添加新的节点来getPlotChildren来表示这个系列。 此外，您必须处理添加已经在系列中的任何数据项。 您可以简单地为每一个调用dataItemAdded（），或为要添加的整个系列提供一些不同的动画。
        Specified by:
        seriesAdded在 XYChart<X,Y>
        参数
        series - 已添加的系列
        seriesIndex - 新系列的索引

      • seriesRemoved

        protected void seriesRemoved​(XYChart.Series<X,Y> series)
        描述从类别复制： XYChart
        数据模型中已经删除了一个系列，但它仍然可以在图表上显示。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeSeriesFromDisplay（）从显示列表中删除该系列。
        Specified by:
        seriesRemoved在 XYChart<X,Y>
        参数
        series - 已被删除的系列

      • layoutPlotChildren

        protected void layoutPlotChildren​()
        被要求更新和布局情节儿童。 这应该包括更新表示轴和网格线顶部的图的节点的所有工作。原点是绘图区域的左上角，绘制区域可以通过获取x轴的宽度及其高度从y轴的高度。
        Specified by:
        layoutPlotChildren在 XYChart<X,Y>

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData中的 XYChart<X,Y>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Axis (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class Axis<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Axis<T>
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    CategoryAxis ， ValueAxis

    public abstract class Axis<T>
extends Region
    JavaFX中所有轴的基类，表示在图表区域上绘制的轴。 它具有轴自动测距，刻度线和沿着轴的标签的属性。

    具体子类的一些示例包括NumberAxis，其轴绘制数字数据和CategoryAxis，其值/ tick表示其轴上的字符串类别。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty animated
      当真实时，轴和其范围的任何更改将被动画化。
      BooleanProperty autoRanging
      当轴自动从数据中确定其范围时，这一点是正确的
      ObjectProperty<String> label
      轴标签
      ObjectProperty<Side> side
      该轴正在绘制的曲线的一侧
      ObjectProperty<Paint> tickLabelFill
      填写所有刻度标签
      ObjectProperty<Font> tickLabelFont
      所有刻度标签的字体
      DoubleProperty tickLabelGap
      刻度标签和刻度线之间的差距
      DoubleProperty tickLabelRotation
      刻度标记以其正常水平旋转。
      BooleanProperty tickLabelsVisible
      如果显示标记标签，则为true
      DoubleProperty tickLength
      刻度线的长度
      BooleanProperty tickMarkVisible
      如果显示刻度线，则为真

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Axis.TickMark<T>
      TickMark代表标签文本，它与Axis的每个刻度相关联的属性。

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Axis​()
      创建并初始化Axis类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      BooleanProperty animatedProperty​()
      当真实时，轴和其范围的任何更改将被动画化。
      protected abstract Object autoRange​(double length)
      这将根据提供给invalidateRange（）方法的数据计算上限和下限。
      BooleanProperty autoRangingProperty​()
      当轴自动从数据中确定其范围时，这一点是正确的
      protected abstract List<T> calculateTickValues​(double length, Object range)
      计算范围内每个刻度线的所有数据值的列表
      protected double computePrefHeight​(double width)
      计算给定宽度的该轴的首选高度。
      protected double computePrefWidth​(double height)
      计算给定高度的该轴的首选宽度。
      boolean getAnimated​()
      指示轴范围的更改是否将被动画化。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      abstract double getDisplayPosition​(T value)
      获取给定值的沿该轴的显示位置。
      String getLabel​()
      获取属性标签的值。
      protected abstract Object getRange​()
      被称为获取当前的轴范围。
      Side getSide​()
      获取属性侧的值。
      Paint getTickLabelFill​()
      获取属性tickLabelFill的值。
      Font getTickLabelFont​()
      获取属性tickLabelFont的值。
      double getTickLabelGap​()
      获取属性tickLabelGap的值。
      double getTickLabelRotation​()
      获取属性tickLabelRotation的值。
      double getTickLength​()
      获取属性tickLength的值。
      protected abstract String getTickMarkLabel​(T value)
      获取具有给定值的刻度线的字符串标签名称
      ObservableList<Axis.TickMark<T>> getTickMarks​()
      不可修改的可观察的刻度表列表，每个TickMark在此轴上直接表示一个刻度。
      abstract T getValueForDisplay​(double displayPosition)
      获取此轴上给定显示位置的数据值。
      abstract double getZeroPosition​()
      获取沿该轴的零线的显示位置。
      protected void invalidateRange​()
      将当前范围标记为无效，这将导致在下一个布局上重新计算取决于范围的任何内容。
      void invalidateRange​(List<T> data)
      数据更改时调用，范围可能不再有效。
      boolean isAutoRanging​()
      获取属性autoRanging的值。
      protected boolean isRangeValid​()
      查看当前范围是否有效，如果不是，则在下一个布局通过时不需要重新排列任何范围相关的计算
      boolean isTickLabelsVisible​()
      获取属性tickLabelsVisible的值。
      boolean isTickMarkVisible​()
      获取属性tickMarkVisible的值。
      abstract boolean isValueOnAxis​(T value)
      检查给定值是否在该轴上是可绘制的
      ObjectProperty<String> labelProperty​()
      轴标签
      protected void layoutChildren​()
      在布局传递期间调用以布局此轴及其所有内容。
      protected Dimension2D measureTickMarkLabelSize​(String labelText, double rotation)
      测量给定刻度标记值的标签尺寸。
      protected Dimension2D measureTickMarkSize​(T value, double rotation)
      测量给定刻度标记值的标签尺寸。
      protected Dimension2D measureTickMarkSize​(T value, Object range)
      测量给定刻度标记值的标签尺寸。
      void requestAxisLayout​()
      请求轴在下一个布局通过中布局。
      void requestLayout​()
      我们通过不做任何事情来抑制requestLayout（）调用，因为我们不希望更改我们的孩子来导致布局。
      void setAnimated​(boolean value)
      设置动画属性的值。
      void setAutoRanging​(boolean value)
      设置属性autoRanging的值。
      void setLabel​(String value)
      设置属性标签的值。
      protected abstract void setRange​(Object range, boolean animate)
      调用将当前轴范围设置为给定范围。
      void setSide​(Side value)
      设置属性侧的值。
      void setTickLabelFill​(Paint value)
      设置属性tickLabelFill的值。
      void setTickLabelFont​(Font value)
      设置属性tickLabelFont的值。
      void setTickLabelGap​(double value)
      设置属性tickLabelGap的值。
      void setTickLabelRotation​(double value)
      设置属性tickLabelRotation的值。
      void setTickLabelsVisible​(boolean value)
      设置属性tickLabelsVisible的值。
      void setTickLength​(double value)
      设置属性tickLength的值。
      void setTickMarkVisible​(boolean value)
      设置属性tickMarkVisible的值。
      protected boolean shouldAnimate​()
      这是用来检查任何给定的动画是否应该运行。
      ObjectProperty<Side> sideProperty​()
      该轴正在绘制的曲线的一侧
      ObjectProperty<Paint> tickLabelFillProperty​()
      填写所有刻度标签
      ObjectProperty<Font> tickLabelFontProperty​()
      所有刻度标签的字体
      DoubleProperty tickLabelGapProperty​()
      刻度标签和刻度线之间的差距
      DoubleProperty tickLabelRotationProperty​()
      刻度标记以其正常水平旋转。
      BooleanProperty tickLabelsVisibleProperty​()
      如果显示标记标签，则为true
      DoubleProperty tickLengthProperty​()
      刻度线的长度
      protected void tickMarksUpdated​()
      如果已经更新了标记，则在布局期间调用，允许子类在反应中执行所需的任何操作。
      BooleanProperty tickMarkVisibleProperty​()
      如果显示刻度线，则为真
      abstract double toNumericValue​(T value)
      所有轴值必须由某些数值表示。
      abstract T toRealValue​(double value)
      所有轴值必须由某些数值表示。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • side

        public final ObjectProperty<Side> sideProperty
        该轴正在绘制的曲线的一侧
        另请参见：
        getSide() ， setSide(Side)

      • label

        public final ObjectProperty<String> labelProperty
        轴标签
        另请参见：
        getLabel() ， setLabel(String)

      • tickMarkVisible

        public final BooleanProperty tickMarkVisibleProperty
        如果显示刻度线，则为真
        另请参见：
        isTickMarkVisible() ， setTickMarkVisible(boolean)

      • tickLabelsVisible

        public final BooleanProperty tickLabelsVisibleProperty
        如果显示标记标签，则为true
        另请参见：
        isTickLabelsVisible() ， setTickLabelsVisible(boolean)

      • tickLength

        public final DoubleProperty tickLengthProperty
        刻度线的长度
        另请参见：
        getTickLength() ， setTickLength(double)

      • autoRanging

        public final BooleanProperty autoRangingProperty
        当轴自动从数据中确定其范围时，这一点是正确的
        另请参见：
        isAutoRanging() ， setAutoRanging(boolean)

      • tickLabelFont

        public final ObjectProperty<Font> tickLabelFontProperty
        所有刻度标签的字体
        另请参见：
        getTickLabelFont() ， setTickLabelFont(Font)

      • tickLabelFill

        public final ObjectProperty<Paint> tickLabelFillProperty
        填写所有刻度标签
        另请参见：
        getTickLabelFill() ， setTickLabelFill(Paint)

      • tickLabelGap

        public final DoubleProperty tickLabelGapProperty
        刻度标签和刻度线之间的差距
        另请参见：
        getTickLabelGap() ， setTickLabelGap(double)

      • animated

        public final BooleanProperty animatedProperty
        当真实时，轴和其范围的任何更改将被动画化。
        另请参见：
        getAnimated() ， setAnimated(boolean)

      • tickLabelRotation

        public final DoubleProperty tickLabelRotationProperty
        刻度标记以其正常水平旋转。
        另请参见：
        getTickLabelRotation() ， setTickLabelRotation(double)

    • 构造方法详细信息

      • Axis

        public Axis​()
        创建并初始化Axis类的新实例。

    • 方法详细信息

      • getTickMarks

        public ObservableList<Axis.TickMark<T>> getTickMarks​()
        不可修改的可观察的刻度表列表，每个TickMark在此轴上直接表示一个刻度。 每当显示的标记更改时，它都会更新。
        结果
        该轴上的TickMarks的不可修改的可观察列表

      • getSide

        public final Side getSide​()
        获取属性侧的值。
        Property description:
        该轴正在绘制的曲线的一侧

      • setSide

        public final void setSide​(Side value)
        设置属性侧的值。
        Property description:
        该轴正在绘制的曲线的一侧

      • sideProperty

        public final ObjectProperty<Side> sideProperty​()
        该轴正在绘制的曲线的一侧
        另请参见：
        getSide() ， setSide(Side)

      • getLabel

        public final String getLabel​()
        获取属性标签的值。
        Property description:
        轴标签

      • setLabel

        public final void setLabel​(String value)
        设置属性标签的值。
        Property description:
        轴标签

      • labelProperty

        public final ObjectProperty<String> labelProperty​()
        轴标签
        另请参见：
        getLabel() ， setLabel(String)

      • isTickMarkVisible

        public final boolean isTickMarkVisible​()
        获取属性tickMarkVisible的值。
        Property description:
        如果显示刻度线，则为真

      • setTickMarkVisible

        public final void setTickMarkVisible​(boolean value)
        设置属性tickMarkVisible的值。
        Property description:
        如果显示刻度线，则为真

      • tickMarkVisibleProperty

        public final BooleanProperty tickMarkVisibleProperty​()
        如果显示刻度线，则为真
        另请参见：
        isTickMarkVisible() ， setTickMarkVisible(boolean)

      • isTickLabelsVisible

        public final boolean isTickLabelsVisible​()
        获取属性tickLabelsVisible的值。
        Property description:
        如果显示标记标签，则为true

      • setTickLabelsVisible

        public final void setTickLabelsVisible​(boolean value)
        设置属性tickLabelsVisible的值。
        Property description:
        如果显示标记标签，则为true

      • tickLabelsVisibleProperty

        public final BooleanProperty tickLabelsVisibleProperty​()
        如果显示标记标签，则为true
        另请参见：
        isTickLabelsVisible() ， setTickLabelsVisible(boolean)

      • getTickLength

        public final double getTickLength​()
        获取属性tickLength的值。
        Property description:
        刻度线的长度

      • setTickLength

        public final void setTickLength​(double value)
        设置属性tickLength的值。
        Property description:
        刻度线的长度

      • tickLengthProperty

        public final DoubleProperty tickLengthProperty​()
        刻度线的长度
        另请参见：
        getTickLength() ， setTickLength(double)

      • isAutoRanging

        public final boolean isAutoRanging​()
        获取属性autoRanging的值。
        Property description:
        当轴自动从数据中确定其范围时，这一点是正确的

      • setAutoRanging

        public final void setAutoRanging​(boolean value)
        设置属性autoRanging的值。
        Property description:
        当轴自动从数据中确定其范围时，这一点是正确的

      • autoRangingProperty

        public final BooleanProperty autoRangingProperty​()
        当轴自动从数据中确定其范围时，这一点是正确的
        另请参见：
        isAutoRanging() ， setAutoRanging(boolean)

      • getTickLabelFont

        public final Font getTickLabelFont​()
        获取属性tickLabelFont的值。
        Property description:
        所有刻度标签的字体

      • setTickLabelFont

        public final void setTickLabelFont​(Font value)
        设置属性tickLabelFont的值。
        Property description:
        所有刻度标签的字体

      • tickLabelFontProperty

        public final ObjectProperty<Font> tickLabelFontProperty​()
        所有刻度标签的字体
        另请参见：
        getTickLabelFont() ， setTickLabelFont(Font)

      • getTickLabelFill

        public final Paint getTickLabelFill​()
        获取属性tickLabelFill的值。
        Property description:
        填写所有刻度标签

      • setTickLabelFill

        public final void setTickLabelFill​(Paint value)
        设置属性tickLabelFill的值。
        Property description:
        填写所有刻度标签

      • tickLabelFillProperty

        public final ObjectProperty<Paint> tickLabelFillProperty​()
        填写所有刻度标签
        另请参见：
        getTickLabelFill() ， setTickLabelFill(Paint)

      • getTickLabelGap

        public final double getTickLabelGap​()
        获取属性tickLabelGap的值。
        Property description:
        刻度标签和刻度线之间的差距

      • setTickLabelGap

        public final void setTickLabelGap​(double value)
        设置属性tickLabelGap的值。
        Property description:
        刻度标签和刻度线之间的差距

      • tickLabelGapProperty

        public final DoubleProperty tickLabelGapProperty​()
        刻度标签和刻度线之间的差距
        另请参见：
        getTickLabelGap() ， setTickLabelGap(double)

      • getAnimated

        public final boolean getAnimated​()
        指示轴范围的更改是否将被动画化。
        结果
        如果轴范围更改将被动画为true，否则为false

      • setAnimated

        public final void setAnimated​(boolean value)
        设置动画属性的值。
        Property description:
        当真实时，轴和其范围的任何更改将被动画化。

      • animatedProperty

        public final BooleanProperty animatedProperty​()
        当真实时，轴和其范围的任何更改将被动画化。
        另请参见：
        getAnimated() ， setAnimated(boolean)

      • getTickLabelRotation

        public final double getTickLabelRotation​()
        获取属性tickLabelRotation的值。
        Property description:
        刻度标记以其正常水平旋转。

      • setTickLabelRotation

        public final void setTickLabelRotation​(double value)
        设置属性tickLabelRotation的值。
        Property description:
        刻度标记以其正常水平旋转。

      • tickLabelRotationProperty

        public final DoubleProperty tickLabelRotationProperty​()
        刻度标记以其正常水平旋转。
        另请参见：
        getTickLabelRotation() ， setTickLabelRotation(double)

      • isRangeValid

        protected final boolean isRangeValid​()
        查看当前范围是否有效，如果不是，则在下一个布局通过时不需要重新排列任何范围相关的计算
        结果
        如果当前范围计算有效，则为true

      • invalidateRange

        protected final void invalidateRange​()
        将当前范围标记为无效，这将导致在下一个布局上重新计算取决于范围的任何内容。

      • shouldAnimate

        protected final boolean shouldAnimate​()
        这是用来检查任何给定的动画是否应该运行。 如果启用了动画并且节点在可见的场景中，则返回true。
        结果
        如果动画应该发生，则为真

      • requestLayout

        public void requestLayout​()
        我们通过不做任何事情来抑制requestLayout（）调用，因为我们不希望更改我们的孩子来导致布局。 如果您真的需要请求布局，请调用requestAxisLayout（）。
        重写：
        requestLayout在 Parent

      • requestAxisLayout

        public void requestAxisLayout​()
        请求轴在下一个布局通过中布局。 这将替换requestLayout（），因为它已被覆盖，不执行任何操作，以便更改子对象等不会导致布局。 这是作为优化完成的，因为Axis知道真正需要布局更新的精确的最小变化集。 所以我们只想要布局，而不是任何孩子改变。

      • invalidateRange

        public void invalidateRange​(List<T> data)
        数据更改时调用，范围可能不再有效。 如果isAutoRanging（）返回true，则仅由图表调用。 如果我们是自动测距，它将导致布局被请求，并且自动测距在下一个布局传递中发生。
        参数
        data - 需要在此轴上绘制的所有数据的当前集合

      • autoRange

        protected abstract Object autoRange​(double length)
        这将根据提供给invalidateRange（）方法的数据计算上限和下限。 这不能影响轴的状态，改变轴的任何属性。 应在范围对象中返回自动范围的任何结果。 如果已决定为此轴采用此范围，我们将传递给setRange（）。
        参数
        length - 屏幕坐标轴的长度
        结果
        范围信息，这是依赖于实现的

      • setRange

        protected abstract void setRange​(Object range,
                                 boolean animate)
        调用将当前轴范围设置为给定范围。 如果isAnimating（）为true，那么此方法应将范围设置为新范围。
        参数
        range - 从autoRange（）返回的范围对象
        animate - 如果真的动画范围的变化

      • getRange

        protected abstract Object getRange​()
        被称为获取当前的轴范围。
        结果
        可以传递给setRange（）和calculateTickValues（）的范围对象

      • getZeroPosition

        public abstract double getZeroPosition​()
        获取沿该轴的零线的显示位置。
        结果
        显示位置或Double.NaN如果零不在当前范围内;

      • getDisplayPosition

        public abstract double getDisplayPosition​(T value)
        获取给定值的沿该轴的显示位置。 如果该值不在当前范围内，返回的值将是显示位置的外推。 如果该值对该轴无效，并且轴不能在任何范围内显示此值，则返回Double.NaN
        参数
        value - 要显示的数据值显示位置
        结果
        显示位置或Double.NaN，如果值无效

      • getValueForDisplay

        public abstract T getValueForDisplay​(double displayPosition)
        获取此轴上给定显示位置的数据值。 如果轴是一个CategoryAxis，这将是最接近的值。
        参数
        displayPosition - 此轴上的像素位置
        结果
        给定像素位置的最近数据值，如果不在轴上则为null;

      • isValueOnAxis

        public abstract boolean isValueOnAxis​(T value)
        检查给定值是否在该轴上是可绘制的
        参数
        value - 检查其轴上的值
        结果
        如果给定值在此轴上是可绘制的，则为true

      • toNumericValue

        public abstract double toNumericValue​(T value)
        所有轴值必须由某些数值表示。 这将获取给定数据值的数值。
        参数
        value - 要转换的数据值
        结果
        给定数据值的数值

      • toRealValue

        public abstract T toRealValue​(double value)
        所有轴值必须由某些数值表示。 这将获取给定数值的数据值。
        参数
        value - 要转换的数值
        结果
        给定数值的数据值

      • calculateTickValues

        protected abstract List<T> calculateTickValues​(double length,
                                               Object range)
        计算范围内每个刻度线的所有数据值的列表
        参数
        length - 显示单位中轴的长度
        range - 从autoRange（）返回的范围对象
        结果
        如果是给定长度，则可以沿轴线拟合的刻度线列表

      • computePrefHeight

        protected double computePrefHeight​(double width)
        计算给定宽度的该轴的首选高度。 如果轴方向是水平方向，则考虑到刻度标记长度，刻度标签间隙和标签高度。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        计算此轴的首选宽度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        计算给定高度的该轴的首选宽度。 如果轴方向是垂直的，则考虑到刻度标记长度，刻度标签间隙和标签高度。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算此轴的首选宽度

      • tickMarksUpdated

        protected void tickMarksUpdated​()
        如果已经更新了标记，则在布局期间调用，允许子类在反应中执行所需的任何操作。

      • layoutChildren

        protected void layoutChildren​()
        在布局传递期间调用以布局此轴及其所有内容。
        重写：
        layoutChildren中的 Parent

      • getTickMarkLabel

        protected abstract String getTickMarkLabel​(T value)
        获取具有给定值的刻度线的字符串标签名称
        参数
        value - 要格式化为刻度标签字符串的值
        结果
        给定值的格式化字符串

      • measureTickMarkLabelSize

        protected final Dimension2D measureTickMarkLabelSize​(String labelText,
                                                     double rotation)
        测量给定刻度标记值的标签尺寸。 这使用为刻度线设置的字体
        参数
        labelText - 刻度线标签文字
        rotation - 文字旋转
        结果
        给定值的刻度标签的大小

      • measureTickMarkSize

        protected final Dimension2D measureTickMarkSize​(T value,
                                                double rotation)
        测量给定刻度标记值的标签尺寸。 这使用为刻度线设置的字体
        参数
        value - 刻度值
        rotation - 文本旋转
        结果
        给定值的刻度标签的大小

      • measureTickMarkSize

        protected Dimension2D measureTickMarkSize​(T value,
                                          Object range)
        测量给定刻度标记值的标签尺寸。 这使用为刻度线设置的字体
        参数
        value - 刻度值
        range - 计算过程中使用的范围
        结果
        给定值的刻度标签的大小

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Axis.TickMark (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class Axis.TickMark<T>

  • java.lang.Object
    • javafx.scene.chart.Axis.TickMark<T>
  • Enclosing class:
    Axis < T >

    public static final class Axis.TickMark<T>
extends Object
    TickMark代表标签文本，它与Axis的每个刻度相关联的属性。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      StringExpression label
      刻度线的显示文字
      DoubleExpression position
      沿轴的显示位置以轴原点为单位
      ObjectExpression<T> value
      数据单位中该刻度线的值

    • 构造方法摘要

      构造方法
      Constructor 描述
      TickMark​()
      创建并初始化TickMark的一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getLabel​()
      获取属性标签的值。
      double getPosition​()
      获取属性位置的值。
      T getValue​()
      获取属性值的值。
      boolean isTextVisible​()
      指示是否显示此刻度标签标签文本。
      StringExpression labelProperty​()
      刻度线的显示文字
      DoubleExpression positionProperty​()
      沿轴的显示位置以轴原点为单位
      void setLabel​(String value)
      设置属性标签的值。
      void setPosition​(double value)
      设置属性位置的值。
      void setTextVisible​(boolean value)
      指定是否显示此刻度标签标签文本。
      void setValue​(T v)
      设置属性值的值。
      String toString​()
      返回此 TickMark对象的字符串表示形式。
      ObjectExpression<T> valueProperty​()
      数据单位中该刻度线的值

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • label

        public final StringExpression labelProperty
        刻度线的显示文字
        另请参见：
        getLabel() ， setLabel(String)

      • value

        public final ObjectExpression<T> valueProperty
        数据单位中该刻度线的值
        另请参见：
        getValue() ， setValue(T)

      • position

        public final DoubleExpression positionProperty
        沿轴的显示位置以轴原点为单位
        另请参见：
        getPosition() ， setPosition(double)

    • 构造方法详细信息

      • TickMark

        public TickMark​()
        创建并初始化TickMark的一个实例。

    • 方法详细信息

      • getLabel

        public final String getLabel​()
        获取属性标签的值。
        Property description:
        刻度线的显示文字

      • setLabel

        public final void setLabel​(String value)
        设置属性标签的值。
        Property description:
        刻度线的显示文字

      • labelProperty

        public final StringExpression labelProperty​()
        刻度线的显示文字
        另请参见：
        getLabel() ， setLabel(String)

      • getValue

        public final T getValue​()
        获取属性值的值。
        Property description:
        数据单位中该刻度线的值

      • setValue

        public final void setValue​(T v)
        设置属性值的值。
        Property description:
        数据单位中该刻度线的值

      • valueProperty

        public final ObjectExpression<T> valueProperty​()
        数据单位中该刻度线的值
        另请参见：
        getValue() ， setValue(T)

      • getPosition

        public final double getPosition​()
        获取属性位置的值。
        Property description:
        沿轴的显示位置以轴原点为单位

      • setPosition

        public final void setPosition​(double value)
        设置属性位置的值。
        Property description:
        沿轴的显示位置以轴原点为单位

      • positionProperty

        public final DoubleExpression positionProperty​()
        沿轴的显示位置以轴原点为单位
        另请参见：
        getPosition() ， setPosition(double)

      • isTextVisible

        public final boolean isTextVisible​()
        指示是否显示此刻度标签标签文本。
        结果
        如果刻度标签标签文本可见，则为true，否则为false

      • setTextVisible

        public final void setTextVisible​(boolean value)
        指定是否显示此刻度标签标签文本。
        参数
        value - 如果刻度标签标签文本可见，则为true，否则为false

      • toString

        public String toString​()
        返回此 TickMark对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 TickMark对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BarChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class BarChart<X,Y>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
            • javafx.scene.chart.XYChart<X,Y>
              • javafx.scene.chart.BarChart<X,Y>
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class BarChart<X,Y>
extends XYChart<X,Y>
    绘制一个指示类别数据值的条形图。 条可以是垂直或水平，取决于哪个轴是类别轴。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty barGap
      在同一类别的酒吧之间留下的差距
      DoubleProperty categoryGap
      在不同类别的酒吧之间留下的差距

      • Properties inherited from class javafx.scene.chart.Chart

        animated, legend, legendSide, legendVisible, title, titleSide

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisible, alternativeRowFillVisible, data, horizontalGridLinesVisible, horizontalZeroLineVisible, verticalGridLinesVisible, verticalZeroLineVisible

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.chart.XYChart

        XYChart.Data<X,Y>, XYChart.Series<X,Y>

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定的轴构建一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      用给定的轴和数据构造一个新的BarChart。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      DoubleProperty barGapProperty​()
      在同一类别的酒吧之间留下的差距
      DoubleProperty categoryGapProperty​()
      在不同类别的酒吧之间留下的差距
      protected void dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      double getBarGap​()
      获取属性barGap的值。
      double getCategoryGap​()
      获取属性categoryGap的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      protected void layoutPlotChildren​()
      被要求更新和布局情节儿童。
      protected void seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      当将每个原子更改作为此图表的系列列表时调用
      protected void seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。
      void setBarGap​(double value)
      设置属性barGap的值。
      void setCategoryGap​(double value)
      设置属性categoryGap的值。

      • Methods inherited from class javafx.scene.chart.Chart

        animate, animatedProperty, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getAnimated, getChartChildren, getLegend, getLegendSide, getTitle, getTitleSide, isLegendVisible, layoutChildren, legendProperty, legendSideProperty, legendVisibleProperty, requestChartLayout, setAnimated, setLegend, setLegendSide, setLegendVisible, setTitle, setTitleSide, shouldAnimate, titleProperty, titleSideProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisibleProperty, alternativeRowFillVisibleProperty, currentDisplayedExtraValueProperty, currentDisplayedXValueProperty, currentDisplayedYValueProperty, dataProperty, getCurrentDisplayedExtraValue, getCurrentDisplayedXValue, getCurrentDisplayedYValue, getData, getDisplayedDataIterator, getDisplayedSeriesIterator, getPlotChildren, getVerticalGridLinesVisible, getXAxis, getYAxis, horizontalGridLinesVisibleProperty, horizontalZeroLineVisibleProperty, isAlternativeColumnFillVisible, isAlternativeRowFillVisible, isHorizontalGridLinesVisible, isHorizontalZeroLineVisible, isVerticalZeroLineVisible, layoutChartChildren, removeDataItemFromDisplay, removeSeriesFromDisplay, setAlternativeColumnFillVisible, setAlternativeRowFillVisible, setCurrentDisplayedExtraValue, setCurrentDisplayedXValue, setCurrentDisplayedYValue, setData, setHorizontalGridLinesVisible, setHorizontalZeroLineVisible, setVerticalGridLinesVisible, setVerticalZeroLineVisible, updateAxisRange, updateLegend, verticalGridLinesVisibleProperty, verticalZeroLineVisibleProperty

    • Property Detail

      • barGap

        public final DoubleProperty barGapProperty
        在同一类别的酒吧之间留下的差距
        另请参见：
        getBarGap() ， setBarGap(double)

      • categoryGap

        public final DoubleProperty categoryGapProperty
        在不同类别的酒吧之间留下的差距
        另请参见：
        getCategoryGap() ， setCategoryGap(double)

    • 构造方法详细信息

      • BarChart

        public BarChart​(Axis<X> xAxis,
                Axis<Y> yAxis)
        用给定的轴构建一个新的BarChart。 两轴应该是ValueAxis / NumberAxis和CategoryAxis，它们可以是任意顺序，具体取决于是否要使用水平或垂直条形图。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴

      • BarChart

        public BarChart​(Axis<X> xAxis,
                Axis<Y> yAxis,
                ObservableList<XYChart.Series<X,Y>> data)
        用给定的轴和数据构造一个新的BarChart。 两轴应该是ValueAxis / NumberAxis和CategoryAxis，它们可以是任意顺序，具体取决于是否要使用水平或垂直条形图。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中

      • BarChart

        public BarChart​(Axis<X> xAxis,
                Axis<Y> yAxis,
                ObservableList<XYChart.Series<X,Y>> data,
                double categoryGap)
        用给定的轴和数据构造一个新的BarChart。 两轴应该是ValueAxis / NumberAxis和CategoryAxis，它们可以是任意顺序，具体取决于是否要使用水平或垂直条形图。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中
        categoryGap - 不同类别酒吧之间的差距

    • 方法详细信息

      • getBarGap

        public final double getBarGap​()
        获取属性barGap的值。
        Property description:
        在同一类别的酒吧之间留下的差距

      • setBarGap

        public final void setBarGap​(double value)
        设置属性barGap的值。
        Property description:
        在同一类别的酒吧之间留下的差距

      • barGapProperty

        public final DoubleProperty barGapProperty​()
        在同一类别的酒吧之间留下的差距
        另请参见：
        getBarGap() ， setBarGap(double)

      • getCategoryGap

        public final double getCategoryGap​()
        获取属性categoryGap的值。
        Property description:
        在不同类别的酒吧之间留下的差距

      • setCategoryGap

        public final void setCategoryGap​(double value)
        设置属性categoryGap的值。
        Property description:
        在不同类别的酒吧之间留下的差距

      • categoryGapProperty

        public final DoubleProperty categoryGapProperty​()
        在不同类别的酒吧之间留下的差距
        另请参见：
        getCategoryGap() ， setCategoryGap(double)

      • dataItemAdded

        protected void dataItemAdded​(XYChart.Series<X,Y> series,
                             int itemIndex,
                             XYChart.Data<X,Y> item)
        说明从类别复制： XYChart
        将数据项添加到系列时调用。 这是XYChart的实现可以创建/添加新节点，以使getPlotChildren表示此数据项。 如果animated = true，他们也可以将数据添加为淡入淡出或相似。
        Specified by:
        dataItemAdded在 XYChart<X,Y>
        参数
        series - 数据项被添加到的系列
        itemIndex - 系列中新项目的索引
        item - 添加的新数据项

      • dataItemRemoved

        protected void dataItemRemoved​(XYChart.Data<X,Y> item,
                               XYChart.Series<X,Y> series)
        描述从类别复制： XYChart
        当数据项已从数据模型中删除但在图表上仍然可见时调用。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeDataItemFromDisplay（）来删除项目节点不显示在图表上。
        Specified by:
        dataItemRemoved在 XYChart<X,Y>
        参数
        item - 从系列中删除的项目
        series - 该项目已被删除

      • dataItemChanged

        protected void dataItemChanged​(XYChart.Data<X,Y> item)
        数据项已更改时调用，即其xValue，yValue或extraValue已更改。
        Specified by:
        dataItemChanged在 XYChart<X,Y>
        参数
        item - 被更改的数据项

      • seriesChanged

        protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
        说明从类别复制： XYChart
        当将每个原子更改作为此图表的系列列表时调用
        重写：
        seriesChanged在 XYChart<X,Y>
        参数
        c - 表示系列更改的更改实例

      • seriesAdded

        protected void seriesAdded​(XYChart.Series<X,Y> series,
                           int seriesIndex)
        说明从类别复制： XYChart
        一系列已经添加到图表数据模型中。 这是XYChart的实现可以创建/添加新的节点来getPlotChildren来表示这个系列。 此外，您必须处理添加已经在系列中的任何数据项。 您可以简单地为每一个调用dataItemAdded（），或为要添加的整个系列提供一些不同的动画。
        Specified by:
        seriesAdded在 XYChart<X,Y>
        参数
        series - 已添加的系列
        seriesIndex - 新系列的索引

      • seriesRemoved

        protected void seriesRemoved​(XYChart.Series<X,Y> series)
        说明从类别复制： XYChart
        数据模型中已经删除了一个系列，但它仍然可以在图表上显示。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeSeriesFromDisplay（）从显示列表中删除该系列。
        Specified by:
        seriesRemoved在 XYChart<X,Y>
        参数
        series - 已被删除的系列

      • layoutPlotChildren

        protected void layoutPlotChildren​()
        被要求更新和布局情节儿童。 这应该包括更新表示轴和网格线顶部的图的节点的所有工作。原点是绘图区域的左上角，绘制区域可以通过获取x轴的宽度及其高度从y轴的高度。
        Specified by:
        layoutPlotChildren的 XYChart<X,Y>

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 XYChart<X,Y>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BubbleChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class BubbleChart<X,Y>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
            • javafx.scene.chart.XYChart<X,Y>
              • javafx.scene.chart.BubbleChart<X,Y>
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class BubbleChart<X,Y>
extends XYChart<X,Y>
    为一系列数据点绘制气泡的图表类型。 Data的extra值属性用于表示它应该是java.lang.Number的气泡的半径。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.chart.Chart

        animated, legend, legendSide, legendVisible, title, titleSide

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisible, alternativeRowFillVisible, data, horizontalGridLinesVisible, horizontalZeroLineVisible, verticalGridLinesVisible, verticalZeroLineVisible

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.chart.XYChart

        XYChart.Data<X,Y>, XYChart.Series<X,Y>

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴构建一个新的BubbleChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的BubbleChart。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      protected void layoutPlotChildren​()
      被要求更新和布局情节儿童。
      protected void seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。
      protected void updateAxisRange​()
      当范围已经无效并且我们需要更新时，这被称为。

      • Methods inherited from class javafx.scene.chart.Chart

        animate, animatedProperty, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getAnimated, getChartChildren, getLegend, getLegendSide, getTitle, getTitleSide, isLegendVisible, layoutChildren, legendProperty, legendSideProperty, legendVisibleProperty, requestChartLayout, setAnimated, setLegend, setLegendSide, setLegendVisible, setTitle, setTitleSide, shouldAnimate, titleProperty, titleSideProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisibleProperty, alternativeRowFillVisibleProperty, currentDisplayedExtraValueProperty, currentDisplayedXValueProperty, currentDisplayedYValueProperty, dataProperty, getClassCssMetaData, getCssMetaData, getCurrentDisplayedExtraValue, getCurrentDisplayedXValue, getCurrentDisplayedYValue, getData, getDisplayedDataIterator, getDisplayedSeriesIterator, getPlotChildren, getVerticalGridLinesVisible, getXAxis, getYAxis, horizontalGridLinesVisibleProperty, horizontalZeroLineVisibleProperty, isAlternativeColumnFillVisible, isAlternativeRowFillVisible, isHorizontalGridLinesVisible, isHorizontalZeroLineVisible, isVerticalZeroLineVisible, layoutChartChildren, removeDataItemFromDisplay, removeSeriesFromDisplay, seriesChanged, setAlternativeColumnFillVisible, setAlternativeRowFillVisible, setCurrentDisplayedExtraValue, setCurrentDisplayedXValue, setCurrentDisplayedYValue, setData, setHorizontalGridLinesVisible, setHorizontalZeroLineVisible, setVerticalGridLinesVisible, setVerticalZeroLineVisible, updateLegend, verticalGridLinesVisibleProperty, verticalZeroLineVisibleProperty

    • 构造方法详细信息

      • BubbleChart

        public BubbleChart​(Axis<X> xAxis,
                   Axis<Y> yAxis)
        使用给定的轴构建一个新的BubbleChart。 BubbleChart不使用类别轴。 X轴和Y轴均应为NumberAxis型。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴

      • BubbleChart

        public BubbleChart​(Axis<X> xAxis,
                   Axis<Y> yAxis,
                   ObservableList<XYChart.Series<X,Y>> data)
        使用给定的轴和数据构建新的BubbleChart。 BubbleChart不使用类别轴。 X轴和Y轴均应为NumberAxis型。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中

    • 方法详细信息

      • layoutPlotChildren

        protected void layoutPlotChildren​()
        被要求更新和布局情节儿童。 这应该包括更新表示轴和网格线顶部的图的节点的所有工作。原点是绘图区域的左上角，绘制区域可以通过获取x轴的宽度及其高度从y轴的高度。
        Specified by:
        layoutPlotChildren在 XYChart<X,Y>

      • dataItemAdded

        protected void dataItemAdded​(XYChart.Series<X,Y> series,
                             int itemIndex,
                             XYChart.Data<X,Y> item)
        描述从类复制： XYChart
        将数据项添加到系列时调用。 这是XYChart的实现可以创建/添加新节点，以使getPlotChildren表示此数据项。 如果animated = true，他们也可以将数据添加为淡入淡出或相似。
        Specified by:
        dataItemAdded在 XYChart<X,Y>
        参数
        series - 数据项被添加到的系列
        itemIndex - 系列中新项目的索引
        item - 添加的新数据项

      • dataItemRemoved

        protected void dataItemRemoved​(XYChart.Data<X,Y> item,
                               XYChart.Series<X,Y> series)
        描述从类别复制XYChart
        当数据项已从数据模型中删除但在图表上仍然可见时调用。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeDataItemFromDisplay（）来删除项目节点不显示在图表上。
        Specified by:
        dataItemRemoved在 XYChart<X,Y>
        参数
        item - 从系列中删除的项目
        series - 该项目已被删除

      • dataItemChanged

        protected void dataItemChanged​(XYChart.Data<X,Y> item)
        数据项已更改时调用，即其xValue，yValue或extraValue已更改。
        Specified by:
        dataItemChanged在 XYChart<X,Y>
        参数
        item - 已更改的数据项

      • seriesAdded

        protected void seriesAdded​(XYChart.Series<X,Y> series,
                           int seriesIndex)
        描述从类别复制： XYChart
        一系列已经添加到图表数据模型中。 这是XYChart的实现可以创建/添加新的节点来getPlotChildren来表示这个系列。 此外，您必须处理添加已经在系列中的任何数据项。 您可以简单地为每一个调用dataItemAdded（），或为要添加的整个系列提供一些不同的动画。
        Specified by:
        seriesAdded在 XYChart<X,Y>
        参数
        series - 已添加的系列
        seriesIndex - 新系列的索引

      • seriesRemoved

        protected void seriesRemoved​(XYChart.Series<X,Y> series)
        描述从类别复制： XYChart
        数据模型中已经删除了一个系列，但它仍然可以在图表上显示。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeSeriesFromDisplay（）从显示列表中删除该系列。
        Specified by:
        seriesRemoved在 XYChart<X,Y>
        参数
        series - 已被删除的系列

      • updateAxisRange

        protected void updateAxisRange​()
        当范围已经无效并且我们需要更新时，这被称为。 如果轴是自动测距，那么我们编译给定轴必须绘制的所有数据的列表，并在传递该数据的轴上调用invalidateRange（）。
        重写：
        updateAxisRange在 XYChart<X,Y>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CategoryAxis (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class CategoryAxis

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Axis<String>
            • javafx.scene.chart.CategoryAxis
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public final class CategoryAxis
extends Axis<String>
    一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyDoubleProperty categorySpacing
      这是沿着这个轴线的一个类别和下一个类别之间的差距
      DoubleProperty endMargin
      最后一个刻度线与轴端之间的余量
      BooleanProperty gapStartAndEnd
      如果这是真的，那么刻度之间的一半空格留在开始和结束
      DoubleProperty startMargin
      轴开始和第一个刻度线之间的余量

      • Properties inherited from class javafx.scene.chart.Axis

        animated, autoRanging, label, side, tickLabelFill, tickLabelFont, tickLabelGap, tickLabelRotation, tickLabelsVisible, tickLength, tickMarkVisible

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.chart.Axis

        Axis.TickMark<T>

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      CategoryAxis​()
      创建一个具有空列表类别的自动范围类别轴。
      CategoryAxis​(ObservableList<String> categories)
      创建具有给定类别的类别轴。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Object autoRange​(double length)
      这将根据提供给invalidateRange（）方法的数据计算类别。
      protected List<String> calculateTickValues​(double length, Object range)
      计算范围内每个刻度线的所有数据值的列表
      ReadOnlyDoubleProperty categorySpacingProperty​()
      这是沿着这个轴线的一个类别和下一个类别之间的差距
      DoubleProperty endMarginProperty​()
      最后一个刻度线与轴端之间的余量
      BooleanProperty gapStartAndEndProperty​()
      如果这是真的，那么刻度之间的一半空格留在开始和结束
      ObservableList<String> getCategories​()
      返回在此轴上绘制的类别的ObservableList 。
      double getCategorySpacing​()
      获取属性categorySpacing的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      double getDisplayPosition​(String value)
      获取给定值的沿该轴的显示位置。
      double getEndMargin​()
      获取属性endMargin的值。
      protected Object getRange​()
      被称为获取当前的轴范围。
      double getStartMargin​()
      获取属性startMargin的值。
      protected String getTickMarkLabel​(String value)
      获取具有给定值的刻度线的字符串标签名称
      String getValueForDisplay​(double displayPosition)
      获取此轴上给定显示位置的数据值。
      double getZeroPosition​()
      获取沿该轴的零线的显示位置。
      void invalidateRange​(List<String> data)
      数据更改时调用，范围可能不再有效。
      boolean isGapStartAndEnd​()
      获取属性gapStartAndEnd的值。
      boolean isValueOnAxis​(String value)
      检查给定值是否在该轴上是可绘制的
      protected Dimension2D measureTickMarkSize​(String value, Object range)
      测量给定刻度标记值的标签尺寸。
      void setCategories​(ObservableList<String> value)
      在此轴上绘制的类别的有序列表。
      void setEndMargin​(double value)
      设置属性endMargin的值。
      void setGapStartAndEnd​(boolean value)
      设置属性gapStartAndEnd的值。
      protected void setRange​(Object range, boolean animate)
      调用将当前轴范围设置为给定范围。
      void setStartMargin​(double value)
      设置属性startMargin的值。
      DoubleProperty startMarginProperty​()
      轴开始和第一个刻度线之间的余量
      double toNumericValue​(String value)
      所有轴值必须由某些数值表示。
      String toRealValue​(double value)
      所有轴值必须由某些数值表示。

      • Methods inherited from class javafx.scene.chart.Axis

        animatedProperty, autoRangingProperty, computePrefHeight, computePrefWidth, getAnimated, getLabel, getSide, getTickLabelFill, getTickLabelFont, getTickLabelGap, getTickLabelRotation, getTickLength, getTickMarks, invalidateRange, isAutoRanging, isRangeValid, isTickLabelsVisible, isTickMarkVisible, labelProperty, layoutChildren, measureTickMarkLabelSize, measureTickMarkSize, requestAxisLayout, requestLayout, setAnimated, setAutoRanging, setLabel, setSide, setTickLabelFill, setTickLabelFont, setTickLabelGap, setTickLabelRotation, setTickLabelsVisible, setTickLength, setTickMarkVisible, shouldAnimate, sideProperty, tickLabelFillProperty, tickLabelFontProperty, tickLabelGapProperty, tickLabelRotationProperty, tickLabelsVisibleProperty, tickLengthProperty, tickMarksUpdated, tickMarkVisibleProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • startMargin

        public final DoubleProperty startMarginProperty
        轴开始和第一个刻度线之间的余量
        另请参见：
        getStartMargin() ， setStartMargin(double)

      • endMargin

        public final DoubleProperty endMarginProperty
        最后一个刻度线与轴端之间的余量
        另请参见：
        getEndMargin() ， setEndMargin(double)

      • gapStartAndEnd

        public final BooleanProperty gapStartAndEndProperty
        如果这是真的，那么刻度之间的一半空格留在开始和结束
        另请参见：
        isGapStartAndEnd() ， setGapStartAndEnd(boolean)

      • categorySpacing

        public final ReadOnlyDoubleProperty categorySpacingProperty
        这是沿着这个轴线的一个类别和下一个类别之间的差距
        另请参见：
        getCategorySpacing()

    • 构造方法详细信息

      • CategoryAxis

        public CategoryAxis​()
        创建一个具有空列表类别的自动范围类别轴。

      • CategoryAxis

        public CategoryAxis​(ObservableList<String> categories)
        创建具有给定类别的类别轴。 这不会是自动范围的，而是按照给定的类别进行修改。
        参数
        categories - 此轴的类别列表

    • 方法详细信息

      • getStartMargin

        public final double getStartMargin​()
        获取属性startMargin的值。
        Property description:
        轴开始和第一个刻度线之间的余量

      • setStartMargin

        public final void setStartMargin​(double value)
        设置属性startMargin的值。
        Property description:
        轴开始和第一个刻度线之间的余量

      • startMarginProperty

        public final DoubleProperty startMarginProperty​()
        轴开始和第一个刻度线之间的余量
        另请参见：
        getStartMargin() ， setStartMargin(double)

      • getEndMargin

        public final double getEndMargin​()
        获取属性endMargin的值。
        Property description:
        最后一个刻度线与轴端之间的余量

      • setEndMargin

        public final void setEndMargin​(double value)
        设置属性endMargin的值。
        Property description:
        最后一个刻度线与轴端之间的余量

      • endMarginProperty

        public final DoubleProperty endMarginProperty​()
        最后一个刻度线与轴端之间的余量
        另请参见：
        getEndMargin() ， setEndMargin(double)

      • isGapStartAndEnd

        public final boolean isGapStartAndEnd​()
        获取属性gapStartAndEnd的值。
        Property description:
        如果这是真的，那么刻度之间的一半空格留在开始和结束

      • setGapStartAndEnd

        public final void setGapStartAndEnd​(boolean value)
        设置属性gapStartAndEnd的值。
        Property description:
        如果这是真的，那么刻度之间的一半空格留在开始和结束

      • gapStartAndEndProperty

        public final BooleanProperty gapStartAndEndProperty​()
        如果这是真的，那么刻度之间的一半空格留在开始和结束
        另请参见：
        isGapStartAndEnd() ， setGapStartAndEnd(boolean)

      • setCategories

        public final void setCategories​(ObservableList<String> value)
        在此轴上绘制的类别的有序列表。 如果autoRanging为true，则会根据图表数据自动设置。 如果应用程序设置了类别，那么自动测距关闭。 如果尝试将重复条目添加到此列表中，则抛出一个IllegalArgumentException 。
        参数
        value - 在此轴上绘制的类别的有序列表

      • getCategories

        public final ObservableList<String> getCategories​()
        返回在该轴上绘制的类别的ObservableList 。
        结果
        ObservableList这个轴的类别列表。
        另请参见：
        categories

      • getCategorySpacing

        public final double getCategorySpacing​()
        获取属性categorySpacing的值。
        Property description:
        这是沿着这个轴线的一个类别和下一个类别之间的差距

      • categorySpacingProperty

        public final ReadOnlyDoubleProperty categorySpacingProperty​()
        这是沿着这个轴线的一个类别和下一个类别之间的差距
        另请参见：
        getCategorySpacing()

      • getRange

        protected Object getRange​()
        被称为获取当前的轴范围。
        Specified by:
        getRange在 Axis<String>
        结果
        可以传递给setRange（）和calculateTickValues（）的范围对象

      • setRange

        protected void setRange​(Object range,
                        boolean animate)
        调用将当前轴范围设置为给定范围。 如果isAnimating（）为true，那么此方法应将范围设置为新范围。
        Specified by:
        setRange中的 Axis<String>
        参数
        range - 从autoRange（）返回的范围对象
        animate - 如果真实的动画变化范围

      • autoRange

        protected Object autoRange​(double length)
        这将根据提供给invalidateRange（）方法的数据计算类别。 这不能影响轴的状态，改变轴的任何属性。 应在范围对象中返回自动范围的任何结果。 如果已决定为此轴采用此范围，我们将传递给setRange（）。
        Specified by:
        autoRange在 Axis<String>
        参数
        length - 屏幕坐标轴的长度
        结果
        范围信息，这是依赖于实现的

      • calculateTickValues

        protected List<String> calculateTickValues​(double length,
                                           Object range)
        计算范围内每个刻度线的所有数据值的列表
        Specified by:
        calculateTickValues在 Axis<String>
        参数
        length - 显示单位轴的长度
        range - 从autoRange（）返回的范围对象
        结果
        如果是给定长度，则可以沿轴线拟合的刻度线列表

      • getTickMarkLabel

        protected String getTickMarkLabel​(String value)
        获取具有给定值的刻度线的字符串标签名称
        Specified by:
        getTickMarkLabel在 Axis<String>
        参数
        value - 要格式化为刻度标签字符串的值
        结果
        给定值的格式化字符串

      • measureTickMarkSize

        protected Dimension2D measureTickMarkSize​(String value,
                                          Object range)
        测量给定刻度标记值的标签尺寸。 这使用为刻度线设置的字体
        重写：
        measureTickMarkSize在 Axis<String>
        参数
        value - 刻度值
        range - 计算期间使用的范围
        结果
        给定值的刻度标签的大小

      • invalidateRange

        public void invalidateRange​(List<String> data)
        数据更改时调用，范围可能不再有效。 如果isAutoRanging（）返回true，则仅由图表调用。 如果我们是自动测距，它将导致布局被请求，并且自动测距在下一个布局传递中发生。
        重写：
        invalidateRange在 Axis<String>
        参数
        data - 需要在此轴上绘制的所有数据的当前集合

      • getDisplayPosition

        public double getDisplayPosition​(String value)
        获取给定值的沿该轴的显示位置。 如果该值不等于任何类别，则返回Double.NaN
        Specified by:
        getDisplayPosition中的 Axis<String>
        参数
        value - 数据值计算显示位置
        结果
        显示位置或Double.NaN如果值不是其中一个类别

      • getValueForDisplay

        public String getValueForDisplay​(double displayPosition)
        获取此轴上给定显示位置的数据值。 如果轴是一个CategoryAxis，这将是最接近的值。
        Specified by:
        getValueForDisplay在 Axis<String>
        参数
        displayPosition - 此轴上的像素位置
        结果
        给定像素位置的最近数据值，如果不在轴上则为null;

      • isValueOnAxis

        public boolean isValueOnAxis​(String value)
        检查给定值是否在该轴上是可绘制的
        Specified by:
        isValueOnAxis在 Axis<String>
        参数
        value - 检查其轴上的值
        结果
        如果给定值在此轴上是可绘制的，则为true

      • toNumericValue

        public double toNumericValue​(String value)
        所有轴值必须由某些数值表示。 这将获取给定数据值的数值。
        Specified by:
        toNumericValue在 Axis<String>
        参数
        value - 要转换的数据值
        结果
        给定数据值的数值

      • toRealValue

        public String toRealValue​(double value)
        所有轴值必须由某些数值表示。 这将获取给定数值的数据值。
        Specified by:
        toRealValue在 Axis<String>
        参数
        value - 要转换的数值
        结果
        给定数值的数据值

      • getZeroPosition

        public double getZeroPosition​()
        获取沿该轴的零线的显示位置。 由于在类别Axis上没有零的概念，这总是Double.NaN。
        Specified by:
        getZeroPosition在 Axis<String>
        结果
        总是Double.NaN为CategoryAxis

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Axis<String>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Chart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class Chart

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    PieChart ， XYChart

    public abstract class Chart
extends Region
    所有图表的基础类。 它有3个部分的标题，图例和图表内容。 图表内容由图表的特定子类填充。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty animated
      当真的任何数据变化将被动画。
      protected ObjectProperty<Node> legend
      该节点显示为Legend。
      ObjectProperty<Side> legendSide
      图表侧面应显示图例
      BooleanProperty legendVisible
      当为true时，如果图表实现支持图例，图表将显示图例。
      StringProperty title
      图表标题
      ObjectProperty<Side> titleSide
      显示标题的图表侧

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Chart​()
      创建一个新的默认图表实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected void animate​(Animation animation)
      在动画完成后，在图形的每一帧上播放给定的动画图表。
      BooleanProperty animatedProperty​()
      当真的任何数据变化将被动画。
      protected double computeMinHeight​(double width)
      图表的大小在外，用户告诉图表，它有多少空间和图表在里面。
      protected double computeMinWidth​(double height)
      图表的大小在外，用户告诉图表，它有多少空间和图表在里面。
      protected double computePrefHeight​(double width)
      图表的大小在外，用户告诉图表，它有多少空间和图表在里面。
      protected double computePrefWidth​(double height)
      图表的大小在外，用户告诉图表，它有多少空间和图表在里面。
      boolean getAnimated​()
      指示数据更改是否将被动画化。
      protected ObservableList<Node> getChartChildren​()
      图表中所有内容的可修改和可观察的列表。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      protected Node getLegend​()
      获取属性图例的值。
      Side getLegendSide​()
      获取属性legendSide的值。
      String getTitle​()
      获取属性标题的值。
      Side getTitleSide​()
      获取属性titleSide的值。
      boolean isLegendVisible​()
      获取属性legendVisible的值。
      protected abstract void layoutChartChildren​(double top, double left, double width, double height)
      调用更新和布局从getChartChildren（）
      protected void layoutChildren​()
      在布局传递期间调用以布局此图表及其所有内容。
      protected ObjectProperty<Node> legendProperty​()
      该节点显示为Legend。
      ObjectProperty<Side> legendSideProperty​()
      图表侧面应显示图例
      BooleanProperty legendVisibleProperty​()
      当为true时，如果图表实现支持图例，图表将显示图例。
      protected void requestChartLayout​()
      当你知道某些事情发生了变化，需要将图表转发出来时，就会调用它。
      void setAnimated​(boolean value)
      设置动画属性的值。
      protected void setLegend​(Node value)
      设置属性图例的值。
      void setLegendSide​(Side value)
      设置属性legendSide的值。
      void setLegendVisible​(boolean value)
      设置属性legendVisible的值。
      void setTitle​(String value)
      设置属性标题的值。
      void setTitleSide​(Side value)
      设置属性titleSide的值。
      protected boolean shouldAnimate​()
      这是用来检查任何给定的动画是否应该运行。
      StringProperty titleProperty​()
      图表标题
      ObjectProperty<Side> titleSideProperty​()
      显示标题的图表侧

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • title

        public final StringProperty titleProperty
        图表标题
        另请参见：
        getTitle() ， setTitle(String)

      • titleSide

        public final ObjectProperty<Side> titleSideProperty
        显示标题的图表侧
        Default value:
        Side.TOP
        另请参见：
        getTitleSide() ， setTitleSide(Side)

      • legend

        protected final ObjectProperty<Node> legendProperty
        该节点显示为Legend。 子类可以在这里设置一个节点作为图例显示在一边。 如果没有图例，那么这可以设置为null
        另请参见：
        getLegend() ， setLegend(Node)

      • legendVisible

        public final BooleanProperty legendVisibleProperty
        当为true时，如果图表实现支持图例，图表将显示图例。
        另请参见：
        isLegendVisible() ， setLegendVisible(boolean)

      • legendSide

        public final ObjectProperty<Side> legendSideProperty
        图表侧面应显示图例
        Default value:
        Side.BOTTOM
        另请参见：
        getLegendSide() ， setLegendSide(Side)

      • animated

        public final BooleanProperty animatedProperty
        当真的任何数据变化将被动画。
        另请参见：
        getAnimated() ， setAnimated(boolean)

    • 构造方法详细信息

      • Chart

        public Chart​()
        创建一个新的默认图表实例。

    • 方法详细信息

      • getTitle

        public final String getTitle​()
        获取属性标题的值。
        Property description:
        图表标题

      • setTitle

        public final void setTitle​(String value)
        设置属性标题的值。
        Property description:
        图表标题

      • titleProperty

        public final StringProperty titleProperty​()
        图表标题
        另请参见：
        getTitle() ， setTitle(String)

      • getTitleSide

        public final Side getTitleSide​()
        获取属性titleSide的值。
        Property description:
        显示标题的图表侧
        Default value:
        Side.TOP

      • setTitleSide

        public final void setTitleSide​(Side value)
        设置属性titleSide的值。
        Property description:
        显示标题的图表侧
        Default value:
        Side.TOP

      • titleSideProperty

        public final ObjectProperty<Side> titleSideProperty​()
        显示标题的图表侧
        Default value:
        Side.TOP
        另请参见：
        getTitleSide() ， setTitleSide(Side)

      • getLegend

        protected final Node getLegend​()
        获取属性图例的值。
        Property description:
        该节点显示为Legend。 子类可以在这里设置一个节点作为图例显示在一边。 如果没有图例，那么这可以设置为null

      • setLegend

        protected final void setLegend​(Node value)
        设置属性图例的值。
        Property description:
        该节点显示为Legend。 子类可以在这里设置一个节点作为图例显示在一边。 如果没有图例，那么这可以设置为null

      • legendProperty

        protected final ObjectProperty<Node> legendProperty​()
        该节点显示为Legend。 子类可以在这里设置一个节点作为图例显示在一边。 如果没有图例，那么这可以设置为null
        另请参见：
        getLegend() ， setLegend(Node)

      • isLegendVisible

        public final boolean isLegendVisible​()
        获取属性legendVisible的值。
        Property description:
        当为true时，如果图表实现支持图例，图表将显示图例。

      • setLegendVisible

        public final void setLegendVisible​(boolean value)
        设置属性legendVisible的值。
        Property description:
        当为true时，如果图表实现支持图例，图表将显示图例。

      • legendVisibleProperty

        public final BooleanProperty legendVisibleProperty​()
        当为true时，如果图表实现支持图例，图表将显示图例。
        另请参见：
        isLegendVisible() ， setLegendVisible(boolean)

      • getLegendSide

        public final Side getLegendSide​()
        获取属性legendSide的值。
        Property description:
        图表侧面应显示图例
        Default value:
        Side.BOTTOM

      • setLegendSide

        public final void setLegendSide​(Side value)
        设置属性legendSide的值。
        Property description:
        图表侧面应显示图例
        Default value:
        Side.BOTTOM

      • legendSideProperty

        public final ObjectProperty<Side> legendSideProperty​()
        图表侧面应显示图例
        Default value:
        Side.BOTTOM
        另请参见：
        getLegendSide() ， setLegendSide(Side)

      • getAnimated

        public final boolean getAnimated​()
        指示数据更改是否将被动画化。
        结果
        如果数据更改将被动画化，否则为false。

      • setAnimated

        public final void setAnimated​(boolean value)
        设置动画属性的值。
        Property description:
        当真的任何数据变化将被动画。

      • animatedProperty

        public final BooleanProperty animatedProperty​()
        当真的任何数据变化将被动画。
        另请参见：
        getAnimated() ， setAnimated(boolean)

      • getChartChildren

        protected ObservableList<Node> getChartChildren​()
        图表中所有内容的可修改和可观察的列表。 这就是Chart的实现应该添加任何用来绘制图表的节点。 这不包括这个课程照顾的传说和标题。
        结果
        可观察的情节儿童列表

      • animate

        protected void animate​(Animation animation)
        在动画完成后，在图形的每一帧上播放给定的动画图表。 因此，为了向图表添加动画，请在数据模型上创建一个动画，然后在layoutChartContent（）映射数据模型中创建动画，然后使用动画调用此方法。
        参数
        animation - 要玩的动画

      • requestChartLayout

        protected void requestChartLayout​()
        当你知道某些事情发生了变化，需要将图表转发出来时，就会调用它。

      • shouldAnimate

        protected final boolean shouldAnimate​()
        这是用来检查任何给定的动画是否应该运行。 如果启用了动画并且节点在可见的场景中，则返回true。
        结果
        如果启用动画并且节点可见并且在场景中，则为true

      • layoutChartChildren

        protected abstract void layoutChartChildren​(double top,
                                            double left,
                                            double width,
                                            double height)
        调用更新和布局从getChartChildren（）
        参数
        top - 从原始位置的顶部偏移量来计算图表内容上的任何填充
        left - 从原点向左偏移以计算图表内容上的任何填充
        width - 布局图表的区域的宽度
        height - 布局图表的区域的高度

      • layoutChildren

        protected void layoutChildren​()
        在布局传递期间调用以布局此图表及其所有内容。
        重写：
        layoutChildren在 Parent

      • computeMinHeight

        protected double computeMinHeight​(double width)
        图表的大小在外，用户告诉图表，它有多少空间和图表在里面。 所以最小高度是一个常数150。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computeMinWidth

        protected double computeMinWidth​(double height)
        图表的大小在外，用户告诉图表，它有多少空间和图表在里面。 所以最小宽度是一个常数200。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        计算出该区域的最小宽度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        图表的大小在外，用户告诉图表，它有多少空间和图表在里面。 所以优选的宽度是500。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        图表的大小在外，用户告诉图表，它有多少空间和图表在里面。 所以优选的高度是一个常数400。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.chart (Java SE 9 & JDK 9 )

javafx.scene.chart

Classes

  • AreaChart
  • Axis
  • Axis.TickMark
  • BarChart
  • BubbleChart
  • CategoryAxis
  • Chart
  • LineChart
  • NumberAxis
  • NumberAxis.DefaultFormatter
  • PieChart
  • PieChart.Data
  • ScatterChart
  • StackedAreaChart
  • StackedBarChart
  • ValueAxis
  • XYChart
  • XYChart.Data
  • XYChart.Series

Enums

  • LineChart.SortingPolicy


javafx.scene.chart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.controls

Package javafx.scene.chart

JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。 应用程序开发人员可以利用JavaFX运行时提供的这些脱机图形图表来显示各种各样的数据。

常见合类型的图表如Bar ， Line ， Area ， Pie ， Scatter和Bubble个设置图表。 这些图表很容易创建，可定制。 JavaFX图表API是以视觉为中心的API，而不是以模型为中心。

JavaFX图表支持图表组件的动画以及图表轴的自动测距。 此外，与其他JavaFX UI控件一样，图表可视化组件可以通过CSS进行风格化。 因此，有几种公共的视觉属性可以通过CSS风格。 稍后在文档中提供一个示例。

以下是列出现有图表类型的表格及其预期用途的简要摘要。

Table of Chart Types

Chart

Summary

LineChart

Plots line between the data points in a series. Used usually to view data trends over time.

AreaChart

Plots the area between the line that connects the data points and the axis. Good for comparing cumulated totals over time.

BarChart

Plots rectangular bars with heights indicating data values they represent, and corresponding to the categories they belongs to. Used for displaying discontinuous / discrete data

PieChart

Plots circular chart divided into segments with each segment representing a value as a proportion of the total. It looks like a Pie and hence the name

BubbleChart

Plots bubbles for data points in a series. Each plotted entity depicts three parameters in a 2D chart and hence a unique chart type.

ScatterChart

Plots symbols for the data points in a series. This type of chart is useful in viewing distribution of data and its corelation, if there is any clustering.

Chart是所有图表的基础。 它负责绘制背景，框架，标题和图例。 它可以扩展到创建自定义图表类型。 XYChart是所有两个轴图的基础类，它从Chart类扩展。 它主要负责绘制图表的两个轴和背景。 大多数图表从XYChart类展开，除了从Chart类扩展的PieChart，它不是双轴图。

javafx.scene.chart软件包包括在创建两个轴图时可以使用的轴类 。 Axis是所有图表轴的抽象基类。 CategoryAxis绘制字符串类别，其中每个值是沿轴的唯一类别。 NumberAxis绘制每个tickUnit的主要刻度线的数字范围。

例如BarChart绘制XYChart.Series对象序列中的数据。 每个系列包含XYChart.Data个对象。

   // add data XYChart.Series<String,Number> series1 = new XYChart.Series<String,Number>(); series1.setName("Data Series 1"); series1.getData().add(new XYChart.Data<String,Number>("2007", 567));

我们可以同样定义更多的系列对象。 以下代码片段显示如何创建具有3个类别及其X和Y轴的BarChart：

   static String[] years = {"2007", "2008", "2009"}; final CategoryAxis xAxis = new CategoryAxis(); final NumberAxis yAxis = new NumberAxis(); final BarChart<String,Number> bc = new BarChart<String,Number>(xAxis, yAxis); xAxis.setCategories(FXCollections.<String>observableArrayList(Arrays.asList(years))); bc.getData().addAll(series1, series2, series3);

JavaFX图表适用于实时数据集中的实时或动态图表（如在线股票，网络流量等）。 以下是使用模拟数据创建的动态图表的示例。 A Timeline用于模拟随时间（小时）的股价变动的动态数据。

   private XYChart.Series<Number,Number> hourDataSeries; private NumberAxis xAxis; private Timeline animation; private double hours = 0; private double timeInHours = 0; private double prevY = 10; private double y = 10; // timeline to add new data every 60th of a second animation = new Timeline(); animation.getKeyFrames().add(new KeyFrame(Duration.millis(1000 / 60), new EventHandler<ActionEvent>() { @Override public void handle(ActionEvent actionEvent) { // 6 minutes data per frame for(int count = 0; count < 6; count++) { nextTime(); plotTime(); } } })); animation.setCycleCount(Animation.INDEFINITE); xAxis = new NumberAxis(0, 24, 3); final NumberAxis yAxis = new NumberAxis(0, 100, 10); final LineChart<Number,Number> lc = new LineChart<Number,Number>(xAxis, yAxis); lc.setCreateSymbols(false); lc.setAnimated(false); lc.setLegendVisible(false); lc.setTitle("ACME Company Stock"); xAxis.setLabel("Time"); xAxis.setForceZeroInRange(false); yAxis.setLabel("Share Price"); yAxis.setTickLabelFormatter(new NumberAxis.DefaultFormatter(yAxis, "$", null)); hourDataSeries = new XYChart.Series<Number,Number>(); hourDataSeries.setName("Hourly Data"); hourDataSeries.getData().add(new XYChart.Data<Number,Number>(timeInHours, prevY)); lc.getData().add(hourDataSeries); private void nextTime() { if (minutes == 59) { hours++; minutes = 0; } else { minutes++; } timeInHours = hours + ((1d/60d) * minutes); } private void plotTime() { if ((timeInHours % 1) == 0) { // change of hour double oldY = y; y = prevY - 10 + (Math.random() * 20); prevY = oldY; while (y < 10 || y > 90) y = y - 10 + (Math.random() * 20); hourDataSeries.getData().add(new XYChart.Data<Number, Number>(timeInHours, prevY)); // after 25hours delete old data if (timeInHours > 25) hourDataSeries.getData().remove(0); // every hour after 24 move range 1 hour if (timeInHours > 24) { xAxis.setLowerBound(xAxis.getLowerBound() + 1); xAxis.setUpperBound(xAxis.getUpperBound() + 1); } } }

start方法需要调用动画，.play（）来启动模拟动态图。

请参阅关于CSS样式的javafx.scene.control包文档。 通过CSS样式化图表的示例如下： - 将图表内容背景设置为某种颜色：

.chart-content {-fx-background-color：cyan;}

线条线颜色可以设置如下： -

.chart-series-line {-fx-stroke：green; -fx-stroke-width：4px;}

  • 类摘要
    Class 描述
    AreaChart<X,Y>
    AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
    Axis<T>
    JavaFX中所有轴的基类，表示在图表区域上绘制的轴。
    Axis.TickMark<T>
    TickMark代表标签文本，它与Axis的每个刻度相关联的属性。
    BarChart<X,Y>
    绘制一个指示类别数据值的条形图。
    BubbleChart<X,Y>
    为一系列数据点绘制气泡的图表类型。
    CategoryAxis
    一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。
    Chart
    所有图表的基础类。
    LineChart<X,Y>
    线图绘制了连接数据点的行。
    NumberAxis
    一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
    NumberAxis.DefaultFormatter
    NumberAxis的默认数字格式化程序，与自动量程保持同步，并适当地格式化值。
    PieChart
    显示PieChart。
    PieChart.Data
    PieChart数据项，表示PieChart中的一个切片
    ScatterChart<X,Y>
    绘制一系列数据点符号的图表类型。
    StackedAreaChart<X,Y>
    StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。
    StackedBarChart<X,Y>
    StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。
    ValueAxis<T extends Number>
    数据定义为数字的轴。
    XYChart<X,Y>
    所有2轴图的图表基类。
    XYChart.Data<X,Y>
    具有2轴图数据的单个数据项
    XYChart.Series<X,Y>
    一系列命名的数据项
  • 枚举摘要
    Enum 描述
    LineChart.SortingPolicy
    此枚举定义了一个 LineChart.axisSortingPolicyProperty()的策略。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.chart Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.chart

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.chart.Axis.TickMark<T>
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Axis<T>
            • javafx.scene.chart.CategoryAxis
            • javafx.scene.chart.ValueAxis<T>
              • javafx.scene.chart.NumberAxis
          • javafx.scene.chart.Chart
            • javafx.scene.chart.PieChart
            • javafx.scene.chart.XYChart<X,Y>
              • javafx.scene.chart.AreaChart<X,Y>
              • javafx.scene.chart.BarChart<X,Y>
              • javafx.scene.chart.BubbleChart<X,Y>
              • javafx.scene.chart.LineChart<X,Y>
              • javafx.scene.chart.ScatterChart<X,Y>
              • javafx.scene.chart.StackedAreaChart<X,Y>
              • javafx.scene.chart.StackedBarChart<X,Y>
    • javafx.scene.chart.PieChart.Data
    • javafx.util.StringConverter<T>
      • javafx.scene.chart.NumberAxis.DefaultFormatter
    • javafx.scene.chart.XYChart.Data<X,Y>
    • javafx.scene.chart.XYChart.Series<X,Y>

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.chart.LineChart.SortingPolicy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LineChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class LineChart<X,Y>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
            • javafx.scene.chart.XYChart<X,Y>
              • javafx.scene.chart.LineChart<X,Y>
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class LineChart<X,Y>
extends XYChart<X,Y>
    线图绘制了连接数据点的行。 数据点本身可以由符号可选地表示。 线图通常用于查看随时间或类别的数据趋势。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<LineChart.SortingPolicy> axisSortingPolicy
      指示传递给LineChart的数据是否应按其中一个轴的自然顺序进行排序。
      BooleanProperty createSymbols
      当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。

      • Properties inherited from class javafx.scene.chart.Chart

        animated, legend, legendSide, legendVisible, title, titleSide

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisible, alternativeRowFillVisible, data, horizontalGridLinesVisible, horizontalZeroLineVisible, verticalGridLinesVisible, verticalZeroLineVisible

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  LineChart.SortingPolicy
      此枚举定义了一个 axisSortingPolicyProperty()的策略。

      • Nested classes/interfaces inherited from class javafx.scene.chart.XYChart

        XYChart.Data<X,Y>, XYChart.Series<X,Y>

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定的轴构造一个新的LineChart。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的LineChart。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<LineChart.SortingPolicy> axisSortingPolicyProperty​()
      指示传递给LineChart的数据是否应按其中一个轴的自然顺序进行排序。
      BooleanProperty createSymbolsProperty​()
      当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
      protected void dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      LineChart.SortingPolicy getAxisSortingPolicy​()
      获取属性axisSortingPolicy的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      boolean getCreateSymbols​()
      指示是否创建数据点的符号。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      protected void layoutPlotChildren​()
      被要求更新和布局情节儿童。
      protected void seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      当将每个原子更改作为此图表的系列列表时调用
      protected void seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。
      void setAxisSortingPolicy​(LineChart.SortingPolicy value)
      设置属性axisSortingPolicy的值。
      void setCreateSymbols​(boolean value)
      设置属性createSymbols的值。
      protected void updateAxisRange​()
      当范围已经无效并且我们需要更新时，这被称为。

      • Methods inherited from class javafx.scene.chart.Chart

        animate, animatedProperty, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getAnimated, getChartChildren, getLegend, getLegendSide, getTitle, getTitleSide, isLegendVisible, layoutChildren, legendProperty, legendSideProperty, legendVisibleProperty, requestChartLayout, setAnimated, setLegend, setLegendSide, setLegendVisible, setTitle, setTitleSide, shouldAnimate, titleProperty, titleSideProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisibleProperty, alternativeRowFillVisibleProperty, currentDisplayedExtraValueProperty, currentDisplayedXValueProperty, currentDisplayedYValueProperty, dataProperty, getCurrentDisplayedExtraValue, getCurrentDisplayedXValue, getCurrentDisplayedYValue, getData, getDisplayedDataIterator, getDisplayedSeriesIterator, getPlotChildren, getVerticalGridLinesVisible, getXAxis, getYAxis, horizontalGridLinesVisibleProperty, horizontalZeroLineVisibleProperty, isAlternativeColumnFillVisible, isAlternativeRowFillVisible, isHorizontalGridLinesVisible, isHorizontalZeroLineVisible, isVerticalZeroLineVisible, layoutChartChildren, removeDataItemFromDisplay, removeSeriesFromDisplay, setAlternativeColumnFillVisible, setAlternativeRowFillVisible, setCurrentDisplayedExtraValue, setCurrentDisplayedXValue, setCurrentDisplayedYValue, setData, setHorizontalGridLinesVisible, setHorizontalZeroLineVisible, setVerticalGridLinesVisible, setVerticalZeroLineVisible, updateLegend, verticalGridLinesVisibleProperty, verticalZeroLineVisibleProperty

    • Property Detail

      • createSymbols

        public final BooleanProperty createSymbolsProperty
        当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
        另请参见：
        getCreateSymbols() ， setCreateSymbols(boolean)

      • axisSortingPolicy

        public final ObjectProperty<LineChart.SortingPolicy> axisSortingPolicyProperty
        指示传递给LineChart的数据是否应按其中一个轴的自然顺序进行排序。 如果设置为LineChart.SortingPolicy.NONE ，顺序XYChart.dataProperty()将被使用。
        Default value:
        SortingPolicy＃X_AXIS
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAxisSortingPolicy() ， setAxisSortingPolicy(LineChart.SortingPolicy)

    • 构造方法详细信息

      • LineChart

        public LineChart​(Axis<X> xAxis,
                 Axis<Y> yAxis)
        用给定的轴构造一个新的LineChart。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴

      • LineChart

        public LineChart​(Axis<X> xAxis,
                 Axis<Y> yAxis,
                 ObservableList<XYChart.Series<X,Y>> data)
        使用给定的轴和数据构造一个新的LineChart。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中

    • 方法详细信息

      • getCreateSymbols

        public final boolean getCreateSymbols​()
        指示是否创建数据点的符号。
        结果
        如果将创建数据点的符号，则为true，否则为false。

      • setCreateSymbols

        public final void setCreateSymbols​(boolean value)
        设置属性createSymbols的值。
        Property description:
        当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。

      • createSymbolsProperty

        public final BooleanProperty createSymbolsProperty​()
        当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
        另请参见：
        getCreateSymbols() ， setCreateSymbols(boolean)

      • getAxisSortingPolicy

        public final LineChart.SortingPolicy getAxisSortingPolicy​()
        获取属性axisSortingPolicy的值。
        Property description:
        指示传递给LineChart的数据是否应按其中一个轴的自然顺序进行排序。 如果设置为LineChart.SortingPolicy.NONE ，顺序XYChart.dataProperty()将被使用。
        Default value:
        SortingPolicy＃X_AXIS
        从以下版本开始：
        JavaFX 8u40

      • setAxisSortingPolicy

        public final void setAxisSortingPolicy​(LineChart.SortingPolicy value)
        设置属性axisSortingPolicy的值。
        Property description:
        指示传递给LineChart的数据是否应按其中一个轴的自然顺序进行排序。 如果设置为LineChart.SortingPolicy.NONE ，顺序XYChart.dataProperty()将被使用。
        Default value:
        SortingPolicy＃X_AXIS
        从以下版本开始：
        JavaFX 8u40

      • axisSortingPolicyProperty

        public final ObjectProperty<LineChart.SortingPolicy> axisSortingPolicyProperty​()
        指示传递给LineChart的数据是否应按其中一个轴的自然顺序进行排序。 如果设置为LineChart.SortingPolicy.NONE ，顺序XYChart.dataProperty()将被使用。
        Default value:
        SortingPolicy＃X_AXIS
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getAxisSortingPolicy() ， setAxisSortingPolicy(LineChart.SortingPolicy)

      • updateAxisRange

        protected void updateAxisRange​()
        当范围已经无效并且我们需要更新时，这被称为。 如果轴是自动测距，那么我们编译给定轴必须绘制的所有数据的列表，并在传递该数据的轴上调用invalidateRange（）。
        重写：
        updateAxisRange在 XYChart<X,Y>

      • dataItemAdded

        protected void dataItemAdded​(XYChart.Series<X,Y> series,
                             int itemIndex,
                             XYChart.Data<X,Y> item)
        说明从类别复制： XYChart
        将数据项添加到系列时调用。 这是XYChart的实现可以创建/添加新节点，以使getPlotChildren表示此数据项。 如果animated = true，他们也可以将数据添加为淡入淡出或相似。
        Specified by:
        dataItemAdded在 XYChart<X,Y>
        参数
        series - 添加到数据项的系列
        itemIndex - 系列中新项目的索引
        item - 添加的新数据项

      • dataItemRemoved

        protected void dataItemRemoved​(XYChart.Data<X,Y> item,
                               XYChart.Series<X,Y> series)
        描述从类别复制： XYChart
        当数据项已从数据模型中删除但在图表上仍然可见时调用。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeDataItemFromDisplay（）来删除项目节点不显示在图表上。
        Specified by:
        dataItemRemoved在 XYChart<X,Y>
        参数
        item - 从系列中删除的项目
        series - 该项目已被删除

      • dataItemChanged

        protected void dataItemChanged​(XYChart.Data<X,Y> item)
        数据项已更改时调用，即其xValue，yValue或extraValue已更改。
        Specified by:
        dataItemChanged在 XYChart<X,Y>
        参数
        item - 已更改的数据项

      • seriesChanged

        protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
        描述从类别复制： XYChart
        当将每个原子更改作为此图表的系列列表时调用
        重写：
        seriesChanged在 XYChart<X,Y>
        参数
        c - 表示系列更改的更改实例

      • seriesAdded

        protected void seriesAdded​(XYChart.Series<X,Y> series,
                           int seriesIndex)
        描述从类别复制： XYChart
        一系列已经添加到图表数据模型中。 这是XYChart的实现可以创建/添加新的节点来getPlotChildren来表示这个系列。 此外，您必须处理添加已经在系列中的任何数据项。 您可以简单地为每一个调用dataItemAdded（），或为要添加的整个系列提供一些不同的动画。
        Specified by:
        seriesAdded在 XYChart<X,Y>
        参数
        series - 已添加的系列
        seriesIndex - 新系列的索引

      • seriesRemoved

        protected void seriesRemoved​(XYChart.Series<X,Y> series)
        描述从类别复制： XYChart
        数据模型中已经删除了一个系列，但它仍然可以在图表上显示。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeSeriesFromDisplay（）从显示列表中删除该系列。
        Specified by:
        seriesRemoved在 XYChart<X,Y>
        参数
        series - 已被删除的系列

      • layoutPlotChildren

        protected void layoutPlotChildren​()
        被要求更新和布局情节儿童。 这应该包括更新表示轴和网格线顶部的图的节点的所有工作。原点是绘图区域的左上角，绘制区域可以通过获取x轴的宽度及其高度从y轴的高度。
        Specified by:
        layoutPlotChildren在 XYChart<X,Y>

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 XYChart<X,Y>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LineChart.SortingPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Enum LineChart.SortingPolicy

  • java.lang.Object
    • java.lang.Enum<LineChart.SortingPolicy>
      • javafx.scene.chart.LineChart.SortingPolicy
  • All Implemented Interfaces:
    Serializable ， Comparable<LineChart.SortingPolicy>
    Enclosing class:
    LineChart < X ， Y >

    public static enum LineChart.SortingPolicy
extends Enum<LineChart.SortingPolicy>
    此枚举定义了一个 LineChart.axisSortingPolicyProperty()的策略。
    从以下版本开始：
    JavaFX 8u40

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NONE
      数据应按 XYChart.dataProperty()中的列表定义的顺序 保留 。
      X_AXIS
      数据按x轴排序。
      Y_AXIS
      数据按y轴排序。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static LineChart.SortingPolicy valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static LineChart.SortingPolicy[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NONE

        public static final LineChart.SortingPolicy NONE
        数据应按 XYChart.dataProperty()中的列表定义的顺序 保留 。

      • X_AXIS

        public static final LineChart.SortingPolicy X_AXIS
        数据按x轴排序。

      • Y_AXIS

        public static final LineChart.SortingPolicy Y_AXIS
        数据按y轴排序。

    • 方法详细信息

      • values

        public static LineChart.SortingPolicy[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (LineChart.SortingPolicy c : LineChart.SortingPolicy.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static LineChart.SortingPolicy valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


NumberAxis (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class NumberAxis

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Axis<T>
            • javafx.scene.chart.ValueAxis<Number>
              • javafx.scene.chart.NumberAxis
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public final class NumberAxis
extends ValueAxis<Number>
    一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。 您可以使用此轴的任何数字类型。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty forceZeroInRange
      当真实零值始终包含在可见范围内时。
      DoubleProperty tickUnit
      数据单位中每个主要刻度线之间的值。

      • Properties inherited from class javafx.scene.chart.Axis

        animated, autoRanging, label, side, tickLabelFill, tickLabelFont, tickLabelGap, tickLabelRotation, tickLabelsVisible, tickLength, tickMarkVisible

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.chart.ValueAxis

        lowerBound, minorTickCount, minorTickLength, minorTickVisible, scale, tickLabelFormatter, upperBound

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  NumberAxis.DefaultFormatter
      NumberAxis的默认数字格式化程序，与自动量程保持同步，并适当地格式化值。

      • Nested classes/interfaces inherited from class javafx.scene.chart.Axis

        Axis.TickMark<T>

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

      • Fields inherited from class javafx.scene.chart.ValueAxis

        currentLowerBound

    • 构造方法摘要

      构造方法
      Constructor 描述
      NumberAxis​()
      创建自动范围NumberAxis。
      NumberAxis​(double lowerBound, double upperBound, double tickUnit)
      使用给定的上限，下限和滴答单位创建非自动范围的NumberAxis。
      NumberAxis​(String axisLabel, double lowerBound, double upperBound, double tickUnit)
      用给定的下限，上限和滴答单位创建非自动范围的NumberAxis。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Object autoRange​(double minValue, double maxValue, double length, double labelSize)
      被要求设置上限和下限以及需要自动调整的任何其他内容。
      protected List<Number> calculateMinorTickMarks​()
      计算每个小刻度线的数据值列表
      protected List<Number> calculateTickValues​(double length, Object range)
      计算范围内每个刻度线的所有数据值的列表
      BooleanProperty forceZeroInRangeProperty​()
      当真实零值始终包含在可见范围内时。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      protected Object getRange​()
      被称为获取当前的轴范围。
      protected String getTickMarkLabel​(Number value)
      获取具有给定值的刻度线的字符串标签名称。
      double getTickUnit​()
      获取属性tickUnit的值。
      boolean isForceZeroInRange​()
      获取属性forceZeroInRange的值。
      protected Dimension2D measureTickMarkSize​(Number value, Object range)
      测量给定刻度标记值的标签尺寸。
      void setForceZeroInRange​(boolean value)
      设置属性forceZeroInRange的值。
      protected void setRange​(Object range, boolean animate)
      调用将当前轴范围设置为给定范围。
      void setTickUnit​(double value)
      设置属性tickUnit的值。
      DoubleProperty tickUnitProperty​()
      数据单位中每个主要刻度线之间的值。

      • Methods inherited from class javafx.scene.chart.Axis

        animatedProperty, autoRangingProperty, computePrefHeight, computePrefWidth, getAnimated, getLabel, getSide, getTickLabelFill, getTickLabelFont, getTickLabelGap, getTickLabelRotation, getTickLength, getTickMarks, invalidateRange, isAutoRanging, isRangeValid, isTickLabelsVisible, isTickMarkVisible, labelProperty, measureTickMarkLabelSize, measureTickMarkSize, requestAxisLayout, requestLayout, setAnimated, setAutoRanging, setLabel, setSide, setTickLabelFill, setTickLabelFont, setTickLabelGap, setTickLabelRotation, setTickLabelsVisible, setTickLength, setTickMarkVisible, shouldAnimate, sideProperty, tickLabelFillProperty, tickLabelFontProperty, tickLabelGapProperty, tickLabelRotationProperty, tickLabelsVisibleProperty, tickLengthProperty, tickMarkVisibleProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.chart.ValueAxis

        autoRange, calculateNewScale, getDisplayPosition, getLowerBound, getMinorTickCount, getMinorTickLength, getScale, getTickLabelFormatter, getUpperBound, getValueForDisplay, getZeroPosition, invalidateRange, isMinorTickVisible, isValueOnAxis, layoutChildren, lowerBoundProperty, minorTickCountProperty, minorTickLengthProperty, minorTickVisibleProperty, scaleProperty, setLowerBound, setMinorTickCount, setMinorTickLength, setMinorTickVisible, setScale, setTickLabelFormatter, setUpperBound, tickLabelFormatterProperty, tickMarksUpdated, toNumericValue, toRealValue, upperBoundProperty

    • Property Detail

      • forceZeroInRange

        public final BooleanProperty forceZeroInRangeProperty
        当真实零值始终包含在可见范围内时。 这只有在自动量程打开时才有效果。
        另请参见：
        isForceZeroInRange() ， setForceZeroInRange(boolean)

      • tickUnit

        public final DoubleProperty tickUnitProperty
        数据单位中每个主要刻度线之间的值。 如果我们是自动量程，这是自动设置的。
        另请参见：
        getTickUnit() ， setTickUnit(double)

    • 构造方法详细信息

      • NumberAxis

        public NumberAxis​()
        创建自动范围NumberAxis。

      • NumberAxis

        public NumberAxis​(double lowerBound,
                  double upperBound,
                  double tickUnit)
        使用给定的上限，下限和滴答单位创建非自动范围的NumberAxis。
        参数
        lowerBound - 该轴的下限，即最小可绘图值
        upperBound - 该轴的上限，即最大可绘图值
        tickUnit - 刻度单位，即刻度之间的空格

      • NumberAxis

        public NumberAxis​(String axisLabel,
                  double lowerBound,
                  double upperBound,
                  double tickUnit)
        用给定的下限，上限和滴答单位创建非自动范围的NumberAxis。
        参数
        axisLabel - 要显示此轴的名称
        lowerBound - 该轴的下限，即最小可绘图值
        upperBound - 此轴的上限，即最大可绘图值
        tickUnit - 刻度单位，即刻度之间的空格

    • 方法详细信息

      • isForceZeroInRange

        public final boolean isForceZeroInRange​()
        获取属性forceZeroInRange的值。
        Property description:
        当真实零值始终包含在可见范围内时。 这只有在自动量程打开时才有效果。

      • setForceZeroInRange

        public final void setForceZeroInRange​(boolean value)
        设置属性forceZeroInRange的值。
        Property description:
        当真实零值始终包含在可见范围内时。 这只有在自动量程打开时才有效果。

      • forceZeroInRangeProperty

        public final BooleanProperty forceZeroInRangeProperty​()
        当真实零值始终包含在可见范围内时。 这只有在自动量程打开时才有效果。
        另请参见：
        isForceZeroInRange() ， setForceZeroInRange(boolean)

      • getTickUnit

        public final double getTickUnit​()
        获取属性tickUnit的值。
        Property description:
        数据单位中每个主要刻度线之间的值。 如果我们是自动量程，这是自动设置的。

      • setTickUnit

        public final void setTickUnit​(double value)
        设置属性tickUnit的值。
        Property description:
        数据单位中每个主要刻度线之间的值。 如果我们是自动量程，这是自动设置的。

      • tickUnitProperty

        public final DoubleProperty tickUnitProperty​()
        数据单位中每个主要刻度线之间的值。 如果我们是自动量程，这是自动设置的。
        另请参见：
        getTickUnit() ， setTickUnit(double)

      • getTickMarkLabel

        protected String getTickMarkLabel​(Number value)
        获取具有给定值的刻度线的字符串标签名称。
        Specified by:
        getTickMarkLabel在 Axis<Number>
        参数
        value - 要格式化为刻度标签字符串的值
        结果
        给定值的格式化字符串

      • getRange

        protected Object getRange​()
        被称为获取当前的轴范围。
        Specified by:
        getRange在 Axis<Number>
        结果
        可以传递给setRange（）和calculateTickValues（）的范围对象

      • setRange

        protected void setRange​(Object range,
                        boolean animate)
        调用将当前轴范围设置为给定范围。 如果isAnimating（）为true，那么此方法应将范围设置为新范围。
        Specified by:
        setRange在 Axis<Number>
        参数
        range - 从autoRange（）返回的范围对象
        animate - 如果真的动画变化范围

      • calculateTickValues

        protected List<Number> calculateTickValues​(double length,
                                           Object range)
        计算范围内每个刻度线的所有数据值的列表
        Specified by:
        calculateTickValues在 Axis<Number>
        参数
        length - 显示单位中轴的长度
        range - 从autoRange（）返回的范围对象
        结果
        如果是给定长度，则可以沿轴线拟合的刻度线列表

      • calculateMinorTickMarks

        protected List<Number> calculateMinorTickMarks​()
        计算每个小刻度线的数据值列表
        Specified by:
        calculateMinorTickMarks在 ValueAxis<Number>
        结果
        数据值列表，用于绘制小刻度线

      • measureTickMarkSize

        protected Dimension2D measureTickMarkSize​(Number value,
                                          Object range)
        测量给定刻度标记值的标签尺寸。 这使用为刻度线设置的字体。
        重写：
        measureTickMarkSize在 Axis<Number>
        参数
        value - 刻度值
        range - 计算期间使用的范围
        结果
        给定值的刻度标签的大小

      • autoRange

        protected Object autoRange​(double minValue,
                           double maxValue,
                           double length,
                           double labelSize)
        被要求设置上限和下限以及需要自动调整的任何其他内容。
        重写：
        autoRange在 ValueAxis<Number>
        参数
        minValue - 需要在此轴上绘制的最小数据值
        maxValue - 需要在此轴上绘制的最大数据值
        length - 显示坐标轴的长度
        labelSize - 标签沿轴的大致平均尺寸
        结果
        计算范围

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 ValueAxis<Number>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NumberAxis.DefaultFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class NumberAxis.DefaultFormatter

  • java.lang.Object
    • javafx.util.StringConverter<Number>
      • javafx.scene.chart.NumberAxis.DefaultFormatter
  • Enclosing class:
    NumberAxis

    public static class NumberAxis.DefaultFormatter
extends StringConverter<Number>
    NumberAxis的默认数字格式化程序，与自动量程保持同步，并适当地格式化值。 您可以包装此格式化程序以添加前缀或后缀;
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      DefaultFormatter​(NumberAxis axis)
      为给定的NumberAxis构造一个DefaultFormatter
      DefaultFormatter​(NumberAxis axis, String prefix, String suffix)
      为给定的NumberAxis构造一个带有前缀和/或后缀的DefaultFormatter。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Number fromString​(String string)
      将提供的字符串转换为由此转换器定义的数字。
      String toString​(Number object)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultFormatter

        public DefaultFormatter​(NumberAxis axis)
        为给定的NumberAxis构造一个DefaultFormatter
        参数
        axis - 用于格式刻度线的轴

      • DefaultFormatter

        public DefaultFormatter​(NumberAxis axis,
                        String prefix,
                        String suffix)
        为给定的NumberAxis构造一个带有前缀和/或后缀的DefaultFormatter。
        参数
        axis - 格式刻度线的轴
        prefix - 附加到格式化数字开头的前缀，如果不需要，可以为null
        suffix - 附加到格式化数字结尾的后缀，如果不需要则可以为null

    • 方法详细信息

      • toString

        public String toString​(Number object)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由此转换器定义。
        Specified by:
        toString在 StringConverter<Number>
        参数
        object - T类型的对象转换
        结果
        传入的对象的字符串表示形式。
        另请参见：
        StringConverter.toString(T)

      • fromString

        public Number fromString​(String string)
        将提供的字符串转换为由此转换器定义的数字。 字符串的格式和结果对象的类型由此转换器定义。
        Specified by:
        fromString在 StringConverter<Number>
        参数
        string - 转换 String
        结果
        传入的字符串的数字表示形式。
        另请参见：
        StringConverter.toString(T)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PieChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class PieChart

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
            • javafx.scene.chart.PieChart
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class PieChart
extends Chart
    显示PieChart。 图表内容由基于PieChart上设置的数据的饼图填充。

    顺时针属性默认设置为true，这意味着切片以顺时针顺序放置。 labelsVisible属性用于显示饼图切片标签。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty clockwise
      如果真的，我们从startAngle开始顺时针放置切片
      ObjectProperty<ObservableList<PieChart.Data>> data
      PieCharts数据
      DoubleProperty labelLineLength
      从饼图的外部到切片标签的线的长度。
      BooleanProperty labelsVisible
      当绘制真实的饼图切片标签时
      DoubleProperty startAngle
      开始第一个饼切片的角度

      • Properties inherited from class javafx.scene.chart.Chart

        animated, legend, legendSide, legendVisible, title, titleSide

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  PieChart.Data
      PieChart数据项，表示PieChart中的一个切片

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      PieChart​()
      构造一个新的空的PieChart。
      PieChart​(ObservableList<PieChart.Data> data)
      用给定的数据构建一个新的PieChart

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      BooleanProperty clockwiseProperty​()
      如果真的，我们从startAngle开始顺时针放置切片
      ObjectProperty<ObservableList<PieChart.Data>> dataProperty​()
      PieCharts数据
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      ObservableList<PieChart.Data> getData​()
      获取属性数据的值。
      double getLabelLineLength​()
      获取属性labelLineLength的值。
      boolean getLabelsVisible​()
      指示是否绘制饼切片标签
      double getStartAngle​()
      获取属性startAngle的值。
      boolean isClockwise​()
      顺时针方向获取属性值。
      DoubleProperty labelLineLengthProperty​()
      从饼图的外部到切片标签的线的长度。
      BooleanProperty labelsVisibleProperty​()
      当绘制真实的饼图切片标签时
      protected void layoutChartChildren​(double top, double left, double contentWidth, double contentHeight)
      调用更新和布局从getChartChildren（）
      void setClockwise​(boolean value)
      顺时针设置属性的值。
      void setData​(ObservableList<PieChart.Data> value)
      设置属性数据的值。
      void setLabelLineLength​(double value)
      设置属性labelLineLength的值。
      void setLabelsVisible​(boolean value)
      设置属性labelsVisible的值。
      void setStartAngle​(double value)
      设置属性startAngle的值。
      DoubleProperty startAngleProperty​()
      开始第一个饼切片的角度

      • Methods inherited from class javafx.scene.chart.Chart

        animate, animatedProperty, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getAnimated, getChartChildren, getLegend, getLegendSide, getTitle, getTitleSide, isLegendVisible, layoutChildren, legendProperty, legendSideProperty, legendVisibleProperty, requestChartLayout, setAnimated, setLegend, setLegendSide, setLegendVisible, setTitle, setTitleSide, shouldAnimate, titleProperty, titleSideProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • data

        public final ObjectProperty<ObservableList<PieChart.Data>> dataProperty
        PieCharts数据
        另请参见：
        getData() ， setData(ObservableList)

      • startAngle

        public final DoubleProperty startAngleProperty
        开始第一个饼切片的角度
        另请参见：
        getStartAngle() ， setStartAngle(double)

      • clockwise

        public final BooleanProperty clockwiseProperty
        如果真的，我们从startAngle开始顺时针放置切片
        另请参见：
        isClockwise() ， setClockwise(boolean)

      • labelLineLength

        public final DoubleProperty labelLineLengthProperty
        从饼图的外部到切片标签的线的长度。
        另请参见：
        getLabelLineLength() ， setLabelLineLength(double)

      • labelsVisible

        public final BooleanProperty labelsVisibleProperty
        当绘制真实的饼图切片标签时
        另请参见：
        getLabelsVisible() ， setLabelsVisible(boolean)

    • 构造方法详细信息

      • PieChart

        public PieChart​()
        构造一个新的空的PieChart。

      • PieChart

        public PieChart​(ObservableList<PieChart.Data> data)
        用给定的数据构建一个新的PieChart
        参数
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中

    • 方法详细信息

      • getData

        public final ObservableList<PieChart.Data> getData​()
        获取属性数据的值。
        Property description:
        PieCharts数据

      • setData

        public final void setData​(ObservableList<PieChart.Data> value)
        设置属性数据的值。
        Property description:
        PieCharts数据

      • dataProperty

        public final ObjectProperty<ObservableList<PieChart.Data>> dataProperty​()
        PieCharts数据
        另请参见：
        getData() ， setData(ObservableList)

      • getStartAngle

        public final double getStartAngle​()
        获取属性startAngle的值。
        Property description:
        开始第一个饼切片的角度

      • setStartAngle

        public final void setStartAngle​(double value)
        设置属性startAngle的值。
        Property description:
        开始第一个饼切片的角度

      • startAngleProperty

        public final DoubleProperty startAngleProperty​()
        开始第一个饼切片的角度
        另请参见：
        getStartAngle() ， setStartAngle(double)

      • setClockwise

        public final void setClockwise​(boolean value)
        顺时针设置属性的值。
        Property description:
        如果真的，我们从startAngle开始顺时针放置切片

      • isClockwise

        public final boolean isClockwise​()
        顺时针方向获取属性值。
        Property description:
        如果真的，我们从startAngle开始顺时针放置切片

      • clockwiseProperty

        public final BooleanProperty clockwiseProperty​()
        如果真的，我们从startAngle开始顺时针放置切片
        另请参见：
        isClockwise() ， setClockwise(boolean)

      • getLabelLineLength

        public final double getLabelLineLength​()
        获取属性labelLineLength的值。
        Property description:
        从饼图的外部到切片标签的线的长度。

      • setLabelLineLength

        public final void setLabelLineLength​(double value)
        设置属性labelLineLength的值。
        Property description:
        从饼图的外部到切片标签的线的长度。

      • labelLineLengthProperty

        public final DoubleProperty labelLineLengthProperty​()
        从饼图的外部到切片标签的线的长度。
        另请参见：
        getLabelLineLength() ， setLabelLineLength(double)

      • setLabelsVisible

        public final void setLabelsVisible​(boolean value)
        设置属性labelsVisible的值。
        Property description:
        当绘制真实的饼图切片标签时

      • getLabelsVisible

        public final boolean getLabelsVisible​()
        指示是否绘制饼切片标签
        结果
        如果饼图切片标签可见，则为true，否则为false。

      • labelsVisibleProperty

        public final BooleanProperty labelsVisibleProperty​()
        当绘制真实的饼图切片标签时
        另请参见：
        getLabelsVisible() ， setLabelsVisible(boolean)

      • layoutChartChildren

        protected void layoutChartChildren​(double top,
                                   double left,
                                   double contentWidth,
                                   double contentHeight)
        调用更新和布局从getChartChildren（）
        Specified by:
        layoutChartChildren在 Chart
        参数
        top - 从原始位置的顶部偏移量计入图表内容上的任何填充
        left - 从原始位置左偏移到图表内容上的任何填充
        contentWidth - 布局图表的区域的宽度
        contentHeight - 将图表布置的区域的高度

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Chart
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PieChart.Data (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class PieChart.Data

  • java.lang.Object
    • javafx.scene.chart.PieChart.Data
  • Enclosing class:
    PieChart

    public static final class PieChart.Data
extends Object
    PieChart数据项，表示PieChart中的一个切片
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<PieChart> chart
      该数据所属的图表。
      StringProperty name
      饼图的名称
      ReadOnlyObjectProperty<Node> node
      访问表示饼图切片的节点。
      DoubleProperty pieValue
      饼图的值

    • 构造方法摘要

      构造方法
      Constructor 描述
      Data​(String name, double value)
      构造具有给定名称和值的PieChart.Data对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<PieChart> chartProperty​()
      该数据所属的图表。
      PieChart getChart​()
      获取属性图表的值。
      String getName​()
      获取属性名称的值。
      Node getNode​()
      返回表示饼图切片的节点。
      double getPieValue​()
      获取属性pieValue的值。
      StringProperty nameProperty​()
      饼图的名称
      ReadOnlyObjectProperty<Node> nodeProperty​()
      访问表示饼图切片的节点。
      DoubleProperty pieValueProperty​()
      饼图的值
      void setName​(String value)
      设置属性名称的值。
      void setPieValue​(double value)
      设置属性pieValue的值。
      String toString​()
      返回此 Data对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • chart

        public final ReadOnlyObjectProperty<PieChart> chartProperty
        该数据所属的图表。
        另请参见：
        getChart()

      • name

        public final StringProperty nameProperty
        饼图的名称
        另请参见：
        getName() ， setName(String)

      • pieValue

        public final DoubleProperty pieValueProperty
        饼图的值
        另请参见：
        getPieValue() ， setPieValue(double)

      • node

        public ReadOnlyObjectProperty<Node> nodeProperty
        访问表示饼图切片的节点。 您可以使用它来添加鼠标事件侦听器等
        另请参见：
        getNode()

    • 构造方法详细信息

      • Data

        public Data​(String name,
            double value)
        构造具有给定名称和值的PieChart.Data对象。
        参数
        name - 饼的名字
        value - 饼图值

    • 方法详细信息

      • getChart

        public final PieChart getChart​()
        获取属性图表的值。
        Property description:
        该数据所属的图表。

      • chartProperty

        public final ReadOnlyObjectProperty<PieChart> chartProperty​()
        该数据所属的图表。
        另请参见：
        getChart()

      • setName

        public final void setName​(String value)
        设置属性名称的值。
        Property description:
        饼图的名称

      • getName

        public final String getName​()
        获取属性名称的值。
        Property description:
        饼图的名称

      • nameProperty

        public final StringProperty nameProperty​()
        饼图的名称
        另请参见：
        getName() ， setName(String)

      • getPieValue

        public final double getPieValue​()
        获取属性pieValue的值。
        Property description:
        饼图的值

      • setPieValue

        public final void setPieValue​(double value)
        设置属性pieValue的值。
        Property description:
        饼图的值

      • pieValueProperty

        public final DoubleProperty pieValueProperty​()
        饼图的值
        另请参见：
        getPieValue() ， setPieValue(double)

      • getNode

        public Node getNode​()
        返回表示饼图切片的节点。 您可以使用它来添加鼠标事件侦听器等
        结果
        表示饼图切片的节点

      • nodeProperty

        public ReadOnlyObjectProperty<Node> nodeProperty​()
        访问表示饼图切片的节点。 您可以使用它来添加鼠标事件侦听器等
        另请参见：
        getNode()

      • toString

        public String toString​()
        返回此 Data对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 Data对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScatterChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class ScatterChart<X,Y>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
            • javafx.scene.chart.XYChart<X,Y>
              • javafx.scene.chart.ScatterChart<X,Y>
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class ScatterChart<X,Y>
extends XYChart<X,Y>
    绘制一系列数据点符号的图表类型。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.chart.Chart

        animated, legend, legendSide, legendVisible, title, titleSide

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisible, alternativeRowFillVisible, data, horizontalGridLinesVisible, horizontalZeroLineVisible, verticalGridLinesVisible, verticalZeroLineVisible

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.chart.XYChart

        XYChart.Data<X,Y>, XYChart.Series<X,Y>

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴和数据构造新的ScatterChart。
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造新的ScatterChart。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      protected void layoutPlotChildren​()
      被要求更新和布局情节儿童。
      protected void seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。

      • Methods inherited from class javafx.scene.chart.Chart

        animate, animatedProperty, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getAnimated, getChartChildren, getLegend, getLegendSide, getTitle, getTitleSide, isLegendVisible, layoutChildren, legendProperty, legendSideProperty, legendVisibleProperty, requestChartLayout, setAnimated, setLegend, setLegendSide, setLegendVisible, setTitle, setTitleSide, shouldAnimate, titleProperty, titleSideProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisibleProperty, alternativeRowFillVisibleProperty, currentDisplayedExtraValueProperty, currentDisplayedXValueProperty, currentDisplayedYValueProperty, dataProperty, getClassCssMetaData, getCssMetaData, getCurrentDisplayedExtraValue, getCurrentDisplayedXValue, getCurrentDisplayedYValue, getData, getDisplayedDataIterator, getDisplayedSeriesIterator, getPlotChildren, getVerticalGridLinesVisible, getXAxis, getYAxis, horizontalGridLinesVisibleProperty, horizontalZeroLineVisibleProperty, isAlternativeColumnFillVisible, isAlternativeRowFillVisible, isHorizontalGridLinesVisible, isHorizontalZeroLineVisible, isVerticalZeroLineVisible, layoutChartChildren, removeDataItemFromDisplay, removeSeriesFromDisplay, seriesChanged, setAlternativeColumnFillVisible, setAlternativeRowFillVisible, setCurrentDisplayedExtraValue, setCurrentDisplayedXValue, setCurrentDisplayedYValue, setData, setHorizontalGridLinesVisible, setHorizontalZeroLineVisible, setVerticalGridLinesVisible, setVerticalZeroLineVisible, updateAxisRange, updateLegend, verticalGridLinesVisibleProperty, verticalZeroLineVisibleProperty

    • 构造方法详细信息

      • ScatterChart

        public ScatterChart​(Axis<X> xAxis,
                    Axis<Y> yAxis)
        使用给定的轴和数据构造新的ScatterChart。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴

      • ScatterChart

        public ScatterChart​(Axis<X> xAxis,
                    Axis<Y> yAxis,
                    ObservableList<XYChart.Series<X,Y>> data)
        使用给定的轴和数据构造新的ScatterChart。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中

    • 方法详细信息

      • dataItemAdded

        protected void dataItemAdded​(XYChart.Series<X,Y> series,
                             int itemIndex,
                             XYChart.Data<X,Y> item)
        将数据项添加到系列时调用。 这是XYChart的实现可以创建/添加新节点，以使getPlotChildren表示此数据项。 如果animated = true，他们也可以将数据添加为淡入淡出或相似。
        Specified by:
        dataItemAdded在 XYChart<X,Y>
        参数
        series - 数据项被添加到的系列
        itemIndex - 系列中新项目的索引
        item - 添加的新数据项

      • dataItemRemoved

        protected void dataItemRemoved​(XYChart.Data<X,Y> item,
                               XYChart.Series<X,Y> series)
        当数据项已从数据模型中删除但在图表上仍然可见时调用。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeDataItemFromDisplay（）来删除项目节点不显示在图表上。
        Specified by:
        dataItemRemoved在 XYChart<X,Y>
        参数
        item - 从系列中删除的项目
        series - 该项目被删除的系列

      • dataItemChanged

        protected void dataItemChanged​(XYChart.Data<X,Y> item)
        数据项已更改时调用，即其xValue，yValue或extraValue已更改。
        Specified by:
        dataItemChanged在 XYChart<X,Y>
        参数
        item - 被更改的数据项

      • seriesAdded

        protected void seriesAdded​(XYChart.Series<X,Y> series,
                           int seriesIndex)
        一系列已经添加到图表数据模型中。 这是XYChart的实现可以创建/添加新的节点来getPlotChildren来表示这个系列。 此外，您必须处理添加已经在系列中的任何数据项。 您可以简单地为每一个调用dataItemAdded（），或为要添加的整个系列提供一些不同的动画。
        Specified by:
        seriesAdded在 XYChart<X,Y>
        参数
        series - 已添加的系列
        seriesIndex - 新系列的索引

      • seriesRemoved

        protected void seriesRemoved​(XYChart.Series<X,Y> series)
        数据模型中已经删除了一个系列，但它仍然可以在图表上显示。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeSeriesFromDisplay（）从显示列表中删除该系列。
        Specified by:
        seriesRemoved在 XYChart<X,Y>
        参数
        series - 已被删除的系列

      • layoutPlotChildren

        protected void layoutPlotChildren​()
        被要求更新和布局情节儿童。 这应该包括更新表示轴和网格线顶部的图的节点的所有工作。原点是绘图区域的左上角，绘制区域可以通过获取x轴的宽度及其高度从y轴的高度。
        Specified by:
        layoutPlotChildren在 XYChart<X,Y>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StackedAreaChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class StackedAreaChart<X,Y>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
            • javafx.scene.chart.XYChart<X,Y>
              • javafx.scene.chart.StackedAreaChart<X,Y>
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class StackedAreaChart<X,Y>
extends XYChart<X,Y>
    StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。 （随着时间的推移，例如）这些区域被堆叠，使得每个系列相邻，但不与先前的系列重叠。 这与“区域”图相反，每个系列覆盖上一个系列。 StackedAreaChart的累积性质提供了沿X轴的任意给定点的总Y数据值的概念。 由于跨多个系列的数据点可能不常见，StackedAreaChart会在必要时插入连接数据点的行。
    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty createSymbols
      当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。

      • Properties inherited from class javafx.scene.chart.Chart

        animated, legend, legendSide, legendVisible, title, titleSide

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisible, alternativeRowFillVisible, data, horizontalGridLinesVisible, horizontalZeroLineVisible, verticalGridLinesVisible, verticalZeroLineVisible

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.chart.XYChart

        XYChart.Data<X,Y>, XYChart.Series<X,Y>

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定轴构建新的区域图
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      BooleanProperty createSymbolsProperty​()
      当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
      protected void dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      boolean getCreateSymbols​()
      指示是否创建数据点的符号。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      protected void layoutPlotChildren​()
      被要求更新和布局情节儿童。
      protected void seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      当将每个原子更改作为此图表的系列列表时调用
      protected void seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。
      void setCreateSymbols​(boolean value)
      设置属性createSymbols的值。
      protected void updateAxisRange​()
      当范围已经无效并且我们需要更新时，这被称为。

      • Methods inherited from class javafx.scene.chart.Chart

        animate, animatedProperty, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getAnimated, getChartChildren, getLegend, getLegendSide, getTitle, getTitleSide, isLegendVisible, layoutChildren, legendProperty, legendSideProperty, legendVisibleProperty, requestChartLayout, setAnimated, setLegend, setLegendSide, setLegendVisible, setTitle, setTitleSide, shouldAnimate, titleProperty, titleSideProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisibleProperty, alternativeRowFillVisibleProperty, currentDisplayedExtraValueProperty, currentDisplayedXValueProperty, currentDisplayedYValueProperty, dataProperty, getCurrentDisplayedExtraValue, getCurrentDisplayedXValue, getCurrentDisplayedYValue, getData, getDisplayedDataIterator, getDisplayedSeriesIterator, getPlotChildren, getVerticalGridLinesVisible, getXAxis, getYAxis, horizontalGridLinesVisibleProperty, horizontalZeroLineVisibleProperty, isAlternativeColumnFillVisible, isAlternativeRowFillVisible, isHorizontalGridLinesVisible, isHorizontalZeroLineVisible, isVerticalZeroLineVisible, layoutChartChildren, removeDataItemFromDisplay, removeSeriesFromDisplay, setAlternativeColumnFillVisible, setAlternativeRowFillVisible, setCurrentDisplayedExtraValue, setCurrentDisplayedXValue, setCurrentDisplayedYValue, setData, setHorizontalGridLinesVisible, setHorizontalZeroLineVisible, setVerticalGridLinesVisible, setVerticalZeroLineVisible, updateLegend, verticalGridLinesVisibleProperty, verticalZeroLineVisibleProperty

    • Property Detail

      • createSymbols

        public final BooleanProperty createSymbolsProperty
        当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getCreateSymbols() ， setCreateSymbols(boolean)

    • 构造方法详细信息

      • StackedAreaChart

        public StackedAreaChart​(Axis<X> xAxis,
                        Axis<Y> yAxis)
        用给定轴构建新的区域图
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴

      • StackedAreaChart

        public StackedAreaChart​(Axis<X> xAxis,
                        Axis<Y> yAxis,
                        ObservableList<XYChart.Series<X,Y>> data)
        使用给定的轴和数据构建新的区域图。

        注意：yAx必须是ValueAxis，否则抛出IllegalArgumentException 。

        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中
        异常
        IllegalArgumentException - 如果yAxis不是ValueAxis

    • 方法详细信息

      • getCreateSymbols

        public final boolean getCreateSymbols​()
        指示是否创建数据点的符号。
        结果
        如果将创建数据点的符号，则为true，否则为false。
        从以下版本开始：
        JavaFX 8.0

      • setCreateSymbols

        public final void setCreateSymbols​(boolean value)
        设置属性createSymbols的值。
        Property description:
        当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
        从以下版本开始：
        JavaFX 8.0

      • createSymbolsProperty

        public final BooleanProperty createSymbolsProperty​()
        当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getCreateSymbols() ， setCreateSymbols(boolean)

      • dataItemAdded

        protected void dataItemAdded​(XYChart.Series<X,Y> series,
                             int itemIndex,
                             XYChart.Data<X,Y> item)
        描述从类复制： XYChart
        将数据项添加到系列时调用。 这是XYChart的实现可以创建/添加新节点，以使getPlotChildren表示此数据项。 如果animated = true，他们也可以将数据添加为淡入淡出或相似。
        Specified by:
        dataItemAdded在 XYChart<X,Y>
        参数
        series - 数据项被添加到的系列
        itemIndex - 系列中新项目的索引
        item - 添加的新数据项

      • dataItemRemoved

        protected void dataItemRemoved​(XYChart.Data<X,Y> item,
                               XYChart.Series<X,Y> series)
        描述从类别复制： XYChart
        当数据项已从数据模型中删除但在图表上仍然可见时调用。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeDataItemFromDisplay（）来删除项目节点不显示在图表上。
        Specified by:
        dataItemRemoved在 XYChart<X,Y>
        参数
        item - 从系列中删除的项目
        series - 该项目已被删除

      • dataItemChanged

        protected void dataItemChanged​(XYChart.Data<X,Y> item)
        数据项已更改时调用，即其xValue，yValue或extraValue已更改。
        Specified by:
        dataItemChanged在 XYChart<X,Y>
        参数
        item - 已更改的数据项

      • seriesChanged

        protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
        描述从类复制： XYChart
        当将每个原子更改作为此图表的系列列表时调用
        重写：
        seriesChanged在 XYChart<X,Y>
        参数
        c - 表示系列更改的更改实例

      • seriesAdded

        protected void seriesAdded​(XYChart.Series<X,Y> series,
                           int seriesIndex)
        描述从类别复制： XYChart
        一系列已经添加到图表数据模型中。 这是XYChart的实现可以创建/添加新的节点来getPlotChildren来表示这个系列。 此外，您必须处理添加已经在系列中的任何数据项。 您可以简单地为每一个调用dataItemAdded（），或为要添加的整个系列提供一些不同的动画。
        Specified by:
        seriesAdded在 XYChart<X,Y>
        参数
        series - 已添加的系列
        seriesIndex - 新系列的索引

      • seriesRemoved

        protected void seriesRemoved​(XYChart.Series<X,Y> series)
        描述从类复制： XYChart
        数据模型中已经删除了一个系列，但它仍然可以在图表上显示。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeSeriesFromDisplay（）从显示列表中删除该系列。
        Specified by:
        seriesRemoved在 XYChart<X,Y>
        参数
        series - 已被删除的系列

      • updateAxisRange

        protected void updateAxisRange​()
        当范围已经无效并且我们需要更新时，这被称为。 如果轴是自动测距，那么我们编译给定轴必须绘制的所有数据的列表，并在传递该数据的轴上调用invalidateRange（）。
        重写：
        updateAxisRange在 XYChart<X,Y>

      • layoutPlotChildren

        protected void layoutPlotChildren​()
        被要求更新和布局情节儿童。 这应该包括更新表示轴和网格线顶部的图的节点的所有工作。原点是绘图区域的左上角，绘制区域可以通过获取x轴的宽度及其高度从y轴的高度。
        Specified by:
        layoutPlotChildren在 XYChart<X,Y>

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 XYChart<X,Y>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StackedBarChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class StackedBarChart<X,Y>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
            • javafx.scene.chart.XYChart<X,Y>
              • javafx.scene.chart.StackedBarChart<X,Y>
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class StackedBarChart<X,Y>
extends XYChart<X,Y>
    StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。 条可以是垂直或水平，取决于哪个轴是类别轴。 每个系列的酒吧堆叠在以前的系列之上。
    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty categoryGap
      在不同类别的酒吧之间留下的差距

      • Properties inherited from class javafx.scene.chart.Chart

        animated, legend, legendSide, legendVisible, title, titleSide

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisible, alternativeRowFillVisible, data, horizontalGridLinesVisible, horizontalZeroLineVisible, verticalGridLinesVisible, verticalZeroLineVisible

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.chart.XYChart

        XYChart.Data<X,Y>, XYChart.Series<X,Y>

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴构建一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      使用给定的轴和数据构造一个新的StackedBarChart。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      DoubleProperty categoryGapProperty​()
      在不同类别的酒吧之间留下的差距
      protected void dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      double getCategoryGap​()
      获取属性categoryGap的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      protected void layoutPlotChildren​()
      被要求更新和布局情节儿童。
      protected void seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      当将每个原子更改作为此图表的系列列表时调用
      protected void seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。
      void setCategoryGap​(double value)
      设置属性categoryGap的值。
      protected void updateAxisRange​()
      当范围已经无效并且我们需要更新时，这被称为。

      • Methods inherited from class javafx.scene.chart.Chart

        animate, animatedProperty, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getAnimated, getChartChildren, getLegend, getLegendSide, getTitle, getTitleSide, isLegendVisible, layoutChildren, legendProperty, legendSideProperty, legendVisibleProperty, requestChartLayout, setAnimated, setLegend, setLegendSide, setLegendVisible, setTitle, setTitleSide, shouldAnimate, titleProperty, titleSideProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.chart.XYChart

        alternativeColumnFillVisibleProperty, alternativeRowFillVisibleProperty, currentDisplayedExtraValueProperty, currentDisplayedXValueProperty, currentDisplayedYValueProperty, dataProperty, getCurrentDisplayedExtraValue, getCurrentDisplayedXValue, getCurrentDisplayedYValue, getData, getDisplayedDataIterator, getDisplayedSeriesIterator, getPlotChildren, getVerticalGridLinesVisible, getXAxis, getYAxis, horizontalGridLinesVisibleProperty, horizontalZeroLineVisibleProperty, isAlternativeColumnFillVisible, isAlternativeRowFillVisible, isHorizontalGridLinesVisible, isHorizontalZeroLineVisible, isVerticalZeroLineVisible, layoutChartChildren, removeDataItemFromDisplay, removeSeriesFromDisplay, setAlternativeColumnFillVisible, setAlternativeRowFillVisible, setCurrentDisplayedExtraValue, setCurrentDisplayedXValue, setCurrentDisplayedYValue, setData, setHorizontalGridLinesVisible, setHorizontalZeroLineVisible, setVerticalGridLinesVisible, setVerticalZeroLineVisible, updateLegend, verticalGridLinesVisibleProperty, verticalZeroLineVisibleProperty

    • Property Detail

      • categoryGap

        public DoubleProperty categoryGapProperty
        在不同类别的酒吧之间留下的差距
        另请参见：
        getCategoryGap() ， setCategoryGap(double)

    • 构造方法详细信息

      • StackedBarChart

        public StackedBarChart​(Axis<X> xAxis,
                       Axis<Y> yAxis)
        使用给定的轴构建一个新的StackedBarChart。 两轴应该是ValueAxis / NumberAxis和CategoryAxis，它们可以是任意顺序，具体取决于是否要使用水平或垂直条形图。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴

      • StackedBarChart

        public StackedBarChart​(Axis<X> xAxis,
                       Axis<Y> yAxis,
                       ObservableList<XYChart.Series<X,Y>> data)
        使用给定的轴和数据构造一个新的StackedBarChart。 两轴应该是ValueAxis / NumberAxis和CategoryAxis，它们可以是任意顺序，具体取决于是否要使用水平或垂直条形图。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中

      • StackedBarChart

        public StackedBarChart​(Axis<X> xAxis,
                       Axis<Y> yAxis,
                       ObservableList<XYChart.Series<X,Y>> data,
                       double categoryGap)
        使用给定的轴和数据构造一个新的StackedBarChart。 两轴应该是ValueAxis / NumberAxis和CategoryAxis，它们可以是任意顺序，具体取决于是否要使用水平或垂直条形图。
        参数
        xAxis - 要使用的x轴
        yAxis - 要使用的y轴
        data - 要使用的数据，这是使用的实际列表，所以对其进行的任何更改将反映在图表中
        categoryGap - 在不同类别的酒吧之间留下的差距

    • 方法详细信息

      • getCategoryGap

        public double getCategoryGap​()
        获取属性categoryGap的值。
        Property description:
        在不同类别的酒吧之间留下的差距

      • setCategoryGap

        public void setCategoryGap​(double value)
        设置属性categoryGap的值。
        Property description:
        在不同类别的酒吧之间留下的差距

      • categoryGapProperty

        public DoubleProperty categoryGapProperty​()
        在不同类别的酒吧之间留下的差距
        另请参见：
        getCategoryGap() ， setCategoryGap(double)

      • dataItemAdded

        protected void dataItemAdded​(XYChart.Series<X,Y> series,
                             int itemIndex,
                             XYChart.Data<X,Y> item)
        描述从类别复制： XYChart
        将数据项添加到系列时调用。 这是XYChart的实现可以创建/添加新节点，以使getPlotChildren表示此数据项。 如果animated = true，他们也可以将数据添加为淡入淡出或相似。
        Specified by:
        dataItemAdded在 XYChart<X,Y>
        参数
        series - 数据项被添加到的系列
        itemIndex - 系列中新项目的索引
        item - 添加的新数据项

      • dataItemRemoved

        protected void dataItemRemoved​(XYChart.Data<X,Y> item,
                               XYChart.Series<X,Y> series)
        描述从类复制： XYChart
        当数据项已从数据模型中删除但在图表上仍然可见时调用。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeDataItemFromDisplay（）来删除项目节点不显示在图表上。
        Specified by:
        dataItemRemoved在 XYChart<X,Y>
        参数
        item - 从系列中删除的项目
        series - 该项目已被删除

      • dataItemChanged

        protected void dataItemChanged​(XYChart.Data<X,Y> item)
        数据项已更改时调用，即其xValue，yValue或extraValue已更改。
        Specified by:
        dataItemChanged在 XYChart<X,Y>
        参数
        item - 已更改的数据项

      • seriesChanged

        protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
        说明从类别复制： XYChart
        当将每个原子更改作为此图表的系列列表时调用
        重写：
        seriesChanged在 XYChart<X,Y>
        参数
        c - 表示系列更改的更改实例

      • seriesAdded

        protected void seriesAdded​(XYChart.Series<X,Y> series,
                           int seriesIndex)
        一系列已经添加到图表数据模型中。 这是XYChart的实现可以创建/添加新的节点来getPlotChildren来表示这个系列。 此外，您必须处理添加已经在系列中的任何数据项。 您可以简单地为每一个调用dataItemAdded（），或为要添加的整个系列提供一些不同的动画。
        Specified by:
        seriesAdded在 XYChart<X,Y>
        参数
        series - 已添加的系列
        seriesIndex - 新系列的索引

      • seriesRemoved

        protected void seriesRemoved​(XYChart.Series<X,Y> series)
        描述从类别复制： XYChart
        数据模型中已经删除了一个系列，但它仍然可以在图表上显示。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeSeriesFromDisplay（）从显示列表中删除该系列。
        Specified by:
        seriesRemoved在 XYChart<X,Y>
        参数
        series - 已被删除的系列

      • updateAxisRange

        protected void updateAxisRange​()
        当范围已经无效并且我们需要更新时，这被称为。 如果轴是自动测距，那么我们编译给定轴必须绘制的所有数据的列表，并在传递该数据的轴上调用invalidateRange（）。
        重写：
        updateAxisRange在 XYChart<X,Y>

      • layoutPlotChildren

        protected void layoutPlotChildren​()
        被要求更新和布局情节儿童。 这应该包括更新表示轴和网格线顶部的图的节点的所有工作。原点是绘图区域的左上角，绘制区域可以通过获取x轴的宽度及其高度从y轴的高度。
        Specified by:
        layoutPlotChildren在 XYChart<X,Y>

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 XYChart<X,Y>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.chart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.chart

  • Packages that use javafx.scene.chart
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
  • Classes in javafx.scene.chart used by javafx.scene.chart
    Class 描述
    Axis
    JavaFX中所有轴的基类，表示在图表区域上绘制的轴。
    Axis.TickMark
    TickMark代表标签文本，它与Axis的每个刻度相关联的属性。
    Chart
    所有图表的基础类。
    LineChart.SortingPolicy
    此枚举定义了一个 LineChart.axisSortingPolicyProperty()的策略。
    NumberAxis
    一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
    PieChart
    显示PieChart。
    PieChart.Data
    PieChart数据项，表示PieChart中的一个切片
    ValueAxis
    数据定义为数字的轴。
    XYChart
    所有2轴图的图表基类。
    XYChart.Data
    具有2轴图数据的单个数据项
    XYChart.Series
    一系列命名的数据项
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ValueAxis (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class ValueAxis<T extends Number>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Axis<T>
            • javafx.scene.chart.ValueAxis<T>
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    NumberAxis

    public abstract class ValueAxis<T extends Number>
extends Axis<T>
    数据定义为数字的轴。 它也可以在主要的之间绘制小的标记。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty lowerBound
      该轴下限值（最小值）。
      IntegerProperty minorTickCount
      每个主要刻度线之间显示的小刻度分割数。
      DoubleProperty minorTickLength
      小刻度线的长度。
      BooleanProperty minorTickVisible
      如果显示较小的刻度线，则为真
      ReadOnlyDoubleProperty scale
      从数据单位到视觉单位的比例因子
      ObjectProperty<StringConverter<T>> tickLabelFormatter
      StringConverter用于格式化刻度线标签。
      DoubleProperty upperBound
      该轴上限值（最大值）。

      • Properties inherited from class javafx.scene.chart.Axis

        animated, autoRanging, label, side, tickLabelFill, tickLabelFont, tickLabelGap, tickLabelRotation, tickLabelsVisible, tickLength, tickMarkVisible

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.chart.Axis

        Axis.TickMark<T>

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected DoubleProperty currentLowerBound
      该轴的lowerBound的当前值（最小值）。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ValueAxis​()
      创建自动范围的ValueAxis。
      ValueAxis​(double lowerBound, double upperBound)
      用给定的下限和上限创建一个非自动范围的ValueAxis。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Object autoRange​(double length)
      这将根据提供给invalidateRange（）方法的数据计算上限和下限。
      protected Object autoRange​(double minValue, double maxValue, double length, double labelSize)
      被要求设置上限和下限以及需要自动调整的任何其他内容。
      protected abstract List<T> calculateMinorTickMarks​()
      计算每个小刻度线的数据值列表
      protected double calculateNewScale​(double length, double lowerBound, double upperBound)
      计算此轴的新刻度。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      double getDisplayPosition​(T value)
      获取给定值的沿该轴的显示位置。
      double getLowerBound​()
      获取属性lowerBound的值。
      int getMinorTickCount​()
      获取属性minorTickCount的值。
      double getMinorTickLength​()
      获取属性minorTickLength的值。
      double getScale​()
      获取属性比例的值。
      StringConverter<T> getTickLabelFormatter​()
      获取属性tickLabelFormatter的值。
      double getUpperBound​()
      获取属性upperBound的值。
      T getValueForDisplay​(double displayPosition)
      获取此轴上给定显示位置的数据值。
      double getZeroPosition​()
      获取零轴沿该轴的显示位置。
      void invalidateRange​(List<T> data)
      当数据发生变化并且范围可能不再有效时调用。
      boolean isMinorTickVisible​()
      获取属性minorTickVisible的值。
      boolean isValueOnAxis​(T value)
      检查给定值是否在该轴上是可绘制的
      protected void layoutChildren​()
      在布局传递期间调用以布局此轴及其所有内容。
      DoubleProperty lowerBoundProperty​()
      该轴下限值（最小值）。
      IntegerProperty minorTickCountProperty​()
      每个主要刻度线之间显示的小刻度分割数。
      DoubleProperty minorTickLengthProperty​()
      小刻度线的长度。
      BooleanProperty minorTickVisibleProperty​()
      如果显示较小的刻度线，则为真
      ReadOnlyDoubleProperty scaleProperty​()
      从数据单位到视觉单位的比例因子
      void setLowerBound​(double value)
      设置属性lowerBound的值。
      void setMinorTickCount​(int value)
      设置属性minorTickCount的值。
      void setMinorTickLength​(double value)
      设置属性minorTickLength的值。
      void setMinorTickVisible​(boolean value)
      设置属性minorTickVisible的值。
      protected void setScale​(double scale)
      设置属性比例的值。
      void setTickLabelFormatter​(StringConverter<T> value)
      设置属性tickLabelFormatter的值。
      void setUpperBound​(double value)
      设置属性upperBound的值。
      ObjectProperty<StringConverter<T>> tickLabelFormatterProperty​()
      StringConverter用于格式化刻度线标签。
      protected void tickMarksUpdated​()
      如果已经更新了标记，则在布局期间调用，允许子类在反应中执行所需的任何操作。
      double toNumericValue​(T value)
      所有轴值必须由某些数值表示。
      T toRealValue​(double value)
      所有轴值必须由某些数值表示。
      DoubleProperty upperBoundProperty​()
      该轴上限值（最大值）。

      • Methods inherited from class javafx.scene.chart.Axis

        animatedProperty, autoRangingProperty, calculateTickValues, computePrefHeight, computePrefWidth, getAnimated, getLabel, getRange, getSide, getTickLabelFill, getTickLabelFont, getTickLabelGap, getTickLabelRotation, getTickLength, getTickMarkLabel, getTickMarks, invalidateRange, isAutoRanging, isRangeValid, isTickLabelsVisible, isTickMarkVisible, labelProperty, measureTickMarkLabelSize, measureTickMarkSize, measureTickMarkSize, requestAxisLayout, requestLayout, setAnimated, setAutoRanging, setLabel, setRange, setSide, setTickLabelFill, setTickLabelFont, setTickLabelGap, setTickLabelRotation, setTickLabelsVisible, setTickLength, setTickMarkVisible, shouldAnimate, sideProperty, tickLabelFillProperty, tickLabelFontProperty, tickLabelGapProperty, tickLabelRotationProperty, tickLabelsVisibleProperty, tickLengthProperty, tickMarkVisibleProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • minorTickVisible

        public final BooleanProperty minorTickVisibleProperty
        如果显示较小的刻度线，则为真
        另请参见：
        isMinorTickVisible() ， setMinorTickVisible(boolean)

      • scale

        public final ReadOnlyDoubleProperty scaleProperty
        从数据单位到视觉单位的比例因子
        另请参见：
        getScale() ， setScale(double)

      • upperBound

        public final DoubleProperty upperBoundProperty
        该轴上限值（最大值）。 如果自动量程打开，则自动设置。
        另请参见：
        getUpperBound() ， setUpperBound(double)

      • lowerBound

        public final DoubleProperty lowerBoundProperty
        该轴下限值（最小值）。 如果自动量程打开，则自动设置。
        另请参见：
        getLowerBound() ， setLowerBound(double)

      • tickLabelFormatter

        public final ObjectProperty<StringConverter<T extends Number>> tickLabelFormatterProperty
        StringConverter用于格式化刻度线标签。 如果null，将使用默认值
        另请参见：
        getTickLabelFormatter() ， setTickLabelFormatter(StringConverter)

      • minorTickLength

        public final DoubleProperty minorTickLengthProperty
        小刻度线的长度。 设置为0以不显示小刻度线。
        另请参见：
        getMinorTickLength() ， setMinorTickLength(double)

      • minorTickCount

        public final IntegerProperty minorTickCountProperty
        每个主要刻度线之间显示的小刻度分割数。 实际的小刻度标记的数量将比此少一个。
        另请参见：
        getMinorTickCount() ， setMinorTickCount(int)

    • 字段详细信息

      • currentLowerBound

        protected final DoubleProperty currentLowerBound
        该轴的lowerBound的当前值（最小值）。 这可能与lowerBound相同或不同。 NumberAxis用于将lowerBound从旧值设为新值。

    • 构造方法详细信息

      • ValueAxis

        public ValueAxis​()
        创建自动范围的ValueAxis。

      • ValueAxis

        public ValueAxis​(double lowerBound,
                 double upperBound)
        用给定的下限和上限创建一个非自动范围的ValueAxis。
        参数
        lowerBound - 该轴的下限，即最小可绘图值
        upperBound - 此轴的上限，即最大可绘图值

    • 方法详细信息

      • isMinorTickVisible

        public final boolean isMinorTickVisible​()
        获取属性minorTickVisible的值。
        Property description:
        如果显示较小的刻度线，则为真

      • setMinorTickVisible

        public final void setMinorTickVisible​(boolean value)
        设置属性minorTickVisible的值。
        Property description:
        如果显示较小的刻度线，则为真

      • minorTickVisibleProperty

        public final BooleanProperty minorTickVisibleProperty​()
        如果显示较小的刻度线，则为真
        另请参见：
        isMinorTickVisible() ， setMinorTickVisible(boolean)

      • getScale

        public final double getScale​()
        获取属性比例的值。
        Property description:
        从数据单位到视觉单位的比例因子

      • setScale

        protected final void setScale​(double scale)
        设置属性比例的值。
        Property description:
        从数据单位到视觉单位的比例因子

      • scaleProperty

        public final ReadOnlyDoubleProperty scaleProperty​()
        从数据单位到视觉单位的比例因子
        另请参见：
        getScale() ， setScale(double)

      • getUpperBound

        public final double getUpperBound​()
        获取属性upperBound的值。
        Property description:
        该轴上限值（最大值）。 如果自动量程打开，则自动设置。

      • setUpperBound

        public final void setUpperBound​(double value)
        设置属性upperBound的值。
        Property description:
        该轴上限值（最大值）。 如果自动量程打开，则自动设置。

      • upperBoundProperty

        public final DoubleProperty upperBoundProperty​()
        该轴上限值（最大值）。 如果自动量程打开，则自动设置。
        另请参见：
        getUpperBound() ， setUpperBound(double)

      • getLowerBound

        public final double getLowerBound​()
        获取属性lowerBound的值。
        Property description:
        该轴下限值（最小值）。 如果自动量程打开，则自动设置。

      • setLowerBound

        public final void setLowerBound​(double value)
        设置属性lowerBound的值。
        Property description:
        该轴下限值（最小值）。 如果自动量程打开，则自动设置。

      • lowerBoundProperty

        public final DoubleProperty lowerBoundProperty​()
        该轴下限值（最小值）。 如果自动量程打开，则自动设置。
        另请参见：
        getLowerBound() ， setLowerBound(double)

      • getTickLabelFormatter

        public final StringConverter<T> getTickLabelFormatter​()
        获取属性tickLabelFormatter的值。
        Property description:
        StringConverter用于格式化刻度线标签。 如果null，将使用默认值

      • setTickLabelFormatter

        public final void setTickLabelFormatter​(StringConverter<T> value)
        设置属性tickLabelFormatter的值。
        Property description:
        StringConverter用于格式化刻度线标签。 如果null，将使用默认值

      • tickLabelFormatterProperty

        public final ObjectProperty<StringConverter<T>> tickLabelFormatterProperty​()
        StringConverter用于格式化刻度线标签。 如果null，将使用默认值
        另请参见：
        getTickLabelFormatter() ， setTickLabelFormatter(StringConverter)

      • getMinorTickLength

        public final double getMinorTickLength​()
        获取属性minorTickLength的值。
        Property description:
        小刻度线的长度。 设置为0以不显示小刻度线。

      • setMinorTickLength

        public final void setMinorTickLength​(double value)
        设置属性minorTickLength的值。
        Property description:
        小刻度线的长度。 设置为0以不显示小刻度线。

      • minorTickLengthProperty

        public final DoubleProperty minorTickLengthProperty​()
        小刻度线的长度。 设置为0以不显示小刻度线。
        另请参见：
        getMinorTickLength() ， setMinorTickLength(double)

      • getMinorTickCount

        public final int getMinorTickCount​()
        获取属性minorTickCount的值。
        Property description:
        每个主要刻度线之间显示的小刻度分割数。 实际的小刻度标记的数量将比此少一个。

      • setMinorTickCount

        public final void setMinorTickCount​(int value)
        设置属性minorTickCount的值。
        Property description:
        每个主要刻度线之间显示的小刻度分割数。 实际的小刻度标记的数量将比此少一个。

      • minorTickCountProperty

        public final IntegerProperty minorTickCountProperty​()
        每个主要刻度线之间显示的小刻度分割数。 实际的小刻度标记的数量将比此少一个。
        另请参见：
        getMinorTickCount() ， setMinorTickCount(int)

      • autoRange

        protected final Object autoRange​(double length)
        这将根据提供给invalidateRange（）方法的数据计算上限和下限。 这不能影响轴的状态。 应在范围对象中返回自动范围的任何结果。 如果已决定为此轴采用此范围，我们将传递给setRange（）。
        Specified by:
        autoRange在 Axis<T extends Number>
        参数
        length - 屏幕坐标轴的长度
        结果
        范围信息，这是依赖于实现的

      • calculateNewScale

        protected final double calculateNewScale​(double length,
                                         double lowerBound,
                                         double upperBound)
        计算此轴的新刻度。 这不应影响该轴的任何属性。
        参数
        length - 轴的显示长度
        lowerBound - 下限值
        upperBound - 上限值
        结果
        新尺度以适应从给定显示长度的下限到上限的范围

      • autoRange

        protected Object autoRange​(double minValue,
                           double maxValue,
                           double length,
                           double labelSize)
        被要求设置上限和下限以及需要自动调整的任何其他内容。 这不能影响轴的状态。 应在范围对象中返回自动范围的任何结果。 如果已决定为此轴采用此范围，我们将传递给setRange（）。
        参数
        minValue - 需要在此轴上绘制的最小数据值
        maxValue - 需要在此轴上绘制的最大数据值
        length - 显示坐标轴的长度
        labelSize - 标签沿着轴的大致平均尺寸
        结果
        计算范围

      • calculateMinorTickMarks

        protected abstract List<T> calculateMinorTickMarks​()
        计算每个小刻度线的数据值列表
        结果
        数据值列表，用于绘制小刻度线

      • tickMarksUpdated

        protected void tickMarksUpdated​()
        如果已经更新了标记，则在布局期间调用，允许子类在反应中执行所需的任何操作。
        重写：
        tickMarksUpdated在 Axis<T extends Number>

      • layoutChildren

        protected void layoutChildren​()
        在布局传递期间调用以布局此轴及其所有内容。
        重写：
        layoutChildren在 Axis<T extends Number>

      • invalidateRange

        public void invalidateRange​(List<T> data)
        当数据发生变化并且范围可能不再有效时调用。 如果isAutoRanging（）返回true，则仅由图表调用。 如果我们是自动测距，它将导致布局被请求，并且自动测距在下一个布局传递中发生。
        重写：
        invalidateRange在 Axis<T extends Number>
        参数
        data - 需要在此轴上绘制的所有数据的当前集合

      • getDisplayPosition

        public double getDisplayPosition​(T value)
        获取给定值的沿该轴的显示位置。 如果该值不在当前范围内，返回的值将是显示位置的外推。
        Specified by:
        getDisplayPosition在 Axis<T extends Number>
        参数
        value - 要计算的数据值显示位置
        结果
        显示位置

      • getValueForDisplay

        public T getValueForDisplay​(double displayPosition)
        获取此轴上给定显示位置的数据值。 如果轴是一个CategoryAxis，这将是最接近的值。
        Specified by:
        getValueForDisplay在 Axis<T extends Number>
        参数
        displayPosition - 此轴上的像素位置
        结果
        给定像素位置的最近数据值，如果不在轴上则为null;

      • getZeroPosition

        public double getZeroPosition​()
        获取零轴沿该轴的显示位置。
        Specified by:
        getZeroPosition在 Axis<T extends Number>
        结果
        显示位置或Double.NaN如果零不在当前范围内;

      • isValueOnAxis

        public boolean isValueOnAxis​(T value)
        检查给定值是否在该轴上是可绘制的
        Specified by:
        isValueOnAxis在 Axis<T extends Number>
        参数
        value - 检查其轴上的值
        结果
        如果给定值在此轴上是可绘制的，则为true

      • toNumericValue

        public double toNumericValue​(T value)
        所有轴值必须由某些数值表示。 这将获取给定数据值的数值。
        Specified by:
        toNumericValue在 Axis<T extends Number>
        参数
        value - 要转换的数据值
        结果
        给定数据值的数值

      • toRealValue

        public T toRealValue​(double value)
        所有轴值必须由某些数值表示。 这将获取给定数值的数据值。
        Specified by:
        toRealValue在 Axis<T extends Number>
        参数
        value - 要转换的数值
        结果
        给定数值的数据值

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Axis<T extends Number>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


XYChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class XYChart<X,Y>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.chart.Chart
            • javafx.scene.chart.XYChart<X,Y>
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    AreaChart ， BarChart ， BubbleChart ， LineChart ， ScatterChart ， StackedAreaChart ， StackedBarChart

    public abstract class XYChart<X,Y>
extends Chart
    所有2轴图的图表基类。 它负责绘制两个轴和绘图内容。 它包含了绘图中所有内容的列表，XYChart的实现可以将节点添加到需要呈现的列表中。

    可以在数据项/符号上安装工具提示。 例如，以下代码段在第一个数据项上安装Tooltip。

       XYChart.Data item = ( XYChart.Data)series.getData().get(0); Tooltip.install(item.getNode(), new Tooltip("Symbol-0"));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty alternativeColumnFillVisible
      如果为真，则替代垂直列将填充
      BooleanProperty alternativeRowFillVisible
      如果为真，则替代的水平行将填充
      ObjectProperty<ObservableList<XYChart.Series<X,Y>>> data
      XYCharts数据
      BooleanProperty horizontalGridLinesVisible
      如果水平网格线应绘制，则为真
      BooleanProperty horizontalZeroLineVisible
      如果这是真的并且横轴具有正值和负值，则在零点处将绘制另外的轴线
      BooleanProperty verticalGridLinesVisible
      如果绘制垂直网格线，则为真
      BooleanProperty verticalZeroLineVisible
      如果这是真的并且垂直轴具有正值和负值，则在零点处将绘制另外的轴线

      • Properties inherited from class javafx.scene.chart.Chart

        animated, legend, legendSide, legendVisible, title, titleSide

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  XYChart.Data<X,Y>
      具有2轴图数据的单个数据项
      static class  XYChart.Series<X,Y>
      一系列命名的数据项

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      XYChart​(Axis<X> xAxis, Axis<Y> yAxis)
      构造给定两个轴的XYChart。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      BooleanProperty alternativeColumnFillVisibleProperty​()
      如果为真，则替代垂直列将填充
      BooleanProperty alternativeRowFillVisibleProperty​()
      如果为真，则替代的水平行将填充
      protected ObjectProperty<Object> currentDisplayedExtraValueProperty​(XYChart.Data<X,Y> item)
      当前显示的额外值属性。
      protected ObjectProperty<X> currentDisplayedXValueProperty​(XYChart.Data<X,Y> item)
      在X轴上绘制的当前显示的数据值属性。
      protected ObjectProperty<Y> currentDisplayedYValueProperty​(XYChart.Data<X,Y> item)
      在Y轴上绘制的当前显示的数据值属性。
      protected abstract void dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected abstract void dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected abstract void dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      ObjectProperty<ObservableList<XYChart.Series<X,Y>>> dataProperty​()
      XYCharts数据
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      protected Object getCurrentDisplayedExtraValue​(XYChart.Data<X,Y> item)
      当前显示的数据额外值。
      protected X getCurrentDisplayedXValue​(XYChart.Data<X,Y> item)
      当前显示的数据值绘制在X轴上。
      protected Y getCurrentDisplayedYValue​(XYChart.Data<X,Y> item)
      当前显示的数据值绘制在Y轴上。
      ObservableList<XYChart.Series<X,Y>> getData​()
      获取属性数据的值。
      protected Iterator<XYChart.Data<X,Y>> getDisplayedDataIterator​(XYChart.Series<X,Y> series)
      XYChart维护当前显示的所有项目的列表，其中包括所有当前数据+最近删除的正在淡出的数据项。
      protected Iterator<XYChart.Series<X,Y>> getDisplayedSeriesIterator​()
      XYChart维护当前显示的所有系列的列表，其中包括所有当前系列+最近被删除的系列，它们正在被褪色（动画）过程中。
      protected ObservableList<Node> getPlotChildren​()
      情节中所有内容的可修改和可观察的列表。
      boolean getVerticalGridLinesVisible​()
      指示垂直网格线是否可见。
      Axis<X> getXAxis​()
      获取X轴，默认情况下，它是沿着图的底部
      Axis<Y> getYAxis​()
      获取Y轴，默认情况下它在图的左侧
      BooleanProperty horizontalGridLinesVisibleProperty​()
      如果水平网格线应绘制，则为真
      BooleanProperty horizontalZeroLineVisibleProperty​()
      如果这是真的并且横轴具有正值和负值，则在零点处将绘制另外的轴线
      boolean isAlternativeColumnFillVisible​()
      获取propertyColumnFillVisible属性的值。
      boolean isAlternativeRowFillVisible​()
      获取属性alternativeRowFillVisible的值。
      boolean isHorizontalGridLinesVisible​()
      获取属性horizontalGridLinesVisible的值。
      boolean isHorizontalZeroLineVisible​()
      获取属性horizontalZeroLineVisible的值。
      boolean isVerticalZeroLineVisible​()
      获取属性verticalZeroLineVisible的值。
      protected void layoutChartChildren​(double top, double left, double width, double height)
      调用更新和布局从getChartChildren（）
      protected abstract void layoutPlotChildren​()
      被要求更新和布局情节儿童。
      protected void removeDataItemFromDisplay​(XYChart.Series<X,Y> series, XYChart.Data<X,Y> item)
      当您完成从图表中删除该项目的任何动画后，应从dataItemRemoved（）中调用此方法。
      protected void removeSeriesFromDisplay​(XYChart.Series<X,Y> series)
      当您完成从图表中删除该系列的任何动画后，应从serialRemoved（）中调用这个。
      protected abstract void seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      当将每个原子更改作为此图表的系列列表时调用
      protected abstract void seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。
      void setAlternativeColumnFillVisible​(boolean value)
      设置propertyColumnFillVisible属性的值。
      void setAlternativeRowFillVisible​(boolean value)
      设置属性alternativeRowFillVisible的值。
      protected void setCurrentDisplayedExtraValue​(XYChart.Data<X,Y> item, Object value)
      设置当前显示的数据额外值。
      protected void setCurrentDisplayedXValue​(XYChart.Data<X,Y> item, X value)
      设置在X轴上绘制的当前显示数据值。
      protected void setCurrentDisplayedYValue​(XYChart.Data<X,Y> item, Y value)
      设置在Y轴上绘制的当前显示数据值。
      void setData​(ObservableList<XYChart.Series<X,Y>> value)
      设置属性数据的值。
      void setHorizontalGridLinesVisible​(boolean value)
      设置属性horizontalGridLinesVisible的值。
      void setHorizontalZeroLineVisible​(boolean value)
      设置属性horizontalZeroLineVisible的值。
      void setVerticalGridLinesVisible​(boolean value)
      设置属性verticalGridLinesVisible的值。
      void setVerticalZeroLineVisible​(boolean value)
      设置属性verticalZeroLineVisible的值。
      protected void updateAxisRange​()
      当范围已经无效并且我们需要更新时，这被称为。
      protected void updateLegend​()
      每当添加或删除一个系列并且需要更新图例时，就会调用这一点
      BooleanProperty verticalGridLinesVisibleProperty​()
      如果绘制垂直网格线，则为真
      BooleanProperty verticalZeroLineVisibleProperty​()
      如果这是真的并且垂直轴具有正值和负值，则在零点处将绘制另外的轴线

      • Methods inherited from class javafx.scene.chart.Chart

        animate, animatedProperty, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getAnimated, getChartChildren, getLegend, getLegendSide, getTitle, getTitleSide, isLegendVisible, layoutChildren, legendProperty, legendSideProperty, legendVisibleProperty, requestChartLayout, setAnimated, setLegend, setLegendSide, setLegendVisible, setTitle, setTitleSide, shouldAnimate, titleProperty, titleSideProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • data

        public final ObjectProperty<ObservableList<XYChart.Series<X,Y>>> dataProperty
        XYCharts数据
        另请参见：
        getData() ， setData(ObservableList)

      • verticalGridLinesVisible

        public final BooleanProperty verticalGridLinesVisibleProperty
        如果绘制垂直网格线，则为真
        另请参见：
        getVerticalGridLinesVisible() ， setVerticalGridLinesVisible(boolean)

      • horizontalGridLinesVisible

        public final BooleanProperty horizontalGridLinesVisibleProperty
        如果水平网格线应绘制，则为真
        另请参见：
        isHorizontalGridLinesVisible() ， setHorizontalGridLinesVisible(boolean)

      • alternativeColumnFillVisible

        public final BooleanProperty alternativeColumnFillVisibleProperty
        如果为真，则替代垂直列将填充
        另请参见：
        isAlternativeColumnFillVisible() ， setAlternativeColumnFillVisible(boolean)

      • alternativeRowFillVisible

        public final BooleanProperty alternativeRowFillVisibleProperty
        如果为真，则替代的水平行将填充
        另请参见：
        isAlternativeRowFillVisible() ， setAlternativeRowFillVisible(boolean)

      • verticalZeroLineVisible

        public final BooleanProperty verticalZeroLineVisibleProperty
        如果这是真的并且垂直轴具有正值和负值，则在零点处将绘制另外的轴线
        Default value:
        真正
        另请参见：
        isVerticalZeroLineVisible() ， setVerticalZeroLineVisible(boolean)

      • horizontalZeroLineVisible

        public final BooleanProperty horizontalZeroLineVisibleProperty
        如果这是真的并且横轴具有正值和负值，则在零点处将绘制另外的轴线
        Default value:
        真正
        另请参见：
        isHorizontalZeroLineVisible() ， setHorizontalZeroLineVisible(boolean)

    • 构造方法详细信息

      • XYChart

        public XYChart​(Axis<X> xAxis,
               Axis<Y> yAxis)
        构造给定两个轴的XYChart。 添加了包括垂直和水平网格线和填充的图表绘图背景和绘图区域的初始内容。
        参数
        xAxis - 此XY图表的X轴
        yAxis - 此XY图表的Y轴

    • 方法详细信息

      • getXAxis

        public Axis<X> getXAxis​()
        获取X轴，默认情况下，它是沿着图的底部
        结果
        图表的X轴

      • getYAxis

        public Axis<Y> getYAxis​()
        获取Y轴，默认情况下它在图的左侧
        结果
        该图的Y轴

      • getData

        public final ObservableList<XYChart.Series<X,Y>> getData​()
        获取属性数据的值。
        Property description:
        XYCharts数据

      • setData

        public final void setData​(ObservableList<XYChart.Series<X,Y>> value)
        设置属性数据的值。
        Property description:
        XYCharts数据

      • dataProperty

        public final ObjectProperty<ObservableList<XYChart.Series<X,Y>>> dataProperty​()
        XYCharts数据
        另请参见：
        getData() ， setData(ObservableList)

      • getVerticalGridLinesVisible

        public final boolean getVerticalGridLinesVisible​()
        指示垂直网格线是否可见。
        结果
        如果verticalGridLines可见，则为true否则为false。
        另请参见：
        verticalGridLinesVisible

      • setVerticalGridLinesVisible

        public final void setVerticalGridLinesVisible​(boolean value)
        设置属性verticalGridLinesVisible的值。
        Property description:
        如果绘制垂直网格线，则为真

      • verticalGridLinesVisibleProperty

        public final BooleanProperty verticalGridLinesVisibleProperty​()
        如果绘制垂直网格线，则为真
        另请参见：
        getVerticalGridLinesVisible() ， setVerticalGridLinesVisible(boolean)

      • isHorizontalGridLinesVisible

        public final boolean isHorizontalGridLinesVisible​()
        获取属性horizontalGridLinesVisible的值。
        Property description:
        如果水平网格线应绘制，则为真

      • setHorizontalGridLinesVisible

        public final void setHorizontalGridLinesVisible​(boolean value)
        设置属性horizontalGridLinesVisible的值。
        Property description:
        如果水平网格线应绘制，则为真

      • horizontalGridLinesVisibleProperty

        public final BooleanProperty horizontalGridLinesVisibleProperty​()
        如果水平网格线应绘制，则为真
        另请参见：
        isHorizontalGridLinesVisible() ， setHorizontalGridLinesVisible(boolean)

      • isAlternativeColumnFillVisible

        public final boolean isAlternativeColumnFillVisible​()
        获取propertyColumnFillVisible属性的值。
        Property description:
        如果为真，则替代垂直列将填充

      • setAlternativeColumnFillVisible

        public final void setAlternativeColumnFillVisible​(boolean value)
        设置propertyColumnFillVisible属性的值。
        Property description:
        如果为真，则替代垂直列将填充

      • alternativeColumnFillVisibleProperty

        public final BooleanProperty alternativeColumnFillVisibleProperty​()
        如果为真，则替代垂直列将填充
        另请参见：
        isAlternativeColumnFillVisible() ， setAlternativeColumnFillVisible(boolean)

      • isAlternativeRowFillVisible

        public final boolean isAlternativeRowFillVisible​()
        获取属性alternativeRowFillVisible的值。
        Property description:
        如果为真，则替代的水平行将填充

      • setAlternativeRowFillVisible

        public final void setAlternativeRowFillVisible​(boolean value)
        设置属性alternativeRowFillVisible的值。
        Property description:
        如果为真，则替代的水平行将填充

      • alternativeRowFillVisibleProperty

        public final BooleanProperty alternativeRowFillVisibleProperty​()
        如果为真，则替代的水平行将填充
        另请参见：
        isAlternativeRowFillVisible() ， setAlternativeRowFillVisible(boolean)

      • isVerticalZeroLineVisible

        public final boolean isVerticalZeroLineVisible​()
        获取属性verticalZeroLineVisible的值。
        Property description:
        如果这是真的并且垂直轴具有正值和负值，则在零点处将绘制另外的轴线
        Default value:
        真正

      • setVerticalZeroLineVisible

        public final void setVerticalZeroLineVisible​(boolean value)
        设置属性verticalZeroLineVisible的值。
        Property description:
        如果这是真的并且垂直轴具有正值和负值，则在零点处将绘制另外的轴线
        Default value:
        真正

      • verticalZeroLineVisibleProperty

        public final BooleanProperty verticalZeroLineVisibleProperty​()
        如果这是真的并且垂直轴具有正值和负值，则在零点处将绘制另外的轴线
        Default value:
        真正
        另请参见：
        isVerticalZeroLineVisible() ， setVerticalZeroLineVisible(boolean)

      • isHorizontalZeroLineVisible

        public final boolean isHorizontalZeroLineVisible​()
        获取属性horizontalZeroLineVisible的值。
        Property description:
        如果这是真的并且横轴具有正值和负值，则在零点处将绘制另外的轴线
        Default value:
        真正

      • setHorizontalZeroLineVisible

        public final void setHorizontalZeroLineVisible​(boolean value)
        设置属性horizontalZeroLineVisible的值。
        Property description:
        如果这是真的并且横轴具有正值和负值，则在零点处将绘制另外的轴线
        Default value:
        真正

      • horizontalZeroLineVisibleProperty

        public final BooleanProperty horizontalZeroLineVisibleProperty​()
        如果这是真的并且横轴具有正值和负值，则在零点处将绘制另外的轴线
        Default value:
        真正
        另请参见：
        isHorizontalZeroLineVisible() ， setHorizontalZeroLineVisible(boolean)

      • getPlotChildren

        protected ObservableList<Node> getPlotChildren​()
        情节中所有内容的可修改和可观察的列表。 这是XYChart的实现应该添加任何用于绘制绘图的节点。
        结果
        可观察的情节儿童列表

      • updateLegend

        protected void updateLegend​()
        每当添加或删除一个系列并且需要更新图例时，就会调用这一点

      • dataItemAdded

        protected abstract void dataItemAdded​(XYChart.Series<X,Y> series,
                                      int itemIndex,
                                      XYChart.Data<X,Y> item)
        将数据项添加到系列时调用。 这是XYChart的实现可以创建/添加新节点，以使getPlotChildren表示此数据项。 如果animated = true，他们也可以将数据添加为淡入淡出或相似。
        参数
        series - 数据项被添加到的系列
        itemIndex - 系列中新项目的索引
        item - 添加的新数据项

      • dataItemRemoved

        protected abstract void dataItemRemoved​(XYChart.Data<X,Y> item,
                                        XYChart.Series<X,Y> series)
        当数据项已从数据模型中删除但在图表上仍然可见时调用。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeDataItemFromDisplay（）来删除项目节点不显示在图表上。
        参数
        item - 从系列中删除的项目
        series - 该项目已被删除

      • dataItemChanged

        protected abstract void dataItemChanged​(XYChart.Data<X,Y> item)
        数据项已更改时调用，即其xValue，yValue或extraValue已更改。
        参数
        item - 已更改的数据项

      • seriesAdded

        protected abstract void seriesAdded​(XYChart.Series<X,Y> series,
                                    int seriesIndex)
        一系列已经添加到图表数据模型中。 这是XYChart的实现可以创建/添加新的节点来getPlotChildren来表示这个系列。 此外，您必须处理添加已经在系列中的任何数据项。 您可以简单地为每一个调用dataItemAdded（），或为要添加的整个系列提供一些不同的动画。
        参数
        series - 已添加的系列
        seriesIndex - 新系列的索引

      • seriesRemoved

        protected abstract void seriesRemoved​(XYChart.Series<X,Y> series)
        数据模型中已经删除了一个系列，但它仍然可以在图表上显示。 它仍然可见，以便您可以处理动画，以删除它在这种方法。 完成动画数据项后，您必须调用removeSeriesFromDisplay（）从显示列表中删除该系列。
        参数
        series - 已被删除的系列

      • seriesChanged

        protected void seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
        当将每个原子更改作为此图表的系列列表时调用
        参数
        c - 表示系列更改的更改实例

      • updateAxisRange

        protected void updateAxisRange​()
        当范围已经无效并且我们需要更新时，这被称为。 如果轴是自动测距，那么我们编译给定轴必须绘制的所有数据的列表，并在传递该数据的轴上调用invalidateRange（）。

      • layoutPlotChildren

        protected abstract void layoutPlotChildren​()
        被要求更新和布局情节儿童。 这应该包括更新表示轴和网格线顶部的图的节点的所有工作。原点是绘图区域的左上角，绘制区域可以通过获取x轴的宽度及其高度从y轴的高度。

      • layoutChartChildren

        protected final void layoutChartChildren​(double top,
                                         double left,
                                         double width,
                                         double height)
        调用更新和布局从getChartChildren（）
        Specified by:
        layoutChartChildren在 Chart
        参数
        top - 从原点的顶部偏移量，以解释图表内容上的任何填充
        left - 从原点向左偏移以计算图表内容上的任何填充
        width - 布局图表的区域的宽度
        height - 布局图表的区域的高度

      • removeSeriesFromDisplay

        protected final void removeSeriesFromDisplay​(XYChart.Series<X,Y> series)
        当您完成从图表中删除该系列的任何动画后，应从serialRemoved（）中调用这个。 它将删除该系列不显示在getDisplayedSeriesIterator（）返回的Iterator中。
        参数
        series - 要删除的系列

      • getDisplayedSeriesIterator

        protected final Iterator<XYChart.Series<X,Y>> getDisplayedSeriesIterator​()
        XYChart维护当前显示的所有系列的列表，其中包括所有当前系列+最近被删除的系列，它们正在被褪色（动画）过程中。 这将创建并返回该列表的迭代器。 这是XYChart在绘制数据时应该使用的实现方式。
        结果
        迭代器超过当前显示的系列

      • getCurrentDisplayedXValue

        protected final X getCurrentDisplayedXValue​(XYChart.Data<X,Y> item)
        当前显示的数据值绘制在X轴上。 这可能与xValue或不同的相同。 XYChart使用它将xValue从旧值设为新值。 这是您应该在任何自定义XYChart实现中绘制的。 一些XYChart图表实现（如LineChart）也可以使用此功能在添加或删除数据时进行动画处理。
        参数
        item - 获取当前X轴数据值的XYChart.Data项目
        结果
        当前显示的X数据值

      • setCurrentDisplayedXValue

        protected final void setCurrentDisplayedXValue​(XYChart.Data<X,Y> item,
                                               X value)
        设置在X轴上绘制的当前显示数据值。
        参数
        item - 获取当前X轴数据值的XYChart.Data项目。
        value - X轴数据值
        另请参见：
        getCurrentDisplayedXValue(javafx.scene.chart.XYChart.Data<X, Y>)

      • currentDisplayedXValueProperty

        protected final ObjectProperty<X> currentDisplayedXValueProperty​(XYChart.Data<X,Y> item)
        在X轴上绘制的当前显示的数据值属性。
        参数
        item - 获取当前X轴数据值属性对象的XYChart.Data项。
        结果
        当前显示的X数据值ObjectProperty。
        另请参见：
        getCurrentDisplayedXValue(javafx.scene.chart.XYChart.Data<X, Y>)

      • getCurrentDisplayedYValue

        protected final Y getCurrentDisplayedYValue​(XYChart.Data<X,Y> item)
        当前显示的数据值绘制在Y轴上。 这可能与yValue或不同的相同。 它由XYChart用于将yValue从旧值设为新值。 这是您应该在任何自定义XYChart实现中绘制的。 一些XYChart图表实现（如LineChart）也可以使用此功能在添加或删除数据时进行动画处理。
        参数
        item - 获取当前Y轴数据值的XYChart.Data项目
        结果
        当前显示的Y数据值

      • setCurrentDisplayedYValue

        protected final void setCurrentDisplayedYValue​(XYChart.Data<X,Y> item,
                                               Y value)
        设置在Y轴上绘制的当前显示数据值。
        参数
        item - 获取当前Y轴数据值的XYChart.Data项目。
        value - Y轴数据值
        另请参见：
        getCurrentDisplayedYValue(javafx.scene.chart.XYChart.Data<X, Y>)

      • currentDisplayedYValueProperty

        protected final ObjectProperty<Y> currentDisplayedYValueProperty​(XYChart.Data<X,Y> item)
        在Y轴上绘制的当前显示的数据值属性。
        参数
        item - 从中获取当前Y轴数据值属性对象的XYChart.Data项。
        结果
        当前显示的Y数据值为ObjectProperty。
        另请参见：
        getCurrentDisplayedYValue(javafx.scene.chart.XYChart.Data<X, Y>)

      • getCurrentDisplayedExtraValue

        protected final Object getCurrentDisplayedExtraValue​(XYChart.Data<X,Y> item)
        当前显示的数据额外值。 这可能与extraValue或不同的相同。 它由XYChart用于将extraValue从旧值设为新值。 这是您应该在任何自定义XYChart实现中绘制的。
        参数
        item - 获取当前额外值的XYChart.Data项目
        结果
        当前的额外值

      • setCurrentDisplayedExtraValue

        protected final void setCurrentDisplayedExtraValue​(XYChart.Data<X,Y> item,
                                                   Object value)
        设置当前显示的数据额外值。
        参数
        item - 获取当前额外值的XYChart.Data项目。
        value - 额外的价值
        另请参见：
        getCurrentDisplayedExtraValue(javafx.scene.chart.XYChart.Data<X, Y>)

      • currentDisplayedExtraValueProperty

        protected final ObjectProperty<Object> currentDisplayedExtraValueProperty​(XYChart.Data<X,Y> item)
        当前显示的额外值属性。
        参数
        item - 获取当前额外值属性对象的XYChart.Data项。
        结果
        ObjectProperty <Object>当前额外的值ObjectProperty
        另请参见：
        getCurrentDisplayedExtraValue(javafx.scene.chart.XYChart.Data<X, Y>)

      • getDisplayedDataIterator

        protected final Iterator<XYChart.Data<X,Y>> getDisplayedDataIterator​(XYChart.Series<X,Y> series)
        XYChart维护当前显示的所有项目的列表，其中包括所有当前数据+最近删除的正在淡出的数据项。 这将创建并返回该列表的迭代器。 这是XYChart在绘制数据时应该使用的实现方式。
        参数
        series - 获取显示数据的系列
        结果
        从本系列中显示当前显示的项目的迭代器

      • removeDataItemFromDisplay

        protected final void removeDataItemFromDisplay​(XYChart.Series<X,Y> series,
                                               XYChart.Data<X,Y> item)
        当您完成从图表中删除该项目的任何动画后，应从dataItemRemoved（）中调用此方法。 它将从getDisplayedDataIterator（）返回的Iterator中删除数据项。
        参数
        series - 要删除的系列
        item - 要从系列显示列表中删除的项目

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Chart
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


XYChart.Data (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class XYChart.Data<X,Y>

  • java.lang.Object
    • javafx.scene.chart.XYChart.Data<X,Y>
  • Enclosing class:
    XYChart < X ， Y >

    public static final class XYChart.Data<X,Y>
extends Object
    具有2轴图数据的单个数据项
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Object> extraValue
      以图表所需的任何方式绘制的通用数据值。
      ObjectProperty<Node> node
      要显示此数据项的节点。
      ObjectProperty<X> XValue
      要在X轴上绘制的通用数据值。
      ObjectProperty<Y> YValue
      在Y轴上绘制的通用数据值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Data​()
      创建一个空XYChart.Data对象。
      Data​(X xValue, Y yValue)
      创建一个XYChart.Data对象的实例，并初始化X，Y数据值。
      Data​(X xValue, Y yValue, Object extraValue)
      创建XYChart.Data对象的实例，并初始化X，Y数据值和extraValue。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Object> extraValueProperty​()
      以图表所需的任何方式绘制的通用数据值。
      Object getExtraValue​()
      获取属性extraValue的值。
      Node getNode​()
      获取属性节点的值。
      X getXValue​()
      获取在X轴上绘制的通用数据值。
      Y getYValue​()
      获取在Y轴上绘制的通用数据值。
      ObjectProperty<Node> nodeProperty​()
      要显示此数据项的节点。
      void setExtraValue​(Object value)
      设置属性extraValue的值。
      void setNode​(Node value)
      设置属性节点的值。
      void setXValue​(X value)
      设置在X轴上绘制的通用数据值。
      void setYValue​(Y value)
      设置在Y轴上绘制的通用数据值。
      String toString​()
      返回此 Data对象的字符串表示形式。
      ObjectProperty<X> XValueProperty​()
      要在X轴上绘制的通用数据值。
      ObjectProperty<Y> YValueProperty​()
      在Y轴上绘制的通用数据值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • XValue

        public final ObjectProperty<X> XValueProperty
        要在X轴上绘制的通用数据值。
        另请参见：
        getXValue() ， setXValue(X)

      • YValue

        public final ObjectProperty<Y> YValueProperty
        在Y轴上绘制的通用数据值。
        另请参见：
        getYValue() ， setYValue(Y)

      • extraValue

        public final ObjectProperty<Object> extraValueProperty
        以图表所需的任何方式绘制的通用数据值。 例如用作BubbleChart的半径。
        另请参见：
        getExtraValue() ， setExtraValue(Object)

      • node

        public final ObjectProperty<Node> nodeProperty
        要显示此数据项的节点。 在将项目添加到图表之前，您可以创建自己的节点并将其设置在数据项上。 否则，图表将为您创建一个具有图表类型的默认表示形式的节点。 一旦将数据添加到图表，该节点将被设置。 然后，您可以获取它添加鼠标监听器等。图表将尽可能地适当地定位和定位节点，例如在线或散点图上，该节点将以数据值位置为中心。 对于条形图，它被定位并被调整为该数据项的条。
        另请参见：
        getNode() ， setNode(Node)

    • 构造方法详细信息

      • Data

        public Data​()
        创建一个空XYChart.Data对象。

      • Data

        public Data​(X xValue,
            Y yValue)
        创建一个XYChart.Data对象的实例，并初始化X，Y数据值。
        参数
        xValue - X轴数据值
        yValue - Y轴数据值

      • Data

        public Data​(X xValue,
            Y yValue,
            Object extraValue)
        创建XYChart.Data对象的实例，并初始化X，Y数据值和extraValue。
        参数
        xValue - X轴数据值。
        yValue - Y轴数据值。
        extraValue - 图表额外价值。

    • 方法详细信息

      • getXValue

        public final X getXValue​()
        获取在X轴上绘制的通用数据值。
        结果
        在X轴上绘制的通用数据值。

      • setXValue

        public final void setXValue​(X value)
        设置在X轴上绘制的通用数据值。
        参数
        value - 要在X轴上绘制的通用数据值。

      • XValueProperty

        public final ObjectProperty<X> XValueProperty​()
        要在X轴上绘制的通用数据值。
        另请参见：
        getXValue() ， setXValue(X)

      • getYValue

        public final Y getYValue​()
        获取在Y轴上绘制的通用数据值。
        结果
        要在Y轴上绘制的通用数据值。

      • setYValue

        public final void setYValue​(Y value)
        设置在Y轴上绘制的通用数据值。
        参数
        value - 在Y轴上绘制的通用数据值。

      • YValueProperty

        public final ObjectProperty<Y> YValueProperty​()
        在Y轴上绘制的通用数据值。
        另请参见：
        getYValue() ， setYValue(Y)

      • getExtraValue

        public final Object getExtraValue​()
        获取属性extraValue的值。
        Property description:
        以图表所需的任何方式绘制的通用数据值。 例如用作BubbleChart的半径。

      • setExtraValue

        public final void setExtraValue​(Object value)
        设置属性extraValue的值。
        Property description:
        以图表所需的任何方式绘制的通用数据值。 例如用作BubbleChart的半径。

      • extraValueProperty

        public final ObjectProperty<Object> extraValueProperty​()
        以图表所需的任何方式绘制的通用数据值。 例如用作BubbleChart的半径。
        另请参见：
        getExtraValue() ， setExtraValue(Object)

      • getNode

        public final Node getNode​()
        获取属性节点的值。
        Property description:
        要显示此数据项的节点。 在将项目添加到图表之前，您可以创建自己的节点并将其设置在数据项上。 否则，图表将为您创建一个具有图表类型的默认表示形式的节点。 一旦将数据添加到图表，该节点将被设置。 然后，您可以获取它添加鼠标监听器等。图表将尽可能地适当地定位和定位节点，例如在线或散点图上，该节点将以数据值位置为中心。 对于条形图，它被定位并被调整为该数据项的条。

      • setNode

        public final void setNode​(Node value)
        设置属性节点的值。
        Property description:
        要显示此数据项的节点。 在将项目添加到图表之前，您可以创建自己的节点并将其设置在数据项上。 否则，图表将为您创建一个具有图表类型的默认表示形式的节点。 一旦将数据添加到图表，该节点将被设置。 然后，您可以获取它添加鼠标监听器等。图表将尽可能地适当地定位和定位节点，例如在线或散点图上，该节点将以数据值位置为中心。 对于条形图，它被定位并被调整为该数据项的条。

      • nodeProperty

        public final ObjectProperty<Node> nodeProperty​()
        要显示此数据项的节点。 在将项目添加到图表之前，您可以创建自己的节点并将其设置在数据项上。 否则，图表将为您创建一个具有图表类型的默认表示形式的节点。 一旦将数据添加到图表，该节点将被设置。 然后，您可以获取它添加鼠标监听器等。图表将尽可能地适当地定位和定位节点，例如在线或散点图上，该节点将以数据值位置为中心。 对于条形图，它被定位并被调整为该数据项的条。
        另请参见：
        getNode() ， setNode(Node)

      • toString

        public String toString​()
        返回此 Data对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 Data对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


XYChart.Series (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.chart

Class XYChart.Series<X,Y>

  • java.lang.Object
    • javafx.scene.chart.XYChart.Series<X,Y>
  • Enclosing class:
    XYChart < X ， Y >

    public static final class XYChart.Series<X,Y>
extends Object
    一系列命名的数据项
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<XYChart<X,Y>> chart
      参考本系列所属的图表
      ObjectProperty<ObservableList<XYChart.Data<X,Y>>> data
      ObservableList组成本系列的数据项
      StringProperty name
      该系列的用户可显示的名称
      ObjectProperty<Node> node
      该系列显示的节点。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Series​()
      构建一个空的系列
      Series​(String name, ObservableList<XYChart.Data<X,Y>> data)
      构造一个命名的系列，并使用给定的ObservableList数据填充它。
      Series​(ObservableList<XYChart.Data<X,Y>> data)
      构造一个系列，并使用给定的ObservableList数据填充它。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<XYChart<X,Y>> chartProperty​()
      参考本系列所属的图表
      ObjectProperty<ObservableList<XYChart.Data<X,Y>>> dataProperty​()
      ObservableList组成本系列的数据项
      XYChart<X,Y> getChart​()
      获取属性图表的值。
      ObservableList<XYChart.Data<X,Y>> getData​()
      获取属性数据的值。
      String getName​()
      获取属性名称的值。
      Node getNode​()
      获取属性节点的值。
      StringProperty nameProperty​()
      该系列的用户可显示的名称
      ObjectProperty<Node> nodeProperty​()
      该系列显示的节点。
      void setData​(ObservableList<XYChart.Data<X,Y>> value)
      设置属性数据的值。
      void setName​(String value)
      设置属性名称的值。
      void setNode​(Node value)
      设置属性节点的值。
      String toString​()
      返回此 Series对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • chart

        public final ReadOnlyObjectProperty<XYChart<X,Y>> chartProperty
        参考本系列所属的图表
        另请参见：
        getChart()

      • name

        public final StringProperty nameProperty
        该系列的用户可显示的名称
        另请参见：
        getName() ， setName(String)

      • node

        public final ObjectProperty<Node> nodeProperty
        该系列显示的节点。 如果它使用节点来表示整个系列，则由图表创建。 例如，折线图用于此行，但散点图不使用它。 一旦将该系列添加到图表，该节点将被设置。 然后可以让它添加鼠标监听器等
        另请参见：
        getNode() ， setNode(Node)

      • data

        public final ObjectProperty<ObservableList<XYChart.Data<X,Y>>> dataProperty
        ObservableList组成本系列的数据项
        另请参见：
        getData() ， setData(ObservableList)

    • 构造方法详细信息

      • Series

        public Series​()
        构建一个空的系列

      • Series

        public Series​(ObservableList<XYChart.Data<X,Y>> data)
        构造一个系列，并使用给定的ObservableList数据填充它。
        参数
        data - data ObservableList

      • Series

        public Series​(String name,
              ObservableList<XYChart.Data<X,Y>> data)
        构造一个命名的系列，并用给定的ObservableList数据填充它。
        参数
        name - 系列的名称
        data - data ObservableList

    • 方法详细信息

      • getChart

        public final XYChart<X,Y> getChart​()
        获取属性图表的值。
        Property description:
        参考本系列所属的图表

      • chartProperty

        public final ReadOnlyObjectProperty<XYChart<X,Y>> chartProperty​()
        参考本系列所属的图表
        另请参见：
        getChart()

      • getName

        public final String getName​()
        获取属性名称的值。
        Property description:
        该系列的用户可显示的名称

      • setName

        public final void setName​(String value)
        设置属性名称的值。
        Property description:
        该系列的用户可显示的名称

      • nameProperty

        public final StringProperty nameProperty​()
        该系列的用户可显示的名称
        另请参见：
        getName() ， setName(String)

      • getNode

        public final Node getNode​()
        获取属性节点的值。
        Property description:
        该系列显示的节点。 如果它使用节点来表示整个系列，则由图表创建。 例如，折线图用于此行，但散点图不使用它。 一旦将该系列添加到图表，该节点将被设置。 然后可以让它添加鼠标监听器等

      • setNode

        public final void setNode​(Node value)
        设置属性节点的值。
        Property description:
        该系列显示的节点。 如果它使用节点来表示整个系列，则由图表创建。 例如，折线图用于此行，但散点图不使用它。 一旦将该系列添加到图表，该节点将被设置。 然后可以让它添加鼠标监听器等

      • nodeProperty

        public final ObjectProperty<Node> nodeProperty​()
        该系列显示的节点。 如果它使用节点来表示整个系列，则由图表创建。 例如，折线图用于此行，但散点图不使用它。 一旦将该系列添加到图表，该节点将被设置。 然后可以让它添加鼠标监听器等
        另请参见：
        getNode() ， setNode(Node)

      • getData

        public final ObservableList<XYChart.Data<X,Y>> getData​()
        获取属性数据的值。
        Property description:
        ObservableList组成本系列的数据项

      • setData

        public final void setData​(ObservableList<XYChart.Data<X,Y>> value)
        设置属性数据的值。
        Property description:
        ObservableList组成本系列的数据项

      • dataProperty

        public final ObjectProperty<ObservableList<XYChart.Data<X,Y>>> dataProperty​()
        ObservableList组成本系列的数据项
        另请参见：
        getData() ， setData(ObservableList)

      • toString

        public String toString​()
        返回此 Series对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of this Series object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.scene.chart.AreaChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.AreaChart

No usage of javafx.scene.chart.AreaChart
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.Axis (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.Axis

  • Packages that use Axis
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of Axis in javafx.scene.chart

      Subclasses of Axis in javafx.scene.chart
      Modifier and Type Class 描述
      class  CategoryAxis
      一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。
      class  NumberAxis
      一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
      class  ValueAxis<T extends Number>
      数据定义为数字的轴。
      Methods in javafx.scene.chart that return Axis
      Modifier and Type 方法 描述
      Axis<X> XYChart.getXAxis​()
      获取X轴，默认情况下，它是沿着图的底部
      Axis<Y> XYChart.getYAxis​()
      获取Y轴，默认情况下它在图的左侧
      Constructors in javafx.scene.chart with parameters of type Axis
      Constructor 描述
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定轴构建新的区域图
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定的轴构建一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      用给定的轴和数据构造一个新的BarChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴构建一个新的BubbleChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的BubbleChart。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定的轴构造一个新的LineChart。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的LineChart。
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴和数据构造新的ScatterChart。
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造新的ScatterChart。
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis)
      用给定轴构建新的区域图
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis)
      使用给定的轴构建一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      使用给定的轴和数据构造一个新的StackedBarChart。
      XYChart​(Axis<X> xAxis, Axis<Y> yAxis)
      构造给定两个轴的XYChart。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.Axis.TickMark (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.Axis.TickMark

  • Packages that use Axis.TickMark
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of Axis.TickMark in javafx.scene.chart

      Methods in javafx.scene.chart that return types with arguments of type Axis.TickMark
      Modifier and Type 方法 描述
      ObservableList<Axis.TickMark<T>> Axis.getTickMarks​()
      不可修改的可观察的刻度表列表，每个TickMark在此轴上直接表示一个刻度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.BarChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.BarChart

No usage of javafx.scene.chart.BarChart
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.BubbleChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.BubbleChart

No usage of javafx.scene.chart.BubbleChart
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.CategoryAxis (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.CategoryAxis

No usage of javafx.scene.chart.CategoryAxis
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.Chart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.Chart

  • Packages that use Chart
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of Chart in javafx.scene.chart

      Subclasses of Chart in javafx.scene.chart
      Modifier and Type Class 描述
      class  AreaChart<X,Y>
      AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
      class  BarChart<X,Y>
      绘制一个指示类别数据值的条形图。
      class  BubbleChart<X,Y>
      为一系列数据点绘制气泡的图表类型。
      class  LineChart<X,Y>
      线图绘制了连接数据点的行。
      class  PieChart
      显示PieChart。
      class  ScatterChart<X,Y>
      绘制一系列数据点符号的图表类型。
      class  StackedAreaChart<X,Y>
      StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。
      class  StackedBarChart<X,Y>
      StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。
      class  XYChart<X,Y>
      所有2轴图的图表基类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.LineChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.LineChart

No usage of javafx.scene.chart.LineChart
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.LineChart.SortingPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.LineChart.SortingPolicy

  • Packages that use LineChart.SortingPolicy
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of LineChart.SortingPolicy in javafx.scene.chart

      Methods in javafx.scene.chart that return LineChart.SortingPolicy
      Modifier and Type 方法 描述
      LineChart.SortingPolicy LineChart.getAxisSortingPolicy​()
      获取属性axisSortingPolicy的值。
      static LineChart.SortingPolicy LineChart.SortingPolicy.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static LineChart.SortingPolicy[] LineChart.SortingPolicy.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.chart that return types with arguments of type LineChart.SortingPolicy
      Modifier and Type 方法 描述
      ObjectProperty<LineChart.SortingPolicy> LineChart.axisSortingPolicyProperty​()
      指示传递给LineChart的数据是否应按其中一个轴的自然顺序进行排序。
      Methods in javafx.scene.chart with parameters of type LineChart.SortingPolicy
      Modifier and Type 方法 描述
      void LineChart.setAxisSortingPolicy​(LineChart.SortingPolicy value)
      设置属性axisSortingPolicy的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.NumberAxis (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.NumberAxis

  • Packages that use NumberAxis
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of NumberAxis in javafx.scene.chart

      Constructors in javafx.scene.chart with parameters of type NumberAxis
      Constructor 描述
      DefaultFormatter​(NumberAxis axis)
      为给定的NumberAxis构造一个DefaultFormatter
      DefaultFormatter​(NumberAxis axis, String prefix, String suffix)
      为给定的NumberAxis构造一个带有前缀和/或后缀的DefaultFormatter。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.NumberAxis.DefaultFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.NumberAxis.DefaultFormatter

No usage of javafx.scene.chart.NumberAxis.DefaultFormatter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.PieChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.PieChart

  • Packages that use PieChart
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of PieChart in javafx.scene.chart

      Methods in javafx.scene.chart that return PieChart
      Modifier and Type 方法 描述
      PieChart PieChart.Data.getChart​()
      获取属性图表的值。
      Methods in javafx.scene.chart that return types with arguments of type PieChart
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<PieChart> PieChart.Data.chartProperty​()
      该数据所属的图表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.PieChart.Data (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.PieChart.Data

  • Packages that use PieChart.Data
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of PieChart.Data in javafx.scene.chart

      Methods in javafx.scene.chart that return types with arguments of type PieChart.Data
      Modifier and Type 方法 描述
      ObjectProperty<ObservableList<PieChart.Data>> PieChart.dataProperty​()
      PieCharts数据
      ObservableList<PieChart.Data> PieChart.getData​()
      获取属性数据的值。
      Method parameters in javafx.scene.chart with type arguments of type PieChart.Data
      Modifier and Type 方法 描述
      void PieChart.setData​(ObservableList<PieChart.Data> value)
      设置属性数据的值。
      Constructor parameters in javafx.scene.chart with type arguments of type PieChart.Data
      Constructor 描述
      PieChart​(ObservableList<PieChart.Data> data)
      用给定的数据构建一个新的PieChart
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.ScatterChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.ScatterChart

No usage of javafx.scene.chart.ScatterChart
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.StackedAreaChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.StackedAreaChart

No usage of javafx.scene.chart.StackedAreaChart
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.StackedBarChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.StackedBarChart

No usage of javafx.scene.chart.StackedBarChart
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.ValueAxis (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.ValueAxis

  • Packages that use ValueAxis
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of ValueAxis in javafx.scene.chart

      Subclasses of ValueAxis in javafx.scene.chart
      Modifier and Type Class 描述
      class  NumberAxis
      一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.XYChart (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.XYChart

  • Packages that use XYChart
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of XYChart in javafx.scene.chart

      Subclasses of XYChart in javafx.scene.chart
      Modifier and Type Class 描述
      class  AreaChart<X,Y>
      AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
      class  BarChart<X,Y>
      绘制一个指示类别数据值的条形图。
      class  BubbleChart<X,Y>
      为一系列数据点绘制气泡的图表类型。
      class  LineChart<X,Y>
      线图绘制了连接数据点的行。
      class  ScatterChart<X,Y>
      绘制一系列数据点符号的图表类型。
      class  StackedAreaChart<X,Y>
      StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。
      class  StackedBarChart<X,Y>
      StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。
      Methods in javafx.scene.chart that return XYChart
      Modifier and Type 方法 描述
      XYChart<X,Y> XYChart.Series.getChart​()
      获取属性图表的值。
      Methods in javafx.scene.chart that return types with arguments of type XYChart
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<XYChart<X,Y>> XYChart.Series.chartProperty​()
      参考本系列所属的图表
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.XYChart.Data (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.XYChart.Data

  • Packages that use XYChart.Data
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of XYChart.Data in javafx.scene.chart

      Methods in javafx.scene.chart that return types with arguments of type XYChart.Data
      Modifier and Type 方法 描述
      ObjectProperty<ObservableList<XYChart.Data<X,Y>>> XYChart.Series.dataProperty​()
      ObservableList组成本系列的数据项
      ObservableList<XYChart.Data<X,Y>> XYChart.Series.getData​()
      获取属性数据的值。
      protected Iterator<XYChart.Data<X,Y>> XYChart.getDisplayedDataIterator​(XYChart.Series<X,Y> series)
      XYChart维护当前显示的所有项目的列表，其中包括所有当前数据+最近删除的正在淡出的数据项。
      Methods in javafx.scene.chart with parameters of type XYChart.Data
      Modifier and Type | 方法 | 描述
      protected ObjectProperty<Object> XYChart.currentDisplayedExtraValueProperty​(XYChart.Data<X,Y> item)
      当前显示的额外值属性。
      protected ObjectProperty<X> XYChart.currentDisplayedXValueProperty​(XYChart.Data<X,Y> item)
      在X轴上绘制的当前显示的数据值属性。
      protected ObjectProperty<Y> XYChart.currentDisplayedYValueProperty​(XYChart.Data<X,Y> item)
      在Y轴上绘制的当前显示的数据值属性。
      protected void | AreaChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void | BarChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void | BubbleChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void | LineChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void ScatterChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void | StackedAreaChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void | StackedBarChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected abstract void XYChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void AreaChart.dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void BarChart.dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void BubbleChart.dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void LineChart.dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void ScatterChart.dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void StackedAreaChart.dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void StackedBarChart.dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected abstract void XYChart.dataItemChanged​(XYChart.Data<X,Y> item)
      数据项已更改时调用，即其xValue，yValue或extraValue已更改。
      protected void | AreaChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void | BarChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void | BubbleChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void | LineChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void ScatterChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      protected void | StackedAreaChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void | StackedBarChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected abstract void XYChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      protected Object XYChart.getCurrentDisplayedExtraValue​(XYChart.Data<X,Y> item)
      当前显示的数据额外值。
      protected X XYChart.getCurrentDisplayedXValue​(XYChart.Data<X,Y> item)
      当前显示的数据值绘制在X轴上。
      protected Y XYChart.getCurrentDisplayedYValue​(XYChart.Data<X,Y> item)
      当前显示的数据值绘制在Y轴上。
      protected void XYChart.removeDataItemFromDisplay​(XYChart.Series<X,Y> series, XYChart.Data<X,Y> item)
      当您完成从图表中删除该项目的任何动画后，应从dataItemRemoved（）中调用此方法。
      protected void XYChart.setCurrentDisplayedExtraValue​(XYChart.Data<X,Y> item, Object value)
      设置当前显示的数据额外值。
      protected void XYChart.setCurrentDisplayedXValue​(XYChart.Data<X,Y> item, X value)
      设置在X轴上绘制的当前显示数据值。
      protected void XYChart.setCurrentDisplayedYValue​(XYChart.Data<X,Y> item, Y value)
      设置在Y轴上绘制的当前显示数据值。
      Method parameters in javafx.scene.chart with type arguments of type XYChart.Data
      Modifier and Type 方法 描述
      void XYChart.Series.setData​(ObservableList<XYChart.Data<X,Y>> value)
      设置属性数据的值。
      Constructor parameters in javafx.scene.chart with type arguments of type XYChart.Data
      Constructor 描述
      Series​(String name, ObservableList<XYChart.Data<X,Y>> data)
      构造一个命名的系列，并使用给定的ObservableList数据填充它。
      Series​(ObservableList<XYChart.Data<X,Y>> data)
      构造一个系列，并使用给定的数据填充它ObservableList 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.chart.XYChart.Series (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.chart.XYChart.Series

  • Packages that use XYChart.Series
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

    • Uses of XYChart.Series in javafx.scene.chart

      Methods in javafx.scene.chart that return types with arguments of type XYChart.Series
      Modifier and Type 方法 描述
      ObjectProperty<ObservableList<XYChart.Series<X,Y>>> XYChart.dataProperty​()
      XYCharts数据
      ObservableList<XYChart.Series<X,Y>> XYChart.getData​()
      获取属性数据的值。
      protected Iterator<XYChart.Series<X,Y>> XYChart.getDisplayedSeriesIterator​()
      XYChart维护当前显示的所有系列的列表，其中包括所有当前系列+最近被删除的系列，它们正在被褪色（动画）过程中。
      Methods in javafx.scene.chart with parameters of type XYChart.Series
      Modifier and Type | 方法 | 描述
      protected void | AreaChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void | BarChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void | BubbleChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void | LineChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void ScatterChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void | StackedAreaChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected void | StackedBarChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      protected abstract void XYChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)
      将数据项添加到系列时调用。
      protected void | AreaChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void | BarChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void | BubbleChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void | LineChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void ScatterChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      protected void | StackedAreaChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected void | StackedBarChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      protected abstract void XYChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)
      当数据项已从数据模型中删除但在图表上仍然可见时调用。
      protected Iterator<XYChart.Data<X,Y>> XYChart.getDisplayedDataIterator​(XYChart.Series<X,Y> series)
      XYChart维护当前显示的所有项目的列表，其中包括所有当前数据+最近删除的正在淡出的数据项。
      protected void XYChart.removeDataItemFromDisplay​(XYChart.Series<X,Y> series, XYChart.Data<X,Y> item)
      当您完成从图表中删除该项目的任何动画后，应从dataItemRemoved（）中调用此方法。
      protected void XYChart.removeSeriesFromDisplay​(XYChart.Series<X,Y> series)
      当您完成从图表中删除该系列的任何动画后，应从serialRemoved（）中调用这个。
      protected void | AreaChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      protected void | BarChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      protected void | BubbleChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      protected void | LineChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      protected void ScatterChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void | StackedAreaChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      protected void StackedBarChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected abstract void XYChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)
      一系列已经添加到图表数据模型中。
      protected void | AreaChart.seriesRemoved​(XYChart.Series<X,Y> series)
      protected void | BarChart.seriesRemoved​(XYChart.Series<X,Y> series)
      protected void | BubbleChart.seriesRemoved​(XYChart.Series<X,Y> series)
      protected void | LineChart.seriesRemoved​(XYChart.Series<X,Y> series)
      protected void ScatterChart.seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。
      protected void | StackedAreaChart.seriesRemoved​(XYChart.Series<X,Y> series)
      protected void | StackedBarChart.seriesRemoved​(XYChart.Series<X,Y> series)
      protected abstract void XYChart.seriesRemoved​(XYChart.Series<X,Y> series)
      数据模型中已经删除了一个系列，但它仍然可以在图表上显示。
      Method parameters in javafx.scene.chart with type arguments of type XYChart.Series
      Modifier and Type | 方法 | 描述
      protected void | AreaChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void | BarChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void | LineChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void | StackedAreaChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void | StackedBarChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      protected void XYChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)
      当将每个原子更改作为此图表的系列列表时调用
      void XYChart.setData​(ObservableList<XYChart.Series<X,Y>> value)
      设置属性数据的值。
      Constructor parameters in javafx.scene.chart with type arguments of type XYChart.Series
      Constructor 描述
      AreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      用给定的轴和数据构造一个新的BarChart。
      BarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      用给定的轴和数据构造一个新的BarChart。
      BubbleChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的BubbleChart。
      LineChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的LineChart。
      ScatterChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造新的ScatterChart。
      StackedAreaChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构建新的区域图。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data)
      使用给定的轴和数据构造一个新的StackedBarChart。
      StackedBarChart​(Axis<X> xAxis, Axis<Y> yAxis, ObservableList<XYChart.Series<X,Y>> data, double categoryGap)
      使用给定的轴和数据构造一个新的StackedBarChart。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.AccessibleAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.AccessibleAction

  • Packages that use AccessibleAction
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of AccessibleAction in javafx.scene

      Methods in javafx.scene that return AccessibleAction
      Modifier and Type 方法 描述
      static AccessibleAction AccessibleAction.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AccessibleAction[] AccessibleAction.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene with parameters of type AccessibleAction
      Modifier and Type 方法 描述
      void Node.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。

    • Uses of AccessibleAction in javafx.scene.control

      Methods in javafx.scene.control with parameters of type AccessibleAction
      Modifier and Type 方法 描述
      void ButtonBase.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void ChoiceBox.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void ComboBoxBase.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void Control.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void ListCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void MenuButton.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void ScrollBar.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      protected void SkinBase.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void Slider.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void Spinner.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void SplitMenuButton.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void TableCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void TextInputControl.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void TitledPane.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void TreeCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void TreeTableCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void TreeTableRow.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。

    • Uses of AccessibleAction in javafx.scene.control.skin

      Methods in javafx.scene.control.skin with parameters of type AccessibleAction
      Modifier and Type | 方法 | 描述
      protected void ListViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      protected void TableViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      protected void | TextInputControlSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      protected void | ToolBarSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      protected void | TreeTableViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      protected void TreeViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.AccessibleAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.AccessibleAttribute

  • Packages that use AccessibleAttribute
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of AccessibleAttribute in javafx.scene

      Methods in javafx.scene that return AccessibleAttribute
      Modifier and Type 方法 描述
      static AccessibleAttribute AccessibleAttribute.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AccessibleAttribute[] AccessibleAttribute.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene with parameters of type AccessibleAttribute
      Modifier and Type 方法 描述
      void Node.notifyAccessibleAttributeChanged​(AccessibleAttribute attributes)
      该方法由应用程序调用，以通知辅助技术属性的值已更改。
      Object Node.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object Parent.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

    • Uses of AccessibleAttribute in javafx.scene.control

      Methods in javafx.scene.control with parameters of type AccessibleAttribute
      Modifier and Type 方法 描述
      Object CheckBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ChoiceBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ComboBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ComboBoxBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object Control.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object DatePicker.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object Hyperlink.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ListCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ListView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object PasswordField.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ProgressBar.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ProgressIndicator.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object RadioButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ScrollBar.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ScrollPane.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object SkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object Slider.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object Spinner.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object SplitMenuButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TableCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TableRow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TableView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TextInputControl.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TitledPane.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object ToggleButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TreeCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TreeTableCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TreeTableRow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TreeTableView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TreeView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

    • Uses of AccessibleAttribute in javafx.scene.control.skin

      Methods in javafx.scene.control.skin with parameters of type AccessibleAttribute
      Modifier and Type | 方法 | 描述
      Object ComboBoxListViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object LabeledSkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object ListViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object MenuBarSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object MenuButtonSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object PaginationSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object ScrollPaneSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TableColumnHeader.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object TableRowSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TableViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object TableViewSkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object | TabPaneSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      protected Object TextAreaSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object TextFieldSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object | ToolBarSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      protected Object TreeTableRowSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object TreeTableViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected Object TreeViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

    • Uses of AccessibleAttribute in javafx.scene.text

      Methods in javafx.scene.text with parameters of type AccessibleAttribute
      Modifier and Type 方法 描述
      Object Text.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      Object TextFlow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.AccessibleRole (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.AccessibleRole

  • Packages that use AccessibleRole
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of AccessibleRole in javafx.scene

      Methods in javafx.scene that return AccessibleRole
      Modifier and Type 方法 描述
      AccessibleRole Node.getAccessibleRole​()
      获取属性accessibilityRole的值。
      static AccessibleRole AccessibleRole.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AccessibleRole[] AccessibleRole.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene that return types with arguments of type AccessibleRole
      Modifier and Type 方法 描述
      ObjectProperty<AccessibleRole> Node.accessibleRoleProperty​()
      这个 Node的可访问角色。
      Methods in javafx.scene with parameters of type AccessibleRole
      Modifier and Type 方法 描述
      void Node.setAccessibleRole​(AccessibleRole value)
      设置属性accessibilityRole的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.AmbientLight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.AmbientLight

No usage of javafx.scene.AmbientLight
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.CacheHint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.CacheHint

  • Packages that use CacheHint
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of CacheHint in javafx.scene

      Methods in javafx.scene that return CacheHint
      Modifier and Type 方法 描述
      CacheHint Node.getCacheHint​()
      获取属性cacheHint的值。
      static CacheHint CacheHint.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CacheHint[] CacheHint.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene that return types with arguments of type CacheHint
      Modifier and Type 方法 描述
      ObjectProperty<CacheHint> Node.cacheHintProperty​()
      控制位图缓存的其他提示。
      Methods in javafx.scene with parameters of type CacheHint
      Modifier and Type 方法 描述
      void Node.setCacheHint​(CacheHint value)
      设置属性cacheHint的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.Camera (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.Camera

  • Packages that use Camera
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of Camera in javafx.scene

      Subclasses of Camera in javafx.scene
      Modifier and Type Class 描述
      class  ParallelCamera
      指定用于渲染场景而不进行透视校正的并行相机。
      class  PerspectiveCamera
      指定用于渲染场景的透视相机。
      Methods in javafx.scene that return Camera
      Modifier and Type 方法 描述
      Camera Scene.getCamera​()
      获取属性摄像机的值。
      Camera SnapshotParameters.getCamera​()
      获取当前相机。
      Camera SubScene.getCamera​()
      获取属性摄像机的值。
      Methods in javafx.scene that return types with arguments of type Camera
      Modifier and Type 方法 描述
      ObjectProperty<Camera> Scene.cameraProperty​()
      指定用于呈现 Scene的相机使用类型。
      ObjectProperty<Camera> SubScene.cameraProperty​()
      指定用于渲染 SubScene的相机使用类型。
      Methods in javafx.scene with parameters of type Camera
      Modifier and Type 方法 描述
      void Scene.setCamera​(Camera value)
      设置属性摄像机的值。
      void SnapshotParameters.setCamera​(Camera camera)
      将相机设置为指定值。
      void SubScene.setCamera​(Camera value)
      设置属性摄像机的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.Cursor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.Cursor

  • Packages that use Cursor
    软件包 描述
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of Cursor in javafx.css.converter

      Methods in javafx.css.converter that return Cursor
      Modifier and Type | 方法 | 描述
      Cursor | CursorConverter.convert​(ParsedValue<String,Cursor> value, Font not_used)
      Methods in javafx.css.converter that return types with arguments of type Cursor
      Modifier and Type | 方法 | 描述
      static StyleConverter<String,Cursor> | CursorConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Cursor
      Modifier and Type | 方法 | 描述
      Cursor | CursorConverter.convert​(ParsedValue<String,Cursor> value, Font not_used)

    • Uses of Cursor in javafx.scene

      Subclasses of Cursor in javafx.scene
      Modifier and Type Class 描述
      class  ImageCursor
      鼠标光标的自定义图像表示。
      Fields in javafx.scene declared as Cursor
      Modifier and Type Field 描述
      static Cursor Cursor.CLOSED_HAND
      用手关闭的光标，通常在“抓取”时使用，例如，当平移时。
      static Cursor Cursor.CROSSHAIR
      十字准线游标类型。
      static Cursor Cursor.DEFAULT
      默认游标类型（如果未定义游标，则设置）。
      static Cursor Cursor.DISAPPEAR
      消失的游标类型。
      static Cursor Cursor.E_RESIZE
      东调整游标类型。
      static Cursor Cursor.H_RESIZE
      水平光标类型。
      static Cursor Cursor.HAND
      手指游标类型，类似于指针，通常用于指示可以点击某些内容，例如超链接。
      static Cursor Cursor.MOVE
      移动光标类型。
      static Cursor Cursor.N_RESIZE
      北移大小的游标类型。
      static Cursor Cursor.NE_RESIZE
      东北调整大小的光标类型。
      static Cursor Cursor.NONE
      无光标类型。
      static Cursor Cursor.NW_RESIZE
      西北大小的游标类型。
      static Cursor Cursor.OPEN_HAND
      用手打开的光标
      static Cursor Cursor.S_RESIZE
      调整大小的光标类型。
      static Cursor Cursor.SE_RESIZE
      东南大小的光标类型。
      static Cursor Cursor.SW_RESIZE
      西南大小的光标类型。
      static Cursor Cursor.TEXT
      文本光标类型。
      static Cursor Cursor.V_RESIZE
      垂直光标类型。
      static Cursor Cursor.W_RESIZE
      西调整游标类型。
      static Cursor Cursor.WAIT
      等待光标类型。
      Methods in javafx.scene that return Cursor
      Modifier and Type 方法 描述
      static Cursor Cursor.cursor​(String identifier)
      返回指定标识符的游标。
      Cursor Node.getCursor​()
      获取属性游标的值。
      Cursor Scene.getCursor​()
      获取属性游标的值。
      protected Cursor Node.getInitialCursor​()
      返回此节点的初始游标状态，供JavaFX CSS引擎正确设置其初始值。
      Methods in javafx.scene that return types with arguments of type Cursor
      Modifier and Type 方法 描述
      ObjectProperty<Cursor> Node.cursorProperty​()
      为此 Node和子节点定义鼠标光标。
      ObjectProperty<Cursor> Scene.cursorProperty​()
      为此 Scene定义鼠标光标。
      Methods in javafx.scene with parameters of type Cursor
      Modifier and Type 方法 描述
      void Node.setCursor​(Cursor value)
      设置属性游标的值。
      void Scene.setCursor​(Cursor value)
      设置属性游标的值。

    • Uses of Cursor in javafx.scene.control

      Methods in javafx.scene.control that return Cursor
      Modifier and Type 方法 描述
      protected Cursor Hyperlink.getInitialCursor​()
      返回此控件的初始游标状态，供JavaFX CSS引擎正确设置其初始值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.DepthTest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.DepthTest

  • Packages that use DepthTest
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of DepthTest in javafx.scene

      Methods in javafx.scene that return DepthTest
      Modifier and Type 方法 描述
      DepthTest Node.getDepthTest​()
      获取属性depthTest的值。
      static DepthTest DepthTest.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DepthTest[] DepthTest.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene that return types with arguments of type DepthTest
      Modifier and Type 方法 描述
      ObjectProperty<DepthTest> Node.depthTestProperty​()
      指示在渲染此节点时是否使用深度测试。
      Methods in javafx.scene with parameters of type DepthTest
      Modifier and Type 方法 描述
      void Node.setDepthTest​(DepthTest value)
      设置属性depthTest的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.Group (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.Group

No usage of javafx.scene.Group
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.ImageCursor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.ImageCursor

  • Packages that use ImageCursor
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of ImageCursor in javafx.scene

      Methods in javafx.scene that return ImageCursor
      Modifier and Type 方法 描述
      static ImageCursor ImageCursor.chooseBestCursor​(Image[] images, double hotspotX, double hotspotY)
      从指定的图像之一创建自定义图像光标。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.LightBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.LightBase

  • Packages that use LightBase
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of LightBase in javafx.scene

      Subclasses of LightBase in javafx.scene
      Modifier and Type Class 描述
      class  AmbientLight
      定义环境光源对象。
      class  PointLight
      定义点光源对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.Node (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.Node

  • Packages that use Node
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of Node in javafx.animation

      Methods in javafx.animation that return Node
      Modifier and Type 方法 描述
      Node FadeTransition.getNode​()
      获取属性节点的值。
      Node ParallelTransition.getNode​()
      获取属性节点的值。
      Node PathTransition.getNode​()
      获取属性节点的值。
      Node RotateTransition.getNode​()
      获取属性节点的值。
      Node ScaleTransition.getNode​()
      获取属性节点的值。
      Node SequentialTransition.getNode​()
      获取属性节点的值。
      Node TranslateTransition.getNode​()
      获取属性节点的值。
      protected Node ParallelTransition.getParentTargetNode​()
      返回此Transition的动画的目标Transition 。
      protected Node SequentialTransition.getParentTargetNode​()
      返回Transition的动画目标Transition 。
      protected Node Transition.getParentTargetNode​()
      返回这个Transition的动画的目标Transition 。
      Methods in javafx.animation that return types with arguments of type Node
      Modifier and Type 方法 描述
      ObjectProperty<Node> FadeTransition.nodeProperty​()
      这个 Transition的目标节点。
      ObjectProperty<Node> ParallelTransition.nodeProperty​()
      这个Node是在所有的小孩Transitions中使用的 ，没有定义一个目标Node自己。
      ObjectProperty<Node> PathTransition.nodeProperty​()
      该 PathTransition的目标节点。
      ObjectProperty<Node> RotateTransition.nodeProperty​()
      这个 RotateTransition的目标节点。
      ObjectProperty<Node> ScaleTransition.nodeProperty​()
      这个 ScaleTransition的目标节点。
      ObjectProperty<Node> SequentialTransition.nodeProperty​()
      这个Node是在所有的小孩Transitions中使用的 ，没有定义目标Node本身。
      ObjectProperty<Node> TranslateTransition.nodeProperty​()
      这个 TranslateTransition的目标节点。
      Methods in javafx.animation with parameters of type Node
      Modifier and Type 方法 描述
      void FadeTransition.setNode​(Node value)
      设置属性节点的值。
      void ParallelTransition.setNode​(Node value)
      设置属性节点的值。
      void PathTransition.setNode​(Node value)
      设置属性节点的值。
      void RotateTransition.setNode​(Node value)
      设置属性节点的值。
      void ScaleTransition.setNode​(Node value)
      设置属性节点的值。
      void SequentialTransition.setNode​(Node value)
      设置属性节点的值。
      void TranslateTransition.setNode​(Node value)
      设置属性节点的值。
      Constructors in javafx.animation with parameters of type Node
      Constructor 描述
      FadeTransition​(Duration duration, Node node)
      构造函数为 FadeTransition
      ParallelTransition​(Node node)
      构造函数为 ParallelTransition 。
      ParallelTransition​(Node node, Animation... children)
      构造函数为 ParallelTransition 。
      PathTransition​(Duration duration, Shape path, Node node)
      构造函数为 PathTransition 。
      RotateTransition​(Duration duration, Node node)
      构造函数为 RotateTransition
      ScaleTransition​(Duration duration, Node node)
      构造函数为 ScaleTransition
      SequentialTransition​(Node node)
      构造函数为 SequentialTransition 。
      SequentialTransition​(Node node, Animation... children)
      构造函数为 SequentialTransition 。
      TranslateTransition​(Duration duration, Node node)
      构造函数为 TranslateTransition

    • Uses of Node in javafx.css

      Methods in javafx.css that return Node
      Modifier and Type 方法 描述
      default Node Styleable.getStyleableNode​()
      返回表示此Styleable对象的Node。

    • Uses of Node in javafx.embed.swing

      Subclasses of Node in javafx.embed.swing
      Modifier and Type Class 描述
      class  SwingNode
      此类用于将Swing内容嵌入到JavaFX应用程序中。

    • Uses of Node in javafx.print

      Methods in javafx.print with parameters of type Node
      Modifier and Type 方法 描述
      boolean PrinterJob.printPage​(PageLayout pageLayout, Node node)
      使用指定的页面布局打印指定的节点。
      boolean PrinterJob.printPage​(Node node)
      打印指定的节点。

    • Uses of Node in javafx.scene

      Subclasses of Node in javafx.scene
      Modifier and Type Class 描述
      class  AmbientLight
      定义环境光源对象。
      class  Camera
      用于渲染场景的相机的基类。
      class  Group
      一个 Group节点包含一个可观察的子节点列表，每当呈现此节点时，它们按顺序渲染。
      class  LightBase
      LightBase类提供了表示光源形式的对象的常用属性的定义。
      class  ParallelCamera
      指定用于渲染场景而不进行透视校正的并行相机。
      class  Parent
      在场景图中有子节点的所有节点的基类。
      class  PerspectiveCamera
      指定用于渲染场景的透视相机。
      class  PointLight
      定义点光源对象。
      class  SubScene
      SubScene类是场景图中内容的容器。
      Methods in javafx.scene with type parameters of type Node
      Modifier and Type 方法 描述
      protected <E extends Node>
      List<E>             		Parent.getManagedChildren​()
      获取此 Parent的所有受管孩子的 Parent 。
      Methods in javafx.scene that return Node
      Modifier and Type | 方法 | 描述
      Node Node.getClip​()
      获取属性剪辑的值。
      Node Scene.getFocusOwner​()
      获取focusOwner属性的值。
      Node Node.lookup​(String selector)
      根据给定的CSS选择器找到这个 Node或第一个子节点。
      Node | Parent.lookup​(String selector)
      Node Scene.lookup​(String selector)
      根据指定的CSS选择器查找场景图中的任何节点。
      Methods in javafx.scene that return types with arguments of type Node
      Modifier and Type 方法 描述
      ObjectProperty<Node> Node.clipProperty​()
      指定用于定义此节点的剪切形状的 Node 。
      ReadOnlyObjectProperty<Node> Scene.focusOwnerProperty​()
      场景当前焦点所有者节点。
      ObservableList<Node> Group.getChildren​()
      获取此 Group的孩子列表。
      protected ObservableList<Node> Parent.getChildren​()
      获取此 Parent的孩子列表。
      ObservableList<Node> Parent.getChildrenUnmodifiable​()
      获取此 Parent的子项列表作为只读列表。
      ObservableList<Node> LightBase.getScope​()
      获取指定此Light的分层范围的节点列表。
      Set<Node> Node.lookupAll​(String selector)
      查找所有 Node s，包括这个和任何孩子，匹配给定的CSS选择器。
      Methods in javafx.scene with parameters of type Node
      Modifier and Type 方法 描述
      void Node.setClip​(Node value)
      设置属性剪辑的值。
      Constructors in javafx.scene with parameters of type Node
      Constructor 描述
      Group​(Node... children)
      构建一个由儿童组成的小组。
      Constructor parameters in javafx.scene with type arguments of type Node
      Constructor 描述
      Group​(Collection<Node> children)
      构建由给定的孩子组成的组。

    • Uses of Node in javafx.scene.canvas

      Subclasses of Node in javafx.scene.canvas
      Modifier and Type Class 描述
      class  Canvas
      Canvas是可以使用GraphicsContext提供的一组图形命令绘制的图像。

    • Uses of Node in javafx.scene.chart

      Subclasses of Node in javafx.scene.chart
      Modifier and Type Class 描述
      class  AreaChart<X,Y>
      AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
      class  Axis<T>
      JavaFX中所有轴的基类，表示在图表区域上绘制的轴。
      class  BarChart<X,Y>
      绘制一个指示类别数据值的条形图。
      class  BubbleChart<X,Y>
      为一系列数据点绘制气泡的图表类型。
      class  CategoryAxis
      一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。
      class  Chart
      所有图表的基础类。
      class  LineChart<X,Y>
      线图绘制了连接数据点的行。
      class  NumberAxis
      一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
      class  PieChart
      显示PieChart。
      class  ScatterChart<X,Y>
      绘制一系列数据点符号的图表类型。
      class  StackedAreaChart<X,Y>
      StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。
      class  StackedBarChart<X,Y>
      StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。
      class  ValueAxis<T extends Number>
      数据定义为数字的轴。
      class  XYChart<X,Y>
      所有2轴图的图表基类。
      Methods in javafx.scene.chart that return Node
      Modifier and Type 方法 描述
      protected Node Chart.getLegend​()
      获取属性图例的值。
      Node PieChart.Data.getNode​()
      返回表示饼图切片的节点。
      Node XYChart.Data.getNode​()
      获取属性节点的值。
      Node XYChart.Series.getNode​()
      获取属性节点的值。
      Methods in javafx.scene.chart that return types with arguments of type Node
      Modifier and Type 方法 描述
      protected ObservableList<Node> Chart.getChartChildren​()
      图表中所有内容的可修改和可观察的列表。
      protected ObservableList<Node> XYChart.getPlotChildren​()
      情节中所有内容的可修改和可观察的列表。
      protected ObjectProperty<Node> Chart.legendProperty​()
      该节点显示为Legend。
      ReadOnlyObjectProperty<Node> PieChart.Data.nodeProperty​()
      访问表示饼图切片的节点。
      ObjectProperty<Node> XYChart.Data.nodeProperty​()
      要显示此数据项的节点。
      ObjectProperty<Node> XYChart.Series.nodeProperty​()
      该系列显示的节点。
      Methods in javafx.scene.chart with parameters of type Node
      Modifier and Type 方法 描述
      protected void Chart.setLegend​(Node value)
      设置属性图例的值。
      void XYChart.Data.setNode​(Node value)
      设置属性节点的值。
      void XYChart.Series.setNode​(Node value)
      设置属性节点的值。

    • Uses of Node in javafx.scene.control

      Subclasses of Node in javafx.scene.control
      Modifier and Type Class 描述
      class  Accordion
      手风琴是一组TitlePanes 。
      class  Button
      一个简单的按钮控件。
      class  ButtonBar
      ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。
      class  ButtonBase
      按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
      class  Cell<T>
      细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
      class  CheckBox
      三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
      class  ChoiceBox<T>
      ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
      class  ColorPicker
      ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
      class  ComboBox<T>
      为ComboBox最常见形式的ComboBoxBase抽象类的实现，向用户提供弹出列表，为他们提供他们可以选择的选项。
      class  ComboBoxBase<T>
      ComboBox类控件的抽象基类。
      class  Control
      所有用户界面控件的基类。
      class  DateCell
      DateCell由DatePicker用于在日历月中呈现单个网格单元格。
      class  DatePicker
      DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
      class  DialogPane
      DialogPane应该被认为是在一个Dialog实例中显示的根节点 。
      class  Hyperlink
      一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
      class  IndexedCell<T>
      一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。
      class  Label
      标签是不可编辑的文本控件。
      class  Labeled
      标签Control是其用户界面的一部分，与其相关联的文本内容。
      class  ListCell<T>
      在ListView实例中使用的Cell类型。
      class  ListView<T>
      ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
      class  MenuBar
      MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。
      class  MenuButton
      MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
      class  Pagination
      分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
      class  PasswordField
      掩码输入字符的文本字段。
      protected class  PopupControl.CSSBridge
      弹出窗口和场景图之间的链接。
      class  ProgressBar
      ProgressIndator的专业化表示为横杠。
      class  ProgressIndicator
      用于指示进度的循环控制，无限（也称为不确定）或有限。
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  ScrollBar
      具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。
      class  ScrollPane
      提供其内容的滚动，剪切视口的控件。
      class  Separator
      水平或垂直分隔线。
      class  Slider
      滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。
      class  Spinner<T>
      单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。
      class  SplitMenuButton
      该SplitMenuButton，像MenuButton密切与选择的概念相关MenuItem从菜单。
      class  SplitPane
      具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
      class  TableCell<S,T>
      在TableView中表示单行/列交集。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TableView<S>
      TableView控件旨在可视化无限数量的数据行，分为列。
      class  TabPane
      允许在一组Tabs之间切换的控件 。
      class  TextArea
      文本输入组件，允许用户输入多行纯文本。
      class  TextField
      文本输入组件，允许用户输入一行未格式化的文本。
      class  TextInputControl
      文本输入控件的抽象基类。
      class  TitledPane
      TitledPane是一个可以打开和关闭的标题的面板。
      class  ToggleButton
      A ToggleButton是具有选择能力的专业控制。
      class  ToolBar
      ToolBar是一个可以水平或垂直显示项目的控件。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
      class  TreeTableView<S>
      TreeTableView控件旨在可视化无限数量的数据行，分为列。
      class  TreeView<T>
      TreeView控件提供了一个树根视图（类型为TreeItem ）。
      Methods in javafx.scene.control that return Node
      Modifier and Type 方法 描述
      protected Node DialogPane.createButton​(ButtonType buttonType)
      子类可以覆盖此方法来创建一个自定义按钮，随后将其插入DialogPane按钮区域（通过DialogPane.createButtonBar()方法创建，但通常它是ButtonBar的一个实例）。
      protected Node DialogPane.createButtonBar​()
      这个方法可以被子类覆盖以提供按钮栏。
      protected Node DialogPane.createDetailsButton​()
      子类可以覆盖此方法来创建自定义详细信息按钮。
      Node CustomMenuItem.getContent​()
      获取属性内容的值。
      Node DialogPane.getContent​()
      将对话框内容作为Node返回（即使将其设置为使用DialogPane.setContentText(String)的字符串 - 这仅仅是转换为Node （最可能是Label ）。
      Node ScrollPane.getContent​()
      获取属性内容的值。
      Node Tab.getContent​()
      与标签相关的内容。
      Node TitledPane.getContent​()
      TitledPane的内容。
      Node TreeCell.getDisclosureNode​()
      返回此TreeCell中设置的当前披露节点。
      Node TreeTableRow.getDisclosureNode​()
      返回此TreeTableCell中设置的当前披露节点。
      Node DialogPane.getExpandableContent​()
      返回对话框可扩展内容节点（如果已设置），否则返回null。
      Node Dialog.getGraphic​()
      获取属性图形的值。
      Node DialogPane.getGraphic​()
      获取属性图形的值。
      Node Labeled.getGraphic​()
      获取属性图形的值。
      Node MenuItem.getGraphic​()
      获取属性图形的值。
      Node Tab.getGraphic​()
      标签中显示的图形。
      Node TableColumnBase.getGraphic​()
      获取属性图形的值。
      Node Tooltip.getGraphic​()
      获取属性图形的值。
      Node TreeItem.getGraphic​()
      返回通常显示在value属性左侧的节点。
      Node DialogPane.getHeader​()
      用作对话框窗格标题的节点。
      Node Label.getLabelFor​()
      获取属性labelFor的值。
      Node Skin.getNode​()
      获取代表此皮肤的节点。
      Node SkinBase.getNode​()
      获取代表此皮肤的节点。
      Node ComboBox.getPlaceholder​()
      获取属性占位符的值。
      Node ListView.getPlaceholder​()
      获取属性占位符的值。
      Node TableView.getPlaceholder​()
      获取属性占位符的值。
      Node TreeTableView.getPlaceholder​()
      获取属性占位符的值。
      Node TableColumnBase.getSortNode​()
      获取属性sortNode的值。
      Node MenuItem.getStyleableNode​()
      返回表示此Styleable对象的Node。
      Node PopupControl.getStyleableNode​()
      返回表示此Styleable对象的Node。
      Node TableColumn.getStyleableNode​()
      返回表示此Styleable对象的Node。
      Node TreeTableColumn.getStyleableNode​()
      返回表示此Styleable对象的Node。
      Node TabPane.lookup​(String selector)
      找到这个 Node ，或第一个子节点，基于给定的CSS选择器。
      Node DialogPane.lookupButton​(ButtonType buttonType)
      该方法提供了开发人员可以为给定的ButtonType检索实际节点（假设它是button types列表的一部分）的方式。
      Methods in javafx.scene.control that return types with arguments of type Node
      Modifier and Type 方法 描述
      ObjectProperty<Node> CustomMenuItem.contentProperty​()
      在此CustomMenuItem中显示的节点。
      ObjectProperty<Node> DialogPane.contentProperty​()
      表示对话框的内容区域的属性。
      ObjectProperty<Node> ScrollPane.contentProperty​()
      该节点用作此ScrollPane的内容。
      ObjectProperty<Node> Tab.contentProperty​()
      与标签相关的内容。
      ObjectProperty<Node> TitledPane.contentProperty​()
      TitledPane的内容。
      ObjectProperty<Node> TreeCell.disclosureNodeProperty​()
      公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
      ObjectProperty<Node> TreeTableRow.disclosureNodeProperty​()
      公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
      ObjectProperty<Node> DialogPane.expandableContentProperty​()
      表示对话框可扩展内容区域的属性。
      ObservableList<Node> ButtonBar.getButtons​()
      在此ObservableList内放置按钮将指示ButtonBar根据其指定的ButtonBar.ButtonData相对于彼此定位 。
      ObservableList<Node> SkinBase.getChildren​()
      返回皮肤的孩子。
      ObservableList<Node> SplitPane.getItems​()
      返回一个ObservableList，可用于修改SplitPane的内容。
      ObservableList<Node> ToolBar.getItems​()
      这些项目包含在 ToolBar 。
      Callback<Integer,Node> Pagination.getPageFactory​()
      返回页面工厂回调函数。
      ObjectProperty<Node> Dialog.graphicProperty​()
      对话图形，在标题中显示，如果显示，或者在 content的左侧。
      ObjectProperty<Node> DialogPane.graphicProperty​()
      对话图形，显示在标题中，如果显示，或在 content的左侧。
      ObjectProperty<Node> Labeled.graphicProperty​()
      标签的可选图标。
      ObjectProperty<Node> MenuItem.graphicProperty​()
      MenuItem的可选图形。
      ObjectProperty<Node> Tab.graphicProperty​()
      选项卡中的图形。
      ObjectProperty<Node> TableColumnBase.graphicProperty​()
      在表列中显示的图形，以允许用户以图形方式指示列中的内容。
      ObjectProperty<Node> Tooltip.graphicProperty​()
      工具提示的可选图标。
      ObjectProperty<Node> TreeItem.graphicProperty​()
      通常显示在value属性左侧的节点。
      ObjectProperty<Node> DialogPane.headerProperty​()
      表示对话框窗格的标题区域的属性。
      ObjectProperty<Node> Label.labelForProperty​()
      标签可以作为不同控件或节点的标签。
      Set<Node> TabPane.lookupAll​(String selector)
      查找所有 Node s，包括这个和任何孩子，匹配给定的CSS选择器。
      ObjectProperty<Callback<Integer,Node>> Pagination.pageFactoryProperty​()
      当应用程序或用户选择页面时调用的pageFactory回调函数。
      ObjectProperty<Node> ComboBox.placeholderProperty​()
      当ComboBox没有内容显示时，该节点将显示给用户。
      ObjectProperty<Node> ListView.placeholderProperty​()
      当列表视图没有显示的内容时，向用户显示该节点。
      ObjectProperty<Node> TableView.placeholderProperty​()
      当表没有显示的内容时，向用户显示该节点。
      ObjectProperty<Node> TreeTableView.placeholderProperty​()
      当表没有显示的内容时，向用户显示该节点。
      ObjectProperty<Node> TableColumnBase.sortNodeProperty​()
      用作“排序箭头”的节点，在表列是排序顺序的一部分的情况下向用户显示。
      Methods in javafx.scene.control with parameters of type Node
      Modifier and Type 方法 描述
      static ButtonBar.ButtonData ButtonBar.getButtonData​(Node button)
      返回给定按钮上先前设置的ButtonData属性。
      static void Tooltip.install​(Node node, Tooltip t)
      将给定的Tooltip与给定的Node相关联 。
      static boolean ButtonBar.isButtonUniformSize​(Node button)
      返回给定节点是否是统一尺寸计算的一部分。
      static Boolean SplitPane.isResizableWithParent​(Node node)
      如果父容器调整大小为false时，如果节点可调整大小，则返回true。
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void SkinBase.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void ButtonBar.setButtonData​(Node button, ButtonBar.ButtonData buttonData)
      在给定的按钮上设置给定的ButtonData。
      static void ButtonBar.setButtonUniformSize​(Node button, boolean uniformSize)
      默认情况下，所有按钮在ButtonBar中均匀的大小，这意味着所有按钮都占据最宽按钮的宽度。
      void CustomMenuItem.setContent​(Node value)
      设置属性内容的值。
      void DialogPane.setContent​(Node content)
      分配对话框内容。
      void ScrollPane.setContent​(Node value)
      设置属性内容的值。
      void Tab.setContent​(Node value)
      内容显示在主TabPane区域内。
      void TitledPane.setContent​(Node value)
      TitlePane的内容可以是任何节点，如UI控件或添加到布局容器的节点组。
      void TreeCell.setDisclosureNode​(Node value)
      用作“披露”三角形的节点，或用于展开和折叠项目的切换。
      void TreeTableRow.setDisclosureNode​(Node value)
      用作“披露”三角形的节点，或用于展开和折叠项目的切换。
      void DialogPane.setExpandableContent​(Node content)
      设置对话框可扩展内容节点，如果不显示可扩展内容，则设置为null。
      void Dialog.setGraphic​(Node graphic)
      设置对话框图形，将显示在标题中，如果显示，或 content的左侧。
      void DialogPane.setGraphic​(Node graphic)
      设置对话框图形，显示在标题中，如果显示，或 content的左侧。
      void Labeled.setGraphic​(Node value)
      设置属性图形的值。
      void MenuItem.setGraphic​(Node value)
      设置属性图形的值。
      void Tab.setGraphic​(Node value)
      将图形设置为在标签中显示，以允许用户区分每个选项卡的功能。
      void TableColumnBase.setGraphic​(Node value)
      设置属性图形的值。
      void Tooltip.setGraphic​(Node value)
      设置属性图形的值。
      void TreeItem.setGraphic​(Node value)
      设置通常显示在value属性左侧的节点。
      void DialogPane.setHeader​(Node header)
      分配对话窗格标题。
      void Label.setLabelFor​(Node value)
      设置属性labelFor的值。
      void ComboBox.setPlaceholder​(Node value)
      设置属性占位符的值。
      void ListView.setPlaceholder​(Node value)
      设置属性占位符的值。
      void TableView.setPlaceholder​(Node value)
      设置属性占位符的值。
      void TreeTableView.setPlaceholder​(Node value)
      设置属性占位符的值。
      static void SplitPane.setResizableWithParent​(Node node, Boolean value)
      在SplitPane调整大小时，将SplitPane中的节点设置为可调整大小。
      void TableColumnBase.setSortNode​(Node value)
      设置属性sortNode的值。
      void ContextMenu.show​(Node anchor, double screenX, double screenY)
      在指定的屏幕坐标处显示 ContextMenu 。
      void ContextMenu.show​(Node anchor, Side side, double dx, double dy)
      示出了 ContextMenu相对于给定锚节点，在由指定的侧 hpos个 vpos参数，并且由给定的偏移 dx倍 dy分别用于x轴和y轴，的值。
      static void Tooltip.uninstall​(Node node, Tooltip t)
      删除给定的Tooltip在指定的Node的关联 。
      Method parameters in javafx.scene.control with type arguments of type Node
      Modifier and Type 方法 描述
      void Pagination.setPageFactory​(Callback<Integer,Node> value)
      设置页面工厂回调函数。
      Constructors in javafx.scene.control with parameters of type Node
      Constructor 描述
      Button​(String text, Node graphic)
      创建一个带有指定文本和图标的按钮。
      ButtonBase​(String text, Node graphic)
      创建一个带有给定文本和图形的ButtonBase。
      CheckBoxTreeItem​(T value, Node graphic)
      创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的节点。
      CheckBoxTreeItem​(T value, Node graphic, boolean selected)
      创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的Node，并将 CheckBoxTreeItem.selectedProperty()的初始状态设置为提供的布尔值。
      CheckBoxTreeItem​(T value, Node graphic, boolean selected, boolean independent)
      创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的节点，初始状态为 CheckBoxTreeItem.selectedProperty()设置为提供的布尔值，以及 independent属性的初始状态为提供的布尔值。
      CheckMenuItem​(String text, Node graphic)
      构造CheckMenuItem并设置指定文本的显示文本，并将图形Node设置为给定节点。
      CustomMenuItem​(Node node)
      构造一个CustomMenuItem并使用指定的节点初始化其内容。
      CustomMenuItem​(Node node, boolean hideOnClick)
      构造一个CustomMenuItem并将内容设置为指定的节点。
      Hyperlink​(String text, Node graphic)
      创建指定文本和图形作为其标签的超链接。
      Label​(String text, Node graphic)
      使用提供的文本和图形创建标签。
      Labeled​(String text, Node graphic)
      创建带有文本和图形的标签
      Menu​(String text, Node graphic)
      构造一个菜单，并使用指定的文本设置显示文本，并将图形Node设置为给定的节点。
      Menu​(String text, Node graphic, MenuItem... items)
      构建菜单，并将指定文本的显示文本（给定节点的图形Node）设置，并将给定项目插入到items列表中。
      MenuButton​(String text, Node graphic)
      创建一个新的空的菜单按钮，给定的文本和图形显示在按钮上。
      MenuButton​(String text, Node graphic, MenuItem... items)
      创建一个新的菜单按钮，给定的文本和图形显示在按钮上，并将给定的项目插入到 items列表中。
      MenuItem​(String text, Node graphic)
      构造函数的MenuItem并设置具有指定文本的显示文本，并将图形设置为给定节点Node 。
      RadioMenuItem​(String text, Node graphic)
      构造一个RadioMenuItem，并使用指定的文本设置显示文本，并将图形Node设置为给定节点。
      ScrollPane​(Node content)
      创建一个新的ScrollPane。
      SplitPane​(Node... items)
      创建一个新的SplitPane，其中给定的项目设置为在一个或多个分频器之间分割的内容。
      Tab​(String text, Node content)
      创建一个带有文本标题和指定内容节点的选项卡。
      TitledPane​(String title, Node content)
      创建一个标题和内容的新TitledPane。
      ToggleButton​(String text, Node graphic)
      创建一个切换按钮，其标签具有指定的文本和图标。
      ToolBar​(Node... items)
      创建一个填充指定节点的工具栏。
      TreeItem​(T value, Node graphic)
      创建一个TreeItem，其value属性设置为提供的对象，图形设置为提供的节点。

    • Uses of Node in javafx.scene.control.cell

      Subclasses of Node in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含一个ListCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含一个TableCell实现的类，可以在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个包含TreeCell实现的类，在单元格中绘制一个CheckBox节点，并支持常见的交互（ 稍后更详细地讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个类包含一个TreeTableCell实现，它在单元格内绘制一个CheckBox节点，可选地带有一个标签，表示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格内绘制一个2706858272828节点。
      class  ChoiceBoxTreeCell<T>
      一个包含ListCell实现的类，在单元格中绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含一个ListCell实现的类，它在单元格中绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个270685827380809节点。
      class  ComboBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含TableCell实现的类，在单元格内绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含TreeTableCell实现的类，在该单元格内绘制一个ProgressBar节点。
      class  TextFieldListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个包含TableCell实现的类，它在单元格内绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个包含TreeCell实现的类，在该单元格内绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格中绘制一个TextField节点。

    • Uses of Node in javafx.scene.control.skin

      Subclasses of Node in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  NestedTableColumnHeader
      此类用于构造TableView的头。
      class  TableColumnHeader
      负责绘制单列标题的区域。
      class  TableHeaderRow
      负责绘制整列列标题的区域。
      class  VirtualFlow<T extends IndexedCell>
      使用基于单元的机制实现虚拟化容器。
      Methods in javafx.scene.control.skin that return Node
      Modifier and Type 方法 描述
      Node ColorPickerSkin.getDisplayNode​()
      该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
      abstract Node ComboBoxBaseSkin.getDisplayNode​()
      该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
      Node ComboBoxListViewSkin.getDisplayNode​()
      该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
      Node DatePickerSkin.getDisplayNode​()
      该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
      Node ContextMenuSkin.getNode​()
      获取代表此皮肤的节点。
      Node TooltipSkin.getNode​()
      获取代表此皮肤的节点。
      protected Node ColorPickerSkin.getPopupContent​()
      此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
      Node ComboBoxListViewSkin.getPopupContent​()
      此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
      protected abstract Node ComboBoxPopupControl.getPopupContent​()
      此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
      Node DatePickerSkin.getPopupContent​()
      此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
      Methods in javafx.scene.control.skin that return types with arguments of type Node
      Modifier and Type 方法 描述
      protected ObjectProperty<Node> TableRowSkinBase.graphicProperty​()
      返回在公开节点内部绘制的图形。
      protected ObjectProperty<Node> TreeTableRowSkin.graphicProperty​()
      返回在公开节点内部绘制的图形。
      Method parameters in javafx.scene.control.skin with type arguments of type Node
      Modifier and Type 方法 描述
      protected void TextAreaSkin.addHighlight​(List<? extends Node> nodes, int start)
      从输入法添加组合文本的高亮。
      protected void TextFieldSkin.addHighlight​(List<? extends Node> nodes, int start)
      从输入法添加组合文本的高亮。
      protected abstract void TextInputControlSkin.addHighlight​(List<? extends Node> nodes, int start)
      从输入法添加组合文本的高亮。
      protected void TextAreaSkin.removeHighlight​(List<? extends Node> nodes)
      从Input Method中删除组合文本的高亮。
      protected void TextFieldSkin.removeHighlight​(List<? extends Node> nodes)
      从Input Method中删除组合文本的高亮。
      protected abstract void TextInputControlSkin.removeHighlight​(List<? extends Node> nodes)
      从Input Method中删除组合文本的高亮。

    • Uses of Node in javafx.scene.image

      Subclasses of Node in javafx.scene.image
      Modifier and Type Class 描述
      class  ImageView
      ImageView是一个Node用于绘画图像加载Image类。

    • Uses of Node in javafx.scene.input

      Methods in javafx.scene.input that return Node
      Modifier and Type 方法 描述
      Node PickResult.getIntersectedNode​()
      返回相交的节点。
      Node Mnemonic.getNode​()
      返回Node
      Methods in javafx.scene.input with parameters of type Node
      Modifier and Type 方法 描述
      void Mnemonic.setNode​(Node node)
      设置Node
      Constructors in javafx.scene.input with parameters of type Node
      Constructor 描述
      Mnemonic​(Node node, KeyCombination keyCombination)
      构造一个Mnemonic与指定的目标Node和触发KeyCombination 。
      PickResult​(Node node, Point3D point, double distance)
      为非3d形状的目标创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。

    • Uses of Node in javafx.scene.layout

      Subclasses of Node in javafx.scene.layout
      Modifier and Type Class 描述
      class  AnchorPane
      AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。
      class  BorderPane
      BorderPane在上，左，右，底部和中间位置摆放孩子。
      class  FlowPane
      FlowPane将其孩子摆放在流过玻璃边界的流中。
      class  GridPane
      GridPane将其孩子放在一个灵活的行和列格网中。
      class  HBox
      HBox将孩子放在一排水平排列中。
      class  Pane
      布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
      class  Region
      Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
      class  StackPane
      StackPane将它的孩子放在一个靠前的堆叠中。
      class  TilePane
      TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。
      class  VBox
      VBox把孩子放在一个垂直的立柱上。
      Methods in javafx.scene.layout that return Node
      Modifier and Type 方法 描述
      Node BorderPane.getBottom​()
      获取属性底部的值。
      Node BorderPane.getCenter​()
      获取物业中心的价值。
      Node BorderPane.getLeft​()
      获取剩下的属性的值。
      Node BorderPane.getRight​()
      获取产权的价值。
      Node BorderPane.getTop​()
      获取属性顶部的值。
      Methods in javafx.scene.layout that return types with arguments of type Node
      Modifier and Type | 方法 | 描述
      ObjectProperty<Node> BorderPane.bottomProperty​()
      节点放置在此边框的底部边缘。
      ObjectProperty<Node> BorderPane.centerProperty​()
      节点放置在此边框窗格的中心。
      ObservableList<Node> | Pane.getChildren​()
      ObjectProperty<Node> BorderPane.leftProperty​()
      节点位于此边框的左边缘。
      ObjectProperty<Node> BorderPane.rightProperty​()
      放置在该边框窗格右边缘的节点。
      ObjectProperty<Node> BorderPane.topProperty​()
      节点放置在此边框的顶部边缘。
      Methods in javafx.scene.layout with parameters of type Node
      Modifier and Type 方法 描述
      void GridPane.add​(Node child, int columnIndex, int rowIndex)
      在指定的列，行位置向子窗格添加一个小孩。
      void GridPane.add​(Node child, int columnIndex, int rowIndex, int colspan, int rowspan)
      在指定的列，行位置和跨度向窗格中添加一个小孩。
      void GridPane.addColumn​(int columnIndex, Node... children)
      将指定节点顺序放置在网格的给定列中的便利方法。
      void GridPane.addRow​(int rowIndex, Node... children)
      将指定节点顺序放置在网格的给定行中的便利方法。
      static void AnchorPane.clearConstraints​(Node child)
      从子节点中删除所有锚窗格约束。
      static void BorderPane.clearConstraints​(Node child)
      从子节点中删除所有边框窗格约束。
      static void FlowPane.clearConstraints​(Node child)
      从子节点中删除所有flowpane约束。
      static void GridPane.clearConstraints​(Node child)
      从子节点中删除所有网格框约束。
      static void HBox.clearConstraints​(Node child)
      从子节点中删除所有hbox约束。
      static void StackPane.clearConstraints​(Node child)
      从子节点中删除所有stackpane约束。
      static void TilePane.clearConstraints​(Node child)
      从子节点中删除所有瓦楞纸板约束。
      static void VBox.clearConstraints​(Node child)
      从子节点中删除所有vbox约束。
      static Pos BorderPane.getAlignment​(Node child)
      如果设置，返回小孩的对齐约束。
      static Pos StackPane.getAlignment​(Node child)
      如果设置，返回小孩的对齐约束。
      static Pos TilePane.getAlignment​(Node node)
      如果设置，返回小孩的对齐约束。
      static Double AnchorPane.getBottomAnchor​(Node child)
      如果设置，返回小孩的底部锚约束。
      static Integer GridPane.getColumnIndex​(Node child)
      如果设置，则返回小孩的列索引约束。
      static Integer GridPane.getColumnSpan​(Node child)
      如果设置，则返回小孩的列跨度约束。
      static HPos GridPane.getHalignment​(Node child)
      如果设置，返回小孩的暂停约束。
      static Priority GridPane.getHgrow​(Node child)
      如果设置，返回小孩的hgrow约束。
      static Priority HBox.getHgrow​(Node child)
      如果设置，返回小孩的hgrow约束。
      static Double AnchorPane.getLeftAnchor​(Node child)
      如果设置，返回小孩的左锚约束。
      static Insets BorderPane.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets FlowPane.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets GridPane.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets HBox.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets StackPane.getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      static Insets TilePane.getMargin​(Node node)
      如果设置，返回小孩的边距约束。
      static Insets VBox.getMargin​(Node child)
      如果设置，返回小孩的边距属性。
      static Double AnchorPane.getRightAnchor​(Node child)
      如果设置，返回小孩的右侧锚点约束。
      static Integer GridPane.getRowIndex​(Node child)
      如果设置，返回小孩的行索引约束。
      static Integer GridPane.getRowSpan​(Node child)
      如果设置，返回小孩的行跨限制。
      static Double AnchorPane.getTopAnchor​(Node child)
      如果设置，返回小孩的顶部锚约束。
      static VPos GridPane.getValignment​(Node child)
      如果设置，则返回小孩的对齐约束。
      static Priority GridPane.getVgrow​(Node child)
      如果设置，则返回小孩的vgrow约束。
      static Priority VBox.getVgrow​(Node child)
      如果设置，返回小孩的vgrow属性。
      static Boolean GridPane.isFillHeight​(Node child)
      如果设置，返回小孩的垂直填充策略
      static Boolean GridPane.isFillWidth​(Node child)
      如果设置，返回小孩的横向填充策略
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment, boolean isSnapToPixel)
      其中规定了儿童的它的区域内的工具方法的父通过定义 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void Region.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void Region.positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment, boolean isSnapToPixel)
      通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void BorderPane.setAlignment​(Node child, Pos value)
      设置边框窗格中包含的子对象。
      static void StackPane.setAlignment​(Node child, Pos value)
      设置子堆栈的对齐方式。
      static void TilePane.setAlignment​(Node node, Pos value)
      设置小屋的对齐方式，包含在tilepane中。
      void BorderPane.setBottom​(Node value)
      设置属性值的底部。
      static void AnchorPane.setBottomAnchor​(Node child, Double value)
      设置锚定窗格包含的小孩的底部锚点。
      void BorderPane.setCenter​(Node value)
      设置物业中心的价值。
      static void GridPane.setColumnIndex​(Node child, Integer value)
      设置子窗格的列索引，当窗格包含时，它将从网格窗的该列开始定位。
      static void GridPane.setColumnSpan​(Node child, Integer value)
      设置子窗格包含的网格窗格的列跨度，以便它横跨该列数列。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex)
      设置子窗格中包含的列，行排列。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan)
      设置子网格中包含的列，列，列跨度和行跨度值。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment)
      设置网格位置，跨度和子对齐方式。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow)
      设置网格位置，跨度和子对齐方式。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow, Insets margin)
      设置网格位置，跨度，对齐方式，增加优先级，以及子窗格包含在网格中时的边距。
      static void GridPane.setFillHeight​(Node child, Boolean value)
      设置子窗格包含的窗格的垂直填充策略。
      static void GridPane.setFillWidth​(Node child, Boolean value)
      设置子窗格的水平填充策略。
      static void GridPane.setHalignment​(Node child, HPos value)
      设置子窗格的水平对齐方式。
      static void GridPane.setHgrow​(Node child, Priority value)
      设置子格中包含的网格的水平增长优先级。
      static void HBox.setHgrow​(Node child, Priority value)
      设置由hbox包含的小孩的横向增长优先级。
      void BorderPane.setLeft​(Node value)
      设置剩余属性的值。
      static void AnchorPane.setLeftAnchor​(Node child, Double value)
      设置锚定窗格所包含的小孩的左侧锚点。
      static void BorderPane.setMargin​(Node child, Insets value)
      设置由边框窗格包含的小孩的边距。
      static void FlowPane.setMargin​(Node child, Insets value)
      设置一个flowpane包含的孩子的边距。
      static void GridPane.setMargin​(Node child, Insets value)
      设置子窗格包含的格子的边距。
      static void HBox.setMargin​(Node child, Insets value)
      设置hbox包含的小孩的边距。
      static void StackPane.setMargin​(Node child, Insets value)
      设置一个堆栈包含的小孩的边距。
      static void TilePane.setMargin​(Node node, Insets value)
      设置小孩的边框，当包含一个瓦楞纸板时。
      static void VBox.setMargin​(Node child, Insets value)
      设置由vbox包含的小孩的边距。
      void BorderPane.setRight​(Node value)
      设置属性的值。
      static void AnchorPane.setRightAnchor​(Node child, Double value)
      为锚定窗格包含的小孩设置正确的锚点。
      static void GridPane.setRowIndex​(Node child, Integer value)
      设置子窗格的行索引，当窗格包含时，它将从网格的该行开始定位。
      static void GridPane.setRowSpan​(Node child, Integer value)
      设置子窗格包含的格子行的行跨度，以便它垂直跨越该行数。
      void BorderPane.setTop​(Node value)
      设置属性顶部的值。
      static void AnchorPane.setTopAnchor​(Node child, Double value)
      设置锚定窗格包含的小孩的顶部锚点。
      static void GridPane.setValignment​(Node child, VPos value)
      设置子窗格的垂直对齐方式。
      static void GridPane.setVgrow​(Node child, Priority value)
      设置子格中包含的网格的垂直成长优先级。
      static void VBox.setVgrow​(Node child, Priority value)
      设置由vbox包含的小孩的垂直成长优先级。
      Constructors in javafx.scene.layout with parameters of type Node
      Constructor 描述
      AnchorPane​(Node... children)
      与给定的孩子创建AnchorPane布局。
      BorderPane​(Node center)
      创建一个BorderPane布局，给定的Node作为BorderPane的中心。
      BorderPane​(Node center, Node top, Node right, Node bottom, Node left)
      创建BorderPane布局，其中给定的节点用于边框中每个主要布局区域。
      FlowPane​(double hgap, double vgap, Node... children)
      使用指定的hgap / vgap创建一个水平FlowPane布局。
      FlowPane​(Orientation orientation, double hgap, double vgap, Node... children)
      使用指定的方向和hgap / vgap创建FlowPane布局。
      FlowPane​(Orientation orientation, Node... children)
      使用指定的方向创建一个FlowPane布局，并创建hgap / vgap = 0。
      FlowPane​(Node... children)
      使用hgap / vgap = 0创建一个水平FlowPane布局。
      HBox​(double spacing, Node... children)
      创建一个具有指定间隔的HBox布局。
      HBox​(Node... children)
      创建一个间距= 0的HBox布局。
      Pane​(Node... children)
      创建一个窗格布局。
      StackPane​(Node... children)
      使用默认CENTER对齐方式创建StackPane布局。
      TilePane​(double hgap, double vgap, Node... children)
      创建一个水平的TilePane布局，其中prefColumn = 5和指定的hgap / vgap。
      TilePane​(Orientation orientation, double hgap, double vgap, Node... children)
      使用指定的方向hgap / vgap和prefRows / prefColumns = 5创建TilePane布局。
      TilePane​(Orientation orientation, Node... children)
      创建具有指定方向的TilePane布局，prefColumn / prefRows = 5和hgap / vgap = 0。
      TilePane​(Node... children)
      创建一个水平的TilePane布局，其中prefColumn = 5和hgap / vgap = 0。
      VBox​(double spacing, Node... children)
      创建一个VBox布局，其间指定间隔。
      VBox​(Node... children)
      创建一个间距= 0的VBox布局。

    • Uses of Node in javafx.scene.media

      Subclasses of Node in javafx.scene.media
      Modifier and Type Class 描述
      class  MediaView
      A Node ，提供Media由MediaPlayer播放的视图 。

    • Uses of Node in javafx.scene.shape

      Subclasses of Node in javafx.scene.shape
      Modifier and Type Class 描述
      class  Arc
      所述 Arc类表示2D弧对象，由中心点限定的，起始角度（度），角度范围（以度数表示的弧的长度），和一弧型（ ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND ）。
      class  Box
      Box类定义了具有指定大小的3维框。
      class  Circle
      Circle类创建一个具有指定半径和中心位置的新圆圈，以像素为单位。
      class  CubicCurve
      CubiCurve类定义了（x，y）坐标空间中的三次Bézier参数曲线段。
      class  Cylinder
      Cylinder类定义了具有指定尺寸的3维圆柱体。
      class  Ellipse
      Ellipse类创建一个新的椭圆，具有指定的大小和位置（以像素为单位）
      class  Line
      此行代表 (x,y)坐标空间中的线段。
      class  MeshView
      MeshView类定义了具有指定3D网格数据的曲面。
      class  Path
      Path类代表了一个简单的形状，并提供了基本构建和管理几何路径所需的设施。
      class  Polygon
      创建由x，y坐标数组定义的多边形。
      class  Polyline
      创建折线，由分段点数组定义。
      class  QuadCurve
      Quadcurve类定义了（x，y）坐标空间中的二次Bézier参数曲线段。
      class  Rectangle
      Rectangle类定义了一个具有指定大小和位置的矩形。
      class  Shape
      Shape类为表示某种形式的几何形状的对象提供了常见属性的定义。
      class  Shape3D
      Shape3D基类为表示某种形式的3D几何形状的对象提供了常用属性的定义。
      class  Sphere
      Sphere类定义了具有指定大小的三维球体。
      class  SVGPath
      SVGPath类表示通过从String解析SVG路径数据构建的简单形状。

    • Uses of Node in javafx.scene.text

      Subclasses of Node in javafx.scene.text
      Modifier and Type Class 描述
      class  Text
      Text类定义了一个显示文本的节点。
      class  TextFlow
      TextFlow是设计用于布置富文本的特殊布局。
      Constructors in javafx.scene.text with parameters of type Node
      Constructor 描述
      TextFlow​(Node... children)
      使用给定的子项创建TextFlow布局。

    • Uses of Node in javafx.scene.web

      Subclasses of Node in javafx.scene.web
      Modifier and Type Class 描述
      class  HTMLEditor
      允许用户编辑文本并将样式应用于此文本的控件。
      class  WebView
      WebView是一个Node ，管理一个WebEngine并显示其内容。
      Methods in javafx.scene.web that return types with arguments of type Node
      Modifier and Type | 方法 | 描述
      protected ObservableList<Node> | WebView.getChildren​()

    • Uses of Node in javafx.stage

      Methods in javafx.stage that return Node
      Modifier and Type 方法 描述
      Node PopupWindow.getOwnerNode​()
      获取属性ownerNode的值。
      Methods in javafx.stage that return types with arguments of type Node
      Modifier and Type 方法 描述
      ObservableList<Node> Popup.getContent​()
      Node的ObservableList将在此 Popup上呈现。
      ReadOnlyObjectProperty<Node> PopupWindow.ownerNodeProperty​()
      该弹出窗口的所有者的节点。
      Methods in javafx.stage with parameters of type Node
      Modifier and Type 方法 描述
      void PopupWindow.show​(Node ownerNode, double anchorX, double anchorY)
      显示屏幕上指定位置的弹出窗口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.ParallelCamera (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.ParallelCamera

No usage of javafx.scene.ParallelCamera
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.Parent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.Parent

  • Packages that use Parent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of Parent in javafx.scene

      Subclasses of Parent in javafx.scene
      Modifier and Type Class 描述
      class  Group
      一个 Group节点包含一个可观察的子节点列表，每当呈现此节点时，它们按顺序渲染。
      Methods in javafx.scene that return Parent
      Modifier and Type 方法 描述
      Parent Node.getParent​()
      获取属性parent的值。
      Parent Scene.getRoot​()
      获取属性根的值。
      Parent SubScene.getRoot​()
      获取属性根的值。
      Methods in javafx.scene that return types with arguments of type Parent
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Parent> Node.parentProperty​()
      这是 Node的父母。
      ObjectProperty<Parent> Scene.rootProperty​()
      定义场景图的根 Node 。
      ObjectProperty<Parent> SubScene.rootProperty​()
      定义 SubScene场景图的根 Node 。
      Methods in javafx.scene with parameters of type Parent
      Modifier and Type 方法 描述
      void Scene.setRoot​(Parent value)
      设置属性根的值。
      void SubScene.setRoot​(Parent value)
      设置属性根的值。
      Constructors in javafx.scene with parameters of type Parent
      Constructor 描述
      Scene​(Parent root)
      为特定根节点创建场景。
      Scene​(Parent root, double width, double height)
      为特定大小的特定根节点创建场景。
      Scene​(Parent root, double width, double height, boolean depthBuffer)
      构造一个由根组成的场景，宽度和高度的尺寸，并指定是否为此场景创建深度缓冲区。
      Scene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      Scene​(Parent root, double width, double height, Paint fill)
      创建具有特定大小和填充的特定根节点的场景。
      Scene​(Parent root, Paint fill)
      为具有填充的特定根节点创建场景。
      SubScene​(Parent root, double width, double height)
      为特定大小的特定根节点创建一个 SubScene 。
      SubScene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造一个 SubScene其中包含宽度和高度的根，指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。

    • Uses of Parent in javafx.scene.chart

      Subclasses of Parent in javafx.scene.chart
      Modifier and Type Class 描述
      class  AreaChart<X,Y>
      AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
      class  Axis<T>
      JavaFX中所有轴的基类，表示在图表区域上绘制的轴。
      class  BarChart<X,Y>
      绘制一个指示类别数据值的条形图。
      class  BubbleChart<X,Y>
      为一系列数据点绘制气泡的图表类型。
      class  CategoryAxis
      一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。
      class  Chart
      所有图表的基础类。
      class  LineChart<X,Y>
      线图绘制了连接数据点的行。
      class  NumberAxis
      一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
      class  PieChart
      显示PieChart。
      class  ScatterChart<X,Y>
      绘制一系列数据点符号的图表类型。
      class  StackedAreaChart<X,Y>
      StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。
      class  StackedBarChart<X,Y>
      StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。
      class  ValueAxis<T extends Number>
      数据定义为数字的轴。
      class  XYChart<X,Y>
      所有2轴图的图表基类。

    • Uses of Parent in javafx.scene.control

      Subclasses of Parent in javafx.scene.control
      Modifier and Type Class 描述
      class  Accordion
      手风琴是一组TitlePanes 。
      class  Button
      一个简单的按钮控件。
      class  ButtonBar
      ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。
      class  ButtonBase
      按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
      class  Cell<T>
      细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
      class  CheckBox
      三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
      class  ChoiceBox<T>
      ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
      class  ColorPicker
      ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
      class  ComboBox<T>
      对于最常见的ComboBox形式的2706857837387抽象类的实现，其中向用户提供弹出列表，以向他们提供他们可以选择的选项。
      class  ComboBoxBase<T>
      ComboBox类控件的抽象基类。
      class  Control
      所有用户界面控件的基类。
      class  DateCell
      DateCell由DatePicker用于在日历月中呈现单个网格单元格。
      class  DatePicker
      DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
      class  DialogPane
      DialogPane应该被认为是在一个Dialog实例中显示的根节点 。
      class  Hyperlink
      一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
      class  IndexedCell<T>
      一个Cell的实现，其中包含一个索引属性，该属性映射到可视化的底层数据模型中。
      class  Label
      标签是不可编辑的文本控件。
      class  Labeled
      标签Control是与其用户界面的一部分相关联的文本内容。
      class  ListCell<T>
      Cell类型在ListView实例中使用。
      class  ListView<T>
      ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
      class  MenuBar
      MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。
      class  MenuButton
      MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
      class  Pagination
      分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
      class  PasswordField
      掩码输入字符的文本字段。
      protected class  PopupControl.CSSBridge
      弹出窗口和场景图之间的链接。
      class  ProgressBar
      ProgressIndator的专业化表示为横杠。
      class  ProgressIndicator
      用于指示进度的循环控制，无限（也称为不确定）或有限。
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  ScrollBar
      具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。
      class  ScrollPane
      提供其内容的滚动，剪切视口的控件。
      class  Separator
      水平或垂直分隔线。
      class  Slider
      滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。
      class  Spinner<T>
      单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。
      class  SplitMenuButton
      SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。
      class  SplitPane
      具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
      class  TableCell<S,T>
      在TableView中表示单行/列交集。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TableView<S>
      TableView控件旨在可视化无限数量的数据行，分为列。
      class  TabPane
      允许在一组Tabs之间切换的控件 。
      class  TextArea
      文本输入组件，允许用户输入多行纯文本。
      class  TextField
      文本输入组件，允许用户输入一行未格式化的文本。
      class  TextInputControl
      文本输入控件的抽象基类。
      class  TitledPane
      TitledPane是一个可以打开和关闭的标题的面板。
      class  ToggleButton
      A ToggleButton是具有选择能力的专业控制。
      class  ToolBar
      ToolBar是一个可以水平或垂直显示项目的控件。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
      class  TreeTableView<S>
      TreeTableView控件旨在可视化无限数量的数据行，分为列。
      class  TreeView<T>
      TreeView控件提供了一个树根视图（类型为TreeItem ）。

    • Uses of Parent in javafx.scene.control.cell

      Subclasses of Parent in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含一个ListCell实现的类，其中可以在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格中绘制一个CheckBox节点，同时支持常见的交互（ 稍后更详细地讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含ListCell实现的类，在单元格中绘制一个ChoiceBox节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeCell<T>
      一个包含一个ListCell实现的类，它在单元格中绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，该单元在单元格内绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格内绘制一个27068578493025节点。
      class  ComboBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含TableCell实现的类，在单元格内绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含TreeTableCell实现的类，它在单元格内绘制一个ProgressBar节点。
      class  TextFieldListCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个包含TableCell实现的类，它在单元格内绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格内绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格中绘制一个TextField节点。

    • Uses of Parent in javafx.scene.control.skin

      Subclasses of Parent in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  NestedTableColumnHeader
      此类用于构造TableView的头。
      class  TableColumnHeader
      负责绘制单列标题的区域。
      class  TableHeaderRow
      负责绘制整列列标题的区域。
      class  VirtualFlow<T extends IndexedCell>
      使用基于单元的机制实现虚拟化容器。

    • Uses of Parent in javafx.scene.layout

      Subclasses of Parent in javafx.scene.layout
      Modifier and Type Class 描述
      class  AnchorPane
      AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。
      class  BorderPane
      BorderPane在上，左，右，底部和中间位置摆放孩子。
      class  FlowPane
      FlowPane将其孩子摆放在流过玻璃边界的流中。
      class  GridPane
      GridPane将其孩子放在一个灵活的行和列格网中。
      class  HBox
      HBox将孩子放在一排水平排列中。
      class  Pane
      布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
      class  Region
      Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
      class  StackPane
      StackPane将它的孩子放在一个靠前的堆叠中。
      class  TilePane
      TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。
      class  VBox
      VBox把孩子放在一个垂直的立柱上。

    • Uses of Parent in javafx.scene.text

      Subclasses of Parent in javafx.scene.text
      Modifier and Type Class 描述
      class  TextFlow
      TextFlow是设计用于布置富文本的特殊布局。

    • Uses of Parent in javafx.scene.web

      Subclasses of Parent in javafx.scene.web
      Modifier and Type Class 描述
      class  HTMLEditor
      允许用户编辑文本并将样式应用于此文本的控件。
      class  WebView
      WebView是一个Node ，管理一个WebEngine并显示其内容。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.PerspectiveCamera (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.PerspectiveCamera

No usage of javafx.scene.PerspectiveCamera
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.PointLight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.PointLight

No usage of javafx.scene.PointLight
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.Scene (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.Scene

  • Packages that use Scene
    软件包 描述
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of Scene in javafx.embed.swing

      Methods in javafx.embed.swing that return Scene
      Modifier and Type 方法 描述
      Scene JFXPanel.getScene​()
      返回附加到此 JFXPanel的JavaFX场景。
      Methods in javafx.embed.swing with parameters of type Scene
      Modifier and Type 方法 描述
      void JFXPanel.setScene​(Scene newScene)
      附加一个 Scene对象显示在这个 JFXPanel 。

    • Uses of Scene in javafx.scene

      Methods in javafx.scene that return Scene
      Modifier and Type 方法 描述
      Scene Node.getScene​()
      获取属性场景的值。
      Methods in javafx.scene that return types with arguments of type Scene
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Scene> Node.sceneProperty​()
      这Node是这个Node的一部分。

    • Uses of Scene in javafx.stage

      Methods in javafx.stage that return Scene
      Modifier and Type 方法 描述
      Scene Window.getScene​()
      获取属性场景的值。
      Methods in javafx.stage that return types with arguments of type Scene
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Scene> Window.sceneProperty​()
      Scene要呈现在这个 Window 。
      Methods in javafx.stage with parameters of type Scene
      Modifier and Type 方法 描述
      protected void PopupWindow.setScene​(Scene scene)
      注意子类：PopupWindow使用的场景是非常具体由PopupWindow管理的。
      void Stage.setScene​(Scene value)
      指定此舞台上要使用的场景。
      protected void Window.setScene​(Scene value)
      设置属性场景的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.SceneAntialiasing (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.SceneAntialiasing

  • Packages that use SceneAntialiasing
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of SceneAntialiasing in javafx.scene

      Fields in javafx.scene declared as SceneAntialiasing
      Modifier and Type Field 描述
      static SceneAntialiasing SceneAntialiasing.BALANCED
      实现抗锯齿优化，实现质量和性能的平衡
      static SceneAntialiasing SceneAntialiasing.DISABLED
      禁用反锯齿
      Methods in javafx.scene that return SceneAntialiasing
      Modifier and Type 方法 描述
      SceneAntialiasing Scene.getAntiAliasing​()
      返回 SceneAntialiasing为这个 Scene 。
      SceneAntialiasing SubScene.getAntiAliasing​()
      返回定义 SceneAntialiasing这个 SubScene 。
      Constructors in javafx.scene with parameters of type SceneAntialiasing
      Constructor 描述
      Scene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。
      SubScene​(Parent root, double width, double height, boolean depthBuffer, SceneAntialiasing antiAliasing)
      Constructs a SubScene consisting of a root, with a dimension of width and height, specifies whether a depth buffer is created for this scene and specifies whether scene anti-aliasing is requested.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.SnapshotParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.SnapshotParameters

  • Packages that use SnapshotParameters
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of SnapshotParameters in javafx.scene

      Methods in javafx.scene that return SnapshotParameters
      Modifier and Type 方法 描述
      SnapshotParameters SnapshotResult.getSnapshotParameters​()
      获取用于生成快照的SnapshotParameters的副本。
      Methods in javafx.scene with parameters of type SnapshotParameters
      Modifier and Type 方法 描述
      WritableImage Node.snapshot​(SnapshotParameters params, WritableImage image)
      获取该节点的快照，并在渲染图像准备就绪时返回。
      void Node.snapshot​(Callback<SnapshotResult,Void> callback, SnapshotParameters params, WritableImage image)
      在下一帧获取该节点的快照，并在映像准备就绪时调用指定的回调方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.SnapshotResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.SnapshotResult

  • Packages that use SnapshotResult
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of SnapshotResult in javafx.scene

      Method parameters in javafx.scene with type arguments of type SnapshotResult
      Modifier and Type 方法 描述
      void Node.snapshot​(Callback<SnapshotResult,Void> callback, SnapshotParameters params, WritableImage image)
      在下一帧获取该节点的快照，并在映像准备就绪时调用指定的回调方法。
      void Scene.snapshot​(Callback<SnapshotResult,Void> callback, WritableImage image)
      在下一帧拍摄此场景的快照，并在图像准备就绪时调用指定的回调方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.SubScene (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.SubScene

No usage of javafx.scene.SubScene
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Accordion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Accordion

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Accordion
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class Accordion
extends Control

    手风琴是一组TitlePanes 。 一次只能打开一个TitledPane。

    手风琴中的TitledPane内容可以是任何Node ，如UI控件或添加到布局容器的节点组。

    不建议为此控件设置MinHeight，PrefHeight或MaxHeight。 出现意外行为，因为当打开或关闭TitledPane时手风琴的高度会发生变化。

    手风琴将focusTraversable设为false。

    例：

       TitledPane t1 = new TitledPane("T1", new Button("B1")); TitledPane t2 = new TitledPane("T2", new Button("B2")); TitledPane t3 = new TitledPane("T3", new Button("B3")); Accordion accordion = new Accordion(); accordion.getPanes().addAll(t1, t2, t3);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<TitledPane> expandedPane
      手风琴中扩大的TitledPane。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Accordion​()
      创建一个没有TitledPanes的新手风琴。
      Accordion​(TitledPane... titledPanes)
      创建一个新的手风琴与给定的TitledPanes在其中显示。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      ObjectProperty<TitledPane> expandedPaneProperty​()
      手风琴中扩大的TitledPane。
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      TitledPane getExpandedPane​()
      在手风琴中获得扩大的“TitledPane”。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      ObservableList<TitledPane> getPanes​()
      获得此手风琴中的TitledPane的列表。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。
      void setExpandedPane​(TitledPane value)
      目前可见的扩展TitledPane 。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • expandedPane

        public final ObjectProperty<TitledPane> expandedPaneProperty
        手风琴中扩大的TitledPane。
        结果
        手风琴中扩大的TitledPane。

    • 构造方法详细信息

      • Accordion

        public Accordion​()
        创建一个没有TitledPanes的新手风琴。

      • Accordion

        public Accordion​(TitledPane... titledPanes)
        创建一个新的手风琴与给定的TitledPanes在其中显示。
        参数
        titledPanes - The TitledPanes显示在手风琴里面。
        从以下版本开始：
        JavaFX 8u40

    • 方法详细信息

      • setExpandedPane

        public final void setExpandedPane​(TitledPane value)

        当前可见的扩展的TitledPane 。 虽然技术上可以将展开的窗格设置为不在getPanes()中的值，但这样做将被皮肤处理，就好像expandedPane为空。 如果将窗格设置为扩展窗格，并且随后从getPanes()中删除，则扩展窗格将被设置为null（如果可能）。 （例如，如果手动将扩展窗格绑定到某些值，则不可能）。

        参数
        value - 扩大TitledPane

      • getExpandedPane

        public final TitledPane getExpandedPane​()
        在手风琴中获得扩大的“TitledPane”。 如果展开的窗格已被删除或没有展开的TitledPane返回null 。
        结果
        手风琴中扩大的TitledPane。

      • expandedPaneProperty

        public final ObjectProperty<TitledPane> expandedPaneProperty​()
        手风琴中扩大的TitledPane。
        结果
        手风琴中扩大的TitledPane。

      • getPanes

        public final ObservableList<TitledPane> getPanes​()
        获得此手风琴中的TitledPane的列表。 更改此ObservableList将立即导致Accordion更新以显示此ObservableList的新内容。
        结果
        此手风琴中的TitledPane列表。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • requestLayout

        public void requestLayout​()
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果此父对象是布局根或非托管，则将直接添加到场景的脏布局列表中，否则将调用requestParentLayout。

        重写：
        requestLayout在 Parent

      • getContentBias

        public Orientation getContentBias​()
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        重写：
        getContentBias在 Node
        结果
        width / height依赖的方向，如果没有则为null
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Alert (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Alert

  • java.lang.Object
    • javafx.scene.control.Dialog<ButtonType>
      • javafx.scene.control.Alert
  • All Implemented Interfaces:
    EventTarget

    public class Alert
extends Dialog<ButtonType>
    Alert类对Dialog类进行子类化，并为许多预构建的对话框类型提供支持，可以轻松向用户显示提示响应。 因此，对于许多用户来说，Alert类是最适合他们需要的类（而不是直接使用Dialog ）。 或者，希望通过使用TextInputDialog和ChoiceDialog来更好地服务于想要提示用户进行文本输入或从选项列表中进行选择的用户。

    创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。 它是通过在该值警报实例将自身适当配置（由许多的设置默认值Dialog个属性，包括title ， header ，并graphic ，以及默认buttons预计，在给定的一个对话框，类型。

    要实例化（但尚未显示）警报，只需使用以下代码： Alert alert = new Alert(AlertType.CONFIRMATION, "Are you sure you want to format your system?");

    一旦警报被实例化，我们必须显示。 通常，警报（和一般对话框）以模态和阻止的方式显示。 'Modal'意味着该对话框可以防止用户在显示时与所拥有的应用程序进行交互，而'blocking'意味着代码执行在显示对话框的时候停止。 这意味着您可以显示一个对话框，等待用户响应，然后继续运行直接在show调用之后的代码，使开发人员能够立即处理来自对话框的用户输入（如果相关）。

    默认情况下，JavaFX对话框是模态的（您可以通过Dialog.initModality(javafx.stage.Modality) API更改此对话框 ）。 要指定是否要阻止或不阻止对话框，开发人员只需选择分别调用Dialog.showAndWait()或Dialog.show() 。 默认情况下，大多数开发人员应该选择使用Dialog.showAndWait() ，因为在这些情况下易于编码。 下面显示的是三个代码片段，显示了三个同样有效的方式来显示上面指定的“警报”对话框：

    选项1：“传统”方法

      Optional<ButtonType> result = alert.showAndWait(); if (result.isPresent() && result.get() == ButtonType.OK) { formatSystem(); }

    选项2：传统+可选方法

      alert.showAndWait().ifPresent(response -> { if (response == ButtonType.OK) { formatSystem(); } });

    选项3：完全lambda方法

      alert.showAndWait() .filter(response -> response == ButtonType.OK) .ifPresent(response -> formatSystem());

    上面列出的三个选项没有更好或更差的选择，所以鼓励开发人员自己设计风格偏好。 显示上述内容的目的是帮助开发人员介绍API6.0685923290699 API，这是Java 8中的新增功能，可能是许多开发人员的外部 API。

    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Dialog ， Alert.AlertType ， TextInputDialog ， ChoiceDialog

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Alert.AlertType> alertType
      创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。

      • Properties inherited from class javafx.scene.control.Dialog

        contentText, dialogPane, graphic, headerText, height, onCloseRequest, onHidden, onHiding, onShowing, onShown, resizable, resultConverter, result, showing, title, width, x, y

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Alert.AlertType
      包含Alert类可用于预先填充各种属性的可用的预构建警报类型的枚举 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Alert​(Alert.AlertType alertType)
      使用给定的AlertType创建警报（参考Alert.AlertType文档，了解哪一个是最合适的）。
      Alert​(Alert.AlertType alertType, String contentText, ButtonType... buttons)
      使用给定的contentText，ButtonTypes和AlertType创建警报（参考Alert.AlertType文档了解哪一个是最合适的）。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Alert.AlertType> alertTypeProperty​()
      创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。
      Alert.AlertType getAlertType​()
      获取属性alertType的值。
      ObservableList<ButtonType> getButtonTypes​()
      返回此Alert实例当前设置的所有ButtonType个实例中的ObservableList 。
      void setAlertType​(Alert.AlertType alertType)
      设置属性alertType的值。

      • Methods inherited from class javafx.scene.control.Dialog

        buildEventDispatchChain, close, contentTextProperty, dialogPaneProperty, getContentText, getDialogPane, getGraphic, getHeaderText, getHeight, getModality, getOnCloseRequest, getOnHidden, getOnHiding, getOnShowing, getOnShown, getOwner, getResult, getResultConverter, getTitle, getWidth, getX, getY, graphicProperty, headerTextProperty, heightProperty, hide, initModality, initOwner, initStyle, isResizable, isShowing, onCloseRequestProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, resizableProperty, resultConverterProperty, resultProperty, setContentText, setDialogPane, setGraphic, setHeaderText, setHeight, setOnCloseRequest, setOnHidden, setOnHiding, setOnShowing, setOnShown, setResizable, setResult, setResultConverter, setTitle, setWidth, setX, setY, show, showAndWait, showingProperty, titleProperty, widthProperty, xProperty, yProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • alertType

        public final ObjectProperty<Alert.AlertType> alertTypeProperty
        创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。 它是通过在该值警报实例将自身适当配置（由许多的设置默认值Dialog个属性，包括title ， header ，并graphic ，以及默认buttons预计，在给定的一个对话框，类型。
        另请参见：
        getAlertType() ， setAlertType(Alert.AlertType)

    • 构造方法详细信息

      • Alert

        public Alert​(Alert.AlertType alertType)
        使用给定的AlertType创建警报（请参阅Alert.AlertType文档以了解哪一个是最合适的）。

        通过传递一个警告类型，默认值title ， headerText ，并graphic属性设置，以及相关buttons正在安装。 一旦Alert被实例化，开发人员就可以根据需要修改警报的值。

        重要的是要注意，没有默认值设置的属性，因此开发人员必须设置的属性是content text属性（或者，如果他们想要更复杂的警报，开发人员可能会调用alert.getDialogPane().setContent(Node) ）。 如果未设置contentText（或内容）属性，则没有向最终用户显示有用的信息。

        参数
        alertType - 给定AlertType的警报

      • Alert

        public Alert​(Alert.AlertType alertType,
             String contentText,
             ButtonType... buttons)
        使用给定的contentText，ButtonTypes和AlertType创建警报（请参阅Alert.AlertType文档，了解哪一个是最合适的）。

        通过传递可变数量的ButtonType参数，开发人员直接覆盖将在对话框中显示的默认按钮，用varargs数组中指定的任何内容替换预定义的按钮。

        通过使在警告类型，默认值title ， headerText ，和graphic属性被设置。 一旦Alert被实例化，开发人员就可以根据需要修改警报的值。

        参数
        alertType - 警报类型
        contentText - 内容文本
        buttons - 按钮类型

    • 方法详细信息

      • getAlertType

        public final Alert.AlertType getAlertType​()
        获取属性alertType的值。
        Property description:
        创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。 它是通过在该值警报实例将自身适当配置（由许多的设置默认值Dialog个属性，包括title ， header ，并graphic ，以及默认buttons预计，在给定的一个对话框，类型。

      • setAlertType

        public final void setAlertType​(Alert.AlertType alertType)
        设置属性alertType的值。
        Property description:
        创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。 它是通过在该值警报实例将自身适当配置（由许多的设置默认值Dialog个属性，包括title ， header ，并graphic ，以及默认buttons预计，在给定的一个对话框，类型。

      • alertTypeProperty

        public final ObjectProperty<Alert.AlertType> alertTypeProperty​()
        创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。 它是通过在该值警报实例将自身适当配置（由许多的设置默认值Dialog个属性，包括title ， header ，并graphic ，以及默认buttons预计，在给定的一个对话框，类型。
        另请参见：
        getAlertType() ， setAlertType(Alert.AlertType)

      • getButtonTypes

        public final ObservableList<ButtonType> getButtonTypes​()
        返回当前在此Alert实例中设置的所有ButtonType个实例中的ObservableList 。 ButtonType可以是预定义类型之一（例如ButtonType.OK ），也可以是自定义类型（通过ButtonType(String)或ButtonType(String, javafx.scene.control.ButtonBar.ButtonData)构造函数创建）。

        读者应参考ButtonType类文档以获得更多的细节，但是在较高的水平，每个按钮类型实例被转换为节点（虽然最常用的是Button ）经由（重写） DialogPane.createButton(ButtonType)方法上DialogPane 。

        结果
        一个ObservableList所有ButtonType实例当前设置此警报实例内部
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Alert.AlertType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum Alert.AlertType

  • java.lang.Object
    • java.lang.Enum<Alert.AlertType>
      • javafx.scene.control.Alert.AlertType
  • All Implemented Interfaces:
    Serializable ， Comparable<Alert.AlertType>
    Enclosing class:
    Alert

    public static enum Alert.AlertType
extends Enum<Alert.AlertType>
    包含Alert类可用于预先填充各种属性的可用的预构建警报类型的枚举 。
    从以下版本开始：
    JavaFX 8u40

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CONFIRMATION
      CONFIRMATION警报类型配置警报对话框，以提示对话框的内容正在寻求用户确认的方式显示。
      ERROR
      ERROR警报类型配置警报对话框以表明出现问题的方式出现。
      INFORMATION
      “信息”警报类型配置“警报”对话框，以提示对话框的内容通知用户一条信息的方式显示。
      NONE
      NONE警报类型具有在Alert中未设置任何默认属性的效果。
      WARNING
      “警告”警告类型将“警报”对话框配置为以提示对话框的内容向用户警告某些事实或操作的方式显示。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Alert.AlertType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Alert.AlertType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NONE

        public static final Alert.AlertType NONE
        NONE警报类型具有在Alert中未设置任何默认属性的效果。

      • INFORMATION

        public static final Alert.AlertType INFORMATION
        “信息”警报类型配置“警报”对话框，以提示对话框的内容通知用户一条信息的方式显示。 这包括一个“信息”图像，适当的标题和标题，只需一个确定按钮，用户点击就可以关闭对话框。

      • WARNING

        public static final Alert.AlertType WARNING
        “警告”警告类型将“警报”对话框配置为以提示对话框的内容向用户警告某些事实或操作的方式显示。 这包括一个“警告”图像，一个适当的标题和标题，只需一个确定按钮，用户点击即可关闭该对话框。

      • CONFIRMATION

        public static final Alert.AlertType CONFIRMATION
        CONFIRMATION警报类型配置警报对话框，以提示对话框的内容正在寻求用户确认的方式显示。 这包括“确认”图像，适当的标题和标题，以及用户单击确定和取消按钮以关闭对话框。

      • ERROR

        public static final Alert.AlertType ERROR
        ERROR警报类型配置警报对话框以表明出现问题的方式出现。 这包括一个“错误”图像，适当的标题和标题，只需一个确定按钮，用户点击即可关闭该对话框。

    • 方法详细信息

      • values

        public static Alert.AlertType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Alert.AlertType c : Alert.AlertType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Alert.AlertType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Button (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Button

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.ButtonBase
                • javafx.scene.control.Button
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class Button
extends ButtonBase

    一个简单的按钮控件。 按钮控件可以包含文本和/或图形。 按钮控件有三种不同的模式

    • 正常：普通按钮。
    • 默认值：默认按钮的呈现方式不同，使用户明白，如果不清楚应该选择什么，它应该是默认选择。 默认按钮的行为根据显示的平台而有所不同：
      • Windows / Linux：当有焦点时，默认按钮接收到ENTER按键。 当默认按钮没有焦点，并且焦点在另一个按钮控件上时，按ENTER键将被其他非默认按钮接收。 当焦点位于用户界面的其他位置，而不是任何按钮时，如果指定了默认按钮，则按ENTER键将被默认按钮接收，并且场景中没有其他节点首先消耗。
      • Mac OS X：默认按钮是用户界面中唯一响应ENTER键的按钮。 如果焦点在另一个非默认按钮和ENTER按下，事件只会被默认的按钮接收。 在macOS上，启动非默认按钮的唯一方法是通过SPACE键。
    • 取消：取消按钮是接收键盘VK_ESC的按钮，如果场景中没有其他节点消耗它。

    当按下并释放按钮时，会发送一个ActionEvent 。 您的应用程序可以通过实现执行基于此事件的一些动作EventHandler处理ActionEvent 。 按钮也可以鼠标事件通过实施应对EventHandler处理MouseEvent

    默认情况下为Button启用助记符分析。

    例：

      Button button = new Button("Click Me");
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty cancelButton
      取消按钮是接收键盘VK_ESC的按钮，如果场景中没有其他节点消耗它。
      BooleanProperty defaultButton
      默认按钮是接收键盘VK_ENTER的按钮，如果场景中没有其他节点消耗它。

      • Properties inherited from class javafx.scene.control.ButtonBase

        armed, onAction

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Button​()
      为其标签创建一个空字符串的按钮。
      Button​(String text)
      创建具有指定文本的按钮作为其标签。
      Button​(String text, Node graphic)
      创建一个带有指定文本和图标的按钮。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanProperty cancelButtonProperty​()
      取消按钮是接收键盘VK_ESC的按钮，如果场景中没有其他节点消耗它。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      BooleanProperty defaultButtonProperty​()
      默认按钮是接收键盘VK_ENTER的按钮，如果场景中没有其他节点消耗它。
      void fire​()
      当用户手势指示应发生 ButtonBase的事件时调用。
      boolean isCancelButton​()
      获取属性cancelButton的值。
      boolean isDefaultButton​()
      获取属性defaultButton的值。
      void setCancelButton​(boolean value)
      设置属性cancelButton的值。
      void setDefaultButton​(boolean value)
      设置属性defaultButton的值。

      • Methods inherited from class javafx.scene.control.ButtonBase

        arm, armedProperty, disarm, executeAccessibleAction, getOnAction, isArmed, onActionProperty, setOnAction

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • defaultButton

        public final BooleanProperty defaultButtonProperty
        默认按钮是接收键盘VK_ENTER的按钮，如果场景中没有其他节点消耗它。
        另请参见：
        isDefaultButton() ， setDefaultButton(boolean)

      • cancelButton

        public final BooleanProperty cancelButtonProperty
        取消按钮是接收键盘VK_ESC的按钮，如果场景中没有其他节点消耗它。
        另请参见：
        isCancelButton() ， setCancelButton(boolean)

    • 构造方法详细信息

      • Button

        public Button​()
        为其标签创建一个空字符串的按钮。

      • Button

        public Button​(String text)
        创建具有指定文本的按钮作为其标签。
        参数
        text - 其标签的文本字符串。

      • Button

        public Button​(String text,
              Node graphic)
        创建一个带有指定文本和图标的按钮。
        参数
        text - 其标签的文本字符串。
        graphic - 其标签的图标。

    • 方法详细信息

      • setDefaultButton

        public final void setDefaultButton​(boolean value)
        设置属性defaultButton的值。
        Property description:
        默认按钮是接收键盘VK_ENTER的按钮，如果场景中没有其他节点消耗它。

      • isDefaultButton

        public final boolean isDefaultButton​()
        获取属性defaultButton的值。
        Property description:
        默认按钮是接收键盘VK_ENTER的按钮，如果场景中没有其他节点消耗它。

      • defaultButtonProperty

        public final BooleanProperty defaultButtonProperty​()
        默认按钮是接收键盘VK_ENTER的按钮，如果场景中没有其他节点消耗它。
        另请参见：
        isDefaultButton() ， setDefaultButton(boolean)

      • setCancelButton

        public final void setCancelButton​(boolean value)
        设置属性cancelButton的值。
        Property description:
        取消按钮是接收键盘VK_ESC的按钮，如果场景中没有其他节点消耗它。

      • isCancelButton

        public final boolean isCancelButton​()
        获取属性cancelButton的值。
        Property description:
        取消按钮是接收键盘VK_ESC的按钮，如果场景中没有其他节点消耗它。

      • cancelButtonProperty

        public final BooleanProperty cancelButtonProperty​()
        取消按钮是接收键盘VK_ESC的按钮，如果场景中没有其他节点消耗它。
        另请参见：
        isCancelButton() ， setCancelButton(boolean)

      • fire

        public void fire​()
        当用户手势指示应发生ButtonBase的事件时调用。

        如果调用，无论ButtonBase.arm()的状态如何，都将执行此方法。

        Specified by:
        fire在 ButtonBase

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤，或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin中的 Control
        结果
        new instance of default skin for this control. If null then the control will have no skin unless one is provided by css.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ButtonBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ButtonBar

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ButtonBar
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ButtonBar
extends Control
    ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。 换句话说，任何节点都可以被注释（通过setButtonData(Node, ButtonData)方法，放置在ButtonBar内（通过getButtons()列表），然后根据它们的注释将其定位在按钮列表中的所有其他节点以及总体上为ButtonBar指定的button order 。

    均匀按钮尺寸

    默认情况下，所有按钮在ButtonBar中均匀的大小，这意味着所有按钮都占据最宽按钮的宽度。 可以根据每个按钮选择退出，但是使用布尔值为false调用setButtonUniformSize(Node, boolean)方法。

    如果一个按钮被排除在均匀尺寸之外，那么它们都不能从其首选尺寸被调整大小，并且也被排除在测量过程之外，因此其尺寸不会影响对ButtonBar中所有按钮计算的最大尺寸。

    截图

    由于ButtonBar具有Windows，Mac OS和Linux的内置支持，所以下面显示了三个屏幕截图，在三个操作系统中都有相同的按钮。

    视窗：

    Mac OS：

    Linux的：

    代码示例

    实例化和使用ButtonBar很简单，只需执行以下操作：

       // Create the ButtonBar instance ButtonBar buttonBar = new ButtonBar(); // Create the buttons to go into the ButtonBar Button yesButton = new Button("Yes"); ButtonBar.setButtonData(yesButton, ButtonData.YES); Button noButton = new Button("No"); ButtonBar.setButtonData(noButton, ButtonData.NO); // Add buttons to the ButtonBar buttonBar.getButtons().addAll(yesButton, noButton);

    上面的代码示例将相对于用户操作系统定位“是”和“否”按钮。 这意味着在Windows和Linux上，Yes按钮将出现在No按钮之前，而在Mac OS上，它将为No，然后是Yes。

    在大多数情况下，操作系统特定的布局是最佳选择，但是在需要自定义布局的情况下，可以修改button order property 。 这些是令人难以置信的字符串，它们是按钮顺序的缩写。 Windows，Mac OS和Linux的内置订单有：

    ButtonBar Layout Table Windows: L_E+U+FBXI_YNOCAH_R Mac OS: L_HE+U+FBIX_NCYOA_R Linux: L_HE+UNYACBXIO_R

    您应该参考ButtonBar.ButtonData枚举来说明这些字符是什么意思。 但是，如果您的ButtonBar仅包含ButtonBar.ButtonData.YES和ButtonBar.ButtonData.NO按钮，则您始终想要在no按钮之前的是按钮，并且您希望按钮为right-aligned ，则可以执行以下操作：

       // Create the ButtonBar instance ButtonBar buttonBar = new ButtonBar(); // Set the custom button order buttonBar.setButtonOrder("+YN");
    从以下版本开始：
    JavaFX 8u40
    另请参见：
    ButtonBar.ButtonData

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty buttonMinWidth
      指定放置在此按钮栏中的所有按钮的最小宽度。
      StringProperty buttonOrder
      标准按钮栏中典型按钮的顺序。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ButtonBar.ButtonData
      枚举所有可用的按钮数据注释。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String BUTTON_ORDER_LINUX
      Linux上的默认按钮排序（特别是GNOME）。
      static String BUTTON_ORDER_MAC_OS
      Mac OS上的默认按钮排序。
      static String BUTTON_ORDER_NONE
      一个按钮排序字符串，指定没有按钮排序。
      static String BUTTON_ORDER_WINDOWS
      Windows上的默认按钮排序。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ButtonBar​()
      使用用户操作系统的默认属性创建默认的ButtonBar实例。
      ButtonBar​(String buttonOrder)
      使用给定的按钮顺序创建ButtonBar（有关详细信息，请参阅 buttonOrderProperty() ）。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty buttonMinWidthProperty​()
      指定放置在此按钮栏中的所有按钮的最小宽度。
      StringProperty buttonOrderProperty​()
      标准按钮栏中典型按钮的顺序。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      static ButtonBar.ButtonData getButtonData​(Node button)
      返回给定按钮上先前设置的ButtonData属性。
      double getButtonMinWidth​()
      返回放置在此按钮栏中的所有按钮的最小宽度。
      String getButtonOrder​()
      返回当前的 button order 。
      ObservableList<Node> getButtons​()
      在此ObservableList内放置按钮将指示ButtonBar根据其指定的ButtonBar.ButtonData将它们相对放置 。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      static boolean isButtonUniformSize​(Node button)
      返回给定节点是否是统一尺寸计算的一部分。
      static void setButtonData​(Node button, ButtonBar.ButtonData buttonData)
      在给定的按钮上设置给定的ButtonData。
      void setButtonMinWidth​(double value)
      设置放置在此按钮栏中的所有按钮的最小宽度。
      void setButtonOrder​(String buttonOrder)
      设置 button order
      static void setButtonUniformSize​(Node button, boolean uniformSize)
      默认情况下，所有按钮在ButtonBar中均匀的大小，这意味着所有按钮都占据最宽按钮的宽度。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • buttonOrder

        public final StringProperty buttonOrderProperty
        标准按钮栏中典型按钮的顺序。 它是每个ButtonBar.ButtonData枚举值一个字母。 对于操作系统的默认按钮的订单也可用： BUTTON_ORDER_WINDOWS ， BUTTON_ORDER_MAC_OS ，并BUTTON_ORDER_LINUX 。
        另请参见：
        getButtonOrder() ， setButtonOrder(String)

      • buttonMinWidth

        public final DoubleProperty buttonMinWidthProperty
        指定放置在此按钮栏中的所有按钮的最小宽度。
        另请参见：
        getButtonMinWidth() ， setButtonMinWidth(double)

    • 字段详细信息

      • BUTTON_ORDER_WINDOWS

        public static final String BUTTON_ORDER_WINDOWS
        Windows上的默认按钮排序。
        另请参见：
        Constant Field Values

      • BUTTON_ORDER_MAC_OS

        public static final String BUTTON_ORDER_MAC_OS
        Mac OS上的默认按钮排序。
        另请参见：
        Constant Field Values

      • BUTTON_ORDER_LINUX

        public static final String BUTTON_ORDER_LINUX
        Linux上的默认按钮排序（特别是GNOME）。
        另请参见：
        Constant Field Values

      • BUTTON_ORDER_NONE

        public static final String BUTTON_ORDER_NONE
        一个按钮排序字符串，指定没有按钮排序。 换句话说，按钮将按getButtons()列表中的顺序放置。 与使用HBox不同的布局的唯一方面是按钮是右对齐的。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ButtonBar

        public ButtonBar​()
        使用用户操作系统的默认属性创建默认的ButtonBar实例。

      • ButtonBar

        public ButtonBar​(String buttonOrder)
        使用给定的按钮顺序创建ButtonBar（有关详细信息，请参阅 buttonOrderProperty() ）。
        参数
        buttonOrder - 在此按钮栏实例中使用的按钮顺序。

    • 方法详细信息

      • setButtonData

        public static void setButtonData​(Node button,
                                 ButtonBar.ButtonData buttonData)
        在给定的按钮上设置给定的ButtonData。 如果此按钮随后放置在ButtonBar中 ，它将被放置在相对于条中所有其他按钮的正确位置。
        参数
        button - 使用给定的ButtonBar.ButtonData值进行注释的按钮。
        buttonData - ButtonData将按钮指定为。

      • getButtonData

        public static ButtonBar.ButtonData getButtonData​(Node button)
        返回给定按钮上先前设置的ButtonData属性。 如果没有设置，这个方法将返回null。
        参数
        button - 返回之前设置的ButtonData的按钮。
        结果
        给定按钮上先前设置的ButtonData属性

      • setButtonUniformSize

        public static void setButtonUniformSize​(Node button,
                                        boolean uniformSize)
        默认情况下，所有按钮在ButtonBar中均匀的大小，这意味着所有按钮都占据最宽按钮的宽度。 可以根据每个按钮选择退出，但是使用布尔值为false调用setButtonUniformSize方法。

        如果一个按钮被排除在均匀尺寸之外，那么它们都不能从其首选尺寸被调整大小，并且也被排除在测量过程之外，因此其尺寸不会影响对ButtonBar中所有按钮计算的最大尺寸。

        参数
        button - 包含/排除统一尺寸的按钮。
        uniformSize - 布尔值true以强制按钮上的均匀尺寸，false将排除按钮的均匀尺寸。

      • isButtonUniformSize

        public static boolean isButtonUniformSize​(Node button)
        返回给定节点是否是统一尺寸计算的一部分。 默认情况下，所有未选择退出的节点（通过setButtonUniformSize(Node, boolean) ）将在此返回true。
        参数
        button - 按钮
        结果
        如果按钮是统一尺寸计算的一部分，则为true

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤，或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getButtons

        public final ObservableList<Node> getButtons​()
        在此ObservableList内放置按钮将指示ButtonBar根据其指定的ButtonBar.ButtonData将它们相对于彼此定位 。 要设置ButtonData为一个按钮，只需调用setButtonData(Node, ButtonData) ，传递相关的ButtonData。
        结果
        包含当前按钮栏中所有按钮的列表，并允许添加或删除其他按钮。

      • buttonOrderProperty

        public final StringProperty buttonOrderProperty​()
        标准按钮栏中典型按钮的顺序。 每个ButtonBar.ButtonData一个字母的枚举值。 对于操作系统的默认按钮的订单也可用： BUTTON_ORDER_WINDOWS ， BUTTON_ORDER_MAC_OS ，并BUTTON_ORDER_LINUX 。
        另请参见：
        getButtonOrder() ， setButtonOrder(String)

      • setButtonOrder

        public final void setButtonOrder​(String buttonOrder)
        设置 button order
        参数
        buttonOrder - 当前设置的按钮顺序，默认情况下将是特定于操作系统的按钮顺序。

      • getButtonOrder

        public final String getButtonOrder​()
        返回当前的 button order 。
        结果
        目前 button order 。

      • buttonMinWidthProperty

        public final DoubleProperty buttonMinWidthProperty​()
        指定放置在此按钮栏中的所有按钮的最小宽度。
        另请参见：
        getButtonMinWidth() ， setButtonMinWidth(double)

      • setButtonMinWidth

        public final void setButtonMinWidth​(double value)
        设置放置在此按钮栏中的所有按钮的最小宽度。
        参数
        value - 最小宽度值

      • getButtonMinWidth

        public final double getButtonMinWidth​()
        返回放置在此按钮栏中的所有按钮的最小宽度。
        结果
        最小宽度值

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ButtonBar.ButtonData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum ButtonBar.ButtonData

  • java.lang.Object
    • java.lang.Enum<ButtonBar.ButtonData>
      • javafx.scene.control.ButtonBar.ButtonData
  • All Implemented Interfaces:
    Serializable ， Comparable<ButtonBar.ButtonData>
    Enclosing class:
    ButtonBar

    public static enum ButtonBar.ButtonData
extends Enum<ButtonBar.ButtonData>
    枚举所有可用的按钮数据注释。 通过使用这些注释之一注释ButtonBar中的每个按钮，按钮将相对于ButtonBar中的所有其他按钮进行适当定位。

    有关每个ButtonData的按钮顺序代码的详细信息，请参阅javadoc注释。

    从以下版本开始：
    JavaFX 8u40

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APPLY
      “应用”按钮的标签。
      BACK_PREVIOUS
      “back”或“previous”按钮的标签。
      BIG_GAP
      胶水推动间隙将占用尽可能多的空间，至少有一个“无关”的差距。
      CANCEL_CLOSE
      “取消”或“关闭”按钮的标签。
      FINISH
      “完成”的标签。
      HELP
      通常应该在右侧的“帮助”按钮的标签。
      HELP_2
      “help2”按钮的标签通常应在左侧。
      LEFT
      带有此样式标签的按钮将静态地结束在栏的左侧。
      NEXT_FORWARD
      “下一个”或“前进”按钮的标签。
      NO
      “no”按钮的标签。
      OK_DONE
      “ok”或“done”按钮的标签。
      OTHER
      所有未分类，其他或“未知”按钮。
      RIGHT
      带有此样式标签的按钮将静态地位于条的右端。
      SMALL_GAP
      一个“无关”的差距。
      YES
      “yes”按钮的标签。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getTypeCode​()
      返回 button order字符串中用于表示ButtonData注释的单个字符代码。
      boolean isCancelButton​()
      指示从ButtonData枚举创建的按钮是否应该是用户界面中的“取消”按钮。
      boolean isDefaultButton​()
      指示从ButtonData枚举创建的按钮是否应该是用户界面中的“默认”按钮。
      static ButtonBar.ButtonData valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ButtonBar.ButtonData[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LEFT

        public static final ButtonBar.ButtonData LEFT
        带有此样式标签的按钮将静态地结束在栏的左侧。

        按钮订单代码： L

      • RIGHT

        public static final ButtonBar.ButtonData RIGHT
        带有此样式标签的按钮将静态地位于条的右端。

        按钮订单代码： R

      • HELP

        public static final ButtonBar.ButtonData HELP
        通常应该在右侧的“帮助”按钮的标签。

        按钮订单代码： H

      • HELP_2

        public static final ButtonBar.ButtonData HELP_2
        “help2”按钮的标签通常应在左侧。

        按钮订单代码： E

      • YES

        public static final ButtonBar.ButtonData YES
        “yes”按钮的标签。

        是默认按钮： True

        按钮订单代码： Y

      • NO

        public static final ButtonBar.ButtonData NO
        “no”按钮的标签。

        取消按钮： True

        按钮订单代码： N

      • NEXT_FORWARD

        public static final ButtonBar.ButtonData NEXT_FORWARD
        “下一个”或“前进”按钮的标签。

        是默认按钮： True

        按钮订单代码： X

      • BACK_PREVIOUS

        public static final ButtonBar.ButtonData BACK_PREVIOUS
        “back”或“previous”按钮的标签。

        按钮订单代码： B

      • FINISH

        public static final ButtonBar.ButtonData FINISH
        “完成”的标签。

        是默认按钮： True

        按钮订单代码： I

      • APPLY

        public static final ButtonBar.ButtonData APPLY
        “应用”按钮的标签。

        按钮订单代码： A

      • CANCEL_CLOSE

        public static final ButtonBar.ButtonData CANCEL_CLOSE
        “取消”或“关闭”按钮的标签。

        取消按钮： True

        按钮订单代码： C

      • OK_DONE

        public static final ButtonBar.ButtonData OK_DONE
        “ok”或“done”按钮的标签。

        是默认按钮： True

        按钮订单代码： O

      • OTHER

        public static final ButtonBar.ButtonData OTHER
        所有未分类，其他或“未知”按钮。 标签将是“其他”。

        按钮订单代码： U

      • BIG_GAP

        public static final ButtonBar.ButtonData BIG_GAP
        胶水推动间隙将占用尽可能多的空间，至少有一个“无关”的差距。 （平台依赖）

        按钮订单代码： +

      • SMALL_GAP

        public static final ButtonBar.ButtonData SMALL_GAP
        一个“无关”的差距。 （平台依赖）

        按钮订单代码： _（下划线）

    • 方法详细信息

      • values

        public static ButtonBar.ButtonData[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ButtonBar.ButtonData c : ButtonBar.ButtonData.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ButtonBar.ButtonData valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • getTypeCode

        public String getTypeCode​()
        返回 button order字符串中用于表示ButtonData注释的单个字符代码。
        结果
        用于表示ButtonData注释的单字符代码

      • isCancelButton

        public final boolean isCancelButton​()
        指示从ButtonData枚举创建的按钮是否应该是用户界面中的“取消”按钮。 这通常意味着按钮将响应转义键按，即使该按钮没有焦点。

        ButtonData枚举值可以是取消按钮，在其javadoc中有一条注释。

        结果
        如果这是“取消”按钮，则为true

      • isDefaultButton

        public final boolean isDefaultButton​()
        指示从ButtonData枚举创建的按钮是否应该是用户界面中的“默认”按钮。 这通常意味着按钮将响应进入按键，即使该按钮没有焦点。

        可以是默认按钮的ButtonData枚举值在其javadoc中有一条注释。

        结果
        如果这是“默认”按钮，则为true
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ButtonBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ButtonBase

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.ButtonBase
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    Button ， CheckBox ， Hyperlink ， MenuButton ， ToggleButton

    public abstract class ButtonBase
extends Labeled
    按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。 ButtonBase的主要贡献是提供一致的API来处理按钮“布防”的概念。 在UI中，按钮通常只会在按钮“布防”时发生某些用户手势“触发”。 例如，如果鼠标被按下并且按钮被启用并且鼠标在按钮上方，则按钮可以被布防。 在这种情况下，如果鼠标被释放，则按钮被“触发”，意味着它的动作发生。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty armed
      表示该按钮已被“布防”，使得鼠标释放将导致按钮的动作被调用。
      ObjectProperty<EventHandler<ActionEvent>> onAction
      按钮的动作，当按钮被触发时被调用。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ButtonBase​()
      创建一个带有空文本的默认ButtonBase。
      ButtonBase​(String text)
      创建一个带有给定文本的ButtonBase。
      ButtonBase​(String text, Node graphic)
      创建一个带有给定文本和图形的ButtonBase。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void arm​()
      按下按钮。
      ReadOnlyBooleanProperty armedProperty​()
      表示该按钮已被“布防”，使得鼠标释放将导致按钮的动作被调用。
      void disarm​()
      取消按钮。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      abstract void fire​()
      当用户手势指示应发生此事件时，调用此功能 ButtonBase 。
      EventHandler<ActionEvent> getOnAction​()
      获取属性onAction的值。
      boolean isArmed​()
      获得武器的价值。
      ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
      按钮的动作，当按钮被触发时被调用。
      void setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, createDefaultSkin, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • armed

        public final ReadOnlyBooleanProperty armedProperty
        表示该按钮已被“布防”，使得鼠标释放将导致按钮的动作被调用。 这与压制有所不同。 Pressed表示鼠标已经在节点上按下并且尚未被释放。 arm但是也考虑到鼠标是否实际上在按钮上按下。
        另请参见：
        isArmed()

      • onAction

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty
        按钮的动作，当按钮被触发时被调用。 这可能是由于用户用鼠标点击按钮，或者通过触摸事件或按键，或者如果开发者以编程方式调用fire()方法。
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

    • 构造方法详细信息

      • ButtonBase

        public ButtonBase​()
        创建一个带有空文本的默认ButtonBase。

      • ButtonBase

        public ButtonBase​(String text)
        创建一个带有给定文本的ButtonBase。
        参数
        text - 空文本被视为空字符串

      • ButtonBase

        public ButtonBase​(String text,
                  Node graphic)
        创建一个带有给定文本和图形的ButtonBase。
        参数
        text - 空文本被视为空字符串
        graphic - 一个空图形是可以接受的

    • 方法详细信息

      • armedProperty

        public final ReadOnlyBooleanProperty armedProperty​()
        表示该按钮已被“布防”，使得鼠标释放将导致按钮的动作被调用。 这与压制有所不同。 Pressed表示鼠标已经在节点上按下并且尚未被释放。 然而， arm还考虑了鼠标是否实际上在按钮上按下。
        另请参见：
        isArmed()

      • isArmed

        public final boolean isArmed​()
        获得武器的价值。
        Property description:
        表示该按钮已被“布防”，使得鼠标释放将导致按钮的动作被调用。 这与压制有所不同。 Pressed表示鼠标已经在节点上按下并且尚未被释放。 arm但是也考虑到鼠标是否实际上在按钮上按下。

      • onActionProperty

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
        按钮的动作，当按钮被触发时被调用。 这可能是由于用户用鼠标点击按钮，或者通过触摸事件或按键，或者如果开发者以编程方式调用fire()方法。
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • setOnAction

        public final void setOnAction​(EventHandler<ActionEvent> value)
        设置属性onAction的值。
        Property description:
        按钮的动作，当按钮被触发时被调用。 这可能是由于用户使用鼠标点击按钮，或者通过触摸事件或按键，或者如果开发者以编程方式调用fire()方法。

      • getOnAction

        public final EventHandler<ActionEvent> getOnAction​()
        获取属性onAction的值。
        Property description:
        按钮的动作，当按钮被触发时被调用。 这可能是由于用户用鼠标点击按钮，或者通过触摸事件或按键，或者如果开发者以编程方式调用fire()方法。

      • arm

        public void arm​()
        按下按钮。 一个全副武装的按钮将火的动作（不管是一个的动作Button或切换选择在CheckBox或其他一些行为）上的下一个预期的UI手势。 注意：此功能主要由专家使用，主要由实施新皮肤或行为的人员使用。 开发人员或设计师直接访问此功能并不常见。

      • disarm

        public void disarm​()
        取消按钮。 见arm() 。 注意：此功能主要由专家使用，主要由实施新皮肤或行为的人员使用。 开发人员或设计师直接访问此功能并不常见。

      • fire

        public abstract void fire​()
        当用户手势指示应发生ButtonBase的事件时调用。

        如果调用，无论arm()的状态如何，都将执行此方法。

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 要执行的操作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ButtonType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ButtonType

  • java.lang.Object
    • javafx.scene.control.ButtonType

  • public final class ButtonType
extends Object
    ButtonType类用作JavaFX Dialog API（更具体地说， DialogPane API）的一部分，用于指定在对话框中向用户显示哪些按钮。 有关如何使用此类的更多信息，请参阅DialogPane类javadoc。
    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Alert ， Dialog ， DialogPane

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static ButtonType APPLY
      预先定义的ButtonType显示“应用”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.APPLY 。
      static ButtonType CANCEL
      一个预先定义的ButtonType显示“取消”，并有ButtonBar.ButtonData的ButtonBar.ButtonData.CANCEL_CLOSE 。
      static ButtonType CLOSE
      一个预先定义的ButtonType ，显示“关闭”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.CANCEL_CLOSE 。
      static ButtonType FINISH
      预先定义的ButtonType显示“完成”，并具有ButtonBar.ButtonData ButtonBar.ButtonData.FINISH 。
      static ButtonType NEXT
      预先定义的ButtonType显示“下一步”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.NEXT_FORWARD 。
      static ButtonType NO
      一个预先定义的ButtonType ，显示“否”，并有ButtonBar.ButtonData的ButtonBar.ButtonData.NO 。
      static ButtonType OK
      一个预先定义的ButtonType ，显示“确定”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.OK_DONE 。
      static ButtonType PREVIOUS
      预先定义的ButtonType显示“上一个”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.BACK_PREVIOUS 。
      static ButtonType YES
      一个预先定义的ButtonType ，显示“是”，并有ButtonBar.ButtonData的ButtonBar.ButtonData.YES 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ButtonType​(String text)
      使用给定的文本创建一个ButtonType实例，并将ButtonData设置为 ButtonBar.ButtonData.OTHER 。
      ButtonType​(String text, ButtonBar.ButtonData buttonData)
      创建一个带有给定文本的ButtonType实例，并按指定的方式设置ButtonData。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ButtonBar.ButtonData getButtonData​()
      返回在构造函数中为此ButtonType指定的ButtonData。
      String getText​()
      返回在构造函数中为此ButtonType指定的文本。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • APPLY

        public static final ButtonType APPLY
        一个预先定义的ButtonType ，显示“应用”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.APPLY 。

      • OK

        public static final ButtonType OK
        预先定义的ButtonType显示“确定”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.OK_DONE 。

      • CANCEL

        public static final ButtonType CANCEL
        一个预先定义的ButtonType显示“取消”，并有ButtonBar.ButtonData的ButtonBar.ButtonData.CANCEL_CLOSE 。

      • CLOSE

        public static final ButtonType CLOSE
        一个预先定义的ButtonType显示“关闭”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.CANCEL_CLOSE 。

      • YES

        public static final ButtonType YES
        预先定义的ButtonType显示“是”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.YES 。

      • NO

        public static final ButtonType NO
        一个预先定义的ButtonType显示“否”，并有ButtonBar.ButtonData的ButtonBar.ButtonData.NO 。

      • FINISH

        public static final ButtonType FINISH
        预先定义的ButtonType显示“完成”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.FINISH 。

      • NEXT

        public static final ButtonType NEXT
        预先定义的ButtonType显示“下一步”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.NEXT_FORWARD 。

      • PREVIOUS

        public static final ButtonType PREVIOUS
        一个预先定义的ButtonType显示“上一个”，并有ButtonBar.ButtonData的ButtonBar.ButtonData.BACK_PREVIOUS 。

    • 构造方法详细信息

      • ButtonType

        public ButtonType​(String text)
        创建一个带有给定文本的ButtonType实例，并将ButtonData设置为 ButtonBar.ButtonData.OTHER 。
        参数
        text - 要显示在控件的文本属性中的字符串，如 Button 。

      • ButtonType

        public ButtonType​(String text,
                  ButtonBar.ButtonData buttonData)
        创建一个带有给定文本的ButtonType实例，并按指定的方式设置ButtonData。
        参数
        text - 要显示在控件的文本属性中的字符串，如 Button 。
        buttonData - 应该从此ButtonType创建的按钮类型。

    • 方法详细信息

      • getButtonData

        public final ButtonBar.ButtonData getButtonData​()
        返回在构造函数中为此ButtonType指定的ButtonData。
        结果
        在构造函数中为此ButtonType指定的ButtonData

      • getText

        public final String getText​()
        返回在构造函数中为此ButtonType指定的文本。
        结果
        在构造函数中为此ButtonType指定的文本

      • toString

        public String toString​()
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本上表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Cell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Cell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
  • 参数类型
    T - 单元格中包含的项目的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    DateCell ， IndexedCell

    public class Cell<T>
extends Labeled
    细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。 单元格是Labeled Control ，用于在ListView，TreeView或TableView中呈现单个“行”。 单元格也用于TableView内的每个单独的单元格（即每行/列交点）。 有关详细信息，请分别参阅JavaDoc的每个控件。

    每个单元格与单个数据项（由item属性表示）相关联。 单元格负责渲染该项目，并在适当情况下负责编辑该项目。 小区内的一个项目可以由文本或一些其它控制，例如一个来表示CheckBox ， ChoiceBox或任何其他Node诸如HBox ， GridPane ，或甚至是Rectangle 。

    因为TreeView，ListView，TableView和其他这样的控件可能潜在地用于显示非常大量的数据，所以不可能为控件中的每个项目创建一个实际的单元格。 我们只使用很少的单元格代表非常大的数据集。 每个Cell都被“回收”，或重用。 当我们说这些控件被虚拟化时，这就是我们的意思。

    由于Cell是一个控件，它本质上是一个“模型”。 它的皮肤负责定义外观和布局，而行为负责处理所有输入事件并使用该信息来修改控制状态。 另外，像任何其他控件一样，单元格从CSS样式。 然而，对于Cell的大多数使用，不需要实施Skin。 这是因为一个电池厂可以设置 - 这很详细。

    因为到目前为止，单元格最常用的用例是向用户显示文本，这种用例是针对单元格进行了特别优化的。 这是由细胞从Labeled延伸完成的。 这意味着Cell的子类只需要设置text属性，而不是创建一个单独的Label并在Cell中进行设置。 然而，对于不仅仅需要纯文本的事情，可以在Cell graphic属性中放置任何Node 。 尽管这个术语，图形可以是任何节点，并将完全交互。 例如，ListCell可能配置为Button作为其图形。 然后可以将按钮文本绑定到单元格item属性。 这样，只要单元格中的项目更改，Button文本就会自动更新。

    单元格集focusTraversable为false。

    电池厂

    Cell item的默认表示item各种虚拟化容器的外观。 例如，默认情况下，ListView会将该项目转换为字符串，并使用此值调用Labeled.setText(java.lang.String) 。 如果要专门为ListView使用的单元格（例如），则必须提供在ListView上定义的cellFactory回调函数的实现。 类似的API存在于使用的细胞（例如大多数控件， TreeView ， TableView ， TableColumn和ListView 。

    当它确定需要创建一个新的单元格时，该平台将调用该单元格工厂。 例如，也许您的ListView有1000万项。 创建所有1000万个单元格将是非常昂贵的。 因此，ListView皮肤实现可能只创建足够的单元格来适应视觉空间。 如果将ListView的大小调整为较大，系统将确定需要创建一些其他单元格。 在这种情况下，它将调用cellFactory回调函数（如果提供一个）来创建应该使用的Cell实现。 如果没有提供单元格工厂，将使用内置的默认实现。

    然后，单元工厂的实现不仅仅用于创建单元实例，还负责配置该单元格，使其对其状态的变化作出反应。 例如，如果我要创建一个格式化数字的自定义单元格，以便它们显示为货币类型，我可能会这样做：

      public class MoneyFormatCell extends ListCell<Number> {

     public MoneyFormatCell() {    }

     @Override protected void updateItem(Number item, boolean empty) {
         // calling super here is very important - don't skip this!
         super.updateItem(item, empty);

         // format the number as if it were a monetary value using the
         // formatting relevant to the current locale. This would format
         // 43.68 as "$43.68", and -23.67 as "-$23.67"
         setText(item == null ? "" : NumberFormat.getCurrencyInstance().format(item));

         // change the text fill based on whether it is positive (green)
         // or negative (red). If the cell is selected, the text will
         // always be white (so that it can be read against the blue
         // background), and if the value is zero, we'll make it black.
         if (item != null) {
             double value = item.doubleValue();
             setTextFill(isSelected() ? Color.WHITE :
                 value == 0 ? Color.BLACK :
                 value < 0 ? Color.RED : Color.GREEN);
         }
     }
 }
    这个类可以在ListView中被使用：
      ObservableList<Number> money = ...;
 final ListView<Number> listView = new ListView<Number>(money);
 listView.setCellFactory(new Callback<ListView<Number>, ListCell<Number>>() {
     @Override public ListCell<Number> call(ListView<Number> list) {
         return new MoneyFormatCell();
     }
 });
    在这个例子中，创建一个匿名内部类，只要它被调用时就简单地返回MoneyFormatCell的实例。 MoneyFormatCell类扩展了ListCell ，覆盖了updateItem方法。 当单元格中的项目更改时，就会调用此方法，例如，当用户滚动ListView或底层数据模型的内容时，会更改（并且单元格重用于在ListView中表示某些不同的项目）。 因此，不需要管理绑定 - 只要在发生此方法时对项目的更改做出反应。 在上面的示例中，每当项目更改时，我们更新单元格文本属性，并修改文本填充，以确保我们获得正确的视觉效果。 另外，如果单元格是“空”（意思是用于填写ListView中的空格，但没有与之相关联的任何数据），那么我们只使用空字符串。

    请注意，还有一些额外的方法以'update'为前缀可能是有意义的，因此请务必仔细阅读Cell的Cell文档和Cell的子类。

    当然，我们也可以使用绑定API而不是覆盖'update'方法。 下面显示的是一个非常简单的例子，说明如何实现这一点。

      public class BoundLabelCell extends ListCell<String> {

     public BoundLabelCell() {
         textProperty().bind(itemProperty());
     }
 }

    主要设计目标

    • 对于大型数据集，时间和记忆都是有效的
    • 易于构建和使用自定义单元格的库
    • 容易定制细胞视觉效果
    • 易于自定义显示格式（12.34为$ 12.34或1234％等）
    • 轻松扩展自定义视觉效果
    • 易于拥有“面板”的数据视觉效果
    • 易于动画的细胞大小或其他属性

    关键用例

    以下是用于驱动Cell API设计的一些关键用例，以及显示这些API如何满足这些用例的代码示例。 这绝对不能被视为支持的功能或功能的确定列表，而是提供关于如何使用Cell API的一些指导。 以下示例集中在ListView上，但同样的理念适用于TreeCells或其他类型的单元格。

    更改单元格的颜色

    这在JavaFX中应该非常简单。 每个单元格可以直接从CSS样式。 所以例如，如果您想将ListView中每个单元格的默认背景更改为WHITE，您可以执行以下CSS：

      .list-cell {
   -fx-padding: 3 3 3 3;
   -fx-background-color: white;
 }
    如果要将所选ListView单元格的颜色设置为蓝色，可以将其添加到CSS文件中：
      .list-cell:selected {
   -fx-background-color: blue;
 }
    大多数Cell实现从IndexedCell而不是Cell扩展。 IndexedCell增加了另外两个伪类：“奇”和“偶”。 使用这个可以通过在CSS文件中执行这样的操作来获得替代行条带：
      .list-cell:odd {
   -fx-background-color: grey;
 }
    这些示例中的每一个都不需要更改代码。 只需更新您的CSS文件来改变颜色。 您也可以使用CSS中的“hover”和其他伪类与其他控件相同。

    上面第一个例子的另一种方法（格式化数字列表）将是使用样式类。 假设你有一个ObservableList的Numbers要显示在ListView中，并且想要将所有的负值都设为红色，所有的正值或者0值都是黑色的。 实现这一点的一种方法是使用自定义的cellFactory，它可以根据值为负还是正值来更改单元格的styleClass。 这样添加代码来测试单元格中的数字是否为负数，并添加一个“负”样式类。 如果数字不是负数，则应该删除“否定”字符串。 这种方法允许从CSS定义颜色，允许简单的定制。 CSS文件将包含以下内容：

      .list-cell {
   -fx-text-fill: black;
 }

 .list-cell .negative {
   -fx-text-fill: red;
 }

    编辑

    使用Cell体系结构（例如最虚拟控制ListView ， TreeView ， TableView和TreeTableView ）所有经由细胞直接支持编辑值的概念。 您可以通过上述类文档中的“编辑”部分获取有关控制特定详细信息的更多信息。 本节的其余部分将介绍使用单元格编辑的一些更精细的细节。

    编辑的一般流程如下（注意，在这些步骤中，使用ListView控件作为示例，但对于上述所有控件，存在类似的API，并且整个过程完全相同）：

    1. 用户请求单元格进入编辑模式（通过键盘或鼠标命令），或者开发者请求单元格进入编辑模式（通过调用ListView edit方法） 注意：如果用户双击或触发一个适当的键盘命令启动编辑，那么它们就有效地调用了控件上的适当的编辑方法（即用户发起的和开发人员启动的编辑的输入方法是相同的）。
    2. 通知控件可见区域中的每个单元格，当前的editing cell已更改，并检查其是否为自身。 在这一点上，三件事之一可能发生：
      1. 如果编辑索引与单元格索引相同，则在此单元格上将调用startEdit() 。 一些指针：
        1. 建议当进入编辑状态时，单元格的子类覆盖startEdit()方法来更新单元格的视觉效果。 但是请注意，覆盖startEdit()方法的子类继续调用super.startEdit()非常重要，以便父类可以更新编辑成功所需的附加状态。
        2. 在startEdit()方法之内是改变细胞视觉效果的理想时间。 例如（请注意，在UI控件的javadoc这个例子更充实为ListView ，等等），你可以设置Labeled.graphicProperty()的细胞对TextField并设置Labeled.textProperty()为null。 这将允许最终用户键入输入并对数据模型进行更改。
        3. 当用户完成编辑时，他们将要提交或取消其更改。 这是您的责任（例如通过输入密钥commit the edit和ESC键cancel the edit ）。 您可以通过将适当的事件侦听器附加到在编辑状态下显示的节点。
      2. 如果编辑索引与单元格不一样，并且如果单元格当前在editing state中 ，则在此单元格上将调用cancelEdit() 。 与startEdit()方法一样，您应该覆盖此方法以清理单元格的视觉效果（并且最有可能将Labeled.graphicProperty()返回到null，并将其设置为（可能为新值）为Labeled.textProperty()。同样，请务必始终调用super.cancelEdit()确保所有状态正确更新。
      3. 如果编辑指数是不一样的指数作为小区，如果小区是不是目前在isEditing()编辑状态}，则什么也不会发生在这个小区。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty editable
      表示该单元是否被允许进入编辑状态的属性。
      ReadOnlyBooleanProperty editing
      表示该单元格当前处于编辑状态的属性。
      ReadOnlyBooleanProperty empty
      用于表示单元格是否具有任何内容的属性。
      ObjectProperty<T> item
      与该单元格相关联的数据值。
      ReadOnlyBooleanProperty selected
      指示此单元格是否已被选中。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Cell​()
      创建默认样式类为“单元格”的默认单元格。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      void commitEdit​(T newValue)
      在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如
      BooleanProperty editableProperty​()
      表示该单元是否被允许进入编辑状态的属性。
      ReadOnlyBooleanProperty editingProperty​()
      表示该单元格当前处于编辑状态的属性。
      ReadOnlyBooleanProperty emptyProperty​()
      用于表示单元格是否具有任何内容的属性。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      T getItem​()
      返回与该单元格相关联的数据值。
      boolean isEditable​()
      返回此单元格是否被允许进入编辑状态。
      boolean isEditing​()
      表示单元格当前是否处于编辑状态。
      boolean isEmpty​()
      返回一个布尔值，表示单元格是否被认为是空的。
      protected boolean isItemChanged​(T oldItem, T newItem)
      此方法由Cell子类调用，以便某些CPU密集型操作（具体来说，调用 updateItem(Object, boolean) ）仅在必要时执行（即，仅当当前设置的 item与所提出的新项目不同时才执行设置）。
      boolean isSelected​()
      返回此单元格当前是否被选中。
      ObjectProperty<T> itemProperty​()
      与该单元格相关联的数据值。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      ReadOnlyBooleanProperty selectedProperty​()
      指示此单元格是否已被选中。
      void setEditable​(boolean value)
      允许某些单元格无法编辑。
      void setItem​(T value)
      将项目设置为给定的值 - 不应该直接调用该项目由虚拟化控件管理。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      protected void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
      void updateSelected​(boolean selected)
      更新此单元格是否处于选定状态。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, createDefaultSkin, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • item

        public final ObjectProperty<T> itemProperty
        与该单元格相关联的数据值。 当创建或更新单元格时，此值由虚拟控件设置。 这表示原始数据值。

        这个值只能在Cell的子类中被虚拟化的用户界面控件设置，这些控件知道如何正确使用Cell类。

        结果
        与该单元格相关联的数据值

      • empty

        public final ReadOnlyBooleanProperty emptyProperty
        用于表示单元格是否具有任何内容的属性。 如果为true，则Cell不包含数据，并且不与虚拟控件中的任何数据项相关联。

        当单元格为空时，可以通过“空”CSS伪类状态对其进行样式化。 例如，它可能不会接收任何替代行突出显示，或者当悬停时可能不会收到悬停背景填充。

        另请参见：
        isEmpty()

      • selected

        public final ReadOnlyBooleanProperty selectedProperty
        指示此单元格是否已被选中。 例如，ListView将零个或多个单元格定义为“选定”单元格。
        另请参见：
        isSelected()

      • editing

        public final ReadOnlyBooleanProperty editingProperty
        表示该单元格当前处于编辑状态的属性。
        另请参见：
        isEditing()

      • editable

        public final BooleanProperty editableProperty
        表示该单元是否被允许进入编辑状态的属性。 默认情况下，可以在单元格中将editable设置为true（尽管可以允许Cell的子类进入编辑状态，但可能需要满足其他条件，例如，ListCell要求ListView editable属性也为true。
        另请参见：
        isEditable() ， setEditable(boolean)

    • 构造方法详细信息

      • Cell

        public Cell​()
        创建默认样式类为“单元格”的默认单元格。

    • 方法详细信息

      • itemProperty

        public final ObjectProperty<T> itemProperty​()
        与该单元格相关联的数据值。 当创建或更新单元格时，此值由虚拟控件设置。 这表示原始数据值。

        这个值只能在Cell的子类中被虚拟化的用户界面控件设置，这些控件知道如何正确使用Cell类。

        结果
        与该单元格相关联的数据值

      • setItem

        public final void setItem​(T value)
        将项目设置为给定的值 - 不应该直接调用该项目由虚拟化控件管理。
        参数
        value - 要在此单元格中设置的新数据值

      • getItem

        public final T getItem​()
        返回与该单元格相关联的数据值。
        结果
        与该单元格相关联的数据值

      • emptyProperty

        public final ReadOnlyBooleanProperty emptyProperty​()
        用于表示单元格是否具有任何内容的属性。 如果为true，则Cell不包含数据，并且不与虚拟控件中的任何数据项相关联。

        当单元格为空时，可以通过“空”CSS伪类状态对其进行样式化。 例如，它可能不会接收任何替代行突出显示，或者当悬停时可能不会收到悬停背景填充。

        另请参见：
        isEmpty()

      • isEmpty

        public final boolean isEmpty​()
        返回一个布尔值，表示单元格是否被认为是空的。
        结果
        如果单元格为空，则为true，否则为false

      • selectedProperty

        public final ReadOnlyBooleanProperty selectedProperty​()
        指示此单元格是否已被选中。 例如，ListView将零个或多个单元格定义为“选定”单元格。
        另请参见：
        isSelected()

      • isSelected

        public final boolean isSelected​()
        返回此单元格当前是否被选中。
        结果
        如果选择单元格，则为真，否则为false。

      • isEditing

        public final boolean isEditing​()
        表示单元格当前是否处于编辑状态。
        结果
        如果此单元格当前处于编辑状态，则为true，否则为false

      • editingProperty

        public final ReadOnlyBooleanProperty editingProperty​()
        表示该单元格当前处于编辑状态的属性。
        另请参见：
        isEditing()

      • setEditable

        public final void setEditable​(boolean value)
        允许某些单元格无法编辑。 这在List表示“标题行”的情况下很有用 - 标题行可以编辑没有意义，因此它们应该具有可编辑设置为false。
        参数
        value - 表示单元格是否可编辑的布尔值。 如果为true，则单元格是可编辑的，如果为false，则不能编辑单元格。

      • isEditable

        public final boolean isEditable​()
        返回此单元格是否被允许进入编辑状态。
        结果
        如果允许这个单元格进入编辑状态，则为true，否则为false

      • editableProperty

        public final BooleanProperty editableProperty​()
        表示该单元是否被允许进入编辑状态的属性。 默认情况下，可以在单元格中将editable设置为true（尽管可以允许Cell的子类进入其编辑状态，但可能需要满足其他条件。例如，ListCell要求ListView editable属性也为true。
        另请参见：
        isEditable() ， setEditable(boolean)

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

      • commitEdit

        public void commitEdit​(T newValue)
        在适当的时候调用此功能（基于您的单元格编辑用户界面的用户交互要求）来做两件事情：
        1. 将适当的事件触发回到支持UI控件（例如ListView ）。 这将开始将此编辑推回相关数据源/属性（尽管不能保证这将成功 - 这取决于正在使用的特定编辑提交处理程序）。 有关更多详细信息，请参阅UI控件类javadoc。
        2. 开始从编辑状态转换到非编辑状态。

        一般来说，在自定义单元实现中无需重写此方法 - 在适当的时候简单地调用此方法就足够了（例如，当用户按下Enter键时，可以执行像cell.commitEdit(converter.fromString(textField.getText()));

        参数
        newValue - 作为最终用户输入的值，应该以相关的方式保持给定基于用户界面的数据源和UI控件的安装编辑提交处理程序。

      • layoutChildren

        protected void layoutChildren​()
        在布局传递期间调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Control

      • updateItem

        protected void updateItem​(T item,
                          boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了弄清楚，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，比如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是让开发人员在指定自定义单元格工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。

      • updateSelected

        public void updateSelected​(boolean selected)
        更新此单元格是否处于选定状态。
        参数
        selected - 是否选择此单元格。

      • isItemChanged

        protected boolean isItemChanged​(T oldItem,
                                T newItem)
        此方法由Cell子类调用，以便某些CPU密集型操作（具体来说，调用updateItem(Object, boolean) ）仅在必要时执行（即，仅当当前设置的item与所提出的新项目不同时才执行设置）。

        此方法的默认实现将针对相等性进行测试，但开发人员可以覆盖此方法，以其他特定于其域的方式执行检查。

        参数
        oldItem - 单元格中包含的当前设置的项目（即它与通过 getItem()可用的项目相同）。
        newItem - 如果此方法返回true，将在单元格中设置的项目。 如果此方法返回false，则可能无法设置。
        结果
        如果新项目被认为与旧项目不同，则返回true。 默认情况下，此方法针对相等性进行测试，但子类可能会更改实现以适应其需求进行测试。
        从以下版本开始：
        JavaFX 8u40

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CheckBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class CheckBox

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.ButtonBase
                • javafx.scene.control.CheckBox
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class CheckBox
extends ButtonBase
    三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。 CheckBox控件可以处于三种状态之一：
    • checked ：indeterminate == false，checked == true
    • 未选中 ：indeterminate == false，checked == false
    • undefined ：indeterminate == true
    如果勾选了CheckBox，那么也按定义定义。 勾选CheckBox时，通常会使用“check”或“tick”标记。 如果选择为true并且indeterminate为false，则CheckBox处于此状态。

    如果选择为false并且indeterminate为false，则取消选中复选框。

    如果indeterminate为true，则复选框未定义，无论选择的状态如何。 典型的渲染将是带有减号或破折号，以指示复选框的未定义或不确定状态。 这对于构建基于三态复选框的树很方便，例如，未定义的复选框通常意味着“继承父设置”。

    allowIndeterminate变量（如果为true）允许用户循环访问未定义的状态。 如果为false，则复选框不处于不确定状态，并且允许用户仅更改已检查状态。

    例：

      CheckBox cb = new CheckBox("a checkbox"); cb.setIndeterminate(false);

    默认情况下启用助记符分配功能。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty allowIndeterminate
      确定用户是否切换复选框应该循环遍历所有三个状态：已 选中 ， 未选中和 未定义 。
      BooleanProperty indeterminate
      确定复选框是否处于不确定状态。
      BooleanProperty selected
      指示是否选中此复选框。

      • Properties inherited from class javafx.scene.control.ButtonBase

        armed, onAction

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckBox​()
      为其标签创建一个带有空字符串的复选框。
      CheckBox​(String text)
      创建一个带有指定文本的复选框作为其标签。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanProperty allowIndeterminateProperty​()
      确定用户是否切换复选框应该循环遍历所有三个状态：已 选中 ， 未选中和 未定义 。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void fire​()
      切换 CheckBox的状态。
      BooleanProperty indeterminateProperty​()
      确定复选框是否处于不确定状态。
      boolean isAllowIndeterminate​()
      获取属性allowIndeterminate的值。
      boolean isIndeterminate​()
      获取属性的值不确定。
      boolean isSelected​()
      获取所选属性的值。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      BooleanProperty selectedProperty​()
      指示是否选中此复选框。
      void setAllowIndeterminate​(boolean value)
      设置属性allowIndeterminate的值。
      void setIndeterminate​(boolean value)
      设置属性的值不确定。
      void setSelected​(boolean value)
      设置所选属性的值。

      • Methods inherited from class javafx.scene.control.ButtonBase

        arm, armedProperty, disarm, executeAccessibleAction, getOnAction, isArmed, onActionProperty, setOnAction

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • indeterminate

        public final BooleanProperty indeterminateProperty
        确定复选框是否处于不确定状态。
        另请参见：
        isIndeterminate() ， setIndeterminate(boolean)

      • selected

        public final BooleanProperty selectedProperty
        指示是否选中此复选框。
        另请参见：
        isSelected() ， setSelected(boolean)

      • allowIndeterminate

        public final BooleanProperty allowIndeterminateProperty
        确定用户是否切换复选框应该循环遍历所有三个状态：已选中 ， 未选中和未定义 。 如果是true那么所有三个州都将循环通过; 如果false然后只检查并取消选中将循环。
        另请参见：
        isAllowIndeterminate() ， setAllowIndeterminate(boolean)

    • 构造方法详细信息

      • CheckBox

        public CheckBox​()
        为其标签创建一个带有空字符串的复选框。

      • CheckBox

        public CheckBox​(String text)
        创建一个带有指定文本的复选框作为其标签。
        参数
        text - 其标签的文本字符串。

    • 方法详细信息

      • setIndeterminate

        public final void setIndeterminate​(boolean value)
        设置属性的值不确定。
        Property description:
        确定复选框是否处于不确定状态。

      • isIndeterminate

        public final boolean isIndeterminate​()
        获取属性的值不确定。
        Property description:
        确定复选框是否处于不确定状态。

      • indeterminateProperty

        public final BooleanProperty indeterminateProperty​()
        确定复选框是否处于不确定状态。
        另请参见：
        isIndeterminate() ， setIndeterminate(boolean)

      • setSelected

        public final void setSelected​(boolean value)
        设置所选属性的值。
        Property description:
        指示是否选中此复选框。

      • isSelected

        public final boolean isSelected​()
        获取所选属性的值。
        Property description:
        指示是否选中此复选框。

      • selectedProperty

        public final BooleanProperty selectedProperty​()
        指示是否选中此复选框。
        另请参见：
        isSelected() ， setSelected(boolean)

      • setAllowIndeterminate

        public final void setAllowIndeterminate​(boolean value)
        设置属性allowIndeterminate的值。
        Property description:
        确定用户是否切换复选框应该循环遍历所有三个状态：已选中 ， 未选中和未定义 。 如果是true那么所有三个州将循环通过; 如果是false那么只有选中和取消选中才会循环。

      • isAllowIndeterminate

        public final boolean isAllowIndeterminate​()
        获取属性allowIndeterminate的值。
        Property description:
        确定用户是否切换复选框应该循环遍历所有三个状态：已选中 ， 未选中和未定义 。 如果是true那么所有三个州都将循环通过; 如果是false那么只有选中并取消选中才会循环。

      • allowIndeterminateProperty

        public final BooleanProperty allowIndeterminateProperty​()
        确定用户是否切换复选框应该循环遍历所有三个状态：已选中 ， 未选中和未定义 。 如果是true那么所有三个州都将循环通过; 如果false那么只有检查并取消选中才能循环。
        另请参见：
        isAllowIndeterminate() ， setAllowIndeterminate(boolean)

      • fire

        public void fire​()
        切换CheckBox的状态。 如果allowIndeterminate为true，则此函数的每次调用将通过已选中，未选中和未定义的状态来提前复选框。 如果allowIndeterminate为false，那么CheckBox只会循环执行已检查和未检查的状态，并强制不确定等于false。
        Specified by:
        fire在 ButtonBase

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CheckBoxTreeItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class CheckBoxTreeItem<T>

  • java.lang.Object
    • javafx.scene.control.TreeItem<T>
      • javafx.scene.control.CheckBoxTreeItem<T>
  • 参数类型
    T - TreeItem中包含的值的类型
    All Implemented Interfaces:
    EventTarget

    public class CheckBoxTreeItem<T>
extends TreeItem<T>
    TreeItem子类增加了在选定的，未选择的和不确定的状态中的支持。 当与安装了CheckBoxTreeCell的TreeView结合使用时，这是非常有用的。

    CheckBoxTreeItem可以是independent或依赖。 默认情况下，CheckBoxTreeItem实例是依赖的，这意味着对TreeItem的选择状态的任何更改都将对父项和子项CheckBoxTreeItem实例产生影响。 如果CheckBoxTreeItem设置为独立，这意味着对该CheckBoxTreeItem的任何更改都不会直接影响父项和子项CheckBoxTreeItem实例的状态。

    indeterminate属性用于表示与CheckBox.indeterminateProperty()相同的概念，即复选框既不被选择也未选择。 这在TreeView中通常使用，当某些（但不是全部）分支的孩子被选中时。

    使用CheckBoxTreeItem类与CheckBoxTreeCell一起使用的简单示例如下所示：

       // create the tree model CheckBoxTreeItem<String> jonathanGiles = new CheckBoxTreeItem<String>("Jonathan"); CheckBoxTreeItem<String> juliaGiles = new CheckBoxTreeItem<String>("Julia"); CheckBoxTreeItem<String> mattGiles = new CheckBoxTreeItem<String>("Matt"); CheckBoxTreeItem<String> sueGiles = new CheckBoxTreeItem<String>("Sue"); CheckBoxTreeItem<String> ianGiles = new CheckBoxTreeItem<String>("Ian"); CheckBoxTreeItem<String> gilesFamily = new CheckBoxTreeItem<String>("Giles Family"); gilesFamily.setExpanded(true); gilesFamily.getChildren().addAll(jonathanGiles, juliaGiles, mattGiles, sueGiles, ianGiles); // create the treeView final TreeView<String> treeView = new TreeView<String>(); treeView.setRoot(gilesFamily); // set the cell factory treeView.setCellFactory(CheckBoxTreeCell.<String>forTreeView());
    从以下版本开始：
    JavaFX 2.2
    另请参见：
    CheckBoxTreeCell ， TreeItem ， CheckBox

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty independent
      A BooleanProperty用于表示此CheckBoxTreeItem的独立状态。
      BooleanProperty indeterminate
      A BooleanProperty用于表示此CheckBoxTreeItem的不确定状态。
      BooleanProperty selected
      A BooleanProperty用于表示此CheckBoxTreeItem的选定状态。

      • Properties inherited from class javafx.scene.control.TreeItem

        expanded, graphic, leaf, parent, value

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  CheckBoxTreeItem.TreeModificationEvent<T>
      一个类似于TreeItem.TreeModificationEvent类的TreeModificationEvent类，因为这个事件会引发 CheckBoxTreeItem层次结构，直到父节点为空。

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckBoxTreeItem​()
      创建一个空的CheckBoxTreeItem。
      CheckBoxTreeItem​(T value)
      创建一个CheckBoxTreeItem，其value属性设置为提供的对象。
      CheckBoxTreeItem​(T value, Node graphic)
      创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的节点。
      CheckBoxTreeItem​(T value, Node graphic, boolean selected)
      创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的Node，并将 selectedProperty()的初始状态设置为提供的布尔值。
      CheckBoxTreeItem​(T value, Node graphic, boolean selected, boolean independent)
      创建具有设置为所提供的对象，该图形集所提供的节点，所述的初始状态下的值属性CheckBoxTreeItem selectedProperty()组所提供的布尔值，和的初始状态 independent属性所提供的布尔值。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static <T> EventType<CheckBoxTreeItem.TreeModificationEvent<T>> checkBoxSelectionChangedEvent​()
      当CheckBoxTreeItem选择/不确定状态改变时使用的EventType。
      BooleanProperty independentProperty​()
      A BooleanProperty用于表示此CheckBoxTreeItem的独立状态。
      BooleanProperty indeterminateProperty​()
      A BooleanProperty用于表示此CheckBoxTreeItem的不确定状态。
      boolean isIndependent​()
      获取属性的值独立。
      boolean isIndeterminate​()
      返回此CheckBoxTreeItem的不确定状态。
      boolean isSelected​()
      返回此CheckBoxTreeItem的选定状态。
      BooleanProperty selectedProperty​()
      A BooleanProperty用于表示此CheckBoxTreeItem的选定状态。
      void setIndependent​(boolean value)
      设置属性的值独立。
      void setIndeterminate​(boolean value)
      设置此CheckBoxTreeItem的不确定状态。
      void setSelected​(boolean value)
      设置此CheckBoxTreeItem的选定状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.control.TreeItem

        addEventHandler, branchCollapsedEvent, branchExpandedEvent, buildEventDispatchChain, childrenModificationEvent, expandedItemCountChangeEvent, expandedProperty, getChildren, getGraphic, getParent, getValue, graphicChangedEvent, graphicProperty, isExpanded, isLeaf, leafProperty, nextSibling, nextSibling, parentProperty, previousSibling, previousSibling, removeEventHandler, setExpanded, setGraphic, setValue, toString, treeNotificationEvent, valueChangedEvent, valueProperty

    • Property Detail

      • selected

        public final BooleanProperty selectedProperty
        A BooleanProperty用于表示此CheckBoxTreeItem的选定状态。
        结果
        该CheckBoxTreeItem的选定状态属性

      • indeterminate

        public final BooleanProperty indeterminateProperty
        A BooleanProperty用于表示此CheckBoxTreeItem的不确定状态。
        另请参见：
        isIndeterminate() ， setIndeterminate(boolean)

      • independent

        public final BooleanProperty independentProperty
        A BooleanProperty用于表示此CheckBoxTreeItem的独立状态。 独立状态用于表示对单个CheckBoxTreeItem的更改是否应影响其父级和子级的状态。

        默认情况下，独立属性为false，这意味着当CheckBoxTreeItem对所选或不确定的属性进行状态更改时，相关的CheckBoxTreeItems的状态可能会被更改。 如果独立属性设置为true，则相关的CheckBoxTreeItems的状态将永远不会改变。

        另请参见：
        isIndependent() ， setIndependent(boolean)

    • 构造方法详细信息

      • CheckBoxTreeItem

        public CheckBoxTreeItem​()
        创建一个空的CheckBoxTreeItem。

      • CheckBoxTreeItem

        public CheckBoxTreeItem​(T value)
        创建一个CheckBoxTreeItem，其value属性设置为提供的对象。
        参数
        value - 要存储的对象作为此TreeItem的值。

      • CheckBoxTreeItem

        public CheckBoxTreeItem​(T value,
                        Node graphic)
        创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的节点。
        参数
        value - 要存储的对象作为此CheckBoxTreeItem的值。
        graphic - 节点显示在此CheckBoxTreeItem旁边的TreeView中。

      • CheckBoxTreeItem

        public CheckBoxTreeItem​(T value,
                        Node graphic,
                        boolean selected)
        创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的Node，并将 selectedProperty()的初始状态设置为提供的布尔值。
        参数
        value - 要存储的对象作为此CheckBoxTreeItem的值。
        graphic - 节点显示在此CheckBoxTreeItem旁边的TreeView中。
        selected - selected属性的初始值。

      • CheckBoxTreeItem

        public CheckBoxTreeItem​(T value,
                        Node graphic,
                        boolean selected,
                        boolean independent)
        创建一个CheckBoxTreeItem，其中value属性设置为提供的对象，图形设置为提供的Node， selectedProperty()的初始状态设置为提供的布尔值，以及 independent属性的初始状态为提供的布尔值。
        参数
        value - 要存储的对象作为此CheckBoxTreeItem的值。
        graphic - 节点显示在此CheckBoxTreeItem旁边的TreeView中。
        selected - selected属性的初始值。
        independent - independent属性的初始值

    • 方法详细信息

      • checkBoxSelectionChangedEvent

        public static <T> EventType<CheckBoxTreeItem.TreeModificationEvent<T>> checkBoxSelectionChangedEvent​()
        当CheckBoxTreeItem选择/不确定状态改变时使用的EventType。 要使用它，建议您使用以下代码：
           child1.addEventHandler(CheckBoxTreeItem.<String>checkBoxSelectionChangedEvent(), new EventHandler<TreeModificationEvent<String>>() { public void handle(TreeModificationEvent<String> event) { ... } });
        参数类型
        T - TreeItem中包含的值的类型。
        结果
        当CheckBoxTreeItem选择/不确定状态改变时使用的EventType

      • setSelected

        public final void setSelected​(boolean value)
        设置此CheckBoxTreeItem的选定状态。
        参数
        value - 此CheckBoxTreeItem的选定状态

      • isSelected

        public final boolean isSelected​()
        返回此CheckBoxTreeItem的选定状态。
        结果
        如果选中CheckBoxTreeItem，则为true

      • selectedProperty

        public final BooleanProperty selectedProperty​()
        A BooleanProperty用于表示此CheckBoxTreeItem的选定状态。
        结果
        该CheckBoxTreeItem的选定状态属性

      • setIndeterminate

        public final void setIndeterminate​(boolean value)
        设置此CheckBoxTreeItem的不确定状态。
        参数
        value - 此CheckBoxTreeItem的不确定状态

      • isIndeterminate

        public final boolean isIndeterminate​()
        返回此CheckBoxTreeItem的不确定状态。
        结果
        如果CheckBoxTreeItem是不确定状态，则为true

      • indeterminateProperty

        public final BooleanProperty indeterminateProperty​()
        A BooleanProperty用于表示此CheckBoxTreeItem的不确定状态。
        另请参见：
        isIndeterminate() ， setIndeterminate(boolean)

      • independentProperty

        public final BooleanProperty independentProperty​()
        A BooleanProperty用于表示此CheckBoxTreeItem的独立状态。 独立状态用于表示对单个CheckBoxTreeItem的更改是否应影响其父级和子级的状态。

        默认情况下，独立属性为false，这意味着当CheckBoxTreeItem对所选或不确定的属性进行状态更改时，相关的CheckBoxTreeItems的状态可能会被更改。 如果独立属性设置为true，则相关的CheckBoxTreeItems的状态将永远不会改变。

        另请参见：
        isIndependent() ， setIndependent(boolean)

      • setIndependent

        public final void setIndependent​(boolean value)
        设置属性的值独立。
        Property description:
        A BooleanProperty用于表示此CheckBoxTreeItem的独立状态。 独立状态用于表示对单个CheckBoxTreeItem的更改是否应影响其父级和子级的状态。

        默认情况下，独立属性为false，这意味着当CheckBoxTreeItem对所选或不确定的属性进行状态更改时，相关的CheckBoxTreeItems的状态可能会被更改。 如果独立属性设置为true，则相关的CheckBoxTreeItems的状态将永远不会改变。

      • isIndependent

        public final boolean isIndependent​()
        获取属性的值独立。
        Property description:
        A BooleanProperty用于表示此CheckBoxTreeItem的独立状态。 独立状态用于表示对单个CheckBoxTreeItem的更改是否应影响其父级和子级的状态。

        默认情况下，独立属性为false，这意味着当CheckBoxTreeItem对所选或不确定的属性进行状态更改时，相关的CheckBoxTreeItems的状态可能会被更改。 如果独立属性设置为true，则相关的CheckBoxTreeItems的状态将永远不会改变。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CheckBoxTreeItem.TreeModificationEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class CheckBoxTreeItem.TreeModificationEvent<T>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.CheckBoxTreeItem.TreeModificationEvent<T>
  • 参数类型
    T - value属性中包含的值的类型。
    All Implemented Interfaces:
    Serializable ， Cloneable
    Enclosing class:
    CheckBoxTreeItem < T >

    public static class CheckBoxTreeItem.TreeModificationEvent<T>
extends Event
    一个TreeModificationEvent类，类似于TreeItem.TreeModificationEvent类的工作，因为该事件会引发 CheckBoxTreeItem层次结构，直到父节点为空。
    从以下版本开始：
    JavaFX 2.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<Event> ANY
      所有树修改事件类型的常用超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeModificationEvent​(EventType<? extends Event> eventType, CheckBoxTreeItem<T> treeItem, boolean selectionChanged)
      创建一个默认的TreeModificationEvent实例来表示给定的CheckBoxTreeItem实例的选择/不确定状态的变化。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CheckBoxTreeItem<T> getTreeItem​()
      返回此事件发生的CheckBoxTreeItem。
      boolean wasIndeterminateChanged​()
      表示此事件的原因是CheckBoxTreeItem中的不确定状态发生了变化（而不是被选择或未选择）。
      boolean wasSelectionChanged​()
      表示此事件的原因是CheckBoxTreeItem上的选择已更改（与其变为不确定）相反。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<Event> ANY
        所有树修改事件类型的常用超类型。

    • 构造方法详细信息

      • TreeModificationEvent

        public TreeModificationEvent​(EventType<? extends Event> eventType,
                             CheckBoxTreeItem<T> treeItem,
                             boolean selectionChanged)
        创建一个默认的TreeModificationEvent实例来表示给定的CheckBoxTreeItem实例的选择/不确定状态的变化。
        参数
        eventType - eventType
        treeItem - 树项目
        selectionChanged - 表示选择是否改变

    • 方法详细信息

      • getTreeItem

        public CheckBoxTreeItem<T> getTreeItem​()
        返回此事件发生的CheckBoxTreeItem。
        结果
        该事件发生的CheckBoxTreeItem。

      • wasSelectionChanged

        public boolean wasSelectionChanged​()
        表示此事件的原因是CheckBoxTreeItem上的选择已更改（与其变为不确定）相反。
        结果
        CheckBoxTreeItem的选择已更改

      • wasIndeterminateChanged

        public boolean wasIndeterminateChanged​()
        表示此事件的原因是CheckBoxTreeItem中的不确定状态发生了变化（而不是被选择或未选择）。
        结果
        CheckBoxTreeItem的不确定性已更改
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


CheckMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class CheckMenuItem

  • java.lang.Object
    • javafx.scene.control.MenuItem
      • javafx.scene.control.CheckMenuItem
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class CheckMenuItem
extends MenuItem

    A MenuItem可以在选定状态和未选择状态之间切换。 它的目的是将CheckMenuItem与Menu或ContextMenu控件结合使用。

    在菜单中创建和插入一个CheckMenuItem如下所示。

       final subsystem1 = new CheckMenuItem("Enabled"); subsystem1.setOnAction(new EventHandler<ActionEvent>() { public void handle(ActionEvent e) { System.out.println("subsystem1 #1 Enabled!"); } }); Menu subsystemsMenu = new Menu("Subsystems"); subsystemsMenu.add(subsystem1);

    当然，上面的方法从菜单中分离出CheckMenuItem的定义，但这不一定是这样的。

    要确定CheckMenuItem的当前状态，您应该参考selected布尔值。 示例用例可能是以下示例：

       final checkMenuItem = new CheckMenuItem("Show Widget"); subsystem1.setOnAction(new EventHandler<ActionEvent>() { public void handle(ActionEvent e) { System.out.println("Show the widget!"); } }); private final BooleanProperty widgetShowing(); public final boolean isWidgetShowing() { return widgetShowing.get(); ) public final void setWidgetShowing(boolean value) { widgetShowingProperty().set(value); } public final BooleanProperty widgetShowingProperty() { if (widgetShowing == null) { widgetShowing = new SimpleBooleanProperty(this, "widgetShowing", true); } return widgetShowing; } widgetShowing.bind(checkMenuItem.selected);

    通常，一个CheckMenuItem将被渲染，使得当被选中时，它在通常为MenuItem图形保留的区域中显示一个检查（或刻度）标记。 当然，这会因皮肤和造型而异。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Menu ， MenuItem ， RadioMenuItem

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty selected
      表示此CheckMenuItem的当前状态。

      • Properties inherited from class javafx.scene.control.MenuItem

        accelerator, disable, graphic, id, mnemonicParsing, onAction, onMenuValidation, parentMenu, parentPopup, style, text, visible

    • Field Summary

      • Fields inherited from class javafx.scene.control.MenuItem

        MENU_VALIDATION_EVENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckMenuItem​()
      *构造函数* *
      CheckMenuItem​(String text)
      构造一个CheckMenuItem并设置具有指定文本的显示文本。
      CheckMenuItem​(String text, Node graphic)
      构造一个CheckMenuItem并设置指定文本的显示文本，并将图形Node设置为给定节点。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean isSelected​()
      获取所选属性的值。
      BooleanProperty selectedProperty​()
      表示此CheckMenuItem的当前状态。
      void setSelected​(boolean value)
      设置所选属性的值。

      • Methods inherited from class javafx.scene.control.MenuItem

        acceleratorProperty, addEventHandler, buildEventDispatchChain, disableProperty, fire, getAccelerator, getCssMetaData, getGraphic, getId, getOnAction, getOnMenuValidation, getParentMenu, getParentPopup, getProperties, getPseudoClassStates, getStyle, getStyleableNode, getStyleableParent, getStyleClass, getText, getTypeSelector, getUserData, graphicProperty, idProperty, isDisable, isMnemonicParsing, isVisible, mnemonicParsingProperty, onActionProperty, onMenuValidationProperty, parentMenuProperty, parentPopupProperty, removeEventHandler, setAccelerator, setDisable, setGraphic, setId, setMnemonicParsing, setOnAction, setOnMenuValidation, setParentMenu, setParentPopup, setStyle, setText, setUserData, setVisible, styleProperty, textProperty, toString, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • selected

        public final BooleanProperty selectedProperty
        表示此CheckMenuItem的当前状态。 绑定到这一点，只要用户与CheckMenuItem进行交互（并导致所选状态被切换）。
        Default value:
        假
        另请参见：
        isSelected() ， setSelected(boolean)

    • 构造方法详细信息

      • CheckMenuItem

        public CheckMenuItem​()
        *构造函数* *

      • CheckMenuItem

        public CheckMenuItem​(String text)
        构造一个CheckMenuItem并设置具有指定文本的显示文本。
        参数
        text - 显示文字

      • CheckMenuItem

        public CheckMenuItem​(String text,
                     Node graphic)
        构造一个CheckMenuItem并设置具有指定文本的显示文本，并将图形Node设置为给定节点。
        参数
        text - 显示文字
        graphic - 图形节点

    • 方法详细信息

      • setSelected

        public final void setSelected​(boolean value)
        设置所选属性的值。
        Property description:
        表示此CheckMenuItem的当前状态。 绑定到这一点，只要用户与CheckMenuItem进行交互（并导致所选状态被切换）。
        Default value:
        假

      • isSelected

        public final boolean isSelected​()
        获取所选属性的值。
        Property description:
        表示此CheckMenuItem的当前状态。 绑定到这一点，只要用户与CheckMenuItem进行交互（并导致所选状态被切换）。
        Default value:
        假

      • selectedProperty

        public final BooleanProperty selectedProperty​()
        表示此CheckMenuItem的当前状态。 绑定到这一点，只要用户与CheckMenuItem进行交互（并导致所选状态被切换）。
        Default value:
        假
        另请参见：
        isSelected() ， setSelected(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChoiceBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ChoiceBox<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ChoiceBox<T>
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("items")
public class ChoiceBox<T>
extends Control
    ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。 ChoiceBox在“显示”时将向用户显示这些选择，并允许他们选择一个选择。 当不显示时，显示当前选择。

    默认情况下，ChoiceBox没有选择任何项目，除非另有说明。 虽然ChoiceBox只允许用户从预定义的列表中进行选择，但开发人员可以将所选项目指定为除了预定义列表中可用的内容之外的其他项目。 这对于几个重要的用例是必需的。

    这意味着ChoiceBox的配置是独立的。 您可以指定项目，然后指定所选项目，或者您可以指定所选项目，然后指定项目。 无论哪种方式都能正常工作。

    ChoiceBox项目选择由SelectionModel处理与ListView和ComboBox一样，可以修改所使用的SelectionModel ，尽管这很可能很少更改。 ChoiceBox只支持一个选择模型，因此默认使用的是SingleSelectionModel 。

      import javafx.scene.control.ChoiceBox;

 ChoiceBox cb = new ChoiceBox();
 cb.getItems().addAll("item1", "item2", "item3");
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      允许一种方式来指定如何表示项目列表中的对象。
      ObjectProperty<ObservableList<T>> items
      要在选框中显示的项目。
      ObjectProperty<EventHandler<ActionEvent>> onAction
      ChoiceBox操作，每当更改ChoiceBox value属性时调用。
      ObjectProperty<EventHandler<Event>> onHidden
      在ChoiceBox弹出窗口之后刚刚被隐藏。
      ObjectProperty<EventHandler<Event>> onHiding
      在ChoiceBox弹出窗口被隐藏之前调用。
      ObjectProperty<EventHandler<Event>> onShowing
      在 ChoiceBox弹出窗口之前调用。
      ObjectProperty<EventHandler<Event>> onShown
      在ChoiceBox弹出窗口之后调用。
      ObjectProperty<SingleSelectionModel<T>> selectionModel
      ChoiceBox的选择模型。
      ReadOnlyBooleanProperty showing
      指示下拉列表是否向用户显示选择列表。
      ObjectProperty<T> value
      此ChoiceBox的值被定义为ChoiceBox选择模型中选定的项目。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<Event> ON_HIDDEN
      当ChoiceBox弹出窗口被隐藏时调用。
      static EventType<Event> ON_HIDING
      调用的时候ChoiceBox弹出窗口 将被隐藏。
      static EventType<Event> ON_SHOWING
      在选择框之前调用，在用户单击或以其他方式与ChoiceBox进行交互之后显示弹出窗口。
      static EventType<Event> ON_SHOWN
      在ChoiceBox显示弹出窗口后调用。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ChoiceBox​()
      创建一个新的ChoiceBox，它有一个空的项目列表。
      ChoiceBox​(ObservableList<T> items)
      使用给定的项目创建一个新的ChoiceBox。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<T>> converterProperty​()
      允许一种方式来指定如何表示项目列表中的对象。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      StringConverter<T> getConverter​()
      获取属性转换器的值。
      ObservableList<T> getItems​()
      获取属性项的值。
      EventHandler<ActionEvent> getOnAction​()
      获取属性onAction的值。
      EventHandler<Event> getOnHidden​()
      获取属性onHidden的值。
      EventHandler<Event> getOnHiding​()
      获取属性onHiding的值。
      EventHandler<Event> getOnShowing​()
      获取属性onShowing的值。
      EventHandler<Event> getOnShown​()
      获取onShown属性的值。
      SingleSelectionModel<T> getSelectionModel​()
      获取属性selectionModel的值。
      T getValue​()
      获取属性值的值。
      void hide​()
      关闭选择列表。
      boolean isShowing​()
      获取显示的属性的值。
      ObjectProperty<ObservableList<T>> itemsProperty​()
      要在选框中显示的项目。
      ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
      ChoiceBox操作，每当更改ChoiceBox value属性时调用。
      ObjectProperty<EventHandler<Event>> onHiddenProperty​()
      在ChoiceBox弹出窗口之后刚刚被隐藏。
      ObjectProperty<EventHandler<Event>> onHidingProperty​()
      在ChoiceBox弹出窗口被隐藏之前。
      ObjectProperty<EventHandler<Event>> onShowingProperty​()
      在 ChoiceBox弹出窗口之前调用。
      ObjectProperty<EventHandler<Event>> onShownProperty​()
      在ChoiceBox弹出窗口之后调用。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      ObjectProperty<SingleSelectionModel<T>> selectionModelProperty​()
      ChoiceBox的选择模型。
      void setConverter​(StringConverter<T> value)
      设置属性转换器的值。
      void setItems​(ObservableList<T> value)
      设置属性项的值。
      void setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void setOnHidden​(EventHandler<Event> value)
      设置属性onHidden的值。
      void setOnHiding​(EventHandler<Event> value)
      设置属性onHiding的值。
      void setOnShowing​(EventHandler<Event> value)
      设置属性onShowing的值。
      void setOnShown​(EventHandler<Event> value)
      设置属性onShown的值。
      void setSelectionModel​(SingleSelectionModel<T> value)
      设置属性selectionModel的值。
      void setValue​(T value)
      设置属性值的值。
      void show​()
      打开选择列表。
      ReadOnlyBooleanProperty showingProperty​()
      指示下拉列表是否向用户显示选择列表。
      ObjectProperty<T> valueProperty​()
      此ChoiceBox的值被定义为ChoiceBox选择模型中选定的项目。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • selectionModel

        public final ObjectProperty<SingleSelectionModel<T>> selectionModelProperty
        ChoiceBox的选择模型。 只有一个选择可以做，因此，ChoiceBox只支持一个SingleSelectionModel。 通常，与选择模型的主要交互是明确地设置项目列表中哪个项目应该被选择，或者倾听选择中的变化以知道选择哪个项目。
        另请参见：
        getSelectionModel() ， setSelectionModel(SingleSelectionModel)

      • showing

        public final ReadOnlyBooleanProperty showingProperty
        指示下拉列表是否向用户显示选择列表。 这是一个只读属性，它应该通过#show和#hide方法进行操作。
        另请参见：
        isShowing()

      • items

        public final ObjectProperty<ObservableList<T>> itemsProperty
        要在选框中显示的项目。 所选项目（如选择模型中所示）必须始终为这些项目之一。
        另请参见：
        getItems() ， setItems(ObservableList)

      • converter

        public ObjectProperty<StringConverter<T>> converterProperty
        允许一种方式来指定如何表示项目列表中的对象。 当设置StringConverter时，不调用对象toString方法，而是调用其toString（对象T），将对象传递到items列表中。 当在ChoiceBox中使用域对象时，这是有用的，因为此属性允许自定义表示。 此外，可以设置javafx.util.converter软件包中提供的任何预先构建的转换器。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getConverter() ， setConverter(StringConverter)

      • value

        public ObjectProperty<T> valueProperty
        此ChoiceBox的值被定义为ChoiceBox选择模型中选定的项目。 valueProperty与selectedItem同步。 该属性允许将外部属性双向绑定到ChoiceBox，并相应地更新选择模型。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getValue() ， setValue(T)

      • onAction

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty
        ChoiceBox操作，每当更改ChoiceBox value属性时调用。 这可能是由于value属性被程序化地更改，或者当用户在弹出菜单中选择一个项目时。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • onShowing

        public final ObjectProperty<EventHandler<Event>> onShowingProperty
        在 ChoiceBox弹出窗口之前调用。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • onShown

        public final ObjectProperty<EventHandler<Event>> onShownProperty
        在ChoiceBox弹出窗口后刚刚显示。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • onHiding

        public final ObjectProperty<EventHandler<Event>> onHidingProperty
        被称为在ChoiceBox弹出窗口之前被隐藏。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • onHidden

        public final ObjectProperty<EventHandler<Event>> onHiddenProperty
        在ChoiceBox弹出窗口之后刚刚被隐藏。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

    • 字段详细信息

      • ON_SHOWING

        public static final EventType<Event> ON_SHOWING
        在选择框之前调用，在用户单击或以其他方式与ChoiceBox进行交互之后显示弹出窗口。
        从以下版本开始：
        JavaFX 8u60

      • ON_SHOWN

        public static final EventType<Event> ON_SHOWN
        在ChoiceBox显示弹出窗口后调用。
        从以下版本开始：
        JavaFX 8u60

      • ON_HIDING

        public static final EventType<Event> ON_HIDING
        调用的时候ChoiceBox弹出窗口 将被隐藏。
        从以下版本开始：
        JavaFX 8u60

      • ON_HIDDEN

        public static final EventType<Event> ON_HIDDEN
        当ChoiceBox弹出窗口被隐藏时调用。
        从以下版本开始：
        JavaFX 8u60

    • 构造方法详细信息

      • ChoiceBox

        public ChoiceBox​()
        创建一个新的ChoiceBox，它有一个空的项目列表。

      • ChoiceBox

        public ChoiceBox​(ObservableList<T> items)
        使用给定的项目创建一个新的ChoiceBox。 由于可以观察到，此列表的内容可能会随时间而变化，并且ChoiceBox将相应更新。
        参数
        items - 一组项目

    • 方法详细信息

      • setSelectionModel

        public final void setSelectionModel​(SingleSelectionModel<T> value)
        设置属性selectionModel的值。
        Property description:
        ChoiceBox的选择模型。 只有一个选择可以做，因此，ChoiceBox只支持一个SingleSelectionModel。 通常，与选择模型的主要交互是明确地设置项目列表中哪个项目应该被选择，或者倾听选择中的变化以知道选择哪个项目。

      • getSelectionModel

        public final SingleSelectionModel<T> getSelectionModel​()
        获取属性selectionModel的值。
        Property description:
        ChoiceBox的选择模型。 只有一个选择可以做，因此，ChoiceBox只支持一个SingleSelectionModel。 通常，与选择模型的主要交互是明确地设置项目列表中哪个项目应该被选择，或者倾听选择中的变化以知道选择哪个项目。

      • selectionModelProperty

        public final ObjectProperty<SingleSelectionModel<T>> selectionModelProperty​()
        ChoiceBox的选择模型。 只有一个选择可以做，因此，ChoiceBox只支持一个SingleSelectionModel。 通常，与选择模型的主要交互是明确地设置项目列表中哪个项目应该被选择，或者倾听选择中的变化以知道选择哪个项目。
        另请参见：
        getSelectionModel() ， setSelectionModel(SingleSelectionModel)

      • isShowing

        public final boolean isShowing​()
        获取显示的属性的值。
        Property description:
        指示下拉列表是否向用户显示选择列表。 这是一个只读属性，它应该通过#show和#hide方法进行操作。

      • showingProperty

        public final ReadOnlyBooleanProperty showingProperty​()
        指示下拉列表是否向用户显示选择列表。 这是一个只读属性，它应该通过#show和#hide方法进行操作。
        另请参见：
        isShowing()

      • setItems

        public final void setItems​(ObservableList<T> value)
        设置属性项的值。
        Property description:
        要在选框中显示的项目。 所选项目（如选择模型中所示）必须始终为这些项目之一。

      • getItems

        public final ObservableList<T> getItems​()
        获取属性项的值。
        Property description:
        要在选框中显示的项目。 所选项目（如选择模型中所示）必须始终为这些项目之一。

      • itemsProperty

        public final ObjectProperty<ObservableList<T>> itemsProperty​()
        要在选框中显示的项目。 所选项目（如选择模型中所示）必须始终为这些项目之一。
        另请参见：
        getItems() ， setItems(ObservableList)

      • converterProperty

        public ObjectProperty<StringConverter<T>> converterProperty​()
        允许一种方式来指定如何表示项目列表中的对象。 当设置StringConverter时，不调用对象toString方法，而是调用其toString（对象T），将对象传递到items列表中。 当在ChoiceBox中使用域对象时，这是有用的，因为此属性允许自定义表示。 此外，可以设置javafx.util.converter软件包中提供的任何预先构建的转换器。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getConverter() ， setConverter(StringConverter)

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置属性转换器的值。
        Property description:
        允许一种方式来指定如何表示项目列表中的对象。 当设置StringConverter时，不调用对象toString方法，而是调用其toString（对象T），将对象传递到items列表中。 当在ChoiceBox中使用域对象时，这是有用的，因为此属性允许自定义表示。 此外，可以设置javafx.util.converter包中提供的任何预构成的转换器。
        从以下版本开始：
        JavaFX 2.1

      • getConverter

        public final StringConverter<T> getConverter​()
        获取属性转换器的值。
        Property description:
        允许一种方式来指定如何表示项目列表中的对象。 当设置StringConverter时，不调用对象toString方法，而是调用其toString（对象T），将对象传递到items列表中。 当在ChoiceBox中使用域对象时，这是有用的，因为此属性允许自定义表示。 此外，可以设置javafx.util.converter包中提供的任何预构造转换器。
        从以下版本开始：
        JavaFX 2.1

      • valueProperty

        public ObjectProperty<T> valueProperty​()
        此ChoiceBox的值被定义为ChoiceBox选择模型中选定的项目。 valueProperty与selectedItem同步。 该属性允许将外部属性双向绑定到ChoiceBox，并相应地更新选择模型。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getValue() ， setValue(T)

      • setValue

        public final void setValue​(T value)
        设置属性值的值。
        Property description:
        此ChoiceBox的值被定义为ChoiceBox选择模型中选定的项目。 valueProperty与selectedItem同步。 该属性允许将外部属性双向绑定到ChoiceBox，并相应地更新选择模型。
        从以下版本开始：
        JavaFX 2.1

      • getValue

        public final T getValue​()
        获取属性值的值。
        Property description:
        此ChoiceBox的值被定义为ChoiceBox选择模型中选定的项目。 valueProperty与selectedItem同步。 该属性允许将外部属性双向绑定到ChoiceBox，并相应地更新选择模型。
        从以下版本开始：
        JavaFX 2.1

      • onActionProperty

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
        ChoiceBox操作，每当更改ChoiceBox value属性时调用。 这可能是由于value属性被程序化地更改，或者当用户在弹出菜单中选择一个项目时。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • setOnAction

        public final void setOnAction​(EventHandler<ActionEvent> value)
        设置属性onAction的值。
        Property description:
        ChoiceBox操作，每当更改ChoiceBox value属性时调用。 这可能是由于value属性被程序化地更改，或者当用户在弹出菜单中选择一个项目时。
        从以下版本开始：
        JavaFX 8u60

      • getOnAction

        public final EventHandler<ActionEvent> getOnAction​()
        获取属性onAction的值。
        Property description:
        ChoiceBox操作，每当更改ChoiceBox value属性时调用。 这可能是由于value属性被程序化地更改，或者当用户在弹出菜单中选择一个项目时。
        从以下版本开始：
        JavaFX 8u60

      • onShowingProperty

        public final ObjectProperty<EventHandler<Event>> onShowingProperty​()
        在 ChoiceBox弹出窗口之前调用。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • setOnShowing

        public final void setOnShowing​(EventHandler<Event> value)
        设置属性onShowing的值。
        Property description:
        在 ChoiceBox弹出窗口之前调用。
        从以下版本开始：
        JavaFX 8u60

      • getOnShowing

        public final EventHandler<Event> getOnShowing​()
        获取属性onShowing的值。
        Property description:
        在 ChoiceBox弹出窗口之前调用。
        从以下版本开始：
        JavaFX 8u60

      • onShownProperty

        public final ObjectProperty<EventHandler<Event>> onShownProperty​()
        在ChoiceBox弹出窗口之后调用。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • setOnShown

        public final void setOnShown​(EventHandler<Event> value)
        设置属性onShown的值。
        Property description:
        在ChoiceBox弹出窗口之后调用。
        从以下版本开始：
        JavaFX 8u60

      • getOnShown

        public final EventHandler<Event> getOnShown​()
        获取onShown属性的值。
        Property description:
        在ChoiceBox弹出窗口之后调用。
        从以下版本开始：
        JavaFX 8u60

      • onHidingProperty

        public final ObjectProperty<EventHandler<Event>> onHidingProperty​()
        在ChoiceBox弹出窗口被隐藏之前调用。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • setOnHiding

        public final void setOnHiding​(EventHandler<Event> value)
        设置属性onHiding的值。
        Property description:
        被称为在ChoiceBox弹出窗口之前被隐藏。
        从以下版本开始：
        JavaFX 8u60

      • getOnHiding

        public final EventHandler<Event> getOnHiding​()
        获取属性onHiding的值。
        Property description:
        在ChoiceBox弹出窗口之前被称为隐藏。
        从以下版本开始：
        JavaFX 8u60

      • onHiddenProperty

        public final ObjectProperty<EventHandler<Event>> onHiddenProperty​()
        在ChoiceBox弹出窗口之后刚刚被隐藏。
        从以下版本开始：
        JavaFX 8u60
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

      • setOnHidden

        public final void setOnHidden​(EventHandler<Event> value)
        设置属性onHidden的值。
        Property description:
        在ChoiceBox弹出窗口之后刚刚被隐藏。
        从以下版本开始：
        JavaFX 8u60

      • getOnHidden

        public final EventHandler<Event> getOnHidden​()
        获取属性onHidden的值。
        Property description:
        在ChoiceBox弹出窗口之后刚刚被隐藏。
        从以下版本开始：
        JavaFX 8u60

      • show

        public void show​()
        打开选择列表。

      • hide

        public void hide​()
        关闭选择列表。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ChoiceDialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ChoiceDialog<T>

  • java.lang.Object
    • javafx.scene.control.Dialog<T>
      • javafx.scene.control.ChoiceDialog<T>
  • 参数类型
    T - 要向用户显示的项目的类型， 以及当对话框被关闭时通过 Dialog.getResult()返回的类型。
    All Implemented Interfaces:
    EventTarget

    public class ChoiceDialog<T>
extends Dialog<T>
    一个对话框，向用户显示选择列表，最多可以从中选择一个项目。
    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Dialog

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<T> selectedItem
      返回表示对话框中当前选定项目的属性。

      • Properties inherited from class javafx.scene.control.Dialog

        contentText, dialogPane, graphic, headerText, height, onCloseRequest, onHidden, onHiding, onShowing, onShown, resizable, resultConverter, result, showing, title, width, x, y

    • 构造方法摘要

      构造方法
      Constructor 描述
      ChoiceDialog​()
      创建一个DefaultDialog的默认空的实例，没有设置项和空默认选项。
      ChoiceDialog​(T defaultChoice, Collection<T> choices)
      创建一个新的ChoiceDialog实例，第一个参数指定应向用户显示的默认选择，第二个参数指定用户的所有可用选项的集合。
      ChoiceDialog​(T defaultChoice, T... choices)
      创建一个新的ChoiceDialog实例，第一个参数指定应向用户显示的默认选项，并且所有以下参数都被视为用户所有可用选项的varargs数组。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T getDefaultChoice​()
      返回在构造函数中指定的默认选项。
      ObservableList<T> getItems​()
      返回将显示给用户的所有项目的列表。
      T getSelectedItem​()
      返回对话框中当前选定的项目。
      ReadOnlyObjectProperty<T> selectedItemProperty​()
      返回表示对话框中当前选定项目的属性。
      void setSelectedItem​(T item)
      设置对话框中当前选定的项目。

      • Methods inherited from class javafx.scene.control.Dialog

        buildEventDispatchChain, close, contentTextProperty, dialogPaneProperty, getContentText, getDialogPane, getGraphic, getHeaderText, getHeight, getModality, getOnCloseRequest, getOnHidden, getOnHiding, getOnShowing, getOnShown, getOwner, getResult, getResultConverter, getTitle, getWidth, getX, getY, graphicProperty, headerTextProperty, heightProperty, hide, initModality, initOwner, initStyle, isResizable, isShowing, onCloseRequestProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, resizableProperty, resultConverterProperty, resultProperty, setContentText, setDialogPane, setGraphic, setHeaderText, setHeight, setOnCloseRequest, setOnHidden, setOnHiding, setOnShowing, setOnShown, setResizable, setResult, setResultConverter, setTitle, setWidth, setX, setY, show, showAndWait, showingProperty, titleProperty, widthProperty, xProperty, yProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • selectedItem

        public final ReadOnlyObjectProperty<T> selectedItemProperty
        返回表示对话框中当前选定项目的属性。
        另请参见：
        getSelectedItem() ， setSelectedItem(T)

    • 构造方法详细信息

      • ChoiceDialog

        public ChoiceDialog​()
        创建一个DefaultDialog的默认空的实例，没有设置项和空默认选项。 此构造函数的用户随后需要调用getItems()来指定向用户显示哪些项目。

      • ChoiceDialog

        public ChoiceDialog​(T defaultChoice,
                    T... choices)
        创建一个新的ChoiceDialog实例，第一个参数指定应向用户显示的默认选项，并且所有以下参数都被视为用户所有可用选项的varargs数组。 预期defaultChoice是选项varargs数组中的一个元素。 如果这不是真的，那么defaultChoice将被设置为null，对话框将显示初始选择设置为选项列表中的第一个项目。
        参数
        defaultChoice - 在对话框中作为预先选择的选项显示的项目。 该项目必须包含在选项varargs数组中。
        choices - 向用户呈现的所有可能选择。

      • ChoiceDialog

        public ChoiceDialog​(T defaultChoice,
                    Collection<T> choices)
        创建一个新的ChoiceDialog实例，第一个参数指定应向用户显示的默认选择，第二个参数指定用户的所有可用选项的集合。 预期defaultChoice是选择集合中的元素之一。 如果这不是真的，那么defaultChoice将被设置为null，对话框将显示初始选择设置为选项列表中的第一个项目。
        参数
        defaultChoice - 在对话框中作为预先选择的选项显示的项目。 该项目必须包含在选项varargs数组中。
        choices - 向用户呈现的所有可能选择。

    • 方法详细信息

      • getSelectedItem

        public final T getSelectedItem​()
        返回对话框中当前选定的项目。
        结果
        当前选择的项目

      • selectedItemProperty

        public final ReadOnlyObjectProperty<T> selectedItemProperty​()
        返回表示对话框中当前选定项目的属性。
        另请参见：
        getSelectedItem() ， setSelectedItem(T)

      • setSelectedItem

        public final void setSelectedItem​(T item)
        设置对话框中当前选定的项目。
        参数
        item - 在对话框中选择的项目。

      • getItems

        public final ObservableList<T> getItems​()
        返回将显示给用户的所有项目的列表。 开发人员可以修改此列表，以添加，删除或重新排序要呈现给用户的项目。
        结果
        将显示给用户的所有项目的列表

      • getDefaultChoice

        public final T getDefaultChoice​()
        返回在构造函数中指定的默认选项。
        结果
        默认选择
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ColorPicker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ColorPicker

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ComboBoxBase<Color>
              • javafx.scene.control.ColorPicker
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ColorPicker
extends ComboBoxBase<Color>

    ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。

    value是当前选择的Color 。 初始颜色可以通过调用setColor或通过构造函数来设置。 如果没有指定，则使用默认的初始颜色。

    ColorPicker控件提供具有预定义颜色集的调色板。 如果用户不想从预定义的集合中选择，则可以通过与自定义颜色对话框交互来创建自定义颜色。 该对话框提供RGB，HSB和Web的交互模式，以创建新的颜色。 它还允许修改颜色的不透明度。

    一旦定义了一种新的颜色，用户可以选择是保存它还是使用它。 如果保存新颜色，则此颜色将显示在调色板上的自定义颜色区域中。 另外getCustomColors返回保存的自定义颜色列表。

    promptText不支持，因此是无操作的。 但未来可能会得到支持。

       final ColorPicker colorPicker = new ColorPicker(); colorPicker.setOnAction(new EventHandler() { public void handle(Event t) { Color c = colorPicker.getValue(); System.out.println("New Color's RGB = "+c.getRed()+" "+c.getGreen()+" "+c.getBlue()); } });

    ColorPicker控件的外观可以通过三种方式进行设计：简单的按钮模式，MenuButton模式或SplitMenuButton模式。 默认为MenuButton模式。 对于像外观的按钮，使用的样式类是STYLE_CLASS_BUTTON ，对于SplitMenuButton的外观和行为，使用的样式类是STYLE_CLASS_SPLIT_BUTTON 。

       colorPicker.getStyleClass().add("button");
    要么
       colorPicker.getStyleClass().add("split-button");
    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      • Properties inherited from class javafx.scene.control.ComboBoxBase

        armed, editable, onAction, onHidden, onHiding, onShowing, onShown, promptText, showing, value

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String STYLE_CLASS_BUTTON
      指定一个Button的样式类就像ColorPicker控件的外观。
      static String STYLE_CLASS_SPLIT_BUTTON
      指定SplitMenuButton的样式类，如ColorPicker控件的外观。

      • Fields inherited from class javafx.scene.control.ComboBoxBase

        ON_HIDDEN, ON_HIDING, ON_SHOWING, ON_SHOWN

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ColorPicker​()
      创建默认的ColorPicker实例，将所选颜色设置为白色。
      ColorPicker​(Color color)
      创建一个ColorPicker实例，并将所选颜色设置为给定的颜色。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      ObservableList<Color> getCustomColors​()
      获取用户添加到调色板的自定义颜色列表。

      • Methods inherited from class javafx.scene.control.ComboBoxBase

        arm, armedProperty, disarm, editableProperty, executeAccessibleAction, getOnAction, getOnHidden, getOnHiding, getOnShowing, getOnShown, getPromptText, getValue, hide, isArmed, isEditable, isShowing, onActionProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, promptTextProperty, queryAccessibleAttribute, setEditable, setOnAction, setOnHidden, setOnHiding, setOnShowing, setOnShown, setPromptText, setValue, show, showingProperty, valueProperty

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 字段详细信息

      • STYLE_CLASS_BUTTON

        public static final String STYLE_CLASS_BUTTON
        指定一个Button的样式类就像ColorPicker控件的外观。
        另请参见：
        Constant Field Values

      • STYLE_CLASS_SPLIT_BUTTON

        public static final String STYLE_CLASS_SPLIT_BUTTON
        指定SplitMenuButton的样式类，如ColorPicker控件的外观。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ColorPicker

        public ColorPicker​()
        创建默认的ColorPicker实例，将所选颜色设置为白色。

      • ColorPicker

        public ColorPicker​(Color color)
        创建一个ColorPicker实例，并将所选颜色设置为给定的颜色。
        参数
        color - 要设置为ColorPicker当前选定的颜色。

    • 方法详细信息

      • getCustomColors

        public final ObservableList<Color> getCustomColors​()
        获取用户添加到调色板的自定义颜色列表。
        结果
        自定义颜色列表

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ComboBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ComboBox<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ComboBoxBase<T>
              • javafx.scene.control.ComboBox<T>
  • 参数类型
    T - 已选择或以其他方式输入到此组合框的值的类型
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ComboBox<T>
extends ComboBoxBase<T>
    对于最常见的ComboBox形式的ComboBoxBase抽象类的实现，其中向用户提供弹出列表，以提供他们可以选择的选项。 有关ComboBox的一般概念和API的更多信息，请参阅ComboBoxBase类文档。

    在ComboBoxBase之上，ComboBox类引入了额外的API。 最重要的是，它添加了一个items属性，其工作方式与ListView items属性的方式大致相同。 换句话说，当用户单击ComboBox按钮时，它是向用户显示的项目列表的内容。

    ComboBox从ComboBoxBase公开了ComboBoxBase.valueProperty() ，但是有一些关于ComboBox需要理解的值属性的一些重要点。 这些包括：

    1. value属性不限制于包含的项目列表中的项目-它可以是任何东西，只要它是T类型的有效值
    2. 如果将value属性设置为非空对象，并且随后清除了项目列表，则value属性不会被清空。
    3. 清除选择模型中的selection 不会使值属性为空 - 它与以前保持一致。
    4. 即使列表中没有项目（或列表中的项目少于给定索引），选择模型也可以将选择集设置为给定的索引。 一旦项目列表进一步填充，使得列表包含足够的项目以使给定索引中的项目，选择模型SelectionModel.selectedItemProperty()和值属性将被更新为具有该值。 这与使用选择模型的其他控件不一致，但是有意为ComboBox进行操作。

    默认情况下，当弹出列表显示时，可见的最大行数为10，但可以通过修改visibleRowCount属性来更改。 如果ComboBox中的项目数量小于visibleRowCount的值，则将使用项目大小，以使弹出列表不会很长。

    与ListView一样，可以修改所使用的selection model ，尽管这很可能很少改变。 这是因为ComboBox强制需要一个SingleSelectionModel的实例，并不太可能需要替代的实现。 尽管如此，选择是应该使用案例来切换选择模型。

    由于ComboBox使用ListView内部呈现内容，所以在ComboBox类中存在API，以允许设置自定义单元格工厂。 有关电池厂的更多信息，请参阅Cell和ListCell类。 重要的是要注意，如果单元格工厂设置在ComboBox上，单元格将仅在ListView中使用，该单元格显示何时单击组合框。 如果您还要自定义ComboBox“按钮”区域的渲染，可以在button cell属性中设置自定义的ListCell实例。 一种方法是使用以下代码（注意使用setButtonCell ：

       Callback<ListView<String>, ListCell<String>> cellFactory = ...; ComboBox comboBox = new ComboBox(); comboBox.setItems(items); comboBox.setButtonCell(cellFactory.call(null)); comboBox.setCellFactory(cellFactory);

    因为ComboBox可以是editable ，并且允许用户输入的默认方式是通过TextField ，提供string converter属性，以允许开发人员指定如何将用户字符串转换为类型T的对象，使得27069266292882属性可以包含它 默认情况下，转换器只是按用户输入的方式返回String输入，因此假设可编辑ComboBox的类型为String。 如果指定了不同的类型，ComboBox是可编辑的，则需要指定自定义的StringConverter 。

    关于将节点插入ComboBox项目列表中的警告

    ComboBox允许项目列表包含任何类型的元素，包括Node个实例。 将节点放置在项目列表中是不推荐的 。 这是因为默认的cell factory将节点项直接插入到单元格中，包括ComboBox的“按钮”区域。 因为场景图片一次允许节点在一个位置，这意味着当选择项目时，它将从ComboBox列表中删除，并在按钮区域中变得可见。 当选择更改时，先前选择的项目返回到列表，并且删除新的选择。

    推荐的方法，而不是将节点实例插入到项目列表中，是将相关信息放入ComboBox中，然后提供自定义的cell factory 。 例如，而不是使用以下代码：

       ComboBox<Rectangle> cmb = new ComboBox<Rectangle>(); cmb.getItems().addAll( new Rectangle(10, 10, Color.RED), new Rectangle(10, 10, Color.GREEN), new Rectangle(10, 10, Color.BLUE));

    您应该执行以下操作：

       ComboBox<Color> cmb = new ComboBox<Color>(); cmb.getItems().addAll( Color.RED, Color.GREEN, Color.BLUE); cmb.setCellFactory(new Callback<ListView<Color>, ListCell<Color>>() { @Override public ListCell<Color> call(ListView<Color> p) { return new ListCell<Color>() { private final Rectangle rectangle; { setContentDisplay(ContentDisplay.GRAPHIC_ONLY); rectangle = new Rectangle(10, 10); } @Override protected void updateItem(Color item, boolean empty) { super.updateItem(item, empty); if (item == null || empty) { setGraphic(null); } else { rectangle.setFill(item); setGraphic(rectangle); } } }; } });

    诚然，上述方法更详细，但它提供了所需的功能，而不会遇到场景图限制。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ComboBoxBase ， Cell ， ListCell ， StringConverter

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<ListCell<T>> buttonCell
      按钮单元格用于渲染ComboBox“按钮”区域中显示的内容。
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> cellFactory
      提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。
      ObjectProperty<StringConverter<T>> converter
      将用户输入的输入（ComboBox为 editable ）转换为类型T的对象，以便可以通过 value属性检索输入。
      ReadOnlyObjectProperty<TextField> editor
      ComboBox的编辑器。
      ObjectProperty<ObservableList<T>> items
      在ComboBox弹出窗口中显示的项目列表。
      ObjectProperty<Node> placeholder
      当ComboBox没有内容显示时，该节点将显示给用户。
      ObjectProperty<SingleSelectionModel<T>> selectionModel
      ComboBox的选择模型。
      IntegerProperty visibleRowCount
      ComboBox弹出窗口中显示的最大行数。

      • Properties inherited from class javafx.scene.control.ComboBoxBase

        armed, editable, onAction, onHidden, onHiding, onShowing, onShown, promptText, showing, value

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.control.ComboBoxBase

        ON_HIDDEN, ON_HIDING, ON_SHOWING, ON_SHOWN

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComboBox​()
      创建一个默认的ComboBox实例，具有一个空的 items列表和默认的 selection model 。
      ComboBox​(ObservableList<T> items)
      使用提供的项目列表创建默认的ComboBox实例，默认为 selection model 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<ListCell<T>> buttonCellProperty​()
      按钮单元格用于渲染ComboBox“按钮”区域中显示的内容。
      void cancelEdit​()
      如果ComboBox是 editable ，调用此方法将尝试用最后提交的 value替换编辑器文本。
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> cellFactoryProperty​()
      提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。
      void commitValue​()
      如果ComboBox是 editable ，调用此方法将尝试提交当前文本并将其转换为 value 。
      ObjectProperty<StringConverter<T>> converterProperty​()
      将用户输入的输入（ComboBox为 editable ）转换为类型T的对象，以便可以通过 value属性检索输入。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      ReadOnlyObjectProperty<TextField> editorProperty​()
      ComboBox的编辑器。
      ListCell<T> getButtonCell​()
      获取属性buttonCell的值。
      Callback<ListView<T>,ListCell<T>> getCellFactory​()
      获取属性cellFactory的值。
      StringConverter<T> getConverter​()
      获取属性转换器的值。
      TextField getEditor​()
      获取属性编辑器的值。
      ObservableList<T> getItems​()
      获取属性项的值。
      Node getPlaceholder​()
      获取属性占位符的值。
      SingleSelectionModel<T> getSelectionModel​()
      获取属性selectionModel的值。
      int getVisibleRowCount​()
      获取属性visibleRowCount的值。
      ObjectProperty<ObservableList<T>> itemsProperty​()
      在ComboBox弹出窗口中显示的项目列表。
      ObjectProperty<Node> placeholderProperty​()
      当ComboBox没有内容显示时，该节点将显示给用户。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      ObjectProperty<SingleSelectionModel<T>> selectionModelProperty​()
      ComboBox的选择模型。
      void setButtonCell​(ListCell<T> value)
      设置属性buttonCell的值。
      void setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
      设置属性cellFactory的值。
      void setConverter​(StringConverter<T> value)
      设置属性转换器的值。
      void setItems​(ObservableList<T> value)
      设置属性项的值。
      void setPlaceholder​(Node value)
      设置属性占位符的值。
      void setSelectionModel​(SingleSelectionModel<T> value)
      设置属性selectionModel的值。
      void setVisibleRowCount​(int value)
      设置属性visibleRowCount的值。
      IntegerProperty visibleRowCountProperty​()
      ComboBox弹出窗口中显示的最大行数。

      • Methods inherited from class javafx.scene.control.ComboBoxBase

        arm, armedProperty, disarm, editableProperty, executeAccessibleAction, getOnAction, getOnHidden, getOnHiding, getOnShowing, getOnShown, getPromptText, getValue, hide, isArmed, isEditable, isShowing, onActionProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, promptTextProperty, setEditable, setOnAction, setOnHidden, setOnHiding, setOnShowing, setOnShown, setPromptText, setValue, show, showingProperty, valueProperty

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • items

        public ObjectProperty<ObservableList<T>> itemsProperty
        在ComboBox弹出窗口中显示的项目列表。
        另请参见：
        getItems() ， setItems(ObservableList)

      • converter

        public ObjectProperty<StringConverter<T>> converterProperty
        将用户输入的输入（当ComboBox为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。
        另请参见：
        getConverter() ， setConverter(StringConverter)

      • cellFactory

        public ObjectProperty<Callback<ListView<T>,ListCell<T>>> cellFactoryProperty
        提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。 有关电池工厂的更多信息，请参阅Cell javadoc。
        另请参见：
        getCellFactory() ， setCellFactory(Callback)

      • buttonCell

        public ObjectProperty<ListCell<T>> buttonCellProperty
        按钮单元格用于渲染ComboBox“按钮”区域中显示的内容。 如果一个单元格设置在这里，它不会改变ComboBox弹出列表的渲染 - 通过cell factory API来控制渲染。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getButtonCell() ， setButtonCell(ListCell)

      • selectionModel

        public final ObjectProperty<SingleSelectionModel<T>> selectionModelProperty
        ComboBox的选择模型。 ComboBox只支持单选。
        另请参见：
        getSelectionModel() ， setSelectionModel(SingleSelectionModel)

      • visibleRowCount

        public final IntegerProperty visibleRowCountProperty
        ComboBox弹出窗口中显示的最大行数。 默认情况下，此值为10，但可以更改此值，以增加或减少弹出窗口的高度。
        另请参见：
        getVisibleRowCount() ， setVisibleRowCount(int)

      • editor

        public final ReadOnlyObjectProperty<TextField> editorProperty
        ComboBox的编辑器。 如果ComboBox不是editable ，编辑器为null。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getEditor()

      • placeholder

        public final ObjectProperty<Node> placeholderProperty
        当ComboBox没有内容显示时，该节点将显示给用户。 当项列表为空或为空时，占位符节点显示在ComboBox弹出区域中。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getPlaceholder() ， setPlaceholder(Node)

    • 构造方法详细信息

      • ComboBox

        public ComboBox​()
        创建一个默认的ComboBox实例，具有一个空的 items列表和默认的 selection model 。

      • ComboBox

        public ComboBox​(ObservableList<T> items)
        使用提供的项目列表创建一个默认的ComboBox实例，默认为 selection model 。
        参数
        items - 项目清单

    • 方法详细信息

      • setItems

        public final void setItems​(ObservableList<T> value)
        设置属性项的值。
        Property description:
        在ComboBox弹出窗口中显示的项目列表。

      • getItems

        public final ObservableList<T> getItems​()
        获取属性项的值。
        Property description:
        在ComboBox弹出窗口中显示的项目列表。

      • itemsProperty

        public ObjectProperty<ObservableList<T>> itemsProperty​()
        在ComboBox弹出窗口中显示的项目列表。
        另请参见：
        getItems() ， setItems(ObservableList)

      • converterProperty

        public ObjectProperty<StringConverter<T>> converterProperty​()
        将用户输入的输入（ComboBox为 editable ）转换为类型T的对象，以便可以通过 value属性检索输入。
        另请参见：
        getConverter() ， setConverter(StringConverter)

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置属性转换器的值。
        Property description:
        将用户输入的输入（当ComboBox为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。

      • getConverter

        public final StringConverter<T> getConverter​()
        获取属性转换器的值。
        Property description:
        将用户输入的输入（当ComboBox为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。

      • setCellFactory

        public final void setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
        设置属性cellFactory的值。
        Property description:
        提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。 有关细胞工厂的更多信息，请参阅Cell javadoc。

      • getCellFactory

        public final Callback<ListView<T>,ListCell<T>> getCellFactory​()
        获取属性cellFactory的值。
        Property description:
        提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。 有关细胞工厂的更多信息，请参阅Cell javadoc。

      • cellFactoryProperty

        public ObjectProperty<Callback<ListView<T>,ListCell<T>>> cellFactoryProperty​()
        提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。 有关细胞工厂的更多信息，请参阅Cell javadoc。
        另请参见：
        getCellFactory() ， setCellFactory(Callback)

      • buttonCellProperty

        public ObjectProperty<ListCell<T>> buttonCellProperty​()
        按钮单元格用于渲染ComboBox“按钮”区域中显示的内容。 新新新旗新新新旗新新旗新新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗旗新新旗新旗200 200新新新旗200新新新200旗新200新新旗200新新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200新新200新新200新新200新新200架新旗新新旗榜
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getButtonCell() ， setButtonCell(ListCell)

      • setButtonCell

        public final void setButtonCell​(ListCell<T> value)
        设置属性buttonCell的值。
        Property description:
        按钮单元格用于渲染ComboBox“按钮”区域中显示的内容。 如果一个单元格设置在这里，它不会改变ComboBox弹出列表的渲染 - 通过cell factory API来控制渲染。
        从以下版本开始：
        JavaFX 2.2

      • getButtonCell

        public final ListCell<T> getButtonCell​()
        获取属性buttonCell的值。
        Property description:
        按钮单元格用于渲染ComboBox“按钮”区域中显示的内容。 如果一个单元格设置在这里，它不会改变ComboBox弹出列表的渲染 - 通过cell factory API来控制渲染。
        从以下版本开始：
        JavaFX 2.2

      • setSelectionModel

        public final void setSelectionModel​(SingleSelectionModel<T> value)
        设置属性selectionModel的值。
        Property description:
        ComboBox的选择模型。 ComboBox只支持单选。

      • getSelectionModel

        public final SingleSelectionModel<T> getSelectionModel​()
        获取属性selectionModel的值。
        Property description:
        ComboBox的选择模型。 ComboBox只支持单选。

      • selectionModelProperty

        public final ObjectProperty<SingleSelectionModel<T>> selectionModelProperty​()
        ComboBox的选择模型。 ComboBox只支持单选。
        另请参见：
        getSelectionModel() ， setSelectionModel(SingleSelectionModel)

      • setVisibleRowCount

        public final void setVisibleRowCount​(int value)
        设置属性visibleRowCount的值。
        Property description:
        ComboBox弹出窗口中显示的最大行数。 默认情况下，此值为10，但可以更改此值，以增加或减少弹出窗口的高度。

      • getVisibleRowCount

        public final int getVisibleRowCount​()
        获取属性visibleRowCount的值。
        Property description:
        ComboBox弹出窗口中显示的最大行数。 默认情况下，此值为10，但可以更改此值，以增加或减少弹出窗口的高度。

      • visibleRowCountProperty

        public final IntegerProperty visibleRowCountProperty​()
        ComboBox弹出窗口中显示的最大行数。 默认情况下，此值为10，但可以更改此值，以增加或减少弹出窗口的高度。
        另请参见：
        getVisibleRowCount() ， setVisibleRowCount(int)

      • getEditor

        public final TextField getEditor​()
        获取属性编辑器的值。
        Property description:
        ComboBox的编辑器。 如果ComboBox不是editable ，编辑器为null。
        从以下版本开始：
        JavaFX 2.2

      • editorProperty

        public final ReadOnlyObjectProperty<TextField> editorProperty​()
        ComboBox的编辑器。 如果ComboBox不是editable ，编辑器为null。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getEditor()

      • placeholderProperty

        public final ObjectProperty<Node> placeholderProperty​()
        当ComboBox没有内容显示时，该节点将显示给用户。 当项列表为空或为空时，占位符节点显示在ComboBox弹出区域中。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getPlaceholder() ， setPlaceholder(Node)

      • setPlaceholder

        public final void setPlaceholder​(Node value)
        设置属性占位符的值。
        Property description:
        当ComboBox没有内容显示时，该节点将显示给用户。 当项列表为空或为空时，占位符节点显示在ComboBox弹出区域中。
        从以下版本开始：
        JavaFX 8.0

      • getPlaceholder

        public final Node getPlaceholder​()
        获取属性占位符的值。
        Property description:
        当ComboBox没有内容显示时，该节点将显示给用户。 当项列表为空或为空时，占位符节点显示在ComboBox弹出区域中。
        从以下版本开始：
        JavaFX 8.0

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • commitValue

        public final void commitValue​()
        如果ComboBox是 editable ，调用此方法将尝试提交当前文本并将其转换为 value 。
        从以下版本开始：
        9

      • cancelEdit

        public final void cancelEdit​()
        如果ComboBox是 editable ，调用此方法将尝试用最后提交的 value替换编辑器文本。
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 ComboBoxBase<T>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ComboBoxBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ComboBoxBase<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ComboBoxBase<T>
  • 参数类型
    T - 已选择或以其他方式输入到此ComboBox的值的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    ColorPicker ， ComboBox ， DatePicker

    public abstract class ComboBoxBase<T>
extends Control
    ComboBox类控件的抽象基类。 ComboBox通常具有一个按钮，当被点击时，会弹出一些允许用户选择一个或多个值（取决于实现）的方法。 这个基类不会考虑当调用show()和hide()方法时会发生什么，但是通常会导致出现弹出窗口或对话框，从而允许用户提供所需的信息。

    ComboBox有一个表示当前用户输入的value属性。 这可以基于从下拉列表中的选择，或者当ComboBox是editable时可能来自用户输入。

    一个editable ComboBox是为最终用户提供一些手段，为其他可选择的选项提供输入。 例如，在ComboBox实现中，可编辑的ComboBox提供了可能键入的TextField 。 如上所述，当用户将文本输入提交到文本字段（通常按Enter键盘键）时， value属性将被更新。

    这个类与ComboBox之间的分离的目的是允许不一定弹出一个项目列表的类似ComboBox的控件。 其他实现的示例包括颜色选择器，日历选择器等。ComboBox类提供了默认的，最常见的预期实现。 有关更多信息，请参阅javadoc类。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    ComboBox

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty armed
      表示ComboBox已经“布防”，使得鼠标释放将导致ComboBox show()方法被调用。
      BooleanProperty editable
      指定ComboBox是否允许用户输入。
      ObjectProperty<EventHandler<ActionEvent>> onAction
      ComboBox操作，当ComboBox value属性更改时调用。
      ObjectProperty<EventHandler<Event>> onHidden
      在ComboBoxBase弹出/显示已被隐藏之后调用。
      ObjectProperty<EventHandler<Event>> onHiding
      在ComboBox弹出窗口/显示屏被隐藏之前调用。
      ObjectProperty<EventHandler<Event>> onShowing
      在 ComboBoxBase弹出/显示之前打电话。
      ObjectProperty<EventHandler<Event>> onShown
      在显示ComboBoxBase弹出/显示之后调用。
      StringProperty promptText
      要显示 ComboBox提示文本，如果没有显示提示文本，则显示 null 。
      ReadOnlyBooleanProperty showing
      表示ComboBox弹出窗口的当前状态，以及当前是否在屏幕上可见（尽管可能隐藏在其他窗口后面）。
      ObjectProperty<T> value
      如果输入不可编辑，或者如果可编辑，则该组合框的值被定义为所选项，最近的用户操作：用户输入的值或最后选择的项。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<Event> ON_HIDDEN
      当ComboBox弹出/显示已被隐藏时调用。
      static EventType<Event> ON_HIDING
      当ComboBox弹出/显示 将被隐藏时调用。
      static EventType<Event> ON_SHOWING
      在ComboBox之前调用，在用户单击或以其他方式与ComboBox进行交互之后显示弹出/显示。
      static EventType<Event> ON_SHOWN
      在ComboBox显示弹出/显示后调用。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComboBoxBase​()
      创建默认的ComboBoxBase实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void arm​()
      武装ComboBox。
      BooleanProperty armedProperty​()
      表示ComboBox已被“布防”，使得鼠标释放将导致ComboBox show()方法被调用。
      void disarm​()
      取消ComboBox。
      BooleanProperty editableProperty​()
      指定ComboBox是否允许用户输入。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      EventHandler<ActionEvent> getOnAction​()
      获取属性onAction的值。
      EventHandler<Event> getOnHidden​()
      获取属性onHidden的值。
      EventHandler<Event> getOnHiding​()
      获取属性onHiding的值。
      EventHandler<Event> getOnShowing​()
      获取属性onShowing的值。
      EventHandler<Event> getOnShown​()
      获取onShown属性的值。
      String getPromptText​()
      获取属性promptText的值。
      T getValue​()
      获取属性值的值。
      void hide​()
      关闭当 调用show()时显示的弹出/对话框。
      boolean isArmed​()
      获得武器的价值。
      boolean isEditable​()
      获取可编辑属性的值。
      boolean isShowing​()
      获取显示的属性的值。
      ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
      ComboBox操作，当ComboBox value属性更改时调用。
      ObjectProperty<EventHandler<Event>> onHiddenProperty​()
      在ComboBoxBase弹出/显示已被隐藏之后调用。
      ObjectProperty<EventHandler<Event>> onHidingProperty​()
      在ComboBox弹出/显示被隐藏之前调用。
      ObjectProperty<EventHandler<Event>> onShowingProperty​()
      在 ComboBoxBase弹出/显示之前打电话。
      ObjectProperty<EventHandler<Event>> onShownProperty​()
      在显示ComboBoxBase弹出/显示后调用。
      StringProperty promptTextProperty​()
      ComboBox提示文本显示，如果没有显示提示文本，则显示 null 。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setEditable​(boolean value)
      设置属性可编辑的值。
      void setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void setOnHidden​(EventHandler<Event> value)
      设置属性onHidden的值。
      void setOnHiding​(EventHandler<Event> value)
      设置属性onHiding的值。
      void setOnShowing​(EventHandler<Event> value)
      设置属性onShowing的值。
      void setOnShown​(EventHandler<Event> value)
      设置属性onShown的值。
      void setPromptText​(String value)
      设置属性promptText的值。
      void setValue​(T value)
      设置属性值的值。
      void show​()
      请求ComboBox显示用户界面的弹出窗口。
      ReadOnlyBooleanProperty showingProperty​()
      表示ComboBox弹出窗口的当前状态，以及当前是否在屏幕上可见（尽管可能隐藏在其他窗口后面）。
      ObjectProperty<T> valueProperty​()
      如果输入不可编辑，或者如果可编辑，则该组合框的值被定义为所选项，最近的用户操作：用户输入的值或最后选择的项。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, createDefaultSkin, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • value

        public ObjectProperty<T> valueProperty
        如果输入不可编辑，或者如果可编辑，则该组合框的值被定义为所选项，最近的用户操作：用户输入的值或最后选择的项。
        另请参见：
        getValue() ， setValue(T)

      • editable

        public BooleanProperty editableProperty
        指定ComboBox是否允许用户输入。 当可编辑为true时，ComboBox具有用户可能键入的文本输入区域。 此输入可通过value属性获得。

        请注意，当editable属性更改时，value属性将重新设置，以及任何其他相关状态。

        另请参见：
        isEditable() ， setEditable(boolean)

      • showing

        public ReadOnlyBooleanProperty showingProperty
        表示ComboBox弹出窗口的当前状态，以及当前是否在屏幕上可见（尽管可能隐藏在其他窗口后面）。
        另请参见：
        isShowing()

      • promptText

        public final StringProperty promptTextProperty
        要显示ComboBox提示文本，或者如果没有显示提示文本， null 。 在所有情况下不显示提示文本，它将依赖于ComboBoxBase的子类，以便在显示promptText时进行说明。 例如，在大多数情况下，当组合框不可编辑时（即，仅当通过文本输入允许用户输入时才显示提示文本），提示文本将永远不会显示。
        另请参见：
        getPromptText() ， setPromptText(String)

      • armed

        public BooleanProperty armedProperty
        表示ComboBox已被“布防”，使得鼠标释放将导致ComboBox show()方法被调用。 这与压制有所不同。 Pressed表示鼠标已经在节点上按下并且尚未被释放。 然而， arm还考虑了鼠标是否实际上在ComboBox上并按下。
        另请参见：
        isArmed()

      • onAction

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty
        ComboBox操作，当ComboBox value属性更改时调用。 这可能是由于value属性被程序改变，当用户选择弹出列表或对话框中的项目时，或者在editable ComboBoxes的情况下，可能是当用户提供自己的输入（通过TextField或其他一些输入机制。
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • onShowing

        public final ObjectProperty<EventHandler<Event>> onShowingProperty
        在刚刚显示的 ComboBoxBase弹出窗口之前调用。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • onShown

        public final ObjectProperty<EventHandler<Event>> onShownProperty
        在显示ComboBoxBase弹出/显示之后调用。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • onHiding

        public final ObjectProperty<EventHandler<Event>> onHidingProperty
        在ComboBox弹出/显示被隐藏之前调用。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • onHidden

        public final ObjectProperty<EventHandler<Event>> onHiddenProperty
        在ComboBoxBase弹出/显示已被隐藏之后调用。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

    • 字段详细信息

      • ON_SHOWING

        public static final EventType<Event> ON_SHOWING

        在ComboBox之前调用，在用户单击或以其他方式与ComboBox进行交互之后显示弹出/显示。

        从以下版本开始：
        JavaFX 2.2

      • ON_SHOWN

        public static final EventType<Event> ON_SHOWN

        在ComboBox显示弹出/显示后调用。

        从以下版本开始：
        JavaFX 2.2

      • ON_HIDING

        public static final EventType<Event> ON_HIDING

        当ComboBox弹出/显示将被隐藏时调用。

        从以下版本开始：
        JavaFX 2.2

      • ON_HIDDEN

        public static final EventType<Event> ON_HIDDEN

        当ComboBox弹出/显示已被隐藏时调用。

        从以下版本开始：
        JavaFX 2.2

    • 构造方法详细信息

      • ComboBoxBase

        public ComboBoxBase​()
        创建默认的ComboBoxBase实例。

    • 方法详细信息

      • valueProperty

        public ObjectProperty<T> valueProperty​()
        如果输入不可编辑，或者如果可编辑，则该组合框的值被定义为所选项，最近的用户操作：用户输入的值或最后选择的项。
        另请参见：
        getValue() ， setValue(T)

      • setValue

        public final void setValue​(T value)
        设置属性值的值。
        Property description:
        如果输入不可编辑，或者如果可编辑，则该组合框的值被定义为所选项，最近的用户操作：用户输入的值或最后选择的项。

      • getValue

        public final T getValue​()
        获取属性值的值。
        Property description:
        如果输入不可编辑，或者如果可编辑，则该组合框的值被定义为所选项，最近的用户操作：用户输入的值或最后选择的项。

      • editableProperty

        public BooleanProperty editableProperty​()
        指定ComboBox是否允许用户输入。 当可编辑为true时，ComboBox具有用户可能键入的文本输入区域。 此输入可通过value属性获得。

        请注意，当editable属性更改时，value属性将重新设置，以及任何其他相关状态。

        另请参见：
        isEditable() ， setEditable(boolean)

      • setEditable

        public final void setEditable​(boolean value)
        设置属性可编辑的值。
        Property description:
        指定ComboBox是否允许用户输入。 当可编辑为true时，ComboBox具有用户可能键入的文本输入区域。 此输入可通过value属性获得。

        请注意，当editable属性更改时，value属性将重新设置，以及任何其他相关状态。

      • isEditable

        public final boolean isEditable​()
        获取可编辑属性的值。
        Property description:
        指定ComboBox是否允许用户输入。 当可编辑为true时，ComboBox具有用户可能键入的文本输入区域。 此输入可通过value属性获得。

        请注意，当editable属性更改时，value属性将重新设置，以及任何其他相关状态。

      • showingProperty

        public ReadOnlyBooleanProperty showingProperty​()
        表示ComboBox弹出窗口的当前状态，以及当前是否在屏幕上可见（尽管可能隐藏在其他窗口后面）。
        另请参见：
        isShowing()

      • isShowing

        public final boolean isShowing​()
        获取显示的属性的值。
        Property description:
        表示ComboBox弹出窗口的当前状态，以及当前是否在屏幕上可见（尽管可能隐藏在其他窗口后面）。

      • promptTextProperty

        public final StringProperty promptTextProperty​()
        ComboBox提示文本显示，如果没有显示提示文本，则显示null 。 在所有情况下不显示提示文本，它将依赖于ComboBoxBase的子类，以便在显示promptText时进行说明。 例如，在大多数情况下，当组合框不可编辑时（即，仅当通过文本输入允许用户输入时才显示提示文本），提示文本将永远不会显示。
        另请参见：
        getPromptText() ， setPromptText(String)

      • getPromptText

        public final String getPromptText​()
        获取属性promptText的值。
        Property description:
        ComboBox提示文本显示，如果没有显示提示文本，则显示null 。 在所有情况下不显示提示文本，它将依赖于ComboBoxBase的子类，以便在显示promptText时进行说明。 例如，在大多数情况下，当组合框不可编辑时（即，仅当通过文本输入允许用户输入时才显示提示文本），提示文本将永远不会显示。

      • setPromptText

        public final void setPromptText​(String value)
        设置属性promptText的值。
        Property description:
        ComboBox提示文本显示，如果没有显示提示文本， null 。 在所有情况下不显示提示文本，它将依赖于ComboBoxBase的子类，以便在显示promptText时进行说明。 例如，在大多数情况下，当组合框不可编辑时（即，仅当通过文本输入允许用户输入时才显示提示文本），提示文本将永远不会显示。

      • armedProperty

        public BooleanProperty armedProperty​()
        表示ComboBox已被“布防”，以便鼠标释放将导致ComboBox show()方法被调用。 这与压制有所不同。 Pressed表示鼠标已经在节点上按下并且尚未被释放。 arm但是也考虑到鼠标是否实际上是在ComboBox上按下。
        另请参见：
        isArmed()

      • isArmed

        public final boolean isArmed​()
        获得武器的价值。
        Property description:
        表示ComboBox已被“布防”，使得鼠标释放将导致ComboBox show()方法被调用。 这与压制有所不同。 Pressed表示鼠标已经在节点上按下并且尚未被释放。 然而， arm还考虑了鼠标是否实际上在ComboBox上并按下。

      • onActionProperty

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
        ComboBox操作，当ComboBox value属性更改时调用。 这可能是由于value属性被编程改变，当用户选择弹出列表或对话框中的项目时，或者在editable ComboBoxes的情况下，可能是用户提供自己的输入（通过TextField X- 200 200 X- 200 200 X- 200 200 X- 200 200 X-
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • setOnAction

        public final void setOnAction​(EventHandler<ActionEvent> value)
        设置属性onAction的值。
        Property description:
        ComboBox操作，当ComboBox value属性更改时调用。 这可能是由于value属性被程序改变，当用户选择弹出列表或对话框中的项目时，或者在editable ComboBoxes的情况下，可能是当用户提供自己的输入（通过TextField X- 200 200 X- 200 200 X- 200 200 X- 200 200 X-

      • getOnAction

        public final EventHandler<ActionEvent> getOnAction​()
        获取属性onAction的值。
        Property description:
        ComboBox操作，当ComboBox value属性更改时调用。 这可能是由于value属性被程序更改，当用户选择弹出列表或对话框中的项目时，或者在editable组合框的情况下，可能是用户提供自己的输入（通过TextField或其他一些输入机制。

      • onShowingProperty

        public final ObjectProperty<EventHandler<Event>> onShowingProperty​()
        在 ComboBoxBase弹出/显示之前打电话。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • setOnShowing

        public final void setOnShowing​(EventHandler<Event> value)
        设置属性onShowing的值。
        Property description:
        在 ComboBoxBase弹出/显示之前调用。
        从以下版本开始：
        JavaFX 2.2

      • getOnShowing

        public final EventHandler<Event> getOnShowing​()
        获取属性onShowing的值。
        Property description:
        在 ComboBoxBase弹出/显示之前调用。
        从以下版本开始：
        JavaFX 2.2

      • onShownProperty

        public final ObjectProperty<EventHandler<Event>> onShownProperty​()
        在ComboBoxBase弹出/显示后显示。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • setOnShown

        public final void setOnShown​(EventHandler<Event> value)
        设置属性onShown的值。
        Property description:
        在显示ComboBoxBase弹出/显示之后调用。
        从以下版本开始：
        JavaFX 2.2

      • getOnShown

        public final EventHandler<Event> getOnShown​()
        获取onShown属性的值。
        Property description:
        在显示ComboBoxBase弹出/显示后调用。
        从以下版本开始：
        JavaFX 2.2

      • onHidingProperty

        public final ObjectProperty<EventHandler<Event>> onHidingProperty​()
        在ComboBox弹出/显示被隐藏之前调用。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • setOnHiding

        public final void setOnHiding​(EventHandler<Event> value)
        设置属性onHiding的值。
        Property description:
        在ComboBox弹出/显示被隐藏之前调用。
        从以下版本开始：
        JavaFX 2.2

      • getOnHiding

        public final EventHandler<Event> getOnHiding​()
        获取属性onHiding的值。
        Property description:
        在ComboBox弹出/显示被隐藏之前调用。
        从以下版本开始：
        JavaFX 2.2

      • onHiddenProperty

        public final ObjectProperty<EventHandler<Event>> onHiddenProperty​()
        在ComboBoxBase弹出/显示已被隐藏之后调用。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

      • setOnHidden

        public final void setOnHidden​(EventHandler<Event> value)
        设置属性onHidden的值。
        Property description:
        在ComboBoxBase弹出/显示已被隐藏之后调用。
        从以下版本开始：
        JavaFX 2.2

      • getOnHidden

        public final EventHandler<Event> getOnHidden​()
        获取属性onHidden的值。
        Property description:
        在ComboBoxBase弹出/显示已被隐藏之后调用。
        从以下版本开始：
        JavaFX 2.2

      • show

        public void show​()
        请求ComboBox显示用户界面的弹出窗口。 如ComboBoxBase类javadoc中所提到的，调用此方法时实际显示的内容是未定义的，但通常它是某种形式的弹出窗口或对话窗口。

      • hide

        public void hide​()
        关闭当 调用show()时显示的弹出/对话框。

      • arm

        public void arm​()
        武装ComboBox。 武装的ComboBox将在下一个预期的UI手势上显示一个弹出列表。 注意：此功能主要由专家使用，主要由实施新皮肤或行为的人员使用。 开发人员或设计师直接访问此功能并不常见。

      • disarm

        public void disarm​()
        取消ComboBox。 见arm() 。 注意：此功能主要由专家使用，主要由实施新皮肤或行为的人员使用。 开发人员或设计师直接访问此功能并不常见。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 要执行的操作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ContentDisplay (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum ContentDisplay

  • java.lang.Object
    • java.lang.Enum<ContentDisplay>
      • javafx.scene.control.ContentDisplay
  • All Implemented Interfaces:
    Serializable ， Comparable<ContentDisplay>

    public enum ContentDisplay
extends Enum<ContentDisplay>

    将内容放置在标签内的位置。

    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BOTTOM
      内容将被放置在标签的底部。
      CENTER
      内容将被放置在标签的中心。
      GRAPHIC_ONLY
      只会显示内容。
      LEFT
      内容将放置在标签的左侧。
      RIGHT
      内容将放在标签的右侧。
      TEXT_ONLY
      只显示标签的文字。
      TOP
      内容将被放置在标签的顶部。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ContentDisplay valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ContentDisplay[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • TOP

        public static final ContentDisplay TOP

        内容将被放置在标签的顶部。

      • RIGHT

        public static final ContentDisplay RIGHT

        内容将放在标签的右侧。

      • BOTTOM

        public static final ContentDisplay BOTTOM

        内容将被放置在标签的底部。

      • LEFT

        public static final ContentDisplay LEFT

        内容将放置在标签的左侧。

      • CENTER

        public static final ContentDisplay CENTER

        内容将被放置在标签的中心。

      • GRAPHIC_ONLY

        public static final ContentDisplay GRAPHIC_ONLY

        只会显示内容。

      • TEXT_ONLY

        public static final ContentDisplay TEXT_ONLY

        只显示标签的文字。

    • 方法详细信息

      • values

        public static ContentDisplay[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ContentDisplay c : ContentDisplay.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ContentDisplay valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ContextMenu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ContextMenu

  • java.lang.Object
    • javafx.stage.Window
      • javafx.stage.PopupWindow
        • javafx.scene.control.PopupControl
          • javafx.scene.control.ContextMenu
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @IDProperty("id")
public class ContextMenu
extends PopupControl

    一个包含菜单项的ObservableList的弹出控件。 所述items ObservableList允许任何MenuItem要被插入的类型，包括它的子类Menu ， MenuItem ， RadioMenuItem ， CheckMenuItem和CustomMenuItem 。 如果任意一个Node需要插入菜单，可以使用CustomMenuItem。 这个一般规则的一个例外是SeparatorMenuItem可以用于插入分隔符。

    此类的常见用例是为用户创建和显示上下文菜单。 要使用ContextMenu创建上下文菜单，您可以执行以下操作：

       final ContextMenu contextMenu = new ContextMenu(); contextMenu.setOnShowing(new EventHandler<WindowEvent>() { public void handle(WindowEvent e) { System.out.println("showing"); } }); contextMenu.setOnShown(new EventHandler<WindowEvent>() { public void handle(WindowEvent e) { System.out.println("shown"); } }); MenuItem item1 = new MenuItem("About"); item1.setOnAction(new EventHandler<ActionEvent>() { public void handle(ActionEvent e) { System.out.println("About"); } }); MenuItem item2 = new MenuItem("Preferences"); item2.setOnAction(new EventHandler<ActionEvent>() { public void handle(ActionEvent e) { System.out.println("Preferences"); } }); contextMenu.getItems().addAll(item1, item2); final TextField textField = new TextField("Type Something"); textField.setContextMenu(contextMenu);

    Control.setContextMenu(javafx.scene.control.ContextMenu)方便的方法可以用于在任何控件上设置上下文菜单。 上述示例导致上下文菜单显示在TextField的右侧Side上。 或者，也可以在控件上设置事件处理程序来调用上下文菜单，如下所示。

       textField.setOnAction(new EventHandler<ActionEvent>() { public void handle(ActionEvent e) { contextMenu.show(textField, Side.BOTTOM, 0, 0); } }); Group root = (Group) scene.getRoot(); root.getChildren().add(textField);

    在此示例中，当用户点击Button （当然，您应该使用MenuButton控件来执行此操作而不是执行上述操作）时，将显示上下文菜单。

    请注意，上述代码示例中使用的show函数将导致ContextMenu直接出现在TextField下方。 您可以更改Side以获取您期望的结果。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MenuItem ， Menu

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<EventHandler<ActionEvent>> onAction
      当该 ContextMenu包含的项目已被激活时，通知回调功能。

      • Properties inherited from class javafx.scene.control.PopupControl

        id, maxHeight, maxWidth, minHeight, minWidth, prefHeight, prefWidth, skin, style

      • Properties inherited from class javafx.stage.PopupWindow

        anchorLocation, anchorX, anchorY, autoFix, autoHide, consumeAutoHidingEvents, hideOnEscape, onAutoHide, ownerNode, ownerWindow

      • Properties inherited from class javafx.stage.Window

        eventDispatcher, focused, forceIntegerRenderScale, height, onCloseRequest, onHidden, onHiding, onShowing, onShown, opacity, outputScaleX, outputScaleY, renderScaleX, renderScaleY, scene, showing, width, x, y

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.control.PopupControl

        PopupControl.CSSBridge

      • Nested classes/interfaces inherited from class javafx.stage.PopupWindow

        PopupWindow.AnchorLocation

    • Field Summary

      • Fields inherited from class javafx.scene.control.PopupControl

        bridge, USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ContextMenu​()
      创建一个新的ContextMenu
      ContextMenu​(MenuItem... items)
      创建一个使用给定项目初始化的新的ContextMenu

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      ObservableList<MenuItem> getItems​()
      上下文菜单中的菜单项。
      EventHandler<ActionEvent> getOnAction​()
      获取属性onAction的值。
      void hide​()
      隐藏这个 ContextMenu和任何可见的子菜单，假设当这个函数被调用时显示 ContextMenu 。
      ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
      当该 ContextMenu包含的项目已被激活时，回调功能将被通知。
      void setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void show​(Node anchor, double screenX, double screenY)
      在指定的屏幕坐标处显示 ContextMenu 。
      void show​(Node anchor, Side side, double dx, double dy)
      示出了 ContextMenu相对于给定锚节点，在由指定的侧 hpos个 vpos参数，并且由给定的偏移 dx倍 dy分别用于x轴和y轴，的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.PopupControl

        getClassCssMetaData, getCssMetaData, getId, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getPrefHeight, getPrefWidth, getPseudoClassStates, getSkin, getStyle, getStyleableNode, getStyleableParent, getStyleClass, getTypeSelector, idProperty, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, pseudoClassStateChanged, setId, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setPrefHeight, setPrefSize, setPrefWidth, setSkin, setStyle, skinProperty, styleProperty

      • Methods inherited from class javafx.stage.PopupWindow

        anchorLocationProperty, anchorXProperty, anchorYProperty, autoFixProperty, autoHideProperty, consumeAutoHidingEventsProperty, getAnchorLocation, getAnchorX, getAnchorY, getConsumeAutoHidingEvents, getOnAutoHide, getOwnerNode, getOwnerWindow, hideOnEscapeProperty, isAutoFix, isAutoHide, isHideOnEscape, onAutoHideProperty, ownerNodeProperty, ownerWindowProperty, setAnchorLocation, setAnchorX, setAnchorY, setAutoFix, setAutoHide, setConsumeAutoHidingEvents, setHideOnEscape, setOnAutoHide, setScene, show, show

      • Methods inherited from class javafx.stage.Window

        addEventFilter, addEventHandler, buildEventDispatchChain, centerOnScreen, eventDispatcherProperty, fireEvent, focusedProperty, forceIntegerRenderScaleProperty, getEventDispatcher, getHeight, getOnCloseRequest, getOnHidden, getOnHiding, getOnShowing, getOnShown, getOpacity, getOutputScaleX, getOutputScaleY, getProperties, getRenderScaleX, getRenderScaleY, getScene, getUserData, getWidth, getWindows, getX, getY, hasProperties, heightProperty, isFocused, isForceIntegerRenderScale, isShowing, onCloseRequestProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, opacityProperty, outputScaleXProperty, outputScaleYProperty, removeEventFilter, removeEventHandler, renderScaleXProperty, renderScaleYProperty, requestFocus, sceneProperty, setEventDispatcher, setEventHandler, setForceIntegerRenderScale, setHeight, setOnCloseRequest, setOnHidden, setOnHiding, setOnShowing, setOnShown, setOpacity, setRenderScaleX, setRenderScaleY, setUserData, setWidth, setX, setY, show, showingProperty, sizeToScene, widthProperty, xProperty, yProperty

    • Property Detail

      • onAction

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty
        当这个ContextMenu包含的项目被激活时，回调功能被通知。 当前的实现也通知所有父菜单，因此不需要收听所有子菜单的事件。
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

    • 构造方法详细信息

      • ContextMenu

        public ContextMenu​()
        创建一个新的ContextMenu

      • ContextMenu

        public ContextMenu​(MenuItem... items)
        创建一个使用给定项目初始化的新的ContextMenu
        参数
        items - 菜单项列表

    • 方法详细信息

      • setOnAction

        public final void setOnAction​(EventHandler<ActionEvent> value)
        设置属性onAction的值。
        Property description:
        当这个ContextMenu包含的项目被激活时，通知回调函数。 当前的实现也通知所有父菜单，因此不需要收听所有子菜单的事件。

      • getOnAction

        public final EventHandler<ActionEvent> getOnAction​()
        获取属性onAction的值。
        Property description:
        当这个ContextMenu包含的项目被激活时，回调功能被通知。 当前的实现也通知所有父菜单，因此不需要收听所有子菜单的事件。

      • onActionProperty

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
        当这个ContextMenu包含的项目被激活时，通知回调功能。 当前的实现也通知所有父菜单，因此不需要收听所有子菜单的事件。
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • getItems

        public final ObservableList<MenuItem> getItems​()
        上下文菜单中的菜单项。 如果这个ObservableList在运行时被修改，ContextMenu将按预期更新。
        结果
        此上下文菜单上的菜单项
        另请参见：
        MenuItem

      • show

        public void show​(Node anchor,
                 Side side,
                 double dx,
                 double dy)
        示出了ContextMenu相对于给定锚节点，在由指定的侧hpos个vpos参数，并且由给定的偏移dx倍dy分别用于x轴和y轴，的值。 如果没有足够的空间，菜单将移动到相反的一侧，并且不应用偏移量。

        为了澄清hpos和vpos参数的目的，请考虑它们是相对于锚节点。 因此， hpos和vpos的CENTER将意味着ContextMenu出现在锚点的顶部， ContextMenu的（0,0）位置位于ContextMenu的（0,0）处。 甲hpos的右然后将转移的ContextMenu使得其左上（0,0）位置将被附接至锚定件的右上方位置。

        此功能可用于精细调整菜单的位置，相对于父节点，以确保紧密对齐。

        参数
        anchor - 锚节点
        side - 一边
        dx - x轴的dx值
        dy - y轴的dy值

      • show

        public void show​(Node anchor,
                 double screenX,
                 double screenY)
        在指定的屏幕坐标处显示ContextMenu 。 如果在指定位置没有足够的空间来显示ContextMenu给出其尺寸要求，则必须进行调整以使ContextMenu回到屏幕上。 这也意味着ContextMenu不会跨越多个显示器。
        重写：
        show在 PopupWindow
        参数
        anchor - 锚节点
        screenX - 锚点在屏幕坐标中的x位置
        screenY - 锚点在屏幕坐标中的y位置

      • hide

        public void hide​()
        隐藏这个ContextMenu和任何可见的子菜单，假设当这个函数被调用时显示ContextMenu 。

        如果这个ContextMenu没有显示，那么没有任何反应。

        重写：
        hide在 PopupWindow

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 PopupControl
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Control (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Control

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    Accordion ， ButtonBar ， ChoiceBox ， ComboBoxBase ， HTMLEditor ， Labeled ， ListView ， MenuBar ， Pagination ， ProgressIndicator ， ScrollBar ， ScrollPane ， Separator ， Slider ， Spinner ， SplitPane ， TableView ， TabPane ， TextInputControl ， ToolBar ， TreeTableView ， TreeView

    public abstract class Control
extends Region
implements Skinnable
    所有用户界面控件的基类。 “控制”是场景图中可由用户操纵的节点。 控件提供了超出Node以外的其他变量和行为，以便为用户提供一致和可预测的方式来支持常见的用户交互。

    此外，控件支持显式外观，以便在自定义其外观时轻松利用控件的功能。

    有关如何使用各种类型的控件的信息，请参阅具体的“控制”子类。

    大多数控件的focusTraversable属性默认设置为true，但是只读控件（例如Label和ProgressIndicator ）以及一些控件是容器ScrollPane和ToolBar 。 有关详细信息，请参阅个人控制文件

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<ContextMenu> contextMenu
      为此控件显示的ContextMenu。
      ObjectProperty<Skin<?>> skin
      皮肤负责渲染这个 Control 。
      ObjectProperty<Tooltip> tooltip
      用于此控件的工具提示。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Control​()
      创建一个新的控件。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected double computeMaxHeight​(double width)
      根据提供的宽度计算控制的最大允许高度。
      protected double computeMaxWidth​(double height)
      根据提供的高度计算控件的最大允许宽度。
      protected double computeMinHeight​(double width)
      根据提供的宽度计算控制的最小允许高度。
      protected double computeMinWidth​(double height)
      根据提供的高度计算控件的最小允许宽度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      ObjectProperty<ContextMenu> contextMenuProperty​()
      为此控件显示的ContextMenu。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      double getBaselineOffset​()
      基于第一个受管理的子节点计算基线偏移量。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      ContextMenu getContextMenu​()
      获取属性contextMenu的值。
      protected List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      此方法返回List包含所有CssMetaData两个这种控制（从返回getControlCssMetaData()及其Skin ，假设skin property为SkinBase 。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      Skin<?> getSkin​()
      获取属性皮肤的值。
      Tooltip getTooltip​()
      获取属性工具提示的值。
      boolean isResizable​()
      返回 true因为所有控件都可调整大小。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setContextMenu​(ContextMenu value)
      设置属性contextMenu的值。
      void setSkin​(Skin<?> value)
      设置属性皮肤的值。
      void setTooltip​(Tooltip value)
      设置属性工具提示的值。
      ObjectProperty<Skin<?>> skinProperty​()
      皮肤负责渲染这个 Control 。
      ObjectProperty<Tooltip> tooltipProperty​()
      用于此控件的工具提示。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • skin

        public final ObjectProperty<Skin<?>> skinProperty
        皮肤负责渲染这个Control 。 从Control的角度来看， Skin是一个黑盒子。 它在Control监听和响应状态的Control 。

        Control与其Skin之间存在一对一的关系。 每Skin保持回参考Control通过Skin.getSkinnable()方法。

        皮肤可能为空。

        Specified by:
        skinProperty在接口 Skinnable
        另请参见：
        getSkin() ， setSkin(Skin)

      • tooltip

        public final ObjectProperty<Tooltip> tooltipProperty
        用于此控件的工具提示。
        另请参见：
        getTooltip() ， setTooltip(Tooltip)

      • contextMenu

        public final ObjectProperty<ContextMenu> contextMenuProperty
        为此控件显示的ContextMenu。
        另请参见：
        getContextMenu() ， setContextMenu(ContextMenu)

    • 构造方法详细信息

      • Control

        protected Control​()
        创建一个新的控件。

    • 方法详细信息

      • skinProperty

        public final ObjectProperty<Skin<?>> skinProperty​()
        皮肤负责渲染这个Control 。 从Control的角度来看， Skin是一个黑盒子。 它在Control监听和响应状态的Control 。

        一个Control和它的Skin之间有一对一的关系。 每Skin保持回参考Control通过Skin.getSkinnable()方法。

        皮肤可能为空。

        Specified by:
        skinProperty在接口 Skinnable
        另请参见：
        getSkin() ， setSkin(Skin)

      • setSkin

        public final void setSkin​(Skin<?> value)
        设置属性皮肤的值。
        Specified by:
        setSkin在接口 Skinnable
        Property description:
        皮肤负责渲染这个Control 。 从Control的角度来看， Skin是一个黑盒子。 它在一个Control监听和响应状态的Control 。

        一个Control和它的Skin之间有一对一的关系。 每Skin保持回参考Control通过Skin.getSkinnable()方法。

        皮肤可能为空。

        参数
        value - 此控件的皮肤值

      • getSkin

        public final Skin<?> getSkin​()
        获取属性皮肤的值。
        Specified by:
        getSkin在接口 Skinnable
        Property description:
        皮肤负责渲染这个Control 。 从Control的角度来看， Skin是一个黑盒子。 它在Control监听和响应状态的Control 。

        Control与其Skin之间存在一对一的关系。 每Skin保持回参考Control通过Skin.getSkinnable()方法。

        皮肤可能为空。

        结果
        这个控制的皮肤

      • tooltipProperty

        public final ObjectProperty<Tooltip> tooltipProperty​()
        用于此控件的工具提示。
        另请参见：
        getTooltip() ， setTooltip(Tooltip)

      • setTooltip

        public final void setTooltip​(Tooltip value)
        设置属性工具提示的值。
        Property description:
        用于此控件的工具提示。

      • getTooltip

        public final Tooltip getTooltip​()
        获取属性工具提示的值。
        Property description:
        用于此控件的工具提示。

      • contextMenuProperty

        public final ObjectProperty<ContextMenu> contextMenuProperty​()
        为此控件显示的ContextMenu。
        另请参见：
        getContextMenu() ， setContextMenu(ContextMenu)

      • setContextMenu

        public final void setContextMenu​(ContextMenu value)
        设置属性contextMenu的值。
        Property description:
        为此控件显示的ContextMenu。

      • getContextMenu

        public final ContextMenu getContextMenu​()
        获取属性contextMenu的值。
        Property description:
        为此控件显示的ContextMenu。

      • isResizable

        public boolean isResizable​()
        返回 true因为所有控件都可调整大小。
        重写：
        isResizable在 Region
        结果
        该布局期间该节点是否可以由其父节点调整大小
        另请参见：
        Node.getContentBias() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double) ，
Node.resize(double, double) ，
Node.getLayoutBounds()

      • computeMinWidth

        protected double computeMinWidth​(double height)
        根据提供的高度计算控件的最小允许宽度。 的最小宽度没有在控制内计算，而不是计算被委托给Node.minWidth(double)所述的方法Skin 。 如果皮肤为空，则返回的值为0。
        重写：
        computeMinWidth在 Region
        参数
        height - 控件的高度，以防该值可能决定最小宽度。
        结果
        表示此控件的最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width)
        根据提供的宽度计算控制的最小允许高度。 最小高度没有在控制内计算，而不是计算被委托给Node.minHeight(double)所述的方法Skin 。 如果皮肤为空，则返回的值为0。
        重写：
        computeMinHeight中的 Region
        参数
        width - 控件的宽度，以防该值可能决定最小高度。
        结果
        双重表示该控件的最小高度。

      • computeMaxWidth

        protected double computeMaxWidth​(double height)
        根据提供的高度计算控件的最大允许宽度。 最大宽度没有在控制内计算，而不是计算被委托给Node.maxWidth(double)所述的方法Skin 。 如果皮肤为空，则返回的值为0。
        重写：
        computeMaxWidth在 Region
        参数
        height - 控件的高度，以防该值可能指定最大宽度。
        结果
        表示此控件的最大宽度的double。

      • computeMaxHeight

        protected double computeMaxHeight​(double width)
        根据提供的宽度计算控制的最大允许高度。 最大高度没有在控制内计算，而不是计算被委托给Node.maxHeight(double)所述的方法Skin 。 如果皮肤为空，则返回的值为0。
        重写：
        computeMaxHeight在 Region
        参数
        width - 控件的宽度，以防该值可能决定最大高度。
        结果
        双重表示此控件的最大高度。

      • computePrefWidth

        protected double computePrefWidth​(double height)
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果首选高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • getBaselineOffset

        public double getBaselineOffset​()
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        getBaselineOffset在 Parent
        结果
        基线偏移

      • layoutChildren

        protected void layoutChildren​()
        在布局传递期间调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren Parent

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。
        从以下版本开始：
        JavaFX 8.0

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public final List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        此方法返回List包含所有CssMetaData两个这种控制（从返回getControlCssMetaData()及其Skin ，假设skin property为SkinBase 。

        因此，希望提供自定义CssMetaData的开发人员被鼓励覆盖getControlCssMetaData()或SkinBase.getCssMetaData() ，具体取决于CssMetaData所在的位置。

        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        protected List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 默认情况下，所有UI控件都是可遍历的，所以在Control中覆盖此方法，以将初始可遍历状态设置为true。
        重写：
        getInitialFocusTraversable在 Node
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Parent
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Node
        参数
        action - 执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CustomMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class CustomMenuItem

  • java.lang.Object
    • javafx.scene.control.MenuItem
      • javafx.scene.control.CustomMenuItem
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    SeparatorMenuItem

    public class CustomMenuItem
extends MenuItem

    A MenuItem允许通过为content属性分配一个Node来嵌入任意节点。 CustomMenuItem尝试使任意节点在菜单中显得更自然。 例如，当用户将鼠标悬停在节点上（或使用键盘或其他替代方法导航到它）时，您会自动将悬停高亮显示。

    这个类的一个有用的属性是hideOnClick 。 此布尔值指定用户在CustomMenuItem的范围内单击时是否自动隐藏CustomMenuItem。 当CustomMenuItem中的节点是需要用户交互的控件时，这一点特别有用，因为将hideOnClick属性设置为false意味着用户可以在没有菜单隐藏的情况下与其进行交互。 请注意，默认情况下，hideOnClick为true。

    如何使用CustomMenuItem的示例如下所示。

       CustomMenuItem customMenuItem = new CustomMenuItem(new Slider()); customMenuItem.setHideOnClick(false);

    如果此CustomMenuItem与其中的Slider一起放置在菜单中，则会在菜单可见时以水平居中的滑块显示，并且与滑块进行交互不会导致菜单消失。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MenuItem ， Menu

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Node> content
      在此CustomMenuItem中显示的节点。
      BooleanProperty hideOnClick
      如果为真，则在单击此菜单项时，将隐藏此菜单项和所有可见菜单。

      • Properties inherited from class javafx.scene.control.MenuItem

        accelerator, disable, graphic, id, mnemonicParsing, onAction, onMenuValidation, parentMenu, parentPopup, style, text, visible

    • Field Summary

      • Fields inherited from class javafx.scene.control.MenuItem

        MENU_VALIDATION_EVENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      CustomMenuItem​()
      创建默认的CustomMenuItem实例。
      CustomMenuItem​(Node node)
      构造一个CustomMenuItem并使用指定的节点初始化其内容。
      CustomMenuItem​(Node node, boolean hideOnClick)
      构造一个CustomMenuItem并将内容设置为指定的节点。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Node> contentProperty​()
      在此CustomMenuItem中显示的节点。
      Node getContent​()
      获取属性内容的值。
      BooleanProperty hideOnClickProperty​()
      如果为真，则在单击此菜单项时，将隐藏此菜单项和所有可见菜单。
      boolean isHideOnClick​()
      获取属性hideOnClick的值。
      void setContent​(Node value)
      设置属性内容的值。
      void setHideOnClick​(boolean value)
      设置属性hideOnClick的值。

      • Methods inherited from class javafx.scene.control.MenuItem

        acceleratorProperty, addEventHandler, buildEventDispatchChain, disableProperty, fire, getAccelerator, getCssMetaData, getGraphic, getId, getOnAction, getOnMenuValidation, getParentMenu, getParentPopup, getProperties, getPseudoClassStates, getStyle, getStyleableNode, getStyleableParent, getStyleClass, getText, getTypeSelector, getUserData, graphicProperty, idProperty, isDisable, isMnemonicParsing, isVisible, mnemonicParsingProperty, onActionProperty, onMenuValidationProperty, parentMenuProperty, parentPopupProperty, removeEventHandler, setAccelerator, setDisable, setGraphic, setId, setMnemonicParsing, setOnAction, setOnMenuValidation, setParentMenu, setParentPopup, setStyle, setText, setUserData, setVisible, styleProperty, textProperty, toString, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • content

        public final ObjectProperty<Node> contentProperty
        在此CustomMenuItem中显示的节点。
        另请参见：
        getContent() ， setContent(Node)

      • hideOnClick

        public final BooleanProperty hideOnClickProperty
        如果为真，则在单击此菜单项时，将隐藏此菜单项和所有可见菜单。
        Default value:
        真正
        另请参见：
        isHideOnClick() ， setHideOnClick(boolean)

    • 构造方法详细信息

      • CustomMenuItem

        public CustomMenuItem​()
        创建默认的CustomMenuItem实例。

      • CustomMenuItem

        public CustomMenuItem​(Node node)
        构造一个CustomMenuItem并使用指定的节点初始化其内容。
        参数
        node - 嵌入在此CustomMenuItem内

      • CustomMenuItem

        public CustomMenuItem​(Node node,
                      boolean hideOnClick)
        构造一个CustomMenuItem并将内容设置为指定的节点。
        参数
        node - 嵌入到此CustomMenuItem中
        hideOnClick - 如果为false，当用户与节点交互时，菜单将不会隐藏。

    • 方法详细信息

      • setContent

        public final void setContent​(Node value)
        设置属性内容的值。
        Property description:
        在此CustomMenuItem中显示的节点。

      • getContent

        public final Node getContent​()
        获取属性内容的值。
        Property description:
        在此CustomMenuItem中显示的节点。

      • contentProperty

        public final ObjectProperty<Node> contentProperty​()
        在此CustomMenuItem中显示的节点。
        另请参见：
        getContent() ， setContent(Node)

      • setHideOnClick

        public final void setHideOnClick​(boolean value)
        设置属性hideOnClick的值。
        Property description:
        如果为真，则在单击此菜单项时，将隐藏此菜单项和所有可见菜单。
        Default value:
        真正

      • isHideOnClick

        public final boolean isHideOnClick​()
        获取属性hideOnClick的值。
        Property description:
        如果为真，则在单击此菜单项时，将隐藏此菜单项和所有可见菜单。
        Default value:
        真正

      • hideOnClickProperty

        public final BooleanProperty hideOnClickProperty​()
        如果为真，则在单击此菜单项时，将隐藏此菜单项和所有可见菜单。
        Default value:
        真正
        另请参见：
        isHideOnClick() ， setHideOnClick(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DateCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class DateCell

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<LocalDate>
                • javafx.scene.control.DateCell
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class DateCell
extends Cell<LocalDate>
    DateCell由DatePicker用于在日历月中呈现单个网格单元格。 通过提供dayCellFactory ，应用程序可以提供更新方法来更改每个单元格的属性，如文本，背景颜色等。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      DateCell​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void updateItem​(LocalDate item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        cancelEdit, commitEdit, editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, startEdit, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • DateCell

        public DateCell​()

    • 方法详细信息

      • updateItem

        public void updateItem​(LocalDate item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了弄清楚，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，比如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<LocalDate>
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DatePicker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class DatePicker

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ComboBoxBase<LocalDate>
              • javafx.scene.control.DatePicker
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class DatePicker
extends ComboBoxBase<LocalDate>
    DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。 该日历基于标准ISO-8601年表或java.time.chrono包中定义的任何其他年表类。

    value属性表示当前选定的LocalDate 。 初始日期可以通过constructor或致电setValue(LocalDate)进行设置。 默认值为null。

       final DatePicker datePicker = new DatePicker(); datePicker.setOnAction(new EventHandler() { public void handle(Event t) { LocalDate date = datePicker.getValue(); System.err.println("Selected date: " + date); } });
    chronology属性指定用于解析，显示和选择日期的日历系统。 value属性始终在ISO日历系统中定义，因此，基于不同年表的应用程序可能会使用Chronology API中提供的转换方法来获取或设置相应的ChronoLocalDate值。 例如：
       LocalDate isoDate = datePicker.getValue(); ChronoLocalDate chronoDate = ((isoDate != null) ? datePicker.getChronology().date(isoDate) : null); System.err.println("Selected date: " + chronoDate);
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Chronology> chronology
      用于在DatePicker控件中解析，显示和选择日期的日历系统。
      ObjectProperty<StringConverter<LocalDate>> converter
      将输入文本转换为类型为LocalDate的对象，反之亦然。
      ObjectProperty<Callback<DatePicker,DateCell>> dayCellFactory
      可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。
      ReadOnlyObjectProperty<TextField> editor
      DatePicker的编辑器。
      BooleanProperty showWeekNumbers
      DatePicker弹出窗口是否应显示显示周数的列。

      • Properties inherited from class javafx.scene.control.ComboBoxBase

        armed, editable, onAction, onHidden, onHiding, onShowing, onShown, promptText, showing, value

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.control.ComboBoxBase

        ON_HIDDEN, ON_HIDING, ON_SHOWING, ON_SHOWN

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      DatePicker​()
      创建一个默认的DatePicker实例，其日期值为 null 。
      DatePicker​(LocalDate localDate)
      创建一个DatePicker实例，并将 value设置为给定的日期。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Chronology> chronologyProperty​()
      用于在DatePicker控件中解析，显示和选择日期的日历系统。
      ObjectProperty<StringConverter<LocalDate>> converterProperty​()
      将输入文本转换为类型为LocalDate的对象，反之亦然。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      ObjectProperty<Callback<DatePicker,DateCell>> dayCellFactoryProperty​()
      可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。
      ReadOnlyObjectProperty<TextField> editorProperty​()
      DatePicker的编辑器。
      Chronology getChronology​()
      获取物业年表的价值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      StringConverter<LocalDate> getConverter​()
      获取属性转换器的值。
      Callback<DatePicker,DateCell> getDayCellFactory​()
      获取属性dayCellFactory的值。
      TextField getEditor​()
      获取属性编辑器的值。
      boolean isShowWeekNumbers​()
      获取属性showWeekNumbers的值。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setChronology​(Chronology value)
      设置属性年表的值。
      void setConverter​(StringConverter<LocalDate> value)
      设置属性转换器的值。
      void setDayCellFactory​(Callback<DatePicker,DateCell> value)
      设置属性dayCellFactory的值。
      void setShowWeekNumbers​(boolean value)
      设置属性showWeekNumbers的值。
      BooleanProperty showWeekNumbersProperty​()
      DatePicker弹出窗口是否应显示显示周数的列。

      • Methods inherited from class javafx.scene.control.ComboBoxBase

        arm, armedProperty, disarm, editableProperty, executeAccessibleAction, getOnAction, getOnHidden, getOnHiding, getOnShowing, getOnShown, getPromptText, getValue, hide, isArmed, isEditable, isShowing, onActionProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, promptTextProperty, setEditable, setOnAction, setOnHidden, setOnHiding, setOnShowing, setOnShown, setPromptText, setValue, show, showingProperty, valueProperty

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • dayCellFactory

        public final ObjectProperty<Callback<DatePicker,DateCell>> dayCellFactoryProperty
        可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。 有关电池工厂的更多信息，请参阅DateCell和Cell 。 例：
           final Callback<DatePicker, DateCell> dayCellFactory = new Callback<DatePicker, DateCell>() { public DateCell call(final DatePicker datePicker) { return new DateCell() { @Override public void updateItem(LocalDate item, boolean empty) { super.updateItem(item, empty); if (MonthDay.from(item).equals(MonthDay.of(9, 25))) { setTooltip(new Tooltip("Happy Birthday!")); setStyle("-fx-background-color: #ff4444;"); } if (item.equals(LocalDate.now().plusDays(1))) { // Tomorrow is too soon. setDisable(true); } } }; } }; datePicker.setDayCellFactory(dayCellFactory);
        Default value:
        空值
        另请参见：
        getDayCellFactory() ， setDayCellFactory(Callback)

      • chronology

        public final ObjectProperty<Chronology> chronologyProperty
        用于在DatePicker控件中解析，显示和选择日期的日历系统。

        默认值从调用返回到Chronology.ofLocale(Locale.getDefault(Locale.Category.FORMAT)) 。 默认值通常为IsoChronology，除非通过使用区域设置日历扩展名在Locale中明确提供。 将值设置为null将恢复默认年表。

        另请参见：
        getChronology() ， setChronology(Chronology)

      • showWeekNumbers

        public final BooleanProperty showWeekNumbersProperty
        DatePicker弹出窗口是否应显示显示周数的列。

        默认值在资源束中指定，并且取决于当前语言环境的国家/地区。

        另请参见：
        isShowWeekNumbers() ， setShowWeekNumbers(boolean)

      • converter

        public final ObjectProperty<StringConverter<LocalDate>> converterProperty
        将输入文本转换为类型为LocalDate的对象，反之亦然。

        如果没有由应用程序设置，DatePicker皮肤类将基于Locale和chronology的DateTimeFormatter设置转换器。 然后，此格式化程序用于解析和显示当前日期值。 将值设置为null将恢复默认转换器。

        使用显式格式化程序的示例：

           datePicker.setConverter(new StringConverter<LocalDate>() { String pattern = "yyyy-MM-dd"; DateTimeFormatter dateFormatter = DateTimeFormatter.ofPattern(pattern); { datePicker.setPromptText(pattern.toLowerCase()); } @Override public String toString(LocalDate date) { if (date != null) { return dateFormatter.format(date); } else { return ""; } } @Override public LocalDate fromString(String string) { if (string != null && !string.isEmpty()) { return LocalDate.parse(string, dateFormatter); } else { return null; } } });

        包装默认格式化程序并捕获解析异常的示例：

           final StringConverter<LocalDate> defaultConverter = datePicker.getConverter(); datePicker.setConverter(new StringConverter<LocalDate>() { @Override public String toString(LocalDate value) { return defaultConverter.toString(value); } @Override public LocalDate fromString(String text) { try { return defaultConverter.fromString(text); } catch (DateTimeParseException ex) { System.err.println("HelloDatePicker: "+ex.getMessage()); throw ex; } } });

        解析输入的默认基准年仅包含两年的数字为2000（见DateTimeFormatter ）。 此默认对于允许输入人的出生日期无效。 以下示例将转换器的fromString（）方法修改为允许两位数的年份为过去99年的出生日期。

           @Override public LocalDate fromString(String text) { if (text != null && !text.isEmpty()) { Locale locale = Locale.getDefault(Locale.Category.FORMAT); Chronology chrono = datePicker.getChronology(); String pattern = DateTimeFormatterBuilder.getLocalizedDateTimePattern(FormatStyle.SHORT, null, chrono, locale); String prePattern = pattern.substring(0, pattern.indexOf("y")); String postPattern = pattern.substring(pattern.lastIndexOf("y")+1); int baseYear = LocalDate.now().getYear() - 99; DateTimeFormatter df = new DateTimeFormatterBuilder() .parseLenient() .appendPattern(prePattern) .appendValueReduced(ChronoField.YEAR, 2, 2, baseYear) .appendPattern(postPattern) .toFormatter(); return LocalDate.from(chrono.date(df.parse(text))); } else { return null; } }
        另请参见：
        getConverter() ， setConverter(StringConverter)

      • editor

        public final ReadOnlyObjectProperty<TextField> editorProperty
        DatePicker的编辑器。
        另请参见：
        getEditor()

    • 构造方法详细信息

      • DatePicker

        public DatePicker​()
        创建一个默认的DatePicker实例，具有 null日期值集。

      • DatePicker

        public DatePicker​(LocalDate localDate)
        创建一个DatePicker实例，并将 value设置为给定日期。
        参数
        localDate - 被设置为DatePicker当前选定的日期。 可以为null。

    • 方法详细信息

      • setDayCellFactory

        public final void setDayCellFactory​(Callback<DatePicker,DateCell> value)
        设置属性dayCellFactory的值。
        Property description:
        可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。 有关电池工厂的更多信息，请参阅DateCell和Cell 。 例：
           final Callback<DatePicker, DateCell> dayCellFactory = new Callback<DatePicker, DateCell>() { public DateCell call(final DatePicker datePicker) { return new DateCell() { @Override public void updateItem(LocalDate item, boolean empty) { super.updateItem(item, empty); if (MonthDay.from(item).equals(MonthDay.of(9, 25))) { setTooltip(new Tooltip("Happy Birthday!")); setStyle("-fx-background-color: #ff4444;"); } if (item.equals(LocalDate.now().plusDays(1))) { // Tomorrow is too soon. setDisable(true); } } }; } }; datePicker.setDayCellFactory(dayCellFactory);
        Default value:
        空值

      • getDayCellFactory

        public final Callback<DatePicker,DateCell> getDayCellFactory​()
        获取属性dayCellFactory的值。
        Property description:
        可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。 有关电池工厂的更多信息，请参阅DateCell和Cell 。 例：
           final Callback<DatePicker, DateCell> dayCellFactory = new Callback<DatePicker, DateCell>() { public DateCell call(final DatePicker datePicker) { return new DateCell() { @Override public void updateItem(LocalDate item, boolean empty) { super.updateItem(item, empty); if (MonthDay.from(item).equals(MonthDay.of(9, 25))) { setTooltip(new Tooltip("Happy Birthday!")); setStyle("-fx-background-color: #ff4444;"); } if (item.equals(LocalDate.now().plusDays(1))) { // Tomorrow is too soon. setDisable(true); } } }; } }; datePicker.setDayCellFactory(dayCellFactory);
        Default value:
        空值

      • dayCellFactoryProperty

        public final ObjectProperty<Callback<DatePicker,DateCell>> dayCellFactoryProperty​()
        可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。 有关电池工厂的更多信息，请参阅DateCell和Cell 。 例：
           final Callback<DatePicker, DateCell> dayCellFactory = new Callback<DatePicker, DateCell>() { public DateCell call(final DatePicker datePicker) { return new DateCell() { @Override public void updateItem(LocalDate item, boolean empty) { super.updateItem(item, empty); if (MonthDay.from(item).equals(MonthDay.of(9, 25))) { setTooltip(new Tooltip("Happy Birthday!")); setStyle("-fx-background-color: #ff4444;"); } if (item.equals(LocalDate.now().plusDays(1))) { // Tomorrow is too soon. setDisable(true); } } }; } }; datePicker.setDayCellFactory(dayCellFactory);
        Default value:
        空值
        另请参见：
        getDayCellFactory() ， setDayCellFactory(Callback)

      • chronologyProperty

        public final ObjectProperty<Chronology> chronologyProperty​()
        用于在DatePicker控件中解析，显示和选择日期的日历系统。

        默认值从调用返回到Chronology.ofLocale(Locale.getDefault(Locale.Category.FORMAT)) 。 默认值通常为IsoChronology，除非通过使用区域设置日历扩展名在Locale中明确提供。 将值设置为null将恢复默认年表。

        另请参见：
        getChronology() ， setChronology(Chronology)

      • getChronology

        public final Chronology getChronology​()
        获取物业年表的价值。
        Property description:
        用于在DatePicker控件中解析，显示和选择日期的日历系统。

        默认值从调用返回到Chronology.ofLocale(Locale.getDefault(Locale.Category.FORMAT)) 。 默认值通常为IsoChronology，除非通过使用区域设置日历扩展名在Locale中明确提供。 将值设置为null将恢复默认年表。

      • setChronology

        public final void setChronology​(Chronology value)
        设置属性年表的值。
        Property description:
        用于在DatePicker控件中解析，显示和选择日期的日历系统。

        从调用Chronology.ofLocale(Locale.getDefault(Locale.Category.FORMAT))返回默认值。 默认值通常为IsoChronology，除非通过使用区域设置日历扩展名在Locale中明确提供。 将值设置为null将恢复默认年表。

      • showWeekNumbersProperty

        public final BooleanProperty showWeekNumbersProperty​()
        DatePicker弹出窗口是否应显示显示周数的列。

        默认值在资源束中指定，并且取决于当前语言环境的国家/地区。

        另请参见：
        isShowWeekNumbers() ， setShowWeekNumbers(boolean)

      • setShowWeekNumbers

        public final void setShowWeekNumbers​(boolean value)
        设置属性showWeekNumbers的值。
        Property description:
        DatePicker弹出窗口是否应显示显示周数的列。

        默认值在资源束中指定，并且取决于当前语言环境的国家/地区。

      • isShowWeekNumbers

        public final boolean isShowWeekNumbers​()
        获取属性showWeekNumbers的值。
        Property description:
        DatePicker弹出窗口是否应显示显示周数的列。

        默认值在资源束中指定，并且取决于当前语言环境的国家/地区。

      • converterProperty

        public final ObjectProperty<StringConverter<LocalDate>> converterProperty​()
        将输入文本转换为类型为LocalDate的对象，反之亦然。

        如果没有由应用程序设置，DatePicker皮肤类将基于Locale和chronology的DateTimeFormatter设置转换器。 然后，此格式化程序用于解析和显示当前日期值。 将值设置为null将恢复默认转换器。

        使用显式格式化程序的示例：

           datePicker.setConverter(new StringConverter<LocalDate>() { String pattern = "yyyy-MM-dd"; DateTimeFormatter dateFormatter = DateTimeFormatter.ofPattern(pattern); { datePicker.setPromptText(pattern.toLowerCase()); } @Override public String toString(LocalDate date) { if (date != null) { return dateFormatter.format(date); } else { return ""; } } @Override public LocalDate fromString(String string) { if (string != null && !string.isEmpty()) { return LocalDate.parse(string, dateFormatter); } else { return null; } } });

        包装默认格式化程序并捕获解析异常的示例：

           final StringConverter<LocalDate> defaultConverter = datePicker.getConverter(); datePicker.setConverter(new StringConverter<LocalDate>() { @Override public String toString(LocalDate value) { return defaultConverter.toString(value); } @Override public LocalDate fromString(String text) { try { return defaultConverter.fromString(text); } catch (DateTimeParseException ex) { System.err.println("HelloDatePicker: "+ex.getMessage()); throw ex; } } });

        解析输入的默认基准年仅包含两年的数字为2000（见DateTimeFormatter ）。 此默认对于允许输入人的出生日期无效。 以下示例将转换器的fromString（）方法修改为允许两位数的年份为过去99年的出生日期。

           @Override public LocalDate fromString(String text) { if (text != null && !text.isEmpty()) { Locale locale = Locale.getDefault(Locale.Category.FORMAT); Chronology chrono = datePicker.getChronology(); String pattern = DateTimeFormatterBuilder.getLocalizedDateTimePattern(FormatStyle.SHORT, null, chrono, locale); String prePattern = pattern.substring(0, pattern.indexOf("y")); String postPattern = pattern.substring(pattern.lastIndexOf("y")+1); int baseYear = LocalDate.now().getYear() - 99; DateTimeFormatter df = new DateTimeFormatterBuilder() .parseLenient() .appendPattern(prePattern) .appendValueReduced(ChronoField.YEAR, 2, 2, baseYear) .appendPattern(postPattern) .toFormatter(); return LocalDate.from(chrono.date(df.parse(text))); } else { return null; } }
        另请参见：
        getConverter() ， setConverter(StringConverter)

      • setConverter

        public final void setConverter​(StringConverter<LocalDate> value)
        设置属性转换器的值。
        Property description:
        将输入文本转换为类型为LocalDate的对象，反之亦然。

        如果没有由应用程序设置，DatePicker皮肤类将根据当前的Locale和chronology的DateTimeFormatter设置一个转换器。 然后，此格式化程序用于解析和显示当前日期值。 将值设置为null将恢复默认转换器。

        使用显式格式化程序的示例：

           datePicker.setConverter(new StringConverter<LocalDate>() { String pattern = "yyyy-MM-dd"; DateTimeFormatter dateFormatter = DateTimeFormatter.ofPattern(pattern); { datePicker.setPromptText(pattern.toLowerCase()); } @Override public String toString(LocalDate date) { if (date != null) { return dateFormatter.format(date); } else { return ""; } } @Override public LocalDate fromString(String string) { if (string != null && !string.isEmpty()) { return LocalDate.parse(string, dateFormatter); } else { return null; } } });

        包装默认格式化程序并捕获解析异常的示例：

           final StringConverter<LocalDate> defaultConverter = datePicker.getConverter(); datePicker.setConverter(new StringConverter<LocalDate>() { @Override public String toString(LocalDate value) { return defaultConverter.toString(value); } @Override public LocalDate fromString(String text) { try { return defaultConverter.fromString(text); } catch (DateTimeParseException ex) { System.err.println("HelloDatePicker: "+ex.getMessage()); throw ex; } } });

        解析输入的默认基准年仅包含两位数字，为2000（见DateTimeFormatter ）。 此默认对于允许输入人的出生日期无效。 以下示例将转换器的fromString（）方法修改为允许两位数的年份为过去99年的出生日期。

           @Override public LocalDate fromString(String text) { if (text != null && !text.isEmpty()) { Locale locale = Locale.getDefault(Locale.Category.FORMAT); Chronology chrono = datePicker.getChronology(); String pattern = DateTimeFormatterBuilder.getLocalizedDateTimePattern(FormatStyle.SHORT, null, chrono, locale); String prePattern = pattern.substring(0, pattern.indexOf("y")); String postPattern = pattern.substring(pattern.lastIndexOf("y")+1); int baseYear = LocalDate.now().getYear() - 99; DateTimeFormatter df = new DateTimeFormatterBuilder() .parseLenient() .appendPattern(prePattern) .appendValueReduced(ChronoField.YEAR, 2, 2, baseYear) .appendPattern(postPattern) .toFormatter(); return LocalDate.from(chrono.date(df.parse(text))); } else { return null; } }

      • getConverter

        public final StringConverter<LocalDate> getConverter​()
        获取属性转换器的值。
        Property description:
        将输入文本转换为类型为LocalDate的对象，反之亦然。

        如果没有由应用程序设置，DatePicker皮肤类将根据当前的Locale和chronology的DateTimeFormatter设置一个转换器。 然后，此格式化程序用于解析和显示当前日期值。 将值设置为null将恢复默认转换器。

        使用显式格式化程序的示例：

           datePicker.setConverter(new StringConverter<LocalDate>() { String pattern = "yyyy-MM-dd"; DateTimeFormatter dateFormatter = DateTimeFormatter.ofPattern(pattern); { datePicker.setPromptText(pattern.toLowerCase()); } @Override public String toString(LocalDate date) { if (date != null) { return dateFormatter.format(date); } else { return ""; } } @Override public LocalDate fromString(String string) { if (string != null && !string.isEmpty()) { return LocalDate.parse(string, dateFormatter); } else { return null; } } });

        包装默认格式化程序并捕获解析异常的示例：

           final StringConverter<LocalDate> defaultConverter = datePicker.getConverter(); datePicker.setConverter(new StringConverter<LocalDate>() { @Override public String toString(LocalDate value) { return defaultConverter.toString(value); } @Override public LocalDate fromString(String text) { try { return defaultConverter.fromString(text); } catch (DateTimeParseException ex) { System.err.println("HelloDatePicker: "+ex.getMessage()); throw ex; } } });

        解析输入的默认基准年仅包含两年的数字为2000（见DateTimeFormatter ）。 此默认对于允许输入人的出生日期无效。 以下示例将转换器的fromString（）方法修改为允许两位数的年份为过去99年的出生日期。

           @Override public LocalDate fromString(String text) { if (text != null && !text.isEmpty()) { Locale locale = Locale.getDefault(Locale.Category.FORMAT); Chronology chrono = datePicker.getChronology(); String pattern = DateTimeFormatterBuilder.getLocalizedDateTimePattern(FormatStyle.SHORT, null, chrono, locale); String prePattern = pattern.substring(0, pattern.indexOf("y")); String postPattern = pattern.substring(pattern.lastIndexOf("y")+1); int baseYear = LocalDate.now().getYear() - 99; DateTimeFormatter df = new DateTimeFormatterBuilder() .parseLenient() .appendPattern(prePattern) .appendValueReduced(ChronoField.YEAR, 2, 2, baseYear) .appendPattern(postPattern) .toFormatter(); return LocalDate.from(chrono.date(df.parse(text))); } else { return null; } }

      • getEditor

        public final TextField getEditor​()
        获取属性编辑器的值。
        Property description:
        DatePicker的编辑器。

      • editorProperty

        public final ReadOnlyObjectProperty<TextField> editorProperty​()
        DatePicker的编辑器。
        另请参见：
        getEditor()

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用它来创建控件的皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 ComboBoxBase<LocalDate>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Dialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Dialog<R>

  • java.lang.Object
    • javafx.scene.control.Dialog<R>
  • 参数类型
    R - 对话框的返回类型，通过 result属性。
    All Implemented Interfaces:
    EventTarget
    已知直接子类：
    Alert ， ChoiceDialog ， TextInputDialog

    public class Dialog<R>
extends Object
implements EventTarget
    JavaFX中的Dialog包装了一个DialogPane，并提供了必要的API来将其呈现给最终用户。 在JavaFX 8u40中，这基本上意味着DialogPane向用户显示了一个Stage ，但将来的版本可能会提供其他选项（如“轻量级”或“内部”对话框）。 因此，此API故意无知底层实现，并尝试为所有可能的实现呈现一个通用API。

    Dialog类有一个通用类型R，用于表示result属性的类型（以及如何通过使用result converter Callback从ButtonType转换为R）。

    重要注意事项：通过扩展Dialog类了解result converter属性的重要性，所有选择创建自己对话框的开发人员至关重要。 每当R型不是Void或ButtonType时，必须始终设置结果转换器。 如果不加注意，开发者会发现，他们得到的ClassCastExceptions在他们的代码，未能从转换ButtonType通过result converter 。

    大多数开发人员可能会使用Alert类（用于预定义的通知类型的警报）或两个预构建的对话框（ TextInputDialog和ChoiceDialog ）中的任何一个，取决于他们的需要。

    一旦对话框被实例化，下一步是配置它。 几乎在所有对话属性不相关的对话框的内容，唯一的例外是contentTextProperty() ， headerTextProperty() ，并graphicProperty() ，这些性质简单地转发到API的各种特性DialogPane存储在dialog pane财产。 这三个属性从DialogPane转发，以便开发人员方便。 对于想要配置对话框的开发人员，在许多情况下，需要使用符合dialog.getDialogPane().setExpandableContent(node)代码。

    配置这些属性后，所有这些属性都是考虑是否完全配置按钮（使用ButtonType和DialogPane.createButton(ButtonType)创建）。 开发人员将很快发现通过ButtonType类提供的可配置性的数量很少。 这是有意的，但并不意味着开发人员不能修改由指定的ButtonType创建的按钮。 为此，开发人员只需使用ButtonType调用DialogPane.lookupButton(ButtonType)方法（假设它已经在DialogPane.getButtonTypes()列表中设置），返回的节点通常是Button类型，但这取决于是否已经覆盖了DialogPane.createButton(ButtonType)方法。所以按照以下几点：

      ButtonType loginButtonType = new ButtonType("Login", ButtonData.OK_DONE); Dialog<String> dialog = new Dialog<>(); dialog.getDialogPane().getButtonTypes().add(loginButtonType); boolean disabled = false; // computed based on content of text fields, for example dialog.getDialogPane().lookupButton(loginButtonType).setDisable(disabled);

    一旦对话框被实例化和完全配置，下一步就是显示它。 通常情况下，对话框以模态和阻止的方式显示。 'Modal'意味着该对话框可以防止用户在显示时与所拥有的应用程序进行交互，而'blocking'意味着代码执行在显示对话框的时候停止。 这意味着您可以显示一个对话框，等待用户响应，然后继续运行直接在show调用之后的代码，使开发人员能够立即处理来自对话框的用户输入（如果相关）。

    默认情况下，JavaFX对话框是模态的（您可以通过initModality(javafx.stage.Modality) API更改此对话框 ）。 要指定是否要阻止或不阻止对话框，开发人员只需选择分别调用showAndWait()或show() 。 默认情况下，大多数开发人员应该选择使用showAndWait() ，因为在这些情况下易于编码。 下面显示了三个代码片段，显示了三个显示对话框的同样有效的方法：

    选项1：“传统”方法

      Optional<ButtonType> result = dialog.showAndWait(); if (result.isPresent() && result.get() == ButtonType.OK) { formatSystem(); }

    选项2：传统+可选方法

      dialog.showAndWait().ifPresent(response -> { if (response == ButtonType.OK) { formatSystem(); } });

    选项3：完全lambda方法

      dialog.showAndWait() .filter(response -> response == ButtonType.OK) .ifPresent(response -> formatSystem());

    上面列出的三个选项没有更好或更差的选择，所以鼓励开发人员自己设计风格偏好。 显示上述内容的目的是帮助开发人员将其引入到Optional API中，这是Java 8中的新增功能，可能对许多开发人员来说是外来的。

    对话验证/拦截按钮操作

    在某些情况下，希望防止对话框关闭，直到对话框的某些方面变得内部一致（例如，对话框内的表单具有有效状态的所有字段）。 为此，对话框API的用户应该熟悉DialogPane.lookupButton(ButtonType)方法。 通过传递ButtonType （已经在button types列表中设置），用户将返回一个通常为Button类型的节点 （但这取决于DialogPane.createButton(ButtonType)方法是否被覆盖）。 使用此按钮，用户可以添加在按钮执行其常规事件处理之前调用的事件过滤器，因此用户可以防止事件处理consuming 。 这是一个简化的例子：

      final Button btOk = (Button) dlg.getDialogPane().lookupButton(ButtonType.OK); btOk.addEventFilter(ActionEvent.ACTION, event -> { if (!validateAndStore()) { event.consume(); } });

    对话框关闭规则

    重要的是要了解当对话框关闭时会发生什么，以及如何关闭对话框，特别是在异常关闭情况下（例如在对话框标题栏中单击“X”按钮时，或操作系统特定键盘时）输入快捷键（如Windows上的alt-F4）。 幸运的是，在这些情况下，结果是明确的，可以在以下几个方面进行总结：

    • JavaFX对话框只能在两种情况下被“异常”（如上定义）关闭：
      1. 当对话框只有一个按钮，或者
      2. 当对话框有多个按钮时，只要其中一个按钮满足以下要求之一：
        1. 该按钮有ButtonType，其ButtonBar.ButtonData是ButtonBar.ButtonData.CANCEL_CLOSE 。
        2. 该按钮有一个ButtonType ，当ButtonBar.ButtonData.isCancelButton()被调用时，其ButtonBar.ButtonData返回true。
    • 在所有其他情况下，对话框将拒绝回复所有关闭请求，保持打开，直到用户单击对话框的DialogPane区域中的可用按钮之一。
    • 如果对话框异常关闭，并且如果对话框包含符合上述两个条件之一的按钮，则对话框将尝试将result属性设置为调用result converter与第一个匹配的值为ButtonType的任何值。
    • 如果由于任何原因，结果转换器返回null，或者如果只有一个非取消按钮存在时对话框关闭，则result属性将为null，而showAndWait()方法将返回Optional.empty() 。 这个稍后的点意味着，如果您使用选项2或选项3（如本类文档中之前所述），则将永远不会调用Optional.ifPresent(java.util.function.Consumer) lambda，代码将继续执行，就好像该对话框根本没有返回任何值。
    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Alert ， TextInputDialog ， ChoiceDialog

    • Property Summary

      Properties
      Type Property 描述
      StringProperty contentText
      表示对话窗格的内容文本的属性。
      ObjectProperty<DialogPane> dialogPane
      对话框的根节点 ， DialogPane包含对话框中显示的所有可视元素。
      ObjectProperty<Node> graphic
      对话图形，在标题中显示，如果显示，或 content的左侧。
      StringProperty headerText
      表示对话框窗格的标题文本的属性。
      ReadOnlyDoubleProperty height
      表示对话框高度的属性。
      ObjectProperty<EventHandler<DialogEvent>> onCloseRequest
      当有外部请求关闭此 Dialog 。
      ObjectProperty<EventHandler<DialogEvent>> onHidden
      Dialog已被隐藏之后调用。
      ObjectProperty<EventHandler<DialogEvent>> onHiding
      在对话框被隐藏之前调用。
      ObjectProperty<EventHandler<DialogEvent>> onShowing
      在对话框显示之前调用。
      ObjectProperty<EventHandler<DialogEvent>> onShown
      在对话框显示之后调用。
      BooleanProperty resizable
      表示对话框是否可调整大小。
      ObjectProperty<Callback<ButtonType,R>> resultConverter
      将用户点击的ButtonType转换为可通过result属性返回的结果的API 。
      ObjectProperty<R> result
      表示从对话框返回的属性的属性。
      ReadOnlyBooleanProperty showing
      表示对话框当前是否显示。
      StringProperty title
      返回对话框的titleProperty。
      ReadOnlyDoubleProperty width
      表示对话框宽度的属性。
      ReadOnlyDoubleProperty x
      这个 Dialog的水平位置。
      ReadOnlyDoubleProperty y
      这个 Dialog的垂直位置。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Dialog​()
      创建一个没有指定所有者的对话框。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      void close​()
      关闭此 Dialog 。
      StringProperty contentTextProperty​()
      表示对话窗格的内容文本的属性。
      ObjectProperty<DialogPane> dialogPaneProperty​()
      对话框的根节点 ， DialogPane包含对话框中显示的所有可视元素。
      String getContentText​()
      返回此DialogPane的当前设置的内容文本。
      DialogPane getDialogPane​()
      获取属性dialogPane的值。
      Node getGraphic​()
      获取属性图形的值。
      String getHeaderText​()
      返回此DialogPane的当前设置的标题文本。
      double getHeight​()
      返回对话框的高度。
      Modality getModality​()
      检索此对话框的模态属性。
      EventHandler<DialogEvent> getOnCloseRequest​()
      获取属性onCloseRequest的值。
      EventHandler<DialogEvent> getOnHidden​()
      获取属性onHidden的值。
      EventHandler<DialogEvent> getOnHiding​()
      获取属性onHiding的值。
      EventHandler<DialogEvent> getOnShowing​()
      获取属性onShowing的值。
      EventHandler<DialogEvent> getOnShown​()
      获取onShown属性的值。
      Window getOwner​()
      检索该对话框的所有者窗口，或者取消未知对话框的null。
      R getResult​()
      获取属性结果的值。
      Callback<ButtonType,R> getResultConverter​()
      获取属性resultConverter的值。
      String getTitle​()
      返回对话框的标题。
      double getWidth​()
      返回对话框的宽度。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      ObjectProperty<Node> graphicProperty​()
      对话图形，在标题中显示，如果显示，或 content的左侧。
      StringProperty headerTextProperty​()
      表示对话框窗格的标题文本的属性。
      ReadOnlyDoubleProperty heightProperty​()
      表示对话框高度的属性。
      void hide​()
      隐藏这个 Dialog 。
      void initModality​(Modality modality)
      指定此对话框的模态。
      void initOwner​(Window window)
      指定该对话框的所有者Window ，或者对于顶级的未知对话框，指定为null。
      void initStyle​(StageStyle style)
      指定此对话框的样式。
      boolean isResizable​()
      返回对话框是否可调整大小。
      boolean isShowing​()
      返回对话框是否显示。
      ObjectProperty<EventHandler<DialogEvent>> onCloseRequestProperty​()
      当有外部请求关闭此 Dialog 。
      ObjectProperty<EventHandler<DialogEvent>> onHiddenProperty​()
      Dialog已被隐藏之后调用。
      ObjectProperty<EventHandler<DialogEvent>> onHidingProperty​()
      在对话框被隐藏之前调用。
      ObjectProperty<EventHandler<DialogEvent>> onShowingProperty​()
      在对话框显示之前调用。
      ObjectProperty<EventHandler<DialogEvent>> onShownProperty​()
      在对话框显示之后调用。
      BooleanProperty resizableProperty​()
      表示对话框是否可调整大小。
      ObjectProperty<Callback<ButtonType,R>> resultConverterProperty​()
      将用户点击的ButtonType转换为可通过result属性返回的结果的API 。
      ObjectProperty<R> resultProperty​()
      表示从对话框返回的属性的属性。
      void setContentText​(String contentText)
      设置在对话框内容区域显示的字符串。
      void setDialogPane​(DialogPane value)
      设置属性dialogPane的值。
      void setGraphic​(Node graphic)
      设置对话图形，将显示在标题中，如果显示，或 content的左侧。
      void setHeaderText​(String headerText)
      设置在对话框头部区域显示的字符串。
      void setHeight​(double height)
      设置对话框的高度。
      void setOnCloseRequest​(EventHandler<DialogEvent> value)
      设置属性onCloseRequest的值。
      void setOnHidden​(EventHandler<DialogEvent> value)
      设置属性onHidden的值。
      void setOnHiding​(EventHandler<DialogEvent> value)
      设置属性onHiding的值。
      void setOnShowing​(EventHandler<DialogEvent> value)
      设置属性onShowing的值。
      void setOnShown​(EventHandler<DialogEvent> value)
      设置属性onShown的值。
      void setResizable​(boolean resizable)
      设置对话框是否可以由用户调整大小。
      void setResult​(R value)
      设置属性结果的值。
      void setResultConverter​(Callback<ButtonType,R> value)
      设置属性resultConverter的值。
      void setTitle​(String title)
      更改对话框的标题。
      void setWidth​(double width)
      设置对话框的宽度。
      void setX​(double x)
      设置属性x的值。
      void setY​(double y)
      设置属性y的值。
      void show​()
      显示对话框，但不等待用户响应（换句话说，这会打开一个非阻塞对话框）。
      Optional<R> showAndWait​()
      显示对话框并等待用户响应（换句话说，显示阻止对话框，用户输入的返回值）。
      ReadOnlyBooleanProperty showingProperty​()
      表示对话框当前是否显示。
      StringProperty titleProperty​()
      返回对话框的titleProperty。
      ReadOnlyDoubleProperty widthProperty​()
      表示对话框宽度的属性。
      ReadOnlyDoubleProperty xProperty​()
      这个 Dialog的水平位置。
      ReadOnlyDoubleProperty yProperty​()
      这个 Dialog的垂直位置。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • dialogPane

        public final ObjectProperty<DialogPane> dialogPaneProperty
        对话框的根节点 ， DialogPane包含对话框中显示的所有可视元素。 因此，可以通过修改现有的对话窗格或创建新的对话框来完全调整对话框的显示。
        另请参见：
        getDialogPane() ， setDialogPane(DialogPane)

      • contentText

        public final StringProperty contentTextProperty
        表示对话窗格的内容文本的属性。 内容文本的优先级低于content node ，这意味着如果内容节点和contentText属性均已设置，内容文本将不会显示在默认的DialogPane实例中。
        另请参见：
        getContentText() ， setContentText(String)

      • headerText

        public final StringProperty headerTextProperty
        表示对话框窗格的标题文本的属性。 标题文本的优先级低于header node ，这意味着如果头节点和headerText属性均已设置，则标题文本将不会显示在默认的DialogPane实例中。
        另请参见：
        getHeaderText() ， setHeaderText(String)

      • graphic

        public final ObjectProperty<Node> graphicProperty
        对话图形，在标题中显示，如果显示，或 content的左侧。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • result

        public final ObjectProperty<R> resultProperty
        表示从对话框返回的属性的属性。 结果是通过result converter生成的，其目的是将用户点击的ButtonType转换为R类型的值。有关更多详细信息，请参阅Dialog类JavaDoc。
        另请参见：
        getResult() ， setResult(R)

      • resultConverter

        public final ObjectProperty<Callback<ButtonType,R>> resultConverterProperty
        将用户点击的ButtonType转换为可通过result属性返回的结果的API 。 这是必需的，因为ButtonType表示对话框中的可视化按钮，并且不知道如何将自己映射到有效的结果 - 这是通过使用结果转换器来实现对话框的要求。 在某些情况下，Dialog子类的结果类型是ButtonType（这意味着结果转换器可以为null），但在某些情况下（结果类型为R，不是ButtonType或Void），则必须指定此回调。
        另请参见：
        getResultConverter() ， setResultConverter(Callback)

      • showing

        public final ReadOnlyBooleanProperty showingProperty
        表示对话框当前是否显示。
        另请参见：
        isShowing()

      • resizable

        public final BooleanProperty resizableProperty
        表示对话框是否可调整大小。
        另请参见：
        isResizable() ， setResizable(boolean)

      • width

        public final ReadOnlyDoubleProperty widthProperty
        表示对话框宽度的属性。
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final ReadOnlyDoubleProperty heightProperty
        表示对话框高度的属性。
        另请参见：
        getHeight() ， setHeight(double)

      • title

        public final StringProperty titleProperty
        返回对话框的titleProperty。
        另请参见：
        getTitle() ， setTitle(String)

      • x

        public final ReadOnlyDoubleProperty xProperty
        这个水平位置这个Dialog 。 更改此属性将水平移动Dialog 。
        另请参见：
        getX() ， setX(double)

      • y

        public final ReadOnlyDoubleProperty yProperty
        这个Dialog的垂直位置。 更改此属性将垂直移动Dialog 。
        另请参见：
        getY() ， setY(double)

      • onShowing

        public final ObjectProperty<EventHandler<DialogEvent>> onShowingProperty
        在对话框显示之前调用。
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • onShown

        public final ObjectProperty<EventHandler<DialogEvent>> onShownProperty
        在对话框显示之后调用。
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • onHiding

        public final ObjectProperty<EventHandler<DialogEvent>> onHidingProperty
        在对话框被隐藏之前调用。
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • onHidden

        public final ObjectProperty<EventHandler<DialogEvent>> onHiddenProperty
        Dialog已被隐藏之后调用。 当隐藏Dialog ，调用此事件处理程序，允许开发人员在Alert关闭时清理资源或执行其他任务。
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

      • onCloseRequest

        public final ObjectProperty<EventHandler<DialogEvent>> onCloseRequestProperty
        当有外部请求关闭此Dialog 。 安装的事件处理程序可以通过消耗接收的事件来阻止对话关闭。
        另请参见：
        getOnCloseRequest() ， setOnCloseRequest(EventHandler)

    • 构造方法详细信息

      • Dialog

        public Dialog​()
        创建一个没有指定所有者的对话框。

    • 方法详细信息

      • show

        public final void show​()
        显示对话框，但不等待用户响应（换句话说，这会打开一个非阻塞对话框）。 该API的用户必须轮询result property ，否则将添加一个监听器到结果属性，以便被通知何时被设置。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。

      • showAndWait

        public final Optional<R> showAndWait​()
        显示对话框并等待用户响应（换句话说，显示阻止对话框，用户输入的返回值）。

        必须在JavaFX应用程序线程上调用此方法。 另外，它必须从输入事件处理程序或从Runnable的run方法调用传递给Platform.runLater 。 在动画或布局处理过程中不得调用它。

        结果
        一个Optional ，其中包含result 。 有关详细信息，请参阅Dialog类文档。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        IllegalStateException - 如果在动画或布局处理期间调用此方法。

      • close

        public final void close​()
        关闭此Dialog 。 此通话相当于hide() 。

      • hide

        public final void hide​()
        隐藏这个 Dialog 。

      • initModality

        public final void initModality​(Modality modality)
        指定此对话框的模态。 这必须在使对话框可见之前完成。 模态是以下之一：Modality.NONE，Modality.WINDOW_MODAL或Modality.APPLICATION_MODAL。
        Default value:
        Modality.APPLICATION_MODAL
        参数
        modality - 此对话框的模式。
        异常
        IllegalStateException - 如果在对话框显示后设置了此属性。

      • getModality

        public final Modality getModality​()
        检索此对话框的模态属性。
        结果
        的模式。

      • initStyle

        public final void initStyle​(StageStyle style)
        指定此对话框的样式。 这必须在使对话框可见之前完成。 风格是以下之一：StageStyle.DECORATED，StageStyle.UNDECORATED，StageStyle.TRANSPARENT，StageStyle.UTILITY或StageStyle.UNIFIED。
        Default value:
        StageStyle.DECORATED
        参数
        style - 此对话框的样式。
        异常
        IllegalStateException - 如果在对话框显示之后设置了此属性。

      • initOwner

        public final void initOwner​(Window window)
        指定此对话框的所有者Window ，或者为顶级的未知对话框指定null。 这必须在使对话框可见之前完成。
        Default value:
        空值
        参数
        window - 该对话框的所有者Window 。
        异常
        IllegalStateException - 如果在对话框显示之后设置了此属性。

      • getOwner

        public final Window getOwner​()
        检索该对话框的所有者窗口，或者取消未知对话框的null。
        结果
        所有者窗口。

      • dialogPaneProperty

        public final ObjectProperty<DialogPane> dialogPaneProperty​()
        对话框的根节点 ， DialogPane包含对话框中显示的所有可视元素。 因此，可以通过修改现有的对话窗格或创建新的对话框来完全调整对话框的显示。
        另请参见：
        getDialogPane() ， setDialogPane(DialogPane)

      • getDialogPane

        public final DialogPane getDialogPane​()
        获取属性dialogPane的值。
        Property description:
        对话框的根节点 ， DialogPane包含对话框中显示的所有可视元素。 因此，可以通过修改现有的对话窗格或创建新的对话框来完全调整对话框的显示。

      • setDialogPane

        public final void setDialogPane​(DialogPane value)
        设置属性dialogPane的值。
        Property description:
        对话框的根节点 ， DialogPane包含对话框中显示的所有可视元素。 因此，可以通过修改现有的对话窗格或创建新的对话框来完全调整对话框的显示。

      • contentTextProperty

        public final StringProperty contentTextProperty​()
        表示对话窗格的内容文本的属性。 内容文本的优先级低于content node ，这意味着如果内容节点和contentText属性均已设置，内容文本将不会显示在默认的DialogPane实例中。
        另请参见：
        getContentText() ， setContentText(String)

      • getContentText

        public final String getContentText​()
        返回此DialogPane的当前设置的内容文本。
        结果
        此DialogPane的当前设置的内容文本

      • setContentText

        public final void setContentText​(String contentText)
        设置在对话框内容区域显示的字符串。 请注意，内容文本的优先级低于content node ，这意味着如果内容节点和contentText属性均已设置，内容文本将不会显示在默认的DialogPane实例中。
        参数
        contentText - 要在对话框内容区域显示的字符串

      • headerTextProperty

        public final StringProperty headerTextProperty​()
        表示对话框窗格的标题文本的属性。 标题文本的优先级低于header node ，这意味着如果头节点和headerText属性均已设置，则头文本将不会显示在默认的DialogPane实例中。
        另请参见：
        getHeaderText() ， setHeaderText(String)

      • getHeaderText

        public final String getHeaderText​()
        返回此DialogPane的当前设置的标题文本。
        结果
        此DialogPane的当前设置的标题文本

      • setHeaderText

        public final void setHeaderText​(String headerText)
        设置在对话框头部区域显示的字符串。 请注意，标题文本的优先级低于header node ，这意味着如果头节点和headerText属性均已设置，则头文本将不会显示在默认的DialogPane实例中。
        参数
        headerText - 要在对话框标题区域显示的字符串

      • graphicProperty

        public final ObjectProperty<Node> graphicProperty​()
        对话图形，在标题中显示，如果显示，或 content的左侧。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • getGraphic

        public final Node getGraphic​()
        获取属性图形的值。
        Property description:
        对话图形，在标题中显示，如果显示，或 content的左侧。

      • setGraphic

        public final void setGraphic​(Node graphic)
        设置对话框图形，将显示在标题中，如果显示，或 content的左侧。
        参数
        graphic - 新的对话框图形，如果不显示图形，则为null。

      • resultProperty

        public final ObjectProperty<R> resultProperty​()
        表示从对话框返回的属性的属性。 结果是通过result converter产生的，其目的是将用户点击的ButtonType转换为R类型的值。有关更多详细信息，请参阅Dialog类JavaDoc。
        另请参见：
        getResult() ， setResult(R)

      • getResult

        public final R getResult​()
        获取属性结果的值。
        Property description:
        表示从对话框返回的属性的属性。 结果是通过result converter生成的，其目的是从用户点击的ButtonType转换为类型R的值。有关更多详细信息，请参阅Dialog类JavaDoc。

      • setResult

        public final void setResult​(R value)
        设置属性结果的值。
        Property description:
        表示从对话框返回的属性的属性。 结果是通过result converter生成的，其目的是将用户点击的ButtonType转换为R类型的值。有关更多详细信息，请参阅Dialog JavaDoc类。

      • resultConverterProperty

        public final ObjectProperty<Callback<ButtonType,R>> resultConverterProperty​()
        API将用户点击的ButtonType转换为可通过result属性返回的结果。 这是必需的，因为ButtonType表示对话框中的可视化按钮，并且不知道如何将自己映射到有效的结果 - 这是通过使用结果转换器来执行对话框的要求。 在某些情况下，Dialog子类的结果类型是ButtonType（这意味着结果转换器可以为null），但在某些情况下（结果类型为R，不是ButtonType或Void），则必须指定此回调。
        另请参见：
        getResultConverter() ， setResultConverter(Callback)

      • getResultConverter

        public final Callback<ButtonType,R> getResultConverter​()
        获取属性resultConverter的值。
        Property description:
        API将用户点击的ButtonType转换为可以通过result属性返回的结果。 这是必要的，因为ButtonType表示对话框中的可视化按钮，并且不知道如何将自己映射到有效的结果 - 这是通过使用结果转换器来执行对话框的要求。 在某些情况下，Dialog子类的结果类型是ButtonType（这意味着结果转换器可以为null），但在某些情况下（结果类型为R，不是ButtonType或Void），则必须指定此回调。

      • setResultConverter

        public final void setResultConverter​(Callback<ButtonType,R> value)
        设置属性resultConverter的值。
        Property description:
        API将用户点击的ButtonType转换为可通过result属性返回的结果。 这是必要的，因为ButtonType表示对话框中的可视化按钮，并且不知道如何将自己映射到有效的结果 - 这是通过使用结果转换器来执行对话框的要求。 在某些情况下，Dialog子类的结果类型是ButtonType（这意味着结果转换器可以为null），但在某些情况下（结果类型为R，不是ButtonType或Void），则必须指定此回调。

      • showingProperty

        public final ReadOnlyBooleanProperty showingProperty​()
        表示对话框当前是否显示。
        另请参见：
        isShowing()

      • isShowing

        public final boolean isShowing​()
        返回对话框是否显示。
        结果
        如果显示对话框，则为true。

      • resizableProperty

        public final BooleanProperty resizableProperty​()
        表示对话框是否可调整大小。
        另请参见：
        isResizable() ， setResizable(boolean)

      • isResizable

        public final boolean isResizable​()
        返回对话框是否可调整大小。
        结果
        如果对话框可调整大小，则为true

      • setResizable

        public final void setResizable​(boolean resizable)
        设置对话框是否可以由用户调整大小。 可调整大小的对话框也可以最大化（最大化按钮变得可见）
        参数
        resizable - 如果对话框可以调整大小， resizable true。

      • widthProperty

        public final ReadOnlyDoubleProperty widthProperty​()
        表示对话框宽度的属性。
        另请参见：
        getWidth() ， setWidth(double)

      • getWidth

        public final double getWidth​()
        返回对话框的宽度。
        结果
        对话框的宽度

      • setWidth

        public final void setWidth​(double width)
        设置对话框的宽度。
        参数
        width - 对话框的宽度

      • heightProperty

        public final ReadOnlyDoubleProperty heightProperty​()
        表示对话框高度的属性。
        另请参见：
        getHeight() ， setHeight(double)

      • getHeight

        public final double getHeight​()
        返回对话框的高度。
        结果
        对话框的高度

      • setHeight

        public final void setHeight​(double height)
        设置对话框的高度。
        参数
        height - 对话框的高度

      • titleProperty

        public final StringProperty titleProperty​()
        返回对话框的titleProperty。
        另请参见：
        getTitle() ， setTitle(String)

      • getTitle

        public final String getTitle​()
        返回对话框的标题。
        结果
        对话框的标题

      • setTitle

        public final void setTitle​(String title)
        更改对话框的标题。
        参数
        title - 对话框的标题

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        这个Dialog的水平位置。 更改此属性将水平移动Dialog 。

      • setX

        public final void setX​(double x)
        设置属性x的值。
        Property description:
        这个水平位置这个Dialog 。 更改此属性将水平移动Dialog 。

      • xProperty

        public final ReadOnlyDoubleProperty xProperty​()
        这个Dialog的水平位置。 更改此属性将水平移动Dialog 。
        另请参见：
        getX() ， setX(double)

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        这个Dialog的垂直位置。 更改此属性将垂直移动Dialog 。

      • setY

        public final void setY​(double y)
        设置属性y的值。
        Property description:
        这个Dialog的垂直位置。 更改此属性将垂直移动Dialog 。

      • yProperty

        public final ReadOnlyDoubleProperty yProperty​()
        这个Dialog的垂直位置。 更改此属性将垂直移动Dialog 。
        另请参见：
        getY() ， setY(double)

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此目标构建事件调度链。 事件调度链包含可能对处理针对EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要为链接添加一个EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 建立起来的初始链
        结果
        此目标的结果事件调度链

      • setOnShowing

        public final void setOnShowing​(EventHandler<DialogEvent> value)
        设置属性onShowing的值。
        Property description:
        在对话框显示之前调用。

      • getOnShowing

        public final EventHandler<DialogEvent> getOnShowing​()
        获取属性onShowing的值。
        Property description:
        在对话框显示之前调用。

      • onShowingProperty

        public final ObjectProperty<EventHandler<DialogEvent>> onShowingProperty​()
        在对话框显示之前调用。
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • setOnShown

        public final void setOnShown​(EventHandler<DialogEvent> value)
        设置属性onShown的值。
        Property description:
        在对话框显示之后调用。

      • getOnShown

        public final EventHandler<DialogEvent> getOnShown​()
        获取onShown属性的值。
        Property description:
        在对话框显示之后调用。

      • onShownProperty

        public final ObjectProperty<EventHandler<DialogEvent>> onShownProperty​()
        在对话框显示之后调用。
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • setOnHiding

        public final void setOnHiding​(EventHandler<DialogEvent> value)
        设置属性onHiding的值。
        Property description:
        在对话框被隐藏之前调用。

      • getOnHiding

        public final EventHandler<DialogEvent> getOnHiding​()
        获取属性onHiding的值。
        Property description:
        在对话框被隐藏之前调用。

      • onHidingProperty

        public final ObjectProperty<EventHandler<DialogEvent>> onHidingProperty​()
        在对话框被隐藏之前调用。
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • setOnHidden

        public final void setOnHidden​(EventHandler<DialogEvent> value)
        设置属性onHidden的值。
        Property description:
        Dialog已被隐藏之后调用。 当隐藏Dialog ，将调用此事件处理程序，以允许开发人员在Alert关闭时清理资源或执行其他任务。

      • getOnHidden

        public final EventHandler<DialogEvent> getOnHidden​()
        获取属性onHidden的值。
        Property description:
        Dialog已被隐藏之后调用。 当隐藏Dialog ，调用此事件处理程序，允许开发人员在Alert关闭时清理资源或执行其他任务。

      • onHiddenProperty

        public final ObjectProperty<EventHandler<DialogEvent>> onHiddenProperty​()
        Dialog已被隐藏之后调用。 当隐藏Dialog ，调用此事件处理程序，允许开发人员在Alert关闭时清理资源或执行其他任务。
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

      • setOnCloseRequest

        public final void setOnCloseRequest​(EventHandler<DialogEvent> value)
        设置属性onCloseRequest的值。
        Property description:
        当有外部请求关闭此Dialog 。 安装的事件处理程序可以通过消耗接收的事件来阻止对话关闭。

      • getOnCloseRequest

        public final EventHandler<DialogEvent> getOnCloseRequest​()
        获取属性onCloseRequest的值。
        Property description:
        当有外部请求关闭此Dialog 。 安装的事件处理程序可以通过消耗接收的事件来阻止对话关闭。

      • onCloseRequestProperty

        public final ObjectProperty<EventHandler<DialogEvent>> onCloseRequestProperty​()
        当有外部请求关闭此Dialog 。 安装的事件处理程序可以通过消耗接收的事件来阻止对话关闭。
        另请参见：
        getOnCloseRequest(), setOnCloseRequest(EventHandler)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DialogEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class DialogEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.DialogEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class DialogEvent
extends Event
    与对话框显示/隐藏操作相关的事件。 特别地，此事件仅由以下方法使用：
    • Dialog.onShowingProperty()
    • Dialog.onShownProperty()
    • Dialog.onHidingProperty()
    • Dialog.onCloseRequestProperty()
    • Dialog.onHiddenProperty()
    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Dialog ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<DialogEvent> ANY
      所有对话事件类型的常用超类型。
      static EventType<DialogEvent> DIALOG_CLOSE_REQUEST
      当有外部请求关闭该对话框时，此事件将传递到对话框。
      static EventType<DialogEvent> DIALOG_HIDDEN
      此事件发生在隐藏后的对话框上。
      static EventType<DialogEvent> DIALOG_HIDING
      此事件发生在隐藏之前的对话框上。
      static EventType<DialogEvent> DIALOG_SHOWING
      此事件发生在显示之前的对话框上。
      static EventType<DialogEvent> DIALOG_SHOWN
      此事件发生在显示之后的对话框上。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      DialogEvent​(Dialog<?> source, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DialogEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      DialogEvent copyFor​(Object newSource, EventTarget newTarget, EventType<DialogEvent> type)
      用给定的字段替换给定事件的副本。
      EventType<DialogEvent> getEventType​()
      获取此事件的事件类型。
      String toString​()
      返回此 DialogEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<DialogEvent> ANY
        所有对话事件类型的常用超类型。

      • DIALOG_SHOWING

        public static final EventType<DialogEvent> DIALOG_SHOWING
        此事件发生在显示之前的对话框上。

      • DIALOG_SHOWN

        public static final EventType<DialogEvent> DIALOG_SHOWN
        此事件发生在显示之后的对话框上。

      • DIALOG_HIDING

        public static final EventType<DialogEvent> DIALOG_HIDING
        此事件发生在隐藏之前的对话框上。

      • DIALOG_HIDDEN

        public static final EventType<DialogEvent> DIALOG_HIDDEN
        此事件发生在隐藏后的对话框上。

      • DIALOG_CLOSE_REQUEST

        public static final EventType<DialogEvent> DIALOG_CLOSE_REQUEST
        当有外部请求关闭该对话框时，此事件将传递到对话框。 如果事件没有被任何安装的对话框事件处理程序使用，则此事件的默认处理程序将关闭相应的对话框。

    • 构造方法详细信息

      • DialogEvent

        public DialogEvent​(Dialog<?> source,
                   EventType<? extends Event> eventType)
        构造一个新的Event与指定的事件源，目标和类型。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        参数
        source - 发送事件的事件源
        eventType - 事件类型

    • 方法详细信息

      • toString

        public String toString​()
        返回此 DialogEvent对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        这个 DialogEvent对象的字符串表示形式。

      • copyFor

        public DialogEvent copyFor​(Object newSource,
                           EventTarget newTarget)
        描述从类别复制Event
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • copyFor

        public DialogEvent copyFor​(Object newSource,
                           EventTarget newTarget,
                           EventType<DialogEvent> type)
        用给定的字段替换给定事件的副本。
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        type - 新的eventType
        结果
        事件副本与字段被替换

      • getEventType

        public EventType<DialogEvent> getEventType​()
        描述从类别复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 Event
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DialogPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class DialogPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.control.DialogPane
  • All Implemented Interfaces:
    Styleable ， EventTarget

    @DefaultProperty("buttonTypes")
public class DialogPane
extends Pane
    DialogPane应该被认为是在Dialog实例中显示的根节点 。 在此作用下，DialogPane负责安置headers ， graphics ， content ，并buttons 。 DialogPane的默认实现（即DialogPane类本身）通过正常的layoutChildren()方法处理布局。 这个方法可能被希望以另一种方式处理布局的子类覆盖）。

    除了header和content属性外，还有header text和content text属性。 * Text属性的工作方式是与Node属性相比，它们的优先级较低，但是对于常见情况下的开发人员而言，它们更为方便，因为开发人员通常可能并不想简单地设置一个字符串值到DialogPane的标题或内容区域。

    了解在header和headerText属性中设置非空值的含义很重要。 要点如下：

    1. 该header财产优先于headerText属性，所以如果两者都设置为非空值， header将被使用， headerText将被忽略。
    2. 如果headerText设置为非空值，并且还设置了graphic ，则图形的默认位置从位于内容区域的左侧移动到标题文本的右侧。
    3. 如果header设置为非空值，并且还设置了graphic ，则图形将从其默认位置（内容区域的左侧）移除，并且不会放置在自定义标题节点的右侧。 如果需要图形，则应手动将其手动添加到自定义标题节点的布局中。

    DialogPane上的概念操作ButtonType 。 ButtonType是单个按钮的描述符，应在DialogPane中以可视方式表示。 因此，创建DialogPane的开发人员必须指定要显示的按钮类型，并通过getButtonTypes()方法完成，该方法返回可修改的ObservableList ，用户可以根据需要添加和删除。

    ButtonType类定义了一些预定义的按钮类型，例如ButtonType.OK和ButtonType.CANCEL 。 JavaFX对话框API的许多用户将发现这些预定义的按钮类型满足他们的需求，特别是由于它们内置了对default和cancel按钮的支持，以及将字符串转换成JavaFX所有语言的好处翻译成 对于想要定义自己的ButtonType （最常用来定义带有自定义文本的按钮）的用户，他们可以通过ButtonType类上可用的构造函数来实现。

    开发人员将很快发现，通过ButtonType课程提供的可配置性数量很少。 这是有意的，但并不意味着开发人员不能修改由指定的ButtonType创建的按钮。 为此，开发人员只需使用ButtonType调用lookupButton(ButtonType)方法（假设它已经在getButtonTypes()列表中设置），返回的节点通常是Button ，但这取决于是否已经覆盖了createButton(ButtonType)方法。

    DialogPane类提供了一些可以被子类覆盖的方法，以便更轻松地启用自定义功能。 这些方法包括：

    • createButton(ButtonType)
    • createDetailsButton()
    • createButtonBar()

    这些方法被记录在案，所以请注意任何开发人员希望通过自己的功能覆盖这些方法的期望。

    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Dialog

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Node> content
      表示对话框的内容区域的属性。
      StringProperty contentText
      表示对话窗格的内容文本的属性。
      ObjectProperty<Node> expandableContent
      表示对话框可扩展内容区域的属性。
      BooleanProperty expanded
      表示是否扩展了dialogPane。
      ObjectProperty<Node> graphic
      对话图形，显示在标题中，如果显示，或 content的左侧。
      ObjectProperty<Node> header
      表示对话框窗格的标题区域的属性。
      StringProperty headerText
      表示对话框窗格的标题文本的属性。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      DialogPane​()
      创建一个带有“dialog-pane”样式类的新DialogPane实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      ObjectProperty<Node> contentProperty​()
      表示对话框的内容区域的属性。
      StringProperty contentTextProperty​()
      表示对话窗格的内容文本的属性。
      protected Node createButton​(ButtonType buttonType)
      子类可以覆盖此方法来创建一个随后插入DialogPane按钮区域的自定义按钮（通过createButtonBar()方法创建，但通常它是ButtonBar的一个实例）。
      protected Node createButtonBar​()
      这个方法可以被子类覆盖以提供按钮栏。
      protected Node createDetailsButton​()
      子类可以覆盖此方法来创建自定义详细信息按钮。
      ObjectProperty<Node> expandableContentProperty​()
      表示对话框可扩展内容区域的属性。
      BooleanProperty expandedProperty​()
      表示是否扩展了dialogPane。
      ObservableList<ButtonType> getButtonTypes​()
      用于对话框按钮栏区域的按钮类型的可观察列表（通过 createButtonBar()方法创建）。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Node getContent​()
      将对话框内容作为节点返回（即使将其设置为使用setContentText(String)的字符串 - 这仅仅是转换为Node （最可能是Label ）。
      String getContentText​()
      返回此DialogPane的当前设置的内容文本。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      Node getExpandableContent​()
      返回对话框可扩展内容节点（如果已设置），否则返回null。
      Node getGraphic​()
      获取属性图形的值。
      Node getHeader​()
      用作对话框窗格标题的节点。
      String getHeaderText​()
      返回此DialogPane的当前设置的标题文本。
      ObjectProperty<Node> graphicProperty​()
      对话图形，在标题中显示，如果显示，或在 content的左侧。
      ObjectProperty<Node> headerProperty​()
      表示对话框窗格的标题区域的属性。
      StringProperty headerTextProperty​()
      表示对话框窗格的标题文本的属性。
      boolean isExpanded​()
      返回是否扩展了dialogPane。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      Node lookupButton​(ButtonType buttonType)
      该方法提供了开发人员可以为给定的ButtonType （假设它是button types列表的一部分）检索实际节点的一种方法。
      void setContent​(Node content)
      分配对话框内容。
      void setContentText​(String contentText)
      设置在对话框内容区域显示的字符串。
      void setExpandableContent​(Node content)
      设置对话框可扩展内容节点，如果不显示可扩展内容，则设置为null。
      void setExpanded​(boolean value)
      设置dialogPane是否展开。
      void setGraphic​(Node graphic)
      设置对话框图形，将显示在标题中，如果显示，或 content的左侧。
      void setHeader​(Node header)
      分配对话窗格标题。
      void setHeaderText​(String headerText)
      设置在对话框头部区域显示的字符串。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • graphic

        public final ObjectProperty<Node> graphicProperty
        对话图形，在标题中显示，如果显示，或 content的左侧。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • header

        public final ObjectProperty<Node> headerProperty
        表示对话框窗格的标题区域的属性。 请注意，如果此标头设置为非空值，它将占用DialogPane的整个顶部区域。 它也将导致DialogPane将其布局切换到“标题”布局，如DialogPane类javadoc中所述。
        另请参见：
        getHeader() ， setHeader(Node)

      • headerText

        public final StringProperty headerTextProperty
        表示对话框窗格的标题文本的属性。 标题文本的优先级低于header node ，这意味着如果头节点和headerText属性均已设置，则头文本将不会显示在默认的DialogPane实例中。

        当headerText设置为非空值时，这将导致DialogPane将其布局切换到“标题”布局，如DialogPane类javadoc中所述。

        另请参见：
        getHeaderText() ， setHeaderText(String)

      • content

        public final ObjectProperty<Node> contentProperty
        表示对话框的内容区域的属性。
        另请参见：
        getContent() ， setContent(Node)

      • contentText

        public final StringProperty contentTextProperty
        表示对话窗格的内容文本的属性。 内容文本的优先级低于content node ，这意味着如果内容节点和contentText属性均已设置，内容文本将不会显示在默认的DialogPane实例中。
        另请参见：
        getContentText() ， setContentText(String)

      • expandableContent

        public final ObjectProperty<Node> expandableContentProperty
        表示对话框可扩展内容区域的属性。 任何节点都可以放置在此区域，但只有当用户点击“显示详细信息”可展开按钮时才会显示。 当可扩展内容属性不为空时，将自动添加此按钮。
        另请参见：
        getExpandableContent() ， setExpandableContent(Node)

      • expanded

        public final BooleanProperty expandedProperty
        表示是否扩展了dialogPane。
        另请参见：
        isExpanded() ， setExpanded(boolean)

    • 构造方法详细信息

      • DialogPane

        public DialogPane​()
        创建一个带有“dialog-pane”样式类的新DialogPane实例。

    • 方法详细信息

      • graphicProperty

        public final ObjectProperty<Node> graphicProperty​()
        对话图形，在标题中显示，如果显示，或 content的左侧。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • getGraphic

        public final Node getGraphic​()
        获取属性图形的值。
        Property description:
        对话图形，在标题中显示，如果显示，或 content的左侧。

      • setGraphic

        public final void setGraphic​(Node graphic)
        设置对话框图形，将显示在标题中（如果显示）或 content左侧。
        参数
        graphic - 新的对话框图形，如果不显示图形，则为null。

      • getHeader

        public final Node getHeader​()
        用作对话框窗格标题的节点。
        结果
        对话窗格的标题。

      • setHeader

        public final void setHeader​(Node header)
        分配对话窗格标题。 任何节点都可以使用。
        参数
        header - header的新标题。

      • headerProperty

        public final ObjectProperty<Node> headerProperty​()
        表示对话框窗格的标题区域的属性。 请注意，如果此标头设置为非空值，它将占用DialogPane的整个顶部区域。 它也将导致DialogPane将其布局切换到“标题”布局，如DialogPane类javadoc中所述。
        另请参见：
        getHeader() ， setHeader(Node)

      • setHeaderText

        public final void setHeaderText​(String headerText)
        设置在对话框头部区域显示的字符串。 请注意，标题文本的优先级低于header node ，这意味着如果头节点和headerText属性均已设置，则头文本将不会显示在默认的DialogPane实例中。

        当headerText设置为非空值时，这将导致DialogPane将其布局切换到“标题”布局，如DialogPane类javadoc中所述。

        参数
        headerText - 要在对话框标题区域中显示的字符串

      • getHeaderText

        public final String getHeaderText​()
        返回此DialogPane的当前设置的标题文本。
        结果
        此DialogPane的当前设置的标题文本

      • headerTextProperty

        public final StringProperty headerTextProperty​()
        表示对话框窗格的标题文本的属性。 标题文本的优先级低于header node ，这意味着如果头节点和headerText属性均已设置，则标题文本将不会显示在默认的DialogPane实例中。

        当headerText设置为非空值时，这将导致DialogPane将其布局切换到“标题”布局，如DialogPane类javadoc中所述。

        另请参见：
        getHeaderText() ， setHeaderText(String)

      • getContent

        public final Node getContent​()
        将对话框内容作为节点返回（即使使用setContentText(String)将其设置为String） - 这仅仅是转换为Node （最可能是Label ）。
        结果
        对话框的内容

      • setContent

        public final void setContent​(Node content)
        分配对话框内容。 任何节点都可以使用
        参数
        content - 对话框的内容

      • contentProperty

        public final ObjectProperty<Node> contentProperty​()
        表示对话框的内容区域的属性。
        另请参见：
        getContent() ， setContent(Node)

      • setContentText

        public final void setContentText​(String contentText)
        设置在对话框内容区域显示的字符串。 请注意，内容文本的优先级低于content node ，这意味着如果内容节点和contentText属性均已设置，内容文本将不会显示在默认的DialogPane实例中。
        参数
        contentText - 要在对话框内容区域显示的字符串

      • getContentText

        public final String getContentText​()
        返回此DialogPane的当前设置的内容文本。
        结果
        此DialogPane的当前设置的内容文本

      • contentTextProperty

        public final StringProperty contentTextProperty​()
        表示对话窗格的内容文本的属性。 内容文本的优先级低于content node ，这意味着如果内容节点和contentText属性均已设置，内容文本将不会显示在默认的DialogPane实例中。
        另请参见：
        getContentText() ， setContentText(String)

      • expandableContentProperty

        public final ObjectProperty<Node> expandableContentProperty​()
        表示对话框可扩展内容区域的属性。 任何节点都可以放置在此区域，但只有当用户点击“显示详细信息”可展开按钮时才会显示。 当可扩展内容属性不为空时，将自动添加此按钮。
        另请参见：
        getExpandableContent() ， setExpandableContent(Node)

      • getExpandableContent

        public final Node getExpandableContent​()
        返回对话框可扩展内容节点（如果已设置），否则返回null。
        结果
        对话框可展开内容节点

      • setExpandableContent

        public final void setExpandableContent​(Node content)
        设置对话框可扩展内容节点，如果不显示可扩展内容，则设置为null。
        参数
        content - 对话框可扩展内容节点

      • expandedProperty

        public final BooleanProperty expandedProperty​()
        表示是否扩展了dialogPane。
        另请参见：
        isExpanded() ， setExpanded(boolean)

      • isExpanded

        public final boolean isExpanded​()
        返回是否扩展了dialogPane。
        结果
        如果对话框扩展，则为true。

      • setExpanded

        public final void setExpanded​(boolean value)
        设置dialogPane是否展开。 当有expandable content显示时，这只是有意义的。
        参数
        value - 如果对话框应该展开， value true。

      • getButtonTypes

        public final ObservableList<ButtonType> getButtonTypes​()
        用于对话框按钮栏区域的按钮类型的可观察列表（通过createButtonBar()方法创建）。 修改此列表的内容将立即更改对话窗格中显示给用户的按钮。
        结果
        用户可以使用button types的ObservableList1 。

      • lookupButton

        public final Node lookupButton​(ButtonType buttonType)
        该方法提供了开发人员可以为给定的ButtonType检索实际节点（假设它是button types列表的一部分）的方式。
        参数
        buttonType - 请求节点表示的ButtonType 。
        结果
        节点用于表示由 createButton(ButtonType)创建的按钮类型，只有按钮类型是 button types列表的一部分，否则为空。

      • createButtonBar

        protected Node createButtonBar​()
        这个方法可以被子类覆盖以提供按钮栏。 请注意，通过覆盖此方法，开发人员必须承担多重责任：
        1. 开发人员必须立即重复所有button types，并依次调用createButton(ButtonType) 。
        2. 开发人员必须向button types列表添加一个监听器，并且当此列表更改时更新按钮栏。
        3. 类似地，开发人员必须注意更改expandable content属性，添加和删除详细信息按钮（通过createDetailsButton()创建）。

        此方法的默认实现将创建并返回一个新的ButtonBar实例。

        结果
        创建的按钮栏

      • createButton

        protected Node createButton​(ButtonType buttonType)
        这个方法可以被子类覆盖，创建一个随后插入DialogPane按钮区域的自定义按钮（通过createButtonBar()方法创建，但通常它是ButtonBar的一个实例。
        参数
        buttonType - ButtonType创建一个按钮。
        结果
        一个JavaFX Node ，代表给定的ButtonType ，最常见的是Button的一个实例。

      • createDetailsButton

        protected Node createDetailsButton​()
        子类可以覆盖此方法来创建自定义详细信息按钮。

        要重写这个方法，你必须做两件事情：

        1. 该按钮将需要有自己的代码集来处理鼠标/键盘交互并切换expanded属性的状态。
        2. 如果您的按钮基于对话框窗格是否展开或折叠来更改其视觉效果，则应将监听器添加到expanded属性，以便您可以更新按钮的视觉效果。
        结果
        创建的详细信息按钮

      • layoutChildren

        protected void layoutChildren​()
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • computeMinWidth

        protected double computeMinWidth​(double height)
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于它应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FocusModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class FocusModel<T>

  • java.lang.Object
    • javafx.scene.control.FocusModel<T>
  • 已知直接子类：
    TableFocusModel

    public abstract class FocusModel<T>
extends Object
    FocusModel实现的抽象基类。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyIntegerProperty focusedIndex
      FocusModel中具有焦点的当前项目的索引。
      ReadOnlyObjectProperty<T> focusedItem
      FocusModel中的当前项目具有重点。

    • 构造方法摘要

      构造方法
      Constructor 描述
      FocusModel​()
      创建默认的FocusModel实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void focus​(int index)
      导致给定索引处的项目接收焦点。
      ReadOnlyIntegerProperty focusedIndexProperty​()
      FocusModel中具有焦点的当前项目的索引。
      ReadOnlyObjectProperty<T> focusedItemProperty​()
      FocusModel中的当前项目具有重点。
      void focusNext​()
      尝试将焦点放在当前焦点集中的行之后。
      void focusPrevious​()
      尝试将重点放在目前重点集中的行之前。
      int getFocusedIndex​()
      获取focusIndex属性的值。
      T getFocusedItem​()
      获取对focusItem的值。
      protected abstract int getItemCount​()
      返回数据模型中支配控件的项目数。
      protected abstract T getModelItem​(int index)
      返回给定索引处的项目。
      boolean isFocused​(int index)
      方便的方法来通知给定的索引当前是否集中在此SelectionModel中。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • focusedIndex

        public final ReadOnlyIntegerProperty focusedIndexProperty
        FocusModel中具有焦点的当前项目的索引。 这可能是-1，但只有当控件为空时。 如果控件本身没有聚焦，则如果控件本身被集中，则此属性仍将引用将接收键盘焦点的行索引。
        另请参见：
        getFocusedIndex()

      • focusedItem

        public final ReadOnlyObjectProperty<T> focusedItemProperty
        FocusModel中的当前项目具有重点。 这可能是null，但只有当控件为空时。 如果控件本身没有聚焦，如果控件本身集中在一起，该属性仍将引用将接收键盘焦点的项目。
        另请参见：
        getFocusedItem()

    • 构造方法详细信息

      • FocusModel

        public FocusModel​()
        创建默认的FocusModel实例。

    • 方法详细信息

      • focusedIndexProperty

        public final ReadOnlyIntegerProperty focusedIndexProperty​()
        FocusModel中具有焦点的当前项目的索引。 这可能是-1，但只有当控件为空时。 如果控件本身没有聚焦，则如果控件本身被集中，则此属性仍将引用将接收键盘焦点的行索引。
        另请参见：
        getFocusedIndex()

      • getFocusedIndex

        public final int getFocusedIndex​()
        获取focusIndex属性的值。
        Property description:
        FocusModel中具有焦点的当前项目的索引。 这可能是-1，但只有当控件为空时。 如果控件本身没有聚焦，则如果控件本身被集中，则此属性仍将引用将接收键盘焦点的行索引。

      • focusedItemProperty

        public final ReadOnlyObjectProperty<T> focusedItemProperty​()
        FocusModel中的当前项目具有重点。 这可能是null，但只有当控件为空时。 如果控件本身没有聚焦，如果控件本身集中在一起，该属性仍将引用将接收键盘焦点的项目。
        另请参见：
        getFocusedItem()

      • getFocusedItem

        public final T getFocusedItem​()
        获取对focusItem的值。
        Property description:
        FocusModel中的当前项目具有重点。 这可能是null，但只有当控件为空时。 如果控件本身没有聚焦，如果控件本身集中在一起，该属性仍将引用将接收键盘焦点的项目。

      • getItemCount

        protected abstract int getItemCount​()
        返回数据模型中支配控件的项目数。 一个例子就是ListView焦点模型可能会返回listView.getItems().size() 。 可聚焦索引的有效范围在0和此方法返回的任何值之间。
        结果
        支持控制的数据模型中的项目数

      • getModelItem

        protected abstract T getModelItem​(int index)
        返回给定索引处的项目。 使用ListView的示例将是listView.getItems().get(index) 。
        参数
        index - 从底层数据模型请求的项目的索引。
        结果
        如果索引超出范围，则返回null，或者与给定索引相关的类型T的元素。

      • isFocused

        public boolean isFocused​(int index)

        方便的方法来通知给定的索引当前是否集中在此SelectionModel中。 在功能上等同于调用

          getFocusedIndex() == index
        。
        参数
        index - 检查目前是否关注的索引。
        结果
        如果给定的索引是集中的，则为真，否则为false。

      • focus

        public void focus​(int index)
        导致给定索引处的项目接收焦点。 这不会导致当前的选择更改。 更新focusItem和focusedIndex属性，使focusedIndex = -1除非0 <= index < model size 。
        参数
        index - 要获取焦点的项目的索引。

      • focusPrevious

        public void focusPrevious​()
        尝试将重点放在目前重点集中的行之前。 如果当前焦点所有者是第一行，或者是-1（表示没有当前焦点所有者），调用此方法将不会有结果。

      • focusNext

        public void focusNext​()
        尝试将焦点放在当前焦点集中的行之后。 如果当前焦点所有者是最后一行，调用此方法将不会有结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Hyperlink (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Hyperlink

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.ButtonBase
                • javafx.scene.control.Hyperlink
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class Hyperlink
extends ButtonBase

    一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。 当点击/按压超链接isVisited()成为true 。 超链接的行为就像一个Button 。 当按下并释放超链接时，发送一个ActionEvent ，您的应用程序可以根据此事件执行一些操作。

    例：

    Hyperlink link = new Hyperlink("www.oracle.com");
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty visited
      指示此链接是否已被“访问”。

      • Properties inherited from class javafx.scene.control.ButtonBase

        armed, onAction

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Hyperlink​()
      创建没有标签的超链接。
      Hyperlink​(String text)
      创建指定文本的超链接作为其标签。
      Hyperlink​(String text, Node graphic)
      创建指定文本和图形作为其标签的超链接。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void fire​()
      实现调用ActionEvent如果定义了一个。
      protected Cursor getInitialCursor​()
      返回此控件的初始游标状态，供JavaFX CSS引擎正确设置其初始值。
      boolean isVisited​()
      获取访问的属性的值。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setVisited​(boolean value)
      设置访问的属性的值。
      BooleanProperty visitedProperty​()
      指示此链接是否已被“访问”。

      • Methods inherited from class javafx.scene.control.ButtonBase

        arm, armedProperty, disarm, executeAccessibleAction, getOnAction, isArmed, onActionProperty, setOnAction

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • visited

        public final BooleanProperty visitedProperty
        指示此链接是否已被“访问”。
        另请参见：
        isVisited() ， setVisited(boolean)

    • 构造方法详细信息

      • Hyperlink

        public Hyperlink​()
        创建没有标签的超链接。

      • Hyperlink

        public Hyperlink​(String text)
        创建指定文本的超链接作为其标签。
        参数
        text - 其标签的文本字符串。

      • Hyperlink

        public Hyperlink​(String text,
                 Node graphic)
        创建指定文本和图形作为其标签的超链接。
        参数
        text - 其标签的文本字符串。
        graphic - 其标签的图形

    • 方法详细信息

      • visitedProperty

        public final BooleanProperty visitedProperty​()
        指示此链接是否已被“访问”。
        另请参见：
        isVisited() ， setVisited(boolean)

      • setVisited

        public final void setVisited​(boolean value)
        设置访问的属性的值。
        Property description:
        指示此链接是否已被“访问”。

      • isVisited

        public final boolean isVisited​()
        获取访问的属性的值。
        Property description:
        指示此链接是否已被“访问”。

      • fire

        public void fire​()
        实现调用ActionEvent如果定义了一个。 此功能也将setVisited(boolean)设为true。
        Specified by:
        fire在 ButtonBase

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getInitialCursor

        protected Cursor getInitialCursor​()
        返回此控件的初始游标状态，供JavaFX CSS引擎正确设置其初始值。 该方法最初被覆盖以使用HAND光标。
        重写：
        getInitialCursor在 Node
        结果
        这个 Node的初始光标状态。
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IndexedCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class IndexedCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
  • 参数类型
    T - 单元格中包含的项目的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    ListCell ， TableCell ， TableRow ， TreeCell ， TreeTableCell ， TreeTableRow

    public class IndexedCell<T>
extends Cell<T>
    一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。 尽管如此， IndexedCell不应该直接在单元格工厂中实例化（有关细胞工厂的详细信息，请参阅Cell ）。 而不是创造的IndexedCell直接，则应该利用特定的控制单元实现的（例如， ListCell ， TreeCell ） TableRow和TableCell ）。 有关使用和定制单元格的更多信息，请参阅Cell API文档。

    由于每个顺序索引表示控件中的单个顺序元素，因此可以轻松替代行突出显示。 默认情况下，使用Cells的控件提供自己的替代行突出显示颜色，但是可以使用IndexedCell ：“even”和“odd”提供的两个伪类状态来覆盖它。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyIntegerProperty index
      （：例如，在虚拟化控制这个小区的位置ListView ， TreeView ， TableView等）。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      IndexedCell​()
      使用默认样式类“indexed-cell”创建默认IndexedCell。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getIndex​()
      返回此单元格在底层控件数据模型中的索引。
      ReadOnlyIntegerProperty indexProperty​()
      （：例如，在虚拟化控制这个小区的位置ListView ， TreeView ， TableView等）。
      void updateIndex​(int i)
      更新与此IndexedCell相关联的索引。

      • Methods inherited from class javafx.scene.control.Cell

        cancelEdit, commitEdit, editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, startEdit, updateItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, createDefaultSkin, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • index

        public final ReadOnlyIntegerProperty indexProperty
        （：例如，在虚拟化控制这个小区的位置ListView ， TreeView ， TableView等）。 这是与Cell item属性完全对应的模型索引。 例如，在ListView的情况下，这意味着： cell.item == listView.getItems().get(cell.getIndex())
        结果
        这个单元格在虚拟化控件中的位置

    • 构造方法详细信息

      • IndexedCell

        public IndexedCell​()
        使用默认样式类“indexed-cell”创建默认IndexedCell。

    • 方法详细信息

      • getIndex

        public final int getIndex​()
        返回此单元格在底层控件数据模型中的索引。
        结果
        该单元格在底层控制数据模型中的索引

      • indexProperty

        public final ReadOnlyIntegerProperty indexProperty​()
        （：例如，在虚拟化控制这个小区的位置ListView ， TreeView ， TableView等）。 这是与Cell item属性完全对应的模型索引。 例如，在ListView的情况下，这意味着： cell.item == listView.getItems().get(cell.getIndex())
        结果
        这个单元格在虚拟化控件中的位置

      • updateIndex

        public void updateIndex​(int i)
        更新与此IndexedCell相关联的索引。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        i - the index associated with this indexed cell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IndexRange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class IndexRange

  • java.lang.Object
    • javafx.scene.control.IndexRange

  • public final class IndexRange
extends Object
    表示整数值的连续范围的类。
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String VALUE_DELIMITER
      索引范围值分隔符。

    • 构造方法摘要

      构造方法
      Constructor 描述
      IndexRange​(int start, int end)
      创建一个IndexRange的实例，表示 start和 end之间的范围。
      IndexRange​(IndexRange range)
      通过复制给定的IndexRange对象的值来创建IndexRange的实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object object)
      指示一些其他对象是否等于此。
      int getEnd​()
      返回范围的结束位置（排除）。
      int getLength​()
      返回范围的长度。
      int getStart​()
      返回范围的起始位置。
      int hashCode​()
      返回此 Range对象的哈希码。
      static IndexRange normalize​(int v1, int v2)
      创建一个具有较小值作为起始索引的IndexRange实例的便利方法，较大的值作为结束索引。
      String toString​()
      返回此 Range对象的字符串表示形式。
      static IndexRange valueOf​(String value)
      在“2,6”形式的字符串中解析的方便方法，它将创建一个起始值为2的IndexRange实例，最终值为6。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • VALUE_DELIMITER

        public static final String VALUE_DELIMITER
        索引范围值分隔符。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • IndexRange

        public IndexRange​(int start,
                  int end)
        创建一个IndexRange的实例，表示 start和 end之间的范围。
        参数
        start - 范围的开始位置。
        end - 范围的结束位置。

      • IndexRange

        public IndexRange​(IndexRange range)
        通过复制给定的IndexRange对象的值来创建IndexRange的实例。
        参数
        range - 从中复制开始和结束值的IndexRange实例。

    • 方法详细信息

      • getStart

        public int getStart​()
        返回范围的起始位置。
        结果
        范围的起始位置

      • getEnd

        public int getEnd​()
        返回范围的结束位置（排除）。
        结果
        范围的最终位置（独占）

      • getLength

        public int getLength​()
        返回范围的长度。
        结果
        范围的长度

      • equals

        public boolean equals​(Object object)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        object - 与之比较的参考对象。
        结果
        true如果此对象等于object参数; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 Range对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 Range对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此 Range对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 Range对象的字符串表示形式。

      • normalize

        public static IndexRange normalize​(int v1,
                                   int v2)
        创建一个具有较小值作为起始索引的IndexRange实例的便利方法，较大的值作为结束索引。
        参数
        v1 - 范围内使用的第一个值。
        v2 - 范围内使用的第二个值。
        结果
        一个IndexRange实例，其中较小的值为开始，较大的值为结束。

      • valueOf

        public static IndexRange valueOf​(String value)
        在“2,6”形式的字符串中解析的方便方法，它将创建一个起始值为2的IndexRange实例，最终值为6。
        参数
        value - 要解析并转换为IndexRange的字符串。
        结果
        表示值字符串中提供的起始值和结束值的IndexRange实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javafx.scene.control (Java SE 9 & JDK 9 )

javafx.scene.control

Interfaces

  • Skin
  • Skinnable
  • TextInputControl.Content
  • Toggle

Classes

  • Accordion
  • Alert
  • Button
  • ButtonBar
  • ButtonBase
  • ButtonType
  • Cell
  • CheckBox
  • CheckBoxTreeItem
  • CheckBoxTreeItem.TreeModificationEvent
  • CheckMenuItem
  • ChoiceBox
  • ChoiceDialog
  • ColorPicker
  • ComboBox
  • ComboBoxBase
  • ContextMenu
  • Control
  • CustomMenuItem
  • DateCell
  • DatePicker
  • Dialog
  • DialogEvent
  • DialogPane
  • FocusModel
  • Hyperlink
  • IndexedCell
  • IndexRange
  • Label
  • Labeled
  • ListCell
  • ListView
  • ListView.EditEvent
  • Menu
  • MenuBar
  • MenuButton
  • MenuItem
  • MultipleSelectionModel
  • Pagination
  • PasswordField
  • PopupControl
  • ProgressBar
  • ProgressIndicator
  • RadioButton
  • RadioMenuItem
  • ResizeFeaturesBase
  • ScrollBar
  • ScrollPane
  • ScrollToEvent
  • SelectionModel
  • Separator
  • SeparatorMenuItem
  • SingleSelectionModel
  • SkinBase
  • Slider
  • SortEvent
  • Spinner
  • SpinnerValueFactory
  • SpinnerValueFactory.DoubleSpinnerValueFactory
  • SpinnerValueFactory.IntegerSpinnerValueFactory
  • SpinnerValueFactory.ListSpinnerValueFactory
  • SplitMenuButton
  • SplitPane
  • SplitPane.Divider
  • Tab
  • TableCell
  • TableColumn
  • TableColumn.CellDataFeatures
  • TableColumn.CellEditEvent
  • TableColumnBase
  • TableFocusModel
  • TablePosition
  • TablePositionBase
  • TableRow
  • TableSelectionModel
  • TableView
  • TableView.ResizeFeatures
  • TableView.TableViewFocusModel
  • TableView.TableViewSelectionModel
  • TabPane
  • TextArea
  • TextField
  • TextFormatter
  • TextFormatter.Change
  • TextInputControl
  • TextInputDialog
  • TitledPane
  • ToggleButton
  • ToggleGroup
  • ToolBar
  • Tooltip
  • TreeCell
  • TreeItem
  • TreeItem.TreeModificationEvent
  • TreeTableCell
  • TreeTableColumn
  • TreeTableColumn.CellDataFeatures
  • TreeTableColumn.CellEditEvent
  • TreeTablePosition
  • TreeTableRow
  • TreeTableView
  • TreeTableView.EditEvent
  • TreeTableView.ResizeFeatures
  • TreeTableView.TreeTableViewFocusModel
  • TreeTableView.TreeTableViewSelectionModel
  • TreeView
  • TreeView.EditEvent

Enums

  • Alert.AlertType
  • ButtonBar.ButtonData
  • ContentDisplay
  • OverrunStyle
  • ScrollPane.ScrollBarPolicy
  • SelectionMode
  • TableColumn.SortType
  • TabPane.TabClosingPolicy
  • TreeSortMode
  • TreeTableColumn.SortType


javafx.scene.control (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.controls

Package javafx.scene.control

JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。 它们被设计为由设计师和开发人员高度定制的视觉。 它们设计用于布局系统。 突出控制的例子包括Button ， Label ， ListView ，并TextField 。

由于控制是Nodes在场景图，它们可以自由地与混合Groups ， Images ， Media ， Text ，和basic geometric shapes 。 在编写新的UI控件时不是很简单，使用和设计它们非常简单，特别是对现有的Web开发人员。

本文档的其余部分将描述JavaFX UI控件库的基本架构，如何对现有控件进行样式编写，编写自定义外观以及如何使用控件来构建更复杂的用户界面。

建筑

控件遵循经典的MVC设计模式。 Control是“模特儿”。 它包含操纵该状态的状态和功能。 Control类本身不知道它如何呈现或用户交互是什么。 这些任务被委派给Skin （“视图”），可以将视图和控制器功能内部分离成单独的类，尽管目前没有“控制器”方面的公共API。

所有控件都从Control类扩展，它是Parent节点，它是一个Node 。 每个控件都有一个单一的皮肤的参考，它是控件的视图实现。 控制委托皮肤负责计算控制的最小，最大和最小尺寸，基线偏移和命中测试（遏制和交叉）。 皮肤或皮肤代表也负责对包含焦点的控件上发生的所有相关关键事件进行实施和回复。

控制

控制从Parent扩展，因此不是叶节点。 从开发人员或设计师的角度来说，在许多情况下，Control可以被认为是一个叶节点。 例如，开发者或设计者可以将Button视为一个Rectangle或其他简单的叶节点。

由于控件可调整大小，因此控件将自动调整为每个场景图脉冲的首选大小 。 设置控件的宽度和高度不会影响其首选大小。 当在布局容器中使用时，施加在控件上的布局约束（或在控件上手动指定）将决定它的定位和大小。

随时可以更改控件的皮肤。 这样做会将控制标记为需要布局，因为更改皮肤可能已更改了控件的首选大小。 如果在创建控件时没有指定皮肤，则将为所有内置控件提供默认的基于CSS的皮肤。

每个控件可能具有指定的可选工具提示。 工具提示是一种控件，当鼠标从某个时间段悬停在控件上时，该控件会向用户显示有关控件的一些（通常是文本的）信息。 它可以从CSS与其他控件相同。

默认情况下，控件中的focusTraversable被覆盖为true，而使用Node，默认情况下为false。 默认情况下不能对焦的控件（例如Label）会将其替换为false。

将getMinWidth，getMinHeight，getPrefWidth，getPrefHeight，getMaxWidth和getMaxHeight函数直接委派给皮肤。 将baselineOffset方法委托给皮肤的节点。 不建议子类改变这些代理。

造型控制

有两种方法可以自定义控件的外观。 最困难但最灵活的方法是为控件编写一个新的皮肤，它精确地实现了您对控件所需的视觉效果。 有关详细信息，请参阅皮肤文档。

通过使用CSS，最简单但非常强大的对内置控件进行样式化的方法。 请注意，在此版本中，以下CSS描述仅适用于为内置控件提供的默认外观。 随后的版本将使这一般可用于希望利用这些CSS功能的任何自定义第三方控件。

内置控件的每个默认外观都由多个单独样式的区域或区域组成。 这很像一个由<div>组成的HTML页面，然后从CSS样式化。 每个单独的区域可以绘制背景，边框，图像，填充，边距等。 JavaFX CSS支持包括具有多个背景和边框以及派生颜色的功能。 这些功能使得从CSS更改JavaFX中的Controls的外观非常容易。

用于绘制内置控件的默认外观的颜色均来自基色，重音颜色和背景颜色。 只需通过修改控件的基础颜色，您可以更改派生的渐变，并创建按钮或其他控件，使用默认的外观可视化显示，而视觉上却突出显示。

与场景图中的所有其他节点一样，控件可以通过使用外部样式表或直接在控件上指定样式进行样式化。 虽然例如，通过在Node上直接指定样式来更容易地表达和理解，建议使用外部样式表，并使用Control的styleClass或id，就像使用“class”或id具有HTML CSS的HTML元素。

每个UI控件都指定一个styleClass，可用于从外部样式表中对控件进行样式调整。 例如，Button控件被赋予了“按钮”CSS样式类。 CSS样式类名称是连字符分隔的小写，而不是骆驼壳，否则它们是完全相同的。 例如，Button是“按钮”，RadioButton是“radio-button”，Tooltip是“tooltip”等等。

每个控件的类文档定义了可以设置样式的默认皮肤区域。 有关JavaFX提供的CSS功能的更多信息，请参阅CSS Reference Guide 。

  • 接口摘要
    接口 描述
    Skin<C extends Skinnable>
    基类通过定义节点的场景图来定义用户界面控件的视觉表示，以表示皮肤。
    Skinnable
    Skinnable接口由Control类实现，因此由所有Control实现实现。
    TextInputControl.Content
    界面表示文本输入的内容。
    Toggle
    表示可以在选定状态和未选择状态之间切换的控件。
  • 类摘要
    Class 描述
    Accordion
    手风琴是一组TitlePanes 。
    Alert
    Alert类对Dialog类进行子类化，并为许多预构建的对话框类型提供支持，可以轻松向用户显示提示响应。
    Button
    一个简单的按钮控件。
    ButtonBar
    ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。
    ButtonBase
    按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
    ButtonType
    ButtonType类用作JavaFX Dialog API（更具体地说是DialogPane API）的一部分，用于指定在对话框中向用户显示哪些按钮。
    Cell<T>
    细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
    CheckBox
    三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
    CheckBoxTreeItem<T>
    TreeItem子类增加了在选定的，未选择的和不确定的状态中的支持。
    CheckBoxTreeItem.TreeModificationEvent<T>
    一个TreeModificationEvent类的工作原理与TreeItem.TreeModificationEvent类相似，因为这个事件会引发 CheckBoxTreeItem层次结构，直到父节点为空。
    CheckMenuItem
    A MenuItem可以在选定状态和未选择状态之间切换。
    ChoiceBox<T>
    ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
    ChoiceDialog<T>
    一个对话框，向用户显示选择列表，最多可以从中选择一个项目。
    ColorPicker
    ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
    ComboBox<T>
    针对最常见形式的ComboBox的ComboBoxBase抽象类的实现，其中向用户提供弹出列表，以向他们提供他们可以选择的选项。
    ComboBoxBase<T>
    ComboBox类控件的抽象基类。
    ContextMenu
    一个包含菜单项的ObservableList的弹出控件。
    Control
    所有用户界面控件的基类。
    CustomMenuItem
    A MenuItem允许通过为content属性分配一个Node来嵌入任意节点。
    DateCell
    DateCell由DatePicker用于在日历月中呈现单个网格单元格。
    DatePicker
    DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
    Dialog<R>
    JavaFX中的Dialog包装了一个DialogPane，并提供了必要的API来将其呈现给最终用户。
    DialogEvent
    与对话框显示/隐藏操作相关的事件。
    DialogPane
    DialogPane应该被认为是在Dialog实例中显示的根节点 。
    FocusModel<T>
    FocusModel实现的抽象基类。
    Hyperlink
    一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
    IndexedCell<T>
    一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。
    IndexRange
    表示整数值的连续范围的类。
    Label
    标签是不可编辑的文本控件。
    Labeled
    A标签Control是其用户界面的一部分，与其相关联的文本内容。
    ListCell<T>
    Cell类型在ListView实例中使用。
    ListView<T>
    ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
    ListView.EditEvent<T>
    一个Event在ListView中专门用于表示编辑相关事件的子类。
    Menu
    可触发的项目的弹出菜单，仅根据请求向用户显示。
    MenuBar
    MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。
    MenuButton
    MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
    MenuItem
    MenuItem旨在与Menu结合使用，为用户提供选项。
    MultipleSelectionModel<T>
    一个抽象类，扩展SelectionModel以添加API以支持多选。
    Pagination
    分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
    PasswordField
    掩码输入字符的文本字段。
    PopupControl
    PopupWindow的扩展，允许CSS样式。
    ProgressBar
    ProgressIndator的专业化表示为横杠。
    ProgressIndicator
    用于指示进度的循环控制，无限（也称为不确定）或有限。
    RadioButton
    RadioButtons创建一系列只能选择一个项目的项目。
    RadioMenuItem
    RadioMenuItem是一个MenuItem可以切换（它使用Toggle mixin）。
    ResizeFeaturesBase<S>
    列使用的不可变包装类可调整由控件（如TableView和TreeTableView）提供的策略大小。
    ScrollBar
    具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。
    ScrollPane
    提供其内容的滚动，剪切视口的控件。
    ScrollToEvent<T>
    事件相关ScrollPane所虚拟化控制，比如ListView ， TableView ， TreeView和TreeTableView 。
    SelectionModel<T>
    SelectionModel是UI控件用来提供一致的API来维护选择的抽象类。
    Separator
    水平或垂直分隔线。
    SeparatorMenuItem
    甲MenuItem该顾名思义允许的水平隔板将要被嵌入在其内，通过分配一个Separator到content所述的属性CustomMenuItem这提供了方便作为基menuitems可以通过分离器进行分离。
    SingleSelectionModel<T>
    一个SelectionModel，它强制要求在任何给定的时间只选择一个索引。
    SkinBase<C extends Control>
    基本实现类，用于通过定义节点的场景图来定义用户界面控件的可视化表示，以表示skin 。
    Slider
    滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。
    SortEvent<C>
    事件相关TableView和TreeTableView排序。
    Spinner<T>
    单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。
    SpinnerValueFactory<T>
    SpinnerValueFactory是JavaFX Spinner control背后的模型 - 没有值工厂安装的Spinner不可用。
    SpinnerValueFactory.DoubleSpinnerValueFactory
    一个SpinnerValueFactory实现，旨在迭代双重值。
    SpinnerValueFactory.IntegerSpinnerValueFactory
    A SpinnerValueFactory旨在迭代整数值的实现。
    SpinnerValueFactory.ListSpinnerValueFactory<T>
    一个SpinnerValueFactory实现，旨在迭代一个值列表。
    SplitMenuButton
    SplitMenuButton，像MenuButton与从菜单中选择MenuItem的概念密切相关。
    SplitPane
    具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
    SplitPane.Divider
    在SplitPane中代表一个分隔符。
    Tab
    标签位于TabPane中 ，其中每个标签代表单个“页面”。
    TableCell<S,T>
    在TableView中表示单行/列交集。
    TableColumn<S,T>
    A TableView由多个TableColumn实例组成。
    TableColumn.CellDataFeatures<S,T>
    在TableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。
    TableColumn.CellEditEvent<S,T>
    用户在表单元格上执行编辑时触发的事件。
    TableColumnBase<S,T>
    表类控件（例如TableView和TreeTableView ）由零个或多个具体TableColumnBase子类（ TableColumn和TreeTableColumn ）的实例组成。
    TableFocusModel<T,TC extends TableColumnBase<T,?>>
    FocusModel实现的抽象基类，用于表类控件（最着名的是TableView和TreeTableView） 。
    TablePosition<S,T>
    此类用于表示TableView中的单个行/列/单元格。
    TablePositionBase<TC extends TableColumnBase>
    此类用于表示表中的单个行/列/单元格。
    TableRow<T>
    TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
    TableSelectionModel<T>
    在表类控件中使用的MultipleSelectionModel实现的抽象基类（最着名的是TableView和TreeTableView） 。
    TableView<S>
    TableView控件旨在可视化无限数量的数据行，分为列。
    TableView.ResizeFeatures<S>
    用于TableView column resize功能的不可变包装类。
    TableView.TableViewFocusModel<S>
    A FocusModel具有附加功能以支持TableView控件的要求。
    TableView.TableViewSelectionModel<S>
    SelectionModel抽象类的简单扩展，允许对TableView控件的特殊支持。
    TabPane
    允许在一组Tabs之间切换的控件 。
    TextArea
    文本输入组件，允许用户输入多行纯文本。
    TextField
    文本输入组件，允许用户输入一行未格式化的文本。
    TextFormatter<V>
    格式化器通过使用两种不同的机制来描述 TextInputControl文本的格式：可以拦截和修改用户输入的过滤器（ TextFormatter.getFilter() ）。
    TextFormatter.Change
    包含表示TextInputControl的内容或选择更改的状态。
    TextInputControl
    文本输入控件的抽象基类。
    TextInputDialog
    显示给用户的文本输入控件的对话框。
    TitledPane
    TitledPane是一个可以打开和关闭的标题的面板。
    ToggleButton
    A ToggleButton是具有选择能力的专业控制。
    ToggleGroup
    它包含所有的引用的类 Toggles其 selected变量应该被管理，使得仅仅单个 Toggle的内 ToggleGroup可以在任一周时间来选择。
    ToolBar
    ToolBar是一个可以水平或垂直显示项目的控件。
    Tooltip
    工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。
    TreeCell<T>
    Cell类型与TreeView控件一起使用。
    TreeItem<T>
    单个节点的模型为诸如TreeView之类的控件提供值的层次结构。
    TreeItem.TreeModificationEvent<T>
    一个Event ，其中包含所有形式的TreeItem修改的相关信息。
    TreeTableCell<S,T>
    表示TreeTableView中的单行 /列交集。
    TreeTableColumn<S,T>
    A TreeTableView由多个TreeTableColumn实例组成。
    TreeTableColumn.CellDataFeatures<S,T>
    在TreeTableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。
    TreeTableColumn.CellEditEvent<S,T>
    用户在表单元格上执行编辑时触发的事件。
    TreeTablePosition<S,T>
    此类用于在TreeTableView中表示单个行/列/单元格。
    TreeTableRow<T>
    TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
    TreeTableView<S>
    TreeTableView控件旨在可视化无限数量的数据行，分为列。
    TreeTableView.EditEvent<S>
    一个Event在TreeTableView中专门用于表示编辑相关事件的子类。
    TreeTableView.ResizeFeatures<S>
    用于TableView column resize功能的不可变包装类。
    TreeTableView.TreeTableViewFocusModel<S>
    A FocusModel具有支持TableView控件要求的附加功能。
    TreeTableView.TreeTableViewSelectionModel<S>
    SelectionModel抽象类的简单扩展，允许对TreeTableView控件的特殊支持。
    TreeView<T>
    TreeView控件提供了一个树根视图（类型为TreeItem ）。
    TreeView.EditEvent<T>
    一个Event在TreeView中专门用于表示编辑相关事件的子类。
  • 枚举摘要
    Enum 描述
    Alert.AlertType
    包含Alert类可用于预先填充各种属性的可用的预构建警报类型的枚举 。
    ButtonBar.ButtonData
    枚举所有可用的按钮数据注释。
    ContentDisplay
    将内容放置在标签内的位置。
    OverrunStyle
    当渲染文本的空间小于渲染整个字符串所需的空间时，定义标记的控件的行为。
    ScrollPane.ScrollBarPolicy
    表示可滚动控件在决定是否显示滚动条时使用的策略的枚举。
    SelectionMode
    用于指定在MultipleSelectionModel中可以选择多少项的枚举 。
    TableColumn.SortType
    枚举，指定应用于特定列的排序类型。
    TabPane.TabClosingPolicy
    这指定了TabPane如何处理从最终用户角度看待标签关闭。
    TreeSortMode
    指定如何对树状UI控件中的树项进行排序。
    TreeTableColumn.SortType
    枚举，指定应用于特定列的排序类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.control Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.control

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.control.ButtonType
    • javafx.scene.control.Dialog<R> (implements javafx.event.EventTarget)
      • javafx.scene.control.Alert
      • javafx.scene.control.ChoiceDialog<T>
      • javafx.scene.control.TextInputDialog
    • java.util.EventObject (implements java.io.Serializable)
      • javafx.event.Event (implements java.lang.Cloneable)
        • javafx.scene.control.CheckBoxTreeItem.TreeModificationEvent<T>
        • javafx.scene.control.DialogEvent
        • javafx.scene.control.ListView.EditEvent<T>
        • javafx.scene.control.ScrollToEvent<T>
        • javafx.scene.control.SortEvent<C>
        • javafx.scene.control.TableColumn.CellEditEvent<S,T>
        • javafx.scene.control.TreeItem.TreeModificationEvent<T>
        • javafx.scene.control.TreeTableColumn.CellEditEvent<S,T>
        • javafx.scene.control.TreeTableView.EditEvent<S>
        • javafx.scene.control.TreeView.EditEvent<T>
    • javafx.scene.control.FocusModel<T>
      • javafx.scene.control.TableFocusModel<T,TC>
        • javafx.scene.control.TableView.TableViewFocusModel<S>
        • javafx.scene.control.TreeTableView.TreeTableViewFocusModel<S>
    • javafx.scene.control.IndexRange
    • javafx.scene.control.MenuItem (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.control.CheckMenuItem
      • javafx.scene.control.CustomMenuItem
        • javafx.scene.control.SeparatorMenuItem
      • javafx.scene.control.Menu
      • javafx.scene.control.RadioMenuItem (implements javafx.scene.control.Toggle)
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control (implements javafx.scene.control.Skinnable)
            • javafx.scene.control.Accordion
            • javafx.scene.control.ButtonBar
            • javafx.scene.control.ChoiceBox<T>
            • javafx.scene.control.ComboBoxBase<T>
              • javafx.scene.control.ColorPicker
              • javafx.scene.control.ComboBox<T>
              • javafx.scene.control.DatePicker
            • javafx.scene.control.Labeled
              • javafx.scene.control.ButtonBase
                • javafx.scene.control.Button
                • javafx.scene.control.CheckBox
                • javafx.scene.control.Hyperlink
                • javafx.scene.control.MenuButton
                  • javafx.scene.control.SplitMenuButton
                • javafx.scene.control.ToggleButton (implements javafx.scene.control.Toggle)
                  • javafx.scene.control.RadioButton
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.DateCell
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.ListCell<T>
                  • javafx.scene.control.TableCell<S,T>
                  • javafx.scene.control.TableRow<T>
                  • javafx.scene.control.TreeCell<T>
                  • javafx.scene.control.TreeTableCell<S,T>
                  • javafx.scene.control.TreeTableRow<T>
              • javafx.scene.control.Label
              • javafx.scene.control.TitledPane
            • javafx.scene.control.ListView<T>
            • javafx.scene.control.MenuBar
            • javafx.scene.control.Pagination
            • javafx.scene.control.ProgressIndicator
              • javafx.scene.control.ProgressBar
            • javafx.scene.control.ScrollBar
            • javafx.scene.control.ScrollPane
            • javafx.scene.control.Separator
            • javafx.scene.control.Slider
            • javafx.scene.control.Spinner<T>
            • javafx.scene.control.SplitPane
            • javafx.scene.control.TableView<S>
            • javafx.scene.control.TabPane
            • javafx.scene.control.TextInputControl
              • javafx.scene.control.TextArea
              • javafx.scene.control.TextField
                • javafx.scene.control.PasswordField
            • javafx.scene.control.ToolBar
            • javafx.scene.control.TreeTableView<S>
            • javafx.scene.control.TreeView<T>
          • javafx.scene.layout.Pane
            • javafx.scene.control.DialogPane
            • javafx.scene.control.PopupControl.CSSBridge
    • javafx.scene.control.ResizeFeaturesBase<S>
      • javafx.scene.control.TableView.ResizeFeatures<S>
      • javafx.scene.control.TreeTableView.ResizeFeatures<S>
    • javafx.scene.control.SelectionModel<T>
      • javafx.scene.control.MultipleSelectionModel<T>
        • javafx.scene.control.TableSelectionModel<T>
          • javafx.scene.control.TableView.TableViewSelectionModel<S>
          • javafx.scene.control.TreeTableView.TreeTableViewSelectionModel<S>
      • javafx.scene.control.SingleSelectionModel<T>
    • javafx.scene.control.SkinBase<C> (implements javafx.scene.control.Skin<C>)
    • javafx.scene.control.SpinnerValueFactory<T>
      • javafx.scene.control.SpinnerValueFactory.DoubleSpinnerValueFactory
      • javafx.scene.control.SpinnerValueFactory.IntegerSpinnerValueFactory
      • javafx.scene.control.SpinnerValueFactory.ListSpinnerValueFactory<T>
    • javafx.scene.control.SplitPane.Divider
    • javafx.scene.control.Tab (implements javafx.event.EventTarget, javafx.css.Styleable)
    • javafx.scene.control.TableColumn.CellDataFeatures<S,T>
    • javafx.scene.control.TableColumnBase<S,T> (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.control.TableColumn<S,T> (implements javafx.event.EventTarget)
      • javafx.scene.control.TreeTableColumn<S,T> (implements javafx.event.EventTarget)
    • javafx.scene.control.TablePositionBase<TC>
      • javafx.scene.control.TablePosition<S,T>
      • javafx.scene.control.TreeTablePosition<S,T>
    • javafx.scene.control.TextFormatter<V>
    • javafx.scene.control.TextFormatter.Change (implements java.lang.Cloneable)
    • javafx.scene.control.ToggleGroup
    • javafx.scene.control.TreeItem<T> (implements javafx.event.EventTarget)
      • javafx.scene.control.CheckBoxTreeItem<T>
    • javafx.scene.control.TreeTableColumn.CellDataFeatures<S,T>
    • javafx.stage.Window (implements javafx.event.EventTarget)
      • javafx.stage.PopupWindow
        • javafx.scene.control.PopupControl (implements javafx.scene.control.Skinnable, javafx.css.Styleable)
          • javafx.scene.control.ContextMenu
          • javafx.scene.control.Tooltip

Interface Hierarchy

  • javafx.beans.Observable
    • javafx.beans.value.ObservableValue<T>
      • javafx.beans.value.ObservableObjectValue<T>
        • javafx.beans.value.ObservableStringValue
          • javafx.scene.control.TextInputControl.Content
  • javafx.scene.control.Skin<C>
  • javafx.scene.control.Skinnable
  • javafx.scene.control.Toggle

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.control.Alert.AlertType
      • javafx.scene.control.ButtonBar.ButtonData
      • javafx.scene.control.ContentDisplay
      • javafx.scene.control.OverrunStyle
      • javafx.scene.control.ScrollPane.ScrollBarPolicy
      • javafx.scene.control.SelectionMode
      • javafx.scene.control.TableColumn.SortType
      • javafx.scene.control.TabPane.TabClosingPolicy
      • javafx.scene.control.TreeSortMode
      • javafx.scene.control.TreeTableColumn.SortType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Label (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Label

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Label
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class Label
extends Labeled
    标签是不可编辑的文本控件。 标签对于显示适合特定空间所需的文本很有用，因此可能需要使用省略号或截断来对字符串进行匹配。 标签也是有用的，因为他们可以使用助记符，如果使用，将把焦点发送到作为labelFor属性的目标列出的控件。

    标签集focusTraversable为false。

    例：

      Label label = new Label("a label");
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Node> labelFor
      标签可以作为不同控件或节点的标签。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Label​()
      创建一个空标签
      Label​(String text)
      创建带有提供文本的标签。
      Label​(String text, Node graphic)
      使用提供的文本和图形创建标签。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      Node getLabelFor​()
      获取属性labelFor的值。
      ObjectProperty<Node> labelForProperty​()
      标签可以作为不同控件或节点的标签。
      void setLabelFor​(Node value)
      设置属性labelFor的值。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • labelFor

        public ObjectProperty<Node> labelForProperty
        标签可以作为不同控件或节点的标签。 这用于助记符和加速器解析。 这允许设置目标节点。
        另请参见：
        getLabelFor() ， setLabelFor(Node)

    • 构造方法详细信息

      • Label

        public Label​()
        创建一个空标签

      • Label

        public Label​(String text)
        创建带有提供文本的标签。
        参数
        text - 空文本被视为空字符串

      • Label

        public Label​(String text,
             Node graphic)
        使用提供的文本和图形创建标签。
        参数
        text - 空文本被视为空字符串
        graphic - 一个空图形是可以接受的

    • 方法详细信息

      • labelForProperty

        public ObjectProperty<Node> labelForProperty​()
        标签可以作为不同控件或节点的标签。 这用于助记符和加速器解析。 这允许设置目标节点。
        另请参见：
        getLabelFor() ， setLabelFor(Node)

      • setLabelFor

        public final void setLabelFor​(Node value)
        设置属性labelFor的值。
        Property description:
        标签可以作为不同控件或节点的标签。 这用于助记符和加速器解析。 这允许设置目标节点。

      • getLabelFor

        public final Node getLabelFor​()
        获取属性labelFor的值。
        Property description:
        标签可以作为不同控件或节点的标签。 这用于助记符和加速器解析。 这允许设置目标节点。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Labeled (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Labeled

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    ButtonBase ， Cell ， Label ， TitledPane

    @DefaultProperty("text")
public abstract class Labeled
extends Control
    标签Control是其用户界面的一部分，与其相关联的文本内容。 例如， Button个显示text ，象一个Label ，一个Tooltip ，以及许多其他的控制。

    标签也是一个方便的基类，当构建新的控件时，作为其UI的一部分，显示只读文本内容。

    示例如何在文本上方放置图形：

       Image image = new Image(getClass().getResourceAsStream("image.png")); ImageView imageView = new ImageView(); imageView.setImage(image); Label label = new Label("text", imageView); label.setContentDisplay(ContentDisplay.TOP);
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Button ， Label ， ToggleButton

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Pos> alignment
      指定Labeled内的空格时如何对齐Labeled中的文本和图形。
      ObjectProperty<ContentDisplay> contentDisplay
      指定图形相对于文本的位置。
      StringProperty ellipsisString
      指定在文本被截断时为省略号显示的字符串。
      ObjectProperty<Font> font
      用于标签中文本的默认字体。
      ObjectProperty<Node> graphic
      标签的可选图标。
      DoubleProperty graphicTextGap
      图形和文字之间的空间量
      ReadOnlyObjectProperty<Insets> labelPadding
      标签周围的文字和图形内容。
      DoubleProperty lineSpacing
      指定行之间的像素间距。
      BooleanProperty mnemonicParsing
      助记符属性启用/禁用文本解析。
      ObjectProperty<TextAlignment> textAlignment
      指定 文本行多行的文本 行与 contentDisplayProperty()影响图形和文本的行为不同，此设置仅影响文本边界的多行文本。
      ObjectProperty<Paint> textFill
      Paint用于填写文字。
      ObjectProperty<OverrunStyle> textOverrun
      指定 Labeled的文本超过可用空间来呈现文本时使用的行为。
      StringProperty text
      要在标签中显示的文字。
      BooleanProperty underline
      是否所有文本都应加下划线。
      BooleanProperty wrapText
      如果文本运行超过了标签的宽度，则该变量指示文本是否应该包装到另一行。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Labeled​()
      创建一个没有文字和图形的标签
      Labeled​(String text)
      创建带有文本的标签
      Labeled​(String text, Node graphic)
      创建带有文本和图形的标签

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Pos> alignmentProperty​()
      指定Labeled内的空格时如何对齐Labeled中的文本和图形。
      ObjectProperty<ContentDisplay> contentDisplayProperty​()
      指定图形相对于文本的位置。
      StringProperty ellipsisStringProperty​()
      指定在文本被截断时为省略号显示的字符串。
      ObjectProperty<Font> fontProperty​()
      用于标签中文本的默认字体。
      Pos getAlignment​()
      获取属性对齐的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Orientation getContentBias​()
      如果wrapText为true，则contentBias将为HORIZONTAL，否则为null。
      ContentDisplay getContentDisplay​()
      获取属性contentDisplay的值。
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      String getEllipsisString​()
      获取属性ellipsisString的值。
      Font getFont​()
      获取属性字体的值。
      Node getGraphic​()
      获取属性图形的值。
      double getGraphicTextGap​()
      获取属性graphicTextGap的值。
      protected Pos getInitialAlignment​()
      返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。
      Insets getLabelPadding​()
      获取属性labelPadding的值。
      double getLineSpacing​()
      获取属性lineSpacing的值。
      String getText​()
      获取属性文本的值。
      TextAlignment getTextAlignment​()
      获取属性textAlignment的值。
      Paint getTextFill​()
      获取属性textFill的值。
      OverrunStyle getTextOverrun​()
      获取textOverrun属性的值。
      ObjectProperty<Node> graphicProperty​()
      标签的可选图标。
      DoubleProperty graphicTextGapProperty​()
      图形和文字之间的空间量
      boolean isMnemonicParsing​()
      获取属性mnemonicParsing的值。
      boolean isUnderline​()
      获取属性下划线的值。
      boolean isWrapText​()
      获取propertyTextText的值。
      ReadOnlyObjectProperty<Insets> labelPaddingProperty​()
      标签周围的文字和图形内容。
      DoubleProperty lineSpacingProperty​()
      指定行之间的像素间距。
      BooleanProperty mnemonicParsingProperty​()
      助记符属性启用/禁用文本解析。
      void setAlignment​(Pos value)
      设置属性对齐的值。
      void setContentDisplay​(ContentDisplay value)
      设置属性contentDisplay的值。
      void setEllipsisString​(String value)
      设置属性ellipsisString的值。
      void setFont​(Font value)
      设置属性字体的值。
      void setGraphic​(Node value)
      设置属性图形的值。
      void setGraphicTextGap​(double value)
      设置属性graphicTextGap的值。
      void setLineSpacing​(double value)
      设置属性lineSpacing的值。
      void setMnemonicParsing​(boolean value)
      设置属性mnemonicParsing的值。
      void setText​(String value)
      设置属性文本的值。
      void setTextAlignment​(TextAlignment value)
      设置textAlignment属性的值。
      void setTextFill​(Paint value)
      设置属性textFill的值。
      void setTextOverrun​(OverrunStyle value)
      设置textOverrun属性的值。
      void setUnderline​(boolean value)
      设置属性下划线的值。
      void setWrapText​(boolean value)
      设置属性wrapText的值。
      ObjectProperty<TextAlignment> textAlignmentProperty​()
      指定 文本行多 行时的 行文行与影响图形和文本的 contentDisplayProperty()不同，此设置仅影响文本边界的多行文本。
      ObjectProperty<Paint> textFillProperty​()
      Paint用于填写文字。
      ObjectProperty<OverrunStyle> textOverrunProperty​()
      指定 Labeled的文本超过可用空间来呈现文本时使用的行为。
      StringProperty textProperty​()
      要在标签中显示的文字。
      String toString​()
      返回对象的字符串表示形式。
      BooleanProperty underlineProperty​()
      是否所有文本都应加下划线。
      BooleanProperty wrapTextProperty​()
      如果文本运行超过了标签的宽度，则该变量指示文本是否应该包装到另一行。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, createDefaultSkin, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • text

        public final StringProperty textProperty
        要在标签中显示的文字。 文本可能为null。
        另请参见：
        getText() ， setText(String)

      • alignment

        public final ObjectProperty<Pos> alignmentProperty
        指定Labeled内的空格时如何对齐Labeled中的文本和图形。
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • textAlignment

        public final ObjectProperty<TextAlignment> textAlignmentProperty
        指定 文本行多 行时的文本行行为不同于影响图形和文本的 contentDisplayProperty() ，此设置仅影响文本边界的多行文本。
        另请参见：
        getTextAlignment() ， setTextAlignment(TextAlignment)

      • textOverrun

        public final ObjectProperty<OverrunStyle> textOverrunProperty
        指定 Labeled的文本超过可用空间进行渲染时使用的行为。
        另请参见：
        getTextOverrun() ， setTextOverrun(OverrunStyle)

      • ellipsisString

        public final StringProperty ellipsisStringProperty
        指定在文本被截断时为省略号显示的字符串。 Ellipsis Table Examples "..." Default value for most locales " . . . " " [...] " "\u2026" The Unicode ellipsis character '…' "" No ellipsis, just display the truncated string

        请注意，并非所有字体都支持所有Unicode字符。

        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getEllipsisString() ， setEllipsisString(String)

      • wrapText

        public final BooleanProperty wrapTextProperty
        如果文本运行超过了标签的宽度，则该变量指示文本是否应该包装到另一行。
        另请参见：
        isWrapText() ， setWrapText(boolean)

      • font

        public final ObjectProperty<Font> fontProperty
        用于标签中文本的默认字体。 如果Label的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用该字体，但是在任何需要默认字体的情况下，将使用该字体。
        另请参见：
        getFont() ， setFont(Font)

      • graphic

        public final ObjectProperty<Node> graphicProperty
        标签的可选图标。 这可以通过使用setContentDisplay(javafx.scene.control.ContentDisplay)相对于文本定位 。 为此变量指定的节点不能出现在场景图中的其他IllegalArgumentException ，否则抛出IllegalArgumentException 。 有关详细信息，请参阅Node的类描述。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • underline

        public final BooleanProperty underlineProperty
        是否所有文本都应加下划线。
        另请参见：
        isUnderline() ， setUnderline(boolean)

      • lineSpacing

        public final DoubleProperty lineSpacingProperty
        指定行之间的像素间距。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getLineSpacing() ， setLineSpacing(double)

      • contentDisplay

        public final ObjectProperty<ContentDisplay> contentDisplayProperty
        指定图形相对于文本的位置。
        另请参见：
        getContentDisplay() ， setContentDisplay(ContentDisplay)

      • labelPadding

        public final ReadOnlyObjectProperty<Insets> labelPaddingProperty
        标签周围的文字和图形内容。 默认情况下labelPadding为Insets.EMPTY，不能设置为null。 子类可以在该填充之外添加节点，并在Labeled的填充内添加节点。 此属性只能从CSS设置。
        另请参见：
        getLabelPadding()

      • graphicTextGap

        public final DoubleProperty graphicTextGapProperty
        图形和文字之间的空间量
        另请参见：
        getGraphicTextGap() ， setGraphicTextGap(double)

      • textFill

        public final ObjectProperty<Paint> textFillProperty
        Paint用于填写文字。
        另请参见：
        getTextFill() ， setTextFill(Paint)

      • mnemonicParsing

        public final BooleanProperty mnemonicParsingProperty
        助记符属性启用/禁用文本解析。 如果设置为true，则将解析Label文本，以查看它是否包含助记符解析字符“_”。 当检测到助记符时，密钥组合将根据后续字符确定，并添加助记符。

        Labeled的默认值为false，但默认情况下在某些控件上启用。

        另请参见：
        isMnemonicParsing() ， setMnemonicParsing(boolean)

    • 构造方法详细信息

      • Labeled

        public Labeled​()
        创建一个没有文字和图形的标签

      • Labeled

        public Labeled​(String text)
        创建带有文本的标签
        参数
        text - 标签的文字。

      • Labeled

        public Labeled​(String text,
               Node graphic)
        创建带有文本和图形的标签
        参数
        text - 标签的文本。
        graphic - 标签的图形。

    • 方法详细信息

      • textProperty

        public final StringProperty textProperty​()
        要在标签中显示的文字。 文本可能为null。
        另请参见：
        getText() ， setText(String)

      • setText

        public final void setText​(String value)
        设置属性文本的值。
        Property description:
        要在标签中显示的文字。 文本可能为null。

      • getText

        public final String getText​()
        获取属性文本的值。
        Property description:
        要在标签中显示的文字。 文本可能为null。

      • alignmentProperty

        public final ObjectProperty<Pos> alignmentProperty​()
        指定Labeled内的空格时如何对齐Labeled中的文本和图形。
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • setAlignment

        public final void setAlignment​(Pos value)
        设置属性对齐的值。
        Property description:
        指定Labeled内的空格时如何对齐Labeled中的文本和图形。

      • getAlignment

        public final Pos getAlignment​()
        获取属性对齐的值。
        Property description:
        指定Labeled内的空格时如何对齐Labeled中的文本和图形。

      • textAlignmentProperty

        public final ObjectProperty<TextAlignment> textAlignmentProperty​()
        指定 文本行多行的文本 行与 contentDisplayProperty()影响图形和文本的行为不同，此设置仅影响文本边界的多行文本。
        另请参见：
        getTextAlignment() ， setTextAlignment(TextAlignment)

      • setTextAlignment

        public final void setTextAlignment​(TextAlignment value)
        设置textAlignment属性的值。
        Property description:
        指定 文本行多 行时的文本行的行为与影响图形和文本的 contentDisplayProperty()不同，此设置仅影响文本边界的多行文本。

      • getTextAlignment

        public final TextAlignment getTextAlignment​()
        获取属性textAlignment的值。
        Property description:
        指定 文本行多 行时的文本行行为不同于影响图形和文本的 contentDisplayProperty() ，此设置仅影响文本边界的多行文本。

      • textOverrunProperty

        public final ObjectProperty<OverrunStyle> textOverrunProperty​()
        指定 Labeled的文本超过可用空间进行渲染时使用的行为。
        另请参见：
        getTextOverrun() ， setTextOverrun(OverrunStyle)

      • setTextOverrun

        public final void setTextOverrun​(OverrunStyle value)
        设置textOverrun属性的值。
        Property description:
        指定 Labeled的文本超过可用空间进行渲染时使用的行为。

      • getTextOverrun

        public final OverrunStyle getTextOverrun​()
        获取textOverrun属性的值。
        Property description:
        指定 Labeled的文本超过可用空间来呈现文本时使用的行为。

      • ellipsisStringProperty

        public final StringProperty ellipsisStringProperty​()
        指定在文本被截断时为省略号显示的字符串。 Ellipsis Table Examples "..." Default value for most locales " . . . " " [...] " "\u2026" The Unicode ellipsis character '…' "" No ellipsis, just display the truncated string

        请注意，并非所有字体都支持所有Unicode字符。

        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getEllipsisString() ， setEllipsisString(String)

      • setEllipsisString

        public final void setEllipsisString​(String value)
        设置属性ellipsisString的值。
        Property description:
        指定在文本被截断时为省略号显示的字符串。 Ellipsis Table Examples "..." Default value for most locales " . . . " " [...] " "\u2026" The Unicode ellipsis character '…' "" No ellipsis, just display the truncated string

        请注意，并非所有字体都支持所有Unicode字符。

        从以下版本开始：
        JavaFX 2.2

      • getEllipsisString

        public final String getEllipsisString​()
        获取属性ellipsisString的值。
        Property description:
        指定在文本被截断时为省略号显示的字符串。 Ellipsis Table Examples "..." Default value for most locales " . . . " " [...] " "\u2026" The Unicode ellipsis character '…' "" No ellipsis, just display the truncated string

        请注意，并非所有字体都支持所有Unicode字符。

        从以下版本开始：
        JavaFX 2.2

      • wrapTextProperty

        public final BooleanProperty wrapTextProperty​()
        如果文本运行超过了标签的宽度，则该变量指示文本是否应该包装到另一行。
        另请参见：
        isWrapText() ， setWrapText(boolean)

      • setWrapText

        public final void setWrapText​(boolean value)
        设置属性wrapText的值。
        Property description:
        如果文本运行超过了标签的宽度，则该变量指示文本是否应该包装到另一行。

      • isWrapText

        public final boolean isWrapText​()
        获取propertyTextText的值。
        Property description:
        如果文本运行超过了标签的宽度，则该变量指示文本是否应该包装到另一行。

      • getContentBias

        public Orientation getContentBias​()
        如果wrapText为true，则contentBias将为HORIZONTAL，否则为null。
        重写：
        getContentBias在 Node
        结果
        width / height依赖的方向，如果没有则为null
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • fontProperty

        public final ObjectProperty<Font> fontProperty​()
        用于标签中文本的默认字体。 如果Label的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用该字体，但是在任何需要默认字体的情况下，将使用该字体。
        另请参见：
        getFont() ， setFont(Font)

      • setFont

        public final void setFont​(Font value)
        设置属性字体的值。
        Property description:
        用于标签中文本的默认字体。 如果Label的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用该字体，但是在任何需要默认字体的情况下，将使用该字体。

      • getFont

        public final Font getFont​()
        获取属性字体的值。
        Property description:
        用于标签中文本的默认字体。 如果Label的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用该字体，但是在任何需要默认字体的情况下，将使用该字体。

      • graphicProperty

        public final ObjectProperty<Node> graphicProperty​()
        标签的可选图标。 这可以通过使用setContentDisplay(javafx.scene.control.ContentDisplay)相对于文本进行定位 。 为此变量指定的节点不能出现在场景图中的其他IllegalArgumentException ，否则抛出IllegalArgumentException 。 有关详细信息，请参阅Node的类描述。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • setGraphic

        public final void setGraphic​(Node value)
        设置属性图形的值。
        Property description:
        标签的可选图标。 这可以通过使用setContentDisplay(javafx.scene.control.ContentDisplay)相对于文本进行定位 。 为此变量指定的节点不能出现在场景图中的其他IllegalArgumentException ，否则抛出IllegalArgumentException 。 有关详细信息，请参阅Node的类描述。

      • getGraphic

        public final Node getGraphic​()
        获取属性图形的值。
        Property description:
        标签的可选图标。 这可以通过使用setContentDisplay(javafx.scene.control.ContentDisplay)相对于文本进行定位 。 为此变量指定的节点不能出现在场景图中的其他IllegalArgumentException ，否则抛出IllegalArgumentException 。 有关详细信息，请参阅Node的类描述。

      • underlineProperty

        public final BooleanProperty underlineProperty​()
        是否所有文本都应加下划线。
        另请参见：
        isUnderline() ， setUnderline(boolean)

      • setUnderline

        public final void setUnderline​(boolean value)
        设置属性下划线的值。
        Property description:
        是否所有文本都应加下划线。

      • isUnderline

        public final boolean isUnderline​()
        获取属性下划线的值。
        Property description:
        是否所有文本都应加下划线。

      • lineSpacingProperty

        public final DoubleProperty lineSpacingProperty​()
        指定行之间的像素间距。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getLineSpacing() ， setLineSpacing(double)

      • setLineSpacing

        public final void setLineSpacing​(double value)
        设置属性lineSpacing的值。
        Property description:
        指定行之间的像素间距。
        从以下版本开始：
        JavaFX 8.0

      • getLineSpacing

        public final double getLineSpacing​()
        获取属性lineSpacing的值。
        Property description:
        指定行之间的像素间距。
        从以下版本开始：
        JavaFX 8.0

      • contentDisplayProperty

        public final ObjectProperty<ContentDisplay> contentDisplayProperty​()
        指定图形相对于文本的位置。
        另请参见：
        getContentDisplay() ， setContentDisplay(ContentDisplay)

      • setContentDisplay

        public final void setContentDisplay​(ContentDisplay value)
        设置属性contentDisplay的值。
        Property description:
        指定图形相对于文本的位置。

      • getContentDisplay

        public final ContentDisplay getContentDisplay​()
        获取属性contentDisplay的值。
        Property description:
        指定图形相对于文本的位置。

      • labelPaddingProperty

        public final ReadOnlyObjectProperty<Insets> labelPaddingProperty​()
        标签周围的文字和图形内容。 默认情况下labelPadding为Insets.EMPTY，不能设置为null。 子类可以在该填充之外添加节点，并在Labeled的填充内添加节点。 此属性只能从CSS设置。
        另请参见：
        getLabelPadding()

      • getLabelPadding

        public final Insets getLabelPadding​()
        获取属性labelPadding的值。
        Property description:
        标签周围的文字和图形内容。 默认情况下labelPadding为Insets.EMPTY，不能设置为null。 子类可以在该填充之外添加节点，并在Labeled的填充内添加节点。 此属性只能从CSS设置。

      • graphicTextGapProperty

        public final DoubleProperty graphicTextGapProperty​()
        图形和文字之间的空间量
        另请参见：
        getGraphicTextGap() ， setGraphicTextGap(double)

      • setGraphicTextGap

        public final void setGraphicTextGap​(double value)
        设置属性graphicTextGap的值。
        Property description:
        图形和文字之间的空间量

      • getGraphicTextGap

        public final double getGraphicTextGap​()
        获取属性graphicTextGap的值。
        Property description:
        图形和文字之间的空间量

      • setTextFill

        public final void setTextFill​(Paint value)
        设置属性textFill的值。
        Property description:
        Paint用于填写文字。

      • getTextFill

        public final Paint getTextFill​()
        获取属性textFill的值。
        Property description:
        Paint用于填写文字。

      • textFillProperty

        public final ObjectProperty<Paint> textFillProperty​()
        Paint用于填写文字。
        另请参见：
        getTextFill() ， setTextFill(Paint)

      • setMnemonicParsing

        public final void setMnemonicParsing​(boolean value)
        设置属性mnemonicParsing的值。
        Property description:
        助记符属性启用/禁用文本解析。 如果设置为true，则将解析Label文本，以查看它是否包含助记符解析字符“_”。 当检测到助记符时，密钥组合将根据后续字符确定，并添加助记符。

        Labeled的默认值为false，但默认情况下在某些控件上启用。

      • isMnemonicParsing

        public final boolean isMnemonicParsing​()
        获取属性mnemonicParsing的值。
        Property description:
        助记符属性启用/禁用文本解析。 如果设置为true，则将解析Label文本，以查看它是否包含助记符解析字符“_”。 当检测到助记符时，密钥组合将根据后续字符确定，并添加助记符。

        Labeled的默认值为false，但默认情况下在某些控件上启用。

      • mnemonicParsingProperty

        public final BooleanProperty mnemonicParsingProperty​()
        助记符属性启用/禁用文本解析。 如果设置为true，则将解析Label文本，以查看它是否包含助记符解析字符“_”。 当检测到助记符时，密钥组合将根据后续字符确定，并添加助记符。

        Labeled的默认值为false，但默认情况下在某些控件上启用。

        另请参见：
        isMnemonicParsing() ， setMnemonicParsing(boolean)

      • toString

        public String toString​()
        说明从类别复制Node
        返回对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        对象的字符串表示形式。

      • getInitialAlignment

        protected Pos getInitialAlignment​()
        返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。 该方法最初被覆盖使用Pos.CENTER_LEFT。
        结果
        该控件的初始对齐状态
        从以下版本开始：
        9

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ListCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.ListCell<T>
  • 参数类型
    T - ListCell中包含的项目的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    CheckBoxListCell ， ChoiceBoxListCell ， ComboBoxListCell ， TextFieldListCell

    public class ListCell<T>
extends IndexedCell<T>

    Cell类型在ListView实例中使用。 除了在Cell和IndexedCell上定义的API 之外 ，ListCell更紧密地绑定到ListView，从而更好地支持编辑事件等。

    ListView维护选择，指示已选择哪些单元格，并对焦，指示任何给定ListView的当前焦点所有者。 对于每个属性，每个ListCell都有一个布尔值，反映该特定单元格是被选中还是聚焦。 为了实现这一点，每个ListCell都有一个引用到ListView，它被使用在它内部。 每个ListCell属于唯一的一个ListView。

    请注意，在虚拟化控件（如ListView）的情况下，当单元格具有焦点时，这与应用程序焦点的含义不一样。 当ListCell具有焦点时，它只是表示在拥有ListView实际包含焦点的情况下，单元格将接收键盘事件的事实。 当然，在一个小区在graphic属性中设置了一个节点的情况下，这个节点要求和获取焦点是完全合法的，如通常所预期的那样。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<ListView<T>> listView
      与此单元格关联的ListView。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListCell​()
      使用默认样式类“list-cell”创建默认的ListCell。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      void commitEdit​(T newValue)
      在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      ListView<T> getListView​()
      获取属性listView的值。
      ReadOnlyObjectProperty<ListView<T>> listViewProperty​()
      与此单元格关联的ListView。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateListView​(ListView<T> listView)
      更新与此单元格关联的ListView。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • listView

        public final ReadOnlyObjectProperty<ListView<T>> listViewProperty
        与此单元格关联的ListView。
        另请参见：
        getListView()

    • 构造方法详细信息

      • ListCell

        public ListCell​()
        使用默认样式类“list-cell”创建默认的ListCell。

    • 方法详细信息

      • getListView

        public final ListView<T> getListView​()
        获取属性listView的值。
        Property description:
        与此单元格关联的ListView。

      • listViewProperty

        public final ReadOnlyObjectProperty<ListView<T>> listViewProperty​()
        与此单元格关联的ListView。
        另请参见：
        getListView()

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或在具有setSkin(...)的子类中显式设置，则会调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 Cell<T>

      • commitEdit

        public void commitEdit​(T newValue)
        在适当的时候调用此功能（基于您的单元格编辑用户界面的用户交互要求）来做两件事情：
        1. 将适当的事件触发回到支持UI控件（例如ListView ）。 这将开始将此编辑推回相关数据源/属性（尽管不能保证这将成功 - 这取决于正在使用的特定编辑提交处理程序）。 有关更多详细信息，请参阅UI控件类javadoc。
        2. 开始从编辑状态转换到非编辑状态。

        一般来说，在自定义单元实现中无需重写此方法 - 在适当的时候简单地调用此方法就足够了（例如，当用户按下Enter键时，您可以使用像cell.commitEdit(converter.fromString(textField.getText()));

        重写：
        commitEdit在 Cell<T>
        参数
        newValue - 作为最终用户输入的值，应该以相关的方式 newValue给出支持用户界面的数据源和UI控件的安装编辑提交处理程序。

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 Cell<T>

      • updateListView

        public final void updateListView​(ListView<T> listView)
        更新与此单元格关联的ListView。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        listView - 与此单元格关联的ListView

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 参数的可选列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction Control
        参数
        action - 要执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ListView<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ListView<T>
  • 参数类型
    T - 此类型用于表示存储在ListViews items ObservableList中的对象的类型。 它也用于selection model和focus model 。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("items")
public class ListView<T>
extends Control
    ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。 ListView能够将其通用类型设置为表示后台模型中的数据类型。 这样做有利于在ListView中进行各种方法以及支持类（如下所述），类型安全。 此外，使用通用类型支持使用ListView的应用程序的大大简化开发，因为所有现代IDE都能够更加成功地使用附加类型信息自动完成。

    填充ListView

    如何创建和填充ListView的名称（Strings）的简单示例如下所示：

       ObservableList<String> names = FXCollections.observableArrayList( "Julia", "Ian", "Sue", "Matthew", "Hannah", "Stephan", "Denise"); ListView<String> listView = new ListView<String>(names);

    ListView的元素包含在items ObservableList中 。 这个ObservableList由ListView自动观察到，这样ObservableList中发生的任何更改都将自动显示在ListView本身中。 如果将ObservableList传递给ListView构造函数是不可行的，那么设置项目的推荐方法是简单地调用：

       ObservableList<T> content = ... listView.setItems(content);
    最后的结果是，如上所述，ListView将自动刷新视图来表示列表中的项目。

    ListView接受的另一种方法不是推荐的方法 ：

       List<T> content = ... getItems().setAll(content);
    上述方法的问题是内容列表被复制到项目列表中 - 这意味着对内容列表的后续更改没有被观察到，并且不会在ListView中被视觉反映出来。

    ListView选择/焦点API

    要跟踪选择和重点，有必要熟悉SelectionModel和FocusModel类。 ListView最多只有一个这些类的一个实例，分别可从selectionModel和focusModel属性获得。 虽然可以使用此API来设置新的选择模型，但在大多数情况下，这不是必需的 - 默认选择和焦点模型应该在大多数情况下工作。

    实例化ListView时使用的默认值为SelectionModel是MultipleSelectionModel抽象类的实现。 但是，如selectionMode属性的API文档中所述，默认值为SelectionMode.SINGLE 。 要在默认ListView实例中启用多个选择，因此需要执行以下操作：

       listView.getSelectionModel().setSelectionMode(SelectionMode.MULTIPLE);

    自定义ListView视觉

    可以通过替换默认的cell factory完全自定义ListView的视觉效果。 一个单元格工厂用于生成ListCell个实例，用于表示ListView中的一个项目。 有关如何编写自定义单元格的更完整的说明，请参阅Cell类文档。

    编辑

    此控件支持值的内联编辑，本节尝试概述可用的API以及如何使用它们。

    首先，细胞编辑通常需要不同于不编辑细胞的用户界面。 这是正在使用的Cell实现的责任。 对于ListView，这是cell factory的责任。 您可以选择单元格是否永久处于编辑状态（例如，这对于CheckBox单元格是常见的），或者在编辑开始时切换到不同的UI（例如，在单元格上接收到双击时）。

    要知道在单元格上请求编辑时，只需覆盖Cell.startEdit()方法，并根据需要更新单元格text和graphic属性（例如，将文本设置为空，并将图形设置为TextField ）。 此外，您还应该覆盖Cell.cancelEdit()，以便在编辑结束时将UI重置为原始的可视状态。 在这两种情况下，重要的是您还要确保您调用超级方法以使单元格执行所有必须执行的任务，以进入或退出其编辑模式。

    一旦您的单元格处于编辑状态，您最感兴趣的下一件事就是如何提交或取消正在进行的编辑。 这是您作为电池厂商的责任。 您的单元实现将基于用户输入（例如当用户按下键盘上的Enter键或ESC键时）知道编辑结束。 发生这种情况时，您有责任酌情致电Cell.commitEdit(Object)或Cell.cancelEdit() 。

    当您拨打Cell.commitEdit(Object)一个事件触发到ListView，您可以通过setOnEditCommit(javafx.event.EventHandler)添加一个EventHandler来观察 。 同样，您还可以观察edit start和edit cancel的编辑事件。

    默认情况下，ListView编辑提交处理程序是非空的，默认处理程序会尝试覆盖当前正在编辑的行中的项目的属性值。 它可以这样做，因为Cell.commitEdit(Object)方法在新值中传递，并通过被触发的ListView.EditEvent传递给编辑提交处理程序。 这只是一个调用ListView.EditEvent.getNewValue()来检索这个值的问题。

    需要注意的是，如果你把它是非常重要的setOnEditCommit(javafx.event.EventHandler)用自己EventHandler ，那么你会删除默认的处理程序。 除非您再处理该属性（或相关数据源）的回写，否则不会发生任何事情。 您可以使用Node.addEventHandler(javafx.event.EventType, javafx.event.EventHandler)方法添加一个EDIT_COMMIT_EVENT EventType与您所需的EventHandler作为第二个参数。 使用此方法，您将不会替换默认实现，但在发生编辑提交时会收到通知。

    希望这个总结回答了一些常见问题。 幸运的是，JavaFX附带了许多预先构建的单元格工厂，可以代表您处理所有的编辑要求。 您可以在javafx.scene.control.cell包中找到这些预构建的单元工厂。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    ListCell ， MultipleSelectionModel ， FocusModel

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> cellFactory
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      BooleanProperty editable
      指定此ListView是否可编辑 - 只有当ListView和ListCells都可编辑时，ListCell才能进入编辑状态。
      ReadOnlyIntegerProperty editingIndex
      用于表示当前在ListView中编辑的项目的索引的属性（如果正在进行编辑），如果没有编辑任何项目，则用于表示-1。
      DoubleProperty fixedCellSize
      指定此控件是否具有固定高度（指定值）的单元格。
      ObjectProperty<FocusModel<T>> focusModel
      FocusModel提供了API，通过它可以获得并设置ListView中单个项目的焦点。
      ObjectProperty<ObservableList<T>> items
      ListView的底层数据模型。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditCancel
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditCommit
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditStart
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollTo
      当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<Orientation> orientation
      ListView的方向 - 这可以是水平还是垂直。
      ObjectProperty<Node> placeholder
      当列表视图没有显示的内容时，向用户显示该节点。
      ObjectProperty<MultipleSelectionModel<T>> selectionModel
      SelectionModel提供了可以在ListView中选择单个或多个项目的API，以及检查用户选择了哪些项目。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ListView.EditEvent<T>
      一个Event在ListView中专门用于表示编辑相关事件的子类。

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListView​()
      创建一个默认的ListView，它将显示垂直堆叠的内容。
      ListView​(ObservableList<T> items)
      创建一个默认的ListView，它将堆叠从垂直提供的ObservableList检索的内容。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> cellFactoryProperty​()
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void edit​(int itemIndex)
      如果ListView为 editable ，则指示ListView开始编辑给定索引中的项目。
      BooleanProperty editableProperty​()
      指定此ListView是否可编辑 - 只有当ListView和ListCells都可编辑时，ListCell才能进入编辑状态。
      static <T> EventType<ListView.EditEvent<T>> editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <T> EventType<ListView.EditEvent<T>> editCancelEvent​()
      一个EventType，用于指示在事件触发的ListView中刚刚取消了编辑事件。
      static <T> EventType<ListView.EditEvent<T>> editCommitEvent​()
      EventType用于指示已在触发事件的ListView中提交了编辑事件。
      ReadOnlyIntegerProperty editingIndexProperty​()
      用于表示当前在ListView中编辑的项目的索引的属性（如果正在进行编辑），如果没有编辑任何项目，则用于表示-1。
      static <T> EventType<ListView.EditEvent<T>> editStartEvent​()
      EventType用于指示在事件被触发的ListView中启动编辑事件。
      DoubleProperty fixedCellSizeProperty​()
      指定此控件是否具有固定高度（指定值）的单元格。
      ObjectProperty<FocusModel<T>> focusModelProperty​()
      FocusModel提供了API，通过它可以获得并设置ListView中单个项目的焦点。
      Callback<ListView<T>,ListCell<T>> getCellFactory​()
      返回当前的单元格工厂。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      int getEditingIndex​()
      返回ListView中当前正在编辑的项目的索引，如果没有编辑任何项目，则返回-1。
      double getFixedCellSize​()
      返回固定的单元格大小值。
      FocusModel<T> getFocusModel​()
      返回当前安装的FocusModel 。
      ObservableList<T> getItems​()
      返回一个ObservableList ，其中包含当前显示给用户的项目。
      EventHandler<ListView.EditEvent<T>> getOnEditCancel​()
      返回当用户取消编辑时将被调用的EventHandler 。
      EventHandler<ListView.EditEvent<T>> getOnEditCommit​()
      返回当用户提交编辑时将被调用的EventHandler 。
      EventHandler<ListView.EditEvent<T>> getOnEditStart​()
      返回当用户开始编辑时将被调用的EventHandler 。
      EventHandler<ScrollToEvent<Integer>> getOnScrollTo​()
      获取属性onScrollTo的值。
      Orientation getOrientation​()
      返回ListView的当前方向，它决定了它是垂直滚动还是水平滚动。
      Node getPlaceholder​()
      获取属性占位符的值。
      MultipleSelectionModel<T> getSelectionModel​()
      返回当前安装的选择模型。
      boolean isEditable​()
      获取可编辑属性的值。
      ObjectProperty<ObservableList<T>> itemsProperty​()
      ListView的底层数据模型。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditCommitProperty​()
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty​()
      当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<Orientation> orientationProperty​()
      ListView的方向 - 这可以是水平还是垂直。
      ObjectProperty<Node> placeholderProperty​()
      当列表视图没有显示的内容时，向用户显示该节点。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void refresh​()
      调用 refresh()强制ListView控件重新创建并重新填充填充控件的可视边界所需的单元格。
      void scrollTo​(int index)
      滚动ListView，使给定索引中的项目对最终用户可见。
      void scrollTo​(T object)
      滚动ListView，使给定对象在视口内可见。
      ObjectProperty<MultipleSelectionModel<T>> selectionModelProperty​()
      SelectionModel提供了可以在ListView中选择单个或多个项目的API，以及检查用户选择了哪些项目。
      void setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
      设置要在ListView中使用的新单元格工厂。
      void setEditable​(boolean value)
      设置属性可编辑的值。
      void setFixedCellSize​(double value)
      设置此控件的新固定单元格大小。
      void setFocusModel​(FocusModel<T> value)
      设置要在ListView中使用的FocusModel 。
      void setItems​(ObservableList<T> value)
      设置ListView的底层数据模型。
      void setOnEditCancel​(EventHandler<ListView.EditEvent<T>> value)
      设置当用户取消编辑时将被调用的EventHandler 。
      void setOnEditCommit​(EventHandler<ListView.EditEvent<T>> value)
      设置当用户完成编辑时将被调用的EventHandler 。
      void setOnEditStart​(EventHandler<ListView.EditEvent<T>> value)
      设置当用户开始编辑时将被调用的EventHandler 。
      void setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void setOrientation​(Orientation value)
      设置ListView的方向，它决定它是垂直滚动还是水平滚动。
      void setPlaceholder​(Node value)
      设置属性占位符的值。
      void setSelectionModel​(MultipleSelectionModel<T> value)
      设置要在ListView中使用的MultipleSelectionModel 。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • items

        public final ObjectProperty<ObservableList<T>> itemsProperty
        ListView的底层数据模型。 请注意，它具有必须与ListView本身类型匹配的通用类型。
        结果
        这个ListView的items属性

      • placeholder

        public final ObjectProperty<Node> placeholderProperty
        当列表视图没有显示的内容时，向用户显示该节点。 可能是这种情况，因为表模型首先没有数据，或者过滤器已经应用于列表模型，导致无法显示用户。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getPlaceholder() ， setPlaceholder(Node)

      • selectionModel

        public final ObjectProperty<MultipleSelectionModel<T>> selectionModelProperty
        SelectionModel提供了可以在ListView中选择单个或多个项目的API，以及检查用户选择了哪些项目。 请注意，它具有必须与ListView本身类型匹配的通用类型。
        另请参见：
        getSelectionModel() ， setSelectionModel(MultipleSelectionModel)

      • focusModel

        public final ObjectProperty<FocusModel<T>> focusModelProperty
        FocusModel提供了API，通过它可以获得并设置ListView中单个项目的焦点。 请注意，它具有必须与ListView本身类型匹配的通用类型。
        另请参见：
        getFocusModel() ， setFocusModel(FocusModel)

      • orientation

        public final ObjectProperty<Orientation> orientationProperty
        ListView的方向 - 这可以是水平还是垂直。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • cellFactory

        public final ObjectProperty<Callback<ListView<T>,ListCell<T>>> cellFactoryProperty

        设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。 在内部，ListView负责重用ListCells - 所有必要的是自定义单元格工厂从此函数返回可用于表示ListView中任何项目的ListCell。

        有关详细信息，请参阅Cell类文档。

        另请参见：
        getCellFactory() ， setCellFactory(Callback)

      • fixedCellSize

        public final DoubleProperty fixedCellSizeProperty
        指定此控件是否具有固定高度（指定值）的单元格。 如果该值小于或等于零，则所有单元格都被单独设置和定位。 这是一个缓慢的操作。 因此，当性能重要且开发人员不依赖于可变单元大小时，设置固定单元大小值是一个好主意。 一般情况下，单元格大约为24像素，因此设置固定的单元格大小为24可能导致视觉差异很小，但性能有所改善。

        要通过CSS设置此属性，请使用-fx-fixed-cell-size属性。 这不应该与-fx-cell-size属性混淆。 这两个CSS属性之间的区别是-fx-cell-size将所有单元格的大小设置为指定的大小，但不会强制这是唯一的大小（从而允许变量单元大小，并且阻止性能提升可能）。 因此，当性能很重要的时候使用-fx-fixed-cell-size，而不是-fx-cell-size。 如果在CSS中指定了两个属性，则-fx-fixed-cell-size优先。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • editable

        public final BooleanProperty editableProperty
        指定此ListView是否可编辑 - 只有当ListView和ListCells都可编辑时，ListCell才能进入编辑状态。
        另请参见：
        isEditable() ， setEditable(boolean)

      • editingIndex

        public final ReadOnlyIntegerProperty editingIndexProperty

        用于表示当前在ListView中编辑的项目的索引的属性（如果正在进行编辑），如果没有编辑任何项目，则用于表示-1。

        不可能设置编辑索引，而需要您调用edit(int) 。

        另请参见：
        getEditingIndex()

      • onEditStart

        public final ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditStartProperty
        当用户成功启动编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditStart() ， setOnEditStart(EventHandler)

      • onEditCommit

        public final ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditCommitProperty

        当用户执行应导致其编辑输入持久化的操作时，将使用此属性。

        此属性中的EventHandler不应该直接调用 - 而是从您的自定义ListCell中调用ListCell.commitEdit(java.lang.Object) 。 这将处理触发此事件，更新视图和切换编辑状态。

        另请参见：
        getOnEditCommit() ， setOnEditCommit(EventHandler)

      • onEditCancel

        public final ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditCancelProperty
        当用户取消编辑单元格时，将触发此事件处理程序。
        另请参见：
        getOnEditCancel() ， setOnEditCancel(EventHandler)

      • onScrollTo

        public ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty
        当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnScrollTo() ， setOnScrollTo(EventHandler)

    • 构造方法详细信息

      • ListView

        public ListView​()
        创建一个默认的ListView，它将显示垂直堆叠的内容。 由于在此构造函数中没有提供ObservableList ，因此创建一个空的ObservableList，这意味着如果需要，直接调用getItems()是合法的。 但是，如其他地方所述，这不是推荐的方法（而是调用setItems(javafx.collections.ObservableList) ）。

        有关其他属性的默认状态的详细信息，请参阅ListView类文档。

      • ListView

        public ListView​(ObservableList<T> items)
        创建一个默认的ListView，它将堆叠从垂直提供的ObservableList检索的内容。

        尝试将一个监听器添加到ObservableList ，以便列表中的所有后续更改将显示给用户。

        有关其他属性的默认状态的详细信息，请参阅ListView类文档。

        参数
        items - 项目列表

    • 方法详细信息

      • editAnyEvent

        public static <T> EventType<ListView.EditEvent<T>> editAnyEvent​()
        指示发生一些编辑事件的EventType。 这是所有其他编辑的事件父类型： EDIT_START_EVENT ， EDIT_COMMIT_EVENT和EDIT_CANCEL_EVENT 。
        参数类型
        T - 存储在此ListView中的对象的类型
        结果
        事件类型

      • editStartEvent

        public static <T> EventType<ListView.EditEvent<T>> editStartEvent​()
        EventType用于指示在事件被触发的ListView中启动编辑事件。
        参数类型
        T - 存储在此ListView中的对象的类型
        结果
        事件类型

      • editCancelEvent

        public static <T> EventType<ListView.EditEvent<T>> editCancelEvent​()
        一个EventType，用于指示在事件触发的ListView中刚刚取消了编辑事件。
        参数类型
        T - 存储在此ListView中的对象的类型
        结果
        事件类型

      • editCommitEvent

        public static <T> EventType<ListView.EditEvent<T>> editCommitEvent​()
        EventType用于指示已在触发事件的ListView中提交了编辑事件。
        参数类型
        T - 存储在此ListView中的对象的类型
        结果
        事件类型

      • setItems

        public final void setItems​(ObservableList<T> value)
        设置ListView的底层数据模型。 请注意，它具有必须与ListView本身类型匹配的通用类型。
        参数
        value - 此ListView的项目列表

      • getItems

        public final ObservableList<T> getItems​()
        返回一个ObservableList ，其中包含当前向用户显示的项目。 如果先前已经调用了setItems(javafx.collections.ObservableList)，这可能为null，但是默认情况下，它是一个空的ObservableList。
        结果
        包含要显示给用户的项目的ObservableList，如果项目以前设置为null，则为null。

      • itemsProperty

        public final ObjectProperty<ObservableList<T>> itemsProperty​()
        ListView的底层数据模型。 请注意，它具有必须与ListView本身类型匹配的通用类型。
        结果
        这个ListView的items属性

      • placeholderProperty

        public final ObjectProperty<Node> placeholderProperty​()
        当列表视图没有显示的内容时，向用户显示该节点。 可能是这种情况，因为表模型首先没有数据，或者过滤器已经应用于列表模型，导致无法显示用户。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getPlaceholder() ， setPlaceholder(Node)

      • setPlaceholder

        public final void setPlaceholder​(Node value)
        设置属性占位符的值。
        Property description:
        当列表视图没有显示的内容时，向用户显示该节点。 可能是这种情况，因为表模型首先没有数据，或者过滤器已经应用于列表模型，导致无法显示用户。
        从以下版本开始：
        JavaFX 8.0

      • getPlaceholder

        public final Node getPlaceholder​()
        获取属性占位符的值。
        Property description:
        当列表视图没有显示的内容时，向用户显示该节点。 可能是这种情况，因为表模型首先没有数据，或者过滤器已经应用于列表模型，导致无法显示用户。
        从以下版本开始：
        JavaFX 8.0

      • setSelectionModel

        public final void setSelectionModel​(MultipleSelectionModel<T> value)
        设置要在ListView中使用的MultipleSelectionModel 。 尽管需要使用多个 SelectionModel的ListView，但可以将其配置为仅允许单次选择（有关详细信息，请参阅MultipleSelectionModel.setSelectionMode(javafx.scene.control.SelectionMode) ）。
        参数
        value - 要在此ListView中使用的MultipleSelectionModel

      • getSelectionModel

        public final MultipleSelectionModel<T> getSelectionModel​()
        返回当前安装的选择模型。
        结果
        当前安装的选择模型

      • selectionModelProperty

        public final ObjectProperty<MultipleSelectionModel<T>> selectionModelProperty​()
        SelectionModel提供了可以在ListView中选择单个或多个项目的API，以及检查用户选择了哪些项目。 请注意，它具有必须与ListView本身类型匹配的通用类型。
        另请参见：
        getSelectionModel() ， setSelectionModel(MultipleSelectionModel)

      • setFocusModel

        public final void setFocusModel​(FocusModel<T> value)
        设置要在ListView中使用的FocusModel 。
        参数
        value - 要在ListView中使用的FocusModel

      • getFocusModel

        public final FocusModel<T> getFocusModel​()
        返回当前安装的FocusModel 。
        结果
        当前安装的FocusModel

      • focusModelProperty

        public final ObjectProperty<FocusModel<T>> focusModelProperty​()
        FocusModel提供了API，通过它可以获得并设置ListView中单个项目的焦点。 请注意，它具有必须与ListView本身类型匹配的通用类型。
        另请参见：
        getFocusModel() ， setFocusModel(FocusModel)

      • setOrientation

        public final void setOrientation​(Orientation value)
        设置ListView的方向，它决定它是垂直滚动还是水平滚动。
        参数
        value - ListView的方向

      • getOrientation

        public final Orientation getOrientation​()
        返回ListView的当前方向，它决定了它是垂直滚动还是水平滚动。
        结果
        ListView的当前方向

      • orientationProperty

        public final ObjectProperty<Orientation> orientationProperty​()
        ListView的方向 - 这可以是水平还是垂直。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • setCellFactory

        public final void setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
        设置要在ListView中使用的新单元格工厂。 这迫使所有旧的ListCell被抛弃，并且新的ListCell是用新的单元格工厂创建的。
        参数
        value - 在这个ListView中使用的单元格工厂

      • getCellFactory

        public final Callback<ListView<T>,ListCell<T>> getCellFactory​()
        返回当前的单元格工厂。
        结果
        目前的电池厂

      • cellFactoryProperty

        public final ObjectProperty<Callback<ListView<T>,ListCell<T>>> cellFactoryProperty​()

        设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。 在内部，ListView负责重用ListCells - 所有必要的是自定义单元格工厂从此函数返回可用于表示ListView中任何项目的ListCell。

        有关详细信息，请参阅Cell类文档。

        另请参见：
        getCellFactory() ， setCellFactory(Callback)

      • setFixedCellSize

        public final void setFixedCellSize​(double value)
        设置此控件的新固定单元格大小。 任何大于零的值将启用固定的单元大小模式，而零值或负值（或Region.USE_COMPUTED_SIZE）将用于禁用固定单元大小模式。
        参数
        value - 新的固定单元格大小值，或小于或等于零（或Region.USE_COMPUTED_SIZE）的值禁用。
        从以下版本开始：
        JavaFX 8.0

      • getFixedCellSize

        public final double getFixedCellSize​()
        返回固定的单元格大小值。 使用小于或等于零的值来表示禁用固定单元大小模式，大于零的值表示此控件中所有单元格的大小。
        结果
        表示该控件的固定单元大小的double，或者如果固定单元大小模式被禁用，小于或等于零的值。
        从以下版本开始：
        JavaFX 8.0

      • fixedCellSizeProperty

        public final DoubleProperty fixedCellSizeProperty​()
        指定此控件是否具有固定高度（指定值）的单元格。 如果该值小于或等于零，则所有单元格都被单独设置和定位。 这是一个缓慢的操作。 因此，当性能重要且开发人员不依赖于可变单元大小时，设置固定单元大小值是一个好主意。 一般情况下，单元格大约为24像素，因此设置固定的单元格大小为24可能导致视觉差异很小，但性能有所改善。

        要通过CSS设置此属性，请使用-fx-fixed-cell-size属性。 这不应该与-fx-cell-size属性混淆。 这两个CSS属性之间的区别是-fx-cell-size将所有单元格的大小设置为指定的大小，但不会强制这是唯一的大小（从而允许变量单元大小，并且阻止性能提升可能）。 因此，当性能很重要的时候使用-fx-fixed-cell-size，而不是-fx-cell-size。 如果在CSS中指定了两个属性，则-fx-fixed-cell-size优先。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • setEditable

        public final void setEditable​(boolean value)
        设置属性可编辑的值。
        Property description:
        指定此ListView是否可编辑 - 只有当ListView和ListCells都可编辑时，ListCell才能进入编辑状态。

      • isEditable

        public final boolean isEditable​()
        获取可编辑属性的值。
        Property description:
        指定此ListView是否可编辑 - 只有当ListView和ListCells都可编辑时，ListCell才能进入编辑状态。

      • editableProperty

        public final BooleanProperty editableProperty​()
        指定此ListView是否可编辑 - 只有当ListView和ListCells都可编辑时，ListCell才能进入编辑状态。
        另请参见：
        isEditable() ， setEditable(boolean)

      • getEditingIndex

        public final int getEditingIndex​()
        返回ListView中当前正在编辑的项目的索引，如果没有编辑任何项目，则返回-1。
        结果
        当前正在编辑的项目的索引

      • editingIndexProperty

        public final ReadOnlyIntegerProperty editingIndexProperty​()

        用于表示当前在ListView中编辑的项目的索引的属性（如果正在进行编辑），如果没有编辑任何项目，则用于表示-1。

        无法设置编辑索引，而需要调用edit(int) 。

        另请参见：
        getEditingIndex()

      • setOnEditStart

        public final void setOnEditStart​(EventHandler<ListView.EditEvent<T>> value)
        设置当用户开始编辑时将被调用的EventHandler 。

        这是一个方便的方法 - 通过调用addEventHandler(ListView.EDIT_START_EVENT, eventHandler)可以实现相同的结果。

        参数
        value - 当用户开始编辑时将被调用的EventHandler

      • getOnEditStart

        public final EventHandler<ListView.EditEvent<T>> getOnEditStart​()
        返回当用户开始编辑时将被调用的EventHandler 。
        结果
        当用户开始编辑时将被调用的EventHandler

      • onEditStartProperty

        public final ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditStartProperty​()
        当用户成功启动编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditStart() ， setOnEditStart(EventHandler)

      • setOnEditCommit

        public final void setOnEditCommit​(EventHandler<ListView.EditEvent<T>> value)
        设置当用户完成编辑时将被调用的EventHandler 。 这被称为ListCell.commitEdit(java.lang.Object)方法的一部分。

        这是一个方便的方法 - 通过调用addEventHandler(ListView.EDIT_START_EVENT, eventHandler)相同的结果。

        参数
        value - 当用户完成编辑时将被调用的EventHandler

      • getOnEditCommit

        public final EventHandler<ListView.EditEvent<T>> getOnEditCommit​()
        返回当用户提交编辑时将被调用的EventHandler 。
        结果
        当用户提交编辑时将被调用的EventHandler

      • onEditCommitProperty

        public final ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditCommitProperty​()

        当用户执行应导致其编辑输入持久化的操作时，将使用此属性。

        此属性中的EventHandler不应该直接调用 - 而是从您的自定义ListCell中调用ListCell.commitEdit(java.lang.Object) 。 这将处理触发此事件，更新视图和切换编辑状态。

        另请参见：
        getOnEditCommit() ， setOnEditCommit(EventHandler)

      • setOnEditCancel

        public final void setOnEditCancel​(EventHandler<ListView.EditEvent<T>> value)
        设置当用户取消编辑时将被调用的EventHandler 。
        参数
        value - 当用户取消编辑时将被调用的EventHandler

      • getOnEditCancel

        public final EventHandler<ListView.EditEvent<T>> getOnEditCancel​()
        返回当用户取消编辑时将被调用的EventHandler 。
        结果
        当用户取消编辑时将被调用的EventHandler

      • onEditCancelProperty

        public final ObjectProperty<EventHandler<ListView.EditEvent<T>>> onEditCancelProperty​()
        当用户取消编辑单元格时，将触发此事件处理程序。
        另请参见：
        getOnEditCancel() ， setOnEditCancel(EventHandler)

      • edit

        public void edit​(int itemIndex)
        指示ListView开始编辑给定索引中的项目，如果ListView为editable 。 一旦调用此方法，如果当前的cellFactoryProperty()设置为支持编辑，则Cell将切换其视觉状态以使用户可以进行输入。
        参数
        itemIndex - ListView中应编辑的项目的索引。

      • scrollTo

        public void scrollTo​(int index)
        滚动ListView，使给定索引中的项目对最终用户可见。
        参数
        index - 应该对用户可见的索引，假定它大于或等于0，小于给定ListView中包含的项目列表的大小。

      • scrollTo

        public void scrollTo​(T object)
        滚动ListView，使给定对象在视口内可见。
        参数
        object - 用户应该可以看到的对象。
        从以下版本开始：
        JavaFX 8.0

      • setOnScrollTo

        public void setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
        设置属性onScrollTo的值。
        Property description:
        当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0

      • getOnScrollTo

        public EventHandler<ScrollToEvent<Integer>> getOnScrollTo​()
        获取属性onScrollTo的值。
        Property description:
        当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0

      • onScrollToProperty

        public ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty​()
        当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnScrollTo() ， setOnScrollTo(EventHandler)

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • refresh

        public void refresh​()
        调用refresh()强制ListView控件重新创建并重新填充填充控件的可视边界所需的单元格。 换句话说，这会强制ListView更新它向用户显示的内容。 这在底层数据源以ListView本身未观察到的方式发生更改的情况下很有用。
        从以下版本开始：
        JavaFX 8u60

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListView.EditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ListView.EditEvent<T>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.ListView.EditEvent<T>
  • 参数类型
    T - 输入的类型，与ListView本身的类型相同。
    All Implemented Interfaces:
    Serializable ， Cloneable
    Enclosing class:
    ListView < T >

    public static class ListView.EditEvent<T>
extends Event
    一个Event子类，专门用于ListView中用于表示编辑相关事件。 它提供了额外的API来轻松访问编辑事件发生的索引，以及最终用户提供的输入。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<?> ANY
      所有编辑事件类型的公共超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

    • 构造方法摘要

      构造方法
      Constructor 描述
      EditEvent​(ListView<T> source, EventType<? extends ListView.EditEvent<T>> eventType, T newValue, int editIndex)
      创建一个新的EditEvent实例来表示编辑事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getIndex​()
      返回编辑发生的索引。
      T getNewValue​()
      返回最终用户提供的新输入的值。
      ListView<T> getSource​()
      返回发生编辑的ListView。
      String toString​()
      返回此 EditEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<?> ANY
        所有编辑事件类型的公共超类型。
        从以下版本开始：
        JavaFX 8.0

    • 构造方法详细信息

      • EditEvent

        public EditEvent​(ListView<T> source,
                 EventType<? extends ListView.EditEvent<T>> eventType,
                 T newValue,
                 int editIndex)
        创建一个新的EditEvent实例来表示编辑事件。 此事件是用于ListView.EDIT_START_EVENT ， ListView.EDIT_COMMIT_EVENT和ListView.EDIT_CANCEL_EVENT类型。
        参数
        source - 来源
        eventType - 事件类型
        newValue - 新价值
        editIndex - 编辑索引

    • 方法详细信息

      • getSource

        public ListView<T> getSource​()
        返回发生编辑的ListView。
        重写：
        getSource在 EventObject
        结果
        事件最初发生的对象。

      • getIndex

        public int getIndex​()
        返回编辑发生的索引。
        结果
        编辑发生的索引

      • getNewValue

        public T getNewValue​()
        返回最终用户提供的新输入的值。
        结果
        最终用户提供的新输入的值

      • toString

        public String toString​()
        返回此 EditEvent对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        这个 EditEvent对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Menu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Menu

  • java.lang.Object
    • javafx.scene.control.MenuItem
      • javafx.scene.control.Menu
  • All Implemented Interfaces:
    Styleable ， EventTarget

    @DefaultProperty("items")
public class Menu
extends MenuItem

    可触发的项目的弹出菜单，仅根据请求向用户显示。 当菜单可见时，在大多数情况下，用户可以在菜单返回到其隐藏状态之前选择一个菜单项。 这意味着菜单是放置重要功能的好地方，这些功能不一定需要在任何时候都可见到用户。

    菜单通常放置在MenuBar中 ，或作为另一个菜单的子菜单。 如果用户在用户界面的特定区域右键点击时提供上下文菜单，则这是使用错误的控件。 这是因为当将菜单添加到场景图中时，它具有将导致显示在屏幕上的视觉表示。 相反，在这种情况下应该使用ContextMenu 。

    创建菜单并将其插入到MenuBar中是很容易的，如下所示：

       final Menu menu1 = new Menu("File"); MenuBar menuBar = new MenuBar(); menuBar.getMenus().add(menu1);

    菜单是MenuItem的子类，这意味着它可以插入到菜单的items ObservableList中，从而创建一个子菜单：

       MenuItem menu12 = new MenuItem("Open"); menu1.getItems().add(menu12);

    ObservableList允许任何项目MenuItem类型将被插入，包括它的子类Menu ， MenuItem ， RadioMenuItem ， CheckMenuItem ， CustomMenuItem和SeparatorMenuItem 。 为了在菜单中插入任意的Node ，可以使用CustomMenuItem。 这个一般规则的一个例外是SeparatorMenuItem可以用于插入分隔符。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MenuBar ， MenuItem

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<EventHandler<Event>> onHidden
      紧随ContextMenu被隐藏。
      ObjectProperty<EventHandler<Event>> onHiding
      被称为在ContextMenu之前被隐藏。
      ObjectProperty<EventHandler<Event>> onShowing
      在 ContextMenu被显示之前，即使菜单没有显示项目。
      ObjectProperty<EventHandler<Event>> onShown
      在ContextMenu之后刚刚显示。
      ReadOnlyBooleanProperty showing
      指示ContextMenu当前是否可见。

      • Properties inherited from class javafx.scene.control.MenuItem

        accelerator, disable, graphic, id, mnemonicParsing, onAction, onMenuValidation, parentMenu, parentPopup, style, text, visible

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<Event> ON_HIDDEN
      当此菜单的contextMenu隐藏时调用。
      static EventType<Event> ON_HIDING
      当该菜单的contextMenu 将被隐藏时调用。
      static EventType<Event> ON_SHOWING
      当此菜单的contextMenu 将被显示时调用。
      static EventType<Event> ON_SHOWN
      当此菜单的contextMenu显示时调用。

      • Fields inherited from class javafx.scene.control.MenuItem

        MENU_VALIDATION_EVENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Menu​()
      为其显示文本构造一个空字符串的菜单。
      Menu​(String text)
      构造一个菜单，并将显示文本设置为指定的文本。
      Menu​(String text, Node graphic)
      构造一个菜单，并使用指定的文本设置显示文本，并将图形Node设置为给定节点。
      Menu​(String text, Node graphic, MenuItem... items)
      构建菜单并将指定文本的显示文本（给定节点的图形Node）设置，并将给定项目插入到items列表中。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      <E extends Event>
      void             		addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此MenuItem中注册一个事件处理程序。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      ObservableList<MenuItem> getItems​()
      在此菜单中显示的项目。
      EventHandler<Event> getOnHidden​()
      获取属性onHidden的值。
      EventHandler<Event> getOnHiding​()
      获取属性onHiding的值。
      EventHandler<Event> getOnShowing​()
      获取属性onShowing的值。
      EventHandler<Event> getOnShown​()
      获取onShown属性的值。
      void hide​()
      隐藏ContextMenu如果它以前显示，和任何显示子菜单。
      boolean isShowing​()
      获取显示的属性的值。
      ObjectProperty<EventHandler<Event>> onHiddenProperty​()
      在ContextMenu被隐藏之后调用。
      ObjectProperty<EventHandler<Event>> onHidingProperty​()
      被称为在ContextMenu被隐藏之前。
      ObjectProperty<EventHandler<Event>> onShowingProperty​()
      在 ContextMenu之前 ContextMenu ，即使菜单没有显示项目。
      ObjectProperty<EventHandler<Event>> onShownProperty​()
      在ContextMenu之后刚刚显示。
      <E extends Event>
      void             		removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此MenuItem中注销先前注册的事件处理程序。
      void setOnHidden​(EventHandler<Event> value)
      设置属性onHidden的值。
      void setOnHiding​(EventHandler<Event> value)
      设置属性onHiding的值。
      void setOnShowing​(EventHandler<Event> value)
      设置属性onShowing的值。
      void setOnShown​(EventHandler<Event> value)
      设置属性onShown的值。
      void show​()
      如果菜单没有禁用，并且ContextMenu尚未显示，则会导致显示ContextMenu 。
      ReadOnlyBooleanProperty showingProperty​()
      指示ContextMenu当前是否可见。

      • Methods inherited from class javafx.scene.control.MenuItem

        acceleratorProperty, disableProperty, fire, getAccelerator, getCssMetaData, getGraphic, getId, getOnAction, getOnMenuValidation, getParentMenu, getParentPopup, getProperties, getPseudoClassStates, getStyle, getStyleableNode, getStyleableParent, getStyleClass, getText, getTypeSelector, getUserData, graphicProperty, idProperty, isDisable, isMnemonicParsing, isVisible, mnemonicParsingProperty, onActionProperty, onMenuValidationProperty, parentMenuProperty, parentPopupProperty, setAccelerator, setDisable, setGraphic, setId, setMnemonicParsing, setOnAction, setOnMenuValidation, setParentMenu, setParentPopup, setStyle, setText, setUserData, setVisible, styleProperty, textProperty, toString, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • showing

        public final ReadOnlyBooleanProperty showingProperty
        指示ContextMenu当前是否可见。
        Default value:
        假
        另请参见：
        isShowing()

      • onShowing

        public final ObjectProperty<EventHandler<Event>> onShowingProperty
        在ContextMenu被显示之前，即使菜单没有显示项目。 但是请注意，如果菜单没有有效的锚点节点，则不会调用此方法。
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • onShown

        public final ObjectProperty<EventHandler<Event>> onShownProperty
        紧接ContextMenu后显示。
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • onHiding

        public final ObjectProperty<EventHandler<Event>> onHidingProperty
        在ContextMenu被隐藏之前叫。
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • onHidden

        public final ObjectProperty<EventHandler<Event>> onHiddenProperty
        在ContextMenu被隐藏之后调用。
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

    • 字段详细信息

      • ON_SHOWING

        public static final EventType<Event> ON_SHOWING

        当此菜单的contextMenu 将被显示时调用。 但是如果contextMenu为空，则不会被调用。

      • ON_SHOWN

        public static final EventType<Event> ON_SHOWN

        当此菜单的contextMenu显示时调用。 但是如果contextMenu为空，则不会被调用。

      • ON_HIDING

        public static final EventType<Event> ON_HIDING

        当该菜单的contextMenu 将被隐藏时调用。 但是如果contextMenu为空，则不会被调用。

      • ON_HIDDEN

        public static final EventType<Event> ON_HIDDEN

        当此菜单的contextMenu隐藏时调用。 但是如果contextMenu为空，则不会被调用。

    • 构造方法详细信息

      • Menu

        public Menu​()
        为其显示文本构造一个空字符串的菜单。
        从以下版本开始：
        JavaFX 2.2

      • Menu

        public Menu​(String text)
        构造一个菜单，并将显示文本设置为指定的文本。
        参数
        text - 要在菜单按钮上显示的文字

      • Menu

        public Menu​(String text,
            Node graphic)
        构造一个菜单，并使用指定的文本设置显示文本，并将图形Node设置为给定节点。
        参数
        text - 要在菜单按钮上显示的文字
        graphic - 要在菜单按钮上显示的图形

      • Menu

        public Menu​(String text,
            Node graphic,
            MenuItem... items)
        构建一个菜单，并将指定文本的图形Node设置为给定节点，并将给定项目插入到items列表中。
        参数
        text - 要在菜单按钮上显示的文字
        graphic - 在菜单按钮上显示的图形
        items - 要在弹出菜单中显示的项目。
        从以下版本开始：
        JavaFX 8u40

    • 方法详细信息

      • isShowing

        public final boolean isShowing​()
        获取显示的属性的值。
        Property description:
        指示ContextMenu当前是否可见。
        Default value:
        假

      • showingProperty

        public final ReadOnlyBooleanProperty showingProperty​()
        指示ContextMenu当前是否可见。
        Default value:
        假
        另请参见：
        isShowing()

      • onShowingProperty

        public final ObjectProperty<EventHandler<Event>> onShowingProperty​()
        在ContextMenu被显示之前，即使菜单没有显示项目。 但是请注意，如果菜单没有有效的锚点节点，则不会调用此方法。
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • setOnShowing

        public final void setOnShowing​(EventHandler<Event> value)
        设置属性onShowing的值。
        Property description:
        在ContextMenu被显示之前，即使菜单没有显示项目。 但是请注意，如果菜单没有有效的锚点节点，则不会调用此方法。

      • getOnShowing

        public final EventHandler<Event> getOnShowing​()
        获取属性onShowing的值。
        Property description:
        在ContextMenu被显示之前，即使菜单没有显示项目。 但是请注意，如果菜单没有有效的锚点节点，则不会调用此方法。

      • onShownProperty

        public final ObjectProperty<EventHandler<Event>> onShownProperty​()
        在ContextMenu之后就被称为。
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • setOnShown

        public final void setOnShown​(EventHandler<Event> value)
        设置属性onShown的值。
        Property description:
        在ContextMenu之后刚刚显示。

      • getOnShown

        public final EventHandler<Event> getOnShown​()
        获取onShown属性的值。
        Property description:
        在ContextMenu后显示。

      • onHidingProperty

        public final ObjectProperty<EventHandler<Event>> onHidingProperty​()
        称之为ContextMenu之前被隐藏。
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • setOnHiding

        public final void setOnHiding​(EventHandler<Event> value)
        设置属性onHiding的值。
        Property description:
        称之为ContextMenu之前被隐藏。

      • getOnHiding

        public final EventHandler<Event> getOnHiding​()
        获取属性onHiding的值。
        Property description:
        被称为在ContextMenu被隐藏之前。

      • onHiddenProperty

        public final ObjectProperty<EventHandler<Event>> onHiddenProperty​()
        在ContextMenu之后刚刚被隐藏。
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

      • setOnHidden

        public final void setOnHidden​(EventHandler<Event> value)
        设置属性onHidden的值。
        Property description:
        在ContextMenu之后刚刚被隐藏。

      • getOnHidden

        public final EventHandler<Event> getOnHidden​()
        获取属性onHidden的值。
        Property description:
        紧接ContextMenu后被称为隐藏。

      • getItems

        public final ObservableList<MenuItem> getItems​()
        在此菜单中显示的项目。 如果在运行时修改了ObservableList，菜单将按预期更新。
        结果
        项目清单

      • show

        public void show​()
        如果菜单未被禁用，并且ContextMenu尚未显示，则会导致显示ContextMenu 。

      • hide

        public void hide​()
        隐藏ContextMenu，如果它以前显示，和任何显示子菜单。 如果此菜单未显示，则调用此功能不起作用。

      • addEventHandler

        public <E extends Event> void addEventHandler​(EventType<E> eventType,
                                              EventHandler<E> eventHandler)
        在此MenuItem中注册一个事件处理程序。 当菜单项在事件传送的冒泡阶段期间接收到指定类型的Event时，调用处理程序。
        重写：
        addEventHandler在 MenuItem
        参数类型
        E - 处理程序的特定事件类
        参数
        eventType - 由处理程序接收的事件的类型
        eventHandler - 要注册的处理程序

      • removeEventHandler

        public <E extends Event> void removeEventHandler​(EventType<E> eventType,
                                                 EventHandler<E> eventHandler)
        从此MenuItem中注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        重写：
        removeEventHandler在 MenuItem
        参数类型
        E - 处理程序的特定事件类
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此目标构建事件调度链。 事件调度链包含可能对处理针对EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要为链接添加一个EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        Specified by:
        buildEventDispatchChain接口 EventTarget
        重写：
        buildEventDispatchChain在 MenuItem
        参数
        tail - 建立的初始链
        结果
        此目标的结果事件调度链
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


MenuBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class MenuBar

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.MenuBar
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("menus")
public class MenuBar
extends Control

    MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。 要将菜单添加到菜单栏，请将其添加到menus ObservableList。 默认情况下，对于添加到菜单栏的每个菜单，它将被表示为一个按钮，显示菜单text值。

    MenuBar将focusTraversable设置为false。

    要创建和填充MenuBar ，您可以执行下面所示的操作。 有关如何进行配置的详细信息，请参阅Menu API页面。
       final Menu menu1 = new Menu("File"); final Menu menu2 = new Menu("Options"); final Menu menu3 = new Menu("Help"); MenuBar menuBar = new MenuBar(); menuBar.getMenus().addAll(menu1, menu2, menu3);
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Menu ， MenuItem

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty useSystemMenuBar
      如果当前平台支持，请使用系统菜单栏。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuBar​()
      创建一个新的空MenuBar。
      MenuBar​(Menu... menus)
      使用给定的菜单创建一个新的MenuBar。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      ObservableList<Menu> getMenus​()
      在MenuBar中显示的菜单。
      boolean isUseSystemMenuBar​()
      获取propertySystemMenuBar属性的值。
      void setUseSystemMenuBar​(boolean value)
      设置属性useSystemMenuBar的值。
      BooleanProperty useSystemMenuBarProperty​()
      如果当前平台支持，请使用系统菜单栏。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • useSystemMenuBar

        public final BooleanProperty useSystemMenuBarProperty
        如果当前平台支持，请使用系统菜单栏。 这不应该在每个Stage的多个MenuBar实例上设置。 如果在同一阶段的多个MenuBar上将此属性设置为true，则允许最后一个菜单集修改系统菜单栏，如果存在已安装的系统菜单，则会从系统菜单栏中取消设置。 请注意，尝试单向绑定到此属性将抛出一个RuntimeException。 请使用双向绑定到此属性。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        isUseSystemMenuBar() ， setUseSystemMenuBar(boolean)

    • 构造方法详细信息

      • MenuBar

        public MenuBar​()
        创建一个新的空MenuBar。

      • MenuBar

        public MenuBar​(Menu... menus)
        使用给定的菜单创建一个新的MenuBar。
        参数
        menus - 放置在MenuBar中的菜单
        从以下版本开始：
        JavaFX 8u40

    • 方法详细信息

      • useSystemMenuBarProperty

        public final BooleanProperty useSystemMenuBarProperty​()
        如果当前平台支持，请使用系统菜单栏。 这不应该在每个Stage的多个MenuBar实例上设置。 如果在同一阶段的多个MenuBar上将此属性设置为true，则允许最后一个菜单集修改系统菜单栏，如果存在已安装的系统菜单，则会从系统菜单栏中取消设置。 请注意，尝试单向绑定到此属性将抛出一个RuntimeException。 请使用双向绑定到此属性。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        isUseSystemMenuBar() ， setUseSystemMenuBar(boolean)

      • setUseSystemMenuBar

        public final void setUseSystemMenuBar​(boolean value)
        设置属性useSystemMenuBar的值。
        Property description:
        如果当前平台支持，请使用系统菜单栏。 这不应该在每个Stage的多个MenuBar实例上设置。 如果在同一阶段的多个MenuBar上将此属性设置为true，则允许最后一个菜单集修改系统菜单栏，如果存在已安装的系统菜单，则会从系统菜单栏中取消设置。 请注意，尝试单向绑定到此属性将抛出一个RuntimeException。 请使用双向绑定到此属性。
        从以下版本开始：
        JavaFX 2.1

      • isUseSystemMenuBar

        public final boolean isUseSystemMenuBar​()
        获取propertySystemMenuBar属性的值。
        Property description:
        如果当前平台支持，请使用系统菜单栏。 这不应该在每个Stage的多个MenuBar实例上设置。 如果在同一阶段的多个MenuBar上将此属性设置为true，则允许最后一个菜单集修改系统菜单栏，如果存在已安装的系统菜单，则会从系统菜单栏中取消设置。 请注意，尝试单向绑定到此属性将抛出一个RuntimeException。 请使用双向绑定到此属性。
        从以下版本开始：
        JavaFX 2.1

      • getMenus

        public final ObservableList<Menu> getMenus​()
        在MenuBar中显示的菜单。 如果在运行时修改了ObservableList，则MenuBar将按预期更新。
        结果
        在此MenuBar中显示的菜单列表
        另请参见：
        Menu

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则会调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData中的 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MenuButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class MenuButton

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.ButtonBase
                • javafx.scene.control.MenuButton
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    SplitMenuButton

    public class MenuButton
extends ButtonBase
    MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。 MenuButton与Menu控件共享一个非常相似的API，只要您设置items ObservableList中应显示的项目，并且有一个Labeled.text属性来指定MenuButton中显示的标签。

    如上所述，像Menu API本身一样，您会发现一个items ObservableList，您可以在其中提供从MenuItem扩展的任何内容 。 有一些有用的子类MenuItem包括RadioMenuItem ， CheckMenuItem ， Menu ， SeparatorMenuItem和CustomMenuItem 。

    可以将MenuButton设置为在按钮的任意一侧显示其菜单。 这是使用popupSide属性指定的。 默认情况下，菜单出现在按钮下方。 但是，无论popupSide如何指定，如果没有足够的空间， ContextMenu将会被巧妙地重新定位，最有可能是在MenuButton的对面。

    例：

      MenuButton m = new MenuButton("Eats");
 m.getItems().addAll(new MenuItem("Burger"), new MenuItem("Hot Dog"));

    默认情况下，MenuButton启用助记符分配。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MenuItem ， Menu ， SplitMenuButton

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Side> popupSide
      表示ContextMenu应该在哪一边打开与MenuButton相关的方面。
      ReadOnlyBooleanProperty showing
      指示ContextMenu当前是否可见。

      • Properties inherited from class javafx.scene.control.ButtonBase

        armed, onAction

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<Event> ON_HIDDEN
      当MenuButton弹出窗口被隐藏时调用。
      static EventType<Event> ON_HIDING
      调用的时候，菜单按钮弹出 将被隐藏。
      static EventType<Event> ON_SHOWING
      在MenuButton显示弹出窗口之前，在用户单击或以其他方式与MenuButton进行交互之后调用。
      static EventType<Event> ON_SHOWN
      在MenuButton显示弹出窗口后调用。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuButton​()
      创建一个新的空的菜单按钮。
      MenuButton​(String text)
      创建一个新的空的菜单按钮，给定的文本显示在按钮上。
      MenuButton​(String text, Node graphic)
      创建一个新的空的菜单按钮，给定的文本和图形显示在按钮上。
      MenuButton​(String text, Node graphic, MenuItem... items)
      创建一个新的菜单按钮，给定的文本和图形显示在按钮上，并将给定的项目插入到 items列表中。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void fire​()
      这没有影响。
      ObservableList<MenuItem> getItems​()
      在此按钮菜单中显示的项目。
      Side getPopupSide​()
      获取属性popupSide的值。
      void hide​()
      隐藏ContextMenu 。
      boolean isShowing​()
      获取显示的属性的值。
      ObjectProperty<Side> popupSideProperty​()
      表示ContextMenu应该在哪一面打开相对于MenuButton。
      void setPopupSide​(Side value)
      设置属性popupSide的值。
      void show​()
      显示ContextMenu ，假设该MenuButton未被禁用。
      ReadOnlyBooleanProperty showingProperty​()
      指示ContextMenu当前是否可见。

      • Methods inherited from class javafx.scene.control.ButtonBase

        arm, armedProperty, disarm, getOnAction, isArmed, onActionProperty, setOnAction

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • showing

        public final ReadOnlyBooleanProperty showingProperty
        指示ContextMenu当前是否可见。
        另请参见：
        isShowing()

      • popupSide

        public final ObjectProperty<Side> popupSideProperty
        表示ContextMenu应该在哪一边打开相对于MenuButton。 菜单项通常在两种情况下垂直布置。 例如，如果菜单按钮位于应用程序左边缘的垂直工具栏中，则可以将popupSide更改为Side.RIGHT ，以使弹出窗口显示在MenuButton的右侧。
        Default value:
        Side.BOTTOM
        另请参见：
        getPopupSide() ， setPopupSide(Side)

    • 字段详细信息

      • ON_SHOWING

        public static final EventType<Event> ON_SHOWING
        在MenuButton显示弹出窗口之前，在用户单击或以其他方式与MenuButton进行交互之后调用。
        从以下版本开始：
        JavaFX 8u60

      • ON_SHOWN

        public static final EventType<Event> ON_SHOWN
        在MenuButton显示弹出窗口后调用。
        从以下版本开始：
        JavaFX 8u60

      • ON_HIDING

        public static final EventType<Event> ON_HIDING
        调用的时候，菜单按钮弹出 将被隐藏。
        从以下版本开始：
        JavaFX 8u60

      • ON_HIDDEN

        public static final EventType<Event> ON_HIDDEN
        当MenuButton弹出窗口被隐藏时调用。
        从以下版本开始：
        JavaFX 8u60

    • 构造方法详细信息

      • MenuButton

        public MenuButton​()
        创建一个新的空的菜单按钮。 使用Labeled.setText(String) ， Labeled.setGraphic(Node)和getItems()设置内容。

      • MenuButton

        public MenuButton​(String text)
        创建一个新的空的菜单按钮，给定的文本显示在按钮上。 使用Labeled.setGraphic(Node)和getItems()设置内容。
        参数
        text - 要在菜单按钮上显示的文字

      • MenuButton

        public MenuButton​(String text,
                  Node graphic)
        创建一个新的空的菜单按钮，给定的文本和图形显示在按钮上。 使用getItems()设置内容。
        参数
        text - 要在菜单按钮上显示的文字
        graphic - 在菜单按钮上显示的图形

      • MenuButton

        public MenuButton​(String text,
                  Node graphic,
                  MenuItem... items)
        创建一个新的菜单按钮，给定的文本和图形显示在按钮上，并将给定的项目插入到 items列表中。
        参数
        text - 在菜单按钮上显示的文字
        graphic - 在菜单按钮上显示的图形
        items - 要在弹出菜单中显示的项目。
        从以下版本开始：
        JavaFX 8u40

    • 方法详细信息

      • getItems

        public final ObservableList<MenuItem> getItems​()
        在此按钮菜单中显示的项目。 如果在运行时修改了ObservableList，菜单将按预期更新。

        常用控件包括包含MenuItem ， CheckMenuItem ， RadioMenuItem ，当然Menu ，其中，如果添加到菜单，将成为一个子菜单。 SeparatorMenuItem是菜单项目ObservableList中另一个常用的节点。

        结果
        此按钮菜单中的菜单项列表

      • isShowing

        public final boolean isShowing​()
        获取显示的属性的值。
        Property description:
        指示ContextMenu当前是否可见。

      • showingProperty

        public final ReadOnlyBooleanProperty showingProperty​()
        指示ContextMenu当前是否可见。
        另请参见：
        isShowing()

      • setPopupSide

        public final void setPopupSide​(Side value)
        设置属性popupSide的值。
        Property description:
        表示ContextMenu应该在哪一面打开与MenuButton相关的方面。 菜单项通常在两种情况下垂直布置。 例如，如果菜单按钮位于应用程序左边缘的垂直工具栏中，则可以将popupSide更改为Side.RIGHT ，以使弹出窗口显示在MenuButton的右侧。
        Default value:
        Side.BOTTOM

      • getPopupSide

        public final Side getPopupSide​()
        获取属性popupSide的值。
        Property description:
        表示ContextMenu应该在哪一面打开与MenuButton相关的方面。 菜单项通常在两种情况下垂直布置。 例如，如果菜单按钮位于应用程序左边缘的垂直工具栏中，则可以将popupSide更改为Side.RIGHT ，以使弹出窗口显示在MenuButton的右侧。
        Default value:
        Side.BOTTOM

      • popupSideProperty

        public final ObjectProperty<Side> popupSideProperty​()
        表示ContextMenu应该在哪一面打开与MenuButton相关的方面。 菜单项通常在两种情况下垂直布置。 例如，如果菜单按钮位于应用程序左边缘的垂直工具栏中，则可以将popupSide更改为Side.RIGHT ，以使弹出窗口显示在MenuButton的右侧。
        Default value:
        Side.BOTTOM
        另请参见：
        getPopupSide() ， setPopupSide(Side)

      • show

        public void show​()
        显示ContextMenu ，假设该MenuButton未被禁用。
        另请参见：
        Node.isDisabled() ， isShowing()

      • hide

        public void hide​()
        隐藏ContextMenu 。
        另请参见：
        isShowing()

      • fire

        public void fire​()
        这没有影响。
        Specified by:
        fire在 ButtonBase

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则会调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 ButtonBase
        参数
        action - 执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


MenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class MenuItem

  • java.lang.Object
    • javafx.scene.control.MenuItem
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    CheckMenuItem ， CustomMenuItem ， Menu ， RadioMenuItem

    @IDProperty("id")
public class MenuItem
extends Object
implements EventTarget, Styleable

    MenuItem旨在与Menu结合使用，为用户提供选项。 MenuItem作为大量JavaFX菜单API的基类。 它具有显示text属性，以及可以在其上设置的可选的graphic节点。 accelerator属性可以在一个击键中访问关联的操作。 此外，与Button控件一样，通过使用setOnAction(javafx.event.EventHandler<javafx.event.ActionEvent>)方法，您可以让MenuItem的一个实例执行任何您希望的操作。

    注意：虽然任何尺寸的图形可以插入到MenuItem中，但大多数应用程序中最常用的大小是16x16像素。 如果您使用JavaFX提供的默认样式，这是建议使用的图形维度。

    创建一个MenuItem很简单：

       MenuItem menuItem = new MenuItem("Open"); menuItem.setOnAction(new EventHandler<ActionEvent>() { @Override public void handle(ActionEvent e) { System.out.println("Opening Database Connection..."); } }); menuItem.setGraphic(new ImageView(new Image("flower.png")));

    请参阅Menu页面了解如何将MenuItem插入菜单实例。 但简而言之，您可以将MenuItem从上一个示例插入到菜单中：

       final Menu menu = new Menu("File"); menu.getItems().add(menuItem);
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Menu

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<KeyCombination> accelerator
      加速器属性使得能够在一个击键中访问关联的动作。
      BooleanProperty disable
      设置此MenuItem的单独禁用状态。
      ObjectProperty<Node> graphic
      MenuItem的可选图形。
      StringProperty id
      该MenuItem的ID。
      BooleanProperty mnemonicParsing
      助记符属性启用/禁用文本解析。
      ObjectProperty<EventHandler<ActionEvent>> onAction
      每当MenuItem被触发时调用该动作。
      ObjectProperty<EventHandler<Event>> onMenuValidation
      与调用MenuItem的加速器相关联的事件处理程序。
      ReadOnlyObjectProperty<Menu> parentMenu
      这是Menu ，其中MenuItem存在。
      ReadOnlyObjectProperty<ContextMenu> parentPopup
      这是ContextMenu ，其中MenuItem存在。
      StringProperty style
      与此特定MenuItem相关联的CSS样式的字符串表示形式。
      StringProperty text
      文字显示在 MenuItem 。
      BooleanProperty visible
      指定此MenuItem是否应呈现为场景图的一部分。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<Event> MENU_VALIDATION_EVENT
      当调用Menuitem的加速器时调用

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuItem​()
      构造一个没有显示文本的MenuItem。
      MenuItem​(String text)
      构造一个MenuItem并设置具有指定文本的显示文本
      MenuItem​(String text, Node graphic)
      构造函数的MenuItem，并使用指定的文本设置显示文本，并将图形Node设置为给定节点。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<KeyCombination> acceleratorProperty​()
      加速器属性使得能够在一个击键中访问关联的动作。
      <E extends Event>
      void             		addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此MenuItem中注册一个事件处理程序。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      BooleanProperty disableProperty​()
      设置此MenuItem的单独禁用状态。
      void fire​()
      触发一个新的ActionEvent。
      KeyCombination getAccelerator​()
      获取属性加速器的值。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      这个样式的CssMetaData。
      Node getGraphic​()
      获取属性图形的值。
      String getId​()
      获取属性ID的值。
      EventHandler<ActionEvent> getOnAction​()
      获取属性onAction的值。
      EventHandler<Event> getOnMenuValidation​()
      获取属性onMenuValidation的值。
      Menu getParentMenu​()
      获取属性parentMenu的值。
      ContextMenu getParentPopup​()
      获取属性parentPopup的值。
      ObservableMap<Object,Object> getProperties​()
      返回此菜单项上可观察到的属性映射，主要由应用程序开发人员使用。
      ObservableSet<PseudoClass> getPseudoClassStates​()
      返回此Styleable的伪类状态。
      String getStyle​()
      获取属性样式的值。
      Node getStyleableNode​()
      返回表示此Styleable对象的Node。
      Styleable getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      ObservableList<String> getStyleClass​()
      *公开API * *
      String getText​()
      获取属性文本的值。
      String getTypeSelector​()
      这种 Styleable的类型用于选择器匹配。
      Object getUserData​()
      返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
      ObjectProperty<Node> graphicProperty​()
      MenuItem的可选图形。
      StringProperty idProperty​()
      该MenuItem的ID。
      boolean isDisable​()
      获取属性禁用的值。
      boolean isMnemonicParsing​()
      获取属性mnemonicParsing的值。
      boolean isVisible​()
      获取属性的值可见。
      BooleanProperty mnemonicParsingProperty​()
      助记符属性启用/禁用文本解析。
      ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
      每当MenuItem被触发时调用该动作。
      ObjectProperty<EventHandler<Event>> onMenuValidationProperty​()
      与调用MenuItem的加速器相关联的事件处理程序。
      ReadOnlyObjectProperty<Menu> parentMenuProperty​()
      这是Menu在此MenuItem存在。
      ReadOnlyObjectProperty<ContextMenu> parentPopupProperty​()
      这是ContextMenu在此MenuItem存在。
      <E extends Event>
      void             		removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此MenuItem中注销先前注册的事件处理程序。
      void setAccelerator​(KeyCombination value)
      设置属性加速器的值。
      void setDisable​(boolean value)
      设置属性的值禁用。
      void setGraphic​(Node value)
      设置属性图形的值。
      void setId​(String value)
      设置属性id的值。
      void setMnemonicParsing​(boolean value)
      设置属性mnemonicParsing的值。
      void setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void setOnMenuValidation​(EventHandler<Event> value)
      设置属性onMenuValidation的值。
      protected void setParentMenu​(Menu value)
      设置属性parentMenu的值。
      protected void setParentPopup​(ContextMenu value)
      设置属性parentPopup的值。
      void setStyle​(String value)
      设置属性样式的值。
      void setText​(String value)
      设置属性文本的值。
      void setUserData​(Object value)
      用于设置可以在以后检索的单个Object属性的便利方法。
      void setVisible​(boolean value)
      设置属性的值可见。
      StringProperty styleProperty​()
      与此特定MenuItem相关联的CSS样式的字符串表示形式。
      StringProperty textProperty​()
      文字显示在 MenuItem 。
      String toString​()
      返回对象的字符串表示形式。
      BooleanProperty visibleProperty​()
      指定此MenuItem是否应呈现为场景图的一部分。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • id

        public final StringProperty idProperty
        该MenuItem的ID。 这个简单的字符串标识符可用于在场景图中查找特定的MenuItem。
        另请参见：
        getId() ， setId(String)

      • style

        public final StringProperty styleProperty
        与此特定MenuItem相关联的CSS样式的字符串表示形式。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        另请参见：
        getStyle() ， setStyle(String)

      • parentMenu

        public final ReadOnlyObjectProperty<Menu> parentMenuProperty
        这是Menu在此MenuItem存在。 这个类的一个实例可能没有一个parentMenu - 这意味着这个实例是：
        • 尚未与其parentMenu相关联。
        • A“根” Menu （即它是上下文菜单，直接连接到一个MenuBar ， MenuButton ，或任何其他控制的使用Menu内部。
        另请参见：
        getParentMenu() ， setParentMenu(Menu)

      • parentPopup

        public final ReadOnlyObjectProperty<ContextMenu> parentPopupProperty
        这是ContextMenu在此MenuItem存在。
        另请参见：
        getParentPopup() ， setParentPopup(ContextMenu)

      • text

        public final StringProperty textProperty
        文字显示在 MenuItem 。
        另请参见：
        getText() ， setText(String)

      • graphic

        public final ObjectProperty<Node> graphicProperty
        MenuItem的可选图形。 这通常是一个ImageView节点，但是并不要求这样做。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • onAction

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty
        每当MenuItem被触发时调用该动作。 这可能是由于用户使用鼠标点击按钮，或者通过触摸事件或按键，或者如果开发者编程地调用fire()方法。
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • onMenuValidation

        public final ObjectProperty<EventHandler<Event>> onMenuValidationProperty
        与调用MenuItem的加速器相关联的事件处理程序。 当按下加速器的按键顺序时，可能会发生这种情况。 当调用onShowing事件处理程序时，也会调用事件处理程序。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnMenuValidation() ， setOnMenuValidation(EventHandler)

      • disable

        public final BooleanProperty disableProperty
        设置此MenuItem的单独禁用状态。 将disable设置为true将导致此MenuItem被禁用。
        另请参见：
        isDisable() ， setDisable(boolean)

      • visible

        public final BooleanProperty visibleProperty
        指定此MenuItem是否应呈现为场景图的一部分。
        另请参见：
        isVisible() ， setVisible(boolean)

      • accelerator

        public final ObjectProperty<KeyCombination> acceleratorProperty
        加速器属性使得能够在一个击键中访问关联的动作。 提供快速执行给定动作的方便。
        另请参见：
        getAccelerator() ， setAccelerator(KeyCombination)

      • mnemonicParsing

        public final BooleanProperty mnemonicParsingProperty
        助记符属性启用/禁用文本解析。 如果设置为true，那么将解析MenuItem文本，以查看它是否包含助记符解析字符“_”。 当检测到助记符时，密钥组合将根据后续字符确定，并添加助记符。

        MenuItem的默认值为true。

        另请参见：
        isMnemonicParsing() ， setMnemonicParsing(boolean)

    • 字段详细信息

      • MENU_VALIDATION_EVENT

        public static final EventType<Event> MENU_VALIDATION_EVENT

        当调用Menuitem的加速器时调用

        从以下版本开始：
        JavaFX 2.2

    • 构造方法详细信息

      • MenuItem

        public MenuItem​()
        构造一个没有显示文本的MenuItem。

      • MenuItem

        public MenuItem​(String text)
        构造一个MenuItem并设置具有指定文本的显示文本
        参数
        text - 显示文字
        另请参见：
        setText(java.lang.String)

      • MenuItem

        public MenuItem​(String text,
                Node graphic)
        构造函数的MenuItem并设置具有指定文本的显示文本，并将图形Node设置为给定节点。
        参数
        text - 显示文字
        graphic - 图形节点
        另请参见：
        setText(java.lang.String) ， setGraphic(javafx.scene.Node)

    • 方法详细信息

      • setId

        public final void setId​(String value)
        设置属性id的值。
        Property description:
        该MenuItem的ID。 这个简单的字符串标识符可用于在场景图中查找特定的MenuItem。

      • getId

        public final String getId​()
        获取属性ID的值。
        Specified by:
        getId在接口 Styleable
        Property description:
        该MenuItem的ID。 这个简单的字符串标识符可用于在场景图中查找特定的MenuItem。
        结果
        该 Styleable为 Styleable

      • idProperty

        public final StringProperty idProperty​()
        该MenuItem的ID。 这个简单的字符串标识符可用于在场景图中查找特定的MenuItem。
        另请参见：
        getId() ， setId(String)

      • setStyle

        public final void setStyle​(String value)
        设置属性样式的值。
        Property description:
        与此特定MenuItem相关联的CSS样式的字符串表示形式。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。

      • getStyle

        public final String getStyle​()
        获取属性样式的值。
        Specified by:
        getStyle在接口 Styleable
        Property description:
        与此特定MenuItem相关联的CSS样式的字符串表示形式。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        结果
        与此特定 Node相关联的CSS样式的字符串表示 Node

      • styleProperty

        public final StringProperty styleProperty​()
        与此特定MenuItem相关联的CSS样式的字符串表示形式。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        另请参见：
        getStyle() ， setStyle(String)

      • setParentMenu

        protected final void setParentMenu​(Menu value)
        设置属性parentMenu的值。
        Property description:
        这是Menu在此MenuItem存在。 这个类的一个实例可能没有一个parentMenu - 这意味着这个实例是：
        • 尚未与其parentMenu相关联。
        • A“根” Menu （即它是上下文菜单，直接连接到一个MenuBar ， MenuButton ，或任何其他控制的使用Menu内部。

      • getParentMenu

        public final Menu getParentMenu​()
        获取属性parentMenu的值。
        Property description:
        这是Menu在此MenuItem存在。 这个类的一个实例可能没有一个parentMenu - 这意味着这个实例是：
        • 尚未与其parentMenu相关联。
        • A“根” Menu （即它是上下文菜单，直接连接到一个MenuBar ， MenuButton ，或任何其他控制的使用Menu内部。

      • parentMenuProperty

        public final ReadOnlyObjectProperty<Menu> parentMenuProperty​()
        这是Menu ，其中MenuItem存在。 这个类的一个实例可能没有一个parentMenu - 这意味着这个实例是：
        • 尚未与其parentMenu相关联。
        • A“根” Menu （即它是上下文菜单，直接连接到一个MenuBar ， MenuButton ，或任何其他控制的使用Menu内部。
        另请参见：
        getParentMenu() ， setParentMenu(Menu)

      • setParentPopup

        protected final void setParentPopup​(ContextMenu value)
        设置属性parentPopup的值。
        Property description:
        这是ContextMenu在此MenuItem存在。

      • getParentPopup

        public final ContextMenu getParentPopup​()
        获取属性parentPopup的值。
        Property description:
        这是ContextMenu在此MenuItem存在。

      • parentPopupProperty

        public final ReadOnlyObjectProperty<ContextMenu> parentPopupProperty​()
        这是ContextMenu在此MenuItem存在。
        另请参见：
        getParentPopup() ， setParentPopup(ContextMenu)

      • setText

        public final void setText​(String value)
        设置属性文本的值。
        Property description:
        文字显示在 MenuItem 。

      • getText

        public final String getText​()
        获取属性文本的值。
        Property description:
        文字显示在 MenuItem 。

      • textProperty

        public final StringProperty textProperty​()
        文字显示在 MenuItem 。
        另请参见：
        getText() ， setText(String)

      • setGraphic

        public final void setGraphic​(Node value)
        设置属性图形的值。
        Property description:
        MenuItem的可选图形。 这通常是一个ImageView节点，但是并不要求这样做。

      • getGraphic

        public final Node getGraphic​()
        获取属性图形的值。
        Property description:
        MenuItem的可选图形。 这通常是一个ImageView节点，但没有要求这样做。

      • graphicProperty

        public final ObjectProperty<Node> graphicProperty​()
        MenuItem的可选图形。 这通常是一个ImageView节点，但是并不要求这样做。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • setOnAction

        public final void setOnAction​(EventHandler<ActionEvent> value)
        设置属性onAction的值。
        Property description:
        每当MenuItem被触发时调用该动作。 这可能是由于用户用鼠标点击按钮，或者通过触摸事件或按键按下，或者如果开发者编程地调用fire()方法。

      • getOnAction

        public final EventHandler<ActionEvent> getOnAction​()
        获取属性onAction的值。
        Property description:
        每当MenuItem被触发时调用该动作。 这可能是由于用户用鼠标点击按钮，或者通过触摸事件或按键，或者如果开发者编程地调用fire()方法。

      • onActionProperty

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
        每当MenuItem被触发时调用该动作。 这可能是由于用户用鼠标点击按钮，或者通过触摸事件或按键，或者如果开发者编程地调用fire()方法。
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • setOnMenuValidation

        public final void setOnMenuValidation​(EventHandler<Event> value)
        设置属性onMenuValidation的值。
        Property description:
        与调用MenuItem的加速器相关联的事件处理程序。 当按下加速器的按键顺序时，可能会发生这种情况。 当调用onShowing事件处理程序时，也会调用事件处理程序。
        从以下版本开始：
        JavaFX 2.2

      • getOnMenuValidation

        public final EventHandler<Event> getOnMenuValidation​()
        获取属性onMenuValidation的值。
        Property description:
        与调用MenuItem的加速器相关联的事件处理程序。 当按下加速器的按键顺序时，可能会发生这种情况。 当调用onShowing事件处理程序时，也会调用事件处理程序。
        从以下版本开始：
        JavaFX 2.2

      • onMenuValidationProperty

        public final ObjectProperty<EventHandler<Event>> onMenuValidationProperty​()
        与调用MenuItem的加速器相关联的事件处理程序。 当按下加速器的按键顺序时，可能会发生这种情况。 当调用onShowing事件处理程序时，也会调用事件处理程序。
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getOnMenuValidation() ， setOnMenuValidation(EventHandler)

      • setDisable

        public final void setDisable​(boolean value)
        设置属性的值禁用。
        Property description:
        设置此MenuItem的单独禁用状态。 将disable设置为true将导致此MenuItem被禁用。

      • isDisable

        public final boolean isDisable​()
        获取属性禁用的值。
        Property description:
        设置此MenuItem的单独禁用状态。 将disable设置为true将导致此MenuItem被禁用。

      • disableProperty

        public final BooleanProperty disableProperty​()
        设置此MenuItem的单独禁用状态。 将disable设置为true将导致此MenuItem被禁用。
        另请参见：
        isDisable() ， setDisable(boolean)

      • setVisible

        public final void setVisible​(boolean value)
        设置属性的值可见。
        Property description:
        指定此MenuItem是否应呈现为场景图的一部分。

      • isVisible

        public final boolean isVisible​()
        获取属性的值可见。
        Property description:
        指定此MenuItem是否应呈现为场景图的一部分。

      • visibleProperty

        public final BooleanProperty visibleProperty​()
        指定此MenuItem是否应呈现为场景图的一部分。
        另请参见：
        isVisible() ， setVisible(boolean)

      • setAccelerator

        public final void setAccelerator​(KeyCombination value)
        设置属性加速器的值。
        Property description:
        加速器属性使得能够在一个击键中访问关联的动作。 提供快速执行给定动作的方便。

      • getAccelerator

        public final KeyCombination getAccelerator​()
        获取属性加速器的值。
        Property description:
        加速器属性使得能够在一个击键中访问关联的动作。 提供快速执行给定动作的方便。

      • acceleratorProperty

        public final ObjectProperty<KeyCombination> acceleratorProperty​()
        加速器属性使得能够在一个击键中访问关联的动作。 提供快速执行给定动作的方便。
        另请参见：
        getAccelerator() ， setAccelerator(KeyCombination)

      • setMnemonicParsing

        public final void setMnemonicParsing​(boolean value)
        设置属性mnemonicParsing的值。
        Property description:
        助记符属性启用/禁用文本解析。 如果设置为true，那么将解析MenuItem文本，以查看它是否包含助记符解析字符“_”。 当检测到助记符时，密钥组合将根据后续字符确定，并添加助记符。

        MenuItem的默认值为true。

      • isMnemonicParsing

        public final boolean isMnemonicParsing​()
        获取属性mnemonicParsing的值。
        Property description:
        助记符属性启用/禁用文本解析。 如果设置为true，那么将解析MenuItem文本，以查看它是否包含助记符解析字符“_”。 当检测到助记符时，密钥组合将根据后续字符确定，并添加助记符。

        MenuItem的默认值为true。

      • mnemonicParsingProperty

        public final BooleanProperty mnemonicParsingProperty​()
        助记符属性启用/禁用文本解析。 如果设置为true，那么将解析MenuItem文本，以查看它是否包含助记符解析字符“_”。 当检测到助记符时，密钥组合将根据后续字符确定，并添加助记符。

        MenuItem的默认值为true。

        另请参见：
        isMnemonicParsing() ， setMnemonicParsing(boolean)

      • getStyleClass

        public ObservableList<String> getStyleClass​()
        *公开API * *
        Specified by:
        getStyleClass在接口 Styleable
        结果
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎
        另请参见：
        CSS3 class selectors

      • fire

        public void fire​()
        触发一个新的ActionEvent。

      • addEventHandler

        public <E extends Event> void addEventHandler​(EventType<E> eventType,
                                              EventHandler<E> eventHandler)
        在此MenuItem中注册一个事件处理程序。 当菜单项在事件传送的冒泡阶段期间接收到指定类型的Event时，调用处理程序。
        参数类型
        E - 处理程序的特定事件类
        参数
        eventType - 由处理程序接收的事件的类型
        eventHandler - 要注册的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • removeEventHandler

        public <E extends Event> void removeEventHandler​(EventType<E> eventType,
                                                 EventHandler<E> eventHandler)
        从此MenuItem中注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        参数类型
        E - 处理程序的特定事件类
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此目标构建事件调度链。 事件调度链包含可能对处理针对EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要为链接添加一个EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 建立起来的初始链
        结果
        此目标的结果事件调度链

      • getUserData

        public Object getUserData​()
        返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
        结果
        先前设置的对象，如果没有设置属性或设置为null，则为null。

      • setUserData

        public void setUserData​(Object value)
        用于设置可以在以后检索的单个Object属性的便利方法。 这在功能上等同于调用getProperties（）。put（Object key，Object value）方法。 这可以稍后通过调用Node.getUserData()来检索。
        参数
        value - 要存储的值 - 以后可以通过调用 Node.getUserData()检索。

      • getProperties

        public ObservableMap<Object,Object> getProperties​()
        返回此菜单项上可观察到的属性映射，主要由应用程序开发人员使用。
        结果
        此菜单项上的属性的可观察地图主要由应用程序开发人员使用

      • getTypeSelector

        public String getTypeSelector​()
        这种Styleable的类型，用于选择器匹配。 这类似于HTML中的“元素”。 （ CSS Type Selector ）。
        Specified by:
        getTypeSelector在接口 Styleable
        结果
        “菜单项”
        从以下版本开始：
        JavaFX 8.0

      • getStyleableParent

        public Styleable getStyleableParent​()
        返回此Styleable的父项，如果没有父项则返回null。
        Specified by:
        getStyleableParent在接口 Styleable
        结果
        getParentMenu()或 getParentPopup()如果 parentMenu为空
        从以下版本开始：
        JavaFX 8.0

      • getPseudoClassStates

        public final ObservableSet<PseudoClass> getPseudoClassStates​()
        返回此Styleable的伪类状态。 CSS假定此集是只读的。
        Specified by:
        getPseudoClassStates在接口 Styleable
        结果
        伪类状态
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        描述从接口Styleable复制
        这个样式的CssMetaData。 这可以作为不可修改的列表返回。
        Specified by:
        getCssMetaData在接口 Styleable
        结果
        CssMetaData

      • getStyleableNode

        public Node getStyleableNode​()
        返回表示此Styleable对象的Node。 在Styleable本身不是Node的情况下，应该覆盖此方法，以便它可以可选地返回其本身的相关根节点表示。 默认情况下，此方法返回null，这可能意味着Styleable本身是一个Node，如果不是这种情况，则Styleable在请求时没有可用的节点表示。
        Specified by:
        getStyleableNode在接口 Styleable
        结果
        表示此Styleable对象的节点

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


MultipleSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class MultipleSelectionModel<T>

  • java.lang.Object
    • javafx.scene.control.SelectionModel<T>
      • javafx.scene.control.MultipleSelectionModel<T>
  • 参数类型
    T - 可以选择的控件中包含的项目的类型。
    已知直接子类：
    TableSelectionModel

    public abstract class MultipleSelectionModel<T>
extends SelectionModel<T>
    一个抽象类，扩展SelectionModel以添加API以支持多选。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    SelectionModel ， SelectionMode

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<SelectionMode> selectionMode
      指定在此选择模型中使用的选择模式。

      • Properties inherited from class javafx.scene.control.SelectionModel

        selectedIndex, selectedItem

    • 构造方法摘要

      构造方法
      Constructor 描述
      MultipleSelectionModel​()
      创建一个默认的MultipleSelectionModel实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract ObservableList<Integer> getSelectedIndices​()
      返回所有选定索引的 只读 ObservableList。
      abstract ObservableList<T> getSelectedItems​()
      返回所有选定项目的 只读 ObservableList。
      SelectionMode getSelectionMode​()
      获取属性selectionMode的值。
      abstract void selectAll​()
      方便的方法来选择所有可用的索引。
      abstract void selectFirst​()
      该方法将尝试选择控件中的第一个索引。
      abstract void selectIndices​(int index, int... indices)
      该方法允许同时设置一个或多个选择。
      ObjectProperty<SelectionMode> selectionModeProperty​()
      指定在此选择模型中使用的选择模式。
      abstract void selectLast​()
      此方法将尝试选择控件中的最后一个索引。
      void selectRange​(int start, int end)
      从给定的开始索引中选择所有索引到给定的结束索引之前的项目。
      void setSelectionMode​(SelectionMode value)
      设置属性selectionMode的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SelectionModel

        clearAndSelect, clearSelection, clearSelection, getSelectedIndex, getSelectedItem, isEmpty, isSelected, select, select, selectedIndexProperty, selectedItemProperty, selectNext, selectPrevious, setSelectedIndex, setSelectedItem

    • Property Detail

      • selectionMode

        public final ObjectProperty<SelectionMode> selectionModeProperty

        指定在此选择模型中使用的选择模式。 选择模式指定在任何时候可以选择底层数据模型中的多少项目。

        默认情况下，选择模式为SelectionMode.SINGLE 。

        另请参见：
        getSelectionMode() ， setSelectionMode(SelectionMode)

    • 构造方法详细信息

      • MultipleSelectionModel

        public MultipleSelectionModel​()
        创建一个默认的MultipleSelectionModel实例。

    • 方法详细信息

      • setSelectionMode

        public final void setSelectionMode​(SelectionMode value)
        设置属性selectionMode的值。
        Property description:

        指定在此选择模型中使用的选择模式。 选择模式指定在任何时候可以选择底层数据模型中的多少项目。

        默认情况下，选择模式为SelectionMode.SINGLE 。

      • getSelectionMode

        public final SelectionMode getSelectionMode​()
        获取属性selectionMode的值。
        Property description:

        指定在此选择模型中使用的选择模式。 选择模式指定在任何时候可以选择底层数据模型中的多少项目。

        默认情况下，选择模式为SelectionMode.SINGLE 。

      • selectionModeProperty

        public final ObjectProperty<SelectionMode> selectionModeProperty​()

        指定在此选择模型中使用的选择模式。 选择模式指定在任何时候可以选择底层数据模型中的多少项目。

        默认情况下，选择模式为SelectionMode.SINGLE 。

        另请参见：
        getSelectionMode() ， setSelectionMode(SelectionMode)

      • getSelectedIndices

        public abstract ObservableList<Integer> getSelectedIndices​()

        返回所有选定索引的只读 ObservableList。 ObservableList将由选择模型更新以始终反映选择的变化。 这可以通过向返回的ObservableList添加一个ListChangeListener来观察。

        结果
        所选索引的列表

      • getSelectedItems

        public abstract ObservableList<T> getSelectedItems​()

        返回所有选定项目的只读 ObservableList。 ObservableList将通过选择模型进一步更新以始终反映选择的变化。 这可以通过向返回的ObservableList添加一个ListChangeListener来观察。

        结果
        所选项目的列表

      • selectIndices

        public abstract void selectIndices​(int index,
                                   int... indices)

        该方法允许同时设置一个或多个选择。 它将忽略不在有效范围内的任何值（即大于或等于零，小于底层数据模型中的项目总数）。 任何重复的索引都将被忽略。

        如果在此模型中已经选择了一个或多个索引，则调用此方法将不会清除这些选择 - 为此，必须首先调用clearSelection。

        给定的最后一个有效值将成为所选择的索引/选定项目。

        参数
        index - 第一个要选择的索引
        indices - 零个或多个附加索引进行选择

      • selectRange

        public void selectRange​(int start,
                        int end)

        从给定的开始索引中选择所有索引到给定的结束索引之前的项目。 这意味着选择包含开始索引，并且不包括结束索引。 无论开始<end或start> end，此方法都将工作：唯一的常量是给定结束索引之前的索引将成为所选索引。

        如果在此模型中已经选择了一个或多个索引，则调用此方法将不会清除这些选择 - 为此，必须首先调用clearSelection。

        参数
        start - 要选择的第一个索引 - 将选择此索引。
        end - 选择的最后一个索引 - 此索引将不被选中。

      • selectAll

        public abstract void selectAll​()

        方便的方法来选择所有可用的索引。

      • selectFirst

        public abstract void selectFirst​()

        该方法将尝试选择控件中的第一个索引。 如果首先不调用clearSelection，则该方法将具有选择第一个索引的结果，同时保留对当前其他任何索引的选择。

        如果已经选择了第一个索引，调用此方法将不会产生任何结果，并且不会执行选择事件。

        Specified by:
        selectFirst在 SelectionModel<T>

      • selectLast

        public abstract void selectLast​()

        此方法将尝试选择控件中的最后一个索引。 如果没有首先调用clearSelection，则该方法将具有选择最后一个索引的结果，同时保留对其他当前选定索引的选择。

        如果最后一个索引已经被选中，调用该方法将不会有结果，并且不会发生选择事件。

        Specified by:
        selectLast在 SelectionModel<T>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OverrunStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum OverrunStyle

  • java.lang.Object
    • java.lang.Enum<OverrunStyle>
      • javafx.scene.control.OverrunStyle
  • All Implemented Interfaces:
    Serializable ， Comparable<OverrunStyle>

    public enum OverrunStyle
extends Enum<OverrunStyle>
    当渲染文本的空间小于渲染整个字符串所需的空间时，定义标记的控件的行为。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CENTER_ELLIPSIS
      修剪正在显示的字符串的中心，并用“...”替换中间的三个字符。
      CENTER_WORD_ELLIPSIS
      与CENTER_ELLIPSIS相同，但确保“...”发生在完整的单词之间。
      CLIP
      任何超过标签范围的文本都将被剪切。
      ELLIPSIS
      如果标签的文字超过标签范围，则可显示的最后三个字符为“...”。
      LEADING_ELLIPSIS
      与ELLIPSIS相同，但将“...”放在文本的开头，而不是结尾
      LEADING_WORD_ELLIPSIS
      与WORD_ELLIPSIS相同，但将“...”放在文本的开头，而不是结尾
      WORD_ELLIPSIS
      与ELLIPSIS相同，但首先删除标签边界上的任何部分单词，然后应用省略号。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static OverrunStyle valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static OverrunStyle[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CLIP

        public static final OverrunStyle CLIP
        任何超过标签范围的文本都将被剪切。

      • ELLIPSIS

        public static final OverrunStyle ELLIPSIS
        如果标签的文字超过标签范围，则可显示的最后三个字符为“...”。 如果标签太短，甚至不能显示，那么只有很多“。” 将会显示出来。

      • WORD_ELLIPSIS

        public static final OverrunStyle WORD_ELLIPSIS
        与ELLIPSIS相同，但首先删除标签边界上的任何部分单词，然后应用省略号。 这样可确保在省略号之前显示的最后一个字符是完整字的一部分。 如果无法显示完整的字词，则会像ELLIPSIS一样显示尽可能多的字符。

      • CENTER_ELLIPSIS

        public static final OverrunStyle CENTER_ELLIPSIS
        修剪正在显示的字符串的中心，并用“...”替换中间的三个字符。 字符串的第一个和最后一个字符总是显示在标签中，除非标签变得很短，否则不能显示除省略号以外的任何内容。

      • CENTER_WORD_ELLIPSIS

        public static final OverrunStyle CENTER_WORD_ELLIPSIS
        与CENTER_ELLIPSIS相同，但确保“...”发生在完整的单词之间。 如果标签变得如此之短，以至于无法修剪任何其他字词，则会显示部分字词，并且其行为与CENTER_ELLIPSIS相同

      • LEADING_ELLIPSIS

        public static final OverrunStyle LEADING_ELLIPSIS
        与ELLIPSIS相同，但将“...”放在文本的开头，而不是结尾

      • LEADING_WORD_ELLIPSIS

        public static final OverrunStyle LEADING_WORD_ELLIPSIS
        与WORD_ELLIPSIS相同，但将“...”放在文本的开头，而不是结尾

    • 方法详细信息

      • values

        public static OverrunStyle[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (OverrunStyle c : OverrunStyle.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static OverrunStyle valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Pagination (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Pagination

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Pagination
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("pages")
public class Pagination
extends Control

    分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。

    对页面指标进行样式化

    可以通过设置样式类别STYLE_CLASS_BULLET来定制控件以显示数字页面指示符或项目符号样式指示符。 maxPageIndicatorCountProperty可用于更改页面指示器的最大数量。 属性值也可以使用-fx-max-page-indicator-count通过CSS更改。

    页数

    pageCountProperty控制此分页控件具有的页数。 如果页数未知INDETERMINATE应该用作页数。

    页面工厂

    pageFactoryProperty是当应用程序或用户选择页面时调用的回调函数。 该功能是分页控件功能所必需的。 回调函数应该加载并返回所选页面的内容。 如果所选页面索引不存在，则应返回空值。

    创建分页控件：

    一个简单的例子，如何创建一个分页控件与十页和每个页面包含十个超链接。

       Pagination pagination = new Pagination(10, 0); pagination.setPageFactory(new Callback<Integer, Node>() { public Node call(Integer pageIndex) { VBox box = new VBox(5); for (int i = 0; i < pageIndex + 10; i++) { Hyperlink link = new Hyperlink(myurls[i]); box.getChildren().add(link); } return box; } });
    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      IntegerProperty currentPageIndex
      要为此分页控件显示的当前页面索引。
      IntegerProperty maxPageIndicatorCount
      用于此分页控件的页面指示符的最大数量。
      IntegerProperty pageCount
      此分页控件的页数。
      ObjectProperty<Callback<Integer,Node>> pageFactory
      当应用程序或用户选择页面时调用的pageFactory回调函数。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int INDETERMINATE
      用于指示页数不确定的值。
      static String STYLE_CLASS_BULLET
      将类型的数字页面指示符更改为子弹指示器。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Pagination​()
      构造具有 INDETERMINATE页数和页索引等于零的分页控件。
      Pagination​(int pageCount)
      构造一个具有指定页数的新的分页控件。
      Pagination​(int pageCount, int pageIndex)
      使用指定的页数和页索引构造一个新的分页控件。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      IntegerProperty currentPageIndexProperty​()
      要为此分页控件显示的当前页面索引。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      int getCurrentPageIndex​()
      返回当前页面索引。
      int getMaxPageIndicatorCount​()
      返回页面指示符的最大数量。
      int getPageCount​()
      返回页数。
      Callback<Integer,Node> getPageFactory​()
      返回页面工厂回调函数。
      IntegerProperty maxPageIndicatorCountProperty​()
      用于此分页控件的页面指示符的最大数量。
      IntegerProperty pageCountProperty​()
      此分页控件的页数。
      ObjectProperty<Callback<Integer,Node>> pageFactoryProperty​()
      当应用程序或用户选择页面时调用的pageFactory回调函数。
      void setCurrentPageIndex​(int value)
      设置当前页面索引。
      void setMaxPageIndicatorCount​(int value)
      设置页面指示器的最大数量。
      void setPageCount​(int value)
      设置页数。
      void setPageFactory​(Callback<Integer,Node> value)
      设置页面工厂回调函数。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • maxPageIndicatorCount

        public final IntegerProperty maxPageIndicatorCountProperty
        用于此分页控件的页面指示符的最大数量。 如果值小于1或大于pageCount ，则最大页面指标将保持不变。 如果maxPageIndicatorCount不适合，页面指标的数量将减少到适合控件。 默认为10页指示。
        另请参见：
        getMaxPageIndicatorCount() ， setMaxPageIndicatorCount(int)

      • pageCount

        public final IntegerProperty pageCountProperty
        此分页控件的页数。 该值必须大于或等于1.如果总页数未知，则应使用INDETERMINATE作为页数。 默认值为INDETERMINATE页数。
        另请参见：
        getPageCount() ， setPageCount(int)

      • currentPageIndex

        public final IntegerProperty currentPageIndexProperty
        要为此分页控件显示的当前页面索引。 如果值小于0，则第一页将是当前页面。同样，如果值大于pageCount ，最后一页将是当前页面。第一页的默认值为0。

        因为页面指标设置当前页面索引，所以currentPageIndex属性只允许双向绑定。 bind方法抛出UnsupportedOperationException异常。

        另请参见：
        getCurrentPageIndex() ， setCurrentPageIndex(int)

      • pageFactory

        public final ObjectProperty<Callback<Integer,Node>> pageFactoryProperty
        当应用程序或用户选择页面时调用的pageFactory回调函数。 此功能是分页控件功能所必需的。 回调函数应该加载并返回页面索引的内容。 如果页面索引不存在，则应返回空值。 当返回null时，currentPageIndex不会改变。 如果没有页面出厂设置，默认值为null。
        另请参见：
        getPageFactory() ， setPageFactory(Callback)

    • 字段详细信息

      • STYLE_CLASS_BULLET

        public static final String STYLE_CLASS_BULLET
        将类型的数字页面指示符更改为子弹指示器。
        另请参见：
        Constant Field Values

      • INDETERMINATE

        public static final int INDETERMINATE
        用于指示页数不确定的值。
        另请参见：
        setPageCount(int) ， Constant Field Values

    • 构造方法详细信息

      • Pagination

        public Pagination​(int pageCount,
                  int pageIndex)
        使用指定的页数和页索引构造一个新的分页控件。
        参数
        pageCount - 分页控件的页数
        pageIndex - 第一页的索引。

      • Pagination

        public Pagination​(int pageCount)
        构造一个具有指定页数的新的分页控件。
        参数
        pageCount - 分页控件的页数

      • Pagination

        public Pagination​()
        构造分页控件，页面索引为 INDETERMINATE ，页面索引为零。

    • 方法详细信息

      • setMaxPageIndicatorCount

        public final void setMaxPageIndicatorCount​(int value)
        设置页面指示器的最大数量。
        参数
        value - 页面指标的数量。 默认值为10。

      • getMaxPageIndicatorCount

        public final int getMaxPageIndicatorCount​()
        返回页面指示符的最大数量。
        结果
        页面指标的最大数量

      • maxPageIndicatorCountProperty

        public final IntegerProperty maxPageIndicatorCountProperty​()
        用于此分页控件的页面指示符的最大数量。 如果值小于1或大于pageCount ，则最大页面指标将保持不变。 如果maxPageIndicatorCount不适合，页面指标的数量将减少到适合控件。 默认为10页指示。
        另请参见：
        getMaxPageIndicatorCount() ， setMaxPageIndicatorCount(int)

      • setPageCount

        public final void setPageCount​(int value)
        设置页数。
        参数
        value - 页数

      • getPageCount

        public final int getPageCount​()
        返回页数。
        结果
        页数

      • pageCountProperty

        public final IntegerProperty pageCountProperty​()
        此分页控件的页数。 该值必须大于或等于1.如果总页数未知，则应使用INDETERMINATE作为页数。 默认值为INDETERMINATE页数。
        另请参见：
        getPageCount() ， setPageCount(int)

      • setCurrentPageIndex

        public final void setCurrentPageIndex​(int value)
        设置当前页面索引。
        参数
        value - 当前页索引。

      • getCurrentPageIndex

        public final int getCurrentPageIndex​()
        返回当前页面索引。
        结果
        当前页面索引

      • currentPageIndexProperty

        public final IntegerProperty currentPageIndexProperty​()
        要为此分页控件显示的当前页面索引。 如果值小于0，则第一页将是当前页面。同样，如果值大于pageCount ，则最后一页将是当前页面。第一页的默认值为0。

        因为页面指标设置当前页面索引，所以currentPageIndex属性只允许双向绑定。 bind方法抛出UnsupportedOperationException。

        另请参见：
        getCurrentPageIndex() ， setCurrentPageIndex(int)

      • setPageFactory

        public final void setPageFactory​(Callback<Integer,Node> value)
        设置页面工厂回调函数。
        参数
        value - 页面工厂回调函数

      • getPageFactory

        public final Callback<Integer,Node> getPageFactory​()
        返回页面工厂回调函数。
        结果
        页面工厂回调函数

      • pageFactoryProperty

        public final ObjectProperty<Callback<Integer,Node>> pageFactoryProperty​()
        当应用程序或用户选择页面时调用的pageFactory回调函数。 此功能是分页控件功能所必需的。 回调函数应该加载并返回页面索引的内容。 如果页面索引不存在，则应返回空值。 当返回null时，currentPageIndex不会改变。 如果没有页面出厂设置，默认值为null。
        另请参见：
        getPageFactory() ， setPageFactory(Callback)

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PasswordField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class PasswordField

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.TextInputControl
              • javafx.scene.control.TextField
                • javafx.scene.control.PasswordField
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class PasswordField
extends TextField
    掩码输入字符的文本字段。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TextField

        alignment, onAction, prefColumnCount

      • Properties inherited from class javafx.scene.control.TextInputControl

        anchor, caretPosition, editable, font, length, promptText, redoable, selectedText, selection, textFormatter, text, undoable

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.control.TextInputControl

        TextInputControl.Content

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

      • Fields inherited from class javafx.scene.control.TextField

        DEFAULT_PREF_COLUMN_COUNT

    • 构造方法摘要

      构造方法
      Constructor 描述
      PasswordField​()
      创建一个默认的PasswordField实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void copy​()
      PasswordField什么也不做。
      void cut​()
      PasswordField什么也不做。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TextField

        alignmentProperty, createDefaultSkin, getAlignment, getCharacters, getClassCssMetaData, getControlCssMetaData, getOnAction, getPrefColumnCount, onActionProperty, prefColumnCountProperty, setAlignment, setOnAction, setPrefColumnCount

      • Methods inherited from class javafx.scene.control.TextInputControl

        anchorProperty, appendText, backward, cancelEdit, caretPositionProperty, clear, commitValue, deleteNextChar, deletePreviousChar, deleteText, deleteText, deselect, editableProperty, end, endOfNextWord, executeAccessibleAction, extendSelection, fontProperty, forward, getAnchor, getCaretPosition, getContent, getFont, getLength, getPromptText, getSelectedText, getSelection, getText, getText, getTextFormatter, home, insertText, isEditable, isRedoable, isUndoable, lengthProperty, nextWord, paste, positionCaret, previousWord, promptTextProperty, redo, redoableProperty, replaceSelection, replaceText, replaceText, selectAll, selectBackward, selectedTextProperty, selectEnd, selectEndOfNextWord, selectForward, selectHome, selectionProperty, selectNextWord, selectPositionCaret, selectPreviousWord, selectRange, setEditable, setFont, setPromptText, setText, setTextFormatter, textFormatterProperty, textProperty, undo, undoableProperty

    • 构造方法详细信息

      • PasswordField

        public PasswordField​()
        创建一个默认的PasswordField实例。

    • 方法详细信息

      • cut

        public void cut​()
        PasswordField什么也不做。
        重写：
        cut在 TextInputControl

      • copy

        public void copy​()
        PasswordField什么也不做。
        重写：
        copy在 TextInputControl

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 TextInputControl
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PopupControl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class PopupControl

  • java.lang.Object
    • javafx.stage.Window
      • javafx.stage.PopupWindow
        • javafx.scene.control.PopupControl
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    ContextMenu ， Tooltip

    public class PopupControl
extends PopupWindow
implements Skinnable, Styleable
    PopupWindow的扩展，允许CSS样式。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      StringProperty id
      该 PopupControl为 PopupControl 。
      DoubleProperty maxHeight
      覆盖控制计算最大高度的属性。
      DoubleProperty maxWidth
      覆盖控件计算出的最大宽度的属性。
      DoubleProperty minHeight
      超越控制计算的最小高度的属性。
      DoubleProperty minWidth
      覆盖控制计算最小宽度的属性。
      DoubleProperty prefHeight
      用于覆盖控件计算的首选高度的属性。
      DoubleProperty prefWidth
      覆盖控件计算的首选宽度的属性。
      ObjectProperty<Skin<?>> skin
      皮肤负责渲染这个 PopupControl 。
      StringProperty style

      • Properties inherited from class javafx.stage.PopupWindow

        anchorLocation, anchorX, anchorY, autoFix, autoHide, consumeAutoHidingEvents, hideOnEscape, onAutoHide, ownerNode, ownerWindow

      • Properties inherited from class javafx.stage.Window

        eventDispatcher, focused, forceIntegerRenderScale, height, onCloseRequest, onHidden, onHiding, onShowing, onShown, opacity, outputScaleX, outputScaleY, renderScaleX, renderScaleY, scene, showing, width, x, y

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  PopupControl.CSSBridge
      弹出窗口和场景图之间的链接。

      • Nested classes/interfaces inherited from class javafx.stage.PopupWindow

        PopupWindow.AnchorLocation

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected PopupControl.CSSBridge bridge
      我们需要一个特殊的根节点，除了我们不能替代PopupControl中的特殊根节点。
      static double USE_COMPUTED_SIZE
      Sentinel值可以传递给控件的setMinWidth（），setMinHeight（），setPrefWidth（），setPrefHeight（），setMaxWidth（），setMaxHeight（）方法将控件的大小约束重新设置为由computeMinWidth（）返回的内在大小， computeMinHeight（），computePrefWidth（），computePrefHeight（），computeMaxWidth（）或computeMaxHeight（）。
      static double USE_PREF_SIZE
      可以传递给控件的setMinWidth（），setMinHeight（），setMaxWidth（）或setMaxHeight（）方法的Sentinel值，以指示应该使用该最大和/或最小约束的首选维度。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PopupControl​()
      创建一个新的空PopupControl。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      这个样式的CssMetaData。
      String getId​()
      该 PopupControl为 PopupControl 。
      double getMaxHeight​()
      覆盖控制计算最大高度的属性。
      double getMaxWidth​()
      覆盖控件计算出的最大宽度的属性。
      double getMinHeight​()
      超越控制计算的最小高度的属性。
      double getMinWidth​()
      覆盖控制计算最小宽度的属性。
      double getPrefHeight​()
      用于覆盖控件计算的首选高度的属性。
      double getPrefWidth​()
      覆盖控件计算的首选宽度的属性。
      ObservableSet<PseudoClass> getPseudoClassStates​()
      返回此Styleable的伪类状态。
      Skin<?> getSkin​()
      获取属性皮肤的值。
      String getStyle​()
      与此特定 PopupControl相关联的CSS样式的字符串表示 PopupControl 。
      Node getStyleableNode​()
      返回表示此Styleable对象的Node。
      Styleable getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      ObservableList<String> getStyleClass​()
      返回构成此PopupControl的styleClass的String标识符列表。
      String getTypeSelector​()
      这种 Styleable的类型用于选择器匹配。
      StringProperty idProperty​()
      该 PopupControl为 PopupControl 。
      double maxHeight​(double width)
      在布局期间调用以确定此节点的最大高度。
      DoubleProperty maxHeightProperty​()
      覆盖控制计算最大高度的属性。
      double maxWidth​(double height)
      在布局期间调用以确定此节点的最大宽度。
      DoubleProperty maxWidthProperty​()
      覆盖控件计算出的最大宽度的属性。
      double minHeight​(double width)
      在布局期间调用以确定此节点的最小高度。
      DoubleProperty minHeightProperty​()
      超越控制计算的最小高度的属性。
      double minWidth​(double height)
      在布局期间调用以确定此节点的最小宽度。
      DoubleProperty minWidthProperty​()
      覆盖控制计算最小宽度的属性。
      double prefHeight​(double width)
      在布局期间调用以确定此节点的首选高度。
      DoubleProperty prefHeightProperty​()
      用于覆盖控件计算的首选高度的属性。
      double prefWidth​(double height)
      在布局期间调用以确定此节点的首选宽度。
      DoubleProperty prefWidthProperty​()
      覆盖控件计算的首选宽度的属性。
      void | pseudoClassStateChanged​(PseudoClass pseudoClass, boolean active)
      void setId​(String value)
      设置这个 PopupControl的id。
      void setMaxHeight​(double value)
      覆盖控制计算最大高度的属性。
      void setMaxSize​(double maxWidth, double maxHeight)
      用于覆盖控件计算的最大宽度和高度的便捷方法。
      void setMaxWidth​(double value)
      覆盖控件计算出的最大宽度的属性。
      void setMinHeight​(double value)
      超越控制计算的最小高度的属性。
      void setMinSize​(double minWidth, double minHeight)
      用于覆盖控制计算的最小宽度和高度的便捷方法。
      void setMinWidth​(double value)
      覆盖控制计算最小宽度的属性。
      void setPrefHeight​(double value)
      用于覆盖控件计算的首选高度的属性。
      void setPrefSize​(double prefWidth, double prefHeight)
      用于覆盖控件计算的首选宽度和高度的便捷方法。
      void setPrefWidth​(double value)
      覆盖控件计算的首选宽度的属性。
      void setSkin​(Skin<?> value)
      设置属性皮肤的值。
      void setStyle​(String value)
      与此特定 PopupControl相关联的CSS样式的字符串表示 PopupControl 。
      ObjectProperty<Skin<?>> skinProperty​()
      皮肤负责渲染这个 PopupControl 。
      StringProperty styleProperty​()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.stage.PopupWindow

        anchorLocationProperty, anchorXProperty, anchorYProperty, autoFixProperty, autoHideProperty, consumeAutoHidingEventsProperty, getAnchorLocation, getAnchorX, getAnchorY, getConsumeAutoHidingEvents, getOnAutoHide, getOwnerNode, getOwnerWindow, hide, hideOnEscapeProperty, isAutoFix, isAutoHide, isHideOnEscape, onAutoHideProperty, ownerNodeProperty, ownerWindowProperty, setAnchorLocation, setAnchorX, setAnchorY, setAutoFix, setAutoHide, setConsumeAutoHidingEvents, setHideOnEscape, setOnAutoHide, setScene, show, show, show

      • Methods inherited from class javafx.stage.Window

        addEventFilter, addEventHandler, buildEventDispatchChain, centerOnScreen, eventDispatcherProperty, fireEvent, focusedProperty, forceIntegerRenderScaleProperty, getEventDispatcher, getHeight, getOnCloseRequest, getOnHidden, getOnHiding, getOnShowing, getOnShown, getOpacity, getOutputScaleX, getOutputScaleY, getProperties, getRenderScaleX, getRenderScaleY, getScene, getUserData, getWidth, getWindows, getX, getY, hasProperties, heightProperty, isFocused, isForceIntegerRenderScale, isShowing, onCloseRequestProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, opacityProperty, outputScaleXProperty, outputScaleYProperty, removeEventFilter, removeEventHandler, renderScaleXProperty, renderScaleYProperty, requestFocus, sceneProperty, setEventDispatcher, setEventHandler, setForceIntegerRenderScale, setHeight, setOnCloseRequest, setOnHidden, setOnHiding, setOnShowing, setOnShown, setOpacity, setRenderScaleX, setRenderScaleY, setUserData, setWidth, setX, setY, show, showingProperty, sizeToScene, widthProperty, xProperty, yProperty

    • Property Detail

      • id

        public final StringProperty idProperty
        该PopupControl为PopupControl 。 这个简单的字符串标识符可用于在场景图中查找特定的节点。 虽然节点的ID在场景图中应该是唯一的，但是这种唯一性不会被强制执行。 这类似于HTML元素（ CSS ID Specification ）上的“id”属性。
        Default value:
        空值
        另请参见：
        getId() ， setId(String)

      • style

        public final StringProperty styleProperty
        另请参见：
        getStyle() ， setStyle(String)

      • skin

        public final ObjectProperty<Skin<?>> skinProperty
        皮肤负责渲染这个PopupControl 。 从PopupControl的角度来看， Skin是一个黑盒子。 它在PopupControl监听和响应状态的PopupControl 。

        PopupControl与其Skin之间存在一对一的关系。 每Skin保持回参考PopupControl 。

        皮肤可能为空。

        Specified by:
        skinProperty在接口 Skinnable
        另请参见：
        getSkin() ， setSkin(Skin)

      • minWidth

        public final DoubleProperty minWidthProperty
        覆盖控制计算最小宽度的属性。 只有当控件的内部计算的最小宽度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMinWidth(forHeight)将返回控件的内部计算的最小宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMinWidth(forHeight)返回控件的首选宽度，从而使应用程序能够轻松限制控件的可复位性。

        另请参见：
        getMinWidth() ， setMinWidth(double)

      • minHeight

        public final DoubleProperty minHeightProperty
        超越控制计算的最小高度的属性。 只有当控件的内部计算的最小高度不符合应用程序的布局需求时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getMinHeight(forWidth)将返回控件内部计算的最小高度。

        将此值设置为USE_PREF_SIZE标志将导致getMinHeight(forWidth)返回控件的首选高度，使应用程序能够轻松限制控件的可复位性。

        另请参见：
        getMinHeight() ， setMinHeight(double)

      • prefWidth

        public final DoubleProperty prefWidthProperty
        覆盖控件计算的首选宽度的属性。 只有当控件的内部计算的首选宽度不符合应用程序的布局需要时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefWidth(forHeight)将返回控件的内部计算的首选宽度。

        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • prefHeight

        public final DoubleProperty prefHeightProperty
        用于覆盖控件计算的首选高度的属性。 只有当控件的内部计算的首选高度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefHeight(forWidth)将返回控件的内部计算的首选宽度。

        另请参见：
        getPrefHeight() ， setPrefHeight(double)

      • maxWidth

        public final DoubleProperty maxWidthProperty
        覆盖控件计算出的最大宽度的属性。 只有当控件的内部计算的最大宽度不符合应用程序的布局需求时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxWidth(forHeight)将返回控件的内部计算的最大宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxWidth(forHeight)返回控件的首选宽度，使应用程序能够轻松地限制控件的可复位性。

        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • maxHeight

        public final DoubleProperty maxHeightProperty
        覆盖控制计算最大高度的属性。 只有当控件的内部计算的最大高度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxHeight(forWidth)将返回控件的内部计算最大高度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxHeight(forWidth)返回控件的首选高度，使应用程序能够轻松限制控件的可复位性。

        另请参见：
        getMaxHeight() ， setMaxHeight(double)

    • 字段详细信息

      • USE_PREF_SIZE

        public static final double USE_PREF_SIZE
        可以传递给控件的setMinWidth（），setMinHeight（），setMaxWidth（）或setMaxHeight（）方法的Sentinel值，以指示应该使用该最大和/或最小约束的首选维度。
        另请参见：
        Constant Field Values

      • USE_COMPUTED_SIZE

        public static final double USE_COMPUTED_SIZE
        Sentinel值可以传递给控件的setMinWidth（），setMinHeight（），setPrefWidth（），setPrefHeight（），setMaxWidth（），setMaxHeight（）方法将控件的大小约束重新设置为由computeMinWidth（）返回的内在大小， computeMinHeight（），computePrefWidth（），computePrefHeight（），computeMaxWidth（）或computeMaxHeight（）。
        另请参见：
        Constant Field Values

      • bridge

        protected PopupControl.CSSBridge bridge
        我们需要一个特殊的根节点，除了我们不能替代PopupControl中的特殊根节点。 所以我们将设置我们自己的特殊的几乎根节点，它是根的一个孩子。 这个特殊的根节点负责映射在PopupControl上定义的id，styleClass和style，使得CSS将从PopupControl中读取值，然后将CSS状态应用于该特殊节点。 然后，节点将能够传递cssSet调用，使得PopupControl的任何子类都能够使用Styleable属性，并且我们将能够从CSS进行样式化，使其参与并应用于皮肤，正常皮肤正常控制的工作方式。
        从以下版本开始：
        JavaFX 2.1

    • 构造方法详细信息

      • PopupControl

        public PopupControl​()
        创建一个新的空PopupControl。

    • 方法详细信息

      • idProperty

        public final StringProperty idProperty​()
        该PopupControl为PopupControl 。 这个简单的字符串标识符可用于在场景图中查找特定的节点。 虽然节点的ID在场景图中应该是唯一的，但是这种唯一性不会被强制执行。 这类似于HTML元素上的“id”属性（ CSS ID Specification ）。
        Default value:
        空值
        另请参见：
        getId() ， setId(String)

      • setId

        public final void setId​(String value)
        设置这个PopupControl的id。 这个简单的字符串标识符可用于在场景图中查找特定的节点。 虽然节点的ID在场景图中应该是唯一的，但是这种唯一性不会被强制执行。 这类似于HTML元素上的“id”属性（ CSS ID Specification ）。
        Default value:
        空值
        参数
        value - 使用 setId方法分配给此 PopupControl的 setId或 null ，如果没有分配ID。

      • getId

        public final String getId​()
        该PopupControl为PopupControl 。 这个简单的字符串标识符可用于在场景图中查找特定的节点。 虽然节点的ID在场景图中应该是唯一的，但是这种唯一性不会被强制执行。 这类似于HTML元素上的“id”属性（ CSS ID Specification ）。
        Specified by:
        getId在接口 Styleable
        Default value:
        空值
        结果
        使用 setId方法或 null分配给此 PopupControl的ID，如果没有分配ID。

      • getStyleClass

        public final ObservableList<String> getStyleClass​()
        返回构成此PopupControl的styleClass的String标识符列表。
        Specified by:
        getStyleClass在接口 Styleable
        结果
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎
        另请参见：
        CSS3 class selectors

      • setStyle

        public final void setStyle​(String value)
        与此特定PopupControl相关联的CSS样式的字符串表示PopupControl 。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        Default value:
        空字符串
        参数
        value - 用于此PopupControl的内联CSS样式。 null隐式转换为空字符串。

      • getStyle

        public final String getStyle​()
        与此特定PopupControl相关联的CSS样式的字符串表示PopupControl 。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。
        Specified by:
        getStyle在接口 Styleable
        Default value:
        空字符串
        结果
        与此PopupControl相关联的内联CSS样式。 如果这个PopupControl没有内联样式，则返回一个空字符串。

      • styleProperty

        public final StringProperty styleProperty​()
        另请参见：
        getStyle() ， setStyle(String)

      • skinProperty

        public final ObjectProperty<Skin<?>> skinProperty​()
        皮肤负责渲染这个PopupControl 。 从PopupControl的角度来看， Skin是一个黑盒子。 它在PopupControl监听和响应状态的PopupControl 。

        PopupControl与其Skin之间存在一对一的关系。 每Skin保持回参考PopupControl 。

        皮肤可能为空。

        Specified by:
        skinProperty在接口 Skinnable
        另请参见：
        getSkin() ， setSkin(Skin)

      • setSkin

        public final void setSkin​(Skin<?> value)
        设置属性皮肤的值。
        Specified by:
        setSkin在接口 Skinnable
        Property description:
        皮肤负责渲染这个PopupControl 。 从PopupControl的角度来看， Skin是一个黑盒子。 它在PopupControl监听和响应状态的PopupControl 。

        PopupControl与其Skin之间存在一对一的关系。 每Skin保持回参考PopupControl 。

        皮肤可能为空。

        参数
        value - 此控件的皮肤值

      • getSkin

        public final Skin<?> getSkin​()
        获取属性皮肤的值。
        Specified by:
        getSkin在接口 Skinnable
        Property description:
        皮肤负责渲染这个PopupControl 。 从PopupControl的角度来看， Skin是一个黑盒子。 它在PopupControl监听和响应状态的PopupControl 。

        PopupControl与其Skin之间存在一对一的关系。 每Skin保持回参考PopupControl 。

        皮肤可能为空。

        结果
        这个控制的皮肤

      • setMinWidth

        public final void setMinWidth​(double value)
        覆盖控制计算最小宽度的属性。 只有当控件的内部计算的最小宽度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMinWidth(forHeight)将返回控件的内部计算的最小宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMinWidth(forHeight)返回控件的首选宽度，从而使应用程序能够轻松限制控件的可复位性。

        参数
        value - 最小宽度

      • getMinWidth

        public final double getMinWidth​()
        覆盖控制计算最小宽度的属性。 只有当控件的内部计算的最小宽度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMinWidth(forHeight)将返回控件的内部计算的最小宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMinWidth(forHeight)返回控件的首选宽度，使应用程序能够轻松限制控件的可复位性。

        结果
        最小宽度

      • minWidthProperty

        public final DoubleProperty minWidthProperty​()
        覆盖控制计算最小宽度的属性。 只有当控件的内部计算的最小宽度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMinWidth(forHeight)将返回控件的内部计算的最小宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMinWidth(forHeight)返回控件的首选宽度，使应用程序能够轻松地限制控件的可复位性。

        另请参见：
        getMinWidth() ， setMinWidth(double)

      • setMinHeight

        public final void setMinHeight​(double value)
        超越控制计算的最小高度的属性。 只有当控件的内部计算的最小高度不符合应用程序的布局需求时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getMinHeight(forWidth)将返回控件内部计算的最小高度。

        将此值设置为USE_PREF_SIZE标志将导致getMinHeight(forWidth)返回控件的首选高度，使应用程序能够轻松限制控件的可复位性。

        参数
        value - 最小高度

      • getMinHeight

        public final double getMinHeight​()
        超越控制计算的最小高度的属性。 只有当控件的内部计算的最小高度不符合应用程序的布局需求时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getMinHeight(forWidth)将返回控件的内部计算的最小高度。

        将此值设置为USE_PREF_SIZE标志将导致getMinHeight(forWidth)返回控件的首选高度，使应用程序能够轻松限制控件的可复位性。

        结果
        最小高度

      • minHeightProperty

        public final DoubleProperty minHeightProperty​()
        超越控制计算的最小高度的属性。 只有当控件的内部计算的最小高度不符合应用程序的布局需求时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getMinHeight(forWidth)将返回控件的内部计算的最小高度。

        将此值设置为USE_PREF_SIZE标志将导致getMinHeight(forWidth)返回控件的首选高度，使应用程序能够轻松限制控件的可复位性。

        另请参见：
        getMinHeight() ， setMinHeight(double)

      • setMinSize

        public void setMinSize​(double minWidth,
                       double minHeight)
        用于覆盖控制计算的最小宽度和高度的便捷方法。 只有当控件的内部计算的最小大小不符合应用程序的布局需求时，才应该调用这个。
        参数
        minWidth - 最小宽度的覆盖值
        minHeight - 最小高度的覆盖值
        另请参见：
        setMinWidth(double) ， setMinHeight(double)

      • setPrefWidth

        public final void setPrefWidth​(double value)
        覆盖控件计算的首选宽度的属性。 只有当控件的内部计算的首选宽度不符合应用程序的布局需要时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefWidth(forHeight)将返回控件的内部计算首选宽度。

        参数
        value - 首选宽度

      • getPrefWidth

        public final double getPrefWidth​()
        覆盖控件计算的首选宽度的属性。 只有当控件的内部计算的首选宽度不符合应用程序的布局需要时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefWidth(forHeight)将返回控件的内部计算的首选宽度。

        结果
        优选的宽度

      • prefWidthProperty

        public final DoubleProperty prefWidthProperty​()
        覆盖控件计算的首选宽度的属性。 只有当控件的内部计算的首选宽度不符合应用程序的布局需要时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefWidth(forHeight)将返回控件的内部计算的首选宽度。

        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • setPrefHeight

        public final void setPrefHeight​(double value)
        用于覆盖控件计算的首选高度的属性。 只有当控件的内部计算的首选高度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefHeight(forWidth)将返回控件的内部计算的首选宽度。

        参数
        value - 首选高度

      • getPrefHeight

        public final double getPrefHeight​()
        用于覆盖控件计算的首选高度的属性。 只有当控件的内部计算的首选高度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefHeight(forWidth)将返回控件的内部计算的首选宽度。

        结果
        首选高度

      • prefHeightProperty

        public final DoubleProperty prefHeightProperty​()
        用于覆盖控件计算的首选高度的属性。 只有当控件的内部计算的首选高度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefHeight(forWidth)将返回控件的内部计算的首选宽度。

        另请参见：
        getPrefHeight() ， setPrefHeight(double)

      • setPrefSize

        public void setPrefSize​(double prefWidth,
                        double prefHeight)
        用于覆盖控件计算的首选宽度和高度的便捷方法。 只有当控件的内部计算的首选大小不符合应用程序的布局需求时，才应该调用此方法。
        参数
        prefWidth - 首选宽度的覆盖值
        prefHeight - 首选高度的覆盖值
        另请参见：
        setPrefWidth(double) ， setPrefHeight(double)

      • setMaxWidth

        public final void setMaxWidth​(double value)
        覆盖控件计算出的最大宽度的属性。 只有当控件的内部计算的最大宽度不符合应用程序的布局需求时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxWidth(forHeight)将返回控件的内部计算的最大宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxWidth(forHeight)返回控件的首选宽度，使应用程序能够轻松限制控件的可复位性。

        参数
        value - 最大宽度

      • getMaxWidth

        public final double getMaxWidth​()
        覆盖控件计算出的最大宽度的属性。 只有当控件的内部计算的最大宽度不符合应用程序的布局需求时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxWidth(forHeight)将返回控件的内部计算的最大宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxWidth(forHeight)返回控件的首选宽度，使应用程序能够轻松限制控件的可重定位。

        结果
        最大宽度

      • maxWidthProperty

        public final DoubleProperty maxWidthProperty​()
        覆盖控件计算出的最大宽度的属性。 只有当控件的内部计算的最大宽度不符合应用程序的布局需求时，才应该设置。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxWidth(forHeight)将返回控件的内部计算的最大宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxWidth(forHeight)返回控件的首选宽度，使应用程序能够轻松限制控件的可复位性。

        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • setMaxHeight

        public final void setMaxHeight​(double value)
        覆盖控制计算最大高度的属性。 只有当控件的内部计算的最大高度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxHeight(forWidth)将返回控件的内部计算的最大高度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxHeight(forWidth)返回控件的首选高度，使应用程序能够轻松限制控件的可复位性。

        参数
        value - 最大高度

      • getMaxHeight

        public final double getMaxHeight​()
        覆盖控制计算最大高度的属性。 只有当控件的内部计算的最大高度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxHeight(forWidth)将返回控件的内部计算最大高度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxHeight(forWidth)返回控件的首选高度，使应用程序能够轻松地限制控件的可复位性。

        结果
        最大高度

      • maxHeightProperty

        public final DoubleProperty maxHeightProperty​()
        覆盖控制计算最大高度的属性。 只有当控件的内部计算的最大高度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxHeight(forWidth)将返回控件的内部计算的最大高度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxHeight(forWidth)返回控件的首选高度，使应用程序能够轻松限制控件的可复位性。

        另请参见：
        getMaxHeight() ， setMaxHeight(double)

      • setMaxSize

        public void setMaxSize​(double maxWidth,
                       double maxHeight)
        用于覆盖控件计算的最大宽度和高度的便捷方法。 只有当控件的内部计算的最大大小不符合应用程序的布局需求时，才应该调用此方法。
        参数
        maxWidth - 最大宽度的覆盖值
        maxHeight - 最大高度的覆盖值
        另请参见：
        setMaxWidth(double) ， setMaxHeight(double)

      • minWidth

        public final double minWidth​(double height)
        在布局期间调用以确定此节点的最小宽度。 从minWidth(forHeight)返回值，除非应用程序通过设置minWidth属性来覆盖最小宽度。
        参数
        height - 高度
        结果
        在布局期间该节点应该调整大小的最小宽度
        另请参见：
        setMinWidth(double)

      • minHeight

        public final double minHeight​(double width)
        在布局期间调用以确定此节点的最小高度。 从minHeight(forWidth)返回值，除非应用程序通过设置minHeight属性来覆盖最小高度。
        参数
        width - 宽度
        结果
        在布局期间该节点应该调整大小的最小高度
        另请参见：
        setMinHeight(double)

      • prefWidth

        public final double prefWidth​(double height)
        在布局期间调用以确定此节点的首选宽度。 返回值从prefWidth(forHeight)除非应用程序通过设置prefWidth属性来覆盖首选宽度。
        参数
        height - 高度
        结果
        在布局期间该节点应该调整大小的首选宽度
        另请参见：
        setPrefWidth(double)

      • prefHeight

        public final double prefHeight​(double width)
        在布局期间调用以确定此节点的首选高度。 从prefHeight(forWidth)返回值，除非应用程序通过设置prefHeight属性来覆盖首选高度。
        参数
        width - 宽度
        结果
        在布局期间该节点应该调整大小的首选高度
        另请参见：
        setPrefHeight(double)

      • maxWidth

        public final double maxWidth​(double height)
        在布局期间调用以确定此节点的最大宽度。 从maxWidth(forHeight)返回值，除非应用程序通过设置maxWidth属性来覆盖最大宽度。
        参数
        height - 高度
        结果
        在布局期间该节点应该调整大小的最大宽度
        另请参见：
        setMaxWidth(double)

      • maxHeight

        public final double maxHeight​(double width)
        在布局期间调用以确定此节点的最大高度。 从maxHeight(forWidth)返回值，除非应用程序通过设置maxHeight属性来覆盖最大高度。
        参数
        width - 宽度
        结果
        在布局期间该节点应该调整大小的最大高度
        另请参见：
        setMaxHeight(double)

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用它来创建控件的皮肤。
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。
        从以下版本开始：
        JavaFX 8.0

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        这个样式的CssMetaData。 这可以作为不可修改的列表返回。
        Specified by:
        getCssMetaData在接口 Styleable
        结果
        CssMetaData
        从以下版本开始：
        JavaFX 8.0

      • pseudoClassStateChanged

        public final void pseudoClassStateChanged​(PseudoClass pseudoClass,
                                          boolean active)
        参数
        pseudoClass - 伪类
        active - 活动状态
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Node.pseudoClassStateChanged(javafx.css.PseudoClass, boolean)

      • getTypeSelector

        public String getTypeSelector​()
        这种Styleable的类型用于选择器匹配。 这类似于HTML中的“元素”。 （ CSS Type Selector ）。
        Specified by:
        getTypeSelector在接口 Styleable
        结果
        “PopupControl”
        从以下版本开始：
        JavaFX 8.0

      • getStyleableParent

        public Styleable getStyleableParent​()
        返回此Styleable的父项，如果没有父项则返回null。 PopupControl的样式基于弹出的“所有者”，即ownerNode，或者如果ownerNode未设置， 则为ownerWindow's场景的根。 如果弹出窗口尚未显示，ownerNode和ownerWindow都将为null，并返回null 。 请注意，PopupWindow的场景根不会返回，因为没有办法保证PopupWindow的场景根将正确返回ownerNode或ownerWindow。
        Specified by:
        getStyleableParent在接口 Styleable
        结果
        PopupWindow.getOwnerNode() ， PopupWindow.getOwnerWindow() ，或者为null。
        从以下版本开始：
        JavaFX 8.0

      • getPseudoClassStates

        public final ObservableSet<PseudoClass> getPseudoClassStates​()
        返回此Styleable的伪类状态。 CSS假定此集是只读的。
        Specified by:
        getPseudoClassStates在接口 Styleable
        结果
        伪类状态
        从以下版本开始：
        JavaFX 8.0

      • getStyleableNode

        public Node getStyleableNode​()
        返回表示此Styleable对象的Node。 在Styleable本身不是Node的情况下，应该覆盖此方法，以便它可以可选地返回其本身的相关根节点表示。 默认情况下，此方法返回null，这可能意味着Styleable本身是一个Node，如果不是这种情况，则Styleable在请求时没有可用的节点表示。
        Specified by:
        getStyleableNode在接口 Styleable
        结果
        表示此Styleable对象的节点
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PopupControl.CSSBridge (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class PopupControl.CSSBridge

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.control.PopupControl.CSSBridge
  • All Implemented Interfaces:
    Styleable ， EventTarget
    Enclosing class:
    PopupControl

    protected class PopupControl.CSSBridge
extends Pane
    弹出窗口和场景图之间的链接。
    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | CSSBridge​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      Styleable getStyleableParent​()
      该方法应被视为最终方法，不应被CSSBridge的任何子类覆盖。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, layoutChildren, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getBackground, getBorder, getClassCssMetaData, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • CSSBridge

        protected CSSBridge​()

    • 方法详细信息

      • requestLayout

        public void requestLayout​()
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果这个父对象是布局根或非托管，那么它将直接添加到场景的脏布局列表中，否则requestLayout将在其父对象上被调用。

        重写：
        requestLayout在 Parent

      • getStyleableParent

        public Styleable getStyleableParent​()
        该方法应被视为最终方法，不应被CSSBridge的任何子类覆盖。
        Specified by:
        getStyleableParent在接口 Styleable
        重写：
        getStyleableParent在 Node
        结果
        风格的父母

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        描述从类别复制Region
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProgressBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ProgressBar

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ProgressIndicator
              • javafx.scene.control.ProgressBar
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ProgressBar
extends ProgressIndicator
    ProgressIndator的专业化表示为横杠。

    ProgressBar将focusTraversable设置为false。

    此第一个示例创建一个具有不确定值的ProgressBar：

       import javafx.scene.control.ProgressBar; ProgressBar p1 = new ProgressBar();

    下一个示例创建一个25％完成的ProgressBar：

       import javafx.scene.control.ProgressBar; ProgressBar p2 = new ProgressBar(); p2.setProgress(0.25F);
    根据JavaFX UI Control API规范实现ProgressBar
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.control.ProgressIndicator

        indeterminate, progress

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.control.ProgressIndicator

        INDETERMINATE_PROGRESS

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProgressBar​()
      创建一个新的不确定ProgressBar。
      ProgressBar​(double progress)
      用给定的进度值创建一个新的ProgressBar。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.control.ProgressIndicator

        getProgress, indeterminateProperty, isIndeterminate, progressProperty, setProgress

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • ProgressBar

        public ProgressBar​()
        创建一个新的不确定ProgressBar。

      • ProgressBar

        public ProgressBar​(double progress)
        用给定的进度值创建一个新的ProgressBar。
        参数
        progress - 进度，以0和1之间的值表示

    • 方法详细信息

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin ProgressIndicator
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 ProgressIndicator
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 ProgressIndicator
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProgressIndicator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ProgressIndicator

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ProgressIndicator
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    ProgressBar

    public class ProgressIndicator
extends Control
    用于指示进度的循环控制，无限（也称为不确定）或有限。 通常与Task API一起使用来表示后台任务的进度。

    ProgressIndicator将focusTraversable设置为false。

    此第一个示例创建一个具有不确定值的ProgressIndicator：

       import javafx.scene.control.ProgressIndicator; ProgressIndicator p1 = new ProgressIndicator();

    下一个示例创建一个完成25％的ProgressIndicator：

       import javafx.scene.control.ProgressIndicator; ProgressIndicator p2 = new ProgressIndicator(); p2.setProgress(0.25F);
    根据JavaFX UI控件API规范实现ProgressIndicator
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty indeterminate
      指示是否可以确定ProgressIndicator的进度的标志。
      DoubleProperty progress
      ProgressIndicator的实际进展。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double INDETERMINATE_PROGRESS
      进度值显示进度是不确定的。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProgressIndicator​()
      创建一个新的不确定的ProgressIndicator。
      ProgressIndicator​(double progress)
      使用给定的进度值创建一个新的ProgressIndicator。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      double getProgress​()
      获取属性进度的值。
      ReadOnlyBooleanProperty indeterminateProperty​()
      指示是否可以确定ProgressIndicator的进度的标志。
      boolean isIndeterminate​()
      获取属性的值不确定。
      DoubleProperty progressProperty​()
      ProgressIndicator的实际进展。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setProgress​(double value)
      设置属性进度的值。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • indeterminate

        public final ReadOnlyBooleanProperty indeterminateProperty
        指示是否可以确定ProgressIndicator的进度的标志。 通常，不确定的进度条呈现为某种形式的动画，指示潜在的“无限”进度。
        另请参见：
        isIndeterminate()

      • progress

        public final DoubleProperty progressProperty
        ProgressIndicator的实际进展。 进度的负值表示进度是不确定的。 0和1之间的正值表示0为0％，1为100％的进度百分比。 任何大于1的值都被解释为100％。
        另请参见：
        getProgress() ， setProgress(double)

    • 字段详细信息

      • INDETERMINATE_PROGRESS

        public static final double INDETERMINATE_PROGRESS
        进度值显示进度是不确定的。
        另请参见：
        setProgress(double) ， Constant Field Values

    • 构造方法详细信息

      • ProgressIndicator

        public ProgressIndicator​()
        创建一个新的不确定的ProgressIndicator。

      • ProgressIndicator

        public ProgressIndicator​(double progress)
        使用给定的进度值创建一个新的ProgressIndicator。
        参数
        progress - 进度，表示为0和1之间的值

    • 方法详细信息

      • isIndeterminate

        public final boolean isIndeterminate​()
        获取属性的值不确定。
        Property description:
        指示是否可以确定ProgressIndicator的进度的标志。 通常，不确定的进度条呈现为某种形式的动画，指示潜在的“无限”进度。

      • indeterminateProperty

        public final ReadOnlyBooleanProperty indeterminateProperty​()
        指示是否可以确定ProgressIndicator的进度的标志。 通常，不确定的进度条呈现为某种形式的动画，指示潜在的“无限”进度。
        另请参见：
        isIndeterminate()

      • setProgress

        public final void setProgress​(double value)
        设置属性进度的值。
        Property description:
        ProgressIndicator的实际进展。 进度的负值表示进度是不确定的。 0和1之间的正值表示0为0％，1为100％的进度百分比。 任何大于1的值都被解释为100％。

      • getProgress

        public final double getProgress​()
        获取属性进度的值。
        Property description:
        ProgressIndicator的实际进展。 进度的负值表示进度是不确定的。 0和1之间的正值表示0为0％，1为100％的进度百分比。 任何大于1的值都被解释为100％。

      • progressProperty

        public final DoubleProperty progressProperty​()
        ProgressIndicator的实际进展。 进度的负值表示进度是不确定的。 0和1之间的正值表示0为0％，1为100％的进度百分比。 任何大于1的值都被解释为100％。
        另请参见：
        getProgress() ， setProgress(double)

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RadioButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class RadioButton

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.ButtonBase
                • javafx.scene.control.ToggleButton
                  • javafx.scene.control.RadioButton
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable ， Toggle

    public class RadioButton
extends ToggleButton

    RadioButtons创建一系列只能选择一个项目的项目。 RadioButtons是一个专业的ToggleButton 。 当一个RadioButton被按下并释放时，发送一个ActionEvent 。 您的应用程序可以通过实现执行基于此事件的一些动作EventHandler处理ActionEvent 。

    放置在ToggleGroup中时，只能选择一个RadioButton。 点击所选的RadioButton将不起作用。 不能在ToggleGroup中的RadioButton可以被选择和取消选择。 默认情况下，RadioButton不在ToggleGroup中。 拨打ToggleGroup.getSelectedToggle()将会返回已选择的RadioButton。

       ToggleGroup group = new ToggleGroup(); RadioButton button1 = new RadioButton("select first"); button1.setToggleGroup(group); button1.setSelected(true); RadioButton button2 = new RadioButton("select second"); button2.setToggleGroup(group);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.control.ButtonBase

        armed, onAction

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.ToggleButton

        selected, toggleGroup

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      RadioButton​()
      为其标签创建一个空字符串的单选按钮。
      RadioButton​(String text)
      创建具有指定文本的单选按钮作为其标签。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void fire​()
      当且仅当RadioButton尚未选择或不是ToggleGroup的一部分时，才能切换单选按钮的状态。
      protected Pos getInitialAlignment​()
      返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class javafx.scene.control.ButtonBase

        arm, armedProperty, disarm, executeAccessibleAction, getOnAction, isArmed, onActionProperty, setOnAction

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from interface javafx.scene.control.Toggle

        getProperties, getUserData, setUserData

      • Methods inherited from class javafx.scene.control.ToggleButton

        getToggleGroup, isSelected, selectedProperty, setSelected, setToggleGroup, toggleGroupProperty

    • 构造方法详细信息

      • RadioButton

        public RadioButton​()
        为其标签创建一个空字符串的单选按钮。

      • RadioButton

        public RadioButton​(String text)
        创建具有指定文本的单选按钮作为其标签。
        参数
        text - 其标签的文本字符串。

    • 方法详细信息

      • fire

        public void fire​()
        当且仅当RadioButton尚未选择或不是ToggleGroup的一部分时，才能切换单选按钮的状态。
        重写：
        fire在 ToggleButton

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用它来创建控件的皮肤。
        重写：
        createDefaultSkin在 ToggleButton
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getInitialAlignment

        protected Pos getInitialAlignment​()
        返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。 该方法最初被覆盖使用Pos.CENTER_LEFT。
        重写：
        getInitialAlignment在 ToggleButton
        结果
        该控件的初始对齐状态
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 ToggleButton
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RadioMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class RadioMenuItem

  • java.lang.Object
    • javafx.scene.control.MenuItem
      • javafx.scene.control.RadioMenuItem
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Toggle

    public class RadioMenuItem
extends MenuItem
implements Toggle

    RadioMenuItem是一个MenuItem可以切换（它使用Toggle mixin）。 这意味着RadioMenuItem的API性质与使用Toggle的其他控件（如RadioButton和ToggleButton）非常相似。 RadioMenuItem专门设计用于Menu ，因此请参考该类API文档以获取有关如何在其中添加RadioMenuItem的更多信息。

    要创建一个简单的，未分组的RadioMenuItem，请执行以下操作：

       RadioMenuItem radioItem = new RadioMenuItem("radio text"); radioItem.setSelected(false); radioItem.setOnAction(new EventHandler<ActionEvent>() { @Override public void handle(ActionEvent e) { System.out.println("radio toggled"); } });

    上述示例的问题是，这不利于使用普通菜单项。 如前所述，RadioMenuItem的目的是为用户提供多种选择，并且只允许在任何一个时间选择这些选择之一（即选择应该是相互排斥的 ）。 要实现这一点，您可以将零个或多个RadioMenuItem放入组中。 在组中，可以选择该组内每次只有一个RadioMenuItem。 要将两个RadioMenuItem实例放入同一个组，只需为它们分配toggleGroup的相同值。 例如：

       ToggleGroup toggleGroup = new ToggleGroup(); RadioMenuItem radioItem1 = new RadioMenuItem("Option 1"); radioItem.setOnAction(new EventHandler<ActionEvent>() { @Override public void handle(ActionEvent e) { System.out.println("radio toggled"); } }); radioItem1.setToggleGroup(toggleGroup); RadioMenuItem radioItem2 = new RadioMenuItem("Option 2"); radioItem.setOnAction(new EventHandler<ActionEvent>() { @Override public void handle(ActionEvent e) { System.out.println("radio toggled"); } }); radioItem2.setToggleGroup(toggleGroup);
    在这个例子中，由于RadioMenuItem的两个分配给相同的ToggleGroup ，所以在任何一个时间只能选择一个项目，如果选择更改，则ToggleGroup将会关闭取消选择上一个项目。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MenuItem ， Menu

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty selected
      选择状态为这个 Toggle 。
      ObjectProperty<ToggleGroup> toggleGroup
      代表这个RadioMenuItem所属的ToggleGroup 。

      • Properties inherited from class javafx.scene.control.MenuItem

        accelerator, disable, graphic, id, mnemonicParsing, onAction, onMenuValidation, parentMenu, parentPopup, style, text, visible

    • Field Summary

      • Fields inherited from class javafx.scene.control.MenuItem

        MENU_VALIDATION_EVENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      RadioMenuItem​()
      构造一个没有显示文本的RadioMenuItem。
      RadioMenuItem​(String text)
      构造一个RadioMenuItem并设置指定文本的显示文本。
      RadioMenuItem​(String text, Node graphic)
      构造一个RadioMenuItem，并使用指定的文本设置显示文本，并将图形Node设置为给定节点。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ToggleGroup getToggleGroup​()
      获取属性toggleGroup的值。
      boolean isSelected​()
      获取所选属性的值。
      BooleanProperty selectedProperty​()
      该选择的状态为 Toggle 。
      void setSelected​(boolean value)
      设置所选属性的值。
      void setToggleGroup​(ToggleGroup value)
      设置属性toggleGroup的值。
      ObjectProperty<ToggleGroup> toggleGroupProperty​()
      代表这个RadioMenuItem所属的ToggleGroup 。

      • Methods inherited from class javafx.scene.control.MenuItem

        acceleratorProperty, addEventHandler, buildEventDispatchChain, disableProperty, fire, getAccelerator, getCssMetaData, getGraphic, getId, getOnAction, getOnMenuValidation, getParentMenu, getParentPopup, getProperties, getPseudoClassStates, getStyle, getStyleableNode, getStyleableParent, getStyleClass, getText, getTypeSelector, getUserData, graphicProperty, idProperty, isDisable, isMnemonicParsing, isVisible, mnemonicParsingProperty, onActionProperty, onMenuValidationProperty, parentMenuProperty, parentPopupProperty, removeEventHandler, setAccelerator, setDisable, setGraphic, setId, setMnemonicParsing, setOnAction, setOnMenuValidation, setParentMenu, setParentPopup, setStyle, setText, setUserData, setVisible, styleProperty, textProperty, toString, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.scene.control.Toggle

        getProperties, getUserData, setUserData

    • Property Detail

      • toggleGroup

        public final ObjectProperty<ToggleGroup> toggleGroupProperty
        代表这个RadioMenuItem所属的ToggleGroup 。
        Specified by:
        toggleGroupProperty在接口 Toggle
        另请参见：
        getToggleGroup() ， setToggleGroup(ToggleGroup)

      • selected

        public final BooleanProperty selectedProperty
        Specified by:
        selectedProperty在接口 Toggle
        另请参见：
        isSelected() ， setSelected(boolean)

    • 构造方法详细信息

      • RadioMenuItem

        public RadioMenuItem​()
        构造一个没有显示文本的RadioMenuItem。

      • RadioMenuItem

        public RadioMenuItem​(String text)
        构造一个RadioMenuItem并设置指定文本的显示文本。
        参数
        text - 显示文字

      • RadioMenuItem

        public RadioMenuItem​(String text,
                     Node graphic)
        构造一个RadioMenuItem，并使用指定的文本设置显示文本，并将图形Node设置为给定节点。
        参数
        text - 显示文字
        graphic - 图形节点

    • 方法详细信息

      • setToggleGroup

        public final void setToggleGroup​(ToggleGroup value)
        设置属性toggleGroup的值。
        Specified by:
        setToggleGroup在接口 Toggle
        Property description:
        代表这个RadioMenuItem所属的ToggleGroup 。
        参数
        value - 新的ToggleGroup 。

      • getToggleGroup

        public final ToggleGroup getToggleGroup​()
        获取属性toggleGroup的值。
        Specified by:
        getToggleGroup在接口 Toggle
        Property description:
        代表这个RadioMenuItem所属的ToggleGroup 。
        结果
        该ToggleGroup到这个Toggle所属。

      • toggleGroupProperty

        public final ObjectProperty<ToggleGroup> toggleGroupProperty​()
        代表这个RadioMenuItem所属的ToggleGroup 。
        Specified by:
        toggleGroupProperty在接口 Toggle
        另请参见：
        getToggleGroup() ， setToggleGroup(ToggleGroup)

      • setSelected

        public final void setSelected​(boolean value)
        设置所选属性的值。
        Specified by:
        setSelected在接口 Toggle
        Property description:
        参数
        value - true以使此 Toggle被选中。

      • isSelected

        public final boolean isSelected​()
        获取所选属性的值。
        Specified by:
        isSelected在接口 Toggle
        Property description:
        结果
        true如果这个 Toggle被选中。

      • selectedProperty

        public final BooleanProperty selectedProperty​()
        描述从接口Toggle复制
        该选择状态为 Toggle 。
        Specified by:
        selectedProperty接口 Toggle
        另请参见：
        isSelected() ， setSelected(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ResizeFeaturesBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ResizeFeaturesBase<S>

  • java.lang.Object
    • javafx.scene.control.ResizeFeaturesBase<S>
  • 已知直接子类：
    TableView.ResizeFeatures ， TreeTableView.ResizeFeatures

    public class ResizeFeaturesBase<S>
extends Object
    列使用的不可变包装类可调整由控件（如TableView和TreeTableView）提供的策略大小。
    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ResizeFeaturesBase​(TableColumnBase<S,?> column, Double delta)
      创建此类的实例，其中提供的TableColumnBase和delta值被设置并存储在此不可变实例中。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TableColumnBase<S,?> getColumn​()
      返回发生resize的列，如果由于大小调整操作而创建了此ResizeFeatures实例，则返回null。
      Double getDelta​()
      返回在resize操作中添加或删除的水平空间量。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ResizeFeaturesBase

        public ResizeFeaturesBase​(TableColumnBase<S,?> column,
                          Double delta)
        创建此类的实例，其中提供的TableColumnBase和delta值被设置并存储在此不可变实例中。
        参数
        column - 发生调整大小的列，如果由于大小调整操作而创建此ResizeFeatures实例，则为null。
        delta - 在调整大小操作中添加或删除的水平空间量。

    • 方法详细信息

      • getColumn

        public TableColumnBase<S,?> getColumn​()
        返回发生resize的列，如果由于大小调整操作而创建了此ResizeFeatures实例，则返回null。
        结果
        正在发生调整大小的列

      • getDelta

        public Double getDelta​()
        返回在resize操作中添加或删除的水平空间量。
        结果
        the amount of horizontal space added or removed in the resize operation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScrollBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ScrollBar

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ScrollBar
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ScrollBar
extends Control
    具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。 通常不是单独使用，而是用于构建更复杂的控件，如ScrollPane和ListView。

    ScrollBar将focusTraversable设置为false。

    此示例创建一个垂直ScrollBar：

       import javafx.scene.control.ScrollBar; ScrollBar s1 = new ScrollBar(); s1.setOrientation(Orientation.VERTICAL);
    根据JavaFX UI控件API规范实现ScrollBar
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty blockIncrement
      如果点击栏的轨道，调整滚动条的量。
      DoubleProperty max
      由该 ScrollBar表示的 ScrollBar 。
      DoubleProperty min
      由该 ScrollBar表示的 ScrollBar 。
      ObjectProperty<Orientation> orientation
      ScrollBar的方向可以是 HORIZONTAL或 VERTICAL 。
      DoubleProperty unitIncrement
      当 调用increment或 decrement方法时调整ScrollBar的量。
      DoubleProperty value
      由此 ScrollBar代表的当前值。
      DoubleProperty visibleAmount
      滚动条的范围可见，通常由滚动条的大小表示。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScrollBar​()
      创建一个新的水平ScrollBar（即getOrientation（）== Orientation.HORIZONTAL）。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      void adjustValue​(double position)
      调整 value物业 blockIncrement 。
      DoubleProperty blockIncrementProperty​()
      如果点击栏的轨道，调整滚动条的量。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void decrement​()
      由 unitIncrement减去 ScrollBar的 价值
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      double getBlockIncrement​()
      获取属性blockIncrement的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      double getMax​()
      获取最大值的属性值。
      double getMin​()
      获取属性的值min。
      Orientation getOrientation​()
      获取属性方向的值。
      double getUnitIncrement​()
      获取属性unitIncrement的值。
      double getValue​()
      获取属性值的值。
      double getVisibleAmount​()
      获取属性visibleAmount的值。
      void increment​()
      由 unitIncrement增加 ScrollBar的值
      DoubleProperty maxProperty​()
      由该 ScrollBar表示的 ScrollBar 。
      DoubleProperty minProperty​()
      由该 ScrollBar表示的 ScrollBar 。
      ObjectProperty<Orientation> orientationProperty​()
      ScrollBar的方向可以是 HORIZONTAL或 VERTICAL 。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setBlockIncrement​(double value)
      设置属性blockIncrement的值。
      void setMax​(double value)
      设置属性max的值。
      void setMin​(double value)
      设置属性的值min。
      void setOrientation​(Orientation value)
      设置属性方向的值。
      void setUnitIncrement​(double value)
      设置属性unitIncrement的值。
      void setValue​(double value)
      设置属性值的值。
      void setVisibleAmount​(double value)
      设置属性visibleAmount的值。
      DoubleProperty unitIncrementProperty​()
      调用 increment或 decrement方法时调整ScrollBar的量。
      DoubleProperty valueProperty​()
      由该 ScrollBar表示的当前值。
      DoubleProperty visibleAmountProperty​()
      滚动条的范围可见，通常由滚动条的大小表示。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • min

        public final DoubleProperty minProperty
        由该ScrollBar表示的ScrollBar 。 这应该是小于或等于max的值 。 默认值为0。
        另请参见：
        getMin() ， setMin(double)

      • max

        public final DoubleProperty maxProperty
        由该ScrollBar表示的ScrollBar 。 这应该是大于或等于min的值 。 默认值为100。
        另请参见：
        getMax() ， setMax(double)

      • value

        public final DoubleProperty valueProperty
        由该ScrollBar表示的当前值。 该值应在min和max之间。
        另请参见：
        getValue() ， setValue(double)

      • orientation

        public final ObjectProperty<Orientation> orientationProperty
        ScrollBar的方向可以是 HORIZONTAL或 VERTICAL 。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • unitIncrement

        public final DoubleProperty unitIncrementProperty
        调用 increment或 decrement方法时调整ScrollBar的量。
        另请参见：
        getUnitIncrement() ， setUnitIncrement(double)

      • blockIncrement

        public final DoubleProperty blockIncrementProperty
        如果点击栏的轨道，调整滚动条的量。
        另请参见：
        getBlockIncrement() ， setBlockIncrement(double)

      • visibleAmount

        public final DoubleProperty visibleAmountProperty
        滚动条的范围可见，通常由滚动条的大小表示。
        另请参见：
        getVisibleAmount() ， setVisibleAmount(double)

    • 构造方法详细信息

      • ScrollBar

        public ScrollBar​()
        创建一个新的水平ScrollBar（即getOrientation（）== Orientation.HORIZONTAL）。

    • 方法详细信息

      • setMin

        public final void setMin​(double value)
        设置属性的值min。
        Property description:
        由该ScrollBar表示的ScrollBar 。 这应该是小于或等于max的值 。 默认值为0。

      • getMin

        public final double getMin​()
        获取属性的值min。
        Property description:
        由该ScrollBar表示的ScrollBar 。 这应该是小于或等于max的值 。 默认值为0。

      • minProperty

        public final DoubleProperty minProperty​()
        由该ScrollBar表示的ScrollBar 。 这应该是小于或等于max的值 。 默认值为0。
        另请参见：
        getMin() ， setMin(double)

      • setMax

        public final void setMax​(double value)
        设置属性max的值。
        Property description:
        由该ScrollBar表示的ScrollBar 。 这应该是大于或等于min的值 。 默认值为100。

      • getMax

        public final double getMax​()
        获取最大值的属性值。
        Property description:
        由该ScrollBar表示的ScrollBar 。 这应该是大于或等于min的值 。 默认值为100。

      • maxProperty

        public final DoubleProperty maxProperty​()
        由该ScrollBar表示的ScrollBar 。 这应该是大于或等于min的值 。 默认值为100。
        另请参见：
        getMax() ， setMax(double)

      • setValue

        public final void setValue​(double value)
        设置属性值的值。
        Property description:
        由此ScrollBar代表的当前值。 该值应在min和max之间。

      • getValue

        public final double getValue​()
        获取属性值的值。
        Property description:
        由此ScrollBar表示的当前值。 该值应在min和max之间。

      • valueProperty

        public final DoubleProperty valueProperty​()
        由该ScrollBar表示的当前值。 该值应在min和max之间（含）。
        另请参见：
        getValue() ， setValue(double)

      • setOrientation

        public final void setOrientation​(Orientation value)
        设置属性方向的值。
        Property description:
        ScrollBar的方向可以是 HORIZONTAL或 VERTICAL 。

      • getOrientation

        public final Orientation getOrientation​()
        获取属性方向的值。
        Property description:
        ScrollBar的方向可以是 HORIZONTAL或 VERTICAL 。

      • orientationProperty

        public final ObjectProperty<Orientation> orientationProperty​()
        ScrollBar的方向可以是 HORIZONTAL或 VERTICAL 。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • setUnitIncrement

        public final void setUnitIncrement​(double value)
        设置属性unitIncrement的值。
        Property description:
        调用 increment或 decrement方法时调整ScrollBar的量。

      • getUnitIncrement

        public final double getUnitIncrement​()
        获取属性unitIncrement的值。
        Property description:
        调用 increment或 decrement方法时调整ScrollBar的量。

      • unitIncrementProperty

        public final DoubleProperty unitIncrementProperty​()
        当 调用increment或 decrement方法时调整ScrollBar的量。
        另请参见：
        getUnitIncrement() ， setUnitIncrement(double)

      • setBlockIncrement

        public final void setBlockIncrement​(double value)
        设置属性blockIncrement的值。
        Property description:
        如果点击栏的轨道，调整滚动条的量。

      • getBlockIncrement

        public final double getBlockIncrement​()
        获取属性blockIncrement的值。
        Property description:
        如果点击栏的轨道，调整滚动条的量。

      • blockIncrementProperty

        public final DoubleProperty blockIncrementProperty​()
        如果点击栏的轨道，调整滚动条的量。
        另请参见：
        getBlockIncrement() ， setBlockIncrement(double)

      • setVisibleAmount

        public final void setVisibleAmount​(double value)
        设置属性visibleAmount的值。
        Property description:
        滚动条的范围可见，通常由滚动条的大小表示。

      • getVisibleAmount

        public final double getVisibleAmount​()
        获取属性visibleAmount的值。
        Property description:
        滚动条的范围可见，通常由滚动条的大小表示。

      • visibleAmountProperty

        public final DoubleProperty visibleAmountProperty​()
        滚动条的范围可见，通常由滚动条的大小表示。
        另请参见：
        getVisibleAmount() ， setVisibleAmount(double)

      • adjustValue

        public void adjustValue​(double position)
        调整value物业blockIncrement 。 position是min和max之间的分数。 例如，可能是50％。 如果#minProperty min分别为0和#maxProperty max分别为100和value分别为25，那么.5的位置将表明，我们应该增加value由blockIncrement 。 X- 45454545 X-45 X-45 X-45 X-45 X-45 X- 200 X- 200 200 200 200 200 -40 200 200 200 200 200 -40 200 200 200 200 200 -40 200 200 200 -40 200 200 200 200 -40 200 200 200 X- 注意：此功能主要由专家使用，主要由实施新皮肤或行为的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        position - 位置

      • increment

        public void increment​()
        增加 ScrollBar的价值 unitIncrement

      • decrement

        public void decrement​()
        由 unitIncrement减去 ScrollBar的 价值

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 这就是所谓的创建控制皮肤如果没有皮肤通过CSS提供-fx-skin或在子类明确设置setSkin(...) 。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 要执行的动作
        parameters - 参数的可选列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScrollPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ScrollPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ScrollPane
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("content")
public class ScrollPane
extends Control
    提供其内容的滚动，剪切视口的控件。 它允许用户直接滚动内容（平移）或使用滚动条滚动。 ScrollPane允许指定滚动条策略，该策略决定何时显示滚动条：始终，永不，或仅在需要时。 可以为水平和垂直滚动条独立指定滚动条策略。

    ScrollPane允许应用程序设置在水平和垂直方向上定位内容的当前，最小和最大值。 这些值按比例映射到所包含节点的layoutBounds上。

    ScrollPane布局计算基于layoutBounds而不是滚动节点的boundsInParent（可视边界）。 如果应用程序希望滚动基于节点的可视边界（对于缩放内容等），则需要将滚动节点包裹在组中。

    ScrollPane将focusTraversable设置为false。

    此示例创建一个ScrollPane，其中包含一个Rectangle：

       import javafx.scene.control.ScrollPane; import javafx.scene.shape.Rectangle; Rectangle rect = new Rectangle(200, 200, Color.RED); ScrollPane s1 = new ScrollPane(); s1.setPrefSize(120, 120); s1.setContent(rect);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Node> content
      该节点用作此ScrollPane的内容。
      BooleanProperty fitToHeight
      如果为true，并且如果包含的节点是可调整大小，则节点将被保持调整大小以匹配ScrollPane视口的高度。
      BooleanProperty fitToWidth
      如果为true，并且如果包含的节点是可调整大小，那么该节点将保持调整大小以匹配ScrollPane视口的宽度。
      ObjectProperty<ScrollPane.ScrollBarPolicy> hbarPolicy
      指定显示水平滚动条的策略。
      DoubleProperty hmax
      此ScrollPane的最大允许 数为 hvalue 。
      DoubleProperty hmin
      此ScrollPane的最小允许 值为hvalue 。
      DoubleProperty hvalue
      ScrollPane的当前水平滚动位置。
      DoubleProperty minViewportHeight
      指定ScrollPane视口的最小高度。
      DoubleProperty minViewportWidth
      指定ScrollPane视口的最小宽度。
      BooleanProperty pannable
      指定用户是否应该能够使用鼠标平移视口。
      DoubleProperty prefViewportHeight
      指定ScrollPane视口的首选高度。
      DoubleProperty prefViewportWidth
      指定ScrollPane视口的首选宽度。
      ObjectProperty<ScrollPane.ScrollBarPolicy> vbarPolicy
      指定显示垂直滚动条的策略。
      ObjectProperty<Bounds> viewportBounds
      ScrollPane视口的实际边界。
      DoubleProperty vmax
      此ScrollPane的最大允许 数为 vvalue 。
      DoubleProperty vmin
      该ScrollPane的最小允许 值为vvalue 。
      DoubleProperty vvalue
      ScrollPane的当前垂直滚动位置。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ScrollPane.ScrollBarPolicy
      表示可滚动控件在决定是否显示滚动条时使用的策略的枚举。

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScrollPane​()
      创建一个新的ScrollPane。
      ScrollPane​(Node content)
      创建一个新的ScrollPane。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Node> contentProperty​()
      该节点用作此ScrollPane的内容。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      BooleanProperty fitToHeightProperty​()
      如果为true，并且如果包含的节点是可调整大小，则节点将被保持调整大小以匹配ScrollPane视口的高度。
      BooleanProperty fitToWidthProperty​()
      如果为true，并且如果包含的节点是可调整大小，那么该节点将保持调整大小以匹配ScrollPane视口的宽度。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Node getContent​()
      获取属性内容的值。
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      ScrollPane.ScrollBarPolicy getHbarPolicy​()
      获取属性hbarPolicy的值。
      double getHmax​()
      获取属性hmax的值。
      double getHmin​()
      获取属性hmin的值。
      double getHvalue​()
      获取属性h值的值。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      double getMinViewportHeight​()
      获取属性minViewportHeight的值。
      double getMinViewportWidth​()
      获取属性minViewportWidth的值。
      double getPrefViewportHeight​()
      获取属性prefViewportHeight的值。
      double getPrefViewportWidth​()
      获取属性prefViewportWidth的值。
      ScrollPane.ScrollBarPolicy getVbarPolicy​()
      获取属性vbarPolicy的值。
      Bounds getViewportBounds​()
      获取属性viewportBounds的值。
      double getVmax​()
      获取属性vmax的值。
      double getVmin​()
      获取属性vmin的值。
      double getVvalue​()
      获取属性vvalue的值。
      ObjectProperty<ScrollPane.ScrollBarPolicy> hbarPolicyProperty​()
      指定显示水平滚动条的策略。
      DoubleProperty hmaxProperty​()
      此ScrollPane的最大允许 数为 hvalue 。
      DoubleProperty hminProperty​()
      该ScrollPane的最小允许 值为hvalue 。
      DoubleProperty hvalueProperty​()
      ScrollPane的当前水平滚动位置。
      boolean isFitToHeight​()
      获取属性fitToHeight的值。
      boolean isFitToWidth​()
      获取属性fitToWidth的值。
      boolean isPannable​()
      获取pannable属性的值。
      DoubleProperty minViewportHeightProperty​()
      指定ScrollPane视口的最小高度。
      DoubleProperty minViewportWidthProperty​()
      指定ScrollPane视口的最小宽度。
      BooleanProperty pannableProperty​()
      指定用户是否应该能够使用鼠标平移视口。
      DoubleProperty prefViewportHeightProperty​()
      指定ScrollPane视口的首选高度。
      DoubleProperty prefViewportWidthProperty​()
      指定ScrollPane视口的首选宽度。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setContent​(Node value)
      设置属性内容的值。
      void setFitToHeight​(boolean value)
      设置属性fitToHeight的值。
      void setFitToWidth​(boolean value)
      设置属性fitToWidth的值。
      void setHbarPolicy​(ScrollPane.ScrollBarPolicy value)
      设置属性hbarPolicy的值。
      void setHmax​(double value)
      设置属性hmax的值。
      void setHmin​(double value)
      设置属性hmin的值。
      void setHvalue​(double value)
      设置属性hvalue的值。
      void setMinViewportHeight​(double value)
      设置属性minViewportHeight的值。
      void setMinViewportWidth​(double value)
      设置属性minViewportWidth的值。
      void setPannable​(boolean value)
      设置pannable属性的值。
      void setPrefViewportHeight​(double value)
      设置属性prefViewportHeight的值。
      void setPrefViewportWidth​(double value)
      设置属性prefViewportWidth的值。
      void setVbarPolicy​(ScrollPane.ScrollBarPolicy value)
      设置属性vbarPolicy的值。
      void setViewportBounds​(Bounds value)
      设置属性viewportBounds的值。
      void setVmax​(double value)
      设置属性vmax的值。
      void setVmin​(double value)
      设置属性vmin的值。
      void setVvalue​(double value)
      设置属性vvalue的值。
      ObjectProperty<ScrollPane.ScrollBarPolicy> vbarPolicyProperty​()
      指定显示垂直滚动条的策略。
      ObjectProperty<Bounds> viewportBoundsProperty​()
      ScrollPane视口的实际边界。
      DoubleProperty vmaxProperty​()
      此ScrollPane的最大允许 数量为 vvalue 。
      DoubleProperty vminProperty​()
      该ScrollPane的最小允许 值为vvalue 。
      DoubleProperty vvalueProperty​()
      ScrollPane的当前垂直滚动位置。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • hbarPolicy

        public final ObjectProperty<ScrollPane.ScrollBarPolicy> hbarPolicyProperty
        指定显示水平滚动条的策略。
        另请参见：
        getHbarPolicy() ， setHbarPolicy(ScrollPane.ScrollBarPolicy)

      • vbarPolicy

        public final ObjectProperty<ScrollPane.ScrollBarPolicy> vbarPolicyProperty
        指定显示垂直滚动条的策略。
        另请参见：
        getVbarPolicy() ， setVbarPolicy(ScrollPane.ScrollBarPolicy)

      • content

        public final ObjectProperty<Node> contentProperty
        该节点用作此ScrollPane的内容。
        另请参见：
        getContent() ， setContent(Node)

      • hvalue

        public final DoubleProperty hvalueProperty
        ScrollPane的当前水平滚动位置。 该值可以由应用程序设置，以编程方式滚动视图。 每当视口被用户滚动或平移时，ScrollPane将会更新此值。 该值必须始终在hmin至hmax的范围内。 当hvalue等于hmin时 ，包含的节点被定位成使得其layoutBounds minX可见。 当hvalue等于hmax时 ，包含的节点被定位成使得其layoutBounds maxX可见。 当hvalue在hmin和hmax之间时，所包含的节点按照layoutBounds minX和layoutBounds maxX之间成比例地放置 。
        另请参见：
        getHvalue() ， setHvalue(double)

      • vvalue

        public final DoubleProperty vvalueProperty
        ScrollPane的当前垂直滚动位置。 该值可以由应用程序设置，以编程方式滚动视图。 每当视口被用户滚动或平移时，ScrollPane将会更新此值。 该值必须始终在vmin至vmax的范围内。 当vvalue等于vmin时 ，所包含的节点被定位成使得其layoutBounds minY可见。 当vvalue等于vmax时 ，所包含的节点被定位成使得其layoutBounds maxY可见。 当vvalue在vmin和vmax之间时，所包含的节点按照layoutBounds minY和layoutBounds maxY成比例地定位。
        另请参见：
        getVvalue() ， setVvalue(double)

      • hmin

        public final DoubleProperty hminProperty
        此ScrollPane的最小允许数为hvalue 。 默认值为0。
        另请参见：
        getHmin() ， setHmin(double)

      • vmin

        public final DoubleProperty vminProperty
        此ScrollPane的最小允许数为vvalue 。 默认值为0。
        另请参见：
        getVmin() ， setVmin(double)

      • hmax

        public final DoubleProperty hmaxProperty
        此ScrollPane的最大允许数量为hvalue 。 默认值为1。
        另请参见：
        getHmax() ， setHmax(double)

      • vmax

        public final DoubleProperty vmaxProperty
        此ScrollPane的最大允许数为vvalue 。 默认值为1。
        另请参见：
        getVmax() ， setVmax(double)

      • fitToWidth

        public final BooleanProperty fitToWidthProperty
        如果为true，并且如果包含的节点是可调整大小，那么该节点将保持调整大小以匹配ScrollPane视口的宽度。 如果包含的节点不是可调整大小，则忽略此值。
        另请参见：
        isFitToWidth() ， setFitToWidth(boolean)

      • fitToHeight

        public final BooleanProperty fitToHeightProperty
        如果为true，并且如果包含的节点是可调整大小，则节点将被保持调整大小以匹配ScrollPane视口的高度。 如果包含的节点不是可调整大小，则忽略此值。
        另请参见：
        isFitToHeight() ， setFitToHeight(boolean)

      • pannable

        public final BooleanProperty pannableProperty
        指定用户是否应该能够使用鼠标平移视口。 如果鼠标事件到达ScrollPane（也就是说，如果鼠标事件没有被包含的节点或其一个孩子阻止），则查询pannable以确定是否应该将事件用于平移。
        另请参见：
        isPannable() ， setPannable(boolean)

      • prefViewportWidth

        public final DoubleProperty prefViewportWidthProperty
        指定ScrollPane视口的首选宽度。 这是内容节点可用的宽度。 ScrollPane的整体宽度是ViewportWidth + padding
        另请参见：
        getPrefViewportWidth() ， setPrefViewportWidth(double)

      • prefViewportHeight

        public final DoubleProperty prefViewportHeightProperty
        指定ScrollPane视口的首选高度。 这是内容节点可用的高度。 ScrollPane的整体高度是ViewportHeight + padding
        另请参见：
        getPrefViewportHeight() ， setPrefViewportHeight(double)

      • minViewportWidth

        public final DoubleProperty minViewportWidthProperty
        指定ScrollPane视口的最小宽度。 这是内容节点可用的宽度。
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getMinViewportWidth() ， setMinViewportWidth(double)

      • minViewportHeight

        public final DoubleProperty minViewportHeightProperty
        指定ScrollPane视口的最小高度。 这是内容节点可用的高度。
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getMinViewportHeight() ， setMinViewportHeight(double)

      • viewportBounds

        public final ObjectProperty<Bounds> viewportBoundsProperty
        ScrollPane视口的实际边界。 这是内容节点的边界。
        另请参见：
        getViewportBounds() ， setViewportBounds(Bounds)

    • 构造方法详细信息

      • ScrollPane

        public ScrollPane​()
        创建一个新的ScrollPane。

      • ScrollPane

        public ScrollPane​(Node content)
        创建一个新的ScrollPane。
        参数
        content - ScrollPane的初始内容
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setHbarPolicy

        public final void setHbarPolicy​(ScrollPane.ScrollBarPolicy value)
        设置属性hbarPolicy的值。
        Property description:
        指定显示水平滚动条的策略。

      • getHbarPolicy

        public final ScrollPane.ScrollBarPolicy getHbarPolicy​()
        获取属性hbarPolicy的值。
        Property description:
        指定显示水平滚动条的策略。

      • hbarPolicyProperty

        public final ObjectProperty<ScrollPane.ScrollBarPolicy> hbarPolicyProperty​()
        指定显示水平滚动条的策略。
        另请参见：
        getHbarPolicy() ， setHbarPolicy(ScrollPane.ScrollBarPolicy)

      • setVbarPolicy

        public final void setVbarPolicy​(ScrollPane.ScrollBarPolicy value)
        设置属性vbarPolicy的值。
        Property description:
        指定显示垂直滚动条的策略。

      • getVbarPolicy

        public final ScrollPane.ScrollBarPolicy getVbarPolicy​()
        获取属性vbarPolicy的值。
        Property description:
        指定显示垂直滚动条的策略。

      • vbarPolicyProperty

        public final ObjectProperty<ScrollPane.ScrollBarPolicy> vbarPolicyProperty​()
        指定显示垂直滚动条的策略。
        另请参见：
        getVbarPolicy() ， setVbarPolicy(ScrollPane.ScrollBarPolicy)

      • setContent

        public final void setContent​(Node value)
        设置属性内容的值。
        Property description:
        该节点用作此ScrollPane的内容。

      • getContent

        public final Node getContent​()
        获取属性内容的值。
        Property description:
        该节点用作此ScrollPane的内容。

      • contentProperty

        public final ObjectProperty<Node> contentProperty​()
        该节点用作此ScrollPane的内容。
        另请参见：
        getContent() ， setContent(Node)

      • setHvalue

        public final void setHvalue​(double value)
        设置属性hvalue的值。
        Property description:
        ScrollPane的当前水平滚动位置。 该值可以由应用程序设置，以编程方式滚动视图。 每当视口被用户滚动或平移时，ScrollPane将会更新此值。 该值必须始终在hmin至hmax的范围内。 当hvalue等于hmin时 ，包含的节点被定位成使得其layoutBounds minX可见。 当hvalue等于hmax时 ，所包含的节点被定位成使其layoutBounds maxX可见。 当hvalue在hmin和hmax之间时，所包含的节点按照layoutBounds minX和layoutBounds maxX按比例放置 。

      • getHvalue

        public final double getHvalue​()
        获取属性h值的值。
        Property description:
        ScrollPane的当前水平滚动位置。 该值可以由应用程序设置，以编程方式滚动视图。 每当视口被用户滚动或平移时，ScrollPane将会更新此值。 该值必须始终在hmin至hmax的范围内。 当hvalue等于hmin时 ，包含的节点被定位成使得其layoutBounds minX可见。 当hvalue等于hmax时 ，包含的节点被定位成使得其layoutBounds maxX可见。 当hvalue在hmin和hmax之间时，所包含的节点按照layoutBounds minX和layoutBounds maxX按比例放置 。

      • hvalueProperty

        public final DoubleProperty hvalueProperty​()
        ScrollPane的当前水平滚动位置。 该值可以由应用程序设置，以编程方式滚动视图。 每当视口被用户滚动或平移时，ScrollPane将会更新此值。 此值必须始终在hmin至hmax的范围内。 当hvalue等于hmin时 ，包含的节点被定位成使得其layoutBounds minX可见。 当hvalue等于hmax时 ，所包含的节点被定位成使得其layoutBounds maxX是可见的。 当hvalue在hmin和hmax之间时，所包含的节点按照layoutBounds minX和layoutBounds maxX按比例放置 。
        另请参见：
        getHvalue() ， setHvalue(double)

      • setVvalue

        public final void setVvalue​(double value)
        设置属性vvalue的值。
        Property description:
        ScrollPane的当前垂直滚动位置。 该值可以由应用程序设置，以编程方式滚动视图。 每当视口被用户滚动或平移时，ScrollPane将会更新此值。 该值必须始终在vmin至vmax的范围内。 当vvalue等于vmin时 ，包含的节点被定位成使得其layoutBounds minY可见。 当vvalue等于vmax时 ，所包含的节点被定位成使得它的layoutBounds maxY可见。 当vvalue在vmin和vmax之间时，所包含的节点按照layoutBounds minY和layoutBounds maxY按比例放置 。

      • getVvalue

        public final double getVvalue​()
        获取属性vvalue的值。
        Property description:
        ScrollPane的当前垂直滚动位置。 该值可以由应用程序设置，以编程方式滚动视图。 每当视口被用户滚动或平移时，ScrollPane将会更新此值。 该值必须始终在vmin至vmax的范围内。 当vvalue等于vmin时 ，所包含的节点被定位成使得它的layoutBounds minY可见。 当vvalue等于vmax时 ，包含的节点被定位成使得其layoutBounds maxY可见。 当27069494505842和vmax之间的vmin和vmax之间时，所包含的节点按比例位于layoutBounds minY和layoutBounds maxY之间 。

      • vvalueProperty

        public final DoubleProperty vvalueProperty​()
        ScrollPane的当前垂直滚动位置。 该值可以由应用程序设置，以编程方式滚动视图。 每当视口被用户滚动或平移时，ScrollPane将会更新此值。 此值必须始终在vmin至vmax的范围内。 当vvalue等于vmin时 ，所包含的节点被定位成使得其layoutBounds minY可见。 当vvalue等于vmax时 ，包含的节点被定位成使其layoutBounds maxY可见。 当vvalue在vmin和vmax之间时，所包含的节点按照layoutBounds minY和layoutBounds maxY按比例放置 。
        另请参见：
        getVvalue() ， setVvalue(double)

      • setHmin

        public final void setHmin​(double value)
        设置属性hmin的值。
        Property description:
        该ScrollPane的最小允许值为hvalue 。 默认值为0。

      • getHmin

        public final double getHmin​()
        获取属性hmin的值。
        Property description:
        该ScrollPane的最小允许值为hvalue 。 默认值为0。

      • hminProperty

        public final DoubleProperty hminProperty​()
        该ScrollPane的最小允许值为hvalue 。 默认值为0。
        另请参见：
        getHmin() ， setHmin(double)

      • setVmin

        public final void setVmin​(double value)
        设置属性vmin的值。
        Property description:
        该ScrollPane的最小允许值为vvalue 。 默认值为0。

      • getVmin

        public final double getVmin​()
        获取属性vmin的值。
        Property description:
        此ScrollPane的最小允许值为vvalue 。 默认值为0。

      • vminProperty

        public final DoubleProperty vminProperty​()
        该ScrollPane的最小允许值为vvalue 。 默认值为0。
        另请参见：
        getVmin() ， setVmin(double)

      • setHmax

        public final void setHmax​(double value)
        设置属性hmax的值。
        Property description:
        此ScrollPane的最大允许数为hvalue 。 默认值为1。

      • getHmax

        public final double getHmax​()
        获取属性hmax的值。
        Property description:
        此ScrollPane的最大允许数为hvalue 。 默认值为1。

      • hmaxProperty

        public final DoubleProperty hmaxProperty​()
        此ScrollPane的最大允许数为hvalue 。 默认值为1。
        另请参见：
        getHmax() ， setHmax(double)

      • setVmax

        public final void setVmax​(double value)
        设置属性vmax的值。
        Property description:
        此ScrollPane的最大允许数为vvalue 。 默认值为1。

      • getVmax

        public final double getVmax​()
        获取属性vmax的值。
        Property description:
        此ScrollPane的最大允许数为vvalue 。 默认值为1。

      • vmaxProperty

        public final DoubleProperty vmaxProperty​()
        此ScrollPane的最大允许数量为vvalue 。 默认值为1。
        另请参见：
        getVmax() ， setVmax(double)

      • setFitToWidth

        public final void setFitToWidth​(boolean value)
        设置属性fitToWidth的值。
        Property description:
        如果为true，并且如果包含的节点是可调整大小，那么该节点将保持调整大小以匹配ScrollPane视口的宽度。 如果包含的节点不是可调整大小，则忽略此值。

      • isFitToWidth

        public final boolean isFitToWidth​()
        获取属性fitToWidth的值。
        Property description:
        如果为true，并且如果包含的节点是可调整大小，那么该节点将保持调整大小以匹配ScrollPane视口的宽度。 如果包含的节点不是可调整大小，则忽略此值。

      • fitToWidthProperty

        public final BooleanProperty fitToWidthProperty​()
        如果为true，并且如果包含的节点是可调整大小，那么该节点将保持调整大小以匹配ScrollPane视口的宽度。 如果包含的节点不是可调整大小，则忽略此值。
        另请参见：
        isFitToWidth() ， setFitToWidth(boolean)

      • setFitToHeight

        public final void setFitToHeight​(boolean value)
        设置属性fitToHeight的值。
        Property description:
        如果为true，并且如果包含的节点是可调整大小，则节点将被保持调整大小以匹配ScrollPane视口的高度。 如果包含的节点不是可调整大小，则忽略此值。

      • isFitToHeight

        public final boolean isFitToHeight​()
        获取属性fitToHeight的值。
        Property description:
        如果为true，并且如果包含的节点是可调整大小，则节点将被保持调整大小以匹配ScrollPane视口的高度。 如果包含的节点不是可调整大小，则忽略此值。

      • fitToHeightProperty

        public final BooleanProperty fitToHeightProperty​()
        如果为true，并且如果包含的节点是可调整大小，则节点将被保持调整大小以匹配ScrollPane视口的高度。 如果包含的节点不是可调整大小，则忽略此值。
        另请参见：
        isFitToHeight() ， setFitToHeight(boolean)

      • setPannable

        public final void setPannable​(boolean value)
        设置pannable属性的值。
        Property description:
        指定用户是否应该能够使用鼠标平移视口。 如果鼠标事件到达ScrollPane（也就是说，如果鼠标事件不被包含的节点或其中一个孩子阻止），则请参阅pannable以确定是否应将事件用于平移。

      • isPannable

        public final boolean isPannable​()
        获取pannable属性的值。
        Property description:
        指定用户是否应该能够使用鼠标平移视口。 如果鼠标事件到达ScrollPane（也就是说，如果鼠标事件没有被包含的节点或其一个孩子阻止），那么请参阅pannable以确定事件是否应该用于平移。

      • pannableProperty

        public final BooleanProperty pannableProperty​()
        指定用户是否应该能够使用鼠标平移视口。 如果鼠标事件到达ScrollPane（即，如果鼠标事件未被包含的节点或其子节点阻止），则请参阅pannable以确定事件是否应用于平移。
        另请参见：
        isPannable() ， setPannable(boolean)

      • setPrefViewportWidth

        public final void setPrefViewportWidth​(double value)
        设置属性prefViewportWidth的值。
        Property description:
        指定ScrollPane视口的首选宽度。 这是内容节点可用的宽度。 ScrollPane的整体宽度是ViewportWidth + padding

      • getPrefViewportWidth

        public final double getPrefViewportWidth​()
        获取属性prefViewportWidth的值。
        Property description:
        指定ScrollPane视口的首选宽度。 这是内容节点可用的宽度。 ScrollPane的整体宽度是ViewportWidth + padding

      • prefViewportWidthProperty

        public final DoubleProperty prefViewportWidthProperty​()
        指定ScrollPane视口的首选宽度。 这是内容节点可用的宽度。 ScrollPane的整体宽度是ViewportWidth + padding
        另请参见：
        getPrefViewportWidth() ， setPrefViewportWidth(double)

      • setPrefViewportHeight

        public final void setPrefViewportHeight​(double value)
        设置属性prefViewportHeight的值。
        Property description:
        指定ScrollPane视口的首选高度。 这是内容节点可用的高度。 ScrollPane的整体高度是ViewportHeight + padding

      • getPrefViewportHeight

        public final double getPrefViewportHeight​()
        获取属性prefViewportHeight的值。
        Property description:
        指定ScrollPane视口的首选高度。 这是内容节点可用的高度。 ScrollPane的整体高度是ViewportHeight + padding

      • prefViewportHeightProperty

        public final DoubleProperty prefViewportHeightProperty​()
        指定ScrollPane视口的首选高度。 这是内容节点可用的高度。 ScrollPane的整体高度是ViewportHeight + padding
        另请参见：
        getPrefViewportHeight() ， setPrefViewportHeight(double)

      • setMinViewportWidth

        public final void setMinViewportWidth​(double value)
        设置属性minViewportWidth的值。
        Property description:
        指定ScrollPane视口的最小宽度。 这是内容节点可用的宽度。
        从以下版本开始：
        JavaFX 8u40

      • getMinViewportWidth

        public final double getMinViewportWidth​()
        获取属性minViewportWidth的值。
        Property description:
        指定ScrollPane视口的最小宽度。 这是内容节点可用的宽度。
        从以下版本开始：
        JavaFX 8u40

      • minViewportWidthProperty

        public final DoubleProperty minViewportWidthProperty​()
        指定ScrollPane视口的最小宽度。 这是内容节点可用的宽度。
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getMinViewportWidth() ， setMinViewportWidth(double)

      • setMinViewportHeight

        public final void setMinViewportHeight​(double value)
        设置属性minViewportHeight的值。
        Property description:
        指定ScrollPane视口的最小高度。 这是内容节点可用的高度。
        从以下版本开始：
        JavaFX 8u40

      • getMinViewportHeight

        public final double getMinViewportHeight​()
        获取属性minViewportHeight的值。
        Property description:
        指定ScrollPane视口的最小高度。 这是内容节点可用的高度。
        从以下版本开始：
        JavaFX 8u40

      • minViewportHeightProperty

        public final DoubleProperty minViewportHeightProperty​()
        指定ScrollPane视口的最小高度。 这是内容节点可用的高度。
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getMinViewportHeight() ， setMinViewportHeight(double)

      • setViewportBounds

        public final void setViewportBounds​(Bounds value)
        设置属性viewportBounds的值。
        Property description:
        ScrollPane视口的实际边界。 这是内容节点的边界。

      • getViewportBounds

        public final Bounds getViewportBounds​()
        获取属性viewportBounds的值。
        Property description:
        ScrollPane视口的实际边界。 这是内容节点的边界。

      • viewportBoundsProperty

        public final ObjectProperty<Bounds> viewportBoundsProperty​()
        ScrollPane视口的实际边界。 这是内容节点的边界。
        另请参见：
        getViewportBounds() ， setViewportBounds(Bounds)

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 参数的可选列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScrollPane.ScrollBarPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum ScrollPane.ScrollBarPolicy

  • java.lang.Object
    • java.lang.Enum<ScrollPane.ScrollBarPolicy>
      • javafx.scene.control.ScrollPane.ScrollBarPolicy
  • All Implemented Interfaces:
    Serializable ， Comparable<ScrollPane.ScrollBarPolicy>
    Enclosing class:
    ScrollPane

    public static enum ScrollPane.ScrollBarPolicy
extends Enum<ScrollPane.ScrollBarPolicy>
    表示可滚动控件在决定是否显示滚动条时使用的策略的枚举。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALWAYS
      表示应始终显示滚动条。
      AS_NEEDED
      表示需要时显示滚动条。
      NEVER
      表示不应显示滚动条。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ScrollPane.ScrollBarPolicy valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ScrollPane.ScrollBarPolicy[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NEVER

        public static final ScrollPane.ScrollBarPolicy NEVER
        表示不应显示滚动条。

      • ALWAYS

        public static final ScrollPane.ScrollBarPolicy ALWAYS
        表示应始终显示滚动条。

      • AS_NEEDED

        public static final ScrollPane.ScrollBarPolicy AS_NEEDED
        表示需要时显示滚动条。

    • 方法详细信息

      • values

        public static ScrollPane.ScrollBarPolicy[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ScrollPane.ScrollBarPolicy c : ScrollPane.ScrollBarPolicy.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ScrollPane.ScrollBarPolicy valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ScrollToEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ScrollToEvent<T>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.ScrollToEvent<T>
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class ScrollToEvent<T>
extends Event
    事件相关ScrollPane所虚拟化控制，比如ListView ， TableView ， TreeView和TreeTableView 。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<ScrollToEvent> ANY
      所有滚动到事件类型的常用超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScrollToEvent​(Object source, EventTarget target, EventType<ScrollToEvent<T>> type, T scrollTarget)
      使用指定的事件源，目标和类型构造新的 Event 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T getScrollTarget​()
      static <T extends TableColumnBase<?,?>>
      EventType<ScrollToEvent<T>>             		scrollToColumn​()
      如果用户请求滚动一个TableColumnBase （即
      static EventType<ScrollToEvent<Integer>> scrollToTopIndex​()
      如果用户请求将给定索引滚动到视图中，则会发生此事件。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<ScrollToEvent> ANY
        所有滚动到事件类型的常用超类型。

    • 构造方法详细信息

      • ScrollToEvent

        public ScrollToEvent​(Object source,
                     EventTarget target,
                     EventType<ScrollToEvent<T>> type,
                     T scrollTarget)
        构造一个新的Event与指定的事件源，目标和类型。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        参数
        source - 发送事件的事件源
        target - 发送事件的事件源
        type - 事件类型
        scrollTarget - 滚动到操作的目标

    • 方法详细信息

      • scrollToTopIndex

        public static EventType<ScrollToEvent<Integer>> scrollToTopIndex​()
        如果用户请求将给定索引滚动到视图中，则会发生此事件。
        结果
        滚动到事件类型

      • scrollToColumn

        public static <T extends TableColumnBase<?,?>> EventType<ScrollToEvent<T>> scrollToColumn​()
        如果用户请求滚动查看TableColumnBase （即TableColumn或TreeTableColumn ），则会发生此事件。
        参数类型
        T - 类型
        结果
        the scroll to event type

      • getScrollTarget

        public T getScrollTarget​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


SelectionMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum SelectionMode

  • java.lang.Object
    • java.lang.Enum<SelectionMode>
      • javafx.scene.control.SelectionMode
  • All Implemented Interfaces:
    Serializable ， Comparable<SelectionMode>

    public enum SelectionMode
extends Enum<SelectionMode>
    用于指定可以在MultipleSelectionModel中选择多少项的枚举 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    SelectionModel ， MultipleSelectionModel

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      MULTIPLE
      允许一次选择一个或多个连续的索引范围。
      SINGLE
      一次只能选择一个项目。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static SelectionMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SelectionMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SINGLE

        public static final SelectionMode SINGLE
        一次只能选择一个项目。

      • MULTIPLE

        public static final SelectionMode MULTIPLE
        允许一次选择一个或多个连续的索引范围。

    • 方法详细信息

      • values

        public static SelectionMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (SelectionMode c : SelectionMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static SelectionMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


SelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SelectionModel<T>

  • java.lang.Object
    • javafx.scene.control.SelectionModel<T>
  • 参数类型
    T - 可以选择的控件中包含的项目的类型。
    已知直接子类：
    MultipleSelectionModel ， SingleSelectionModel

    public abstract class SelectionModel<T>
extends Object
    SelectionModel是UI控件用来提供一致的API来维护选择的抽象类。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyIntegerProperty selectedIndex
      指所选索引属性，用于指示选择模型中当前选定的索引值。
      ReadOnlyObjectProperty<T> selectedItem
      指所选项目属性，用于指示选择模型中当前选定的项目。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SelectionModel​()
      创建一个默认的SelectionModel实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void clearAndSelect​(int index)
      在将选择设置为给定索引之前清除任何选择的方法。
      abstract void clearSelection​()
      清除所有选定索引的选择模型。
      abstract void clearSelection​(int index)
      该方法将清除给定索引中项目的选择。
      int getSelectedIndex​()
      返回此模型中指示当前所选索引的整数值。
      T getSelectedItem​()
      返回当前选定的对象（位于所选索引位置）。
      abstract boolean isEmpty​()
      该方法可用于测试是否有任何选定的索引/项目。
      abstract boolean isSelected​(int index)
      通知此SelectionModel中当前选定给定索引的方便方法。
      abstract void select​(int index)
      这将在选择模型中选择给定的索引，假设索引在有效范围内（即大于或等于零，并且小于底层数据模型中的项目总数）。
      abstract void select​(T obj)
      此方法将尝试选择包含给定对象的索引。
      ReadOnlyIntegerProperty selectedIndexProperty​()
      指所选索引属性，用于指示选择模型中当前选定的索引值。
      ReadOnlyObjectProperty<T> selectedItemProperty​()
      指所选项目属性，用于指示选择模型中当前选定的项目。
      abstract void selectFirst​()
      该方法将尝试选择控件中的第一个索引。
      abstract void selectLast​()
      此方法将尝试选择控件中的最后一个索引。
      abstract void selectNext​()
      此方法将尝试在当前焦点索引之后直接选择索引。
      abstract void selectPrevious​()
      此方法将尝试直接在当前聚焦索引之前选择索引。
      protected void setSelectedIndex​(int value)
      设置属性selectedIndex的值。
      protected void setSelectedItem​(T value)
      设置属性selectedItem的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • selectedIndex

        public final ReadOnlyIntegerProperty selectedIndexProperty

        指所选索引属性，用于指示选择模型中当前选定的索引值。 选择的索引为-1，表示没有选择，或者在基础数据模型大小的范围内的整数值。

        当选择模型仅允许单次选择时，所选索引属性最常用，但在多选模式下同样适用。 在这种模式下，所选择的索引将始终代表最后一个选择。

        请注意，在多项选择的情况下，可以添加一个ListChangeListener被返回的集合MultipleSelectionModel.getSelectedIndices()只要选择的变化，而这也将在单一的选择的情况下工作，被告知。

        另请参见：
        getSelectedIndex() ， setSelectedIndex(int)

      • selectedItem

        public final ReadOnlyObjectProperty<T> selectedItemProperty

        指所选项目属性，用于指示选择模型中当前选定的项目。 所选项目为空，表示没有选择项，或从选择模型关联的控件的底层数据模型中检索到的对象。

        当选择模型设置为单次选择时，所选项目属性最常用，但在多选模式下同等适用。 在此模式下，所选项目将始终代表最后选择。

        另请参见：
        getSelectedItem() ， setSelectedItem(T)

    • 构造方法详细信息

      • SelectionModel

        public SelectionModel​()
        创建一个默认的SelectionModel实例。

    • 方法详细信息

      • selectedIndexProperty

        public final ReadOnlyIntegerProperty selectedIndexProperty​()

        指所选索引属性，用于指示选择模型中当前选定的索引值。 选择的索引为-1，表示没有选择，或者在基础数据模型大小的范围内的整数值。

        当选择模型仅允许单次选择时，所选索引属性最常用，但在多选模式下同样适用。 在这种模式下，所选择的索引将始终代表最后一个选择。

        请注意，在多项选择的情况下，可以添加一个ListChangeListener被返回的集合MultipleSelectionModel.getSelectedIndices()只要选择的变化，而这也将在单一的选择的情况下工作，被告知。

        另请参见：
        getSelectedIndex() ， setSelectedIndex(int)

      • setSelectedIndex

        protected final void setSelectedIndex​(int value)
        设置属性selectedIndex的值。
        Property description:

        指所选索引属性，用于指示选择模型中当前选定的索引值。 选择的索引为-1，表示没有选择，或者在基础数据模型大小的范围内的整数值。

        当选择模型仅允许单次选择时，所选索引属性最常用，但在多选模式下同样适用。 在这种模式下，所选择的索引将始终代表最后一个选择。

        请注意，在多项选择的情况下，可以添加一个ListChangeListener被返回的集合MultipleSelectionModel.getSelectedIndices()只要选择的变化，而这也将在单一的选择的情况下工作，被告知。

      • getSelectedIndex

        public final int getSelectedIndex​()

        返回此模型中指示当前所选索引的整数值。 如果选择了多个项目，这将返回最近的选择。

        请注意，返回值是时间上的快照 - 如果希望观察所选索引更改的选择模型，则可以添加ChangeListener：

           SelectionModel sm = ...; InvalidationListener listener = ...; sm.selectedIndexProperty().addListener(listener);
        结果
        所选索引

      • selectedItemProperty

        public final ReadOnlyObjectProperty<T> selectedItemProperty​()

        指所选项目属性，用于指示选择模型中当前选定的项目。 所选项目为空，表示没有选择项，或从选择模型关联的控件的底层数据模型中检索到的对象。

        当选择模型设置为单次选择时，所选项目属性最常用，但在多选模式下同等适用。 在此模式下，所选项目将始终代表最后选择。

        另请参见：
        getSelectedItem() ， setSelectedItem(T)

      • setSelectedItem

        protected final void setSelectedItem​(T value)
        设置属性selectedItem的值。
        Property description:

        指所选项目属性，用于指示选择模型中当前选定的项目。 所选项目为空，表示没有选择项，或从选择模型关联的控件的底层数据模型中检索到的对象。

        当选择模型设置为单次选择时，所选项目属性最常用，但在多选模式下同等适用。 在此模式下，所选项目将始终代表最后选择。

      • getSelectedItem

        public final T getSelectedItem​()
        返回当前选定的对象（位于所选索引位置）。 如果选择了多个项目，这将返回由getSelectedIndex（）返回的索引所包含的对象（它始终是最近选定项目的索引）。

        请注意，返回的值是快照的快照 - 如果您希望观察所选项目的更改的选择模型，则可以添加ChangeListener：

           SelectionModel sm = ...; InvalidationListener listener = ...; sm.selectedItemProperty().addListener(listener);
        结果
        所选项目

      • clearAndSelect

        public abstract void clearAndSelect​(int index)
        在将选择设置为给定索引之前清除任何选择的方法。 该方法的目的是避免首先调用clearSelection() ，这意味着正在监听selected index属性的观察者将不会将所选索引临时设置为-1。
        参数
        index - 应该是此选择模型中唯一选择的索引的索引。

      • select

        public abstract void select​(int index)

        这将在选择模型中选择给定的索引，假设索引在有效范围内（即大于或等于零，并且小于底层数据模型中的项目总数）。

        如果在此模型中已经选择了一个或多个索引，调用此方法将不会清除这些选择 - 为此，有必要首先调用clearSelection() 。

        如果索引已被选中，则不会再次选择或未选择。 然而，如果实现了多个选择，则对已经选择的索引进行调用select将会使索引成为新的所选索引（由getSelectedIndex()返回）。

        参数
        index - 要在选择模型中选择的项目的位置。

      • select

        public abstract void select​(T obj)

        此方法将尝试选择包含给定对象的索引。 它将遍历底层数据模型，直到找到一个值等于给定对象的项。 在这一点上它将停止迭代 - 这意味着该方法将不会选择多个索引。

        参数
        obj - 要在底层数据模型中选择的对象。

      • clearSelection

        public abstract void clearSelection​(int index)

        该方法将清除给定索引中项目的选择。 如果没有选择给定的索引，则不会发生任何事情。

        参数
        index - 要取消选择的选定项目。

      • clearSelection

        public abstract void clearSelection​()

        清除所有选定索引的选择模型。

      • isSelected

        public abstract boolean isSelected​(int index)

        通知此SelectionModel中当前选定给定索引的方便方法。 功能上相当于调用getSelectedIndices().contains(index) 。

        参数
        index - 检查当前是否选择的索引。
        结果
        如果给定的索引被选择，则为真，否则为false。

      • isEmpty

        public abstract boolean isEmpty​()
        该方法可用于测试是否有任何选定的索引/项目。 如果没有选定的项目，它将返回true，如果有，则返回false。
        结果
        如果 没有选择的项目将返回true，如果有的话将返回false。

      • selectPrevious

        public abstract void selectPrevious​()

        此方法将尝试直接在当前聚焦索引之前选择索引。 如果没有首先调用clearSelection，则该方法将具有选择先前索引的结果，同时保留对其他当前选择的索引的选择。

        调用此方法将仅在以下情况下成功：

        • 目前有一个主角/重点指数。
        • 主要/焦点指数不是控制中的第一个指标。
        • 以前的索引尚未被选中。

        如果这些条件中的任何一个都是假的，则不会发生选择事件。

      • selectNext

        public abstract void selectNext​()

        此方法将尝试在当前焦点索引之后直接选择索引。 如果没有首先调用clearSelection，则该方法将具有选择下一个索引的结果，同时保留对任何其他当前选择的索引的选择。

        调用此方法将仅在以下情况下成功：

        • 目前有一个主角/重点指数。
        • 主要/焦点指数不是控件中的最后一个指标。
        • 下一个索引尚未被选中。

        如果这些条件中的任何一个都是假的，则不会发生选择事件。

      • selectFirst

        public abstract void selectFirst​()

        该方法将尝试选择控件中的第一个索引。 如果首先不调用clearSelection，则该方法将具有选择第一个索引的结果，同时保留对当前其他任何索引的选择。

        如果已经选择了第一个索引，调用此方法将不会产生任何结果，并且不会执行选择事件。

      • selectLast

        public abstract void selectLast​()

        此方法将尝试选择控件中的最后一个索引。 如果没有首先调用clearSelection，则该方法将具有选择最后一个索引的结果，同时保留对其他当前选定索引的选择。

        如果最后一个索引已经被选中，调用该方法将不会有结果，并且不会发生选择事件。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Separator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Separator

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Separator
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class Separator
extends Control
    水平或垂直分隔线。 该分离器的视觉外观可以通过CSS控制。 水平分隔符占据分配给它的完整水平空间（较少填充），垂直分隔符占据分配给它的完整垂直空间（较少填充）。 halignment和valignment属性确定分隔符在另一个维度中的位置，例如，水平分隔符如何在其分配的空间内垂直定位。

    默认情况下，分隔符是水平的（即isVertical() == false ）。

    此控件的样式类为“separator”。

    分隔符提供两个相互排斥的伪类“horizontal”和“vertical”。 如果分隔符是水平的，则应用“horizontal”伪类，如果分隔符是垂直的，则应用“vertical”伪类。

    分隔符将focusTraversable设置为false。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<HPos> halignment
      对于垂直分隔符，指定分隔线在空间中的水平位置。
      ObjectProperty<Orientation> orientation
      Separator的方向可以是水平还是垂直。
      ObjectProperty<VPos> valignment
      对于水平分隔符，指定分隔符控件空间内的分隔线的垂直对齐方式。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Separator​()
      创建一个新的水平分隔符，其中的对齐和对齐设置为它们各自的CENTER值。
      Separator​(Orientation orientation)
      创建一个新的分隔符，其中的对齐和赋值设置为它们各自的CENTER值。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      HPos getHalignment​()
      获取属性暂停的值。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      Orientation getOrientation​()
      获取属性方向的值。
      VPos getValignment​()
      获取属性对齐的值。
      ObjectProperty<HPos> halignmentProperty​()
      对于垂直分隔符，指定分隔线在空间中的水平位置。
      ObjectProperty<Orientation> orientationProperty​()
      Separator的方向可以是水平还是垂直。
      void setHalignment​(HPos value)
      设置属性暂停的值。
      void setOrientation​(Orientation value)
      设置属性方向的值。
      void setValignment​(VPos value)
      设置属性对齐的值。
      ObjectProperty<VPos> valignmentProperty​()
      对于水平分隔符，指定分隔符控件空间内的分隔线的垂直对齐方式。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • orientation

        public final ObjectProperty<Orientation> orientationProperty
        Separator的方向可以是水平还是垂直。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • halignment

        public final ObjectProperty<HPos> halignmentProperty
        对于垂直分隔符，指定分隔线在空间中的水平位置。 忽略水平分离器。
        另请参见：
        getHalignment() ， setHalignment(HPos)

      • valignment

        public final ObjectProperty<VPos> valignmentProperty
        对于水平分隔符，指定分隔符控件空间内的分隔线的垂直对齐方式。 忽略垂直分离器。
        另请参见：
        getValignment() ， setValignment(VPos)

    • 构造方法详细信息

      • Separator

        public Separator​()
        创建一个新的水平分隔符，其中的对齐和对齐设置为它们各自的CENTER值。

      • Separator

        public Separator​(Orientation orientation)
        创建一个新的分隔符，其中的对齐和赋值设置为它们各自的CENTER值。 分隔符的方向由垂直属性指定。
        参数
        orientation - 指定Separator实例最初是垂直还是水平。

    • 方法详细信息

      • setOrientation

        public final void setOrientation​(Orientation value)
        设置属性方向的值。
        Property description:
        Separator的方向可以是水平还是垂直。

      • getOrientation

        public final Orientation getOrientation​()
        获取属性方向的值。
        Property description:
        Separator的方向可以是水平还是垂直。

      • orientationProperty

        public final ObjectProperty<Orientation> orientationProperty​()
        Separator的方向可以是水平还是垂直。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • setHalignment

        public final void setHalignment​(HPos value)
        设置属性暂停的值。
        Property description:
        对于垂直分隔符，指定分隔线在空间中的水平位置。 忽略水平分离器。

      • getHalignment

        public final HPos getHalignment​()
        获取属性暂停的值。
        Property description:
        对于垂直分隔符，指定分隔线在空间中的水平位置。 忽略水平分离器。

      • halignmentProperty

        public final ObjectProperty<HPos> halignmentProperty​()
        对于垂直分隔符，指定分隔线在空间中的水平位置。 忽略水平分离器。
        另请参见：
        getHalignment() ， setHalignment(HPos)

      • setValignment

        public final void setValignment​(VPos value)
        设置属性对齐的值。
        Property description:
        对于水平分隔符，指定分隔符控件空间内的分隔线的垂直对齐方式。 忽略垂直分离器。

      • getValignment

        public final VPos getValignment​()
        获取属性对齐的值。
        Property description:
        对于水平分隔符，指定分隔符控件空间内的分隔线的垂直对齐方式。 忽略垂直分离器。

      • valignmentProperty

        public final ObjectProperty<VPos> valignmentProperty​()
        对于水平分隔符，指定分隔符控件空间内的分隔线的垂直对齐方式。 忽略垂直分离器。
        另请参见：
        getValignment() ， setValignment(VPos)

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤，或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin中的 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        protected List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SeparatorMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SeparatorMenuItem

  • java.lang.Object
    • javafx.scene.control.MenuItem
      • javafx.scene.control.CustomMenuItem
        • javafx.scene.control.SeparatorMenuItem
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class SeparatorMenuItem
extends CustomMenuItem

    A MenuItem ，如名称所示，允许在其中嵌入一个水平分隔符，通过将Separator分配给content属性CustomMenuItem来提供CustomMenuItem这是为方便起见提供的，可以通过分隔符分隔menuitems 。 为了这个目的而不是创建一个CustomMenuItem ，用户可以使用这个类，如下所示。

       SeparatorMenuItem separatorMenuItem = new SeparatorMenuItem();

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    CustomMenuItem ， MenuItem ， Menu

    • Property Summary

      • Properties inherited from class javafx.scene.control.CustomMenuItem

        content, hideOnClick

      • Properties inherited from class javafx.scene.control.MenuItem

        accelerator, disable, graphic, id, mnemonicParsing, onAction, onMenuValidation, parentMenu, parentPopup, style, text, visible

    • Field Summary

      • Fields inherited from class javafx.scene.control.MenuItem

        MENU_VALIDATION_EVENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      SeparatorMenuItem​()
      创建一个默认的SeparatorMenuItem实例。

    • 方法摘要

      • Methods inherited from class javafx.scene.control.CustomMenuItem

        contentProperty, getContent, hideOnClickProperty, isHideOnClick, setContent, setHideOnClick

      • Methods inherited from class javafx.scene.control.MenuItem

        acceleratorProperty, addEventHandler, buildEventDispatchChain, disableProperty, fire, getAccelerator, getCssMetaData, getGraphic, getId, getOnAction, getOnMenuValidation, getParentMenu, getParentPopup, getProperties, getPseudoClassStates, getStyle, getStyleableNode, getStyleableParent, getStyleClass, getText, getTypeSelector, getUserData, graphicProperty, idProperty, isDisable, isMnemonicParsing, isVisible, mnemonicParsingProperty, onActionProperty, onMenuValidationProperty, parentMenuProperty, parentPopupProperty, removeEventHandler, setAccelerator, setDisable, setGraphic, setId, setMnemonicParsing, setOnAction, setOnMenuValidation, setParentMenu, setParentPopup, setStyle, setText, setUserData, setVisible, styleProperty, textProperty, toString, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SeparatorMenuItem

        public SeparatorMenuItem​()
        创建一个默认的SeparatorMenuItem实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SingleSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SingleSelectionModel<T>

  • java.lang.Object
    • javafx.scene.control.SelectionModel<T>
      • javafx.scene.control.SingleSelectionModel<T>
  • 参数类型
    T - 可以选择的控件中包含的项目的类型。

    public abstract class SingleSelectionModel<T>
extends SelectionModel<T>
    一个SelectionModel，它强制要求在任何给定的时间只选择一个索引。 该类存在用于允许可插拔选择模型但不允许多个选择的控件。 一个很好的例子是ChoiceBox控件。 相反，大多数其他控件（ ListView ， TreeView ， TableView等）需要MultipleSelectionModel个实现（虽然MultipleSelectionModel确实还允许单个选择经由设置selectionMode属性）。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    SelectionModel ， MultipleSelectionModel ， SelectionMode

    • Property Summary

      • Properties inherited from class javafx.scene.control.SelectionModel

        selectedIndex, selectedItem

    • 构造方法摘要

      构造方法
      Constructor 描述
      SingleSelectionModel​()
      创建一个默认的SingleSelectionModel实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void clearAndSelect​(int index)
      在SingleSelectionModel中，此方法在功能上等同于调用 select(index) ，因为一次只允许一个选择。
      void clearSelection​()
      清除所有选定索引的选择模型。
      void clearSelection​(int index)
      清除给定索引的选择，如果它当前被选中。
      protected abstract int getItemCount​()
      获取可用于选择模型的项目数。
      protected abstract T getModelItem​(int index)
      获取与特定索引关联的数据模型项。
      boolean isEmpty​()
      该方法可用于测试是否有任何选定的索引/项目。
      boolean isSelected​(int index)
      如果给定的索引是此SingleSelectionModel中当前选定的索引，则此方法将返回true。
      void select​(int index)
      选择给定的索引。
      void select​(T obj)
      选择基础数据模型中给定对象的第一个实例的索引。
      void selectFirst​()
      选择第一个索引。
      void selectLast​()
      选择最后一个索引。
      void selectNext​()
      选择下一个索引。
      void selectPrevious​()
      选择上一个索引。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SelectionModel

        getSelectedIndex, getSelectedItem, selectedIndexProperty, selectedItemProperty, setSelectedIndex, setSelectedItem

    • 构造方法详细信息

      • SingleSelectionModel

        public SingleSelectionModel​()
        创建一个默认的SingleSelectionModel实例。

    • 方法详细信息

      • clearSelection

        public void clearSelection​()

        清除所有选定索引的选择模型。

        Specified by:
        clearSelection在 SelectionModel<T>

      • clearSelection

        public void clearSelection​(int index)
        清除给定索引的选择，如果它当前被选中。
        Specified by:
        clearSelection在 SelectionModel<T>
        参数
        index - 要取消选择的选定项目。

      • isEmpty

        public boolean isEmpty​()
        该方法可用于测试是否有任何选定的索引/项目。 如果没有选定的项目，它将返回true，如果有，则返回false。
        Specified by:
        isEmpty在 SelectionModel<T>
        结果
        如果 没有选择的项目将返回true，如果有的话将返回false。

      • isSelected

        public boolean isSelected​(int index)

        如果给定的索引是此SingleSelectionModel中当前选定的索引，则此方法将返回true。

        Specified by:
        isSelected在 SelectionModel<T>
        参数
        index - 检查当前是否选择的索引。
        结果
        如果给定的索引被选择，则为真，否则为false。

      • clearAndSelect

        public void clearAndSelect​(int index)
        在SingleSelectionModel中，此方法在功能上等同于调用 select(index) ，因为一次只允许一个选择。
        Specified by:
        clearAndSelect在 SelectionModel<T>
        参数
        index - 应该是此选择模型中唯一选择的索引的索引。

      • select

        public void select​(T obj)
        选择基础数据模型中给定对象的第一个实例的索引。 由于SingleSelectionModel只能支持一次选择一个索引，所以这也导致任何先前选择的索引被取消选择。
        Specified by:
        select中的 SelectionModel<T>
        参数
        obj - 要在底层数据模型中选择的对象。

      • select

        public void select​(int index)
        选择给定的索引。 由于SingleSelectionModel只能支持一次选择一个索引，所以这也导致任何先前选择的索引被取消选择。
        Specified by:
        select类 SelectionModel<T>
        参数
        index - 选择模型中要选择的项目的位置。

      • selectPrevious

        public void selectPrevious​()
        选择上一个索引。 由于SingleSelectionModel只能支持一次选择一个索引，所以这也导致任何先前选择的索引被取消选择。
        Specified by:
        selectPrevious在 SelectionModel<T>

      • selectNext

        public void selectNext​()
        选择下一个索引。 由于SingleSelectionModel只能支持一次选择一个索引，所以这也导致任何先前选择的索引被取消选择。
        Specified by:
        selectNext在 SelectionModel<T>

      • selectFirst

        public void selectFirst​()
        选择第一个索引。 由于SingleSelectionModel只能支持一次选择一个索引，所以这也导致任何先前选择的索引被取消选择。
        Specified by:
        selectFirst在 SelectionModel<T>

      • selectLast

        public void selectLast​()
        选择最后一个索引。 由于SingleSelectionModel只能支持一次选择一个索引，所以这也导致任何先前选择的索引被取消选择。
        Specified by:
        selectLast中的 SelectionModel<T>

      • getModelItem

        protected abstract T getModelItem​(int index)
        获取与特定索引关联的数据模型项。
        参数
        index - 项目在基础数据模型中的位置。
        结果
        存在于给定索引处的项目。

      • getItemCount

        protected abstract int getItemCount​()
        获取可用于选择模型的项目数。 如果项目数量可以动态更改，则具体的SingleSelectionModel实现将有责任确保在项目更改时选择或取消选择项目。
        结果
        数字大于或等于0。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Skin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Interface Skin<C extends Skinnable>

  • 参数类型
    C - 皮肤代表的Skinnable的亚型。 这允许皮肤实现访问Skinnable实现，通常是一个Control实现。
    所有已知实现类：
    AccordionSkin ， ButtonBarSkin ， ButtonSkin ， CellSkinBase ， CheckBoxSkin ， ChoiceBoxSkin ， ColorPickerSkin ， ComboBoxBaseSkin ， ComboBoxListViewSkin ， ComboBoxPopupControl ， ContextMenuSkin ， DateCellSkin ， DatePickerSkin ， HTMLEditorSkin ， HyperlinkSkin ， LabeledSkinBase ， LabelSkin ， ListCellSkin ， ListViewSkin ， MenuBarSkin ， MenuButtonSkin ， MenuButtonSkinBase ， PaginationSkin ， ProgressBarSkin ， ProgressIndicatorSkin ， RadioButtonSkin ， ScrollBarSkin ， ScrollPaneSkin ， SeparatorSkin ， SkinBase ， SliderSkin ， SpinnerSkin ， SplitMenuButtonSkin ， SplitPaneSkin ， TableCellSkin ， TableCellSkinBase ， TableRowSkin ， TableRowSkinBase ， TableViewSkin ， TableViewSkinBase ， TabPaneSkin ， TextAreaSkin ， TextFieldSkin ， TextInputControlSkin ， TitledPaneSkin ， ToggleButtonSkin ， ToolBarSkin ， TooltipSkin ， TreeCellSkin ， TreeTableCellSkin ， TreeTableRowSkin ， TreeTableViewSkin ， TreeViewSkin ， VirtualContainerBase

    public interface Skin<C extends Skinnable>
    基类通过定义节点的场景图来定义用户界面控件的视觉表示，以表示皮肤。 Skinnable界面后面的用户界面控件被抽象出来 。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      Node getNode​()
      获取代表此皮肤的节点。
      C getSkinnable​()
      获取此皮肤分配到的Skinnable。

    • 方法详细信息

      • getSkinnable

        C getSkinnable​()
        获取此皮肤分配到的Skinnable。 必须为仅一个Skinnable创建一个皮肤。 当皮肤从Skinnable中删除时，此值只会从非空值转换为空值，并且仅作为对dispose()的调用的结果 。

        构建Skinnable的调用者还必须构建一个“皮肤”并正确建立“控件”和“皮肤”之间的关系。

        结果
        非空的Skinnable，如果处理，则为空值。

      • getNode

        Node getNode​()
        获取代表此皮肤的节点。 除非在调用dispose()之后 ，除非更改为null，否则绝对不能为空。
        结果
        非空节点，除了皮肤被处理之外。

      • dispose

        void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法getSkinnable()和getNode()应在调用处理后返回null。 呼叫处理两次无效。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SkinBase<C extends Control>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
  • All Implemented Interfaces:
    Skin<C>
    已知直接子类：
    AccordionSkin ， ButtonBarSkin ， ChoiceBoxSkin ， ComboBoxBaseSkin ， HTMLEditorSkin ， LabeledSkinBase ， MenuBarSkin ， MenuButtonSkinBase ， PaginationSkin ， ProgressIndicatorSkin ， ScrollBarSkin ， ScrollPaneSkin ， SeparatorSkin ， SliderSkin ， SpinnerSkin ， SplitPaneSkin ， TabPaneSkin ， TextInputControlSkin ， ToolBarSkin ， VirtualContainerBase

    public abstract class SkinBase<C extends Control>
extends Object
implements Skin<C>
    基本实现类，用于通过定义节点的场景图来定义用户界面控件的可视表示，以表示skin 。 Skinnable接口后面的用户界面控件被抽象出来 。
    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SkinBase​(C control)
      所有SkinBase实例的构造方法。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      protected double computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)
      基于第一个受管理的子节点计算基线偏移量。
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      protected void consumeMouseEvents​(boolean value)
      确定是否应自动消耗所有鼠标事件。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      ObservableList<Node> getChildren​()
      返回皮肤的孩子。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      Node getNode​()
      获取代表此皮肤的节点。
      C getSkinnable​()
      获取此皮肤分配到的Skinnable。
      protected void layoutChildren​(double contentX, double contentY, double contentWidth, double contentHeight)
      在场景图的布局过程中调用。
      protected void layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      void pseudoClassStateChanged​(PseudoClass pseudoClass, boolean active)
      用于指定此节点的伪类已更改。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected void registerChangeListener​(ObservableValue<?> property, Consumer<ObservableValue<?>> consumer)
      子类可以调用此方法来注册他们想要监听给定属性的属性更改事件。
      protected double snappedBottomInset​()
      获取底部插图的实用方法，其中包括填充和边框插入。
      protected double snappedLeftInset​()
      获取包含填充和边框插入的左边插图的实用方法。
      protected double snappedRightInset​()
      获取正确的插图的实用方法，包括填充和边框插入。
      protected double snappedTopInset​()
      获取包含填充和边框插入的顶层插图的实用方法。
      protected double snapPosition​(double value)
      已过时。
      替换为snapPositionX()和snapPositionY()
      protected double snapPositionX​(double value)
      便于访问 snapPositionX()方法的 skinnable 。
      protected double snapPositionY​(double value)
      方便访问 snapPositionY()方法的 skinnable 。
      protected double snapSize​(double value)
      已过时。
      由snapSizeX()和snapSizeY()取代
      protected double snapSizeX​(double value)
      方便访问 snapSizeX()方法的 skinnable 。
      protected double snapSizeY​(double value)
      方便访问 snapSizeY()方法的 skinnable 。
      protected double snapSpace​(double value)
      已过时。
      替换为snapSpaceX()和snapSpaceY()
      protected double snapSpaceX​(double value)
      方便访问 snapSpaceX()方法的 skinnable 。
      protected double snapSpaceY​(double value)
      方便的方法访问 snapSpaceY()方法在 skinnable 。
      protected Consumer<ObservableValue<?>> unregisterChangeListeners​(ObservableValue<?> property)
      取消注册已使用 registerChangeListener(ObservableValue, Consumer)注册的所有更改侦听器的给定属性。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SkinBase

        protected SkinBase​(C control)
        所有SkinBase实例的构造方法。
        参数
        control - 此皮肤应附加到的控件。

    • 方法详细信息

      • getSkinnable

        public final C getSkinnable​()
        获取此皮肤分配到的Skinnable。 必须为仅一个Skinnable创建一个皮肤。 当皮肤从Skinnable中删除时，此值只会从非空值转为空值，并且仅作为调用Skin.dispose()的结果 。

        构建Skinnable的调用者还必须构建一个“皮肤”并正确建立“控件”和“皮肤”之间的关系。

        Specified by:
        getSkinnable在接口 Skin<C extends Control>
        结果
        非空的Skinnable，如果处理，则为空值。

      • getNode

        public final Node getNode​()
        获取代表此皮肤的节点。 除非在调用Skin.dispose()之后 ，除非更改为null，否则绝对不能为空。
        Specified by:
        getNode在接口 Skin<C extends Control>
        结果
        非空节点，除了皮肤被处理之外。

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用后，方法Skin.getSkinnable()和Skin.getNode()应返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends Control>

      • getChildren

        public final ObservableList<Node> getChildren​()
        返回皮肤的孩子。
        结果
        皮肤的孩子

      • layoutChildren

        protected void layoutChildren​(double contentX,
                              double contentY,
                              double contentWidth,
                              double contentHeight)
        在场景图的布局过程中调用。
        参数
        contentX - x位置
        contentY - y位置
        contentWidth - 宽度
        contentHeight - 高度

      • consumeMouseEvents

        protected final void consumeMouseEvents​(boolean value)
        确定是否应自动消耗所有鼠标事件。
        参数
        value - 消费鼠标事件标志

      • registerChangeListener

        protected final void registerChangeListener​(ObservableValue<?> property,
                                            Consumer<ObservableValue<?>> consumer)
        子类可以调用此方法来注册他们想要监听给定属性的属性更改事件。 注册的Consumer实例将按照注册顺序执行。
        参数
        property - 该物业
        consumer - 消费者

      • unregisterChangeListeners

        protected final Consumer<ObservableValue<?>> unregisterChangeListeners​(ObservableValue<?> property)
        取消注册已使用registerChangeListener(ObservableValue, Consumer)注册的所有更改侦听器的给定属性。 最终的结果是任何变化监听者不再观察到给定的属性，但是通过registerChangeListener(ObservableValue, Consumer)之外的手段，它仍然可以在其上注册另外的监听器 。
        参数
        property - 应该删除所有侦听器的属性。
        结果
        单链Consumer由所有的consumers挂号registerChangeListener(ObservableValue, Consumer) 。 如果该物业没有注册消费者，则返回null。
        从以下版本开始：
        9

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算此SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeBaselineOffset

        protected double computeBaselineOffset​(double topInset,
                                       double rightInset,
                                       double bottomInset,
                                       double leftInset)
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        参数
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        基线偏移

      • snappedTopInset

        protected double snappedTopInset​()
        获取包含填充和边框插入的顶层插图的实用方法。 如果getSkinnable（）。isSnapToPixel（）为true，则将其全部移动到像素上。
        结果
        圆顶顶

      • snappedBottomInset

        protected double snappedBottomInset​()
        获取底部插图的实用方法，其中包括填充和边框插入。 如果getSkinnable（）。isSnapToPixel（）为true，则将其全部移动到像素上。
        结果
        倒圆角的底部

      • snappedLeftInset

        protected double snappedLeftInset​()
        获取包含填充和边框插入的左边插图的实用方法。 如果getSkinnable（）。isSnapToPixel（）为true，则将其全部移动到像素上。
        结果
        向左舍入

      • snappedRightInset

        protected double snappedRightInset​()
        获取正确的插图的实用方法，包括填充和边框插入。 如果getSkinnable（）。isSnapToPixel（）为true，则将其全部移动到像素上。
        结果
        圆形插图正确

      • snapSpace

        @Deprecated(since="9")
protected double snapSpace​(double value)
        已过时。 替换为snapSpaceX()和snapSpaceY()
        如果 getSkinnable().isSnapToPixel()为false，则该方法返回相同的值，否则它会尝试将值舍入到最近的像素，但是由于没有指示值是垂直还是水平测量，那么它可能会 getSkinnable().isSnapToPixel()错误的像素大小具有不同水平和垂直刻度的屏幕上的公制。
        参数
        value - 要捕获的空间值
        结果
        值舍入到最近的像素

      • snapSpaceX

        protected double snapSpaceX​(double value)
        方便的方法访问snapSpaceX()方法在skinnable 。 相当于调用getSkinnable().snapSpaceX(value) 。
        参数
        value - 要捕获的空间值
        结果
        值舍入到最近的像素
        从以下版本开始：
        9
        另请参见：
        Region.snapSpaceX(double)

      • snapSpaceY

        protected double snapSpaceY​(double value)
        方便的方法访问snapSpaceY()方法在skinnable 。 相当于调用getSkinnable().snapSpaceY(value) 。
        参数
        value - 要捕获的空间值
        结果
        值舍入到最近的像素
        从以下版本开始：
        9
        另请参见：
        Region.snapSpaceY(double)

      • snapSize

        @Deprecated(since="9")
protected double snapSize​(double value)
        已过时。 替换为snapSizeX()和snapSizeY()
        如果 getSkinnable().isSnapToPixel()为false，则该方法返回相同的值，否则会尝试将值舍弃为最近的像素，但是由于没有指示值是垂直还是水平测量，因此可能会捕获到错误的像素大小具有不同水平和垂直刻度的屏幕上的公制。
        参数
        value - 要拍摄的大小值
        结果
        值被忽略到最近的像素

      • snapSizeX

        protected double snapSizeX​(double value)
        方便访问snapSizeX()方法的skinnable 。 相当于调用getSkinnable().snapSizeX(value) 。
        参数
        value - 要拍摄的大小值
        结果
        值被忽略到最近的像素
        从以下版本开始：
        9
        另请参见：
        Region.snapSizeX(double)

      • snapSizeY

        protected double snapSizeY​(double value)
        方便的方法访问snapSizeY()方法的skinnable 。 相当于调用getSkinnable().snapSizeY(value) 。
        参数
        value - 要拍摄的大小值
        结果
        值被忽略到最近的像素
        从以下版本开始：
        9
        另请参见：
        Region.snapSizeY(double)

      • snapPosition

        @Deprecated(since="9")
protected double snapPosition​(double value)
        已过时。 替换为snapPositionX()和snapPositionY()
        如果 getSkinnable().isSnapToPixel()为false，则该方法返回相同的值，否则将尝试将值舍入到最近的像素，但是由于没有指示值是垂直还是水平测量，因此可能会 getSkinnable().isSnapToPixel()错误的像素大小具有不同水平和垂直刻度的屏幕上的公制。
        参数
        value - 要 value的位置值
        结果
        值舍入到最近的像素

      • snapPositionX

        protected double snapPositionX​(double value)
        方便访问snapPositionX()方法的skinnable 。 相当于调用getSkinnable().snapPositionX(value) 。
        参数
        value - 要 value的位置值
        结果
        值舍入到最近的像素
        从以下版本开始：
        9
        另请参见：
        Region.snapPositionX(double)

      • snapPositionY

        protected double snapPositionY​(double value)
        方便访问snapPositionY()方法的skinnable 。 相当于调用getSkinnable().snapPositionY(value) 。
        参数
        value - 要 value的位置值
        结果
        值舍入到最近的像素
        从以下版本开始：
        9
        另请参见：
        Region.snapPositionY(double)

      • positionInArea

        protected void positionInArea​(Node child,
                              double areaX,
                              double areaY,
                              double areaWidth,
                              double areaHeight,
                              double areaBaselineOffset,
                              HPos halignment,
                              VPos valignment)
        通过定义哪个位置此皮肤区域中的子项实用方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        此功能不调整节点和使用节点的布局界限的宽度和高度，以决定应如何定位的区域内。

        如果垂直对齐是VPos.BASELINE那么它将定位节点，使其自己的基线与baselineOffset传递的基线对齐，否则基线参数将被忽略。

        如果snapToPixel是这个皮肤的true ，则x / y位置值将被舍入到最接近的像素边界。

        参数
        child - 孩子被定位在这个皮肤内
        areaX - 相对于这个皮肤的布局区域的水平偏移
        areaY - 相对于这个皮肤的布局面积的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果VPos为BASELINE，则使用的基线偏移量
        halignment - 区域内儿童的水平对齐方式
        valignment - 区域内儿童的垂直对齐方式

      • positionInArea

        protected void positionInArea​(Node child,
                              double areaX,
                              double areaY,
                              double areaWidth,
                              double areaHeight,
                              double areaBaselineOffset,
                              Insets margin,
                              HPos halignment,
                              VPos valignment)
        通过定义哪个位置此皮肤区域中的子项实用方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        此功能不调整节点和使用节点的布局界限的宽度和高度，以决定应如何定位的区域内。

        如果垂直对齐是VPos.BASELINE那么它将定位节点，使其自己的基线与baselineOffset传递的基线对齐，否则基线参数将被忽略。

        如果snapToPixel是这个皮肤的true ，则x / y位置值将被舍入到最接近的像素边界。

        如果margin为非空值，则该空间将在布局区域内的小孩周围分配。 保证金可能为空。

        参数
        child - 孩子被定位在这个皮肤内
        areaX - 相对于这个皮肤的布局区域的水平偏移
        areaY - 相对于这个皮肤的布局区域的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果 areaBaselineOffset为基线，则使用的基线偏移量
        margin - 要分配给孩子的空间余量
        halignment - 区域内儿童的水平对齐方式
        valignment - 区域内儿童的垂直对齐方式
        从以下版本开始：
        JavaFX 8.0

      • layoutInArea

        protected void layoutInArea​(Node child,
                            double areaX,
                            double areaY,
                            double areaWidth,
                            double areaHeight,
                            double areaBaselineOffset,
                            HPos halignment,
                            VPos valignment)
        其中规定了子由所限定的本皮肤区域内实用方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        如果孩子可调整大小，则该方法将调整其大小以填充指定的区域，除非该节点的最大大小阻止它。 如果节点的最大大小偏好小于区域大小，则将使用最大大小。 如果节点的最大值大于区域大小，则节点将被调整大小以适合该区域，除非它的最小大小阻止它。

        如果孩子有一个非空的contentBias，那么这个方法将在调整小孩时使用它。 如果contentBias是水平的，它将首先将其宽度设置为区域的宽度（直到孩子的最大宽度限制），然后传递该值以计算孩子的高度。 如果孩子的contentBias是垂直的，那么它将把它的高度设置为区域高度（最高到孩子的最大高度限制），并传递该高度来计算孩子的宽度。 如果孩子的contentBias为null，那么它的width和height没有彼此的依赖关系。

        如果孩子不能调整大小（Shape，Group等），那么它只能被定位，而不是调整大小。

        如果小孩的大小与区域的大小不同（由于它不是可调整大小，或者是调整大小偏好设置），那么这个函数将使用水平和垂直对齐值来对齐节点。 如果取值为VPos.BASELINE则节点的基线将与区域基线偏移参数对齐，否则基线参数将被忽略。

        如果此皮肤的snapToPixel为true ，则所得到的x，y值将舍入为最近的像素边界，宽/高值将被忽略到下一个像素边界。

        参数
        child - 孩子被定位在这个皮肤内
        areaX - 相对于这个皮肤的布局区域的水平偏移
        areaY - 相对于这个皮肤的布局面积的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果 areaBaselineOffset为基线，则使用的基线偏移量
        halignment - 区域内儿童的水平对齐方式
        valignment - 区域内儿童的垂直对齐方式

      • layoutInArea

        protected void layoutInArea​(Node child,
                            double areaX,
                            double areaY,
                            double areaWidth,
                            double areaHeight,
                            double areaBaselineOffset,
                            Insets margin,
                            HPos halignment,
                            VPos valignment)
        其中规定了子由所限定的本皮肤区域内实用方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        如果孩子可调整大小，则该方法将调整其大小以填充指定的区域，除非该节点的最大大小阻止它。 如果节点的最大大小偏好小于区域大小，则将使用最大大小。 如果节点的最大值大于区域大小，则节点将被调整大小以适合该区域，除非它的最小大小阻止它。

        如果孩子有一个非空的contentBias，那么这个方法将在调整小孩时使用它。 如果contentBias是水平的，它将首先将其宽度设置为区域的宽度（直到孩子的最大宽度限制），然后传递该值以计算孩子的高度。 如果孩子的contentBias是垂直的，那么它将把它的高度设置为区域高度（最高到孩子的最大高度限制），并传递该高度来计算孩子的宽度。 如果孩子的contentBias为null，那么它的width和height没有彼此的依赖关系。

        如果孩子不能调整大小（Shape，Group等），那么它只能被定位，而不是调整大小。

        如果小孩的大小与区域的大小不同（由于它不是可调整大小，或者是调整大小偏好设置），那么这个函数将使用水平和垂直对齐值来对齐节点。 如果取值为VPos.BASELINE则节点的基线将与区域基线偏移参数对齐，否则基线参数将被忽略。

        如果margin为非空值，则该空间将在布局区域内的小孩周围分配。 保证金可能为空。

        如果snapToPixel是这个皮肤的true ，则所得到的x，y值将被四舍五入到其最近的像素边界，并且宽/高值将被忽略到下一个像素边界。

        参数
        child - 孩子被定位在这个皮肤内
        areaX - 相对于这个皮肤的布局区域的水平偏移
        areaY - 相对于这个皮肤的布局区域的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果VPOS为BASELINE，则使用的基线偏移量
        margin - 要在孩子周围分配的空间余量
        halignment - 区域内儿童的水平对齐方式
        valignment - 区域内儿童的垂直对齐方式

      • layoutInArea

        protected void layoutInArea​(Node child,
                            double areaX,
                            double areaY,
                            double areaWidth,
                            double areaHeight,
                            double areaBaselineOffset,
                            Insets margin,
                            boolean fillWidth,
                            boolean fillHeight,
                            HPos halignment,
                            VPos valignment)
        其中规定了子由所限定的本皮肤区域内实用方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        如果小孩可调整大小，则此方法将使用fillWidth和fillHeight来确定是否调整其大小以填充该区域或将孩子保持在其首选的尺寸。 如果fillWidth / fillHeight为true，那么此方法将仅调整小孩的大小，直到其最大大小限制。 如果节点的最大大小偏好小于区域大小，则将使用最大大小。 如果节点的最大值大于区域大小，则节点将被调整大小以适合该区域，除非它的最小大小阻止它。

        如果孩子有一个非空的contentBias，那么这个方法将在调整小孩时使用它。 如果contentBias是水平的，它将首先设置它的宽度，然后传递该值来计算孩子的高度。 如果child的contentBias是垂直的，那么它将首先设置它的高度，并传递该值来计算孩子的宽度。 如果孩子的contentBias为null，那么它的width和height没有彼此的依赖关系。

        如果孩子不能调整大小（Shape，Group等），那么它只能被定位，而不是调整大小。

        如果小孩的大小与区域的大小不同（由于它不是可调整大小，或者是调整大小偏好设置），那么这个函数将使用水平和垂直对齐值来对齐节点。 如果取值为VPos.BASELINE则节点的基线将与区域基线偏移参数对齐，否则基线参数将被忽略。

        如果margin为非空值，则该空间将在布局区域内的小孩周围分配。 保证金可能为空。

        如果此皮肤的snapToPixel为true ，则所得到的x，y值将舍入为最近的像素边界，宽/高值将被忽略到下一个像素边界。

        参数
        child - 孩子被定位在这个皮肤内
        areaX - 相对于此皮肤的布局区域的水平偏移
        areaY - 相对于这个皮肤的布局区域的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果VPOS为BASELINE，则使用的基线偏移量
        margin - 要在孩子周围分配的空间余量
        fillWidth - 小孩是否应调整大小以填补面积宽度或保持其首选宽度
        fillHeight - 无论小孩是否应该调整大小以填补区域高度或保持在其首选高度
        halignment - 区域内儿童的水平对齐
        valignment - 区域内儿童的垂直对齐方式

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。

      • pseudoClassStateChanged

        public final void pseudoClassStateChanged​(PseudoClass pseudoClass,
                                          boolean active)
        用于指定此节点的伪类已更改。 如果在与CSS相符的CSS选择器中使用伪类，则将重新应用CSS。 通常，该方法是从用作伪类的属性的invalidated方法中调用的。 例如：
           private static final PseudoClass MY_PSEUDO_CLASS_STATE = PseudoClass.getPseudoClass("my-state"); BooleanProperty myPseudoClassState = new BooleanPropertyBase(false) { @Override public void invalidated() { pseudoClassStateChanged(MY_PSEUDO_CLASS_STATE, get()); } @Override public Object getBean() { return MyControl.this; } @Override public String getName() { return "myPseudoClassState"; } };
        参数
        pseudoClass - 已修改状态的伪类
        active - 状态是否活动
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Node.pseudoClassStateChanged(javafx.css.PseudoClass, boolean)

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)

      • executeAccessibleAction

        protected void executeAccessibleAction​(AccessibleAction action,
                                       Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        参数
        action - 要执行的动作
        parameters - 可选参数列表
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        AccessibleAction, Node.executeAccessibleAction(javafx.scene.AccessibleAction, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Skinnable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Interface Skinnable

  • 所有已知实现类：
    Accordion ， Button ， ButtonBar ， ButtonBase ， Cell ， CheckBox ， CheckBoxListCell ， CheckBoxTableCell ， CheckBoxTreeCell ， CheckBoxTreeTableCell ， ChoiceBox ， ChoiceBoxListCell ， ChoiceBoxTableCell ， ChoiceBoxTreeCell ， ChoiceBoxTreeTableCell ， ColorPicker ， ComboBox ， ComboBoxBase ， ComboBoxListCell ， ComboBoxTableCell ， ComboBoxTreeCell ， ComboBoxTreeTableCell ， ContextMenu ， Control ， DateCell ， DatePicker ， HTMLEditor ， Hyperlink ， IndexedCell ， Label ， Labeled ， ListCell ， ListView ， MenuBar ， MenuButton ， Pagination ， PasswordField ， PopupControl ， ProgressBar ， ProgressBarTableCell ， ProgressBarTreeTableCell ， ProgressIndicator ， RadioButton ， ScrollBar ， ScrollPane ， Separator ， Slider ， Spinner ， SplitMenuButton ， SplitPane ， TableCell ， TableRow ， TableView ， TabPane ， TextArea ， TextField TextField ， TextFieldListCell ， TextFieldTableCell ， TextFieldTreeCell ， TextFieldTreeTableCell ， TextInputControl ， TitledPane ， ToggleButton ， ToolBar ， Tooltip ， TreeCell ， TreeTableCell ， TreeTableRow ， TreeTableView ， TreeView

    public interface Skinnable

    Skinnable接口由Control类实现，因此由所有控件实现实现。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Skin<?>> skin
      皮肤负责渲染这个 Control 。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Skin<?> getSkin​()
      返回呈现Control的皮肤
      void setSkin​(Skin<?> value)
      设置将呈现Control的皮肤
      ObjectProperty<Skin<?>> skinProperty​()
      皮肤负责渲染这个 Control 。

    • Property Detail

      • skin

        ObjectProperty<Skin<?>> skinProperty
        皮肤负责渲染这个Control 。 从Control的角度来看， Skin是一个黑盒子。 它在Control监听和响应状态的Control 。

        一个Control和它的Skin之间有一对一的关系。 每Skin保持回参考Control 。

        皮肤可能为空。

        另请参见：
        getSkin() ， setSkin(Skin)

    • 方法详细信息

      • skinProperty

        ObjectProperty<Skin<?>> skinProperty​()
        皮肤负责渲染这个Control 。 从Control的角度来看， Skin是一个黑盒子。 它在Control监听和响应状态的Control 。

        一个Control和它的Skin之间有一对一的关系。 每Skin保持回参考Control 。

        皮肤可能为空。

        另请参见：
        getSkin() ， setSkin(Skin)

      • setSkin

        void setSkin​(Skin<?> value)
        设置将呈现Control的皮肤
        参数
        value - 此控件的皮肤值

      • getSkin

        Skin<?> getSkin​()
        返回呈现Control的皮肤
        结果
        这个控制的皮肤
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Slider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Slider

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Slider
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class Slider
extends Control
    滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。 它通常在视觉上表示为具有在轨道内拖动的“轨道”和“旋钮”或“拇指”。 滑块可以选择显示刻度线和标签，指示不同的滑块位置值。

    滑块的三个基本变量是min ， max ，并value 。 value应始终是由min和max定义的范围内的max 。 min应始终小于或等于max （尽管其min和max相等的滑块是没有任何意义的退化情况）。 min默认为0，而max默认为100。

    此第一个示例创建一个滑块，其范围或span从0变为1，其值默认为.5：

      import javafx.scene.control.Slider;

 Slider slider = new Slider(0, 1, 0.5);

    下一个示例显示一个带有自定义刻度线和刻度线标签的滑块，也从0到1：

      import javafx.scene.control.Slider;

 Slider slider = new Slider(0, 1, 0.5);
 slider.setShowTickMarks(true);
 slider.setShowTickLabels(true);
 slider.setMajorTickUnit(0.25f);
 slider.setBlockIncrement(0.1f);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty blockIncrement
      如果点击滑块的轨道，则调整滑块的量。
      ObjectProperty<StringConverter<Double>> labelFormatter
      用于格式化主要刻度的标签的功能。
      DoubleProperty majorTickUnit
      主要刻度线之间的单位距离。
      DoubleProperty max
      由此滑块表示的最大值。
      IntegerProperty minorTickCount
      任何两个主要蜱之间的次要蜱的数量。
      DoubleProperty min
      由此滑块表示的最小值。
      ObjectProperty<Orientation> orientation
      Slider的方向可以是水平还是垂直。
      BooleanProperty showTickLabels
      表示应该显示刻度线的标签。
      BooleanProperty showTickMarks
      指定Skin实现是否应显示刻度线。
      BooleanProperty snapToTicks
      指示 Slider中的 Slider是否应始终与刻度线对齐。
      BooleanProperty valueChanging
      当为true时，表示此滑块的当前值正在更改。
      DoubleProperty value
      由此滑块表示的当前值。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Slider​()
      创建一个默认的Slider实例。
      Slider​(double min, double max, double value)
      使用指定的滑块最小值，最大值和当前值值构造滑块控件。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      void adjustValue​(double newValue)
      调整 value匹配 newValue 。
      DoubleProperty blockIncrementProperty​()
      如果点击滑块的轨道，则调整滑块的量。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void decrement​()
      将值减少 blockIncrement ，以最大值为单位。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      double getBlockIncrement​()
      获取属性blockIncrement的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      protected List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      StringConverter<Double> getLabelFormatter​()
      获取属性labelFormatter的值。
      double getMajorTickUnit​()
      获取属性majorTickUnit的值。
      double getMax​()
      获取最大值的属性值。
      double getMin​()
      获取属性的值min。
      int getMinorTickCount​()
      获取属性minorTickCount的值。
      Orientation getOrientation​()
      获取属性方向的值。
      double getValue​()
      获取属性值的值。
      void increment​()
      将值增加 blockIncrement ，以最大值
      boolean isShowTickLabels​()
      获取属性showTickLabels的值。
      boolean isShowTickMarks​()
      获取属性showTickMarks的值。
      boolean isSnapToTicks​()
      获取属性snapToTicks的值。
      boolean isValueChanging​()
      获取属性valueChanging的值。
      ObjectProperty<StringConverter<Double>> labelFormatterProperty​()
      用于格式化主要刻度的标签的功能。
      DoubleProperty majorTickUnitProperty​()
      主要刻度线之间的单位距离。
      DoubleProperty maxProperty​()
      由此滑块表示的最大值。
      IntegerProperty minorTickCountProperty​()
      任何两个主要蜱之间的次要蜱的数量。
      DoubleProperty minProperty​()
      由此滑块表示的最小值。
      ObjectProperty<Orientation> orientationProperty​()
      Slider的方向可以是水平还是垂直。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setBlockIncrement​(double value)
      设置属性blockIncrement的值。
      void setLabelFormatter​(StringConverter<Double> value)
      设置属性labelFormatter的值。
      void setMajorTickUnit​(double value)
      设置属性majorTickUnit的值。
      void setMax​(double value)
      设置属性max的值。
      void setMin​(double value)
      设置属性的值min。
      void setMinorTickCount​(int value)
      设置属性minorTickCount的值。
      void setOrientation​(Orientation value)
      设置属性方向的值。
      void setShowTickLabels​(boolean value)
      设置属性showTickLabels的值。
      void setShowTickMarks​(boolean value)
      设置属性showTickMarks的值。
      void setSnapToTicks​(boolean value)
      设置属性snapToTicks的值。
      void setValue​(double value)
      设置属性值的值。
      void setValueChanging​(boolean value)
      设置属性valueChanging的值。
      BooleanProperty showTickLabelsProperty​()
      表示应该显示刻度线的标签。
      BooleanProperty showTickMarksProperty​()
      指定Skin实现是否应显示刻度线。
      BooleanProperty snapToTicksProperty​()
      指示 Slider中的 Slider是否应始终与刻度线对齐。
      BooleanProperty valueChangingProperty​()
      当为true时，表示此滑块的当前值正在更改。
      DoubleProperty valueProperty​()
      由此滑块表示的当前值。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • max

        public final DoubleProperty maxProperty
        由此滑块表示的最大值。 这个值必须大于min 。
        另请参见：
        getMax() ， setMax(double)

      • min

        public final DoubleProperty minProperty
        由此滑块表示的最小值。 这个值必须小于max 。
        另请参见：
        getMin() ， setMin(double)

      • value

        public final DoubleProperty valueProperty
        由此滑块表示的当前值。 该值必须始终在min和max之间。 如果由于min或max改变或由于自身被更改而超出范围，则将被夹紧以始终保持有效。
        另请参见：
        getValue() ， setValue(double)

      • valueChanging

        public final BooleanProperty valueChangingProperty
        当为true时，表示此滑块的当前值正在更改。 它提供了值正在改变的通知。 一旦计算了值，它将重置为false。
        另请参见：
        isValueChanging() ， setValueChanging(boolean)

      • orientation

        public final ObjectProperty<Orientation> orientationProperty
        Slider的方向可以是水平还是垂直。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • showTickLabels

        public final BooleanProperty showTickLabelsProperty
        表示应该显示刻度线的标签。 通常Skin实现只会显示标签，如果showTickMarks也是真的。
        另请参见：
        isShowTickLabels() ， setShowTickLabels(boolean)

      • showTickMarks

        public final BooleanProperty showTickMarksProperty
        指定Skin实现是否应显示刻度线。
        另请参见：
        isShowTickMarks() ， setShowTickMarks(boolean)

      • majorTickUnit

        public final DoubleProperty majorTickUnitProperty
        主要刻度线之间的单位距离。 例如，如果min是0，而max是100，而majorTickUnit是25，那么将会有5个刻度线：一个在位置0，一个在位置25，一个在位置50，一个在位置75，一个在位置75一个在位置100。

        该值应为正值，应为小于跨度的值。 超出范围值与禁用刻度线基本相同。

        另请参见：
        getMajorTickUnit() ， setMajorTickUnit(double)

      • minorTickCount

        public final IntegerProperty minorTickCountProperty
        任何两个主要蜱之间的次要蜱的数量。 这个数字应该是正数或零。 超出范围值将禁用禁用次要tick，值为零。
        另请参见：
        getMinorTickCount() ， setMinorTickCount(int)

      • snapToTicks

        public final BooleanProperty snapToTicksProperty
        指示Slider的Slider应始终与刻度线对齐。 即使没有显示刻度线，也是如此。
        另请参见：
        isSnapToTicks() ， setSnapToTicks(boolean)

      • labelFormatter

        public final ObjectProperty<StringConverter<Double>> labelFormatterProperty
        用于格式化主要刻度的标签的功能。 表示主要刻度的数字将被传递给该功能。 如果未指定此功能，则Skin实现将使用默认功能。
        另请参见：
        getLabelFormatter() ， setLabelFormatter(StringConverter)

      • blockIncrement

        public final DoubleProperty blockIncrementProperty
        如果点击滑块的轨道，则调整滑块的量。 当使用键操作滑块位置时使用。 如果snapToTicks为真，则将使用最接近调整值的刻度标记。
        另请参见：
        getBlockIncrement() ， setBlockIncrement(double)

    • 构造方法详细信息

      • Slider

        public Slider​()
        创建一个默认的Slider实例。

      • Slider

        public Slider​(double min,
              double max,
              double value)
        使用指定的滑块最小值，最大值和当前值值构造滑块控件。
        参数
        min - 滑块最小值
        max - 滑块最大值
        value - 滑块当前值

    • 方法详细信息

      • setMax

        public final void setMax​(double value)
        设置属性max的值。
        Property description:
        由此滑块表示的最大值。 这个值必须大于min 。

      • getMax

        public final double getMax​()
        获取最大值的属性值。
        Property description:
        由此滑块表示的最大值。 这个值必须大于min 。

      • maxProperty

        public final DoubleProperty maxProperty​()
        由此滑块表示的最大值。 这个值必须大于min 。
        另请参见：
        getMax() ， setMax(double)

      • setMin

        public final void setMin​(double value)
        设置属性的值min。
        Property description:
        由此滑块表示的最小值。 这个值必须小于max 。

      • getMin

        public final double getMin​()
        获取属性的值min。
        Property description:
        由此滑块表示的最小值。 这个值必须小于max 。

      • minProperty

        public final DoubleProperty minProperty​()
        由此滑块表示的最小值。 这个值必须小于max 。
        另请参见：
        getMin() ， setMin(double)

      • setValue

        public final void setValue​(double value)
        设置属性值的值。
        Property description:
        由此滑块表示的当前值。 该值必须始终在min和max之间。 如果由于min或max发生变化或由于本身发生变化而导致的限制，则将被夹紧以始终保持有效。

      • getValue

        public final double getValue​()
        获取属性值的值。
        Property description:
        由此滑块表示的当前值。 该值必须始终在min和max之间。 如果由于min或max发生变化或由于本身发生变化而超出范围，则将被夹紧以始终保持有效。

      • valueProperty

        public final DoubleProperty valueProperty​()
        由此滑块表示的当前值。 该值必须始终在min和max之间。 如果由于min或max发生变化或由于自身被更改而超出范围，则将被钳制以始终保持有效。
        另请参见：
        getValue() ， setValue(double)

      • setValueChanging

        public final void setValueChanging​(boolean value)
        设置属性valueChanging的值。
        Property description:
        当为true时，表示此滑块的当前值正在更改。 它提供了值正在改变的通知。 一旦计算了值，它将重置为false。

      • isValueChanging

        public final boolean isValueChanging​()
        获取属性valueChanging的值。
        Property description:
        当为true时，表示此滑块的当前值正在更改。 它提供了值正在改变的通知。 一旦计算了值，它将重置为false。

      • valueChangingProperty

        public final BooleanProperty valueChangingProperty​()
        当为true时，表示此滑块的当前值正在更改。 它提供了值正在改变的通知。 一旦计算了值，它将重置为false。
        另请参见：
        isValueChanging() ， setValueChanging(boolean)

      • setOrientation

        public final void setOrientation​(Orientation value)
        设置属性方向的值。
        Property description:
        Slider的方向可以是水平还是垂直。

      • getOrientation

        public final Orientation getOrientation​()
        获取属性方向的值。
        Property description:
        Slider的方向可以是水平还是垂直。

      • orientationProperty

        public final ObjectProperty<Orientation> orientationProperty​()
        Slider的方向可以是水平还是垂直。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • setShowTickLabels

        public final void setShowTickLabels​(boolean value)
        设置属性showTickLabels的值。
        Property description:
        表示应该显示刻度线的标签。 通常， Skin实现只会显示标签，如果showTickMarks也为真。

      • isShowTickLabels

        public final boolean isShowTickLabels​()
        获取属性showTickLabels的值。
        Property description:
        表示应该显示刻度线的标签。 通常Skin实现只会显示标签，如果showTickMarks也是真的。

      • showTickLabelsProperty

        public final BooleanProperty showTickLabelsProperty​()
        表示应该显示刻度线的标签。 通常Skin的实现只会显示标签，如果showTickMarks也是真的。
        另请参见：
        isShowTickLabels() ， setShowTickLabels(boolean)

      • setShowTickMarks

        public final void setShowTickMarks​(boolean value)
        设置属性showTickMarks的值。
        Property description:
        指定Skin实现是否应显示刻度线。

      • isShowTickMarks

        public final boolean isShowTickMarks​()
        获取属性showTickMarks的值。
        Property description:
        指定Skin实现是否应显示刻度线。

      • showTickMarksProperty

        public final BooleanProperty showTickMarksProperty​()
        指定Skin实现是否应显示刻度线。
        另请参见：
        isShowTickMarks() ， setShowTickMarks(boolean)

      • setMajorTickUnit

        public final void setMajorTickUnit​(double value)
        设置属性majorTickUnit的值。
        Property description:
        主要刻度线之间的单位距离。 例如，如果27069963989363是0，而max是100，而majorTickUnit是25，那么将有5个刻度线：一个在位置0，一个在位置25，一个在位置50，一个在位置75，最后一个一个在位置100。

        该值应为正值，应为小于跨度的值。 超出范围值与禁用刻度线基本相同。

      • getMajorTickUnit

        public final double getMajorTickUnit​()
        获取属性majorTickUnit的值。
        Property description:
        主要刻度线之间的单位距离。 例如，如果min为0且max为100，而majorTickUnit为25，那么将出现5个刻度线：一个在位置0，一个在位置25，一个在位置50，一个在位置75，最后一个位置一个在位置100。

        该值应为正值，应为小于跨度的值。 超出范围值与禁用刻度线基本相同。

      • majorTickUnitProperty

        public final DoubleProperty majorTickUnitProperty​()
        主要刻度线之间的单位距离。 例如，如果min为0且max是100和majorTickUnit为25，然后将有5刻度标记：一个在位置0，一个在位置25，一个在位置50，一个在位置75和最终一个在位置100。

        该值应为正值，应为小于跨度的值。 超出范围值与禁用刻度线基本相同。

        另请参见：
        getMajorTickUnit() ， setMajorTickUnit(double)

      • setMinorTickCount

        public final void setMinorTickCount​(int value)
        设置属性minorTickCount的值。
        Property description:
        任何两个主要蜱之间的次要蜱的数量。 这个数字应该是正数或零。 超出范围值将禁用禁用次要tick，值为零。

      • getMinorTickCount

        public final int getMinorTickCount​()
        获取属性minorTickCount的值。
        Property description:
        任何两个主要蜱之间的次要蜱的数量。 这个数字应该是正数或零。 超出范围值将禁用禁用次要tick，值为零。

      • minorTickCountProperty

        public final IntegerProperty minorTickCountProperty​()
        任何两个主要蜱之间的次要蜱的数量。 这个数字应该是正数或零。 超出范围值将禁用禁用次要tick，值为零。
        另请参见：
        getMinorTickCount() ， setMinorTickCount(int)

      • setSnapToTicks

        public final void setSnapToTicks​(boolean value)
        设置属性snapToTicks的值。
        Property description:
        指示Slider的Slider应始终与刻度线对齐。 即使没有显示刻度线，也是如此。

      • isSnapToTicks

        public final boolean isSnapToTicks​()
        获取属性snapToTicks的值。
        Property description:
        指示Slider的Slider应始终与刻度线对齐。 即使没有显示刻度线，也是如此。

      • snapToTicksProperty

        public final BooleanProperty snapToTicksProperty​()
        指示Slider的Slider应始终与刻度线对齐。 即使没有显示刻度线，也是如此。
        另请参见：
        isSnapToTicks() ， setSnapToTicks(boolean)

      • setLabelFormatter

        public final void setLabelFormatter​(StringConverter<Double> value)
        设置属性labelFormatter的值。
        Property description:
        用于格式化主要刻度的标签的功能。 表示主要刻度的数字将被传递给该功能。 如果未指定此功能，则Skin实现将使用默认功能。

      • getLabelFormatter

        public final StringConverter<Double> getLabelFormatter​()
        获取属性labelFormatter的值。
        Property description:
        用于格式化主要刻度的标签的功能。 表示主要刻度的数字将被传递给该功能。 如果未指定此功能，则Skin实现将使用默认功能。

      • labelFormatterProperty

        public final ObjectProperty<StringConverter<Double>> labelFormatterProperty​()
        用于格式化主要刻度的标签的功能。 表示主要刻度的数字将被传递给该功能。 如果未指定此功能，则Skin实现将使用默认功能。
        另请参见：
        getLabelFormatter() ， setLabelFormatter(StringConverter)

      • setBlockIncrement

        public final void setBlockIncrement​(double value)
        设置属性blockIncrement的值。
        Property description:
        如果点击滑块的轨道，则调整滑块的量。 当使用键操作滑块位置时使用。 如果snapToTicks为真，那么将使用最接近调整值的刻度标记。

      • getBlockIncrement

        public final double getBlockIncrement​()
        获取属性blockIncrement的值。
        Property description:
        如果点击滑块的轨道，则调整滑块的量。 当使用键操作滑块位置时使用。 如果snapToTicks为真，那么将使用最接近调整值的刻度标记。

      • blockIncrementProperty

        public final DoubleProperty blockIncrementProperty​()
        如果点击滑块的轨道，则调整滑块的量。 当使用键操作滑块位置时使用。 如果snapToTicks为真，那么将使用最接近调整值的刻度标记。
        另请参见：
        getBlockIncrement() ， setBlockIncrement(double)

      • adjustValue

        public void adjustValue​(double newValue)
        调整value匹配newValue 。 value是min和max之间的实际数额。 这个功能也考虑到了snapToTicks ，这是adjustValue和setValue之间的主要区别。 它还确保该值是最小和最大值之间的一些有效数字。 注意：此功能主要由专家使用，主要由实施新皮肤或行为的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        newValue - 新调整值

      • increment

        public void increment​()
        将值增加blockIncrement ，以最大值 如果max小于或等于min，则此方法不执行任何操作。

      • decrement

        public void decrement​()
        将值减少blockIncrement ，以最大值为单位。 如果max小于或等于min，则此方法不执行任何操作。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则会调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        protected List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute中的 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SortEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SortEvent<C>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.SortEvent<C>
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class SortEvent<C>
extends Event
    事件涉及TableView和TreeTableView排序。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<SortEvent> ANY
      所有排序事件类型的常用超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      SortEvent​(C source, EventTarget target)

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      C getSource​()
      事件最初发生的对象。
      static <C> EventType<SortEvent<C>> | sortEvent​()

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<SortEvent> ANY
        所有排序事件类型的常用超类型。

    • 构造方法详细信息

      • SortEvent

        public SortEvent​(C source,
                 EventTarget target)

    • 方法详细信息

      • sortEvent

        public static <C> EventType<SortEvent<C>> sortEvent​()

      • getSource

        public C getSource​()
        描述从类别复制： EventObject
        事件最初发生的对象。
        重写：
        getSource在 EventObject
        结果
        事件最初发生的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Spinner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Spinner<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Spinner<T>
  • 参数类型
    T - Spinner中可以重复遍历的所有值的类型。 通用类型包括整数和字符串。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class Spinner<T>
extends Control
    单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。 旋转器通常提供一对微小的箭头按钮，用于逐步穿过序列的元素。 键盘上/下箭头键也循环遍历元素。 也可以允许用户在旋转器中直接输入（合法）值。 尽管组合框提供了类似的功能，但是有时候优选旋转器，因为它们不需要可以掩盖重要数据的下拉列表，也因为它们允许诸如wrapping和更简单的“无限”数据模型（ SpinnerValueFactory ，而不是像许多其他JavaFX UI控件一样使用ObservableList数据模型。

    微调器的序列值由其SpinnerValueFactory定义。 值工厂可以指定为构造函数参数，并用value factory property进行更改。 JavaFX提供了一些常见类型的SpinnerValueFactory类，其中包括：

    • SpinnerValueFactory.IntegerSpinnerValueFactory
    • SpinnerValueFactory.DoubleSpinnerValueFactory
    • SpinnerValueFactory.ListSpinnerValueFactory

    Spinner有一个TextField子组件，负责显示和潜在地更改Spinner的当前value ，这被称为editor 。 默认情况下，Spinner不可编辑，但如果editable property设置为true，则可以接受输入。 通过监听价值工厂的value property的更改，Spinner编辑器与值工厂保持同步。 如果用户已更改编辑器中显示的值，则Spinner value可能与编辑器不同。 为了确保模型与编辑器具有相同的值，用户必须使用Enter键提交编辑。

    从以下版本开始：
    JavaFX 8u40
    另请参见：
    SpinnerValueFactory

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty editable
      可编辑属性用于指定用户输入是否能够输入到Spinner editor中 。
      ReadOnlyObjectProperty<TextField> editor
      Spinner控件使用的编辑器。
      StringProperty promptText
      在 Spinner显示的提示文本，如果没有显示提示文本，则显示 null 。
      ObjectProperty<SpinnerValueFactory<T>> valueFactory
      价值工厂是JavaFX Spinner控件背后的模型 - 没有工厂安装的Spinner不可用的值。
      ReadOnlyObjectProperty<T> value
      Spinner上的value属性是只读属性，因为它与SpinnerValueFactory value property绑定。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String STYLE_CLASS_ARROWS_ON_LEFT_HORIZONTAL
      箭头放置在Spinner的左侧，水平（即左右）指向。
      static String STYLE_CLASS_ARROWS_ON_LEFT_VERTICAL
      箭头放置在旋钮的左侧，垂直指向（即上下）。
      static String STYLE_CLASS_ARROWS_ON_RIGHT_HORIZONTAL
      箭头放置在Spinner的右侧，水平（即左右）指向。
      static String STYLE_CLASS_SPLIT_ARROWS_HORIZONTAL
      减量箭头位于微调器的左侧，右侧的增量。
      static String STYLE_CLASS_SPLIT_ARROWS_VERTICAL
      将箭头放置在旋转器的上方和下方，拉伸以占据整个宽度。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Spinner​()
      构造一个默认的Spinner实例，使用默认的“spinner”样式类和不可编辑的编辑器。
      Spinner​(double min, double max, double initialValue)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。
      Spinner​(double min, double max, double initialValue, double amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。
      Spinner​(int min, int max, int initialValue)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。
      Spinner​(int min, int max, int initialValue, int amountToStepBy)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。
      Spinner​(ObservableList<T> items)
      创建一个微调实例与value factory设置为实例SpinnerValueFactory.ListSpinnerValueFactory 。
      Spinner​(SpinnerValueFactory<T> valueFactory)
      使用给定值出厂设置创建一个Spinner实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      如果微调器是 editable ，则调用此方法将尝试将编辑器文本替换为最后提交的 value 。
      void commitValue​()
      如果微调器是 editable ，调用此方法将尝试提交当前文本并将其转换为 value 。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void decrement​()
      尝试将 value factory递减一步，通过调用参数为1的 SpinnerValueFactory.decrement(int)方法。
      void decrement​(int steps)
      尝试通过调用 SpinnerValueFactory.decrement(int)方法并转发步骤参数来减少 value factory的给定数量的步骤。
      BooleanProperty editableProperty​()
      可编辑属性用于指定用户输入是否能够输入到Spinner editor中 。
      ReadOnlyObjectProperty<TextField> editorProperty​()
      Spinner控件使用的编辑器。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      TextField getEditor​()
      获取属性编辑器的值。
      String getPromptText​()
      获取属性promptText的值。
      T getValue​()
      获取属性值的值。
      SpinnerValueFactory<T> getValueFactory​()
      获取属性valueFactory的值。
      void increment​()
      尝试通过调用 270699635783888方法一个参数来递增 value factory 。
      void increment​(int steps)
      尝试通过调用 SpinnerValueFactory.increment(int)方法并转发步骤参数来增加 value factory的给定数量的步骤。
      boolean isEditable​()
      获取可编辑属性的值。
      StringProperty promptTextProperty​()
      在 Spinner显示的提示文本，如果没有显示提示文本，则显示 null 。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setEditable​(boolean value)
      设置属性可编辑的值。
      void setPromptText​(String value)
      设置属性promptText的值。
      void setValueFactory​(SpinnerValueFactory<T> value)
      设置属性valueFactory的值。
      ObjectProperty<SpinnerValueFactory<T>> valueFactoryProperty​()
      价值工厂是JavaFX Spinner控件背后的模型 - 没有工厂安装的Spinner不可用的值。
      ReadOnlyObjectProperty<T> valueProperty​()
      Spinner上的value属性是只读属性，因为它与SpinnerValueFactory value property绑定。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • value

        public final ReadOnlyObjectProperty<T> valueProperty
        Spinner上的value属性是只读属性，因为它与SpinnerValueFactory value property绑定。 如果value factory发生变化，此值属性将与旧值工厂绑定并绑定到新值。

        如果开发人员希望修改value属性，他们可以使用以下形式的代码：

           Object newValue = ...; spinner.getValueFactory().setValue(newValue);
        另请参见：
        getValue()

      • valueFactory

        public final ObjectProperty<SpinnerValueFactory<T>> valueFactoryProperty
        价值工厂是JavaFX Spinner控件背后的模型 - 没有工厂安装的Spinner不可用的值。 价值工厂处理Spinner几乎所有方面的作用，包括：
        • 代表目前的状态value ，
        • Incrementing和decrementing的值，每个呼叫具有一个或多个步骤，
        • Converting来自用户的文本输入（通过Spinner editor ，
        • 转换objects to user-readable strings显示在屏幕上
        另请参见：
        getValueFactory() ， setValueFactory(SpinnerValueFactory)

      • editable

        public final BooleanProperty editableProperty
        可编辑属性用于指定用户输入是否能够输入到Spinner editor中 。 如果可编辑为真，用户输入后将按照Enter键的方式接收用户输入。 此时，输入将传递给SpinnerValueFactory converter StringConverter.fromString(String)方法。 来自此呼叫（类型T）的返回值然后发送到SpinnerValueFactory.setValue(Object)方法。 如果值有效，它将保持为该值。 如果它是无效的，工厂将需要做出相应的反应并退出这个改变。
        另请参见：
        isEditable() ， setEditable(boolean)

      • editor

        public final ReadOnlyObjectProperty<TextField> editorProperty
        Spinner控件使用的编辑器。
        另请参见：
        getEditor()

      • promptText

        public final StringProperty promptTextProperty
        在 Spinner显示提示文本，如果没有显示提示文本，则显示 null 。
        从以下版本开始：
        9
        另请参见：
        getPromptText() ， setPromptText(String)

    • 字段详细信息

      • STYLE_CLASS_ARROWS_ON_RIGHT_HORIZONTAL

        public static final String STYLE_CLASS_ARROWS_ON_RIGHT_HORIZONTAL
        箭头放置在Spinner的右侧，水平（即左右）指向。
        另请参见：
        Constant Field Values

      • STYLE_CLASS_ARROWS_ON_LEFT_VERTICAL

        public static final String STYLE_CLASS_ARROWS_ON_LEFT_VERTICAL
        箭头放置在旋钮的左侧，垂直指向（即上下）。
        另请参见：
        Constant Field Values

      • STYLE_CLASS_ARROWS_ON_LEFT_HORIZONTAL

        public static final String STYLE_CLASS_ARROWS_ON_LEFT_HORIZONTAL
        箭头放置在Spinner的左侧，水平（即左右）指向。
        另请参见：
        Constant Field Values

      • STYLE_CLASS_SPLIT_ARROWS_VERTICAL

        public static final String STYLE_CLASS_SPLIT_ARROWS_VERTICAL
        将箭头放置在旋转器的上方和下方，拉伸以占据整个宽度。
        另请参见：
        Constant Field Values

      • STYLE_CLASS_SPLIT_ARROWS_HORIZONTAL

        public static final String STYLE_CLASS_SPLIT_ARROWS_HORIZONTAL
        减量箭头位于微调器的左侧，右侧的增量。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Spinner

        public Spinner​()
        构造一个默认的Spinner实例，使用默认的“spinner”样式类和不可编辑的编辑器。

      • Spinner

        public Spinner​(int min,
               int max,
               int initialValue)
        创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。 请注意，如果调用此构造函数，则Spinner实例的唯一有效通用类型为Integer，即Spinner <Integer>。
        参数
        min - Spinner的最小允许整数值。
        max - Spinner的最大允许整数值。
        initialValue - 当第一次实例化时，Spinner的值必须在min和max参数的范围内，否则将使用最小值。

      • Spinner

        public Spinner​(int min,
               int max,
               int initialValue,
               int amountToStepBy)
        创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。 请注意，如果调用此构造函数，则Spinner实例的唯一有效通用类型为Integer，即Spinner <Integer>。
        参数
        min - Spinner的最小允许整数值。
        max - Spinner允许的最大整数值。
        initialValue - 第一次实例化时，Spinner的值必须在min和max参数的范围内，否则将使用最小值。
        amountToStepBy - 每步骤增加或减少的量。

      • Spinner

        public Spinner​(double min,
               double max,
               double initialValue)
        创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。 请注意，如果调用此构造函数，则Spinner实例的唯一有效通用类型为Double，即Spinner <Double>。
        参数
        min - Spinner的最小允许双倍值。
        max - Spinner的最大允许双倍值。
        initialValue - 第一次实例化时，微调器的值必须在min和max参数的范围内，否则将使用最小值。

      • Spinner

        public Spinner​(double min,
               double max,
               double initialValue,
               double amountToStepBy)
        创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。 请注意，如果调用此构造函数，则Spinner实例的唯一有效通用类型为Double，即Spinner <Double>。
        参数
        min - Spinner的最小允许双倍值。
        max - Spinner的最大允许双倍值。
        initialValue - 当第一次实例化时，Spinner的值必须在min和max参数的范围内，否则将使用最小值。
        amountToStepBy - 每步骤增加或减少的量。

      • Spinner

        public Spinner​(ObservableList<T> items)
        创建一个微调实例与value factory设置为实例SpinnerValueFactory.ListSpinnerValueFactory 。 如果元素存在，则微调器value property将被设置为列表的第一个元素，否则为空。
        参数
        items - 将在Spinner中通过的项目列表。

      • Spinner

        public Spinner​(SpinnerValueFactory<T> valueFactory)
        使用给定值出厂设置创建一个Spinner实例。
        参数
        valueFactory - 要使用的 value factory 。

    • 方法详细信息

      • increment

        public void increment​()
        试图递增value factory一步，通过调用SpinnerValueFactory.increment(int)方法与一种的参数。 如果值factory为null，则抛出IllegalStateException。
        异常
        IllegalStateException - 如果通过调用 getValueFactory()返回的值工厂为null。

      • increment

        public void increment​(int steps)
        通过调用SpinnerValueFactory.increment(int)方法并转发步骤参数，尝试将给定的步数增加value factory 。 如果值factory为null，则抛出IllegalStateException。
        参数
        steps - 应该对该值执行的增量数。
        异常
        IllegalStateException - 如果通过调用 getValueFactory()返回的值为null。

      • decrement

        public void decrement​()
        尝试将value factory递减一步，通过调用参数为1的2706996377171方法。 如果值factory为null，则抛出IllegalStateException。
        异常
        IllegalStateException - 如果通过调用 getValueFactory()返回的值工厂为null。

      • decrement

        public void decrement​(int steps)
        尝试通过调用SpinnerValueFactory.decrement(int)方法并转发步骤参数来减少value factory的给定数量的步骤。 如果值factory为null，则抛出IllegalStateException。
        参数
        steps - 应该对该值执行的减量的数量。
        异常
        IllegalStateException - 如果通过调用 getValueFactory()返回的值为null。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则会调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • commitValue

        public final void commitValue​()
        如果微调器是 editable ，调用此方法将尝试提交当前文本并将其转换为 value 。
        从以下版本开始：
        9

      • cancelEdit

        public final void cancelEdit​()
        如果微调器是 editable ，调用此方法将尝试用最后提交的 value替换编辑器文本。
        从以下版本开始：
        9

      • getValue

        public final T getValue​()
        获取属性值的值。
        Property description:
        Spinner上的value属性是只读属性，因为它绑定到SpinnerValueFactory value property 。 如果value factory发生变化，此值属性将与旧值工厂绑定并绑定到新值。

        如果开发人员希望修改value属性，他们可以使用以下形式的代码：

           Object newValue = ...; spinner.getValueFactory().setValue(newValue);

      • valueProperty

        public final ReadOnlyObjectProperty<T> valueProperty​()
        Spinner上的value属性是只读属性，因为它绑定到SpinnerValueFactory value property 。 如果value factory发生变化，此值属性将与旧值工厂绑定并绑定到新值。

        如果开发人员希望修改value属性，他们可以使用以下形式的代码：

           Object newValue = ...; spinner.getValueFactory().setValue(newValue);
        另请参见：
        getValue()

      • setValueFactory

        public final void setValueFactory​(SpinnerValueFactory<T> value)
        设置属性valueFactory的值。
        Property description:
        价值工厂是JavaFX Spinner控件背后的模型 - 没有工厂安装的Spinner不可用的值。 价值工厂处理Spinner几乎所有方面的作用，包括：
        • 代表目前的状态value ，
        • Incrementing和decrementing的值，每个呼叫具有一个或多个步骤，
        • Converting来自用户的文本输入（通过Spinner editor ，
        • 转换objects to user-readable strings在屏幕上显示

      • getValueFactory

        public final SpinnerValueFactory<T> getValueFactory​()
        获取属性valueFactory的值。
        Property description:
        价值工厂是JavaFX Spinner控件背后的模型 - 没有工厂安装的Spinner不可用的值。 价值工厂处理Spinner几乎所有方面的作用，包括：
        • 代表目前的状态value ，
        • Incrementing和decrementing的值，每个呼叫一个或多个步骤，
        • Converting来自用户的文本输入（通过Spinner editor ，
        • 转换objects to user-readable strings进行屏幕显示

      • valueFactoryProperty

        public final ObjectProperty<SpinnerValueFactory<T>> valueFactoryProperty​()
        价值工厂是JavaFX Spinner控件背后的模型 - 没有工厂安装的Spinner不可用的值。 价值工厂处理Spinner几乎所有方面的作用，包括：
        • 代表当前状态的value ，
        • Incrementing和decrementing的值，每个呼叫有一个或多个步骤，
        • Converting来自用户的文本输入（通过Spinner editor ，
        • 转换objects to user-readable strings显示在屏幕上
        另请参见：
        getValueFactory() ， setValueFactory(SpinnerValueFactory)

      • setEditable

        public final void setEditable​(boolean value)
        设置属性可编辑的值。
        Property description:
        可编辑属性用于指定用户输入是否能够输入到Spinner editor中 。 如果可编辑为真，用户输入后将按照Enter键的方式接收用户输入。 此时，输入将传递给SpinnerValueFactory converter StringConverter.fromString(String)方法。 来自此呼叫（类型T）的返回值然后发送到SpinnerValueFactory.setValue(Object)方法。 如果值有效，它将保持为该值。 如果它是无效的，工厂将需要做出相应的反应并退出这个改变。

      • isEditable

        public final boolean isEditable​()
        获取可编辑属性的值。
        Property description:
        可编辑属性用于指定用户输入是否能够输入到Spinner editor中 。 如果可编辑为真，用户输入后将按照Enter键的方式接收用户输入。 此时，输入将传递给SpinnerValueFactory converter StringConverter.fromString(String)方法。 来自此呼叫（类型T）的返回值然后发送到SpinnerValueFactory.setValue(Object)方法。 如果值有效，它将保持为该值。 如果它是无效的，工厂将需要做出相应的反应并退出这个改变。

      • editableProperty

        public final BooleanProperty editableProperty​()
        可编辑属性用于指定用户输入是否能够输入到Spinner editor中 。 如果可编辑为真，用户输入后将按照Enter键的方式接收用户输入。 此时，输入将传递给SpinnerValueFactory converter StringConverter.fromString(String)方法。 来自此呼叫（类型T）的返回值然后发送到SpinnerValueFactory.setValue(Object)方法。 如果值有效，它将保持为该值。 如果它是无效的，工厂将需要做出相应的反应并退出这个改变。
        另请参见：
        isEditable() ， setEditable(boolean)

      • editorProperty

        public final ReadOnlyObjectProperty<TextField> editorProperty​()
        Spinner控件使用的编辑器。
        另请参见：
        getEditor()

      • getEditor

        public final TextField getEditor​()
        获取属性编辑器的值。
        Property description:
        Spinner控件使用的编辑器。

      • promptTextProperty

        public final StringProperty promptTextProperty​()
        在 Spinner显示的提示文本，如果没有显示提示文本，则显示 null 。
        从以下版本开始：
        9
        另请参见：
        getPromptText() ， setPromptText(String)

      • getPromptText

        public final String getPromptText​()
        获取属性promptText的值。
        Property description:
        在 Spinner显示的提示文本，如果没有显示提示文本，则显示 null 。
        从以下版本开始：
        9

      • setPromptText

        public final void setPromptText​(String value)
        设置属性promptText的值。
        Property description:
        在 Spinner显示的提示文本，如果没有显示提示文本，则显示 null 。
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


SpinnerValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SpinnerValueFactory<T>

  • java.lang.Object
    • javafx.scene.control.SpinnerValueFactory<T>
  • 参数类型
    T - 该值工厂处理的数据类型，必须与值工厂设置的微调器的类型一致。
    已知直接子类：
    SpinnerValueFactory.DoubleSpinnerValueFactory ， SpinnerValueFactory.IntegerSpinnerValueFactory ， SpinnerValueFactory.ListSpinnerValueFactory

    public abstract class SpinnerValueFactory<T>
extends Object
    SpinnerValueFactory是JavaFX Spinner control后面的模型 - 没有值出厂安装的Spinner不可用。 价值工厂处理Spinner几乎所有方面的作用，包括：
    • 代表目前的状态value ，
    • Incrementing和decrementing的值，每个呼叫一个或多个步骤，
    • Converting来自用户的文本输入（通过Spinner editor ，
    • 转换objects to user-readable strings进行屏幕显示

    JavaFX提供了一些常见类型的SpinnerValueFactory类，其中包括：

    • SpinnerValueFactory.IntegerSpinnerValueFactory
    • SpinnerValueFactory.DoubleSpinnerValueFactory
    • SpinnerValueFactory.ListSpinnerValueFactory
    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Spinner ， SpinnerValueFactory.IntegerSpinnerValueFactory ， SpinnerValueFactory.DoubleSpinnerValueFactory ， SpinnerValueFactory.ListSpinnerValueFactory

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      将用户输入的输入（当Spinner为 editable ）转换为T型对象时，可以通过 value属性检索输入。
      ObjectProperty<T> value
      表示SpinnerValueFactory的当前值，如果未设置值，则为null。
      BooleanProperty wrapAround
      wrapAround属性用于指定值factory是圆形的。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  SpinnerValueFactory.DoubleSpinnerValueFactory
      A SpinnerValueFactory实现旨在迭代双重值。
      static class  SpinnerValueFactory.IntegerSpinnerValueFactory
      A SpinnerValueFactory旨在迭代整数值的实现。
      static class  SpinnerValueFactory.ListSpinnerValueFactory<T>
      一个SpinnerValueFactory实现，旨在迭代一个值列表。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SpinnerValueFactory​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<T>> converterProperty​()
      将用户键入的输入（当微调器为 editable ）转换为类型T的对象时，以便可以通过 value属性检索输入。
      abstract void decrement​(int steps)
      尝试按照给定的步数减少 value 。
      StringConverter<T> getConverter​()
      获取属性转换器的值。
      T getValue​()
      获取属性值的值。
      abstract void increment​(int steps)
      试图通过给定的步数来弥补 value 。
      boolean isWrapAround​()
      获取属性wrapAround的值。
      void setConverter​(StringConverter<T> newValue)
      设置属性转换器的值。
      void setValue​(T newValue)
      设置属性值的值。
      void setWrapAround​(boolean value)
      设置属性wrapAround的值。
      ObjectProperty<T> valueProperty​()
      表示SpinnerValueFactory的当前值，如果未设置值，则为null。
      BooleanProperty wrapAroundProperty​()
      wrapAround属性用于指定值factory是圆形的。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • value

        public final ObjectProperty<T> valueProperty
        表示SpinnerValueFactory的当前值，如果未设置值，则为null。
        另请参见：
        getValue() ， setValue(T)

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        将用户输入的输入（当Spinner为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。
        另请参见：
        getConverter() ， setConverter(StringConverter)

      • wrapAround

        public final BooleanProperty wrapAroundProperty
        wrapAround属性用于指定值factory是圆形的。 例如，如果基于整数的值模型从最大值增加到最小值（反之亦然）。
        另请参见：
        isWrapAround() ， setWrapAround(boolean)

    • 构造方法详细信息

      • SpinnerValueFactory

        public SpinnerValueFactory​()

    • 方法详细信息

      • decrement

        public abstract void decrement​(int steps)
        尝试按照给定的步数减少 value 。
        参数
        steps - 应该对该值执行的减量的数量。

      • increment

        public abstract void increment​(int steps)
        试图通过给定的步数来剔除 value 。
        参数
        steps - 应该对值执行的增量数。

      • getValue

        public final T getValue​()
        获取属性值的值。
        Property description:
        表示SpinnerValueFactory的当前值，如果未设置值，则为null。

      • setValue

        public final void setValue​(T newValue)
        设置属性值的值。
        Property description:
        表示SpinnerValueFactory的当前值，如果未设置值，则为null。

      • valueProperty

        public final ObjectProperty<T> valueProperty​()
        表示SpinnerValueFactory的当前值，如果未设置值，则为null。
        另请参见：
        getValue() ， setValue(T)

      • getConverter

        public final StringConverter<T> getConverter​()
        获取属性转换器的值。
        Property description:
        将用户输入的输入（当微调器为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。

      • setConverter

        public final void setConverter​(StringConverter<T> newValue)
        设置属性转换器的值。
        Property description:
        将用户键入的输入（当微调器为 editable ）转换为类型T的对象时，以便可以通过 value属性检索输入。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        将用户输入的输入（当微调器为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。
        另请参见：
        getConverter() ， setConverter(StringConverter)

      • setWrapAround

        public final void setWrapAround​(boolean value)
        设置属性wrapAround的值。
        Property description:
        wrapAround属性用于指定值factory是圆形的。 例如，如果基于整数的值模型从最大值增加到最小值（反之亦然）。

      • isWrapAround

        public final boolean isWrapAround​()
        获取属性wrapAround的值。
        Property description:
        wrapAround属性用于指定值factory是圆形的。 例如，如果基于整数的值模型从最大值增加到最小值（反之亦然）。

      • wrapAroundProperty

        public final BooleanProperty wrapAroundProperty​()
        wrapAround属性用于指定值factory是圆形的。 例如，如果基于整数的值模型从最大值增加到最小值（反之亦然）。
        另请参见：
        isWrapAround() ， setWrapAround(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SpinnerValueFactory.DoubleSpinnerValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SpinnerValueFactory.DoubleSpinnerValueFactory

  • java.lang.Object
    • javafx.scene.control.SpinnerValueFactory<Double>
      • javafx.scene.control.SpinnerValueFactory.DoubleSpinnerValueFactory
  • Enclosing class:
    SpinnerValueFactory < T >

    public static class SpinnerValueFactory.DoubleSpinnerValueFactory
extends SpinnerValueFactory<Double>
    A SpinnerValueFactory实现，旨在迭代双重值。

    请注意，默认converter的实现方式简单如下，在许多情况下可能是足够的，但是对于用户来说，确保满足其需要（并在必要时进行调整）是很重要的。 要注意的一点是，这个StringConverter嵌入了一个DecimalFormat实例，显示了两到两位的小数位。 这用于toString和fromString方法：

      setConverter(new StringConverter<Double>() {
     private final DecimalFormat df = new DecimalFormat("#.##");

     @Override public String toString(Double value) {
         // If the specified value is null, return a zero-length String
         if (value == null) {
             return "";
         }

         return df.format(value);
     }

     @Override public Double fromString(String value) {
         try {
             // If the specified value is null or zero-length, return null
             if (value == null) {
                 return null;
             }

             value = value.trim();

             if (value.length() < 1) {
                 return null;
             }

             // Perform the requested parsing
             return df.parse(value).doubleValue();
         } catch (ParseException ex) {
             throw new RuntimeException(ex);
         }
     }
 });
    从以下版本开始：
    JavaFX 8u40

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty amountToStepBy
      设置每步增加或减少的量。
      DoubleProperty max
      设置该值工厂的最大允许值
      DoubleProperty min
      设置该值工厂的最小允许值

      • Properties inherited from class javafx.scene.control.SpinnerValueFactory

        converter, value, wrapAround

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.control.SpinnerValueFactory

        SpinnerValueFactory.DoubleSpinnerValueFactory, SpinnerValueFactory.IntegerSpinnerValueFactory, SpinnerValueFactory.ListSpinnerValueFactory<T>

    • 构造方法摘要

      构造方法
      Constructor 描述
      DoubleSpinnerValueFactory​(double min, double max)
      构造一个新的DoubleSpinnerValueFactory，将初始值设置为等于最小值，默认 amountToStepBy 。
      DoubleSpinnerValueFactory​(double min, double max, double initialValue)
      构造一个新的DoubleSpinnerValueFactory，默认 amountToStepBy 。
      DoubleSpinnerValueFactory​(double min, double max, double initialValue, double amountToStepBy)
      构造一个新的DoubleSpinnerValueFactory。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty amountToStepByProperty​()
      设置每步增加或减少的量。
      void decrement​(int steps)
      尝试按照给定的步数减少 value 。
      double getAmountToStepBy​()
      获取属性amountToStepBy的值。
      double getMax​()
      获取最大值的属性值。
      double getMin​()
      获取属性的值min。
      void increment​(int steps)
      试图通过给定的步数来剔除 value 。
      DoubleProperty maxProperty​()
      设置该值工厂的最大允许值
      DoubleProperty minProperty​()
      设置该值工厂的最小允许值
      void setAmountToStepBy​(double value)
      设置属性amountToStepBy的值。
      void setMax​(double value)
      设置属性max的值。
      void setMin​(double value)
      设置属性的值min。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SpinnerValueFactory

        converterProperty, getConverter, getValue, isWrapAround, setConverter, setValue, setWrapAround, valueProperty, wrapAroundProperty

    • Property Detail

      • min

        public final DoubleProperty minProperty
        设置该值工厂的最小允许值
        结果
        该值工厂的最小允许值

      • max

        public final DoubleProperty maxProperty
        设置该值工厂的最大允许值
        另请参见：
        getMax() ， setMax(double)

      • amountToStepBy

        public final DoubleProperty amountToStepByProperty
        设置每步增加或减少的量。
        另请参见：
        getAmountToStepBy() ， setAmountToStepBy(double)

    • 构造方法详细信息

      • DoubleSpinnerValueFactory

        public DoubleSpinnerValueFactory​(double min,
                                 double max)
        构造一个新的DoubleSpinnerValueFactory，将初始值设置为等于最小值，默认 amountToStepBy 。
        参数
        min - Spinner的最小允许双重值。
        max - Spinner的最大允许双倍值。

      • DoubleSpinnerValueFactory

        public DoubleSpinnerValueFactory​(double min,
                                 double max,
                                 double initialValue)
        构造一个新的DoubleSpinnerValueFactory，默认 amountToStepBy 。
        参数
        min - Spinner的最小允许双倍值。
        max - Spinner允许的最大双重值。
        initialValue - 第一次实例化时，Spinner的值必须在min和max参数的范围内，否则将使用最小值。

      • DoubleSpinnerValueFactory

        public DoubleSpinnerValueFactory​(double min,
                                 double max,
                                 double initialValue,
                                 double amountToStepBy)
        构造一个新的DoubleSpinnerValueFactory。
        参数
        min - Spinner的最小允许双重值。
        max - Spinner的允许的最大双重值。
        initialValue - 第一次实例化时，微调器的值必须在min和max参数的范围内，否则将使用最小值。
        amountToStepBy - 每步骤增加或减少的量。

    • 方法详细信息

      • setMin

        public final void setMin​(double value)
        设置属性的值min。
        Property description:
        *属性* *

      • getMin

        public final double getMin​()
        获取属性的值min。
        Property description:
        *属性* *

      • minProperty

        public final DoubleProperty minProperty​()
        设置该值工厂的最小允许值
        结果
        该值工厂的最小允许值

      • setMax

        public final void setMax​(double value)
        设置属性max的值。
        Property description:
        设置该值工厂的最大允许值

      • getMax

        public final double getMax​()
        获取最大值的属性值。
        Property description:
        设置该值工厂的最大允许值

      • maxProperty

        public final DoubleProperty maxProperty​()
        设置该值工厂的最大允许值
        另请参见：
        getMax() ， setMax(double)

      • setAmountToStepBy

        public final void setAmountToStepBy​(double value)
        设置属性amountToStepBy的值。
        Property description:
        设置每步增加或减少的量。

      • getAmountToStepBy

        public final double getAmountToStepBy​()
        获取属性amountToStepBy的值。
        Property description:
        设置每步增加或减少的量。

      • amountToStepByProperty

        public final DoubleProperty amountToStepByProperty​()
        设置每步增加或减少的量。
        另请参见：
        getAmountToStepBy() ， setAmountToStepBy(double)

      • decrement

        public void decrement​(int steps)
        尝试按照给定的步数减少 value 。
        Specified by:
        decrement在 SpinnerValueFactory<Double>
        参数
        steps - 应该对该值执行的减量的数量。

      • increment

        public void increment​(int steps)
        试图通过给定的步数来弥补 value 。
        Specified by:
        increment在 SpinnerValueFactory<Double>
        参数
        steps - 应该对该值执行的增量数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SpinnerValueFactory.IntegerSpinnerValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SpinnerValueFactory.IntegerSpinnerValueFactory

  • java.lang.Object
    • javafx.scene.control.SpinnerValueFactory<Integer>
      • javafx.scene.control.SpinnerValueFactory.IntegerSpinnerValueFactory
  • Enclosing class:
    SpinnerValueFactory < T >

    public static class SpinnerValueFactory.IntegerSpinnerValueFactory
extends SpinnerValueFactory<Integer>
    一个SpinnerValueFactory实现，旨在迭代整数值。

    请注意，默认的converter实现为IntegerStringConverter实例。

    从以下版本开始：
    JavaFX 8u40

    • Property Summary

      Properties
      Type Property 描述
      IntegerProperty amountToStepBy
      设置每步增加或减少的量。
      IntegerProperty max
      设置该值工厂的最大允许值
      IntegerProperty min
      设置该值工厂的最小允许值

      • Properties inherited from class javafx.scene.control.SpinnerValueFactory

        converter, value, wrapAround

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.control.SpinnerValueFactory

        SpinnerValueFactory.DoubleSpinnerValueFactory, SpinnerValueFactory.IntegerSpinnerValueFactory, SpinnerValueFactory.ListSpinnerValueFactory<T>

    • 构造方法摘要

      构造方法
      Constructor 描述
      IntegerSpinnerValueFactory​(int min, int max)
      构造一个新的IntegerSpinnerValueFactory，将初始值设置为等于最小值，默认 amountToStepBy 。
      IntegerSpinnerValueFactory​(int min, int max, int initialValue)
      构造一个新的IntegerSpinnerValueFactory，默认 amountToStepBy 。
      IntegerSpinnerValueFactory​(int min, int max, int initialValue, int amountToStepBy)
      构造一个新的IntegerSpinnerValueFactory。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      IntegerProperty amountToStepByProperty​()
      设置每步增加或减少的量。
      void decrement​(int steps)
      尝试按照给定的步数减少 value 。
      int getAmountToStepBy​()
      获取属性amountToStepBy的值。
      int getMax​()
      获取最大值的属性值。
      int getMin​()
      获取属性的值min。
      void increment​(int steps)
      试图通过给定的步骤来弥补 value 。
      IntegerProperty maxProperty​()
      设置该值工厂的最大允许值
      IntegerProperty minProperty​()
      设置该值工厂的最小允许值
      void setAmountToStepBy​(int value)
      设置属性amountToStepBy的值。
      void setMax​(int value)
      设置属性max的值。
      void setMin​(int value)
      设置属性的值min。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SpinnerValueFactory

        converterProperty, getConverter, getValue, isWrapAround, setConverter, setValue, setWrapAround, valueProperty, wrapAroundProperty

    • Property Detail

      • min

        public final IntegerProperty minProperty
        设置该值工厂的最小允许值
        结果
        该值工厂的最小允许值

      • max

        public final IntegerProperty maxProperty
        设置该值工厂的最大允许值
        另请参见：
        getMax() ， setMax(int)

      • amountToStepBy

        public final IntegerProperty amountToStepByProperty
        设置每步增加或减少的量。
        另请参见：
        getAmountToStepBy() ， setAmountToStepBy(int)

    • 构造方法详细信息

      • IntegerSpinnerValueFactory

        public IntegerSpinnerValueFactory​(int min,
                                  int max)
        构造一个新的IntegerSpinnerValueFactory，将初始值设置为等于最小值，默认 amountToStepBy 。
        参数
        min - Spinner的最小允许整数值。
        max - Spinner允许的最大允许值。

      • IntegerSpinnerValueFactory

        public IntegerSpinnerValueFactory​(int min,
                                  int max,
                                  int initialValue)
        构造一个新的IntegerSpinnerValueFactory，默认 amountToStepBy 。
        参数
        min - Spinner的最小允许整数值。
        max - Spinner允许的最大整数值。
        initialValue - 当第一次实例化时，微调器的值必须在min和max参数的范围内，否则将使用最小值。

      • IntegerSpinnerValueFactory

        public IntegerSpinnerValueFactory​(int min,
                                  int max,
                                  int initialValue,
                                  int amountToStepBy)
        构造一个新的IntegerSpinnerValueFactory。
        参数
        min - Spinner的最小允许整数值。
        max - Spinner的最大允许整数值。
        initialValue - 当第一个实例化时，Spinner的值必须在min和max参数的范围之内，否则将使用最小值。
        amountToStepBy - 每步骤增加或减少的量。

    • 方法详细信息

      • setMin

        public final void setMin​(int value)
        设置属性的值min。
        Property description:
        *属性* *

      • getMin

        public final int getMin​()
        获取属性的值min。
        Property description:
        *属性* *

      • minProperty

        public final IntegerProperty minProperty​()
        设置该值工厂的最小允许值
        结果
        该值工厂的最小允许值

      • setMax

        public final void setMax​(int value)
        设置属性max的值。
        Property description:
        设置该值工厂的最大允许值

      • getMax

        public final int getMax​()
        获取最大值的属性值。
        Property description:
        设置该值工厂的最大允许值

      • maxProperty

        public final IntegerProperty maxProperty​()
        设置该值工厂的最大允许值
        另请参见：
        getMax() ， setMax(int)

      • setAmountToStepBy

        public final void setAmountToStepBy​(int value)
        设置属性amountToStepBy的值。
        Property description:
        设置每步增加或减少的量。

      • getAmountToStepBy

        public final int getAmountToStepBy​()
        获取属性amountToStepBy的值。
        Property description:
        设置每步增加或减少的量。

      • amountToStepByProperty

        public final IntegerProperty amountToStepByProperty​()
        设置每步增加或减少的量。
        另请参见：
        getAmountToStepBy() ， setAmountToStepBy(int)

      • decrement

        public void decrement​(int steps)
        尝试按照给定的步数减少 value 。
        Specified by:
        decrement在 SpinnerValueFactory<Integer>
        参数
        steps - 应该对该值执行的减量的数量。

      • increment

        public void increment​(int steps)
        试图通过给定的步数来剔除 value 。
        Specified by:
        increment在 SpinnerValueFactory<Integer>
        参数
        steps - 应对值执行的增量数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SpinnerValueFactory.ListSpinnerValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SpinnerValueFactory.ListSpinnerValueFactory<T>

  • java.lang.Object
    • javafx.scene.control.SpinnerValueFactory<T>
      • javafx.scene.control.SpinnerValueFactory.ListSpinnerValueFactory<T>
  • 参数类型
    T - T中元素的类型 。
    Enclosing class:
    SpinnerValueFactory < T >

    public static class SpinnerValueFactory.ListSpinnerValueFactory<T>
extends SpinnerValueFactory<T>
    一个SpinnerValueFactory实现，旨在迭代一个值列表。

    请注意，默认converter的实现方式简单如下，这在许多情况下可能是足够的，但是对于用户来说，确保满足其需要（并在必要时进行调整）是非常重要的：

      setConverter(new StringConverter<T>() {
     @Override public String toString(T value) {
         if (value == null) {
             return "";
         }
         return value.toString();
     }

     @Override public T fromString(String string) {
         return (T) string;
     }
 });
    从以下版本开始：
    JavaFX 8u40

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<ObservableList<T>> items
      ListView的底层数据模型。

      • Properties inherited from class javafx.scene.control.SpinnerValueFactory

        converter, value, wrapAround

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.control.SpinnerValueFactory

        SpinnerValueFactory.DoubleSpinnerValueFactory, SpinnerValueFactory.IntegerSpinnerValueFactory, SpinnerValueFactory.ListSpinnerValueFactory<T>

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListSpinnerValueFactory​(ObservableList<T> items)
      创建一个ListSpinnerValueFactory的新实例，其中给定的列表用作列表以逐步完成。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void decrement​(int steps)
      尝试按照给定的步数减少 value 。
      ObservableList<T> getItems​()
      返回一个ObservableList ，其中包含当前用户可以迭代的项目。
      void increment​(int steps)
      试图通过给定的步数来弥补 value 。
      ObjectProperty<ObservableList<T>> itemsProperty​()
      ListView的底层数据模型。
      void setItems​(ObservableList<T> value)
      设置ListSpinnerValueFactory的底层数据模型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SpinnerValueFactory

        converterProperty, getConverter, getValue, isWrapAround, setConverter, setValue, setWrapAround, valueProperty, wrapAroundProperty

    • Property Detail

      • items

        public final ObjectProperty<ObservableList<T>> itemsProperty
        ListView的底层数据模型。 请注意，它具有必须与ListView本身类型匹配的通用类型。
        结果
        项目清单

    • 构造方法详细信息

      • ListSpinnerValueFactory

        public ListSpinnerValueFactory​(ObservableList<T> items)
        创建一个ListSpinnerValueFactory的新实例，其中给定的列表用作列表以逐步完成。
        参数
        items - 使用 items步骤的项目列表。

    • 方法详细信息

      • setItems

        public final void setItems​(ObservableList<T> value)
        设置ListSpinnerValueFactory的底层数据模型。 请注意，它具有必须匹配Spinner本身类型的通用类型。
        参数
        value - 项目清单

      • getItems

        public final ObservableList<T> getItems​()
        返回一个ObservableList ，其中包含当前能够被用户迭代的项目。 如果先前已经调用了setItems(javafx.collections.ObservableList)，这可能为null，但默认情况下，它是一个空的ObservableList。
        结果
        包含要显示给用户的项目的ObservableList，如果项目以前设置为null，则为null。

      • itemsProperty

        public final ObjectProperty<ObservableList<T>> itemsProperty​()
        ListView的底层数据模型。 请注意，它具有必须与ListView本身类型匹配的通用类型。
        结果
        项目清单

      • decrement

        public void decrement​(int steps)
        尝试按照给定的步数减少 value 。
        Specified by:
        decrement在 SpinnerValueFactory<T>
        参数
        steps - 应该对该值执行的减量的数量。

      • increment

        public void increment​(int steps)
        试图通过给定的步数来弥补 value 。
        Specified by:
        increment在 SpinnerValueFactory<T>
        参数
        steps - 应该对该值执行的增量数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SplitMenuButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SplitMenuButton

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.ButtonBase
                • javafx.scene.control.MenuButton
                  • javafx.scene.control.SplitMenuButton
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class SplitMenuButton
extends MenuButton
    SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。 与MenuButton不同，SplitMenuButton分为两部分，“动作”区域和“菜单打开”区域。

    如果用户在操作区域中单击，SplitMenuButton将以类似于Button的方式起作用 ，触发与ButtonBase.onAction属性相关的任何内容。

    控件的菜单打开区域将显示一个菜单，如果点击。 当用户从菜单中选择一个项目时，它被执行。

    请注意，SplitMenuButton不会自动分配菜单中最后选择的任何内容，作为单击操作区域的操作。

    例：

      SplitMenuButton m = new SplitMenuButton();
 m.setText("Shutdown");
 m.getItems().addAll(new MenuItem("Logout"), new MenuItem("Sleep"));
 m.setOnAction(new EventHandler<ActionEvent>() {
     &#064;Override public void handle(ActionEvent e) {
         System.out.println("Shutdown");
     }
 });

    默认情况下，SplitMenuButton启用MnemonicParsing。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MenuItem ， Menu

    • Property Summary

      • Properties inherited from class javafx.scene.control.ButtonBase

        armed, onAction

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.control.MenuButton

        popupSide, showing

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.control.MenuButton

        ON_HIDDEN, ON_HIDING, ON_SHOWING, ON_SHOWN

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      SplitMenuButton​()
      创建一个新的空拆分菜单按钮。
      SplitMenuButton​(MenuItem... items)
      使用给定的菜单项列表创建一个新的拆分菜单按钮。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void fire​()
      按下按钮时调用动作。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class javafx.scene.control.ButtonBase

        arm, armedProperty, disarm, getOnAction, isArmed, onActionProperty, setOnAction

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.control.MenuButton

        getItems, getPopupSide, hide, isShowing, popupSideProperty, setPopupSide, show, showingProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • SplitMenuButton

        public SplitMenuButton​()
        创建一个新的空拆分菜单按钮。 使用Labeled.setText(String) ， Labeled.setGraphic(Node)和MenuButton.getItems()设置内容。

      • SplitMenuButton

        public SplitMenuButton​(MenuItem... items)
        使用给定的菜单项列表创建一个新的拆分菜单按钮。
        参数
        items - 此按钮菜单中显示的项目

    • 方法详细信息

      • fire

        public void fire​()
        按下按钮时调用动作。
        重写：
        fire在 MenuButton

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则会调用此控件创建皮肤。
        重写：
        createDefaultSkin在 MenuButton
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 MenuButton
        参数
        action - 要执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SplitPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SplitPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.SplitPane
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("items")
public class SplitPane
extends Control

    具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。

    Nodes可以水平放置在彼此旁边，或垂直堆叠。 这可以通过设置orientationProperty()来控制。

    SplitPane中的分隔符具有以下行为

    • 分隔线不能与另一个分隔线重叠
    • 分隔线不能与节点重叠。
    • 当达到节点的最小大小时，移动到左/顶的分隔线将停止。
    • 当达到节点的最大大小时，移动到右边/底部的分隔线将停止。

    在将它们添加到SplitPane之前，需要在布局容器中放置节点。 如果节点不在布局容器内，则分隔符的最大和最小位置将是内容的最大和最小大小。

    分频器的位置范围为0到1.0（含）。 位置为0会将分频器置于SplitPane的左上角/最上边缘加上节点的最小尺寸。 1.0的位置将分割器放在SplitPane的右下边缘，减去节点的最小尺寸。 分频器位置为0.5将分频器放置在SplitPane的中间。 将分频器位置设置为大于节点的最大大小位置将导致分频器设置在节点的最大大小位置。 将分频器位置设置为小于节点的最小尺寸位置将导致分频器设置在节点的最小尺寸位置。 因此， setDividerPosition(int, double)和setDividerPositions(double...)中设置的值可能与getDividerPositions()返回的值不同 。

    如果SplitPane中有两个以上的节点，并且分隔符位置被设置为使得分隔符不能适合节点，则分割器将被SplitPane自动调整。

    例如，我们有三个节点的大小和分隔位置

      Node 1: min 25 max 100
 Node 2: min 100 max 200
 Node 3: min 25 max 50
 divider 1: 0.40
 divider 2: 0.45

    结果将是节点1的大小将其pref尺寸和分频器1定位为0.40，节点2的大小将是其最小大小和分频器2位置将是最小大小的节点2加分频器1的位置，剩余的空间将给予节点3。

    SplitPane将focusTraversable设置为false。

    例：

       SplitPane sp = new SplitPane(); final StackPane sp1 = new StackPane(); sp1.getItems().add(new Button("Button One")); final StackPane sp2 = new StackPane(); sp2.getItems().add(new Button("Button Two")); final StackPane sp3 = new StackPane(); sp3.getItems().add(new Button("Button Three")); sp.getItems().addAll(sp1, sp2, sp3); sp.setDividerPositions(0.3f, 0.6f, 0.9f);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Orientation> orientation
      SplitPane的方向。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  SplitPane.Divider
      在SplitPane中代表一个分隔符。

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      SplitPane​()
      创建一个没有内容的新SplitPane。
      SplitPane​(Node... items)
      创建一个新的SplitPane，其中给定的项目设置为在一个或多个分频器之间分割的内容。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      double[] getDividerPositions​()
      返回一个包含每个分隔符位置的double数组。
      ObservableList<SplitPane.Divider> getDividers​()
      返回此SplitPane中所有分隔符的不可修改列表。
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      ObservableList<Node> getItems​()
      返回一个ObservableList，可用于修改SplitPane的内容。
      Orientation getOrientation​()
      SplitPane的方向。
      static Boolean isResizableWithParent​(Node node)
      如果父容器调整大小为false时，如果节点可调整大小，则返回true。
      ObjectProperty<Orientation> orientationProperty​()
      SplitPane的方向。
      void setDividerPosition​(int dividerIndex, double position)
      以指定的分频器指数设置分频器的位置。
      void setDividerPositions​(double... positions)
      设置分频器的位置
      void setOrientation​(Orientation value)
      此属性控制如何向用户显示SplitPane。
      static void setResizableWithParent​(Node node, Boolean value)
      在SplitPane调整大小时，将SplitPane中的节点设置为可调整大小。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • orientation

        public final ObjectProperty<Orientation> orientationProperty
        SplitPane的方向。
        结果
        SplitPane的orientation属性

    • 构造方法详细信息

      • SplitPane

        public SplitPane​()
        创建一个没有内容的新SplitPane。

      • SplitPane

        public SplitPane​(Node... items)
        创建一个新的SplitPane，其中给定的项目设置为在一个或多个分频器之间分割的内容。
        参数
        items - 要放置在SplitPane中的项目。
        从以下版本开始：
        JavaFX 8u40

    • 方法详细信息

      • setResizableWithParent

        public static void setResizableWithParent​(Node node,
                                          Boolean value)
        在SplitPane调整大小时，将SplitPane中的节点设置为可调整大小。 默认情况下所有节点都可调整大小。 将值设置为false将阻止节点调整大小。
        参数
        node - SplitPane中的一个节点。
        value - 如果节点可调整大小，则为true，如果不可调整大小则为false。
        从以下版本开始：
        JavaFX 2.1

      • isResizableWithParent

        public static Boolean isResizableWithParent​(Node node)
        如果父容器调整大小为false时，如果节点可调整大小，则返回true。
        Default value:
        真正
        参数
        node - SplitPane中的一个节点。
        结果
        如果节点可调整大小，则为true否则为false。
        从以下版本开始：
        JavaFX 2.1

      • setOrientation

        public final void setOrientation​(Orientation value)

        此属性控制如何向用户显示SplitPane。 Orientation.HORIZONTAL将导致两个（或多个）节点相互水平放置，而Orientation.VERTICAL将导致节点垂直堆叠。

        参数
        value - 取向值

      • getOrientation

        public final Orientation getOrientation​()
        SplitPane的方向。
        结果
        SplitPane的方向。

      • orientationProperty

        public final ObjectProperty<Orientation> orientationProperty​()
        SplitPane的方向。
        结果
        SplitPane的orientation属性

      • getItems

        public ObservableList<Node> getItems​()
        返回一个ObservableList，可用于修改SplitPane的内容。 节点放置到此列表中的顺序在SplitPane中将是相同的顺序。
        结果
        此SplitPane中的项目列表。

      • getDividers

        public ObservableList<SplitPane.Divider> getDividers​()
        返回此SplitPane中所有分隔符的不可修改列表。
        结果
        分隔线列表。

      • setDividerPosition

        public void setDividerPosition​(int dividerIndex,
                               double position)
        以指定的分频器指数设置分频器的位置。
        参数
        dividerIndex - 分频器的索引。
        position - 分频器位置，介于0.0和1.0之间（含）。

      • setDividerPositions

        public void setDividerPositions​(double... positions)
        设置分频器的位置
        参数
        positions - 分频器位置，介于0.0和1.0之间（含）。

      • getDividerPositions

        public double[] getDividerPositions​()
        返回一个包含每个分隔符位置的double数组。
        结果
        一个double数组，包含每个分频器的位置。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SplitPane.Divider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class SplitPane.Divider

  • java.lang.Object
    • javafx.scene.control.SplitPane.Divider
  • Enclosing class:
    SplitPane

    public static class SplitPane.Divider
extends Object
    在SplitPane中代表一个分隔符。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty position
      代表分隔符理想位置的位置，介于0.0和1.0（含）之间。 0.0表示最左侧或最上方，1.0表示右下角（取决于水平属性）。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Divider​()
      创建一个默认的Divider实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getPosition​()
      获取属性位置的值。
      DoubleProperty positionProperty​()
      代表分隔符理想位置的位置，介于0.0和1.0（含）之间。 0.0表示最左侧或最上方，1.0表示右下角（取决于水平属性）。
      void setPosition​(double value)
      设置属性位置的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • position

        public final DoubleProperty positionProperty

        代表分隔符理想位置的位置，介于0.0和1.0（含）之间。 0.0表示最左侧或最上方，1.0表示右下角（取决于水平属性）。 SplitPane将尝试将分隔符分配到所请求的点，但必须考虑其中包含的节点的最小宽度/高度。

        当用户拖动SplitPane分频器时，此属性将被更新以始终表示其当前位置。

        Default value:
        0.5
        另请参见：
        getPosition() ， setPosition(double)

    • 构造方法详细信息

      • Divider

        public Divider​()
        创建一个默认的Divider实例。

    • 方法详细信息

      • setPosition

        public final void setPosition​(double value)
        设置属性位置的值。
        Property description:

        代表分隔符理想位置的位置，介于0.0和1.0（含）之间。 0.0表示最左侧或最上方，1.0表示右下角（取决于水平属性）。 SplitPane将尝试将分隔符分配到所请求的点，但必须考虑其中包含的节点的最小宽度/高度。

        当用户拖动SplitPane分频器时，此属性将被更新以始终表示其当前位置。

        Default value:
        0.5

      • getPosition

        public final double getPosition​()
        获取属性位置的值。
        Property description:

        代表分隔符理想位置的位置，介于0.0和1.0（含）之间。 0.0表示最左侧或最上方，1.0表示右下角（取决于水平属性）。 SplitPane将尝试将分隔符分配到所请求的点，但必须考虑其中包含的节点的最小宽度/高度。

        当用户拖动SplitPane分频器时，此属性将被更新以始终表示其当前位置。

        Default value:
        0.5

      • positionProperty

        public final DoubleProperty positionProperty​()

        代表分隔符理想位置的位置，介于0.0和1.0（含）之间。 0.0表示最左侧或最上方，1.0表示右下角（取决于水平属性）。 SplitPane将尝试将分隔符分配到所请求的点，但必须考虑其中包含的节点的最小宽度/高度。

        当用户拖动SplitPane分频器时，此属性将被更新以始终表示其当前位置。

        Default value:
        0.5
        另请参见：
        getPosition() ， setPosition(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Tab (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Tab

  • java.lang.Object
    • javafx.scene.control.Tab
  • All Implemented Interfaces:
    Styleable ， EventTarget

    @DefaultProperty("content")
@IDProperty("id")
public class Tab
extends Object
implements EventTarget, Styleable

    标签放置在一个TabPane中 ，其中每个选项卡表示单个“页面”。

    标签可以包含任何Node ，如UI控件或添加到布局容器的节点组。

    当用户点击TabPane中的Tab时，Tab内容对用户可见。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty closable
      此选项卡的可关闭状态。
      ObjectProperty<Node> content
      与标签相关的内容。
      ObjectProperty<ContextMenu> contextMenu
      与选项卡关联的上下文菜单。
      ReadOnlyBooleanProperty disabled
      表示此 Tab是否被禁用。
      BooleanProperty disable
      设置此选项卡的禁用状态。
      ObjectProperty<Node> graphic
      选项卡中的图形。
      StringProperty id
      此选项卡的ID。
      ObjectProperty<EventHandler<Event>> onClosed
      当选项卡关闭时与选项卡关联的事件处理程序。
      ObjectProperty<EventHandler<Event>> onCloseRequest
      当有外部请求关闭此 Tab 。
      ObjectProperty<EventHandler<Event>> onSelectionChanged
      与选项卡上的选择相关联的事件处理程序。
      ReadOnlyBooleanProperty selected
      当前选中的选项卡。
      StringProperty style
      与此选项卡关联的CSS样式字符串。
      ReadOnlyObjectProperty<TabPane> tabPane
      包含此选项卡的TabPane。
      StringProperty text
      选项卡中显示的文本。
      ObjectProperty<Tooltip> tooltip
      与此选项卡关联的工具提示。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<Event> CLOSED_EVENT
      当用户关闭此选项卡时调用。
      static EventType<Event> SELECTION_CHANGED_EVENT
      当选项卡被选中或未选择时调用。
      static EventType<Event> TAB_CLOSE_REQUEST_EVENT
      当有外部请求关闭此 Tab 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Tab​()
      创建没有标题的选项卡。
      Tab​(String text)
      创建一个带有文本标题的选项卡。
      Tab​(String text, Node content)
      创建一个带有文本标题和指定内容节点的选项卡。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      BooleanProperty closableProperty​()
      此选项卡的可关闭状态。
      ObjectProperty<Node> contentProperty​()
      与标签相关的内容。
      ObjectProperty<ContextMenu> contextMenuProperty​()
      与选项卡关联的上下文菜单。
      ReadOnlyBooleanProperty disabledProperty​()
      表示此 Tab是否被禁用。
      BooleanProperty disableProperty​()
      设置此选项卡的禁用状态。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Node getContent​()
      与标签相关的内容。
      ContextMenu getContextMenu​()
      与选项卡关联的上下文菜单。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      这个样式的CssMetaData。
      Node getGraphic​()
      标签中显示的图形。
      String getId​()
      此选项卡的ID。
      EventHandler<Event> getOnClosed​()
      当选项卡关闭时与选项卡关联的事件处理程序。
      EventHandler<Event> getOnCloseRequest​()
      获取属性onCloseRequest的值。
      EventHandler<Event> getOnSelectionChanged​()
      与选项卡上的选择相关联的事件处理程序。
      ObservableMap<Object,Object> getProperties​()
      返回此选项卡上属性的可观察图，主要由应用程序开发人员使用。
      ObservableSet<PseudoClass> getPseudoClassStates​()
      返回此Styleable的伪类状态。
      String getStyle​()
      与此选项卡关联的CSS样式字符串。
      Styleable getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      ObservableList<String> getStyleClass​()
      可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。
      TabPane getTabPane​()
      对包含此选项卡实例的TabPane的引用。
      String getText​()
      选项卡中显示的文本。
      Tooltip getTooltip​()
      与此选项卡关联的工具提示。
      String getTypeSelector​()
      这种 Styleable的类型用于选择器匹配。
      Object getUserData​()
      返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
      ObjectProperty<Node> graphicProperty​()
      选项卡中的图形。
      boolean hasProperties​()
      测试此选项卡是否具有属性。
      StringProperty idProperty​()
      此选项卡的ID。
      boolean isClosable​()
      如果此选项卡是可关闭的，则返回 true 。
      boolean isDisable​()
      如果此选项卡禁用，则返回 true 。
      boolean isDisabled​()
      当返回true Tab disable设置为 true ，或者如果 TabPane被禁用。
      boolean isSelected​()
      表示此选项卡是否为当前选定的选项卡，要更改选定的选项卡，请使用 tabPane.getSelectionModel().select()
      ObjectProperty<EventHandler<Event>> onClosedProperty​()
      当选项卡关闭时与选项卡关联的事件处理程序。
      ObjectProperty<EventHandler<Event>> onCloseRequestProperty​()
      当有外部请求关闭此 Tab 。
      ObjectProperty<EventHandler<Event>> onSelectionChangedProperty​()
      与选项卡上的选择相关联的事件处理程序。
      ReadOnlyBooleanProperty selectedProperty​()
      当前选中的选项卡。
      void setClosable​(boolean value)
      如果选项卡可关闭，请设置 true 。
      void setContent​(Node value)
      内容显示在主TabPane区域内。
      void setContextMenu​(ContextMenu value)
      指定上下文菜单，以显示用户在选项卡上的右键单击。
      void setDisable​(boolean value)
      设置此选项卡的禁用状态。
      void setGraphic​(Node value)
      将图形设置为在标签中显示，以允许用户区分每个选项卡的功能。
      void setId​(String value)
      设置此选项卡的ID。
      void setOnClosed​(EventHandler<Event> value)
      定义标签关闭时要调用的函数。
      void setOnCloseRequest​(EventHandler<Event> value)
      设置属性onCloseRequest的值。
      void setOnSelectionChanged​(EventHandler<Event> value)
      定义在选项卡上发生选择更改时要调用的函数。
      void setStyle​(String value)
      与此选项卡相关联的CSS样式的字符串表示形式。
      void setText​(String value)
      将选项卡中显示的文本设置为允许用户区分每个选项卡的功能。
      void setTooltip​(Tooltip value)
      指定工具提示，以显示用户何时悬停在选项卡上。
      void setUserData​(Object value)
      用于设置可以在以后检索的单个Object属性的便利方法。
      StringProperty styleProperty​()
      与此选项卡关联的CSS样式字符串。
      ReadOnlyObjectProperty<TabPane> tabPaneProperty​()
      包含此选项卡的TabPane。
      StringProperty textProperty​()
      选项卡中显示的文本。
      ObjectProperty<Tooltip> tooltipProperty​()
      与此选项卡关联的工具提示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • id

        public final StringProperty idProperty
        此选项卡的ID。
        结果
        该标签的id属性

      • style

        public final StringProperty styleProperty
        与此选项卡关联的CSS样式字符串。
        另请参见：
        getStyle() ， setStyle(String)

      • selected

        public final ReadOnlyBooleanProperty selectedProperty
        当前选中的选项卡。
        另请参见：
        isSelected()

      • tabPane

        public final ReadOnlyObjectProperty<TabPane> tabPaneProperty
        包含此选项卡的TabPane。
        另请参见：
        getTabPane()

      • text

        public final StringProperty textProperty
        选项卡中显示的文本。
        另请参见：
        getText() ， setText(String)

      • graphic

        public final ObjectProperty<Node> graphicProperty
        选项卡中的图形。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • content

        public final ObjectProperty<Node> contentProperty

        与标签相关的内容。

        另请参见：
        getContent() ， setContent(Node)

      • contextMenu

        public final ObjectProperty<ContextMenu> contextMenuProperty
        与选项卡关联的上下文菜单。
        另请参见：
        getContextMenu() ， setContextMenu(ContextMenu)

      • closable

        public final BooleanProperty closableProperty
        此选项卡的可关闭状态。
        另请参见：
        isClosable() ， setClosable(boolean)

      • onSelectionChanged

        public final ObjectProperty<EventHandler<Event>> onSelectionChangedProperty
        与选项卡上的选择相关联的事件处理程序。
        另请参见：
        getOnSelectionChanged() ， setOnSelectionChanged(EventHandler)

      • onClosed

        public final ObjectProperty<EventHandler<Event>> onClosedProperty
        当选项卡关闭时与选项卡关联的事件处理程序。
        另请参见：
        getOnClosed() ， setOnClosed(EventHandler)

      • tooltip

        public final ObjectProperty<Tooltip> tooltipProperty
        与此选项卡关联的工具提示。
        另请参见：
        getTooltip() ， setTooltip(Tooltip)

      • disable

        public final BooleanProperty disableProperty
        设置此选项卡的禁用状态。 禁用选项卡不再是交互式或可遍历，但内容保持互动。 可以使用TabPane.getSelectionModel()选择禁用选项卡。
        Default value:
        假
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        isDisable() ， setDisable(boolean)

      • disabled

        public final ReadOnlyBooleanProperty disabledProperty
        指示此Tab是否被禁用。 一个Tab如果将被禁用disable设置为true上自行或如果TabPane被禁用。
        Default value:
        假
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        isDisabled()

      • onCloseRequest

        public final ObjectProperty<EventHandler<Event>> onCloseRequestProperty
        当有外部请求关闭此Tab 。 安装的事件处理程序可以通过消耗接收的事件来阻止标签关闭。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnCloseRequest() ， setOnCloseRequest(EventHandler)

    • 字段详细信息

      • SELECTION_CHANGED_EVENT

        public static final EventType<Event> SELECTION_CHANGED_EVENT

        当选项卡被选中或未选择时调用。

      • CLOSED_EVENT

        public static final EventType<Event> CLOSED_EVENT

        当用户关闭此选项卡时调用。 这对于释放内存很有用。

      • TAB_CLOSE_REQUEST_EVENT

        public static final EventType<Event> TAB_CLOSE_REQUEST_EVENT
        当有外部请求关闭此Tab 。 安装的事件处理程序可以通过消耗接收的事件来阻止标签关闭。
        从以下版本开始：
        JavaFX 8.0

    • 构造方法详细信息

      • Tab

        public Tab​()
        创建没有标题的选项卡。

      • Tab

        public Tab​(String text)
        创建一个带有文本标题的选项卡。
        参数
        text - 标签的标题。

      • Tab

        public Tab​(String text,
           Node content)
        创建一个带有文本标题和指定内容节点的选项卡。
        参数
        text - 标签的标题。
        content - 选项卡的内容。
        从以下版本开始：
        JavaFX 8u40

    • 方法详细信息

      • setId

        public final void setId​(String value)
        设置此选项卡的ID。 这个简单的字符串标识符可用于查找TabPane的特定标签。 默认值为null 。
        参数
        value - 此选项卡的ID

      • getId

        public final String getId​()
        此选项卡的ID。
        Specified by:
        getId在接口 Styleable
        结果
        标签的ID。

      • idProperty

        public final StringProperty idProperty​()
        此选项卡的ID。
        结果
        该标签的id属性

      • setStyle

        public final void setStyle​(String value)
        与此选项卡相关联的CSS样式的字符串表示形式。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。

        在某些有限的平台上可能不支持解析此样式。 建议使用独立的CSS文件。

        参数
        value - 风格字符串

      • getStyle

        public final String getStyle​()
        与此选项卡关联的CSS样式字符串。
        Specified by:
        getStyle在接口 Styleable
        结果
        与此选项卡关联的CSS样式字符串。

      • styleProperty

        public final StringProperty styleProperty​()
        与此选项卡关联的CSS样式字符串。
        另请参见：
        getStyle() ， setStyle(String)

      • isSelected

        public final boolean isSelected​()

        表示此选项卡是否为当前选定的选项卡，要更改选定的选项卡，请使用tabPane.getSelectionModel().select()

        结果
        如果选择则为真

      • selectedProperty

        public final ReadOnlyBooleanProperty selectedProperty​()
        当前选中的选项卡。
        另请参见：
        isSelected()

      • getTabPane

        public final TabPane getTabPane​()

        对包含此选项卡实例的TabPane的引用。

        结果
        TabPane

      • tabPaneProperty

        public final ReadOnlyObjectProperty<TabPane> tabPaneProperty​()
        包含此选项卡的TabPane。
        另请参见：
        getTabPane()

      • setText

        public final void setText​(String value)

        将选项卡中显示的文本设置为允许用户区分每个选项卡的功能。 文字始终可见

        参数
        value - 文本字符串

      • getText

        public final String getText​()
        选项卡中显示的文本。
        结果
        选项卡中显示的文本。

      • textProperty

        public final StringProperty textProperty​()
        选项卡中显示的文本。
        另请参见：
        getText() ， setText(String)

      • setGraphic

        public final void setGraphic​(Node value)

        将图形设置为在标签中显示，以允许用户区分每个选项卡的功能。 默认情况下，图形不会基于TabPane.tabPosition值进行旋转，但可以通过将TabPane.rotateGraphic设置为true来将其设置为旋转。

        参数
        value - 图形节点

      • getGraphic

        public final Node getGraphic​()
        标签中显示的图形。
        结果
        标签中显示的图形。

      • graphicProperty

        public final ObjectProperty<Node> graphicProperty​()
        选项卡中的图形。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • setContent

        public final void setContent​(Node value)

        内容显示在主TabPane区域内。 内容可以是任何节点，如UI控件或添加到布局容器的节点组。

        参数
        value - 内容节点

      • getContent

        public final Node getContent​()

        与标签相关的内容。

        结果
        与标签相关的内容。

      • contentProperty

        public final ObjectProperty<Node> contentProperty​()

        与标签相关的内容。

        另请参见：
        getContent() ， setContent(Node)

      • setContextMenu

        public final void setContextMenu​(ContextMenu value)

        指定上下文菜单，以显示用户在选项卡上的右键单击。

        参数
        value - 上下文菜单

      • getContextMenu

        public final ContextMenu getContextMenu​()
        与选项卡关联的上下文菜单。
        结果
        与选项卡关联的上下文菜单。

      • contextMenuProperty

        public final ObjectProperty<ContextMenu> contextMenuProperty​()
        与选项卡关联的上下文菜单。
        另请参见：
        getContextMenu() ， setContextMenu(ContextMenu)

      • setClosable

        public final void setClosable​(boolean value)

        如果选项卡是可关闭的，请设置true 。 如果设置为false ，则无论false如何，用户将无法关闭此选项卡。 因此，当此属性为false ，标签上不会显示“关闭”按钮。 默认值为true 。

        参数
        value - 可关闭的值

      • isClosable

        public final boolean isClosable​()
        如果此选项卡可关闭，则返回 true 。
        结果
        true如果选项卡是可关闭的。

      • closableProperty

        public final BooleanProperty closableProperty​()
        此选项卡的可关闭状态。
        另请参见：
        isClosable() ， setClosable(boolean)

      • setOnSelectionChanged

        public final void setOnSelectionChanged​(EventHandler<Event> value)
        定义在选项卡上发生选择更改时要调用的函数。
        参数
        value - 选择更改的事件处理程序

      • getOnSelectionChanged

        public final EventHandler<Event> getOnSelectionChanged​()
        与选项卡上的选择相关联的事件处理程序。
        结果
        与选项卡选择相关联的事件处理程序。

      • onSelectionChangedProperty

        public final ObjectProperty<EventHandler<Event>> onSelectionChangedProperty​()
        与选项卡上的选择相关联的事件处理程序。
        另请参见：
        getOnSelectionChanged() ， setOnSelectionChanged(EventHandler)

      • setOnClosed

        public final void setOnClosed​(EventHandler<Event> value)
        定义标签关闭时要调用的函数。
        参数
        value - 关闭事件处理程序

      • getOnClosed

        public final EventHandler<Event> getOnClosed​()
        当选项卡关闭时与选项卡关联的事件处理程序。
        结果
        当选项卡关闭时与选项卡关联的事件处理程序。

      • onClosedProperty

        public final ObjectProperty<EventHandler<Event>> onClosedProperty​()
        当选项卡关闭时与选项卡关联的事件处理程序。
        另请参见：
        getOnClosed() ， setOnClosed(EventHandler)

      • setTooltip

        public final void setTooltip​(Tooltip value)

        指定工具提示，以显示用户何时悬停在选项卡上。

        参数
        value - 刀尖值

      • getTooltip

        public final Tooltip getTooltip​()
        与此选项卡关联的工具提示。
        结果
        与此选项卡关联的工具提示。

      • tooltipProperty

        public final ObjectProperty<Tooltip> tooltipProperty​()
        与此选项卡关联的工具提示。
        另请参见：
        getTooltip() ， setTooltip(Tooltip)

      • setDisable

        public final void setDisable​(boolean value)
        设置此选项卡的禁用状态。
        Default value:
        假
        参数
        value - 设置此选项卡的状态
        从以下版本开始：
        JavaFX 2.2

      • isDisable

        public final boolean isDisable​()
        如果此选项卡 true禁用 true则返回 true 。
        结果
        如果此选项卡禁用，则为true
        从以下版本开始：
        JavaFX 2.2

      • disableProperty

        public final BooleanProperty disableProperty​()
        设置此选项卡的禁用状态。 禁用选项卡不再是交互式或可遍历，但内容保持互动。 可以使用TabPane.getSelectionModel()选择禁用选项卡。
        Default value:
        假
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        isDisable() ， setDisable(boolean)

      • isDisabled

        public final boolean isDisabled​()
        当返回true Tab disable设置为 true ，或者如果 TabPane被禁用。
        结果
        如果禁用TabPane，则为true
        从以下版本开始：
        JavaFX 2.2

      • disabledProperty

        public final ReadOnlyBooleanProperty disabledProperty​()
        表示此Tab是否被禁用。 一个Tab如果将被禁用disable设置为true上自行或如果TabPane被禁用。
        Default value:
        假
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        isDisabled()

      • onCloseRequestProperty

        public final ObjectProperty<EventHandler<Event>> onCloseRequestProperty​()
        当有外部请求关闭此Tab 。 安装的事件处理程序可以通过消耗接收的事件来阻止标签关闭。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnCloseRequest() ， setOnCloseRequest(EventHandler)

      • getOnCloseRequest

        public EventHandler<Event> getOnCloseRequest​()
        获取属性onCloseRequest的值。
        Property description:
        当有外部请求关闭此Tab 。 安装的事件处理程序可以通过消耗接收的事件来阻止标签关闭。
        从以下版本开始：
        JavaFX 8.0

      • setOnCloseRequest

        public void setOnCloseRequest​(EventHandler<Event> value)
        设置属性onCloseRequest的值。
        Property description:
        当有外部请求关闭这个Tab 。 安装的事件处理程序可以通过消耗接收的事件来阻止标签关闭。
        从以下版本开始：
        JavaFX 8.0

      • getProperties

        public final ObservableMap<Object,Object> getProperties​()
        返回此选项卡上属性的可观察图，主要由应用程序开发人员使用。
        结果
        该Tab上的属性的可观察地图主要由应用程序开发人员使用
        从以下版本开始：
        JavaFX 2.2

      • hasProperties

        public boolean hasProperties​()
        测试此选项卡是否具有属性。
        结果
        如果此选项卡具有属性，则为true
        从以下版本开始：
        JavaFX 2.2

      • setUserData

        public void setUserData​(Object value)
        用于设置可以在以后检索的单个Object属性的便利方法。 这在功能上等同于调用getProperties（）。put（Object key，Object value）方法。 这可以稍后通过调用getUserData()检索。
        参数
        value - 要存储的值 - 以后可以通过调用 getUserData()来检索。
        从以下版本开始：
        JavaFX 2.2

      • getUserData

        public Object getUserData​()
        返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
        结果
        先前设置的对象，如果没有设置属性或设置为null，则为null。
        从以下版本开始：
        JavaFX 2.2

      • getStyleClass

        public ObservableList<String> getStyleClass​()
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。 该变量类似于HTML元素上的“类”属性，因此列表的每个元素都是此节点所属的样式类。
        Specified by:
        getStyleClass在接口 Styleable
        结果
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎
        另请参见：
        CSS3 class selectors

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此目标构建事件调度链。 事件调度链包含可能对处理针对这个EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要为链接添加一个EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 建立起来的初始链
        结果
        此目标的结果事件调度链

      • getTypeSelector

        public String getTypeSelector​()
        这种Styleable的类型用于选择器匹配。 这类似于HTML中的“元素”。 （ CSS Type Selector ）。
        Specified by:
        getTypeSelector在接口 Styleable
        结果
        “标签”
        从以下版本开始：
        JavaFX 8.0

      • getStyleableParent

        public Styleable getStyleableParent​()
        返回此Styleable的父项，如果没有父项则返回null。
        Specified by:
        getStyleableParent在接口 Styleable
        结果
        getTabPane()
        从以下版本开始：
        JavaFX 8.0

      • getPseudoClassStates

        public final ObservableSet<PseudoClass> getPseudoClassStates​()
        返回此Styleable的伪类状态。 CSS假定此集是只读的。
        Specified by:
        getPseudoClassStates在接口 Styleable
        结果
        伪类状态
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        这个样式的CssMetaData。 这可以作为不可修改的列表返回。
        Specified by:
        getCssMetaData在接口 Styleable
        结果
        CssMetaData
        从以下版本开始：
        JavaFX 8.0

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TableCell<S,T>
  • 参数类型
    S - TableView通用类型的类型（即S == TableView <S>）。 这也应该与TableColumn中的第一个泛型类型匹配。
    T - 单元格中包含的项目的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    CheckBoxTableCell ， ChoiceBoxTableCell ， ComboBoxTableCell ， ProgressBarTableCell ， TextFieldTableCell

    public class TableCell<S,T>
extends IndexedCell<T>
    在TableView中表示单行/列交集。 要表示此交集，TableCell包含一个index属性，以及一个tableColumn属性。 另外，TableCell实例知道它存在的是什么TableRow 。

    关于选择的注意事项： TableCell可视化显示当满足两个条件时被选中：

    1. TableSelectionModel.isSelected(int, TableColumnBase)方法对该单元格表示的行/列返回true，
    2. cell selection mode属性设置为true（表示可以选择单个单元格（而不仅仅是单元格行））。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TableView ， TableColumn ， Cell ， IndexedCell ， TableRow

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<TableColumn<S,T>> tableColumn
      支持此TableCell的TableColumn实例。
      ReadOnlyObjectProperty<TableRow<S>> tableRow
      该TableCow目前发现自己位于的TableRow。
      ReadOnlyObjectProperty<TableView<S>> tableView
      TableView与此TableCell关联。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableCell​()
      构造一个默认的TableCell实例，其样式类为“table-cell”

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      void commitEdit​(T newValue)
      在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      TableColumn<S,T> getTableColumn​()
      获取属性tableColumn的值。
      TableRow<S> getTableRow​()
      获取属性tableRow的值。
      TableView<S> getTableView​()
      获取属性tableView的值。
      protected void layoutChildren​()
      在布局传递期间调用这个 Parent的孩子。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      ReadOnlyObjectProperty<TableColumn<S,T>> tableColumnProperty​()
      支持此TableCell的TableColumn实例。
      ReadOnlyObjectProperty<TableRow<S>> tableRowProperty​()
      该TableCow目前发现自己位于的TableRow。
      ReadOnlyObjectProperty<TableView<S>> tableViewProperty​()
      TableView与此TableCell关联。
      void updateSelected​(boolean selected)
      更新此单元格是否处于选定状态。
      void updateTableColumn​(TableColumn col)
      更新与此TableCell关联的TableColumn。
      void updateTableRow​(TableRow tableRow)
      更新与此TableCell关联的TableRow。
      void updateTableView​(TableView tv)
      更新与TableCell相关联的TableView。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem, updateItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • tableColumn

        public final ReadOnlyObjectProperty<TableColumn<S,T>> tableColumnProperty
        支持此TableCell的TableColumn实例。
        结果
        支持此TableCell的TableColumn实例

      • tableView

        public final ReadOnlyObjectProperty<TableView<S>> tableViewProperty
        TableView与此TableCell关联。
        另请参见：
        getTableView()

      • tableRow

        public final ReadOnlyObjectProperty<TableRow<S>> tableRowProperty
        该TableCow目前发现自己位于的TableRow。 TableCell在TableCell生命周期早期可能为空，在TableCell被实例化并被设置为所有者TableRow之间的时间段内。
        另请参见：
        getTableRow()

    • 构造方法详细信息

      • TableCell

        public TableCell​()
        构造一个默认的TableCell实例，其样式类为“table-cell”

    • 方法详细信息

      • tableColumnProperty

        public final ReadOnlyObjectProperty<TableColumn<S,T>> tableColumnProperty​()
        支持此TableCell的TableColumn实例。
        结果
        支持此TableCell的TableColumn实例

      • getTableColumn

        public final TableColumn<S,T> getTableColumn​()
        获取属性tableColumn的值。
        Property description:
        *属性* *

      • getTableView

        public final TableView<S> getTableView​()
        获取属性tableView的值。
        Property description:
        TableView与此TableCell关联。

      • tableViewProperty

        public final ReadOnlyObjectProperty<TableView<S>> tableViewProperty​()
        TableView与此TableCell关联。
        另请参见：
        getTableView()

      • getTableRow

        public final TableRow<S> getTableRow​()
        获取属性tableRow的值。
        Property description:
        该TableCow目前发现自己位于的TableRow。 TableCell在TableCell生命周期早期可能为空，在TableCell被实例化并被设置为所有者TableRow之间的时间段内。

      • tableRowProperty

        public final ReadOnlyObjectProperty<TableRow<S>> tableRowProperty​()
        该TableCow目前发现自己位于的TableRow。 TableCell在TableCell生命周期早期可能为空，在TableCell被实例化并被设置为所有者TableRow之间的时间段内。
        另请参见：
        getTableRow()

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 Cell<T>

      • commitEdit

        public void commitEdit​(T newValue)
        在适当的时候调用此功能（基于您的单元格编辑用户界面的用户交互要求）来做两件事情：
        1. 将相应的事件回到支持UI控件（例如ListView ）。 这将开始将此编辑推回相关数据源/属性（尽管不能保证这将成功 - 这取决于正在使用的特定编辑提交处理程序）。 有关更多详细信息，请参阅UI控件类javadoc。
        2. 开始从编辑状态转换到非编辑状态。

        一般来说，在自定义单元实现中无需重写此方法 - 在适当的时候简单地调用此方法就足够了（例如，当用户按下Enter键时，可以执行像cell.commitEdit(converter.fromString(textField.getText()));

        重写：
        commitEdit在 Cell<T>
        参数
        newValue - 作为最终用户输入的值，应该以相关方式持久 newValue给出支持用户界面的数据源和UI控件的安装编辑提交处理程序。

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 Cell<T>

      • updateSelected

        public void updateSelected​(boolean selected)
        更新此单元格是否处于选定状态。
        重写：
        updateSelected在 Cell<T>
        参数
        selected - 是否选择此单元格。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或在具有setSkin(...)的子类中显式设置，则会调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Cell
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Cell<T>

      • updateTableView

        public final void updateTableView​(TableView tv)
        更新与TableCell相关联的TableView。 当TableCell首次添加到TableView时，通常只执行一次。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        tv - 与此TableCell关联的TableView

      • updateTableRow

        public final void updateTableRow​(TableRow tableRow)
        更新与此TableCell关联的TableRow。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        tableRow - 与此TableCell关联的TableRow

      • updateTableColumn

        public final void updateTableColumn​(TableColumn col)
        更新与此TableCell关联的TableColumn。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        col - 与此TableCell关联的TableColumn

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 要执行的操作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableColumn (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableColumn<S,T>

  • java.lang.Object
    • javafx.scene.control.TableColumnBase<S,T>
      • javafx.scene.control.TableColumn<S,T>
  • 参数类型
    S - TableView通用类型的类型（即S == TableView <S>）
    T - 此TableColumn中所有单元格中的内容类型。
    All Implemented Interfaces:
    Styleable ， EventTarget

    public class TableColumn<S,T>
extends TableColumnBase<S,T>
implements EventTarget
    A TableView由多个TableColumn实例组成。 表中的每个TableColumn都负责显示（和编辑）该列的内容。 除了负责显示和编辑单个列的数据之外，TableColumn还包含必要的属性：
    • 可以（使用尺寸调整二七零七零零五五二三六五七八二 / 二百七万七千零五亿五千二百三十八万一千一百七十七 / 二百七十万七千零五亿五千二百四十一万七千一和width特性）
    • 有其visibility切换
    • 显示header text
    • 显示可能包含的任何nested columns
    • 有一个context menu用户右键单击列标题区域
    • 有表的内容进行排序（使用comparator ， sortable和sortType ）
    创建TableColumn实例时，可能要设置的两个最重要的属性是列text （列标题区域中显示的内容）和列cell value factory （用于填充列中的单个单元格）的列。 这可以使用以下代码中的一些变体来实现：
       ObservableList<Person> data = ... TableView<Person> tableView = new TableView<Person>(data); TableColumn<Person,String> firstNameCol = new TableColumn<Person,String>("First Name"); firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the Person instance for a particular TableView row return p.getValue().firstNameProperty(); } });
 tableView.getColumns().add(firstNameCol);}
    此方法假定从p.getValue()返回的对象具有可以简单地返回的JavaFX ObservableValue 。 这样做的好处是，TableView将在内部创建绑定，以确保在返回的ObservableValue更改时，单元格内容将被自动刷新。

    在TableColumn必须与JavaFX之前创建的类进行交互的情况下，或者通常不希望为属性使用JavaFX apis的情况下，可以将返回的值包装在一个ReadOnlyObjectWrapper实例中。 例如：

       firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { return new ReadOnlyObjectWrapper(p.getValue().getFirstName()); } });
    希望随着时间的推移，开发商可以开发和提供便利的电池价值工厂。 自从 JavaFX 2.0发布以来，有一个这样的便利类： PropertyValueFactory 。 这个类不需要编写上面的代码，而是依靠反射来从String中查找给定的属性。 有关如何使用TableColumn的更多信息，请参阅PropertyValueFactory类文档。 最后，有关如何使用TableColumn的更多详细信息，请参阅TableView类文档中的进一步文档。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TableView ， TableCell ， TablePosition

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Callback<TableColumn<S,T>,TableCell<S,T>>> cellFactory
      该列中所有单元格的单元格工厂。
      ObjectProperty<Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> cellValueFactory
      单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditCancel
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditCommit
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditStart
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<TableColumn.SortType> sortType
      用于说明此列是否为排序顺序的一部分（详见 TableView.getSortOrder() ），应按升序或降序进行排序。
      ReadOnlyObjectProperty<TableView<S>> tableView
      TableView这个TableColumn属于。

      • Properties inherited from class javafx.scene.control.TableColumnBase

        comparator, contextMenu, editable, graphic, id, maxWidth, minWidth, parentColumn, prefWidth, reorderable, resizable, sortable, sortNode, style, text, visible, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TableColumn.CellDataFeatures<S,T>
      在TableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。
      static class  TableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TableColumn.SortType
      枚举，指定应用于特定列的排序类型。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Callback<TableColumn<?,?>,TableCell<?,?>> DEFAULT_CELL_FACTORY
      如果在TableColumn实例上未指定cellFactory，则默认情况下将使用该实例。

      • Fields inherited from class javafx.scene.control.TableColumnBase

        DEFAULT_COMPARATOR

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableColumn​()
      使用默认单元格工厂，比较器和onEditCommit实现创建默认的TableColumn。
      TableColumn​(String text)
      创建一个TableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Callback<TableColumn<S,T>,TableCell<S,T>>> cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      ObjectProperty<Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> editAnyEvent​()
      任何TableColumn编辑事件的父事件。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> editCancelEvent​()
      表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> editCommitEvent​()
      表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> editStartEvent​()
      表示用户已经执行了一些交互来启动编辑事件，或者已经调用了 TableView.edit(int, javafx.scene.control.TableColumn)方法。
      Callback<TableColumn<S,T>,TableCell<S,T>> getCellFactory​()
      获取属性cellFactory的值。
      ObservableValue<T> getCellObservableValue​(int index)
      尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。
      ObservableValue<T> getCellObservableValue​(S item)
      尝试返回给定项目（其类型为S）的ObservableValue <T>。
      Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> getCellValueFactory​()
      获取属性cellValueFactory的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      ObservableList<TableColumn<S,?>> getColumns​()
      这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      这个样式的CssMetaData。
      EventHandler<TableColumn.CellEditEvent<S,T>> getOnEditCancel​()
      获取属性onEditCancel的值。
      EventHandler<TableColumn.CellEditEvent<S,T>> getOnEditCommit​()
      获取属性onEditCommit的值。
      EventHandler<TableColumn.CellEditEvent<S,T>> getOnEditStart​()
      获取onEditStart上的属性的值。
      TableColumn.SortType getSortType​()
      获取属性sortType的值。
      Node getStyleableNode​()
      返回表示此Styleable对象的Node。
      Styleable getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      TableView<S> getTableView​()
      获取属性tableView的值。
      String getTypeSelector​()
      这种 Styleable的类型用于选择器匹配。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditCommitProperty​()
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      void setCellFactory​(Callback<TableColumn<S,T>,TableCell<S,T>> value)
      设置属性cellFactory的值。
      void setCellValueFactory​(Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
      设置属性cellValueFactory的值。
      void setOnEditCancel​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCancel的值。
      void setOnEditCommit​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCommit的值。
      void setOnEditStart​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
      设置属性onEditStart的值。
      void setSortType​(TableColumn.SortType value)
      设置属性sortType的值。
      ObjectProperty<TableColumn.SortType> sortTypeProperty​()
      用于说明此列是否是排序顺序的一部分（更多详细信息，请参阅 TableView.getSortOrder() ），应按升序或降序排列。
      ReadOnlyObjectProperty<TableView<S>> tableViewProperty​()
      TableView这个TableColumn属于。

      • Methods inherited from interface javafx.event.EventTarget

        buildEventDispatchChain

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.TableColumnBase

        addEventHandler, buildEventDispatchChain, comparatorProperty, contextMenuProperty, editableProperty, getCellData, getCellData, getComparator, getContextMenu, getGraphic, getId, getMaxWidth, getMinWidth, getParentColumn, getPrefWidth, getProperties, getPseudoClassStates, getSortNode, getStyle, getStyleClass, getText, getUserData, getWidth, graphicProperty, hasProperties, idProperty, isEditable, isReorderable, isResizable, isSortable, isVisible, maxWidthProperty, minWidthProperty, parentColumnProperty, prefWidthProperty, removeEventHandler, reorderableProperty, resizableProperty, setComparator, setContextMenu, setEditable, setGraphic, setId, setMaxWidth, setMinWidth, setPrefWidth, setReorderable, setResizable, setSortable, setSortNode, setStyle, setText, setUserData, setVisible, sortableProperty, sortNodeProperty, styleProperty, textProperty, visibleProperty, widthProperty

    • Property Detail

      • tableView

        public final ReadOnlyObjectProperty<TableView<S>> tableViewProperty
        TableView这个TableColumn属于。
        另请参见：
        getTableView()

      • cellValueFactory

        public final ObjectProperty<Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> cellValueFactoryProperty
        单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。 一个单元格值工厂是一个Callback ，它提供了一个TableColumn.CellDataFeatures的实例，并期望返回一个ObservableValue 。 将在内部观察返回的ObservableValue实例，以便立即更新要在屏幕上反映的值。 如何设置单元格值工厂的一个例子是：
           lastNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the Person instance for a particular TableView row return p.getValue().lastNameProperty(); } }); }
        一个常见的方法是使用Java bean中的单个值来填充TableColumn中的单元格。 为了支持这种常见的情况，有PropertyValueFactory类。 有关如何使用它的更多信息，请参阅此类，但简要的说明如何使用PropertyValueFactory类简化上述用例：
           lastNameCol.setCellValueFactory(new PropertyValueFactory<Person,String>("lastName"));
        另请参见：
        getCellValueFactory() ， setCellValueFactory(Callback)

      • cellFactory

        public final ObjectProperty<Callback<TableColumn<S,T>,TableCell<S,T>>> cellFactoryProperty
        该列中所有单元格的单元格工厂。 单元工厂负责渲染每个TableCell中包含的单个表列的数据。

        默认情况下，TableColumn使用default cell factory ，但是可以用自定义实现来替换，例如以不同的方式显示数据或支持编辑。有很多关于在其他地方创建自定义单元格工厂的文档（参见Cell和TableView） ）。

        最后，在javafx.scene.control.cell包中有一些预建的电池厂可用。

        另请参见：
        getCellFactory() ， setCellFactory(Callback)

      • sortType

        public final ObjectProperty<TableColumn.SortType> sortTypeProperty
        用于说明此列是否为排序顺序的一部分（详见TableView.getSortOrder() ），应按升序或降序排列。 只需切换此属性将导致排序顺序在TableView中更改，假设此列位于sortOrder ObservableList中。
        另请参见：
        getSortType() ， setSortType(TableColumn.SortType)

      • onEditStart

        public final ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditStartProperty
        当用户成功启动编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditStart() ， setOnEditStart(EventHandler)

      • onEditCommit

        public final ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditCommitProperty
        当用户成功提交编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditCommit() ， setOnEditCommit(EventHandler)

      • onEditCancel

        public final ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditCancelProperty
        当用户取消编辑单元格时，将触发此事件处理程序。
        另请参见：
        getOnEditCancel() ， setOnEditCancel(EventHandler)

    • 字段详细信息

      • DEFAULT_CELL_FACTORY

        public static final Callback<TableColumn<?,?>,TableCell<?,?>> DEFAULT_CELL_FACTORY
        如果在TableColumn实例上未指定cellFactory，则默认情况下将使用该实例。 目前，如果item是节点，它将简单地将TableCell项目属性提交到graphic属性中，或者如果它不为空，则调用toString() ，将生成的字符串设置在text属性中。

    • 构造方法详细信息

      • TableColumn

        public TableColumn​()
        使用默认单元格工厂，比较器和onEditCommit实现创建默认的TableColumn。

      • TableColumn

        public TableColumn​(String text)
        创建一个TableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。
        参数
        text - 在TableView中放置TableColumn时显示的字符串。

    • 方法详细信息

      • editAnyEvent

        public static <S,T> EventType<TableColumn.CellEditEvent<S,T>> editAnyEvent​()
        任何TableColumn编辑事件的父事件。
        参数类型
        S - TableView通用类型的类型
        T - 此TableColumn中所有单元格中的内容类型
        结果
        任何TableColumn编辑事件

      • editStartEvent

        public static <S,T> EventType<TableColumn.CellEditEvent<S,T>> editStartEvent​()
        表示用户已经执行了一些交互以启动编辑事件，或者已经调用了 TableView.edit(int, javafx.scene.control.TableColumn)方法。
        参数类型
        S - TableView通用类型的类型
        T - 此TableColumn中所有单元格中的内容类型
        结果
        开始编辑事件

      • editCancelEvent

        public static <S,T> EventType<TableColumn.CellEditEvent<S,T>> editCancelEvent​()
        表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
        参数类型
        S - TableView通用类型的类型
        T - 此TableColumn中所有单元格中的内容类型
        结果
        取消编辑事件

      • editCommitEvent

        public static <S,T> EventType<TableColumn.CellEditEvent<S,T>> editCommitEvent​()
        表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
        参数类型
        S - TableView通用类型的类型
        T - 此TableColumn中所有单元格中的内容类型
        结果
        提交编辑事件

      • tableViewProperty

        public final ReadOnlyObjectProperty<TableView<S>> tableViewProperty​()
        TableView这个TableColumn属于。
        另请参见：
        getTableView()

      • getTableView

        public final TableView<S> getTableView​()
        获取属性tableView的值。
        Property description:
        TableView这个TableColumn属于。

      • setCellValueFactory

        public final void setCellValueFactory​(Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
        设置属性cellValueFactory的值。
        Property description:
        单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。 一个单元格值工厂是一个Callback ，它提供了一个TableColumn.CellDataFeatures实例，并期望返回一个ObservableValue 。 将在内部观察返回的ObservableValue实例，以便立即更新要在屏幕上反映的值。 如何设置单元格值工厂的一个例子是：
           lastNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the Person instance for a particular TableView row return p.getValue().lastNameProperty(); } }); }
        一个常见的方法是使用Java bean中的单个值来填充TableColumn中的单元格。 为了支持这种常见的情况，有PropertyValueFactory类。 有关如何使用它的更多信息，请参阅此类，但简要的说明如何使用PropertyValueFactory类简化上述用例：
           lastNameCol.setCellValueFactory(new PropertyValueFactory<Person,String>("lastName"));

      • getCellValueFactory

        public final Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> getCellValueFactory​()
        获取属性cellValueFactory的值。
        Property description:
        单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。 一个单元格值工厂是一个Callback ，它提供了一个TableColumn.CellDataFeatures实例，并期望返回一个ObservableValue 。 将在内部观察返回的ObservableValue实例，以便立即更新要在屏幕上反映的值。 如何设置单元格值工厂的一个例子是：
           lastNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the Person instance for a particular TableView row return p.getValue().lastNameProperty(); } }); }
        一个常见的方法是使用Java bean中的单个值来填充TableColumn中的单元格。 为了支持这种常见的情况，有PropertyValueFactory类。 有关如何使用它的更多信息，请参阅此类，但简要的说明如何使用PropertyValueFactory类简化上述用例：
           lastNameCol.setCellValueFactory(new PropertyValueFactory<Person,String>("lastName"));

      • cellValueFactoryProperty

        public final ObjectProperty<Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> cellValueFactoryProperty​()
        单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。 一个单元格值工厂是一个Callback ，它提供了一个TableColumn.CellDataFeatures实例，并期望返回一个ObservableValue 。 将在内部观察返回的ObservableValue实例，以便立即更新要在屏幕上反映的值。 如何设置单元格值工厂的一个例子是：
           lastNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the Person instance for a particular TableView row return p.getValue().lastNameProperty(); } }); }
        一个常见的方法是使用Java bean中的单个值来填充TableColumn中的单元格。 为了支持这种常见的情况，有PropertyValueFactory类。 有关如何使用它的更多信息，请参阅此类，但简要的说明如何使用PropertyValueFactory类简化上述用例：
           lastNameCol.setCellValueFactory(new PropertyValueFactory<Person,String>("lastName"));
        另请参见：
        getCellValueFactory() ， setCellValueFactory(Callback)

      • setCellFactory

        public final void setCellFactory​(Callback<TableColumn<S,T>,TableCell<S,T>> value)
        设置属性cellFactory的值。
        Property description:
        该列中所有单元格的单元格工厂。 单元工厂负责渲染每个TableCell中包含的单个表列的数据。

        默认情况下，TableColumn使用default cell factory ，但是可以用自定义实现替换，例如以不同的方式显示数据或支持编辑。有很多关于在其他地方创建自定义单元格工厂的文档（参见Cell和TableView） ）。

        最后，在javafx.scene.control.cell包中有许多预建的电池厂可用。

      • getCellFactory

        public final Callback<TableColumn<S,T>,TableCell<S,T>> getCellFactory​()
        获取属性cellFactory的值。
        Property description:
        该列中所有单元格的单元格工厂。 单元工厂负责渲染每个TableCell中包含的单个表列的数据。

        默认情况下，TableColumn使用default cell factory ，但是可以用自定义实现替换，例如以不同的方式显示数据或支持编辑。有很多关于在其他地方创建自定义单元格工厂的文档（参见Cell和TableView） ）。

        最后，在javafx.scene.control.cell包中有许多预建的电池厂可用。

      • cellFactoryProperty

        public final ObjectProperty<Callback<TableColumn<S,T>,TableCell<S,T>>> cellFactoryProperty​()
        该列中所有单元格的单元格工厂。 单元工厂负责渲染每个TableCell中包含的单个表列的数据。

        默认情况下，TableColumn使用default cell factory ，但是可以用自定义实现来替换，例如以不同的方式显示数据或支持编辑。有很多关于在其他地方创建自定义单元格工厂的文档（参见Cell和TableView） ）。

        最后，在javafx.scene.control.cell包中有一些预先建成的电池厂 。

        另请参见：
        getCellFactory() ， setCellFactory(Callback)

      • sortTypeProperty

        public final ObjectProperty<TableColumn.SortType> sortTypeProperty​()
        用于说明此列是否为排序顺序的一部分（详细信息请参阅TableView.getSortOrder() ），应按升序或降序进行排序。 只需切换此属性将导致排序顺序在TableView中更改，假设此列位于sortOrder ObservableList中。
        另请参见：
        getSortType() ， setSortType(TableColumn.SortType)

      • setSortType

        public final void setSortType​(TableColumn.SortType value)
        设置属性sortType的值。
        Property description:
        用于说明此列是否为排序顺序的一部分（详见TableView.getSortOrder() ），应按升序或降序排列。 只需切换此属性将导致排序顺序在TableView中更改，假设此列位于sortOrder ObservableList中。

      • getSortType

        public final TableColumn.SortType getSortType​()
        获取属性sortType的值。
        Property description:
        用于说明此列是否为排序顺序的一部分（详见TableView.getSortOrder() ），应按升序或降序进行排序。 只需切换此属性将导致排序顺序在TableView中更改，假设此列位于sortOrder ObservableList中。

      • setOnEditStart

        public final void setOnEditStart​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
        设置属性onEditStart的值。
        Property description:
        当用户成功启动编辑时，会触发此事件处理程序。

      • getOnEditStart

        public final EventHandler<TableColumn.CellEditEvent<S,T>> getOnEditStart​()
        获取onEditStart上的属性的值。
        Property description:
        当用户成功启动编辑时，会触发此事件处理程序。

      • onEditStartProperty

        public final ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditStartProperty​()
        当用户成功启动编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditStart() ， setOnEditStart(EventHandler)

      • setOnEditCommit

        public final void setOnEditCommit​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
        设置属性onEditCommit的值。
        Property description:
        当用户成功提交编辑时，会触发此事件处理程序。

      • getOnEditCommit

        public final EventHandler<TableColumn.CellEditEvent<S,T>> getOnEditCommit​()
        获取属性onEditCommit的值。
        Property description:
        当用户成功提交编辑时，会触发此事件处理程序。

      • onEditCommitProperty

        public final ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditCommitProperty​()
        当用户成功提交编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditCommit() ， setOnEditCommit(EventHandler)

      • setOnEditCancel

        public final void setOnEditCancel​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
        设置属性onEditCancel的值。
        Property description:
        当用户取消编辑单元格时，将触发此事件处理程序。

      • getOnEditCancel

        public final EventHandler<TableColumn.CellEditEvent<S,T>> getOnEditCancel​()
        获取属性onEditCancel的值。
        Property description:
        当用户取消编辑单元格时，将触发此事件处理程序。

      • onEditCancelProperty

        public final ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> onEditCancelProperty​()
        当用户取消编辑单元格时，将触发此事件处理程序。
        另请参见：
        getOnEditCancel() ， setOnEditCancel(EventHandler)

      • getColumns

        public final ObservableList<TableColumn<S,?>> getColumns​()
        这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。 例如，我们可能有一个“名称”列，其中包含“First”和“Last”名称的两个嵌套列。

        这对于这样没有影响 - 所有列索引仅指向叶子列，并且不可能使用父列进行排序，只能使用叶列。 换句话说，这纯粹是一个视觉特征。

        Specified by:
        getColumns在 TableColumnBase<S,T>
        结果
        一个包含TableColumnBase实例（或子类）的ObservableList，它是此TableColumnBase的子项。 如果这些孩子的TableColumnBase实例设置为可见，它们将显示在此表列下方。

      • getCellObservableValue

        public final ObservableValue<T> getCellObservableValue​(int index)
        尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。 换句话说，该方法期望接收大于或等于零且小于底层数据模型大小的整数值。 如果索引有效，此方法将返回此特定列的ObservableValue <T>。

        这可以通过调用cell value factory来实现，当通过一个CellDataFeatures （参见例如CellDataFeatures类属于TableColumn和TreeTableColumn的更多信息）时返回它。

        Specified by:
        getCellObservableValue在 TableColumnBase<S,T>
        参数
        index - 寻求ObservableValue <T>的项目（S型）的索引。
        结果
        此特定表列的ObservableValue <T>。

      • getCellObservableValue

        public final ObservableValue<T> getCellObservableValue​(S item)
        尝试返回给定项目（其类型为S）的ObservableValue <T>。 换句话说，该方法期望从表中的整个“行”的底层数据模型接收一个对象，并且必须返回该特定列中的值的ObservableValue <T>。

        这可以通过调用cell value factory实现，并返回通过CellDataFeatures时返回的任何内容（例如，有关详细信息，请参阅例如，属于TableColumn和TreeTableColumn的CellDataFeatures类）。

        Specified by:
        getCellObservableValue在 TableColumnBase<S,T>
        参数
        item - 寻求ObservableValue <T>的项目（S型）。
        结果
        此特定表列的ObservableValue <T>。

      • getTypeSelector

        public String getTypeSelector​()
        这种Styleable的类型用于选择器匹配。 这类似于HTML中的“元素”。 （ CSS Type Selector ）。
        Specified by:
        getTypeSelector在接口 Styleable
        结果
        “TableColumn的”
        从以下版本开始：
        JavaFX 8.0

      • getStyleableParent

        public Styleable getStyleableParent​()
        返回此Styleable的父项，如果没有父项则返回null。
        Specified by:
        getStyleableParent在接口 Styleable
        结果
        getTableView()
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        这个样式的CssMetaData。 这可以作为不可修改的列表返回。
        Specified by:
        getCssMetaData在接口 Styleable
        结果
        CssMetaData
        从以下版本开始：
        JavaFX 8.0

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getStyleableNode

        public Node getStyleableNode​()
        返回表示此Styleable对象的Node。 在Styleable本身不是Node的情况下，应该覆盖此方法，以便它可以可选地返回其本身的相关根节点表示。 默认情况下，此方法返回null，这可能意味着Styleable本身是一个Node，如果不是这种情况，则Styleable在请求时没有可用的节点表示。
        Specified by:
        getStyleableNode在接口 Styleable
        结果
        表示此Styleable对象的节点
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TableColumn.CellDataFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableColumn.CellDataFeatures<S,T>

  • java.lang.Object
    • javafx.scene.control.TableColumn.CellDataFeatures<S,T>
  • 参数类型
    S - TableView类型
    T - TableColumn类型
    Enclosing class:
    TableColumn < S ， T >

    public static class TableColumn.CellDataFeatures<S,T>
extends Object
    在TableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。 一旦实例化，这个类是不可变的。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      CellDataFeatures​(TableView<S> tableView, TableColumn<S,T> tableColumn, S value)
      实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TableColumn<S,T> getTableColumn​()
      返回传递给构造函数的TableColumn 。
      TableView<S> getTableView​()
      返回传递给构造函数的TableView 。
      S getValue​()
      返回传递给构造函数的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CellDataFeatures

        public CellDataFeatures​(TableView<S> tableView,
                        TableColumn<S,T> tableColumn,
                        S value)
        实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。
        参数
        tableView - 此实例引用的TableView。
        tableColumn - 此实例引用的TableColumn。
        value - TableView中的一行的值。

    • 方法详细信息

      • getValue

        public S getValue​()
        返回传递给构造函数的值。
        结果
        该值传递给构造函数

      • getTableColumn

        public TableColumn<S,T> getTableColumn​()
        返回传递给构造函数的TableColumn 。
        结果
        传递给构造函数的TableColumn

      • getTableView

        public TableView<S> getTableView​()
        返回传递给构造函数的TableView 。
        结果
        the TableView passed in to the constructor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableColumn.CellEditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableColumn.CellEditEvent<S,T>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.TableColumn.CellEditEvent<S,T>
  • 参数类型
    S - TableView通用类型的类型
    T - 此TableColumn中所有单元格中的内容类型
    All Implemented Interfaces:
    Serializable ， Cloneable
    Enclosing class:
    TableColumn < S ， T >

    public static class TableColumn.CellEditEvent<S,T>
extends Event
    用户在表单元格上执行编辑时触发的事件。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<?> ANY
      所有单元格编辑事件类型的公共超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      CellEditEvent​(TableView<S> table, TablePosition<S,T> pos, EventType<TableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T getNewValue​()
      返回最终用户输入的新值。
      T getOldValue​()
      尝试在 getTablePosition()返回的 TablePosition中提到的位置返回旧值。
      S getRowValue​()
      为getTablePosition()中返回的TablePosition中包含的行返回行的值（即TableView items列表）的便利方法。
      TableColumn<S,T> getTableColumn​()
      返回发生此事件的TableColumn。
      TablePosition<S,T> getTablePosition​()
      返回此事件发生的位置。
      TableView<S> getTableView​()
      返回发生此事件的TableView。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<?> ANY
        所有单元格编辑事件类型的公共超类型。
        从以下版本开始：
        JavaFX 8.0

    • 构造方法详细信息

      • CellEditEvent

        public CellEditEvent​(TableView<S> table,
                     TablePosition<S,T> pos,
                     EventType<TableColumn.CellEditEvent<S,T>> eventType,
                     T newValue)
        创建一个可以随后向相关听众触发的新事件。
        参数
        table - 发生此事件的TableView。
        pos - 发生此事件的位置。
        eventType - 发生的事件类型。
        newValue - 最终用户输入的值。

    • 方法详细信息

      • getTableView

        public TableView<S> getTableView​()
        返回发生此事件的TableView。
        结果
        发生此事件的TableView控件。

      • getTableColumn

        public TableColumn<S,T> getTableColumn​()
        返回发生此事件的TableColumn。
        结果
        编辑发生在的TableColumn。

      • getTablePosition

        public TablePosition<S,T> getTablePosition​()
        返回此事件发生的位置。
        结果
        该事件发生的位置。

      • getNewValue

        public T getNewValue​()
        返回最终用户输入的新值。 这不是返回到TableView.items列表的值 - 这个新值仅代表单个单元格的输入，因此它可能需要返回到TableView.items列表中的一个项目中的属性。
        结果
        表示用户输入的新值的对象。

      • getOldValue

        public T getOldValue​()
        尝试在getTablePosition()返回的TablePosition中提到的位置返回旧值。 这可能会返回null，原因有很多。
        结果
        返回正在编辑的位置中存储的值，如果无法检索，则返回null。

      • getRowValue

        public S getRowValue​()
        为getTablePosition()中返回的TablePosition中包含的行返回行的值（即TableView items列表）的便利方法。
        结果
        该行的值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TableColumn.SortType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum TableColumn.SortType

  • java.lang.Object
    • java.lang.Enum<TableColumn.SortType>
      • javafx.scene.control.TableColumn.SortType
  • All Implemented Interfaces:
    Serializable ， Comparable<TableColumn.SortType>
    Enclosing class:
    TableColumn < S ， T >

    public static enum TableColumn.SortType
extends Enum<TableColumn.SortType>
    枚举，指定应用于特定列的排序类型。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ASCENDING
      列将按升序排序。
      DESCENDING
      列将按降序排序。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TableColumn.SortType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TableColumn.SortType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ASCENDING

        public static final TableColumn.SortType ASCENDING
        列将按升序排序。

      • DESCENDING

        public static final TableColumn.SortType DESCENDING
        列将按降序排序。

    • 方法详细信息

      • values

        public static TableColumn.SortType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TableColumn.SortType c : TableColumn.SortType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TableColumn.SortType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TableColumnBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableColumnBase<S,T>

  • java.lang.Object
    • javafx.scene.control.TableColumnBase<S,T>
  • 参数类型
    S - UI控件的类型（例如“行”的类型）。
    T - 此表列中所有单元格中的内容类型。
    All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    TableColumn ， TreeTableColumn

    @IDProperty("id")
public abstract class TableColumnBase<S,T>
extends Object
implements EventTarget, Styleable
    表类控件（如TableView和TreeTableView ）由零个或多个具体TableColumnBase子类（ TableColumn和TreeTableColumn ）的实例组成。 表中的每个表列都负责显示（和编辑）该列的内容。 除了负责显示和编辑单个列的数据之外，表列还包含必要的属性：
    • 可以（使用尺寸调整二百七十万七千零五亿零七百五十五万二千八百九十七 / prefWidth / 二七零七零零五零七五八二一零九和width特性）
    • 有其visibility切换
    • 显示header text
    • 显示可能包含的任何nested columns
    • 当用户右键单击列标题区域时，有一个context menu
    • 有表的内容（使用排序comparator ， sortable和sortType）。
    当实例化TableColumnBase的具体子类时，可能要设置的两个最重要的属性是列text （列标题区域中显示的内容）和列cell value factory （用于填充列中的单个单元格）的列。 有关详细信息，请参阅TableColumn和TreeTableColumn的课程文档。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TableColumn ， TreeTableColumn ， TablePositionBase

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Comparator<T>> comparator
      排序此表列时使用的比较器功能。
      ObjectProperty<ContextMenu> contextMenu
      当用户右键单击此TableColumnBase的标题区域时，将显示此菜单。
      BooleanProperty editable
      指定此表列是否允许编辑。
      ObjectProperty<Node> graphic
      在表列中显示的图形，以允许用户以图形方式指示列中的内容。
      StringProperty id
      此TableColumnBase的ID。
      DoubleProperty maxWidth
      表列允许调整大小的最大宽度。
      DoubleProperty minWidth
      允许表列调整大小的最小宽度。
      ReadOnlyObjectProperty<TableColumnBase<S,?>> parentColumn
      在使用嵌套列的情况下，此只读属性将始终引用此列的父级。
      DoubleProperty prefWidth
      TableColumn的首选宽度。
      BooleanProperty reorderable
      一个布尔属性可以打开和关闭此列的“可重新排序”（通过修改适当的 columns列表进行拖放 - 重新排序）始终被允许）。
      BooleanProperty resizable
      用于指示此列的宽度是否可以更改。
      BooleanProperty sortable
      用于打开和关闭此列的“可排序性”的布尔属性。
      ObjectProperty<Node> sortNode
      用作“排序箭头”的节点，在表列是排序顺序的一部分的情况下向用户显示。
      StringProperty style
      与此TableColumnBase实例相关联的CSS样式的字符串表示形式。
      StringProperty text
      这是此列的标题中显示的文本。
      BooleanProperty visible
      切换此项将立即切换此列和所有子列的可见性。
      ReadOnlyDoubleProperty width
      此列的宽度。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Comparator DEFAULT_COMPARATOR
      默认情况下，所有列将使用此比较器执行排序。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected TableColumnBase​()
      使用默认单元格工厂，比较器和onEditCommit实现创建默认的TableColumn。
      protected TableColumnBase​(String text)
      创建一个TableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      <E extends Event>
      void             		addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      在此表列中注册一个事件处理程序。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      ObjectProperty<Comparator<T>> comparatorProperty​()
      排序此表列时使用的比较器功能。
      ObjectProperty<ContextMenu> contextMenuProperty​()
      当用户右键单击此TableColumnBase的标题区域时，将显示此菜单。
      BooleanProperty editableProperty​()
      指定此表列是否允许编辑。
      T getCellData​(int index)
      返回给定行索引（并且属于此表列）的单元格的实际值。
      T getCellData​(S item)
      从给定项返回单元格的实际值。
      abstract ObservableValue<T> getCellObservableValue​(int index)
      尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。
      abstract ObservableValue<T> getCellObservableValue​(S item)
      尝试返回给定项目（其类型为S）的ObservableValue <T>。
      abstract ObservableList<? extends TableColumnBase<S,?>> getColumns​()
      这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。
      Comparator<T> getComparator​()
      获取属性比较器的值。
      ContextMenu getContextMenu​()
      获取属性contextMenu的值。
      Node getGraphic​()
      获取属性图形的值。
      String getId​()
      获取属性ID的值。
      double getMaxWidth​()
      获取属性maxWidth的值。
      double getMinWidth​()
      获取属性minWidth的值。
      TableColumnBase<S,?> getParentColumn​()
      获取属性parentColumn的值。
      double getPrefWidth​()
      获取属性prefWidth的值。
      ObservableMap<Object,Object> getProperties​()
      返回此表列上属性的可观察图，主要由应用程序开发人员使用。
      ObservableSet<PseudoClass> getPseudoClassStates​()
      返回此Styleable的伪类状态。
      Node getSortNode​()
      获取属性sortNode的值。
      String getStyle​()
      获取属性样式的值。
      ObservableList<String> getStyleClass​()
      可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。
      String getText​()
      获取属性文本的值。
      Object getUserData​()
      返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
      double getWidth​()
      获取属性宽度的值。
      ObjectProperty<Node> graphicProperty​()
      在表列中显示的图形，以允许用户以图形方式指示列中的内容。
      boolean hasProperties​()
      测试此表列是否具有属性。
      StringProperty idProperty​()
      此TableColumnBase的ID。
      boolean isEditable​()
      获取可编辑属性的值。
      boolean isReorderable​()
      获取属性可重新排序的值。
      boolean isResizable​()
      获取属性可调整大小的值。
      boolean isSortable​()
      获取属性可排序的值。
      boolean isVisible​()
      获取属性的值可见。
      DoubleProperty maxWidthProperty​()
      表列允许调整大小的最大宽度。
      DoubleProperty minWidthProperty​()
      允许表列调整大小的最小宽度。
      ReadOnlyObjectProperty<TableColumnBase<S,?>> parentColumnProperty​()
      在使用嵌套列的情况下，此只读属性将始终引用此列的父级。
      DoubleProperty prefWidthProperty​()
      TableColumn的首选宽度。
      <E extends Event>
      void             		removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此表列中注销先前注册的事件处理程序。
      BooleanProperty reorderableProperty​()
      一个布尔属性可以打开和关闭此列的“可重新排序”（通过修改适当的 columns列表进行拖放 - 重新排序）始终是允许的）。
      BooleanProperty resizableProperty​()
      用于指示此列的宽度是否可以更改。
      void setComparator​(Comparator<T> value)
      设置属性比较器的值。
      void setContextMenu​(ContextMenu value)
      设置属性contextMenu的值。
      void setEditable​(boolean value)
      设置属性可编辑的值。
      void setGraphic​(Node value)
      设置属性图形的值。
      void setId​(String value)
      设置属性id的值。
      void setMaxWidth​(double value)
      设置属性maxWidth的值。
      void setMinWidth​(double value)
      设置属性minWidth的值。
      void setPrefWidth​(double value)
      设置属性prefWidth的值。
      void setReorderable​(boolean value)
      设置属性可重新排序的值。
      void setResizable​(boolean value)
      设置属性可调整大小的值。
      void setSortable​(boolean value)
      设置属性可分类的值。
      void setSortNode​(Node value)
      设置属性sortNode的值。
      void setStyle​(String value)
      设置属性样式的值。
      void setText​(String value)
      设置属性文本的值。
      void setUserData​(Object value)
      用于设置可以在以后检索的单个Object属性的便利方法。
      void setVisible​(boolean value)
      设置属性的值可见。
      BooleanProperty sortableProperty​()
      用于打开和关闭此列的“可排序性”的布尔属性。
      ObjectProperty<Node> sortNodeProperty​()
      用作“排序箭头”的节点，在表列是排序顺序的一部分的情况下向用户显示。
      StringProperty styleProperty​()
      与此TableColumnBase实例相关联的CSS样式的字符串表示形式。
      StringProperty textProperty​()
      这是此列的标题中显示的文本。
      BooleanProperty visibleProperty​()
      切换此项将立即切换此列和所有子列的可见性。
      ReadOnlyDoubleProperty widthProperty​()
      此列的宽度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getCssMetaData, getStyleableNode, getStyleableParent, getTypeSelector

    • Property Detail

      • text

        public final StringProperty textProperty
        这是此列的标题中显示的文本。
        另请参见：
        getText() ， setText(String)

      • visible

        public final BooleanProperty visibleProperty
        切换此项将立即切换此列和所有子列的可见性。
        另请参见：
        isVisible() ， setVisible(boolean)

      • parentColumn

        public final ReadOnlyObjectProperty<TableColumnBase<S,?>> parentColumnProperty
        在使用嵌套列的情况下，此只读属性将始终引用此列的父级。

        在当前存在的子类中，创建嵌套列只是将相关TableColumnBase实例放在ObservableList列中的一个问题（例如，参见TableColumn.getColumns()和TreeTableColumn.getColumns()） 。

        另请参见：
        getParentColumn()

      • contextMenu

        public final ObjectProperty<ContextMenu> contextMenuProperty
        当用户右键单击此TableColumnBase的标题区域时，将显示此菜单。
        另请参见：
        getContextMenu() ， setContextMenu(ContextMenu)

      • id

        public final StringProperty idProperty
        此TableColumnBase的ID。 这个简单的字符串标识符可用于在使用TableColumnBase实例的UI控件中查找特定的TableColumnBase。 默认值为null 。
        Default value:
        空值
        另请参见：
        getId() ， setId(String)

      • style

        public final StringProperty styleProperty
        与此TableColumnBase实例相关联的CSS样式的字符串表示形式。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。

        在某些有限的平台上可能不支持解析此样式。 建议使用独立的CSS文件。

        Default value:
        空字符串
        另请参见：
        getStyle() ， setStyle(String)

      • graphic

        public final ObjectProperty<Node> graphicProperty

        在表列中显示的图形，以允许用户以图形方式指示列中的内容。

        另请参见：
        getGraphic() ， setGraphic(Node)

      • sortNode

        public final ObjectProperty<Node> sortNodeProperty

        用作“排序箭头”的节点，在表列是排序顺序的一部分的情况下向用户显示。 它可能是排序顺序中唯一的项目，或者它可能是次要，三级或后一种排序项目，并且节点应该可视化地反映出来。 这仅在表列处于排序顺序的情况下使用（参见，例如， TableView.getSortOrder()和TreeTableView.getSortOrder() ）。 如果未指定，则表列皮肤实现负责提供默认排序节点。

        排序节点通常被视为在屏幕上旋转以指示表列是否是排序顺序的一部分的三角形，如果是，排序是升序还是降序，以及排序顺序中的位置。

        另请参见：
        getSortNode() ， setSortNode(Node)

      • width

        public final ReadOnlyDoubleProperty widthProperty
        此列的宽度。 修改此操作将导致列宽可视化调整。 建议不要将此属性绑定到外部属性，因为这将导致用户通过拖动列标题的左右边框不能调整列宽。
        另请参见：
        getWidth()

      • minWidth

        public final DoubleProperty minWidthProperty
        允许表列调整大小的最小宽度。
        另请参见：
        getMinWidth() ， setMinWidth(double)

      • prefWidth

        public final DoubleProperty prefWidthProperty
        TableColumn的首选宽度。
        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • maxWidth

        public final DoubleProperty maxWidthProperty
        表列允许调整大小的最大宽度。
        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • resizable

        public final BooleanProperty resizableProperty
        用于指示此列的宽度是否可以更改。 然而，由大小调整政策来执行。
        另请参见：
        isResizable() ， setResizable(boolean)

      • sortable

        public final BooleanProperty sortableProperty

        用于打开和关闭此列的“可排序性”的布尔属性。 当此属性为true时，此列可以包含在排序操作中。 如果此属性为false，即使它包含在底层UI控件的排序顺序列表中（例如， TableView.getSortOrder()或TreeTableView.getSortOrder() ）也不会包含在排序操作中。

        例如，如果TableColumn实例包含在TableView sortOrder ObservableList中，并且其可排序属性将切换状态，则它将强制TableView执行排序，因为该视图可能需要更新。

        另请参见：
        isSortable() ， setSortable(boolean)

      • reorderable

        public final BooleanProperty reorderableProperty
        用于打开和关闭此列的“可重新排序”的布尔属性（通过修改适当的columns列表进行拖放 - 重新排序）始终是允许的）。 当此属性为true时，用户可以通过将列拖放到所需的位置来重新排序此列。 当此属性为false时，这种拖放列的功能不可用。
        从以下版本开始：
        9
        另请参见：
        isReorderable() ， setReorderable(boolean)

      • comparator

        public final ObjectProperty<Comparator<T>> comparatorProperty
        排序此表列时使用的比较器功能。 作为参数给出的两个对象是此列中两个单独单元格的单元格数据。
        另请参见：
        getComparator() ， setComparator(Comparator)

      • editable

        public final BooleanProperty editableProperty
        指定此表列是否允许编辑。 这与TableView.editableProperty()和TreeTableView.editableProperty()不同，默认情况下为true。
        另请参见：
        isEditable() ， setEditable(boolean)

    • 字段详细信息

      • DEFAULT_COMPARATOR

        public static final Comparator DEFAULT_COMPARATOR
        默认情况下，所有列将使用此比较器执行排序。 该比较器仅执行空检查，并检查对象是否为Comparable 。 如果是，则调用Comparable.compareTo(java.lang.Object)方法，否则该方法将推迟到Collator.compare(java.lang.String, java.lang.String) 。

    • 构造方法详细信息

      • TableColumnBase

        protected TableColumnBase​()
        使用默认单元格工厂，比较器和onEditCommit实现创建默认的TableColumn。

      • TableColumnBase

        protected TableColumnBase​(String text)
        创建一个TableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。
        参数
        text - 当TableColumn放置在TableView中时显示的字符串。

    • 方法详细信息

      • textProperty

        public final StringProperty textProperty​()
        这是此列的标题中显示的文本。
        另请参见：
        getText() ， setText(String)

      • setText

        public final void setText​(String value)
        设置属性文本的值。
        Property description:
        这是此列的标题中显示的文本。

      • getText

        public final String getText​()
        获取属性文本的值。
        Property description:
        这是此列的标题中显示的文本。

      • setVisible

        public final void setVisible​(boolean value)
        设置属性的值可见。
        Property description:
        切换此项将立即切换此列和所有子列的可见性。

      • isVisible

        public final boolean isVisible​()
        获取属性的值可见。
        Property description:
        切换此项将立即切换此列和所有子列的可见性。

      • visibleProperty

        public final BooleanProperty visibleProperty​()
        切换此项将立即切换此列和所有子列的可见性。
        另请参见：
        isVisible() ， setVisible(boolean)

      • getParentColumn

        public final TableColumnBase<S,?> getParentColumn​()
        获取属性parentColumn的值。
        Property description:
        在使用嵌套列的情况下，此只读属性将始终引用此列的父级。

        在当前存在的子类中，创建嵌套列只是将相关的TableColumnBase实例放在ObservableList列中的一个问题（例如，参见TableColumn.getColumns()和TreeTableColumn.getColumns()） 。

      • parentColumnProperty

        public final ReadOnlyObjectProperty<TableColumnBase<S,?>> parentColumnProperty​()
        在使用嵌套列的情况下，此只读属性将始终引用此列的父级。

        在当前现有的子类中，创建嵌套列只是将相关TableColumnBase实例放在ObservableList列中的一个问题（例如，参见TableColumn.getColumns()和TreeTableColumn.getColumns()） 。

        另请参见：
        getParentColumn()

      • setContextMenu

        public final void setContextMenu​(ContextMenu value)
        设置属性contextMenu的值。
        Property description:
        当用户右键单击此TableColumnBase的标题区域时，将显示此菜单。

      • getContextMenu

        public final ContextMenu getContextMenu​()
        获取属性contextMenu的值。
        Property description:
        当用户右键单击此TableColumnBase的标题区域时，将显示此菜单。

      • contextMenuProperty

        public final ObjectProperty<ContextMenu> contextMenuProperty​()
        当用户右键单击此TableColumnBase的标题区域时，将显示此菜单。
        另请参见：
        getContextMenu() ， setContextMenu(ContextMenu)

      • setId

        public final void setId​(String value)
        设置属性id的值。
        Property description:
        此TableColumnBase的ID。 这个简单的字符串标识符可用于在使用TableColumnBase实例的UI控件中查找特定的TableColumnBase。 默认值为null 。
        Default value:
        空值

      • getId

        public final String getId​()
        获取属性ID的值。
        Specified by:
        getId在接口 Styleable
        Property description:
        此TableColumnBase的ID。 这个简单的字符串标识符可用于在使用TableColumnBase实例的UI控件中查找特定的TableColumnBase。 默认值为null 。
        Default value:
        空值
        结果
        该 Styleable为 Styleable

      • idProperty

        public final StringProperty idProperty​()
        此TableColumnBase的ID。 这个简单的字符串标识符可用于在使用TableColumnBase实例的UI控件中查找特定的TableColumnBase。 默认值为null 。
        Default value:
        空值
        另请参见：
        getId() ， setId(String)

      • setStyle

        public final void setStyle​(String value)
        设置属性样式的值。
        Property description:
        与此TableColumnBase实例相关联的CSS样式的字符串表示形式。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。

        在某些有限的平台上可能不支持解析此样式。 建议使用独立的CSS文件。

        Default value:
        空字符串

      • getStyle

        public final String getStyle​()
        获取属性样式的值。
        Specified by:
        getStyle在接口 Styleable
        Property description:
        与此TableColumnBase实例相关联的CSS样式的字符串表示形式。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。

        在某些有限的平台上可能不支持解析此样式。 建议使用独立的CSS文件。

        Default value:
        空字符串
        结果
        与此特定的 Node相关联的CSS样式的字符串表示 Node

      • styleProperty

        public final StringProperty styleProperty​()
        与此TableColumnBase实例相关联的CSS样式的字符串表示形式。 这类似于HTML元素的“样式”属性。 请注意，像HTML样式属性一样，此变量包含样式属性和值，而不包含样式规则的选择器部分。

        在某些有限的平台上可能不支持解析此样式。 建议使用独立的CSS文件。

        Default value:
        空字符串
        另请参见：
        getStyle() ， setStyle(String)

      • getStyleClass

        public ObservableList<String> getStyleClass​()
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。 该变量类似于HTML元素上的“类”属性，因此列表的每个元素都是此节点所属的样式类。
        Specified by:
        getStyleClass在接口 Styleable
        结果
        可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎
        另请参见：
        CSS3 class selectors

      • setGraphic

        public final void setGraphic​(Node value)
        设置属性图形的值。
        Property description:

        在表列中显示的图形，以允许用户以图形方式指示列中的内容。

      • getGraphic

        public final Node getGraphic​()
        获取属性图形的值。
        Property description:

        在表列中显示的图形，以允许用户以图形方式指示列中的内容。

      • graphicProperty

        public final ObjectProperty<Node> graphicProperty​()

        在表列中显示的图形，以允许用户以图形方式指示列中的内容。

        另请参见：
        getGraphic() ， setGraphic(Node)

      • setSortNode

        public final void setSortNode​(Node value)
        设置属性sortNode的值。
        Property description:

        用作“排序箭头”的节点，在表列是排序顺序的一部分的情况下向用户显示。 它可能是排序顺序中唯一的项目，或者它可能是次要，三级或后一种排序项目，并且节点应该可视化地反映出来。 这仅在表列处于排序顺序的情况下使用（参见，例如， TableView.getSortOrder()和TreeTableView.getSortOrder() ）。 如果未指定，则表列皮肤实现负责提供默认排序节点。

        排序节点通常被视为在屏幕上旋转以指示表列是否是排序顺序的一部分的三角形，如果是，排序是升序还是降序，以及排序顺序中的位置。

      • getSortNode

        public final Node getSortNode​()
        获取属性sortNode的值。
        Property description:

        用作“排序箭头”的节点，在表列是排序顺序的一部分的情况下向用户显示。 它可能是排序顺序中唯一的项目，或者它可能是次要，三级或后一种排序项目，并且节点应该可视化地反映出来。 这仅在表列处于排序顺序的情况下使用（参见，例如， TableView.getSortOrder()和TreeTableView.getSortOrder() ）。 如果未指定，则表列皮肤实现负责提供默认排序节点。

        排序节点通常被视为在屏幕上旋转以指示表列是否是排序顺序的一部分的三角形，如果是，排序是升序还是降序，以及排序顺序中的位置。

      • sortNodeProperty

        public final ObjectProperty<Node> sortNodeProperty​()

        用作“排序箭头”的节点，在表列是排序顺序的一部分的情况下向用户显示。 它可能是排序顺序中唯一的项目，或者它可能是次要，三级或后一种排序项目，并且节点应该可视化地反映出来。 这仅在表列处于排序顺序的情况下使用（参见，例如， TableView.getSortOrder()和TreeTableView.getSortOrder() ）。 如果未指定，则表列皮肤实现负责提供默认排序节点。

        排序节点通常被视为在屏幕上旋转以指示表列是否是排序顺序的一部分的三角形，如果是，排序是升序还是降序，以及排序顺序中的位置。

        另请参见：
        getSortNode() ， setSortNode(Node)

      • widthProperty

        public final ReadOnlyDoubleProperty widthProperty​()
        此列的宽度。 修改此操作将导致列宽可视化调整。 建议不要将此属性绑定到外部属性，因为这将导致用户通过拖动列标题的左右边框不能调整列宽。
        另请参见：
        getWidth()

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        此列的宽度。 修改此操作将导致列宽可视化调整。 建议不要将此属性绑定到外部属性，因为这将导致用户通过拖动列标题的左右边框不能调整列宽。

      • setMinWidth

        public final void setMinWidth​(double value)
        设置属性minWidth的值。
        Property description:
        允许表列调整大小的最小宽度。

      • getMinWidth

        public final double getMinWidth​()
        获取属性minWidth的值。
        Property description:
        允许表列调整大小的最小宽度。

      • minWidthProperty

        public final DoubleProperty minWidthProperty​()
        允许表列调整大小的最小宽度。
        另请参见：
        getMinWidth() ， setMinWidth(double)

      • prefWidthProperty

        public final DoubleProperty prefWidthProperty​()
        TableColumn的首选宽度。
        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • setPrefWidth

        public final void setPrefWidth​(double value)
        设置属性prefWidth的值。
        Property description:
        TableColumn的首选宽度。

      • getPrefWidth

        public final double getPrefWidth​()
        获取属性prefWidth的值。
        Property description:
        TableColumn的首选宽度。

      • maxWidthProperty

        public final DoubleProperty maxWidthProperty​()
        表列允许调整大小的最大宽度。
        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • setMaxWidth

        public final void setMaxWidth​(double value)
        设置属性maxWidth的值。
        Property description:
        表列允许调整大小的最大宽度。

      • getMaxWidth

        public final double getMaxWidth​()
        获取属性maxWidth的值。
        Property description:
        表列允许调整大小的最大宽度。

      • resizableProperty

        public final BooleanProperty resizableProperty​()
        用于指示此列的宽度是否可以更改。 然而，由大小调整政策来执行。
        另请参见：
        isResizable() ， setResizable(boolean)

      • setResizable

        public final void setResizable​(boolean value)
        设置属性可调整大小的值。
        Property description:
        用于指示此列的宽度是否可以更改。 然而，由大小调整政策来执行。

      • isResizable

        public final boolean isResizable​()
        获取属性可调整大小的值。
        Property description:
        用于指示此列的宽度是否可以更改。 然而，由大小调整政策来执行。

      • sortableProperty

        public final BooleanProperty sortableProperty​()

        用于打开和关闭此列的“可排序性”的布尔属性。 当此属性为true时，此列可以包含在排序操作中。 如果此属性为false，则不会将其包含在排序操作中，即使它包含在底层UI控件的排序顺序列表中（例如TableView.getSortOrder()或TreeTableView.getSortOrder() ）。

        例如，如果TableColumn实例包含在TableView sortOrder ObservableList中，并且其可排序属性将切换状态，则它将强制TableView执行排序，因为该视图可能需要更新。

        另请参见：
        isSortable() ， setSortable(boolean)

      • setSortable

        public final void setSortable​(boolean value)
        设置属性可分类的值。
        Property description:

        用于打开和关闭此列的“可排序性”的布尔属性。 当此属性为true时，此列可以包含在排序操作中。 如果此属性为false，即使它包含在底层UI控件的排序顺序列表（例如TableView.getSortOrder()或TreeTableView.getSortOrder() ）中，也不会包含在排序操作中。

        例如，如果TableColumn实例包含在TableView sortOrder ObservableList中，并且其可排序属性将切换状态，则它将强制TableView执行排序，因为该视图可能需要更新。

      • isSortable

        public final boolean isSortable​()
        获取属性可排序的值。
        Property description:

        用于打开和关闭此列的“可排序性”的布尔属性。 当此属性为true时，此列可以包含在排序操作中。 如果此属性为false，即使它包含在底层UI控件的排序顺序列表中（例如TableView.getSortOrder()或TreeTableView.getSortOrder() ）也不会包含在排序操作中。

        例如，如果TableColumn实例包含在TableView sortOrder ObservableList中，并且其可排序属性将切换状态，则它将强制TableView执行排序，因为该视图可能需要更新。

      • reorderableProperty

        public final BooleanProperty reorderableProperty​()
        一个布尔属性可以打开和关闭此列的“可重新排序”（通过修改适当的columns列表可以拖放 - 重新排序）。 当此属性为true时，用户可以通过将列拖放到所需的位置来重新排序此列。 当此属性为false时，这种拖放列的功能不可用。
        从以下版本开始：
        9
        另请参见：
        isReorderable() ， setReorderable(boolean)

      • setReorderable

        public final void setReorderable​(boolean value)
        设置属性可重新排序的值。
        Property description:
        一个布尔属性可以打开和关闭此列的“可重新排序”（通过修改适当的columns列表进行拖放 - 重新排序）始终是允许的）。 当此属性为true时，用户可以通过将列拖放到所需的位置来重新排序此列。 当此属性为false时，这种拖放列的功能不可用。
        从以下版本开始：
        9

      • isReorderable

        public final boolean isReorderable​()
        获取属性可重新排序的值。
        Property description:
        用于打开和关闭此列的“可重新排序”的布尔属性（通过修改适当的columns列表进行拖放 - 重新排序）始终是允许的）。 当此属性为true时，用户可以通过将列拖放到所需的位置来重新排序此列。 当此属性为false时，这种拖放列的功能不可用。
        从以下版本开始：
        9

      • comparatorProperty

        public final ObjectProperty<Comparator<T>> comparatorProperty​()
        排序此表列时使用的比较器功能。 作为参数给出的两个对象是此列中两个单独单元格的单元格数据。
        另请参见：
        getComparator() ， setComparator(Comparator)

      • setComparator

        public final void setComparator​(Comparator<T> value)
        设置属性比较器的值。
        Property description:
        排序此表列时使用的比较器功能。 作为参数给出的两个对象是此列中两个单独单元格的单元格数据。

      • getComparator

        public final Comparator<T> getComparator​()
        获取属性比较器的值。
        Property description:
        排序此表列时使用的比较器功能。 作为参数给出的两个对象是此列中两个单独单元格的单元格数据。

      • setEditable

        public final void setEditable​(boolean value)
        设置属性可编辑的值。
        Property description:
        指定此表列是否允许编辑。 这与TableView.editableProperty()和TreeTableView.editableProperty()不同，默认情况下为true。

      • isEditable

        public final boolean isEditable​()
        获取可编辑属性的值。
        Property description:
        指定此表列是否允许编辑。 这与TableView.editableProperty()和TreeTableView.editableProperty()不同，默认情况下为true。

      • editableProperty

        public final BooleanProperty editableProperty​()
        指定此表列是否允许编辑。 这与TableView.editableProperty()和TreeTableView.editableProperty()不同，默认情况下为true。
        另请参见：
        isEditable() ， setEditable(boolean)

      • getProperties

        public final ObservableMap<Object,Object> getProperties​()
        返回此表列上属性的可观察图，主要由应用程序开发人员使用。
        结果
        这个表列的属性的可观察图，主要由应用程序开发人员使用

      • hasProperties

        public boolean hasProperties​()
        测试此表列是否具有属性。
        结果
        如果节点有属性，则为true。

      • setUserData

        public void setUserData​(Object value)
        用于设置可以在以后检索的单个Object属性的便利方法。 这在功能上等同于调用getProperties（）。put（Object key，Object value）方法。 这可以稍后通过调用getUserData()来检索。
        参数
        value - 要存储的值 - 以后可以通过调用 getUserData()来检索。

      • getUserData

        public Object getUserData​()
        返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
        结果
        先前设置的对象，如果没有设置属性或设置为null，则为null。

      • getColumns

        public abstract ObservableList<? extends TableColumnBase<S,?>> getColumns​()
        这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。 例如，我们可能有一个“名称”列，其中包含“First”和“Last”名称的两个嵌套列。

        这对于这样没有影响 - 所有列索引仅指向叶子列，并且不可能使用父列进行排序，只能使用叶列。 换句话说，这纯粹是一个视觉特征。

        结果
        一个包含TableColumnBase实例（或子类）的ObservableList，它是此TableColumnBase的子项。 如果这些孩子的TableColumnBase实例设置为可见，它们将显示在此表列下方。

      • getCellData

        public final T getCellData​(int index)
        返回给定行索引（并且属于此表列）的单元格的实际值。
        参数
        index - 需要数据的行索引。
        结果
        属于该给定行索引和该表的这个方法所调用的表列的交点处的单元格的数据。

      • getCellData

        public final T getCellData​(S item)
        从给定项返回单元格的实际值。
        参数
        item - 应从中提取类型T值的项目。
        结果
        基于作为参数传入的项目，该列中特定单元格中应使用的数据。

      • getCellObservableValue

        public abstract ObservableValue<T> getCellObservableValue​(int index)
        尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。 换句话说，该方法期望接收大于或等于零且小于底层数据模型大小的整数值。 如果索引有效，此方法将返回此特定列的ObservableValue <T>。

        这可以通过调用cell value factory来实现，当通过一个CellDataFeatures （参见例如CellDataFeatures类属于TableColumn和TreeTableColumn）以获取更多信息时返回）。

        参数
        index - 寻求ObservableValue <T>的项目（S型）的索引。
        结果
        此特定表列的ObservableValue <T>。

      • getCellObservableValue

        public abstract ObservableValue<T> getCellObservableValue​(S item)
        尝试返回给定项目（其类型为S）的ObservableValue <T>。 换句话说，该方法期望从表中的整个“行”的底层数据模型接收一个对象，并且必须返回该特定列中的值的ObservableValue <T>。

        这可以通过调用cell value factory来实现，当通过一个CellDataFeatures （参见例如CellDataFeatures类属于TableColumn和TreeTableColumn）以获取更多信息）时返回。

        参数
        item - 寻找一个ObservableValue <T>的项目（S型）。
        结果
        此特定表列的ObservableValue <T>。

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此目标构建事件调度链。 事件调度链包含可能对处理针对EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要为链接添加一个自己的EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 建立起来的初始链
        结果
        此目标的结果事件调度链

      • addEventHandler

        public <E extends Event> void addEventHandler​(EventType<E> eventType,
                                              EventHandler<E> eventHandler)
        在此表列中注册一个事件处理程序。 TableColumnBase类允许注册监听器，编辑时将会通知它们。 但是请注意，TableColumnBase 不是一个节点，因此没有触发视觉事件。
        参数类型
        E - 事件的类型
        参数
        eventType - 处理程序接收事件的类型
        eventHandler - 要注册的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • removeEventHandler

        public <E extends Event> void removeEventHandler​(EventType<E> eventType,
                                                 EventHandler<E> eventHandler)
        从此表列中注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        参数类型
        E - 事件的类型
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • getPseudoClassStates

        public final ObservableSet<PseudoClass> getPseudoClassStates​()
        返回此Styleable的伪类状态。 CSS假定此集是只读的。
        Specified by:
        getPseudoClassStates在接口 Styleable
        结果
        伪类状态
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TableFocusModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableFocusModel<T,TC extends TableColumnBase<T,?>>

  • java.lang.Object
    • javafx.scene.control.FocusModel<T>
      • javafx.scene.control.TableFocusModel<T,TC>
  • 参数类型
    T - UI控件的基础数据模型的类型。
    TC - 由底层UI控件使用的TableColumnBase的具体子类（例如TableColumn或TreeTableColumn） 。
    已知直接子类：
    TableView.TableViewFocusModel ， TreeTableView.TreeTableViewFocusModel

    public abstract class TableFocusModel<T,TC extends TableColumnBase<T,?>>
extends FocusModel<T>
    FocusModel实现的抽象基类在表状控件中使用（最着名的是TableView和TreeTableView） 。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      • Properties inherited from class javafx.scene.control.FocusModel

        focusedIndex, focusedItem

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableFocusModel​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract void focus​(int row, TC column)
      导致给定索引处的项目接收焦点。
      abstract void focusAboveCell​()
      尝试将焦点移动到当前聚焦单元格上方的单元格。
      abstract void focusBelowCell​()
      尝试将焦点移动到当前聚焦单元格下方的单元格。
      abstract void focusLeftCell​()
      尝试将焦点移动到当前聚焦单元格左侧的单元格。
      abstract void focusRightCell​()
      尝试将焦点移动到当前聚焦单元格右侧的单元格。
      abstract boolean isFocused​(int row, TC column)
      测试给定位置的行/单元格是否在UI控件内具有焦点。

      • Methods inherited from class javafx.scene.control.FocusModel

        focus, focusedIndexProperty, focusedItemProperty, focusNext, focusPrevious, getFocusedIndex, getFocusedItem, getItemCount, getModelItem, isFocused

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TableFocusModel

        public TableFocusModel​()

    • 方法详细信息

      • focus

        public abstract void focus​(int row,
                           TC column)
        导致给定索引处的项目接收焦点。
        参数
        row - 要给予关注的项目的行索引。
        column - 要专注的项目的列。 可以为null。

      • isFocused

        public abstract boolean isFocused​(int row,
                                  TC column)
        测试给定位置的行/单元格是否在UI控件内具有焦点。
        参数
        row - 行
        column - 列
        结果
        如果给定位置的行/单元格当前具有UI控件内的焦点，则为true

      • focusAboveCell

        public abstract void focusAboveCell​()
        尝试将焦点移动到当前聚焦单元格上方的单元格。

      • focusBelowCell

        public abstract void focusBelowCell​()
        尝试将焦点移动到当前聚焦单元格下方的单元格。

      • focusLeftCell

        public abstract void focusLeftCell​()
        尝试将焦点移动到当前聚焦单元格左侧的单元格。

      • focusRightCell

        public abstract void focusRightCell​()
        尝试将焦点移动到当前聚焦单元格右侧的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TablePosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TablePosition<S,T>

  • java.lang.Object
    • javafx.scene.control.TablePositionBase<TableColumn<S,T>>
      • javafx.scene.control.TablePosition<S,T>
  • 参数类型
    S - TableView中包含的项目的类型（即与TableView <S>中的S相同的通用类型）。
    T - TableColumn中包含的项目的类型。

    public class TablePosition<S,T>
extends TablePositionBase<TableColumn<S,T>>
    此类用于表示TableView中的单个行/列/单元格。 这在TableView API中用于表示当前选择，聚焦，编辑等行/列/单元格。请注意，创建该类之后，该类是不可变的。

    因为TableView可以具有不同的selection modes ，所以TablePosition中的行和列属性可以被禁用来表示整个行或列。 这是通过将unrequired属性设置为-1或null来完成的。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TableView ， TableColumn

    • 构造方法摘要

      构造方法
      Constructor 描述
      TablePosition​(TableView<S> tableView, int row, TableColumn<S,T> tableColumn)
      构造一个TablePosition实例来表示给定TableView实例中给定的行/列位置。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getColumn​()
      Table Table在TableView中表示的列索引。
      TableColumn<S,T> getTableColumn​()
      Table Table在TableView中表示的TableColumn。
      TableView<S> getTableView​()
      TableView这个TablePosition是相关的。
      String toString​()
      返回此 TablePosition对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.control.TablePositionBase

        equals, getRow, hashCode

    • 构造方法详细信息

      • TablePosition

        public TablePosition​(TableView<S> tableView,
                     int row,
                     TableColumn<S,T> tableColumn)
        构造一个TablePosition实例来表示给定TableView实例中给定的行/列位置。 在这个类中，TableView和TableColumn都被弱引用，所以当调用它们各自的getter时，它们可能是null。
        参数
        tableView - TableView这个位置是相关的。
        row - 此TablePosition表示的行。
        tableColumn - 此TablePosition表示的TableColumn实例。

    • 方法详细信息

      • getColumn

        public int getColumn​()
        Table Table在TableView中表示的列索引。 如果TableView或TableColumn实例在类实例化时为空（即在构造时计算），则为-1。
        Specified by:
        getColumn在 TablePositionBase<TableColumn<S,T>>
        结果
        该TablePosition在TableView中表示的列索引

      • getTableView

        public final TableView<S> getTableView​()
        TableView这个TablePosition是相关的。
        结果
        TableView

      • getTableColumn

        public final TableColumn<S,T> getTableColumn​()
        Table Table在TableView中表示的TableColumn。
        重写：
        getTableColumn在 TablePositionBase<TableColumn<S,T>>
        结果
        Table Table在TableView中表示的TableColumn

      • toString

        public String toString​()
        返回此 TablePosition对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of this TablePosition object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TablePositionBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TablePositionBase<TC extends TableColumnBase>

  • java.lang.Object
    • javafx.scene.control.TablePositionBase<TC>
  • 已知直接子类：
    TablePosition ， TreeTablePosition

    public abstract class TablePositionBase<TC extends TableColumnBase>
extends Object
    此类用于表示表中的单个行/列/单元格。 这个抽象类的具体子类用于TableView和TreeTableView API中，用于表示当前选择，聚焦，编辑等行/列/单元格。注意，创建该类后，该类是不可变的。

    因为TableView和TreeTableView控件可以具有不同的selection modes ，所以TablePositionBase中的行和列属性可以被禁用来表示整个行或列。 这是通过将unrequired属性设置为-1或null来完成的。

    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TablePosition ， TreeTablePosition

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected TablePositionBase​(int row, TC tableColumn)
      构造一个TablePositionBase实例来表示底层表实例中的给定行/列位置（它不是抽象TablePositionBase类的一部分，而是具体子类的一部分，如TablePosition和TreeTablePosition ）。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      abstract int getColumn​()
      Table Table在TableView中表示的列索引。
      int getRow​()
      TablePosition在TableView中表示的行。
      TC getTableColumn​()
      Table Table在TableView中表示的TableColumn。
      int hashCode​()
      返回此 TablePosition对象的哈希码。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TablePositionBase

        protected TablePositionBase​(int row,
                            TC tableColumn)
        构造一个TablePositionBase实例来表示底层表实例中的给定行/列位置（它不是抽象TablePositionBase类的一部分，而是具体子类的一部分，如TablePosition和TreeTablePosition ）。 在所有情况下，TablePositionBase实例中的所有字段都被弱引用，以防止内存泄漏。 这意味着get方法可能（但不太可能）返回null。
        参数
        row - 此TablePosition表示的行。
        tableColumn - TablePosition表示的TableColumn实例。

    • 方法详细信息

      • getRow

        public int getRow​()
        TablePosition在TableView中表示的行。
        结果
        TablePosition在TableView中表示的行

      • getColumn

        public abstract int getColumn​()
        Table Table在TableView中表示的列索引。 如果TableView或TableColumn实例为空，则为-1。
        结果
        该TablePosition在TableView中表示的列索引

      • getTableColumn

        public TC getTableColumn​()
        Table Table在TableView中表示的TableColumn。
        结果
        Table Table在TableView中表示的TableColumn

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象等于obj参数; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 TablePosition对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 TablePosition对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableRow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableRow<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TableRow<T>
  • 参数类型
    T - 单元格中包含的项目的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class TableRow<T>
extends IndexedCell<T>

    TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。 如果他们希望创建一个替换TableView整个行的自定义的rowFactory ，那么开发人员可能只会遇到TableRow。

    通常情况下，开发人员更容易定制行中的单个单元格，而不是整行。 为此，您可以在每个TableColumn实例上指定自定义的cellFactory 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TableView ， TableColumn ， TableCell ， IndexedCell ， Cell

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<TableView<T>> tableView
      与此Cell关联的TableView。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableRow​()
      构造一个具有“table-row-cell”样式类的默认TableRow实例

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      TableView<T> getTableView​()
      获取属性tableView的值。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      ReadOnlyObjectProperty<TableView<T>> tableViewProperty​()
      与此Cell关联的TableView。
      void updateTableView​(TableView<T> tv)
      更新与TableCell相关联的TableView。

      • Methods inherited from class javafx.scene.control.Cell

        cancelEdit, commitEdit, editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, startEdit, updateItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • tableView

        public final ReadOnlyObjectProperty<TableView<T>> tableViewProperty
        与此Cell关联的TableView。
        结果
        与此Cell相关的TableView

    • 构造方法详细信息

      • TableRow

        public TableRow​()
        构造一个具有“table-row-cell”样式类的默认TableRow实例

    • 方法详细信息

      • getTableView

        public final TableView<T> getTableView​()
        获取属性tableView的值。
        Property description:
        *属性* *

      • tableViewProperty

        public final ReadOnlyObjectProperty<TableView<T>> tableViewProperty​()
        与此Cell关联的TableView。
        结果
        与此Cell相关的TableView

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • updateTableView

        public final void updateTableView​(TableView<T> tv)
        更新与TableCell相关联的TableView。 当TableCell首次添加到TableView时，通常只执行一次。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        tv - TableView

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableSelectionModel<T>

  • java.lang.Object
    • javafx.scene.control.SelectionModel<T>
      • javafx.scene.control.MultipleSelectionModel<T>
        • javafx.scene.control.TableSelectionModel<T>
  • 参数类型
    T - UI控件的基础数据模型的类型。
    已知直接子类：
    TableView.TableViewSelectionModel ， TreeTableView.TreeTableViewSelectionModel

    public abstract class TableSelectionModel<T>
extends MultipleSelectionModel<T>
    在表类控件中使用的MultipleSelectionModel实现的抽象基类（最着名的是TableView和TreeTableView） 。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty cellSelectionEnabled
      一个布尔属性，用于表示表是行还是单元格选择模式。

      • Properties inherited from class javafx.scene.control.MultipleSelectionModel

        selectionMode

      • Properties inherited from class javafx.scene.control.SelectionModel

        selectedIndex, selectedItem

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableSelectionModel​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      BooleanProperty cellSelectionEnabledProperty​()
      一个布尔属性，用于表示表是行还是单元格选择模式。
      void clearAndSelect​(int row)
      在将选择设置为给定索引之前清除任何选择的方法。
      abstract void clearAndSelect​(int row, TableColumnBase<T,?> column)
      清除所有选择，然后选择给定行/列交点处的单元格。
      void clearSelection​()
      清除所有选定索引的选择模型。
      void clearSelection​(int index)
      该方法将清除给定索引中项目的选择。
      abstract void clearSelection​(int row, TableColumnBase<T,?> column)
      从指定的行/列位置（视图索引）中移除选择。
      protected abstract void | focus​(int index)
      protected abstract int | getFocusedIndex​()
      protected abstract int getItemCount​()
      返回数据模型中支配控件的项目数。
      protected abstract T getModelItem​(int index)
      返回给定索引处的项目。
      ObservableList<Integer> getSelectedIndices​()
      返回所有选定索引的 只读 ObservableList。
      ObservableList<T> getSelectedItems​()
      返回所有选定项目的 只读 ObservableList。
      boolean isCellSelectionEnabled​()
      获取属性cellSelectionEnabled的值。
      boolean isEmpty​()
      该方法可用于测试是否有任何选定的索引/项目。
      boolean isSelected​(int index)
      通知此SelectionModel中当前选定给定索引的方便方法。
      abstract boolean isSelected​(int row, TableColumnBase<T,?> column)
      测试在此表实例中当前是否选择给定行和列索引的便利函数。
      void select​(int row)
      这将在选择模型中选择给定的索引，假设索引在有效范围内（即大于或等于零，并且小于底层数据模型中的项目总数）。
      void select​(T obj)
      此方法将尝试选择包含给定对象的索引。
      abstract void select​(int row, TableColumnBase<T,?> column)
      选择给定的行/列交叉点的单元格。
      abstract void selectAboveCell​()
      选择当前所选单元格正上方的单元格。
      void selectAll​()
      方便的方法来选择所有可用的索引。
      abstract void selectBelowCell​()
      选择当前选定单元格正下方的单元格。
      void selectFirst​()
      该方法将尝试选择控件中的第一个索引。
      void selectIndices​(int row, int... rows)
      该方法允许同时设置一个或多个选择。
      void selectLast​()
      此方法将尝试选择控件中的最后一个索引。
      abstract void selectLeftCell​()
      选择当前所选单元格左侧的单元格。
      void selectNext​()
      此方法将尝试在当前焦点索引之后直接选择索引。
      void selectPrevious​()
      此方法将尝试直接在当前聚焦索引之前选择索引。
      abstract void selectRange​(int minRow, TableColumnBase<T,?> minColumn, int maxRow, TableColumnBase<T,?> maxColumn)
      选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。
      abstract void selectRightCell​()
      选择当前所选单元格右侧的单元格。
      void setCellSelectionEnabled​(boolean value)
      设置属性cellSelectionEnabled的值。

      • Methods inherited from class javafx.scene.control.MultipleSelectionModel

        getSelectionMode, selectionModeProperty, selectRange, setSelectionMode

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SelectionModel

        getSelectedIndex, getSelectedItem, selectedIndexProperty, selectedItemProperty, setSelectedIndex, setSelectedItem

    • Property Detail

      • cellSelectionEnabled

        public final BooleanProperty cellSelectionEnabledProperty
        一个布尔属性，用于表示表是行还是单元格选择模式。 默认情况下，表处于行选择模式，这意味着无法选择单个单元格。 设置cellSelectionEnabled在单元格能够被选择（但不是行）中是真实的结果。
        另请参见：
        isCellSelectionEnabled() ， setCellSelectionEnabled(boolean)

    • 构造方法详细信息

      • TableSelectionModel

        public TableSelectionModel​()

    • 方法详细信息

      • isSelected

        public abstract boolean isSelected​(int row,
                                   TableColumnBase<T,?> column)
        测试在此表实例中当前是否选择给定行和列索引的便利函数。 如果表控件处于其“单元格选择”模式（可以选择单个单元格而不是整个行），并且如果列参数为空，则只有在给定行中的所有单元格被选中时，此方法才应返回true。
        参数
        row - 行
        column - 列
        结果
        如果当前在此表实例中选择了给定的行和列索引，则为true

      • select

        public abstract void select​(int row,
                            TableColumnBase<T,?> column)
        选择给定的行/列交叉点的单元格。 如果表控件处于其“单元格选择”模式（可以选择单个单元格而不是整行），并且如果列参数为空，则此方法应选择给定行中的所有单元格。
        参数
        row - 行
        column - 列

      • clearAndSelect

        public abstract void clearAndSelect​(int row,
                                    TableColumnBase<T,?> column)
        清除所有选择，然后选择给定行/列交点处的单元格。 如果表控件处于其“单元格选择”模式（可以选择单个单元格而不是整行），并且如果列参数为空，则此方法应选择给定行中的所有单元格。
        参数
        row - 行
        column - 列

      • clearSelection

        public abstract void clearSelection​(int row,
                                    TableColumnBase<T,?> column)
        从指定的行/列位置（视图索引）中移除选择。 如果没有选择这个特定的单元格（如果列值为-1），则不会发生任何事情。 如果表格控件处于其“单元格选择”模式（可以选择单个单元格而不是整个行），并且如果列参数为空，则此方法应取消选择给定行中的所有单元格。
        参数
        row - 行
        column - 列

      • selectLeftCell

        public abstract void selectLeftCell​()
        选择当前所选单元格左侧的单元格。

      • selectRightCell

        public abstract void selectRightCell​()
        选择当前所选单元格右侧的单元格。

      • selectAboveCell

        public abstract void selectAboveCell​()
        选择当前所选单元格正上方的单元格。

      • selectBelowCell

        public abstract void selectBelowCell​()
        选择当前选定单元格正下方的单元格。

      • selectRange

        public abstract void selectRange​(int minRow,
                                 TableColumnBase<T,?> minColumn,
                                 int maxRow,
                                 TableColumnBase<T,?> maxColumn)
        选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。
        参数
        minRow - minRow
        minColumn - minColumn
        maxRow - maxRow
        maxColumn - maxColumn

      • cellSelectionEnabledProperty

        public final BooleanProperty cellSelectionEnabledProperty​()
        一个布尔属性，用于表示表是行还是单元格选择模式。 默认情况下，表处于行选择模式，这意味着无法选择单个单元格。 设置cellSelectionEnabled在能够被选择（但不是行）的单元格中是真实的结果。
        另请参见：
        isCellSelectionEnabled() ， setCellSelectionEnabled(boolean)

      • setCellSelectionEnabled

        public final void setCellSelectionEnabled​(boolean value)
        设置属性cellSelectionEnabled的值。
        Property description:
        一个布尔属性，用于表示表是行还是单元格选择模式。 默认情况下，表处于行选择模式，这意味着无法选择单个单元格。 设置cellSelectionEnabled在能够被选择（但不是行）的单元格中是真实的结果。

      • isCellSelectionEnabled

        public final boolean isCellSelectionEnabled​()
        获取属性cellSelectionEnabled的值。
        Property description:
        一个布尔属性，用于表示表是行还是单元格选择模式。 默认情况下，表处于行选择模式，这意味着无法选择单个单元格。 设置cellSelectionEnabled在能够被选择（但不是行）的单元格中是真实的结果。

      • getSelectedIndices

        public ObservableList<Integer> getSelectedIndices​()
        描述从类复制： MultipleSelectionModel

        返回所有选定索引的只读 ObservableList。 ObservableList将由选择模型更新以始终反映选择的变化。 这可以通过向返回的ObservableList添加一个ListChangeListener来观察。

        Specified by:
        getSelectedIndices在 MultipleSelectionModel<T>
        结果
        所选索引的列表

      • getSelectedItems

        public ObservableList<T> getSelectedItems​()
        描述从类复制： MultipleSelectionModel

        返回所有选定项目的只读 ObservableList。 ObservableList将通过选择模型进一步更新以始终反映选择的变化。 这可以通过向返回的ObservableList添加一个ListChangeListener来观察。

        Specified by:
        getSelectedItems在 MultipleSelectionModel<T>
        结果
        所选项目的列表

      • getItemCount

        protected abstract int getItemCount​()
        返回数据模型中支配控件的项目数。 一个例子就是ListView选择模型可能会返回listView.getItems().size() 。 可选索引的有效范围在0和此方法返回的任何值之间。
        结果
        支持控制的数据模型中的项目数

      • getModelItem

        protected abstract T getModelItem​(int index)
        返回给定索引处的项目。 使用ListView的示例将为listView.getItems().get(index) 。
        参数
        index - 从底层数据模型请求的项目的索引。
        结果
        如果索引超出范围，则返回null，或者与给定索引相关的类型T的元素。

      • focus

        protected abstract void focus​(int index)

      • getFocusedIndex

        protected abstract int getFocusedIndex​()

      • clearAndSelect

        public void clearAndSelect​(int row)
        描述从类复制： SelectionModel
        在将选择设置为给定索引之前清除任何选择的方法。 该方法的目的是避免首先调用SelectionModel.clearSelection() ，这意味着正在监听selected index属性的观察者将不会将所选索引临时设置为-1。
        Specified by:
        clearAndSelect在 SelectionModel<T>
        参数
        row - 应该是此选择模型中唯一选择的索引的索引。

      • select

        public void select​(int row)
        描述从类复制： SelectionModel

        这将在选择模型中选择给定的索引，假设索引在有效范围内（即大于或等于零，并且小于底层数据模型中的项目总数）。

        如果在此模型中已经选择了一个或多个索引，调用此方法将不会清除这些选择 - 为此，有必要首先调用SelectionModel.clearSelection() 。

        如果索引已被选中，则不会再次选择或未选择。 然而，如果实现了多个选择，则对已经选择的索引进行调用select将使索引成为新的所选索引（由SelectionModel.getSelectedIndex()返回）。

        Specified by:
        select在 SelectionModel<T>
        参数
        row - 要在选择模型中选择的项目的位置。

      • select

        public void select​(T obj)
        描述从类别复制： SelectionModel

        此方法将尝试选择包含给定对象的索引。 它将遍历底层数据模型，直到找到一个值等于给定对象的项。 在这一点上它将停止迭代 - 这意味着该方法将不会选择多个索引。

        Specified by:
        select在 SelectionModel<T>
        参数
        obj - 要在底层数据模型中选择的对象。

      • selectIndices

        public void selectIndices​(int row,
                          int... rows)
        描述从类复制： MultipleSelectionModel

        该方法允许同时设置一个或多个选择。 它将忽略不在有效范围内的任何值（即大于或等于零，小于底层数据模型中的项目总数）。 任何重复的索引都将被忽略。

        如果在此模型中已经选择了一个或多个索引，则调用此方法将不会清除这些选择 - 为此，必须首先调用clearSelection。

        给定的最后一个有效值将成为所选择的索引/选定项目。

        Specified by:
        selectIndices在 MultipleSelectionModel<T>
        参数
        row - 第一个索引选择
        rows - 零个或多个附加索引进行选择

      • selectAll

        public void selectAll​()
        描述从类复制： MultipleSelectionModel

        方便的方法来选择所有可用的索引。

        Specified by:
        selectAll在 MultipleSelectionModel<T>

      • selectFirst

        public void selectFirst​()
        描述从类复制MultipleSelectionModel

        该方法将尝试选择控件中的第一个索引。 如果首先不调用clearSelection，则该方法将具有选择第一个索引的结果，同时保留对当前其他任何索引的选择。

        如果已经选择了第一个索引，调用此方法将不会产生任何结果，并且不会执行选择事件。

        Specified by:
        selectFirst在 MultipleSelectionModel<T>

      • selectLast

        public void selectLast​()
        描述从类复制： MultipleSelectionModel

        此方法将尝试选择控件中的最后一个索引。 如果没有首先调用clearSelection，则该方法将具有选择最后一个索引的结果，同时保留对其他当前选定索引的选择。

        如果最后一个索引已经被选中，调用该方法将不会有结果，并且不会发生选择事件。

        Specified by:
        selectLast在 MultipleSelectionModel<T>

      • clearSelection

        public void clearSelection​(int index)
        描述从类复制： SelectionModel

        该方法将清除给定索引中项目的选择。 如果没有选择给定的索引，则不会发生任何事情。

        Specified by:
        clearSelection在 SelectionModel<T>
        参数
        index - 要取消选择的选定项目。

      • clearSelection

        public void clearSelection​()
        描述从类复制： SelectionModel

        清除所有选定索引的选择模型。

        Specified by:
        clearSelection在 SelectionModel<T>

      • isSelected

        public boolean isSelected​(int index)
        描述从类复制： SelectionModel

        通知此SelectionModel中当前选定给定索引的方便方法。 在功能上相当于调用getSelectedIndices().contains(index) 。

        Specified by:
        isSelected在 SelectionModel<T>
        参数
        index - 检查当前是否选择的索引。
        结果
        如果给定的索引被选择，则为真，否则为false。

      • isEmpty

        public boolean isEmpty​()
        描述从类复制： SelectionModel
        该方法可用于测试是否有任何选定的索引/项目。 如果没有选定的项目，它将返回true，如果有，则返回false。
        Specified by:
        isEmpty在 SelectionModel<T>
        结果
        如果 没有选择的项目将返回true，如果有的话将返回false。

      • selectPrevious

        public void selectPrevious​()
        描述从类复制： SelectionModel

        此方法将尝试直接在当前聚焦索引之前选择索引。 如果没有首先调用clearSelection，则该方法将具有选择先前索引的结果，同时保留对其他当前选择的索引的选择。

        调用此方法将仅在以下情况下成功：

        • 目前有一个主角/重点指数。
        • 主要/焦点指数不是控制中的第一个指标。
        • 以前的索引尚未被选中。

        如果这些条件中的任何一个都是假的，则不会发生选择事件。

        Specified by:
        selectPrevious在 SelectionModel<T>

      • selectNext

        public void selectNext​()
        描述从类复制： SelectionModel

        此方法将尝试在当前焦点索引之后直接选择索引。 如果没有首先调用clearSelection，则该方法将具有选择下一个索引的结果，同时保留对任何其他当前选择的索引的选择。

        调用此方法将仅在以下情况下成功：

        • 目前有一个主角/重点指数。
        • 主要/焦点指数不是控件中的最后一个指标。
        • 下一个索引尚未被选中。

        如果这些条件中的任何一个都是假的，则不会发生选择事件。

        Specified by:
        selectNext在 SelectionModel<T>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableView<S>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.TableView<S>
  • 参数类型
    S - TableView项目列表中包含的对象的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("items")
public class TableView<S>
extends Control
    TableView控件旨在可视化无限数量的数据行，分为列。 因此，TableView非常类似于ListView控件，还增加了对列的支持。 有关如何创建TableView的示例，请参阅下面的“创建TableView”控件部分。

    TableView控件有许多功能，包括：

    • 强大的TableColumn API：
      • 支持cell factories轻松自定义cell内容在渲染和编辑状态。
      • 的说明书二七零七零零七五四七九七四八九 / 二百七万七千零七亿五千四百八十一万五千二百五十三 / 二百七十○万七千零七亿五千四百八十二万八千六百七十五 ，并且还fixed width columns 。
      • 用户在运行时调整宽度。
      • 用户在运行时重新排序列。
      • 内置支持column nesting
    • 不同的resizing policies来指定当用户调整列的大小时会发生什么。
    • 通过点击列标题支持multiple column sorting （按住Shift键盘键，同时点击标题按多列排序）。

    请注意，TableView旨在用于可视化数据 - 它不打算用于布局用户界面。 如果要将用户界面放置成网格状，请考虑使用GridPane布局。

    创建TableView

    创建TableView是一个多步骤的过程，也取决于需要表示的底层数据模型。 对于这个例子，我们将使用一个ObservableList <Person>，因为它是在TableView中显示数据的最简单方法。 <code> Person </ code>类将包含名字和姓氏属性。 那是：

       public class Person { private StringProperty firstName; public void setFirstName(String value) { firstNameProperty().set(value); } public String getFirstName() { return firstNameProperty().get(); } public StringProperty firstNameProperty() { if (firstName == null) firstName = new SimpleStringProperty(this, "firstName"); return firstName; } private StringProperty lastName; public void setLastName(String value) { lastNameProperty().set(value); } public String getLastName() { return lastNameProperty().get(); } public StringProperty lastNameProperty() { if (lastName == null) lastName = new SimpleStringProperty(this, "lastName"); return lastName; } }

    首先，需要定义TableView实例：

       TableView<Person> table = new TableView<Person>();
    <p>在定义了基本表格之后，我们再重点关注数据模型。 如上所述，对于这个例子，我们将使用一个ObservableList <Person>。 我们可以立即将这样的列表直接设置到TableView中：
       ObservableList<Person> teamMembers = getTeamMembers(); table.setItems(teamMembers);

    对于这样的项目，TableView会在teamMembers列表更改时自动更新。 如果项目列表在TableView被实例化之前可用，则可以将它直接传递给构造函数。

    在这一点上，我们现在有一个TableView挂接观察teamMembers observableList。 缺失的成分现在是分解模型中包含的数据并在一个或多个TableColumn实例中表示的方法。 要创建一个两列TableView以显示firstName和lastName属性，我们将如下扩展最后一个代码示例：

       ObservableList<Person> teamMembers = ...; table.setItems(teamMembers); TableColumn<Person,String> firstNameCol = new TableColumn<Person,String>("First Name"); firstNameCol.setCellValueFactory(new PropertyValueFactory("firstName")); TableColumn<Person,String> lastNameCol = new TableColumn<Person,String>("Last Name"); lastNameCol.setCellValueFactory(new PropertyValueFactory("lastName")); table.getColumns().setAll(firstNameCol, lastNameCol);

    使用上面显示的代码，我们已经完全定义了创建TableView实例所需的最小属性。 运行这个代码（假设人物ObservableList被适当地创建）将导致一个TableView被显示为具有firstName和lastName两列。 不会显示Person类的任何其他属性，因为没有定义TableColumns。

    对于不包含属性的类，TableView支持

    上面所示的代码是在域对象设计时考虑到JavaFX属性时创建TableView的最短代码（另外， PropertyValueFactory也支持普通的JavaBean属性，尽管有一个警告，因此请参考类文档以获取更多信息信息）。 当不是这种情况时，需要提供一个自定义单元格值工厂。 有关单元格值工厂的更多信息，请参见TableColumn API文档，但简要说明如何指定TableColumn：

       firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the Person instance for a particular TableView row return p.getValue().firstNameProperty(); } }); }

    TableView Selection / Focus API

    要跟踪选择和重点，有必要熟悉SelectionModel和FocusModel类。 TableView最多有一个这些类的一个实例，分别可从selectionModel和focusModel属性获得。 虽然可以使用此API来设置新的选择模型，但在大多数情况下，这不是必需的 - 默认选择和焦点模型应该在大多数情况下工作。

    在实例化TableView时使用的默认值为SelectionModel是MultipleSelectionModel抽象类的实现。 但是，如selectionMode属性的API文档中所述，默认值为SelectionMode.SINGLE 。 要在默认的TableView实例中启用多个选择，因此需要执行以下操作：

       tableView.getSelectionModel().setSelectionMode(SelectionMode.MULTIPLE);

    自定义TableView视觉

    可以通过替换默认的row factory完全自定义TableView的视觉效果。 行工厂用于生成TableRow个实例，用于表示TableView中的整个行。

    在许多情况下，这不是所期望的，因为更常见的情况是，单元格是以每列为单位进行定制的，而不是每行。 因此，重要的是要注意， TableRow不是TableCell 。 A TableRow只是一个零或多个TableCell的容器，在大多数情况下，您更有可能要创建自定义TableCells而不是TableRows。 创建自定义TableRow实例的主要用例很可能是引入某种形式的列跨越支持。

    您可以通过将适当的功能分配给TableColumn cell factory属性来创建每列的自定义TableCell实例。

    有关如何编写自定义单元格的更完整的说明，请参阅Cell类文档。

    排序

    在JavaFX 8.0之前，TableView控件会将items列表视为视图模型，这意味着对列表的任何更改都将立即反映在视觉上。 当用户发起排序时，TableView也会直接修改此列表的顺序。 这意味着（再次，在JavaFX 8.0之前），不可能让TableView返回到未排序的状态（通过升序和降序顺序迭代）。

    从JavaFX 8.0开始（和SortedList的介绍），当没有列作为TableView sort order的一部分时，现在可以使收集返回到未排序状态。 为此，您必须创建一个SortedList实例，并将其comparator属性绑定到TableView comparator属性列表中：

       // create a SortedList based on the provided ObservableList SortedList sortedList = new SortedList(FXCollections.observableArrayList(2, 1, 3)); // create a TableView with the sorted list set as the items it will show final TableView<Integer> tableView = new TableView<>(sortedList); // bind the sortedList comparator to the TableView comparator sortedList.comparatorProperty().bind(tableView.comparatorProperty()); // Don't forget to define columns!

    编辑

    此控件支持值的内联编辑，本节尝试概述可用的API以及如何使用它们。

    首先，细胞编辑通常需要不同于不编辑细胞的用户界面。 这是正在使用的Cell实现的责任。 对于TableView，强烈建议编辑为per-TableColumn而不是per row ，因为您希望用户不希望用不同的方式编辑每个列值，并且这种方法允许对每列进行编辑。 您可以选择单元格是否处于编辑状态（例如，这对于CheckBox单元格是常见的），或者在编辑开始时切换到不同的UI（例如，当单元格上接收到双击时）。

    要知道在单元格上请求编辑时，只需覆盖Cell.startEdit()方法，并根据需要更新单元格text和graphic属性（例如，将文本设置为null，并将图形设置为TextField ）。 此外，您还应该覆盖Cell.cancelEdit()，以便在编辑结束时将UI重置为原始的可视状态。 在这两种情况下，重要的是您还要确保您调用超级方法以使单元格执行所有必须执行的任务，以进入或退出其编辑模式。

    一旦您的单元格处于编辑状态，您最感兴趣的下一件事就是如何提交或取消正在进行的编辑。 这是您作为电池厂商的责任。 您的单元实现将基于用户输入（例如当用户按下键盘上的Enter键或ESC键时）知道编辑结束。 发生这种情况时，您有责任酌情致电Cell.commitEdit(Object)或Cell.cancelEdit() 。

    当您调用Cell.commitEdit(Object)事件触发到TableView时，您可以通过TableColumn.setOnEditCommit(javafx.event.EventHandler)添加一个EventHandler来观察 。 同样，您也可以观察edit start和edit cancel的编辑事件。

    默认情况下，TableColumn编辑提交处理程序是非空的，默认处理程序会尝试覆盖当前正在编辑的行中的项目的属性值。 它可以做到这一点，因为Cell.commitEdit(Object)方法被传递给新的值，并且这被传递给编辑提交处理程序通过CellEditEvent被触发。 只需调用TableColumn.CellEditEvent.getNewValue()即可检索该值。

    需要注意的是，如果你把它是非常重要的TableColumn.setOnEditCommit(javafx.event.EventHandler)用自己EventHandler ，那么你会删除默认的处理程序。 除非您再处理该属性（或相关数据源）的回写，否则不会发生任何事情。 您可以使用TableColumnBase.addEventHandler(javafx.event.EventType, javafx.event.EventHandler)方法添加一个TableColumn.EDIT_COMMIT_EVENT EventType与您所需的EventHandler作为第二个参数。 使用此方法，您将不会替换默认实现，但在发生编辑提交时会收到通知。

    希望这个总结回答了一些常见问题。 幸运的是，JavaFX附带了许多预先构建的单元格工厂，可以代表您处理所有的编辑要求。 您可以在javafx.scene.control.cell包中找到这些预构建的单元工厂。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TableColumn ， TablePosition

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Callback<TableView.ResizeFeatures,Boolean>> columnResizePolicy
      这是当用户完成列大小调整操作时调用的函数。
      ReadOnlyObjectProperty<Comparator<S>> comparator
      比较器属性是一个只读属性，代表 sort order列表的当前状态。
      BooleanProperty editable
      指定此TableView是否可编辑 - 只有TableView，TableColumn（如果适用）和TableCells中的TableCells都可以编辑，TableCell才能进入编辑状态。
      ReadOnlyObjectProperty<TablePosition<S,?>> editingCell
      表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
      DoubleProperty fixedCellSize
      指定此控件是否具有固定高度（指定值）的单元格。
      ObjectProperty<TableView.TableViewFocusModel<S>> focusModel
      代表此TableView当前安装的TableView.TableViewFocusModel 。
      ObjectProperty<ObservableList<S>> items
      TableView的基础数据模型。
      ObjectProperty<EventHandler<ScrollToEvent<TableColumn<S,?>>>> onScrollToColumn
      当有请求使用 scrollToColumn(TableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollTo
      当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<SortEvent<TableView<S>>>> onSort
      当有请求排序控件时调用。
      ObjectProperty<Node> placeholder
      当表没有显示的内容时，向用户显示该节点。
      ObjectProperty<Callback<TableView<S>,TableRow<S>>> rowFactory
      一个产生TableRow的函数。
      ObjectProperty<TableView.TableViewSelectionModel<S>> selectionModel
      SelectionModel提供了可以在TableView中选择单个或多个项目的API，以及检查用户选择了哪些项目。
      ObjectProperty<Callback<TableView<S>,Boolean>> sortPolicy
      排序策略指定如何执行此TableView中的排序。
      BooleanProperty tableMenuButtonVisible
      当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TableColumn的无线菜单项。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TableView.ResizeFeatures<S>
      用于TableView column resize功能的不可变包装类。
      static class  TableView.TableViewFocusModel<S>
      A FocusModel具有支持TableView控件要求的附加功能。
      static class  TableView.TableViewSelectionModel<S>
      SelectionModel抽象类的简单扩展，允许对TableView控件的特殊支持。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Callback<TableView.ResizeFeatures,Boolean> CONSTRAINED_RESIZE_POLICY
      确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。
      static Callback<TableView,Boolean> DEFAULT_SORT_POLICY
      如果没有指定其他策略，则TableView将使用默认值 sort policy 。
      static Callback<TableView.ResizeFeatures,Boolean> UNCONSTRAINED_RESIZE_POLICY
      非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableView​()
      创建一个没有内容的默认TableView控件。
      TableView​(ObservableList<S> items)
      使用ObservableList项中提供的内容创建TableView。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Callback<TableView.ResizeFeatures,Boolean>> columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      ReadOnlyObjectProperty<Comparator<S>> comparatorProperty​()
      比较器属性是一个只读属性，代表 sort order列表的当前状态。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void edit​(int row, TableColumn<S,?> column)
      导致给定行/列视图索引处的单元格切换到其编辑状态（如果尚未存在），并且假设TableView和列也是可编辑的。
      BooleanProperty editableProperty​()
      指定此TableView是否可编辑 - 只有TableView，TableColumn（如果适用）和TableCells中的TableCells都可以编辑，TableCell才能进入编辑状态。
      ReadOnlyObjectProperty<TablePosition<S,?>> editingCellProperty​()
      表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
      DoubleProperty fixedCellSizeProperty​()
      指定此控件是否具有固定高度（指定值）的单元格。
      ObjectProperty<TableView.TableViewFocusModel<S>> focusModelProperty​()
      代表此TableView当前安装的TableView.TableViewFocusModel 。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Callback<TableView.ResizeFeatures,Boolean> getColumnResizePolicy​()
      获取属性columnResizePolicy的值。
      ObservableList<TableColumn<S,?>> getColumns​()
      TableColumns是TableView的一部分。
      Comparator<S> getComparator​()
      获取属性比较器的值。
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      TablePosition<S,?> getEditingCell​()
      获取属性editingCell的值。
      double getFixedCellSize​()
      返回固定的单元格大小值。
      TableView.TableViewFocusModel<S> getFocusModel​()
      获取属性focusModel的值。
      ObservableList<S> getItems​()
      获取属性项的值。
      EventHandler<ScrollToEvent<Integer>> getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<TableColumn<S,?>>> getOnScrollToColumn​()
      获取属性onScrollToColumn的值。
      EventHandler<SortEvent<TableView<S>>> getOnSort​()
      获取属性onSort的值。
      Node getPlaceholder​()
      获取属性占位符的值。
      Callback<TableView<S>,TableRow<S>> getRowFactory​()
      获取属性rowFactory的值。
      TableView.TableViewSelectionModel<S> getSelectionModel​()
      获取属性selectionModel的值。
      ObservableList<TableColumn<S,?>> getSortOrder​()
      sortOrder列表定义TableColumn实例排序的顺序。
      Callback<TableView<S>,Boolean> getSortPolicy​()
      获取属性sortPolicy的值。
      TableColumn<S,?> getVisibleLeafColumn​(int column)
      相对于所有其他可见的叶子列，返回给定列索引中的TableColumn。
      ObservableList<TableColumn<S,?>> getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      int getVisibleLeafIndex​(TableColumn<S,?> column)
      相对于所有其他可见的叶子列，返回给定列的位置。
      boolean isEditable​()
      获取可编辑属性的值。
      boolean isTableMenuButtonVisible​()
      获取属性tableMenuButtonVisible的值。
      ObjectProperty<ObservableList<S>> itemsProperty​()
      TableView的基础数据模型。
      ObjectProperty<EventHandler<ScrollToEvent<TableColumn<S,?>>>> onScrollToColumnProperty​()
      当有要求使用 scrollToColumn(TableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty​()
      当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<SortEvent<TableView<S>>>> onSortProperty​()
      当有请求排序控件时调用。
      ObjectProperty<Node> placeholderProperty​()
      当表没有显示的内容时，向用户显示该节点。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void refresh​()
      调用 refresh()强制TableView控件重新创建并重新填充填充控件的可视边界所需的单元格。
      boolean resizeColumn​(TableColumn<S,?> column, double delta)
      根据给定的列应用当前安装的大小调整策略，根据提供的增量值调整其大小。
      ObjectProperty<Callback<TableView<S>,TableRow<S>>> rowFactoryProperty​()
      一个产生TableRow的函数。
      void scrollTo​(int index)
      滚动TableView，使给定索引在视口内可见。
      void scrollTo​(S object)
      滚动TableView，使给定对象在视口内可见。
      void scrollToColumn​(TableColumn<S,?> column)
      滚动TableView，使给定的列在视口内可见。
      void scrollToColumnIndex​(int columnIndex)
      滚动TableView，使给定索引在视口内可见。
      ObjectProperty<TableView.TableViewSelectionModel<S>> selectionModelProperty​()
      SelectionModel提供了可以在TableView中选择单个或多个项目的API，以及检查用户选择了哪些项目。
      void setColumnResizePolicy​(Callback<TableView.ResizeFeatures,Boolean> callback)
      设置属性columnResizePolicy的值。
      void setEditable​(boolean value)
      设置属性可编辑的值。
      void setFixedCellSize​(double value)
      设置此控件的新固定单元格大小。
      void setFocusModel​(TableView.TableViewFocusModel<S> value)
      设置属性focusModel的值。
      void setItems​(ObservableList<S> value)
      设置属性项的值。
      void setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void setOnScrollToColumn​(EventHandler<ScrollToEvent<TableColumn<S,?>>> value)
      设置属性onScrollToColumn的值。
      void setOnSort​(EventHandler<SortEvent<TableView<S>>> value)
      设置属性onSort的值。
      void setPlaceholder​(Node value)
      设置属性占位符的值。
      void setRowFactory​(Callback<TableView<S>,TableRow<S>> value)
      设置属性rowFactory的值。
      void setSelectionModel​(TableView.TableViewSelectionModel<S> value)
      设置属性selectionModel的值。
      void setSortPolicy​(Callback<TableView<S>,Boolean> callback)
      设置属性sortPolicy的值。
      void setTableMenuButtonVisible​(boolean value)
      设置属性tableMenuButtonVisible的值。
      void sort​()
      排序方法强制TableView重新运行其排序算法。
      ObjectProperty<Callback<TableView<S>,Boolean>> sortPolicyProperty​()
      排序策略指定如何执行此TableView中的排序。
      BooleanProperty tableMenuButtonVisibleProperty​()
      当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TableColumn的无线菜单项。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • items

        public final ObjectProperty<ObservableList<S>> itemsProperty
        TableView的基础数据模型。 请注意，它具有必须与TableView本身类型匹配的通用类型。
        另请参见：
        getItems() ， setItems(ObservableList)

      • tableMenuButtonVisible

        public final BooleanProperty tableMenuButtonVisibleProperty
        当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TableColumn的无线菜单项。 此菜单允许用户轻松显示和隐藏所有TableColumns。
        另请参见：
        isTableMenuButtonVisible() ， setTableMenuButtonVisible(boolean)

      • columnResizePolicy

        public final ObjectProperty<Callback<TableView.ResizeFeatures,Boolean>> columnResizePolicyProperty
        这是当用户完成列大小调整操作时调用的函数。 X- 20045 X-4545 X-4545 X-4545 X-4545 X-4545 X-4545 X-4545 X-45 X- 200 200 200 200 200 200 ： 20045 -40 200 X-
        另请参见：
        getColumnResizePolicy() ， setColumnResizePolicy(Callback)

      • rowFactory

        public final ObjectProperty<Callback<TableView<S>,TableRow<S>>> rowFactoryProperty
        一个产生TableRow的函数。 该系统负责重用TableRows。 从此函数返回可用于在TableView中表示单个行的TableRow。

        请注意，TableRow 不是 TableCell。 200的X- 20045 X- 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 创建自定义TableRow实例的主要用例很可能是引入某种形式的列跨越支持。

        您可以通过将适当的函数分配给TableColumn类中的cellFactory属性来创建每个列的自定义TableCell实例。

        另请参见：
        getRowFactory() ， setRowFactory(Callback)

      • placeholder

        public final ObjectProperty<Node> placeholderProperty
        当表没有显示的内容时，向用户显示该节点。 新新新新旗新新新旗新新旗新新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗新新旗新新旗新新旗新200新新旗新新旗新新旗新新旗新新旗新200新新旗新新200新新旗新新200新新旗新新200新200新新旗新新200新新旗2001-新新新新旗新新200新新200新200新新200新新200新200新新200新新200新新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新
        另请参见：
        getPlaceholder() ， setPlaceholder(Node)

      • selectionModel

        public final ObjectProperty<TableView.TableViewSelectionModel<S>> selectionModelProperty
        SelectionModel提供了可以在TableView中选择单个或多个项目的API，以及检查用户选择了哪些项目。 请注意，它具有必须与TableView本身类型匹配的通用类型。
        另请参见：
        getSelectionModel() ， setSelectionModel(TableView.TableViewSelectionModel)

      • focusModel

        public final ObjectProperty<TableView.TableViewFocusModel<S>> focusModelProperty
        代表当前安装的TableView.TableViewFocusModel for TableView。 在几乎所有情况下，将此作为默认焦点模型就足够了。
        另请参见：
        getFocusModel() ， setFocusModel(TableView.TableViewFocusModel)

      • editable

        public final BooleanProperty editableProperty
        指定此TableView是否可编辑 - 只有TableView，TableColumn（如果适用）和TableCells中的TableCells都可以编辑，TableCell才能进入编辑状态。
        另请参见：
        isEditable() ， setEditable(boolean)

      • fixedCellSize

        public final DoubleProperty fixedCellSizeProperty
        指定此控件是否具有固定高度（指定值）的单元格。 如果该值小于或等于零，则所有单元格都被单独设置和定位。 这是一个缓慢的操作。 因此，当性能重要且开发人员不依赖于可变单元大小时，设置固定单元大小值是一个好主意。 一般情况下，单元格大约为24像素，因此设置固定的单元格大小为24可能导致视觉差异很小，但性能有所改善。

        要通过CSS设置此属性，请使用-fx-fixed-cell-size属性。 这不应该与-fx-cell-size属性混淆。 这两个CSS属性之间的区别是-fx-cell-size将所有单元格的大小设置为指定的大小，但不会强制这是唯一的大小（从而允许变量单元大小，并且阻止性能提升可能）。 因此，当性能很重要的时候使用-fx-fixed-cell-size，而不是-fx-cell-size。 如果在CSS中指定了两个属性，则-fx-fixed-cell-size优先。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • editingCell

        public final ReadOnlyObjectProperty<TablePosition<S,?>> editingCellProperty
        表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
        另请参见：
        getEditingCell()

      • comparator

        public final ReadOnlyObjectProperty<Comparator<S>> comparatorProperty
        比较器属性是一个只读属性，代表sort order列表的当前状态。 排序顺序列表包含以编程方式添加的列或通过用户单击标题本身的列。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getComparator()

      • sortPolicy

        public final ObjectProperty<Callback<TableView<S>,Boolean>> sortPolicyProperty
        排序策略指定如何执行此TableView中的排序。 例如，基本的排序策略可能只是调用FXCollections.sort(tableView.getItems()) ，而更高级的排序策略可以调用数据库来在服务器端执行必要的排序。

        TableView配有一个default sort policy ，正如上面提到的那样：它只是尝试在原位排序项目列表。

        建议不要覆盖sort方法，而不是提供不同的排序策略。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getSortPolicy() ， setSortPolicy(Callback)

      • onSort

        public ObjectProperty<EventHandler<SortEvent<TableView<S>>>> onSortProperty
        当有请求排序控件时调用。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnSort() ， setOnSort(EventHandler)

      • onScrollTo

        public ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty
        当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnScrollTo() ， setOnScrollTo(EventHandler)

      • onScrollToColumn

        public ObjectProperty<EventHandler<ScrollToEvent<TableColumn<S,?>>>> onScrollToColumnProperty
        当有要求使用 scrollToColumn(TableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnScrollToColumn() ， setOnScrollToColumn(EventHandler)

    • 字段详细信息

      • UNCONSTRAINED_RESIZE_POLICY

        public static final Callback<TableView.ResizeFeatures,Boolean> UNCONSTRAINED_RESIZE_POLICY

        非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。

        它还处理我们通过共享新空间嵌套列或者在所有直接子列之间均匀地减去已移除的空间的情况。 当然，直接的孩子本身可能是嵌套的，然后他们会对孩子们使用这个政策。

      • CONSTRAINED_RESIZE_POLICY

        public static final Callback<TableView.ResizeFeatures,Boolean> CONSTRAINED_RESIZE_POLICY

        确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。

        当用户使用此策略调整列宽时，表会自动调整右侧列的宽度。 当用户增加列宽时，表会减小最右列的宽度，直到达到最小宽度。 然后它减小第二个最右边的列的宽度，直到达到最小宽度等等。 当所有右侧列达到最小尺寸时，用户不能再增加已调整大小的列的大小。

      • DEFAULT_SORT_POLICY

        public static final Callback<TableView,Boolean> DEFAULT_SORT_POLICY
        如果没有指定其他策略，则TableView将使用默认值sort policy 。 排序策略是一个简单的Callback ，它接受TableView作为唯一的参数，并期望一个布尔响应来表示排序是否成功。 一个布尔响应为true表示成功，并且一个false（或null）的响应将被视为代表失败。
        从以下版本开始：
        JavaFX 8.0

    • 构造方法详细信息

      • TableView

        public TableView​()
        创建一个没有内容的默认TableView控件。

        有关其他属性的默认状态的详细信息，请参阅TableView类文档。

      • TableView

        public TableView​(ObservableList<S> items)
        使用ObservableList项中提供的内容创建TableView。 这也设置一个观察者，使得对项目列表的任何更改将立即反映在TableView本身中。

        有关其他属性的默认状态的详细信息，请参阅TableView类文档。

        参数
        items - 要插入TableView的项目，以及要监视更改的列表（在TableView中自动显示）。

    • 方法详细信息

      • itemsProperty

        public final ObjectProperty<ObservableList<S>> itemsProperty​()
        TableView的基础数据模型。 请注意，它具有必须与TableView本身类型匹配的通用类型。
        另请参见：
        getItems() ， setItems(ObservableList)

      • setItems

        public final void setItems​(ObservableList<S> value)
        设置属性项的值。
        Property description:
        TableView的基础数据模型。 请注意，它具有必须与TableView本身类型匹配的通用类型。

      • getItems

        public final ObservableList<S> getItems​()
        获取属性项的值。
        Property description:
        TableView的基础数据模型。 请注意，它具有必须与TableView本身类型匹配的通用类型。

      • tableMenuButtonVisibleProperty

        public final BooleanProperty tableMenuButtonVisibleProperty​()
        当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TableColumn的无线菜单项。 此菜单允许用户轻松显示和隐藏所有TableColumns。
        另请参见：
        isTableMenuButtonVisible() ， setTableMenuButtonVisible(boolean)

      • setTableMenuButtonVisible

        public final void setTableMenuButtonVisible​(boolean value)
        设置属性tableMenuButtonVisible的值。
        Property description:
        当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TableColumn的无线菜单项。 此菜单允许用户轻松显示和隐藏所有TableColumns。

      • isTableMenuButtonVisible

        public final boolean isTableMenuButtonVisible​()
        获取属性tableMenuButtonVisible的值。
        Property description:
        当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TableColumn的无线菜单项。 此菜单允许用户轻松显示和隐藏所有TableColumns。

      • setColumnResizePolicy

        public final void setColumnResizePolicy​(Callback<TableView.ResizeFeatures,Boolean> callback)
        设置属性columnResizePolicy的值。
        Property description:
        这是当用户完成列大小调整操作时调用的函数。 两个最常见的策略作为TableView类中的静态函数可用： UNCONSTRAINED_RESIZE_POLICY和CONSTRAINED_RESIZE_POLICY 。

      • getColumnResizePolicy

        public final Callback<TableView.ResizeFeatures,Boolean> getColumnResizePolicy​()
        获取属性columnResizePolicy的值。
        Property description:
        这是当用户完成列大小调整操作时调用的函数。 两个最常见的策略作为TableView类中的静态函数可用： UNCONSTRAINED_RESIZE_POLICY和CONSTRAINED_RESIZE_POLICY 。

      • columnResizePolicyProperty

        public final ObjectProperty<Callback<TableView.ResizeFeatures,Boolean>> columnResizePolicyProperty​()
        这是当用户完成列大小调整操作时调用的函数。 两个最常见的策略作为TableView类中的静态函数可用： UNCONSTRAINED_RESIZE_POLICY和CONSTRAINED_RESIZE_POLICY 。
        另请参见：
        getColumnResizePolicy() ， setColumnResizePolicy(Callback)

      • rowFactoryProperty

        public final ObjectProperty<Callback<TableView<S>,TableRow<S>>> rowFactoryProperty​()
        一个产生TableRow的函数。 该系统负责重用TableRows。 从此函数返回可用于在TableView中表示单个行的TableRow。

        请注意，TableRow 不是 TableCell。 200的X- 20045 X- 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 创建自定义TableRow实例的主要用例很可能是引入某种形式的列跨越支持。

        您可以通过将适当的函数分配给TableColumn类中的cellFactory属性来创建每个列的自定义TableCell实例。

        另请参见：
        getRowFactory() ， setRowFactory(Callback)

      • setRowFactory

        public final void setRowFactory​(Callback<TableView<S>,TableRow<S>> value)
        设置属性rowFactory的值。
        Property description:
        一个产生TableRow的函数。 该系统负责重用TableRows。 从此函数返回可用于在TableView中表示单个行的TableRow。

        请注意，TableRow 不是 TableCell。 200的X- 20045 X- 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 创建自定义TableRow实例的主要用例很可能是引入某种形式的列跨越支持。

        您可以通过将适当的函数分配给TableColumn类中的cellFactory属性来创建每个列的自定义TableCell实例。

      • getRowFactory

        public final Callback<TableView<S>,TableRow<S>> getRowFactory​()
        获取属性rowFactory的值。
        Property description:
        一个产生TableRow的函数。 该系统负责重用TableRows。 从此函数返回可用于在TableView中表示单个行的TableRow。

        请注意，TableRow 不是 TableCell。 200的X- 20045 X- 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 创建自定义TableRow实例的主要用例很可能是引入某种形式的列跨越支持。

        您可以通过将适当的函数分配给TableColumn类中的cellFactory属性来创建每个列的自定义TableCell实例。

      • placeholderProperty

        public final ObjectProperty<Node> placeholderProperty​()
        当表没有显示的内容时，向用户显示该节点。 新新新新旗新新新旗新新旗新新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗新新旗新新旗新新旗新200新新旗新新旗新新旗新新旗新新旗新200新新旗新新200新新旗新新200新新旗新新200新200新新旗新新200新新旗2001-新新新新旗新新200新新200新200新新200新新200新200新新200新新200新新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新
        另请参见：
        getPlaceholder() ， setPlaceholder(Node)

      • setPlaceholder

        public final void setPlaceholder​(Node value)
        设置属性占位符的值。
        Property description:
        当表没有显示的内容时，向用户显示该节点。 新新新新旗新新新旗新新旗新新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗新新旗新新旗新新旗新200新新旗新新旗新新旗新新旗新新旗新200新新旗新新200新新旗新新200新新旗新新200新200新新旗新新200新新旗2001-新新新新旗新新200新新200新200新新200新新200新200新新200新新200新新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新

      • getPlaceholder

        public final Node getPlaceholder​()
        获取属性占位符的值。
        Property description:
        当表没有显示的内容时，向用户显示该节点。 新新新新旗新新新旗新新旗新新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗新新旗新新旗新新旗新200新新旗新新旗新新旗新新旗新新旗新200新新旗新新200新新旗新新200新新旗新新200新200新新旗新新200新新旗2001-新新新新旗新新200新新200新200新新200新新200新200新新200新新200新新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新

      • selectionModelProperty

        public final ObjectProperty<TableView.TableViewSelectionModel<S>> selectionModelProperty​()
        SelectionModel提供了可以在TableView中选择单个或多个项目的API，以及检查用户选择了哪些项目。 请注意，它具有必须与TableView本身类型匹配的通用类型。
        另请参见：
        getSelectionModel() ， setSelectionModel(TableView.TableViewSelectionModel)

      • setSelectionModel

        public final void setSelectionModel​(TableView.TableViewSelectionModel<S> value)
        设置属性selectionModel的值。
        Property description:
        SelectionModel提供了可以在TableView中选择单个或多个项目的API，以及检查用户选择了哪些项目。 请注意，它具有必须与TableView本身类型匹配的通用类型。

      • getSelectionModel

        public final TableView.TableViewSelectionModel<S> getSelectionModel​()
        获取属性selectionModel的值。
        Property description:
        SelectionModel提供了可以在TableView中选择单个或多个项目的API，以及检查用户选择了哪些项目。 请注意，它具有必须与TableView本身类型匹配的通用类型。

      • setFocusModel

        public final void setFocusModel​(TableView.TableViewFocusModel<S> value)
        设置属性focusModel的值。
        Property description:
        代表此TableView当前安装的TableView.TableViewFocusModel 。 在几乎所有情况下，将此作为默认焦点模型就足够了。

      • getFocusModel

        public final TableView.TableViewFocusModel<S> getFocusModel​()
        获取属性focusModel的值。
        Property description:
        代表此TableView当前安装的TableView.TableViewFocusModel 。 在几乎所有情况下，将此作为默认焦点模型就足够了。

      • focusModelProperty

        public final ObjectProperty<TableView.TableViewFocusModel<S>> focusModelProperty​()
        代表当前安装的TableView.TableViewFocusModel此TableView。 在几乎所有情况下，将此作为默认焦点模型就足够了。
        另请参见：
        getFocusModel() ， setFocusModel(TableView.TableViewFocusModel)

      • setEditable

        public final void setEditable​(boolean value)
        设置属性可编辑的值。
        Property description:
        指定此TableView是否可编辑 - 只有TableView，TableColumn（如果适用）和TableCells中的TableCells都可以编辑，TableCell才能进入编辑状态。

      • isEditable

        public final boolean isEditable​()
        获取可编辑属性的值。
        Property description:
        指定此TableView是否可编辑 - 只有TableView，TableColumn（如果适用）和TableCells中的TableCells都可以编辑，TableCell才能进入编辑状态。

      • editableProperty

        public final BooleanProperty editableProperty​()
        指定此TableView是否可编辑 - 只有TableView，TableColumn（如果适用）和TableCells中的TableCells都可以编辑，TableCell才能进入编辑状态。
        另请参见：
        isEditable() ， setEditable(boolean)

      • setFixedCellSize

        public final void setFixedCellSize​(double value)
        设置此控件的新固定单元格大小。 任何大于零的值将启用固定的单元大小模式，而零值或负值（或Region.USE_COMPUTED_SIZE）将用于禁用固定单元大小模式。
        参数
        value - 新的固定单元格大小值，或小于或等于零（或Region.USE_COMPUTED_SIZE）的值禁用。
        从以下版本开始：
        JavaFX 8.0

      • getFixedCellSize

        public final double getFixedCellSize​()
        返回固定的单元格大小值。 使用小于或等于零的值来表示禁用固定单元大小模式，大于零的值表示此控件中所有单元格的大小。
        结果
        表示该控件的固定单元大小的double，或者如果固定单元大小模式被禁用，小于或等于零的值。
        从以下版本开始：
        JavaFX 8.0

      • fixedCellSizeProperty

        public final DoubleProperty fixedCellSizeProperty​()
        指定此控件是否具有固定高度（指定值）的单元格。 如果该值小于或等于零，则所有单元格都被单独设置和定位。 这是一个缓慢的操作。 因此，当性能重要且开发人员不依赖于可变单元大小时，设置固定单元大小值是一个好主意。 一般情况下，单元格大约为24像素，因此设置固定的单元格大小为24可能导致视觉差异很小，但性能有所改善。

        要通过CSS设置此属性，请使用-fx-fixed-cell-size属性。 这不应该与-fx-cell-size属性混淆。 这两个CSS属性之间的区别是-fx-cell-size将所有单元格的大小设置为指定的大小，但不会强制这是唯一的大小（从而允许变量单元大小，并且阻止性能提升可能）。 因此，当性能很重要的时候使用-fx-fixed-cell-size，而不是-fx-cell-size。 如果在CSS中指定了两个属性，则-fx-fixed-cell-size优先。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • getEditingCell

        public final TablePosition<S,?> getEditingCell​()
        获取属性editingCell的值。
        Property description:
        表示正在编辑的当前单元格，如果没有编辑单元格，则为空。

      • editingCellProperty

        public final ReadOnlyObjectProperty<TablePosition<S,?>> editingCellProperty​()
        表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
        另请参见：
        getEditingCell()

      • getComparator

        public final Comparator<S> getComparator​()
        获取属性比较器的值。
        Property description:
        比较器属性是一个只读属性，代表sort order列表的当前状态。 排序顺序列表包含以编程方式添加的列或通过用户单击标题本身的列。
        从以下版本开始：
        JavaFX 8.0

      • comparatorProperty

        public final ReadOnlyObjectProperty<Comparator<S>> comparatorProperty​()
        比较器属性是一个只读属性，表示sort order列表的当前状态。 排序顺序列表包含以编程方式添加的列或通过用户单击标题本身的列。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getComparator()

      • setSortPolicy

        public final void setSortPolicy​(Callback<TableView<S>,Boolean> callback)
        设置属性sortPolicy的值。
        Property description:
        排序策略指定如何执行此TableView中的排序。 例如，基本的排序策略可以调用FXCollections.sort(tableView.getItems()) ，而更高级的排序策略可以调用数据库来在服务器端执行必要的排序。

        TableView附带了一个default sort policy ，正如上面提到的那样：它只是尝试在原位排序项目列表。

        建议不要覆盖sort方法，而是提供不同的排序策略。

        从以下版本开始：
        JavaFX 8.0

      • getSortPolicy

        public final Callback<TableView<S>,Boolean> getSortPolicy​()
        获取属性sortPolicy的值。
        Property description:
        排序策略指定如何执行此TableView中的排序。 例如，基本排序策略可能只是调用FXCollections.sort(tableView.getItems()) ，而更高级的排序策略可能会调用数据库来在服务器端执行必要的排序。

        TableView附带一个default sort policy ，正如上面提到的那样：它只是尝试在原位排序项目列表。

        建议不要覆盖提供不同排序策略的sort方法。

        从以下版本开始：
        JavaFX 8.0

      • sortPolicyProperty

        public final ObjectProperty<Callback<TableView<S>,Boolean>> sortPolicyProperty​()
        排序策略指定如何执行此TableView中的排序。 例如，基本排序策略可以调用FXCollections.sort(tableView.getItems()) ，而更高级的排序策略可以调用数据库来在服务器端执行必要的排序。

        TableView附带一个default sort policy ，正如上面提到的那样：它只是尝试在原位排序项目列表。

        建议不要覆盖sort方法，而是提供不同的排序策略。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getSortPolicy() ， setSortPolicy(Callback)

      • setOnSort

        public void setOnSort​(EventHandler<SortEvent<TableView<S>>> value)
        设置属性onSort的值。
        Property description:
        当有请求排序控件时调用。
        从以下版本开始：
        JavaFX 8.0

      • getOnSort

        public EventHandler<SortEvent<TableView<S>>> getOnSort​()
        获取属性onSort的值。
        Property description:
        当有请求排序控件时调用。
        从以下版本开始：
        JavaFX 8.0

      • onSortProperty

        public ObjectProperty<EventHandler<SortEvent<TableView<S>>>> onSortProperty​()
        当有请求排序控件时调用。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnSort() ， setOnSort(EventHandler)

      • getColumns

        public final ObservableList<TableColumn<S,?>> getColumns​()
        TableColumns是TableView的一部分。 当用户重新排列TableView列时，此列表将被更新以反映当前的视觉排序。

        注意：要在TableView中显示任何数据，该ObservableList中必须至少有一个TableColumn。

        结果
        列

      • getSortOrder

        public final ObservableList<TableColumn<S,?>> getSortOrder​()
        sortOrder列表定义了TableColumn实例进行排序的顺序。 一个空的排序列表表示在TableView上没有应用排序。 如果sortOrder列表中有一个TableColumn，则TableView将使用此TableColumn的sortType和comparator属性进行排序（假设为TableColumn.sortable为true）。 如果sortOrder列表包含多个TableColumn实例，则首先根据第一个TableColumn的属性对TableView进行排序。 如果两个元素被认为相等，则列表中的第二个TableColumn用于确定排序。 如果需要，将重复此操作，直到所有TableColumn比较器的结果被考虑为止。
        结果
        一个包含零个或多个TableColumn实例的ObservableList。

      • scrollTo

        public void scrollTo​(int index)
        滚动TableView，使给定索引在视口内可见。
        参数
        index - 应该对用户可见的项目的索引。

      • scrollTo

        public void scrollTo​(S object)
        滚动TableView，使给定对象在视口内可见。
        参数
        object - 应该对用户可见的对象。
        从以下版本开始：
        JavaFX 8.0

      • setOnScrollTo

        public void setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
        设置属性onScrollTo的值。
        Property description:
        当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0

      • getOnScrollTo

        public EventHandler<ScrollToEvent<Integer>> getOnScrollTo​()
        获取属性onScrollTo的值。
        Property description:
        当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0

      • onScrollToProperty

        public ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty​()
        当有请求使用 scrollTo(int)或 scrollTo(Object)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnScrollTo() ， setOnScrollTo(EventHandler)

      • scrollToColumn

        public void scrollToColumn​(TableColumn<S,?> column)
        滚动TableView，使给定的列在视口内可见。
        参数
        column - 应该对用户可见的列。
        从以下版本开始：
        JavaFX 8.0

      • scrollToColumnIndex

        public void scrollToColumnIndex​(int columnIndex)
        滚动TableView，使给定索引在视口内可见。
        参数
        columnIndex - 用户可以看到的列的索引。
        从以下版本开始：
        JavaFX 8.0

      • setOnScrollToColumn

        public void setOnScrollToColumn​(EventHandler<ScrollToEvent<TableColumn<S,?>>> value)
        设置属性onScrollToColumn的值。
        Property description:
        当有要求使用 scrollToColumn(TableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0

      • getOnScrollToColumn

        public EventHandler<ScrollToEvent<TableColumn<S,?>>> getOnScrollToColumn​()
        获取属性onScrollToColumn的值。
        Property description:
        当有要求使用 scrollToColumn(TableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0

      • onScrollToColumnProperty

        public ObjectProperty<EventHandler<ScrollToEvent<TableColumn<S,?>>>> onScrollToColumnProperty​()
        当有请求使用 scrollToColumn(TableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnScrollToColumn() ， setOnScrollToColumn(EventHandler)

      • resizeColumn

        public boolean resizeColumn​(TableColumn<S,?> column,
                            double delta)
        根据给定的列应用当前安装的大小调整策略，根据提供的增量值调整其大小。
        参数
        column - 列
        delta - 三角洲
        结果
        如果允许列调整大小，则为true

      • edit

        public void edit​(int row,
                 TableColumn<S,?> column)
        导致给定行/列视图索引处的单元格切换到其编辑状态（如果尚未存在），并且假设TableView和列也是可编辑的。

        注意：如果给定的行值小于零并且给定的列为空，此方法将取消编辑。

        参数
        row - 行
        column - 列

      • getVisibleLeafColumns

        public ObservableList<TableColumn<S,?>> getVisibleLeafColumns​()
        返回一个不可修改的列表，其中包含当前可见的叶子列。
        结果
        一个包含当前可见的叶子列的不可修改的列表

      • getVisibleLeafIndex

        public int getVisibleLeafIndex​(TableColumn<S,?> column)
        相对于所有其他可见的叶子列，返回给定列的位置。
        参数
        column - 列
        结果
        相对于所有其他可见叶列，给定列的位置

      • getVisibleLeafColumn

        public TableColumn<S,?> getVisibleLeafColumn​(int column)
        相对于所有其他可见的叶子列，返回给定列索引中的TableColumn。
        参数
        column - 列
        结果
        相对于所有其他可见的叶子列，给定列索引中的TableColumn

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • sort

        public void sort​()
        排序方法强制TableView重新运行其排序算法。 往往不是没有必要直接调用此方法，因为它被自动调用时sort order ， sort policy ，或将TableColumn的状态sort type和性质发生变化。 换句话说，这种方法只能在需要外部更改和排序时直接调用。
        从以下版本开始：
        JavaFX 8.0

      • refresh

        public void refresh​()
        调用refresh()强制TableView控件重新创建并重新填充填充控件的可视边界所需的单元格。 换句话说，这会强制TableView更新它向用户显示的内容。 这在底层数据源以TableView本身未观察到的方式发生更改的情况下很有用。
        从以下版本开始：
        JavaFX 8u60

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TableView.ResizeFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableView.ResizeFeatures<S>

  • java.lang.Object
    • javafx.scene.control.ResizeFeaturesBase<S>
      • javafx.scene.control.TableView.ResizeFeatures<S>
  • Enclosing class:
    TableView < S >

    public static class TableView.ResizeFeatures<S>
extends ResizeFeaturesBase<S>
    用于TableView column resize功能的不可变包装类。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ResizeFeatures​(TableView<S> table, TableColumn<S,?> column, Double delta)
      创建此类的实例，提供的TableView，TableColumn和delta值被设置并存储在此不可变实例中。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TableColumn<S,?> getColumn​()
      返回发生resize的列，如果由于TableView resize操作而创建了此ResizeFeatures实例，则返回null。
      TableView<S> getTable​()
      返回执行resize操作的TableView。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.ResizeFeaturesBase

        getDelta

    • 构造方法详细信息

      • ResizeFeatures

        public ResizeFeatures​(TableView<S> table,
                      TableColumn<S,?> column,
                      Double delta)
        创建此类的实例，提供的TableView，TableColumn和delta值被设置并存储在此不可变实例中。
        参数
        table - 发生大小调整操作的TableView。
        column - 发生调整大小的列，如果由于TableView大小操作而创建此ResizeFeatures实例，则为null。
        delta - 在调整大小操作中添加或删除的水平空间量。

    • 方法详细信息

      • getColumn

        public TableColumn<S,?> getColumn​()
        返回发生resize的列，如果由于TableView resize操作而创建了此ResizeFeatures实例，则返回null。
        重写：
        getColumn在 ResizeFeaturesBase<S>
        结果
        正在发生调整大小的列

      • getTable

        public TableView<S> getTable​()
        返回执行resize操作的TableView。
        结果
        TableView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableView.TableViewFocusModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableView.TableViewFocusModel<S>

  • java.lang.Object
    • javafx.scene.control.FocusModel<T>
      • javafx.scene.control.TableFocusModel<S,TableColumn<S,?>>
        • javafx.scene.control.TableView.TableViewFocusModel<S>
  • Enclosing class:
    TableView < S >

    public static class TableView.TableViewFocusModel<S>
extends TableFocusModel<S,TableColumn<S,?>>
    A FocusModel具有支持TableView控件要求的附加功能。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TableView

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<TablePosition> focusedCell
      当前项目在TableView中的位置具有重点。

      • Properties inherited from class javafx.scene.control.FocusModel

        focusedIndex, focusedItem

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableViewFocusModel​(TableView<S> tableView)
      创建一个默认的TableViewFocusModel实例，用于管理提供的TableView控件的焦点。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void focus​(int index)
      导致给定索引处的项目接收焦点。
      void focus​(int row, TableColumn<S,?> column)
      导致给定索引处的项目接收焦点。
      void focus​(TablePosition pos)
      使用TablePosition设置焦点在特定行或单元格的便利方法。
      void focusAboveCell​()
      尝试将焦点移动到当前聚焦单元格上方的单元格。
      void focusBelowCell​()
      尝试将焦点移动到当前聚焦单元格下方的单元格。
      ReadOnlyObjectProperty<TablePosition> focusedCellProperty​()
      当前项目在TableView中的位置具有重点。
      void focusLeftCell​()
      尝试将焦点移动到当前聚焦单元格左侧的单元格。
      void focusNext​()
      尝试将焦点放在当前焦点集中的行之后。
      void focusPrevious​()
      尝试将重点放在目前重点集中的行之前。
      void focusRightCell​()
      尝试将焦点移动到当前聚焦单元格右侧的单元格。
      TablePosition getFocusedCell​()
      获取focusCell属性的值。
      protected int getItemCount​()
      返回数据模型中支配控件的项目数。
      protected S getModelItem​(int index)
      返回给定索引处的项目。
      boolean isFocused​(int row, TableColumn<S,?> column)
      测试给定位置的行/单元格当前是否具有TableView内的焦点。

      • Methods inherited from class javafx.scene.control.FocusModel

        focusedIndexProperty, focusedItemProperty, getFocusedIndex, getFocusedItem, isFocused

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • focusedCell

        public final ReadOnlyObjectProperty<TablePosition> focusedCellProperty
        当前项目在TableView中的位置具有重点。
        另请参见：
        getFocusedCell()

    • 构造方法详细信息

      • TableViewFocusModel

        public TableViewFocusModel​(TableView<S> tableView)
        创建一个默认的TableViewFocusModel实例，用于管理提供的TableView控件的焦点。
        参数
        tableView - 此对焦模型运行的tableView。
        异常
        NullPointerException - TableView参数不能为空。

    • 方法详细信息

      • getItemCount

        protected int getItemCount​()
        返回数据模型中支配控件的项目数。 一个例子就是ListView焦点模型可能会返回listView.getItems().size() 。 可聚焦索引的有效范围在0和此方法返回的任何值之间。
        Specified by:
        getItemCount在 FocusModel<S>
        结果
        支持控制的数据模型中的项目数

      • getModelItem

        protected S getModelItem​(int index)
        返回给定索引处的项目。 使用ListView的示例将是listView.getItems().get(index) 。
        Specified by:
        getModelItem在 FocusModel<S>
        参数
        index - 从底层数据模型请求的项目的索引。
        结果
        如果索引超出范围，则返回null，或者与给定索引相关的类型T的元素。

      • focusedCellProperty

        public final ReadOnlyObjectProperty<TablePosition> focusedCellProperty​()
        当前项目在TableView中的位置具有重点。
        另请参见：
        getFocusedCell()

      • getFocusedCell

        public final TablePosition getFocusedCell​()
        获取focusCell属性的值。
        Property description:
        当前项目在TableView中的位置具有重点。

      • focus

        public void focus​(int row,
                  TableColumn<S,?> column)
        导致给定索引处的项目接收焦点。
        Specified by:
        focus在 TableFocusModel<S,TableColumn<S,?>>
        参数
        row - 要重点 row的项目的行索引。
        column - 要专注的项目的列。 可以为null。

      • focus

        public void focus​(TablePosition pos)
        使用TablePosition设置焦点在特定行或单元格的便利方法。
        参数
        pos - 要设置焦点的表格位置。

      • isFocused

        public boolean isFocused​(int row,
                         TableColumn<S,?> column)
        测试给定位置的行/单元格当前是否具有TableView内的焦点。
        Specified by:
        isFocused在 TableFocusModel<S,TableColumn<S,?>>
        参数
        row - 行
        column - 列
        结果
        如果给定位置的行/单元格当前具有UI控件内的焦点，则为true

      • focus

        public void focus​(int index)
        导致给定索引处的项目接收焦点。 这不会导致当前的选择更改。 更新focusItem和focusedIndex属性，以便focusedIndex = -1除非
          0 <= index < model size
        。
        重写：
        focus在 FocusModel<S>
        参数
        index - 要获取焦点的项目的索引。

      • focusAboveCell

        public void focusAboveCell​()
        尝试将焦点移动到当前聚焦单元格上方的单元格。
        Specified by:
        focusAboveCell在 TableFocusModel<S,TableColumn<S,?>>

      • focusBelowCell

        public void focusBelowCell​()
        尝试将焦点移动到当前聚焦单元格下方的单元格。
        Specified by:
        focusBelowCell在 TableFocusModel<S,TableColumn<S,?>>

      • focusLeftCell

        public void focusLeftCell​()
        尝试将焦点移动到当前聚焦单元格左侧的单元格。
        Specified by:
        focusLeftCell在 TableFocusModel<S,TableColumn<S,?>>

      • focusRightCell

        public void focusRightCell​()
        尝试将焦点移动到当前聚焦单元格右侧的单元格。
        Specified by:
        focusRightCell在 TableFocusModel<S,TableColumn<S,?>>

      • focusPrevious

        public void focusPrevious​()
        尝试将重点放在目前重点集中的行之前。 如果当前焦点所有者是第一行，或者是-1（表示没有当前焦点所有者），调用此方法将不会有结果。
        重写：
        focusPrevious在 FocusModel<S>

      • focusNext

        public void focusNext​()
        尝试将焦点放在当前焦点集中的行之后。 如果当前焦点所有者是最后一行，调用此方法将不会有结果。
        重写：
        focusNext FocusModel<S>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableView.TableViewSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TableView.TableViewSelectionModel<S>

  • java.lang.Object
    • javafx.scene.control.SelectionModel<T>
      • javafx.scene.control.MultipleSelectionModel<T>
        • javafx.scene.control.TableSelectionModel<S>
          • javafx.scene.control.TableView.TableViewSelectionModel<S>
  • Enclosing class:
    TableView < S >

    public abstract static class TableView.TableViewSelectionModel<S>
extends TableSelectionModel<S>
    SelectionModel抽象类的简单扩展，允许对TableView控件的特殊支持。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.control.MultipleSelectionModel

        selectionMode

      • Properties inherited from class javafx.scene.control.SelectionModel

        selectedIndex, selectedItem

      • Properties inherited from class javafx.scene.control.TableSelectionModel

        cellSelectionEnabled

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableViewSelectionModel​(TableView<S> tableView)
      使用提供的TableView构建默认的TableViewSelectionModel实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      void clearAndSelect​(int row)
      在将选择设置为给定索引之前清除任何选择的方法。
      abstract void clearAndSelect​(int row, TableColumn<S,?> column)
      清除所有选择，然后选择给定行/列交点处的单元格。
      void clearAndSelect​(int row, TableColumnBase<S,?> column)
      清除所有选择，然后选择给定行/列交点处的单元格。
      void clearSelection​()
      清除所有选定索引的选择模型。
      void clearSelection​(int index)
      该方法将清除给定索引中项目的选择。
      abstract void clearSelection​(int row, TableColumn<S,?> column)
      从指定的行/列位置（视图索引）中移除选择。
      void clearSelection​(int row, TableColumnBase<S,?> column)
      从指定的行/列位置（视图索引）中移除选择。
      void | focus​(int row)
      int | getFocusedIndex​()
      protected int getItemCount​()
      返回数据模型中支配控件的项目数。
      protected S getModelItem​(int index)
      返回给定索引处的项目。
      abstract ObservableList<TablePosition> getSelectedCells​()
      一个只读ObservableList，表示此TableView中当前选定的单元格。
      ObservableList<Integer> getSelectedIndices​()
      返回所有选定索引的 只读 ObservableList。
      ObservableList<T> getSelectedItems​()
      返回所有选定项目的 只读 ObservableList。
      protected List<S> getTableModel​()
      getTableView（）。getItems（）的方便方法。
      TableView<S> getTableView​()
      返回安装此选择模型的TableView实例。
      boolean isEmpty​()
      该方法可用于测试是否有任何选定的索引/项目。
      boolean isSelected​(int index)
      通知此SelectionModel中当前选定给定索引的方便方法。
      abstract boolean isSelected​(int row, TableColumn<S,?> column)
      测试在此表实例中当前是否选择给定行和列索引的便利函数。
      boolean isSelected​(int row, TableColumnBase<S,?> column)
      测试在此表实例中当前是否选择给定行和列索引的便利函数。
      void select​(int row)
      这将在选择模型中选择给定的索引，假设索引在有效范围内（即大于或等于零，并且小于底层数据模型中的项目总数）。
      void select​(T obj)
      此方法将尝试选择包含给定对象的索引。
      abstract void select​(int row, TableColumn<S,?> column)
      选择给定的行/列交叉点的单元格。
      void select​(int row, TableColumnBase<S,?> column)
      选择给定的行/列交叉点的单元格。
      void selectAll​()
      方便的方法来选择所有可用的索引。
      void selectFirst​()
      该方法将尝试选择控件中的第一个索引。
      void selectIndices​(int row, int... rows)
      该方法允许同时设置一个或多个选择。
      void selectLast​()
      此方法将尝试选择控件中的最后一个索引。
      void selectNext​()
      此方法将尝试在当前焦点索引之后直接选择索引。
      void selectPrevious​()
      此方法将尝试直接在当前聚焦索引之前选择索引。
      void selectRange​(int minRow, TableColumnBase<S,?> minColumn, int maxRow, TableColumnBase<S,?> maxColumn)
      选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。

      • Methods inherited from class javafx.scene.control.MultipleSelectionModel

        getSelectionMode, selectionModeProperty, selectRange, setSelectionMode

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SelectionModel

        getSelectedIndex, getSelectedItem, selectedIndexProperty, selectedItemProperty, setSelectedIndex, setSelectedItem

      • Methods inherited from class javafx.scene.control.TableSelectionModel

        cellSelectionEnabledProperty, isCellSelectionEnabled, selectAboveCell, selectBelowCell, selectLeftCell, selectRightCell, setCellSelectionEnabled

    • 构造方法详细信息

      • TableViewSelectionModel

        public TableViewSelectionModel​(TableView<S> tableView)
        使用提供的TableView构建默认的TableViewSelectionModel实例。
        参数
        tableView - 此选择模型应在其上运行的TableView。
        异常
        NullPointerException - TableView不能为空。

    • 方法详细信息

      • getSelectedCells

        public abstract ObservableList<TablePosition> getSelectedCells​()
        一个只读ObservableList，表示此TableView中当前选定的单元格。 而不是直接修改此列表，请使用TableViewSelectionModel中提供的其他方法。
        结果
        一个只读ObservableList，表示此TableView中当前选定的单元格

      • isSelected

        public boolean isSelected​(int row,
                          TableColumnBase<S,?> column)
        测试在此表实例中当前是否选择给定行和列索引的便利函数。 如果表控件处于其“单元格选择”模式（可以选择单个单元格而不是整个行），并且如果列参数为空，则只有在给定行中的所有单元格被选中时，此方法才应返回true。
        Specified by:
        isSelected在 TableSelectionModel<S>
        参数
        row - 行
        column - 列
        结果
        如果当前在此表实例中选择了给定的行和列索引，则为true

      • isSelected

        public abstract boolean isSelected​(int row,
                                   TableColumn<S,?> column)
        测试在此表实例中当前是否选择给定行和列索引的便利函数。
        参数
        row - 行
        column - 列
        结果
        如果当前选择了行和列索引，则为true

      • select

        public void select​(int row,
                   TableColumnBase<S,?> column)
        选择给定的行/列交叉点的单元格。 如果表控件处于其“单元格选择”模式（可以选择单个单元格而不是整行），并且如果列参数为空，则此方法应选择给定行中的所有单元格。
        Specified by:
        select在 TableSelectionModel<S>
        参数
        row - 行
        column - 列

      • select

        public abstract void select​(int row,
                            TableColumn<S,?> column)
        选择给定的行/列交叉点的单元格。
        参数
        row - 行
        column - 列

      • clearAndSelect

        public void clearAndSelect​(int row,
                           TableColumnBase<S,?> column)
        清除所有选择，然后选择给定行/列交点处的单元格。 如果表控件处于其“单元格选择”模式（可以选择单个单元格而不是整行），并且如果列参数为空，则此方法应选择给定行中的所有单元格。
        Specified by:
        clearAndSelect在 TableSelectionModel<S>
        参数
        row - 行
        column - 列

      • clearAndSelect

        public abstract void clearAndSelect​(int row,
                                    TableColumn<S,?> column)
        清除所有选择，然后选择给定行/列交点处的单元格。
        参数
        row - 行
        column - 列

      • clearSelection

        public void clearSelection​(int row,
                           TableColumnBase<S,?> column)
        从指定的行/列位置（视图索引）中移除选择。 如果没有选择这个特定的单元格（如果列值为-1），则不会发生任何事情。 如果表格控件处于其“单元格选择”模式（可以选择单个单元格而不是整个行），并且如果列参数为空，则此方法应取消选择给定行中的所有单元格。
        Specified by:
        clearSelection在 TableSelectionModel<S>
        参数
        row - 行
        column - 列

      • clearSelection

        public abstract void clearSelection​(int row,
                                    TableColumn<S,?> column)
        从指定的行/列位置（视图索引）中移除选择。 如果没有选择这个特定的单元格（如果列值为-1），则不会发生任何事情。
        参数
        row - 行
        column - 列

      • selectRange

        public void selectRange​(int minRow,
                        TableColumnBase<S,?> minColumn,
                        int maxRow,
                        TableColumnBase<S,?> maxColumn)
        选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。
        Specified by:
        selectRange在 TableSelectionModel<S>
        参数
        minRow - minRow
        minColumn - minColumn
        maxRow - maxRow
        maxColumn - maxColumn

      • getTableView

        public TableView<S> getTableView​()
        返回安装此选择模型的TableView实例。
        结果
        TableView

      • getTableModel

        protected List<S> getTableModel​()
        getTableView（）。getItems（）的方便方法。
        结果
        当前TableView的项目列表。

      • getModelItem

        protected S getModelItem​(int index)
        返回给定索引处的项目。 使用ListView的示例将为listView.getItems().get(index) 。
        参数
        index - 从基础数据模型请求的项目的索引。
        结果
        如果索引超出范围，则返回null，或者与给定索引相关的类型T的元素。

      • getItemCount

        protected int getItemCount​()
        返回数据模型中支配控件的项目数。 一个例子就是ListView选择模型可能会返回listView.getItems().size() 。 可选索引的有效范围在0和此方法返回的任何值之间。
        结果
        支持控制的数据模型中的项目数

      • focus

        public void focus​(int row)

      • getFocusedIndex

        public int getFocusedIndex​()

      • getSelectedIndices

        public ObservableList<Integer> getSelectedIndices​()
        描述从类别复制： MultipleSelectionModel

        返回所有选定索引的只读 ObservableList。 ObservableList将由选择模型更新以始终反映选择的变化。 这可以通过向返回的ObservableList添加一个ListChangeListener来观察。

        Specified by:
        getSelectedIndices在 MultipleSelectionModel<T>
        结果
        所选索引的列表

      • getSelectedItems

        public ObservableList<T> getSelectedItems​()
        说明从类别复制MultipleSelectionModel

        返回所有选定项目的只读 ObservableList。 ObservableList将通过选择模型进一步更新以始终反映选择的变化。 这可以通过向返回的ObservableList添加一个ListChangeListener来观察。

        Specified by:
        getSelectedItems在 MultipleSelectionModel<T>
        结果
        所选项目的列表

      • clearAndSelect

        public void clearAndSelect​(int row)
        描述从类别复制SelectionModel
        在将选择设置为给定索引之前清除任何选择的方法。 该方法的目的是避免首先调用SelectionModel.clearSelection() ，这意味着正在监听selected index属性的观察者将看不到所选索引临时设置为-1。
        Specified by:
        clearAndSelect在 SelectionModel<T>
        参数
        row - 应该是此选择模型中唯一选择的索引的索引。

      • select

        public void select​(int row)
        描述从类别SelectionModel复制

        这将在选择模型中选择给定的索引，假设索引在有效范围内（即大于或等于零，并且小于底层数据模型中的项目总数）。

        如果在此模型中已经选择了一个或多个索引，调用此方法将不会清除这些选择 - 为此，有必要首先调用SelectionModel.clearSelection() 。

        如果索引已被选中，则不会再次选择或未选择。 然而，如果实现了多个选择，那么在已经选择的索引上的调用选择将具有使索引成为新的所选索引的效果（由SelectionModel.getSelectedIndex()返回）。

        Specified by:
        select在 SelectionModel<T>
        参数
        row - 要在选择模型中选择的项目的位置。

      • select

        public void select​(T obj)
        描述从类别复制： SelectionModel

        此方法将尝试选择包含给定对象的索引。 它将遍历底层数据模型，直到找到一个值等于给定对象的项。 在这一点上它将停止迭代 - 这意味着该方法将不会选择多个索引。

        Specified by:
        select在 SelectionModel<T>
        参数
        obj - 要在底层数据模型中选择的对象。

      • selectIndices

        public void selectIndices​(int row,
                          int... rows)
        描述从类别MultipleSelectionModel复制

        该方法允许同时设置一个或多个选择。 它将忽略不在有效范围内的任何值（即大于或等于零，小于底层数据模型中的项目总数）。 任何重复的索引都将被忽略。

        如果在此模型中已经选择了一个或多个索引，则调用此方法将不会清除这些选择 - 为此，必须首先调用clearSelection。

        给定的最后一个有效值将成为所选择的索引/选定项目。

        Specified by:
        selectIndices在 MultipleSelectionModel<T>
        参数
        row - 第一个索引选择
        rows - 零个或多个附加索引进行选择

      • selectAll

        public void selectAll​()
        描述从类别复制： MultipleSelectionModel

        方便的方法来选择所有可用的索引。

        Specified by:
        selectAll在 MultipleSelectionModel<T>

      • selectFirst

        public void selectFirst​()
        描述从类复制： MultipleSelectionModel

        该方法将尝试选择控件中的第一个索引。 如果首先不调用clearSelection，则该方法将具有选择第一个索引的结果，同时保留对当前其他任何索引的选择。

        如果已经选择了第一个索引，调用此方法将不会产生任何结果，并且不会执行选择事件。

        Specified by:
        selectFirst在 MultipleSelectionModel<T>

      • selectLast

        public void selectLast​()
        说明从类别复制MultipleSelectionModel

        此方法将尝试选择控件中的最后一个索引。 如果没有首先调用clearSelection，则该方法将具有选择最后一个索引的结果，同时保留对其他当前选定索引的选择。

        如果最后一个索引已经被选中，调用该方法将不会有结果，并且不会发生选择事件。

        Specified by:
        selectLast在 MultipleSelectionModel<T>

      • clearSelection

        public void clearSelection​(int index)
        描述从类： SelectionModel复制

        该方法将清除给定索引中项目的选择。 如果没有选择给定的索引，则不会发生任何事情。

        Specified by:
        clearSelection在 SelectionModel<T>
        参数
        index - 要取消选择的选定项目。

      • clearSelection

        public void clearSelection​()
        说明从类别复制SelectionModel

        清除所有选定索引的选择模型。

        Specified by:
        clearSelection在 SelectionModel<T>

      • isSelected

        public boolean isSelected​(int index)
        描述从类SelectionModel复制

        通知此SelectionModel中当前选定给定索引的方便方法。 在功能上等同于调用getSelectedIndices().contains(index) 。

        Specified by:
        isSelected中的 SelectionModel<T>
        参数
        index - 检查当前是否选择的索引。
        结果
        如果给定的索引被选择，则为真，否则为false。

      • isEmpty

        public boolean isEmpty​()
        描述从类SelectionModel复制
        该方法可用于测试是否有任何选定的索引/项目。 如果没有选定的项目，它将返回true，如果有，则返回false。
        Specified by:
        isEmpty在 SelectionModel<T>
        结果
        如果 没有选择的项目将返回true，如果有的话将返回false。

      • selectPrevious

        public void selectPrevious​()
        描述从类SelectionModel复制

        此方法将尝试直接在当前聚焦索引之前选择索引。 如果没有首先调用clearSelection，则该方法将具有选择先前索引的结果，同时保留对其他当前选择的索引的选择。

        调用此方法将仅在以下情况下成功：

        • 目前有一个主角/重点指数。
        • 主要/焦点指数不是控制中的第一个指标。
        • 以前的索引尚未被选中。

        如果这些条件中的任何一个都是假的，则不会发生选择事件。

        Specified by:
        selectPrevious在 SelectionModel<T>

      • selectNext

        public void selectNext​()
        描述从类复制： SelectionModel

        此方法将尝试在当前焦点索引之后直接选择索引。 如果没有首先调用clearSelection，则该方法将具有选择下一个索引的结果，同时保留对任何其他当前选择的索引的选择。

        调用此方法将仅在以下情况下成功：

        • 目前有一个主角/重点指数。
        • 主要/焦点指数不是控件中的最后一个指标。
        • 下一个索引尚未被选中。

        如果这些条件中的任何一个都是假的，则不会发生选择事件。

        Specified by:
        selectNext in class SelectionModel<T>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TabPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TabPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.TabPane
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("tabs")
public class TabPane
extends Control

    允许在一组Tabs之间切换的控件 。 一次只能看到一个选项卡。 选项卡通过使用getTabs()添加到TabPane 。

    TabPane中的标签可以通过指定Side定位在四面中的任意一个 。

    TabPane有两种浮动或凹进的模式。 应用styleclass STYLE_CLASS_FLOATING将将TabPane模式更改为浮动。

    通过设置最小和最大的高度和宽度，可以将选项卡的宽度和高度设置为特定的大小。 TabPane默认宽度将由TabPane中最大的内容宽度确定。 这是相同的高度。 如果需要不同的尺寸，则可以通过设置min，pref和max尺寸来覆盖TabPane的宽度和高度。

    当选项卡的数量不符合TabPane时，右侧将出现一个菜单按钮。 菜单按钮用于选择当前不可见的选项卡。

    例：

       TabPane tabPane = new TabPane(); Tab tab = new Tab(); tab.setText("new tab"); tab.setContent(new Rectangle(200,200, Color.LIGHTSTEELBLUE)); tabPane.getTabs().add(tab);
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Tab

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty rotateGraphic
      TabPane中选项卡的rotateGraphic状态。
      ObjectProperty<SingleSelectionModel<Tab>> selectionModel
      用于选择标签的选择模型。
      ObjectProperty<Side> side
      TabPane中选项卡的位置。
      ObjectProperty<TabPane.TabClosingPolicy> tabClosingPolicy
      选项卡的关闭策略。
      DoubleProperty tabMaxHeight
      TabPane中选项卡的最大高度。
      DoubleProperty tabMaxWidth
      TabPane中选项卡的最大宽度。
      DoubleProperty tabMinHeight
      标签的最小高度。
      DoubleProperty tabMinWidth
      TabPane中选项卡的最小宽度。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TabPane.TabClosingPolicy
      这指定了TabPane如何处理从最终用户角度看待标签关闭。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String STYLE_CLASS_FLOATING
      TabPane模式将被更改为浮动，允许TabPane与其他控件一起放置。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TabPane​()
      构造一个新的TabPane。
      TabPane​(Tab... tabs)
      构造一个新的TabPane，其中给定的选项卡设置为显示。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      SingleSelectionModel<Tab> getSelectionModel​()
      获取用于选项卡选择的模型。
      Side getSide​()
      TabPane中选项卡的当前位置。
      TabPane.TabClosingPolicy getTabClosingPolicy​()
      选项卡的关闭策略。
      double getTabMaxHeight​()
      TabPane中选项卡的最大高度。
      double getTabMaxWidth​()
      TabPane中选项卡的最大宽度。
      double getTabMinHeight​()
      TabPane中选项卡的最小高度。
      double getTabMinWidth​()
      TabPane中选项卡的最小宽度。
      ObservableList<Tab> getTabs​()
      要在此TabPane中显示的选项卡。
      boolean isRotateGraphic​()
      如果Tab中的图形旋转，则返回 true 。
      Node lookup​(String selector)
      找到这个 Node ，或第一个子节点，基于给定的CSS选择器。
      Set<Node> lookupAll​(String selector)
      查找所有 Node s，包括这个和任何孩子，它们匹配给定的CSS选择器。
      BooleanProperty rotateGraphicProperty​()
      TabPane中选项卡的rotateGraphic状态。
      ObjectProperty<SingleSelectionModel<Tab>> selectionModelProperty​()
      用于选择标签的选择模型。
      void setRotateGraphic​(boolean value)
      指定Tab中的图形是否旋转，使其始终是直立的，或者以与Tab文本相同的方式旋转。
      void setSelectionModel​(SingleSelectionModel<Tab> value)
      设置用于选项卡选择的模型。
      void setSide​(Side value)
      将标签放置在此TabPane中的位置。
      void setTabClosingPolicy​(TabPane.TabClosingPolicy value)
      指定TabPane如何从最终用户角度处理标签关闭。
      void setTabMaxHeight​(double value)
      设置属性tabMaxHeight的值。
      void setTabMaxWidth​(double value)
      设置属性tabMaxWidth的值。
      void setTabMinHeight​(double value)
      TabPane中选项卡的最小高度。
      void setTabMinWidth​(double value)
      TabPane中选项卡的最小宽度。
      ObjectProperty<Side> sideProperty​()
      TabPane中选项卡的位置。
      ObjectProperty<TabPane.TabClosingPolicy> tabClosingPolicyProperty​()
      选项卡的关闭策略。
      DoubleProperty tabMaxHeightProperty​()
      TabPane中选项卡的最大高度。
      DoubleProperty tabMaxWidthProperty​()
      TabPane中选项卡的最大宽度。
      DoubleProperty tabMinHeightProperty​()
      标签的最小高度。
      DoubleProperty tabMinWidthProperty​()
      TabPane中选项卡的最小宽度。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • selectionModel

        public final ObjectProperty<SingleSelectionModel<Tab>> selectionModelProperty
        用于选择标签的选择模型。
        另请参见：
        getSelectionModel() ， setSelectionModel(SingleSelectionModel)

      • side

        public final ObjectProperty<Side> sideProperty
        TabPane中选项卡的位置。
        另请参见：
        getSide() ， setSide(Side)

      • tabClosingPolicy

        public final ObjectProperty<TabPane.TabClosingPolicy> tabClosingPolicyProperty
        选项卡的关闭策略。
        另请参见：
        getTabClosingPolicy() ， setTabClosingPolicy(TabPane.TabClosingPolicy)

      • rotateGraphic

        public final BooleanProperty rotateGraphicProperty
        TabPane中选项卡的rotateGraphic状态。
        另请参见：
        isRotateGraphic() ， setRotateGraphic(boolean)

      • tabMinWidth

        public final DoubleProperty tabMinWidthProperty
        TabPane中选项卡的最小宽度。
        另请参见：
        getTabMinWidth() ， setTabMinWidth(double)

      • tabMaxWidth

        public final DoubleProperty tabMaxWidthProperty
        TabPane中选项卡的最大宽度。
        结果
        最大宽度属性

      • tabMinHeight

        public final DoubleProperty tabMinHeightProperty
        标签的最小高度。
        另请参见：
        getTabMinHeight() ， setTabMinHeight(double)

      • tabMaxHeight

        public final DoubleProperty tabMaxHeightProperty

        TabPane中选项卡的最大高度。

        结果
        标签的最大高度

    • 字段详细信息

      • STYLE_CLASS_FLOATING

        public static final String STYLE_CLASS_FLOATING
        TabPane模式将被更改为浮动，允许TabPane与其他控件一起放置。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • TabPane

        public TabPane​()
        构造一个新的TabPane。

      • TabPane

        public TabPane​(Tab... tabs)
        构造一个新的TabPane，其中给定的选项卡设置为显示。
        参数
        tabs - 要在TabPane中显示的tabs。
        从以下版本开始：
        JavaFX 8u40

    • 方法详细信息

      • getTabs

        public final ObservableList<Tab> getTabs​()

        要在此TabPane中显示的选项卡。 更改此ObservableList将立即导致TabPane更新以显示此ObservableList的新内容。

        如果选项卡ObservableList发生更改，则选定的选项卡将保留在先前选定的选项卡中，如果该选项卡保留在此ObservableList中。 如果先前选择的选项卡不再位于“可观察列表”选项卡中，则所选选项卡将成为“可观察列表”中的第一个选项卡。

        结果
        标签列表

      • setSelectionModel

        public final void setSelectionModel​(SingleSelectionModel<Tab> value)

        设置用于选项卡选择的模型。 通过更改模型，您可以更改选项卡的选择以及哪些选项卡是第一个还是最后一个。

        参数
        value - 选择模型

      • getSelectionModel

        public final SingleSelectionModel<Tab> getSelectionModel​()

        获取用于选项卡选择的模型。

        结果
        用于选项卡选择的模型

      • selectionModelProperty

        public final ObjectProperty<SingleSelectionModel<Tab>> selectionModelProperty​()
        用于选择标签的选择模型。
        另请参见：
        getSelectionModel() ， setSelectionModel(SingleSelectionModel)

      • setSide

        public final void setSide​(Side value)

        将标签放置在此TabPane中的位置。 每当这个更改TabPane将立即更新选项卡的位置以反映这一点。

        参数
        value - 一边

      • getSide

        public final Side getSide​()
        TabPane中选项卡的当前位置。 选项卡的默认位置是Side.Top。
        结果
        TabPane中选项卡的当前位置。

      • sideProperty

        public final ObjectProperty<Side> sideProperty​()
        TabPane中选项卡的位置。
        另请参见：
        getSide() ， setSide(Side)

      • setTabClosingPolicy

        public final void setTabClosingPolicy​(TabPane.TabClosingPolicy value)

        指定TabPane如何从最终用户角度处理标签关闭。 选项是：

        • TabClosingPolicy.UNAVAILABLE：用户无法关闭选项卡
        • TabClosingPolicy.SELECTED_TAB：只有当前选定的选项卡可以选择关闭，并显示标签文本旁边的图形。 当不再选择选项卡时，图形将消失。
        • TabClosingPolicy.ALL_TABS：所有选项卡都可以选择关闭。

        有关详细信息，请参阅TabPane.TabClosingPolicy枚举。

        默认关闭策略为TabClosingPolicy.SELECTED_TAB
        参数
        value - 关闭政策

      • getTabClosingPolicy

        public final TabPane.TabClosingPolicy getTabClosingPolicy​()
        选项卡的关闭策略。
        结果
        选项卡的关闭策略。

      • tabClosingPolicyProperty

        public final ObjectProperty<TabPane.TabClosingPolicy> tabClosingPolicyProperty​()
        选项卡的关闭策略。
        另请参见：
        getTabClosingPolicy() ， setTabClosingPolicy(TabPane.TabClosingPolicy)

      • setRotateGraphic

        public final void setRotateGraphic​(boolean value)

        指定Tab中的图形是否旋转，使其始终是直立的，或者以与Tab文本相同的方式旋转。

        默认情况下，rotateGraphic设置为false，以表示图形不旋转的事实，导致它始终显示为直立。 如果rotateGraphic设置为true ，则图形将旋转，使其与标签文本一起旋转。

        参数
        value - 表示是否旋转图形的标志

      • isRotateGraphic

        public final boolean isRotateGraphic​()
        如果Tab中的图形旋转，则返回true 。 默认值为false
        结果
        旋转图形状态。

      • rotateGraphicProperty

        public final BooleanProperty rotateGraphicProperty​()
        TabPane中选项卡的rotateGraphic状态。
        另请参见：
        isRotateGraphic() ， setRotateGraphic(boolean)

      • setTabMinWidth

        public final void setTabMinWidth​(double value)

        TabPane中选项卡的最小宽度。 这可以用来限制标签中的文本长度以防止截断。 将min设置为最大值将修复选项卡的宽度。 默认情况下，min等于max。 此值也可以通过CSS使用-fx-tab-min-width设置

        参数
        value - 选项卡的最小宽度

      • getTabMinWidth

        public final double getTabMinWidth​()
        TabPane中选项卡的最小宽度。
        结果
        标签的最小宽度

      • tabMinWidthProperty

        public final DoubleProperty tabMinWidthProperty​()
        TabPane中选项卡的最小宽度。
        另请参见：
        getTabMinWidth() ， setTabMinWidth(double)

      • setTabMaxWidth

        public final void setTabMaxWidth​(double value)
        设置属性tabMaxWidth的值。
        Property description:

        指定选项卡的最大宽度。 这可以用来限制选项卡中的文本长度。 如果选项卡文本长于文本的最大宽度将被截断。 将max设置为最小值将会固定选项卡的宽度。 默认情况下，min等于max该值也可以通过CSS使用-fx-tab-max-width设置。

      • getTabMaxWidth

        public final double getTabMaxWidth​()
        TabPane中选项卡的最大宽度。
        结果
        标签的最大宽度

      • tabMaxWidthProperty

        public final DoubleProperty tabMaxWidthProperty​()
        TabPane中选项卡的最大宽度。
        结果
        最大宽度属性

      • setTabMinHeight

        public final void setTabMinHeight​(double value)

        TabPane中选项卡的最小高度。 这可以用来限制选项卡中的高度。 将最小值设置为最大值将修复选项卡的高度。 默认情况下，min等于max。 此值也可以通过CSS使用-fx-tab-min-height设置

        参数
        value - 标签的最小高度

      • getTabMinHeight

        public final double getTabMinHeight​()
        TabPane中选项卡的最小高度。
        结果
        标签的最小高度

      • tabMinHeightProperty

        public final DoubleProperty tabMinHeightProperty​()
        标签的最小高度。
        另请参见：
        getTabMinHeight() ， setTabMinHeight(double)

      • setTabMaxHeight

        public final void setTabMaxHeight​(double value)
        设置属性tabMaxHeight的值。
        Property description:

        TabPane中的选项卡的最大高度。 这可以用来限制选项卡中的高度。 将max设置为min将会固定标签的高度。 默认情况下，min等于max。 也可以使用-fx-tab-max-height通过CSS设置此值

      • getTabMaxHeight

        public final double getTabMaxHeight​()
        TabPane中选项卡的最大高度。
        结果
        标签的最大高度

      • tabMaxHeightProperty

        public final DoubleProperty tabMaxHeightProperty​()

        TabPane中选项卡的最大高度。

        结果
        标签的最大高度

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • lookup

        public Node lookup​(String selector)
        根据给定的CSS选择器，找到这个Node或第一个子节点。 如果此节点为Parent ，则该函数将遍历到分支中，直到找到匹配项。 如果多个子节点与指定的选择器匹配，则此函数返回其中的第一个。

        例如，如果节点的ID为“myId”，则可以使用查找方法来查找此节点，如下所示： scene.lookup("#myId"); 。

        重写：
        lookup在 Parent
        参数
        selector - 要查找的节点的css选择器
        结果
        第一个节点，从这个 Node开始，与CSS selector匹配，如果没有找到， selector null。

      • lookupAll

        public Set<Node> lookupAll​(String selector)
        查找所有Node s，包括这个和任何孩子，匹配给定的CSS选择器。 如果没有找到匹配项，则返回一个空的不可修改的集合。 该集合是明确无序的。
        重写：
        lookupAll在 Node
        参数
        selector - 要查找的节点的css选择器
        结果
        所有节点，从包含这个Node ，它与CSS selector匹配。 返回的集合始终是无序的，不可修改的，永远不会为空。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TabPane.TabClosingPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum TabPane.TabClosingPolicy

  • java.lang.Object
    • java.lang.Enum<TabPane.TabClosingPolicy>
      • javafx.scene.control.TabPane.TabClosingPolicy
  • All Implemented Interfaces:
    Serializable ， Comparable<TabPane.TabClosingPolicy>
    Enclosing class:
    TabPane

    public static enum TabPane.TabClosingPolicy
extends Enum<TabPane.TabClosingPolicy>

    这指定了TabPane如何处理从最终用户角度看待标签关闭。 选项是：

    • TabClosingPolicy.UNAVAILABLE：用户无法关闭选项卡
    • TabClosingPolicy.SELECTED_TAB：只有当前选定的选项卡可以选择关闭，并显示标签文本旁边的图形。 当不再选择选项卡时，图形将消失。
    • TabClosingPolicy.ALL_TABS：所有选项卡都可以选择关闭。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALL_TABS
      所有选项卡都可以选择关闭。
      SELECTED_TAB
      只有当前选中的选项卡可以选择关闭，并显示标签文本旁边的图形。
      UNAVAILABLE
      选项卡不能被用户关闭。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TabPane.TabClosingPolicy valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TabPane.TabClosingPolicy[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SELECTED_TAB

        public static final TabPane.TabClosingPolicy SELECTED_TAB
        只有当前选中的选项卡可以选择关闭，并显示标签文本旁边的图形。 当不再选择选项卡时，图形将消失。

      • ALL_TABS

        public static final TabPane.TabClosingPolicy ALL_TABS
        所有选项卡都可以选择关闭。

      • UNAVAILABLE

        public static final TabPane.TabClosingPolicy UNAVAILABLE
        选项卡不能被用户关闭。

    • 方法详细信息

      • values

        public static TabPane.TabClosingPolicy[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TabPane.TabClosingPolicy c : TabPane.TabClosingPolicy.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TabPane.TabClosingPolicy valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TextArea (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TextArea

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.TextInputControl
              • javafx.scene.control.TextArea
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class TextArea
extends TextInputControl
    文本输入组件，允许用户输入多行纯文本。 与以前的JavaFX版本不同，对单行输入的支持不能作为TextArea控件的一部分提供，但这是TextField控件的唯一目的。 另外，如果你想要一个富文本编辑的形式，还有HTMLEditor控件。

    当TextArea中没有text （通过用户或以编程方式设置））时，TextArea支持向用户显示prompt text的概念。 这是向用户通知文本区域中预期的内容的有用方式，而无需诉诸tooltips或屏幕上的labels 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TextField

    • Property Summary

      Properties
      Type Property 描述
      IntegerProperty prefColumnCount
      文本列的首选数量。
      IntegerProperty prefRowCount
      文本行的首选数量。
      DoubleProperty scrollLeft
      内容水平滚动的像素数。
      DoubleProperty scrollTop
      垂直滚动内容的像素数。
      BooleanProperty wrapText
      如果文本的运行超出了 TextArea的宽度，则该变量指示文本是否应该 TextArea另一行。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TextInputControl

        anchor, caretPosition, editable, font, length, promptText, redoable, selectedText, selection, textFormatter, text, undoable

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.control.TextInputControl

        TextInputControl.Content

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DEFAULT_PREF_COLUMN_COUNT
      默认值为 prefColumnCount 。
      static int DEFAULT_PREF_ROW_COUNT
      默认值为 prefRowCount 。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextArea​()
      创建一个 TextArea空文本内容。
      TextArea​(String text)
      创建一个包含初始文本内容的 TextArea 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      ObservableList<CharSequence> getParagraphs​()
      返回返回文本区域内容的字符序列的不可修改列表。
      int getPrefColumnCount​()
      获取属性prefColumnCount的值。
      int getPrefRowCount​()
      获取属性prefRowCount的值。
      double getScrollLeft​()
      获取属性scrollLeft的值。
      double getScrollTop​()
      获取属性scrollTop的值。
      boolean isWrapText​()
      获取propertyTextText的值。
      IntegerProperty prefColumnCountProperty​()
      文本列的首选数量。
      IntegerProperty prefRowCountProperty​()
      文本行的首选数量。
      DoubleProperty scrollLeftProperty​()
      内容水平滚动的像素数。
      DoubleProperty scrollTopProperty​()
      垂直滚动内容的像素数。
      void setPrefColumnCount​(int value)
      设置属性prefColumnCount的值。
      void setPrefRowCount​(int value)
      设置属性prefRowCount的值。
      void setScrollLeft​(double value)
      设置属性scrollLeft的值。
      void setScrollTop​(double value)
      设置属性scrollTop的值。
      void setWrapText​(boolean value)
      设置属性wrapText的值。
      BooleanProperty wrapTextProperty​()
      如果文本的运行超出了 TextArea的宽度，则该变量指示文本是否应该 TextArea另一行。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TextInputControl

        anchorProperty, appendText, backward, cancelEdit, caretPositionProperty, clear, commitValue, copy, cut, deleteNextChar, deletePreviousChar, deleteText, deleteText, deselect, editableProperty, end, endOfNextWord, executeAccessibleAction, extendSelection, fontProperty, forward, getAnchor, getCaretPosition, getContent, getFont, getLength, getPromptText, getSelectedText, getSelection, getText, getText, getTextFormatter, home, insertText, isEditable, isRedoable, isUndoable, lengthProperty, nextWord, paste, positionCaret, previousWord, promptTextProperty, queryAccessibleAttribute, redo, redoableProperty, replaceSelection, replaceText, replaceText, selectAll, selectBackward, selectedTextProperty, selectEnd, selectEndOfNextWord, selectForward, selectHome, selectionProperty, selectNextWord, selectPositionCaret, selectPreviousWord, selectRange, setEditable, setFont, setPromptText, setText, setTextFormatter, textFormatterProperty, textProperty, undo, undoableProperty

    • Property Detail

      • wrapText

        public final BooleanProperty wrapTextProperty
        如果文本的运行超出了 TextArea的宽度，则该变量指示文本是否应该 TextArea另一行。
        另请参见：
        isWrapText() ， setWrapText(boolean)

      • prefColumnCount

        public final IntegerProperty prefColumnCountProperty
        文本列的首选数量。 这用于计算TextArea的首选宽度。
        另请参见：
        getPrefColumnCount() ， setPrefColumnCount(int)

      • prefRowCount

        public final IntegerProperty prefRowCountProperty
        文本行的首选数量。 这用于计算TextArea的首选高度。
        另请参见：
        getPrefRowCount() ， setPrefRowCount(int)

      • scrollTop

        public final DoubleProperty scrollTopProperty
        垂直滚动内容的像素数。
        另请参见：
        getScrollTop() ， setScrollTop(double)

      • scrollLeft

        public final DoubleProperty scrollLeftProperty
        内容水平滚动的像素数。
        另请参见：
        getScrollLeft() ， setScrollLeft(double)

    • 字段详细信息

      • DEFAULT_PREF_COLUMN_COUNT

        public static final int DEFAULT_PREF_COLUMN_COUNT
        默认值为 prefColumnCount 。
        另请参见：
        Constant Field Values

      • DEFAULT_PREF_ROW_COUNT

        public static final int DEFAULT_PREF_ROW_COUNT
        默认值为 prefRowCount 。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • TextArea

        public TextArea​()
        创建一个 TextArea空文本内容。

      • TextArea

        public TextArea​(String text)
        创建一个 TextArea与初始文本内容。
        参数
        text - 文本内容的字符串。

    • 方法详细信息

      • getParagraphs

        public ObservableList<CharSequence> getParagraphs​()
        返回返回文本区域内容的字符序列的不可修改列表。
        结果
        字符序列的不可修改列表，用于返回文本区域的内容

      • wrapTextProperty

        public final BooleanProperty wrapTextProperty​()
        如果文本运行超过了 TextArea的宽度，则该变量指示文本是否应该包装到另一行。
        另请参见：
        isWrapText() ， setWrapText(boolean)

      • isWrapText

        public final boolean isWrapText​()
        获取propertyTextText的值。
        Property description:
        如果文本的运行超出了 TextArea的宽度，则该变量指示文本是否应该 TextArea另一行。

      • setWrapText

        public final void setWrapText​(boolean value)
        设置属性wrapText的值。
        Property description:
        如果文本的运行超出了 TextArea的宽度，则该变量指示文本是否应该 TextArea另一行。

      • prefColumnCountProperty

        public final IntegerProperty prefColumnCountProperty​()
        文本列的首选数量。 这用于计算TextArea的首选宽度。
        另请参见：
        getPrefColumnCount() ， setPrefColumnCount(int)

      • getPrefColumnCount

        public final int getPrefColumnCount​()
        获取属性prefColumnCount的值。
        Property description:
        文本列的首选数量。 这用于计算TextArea的首选宽度。

      • setPrefColumnCount

        public final void setPrefColumnCount​(int value)
        设置属性prefColumnCount的值。
        Property description:
        文本列的首选数量。 这用于计算TextArea的首选宽度。

      • prefRowCountProperty

        public final IntegerProperty prefRowCountProperty​()
        文本行的首选数量。 这用于计算TextArea的首选高度。
        另请参见：
        getPrefRowCount() ， setPrefRowCount(int)

      • getPrefRowCount

        public final int getPrefRowCount​()
        获取属性prefRowCount的值。
        Property description:
        文本行的首选数量。 这用于计算TextArea的首选高度。

      • setPrefRowCount

        public final void setPrefRowCount​(int value)
        设置属性prefRowCount的值。
        Property description:
        文本行的首选数量。 这用于计算TextArea的首选高度。

      • scrollTopProperty

        public final DoubleProperty scrollTopProperty​()
        垂直滚动内容的像素数。
        另请参见：
        getScrollTop() ， setScrollTop(double)

      • getScrollTop

        public final double getScrollTop​()
        获取属性scrollTop的值。
        Property description:
        垂直滚动内容的像素数。

      • setScrollTop

        public final void setScrollTop​(double value)
        设置属性scrollTop的值。
        Property description:
        垂直滚动内容的像素数。

      • scrollLeftProperty

        public final DoubleProperty scrollLeftProperty​()
        内容水平滚动的像素数。
        另请参见：
        getScrollLeft() ， setScrollLeft(double)

      • getScrollLeft

        public final double getScrollLeft​()
        获取属性scrollLeft的值。
        Property description:
        内容水平滚动的像素数。

      • setScrollLeft

        public final void setScrollLeft​(double value)
        设置属性scrollLeft的值。
        Property description:
        内容水平滚动的像素数。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤，或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData TextInputControl
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TextField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TextField

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.TextInputControl
              • javafx.scene.control.TextField
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    PasswordField

    public class TextField
extends TextInputControl
    文本输入组件，允许用户输入一行未格式化的文本。 与以前的JavaFX版本不同，对多线输入的支持不能作为TextField控件的一部分提供，但这是TextArea控件的唯一目的。 另外，如果你想要一个富文本编辑的形式，还有HTMLEditor控件。

    TextField支持在TextField中没有text （通过用户或以编程方式设置）时向用户显示prompt text的概念。 这是一种有用的方法，可以通知用户文本字段中的预期内容，而无需使用tooltips或屏幕labels 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TextArea

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Pos> alignment
      指定当TextField中有空格时如何对齐文本。
      ObjectProperty<EventHandler<ActionEvent>> onAction
      与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。
      IntegerProperty prefColumnCount
      文本列的首选数量。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TextInputControl

        anchor, caretPosition, editable, font, length, promptText, redoable, selectedText, selection, textFormatter, text, undoable

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.control.TextInputControl

        TextInputControl.Content

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DEFAULT_PREF_COLUMN_COUNT
      默认值为 prefColumnCount 。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextField​()
      创建一个 TextField空文本内容。
      TextField​(String text)
      创建一个 TextField与初始文本内容。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Pos> alignmentProperty​()
      指定当TextField中有空格时如何对齐文本。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      Pos getAlignment​()
      获取属性对齐的值。
      CharSequence getCharacters​()
      返回支持文本字段内容的字符序列。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      EventHandler<ActionEvent> getOnAction​()
      获取属性onAction的值。
      int getPrefColumnCount​()
      获取属性prefColumnCount的值。
      ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
      与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。
      IntegerProperty prefColumnCountProperty​()
      文本列的首选数量。
      void setAlignment​(Pos value)
      设置属性对齐的值。
      void setOnAction​(EventHandler<ActionEvent> value)
      设置属性onAction的值。
      void setPrefColumnCount​(int value)
      设置属性prefColumnCount的值。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TextInputControl

        anchorProperty, appendText, backward, cancelEdit, caretPositionProperty, clear, commitValue, copy, cut, deleteNextChar, deletePreviousChar, deleteText, deleteText, deselect, editableProperty, end, endOfNextWord, executeAccessibleAction, extendSelection, fontProperty, forward, getAnchor, getCaretPosition, getContent, getFont, getLength, getPromptText, getSelectedText, getSelection, getText, getText, getTextFormatter, home, insertText, isEditable, isRedoable, isUndoable, lengthProperty, nextWord, paste, positionCaret, previousWord, promptTextProperty, queryAccessibleAttribute, redo, redoableProperty, replaceSelection, replaceText, replaceText, selectAll, selectBackward, selectedTextProperty, selectEnd, selectEndOfNextWord, selectForward, selectHome, selectionProperty, selectNextWord, selectPositionCaret, selectPreviousWord, selectRange, setEditable, setFont, setPromptText, setText, setTextFormatter, textFormatterProperty, textProperty, undo, undoableProperty

    • Property Detail

      • prefColumnCount

        public final IntegerProperty prefColumnCountProperty
        文本列的首选数量。 这用于计算TextField的首选宽度。
        另请参见：
        getPrefColumnCount() ， setPrefColumnCount(int)

      • onAction

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty
        与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。 通常在用户键入ENTER键时调用操作处理程序。
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • alignment

        public final ObjectProperty<Pos> alignmentProperty
        指定当TextField中有空格时如何对齐文本。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getAlignment() ， setAlignment(Pos)

    • 字段详细信息

      • DEFAULT_PREF_COLUMN_COUNT

        public static final int DEFAULT_PREF_COLUMN_COUNT
        默认值为 prefColumnCount 。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • TextField

        public TextField​()
        创建一个 TextField空文本内容。

      • TextField

        public TextField​(String text)
        创建一个 TextField与初始文本内容。
        参数
        text - 文本内容的字符串。

    • 方法详细信息

      • getCharacters

        public CharSequence getCharacters​()
        返回支持文本字段内容的字符序列。
        结果
        字符序列支持文本字段的内容

      • prefColumnCountProperty

        public final IntegerProperty prefColumnCountProperty​()
        文本列的首选数量。 这用于计算TextField的首选宽度。
        另请参见：
        getPrefColumnCount() ， setPrefColumnCount(int)

      • getPrefColumnCount

        public final int getPrefColumnCount​()
        获取属性prefColumnCount的值。
        Property description:
        文本列的首选数量。 这用于计算TextField的首选宽度。

      • setPrefColumnCount

        public final void setPrefColumnCount​(int value)
        设置属性prefColumnCount的值。
        Property description:
        文本列的首选数量。 这用于计算TextField的首选宽度。

      • onActionProperty

        public final ObjectProperty<EventHandler<ActionEvent>> onActionProperty​()
        与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。 通常在用户键入ENTER键时调用操作处理程序。
        另请参见：
        getOnAction() ， setOnAction(EventHandler)

      • getOnAction

        public final EventHandler<ActionEvent> getOnAction​()
        获取属性onAction的值。
        Property description:
        与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。 通常在用户键入ENTER键时调用操作处理程序。

      • setOnAction

        public final void setOnAction​(EventHandler<ActionEvent> value)
        设置属性onAction的值。
        Property description:
        与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。 通常在用户键入ENTER键时调用操作处理程序。

      • alignmentProperty

        public final ObjectProperty<Pos> alignmentProperty​()
        指定当TextField中有空格时如何对齐文本。
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • setAlignment

        public final void setAlignment​(Pos value)
        设置属性对齐的值。
        Property description:
        指定当TextField中有空格时如何对齐文本。
        从以下版本开始：
        JavaFX 2.1

      • getAlignment

        public final Pos getAlignment​()
        获取属性对齐的值。
        Property description:
        指定当TextField中有空格时如何对齐文本。
        从以下版本开始：
        JavaFX 2.1

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则会调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 TextInputControl
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TextFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TextFormatter<V>

  • java.lang.Object
    • javafx.scene.control.TextFormatter<V>
  • 参数类型
    V - 值的类型

    public class TextFormatter<V>
extends Object
    格式化器通过使用两种不同的机制来描述TextInputControl文本的格式：
    • 可以拦截和修改用户输入的过滤器（ getFilter() ）。 这有助于保持所需格式的文本。 可以使用默认文本供应商来提供初始文本。
    • 值转换器（ getValueConverter() ）和值（ valueProperty() ）可用于提供表示V型值的特殊格式。 如果控件是可编辑的，并且文本被用户改变，则该值被更新为对应于文本。

    只需要一个格式化器就可以使用过滤器或值转换器。 如果不提供值转换器，则设置一个值将导致一个IllegalStateException ，该值始终为空。

    由于Formatter包含一个表示其当前分配到的TextInputControl的状态的值，因此一个Formatter实例只能在一个TextInputControl中使用。

    从以下版本开始：
    JavaFX 8u40

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<V> value
      该格式化程序的当前值。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TextFormatter.Change
      包含表示TextInputControl的内容或选择更改的状态。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static StringConverter<String> IDENTITY_STRING_CONVERTER
      该字符串转换器将文本转换为相同的String值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextFormatter​(UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器创建一个新的Formatter。
      TextFormatter​(StringConverter<V> valueConverter)
      使用提供的值转换器创建一个新的格式化器。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue)
      使用提供的值转换器和默认值创建一个新的格式化器。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue, UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器，值转换器和默认值创建一个新的格式化器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      UnaryOperator<TextFormatter.Change> getFilter​()
      过滤器允许用户截取和修改对文本内容所做的任何更改。
      V getValue​()
      获取属性值的值。
      StringConverter<V> getValueConverter​()
      值之间的转换器和文本。
      void setValue​(V value)
      设置属性值的值。
      ObjectProperty<V> valueProperty​()
      该格式化程序的当前值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • value

        public final ObjectProperty<V> valueProperty
        该格式化程序的当前值。 当格式化器设置为TextInputControl并具有valueConverter ，该值由控件在文本被valueConverter设置。
        另请参见：
        getValue() ， setValue(V)

    • 字段详细信息

      • IDENTITY_STRING_CONVERTER

        public static final StringConverter<String> IDENTITY_STRING_CONVERTER
        该字符串转换器将文本转换为相同的String值。 这对于您想要通过该值操作文本或需要提供默认文本值的情况可能很有用。

    • 构造方法详细信息

      • TextFormatter

        public TextFormatter​(UnaryOperator<TextFormatter.Change> filter)
        使用提供的过滤器创建一个新的Formatter。
        参数
        filter - 在此格式化程序中使用的过滤器或null

      • TextFormatter

        public TextFormatter​(StringConverter<V> valueConverter,
                     V defaultValue,
                     UnaryOperator<TextFormatter.Change> filter)
        使用提供的过滤器，值转换器和默认值创建一个新的格式化器。
        参数
        valueConverter - 在此格式化程序中使用的值转换器或null。
        defaultValue - 默认值。
        filter - 在此格式化程序中使用的过滤器或null

      • TextFormatter

        public TextFormatter​(StringConverter<V> valueConverter,
                     V defaultValue)
        使用提供的值转换器和默认值创建一个新的格式化器。
        参数
        valueConverter - 在此格式化程序中使用的值转换器。 这不能为空。
        defaultValue - 默认值

      • TextFormatter

        public TextFormatter​(StringConverter<V> valueConverter)
        使用提供的值转换器创建一个新的格式化器。 默认值为null。
        参数
        valueConverter - 在此格式化程序中使用的值转换器。 这不能为空。

    • 方法详细信息

      • getValueConverter

        public final StringConverter<V> getValueConverter​()
        值之间的转换器和文本。 它保持TextInputControl.textProperty() }和valueProperty() }之间的“绑定”。 当控件失去焦点或被提交时，该值被更新（仅限TextField）。 使用提供的转换器设置值将更新控件的文本。 如果不可能将文本转换为值，则应抛出异常。
        结果
        StringConverter为值，如果没有提供则为null
        另请参见：
        TextInputControl.commitValue() ， TextInputControl.cancelEdit()

      • getFilter

        public final UnaryOperator<TextFormatter.Change> getFilter​()
        过滤器允许用户截取和修改对文本内容所做的任何更改。

        该过滤器本身是一个UnaryOperator接受TextFormatter.Change对象。 它应该返回一个包含实际（过滤的）更改的TextFormatter.Change对象。 返回null拒绝更改。

        结果
        这个格式化程序的过滤器，如果没有，则返回null

      • valueProperty

        public final ObjectProperty<V> valueProperty​()
        该格式化程序的当前值。 当格式化程序设置为TextInputControl并具有valueConverter ，该值由控件在文本被valueConverter设置。
        另请参见：
        getValue() ， setValue(V)

      • setValue

        public final void setValue​(V value)
        设置属性值的值。
        Property description:
        该格式化程序的当前值。 当格式化器设置在TextInputControl并且具有valueConverter ，该值由控件在文本被valueConverter设置。

      • getValue

        public final V getValue​()
        获取属性值的值。
        Property description:
        该格式化程序的当前值。 当格式化器设置为TextInputControl并具有valueConverter ，该值由控件设置，当文本被提交时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TextFormatter.Change (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TextFormatter.Change

  • java.lang.Object
    • javafx.scene.control.TextFormatter.Change
  • All Implemented Interfaces:
    Cloneable
    Enclosing class:
    TextFormatter < V >

    public static final class TextFormatter.Change
extends Object
implements Cloneable
    包含表示TextInputControl的内容或选择更改的状态。 每当TextInputControl的文本被修改时，该对象将传递给TextInputControl上的任何注册的formatter 。

    该类包含用于确定控件上发生什么变化的状态和方便方法。 它还引用了TextInputControl本身，以便开发人员可以查询控件上的任何其他状态。 请注意，您不应该直接从格式化程序处理程序中修改控件的状态。

    文本的变化是由范围 （描述getRangeStart() ， getRangeEnd() ）和文本（ getText() 。有3箱子可能发生：

    • 一些文字被删除：在这种情况下， text是空的， range表示删除的文本的range 。 例如，在文本“Lorem ipsum dolor sit amet”中，删除第二个字将导致range （6,11）和一个空的text 。 同样，如果要删除一些不同的或者附加的文字，只要设置range 。 如果要删除第一个字而不是第二个字，请拨打setRange(0,5)
    • 添加了一些文本：现在range是空的（意味着没有删除），但它的价值还是很重要的。 range的开始和结束点指向添加新文本的索引。 例如加入“ipsum的”到“的Lorem悲坐阿梅特”将导致具有变化range的（6,6）和text包含字符串“文字”。
    • 一些文字被替换： 2个以上的组合。 text和range都不为空。 在文本range被删除并替换为text的变化。 添加新文本而不是旧文本，它在range的开头。 例如，当删除某些文本时，您可以通过设置新文本（ setText("new text") ）来简单地替换一些占位符文本，

    变化是可变的，但不可观察。 它应该只用于一次变化的生命。 意图是将更改从格式化程序中修改。

    从以下版本开始：
    JavaFX 8u40

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TextFormatter.Change clone​()
      创建并返回此对象的副本。
      int getAnchor​()
      获得新的锚点。
      int getCaretPosition​()
      获得新的插入位置。
      Control getControl​()
      获取与此更改相关联的控件。
      int getControlAnchor​()
      获取控件的当前锚定位置。
      int getControlCaretPosition​()
      获取控件的当前插入位置。
      String getControlNewText​()
      获取完整的新文本，将在此更改后用于控件。
      String getControlText​()
      这是控制在更改之前的全文。
      int getRangeEnd​()
      获取最终索引到 TextInputControl.getText()进行修改。
      int getRangeStart​()
      获取起始索引到 TextInputControl.getText()进行修改。
      IndexRange getSelection​()
      获取此更改的选择。
      String getText​()
      获取此更改中使用的文本。
      boolean isAdded​()
      获取此更改是否响应添加的文本。
      boolean isContentChange​()
      内容更改是任何添加，删除或替换更改。
      boolean isDeleted​()
      获取此更改是否正在删除文本。
      boolean isReplaced​()
      获取此更改是否正在替换文本。
      void selectRange​(int newAnchor, int newCaretPosition)
      设置选择。
      void setAnchor​(int newAnchor)
      设置锚点。
      void setCaretPosition​(int newCaretPosition)
      设置插入位置。
      void setRange​(int start, int end)
      一种将起始值和结束值分配在一起的方法，以确保它们相对于彼此有效。
      void setText​(String value)
      设置在此更改中使用的文本。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getControl

        public final Control getControl​()
        获取与此更改相关联的控件。
        结果
        与此更改相关联的控件。 这将永远不会为空。

      • getRangeStart

        public final int getRangeStart​()
        获取起始索引到TextInputControl.getText()进行修改。 这将永远是一个值> 0和<= TextInputControl.getLength() 。
        结果
        开始索引

      • getRangeEnd

        public final int getRangeEnd​()
        获取最终索引到TextInputControl.getText()进行修改。 这将永远是一个值> getRangeStart()和<= TextInputControl.getLength() 。
        结果
        最终索引

      • setRange

        public final void setRange​(int start,
                           int end)
        一种将起始值和结束值分配在一起的方法，以确保它们相对于彼此有效。 开始必须小于或等于结束。
        参数
        start - 新的起始值。 必须是有效的起始值
        end - 新的结束值。 必须是有效的结束值

      • getCaretPosition

        public final int getCaretPosition​()
        获得新的插入位置。 该值始终为> 0，<= getControlNewText() .getLength（）}
        结果
        新的插入位置

      • getAnchor

        public final int getAnchor​()
        获得新的锚点。 该值始终为> 0，<= getControlNewText() .getLength（）}
        结果
        新的职位

      • getControlCaretPosition

        public final int getControlCaretPosition​()
        获取控件的当前插入位置。
        结果
        以前的插入位置

      • getControlAnchor

        public final int getControlAnchor​()
        获取控件的当前锚定位置。
        结果
        以前的锚

      • selectRange

        public final void selectRange​(int newAnchor,
                              int newCaretPosition)
        设置选择。 锚点和插入位置值必须> 0和<= getControlNewText() .getLength（）}。 请注意，这里有一个顺序依赖，因为在指定新文本后应该指定位置。
        参数
        newAnchor - 新的锚点位置
        newCaretPosition - 新的插入位置

      • getSelection

        public final IndexRange getSelection​()
        获取此更改的选择。 注意，选择范围是指getControlNewText() ，而不是当前的控制文本。
        结果
        这个变化的选定范围。

      • setAnchor

        public final void setAnchor​(int newAnchor)
        设置锚点。 锚点值必须大于0且<= getControlNewText() .getLength（）}。 请注意，这里有一个顺序依赖，因为在指定新文本之后应该指定该位置。
        参数
        newAnchor - 新的职位

      • setCaretPosition

        public final void setCaretPosition​(int newCaretPosition)
        设置插入位置。 插入位置值必须大于0且<= getControlNewText() .getLength（）}。 请注意，这里有一个顺序依赖，因为在指定新文本之后应该指定该位置。
        参数
        newCaretPosition - 新的插入位置

      • getText

        public final String getText​()
        获取此更改中使用的文本。 例如，这可能是要添加的新文本，或正在替换开始和结束范围内的所有控件文本的文本。 通常，只有在删除范围的情况下，它才是空字符串。
        结果
        涉及这一变化的案文。 这将永远不会为空。

      • setText

        public final void setText​(String value)
        设置在此更改中使用的文本。 这用于替换从开始到结束的范围，如果这样的范围存在，或者在由start == end表示的位置插入文本。
        参数
        value - 文字。 这不能为空。

      • getControlText

        public final String getControlText​()
        这是控制在更改之前的全文。 要在此更改后获取文本，请使用getControlNewText() 。
        结果
        以前的控制文本

      • getControlNewText

        public final String getControlNewText​()
        获取完整的新文本，将在此更改后用于控件。 请注意，某些控件（例如TextField）可能会在进行更改后进行进一步过滤（例如剥离换行符），以便您不能假定newText将与最终设置为控件上的内容完全相同，然而，假设为了计算新的插入位置和新的锚定位置（因为在控件剥离了控件可能剥离的任何附加字符之后，根据需要提供的值将被修改）是正确的。
        结果
        根据为此Change对象设置的开始，结束和文本属性的状态，控件在此调用时提出新文本。

      • isAdded

        public final boolean isAdded​()
        获取此更改是否响应添加的文本。 请注意，在更改对象由格式化程序（由其中一个setter）修改后，此方法的返回值不会更改。 它是否回答这个更改是否被添加文本的结果而被触发，而不是文本最终被添加到最后。
        结果
        如果正在添加文本，则为true

      • isDeleted

        public final boolean isDeleted​()
        获取此更改是否正在删除文本。 请注意，在更改对象由格式化程序（由其中一个setter）修改后，此方法的返回值不会更改。 它是否解释这个更改是否被删除文本的结果，而不是文本最终会被删除。
        结果
        如果正在删除文本，则为true

      • isReplaced

        public final boolean isReplaced​()
        获取此更改是否正在替换文本。 请注意，在更改对象由格式化程序（由其中一个setter）修改后，此方法的返回值不会更改。 它是否由于文本被替换而被触发了这个更改，而不是最终文本是否被替换。
        结果
        如果正在替换文本，则为true

      • isContentChange

        public final boolean isContentChange​()
        内容更改是任何添加，删除或替换更改。 基本上它是c.isAdded() || c.isDeleted()的捷径
        结果
        如果内容改变，则为true

      • toString

        public String toString​()
        描述从类别复制Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • clone

        public TextFormatter.Change clone​()
        描述从类别复制Object
        创建并返回此对象的副本。 “复制”的精确含义可能取决于对象的类。 一般的意图是，对于任何对象x ，表达式：
         x.clone() != x
        将是真实的，而且表达：
         x.clone().getClass() == x.getClass()
        将是true ，但这些都不是绝对的要求。 通常情况是：
         x.clone().equals(x)
        将是true ，这不是绝对要求。

        按照惯例，返回的对象应该通过调用super.clone获得。 如果一个类及其所有的超类（ Object除外）遵守这个约定，那就是x.clone().getClass() == x.getClass()的情况。

        按照惯例，此方法返回的对象应该与此对象（正被克隆）无关。 为了实现这种独立性，可能需要修改super.clone返回的对象的一个或多个字段。 通常，这意味着复制构成被克隆的对象的内部“深层结构”的任何可变对象，并通过引用该副本替换对这些对象的引用。 如果一个类仅包含原始字段或对不可变对象的引用，则通常情况下， super.clone返回的对象中的字段通常不需要修改。

        类Object的方法clone执行特定的克隆操作。 首先，如果此对象的类不实现接口Cloneable ，则抛出CloneNotSupportedException 。 请注意，所有阵列被认为是实现该接口Cloneable并且所述的返回类型clone数组类型的方法T[]是T[]其中T是任何引用或原始类型。 否则，该方法将创建该对象的类的新实例，并将其所有字段初始化为该对象的相应字段的内容，就像通过赋值一样。 这些字段的内容本身不被克隆。 因此，该方法执行该对象的“浅拷贝”，而不是“深度拷贝”操作。

        类Object本身并不实现接口Cloneable ，因此在类为Object的对象上调用clone方法将导致在运行时抛出异常。

        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextInputControl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TextInputControl

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.TextInputControl
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    TextArea ， TextField

    @DefaultProperty("text")
public abstract class TextInputControl
extends Control
    文本输入控件的抽象基类。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyIntegerProperty anchor
      anchor的文字选择。
      ReadOnlyIntegerProperty caretPosition
      文本中插入符号的当前位置。
      BooleanProperty editable
      指示该TextInputControl是否可以由用户编辑。
      ObjectProperty<Font> font
      TextInputControl中用于文本的默认字体。
      ReadOnlyIntegerProperty length
      文本输入中的字符数。
      StringProperty promptText
      提示文字显示在 TextInputControl 。
      ReadOnlyBooleanProperty redoable
      该属性描述如果现在可以重做已撤销的内容的最新更改。
      ReadOnlyStringProperty selectedText
      定义所选文本输入控件中的字符
      ReadOnlyObjectProperty<IndexRange> selection
      当前选择。
      ObjectProperty<TextFormatter<?>> textFormatter
      该物业包含目前附件TextFormatter 。
      StringProperty text
      TextInputControl的文本内容。
      ReadOnlyBooleanProperty undoable
      该属性描述如果目前可以撤消已完成的内容的最新更改。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected static interface  TextInputControl.Content
      界面表示文本输入的内容。

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected TextInputControl​(TextInputControl.Content content)
      创建一个新的TextInputControl。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ReadOnlyIntegerProperty anchorProperty​()
      anchor的文字选择。
      void appendText​(String text)
      向内容追加一串字符。
      void backward​()
      向后移动插入符号位置。
      void cancelEdit​()
      如果该字段当前正在被编辑，该调用将把文本设置为最后一个被提交的值。
      ReadOnlyIntegerProperty caretPositionProperty​()
      文本中插入符号的当前位置。
      void clear​()
      清除文本。
      void commitValue​()
      提交当前文本并将其转换为值。
      void copy​()
      将文本中当前选定的范围传输到剪贴板，留下当前的选择。
      void cut​()
      将文本中当前选定的范围传输到剪贴板，删除当前选择。
      boolean deleteNextChar​()
      如果没有选择，则从文本中删除当前插入符号位置后的字符，如果有选择则删除选择。
      boolean deletePreviousChar​()
      如果没有选择，则从文本中删除当前插入符号位置之前的字符，如果有选择则删除选择。
      void deleteText​(int start, int end)
      从内容中删除一系列字符。
      void deleteText​(IndexRange range)
      从内容中删除一系列字符。
      void deselect​()
      清除选择。
      BooleanProperty editableProperty​()
      指示该TextInputControl是否可以由用户编辑。
      void end​()
      将插入符移动到文本的最后一个字符之后。
      void endOfNextWord​()
      将插入符移动到下一个单词的末尾。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      void extendSelection​(int pos)
      此功能将扩展选择以包括指定的位置。
      ObjectProperty<Font> fontProperty​()
      TextInputControl中用于文本的默认字体。
      void forward​()
      向前移动插入位置。
      int getAnchor​()
      获取属性锚点的值。
      int getCaretPosition​()
      获取属性caretPosition的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      protected TextInputControl.Content getContent​()
      返回文本输入的内容模型。
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      Font getFont​()
      获取属性字体的值。
      int getLength​()
      获取属性长度的值。
      String getPromptText​()
      获取属性promptText的值。
      String getSelectedText​()
      获取属性selectedText的值。
      IndexRange getSelection​()
      获取属性选择的值。
      String getText​()
      获取属性文本的值。
      String getText​(int start, int end)
      返回文本输入内容的一个子集。
      TextFormatter<?> getTextFormatter​()
      获取属性textFormatter的值。
      void home​()
      将插入符移动到文本的第一个字符之前。
      void insertText​(int index, String text)
      在内容中插入一串字符。
      boolean isEditable​()
      获取可编辑属性的值。
      boolean isRedoable​()
      获取属性值可重新生成。
      boolean isUndoable​()
      200新200新新新200新200新200新200新新新200新200新新新200新新新200新新200新新200新新新新旗新新200新新200新新200新
      ReadOnlyIntegerProperty lengthProperty​()
      文本输入中的字符数。
      void nextWord​()
      将插入符号移到下一个字的开头。
      void paste​()
      将剪贴板中的内容传输到此文本中，替换当前选择。
      void positionCaret​(int pos)
      将插入符号置于 pos所示的位置。
      void previousWord​()
      将插入符号移动到上一个单词的开头。
      StringProperty promptTextProperty​()
      提示文字显示在 TextInputControl 。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void redo​()
      如果可能，重做最后一次修改。
      ReadOnlyBooleanProperty redoableProperty​()
      该属性描述如果现在可以重做已撤销的内容的最新更改。
      void replaceSelection​(String replacement)
      用给定的替换字符串替换选择。
      void replaceText​(int start, int end, String text)
      用给定的文本替换一系列的字符。
      void replaceText​(IndexRange range, String text)
      用给定的文本替换一系列的字符。
      void selectAll​()
      选择文本输入中的所有文本。
      void selectBackward​()
      在文本中向后移动选择一个字符。
      ReadOnlyStringProperty selectedTextProperty​()
      定义所选文本输入控件中的字符
      void selectEnd​()
      将插入符移动到文本的最后一个字符之后。
      void selectEndOfNextWord​()
      将插入符移动到下一个单词的末尾。
      void selectForward​()
      将选项向前移动文本中的一个字符。
      void selectHome​()
      将插入符移动到文本的第一个字符之前。
      ReadOnlyObjectProperty<IndexRange> selectionProperty​()
      当前选择。
      void selectNextWord​()
      将插入符号移到下一个字的开头。
      void selectPositionCaret​(int pos)
      将插入符号插入 pos所示的位置，并扩展选择（如果有）。
      void selectPreviousWord​()
      将插入符号移动到上一个单词的开头。
      void selectRange​(int anchor, int caretPosition)
      定位锚和caretPosition明确。
      void setEditable​(boolean value)
      设置属性可编辑的值。
      void setFont​(Font value)
      设置属性字体的值。
      void setPromptText​(String value)
      设置属性promptText的值。
      void setText​(String value)
      设置属性文本的值。
      void setTextFormatter​(TextFormatter<?> value)
      设置属性textFormatter的值。
      ObjectProperty<TextFormatter<?>> textFormatterProperty​()
      该物业包含目前附件TextFormatter 。
      StringProperty textProperty​()
      TextInputControl的文本内容。
      void undo​()
      如果可能，撤销最后修改。
      ReadOnlyBooleanProperty undoableProperty​()
      该属性描述如果目前可以撤消已完成的内容的最新更改。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, createDefaultSkin, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • font

        public final ObjectProperty<Font> fontProperty
        TextInputControl中用于文本的默认字体。 如果TextInputControl的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用此字体，但是在任何需要默认字体的情况下，将使用该字体。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFont() ， setFont(Font)

      • promptText

        public final StringProperty promptTextProperty
        提示文字显示在TextInputControl 。 如果设置为空或空字符串，则不显示提示文本。
        Default value:
        一个空字符串
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getPromptText() ， setPromptText(String)

      • textFormatter

        public final ObjectProperty<TextFormatter<?>> textFormatterProperty
        该物业包含目前附件TextFormatter 。 由于该值是Formatter一部分，更改TextFormatter将基于新的textFormatter更新文本。
        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getTextFormatter() ， setTextFormatter(TextFormatter)

      • text

        public final StringProperty textProperty
        TextInputControl的文本内容。
        另请参见：
        getText() ， setText(String)

      • length

        public final ReadOnlyIntegerProperty lengthProperty
        文本输入中的字符数。
        另请参见：
        getLength()

      • editable

        public final BooleanProperty editableProperty
        指示该TextInputControl是否可以由用户编辑。
        另请参见：
        isEditable() ， setEditable(boolean)

      • selection

        public final ReadOnlyObjectProperty<IndexRange> selectionProperty
        当前选择。
        另请参见：
        getSelection()

      • selectedText

        public final ReadOnlyStringProperty selectedTextProperty
        定义所选文本输入控件中的字符
        另请参见：
        getSelectedText()

      • anchor

        public final ReadOnlyIntegerProperty anchorProperty
        anchor的文字选择。 anchor和caretPosition构成了选择范围。 选择必须始终以开始<=结束的方式指定，但anchor可能小于，等于或大于caretPosition 。 根据用户如何选择文本，锚点可能表示选择的下限或上限。
        另请参见：
        getAnchor()

      • caretPosition

        public final ReadOnlyIntegerProperty caretPositionProperty
        文本中插入符号的当前位置。 anchor和caretPosition组成选择范围。 必须始终以begin <= end来指定选择，但是anchor可能小于，等于或大于caretPosition 。 取决于用户如何选择文本，插入位置可能表示选择的下限或上限。
        另请参见：
        getCaretPosition()

      • undoable

        public final ReadOnlyBooleanProperty undoableProperty
        该属性描述如果目前可以撤消已完成的内容的最新更改。
        Default value:
        假
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        isUndoable()

      • redoable

        public final ReadOnlyBooleanProperty redoableProperty
        该属性描述如果现在可以重做已撤销的内容的最新更改。
        Default value:
        假
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        isRedoable()

    • 构造方法详细信息

      • TextInputControl

        protected TextInputControl​(TextInputControl.Content content)
        创建一个新的TextInputControl。 内容是不可变的财产，在建造时必须指定（非空）。
        参数
        content - 内容的非空执行。

    • 方法详细信息

      • fontProperty

        public final ObjectProperty<Font> fontProperty​()
        TextInputControl中用于文本的默认字体。 如果TextInputControl的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用此字体，但是在任何需要默认字体的情况下，将使用该字体。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFont() ， setFont(Font)

      • setFont

        public final void setFont​(Font value)
        设置属性字体的值。
        Property description:
        TextInputControl中用于文本的默认字体。 如果TextInputControl的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用此字体，但是在任何需要默认字体的情况下，将使用该字体。
        从以下版本开始：
        JavaFX 8.0

      • getFont

        public final Font getFont​()
        获取属性字体的值。
        Property description:
        TextInputControl中用于文本的默认字体。 如果TextInputControl的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用此字体，但是在任何需要默认字体的情况下，将使用该字体。
        从以下版本开始：
        JavaFX 8.0

      • promptTextProperty

        public final StringProperty promptTextProperty​()
        提示文字显示在TextInputControl 。 如果设置为空或空字符串，则不显示提示文本。
        Default value:
        一个空字符串
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getPromptText() ， setPromptText(String)

      • getPromptText

        public final String getPromptText​()
        获取属性promptText的值。
        Property description:
        提示文字显示在TextInputControl 。 如果设置为空或空字符串，则不显示提示文本。
        Default value:
        一个空字符串
        从以下版本开始：
        JavaFX 2.2

      • setPromptText

        public final void setPromptText​(String value)
        设置属性promptText的值。
        Property description:
        提示文字显示在TextInputControl 。 如果设置为空或空字符串，则不显示提示文本。
        Default value:
        一个空字符串
        从以下版本开始：
        JavaFX 2.2

      • textFormatterProperty

        public final ObjectProperty<TextFormatter<?>> textFormatterProperty​()
        该物业包含目前附件TextFormatter 。 由于该值是Formatter一部分，因此更改TextFormatter将根据新的textFormatter更新文本。
        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getTextFormatter() ， setTextFormatter(TextFormatter)

      • getTextFormatter

        public final TextFormatter<?> getTextFormatter​()
        获取属性textFormatter的值。
        Property description:
        该物业包含目前附件TextFormatter 。 由于该值是Formatter一部分，因此更改TextFormatter将基于新的textFormatter更新文本。
        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40

      • setTextFormatter

        public final void setTextFormatter​(TextFormatter<?> value)
        设置属性textFormatter的值。
        Property description:
        该物业包含目前附件TextFormatter 。 由于该值是Formatter一部分，因此更改TextFormatter将基于新的textFormatter更新文本。
        Default value:
        空值
        从以下版本开始：
        JavaFX 8u40

      • getContent

        protected final TextInputControl.Content getContent​()
        返回文本输入的内容模型。
        结果
        文本输入的内容模型

      • getText

        public final String getText​()
        获取属性文本的值。
        Property description:
        TextInputControl的文本内容。

      • setText

        public final void setText​(String value)
        设置属性文本的值。
        Property description:
        TextInputControl的文本内容。

      • textProperty

        public final StringProperty textProperty​()
        TextInputControl的文本内容。
        另请参见：
        getText() ， setText(String)

      • getLength

        public final int getLength​()
        获取属性长度的值。
        Property description:
        文本输入中的字符数。

      • lengthProperty

        public final ReadOnlyIntegerProperty lengthProperty​()
        文本输入中的字符数。
        另请参见：
        getLength()

      • isEditable

        public final boolean isEditable​()
        获取可编辑属性的值。
        Property description:
        指示该TextInputControl是否可以由用户编辑。

      • setEditable

        public final void setEditable​(boolean value)
        设置属性可编辑的值。
        Property description:
        指示该TextInputControl是否可以由用户编辑。

      • editableProperty

        public final BooleanProperty editableProperty​()
        指示该TextInputControl是否可以由用户编辑。
        另请参见：
        isEditable() ， setEditable(boolean)

      • getSelection

        public final IndexRange getSelection​()
        获取属性选择的值。
        Property description:
        当前选择。

      • selectionProperty

        public final ReadOnlyObjectProperty<IndexRange> selectionProperty​()
        当前选择。
        另请参见：
        getSelection()

      • getSelectedText

        public final String getSelectedText​()
        获取属性selectedText的值。
        Property description:
        定义所选文本输入控件中的字符

      • selectedTextProperty

        public final ReadOnlyStringProperty selectedTextProperty​()
        定义所选文本输入控件中的字符
        另请参见：
        getSelectedText()

      • getAnchor

        public final int getAnchor​()
        获取属性锚点的值。
        Property description:
        anchor的文字选择。 anchor和caretPosition组成选择范围。 选择必须始终以begin <= end来指定，但anchor可能小于，等于或大于caretPosition 。 根据用户如何选择文本，锚点可能表示选择的下限或上限。

      • anchorProperty

        public final ReadOnlyIntegerProperty anchorProperty​()
        anchor的文字选择。 anchor和caretPosition组成选择范围。 选择始终必须以开始<= end来指定，但是anchor可能小于，等于或大于caretPosition 。 根据用户如何选择文本，锚点可能表示选择的下限或上限。
        另请参见：
        getAnchor()

      • getCaretPosition

        public final int getCaretPosition​()
        获取属性caretPosition的值。
        Property description:
        文本中插入符号的当前位置。 anchor和caretPosition组成选择范围。 选择必须始终以begin <= end来指定，但anchor可能小于，等于或大于caretPosition 。 取决于用户如何选择文本，插入位置可能表示选择的下限或上限。

      • caretPositionProperty

        public final ReadOnlyIntegerProperty caretPositionProperty​()
        文本中插入符号的当前位置。 anchor和caretPosition组成了选择范围。 必须始终以开始<= end来指定选择，但是anchor可能小于，等于或大于caretPosition 。 取决于用户如何选择文本，插入位置可能表示选择的下限或上限。
        另请参见：
        getCaretPosition()

      • isUndoable

        public final boolean isUndoable​()
        200新200新新新200新200新200新200新新新200新200新新新200新新新200新新200新新200新新新新旗新新200新新200新新200新
        Property description:
        该属性描述如果目前可以撤消已完成的内容的最新更改。
        Default value:
        假
        从以下版本开始：
        JavaFX 8u40

      • undoableProperty

        public final ReadOnlyBooleanProperty undoableProperty​()
        该属性描述如果目前可以撤消已完成的内容的最新更改。
        Default value:
        假
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        isUndoable()

      • isRedoable

        public final boolean isRedoable​()
        获取属性值可重新生成。
        Property description:
        该属性描述如果现在可以重做已撤销的内容的最新更改。
        Default value:
        假
        从以下版本开始：
        JavaFX 8u40

      • redoableProperty

        public final ReadOnlyBooleanProperty redoableProperty​()
        该属性描述如果现在可以重做已撤销的内容的最新更改。
        Default value:
        假
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        isRedoable()

      • getText

        public String getText​(int start,
                      int end)
        返回文本输入内容的一个子集。
        参数
        start - 必须是0到结束-1之间的值。
        end - 必须小于或等于长度
        结果
        文本输入内容的子集

      • appendText

        public void appendText​(String text)
        向内容追加一串字符。
        参数
        text - 一个非空字符串

      • insertText

        public void insertText​(int index,
                       String text)
        在内容中插入一串字符。
        参数
        index - 插入文本的位置。
        text - 要插入的文本。

      • deleteText

        public void deleteText​(IndexRange range)
        从内容中删除一系列字符。
        参数
        range - 要删除的文本范围。 范围对象不能为空。
        另请参见：
        deleteText(int, int)

      • deleteText

        public void deleteText​(int start,
                       int end)
        从内容中删除一系列字符。
        参数
        start - 范围内的起始索引（含）。 这必须是> = 0和<结束。
        end - 范围内的结束索引，独占。 这是一个删除的最后一个字符（与String操作方法一致）。 这必须>开始，而<=文本的长度。

      • replaceText

        public void replaceText​(IndexRange range,
                        String text)
        用给定的文本替换一系列的字符。
        参数
        range - 要替换的文本范围。 范围对象不能为空。
        text - 要替换范围的文本。 这不能为空。
        另请参见：
        replaceText(int, int, String)

      • replaceText

        public void replaceText​(int start,
                        int end,
                        String text)
        用给定的文本替换一系列的字符。
        参数
        start - 范围内的起始指数（含）。 这必须是> = 0和<结束。
        end - 范围内的结束索引，独占。 这是一个删除的最后一个字符（与String操作方法一致）。 这必须>开始，而<=文本的长度。
        text - 要替换范围的文本。 这不能为空。

      • cut

        public void cut​()
        将文本中当前选定的范围传输到剪贴板，删除当前选择。

      • copy

        public void copy​()
        将文本中当前选定的范围传输到剪贴板，留下当前的选择。

      • paste

        public void paste​()
        将剪贴板中的内容传输到此文本中，替换当前选择。 如果没有选择，则剪贴板中的内容将插入当前插入符号位置。

      • selectBackward

        public void selectBackward​()
        在文本中向后移动选择一个字符。 这可能取决于锚点相对于插入位置的位置而取消选择的效果。 这个功能有效地移动了插入位置。

      • selectForward

        public void selectForward​()
        将选项向前移动文本中的一个字符。 这可能取决于锚点相对于插入位置的位置而取消选择的效果。 这个功能有效地将插入符号向前移动。

      • previousWord

        public void previousWord​()
        将插入符号移动到上一个单词的开头。 此功能也具有清除选择的效果。

      • nextWord

        public void nextWord​()
        将插入符号移到下一个字的开头。 此功能也具有清除选择的效果。

      • endOfNextWord

        public void endOfNextWord​()
        将插入符移动到下一个单词的末尾。 此功能也具有清除选择的效果。

      • selectPreviousWord

        public void selectPreviousWord​()
        将插入符号移动到上一个单词的开头。 这不会导致选择被清除。 相反，锚保持放置，插入位置移动到上一个单词的开头。

      • selectNextWord

        public void selectNextWord​()
        将插入符号移到下一个字的开头。 这不会导致选择被清除。 相反，锚保持放置，插入位置移动到下一个单词的开头。

      • selectEndOfNextWord

        public void selectEndOfNextWord​()
        将插入符移动到下一个单词的末尾。 这不会导致选择被清除。

      • selectAll

        public void selectAll​()
        选择文本输入中的所有文本。

      • home

        public void home​()
        将插入符移动到文本的第一个字符之前。 此功能也具有清除选择的效果。

      • end

        public void end​()
        将插入符移动到文本的最后一个字符之后。 此功能也具有清除选择的效果。

      • selectHome

        public void selectHome​()
        将插入符移动到文本的第一个字符之前。 这不会导致选择被清除。 相反，锚保持放置，插入位置移动到第一个字符之前。

      • selectEnd

        public void selectEnd​()
        将插入符移动到文本的最后一个字符之后。 这不会导致选择被清除。 相反，锚点保持放置，插入位置移动到最后一个字符之后。

      • deletePreviousChar

        public boolean deletePreviousChar​()
        如果没有选择，则从文本中删除当前插入符号位置之前的字符，如果有选择则删除选择。 如果删除成功，此函数返回true，否则返回false。
        结果
        如果删除成功则为true，否则为false

      • deleteNextChar

        public boolean deleteNextChar​()
        如果没有选择，则从文本中删除当前插入符号位置后的字符，如果有选择则删除选择。 如果删除成功，此函数返回true，否则返回false。
        结果
        如果删除成功则为true，否则为false

      • forward

        public void forward​()
        向前移动插入位置。 如果没有选择，则插入符号位置向前移动一个字符。 如果有选择，则插入符号位置被移动到选择结束，并且清除选择。

      • backward

        public void backward​()
        向后移动插入符号位置。 如果没有选择，则插入符号位置向后移动一个字符。 如果有选择，则插入符号位置将移动到选择的开头，并将选择清除。 注意：此功能主要由专家使用，主要由实施新皮肤或行为的人员使用。 开发人员或设计师直接访问此功能并不常见。

      • positionCaret

        public void positionCaret​(int pos)
        将插入符号置于pos所示的位置。 此功能也将清除选择。
        参数
        pos - 位置

      • selectPositionCaret

        public void selectPositionCaret​(int pos)
        将插入符号放置在pos所示的位置，并扩展选择（如果有）。 如果没有选择，则形成锚点处于当前插入位置并将插入位置移动到位置的选择。
        参数
        pos - 的位置

      • selectRange

        public void selectRange​(int anchor,
                        int caretPosition)
        定位锚和caretPosition明确。
        参数
        anchor - 锚
        caretPosition - caretPosition

      • extendSelection

        public void extendSelection​(int pos)
        此功能将扩展选择以包括指定的位置。 这不同于selectPositionCaret，因为它不会简单地移动插入符号。 相反，它将根据需要重新定位插入符号和锚点，以确保pos成为新的插入符号，并且选择的另一端成为锚点。
        参数
        pos - 位置

      • clear

        public void clear​()
        清除文本。

      • deselect

        public void deselect​()
        清除选择。

      • replaceSelection

        public void replaceSelection​(String replacement)
        用给定的替换字符串替换选择。 如果没有选择，则替换文本将简单地插入到当前插入位置。 如果有选择，则清除选择并插入给定的替换文本。
        参数
        replacement - 替换字符串

      • undo

        public final void undo​()
        如果可能，撤销最后修改。 如果isUndoable()返回false，则调用此方法没有任何作用。
        从以下版本开始：
        JavaFX 8u40

      • redo

        public final void redo​()
        如果可能，重做最后一次修改。 如果isRedoable()返回false，则调用此方法没有任何作用。
        从以下版本开始：
        JavaFX 8u40

      • commitValue

        public final void commitValue​()
        提交当前文本并将其转换为值。
        从以下版本开始：
        JavaFX 8u40

      • cancelEdit

        public final void cancelEdit​()
        如果该字段当前正在被编辑，该调用将把文本设置为最后一个被提交的值。
        从以下版本开始：
        JavaFX 8u40

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 要执行的操作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextInputControl.Content (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Interface TextInputControl.Content

  • All Superinterfaces:
    Observable ， ObservableObjectValue<String> ， ObservableStringValue ， ObservableValue<String>
    Enclosing class:
    TextInputControl

    protected static interface TextInputControl.Content
extends ObservableStringValue
    界面表示文本输入的内容。 由于它是一个ObservableStringValue，您还可以绑定到或观察内容。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void delete​(int start, int end, boolean notifyListeners)
      从内容中删除一串字符。
      String get​(int start, int end)
      检索内容的一个子集。
      void insert​(int index, String text, boolean notifyListeners)
      在内容中插入一串字符。
      int length​()
      返回由内容表示的字符数。

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.beans.value.ObservableObjectValue

        get

      • Methods inherited from interface javafx.beans.value.ObservableValue

        addListener, getValue, removeListener

    • 方法详细信息

      • get

        String get​(int start,
           int end)
        检索内容的一个子集。
        参数
        start - 开始
        end - 结束
        结果
        内容的一个子集

      • insert

        void insert​(int index,
            String text,
            boolean notifyListeners)
        在内容中插入一串字符。
        参数
        index - 索引
        text - 文本字符串
        notifyListeners - 通知侦听器标志
        从以下版本开始：
        JavaFX 2.1

      • delete

        void delete​(int start,
            int end,
            boolean notifyListeners)
        从内容中删除一串字符。
        参数
        start - 开始
        end - 结束
        notifyListeners - 通知侦听器标志
        从以下版本开始：
        JavaFX 2.1

      • length

        int length​()
        返回由内容表示的字符数。
        结果
        字符数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextInputDialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TextInputDialog

  • java.lang.Object
    • javafx.scene.control.Dialog<String>
      • javafx.scene.control.TextInputDialog
  • All Implemented Interfaces:
    EventTarget

    public class TextInputDialog
extends Dialog<String>
    显示给用户的文本输入控件的对话框。
    从以下版本开始：
    JavaFX 8u40
    另请参见：
    Dialog

    • Property Summary

      • Properties inherited from class javafx.scene.control.Dialog

        contentText, dialogPane, graphic, headerText, height, onCloseRequest, onHidden, onHiding, onShowing, onShown, resizable, resultConverter, result, showing, title, width, x, y

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextInputDialog​()
      创建一个新的TextInputDialog，而不会在对话框TextField中输入默认值。
      TextInputDialog​(String defaultValue)
      创建一个新的TextInput对话框，其默认值输入到对话框TextField 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getDefaultValue​()
      返回在构造函数中指定的默认值。
      TextField getEditor​()
      返回此对话框中使用的TextField 。

      • Methods inherited from class javafx.scene.control.Dialog

        buildEventDispatchChain, close, contentTextProperty, dialogPaneProperty, getContentText, getDialogPane, getGraphic, getHeaderText, getHeight, getModality, getOnCloseRequest, getOnHidden, getOnHiding, getOnShowing, getOnShown, getOwner, getResult, getResultConverter, getTitle, getWidth, getX, getY, graphicProperty, headerTextProperty, heightProperty, hide, initModality, initOwner, initStyle, isResizable, isShowing, onCloseRequestProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, resizableProperty, resultConverterProperty, resultProperty, setContentText, setDialogPane, setGraphic, setHeaderText, setHeight, setOnCloseRequest, setOnHidden, setOnHiding, setOnShowing, setOnShown, setResizable, setResult, setResultConverter, setTitle, setWidth, setX, setY, show, showAndWait, showingProperty, titleProperty, widthProperty, xProperty, yProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TextInputDialog

        public TextInputDialog​()
        创建一个新的TextInputDialog，而不会在对话框TextField中输入默认值。

      • TextInputDialog

        public TextInputDialog​(String defaultValue)
        创建一个新的TextInputDialog，其默认值输入到对话框TextField中 。
        参数
        defaultValue - 输入到对话框的默认值

    • 方法详细信息

      • getEditor

        public final TextField getEditor​()
        返回此对话框中使用的TextField 。
        结果
        在此对话框中使用TextField

      • getDefaultValue

        public final String getDefaultValue​()
        返回在构造函数中指定的默认值。
        结果
        在构造函数中指定的默认值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TitledPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TitledPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.TitledPane
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("content")
public class TitledPane
extends Labeled

    TitledPane是一个可以打开和关闭的标题的面板。

    TitledPane中的面板可以是任何Node，例如UI控件或添加到布局容器的节点组。

    不建议为此控件设置MinHeight，PrefHeight或MaxHeight。 TitledPane的高度在打开或关闭时会改变，将会发生意外的行为。

    注意，当TitledPane从Labeled扩展时，继承的属性用于操纵TitledPane头，而不是内容区本身。 如果意图修改内容区域，请考虑使用布局容器，如StackPane，并将其中的实际内容设置为其中。 然后，您可以操作StackPane来获取您之后的布局结果。

    例：

       TitledPane t1 = new TitledPane("T1", new Button("B1"));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty animated
      TitledPane的动画状态。
      BooleanProperty collapsible
      TitledPane的可折叠状态。
      ObjectProperty<Node> content
      TitledPane的内容。
      BooleanProperty expanded
      TitledPane的扩展状态。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TitledPane​()
      创建一个没有标题或内容的新TitledPane。
      TitledPane​(String title, Node content)
      创建一个标题和内容的新TitledPane。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      BooleanProperty animatedProperty​()
      TitledPane的动画状态。
      BooleanProperty collapsibleProperty​()
      TitledPane的可折叠状态。
      ObjectProperty<Node> contentProperty​()
      TitledPane的内容。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      BooleanProperty expandedProperty​()
      TitledPane的扩展状态。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Node getContent​()
      TitledPane的内容。
      Orientation getContentBias​()
      如果wrapText为true，则contentBias将为HORIZONTAL，否则为null。
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      boolean isAnimated​()
      返回TitledPane的动画状态。
      boolean isCollapsible​()
      返回TitlePane的可折叠状态。
      boolean isExpanded​()
      获取扩展的属性的值。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setAnimated​(boolean value)
      指定TitledPane应如何打开和关闭。
      void setCollapsible​(boolean value)
      指定TitledPane是否可以折叠。
      void setContent​(Node value)
      TitlePane的内容可以是任何节点，如UI控件或添加到布局容器的节点组。
      void setExpanded​(boolean value)
      设置TitledPane的展开状态。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getContentDisplay, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • content

        public final ObjectProperty<Node> contentProperty
        TitledPane的内容。
        结果
        TitlePane的内容。

      • expanded

        public final BooleanProperty expandedProperty
        TitledPane的扩展状态。
        另请参见：
        isExpanded() ， setExpanded(boolean)

      • animated

        public final BooleanProperty animatedProperty
        TitledPane的动画状态。
        另请参见：
        isAnimated() ， setAnimated(boolean)

      • collapsible

        public final BooleanProperty collapsibleProperty
        TitledPane的可折叠状态。
        另请参见：
        isCollapsible() ， setCollapsible(boolean)

    • 构造方法详细信息

      • TitledPane

        public TitledPane​()
        创建一个没有标题或内容的新TitledPane。

      • TitledPane

        public TitledPane​(String title,
                  Node content)
        创建一个标题和内容的新TitledPane。
        参数
        title - title的标题。
        content - content的内容。

    • 方法详细信息

      • setContent

        public final void setContent​(Node value)

        TitlePane的内容可以是任何节点，如UI控件或添加到布局容器的节点组。

        参数
        value - 此TitlePane的内容。

      • getContent

        public final Node getContent​()
        TitledPane的内容。 如果没有内容，则返回Null 。
        结果
        此TitledPane的内容。

      • contentProperty

        public final ObjectProperty<Node> contentProperty​()
        TitledPane的内容。
        结果
        TitlePane的内容。

      • setExpanded

        public final void setExpanded​(boolean value)
        设置TitledPane的展开状态。 默认值为true 。
        参数
        value - 指示展开状态的标志

      • isExpanded

        public final boolean isExpanded​()
        获取扩展的属性的值。
        Property description:
        TitledPane的扩展状态。

      • expandedProperty

        public final BooleanProperty expandedProperty​()
        TitledPane的扩展状态。
        另请参见：
        isExpanded() ， setExpanded(boolean)

      • setAnimated

        public final void setAnimated​(boolean value)
        指定TitledPane应如何打开和关闭。 当该值设置为true时，面板将被动画true 。 默认值为true 。
        参数
        value - 表示动画状态的标志

      • isAnimated

        public final boolean isAnimated​()
        返回TitledPane的动画状态。
        结果
        TitledPane的动画状态。

      • animatedProperty

        public final BooleanProperty animatedProperty​()
        TitledPane的动画状态。
        另请参见：
        isAnimated() ， setAnimated(boolean)

      • setCollapsible

        public final void setCollapsible​(boolean value)
        指定TitledPane是否可以折叠。 默认值为true 。
        参数
        value - 表示可折叠状态的标志

      • isCollapsible

        public final boolean isCollapsible​()
        返回TitlePane的可折叠状态。
        结果
        TitledPane的可折叠状态。

      • collapsibleProperty

        public final BooleanProperty collapsibleProperty​()
        TitledPane的可折叠状态。
        另请参见：
        isCollapsible() ， setCollapsible(boolean)

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Labeled
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • getContentBias

        public Orientation getContentBias​()
        描述从类复制： Labeled
        如果wrapText为true，则contentBias将为HORIZONTAL，否则为null。
        重写：
        getContentBias在 Labeled
        结果
        width / height依赖的方向，如果没有则为null
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 要执行的操作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Toggle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Interface Toggle

  • 所有已知实现类：
    RadioButton ， RadioMenuItem ， ToggleButton

    public interface Toggle
    表示可以在选定状态和未选择状态之间切换的控件。 另外，一个Toggle可以被分配一个ToggleGroup ，它管理所有分配的切换，使得只能在ToggleGroup的一个Toggle在任何一个时间被选中。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty selected
      该选择状态为 Toggle 。
      ObjectProperty<ToggleGroup> toggleGroup
      该ToggleGroup到这个Toggle所属。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ObservableMap<Object,Object> getProperties​()
      返回此切换上属性的可观察地图，主要由应用程序开发人员使用。
      ToggleGroup getToggleGroup​()
      返回的ToggleGroup到这个Toggle所属。
      Object getUserData​()
      返回先前设置的Object属性，如果没有使用 Node.setUserData(java.lang.Object)方法设置此属性，则返回null。
      boolean isSelected​()
      指示是否选择此 Toggle 。
      BooleanProperty selectedProperty​()
      该选择状态为 Toggle 。
      void setSelected​(boolean selected)
      将此 Toggle设置为选定或未选择。
      void setToggleGroup​(ToggleGroup toggleGroup)
      设置ToggleGroup到这个Toggle所属。
      void setUserData​(Object value)
      用于设置可以在以后检索的单个Object属性的便利方法。
      ObjectProperty<ToggleGroup> toggleGroupProperty​()
      该ToggleGroup到这个Toggle所属。

    • Property Detail

      • toggleGroup

        ObjectProperty<ToggleGroup> toggleGroupProperty
        该ToggleGroup到这个Toggle所属。
        另请参见：
        getToggleGroup() ， setToggleGroup(ToggleGroup)

      • selected

        BooleanProperty selectedProperty
        该选择的状态为 Toggle 。
        另请参见：
        isSelected() ， setSelected(boolean)

    • 方法详细信息

      • getToggleGroup

        ToggleGroup getToggleGroup​()
        返回的ToggleGroup到这个Toggle所属。
        结果
        该ToggleGroup到这个Toggle所属。

      • setToggleGroup

        void setToggleGroup​(ToggleGroup toggleGroup)
        设置ToggleGroup到这个Toggle所属。
        参数
        toggleGroup - 新的ToggleGroup 。

      • toggleGroupProperty

        ObjectProperty<ToggleGroup> toggleGroupProperty​()
        该ToggleGroup到这个Toggle所属。
        另请参见：
        getToggleGroup() ， setToggleGroup(ToggleGroup)

      • isSelected

        boolean isSelected​()
        指示是否选择此 Toggle 。
        结果
        true如果这个 Toggle被选中。

      • setSelected

        void setSelected​(boolean selected)
        将此 Toggle设置为选定或未选择。
        参数
        selected - true使此 Toggle被选中。

      • selectedProperty

        BooleanProperty selectedProperty​()
        该选择的状态为 Toggle 。
        另请参见：
        isSelected() ， setSelected(boolean)

      • getUserData

        Object getUserData​()
        返回先前设置的Object属性，如果没有使用 Node.setUserData(java.lang.Object)方法设置此属性，则返回null。
        结果
        先前设置的对象，如果没有设置属性或设置为null，则为null。

      • setUserData

        void setUserData​(Object value)
        用于设置可以在以后检索的单个Object属性的便利方法。 这在功能上等同于调用getProperties（）。put（Object key，Object value）方法。 这可以稍后通过调用Node.getUserData()来检索。
        参数
        value - 要存储的值 - 以后可以通过调用 Node.getUserData()来检索。

      • getProperties

        ObservableMap<Object,Object> getProperties​()
        返回此切换上属性的可观察地图，主要由应用程序开发人员使用。
        结果
        该切换的属性的可观察地图主要由应用程序开发人员使用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToggleButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ToggleButton

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.ButtonBase
                • javafx.scene.control.ToggleButton
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable ， Toggle
    已知直接子类：
    RadioButton

    public class ToggleButton
extends ButtonBase
implements Toggle
    A ToggleButton是一种具有选择能力的专业控制。 通常， ToggleButton与Button类似。 但是，它们是两种不同类型的控件。 一个按钮是一个“命令”按钮，它在单击时调用一个功能。 另一方面，A ToggleButton仅仅是一个布尔值的控件，指示是否已被选择。

    ToggleButton也可以放在一起。 默认情况下， ToggleButton不在组中。 在组中，可以选择该组内一次只能有一个ToggleButton 。 要将两个ToggleButtons放在同一组中，只需为ToggleGroup分配相同的值即可 。

    不像RadioButtons ， ToggleButtons在ToggleGroup不要尝试强行至少一个选择ToggleButton在一组。 也就是说，如果选择了ToggleButton ，点击它将导致它被取消选择。 使用RadioButton ，点击组中的所选按钮将不起作用。

    例：

       ToggleButton tb1 = new ToggleButton("toggle button 1"); ToggleButton tb2 = new ToggleButton("toggle button 2"); ToggleButton tb3 = new ToggleButton("toggle button 3"); ToggleGroup group = new ToggleGroup(); tb1.setToggleGroup(group); tb2.setToggleGroup(group); tb3.setToggleGroup(group);

    默认情况下，ToggleButton启用助记符解析。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty selected
      指示是否选择此切换按钮。
      ObjectProperty<ToggleGroup> toggleGroup
      该ToggleGroup到这个ToggleButton所属。

      • Properties inherited from class javafx.scene.control.ButtonBase

        armed, onAction

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ToggleButton​()
      为其标签创建一个空字符串的切换按钮。
      ToggleButton​(String text)
      创建具有指定文本的切换按钮作为其标签。
      ToggleButton​(String text, Node graphic)
      创建一个切换按钮，其标签具有指定的文本和图标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void fire​()
      当用户手势指示应发生 ButtonBase的事件时调用。
      protected Pos getInitialAlignment​()
      返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。
      ToggleGroup getToggleGroup​()
      获取属性toggleGroup的值。
      boolean isSelected​()
      获取所选属性的值。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      BooleanProperty selectedProperty​()
      指示是否选择此切换按钮。
      void setSelected​(boolean value)
      设置所选属性的值。
      void setToggleGroup​(ToggleGroup value)
      设置属性toggleGroup的值。
      ObjectProperty<ToggleGroup> toggleGroupProperty​()
      该ToggleGroup到这个ToggleButton所属。

      • Methods inherited from class javafx.scene.control.ButtonBase

        arm, armedProperty, disarm, executeAccessibleAction, getOnAction, isArmed, onActionProperty, setOnAction

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from interface javafx.scene.control.Toggle

        getProperties, getUserData, setUserData

    • Property Detail

      • selected

        public final BooleanProperty selectedProperty
        指示是否选择此切换按钮。 这可以通过编程方式进行操作。
        Specified by:
        selectedProperty在接口 Toggle
        另请参见：
        isSelected() ， setSelected(boolean)

      • toggleGroup

        public final ObjectProperty<ToggleGroup> toggleGroupProperty
        该ToggleGroup到这个ToggleButton所属。 A ToggleButton只能在任何一个时间在一个组。 如果组更改，则在添加到新组之前，该按钮将从旧组中删除。
        Specified by:
        toggleGroupProperty在接口 Toggle
        另请参见：
        getToggleGroup() ， setToggleGroup(ToggleGroup)

    • 构造方法详细信息

      • ToggleButton

        public ToggleButton​()
        为其标签创建一个空字符串的切换按钮。

      • ToggleButton

        public ToggleButton​(String text)
        创建具有指定文本的切换按钮作为其标签。
        参数
        text - 其标签的文本字符串。

      • ToggleButton

        public ToggleButton​(String text,
                    Node graphic)
        创建一个切换按钮，其标签具有指定的文本和图标。
        参数
        text - 其标签的文本字符串。
        graphic - 其标签的图标。

    • 方法详细信息

      • setSelected

        public final void setSelected​(boolean value)
        设置所选属性的值。
        Specified by:
        setSelected在接口 Toggle
        Property description:
        指示是否选择此切换按钮。 这可以通过编程方式进行操作。
        参数
        value - true使这个 Toggle选择。

      • isSelected

        public final boolean isSelected​()
        获取所选属性的值。
        Specified by:
        isSelected在接口 Toggle
        Property description:
        指示是否选择此切换按钮。 这可以通过编程方式进行操作。
        结果
        true如果这个 Toggle被选中。

      • selectedProperty

        public final BooleanProperty selectedProperty​()
        指示是否选择此切换按钮。 这可以通过编程方式进行操作。
        Specified by:
        selectedProperty在接口 Toggle
        另请参见：
        isSelected() ， setSelected(boolean)

      • setToggleGroup

        public final void setToggleGroup​(ToggleGroup value)
        设置属性toggleGroup的值。
        Specified by:
        setToggleGroup在接口 Toggle
        Property description:
        该ToggleGroup到这个ToggleButton所属。 A ToggleButton只能在任何一个时间在一个组。 如果组更改，则在添加到新组之前，该按钮将从旧组中删除。
        参数
        value - 新的ToggleGroup 。

      • getToggleGroup

        public final ToggleGroup getToggleGroup​()
        获取属性toggleGroup的值。
        Specified by:
        getToggleGroup在接口 Toggle
        Property description:
        该ToggleGroup到这个ToggleButton所属。 A ToggleButton只能在任何一个时间在一个组。 如果组更改，则在添加到新组之前，该按钮将从旧组中删除。
        结果
        该ToggleGroup到这个Toggle所属。

      • toggleGroupProperty

        public final ObjectProperty<ToggleGroup> toggleGroupProperty​()
        该ToggleGroup到这个ToggleButton所属。 A ToggleButton只能在任何一个时间在一个组。 如果组更改，则在添加到新组之前，该按钮将从旧组中删除。
        Specified by:
        toggleGroupProperty在接口 Toggle
        另请参见：
        getToggleGroup() ， setToggleGroup(ToggleGroup)

      • fire

        public void fire​()
        当用户手势指示应发生ButtonBase的事件时调用。

        如果被调用，无论ButtonBase.arm()的状态如何，都将执行此方法。

        Specified by:
        fire在 ButtonBase

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getInitialAlignment

        protected Pos getInitialAlignment​()
        返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。 该方法最初被覆盖使用Pos.CENTER。
        重写：
        getInitialAlignment在 Labeled
        结果
        该控件的初始对齐状态
        从以下版本开始：
        9

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToggleGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ToggleGroup

  • java.lang.Object
    • javafx.scene.control.ToggleGroup

  • public class ToggleGroup
extends Object
    它包含所有的引用的类Toggles其selected变量应该被管理，使得仅仅单个Toggle的内ToggleGroup可以在任一周时间来选择。

    一般来说ToggleGroups只是通过指定的名称自动管理ToggleGroup上Toggle ，但在某些情况下，希望明确地管理其ToggleGroup使用由Toggles 。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<Toggle> selectedToggle
      所选的切换。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ToggleGroup​()
      创建一个默认的ToggleGroup实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableMap<Object,Object> getProperties​()
      返回此节点上属性的可观察图，主要由应用程序开发人员使用。
      Toggle getSelectedToggle​()
      获取所选的 Toggle 。
      ObservableList<Toggle> getToggles​()
      ToggleGroup中的切换列表。
      Object getUserData​()
      返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
      boolean hasProperties​()
      测试ToggleGroup是否具有属性。
      ReadOnlyObjectProperty<Toggle> selectedToggleProperty​()
      所选的切换。
      void selectToggle​(Toggle value)
      选择切换。
      void setUserData​(Object value)
      用于设置可以在以后检索的单个Object属性的便利方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • selectedToggle

        public final ReadOnlyObjectProperty<Toggle> selectedToggleProperty
        所选的切换。
        另请参见：
        getSelectedToggle()

    • 构造方法详细信息

      • ToggleGroup

        public ToggleGroup​()
        创建一个默认的ToggleGroup实例。

    • 方法详细信息

      • getToggles

        public final ObservableList<Toggle> getToggles​()
        ToggleGroup中的切换列表。
        结果
        ToggleGroup中的切换列表

      • selectToggle

        public final void selectToggle​(Toggle value)
        选择切换。
        参数
        value - 要选择的 Toggle 。

      • getSelectedToggle

        public final Toggle getSelectedToggle​()
        获取所选的 Toggle 。
        结果
        切换所选的切换。

      • selectedToggleProperty

        public final ReadOnlyObjectProperty<Toggle> selectedToggleProperty​()
        所选的切换。
        另请参见：
        getSelectedToggle()

      • getProperties

        public final ObservableMap<Object,Object> getProperties​()
        返回此节点上属性的可观察图，主要由应用程序开发人员使用。
        结果
        该节点上属性的可观察地图主要由应用程序开发人员使用
        从以下版本开始：
        JavaFX 8u40

      • hasProperties

        public boolean hasProperties​()
        测试ToggleGroup是否具有属性。
        结果
        如果节点有属性，则为true。
        从以下版本开始：
        JavaFX 8u40

      • setUserData

        public void setUserData​(Object value)
        用于设置可以在以后检索的单个Object属性的便利方法。 这在功能上等同于调用getProperties（）。put（Object key，Object value）方法。 这可以稍后通过调用getUserData()检索。
        参数
        value - 要存储的值 - 以后可以通过调用 getUserData()来检索。
        从以下版本开始：
        JavaFX 8u40

      • getUserData

        public Object getUserData​()
        返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
        结果
        先前设置的对象，如果没有设置属性或设置为null，则为null。
        从以下版本开始：
        JavaFX 8u40
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToolBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class ToolBar

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.ToolBar
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("items")
public class ToolBar
extends Control

    ToolBar是一个可以水平或垂直显示项目的控件。 ToolBar中最常见的项目是Buttons,ToggleButtons和Separators ，但不限 于此 ，可以在其中插入任何Node 。

    如果在ToolBar中有太多项目可以出现溢出按钮。 溢出按钮允许您选择工具栏中当前不可见的项目。

    ToolBar将focusTraversable设置为false。

    具有八个按钮的水平ToolBar示例，两个垂直分隔符分开。

       ToolBar toolBar = new ToolBar( new Button("New"), new Button("Open"), new Button("Save"), new Separator(true), new Button("Clean"), new Button("Compile"), new Button("Run"), new Separator(true), new Button("Debug"), new Button("Profile") );
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Orientation> orientation
      ToolBar的方向 - 这可以是水平还是垂直。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ToolBar​()
      创建一个空的工具栏。
      ToolBar​(Node... items)
      创建一个填充指定节点的工具栏。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      protected Boolean getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      ObservableList<Node> getItems​()
      物品包含在 ToolBar 。
      Orientation getOrientation​()
      获取属性方向的值。
      ObjectProperty<Orientation> orientationProperty​()
      ToolBar的方向 - 这可以是水平还是垂直。
      void setOrientation​(Orientation value)
      设置属性方向的值。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • orientation

        public final ObjectProperty<Orientation> orientationProperty
        ToolBar的方向 - 这可以是水平还是垂直。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

    • 构造方法详细信息

      • ToolBar

        public ToolBar​()
        创建一个空的工具栏。

      • ToolBar

        public ToolBar​(Node... items)
        创建一个填充指定节点的工具栏。 没有任何项可以为空。
        参数
        items - 要添加的项目

    • 方法详细信息

      • getItems

        public final ObservableList<Node> getItems​()
        项目包含在ToolBar 。 典型使用案例为ToolBar认为，最常见的物品放置在它是Buttons ， ToggleButtons ，并Separators ，但你是不是仅仅限于这些，并且可以插入任何Node 。 添加的项不能为空。
        结果
        项目清单

      • setOrientation

        public final void setOrientation​(Orientation value)
        设置属性方向的值。
        Property description:
        ToolBar的方向 - 这可以是水平还是垂直。

      • getOrientation

        public final Orientation getOrientation​()
        获取属性方向的值。
        Property description:
        ToolBar的方向 - 这可以是水平还是垂直。

      • orientationProperty

        public final ObjectProperty<Orientation> orientationProperty​()
        ToolBar的方向 - 这可以是水平还是垂直。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • getInitialFocusTraversable

        protected Boolean getInitialFocusTraversable​()
        返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。 该方法被覆盖，因为默认情况下UI控件将focus遍历设置为true，但这不适用于此控件。
        重写：
        getInitialFocusTraversable在 Control
        结果
        该控件的初始聚焦可移动状态
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Tooltip (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class Tooltip

  • java.lang.Object
    • javafx.stage.Window
      • javafx.stage.PopupWindow
        • javafx.scene.control.PopupControl
          • javafx.scene.control.Tooltip
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @IDProperty("id")
public class Tooltip
extends PopupControl
    工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。 任何节点都可以显示工具提示。 在大多数情况下，将创建一个工具提示，并修改其text属性以向用户显示纯文本。 但是，工具提示可以在其中显示节点的任意场景图 - 这可以通过创建场景图并将其设置在Tooltip graphic属性中来完成。

    您可以使用以下方法在任何节点上设置工具提示：

      Rectangle rect = new Rectangle(0, 0, 100, 100);
 Tooltip t = new Tooltip("A Square");
 Tooltip.install(rect, t);
    然后，该工具提示将参与典型的工具提示语义（即，在悬停等上显示）。 请注意，工具提示不必被卸载：当它不被任何节点引用时将被垃圾收集。 但是，可以手动卸载该工具提示。

    单个工具提示可以安装在多个目标节点或多个控件上。

    因为大多数工具提示都显示在UI控件上，因此所有控件都有特殊的API来使工具提示更加冗长。 下面的示例显示了如何为Button控件创建一个工具提示：

      import javafx.scene.control.Tooltip;
 import javafx.scene.control.Button;

 Button button = new Button("Hover Over Me");
 button.setTooltip(new Tooltip("Tooltip for Button"));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty activated
      通常，当鼠标移动到控件上时，工具提示被“激活”。
      ObjectProperty<ContentDisplay> contentDisplay
      指定图形相对于文本的位置。
      ObjectProperty<Font> font
      工具提示中用于文本的默认字体。
      ObjectProperty<Node> graphic
      工具提示的可选图标。
      DoubleProperty graphicTextGap
      图形和文字之间的空间量
      ObjectProperty<Duration> hideDelay
      在鼠标离开节点后继续显示工具提示的持续时间。
      ObjectProperty<Duration> showDelay
      进入悬停节点的鼠标与相关联的工具提示之间的延迟将显示给用户。
      ObjectProperty<Duration> showDuration
      工具提示应保持显示的持续时间，直到用户不再可见。
      ObjectProperty<TextAlignment> textAlignment
      指定 文本行多行时的行为。
      ObjectProperty<OverrunStyle> textOverrun
      指定 Tooltip的文本超过可用空间进行渲染时使用的行为。
      StringProperty text
      要在工具提示中显示的文字。
      BooleanProperty wrapText
      如果文本运行超过工具提示的宽度，则该变量指示文本是否应该包装到另一行。

      • Properties inherited from class javafx.scene.control.PopupControl

        id, maxHeight, maxWidth, minHeight, minWidth, prefHeight, prefWidth, skin, style

      • Properties inherited from class javafx.stage.PopupWindow

        anchorLocation, anchorX, anchorY, autoFix, autoHide, consumeAutoHidingEvents, hideOnEscape, onAutoHide, ownerNode, ownerWindow

      • Properties inherited from class javafx.stage.Window

        eventDispatcher, focused, forceIntegerRenderScale, height, onCloseRequest, onHidden, onHiding, onShowing, onShown, opacity, outputScaleX, outputScaleY, renderScaleX, renderScaleY, scene, showing, width, x, y

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.stage.PopupWindow

        PopupWindow.AnchorLocation

    • Field Summary

      • Fields inherited from class javafx.scene.control.PopupControl

        bridge, USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Tooltip​()
      为其文本创建一个带有空字符串的工具提示。
      Tooltip​(String text)
      用指定的文本创建一个工具提示。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ReadOnlyBooleanProperty activatedProperty​()
      通常，当鼠标移动到控件上时，工具提示被“激活”。
      ObjectProperty<ContentDisplay> contentDisplayProperty​()
      指定图形相对于文本的位置。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      ObjectProperty<Font> fontProperty​()
      工具提示中用于文本的默认字体。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      ContentDisplay getContentDisplay​()
      获取属性contentDisplay的值。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      这个样式的CssMetaData。
      Font getFont​()
      获取属性字体的值。
      Node getGraphic​()
      获取属性图形的值。
      double getGraphicTextGap​()
      获取属性graphicTextGap的值。
      Duration getHideDelay​()
      获取属性hideDelay的值。
      Duration getShowDelay​()
      获取属性showDelay的值。
      Duration getShowDuration​()
      获取属性showDuration的值。
      Styleable getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      String getText​()
      获取属性文本的值。
      TextAlignment getTextAlignment​()
      获取属性textAlignment的值。
      OverrunStyle getTextOverrun​()
      获取textOverrun属性的值。
      ObjectProperty<Node> graphicProperty​()
      工具提示的可选图标。
      DoubleProperty graphicTextGapProperty​()
      图形和文字之间的空间量
      ObjectProperty<Duration> hideDelayProperty​()
      在鼠标离开节点后继续显示工具提示的持续时间。
      static void install​(Node node, Tooltip t)
      将给定的Tooltip与给定的Node相关联 。
      boolean isActivated​()
      获取激活的属性的值。
      boolean isWrapText​()
      获取propertyTextText的值。
      void setContentDisplay​(ContentDisplay value)
      设置属性contentDisplay的值。
      void setFont​(Font value)
      设置属性字体的值。
      void setGraphic​(Node value)
      设置属性图形的值。
      void setGraphicTextGap​(double value)
      设置属性graphicTextGap的值。
      void setHideDelay​(Duration hideDelay)
      设置属性hideDelay的值。
      void setShowDelay​(Duration showDelay)
      设置属性showDelay的值。
      void setShowDuration​(Duration showDuration)
      设置属性showDuration的值。
      void setText​(String value)
      设置属性文本的值。
      void setTextAlignment​(TextAlignment value)
      设置textAlignment属性的值。
      void setTextOverrun​(OverrunStyle value)
      设置textOverrun属性的值。
      void setWrapText​(boolean value)
      设置属性wrapText的值。
      ObjectProperty<Duration> showDelayProperty​()
      进入悬停节点的鼠标与相关联的工具提示之间的延迟将显示给用户。
      ObjectProperty<Duration> showDurationProperty​()
      工具提示应保持显示的持续时间，直到用户不再可见。
      ObjectProperty<TextAlignment> textAlignmentProperty​()
      指定 文本行多行时的行为。
      ObjectProperty<OverrunStyle> textOverrunProperty​()
      指定 Tooltip的文本超过可用空间来呈现文本时使用的行为。
      StringProperty textProperty​()
      要在工具提示中显示的文字。
      static void uninstall​(Node node, Tooltip t)
      删除给定的Tooltip在指定的Node的关联 。
      BooleanProperty wrapTextProperty​()
      如果文本运行超过工具提示的宽度，则该变量指示文本是否应该包装到另一行。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.PopupControl

        getId, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getPrefHeight, getPrefWidth, getPseudoClassStates, getSkin, getStyle, getStyleableNode, getStyleClass, getTypeSelector, idProperty, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, pseudoClassStateChanged, setId, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setPrefHeight, setPrefSize, setPrefWidth, setSkin, setStyle, skinProperty, styleProperty

      • Methods inherited from class javafx.stage.PopupWindow

        anchorLocationProperty, anchorXProperty, anchorYProperty, autoFixProperty, autoHideProperty, consumeAutoHidingEventsProperty, getAnchorLocation, getAnchorX, getAnchorY, getConsumeAutoHidingEvents, getOnAutoHide, getOwnerNode, getOwnerWindow, hide, hideOnEscapeProperty, isAutoFix, isAutoHide, isHideOnEscape, onAutoHideProperty, ownerNodeProperty, ownerWindowProperty, setAnchorLocation, setAnchorX, setAnchorY, setAutoFix, setAutoHide, setConsumeAutoHidingEvents, setHideOnEscape, setOnAutoHide, setScene, show, show, show

      • Methods inherited from class javafx.stage.Window

        addEventFilter, addEventHandler, buildEventDispatchChain, centerOnScreen, eventDispatcherProperty, fireEvent, focusedProperty, forceIntegerRenderScaleProperty, getEventDispatcher, getHeight, getOnCloseRequest, getOnHidden, getOnHiding, getOnShowing, getOnShown, getOpacity, getOutputScaleX, getOutputScaleY, getProperties, getRenderScaleX, getRenderScaleY, getScene, getUserData, getWidth, getWindows, getX, getY, hasProperties, heightProperty, isFocused, isForceIntegerRenderScale, isShowing, onCloseRequestProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, opacityProperty, outputScaleXProperty, outputScaleYProperty, removeEventFilter, removeEventHandler, renderScaleXProperty, renderScaleYProperty, requestFocus, sceneProperty, setEventDispatcher, setEventHandler, setForceIntegerRenderScale, setHeight, setOnCloseRequest, setOnHidden, setOnHiding, setOnShowing, setOnShown, setOpacity, setRenderScaleX, setRenderScaleY, setUserData, setWidth, setX, setY, show, showingProperty, sizeToScene, widthProperty, xProperty, yProperty

    • Property Detail

      • text

        public final StringProperty textProperty
        要在工具提示中显示的文字。 如果文本设置为null，则将显示一个空字符串，尽管值为null。
        另请参见：
        getText() ， setText(String)

      • textAlignment

        public final ObjectProperty<TextAlignment> textAlignmentProperty
        指定文本行多行时的行为。 与影响图形和文本的contentDisplay不同，此设置仅影响文本边界的多行文本。
        另请参见：
        getTextAlignment() ， setTextAlignment(TextAlignment)

      • textOverrun

        public final ObjectProperty<OverrunStyle> textOverrunProperty
        指定 Tooltip的文本超过可用空间来呈现文本时使用的行为。
        另请参见：
        getTextOverrun() ， setTextOverrun(OverrunStyle)

      • wrapText

        public final BooleanProperty wrapTextProperty
        如果文本运行超过工具提示的宽度，则该变量指示文本是否应该包装到另一行。
        另请参见：
        isWrapText() ， setWrapText(boolean)

      • font

        public final ObjectProperty<Font> fontProperty
        工具提示中用于文本的默认字体。 如果工具提示的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用此字体，但是在任何需要默认字体的情况下，将使用该字体。
        另请参见：
        getFont() ， setFont(Font)

      • showDelay

        public final ObjectProperty<Duration> showDelayProperty
        进入悬停节点的鼠标与相关联的工具提示之间的延迟将显示给用户。 默认延迟为1000ms。
        Default value:
        1000毫秒
        从以下版本开始：
        9
        另请参见：
        getShowDelay() ， setShowDelay(Duration)

      • showDuration

        public final ObjectProperty<Duration> showDurationProperty
        工具提示应保持显示的持续时间，直到用户不再可见。 如果在showDuration完成之前鼠标离开控件，则即使在showDuration的剩余时间小于hideDelay持续时间的情况下 ，工具提示仍将显示hideDelayProperty()中指定的持续时间。 默认值为5000ms。
        Default value:
        5000毫秒
        从以下版本开始：
        9
        另请参见：
        getShowDuration() ， setShowDuration(Duration)

      • hideDelay

        public final ObjectProperty<Duration> hideDelayProperty
        在鼠标离开节点后继续显示工具提示的持续时间。 一旦这段时间过去，工具提示就会隐藏起来。 默认值为200ms。
        Default value:
        200毫秒
        从以下版本开始：
        9
        另请参见：
        getHideDelay() ， setHideDelay(Duration)

      • graphic

        public final ObjectProperty<Node> graphicProperty
        工具提示的可选图标。 这可以通过使用content display属性相对于文本定位。 为此变量指定的节点不能出现在场景图形的其他IllegalArgumentException ，否则抛出IllegalArgumentException 。 有关详细信息，请参阅Node的类描述。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • contentDisplay

        public final ObjectProperty<ContentDisplay> contentDisplayProperty
        指定图形相对于文本的位置。
        另请参见：
        getContentDisplay() ， setContentDisplay(ContentDisplay)

      • graphicTextGap

        public final DoubleProperty graphicTextGapProperty
        图形和文字之间的空间量
        另请参见：
        getGraphicTextGap() ， setGraphicTextGap(double)

      • activated

        public final ReadOnlyBooleanProperty activatedProperty
        通常，当鼠标移动到控件上时，工具提示被“激活”。 当Tooltip变为“激活”和实际显示时，通常会有一些延迟。 细节（如延迟量等）留给皮肤实现。
        另请参见：
        isActivated()

    • 构造方法详细信息

      • Tooltip

        public Tooltip​()
        为其文本创建一个带有空字符串的工具提示。

      • Tooltip

        public Tooltip​(String text)
        用指定的文本创建一个工具提示。
        参数
        text - 工具提示的文本字符串。

    • 方法详细信息

      • install

        public static void install​(Node node,
                           Tooltip t)
        将给定的Tooltip与给定的Node相关联 。 然后，工具提示可以与任何Control上的设置相似 。 单个工具提示可以与多个节点相关联。
        参数
        node - 节点
        t - 工具提示
        另请参见：
        Tooltip

      • uninstall

        public static void uninstall​(Node node,
                             Tooltip t)
        删除给定的Tooltip在指定的Node上的关联 。 因此，在该节点上悬停将不再显示工具提示。
        参数
        node - 节点
        t - 工具提示
        另请参见：
        Tooltip

      • textProperty

        public final StringProperty textProperty​()
        要在工具提示中显示的文字。 如果文本设置为null，则将显示一个空字符串，尽管值为null。
        另请参见：
        getText() ， setText(String)

      • setText

        public final void setText​(String value)
        设置属性文本的值。
        Property description:
        要在工具提示中显示的文字。 如果文本设置为null，则将显示一个空字符串，尽管值为null。

      • getText

        public final String getText​()
        获取属性文本的值。
        Property description:
        要在工具提示中显示的文字。 如果文本设置为null，则将显示一个空字符串，尽管值为null。

      • textAlignmentProperty

        public final ObjectProperty<TextAlignment> textAlignmentProperty​()
        指定文本行多行时的行为。 与影响图形和文本的contentDisplay不同，此设置仅影响文本边界的多行文本。
        另请参见：
        getTextAlignment() ， setTextAlignment(TextAlignment)

      • setTextAlignment

        public final void setTextAlignment​(TextAlignment value)
        设置textAlignment属性的值。
        Property description:
        指定文本行多行时的行为。 与影响图形和文本的contentDisplay不同，此设置仅影响文本边界的多行文本。

      • getTextAlignment

        public final TextAlignment getTextAlignment​()
        获取属性textAlignment的值。
        Property description:
        指定文本行多行时的行为。 与影响图形和文本的contentDisplay不同，此设置仅影响文本边界的多行文本。

      • textOverrunProperty

        public final ObjectProperty<OverrunStyle> textOverrunProperty​()
        如果 Tooltip的文本超出了可用于呈现文本的空间，则指定要使用的行为。
        另请参见：
        getTextOverrun() ， setTextOverrun(OverrunStyle)

      • setTextOverrun

        public final void setTextOverrun​(OverrunStyle value)
        设置textOverrun属性的值。
        Property description:
        指定 Tooltip的文本超过可用空间进行渲染时使用的行为。

      • getTextOverrun

        public final OverrunStyle getTextOverrun​()
        获取textOverrun属性的值。
        Property description:
        指定 Tooltip的文本超过可用空间进行渲染时使用的行为。

      • wrapTextProperty

        public final BooleanProperty wrapTextProperty​()
        如果文本运行超过工具提示的宽度，则该变量指示文本是否应该包装到另一行。
        另请参见：
        isWrapText() ， setWrapText(boolean)

      • setWrapText

        public final void setWrapText​(boolean value)
        设置属性wrapText的值。
        Property description:
        如果文本运行超过工具提示的宽度，则该变量指示文本是否应该包装到另一行。

      • isWrapText

        public final boolean isWrapText​()
        获取propertyTextText的值。
        Property description:
        如果文本运行超过工具提示的宽度，则该变量指示文本是否应该包装到另一行。

      • fontProperty

        public final ObjectProperty<Font> fontProperty​()
        工具提示中用于文本的默认字体。 如果工具提示的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用此字体，但是在任何需要默认字体的情况下，将使用该字体。
        另请参见：
        getFont() ， setFont(Font)

      • setFont

        public final void setFont​(Font value)
        设置属性字体的值。
        Property description:
        工具提示中用于文本的默认字体。 如果工具提示的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用此字体，但是在任何需要默认字体的情况下，将使用该字体。

      • getFont

        public final Font getFont​()
        获取属性字体的值。
        Property description:
        工具提示中用于文本的默认字体。 如果工具提示的文本是富文本，则根据嵌入在富文本中的字体信息，可能会使用或不使用此字体，但是在任何需要默认字体的情况下，将使用该字体。

      • showDelayProperty

        public final ObjectProperty<Duration> showDelayProperty​()
        进入悬停节点的鼠标与相关联的工具提示之间的延迟将显示给用户。 默认延迟为1000ms。
        Default value:
        1000毫秒
        从以下版本开始：
        9
        另请参见：
        getShowDelay() ， setShowDelay(Duration)

      • setShowDelay

        public final void setShowDelay​(Duration showDelay)
        设置属性showDelay的值。
        Property description:
        进入悬停节点的鼠标与相关联的工具提示之间的延迟将显示给用户。 默认延迟为1000ms。
        Default value:
        1000毫秒
        从以下版本开始：
        9

      • getShowDelay

        public final Duration getShowDelay​()
        获取属性showDelay的值。
        Property description:
        进入悬停节点的鼠标与相关联的工具提示之间的延迟将显示给用户。 默认延迟为1000ms。
        Default value:
        1000毫秒
        从以下版本开始：
        9

      • showDurationProperty

        public final ObjectProperty<Duration> showDurationProperty​()
        工具提示应保持显示的持续时间，直到用户不再可见。 如果在showDuration完成之前鼠标离开控件，则即使在showDuration的剩余时间小于hideDelay持续时间，工具提示将继续显示hideDelayProperty()中指定的持续时间。 默认值为5000ms。
        Default value:
        5000毫秒
        从以下版本开始：
        9
        另请参见：
        getShowDuration() ， setShowDuration(Duration)

      • setShowDuration

        public final void setShowDuration​(Duration showDuration)
        设置属性showDuration的值。
        Property description:
        工具提示应保持显示的持续时间，直到用户不再可见。 如果在showDuration完成之前鼠标离开控件，则即使在showDuration的剩余时间小于hideDelay持续时间，工具提示仍将显示hideDelayProperty()中指定的持续时间。 默认值为5000ms。
        Default value:
        5000毫秒
        从以下版本开始：
        9

      • getShowDuration

        public final Duration getShowDuration​()
        获取属性showDuration的值。
        Property description:
        工具提示应保持显示的持续时间，直到用户不再可见。 如果在showDuration完成之前鼠标离开控件，则即使在showDuration的剩余时间小于hideDelay持续时间的情况下 ，工具提示仍将显示hideDelayProperty()中指定的持续时间。 默认值为5000ms。
        Default value:
        5000毫秒
        从以下版本开始：
        9

      • hideDelayProperty

        public final ObjectProperty<Duration> hideDelayProperty​()
        在鼠标离开节点后继续显示工具提示的持续时间。 一旦这段时间过去，工具提示就会隐藏起来。 默认值为200ms。
        Default value:
        200毫秒
        从以下版本开始：
        9
        另请参见：
        getHideDelay() ， setHideDelay(Duration)

      • setHideDelay

        public final void setHideDelay​(Duration hideDelay)
        设置属性hideDelay的值。
        Property description:
        在鼠标离开节点后继续显示工具提示的持续时间。 一旦这段时间过去，工具提示就会隐藏起来。 默认值为200ms。
        Default value:
        200毫秒
        从以下版本开始：
        9

      • getHideDelay

        public final Duration getHideDelay​()
        获取属性hideDelay的值。
        Property description:
        在鼠标离开节点后继续显示工具提示的持续时间。 一旦这段时间过去，工具提示就会隐藏起来。 默认值为200ms。
        Default value:
        200毫秒
        从以下版本开始：
        9

      • graphicProperty

        public final ObjectProperty<Node> graphicProperty​()
        工具提示的可选图标。 这可以通过使用content display属性相对于文本进行定位。 为此变量指定的节点不能出现在场景图中的其他IllegalArgumentException ，否则抛出IllegalArgumentException 。 有关详细信息，请参阅Node的类描述。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • setGraphic

        public final void setGraphic​(Node value)
        设置属性图形的值。
        Property description:
        工具提示的可选图标。 这可以通过使用content display属性相对于文本定位。 为此变量指定的节点不能出现在场景图形的其他IllegalArgumentException ，否则抛出IllegalArgumentException 。 有关详细信息，请参阅Node的类描述。

      • getGraphic

        public final Node getGraphic​()
        获取属性图形的值。
        Property description:
        工具提示的可选图标。 这可以通过使用content display属性相对于文本定位。 为此变量指定的节点不能出现在场景图中的其他IllegalArgumentException ，否则抛出IllegalArgumentException 。 有关详细信息，请参阅Node的类描述。

      • contentDisplayProperty

        public final ObjectProperty<ContentDisplay> contentDisplayProperty​()
        指定图形相对于文本的位置。
        另请参见：
        getContentDisplay() ， setContentDisplay(ContentDisplay)

      • setContentDisplay

        public final void setContentDisplay​(ContentDisplay value)
        设置属性contentDisplay的值。
        Property description:
        指定图形相对于文本的位置。

      • getContentDisplay

        public final ContentDisplay getContentDisplay​()
        获取属性contentDisplay的值。
        Property description:
        指定图形相对于文本的位置。

      • graphicTextGapProperty

        public final DoubleProperty graphicTextGapProperty​()
        图形和文字之间的空间量
        另请参见：
        getGraphicTextGap() ， setGraphicTextGap(double)

      • setGraphicTextGap

        public final void setGraphicTextGap​(double value)
        设置属性graphicTextGap的值。
        Property description:
        图形和文字之间的空间量

      • getGraphicTextGap

        public final double getGraphicTextGap​()
        获取属性graphicTextGap的值。
        Property description:
        图形和文字之间的空间量

      • isActivated

        public final boolean isActivated​()
        获取激活的属性的值。
        Property description:
        通常，当鼠标移动到控件上时，工具提示被“激活”。 当Tooltip变为“激活”和实际显示时，通常会有一些延迟。 细节（如延迟量等）留给皮肤实现。

      • activatedProperty

        public final ReadOnlyBooleanProperty activatedProperty​()
        通常，当鼠标移动到控件上时，工具提示被“激活”。 当Tooltip变为“激活”和实际显示时，通常会有一些延迟。 细节（如延迟量等）留给皮肤实现。
        另请参见：
        isActivated()

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 PopupControl
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        这个样式的CssMetaData。 这可以作为不可修改的列表返回。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 PopupControl
        结果
        CssMetaData
        从以下版本开始：
        JavaFX 8.0

      • getStyleableParent

        public Styleable getStyleableParent​()
        说明从类别复制PopupControl
        返回此Styleable的父项，如果没有父项则返回null。 PopupControl的样式基于弹出的“所有者”，即ownerNode，或者如果ownerNode未设置， 则为ownerWindow's场景的根。 如果弹出窗口尚未显示，ownerNode和ownerWindow都将为null，并返回null 。 请注意，PopupWindow的场景根不会返回，因为没有办法保证PopupWindow的场景根将正确返回ownerNode或ownerWindow。
        Specified by:
        getStyleableParent在接口 Styleable
        重写：
        getStyleableParent在 PopupControl
        结果
        PopupWindow.getOwnerNode() ， PopupWindow.getOwnerWindow() ，或者为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeCell<T>
  • 参数类型
    T - TreeItem属性中包含的值的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    CheckBoxTreeCell ， ChoiceBoxTreeCell ， ComboBoxTreeCell ， TextFieldTreeCell

    public class TreeCell<T>
extends IndexedCell<T>
    Cell类型与TreeView控件一起使用。 除了在IndexedCell上定义的API 之外 ，TreeCell公开了CSS使用的其他状态和伪类。

    TreeCell监视与之关联的TreeView的选择模型，确保它可视地向用户指示是否被选择。 当选择TreeCell时， 它将通过selected属性以及通过“选定”CSS伪类状态显示。

    由于TreeCell从IndexedCell延伸，每个TreeCell还提供了一个index属性。 索引将在单元格展开和折叠时更新，因此应视为视图索引而不是模型索引。

    最后，每个TreeCell还有一个与它正在使用的TreeView的引用。 每个TreeCell属于唯一的一个TreeView。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TreeView ， TreeItem

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Node> disclosureNode
      公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
      ReadOnlyObjectProperty<TreeItem<T>> treeItem
      每个TreeCell最多代表一个TreeItem ，由该属性表示。
      ReadOnlyObjectProperty<TreeView<T>> treeView
      TreeCell显式链接到一个TreeView实例，由该属性表示。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeCell​()
      创建一个默认的TreeCell实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      void commitEdit​(T newValue)
      在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      ObjectProperty<Node> disclosureNodeProperty​()
      公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      Node getDisclosureNode​()
      返回此TreeCell中设置的当前披露节点。
      TreeItem<T> getTreeItem​()
      返回当前在此TreeCell中设置的TreeItem。
      TreeView<T> getTreeView​()
      返回与此TreeCell关联的TreeView。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setDisclosureNode​(Node value)
      用作“披露”三角形的节点，或用于展开和折叠项目的切换。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      ReadOnlyObjectProperty<TreeItem<T>> treeItemProperty​()
      每个TreeCell最多代表一个TreeItem ，由该属性表示。
      ReadOnlyObjectProperty<TreeView<T>> treeViewProperty​()
      TreeCell显式链接到一个TreeView实例，由该属性表示。
      void updateTreeItem​(TreeItem<T> treeItem)
      更新与TreeCell关联的TreeItem。
      void updateTreeView​(TreeView<T> tree)
      更新与TreeCell相关联的TreeView。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • treeItem

        public final ReadOnlyObjectProperty<TreeItem<T>> treeItemProperty
        每个TreeCell最多代表一个TreeItem ，由该属性表示。
        结果
        表示TreeCell的TreeItem属性

      • disclosureNode

        public final ObjectProperty<Node> disclosureNodeProperty
        公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
        另请参见：
        getDisclosureNode() ， setDisclosureNode(Node)

      • treeView

        public final ReadOnlyObjectProperty<TreeView<T>> treeViewProperty
        TreeCell显式链接到一个TreeView实例，由该属性表示。
        另请参见：
        getTreeView()

    • 构造方法详细信息

      • TreeCell

        public TreeCell​()
        创建一个默认的TreeCell实例。

    • 方法详细信息

      • getTreeItem

        public final TreeItem<T> getTreeItem​()
        返回当前在此TreeCell中设置的TreeItem。
        结果
        TreeCell中当前设置的TreeItem

      • treeItemProperty

        public final ReadOnlyObjectProperty<TreeItem<T>> treeItemProperty​()
        每个TreeCell最多表示一个TreeItem ，由该属性表示。
        结果
        表示TreeCell的TreeItem属性

      • setDisclosureNode

        public final void setDisclosureNode​(Node value)
        用作“披露”三角形的节点，或用于展开和折叠项目的切换。 这仅在包含子项目的树中的项目的情况下使用。 如果未指定，TreeCell的Skin实现负责提供默认的公开节点。
        参数
        value - 披露节点

      • getDisclosureNode

        public final Node getDisclosureNode​()
        返回此TreeCell中设置的当前披露节点。
        结果
        当前披露节点设置在此TreeCell中

      • disclosureNodeProperty

        public final ObjectProperty<Node> disclosureNodeProperty​()
        公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
        另请参见：
        getDisclosureNode() ， setDisclosureNode(Node)

      • getTreeView

        public final TreeView<T> getTreeView​()
        返回与此TreeCell关联的TreeView。
        结果
        与TreeCell相关联的TreeView

      • treeViewProperty

        public final ReadOnlyObjectProperty<TreeView<T>> treeViewProperty​()
        TreeCell显式链接到一个TreeView实例，由该属性表示。
        另请参见：
        getTreeView()

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 Cell<T>

      • commitEdit

        public void commitEdit​(T newValue)
        在适当的时候调用此功能（基于您的单元格编辑用户界面的用户交互要求）来做两件事情：
        1. 将适当的事件触发回到支持UI控件（例如ListView ）。 这将开始将此编辑推回相关数据源/属性（尽管不能保证这将成功 - 这取决于正在使用的特定编辑提交处理程序）。 有关更多详细信息，请参阅UI控件类javadoc。
        2. 开始从编辑状态转换到非编辑状态。

        一般来说，在自定义单元实现中无需重写此方法 - 在适当的时候简单地调用此方法就足够了（例如，当用户按Enter键时，可以执行像cell.commitEdit(converter.fromString(textField.getText()));

        重写：
        commitEdit在 Cell<T>
        参数
        newValue - 作为最终用户输入的值，应该以相关的方式 newValue给出支持用户界面的数据源和UI控件的安装编辑提交处理程序。

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 Cell<T>

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • updateTreeView

        public final void updateTreeView​(TreeView<T> tree)
        更新与TreeCell相关联的TreeView。
        参数
        tree - 应该与此TreeCell相关联的新TreeView。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。

      • updateTreeItem

        public final void updateTreeItem​(TreeItem<T> treeItem)
        更新与TreeCell关联的TreeItem。
        参数
        treeItem - 应该与此TreeCell相关联的新TreeItem。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 要执行的操作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeItem<T>

  • java.lang.Object
    • javafx.scene.control.TreeItem<T>
  • 参数类型
    T - TreeItem中的 value属性的类型。
    All Implemented Interfaces:
    EventTarget
    已知直接子类：
    CheckBoxTreeItem

    public class TreeItem<T>
extends Object
implements EventTarget
    单个节点的模型为诸如TreeView之类的控件提供值的层次结构。 可以实现该模型，使得值可以根据需要加载到存储器中。

    该模型允许注册听众，将被通知为项目变更的数量，他们的位置或值本身如何变化。 但是请注意，TreeItem 不是 Node，因此TreeItem上不会触发视觉事件。 为了获得这些事件，有必要将相关观察者添加到TreeCell实例（通过自定义单元格工厂 - 有关详细信息，请参阅Cell类文档）。

    在最简单的情况下，可以在内存中创建TreeItem实例：

       TreeItem<String> root = new TreeItem<String>("Root Node"); root.setExpanded(true); root.getChildren().addAll( new TreeItem<String>("Item 1"), new TreeItem<String>("Item 2"), new TreeItem<String>("Item 3") ); TreeView<String> treeView = new TreeView<String>(root);
    这种方法适用于简单的树结构，或者数据不是过多的（这样可以很容易地适应内存）。 在树结构大小未知（因此潜在巨大）的情况下，可以以高效的内存方式按需创建TreeItem实例。 为了演示这个，下面的代码创建一个文件系统浏览器：
       private TreeView buildFileSystemBrowser() { TreeItem<File> root = createNode(new File("/")); return new TreeView<File>(root); } // This method creates a TreeItem to represent the given File. It does this // by overriding the TreeItem.getChildren() and TreeItem.isLeaf() methods // anonymously, but this could be better abstracted by creating a // 'FileTreeItem' subclass of TreeItem. However, this is left as an exercise // for the reader. private TreeItem<File> createNode(final File f) { return new TreeItem<File>(f) { // We cache whether the File is a leaf or not. A File is a leaf if // it is not a directory and does not have any files contained within // it. We cache this as isLeaf() is called often, and doing the // actual check on File is expensive. private boolean isLeaf; // We do the children and leaf testing only once, and then set these // booleans to false so that we do not check again during this // run. A more complete implementation may need to handle more // dynamic file system situations (such as where a folder has files // added after the TreeView is shown). Again, this is left as an // exercise for the reader. private boolean isFirstTimeChildren = true; private boolean isFirstTimeLeaf = true; @Override public ObservableList<TreeItem<File>> getChildren() { if (isFirstTimeChildren) { isFirstTimeChildren = false; // First getChildren() call, so we actually go off and // determine the children of the File contained in this TreeItem. super.getChildren().setAll(buildChildren(this)); } return super.getChildren(); } @Override public boolean isLeaf() { if (isFirstTimeLeaf) { isFirstTimeLeaf = false; File f = (File) getValue(); isLeaf = f.isFile(); } return isLeaf; } private ObservableList<TreeItem<File>> buildChildren(TreeItem<File> TreeItem) { File f = TreeItem.getValue(); if (f != null && f.isDirectory()) { File[] files = f.listFiles(); if (files != null) { ObservableList<TreeItem<File>> children = FXCollections.observableArrayList(); for (File childFile : files) { children.add(createNode(childFile)); } return children; } } return FXCollections.emptyObservableList(); } }; }
    TreeItem事件

    TreeItem支持与场景图中其他地方相同的事件冒泡概念。 这意味着没有必要在所有TreeItems上收听事件（这当然不鼓励！）。 更好的和更低成本的解决方案是将事件监听器附加到TreeView root项目。 只要在事件发生的地方和根TreeItem之间存在路径，事件将被冒泡到根项目。

    但是请注意，TreeItem 不是一个Node，这意味着只有在TreeItem中定义的事件类型才能被传递。 要收听一般事件（例如鼠标交互），需要在TreeView中包含的cells （通过提供cell factory ）添加必要的侦听器。

    TreeItem类定义了一些具有定义层次结构的事件。 这些显示如下（按照链接了解有关每个事件类型的更多信息）：

    • TreeItem.treeNotificationEvent()
      • TreeItem.valueChangedEvent()
      • TreeItem.graphicChangedEvent()
      • TreeItem.expandedItemCountChangeEvent()
        • TreeItem.branchExpandedEvent()
        • TreeItem.branchCollapsedEvent()
        • TreeItem.childrenModificationEvent()

    上面所示的缩进表示事件类型之间的关系。 例如，所有TreeItem事件类型有treeNotificationEvent()其父事件类型，分支expand / 二七○七○二一五○二五七三八一事件类型均为treeNotificationEvent() 。 出于性能原因，鼓励您只听取您需要听的事件。 这意味着鼓励最好听，例如TreeItem.valueChangedEvent() ，而不是TreeItem.treeNotificationEvent() 。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty expanded
      这个TreeItem的扩展状态。
      ObjectProperty<Node> graphic
      通常显示在value属性左侧的节点。
      ReadOnlyBooleanProperty leaf
      表示TreeItem leaf属性，如果TreeItem没有子节点，则属性为true。
      ReadOnlyObjectProperty<TreeItem<T>> parent
      表示此TreeItem父项的属性。
      ObjectProperty<T> value
      表示此TreeItem中包含的特定于应用程序的数据的属性。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TreeItem.TreeModificationEvent<T>
      一个Event ，其中包含所有形式的TreeItem修改的相关信息。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeItem​()
      创建一个空TreeItem。
      TreeItem​(T value)
      创建一个TreeItem，其value属性设置为提供的对象。
      TreeItem​(T value, Node graphic)
      创建一个TreeItem，其value属性设置为提供的对象，图形设置为提供的节点。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      <E extends Event>
      void             		addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      将一个事件处理程序注册到此TreeItem。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> branchCollapsedEvent​()
      当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于折叠状态。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> branchExpandedEvent​()
      当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于展开状态。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> childrenModificationEvent​()
      当TreeItem接收到对其子列表的直接修改时使用的EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> expandedItemCountChangeEvent​()
      当TreeItem接收到一个修改，导致孩子数目可见的更改时使用的常规EventType。
      BooleanProperty expandedProperty​()
      这个TreeItem的扩展状态。
      ObservableList<TreeItem<T>> getChildren​()
      这个TreeItem的孩子。
      Node getGraphic​()
      返回通常显示在value属性左侧的节点。
      TreeItem<T> getParent​()
      这个TreeItem的父项。
      T getValue​()
      返回此TreeItem表示的特定于应用程序的数据。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> graphicChangedEvent​()
      当TreeItem接收到其图形属性的修改时使用的EventType。
      ObjectProperty<Node> graphicProperty​()
      通常显示在value属性左侧的节点。
      boolean isExpanded​()
      返回此TreeItem的展开状态。
      boolean isLeaf​()
      TreeItem是一个叶子，如果它没有孩子。
      ReadOnlyBooleanProperty leafProperty​()
      表示TreeItem leaf属性，如果TreeItem没有子节点，则属性为true。
      TreeItem<T> nextSibling​()
      返回TreeItem的下一个兄弟节点。
      TreeItem<T> nextSibling​(TreeItem<T> afterNode)
      返回给定节点之后的下一个兄弟节点。
      ReadOnlyObjectProperty<TreeItem<T>> parentProperty​()
      表示此TreeItem父项的属性。
      TreeItem<T> previousSibling​()
      返回TreeItem的以前的同级。
      TreeItem<T> previousSibling​(TreeItem<T> beforeNode)
      返回给定节点之前的同级。
      <E extends Event>
      void             		removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)
      从此TreeItem中注销先前注册的事件处理程序。
      void setExpanded​(boolean value)
      设置此TreeItem的展开状态。
      void setGraphic​(Node value)
      设置通常显示在value属性左侧的节点。
      void setValue​(T value)
      设置此TreeItem表示的应用程序特定数据。
      String toString​()
      返回此 TreeItem对象的字符串表示形式。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> treeNotificationEvent​()
      用于指示事件在TreeItem中发生的基本EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> valueChangedEvent​()
      当TreeItem接收到对其value属性的修改时使用的EventType。
      ObjectProperty<T> valueProperty​()
      表示此TreeItem中包含的特定于应用程序的数据的属性。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • value

        public final ObjectProperty<T> valueProperty
        表示此TreeItem中包含的特定于应用程序的数据的属性。
        结果
        表示此TreeItem中包含的特定于应用程序的数据的属性

      • graphic

        public final ObjectProperty<Node> graphicProperty
        通常显示在value属性左侧的节点。 为了获得最佳效果，这往往是一个16x16的图像。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • expanded

        public final BooleanProperty expandedProperty
        这个TreeItem的扩展状态。
        另请参见：
        isExpanded() ， setExpanded(boolean)

      • leaf

        public final ReadOnlyBooleanProperty leafProperty
        表示TreeItem leaf属性，如果TreeItem没有子节点，则属性为true。
        另请参见：
        isLeaf()

      • parent

        public final ReadOnlyObjectProperty<TreeItem<T>> parentProperty
        表示此TreeItem父项的属性。
        另请参见：
        getParent()

    • 构造方法详细信息

      • TreeItem

        public TreeItem​()
        创建一个空TreeItem。

      • TreeItem

        public TreeItem​(T value)
        创建一个TreeItem，其value属性设置为提供的对象。
        参数
        value - 要存储的对象作为此TreeItem的值。

      • TreeItem

        public TreeItem​(T value,
                Node graphic)
        创建一个TreeItem，其value属性设置为提供的对象，图形设置为提供的节点。
        参数
        value - 要存储的对象作为此TreeItem的值。
        graphic - 要在TreeView旁边显示的节点。

    • 方法详细信息

      • treeNotificationEvent

        public static <T> EventType<TreeItem.TreeModificationEvent<T>> treeNotificationEvent​()
        用于指示事件在TreeItem中发生的基本EventType。 当TreeItem中发生事件时，事件发生之前，事件将触发TreeItem上的任何侦听器，然后通过跟随TreeItem父属性来启动TreeItem链。 这将重复，直到达到父TreeItem为null的TreeItem此时，事件将停止“冒泡”，不再进一步。 这意味着在TreeItem上发生的事件可以相对便宜，因为监听器只需要安装在TreeView根节点上，以便在树中的任何一点发生事件。
        参数类型
        T - TreeItem中包含的值的类型。
        结果
        TreeItem中发生事件时的基本EventType

      • expandedItemCountChangeEvent

        public static <T> EventType<TreeItem.TreeModificationEvent<T>> expandedItemCountChangeEvent​()
        当TreeItem接收到一个修改，导致孩子数目可见的更改时使用的常规EventType。 这是通过子类型此的EventType中的一个通常实现（参见branchExpandedEvent() ， branchCollapsedEvent()和childrenModificationEvent()为三个子类型）。
        参数类型
        T - TreeItem中包含的值的类型。
        结果
        TreeItem接收修改时的常规EventType
        从以下版本开始：
        JavaFX 8.0

      • branchExpandedEvent

        public static <T> EventType<TreeItem.TreeModificationEvent<T>> branchExpandedEvent​()
        当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于展开状态。
        参数类型
        T - TreeItem中包含的值的类型。
        结果
        TreeItem接收到修改时使用的EventType

      • branchCollapsedEvent

        public static <T> EventType<TreeItem.TreeModificationEvent<T>> branchCollapsedEvent​()
        当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于折叠状态。
        参数类型
        T - TreeItem中包含的值的类型。
        结果
        TreeItem接收修改时的EventType

      • childrenModificationEvent

        public static <T> EventType<TreeItem.TreeModificationEvent<T>> childrenModificationEvent​()
        当TreeItem接收到对其子列表的直接修改时使用的EventType。
        参数类型
        T - TreeItem中包含的值的类型。
        结果
        TreeItem接收对其子列表的直接修改时的EventType

      • valueChangedEvent

        public static <T> EventType<TreeItem.TreeModificationEvent<T>> valueChangedEvent​()
        当TreeItem接收到对其value属性的修改时使用的EventType。
        参数类型
        T - TreeItem中包含的值的类型。
        结果
        TreeItem接收到其value属性的修改时的EventType

      • graphicChangedEvent

        public static <T> EventType<TreeItem.TreeModificationEvent<T>> graphicChangedEvent​()
        当TreeItem接收到其图形属性的修改时使用的EventType。
        参数类型
        T - TreeItem中包含的值的类型。
        结果
        TreeItem接收到其图形属性的修改时的EventType

      • setValue

        public final void setValue​(T value)
        设置此TreeItem表示的应用程序特定数据。
        参数
        value - 应用程序特定的数据

      • getValue

        public final T getValue​()
        返回此TreeItem表示的特定于应用程序的数据。
        结果
        该TreeItem表示的数据

      • valueProperty

        public final ObjectProperty<T> valueProperty​()
        表示此TreeItem中包含的特定于应用程序的数据的属性。
        结果
        表示此TreeItem中包含的特定于应用程序的数据的属性

      • setGraphic

        public final void setGraphic​(Node value)
        设置通常显示在value属性左侧的节点。 为了获得最佳效果，这往往是一个16x16的图像。
        参数
        value - 将显示给用户的图形节点。

      • getGraphic

        public final Node getGraphic​()
        返回通常显示在value属性左侧的节点。 为了获得最佳效果，这往往是一个16x16的图像。
        结果
        将显示给用户的图形节点。

      • graphicProperty

        public final ObjectProperty<Node> graphicProperty​()
        通常显示在value属性左侧的节点。 为了获得最佳效果，这往往是一个16x16的图像。
        另请参见：
        getGraphic() ， setGraphic(Node)

      • setExpanded

        public final void setExpanded​(boolean value)
        设置此TreeItem的展开状态。 这对没有孩子的TreeItem没有影响。 在有孩子的TreeItem上，切换该属性的结果是，视觉上孩子将会变得可见或隐藏，基于是否将扩展设置为true或false。
        参数
        value - 如果此TreeItem有子项，则使用true调用true将导致孩子变得可见。 使用false调用setExpanded将隐藏属于TreeItem的任何子项。

      • isExpanded

        public final boolean isExpanded​()
        返回此TreeItem的展开状态。
        结果
        返回此TreeItem的展开状态。

      • expandedProperty

        public final BooleanProperty expandedProperty​()
        这个TreeItem的扩展状态。
        另请参见：
        isExpanded() ， setExpanded(boolean)

      • isLeaf

        public boolean isLeaf​()
        TreeItem是一个叶子，如果它没有孩子。 当然，可以通过子类覆盖isLeaf方法来支持定义TreeItem可能是一个叶子的替代方法，但是一般的前提是相同的：叶子不能被用户扩展，因此不会显示一个披露节点或响应扩展请求。
        结果
        如果此TreeItem没有子项，则为true

      • leafProperty

        public final ReadOnlyBooleanProperty leafProperty​()
        表示TreeItem leaf属性，如果TreeItem没有子节点，则属性为true。
        另请参见：
        isLeaf()

      • getParent

        public final TreeItem<T> getParent​()
        这个TreeItem的父项。 每个TreeItem可以只有一个以上的父项。 如果TreeItem没有父项，它表示树模型中的根。
        结果
        此TreeItem的父项，如果TreeItem没有父项，则为null。

      • parentProperty

        public final ReadOnlyObjectProperty<TreeItem<T>> parentProperty​()
        表示此TreeItem父项的属性。
        另请参见：
        getParent()

      • getChildren

        public ObservableList<TreeItem<T>> getChildren​()
        这个TreeItem的孩子。 这种方法被频繁地调用，因此推荐返回的列表被任何TreeItem实现缓存。
        结果
        包含属于TreeItem的子TreeItems的列表。

      • previousSibling

        public TreeItem<T> previousSibling​()
        返回TreeItem的以前的同级。 订购是基于TreeItem相对于属于TreeItem父项的子列表中的兄弟姐妹的位置。
        结果
        一个TreeItem，它是当前TreeItem的前一个兄弟节点，如果没有找到这样的兄弟节点，则返回null。

      • previousSibling

        public TreeItem<T> previousSibling​(TreeItem<T> beforeNode)
        返回给定节点之前的同级。 订购是基于给定TreeItem相对于属于TreeItem父项的子列表中的兄弟姐妹的位置。
        参数
        beforeNode - 正在寻找以前的兄弟姐妹的TreeItem。
        结果
        一个TreeItem，它是给定TreeItem的前一个同级，如果没有找到这样的兄弟，则为null。

      • nextSibling

        public TreeItem<T> nextSibling​()
        返回TreeItem的下一个兄弟节点。 订购是基于TreeItem相对于属于TreeItem父项的子列表中的兄弟姐妹的位置。
        结果
        一个TreeItem，它是当前TreeItem的下一个兄弟节点，如果没有找到这样的兄弟节点，则为null。

      • nextSibling

        public TreeItem<T> nextSibling​(TreeItem<T> afterNode)
        返回给定节点之后的下一个兄弟节点。 订购是基于给定TreeItem相对于属于TreeItem父项的子列表中的兄弟姐妹的位置。
        参数
        afterNode - 正在寻找下一个兄弟姐妹的TreeItem。
        结果
        作为给定TreeItem的下一个同级的TreeItem，如果没有找到这样的兄弟，则为null。

      • toString

        public String toString​()
        返回此 TreeItem对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 TreeItem对象的字符串表示形式。

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此目标构建事件调度链。 事件调度链包含可能对处理针对EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要为链接添加一个EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 建立起来的初始链
        结果
        此目标的结果事件调度链

      • addEventHandler

        public <E extends Event> void addEventHandler​(EventType<E> eventType,
                                              EventHandler<E> eventHandler)
        将一个事件处理程序注册到此TreeItem。 TreeItem类允许监听器的注册，将被通知为项目更改的数量，它们的位置或值本身是如何变化的。 但是请注意，TreeItem 不是 Node，因此TreeItem上不会触发视觉事件。 要获得这些事件，有必要将相关观察者添加到TreeCell实例（通过一个自定义单元格工厂 - 有关详细信息，请参阅Cell类文档）。
        参数类型
        E - 事件
        参数
        eventType - 由处理程序接收的事件的类型
        eventHandler - 要注册的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • removeEventHandler

        public <E extends Event> void removeEventHandler​(EventType<E> eventType,
                                                 EventHandler<E> eventHandler)
        从此TreeItem中注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        参数类型
        E - 事件
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeItem.TreeModificationEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeItem.TreeModificationEvent<T>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.TreeItem.TreeModificationEvent<T>
  • 参数类型
    T - TreeModificationEvent
    All Implemented Interfaces:
    Serializable ， Cloneable
    Enclosing class:
    TreeItem < T >

    public static class TreeItem.TreeModificationEvent<T>
extends Event
    一个Event ，其中包含所有形式的TreeItem修改的相关信息。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<?> ANY
      所有树修改事件类型的常用超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem)
      构建一个基本的TreeModificationEvent - 这在树项目没有收到新值，扩展/折叠状态之间没有变化，并且其子项没有更改的情况下很有用。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, boolean expanded)
      构建一个TreeModificationEvent，当TreeItem已经更改了 TreeItem.expandedProperty()时 。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, List<? extends TreeItem<T>> added, List<? extends TreeItem<T>> removed)
      构造一个TreeModificationEvent，当TreeItem的子项列表更改时。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, T newValue)
      构建TreeModificationEvent，当TreeItem的 TreeItem.valueProperty()更改时。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      List<? extends TreeItem<T>> getAddedChildren​()
      返回在此事件中添加到TreeItem的子项，如果未添加子项，则返回空列表。
      int getAddedSize​()
      返回在此事件中添加的子项目数，如果未添加子项，则返回零。
      T getNewValue​()
      如果TreeItem的值已更改，则此方法将返回新值。
      List<? extends TreeItem<T>> getRemovedChildren​()
      返回在此事件中从TreeItem中删除的子项，如果未添加子项，则返回空列表。
      int getRemovedSize​()
      返回在此事件中删除的子项目数，如果没有删除子项，则返回零。
      TreeItem<T> getSource​()
      返回发生此事件的TreeItem。
      TreeItem<T> getTreeItem​()
      返回此事件发生的TreeItem。
      boolean wasAdded​()
      如果此事件表示添加了子树项目的TreeItem事件，则返回true。
      boolean wasCollapsed​()
      如果此事件表示TreeItem collapse事件，则返回true，如果TreeItem未折叠，则返回false。
      boolean wasExpanded​()
      如果此事件表示TreeItem展开事件，则返回true，如果TreeItem未展开则返回false。
      boolean wasPermutated​()
      如果TreeItem子列表的顺序已更改，但没有添加或删除，则返回true。
      boolean wasRemoved​()
      如果此事件表示删除了子树项目的TreeItem事件，则返回true。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<?> ANY
        所有树修改事件类型的常用超类型。
        从以下版本开始：
        JavaFX 8.0

    • 构造方法详细信息

      • TreeModificationEvent

        public TreeModificationEvent​(EventType<? extends Event> eventType,
                             TreeItem<T> treeItem)
        构建一个基本的TreeModificationEvent - 这在树项目没有收到新值，扩展/折叠状态之间没有变化，并且其子项没有更改的情况下很有用。 使用此构造函数时的一个示例是当TreeItem图形属性更改时。
        参数
        eventType - 发生的事件的类型。
        treeItem - 发生此事件的TreeItem。

      • TreeModificationEvent

        public TreeModificationEvent​(EventType<? extends Event> eventType,
                             TreeItem<T> treeItem,
                             T newValue)
        构造一个TreeModificationEvent，当TreeItem的 TreeItem.valueProperty()更改时。
        参数
        eventType - 发生的事件的类型。
        treeItem - 发生此事件的TreeItem。
        newValue -已投产的新值 TreeItem.valueProperty() 。

      • TreeModificationEvent

        public TreeModificationEvent​(EventType<? extends Event> eventType,
                             TreeItem<T> treeItem,
                             boolean expanded)
        构建一个TreeModificationEvent，当TreeItem的 TreeItem.expandedProperty()更改时。
        参数
        eventType - 发生的事件的类型。
        treeItem - 发生此事件的TreeItem。
        expanded - 用于表示TreeItem当前展开状态的布尔值。

      • TreeModificationEvent

        public TreeModificationEvent​(EventType<? extends Event> eventType,
                             TreeItem<T> treeItem,
                             List<? extends TreeItem<T>> added,
                             List<? extends TreeItem<T>> removed)
        构造一个TreeModificationEvent，当TreeItem的子项列表更改时。
        参数
        eventType - 发生的事件的类型。
        treeItem - 发生此事件的TreeItem。
        added - 添加到给定TreeItem的子列表中的项目列表。
        removed - 从给定TreeItem的子列表中删除的项目列表。

    • 方法详细信息

      • getSource

        public TreeItem<T> getSource​()
        返回发生此事件的TreeItem。
        重写：
        getSource在 EventObject
        结果
        事件最初发生的对象。
        从以下版本开始：
        JavaFX 2.1

      • getTreeItem

        public TreeItem<T> getTreeItem​()
        返回此事件发生的TreeItem。
        结果
        此事件发生的TreeItem。

      • getNewValue

        public T getNewValue​()
        如果TreeItem的值已更改，则此方法将返回新值。 如果没有改变，这个方法将返回null。
        结果
        TreeItem的新值如果更改，否则为空。

      • getAddedChildren

        public List<? extends TreeItem<T>> getAddedChildren​()
        返回在此事件中添加到TreeItem的子项，如果未添加子项，则返回空列表。
        结果
        新添加的孩子，如果没有添加孩子，则为空列表。

      • getRemovedChildren

        public List<? extends TreeItem<T>> getRemovedChildren​()
        返回在此事件中从TreeItem中删除的子项，如果未添加子项，则返回空列表。
        结果
        移除的孩子，或没有孩子被移除的空列表。

      • getRemovedSize

        public int getRemovedSize​()
        返回在此事件中删除的子项目数，如果没有删除子项，则返回零。
        结果
        删除的儿童物品的数量，如果没有孩子被移除，则为零。

      • getAddedSize

        public int getAddedSize​()
        返回在此事件中添加的子项目数，如果未添加子项，则返回零。
        结果
        添加儿童项目的数量，如果没有添加子项，则为零。

      • wasExpanded

        public boolean wasExpanded​()
        如果此事件表示TreeItem展开事件，则返回true，如果TreeItem未展开则返回false。
        结果
        如果此事件表示TreeItem展开事件，则为true，如果TreeItem未展开则为false

      • wasCollapsed

        public boolean wasCollapsed​()
        如果此事件表示TreeItem collapse事件，则返回true，如果TreeItem未折叠，则返回false。
        结果
        如果此事件表示TreeItem collapse事件，则为true，如果TreeItem未折叠，则为false

      • wasAdded

        public boolean wasAdded​()
        如果此事件表示添加了子树项目的TreeItem事件，则返回true。
        结果
        如果此事件表示添加了子树项目的TreeItem事件，则为true

      • wasRemoved

        public boolean wasRemoved​()
        如果此事件表示删除了子树项目的TreeItem事件，则返回true。
        结果
        如果此事件表示一个TreeItem事件，其中删除了TreeItems，则为true

      • wasPermutated

        public boolean wasPermutated​()
        如果TreeItem子列表的顺序已更改，但没有添加或删除，则返回true。
        结果
        true if the order of the TreeItem children list has changed, but that there have been no additions or removals
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TreeSortMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum TreeSortMode

  • java.lang.Object
    • java.lang.Enum<TreeSortMode>
      • javafx.scene.control.TreeSortMode
  • All Implemented Interfaces:
    Serializable ， Comparable<TreeSortMode>

    public enum TreeSortMode
extends Enum<TreeSortMode>
    指定如何对树状UI控件中的树项进行排序。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALL_DESCENDANTS
      默认; 排序所有节点。
      ONLY_FIRST_LEVEL
      仅排序第一级节点，而不管实际是否显示根。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TreeSortMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TreeSortMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ALL_DESCENDANTS

        public static final TreeSortMode ALL_DESCENDANTS
        默认; 排序所有节点。

      • ONLY_FIRST_LEVEL

        public static final TreeSortMode ONLY_FIRST_LEVEL
        仅排序第一级节点，而不管实际是否显示根。

    • 方法详细信息

      • values

        public static TreeSortMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TreeSortMode c : TreeSortMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TreeSortMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeTableCell<S,T>
  • 参数类型
    S - TreeTableView泛型类型的类型
    T - 单元格中包含的项目的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable
    已知直接子类：
    CheckBoxTreeTableCell ， ChoiceBoxTreeTableCell ， ComboBoxTreeTableCell ， ProgressBarTreeTableCell ， TextFieldTreeTableCell

    public class TreeTableCell<S,T>
extends IndexedCell<T>
    在TreeTableView中表示单行/列交集。 要表示此交集，TreeTableCell包含一个index属性，以及一个tableColumn属性。 另外，一个TreeTableCell实例知道它存在的是TreeTableRow 。

    关于选择的注释： TreeTableCell可视化显示在满足两个条件时被选中：

    1. TableSelectionModel.isSelected(int, TableColumnBase)方法对于此单元格表示的行/列返回true
    2. cell selection mode属性设置为true（表示可以选择单个单元格（而不仅仅是单元格行））。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TreeTableView ， TreeTableColumn ， Cell ， IndexedCell ， TreeTableRow

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<TreeTableColumn<S,T>> tableColumn
      ReadOnlyObjectProperty<TreeTableRow<S>> tableRow
      ReadOnlyObjectProperty<TreeTableView<S>> treeTableView
      与此TreeTableCell关联的TreeTableView。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTableCell​()
      构造一个具有“tree-table-cell”样式类的默认TreeTableCell实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      void commitEdit​(T newValue)
      在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      TreeTableColumn<S,T> getTableColumn​()
      获取属性tableColumn的值。
      TreeTableRow<S> getTreeTableRow​()
      TreeTableView<S> getTreeTableView​()
      获取属性treeTableView的值。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      ReadOnlyObjectProperty<TreeTableColumn<S,T>> tableColumnProperty​()
      ReadOnlyObjectProperty<TreeTableRow<S>> tableRowProperty​()
      ReadOnlyObjectProperty<TreeTableView<S>> treeTableViewProperty​()
      与此TreeTableCell关联的TreeTableView。
      void updateSelected​(boolean selected)
      更新此单元格是否处于选定状态。
      void updateTreeTableColumn​(TreeTableColumn<S,T> col)
      更新与此TreeTableCell关联的TreeTableColumn。
      void updateTreeTableRow​(TreeTableRow<S> treeTableRow)
      更新与此TreeTableCell关联的TreeTableRow。
      void updateTreeTableView​(TreeTableView<S> tv)
      更新与此TreeTableCell关联的TreeTableView。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem, updateItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • tableColumn

        public final ReadOnlyObjectProperty<TreeTableColumn<S,T>> tableColumnProperty
        另请参见：
        getTableColumn()

      • treeTableView

        public final ReadOnlyObjectProperty<TreeTableView<S>> treeTableViewProperty
        与此TreeTableCell关联的TreeTableView。
        另请参见：
        getTreeTableView()

      • tableRow

        public final ReadOnlyObjectProperty<TreeTableRow<S>> tableRowProperty

    • 构造方法详细信息

      • TreeTableCell

        public TreeTableCell​()
        构造一个具有“tree-table-cell”样式类的默认TreeTableCell实例。

    • 方法详细信息

      • tableColumnProperty

        public final ReadOnlyObjectProperty<TreeTableColumn<S,T>> tableColumnProperty​()
        另请参见：
        getTableColumn()

      • getTableColumn

        public final TreeTableColumn<S,T> getTableColumn​()
        获取属性tableColumn的值。
        Property description:

      • getTreeTableView

        public final TreeTableView<S> getTreeTableView​()
        获取属性treeTableView的值。
        Property description:
        与此TreeTableCell关联的TreeTableView。

      • treeTableViewProperty

        public final ReadOnlyObjectProperty<TreeTableView<S>> treeTableViewProperty​()
        与此TreeTableCell关联的TreeTableView。
        另请参见：
        getTreeTableView()

      • getTreeTableRow

        public final TreeTableRow<S> getTreeTableRow​()

      • tableRowProperty

        public final ReadOnlyObjectProperty<TreeTableRow<S>> tableRowProperty​()

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 Cell<T>

      • commitEdit

        public void commitEdit​(T newValue)
        在适当的时候调用此功能（基于您的单元格编辑用户界面的用户交互要求）来做两件事情：
        1. 将适当的事件触发回到支持UI控件（例如ListView ）。 这将开始将此编辑推回相关数据源/属性（尽管不能保证这将成功 - 这取决于正在使用的特定编辑提交处理程序）。 有关更多详细信息，请参阅UI控件类javadoc。
        2. 开始从编辑状态转换到非编辑状态。

        一般来说，在自定义单元实现中无需重写此方法 - 在适当的时候简单地调用此方法就足够了（例如，当用户按下Enter键时，可以执行像cell.commitEdit(converter.fromString(textField.getText()));

        重写：
        commitEdit在 Cell<T>
        参数
        newValue - 作为最终用户输入的值，应该以相关方式 newValue给出支持用户界面的数据源和UI控件的安装编辑提交处理程序。

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 Cell<T>

      • updateSelected

        public void updateSelected​(boolean selected)
        更新此单元格是否处于选定状态。
        重写：
        updateSelected在 Cell<T>
        参数
        selected - 是否选择此单元格。

      • layoutChildren

        protected void layoutChildren​()
        描述从类别Cell复制
        在布局传递期间调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Cell<T>

      • updateTreeTableView

        public final void updateTreeTableView​(TreeTableView<S> tv)
        更新与此TreeTableCell关联的TreeTableView。 当TreeTableCell首次添加到TreeTableView时，通常只执行一次。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        tv - 与此TreeTableCell关联的TreeTableView

      • updateTreeTableRow

        public final void updateTreeTableRow​(TreeTableRow<S> treeTableRow)
        更新与此TreeTableCell关联的TreeTableRow。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        treeTableRow - 与此TreeTableCell关联的TreeTableRow

      • updateTreeTableColumn

        public final void updateTreeTableColumn​(TreeTableColumn<S,T> col)
        更新与此TreeTableCell关联的TreeTableColumn。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。
        参数
        col - 与此TreeTableCell关联的TreeTableColumn

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 要执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeTableColumn (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableColumn<S,T>

  • java.lang.Object
    • javafx.scene.control.TableColumnBase<TreeItem<S>,T>
      • javafx.scene.control.TreeTableColumn<S,T>
  • 参数类型
    S - TableView通用类型的类型（即S == TableView <S>）
    T - 此TableColumn中所有单元格中的内容类型。
    All Implemented Interfaces:
    Styleable ， EventTarget

    public class TreeTableColumn<S,T>
extends TableColumnBase<TreeItem<S>,T>
implements EventTarget
    A TreeTableView由多个TreeTableColumn实例组成。 TreeTableView中的每个TreeTableColumn负责显示（和编辑）该列的内容。 除了负责显示和编辑单个列的数据之外，TreeTableColumn还包含必要的属性：
    • 可以（使用尺寸调整二七○七○二五五一九二○一○一 / 二百七十○万七千零二十五亿五千一百九十三万六千二百八十六 / 二七�銎唼龆�五五一九五�鏊木牌�和width特性）
    • 有其visibility切换
    • 显示header text
    • 显示可能包含的任何nested columns
    • 当用户右键单击列标题区域时，有context menu
    • 有表的内容进行排序（使用comparator ， sortable和sortType ）
    创建TreeTableColumn实例时，可能要设置的两个最重要的属性是列text （列标题区域中显示的内容）和列cell value factory （用于填充列中的单个单元格）的列。 这可以使用以下代码中的一些变体来实现：
       firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the TreeItem<Person> instance for a particular TreeTableView row, // p.getValue().getValue() returns the Person instance inside the TreeItem<Person> return p.getValue().getValue().firstNameProperty(); } }); }
    此方法假定从p.getValue().getValue()返回的对象具有可以简单地返回的JavaFX ObservableValue 。 这样做的好处是，TableView将在内部创建绑定，以确保返回的ObservableValue更改时，单元格内容将被自动刷新。

    在TableColumn必须与在JavaFX之前创建的类进行交互的情况下，或通常不希望为属性使用JavaFX API的情况下，可以将返回的值包装在一个ReadOnlyObjectWrapper的实例中。 例如：

       firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the TreeItem<Person> instance for a particular TreeTableView row, // p.getValue().getValue() returns the Person instance inside the TreeItem<Person> return new ReadOnlyObjectWrapper(p.getValue().getValue().getFirstName()); } }); }
    希望随着时间的推移，开发商可以开发和提供便利的电池价值工厂。 从JavaFX 2.0版本开始，有一个这样的便利类： TreeItemPropertyValueFactory 。 这个类不需要编写上面的代码，而是依靠反射来从String中查找给定的属性。 有关如何使用TableColumn的更多信息，请参阅TreeItemPropertyValueFactory类文档。 最后，有关如何使用TableColumn的更多细节，还有TableView类文档中的进一步文档。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TableView ， TableCell ， TablePosition ， TreeItemPropertyValueFactory

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>> cellFactory
      该列中所有单元格的单元格工厂。
      ObjectProperty<Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> cellValueFactory
      单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditCancel
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditCommit
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditStart
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<TreeTableColumn.SortType> sortType
      用于说明此列是否为排序顺序的一部分（详见 TreeTableView.getSortOrder() ），应按升序或降序排列。
      ReadOnlyObjectProperty<TreeTableView<S>> treeTableView
      TreeTableColumn属于的TreeTableView。

      • Properties inherited from class javafx.scene.control.TableColumnBase

        comparator, contextMenu, editable, graphic, id, maxWidth, minWidth, parentColumn, prefWidth, reorderable, resizable, sortable, sortNode, style, text, visible, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TreeTableColumn.CellDataFeatures<S,T>
      在TreeTableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。
      static class  TreeTableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TreeTableColumn.SortType
      枚举，指定应用于特定列的排序类型。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Callback<TreeTableColumn<?,?>,TreeTableCell<?,?>> DEFAULT_CELL_FACTORY
      如果在TreeTableColumn实例上未指定cellFactory，则默认情况下将使用该实例。

      • Fields inherited from class javafx.scene.control.TableColumnBase

        DEFAULT_COMPARATOR

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTableColumn​()
      使用默认单元格工厂，比较器和onEditCommit实现创建默认的TreeTableColumn。
      TreeTableColumn​(String text)
      创建一个TreeTableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>> cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      ObjectProperty<Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> editAnyEvent​()
      任何TreeTableColumn编辑事件的父事件。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> editCancelEvent​()
      表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> editCommitEvent​()
      表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> editStartEvent​()
      表示用户已经执行了一些交互以启动编辑事件，或者 TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)方法已被调用。
      Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> getCellFactory​()
      获取属性cellFactory的值。
      ObservableValue<T> getCellObservableValue​(int index)
      尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。
      ObservableValue<T> getCellObservableValue​(TreeItem<S> item)
      尝试返回给定项目（其类型为S）的ObservableValue <T>。
      Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> getCellValueFactory​()
      获取属性cellValueFactory的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      ObservableList<TreeTableColumn<S,?>> getColumns​()
      这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      这个样式的CssMetaData。
      EventHandler<TreeTableColumn.CellEditEvent<S,T>> getOnEditCancel​()
      获取属性onEditCancel的值。
      EventHandler<TreeTableColumn.CellEditEvent<S,T>> getOnEditCommit​()
      获取属性onEditCommit的值。
      EventHandler<TreeTableColumn.CellEditEvent<S,T>> getOnEditStart​()
      获取onEditStart上的属性的值。
      TreeTableColumn.SortType getSortType​()
      获取属性sortType的值。
      Node getStyleableNode​()
      返回表示此Styleable对象的Node。
      Styleable getStyleableParent​()
      返回此Styleable的父项，如果没有父项则返回null。
      TreeTableView<S> getTreeTableView​()
      获取属性treeTableView的值。
      String getTypeSelector​()
      这种 Styleable的类型用于选择器匹配。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditCommitProperty​()
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      void setCellFactory​(Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> value)
      设置属性cellFactory的值。
      void setCellValueFactory​(Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
      设置属性cellValueFactory的值。
      void setOnEditCancel​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCancel的值。
      void setOnEditCommit​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCommit的值。
      void setOnEditStart​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
      设置属性onEditStart的值。
      void setSortType​(TreeTableColumn.SortType value)
      设置属性sortType的值。
      ObjectProperty<TreeTableColumn.SortType> sortTypeProperty​()
      用于说明此列是否为排序顺序的一部分（更多详细信息，请参阅 TreeTableView.getSortOrder() ），应按升序或降序进行排序。
      ReadOnlyObjectProperty<TreeTableView<S>> treeTableViewProperty​()
      TreeTableColumn属于的TreeTableView。

      • Methods inherited from interface javafx.event.EventTarget

        buildEventDispatchChain

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.TableColumnBase

        addEventHandler, buildEventDispatchChain, comparatorProperty, contextMenuProperty, editableProperty, getCellData, getCellData, getComparator, getContextMenu, getGraphic, getId, getMaxWidth, getMinWidth, getParentColumn, getPrefWidth, getProperties, getPseudoClassStates, getSortNode, getStyle, getStyleClass, getText, getUserData, getWidth, graphicProperty, hasProperties, idProperty, isEditable, isReorderable, isResizable, isSortable, isVisible, maxWidthProperty, minWidthProperty, parentColumnProperty, prefWidthProperty, removeEventHandler, reorderableProperty, resizableProperty, setComparator, setContextMenu, setEditable, setGraphic, setId, setMaxWidth, setMinWidth, setPrefWidth, setReorderable, setResizable, setSortable, setSortNode, setStyle, setText, setUserData, setVisible, sortableProperty, sortNodeProperty, styleProperty, textProperty, visibleProperty, widthProperty

    • Property Detail

      • treeTableView

        public final ReadOnlyObjectProperty<TreeTableView<S>> treeTableViewProperty
        TreeTableColumn属于的TreeTableView。
        另请参见：
        getTreeTableView()

      • cellValueFactory

        public final ObjectProperty<Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> cellValueFactoryProperty
        单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。 一个单元格值工厂是一个Callback ，它提供了一个TreeTableColumn.CellDataFeatures实例，并期望返回一个ObservableValue 。 返回的ObservableValue实例将在内部进行观察，以允许更新值立即反映在屏幕上。

        如何设置单元格值工厂的一个例子是：

           firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the TreeItem<Person> instance for a particular TreeTableView row, // p.getValue().getValue() returns the Person instance inside the TreeItem<Person> return p.getValue().getValue().firstNameProperty(); } }); }
        一个常见的方法是使用Java bean中的单个值来填充TreeTableColumn中的单元格。 为了支持这种常见的情况，有TreeItemPropertyValueFactory类。 有关如何使用该类的更多信息，请参阅此类，但简要说明如何使用TreeItemPropertyValueFactory类简化上述用例：
           firstNameCol.setCellValueFactory(new TreeItemPropertyValueFactory<Person,String>("firstName"));
        另请参见：
        getCellValueFactory() ， setCellValueFactory(Callback)

      • cellFactory

        public final ObjectProperty<Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>> cellFactoryProperty
        该列中所有单元格的单元格工厂。 单元工厂负责渲染单个TreeTableColumn中每个TreeTableCell中包含的数据。

        默认情况下，TreeTableColumn使用default cell factory ，但可以用自定义实现替换，例如以不同的方式显示数据或支持编辑。 有很多关于在其他地方创建自定义单元格工厂的文档（例如，见Cell和TreeTableView ）。

        最后， javafx.scene.control.cell包中有许多预建的电池厂 。

        另请参见：
        getCellFactory() ， setCellFactory(Callback)

      • sortType

        public final ObjectProperty<TreeTableColumn.SortType> sortTypeProperty
        用于说明此列是否为排序顺序的一部分（详见TreeTableView.getSortOrder() ），应按升序或降序进行排序。 只需切换此属性将导致TreeTableView中的排序顺序更改，假设此列位于sortOrder ObservableList中。
        另请参见：
        getSortType() ， setSortType(TreeTableColumn.SortType)

      • onEditStart

        public final ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditStartProperty
        当用户成功启动编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditStart() ， setOnEditStart(EventHandler)

      • onEditCommit

        public final ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditCommitProperty
        当用户成功提交编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditCommit() ， setOnEditCommit(EventHandler)

      • onEditCancel

        public final ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditCancelProperty
        当用户取消编辑单元格时，将触发此事件处理程序。
        另请参见：
        getOnEditCancel() ， setOnEditCancel(EventHandler)

    • 字段详细信息

      • DEFAULT_CELL_FACTORY

        public static final Callback<TreeTableColumn<?,?>,TreeTableCell<?,?>> DEFAULT_CELL_FACTORY
        如果在TreeTableColumn实例上未指定cellFactory，则默认情况下将使用该实例。 目前，如果item属于节点，它将简单地将TableCell项目属性提交到270702554144952属性中，或者如果它不为空，则调用toString() ，将生成的字符串设置在text属性中。

    • 构造方法详细信息

      • TreeTableColumn

        public TreeTableColumn​()
        使用默认单元格工厂，比较器和onEditCommit实现创建默认的TreeTableColumn。

      • TreeTableColumn

        public TreeTableColumn​(String text)
        创建一个TreeTableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。
        参数
        text - 当TreeTableColumn放置在TreeTableView中时显示的字符串。

    • 方法详细信息

      • editAnyEvent

        public static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> editAnyEvent​()
        任何TreeTableColumn编辑事件的父事件。
        参数类型
        S - TreeTableView泛型类型的类型
        T - 此TreeTableColumn中所有单元格中的内容类型
        结果
        编辑事件

      • editStartEvent

        public static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> editStartEvent​()
        表示用户执行了一些交互以启动编辑事件，或者 TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)方法已被调用。
        参数类型
        S - TreeTableView泛型类型的类型
        T - 此TreeTableColumn中所有单元格中的内容类型
        结果
        编辑开始事件

      • editCancelEvent

        public static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> editCancelEvent​()
        表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
        参数类型
        S - TreeTableView泛型类型的类型
        T - 此TreeTableColumn中所有单元格中的内容类型
        结果
        编辑取消事件

      • editCommitEvent

        public static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> editCommitEvent​()
        表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
        参数类型
        S - TreeTableView通用类型的类型
        T - 此TreeTableColumn中所有单元格中的内容类型
        结果
        编辑提交事件

      • treeTableViewProperty

        public final ReadOnlyObjectProperty<TreeTableView<S>> treeTableViewProperty​()
        TreeTableColumn属于的TreeTableView。
        另请参见：
        getTreeTableView()

      • getTreeTableView

        public final TreeTableView<S> getTreeTableView​()
        获取属性treeTableView的值。
        Property description:
        TreeTableColumn属于的TreeTableView。

      • setCellValueFactory

        public final void setCellValueFactory​(Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
        设置属性cellValueFactory的值。
        Property description:
        单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。 一个单元格值工厂是一个Callback ，它提供了一个TreeTableColumn.CellDataFeatures的实例，并期望返回一个ObservableValue 。 返回的ObservableValue实例将在内部进行观察，以允许更新值立即反映在屏幕上。

        如何设置单元格值工厂的一个例子是：

           firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the TreeItem<Person> instance for a particular TreeTableView row, // p.getValue().getValue() returns the Person instance inside the TreeItem<Person> return p.getValue().getValue().firstNameProperty(); } }); }
        一个常见的方法是使用Java bean中的单个值来填充TreeTableColumn中的单元格。 为了支持这种常见的情况，有TreeItemPropertyValueFactory类。 有关如何使用该类的更多信息，请参阅此类，但简要说明如何使用TreeItemPropertyValueFactory类简化上述用例：
           firstNameCol.setCellValueFactory(new TreeItemPropertyValueFactory<Person,String>("firstName"));

      • getCellValueFactory

        public final Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> getCellValueFactory​()
        获取属性cellValueFactory的值。
        Property description:
        单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。 一个单元格值工厂是一个Callback ，它提供了一个TreeTableColumn.CellDataFeatures实例，并期望返回一个ObservableValue 。 返回的ObservableValue实例将在内部进行观察，以允许更新值立即反映在屏幕上。

        如何设置单元格值工厂的一个例子是：

           firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the TreeItem<Person> instance for a particular TreeTableView row, // p.getValue().getValue() returns the Person instance inside the TreeItem<Person> return p.getValue().getValue().firstNameProperty(); } }); }
        一个常见的方法是使用Java bean中的单个值来填充TreeTableColumn中的单元格。 为了支持这种常见的情况，有TreeItemPropertyValueFactory类。 有关如何使用该类的更多信息，请参阅此类，但简要说明如何使用TreeItemPropertyValueFactory类简化上述用例：
           firstNameCol.setCellValueFactory(new TreeItemPropertyValueFactory<Person,String>("firstName"));

      • cellValueFactoryProperty

        public final ObjectProperty<Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> cellValueFactoryProperty​()
        单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。 一个单元格值工厂是一个Callback ，它提供了一个TreeTableColumn.CellDataFeatures的实例，并期望返回一个ObservableValue 。 返回的ObservableValue实例将在内部进行观察，以允许更新值立即反映在屏幕上。

        如何设置单元格值工厂的一个例子是：

           firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the TreeItem<Person> instance for a particular TreeTableView row, // p.getValue().getValue() returns the Person instance inside the TreeItem<Person> return p.getValue().getValue().firstNameProperty(); } }); }
        一个常见的方法是使用Java bean中的单个值来填充TreeTableColumn中的单元格。 为了支持这种常见的情况，有TreeItemPropertyValueFactory类。 有关如何使用该类的更多信息，请参阅此类，但简要说明如何使用TreeItemPropertyValueFactory类简化上述用例：
           firstNameCol.setCellValueFactory(new TreeItemPropertyValueFactory<Person,String>("firstName"));
        另请参见：
        getCellValueFactory() ， setCellValueFactory(Callback)

      • setCellFactory

        public final void setCellFactory​(Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> value)
        设置属性cellFactory的值。
        Property description:
        该列中所有单元格的单元格工厂。 单元工厂负责渲染单个TreeTableColumn中每个TreeTableCell中包含的数据。

        默认情况下，TreeTableColumn使用default cell factory ，但是可以用自定义实现替换，例如以不同的方式显示数据或支持编辑。 有很多关于在其他地方创建自定义单元格工厂的文档（例如，参见Cell和TreeTableView ）。

        最后， javafx.scene.control.cell包中有许多预建的电池厂可用。

      • getCellFactory

        public final Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> getCellFactory​()
        获取属性cellFactory的值。
        Property description:
        该列中所有单元格的单元格工厂。 单元工厂负责渲染单个TreeTableColumn中每个TreeTableCell中包含的数据。

        默认情况下，TreeTableColumn使用default cell factory ，但是可以用自定义实现替换，例如以不同的方式显示数据或支持编辑。 有很多关于在其他地方创建自定义单元格工厂的文档（例如，参见Cell和TreeTableView ）。

        最后， javafx.scene.control.cell包中有许多预建的电池厂可用。

      • cellFactoryProperty

        public final ObjectProperty<Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>> cellFactoryProperty​()
        该列中所有单元格的单元格工厂。 单元工厂负责渲染单个TreeTableColumn中每个TreeTableCell中包含的数据。

        默认情况下，TreeTableColumn使用default cell factory ，但可以用自定义实现替换，例如以不同的方式显示数据或支持编辑。 有很多关于在其他地方创建自定义单元格工厂的文档（例如，见Cell和TreeTableView ）。

        最后， javafx.scene.control.cell包中有一些预先建成的电池厂 。

        另请参见：
        getCellFactory() ， setCellFactory(Callback)

      • sortTypeProperty

        public final ObjectProperty<TreeTableColumn.SortType> sortTypeProperty​()
        用于说明此列是否为排序顺序的一部分（详见TreeTableView.getSortOrder() ），应按升序或降序排列。 只需切换此属性将导致TreeTableView中的排序顺序更改，假设此列位于sortOrder ObservableList中。
        另请参见：
        getSortType() ， setSortType(TreeTableColumn.SortType)

      • setSortType

        public final void setSortType​(TreeTableColumn.SortType value)
        设置属性sortType的值。
        Property description:
        用于说明此列是否为排序顺序的一部分（详见TreeTableView.getSortOrder() ），应按升序或降序排序。 只需切换此属性将导致TreeTableView中的排序顺序更改，假设此列位于sortOrder ObservableList中。

      • getSortType

        public final TreeTableColumn.SortType getSortType​()
        获取属性sortType的值。
        Property description:
        用于说明此列是否为排序顺序的一部分（详见TreeTableView.getSortOrder() ），应按升序或降序进行排序。 只需切换此属性将导致TreeTableView中的排序顺序更改，假设此列位于sortOrder ObservableList中。

      • setOnEditStart

        public final void setOnEditStart​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
        设置属性onEditStart的值。
        Property description:
        当用户成功启动编辑时，会触发此事件处理程序。

      • getOnEditStart

        public final EventHandler<TreeTableColumn.CellEditEvent<S,T>> getOnEditStart​()
        获取onEditStart上的属性的值。
        Property description:
        当用户成功启动编辑时，会触发此事件处理程序。

      • onEditStartProperty

        public final ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditStartProperty​()
        当用户成功启动编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditStart() ， setOnEditStart(EventHandler)

      • setOnEditCommit

        public final void setOnEditCommit​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
        设置属性onEditCommit的值。
        Property description:
        当用户成功提交编辑时，会触发此事件处理程序。

      • getOnEditCommit

        public final EventHandler<TreeTableColumn.CellEditEvent<S,T>> getOnEditCommit​()
        获取属性onEditCommit的值。
        Property description:
        当用户成功提交编辑时，会触发此事件处理程序。

      • onEditCommitProperty

        public final ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditCommitProperty​()
        当用户成功提交编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditCommit() ， setOnEditCommit(EventHandler)

      • setOnEditCancel

        public final void setOnEditCancel​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
        设置属性onEditCancel的值。
        Property description:
        当用户取消编辑单元格时，将触发此事件处理程序。

      • getOnEditCancel

        public final EventHandler<TreeTableColumn.CellEditEvent<S,T>> getOnEditCancel​()
        获取属性onEditCancel的值。
        Property description:
        当用户取消编辑单元格时，将触发此事件处理程序。

      • onEditCancelProperty

        public final ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> onEditCancelProperty​()
        当用户取消编辑单元格时，将触发此事件处理程序。
        另请参见：
        getOnEditCancel() ， setOnEditCancel(EventHandler)

      • getColumns

        public final ObservableList<TreeTableColumn<S,?>> getColumns​()
        这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。 例如，我们可能有一个“名称”列，其中包含“First”和“Last”名称的两个嵌套列。

        这对于这样没有影响 - 所有列索引仅指向叶子列，并且不可能使用父列进行排序，只能使用叶列。 换句话说，这纯粹是一个视觉特征。

        Specified by:
        getColumns在 TableColumnBase<TreeItem<S>,T>
        结果
        一个包含TableColumnBase实例（或子类）的ObservableList，它是此TableColumnBase的子项。 如果这些孩子的TableColumnBase实例设置为可见，它们将显示在此表列下方。

      • getCellObservableValue

        public final ObservableValue<T> getCellObservableValue​(int index)
        尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。 换句话说，该方法期望接收大于或等于零且小于底层数据模型大小的整数值。 如果索引有效，此方法将返回此特定列的ObservableValue <T>。

        这可以通过调用cell value factory来实现，并返回传递CellDataFeatures任何返回CellDataFeatures （例如，参见例如，属于TableColumn的CellDataFeatures类以及TreeTableColumn的更多信息）。

        Specified by:
        getCellObservableValue在 TableColumnBase<TreeItem<S>,T>
        参数
        index - 寻找ObservableValue <T>的项目（S型）的索引。
        结果
        此特定表列的ObservableValue <T>。

      • getCellObservableValue

        public final ObservableValue<T> getCellObservableValue​(TreeItem<S> item)
        尝试返回给定项目（其类型为S）的ObservableValue <T>。 换句话说，该方法期望从表中的整个“行”的底层数据模型接收一个对象，并且必须返回该特定列中的值的ObservableValue <T>。

        这可以通过调用cell value factory来实现，并返回任何通过CellDataFeatures返回的CellDataFeatures （例如，参见例如，属于TableColumn的CellDataFeatures类和TreeTableColumn的更多信息）。

        Specified by:
        getCellObservableValue在 TableColumnBase<TreeItem<S>,T>
        参数
        item - 寻求ObservableValue <T>的项目（S型）。
        结果
        此特定表列的ObservableValue <T>。

      • getTypeSelector

        public String getTypeSelector​()
        这种Styleable的类型用于选择器匹配。 这类似于HTML中的“元素”。 （ CSS Type Selector ）。
        Specified by:
        getTypeSelector在接口 Styleable
        结果
        “TreeTableColumn”

      • getStyleableParent

        public Styleable getStyleableParent​()
        返回此Styleable的父项，如果没有父项则返回null。
        Specified by:
        getStyleableParent接口 Styleable
        结果
        getTreeTableView()

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        这个样式的CssMetaData。 这可以作为不可修改的列表返回。
        Specified by:
        getCssMetaData在接口 Styleable
        结果
        CssMetaData

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()

      • getStyleableNode

        public Node getStyleableNode​()
        返回表示此Styleable对象的Node。 在Styleable本身不是Node的情况下，应该覆盖此方法，以便它可以可选地返回其本身的相关根节点表示。 默认情况下，此方法返回null，这可能意味着Styleable本身是一个Node，如果不是这种情况，则Styleable在请求时没有可用的节点表示。
        Specified by:
        getStyleableNode在接口 Styleable
        结果
        表示此Styleable对象的节点
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TreeTableColumn.CellDataFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableColumn.CellDataFeatures<S,T>

  • java.lang.Object
    • javafx.scene.control.TreeTableColumn.CellDataFeatures<S,T>
  • 参数类型
    S - TableView类型
    T - TreeTableColumn类型
    Enclosing class:
    TreeTableColumn < S ， T >

    public static class TreeTableColumn.CellDataFeatures<S,T>
extends Object
    在TreeTableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。 一旦实例化，这个类是不可变的。
    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      CellDataFeatures​(TreeTableView<S> treeTableView, TreeTableColumn<S,T> tableColumn, TreeItem<S> value)
      实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TreeTableColumn<S,T> getTreeTableColumn​()
      返回传递给构造函数的TreeTableColumn 。
      TreeTableView<S> getTreeTableView​()
      返回传递给构造函数的TableView 。
      TreeItem<S> getValue​()
      返回传递给构造函数的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CellDataFeatures

        public CellDataFeatures​(TreeTableView<S> treeTableView,
                        TreeTableColumn<S,T> tableColumn,
                        TreeItem<S> value)
        实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。
        参数
        treeTableView - 此实例引用的TableView。
        tableColumn - 此实例引用的TreeTableColumn。
        value - TableView中的一行的值。

    • 方法详细信息

      • getValue

        public TreeItem<S> getValue​()
        返回传递给构造函数的值。
        结果
        该值传递给构造函数

      • getTreeTableColumn

        public TreeTableColumn<S,T> getTreeTableColumn​()
        返回传递给构造函数的TreeTableColumn 。
        结果
        TreeTableColumn传递给构造函数

      • getTreeTableView

        public TreeTableView<S> getTreeTableView​()
        返回传递给构造函数的TableView 。
        结果
        the TableView passed in to the constructor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeTableColumn.CellEditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableColumn.CellEditEvent<S,T>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.TreeTableColumn.CellEditEvent<S,T>
  • All Implemented Interfaces:
    Serializable ， Cloneable
    Enclosing class:
    TreeTableColumn < S ， T >

    public static class TreeTableColumn.CellEditEvent<S,T>
extends Event
    用户在表单元格上执行编辑时触发的事件。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<?> ANY
      所有单元格编辑事件类型的公共超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      CellEditEvent​(TreeTableView<S> table, TreeTablePosition<S,T> pos, EventType<TreeTableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T getNewValue​()
      返回最终用户输入的新值。
      T getOldValue​()
      尝试在 getTreeTablePosition()返回的 TablePosition中提到的位置返回旧值。
      TreeItem<S> getRowValue​()
      为getTreeTablePosition()中返回的TablePosition中包含的行返回行的值（即TableView items列表）的便利方法。
      TreeTableColumn<S,T> getTableColumn​()
      返回发生此事件的TreeTableColumn。
      TreeTablePosition<S,T> getTreeTablePosition​()
      返回此事件发生的位置。
      TreeTableView<S> getTreeTableView​()
      返回发生此事件的TableView。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<?> ANY
        所有单元格编辑事件类型的公共超类型。

    • 构造方法详细信息

      • CellEditEvent

        public CellEditEvent​(TreeTableView<S> table,
                     TreeTablePosition<S,T> pos,
                     EventType<TreeTableColumn.CellEditEvent<S,T>> eventType,
                     T newValue)
        创建一个可以随后向相关听众触发的新事件。
        参数
        table - 发生此事件的TableView。
        pos - 发生此事件的位置。
        eventType - 发生的事件类型。
        newValue - 最终用户输入的值。

    • 方法详细信息

      • getTreeTableView

        public TreeTableView<S> getTreeTableView​()
        返回发生此事件的TableView。
        结果
        发生此事件的TableView控件。

      • getTableColumn

        public TreeTableColumn<S,T> getTableColumn​()
        返回发生此事件的TreeTableColumn。
        结果
        编辑发生的TreeTableColumn。

      • getTreeTablePosition

        public TreeTablePosition<S,T> getTreeTablePosition​()
        返回此事件发生的位置。
        结果
        该事件发生的位置。

      • getNewValue

        public T getNewValue​()
        返回最终用户输入的新值。 这不是返回到TableView.items列表的值 - 这个新值仅代表单个单元格的输入，因此它可能需要返回到TableView.items列表中的一个项目中的属性。
        结果
        表示用户输入的新值的对象。

      • getOldValue

        public T getOldValue​()
        尝试在getTreeTablePosition()返回的TablePosition中提到的位置返回旧值。 这可能会返回null，原因有很多。
        结果
        返回正在编辑的位置中存储的值，如果无法检索，则返回null。

      • getRowValue

        public TreeItem<S> getRowValue​()
        为getTreeTablePosition()中返回的TablePosition中包含的行返回行的值（即TableView items列表）的便捷方法。
        结果
        the row value
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TreeTableColumn.SortType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Enum TreeTableColumn.SortType

  • java.lang.Object
    • java.lang.Enum<TreeTableColumn.SortType>
      • javafx.scene.control.TreeTableColumn.SortType
  • All Implemented Interfaces:
    Serializable ， Comparable<TreeTableColumn.SortType>
    Enclosing class:
    TreeTableColumn < S ， T >

    public static enum TreeTableColumn.SortType
extends Enum<TreeTableColumn.SortType>
    枚举，指定应用于特定列的排序类型。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ASCENDING
      列将按升序排序。
      DESCENDING
      列将按降序排序。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TreeTableColumn.SortType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TreeTableColumn.SortType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ASCENDING

        public static final TreeTableColumn.SortType ASCENDING
        列将按升序排序。

      • DESCENDING

        public static final TreeTableColumn.SortType DESCENDING
        列将按降序排序。

    • 方法详细信息

      • values

        public static TreeTableColumn.SortType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TreeTableColumn.SortType c : TreeTableColumn.SortType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TreeTableColumn.SortType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TreeTablePosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTablePosition<S,T>

  • java.lang.Object
    • javafx.scene.control.TablePositionBase<TreeTableColumn<S,T>>
      • javafx.scene.control.TreeTablePosition<S,T>
  • 参数类型
    S - TreeTableView中包含的TreeItem实例的类型。
    T - TreeTableColumn中包含的项目的类型。

    public class TreeTablePosition<S,T>
extends TablePositionBase<TreeTableColumn<S,T>>
    此类用于在TreeTableView中表示单个行/列/单元格。 这在TreeTableView API中用于表示当前选择，聚焦，正在编辑的行/列/单元格。请注意，此类在创建后是不可变的。

    因为TreeTableView可以具有不同的selection modes ，所以TablePosition中的行和列属性可以被禁用来表示整个行或列。 这是通过将unrequired属性设置为-1或null来完成的。

    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TreeTableView ， TreeTableColumn

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTablePosition​(TreeTableView<S> treeTableView, int row, TreeTableColumn<S,T> tableColumn)
      构造一个TreeTablePosition实例来表示给定TreeTableView实例中给定的行/列位置。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getColumn​()
      TreeTablePosition在TreeTableView中表示的列索引。
      TreeTableColumn<S,T> getTableColumn​()
      Table Table在TableView中表示的TableColumn。
      TreeItem<S> getTreeItem​()
      返回TreeItem那背上TablePositionBase.getRow()行}。
      TreeTableView<S> getTreeTableView​()
      TreeTablePosition与此TreeTablePosition相关。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.TablePositionBase

        equals, getRow, hashCode

    • 构造方法详细信息

      • TreeTablePosition

        public TreeTablePosition​(TreeTableView<S> treeTableView,
                         int row,
                         TreeTableColumn<S,T> tableColumn)
        构造一个TreeTablePosition实例来表示给定TreeTableView实例中给定的行/列位置。 在这个类中，TreeTableView和TreeTableColumn都被弱引用，所以当调用它们各自的getter时，它们可能是null。
        参数
        treeTableView - 与此相关的TreeTableView。
        row - 此TreeTablePosition表示的行。
        tableColumn - TreeTablePosition表示的TreeTableColumn实例。

    • 方法详细信息

      • getColumn

        public int getColumn​()
        TreeTablePosition在TreeTableView中表示的列索引。 如果TreeTableView或TreeTableColumn实例在类被实例化时为空（即在构造时计算），则为-1。
        Specified by:
        getColumn在 TablePositionBase<TreeTableColumn<S,T>>
        结果
        该TablePosition在TableView中表示的列索引

      • getTreeTableView

        public final TreeTableView<S> getTreeTableView​()
        TreeTablePosition与此TreeTablePosition相关。
        结果
        TreeTablePosition与此TreeTablePosition相关联

      • getTableColumn

        public final TreeTableColumn<S,T> getTableColumn​()
        描述从类别复制TablePositionBase
        Table Table在TableView中表示的TableColumn。
        重写：
        getTableColumn在 TablePositionBase<TreeTableColumn<S,T>>
        结果
        Table Table在TableView中表示的TableColumn

      • getTreeItem

        public final TreeItem<S> getTreeItem​()
        返回TreeItem那背上TablePositionBase.getRow()行}。
        结果
        the TreeItem that backs the TablePositionBase.getRow() row}
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeTableRow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableRow<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeTableRow<T>
  • 参数类型
    T - 单元格中包含的项目的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class TreeTableRow<T>
extends IndexedCell<T>

    TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。 TreeTableRow在开发人员完全可能遇到的唯一时间是，如果他们希望创建一个自定义的rowFactory来替代TreeTableView的整个行。

    通常情况下，开发人员更容易定制行中的单个单元格，而不是整行。 为此，您可以在每个TreeTableColumn实例上指定一个自定义的cellFactory 。

    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TreeTableView ， TreeTableColumn ， TreeTableCell ， IndexedCell ， Cell

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Node> disclosureNode
      公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
      ReadOnlyObjectProperty<TreeItem<T>> treeItem
      每个TreeTableCell最多代表一个TreeItem ，由该属性表示。
      ReadOnlyObjectProperty<TreeTableView<T>> treeTableView
      TreeTableCell显式链接到一个TreeTableView实例，由该属性表示。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTableRow​()
      创建一个默认的TreeTableRow实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      void commitEdit​(T newValue)
      在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      ObjectProperty<Node> disclosureNodeProperty​()
      公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
      void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      Node getDisclosureNode​()
      返回此TreeTableCell中设置的当前披露节点。
      TreeItem<T> getTreeItem​()
      返回当前在此TreeTableRow中设置的TreeItem。
      TreeTableView<T> getTreeTableView​()
      返回与此TreeTableCell关联的TreeTableView。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setDisclosureNode​(Node value)
      用作“披露”三角形的节点，或用于展开和折叠项目的切换。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      ReadOnlyObjectProperty<TreeItem<T>> treeItemProperty​()
      每个TreeTableCell最多代表一个TreeItem ，由该属性表示。
      ReadOnlyObjectProperty<TreeTableView<T>> treeTableViewProperty​()
      TreeTableCell显式链接到一个TreeTableView实例，由该属性表示。
      void updateTreeItem​(TreeItem<T> treeItem)
      更新与此TreeTableCell关联的TreeItem。
      void updateTreeTableView​(TreeTableView<T> treeTable)
      更新与此TreeTableCell关联的TreeTableView。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • treeItem

        public final ReadOnlyObjectProperty<TreeItem<T>> treeItemProperty
        每个TreeTableCell最多代表一个TreeItem ，由该属性表示。
        结果
        树项属性

      • disclosureNode

        public final ObjectProperty<Node> disclosureNodeProperty
        公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
        另请参见：
        getDisclosureNode() ， setDisclosureNode(Node)

      • treeTableView

        public final ReadOnlyObjectProperty<TreeTableView<T>> treeTableViewProperty
        TreeTableCell显式链接到一个TreeTableView实例，由该属性表示。
        另请参见：
        getTreeTableView()

    • 构造方法详细信息

      • TreeTableRow

        public TreeTableRow​()
        创建一个默认的TreeTableRow实例。

    • 方法详细信息

      • getTreeItem

        public final TreeItem<T> getTreeItem​()
        返回当前在此TreeTableRow中设置的TreeItem。
        结果
        当前TreeTableRow中设置了TreeItem

      • treeItemProperty

        public final ReadOnlyObjectProperty<TreeItem<T>> treeItemProperty​()
        每个TreeTableCell最多代表一个TreeItem ，由该属性表示。
        结果
        树项属性

      • setDisclosureNode

        public final void setDisclosureNode​(Node value)
        用作“披露”三角形的节点，或用于展开和折叠项目的切换。 这仅在包含子项目的树中的项目的情况下使用。 如果没有指定，TreeTableCell的Skin实现负责提供默认的公开节点。
        参数
        value - 披露节点

      • getDisclosureNode

        public final Node getDisclosureNode​()
        返回此TreeTableCell中设置的当前披露节点。
        结果
        披露节点

      • disclosureNodeProperty

        public final ObjectProperty<Node> disclosureNodeProperty​()
        公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
        另请参见：
        getDisclosureNode() ， setDisclosureNode(Node)

      • getTreeTableView

        public final TreeTableView<T> getTreeTableView​()
        返回与此TreeTableCell关联的TreeTableView。
        结果
        树表视图

      • treeTableViewProperty

        public final ReadOnlyObjectProperty<TreeTableView<T>> treeTableViewProperty​()
        TreeTableCell显式链接到一个TreeTableView实例，由该属性表示。
        另请参见：
        getTreeTableView()

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 Cell<T>

      • commitEdit

        public void commitEdit​(T newValue)
        在适当的时候调用此功能（基于您的单元格编辑用户界面的用户交互要求）来做两件事情：
        1. 将适当的事件触发回到支持UI控件（例如ListView ）。 这将开始将此编辑推回相关数据源/属性（尽管不能保证这将成功 - 这取决于正在使用的特定编辑提交处理程序）。 有关更多详细信息，请参阅UI控件类javadoc。
        2. 开始从编辑状态转换到非编辑状态。

        一般来说，在自定义单元实现中无需重写此方法 - 在适当的时候简单地调用此方法就足够了（例如，当用户按Enter键时，可以执行像cell.commitEdit(converter.fromString(textField.getText()));

        重写：
        commitEdit在 Cell<T>
        参数
        newValue - 作为最终用户输入的值，应该以相关的方式持续提供支持用户界面的数据源和UI控件的安装编辑提交处理程序。

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 Cell<T>

      • updateTreeTableView

        public final void updateTreeTableView​(TreeTableView<T> treeTable)
        更新与此TreeTableCell关联的TreeTableView。
        参数
        treeTable - 应该与此TreeTableCell相关联的新TreeTableView。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。

      • updateTreeItem

        public final void updateTreeItem​(TreeItem<T> treeItem)
        更新与此TreeTableCell关联的TreeItem。
        参数
        treeItem - 应该与此TreeTableCell相关联的新TreeItem。 注意：此功能主要由专家使用，主要由实施新皮肤的人员使用。 开发人员或设计师直接访问此功能并不常见。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤，或者在具有setSkin(...)的子类中显式设置，则调用它来创建控件的皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • executeAccessibleAction

        public void executeAccessibleAction​(AccessibleAction action,
                                    Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 Control
        参数
        action - 执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeTableView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableView<S>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.TreeTableView<S>
  • 参数类型
    S - 此TreeTableView中使用的TreeItem实例的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("root")
public class TreeTableView<S>
extends Control
    TreeTableView控件旨在可视化无限数量的数据行，分为列。 TreeTableView控件在概念上非常类似于TreeView和TableView控件，当您阅读时，您将看到API大致相同。 然而，给予了很高层次的概述，你会注意到，TreeTableView使用相同TreeItem API为TreeView ，而你因此需要简单地设置root node在TreeTableView。 类似地，TreeTableView控件使用与TableView控件使用的相同的基于TableColumn的方法，除了使用特定于TableView的TableColumn类别之外，您应该改用特定于TreeTableView的TreeTableColumn类。 有关如何创建TreeTableView实例的示例，请参阅下面的“创建TreeTableView”控件部分。

    与TableView控件一样，TreeTableView控件具有许多功能，包括：

    • 强大的TreeTableColumn API：
      • 支持cell factories在渲染和编辑状态下轻松自定义cell内容。
      • 的说明书二百七万七千零二十九亿八千三百六十九万七千二百九十九 / 二百七十万七千零二十九亿八千三百七十一万三千八百七十九 / 二七零七零二九八三七二八八八零 ，并且还fixed width columns 。
      • 用户在运行时调整宽度。
      • 用户在运行时重新排序列。
      • 内置支持column nesting
    • 不同的resizing policies来指定当用户调整列的大小时会发生什么。
    • 通过点击列标题来支持multiple column sorting （按住Shift键盘键，同时点击标题按多个列排序）。

    创建一个TreeTableView

    创建TreeTableView是一个多步骤的过程，也取决于需要表示的底层数据模型。 对于这个例子，我们将使用TreeTableView来可视化文件系统，因此将使用如下定义的虚构（和非常简化的）File类：

       public class File { private StringProperty name; public void setName(String value) { nameProperty().set(value); } public String getName() { return nameProperty().get(); } public StringProperty nameProperty() { if (name == null) name = new SimpleStringProperty(this, "name"); return name; } private LongProperty lastModified; public void setLastModified(long value) { lastModifiedProperty().set(value); } public long getLastModified() { return lastModifiedProperty().get(); } public LongProperty lastModifiedProperty() { if (lastModified == null) lastModified = new SimpleLongProperty(this, "lastModified"); return lastModified; } }

    首先，需要定义一个TreeTableView实例：

       TreeTableView<File> treeTable = new TreeTableView<>();

    随着基本的TreeTableView实例化，我们接下来关注数据模型。 如上所述，对于这个例子，我们将使用File实例来表示一个文件系统。 为此，我们需要定义树表的根节点，如下所示：

       TreeItem<File> root = new TreeItem<>(new File("/")); treeTable.setRoot(root);

    随着根目录的设置，TreeTableView会在根目录的children发生变化时自动更新。

    在这一点上，我们现在有一个TreeTableView挂接来观察根TreeItem实例。 缺失的成分现在是分解模型中包含的数据并在一个或多个TreeTableColumn实例中表示的方法。 要创建一个两列的TreeTableView来显示文件名和最后修改的属性，我们扩展如上所示的代码如下：

       TreeTableColumns<File,String> fileNameCol = new TreeTableColumn<>("Filename"); TreeTableColumns<File,Long> lastModifiedCol = new TreeTableColumn<>("Size"); table.getColumns().setAll(fileNameCol, lastModifiedCol);

    使用上面的代码，我们几乎完全定义了创建TreeTableView实例所需的最小属性。 唯一缺少的是27072983966129的两列 - 这是负责确定给定行中单元格的值的这些。 通常这些可以使用TreeItemPropertyValueFactory类来指定，但是您也可以创建一个匿名的内部类并执行必要的任务。 例如，使用TreeItemPropertyValueFactory，您将执行以下操作：

       fileNameCol.setCellValueFactory(new TreeItemPropertyValueFactory("name")); lastModifiedCol.setCellValueFactory(new TreeItemPropertyValueFactory("lastModified"));
    运行此代码（假设文件系统结构可能内置在内存中）会导致一个TreeTableView被显示为两个名称和lastModified列。 File类的任何其他属性将不会显示，因为没有为它们定义TreeTableColumns。

    TreeTableView支持不包含属性的类

    以上显示的代码是在域对象设计时考虑到JavaFX属性时创建TreeTableView的最短代码（另外， TreeItemPropertyValueFactory也支持普通的JavaBean属性，尽管有一个警告，因此请参阅类文档以获取更多信息信息）。 当不是这种情况时，需要提供一个自定义单元格值工厂。 有关单元格值工厂的更多信息，请参见TreeTableColumn API文档，但简要说明如何指定TreeTableColumns：

       firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the TreeItem<Person> instance for a particular TreeTableView row, // p.getValue().getValue() returns the Person instance inside the TreeItem<Person> return p.getValue().getValue().firstNameProperty(); } }); }

    TreeTableView Selection / Focus API

    要跟踪选择和重点，有必要熟悉SelectionModel和FocusModel类。 TreeTableView最多有一个这些类的一个实例，分别可从selectionModel和focusModel属性获得。 虽然可以使用此API来设置新的选择模型，但在大多数情况下，这不是必需的 - 默认选择和焦点模型应该在大多数情况下工作。

    在实例化TreeTableView时使用的默认值为SelectionModel是MultipleSelectionModel抽象类的实现。 但是，如selectionMode属性的API文档中所述，默认值为SelectionMode.SINGLE 。 要在默认TreeTableView实例中启用多选，因此需要执行以下操作：

       treeTableView.getSelectionModel().setSelectionMode(SelectionMode.MULTIPLE);

    自定义TreeTableView视觉

    TreeTableView的视觉效果可以通过替换默认的row factory完全自定义。 一行工厂用于生成TreeTableRow个实例，用于表示TreeTableView中的整个行。

    在许多情况下，这不是所期望的，因为更常见的情况是，单元格是以每列为单位进行定制的，而不是每行。 因此，重要的是要注意， TreeTableRow不是TreeTableCell 。 A TreeTableRow只是一个零或多个TreeTableCell的容器，在大多数情况下，您更有可能要创建自定义TreeTableCells而不是TreeTableRows。 创建自定义TreeTableRow实例的主要用例很可能是引入某种形式的列跨越支持。

    您可以通过将适当的函数分配给TreeTableColumns cell factory属性来创建自定义的TreeTableCell实例。

    有关如何编写自定义单元格的更完整的说明，请参阅Cell类文档。

    编辑

    此控件支持值的内联编辑，本节尝试概述可用的API以及如何使用它们。

    首先，细胞编辑通常需要不同于不编辑细胞的用户界面。 这是正在使用的Cell实现的责任。 对于TreeTableView，强烈建议编辑为per-TreeTableColumn而不是per row ，因为您希望用户不希望用不同的方式编辑每个列值，并且此方法允许对每列进行编辑。 您可以选择单元格是否永久处于编辑状态（例如，这对于CheckBox单元格是常见的），或者在编辑开始时切换到不同的UI（例如，当单元格上接收到双击时）。

    要知道在单元格上请求编辑时，只需覆盖Cell.startEdit()方法，并根据需要更新单元格text和graphic属性（例如，将文本设置为空，并将图形设置为TextField ）。 此外，您还应该覆盖Cell.cancelEdit()，以便在编辑结束时将UI重置为原始的可视状态。 在这两种情况下，重要的是您还要确保您调用超级方法以使单元格执行所有必须执行的任务，以进入或退出其编辑模式。

    一旦您的单元格处于编辑状态，您最感兴趣的下一件事就是如何提交或取消正在进行的编辑。 这是您作为电池厂商的责任。 您的单元实现将基于用户输入（例如当用户按下键盘上的Enter键或ESC键时）知道编辑结束。 发生这种情况时，您有责任酌情致电Cell.commitEdit(Object)或Cell.cancelEdit() 。

    当您拨打Cell.commitEdit(Object)一个事件触发到TreeTableView，您可以通过TreeTableColumn.setOnEditCommit(javafx.event.EventHandler)添加一个EventHandler观察。 同样，您还可以观察edit start和edit cancel的编辑事件。

    默认情况下，TreeTableColumn编辑提交处理程序不为空，并且使用默认处理程序尝试覆盖当前正在编辑的行中的项目的属性值。 它可以这样做，因为Cell.commitEdit(Object)方法被传递到新的值，并且这被传递到编辑提交处理程序通过CellEditEvent被触发。 只需调用TreeTableColumn.CellEditEvent.getNewValue()即可检索该值。

    需要注意的是，如果你把它是非常重要的TreeTableColumn.setOnEditCommit(javafx.event.EventHandler)用自己EventHandler ，那么你会删除默认的处理程序。 除非您再处理该属性（或相关数据源）的回写，否则不会发生任何事情。 您可以使用TableColumnBase.addEventHandler(javafx.event.EventType, javafx.event.EventHandler)方法添加一个270702984729222 EventType与您所需的EventHandler作为第二个参数。 使用此方法，您将不会替换默认实现，但在发生编辑提交时会收到通知。

    希望这个总结回答了一些常见问题。 幸运的是，JavaFX附带了许多预先构建的单元格工厂，可以代表您处理所有的编辑要求。 您可以在javafx.scene.control.cell包中找到这些预构建的单元工厂。

    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TreeTableColumn ， TreeTablePosition

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Callback<TreeTableView.ResizeFeatures,Boolean>> columnResizePolicy
      这是当用户完成列大小调整操作时调用的函数。
      ReadOnlyObjectProperty<Comparator<TreeItem<S>>> comparator
      比较属性是一个只读属性，代表 sort order列表的当前状态。
      BooleanProperty editable
      指定此TreeTableView是否可编辑 - 只有当TreeTableView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
      ReadOnlyObjectProperty<TreeTablePosition<S,?>> editingCell
      表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
      ReadOnlyIntegerProperty expandedItemCount
      表示当前能够在TreeTableView中可见的树节点数。
      DoubleProperty fixedCellSize
      指定此控件是否具有固定高度（指定值）的单元格。
      ObjectProperty<TreeTableView.TreeTableViewFocusModel<S>> focusModel
      FocusModel提供API，通过它可以将焦点控制在零或一行TreeTableView上。
      ObjectProperty<EventHandler<ScrollToEvent<TreeTableColumn<S,?>>>> onScrollToColumn
      当有要求使用 scrollToColumn(TreeTableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollTo
      当有请求使用 scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<SortEvent<TreeTableView<S>>>> onSort
      当有请求排序控件时调用。
      ObjectProperty<Node> placeholder
      当表没有显示的内容时，向用户显示该节点。
      ObjectProperty<TreeItem<S>> root
      表示TreeTableView根节点的属性。
      ObjectProperty<Callback<TreeTableView<S>,TreeTableRow<S>>> rowFactory
      一个生成TreeTableRow的函数。
      ObjectProperty<TreeTableView.TreeTableViewSelectionModel<S>> selectionModel
      SelectionModel提供了可以在TreeTableView中选择单个或多个项目的API，以及检查用户选择了哪些行。
      BooleanProperty showRoot
      表示TreeTableView根节点是否可见的属性。
      ObjectProperty<TreeSortMode> sortMode
      指定在排序此TreeTableView的内容时使用的排序模式，如果在 sort order列表中指定任何列。
      ObjectProperty<Callback<TreeTableView<S>,Boolean>> sortPolicy
      排序策略指定如何执行此TreeTableView中的排序。
      BooleanProperty tableMenuButtonVisible
      当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TreeTableColumn的无线菜单项。
      ObjectProperty<TreeTableColumn<S,?>> treeColumn
      表示哪个列应该在其中显示披露节点的属性（即带有箭头的列）。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TreeTableView.EditEvent<S>
      一个Event在TreeTableView中专门用于表示编辑相关事件的子类。
      static class  TreeTableView.ResizeFeatures<S>
      一个用于TableView column resize功能的不可变包装类。
      static class  TreeTableView.TreeTableViewFocusModel<S>
      A FocusModel具有附加功能以支持TableView控件的要求。
      static class  TreeTableView.TreeTableViewSelectionModel<S>
      SelectionModel抽象类的简单扩展，允许对TreeTableView控件的特殊支持。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Callback<TreeTableView.ResizeFeatures,Boolean> CONSTRAINED_RESIZE_POLICY
      确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。
      static Callback<TreeTableView,Boolean> DEFAULT_SORT_POLICY
      如果没有指定其他策略，则该TreeTableView将使用默认值 sort policy 。
      static Callback<TreeTableView.ResizeFeatures,Boolean> UNCONSTRAINED_RESIZE_POLICY
      非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTableView​()
      创建一个空TreeTableView。
      TreeTableView​(TreeItem<S> root)
      使用提供的根节点创建TreeTableView。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Callback<TreeTableView.ResizeFeatures,Boolean>> columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      ReadOnlyObjectProperty<Comparator<TreeItem<S>>> comparatorProperty​()
      比较器属性是一个只读属性，代表 sort order列表的当前状态。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void edit​(int row, TreeTableColumn<S,?> column)
      导致给定行/列视图索引处的单元格切换到其编辑状态（如果尚未存在），并且假设TableView和列也是可编辑的。
      BooleanProperty editableProperty​()
      指定此TreeTableView是否可编辑 - 只有当TreeTableView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
      static <S> EventType<TreeTableView.EditEvent<S>> editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <S> EventType<TreeTableView.EditEvent<S>> editCancelEvent​()
      EventType用于指示事件被触发的TreeTableView中刚刚取消了编辑事件。
      static <S> EventType<TreeTableView.EditEvent<S>> editCommitEvent​()
      用于指示TreeTableView中的编辑已提交的EventType。
      ReadOnlyObjectProperty<TreeTablePosition<S,?>> editingCellProperty​()
      表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
      static <S> EventType<TreeTableView.EditEvent<S>> editStartEvent​()
      EventType用于指示在触发事件的TreeTableView中启动了编辑事件。
      ReadOnlyIntegerProperty expandedItemCountProperty​()
      表示当前能够在TreeTableView中可见的树节点数。
      DoubleProperty fixedCellSizeProperty​()
      指定此控件是否具有固定高度（指定值）的单元格。
      ObjectProperty<TreeTableView.TreeTableViewFocusModel<S>> focusModelProperty​()
      FocusModel提供API，通过它可以将焦点控制在零或一行TreeTableView上。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Callback<TreeTableView.ResizeFeatures,Boolean> getColumnResizePolicy​()
      获取属性columnResizePolicy的值。
      ObservableList<TreeTableColumn<S,?>> getColumns​()
      作为TableView的一部分的TreeTableColumns。
      Comparator<TreeItem<S>> getComparator​()
      获取属性比较器的值。
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      TreeTablePosition<S,?> getEditingCell​()
      获取属性editingCell的值。
      int getExpandedItemCount​()
      获取属性expandedItemCount的值。
      double getFixedCellSize​()
      返回固定的单元格大小值。
      TreeTableView.TreeTableViewFocusModel<S> getFocusModel​()
      返回当前安装的FocusModel 。
      static int getNodeLevel​(TreeItem<?> node)
      已过时。
      此方法无法正确计算从给定TreeItem到TreeTableView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过getTreeItemLevel(TreeItem)
      EventHandler<ScrollToEvent<Integer>> getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> getOnScrollToColumn​()
      获取属性onScrollToColumn的值。
      EventHandler<SortEvent<TreeTableView<S>>> getOnSort​()
      获取属性onSort的值。
      Node getPlaceholder​()
      获取属性占位符的值。
      TreeItem<S> getRoot​()
      返回此TreeTableView的当前根节点，如果未指定根节点，则返回null。
      int getRow​(TreeItem<S> item)
      返回给定TreeItem的索引位置，假设它目前可通过树层次结构访问（最显着的是所有父树项目都被扩展）。
      Callback<TreeTableView<S>,TreeTableRow<S>> getRowFactory​()
      获取属性rowFactory的值。
      TreeTableView.TreeTableViewSelectionModel<S> getSelectionModel​()
      返回当前安装的选择模型。
      TreeSortMode getSortMode​()
      获取属性sortMode的值。
      ObservableList<TreeTableColumn<S,?>> getSortOrder​()
      sortOrder列表定义了TreeTableColumn实例进行排序的顺序。
      Callback<TreeTableView<S>,Boolean> getSortPolicy​()
      获取属性sortPolicy的值。
      TreeTableColumn<S,?> getTreeColumn​()
      获取属性treeColumn的值。
      TreeItem<S> getTreeItem​(int row)
      返回给定索引中的TreeItem，如果超出范围则返回null。
      int getTreeItemLevel​(TreeItem<?> node)
      根据getParent（）可以递归调用的次数，返回给定TreeItem的“缩进”级别数。
      TreeTableColumn<S,?> getVisibleLeafColumn​(int column)
      相对于所有其他可见的叶子列，返回给定列索引中的TreeTableColumn。
      ObservableList<TreeTableColumn<S,?>> getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      int getVisibleLeafIndex​(TreeTableColumn<S,?> column)
      相对于所有其他可见的叶子列，返回给定列的位置。
      boolean isEditable​()
      获取可编辑属性的值。
      boolean isShowRoot​()
      如果应该显示TreeTableView的根，则返回true，否则返回false。
      boolean isTableMenuButtonVisible​()
      获取属性tableMenuButtonVisible的值。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子进行布局。
      ObjectProperty<EventHandler<ScrollToEvent<TreeTableColumn<S,?>>>> onScrollToColumnProperty​()
      当有要求使用 scrollToColumn(TreeTableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty​()
      当有请求使用 scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<SortEvent<TreeTableView<S>>>> onSortProperty​()
      当有请求排序控件时调用。
      ObjectProperty<Node> placeholderProperty​()
      当表没有显示的内容时，向用户显示该节点。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void refresh​()
      调用 refresh()强制TreeTableView控件重新创建并重新填充填充控件的可视边界所需的单元格。
      boolean resizeColumn​(TreeTableColumn<S,?> column, double delta)
      根据给定的列应用当前安装的大小调整策略，根据提供的增量值调整其大小。
      ObjectProperty<TreeItem<S>> rootProperty​()
      表示TreeTableView根节点的属性。
      ObjectProperty<Callback<TreeTableView<S>,TreeTableRow<S>>> rowFactoryProperty​()
      一个生成TreeTableRow的函数。
      void scrollTo​(int index)
      滚动TreeTableView，使给定索引中的项目对最终用户可见。
      void scrollToColumn​(TreeTableColumn<S,?> column)
      滚动TreeTableView，使给定的列在视口内可见。
      void scrollToColumnIndex​(int columnIndex)
      滚动TreeTableView，使给定的索引在视口内可见。
      ObjectProperty<TreeTableView.TreeTableViewSelectionModel<S>> selectionModelProperty​()
      SelectionModel提供了可以在TreeTableView中选择单个或多个项目的API，以及检查用户选择了哪些行。
      void setColumnResizePolicy​(Callback<TreeTableView.ResizeFeatures,Boolean> callback)
      设置属性columnResizePolicy的值。
      void setEditable​(boolean value)
      设置属性可编辑的值。
      void setFixedCellSize​(double value)
      设置此控件的新固定单元格大小。
      void setFocusModel​(TreeTableView.TreeTableViewFocusModel<S> value)
      设置要在TreeTableView中使用的FocusModel 。
      void setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void setOnScrollToColumn​(EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> value)
      设置属性onScrollToColumn的值。
      void setOnSort​(EventHandler<SortEvent<TreeTableView<S>>> value)
      设置属性onSort的值。
      void setPlaceholder​(Node value)
      设置属性占位符的值。
      void setRoot​(TreeItem<S> value)
      设置此TreeTableView中的根节点。
      void setRowFactory​(Callback<TreeTableView<S>,TreeTableRow<S>> value)
      设置属性rowFactory的值。
      void setSelectionModel​(TreeTableView.TreeTableViewSelectionModel<S> value)
      设置要在TreeTableView中使用的MultipleSelectionModel 。
      void setShowRoot​(boolean value)
      指定是否应在此TreeTableView中显示根目录 TreeItem 。
      void setSortMode​(TreeSortMode value)
      设置属性sortMode的值。
      void setSortPolicy​(Callback<TreeTableView<S>,Boolean> callback)
      设置属性sortPolicy的值。
      void setTableMenuButtonVisible​(boolean value)
      设置属性tableMenuButtonVisible的值。
      void setTreeColumn​(TreeTableColumn<S,?> value)
      设置属性treeColumn的值。
      BooleanProperty showRootProperty​()
      表示TreeTableView根节点是否可见的属性。
      void sort​()
      排序方法强制TreeTableView重新运行其排序算法。
      ObjectProperty<TreeSortMode> sortModeProperty​()
      指定在排序此TreeTableView的内容时使用的排序模式，应在 sort order列表中指定任何列。
      ObjectProperty<Callback<TreeTableView<S>,Boolean>> sortPolicyProperty​()
      排序策略指定如何执行此TreeTableView中的排序。
      BooleanProperty tableMenuButtonVisibleProperty​()
      当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TreeTableColumn的无线菜单项。
      ObjectProperty<TreeTableColumn<S,?>> treeColumnProperty​()
      表示哪个列应该在其中显示披露节点的属性（即带有箭头的列）。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • root

        public final ObjectProperty<TreeItem<S>> rootProperty
        表示TreeTableView根节点的属性。
        结果
        根属性

      • showRoot

        public final BooleanProperty showRootProperty
        表示TreeTableView根节点是否可见的属性。
        另请参见：
        isShowRoot() ， setShowRoot(boolean)

      • treeColumn

        public final ObjectProperty<TreeTableColumn<S,?>> treeColumnProperty
        表示哪个列应该在其中显示披露节点的属性（即带有箭头的列）。 默认情况下，如果此属性为空，则为最左列，否则将为指定的列，假定它为非空，并包含在visible leaf columns列表中。
        另请参见：
        getTreeColumn() ， setTreeColumn(TreeTableColumn)

      • selectionModel

        public final ObjectProperty<TreeTableView.TreeTableViewSelectionModel<S>> selectionModelProperty
        SelectionModel提供了可以在TreeTableView中选择单个或多个项目的API，以及检查用户选择了哪些行。 请注意，它具有必须与TreeTableView本身类型匹配的通用类型。
        另请参见：
        getSelectionModel() ， setSelectionModel(TreeTableView.TreeTableViewSelectionModel)

      • focusModel

        public final ObjectProperty<TreeTableView.TreeTableViewFocusModel<S>> focusModelProperty
        FocusModel提供API，通过它可以将焦点控制在零或一行TreeTableView上。 通常默认的实现应该是足够的。
        另请参见：
        getFocusModel() ， setFocusModel(TreeTableView.TreeTableViewFocusModel)

      • expandedItemCount

        public final ReadOnlyIntegerProperty expandedItemCountProperty

        表示当前能够在TreeTableView中可见的树节点数。 这实质上是所有扩展的树项目及其子项的计数。

        例如，如果只有根节点可见，则expandItemCount将为1。 如果根有三个孩子并且根被扩大，那么这个值将是四个。

        另请参见：
        getExpandedItemCount()

      • editable

        public final BooleanProperty editableProperty
        指定此TreeTableView是否可编辑 - 只有当TreeTableView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
        另请参见：
        isEditable() ， setEditable(boolean)

      • editingCell

        public final ReadOnlyObjectProperty<TreeTablePosition<S,?>> editingCellProperty
        表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
        另请参见：
        getEditingCell()

      • tableMenuButtonVisible

        public final BooleanProperty tableMenuButtonVisibleProperty
        当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TreeTableColumn的无线菜单项。 此菜单允许用户轻松显示和隐藏所有TreeTableColumns。
        另请参见：
        isTableMenuButtonVisible() ， setTableMenuButtonVisible(boolean)

      • columnResizePolicy

        public final ObjectProperty<Callback<TreeTableView.ResizeFeatures,Boolean>> columnResizePolicyProperty
        这是当用户完成列大小调整操作时调用的函数。 两个最常见的策略作为TableView类中的静态函数提供： UNCONSTRAINED_RESIZE_POLICY和CONSTRAINED_RESIZE_POLICY 。
        另请参见：
        getColumnResizePolicy() ， setColumnResizePolicy(Callback)

      • rowFactory

        public final ObjectProperty<Callback<TreeTableView<S>,TreeTableRow<S>>> rowFactoryProperty
        一个生成TreeTableRow的函数。 该系统负责重用TreeTableRows。 从此函数返回一个TreeTableRow，它可能可用于在TableView中表示单个行。

        请注意，TreeTableRow 不是 TableCell。 TreeTableRow只是一个TableCell的容器，在大多数情况下，您更有可能创建自定义TableCells而不是TreeTableRows。 创建自定义TreeTableRow实例的主要用例很可能是引入某种形式的列跨越支持。

        您可以通过将适当的函数分配给TreeTableColumn类中的cellFactory属性来创建每个列的自定义TableCell实例。

        另请参见：
        getRowFactory() ， setRowFactory(Callback)

      • placeholder

        public final ObjectProperty<Node> placeholderProperty
        当表没有显示的内容时，向用户显示该节点。 新新新新旗新新新旗新新旗新新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗新新旗新新旗新新旗新200新新旗新新旗新新旗新新旗新新旗新200新新旗新新200新新旗新新200新新旗新新200新200新新旗新新200新新旗2001-新新新新旗新新200新新200新200新新200新新200新200新新200新新200新新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新
        另请参见：
        getPlaceholder() ， setPlaceholder(Node)

      • fixedCellSize

        public final DoubleProperty fixedCellSizeProperty
        指定此控件是否具有固定高度（指定值）的单元格。 如果该值小于或等于零，则所有单元格都被单独设置和定位。 这是一个缓慢的操作。 因此，当性能重要且开发人员不依赖于可变单元大小时，设置固定单元大小值是一个好主意。 一般情况下，单元格大约为24像素，因此设置固定的单元格大小为24可能导致视觉差异很小，但性能有所改善。

        要通过CSS设置此属性，请使用-fx-fixed-cell-size属性。 这不应该与-fx-cell-size属性混淆。 这两个CSS属性之间的区别是-fx-cell-size将所有单元格的大小设置为指定的大小，但不会强制这是唯一的大小（从而允许变量单元大小，并且阻止性能提升可能）。 因此，当性能很重要的时候使用-fx-fixed-cell-size，而不是-fx-cell-size。 如果在CSS中指定了两个属性，则-fx-fixed-cell-size优先。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • sortMode

        public final ObjectProperty<TreeSortMode> sortModeProperty
        指定在排序此TreeTableView的内容时使用的排序模式，如果在 sort order列表中指定任何列。
        另请参见：
        getSortMode() ， setSortMode(TreeSortMode)

      • comparator

        public final ReadOnlyObjectProperty<Comparator<TreeItem<S>>> comparatorProperty
        比较器属性是一个只读属性，代表sort order列表的当前状态。 排序顺序列表包含以编程方式添加的列或通过用户单击标题本身的列。
        另请参见：
        getComparator()

      • sortPolicy

        public final ObjectProperty<Callback<TreeTableView<S>,Boolean>> sortPolicyProperty
        排序策略指定如何执行此TreeTableView中的排序。 例如，基本排序策略可能只是递归地分类根树项目的子节点，而更高级的排序策略可以调用数据库来在服务器端执行必要的排序。

        TreeTableView附带了一个default sort policy ，正如上面提到的那样：它只是尝试在原位分类树层次结构。

        建议不要覆盖sort方法，而不是提供不同的排序策略。

        另请参见：
        getSortPolicy() ， setSortPolicy(Callback)

      • onSort

        public ObjectProperty<EventHandler<SortEvent<TreeTableView<S>>>> onSortProperty
        当有请求排序控件时调用。
        另请参见：
        getOnSort() ， setOnSort(EventHandler)

      • onScrollTo

        public ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty
        当有请求使用 scrollTo(int)将索引滚动到视图时 调用
        另请参见：
        getOnScrollTo() ， setOnScrollTo(EventHandler)

      • onScrollToColumn

        public ObjectProperty<EventHandler<ScrollToEvent<TreeTableColumn<S,?>>>> onScrollToColumnProperty
        当有要求使用 scrollToColumn(TreeTableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
        另请参见：
        getOnScrollToColumn() ， setOnScrollToColumn(EventHandler)

    • 字段详细信息

      • UNCONSTRAINED_RESIZE_POLICY

        public static final Callback<TreeTableView.ResizeFeatures,Boolean> UNCONSTRAINED_RESIZE_POLICY

        非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。

        它还处理我们通过共享新空间嵌套列或者在所有直接子列之间均匀地减去已移除的空间的情况。 当然，直接的孩子本身可能是嵌套的，然后他们会对孩子们使用这个政策。

      • CONSTRAINED_RESIZE_POLICY

        public static final Callback<TreeTableView.ResizeFeatures,Boolean> CONSTRAINED_RESIZE_POLICY

        确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。

        当用户使用此策略调整列宽时，表会自动调整右侧列的宽度。 当用户增加列宽时，表会减小最右列的宽度，直到达到最小宽度。 然后它减小第二个最右边的列的宽度，直到达到最小宽度等等。 当所有右侧列达到最小尺寸时，用户不能再增加已调整大小的列的大小。

      • DEFAULT_SORT_POLICY

        public static final Callback<TreeTableView,Boolean> DEFAULT_SORT_POLICY
        如果没有指定其他策略，则该TreeTableView将使用默认值sort policy 。 排序策略是一个简单的Callback ，它接受一个TreeTableView作为唯一的参数，并期望一个布尔响应来表示排序是否成功。 一个布尔响应为true表示成功，并且一个false（或null）的响应将被视为代表失败。

    • 构造方法详细信息

      • TreeTableView

        public TreeTableView​()
        创建一个空TreeTableView。

        有关其他属性的默认状态的详细信息，请参阅TreeTableView类文档。

      • TreeTableView

        public TreeTableView​(TreeItem<S> root)
        使用提供的根节点创建TreeTableView。

        有关其他属性的默认状态的详细信息，请参阅TreeTableView类文档。

        参数
        root - 该节点作为此TreeTableView中的根。

    • 方法详细信息

      • editAnyEvent

        public static <S> EventType<TreeTableView.EditEvent<S>> editAnyEvent​()
        指示发生一些编辑事件的EventType。 这是所有其他编辑的事件父类型： editStartEvent() ， editCommitEvent()和editCancelEvent() 。
        参数类型
        S - 此TreeTableView中使用的TreeItem实例的类型
        结果
        指示发生一些编辑事件的EventType

      • editStartEvent

        public static <S> EventType<TreeTableView.EditEvent<S>> editStartEvent​()
        EventType用于指示在触发事件的TreeTableView中启动了编辑事件。
        参数类型
        S - 此TreeTableView中使用的TreeItem实例的类型
        结果
        用于指示编辑事件已启动的EventType

      • editCancelEvent

        public static <S> EventType<TreeTableView.EditEvent<S>> editCancelEvent​()
        EventType用于指示事件被触发的TreeTableView中刚刚取消了编辑事件。
        参数类型
        S - 此TreeTableView中使用的TreeItem实例的类型
        结果
        用于指示编辑事件刚刚被取消的EventType

      • editCommitEvent

        public static <S> EventType<TreeTableView.EditEvent<S>> editCommitEvent​()
        用于指示TreeTableView中的编辑已提交的EventType。 这意味着用户对TreeItem的数据进行了更改，UI应该被更新。
        参数类型
        S - 此TreeTableView中使用的TreeItem实例的类型
        结果
        用于指示TreeTableView中的编辑已提交的EventType

      • getNodeLevel

        @Deprecated(since="8u20")
public static int getNodeLevel​(TreeItem<?> node)
        已过时。 此方法无法正确计算从给定TreeItem到TreeTableView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过getTreeItemLevel(TreeItem)
        返回给定TreeItem的“缩进”级别数，基于可以递归调用的次数TreeItem.getParent() 。 如果TreeItem没有任何父集，则返回的值将为零。 对于每次递归调用getParent（），返回的值都将增加1。

        重要注意事项：此方法已被弃用，因为它不考虑根节点。 这意味着如果根节点具有父节点，则此方法将遍历TreeTableView控件的根节点。 如果这很重要，请拨打getTreeItemLevel(TreeItem) 。

        参数
        node - 需要级别的TreeItem。
        结果
        表示给定节点上父节点数的整数，如果给定的TreeItem为空，则为-1。

      • setRoot

        public final void setRoot​(TreeItem<S> value)
        设置此TreeTableView中的根节点。 有关详细信息，请参阅TreeItem类级别的文档。
        参数
        value - 将放置在TreeTableView根目录的TreeItem 。

      • getRoot

        public final TreeItem<S> getRoot​()
        返回此TreeTableView的当前根节点，如果未指定根节点，则返回null。
        结果
        当前根节点，如果没有根节点存在则为null。

      • rootProperty

        public final ObjectProperty<TreeItem<S>> rootProperty​()
        表示TreeTableView根节点的属性。
        结果
        根属性

      • setShowRoot

        public final void setShowRoot​(boolean value)
        指定是否应在此TreeTableView中显示根 TreeItem根。
        参数
        value - 如果为true，将显示根 value ，如果为false，它将被隐藏。

      • isShowRoot

        public final boolean isShowRoot​()
        如果应该显示TreeTableView的根，则返回true，否则返回false。 默认情况下，Root TreeItem在TreeTableView中可见。
        结果
        如果应该显示TreeTableView的根，则为true

      • showRootProperty

        public final BooleanProperty showRootProperty​()
        表示TreeTableView根节点是否可见的属性。
        另请参见：
        isShowRoot() ， setShowRoot(boolean)

      • treeColumnProperty

        public final ObjectProperty<TreeTableColumn<S,?>> treeColumnProperty​()
        表示哪个列应该在其中显示披露节点的属性（即带有箭头的列）。 默认情况下，如果此属性为null，则为最左列，否则将为指定的列，假定它为非空，并包含在visible leaf columns列表中。
        另请参见：
        getTreeColumn() ， setTreeColumn(TreeTableColumn)

      • setTreeColumn

        public final void setTreeColumn​(TreeTableColumn<S,?> value)
        设置属性treeColumn的值。
        Property description:
        表示哪个列应该在其中显示披露节点的属性（即带有箭头的列）。 默认情况下，如果此属性为空，则为最左列，否则将为指定的列，假定它为非空，并包含在visible leaf columns列表中。

      • getTreeColumn

        public final TreeTableColumn<S,?> getTreeColumn​()
        获取属性treeColumn的值。
        Property description:
        表示哪个列应该在其中显示披露节点的属性（即带有箭头的列）。 默认情况下，如果此属性为空，则为最左列，否则将为指定的列，假定它为非空，并包含在visible leaf columns列表中。

      • setSelectionModel

        public final void setSelectionModel​(TreeTableView.TreeTableViewSelectionModel<S> value)
        设置要在TreeTableView中使用的MultipleSelectionModel 。 尽管有TreeTableView需要一个MultipleSelectionModel ，可以将其配置为仅允许单次选择（更多信息，请参阅MultipleSelectionModel.setSelectionMode(javafx.scene.control.SelectionMode) ）。
        参数
        value - 要使用的MultipleSelectionModel

      • getSelectionModel

        public final TreeTableView.TreeTableViewSelectionModel<S> getSelectionModel​()
        返回当前安装的选择模型。
        结果
        当前安装的选择模型

      • selectionModelProperty

        public final ObjectProperty<TreeTableView.TreeTableViewSelectionModel<S>> selectionModelProperty​()
        SelectionModel提供了可以在TreeTableView中选择单个或多个项目的API，以及检查用户选择了哪些行。 请注意，它具有必须与TreeTableView本身类型匹配的通用类型。
        另请参见：
        getSelectionModel() ， setSelectionModel(TreeTableView.TreeTableViewSelectionModel)

      • setFocusModel

        public final void setFocusModel​(TreeTableView.TreeTableViewFocusModel<S> value)
        设置要在TreeTableView中使用的FocusModel 。
        参数
        value - 要使用的FocusModel

      • getFocusModel

        public final TreeTableView.TreeTableViewFocusModel<S> getFocusModel​()
        返回当前安装的FocusModel 。
        结果
        目前安装的是FocusModel

      • focusModelProperty

        public final ObjectProperty<TreeTableView.TreeTableViewFocusModel<S>> focusModelProperty​()
        FocusModel提供API，通过它可以将焦点控制在零或一行TreeTableView上。 通常默认的实现应该是足够的。
        另请参见：
        getFocusModel() ， setFocusModel(TreeTableView.TreeTableViewFocusModel)

      • expandedItemCountProperty

        public final ReadOnlyIntegerProperty expandedItemCountProperty​()

        表示当前能够在TreeTableView中可见的树节点数。 这实质上是所有扩展的树项目及其子项的计数。

        例如，如果只有根节点可见，则expandItemCount将为1。 如果根有三个孩子并且根被扩大，那么这个值将是四个。

        另请参见：
        getExpandedItemCount()

      • getExpandedItemCount

        public final int getExpandedItemCount​()
        获取属性expandedItemCount的值。
        Property description:

        表示当前能够在TreeTableView中可见的树节点数。 这实质上是所有扩展的树项目及其子项的计数。

        例如，如果只有根节点可见，则expandItemCount将为1。 如果根有三个孩子并且根被扩大，那么这个值将是四个。

      • setEditable

        public final void setEditable​(boolean value)
        设置属性可编辑的值。
        Property description:
        指定此TreeTableView是否可编辑 - 只有当TreeTableView和TreeCells都可编辑时，TreeCell才能进入编辑状态。

      • isEditable

        public final boolean isEditable​()
        获取可编辑属性的值。
        Property description:
        指定此TreeTableView是否可编辑 - 只有当TreeTableView和TreeCells都可编辑时，TreeCell才能进入编辑状态。

      • editableProperty

        public final BooleanProperty editableProperty​()
        指定此TreeTableView是否可编辑 - 只有当TreeTableView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
        另请参见：
        isEditable() ， setEditable(boolean)

      • getEditingCell

        public final TreeTablePosition<S,?> getEditingCell​()
        获取属性editingCell的值。
        Property description:
        表示正在编辑的当前单元格，如果没有编辑单元格，则为空。

      • editingCellProperty

        public final ReadOnlyObjectProperty<TreeTablePosition<S,?>> editingCellProperty​()
        表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
        另请参见：
        getEditingCell()

      • tableMenuButtonVisibleProperty

        public final BooleanProperty tableMenuButtonVisibleProperty​()
        当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TreeTableColumn的无线菜单项。 此菜单允许用户轻松显示和隐藏所有TreeTableColumns。
        另请参见：
        isTableMenuButtonVisible() ， setTableMenuButtonVisible(boolean)

      • setTableMenuButtonVisible

        public final void setTableMenuButtonVisible​(boolean value)
        设置属性tableMenuButtonVisible的值。
        Property description:
        当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TreeTableColumn的无线菜单项。 此菜单允许用户轻松显示和隐藏所有TreeTableColumns。

      • isTableMenuButtonVisible

        public final boolean isTableMenuButtonVisible​()
        获取属性tableMenuButtonVisible的值。
        Property description:
        当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TreeTableColumn的无线菜单项。 此菜单允许用户轻松显示和隐藏所有TreeTableColumns。

      • setColumnResizePolicy

        public final void setColumnResizePolicy​(Callback<TreeTableView.ResizeFeatures,Boolean> callback)
        设置属性columnResizePolicy的值。
        Property description:
        这是当用户完成列大小调整操作时调用的函数。 两个最常见的策略作为TableView类中的静态函数可用： UNCONSTRAINED_RESIZE_POLICY和CONSTRAINED_RESIZE_POLICY 。

      • getColumnResizePolicy

        public final Callback<TreeTableView.ResizeFeatures,Boolean> getColumnResizePolicy​()
        获取属性columnResizePolicy的值。
        Property description:
        这是当用户完成列大小调整操作时调用的函数。 两个最常见的策略作为TableView类中的静态函数可用： UNCONSTRAINED_RESIZE_POLICY和CONSTRAINED_RESIZE_POLICY 。

      • columnResizePolicyProperty

        public final ObjectProperty<Callback<TreeTableView.ResizeFeatures,Boolean>> columnResizePolicyProperty​()
        这是当用户完成列大小调整操作时调用的函数。 两个最常见的策略作为TableView类中的静态函数可用： UNCONSTRAINED_RESIZE_POLICY和CONSTRAINED_RESIZE_POLICY 。
        另请参见：
        getColumnResizePolicy() ， setColumnResizePolicy(Callback)

      • rowFactoryProperty

        public final ObjectProperty<Callback<TreeTableView<S>,TreeTableRow<S>>> rowFactoryProperty​()
        一个生成TreeTableRow的函数。 该系统负责重用TreeTableRows。 从此函数返回一个TreeTableRow，它可能可用于在TableView中表示单个行。

        请注意，TreeTableRow 不是 TableCell。 TreeTableRow只是一个TableCell的容器，在大多数情况下，您更有可能创建自定义TableCells而不是TreeTableRows。 创建自定义TreeTableRow实例的主要用例很可能是引入某种形式的列跨越支持。

        您可以通过将适当的函数分配给TreeTableColumn类中的cellFactory属性来创建每个列的自定义TableCell实例。

        另请参见：
        getRowFactory() ， setRowFactory(Callback)

      • setRowFactory

        public final void setRowFactory​(Callback<TreeTableView<S>,TreeTableRow<S>> value)
        设置属性rowFactory的值。
        Property description:
        一个生成TreeTableRow的函数。 该系统负责重用TreeTableRows。 从此函数返回一个TreeTableRow，它可能可用于在TableView中表示单个行。

        请注意，TreeTableRow 不是 TableCell。 TreeTableRow只是一个TableCell的容器，在大多数情况下，您更有可能创建自定义TableCells而不是TreeTableRows。 创建自定义TreeTableRow实例的主要用例很可能是引入某种形式的列跨越支持。

        您可以通过将适当的函数分配给TreeTableColumn类中的cellFactory属性来创建每个列的自定义TableCell实例。

      • getRowFactory

        public final Callback<TreeTableView<S>,TreeTableRow<S>> getRowFactory​()
        获取属性rowFactory的值。
        Property description:
        一个生成TreeTableRow的函数。 该系统负责重用TreeTableRows。 从此函数返回一个TreeTableRow，它可能可用于在TableView中表示单个行。

        请注意，TreeTableRow 不是 TableCell。 TreeTableRow只是一个TableCell的容器，在大多数情况下，您更有可能创建自定义TableCells而不是TreeTableRows。 创建自定义TreeTableRow实例的主要用例很可能是引入某种形式的列跨越支持。

        您可以通过将适当的函数分配给TreeTableColumn类中的cellFactory属性来创建每个列的自定义TableCell实例。

      • placeholderProperty

        public final ObjectProperty<Node> placeholderProperty​()
        当表没有显示的内容时，向用户显示该节点。 新新新新旗新新新旗新新旗新新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗新新旗新新旗新新旗新200新新旗新新旗新新旗新新旗新新旗新200新新旗新新200新新旗新新200新新旗新新200新200新新旗新新200新新旗2001-新新新新旗新新200新新200新200新新200新新200新200新新200新新200新新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新
        另请参见：
        getPlaceholder() ， setPlaceholder(Node)

      • setPlaceholder

        public final void setPlaceholder​(Node value)
        设置属性占位符的值。
        Property description:
        当表没有显示的内容时，向用户显示该节点。 新新新新旗新新新旗新新旗新新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗新新旗新新旗新新旗新200新新旗新新旗新新旗新新旗新新旗新200新新旗新新200新新旗新新200新新旗新新200新200新新旗新新200新新旗2001-新新新新旗新新200新新200新200新新200新新200新200新新200新新200新新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新

      • getPlaceholder

        public final Node getPlaceholder​()
        获取属性占位符的值。
        Property description:
        当表没有显示的内容时，向用户显示该节点。 新新新新旗新新新旗新新旗新新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗新新旗新新旗新新旗新200新新旗新新旗新新旗新新旗新新旗新200新新旗新新200新新旗新新200新新旗新新200新200新新旗新新200新新旗2001-新新新新旗新新200新新200新200新新200新新200新200新新200新新200新新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新

      • setFixedCellSize

        public final void setFixedCellSize​(double value)
        设置此控件的新固定单元格大小。 任何大于零的值将启用固定的单元大小模式，而零值或负值（或Region.USE_COMPUTED_SIZE）将用于禁用固定单元大小模式。
        参数
        value - 新的固定单元格大小值，或小于或等于零（或Region.USE_COMPUTED_SIZE）的值禁用。
        从以下版本开始：
        JavaFX 8.0

      • getFixedCellSize

        public final double getFixedCellSize​()
        返回固定的单元格大小值。 使用小于或等于零的值来表示禁用固定单元大小模式，大于零的值表示此控件中所有单元格的大小。
        结果
        表示该控件的固定单元大小的double，或者如果固定单元大小模式被禁用，小于或等于零的值。
        从以下版本开始：
        JavaFX 8.0

      • fixedCellSizeProperty

        public final DoubleProperty fixedCellSizeProperty​()
        指定此控件是否具有固定高度（指定值）的单元格。 如果该值小于或等于零，则所有单元格都被单独设置和定位。 这是一个缓慢的操作。 因此，当性能重要且开发人员不依赖于可变单元大小时，设置固定单元大小值是一个好主意。 一般情况下，单元格大约为24像素，因此设置固定的单元格大小为24可能导致视觉差异很小，但性能有所改善。

        要通过CSS设置此属性，请使用-fx-fixed-cell-size属性。 这不应该与-fx-cell-size属性混淆。 这两个CSS属性之间的区别是-fx-cell-size将所有单元格的大小设置为指定的大小，但不会强制这是唯一的大小（从而允许变量单元大小，并且阻止性能提升可能）。 因此，当性能很重要的时候使用-fx-fixed-cell-size，而不是-fx-cell-size。 如果在CSS中指定了两个属性，则-fx-fixed-cell-size优先。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • sortModeProperty

        public final ObjectProperty<TreeSortMode> sortModeProperty​()
        指定在排序此TreeTableView的内容时使用的排序模式，如果在 sort order列表中指定任何列。
        另请参见：
        getSortMode() ， setSortMode(TreeSortMode)

      • setSortMode

        public final void setSortMode​(TreeSortMode value)
        设置属性sortMode的值。
        Property description:
        指定在排序此TreeTableView的内容时使用的排序模式，如果在 sort order列表中指定了任何列。

      • getSortMode

        public final TreeSortMode getSortMode​()
        获取属性sortMode的值。
        Property description:
        指定在排序此TreeTableView的内容时使用的排序模式，如果在 sort order列表中指定了任何列。

      • getComparator

        public final Comparator<TreeItem<S>> getComparator​()
        获取属性比较器的值。
        Property description:
        比较器属性是一个只读属性，代表sort order列表的当前状态。 排序顺序列表包含以编程方式添加的列或通过用户单击标题本身的列。

      • comparatorProperty

        public final ReadOnlyObjectProperty<Comparator<TreeItem<S>>> comparatorProperty​()
        比较器属性是一个只读属性，代表sort order列表的当前状态。 排序顺序列表包含以编程方式添加的列或通过用户单击标题本身的列。
        另请参见：
        getComparator()

      • setSortPolicy

        public final void setSortPolicy​(Callback<TreeTableView<S>,Boolean> callback)
        设置属性sortPolicy的值。
        Property description:
        排序策略指定如何执行此TreeTableView中的排序。 例如，基本排序策略可能只是递归地分类根树项目的子节点，而更高级的排序策略可以调用数据库来在服务器端执行必要的排序。

        TreeTableView附带了一个default sort policy ，正如上面提到的那样：它只是尝试在原位分类树层次结构。

        建议不要覆盖sort方法，而是提供不同的排序策略。

      • getSortPolicy

        public final Callback<TreeTableView<S>,Boolean> getSortPolicy​()
        获取属性sortPolicy的值。
        Property description:
        排序策略指定如何执行此TreeTableView中的排序。 例如，基本排序策略可能只是递归地分类根树项目的子节点，而更高级的排序策略可以调用数据库来在服务器端执行必要的排序。

        TreeTableView配有一个default sort policy ，正如上面提到的那样：它只是尝试将树层次结构排列在原位。

        建议不要覆盖提供不同排序策略的sort方法。

      • sortPolicyProperty

        public final ObjectProperty<Callback<TreeTableView<S>,Boolean>> sortPolicyProperty​()
        排序策略指定如何执行此TreeTableView中的排序。 例如，基本排序策略可能只是递归地分类根树项目的子节点，而更高级的排序策略可以调用数据库来在服务器端执行必要的排序。

        TreeTableView配有一个default sort policy ，正如上面提到的那样：它只是尝试在原位分类树层次结构。

        建议不要覆盖sort方法，而不是提供不同的排序策略。

        另请参见：
        getSortPolicy() ， setSortPolicy(Callback)

      • setOnSort

        public void setOnSort​(EventHandler<SortEvent<TreeTableView<S>>> value)
        设置属性onSort的值。
        Property description:
        当有请求排序控件时调用。

      • getOnSort

        public EventHandler<SortEvent<TreeTableView<S>>> getOnSort​()
        获取属性onSort的值。
        Property description:
        当有请求排序控件时调用。

      • onSortProperty

        public ObjectProperty<EventHandler<SortEvent<TreeTableView<S>>>> onSortProperty​()
        当有请求排序控件时调用。
        另请参见：
        getOnSort() ， setOnSort(EventHandler)

      • layoutChildren

        protected void layoutChildren​()
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Control

      • scrollTo

        public void scrollTo​(int index)
        滚动TreeTableView，使给定索引中的项目对最终用户可见。
        参数
        index - 应该对用户可见的索引，假定它大于或等于0，小于TreeTableView中可见项的数量。

      • setOnScrollTo

        public void setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
        设置属性onScrollTo的值。
        Property description:
        当有请求使用 scrollTo(int)将索引滚动到视图时 调用

      • getOnScrollTo

        public EventHandler<ScrollToEvent<Integer>> getOnScrollTo​()
        获取属性onScrollTo的值。
        Property description:
        当有请求使用 scrollTo(int)将索引滚动到视图时 调用

      • onScrollToProperty

        public ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty​()
        当有请求使用 scrollTo(int)将索引滚动到视图时 调用
        另请参见：
        getOnScrollTo() ， setOnScrollTo(EventHandler)

      • scrollToColumn

        public void scrollToColumn​(TreeTableColumn<S,?> column)
        滚动TreeTableView，使给定的列在视口内可见。
        参数
        column - 应该对用户可见的列。

      • scrollToColumnIndex

        public void scrollToColumnIndex​(int columnIndex)
        滚动TreeTableView，使给定的索引在视口内可见。
        参数
        columnIndex - 应该对用户可见的列的索引。

      • setOnScrollToColumn

        public void setOnScrollToColumn​(EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> value)
        设置属性onScrollToColumn的值。
        Property description:
        当有要求使用 scrollToColumn(TreeTableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用

      • getOnScrollToColumn

        public EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> getOnScrollToColumn​()
        获取属性onScrollToColumn的值。
        Property description:
        当有要求使用 scrollToColumn(TreeTableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用

      • onScrollToColumnProperty

        public ObjectProperty<EventHandler<ScrollToEvent<TreeTableColumn<S,?>>>> onScrollToColumnProperty​()
        当有要求使用 scrollToColumn(TreeTableColumn)或 scrollToColumnIndex(int)将列滚动到视图时 调用
        另请参见：
        getOnScrollToColumn() ， setOnScrollToColumn(EventHandler)

      • getRow

        public int getRow​(TreeItem<S> item)
        返回给定TreeItem的索引位置，假设它目前可通过树层次结构访问（最显着的是所有父树项目都被扩展）。 如果父树项目被折叠，则结果是该方法将返回-1以指示树中不可访问给定树项。
        参数
        item - 寻找索引的TreeItem。
        结果
        表示给定TreeItem的第一个实例的当前TreeTableView中的位置的整数，如果为null或无法找到，则为-1（例如，如果父（一直到根）已折叠）。

      • getTreeItem

        public TreeItem<S> getTreeItem​(int row)
        返回给定索引中的TreeItem，如果超出范围则返回null。
        参数
        row - 正在寻找TreeItem的索引。
        结果
        给定索引中的TreeItem，如果超出范围，则为null。

      • getTreeItemLevel

        public int getTreeItemLevel​(TreeItem<?> node)
        根据getParent（）可以递归调用的次数，返回给定TreeItem的“缩进”级别数。 如果给定的TreeItem是此TreeTableView的根节点，或者如果TreeItem没有任何父集，则返回的值将为零。 对于每次递归调用getParent（），返回的值都将增加1。
        参数
        node - 需要级别的TreeItem。
        结果
        表示给定节点上父节点数的整数，如果给定的TreeItem为空，则为-1。

      • getColumns

        public final ObservableList<TreeTableColumn<S,?>> getColumns​()
        作为TableView的一部分的TreeTableColumns。 当用户重新排列TableView列时，此列表将被更新以反映当前的视觉排序。

        注意：要在TableView中显示任何数据，该ObservableList中必须至少有一个TreeTableColumn。

        结果
        表格列

      • getSortOrder

        public final ObservableList<TreeTableColumn<S,?>> getSortOrder​()
        sortOrder列表定义TreeTableColumn实例进行排序的顺序。 一个空的排序列表表示在TableView上没有应用排序。 如果sortOrder列表中有一个TreeTableColumn，则TableView将使用此TreeTableColumn的sortType和comparator属性进行排序（假设为TreeTableColumn.sortable ）。 如果sortOrder列表包含多个TreeTableColumn实例，则首先根据第一个TreeTableColumn的属性对TableView进行排序。 如果两个元素被认为是相等的，则列表中的第二个TreeTableColumn用于确定排序。 如果需要，将重复此循环，直到所有TreeTableColumn比较器的结果被考虑为止。
        结果
        一个包含零个或多个TreeTableColumn实例的ObservableList。

      • resizeColumn

        public boolean resizeColumn​(TreeTableColumn<S,?> column,
                            double delta)
        根据给定的列应用当前安装的大小调整策略，根据提供的增量值调整其大小。
        参数
        column - 列
        delta - 三角洲
        结果
        如果应用列调整大小，则为true

      • edit

        public void edit​(int row,
                 TreeTableColumn<S,?> column)
        导致给定行/列视图索引处的单元格切换到其编辑状态（如果尚未存在），并且假设TableView和列也是可编辑的。
        参数
        row - 行
        column - 列

      • getVisibleLeafColumns

        public ObservableList<TreeTableColumn<S,?>> getVisibleLeafColumns​()
        返回一个不可修改的列表，其中包含当前可见的叶子列。
        结果
        一个包含当前可见的叶子列的不可修改的列表

      • getVisibleLeafIndex

        public int getVisibleLeafIndex​(TreeTableColumn<S,?> column)
        相对于所有其他可见的叶子列，返回给定列的位置。
        参数
        column - 列
        结果
        相对于所有其他可见叶列，给定列的位置

      • getVisibleLeafColumn

        public TreeTableColumn<S,?> getVisibleLeafColumn​(int column)
        相对于所有其他可见的叶子列，返回给定列索引中的TreeTableColumn。
        参数
        column - 列
        结果
        相对于所有其他可见的叶子列，给定列索引中的TreeTableColumn

      • sort

        public void sort​()
        排序方法强制TreeTableView重新运行其排序算法。 往往不是没有必要直接调用该方法，当它被自动调用sort order ， sort policy ，或TreeTableColumn的状态sort type性质发生变化。 换句话说，这种方法只能在需要外部更改和排序时直接调用。

      • refresh

        public void refresh​()
        调用refresh()强制TreeTableView控件重新创建并重新填充填充控件的可视边界所需的单元格。 换句话说，这将强制TreeTableView更新它向用户显示的内容。 这在底层数据源以TreeTableView本身未观察到的方式发生更改的情况下很有用。
        从以下版本开始：
        JavaFX 8u60

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData在 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤，或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TreeTableView.EditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableView.EditEvent<S>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.TreeTableView.EditEvent<S>
  • 参数类型
    S - 输入的类型，与TreeTableView本身的类型相同。
    All Implemented Interfaces:
    Serializable ， Cloneable
    Enclosing class:
    TreeTableView < S >

    public static class TreeTableView.EditEvent<S>
extends Event
    一个Event在TreeTableView中专门用于表示编辑相关事件的子类。 它提供了额外的API来轻松访问编辑事件发生的TreeItem，以及最终用户提供的输入。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<?> ANY
      所有编辑事件类型的公共超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

    • 构造方法摘要

      构造方法
      Constructor 描述
      EditEvent​(TreeTableView<S> source, EventType<? extends TreeTableView.EditEvent> eventType, TreeItem<S> treeItem, S oldValue, S newValue)
      创建一个新的EditEvent实例来表示编辑事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      S getNewValue​()
      返回最终用户输入到TreeItem的新值。
      S getOldValue​()
      返回在当前编辑事件之前的TreeItem中存在的旧值。
      TreeTableView<S> getSource​()
      返回发生编辑的TreeTableView。
      TreeItem<S> getTreeItem​()
      返回发生编辑的TreeItem 。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<?> ANY
        所有编辑事件类型的公共超类型。

    • 构造方法详细信息

      • EditEvent

        public EditEvent​(TreeTableView<S> source,
                 EventType<? extends TreeTableView.EditEvent> eventType,
                 TreeItem<S> treeItem,
                 S oldValue,
                 S newValue)
        创建一个新的EditEvent实例来表示编辑事件。 此事件是用于TreeTableView.EDIT_START_EVENT ， TreeTableView.EDIT_COMMIT_EVENT和TreeTableView.EDIT_CANCEL_EVENT类型。
        参数
        source - 来源
        eventType - eventType
        treeItem - 树项目
        oldValue - oldValue
        newValue - newValue

    • 方法详细信息

      • getSource

        public TreeTableView<S> getSource​()
        返回发生编辑的TreeTableView。
        重写：
        getSource在 EventObject
        结果
        在其上进行编辑的TreeTableView

      • getTreeItem

        public TreeItem<S> getTreeItem​()
        返回编辑发生的TreeItem 。
        结果
        编辑发生在的TreeItem

      • getNewValue

        public S getNewValue​()
        返回最终用户输入到TreeItem的新值。
        结果
        最终用户输入TreeItem的新值

      • getOldValue

        public S getOldValue​()
        返回在当前编辑事件之前的TreeItem中存在的旧值。
        结果
        在当前编辑事件之前的TreeItem中存在的旧值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TreeTableView.ResizeFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableView.ResizeFeatures<S>

  • java.lang.Object
    • javafx.scene.control.ResizeFeaturesBase<TreeItem<S>>
      • javafx.scene.control.TreeTableView.ResizeFeatures<S>
  • Enclosing class:
    TreeTableView < S >

    public static class TreeTableView.ResizeFeatures<S>
extends ResizeFeaturesBase<TreeItem<S>>
    用于TableView column resize功能的不可变包装类。
    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ResizeFeatures​(TreeTableView<S> treeTable, TreeTableColumn<S,?> column, Double delta)
      创建此类的实例，提供的TreeTableView，TreeTableColumn和delta值被设置并存储在此不可变实例中。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TreeTableColumn<S,?> getColumn​()
      返回发生resize的列，如果由于TreeTableView resize操作而创建了此ResizeFeatures实例，则返回null。
      TreeTableView<S> getTable​()
      返回在其上进行调整大小操作的TreeTableView。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.ResizeFeaturesBase

        getDelta

    • 构造方法详细信息

      • ResizeFeatures

        public ResizeFeatures​(TreeTableView<S> treeTable,
                      TreeTableColumn<S,?> column,
                      Double delta)
        创建此类的实例，提供的TreeTableView，TreeTableColumn和delta值被设置并存储在此不可变实例中。
        参数
        treeTable - 发生调整大小操作的TreeTableView。
        column - 发生调整大小的列，如果由于TreeTableView调整大小操作而创建此ResizeFeatures实例，则为null。
        delta - 在调整大小操作中添加或删除的水平空间量。

    • 方法详细信息

      • getColumn

        public TreeTableColumn<S,?> getColumn​()
        返回发生resize的列，如果由于TreeTableView resize操作而创建了此ResizeFeatures实例，则返回null。
        重写：
        getColumn在 ResizeFeaturesBase<TreeItem<S>>
        结果
        正在发生调整大小的列

      • getTable

        public TreeTableView<S> getTable​()
        返回在其上进行调整大小操作的TreeTableView。
        结果
        正在发生调整大小操作的TreeTableView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeTableView.TreeTableViewFocusModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableView.TreeTableViewFocusModel<S>

  • java.lang.Object
    • javafx.scene.control.FocusModel<T>
      • javafx.scene.control.TableFocusModel<TreeItem<S>,TreeTableColumn<S,?>>
        • javafx.scene.control.TreeTableView.TreeTableViewFocusModel<S>
  • Enclosing class:
    TreeTableView < S >

    public static class TreeTableView.TreeTableViewFocusModel<S>
extends TableFocusModel<TreeItem<S>,TreeTableColumn<S,?>>
    A FocusModel具有支持TableView控件要求的附加功能。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TableView

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<TreeTablePosition<S,?>> focusedCell
      当前项目在TableView中的位置具有重点。

      • Properties inherited from class javafx.scene.control.FocusModel

        focusedIndex, focusedItem

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTableViewFocusModel​(TreeTableView<S> treeTableView)
      创建一个默认的TableViewFocusModel实例，用于管理提供的TableView控件的焦点。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void focus​(int index)
      导致给定索引处的项目接收焦点。
      void focus​(int row, TreeTableColumn<S,?> column)
      导致给定索引处的项目接收焦点。
      void focus​(TreeTablePosition<S,?> pos)
      使用TablePosition设置焦点在特定行或单元格的便利方法。
      void focusAboveCell​()
      尝试将焦点移动到当前聚焦单元格上方的单元格。
      void focusBelowCell​()
      尝试将焦点移动到当前聚焦单元格下方的单元格。
      ReadOnlyObjectProperty<TreeTablePosition<S,?>> focusedCellProperty​()
      当前项目在TableView中的位置具有重点。
      void focusLeftCell​()
      尝试将焦点移动到当前聚焦单元格左侧的单元格。
      void focusNext​()
      尝试将焦点放在当前焦点集中的行之后。
      void focusPrevious​()
      尝试将重点放在目前重点集中的行之前。
      void focusRightCell​()
      尝试将焦点移动到当前聚焦单元格右侧的单元格。
      TreeTablePosition<S,?> getFocusedCell​()
      获取focusCell属性的值。
      protected int getItemCount​()
      返回数据模型中支配控件的项目数。
      protected TreeItem<S> getModelItem​(int index)
      返回给定索引处的项目。
      boolean isFocused​(int row, TreeTableColumn<S,?> column)
      测试给定位置的行/单元格当前是否具有TableView内的焦点。

      • Methods inherited from class javafx.scene.control.FocusModel

        focusedIndexProperty, focusedItemProperty, getFocusedIndex, getFocusedItem, isFocused

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • focusedCell

        public final ReadOnlyObjectProperty<TreeTablePosition<S,?>> focusedCellProperty
        当前项目在TableView中的位置具有重点。
        另请参见：
        getFocusedCell()

    • 构造方法详细信息

      • TreeTableViewFocusModel

        public TreeTableViewFocusModel​(TreeTableView<S> treeTableView)
        创建一个默认的TableViewFocusModel实例，用于管理提供的TableView控件的焦点。
        参数
        treeTableView - 此对焦模型运行的tableView。
        异常
        NullPointerException - TableView参数不能为空。

    • 方法详细信息

      • getItemCount

        protected int getItemCount​()
        返回数据模型中支配控件的项目数。 一个例子就是ListView焦点模型可能会返回listView.getItems().size() 。 可聚焦索引的有效范围在0和此方法返回的任何值之间。
        Specified by:
        getItemCount在 FocusModel<TreeItem<S>>
        结果
        支持控制的数据模型中的项目数

      • getModelItem

        protected TreeItem<S> getModelItem​(int index)
        返回给定索引处的项目。 使用ListView的示例将是listView.getItems().get(index) 。
        Specified by:
        getModelItem在 FocusModel<TreeItem<S>>
        参数
        index - 从底层数据模型请求的项目的索引。
        结果
        如果索引超出范围，则返回null，或者与给定索引相关的类型T的元素。

      • focusedCellProperty

        public final ReadOnlyObjectProperty<TreeTablePosition<S,?>> focusedCellProperty​()
        当前项目在TableView中的位置具有重点。
        另请参见：
        getFocusedCell()

      • getFocusedCell

        public final TreeTablePosition<S,?> getFocusedCell​()
        获取focusCell属性的值。
        Property description:
        当前项目在TableView中的位置具有重点。

      • focus

        public void focus​(int row,
                  TreeTableColumn<S,?> column)
        导致给定索引处的项目接收焦点。
        Specified by:
        focus在 TableFocusModel<TreeItem<S>,TreeTableColumn<S,?>>
        参数
        row - 要重点 row的项目的行索引。
        column - 要专注的项目的列。 可以为null。

      • focus

        public void focus​(TreeTablePosition<S,?> pos)
        使用TablePosition设置焦点在特定行或单元格的便利方法。
        参数
        pos - 要设置焦点的表格位置。

      • isFocused

        public boolean isFocused​(int row,
                         TreeTableColumn<S,?> column)
        测试给定位置的行/单元格当前是否具有TableView内的焦点。
        Specified by:
        isFocused在 TableFocusModel<TreeItem<S>,TreeTableColumn<S,?>>
        参数
        row - 行
        column - 列
        结果
        如果给定位置的行/单元格当前具有UI控件内的焦点，则为true

      • focus

        public void focus​(int index)
        导致给定索引处的项目接收焦点。 这不会导致当前的选择更改。 更新focusItem和focusedIndex属性，使focusedIndex = -1除非
          0 <= index < model size
        。
        重写：
        focus在 FocusModel<TreeItem<S>>
        参数
        index - 要获取焦点的项目的索引。

      • focusAboveCell

        public void focusAboveCell​()
        尝试将焦点移动到当前聚焦单元格上方的单元格。
        Specified by:
        focusAboveCell在 TableFocusModel<TreeItem<S>,TreeTableColumn<S,?>>

      • focusBelowCell

        public void focusBelowCell​()
        尝试将焦点移动到当前聚焦单元格下方的单元格。
        Specified by:
        focusBelowCell在 TableFocusModel<TreeItem<S>,TreeTableColumn<S,?>>

      • focusLeftCell

        public void focusLeftCell​()
        尝试将焦点移动到当前聚焦单元格左侧的单元格。
        Specified by:
        focusLeftCell在 TableFocusModel<TreeItem<S>,TreeTableColumn<S,?>>

      • focusRightCell

        public void focusRightCell​()
        尝试将焦点移动到当前聚焦单元格右侧的单元格。
        Specified by:
        focusRightCell在 TableFocusModel<TreeItem<S>,TreeTableColumn<S,?>>

      • focusPrevious

        public void focusPrevious​()
        尝试将重点放在目前重点集中的行之前。 如果当前焦点所有者是第一行，或者是-1（表示没有当前焦点所有者），调用此方法将不会有结果。
        重写：
        focusPrevious FocusModel<TreeItem<S>>

      • focusNext

        public void focusNext​()
        尝试将焦点放在当前焦点集中的行之后。 如果当前焦点所有者是最后一行，调用此方法将不会有结果。
        重写：
        focusNext在 FocusModel<TreeItem<S>>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeTableView.TreeTableViewSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeTableView.TreeTableViewSelectionModel<S>

  • java.lang.Object
    • javafx.scene.control.SelectionModel<T>
      • javafx.scene.control.MultipleSelectionModel<T>
        • javafx.scene.control.TableSelectionModel<TreeItem<S>>
          • javafx.scene.control.TreeTableView.TreeTableViewSelectionModel<S>
  • Enclosing class:
    TreeTableView < S >

    public abstract static class TreeTableView.TreeTableViewSelectionModel<S>
extends TableSelectionModel<TreeItem<S>>
    SelectionModel抽象类的简单扩展，允许对TreeTableView控件的特殊支持。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      • Properties inherited from class javafx.scene.control.MultipleSelectionModel

        selectionMode

      • Properties inherited from class javafx.scene.control.SelectionModel

        selectedIndex, selectedItem

      • Properties inherited from class javafx.scene.control.TableSelectionModel

        cellSelectionEnabled

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTableViewSelectionModel​(TreeTableView<S> treeTableView)
      使用提供的TreeTableView构建一个默认的TreeTableViewSelectionModel实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      void clearAndSelect​(int row)
      在将选择设置为给定索引之前清除任何选择的方法。
      void clearSelection​()
      清除所有选定索引的选择模型。
      void clearSelection​(int index)
      该方法将清除给定索引中项目的选择。
      void | focus​(int row)
      int | getFocusedIndex​()
      protected int getItemCount​()
      返回数据模型中支配控件的项目数。
      TreeItem<S> getModelItem​(int index)
      返回给定索引处的项目。
      abstract ObservableList<TreeTablePosition<S,?>> getSelectedCells​()
      一个只读ObservableList，表示此TreeTableView中当前选定的单元格。
      ObservableList<Integer> getSelectedIndices​()
      返回所有选定索引的 只读 ObservableList。
      ObservableList<T> getSelectedItems​()
      返回所有选定项目的 只读 ObservableList。
      TreeTableView<S> getTreeTableView​()
      返回安装此选择模型的TreeTableView实例。
      boolean isEmpty​()
      该方法可用于测试是否有任何选定的索引/项目。
      boolean isSelected​(int index)
      通知此SelectionModel中当前选定给定索引的方便方法。
      void select​(int row)
      这将在选择模型中选择给定的索引，假设索引在有效范围内（即大于或等于零，并且小于底层数据模型中的项目总数）。
      void select​(T obj)
      此方法将尝试选择包含给定对象的索引。
      void selectAll​()
      方便的方法来选择所有可用的索引。
      void selectFirst​()
      该方法将尝试选择控件中的第一个索引。
      void selectIndices​(int row, int... rows)
      该方法允许同时设置一个或多个选择。
      void selectLast​()
      此方法将尝试选择控件中的最后一个索引。
      void selectNext​()
      此方法将尝试在当前焦点索引之后直接选择索引。
      void selectPrevious​()
      此方法将尝试直接在当前聚焦索引之前选择索引。
      void selectRange​(int minRow, TableColumnBase<TreeItem<S>,?> minColumn, int maxRow, TableColumnBase<TreeItem<S>,?> maxColumn)
      选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。

      • Methods inherited from class javafx.scene.control.MultipleSelectionModel

        getSelectionMode, selectionModeProperty, selectRange, setSelectionMode

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SelectionModel

        getSelectedIndex, getSelectedItem, selectedIndexProperty, selectedItemProperty, setSelectedIndex, setSelectedItem

      • Methods inherited from class javafx.scene.control.TableSelectionModel

        cellSelectionEnabledProperty, clearAndSelect, clearSelection, isCellSelectionEnabled, isSelected, select, selectAboveCell, selectBelowCell, selectLeftCell, selectRightCell, setCellSelectionEnabled

    • 构造方法详细信息

      • TreeTableViewSelectionModel

        public TreeTableViewSelectionModel​(TreeTableView<S> treeTableView)
        使用提供的TreeTableView构建一个默认的TreeTableViewSelectionModel实例。
        参数
        treeTableView - 此选择模型应在其上运行的TreeTableView。
        异常
        NullPointerException - TreeTableView不能为空。

    • 方法详细信息

      • getSelectedCells

        public abstract ObservableList<TreeTablePosition<S,?>> getSelectedCells​()
        一个只读ObservableList，表示此TreeTableView中当前选定的单元格。 而不是直接修改此列表，请使用TreeTableViewSelectionModel中提供的其他方法。
        结果
        所选单元格的列表

      • getTreeTableView

        public TreeTableView<S> getTreeTableView​()
        返回安装此选择模型的TreeTableView实例。
        结果
        此选择模型安装的TreeTableView实例

      • getModelItem

        public TreeItem<S> getModelItem​(int index)
        返回给定索引处的项目。 使用ListView的示例将是listView.getItems().get(index) 。
        参数
        index - 从底层数据模型请求的项目的索引。
        结果
        如果索引超出范围，则返回null，或者与给定索引相关的类型T的元素。

      • getItemCount

        protected int getItemCount​()
        返回数据模型中支配控件的项目数。 一个例子就是ListView选择模型可能会返回listView.getItems().size() 。 可选索引的有效范围在0和此方法返回的任何值之间。
        结果
        支持控制的数据模型中的项目数

      • focus

        public void focus​(int row)

      • getFocusedIndex

        public int getFocusedIndex​()

      • selectRange

        public void selectRange​(int minRow,
                        TableColumnBase<TreeItem<S>,?> minColumn,
                        int maxRow,
                        TableColumnBase<TreeItem<S>,?> maxColumn)
        选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。
        Specified by:
        selectRange在 TableSelectionModel<TreeItem<S>>
        参数
        minRow - minRow
        minColumn - minColumn
        maxRow - maxRow
        maxColumn - maxColumn

      • getSelectedIndices

        public ObservableList<Integer> getSelectedIndices​()
        说明从类别复制MultipleSelectionModel

        返回所有选定索引的只读 ObservableList。 ObservableList将由选择模型更新以始终反映选择的变化。 这可以通过向返回的ObservableList添加一个ListChangeListener来观察。

        Specified by:
        getSelectedIndices在 MultipleSelectionModel<T>
        结果
        所选索引的列表

      • getSelectedItems

        public ObservableList<T> getSelectedItems​()
        描述从类复制： MultipleSelectionModel

        返回所有选定项目的只读 ObservableList。 ObservableList将通过选择模型进一步更新以始终反映选择的变化。 这可以通过向返回的ObservableList添加一个ListChangeListener来观察。

        Specified by:
        getSelectedItems在 MultipleSelectionModel<T>
        结果
        所选项目的列表

      • clearAndSelect

        public void clearAndSelect​(int row)
        描述从类： SelectionModel复制
        在将选择设置为给定索引之前清除任何选择的方法。 此方法的目的是避免首先调用SelectionModel.clearSelection() ，这意味着正在监听270703271783535属性的观察者将不会将所选索引临时设置为-1。
        Specified by:
        clearAndSelect在 SelectionModel<T>
        参数
        row - 应该是此选择模型中唯一选择的索引的索引。

      • select

        public void select​(int row)
        描述从类复制： SelectionModel

        这将在选择模型中选择给定的索引，假设索引在有效范围内（即大于或等于零，并且小于底层数据模型中的项目总数）。

        如果在此模型中已经选择了一个或多个索引，调用此方法将不会清除这些选择 - 为此，有必要先调用SelectionModel.clearSelection() 。

        如果索引已被选中，则不会再次选择或未选择。 然而，如果实现了多个选择，则对已经选择的索引进行调用select将具有使索引成为新的所选索引的效果（由SelectionModel.getSelectedIndex()返回）。

        Specified by:
        select在 SelectionModel<T>
        参数
        row - 要在选择模型中选择的项目的位置。

      • select

        public void select​(T obj)
        描述从类SelectionModel复制

        此方法将尝试选择包含给定对象的索引。 它将遍历底层数据模型，直到找到一个值等于给定对象的项。 在这一点上它将停止迭代 - 这意味着该方法将不会选择多个索引。

        Specified by:
        select在 SelectionModel<T>
        参数
        obj - 要在底层数据模型中选择的对象。

      • selectIndices

        public void selectIndices​(int row,
                          int... rows)
        描述从类复制： MultipleSelectionModel

        该方法允许同时设置一个或多个选择。 它将忽略不在有效范围内的任何值（即大于或等于零，小于底层数据模型中的项目总数）。 任何重复的索引都将被忽略。

        如果在此模型中已经选择了一个或多个索引，则调用此方法将不会清除这些选择 - 为此，必须首先调用clearSelection。

        给定的最后一个有效值将成为所选择的索引/选定项目。

        Specified by:
        selectIndices在 MultipleSelectionModel<T>
        参数
        row - 第一个要选择的索引
        rows - 零个或多个附加索引进行选择

      • selectAll

        public void selectAll​()
        描述从类复制： MultipleSelectionModel

        方便的方法来选择所有可用的索引。

        Specified by:
        selectAll MultipleSelectionModel<T>

      • selectFirst

        public void selectFirst​()
        描述从类别复制MultipleSelectionModel

        该方法将尝试选择控件中的第一个索引。 如果首先不调用clearSelection，则该方法将具有选择第一个索引的结果，同时保留对当前其他任何索引的选择。

        如果已经选择了第一个索引，调用此方法将不会产生任何结果，并且不会执行选择事件。

        Specified by:
        selectFirst在 MultipleSelectionModel<T>

      • selectLast

        public void selectLast​()
        描述从类MultipleSelectionModel复制

        此方法将尝试选择控件中的最后一个索引。 如果没有首先调用clearSelection，则该方法将具有选择最后一个索引的结果，同时保留对其他当前选定索引的选择。

        如果最后一个索引已经被选中，调用该方法将不会有结果，并且不会发生选择事件。

        Specified by:
        selectLast在 MultipleSelectionModel<T>

      • clearSelection

        public void clearSelection​(int index)
        说明从类别SelectionModel复制

        该方法将清除给定索引中项目的选择。 如果没有选择给定的索引，则不会发生任何事情。

        Specified by:
        clearSelection在 SelectionModel<T>
        参数
        index - 要取消选择的选定项目。

      • clearSelection

        public void clearSelection​()
        描述从类复制： SelectionModel

        清除所有选定索引的选择模型。

        Specified by:
        clearSelection在 SelectionModel<T>

      • isSelected

        public boolean isSelected​(int index)
        描述从类复制： SelectionModel

        通知此SelectionModel中当前选定给定索引的方便方法。 在功能上等同于调用getSelectedIndices().contains(index) 。

        Specified by:
        isSelected在 SelectionModel<T>
        参数
        index - 检查当前是否选择的索引。
        结果
        如果给定的索引被选择，则为真，否则为false。

      • isEmpty

        public boolean isEmpty​()
        描述从类别复制SelectionModel
        该方法可用于测试是否有任何选定的索引/项目。 如果没有选定的项目，它将返回true，如果有，则返回false。
        Specified by:
        isEmpty在 SelectionModel<T>
        结果
        如果 没有选择的项目将返回true，如果有的话将返回false。

      • selectPrevious

        public void selectPrevious​()
        描述从类别复制SelectionModel

        此方法将尝试直接在当前聚焦索引之前选择索引。 如果没有首先调用clearSelection，则该方法将具有选择先前索引的结果，同时保留对其他当前选择的索引的选择。

        调用此方法将仅在以下情况下成功：

        • 目前有一个主角/重点指数。
        • 主要/焦点指数不是控制中的第一个指标。
        • 以前的索引尚未被选中。

        如果这些条件中的任何一个都是假的，则不会发生选择事件。

        Specified by:
        selectPrevious在 SelectionModel<T>

      • selectNext

        public void selectNext​()
        描述从类复制： SelectionModel

        此方法将尝试在当前焦点索引之后直接选择索引。 如果没有首先调用clearSelection，则该方法将具有选择下一个索引的结果，同时保留对任何其他当前选择的索引的选择。

        调用此方法将仅在以下情况下成功：

        • 目前有一个主角/重点指数。
        • 主要/焦点指数不是控件中的最后一个指标。
        • 下一个索引尚未被选中。

        如果这些条件中的任何一个都是假的，则不会发生选择事件。

        Specified by:
        selectNext在 SelectionModel<T>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeView<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.TreeView<T>
  • 参数类型
    T - 此TreeView中所有树项目的TreeItem值属性中包含的项目的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    @DefaultProperty("root")
public class TreeView<T>
extends Control
    TreeView控件提供了一个到根的视图（ TreeItem型）。 通过使用TreeView，可以递归地向下钻取TreeItem的子对象，直到TreeItem没有子节点（即树中的叶节点）。 为了推动这项工作，不像在控制ListView ，在TreeView中有必要只指定root节点。

    有关使用此方法构建树的更多信息，请参阅TreeItem类文档。 但是简单地说，要创建一个TreeView，你应该按照以下几点做一些事情：

       TreeItem<String> root = new TreeItem<String>("Root Node"); root.setExpanded(true); root.getChildren().addAll( new TreeItem<String>("Item 1"), new TreeItem<String>("Item 2"), new TreeItem<String>("Item 3") ); TreeView<String> treeView = new TreeView<String>(root);

    一个TreeView可以被配置为可选地由设置隐藏根节点showRoot属性false 。 如果根节点被隐藏，则减少一个级别的缩进，并显示根节点的所有子节点。 默认情况下，根节点显示在TreeView中。

    TreeView Selection / Focus API

    要跟踪选择和重点，有必要熟悉SelectionModel和FocusModel课程。 TreeView最多只有一个这些类的一个实例，分别可从selectionModel和focusModel属性获得。 虽然可以使用此API来设置新的选择模型，但在大多数情况下，这不是必需的 - 默认选择和焦点模型应该在大多数情况下工作。

    在实例化TreeView时使用的默认值为SelectionModel是MultipleSelectionModel抽象类的实现。 但是，如selectionMode属性的API文档中所述，默认值为SelectionMode.SINGLE 。 要在默认的TreeView实例中启用多个选择，因此需要执行以下操作：

       treeView.getSelectionModel().setSelectionMode(SelectionMode.MULTIPLE);

    自定义TreeView视觉

    TreeView的视觉效果可以通过替换默认的cell factory完全自定义。 一个单元格工厂用于生成TreeCell个实例，用于表示TreeView中的一个项目。 有关如何编写自定义单元格的更完整的说明，请参阅Cell类文档。

    编辑

    此控件支持值的内联编辑，本节尝试概述可用的API以及如何使用它们。

    首先，细胞编辑通常需要不同于不编辑细胞的用户界面。 这是正在使用的Cell实现的责任。 对于TreeView，这是cell factory的责任。 您可以选择单元格是否永久处于编辑状态（例如，这对于CheckBox单元格来说是常见的），或者在编辑开始时切换到不同的UI（例如，当单元格上接收到双击时）。

    要知道在单元格上请求编辑时，只需覆盖Cell.startEdit()方法，并根据需要更新单元格text和graphic属性（例如，将文本设置为空，并将图形设置为TextField ）。 此外，您还应该覆盖Cell.cancelEdit()，以便在编辑结束时将UI重置为原始的可视状态。 在这两种情况下，重要的是您还要确保您调用超级方法以使单元格执行所有必须执行的任务，以进入或退出其编辑模式。

    一旦您的单元格处于编辑状态，您最感兴趣的下一件事就是如何提交或取消正在进行的编辑。 这是您作为电池厂商的责任。 您的单元实现将基于用户输入（例如当用户按下键盘上的Enter键或ESC键时）知道编辑结束。 发生这种情况时，您有责任酌情致电Cell.commitEdit(Object)或Cell.cancelEdit() 。

    当您调用Cell.commitEdit(Object)事件触发到TreeView，您可以通过setOnEditCommit(javafx.event.EventHandler)添加一个EventHandler来观察 。 同样，您也可以观察edit start和edit cancel的编辑事件。

    默认情况下，TreeView编辑提交处理程序是非空的，默认处理程序会尝试覆盖当前正在编辑的行中的项目的属性值。 它可以做到这一点，因为Cell.commitEdit(Object)方法传递给新的值，并且这被传递给编辑提交处理程序通过TreeView.EditEvent被触发。 只需调用TreeView.EditEvent.getNewValue()即可检索该值。

    需要注意的是，如果你把它是非常重要的setOnEditCommit(javafx.event.EventHandler)用自己EventHandler ，那么你会删除默认的处理程序。 除非您再处理该属性（或相关数据源）的回写，否则不会发生任何事情。 您可以通过使用Node.addEventHandler(javafx.event.EventType, javafx.event.EventHandler)方法添加一个EDIT_COMMIT_EVENT EventType与您所需的EventHandler作为第二个参数。 使用此方法，您将不会替换默认实现，但在发生编辑提交时会收到通知。

    希望这个总结回答了一些常见问题。 幸运的是，JavaFX附带了许多预先构建的单元格工厂，可以代表您处理所有的编辑要求。 您可以在javafx.scene.control.cell包中找到这些预构建的单元工厂。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TreeItem ， TreeCell

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Callback<TreeView<T>,TreeCell<T>>> cellFactory
      表示将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
      BooleanProperty editable
      指定此TreeView是否可编辑 - 只有当TreeView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
      ReadOnlyObjectProperty<TreeItem<T>> editingItem
      用于表示当前在TreeView中编辑的TreeItem的属性，如果正在进行编辑，或者如果没有编辑任何项目，则为null。
      ReadOnlyIntegerProperty expandedItemCount
      表示当前能够在TreeView中可见的树节点数。
      DoubleProperty fixedCellSize
      指定此控件是否具有固定高度（指定值）的单元格。
      ObjectProperty<FocusModel<TreeItem<T>>> focusModel
      FocusModel提供API，通过它可以将焦点控制在零行或一行TreeView。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditCancel
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditCommit
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditStart
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollTo
      当有请求使用 scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<TreeItem<T>> root
      表示TreeView根节点的属性。
      ObjectProperty<MultipleSelectionModel<TreeItem<T>>> selectionModel
      SelectionModel提供了可以在TreeView中选择单个或多个项目的API，以及检查用户选择了哪些行。
      BooleanProperty showRoot
      表示TreeView根节点是否可见的属性。

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TreeView.EditEvent<T>
      一个Event在TreeView中专门用于表示编辑相关事件的子类。

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeView​()
      创建一个空TreeView。
      TreeView​(TreeItem<T> root)
      使用提供的根节点创建TreeView。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Callback<TreeView<T>,TreeCell<T>>> cellFactoryProperty​()
      表示将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      void edit​(TreeItem<T> item)
      指示TreeView开始编辑给定的TreeItem，如果TreeView是 editable 。
      BooleanProperty editableProperty​()
      指定此TreeView是否可编辑 - 只有当TreeView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
      static <T> EventType<TreeView.EditEvent<T>> editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <T> EventType<TreeView.EditEvent<T>> editCancelEvent​()
      EventType用于指示事件被触发的TreeView中刚刚取消了编辑事件。
      static <T> EventType<TreeView.EditEvent<T>> editCommitEvent​()
      用于指示TreeView中的编辑已提交的EventType。
      ReadOnlyObjectProperty<TreeItem<T>> editingItemProperty​()
      用于表示当前在TreeView中编辑的TreeItem的属性，如果正在进行编辑，或者如果没有编辑任何项目，则为null。
      static <T> EventType<TreeView.EditEvent<T>> editStartEvent​()
      EventType用于指示在事件触发的TreeView中启动了编辑事件。
      ReadOnlyIntegerProperty expandedItemCountProperty​()
      表示当前能够在TreeView中可见的树节点数。
      DoubleProperty fixedCellSizeProperty​()
      指定此控件是否具有固定高度（指定值）的单元格。
      ObjectProperty<FocusModel<TreeItem<T>>> focusModelProperty​()
      FocusModel提供API，通过它可以将焦点控制在零行或一行TreeView。
      Callback<TreeView<T>,TreeCell<T>> getCellFactory​()
      返回用于创建TreeCells的单元格工厂，用于表示TreeView中的项目，如果未设置自定义单元格工厂，则返回null。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> | getControlCssMetaData​()
      TreeItem<T> getEditingItem​()
      返回TreeView中当前正在编辑的TreeItem，如果没有编辑任何项目，则返回null。
      int getExpandedItemCount​()
      获取属性expandedItemCount的值。
      double getFixedCellSize​()
      返回固定的单元格大小值。
      FocusModel<TreeItem<T>> getFocusModel​()
      返回当前安装的FocusModel 。
      static int getNodeLevel​(TreeItem<?> node)
      已过时。
      此方法无法正确计算从给定TreeItem到TreeView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过getTreeItemLevel(TreeItem)
      EventHandler<TreeView.EditEvent<T>> getOnEditCancel​()
      返回当用户取消编辑时将被调用的EventHandler 。
      EventHandler<TreeView.EditEvent<T>> getOnEditCommit​()
      返回当用户提交编辑时将被调用的EventHandler 。
      EventHandler<TreeView.EditEvent<T>> getOnEditStart​()
      返回当用户开始编辑时将被调用的EventHandler 。
      EventHandler<ScrollToEvent<Integer>> getOnScrollTo​()
      获取属性onScrollTo的值。
      TreeItem<T> getRoot​()
      返回此TreeView的当前根节点，如果未指定根节点，则返回null。
      int getRow​(TreeItem<T> item)
      返回给定TreeItem的索引位置，假设它目前可通过树层次结构访问（最显着的是所有父树项目都被扩展）。
      MultipleSelectionModel<TreeItem<T>> getSelectionModel​()
      返回当前安装的选择模型。
      TreeItem<T> getTreeItem​(int row)
      返回给定索引中的TreeItem，如果超出范围则返回null。
      int getTreeItemLevel​(TreeItem<?> node)
      根据getParent（）可以递归调用的次数，返回给定TreeItem的“缩进”级别数。
      boolean isEditable​()
      获取可编辑属性的值。
      boolean isShowRoot​()
      如果应该显示TreeView的根，则返回true，否则返回false。
      protected void layoutChildren​()
      在布局传递期间调用这个 Parent的孩子进行布局。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditCommitProperty​()
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty​()
      当有请求使用 scrollTo(int)将索引滚动到视图时 调用
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void refresh​()
      调用 refresh()强制TreeView控件重新创建并重新填充填充控件的可视边界所需的单元格。
      ObjectProperty<TreeItem<T>> rootProperty​()
      表示TreeView根节点的属性。
      void scrollTo​(int index)
      滚动TreeView，使给定索引中的项目对最终用户可见。
      ObjectProperty<MultipleSelectionModel<TreeItem<T>>> selectionModelProperty​()
      SelectionModel提供了可以在TreeView中选择单个或多个项目的API，以及检查用户选择了哪些行。
      void setCellFactory​(Callback<TreeView<T>,TreeCell<T>> value)
      设置将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
      void setEditable​(boolean value)
      设置属性可编辑的值。
      void setFixedCellSize​(double value)
      设置此控件的新固定单元格大小。
      void setFocusModel​(FocusModel<TreeItem<T>> value)
      设置要在TreeView中使用的FocusModel 。
      void setOnEditCancel​(EventHandler<TreeView.EditEvent<T>> value)
      设置当用户取消编辑时将被调用的EventHandler 。
      void setOnEditCommit​(EventHandler<TreeView.EditEvent<T>> value)
      设置当用户提交编辑时将被调用的EventHandler 。
      void setOnEditStart​(EventHandler<TreeView.EditEvent<T>> value)
      设置当用户开始编辑时将被调用的EventHandler 。
      void setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void setRoot​(TreeItem<T> value)
      设置此TreeView中的根节点。
      void setSelectionModel​(MultipleSelectionModel<TreeItem<T>> value)
      设置要在TreeView中使用的MultipleSelectionModel 。
      void setShowRoot​(boolean value)
      指定是否应在此TreeView中显示根 TreeItem根。
      BooleanProperty showRootProperty​()
      表示TreeView根节点是否可见的属性。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getContextMenu, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • cellFactory

        public final ObjectProperty<Callback<TreeView<T>,TreeCell<T>>> cellFactoryProperty
        表示将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
        结果
        电池厂属性

      • root

        public final ObjectProperty<TreeItem<T>> rootProperty
        表示TreeView根节点的属性。
        另请参见：
        getRoot() ， setRoot(TreeItem)

      • showRoot

        public final BooleanProperty showRootProperty
        表示TreeView根节点是否可见的属性。
        另请参见：
        isShowRoot() ， setShowRoot(boolean)

      • selectionModel

        public final ObjectProperty<MultipleSelectionModel<TreeItem<T>>> selectionModelProperty
        SelectionModel提供了可以在TreeView中选择单个或多个项目的API，以及检查用户选择了哪些行。 请注意，它有一个通用类型，必须与TreeView本身的类型相匹配。
        另请参见：
        getSelectionModel() ， setSelectionModel(MultipleSelectionModel)

      • focusModel

        public final ObjectProperty<FocusModel<TreeItem<T>>> focusModelProperty
        FocusModel提供API，通过它可以将焦点控制在零行或一行TreeView。 通常默认的实现应该是足够的。
        另请参见：
        getFocusModel() ， setFocusModel(FocusModel)

      • expandedItemCount

        public final ReadOnlyIntegerProperty expandedItemCountProperty

        表示当前能够在TreeView中可见的树节点数。 这实质上是所有扩展的树项目及其子项的计数。

        例如，如果只有根节点可见，则expandItemCount将为1。 如果根有三个孩子并且根被扩大，那么这个值将是四个。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getExpandedItemCount()

      • fixedCellSize

        public final DoubleProperty fixedCellSizeProperty
        指定此控件是否具有固定高度（指定值）的单元格。 如果该值小于或等于零，则所有单元格都被单独设置和定位。 这是一个缓慢的操作。 因此，当性能重要且开发人员不依赖于可变单元大小时，设置固定单元大小值是一个好主意。 一般情况下，单元格大约为24像素，因此设置固定的单元格大小为24可能导致视觉差异很小，但性能有所改善。

        要通过CSS设置此属性，请使用-fx-fixed-cell-size属性。 这不应该与-fx-cell-size属性混淆。 这两个CSS属性之间的区别是-fx-cell-size将所有单元格的大小设置为指定的大小，但不会强制这是唯一的大小（从而允许变量单元大小，并且阻止性能提升可能）。 因此，当性能很重要的时候使用-fx-fixed-cell-size，而不是-fx-cell-size。 如果在CSS中指定了两个属性，则-fx-fixed-cell-size优先。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • editable

        public final BooleanProperty editableProperty
        指定此TreeView是否可编辑 - 只有当TreeView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
        另请参见：
        isEditable() ， setEditable(boolean)

      • editingItem

        public final ReadOnlyObjectProperty<TreeItem<T>> editingItemProperty

        用于表示当前在TreeView中编辑的TreeItem的属性，如果正在进行编辑，或者如果没有编辑任何项目，则为null。

        不可能设置编辑项，而需要调用edit(javafx.scene.control.TreeItem) 。

        另请参见：
        getEditingItem()

      • onEditStart

        public final ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditStartProperty
        当用户成功启动编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditStart() ， setOnEditStart(EventHandler)

      • onEditCommit

        public final ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditCommitProperty

        当用户执行应导致其编辑输入持久化的操作时，将使用此属性。

        此属性中的EventHandler不应该直接调用， 而是从您的自定义TreeCell中调用TreeCell.commitEdit(java.lang.Object) 。 这将处理触发此事件，更新视图和切换编辑状态。

        另请参见：
        getOnEditCommit() ， setOnEditCommit(EventHandler)

      • onEditCancel

        public final ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditCancelProperty
        当用户取消编辑单元格时，将触发此事件处理程序。
        另请参见：
        getOnEditCancel() ， setOnEditCancel(EventHandler)

      • onScrollTo

        public ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty
        当有请求使用 scrollTo(int)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnScrollTo() ， setOnScrollTo(EventHandler)

    • 构造方法详细信息

      • TreeView

        public TreeView​()
        创建一个空TreeView。

        有关其他属性的默认状态的详细信息，请参阅TreeView类文档。

      • TreeView

        public TreeView​(TreeItem<T> root)
        使用提供的根节点创建TreeView。

        有关其他属性的默认状态的详细信息，请参阅TreeView类文档。

        参数
        root - 该节点作为此TreeView中的根。

    • 方法详细信息

      • editAnyEvent

        public static <T> EventType<TreeView.EditEvent<T>> editAnyEvent​()
        指示发生一些编辑事件的EventType。 这是所有其他编辑的事件父类型： editStartEvent() ， editCommitEvent()和editCancelEvent() 。
        参数类型
        T - 此TreeView中使用的TreeItem实例的类型
        结果
        指示发生一些编辑事件的EventType。

      • editStartEvent

        public static <T> EventType<TreeView.EditEvent<T>> editStartEvent​()
        EventType用于指示在事件触发的TreeView中启动了编辑事件。
        参数类型
        T - 此TreeView中使用的TreeItem实例的类型
        结果
        用于指示编辑事件已启动的EventType。

      • editCancelEvent

        public static <T> EventType<TreeView.EditEvent<T>> editCancelEvent​()
        EventType用于指示事件被触发的TreeView中刚刚取消了编辑事件。
        参数类型
        T - 此TreeView中使用的TreeItem实例的类型
        结果
        用于指示编辑事件刚刚被取消的EventType。

      • editCommitEvent

        public static <T> EventType<TreeView.EditEvent<T>> editCommitEvent​()
        用于指示TreeView中的编辑已提交的EventType。 这意味着用户对TreeItem的数据进行了更改，UI应该被更新。
        参数类型
        T - 此TreeView中使用的TreeItem实例的类型
        结果
        用于指示TreeView中的编辑已提交的EventType。

      • getNodeLevel

        @Deprecated(since="8u20")
public static int getNodeLevel​(TreeItem<?> node)
        已过时。 此方法无法正确计算从给定TreeItem到TreeView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过getTreeItemLevel(TreeItem)
        返回给定TreeItem的“缩进”级别数，基于可以递归调用的次数TreeItem.getParent() 。 如果TreeItem没有任何父集，则返回的值将为零。 对于每次递归调用getParent（），返回的值都将增加1。

        重要注意事项：此方法已被弃用，因为它不考虑根节点。 这意味着如果根节点有父节点，则此方法将遍历TreeView控件的根节点。 如果这很重要，请拨打getTreeItemLevel(TreeItem) 。

        参数
        node - 需要级别的TreeItem。
        结果
        表示给定节点上父节点数的整数，如果给定的TreeItem为空，则为-1。

      • setCellFactory

        public final void setCellFactory​(Callback<TreeView<T>,TreeCell<T>> value)
        设置将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。 该工厂与ListView中的cellFactory和其他复杂的复合控件相同。 只有当系统确定没有足够的单元格来表示当前可见的项目时，才需要创建一个新的TreeCell。 TreeCell被系统重用，可以在树中表示不同的项目。

        有关详细信息，请参阅Cell课程文档。

        参数
        value - 用于生成TreeCell实例的Callback ，如果应使用默认单元格工厂，则为null。

      • getCellFactory

        public final Callback<TreeView<T>,TreeCell<T>> getCellFactory​()

        返回用于创建TreeCells的单元格工厂，用于表示TreeView中的项目，如果未设置自定义单元格工厂，则返回null。

        结果
        电池厂

      • cellFactoryProperty

        public final ObjectProperty<Callback<TreeView<T>,TreeCell<T>>> cellFactoryProperty​()
        表示将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
        结果
        电池厂属性

      • setRoot

        public final void setRoot​(TreeItem<T> value)
        设置此TreeView中的根节点。 有关更多详细信息，请参阅TreeItem类级别的文档。
        参数
        value - 将放置在TreeView根目录的TreeItem 。

      • getRoot

        public final TreeItem<T> getRoot​()
        返回此TreeView的当前根节点，如果未指定根节点，则返回null。
        结果
        当前根节点，如果没有根节点存在则为null。

      • rootProperty

        public final ObjectProperty<TreeItem<T>> rootProperty​()
        表示TreeView根节点的属性。
        另请参见：
        getRoot() ， setRoot(TreeItem)

      • setShowRoot

        public final void setShowRoot​(boolean value)
        指定是否应在此TreeView中显示根 TreeItem根。
        参数
        value - 如果为true，则将显示根 value ，如果为false，则它将被隐藏。

      • isShowRoot

        public final boolean isShowRoot​()
        如果应该显示TreeView的根，则返回true，否则返回false。 默认情况下，TreeView中的根树项目可见。
        结果
        如果应该显示TreeView的根，则为true

      • showRootProperty

        public final BooleanProperty showRootProperty​()
        表示TreeView根节点是否可见的属性。
        另请参见：
        isShowRoot() ， setShowRoot(boolean)

      • setSelectionModel

        public final void setSelectionModel​(MultipleSelectionModel<TreeItem<T>> value)
        设置要在TreeView中使用的MultipleSelectionModel 。 尽管TreeView需要MultipleSelectionModel ，但可以将其配置为仅允许单次选择（有关详细信息，请参阅MultipleSelectionModel.setSelectionMode(javafx.scene.control.SelectionMode) ）。
        参数
        value - 要使用的MultipleSelectionModel

      • getSelectionModel

        public final MultipleSelectionModel<TreeItem<T>> getSelectionModel​()
        返回当前安装的选择模型。
        结果
        当前安装的选择模型

      • selectionModelProperty

        public final ObjectProperty<MultipleSelectionModel<TreeItem<T>>> selectionModelProperty​()
        SelectionModel提供了可以在TreeView中选择单个或多个项目的API，以及检查用户选择了哪些行。 请注意，它有一个通用类型，必须与TreeView本身的类型相匹配。
        另请参见：
        getSelectionModel() ， setSelectionModel(MultipleSelectionModel)

      • setFocusModel

        public final void setFocusModel​(FocusModel<TreeItem<T>> value)
        设置要在TreeView中使用的FocusModel 。
        参数
        value - 要使用的FocusModel

      • getFocusModel

        public final FocusModel<TreeItem<T>> getFocusModel​()
        返回当前安装的FocusModel 。
        结果
        目前安装的FocusModel

      • focusModelProperty

        public final ObjectProperty<FocusModel<TreeItem<T>>> focusModelProperty​()
        FocusModel提供API，通过它可以将焦点控制在零行或一行TreeView。 通常默认的实现应该是足够的。
        另请参见：
        getFocusModel() ， setFocusModel(FocusModel)

      • expandedItemCountProperty

        public final ReadOnlyIntegerProperty expandedItemCountProperty​()

        表示当前能够在TreeView中可见的树节点数。 这实质上是所有扩展的树项目及其子项的计数。

        例如，如果只有根节点可见，则expandItemCount将为1。 如果根有三个孩子并且根被扩大，那么这个值将是四个。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getExpandedItemCount()

      • getExpandedItemCount

        public final int getExpandedItemCount​()
        获取属性expandedItemCount的值。
        Property description:

        表示当前能够在TreeView中可见的树节点数。 这实质上是所有扩展的树项目及其子项的计数。

        例如，如果只有根节点可见，则expandItemCount将为1。 如果根有三个孩子并且根被扩大，那么这个值将是四个。

        从以下版本开始：
        JavaFX 8.0

      • setFixedCellSize

        public final void setFixedCellSize​(double value)
        设置此控件的新固定单元格大小。 任何大于零的值将启用固定的单元大小模式，而零值或负值（或Region.USE_COMPUTED_SIZE）将用于禁用固定单元大小模式。
        参数
        value - 新的固定单元格大小值，或小于或等于零（或Region.USE_COMPUTED_SIZE）的值禁用。
        从以下版本开始：
        JavaFX 8.0

      • getFixedCellSize

        public final double getFixedCellSize​()
        返回固定的单元格大小值。 使用小于或等于零的值来表示禁用固定单元大小模式，大于零的值表示此控件中所有单元格的大小。
        结果
        表示该控件的固定单元大小的double，或者如果固定单元大小模式被禁用，小于或等于零的值。
        从以下版本开始：
        JavaFX 8.0

      • fixedCellSizeProperty

        public final DoubleProperty fixedCellSizeProperty​()
        指定此控件是否具有固定高度（指定值）的单元格。 如果该值小于或等于零，则所有单元格都被单独设置和定位。 这是一个缓慢的操作。 因此，当性能重要且开发人员不依赖于可变单元大小时，设置固定单元大小值是一个好主意。 一般情况下，单元格大约为24像素，因此设置固定的单元格大小为24可能导致视觉差异很小，但性能有所改善。

        要通过CSS设置此属性，请使用-fx-fixed-cell-size属性。 这不应该与-fx-cell-size属性混淆。 这两个CSS属性之间的区别是-fx-cell-size将所有单元格的大小设置为指定的大小，但不会强制这是唯一的大小（从而允许变量单元大小，并且阻止性能提升可能）。 因此，当性能很重要的时候使用-fx-fixed-cell-size，而不是-fx-cell-size。 如果在CSS中指定了两个属性，则-fx-fixed-cell-size优先。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • setEditable

        public final void setEditable​(boolean value)
        设置属性可编辑的值。
        Property description:
        指定此TreeView是否可编辑 - 只有当TreeView和TreeCells都可编辑时，TreeCell才能进入编辑状态。

      • isEditable

        public final boolean isEditable​()
        获取可编辑属性的值。
        Property description:
        指定此TreeView是否可编辑 - 只有当TreeView和TreeCells都可编辑时，TreeCell才能进入编辑状态。

      • editableProperty

        public final BooleanProperty editableProperty​()
        指定此TreeView是否可编辑 - 只有当TreeView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
        另请参见：
        isEditable() ， setEditable(boolean)

      • getEditingItem

        public final TreeItem<T> getEditingItem​()
        返回TreeView中当前正在编辑的TreeItem，如果没有编辑任何项目，则返回null。
        结果
        TreeView中当前正在编辑的TreeItem

      • editingItemProperty

        public final ReadOnlyObjectProperty<TreeItem<T>> editingItemProperty​()

        用于表示当前在TreeView中编辑的TreeItem的属性，如果正在进行编辑，或者如果没有编辑任何项目，则为null。

        不可能设置编辑项，而需要调用edit(javafx.scene.control.TreeItem) 。

        另请参见：
        getEditingItem()

      • setOnEditStart

        public final void setOnEditStart​(EventHandler<TreeView.EditEvent<T>> value)
        设置当用户开始编辑时将被调用的EventHandler 。
        参数
        value - 当用户开始编辑时将被调用的EventHandler

      • getOnEditStart

        public final EventHandler<TreeView.EditEvent<T>> getOnEditStart​()
        返回当用户开始编辑时将被调用的EventHandler 。
        结果
        EventHandler当用户开始编辑时

      • onEditStartProperty

        public final ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditStartProperty​()
        当用户成功启动编辑时，会触发此事件处理程序。
        另请参见：
        getOnEditStart() ， setOnEditStart(EventHandler)

      • setOnEditCommit

        public final void setOnEditCommit​(EventHandler<TreeView.EditEvent<T>> value)
        设置当用户提交编辑时将被调用的EventHandler 。
        参数
        value - 当用户提交编辑时将被调用的EventHandler

      • getOnEditCommit

        public final EventHandler<TreeView.EditEvent<T>> getOnEditCommit​()
        返回当用户提交编辑时将被调用的EventHandler 。
        结果
        当用户提交编辑时将被调用的EventHandler

      • onEditCommitProperty

        public final ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditCommitProperty​()

        当用户执行应导致其编辑输入持久化的操作时，将使用此属性。

        此属性中的EventHandler不应该直接调用 - 而是从您的自定义TreeCell中调用TreeCell.commitEdit(java.lang.Object) 。 这将处理触发此事件，更新视图和切换编辑状态。

        另请参见：
        getOnEditCommit() ， setOnEditCommit(EventHandler)

      • setOnEditCancel

        public final void setOnEditCancel​(EventHandler<TreeView.EditEvent<T>> value)
        设置当用户取消编辑时将被调用的EventHandler 。
        参数
        value - 当用户取消编辑时将被调用的EventHandler

      • getOnEditCancel

        public final EventHandler<TreeView.EditEvent<T>> getOnEditCancel​()
        返回当用户取消编辑时将被调用的EventHandler 。
        结果
        当用户取消编辑时将被调用的EventHandler

      • onEditCancelProperty

        public final ObjectProperty<EventHandler<TreeView.EditEvent<T>>> onEditCancelProperty​()
        当用户取消编辑单元格时，将触发此事件处理程序。
        另请参见：
        getOnEditCancel() ， setOnEditCancel(EventHandler)

      • layoutChildren

        protected void layoutChildren​()
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Control

      • edit

        public void edit​(TreeItem<T> item)
        指示TreeView开始编辑给定的TreeItem，如果TreeView是editable 。 一旦调用此方法，如果当前的cell factory设置为支持编辑，Cell将切换其视觉状态以使用户输入。
        参数
        item - 应该编辑的TreeView中的TreeItem。

      • scrollTo

        public void scrollTo​(int index)
        滚动TreeView，使给定索引中的项目对最终用户可见。
        参数
        index - 应该对用户可见的索引，假定它大于或等于0，小于TreeView中可见项的数量。

      • setOnScrollTo

        public void setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
        设置属性onScrollTo的值。
        Property description:
        当有请求使用 scrollTo(int)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0

      • getOnScrollTo

        public EventHandler<ScrollToEvent<Integer>> getOnScrollTo​()
        获取属性onScrollTo的值。
        Property description:
        当有请求使用 scrollTo(int)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0

      • onScrollToProperty

        public ObjectProperty<EventHandler<ScrollToEvent<Integer>>> onScrollToProperty​()
        当有请求使用 scrollTo(int)将索引滚动到视图时 调用
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnScrollTo() ， setOnScrollTo(EventHandler)

      • getRow

        public int getRow​(TreeItem<T> item)
        返回给定TreeItem的索引位置，假设它目前可通过树层次结构访问（最显着的是所有父树项目都被扩展）。 如果父树项目被折叠，则结果是该方法将返回-1以指示树中不可访问给定树项。
        参数
        item - 寻找索引的TreeItem。
        结果
        一个整数，表示给定TreeItem的第一个实例的当前TreeView中的位置，如果为null，或者不能找到，则为-1（例如，如果父（一直到根）已折叠）。

      • getTreeItem

        public TreeItem<T> getTreeItem​(int row)
        返回给定索引中的TreeItem，如果超出范围则返回null。
        参数
        row - 正在寻找TreeItem的索引。
        结果
        给定索引中的TreeItem，如果超出范围，则为null。

      • getTreeItemLevel

        public int getTreeItemLevel​(TreeItem<?> node)
        根据getParent（）可以递归调用的次数，返回给定TreeItem的“缩进”级别数。 如果给定的TreeItem是此TreeView的根节点，或者如果TreeItem没有任何父集，则返回的值将为零。 对于每次递归调用getParent（），返回的值都将增加1。
        参数
        node - 需要级别的TreeItem。
        结果
        表示给定节点上父节点数的整数，如果给定的TreeItem为空，则为-1。

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤，或者在具有setSkin(...)的子类中显式设置，则调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • refresh

        public void refresh​()
        调用refresh()强制TreeView控件重新创建并重新填充填充控件的可视边界所需的单元格。 换句话说，这会强制TreeView更新它向用户显示的内容。 这在底层数据源以TreeView本身未观察到的方式发生更改的情况下很有用。
        从以下版本开始：
        JavaFX 8u60

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getControlCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getControlCssMetaData​()
        重写：
        getControlCssMetaData中的 Control
        结果
        不可修改的控件列表css样式属性
        从以下版本开始：
        JavaFX 8.0

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Control
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeView.EditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control

Class TreeView.EditEvent<T>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.control.TreeView.EditEvent<T>
  • 参数类型
    T - 输入的类型，与TreeView本身的类型相同。
    All Implemented Interfaces:
    Serializable ， Cloneable
    Enclosing class:
    TreeView < T >

    public static class TreeView.EditEvent<T>
extends Event
    一个Event在TreeView中专门用于表示编辑相关事件的子类。 它提供了额外的API来轻松访问编辑事件发生的TreeItem，以及最终用户提供的输入。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<?> ANY
      所有编辑事件类型的公共超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

    • 构造方法摘要

      构造方法
      Constructor 描述
      EditEvent​(TreeView<T> source, EventType<? extends TreeView.EditEvent> eventType, TreeItem<T> treeItem, T oldValue, T newValue)
      创建一个新的EditEvent实例来表示编辑事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T getNewValue​()
      返回最终用户输入到TreeItem的新值。
      T getOldValue​()
      返回在当前编辑事件之前的TreeItem中存在的旧值。
      TreeView<T> getSource​()
      返回发生编辑的TreeView。
      TreeItem<T> getTreeItem​()
      返回编辑发生的TreeItem 。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<?> ANY
        所有编辑事件类型的公共超类型。
        从以下版本开始：
        JavaFX 8.0

    • 构造方法详细信息

      • EditEvent

        public EditEvent​(TreeView<T> source,
                 EventType<? extends TreeView.EditEvent> eventType,
                 TreeItem<T> treeItem,
                 T oldValue,
                 T newValue)
        创建一个新的EditEvent实例来表示编辑事件。 此事件是用于TreeView.EDIT_START_EVENT ， TreeView.EDIT_COMMIT_EVENT和TreeView.EDIT_CANCEL_EVENT类型。
        参数
        source - 来源
        eventType - eventType
        treeItem - 树项目
        oldValue - oldValue
        newValue - newValue

    • 方法详细信息

      • getSource

        public TreeView<T> getSource​()
        返回发生编辑的TreeView。
        重写：
        getSource在 EventObject
        结果
        事件最初发生的对象。

      • getTreeItem

        public TreeItem<T> getTreeItem​()
        返回发生编辑的TreeItem 。
        结果
        编辑发生在的TreeItem

      • getNewValue

        public T getNewValue​()
        返回最终用户输入到TreeItem的新值。
        结果
        最终用户输入TreeItem的新值

      • getOldValue

        public T getOldValue​()
        返回在当前编辑事件之前的TreeItem中存在的旧值。
        结果
        在当前编辑事件之前的TreeItem中存在的旧值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.control (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.control

  • Packages that use javafx.scene.control
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
  • Classes in javafx.scene.control used by javafx.scene.control
    Class 描述
    Alert.AlertType
    包含Alert类可用于预先填充各种属性的可用的预构建警报类型的枚举 。
    ButtonBar.ButtonData
    枚举所有可用的按钮数据注释。
    ButtonBase
    按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
    ButtonType
    ButtonType类用作JavaFX Dialog API（更具体地说是DialogPane API）的一部分，用于指定在对话框中向用户显示哪些按钮。
    Cell
    细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
    CheckBoxTreeItem
    TreeItem子类增加了在选定的，未选择的和不确定的状态中的支持。
    CheckBoxTreeItem.TreeModificationEvent
    一个TreeModificationEvent类，类似于TreeItem.TreeModificationEvent类，因为该事件将引发 CheckBoxTreeItem层次结构，直到父节点为空。
    ComboBoxBase
    ComboBox类控件的抽象基类。
    ContentDisplay
    将内容放置在标签内的位置。
    ContextMenu
    一个包含菜单项的ObservableList的弹出控件。
    Control
    所有用户界面控件的基类。
    CustomMenuItem
    A MenuItem允许通过为content属性分配一个Node来嵌入任意节点。
    DateCell
    DateCell由DatePicker用于在日历月中呈现单个网格单元格。
    DatePicker
    DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
    Dialog
    JavaFX中的Dialog包装了一个DialogPane，并提供必要的API来将其呈现给最终用户。
    DialogEvent
    与对话框显示/隐藏操作相关的事件。
    DialogPane
    DialogPane应该被认为是在一个Dialog实例中显示的根节点 。
    FocusModel
    FocusModel实现的抽象基类。
    IndexedCell
    一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。
    IndexRange
    表示整数值的连续范围的类。
    Labeled
    标签Control是其用户界面的一部分，与其相关联的文本内容。
    ListCell
    Cell类型中使用的ListView实例。
    ListView
    ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
    ListView.EditEvent
    一个Event子类，专门用于ListView中用于表示编辑相关事件。
    Menu
    可触发的项目的弹出菜单，仅根据请求向用户显示。
    MenuButton
    MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
    MenuItem
    MenuItem旨在与Menu结合使用，为用户提供选项。
    MultipleSelectionModel
    一个抽象类，扩展SelectionModel以添加API以支持多选。
    OverrunStyle
    当渲染文本的空间小于渲染整个字符串所需的空间时，定义标记的控件的行为。
    PopupControl
    PopupWindow的扩展，允许CSS样式。
    PopupControl.CSSBridge
    弹出窗口和场景图之间的链接。
    ProgressIndicator
    用于指示进度的循环控制，无限（也称为不确定）或有限。
    ResizeFeaturesBase
    列使用的不可变包装类可调整由控件（如TableView和TreeTableView）提供的策略大小。
    ScrollPane.ScrollBarPolicy
    表示可滚动控件在决定是否显示滚动条时使用的策略的枚举。
    ScrollToEvent
    事件相关ScrollPane所虚拟化控制，比如ListView ， TableView ， TreeView和TreeTableView 。
    SelectionMode
    用于指定在MultipleSelectionModel中可以选择多少项目的枚举 。
    SelectionModel
    SelectionModel是UI控件用来提供一致的API来维护选择的抽象类。
    SingleSelectionModel
    一个SelectionModel，它强制要求在任何给定的时间只选择一个索引。
    Skin
    基类通过定义节点的场景图来定义用户界面控件的视觉表示，以表示皮肤。
    Skinnable
    Skinnable接口由Control类实现，因此由所有Control实现实现。
    SortEvent
    事件涉及TableView和TreeTableView排序。
    SpinnerValueFactory
    SpinnerValueFactory是JavaFX Spinner control后面的模型 - 没有值工厂安装的Spinner不可用。
    SplitPane.Divider
    在SplitPane中代表一个分隔符。
    Tab
    标签放置在TabPane中 ，其中每个选项卡表示单个“页面”。
    TableCell
    在TableView中表示单行/列交集。
    TableColumn
    A TableView由多个TableColumn实例组成。
    TableColumn.CellDataFeatures
    在TableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。
    TableColumn.CellEditEvent
    用户在表单元格上执行编辑时触发的事件。
    TableColumn.SortType
    枚举，指定应用于特定列的排序类型。
    TableColumnBase
    表类控件（如TableView和TreeTableView ）由零个或多个具体TableColumnBase子类（ TableColumn和TreeTableColumn ）的实例组成。
    TableFocusModel
    FocusModel实现的抽象基类，用于表类控件（最着名的是TableView和TreeTableView） 。
    TablePosition
    此类用于表示TableView中的单个行/列/单元格。
    TablePositionBase
    此类用于表示表中的单个行/列/单元格。
    TableRow
    TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
    TableSelectionModel
    用于表类控件中的MultipleSelectionModel实现的抽象基类（最着名的是TableView和TreeTableView） 。
    TableView
    TableView控件旨在可视化无限数量的数据行，分为列。
    TableView.ResizeFeatures
    用于TableView column resize功能的不可变包装类。
    TableView.TableViewFocusModel
    A FocusModel具有附加功能，可支持TableView控件的要求。
    TableView.TableViewSelectionModel
    SelectionModel抽象类的简单扩展，允许对TableView控件的特殊支持。
    TabPane
    一个允许在一组Tabs之间切换的控件 。
    TabPane.TabClosingPolicy
    这指定了TabPane如何处理从最终用户角度看待标签关闭。
    TextField
    文本输入组件，允许用户输入一行未格式化的文本。
    TextFormatter
    格式化器通过使用两种不同的机制来描述 TextInputControl文本的格式：可以拦截和修改用户输入的过滤器（ TextFormatter.getFilter() ）。
    TextFormatter.Change
    包含表示TextInputControl的内容或选择更改的状态。
    TextInputControl
    文本输入控件的抽象基类。
    TextInputControl.Content
    界面表示文本输入的内容。
    TitledPane
    TitledPane是一个可以打开和关闭的标题的面板。
    Toggle
    表示可以在选定状态和未选择状态之间切换的控件。
    ToggleButton
    A ToggleButton是具有选择能力的专业控制。
    ToggleGroup
    它包含所有的引用的类 Toggles其 selected变量应该被管理，使得仅仅单个 Toggle的内 ToggleGroup可以在任一周时间来选择。
    Tooltip
    工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。
    TreeCell
    Cell类型与TreeView控件一起使用。
    TreeItem
    单个节点的模型为诸如TreeView之类的控件提供值的层次结构。
    TreeItem.TreeModificationEvent
    一个Event ，其中包含所有形式的TreeItem修改的相关信息。
    TreeSortMode
    指定如何对树状UI控件中的树项进行排序。
    TreeTableCell
    在TreeTableView中表示单行/列交集。
    TreeTableColumn
    A TreeTableView由多个TreeTableColumn实例组成。
    TreeTableColumn.CellDataFeatures
    在TreeTableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。
    TreeTableColumn.CellEditEvent
    用户在表单元格上执行编辑时触发的事件。
    TreeTableColumn.SortType
    枚举，指定应用于特定列的排序类型。
    TreeTablePosition
    此类用于在TreeTableView中表示单个行/列/单元格。
    TreeTableRow
    TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
    TreeTableView
    TreeTableView控件旨在可视化无限数量的数据行，分为列。
    TreeTableView.EditEvent
    一个Event在TreeTableView中专门用于表示编辑相关事件的子类。
    TreeTableView.ResizeFeatures
    用于TableView column resize功能的不可变包装类。
    TreeTableView.TreeTableViewFocusModel
    A FocusModel具有附加功能以支持TableView控件的要求。
    TreeTableView.TreeTableViewSelectionModel
    SelectionModel抽象类的简单扩展，以允许对TreeTableView控件的特殊支持。
    TreeView
    TreeView控件提供了一个树根视图（ TreeItem型）。
    TreeView.EditEvent
    一个Event在TreeView中专门用于表示编辑相关事件的子类。
  • Classes in javafx.scene.control used by javafx.scene.control.cell
    Class 描述
    Cell
    细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
    Control
    所有用户界面控件的基类。
    IndexedCell
    一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。
    Labeled
    标签Control是与其用户界面的一部分相关联的文本内容。
    ListCell
    Cell类型在ListView中使用。
    ListView
    ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
    Skinnable
    Skinnable接口由Control类实现，因此由所有Control实现实现。
    TableCell
    表示TableView中的单行 /列交集。
    TableColumn
    A TableView由多个TableColumn实例组成。
    TableColumn.CellDataFeatures
    在TableColumn中使用的支持类作为包装类，可以为特定的Cell提供所有必要的信息。
    TreeCell
    Cell类型与TreeView控件一起使用。
    TreeItem
    单个节点的模型为诸如TreeView之类的控件提供值的层次结构。
    TreeTableCell
    在TreeTableView中表示单行/列交集。
    TreeTableColumn
    A TreeTableView由多个TreeTableColumn实例组成。
    TreeTableColumn.CellDataFeatures
    在TreeTableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。
    TreeView
    TreeView控件提供了一个树根视图（ TreeItem型）。
  • Classes in javafx.scene.control used by javafx.scene.control.skin
    Class 描述
    Accordion
    手风琴是一组TitlePanes 。
    Button
    一个简单的按钮控件。
    ButtonBar
    ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。
    Cell
    细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
    CheckBox
    三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
    ChoiceBox
    ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
    ColorPicker
    ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
    ComboBox
    针对最常见形式的ComboBox的ComboBoxBase抽象类的实现，其中向用户提供弹出列表以提供他们可以选择的选项。
    ComboBoxBase
    ComboBox类控件的抽象基类。
    ContextMenu
    一个包含菜单项的ObservableList的弹出控件。
    Control
    所有用户界面控件的基类。
    DateCell
    DateCell由DatePicker用于在日历月中呈现单个网格单元格。
    DatePicker
    DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
    Hyperlink
    一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
    IndexedCell
    一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。
    Label
    标签是不可编辑的文本控件。
    Labeled
    标签Control是与其用户界面的一部分相关联的文本内容。
    ListCell
    Cell类型在ListView实例中使用。
    ListView
    ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
    MenuBar
    MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。
    MenuButton
    MenuButton是一个按钮，当被点击或按下时，它将显示一个ContextMenu 。
    Pagination
    分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
    ProgressBar
    ProgressIndator的专业化表示为横杠。
    ProgressIndicator
    用于指示进度的循环控制，无限（也称为不确定）或有限。
    RadioButton
    RadioButtons创建一系列只能选择一个项目的项目。
    ScrollBar
    具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。
    ScrollPane
    提供其内容的滚动，剪切视口的控件。
    Separator
    水平或垂直分隔线。
    Skin
    基类通过定义节点的场景图来定义用户界面控件的视觉表示，以表示皮肤。
    SkinBase
    基本实现类，用于通过定义节点的场景图来定义用户界面控件的可视化表示，以表示skin 。
    Slider
    滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。
    Spinner
    单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。
    SplitMenuButton
    SplitMenuButton，像MenuButton与从菜单中选择MenuItem的概念密切相关。
    SplitPane
    具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
    TableCell
    表示TableView中的单行 /列交集。
    TableColumn
    A TableView由多个TableColumn实例组成。
    TableColumnBase
    表状控件（例如TableView和TreeTableView ）由零个或多个具体TableColumnBase子类（ TableColumn和TreeTableColumn ）的实例组成。
    TableRow
    TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
    TableView
    TableView控件旨在可视化无限数量的数据行，分为列。
    TabPane
    允许在一组Tabs之间切换的控件 。
    TextArea
    文本输入组件，允许用户输入多行纯文本。
    TextField
    文本输入组件，允许用户输入一行未格式化的文本。
    TextInputControl
    文本输入控件的抽象基类。
    TitledPane
    TitledPane是一个可以打开和关闭的标题的面板。
    ToggleButton
    A ToggleButton是具有选择能力的专业控制。
    ToolBar
    ToolBar是一个可以水平或垂直显示项目的控件。
    Tooltip
    工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。
    TreeCell
    Cell类型与TreeView控件一起使用。
    TreeTableCell
    在TreeTableView中表示单行/列交集。
    TreeTableColumn
    A TreeTableView由多个TreeTableColumn实例组成。
    TreeTableRow
    TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
    TreeTableView
    TreeTableView控件旨在可视化无限数量的数据行，分为列。
    TreeView
    TreeView控件提供了一个到根的视图（类型为TreeItem ）。
  • Classes in javafx.scene.control used by javafx.scene.web
    Class 描述
    Control
    所有用户界面控件的基类。
    Skin
    基类通过定义节点的场景图来定义用户界面控件的视觉表示，以表示皮肤。
    SkinBase
    基本实现类，用于通过定义节点的场景图来定义用户界面控件的可视化表示，以表示skin 。
    Skinnable
    Skinnable接口由Control类实现，因此由所有Control实现实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


CheckBoxListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class CheckBoxListCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.ListCell<T>
                    • javafx.scene.control.cell.CheckBoxListCell<T>
  • 参数类型
    T - ListView中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class CheckBoxListCell<T>
extends ListCell<T>
    一个包含一个ListCell实现的类，它在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。

    CheckBoxListCell使用ListView左侧的CheckBox进行呈现，并且与列表项相关的文本占用所有剩余的水平空间。

    要构造这个类的实例，有必要提供一个Callback ，给定一个类型T的对象将返回一个ObservableValue<Boolean> ，表示给定的项是否被选择。 这个ObservableValue将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，而复选框将反映ObservableValue<Boolean>的状态，如果外部更改）。

    请注意，CheckBoxListCell渲染CheckBox“live”，这意味着CheckBox始终是交互式的，可以直接由用户切换。 这意味着单元格不需要输入其editing state （通常由用户双击单元格）。 这方面的一个副作用是，通常的编辑回调（如on edit commit ）将不被调用。 如果要通知更改，建议直接观察CheckBox操作的布尔属性。

    从以下版本开始：
    JavaFX 2.2
    另请参见：
    CheckBox ， ListCell

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。
      ObjectProperty<Callback<T,ObservableValue<Boolean>>> selectedStateCallback
      属性表示由屏幕上显示的复选框绑定的Callback 。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.control.ListCell

        listView

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckBoxListCell​()
      创建一个默认的CheckBoxListCell。
      CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxListCell。
      CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxListCell。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建用于ListView控件的单元格工厂。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      Callback<T,ObservableValue<Boolean>> getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<T,ObservableValue<Boolean>>> selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void setSelectedStateCallback​(Callback<T,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.control.ListCell

        cancelEdit, commitEdit, createDefaultSkin, executeAccessibleAction, getListView, listViewProperty, queryAccessibleAttribute, startEdit, updateListView

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

      • selectedStateCallback

        public final ObjectProperty<Callback<T,ObservableValue<Boolean>>> selectedStateCallbackProperty
        属性表示由屏幕上显示的复选框绑定的Callback 。
        另请参见：
        getSelectedStateCallback() ， setSelectedStateCallback(Callback)

    • 构造方法详细信息

      • CheckBoxListCell

        public CheckBoxListCell​()
        创建一个默认的CheckBoxListCell。

      • CheckBoxListCell

        public CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
        创建一个默认的CheckBoxListCell。
        参数
        getSelectedProperty - A Callback将从ListView中返回一个ObservableValue<Boolean>给定一个项目。

      • CheckBoxListCell

        public CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty,
                        StringConverter<T> converter)
        用自定义字符串转换器创建一个CheckBoxListCell。
        参数
        getSelectedProperty - A Callback ，将从ListView中返回一个ObservableValue<Boolean>项目。
        converter - 给定类型为T的对象的StringConverter将返回一个可以用于可视化表示对象的字符串。

    • 方法详细信息

      • forListView

        public static <T> Callback<ListView<T>,ListCell<T>> forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
        创建用于ListView控件的单元格工厂。 当在ListView中使用时， CheckBoxListCell将使用ListView左侧的“复选框”进行呈现，与列表项相关的文本占用所有剩余的水平空间。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        getSelectedProperty - A Callback ，给定类型T（这是从ListView<T>.items列表中取出的值）的对象将返回表示给定项目是否被选择的ObservableValue<Boolean> 。 这个ObservableValue将双向绑定（这意味着单元格中的CheckBox将根据用户交互设置/取消设置此属性，如果外部改变，CheckBox将反映ObservableValue的状态）。
        结果
        A Callback将返回能够处理ListView项目列表中包含的元素类型的ListCell。

      • forListView

        public static <T> Callback<ListView<T>,ListCell<T>> forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty,
                                                                StringConverter<T> converter)
        创建用于ListView控件的单元格工厂。 当在ListView中使用时， CheckBoxListCell将使用ListView左侧的复选框进行渲染，其中与列表项相关的文本占用所有剩余的水平空间。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        getSelectedProperty - A Callback ，给定一个类型T（这是从ListView<T>.items列表中取出的值）的对象，将返回一个表示给定项目是否被选择的ObservableValue<Boolean> 。 这个ObservableValue将双向绑定（这意味着单元格中的CheckBox将根据用户交互设置/取消设置此属性，如果外部改变，CheckBox将反映ObservableValue的状态）。
        converter - 提供类型为T的对象的StringConverter将返回一个可以用于可视化表示对象的字符串。
        结果
        A Callback将返回能够处理ListView中包含的元素类型的ListCell。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • selectedStateCallbackProperty

        public final ObjectProperty<Callback<T,ObservableValue<Boolean>>> selectedStateCallbackProperty​()
        属性表示由屏幕上显示的复选框绑定的Callback 。
        另请参见：
        getSelectedStateCallback() ， setSelectedStateCallback(Callback)

      • setSelectedStateCallback

        public final void setSelectedStateCallback​(Callback<T,ObservableValue<Boolean>> value)
        设置由屏幕上显示的复选框绑定的Callback 。
        参数
        value - Callback

      • getSelectedStateCallback

        public final Callback<T,ObservableValue<Boolean>> getSelectedStateCallback​()
        返回由屏幕上显示的复选框绑定的Callback 。
        结果
        由屏幕上显示的复选框绑定的Callback

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CheckBoxTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class CheckBoxTableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TableCell<S,T>
                    • javafx.scene.control.cell.CheckBoxTableCell<S,T>
  • 参数类型
    T - TableColumn中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class CheckBoxTableCell<S,T>
extends TableCell<S,T>
    一个包含一个TableCell实现的类，它在单元格内绘制一个CheckBox节点，可选地带有一个标签，表示复选框代表什么。

    默认情况下，CheckBoxTableCell将以CheckColumn中心的CheckBox进行渲染。 如果需要标签，则必须向CheckBoxTableCell(Callback, StringConverter)构造函数提供非空StringConverter实例。

    要构造此类的实例，有必要提供一个Callback ，给定一个类型T的对象将返回一个ObservableProperty<Boolean> ，表示给定项是否被选择。 这个ObservableValue将双向绑定（这意味着单元格中的CheckBox将根据用户交互设置/取消设置此属性，如果外部改变，CheckBox将反映ObservableValue的状态）。

    请注意，CheckBoxTableCell会呈现CheckBox“live”，这意味着CheckBox始终是交互式的，可以由用户直接切换。 这意味着单元格不需要输入其editing state （通常由用户双击单元格）。 这方面的一个副作用是，通常的编辑回调（如on edit commit ）将不被调用。 如果要通知更改，建议直接观察CheckBox操作的布尔属性。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> selectedStateCallback
      属性表示由屏幕上显示的复选框绑定的Callback 。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TableCell

        tableColumn, tableRow, tableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckBoxTableCell​()
      创建一个默认的CheckBoxTableCell。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxTableCell，使用自定义的Callback检索给定单元格索引的ObservableValue。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个带有自定义字符串转换器的CheckBoxTableCell。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <S> Callback<TableColumn<S,Boolean>,TableCell<S,Boolean>> forTableColumn​(TableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个用于TableColumn电池厂的电池厂 。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      Callback<Integer,ObservableValue<Boolean>> getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TableCell

        cancelEdit, commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTableRow, getTableView, layoutChildren, queryAccessibleAttribute, startEdit, tableColumnProperty, tableRowProperty, tableViewProperty, updateSelected, updateTableColumn, updateTableRow, updateTableView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

      • selectedStateCallback

        public final ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> selectedStateCallbackProperty
        属性表示由屏幕上显示的复选框绑定的Callback 。
        另请参见：
        getSelectedStateCallback() ， setSelectedStateCallback(Callback)

    • 构造方法详细信息

      • CheckBoxTableCell

        public CheckBoxTableCell​()
        创建一个默认的CheckBoxTableCell。

      • CheckBoxTableCell

        public CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
        创建一个默认的CheckBoxTableCell与自定义Callback检索给定单元格索引的ObservableValue。
        参数
        getSelectedProperty - A Callback将从TableColumn返回一个ObservableValue的索引。

      • CheckBoxTableCell

        public CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty,
                         StringConverter<T> converter)
        创建一个带有自定义字符串转换器的CheckBoxTableCell。
        参数
        getSelectedProperty - A Callback将从TableColumn返回一个ObservableValue的索引。
        converter - 给定一个类型T的对象的StringConverter将返回一个可以用于可视化表示对象的String。

    • 方法详细信息

      • forTableColumn

        public static <S> Callback<TableColumn<S,Boolean>,TableCell<S,Boolean>> forTableColumn​(TableColumn<S,Boolean> column)
        创建一个用于TableColumn电池厂的电池厂 。 该方法要求TableColumn的类型为Boolean 。

        当在TableColumn中使用时，CheckBoxCell将以列为中心的CheckBox呈现。

        包含在列中每个单元格内的ObservableValue<Boolean>将双向绑定。 这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态。

        参数类型
        S - TableView通用类型的类型
        参数
        column - 类型为Boolean的TableColumn
        结果
        A Callback将返回一个能够处理TableColumn中包含的元素类型的TableCell 。

      • forTableColumn

        public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
        创建一个电池厂 ，用于TableColumn电池厂 。 此方法要求TableColumn的类型为ObservableValue<Boolean> 。

        当在TableColumn中使用时，CheckBoxCell将以列为中心的CheckBox呈现。

        参数类型
        S - TableView通用类型的类型
        T - TableColumn实例中包含的元素的类型。
        参数
        getSelectedProperty - 给定一个类型为TableColumn<S,T>的对象的回调TableColumn<S,T>将返回一个表示给定项目是否被选择的ObservableValue<Boolean> 。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态）。
        结果
        A Callback将返回一个能够处理TableColumn中包含的元素类型的TableCell 。

      • forTableColumn

        public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty,
                                                                             boolean showLabel)
        创建一个电池厂 ，用于TableColumn电池厂 。 此方法要求TableColumn的类型为ObservableValue<Boolean> 。

        当在TableColumn中使用时，CheckBoxCell将以列为中心的CheckBox呈现。

        参数类型
        S - TableView通用类型的类型
        T - TableColumn实例中包含的元素的类型。
        参数
        getSelectedProperty - 给定一个类型为TableColumn<S,T>的对象的回调TableColumn<S,T>将返回一个表示给定项目是否被选择的ObservableValue<Boolean> 。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态）。
        showLabel - 在某些情况下，可能希望在CheckBox旁边的TableCell中显示一个标签。 默认情况下，不显示标签，但通过将其设置为true，单元格中的项目也将在其上调用toString（）。 如果这不是所需的行为，请考虑使用forTableColumn(javafx.util.Callback, javafx.util.StringConverter) ，它允许您提供一个指定给定行项目的标签的回调。
        结果
        A Callback将返回一个能够处理TableColumn中包含的元素类型的TableCell 。

      • forTableColumn

        public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty,
                                                                             StringConverter<T> converter)
        创建一个电池厂 ，用于TableColumn电池厂 。 此方法要求TableColumn的类型为ObservableValue<Boolean> 。

        当在TableColumn中使用时，CheckBoxCell将以列为中心的CheckBox呈现。

        参数类型
        S - TableView通用类型的类型
        T - TableColumn实例中包含的元素的类型。
        参数
        getSelectedProperty - 给出TableColumn<S,T>类型的对象的回调TableColumn<S,T>将返回一个ObservableValue<Boolean> ，表示给定项目是否被选择。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态）。
        converter - 提供类型T的对象的StringConverter将返回一个可以用于可视化表示对象的字符串。 在forTableColumn(Callback, boolean) （当showLabel为true时）的默认实现是简单地在所有非空项目上调用.toString（）（并且在给定项目为空的情况下只返回一个空字符串）。
        结果
        A Callback将返回一个能够处理TableColumn中包含的元素类型的TableCell 。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • selectedStateCallbackProperty

        public final ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> selectedStateCallbackProperty​()
        属性表示由屏幕上显示的复选框绑定的Callback 。
        另请参见：
        getSelectedStateCallback() ， setSelectedStateCallback(Callback)

      • setSelectedStateCallback

        public final void setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
        设置屏幕上显示的复选框所绑定的Callback 。
        参数
        value - 由屏幕上显示的复选框绑定的Callback

      • getSelectedStateCallback

        public final Callback<Integer,ObservableValue<Boolean>> getSelectedStateCallback​()
        返回由屏幕上显示的复选框绑定的Callback 。
        结果
        由屏幕上显示的复选框绑定的Callback

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了弄清楚，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，比如ListView控件）来调用这个方法。 然而，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - whether or not this cell represents data from the list. If it is empty, then it does not represent any domain data, but is a cell being used to render an "empty" row.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CheckBoxTreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class CheckBoxTreeCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeCell<T>
                    • javafx.scene.control.cell.CheckBoxTreeCell<T>
  • 参数类型
    T - TreeView TreeItem实例中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class CheckBoxTreeCell<T>
extends TreeCell<T>
    一个包含TreeCell实现的类，它在单元格中绘制一个CheckBox节点，同时支持常见的交互（ 稍后更详细地讨论）。

    要使用CheckBox创建TreeView更容易，提供了一个名为CheckBoxTreeItem的便利类。 强烈建议开发人员在构建其TreeView树结构时使用此类，而不是常规的TreeItem类。 有关如何组合这两个类的示例，请参阅CheckBoxTreeItem API文档。

    当在TreeView中使用时，CheckBoxCell将使用“披露节点”右侧的复选框（即箭头）呈现。 然后，存储在TreeItem.getValue()中的项目将会调用StringConverter，此文本将占用所有剩余的水平空间。 另外，通过使用CheckBoxTreeItem ，TreeView会自动处理以下情况：

    • 点击CheckBox旁边有一个项目的孩子将导致所有的孩子也被选中/未选择。
    • 点击CheckBox旁边一个有父项的项目可能会切换父级的状态。 例如，如果您选择一个孩子，父母将变得不确定（指示部分选择孩子）。 如果继续选择所有孩子，父母将显示它也被选中。 这是递归的，所有父节点按预期更新。
    如果决定，使用CheckBoxTreeItem是不可取的，那么就需要调用其中一个构造函数Callback提供了可以返回ObservableValue<Boolean>给予TreeItem实例。 这个ObservableValue<Boolean>应该表示给定的TreeItem的布尔状态。

    请注意，CheckBoxTreeCell呈现CheckBox“live”，这意味着CheckBox始终是交互式的，可以由用户直接切换。 这意味着单元格不需要输入其editing state （通常由用户双击单元格）。 这样做的副作用是 不会调用通常的编辑回调（如on edit commit ）。 如果要通知更改，建议直接观察CheckBox操作的布尔属性。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<TreeItem<T>>> converter
      StringConverter属性。
      ObjectProperty<Callback<TreeItem<T>,ObservableValue<Boolean>>> selectedStateCallback
      属性表示由屏幕上显示的复选框绑定的Callback 。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TreeCell

        disclosureNode, treeItem, treeView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckBoxTreeCell​()
      创建一个默认的CheckBoxTreeCell ，假定TreeView是用CheckBoxTreeItem实例构建的，而不是默认的TreeItem 。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<TreeItem<T>>> converterProperty​()
      StringConverter属性。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​()
      创建一个用于TreeView控件的单元格工厂，尽管在TreeView中使用时有一个主要假设：此单元格工厂假定TreeView根和所有子项都是CheckBoxTreeItem的实例，而不是正常使用的默认值为TreeItem。 。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      StringConverter<TreeItem<T>> getConverter​()
      返回此单元格中使用的StringConverter 。
      Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<TreeItem<T>,ObservableValue<Boolean>>> selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      void setConverter​(StringConverter<TreeItem<T>> value)
      设置要在此单元格中使用的StringConverter 。
      void setSelectedStateCallback​(Callback<TreeItem<T>,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TreeCell

        cancelEdit, commitEdit, createDefaultSkin, disclosureNodeProperty, executeAccessibleAction, getDisclosureNode, getTreeItem, getTreeView, queryAccessibleAttribute, setDisclosureNode, startEdit, treeItemProperty, treeViewProperty, updateTreeItem, updateTreeView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<TreeItem<T>>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

      • selectedStateCallback

        public final ObjectProperty<Callback<TreeItem<T>,ObservableValue<Boolean>>> selectedStateCallbackProperty
        属性表示由屏幕上显示的复选框绑定的Callback 。
        另请参见：
        getSelectedStateCallback() ， setSelectedStateCallback(Callback)

    • 构造方法详细信息

      • CheckBoxTreeCell

        public CheckBoxTreeCell​()
        创建一个默认的CheckBoxTreeCell ，假定TreeView是用CheckBoxTreeItem实例构建的，而不是默认的TreeItem 。 通过使用CheckBoxTreeItem ，它将内部管理树中每个项目的选定和不确定状态。

      • CheckBoxTreeCell

        public CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
        创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。 与CheckBoxTreeCell()不同，该方法不会假定TreeView中的所有TreeItem实例都是CheckBoxTreeItem 。

        要调用此方法，有必要提供一个Callback ，给定一个TreeItem <T>类型的对象，将返回一个表示给定项目是否被选择的ObservableValue<Boolean> 。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态）。

        如果项目不是CheckBoxTreeItem实例，则开发人员负责处理更新父项和子项TreeItems的状态。 这意味着，给定一个TreeItem，这个类将简单地切换提供的ObservableValue<Boolean> ，而不是更多。 当然，这个功能可以通过向ObservableValue<Boolean>添加观察者来外部实现，并根据需要切换其他属性的状态。

        参数
        getSelectedProperty - A Callback将返回一个ObservableValue<Boolean> ，表示给定项目是否被选择。

      • CheckBoxTreeCell

        public CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty,
                        StringConverter<TreeItem<T>> converter)
        创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。 与CheckBoxTreeCell()不同，该方法不会假定TreeView中的所有TreeItem实例都是CheckBoxTreeItem 。

        要调用此方法，有必要提供一个Callback ，给定一个TreeItem <T>类型的对象将返回一个ObservableValue<Boolean> ，表示给定项是否被选择。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，而复选框将反映ObservableValue<Boolean>的状态，如果外部更改）。

        如果项目不是CheckBoxTreeItem实例，则开发人员负责处理更新父和子TreeItems的状态。 这意味着，给定一个TreeItem，这个类将简单地切换提供的ObservableValue<Boolean> ，而不是更多。 当然，这个功能可以通过向ObservableValue<Boolean>添加观察者来外部实现，并根据需要切换其他属性的状态。

        参数
        getSelectedProperty - A Callback将返回一个表示给定项目是否被选择的ObservableValue<Boolean> 。
        converter - 给一个类型为TreeItem <T>的对象的StringConverter将返回一个可以用于可视化表示对象的String。

    • 方法详细信息

      • forTreeView

        public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​()
        创建在TreeView控件中使用的单元格工厂，尽管在TreeView中使用时有一个主要假设：此单元格工厂假定TreeView根和所有子项都是CheckBoxTreeItem的实例，而不是正常使用的默认TreeItem类。

        当在TreeView中使用时，CheckBoxCell将使用“披露节点”右侧的复选框（即箭头）呈现。 存储在TreeItem.getValue()中的项目将在其上调用StringConverter，并且此文本将占用所有剩余的水平空间。 另外，通过使用CheckBoxTreeItem ，TreeView将自动处理以下情况：

        • 点击CheckBox旁边有一个项目的孩子将导致所有的孩子也被选中/未选择。
        • 点击CheckBox旁边一个有父项的项目可能会切换父级的状态。 例如，如果您选择一个孩子，父母将变得不确定（指示部分选择孩子）。 如果继续选择所有孩子，父母将显示它也被选中。 这是递归的，所有父节点按预期更新。

        不幸的是，由于Java的限制，使用这种方法时需要提供一个显式的转换。 例如：

           final TreeView<String> treeView = new TreeView<String>(); treeView.setCellFactory(CheckBoxCell.<String>forTreeView());
        参数类型
        T - CheckBoxTreeItem实例中包含的元素的类型。
        结果
        A Callback将返回一个TreeCell，它能够处理TreeView根目录中包含的元素及其所有子项（递归）。

      • forTreeView

        public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
        创建一个用于TreeView控件的单元格工厂。 与forTreeView()不同，此方法不会假定TreeView中的所有TreeItem实例都是CheckBoxTreeItem实例。

        当在TreeView中使用时，CheckBoxCell将使用“披露节点”右侧的复选框（即箭头）呈现。 然后，存储在TreeItem.getValue()中的项目将会调用StringConverter，此文本将占用所有剩余的水平空间。

        不像forTreeView() ，这个单元格工厂不处理更新父项或子ObservableValue<Boolean> TreeItems的状态 - 它只是切换提供的ObservableValue<Boolean> ，而不是更多。 当然，这个功能可以通过向ObservableValue<Boolean>添加观察者来外部实现，并根据需要切换其他属性的状态。

        参数类型
        T - TreeItem实例中包含的元素的类型。
        参数
        getSelectedProperty - 一个Callback ，给定一个类型为TreeItem <T>的对象，将返回一个ObservableValue<Boolean> ，表示给定项是否被选择。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态）。
        结果
        A Callback将返回一个TreeCell，它可以处理TreeView根目录中包含的元素类型及其所有子项（递归））。

      • forTreeView

        public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty,
                                                                StringConverter<TreeItem<T>> converter)
        创建一个用于TreeView控件的单元格工厂。 与forTreeView()不同，该方法不会假定TreeView中的所有TreeItem实例都是CheckBoxTreeItem 。

        当在TreeView中使用时，CheckBoxCell将使用“披露节点”右侧的复选框（即箭头）呈现。 然后，存储在TreeItem.getValue()中的项目将会调用StringConverter，此文本将占用所有剩余的水平空间。

        不像forTreeView() ，这个单元格工厂不处理更新父项或子ObservableValue<Boolean> TreeItems的状态 - 它只是切换提供的ObservableValue<Boolean> ，而不是更多。 当然，可以通过向ObservableValue<Boolean>添加观察者来外部实现该功能，并根据需要切换其他属性的状态。

        参数类型
        T - TreeItem实例中包含的元素的类型。
        参数
        getSelectedProperty - 给定一个TreeItem <T>类型的对象的回调将返回一个ObservableValue<Boolean> ，表示给定项是否被选择。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，而复选框将反映ObservableValue<Boolean>的状态，如果外部更改）。
        converter - 提供TreeItem <T>类型的对象的StringConverter将返回一个可以用来直观地表示对象的String。 在forTreeView(Callback)中的默认实现是简单地在所有非空项目上调用.toString（）（并且在给定项目为空的情况下只返回一个空字符串）。
        结果
        A Callback将返回一个TreeCell，它可以处理TreeView根目录中包含的元素及其所有子项（递归）。

      • converterProperty

        public final ObjectProperty<StringConverter<TreeItem<T>>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<TreeItem<T>> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 要在此单元格中使用的StringConverter

      • getConverter

        public final StringConverter<TreeItem<T>> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • selectedStateCallbackProperty

        public final ObjectProperty<Callback<TreeItem<T>,ObservableValue<Boolean>>> selectedStateCallbackProperty​()
        属性表示由屏幕上显示的复选框绑定的Callback 。
        另请参见：
        getSelectedStateCallback() ， setSelectedStateCallback(Callback)

      • setSelectedStateCallback

        public final void setSelectedStateCallback​(Callback<TreeItem<T>,ObservableValue<Boolean>> value)
        设置由屏幕上显示的复选框绑定的Callback 。
        参数
        value - 屏幕上显示的复选框所绑定的Callback

      • getSelectedStateCallback

        public final Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedStateCallback​()
        返回由屏幕上显示的复选框绑定的Callback 。
        结果
        由屏幕上显示的复选框绑定的Callback

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，如ListView控件）来调用这个方法。 然而，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CheckBoxTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class CheckBoxTreeTableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeTableCell<S,T>
                    • javafx.scene.control.cell.CheckBoxTreeTableCell<S,T>
  • 参数类型
    S - TreeTableView通用类型的类型
    T - TreeTableColumn中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class CheckBoxTreeTableCell<S,T>
extends TreeTableCell<S,T>
    一个包含一个TreeTableCell实现的类，在该单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。

    默认情况下，CheckBoxTreeTableCell使用以TreeTableColumn为中心的CheckBox进行渲染。 如果需要标签，则必须向CheckBoxTreeTableCell(Callback, StringConverter)构造函数提供非空StringConverter实例。

    要构造此类的实例，有必要提供一个Callback ，给定一个类型T的对象将返回一个ObservableProperty<Boolean> ，表示给定项是否被选择。 这个ObservableValue将双向绑定（这意味着单元格中的CheckBox将根据用户交互设置/取消设置此属性，如果外部改变，CheckBox将反映ObservableValue的状态）。

    请注意，CheckBoxTreeTableCell渲染CheckBox“live”，这意味着CheckBox始终是交互式的，可以由用户直接切换。 这意味着单元格无需进入其editing state （通常由用户双击单元格）。 这方面的一个副作用是，通常的编辑回调（如on edit commit ）将不被调用。 如果要通知更改，建议直接观察CheckBox操作的布尔属性。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> selectedStateCallback
      属性表示由屏幕上显示的复选框绑定的Callback 。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TreeTableCell

        tableColumn, tableRow, treeTableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckBoxTreeTableCell​()
      创建一个默认的CheckBoxTreeTableCell。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxTreeTableCell与自定义Callback来检索给定单元格索引的ObservableValue。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxTreeTableCell。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <S> Callback<TreeTableColumn<S,Boolean>,TreeTableCell<S,Boolean>> forTreeTableColumn​(TreeTableColumn<S,Boolean> column)
      创建一个用于TreeTableColumn电池厂的电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      Callback<Integer,ObservableValue<Boolean>> getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TreeTableCell

        cancelEdit, commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTreeTableRow, getTreeTableView, layoutChildren, queryAccessibleAttribute, startEdit, tableColumnProperty, tableRowProperty, treeTableViewProperty, updateSelected, updateTreeTableColumn, updateTreeTableRow, updateTreeTableView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter财产

      • selectedStateCallback

        public final ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> selectedStateCallbackProperty
        属性表示由屏幕上显示的复选框绑定的Callback 。
        另请参见：
        getSelectedStateCallback() ， setSelectedStateCallback(Callback)

    • 构造方法详细信息

      • CheckBoxTreeTableCell

        public CheckBoxTreeTableCell​()
        创建一个默认的CheckBoxTreeTableCell。

      • CheckBoxTreeTableCell

        public CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
        创建一个默认的CheckBoxTreeTableCell与自定义Callback检索给定单元格索引的ObservableValue。
        参数
        getSelectedProperty - A Callback将从TreeTableColumn返回一个ObservableValue给定的索引。

      • CheckBoxTreeTableCell

        public CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty,
                             StringConverter<T> converter)
        用自定义字符串转换器创建一个CheckBoxTreeTableCell。
        参数
        getSelectedProperty - A Callback将从TreeTableColumn返回给定索引的ObservableValue 。
        converter - 给定一个类型为T的对象的StringConverter将返回一个可以用来直观地表示对象的String。

    • 方法详细信息

      • forTreeTableColumn

        public static <S> Callback<TreeTableColumn<S,Boolean>,TreeTableCell<S,Boolean>> forTreeTableColumn​(TreeTableColumn<S,Boolean> column)
        创建一个电池厂 ，用于TreeTableColumn电池厂 。 此方法要求TreeTableColumn的类型为Boolean 。

        当在TreeTableColumn中使用时，CheckBoxCell将以列为中心的CheckBox呈现。

        包含在列中每个单元格内的ObservableValue<Boolean>将双向绑定。 这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态。

        参数类型
        S - TreeTableView通用类型的类型
        参数
        column - 类型为Boolean的TreeTableColumn
        结果
        A Callback将返回一个能够处理TreeTableColumn中包含的元素类型的TreeTableCell 。

      • forTreeTableColumn

        public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
        创建一个电池厂 ，用于TreeTableColumn电池厂 。 此方法要求TreeTableColumn的类型为ObservableValue<Boolean> 。

        当在TreeTableColumn中使用时，CheckBoxCell将以列为中心的CheckBox呈现。

        参数类型
        S - TreeTableView泛型类型的类型
        T - TreeTableColumn实例中包含的元素的类型。
        参数
        getSelectedProperty - 给定一个TreeTableColumn<S,T>类型的对象的回调TreeTableColumn<S,T>将返回一个ObservableValue<Boolean> ，表示给定的项目是否被选择。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态）。
        结果
        A Callback将返回一个能够处理TreeTableColumn中包含的元素类型的TreeTableCell 。

      • forTreeTableColumn

        public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty,
                                                                                boolean showLabel)
        创建一个电池厂 ，用于TreeTableColumn电池厂 。 此方法要求TreeTableColumn的类型为ObservableValue<Boolean> 。

        当在TreeTableColumn中使用时，CheckBoxCell将以列为中心的CheckBox呈现。

        参数类型
        S - TreeTableView泛型类型的类型
        T - TreeTableColumn实例中包含的元素的类型。
        参数
        getSelectedProperty - 给定一个TreeTableColumn<S,T>类型的对象的回调TreeTableColumn<S,T>将返回一个ObservableValue<Boolean> ，表示给定的项目是否被选择。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态）。
        showLabel - 在某些情况下，可能希望在CheckBox旁边的TreeTableCell中显示一个标签。 默认情况下，不显示标签，但通过将其设置为true，单元格中的项目也将在其上调用toString（）。 如果这不是期望的行为，请考虑使用forTreeTableColumn(javafx.util.Callback, javafx.util.StringConverter) ，这允许您提供指定给定行项目的标签的回调。
        结果
        A Callback将返回一个能够处理TreeTableColumn中包含的元素类型的TreeTableCell 。

      • forTreeTableColumn

        public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty,
                                                                                StringConverter<T> converter)
        创建一个电池厂 ，用于TreeTableColumn电池厂 。 此方法要求TreeTableColumn的类型为ObservableValue<Boolean> 。

        当在TreeTableColumn中使用时，CheckBoxCell将以列为中心的CheckBox呈现。

        参数类型
        S - TreeTableView泛型类型的类型
        T - TreeTableColumn实例中包含的元素的类型。
        参数
        getSelectedProperty - 给予TreeTableColumn<S,T>类型的对象的回调将返回一个表示给定项目是否被选择的ObservableValue<Boolean> 。 这个ObservableValue<Boolean>将双向绑定（这意味着单元格中的复选框将基于用户交互设置/取消设置此属性，如果外部更改，则复选框将反映ObservableValue<Boolean>的状态）。
        converter - 给定类型为T的对象的StringConverter将返回一个可以用于可视化表示对象的字符串。 在forTreeTableColumn(Callback, boolean) （当showLabel为true时）的默认实现是简单地在所有非空项目上调用.toString（）（并且在给定项为null的情况下只返回一个空字符串）。
        结果
        A Callback将返回一个能够处理TreeTableColumn中包含的元素类型的TreeTableCell 。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 要在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • selectedStateCallbackProperty

        public final ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> selectedStateCallbackProperty​()
        属性表示由屏幕上显示的复选框绑定的Callback 。
        另请参见：
        getSelectedStateCallback() ， setSelectedStateCallback(Callback)

      • setSelectedStateCallback

        public final void setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
        设置由屏幕上显示的复选框绑定的Callback 。
        参数
        value - 由屏幕上显示的复选框绑定的Callback

      • getSelectedStateCallback

        public final Callback<Integer,ObservableValue<Boolean>> getSelectedStateCallback​()
        返回由屏幕上显示的复选框绑定的Callback 。
        结果
        由屏幕上显示的复选框绑定的Callback

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该把它放在UI控件上，比如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是让开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChoiceBoxListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ChoiceBoxListCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.ListCell<T>
                    • javafx.scene.control.cell.ChoiceBoxListCell<T>
  • 参数类型
    T - ListView中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ChoiceBoxListCell<T>
extends ListCell<T>
    一个包含ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。

    默认情况下， ChoiceBoxListCell在不被编辑时被渲染为Label ，而在编辑模式时，作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。

    要创建一个ChoiceBoxListCell，有必要提供零个或多个项目，当ChoiceBox菜单显示时，这些项目将显示给用户。 这些项目必须与ListView项目序列具有相同的类型，以便在选择时，它们将替换items列表中的现有值。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.control.ListCell

        listView

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ChoiceBoxListCell​()
      创建一个带有空项目列表的默认ChoiceBoxListCell。
      ChoiceBoxListCell​(ObservableList<T> items)
      创建默认的ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxListCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxListCell实例，其中给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxListCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时显示ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxListCell​(T... items)
      创建默认的ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      ObservableList<T> getItems​()
      返回要显示在ChoiceBox中的项目。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.control.ListCell

        commitEdit, createDefaultSkin, executeAccessibleAction, getListView, listViewProperty, queryAccessibleAttribute, updateListView

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

    • 构造方法详细信息

      • ChoiceBoxListCell

        public ChoiceBoxListCell​()
        创建一个带有空项目列表的默认ChoiceBoxListCell。

      • ChoiceBoxListCell

        @SafeVarargs
public ChoiceBoxListCell​(T... items)
        创建默认的ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
        参数
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxListCell

        @SafeVarargs
public ChoiceBoxListCell​(StringConverter<T> converter,
                         T... items)
        创建一个ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter可以将T型的项目转换为用户可读的字符串，以便可以在ChoiceBox弹出菜单中显示。
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxListCell

        public ChoiceBoxListCell​(ObservableList<T> items)
        创建默认的ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
        参数
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxListCell

        public ChoiceBoxListCell​(StringConverter<T> converter,
                         ObservableList<T> items)
        创建一个ChoiceBoxListCell实例，其中给定的项目用于填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter可以将T类型的项目转换成用户可读的字符串，以便可以在ChoiceBox弹出菜单中显示。
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

    • 方法详细信息

      • forListView

        @SafeVarargs
public static <T> Callback<ListView<T>,ListCell<T>> forListView​(T... items)
        创建一个ChoiceBox单元格工厂，用于ListView控件。 默认情况下， ChoiceBoxCell在不被编辑时被渲染为Label ，而在编辑模式下，作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与ListView项目列表的类型相同，以便在选择时，它们将替换items列表中的现有值。
        结果
        A Callback将返回能够处理ListView中包含的元素类型的ListCell。

      • forListView

        @SafeVarargs
public static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter,
                                                                T... items)
        创建一个ChoiceBox单元格工厂，用于ListView控件。 默认情况下， ChoiceBoxCell在不被编辑时呈现为Label，在编辑模式时，作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        converter - A StringConverter将给定项（类型T）转换为字符串以显示给用户。
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与ListView项目列表的类型相同，以便在选择时，它们将替换items列表中的现有值。
        结果
        A Callback将返回能够处理ListView中包含的元素类型的ListCell。

      • forListView

        public static <T> Callback<ListView<T>,ListCell<T>> forListView​(ObservableList<T> items)
        创建一个ChoiceBox单元格工厂用于ListView控件。 默认情况下， ChoiceBoxCell在不被编辑时呈现为Label ，而在编辑模式下，作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        items - 一个ObservableList包含零个或多个项目，当ChoiceBox菜单显示时将显示给用户。 这些项目必须与ListView项目序列具有相同的类型，以便在选择时，它们将替换items列表中的现有值。
        结果
        A Callback将返回能够处理ListView中包含的元素类型的ListCell。

      • forListView

        public static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter,
                                                                ObservableList<T> items)
        创建一个ChoiceBox单元格工厂用于ListView控件。 默认情况下， ChoiceBoxCell在不被编辑时被渲染为Label，在编辑模式时作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为用于显示给用户的字符串。
        items -一个ObservableList包含零个或多个项目将被显示给用户时， ChoiceBox显示菜单时。 这些项目必须与ListView项目序列具有相同的类型，以便在选择时，它们将替换items列表中的现有值。
        结果
        A Callback将返回能够处理ListView中包含的元素类型的ListCell。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 要在此单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • getItems

        public ObservableList<T> getItems​()
        返回要显示在ChoiceBox中的项目。
        结果
        要显示在ChoiceBox中的项目

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 ListCell<T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 ListCell<T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是使开发人员在指定自定义单元格工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChoiceBoxTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ChoiceBoxTableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TableCell<S,T>
                    • javafx.scene.control.cell.ChoiceBoxTableCell<S,T>
  • 参数类型
    S - TableView通用类型的类型
    T - TableColumn中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ChoiceBoxTableCell<S,T>
extends TableCell<S,T>
    一个包含一个TableCell实现的类，它在单元格中绘制一个ChoiceBox节点。

    默认情况下， ChoiceBoxTableCell在不被编辑时呈现为Label，在编辑模式时作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个表单元格。

    要创建一个ChoiceBoxTableCell，有必要提供零或更多的项目，当ChoiceBox菜单显示时，将显示给用户。 这些项目必须与TableColumn类型相同。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TableCell

        tableColumn, tableRow, tableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ChoiceBoxTableCell​()
      创建一个带有空项目列表的默认ChoiceBoxTableCell。
      ChoiceBoxTableCell​(ObservableList<T> items)
      创建默认的ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTableCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTableCell​(T... items)
      创建默认的ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      ObservableList<T> getItems​()
      返回要显示在ChoiceBox中的项目。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TableCell

        commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTableRow, getTableView, layoutChildren, queryAccessibleAttribute, tableColumnProperty, tableRowProperty, tableViewProperty, updateSelected, updateTableColumn, updateTableRow, updateTableView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

    • 构造方法详细信息

      • ChoiceBoxTableCell

        public ChoiceBoxTableCell​()
        创建一个带有空项目列表的默认ChoiceBoxTableCell。

      • ChoiceBoxTableCell

        @SafeVarargs
public ChoiceBoxTableCell​(T... items)
        创建默认的ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
        参数
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxTableCell

        @SafeVarargs
public ChoiceBoxTableCell​(StringConverter<T> converter,
                          T... items)
        创建一个ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter ，可以将T类型的项目转换为用户可读的字符串，以便可以在ChoiceBox弹出菜单中显示。
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxTableCell

        public ChoiceBoxTableCell​(ObservableList<T> items)
        创建默认的ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
        参数
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxTableCell

        public ChoiceBoxTableCell​(StringConverter<T> converter,
                          ObservableList<T> items)
        创建一个ChoiceBoxTableCell实例，给定的项目用于填充ChoiceBox ，并显示StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter ，可以将T类型的项目转换为用户可读的字符串，以便可以在ChoiceBox弹出菜单中显示。
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

    • 方法详细信息

      • forTableColumn

        @SafeVarargs
public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(T... items)
        创建一个ChoiceBox单元格工厂用于TableColumn控件。 默认情况下， ChoiceBoxCell在不被编辑时被渲染为Label，在编辑模式时作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        S - TableView通用类型的类型
        T - TableColumn中包含的元素的类型。
        参数
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TableColumn类型相同。 请注意，由开发人员设置event handlers以监听TableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回能够处理TableColumn中包含的元素类型的TableCell。

      • forTableColumn

        @SafeVarargs
public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter,
                                                                             T... items)
        创建一个ChoiceBox单元格工厂，用于TableColumn控件。 默认情况下， ChoiceBoxCell在不被编辑时呈现为Label ，而在编辑模式下则作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        S - TableView通用类型的类型
        T - TableColumn中包含的元素的类型。
        参数
        converter - A StringConverter将给定的项目（类型T）转换为用于显示给用户的字符串。
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TableColumn类型相同。 请注意，由开发人员设置event handlers来监听TableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回能够处理TableColumn中包含的元素类型的TableCell。

      • forTableColumn

        public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(ObservableList<T> items)
        创建一个ChoiceBox单元格工厂用于TableColumn控件。 默认情况下， ChoiceBoxCell在编辑时不会被编译为Label，而在编辑模式时会作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        S - TableView通用类型的类型
        T - TableColumn中包含的元素的类型。
        参数
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TableColumn类型相同。 请注意，由开发人员设置event handlers以监听TableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回能够处理TableColumn中包含的元素类型的TableCell。

      • forTableColumn

        public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter,
                                                                             ObservableList<T> items)
        创建一个ChoiceBox单元格工厂，用于TableColumn控件。 默认情况下， ChoiceBoxCell在不被编辑时呈现为Label ，而在编辑模式下，作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        S - TableView通用类型的类型
        T - TableColumn中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为字符串以显示给用户。
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TableColumn类型相同。 请注意，由开发人员设置event handlers以监听TableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回能够处理TableColumn中包含的元素类型的TableCell。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • getItems

        public ObservableList<T> getItems​()
        返回要显示在ChoiceBox中的项目。
        结果
        要显示在ChoiceBox中的项目

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 TableCell<S,T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 TableCell<S,T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，如ListView控件）来调用这个方法。 然而，使用updateItem方法的目的是让开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法，以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - whether or not this cell represents data from the list. If it is empty, then it does not represent any domain data, but is a cell being used to render an "empty" row.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChoiceBoxTreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ChoiceBoxTreeCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeCell<T>
                    • javafx.scene.control.cell.ChoiceBoxTreeCell<T>
  • 参数类型
    T - TreeView中包含的TreeItem的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ChoiceBoxTreeCell<T>
extends TreeCell<T>
    一个包含ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。

    默认情况下， ChoiceBoxTreeCell在不被编辑时呈现为Label，在编辑模式时也作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸填充整个树单元格。

    要创建一个ChoiceBoxTreeCell，有必要提供零个或多个项目，当ChoiceBox菜单显示时，该项目将显示给用户。 这些项目必须与TreeView TreeItems具有相同的类型，以便在选择时，它们将替换TreeItem.valueProperty()中的现有值。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TreeCell

        disclosureNode, treeItem, treeView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ChoiceBoxTreeCell​()
      创建一个带有空项目列表的默认ChoiceBoxTreeCell。
      ChoiceBoxTreeCell​(ObservableList<T> items)
      创建默认的ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxTreeCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxTreeCell实例，其中给定的项目用于填充ChoiceBox ，并且StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeCell​(T... items)
      创建默认的ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter财产。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(T... items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      ObservableList<T> getItems​()
      返回要显示在ChoiceBox中的项目。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TreeCell

        commitEdit, createDefaultSkin, disclosureNodeProperty, executeAccessibleAction, getDisclosureNode, getTreeItem, getTreeView, queryAccessibleAttribute, setDisclosureNode, treeItemProperty, treeViewProperty, updateTreeItem, updateTreeView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter财产

    • 构造方法详细信息

      • ChoiceBoxTreeCell

        public ChoiceBoxTreeCell​()
        创建一个带有空项目列表的默认ChoiceBoxTreeCell。

      • ChoiceBoxTreeCell

        @SafeVarargs
public ChoiceBoxTreeCell​(T... items)
        创建默认的ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
        参数
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxTreeCell

        @SafeVarargs
public ChoiceBoxTreeCell​(StringConverter<T> converter,
                         T... items)
        创建一个ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A Callback可以将T类型的项目转换为用户可读的字符串，以便可以在ChoiceBox弹出菜单中显示。
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxTreeCell

        public ChoiceBoxTreeCell​(ObservableList<T> items)
        创建默认的ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
        参数
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxTreeCell

        public ChoiceBoxTreeCell​(StringConverter<T> converter,
                         ObservableList<T> items)
        创建一个ChoiceBoxTreeCell实例，给定的项目用于填充ChoiceBox ，并显示StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A Callback可以将类型T的项目转换为用户可读的字符串，以便可以在ChoiceBox弹出菜单中显示。
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

    • 方法详细信息

      • forTreeView

        @SafeVarargs
public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(T... items)
        创建一个ChoiceBox单元格工厂，用于TreeView控件。 默认情况下， ChoiceBoxCell在不被编辑时呈现为Label，在编辑模式时作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸填充整个树单元格。
        参数类型
        T - TreeView中包含的元素的类型。
        参数
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeView <T>具有相同的类型，以便选择后，它们将替换TreeItem value属性中的现有值。
        结果
        一个Callback ，它将返回一个TreeCell，它能够处理TreeView中包含的元素的类型。

      • forTreeView

        public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(ObservableList<T> items)
        创建一个ChoiceBox单元格工厂，用于TreeView控件。 默认情况下， ChoiceBoxCell在不被编辑时呈现为Label，在编辑模式时作为ChoiceBox呈现。 默认情况下，ChoiceBox将扩展以填充整个树单元格，不包括分配给树单元格缩进和公开节点（即箭头）的空间。
        参数类型
        T - 包含在TreeView中的TreeItem元素的类型。
        参数
        items - 一个ObservableList包含零个或多个项目，当ChoiceBox菜单显示时将显示给用户。 这些项目必须与TreeView通用类型的类型相同，因此在选择后，它们将替换正在编辑的TreeItem中的现有值（如TreeView.editingItemProperty()中所述）。
        结果
        A Callback将返回能够处理TreeView中包含的元素类型的TreeCell。

      • forTreeView

        @SafeVarargs
public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter,
                                                                T... items)
        创建一个ChoiceBox单元格工厂用于TreeView控件。 默认情况下， ChoiceBoxCell在不被编辑时呈现为Label ，而在编辑模式下，作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸填充整个树单元格。
        参数类型
        T - TreeView中包含的元素的类型。
        参数
        converter - A StringConverter将给定的项目（类型T）转换为字符串以显示给用户。
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeView <T>具有相同的类型，以便在选择时，它们将替换TreeItem value属性中的现有值。
        结果
        一个Callback将返回一个TreeCell，它能够处理TreeView中包含的元素类型。

      • forTreeView

        public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter,
                                                                ObservableList<T> items)
        创建一个ChoiceBox单元格工厂，用于TreeView控件。 默认情况下， ChoiceBoxCell在不被编辑时被渲染为Label ，而在编辑模式下，作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸填充整个树单元格。
        参数类型
        T - TreeView中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为字符串以显示给用户。
        items - 一个ObservableList包含零个或多个项目，当ChoiceBox菜单显示时将显示给用户。 这些项目必须与TreeView通用类型的类型相同，以便在选择时，它们将替换正在编辑的TreeItem中的现有值（如TreeView.editingItemProperty()所述） 。
        结果
        一个Callback将返回一个TreeCell，它能够处理TreeView中包含的元素类型。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 要在此单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • getItems

        public ObservableList<T> getItems​()
        返回要显示在ChoiceBox中的项目。
        结果
        要显示在ChoiceBox中的项目

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 TreeCell<T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 TreeCell<T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该把它放到UI控件上，比如ListView控件）来调用这个方法。 然而，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        参数
        item - 单元格的新项目。
        empty - whether or not this cell represents data from the list. If it is empty, then it does not represent any domain data, but is a cell being used to render an "empty" row.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChoiceBoxTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ChoiceBoxTreeTableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeTableCell<S,T>
                    • javafx.scene.control.cell.ChoiceBoxTreeTableCell<S,T>
  • 参数类型
    S - TreeTableView泛型类型的类型
    T - TreeTableColumn中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ChoiceBoxTreeTableCell<S,T>
extends TreeTableCell<S,T>
    一个包含TreeTableCell实现的类，在该单元格内绘制一个ChoiceBox节点。

    默认情况下， ChoiceBoxTreeTableCell在不被编辑时被渲染为Label，在编辑模式时，作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个表单元格。

    要创建一个ChoiceBoxTreeTableCell，当显示ChoiceBox菜单时，需要提供零个或多个将显示给用户的项目 。 这些项目必须与TreeTableColumn类型相同。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TreeTableCell

        tableColumn, tableRow, treeTableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ChoiceBoxTreeTableCell​()
      创建一个带有空项目列表的默认ChoiceBoxTreeTableCell。
      ChoiceBoxTreeTableCell​(ObservableList<T> items)
      创建默认的ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxTreeTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeTableCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxTreeTableCell实例，给定的项目用于填充ChoiceBox ，并显示StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeTableCell​(T... items)
      创建默认的ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      ObservableList<T> getItems​()
      返回要显示在ChoiceBox中的项目。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TreeTableCell

        commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTreeTableRow, getTreeTableView, layoutChildren, queryAccessibleAttribute, tableColumnProperty, tableRowProperty, treeTableViewProperty, updateSelected, updateTreeTableColumn, updateTreeTableRow, updateTreeTableView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

    • 构造方法详细信息

      • ChoiceBoxTreeTableCell

        public ChoiceBoxTreeTableCell​()
        创建一个带有空项目列表的默认ChoiceBoxTreeTableCell。

      • ChoiceBoxTreeTableCell

        @SafeVarargs
public ChoiceBoxTreeTableCell​(T... items)
        创建默认的ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
        参数
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxTreeTableCell

        @SafeVarargs
public ChoiceBoxTreeTableCell​(StringConverter<T> converter,
                              T... items)
        创建一个ChoiceBoxTreeTableCell实例，其中给定的项目用于填充ChoiceBox ，并且StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter可以将T类型的项目转换为用户可读的字符串，以便可以在ChoiceBox弹出菜单中显示。
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxTreeTableCell

        public ChoiceBoxTreeTableCell​(ObservableList<T> items)
        创建一个默认的ChoiceBoxTreeTableCell实例，给定的项目用于在显示270686640235353时填充它。
        参数
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

      • ChoiceBoxTreeTableCell

        public ChoiceBoxTreeTableCell​(StringConverter<T> converter,
                              ObservableList<T> items)
        创建一个ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter可以将类型T的项目转换为用户可读的字符串，以便可以在ChoiceBox弹出菜单中显示。
        items - 由用户选择时在ChoiceBox弹出菜单中显示的项目。

    • 方法详细信息

      • forTreeTableColumn

        @SafeVarargs
public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(T... items)
        创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。 默认情况下， ChoiceBoxCell在不被编辑时被渲染为Label，在编辑模式时被显示为ChoiceBox 。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        S - TreeTableView泛型类型的类型
        T - TreeTableColumn中包含的元素的类型。
        参数
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeTableColumn类型相同。 请注意，由开发人员设置event handlers以监听TreeTableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回一个TreeTableCell，它可以处理TreeTableColumn中包含的元素的类型。

      • forTreeTableColumn

        @SafeVarargs
public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter,
                                                                                T... items)
        创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。 默认情况下， ChoiceBoxCell在编辑时被渲染为Label，在编辑模式时作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        S - TreeTableView泛型类型的类型
        T - 包含在TreeTableColumn中的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为用于显示给用户的字符串。
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeTableColumn类型相同。 请注意，由开发人员设置event handlers以监听TreeTableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回一个TreeTableCell，它可以处理TreeTableColumn中包含的元素的类型。

      • forTreeTableColumn

        public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(ObservableList<T> items)
        创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。 默认情况下， ChoiceBoxCell在不被编辑时被渲染为Label，在编辑模式时作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        S - TreeTableView通用类型的类型
        T - TreeTableColumn中包含的元素的类型。
        参数
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeTableColumn类型相同。 请注意，由开发人员设置event handlers以监听TreeTableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回一个TreeTableCell，它可以处理TreeTableColumn中包含的元素的类型。

      • forTreeTableColumn

        public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter,
                                                                                ObservableList<T> items)
        创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。 默认情况下， ChoiceBoxCell在不被编辑时被渲染为Label，在编辑模式时作为ChoiceBox呈现。 默认情况下，ChoiceBox将拉伸以填充整个列表单元格。
        参数类型
        S - TreeTableView泛型类型的类型
        T - 包含在TreeTableColumn中的元素的类型。
        参数
        converter - A StringConverter将给定项（类型T）转换为字符串以显示给用户。
        items - 当显示ChoiceBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeTableColumn类型相同。 请注意，由开发人员设置event handlers以监听TreeTableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回一个TreeTableCell，它可以处理TreeTableColumn中包含的元素的类型。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • getItems

        public ObservableList<T> getItems​()
        返回要显示在ChoiceBox中的项目。
        结果
        要显示在ChoiceBox中的项目

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 TreeTableCell<S,T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 TreeTableCell<S,T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该把它放在UI控件上，比如ListView控件）来调用这个方法。 然而，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - whether or not this cell represents data from the list. If it is empty, then it does not represent any domain data, but is a cell being used to render an "empty" row.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ComboBoxListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ComboBoxListCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.ListCell<T>
                    • javafx.scene.control.cell.ComboBoxListCell<T>
  • 参数类型
    T - ListView中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ComboBoxListCell<T>
extends ListCell<T>
    一个包含ListCell实现的类，在该单元格内绘制一个ComboBox节点。

    默认情况下，ComboBoxListCell在不被编辑时呈现为Label ，而在编辑模式时则作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。

    要创建一个ComboBoxListCell，有必要提供零或更多的项目，当ComboBox菜单显示时，将显示给用户。 这些项目必须与ListView项目序列具有相同的类型，以便在选择后，它们将替换items列表中的现有值。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty comboBoxEditable
      表示ComboBox在向用户显示时是否可编辑的属性。
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.control.ListCell

        listView

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComboBoxListCell​()
      创建一个带有空项目列表的默认ComboBoxListCell。
      ComboBoxListCell​(ObservableList<T> items)
      创建默认的ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxListCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxListCell实例，给定的项目用于填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxListCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxListCell实例，给定的项目用于在显示ComboBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxListCell​(T... items)
      创建默认的ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      BooleanProperty comboBoxEditableProperty​()
      表示ComboBox在向用户显示时是否可编辑的属性。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(T... items)
      创建ComboBox单元格工厂，用于ListView控件。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      ObservableList<T> getItems​()
      返回要显示在ChoiceBox中的项目。
      boolean isComboBoxEditable​()
      如果ComboBox是可编辑的，则返回true。
      void setComboBoxEditable​(boolean value)
      将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.control.ListCell

        commitEdit, createDefaultSkin, executeAccessibleAction, getListView, listViewProperty, queryAccessibleAttribute, updateListView

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

      • comboBoxEditable

        public final BooleanProperty comboBoxEditableProperty
        表示ComboBox在向用户显示时是否可编辑的属性。
        另请参见：
        isComboBoxEditable() ， setComboBoxEditable(boolean)

    • 构造方法详细信息

      • ComboBoxListCell

        public ComboBoxListCell​()
        创建一个带有空项目列表的默认ComboBoxListCell。

      • ComboBoxListCell

        @SafeVarargs
public ComboBoxListCell​(T... items)
        创建默认的ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
        参数
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxListCell

        @SafeVarargs
public ComboBoxListCell​(StringConverter<T> converter,
                        T... items)
        创建一个ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter ，可以将T类型的项目转换为用户可读的字符串，以便可以在ComboBox弹出菜单中显示。
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxListCell

        public ComboBoxListCell​(ObservableList<T> items)
        创建默认的ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
        参数
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxListCell

        public ComboBoxListCell​(StringConverter<T> converter,
                        ObservableList<T> items)
        创建一个ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter ，可以将T类型的项目转换为用户可读的字符串，以便可以在ComboBox弹出菜单中显示。
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

    • 方法详细信息

      • forListView

        @SafeVarargs
public static <T> Callback<ListView<T>,ListCell<T>> forListView​(T... items)
        创建ComboBox单元格工厂，用于ListView控件。 默认情况下，ComboBoxCell在不被编辑时被渲染为Label ，而在编辑模式下则作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与ListView项目列表的类型相同，以便在选择时，它们将替换items列表中的现有值。
        结果
        A Callback将返回能够处理ListView中包含的元素类型的ListCell。

      • forListView

        @SafeVarargs
public static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter,
                                                                T... items)
        创建ComboBox单元格工厂，用于ListView控件。 默认情况下，ComboBoxCell在不被编辑时被渲染为Label ，而在编辑模式时则作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为用于显示给用户的字符串。
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与ListView项目列表的类型相同，以便在选择时，它们将替换items列表中的现有值。
        结果
        A Callback将返回能够处理ListView中包含的元素类型的ListCell。

      • forListView

        public static <T> Callback<ListView<T>,ListCell<T>> forListView​(ObservableList<T> items)
        创建ComboBox单元格工厂，用于ListView控件。 默认情况下，ComboBoxCell在不被编辑时被渲染为Label ，而在编辑模式下则作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        items -一个ObservableList包含零个或多个项目将被显示给用户时， ComboBox显示菜单时。 这些项目必须与ListView项目序列具有相同的类型，以便在选择时，它们将替换items列表中的现有值。
        结果
        A Callback将返回能够处理ListView中包含的元素类型的ListCell。

      • forListView

        public static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter,
                                                                ObservableList<T> items)
        创建ComboBox单元格工厂，用于ListView控件。 默认情况下，ComboBoxCell在不被编辑时被渲染为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        T - ListView中包含的元素的类型。
        参数
        converter - A StringConverter将给定的项目（类型T）转换为用于显示给用户的字符串。
        items - 一个ObservableList包含零个或多个项目，当ComboBox菜单显示时将显示给用户。 这些项目必须与ListView项目序列具有相同的类型，以便在选择时，它们将替换items列表中的现有值。
        结果
        A Callback将返回能够处理ListView中包含的元素类型的ListCell。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • comboBoxEditableProperty

        public final BooleanProperty comboBoxEditableProperty​()
        表示ComboBox在向用户显示时是否可编辑的属性。
        另请参见：
        isComboBoxEditable() ， setComboBoxEditable(boolean)

      • setComboBoxEditable

        public final void setComboBoxEditable​(boolean value)
        将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。
        参数
        value - 此ComboBox的可编辑值

      • isComboBoxEditable

        public final boolean isComboBoxEditable​()
        如果ComboBox是可编辑的，则返回true。
        结果
        如果ComboBox是可编辑的，则为true

      • getItems

        public ObservableList<T> getItems​()
        返回要显示在ChoiceBox中的项目。
        结果
        要显示在ChoiceBox中的项目

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 ListCell<T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 ListCell<T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了弄清楚，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，比如ListView控件）来调用这个方法。 然而，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法，以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ComboBoxTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ComboBoxTableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TableCell<S,T>
                    • javafx.scene.control.cell.ComboBoxTableCell<S,T>
  • 参数类型
    S - TableView通用类型的类型
    T - TableColumn中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ComboBoxTableCell<S,T>
extends TableCell<S,T>
    一个包含TableCell实现的类，在该单元格内绘制一个ComboBox节点。

    默认情况下，ComboBoxTableCell在不被编辑时呈现为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个表格单元格。

    要创建一个ComboBoxTableCell，有必要提供零个或多个项目，当ComboBox菜单显示时，将显示给用户。 这些项目必须与TableColumn类型相同。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty comboBoxEditable
      表示ComboBox在向用户显示时是否可编辑的属性。
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TableCell

        tableColumn, tableRow, tableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComboBoxTableCell​()
      创建一个带有空项目列表的默认ComboBoxTableCell。
      ComboBoxTableCell​(ObservableList<T> items)
      创建默认的ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxTableCell实例，其中给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTableCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTableCell​(T... items)
      创建默认的ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      BooleanProperty comboBoxEditableProperty​()
      表示ComboBox在向用户显示时是否可编辑的属性。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(T... items)
      创建ComboBox单元格工厂，用于TableColumn控件。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      ObservableList<T> getItems​()
      返回要显示在ComboBox中的项目。
      boolean isComboBoxEditable​()
      如果ComboBox是可编辑的，则返回true。
      void setComboBoxEditable​(boolean value)
      将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TableCell

        commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTableRow, getTableView, layoutChildren, queryAccessibleAttribute, tableColumnProperty, tableRowProperty, tableViewProperty, updateSelected, updateTableColumn, updateTableRow, updateTableView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

      • comboBoxEditable

        public final BooleanProperty comboBoxEditableProperty
        表示ComboBox在向用户显示时是否可编辑的属性。
        另请参见：
        isComboBoxEditable() ， setComboBoxEditable(boolean)

    • 构造方法详细信息

      • ComboBoxTableCell

        public ComboBoxTableCell​()
        创建一个带有空项目列表的默认ComboBoxTableCell。

      • ComboBoxTableCell

        @SafeVarargs
public ComboBoxTableCell​(T... items)
        创建默认的ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
        参数
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxTableCell

        @SafeVarargs
public ComboBoxTableCell​(StringConverter<T> converter,
                         T... items)
        创建一个ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter可以将T类型的项目转换为用户可读的字符串，以便可以在ComboBox弹出菜单中显示。
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxTableCell

        public ComboBoxTableCell​(ObservableList<T> items)
        创建默认的ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
        参数
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxTableCell

        public ComboBoxTableCell​(StringConverter<T> converter,
                         ObservableList<T> items)
        创建一个ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter可以将类型T的项目转换为用户可读的字符串，以便随后可以在ComboBox弹出菜单中显示。
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

    • 方法详细信息

      • forTableColumn

        @SafeVarargs
public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(T... items)
        创建ComboBox单元格工厂，用于TableColumn控件。 默认情况下，ComboBoxCell在不被编辑时呈现为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        S - TableView通用类型的类型
        T - TableColumn中包含的元素的类型。
        参数
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TableColumn类型相同。 请注意，由开发人员设置event handlers以监听TableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回能够处理TableColumn中包含的元素类型的TableCell。

      • forTableColumn

        @SafeVarargs
public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter,
                                                                             T... items)
        创建ComboBox单元格工厂用于TableColumn控件。 默认情况下，ComboBoxCell在不被编辑时被渲染为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        S - TableView通用类型的类型
        T - TableColumn中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为用于显示给用户的字符串。
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TableColumn类型相同。 请注意，由开发人员设置event handlers以监听TableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回能够处理TableColumn中包含的元素类型的TableCell。

      • forTableColumn

        public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(ObservableList<T> items)
        创建ComboBox单元格工厂用于TableColumn控件。 默认情况下，ComboBoxCell在不被编辑时呈现为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        S - TableView通用类型的类型
        T - TableColumn中包含的元素的类型。
        参数
        items - 显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TableColumn类型相同。 请注意，由开发人员设置event handlers以监听TableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回能够处理TableColumn中包含的元素类型的TableCell。

      • forTableColumn

        public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter,
                                                                             ObservableList<T> items)
        创建ComboBox单元格工厂，用于TableColumn控件。 默认情况下，ComboBoxCell在不被编辑时被渲染为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        S - TableView通用类型的类型
        T - TableColumn中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为用于向用户显示的字符串。
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TableColumn类型相同。 请注意，由开发人员设置event handlers来监听TableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回能够处理TableColumn中包含的元素类型的TableCell。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • comboBoxEditableProperty

        public final BooleanProperty comboBoxEditableProperty​()
        表示ComboBox在向用户显示时是否可编辑的属性。
        另请参见：
        isComboBoxEditable() ， setComboBoxEditable(boolean)

      • setComboBoxEditable

        public final void setComboBoxEditable​(boolean value)
        将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。
        参数
        value - 要为此ComboBox设置的可编辑值

      • isComboBoxEditable

        public final boolean isComboBoxEditable​()
        如果ComboBox是可编辑的，则返回true。
        结果
        如果ComboBox是可编辑的，则为true

      • getItems

        public ObservableList<T> getItems​()
        返回要显示在ComboBox中的项目。
        结果
        当该组合框显示时要显示的项目

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 TableCell<S,T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 TableCell<S,T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，比如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是使开发人员在指定自定义单元格工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - whether or not this cell represents data from the list. If it is empty, then it does not represent any domain data, but is a cell being used to render an "empty" row.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ComboBoxTreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ComboBoxTreeCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeCell<T>
                    • javafx.scene.control.cell.ComboBoxTreeCell<T>
  • 参数类型
    T - TreeView中包含的TreeItem的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ComboBoxTreeCell<T>
extends TreeCell<T>
    一个包含一个TreeCell实现的类，它在单元格内绘制一个ComboBox节点。

    默认情况下，ComboBoxTreeCell在不被编辑时呈现为Label ，在编辑模式时呈现为ComboBox。 默认情况下，ComboBox将拉伸以填充整个树单元格。

    要创建一个ComboBoxTreeCell，有必要提供零个或多个项目，当ComboBox菜单显示时，将显示给用户。 这些项目必须与TreeView TreeItems具有相同的类型，以便在选择时，它们将替换TreeItem.valueProperty()中的现有值。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty comboBoxEditable
      表示ComboBox在向用户显示时是否可编辑的属性。
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TreeCell

        disclosureNode, treeItem, treeView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComboBoxTreeCell​()
      创建一个带有空项目列表的默认ComboBoxTreeCell。
      ComboBoxTreeCell​(ObservableList<T> items)
      创建默认的ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxTreeCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxTreeCell实例，给定的项目用于填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxTreeCell实例，给定的项目用于填充ComboBox ，并且StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeCell​(T... items)
      创建默认的ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      BooleanProperty comboBoxEditableProperty​()
      表示ComboBox在向用户显示时是否可编辑的属性。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(T... items)
      创建ComboBox单元格工厂，用于TreeView控件。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      ObservableList<T> getItems​()
      返回要显示在ComboBox中的项目。
      boolean isComboBoxEditable​()
      如果ComboBox是可编辑的，则返回true。
      void setComboBoxEditable​(boolean value)
      将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TreeCell

        commitEdit, createDefaultSkin, disclosureNodeProperty, executeAccessibleAction, getDisclosureNode, getTreeItem, getTreeView, queryAccessibleAttribute, setDisclosureNode, treeItemProperty, treeViewProperty, updateTreeItem, updateTreeView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter财产

      • comboBoxEditable

        public final BooleanProperty comboBoxEditableProperty
        表示ComboBox在向用户显示时是否可编辑的属性。
        另请参见：
        isComboBoxEditable() ， setComboBoxEditable(boolean)

    • 构造方法详细信息

      • ComboBoxTreeCell

        public ComboBoxTreeCell​()
        创建一个带有空项目列表的默认ComboBoxTreeCell。

      • ComboBoxTreeCell

        @SafeVarargs
public ComboBoxTreeCell​(T... items)
        创建默认的ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
        参数
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxTreeCell

        @SafeVarargs
public ComboBoxTreeCell​(StringConverter<T> converter,
                        T... items)
        创建一个ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - 一个StringConverter ，可以将类型T的项目转换为用户可读的字符串，以便可以在ComboBox弹出菜单中显示。
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxTreeCell

        public ComboBoxTreeCell​(ObservableList<T> items)
        创建默认的ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
        参数
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxTreeCell

        public ComboBoxTreeCell​(StringConverter<T> converter,
                        ObservableList<T> items)
        创建一个ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter可以将T类型的项目转换为用户可读的字符串，以便可以在ComboBox弹出菜单中显示。
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

    • 方法详细信息

      • forTreeView

        @SafeVarargs
public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(T... items)
        创建ComboBox单元格工厂用于TreeView控件。 默认情况下，ComboBoxCell在不被编辑时呈现为Label ，而在编辑模式时则作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个树单元格。
        参数类型
        T - TreeView中包含的元素的类型。
        参数
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeView <T>具有相同的类型，以便在选择时，它们将替换TreeItem value属性中的现有值。
        结果
        A Callback将返回一个TreeCell，它能够处理TreeView中包含的元素的类型。

      • forTreeView

        public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(ObservableList<T> items)
        创建ComboBox单元格工厂，用于TreeView控件。 默认情况下，ComboBoxCell在不被编辑时被渲染为Label ，而在编辑模式下则作为ComboBox呈现。 默认情况下，ComboBox将扩展以填充整个树单元格，不包括分配给树单元格缩进和公开节点（即箭头）的空间。
        参数类型
        T - TreeView中包含的TreeItem元素的类型。
        参数
        items -一个ObservableList包含零个或多个项目将被显示给用户时， ComboBox显示菜单时。 这些项目必须与TreeView通用类型具有相同的类型，以便在选择时，它们将替换正在编辑的TreeItem中的现有值（如TreeView.editingItemProperty()所述） 。
        结果
        A Callback将返回一个TreeCell，它可以处理TreeView中包含的元素的类型。

      • forTreeView

        @SafeVarargs
public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter,
                                                                T... items)
        创建ComboBox单元格工厂，用于TreeView控件。 默认情况下，ComboBoxCell在不被编辑时呈现为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个树单元格。
        参数类型
        T - TreeView中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为用于显示给用户的字符串。
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeView <T>具有相同的类型，以便在选择时，它们将替换TreeItem value属性中的现有值。
        结果
        A Callback将返回一个TreeCell，它能够处理TreeView中包含的元素的类型。

      • forTreeView

        public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter,
                                                                ObservableList<T> items)
        创建ComboBox单元格工厂，用于TreeView控件。 默认情况下，ComboBoxCell在不被编辑时呈现为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个树单元格。
        参数类型
        T - TreeView中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为用于显示给用户的字符串。
        items - 一个ObservableList包含零个或多个项目，当ComboBox菜单显示时将显示给用户。 这些项目必须与TreeView通用类型的类型相同，以便在选择时，它们将替换正在编辑的TreeItem中的现有值（如TreeView.editingItemProperty()中所述）。
        结果
        A Callback将返回一个TreeCell，它能够处理TreeView中包含的元素的类型。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter财产。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • comboBoxEditableProperty

        public final BooleanProperty comboBoxEditableProperty​()
        表示ComboBox在向用户显示时是否可编辑的属性。
        另请参见：
        isComboBoxEditable() ， setComboBoxEditable(boolean)

      • setComboBoxEditable

        public final void setComboBoxEditable​(boolean value)
        将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。
        参数
        value - 要为此ComboBox设置的可编辑值

      • isComboBoxEditable

        public final boolean isComboBoxEditable​()
        如果ComboBox是可编辑的，则返回true。
        结果
        如果ComboBox是可编辑的，则为true

      • getItems

        public ObservableList<T> getItems​()
        返回要显示在ComboBox中的项目。
        结果
        当该组合框显示时要显示的项目

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 TreeCell<T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 TreeCell<T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，如ListView控件）来调用这个方法。 然而，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        参数
        item - 单元格的新项目。
        empty - whether or not this cell represents data from the list. If it is empty, then it does not represent any domain data, but is a cell being used to render an "empty" row.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ComboBoxTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ComboBoxTreeTableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeTableCell<S,T>
                    • javafx.scene.control.cell.ComboBoxTreeTableCell<S,T>
  • 参数类型
    S - TreeTableView泛型类型的类型
    T - TreeTableColumn中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ComboBoxTreeTableCell<S,T>
extends TreeTableCell<S,T>
    一个包含TreeTableCell实现的类，在该单元格内绘制一个ComboBox节点。

    默认情况下，ComboBoxTreeTableCell在不被编辑时呈现为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个表格单元格。

    要创建一个ComboBoxTreeTableCell，当显示ComboBox菜单时，需要提供零个或多个将显示给用户的项目 。 这些项目必须与TreeTableColumn类型相同。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty comboBoxEditable
      表示ComboBox在向用户显示时是否可编辑的属性。
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TreeTableCell

        tableColumn, tableRow, treeTableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComboBoxTreeTableCell​()
      创建一个带有空项目列表的默认ComboBoxTreeTableCell。
      ComboBoxTreeTableCell​(ObservableList<T> items)
      创建默认的ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxTreeTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxTreeTableCell实例，给定的项目用于填充ComboBox，当它被显示时， StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeTableCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxTreeTableCell实例，给定的项目用于填充ComboBox ，并显示StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeTableCell​(T... items)
      创建默认的ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      BooleanProperty comboBoxEditableProperty​()
      表示ComboBox在向用户显示时是否可编辑的属性。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(T... items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      ObservableList<T> getItems​()
      返回要显示在ComboBox中的项目。
      boolean isComboBoxEditable​()
      如果ComboBox是可编辑的，则返回true。
      void setComboBoxEditable​(boolean value)
      将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TreeTableCell

        commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTreeTableRow, getTreeTableView, layoutChildren, queryAccessibleAttribute, tableColumnProperty, tableRowProperty, treeTableViewProperty, updateSelected, updateTreeTableColumn, updateTreeTableRow, updateTreeTableView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        字符串转换器属性

      • comboBoxEditable

        public final BooleanProperty comboBoxEditableProperty
        表示ComboBox在向用户显示时是否可编辑的属性。
        另请参见：
        isComboBoxEditable() ， setComboBoxEditable(boolean)

    • 构造方法详细信息

      • ComboBoxTreeTableCell

        public ComboBoxTreeTableCell​()
        创建一个带有空项目列表的默认ComboBoxTreeTableCell。

      • ComboBoxTreeTableCell

        @SafeVarargs
public ComboBoxTreeTableCell​(T... items)
        创建默认的ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
        参数
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxTreeTableCell

        @SafeVarargs
public ComboBoxTreeTableCell​(StringConverter<T> converter,
                             T... items)
        创建一个ComboBoxTreeTableCell实例，给定的项目用于填充ComboBox ，并显示StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter可以将T型的项目转换为用户可读的字符串，以便可以在ComboBox弹出菜单中显示。
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxTreeTableCell

        public ComboBoxTreeTableCell​(ObservableList<T> items)
        创建默认的ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
        参数
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

      • ComboBoxTreeTableCell

        public ComboBoxTreeTableCell​(StringConverter<T> converter,
                             ObservableList<T> items)
        创建一个ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
        参数
        converter - A StringConverter ，它可以将类型T的项目转换为用户可读的字符串，从而可以在ComboBox弹出菜单中显示。
        items - 由用户选择时在ComboBox弹出菜单中显示的项目。

    • 方法详细信息

      • forTreeTableColumn

        @SafeVarargs
public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(T... items)
        创建ComboBox单元格工厂，用于TreeTableColumn控件。 默认情况下，ComboBoxCell在不被编辑时呈现为Label ，而在编辑模式下则为 ComboBox。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        S - TreeTableView泛型类型的类型
        T - TreeTableColumn中包含的元素的类型。
        参数
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeTableColumn类型相同。 请注意，由开发人员设置event handlers以监听TreeTableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回一个TreeTableCell，它能够处理TreeTableColumn中包含的元素的类型。

      • forTreeTableColumn

        @SafeVarargs
public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter,
                                                                                T... items)
        创建ComboBox单元格工厂，用于TreeTableColumn控件。 默认情况下，ComboBoxCell在不被编辑时被渲染为Label ，在编辑模式时作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        S - TreeTableView泛型类型的类型
        T - TreeTableColumn中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为用于显示给用户的字符串。
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeTableColumn类型相同。 请注意，由开发人员设置event handlers以监听TreeTableColumn中的编辑事件，并作出相应的反应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回一个TreeTableCell，它可以处理TreeTableColumn中包含的元素的类型。

      • forTreeTableColumn

        public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(ObservableList<T> items)
        创建ComboBox单元格工厂用于TreeTableColumn控件。 默认情况下，ComboBoxCell在不被编辑时呈现为Label ，在编辑模式时则作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        S - TreeTableView泛型类型的类型
        T - TreeTableColumn中包含的元素的类型。
        参数
        items - 当显示ComboBox菜单时将显示给用户的零个或多个项目。 这些项目必须与TreeTableColumn类型相同。 请注意，由开发人员设置event handlers以监听TreeTableColumn中的编辑事件，并作出相应的响应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回一个TreeTableCell，它能够处理TreeTableColumn中包含的元素的类型。

      • forTreeTableColumn

        public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter,
                                                                                ObservableList<T> items)
        创建ComboBox单元格工厂，用于TreeTableColumn控件。 默认情况下，ComboBoxCell在不被编辑时呈现为Label ，在编辑模式时则作为ComboBox呈现。 默认情况下，ComboBox将拉伸以填充整个列表单元格。
        参数类型
        S - TreeTableView泛型类型的类型
        T - TreeTableColumn中包含的元素的类型。
        参数
        converter - A StringConverter将给定项目（类型T）转换为用于显示给用户的字符串。
        items - 当显示ComboBox菜单时，将显示给用户的零个或多个项目。 这些项目必须与TreeTableColumn类型相同。 请注意，由开发人员设置event handlers以监听TreeTableColumn中的编辑事件，并作出相应的响应。 感兴趣的方法包括： setOnEditStart ， setOnEditCommit ，并setOnEditCancel 。
        结果
        A Callback将返回一个TreeTableCell，它可以处理TreeTableColumn中包含的元素的类型。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        字符串转换器属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 字符串转换器

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        字符串转换器

      • comboBoxEditableProperty

        public final BooleanProperty comboBoxEditableProperty​()
        表示ComboBox在向用户显示时是否可编辑的属性。
        另请参见：
        isComboBoxEditable() ， setComboBoxEditable(boolean)

      • setComboBoxEditable

        public final void setComboBoxEditable​(boolean value)
        将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。
        参数
        value - 要为此ComboBox设置的可编辑值

      • isComboBoxEditable

        public final boolean isComboBoxEditable​()
        如果ComboBox是可编辑的，则返回true。
        结果
        如果ComboBox是可编辑的，则为true

      • getItems

        public ObservableList<T> getItems​()
        返回要显示在ComboBox中的项目。
        结果
        当该组合框显示时要显示的项目

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 TreeTableCell<S,T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 TreeTableCell<S,T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，如ListView控件）来调用这个方法。 然而，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - whether or not this cell represents data from the list. If it is empty, then it does not represent any domain data, but is a cell being used to render an "empty" row.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.control.cell (Java SE 9 & JDK 9 )

javafx.scene.control.cell

Classes

  • CheckBoxListCell
  • CheckBoxTableCell
  • CheckBoxTreeCell
  • CheckBoxTreeTableCell
  • ChoiceBoxListCell
  • ChoiceBoxTableCell
  • ChoiceBoxTreeCell
  • ChoiceBoxTreeTableCell
  • ComboBoxListCell
  • ComboBoxTableCell
  • ComboBoxTreeCell
  • ComboBoxTreeTableCell
  • MapValueFactory
  • ProgressBarTableCell
  • ProgressBarTreeTableCell
  • PropertyValueFactory
  • TextFieldListCell
  • TextFieldTableCell
  • TextFieldTreeCell
  • TextFieldTreeTableCell
  • TreeItemPropertyValueFactory


javafx.scene.control.cell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.controls

Package javafx.scene.control.cell

所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。 目前这个软件包是比较裸的，但它是未来的单元格相关类的地方。

重要的是要注意，虽然这个包中的大多数单元格都是可编辑的，但要启用单元格编辑功能，需要所有相关的类才能启用编辑。 例如，在TableView中，TableView和相关TableColumn都必须具有setEditing（true）。

  • 类摘要
    Class 描述
    CheckBoxListCell<T>
    一个包含一个ListCell实现的类，它在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
    CheckBoxTableCell<S,T>
    一个包含TableCell实现的类，可以在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
    CheckBoxTreeCell<T>
    一个包含一个TreeCell实现的类，它在单元格中绘制一个CheckBox节点，并支持常见的交互（ 稍后更详细地讨论）。
    CheckBoxTreeTableCell<S,T>
    一个包含一个TreeTableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。
    ChoiceBoxListCell<T>
    一个包含ListCell实现的类，在单元格内绘制一个ChoiceBox节点。
    ChoiceBoxTableCell<S,T>
    一个包含一个TableCell实现的类，它在单元格中绘制一个ChoiceBox节点。
    ChoiceBoxTreeCell<T>
    一个包含ListCell实现的类，在单元格内绘制一个ChoiceBox节点。
    ChoiceBoxTreeTableCell<S,T>
    一个包含TreeTableCell实现的类，在单元格内绘制一个ChoiceBox节点。
    ComboBoxListCell<T>
    一个包含ListCell实现的类，在单元格内绘制一个ComboBox节点。
    ComboBoxTableCell<S,T>
    一个包含TableCell实现的类，在单元格内绘制一个ComboBox节点。
    ComboBoxTreeCell<T>
    一个包含TreeCell实现的类，在单元格内绘制一个ComboBox节点。
    ComboBoxTreeTableCell<S,T>
    一个包含一个TreeTableCell实现的类，它在单元格中绘制一个ComboBox节点。
    MapValueFactory<T>
    Callback界面的方便实现，专为TableColumn cell value factory中使用而设计。
    ProgressBarTableCell<S>
    一个包含TableCell实现的类，在单元格内绘制一个ProgressBar节点。
    ProgressBarTreeTableCell<S>
    一个包含TreeTableCell实现的类，在单元格内绘制一个ProgressBar节点。
    PropertyValueFactory<S,T>
    Callback界面的方便实现，专门设计用于TableColumn cell value factory 。
    TextFieldListCell<T>
    一个包含ListCell实现的类，它在单元格内绘制一个TextField节点。
    TextFieldTableCell<S,T>
    一个包含TableCell实现的类，在单元格内绘制一个TextField节点。
    TextFieldTreeCell<T>
    一个包含TreeCell实现的类，在单元格内绘制一个TextField节点。
    TextFieldTreeTableCell<S,T>
    一个包含TableCell实现的类，在该单元格内绘制一个TextField节点。
    TreeItemPropertyValueFactory<S,T>
    Callback界面的方便实现，专为TreeTableColumn cell value factory中使用而设计。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.control.cell Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.control.cell

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.control.cell.MapValueFactory<T> (implements javafx.util.Callback<P,R>)
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control (implements javafx.scene.control.Skinnable)
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.ListCell<T>
                    • javafx.scene.control.cell.CheckBoxListCell<T>
                    • javafx.scene.control.cell.ChoiceBoxListCell<T>
                    • javafx.scene.control.cell.ComboBoxListCell<T>
                    • javafx.scene.control.cell.TextFieldListCell<T>
                  • javafx.scene.control.TableCell<S,T>
                    • javafx.scene.control.cell.CheckBoxTableCell<S,T>
                    • javafx.scene.control.cell.ChoiceBoxTableCell<S,T>
                    • javafx.scene.control.cell.ComboBoxTableCell<S,T>
                    • javafx.scene.control.cell.ProgressBarTableCell<S>
                    • javafx.scene.control.cell.TextFieldTableCell<S,T>
                  • javafx.scene.control.TreeCell<T>
                    • javafx.scene.control.cell.CheckBoxTreeCell<T>
                    • javafx.scene.control.cell.ChoiceBoxTreeCell<T>
                    • javafx.scene.control.cell.ComboBoxTreeCell<T>
                    • javafx.scene.control.cell.TextFieldTreeCell<T>
                  • javafx.scene.control.TreeTableCell<S,T>
                    • javafx.scene.control.cell.CheckBoxTreeTableCell<S,T>
                    • javafx.scene.control.cell.ChoiceBoxTreeTableCell<S,T>
                    • javafx.scene.control.cell.ComboBoxTreeTableCell<S,T>
                    • javafx.scene.control.cell.ProgressBarTreeTableCell<S>
                    • javafx.scene.control.cell.TextFieldTreeTableCell<S,T>
    • javafx.scene.control.cell.PropertyValueFactory<S,T> (implements javafx.util.Callback<P,R>)
    • javafx.scene.control.cell.TreeItemPropertyValueFactory<S,T> (implements javafx.util.Callback<P,R>)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


MapValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class MapValueFactory<T>

  • java.lang.Object
    • javafx.scene.control.cell.MapValueFactory<T>
  • 参数类型
    T - TableColumn单元格中包含的类的类型。
    All Implemented Interfaces:
    Callback<TableColumn.CellDataFeatures<Map,T>,ObservableValue<T>>

    public class MapValueFactory<T>
extends Object
implements Callback<TableColumn.CellDataFeatures<Map,T>,ObservableValue<T>>
    Callback界面的方便实现，专为TableColumn cell value factory使用而设计。 如何使用这个类的一个例子是：
       ObservableList<Map> personsMapList = ... TableColumn<Map, String> firstNameColumn = new TableColumn<Map, String>("First Name"); firstNameColumn.setCellValueFactory(new MapValueFactory<String>("firstName")); TableView<Map> table = new TableView<Map>(personMapList); tableView.getColumns().setAll(firstNameColumn);

    在此示例中，有一个Map实例列表，其中每个Map实例在TableView中代表一行。 “firstName”字符串用作该映射的密钥，如果存在，则返回与该密钥对应的值。 如果值为ObservableValue ，则直接返回，否则值将包装在一个ReadOnlyObjectWrapper中 。

    从以下版本开始：
    JavaFX 2.2
    另请参见：
    TableColumn ， TableView ， TableCell ， PropertyValueFactory

    • 构造方法摘要

      构造方法
      Constructor 描述
      MapValueFactory​(Object key)
      创建一个默认的MapValueFactory，它将使用提供的键来查找安装此MapValueFactory的TableColumn中的单元格值（通过cell value factory属性）。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableValue<T> call​(TableColumn.CellDataFeatures<Map,T> cdf)
      call方法在需要时被调用，并且被赋予类型为P的单个参数，并且要求返回类型为R的对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MapValueFactory

        public MapValueFactory​(Object key)
        创建默认的MapValueFactory，它将使用提供的键来查找安装此MapValueFactory的TableColumn中的单元格值（通过cell value factory属性）。
        参数
        key - 用于查找 Map的值的 Map 。

    • 方法详细信息

      • call

        public ObservableValue<T> call​(TableColumn.CellDataFeatures<Map,T> cdf)
        描述从接口Callback复制
        call方法在需要时被调用，并且被赋予类型为P的单个参数，并要求返回类型为R的对象。
        Specified by:
        call在接口 Callback<TableColumn.CellDataFeatures<Map,T>,ObservableValue<T>>
        参数
        cdf - 应该确定返回值的单个参数。
        结果
        可以基于所提供的参数值来确定类型R的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProgressBarTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ProgressBarTableCell<S>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TableCell<S,Double>
                    • javafx.scene.control.cell.ProgressBarTableCell<S>
  • 参数类型
    S - TableView中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ProgressBarTableCell<S>
extends TableCell<S,Double>
    一个包含TableCell实现的类，在该单元格内绘制一个ProgressBar节点。
    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TableCell

        tableColumn, tableRow, tableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProgressBarTableCell​()
      创建默认的ProgressBarTableCell实例

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static <S> Callback<TableColumn<S,Double>,TableCell<S,Double>> forTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0的容易显示数字值。
      void updateItem​(Double item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TableCell

        cancelEdit, commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTableRow, getTableView, layoutChildren, queryAccessibleAttribute, startEdit, tableColumnProperty, tableRowProperty, tableViewProperty, updateSelected, updateTableColumn, updateTableRow, updateTableView

    • 构造方法详细信息

      • ProgressBarTableCell

        public ProgressBarTableCell​()
        创建默认的ProgressBarTableCell实例

    • 方法详细信息

      • forTableColumn

        public static <S> Callback<TableColumn<S,Double>,TableCell<S,Double>> forTableColumn​()
        提供一个ProgressBar ，允许从0.0到1.0的容易显示数字值。 如果值为-1，进度条将显示不确定。
        参数类型
        S - TableView通用类型的类型
        结果
        A Callback可以插入到TableColumn的cell factory property中，使得数字可以从0.0到1.0进行显示。

      • updateItem

        public void updateItem​(Double item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是让开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<Double>
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProgressBarTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class ProgressBarTreeTableCell<S>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeTableCell<S,Double>
                    • javafx.scene.control.cell.ProgressBarTreeTableCell<S>
  • 参数类型
    S - TableView中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class ProgressBarTreeTableCell<S>
extends TreeTableCell<S,Double>
    一个包含一个TreeTableCell实现的类，它在单元格内绘制一个ProgressBar节点。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TreeTableCell

        tableColumn, tableRow, treeTableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProgressBarTreeTableCell​()
      创建默认的ProgressBarTreeTableCell实例

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static <S> Callback<TreeTableColumn<S,Double>,TreeTableCell<S,Double>> forTreeTableColumn​()
      提供了一个ProgressBar ，允许从0.0到1.0进行数字值的轻松可视化。
      void updateItem​(Double item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TreeTableCell

        cancelEdit, commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTreeTableRow, getTreeTableView, layoutChildren, queryAccessibleAttribute, startEdit, tableColumnProperty, tableRowProperty, treeTableViewProperty, updateSelected, updateTreeTableColumn, updateTreeTableRow, updateTreeTableView

    • 构造方法详细信息

      • ProgressBarTreeTableCell

        public ProgressBarTreeTableCell​()
        创建默认的ProgressBarTreeTableCell实例

    • 方法详细信息

      • forTreeTableColumn

        public static <S> Callback<TreeTableColumn<S,Double>,TreeTableCell<S,Double>> forTreeTableColumn​()
        提供一个ProgressBar ，允许从0.0到1.0的容易显示数字值。 如果值为-1，进度条将显示不确定。
        参数类型
        S - TreeTableView泛型类型的类型
        结果
        可以将Callback插入到TreeTableColumn的cell factory property中，从而可以将数字从0.0到1.0进行显示。

      • updateItem

        public void updateItem​(Double item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了弄清楚，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，比如ListView控件）来调用这个方法。 然而，使用updateItem方法的目的是使开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem类 Cell<Double>
        参数
        item - 单元格的新项目。
        empty - 此单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PropertyValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class PropertyValueFactory<S,T>

  • java.lang.Object
    • javafx.scene.control.cell.PropertyValueFactory<S,T>
  • 参数类型
    S - TableView.items列表中包含的类的类型。
    T - TableColumn单元格中包含的类的类型。
    All Implemented Interfaces:
    Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>

    public class PropertyValueFactory<S,T>
extends Object
implements Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>
    Callback界面的方便实现，专为TableColumn cell value factory使用而设计。 如何使用这个类的一个例子是：
       TableColumn<Person,String> firstNameCol = new TableColumn<Person,String>("First Name"); firstNameCol.setCellValueFactory(new PropertyValueFactory<Person,String>("firstName"));

    在这个例子中， Person是TableView items列表的类型。 Person必须宣布为公开。 PropertyValueFactory使用构造函数参数"firstName"来假定Person具有公共方法firstNameProperty ，没有形式参数，返回类型为ObservableValue<String> 。

    如果存在这样的方法，那么它将被调用，另外假设返回一个Property<String>的实例。 返回值用于填充TableCell 。 此外， TableView增加观察者的返回值，使得烧制的任何变化将通过观察TableView ，导致细胞立即更新。

    如果不存在这样的方法，则PropertyValueFactory假设Person具有公共方法getFirstName或isFirstName ，没有形式参数，返回类型为String 。 如果存在这样的方法，那么它将被调用，它的返回值被包装在一个ReadOnlyObjectWrapper中并返回到TableCell 。 在这种情况下， TableCell将无法观察到财产的变化，与上述第一种方法不同。

    作为参考（并且如表格cell value factory文档中所述），上述代码的长形式将是以下内容：

       TableColumn<Person,String> firstNameCol = new TableColumn<Person,String>("First Name"); firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the Person instance for a particular TableView row return p.getValue().firstNameProperty(); } }); }

    将应用程序部署为模块

    如果引用的类在命名模块中，那么它必须反映可访问javafx.base模块。 如果模块opens将包含的包至少为javafx.base模块，则可以反射访问类。 否则， call(TableColumn.CellDataFeatures)方法将记录一个警告并返回null 。

    例如，如果Person类在foo.app模块中的com.foo包中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射地访问类。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    TableColumn ， TableView ， TableCell ， TreeItemPropertyValueFactory ， MapValueFactory

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyValueFactory​(String property)
      创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableValue<T> call​(TableColumn.CellDataFeatures<S,T> param)
      当需要时调用 call方法，并且给出类型为P的单个参数，并要求返回类型为R的对象。
      String getProperty​()
      返回构造函数中提供的属性名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PropertyValueFactory

        public PropertyValueFactory​(String property)
        创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。
        参数
        property - 试图在给定对象中反映提取相应值的属性名称。

    • 方法详细信息

      • call

        public ObservableValue<T> call​(TableColumn.CellDataFeatures<S,T> param)
        call方法在需要时被调用，并且被赋予类型为P的单个参数，并且要求返回类型为R的对象。
        Specified by:
        call在接口 Callback<S,T>
        参数
        param - 应该确定返回值的单个参数。
        结果
        可以基于所提供的参数值来确定类型R的对象。

      • getProperty

        public final String getProperty​()
        返回构造函数中提供的属性名称。
        结果
        构造函数中提供的属性名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextFieldListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class TextFieldListCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.ListCell<T>
                    • javafx.scene.control.cell.TextFieldListCell<T>
  • 参数类型
    T - ListView中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class TextFieldListCell<T>
extends ListCell<T>
    一个包含ListCell实现的类，在单元格内绘制一个TextField节点。

    默认情况下，TextFieldListCell在不被编辑时被渲染为Label ，在编辑模式时作为TextField呈现。 默认情况下，TextField将拉伸以填充整个列表单元格。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.control.ListCell

        listView

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextFieldListCell​()
      使用零转换器创建默认的TextFieldListCell。
      TextFieldListCell​(StringConverter<T> converter)
      创建一个TextFieldListCell，当进入编辑模式时，可以编辑TextField单元格内容。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static Callback<ListView<String>,ListCell<String>> forListView​()
      提供TextField ，使单元格内容的编辑在小区双击，或者当ListView.edit(int)被调用。
      static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter)
      提供TextField ，允许双击单元格时或当调用ListView.edit(int)时对单元格内容进行编辑。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.control.ListCell

        commitEdit, createDefaultSkin, executeAccessibleAction, getListView, listViewProperty, queryAccessibleAttribute, updateListView

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

    • 构造方法详细信息

      • TextFieldListCell

        public TextFieldListCell​()
        使用零转换器创建默认的TextFieldListCell。 没有指定一个270687394661414 ，这个单元格将无法接受TextField的输入（因为它不知道如何将它转换回该域对象）。 因此，强烈建议不要使用此构造函数，除非您打算单独设置转换器。

      • TextFieldListCell

        public TextFieldListCell​(StringConverter<T> converter)
        创建一个TextFieldListCell，它在编辑模式时提供TextField ，允许编辑单元格内容。 此方法将适用于任何ListView实例，无论其泛型类型如何。 然而，为了实现这一点，必须提供一个StringConverter ，它将把给定的String（从用户输入的字符串）转换为类型T的一个实例。然后这个项目将被传递给ListView.onEditCommitProperty()回调。
        参数
        converter - A converter可以将给定的String（从用户输入的字符串）转换为类型T的实例。

    • 方法详细信息

      • forListView

        public static Callback<ListView<String>,ListCell<String>> forListView​()
        提供了一个TextField ，允许在双击单元格时调用单元格内容，或者调用ListView.edit(int)时。 此方法仅适用于类型为String的ListView个实例。
        结果
        A Callback可以插入到ListView的cell factory property中，可以对内容进行文本编辑。

      • forListView

        public static <T> Callback<ListView<T>,ListCell<T>> forListView​(StringConverter<T> converter)
        提供TextField ，使单元格内容的编辑在小区双击，或者当ListView.edit(int)被调用。 此方法将适用于任何ListView实例，无论其泛型类型如何。 但是，为了实现这一点，必须提供一个StringConverter ，它将把给定的字符串（从用户输入的字符串）转换为类型T的实例。然后将该项目传递给ListView.onEditCommitProperty()回调。
        参数类型
        T - 单元格中包含的项目的类型
        参数
        converter - A StringConverter可以将给定的String（从用户输入的字符串）转换为类型T的实例。
        结果
        A Callback可以插入到ListView的cell factory property中，可以对内容进行文本编辑。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter财产

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit ListCell<T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 ListCell<T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了弄清楚，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，比如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是让开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextFieldTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class TextFieldTableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TableCell<S,T>
                    • javafx.scene.control.cell.TextFieldTableCell<S,T>
  • 参数类型
    S - TableView通用类型的类型
    T - TableColumn中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class TextFieldTableCell<S,T>
extends TableCell<S,T>
    一个包含TableCell实现的类，它在单元格内绘制一个TextField节点。

    默认情况下，TextFieldTableCell在不被编辑时呈现为Label ，在编辑模式时呈现为TextField。 默认情况下，TextField将拉伸以填充整个表单元格。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TableCell

        tableColumn, tableRow, tableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextFieldTableCell​()
      使用零转换器创建默认的TextFieldTableCell。
      TextFieldTableCell​(StringConverter<T> converter)
      创建一个TextFieldTableCell，它在编辑模式时提供TextField ，允许编辑单元格内容。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static <S> Callback<TableColumn<S,String>,TableCell<S,String>> forTableColumn​()
      提供TextField ，允许在双击单元格时调用单元格内容，或调用TableView.edit(int, javafx.scene.control.TableColumn)时。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时调用单元格内容，或调用TableView.edit(int, javafx.scene.control.TableColumn)时。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TableCell

        commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTableRow, getTableView, layoutChildren, queryAccessibleAttribute, tableColumnProperty, tableRowProperty, tableViewProperty, updateSelected, updateTableColumn, updateTableRow, updateTableView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter的财产。
        结果
        StringConverter属性

    • 构造方法详细信息

      • TextFieldTableCell

        public TextFieldTableCell​()
        使用零转换器创建默认的TextFieldTableCell。 没有指定StringConverter ，该单元格将无法接受来自TextField的输入（因为它不会知道如何将其转换回域对象）。 因此，强烈建议不要使用此构造函数，除非您打算单独设置转换器。

      • TextFieldTableCell

        public TextFieldTableCell​(StringConverter<T> converter)
        创建一个TextFieldTableCell，当进入允许编辑单元格内容的编辑模式时，提供一个TextField 。 此方法将适用于任何TableColumn实例，无论其泛型类型如何。 但是，为了实现这一点，必须提供一个StringConverter ，它将把给定的String（从用户输入的字符串）转换为类型T的一个实例。然后这个项目将被传递给TableColumn.onEditCommitProperty()回调。
        参数
        converter - A converter可以将给定的字符串（从用户输入的内容）转换为类型T的实例。

    • 方法详细信息

      • forTableColumn

        public static <S> Callback<TableColumn<S,String>,TableCell<S,String>> forTableColumn​()
        提供TextField ，使单元格内容的编辑在小区双击，或者当TableView.edit(int, javafx.scene.control.TableColumn)被调用。 此方法仅适用于类型为String的TableColumn实例。
        参数类型
        S - TableView通用类型的类型
        结果
        A Callback可以插入到TableColumn的cell factory property中，可以对内容进行文本编辑。

      • forTableColumn

        public static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> forTableColumn​(StringConverter<T> converter)
        提供一个TextField ，允许在双击单元格时调用单元格内容，或者调用TableView.edit(int, javafx.scene.control.TableColumn)时。 该方法将适用于任何TableColumn实例，无论其通用类型如何。 但是，为了实现这一点，必须提供一个StringConverter ，将把给定的String（从用户输入的字符串）转换为类型T的实例。然后将该项目传递给TableColumn.onEditCommitProperty()回调。
        参数类型
        S - TableView通用类型的类型
        T - TableColumn中包含的元素的类型
        参数
        converter - 一个StringConverter ，可以将给定的字符串（从用户输入的字符串）转换为类型T的实例。
        结果
        A Callback可以插入到TableColumn的cell factory property中，可以对内容进行文本编辑。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 TableCell<S,T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 TableCell<S,T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，比如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是使开发人员在指定自定义单元格工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - whether or not this cell represents data from the list. If it is empty, then it does not represent any domain data, but is a cell being used to render an "empty" row.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextFieldTreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class TextFieldTreeCell<T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeCell<T>
                    • javafx.scene.control.cell.TextFieldTreeCell<T>
  • 参数类型
    T - TreeView中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class TextFieldTreeCell<T>
extends TreeCell<T>
    一个包含一个TreeCell实现的类，它在单元格中绘制一个TextField节点。

    默认情况下，TextFieldTreeCell在不被编辑时呈现为Label ，在编辑模式时呈现为TextField。 默认情况下，TextField将拉伸以填充整个树单元格。

    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TreeCell

        disclosureNode, treeItem, treeView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextFieldTreeCell​()
      使用空转换器创建默认的TextFieldTreeCell。
      TextFieldTreeCell​(StringConverter<T> converter)
      创建一个TextFieldTreeCell，它在编辑模式时提供TextField ，允许编辑单元格内容。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter属性。
      static Callback<TreeView<String>,TreeCell<String>> forTreeView​()
      提供一个TextField ，允许在双击单元格时调用单元格内容，或者调用TreeView.edit(javafx.scene.control.TreeItem)时。
      static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter)
      提供TextField ，使单元格内容的编辑在小区双击，或者当TreeView.edit(javafx.scene.control.TreeItem)被调用。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, layoutChildren, selectedProperty, setEditable, setItem, updateSelected

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TreeCell

        commitEdit, createDefaultSkin, disclosureNodeProperty, executeAccessibleAction, getDisclosureNode, getTreeItem, getTreeView, queryAccessibleAttribute, setDisclosureNode, treeItemProperty, treeViewProperty, updateTreeItem, updateTreeView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

    • 构造方法详细信息

      • TextFieldTreeCell

        public TextFieldTreeCell​()
        使用空转换器创建默认的TextFieldTreeCell。 没有指定一个StringConverter ，这个单元格将无法接受TextField的输入（因为它不会知道如何将它转换回该域对象）。 因此，强烈建议不要使用此构造函数，除非您打算单独设置转换器。

      • TextFieldTreeCell

        public TextFieldTreeCell​(StringConverter<T> converter)
        创建一个TextFieldTreeCell，当进入允许编辑单元格内容的编辑模式时提供一个TextField 。 此方法将适用于任何TreeView实例，无论其通用类型如何。 但是，为了实现这一点，必须提供一个StringConverter ，它将把给定的String（从用户输入的字符串）转换为类型T的一个实例。然后将这个项目传递给TreeView.onEditCommitProperty()回调。
        参数
        converter - A converter可以将给定的字符串（从用户输入的字符串）转换为类型T的实例。

    • 方法详细信息

      • forTreeView

        public static Callback<TreeView<String>,TreeCell<String>> forTreeView​()
        提供TextField ，使单元格内容的编辑在小区双击，或者当TreeView.edit(javafx.scene.control.TreeItem)被调用。 此方法仅适用于类型为String的TreeView实例。
        结果
        一个Callback可以插入到一个TreeView的cell factory property中，可以对内容进行文本编辑。

      • forTreeView

        public static <T> Callback<TreeView<T>,TreeCell<T>> forTreeView​(StringConverter<T> converter)
        提供TextField ，允许在双击单元格时调用单元格内容，或者调用TreeView.edit(javafx.scene.control.TreeItem)时。 此方法将适用于任何TreeView实例，无论其通用类型如何。 但是，为了实现这一点，必须提供一个StringConverter ，将把给定的字符串（从用户输入的字符串）转换为类型T的实例。然后，该项目将被传递给TreeView.onEditCommitProperty()回调。
        参数类型
        T - TreeView中包含的元素的类型
        参数
        converter - A StringConverter可以将给定的字符串（从用户输入的字符串）转换为类型T的实例。
        结果
        一个Callback可以插入到一个TreeView的cell factory property中，可以对内容进行文本编辑。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 要在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 TreeCell<T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 TreeCell<T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是让开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        参数
        item - 单元格的新项目。
        empty - 该单元格是否表示列表中的数据。 如果它是空的，那么它不表示任何域数据，而是用于呈现“空”行的单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextFieldTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class TextFieldTreeTableCell<S,T>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.control.Labeled
              • javafx.scene.control.Cell<T>
                • javafx.scene.control.IndexedCell<T>
                  • javafx.scene.control.TreeTableCell<S,T>
                    • javafx.scene.control.cell.TextFieldTreeTableCell<S,T>
  • 参数类型
    S - TreeTableView泛型类型的类型
    T - TreeTableColumn中包含的元素的类型。
    All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class TextFieldTreeTableCell<S,T>
extends TreeTableCell<S,T>
    一个包含一个TableCell实现的类，它在单元格中绘制一个TextField节点。

    默认情况下，TextFieldTableCell在不被编辑时呈现为Label ，在编辑模式时呈现为TextField。 默认情况下，TextField将拉伸以填充整个表单元格。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<StringConverter<T>> converter
      StringConverter属性。

      • Properties inherited from class javafx.scene.control.Cell

        editable, editing, empty, item, selected

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.control.IndexedCell

        index

      • Properties inherited from class javafx.scene.control.Labeled

        alignment, contentDisplay, ellipsisString, font, graphic, graphicTextGap, labelPadding, lineSpacing, mnemonicParsing, textAlignment, textFill, textOverrun, text, underline, wrapText

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.TreeTableCell

        tableColumn, tableRow, treeTableView

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextFieldTreeTableCell​()
      使用零转换器创建默认的TextFieldTreeTableCell。
      TextFieldTreeTableCell​(StringConverter<T> converter)
      创建一个TextFieldTreeTableCell，当进入允许编辑单元格内容的编辑模式时，它将提供TextField 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancelEdit​()
      调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
      ObjectProperty<StringConverter<T>> converterProperty​()
      StringConverter财产。
      static <S> Callback<TreeTableColumn<S,String>,TreeTableCell<S,String>> forTreeTableColumn​()
      提供TextField ，允许在双击单元格时调用单元格内容，或调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时调用单元格内容，或者调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。
      StringConverter<T> getConverter​()
      返回此单元格中使用的StringConverter 。
      void setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void startEdit​()
      调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。
      void updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

      • Methods inherited from class javafx.scene.control.Cell

        editableProperty, editingProperty, emptyProperty, getInitialFocusTraversable, getItem, isEditable, isEditing, isEmpty, isItemChanged, isSelected, itemProperty, selectedProperty, setEditable, setItem

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, getBaselineOffset, getContextMenu, getCssMetaData, getSkin, getTooltip, isResizable, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.control.IndexedCell

        getIndex, indexProperty, updateIndex

      • Methods inherited from class javafx.scene.control.Labeled

        alignmentProperty, contentDisplayProperty, ellipsisStringProperty, fontProperty, getAlignment, getClassCssMetaData, getContentBias, getContentDisplay, getControlCssMetaData, getEllipsisString, getFont, getGraphic, getGraphicTextGap, getInitialAlignment, getLabelPadding, getLineSpacing, getText, getTextAlignment, getTextFill, getTextOverrun, graphicProperty, graphicTextGapProperty, isMnemonicParsing, isUnderline, isWrapText, labelPaddingProperty, lineSpacingProperty, mnemonicParsingProperty, setAlignment, setContentDisplay, setEllipsisString, setFont, setGraphic, setGraphicTextGap, setLineSpacing, setMnemonicParsing, setText, setTextAlignment, setTextFill, setTextOverrun, setUnderline, setWrapText, textAlignmentProperty, textFillProperty, textOverrunProperty, textProperty, toString, underlineProperty, wrapTextProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.TreeTableCell

        commitEdit, createDefaultSkin, executeAccessibleAction, getTableColumn, getTreeTableRow, getTreeTableView, layoutChildren, queryAccessibleAttribute, tableColumnProperty, tableRowProperty, treeTableViewProperty, updateSelected, updateTreeTableColumn, updateTreeTableRow, updateTreeTableView

    • Property Detail

      • converter

        public final ObjectProperty<StringConverter<T>> converterProperty
        StringConverter属性。
        结果
        StringConverter属性

    • 构造方法详细信息

      • TextFieldTreeTableCell

        public TextFieldTreeTableCell​()
        使用零转换器创建默认的TextFieldTreeTableCell。 没有指定一个StringConverter ，该单元格将无法接受TextField的输入（因为它将不知道如何将此转换回该域对象）。 因此，强烈建议不要使用此构造函数，除非您打算单独设置转换器。

      • TextFieldTreeTableCell

        public TextFieldTreeTableCell​(StringConverter<T> converter)
        创建一个TextFieldTreeTableCell，它在编辑模式时提供TextField ，允许编辑单元格内容。 此方法将适用于任何TreeTableColumn实例，无论其泛型类型如何。 但是，为了实现这一点，必须提供一个StringConverter ，它会将给定的String（从用户输入的字符串）转换为类型T的实例。然后将该项目传递给TreeTableColumn.onEditCommitProperty()回调。
        参数
        converter - A converter可以将给定的字符串（从用户输入的字符串）转换为类型T的实例。

    • 方法详细信息

      • forTreeTableColumn

        public static <S> Callback<TreeTableColumn<S,String>,TreeTableCell<S,String>> forTreeTableColumn​()
        提供一个TextField ，允许在双击单元格时调用单元格内容，或者调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。 此方法仅适用于类型为String的TreeTableColumn实例。
        参数类型
        S - TreeTableView泛型类型的类型
        结果
        一个Callback可以插入到一个TreeTableColumn的cell factory property中，可以对内容进行文本编辑。

      • forTreeTableColumn

        public static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> forTreeTableColumn​(StringConverter<T> converter)
        提供TextField ，允许在双击单元格时调用单元格内容，或调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。 此方法将适用于任何TreeTableColumn实例，无论其通用类型如何。 但是，为了实现这一点，必须提供一个StringConverter ，它将把给定的String（从用户输入的字符串）转换为类型T的一个实例。然后这个项目将被传递给TreeTableColumn.onEditCommitProperty()回调。
        参数类型
        S - TreeTableView泛型类型的类型
        T - 包含在TreeTableColumn中的元素的类型
        参数
        converter - A StringConverter ，可以将给定的字符串（从用户输入的字符串）转换为类型T的实例。
        结果
        一个Callback ，可以插入到一个TreeTableColumn的cell factory property中，可以对内容进行文本编辑。

      • converterProperty

        public final ObjectProperty<StringConverter<T>> converterProperty​()
        StringConverter属性。
        结果
        StringConverter属性

      • setConverter

        public final void setConverter​(StringConverter<T> value)
        设置要在此单元格中使用的StringConverter 。
        参数
        value - 在这个单元格中使用的StringConverter

      • getConverter

        public final StringConverter<T> getConverter​()
        返回此单元格中使用的StringConverter 。
        结果
        在这个单元格中使用的StringConverter

      • startEdit

        public void startEdit​()
        调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。 如果这个单元格已经处于编辑状态，它将保留在它中。
        重写：
        startEdit在 TreeTableCell<S,T>

      • cancelEdit

        public void cancelEdit​()
        调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。
        重写：
        cancelEdit在 TreeTableCell<S,T>

      • updateItem

        public void updateItem​(T item,
                       boolean empty)
        updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。 为了澄清，开发人员不应该在他们的代码中调用这个方法（他们应该留给UI控件，如ListView控件）来调用这个方法。 但是，使用updateItem方法的目的是让开发人员在指定自定义单元工厂时（再次像ListView cell factory ），可以覆盖updateItem方法以允许对单元格进行完全自定义。

        非常重要的是，Cell的子类会正确覆盖updateItem方法，因为这样做会导致诸如空白单元格或其中出现意外内容的单元格等问题。 以下是如何正确覆盖updateItem方法的示例：

          protected void updateItem(T item, boolean empty) {
     super.updateItem(item, empty);

     if (empty || item == null) {
         setText(null);
         setGraphic(null);
     } else {
         setText(item.toString());
     }
 }

        注意在这段代码示例中的两个重点：

        1. 我们称之为super.updateItem（T，boolean）方法。 如果没有这样做，项目和空属性设置不正确，您可能会遇到图形问题。
        2. 我们测试empty条件，如果为true，我们将文本和图形属性设置为null。 如果我们不这样做，几乎可以保证最终用户意外地看到细胞中的图形工件。
        重写：
        updateItem在 Cell<T>
        参数
        item - 单元格的新项目。
        empty - whether or not this cell represents data from the list. If it is empty, then it does not represent any domain data, but is a cell being used to render an "empty" row.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeItemPropertyValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.cell

Class TreeItemPropertyValueFactory<S,T>

  • java.lang.Object
    • javafx.scene.control.cell.TreeItemPropertyValueFactory<S,T>
  • All Implemented Interfaces:
    Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>

    public class TreeItemPropertyValueFactory<S,T>
extends Object
implements Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>
    Callback界面的方便实现，专为TreeTableColumn cell value factory中使用而设计。 如何使用这个类的一个例子是：
       TreeTableColumn<Person,String> firstNameCol = new TreeTableColumn<Person,String>("First Name"); firstNameCol.setCellValueFactory(new TreeItemPropertyValueFactory<Person,String>("firstName"));

    在这个例子中， Person是类类型的的TreeItem个在所使用的实例TreeTableView 。 Person类必须被声明为public。 TreeItemPropertyValueFactory使用构造函数参数"firstName"假设Person具有公共方法firstNameProperty ，没有形式参数，返回类型为ObservableValue<String> 。

    如果存在这种方法，那么它将被调用，并且另外假设返回一个Property<String>的实例。 返回值用于填充TreeTableCell 。 此外， TreeTableView增加观察者的返回值，使得烧制的任何变化将通过观察TreeTableView ，导致细胞立即更新。

    如果不存在这样的方法，则TreeItemPropertyValueFactory假设Person具有公共方法getFirstName或isFirstName ，没有形式参数，返回类型为String 。 如果存在这样的方法，那么它将被调用，并且它的返回值被包装在一个ReadOnlyObjectWrapper中并返回到TreeTableCell 。 在这种情况下， TreeTableCell将无法观察到财产的变化，与上述第一种方法不同。

    为了参考（并且在TreeTableColumn cell value factory文档中指出），上面代码的长形式将是以下内容：

       TreeTableColumn<Person,String> firstNameCol = new TreeTableColumn<Person,String>("First Name"); firstNameCol.setCellValueFactory(new Callback<CellDataFeatures<Person, String>, ObservableValue<String>>() { public ObservableValue<String> call(CellDataFeatures<Person, String> p) { // p.getValue() returns the TreeItem<Person> instance for a particular // TreeTableView row, and the second getValue() call returns the // Person instance contained within the TreeItem. return p.getValue().getValue().firstNameProperty(); } }); }

    将应用程序部署为模块

    如果引用的类在一个命名的模块中，那么javafx.base模块必须能反映javafx.base 。 如果模块opens包含至少包含javafx.base模块，则类可以反射访问。 否则call(TreeTableColumn.CellDataFeatures)方法会记录一个警告并返回null 。

    例如，如果Person类在foo.app模块中的com.foo包中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.base; }

    或者，如果模块exports无条件地包含包，则可以反射地访问类。

    从以下版本开始：
    JavaFX 8.0
    另请参见：
    TreeTableColumn ， TreeTableView ， TreeTableCell ， PropertyValueFactory ， MapValueFactory

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeItemPropertyValueFactory​(String property)
      创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableValue<T> call​(TreeTableColumn.CellDataFeatures<S,T> param)
      call方法在需要时被调用，并且被赋予类型为P的单个参数，并且要求返回类型为R的对象。
      String getProperty​()
      返回构造函数中提供的属性名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TreeItemPropertyValueFactory

        public TreeItemPropertyValueFactory​(String property)
        创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。
        参数
        property - 试图在给定对象中反映提取相应值的属性名称。

    • 方法详细信息

      • call

        public ObservableValue<T> call​(TreeTableColumn.CellDataFeatures<S,T> param)
        call方法在需要时被调用，并且被赋予类型为P的单个参数，要求返回类型为R的对象。
        Specified by:
        call在接口 Callback<S,T>
        参数
        param - 应该确定返回值的单个参数。
        结果
        可以基于所提供的参数值来确定类型R的对象。

      • getProperty

        public final String getProperty​()
        返回构造函数中提供的属性名称。
        结果
        构造函数中提供的属性名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.control.cell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.control.cell

No usage of javafx.scene.control.cell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.CheckBoxListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.CheckBoxListCell

No usage of javafx.scene.control.cell.CheckBoxListCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.CheckBoxTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.CheckBoxTableCell

No usage of javafx.scene.control.cell.CheckBoxTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.CheckBoxTreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.CheckBoxTreeCell

No usage of javafx.scene.control.cell.CheckBoxTreeCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.CheckBoxTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.CheckBoxTreeTableCell

No usage of javafx.scene.control.cell.CheckBoxTreeTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ChoiceBoxListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ChoiceBoxListCell

No usage of javafx.scene.control.cell.ChoiceBoxListCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ChoiceBoxTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ChoiceBoxTableCell

No usage of javafx.scene.control.cell.ChoiceBoxTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ChoiceBoxTreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ChoiceBoxTreeCell

No usage of javafx.scene.control.cell.ChoiceBoxTreeCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ChoiceBoxTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ChoiceBoxTreeTableCell

No usage of javafx.scene.control.cell.ChoiceBoxTreeTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ComboBoxListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ComboBoxListCell

No usage of javafx.scene.control.cell.ComboBoxListCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ComboBoxTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ComboBoxTableCell

No usage of javafx.scene.control.cell.ComboBoxTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ComboBoxTreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ComboBoxTreeCell

No usage of javafx.scene.control.cell.ComboBoxTreeCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ComboBoxTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ComboBoxTreeTableCell

No usage of javafx.scene.control.cell.ComboBoxTreeTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.MapValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.MapValueFactory

No usage of javafx.scene.control.cell.MapValueFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ProgressBarTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ProgressBarTableCell

No usage of javafx.scene.control.cell.ProgressBarTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.ProgressBarTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.ProgressBarTreeTableCell

No usage of javafx.scene.control.cell.ProgressBarTreeTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.PropertyValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.PropertyValueFactory

No usage of javafx.scene.control.cell.PropertyValueFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.TextFieldListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.TextFieldListCell

No usage of javafx.scene.control.cell.TextFieldListCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.TextFieldTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.TextFieldTableCell

No usage of javafx.scene.control.cell.TextFieldTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.TextFieldTreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.TextFieldTreeCell

No usage of javafx.scene.control.cell.TextFieldTreeCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.TextFieldTreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.TextFieldTreeTableCell

No usage of javafx.scene.control.cell.TextFieldTreeTableCell
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.cell.TreeItemPropertyValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.cell.TreeItemPropertyValueFactory

No usage of javafx.scene.control.cell.TreeItemPropertyValueFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Accordion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Accordion

  • Packages that use Accordion
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Accordion in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type Accordion
      Constructor 描述
      AccordionSkin​(Accordion control)
      创建一个新的AccordionSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Alert (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Alert

No usage of javafx.scene.control.Alert
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Alert.AlertType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Alert.AlertType

  • Packages that use Alert.AlertType
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of Alert.AlertType in javafx.scene.control

      Methods in javafx.scene.control that return Alert.AlertType
      Modifier and Type 方法 描述
      Alert.AlertType Alert.getAlertType​()
      获取属性alertType的值。
      static Alert.AlertType Alert.AlertType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Alert.AlertType[] Alert.AlertType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control that return types with arguments of type Alert.AlertType
      Modifier and Type 方法 描述
      ObjectProperty<Alert.AlertType> Alert.alertTypeProperty​()
      创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。
      Methods in javafx.scene.control with parameters of type Alert.AlertType
      Modifier and Type 方法 描述
      void Alert.setAlertType​(Alert.AlertType alertType)
      设置属性alertType的值。
      Constructors in javafx.scene.control with parameters of type Alert.AlertType
      Constructor 描述
      Alert​(Alert.AlertType alertType)
      使用给定的AlertType创建警报（请参阅Alert.AlertType文档，了解哪一个是最合适的）。
      Alert​(Alert.AlertType alertType, String contentText, ButtonType... buttons)
      使用给定的contentText，ButtonTypes和AlertType创建警报（请参阅Alert.AlertType文档以了解哪一个是最合适的）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Button (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Button

  • Packages that use Button
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Button in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type Button
      Constructor 描述
      ButtonSkin​(Button control)
      创建一个新的ButtonSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ButtonBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ButtonBar

  • Packages that use ButtonBar
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ButtonBar in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ButtonBar
      Constructor 描述
      ButtonBarSkin​(ButtonBar control)
      创建一个新的ButtonBarSkin实例，将必要的子节点安装到控件 children列表中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ButtonBar.ButtonData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ButtonBar.ButtonData

  • Packages that use ButtonBar.ButtonData
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ButtonBar.ButtonData in javafx.scene.control

      Methods in javafx.scene.control that return ButtonBar.ButtonData
      Modifier and Type 方法 描述
      static ButtonBar.ButtonData ButtonBar.getButtonData​(Node button)
      返回给定按钮上先前设置的ButtonData属性。
      ButtonBar.ButtonData ButtonType.getButtonData​()
      返回在构造函数中为此ButtonType指定的ButtonData。
      static ButtonBar.ButtonData ButtonBar.ButtonData.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ButtonBar.ButtonData[] ButtonBar.ButtonData.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control with parameters of type ButtonBar.ButtonData
      Modifier and Type 方法 描述
      static void ButtonBar.setButtonData​(Node button, ButtonBar.ButtonData buttonData)
      在给定的按钮上设置给定的ButtonData。
      Constructors in javafx.scene.control with parameters of type ButtonBar.ButtonData
      Constructor 描述
      ButtonType​(String text, ButtonBar.ButtonData buttonData)
      Creates a ButtonType instance with the given text, and the ButtonData set as specified.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ButtonBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ButtonBase

  • Packages that use ButtonBase
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ButtonBase in javafx.scene.control

      Subclasses of ButtonBase in javafx.scene.control
      Modifier and Type Class 描述
      class  Button
      一个简单的按钮控件。
      class  CheckBox
      三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
      class  Hyperlink
      一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
      class  MenuButton
      MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  SplitMenuButton
      SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。
      class  ToggleButton
      A ToggleButton是一种具有选择能力的专业控制。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ButtonType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ButtonType

  • Packages that use ButtonType
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ButtonType in javafx.scene.control

      Fields in javafx.scene.control declared as ButtonType
      Modifier and Type Field 描述
      static ButtonType ButtonType.APPLY
      预先定义的ButtonType显示“应用”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.APPLY 。
      static ButtonType ButtonType.CANCEL
      预先定义的ButtonType显示“取消”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.CANCEL_CLOSE 。
      static ButtonType ButtonType.CLOSE
      一个预先定义的ButtonType ，显示“关闭”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.CANCEL_CLOSE 。
      static ButtonType ButtonType.FINISH
      一个预先定义的ButtonType ，显示“完成”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.FINISH 。
      static ButtonType ButtonType.NEXT
      一个预先定义的ButtonType ，显示“下一步”，并有ButtonBar.ButtonData的ButtonBar.ButtonData.NEXT_FORWARD 。
      static ButtonType ButtonType.NO
      预先定义的ButtonType显示“否”，并具有ButtonBar.ButtonData的270689348882840 。
      static ButtonType ButtonType.OK
      预先定义的ButtonType显示“确定”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.OK_DONE 。
      static ButtonType ButtonType.PREVIOUS
      预先定义的ButtonType显示“上一个”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.BACK_PREVIOUS 。
      static ButtonType ButtonType.YES
      预先定义的ButtonType显示“是”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.YES 。
      Methods in javafx.scene.control that return types with arguments of type ButtonType
      Modifier and Type 方法 描述
      ObservableList<ButtonType> Alert.getButtonTypes​()
      返回当前在此Alert实例中设置的所有ButtonType个实例中的ObservableList 。
      ObservableList<ButtonType> DialogPane.getButtonTypes​()
      用于对话框按钮栏区域的按钮类型的可观察列表（通过 DialogPane.createButtonBar()方法创建）。
      Callback<ButtonType,R> Dialog.getResultConverter​()
      获取属性resultConverter的值。
      ObjectProperty<Callback<ButtonType,R>> Dialog.resultConverterProperty​()
      将用户点击的ButtonType转换为可通过result属性返回的结果的API 。
      Methods in javafx.scene.control with parameters of type ButtonType
      Modifier and Type 方法 描述
      protected Node DialogPane.createButton​(ButtonType buttonType)
      这个方法可以被子类覆盖，创建一个随后插入DialogPane按钮区域的自定义按钮（通过DialogPane.createButtonBar()方法创建，但是通常是ButtonBar的一个实例）。
      Node DialogPane.lookupButton​(ButtonType buttonType)
      该方法提供了开发人员可以为给定的ButtonType检索实际节点的方式 （假定它是button types列表的一部分）。
      Method parameters in javafx.scene.control with type arguments of type ButtonType
      Modifier and Type 方法 描述
      void Dialog.setResultConverter​(Callback<ButtonType,R> value)
      设置属性resultConverter的值。
      Constructors in javafx.scene.control with parameters of type ButtonType
      Constructor 描述
      Alert​(Alert.AlertType alertType, String contentText, ButtonType... buttons)
      使用给定的contentText，ButtonTypes和AlertType创建警报（请参阅Alert.AlertType文档以了解哪一个是最合适的）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Cell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Cell

  • Packages that use Cell
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Cell in javafx.scene.control

      Subclasses of Cell in javafx.scene.control
      Modifier and Type Class 描述
      class  DateCell
      DateCell由DatePicker用于在日历月中呈现单个网格单元格。
      class  IndexedCell<T>
      一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。
      class  ListCell<T>
      在Cell内使用类型ListView个实例。
      class  TableCell<S,T>
      在TableView中表示单行/列交集。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。

    • Uses of Cell in javafx.scene.control.cell

      Subclasses of Cell in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含一个ListCell实现的类，它在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格中绘制一个CheckBox节点，并支持常见的交互（ 稍后讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，它在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个270689397102087节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，它在单元格中绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含ListCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeCell<T>
      一个包含TreeCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含一个TableCell实现的类，它在单元格中绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含一个TreeTableCell实现的类，它在单元格内绘制一个27068939748672节点。
      class  TextFieldListCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个包含TreeCell实现的类，在该单元格内绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个TextField节点。

    • Uses of Cell in javafx.scene.control.skin

      Classes in javafx.scene.control.skin with type parameters of type Cell
      Modifier and Type Class 描述
      class  CellSkinBase<C extends Cell>
      默认皮肤的实施为Cell控制和子类，如ListCell ， TreeCell ，等等。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.CheckBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.CheckBox

  • Packages that use CheckBox
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of CheckBox in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type CheckBox
      Constructor 描述
      CheckBoxSkin​(CheckBox control)
      创建一个新的CheckBoxSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.CheckBoxTreeItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.CheckBoxTreeItem

  • Packages that use CheckBoxTreeItem
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of CheckBoxTreeItem in javafx.scene.control

      Methods in javafx.scene.control that return CheckBoxTreeItem
      Modifier and Type 方法 描述
      CheckBoxTreeItem<T> CheckBoxTreeItem.TreeModificationEvent.getTreeItem​()
      返回此事件发生的CheckBoxTreeItem。
      Constructors in javafx.scene.control with parameters of type CheckBoxTreeItem
      Constructor 描述
      TreeModificationEvent​(EventType<? extends Event> eventType, CheckBoxTreeItem<T> treeItem, boolean selectionChanged)
      创建一个默认的TreeModificationEvent实例来表示给定的CheckBoxTreeItem实例的选择/不确定状态的变化。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.CheckBoxTreeItem.TreeModificationEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.CheckBoxTreeItem.TreeModificationEvent

  • Packages that use CheckBoxTreeItem.TreeModificationEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of CheckBoxTreeItem.TreeModificationEvent in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type CheckBoxTreeItem.TreeModificationEvent
      Modifier and Type 方法 描述
      static <T> EventType<CheckBoxTreeItem.TreeModificationEvent<T>> CheckBoxTreeItem.checkBoxSelectionChangedEvent​()
      当CheckBoxTreeItem选择/不确定状态改变时使用的EventType。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.CheckMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.CheckMenuItem

No usage of javafx.scene.control.CheckMenuItem
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ChoiceBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ChoiceBox

  • Packages that use ChoiceBox
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ChoiceBox in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ChoiceBox
      Constructor 描述
      ChoiceBoxSkin​(ChoiceBox<T> control)
      创建一个新的ChoiceBoxSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ChoiceDialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ChoiceDialog

No usage of javafx.scene.control.ChoiceDialog
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ColorPicker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ColorPicker

  • Packages that use ColorPicker
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ColorPicker in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ColorPicker
      Constructor 描述
      ColorPickerSkin​(ColorPicker control)
      创建一个新的ColorPickerSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ComboBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ComboBox

  • Packages that use ComboBox
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ComboBox in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ComboBox
      Constructor 描述
      ComboBoxListViewSkin​(ComboBox<T> control)
      创建一个新的ComboBoxListViewSkin实例，将必需的子节点安装到控件 children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ComboBoxBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ComboBoxBase

  • Packages that use ComboBoxBase
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ComboBoxBase in javafx.scene.control

      Subclasses of ComboBoxBase in javafx.scene.control
      Modifier and Type Class 描述
      class  ColorPicker
      ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
      class  ComboBox<T>
      针对最常见形式的ComboBox的ComboBoxBase抽象类的实现，其中向用户提供弹出列表以提供他们可以选择的选项。
      class  DatePicker
      DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。

    • Uses of ComboBoxBase in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ComboBoxBase
      Constructor 描述
      ComboBoxBaseSkin​(ComboBoxBase<T> control)
      创建一个新的ComboBoxBaseSkin实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。
      ComboBoxPopupControl​(ComboBoxBase<T> control)
      Creates a new instance of ComboBoxPopupControl, although note that this instance does not handle any behavior / input mappings - this needs to be handled appropriately by subclasses.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ContentDisplay (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ContentDisplay

  • Packages that use ContentDisplay
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ContentDisplay in javafx.scene.control

      Methods in javafx.scene.control that return ContentDisplay
      Modifier and Type 方法 描述
      ContentDisplay Labeled.getContentDisplay​()
      获取属性contentDisplay的值。
      ContentDisplay Tooltip.getContentDisplay​()
      获取属性contentDisplay的值。
      static ContentDisplay ContentDisplay.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ContentDisplay[] ContentDisplay.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control that return types with arguments of type ContentDisplay
      Modifier and Type 方法 描述
      ObjectProperty<ContentDisplay> Labeled.contentDisplayProperty​()
      指定图形相对于文本的位置。
      ObjectProperty<ContentDisplay> Tooltip.contentDisplayProperty​()
      指定图形相对于文本的位置。
      Methods in javafx.scene.control with parameters of type ContentDisplay
      Modifier and Type 方法 描述
      void Labeled.setContentDisplay​(ContentDisplay value)
      设置属性contentDisplay的值。
      void Tooltip.setContentDisplay​(ContentDisplay value)
      设置属性contentDisplay的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ContextMenu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ContextMenu

  • Packages that use ContextMenu
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ContextMenu in javafx.scene.control

      Methods in javafx.scene.control that return ContextMenu
      Modifier and Type 方法 描述
      ContextMenu Control.getContextMenu​()
      获取属性contextMenu的值。
      ContextMenu Tab.getContextMenu​()
      与选项卡关联的上下文菜单。
      ContextMenu TableColumnBase.getContextMenu​()
      获取属性contextMenu的值。
      ContextMenu MenuItem.getParentPopup​()
      获取属性parentPopup的值。
      Methods in javafx.scene.control that return types with arguments of type ContextMenu
      Modifier and Type 方法 描述
      ObjectProperty<ContextMenu> Control.contextMenuProperty​()
      为此控件显示的ContextMenu。
      ObjectProperty<ContextMenu> Tab.contextMenuProperty​()
      与选项卡关联的上下文菜单。
      ObjectProperty<ContextMenu> TableColumnBase.contextMenuProperty​()
      当用户右键单击此TableColumnBase的标题区域时，将显示此菜单。
      ReadOnlyObjectProperty<ContextMenu> MenuItem.parentPopupProperty​()
      这是ContextMenu ，其中MenuItem存在。
      Methods in javafx.scene.control with parameters of type ContextMenu
      Modifier and Type 方法 描述
      void Control.setContextMenu​(ContextMenu value)
      设置属性contextMenu的值。
      void Tab.setContextMenu​(ContextMenu value)
      指定上下文菜单，以显示用户在选项卡上的右键单击。
      void TableColumnBase.setContextMenu​(ContextMenu value)
      设置属性contextMenu的值。
      protected void MenuItem.setParentPopup​(ContextMenu value)
      设置属性parentPopup的值。

    • Uses of ContextMenu in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return ContextMenu
      Modifier and Type 方法 描述
      ContextMenu ContextMenuSkin.getSkinnable​()
      获取此皮肤分配到的Skinnable。
      Constructors in javafx.scene.control.skin with parameters of type ContextMenu
      Constructor 描述
      ContextMenuSkin​(ContextMenu control)
      创建一个新的ContextMenuSkin实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Control (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Control

  • Packages that use Control
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of Control in javafx.scene.control

      Classes in javafx.scene.control with type parameters of type Control
      Modifier and Type Class 描述
      class  SkinBase<C extends Control>
      基本实现类，用于通过定义节点的场景图来定义用户界面控件的可视化表示，以表示skin 。
      Subclasses of Control in javafx.scene.control
      Modifier and Type Class 描述
      class  Accordion
      手风琴是一组TitlePanes 。
      class  Button
      一个简单的按钮控件。
      class  ButtonBar
      ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。
      class  ButtonBase
      按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
      class  Cell<T>
      细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
      class  CheckBox
      三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
      class  ChoiceBox<T>
      ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
      class  ColorPicker
      ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
      class  ComboBox<T>
      对于最常见的ComboBox形式的ComboBoxBase抽象类的实现，向用户提供一个弹出列表，为他们提供可以选择的选项。
      class  ComboBoxBase<T>
      ComboBox类控件的抽象基类。
      class  DateCell
      DateCell由DatePicker用于在日历月中呈现单个网格单元格。
      class  DatePicker
      DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
      class  Hyperlink
      一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
      class  IndexedCell<T>
      一个Cell的实现，其中包含一个索引属性，它映射到可视化的底层的数据模型中。
      class  Label
      标签是不可编辑的文本控件。
      class  Labeled
      标签Control是与其用户界面的一部分相关联的文本内容。
      class  ListCell<T>
      在Cell内使用类型ListView个实例。
      class  ListView<T>
      ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
      class  MenuBar
      MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。
      class  MenuButton
      MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
      class  Pagination
      分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
      class  PasswordField
      掩码输入字符的文本字段。
      class  ProgressBar
      ProgressIndator的专业化表示为横杠。
      class  ProgressIndicator
      用于指示进度的循环控制，无限（也称为不确定）或有限。
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  ScrollBar
      具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。
      class  ScrollPane
      提供其内容的滚动，剪切视口的控件。
      class  Separator
      水平或垂直分隔线。
      class  Slider
      滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。
      class  Spinner<T>
      单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。
      class  SplitMenuButton
      SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。
      class  SplitPane
      具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
      class  TableCell<S,T>
      在TableView中表示单行/列交集。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TableView<S>
      TableView控件旨在可视化无限数量的数据行，分为列。
      class  TabPane
      允许在一组Tabs之间切换的控件 。
      class  TextArea
      文本输入组件，允许用户输入多行纯文本。
      class  TextField
      文本输入组件，允许用户输入一行未格式化的文本。
      class  TextInputControl
      文本输入控件的抽象基类。
      class  TitledPane
      TitledPane是一个可以打开和关闭的标题的面板。
      class  ToggleButton
      A ToggleButton是具有选择能力的专业控制。
      class  ToolBar
      ToolBar是一个可以水平或垂直显示项目的控件。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
      class  TreeTableView<S>
      TreeTableView控件旨在可视化无限数量的数据行，分为列。
      class  TreeView<T>
      TreeView控件提供了一个树根视图（类型为TreeItem ）。
      Methods in javafx.scene.control that return Control
      Modifier and Type 方法 描述
      Control TextFormatter.Change.getControl​()
      获取与此更改相关联的控件。

    • Uses of Control in javafx.scene.control.cell

      Subclasses of Control in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含一个ListCell实现的类，它在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含一个TableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个类包含一个TreeCell实现，在单元格内绘制一个CheckBox节点，以及支持常见的交互（ 稍后讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，其中可以在单元格内绘制一个CheckBox节点，可选地带有一个标签以指示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个2706898035343478节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格中绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，它在单元格内绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格中绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含TableCell实现的类，在单元格内绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含一个TreeTableCell实现的类，它在单元格中绘制一个ProgressBar节点。
      class  TextFieldListCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个类包含一个TableCell实现，在单元格内绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个包含TreeCell实现的类，在单元格内绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个TextField节点。

    • Uses of Control in javafx.scene.control.skin

      Classes in javafx.scene.control.skin with type parameters of type Control
      Modifier and Type Class 描述
      class  TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>
      TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。
      class  VirtualContainerBase<C extends Control,I extends IndexedCell>
      父类控制其内容虚拟化和可滚动的外观。

    • Uses of Control in javafx.scene.web

      Subclasses of Control in javafx.scene.web
      Modifier and Type Class 描述
      class  HTMLEditor
      允许用户编辑文本并将样式应用于此文本的控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.CustomMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.CustomMenuItem

  • Packages that use CustomMenuItem
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of CustomMenuItem in javafx.scene.control

      Subclasses of CustomMenuItem in javafx.scene.control
      Modifier and Type Class 描述
      class  SeparatorMenuItem
      A MenuItem ，其名称建议允许在其中嵌入水平分隔符，通过将Separator分配给CustomMenuItem的content属性来提供CustomMenuItem这是为方便起见而提供的，可以通过分隔符分隔menuitems的组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.DateCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.DateCell

  • Packages that use DateCell
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of DateCell in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type DateCell
      Modifier and Type 方法 描述
      ObjectProperty<Callback<DatePicker,DateCell>> DatePicker.dayCellFactoryProperty​()
      可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。
      Callback<DatePicker,DateCell> DatePicker.getDayCellFactory​()
      获取属性dayCellFactory的值。
      Method parameters in javafx.scene.control with type arguments of type DateCell
      Modifier and Type 方法 描述
      void DatePicker.setDayCellFactory​(Callback<DatePicker,DateCell> value)
      设置属性dayCellFactory的值。

    • Uses of DateCell in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type DateCell
      Constructor 描述
      DateCellSkin​(DateCell control)
      创建一个新的DateCellSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.DatePicker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.DatePicker

  • Packages that use DatePicker
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of DatePicker in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type DatePicker
      Modifier and Type 方法 描述
      ObjectProperty<Callback<DatePicker,DateCell>> DatePicker.dayCellFactoryProperty​()
      可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。
      Callback<DatePicker,DateCell> DatePicker.getDayCellFactory​()
      获取属性dayCellFactory的值。
      Method parameters in javafx.scene.control with type arguments of type DatePicker
      Modifier and Type 方法 描述
      void DatePicker.setDayCellFactory​(Callback<DatePicker,DateCell> value)
      设置属性dayCellFactory的值。

    • Uses of DatePicker in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type DatePicker
      Constructor 描述
      DatePickerSkin​(DatePicker control)
      创建一个新的DatePickerSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Dialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Dialog

  • Packages that use Dialog
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of Dialog in javafx.scene.control

      Subclasses of Dialog in javafx.scene.control
      Modifier and Type Class 描述
      class  Alert
      Alert类对Dialog类进行子类化，并提供对许多预构建的对话框类型的支持，可以轻松向用户显示提示响应。
      class  ChoiceDialog<T>
      一个对话框，向用户显示选择列表，最多可以从中选择一个项目。
      class  TextInputDialog
      显示给用户的文本输入控件的对话框。
      Constructors in javafx.scene.control with parameters of type Dialog
      Constructor 描述
      DialogEvent​(Dialog<?> source, EventType<? extends Event> eventType)
      使用指定的事件源，目标和类型构造一个新的 Event 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.DialogEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.DialogEvent

  • Packages that use DialogEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of DialogEvent in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type DialogEvent
      Modifier and Type Field 描述
      static EventType<DialogEvent> DialogEvent.ANY
      所有对话事件类型的常用超类型。
      static EventType<DialogEvent> DialogEvent.DIALOG_CLOSE_REQUEST
      当有外部请求关闭该对话框时，此事件将传递到对话框。
      static EventType<DialogEvent> DialogEvent.DIALOG_HIDDEN
      此事件发生在隐藏后的对话框上。
      static EventType<DialogEvent> DialogEvent.DIALOG_HIDING
      此事件发生在隐藏之前的对话框上。
      static EventType<DialogEvent> DialogEvent.DIALOG_SHOWING
      此事件发生在显示之前的对话框上。
      static EventType<DialogEvent> DialogEvent.DIALOG_SHOWN
      此事件发生在显示之后的对话框上。
      Methods in javafx.scene.control that return DialogEvent
      Modifier and Type | 方法 | 描述
      DialogEvent | DialogEvent.copyFor​(Object newSource, EventTarget newTarget)
      DialogEvent DialogEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<DialogEvent> type)
      用给定的字段替换给定事件的副本。
      Methods in javafx.scene.control that return types with arguments of type DialogEvent
      Modifier and Type | 方法 | 描述
      EventType<DialogEvent> | DialogEvent.getEventType​()
      EventHandler<DialogEvent> Dialog.getOnCloseRequest​()
      获取属性onCloseRequest的值。
      EventHandler<DialogEvent> Dialog.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<DialogEvent> Dialog.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<DialogEvent> Dialog.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<DialogEvent> Dialog.getOnShown​()
      获取onShown属性的值。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onCloseRequestProperty​()
      当有外部请求关闭此 Dialog 。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onHiddenProperty​()
      Dialog已被隐藏之后调用。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onHidingProperty​()
      在对话框被隐藏之前调用。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onShowingProperty​()
      在对话框显示之前调用。
      ObjectProperty<EventHandler<DialogEvent>> Dialog.onShownProperty​()
      在对话框显示之后调用。
      Method parameters in javafx.scene.control with type arguments of type DialogEvent
      Modifier and Type 方法 描述
      DialogEvent DialogEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<DialogEvent> type)
      用给定的字段替换给定事件的副本。
      void Dialog.setOnCloseRequest​(EventHandler<DialogEvent> value)
      设置属性onCloseRequest的值。
      void Dialog.setOnHidden​(EventHandler<DialogEvent> value)
      设置属性onHidden的值。
      void Dialog.setOnHiding​(EventHandler<DialogEvent> value)
      设置属性onHiding的值。
      void Dialog.setOnShowing​(EventHandler<DialogEvent> value)
      设置属性onShowing的值。
      void Dialog.setOnShown​(EventHandler<DialogEvent> value)
      设置属性onShown的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.DialogPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.DialogPane

  • Packages that use DialogPane
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of DialogPane in javafx.scene.control

      Methods in javafx.scene.control that return DialogPane
      Modifier and Type 方法 描述
      DialogPane Dialog.getDialogPane​()
      获取属性dialogPane的值。
      Methods in javafx.scene.control that return types with arguments of type DialogPane
      Modifier and Type 方法 描述
      ObjectProperty<DialogPane> Dialog.dialogPaneProperty​()
      对话框的根节点 ， DialogPane包含对话框中显示的所有可视元素。
      Methods in javafx.scene.control with parameters of type DialogPane
      Modifier and Type 方法 描述
      void Dialog.setDialogPane​(DialogPane value)
      设置属性dialogPane的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.FocusModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.FocusModel

  • Packages that use FocusModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of FocusModel in javafx.scene.control

      Subclasses of FocusModel in javafx.scene.control
      Modifier and Type Class 描述
      class  TableFocusModel<T,TC extends TableColumnBase<T,?>>
      FocusModel实现的抽象基类，用于表类控件（最着名的是TableView和TreeTableView） 。
      static class  TableView.TableViewFocusModel<S>
      A FocusModel具有支持TableView控件要求的附加功能。
      static class  TreeTableView.TreeTableViewFocusModel<S>
      A FocusModel具有支持TableView控件要求的附加功能。
      Methods in javafx.scene.control that return FocusModel
      Modifier and Type 方法 描述
      FocusModel<T> ListView.getFocusModel​()
      返回当前安装的FocusModel 。
      FocusModel<TreeItem<T>> TreeView.getFocusModel​()
      返回当前安装的FocusModel 。
      Methods in javafx.scene.control that return types with arguments of type FocusModel
      Modifier and Type 方法 描述
      ObjectProperty<FocusModel<T>> ListView.focusModelProperty​()
      FocusModel提供了API，通过它可以获得并设置ListView中单个项目的焦点。
      ObjectProperty<FocusModel<TreeItem<T>>> TreeView.focusModelProperty​()
      FocusModel提供API，通过它可以将焦点控制在零行或一行TreeView。
      Methods in javafx.scene.control with parameters of type FocusModel
      Modifier and Type 方法 描述
      void ListView.setFocusModel​(FocusModel<T> value)
      设置要在ListView中使用的FocusModel 。
      void TreeView.setFocusModel​(FocusModel<TreeItem<T>> value)
      设置要在TreeView中使用的FocusModel 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Hyperlink (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Hyperlink

  • Packages that use Hyperlink
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Hyperlink in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type Hyperlink
      Constructor 描述
      HyperlinkSkin​(Hyperlink control)
      创建一个新的HyperlinkSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.IndexedCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.IndexedCell

  • Packages that use IndexedCell
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of IndexedCell in javafx.scene.control

      Subclasses of IndexedCell in javafx.scene.control
      Modifier and Type Class 描述
      class  ListCell<T>
      Cell类型中使用的ListView实例。
      class  TableCell<S,T>
      在TableView中表示单行/列交集。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。

    • Uses of IndexedCell in javafx.scene.control.cell

      Subclasses of IndexedCell in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含一个ListCell实现的类，它在单元格中绘制一个CheckBox节点，可选地带有一个标签，表示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含TableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格中绘制一个CheckBox节点，并支持常见的交互（ 稍后讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeCell<T>
      一个包含TreeCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含一个TableCell实现的类，它在单元格中绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含TreeTableCell实现的类，在该单元格内绘制一个ProgressBar节点。
      class  TextFieldListCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个包含TreeCell实现的类，在该单元格内绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个TextField节点。

    • Uses of IndexedCell in javafx.scene.control.skin

      Classes in javafx.scene.control.skin with type parameters of type IndexedCell
      Modifier and Type Class 描述
      class  TableCellSkinBase<S,T,C extends IndexedCell<T>>
      表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。
      class  TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>
      TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。
      class  TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>
      TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。
      class  TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>
      TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。
      class  VirtualContainerBase<C extends Control,I extends IndexedCell>
      父类控制其内容虚拟化和可滚动的外观。
      class  VirtualFlow<T extends IndexedCell>
      使用基于单元的机制实现虚拟化容器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.IndexRange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.IndexRange

  • Packages that use IndexRange
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of IndexRange in javafx.scene.control

      Methods in javafx.scene.control that return IndexRange
      Modifier and Type 方法 描述
      IndexRange TextFormatter.Change.getSelection​()
      获取此更改的选择。
      IndexRange TextInputControl.getSelection​()
      获取属性选择的值。
      static IndexRange IndexRange.normalize​(int v1, int v2)
      创建一个具有较小值作为起始索引的IndexRange实例的便利方法，较大的值作为结束索引。
      static IndexRange IndexRange.valueOf​(String value)
      在“2,6”形式的字符串中解析的方便方法，它将创建一个起始值为2的IndexRange实例，最终值为6。
      Methods in javafx.scene.control that return types with arguments of type IndexRange
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<IndexRange> TextInputControl.selectionProperty​()
      当前选择。
      Methods in javafx.scene.control with parameters of type IndexRange
      Modifier and Type 方法 描述
      void TextInputControl.deleteText​(IndexRange range)
      从内容中删除一系列字符。
      void TextInputControl.replaceText​(IndexRange range, String text)
      用给定的文本替换一系列的字符。
      Constructors in javafx.scene.control with parameters of type IndexRange
      Constructor 描述
      IndexRange​(IndexRange range)
      通过复制给定的IndexRange对象的值来创建IndexRange的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Label (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Label

  • Packages that use Label
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Label in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type Label
      Constructor 描述
      LabelSkin​(Label control)
      创建一个新的LabelSkin实例，将必需的子节点安装到控件 children列表中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Labeled (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Labeled

  • Packages that use Labeled
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Labeled in javafx.scene.control

      Subclasses of Labeled in javafx.scene.control
      Modifier and Type Class 描述
      class  Button
      一个简单的按钮控件。
      class  ButtonBase
      按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
      class  Cell<T>
      细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
      class  CheckBox
      三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
      class  DateCell
      DateCell由DatePicker用于在日历月中呈现单个网格单元格。
      class  Hyperlink
      一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
      class  IndexedCell<T>
      一个Cell的实现，其中包含一个索引属性，该属性映射到可视化的底层的数据模型中。
      class  Label
      标签是不可编辑的文本控件。
      class  ListCell<T>
      在ListView实例中使用的Cell类型。
      class  MenuButton
      MenuButton是一个按钮，当被点击或按下时，它将显示一个ContextMenu 。
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  SplitMenuButton
      SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。
      class  TableCell<S,T>
      在TableView中表示单行/列交集。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TitledPane
      TitledPane是一个可以打开和关闭的标题的面板。
      class  ToggleButton
      A ToggleButton是一种具有选择能力的专业控制。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。

    • Uses of Labeled in javafx.scene.control.cell

      Subclasses of Labeled in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含一个ListCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格内绘制一个CheckBox节点，可选地带有一个标签，表示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个包含TreeCell实现的类，它在单元格中绘制一个CheckBox节点，同时支持常见的交互（ 稍后讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，可以在单元格内绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含一个ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeCell<T>
      一个包含TreeCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含TableCell实现的类，在单元格内绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含TreeTableCell实现的类，在单元格内绘制一个ProgressBar节点。
      class  TextFieldListCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格内绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个包含TreeCell实现的类，在该单元格内绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个TextField节点。

    • Uses of Labeled in javafx.scene.control.skin

      Classes in javafx.scene.control.skin with type parameters of type Labeled
      Modifier and Type Class 描述
      class  LabeledSkinBase<C extends Labeled>
      控件的默认皮肤实现扩展为Labeled 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ListCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ListCell

  • Packages that use ListCell
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ListCell in javafx.scene.control

      Methods in javafx.scene.control that return ListCell
      Modifier and Type 方法 描述
      ListCell<T> ComboBox.getButtonCell​()
      获取属性buttonCell的值。
      Methods in javafx.scene.control that return types with arguments of type ListCell
      Modifier and Type 方法 描述
      ObjectProperty<ListCell<T>> ComboBox.buttonCellProperty​()
      按钮单元格用于渲染ComboBox“按钮”区域中显示的内容。
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> ComboBox.cellFactoryProperty​()
      提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> ListView.cellFactoryProperty​()
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      Callback<ListView<T>,ListCell<T>> ComboBox.getCellFactory​()
      获取属性cellFactory的值。
      Callback<ListView<T>,ListCell<T>> ListView.getCellFactory​()
      返回当前的单元格工厂。
      Methods in javafx.scene.control with parameters of type ListCell
      Modifier and Type 方法 描述
      void ComboBox.setButtonCell​(ListCell<T> value)
      设置属性buttonCell的值。
      Method parameters in javafx.scene.control with type arguments of type ListCell
      Modifier and Type 方法 描述
      void ComboBox.setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
      设置属性cellFactory的值。
      void ListView.setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
      设置要在ListView中使用的新单元格工厂。

    • Uses of ListCell in javafx.scene.control.cell

      Subclasses of ListCell in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  TextFieldListCell<T>
      一个包含ListCell实现的类，它在单元格中绘制一个TextField节点。
      Methods in javafx.scene.control.cell that return types with arguments of type ListCell
      Modifier and Type 方法 描述
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(T... items)
      创建一个ComboBox单元格工厂用于ListView控件。
      static Callback<ListView<String>,ListCell<String>> TextFieldListCell.forListView​()
      提供TextField ，允许在双击单元格时调用单元格内容，或调用ListView.edit(int)时。
      static <T> Callback<ListView<T>,ListCell<T>> TextFieldListCell.forListView​(StringConverter<T> converter)
      提供TextField ，允许双击单元格时或当调用ListView.edit(int)时对单元格内容进行编辑。

    • Uses of ListCell in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ListCell
      Constructor 描述
      ListCellSkin​(ListCell<T> control)
      创建一个新的ListCellSkin实例，将必需的子节点安装到控件 children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ListView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ListView

  • Packages that use ListView
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ListView in javafx.scene.control

      Methods in javafx.scene.control that return ListView
      Modifier and Type 方法 描述
      ListView<T> ListCell.getListView​()
      获取属性listView的值。
      ListView<T> ListView.EditEvent.getSource​()
      返回发生编辑的ListView。
      Methods in javafx.scene.control that return types with arguments of type ListView
      Modifier and Type 方法 描述
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> ComboBox.cellFactoryProperty​()
      提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> ListView.cellFactoryProperty​()
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      Callback<ListView<T>,ListCell<T>> ComboBox.getCellFactory​()
      获取属性cellFactory的值。
      Callback<ListView<T>,ListCell<T>> ListView.getCellFactory​()
      返回当前的单元格工厂。
      ReadOnlyObjectProperty<ListView<T>> ListCell.listViewProperty​()
      与此单元格关联的ListView。
      Methods in javafx.scene.control with parameters of type ListView
      Modifier and Type 方法 描述
      void ListCell.updateListView​(ListView<T> listView)
      更新与此单元格关联的ListView。
      Method parameters in javafx.scene.control with type arguments of type ListView
      Modifier and Type 方法 描述
      void ComboBox.setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
      设置属性cellFactory的值。
      void ListView.setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
      设置要在ListView中使用的新单元格工厂。
      Constructors in javafx.scene.control with parameters of type ListView
      Constructor 描述
      EditEvent​(ListView<T> source, EventType<? extends ListView.EditEvent<T>> eventType, T newValue, int editIndex)
      创建一个新的EditEvent实例来表示编辑事件。

    • Uses of ListView in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return types with arguments of type ListView
      Modifier and Type 方法 描述
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(T... items)
      创建ComboBox单元格工厂，用于ListView控件。
      static Callback<ListView<String>,ListCell<String>> TextFieldListCell.forListView​()
      提供一个TextField ，允许在单元格双击时或当调用edit(int)时编辑单元格内容。
      static <T> Callback<ListView<T>,ListCell<T>> TextFieldListCell.forListView​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时调用单元格内容，或调用edit(int)时。

    • Uses of ListView in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ListView
      Constructor 描述
      ListViewSkin​(ListView<T> control)
      创建一个新的ListViewSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ListView.EditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ListView.EditEvent

  • Packages that use ListView.EditEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ListView.EditEvent in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type ListView.EditEvent
      Modifier and Type 方法 描述
      static <T> EventType<ListView.EditEvent<T>> ListView.editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <T> EventType<ListView.EditEvent<T>> ListView.editCancelEvent​()
      一个EventType，用于指示在事件触发的ListView中刚刚取消了编辑事件。
      static <T> EventType<ListView.EditEvent<T>> ListView.editCommitEvent​()
      EventType用于指示已在触发事件的ListView中提交了编辑事件。
      static <T> EventType<ListView.EditEvent<T>> ListView.editStartEvent​()
      EventType用于指示在事件被触发的ListView中启动编辑事件。
      EventHandler<ListView.EditEvent<T>> ListView.getOnEditCancel​()
      返回当用户取消编辑时将调用的EventHandler 。
      EventHandler<ListView.EditEvent<T>> ListView.getOnEditCommit​()
      返回当用户提交编辑时将被调用的EventHandler 。
      EventHandler<ListView.EditEvent<T>> ListView.getOnEditStart​()
      返回当用户开始编辑时将被调用的EventHandler 。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> ListView.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> ListView.onEditCommitProperty​()
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<ListView.EditEvent<T>>> ListView.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      Method parameters in javafx.scene.control with type arguments of type ListView.EditEvent
      Modifier and Type 方法 描述
      void ListView.setOnEditCancel​(EventHandler<ListView.EditEvent<T>> value)
      设置当用户取消编辑时将被调用的EventHandler 。
      void ListView.setOnEditCommit​(EventHandler<ListView.EditEvent<T>> value)
      设置当用户完成编辑时将被调用的EventHandler 。
      void ListView.setOnEditStart​(EventHandler<ListView.EditEvent<T>> value)
      设置当用户开始编辑时将被调用的EventHandler 。
      Constructor parameters in javafx.scene.control with type arguments of type ListView.EditEvent
      Constructor 描述
      EditEvent​(ListView<T> source, EventType<? extends ListView.EditEvent<T>> eventType, T newValue, int editIndex)
      创建一个新的EditEvent实例来表示编辑事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Menu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Menu

  • Packages that use Menu
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of Menu in javafx.scene.control

      Methods in javafx.scene.control that return Menu
      Modifier and Type 方法 描述
      Menu MenuItem.getParentMenu​()
      获取属性parentMenu的值。
      Methods in javafx.scene.control that return types with arguments of type Menu
      Modifier and Type 方法 描述
      ObservableList<Menu> MenuBar.getMenus​()
      在MenuBar中显示的菜单。
      ReadOnlyObjectProperty<Menu> MenuItem.parentMenuProperty​()
      这是Menu ，其中MenuItem存在。
      Methods in javafx.scene.control with parameters of type Menu
      Modifier and Type 方法 描述
      protected void MenuItem.setParentMenu​(Menu value)
      设置属性parentMenu的值。
      Constructors in javafx.scene.control with parameters of type Menu
      Constructor 描述
      MenuBar​(Menu... menus)
      使用给定的菜单创建一个新的MenuBar。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.MenuBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.MenuBar

  • Packages that use MenuBar
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of MenuBar in javafx.scene.control.skin

      Methods in javafx.scene.control.skin with parameters of type MenuBar
      Modifier and Type 方法 描述
      static void MenuBarSkin.setDefaultSystemMenuBar​(MenuBar menuBar)
      设置默认的系统菜单栏。
      Constructors in javafx.scene.control.skin with parameters of type MenuBar
      Constructor 描述
      MenuBarSkin​(MenuBar control)
      创建一个新的MenuBarSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.MenuButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.MenuButton

  • Packages that use MenuButton
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of MenuButton in javafx.scene.control

      Subclasses of MenuButton in javafx.scene.control
      Modifier and Type Class 描述
      class  SplitMenuButton
      SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。

    • Uses of MenuButton in javafx.scene.control.skin

      Classes in javafx.scene.control.skin with type parameters of type MenuButton
      Modifier and Type Class 描述
      class  MenuButtonSkinBase<C extends MenuButton>
      MenuButtonSkin和SplitMenuButtonSkin的基类。
      Constructors in javafx.scene.control.skin with parameters of type MenuButton
      Constructor 描述
      MenuButtonSkin​(MenuButton control)
      创建一个新的MenuButtonSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.MenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.MenuItem

  • Packages that use MenuItem
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of MenuItem in javafx.scene.control

      Subclasses of MenuItem in javafx.scene.control
      Modifier and Type Class 描述
      class  CheckMenuItem
      A MenuItem可以在选定状态和未选择状态之间切换。
      class  CustomMenuItem
      200 200 200 200 200 200 -40 200 200 -40 200 200 -40 200 200 200 200 200 200 200 200 200 200 200 200 200 200 CE 1992 X-
      class  Menu
      可触发的项目的弹出菜单，仅根据请求向用户显示。
      class  RadioMenuItem
      RadioMenuItem是一个MenuItem可以切换（它使用Toggle mixin）。
      class  SeparatorMenuItem
      甲MenuItem该顾名思义允许的水平隔板将要被嵌入在其内，通过分配一个Separator到content所述的属性CustomMenuItem这提供了方便作为基menuitems可以通过分离器进行分离。
      Methods in javafx.scene.control that return types with arguments of type MenuItem
      Modifier and Type 方法 描述
      ObservableList<MenuItem> ContextMenu.getItems​()
      上下文菜单中的菜单项。
      ObservableList<MenuItem> Menu.getItems​()
      在此菜单中显示的项目。
      ObservableList<MenuItem> MenuButton.getItems​()
      在此按钮菜单中显示的项目。
      Constructors in javafx.scene.control with parameters of type MenuItem
      Constructor 描述
      ContextMenu​(MenuItem... items)
      创建一个使用给定项目初始化的新的ContextMenu
      Menu​(String text, Node graphic, MenuItem... items)
      构建菜单，并将指定文本的显示文本（给定节点的图形Node）设置，并将给定项目插入到items列表中。
      MenuButton​(String text, Node graphic, MenuItem... items)
      创建一个新的菜单按钮，给定的文本和图形显示在按钮上，并将给定的项目插入到 items列表中。
      SplitMenuButton​(MenuItem... items)
      Creates a new split menu button with the given list of menu items.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.MultipleSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.MultipleSelectionModel

  • Packages that use MultipleSelectionModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of MultipleSelectionModel in javafx.scene.control

      Subclasses of MultipleSelectionModel in javafx.scene.control
      Modifier and Type Class 描述
      class  TableSelectionModel<T>
      在表类控件中使用的MultipleSelectionModel实现的抽象基类（最着名的是TableView和TreeTableView 。
      static class  TableView.TableViewSelectionModel<S>
      SelectionModel抽象类的简单扩展，允许对TableView控件的特殊支持。
      static class  TreeTableView.TreeTableViewSelectionModel<S>
      SelectionModel抽象类的简单扩展，允许对TreeTableView控件的特殊支持。
      Methods in javafx.scene.control that return MultipleSelectionModel
      Modifier and Type 方法 描述
      MultipleSelectionModel<T> ListView.getSelectionModel​()
      返回当前安装的选择模型。
      MultipleSelectionModel<TreeItem<T>> TreeView.getSelectionModel​()
      返回当前安装的选择模型。
      Methods in javafx.scene.control that return types with arguments of type MultipleSelectionModel
      Modifier and Type 方法 描述
      ObjectProperty<MultipleSelectionModel<T>> ListView.selectionModelProperty​()
      SelectionModel提供了可以在ListView中选择单个或多个项目的API，以及检查用户选择了哪些项目。
      ObjectProperty<MultipleSelectionModel<TreeItem<T>>> TreeView.selectionModelProperty​()
      SelectionModel提供了可以在TreeView中选择单个或多个项目的API，以及检查用户选择了哪些行。
      Methods in javafx.scene.control with parameters of type MultipleSelectionModel
      Modifier and Type 方法 描述
      void ListView.setSelectionModel​(MultipleSelectionModel<T> value)
      设置要在ListView中使用的MultipleSelectionModel 。
      void TreeView.setSelectionModel​(MultipleSelectionModel<TreeItem<T>> value)
      设置要在TreeView中使用的MultipleSelectionModel 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.OverrunStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.OverrunStyle

  • Packages that use OverrunStyle
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of OverrunStyle in javafx.scene.control

      Methods in javafx.scene.control that return OverrunStyle
      Modifier and Type 方法 描述
      OverrunStyle Labeled.getTextOverrun​()
      获取textOverrun属性的值。
      OverrunStyle Tooltip.getTextOverrun​()
      获取textOverrun属性的值。
      static OverrunStyle OverrunStyle.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static OverrunStyle[] OverrunStyle.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control that return types with arguments of type OverrunStyle
      Modifier and Type 方法 描述
      ObjectProperty<OverrunStyle> Labeled.textOverrunProperty​()
      指定 Labeled的文本超过可用空间来呈现文本时使用的行为。
      ObjectProperty<OverrunStyle> Tooltip.textOverrunProperty​()
      指定 Tooltip的文本超过可用空间进行渲染时使用的行为。
      Methods in javafx.scene.control with parameters of type OverrunStyle
      Modifier and Type 方法 描述
      void Labeled.setTextOverrun​(OverrunStyle value)
      设置textOverrun属性的值。
      void Tooltip.setTextOverrun​(OverrunStyle value)
      设置textOverrun属性的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Pagination (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Pagination

  • Packages that use Pagination
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Pagination in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type Pagination
      Constructor 描述
      PaginationSkin​(Pagination control)
      创建一个新的PaginationSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.PasswordField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.PasswordField

No usage of javafx.scene.control.PasswordField
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.PopupControl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.PopupControl

  • Packages that use PopupControl
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of PopupControl in javafx.scene.control

      Subclasses of PopupControl in javafx.scene.control
      Modifier and Type Class 描述
      class  ContextMenu
      一个包含菜单项的ObservableList的弹出控件。
      class  Tooltip
      工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.PopupControl.CSSBridge (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.PopupControl.CSSBridge

  • Packages that use PopupControl.CSSBridge
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of PopupControl.CSSBridge in javafx.scene.control

      Fields in javafx.scene.control declared as PopupControl.CSSBridge
      Modifier and Type Field 描述
      protected PopupControl.CSSBridge PopupControl.bridge
      我们需要一个特殊的根节点，除了我们不能替代PopupControl中的特殊根节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ProgressBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ProgressBar

  • Packages that use ProgressBar
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ProgressBar in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ProgressBar
      Constructor 描述
      ProgressBarSkin​(ProgressBar control)
      创建一个新的ProgressBarSkin实例，将必需的子节点安装到控件 children列表中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ProgressIndicator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ProgressIndicator

  • Packages that use ProgressIndicator
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ProgressIndicator in javafx.scene.control

      Subclasses of ProgressIndicator in javafx.scene.control
      Modifier and Type Class 描述
      class  ProgressBar
      ProgressIndator的专业化表示为横杠。

    • Uses of ProgressIndicator in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ProgressIndicator
      Constructor 描述
      ProgressIndicatorSkin​(ProgressIndicator control)
      创建一个新的ProgressIndicatorSkin实例，将必需的子节点安装到控件 children列表中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.RadioButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.RadioButton

  • Packages that use RadioButton
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of RadioButton in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type RadioButton
      Constructor 描述
      RadioButtonSkin​(RadioButton control)
      创建一个新的RadioButtonSkin实例，将必需的子节点安装到控件 children列表中，以及处理键盘，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.RadioMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.RadioMenuItem

No usage of javafx.scene.control.RadioMenuItem
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ResizeFeaturesBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ResizeFeaturesBase

  • Packages that use ResizeFeaturesBase
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ResizeFeaturesBase in javafx.scene.control

      Subclasses of ResizeFeaturesBase in javafx.scene.control
      Modifier and Type Class 描述
      static class  TableView.ResizeFeatures<S>
      用于TableView column resize功能的不可变包装类。
      static class  TreeTableView.ResizeFeatures<S>
      用于TableView column resize功能的不可变包装类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ScrollBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ScrollBar

  • Packages that use ScrollBar
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ScrollBar in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return ScrollBar
      Modifier and Type 方法 描述
      ScrollBar ScrollPaneSkin.getHorizontalScrollBar​()
      返回此ScrollPaneSkin实例中使用的水平ScrollBar 。
      ScrollBar ScrollPaneSkin.getVerticalScrollBar​()
      返回此ScrollPaneSkin实例中使用的垂直ScrollBar 。
      Constructors in javafx.scene.control.skin with parameters of type ScrollBar
      Constructor 描述
      ScrollBarSkin​(ScrollBar control)
      创建一个新的ScrollBarSkin实例，将必要的子节点安装到控件 children列表中，以及处理键盘，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ScrollPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ScrollPane

  • Packages that use ScrollPane
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ScrollPane in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ScrollPane
      Constructor 描述
      ScrollPaneSkin​(ScrollPane control)
      创建一个新的ScrollPaneSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ScrollPane.ScrollBarPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ScrollPane.ScrollBarPolicy

  • Packages that use ScrollPane.ScrollBarPolicy
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ScrollPane.ScrollBarPolicy in javafx.scene.control

      Methods in javafx.scene.control that return ScrollPane.ScrollBarPolicy
      Modifier and Type 方法 描述
      ScrollPane.ScrollBarPolicy ScrollPane.getHbarPolicy​()
      获取属性hbarPolicy的值。
      ScrollPane.ScrollBarPolicy ScrollPane.getVbarPolicy​()
      获取属性vbarPolicy的值。
      static ScrollPane.ScrollBarPolicy ScrollPane.ScrollBarPolicy.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ScrollPane.ScrollBarPolicy[] ScrollPane.ScrollBarPolicy.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control that return types with arguments of type ScrollPane.ScrollBarPolicy
      Modifier and Type 方法 描述
      ObjectProperty<ScrollPane.ScrollBarPolicy> ScrollPane.hbarPolicyProperty​()
      指定显示水平滚动条的策略。
      ObjectProperty<ScrollPane.ScrollBarPolicy> ScrollPane.vbarPolicyProperty​()
      指定显示垂直滚动条的策略。
      Methods in javafx.scene.control with parameters of type ScrollPane.ScrollBarPolicy
      Modifier and Type 方法 描述
      void ScrollPane.setHbarPolicy​(ScrollPane.ScrollBarPolicy value)
      设置属性hbarPolicy的值。
      void ScrollPane.setVbarPolicy​(ScrollPane.ScrollBarPolicy value)
      设置属性vbarPolicy的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ScrollToEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ScrollToEvent

  • Packages that use ScrollToEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ScrollToEvent in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type ScrollToEvent
      Modifier and Type Field 描述
      static EventType<ScrollToEvent> ScrollToEvent.ANY
      所有滚动到事件类型的常用超类型。
      Methods in javafx.scene.control that return types with arguments of type ScrollToEvent
      Modifier and Type 方法 描述
      EventHandler<ScrollToEvent<Integer>> ListView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<Integer>> TableView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<Integer>> TreeTableView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<Integer>> TreeView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<TableColumn<S,?>>> TableView.getOnScrollToColumn​()
      获取属性onScrollToColumn的值。
      EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> TreeTableView.getOnScrollToColumn​()
      获取属性onScrollToColumn的值。
      ObjectProperty<EventHandler<ScrollToEvent<TableColumn<S,?>>>> TableView.onScrollToColumnProperty​()
      当有请求使用 TableView.scrollToColumn(TableColumn)或 TableView.scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<TreeTableColumn<S,?>>>> TreeTableView.onScrollToColumnProperty​()
      当有请求使用 TreeTableView.scrollToColumn(TreeTableColumn)或 TreeTableView.scrollToColumnIndex(int)将列滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> ListView.onScrollToProperty​()
      当有请求使用 ListView.scrollTo(int)或 ListView.scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TableView.onScrollToProperty​()
      当有请求使用 TableView.scrollTo(int)或 TableView.scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TreeTableView.onScrollToProperty​()
      当有请求使用 TreeTableView.scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TreeView.onScrollToProperty​()
      当有请求使用 TreeView.scrollTo(int)将索引滚动到视图时 调用
      static <T extends TableColumnBase<?,?>>
      EventType<ScrollToEvent<T>>             		ScrollToEvent.scrollToColumn​()
      如果用户请求滚动一个TableColumnBase （即
      static EventType<ScrollToEvent<Integer>> ScrollToEvent.scrollToTopIndex​()
      如果用户请求将给定索引滚动到视图中，则会发生此事件。
      Method parameters in javafx.scene.control with type arguments of type ScrollToEvent
      Modifier and Type 方法 描述
      void ListView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TableView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TreeTableView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TreeView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TableView.setOnScrollToColumn​(EventHandler<ScrollToEvent<TableColumn<S,?>>> value)
      设置属性onScrollToColumn的值。
      void TreeTableView.setOnScrollToColumn​(EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> value)
      设置属性onScrollToColumn的值。
      Constructor parameters in javafx.scene.control with type arguments of type ScrollToEvent
      Constructor 描述
      ScrollToEvent​(Object source, EventTarget target, EventType<ScrollToEvent<T>> type, T scrollTarget)
      使用指定的事件源，目标和类型构造新的 Event 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SelectionMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SelectionMode

  • Packages that use SelectionMode
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of SelectionMode in javafx.scene.control

      Methods in javafx.scene.control that return SelectionMode
      Modifier and Type 方法 描述
      SelectionMode MultipleSelectionModel.getSelectionMode​()
      获取属性selectionMode的值。
      static SelectionMode SelectionMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SelectionMode[] SelectionMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control that return types with arguments of type SelectionMode
      Modifier and Type 方法 描述
      ObjectProperty<SelectionMode> MultipleSelectionModel.selectionModeProperty​()
      指定在此选择模型中使用的选择模式。
      Methods in javafx.scene.control with parameters of type SelectionMode
      Modifier and Type 方法 描述
      void MultipleSelectionModel.setSelectionMode​(SelectionMode value)
      设置属性selectionMode的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SelectionModel

  • Packages that use SelectionModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of SelectionModel in javafx.scene.control

      Subclasses of SelectionModel in javafx.scene.control
      Modifier and Type Class 描述
      class  MultipleSelectionModel<T>
      一个抽象类，扩展SelectionModel以添加API以支持多选。
      class  SingleSelectionModel<T>
      一个SelectionModel，它强制要求在任何给定的时间只选择一个索引。
      class  TableSelectionModel<T>
      在表类控件中使用的MultipleSelectionModel实现的抽象基类（最着名的是TableView和TreeTableView） 。
      static class  TableView.TableViewSelectionModel<S>
      SelectionModel抽象类的简单扩展，允许对TableView控件的特殊支持。
      static class  TreeTableView.TreeTableViewSelectionModel<S>
      SelectionModel抽象类的简单扩展，允许对TreeTableView控件的特殊支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Separator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Separator

  • Packages that use Separator
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Separator in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type Separator
      Constructor 描述
      SeparatorSkin​(Separator control)
      创建一个新的SeparatorSkin实例，将必需的子节点安装到控件 children列表中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SeparatorMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SeparatorMenuItem

No usage of javafx.scene.control.SeparatorMenuItem
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SingleSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SingleSelectionModel

  • Packages that use SingleSelectionModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of SingleSelectionModel in javafx.scene.control

      Methods in javafx.scene.control that return SingleSelectionModel
      Modifier and Type 方法 描述
      SingleSelectionModel<T> ChoiceBox.getSelectionModel​()
      获取属性selectionModel的值。
      SingleSelectionModel<T> ComboBox.getSelectionModel​()
      获取属性selectionModel的值。
      SingleSelectionModel<Tab> TabPane.getSelectionModel​()
      获取用于选项卡选择的模型。
      Methods in javafx.scene.control that return types with arguments of type SingleSelectionModel
      Modifier and Type 方法 描述
      ObjectProperty<SingleSelectionModel<T>> ChoiceBox.selectionModelProperty​()
      ChoiceBox的选择模型。
      ObjectProperty<SingleSelectionModel<T>> ComboBox.selectionModelProperty​()
      ComboBox的选择模型。
      ObjectProperty<SingleSelectionModel<Tab>> TabPane.selectionModelProperty​()
      用于选择标签的选择模型。
      Methods in javafx.scene.control with parameters of type SingleSelectionModel
      Modifier and Type 方法 描述
      void ChoiceBox.setSelectionModel​(SingleSelectionModel<T> value)
      设置属性selectionModel的值。
      void ComboBox.setSelectionModel​(SingleSelectionModel<T> value)
      设置属性selectionModel的值。
      void TabPane.setSelectionModel​(SingleSelectionModel<Tab> value)
      设置用于选项卡选择的模型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SkinBase

  • Packages that use SkinBase
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of SkinBase in javafx.scene.control.skin

      Subclasses of SkinBase in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  AccordionSkin
      Accordion控件的默认皮肤实现。
      class  ButtonBarSkin
      ButtonBar控件的默认皮肤实现。
      class  ButtonSkin
      默认皮肤实现为Button控件。
      class  CellSkinBase<C extends Cell>
      默认皮肤的实施为Cell控制和子类，如ListCell ， TreeCell ，等等。
      class  CheckBoxSkin
      默认皮肤实现为三态CheckBox控件。
      class  ChoiceBoxSkin<T>
      默认皮肤实现为ChoiceBox控件。
      class  ColorPickerSkin
      默认皮肤实现为ColorPicker控件。
      class  ComboBoxBaseSkin<T>
      一个抽象类，旨在用作基于ComboBoxBase的 ComboBox类控件的基础外观 。
      class  ComboBoxListViewSkin<T>
      默认皮肤实现为ComboBox控件。
      class  ComboBoxPopupControl<T>
      一个抽象类，扩展了ComboBoxBaseSkin的功能，以包含与显示ComboBox类控件作为弹出窗口相关的API。
      class  DateCellSkin
      DateCell控件的默认皮肤实现。
      class  DatePickerSkin
      默认皮肤实现为DatePicker控件。
      class  HyperlinkSkin
      默认皮肤实现为Hyperlink控件。
      class  LabeledSkinBase<C extends Labeled>
      控件的默认皮肤实现扩展为Labeled 。
      class  LabelSkin
      默认皮肤实现为Label控件。
      class  ListCellSkin<T>
      ListCell控件的默认皮肤实现。
      class  ListViewSkin<T>
      默认皮肤实现为ListView控件。
      class  MenuBarSkin
      默认皮肤实现为MenuBar控件。
      class  MenuButtonSkin
      默认皮肤实现为MenuButton控件。
      class  MenuButtonSkinBase<C extends MenuButton>
      MenuButtonSkin和SplitMenuButtonSkin的基类。
      class  PaginationSkin
      默认皮肤实现为Pagination控件。
      class  ProgressBarSkin
      默认皮肤实现为ProgressBar控件。
      class  ProgressIndicatorSkin
      默认皮肤实现为ProgressIndicator控件。
      class  RadioButtonSkin
      默认皮肤实现为RadioButton控件。
      class  ScrollBarSkin
      默认皮肤实现为ScrollBar控件。
      class  ScrollPaneSkin
      默认皮肤实现为ScrollPane控件。
      class  SeparatorSkin
      默认皮肤实现为Separator控件。
      class  SliderSkin
      默认皮肤实现为Slider控件。
      class  SpinnerSkin<T>
      默认皮肤实现为Spinner控件。
      class  SplitMenuButtonSkin
      默认皮肤实现为SplitMenuButton控件。
      class  SplitPaneSkin
      默认皮肤实现为SplitPane控件。
      class  TableCellSkin<S,T>
      默认皮肤实现为TableCell控件。
      class  TableCellSkinBase<S,T,C extends IndexedCell<T>>
      表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。
      class  TableRowSkin<T>
      默认皮肤实现为TableRow控件。
      class  TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>
      TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。
      class  TableViewSkin<T>
      默认皮肤实现为TableView控件。
      class  TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>
      TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。
      class  TabPaneSkin
      默认皮肤实现为TabPane控件。
      class  TextAreaSkin
      默认皮肤实现为TextArea控件。
      class  TextFieldSkin
      默认皮肤实现为TextField控件。
      class  TextInputControlSkin<T extends TextInputControl>
      文本输入皮肤的抽象基类。
      class  TitledPaneSkin
      默认皮肤实现为TitledPane控件。
      class  ToggleButtonSkin
      默认皮肤实现为ToggleButton控件。
      class  ToolBarSkin
      ToolBar控件的默认皮肤实现。
      class  TreeCellSkin<T>
      默认皮肤实现为TreeCell控件。
      class  TreeTableCellSkin<S,T>
      默认皮肤实现为TreeTableCell控件。
      class  TreeTableRowSkin<T>
      默认皮肤实现为TreeTableRow控件。
      class  TreeTableViewSkin<T>
      默认皮肤实现为TreeTableView控件。
      class  TreeViewSkin<T>
      默认皮肤实现为TreeView控件。
      class  VirtualContainerBase<C extends Control,I extends IndexedCell>
      父类控制其内容虚拟化和可滚动的外观。

    • Uses of SkinBase in javafx.scene.web

      Subclasses of SkinBase in javafx.scene.web
      Modifier and Type Class 描述
      class  HTMLEditorSkin
      HTML编辑器皮肤。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Slider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Slider

  • Packages that use Slider
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Slider in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type Slider
      Constructor 描述
      SliderSkin​(Slider control)
      创建一个新的SliderSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SortEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SortEvent

  • Packages that use SortEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of SortEvent in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type SortEvent
      Modifier and Type Field 描述
      static EventType<SortEvent> SortEvent.ANY
      所有排序事件类型的常用超类型。
      Methods in javafx.scene.control that return types with arguments of type SortEvent
      Modifier and Type | 方法 | 描述
      EventHandler<SortEvent<TableView<S>>> TableView.getOnSort​()
      获取属性onSort的值。
      EventHandler<SortEvent<TreeTableView<S>>> TreeTableView.getOnSort​()
      获取属性onSort的值。
      ObjectProperty<EventHandler<SortEvent<TableView<S>>>> TableView.onSortProperty​()
      当有请求排序控件时调用。
      ObjectProperty<EventHandler<SortEvent<TreeTableView<S>>>> TreeTableView.onSortProperty​()
      当有请求排序控件时调用。
      static <C> EventType<SortEvent<C>> | SortEvent.sortEvent​()
      Method parameters in javafx.scene.control with type arguments of type SortEvent
      Modifier and Type 方法 描述
      void TableView.setOnSort​(EventHandler<SortEvent<TableView<S>>> value)
      设置属性onSort的值。
      void TreeTableView.setOnSort​(EventHandler<SortEvent<TreeTableView<S>>> value)
      设置属性onSort的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Spinner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Spinner

  • Packages that use Spinner
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Spinner in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type Spinner
      Constructor 描述
      SpinnerSkin​(Spinner<T> control)
      创建一个新的SpinnerSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SpinnerValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SpinnerValueFactory

  • Packages that use SpinnerValueFactory
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of SpinnerValueFactory in javafx.scene.control

      Subclasses of SpinnerValueFactory in javafx.scene.control
      Modifier and Type Class 描述
      static class  SpinnerValueFactory.DoubleSpinnerValueFactory
      一个SpinnerValueFactory实现，旨在迭代双重值。
      static class  SpinnerValueFactory.IntegerSpinnerValueFactory
      一个设计用于遍历整数值的SpinnerValueFactory实现。
      static class  SpinnerValueFactory.ListSpinnerValueFactory<T>
      一个SpinnerValueFactory实现，旨在迭代一个值列表。
      Methods in javafx.scene.control that return SpinnerValueFactory
      Modifier and Type 方法 描述
      SpinnerValueFactory<T> Spinner.getValueFactory​()
      获取属性valueFactory的值。
      Methods in javafx.scene.control that return types with arguments of type SpinnerValueFactory
      Modifier and Type 方法 描述
      ObjectProperty<SpinnerValueFactory<T>> Spinner.valueFactoryProperty​()
      价值工厂是JavaFX Spinner控件背后的模型 - 没有工厂安装的Spinner不可用的值。
      Methods in javafx.scene.control with parameters of type SpinnerValueFactory
      Modifier and Type 方法 描述
      void Spinner.setValueFactory​(SpinnerValueFactory<T> value)
      设置属性valueFactory的值。
      Constructors in javafx.scene.control with parameters of type SpinnerValueFactory
      Constructor 描述
      Spinner​(SpinnerValueFactory<T> valueFactory)
      使用给定值出厂设置创建一个Spinner实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SpinnerValueFactory.DoubleSpinnerValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SpinnerValueFactory.DoubleSpinnerValueFactory

No usage of javafx.scene.control.SpinnerValueFactory.DoubleSpinnerValueFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SpinnerValueFactory.IntegerSpinnerValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SpinnerValueFactory.IntegerSpinnerValueFactory

No usage of javafx.scene.control.SpinnerValueFactory.IntegerSpinnerValueFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SpinnerValueFactory.ListSpinnerValueFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SpinnerValueFactory.ListSpinnerValueFactory

No usage of javafx.scene.control.SpinnerValueFactory.ListSpinnerValueFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SplitMenuButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SplitMenuButton

  • Packages that use SplitMenuButton
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of SplitMenuButton in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type SplitMenuButton
      Constructor 描述
      SplitMenuButtonSkin​(SplitMenuButton control)
      创建一个新的SplitMenuButtonSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SplitPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SplitPane

  • Packages that use SplitPane
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of SplitPane in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type SplitPane
      Constructor 描述
      SplitPaneSkin​(SplitPane control)
      创建一个新的SplitPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.SplitPane.Divider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.SplitPane.Divider

  • Packages that use SplitPane.Divider
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of SplitPane.Divider in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type SplitPane.Divider
      Modifier and Type 方法 描述
      ObservableList<SplitPane.Divider> SplitPane.getDividers​()
      返回此SplitPane中所有分隔符的不可修改列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Tab (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Tab

  • Packages that use Tab
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of Tab in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type Tab
      Modifier and Type 方法 描述
      SingleSelectionModel<Tab> TabPane.getSelectionModel​()
      获取用于选项卡选择的模型。
      ObservableList<Tab> TabPane.getTabs​()
      要在此TabPane中显示的选项卡。
      ObjectProperty<SingleSelectionModel<Tab>> TabPane.selectionModelProperty​()
      用于选择标签的选择模型。
      Method parameters in javafx.scene.control with type arguments of type Tab
      Modifier and Type 方法 描述
      void TabPane.setSelectionModel​(SingleSelectionModel<Tab> value)
      设置用于选项卡选择的模型。
      Constructors in javafx.scene.control with parameters of type Tab
      Constructor 描述
      TabPane​(Tab... tabs)
      构造一个新的TabPane，其中给定的选项卡设置为显示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableCell

  • Packages that use TableCell
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableCell in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type TableCell
      Modifier and Type Field 描述
      static Callback<TableColumn<?,?>,TableCell<?,?>> TableColumn.DEFAULT_CELL_FACTORY
      如果在TableColumn实例上未指定cellFactory，则默认情况下将使用该实例。
      Methods in javafx.scene.control that return types with arguments of type TableCell
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TableColumn<S,T>,TableCell<S,T>>> TableColumn.cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      Callback<TableColumn<S,T>,TableCell<S,T>> TableColumn.getCellFactory​()
      获取属性cellFactory的值。
      Method parameters in javafx.scene.control with type arguments of type TableCell
      Modifier and Type 方法 描述
      void TableColumn.setCellFactory​(Callback<TableColumn<S,T>,TableCell<S,T>> value)
      设置属性cellFactory的值。

    • Uses of TableCell in javafx.scene.control.cell

      Subclasses of TableCell in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxTableCell<S,T>
      一个包含一个TableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  ChoiceBoxTableCell<S,T>
      一个包含TableCell实现的类，它在单元格内绘制一个ChoiceBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含一个TableCell实现的类，它在单元格内绘制一个ProgressBar节点。
      class  TextFieldTableCell<S,T>
      一个包含TableCell实现的类，它在单元格内绘制一个TextField节点。
      Methods in javafx.scene.control.cell that return types with arguments of type TableCell
      Modifier and Type 方法 描述
      static <S> Callback<TableColumn<S,Boolean>,TableCell<S,Boolean>> CheckBoxTableCell.forTableColumn​(TableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(T... items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S> Callback<TableColumn<S,Double>,TableCell<S,Double>> ProgressBarTableCell.forTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0进行数字值的轻松可视化。
      static <S> Callback<TableColumn<S,String>,TableCell<S,String>> TextFieldTableCell.forTableColumn​()
      提供一个TextField ，允许在双击单元格时调用单元格内容，或调用TableView.edit(int, javafx.scene.control.TableColumn)时。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> TextFieldTableCell.forTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时调用单元格内容，或调用TableView.edit(int, javafx.scene.control.TableColumn)时。

    • Uses of TableCell in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return TableCell
      Modifier and Type 方法 描述
      protected TableCell<T,?> TableRowSkin.createCell​(TableColumnBase tcb)
      创建适用于表示给定表列实例的新单元实例。
      Methods in javafx.scene.control.skin with parameters of type TableCell
      Modifier and Type 方法 描述
      protected TableColumn<T,?> TableRowSkin.getTableColumn​(TableCell<T,?> cell)
      返回给定单元格实例的TableColumnBase实例。
      protected void TableRowSkin.updateCell​(TableCell<T,?> cell, TableRow<T> row)
      允许给定单元格被告知它是给定行的成员的方法。
      Constructors in javafx.scene.control.skin with parameters of type TableCell
      Constructor 描述
      TableCellSkin​(TableCell<S,T> control)
      Creates a new TableCellSkin instance, installing the necessary child nodes into the Control children list, as well as the necessary input mappings for handling key, mouse, etc events.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableColumn (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableColumn

  • Packages that use TableColumn
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableColumn in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type TableColumn
      Modifier and Type Field 描述
      static Callback<TableColumn<?,?>,TableCell<?,?>> TableColumn.DEFAULT_CELL_FACTORY
      如果在TableColumn实例上未指定cellFactory，则默认情况下将使用该实例。
      Methods in javafx.scene.control that return TableColumn
      Modifier and Type 方法 描述
      TableColumn<S,?> TableView.ResizeFeatures.getColumn​()
      返回发生resize的列，如果由于TableView resize操作而创建了此ResizeFeatures实例，则返回null。
      TableColumn<S,T> TableCell.getTableColumn​()
      获取属性tableColumn的值。
      TableColumn<S,T> TableColumn.CellDataFeatures.getTableColumn​()
      返回传递给构造函数的TableColumn 。
      TableColumn<S,T> TableColumn.CellEditEvent.getTableColumn​()
      返回发生此事件的TableColumn。
      TableColumn<S,T> TablePosition.getTableColumn​()
      Table Table在TableView中表示的TableColumn。
      TableColumn<S,?> TableView.getVisibleLeafColumn​(int column)
      相对于所有其他可见的叶子列，返回给定列索引中的TableColumn。
      Methods in javafx.scene.control that return types with arguments of type TableColumn
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TableColumn<S,T>,TableCell<S,T>>> TableColumn.cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      Callback<TableColumn<S,T>,TableCell<S,T>> TableColumn.getCellFactory​()
      获取属性cellFactory的值。
      ObservableList<TableColumn<S,?>> TableColumn.getColumns​()
      这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。
      ObservableList<TableColumn<S,?>> TableView.getColumns​()
      TableColumns是TableView的一部分。
      EventHandler<ScrollToEvent<TableColumn<S,?>>> TableView.getOnScrollToColumn​()
      获取属性onScrollToColumn的值。
      ObservableList<TableColumn<S,?>> TableView.getSortOrder​()
      sortOrder列表定义TableColumn实例进行排序的顺序。
      ObservableList<TableColumn<S,?>> TableView.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      ObjectProperty<EventHandler<ScrollToEvent<TableColumn<S,?>>>> TableView.onScrollToColumnProperty​()
      当有请求使用 TableView.scrollToColumn(TableColumn)或 TableView.scrollToColumnIndex(int)将列滚动到视图时 调用
      ReadOnlyObjectProperty<TableColumn<S,T>> TableCell.tableColumnProperty​()
      支持此TableCell的TableColumn实例。
      Methods in javafx.scene.control with parameters of type TableColumn
      Modifier and Type 方法 描述
      abstract void TableView.TableViewSelectionModel.clearAndSelect​(int row, TableColumn<S,?> column)
      清除所有选择，然后选择给定行/列交点处的单元格。
      abstract void TableView.TableViewSelectionModel.clearSelection​(int row, TableColumn<S,?> column)
      从指定的行/列位置（视图索引）中移除选择。
      void TableView.edit​(int row, TableColumn<S,?> column)
      导致给定行/列视图索引处的单元格切换到其编辑状态（如果尚未存在），并且假设TableView和列也是可编辑的。
      void TableView.TableViewFocusModel.focus​(int row, TableColumn<S,?> column)
      导致给定索引处的项目接收焦点。
      int TableView.getVisibleLeafIndex​(TableColumn<S,?> column)
      相对于所有其他可见的叶子列，返回给定列的位置。
      boolean TableView.TableViewFocusModel.isFocused​(int row, TableColumn<S,?> column)
      测试给定位置的行/单元格当前是否具有TableView内的焦点。
      abstract boolean TableView.TableViewSelectionModel.isSelected​(int row, TableColumn<S,?> column)
      测试在此表实例中当前是否选择给定行和列索引的便利函数。
      boolean TableView.resizeColumn​(TableColumn<S,?> column, double delta)
      根据给定的列应用当前安装的大小调整策略，根据提供的增量值调整其大小。
      void TableView.scrollToColumn​(TableColumn<S,?> column)
      滚动TableView，使给定的列在视口内可见。
      abstract void TableView.TableViewSelectionModel.select​(int row, TableColumn<S,?> column)
      选择给定的行/列交叉点的单元格。
      void TableCell.updateTableColumn​(TableColumn col)
      更新与此TableCell关联的TableColumn。
      Method parameters in javafx.scene.control with type arguments of type TableColumn
      Modifier and Type 方法 描述
      void TableColumn.setCellFactory​(Callback<TableColumn<S,T>,TableCell<S,T>> value)
      设置属性cellFactory的值。
      void TableView.setOnScrollToColumn​(EventHandler<ScrollToEvent<TableColumn<S,?>>> value)
      设置属性onScrollToColumn的值。
      Constructors in javafx.scene.control with parameters of type TableColumn
      Constructor 描述
      CellDataFeatures​(TableView<S> tableView, TableColumn<S,T> tableColumn, S value)
      实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。
      ResizeFeatures​(TableView<S> table, TableColumn<S,?> column, Double delta)
      创建此类的实例，提供的TableView，TableColumn和delta值被设置并存储在此不可变实例中。
      TablePosition​(TableView<S> tableView, int row, TableColumn<S,T> tableColumn)
      构造一个TablePosition实例来表示给定TableView实例中给定的行/列位置。

    • Uses of TableColumn in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return types with arguments of type TableColumn
      Modifier and Type 方法 描述
      static <S> Callback<TableColumn<S,Boolean>,TableCell<S,Boolean>> CheckBoxTableCell.forTableColumn​(TableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个用于TableColumn电池厂的电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(T... items)
      创建一个ComboBox单元格工厂用于TableColumn控件。
      static <S> Callback<TableColumn<S,Double>,TableCell<S,Double>> ProgressBarTableCell.forTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0进行数字值的轻松可视化。
      static <S> Callback<TableColumn<S,String>,TableCell<S,String>> TextFieldTableCell.forTableColumn​()
      提供TextField ，使单元格内容的编辑在小区双击，或者当TableView.edit(int, javafx.scene.control.TableColumn)被调用。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> TextFieldTableCell.forTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时调用单元格内容，或调用TableView.edit(int, javafx.scene.control.TableColumn)时。
      Methods in javafx.scene.control.cell with parameters of type TableColumn
      Modifier and Type 方法 描述
      static <S> Callback<TableColumn<S,Boolean>,TableCell<S,Boolean>> CheckBoxTableCell.forTableColumn​(TableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TableColumn电池厂 。

    • Uses of TableColumn in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return TableColumn
      Modifier and Type 方法 描述
      protected TableColumn<T,?> TableRowSkin.getTableColumn​(TableCell<T,?> cell)
      返回给定单元格实例的TableColumnBase实例。
      Methods in javafx.scene.control.skin that return types with arguments of type TableColumn
      Modifier and Type 方法 描述
      protected ObservableList<TableColumn<T,?>> TableRowSkin.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      ReadOnlyObjectProperty<TableColumn<S,T>> TableCellSkin.tableColumnProperty​()
      负责此单元格的TableColumnBase实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableColumn.CellDataFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableColumn.CellDataFeatures

  • Packages that use TableColumn.CellDataFeatures
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。

    • Uses of TableColumn.CellDataFeatures in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type TableColumn.CellDataFeatures
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> TableColumn.cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。
      Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> TableColumn.getCellValueFactory​()
      获取属性cellValueFactory的值。
      Method parameters in javafx.scene.control with type arguments of type TableColumn.CellDataFeatures
      Modifier and Type 方法 描述
      void TableColumn.setCellValueFactory​(Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
      设置属性cellValueFactory的值。

    • Uses of TableColumn.CellDataFeatures in javafx.scene.control.cell

      Methods in javafx.scene.control.cell with parameters of type TableColumn.CellDataFeatures
      Modifier and Type | 方法 | 描述
      ObservableValue<T> | MapValueFactory.call​(TableColumn.CellDataFeatures<Map,T> cdf)
      ObservableValue<T> PropertyValueFactory.call​(TableColumn.CellDataFeatures<S,T> param)
      call方法在需要时被调用，并且被赋予类型为P的单个参数，并且要求返回类型为R的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableColumn.CellEditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableColumn.CellEditEvent

  • Packages that use TableColumn.CellEditEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TableColumn.CellEditEvent in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type TableColumn.CellEditEvent
      Modifier and Type 方法 描述
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editAnyEvent​()
      任何TableColumn编辑事件的父事件。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editCancelEvent​()
      表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editCommitEvent​()
      表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editStartEvent​()
      表示用户已经执行了一些交互来启动编辑事件，或者已经调用了 TableView.edit(int, javafx.scene.control.TableColumn)方法。
      EventHandler<TableColumn.CellEditEvent<S,T>> TableColumn.getOnEditCancel​()
      获取属性onEditCancel的值。
      EventHandler<TableColumn.CellEditEvent<S,T>> TableColumn.getOnEditCommit​()
      获取属性onEditCommit的值。
      EventHandler<TableColumn.CellEditEvent<S,T>> TableColumn.getOnEditStart​()
      获取onEditStart上的属性的值。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> TableColumn.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> TableColumn.onEditCommitProperty​()
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TableColumn.CellEditEvent<S,T>>> TableColumn.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      Method parameters in javafx.scene.control with type arguments of type TableColumn.CellEditEvent
      Modifier and Type 方法 描述
      void TableColumn.setOnEditCancel​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCancel的值。
      void TableColumn.setOnEditCommit​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCommit的值。
      void TableColumn.setOnEditStart​(EventHandler<TableColumn.CellEditEvent<S,T>> value)
      设置属性onEditStart的值。
      Constructor parameters in javafx.scene.control with type arguments of type TableColumn.CellEditEvent
      Constructor 描述
      CellEditEvent​(TableView<S> table, TablePosition<S,T> pos, EventType<TableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableColumn.SortType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableColumn.SortType

  • Packages that use TableColumn.SortType
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TableColumn.SortType in javafx.scene.control

      Methods in javafx.scene.control that return TableColumn.SortType
      Modifier and Type 方法 描述
      TableColumn.SortType TableColumn.getSortType​()
      获取属性sortType的值。
      static TableColumn.SortType TableColumn.SortType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TableColumn.SortType[] TableColumn.SortType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control that return types with arguments of type TableColumn.SortType
      Modifier and Type 方法 描述
      ObjectProperty<TableColumn.SortType> TableColumn.sortTypeProperty​()
      用于说明此列是否为排序顺序的一部分（详情请参阅 TableView.getSortOrder() ），应按升序或降序排列。
      Methods in javafx.scene.control with parameters of type TableColumn.SortType
      Modifier and Type 方法 描述
      void TableColumn.setSortType​(TableColumn.SortType value)
      设置属性sortType的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableColumnBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableColumnBase

  • Packages that use TableColumnBase
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableColumnBase in javafx.scene.control

      Classes in javafx.scene.control with type parameters of type TableColumnBase
      Modifier and Type Class 描述
      class  TableFocusModel<T,TC extends TableColumnBase<T,?>>
      FocusModel实现的抽象基类，用于表类控件（最着名的是TableView和TreeTableView） 。
      class  TablePositionBase<TC extends TableColumnBase>
      此类用于表示表中的单个行/列/单元格。
      Subclasses of TableColumnBase in javafx.scene.control
      Modifier and Type Class 描述
      class  TableColumn<S,T>
      A TableView由多个TableColumn实例组成。
      class  TreeTableColumn<S,T>
      A TreeTableView由多个TreeTableColumn实例组成。
      Methods in javafx.scene.control with type parameters of type TableColumnBase
      Modifier and Type 方法 描述
      static <T extends TableColumnBase<?,?>>
      EventType<ScrollToEvent<T>>             		ScrollToEvent.scrollToColumn​()
      如果用户请求滚动一个TableColumnBase （即
      Methods in javafx.scene.control that return TableColumnBase
      Modifier and Type 方法 描述
      TableColumnBase<S,?> ResizeFeaturesBase.getColumn​()
      返回发生resize的列，如果由于大小调整操作而创建了此ResizeFeatures实例，则返回null。
      TableColumnBase<S,?> TableColumnBase.getParentColumn​()
      获取属性parentColumn的值。
      Methods in javafx.scene.control that return types with arguments of type TableColumnBase
      Modifier and Type 方法 描述
      abstract ObservableList<? extends TableColumnBase<S,?>> TableColumnBase.getColumns​()
      这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。
      ReadOnlyObjectProperty<TableColumnBase<S,?>> TableColumnBase.parentColumnProperty​()
      在使用嵌套列的情况下，此只读属性将始终引用此列的父级。
      Methods in javafx.scene.control with parameters of type TableColumnBase
      Modifier and Type 方法 描述
      abstract void TableSelectionModel.clearAndSelect​(int row, TableColumnBase<T,?> column)
      清除所有选择，然后选择给定行/列交点处的单元格。
      void TableView.TableViewSelectionModel.clearAndSelect​(int row, TableColumnBase<S,?> column)
      清除所有选择，然后选择给定行/列交点处的单元格。
      abstract void TableSelectionModel.clearSelection​(int row, TableColumnBase<T,?> column)
      从指定的行/列位置（视图索引）中移除选择。
      void TableView.TableViewSelectionModel.clearSelection​(int row, TableColumnBase<S,?> column)
      从指定的行/列位置（视图索引）中移除选择。
      abstract boolean TableSelectionModel.isSelected​(int row, TableColumnBase<T,?> column)
      测试在此表实例中当前是否选择给定行和列索引的便利函数。
      boolean TableView.TableViewSelectionModel.isSelected​(int row, TableColumnBase<S,?> column)
      测试在此表实例中当前是否选择给定行和列索引的便利函数。
      abstract void TableSelectionModel.select​(int row, TableColumnBase<T,?> column)
      选择给定的行/列交叉点的单元格。
      void TableView.TableViewSelectionModel.select​(int row, TableColumnBase<S,?> column)
      选择给定的行/列交叉点的单元格。
      abstract void TableSelectionModel.selectRange​(int minRow, TableColumnBase<T,?> minColumn, int maxRow, TableColumnBase<T,?> maxColumn)
      选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。
      void TableView.TableViewSelectionModel.selectRange​(int minRow, TableColumnBase<S,?> minColumn, int maxRow, TableColumnBase<S,?> maxColumn)
      选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。
      void TreeTableView.TreeTableViewSelectionModel.selectRange​(int minRow, TableColumnBase<TreeItem<S>,?> minColumn, int maxRow, TableColumnBase<TreeItem<S>,?> maxColumn)
      选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。
      Constructors in javafx.scene.control with parameters of type TableColumnBase
      Constructor 描述
      ResizeFeaturesBase​(TableColumnBase<S,?> column, Double delta)
      创建此类的实例，其中提供的TableColumnBase和delta值被设置并存储在此不可变实例中。

    • Uses of TableColumnBase in javafx.scene.control.skin

      Classes in javafx.scene.control.skin with type parameters of type TableColumnBase
      Modifier and Type Class 描述
      class  TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>
      TableViewSkinBase是由TableView和TreeTableView等控件使用的基础皮肤类（具体类别分别为TableViewSkin和TreeTableViewSkin ）。
      Methods in javafx.scene.control.skin that return TableColumnBase
      Modifier and Type 方法 描述
      TableColumnBase<S,T> TableCellSkinBase.getTableColumn​()
      获取属性tableColumn的值。
      TableColumnBase<?,?> TableColumnHeader.getTableColumn​()
      获取属性tableColumn的值。
      protected abstract TableColumnBase<T,?> TableRowSkinBase.getTableColumn​(R cell)
      返回给定单元格实例的TableColumnBase实例。
      Methods in javafx.scene.control.skin that return types with arguments of type TableColumnBase
      Modifier and Type 方法 描述
      protected abstract ObservableList<? extends TableColumnBase> TableRowSkinBase.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      abstract ReadOnlyObjectProperty<? extends TableColumnBase<S,T>> TableCellSkinBase.tableColumnProperty​()
      负责此单元格的TableColumnBase实例。
      ReadOnlyObjectProperty<TableColumnBase<?,?>> TableColumnHeader.tableColumnProperty​()
      引用该头部视觉表示的TableColumnBase实例的属性。
      Methods in javafx.scene.control.skin with parameters of type TableColumnBase
      Modifier and Type 方法 描述
      protected TableCell<T,?> TableRowSkin.createCell​(TableColumnBase tcb)
      创建适用于表示给定表列实例的新单元实例。
      protected abstract R TableRowSkinBase.createCell​(TableColumnBase<T,?> tc)
      创建适用于表示给定表列实例的新单元实例。
      protected TreeTableCell<T,?> TreeTableRowSkin.createCell​(TableColumnBase tcb)
      创建适用于表示给定表列实例的新单元实例。
      protected TableColumnHeader NestedTableColumnHeader.createTableColumnHeader​(TableColumnBase col)
      为给定的TableColumnBase实例创建一个新的TableColumnHeader实例。
      Constructors in javafx.scene.control.skin with parameters of type TableColumnBase
      Constructor 描述
      NestedTableColumnHeader​(TableColumnBase tc)
      创建一个新的NestedTableColumnHeader实例来可视化地表示给定的TableColumnBase实例。
      TableColumnHeader​(TableColumnBase tc)
      创建一个新的TableColumnHeader实例来可视化地表示给定的TableColumnBase实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableFocusModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableFocusModel

  • Packages that use TableFocusModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TableFocusModel in javafx.scene.control

      Subclasses of TableFocusModel in javafx.scene.control
      Modifier and Type Class 描述
      static class  TableView.TableViewFocusModel<S>
      A FocusModel具有支持TableView控件要求的附加功能。
      static class  TreeTableView.TreeTableViewFocusModel<S>
      A FocusModel具有附加功能，可支持TableView控件的要求。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TablePosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TablePosition

  • Packages that use TablePosition
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TablePosition in javafx.scene.control

      Methods in javafx.scene.control that return TablePosition
      Modifier and Type 方法 描述
      TablePosition<S,?> TableView.getEditingCell​()
      获取属性editingCell的值。
      TablePosition TableView.TableViewFocusModel.getFocusedCell​()
      获取focusCell属性的值。
      TablePosition<S,T> TableColumn.CellEditEvent.getTablePosition​()
      返回此事件发生的位置。
      Methods in javafx.scene.control that return types with arguments of type TablePosition
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<TablePosition<S,?>> TableView.editingCellProperty​()
      表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
      ReadOnlyObjectProperty<TablePosition> TableView.TableViewFocusModel.focusedCellProperty​()
      当前项目在TableView中的位置具有重点。
      abstract ObservableList<TablePosition> TableView.TableViewSelectionModel.getSelectedCells​()
      一个只读ObservableList，表示此TableView中当前选定的单元格。
      Methods in javafx.scene.control with parameters of type TablePosition
      Modifier and Type 方法 描述
      void TableView.TableViewFocusModel.focus​(TablePosition pos)
      使用TablePosition设置焦点在特定行或单元格的便利方法。
      Constructors in javafx.scene.control with parameters of type TablePosition
      Constructor 描述
      CellEditEvent​(TableView<S> table, TablePosition<S,T> pos, EventType<TableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TablePositionBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TablePositionBase

  • Packages that use TablePositionBase
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TablePositionBase in javafx.scene.control

      Subclasses of TablePositionBase in javafx.scene.control
      Modifier and Type Class 描述
      class  TablePosition<S,T>
      此类用于表示TableView中的单个行/列/单元格。
      class  TreeTablePosition<S,T>
      此类用于在TreeTableView中表示单个行/列/单元格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableRow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableRow

  • Packages that use TableRow
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableRow in javafx.scene.control

      Methods in javafx.scene.control that return TableRow
      Modifier and Type 方法 描述
      TableRow<S> TableCell.getTableRow​()
      获取属性tableRow的值。
      Methods in javafx.scene.control that return types with arguments of type TableRow
      Modifier and Type 方法 描述
      Callback<TableView<S>,TableRow<S>> TableView.getRowFactory​()
      获取属性rowFactory的值。
      ObjectProperty<Callback<TableView<S>,TableRow<S>>> TableView.rowFactoryProperty​()
      一个产生TableRow的函数。
      ReadOnlyObjectProperty<TableRow<S>> TableCell.tableRowProperty​()
      该TableCow目前发现自己位于的TableRow。
      Methods in javafx.scene.control with parameters of type TableRow
      Modifier and Type 方法 描述
      void TableCell.updateTableRow​(TableRow tableRow)
      更新与此TableCell关联的TableRow。
      Method parameters in javafx.scene.control with type arguments of type TableRow
      Modifier and Type 方法 描述
      void TableView.setRowFactory​(Callback<TableView<S>,TableRow<S>> value)
      设置属性rowFactory的值。

    • Uses of TableRow in javafx.scene.control.skin

      Methods in javafx.scene.control.skin with parameters of type TableRow
      Modifier and Type 方法 描述
      protected void TableRowSkin.updateCell​(TableCell<T,?> cell, TableRow<T> row)
      允许给定单元格被告知它是给定行的成员的方法。
      Constructors in javafx.scene.control.skin with parameters of type TableRow
      Constructor 描述
      TableRowSkin​(TableRow<T> control)
      创建一个新的TableRowSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableSelectionModel

  • Packages that use TableSelectionModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TableSelectionModel in javafx.scene.control

      Subclasses of TableSelectionModel in javafx.scene.control
      Modifier and Type Class 描述
      static class  TableView.TableViewSelectionModel<S>
      SelectionModel抽象类的简单扩展，允许对TableView控件的特殊支持。
      static class  TreeTableView.TreeTableViewSelectionModel<S>
      SelectionModel抽象类的简单扩展，允许对TreeTableView控件的特殊支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableView

  • Packages that use TableView
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableView in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type TableView
      Modifier and Type Field 描述
      static Callback<TableView,Boolean> TableView.DEFAULT_SORT_POLICY
      如果没有指定其他策略，则此TableView将使用默认值 sort policy 。
      Methods in javafx.scene.control that return TableView
      Modifier and Type 方法 描述
      TableView<S> TableView.ResizeFeatures.getTable​()
      返回执行resize操作的TableView。
      TableView<S> TableCell.getTableView​()
      获取属性tableView的值。
      TableView<S> TableColumn.CellDataFeatures.getTableView​()
      返回传递给构造函数的TableView 。
      TableView<S> TableColumn.CellEditEvent.getTableView​()
      返回发生此事件的TableView。
      TableView<S> TableColumn.getTableView​()
      获取属性tableView的值。
      TableView<S> TablePosition.getTableView​()
      TableView这个TablePosition是相关的。
      TableView<T> TableRow.getTableView​()
      获取属性tableView的值。
      TableView<S> TableView.TableViewSelectionModel.getTableView​()
      返回安装此选择模型的TableView实例。
      Methods in javafx.scene.control that return types with arguments of type TableView
      Modifier and Type 方法 描述
      EventHandler<SortEvent<TableView<S>>> TableView.getOnSort​()
      获取属性onSort的值。
      Callback<TableView<S>,TableRow<S>> TableView.getRowFactory​()
      获取属性rowFactory的值。
      Callback<TableView<S>,Boolean> TableView.getSortPolicy​()
      获取属性sortPolicy的值。
      ObjectProperty<EventHandler<SortEvent<TableView<S>>>> TableView.onSortProperty​()
      当有请求排序控件时调用。
      ObjectProperty<Callback<TableView<S>,TableRow<S>>> TableView.rowFactoryProperty​()
      一个产生TableRow的函数。
      ObjectProperty<Callback<TableView<S>,Boolean>> TableView.sortPolicyProperty​()
      排序策略指定如何执行此TableView中的排序。
      ReadOnlyObjectProperty<TableView<S>> TableCell.tableViewProperty​()
      TableView与此TableCell关联。
      ReadOnlyObjectProperty<TableView<S>> TableColumn.tableViewProperty​()
      TableView这个TableColumn属于。
      ReadOnlyObjectProperty<TableView<T>> TableRow.tableViewProperty​()
      与此Cell关联的TableView。
      Methods in javafx.scene.control with parameters of type TableView
      Modifier and Type 方法 描述
      void TableCell.updateTableView​(TableView tv)
      更新与TableCell相关联的TableView。
      void TableRow.updateTableView​(TableView<T> tv)
      更新与TableCell相关联的TableView。
      Method parameters in javafx.scene.control with type arguments of type TableView
      Modifier and Type 方法 描述
      void TableView.setOnSort​(EventHandler<SortEvent<TableView<S>>> value)
      设置属性onSort的值。
      void TableView.setRowFactory​(Callback<TableView<S>,TableRow<S>> value)
      设置属性rowFactory的值。
      void TableView.setSortPolicy​(Callback<TableView<S>,Boolean> callback)
      设置属性sortPolicy的值。
      Constructors in javafx.scene.control with parameters of type TableView
      Constructor 描述
      CellDataFeatures​(TableView<S> tableView, TableColumn<S,T> tableColumn, S value)
      实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。
      CellEditEvent​(TableView<S> table, TablePosition<S,T> pos, EventType<TableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。
      ResizeFeatures​(TableView<S> table, TableColumn<S,?> column, Double delta)
      创建此类的实例，提供的TableView，TableColumn和delta值被设置并存储在此不可变实例中。
      TablePosition​(TableView<S> tableView, int row, TableColumn<S,T> tableColumn)
      构造一个TablePosition实例来表示给定TableView实例中给定的行/列位置。
      TableViewFocusModel​(TableView<S> tableView)
      创建一个默认的TableViewFocusModel实例，用于管理提供的TableView控件的焦点。
      TableViewSelectionModel​(TableView<S> tableView)
      使用提供的TableView构建默认的TableViewSelectionModel实例。

    • Uses of TableView in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type TableView
      Constructor 描述
      TableViewSkin​(TableView<T> control)
      创建一个新的TableViewSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableView.ResizeFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableView.ResizeFeatures

  • Packages that use TableView.ResizeFeatures
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TableView.ResizeFeatures in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type TableView.ResizeFeatures
      Modifier and Type Field 描述
      static Callback<TableView.ResizeFeatures,Boolean> TableView.CONSTRAINED_RESIZE_POLICY
      确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。
      static Callback<TableView.ResizeFeatures,Boolean> TableView.UNCONSTRAINED_RESIZE_POLICY
      非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。
      Methods in javafx.scene.control that return types with arguments of type TableView.ResizeFeatures
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TableView.ResizeFeatures,Boolean>> TableView.columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      Callback<TableView.ResizeFeatures,Boolean> TableView.getColumnResizePolicy​()
      获取属性columnResizePolicy的值。
      Method parameters in javafx.scene.control with type arguments of type TableView.ResizeFeatures
      Modifier and Type 方法 描述
      void TableView.setColumnResizePolicy​(Callback<TableView.ResizeFeatures,Boolean> callback)
      设置属性columnResizePolicy的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableView.TableViewFocusModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableView.TableViewFocusModel

  • Packages that use TableView.TableViewFocusModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TableView.TableViewFocusModel in javafx.scene.control

      Methods in javafx.scene.control that return TableView.TableViewFocusModel
      Modifier and Type 方法 描述
      TableView.TableViewFocusModel<S> TableView.getFocusModel​()
      获取属性focusModel的值。
      Methods in javafx.scene.control that return types with arguments of type TableView.TableViewFocusModel
      Modifier and Type 方法 描述
      ObjectProperty<TableView.TableViewFocusModel<S>> TableView.focusModelProperty​()
      代表此TableView当前安装的TableView.TableViewFocusModel 。
      Methods in javafx.scene.control with parameters of type TableView.TableViewFocusModel
      Modifier and Type 方法 描述
      void TableView.setFocusModel​(TableView.TableViewFocusModel<S> value)
      设置属性focusModel的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TableView.TableViewSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TableView.TableViewSelectionModel

  • Packages that use TableView.TableViewSelectionModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TableView.TableViewSelectionModel in javafx.scene.control

      Methods in javafx.scene.control that return TableView.TableViewSelectionModel
      Modifier and Type 方法 描述
      TableView.TableViewSelectionModel<S> TableView.getSelectionModel​()
      获取属性selectionModel的值。
      Methods in javafx.scene.control that return types with arguments of type TableView.TableViewSelectionModel
      Modifier and Type 方法 描述
      ObjectProperty<TableView.TableViewSelectionModel<S>> TableView.selectionModelProperty​()
      SelectionModel提供了可以在TableView中选择单个或多个项目的API，以及检查用户选择了哪些项目。
      Methods in javafx.scene.control with parameters of type TableView.TableViewSelectionModel
      Modifier and Type 方法 描述
      void TableView.setSelectionModel​(TableView.TableViewSelectionModel<S> value)
      设置属性selectionModel的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TabPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TabPane

  • Packages that use TabPane
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TabPane in javafx.scene.control

      Methods in javafx.scene.control that return TabPane
      Modifier and Type 方法 描述
      TabPane Tab.getTabPane​()
      对包含此选项卡实例的TabPane的引用。
      Methods in javafx.scene.control that return types with arguments of type TabPane
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<TabPane> Tab.tabPaneProperty​()
      包含此选项卡的TabPane。

    • Uses of TabPane in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type TabPane
      Constructor 描述
      TabPaneSkin​(TabPane control)
      创建一个新的TabPaneSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TabPane.TabClosingPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TabPane.TabClosingPolicy

  • Packages that use TabPane.TabClosingPolicy
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TabPane.TabClosingPolicy in javafx.scene.control

      Methods in javafx.scene.control that return TabPane.TabClosingPolicy
      Modifier and Type 方法 描述
      TabPane.TabClosingPolicy TabPane.getTabClosingPolicy​()
      选项卡的关闭策略。
      static TabPane.TabClosingPolicy TabPane.TabClosingPolicy.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TabPane.TabClosingPolicy[] TabPane.TabClosingPolicy.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control that return types with arguments of type TabPane.TabClosingPolicy
      Modifier and Type 方法 描述
      ObjectProperty<TabPane.TabClosingPolicy> TabPane.tabClosingPolicyProperty​()
      选项卡的关闭策略。
      Methods in javafx.scene.control with parameters of type TabPane.TabClosingPolicy
      Modifier and Type 方法 描述
      void TabPane.setTabClosingPolicy​(TabPane.TabClosingPolicy value)
      指定TabPane如何从最终用户角度处理标签关闭。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TextArea (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TextArea

  • Packages that use TextArea
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TextArea in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type TextArea
      Constructor 描述
      TextAreaSkin​(TextArea control)
      创建一个新的TextAreaSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TextField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TextField

  • Packages that use TextField
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TextField in javafx.scene.control

      Subclasses of TextField in javafx.scene.control
      Modifier and Type Class 描述
      class  PasswordField
      掩码输入字符的文本字段。
      Methods in javafx.scene.control that return TextField
      Modifier and Type 方法 描述
      TextField ComboBox.getEditor​()
      获取属性编辑器的值。
      TextField DatePicker.getEditor​()
      获取属性编辑器的值。
      TextField Spinner.getEditor​()
      获取属性编辑器的值。
      TextField TextInputDialog.getEditor​()
      返回此对话框中使用的TextField 。
      Methods in javafx.scene.control that return types with arguments of type TextField
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<TextField> ComboBox.editorProperty​()
      ComboBox的编辑器。
      ReadOnlyObjectProperty<TextField> DatePicker.editorProperty​()
      DatePicker的编辑器。
      ReadOnlyObjectProperty<TextField> Spinner.editorProperty​()
      Spinner控件使用的编辑器。

    • Uses of TextField in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return TextField
      Modifier and Type 方法 描述
      protected TextField ColorPickerSkin.getEditor​()
      ColorPicker不使用主文本字段，因此此方法已被覆盖以返回null。
      protected TextField ComboBoxListViewSkin.getEditor​()
      子类负责获取编辑器。
      protected abstract TextField ComboBoxPopupControl.getEditor​()
      子类负责获取编辑器。
      protected TextField DatePickerSkin.getEditor​()
      子类负责获取编辑器。
      Constructors in javafx.scene.control.skin with parameters of type TextField
      Constructor 描述
      TextFieldSkin​(TextField control)
      创建一个新的TextFieldSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TextFormatter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TextFormatter

  • Packages that use TextFormatter
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TextFormatter in javafx.scene.control

      Methods in javafx.scene.control that return TextFormatter
      Modifier and Type 方法 描述
      TextFormatter<?> TextInputControl.getTextFormatter​()
      获取属性textFormatter的值。
      Methods in javafx.scene.control that return types with arguments of type TextFormatter
      Modifier and Type 方法 描述
      ObjectProperty<TextFormatter<?>> TextInputControl.textFormatterProperty​()
      该物业包含目前附件TextFormatter 。
      Methods in javafx.scene.control with parameters of type TextFormatter
      Modifier and Type 方法 描述
      void TextInputControl.setTextFormatter​(TextFormatter<?> value)
      设置属性textFormatter的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TextFormatter.Change (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TextFormatter.Change

  • Packages that use TextFormatter.Change
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TextFormatter.Change in javafx.scene.control

      Methods in javafx.scene.control that return TextFormatter.Change
      Modifier and Type | 方法 | 描述
      TextFormatter.Change | TextFormatter.Change.clone​()
      Methods in javafx.scene.control that return types with arguments of type TextFormatter.Change
      Modifier and Type 方法 描述
      UnaryOperator<TextFormatter.Change> TextFormatter.getFilter​()
      过滤器允许用户截取和修改对文本内容所做的任何更改。
      Constructor parameters in javafx.scene.control with type arguments of type TextFormatter.Change
      Constructor 描述
      TextFormatter​(UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器创建一个新的Formatter。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue, UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器，值转换器和默认值创建一个新的格式化器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TextInputControl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TextInputControl

  • Packages that use TextInputControl
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TextInputControl in javafx.scene.control

      Subclasses of TextInputControl in javafx.scene.control
      Modifier and Type Class 描述
      class  PasswordField
      掩码输入字符的文本字段。
      class  TextArea
      文本输入组件，允许用户输入多行纯文本。
      class  TextField
      文本输入组件，允许用户输入一行未格式化的文本。

    • Uses of TextInputControl in javafx.scene.control.skin

      Classes in javafx.scene.control.skin with type parameters of type TextInputControl
      Modifier and Type Class 描述
      class  TextInputControlSkin<T extends TextInputControl>
      文本输入皮肤的抽象基类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TextInputDialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TextInputDialog

No usage of javafx.scene.control.TextInputDialog
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TitledPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TitledPane

  • Packages that use TitledPane
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TitledPane in javafx.scene.control

      Methods in javafx.scene.control that return TitledPane
      Modifier and Type 方法 描述
      TitledPane Accordion.getExpandedPane​()
      在手风琴中获得扩大的“TitledPane”。
      Methods in javafx.scene.control that return types with arguments of type TitledPane
      Modifier and Type 方法 描述
      ObjectProperty<TitledPane> Accordion.expandedPaneProperty​()
      手风琴中扩大的TitledPane。
      ObservableList<TitledPane> Accordion.getPanes​()
      获取此手风琴中的TitledPane的列表。
      Methods in javafx.scene.control with parameters of type TitledPane
      Modifier and Type 方法 描述
      void Accordion.setExpandedPane​(TitledPane value)
      目前可见的扩展TitledPane 。
      Constructors in javafx.scene.control with parameters of type TitledPane
      Constructor 描述
      Accordion​(TitledPane... titledPanes)
      创建一个新的手风琴与给定的TitledPanes在其中显示。

    • Uses of TitledPane in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type TitledPane
      Constructor 描述
      TitledPaneSkin​(TitledPane control)
      创建一个新的TitledPaneSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ToggleButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ToggleButton

  • Packages that use ToggleButton
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ToggleButton in javafx.scene.control

      Subclasses of ToggleButton in javafx.scene.control
      Modifier and Type Class 描述
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。

    • Uses of ToggleButton in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ToggleButton
      Constructor 描述
      ToggleButtonSkin​(ToggleButton control)
      创建一个新的ToggleButtonSkin实例，将必要的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ToggleGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ToggleGroup

  • Packages that use ToggleGroup
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of ToggleGroup in javafx.scene.control

      Methods in javafx.scene.control that return ToggleGroup
      Modifier and Type 方法 描述
      ToggleGroup RadioMenuItem.getToggleGroup​()
      获取属性toggleGroup的值。
      ToggleGroup Toggle.getToggleGroup​()
      返回的ToggleGroup到这个Toggle所属。
      ToggleGroup ToggleButton.getToggleGroup​()
      获取属性toggleGroup的值。
      Methods in javafx.scene.control that return types with arguments of type ToggleGroup
      Modifier and Type 方法 描述
      ObjectProperty<ToggleGroup> RadioMenuItem.toggleGroupProperty​()
      代表这个RadioMenuItem所属的ToggleGroup 。
      ObjectProperty<ToggleGroup> Toggle.toggleGroupProperty​()
      该ToggleGroup到这个Toggle所属。
      ObjectProperty<ToggleGroup> ToggleButton.toggleGroupProperty​()
      该ToggleGroup到这个ToggleButton所属。
      Methods in javafx.scene.control with parameters of type ToggleGroup
      Modifier and Type 方法 描述
      void RadioMenuItem.setToggleGroup​(ToggleGroup value)
      设置属性toggleGroup的值。
      void Toggle.setToggleGroup​(ToggleGroup toggleGroup)
      设置ToggleGroup到这个Toggle所属。
      void ToggleButton.setToggleGroup​(ToggleGroup value)
      设置属性toggleGroup的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.ToolBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.ToolBar

  • Packages that use ToolBar
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ToolBar in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type ToolBar
      Constructor 描述
      ToolBarSkin​(ToolBar control)
      创建一个新的ToolBarSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.Tooltip (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.Tooltip

  • Packages that use Tooltip
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of Tooltip in javafx.scene.control

      Methods in javafx.scene.control that return Tooltip
      Modifier and Type 方法 描述
      Tooltip Control.getTooltip​()
      获取属性工具提示的值。
      Tooltip Tab.getTooltip​()
      与此选项卡关联的工具提示。
      Methods in javafx.scene.control that return types with arguments of type Tooltip
      Modifier and Type 方法 描述
      ObjectProperty<Tooltip> Control.tooltipProperty​()
      用于此控件的工具提示。
      ObjectProperty<Tooltip> Tab.tooltipProperty​()
      与此选项卡关联的工具提示。
      Methods in javafx.scene.control with parameters of type Tooltip
      Modifier and Type 方法 描述
      static void Tooltip.install​(Node node, Tooltip t)
      将给定的Tooltip与给定的Node相关联 。
      void Control.setTooltip​(Tooltip value)
      设置属性工具提示的值。
      void Tab.setTooltip​(Tooltip value)
      指定工具提示，以显示用户何时悬停在选项卡上。
      static void Tooltip.uninstall​(Node node, Tooltip t)
      删除给定的Tooltip在指定的Node的关联 。

    • Uses of Tooltip in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return Tooltip
      Modifier and Type 方法 描述
      Tooltip TooltipSkin.getSkinnable​()
      获取此皮肤分配到的Skinnable。
      Constructors in javafx.scene.control.skin with parameters of type Tooltip
      Constructor 描述
      TooltipSkin​(Tooltip t)
      为给定的Tooltip创建一个新的TooltipSkin实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeCell

  • Packages that use TreeCell
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TreeCell in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type TreeCell
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TreeView<T>,TreeCell<T>>> TreeView.cellFactoryProperty​()
      表示将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
      Callback<TreeView<T>,TreeCell<T>> TreeView.getCellFactory​()
      返回用于创建TreeCells的单元格工厂，用于表示TreeView中的项目，如果未设置自定义单元格工厂，则返回null。
      Method parameters in javafx.scene.control with type arguments of type TreeCell
      Modifier and Type 方法 描述
      void TreeView.setCellFactory​(Callback<TreeView<T>,TreeCell<T>> value)
      设置将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。

    • Uses of TreeCell in javafx.scene.control.cell

      Subclasses of TreeCell in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxTreeCell<T>
      一个包含TreeCell实现的类，它在单元格内绘制一个CheckBox节点，并支持常见的交互（ 稍后更详细地讨论）。
      class  ChoiceBoxTreeCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ComboBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  TextFieldTreeCell<T>
      一个包含TreeCell实现的类，在单元格内绘制一个TextField节点。
      Methods in javafx.scene.control.cell that return types with arguments of type TreeCell
      Modifier and Type 方法 描述
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​()
      创建在TreeView控件中使用的单元格工厂，尽管在TreeView中使用时有一个主要假设：此单元格工厂假定TreeView根和所有子项为CheckBoxTreeItem的实例，而不是正常使用的默认值为TreeItem的类。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(T... items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(ObservableList<T> items)
      创建一个ComboBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(T... items)
      创建ComboBox单元格工厂用于TreeView控件。
      static Callback<TreeView<String>,TreeCell<String>> TextFieldTreeCell.forTreeView​()
      提供TextField ，允许在双击单元格时调用单元格内容，或者调用TreeView.edit(javafx.scene.control.TreeItem)时。
      static <T> Callback<TreeView<T>,TreeCell<T>> TextFieldTreeCell.forTreeView​(StringConverter<T> converter)
      提供TextField ，允许双击单元格时或当调用TreeView.edit(javafx.scene.control.TreeItem)时编辑单元格内容。

    • Uses of TreeCell in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type TreeCell
      Constructor 描述
      TreeCellSkin​(TreeCell<T> control)
      创建一个新的TreeCellSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeItem

  • Packages that use TreeItem
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。

    • Uses of TreeItem in javafx.scene.control

      Subclasses of TreeItem in javafx.scene.control
      Modifier and Type Class 描述
      class  CheckBoxTreeItem<T>
      TreeItem子类增加了在选定的，未选择的和不确定的状态中的支持。
      Methods in javafx.scene.control that return TreeItem
      Modifier and Type 方法 描述
      TreeItem<T> TreeView.getEditingItem​()
      返回TreeView中当前正在编辑的TreeItem，如果没有编辑任何项目，则返回null。
      protected TreeItem<S> TreeTableView.TreeTableViewFocusModel.getModelItem​(int index)
      返回给定索引处的项目。
      TreeItem<S> TreeTableView.TreeTableViewSelectionModel.getModelItem​(int index)
      返回给定索引处的项目。
      TreeItem<T> TreeItem.getParent​()
      这个TreeItem的父项。
      TreeItem<S> TreeTableView.getRoot​()
      返回此TreeTableView的当前根节点，如果未指定根节点，则返回null。
      TreeItem<T> TreeView.getRoot​()
      返回此TreeView的当前根节点，如果未指定根节点，则返回null。
      TreeItem<S> TreeTableColumn.CellEditEvent.getRowValue​()
      为TreeTableColumn.CellEditEvent.getTreeTablePosition()中返回的TablePosition中包含的行返回行的值（即TableView items列表）的便利方法。
      TreeItem<T> TreeItem.TreeModificationEvent.getSource​()
      返回发生此事件的TreeItem。
      TreeItem<T> TreeCell.getTreeItem​()
      返回当前在此TreeCell中设置的TreeItem。
      TreeItem<T> TreeItem.TreeModificationEvent.getTreeItem​()
      返回此事件发生的TreeItem。
      TreeItem<S> TreeTablePosition.getTreeItem​()
      返回TreeItem那背上TablePositionBase.getRow()行}。
      TreeItem<T> TreeTableRow.getTreeItem​()
      返回当前在此TreeTableRow中设置的TreeItem。
      TreeItem<S> TreeTableView.EditEvent.getTreeItem​()
      返回编辑发生的TreeItem 。
      TreeItem<S> TreeTableView.getTreeItem​(int row)
      返回给定索引中的TreeItem，如果超出范围则返回null。
      TreeItem<T> TreeView.EditEvent.getTreeItem​()
      返回编辑发生的TreeItem 。
      TreeItem<T> TreeView.getTreeItem​(int row)
      返回给定索引中的TreeItem，如果超出范围则返回null。
      TreeItem<S> TreeTableColumn.CellDataFeatures.getValue​()
      返回传递给构造函数的值。
      TreeItem<T> TreeItem.nextSibling​()
      返回TreeItem的下一个兄弟节点。
      TreeItem<T> TreeItem.nextSibling​(TreeItem<T> afterNode)
      返回给定节点之后的下一个兄弟节点。
      TreeItem<T> TreeItem.previousSibling​()
      返回TreeItem的以前的同级。
      TreeItem<T> TreeItem.previousSibling​(TreeItem<T> beforeNode)
      返回给定节点之前的同级。
      Methods in javafx.scene.control that return types with arguments of type TreeItem
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Comparator<TreeItem<S>>> TreeTableView.comparatorProperty​()
      比较器属性是一个只读属性，代表 sort order列表的当前状态。
      ReadOnlyObjectProperty<TreeItem<T>> TreeView.editingItemProperty​()
      用于表示当前在TreeView中编辑的TreeItem的属性，如果正在进行编辑，或者如果没有编辑任何项目，则为null。
      ObjectProperty<FocusModel<TreeItem<T>>> TreeView.focusModelProperty​()
      FocusModel提供API，通过它可以将焦点控制在零行或一行TreeView。
      List<? extends TreeItem<T>> TreeItem.TreeModificationEvent.getAddedChildren​()
      返回在此事件中添加到TreeItem的子项，如果未添加子项，则返回空列表。
      ObservableList<TreeItem<T>> TreeItem.getChildren​()
      这个TreeItem的孩子。
      Comparator<TreeItem<S>> TreeTableView.getComparator​()
      获取属性比较器的值。
      FocusModel<TreeItem<T>> TreeView.getFocusModel​()
      返回当前安装的FocusModel 。
      List<? extends TreeItem<T>> TreeItem.TreeModificationEvent.getRemovedChildren​()
      返回在此事件中从TreeItem中删除的子项，如果未添加子项，则返回空列表。
      MultipleSelectionModel<TreeItem<T>> TreeView.getSelectionModel​()
      返回当前安装的选择模型。
      ReadOnlyObjectProperty<TreeItem<T>> TreeItem.parentProperty​()
      表示此TreeItem父项的属性。
      ObjectProperty<TreeItem<S>> TreeTableView.rootProperty​()
      表示TreeTableView根节点的属性。
      ObjectProperty<TreeItem<T>> TreeView.rootProperty​()
      表示TreeView根节点的属性。
      ObjectProperty<MultipleSelectionModel<TreeItem<T>>> TreeView.selectionModelProperty​()
      SelectionModel提供了可以在TreeView中选择单个或多个项目的API，以及检查用户选择了哪些行。
      ReadOnlyObjectProperty<TreeItem<T>> TreeCell.treeItemProperty​()
      每个TreeCell最多代表一个TreeItem ，由该属性表示。
      ReadOnlyObjectProperty<TreeItem<T>> TreeTableRow.treeItemProperty​()
      每个TreeTableCell最多表示一个TreeItem ，由该属性表示。
      Methods in javafx.scene.control with parameters of type TreeItem
      Modifier and Type 方法 描述
      void TreeView.edit​(TreeItem<T> item)
      指示TreeView开始编辑给定的TreeItem，如果TreeView是 editable 。
      ObservableValue<T> TreeTableColumn.getCellObservableValue​(TreeItem<S> item)
      尝试返回给定项目（其类型为S）的ObservableValue <T>。
      static int TreeTableView.getNodeLevel​(TreeItem<?> node)
      已过时。
      此方法无法正确计算从给定TreeItem到TreeTableView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过TreeTableView.getTreeItemLevel(TreeItem)
      static int TreeView.getNodeLevel​(TreeItem<?> node)
      已过时。
      此方法无法正确计算从给定TreeItem到TreeView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过TreeView.getTreeItemLevel(TreeItem)
      int TreeTableView.getRow​(TreeItem<S> item)
      返回给定TreeItem的索引位置，假设它目前可通过树层次结构访问（最显着的是所有父树项目都被扩展）。
      int TreeView.getRow​(TreeItem<T> item)
      返回给定TreeItem的索引位置，假设它目前可通过树层次结构访问（最显着的是所有父树项目都被扩展）。
      int TreeTableView.getTreeItemLevel​(TreeItem<?> node)
      根据getParent（）可以递归调用的次数，返回给定TreeItem的“缩进”级别数。
      int TreeView.getTreeItemLevel​(TreeItem<?> node)
      根据getParent（）可以递归调用的次数，返回给定TreeItem的“缩进”级别数。
      TreeItem<T> TreeItem.nextSibling​(TreeItem<T> afterNode)
      返回给定节点之后的下一个兄弟节点。
      TreeItem<T> TreeItem.previousSibling​(TreeItem<T> beforeNode)
      返回给定节点之前的同级。
      void TreeTableView.setRoot​(TreeItem<S> value)
      设置此TreeTableView中的根节点。
      void TreeView.setRoot​(TreeItem<T> value)
      设置此TreeView中的根节点。
      void TreeCell.updateTreeItem​(TreeItem<T> treeItem)
      更新与TreeCell关联的TreeItem。
      void TreeTableRow.updateTreeItem​(TreeItem<T> treeItem)
      更新与此TreeTableCell关联的TreeItem。
      Method parameters in javafx.scene.control with type arguments of type TreeItem
      Modifier and Type 方法 描述
      void TreeTableView.TreeTableViewSelectionModel.selectRange​(int minRow, TableColumnBase<TreeItem<S>,?> minColumn, int maxRow, TableColumnBase<TreeItem<S>,?> maxColumn)
      选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。
      void TreeView.setFocusModel​(FocusModel<TreeItem<T>> value)
      设置要在TreeView中使用的FocusModel 。
      void TreeView.setSelectionModel​(MultipleSelectionModel<TreeItem<T>> value)
      设置要在TreeView中使用的MultipleSelectionModel 。
      Constructors in javafx.scene.control with parameters of type TreeItem
      Constructor 描述
      CellDataFeatures​(TreeTableView<S> treeTableView, TreeTableColumn<S,T> tableColumn, TreeItem<S> value)
      实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。
      EditEvent​(TreeTableView<S> source, EventType<? extends TreeTableView.EditEvent> eventType, TreeItem<S> treeItem, S oldValue, S newValue)
      创建一个新的EditEvent实例来表示编辑事件。
      EditEvent​(TreeView<T> source, EventType<? extends TreeView.EditEvent> eventType, TreeItem<T> treeItem, T oldValue, T newValue)
      创建一个新的EditEvent实例来表示编辑事件。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem)
      构建一个基本的TreeModificationEvent - 这在树项目没有收到新值，扩展/折叠状态之间没有变化，并且其子项没有更改的情况下很有用。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, boolean expanded)
      构造一个TreeModificationEvent，当TreeItem已经更改了 expandedProperty()时 。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, List<? extends TreeItem<T>> added, List<? extends TreeItem<T>> removed)
      构造一个TreeModificationEvent，当TreeItem的子项列表更改时。
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, T newValue)
      构建一个TreeModificationEvent，当TreeItem的 valueProperty()更改时。
      TreeTableView​(TreeItem<S> root)
      使用提供的根节点创建TreeTableView。
      TreeView​(TreeItem<T> root)
      使用提供的根节点创建TreeView。
      Constructor parameters in javafx.scene.control with type arguments of type TreeItem
      Constructor 描述
      TreeModificationEvent​(EventType<? extends Event> eventType, TreeItem<T> treeItem, List<? extends TreeItem<T>> added, List<? extends TreeItem<T>> removed)
      构造一个TreeModificationEvent，当TreeItem的子项列表更改时。

    • Uses of TreeItem in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return types with arguments of type TreeItem
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<TreeItem<T>>> CheckBoxTreeCell.converterProperty​()
      StringConverter属性。
      StringConverter<TreeItem<T>> CheckBoxTreeCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      Callback<TreeItem<T>,ObservableValue<Boolean>> CheckBoxTreeCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<TreeItem<T>,ObservableValue<Boolean>>> CheckBoxTreeCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      Method parameters in javafx.scene.control.cell with type arguments of type TreeItem
      Modifier and Type 方法 描述
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      void CheckBoxTreeCell.setConverter​(StringConverter<TreeItem<T>> value)
      设置要在此单元格中使用的StringConverter 。
      void CheckBoxTreeCell.setSelectedStateCallback​(Callback<TreeItem<T>,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      Constructor parameters in javafx.scene.control.cell with type arguments of type TreeItem
      Constructor 描述
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个CheckBoxTreeCell用于通过单元格工厂的TreeView控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeItem.TreeModificationEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeItem.TreeModificationEvent

  • Packages that use TreeItem.TreeModificationEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeItem.TreeModificationEvent in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type TreeItem.TreeModificationEvent
      Modifier and Type 方法 描述
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.branchCollapsedEvent​()
      当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于折叠状态。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.branchExpandedEvent​()
      当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于展开状态。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.childrenModificationEvent​()
      当TreeItem接收到对其子列表的直接修改时使用的EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.expandedItemCountChangeEvent​()
      当TreeItem接收到一个修改，导致孩子数目可见的更改时使用的常规EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.graphicChangedEvent​()
      当TreeItem接收到其图形属性的修改时使用的EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.treeNotificationEvent​()
      用于指示事件在TreeItem中发生的基本EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.valueChangedEvent​()
      当TreeItem接收到对其value属性的修改时使用的EventType。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeSortMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeSortMode

  • Packages that use TreeSortMode
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeSortMode in javafx.scene.control

      Methods in javafx.scene.control that return TreeSortMode
      Modifier and Type 方法 描述
      TreeSortMode TreeTableView.getSortMode​()
      获取属性sortMode的值。
      static TreeSortMode TreeSortMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TreeSortMode[] TreeSortMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control that return types with arguments of type TreeSortMode
      Modifier and Type 方法 描述
      ObjectProperty<TreeSortMode> TreeTableView.sortModeProperty​()
      指定在排序此TreeTableView的内容时使用的排序模式，应在 sort order列表中指定任何列。
      Methods in javafx.scene.control with parameters of type TreeSortMode
      Modifier and Type 方法 描述
      void TreeTableView.setSortMode​(TreeSortMode value)
      设置属性sortMode的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableCell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableCell

  • Packages that use TreeTableCell
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TreeTableCell in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type TreeTableCell
      Modifier and Type Field 描述
      static Callback<TreeTableColumn<?,?>,TreeTableCell<?,?>> TreeTableColumn.DEFAULT_CELL_FACTORY
      如果在TreeTableColumn实例上未指定cellFactory，则默认情况下将使用该实例。
      Methods in javafx.scene.control that return types with arguments of type TreeTableCell
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>> TreeTableColumn.cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> TreeTableColumn.getCellFactory​()
      获取属性cellFactory的值。
      Method parameters in javafx.scene.control with type arguments of type TreeTableCell
      Modifier and Type 方法 描述
      void TreeTableColumn.setCellFactory​(Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> value)
      设置属性cellFactory的值。

    • Uses of TreeTableCell in javafx.scene.control.cell

      Subclasses of TreeTableCell in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ProgressBarTreeTableCell<S>
      一个包含一个TreeTableCell实现的类，它在单元格内绘制一个ProgressBar节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格内绘制一个TextField节点。
      Methods in javafx.scene.control.cell that return types with arguments of type TreeTableCell
      Modifier and Type 方法 描述
      static <S> Callback<TreeTableColumn<S,Boolean>,TreeTableCell<S,Boolean>> CheckBoxTreeTableCell.forTreeTableColumn​(TreeTableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeTableColumn电池厂的电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个用于TreeTableColumn电池厂的电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(T... items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      static <S> Callback<TreeTableColumn<S,Double>,TreeTableCell<S,Double>> ProgressBarTreeTableCell.forTreeTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0轻松显示数字值。
      static <S> Callback<TreeTableColumn<S,String>,TreeTableCell<S,String>> TextFieldTreeTableCell.forTreeTableColumn​()
      提供TextField ，允许在双击单元格时调用单元格内容，或调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> TextFieldTreeTableCell.forTreeTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时调用单元格内容，或调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。

    • Uses of TreeTableCell in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return TreeTableCell
      Modifier and Type 方法 描述
      protected TreeTableCell<T,?> TreeTableRowSkin.createCell​(TableColumnBase tcb)
      创建适用于表示给定表列实例的新单元实例。
      Methods in javafx.scene.control.skin with parameters of type TreeTableCell
      Modifier and Type 方法 描述
      protected TreeTableColumn<T,?> TreeTableRowSkin.getTableColumn​(TreeTableCell cell)
      返回给定单元格实例的TableColumnBase实例。
      protected void TreeTableRowSkin.updateCell​(TreeTableCell<T,?> cell, TreeTableRow<T> row)
      允许给定单元格被告知它是给定行的成员的方法。
      Constructors in javafx.scene.control.skin with parameters of type TreeTableCell
      Constructor 描述
      TreeTableCellSkin​(TreeTableCell<S,T> control)
      Creates a new TreeTableCellSkin instance, installing the necessary child nodes into the Control children list, as well as the necessary input mappings for handling key, mouse, etc events.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableColumn (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableColumn

  • Packages that use TreeTableColumn
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TreeTableColumn in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type TreeTableColumn
      Modifier and Type Field 描述
      static Callback<TreeTableColumn<?,?>,TreeTableCell<?,?>> TreeTableColumn.DEFAULT_CELL_FACTORY
      如果在TreeTableColumn实例上未指定cellFactory，则默认情况下将使用该实例。
      Methods in javafx.scene.control that return TreeTableColumn
      Modifier and Type | 方法 | 描述
      TreeTableColumn<S,?> TreeTableView.ResizeFeatures.getColumn​()
      返回发生resize的列，如果由于TreeTableView resize操作而创建了此ResizeFeatures实例，则返回null。
      TreeTableColumn<S,T> TreeTableCell.getTableColumn​()
      获取属性tableColumn的值。
      TreeTableColumn<S,T> TreeTableColumn.CellEditEvent.getTableColumn​()
      返回发生此事件的TreeTableColumn。
      TreeTableColumn<S,T> | TreeTablePosition.getTableColumn​()
      TreeTableColumn<S,?> TreeTableView.getTreeColumn​()
      获取属性treeColumn的值。
      TreeTableColumn<S,T> TreeTableColumn.CellDataFeatures.getTreeTableColumn​()
      返回传递给构造函数的TreeTableColumn 。
      TreeTableColumn<S,?> TreeTableView.getVisibleLeafColumn​(int column)
      相对于所有其他可见的叶子列，返回给定列索引中的TreeTableColumn。
      Methods in javafx.scene.control that return types with arguments of type TreeTableColumn
      Modifier and Type | 方法 | 描述
      ObjectProperty<Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>> TreeTableColumn.cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> TreeTableColumn.getCellFactory​()
      获取属性cellFactory的值。
      ObservableList<TreeTableColumn<S,?>> TreeTableColumn.getColumns​()
      这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。
      ObservableList<TreeTableColumn<S,?>> TreeTableView.getColumns​()
      作为TableView的一部分的TreeTableColumns。
      EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> TreeTableView.getOnScrollToColumn​()
      获取属性onScrollToColumn的值。
      ObservableList<TreeTableColumn<S,?>> TreeTableView.getSortOrder​()
      sortOrder列表定义了TreeTableColumn实例进行排序的顺序。
      ObservableList<TreeTableColumn<S,?>> TreeTableView.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      ObjectProperty<EventHandler<ScrollToEvent<TreeTableColumn<S,?>>>> TreeTableView.onScrollToColumnProperty​()
      当有请求使用 TreeTableView.scrollToColumn(TreeTableColumn)或 TreeTableView.scrollToColumnIndex(int)将列滚动到视图时 调用
      ReadOnlyObjectProperty<TreeTableColumn<S,T>> | TreeTableCell.tableColumnProperty​()
      ObjectProperty<TreeTableColumn<S,?>> TreeTableView.treeColumnProperty​()
      表示哪个列应该在其中显示披露节点的属性（即带有箭头的列）。
      Methods in javafx.scene.control with parameters of type TreeTableColumn
      Modifier and Type 方法 描述
      void TreeTableView.edit​(int row, TreeTableColumn<S,?> column)
      导致给定行/列视图索引处的单元格切换到其编辑状态（如果尚未存在），并且假设TableView和列也是可编辑的。
      void TreeTableView.TreeTableViewFocusModel.focus​(int row, TreeTableColumn<S,?> column)
      导致给定索引处的项目接收焦点。
      int TreeTableView.getVisibleLeafIndex​(TreeTableColumn<S,?> column)
      相对于所有其他可见的叶子列，返回给定列的位置。
      boolean TreeTableView.TreeTableViewFocusModel.isFocused​(int row, TreeTableColumn<S,?> column)
      测试给定位置的行/单元格当前是否具有TableView内的焦点。
      boolean TreeTableView.resizeColumn​(TreeTableColumn<S,?> column, double delta)
      根据给定的列应用当前安装的大小调整策略，根据提供的增量值调整其大小。
      void TreeTableView.scrollToColumn​(TreeTableColumn<S,?> column)
      滚动TreeTableView，使给定的列在视口内可见。
      void TreeTableView.setTreeColumn​(TreeTableColumn<S,?> value)
      设置属性treeColumn的值。
      void TreeTableCell.updateTreeTableColumn​(TreeTableColumn<S,T> col)
      更新与此TreeTableCell关联的TreeTableColumn。
      Method parameters in javafx.scene.control with type arguments of type TreeTableColumn
      Modifier and Type 方法 描述
      void TreeTableColumn.setCellFactory​(Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> value)
      设置属性cellFactory的值。
      void TreeTableView.setOnScrollToColumn​(EventHandler<ScrollToEvent<TreeTableColumn<S,?>>> value)
      设置属性onScrollToColumn的值。
      Constructors in javafx.scene.control with parameters of type TreeTableColumn
      Constructor 描述
      CellDataFeatures​(TreeTableView<S> treeTableView, TreeTableColumn<S,T> tableColumn, TreeItem<S> value)
      实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。
      ResizeFeatures​(TreeTableView<S> treeTable, TreeTableColumn<S,?> column, Double delta)
      创建此类的实例，提供的TreeTableView，TreeTableColumn和delta值被设置并存储在此不可变实例中。
      TreeTablePosition​(TreeTableView<S> treeTableView, int row, TreeTableColumn<S,T> tableColumn)
      构造一个TreeTablePosition实例来表示给定TreeTableView实例中给定的行/列位置。

    • Uses of TreeTableColumn in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return types with arguments of type TreeTableColumn
      Modifier and Type 方法 描述
      static <S> Callback<TreeTableColumn<S,Boolean>,TreeTableCell<S,Boolean>> CheckBoxTreeTableCell.forTreeTableColumn​(TreeTableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeTableColumn电池厂的电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个用于TreeTableColumn电池厂的电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(T... items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S> Callback<TreeTableColumn<S,Double>,TreeTableCell<S,Double>> ProgressBarTreeTableCell.forTreeTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0轻松地显示数字值。
      static <S> Callback<TreeTableColumn<S,String>,TreeTableCell<S,String>> TextFieldTreeTableCell.forTreeTableColumn​()
      提供TextField ，允许在双击单元格时调用单元格内容，或调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> TextFieldTreeTableCell.forTreeTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时调用单元格内容，或调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。
      Methods in javafx.scene.control.cell with parameters of type TreeTableColumn
      Modifier and Type 方法 描述
      static <S> Callback<TreeTableColumn<S,Boolean>,TreeTableCell<S,Boolean>> CheckBoxTreeTableCell.forTreeTableColumn​(TreeTableColumn<S,Boolean> column)
      创建一个用于TreeTableColumn电池厂的电池厂 。

    • Uses of TreeTableColumn in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return TreeTableColumn
      Modifier and Type 方法 描述
      protected TreeTableColumn<T,?> TreeTableRowSkin.getTableColumn​(TreeTableCell cell)
      返回给定单元格实例的TableColumnBase实例。
      Methods in javafx.scene.control.skin that return types with arguments of type TreeTableColumn
      Modifier and Type 方法 描述
      protected ObservableList<TreeTableColumn<T,?>> TreeTableRowSkin.getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      ReadOnlyObjectProperty<TreeTableColumn<S,T>> TreeTableCellSkin.tableColumnProperty​()
      负责此单元格的TableColumnBase实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableColumn.CellDataFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableColumn.CellDataFeatures

  • Packages that use TreeTableColumn.CellDataFeatures
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。

    • Uses of TreeTableColumn.CellDataFeatures in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type TreeTableColumn.CellDataFeatures
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> TreeTableColumn.cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。
      Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> TreeTableColumn.getCellValueFactory​()
      获取属性cellValueFactory的值。
      Method parameters in javafx.scene.control with type arguments of type TreeTableColumn.CellDataFeatures
      Modifier and Type 方法 描述
      void TreeTableColumn.setCellValueFactory​(Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
      设置属性cellValueFactory的值。

    • Uses of TreeTableColumn.CellDataFeatures in javafx.scene.control.cell

      Methods in javafx.scene.control.cell with parameters of type TreeTableColumn.CellDataFeatures
      Modifier and Type 方法 描述
      ObservableValue<T> TreeItemPropertyValueFactory.call​(TreeTableColumn.CellDataFeatures<S,T> param)
      call方法在需要时被调用，并且被赋予类型为P的单个参数，并且要求返回类型为R的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableColumn.CellEditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableColumn.CellEditEvent

  • Packages that use TreeTableColumn.CellEditEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeTableColumn.CellEditEvent in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type TreeTableColumn.CellEditEvent
      Modifier and Type 方法 描述
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editAnyEvent​()
      任何TreeTableColumn编辑事件的父事件。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editCancelEvent​()
      表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editCommitEvent​()
      表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editStartEvent​()
      表示用户已经执行了一些交互来启动编辑事件，或者已经调用了 TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)方法。
      EventHandler<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.getOnEditCancel​()
      获取属性onEditCancel的值。
      EventHandler<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.getOnEditCommit​()
      获取属性onEditCommit的值。
      EventHandler<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.getOnEditStart​()
      获取onEditStart上的属性的值。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> TreeTableColumn.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> TreeTableColumn.onEditCommitProperty​()
      当用户成功提交编辑时，会触发此事件处理程序。
      ObjectProperty<EventHandler<TreeTableColumn.CellEditEvent<S,T>>> TreeTableColumn.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      Method parameters in javafx.scene.control with type arguments of type TreeTableColumn.CellEditEvent
      Modifier and Type 方法 描述
      void TreeTableColumn.setOnEditCancel​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCancel的值。
      void TreeTableColumn.setOnEditCommit​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
      设置属性onEditCommit的值。
      void TreeTableColumn.setOnEditStart​(EventHandler<TreeTableColumn.CellEditEvent<S,T>> value)
      设置属性onEditStart的值。
      Constructor parameters in javafx.scene.control with type arguments of type TreeTableColumn.CellEditEvent
      Constructor 描述
      CellEditEvent​(TreeTableView<S> table, TreeTablePosition<S,T> pos, EventType<TreeTableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableColumn.SortType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableColumn.SortType

  • Packages that use TreeTableColumn.SortType
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeTableColumn.SortType in javafx.scene.control

      Methods in javafx.scene.control that return TreeTableColumn.SortType
      Modifier and Type 方法 描述
      TreeTableColumn.SortType TreeTableColumn.getSortType​()
      获取属性sortType的值。
      static TreeTableColumn.SortType TreeTableColumn.SortType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TreeTableColumn.SortType[] TreeTableColumn.SortType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control that return types with arguments of type TreeTableColumn.SortType
      Modifier and Type 方法 描述
      ObjectProperty<TreeTableColumn.SortType> TreeTableColumn.sortTypeProperty​()
      用于说明此列是否为排序顺序的一部分（更多详细信息，请参阅 TreeTableView.getSortOrder() ），应按升序或降序排列。
      Methods in javafx.scene.control with parameters of type TreeTableColumn.SortType
      Modifier and Type 方法 描述
      void TreeTableColumn.setSortType​(TreeTableColumn.SortType value)
      设置属性sortType的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTablePosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTablePosition

  • Packages that use TreeTablePosition
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeTablePosition in javafx.scene.control

      Methods in javafx.scene.control that return TreeTablePosition
      Modifier and Type 方法 描述
      TreeTablePosition<S,?> TreeTableView.getEditingCell​()
      获取属性editingCell的值。
      TreeTablePosition<S,?> TreeTableView.TreeTableViewFocusModel.getFocusedCell​()
      获取focusCell属性的值。
      TreeTablePosition<S,T> TreeTableColumn.CellEditEvent.getTreeTablePosition​()
      返回此事件发生的位置。
      Methods in javafx.scene.control that return types with arguments of type TreeTablePosition
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<TreeTablePosition<S,?>> TreeTableView.editingCellProperty​()
      表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
      ReadOnlyObjectProperty<TreeTablePosition<S,?>> TreeTableView.TreeTableViewFocusModel.focusedCellProperty​()
      当前项目在TableView中的位置具有重点。
      abstract ObservableList<TreeTablePosition<S,?>> TreeTableView.TreeTableViewSelectionModel.getSelectedCells​()
      一个只读ObservableList，表示此TreeTableView中当前选定的单元格。
      Methods in javafx.scene.control with parameters of type TreeTablePosition
      Modifier and Type 方法 描述
      void TreeTableView.TreeTableViewFocusModel.focus​(TreeTablePosition<S,?> pos)
      使用TablePosition设置焦点在特定行或单元格的便利方法。
      Constructors in javafx.scene.control with parameters of type TreeTablePosition
      Constructor 描述
      CellEditEvent​(TreeTableView<S> table, TreeTablePosition<S,T> pos, EventType<TreeTableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableRow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableRow

  • Packages that use TreeTableRow
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TreeTableRow in javafx.scene.control

      Methods in javafx.scene.control that return TreeTableRow
      Modifier and Type | 方法 | 描述
      TreeTableRow<S> | TreeTableCell.getTreeTableRow​()
      Methods in javafx.scene.control that return types with arguments of type TreeTableRow
      Modifier and Type | 方法 | 描述
      Callback<TreeTableView<S>,TreeTableRow<S>> TreeTableView.getRowFactory​()
      获取属性rowFactory的值。
      ObjectProperty<Callback<TreeTableView<S>,TreeTableRow<S>>> TreeTableView.rowFactoryProperty​()
      一个生成TreeTableRow的函数。
      ReadOnlyObjectProperty<TreeTableRow<S>> | TreeTableCell.tableRowProperty​()
      Methods in javafx.scene.control with parameters of type TreeTableRow
      Modifier and Type 方法 描述
      void TreeTableCell.updateTreeTableRow​(TreeTableRow<S> treeTableRow)
      更新与此TreeTableCell关联的TreeTableRow。
      Method parameters in javafx.scene.control with type arguments of type TreeTableRow
      Modifier and Type 方法 描述
      void TreeTableView.setRowFactory​(Callback<TreeTableView<S>,TreeTableRow<S>> value)
      设置属性rowFactory的值。

    • Uses of TreeTableRow in javafx.scene.control.skin

      Methods in javafx.scene.control.skin with parameters of type TreeTableRow
      Modifier and Type 方法 描述
      protected void TreeTableRowSkin.updateCell​(TreeTableCell<T,?> cell, TreeTableRow<T> row)
      允许给定单元格被告知它是给定行的成员的方法。
      Constructors in javafx.scene.control.skin with parameters of type TreeTableRow
      Constructor 描述
      TreeTableRowSkin​(TreeTableRow<T> control)
      创建一个新的TreeTableRowSkin实例，将必需的子节点安装到控件 children列表中，以及处理密钥，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableView

  • Packages that use TreeTableView
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TreeTableView in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type TreeTableView
      Modifier and Type Field 描述
      static Callback<TreeTableView,Boolean> TreeTableView.DEFAULT_SORT_POLICY
      如果没有指定其他策略，则该TreeTableView将使用默认值 sort policy 。
      Methods in javafx.scene.control that return TreeTableView
      Modifier and Type 方法 描述
      TreeTableView<S> TreeTableView.EditEvent.getSource​()
      返回发生编辑的TreeTableView。
      TreeTableView<S> TreeTableView.ResizeFeatures.getTable​()
      返回在其上进行调整大小操作的TreeTableView。
      TreeTableView<S> TreeTableCell.getTreeTableView​()
      获取属性treeTableView的值。
      TreeTableView<S> TreeTableColumn.CellDataFeatures.getTreeTableView​()
      返回传递给构造函数的TableView 。
      TreeTableView<S> TreeTableColumn.CellEditEvent.getTreeTableView​()
      返回发生此事件的TableView。
      TreeTableView<S> TreeTableColumn.getTreeTableView​()
      获取属性treeTableView的值。
      TreeTableView<S> TreeTablePosition.getTreeTableView​()
      TreeTablePosition与此TreeTablePosition相关。
      TreeTableView<T> TreeTableRow.getTreeTableView​()
      返回与此TreeTableCell关联的TreeTableView。
      TreeTableView<S> TreeTableView.TreeTableViewSelectionModel.getTreeTableView​()
      返回安装此选择模型的TreeTableView实例。
      Methods in javafx.scene.control that return types with arguments of type TreeTableView
      Modifier and Type 方法 描述
      EventHandler<SortEvent<TreeTableView<S>>> TreeTableView.getOnSort​()
      获取属性onSort的值。
      Callback<TreeTableView<S>,TreeTableRow<S>> TreeTableView.getRowFactory​()
      获取属性rowFactory的值。
      Callback<TreeTableView<S>,Boolean> TreeTableView.getSortPolicy​()
      获取属性sortPolicy的值。
      ObjectProperty<EventHandler<SortEvent<TreeTableView<S>>>> TreeTableView.onSortProperty​()
      当有请求排序控件时调用。
      ObjectProperty<Callback<TreeTableView<S>,TreeTableRow<S>>> TreeTableView.rowFactoryProperty​()
      一个生成TreeTableRow的函数。
      ObjectProperty<Callback<TreeTableView<S>,Boolean>> TreeTableView.sortPolicyProperty​()
      排序策略指定如何执行此TreeTableView中的排序。
      ReadOnlyObjectProperty<TreeTableView<S>> TreeTableCell.treeTableViewProperty​()
      与此TreeTableCell关联的TreeTableView。
      ReadOnlyObjectProperty<TreeTableView<S>> TreeTableColumn.treeTableViewProperty​()
      TreeTableColumn属于的TreeTableView。
      ReadOnlyObjectProperty<TreeTableView<T>> TreeTableRow.treeTableViewProperty​()
      TreeTableCell显式链接到一个TreeTableView实例，由该属性表示。
      Methods in javafx.scene.control with parameters of type TreeTableView
      Modifier and Type 方法 描述
      void TreeTableCell.updateTreeTableView​(TreeTableView<S> tv)
      更新与此TreeTableCell关联的TreeTableView。
      void TreeTableRow.updateTreeTableView​(TreeTableView<T> treeTable)
      更新与此TreeTableCell关联的TreeTableView。
      Method parameters in javafx.scene.control with type arguments of type TreeTableView
      Modifier and Type 方法 描述
      void TreeTableView.setOnSort​(EventHandler<SortEvent<TreeTableView<S>>> value)
      设置属性onSort的值。
      void TreeTableView.setRowFactory​(Callback<TreeTableView<S>,TreeTableRow<S>> value)
      设置属性rowFactory的值。
      void TreeTableView.setSortPolicy​(Callback<TreeTableView<S>,Boolean> callback)
      设置属性sortPolicy的值。
      Constructors in javafx.scene.control with parameters of type TreeTableView
      Constructor 描述
      CellDataFeatures​(TreeTableView<S> treeTableView, TreeTableColumn<S,T> tableColumn, TreeItem<S> value)
      实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。
      CellEditEvent​(TreeTableView<S> table, TreeTablePosition<S,T> pos, EventType<TreeTableColumn.CellEditEvent<S,T>> eventType, T newValue)
      创建一个可以随后向相关听众触发的新事件。
      EditEvent​(TreeTableView<S> source, EventType<? extends TreeTableView.EditEvent> eventType, TreeItem<S> treeItem, S oldValue, S newValue)
      创建一个新的EditEvent实例来表示编辑事件。
      ResizeFeatures​(TreeTableView<S> treeTable, TreeTableColumn<S,?> column, Double delta)
      创建此类的实例，提供的TreeTableView，TreeTableColumn和delta值被设置并存储在此不可变实例中。
      TreeTablePosition​(TreeTableView<S> treeTableView, int row, TreeTableColumn<S,T> tableColumn)
      构造一个TreeTablePosition实例来表示给定TreeTableView实例中给定的行/列位置。
      TreeTableViewFocusModel​(TreeTableView<S> treeTableView)
      创建一个默认的TableViewFocusModel实例，用于管理提供的TableView控件的焦点。
      TreeTableViewSelectionModel​(TreeTableView<S> treeTableView)
      使用提供的TreeTableView构建一个默认的TreeTableViewSelectionModel实例。

    • Uses of TreeTableView in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type TreeTableView
      Constructor 描述
      TreeTableViewSkin​(TreeTableView<T> control)
      创建一个新的TreeTableViewSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableView.EditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableView.EditEvent

  • Packages that use TreeTableView.EditEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeTableView.EditEvent in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type TreeTableView.EditEvent
      Modifier and Type 方法 描述
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editCancelEvent​()
      EventType用于指示事件被触发的TreeTableView中刚刚取消了编辑事件。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editCommitEvent​()
      用于指示TreeTableView中的编辑已提交的EventType。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editStartEvent​()
      EventType用于指示在触发事件的TreeTableView中启动了编辑事件。
      Constructor parameters in javafx.scene.control with type arguments of type TreeTableView.EditEvent
      Constructor 描述
      EditEvent​(TreeTableView<S> source, EventType<? extends TreeTableView.EditEvent> eventType, TreeItem<S> treeItem, S oldValue, S newValue)
      创建一个新的EditEvent实例来表示编辑事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableView.ResizeFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableView.ResizeFeatures

  • Packages that use TreeTableView.ResizeFeatures
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeTableView.ResizeFeatures in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type TreeTableView.ResizeFeatures
      Modifier and Type Field 描述
      static Callback<TreeTableView.ResizeFeatures,Boolean> TreeTableView.CONSTRAINED_RESIZE_POLICY
      确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。
      static Callback<TreeTableView.ResizeFeatures,Boolean> TreeTableView.UNCONSTRAINED_RESIZE_POLICY
      非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。
      Methods in javafx.scene.control that return types with arguments of type TreeTableView.ResizeFeatures
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TreeTableView.ResizeFeatures,Boolean>> TreeTableView.columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      Callback<TreeTableView.ResizeFeatures,Boolean> TreeTableView.getColumnResizePolicy​()
      获取属性columnResizePolicy的值。
      Method parameters in javafx.scene.control with type arguments of type TreeTableView.ResizeFeatures
      Modifier and Type 方法 描述
      void TreeTableView.setColumnResizePolicy​(Callback<TreeTableView.ResizeFeatures,Boolean> callback)
      设置属性columnResizePolicy的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableView.TreeTableViewFocusModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableView.TreeTableViewFocusModel

  • Packages that use TreeTableView.TreeTableViewFocusModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeTableView.TreeTableViewFocusModel in javafx.scene.control

      Methods in javafx.scene.control that return TreeTableView.TreeTableViewFocusModel
      Modifier and Type 方法 描述
      TreeTableView.TreeTableViewFocusModel<S> TreeTableView.getFocusModel​()
      返回当前安装的FocusModel 。
      Methods in javafx.scene.control that return types with arguments of type TreeTableView.TreeTableViewFocusModel
      Modifier and Type 方法 描述
      ObjectProperty<TreeTableView.TreeTableViewFocusModel<S>> TreeTableView.focusModelProperty​()
      FocusModel提供API，通过它可以将焦点控制在零或一行TreeTableView上。
      Methods in javafx.scene.control with parameters of type TreeTableView.TreeTableViewFocusModel
      Modifier and Type 方法 描述
      void TreeTableView.setFocusModel​(TreeTableView.TreeTableViewFocusModel<S> value)
      设置要在TreeTableView中使用的FocusModel 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeTableView.TreeTableViewSelectionModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeTableView.TreeTableViewSelectionModel

  • Packages that use TreeTableView.TreeTableViewSelectionModel
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeTableView.TreeTableViewSelectionModel in javafx.scene.control

      Methods in javafx.scene.control that return TreeTableView.TreeTableViewSelectionModel
      Modifier and Type 方法 描述
      TreeTableView.TreeTableViewSelectionModel<S> TreeTableView.getSelectionModel​()
      返回当前安装的选择模型。
      Methods in javafx.scene.control that return types with arguments of type TreeTableView.TreeTableViewSelectionModel
      Modifier and Type 方法 描述
      ObjectProperty<TreeTableView.TreeTableViewSelectionModel<S>> TreeTableView.selectionModelProperty​()
      SelectionModel提供了可以在TreeTableView中选择单个或多个项目的API，以及检查用户选择了哪些行。
      Methods in javafx.scene.control with parameters of type TreeTableView.TreeTableViewSelectionModel
      Modifier and Type 方法 描述
      void TreeTableView.setSelectionModel​(TreeTableView.TreeTableViewSelectionModel<S> value)
      设置要在TreeTableView中使用的MultipleSelectionModel 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeView

  • Packages that use TreeView
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TreeView in javafx.scene.control

      Methods in javafx.scene.control that return TreeView
      Modifier and Type 方法 描述
      TreeView<T> TreeView.EditEvent.getSource​()
      返回发生编辑的TreeView。
      TreeView<T> TreeCell.getTreeView​()
      返回与此TreeCell关联的TreeView。
      Methods in javafx.scene.control that return types with arguments of type TreeView
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TreeView<T>,TreeCell<T>>> TreeView.cellFactoryProperty​()
      表示将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
      Callback<TreeView<T>,TreeCell<T>> TreeView.getCellFactory​()
      返回用于创建TreeCells的单元格工厂，用于表示TreeView中的项目，如果未设置自定义单元格工厂，则返回null。
      ReadOnlyObjectProperty<TreeView<T>> TreeCell.treeViewProperty​()
      TreeCell显式链接到一个TreeView实例，由该属性表示。
      Methods in javafx.scene.control with parameters of type TreeView
      Modifier and Type 方法 描述
      void TreeCell.updateTreeView​(TreeView<T> tree)
      更新与TreeCell相关联的TreeView。
      Method parameters in javafx.scene.control with type arguments of type TreeView
      Modifier and Type 方法 描述
      void TreeView.setCellFactory​(Callback<TreeView<T>,TreeCell<T>> value)
      设置将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
      Constructors in javafx.scene.control with parameters of type TreeView
      Constructor 描述
      EditEvent​(TreeView<T> source, EventType<? extends TreeView.EditEvent> eventType, TreeItem<T> treeItem, T oldValue, T newValue)
      创建一个新的EditEvent实例来表示编辑事件。

    • Uses of TreeView in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return types with arguments of type TreeView
      Modifier and Type 方法 描述
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​()
      创建用于TreeView控件的单元格工厂，尽管在TreeView中使用时有一个主要假设：此单元格工厂假定TreeView根和所有子项都是CheckBoxTreeItem的实例，而不是正常使用的默认值为TreeItem的类。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(T... items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(T... items)
      创建ComboBox单元格工厂用于TreeView控件。
      static Callback<TreeView<String>,TreeCell<String>> TextFieldTreeCell.forTreeView​()
      提供TextField ，允许在双击单元格时调用单元格内容，或调用edit(javafx.scene.control.TreeItem)时。
      static <T> Callback<TreeView<T>,TreeCell<T>> TextFieldTreeCell.forTreeView​(StringConverter<T> converter)
      提供TextField ，使单元格内容的编辑在小区双击，或者当edit(javafx.scene.control.TreeItem)被调用。

    • Uses of TreeView in javafx.scene.control.skin

      Constructors in javafx.scene.control.skin with parameters of type TreeView
      Constructor 描述
      TreeViewSkin​(TreeView control)
      Creates a new TreeViewSkin instance, installing the necessary child nodes into the Control children list, as well as the necessary input mappings for handling key, mouse, etc events.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.TreeView.EditEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.TreeView.EditEvent

  • Packages that use TreeView.EditEvent
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TreeView.EditEvent in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type TreeView.EditEvent
      Modifier and Type 方法 描述
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editCancelEvent​()
      EventType用于指示事件被触发的TreeView中刚刚取消了编辑事件。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editCommitEvent​()
      用于指示TreeView中的编辑已提交的EventType。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editStartEvent​()
      EventType用于指示在事件触发的TreeView中启动了编辑事件。
      EventHandler<TreeView.EditEvent<T>> TreeView.getOnEditCancel​()
      返回当用户取消编辑时将被调用的EventHandler 。
      EventHandler<TreeView.EditEvent<T>> TreeView.getOnEditCommit​()
      返回当用户提交编辑时将被调用的EventHandler 。
      EventHandler<TreeView.EditEvent<T>> TreeView.getOnEditStart​()
      返回当用户开始编辑时将被调用的EventHandler 。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> TreeView.onEditCancelProperty​()
      当用户取消编辑单元格时，将触发此事件处理程序。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> TreeView.onEditCommitProperty​()
      当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
      ObjectProperty<EventHandler<TreeView.EditEvent<T>>> TreeView.onEditStartProperty​()
      当用户成功启动编辑时，会触发此事件处理程序。
      Method parameters in javafx.scene.control with type arguments of type TreeView.EditEvent
      Modifier and Type 方法 描述
      void TreeView.setOnEditCancel​(EventHandler<TreeView.EditEvent<T>> value)
      设置当用户取消编辑时将被调用的EventHandler 。
      void TreeView.setOnEditCommit​(EventHandler<TreeView.EditEvent<T>> value)
      设置当用户提交编辑时将被调用的EventHandler 。
      void TreeView.setOnEditStart​(EventHandler<TreeView.EditEvent<T>> value)
      设置当用户开始编辑时将被调用的EventHandler 。
      Constructor parameters in javafx.scene.control with type arguments of type TreeView.EditEvent
      Constructor 描述
      EditEvent​(TreeView<T> source, EventType<? extends TreeView.EditEvent> eventType, TreeItem<T> treeItem, T oldValue, T newValue)
      创建一个新的EditEvent实例来表示编辑事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.scene.control.Skin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.scene.control.Skin

  • Packages that use Skin
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of Skin in javafx.scene.control

      Classes in javafx.scene.control that implement Skin
      Modifier and Type Class 描述
      class  SkinBase<C extends Control>
      基本实现类，用于通过定义节点的场景图来定义用户界面控件的可视化表示，以表示skin 。
      Methods in javafx.scene.control that return Skin
      Modifier and Type 方法 描述
      protected Skin<?> Accordion.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> Button.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ButtonBar.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> CheckBox.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ChoiceBox.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ColorPicker.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ComboBox.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ContextMenu.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> Control.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> DateCell.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> DatePicker.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> Hyperlink.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> Label.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ListCell.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ListView.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> MenuBar.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> MenuButton.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> Pagination.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> PopupControl.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ProgressBar.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ProgressIndicator.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> RadioButton.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ScrollBar.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ScrollPane.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> Separator.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> Slider.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> Spinner.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> SplitMenuButton.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> SplitPane.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TableCell.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TableRow.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TableView.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TabPane.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TextArea.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TextField.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TitledPane.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ToggleButton.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> ToolBar.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> Tooltip.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TreeCell.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TreeTableCell.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TreeTableRow.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TreeTableView.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      protected Skin<?> TreeView.createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      Skin<?> Control.getSkin​()
      获取属性皮肤的值。
      Skin<?> PopupControl.getSkin​()
      获取属性皮肤的值。
      Skin<?> Skinnable.getSkin​()
      返回呈现Control的皮肤
      Methods in javafx.scene.control that return types with arguments of type Skin
      Modifier and Type 方法 描述
      ObjectProperty<Skin<?>> Control.skinProperty​()
      皮肤负责渲染这个 Control 。
      ObjectProperty<Skin<?>> PopupControl.skinProperty​()
      皮肤负责渲染这个 PopupControl 。
      ObjectProperty<Skin<?>> Skinnable.skinProperty​()
      皮肤负责渲染这个 Control 。
      Methods in javafx.scene.control with parameters of type Skin
      Modifier and Type 方法 描述
      void Control.setSkin​(Skin<?> value)
      设置属性皮肤的值。
      void PopupControl.setSkin​(Skin<?> value)
      设置属性皮肤的值。
      void Skinnable.setSkin​(Skin<?> value)
      设置将呈现Control的皮肤

    • Uses of Skin in javafx.scene.control.skin

      Classes in javafx.scene.control.skin that implement Skin
      Modifier and Type Class 描述
      class  AccordionSkin
      默认皮肤实现为Accordion控件。
      class  ButtonBarSkin
      默认皮肤实现为ButtonBar控件。
      class  ButtonSkin
      默认皮肤实现为Button控件。
      class  CellSkinBase<C extends Cell>
      默认皮肤的实施为Cell控制和子类，如ListCell ， TreeCell ，等等。
      class  CheckBoxSkin
      默认皮肤实现为三态CheckBox控件。
      class  ChoiceBoxSkin<T>
      默认皮肤实现为ChoiceBox控件。
      class  ColorPickerSkin
      默认皮肤实现为ColorPicker控件。
      class  ComboBoxBaseSkin<T>
      一个抽象类，旨在用作基于ComboBoxBase的 ComboBox类控件的基础外观 。
      class  ComboBoxListViewSkin<T>
      默认皮肤实现为ComboBox控件。
      class  ComboBoxPopupControl<T>
      一个抽象类，扩展了ComboBoxBaseSkin的功能，以包含与显示ComboBox类控件作为弹出窗口相关的API。
      class  ContextMenuSkin
      ContextMenu的默认皮肤实现。
      class  DateCellSkin
      默认皮肤实现为DateCell控件。
      class  DatePickerSkin
      默认皮肤实现为DatePicker控件。
      class  HyperlinkSkin
      默认皮肤实现为Hyperlink控件。
      class  LabeledSkinBase<C extends Labeled>
      控件的默认皮肤实现扩展为Labeled 。
      class  LabelSkin
      默认皮肤实现为Label控件。
      class  ListCellSkin<T>
      默认皮肤实现为ListCell控件。
      class  ListViewSkin<T>
      默认皮肤实现为ListView控件。
      class  MenuBarSkin
      默认皮肤实现为MenuBar控件。
      class  MenuButtonSkin
      默认皮肤实现为MenuButton控件。
      class  MenuButtonSkinBase<C extends MenuButton>
      MenuButtonSkin和SplitMenuButtonSkin的基类。
      class  PaginationSkin
      默认皮肤实现为Pagination控件。
      class  ProgressBarSkin
      ProgressBar控件的默认皮肤实现。
      class  ProgressIndicatorSkin
      默认皮肤实现为ProgressIndicator控件。
      class  RadioButtonSkin
      默认皮肤实现为RadioButton控件。
      class  ScrollBarSkin
      ScrollBar控件的默认皮肤实现。
      class  ScrollPaneSkin
      默认皮肤实现为ScrollPane控件。
      class  SeparatorSkin
      Separator控件的默认皮肤实现。
      class  SliderSkin
      默认皮肤实现为Slider控件。
      class  SpinnerSkin<T>
      默认皮肤实现为Spinner控件。
      class  SplitMenuButtonSkin
      默认皮肤实现为SplitMenuButton控件。
      class  SplitPaneSkin
      默认皮肤实现为SplitPane控件。
      class  TableCellSkin<S,T>
      TableCell控件的默认皮肤实现。
      class  TableCellSkinBase<S,T,C extends IndexedCell<T>>
      表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。
      class  TableRowSkin<T>
      默认皮肤实现为TableRow控件。
      class  TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>
      TableRowSkinBase是由TableRow和TreeTableRow等控件使用的基础皮肤类（具体类别分别为TableRowSkin和TreeTableRowSkin ）。
      class  TableViewSkin<T>
      默认皮肤实现为TableView控件。
      class  TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>
      TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。
      class  TabPaneSkin
      默认皮肤实现为TabPane控件。
      class  TextAreaSkin
      TextArea控件的默认皮肤实现。
      class  TextFieldSkin
      默认皮肤实现为TextField控件。
      class  TextInputControlSkin<T extends TextInputControl>
      文本输入皮肤的抽象基类。
      class  TitledPaneSkin
      默认皮肤实现为TitledPane控件。
      class  ToggleButtonSkin
      默认皮肤实现为ToggleButton控件。
      class  ToolBarSkin
      默认皮肤实现为ToolBar控件。
      class  TooltipSkin
      基于CSS的皮肤为Tooltip。
      class  TreeCellSkin<T>
      TreeCell控件的默认皮肤实现。
      class  TreeTableCellSkin<S,T>
      默认皮肤实现为TreeTableCell控件。
      class  TreeTableRowSkin<T>
      默认皮肤实现为TreeTableRow控件。
      class  TreeTableViewSkin<T>
      默认皮肤实现为TreeTableView控件。
      class  TreeViewSkin<T>
      默认皮肤实现为TreeView控件。
      class  VirtualContainerBase<C extends Control,I extends IndexedCell>
      父类控制其内容虚拟化和可滚动的外观。

    • Uses of Skin in javafx.scene.web

      Classes in javafx.scene.web that implement Skin
      Modifier and Type Class 描述
      class  HTMLEditorSkin
      HTML编辑器皮肤。
      Methods in javafx.scene.web that return Skin
      Modifier and Type | 方法 | 描述
      protected Skin<?> | HTMLEditor.createDefaultSkin​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.scene.control.Skinnable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.scene.control.Skinnable

  • Packages that use Skinnable
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of Skinnable in javafx.scene.control

      Classes in javafx.scene.control with type parameters of type Skinnable
      Modifier and Type 接口 描述
      interface  Skin<C extends Skinnable>
      基类通过定义节点的场景图来定义用户界面控件的视觉表示，以表示皮肤。
      Classes in javafx.scene.control that implement Skinnable
      Modifier and Type Class 描述
      class  Accordion
      手风琴是一组TitlePanes 。
      class  Button
      一个简单的按钮控件。
      class  ButtonBar
      ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。
      class  ButtonBase
      按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
      class  Cell<T>
      细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
      class  CheckBox
      三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
      class  ChoiceBox<T>
      ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
      class  ColorPicker
      ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
      class  ComboBox<T>
      针对最常见形式的ComboBox的ComboBoxBase抽象类的实现，向用户提供弹出列表，以提供他们可以选择的选项。
      class  ComboBoxBase<T>
      ComboBox类控件的抽象基类。
      class  ContextMenu
      一个包含菜单项的ObservableList的弹出控件。
      class  Control
      所有用户界面控件的基类。
      class  DateCell
      DateCell由DatePicker用于在日历月中呈现单个网格单元格。
      class  DatePicker
      DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
      class  Hyperlink
      一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
      class  IndexedCell<T>
      一个Cell的实现，它包含一个索引属性，它映射到可视化的底层的数据模型中。
      class  Label
      标签是不可编辑的文本控件。
      class  Labeled
      标签的Control是其用户界面的一部分，与其相关联的文本内容。
      class  ListCell<T>
      Cell类型在ListView实例中使用。
      class  ListView<T>
      ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
      class  MenuBar
      MenuBar控件传统上放置在用户界面的最上方，嵌入在其中是Menus 。
      class  MenuButton
      MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
      class  Pagination
      分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
      class  PasswordField
      掩码输入字符的文本字段。
      class  PopupControl
      PopupWindow的扩展，允许CSS样式。
      class  ProgressBar
      ProgressIndator的专业化表示为横杠。
      class  ProgressIndicator
      用于指示进度的循环控制，无限（也称为不确定）或有限。
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  ScrollBar
      具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。
      class  ScrollPane
      提供其内容的滚动，剪切视口的控件。
      class  Separator
      水平或垂直分隔线。
      class  Slider
      滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。
      class  Spinner<T>
      单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。
      class  SplitMenuButton
      SplitMenuButton，像MenuButton与从菜单中选择一个MenuItem的概念密切相关。
      class  SplitPane
      具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
      class  TableCell<S,T>
      在TableView中表示单行/列交集。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TableView<S>
      TableView控件旨在可视化无限数量的数据行，分为列。
      class  TabPane
      允许在一组Tabs之间切换的控件 。
      class  TextArea
      文本输入组件，允许用户输入多行纯文本。
      class  TextField
      文本输入组件，允许用户输入一行未格式化的文本。
      class  TextInputControl
      文本输入控件的抽象基类。
      class  TitledPane
      TitledPane是一个可以打开和关闭的标题的面板。
      class  ToggleButton
      A ToggleButton是具有选择能力的专业控制。
      class  ToolBar
      ToolBar是一个可以水平或垂直显示项目的控件。
      class  Tooltip
      工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
      class  TreeTableView<S>
      TreeTableView控件旨在可视化无限数量的数据行，分为列。
      class  TreeView<T>
      TreeView控件提供了一个到根的视图（类型为TreeItem ）。

    • Uses of Skinnable in javafx.scene.control.cell

      Classes in javafx.scene.control.cell that implement Skinnable
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含ListCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格中绘制一个CheckBox节点，可选地带有一个标签，表示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个包含TreeCell实现的类，在单元格内绘制一个CheckBox节点，并支持常见的交互（ 稍后更详细地讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含TableCell实现的类，在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含ListCell实现的类，在单元格内绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含一个TableCell实现的类，它在单元格中绘制一个ComboBox节点。
      class  ComboBoxTreeCell<T>
      一个包含TreeCell实现的类，它在单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，该单元在单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含TableCell实现的类，在该单元格内绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含TreeTableCell实现的类，在单元格中绘制一个ProgressBar节点。
      class  TextFieldListCell<T>
      一个包含一个ListCell实现的类，它在单元格中绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个包含TreeCell实现的类，在单元格内绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含TableCell实现的类，它在单元格内绘制一个TextField节点。

    • Uses of Skinnable in javafx.scene.web

      Classes in javafx.scene.web that implement Skinnable
      Modifier and Type Class 描述
      class  HTMLEditor
      允许用户编辑文本并将样式应用于此文本的控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.scene.control.TextInputControl.Content (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.scene.control.TextInputControl.Content

  • Packages that use TextInputControl.Content
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of TextInputControl.Content in javafx.scene.control

      Methods in javafx.scene.control that return TextInputControl.Content
      Modifier and Type 方法 描述
      protected TextInputControl.Content TextInputControl.getContent​()
      返回文本输入的内容模型。
      Constructors in javafx.scene.control with parameters of type TextInputControl.Content
      Constructor 描述
      TextInputControl​(TextInputControl.Content content)
      创建一个新的TextInputControl。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.scene.control.Toggle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.scene.control.Toggle

  • Packages that use Toggle
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

    • Uses of Toggle in javafx.scene.control

      Classes in javafx.scene.control that implement Toggle
      Modifier and Type Class 描述
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  RadioMenuItem
      RadioMenuItem是一个MenuItem可以切换（它使用Toggle mixin）。
      class  ToggleButton
      A ToggleButton是一种具有选择能力的专业控制。
      Methods in javafx.scene.control that return Toggle
      Modifier and Type 方法 描述
      Toggle ToggleGroup.getSelectedToggle​()
      获取所选的 Toggle 。
      Methods in javafx.scene.control that return types with arguments of type Toggle
      Modifier and Type 方法 描述
      ObservableList<Toggle> ToggleGroup.getToggles​()
      ToggleGroup中的切换列表。
      ReadOnlyObjectProperty<Toggle> ToggleGroup.selectedToggleProperty​()
      所选的切换。
      Methods in javafx.scene.control with parameters of type Toggle
      Modifier and Type 方法 描述
      void ToggleGroup.selectToggle​(Toggle value)
      选择切换。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AccordionSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class AccordionSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<Accordion>
      • javafx.scene.control.skin.AccordionSkin
  • All Implemented Interfaces:
    Skin<Accordion>

    public class AccordionSkin
extends SkinBase<Accordion>
    默认皮肤实现为Accordion控件。
    从以下版本开始：
    9
    另请参见：
    Accordion

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccordionSkin​(Accordion control)
      创建一个新的AccordionSkin实例，将必要的子节点安装到控件 children列表中，以及处理键盘，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinWidth, computePrefWidth, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • AccordionSkin

        public AccordionSkin​(Accordion control)
        创建一个新的AccordionSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用之后 ，方法Skin.getSkinnable()和Skin.getNode()应该返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<Accordion>
        重写：
        dispose在 SkinBase<Accordion>

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<Accordion>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素啪嗒的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<Accordion>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<Accordion>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ButtonBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ButtonBarSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<ButtonBar>
      • javafx.scene.control.skin.ButtonBarSkin
  • All Implemented Interfaces:
    Skin<ButtonBar>

    public class ButtonBarSkin
extends SkinBase<ButtonBar>
    默认皮肤实现为ButtonBar控件。
    从以下版本开始：
    9
    另请参见：
    ButtonBar

    • 构造方法摘要

      构造方法
      Constructor 描述
      ButtonBarSkin​(ButtonBar control)
      创建一个新的ButtonBarSkin实例，将必需的子节点安装到控件 children列表中。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutChildren, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ButtonBarSkin

        public ButtonBarSkin​(ButtonBar control)
        创建一个新的ButtonBarSkin实例，将必需的子节点安装到控件 children列表中。
        参数
        control - The control that this skin should be installed onto.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ButtonSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<Button>
        • javafx.scene.control.skin.ButtonSkin
  • All Implemented Interfaces:
    Skin<C>

    public class ButtonSkin
extends LabeledSkinBase<Button>
    默认皮肤实现为Button控件。
    从以下版本开始：
    9
    另请参见：
    Button

    • 构造方法摘要

      构造方法
      Constructor 描述
      ButtonSkin​(Button control)
      创建一个新的ButtonSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, layoutChildren, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ButtonSkin

        public ButtonSkin​(Button control)
        创建一个新的ButtonSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends Labeled>
        重写：
        dispose在 SkinBase<Button>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CellSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class CellSkinBase<C extends Cell>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<C>
  • All Implemented Interfaces:
    Skin<C>
    已知直接子类：
    DateCellSkin ， ListCellSkin ， TableCellSkinBase ， TableRowSkinBase ， TreeCellSkin

    public class CellSkinBase<C extends Cell>
extends LabeledSkinBase<C>
    默认皮肤的实施为Cell控制和子类，如ListCell ， TreeCell ，等等。
    从以下版本开始：
    9
    另请参见：
    Cell

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyDoubleProperty cellSize
      默认单元格大小。

    • 构造方法摘要

      构造方法
      Constructor 描述
      CellSkinBase​(C control)
      创建一个新的CellSkinBase实例，将必要的子节点安装到控件 children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyDoubleProperty cellSizeProperty​()
      默认单元格大小。
      double getCellSize​()
      获取属性cellSize的值。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, layoutChildren, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • Property Detail

      • cellSize

        public final ReadOnlyDoubleProperty cellSizeProperty
        默认单元格大小。 对于垂直ListView或TreeView或TableView这是高度，对于一个水平ListView这是宽度。 这可以从CSS设置
        另请参见：
        getCellSize()

    • 构造方法详细信息

      • CellSkinBase

        public CellSkinBase​(C control)
        创建一个新的CellSkinBase实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • getCellSize

        public final double getCellSize​()
        获取属性cellSize的值。
        Property description:
        默认单元格大小。 对于垂直ListView或TreeView或TableView这是高度，对于一个水平ListView这是宽度。 这可以从CSS设置

      • cellSizeProperty

        public final ReadOnlyDoubleProperty cellSizeProperty​()
        默认单元格大小。 对于垂直ListView或TreeView或TableView这是高度，对于一个水平ListView这是宽度。 这可以从CSS设置
        另请参见：
        getCellSize()

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 SkinBase<C extends Cell>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CheckBoxSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class CheckBoxSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<CheckBox>
        • javafx.scene.control.skin.CheckBoxSkin
  • All Implemented Interfaces:
    Skin<C>

    public class CheckBoxSkin
extends LabeledSkinBase<CheckBox>
    默认皮肤实现为三态CheckBox控件。
    从以下版本开始：
    9
    另请参见：
    CheckBox

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckBoxSkin​(CheckBox control)
      创建一个新的CheckBoxSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算并返回此Labeled的最小宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
      protected void updateChildren​()
      更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • CheckBoxSkin

        public CheckBoxSkin​(CheckBox control)
        创建一个新的CheckBoxSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose接口 Skin<C extends Labeled>
        重写：
        dispose在 SkinBase<CheckBox>

      • updateChildren

        protected void updateChildren​()
        更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。 仅使用实际必须使用的那些节点。 例如，使用GRAPHIC_ONLY的ContentDisplay不添加文本节点，并且使用TEXT_ONLY的ContentDisplay，不会添加图形。
        重写：
        updateChildren在 LabeledSkinBase<CheckBox>

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        计算并返回此Labeled的最小宽度。 最小宽度是“...”宽度的较小值，带有实际文本的宽度。 这样，如果文本宽度本身小于省略号，那么我们应该将其用作最小宽度，否则省略号需要是最小宽度。

        我们在这里使用相同的计算方法，无论我们在谈论单个或多个标签。 所以一个多行的标签可能会发现，“...”的宽度与它将会得到的一样小。

        重写：
        computeMinWidth在 LabeledSkinBase<CheckBox>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 LabeledSkinBase<CheckBox>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 LabeledSkinBase<CheckBox>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 LabeledSkinBase<CheckBox>
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
        重写：
        layoutChildren在 LabeledSkinBase<CheckBox>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ChoiceBoxSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ChoiceBoxSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<ChoiceBox<T>>
      • javafx.scene.control.skin.ChoiceBoxSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class ChoiceBoxSkin<T>
extends SkinBase<ChoiceBox<T>>
    默认皮肤实现为ChoiceBox控件。
    从以下版本开始：
    9
    另请参见：
    ChoiceBox

    • 构造方法摘要

      构造方法
      Constructor 描述
      ChoiceBoxSkin​(ChoiceBox<T> control)
      创建一个新的ChoiceBoxSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ChoiceBoxSkin

        public ChoiceBoxSkin​(ChoiceBox<T> control)
        创建一个新的ChoiceBoxSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 SkinBase<ChoiceBox<T>>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<ChoiceBox<T>>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<ChoiceBox<T>>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<ChoiceBox<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<ChoiceBox<T>>
        参数
        height - 如果首选宽度取决于它应该使用的高度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<ChoiceBox<T>>
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<ChoiceBox<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 SkinBase<ChoiceBox<T>>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ColorPickerSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ColorPickerSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<ComboBoxBase<T>>
      • javafx.scene.control.skin.ComboBoxBaseSkin<T>
        • javafx.scene.control.skin.ComboBoxPopupControl<Color>
          • javafx.scene.control.skin.ColorPickerSkin
  • All Implemented Interfaces:
    Skin<ComboBoxBase<T>>

    public class ColorPickerSkin
extends ComboBoxPopupControl<Color>
    默认皮肤实现为ColorPicker控件。
    从以下版本开始：
    9
    另请参见：
    ColorPicker

    • 构造方法摘要

      构造方法
      Constructor 描述
      ColorPickerSkin​(ColorPicker control)
      创建一个新的ColorPickerSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      protected StringConverter<Color> getConverter​()
      子类负责获取转换器。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      Node getDisplayNode​()
      该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
      protected TextField getEditor​()
      ColorPicker不使用主文本字段，因此此方法已被覆盖以返回null。
      protected Node getPopupContent​()
      此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      void show​()
      当显示ComboBox弹出窗口时，将调用此方法。

      • Methods inherited from class javafx.scene.control.skin.ComboBoxBaseSkin

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computePrefHeight

      • Methods inherited from class javafx.scene.control.skin.ComboBoxPopupControl

        hide

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeMinHeight, computeMinWidth, consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ColorPickerSkin

        public ColorPickerSkin​(ColorPicker control)
        创建一个新的ColorPickerSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用之后 ，方法Skin.getSkinnable()和Skin.getNode()应该返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<ComboBoxBase<T>>
        重写：
        dispose在 SkinBase<ComboBoxBase<Color>>

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 ComboBoxBaseSkin<Color>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • getPopupContent

        protected Node getPopupContent​()
        此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
        Specified by:
        getPopupContent在 ComboBoxPopupControl<Color>
        结果
        当用户单击ComboBox'按钮'区域时将显示的节点

      • show

        public void show​()
        当显示ComboBox弹出窗口时，将调用此方法。 特定的皮肤实现取决于如何处理它。
        重写：
        show在 ComboBoxPopupControl<Color>

      • getDisplayNode

        public Node getDisplayNode​()
        该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
        Specified by:
        getDisplayNode在 ComboBoxBaseSkin<Color>
        结果
        将位于ComboBox“按钮”区域内的节点

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 ComboBoxBaseSkin<Color>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 SkinBase<ComboBoxBase<Color>>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。

      • getConverter

        protected StringConverter<Color> getConverter​()
        子类负责获取转换器。 当转换器属性移动到具有JDK-8130354的ComboBoxBase时，这将在FX 9中删除。
        Specified by:
        getConverter在 ComboBoxPopupControl<Color>
        结果
        字符串转换器

      • getEditor

        protected TextField getEditor​()
        ColorPicker不使用主文本字段，因此此方法已被覆盖以返回null。
        Specified by:
        getEditor在 ComboBoxPopupControl<Color>
        结果
        编辑
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ComboBoxBaseSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ComboBoxBaseSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<ComboBoxBase<T>>
      • javafx.scene.control.skin.ComboBoxBaseSkin<T>
  • 参数类型
    T - 类似ComboBox的控件。
    All Implemented Interfaces:
    Skin<T>
    已知直接子类：
    ComboBoxPopupControl

    public abstract class ComboBoxBaseSkin<T>
extends SkinBase<ComboBoxBase<T>>
    一个抽象类，旨在用作基于ComboBoxBase的 ComboBox类控件的基础外观 。 大多数这个皮肤类的用户也应该看看ComboBoxPopupControl其他有用的API。
    从以下版本开始：
    9
    另请参见：
    ComboBoxBase ， ComboBoxPopupControl

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComboBoxBaseSkin​(ComboBoxBase<T> control)
      创建一个新的ComboBoxBaseSkin实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)
      基于第一个受管理的子节点计算基线偏移量。
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算此 SkinBase的首选宽度。
      abstract Node getDisplayNode​()
      该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
      abstract void hide​()
      当隐藏ComboBox弹出窗口时，将调用此方法。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      abstract void show​()
      当显示ComboBox弹出窗口时，将调用此方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeMinHeight, computeMinWidth, consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ComboBoxBaseSkin

        public ComboBoxBaseSkin​(ComboBoxBase<T> control)
        创建一个新的ComboBoxBaseSkin实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。
        参数
        control - 应该安装这个皮肤的控件。

    • 方法详细信息

      • getDisplayNode

        public abstract Node getDisplayNode​()
        该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
        结果
        将位于ComboBox“按钮”区域内的节点

      • show

        public abstract void show​()
        当显示ComboBox弹出窗口时，将调用此方法。 特定的皮肤实现取决于如何处理它。

      • hide

        public abstract void hide​()
        当隐藏ComboBox弹出窗口时，将调用此方法。 特定的皮肤实现取决于如何处理它。

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<ComboBoxBase<T>>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<ComboBoxBase<T>>
        参数
        height - 如果首选宽度取决于它应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<ComboBoxBase<T>>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 SkinBase<ComboBoxBase<T>>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<ComboBoxBase<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • computeBaselineOffset

        protected double computeBaselineOffset​(double topInset,
                                       double rightInset,
                                       double bottomInset,
                                       double leftInset)
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        computeBaselineOffset在 SkinBase<ComboBoxBase<T>>
        参数
        topInset - 像素啪嗒的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        baseline offset
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ComboBoxListViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ComboBoxListViewSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<ComboBoxBase<T>>
      • javafx.scene.control.skin.ComboBoxBaseSkin<T>
        • javafx.scene.control.skin.ComboBoxPopupControl<T>
          • javafx.scene.control.skin.ComboBoxListViewSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class ComboBoxListViewSkin<T>
extends ComboBoxPopupControl<T>
    默认皮肤实现为ComboBox控件。
    从以下版本开始：
    9
    另请参见：
    ComboBox

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty hideOnClick
      默认情况下，只要点击ListView，该皮肤就会隐藏弹出窗口。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComboBoxListViewSkin​(ComboBox<T> control)
      创建一个新的ComboBoxListViewSkin实例，将必要的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected StringConverter<T> getConverter​()
      子类负责获取转换器。
      Node getDisplayNode​()
      该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
      protected TextField getEditor​()
      子类负责获取编辑器。
      Node getPopupContent​()
      此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
      BooleanProperty hideOnClickProperty​()
      默认情况下，只要点击ListView，该皮肤就会隐藏弹出窗口。
      boolean isHideOnClick​()
      获取属性hideOnClick的值。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setHideOnClick​(boolean value)
      设置属性hideOnClick的值。

      • Methods inherited from class javafx.scene.control.skin.ComboBoxBaseSkin

        computeBaselineOffset

      • Methods inherited from class javafx.scene.control.skin.ComboBoxPopupControl

        hide, show

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • Property Detail

      • hideOnClick

        public final BooleanProperty hideOnClickProperty
        默认情况下，当单击ListView时，该皮肤将隐藏弹出窗口。通过将hideOnClick设置为false，当ListView被点击时，弹出窗口将不会被隐藏。这在某些情况下是有益的（例如，当ListView单元格具有复选框时） 。
        另请参见：
        isHideOnClick() ， setHideOnClick(boolean)

    • 构造方法详细信息

      • ComboBoxListViewSkin

        public ComboBoxListViewSkin​(ComboBox<T> control)
        创建一个新的ComboBoxListViewSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • hideOnClickProperty

        public final BooleanProperty hideOnClickProperty​()
        默认情况下，当单击ListView时，该皮肤将隐藏弹出窗口。通过将hideOnClick设置为false，当ListView被点击时，弹出窗口将不会被隐藏。这在某些情况下是有益的（例如，当ListView单元格具有复选框时） 。
        另请参见：
        isHideOnClick() ， setHideOnClick(boolean)

      • isHideOnClick

        public final boolean isHideOnClick​()
        获取属性hideOnClick的值。
        Property description:
        默认情况下，当单击ListView时，该皮肤将隐藏弹出窗口。通过将hideOnClick设置为false，当ListView被点击时，弹出窗口将不会被隐藏。这在某些情况下是有益的（例如，当ListView单元格具有复选框时） 。

      • setHideOnClick

        public final void setHideOnClick​(boolean value)
        设置属性hideOnClick的值。
        Property description:
        默认情况下，当单击ListView时，该皮肤将隐藏弹出窗口。通过将hideOnClick设置为false，当ListView被点击时，弹出窗口将不会被隐藏。这在某些情况下是有益的（例如，当ListView单元格具有复选框时） 。

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用之后 ，方法Skin.getSkinnable()和Skin.getNode()应该返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 SkinBase<ComboBoxBase<T>>

      • getEditor

        protected TextField getEditor​()
        子类负责获取编辑器。 当编辑器属性使用JDK-8130354移动到ComboBoxBase时，这将在FX 9中删除注意：ComboBoxListViewSkin应该返回null，如果editable为false，即使ComboBox有编辑器设置。
        Specified by:
        getEditor在 ComboBoxPopupControl<T>
        结果
        编辑

      • getConverter

        protected StringConverter<T> getConverter​()
        子类负责获取转换器。 当转换器属性移动到具有JDK-8130354的ComboBoxBase时，这将在FX 9中删除。
        Specified by:
        getConverter在 ComboBoxPopupControl<T>
        结果
        字符串转换器

      • getDisplayNode

        public Node getDisplayNode​()
        该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
        Specified by:
        getDisplayNode在 ComboBoxBaseSkin<T>
        结果
        将位于ComboBox“按钮”区域内的节点

      • getPopupContent

        public Node getPopupContent​()
        此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
        Specified by:
        getPopupContent在 ComboBoxPopupControl<T>
        结果
        当用户单击ComboBox'按钮'区域时将显示的节点

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<ComboBoxBase<T>>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素啪嗒的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 ComboBoxBaseSkin<T>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素啪嗒的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 ComboBoxBaseSkin<T>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<ComboBoxBase<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 ComboBoxBaseSkin<T>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 ComboBoxBaseSkin<T>
        参数
        width - 皮肤的宽度，以防该值可能指定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 ComboBoxBaseSkin<T>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<ComboBoxBase<T>>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ComboBoxPopupControl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ComboBoxPopupControl<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<ComboBoxBase<T>>
      • javafx.scene.control.skin.ComboBoxBaseSkin<T>
        • javafx.scene.control.skin.ComboBoxPopupControl<T>
  • 参数类型
    T - 类似ComboBox的控件。
    All Implemented Interfaces:
    Skin<T>
    已知直接子类：
    ColorPickerSkin ， ComboBoxListViewSkin ， DatePickerSkin

    public abstract class ComboBoxPopupControl<T>
extends ComboBoxBaseSkin<T>
    一个抽象类，扩展了ComboBoxBaseSkin的功能，以包含与显示ComboBox类控件作为弹出窗口相关的API。
    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComboBoxPopupControl​(ComboBoxBase<T> control)
      创建一个新的ComboBoxPopupControl实例，虽然注意到这个实例没有处理任何行为/输入映射 - 这需要被子类适当地处理。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract StringConverter<T> getConverter​()
      子类负责获取转换器。
      protected abstract TextField getEditor​()
      子类负责获取编辑器。
      protected abstract Node getPopupContent​()
      此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
      void hide​()
      当隐藏ComboBox弹出窗口时，将调用此方法。
      void show​()
      当显示ComboBox弹出窗口时，将调用此方法。

      • Methods inherited from class javafx.scene.control.skin.ComboBoxBaseSkin

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computePrefHeight, computePrefWidth, getDisplayNode, layoutChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeMinHeight, computeMinWidth, consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ComboBoxPopupControl

        public ComboBoxPopupControl​(ComboBoxBase<T> control)
        创建一个新的ComboBoxPopupControl实例，虽然注意到这个实例没有处理任何行为/输入映射 - 这需要被子类适当地处理。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • getPopupContent

        protected abstract Node getPopupContent​()
        此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
        结果
        当用户单击ComboBox'按钮'区域时将显示的节点

      • getEditor

        protected abstract TextField getEditor​()
        子类负责获取编辑器。 当编辑器属性使用JDK-8130354移动到ComboBoxBase时，这将在FX 9中删除注意：ComboBoxListViewSkin应该返回null，如果editable为false，即使ComboBox有编辑器设置。
        结果
        编辑

      • getConverter

        protected abstract StringConverter<T> getConverter​()
        子类负责获取转换器。 当转换器属性移动到具有JDK-8130354的ComboBoxBase时，这将在FX 9中删除。
        结果
        字符串转换器

      • show

        public void show​()
        当显示ComboBox弹出窗口时，将调用此方法。 特定的皮肤实现取决于如何处理它。
        Specified by:
        show在 ComboBoxBaseSkin<T>

      • hide

        public void hide​()
        当隐藏ComboBox弹出窗口时，将调用此方法。 特定的皮肤实现取决于如何处理它。
        Specified by:
        hide在 ComboBoxBaseSkin<T>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ContextMenuSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ContextMenuSkin

  • java.lang.Object
    • javafx.scene.control.skin.ContextMenuSkin
  • All Implemented Interfaces:
    Skin<ContextMenu>

    public class ContextMenuSkin
extends Object
implements Skin<ContextMenu>
    ContextMenu的默认皮肤实现。 几个控件使用ContextMenu来显示下拉列表中的项目。 这个课程主要涉及显示/隐藏逻辑 - 上下文菜单的实际内容包含在root node中 。
    从以下版本开始：
    9
    另请参见：
    ContextMenu

    • 构造方法摘要

      构造方法
      Constructor 描述
      ContextMenuSkin​(ContextMenu control)
      创建一个新的ContextMenuSkin实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      Node getNode​()
      获取代表此皮肤的节点。
      ContextMenu getSkinnable​()
      获取此皮肤分配到的Skinnable。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ContextMenuSkin

        public ContextMenuSkin​(ContextMenu control)
        创建一个新的ContextMenuSkin实例。
        参数
        control - 该皮肤应该安装到的控件。

    • 方法详细信息

      • getSkinnable

        public ContextMenu getSkinnable​()
        获取此皮肤分配到的Skinnable。 必须为仅一个Skinnable创建一个皮肤。 当皮肤从Skinnable中删除时，该值将只会从非空值转换为空值，并且仅作为对Skin.dispose()的调用的结果 。

        构建Skinnable的调用者还必须构建一个“皮肤”并正确建立“控件”和“皮肤”之间的关系。

        Specified by:
        getSkinnable在接口 Skin<ContextMenu>
        结果
        非空的Skinnable，如果处理，则为空值。

      • getNode

        public Node getNode​()
        获取代表此皮肤的节点。 除非在调用Skin.dispose()之后 ，除非更改为null，否则绝对不能为空。
        Specified by:
        getNode在接口 Skin<ContextMenu>
        结果
        非空节点，除了皮肤被处理之外。

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<ContextMenu>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DateCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class DateCellSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<DateCell>
          • javafx.scene.control.skin.DateCellSkin
  • All Implemented Interfaces:
    Skin<C>

    public class DateCellSkin
extends CellSkinBase<DateCell>
    默认皮肤实现为DateCell控件。
    从以下版本开始：
    9
    另请参见：
    DateCell

    • Property Summary

      • Properties inherited from class javafx.scene.control.skin.CellSkinBase

        cellSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      DateCellSkin​(DateCell control)
      创建一个新的DateCellSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
      protected void updateChildren​()
      更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

      • Methods inherited from class javafx.scene.control.skin.CellSkinBase

        cellSizeProperty, getCellSize, getClassCssMetaData, getCssMetaData

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • DateCellSkin

        public DateCellSkin​(DateCell control)
        创建一个新的DateCellSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends Labeled>
        重写：
        dispose在 SkinBase<DateCell>

      • updateChildren

        protected void updateChildren​()
        更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。 仅使用实际必须使用的那些节点。 例如，使用GRAPHIC_ONLY的ContentDisplay不添加文本节点，并且使用TEXT_ONLY的ContentDisplay，不会添加图形。
        重写：
        updateChildren在 LabeledSkinBase<DateCell>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
        重写：
        layoutChildren在 LabeledSkinBase<DateCell>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 LabeledSkinBase<DateCell>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 LabeledSkinBase<DateCell>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DatePickerSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class DatePickerSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<ComboBoxBase<T>>
      • javafx.scene.control.skin.ComboBoxBaseSkin<T>
        • javafx.scene.control.skin.ComboBoxPopupControl<LocalDate>
          • javafx.scene.control.skin.DatePickerSkin
  • All Implemented Interfaces:
    Skin<ComboBoxBase<T>>

    public class DatePickerSkin
extends ComboBoxPopupControl<LocalDate>
    默认皮肤实现为DatePicker控件。
    从以下版本开始：
    9
    另请参见：
    DatePicker

    • 构造方法摘要

      构造方法
      Constructor 描述
      DatePickerSkin​(DatePicker control)
      创建一个新的DatePickerSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected StringConverter<LocalDate> getConverter​()
      子类负责获取转换器。
      Node getDisplayNode​()
      该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
      protected TextField getEditor​()
      子类负责获取编辑器。
      Node getPopupContent​()
      此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
      void show​()
      当显示ComboBox弹出窗口时，将调用此方法。

      • Methods inherited from class javafx.scene.control.skin.ComboBoxBaseSkin

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computePrefHeight, computePrefWidth, layoutChildren

      • Methods inherited from class javafx.scene.control.skin.ComboBoxPopupControl

        hide

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeMinHeight, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • DatePickerSkin

        public DatePickerSkin​(DatePicker control)
        创建一个新的DatePickerSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<ComboBoxBase<T>>
        重写：
        dispose在 SkinBase<ComboBoxBase<LocalDate>>

      • getPopupContent

        public Node getPopupContent​()
        此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。
        Specified by:
        getPopupContent在 ComboBoxPopupControl<LocalDate>
        结果
        当用户单击ComboBox'按钮'区域时将显示的节点

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<ComboBoxBase<LocalDate>>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • show

        public void show​()
        当显示ComboBox弹出窗口时，将调用此方法。 特定的皮肤实现取决于如何处理它。
        重写：
        show在 ComboBoxPopupControl<LocalDate>

      • getEditor

        protected TextField getEditor​()
        子类负责获取编辑器。 当编辑器属性使用JDK-8130354移动到ComboBoxBase时，这将在FX 9中删除注意：ComboBoxListViewSkin应该返回null，如果editable为false，即使ComboBox有编辑器设置。
        Specified by:
        getEditor在 ComboBoxPopupControl<LocalDate>
        结果
        编辑

      • getConverter

        protected StringConverter<LocalDate> getConverter​()
        子类负责获取转换器。 当转换器属性移动到具有JDK-8130354的ComboBoxBase时，这将在FX 9中删除。
        Specified by:
        getConverter在 ComboBoxPopupControl<LocalDate>
        结果
        字符串转换器

      • getDisplayNode

        public Node getDisplayNode​()
        该方法应该返回一个将位于ComboBox'按钮'区域内的节点。
        Specified by:
        getDisplayNode在 ComboBoxBaseSkin<LocalDate>
        结果
        将位于ComboBox“按钮”区域内的节点
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HyperlinkSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class HyperlinkSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<Hyperlink>
        • javafx.scene.control.skin.HyperlinkSkin
  • All Implemented Interfaces:
    Skin<C>

    public class HyperlinkSkin
extends LabeledSkinBase<Hyperlink>
    默认皮肤实现为Hyperlink控件。
    从以下版本开始：
    9
    另请参见：
    Hyperlink

    • 构造方法摘要

      构造方法
      Constructor 描述
      HyperlinkSkin​(Hyperlink control)
      创建一个新的HyperlinkSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, layoutChildren, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • HyperlinkSkin

        public HyperlinkSkin​(Hyperlink control)
        创建一个新的HyperlinkSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 应该安装这个皮肤的控制。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends Labeled>
        重写：
        dispose在 SkinBase<Hyperlink>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.control.skin (Java SE 9 & JDK 9 )

javafx.scene.control.skin

Classes

  • AccordionSkin
  • ButtonBarSkin
  • ButtonSkin
  • CellSkinBase
  • CheckBoxSkin
  • ChoiceBoxSkin
  • ColorPickerSkin
  • ComboBoxBaseSkin
  • ComboBoxListViewSkin
  • ComboBoxPopupControl
  • ContextMenuSkin
  • DateCellSkin
  • DatePickerSkin
  • HyperlinkSkin
  • LabeledSkinBase
  • LabelSkin
  • ListCellSkin
  • ListViewSkin
  • MenuBarSkin
  • MenuButtonSkin
  • MenuButtonSkinBase
  • NestedTableColumnHeader
  • PaginationSkin
  • ProgressBarSkin
  • ProgressIndicatorSkin
  • RadioButtonSkin
  • ScrollBarSkin
  • ScrollPaneSkin
  • SeparatorSkin
  • SliderSkin
  • SpinnerSkin
  • SplitMenuButtonSkin
  • SplitPaneSkin
  • TableCellSkin
  • TableCellSkinBase
  • TableColumnHeader
  • TableHeaderRow
  • TableRowSkin
  • TableRowSkinBase
  • TableViewSkin
  • TableViewSkinBase
  • TabPaneSkin
  • TextAreaSkin
  • TextFieldSkin
  • TextInputControlSkin
  • TitledPaneSkin
  • ToggleButtonSkin
  • ToolBarSkin
  • TooltipSkin
  • TreeCellSkin
  • TreeTableCellSkin
  • TreeTableRowSkin
  • TreeTableViewSkin
  • TreeViewSkin
  • VirtualContainerBase
  • VirtualFlow

Enums

  • TextInputControlSkin.Direction
  • TextInputControlSkin.TextUnit


javafx.scene.control.skin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.controls

Package javafx.scene.control.skin

javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

  • 类摘要
    Class 描述
    AccordionSkin
    默认皮肤实现为Accordion控件。
    ButtonBarSkin
    默认皮肤实现为ButtonBar控件。
    ButtonSkin
    默认皮肤实现为Button控件。
    CellSkinBase<C extends Cell>
    默认皮肤的实施为Cell控制和子类，如ListCell ， TreeCell ，等等。
    CheckBoxSkin
    默认皮肤实现为三态CheckBox控件。
    ChoiceBoxSkin<T>
    默认皮肤实现为ChoiceBox控件。
    ColorPickerSkin
    默认皮肤实现为ColorPicker控件。
    ComboBoxBaseSkin<T>
    一个抽象类，旨在用作基于ComboBoxBase的 ComboBox类控件的基础外观 。
    ComboBoxListViewSkin<T>
    默认皮肤实现为ComboBox控件。
    ComboBoxPopupControl<T>
    一个抽象类，扩展了ComboBoxBaseSkin的功能，以包含与显示ComboBox类控件作为弹出窗口相关的API。
    ContextMenuSkin
    ContextMenu的默认皮肤实现。
    DateCellSkin
    默认皮肤实现为DateCell控件。
    DatePickerSkin
    默认皮肤实现为DatePicker控件。
    HyperlinkSkin
    默认皮肤实现为Hyperlink控件。
    LabeledSkinBase<C extends Labeled>
    控件的默认皮肤实现扩展为Labeled 。
    LabelSkin
    默认皮肤实现为Label控件。
    ListCellSkin<T>
    默认皮肤实现为ListCell控件。
    ListViewSkin<T>
    默认皮肤实现为ListView控件。
    MenuBarSkin
    默认皮肤实现为MenuBar控件。
    MenuButtonSkin
    默认皮肤实现为MenuButton控件。
    MenuButtonSkinBase<C extends MenuButton>
    MenuButtonSkin和SplitMenuButtonSkin的基类。
    NestedTableColumnHeader
    此类用于构造TableView的头。
    PaginationSkin
    默认皮肤实现为Pagination控件。
    ProgressBarSkin
    默认皮肤实现为ProgressBar控件。
    ProgressIndicatorSkin
    默认皮肤实现为ProgressIndicator控件。
    RadioButtonSkin
    默认皮肤实现为RadioButton控件。
    ScrollBarSkin
    默认皮肤实现为ScrollBar控件。
    ScrollPaneSkin
    默认皮肤实现为ScrollPane控件。
    SeparatorSkin
    默认皮肤实现为Separator控件。
    SliderSkin
    默认皮肤实现为Slider控件。
    SpinnerSkin<T>
    默认皮肤实现为Spinner控件。
    SplitMenuButtonSkin
    默认皮肤实现为SplitMenuButton控件。
    SplitPaneSkin
    默认皮肤实现为SplitPane控件。
    TableCellSkin<S,T>
    默认皮肤实现为TableCell控件。
    TableCellSkinBase<S,T,C extends IndexedCell<T>>
    表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。
    TableColumnHeader
    负责绘制单列标题的区域。
    TableHeaderRow
    负责绘制整列列标题的区域。
    TableRowSkin<T>
    默认皮肤实现为TableRow控件。
    TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>
    TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。
    TableViewSkin<T>
    默认皮肤实现为TableView控件。
    TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>
    TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。
    TabPaneSkin
    默认皮肤实现为TabPane控件。
    TextAreaSkin
    默认皮肤实现为TextArea控件。
    TextFieldSkin
    默认皮肤实现为TextField控件。
    TextInputControlSkin<T extends TextInputControl>
    文本输入皮肤的抽象基类。
    TitledPaneSkin
    默认皮肤实现为TitledPane控件。
    ToggleButtonSkin
    默认皮肤实现为ToggleButton控件。
    ToolBarSkin
    默认皮肤实现为ToolBar控件。
    TooltipSkin
    基于CSS的皮肤为Tooltip。
    TreeCellSkin<T>
    默认皮肤实现为TreeCell控件。
    TreeTableCellSkin<S,T>
    默认皮肤实现为TreeTableCell控件。
    TreeTableRowSkin<T>
    默认皮肤实现为TreeTableRow控件。
    TreeTableViewSkin<T>
    默认皮肤实现为TreeTableView控件。
    TreeViewSkin<T>
    默认皮肤实现为TreeView控件。
    VirtualContainerBase<C extends Control,I extends IndexedCell>
    父类控制其内容虚拟化和可滚动的外观。
    VirtualFlow<T extends IndexedCell>
    使用基于单元的机制实现虚拟化容器。
  • 枚举摘要
    Enum 描述
    TextInputControlSkin.Direction
    方向名称用于插入符号移动。
    TextInputControlSkin.TextUnit
    照相机运动的单位名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.control.skin Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.control.skin

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.control.skin.ContextMenuSkin (implements javafx.scene.control.Skin<C>)
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.StackPane
              • javafx.scene.control.skin.TableHeaderRow
          • javafx.scene.control.skin.TableColumnHeader
            • javafx.scene.control.skin.NestedTableColumnHeader
          • javafx.scene.control.skin.VirtualFlow<T>
    • javafx.scene.control.SkinBase<C> (implements javafx.scene.control.Skin<C>)
      • javafx.scene.control.skin.AccordionSkin
      • javafx.scene.control.skin.ButtonBarSkin
      • javafx.scene.control.skin.ChoiceBoxSkin<T>
      • javafx.scene.control.skin.ComboBoxBaseSkin<T>
        • javafx.scene.control.skin.ComboBoxPopupControl<T>
          • javafx.scene.control.skin.ColorPickerSkin
          • javafx.scene.control.skin.ComboBoxListViewSkin<T>
          • javafx.scene.control.skin.DatePickerSkin
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.ButtonSkin
        • javafx.scene.control.skin.CellSkinBase<C>
          • javafx.scene.control.skin.DateCellSkin
          • javafx.scene.control.skin.ListCellSkin<T>
          • javafx.scene.control.skin.TableCellSkinBase<S,T,C>
            • javafx.scene.control.skin.TableCellSkin<S,T>
            • javafx.scene.control.skin.TreeTableCellSkin<S,T>
          • javafx.scene.control.skin.TableRowSkinBase<T,C,R>
            • javafx.scene.control.skin.TableRowSkin<T>
            • javafx.scene.control.skin.TreeTableRowSkin<T>
          • javafx.scene.control.skin.TreeCellSkin<T>
        • javafx.scene.control.skin.CheckBoxSkin
        • javafx.scene.control.skin.HyperlinkSkin
        • javafx.scene.control.skin.LabelSkin
        • javafx.scene.control.skin.RadioButtonSkin
        • javafx.scene.control.skin.TitledPaneSkin
        • javafx.scene.control.skin.ToggleButtonSkin
      • javafx.scene.control.skin.MenuBarSkin
      • javafx.scene.control.skin.MenuButtonSkinBase<C>
        • javafx.scene.control.skin.MenuButtonSkin
        • javafx.scene.control.skin.SplitMenuButtonSkin
      • javafx.scene.control.skin.PaginationSkin
      • javafx.scene.control.skin.ProgressIndicatorSkin
        • javafx.scene.control.skin.ProgressBarSkin
      • javafx.scene.control.skin.ScrollBarSkin
      • javafx.scene.control.skin.ScrollPaneSkin
      • javafx.scene.control.skin.SeparatorSkin
      • javafx.scene.control.skin.SliderSkin
      • javafx.scene.control.skin.SpinnerSkin<T>
      • javafx.scene.control.skin.SplitPaneSkin
      • javafx.scene.control.skin.TabPaneSkin
      • javafx.scene.control.skin.TextInputControlSkin<T>
        • javafx.scene.control.skin.TextAreaSkin
        • javafx.scene.control.skin.TextFieldSkin
      • javafx.scene.control.skin.ToolBarSkin
      • javafx.scene.control.skin.VirtualContainerBase<C,I>
        • javafx.scene.control.skin.ListViewSkin<T>
        • javafx.scene.control.skin.TableViewSkinBase<M,S,C,I,TC>
          • javafx.scene.control.skin.TableViewSkin<T>
          • javafx.scene.control.skin.TreeTableViewSkin<T>
        • javafx.scene.control.skin.TreeViewSkin<T>
    • javafx.scene.control.skin.TooltipSkin (implements javafx.scene.control.Skin<C>)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.control.skin.TextInputControlSkin.Direction
      • javafx.scene.control.skin.TextInputControlSkin.TextUnit
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LabeledSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class LabeledSkinBase<C extends Labeled>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
  • All Implemented Interfaces:
    Skin<C>
    已知直接子类：
    ButtonSkin ， CellSkinBase ， CheckBoxSkin ， HyperlinkSkin ， LabelSkin ， RadioButtonSkin ， TitledPaneSkin ， ToggleButtonSkin

    public abstract class LabeledSkinBase<C extends Labeled>
extends SkinBase<C>
    控件的默认皮肤实现扩展为Labeled 。
    从以下版本开始：
    9
    另请参见：
    Labeled

    • 构造方法摘要

      构造方法
      Constructor 描述
      LabeledSkinBase​(C labeled)
      LabeledSkinBase的构造方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)
      基于第一个受管理的子节点计算基线偏移量。
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算并返回此Labeled的最小宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算此 SkinBase的首选宽度。
      protected void layoutChildren​(double x, double y, double w, double h)
      布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
      protected void layoutLabelInArea​(double x, double y, double w, double h)
      在给定的区域内执行标签内容的实际布局。
      protected void layoutLabelInArea​(double x, double y, double w, double h, Pos alignment)
      在给定的区域内执行标签内容的实际布局。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected void updateChildren​()
      更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • LabeledSkinBase

        public LabeledSkinBase​(C labeled)
        LabeledSkinBase的构造方法。 必须指定“标签”，不能为空。 在构造函数调用结束时，皮肤将被标记为needsLayout，并将根据标记的当前状态进行完全配置。 对标签的任何后续更改将通过监听器处理并适当应用。
        参数
        labeled - 这个皮肤应该被安装的标签。

    • 方法详细信息

      • updateChildren

        protected void updateChildren​()
        更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。 仅使用实际必须使用的那些节点。 例如，使用GRAPHIC_ONLY的ContentDisplay不添加文本节点，并且使用TEXT_ONLY的ContentDisplay，不会添加图形。

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        计算并返回此Labeled的最小宽度。 最小宽度是“...”宽度的较小值，带有实际文本的宽度。 这样，如果文本宽度本身小于省略号，那么我们应该将其用作最小宽度，否则省略号需要是最小宽度。

        我们在这里使用相同的计算方法，无论我们在谈论单个或多个标签。 所以一个多行的标签可能会发现，“...”的宽度与它将会得到的一样小。

        重写：
        computeMinWidth在 SkinBase<C extends Labeled>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素啪嗒的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight中的 SkinBase<C extends Labeled>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth中的 SkinBase<C extends Labeled>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<C extends Labeled>
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth中的 SkinBase<C extends Labeled>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight中的 SkinBase<C extends Labeled>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • computeBaselineOffset

        public double computeBaselineOffset​(double topInset,
                                    double rightInset,
                                    double bottomInset,
                                    double leftInset)
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        computeBaselineOffset在 SkinBase<C extends Labeled>
        参数
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        基线偏移

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
        重写：
        layoutChildren在 SkinBase<C extends Labeled>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • layoutLabelInArea

        protected void layoutLabelInArea​(double x,
                                 double y,
                                 double w,
                                 double h)
        在给定的区域内执行标签内容的实际布局。 该方法由覆盖layoutChildren（）的子类调用。
        参数
        x - 控件的标签部分的x位置，内部填充
        y - 控件的标签部分的y位置，内部填充
        w - 控件的标签部分的宽度，不包括填充
        h - 控件的标签部分的高度，不包括填充

      • layoutLabelInArea

        protected void layoutLabelInArea​(double x,
                                 double y,
                                 double w,
                                 double h,
                                 Pos alignment)
        在给定的区域内执行标签内容的实际布局。 该方法由覆盖layoutChildren（）的子类调用。
        参数
        x - 控件的标签部分的x位置，内部填充
        y - 控件的标签部分的y位置，内部填充
        w - 控件的标签部分的宽度，不包括填充
        h - 控件的标签部分的高度，不包括填充
        alignment - 给定区域内控件标签部分的对齐。 如果为空，则将使用控件的对齐方式。

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<C extends Labeled>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LabelSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class LabelSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<Label>
        • javafx.scene.control.skin.LabelSkin
  • All Implemented Interfaces:
    Skin<C>

    public class LabelSkin
extends LabeledSkinBase<Label>
    默认皮肤实现为Label控件。
    从以下版本开始：
    9
    另请参见：
    Label

    • 构造方法摘要

      构造方法
      Constructor 描述
      LabelSkin​(Label control)
      创建一个新的LabelSkin实例，将必需的子节点安装到Control children列表中。

    • 方法摘要

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, layoutChildren, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • LabelSkin

        public LabelSkin​(Label control)
        创建一个新的LabelSkin实例，将必需的子节点安装到控件 children列表中。
        参数
        control - The control that this skin should be installed onto.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ListCellSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<ListCell<T>>
          • javafx.scene.control.skin.ListCellSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class ListCellSkin<T>
extends CellSkinBase<ListCell<T>>
    默认皮肤实现为ListCell控件。
    从以下版本开始：
    9
    另请参见：
    ListCell

    • Property Summary

      • Properties inherited from class javafx.scene.control.skin.CellSkinBase

        cellSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListCellSkin​(ListCell<T> control)
      创建一个新的ListCellSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。

      • Methods inherited from class javafx.scene.control.skin.CellSkinBase

        cellSizeProperty, getCellSize, getClassCssMetaData, getCssMetaData

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxWidth, computeMinWidth, layoutChildren, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ListCellSkin

        public ListCellSkin​(ListCell<T> control)
        创建一个新的ListCellSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用之后 ，方法Skin.getSkinnable()和Skin.getNode()应该返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 SkinBase<ListCell<T>>

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 LabeledSkinBase<ListCell<T>>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 LabeledSkinBase<ListCell<T>>
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 LabeledSkinBase<ListCell<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 LabeledSkinBase<ListCell<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ListViewSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.VirtualContainerBase<ListView<T>,ListCell<T>>
        • javafx.scene.control.skin.ListViewSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class ListViewSkin<T>
extends VirtualContainerBase<ListView<T>,ListCell<T>>
    默认皮肤实现为ListView控件。
    从以下版本开始：
    9
    另请参见：
    ListView

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListViewSkin​(ListView<T> control)
      创建一个新的ListViewSkin实例，将必需的子节点安装到控件 children列表中，以及处理键盘，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      protected int getItemCount​()
      返回此容器中的项目总数，包括当前未隐藏的项目的总数。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected void updateItemCount​()
      当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, consumeMouseEvents, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.VirtualContainerBase

        markItemCountDirty

    • 构造方法详细信息

      • ListViewSkin

        public ListViewSkin​(ListView<T> control)
        创建一个新的ListViewSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 SkinBase<ListView<T>>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 VirtualContainerBase<ListView<T>,ListCell<T>>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算此SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<ListView<T>>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素啪嗒的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<ListView<T>>
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • getItemCount

        protected int getItemCount​()
        返回此容器中的项目总数，包括当前未隐藏的项目的总数。
        Specified by:
        getItemCount在 VirtualContainerBase<ListView<T>,ListCell<T>>
        结果
        此容器中的项目总数

      • updateItemCount

        protected void updateItemCount​()
        当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。 该方法应重新计算料品数量，并存储以供将来使用的VirtualContainerBase.getItemCount()方法。
        Specified by:
        updateItemCount在 VirtualContainerBase<ListView<T>,ListCell<T>>

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<ListView<T>>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)

      • executeAccessibleAction

        protected void executeAccessibleAction​(AccessibleAction action,
                                       Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 SkinBase<ListView<T>>
        参数
        action - 要执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction ， Node.executeAccessibleAction(javafx.scene.AccessibleAction, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MenuBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class MenuBarSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<MenuBar>
      • javafx.scene.control.skin.MenuBarSkin
  • All Implemented Interfaces:
    Skin<MenuBar>

    public class MenuBarSkin
extends SkinBase<MenuBar>
    MenuBar控件的默认皮肤实现。 实质上它是一个简单的工具栏。 暂时没有溢出行为，我们只隐藏超出边界的节点。
    从以下版本开始：
    9
    另请参见：
    MenuBar

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Pos> containerAlignment
      指定MenuBar中菜单按钮的对齐方式（默认为Pos.TOP_LEFT）。
      DoubleProperty spacing
      指定MenuBar上的菜单按钮之间的间距。

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuBarSkin​(MenuBar control)
      创建一个新的MenuBarSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      ObjectProperty<Pos> containerAlignmentProperty​()
      指定MenuBar中菜单按钮的对齐方式（默认为Pos.TOP_LEFT）。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      Pos getContainerAlignment​()
      获取属性containerAlignment的值。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      double getSpacing​()
      获取属性间距的值。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setContainerAlignment​(Pos value)
      设置属性containerAlignment的值。
      static void setDefaultSystemMenuBar​(MenuBar menuBar)
      设置默认的系统菜单栏。
      void setSpacing​(double value)
      设置属性间距的值。
      protected double snappedBottomInset​()
      获取底部插图的实用方法，其中包括填充和边框插入。
      protected double snappedLeftInset​()
      获取包含填充和边框插入的左边插图的实用方法。
      protected double snappedRightInset​()
      获取正确的插图的实用方法，包括填充和边框插入。
      protected double snappedTopInset​()
      获取包含填充和边框插入的顶层插图的实用方法。
      DoubleProperty spacingProperty​()
      指定MenuBar上的菜单按钮之间的间距。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxWidth, consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • Property Detail

      • spacing

        public final DoubleProperty spacingProperty
        指定MenuBar上的菜单按钮之间的间距。
        另请参见：
        getSpacing() ， setSpacing(double)

      • containerAlignment

        public final ObjectProperty<Pos> containerAlignmentProperty
        指定MenuBar中菜单按钮的对齐方式（默认为Pos.TOP_LEFT）。
        另请参见：
        getContainerAlignment() ， setContainerAlignment(Pos)

    • 构造方法详细信息

      • MenuBarSkin

        public MenuBarSkin​(MenuBar control)
        创建一个新的MenuBarSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • setDefaultSystemMenuBar

        public static void setDefaultSystemMenuBar​(MenuBar menuBar)
        设置默认的系统菜单栏。 这允许应用程序在最后一个窗口关闭后在系统菜单栏中保持菜单。
        参数
        menuBar - 菜单栏

      • setSpacing

        public final void setSpacing​(double value)
        设置属性间距的值。
        Property description:
        指定MenuBar上的菜单按钮之间的间距。

      • getSpacing

        public final double getSpacing​()
        获取属性间距的值。
        Property description:
        指定MenuBar上的菜单按钮之间的间距。

      • spacingProperty

        public final DoubleProperty spacingProperty​()
        指定MenuBar上的菜单按钮之间的间距。
        另请参见：
        getSpacing() ， setSpacing(double)

      • setContainerAlignment

        public final void setContainerAlignment​(Pos value)
        设置属性containerAlignment的值。
        Property description:
        指定MenuBar中菜单按钮的对齐方式（默认为Pos.TOP_LEFT）。

      • getContainerAlignment

        public final Pos getContainerAlignment​()
        获取属性containerAlignment的值。
        Property description:
        指定MenuBar中菜单按钮的对齐方式（默认为Pos.TOP_LEFT）。

      • containerAlignmentProperty

        public final ObjectProperty<Pos> containerAlignmentProperty​()
        指定MenuBar中菜单按钮的对齐方式（默认为Pos.TOP_LEFT）。
        另请参见：
        getContainerAlignment() ， setContainerAlignment(Pos)

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<MenuBar>
        重写：
        dispose在 SkinBase<MenuBar>

      • snappedTopInset

        protected double snappedTopInset​()
        获取包含填充和边框插入的顶层插图的实用方法。 如果getSkinnable（）。isSnapToPixel（）为true，则将其全部移动到像素上。
        重写：
        snappedTopInset在 SkinBase<MenuBar>
        结果
        圆顶顶

      • snappedBottomInset

        protected double snappedBottomInset​()
        获取底部插图的实用方法，其中包括填充和边框插入。 如果getSkinnable（）。isSnapToPixel（）为true，则将其全部移动到像素上。
        重写：
        snappedBottomInset在 SkinBase<MenuBar>
        结果
        倒圆角的底部

      • snappedLeftInset

        protected double snappedLeftInset​()
        获取包含填充和边框插入的左边插图的实用方法。 如果getSkinnable（）。isSnapToPixel（）为true，则将其全部移动到像素上。
        重写：
        snappedLeftInset在 SkinBase<MenuBar>
        结果
        向左舍入

      • snappedRightInset

        protected double snappedRightInset​()
        获取正确的插图的实用方法，包括填充和边框插入。 如果getSkinnable（）。isSnapToPixel（）为true，则将其全部移动到像素上。
        重写：
        snappedRightInset在 SkinBase<MenuBar>
        结果
        圆形插图正确

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<MenuBar>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<MenuBar>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<MenuBar>
        参数
        height - 如果首选宽度取决于它应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<MenuBar>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<MenuBar>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<MenuBar>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 SkinBase<MenuBar>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<MenuBar>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MenuButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class MenuButtonSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.MenuButtonSkinBase<MenuButton>
        • javafx.scene.control.skin.MenuButtonSkin
  • All Implemented Interfaces:
    Skin<C>

    public class MenuButtonSkin
extends MenuButtonSkinBase<MenuButton>
    默认皮肤实现为MenuButton控件。
    从以下版本开始：
    9
    另请参见：
    MenuButton

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuButtonSkin​(MenuButton control)
      创建一个新的MenuButtonSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class javafx.scene.control.skin.MenuButtonSkinBase

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, layoutChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • MenuButtonSkin

        public MenuButtonSkin​(MenuButton control)
        创建一个新的MenuButtonSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends MenuButton>
        重写：
        dispose在 MenuButtonSkinBase<MenuButton>

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<MenuButton>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MenuButtonSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class MenuButtonSkinBase<C extends MenuButton>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.MenuButtonSkinBase<C>
  • All Implemented Interfaces:
    Skin<C>
    已知直接子类：
    MenuButtonSkin ， SplitMenuButtonSkin

    public class MenuButtonSkinBase<C extends MenuButton>
extends SkinBase<C>
    MenuButtonSkin和SplitMenuButtonSkin的基类。 它由标签，箭头形状的箭头和弹出窗口组成。
    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuButtonSkinBase​(C control)
      创建一个新的MenuButtonSkinBase实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • MenuButtonSkinBase

        public MenuButtonSkinBase​(C control)
        创建一个新的MenuButtonSkinBase实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。
        参数
        control - 该皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends MenuButton>
        重写：
        dispose在 SkinBase<C extends MenuButton>

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<C extends MenuButton>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<C extends MenuButton>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<C extends MenuButton>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<C extends MenuButton>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 SkinBase<C extends MenuButton>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<C extends MenuButton>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<C extends MenuButton>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NestedTableColumnHeader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class NestedTableColumnHeader

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.skin.TableColumnHeader
            • javafx.scene.control.skin.NestedTableColumnHeader
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class NestedTableColumnHeader
extends TableColumnHeader

    此类用于构造TableView的头。 我们采用每个TableView头部嵌套的方法 - 即使不是。 这允许我们使用相同的代码构建一行TableColumns，就像我们使用大量嵌套的TableColumns序列一样。 因此，TableHeaderRow类只包含一个NestedTableColumnHeader的一个实例。

    从以下版本开始：
    9
    另请参见：
    TableColumnHeader ， TableHeaderRow ， TableColumnBase

    • Property Summary

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.control.skin.TableColumnHeader

        tableColumn

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      NestedTableColumnHeader​(TableColumnBase tc)
      创建一个新的NestedTableColumnHeader实例来可视化地表示给定的TableColumnBase实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      protected TableColumnHeader createTableColumnHeader​(TableColumnBase col)
      为给定的TableColumnBase实例创建一个新的TableColumnHeader实例。
      ObservableList<TableColumnHeader> getColumnHeaders​()
      返回作为此NestedTableColumnHeader的子项的2706972983333实例的不可修改列表。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

      • Methods inherited from class javafx.scene.control.skin.TableColumnHeader

        computeMinHeight, getClassCssMetaData, getCssMetaData, getTableColumn, queryAccessibleAttribute, tableColumnProperty

    • 构造方法详细信息

      • NestedTableColumnHeader

        public NestedTableColumnHeader​(TableColumnBase tc)
        创建一个新的NestedTableColumnHeader实例来可视化地表示给定的TableColumnBase实例。
        参数
        tc - 由此实例可视化表示的表列。

    • 方法详细信息

      • getColumnHeaders

        public final ObservableList<TableColumnHeader> getColumnHeaders​()
        返回作为此NestedTableColumnHeader的子项的TableColumnHeader实例的不可修改列表。
        结果
        此NestedTableColumnHeader的TableColumnHeader的不可修改列表

      • layoutChildren

        protected void layoutChildren​()
        在布局传递期间调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 TableColumnHeader

      • computePrefWidth

        protected double computePrefWidth​(double height)
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 TableColumnHeader
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 TableColumnHeader
        参数
        width - 如果首选的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • createTableColumnHeader

        protected TableColumnHeader createTableColumnHeader​(TableColumnBase col)
        为给定的TableColumnBase实例创建一个新的TableColumnHeader实例。 实现此方法的一般模式如下：
        • 如果给定的TableColumnBase实例为空，没有子列，或者如果给定的TableColumnBase实例等于通过调用TableColumnHeader.getTableColumn()返回的TableColumnBase实例，则建议返回由给定列组成的27069729863745实例。
        • 否则，我们可以假设给定的TableColumnBase实例有子列，在这种情况下建议返回一个NestedTableColumnHeader实例。
        注意：在大多数情况下，这种方法不应该被覆盖，但在某些情况下，它是有意义的（例如测试，或者当需要极端的定制时）。
        参数
        col - 表列
        结果
        一个新的TableColumnHeader实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PaginationSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class PaginationSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<Pagination>
      • javafx.scene.control.skin.PaginationSkin
  • All Implemented Interfaces:
    Skin<Pagination>

    public class PaginationSkin
extends SkinBase<Pagination>
    默认皮肤实现为Pagination控件。
    从以下版本开始：
    9
    另请参见：
    Pagination

    • 构造方法摘要

      构造方法
      Constructor 描述
      PaginationSkin​(Pagination control)
      创建一个新的PaginationSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • PaginationSkin

        public PaginationSkin​(Pagination control)
        创建一个新的PaginationSkin实例，将必需的子节点安装到控件 children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<Pagination>
        重写：
        dispose在 SkinBase<Pagination>

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<Pagination>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<Pagination>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算此SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<Pagination>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<Pagination>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<Pagination>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<Pagination>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 SkinBase<Pagination>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProgressBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ProgressBarSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<ProgressIndicator>
      • javafx.scene.control.skin.ProgressIndicatorSkin
        • javafx.scene.control.skin.ProgressBarSkin
  • All Implemented Interfaces:
    Skin<ProgressIndicator>

    public class ProgressBarSkin
extends ProgressIndicatorSkin
    默认皮肤实现为ProgressBar控件。
    从以下版本开始：
    9
    另请参见：
    ProgressBar

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProgressBarSkin​(ProgressBar control)
      创建一个新的ProgressBarSkin实例，将必需的子节点安装到控件 children列表中。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)
      基于第一个受管理的子节点计算基线偏移量。
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.skin.ProgressIndicatorSkin

        dispose

      • Methods inherited from class javafx.scene.control.SkinBase

        computeMinHeight, computeMinWidth, consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ProgressBarSkin

        public ProgressBarSkin​(ProgressBar control)
        创建一个新的ProgressBarSkin实例，将必需的子节点安装到控件 children列表中。
        参数
        control - 应该安装这个皮肤的控制。

    • 方法详细信息

      • computeBaselineOffset

        public double computeBaselineOffset​(double topInset,
                                    double rightInset,
                                    double bottomInset,
                                    double leftInset)
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        computeBaselineOffset在 SkinBase<ProgressIndicator>
        参数
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        基线偏移

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<ProgressIndicator>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<ProgressIndicator>
        参数
        width - 如果首选的高度取决于应该使用的宽度
        topInset - 像素啪嗒的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 SkinBase<ProgressIndicator>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素 bottomInset底部插图
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<ProgressIndicator>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 ProgressIndicatorSkin
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 ProgressIndicatorSkin
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProgressIndicatorSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ProgressIndicatorSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<ProgressIndicator>
      • javafx.scene.control.skin.ProgressIndicatorSkin
  • All Implemented Interfaces:
    Skin<ProgressIndicator>
    已知直接子类：
    ProgressBarSkin

    public class ProgressIndicatorSkin
extends SkinBase<ProgressIndicator>
    默认皮肤实现为ProgressIndicator控件。
    从以下版本开始：
    9
    另请参见：
    ProgressIndicator

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProgressIndicatorSkin​(ProgressIndicator control)
      创建一个新的ProgressIndicatorSkin实例，将必要的子节点安装到Control children列表中。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ProgressIndicatorSkin

        public ProgressIndicatorSkin​(ProgressIndicator control)
        创建一个新的ProgressIndicatorSkin实例，将必需的子节点安装到控件 children列表中。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<ProgressIndicator>
        重写：
        dispose在 SkinBase<ProgressIndicator>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<ProgressIndicator>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 SkinBase<ProgressIndicator>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RadioButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class RadioButtonSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<RadioButton>
        • javafx.scene.control.skin.RadioButtonSkin
  • All Implemented Interfaces:
    Skin<C>

    public class RadioButtonSkin
extends LabeledSkinBase<RadioButton>
    默认皮肤实现为RadioButton控件。
    从以下版本开始：
    9
    另请参见：
    RadioButton

    • 构造方法摘要

      构造方法
      Constructor 描述
      RadioButtonSkin​(RadioButton control)
      创建一个新的RadioButtonSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算并返回此Labeled的最小宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
      protected void updateChildren​()
      更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • RadioButtonSkin

        public RadioButtonSkin​(RadioButton control)
        创建一个新的RadioButtonSkin实例，将必要的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends Labeled>
        重写：
        dispose在 SkinBase<RadioButton>

      • updateChildren

        protected void updateChildren​()
        更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。 仅使用实际必须使用的那些节点。 例如，使用GRAPHIC_ONLY的ContentDisplay不添加文本节点，并且使用TEXT_ONLY的ContentDisplay，不会添加图形。
        重写：
        updateChildren在 LabeledSkinBase<RadioButton>

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        计算并返回此Labeled的最小宽度。 最小宽度是“...”宽度的较小值，带有实际文本的宽度。 这样，如果文本宽度本身小于省略号，那么我们应该将其用作最小宽度，否则省略号需要是最小宽度。

        我们在这里使用相同的计算方法，无论我们在谈论单个或多个标签。 所以一个多行的标签可能会发现，“...”的宽度与它将会得到的一样小。

        重写：
        computeMinWidth在 LabeledSkinBase<RadioButton>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 LabeledSkinBase<RadioButton>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 LabeledSkinBase<RadioButton>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 LabeledSkinBase<RadioButton>
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
        重写：
        layoutChildren在 LabeledSkinBase<RadioButton>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScrollBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ScrollBarSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<ScrollBar>
      • javafx.scene.control.skin.ScrollBarSkin
  • All Implemented Interfaces:
    Skin<ScrollBar>

    public class ScrollBarSkin
extends SkinBase<ScrollBar>
    默认皮肤实现为ScrollBar控件。
    从以下版本开始：
    9
    另请参见：
    ScrollBar

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScrollBarSkin​(ScrollBar control)
      创建一个新的ScrollBarSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ScrollBarSkin

        public ScrollBarSkin​(ScrollBar control)
        创建一个新的ScrollBarSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<ScrollBar>
        重写：
        dispose在 SkinBase<ScrollBar>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<ScrollBar>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<ScrollBar>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<ScrollBar>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算此SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<ScrollBar>
        参数
        height - 如果首选宽度取决于它应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double height,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<ScrollBar>
        参数
        height - 如果首选高度取决于它应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 SkinBase<ScrollBar>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<ScrollBar>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素 bottomInset底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScrollPaneSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ScrollPaneSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<ScrollPane>
      • javafx.scene.control.skin.ScrollPaneSkin
  • All Implemented Interfaces:
    Skin<ScrollPane>

    public class ScrollPaneSkin
extends SkinBase<ScrollPane>
    默认皮肤实现为ScrollPane控件。
    从以下版本开始：
    9
    另请参见：
    ScrollPane

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScrollPaneSkin​(ScrollPane control)
      创建一个新的ScrollPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      ScrollBar getHorizontalScrollBar​()
      返回此ScrollPaneSkin实例中使用的水平ScrollBar 。
      ScrollBar getVerticalScrollBar​()
      返回此ScrollPaneSkin实例中使用的垂直ScrollBar 。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ScrollPaneSkin

        public ScrollPaneSkin​(ScrollPane control)
        创建一个新的ScrollPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用之后 ，方法Skin.getSkinnable()和Skin.getNode()应该返回null。 呼叫处理两次无效。
        Specified by:
        dispose接口 Skin<ScrollPane>
        重写：
        dispose在 SkinBase<ScrollPane>

      • getHorizontalScrollBar

        public final ScrollBar getHorizontalScrollBar​()
        返回此ScrollPaneSkin实例中使用的水平ScrollBar 。
        结果
        在此ScrollPaneSkin实例中使用的水平ScrollBar

      • getVerticalScrollBar

        public final ScrollBar getVerticalScrollBar​()
        返回此ScrollPaneSkin实例中使用的垂直ScrollBar 。
        结果
        在此ScrollPaneSkin实例中使用的垂直ScrollBar

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<ScrollPane>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<ScrollPane>
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<ScrollPane>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<ScrollPane>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        描述从类复制： SkinBase
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<ScrollPane>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<ScrollPane>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SeparatorSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class SeparatorSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<Separator>
      • javafx.scene.control.skin.SeparatorSkin
  • All Implemented Interfaces:
    Skin<Separator>

    public class SeparatorSkin
extends SkinBase<Separator>
    默认皮肤实现为Separator控件。
    从以下版本开始：
    9
    另请参见：
    Separator

    • 构造方法摘要

      构造方法
      Constructor 描述
      SeparatorSkin​(Separator control)
      创建一个新的SeparatorSkin实例，将必需的子节点安装到控件 children列表中。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double w, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double h, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double w, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double h, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      protected void layoutChildren​(double x, double y, double w, double h)
      我们只需要处理单一的“线”儿童地区。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • SeparatorSkin

        public SeparatorSkin​(Separator control)
        创建一个新的SeparatorSkin实例，将必需的子节点安装到Control children列表中。
        参数
        control - 应该安装这个皮肤的控制。

    • 方法详细信息

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        我们只需要处理单一的“线”儿童地区。 这里的重要的一点是，我们想要一个水平分隔符具有与分隔符一样宽的行（较少的左/右填充），但是尽可能薄（基于其自己的pref高度）。 垂直分隔符的想法相同。 它应该与分离器一样高（较小的顶部和底部填充），但是尽可能薄（线的最初宽度）。

        然后将线放置在分离器内，使得对准属性得以兑现。

        重写：
        layoutChildren在 SkinBase<Separator>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<Separator>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<Separator>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double h,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<Separator>
        参数
        h - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double w,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<Separator>
        参数
        w - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double h,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 SkinBase<Separator>
        参数
        h - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double w,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<Separator>
        参数
        w - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SliderSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class SliderSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<Slider>
      • javafx.scene.control.skin.SliderSkin
  • All Implemented Interfaces:
    Skin<Slider>

    public class SliderSkin
extends SkinBase<Slider>
    默认皮肤实现为Slider控件。
    从以下版本开始：
    9
    另请参见：
    Slider

    • 构造方法摘要

      构造方法
      Constructor 描述
      SliderSkin​(Slider control)
      创建一个新的SliderSkin实例，将必要的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • SliderSkin

        public SliderSkin​(Slider control)
        创建一个新的SliderSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<Slider>
        重写：
        dispose在 SkinBase<Slider>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<Slider>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<Slider>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<Slider>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<Slider>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<Slider>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 SkinBase<Slider>
        参数
        height - 皮肤的高度，以防该值可能指定最大宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<Slider>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SpinnerSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class SpinnerSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<Spinner<T>>
      • javafx.scene.control.skin.SpinnerSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class SpinnerSkin<T>
extends SkinBase<Spinner<T>>
    默认皮肤实现为Spinner控件。
    从以下版本开始：
    9
    另请参见：
    Spinner

    • 构造方法摘要

      构造方法
      Constructor 描述
      SpinnerSkin​(Spinner<T> control)
      创建一个新的SpinnerSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)
      基于第一个受管理的子节点计算基线偏移量。
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • SpinnerSkin

        public SpinnerSkin​(Spinner<T> control)
        创建一个新的SpinnerSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 应该安装这个皮肤的控制。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用之后 ，方法Skin.getSkinnable()和Skin.getNode()应该返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 SkinBase<Spinner<T>>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<Spinner<T>>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        描述从类复制： SkinBase
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<Spinner<T>>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<Spinner<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素啪嗒的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<Spinner<T>>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<Spinner<T>>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素啪嗒的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 SkinBase<Spinner<T>>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<Spinner<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • computeBaselineOffset

        protected double computeBaselineOffset​(double topInset,
                                       double rightInset,
                                       double bottomInset,
                                       double leftInset)
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        computeBaselineOffset在 SkinBase<Spinner<T>>
        参数
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        基线偏移
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SplitMenuButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class SplitMenuButtonSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.MenuButtonSkinBase<SplitMenuButton>
        • javafx.scene.control.skin.SplitMenuButtonSkin
  • All Implemented Interfaces:
    Skin<C>

    public class SplitMenuButtonSkin
extends MenuButtonSkinBase<SplitMenuButton>
    默认皮肤实现为SplitMenuButton控件。
    从以下版本开始：
    9
    另请参见：
    SplitMenuButton

    • 构造方法摘要

      构造方法
      Constructor 描述
      SplitMenuButtonSkin​(SplitMenuButton control)
      创建一个新的SplitMenuButtonSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。

      • Methods inherited from class javafx.scene.control.skin.MenuButtonSkinBase

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, layoutChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • SplitMenuButtonSkin

        public SplitMenuButtonSkin​(SplitMenuButton control)
        创建一个新的SplitMenuButtonSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends MenuButton>
        重写：
        dispose在 MenuButtonSkinBase<SplitMenuButton>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SplitPaneSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class SplitPaneSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<SplitPane>
      • javafx.scene.control.skin.SplitPaneSkin
  • All Implemented Interfaces:
    Skin<SplitPane>

    public class SplitPaneSkin
extends SkinBase<SplitPane>
    默认皮肤实现为SplitPane控件。
    从以下版本开始：
    9
    另请参见：
    SplitPane

    • 构造方法摘要

      构造方法
      Constructor 描述
      SplitPaneSkin​(SplitPane control)
      创建一个新的SplitPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • SplitPaneSkin

        public SplitPaneSkin​(SplitPane control)
        创建一个新的SplitPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<SplitPane>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<SplitPane>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<SplitPane>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<SplitPane>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<SplitPane>
        参数
        width - 如果首选的高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TableCellSkin<S,T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<C>
          • javafx.scene.control.skin.TableCellSkinBase<S,T,TableCell<S,T>>
            • javafx.scene.control.skin.TableCellSkin<S,T>
  • 参数类型
    S - UI控件的类型（例如“行”的类型）。
    T - 单元格中的内容类型，基于其TableColumn 。
    All Implemented Interfaces:
    Skin<S>

    public class TableCellSkin<S,T>
extends TableCellSkinBase<S,T,TableCell<S,T>>
    默认皮肤实现为TableCell控件。
    从以下版本开始：
    9
    另请参见：
    TableCell

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<TableColumn<S,T>> tableColumn
      负责此单元格的TableColumnBase实例。

      • Properties inherited from class javafx.scene.control.skin.CellSkinBase

        cellSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableCellSkin​(TableCell<S,T> control)
      创建一个新的TableCellSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      ReadOnlyObjectProperty<TableColumn<S,T>> tableColumnProperty​()
      负责此单元格的TableColumnBase实例。

      • Methods inherited from class javafx.scene.control.skin.CellSkinBase

        cellSizeProperty, getCellSize, getClassCssMetaData, getCssMetaData

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.TableCellSkinBase

        computePrefWidth, getTableColumn, layoutChildren

    • Property Detail

      • tableColumn

        public ReadOnlyObjectProperty<TableColumn<S,T>> tableColumnProperty
        负责此单元格的TableColumnBase实例。
        Specified by:
        tableColumnProperty在 TableCellSkinBase<S,T,TableCell<S,T>>
        另请参见：
        TableCellSkinBase.getTableColumn()

    • 构造方法详细信息

      • TableCellSkin

        public TableCellSkin​(TableCell<S,T> control)
        创建一个新的TableCellSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 该皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<S>
        重写：
        dispose在 TableCellSkinBase<S,T,TableCell<S,T>>

      • tableColumnProperty

        public ReadOnlyObjectProperty<TableColumn<S,T>> tableColumnProperty​()
        负责此单元格的TableColumnBase实例。
        Specified by:
        tableColumnProperty在 TableCellSkinBase<S,T,TableCell<S,T>>
        另请参见：
        TableCellSkinBase.getTableColumn()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableCellSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TableCellSkinBase<S,T,C extends IndexedCell<T>>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<C>
          • javafx.scene.control.skin.TableCellSkinBase<S,T,C>
  • 参数类型
    S - UI控件的类型（例如“行”的类型）。
    T - 单元格中的内容类型，基于其TableColumnBase 。
    All Implemented Interfaces:
    Skin<S>
    已知直接子类：
    TableCellSkin ， TreeTableCellSkin

    public abstract class TableCellSkinBase<S,T,C extends IndexedCell<T>>
extends CellSkinBase<C>
    表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。
    从以下版本开始：
    9
    另请参见：
    TableCell ， TreeTableCell

    • Property Summary

      Properties
      Type Property 描述
      abstract ReadOnlyObjectProperty<? extends TableColumnBase<S,T>> tableColumn
      负责此单元格的TableColumnBase实例。

      • Properties inherited from class javafx.scene.control.skin.CellSkinBase

        cellSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableCellSkinBase​(C control)
      创建一个新的TableCellSkinBase实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算此 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      TableColumnBase<S,T> getTableColumn​()
      获取属性tableColumn的值。
      protected void layoutChildren​(double x, double y, double w, double h)
      布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
      abstract ReadOnlyObjectProperty<? extends TableColumnBase<S,T>> tableColumnProperty​()
      负责此单元格的TableColumnBase实例。

      • Methods inherited from class javafx.scene.control.skin.CellSkinBase

        cellSizeProperty, getCellSize, getClassCssMetaData, getCssMetaData

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • Property Detail

      • tableColumn

        public abstract ReadOnlyObjectProperty<? extends TableColumnBase<S,T>> tableColumnProperty
        负责此单元格的TableColumnBase实例。
        另请参见：
        getTableColumn()

    • 构造方法详细信息

      • TableCellSkinBase

        public TableCellSkinBase​(C control)
        创建一个新的TableCellSkinBase实例，将必要的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • tableColumnProperty

        public abstract ReadOnlyObjectProperty<? extends TableColumnBase<S,T>> tableColumnProperty​()
        负责此单元格的TableColumnBase实例。
        另请参见：
        getTableColumn()

      • getTableColumn

        public final TableColumnBase<S,T> getTableColumn​()
        获取属性tableColumn的值。
        Property description:
        负责此单元格的TableColumnBase实例。

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<S>
        重写：
        dispose在 SkinBase<C extends IndexedCell<T>>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
        重写：
        layoutChildren在 LabeledSkinBase<C extends IndexedCell<T>>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 LabeledSkinBase<C extends IndexedCell<T>>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableColumnHeader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TableColumnHeader

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.skin.TableColumnHeader
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    NestedTableColumnHeader

    public class TableColumnHeader
extends Region
    负责绘制单列标题的区域。 子类使用的子组件为TableViewSkinBase 。
    从以下版本开始：
    9

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<TableColumnBase<?,?>> tableColumn
      引用该头部视觉上表示的TableColumnBase实例的属性。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableColumnHeader​(TableColumnBase tc)
      创建一个新的TableColumnHeader实例来可视化地表示给定的TableColumnBase实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      TableColumnBase<?,?> getTableColumn​()
      获取属性tableColumn的值。
      protected void layoutChildren​()
      在布局传递期间调用这个 Parent的孩子。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      ReadOnlyObjectProperty<TableColumnBase<?,?>> tableColumnProperty​()
      引用这个头部在视觉上表示的TableColumnBase实例的属性。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • tableColumn

        public final ReadOnlyObjectProperty<TableColumnBase<?,?>> tableColumnProperty
        引用该头部视觉表示的TableColumnBase实例的属性。
        另请参见：
        getTableColumn()

    • 构造方法详细信息

      • TableColumnHeader

        public TableColumnHeader​(TableColumnBase tc)
        创建一个新的TableColumnHeader实例来可视化地表示给定的TableColumnBase实例。
        参数
        tc - 由此实例可视化表示的表列。

    • 方法详细信息

      • getTableColumn

        public final TableColumnBase<?,?> getTableColumn​()
        获取属性tableColumn的值。
        Property description:
        引用该头部视觉表示的TableColumnBase实例的属性。

      • tableColumnProperty

        public final ReadOnlyObjectProperty<TableColumnBase<?,?>> tableColumnProperty​()
        引用该头部视觉表示的TableColumnBase实例的属性。
        另请参见：
        getTableColumn()

      • layoutChildren

        protected void layoutChildren​()
        在布局传递期间调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • computePrefWidth

        protected double computePrefWidth​(double height)
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果首选的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Parent
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        the CssMetaData associated with this class, which may include the CssMetaData of its superclasses
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableHeaderRow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TableHeaderRow

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.StackPane
              • javafx.scene.control.skin.TableHeaderRow
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class TableHeaderRow
extends StackPane
    负责绘制整列列标题的区域。
    从以下版本开始：
    9
    另请参见：
    TableView ， TableViewSkin ， TreeTableView ， TreeTableViewSkin

    • Property Summary

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

      • Properties inherited from class javafx.scene.layout.StackPane

        alignment

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableHeaderRow​(TableViewSkinBase skin)
      创建一个新的TableHeaderRow实例来可视化地表示控件的列标题区域，如TableView和TreeTableView 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      protected NestedTableColumnHeader createRootHeader​()
      创建一个新的NestedTableColumnHeader实例。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from class javafx.scene.layout.StackPane

        alignmentProperty, clearConstraints, computeMinWidth, getAlignment, getAlignment, getClassCssMetaData, getContentBias, getCssMetaData, getMargin, requestLayout, setAlignment, setAlignment, setMargin

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • TableHeaderRow

        public TableHeaderRow​(TableViewSkinBase skin)
        创建一个新的TableHeaderRow实例来可视化地表示控件的列标题区域，如TableView和TreeTableView 。
        参数
        skin - UI控件使用的皮肤。

    • 方法详细信息

      • layoutChildren

        protected void layoutChildren​()
        在布局传递期间调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 StackPane

      • computePrefWidth

        protected double computePrefWidth​(double height)
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth中的 StackPane
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 StackPane
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 StackPane
        参数
        width - 如果首选的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • createRootHeader

        protected NestedTableColumnHeader createRootHeader​()
        创建一个新的NestedTableColumnHeader实例。 默认情况下，此方法不应被覆盖，但在某些情况下，它是有意义的（例如，测试或需要极端定制时）。
        结果
        一个新的NestedTableColumnHeader实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableRowSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TableRowSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<C>
          • javafx.scene.control.skin.TableRowSkinBase<T,TableRow<T>,TableCell<T,?>>
            • javafx.scene.control.skin.TableRowSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class TableRowSkin<T>
extends TableRowSkinBase<T,TableRow<T>,TableCell<T,?>>
    默认皮肤实现为TableRow控件。
    从以下版本开始：
    9
    另请参见：
    TableRow

    • Property Summary

      • Properties inherited from class javafx.scene.control.skin.CellSkinBase

        cellSize

      • Properties inherited from class javafx.scene.control.skin.TableRowSkinBase

        graphic

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableRowSkin​(TableRow<T> control)
      创建一个新的TableRowSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected TableCell<T,?> createCell​(TableColumnBase tcb)
      创建适用于表示给定表列实例的新单元实例。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected TableColumn<T,?> getTableColumn​(TableCell<T,?> cell)
      返回给定单元格实例的TableColumnBase实例。
      protected ObservableList<TableColumn<T,?>> getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected void updateCell​(TableCell<T,?> cell, TableRow<T> row)
      允许给定单元格被告知它是给定行的成员的方法。

      • Methods inherited from class javafx.scene.control.skin.CellSkinBase

        cellSizeProperty, getCellSize, getClassCssMetaData, getCssMetaData

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxWidth, computeMinWidth, layoutLabelInArea, layoutLabelInArea, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.TableRowSkinBase

        computeMaxHeight, computeMinHeight, computePrefHeight, computePrefWidth, graphicProperty, layoutChildren

    • 构造方法详细信息

      • TableRowSkin

        public TableRowSkin​(TableRow<T> control)
        创建一个新的TableRowSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 该皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 SkinBase<TableRow<T>>

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 LabeledSkinBase<TableRow<T>>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)

      • createCell

        protected TableCell<T,?> createCell​(TableColumnBase tcb)
        创建适用于表示给定表列实例的新单元实例。
        Specified by:
        createCell在 TableRowSkinBase<T,TableRow<T>,TableCell<T,?>>
        参数
        tcb - 表列
        结果
        创建的单元格

      • getVisibleLeafColumns

        protected ObservableList<TableColumn<T,?>> getVisibleLeafColumns​()
        返回一个不可修改的列表，其中包含当前可见的叶子列。
        Specified by:
        getVisibleLeafColumns在 TableRowSkinBase<T,TableRow<T>,TableCell<T,?>>
        结果
        可见叶列列表

      • updateCell

        protected void updateCell​(TableCell<T,?> cell,
                          TableRow<T> row)
        允许给定单元格被告知它是给定行的成员的方法。 如何实现它取决于实际的单元实现。
        Specified by:
        updateCell在 TableRowSkinBase<T,TableRow<T>,TableCell<T,?>>
        参数
        cell - 我们要通知它的所有者行的单元格。
        row - 将在给定单元格上设置的行。

      • getTableColumn

        protected TableColumn<T,?> getTableColumn​(TableCell<T,?> cell)
        返回给定单元格实例的TableColumnBase实例。
        Specified by:
        getTableColumn在 TableRowSkinBase<T,TableRow<T>,TableCell<T,?>>
        参数
        cell - 需要TableColumn的单元格。
        结果
        the table column
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableRowSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<C>
          • javafx.scene.control.skin.TableRowSkinBase<T,C,R>
  • 参数类型
    T - 单元格的类型（即IndexedCell子类的通用类型）。
    C - 单元格类型（例如TableRow或TreeTableRow）
    R - 每行中包含的单元格类型（例如or {@link javafx.scene.control.TreeTableCell} ）。
    All Implemented Interfaces:
    Skin<T>
    已知直接子类：
    TableRowSkin ， TreeTableRowSkin

    public abstract class TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>
extends CellSkinBase<C>
    TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。
    从以下版本开始：
    9
    另请参见：
    TableRow ， TreeTableRow ， TableRowSkin ， TreeTableRowSkin

    • Property Summary

      Properties
      Type Property 描述
      protected ObjectProperty<Node> graphic
      返回在公开节点内部绘制的图形。

      • Properties inherited from class javafx.scene.control.skin.CellSkinBase

        cellSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableRowSkinBase​(C control)
      创建一个新的TableRowSkinBase实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      protected abstract R createCell​(TableColumnBase<T,?> tc)
      创建适用于表示给定表列实例的新单元实例。
      protected abstract TableColumnBase<T,?> getTableColumn​(R cell)
      返回给定单元格实例的TableColumnBase实例。
      protected abstract ObservableList<? extends TableColumnBase> getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      protected ObjectProperty<Node> graphicProperty​()
      返回在公开节点内部绘制的图形。
      protected void layoutChildren​(double x, double y, double w, double h)
      布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
      protected abstract void updateCell​(R cell, C row)
      允许给定单元格被告知它是给定行的成员的方法。

      • Methods inherited from class javafx.scene.control.skin.CellSkinBase

        cellSizeProperty, getCellSize, getClassCssMetaData, getCssMetaData

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxWidth, computeMinWidth, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • Property Detail

      • graphic

        protected ObjectProperty<Node> graphicProperty
        返回在公开节点内部绘制的图形。 当没有图形显示时，Null是可以接受的。 通常这是与TreeItem（即treeItem.getGraphic（））相关联的图形，而不是与单元格关联的图形。

    • 构造方法详细信息

      • TableRowSkinBase

        public TableRowSkinBase​(C control)
        创建一个新的TableRowSkinBase实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。
        参数
        control - 应该安装这个皮肤的控制。

    • 方法详细信息

      • createCell

        protected abstract R createCell​(TableColumnBase<T,?> tc)
        创建适用于表示给定表列实例的新单元实例。
        参数
        tc - 表列
        结果
        创建的单元格

      • updateCell

        protected abstract void updateCell​(R cell,
                                   C row)
        允许给定单元格被告知它是给定行的成员的方法。 如何实现它取决于实际的单元实现。
        参数
        cell - 要通知它所有者行的单元格。
        row - 将在给定单元格上设置的行。

      • getTableColumn

        protected abstract TableColumnBase<T,?> getTableColumn​(R cell)
        返回给定单元格实例的TableColumnBase实例。
        参数
        cell - 需要TableColumn的单元格。
        结果
        表列

      • getVisibleLeafColumns

        protected abstract ObservableList<? extends TableColumnBase> getVisibleLeafColumns​()
        返回一个不可修改的列表，其中包含当前可见的叶子列。
        结果
        可见叶列列表

      • graphicProperty

        protected ObjectProperty<Node> graphicProperty​()
        返回在公开节点内部绘制的图形。 当没有图形显示时，Null是可以接受的。 通常这是与TreeItem（即treeItem.getGraphic（））相关联的图形，而不是与单元格关联的图形。

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
        重写：
        layoutChildren在 LabeledSkinBase<C extends IndexedCell>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算此SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 LabeledSkinBase<C extends IndexedCell>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 LabeledSkinBase<C extends IndexedCell>
        参数
        width - 如果首选的高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 LabeledSkinBase<C extends IndexedCell>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 LabeledSkinBase<C extends IndexedCell>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        A double representing the maximum height of this Skin.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TableViewSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.VirtualContainerBase<C,I>
        • javafx.scene.control.skin.TableViewSkinBase<T,T,TableView<T>,TableRow<T>,TableColumn<T,?>>
          • javafx.scene.control.skin.TableViewSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class TableViewSkin<T>
extends TableViewSkinBase<T,T,TableView<T>,TableRow<T>,TableColumn<T,?>>
    默认皮肤实现为TableView控件。
    从以下版本开始：
    9
    另请参见：
    TableView

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableViewSkin​(TableView<T> control)
      创建一个新的TableViewSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      protected int getItemCount​()
      返回此容器中的项目总数，包括当前未隐藏的项目的总数。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, consumeMouseEvents, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.TableViewSkinBase

        computePrefHeight, computePrefWidth, createTableHeaderRow, layoutChildren, updateItemCount

      • Methods inherited from class javafx.scene.control.skin.VirtualContainerBase

        markItemCountDirty

    • 构造方法详细信息

      • TableViewSkin

        public TableViewSkin​(TableView<T> control)
        创建一个新的TableViewSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 该皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用之后 ，方法Skin.getSkinnable()和Skin.getNode()应该返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 TableViewSkinBase<T,T,TableView<T>,TableRow<T>,TableColumn<T,?>>

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 TableViewSkinBase<T,T,TableView<T>,TableRow<T>,TableColumn<T,?>>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)

      • executeAccessibleAction

        protected void executeAccessibleAction​(AccessibleAction action,
                                       Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 SkinBase<TableView<T>>
        参数
        action - 要执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction ， Node.executeAccessibleAction(javafx.scene.AccessibleAction, java.lang.Object...)

      • getItemCount

        protected int getItemCount​()
        返回此容器中的项目总数，包括当前未隐藏的项目的总数。
        Specified by:
        getItemCount在 VirtualContainerBase<TableView<T>,TableRow<T>>
        结果
        此容器中的项目总数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableViewSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.VirtualContainerBase<C,I>
        • javafx.scene.control.skin.TableViewSkinBase<M,S,C,I,TC>
  • 参数类型
    M - 存储在每行中的项目的类型（对于TableView，这是项目列表的类型，对于TreeTableView，这是TreeItem的类型）。
    S - 由选择模型表示的项目的类型（对于TableView，这又是项目列表的类型，对于TreeTableView，这是与M类型相同的TreeItem）。
    C - 虚拟化控件的类型（例如TableView，TreeTableView）
    I - 此虚拟化控件使用的单元格类型（例如TableRow，TreeTableRow）
    TC - 此虚拟化控件使用的TableColumnBase的类型（例如TableColumn，TreeTableColumn）
    All Implemented Interfaces:
    Skin<M>
    已知直接子类：
    TableViewSkin ， TreeTableViewSkin

    public abstract class TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>
extends VirtualContainerBase<C,I>
    TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。
    从以下版本开始：
    9
    另请参见：
    TableView ， TreeTableView ， TableViewSkin ， TreeTableViewSkin

    • 构造方法摘要

      构造方法
      Constructor 描述
      TableViewSkinBase​(C control)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      protected TableHeaderRow createTableHeaderRow​()
      创建一个新的TableHeaderRow实例。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected void updateItemCount​()
      当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.VirtualContainerBase

        getItemCount, markItemCountDirty

    • 构造方法详细信息

      • TableViewSkinBase

        public TableViewSkinBase​(C control)
        参数
        control - 控制

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<M>
        重写：
        dispose在 SkinBase<C extends Control>

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<C extends Control>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<C extends Control>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 VirtualContainerBase<C extends Control,I extends IndexedCell<M>>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • createTableHeaderRow

        protected TableHeaderRow createTableHeaderRow​()
        创建一个新的TableHeaderRow实例。 默认情况下，此方法不应被覆盖，但在某些情况下，它是有意义的（例如，测试或需要极端定制时）。
        结果
        一个新的TableHeaderRow实例。

      • updateItemCount

        protected void updateItemCount​()
        当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。 此方法应重新计算料品数量，并存储以供将来使用的VirtualContainerBase.getItemCount()方法。
        Specified by:
        updateItemCount在 VirtualContainerBase<C extends Control,I extends IndexedCell<M>>

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute中的 SkinBase<C extends Control>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TabPaneSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TabPaneSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<TabPane>
      • javafx.scene.control.skin.TabPaneSkin
  • All Implemented Interfaces:
    Skin<TabPane>

    public class TabPaneSkin
extends SkinBase<TabPane>
    默认皮肤实现为TabPane控件。
    从以下版本开始：
    9
    另请参见：
    TabPane

    • 构造方法摘要

      构造方法
      Constructor 描述
      TabPaneSkin​(TabPane control)
      创建一个新的TabPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)
      基于第一个受管理的子节点计算基线偏移量。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • TabPaneSkin

        public TabPaneSkin​(TabPane control)
        创建一个新的TabPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 该皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<TabPane>
        重写：
        dispose在 SkinBase<TabPane>

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<TabPane>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<TabPane>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeBaselineOffset

        public double computeBaselineOffset​(double topInset,
                                    double rightInset,
                                    double bottomInset,
                                    double leftInset)
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        computeBaselineOffset在 SkinBase<TabPane>
        参数
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        基线偏移

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<TabPane>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 SkinBase<TabPane>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        说明从类别复制： SkinBase
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<TabPane>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextAreaSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TextAreaSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<T>
      • javafx.scene.control.skin.TextInputControlSkin<TextArea>
        • javafx.scene.control.skin.TextAreaSkin
  • All Implemented Interfaces:
    Skin<T>

    public class TextAreaSkin
extends TextInputControlSkin<TextArea>
    默认皮肤实现为TextArea控件。
    从以下版本开始：
    9
    另请参见：
    TextArea

    • Property Summary

      • Properties inherited from class javafx.scene.control.skin.TextInputControlSkin

        forwardBias, highlightFill, highlightTextFill, promptTextFill, textFill

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.control.skin.TextInputControlSkin

        TextInputControlSkin.Direction, TextInputControlSkin.TextUnit

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextAreaSkin​(TextArea control)
      创建一个新的TextAreaSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected void addHighlight​(List<? extends Node> nodes, int start)
      从输入法添加组合文本的高亮。
      double computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)
      基于第一个受管理的子节点计算基线偏移量。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      Bounds getCaretBounds​()
      Rectangle2D getCharacterBounds​(int index)
      返回给定索引处字符的边界。
      HitInfo getIndex​(double x, double y)
      执行命中测试，映射到内容中的索引。
      protected int getInsertionPoint​(double x, double y)
      返回给定位置的插入点。
      Point2D getMenuPosition​()
      根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。
      protected PathElement[] | getRangeShape​(int start, int end)
      protected PathElement[] | getUnderlineShape​(int start, int end)
      protected void invalidateMetrics​()
      对TextInputControl的缓存最小和最小大小无效。
      protected void layoutChildren​(double contentX, double contentY, double contentWidth, double contentHeight)
      在场景图的布局过程中调用。
      void moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)
      按照给定的方向，以指定文本单位之一移动插入符号。
      void positionCaret​(HitInfo hit, boolean select)
      将插入符号移动到指定的位置。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected void removeHighlight​(List<? extends Node> nodes)
      从Input Method中删除组合文本的高亮。
      protected void scrollCharacterToVisible​(int index)
      确保给定索引处的字符是可见的。
      protected void updateHighlightFill​()
      当highlightFill属性更改时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, consumeMouseEvents, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.TextInputControlSkin

        executeAccessibleAction, forwardBiasProperty, getClassCssMetaData, getCssMetaData, getHighlightFill, getHighlightTextFill, getPromptTextFill, getTextFill, handleInputMethodEvent, highlightFillProperty, highlightTextFillProperty, isForwardBias, maskText, promptTextFillProperty, setCaretAnimating, setForwardBias, setHighlightFill, setHighlightTextFill, setPromptTextFill, setTextFill, textFillProperty, updateHighlightTextFill, updateTextFill

    • 构造方法详细信息

      • TextAreaSkin

        public TextAreaSkin​(TextArea control)
        创建一个新的TextAreaSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • invalidateMetrics

        protected void invalidateMetrics​()
        对TextInputControl的缓存最小和最小大小无效。
        重写：
        invalidateMetrics在 TextInputControlSkin<TextArea>

      • layoutChildren

        protected void layoutChildren​(double contentX,
                              double contentY,
                              double contentWidth,
                              double contentHeight)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<TextArea>
        参数
        contentX - x位置
        contentY - y位置
        contentWidth - 宽度
        contentHeight - 高度

      • updateHighlightFill

        protected void updateHighlightFill​()
        当highlightFill属性更改时调用。
        重写：
        updateHighlightFill在 TextInputControlSkin<TextArea>

      • getIndex

        public HitInfo getIndex​(double x,
                        double y)
        执行命中测试，映射到内容中的索引。
        参数
        x - 点的x坐标。
        y - 点的y坐标。
        结果
        描述索引和正向偏差的 HitInfo对象。

      • moveCaret

        public void moveCaret​(TextInputControlSkin.TextUnit unit,
                      TextInputControlSkin.Direction dir,
                      boolean select)
        按照给定的方向，以指定文本单位之一移动插入符号。 请注意，只有某些组合有效，具体取决于实现的子类。
        Specified by:
        moveCaret在 TextInputControlSkin<TextArea>
        参数
        unit - 要移动的文本单位。
        dir - 运动方向。
        select - 是否将选择扩展到新的定位。

      • getUnderlineShape

        protected PathElement[] getUnderlineShape​(int start,
                                          int end)
        Specified by:
        getUnderlineShape在 TextInputControlSkin<TextArea>
        参数
        start - 开始
        end - 结束
        结果
        描述给定范围的下划线形状的路径元素。

      • getRangeShape

        protected PathElement[] getRangeShape​(int start,
                                      int end)
        Specified by:
        getRangeShape在 TextInputControlSkin<TextArea>
        参数
        start - 开始
        end - 结束
        结果
        描述给定范围文本的边界矩形的路径元素。

      • addHighlight

        protected void addHighlight​(List<? extends Node> nodes,
                            int start)
        从输入法添加组合文本的高亮。
        Specified by:
        addHighlight在 TextInputControlSkin<TextArea>
        参数
        nodes - 节点列表
        start - 开始

      • removeHighlight

        protected void removeHighlight​(List<? extends Node> nodes)
        从Input Method中删除组合文本的高亮。
        Specified by:
        removeHighlight在 TextInputControlSkin<TextArea>
        参数
        nodes - 节点列表

      • getMenuPosition

        public Point2D getMenuPosition​()
        根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。 这仅在触摸显示器上支持，并且不使用鼠标的位置。
        重写：
        getMenuPosition在 TextInputControlSkin<TextArea>
        结果
        用于此上下文菜单的位置

      • getCaretBounds

        public Bounds getCaretBounds​()
        结果
        相对于 Bounds ，插入符号形状的 TextArea 。

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<TextArea>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T extends TextInputControl>
        重写：
        dispose在 SkinBase<TextArea>

      • computeBaselineOffset

        public double computeBaselineOffset​(double topInset,
                                    double rightInset,
                                    double bottomInset,
                                    double leftInset)
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        computeBaselineOffset在 SkinBase<TextArea>
        参数
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        基线偏移

      • getInsertionPoint

        protected int getInsertionPoint​(double x,
                                double y)
        返回给定位置的插入点。
        重写：
        getInsertionPoint在 TextInputControlSkin<TextArea>
        参数
        x - x位置
        y - y位置
        结果
        给定位置的插入点

      • positionCaret

        public void positionCaret​(HitInfo hit,
                          boolean select)
        将插入符号移动到指定的位置。
        参数
        hit - 插入符号的新位置和向前偏移。
        select - 是否将选择扩展到新位置。

      • getCharacterBounds

        public Rectangle2D getCharacterBounds​(int index)
        返回给定索引处字符的边界。
        重写：
        getCharacterBounds在 TextInputControlSkin<TextArea>
        参数
        index - 索引
        结果
        在给定索引处的字符的边界

      • scrollCharacterToVisible

        protected void scrollCharacterToVisible​(int index)
        确保给定索引处的字符是可见的。
        重写：
        scrollCharacterToVisible在 TextInputControlSkin<TextArea>
        参数
        index - the index
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextFieldSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TextFieldSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<T>
      • javafx.scene.control.skin.TextInputControlSkin<TextField>
        • javafx.scene.control.skin.TextFieldSkin
  • All Implemented Interfaces:
    Skin<T>

    public class TextFieldSkin
extends TextInputControlSkin<TextField>
    默认皮肤实现为TextField控件。
    从以下版本开始：
    9
    另请参见：
    TextField

    • Property Summary

      • Properties inherited from class javafx.scene.control.skin.TextInputControlSkin

        forwardBias, highlightFill, highlightTextFill, promptTextFill, textFill

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.control.skin.TextInputControlSkin

        TextInputControlSkin.Direction, TextInputControlSkin.TextUnit

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextFieldSkin​(TextField control)
      创建一个新的TextFieldSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected void addHighlight​(List<? extends Node> nodes, int start)
      从输入法添加组合文本的高亮。
      double computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)
      基于第一个受管理的子节点计算基线偏移量。
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      void deleteChar​(boolean previous)
      如果没有选择，则从文本中删除当前插入符号位置之后或之前的字符，如果有选择则删除选择。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      Rectangle2D getCharacterBounds​(int index)
      返回给定索引处字符的边界。
      HitInfo getIndex​(double x, double y)
      执行命中测试，映射到内容中的索引。
      Point2D getMenuPosition​()
      根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。
      protected PathElement[] | getRangeShape​(int start, int end)
      protected PathElement[] | getUnderlineShape​(int start, int end)
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      protected String maskText​(String txt)
      子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。
      void moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)
      按照给定的方向，以指定文本单位之一移动插入符号。
      void positionCaret​(HitInfo hit, boolean select)
      将插入符号移动到指定的位置。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected void removeHighlight​(List<? extends Node> nodes)
      从Input Method中删除组合文本的高亮。
      void replaceText​(int start, int end, String txt)
      用给定的文本替换一系列的字符。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeMaxWidth, computeMinWidth, consumeMouseEvents, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.TextInputControlSkin

        executeAccessibleAction, forwardBiasProperty, getClassCssMetaData, getCssMetaData, getHighlightFill, getHighlightTextFill, getInsertionPoint, getPromptTextFill, getTextFill, handleInputMethodEvent, highlightFillProperty, highlightTextFillProperty, invalidateMetrics, isForwardBias, promptTextFillProperty, scrollCharacterToVisible, setCaretAnimating, setForwardBias, setHighlightFill, setHighlightTextFill, setPromptTextFill, setTextFill, textFillProperty, updateHighlightFill, updateHighlightTextFill, updateTextFill

    • 构造方法详细信息

      • TextFieldSkin

        public TextFieldSkin​(TextField control)
        创建一个新的TextFieldSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T extends TextInputControl>
        重写：
        dispose在 SkinBase<TextField>

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<TextField>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<TextField>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<TextField>
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<TextField>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • computeBaselineOffset

        public double computeBaselineOffset​(double topInset,
                                    double rightInset,
                                    double bottomInset,
                                    double leftInset)
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        computeBaselineOffset在 SkinBase<TextField>
        参数
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        基线偏移

      • replaceText

        public void replaceText​(int start,
                        int end,
                        String txt)
        用给定的文本替换一系列的字符。 从行为类调用此实现，而不是TextInputControl提供的实现，以确保文本根据需要滚动。
        参数
        start - 范围内的起始索引（含）。 这必须是> = 0和<结束。
        end - 范围内的结束索引，独占。 这是一个删除的最后一个字符（与String操作方法一致）。 这必须>开始，而<=文本的长度。
        txt - 要替换范围的文本。 这不能为空。
        另请参见：
        TextInputControl.replaceText(int, int, String)

      • deleteChar

        public void deleteChar​(boolean previous)
        如果没有选择，则从文本中删除当前插入符号位置之后或之前的字符，如果有选择则删除选择。 从行为类调用此实现，而不是TextInputControl提供的实现，以确保文本根据需要滚动。
        参数
        previous - 是否删除前一个字符。

      • getIndex

        public HitInfo getIndex​(double x,
                        double y)
        执行命中测试，映射到内容中的索引。
        参数
        x - 点的x坐标。
        y - 点的y坐标。
        结果
        描述索引和正向偏差的 HitInfo对象。

      • positionCaret

        public void positionCaret​(HitInfo hit,
                          boolean select)
        将插入符号移动到指定的位置。
        参数
        hit - 插入符号的新位置和向前偏移。
        select - 是否将选择扩展到新的位置。

      • getCharacterBounds

        public Rectangle2D getCharacterBounds​(int index)
        返回给定索引处字符的边界。
        重写：
        getCharacterBounds在 TextInputControlSkin<TextField>
        参数
        index - 索引
        结果
        在给定索引处的字符的边界

      • getUnderlineShape

        protected PathElement[] getUnderlineShape​(int start,
                                          int end)
        Specified by:
        getUnderlineShape在 TextInputControlSkin<TextField>
        参数
        start - 开始
        end - 结束
        结果
        描述给定范围的下划线形状的路径元素。

      • getRangeShape

        protected PathElement[] getRangeShape​(int start,
                                      int end)
        Specified by:
        getRangeShape在 TextInputControlSkin<TextField>
        参数
        start - 开始
        end - 结束
        结果
        描述给定范围文本的边界矩形的路径元素。

      • addHighlight

        protected void addHighlight​(List<? extends Node> nodes,
                            int start)
        从输入法添加组合文本的高亮。
        Specified by:
        addHighlight在 TextInputControlSkin<TextField>
        参数
        nodes - 节点列表
        start - 开始

      • removeHighlight

        protected void removeHighlight​(List<? extends Node> nodes)
        从Input Method中删除组合文本的高亮。
        Specified by:
        removeHighlight在 TextInputControlSkin<TextField>
        参数
        nodes - 节点列表

      • moveCaret

        public void moveCaret​(TextInputControlSkin.TextUnit unit,
                      TextInputControlSkin.Direction dir,
                      boolean select)
        按照给定的方向，以指定文本单位之一移动插入符号。 请注意，只有某些组合有效，具体取决于实现的子类。
        Specified by:
        moveCaret在 TextInputControlSkin<TextField>
        参数
        unit - 要移动的文本的单位。
        dir - 运动方向。
        select - 是否将选择扩展到新的定位。

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<TextField>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • getMenuPosition

        public Point2D getMenuPosition​()
        根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。 这仅在触摸显示器上支持，并且不使用鼠标的位置。
        重写：
        getMenuPosition在 TextInputControlSkin<TextField>
        结果
        用于此上下文菜单的位置

      • maskText

        protected String maskText​(String txt)
        子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。 这用于在PasswordField中显示项目符号。
        重写：
        maskText在 TextInputControlSkin<TextField>
        参数
        txt - 可能需要屏蔽的内容。
        结果
        替换字符串。 这可能只是输入字符串，也可以是与输入字符串长度相同的替换字符串。

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<TextField>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextInputControlSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TextInputControlSkin<T extends TextInputControl>

  • java.lang.Object
    • javafx.scene.control.SkinBase<T>
      • javafx.scene.control.skin.TextInputControlSkin<T>
  • All Implemented Interfaces:
    Skin<T>
    已知直接子类：
    TextAreaSkin ， TextFieldSkin

    public abstract class TextInputControlSkin<T extends TextInputControl>
extends SkinBase<T>
    文本输入皮肤的抽象基类。
    从以下版本开始：
    9
    另请参见：
    TextFieldSkin ， TextAreaSkin

    • Property Summary

      Properties
      Type | Property | 描述
      protected BooleanProperty forwardBias
      插入偏倚的内容。 真正意味着对前进角色的偏见（true = leading / false = trailing）
      protected ObjectProperty<Paint> highlightFill
      突出显示时用于文本的填充。
      protected ObjectProperty<Paint> | highlightTextFill
      protected ObjectProperty<Paint> | promptTextFill
      protected ObjectProperty<Paint> textFill
      在正常条件下用于文本的填充

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TextInputControlSkin.Direction
      方向名称用于插入符号移动。
      static class  TextInputControlSkin.TextUnit
      照相机运动的单位名称。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextInputControlSkin​(T control)
      创建一个新的TextInputControlSkin实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type | 方法 | 描述
      protected abstract void addHighlight​(List<? extends Node> nodes, int start)
      从输入法添加组合文本的高亮。
      protected void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      protected BooleanProperty forwardBiasProperty​()
      插入偏倚的内容。 真正意味着对前进角色的偏见（true = leading / false = trailing）
      Rectangle2D getCharacterBounds​(int index)
      返回给定索引处字符的边界。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      protected Paint getHighlightFill​()
      获取属性highlightFill的值。
      protected Paint getHighlightTextFill​()
      获取属性highlightTextFill的值。
      protected int getInsertionPoint​(double x, double y)
      返回给定位置的插入点。
      Point2D getMenuPosition​()
      根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。
      protected Paint getPromptTextFill​()
      获取属性promptTextFill的值。
      protected abstract PathElement[] | getRangeShape​(int start, int end)
      protected Paint getTextFill​()
      获取属性textFill的值。
      protected abstract PathElement[] | getUnderlineShape​(int start, int end)
      protected void | handleInputMethodEvent​(InputMethodEvent event)
      protected ObjectProperty<Paint> highlightFillProperty​()
      突出显示时用于文本的填充。
      protected ObjectProperty<Paint> | highlightTextFillProperty​()
      protected void invalidateMetrics​()
      对TextInputControl的缓存最小和最小大小无效。
      protected boolean isForwardBias​()
      获取属性forwardBias的值。
      protected String maskText​(String txt)
      子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。
      abstract void moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)
      按照给定的方向，以指定文本单位之一移动插入符号。
      protected ObjectProperty<Paint> | promptTextFillProperty​()
      protected abstract void removeHighlight​(List<? extends Node> nodes)
      从Input Method中删除组合文本的高亮。
      protected void scrollCharacterToVisible​(int index)
      确保给定索引处的字符是可见的。
      void setCaretAnimating​(boolean value)
      启动或停止插入符号闪烁。
      void setForwardBias​(boolean isLeading)
      设置属性forwardBias的值。
      protected void setHighlightFill​(Paint value)
      填充 Paint用于所选文本的背景。
      protected void setHighlightTextFill​(Paint value)
      填充 Paint用于所选文本的前景。
      protected void setPromptTextFill​(Paint value)
      填充 Paint用于前台提示文字颜色。
      protected void setTextFill​(Paint value)
      填充 Paint用于前景文字颜色。
      protected ObjectProperty<Paint> textFillProperty​()
      在正常条件下用于文本的填充
      protected void updateHighlightFill​()
      当highlightFill属性更改时调用。
      protected void updateHighlightTextFill​()
      当highlightTextFill属性更改时调用。
      protected void updateTextFill​()
      当textFill属性更改时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, consumeMouseEvents, dispose, getChildren, getNode, getSkinnable, layoutChildren, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • Property Detail

      • textFill

        protected final ObjectProperty<Paint> textFillProperty
        在正常条件下用于文本的填充
        另请参见：
        getTextFill() ， setTextFill(Paint)

      • promptTextFill

        protected final ObjectProperty<Paint> promptTextFillProperty
        另请参见：
        getPromptTextFill() ， setPromptTextFill(Paint)

      • highlightFill

        protected final ObjectProperty<Paint> highlightFillProperty
        突出显示时用于文本的填充。
        另请参见：
        getHighlightFill() ， setHighlightFill(Paint)

      • highlightTextFill

        protected final ObjectProperty<Paint> highlightTextFillProperty
        另请参见：
        getHighlightTextFill() ， setHighlightTextFill(Paint)

      • forwardBias

        protected final BooleanProperty forwardBiasProperty
        插入偏倚的内容。 真正意味着对前进角色的偏见（true = leading / false = trailing）
        另请参见：
        isForwardBias() ， setForwardBias(boolean)

    • 构造方法详细信息

      • TextInputControlSkin

        public TextInputControlSkin​(T control)
        创建一个新的TextInputControlSkin实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • setTextFill

        protected final void setTextFill​(Paint value)
        填充 Paint用于前景文字颜色。
        参数
        value - 文本填写

      • getTextFill

        protected final Paint getTextFill​()
        获取属性textFill的值。
        Property description:
        在正常条件下用于文本的填充

      • textFillProperty

        protected final ObjectProperty<Paint> textFillProperty​()
        在正常条件下用于文本的填充
        另请参见：
        getTextFill() ， setTextFill(Paint)

      • setPromptTextFill

        protected final void setPromptTextFill​(Paint value)
        填充 Paint用于前景提示文字颜色。
        参数
        value - 提示文字填写

      • getPromptTextFill

        protected final Paint getPromptTextFill​()
        获取属性promptTextFill的值。
        Property description:

      • promptTextFillProperty

        protected final ObjectProperty<Paint> promptTextFillProperty​()
        另请参见：
        getPromptTextFill() ， setPromptTextFill(Paint)

      • setHighlightFill

        protected final void setHighlightFill​(Paint value)
        填充 Paint用于所选文本的背景。
        参数
        value - 亮点填充

      • getHighlightFill

        protected final Paint getHighlightFill​()
        获取属性highlightFill的值。
        Property description:
        突出显示时用于文本的填充。

      • highlightFillProperty

        protected final ObjectProperty<Paint> highlightFillProperty​()
        突出显示时用于文本的填充。
        另请参见：
        getHighlightFill() ， setHighlightFill(Paint)

      • setHighlightTextFill

        protected final void setHighlightTextFill​(Paint value)
        填充 Paint用于所选文本的前景。
        参数
        value - 高亮文字填写

      • getHighlightTextFill

        protected final Paint getHighlightTextFill​()
        获取属性highlightTextFill的值。
        Property description:

      • highlightTextFillProperty

        protected final ObjectProperty<Paint> highlightTextFillProperty​()
        另请参见：
        getHighlightTextFill() ， setHighlightTextFill(Paint)

      • forwardBiasProperty

        protected final BooleanProperty forwardBiasProperty​()
        插入偏倚的内容。 真正意味着对前进角色的偏见（true = leading / false = trailing）
        另请参见：
        isForwardBias() ， setForwardBias(boolean)

      • setForwardBias

        public final void setForwardBias​(boolean isLeading)
        设置属性forwardBias的值。
        Property description:
        插入偏倚的内容。 真正意味着对前进角色的偏见（true = leading / false = trailing）

      • isForwardBias

        protected final boolean isForwardBias​()
        获取属性forwardBias的值。
        Property description:
        插入偏倚的内容。 真正意味着对前进角色的偏见（true = leading / false = trailing）

      • getUnderlineShape

        protected abstract PathElement[] getUnderlineShape​(int start,
                                                   int end)
        参数
        start - 开始
        end - 结束
        结果
        描述给定范围的下划线形状的路径元素。

      • getRangeShape

        protected abstract PathElement[] getRangeShape​(int start,
                                               int end)
        参数
        start - 开始
        end - 结束
        结果
        描述给定范围文本的边界矩形的路径元素。

      • addHighlight

        protected abstract void addHighlight​(List<? extends Node> nodes,
                                     int start)
        从输入法添加组合文本的高亮。
        参数
        nodes - 节点列表
        start - 开始

      • removeHighlight

        protected abstract void removeHighlight​(List<? extends Node> nodes)
        从Input Method中删除组合文本的高亮。
        参数
        nodes - 节点列表

      • moveCaret

        public abstract void moveCaret​(TextInputControlSkin.TextUnit unit,
                               TextInputControlSkin.Direction dir,
                               boolean select)
        按照给定的方向，以指定文本单位之一移动插入符号。 请注意，只有某些组合有效，具体取决于实现的子类。
        参数
        unit - 要移动的文本的单位。
        dir - 运动方向。
        select - 是否将选择扩展到新的定位。

      • getMenuPosition

        public Point2D getMenuPosition​()
        根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。 这仅在触摸显示器上支持，并且不使用鼠标的位置。
        结果
        用于此上下文菜单的位置

      • maskText

        protected String maskText​(String txt)
        子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。 这用于在PasswordField中显示项目符号。
        参数
        txt - 可能需要屏蔽的内容。
        结果
        替换字符串。 这可能只是输入字符串，也可以是与输入字符串长度相同的替换字符串。

      • getInsertionPoint

        protected int getInsertionPoint​(double x,
                                double y)
        返回给定位置的插入点。
        参数
        x - x位置
        y - y位置
        结果
        给定位置的插入点

      • getCharacterBounds

        public Rectangle2D getCharacterBounds​(int index)
        返回给定索引处字符的边界。
        参数
        index - 指数
        结果
        在给定索引处的字符的边界

      • scrollCharacterToVisible

        protected void scrollCharacterToVisible​(int index)
        确保给定索引处的字符是可见的。
        参数
        index - 索引

      • invalidateMetrics

        protected void invalidateMetrics​()
        对TextInputControl的缓存最小和最小大小无效。

      • updateTextFill

        protected void updateTextFill​()
        当textFill属性更改时调用。

      • updateHighlightFill

        protected void updateHighlightFill​()
        当highlightFill属性更改时调用。

      • updateHighlightTextFill

        protected void updateHighlightTextFill​()
        当highlightTextFill属性更改时调用。

      • handleInputMethodEvent

        protected void handleInputMethodEvent​(InputMethodEvent event)

      • setCaretAnimating

        public void setCaretAnimating​(boolean value)
        启动或停止插入符号闪烁。 行为类使用它暂时暂停闪烁，而用户正在键入或以其他方式移动插入符号。
        参数
        value - 插入符号是否应该闪烁。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 SkinBase<T extends TextInputControl>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。

      • executeAccessibleAction

        protected void executeAccessibleAction​(AccessibleAction action,
                                       Object... parameters)
        说明从类别复制： SkinBase
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 SkinBase<T extends TextInputControl>
        参数
        action - 执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction ， Node.executeAccessibleAction(javafx.scene.AccessibleAction, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextInputControlSkin.Direction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Enum TextInputControlSkin.Direction

  • java.lang.Object
    • java.lang.Enum<TextInputControlSkin.Direction>
      • javafx.scene.control.skin.TextInputControlSkin.Direction
  • All Implemented Interfaces:
    Serializable ， Comparable<TextInputControlSkin.Direction>
    Enclosing class:
    TextInputControlSkin < T extends TextInputControl >

    public static enum TextInputControlSkin.Direction
extends Enum<TextInputControlSkin.Direction>
    方向名称用于插入符号移动。
    另请参见：
    TextInputControlSkin.moveCaret(TextUnit, Direction, boolean)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BEGINNING
      DOWN
      END
      LEFT
      RIGHT
      UP

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TextInputControlSkin.Direction valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextInputControlSkin.Direction[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LEFT

        public static final TextInputControlSkin.Direction LEFT

      • RIGHT

        public static final TextInputControlSkin.Direction RIGHT

      • UP

        public static final TextInputControlSkin.Direction UP

      • DOWN

        public static final TextInputControlSkin.Direction DOWN

      • BEGINNING

        public static final TextInputControlSkin.Direction BEGINNING

      • END

        public static final TextInputControlSkin.Direction END

    • 方法详细信息

      • values

        public static TextInputControlSkin.Direction[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TextInputControlSkin.Direction c : TextInputControlSkin.Direction.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TextInputControlSkin.Direction valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TextInputControlSkin.TextUnit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Enum TextInputControlSkin.TextUnit

  • java.lang.Object
    • java.lang.Enum<TextInputControlSkin.TextUnit>
      • javafx.scene.control.skin.TextInputControlSkin.TextUnit
  • All Implemented Interfaces:
    Serializable ， Comparable<TextInputControlSkin.TextUnit>
    Enclosing class:
    TextInputControlSkin < T extends TextInputControl >

    public static enum TextInputControlSkin.TextUnit
extends Enum<TextInputControlSkin.TextUnit>
    照相机运动的单位名称。
    另请参见：
    TextInputControlSkin.moveCaret(TextUnit, Direction, boolean)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CHARACTER
      LINE
      PAGE
      PARAGRAPH
      WORD

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TextInputControlSkin.TextUnit valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextInputControlSkin.TextUnit[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CHARACTER

        public static final TextInputControlSkin.TextUnit CHARACTER

      • WORD

        public static final TextInputControlSkin.TextUnit WORD

      • LINE

        public static final TextInputControlSkin.TextUnit LINE

      • PARAGRAPH

        public static final TextInputControlSkin.TextUnit PARAGRAPH

      • PAGE

        public static final TextInputControlSkin.TextUnit PAGE

    • 方法详细信息

      • values

        public static TextInputControlSkin.TextUnit[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TextInputControlSkin.TextUnit c : TextInputControlSkin.TextUnit.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TextInputControlSkin.TextUnit valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TitledPaneSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TitledPaneSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<TitledPane>
        • javafx.scene.control.skin.TitledPaneSkin
  • All Implemented Interfaces:
    Skin<C>

    public class TitledPaneSkin
extends LabeledSkinBase<TitledPane>
    默认皮肤实现为TitledPane控件。
    从以下版本开始：
    9
    另请参见：
    TitledPane

    • 构造方法摘要

      构造方法
      Constructor 描述
      TitledPaneSkin​(TitledPane control)
      创建一个新的TitledPaneSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算并返回此Labeled的最小宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void layoutChildren​(double x, double y, double w, double h)
      布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
      protected void updateChildren​()
      更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • TitledPaneSkin

        public TitledPaneSkin​(TitledPane control)
        创建一个新的TitledPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends Labeled>
        重写：
        dispose在 SkinBase<TitledPane>

      • updateChildren

        protected void updateChildren​()
        更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。 仅使用实际必须使用的那些节点。 例如，使用GRAPHIC_ONLY的ContentDisplay不添加文本节点，并且使用TEXT_ONLY的ContentDisplay，不会添加图形。
        重写：
        updateChildren在 LabeledSkinBase<TitledPane>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
        重写：
        layoutChildren在 LabeledSkinBase<TitledPane>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        计算并返回此Labeled的最小宽度。 最小宽度是“...”宽度的较小值，带有实际文本的宽度。 这样，如果文本宽度本身小于省略号，那么我们应该将其用作最小宽度，否则省略号需要是最小宽度。

        我们在这里使用相同的计算方法，无论我们在谈论单个或多个标签。 所以一个多行的标签可能会发现，“...”的宽度与它将会得到的一样小。

        重写：
        computeMinWidth在 LabeledSkinBase<TitledPane>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 LabeledSkinBase<TitledPane>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 LabeledSkinBase<TitledPane>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 LabeledSkinBase<TitledPane>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 LabeledSkinBase<TitledPane>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToggleButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ToggleButtonSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<ToggleButton>
        • javafx.scene.control.skin.ToggleButtonSkin
  • All Implemented Interfaces:
    Skin<C>

    public class ToggleButtonSkin
extends LabeledSkinBase<ToggleButton>
    ToggleButton控件的默认皮肤实现。
    从以下版本开始：
    9
    另请参见：
    ToggleButton

    • 构造方法摘要

      构造方法
      Constructor 描述
      ToggleButtonSkin​(ToggleButton control)
      创建一个新的ToggleButtonSkin实例，将必需的子节点安装到控件 children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, layoutChildren, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ToggleButtonSkin

        public ToggleButtonSkin​(ToggleButton control)
        创建一个新的ToggleButtonSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<C extends Labeled>
        重写：
        dispose在 SkinBase<ToggleButton>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToolBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class ToolBarSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<ToolBar>
      • javafx.scene.control.skin.ToolBarSkin
  • All Implemented Interfaces:
    Skin<ToolBar>

    public class ToolBarSkin
extends SkinBase<ToolBar>
    默认皮肤实现为ToolBar控件。
    从以下版本开始：
    9
    另请参见：
    ToolBar

    • 构造方法摘要

      构造方法
      Constructor 描述
      ToolBarSkin​(ToolBar control)
      创建一个新的ToolBarSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最大允许宽度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的高度计算皮肤的最小允许宽度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, consumeMouseEvents, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • ToolBarSkin

        public ToolBarSkin​(ToolBar control)
        创建一个新的ToolBarSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<ToolBar>
        重写：
        dispose在 SkinBase<ToolBar>

      • computeMinWidth

        protected double computeMinWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最小允许宽度。
        重写：
        computeMinWidth在 SkinBase<ToolBar>
        参数
        height - 皮肤的高度，以防该值可能决定最小宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        表示此皮肤最小宽度的双倍。

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 SkinBase<ToolBar>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<ToolBar>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算这个SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<ToolBar>
        参数
        width - 如果首选的高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height,
                                 double topInset,
                                 double rightInset,
                                 double bottomInset,
                                 double leftInset)
        根据提供的高度计算皮肤的最大允许宽度。
        重写：
        computeMaxWidth在 SkinBase<ToolBar>
        参数
        height - 皮肤的高度，以防该值可能决定最大宽度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        双倍表示此皮肤的最大宽度。

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 SkinBase<ToolBar>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<ToolBar>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 SkinBase<ToolBar>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        描述从类别复制SkinBase
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<ToolBar>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)

      • executeAccessibleAction

        protected void executeAccessibleAction​(AccessibleAction action,
                                       Object... parameters)
        描述从类别复制： SkinBase
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 SkinBase<ToolBar>
        参数
        action - 要执行的操作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction ， Node.executeAccessibleAction(javafx.scene.AccessibleAction, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TooltipSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TooltipSkin

  • java.lang.Object
    • javafx.scene.control.skin.TooltipSkin
  • All Implemented Interfaces:
    Skin<Tooltip>

    public class TooltipSkin
extends Object
implements Skin<Tooltip>
    基于CSS的皮肤为Tooltip。 它主要涉及到基于弹出窗口控件的显示隐藏逻辑，特别是在这种情况下用于工具提示。 它还实现了一些Skin接口方法。 TooltipContent类是工具提示的实际皮肤实现。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TooltipSkin​(Tooltip t)
      为给定的Tooltip创建一个新的TooltipSkin实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      Node getNode​()
      获取代表此皮肤的节点。
      Tooltip getSkinnable​()
      获取此皮肤分配到的Skinnable。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TooltipSkin

        public TooltipSkin​(Tooltip t)
        为给定的Tooltip创建一个新的TooltipSkin实例。
        参数
        t - 工具提示

    • 方法详细信息

      • getSkinnable

        public Tooltip getSkinnable​()
        获取此皮肤分配到的Skinnable。 必须为仅一个Skinnable创建一个皮肤。 当皮肤从Skinnable中删除时，该值将只会从非空值转换为空值，并且仅作为对Skin.dispose()的调用的结果 。

        构建Skinnable的调用者还必须构建一个“皮肤”并正确建立“控件”和“皮肤”之间的关系。

        Specified by:
        getSkinnable在接口 Skin<Tooltip>
        结果
        非空的Skinnable，如果处理，则为空值。

      • getNode

        public Node getNode​()
        获取代表此皮肤的节点。 除非在调用Skin.dispose()之后 ，除非更改为null，否则绝对不能为空。
        Specified by:
        getNode在接口 Skin<Tooltip>
        结果
        非空节点，除了皮肤被处理之外。

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用之后 ，方法Skin.getSkinnable()和Skin.getNode()应该返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<Tooltip>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TreeCellSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<TreeCell<T>>
          • javafx.scene.control.skin.TreeCellSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class TreeCellSkin<T>
extends CellSkinBase<TreeCell<T>>
    默认皮肤实现为TreeCell控件。
    从以下版本开始：
    9
    另请参见：
    TreeCell

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty indent
      要获取树形单元格的左边距的树形空间乘以的空间量。

      • Properties inherited from class javafx.scene.control.skin.CellSkinBase

        cellSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeCellSkin​(TreeCell<T> control)
      创建一个新的TreeCellSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最大允许高度。
      protected double computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      根据提供的宽度计算皮肤的最小允许高度。
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      double getIndent​()
      获取属性缩进的值。
      DoubleProperty indentProperty​()
      要获取树形单元格的左边距的树形空间乘以的空间量。
      protected void layoutChildren​(double x, double y, double w, double h)
      布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
      void setIndent​(double value)
      设置属性缩进的值。
      protected void updateChildren​()
      更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

      • Methods inherited from class javafx.scene.control.skin.CellSkinBase

        cellSizeProperty, getCellSize

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxWidth, computeMinWidth, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • Property Detail

      • indent

        public final DoubleProperty indentProperty
        要获取树形单元格的左边距的树形空间乘以的空间量。 这可以从CSS设置
        另请参见：
        getIndent() ， setIndent(double)

    • 构造方法详细信息

      • TreeCellSkin

        public TreeCellSkin​(TreeCell<T> control)
        创建一个新的TreeCellSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 该皮肤应该安装到的控件。

    • 方法详细信息

      • setIndent

        public final void setIndent​(double value)
        设置属性缩进的值。
        Property description:
        要获取树形单元格的左边距的树形空间乘以的空间量。 这可以从CSS设置

      • getIndent

        public final double getIndent​()
        获取属性缩进的值。
        Property description:
        要获取树形单元格的左边距的树形空间乘以的空间量。 这可以从CSS设置

      • indentProperty

        public final DoubleProperty indentProperty​()
        要获取树形单元格的左边距的树形空间乘以的空间量。 这可以从CSS设置
        另请参见：
        getIndent() ， setIndent(double)

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 在处理调用之后 ，方法Skin.getSkinnable()和Skin.getNode()应该返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 SkinBase<TreeCell<T>>

      • updateChildren

        protected void updateChildren​()
        更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。 仅使用实际必须使用的那些节点。 例如，使用GRAPHIC_ONLY的ContentDisplay不添加文本节点，并且使用TEXT_ONLY的ContentDisplay，不会添加图形。
        重写：
        updateChildren在 LabeledSkinBase<TreeCell<T>>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
        重写：
        layoutChildren在 LabeledSkinBase<TreeCell<T>>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • computeMinHeight

        protected double computeMinHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最小允许高度。
        重写：
        computeMinHeight在 LabeledSkinBase<TreeCell<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最小高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最小高度。

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 LabeledSkinBase<TreeCell<T>>
        参数
        width - 如果首选高度取决于应该使用的宽度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插入
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • computeMaxHeight

        protected double computeMaxHeight​(double width,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        根据提供的宽度计算皮肤的最大允许高度。
        重写：
        computeMaxHeight在 LabeledSkinBase<TreeCell<T>>
        参数
        width - 皮肤的宽度，以防该值可能决定最大高度。
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素捕捉底部插图
        leftInset - 像素拍摄左边插图
        结果
        一个双倍代表这个皮肤的最大高度。

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 LabeledSkinBase<TreeCell<T>>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素啪嗒的底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 CellSkinBase<TreeCell<T>>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeTableCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TreeTableCellSkin<S,T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<C>
          • javafx.scene.control.skin.TableCellSkinBase<TreeItem<S>,T,TreeTableCell<S,T>>
            • javafx.scene.control.skin.TreeTableCellSkin<S,T>
  • 参数类型
    S - UI控件的类型（例如“行”的类型），它被包装在一个TreeItem中。
    T - 单元格中的内容类型，基于其TreeTableColumn 。
    All Implemented Interfaces:
    Skin<S>

    public class TreeTableCellSkin<S,T>
extends TableCellSkinBase<TreeItem<S>,T,TreeTableCell<S,T>>
    默认皮肤实现为TreeTableCell控件。
    从以下版本开始：
    9
    另请参见：
    TreeTableCell

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<TreeTableColumn<S,T>> tableColumn
      负责此单元格的TableColumnBase实例。

      • Properties inherited from class javafx.scene.control.skin.CellSkinBase

        cellSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTableCellSkin​(TreeTableCell<S,T> control)
      创建一个新的TreeTableCellSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      ReadOnlyObjectProperty<TreeTableColumn<S,T>> tableColumnProperty​()
      负责此单元格的TableColumnBase实例。

      • Methods inherited from class javafx.scene.control.skin.CellSkinBase

        cellSizeProperty, getCellSize, getClassCssMetaData, getCssMetaData

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, layoutLabelInArea, layoutLabelInArea, queryAccessibleAttribute, updateChildren

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.TableCellSkinBase

        computePrefWidth, getTableColumn, layoutChildren

    • Property Detail

      • tableColumn

        public ReadOnlyObjectProperty<TreeTableColumn<S,T>> tableColumnProperty
        负责此单元格的TableColumnBase实例。
        Specified by:
        tableColumnProperty在 TableCellSkinBase<TreeItem<S>,T,TreeTableCell<S,T>>
        另请参见：
        TableCellSkinBase.getTableColumn()

    • 构造方法详细信息

      • TreeTableCellSkin

        public TreeTableCellSkin​(TreeTableCell<S,T> control)
        创建一个新的TreeTableCellSkin实例，将必需的子节点安装到控件 children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<S>
        重写：
        dispose在 TableCellSkinBase<TreeItem<S>,T,TreeTableCell<S,T>>

      • tableColumnProperty

        public ReadOnlyObjectProperty<TreeTableColumn<S,T>> tableColumnProperty​()
        负责此单元格的TableColumnBase实例。
        Specified by:
        tableColumnProperty在 TableCellSkinBase<TreeItem<S>,T,TreeTableCell<S,T>>
        另请参见：
        TableCellSkinBase.getTableColumn()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeTableRowSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TreeTableRowSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.LabeledSkinBase<C>
        • javafx.scene.control.skin.CellSkinBase<C>
          • javafx.scene.control.skin.TableRowSkinBase<TreeItem<T>,TreeTableRow<T>,TreeTableCell<T,?>>
            • javafx.scene.control.skin.TreeTableRowSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class TreeTableRowSkin<T>
extends TableRowSkinBase<TreeItem<T>,TreeTableRow<T>,TreeTableCell<T,?>>
    默认皮肤实现为TreeTableRow控件。
    从以下版本开始：
    9
    另请参见：
    TreeTableRow

    • Property Summary

      Properties
      Type Property 描述
      protected ObjectProperty<Node> graphic
      返回在公开节点内部绘制的图形。
      DoubleProperty indent
      要获取树形单元格的左边距的树形空间乘以的空间量。

      • Properties inherited from class javafx.scene.control.skin.CellSkinBase

        cellSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTableRowSkin​(TreeTableRow<T> control)
      创建一个新的TreeTableRowSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected TreeTableCell<T,?> createCell​(TableColumnBase tcb)
      创建适用于表示给定表列实例的新单元实例。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
      返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      double getIndent​()
      获取属性缩进的值。
      protected TreeTableColumn<T,?> getTableColumn​(TreeTableCell cell)
      返回给定单元格实例的TableColumnBase实例。
      protected ObservableList<TreeTableColumn<T,?>> getVisibleLeafColumns​()
      返回一个不可修改的列表，其中包含当前可见的叶子列。
      protected ObjectProperty<Node> graphicProperty​()
      返回在公开节点内部绘制的图形。
      DoubleProperty indentProperty​()
      要获取树形单元格的左边距的树形空间乘以的空间量。
      protected void layoutChildren​(double x, double y, double w, double h)
      布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      void setIndent​(double value)
      设置属性缩进的值。
      protected void updateCell​(TreeTableCell<T,?> cell, TreeTableRow<T> row)
      允许给定单元格被告知它是给定行的成员的方法。
      protected void updateChildren​()
      更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

      • Methods inherited from class javafx.scene.control.skin.CellSkinBase

        cellSizeProperty, getCellSize

      • Methods inherited from class javafx.scene.control.skin.LabeledSkinBase

        computeBaselineOffset, computeMaxWidth, computeMinWidth, layoutLabelInArea, layoutLabelInArea

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        consumeMouseEvents, executeAccessibleAction, getChildren, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.TableRowSkinBase

        computeMaxHeight, computeMinHeight, computePrefHeight, computePrefWidth

    • Property Detail

      • indent

        public final DoubleProperty indentProperty
        要获取树形单元格的左边距的树形空间乘以的空间量。 这可以从CSS设置
        另请参见：
        getIndent() ， setIndent(double)

      • graphic

        protected ObjectProperty<Node> graphicProperty
        返回在公开节点内部绘制的图形。 当没有图形显示时，Null是可以接受的。 通常这是与TreeItem（即treeItem.getGraphic（））相关联的图形，而不是与单元格关联的图形。
        重写：
        graphicProperty在 TableRowSkinBase<TreeItem<T>,TreeTableRow<T>,TreeTableCell<T,?>>

    • 构造方法详细信息

      • TreeTableRowSkin

        public TreeTableRowSkin​(TreeTableRow<T> control)
        创建一个新的TreeTableRowSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
        参数
        control - 该皮肤应该安装到的控件。

    • 方法详细信息

      • setIndent

        public final void setIndent​(double value)
        设置属性缩进的值。
        Property description:
        要获取树形单元格的左边距的树形空间乘以的空间量。 这可以从CSS设置

      • getIndent

        public final double getIndent​()
        获取属性缩进的值。
        Property description:
        要获取树形单元格的左边距的树形空间乘以的空间量。 这可以从CSS设置

      • indentProperty

        public final DoubleProperty indentProperty​()
        要获取树形单元格的左边距的树形空间乘以的空间量。 这可以从CSS设置
        另请参见：
        getIndent() ， setIndent(double)

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose中的 SkinBase<TreeTableRow<T>>

      • updateChildren

        protected void updateChildren​()
        更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。 仅使用实际必须使用的那些节点。 例如，使用GRAPHIC_ONLY的ContentDisplay不添加文本节点，并且使用TEXT_ONLY的ContentDisplay，不会添加图形。
        重写：
        updateChildren在 LabeledSkinBase<TreeTableRow<T>>

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
        重写：
        layoutChildren在 TableRowSkinBase<TreeItem<T>,TreeTableRow<T>,TreeTableCell<T,?>>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • createCell

        protected TreeTableCell<T,?> createCell​(TableColumnBase tcb)
        创建适用于表示给定表列实例的新单元实例。
        Specified by:
        createCell在 TableRowSkinBase<TreeItem<T>,TreeTableRow<T>,TreeTableCell<T,?>>
        参数
        tcb - 表列
        结果
        创建的单元格

      • getVisibleLeafColumns

        protected ObservableList<TreeTableColumn<T,?>> getVisibleLeafColumns​()
        返回一个不可修改的列表，其中包含当前可见的叶子列。
        Specified by:
        getVisibleLeafColumns在 TableRowSkinBase<TreeItem<T>,TreeTableRow<T>,TreeTableCell<T,?>>
        结果
        可见叶列列表

      • updateCell

        protected void updateCell​(TreeTableCell<T,?> cell,
                          TreeTableRow<T> row)
        允许给定单元格被告知它是给定行的成员的方法。 如何实现它取决于实际的单元实现。
        Specified by:
        updateCell在 TableRowSkinBase<TreeItem<T>,TreeTableRow<T>,TreeTableCell<T,?>>
        参数
        cell - 我们要通知它的所有者行的单元格。
        row - 将在给定单元格上设置的行。

      • getTableColumn

        protected TreeTableColumn<T,?> getTableColumn​(TreeTableCell cell)
        返回给定单元格实例的TableColumnBase实例。
        Specified by:
        getTableColumn在 TableRowSkinBase<TreeItem<T>,TreeTableRow<T>,TreeTableCell<T,?>>
        参数
        cell - 需要TableColumn的单元格。
        结果
        表列

      • graphicProperty

        protected ObjectProperty<Node> graphicProperty​()
        返回在公开节点内部绘制的图形。 当没有图形显示时，Null是可以接受的。 通常这是与TreeItem（即treeItem.getGraphic（））相关联的图形，而不是与单元格关联的图形。
        重写：
        graphicProperty在 TableRowSkinBase<TreeItem<T>,TreeTableRow<T>,TreeTableCell<T,?>>

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        重写：
        getCssMetaData在 CellSkinBase<TreeTableRow<T>>
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 LabeledSkinBase<TreeTableRow<T>>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeTableViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TreeTableViewSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.VirtualContainerBase<C,I>
        • javafx.scene.control.skin.TableViewSkinBase<T,TreeItem<T>,TreeTableView<T>,TreeTableRow<T>,TreeTableColumn<T,?>>
          • javafx.scene.control.skin.TreeTableViewSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class TreeTableViewSkin<T>
extends TableViewSkinBase<T,TreeItem<T>,TreeTableView<T>,TreeTableRow<T>,TreeTableColumn<T,?>>
    默认皮肤实现为TreeTableView控件。
    从以下版本开始：
    9
    另请参见：
    TreeTableView

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeTableViewSkin​(TreeTableView<T> control)
      创建一个新的TreeTableViewSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      protected int getItemCount​()
      返回此容器中的项目总数，包括当前未隐藏的项目的总数。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected void updateItemCount​()
      当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, consumeMouseEvents, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.TableViewSkinBase

        computePrefHeight, computePrefWidth, createTableHeaderRow, layoutChildren

      • Methods inherited from class javafx.scene.control.skin.VirtualContainerBase

        markItemCountDirty

    • 构造方法详细信息

      • TreeTableViewSkin

        public TreeTableViewSkin​(TreeTableView<T> control)
        创建一个新的TreeTableViewSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 TableViewSkinBase<T,TreeItem<T>,TreeTableView<T>,TreeTableRow<T>,TreeTableColumn<T,?>>

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 TableViewSkinBase<T,TreeItem<T>,TreeTableView<T>,TreeTableRow<T>,TreeTableColumn<T,?>>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)

      • executeAccessibleAction

        protected void executeAccessibleAction​(AccessibleAction action,
                                       Object... parameters)
        描述从类别复制： SkinBase
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 SkinBase<TreeTableView<T>>
        参数
        action - 要执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction ， Node.executeAccessibleAction(javafx.scene.AccessibleAction, java.lang.Object...)

      • getItemCount

        protected int getItemCount​()
        返回此容器中的项目总数，包括当前未隐藏的项目的总数。
        Specified by:
        getItemCount在 VirtualContainerBase<TreeTableView<T>,TreeTableRow<T>>
        结果
        此容器中的项目总数

      • updateItemCount

        protected void updateItemCount​()
        当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。 该方法应重新计算料品数量，并存储以供将来使用的VirtualContainerBase.getItemCount()方法。
        重写：
        updateItemCount在 TableViewSkinBase<T,TreeItem<T>,TreeTableView<T>,TreeTableRow<T>,TreeTableColumn<T,?>>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class TreeViewSkin<T>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.VirtualContainerBase<TreeView<T>,TreeCell<T>>
        • javafx.scene.control.skin.TreeViewSkin<T>
  • All Implemented Interfaces:
    Skin<T>

    public class TreeViewSkin<T>
extends VirtualContainerBase<TreeView<T>,TreeCell<T>>
    默认皮肤实现为TreeView控件。
    从以下版本开始：
    9
    另请参见：
    TreeView

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeViewSkin​(TreeView control)
      创建一个新的TreeViewSkin实例，将必要的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected double computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选高度。
      protected double computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)
      计算这个 SkinBase的首选宽度。
      void dispose​()
      当Skinnable更换皮肤时，由Skinnable调用。
      protected void executeAccessibleAction​(AccessibleAction action, Object... parameters)
      该方法由辅助技术调用，请求执行由参数指示的动作。
      protected int getItemCount​()
      返回此容器中的项目总数，包括当前未隐藏的项目的总数。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      protected Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      protected void updateItemCount​()
      当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, consumeMouseEvents, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

      • Methods inherited from class javafx.scene.control.skin.VirtualContainerBase

        markItemCountDirty

    • 构造方法详细信息

      • TreeViewSkin

        public TreeViewSkin​(TreeView control)
        创建一个新的TreeViewSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 应该安装这个皮肤的控制。

    • 方法详细信息

      • dispose

        public void dispose​()
        当Skinnable更换皮肤时，由Skinnable调用。 该方法允许皮肤在不再需要皮肤后，实现任何必要的清理功能。 它可能用于释放本机资源。 方法Skin.getSkinnable()和Skin.getNode()应在调用处理后返回null。 呼叫处理两次无效。
        Specified by:
        dispose在接口 Skin<T>
        重写：
        dispose在 SkinBase<TreeView<T>>

      • computePrefWidth

        protected double computePrefWidth​(double height,
                                  double topInset,
                                  double rightInset,
                                  double bottomInset,
                                  double leftInset)
        计算这个SkinBase的首选宽度。 默认实现将这个宽度计算为被管理子对象以其首选宽度位于其当前位置时占用的区域的宽度。
        重写：
        computePrefWidth在 SkinBase<TreeView<T>>
        参数
        height - 如果首选宽度取决于应该使用的高度
        topInset - 像素拍摄顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width,
                                   double topInset,
                                   double rightInset,
                                   double bottomInset,
                                   double leftInset)
        计算SkinBase的首选高度。 默认实现将此高度计算为被管理儿童以其首选高度位于其当前位置时占用的区域的高度。
        重写：
        computePrefHeight在 SkinBase<TreeView<T>>
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        topInset - 像素拍摄的顶部插图
        rightInset - 像素拍摄正确的插图
        bottomInset - 像素攫取底部插图
        leftInset - 像素拍摄左边插图
        结果
        计算的优选高度

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 VirtualContainerBase<TreeView<T>,TreeCell<T>>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度

      • queryAccessibleAttribute

        protected Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                          Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 SkinBase<TreeView<T>>
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute ， Node.queryAccessibleAttribute(javafx.scene.AccessibleAttribute, java.lang.Object...)

      • executeAccessibleAction

        protected void executeAccessibleAction​(AccessibleAction action,
                                       Object... parameters)
        该方法由辅助技术调用，请求执行由参数指示的动作。

        此方法通常被子类覆盖，以实现特定角色所需的操作。
        如果未处理特定操作，则必须调用超类实现。

        重写：
        executeAccessibleAction在 SkinBase<TreeView<T>>
        参数
        action - 要执行的动作
        parameters - 可选参数列表
        另请参见：
        AccessibleAction ， Node.executeAccessibleAction(javafx.scene.AccessibleAction, java.lang.Object...)

      • getItemCount

        protected int getItemCount​()
        返回此容器中的项目总数，包括当前未隐藏的项目的总数。
        Specified by:
        getItemCount在 VirtualContainerBase<TreeView<T>,TreeCell<T>>
        结果
        此容器中的项目总数

      • updateItemCount

        protected void updateItemCount​()
        当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。 该方法应重新计算项目数量，并存储以供将来使用的VirtualContainerBase.getItemCount()方法。
        Specified by:
        updateItemCount在 VirtualContainerBase<TreeView<T>,TreeCell<T>>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.control.skin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.control.skin

  • Packages that use javafx.scene.control.skin
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
  • Classes in javafx.scene.control.skin used by javafx.scene.control.skin
    Class 描述
    CellSkinBase
    默认皮肤的实施为Cell控制和子类，如ListCell ， TreeCell ，等等。
    ComboBoxBaseSkin
    一个抽象类，旨在用作基于ComboBoxBase的 ComboBox类控件的基础外观 。
    ComboBoxPopupControl
    一个抽象类，扩展了ComboBoxBaseSkin的功能，以包含与显示ComboBox类控件作为弹出窗口相关的API。
    LabeledSkinBase
    控件的默认皮肤实现扩展为Labeled 。
    MenuButtonSkinBase
    MenuButtonSkin和SplitMenuButtonSkin的基类。
    NestedTableColumnHeader
    此类用于构造TableView的头。
    ProgressIndicatorSkin
    默认皮肤实现为27069727333333控件。
    TableCellSkinBase
    表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。
    TableColumnHeader
    负责绘制单列标题的区域。
    TableHeaderRow
    负责绘制整列列标题的区域。
    TableRowSkinBase
    TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。
    TableViewSkinBase
    TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。
    TextInputControlSkin
    文本输入皮肤的抽象基类。
    TextInputControlSkin.Direction
    方向名称用于插入符号移动。
    TextInputControlSkin.TextUnit
    照相机运动的单位名称。
    VirtualContainerBase
    父类控制其内容虚拟化和可滚动的外观。
    VirtualFlow
    使用基于单元的机制实现虚拟化容器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


VirtualContainerBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class VirtualContainerBase<C extends Control,I extends IndexedCell>

  • java.lang.Object
    • javafx.scene.control.SkinBase<C>
      • javafx.scene.control.skin.VirtualContainerBase<C,I>
  • All Implemented Interfaces:
    Skin<C>
    已知直接子类：
    ListViewSkin ， TableViewSkinBase ， TreeViewSkin

    public abstract class VirtualContainerBase<C extends Control,I extends IndexedCell>
extends SkinBase<C>
    父类控制其内容虚拟化和可滚动的外观。 该类处理与VirtualFlow类的交互，该类是处理此容器内容的虚拟化的主要类。
    从以下版本开始：
    9

    • 构造方法摘要

      构造方法
      Constructor 描述
      VirtualContainerBase​(C control)

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract int getItemCount​()
      返回此容器中的项目总数，包括当前未隐藏的项目的总数。
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      protected void markItemCountDirty​()
      调用此方法来指示应在下一个脉冲上更新项目计数。
      protected abstract void updateItemCount​()
      当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • VirtualContainerBase

        public VirtualContainerBase​(C control)
        参数
        control - 控制

    • 方法详细信息

      • getItemCount

        protected abstract int getItemCount​()
        返回此容器中的项目总数，包括当前未隐藏的项目的总数。
        结果
        此容器中的项目总数

      • updateItemCount

        protected abstract void updateItemCount​()
        当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。 该方法应重新计算项目数量，并存储以供将来使用的getItemCount()方法。

      • markItemCountDirty

        protected final void markItemCountDirty​()
        调用此方法来指示应在下一个脉冲上更新项目计数。

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<C extends Control>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - the height
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


VirtualFlow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.controls
软件包 javafx.scene.control.skin

Class VirtualFlow<T extends IndexedCell>

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.skin.VirtualFlow<T>
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class VirtualFlow<T extends IndexedCell>
extends Region
    使用基于单元的机制实现虚拟化容器。 这是为了UI控件使用的皮肤实现，例如ListView ， TreeView ， TableView ，和TreeTableView 。
    从以下版本开始：
    9

    • Property Summary

      Properties
      Type Property 描述
      IntegerProperty cellCount
      表示流中应该有的单元格数。
      ObjectProperty<Callback<VirtualFlow<T>,T>> cellFactory
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      DoubleProperty fixedCellSize
      为了优化目的，一些用例可以交换动态单元格的速度 - 如果fixedCellSize大于零，我们将使用它，而不是通过查询单元本身来确定它。
      BooleanProperty pannable
      指示VirtualFlow视口是否能够被用户平移（通过鼠标或触摸事件）。
      DoubleProperty position
      VirtualFlow在其单元格列表中的位置。
      BooleanProperty vertical
      表明虚拟化的主要方向。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      VirtualFlow​()
      创建一个新的VirtualFlow实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void addAllToPile​()
      此方法将从VirtualFlow中删除所有单元格，并将其删除，将其添加到“堆”（即，稍后可以使用单元格的位置）。
      IntegerProperty cellCountProperty​()
      表示流中应该有的单元格数。
      ObjectProperty<Callback<VirtualFlow<T>,T>> cellFactoryProperty​()
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      DoubleProperty fixedCellSizeProperty​()
      为了优化目的，一些用例可以交换动态单元格的速度 - 如果fixedCellSize大于零，我们将使用它，而不是通过查询单元本身来确定它。
      protected T getAvailableCell​(int prefIndex)
      获取可以在布局中使用的单元格。
      T getCell​(int index)
      返回给定索引的单元格。
      int getCellCount​()
      获取属性cellCount的值。
      Callback<VirtualFlow<T>,T> getCellFactory​()
      返回当前的单元格工厂。
      protected int getCellIndex​(T cell)
      返回给定单元格的索引。
      T getFirstVisibleCell​()
      找到并返回部分或完全可见的第一个非空IndexedCell。
      double getFixedCellSize​()
      获取属性fixedCellSize的值。
      T getLastVisibleCell​()
      查找并返回当前部分或完全可见的最后一个非空IndexedCell。
      double getPosition​()
      获取属性位置的值。
      T getVisibleCell​(int index)
      如果单元格已创建和布局，则获取给定索引的单元格。
      boolean isPannable​()
      获取pannable属性的值。
      boolean isVertical​()
      获取属性垂直的值。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      BooleanProperty pannableProperty​()
      指示VirtualFlow视口是否能够被用户平移（通过鼠标或触摸事件）。
      DoubleProperty positionProperty​()
      VirtualFlow在其单元格列表中的位置。
      void requestLayout​()
      被覆盖来实现更有效地支持布局。
      double scrollPixels​(double delta)
      给定一个代表像素数的增量值，该方法试图在给定的方向上移动VirtualFlow（正向下/向右，负向上/向左）给定的像素数。
      void scrollTo​(int index)
      调整单元格，使给定索引中的单元格在视口中完全可见。
      void scrollTo​(T cell)
      调整单元格，使所选单元格在视口中完全可见（但仅仅）。
      void scrollToBottom​(T lastCell)
      调整单元格的位置，使指定的单元格位于视口的末端。
      void scrollToTop​(int index)
      调整单元格，使给定索引中的单元格在视口中完全可见，并位于视口的最顶端。
      void scrollToTop​(T firstCell)
      调整单元格的位置，使指定的单元格位于视口的开头。
      void setCellCount​(int value)
      设置属性cellCount的值。
      void setCellFactory​(Callback<VirtualFlow<T>,T> value)
      设置要在VirtualFlow中使用的新单元格工厂。
      protected void setCellIndex​(T cell, int index)
      VirtualFlow使用此方法设置单元 格索引（而不是直接调用 IndexedCell.updateIndex(int) ），因此如果感兴趣，它是子类覆盖的完美场所。
      void setFixedCellSize​(double value)
      设置属性fixedCellSize的值。
      protected void setHeight​(double value)
      设置属性高度的值。
      void setPannable​(boolean value)
      设置pannable属性的值。
      void setPosition​(double value)
      设置属性位置的值。
      void setVertical​(boolean value)
      设置属性垂直的值。
      protected void setWidth​(double value)
      设置属性宽度的值。
      BooleanProperty verticalProperty​()
      表明虚拟化的主要方向。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, getBackground, getBorder, getClassCssMetaData, getCssMetaData, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • vertical

        public final BooleanProperty verticalProperty
        表明虚拟化的主要方向。 如果是真的，则虚拟化的主要方向是垂直的，这意味着单元将垂直堆叠在一起。 如果为false，那么它们将彼此水平叠放。
        另请参见：
        isVertical() ， setVertical(boolean)

      • pannable

        public final BooleanProperty pannableProperty
        指示VirtualFlow视口是否能够被用户平移（通过鼠标或触摸事件）。
        另请参见：
        isPannable() ， setPannable(boolean)

      • cellCount

        public final IntegerProperty cellCountProperty
        表示流中应该有的单元格数。 VirtualFlow的用户必须正确设置。 当单元计数更改时，VirtualFlow将通过更新视觉效果进行响应。 如果支持单元格的项目更改，但计数未更改，则必须调用reconfigureCells（）函数来更新视觉效果。
        另请参见：
        getCellCount() ， setCellCount(int)

      • position

        public final DoubleProperty positionProperty
        VirtualFlow在其单元格列表中的位置。 这是介于0和1之间的值。
        另请参见：
        getPosition() ， setPosition(double)

      • fixedCellSize

        public final DoubleProperty fixedCellSizeProperty
        为了优化目的，一些用例可以交换动态单元格的速度 - 如果fixedCellSize大于零，我们将使用它，而不是通过查询单元本身来确定它。
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • cellFactory

        public final ObjectProperty<Callback<VirtualFlow<T extends IndexedCell>,T extends IndexedCell>> cellFactoryProperty

        设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。 在内部，VirtualFlow负责重用单元格，所有这些都是必需的，因为自定义单元格工厂可以从该函数返回可用于表示VirtualFlow中任何项目的单元格。

        有关更多详细信息，请参阅Cell类文档。

        另请参见：
        getCellFactory() ， setCellFactory(Callback)

    • 构造方法详细信息

      • VirtualFlow

        public VirtualFlow​()
        创建一个新的VirtualFlow实例。

    • 方法详细信息

      • setVertical

        public final void setVertical​(boolean value)
        设置属性垂直的值。
        Property description:
        表明虚拟化的主要方向。 如果是真的，则虚拟化的主要方向是垂直的，这意味着单元将垂直堆叠在一起。 如果为false，那么它们将彼此水平叠放。

      • isVertical

        public final boolean isVertical​()
        获取属性垂直的值。
        Property description:
        表明虚拟化的主要方向。 如果是真的，则虚拟化的主要方向是垂直的，这意味着单元将垂直堆叠在一起。 如果为false，那么它们将彼此水平叠放。

      • verticalProperty

        public final BooleanProperty verticalProperty​()
        表明虚拟化的主要方向。 如果是真的，则虚拟化的主要方向是垂直的，这意味着单元将垂直堆叠在一起。 如果为false，那么它们将彼此水平叠放。
        另请参见：
        isVertical() ， setVertical(boolean)

      • isPannable

        public final boolean isPannable​()
        获取pannable属性的值。
        Property description:
        指示VirtualFlow视口是否能够被用户平移（通过鼠标或触摸事件）。

      • setPannable

        public final void setPannable​(boolean value)
        设置pannable属性的值。
        Property description:
        指示VirtualFlow视口是否能够被用户平移（通过鼠标或触摸事件）。

      • pannableProperty

        public final BooleanProperty pannableProperty​()
        指示VirtualFlow视口是否能够被用户平移（通过鼠标或触摸事件）。
        另请参见：
        isPannable() ， setPannable(boolean)

      • getCellCount

        public final int getCellCount​()
        获取属性cellCount的值。
        Property description:
        表示流中应该有的单元格数。 VirtualFlow的用户必须正确设置。 当单元计数更改时，VirtualFlow将通过更新视觉效果进行响应。 如果支持单元格的项目更改，但计数未更改，则必须调用reconfigureCells（）函数来更新视觉效果。

      • setCellCount

        public final void setCellCount​(int value)
        设置属性cellCount的值。
        Property description:
        表示流中应该有的单元格数。 VirtualFlow的用户必须正确设置。 当单元计数更改时，VirtualFlow将通过更新视觉效果进行响应。 如果支持单元格的项目更改，但计数未更改，则必须调用reconfigureCells（）函数来更新视觉效果。

      • cellCountProperty

        public final IntegerProperty cellCountProperty​()
        表示流中应该有的单元格数。 VirtualFlow的用户必须正确设置。 当单元计数更改时，VirtualFlow将通过更新视觉效果进行响应。 如果支持单元格的项目更改，但计数未更改，则必须调用reconfigureCells（）函数来更新视觉效果。
        另请参见：
        getCellCount() ， setCellCount(int)

      • getPosition

        public final double getPosition​()
        获取属性位置的值。
        Property description:
        VirtualFlow在其单元格列表中的位置。 这是介于0和1之间的值。

      • setPosition

        public final void setPosition​(double value)
        设置属性位置的值。
        Property description:
        VirtualFlow在其单元格列表中的位置。 这是介于0和1之间的值。

      • positionProperty

        public final DoubleProperty positionProperty​()
        VirtualFlow在其单元格列表中的位置。 这是介于0和1之间的值。
        另请参见：
        getPosition() ， setPosition(double)

      • setFixedCellSize

        public final void setFixedCellSize​(double value)
        设置属性fixedCellSize的值。
        Property description:
        为了优化目的，一些用例可以交换动态单元格的速度 - 如果fixedCellSize大于零，我们将使用它，而不是通过查询单元本身来确定它。

      • getFixedCellSize

        public final double getFixedCellSize​()
        获取属性fixedCellSize的值。
        Property description:
        为了优化目的，一些用例可以交换动态单元格的速度 - 如果fixedCellSize大于零，我们将使用它，而不是通过查询单元本身来确定它。

      • fixedCellSizeProperty

        public final DoubleProperty fixedCellSizeProperty​()
        为了优化目的，一些用例可以交换动态单元格的速度 - 如果fixedCellSize大于零，我们将使用它，而不是通过查询单元本身来确定它。
        另请参见：
        getFixedCellSize() ， setFixedCellSize(double)

      • setCellFactory

        public final void setCellFactory​(Callback<VirtualFlow<T>,T> value)
        设置要在VirtualFlow中使用的新单元格工厂。 这将强制所有旧的单元格被丢弃，新的单元格将被创建与新的单元格工厂。
        参数
        value - 新 value

      • getCellFactory

        public final Callback<VirtualFlow<T>,T> getCellFactory​()
        返回当前的单元格工厂。
        结果
        目前的电池厂

      • cellFactoryProperty

        public final ObjectProperty<Callback<VirtualFlow<T>,T>> cellFactoryProperty​()

        设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。 在内部，VirtualFlow负责重用单元格，所有这些都是必需的，因为自定义单元格工厂可以从该函数返回可用于表示VirtualFlow中任何项目的单元格。

        有关详细信息，请参阅Cell类文档。

        另请参见：
        getCellFactory() ， setCellFactory(Callback)

      • requestLayout

        public void requestLayout​()
        被覆盖来实现更有效地支持布局。 通常可以将VirtualFlow视为不受管理的，因为只要位置发生变化或其他这样的事情发生变化，我们需要执行布局，但没有理由通知父母。 但是，当事情发生变化时，可能会影响首选大小（例如垂直，createCell和configCell），那么我们需要通知父级。
        重写：
        requestLayout在 Parent

      • layoutChildren

        protected void layoutChildren​()
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • setWidth

        protected void setWidth​(double value)
        设置属性宽度的值。
        重写：
        setWidth在 Region

      • setHeight

        protected void setHeight​(double value)
        设置属性高度的值。
        重写：
        setHeight在 Region

      • getAvailableCell

        protected T getAvailableCell​(int prefIndex)
        获取可以在布局中使用的单元格。 该功能将在可能的情况下从堆中重复使用单元格，并在必要时创建新的单元格。
        参数
        prefIndex - 首选指数
        结果
        可用的单元格

      • addAllToPile

        protected void addAllToPile​()
        此方法将从VirtualFlow中删除所有单元格，并将其删除，将其添加到“堆”（即，稍后可以使用单元格的位置）。 此方法受到保护，以允许子类正确清理。

      • getVisibleCell

        public T getVisibleCell​(int index)
        如果单元格已创建和布局，则获取给定索引的单元格。 “可见”有点不正确，单元格可能在视口中可能不可见（可能会被剪辑），但区分已创建和正在使用的单元格，而不是在堆中或未创建的单元格。
        参数
        index - 索引
        结果
        可见细胞

      • getLastVisibleCell

        public T getLastVisibleCell​()
        查找并返回当前部分或完全可见的最后一个非空IndexedCell。 如果没有单元格，或视口长度为0，则此函数可能返回null。
        结果
        最后一个可见单元格

      • getFirstVisibleCell

        public T getFirstVisibleCell​()
        找到并返回部分或完全可见的第一个非空IndexedCell。 这真的只有当没有单元格或视口长度为0时才返回null。
        结果
        第一个可见单元格

      • scrollToTop

        public void scrollToTop​(T firstCell)
        调整单元格的位置，使指定的单元格位于视口的开头。 给定的单元格必须已经是“活的”。
        参数
        firstCell - 第一个单元格

      • scrollToBottom

        public void scrollToBottom​(T lastCell)
        调整单元格的位置，使指定的单元格位于视口的末端。 给定的单元格必须已经是“活的”。
        参数
        lastCell - 最后一个单元格

      • scrollTo

        public void scrollTo​(T cell)
        调整单元格，使所选单元格在视口中完全可见（但仅仅）。
        参数
        cell - 电池

      • scrollTo

        public void scrollTo​(int index)
        调整单元格，使给定索引中的单元格在视口中完全可见。
        参数
        index - 索引

      • scrollToTop

        public void scrollToTop​(int index)
        调整单元格，使给定索引中的单元格在视口中完全可见，并位于视口的最顶端。
        参数
        index - 指数

      • scrollPixels

        public double scrollPixels​(double delta)
        给定一个代表像素数的增量值，该方法试图在给定的方向上移动VirtualFlow（正向下/向右，负向上/向左）给定的像素数。 它返回实际移动的像素数。
        参数
        delta - 差值
        结果
        实际移动的像素数

      • computePrefWidth

        protected double computePrefWidth​(double height)
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • getCell

        public T getCell​(int index)
        返回给定索引的单元格。 这可以被调用到任何单元格，包括超出cellCount定义的范围，在这种情况下将返回一个空单元格。 返回的值不应由于任何原因存储。
        参数
        index - 索引
        结果
        细胞

      • setCellIndex

        protected void setCellIndex​(T cell,
                            int index)
        VirtualFlow使用此方法设置单元 格索引（而不是直接调用 IndexedCell.updateIndex(int) ），因此如果感兴趣，它是子类覆盖的完美场所。
        参数
        cell - 索引将被更新的单元格。
        index - 单元格的新索引。

      • getCellIndex

        protected int getCellIndex​(T cell)
        返回给定单元格的索引。 这允许子类自定义如何检索单元格索引。
        参数
        cell - 细胞
        结果
        指数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.scene.control.skin.AccordionSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.AccordionSkin

No usage of javafx.scene.control.skin.AccordionSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ButtonBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ButtonBarSkin

No usage of javafx.scene.control.skin.ButtonBarSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ButtonSkin

No usage of javafx.scene.control.skin.ButtonSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.CellSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.CellSkinBase

  • Packages that use CellSkinBase
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of CellSkinBase in javafx.scene.control.skin

      Subclasses of CellSkinBase in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  DateCellSkin
      默认皮肤实现为DateCell控件。
      class  ListCellSkin<T>
      默认皮肤实现为ListCell控件。
      class  TableCellSkin<S,T>
      默认皮肤实现为TableCell控件。
      class  TableCellSkinBase<S,T,C extends IndexedCell<T>>
      表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。
      class  TableRowSkin<T>
      默认皮肤实现为TableRow控件。
      class  TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>
      TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。
      class  TreeCellSkin<T>
      默认皮肤实现为TreeCell控件。
      class  TreeTableCellSkin<S,T>
      默认皮肤实现为TreeTableCell控件。
      class  TreeTableRowSkin<T>
      默认皮肤实现为TreeTableRow控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.CheckBoxSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.CheckBoxSkin

No usage of javafx.scene.control.skin.CheckBoxSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ChoiceBoxSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ChoiceBoxSkin

No usage of javafx.scene.control.skin.ChoiceBoxSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ColorPickerSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ColorPickerSkin

No usage of javafx.scene.control.skin.ColorPickerSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ComboBoxBaseSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ComboBoxBaseSkin

  • Packages that use ComboBoxBaseSkin
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ComboBoxBaseSkin in javafx.scene.control.skin

      Subclasses of ComboBoxBaseSkin in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  ColorPickerSkin
      默认皮肤实现为ColorPicker控件。
      class  ComboBoxListViewSkin<T>
      默认皮肤实现为ComboBox控件。
      class  ComboBoxPopupControl<T>
      一个抽象类，扩展了ComboBoxBaseSkin的功能，以包含与显示ComboBox类控件作为弹出窗口相关的API。
      class  DatePickerSkin
      默认皮肤实现为DatePicker控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ComboBoxListViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ComboBoxListViewSkin

No usage of javafx.scene.control.skin.ComboBoxListViewSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ComboBoxPopupControl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ComboBoxPopupControl

  • Packages that use ComboBoxPopupControl
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ComboBoxPopupControl in javafx.scene.control.skin

      Subclasses of ComboBoxPopupControl in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  ColorPickerSkin
      默认皮肤实现为ColorPicker控件。
      class  ComboBoxListViewSkin<T>
      默认皮肤实现为ComboBox控件。
      class  DatePickerSkin
      默认皮肤实现为DatePicker控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ContextMenuSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ContextMenuSkin

No usage of javafx.scene.control.skin.ContextMenuSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.DateCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.DateCellSkin

No usage of javafx.scene.control.skin.DateCellSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.DatePickerSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.DatePickerSkin

No usage of javafx.scene.control.skin.DatePickerSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.HyperlinkSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.HyperlinkSkin

No usage of javafx.scene.control.skin.HyperlinkSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.LabeledSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.LabeledSkinBase

  • Packages that use LabeledSkinBase
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of LabeledSkinBase in javafx.scene.control.skin

      Subclasses of LabeledSkinBase in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  ButtonSkin
      默认皮肤实现为Button控件。
      class  CellSkinBase<C extends Cell>
      默认皮肤的实施为Cell控制和子类，如ListCell ， TreeCell ，等等。
      class  CheckBoxSkin
      默认皮肤实现为三态CheckBox控件。
      class  DateCellSkin
      默认皮肤实现为DateCell控件。
      class  HyperlinkSkin
      Hyperlink控件的默认皮肤实现。
      class  LabelSkin
      默认皮肤实现为Label控件。
      class  ListCellSkin<T>
      默认皮肤实现为ListCell控件。
      class  RadioButtonSkin
      默认皮肤实现为RadioButton控件。
      class  TableCellSkin<S,T>
      默认皮肤实现为TableCell控件。
      class  TableCellSkinBase<S,T,C extends IndexedCell<T>>
      表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。
      class  TableRowSkin<T>
      默认皮肤实现为TableRow控件。
      class  TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>
      TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。
      class  TitledPaneSkin
      默认皮肤实现为TitledPane控件。
      class  ToggleButtonSkin
      默认皮肤实现为ToggleButton控件。
      class  TreeCellSkin<T>
      默认皮肤实现为TreeCell控件。
      class  TreeTableCellSkin<S,T>
      默认皮肤实现为TreeTableCell控件。
      class  TreeTableRowSkin<T>
      TreeTableRow控件的默认皮肤实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.LabelSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.LabelSkin

No usage of javafx.scene.control.skin.LabelSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ListCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ListCellSkin

No usage of javafx.scene.control.skin.ListCellSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ListViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ListViewSkin

No usage of javafx.scene.control.skin.ListViewSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.MenuBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.MenuBarSkin

No usage of javafx.scene.control.skin.MenuBarSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.MenuButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.MenuButtonSkin

No usage of javafx.scene.control.skin.MenuButtonSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.MenuButtonSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.MenuButtonSkinBase

  • Packages that use MenuButtonSkinBase
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of MenuButtonSkinBase in javafx.scene.control.skin

      Subclasses of MenuButtonSkinBase in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  MenuButtonSkin
      默认皮肤实现为MenuButton控件。
      class  SplitMenuButtonSkin
      默认皮肤实现为SplitMenuButton控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.NestedTableColumnHeader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.NestedTableColumnHeader

  • Packages that use NestedTableColumnHeader
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of NestedTableColumnHeader in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return NestedTableColumnHeader
      Modifier and Type 方法 描述
      protected NestedTableColumnHeader TableHeaderRow.createRootHeader​()
      创建一个新的NestedTableColumnHeader实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.PaginationSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.PaginationSkin

No usage of javafx.scene.control.skin.PaginationSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ProgressBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ProgressBarSkin

No usage of javafx.scene.control.skin.ProgressBarSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ProgressIndicatorSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ProgressIndicatorSkin

  • Packages that use ProgressIndicatorSkin
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of ProgressIndicatorSkin in javafx.scene.control.skin

      Subclasses of ProgressIndicatorSkin in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  ProgressBarSkin
      ProgressBar控件的默认皮肤实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.RadioButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.RadioButtonSkin

No usage of javafx.scene.control.skin.RadioButtonSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ScrollBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ScrollBarSkin

No usage of javafx.scene.control.skin.ScrollBarSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ScrollPaneSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ScrollPaneSkin

No usage of javafx.scene.control.skin.ScrollPaneSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.SeparatorSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.SeparatorSkin

No usage of javafx.scene.control.skin.SeparatorSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.SliderSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.SliderSkin

No usage of javafx.scene.control.skin.SliderSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.SpinnerSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.SpinnerSkin

No usage of javafx.scene.control.skin.SpinnerSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.SplitMenuButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.SplitMenuButtonSkin

No usage of javafx.scene.control.skin.SplitMenuButtonSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.SplitPaneSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.SplitPaneSkin

No usage of javafx.scene.control.skin.SplitPaneSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TableCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TableCellSkin

No usage of javafx.scene.control.skin.TableCellSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TableCellSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TableCellSkinBase

  • Packages that use TableCellSkinBase
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableCellSkinBase in javafx.scene.control.skin

      Subclasses of TableCellSkinBase in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  TableCellSkin<S,T>
      默认皮肤实现为TableCell控件。
      class  TreeTableCellSkin<S,T>
      默认皮肤实现为TreeTableCell控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TableColumnHeader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TableColumnHeader

  • Packages that use TableColumnHeader
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableColumnHeader in javafx.scene.control.skin

      Subclasses of TableColumnHeader in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  NestedTableColumnHeader
      此类用于构造TableView的头。
      Methods in javafx.scene.control.skin that return TableColumnHeader
      Modifier and Type 方法 描述
      protected TableColumnHeader NestedTableColumnHeader.createTableColumnHeader​(TableColumnBase col)
      为给定的TableColumnBase实例创建一个新的TableColumnHeader实例。
      Methods in javafx.scene.control.skin that return types with arguments of type TableColumnHeader
      Modifier and Type 方法 描述
      ObservableList<TableColumnHeader> NestedTableColumnHeader.getColumnHeaders​()
      返回这个NestedTableColumnHeader的子代的TableColumnHeader实例的不可修改列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TableHeaderRow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TableHeaderRow

  • Packages that use TableHeaderRow
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableHeaderRow in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return TableHeaderRow
      Modifier and Type 方法 描述
      protected TableHeaderRow TableViewSkinBase.createTableHeaderRow​()
      创建一个新的TableHeaderRow实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TableRowSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TableRowSkin

No usage of javafx.scene.control.skin.TableRowSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TableRowSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TableRowSkinBase

  • Packages that use TableRowSkinBase
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableRowSkinBase in javafx.scene.control.skin

      Subclasses of TableRowSkinBase in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  TableRowSkin<T>
      默认皮肤实现为TableRow控件。
      class  TreeTableRowSkin<T>
      默认皮肤实现为TreeTableRow控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TableViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TableViewSkin

No usage of javafx.scene.control.skin.TableViewSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TableViewSkinBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TableViewSkinBase

  • Packages that use TableViewSkinBase
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TableViewSkinBase in javafx.scene.control.skin

      Subclasses of TableViewSkinBase in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  TableViewSkin<T>
      默认皮肤实现为TableView控件。
      class  TreeTableViewSkin<T>
      默认皮肤实现为TreeTableView控件。
      Constructors in javafx.scene.control.skin with parameters of type TableViewSkinBase
      Constructor 描述
      TableHeaderRow​(TableViewSkinBase skin)
      创建一个新的TableHeaderRow实例来可视化地表示控件的列标题区域，如TableView和TreeTableView 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TabPaneSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TabPaneSkin

No usage of javafx.scene.control.skin.TabPaneSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TextAreaSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TextAreaSkin

No usage of javafx.scene.control.skin.TextAreaSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TextFieldSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TextFieldSkin

No usage of javafx.scene.control.skin.TextFieldSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TextInputControlSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TextInputControlSkin

  • Packages that use TextInputControlSkin
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TextInputControlSkin in javafx.scene.control.skin

      Subclasses of TextInputControlSkin in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  TextAreaSkin
      默认皮肤实现为TextArea控件。
      class  TextFieldSkin
      默认皮肤实现为TextField控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TextInputControlSkin.Direction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TextInputControlSkin.Direction

  • Packages that use TextInputControlSkin.Direction
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TextInputControlSkin.Direction in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return TextInputControlSkin.Direction
      Modifier and Type 方法 描述
      static TextInputControlSkin.Direction TextInputControlSkin.Direction.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextInputControlSkin.Direction[] TextInputControlSkin.Direction.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control.skin with parameters of type TextInputControlSkin.Direction
      Modifier and Type 方法 描述
      void TextAreaSkin.moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)
      按照给定的方向，以指定文本单位之一移动插入符号。
      void TextFieldSkin.moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)
      按照给定的方向，以指定文本单位之一移动插入符号。
      abstract void TextInputControlSkin.moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)
      按照给定的方向，以指定文本单位之一移动插入符号。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TextInputControlSkin.TextUnit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TextInputControlSkin.TextUnit

  • Packages that use TextInputControlSkin.TextUnit
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of TextInputControlSkin.TextUnit in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return TextInputControlSkin.TextUnit
      Modifier and Type 方法 描述
      static TextInputControlSkin.TextUnit TextInputControlSkin.TextUnit.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextInputControlSkin.TextUnit[] TextInputControlSkin.TextUnit.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.control.skin with parameters of type TextInputControlSkin.TextUnit
      Modifier and Type 方法 描述
      void TextAreaSkin.moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)
      按照给定的方向，以指定文本单位之一移动插入符号。
      void TextFieldSkin.moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)
      按照给定的方向，以指定文本单位之一移动插入符号。
      abstract void TextInputControlSkin.moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)
      按照给定的方向，以指定文本单位之一移动插入符号。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TitledPaneSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TitledPaneSkin

No usage of javafx.scene.control.skin.TitledPaneSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ToggleButtonSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ToggleButtonSkin

No usage of javafx.scene.control.skin.ToggleButtonSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.ToolBarSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.ToolBarSkin

No usage of javafx.scene.control.skin.ToolBarSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TooltipSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TooltipSkin

No usage of javafx.scene.control.skin.TooltipSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TreeCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TreeCellSkin

No usage of javafx.scene.control.skin.TreeCellSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TreeTableCellSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TreeTableCellSkin

No usage of javafx.scene.control.skin.TreeTableCellSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TreeTableRowSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TreeTableRowSkin

No usage of javafx.scene.control.skin.TreeTableRowSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TreeTableViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TreeTableViewSkin

No usage of javafx.scene.control.skin.TreeTableViewSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.TreeViewSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.TreeViewSkin

No usage of javafx.scene.control.skin.TreeViewSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.VirtualContainerBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.VirtualContainerBase

  • Packages that use VirtualContainerBase
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of VirtualContainerBase in javafx.scene.control.skin

      Subclasses of VirtualContainerBase in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  ListViewSkin<T>
      默认皮肤实现为ListView控件。
      class  TableViewSkin<T>
      默认皮肤实现为TableView控件。
      class  TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>
      TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。
      class  TreeTableViewSkin<T>
      默认皮肤实现为TreeTableView控件。
      class  TreeViewSkin<T>
      默认皮肤实现为TreeView控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.control.skin.VirtualFlow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.control.skin.VirtualFlow

  • Packages that use VirtualFlow
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of VirtualFlow in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return types with arguments of type VirtualFlow
      Modifier and Type 方法 描述
      ObjectProperty<Callback<VirtualFlow<T>,T>> VirtualFlow.cellFactoryProperty​()
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      Callback<VirtualFlow<T>,T> VirtualFlow.getCellFactory​()
      返回当前的单元格工厂。
      Method parameters in javafx.scene.control.skin with type arguments of type VirtualFlow
      Modifier and Type 方法 描述
      void VirtualFlow.setCellFactory​(Callback<VirtualFlow<T>,T> value)
      设置要在VirtualFlow中使用的新单元格工厂。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


JavaFX CSS Reference Guide

Contents

  • Introduction
    • CSS and the JavaFX Scene Graph
    • Scene, Parent and SubScene Stylesheets
    • Naming Conventions
    • CSS Public API
    • Inheritance
    • @ Rules
    • Examples
    • Understanding Parser Warnings
    • Limitations
  • Types
    • inherit
    • <boolean>
    • <string>
    • <number> & <integer>
    • <size>
    • <length>
    • <percentage>
    • <angle>
    • <duration>
    • <point>
    • <color-stop>
    • <uri>
    • <effect>
    • <font>
    • <paint>
    • <color>
  • Stage
    • javafx.stage
      • PopupWindow
  • Nodes
    • javafx.scene
      • Group
      • Node
      • Parent
      • Scene
    • javafx.scene.image
      • ImageView
    • javafx.scene.layout
      • AnchorPane
      • BorderPane
      • DialogPane
      • FlowPane
      • GridPane
      • HBox
      • Pane
      • Region
      • StackPane
      • TilePane
      • VBox
    • javafx.scene.media
      • MediaView
    • javafx.scene.shape
      • Shape
      • Arc
      • Circle
      • CubicCurve
      • Ellipse
      • Line
      • Path
      • Polygon
      • QuadCurve
      • Rectangle
      • SVGPath
    • javafx.scene.text
      • Text
    • javafx.scene.web
      • WebView
  • Controls
    • javafx.scene.control
      • Accordion
      • Button
      • ButtonBase
      • Cell
      • CheckBox
      • CheckMenuItem
      • ChoiceBox
      • ColorPicker
      • ComboBox
      • ContextMenu
      • Control
      • DatePicker
      • HTMLEditor
      • Hyperlink
      • IndexedCell
      • Label
      • Labeled
      • ListCell
      • ListView
      • Menu
      • MenuBar
      • MenuButton
      • MenuItem
      • MenuItemBase
      • Pagination
      • PasswordField
      • ProgressBar
      • ProgressIndicator
      • RadioButton
      • RadioMenuItem
      • ScrollBar
      • ScrollPane
      • Separator
      • Spinner
      • Slider
      • SplitMenuButton
      • SplitPane
      • TabPane
      • TableColumnHeader
      • TableView
      • TextArea
      • TextInputControl
      • TextField
      • TitledPane
      • ToggleButton
      • ToolBar
      • Tooltip
      • TreeCell
      • TreeTableCell
      • TreeTableView
      • TreeView
      • WebView
  • Charts
    • javafx.scene.chart
      • AreaChart
      • Axis
      • BarChart
      • BubbleChart
      • CategoryAxis
      • Chart
      • Legend
      • LineChart
      • NumberAxis
      • PieChart
      • ScatterChart
      • ValueAxis
      • XYChart
  • References

Introduction

Never has styling a Java UI been easier than with JavaFX and Cascading Style Sheets (CSS). Going from one theme to another, or customizing the look of just one control, can all be done through CSS. To the novice, this may be unfamiliar territory; but the learning curve is not that great. Give CSS styling a try and the benefits will soon be apparent. You can also split the design and development workflow, or defer design until later in the project. Up to the last minute changes, and even post-deployment changes, in the UI's look can be achieved through JavaFX CSS.

The structure of this document is as follows. First, there is a description of all value types for JavaFX CSS properties.Where appropriate, this includes a grammar for the syntax of values of that type. Then, for each scene‑graph node that supports CSS styles, a table is given that lists the properties that are supported, along with type and semantic information. The pseudo‑classes for each class are also given. The description of CSS properties continues for the controls. For each control, the substructure of that control's skin is given, along with the style‑class names for the Region objects that implement that substructure.

CSS and the JavaFX Scene Graph

JavaFX Cascading Style Sheets (CSS) is based on the W3C CSS version 2.1 [1] with some additions from current work on version 3 [2]. JavaFX CSS also has some extensions to CSS in support of specific JavaFX features. The goal for JavaFX CSS is to allow web developers already familiar with CSS for HTML to use CSS to customize and develop themes for JavaFX controls and scene‑graph objects in a natural way.

JavaFX has a rich set of extensions to CSS in support of features such as color derivation, property lookup, and multiple background colors and borders for a single node. These features add significant new power for developers and designers and are described in detail in this document.

To the extent possible, JavaFX CSS follows the W3C standards; however, with few exceptions, JavaFX property names have been prefixed with a vendor extension of "-fx-". Even if these properties seem to be compatible with standard HTML CSS, JavaFX CSS processing assumes that the property values make use of JavaFX CSS extensions.

CSS styles are applied to nodes in the JavaFX scene‑graph in a way similar to the way CSS styles are applied to elements in the HTML DOM. Styles are first applied to the parent, then to its children. The code is written such that only those branches of the scene‑graph that might need CSS reapplied are visited. A node is styled after it is added to the scene graph. Styles are reapplied when there is a change to the node's pseudo‑class state, style‑class, id, inline style, or parent, or stylesheets are added to or removed from the scene. Note that the Node must be in the scene‑graph for CSS to be applied. The Node does not have to be shown, but must have a non‑null value for its sceneProperty. See applyCss for more details.

During a normal scene‑graph pulse, CSS styles are applied before the scene‑graph is laid out and painted. Styles for events that trigger a pseudo‑class state change, such as MouseEvent.MOUSE_ENTERED which triggers the "hover" state, are applied on the next pulse following the event.

CSS selectors are used to match styles to scene‑graph nodes. The relationship of a Node to a CSS selector is as follows:

  • Node's getTypeSelector method returns a String which is analogous to a CSS Type Selector. By default, this method returns the simple name of the class. Note that the simple name of an inner class or of an anonymous class may not be usable as a type selector. In such a case, this method should be overridden to return a meaningful value.
  • Each node in the scene‑graph has a styleClass property. Note that a node may have more than one style‑class. A Node's styleClass is analogous to the class="..." attribute that can appear on HTML elements. See Class Selectors.
  • Each node in the scene‑graph has an id variable, a string. This is analogous to the id="..." attribute that can appear HTML elements. See ID Selectors.

JavaFX CSS also supports pseudo‑classes, but does not implement the full range of pseudo‑classes as specified in Pseudo‑classes. The pseudo‑classes supported by each Node type are given in the tables within this reference. Note that JavaFX does not currently support structural pseudo‑classes.

Each node honors a set of properties that depends on the node's JavaFX class (as distinct from its styleClass). The properties honored by each node class are shown in detail in tables later in this document. The property value that is actually applied depends on the precedence of the origin of the rule, as described above, as well as the specificity of the rule's selector as described in CSS 2 [1] . Ultimately, a property value string is converted into a JavaFX value of the appropriate type and is then assigned to an instance variable of the JavaFX object.

Scene, Parent and SubScene Stylesheets

CSS styles can come from style sheets or inline styles. Style sheets are loaded from the URLs specified in the getStylesheets property of the Scene object. If the scene‑graph contains a Control, a default user agent style sheet is loaded. Inline styles are specified via the Node setStyle API. Inline styles are analogous to the style="..." attribute of an HTML element. Styles loaded from a Scene's style sheets take precedence over selectors from the user agent style sheet. Inline styles take precedence over styles originating elsewhere. The precedence order of style selectors can be modified using "!important" in a style declaration.

Beginning with JavaFX 2.1, the Parent class has a getStylesheets property, allowing style sheets to be set on a container. This allows for one branch of of the scene‑graph to have a distinct set of styles. Any instance of Parent can have style sheets. A child will take its styles from its own inline styles, the style sheets of all its ancestors, and any style sheets from the Scene.

Beginning with JavaFX 8u20, the Scene class has a getUserAgentStylesheet property, allowing a user‑style sheet to be set on a Scene. This allows a Scene to have a set of user‑agent styles distinct from the platform default. When a user‑agent stylesheet is set on a Scene, the user‑agent styles are used instead of the styles from the platform default user‑agent stylesheet.

Beginning with JavaFX 8u20, the SubScene class has a getUserAgentStylesheet property, allowing a user‑style sheet to be set on a SubScene. This allows a SubScene of the scene‑graph to have set of user‑agent styles distinct from the platform default or from the Scene in which the SubScene is contained. When a user‑agent stylesheet is set on a SubScene, the user‑agent styles are used instead of the styles from the platform default user‑agent stylesheet or any user‑agent stylesheet set on the Scene.

It is important to note that styles from a stylesheet added to a Scene or Parent, do not affect a SubScene which is a child or descendent of the Scene or Parent. Unless a user‑agent has been set on the SubScene, the SubScene will get styles from the a Scene's user‑agent stylesheet or the platform user‑agent stylesheet.

The implementation allows designers to style an application by using style sheets to override property values set from code. For example, a call to rectangle.setFill(Color.YELLOW) can be overridden by an inline‑style or a style from an author stylesheet. This has implications for the cascade; particularly, when does a style from a style sheet override a value set from code? The JavaFX CSS implementation applies the following order of precedence: a style from a user agent style sheet has lower priority than a value set from code, which has lower priority than a Scene or Parent style sheet. Inline styles have highest precedence. Style sheets from a Parent instance are considered to be more specific than those styles from Scene style sheets.

Naming Conventions

Naming conventions have been established for deriving CSS style‑class names from JavaFX class names, and for deriving CSS property names from JavaFX variable names. Note that this is only a naming convention; there is no automatic name conversion. Most JavaFX names use "camel case," that is, mixed case names formed from compound words, where the initial letter of each sub-word is capitalized. Most CSS names in the HTML world are all lower case, with compound words separated by hyphens. The convention is therefore to take JavaFX class names and form their corresponding CSS style‑class name by separating the compound words with hyphens and convering the letters to all lower case. For example, the JavaFX ToggleButton class would have a style‑class of "toggle-button". The convention for mapping JavaFX variable names to CSS property names is similar, with the addition of the "-fx-" prefix. For example, the blendMode variable would have a corresponding CSS property name of "-fx-blend-mode".

CSS Public API

Beginning with JavaFX 8, public API is available for developers to create styleable properties and manage pseudo-class state. Refer to javafx.css for details.

Inheritance

CSS also provides for certain properties to be inherited by default, or to be inherited if the property value is 'inherit'. If a value is inherited, it is inherited from the computed value of the element's parent in the document tree. In JavaFX, inheritance is similar, except that instead of elements in the document tree, inheritance occurs from parent nodes in the scene‑graph.

The following properties inherit by default. Any property can be made to inherit by giving it the value "inherit".

Class | Property | CSS Property | Initial Value
javafx.scene.Node | cursor | -fx-cursor | javafx.scene.Cursor.DEFAULT
javafx.scene.text.Text | textAlignment | -fx-text-alignment | javafx.scene.text.TextAlignment.LEFT
javafx.scene.text.Font | font | -fx-font, -fx-font-family, -fx-font-size, -fx-font-weight, -fx-font-style | Font.DEFAULT (12px system)

Within the hierarchy of JavaFX classes (for example, Rectangle is a subclass of Shape, which in turn is a subclass of Node), the CSS properties of an ancestor are also CSS properties of the descendant. This means that a subclass will respond to the same set of properties as its ancestor classes, and to additional properties it defines itself. So, a Shape supports all the properties of Node plus several more, and Rectangle supports all the properties of Shape plus a couple more. However, because using a JavaFX class name as a type selector is an exact match, providing style declarations for a Shape will not cause a Rectangle to use those values (unless the .css value for the Rectangle's property is "inherit").

For font inheritance, the CSS engine looks only for the styles in the table above. When looking for a font to inherit, the search terminates at any node that has a Font property that was set by the user. The user-set font is inherited provided there is not an author or an inline-style that applies specifically to that node. In this case, the inherited font is created from the user-set font and any parts of the applicable author or in-line style.

@ Rules

Beginning with JavaFX 8u20, the CSS @import is also partially supported. Only unconditional import is supported. In other words, the media‑type qualifier is not supported. Also, the JavaFX CSS parser is non-compliant with regard to where an @import may appear within a stylesheet (see At‑rules). Users are cautioned that this will be fixed in a future release. Adherence to the W3C standard is strongly advised.

Since JavaFX 8, the implementation partially supports the CSS3 syntax to load a font from a URL using the @font‑face rule:

This allows public resources for fonts to be used in a JavaFX application. For example, assume the URL "http://font.samples/web?family=samples" returns the @font‑face rule given above. Then the following code shows how the sample font could be used in a JavaFX application.

Or, the URL could be imported into a stylesheet with the @import rule.

Although the parser will parse the syntax, all @font‑face descriptors are ignored except for the src descriptor. The src descriptor is expected to be a <url>. The format hint is ignored.

Examples

Consider the following simple JavaFX application:

Scene scene = new Scene(new Group());
scene.getStylesheets().add(“test.css”);
Rectangle rect = new Rectangle(100,100);
rect.setLayoutX(50);
rect.setLayoutY(50);
rect.getStyleClass().add("my-rect");
((Group)scene.getRoot()).getChildren().add(rect);

Without any styles, this will display a plain black rectangle. If test.css contains the following:

.my-rect { -fx-fill: red; }

the rectangle will be red instead of black:

A rectangle with red fill

If test.css contains the following:

.my-rect {
-fx-fill: yellow;
-fx-stroke: green;
-fx-stroke-width: 5;
-fx-stroke-dash-array: 12 2 4 2;
-fx-stroke-dash-offset: 6;
-fx-stroke-line-cap: butt;
}

the result will be a yellow rectangle with a nicely dashed green border:

A rectangle with yellow fill and a green, dashed border

Understanding Parser Warnings

When the JavaFX CSS parser encounters a syntax error, a warning message is emitted which conveys as much information as is available to help resolve the error. For example

WARNING: javafx.css.CssParser declaration Expected '<percent>' while parsing '-fx-background-color' at ?[1,49]

The cryptic '?[1,49]' pertains to the location of the error. The format of the location string is

<url>[line, position]

If the error is found while parsing a file, the file URL will be given. If the error is from an inline style (as in the example above), the URL is given as a question mark. The line and position give an offset into the file or string where the token begins. Please note that the line and position may not be accurate in releases prior to JavaFX 2.2.

Applications needing to detect errors from the parser can add a listener to the errors property of javafx.css.CssParser.

Limitations

  1. While the JavaFX CSS parser will parse valid CSS syntax, it is not a fully compliant CSS parser. One should not expect the parser to handle syntax not specified in this document.
  2. With the exception of @font‑face and @import, @-keyword statements are ignored.
  3. The <media-query-list> of the @import statement is not parsed.
  4. The structural pseudo‑classes are not supported.
  5. The ":active" and ":focus" dynamic pseudo‑classes are not supported. However, Nodes do support the ":pressed" and ":focused" pseudo‑classes, which are similar.
  6. The ":link" and ":visited" pseudo‑classes are not supported in general. However, Hyperlink objects can be styled, and they support the ":visited" pseudo‑class.
  7. JavaFX CSS does not support comma-separated series of font family names in the -fx-font-family property. The optional line height parameter when specifying fonts is not supported. There is no equivalent for the font-variant property.
  8. JavaFX CSS uses the HSB color model instead of the HSL color model.
  9. If a property of a node is initialized by calling the set method of the property, the CSS implementation will see this as a user set value and the value will not be overwritten by a style from a user agent style sheet.
  10. When parsing a URI, the parser doesn't handle URI escapes nor \<hex-digit>[1,6] code points.

Types

inherit

Each property has a type, which determines what kind of value and the syntax for specifying those values. In addition, each property may have a specified value of 'inherit', which means that, for a given node, the property takes the same computed value as the property for the node's parent. The 'inherit' value can be used on properties that are not normally inherited.

If the 'inherit' value is set on the root element, the property is assigned its initial value.

<boolean>

Boolean values can either have the string value of "true" or "false", the values are case insensitive as all CSS is case insensitive.

<string>

Strings can either be written with double quotes or with single quotes. Double quotes cannot occur inside double quotes, unless escaped (e.g., as '\"' or as '\22'). Analogously for single quotes (e.g., "\'" or "\27").

"this is a 'string'"
"this is a \"string\""
'this is a "string"'
'this is a \'string\''

A string cannot directly contain a newline. To include a newline in a string, use an escape representing the line feed character in ISO-10646 (U+000A), such as "\A" or "\00000a". This character represents the generic notion of "newline" in CSS. See the 'content' property for an example.

<number> & <integer>

Some value types may have integer values (denoted by <integer>) or real number values (denoted by <number>). Real numbers and integers are specified in decimal notation only. An <integer> consists of one or more digits "0" to "9". A <number> can either be an <integer>, or it can be zero or more digits followed by a dot (.) followed by one or more digits. Both integers and real numbers may be preceded by a "-" or "+" to indicate the sign. -0 is equivalent to 0 and is not a negative number.

[+|-]? [[0-9]+|[0-9]*"."[0-9]+]

Note that many properties that allow an integer or real number as a value actually restrict the value to some range, often to a non-negative value.

<size>

A size is a <number> with units of <length> or <percentage>. If a unit is not specified then 'px' is assumed.

<length>

<number>[ px | mm | cm | in | pt | pc | em | ex ]?

No whitespace is allowed between the number and units if provided. Some units are relative and others absolute.

Relative

  • px: pixels, relative to the viewing device
  • em: the 'font-size' of the relevant font
  • ex: the 'x-height' of the relevant font

Absolute

  • in: inches — 1 inch is equal to 2.54 centimeters.
  • cm: centimeters
  • mm: millimeters
  • pt: points — the points used by CSS 2.1 are equal to 1/72nd of an inch.
  • pc: picas — 1 pica is equal to 12 points.

<percentage>

These are a percentage of some length, typically to the width or height of a node.

<number>[ % ]

<angle>

An angle is a <number> with one of the following units.

<number>[ deg | rad | grad | turn ]

  • deg: angle in degrees — all other angle units are converted to degrees.
  • rad: angle in radians
  • grad: angle in gradians
  • turn: angle in turns

<duration>

A duration is a <number> with second or millisecond units, or the value indefinite.

[<number>[ s | ms ]] | indefinite

  • s: duration in seconds
  • ms: duration in milliseconds. One second is 1000 milliseconds.
  • indefinite: See Duration.INDEFINITE

See also W3C time units.

<point>

A point is an {x,y} coordinate.

[ [ <length> <length> ] | [ <percentage> | <percentage> ] ]

<color-stop>

Stops are per W3C color-stop syntax.

[ <color> [ <percentage> | <length>]? ]

In a series of <color-stop>, stop distance values must all be <percentage> or <length>. Furthermore, if <length> values are used, then the distance value for first and last stop in the series must be specified. This restriction may be removed in a future release.

"red, white 70%, blue" is valid since the distance for red and blue is assumed to be 0% and 100%, respectively.

"red 10, white, blue 90" is valid. Because distance for red and blue is 10 and 90, respectively, the distance for white can be calculated.

"red, white 70, blue" is not valid since distance units do not agree.

"red, white, blue" is valid. The stops are distributed evenly between 0% and 100%.

<uri>

url ( [\"\']? <address> [\"\']? )

<address> is a hierarchical URI of the form [scheme:][//authority][path] (see [2]). For example:

url(http://example.com/images/Duke.png)
url(/com/example/javafx/app/images/Duke.png)

If the <address> does not have a [scheme:] component, the <address> is considered to be the [path] component only. A leading '/' character indicates that the [path] is relative to the root of the classpath. If the the style appears in a stylesheet and has no leading '/' character, the path is relative to the base URI of the stylesheet. If the style appears in an inline style, the path is relative to the root of the classpath (regardless of whether or not there is a leading '/').

Examples of Resolving URLs in Stylesheets
Stylesheet URL | URL in Style | Resolves to
file:///some/path/build/classes/com/mycompany/myapp/mystyles.css | url(images/Duke.png) | file:///some/path/build/classes/com/mycompany/myapp/images/Duke.png
file:///some/path/build/classes/com/mycompany/myapp/mystyles.css | url(../images/Duke.png) | file:///some/path/build/classes/com/mycompany/images/Duke.png
jar:file:/some/path/build/myapp.jar!/com/mycompany/myapp/mystyles.css | url(images/Duke.png) | jar:file:/some/path/build/myapp.jar!/com/mycompany/myapp/images/Duke.png

Examples of Resolving URLs in Inline Styles
Classpath | URL in Style | Resolved URL
file:///some/path/build/classes | url(/com/mycompany/resources/images/Duke.png) | file:///some/path/build/classes/com/mycompany/resources/images/Duke.png
file:///some/path/build/myapp.jar | url(/com/mycompany/resources/images/Duke.png) | jar:file:/some/path/build/myapp.jar!/com/mycompany/resources/images/Duke.png

Note that for inline styles, leading dot-segments (e.g. '..' or '.') do resolve since the path is always anchored at the root of the classpath.

As an example, the code snippet below creates a scene filled with a fictional 'Duke.png' image, located in an 'image' directory:

The same style would work equally as well from a stylesheet.

<effect>

JavaFX CSS currently supports the DropShadow and InnerShadow effects from the JavaFX platform. See the class documentation in javafx.scene.effect for further details about the semantics of the various effect parameters.

Drop Shadow

A high-level effect that renders a shadow of the given content behind the content.

dropshadow( <blur-type> , <color> , <number> , <number> , <number> , <number> )

<blur-type> = [ gaussian | one-pass-box | three-pass-box | two-pass-box ]
<color> The shadow Color.
<number> The radius of the shadow blur kernel. In the range [0.0 ... 127.0], typical value 10.
<number> The spread of the shadow. The spread is the portion of the radius where the contribution of the source material will be 100%. The remaining portion of the radius will have a contribution controlled by the blur kernel. A spread of 0.0 will result in a distribution of the shadow determined entirely by the blur algorithm. A spread of 1.0 will result in a solid growth outward of the source material opacity to the limit of the radius with a very sharp cutoff to transparency at the radius. Values should be in the range [0.0 ... 1.0].
<number> The shadow offset in the x direction, in pixels.
<number> The shadow offset in the y direction, in pixels.

Inner Shadow

A high-level effect that renders a shadow inside the edges of the given content.

innershadow( <blur-type> , <color> , <number> , <number> , <number> , <number> )

<blur-type> = [ gaussian | one-pass-box | three-pass-box | two-pass-box ]
<color> The shadow Color.
<number> The radius of the shadow blur kernel. In the range [0.0 ... 127.0], typical value 10.
<number> The choke of the shadow. The choke is the portion of the radius where the contribution of the source material will be 100%. The remaining portion of the radius will have a contribution controlled by the blur kernel. A choke of 0.0 will result in a distribution of the shadow determined entirely by the blur algorithm. A choke of 1.0 will result in a solid growth inward of the shadow from the edges to the limit of the radius with a very sharp cutoff to transparency inside the radius. Values should be in the range [0.0 ... 1.0].
<number> The shadow offset in the x direction, in pixels.
<number> The shadow offset in the y direction, in pixels.

<font>

JavaFX CSS supports the ability to specify fonts using separate family, size, style, and weight properties, as well as the ability to specify a font using a single shorthand property. There are four value types related to fonts plus a shorthand property that encompasses all four properties. The font-related types are as follows.

<font-family>The string name of the font family. An actual font family name available on the system can be used, or one of the following generic family names can be used:

  • 'serif' (e.g., Times)
  • 'sans-serif' (e.g., Helvetica)
  • 'cursive' (e.g., Zapf-Chancery)
  • 'fantasy' (e.g., Western)
  • 'monospace' (e.g., Courier)

<font-size> The size of the font, using the <size> syntax.

<font-style> The font's style, using the following syntax:
[ normal | italic | oblique ]

<font-weight> The font's weight, using the following syntax:
[ normal | bold | bolder | lighter | 100 | 200 | 300 | 400 | 500 | 600 | 700 | 800 | 900 ]

<font> This font shorthand property can be used in place of the above properties. It uses the following syntax:
[[ <font-style> || <font-weight> ]? <font-size> <font-family> ]

Font Properties

Most classes that use text will support the following font properties. In some cases a similar set of properties will be supported but with a different prefix instead of "-fx-font".

CSS Property | Values | Default | Comments
-fx-font | <font> | inherit | shorthand property for font-size, font-family, font-weight and font-style
-fx-font-family | <font-family> | inherit |
-fx-font-size | <font-size> | inherit |
-fx-font-style | <font-style> | inherit |
-fx-font-weight | <font-weight> | inherit |

<paint>

Paint values can either be a solid color specified in one of the color syntaxes, they can be a linear or radial gradient, or an image-pattern.

<color> | <linear-gradient> | <radial-gradient> | <image-pattern> <repeating-image-pattern>

Linear Gradients <linear-gradient>

linear-gradient( [ [from <point> to <point>] | [ to <side-or-corner>], ]? [ [ repeat | reflect ], ]? <color-stop>[, <color-stop>]+)

where <side-or-corner> = [left | right] || [top | bottom]

Linear gradient creates a gradient going though all the stop colors along the line between the "from" <point> and the "to" <point>. If the points are percentages, then they are relative to the size of the area being filled. Percentage and length sizes can not be mixed in a single gradient function.

If neither repeat nor reflect are given, then the CycleMethod defaults "NO_CYCLE".
If neither [from <point> to <point>] nor [ to <side-or-corner> ] are given, then the gradient direction defaults to 'to bottom'.
Stops are per W3C color-stop syntax and are normalized accordingly.

This example will create a gradient from top left to bottom right of the filled area with red at the top left corner and black at the bottom right.

linear-gradient(to bottom right, red, black)

This is equivalent to:

linear-gradient(from 0% 0% to 100% 100%, red 0%, black 100%)

This more complex example will create a 50px high bar at the top with a 3 color gradient with white underneath for the rest of the filled area.

linear-gradient(from 0px 0px to 0px 50px, gray, darkgray 50%, dimgray 99%, white)

The following syntax for linear gradient does not conform to the CSS grammar and is deprecated in JavaFX 2.0. The JavaFX 2.0 CSS parser supports the syntax but this support may be removed in later releases.

linear (<size>, <size>) to (<size>, <size>) stops [ (<number>,<color>) ]+ [ repeat | reflect ]?

Radial Gradients <radial-gradient>

radial-gradient([ focus-angle <angle>, ]? [ focus-distance <percentage>, ]? [ center <point>, ]? radius [ <length> | <percentage> ] [ [ repeat | reflect ], ]? <color-stop>[, <color-stop>]+)

Radial gradient creates a gradient going though all the stop colors radiating outward from the center point to the radius. If the center point is not given, the center defaults to (0,0). Percentage values are relative to the size of the area being filled. Percentage and length sizes can not be mixed in a single gradient function.

If neither repeat nor reflect are given, then the CycleMethod defaults "NO_CYCLE".
Stops are per W3C color-stop syntax and are normalized accordingly.

Following are examples of the use of radial-gradient:

radial-gradient(radius 100%, red, darkgray, black)

radial-gradient(focus-angle 45deg, focus-distance 20%, center 25% 25%, radius 50%, reflect, gray, darkgray 75%, dimgray)

The following syntax for radial gradient does not conform to the CSS grammar and is deprecated in JavaFX 2.0. The JavaFX 2.0 CSS parser supports the syntax but this support may be removed in later releases.

radial [focus-angle <number> | <number> ] ]? [ focus-distance <size> ]? [ center <size,size> ]? <size> stops [ ( <number>, <color> ) ]+ [ repeat | reflect ]?

Image Paint <image-pattern>

image-pattern(<string>, [<size>, <size>, <size>, <size>[, <boolean>]?]?)

The parameters, in order, are:

<string> The URL of the image.
<size> The x origin of the anchor rectangle.
<size> The y origin of the anchor rectangle.
<size> The width of the anchor rectangle.
<size> The height of the anchor rectangle.
<boolean> The proportional flag which indicates whether start and end locations are proportional or absolute

For a full explanation of the parameters, refer to the ImagePattern javadoc.

Following are examples of the use of image-pattern:

image-pattern("images/Duke.png")

image-pattern("images/Duke.png", 20%, 20%, 80%, 80%)

image-pattern("images/Duke.png", 20%, 20%, 80%, 80%, true)

image-pattern("images/Duke.png", 20, 20, 80, 80, false)

Related, there is the repeating-image-pattern function which is a shorthand for producing tiled image based fills. It is equivalent to

image-pattern("images/Duke.png", 0, 0, imageWidth, imageHeight, false)

repeating-image-pattern(<string>)

The only parameter is the uri of the image. Following is an example of the use of image-pattern:

repeating-image-pattern("com/mycompany/myapp/images/Duke.png")

<color>

<named-color> | <looked-up-color> | <rgb-color> | <hsb-color> | <color-function>

Named Colors <named-color>

CSS supports a bunch of named constant colors. Named colors can be specified with just their unquoted name for example:

.button {
-fx-background-color: red;
}

The named colors that are available in CSS are:

aliceblue = #f0f8ff | antiquewhite = #faebd7 | aqua = #00ffff | aquamarine = #7fffd4
azure = #f0ffff | beige = #f5f5dc | bisque = #ffe4c4 | black = #000000
blanchedalmond = #ffebcd | blue = #0000ff | blueviolet = #8a2be2 | brown = #a52a2a
burlywood = #deb887 | cadetblue = #5f9ea0 | chartreuse = #7fff00 | chocolate = #d2691e
coral = #ff7f50 | cornflowerblue = #6495ed | cornsilk = #fff8dc | crimson = #dc143c
cyan = #00ffff | darkblue = #00008b | darkcyan = #008b8b | darkgoldenrod = #b8860b
darkgray = #a9a9a9 | darkgreen = #006400 | darkgrey = #a9a9a9 | darkkhaki = #bdb76b
darkmagenta = #8b008b | darkolivegreen = #556b2f | darkorange = #ff8c00 | darkorchid = #9932cc
darkred = #8b0000 | darksalmon = #e9967a | darkseagreen = #8fbc8f | darkslateblue = #483d8b
darkslategray = #2f4f4f | darkslategrey = #2f4f4f | darkturquoise = #00ced1 | darkviolet = #9400d3
deeppink = #ff1493 | deepskyblue = #00bfff | dimgray = #696969 | dimgrey = #696969
dodgerblue = #1e90ff | firebrick = #b22222 | floralwhite = #fffaf0 | forestgreen = #228b22
fuchsia = #ff00ff | gainsboro = #dcdcdc | ghostwhite = #f8f8ff | gold = #ffd700
goldenrod = #daa520 | gray = #808080 | green = #008000 | greenyellow = #adff2f
grey = #808080 | honeydew = #f0fff0 | hotpink = #ff69b4 | indianred = #cd5c5c
indigo = #4b0082 | ivory = #fffff0 | khaki = #f0e68c | lavender = #e6e6fa
lavenderblush = #fff0f5 | lawngreen = #7cfc00 | lemonchiffon = #fffacd | lightblue = #add8e6
lightcoral = #f08080 | lightcyan = #e0ffff | lightgoldenrodyellow = #fafad2 | lightgray = #d3d3d3
lightgreen = #90ee90 | lightgrey = #d3d3d3 | lightpink = #ffb6c1 | lightsalmon = #ffa07a
lightseagreen = #20b2aa | lightskyblue = #87cefa | lightslategray = #778899 | lightslategrey = #778899
lightsteelblue = #b0c4de | lightyellow = #ffffe0 | lime = #00ff00 | limegreen = #32cd32
linen = #faf0e6 | magenta = #ff00ff | maroon = #800000 | mediumaquamarine = #66cdaa
mediumblue = #0000cd | mediumorchid = #ba55d3 | mediumpurple = #9370db | mediumseagreen = #3cb371
mediumslateblue = #7b68ee | mediumspringgreen = #00fa9a | mediumturquoise = #48d1cc | mediumvioletred = #c71585
midnightblue = #191970 | mintcream = #f5fffa | mistyrose = #ffe4e1 | moccasin = #ffe4b5
navajowhite = #ffdead | navy = #000080 | oldlace = #fdf5e6 | olive = #808000
olivedrab = #6b8e23 | orange = #ffa500 | orangered = #ff4500 | orchid = #da70d6
palegoldenrod = #eee8aa | palegreen = #98fb98 | paleturquoise = #afeeee | palevioletred = #db7093
papayawhip = #ffefd5 | peachpuff = #ffdab9 | peru = #cd853f | pink = #ffc0cb
plum = #dda0dd | powderblue = #b0e0e6 | purple = #800080 | red = #ff0000
rosybrown = #bc8f8f | royalblue = #4169e1 | saddlebrown = #8b4513 | salmon = #fa8072
sandybrown = #f4a460 | seagreen = #2e8b57 | seashell = #fff5ee | sienna = #a0522d
silver = #c0c0c0 | skyblue = #87ceeb | slateblue = #6a5acd | slategray = #708090
slategrey = #708090 | snow = #fffafa | springgreen = #00ff7f | steelblue = #4682b4
tan = #d2b48c | teal = #008080 | thistle = #d8bfd8 | tomato = #ff6347
turquoise = #40e0d0 | violet = #ee82ee | wheat = #f5deb3 | white = #ffffff
whitesmoke = #f5f5f5 | yellow = #ffff00 | yellowgreen = #9acd32 | transparent = rgba(0,0,0,0)

Looked-up Colors <looked-up-color>

With looked-up colors you can refer to any other color property that is set on the current node or any of its parents. This is a very powerful feature, as it allows a generic palette of colors to be specified on the scene then used thoughout the application. If you want to change one of those palette colors you can do so at any level in the scene tree and it will affect that node and all its decendents. Looked-up colors are not looked up until they are applied, so they are live and react to any style changes that might occur, such as replacing a palette color at runtime with the "style" property on a node.

In the following example, all background color of all buttons uses the looked up color "abc".

.root { abc: #f00 }
.button { -fx-background-color: abc }

RGB Colors <rgb-color>

The RGB color model is used in numerical color specifications. It has a number of different supported forms.

#<digit><digit><digit>
| #<digit><digit><digit><digit><digit><digit>
| rgb( <integer> , <integer> , <integer> )
| rgb( <integer> %, <integer>% , <integer>% )
| rgba( <integer> , <integer> , <integer> , <number> )
| rgba( <integer>% , <integer>% , <integer> %, <number> )

These examples all specify the same color for the text fill of a Label:

  • .label { -fx-text-fill: #f00 } /* #rgb */
  • .label { -fx-text-fill: #ff0000 } /* #rrggbb */
  • .label { -fx-text-fill: rgb(255,0,0) }
  • .label { -fx-text-fill: rgb(100%, 0%, 0%) }
  • .label { -fx-text-fill: rgba(255,0,0,1) }

RGB Hex: The format of an RGB value in hexadecimal notation is a ‘#’ immediately followed by either three or six hexadecimal characters. The three-digit RGB notation (#rgb) is converted into six-digit form (#rrggbb) by replicating digits, not by adding zeros. For example, #fb0 expands to #ffbb00. This ensures that white (#ffffff) can be specified with the short notation (#fff) and removes any dependencies on the color depth of the display.

RGB Decimal or Percent: The format of an RGB value in the functional notation is ‘rgb(’ followed by a comma-separated list of three numerical values (either three decimal integer values or three percentage values) followed by ‘)’. The integer value 255 corresponds to 100%, and to F or FF in the hexadecimal notation: rgb(255,255,255) = rgb(100%,100%,100%) = #FFF. White space characters are allowed around the numerical values.

RGB + Alpha: This is an extension of the RGB color model to include an ‘alpha’ value that specifies the opacity of a color. This is accomplished via a functional syntax of the form rgba(...) form that takes a fourth parameter which is the alpha value. The alpha value must be a number in the range 0.0 (representing completely transparent) and 1.0 (completely opaque). As with the rgb() function, the red, green, and blue values may be decimal integers or percentages. The following examples all specify the same color:

  • .label { -fx-text-fill: rgb(255,0,0) } /* integer range 0 — 255*/
  • .label { -fx-text-fill: rgba(255,0,0,1) /* the same, with explicit opacity of 1 */
  • .label { -fx-text-fill: rgb(100%,0%,0%) } /* float range 0.0% — 100.0% */
  • .label { -fx-text-fill: rgba(100%,0%,0%,1) } /* the same, with explicit opacity of 1 */

HSB Colors <hsb-color>

Colors can be specified using the HSB (sometimes called HSV) color model, as follows:

hsb( <number> , <number>% , <number>% ) | hsba( <number> , <number>% , <number>% , <number> )

The first number is hue, a number in the range 0 to 360 degrees. The second number is saturation, a percentage in the range 0% to 100%. The third number is brightness, also a percentage in the range 0% to 100%. The hsba(...) form takes a fourth parameter at the end which is a alpha value in the range 0.0 to 1.0, specifying completely transparent and completely opaque, respectively.

Color Functions <color-function>

JavaFX supports some color computation functions. These compute new colors from input colors at the time the color style is applied. This enables a color theme to be specified using a single base color and to have variant colors computed from that base color. There are two color functions: derive() and ladder().

<derive> | <ladder>

Derive <derive>

derive( <color> , <number>% )

The derive function takes a color and computes a brighter or darker version of that color. The second parameter is the brightness offset, representing how much brighter or darker the derived color should be. Positive percentages indicate brighter colors and negative percentages indicate darker colors. A value of -100% means completely black, 0% means no change in brightness, and 100% means completely white.

Ladder<ladder>

ladder(<color> , <color-stop> [, <color-stop>]+)

The ladder function interpolates between colors. The effect is as if a gradient is created using the stops provided, and then the brightness of the provided <color> is used to index a color value within that gradient. At 0% brightness, the color at the 0.0 end of the gradient is used; at 100% brightness, the color at the 1.0 end of the gradient is used; and at 50% brightness, the color at 0.5, the midway point of the gradient, is used. Note that no gradient is actually rendered. This is merely an interpolation function that results in a single color.

Stops are per W3C color-stop syntax and are normalized accordingly.

For example, you could use the following if you want the text color to be black or white depending upon the brightness of the background.

background: white;
-fx-text-fill: ladder(background, white 49%, black 50%);

The resulting -fx-text-fill value will be black, because the background (white) has a brightness of 100%, and the color at 1.0 on the gradient is black. If we were to change the background color to black or dark grey, the brightness would be less than 50%, giving an -fx-text-fill value of white.

The following syntax for ladder does not conform to the CSS grammar and is deprecated in JavaFX 2.0. The JavaFX 2.0 CSS parser supports the syntax but this support may be removed in later releases.

ladder(<color>) stops [ ( <number> , <color> ) ]+

Stage

javafx.stage

Group

Style class: .root.popup

PopupWindow does not have any properties that can be styled by CSS, but a PopupWindow does have its own Scene. Scene's root gets the .root style-class by default. If the Scene is the root scene of a PopupWindow, then the .popup style-class is also added. This allows the root scene of a PopupWindow to have distinct styles via the CSS rule .root.popup { /* declarations */ }

Nodes

javafx.scene

Group

Style class: empty by default

CSS Property Values Default Comments
Group extends Parent. Group does not add any addtional CSS properties.
Also has all properties of Parent

Node

Style class: empty by default

CSS Property | Values | Default | Range | Comments
-fx-blend-mode | [ add | blue | color-burn | color-dodge | darken | difference | exclusion | green | hard-light | lighten | multiply | overlay | red | screen | soft-light | src-atop | src-in | src-out | src-over ] | null |  |
-fx-cursor | [ null | crosshair | default | hand | move | e-resize | h-resize | ne-resize | nw-resize | n-resize | se-resize | sw-resize | s-resize | w-resize | v-resize | text | wait ] | <url> | null |  | inherits
-fx-effect | <effect> | null |  |
-fx-focus-traversable | <boolean> | false |  | The default value for controls is true, although there are some exceptions. See Controls for details.
-fx-view-order | <number> | 0 |  | This property is used to alter the rendering and picking order of a node within its parent without reordering the parent's children list. The parent traverses its children in decreasing viewOrder order.
-fx-opacity | <number> | 1 | [0.0 ... 1.0] | Opacity can be thought of conceptually as a postprocessing operation. Conceptually, after the node (including its descendants) is rendered into an RGBA offscreen image, the opacity setting specifies how to blend the offscreen rendering into the current composite rendering.
-fx-rotate | <number> | 0 |  | This is the angle of the rotation in degrees. Zero degrees is at 3 o'clock (directly to the right). Angle values are positive clockwise. Rotation is about the center.
-fx-scale-x | <number> | 1 |  | scale about the center
-fx-scale-y | <number> | 1 |  | scale about the center
-fx-scale-z | <number> | 1 |  | scale about the center
-fx-translate-x | <number> | 0 |  |
-fx-translate-y | <number> | 0 |  |
-fx-translate-z | <number> | 0 |  |
visibility | [ visible | hidden | collapse | inherit ] | true (i.e, visible) |  | See W3C visibility property

Pseudo-classes

CSS Pseudo-class | Comments
disabled | applies when the disabled variable is true
focused | applies when the focused variable is true
hover | applies when the hover variable is true
pressed | applies when the pressed variable is true
show-mnemonic | apples when the mnemonic affordance (typically an underscore) should be shown.

Parent

Style class: empty by default

CSS Property Values Default Comments
Parent extends Node. Parent does not add any addtional CSS properties.
Also has all properties of Node

Scene

Style class: not applicable

The Scene object has no settable CSS properties, nor does it have any pseudo‑classes. However, the root node of the scene is assigned the style class "root" (in addition to style classes already assigned to the node). This is useful because the root node of Scene is the root container for all active scene‑graph nodes. Thus, it can serve as a container for properties that are inherited or looked up.

javafx.scene.image

ImageView

Style class: image-view

CSS Property | Values | Default | Comments
-fx-image | <uri> | null | Relative URLs are resolved against the URL of the stylesheet.
Also has all properties of Node
javafx.scene.layout

AnchorPane

Style class: empty by default

CSS Property Values Default Comments
AnchorPane extends Pane and does not add any additional CSS properties.
Also has all properties of Pane

BorderPane

Style class: empty by default

CSS Property Values Default Comments
BorderPane extends Pane and does not add any additional CSS properties.
Also has all properties of Pane

DialogPane

Style class: dialog-pane

CSS Property | Values | Default | Comments
-fx-graphic | <uri> | null |
Also has all properties of Pane

Substructure

  • header-panel — BoderPane
    • graphic-container — StackPane
  • content — Label
  • button-bar — ButtonBar

FlowPane

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-hgap | <size> | 0 |
-fx-vgap | <size> | 0 |
-fx-alignment | [ top-left | top-center | top-right | center-left | center | center-right bottom-left | bottom-center | bottom-right | baseline-left | baseline-center | baseline-right ] | top-left |
-fx-column-halignment | [ left | center | right ] | left |
-fx-row-valignment | [ top | center | baseline | bottom ] | center |
-fx-orientation | [ horizontal | vertical ] | horizontal |
Also has all properties of Pane

GridPane

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-hgap | <size> | 0 |
-fx-vgap | <size> | 0 |
-fx-alignment | [ top-left | top-center | top-right | center-left | center | center-right bottom-left | bottom-center | bottom-right | baseline-left | baseline-center | baseline-right ] | top-left |
-fx-grid-lines-visible | <boolean> | false |
Also has all properties of Pane

HBox

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-spacing | <size> | 0 |
-fx-alignment | [ top-left | top-center | top-right | center-left | center | center-right bottom-left | bottom-center | bottom-right | baseline-left | baseline-center | baseline-right ] | top-left |
-fx-fill-height | <boolean> | true |
Also has all properties of Pane

Pane

Style class: empty by default

CSS Property Values Default Comments
Pane extends Region to expose Region's children. Pane does not add any addtional CSS properties.
Also has all properties of Region

Region

Style class: empty by default

A Region is a Node (extending from Parent) with backgrounds and borders that are styleable via CSS. A Region is typically a rounded rectangle, though this can be modified through CSS to be an arbitrary shape. Regions can contain other Region objects (sub-regions) or they can contain sub-controls. All Regions have the same set of CSS properties as described below.

Each Region consists of several layers, painted from bottom to top, in this order:

  1. background fills
  2. background images
  3. border strokes
  4. border images
  5. contents

The background and border mechanisms are patterned after the CSS 3 draft backgrounds and borders module. See [4] for a detailed description.

Background fills are specified with the properties -fx-background-color, -fx-background-radius and -fx-background-insets. The -fx-background-color property is a series of one or more comma-separated <paint> values. The number of values in the series determines the number of background rectangles that are painted. Background rectangles are painted in the order specified using the given <paint> value. Each background rectangle can have different radii and insets. The -fx-background-radius and -fx-background-insets properties are series of comma-separated values (or sets of values). The radius and insets values used for a particular background are the found in the corresponding position in the -fx-background-radius and -fx-background-insets series. For example, suppose a series of three values is given for the -fx-background-color property. A series of three values should also be specified for the -fx-background-radius and -fx-background-insets properties. The first background will be painted using the first radius value and first insets value, the second background will be painted with the second radius value and second insets value, and so forth.

Note also that properties such as -fx-background-radius and -fx-background-insets can contain a series of values or sets of four values. A set of values is separated by whitespace, whereas the values or sets-of-values in a series are separated by commas. For -fx-background-radius, a single value indicates that the value should be used for the radius of all four corners of the background rectangle. A set of four values indicates that different radius values are to be used for the top-left, top-right, bottom-right, and bottom-left corners, in that order. Similarly, the -fx-background-insets property can also contain a series of values or sets of values. A set of four values for -fx-background-insets indicates that different insets are to be used for the top, right, bottom, and left edges of the rectangle, in that order.

Background images are specified with the properties -fx-background-image, -fx-background-repeat, -fx-background-position and -fx-background-size. The number of images in the series of -fx-background-image values determines the number of background images that are painted. The -fx-background-repeat, -fx-background-position, and -fx-background-size properties each can contain a series of values. For each item in the -fx-background-image series, the corresponding items in the -fx-background-repeat, -fx-background-position, and -fx-background-size properties are applied to that background image.

Stroked borders are specified with the properties -fx-border-color, -fx-border-style, -fx-border-width, -fx-border-radius and -fx-border-insets. Each property contains a series of items. The maximum number of items in the -fx- border-color or -fx-border-style property determines the number of border layers that are painted.. Each border in the series is painted using information from the corresponding series item of the -fx-border-color, -fx-border-style, -fx-border-width, -fx-border-radius, and -fx-border-insets properties. If there is no -fx-border-color, the default color is black. if there is no -fx-border-style, the default style is solid.

Image borders are specified with the properties -fx-border-image-source, -fx-border-image-repeat, -fx-border-image-slice, -fx-border-image-width and -fx-border-image-insets. Each property contains a series of items. The number of items in the -fx-border-image-source property determines the number of images that are painted. Each image in the series is painted using information from the corresponding series items of the -fx-border-image-repeat, -fx-border-image-slice, -fx-border-image-width, and -fx-border-image-insets properties.

The region's contents are a sequence of nodes, like any other container. The contents are set programmatically and cannot be set via CSS.

CSS Property | Values | Default | Comments
BACKGROUND FILLS (see CSS Backgrounds and Borders Module Level 3: Backgrounds)
-fx-region-background | javafx.scene.layout.Background | null | This cannot be set directly from CSS but is created from the property values of -fx-background-color, -fx-background-image, -fx-background-insets, -fx-background-position, -fx-background-radius, -fx-background-repeat, -fx-background-size
-fx-background-color | <paint> [ , <paint> ]* | transparent | A series of paint values separated by commas.
-fx-background-insets <size> | <size> <size> <size> <size> [ , [ <size> | <size> <size> <size> <size>] ]* 0 0 0 0

A series of size values or sets of four size values, separated by commas. A single size value means all insets are the same. Otherwise, the four values for each inset are given in the order top, right, bottom, left. Each comma-separated value or set of values in the series applies to the corresponding background color.
-fx-background-radius [<size>]{1,4} [ / [<size>]{1,4} ]? [ , [<size>]{1,4} [ / [<size>]{1,4} ]? ]* 0 0 0 0

The same syntax and semenatics as CSS Backgrounds and Borders Module Level 3: Curve Radii applies to -fx-background-radius. Note that JavaFX supports only the short-hand syntax.

Each comma-separated value or set of values in the series applies to the corresponding background color.
BACKGROUND IMAGES (see CSS Backgrounds and Borders Module Level 3: Background Image)
-fx-background-image | <uri> [ , <uri> ]* | null | A series of image URIs separated by commas.
-fx-background-position

<bg-position> [ , <bg-position> ]*
where <bg-position> = [
[ [ <size> | left | center | right ] [ <size> | top | center | bottom ]? ]
| [ [ center | [ left | right ] <size>? ] || [ center | [ top | bottom ] <size>? ]
]

0% 0%

A series of <bg-position> values separated by commas. Each bg-position item in the series applies to the corresponding image in the background-image series.
-fx-background-repeat <repeat-style> [ , <repeat-style> ]*
where <repeat-style> = repeat-x | repeat-y | [repeat | space | round | stretch | no-repeat]{1,2} 		repeat repeat

A series of <repeat-style> values separated by commas. Each repeat-style item in the series applies to the corresponding image in the background-image series.
-fx-background-size <bg-size> [ , <bg-size> ]*
<bg-size> = [ <size> | auto ]{1,2} | cover | contain | stretch 		auto auto

A series of <bg-size> values separated by commas. Each bg-size item in the series applies to the corresponding image in the background-image series.
STROKED BORDERS (see CSS Backgrounds and Borders Module Level 3: Borders)
BORDER IMAGES (see CSS Backgrounds and Borders Module Level 3: Border Images)
-fx-region-border | javafx.scene.layout.Border | null | This cannot be set directly from CSS but is created from the property values of -fx-border-color, -fx-border-insets, -fx-border-radius, -fx-border-style, -fx-border-width, -fx-border-image-insets, -fx-border-image-repeat, -fx-border-image-slice, -fx-border-image-source, -fx-border-image-width
-fx-border-color <paint> | <paint> <paint> <paint> <paint> [ , [<paint> | <paint> <paint> <paint> <paint>] ]* null

A series of paint values or sets of four paint values, separated by commas. For each item in the series, if a single paint value is specified, then that paint is used as the border for all sides of the region; and if a set of four paints is specified, they are used for the top, right, bottom, and left borders of the region, in that order. If the border is not rectangular, only the first paint value in the set is used.
-fx-border-insets <size> | <size> <size> <size> <size> [ , [ <size> | <size> <size> <size> <size>] ]* null

A series of inset or sets of four inset values, separated by commas. For each item in the series, a single inset value means that all insets are the same; and if a set of four inset values is specified, they are used for the top, right, bottom, and left edges of the region, in that order. Each item in the series of insets applies to the corresponding item in the series of border colors.
-fx-border-radius [<size>]{1,4} [ / [<size>]{1,4} ]? [ , [<size>]{1,4} [ / [<size>]{1,4} ]? ]* null

Refer to CSS Backgrounds and Borders Module Level 3: Curve Radii. JavaFX supports only the short-hand syntax.

Each comma-separated value or set of values in the series applies to the corresponding border color.
-fx-border-style

<border-style> [ , <border-style> ]*
where <border-style> = <dash-style> [phase <number>]? [centered | inside | outside]? [line-join [miter <number> | bevel | round]]? [line-cap [square | butt | round]]?
where <dash-style> = [ none | solid | dotted | dashed | segments( <number>, <number> [, <number>]*) ]

 null

A series of border style values, separated by commas. Each item in the series applies to the corresponding item in the series of border colors.

The segments dash-style defines a sequence representing the lengths of the dash segments. Alternate entries in the sequence represent the lengths of the opaque and transparent segments of the dashes. This corresponds to the strokeDashArray variable of Shape.

The optional phase parameter defines the point in the dashing pattern that will correspond to the beginning of the stroke. This corresponds to the strokeDashOffset variable of Shape.
-fx-border-width <size> | <size> <size> <size> <size> [ , [ <size> | <size> <size> <size> <size>] ]* null

A series of width or sets of four width values, separated by commas. For each item in the series, a single width value means that all border widths are the same; and if a set of four width values is specified, they are used for the top, right, bottom, and left border widths, in that order. If the border is not rectangular, only the first width value is used. Each item in the series of widths applies to the corresponding item in the series of border colors.

-fx-border-image-source <uri> [ , <uri> ]* null

A series of image URIs, separated by commas.
-fx-border-image-insets <size> | <size> <size> <size> <size> [ , [ <size> | <size> <size> <size> <size>] ]* 0 0 0 0

A series of inset or sets of four inset values, separated by commas. For each item in the series, a single inset value means that all insets are the same; and if a set of four inset values is specified, they are used for the top, right, bottom, and left edges of the region, in that order. Each item in the series of insets applies to the corresponding image in the series of border images.
-fx-border-image-repeat <repeat-style> [ , <repeat-style> ]*
where <repeat-style> = repeat-x | repeat-y | [repeat | space | round | no-repeat]{1,2} 		repeat repeat

A series of repeat-style values, separated by commas. Each item in the series applies to the corresponding image in the series of border images.
-fx-border-image-slice

[<size> | <size> <size> <size> <size> ] fill? [ , [ <size> | <size> <size> <size> <size> <size> ] fill? ]*

 100%

A series of image slice values or sets of four values, separated by commas. Each item in the series applies to the corresponding image in the series of border images. For each item in the series, if four values are given, they specify the size of the top, right, bottom, and left slices. This effectively divides the image into nine regions: an upper left corner, a top edge, an upper right corner, a right edge, a lower right corner, a bottom edge, a lower left corner, a left edge and a middle. If one value is specified, this value is used for the slice values for all four edges. If 'fill' is present, the middle slice is preserved, otherwise it is discarded. Percentage values may be used here, in which case the values are considered proportional to the source image.
-fx-border-image-width <size> | <size> <size> <size> <size> [ , [ <size> | <size> <size> <size> <size>] ]* 1 1 1 1

A series of width or sets of four width values, separated by commas. For each item in the series, a single width value means that all border widths are the same; and if a set of four width values is specified, they are used for the top, right, bottom, and left border widths, in that order. If the border is not rectangular, only the first width value is used. Each item in the series of widths applies to the corresponding item in the series of border images. Percentage values may be used here, in which case the values are considered proportional to the border image area.
OTHER
-fx-padding <size> | <size> <size> <size> <size> 0 0 0 0

A sets of four padding values, separated by commas. For each item in the series, a single padding value means that all padding are the same; and if a set of four padding values is specified, they are used for the top, right, bottom, and left edges of the region, in that order.
-fx-position-shape | <boolean> | true | If true means the shape centered within the region's width and height, otherwise the shape is positioned at its source position. Has no effect if a shape string is not specified.
-fx-scale-shape | <boolean> | true | If true means the shape is scaled to fit the size of the region, otherwise the shape is at its source size, and its position depends on the value of the position-shape property. Has no effect if a shape string is not specified.
-fx-shape | "<string>" | null | An SVG path string. By specifying a shape here the region takes on that shape instead of a rectangle or rounded rectangle. The syntax of this path string is specified in [3].
-fx-snap-to-pixel | <boolean> | true | Defines whether this region rounds position/spacing and ceils size values to pixel boundaries when laying out its children.
-fx-region-background | null | This property is set by specifying -fx-background-color and/or -fx-background-image. Optionally, the properties -fx-background-insets, -fx-background-radius, -fx-background-position, -fx-background-repeat, and -fx-background-size may also be set. In order to set the Region background to null, specify the style "-fx-background-color: null; -fx-background-image: null;". There is no shorthand notation for -fx-region-background at this time.
-fx-region-border | null | This property is set by specifying -fx-border-color and/or -fx-border-image. Optionally -fx-border-insets, -fx-border-radius, -fx-border-style, -fx-border-width, -fx-border-image-insets, -fx-border-image-repeat, -fx-border-image-slice and -fx-border-image-width may be specified. In order to set the Region background to null, specify the style "-fx-border-color: null; -fx-border-image: null;". There is no shorthand notation for -fx-region-border at this time.
-fx-min-height, -fx-pref-height, -fx-max-height | <size> | -1 | Percentage values are not useful since the actual value would be computed from the width and/or height of the Regions's parent before the parent is laid out.
-fx-min-width, -fx-pref-width, -fx-max-width | <size> | -1 | Percentage values are not useful since the actual value would be computed from the width and/or height of the Region's parent before the parent is laid out.
Also has all properties of Parent

StackPane

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-alignment | [ top-left | top-center | top-right | center-left | center | center-right bottom-left | bottom-center | bottom-right | baseline-left | baseline-center | baseline-right ] | top-left |
Also has all properties of Pane

TilePane

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-orientation | [ horizontal | vertical ] | horizontal |
-fx-pref-rows | <integer> | 5 |
-fx-pref-columns | <integer> | 5 |
-fx-pref-tile-width | <size> | -1 |
-fx-pref-tile-height | <size> | -1 |
-fx-hgap | <size> | 0 |
-fx-vgap | <size> | 0 |
-fx-alignment | [ top-left | top-center | top-right | center-left | center | center-right bottom-left | bottom-center | bottom-right | baseline-left | baseline-center | baseline-right ] | top-left |
-fx-tile-alignment | [ top-left | top-center | top-right | center-left | center | center-right bottom-left | bottom-center | bottom-right | baseline-left | baseline-center | baseline-right ] | center |
Also has all properties of Pane

VBox

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-spacing | <size> | 0 |
-fx-alignment | [ top-left | top-center | top-right | center-left | center | center-right bottom-left | bottom-center | bottom-right | baseline-left | baseline-center | baseline-right ] | top-left |
-fx-fill-width | <boolean> | true |
Also has all properties of Pane
javafx.scene.media

MediaView

Style class: media-view

javafx.scene.shape

Shape

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-fill | <paint> | BLACK |
-fx-smooth | <boolean> | true |
-fx-stroke | <paint> | null |
-fx-stroke-type | [ inside | outside | centered ] | centered |
-fx-stroke-dash-array | <size>[ <size>]+ | see comment | The initial value is that of an empty array, effectively a solid line.
-fx-stroke-dash-offset | <number> | 0 |
-fx-stroke-line-cap | [ square | butt | round ] | square |
-fx-stroke-line-join | [ miter | bevel | round ] | miter |
-fx-stroke-miter-limit | <number> | 10 |
-fx-stroke-width | <size> | 1 |
Also has all properties of Node

Arc

Style class: empty by default

The Arc node has all the properties of Shape and Node.

Circle

Style class: empty by default

The Circle node has all the properties of Shape and Node.

CubicCurve

Style class: empty by default

The CubicCurve node has all the properties of Shape and Node.

Ellipse

Style class: empty by default

The Ellipse node has all the properties of Shape and Node.

Line

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-fill | <paint> | null |
-fx-stroke | <paint> | black |
Also has all properties of Shape

Path

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-fill | <paint> | null |
-fx-stroke | <paint> | black |
Also has all properties of Shape

Polygon

Style class: empty by default

The Polygon node has all the properties of Shape and Node.

QuadCurve

Style class: empty by default

The QuadCurve node has all the properties of Shape and Node.

Rectangle

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-arc-height | <size> | 0 |
-fx-arc-width | <size> | 0 |
Also has all properties of Shape

SVGPath

Style class: empty by default

The SVGPath node has all the properties of Shape and Node.

javafx.scene.text

Text

Style class: empty by default

CSS Property | Values | Default | Comments
-fx-font | <font> | Font.DEFAULT | inherits
-fx-font-smoothing-type | [ gray | lcd ] | gray |
-fx-strikethrough | <boolean> | false |
-fx-text-alignment | [ left | center | right | justify ] | left | inherits
-fx-text-origin | [ baseline | top | bottom ] | baseline |
-fx-underline | <boolean> | false |
Also has font properties and all properties of Shape
javafx.scene.web

WebView

Style class: web-view

CSS Property | Values | Default | Comments
-fx-context-menu-enabled | <boolean> | true |
-fx-font-smoothing-type | [ gray | lcd ] | lcd |
-fx-font-scale | <number> | 1 |
-fx-min-width | <size> | 0 |
-fx-min-height | <size> | 0 |
-fx-pref-width | <size> | 800 |
-fx-pref-height | <size> | 600 |
-fx-max-width | <size> | Double.MAX_VALUE |
-fx-max-height | <size> | Double.MAX_VALUE |
Also has all properties of Parent
javafx.scene.control

Since JavaFX 2.0, the default skins for all controls support styling from CSS. This is accomplished by building the skins from layout objects called Regions. Most of the style properties for a control are provided by the Region objects that comprise the control's skin. Each Region object of the skin's substructure has its own style‑class so that it can be styled specifically. The control itself will sometimes provide CSS properties in addition to those provided by its Regions. Finally, controls may also define pseudo‑classes such as "vertical" and "horizontal" in addition to those defined by Node.

With the following exceptions, controls are focus traversable. This means that Control sets the initial value of the focusTraversable property true; whereas in Node, the initial value of the focusTraversable property is false. The following controls are not focus traversable by default: Accordion, Cell, Label, MenuBar, ProgressBar, ProgressIndicator, ScrollBar, ScrollPane, Separator, SplitPane, ToolBar.

Accordion

Style class: accordion

The Accordion control has all the properties and pseudo‑classes of Control

Substructure

  • first-titled-pane — the first TitledPane

Button

Style class: button

The Button control has all the properties of ButtonBase

Pseudo-classes

CSS Pseudo-class | Comments
cancel | applies if this Button receives VK_ESC if the event is not otherwise consumed
default | applies if this Button receives VK_ENTER if the event is not otherwise consumed
Also has all pseudo‑classes of ButtonBase

ButtonBase

The ButtonBase control has all the properties of Labeled

Pseudo-classes

CSS Pseudo-class | Comments
armed | applies when the armed variable is true
Also has all pseudo‑classes of Labeled

Cell

Style class: cell

CSS Property | Values | Default | Comments
-fx-cell-size | <size> | 24 | The cell size. For vertical ListView or a TreeView or TableView this is the height, for a horizontal ListView this is the width.
The Cell control has all the properties of Labeled

Pseudo-classes

CSS Pseudo-class | Comments
empty | applies when the empty variable is true
filled | applies when the empty variable is false
selected | applies when the selected variable is true
Also has all pseudo‑classes of Labeled

Substructure

  • text — a Labeled

CheckBox

Style class: check-box

The CheckBox control has all the properties of ButtonBase

Pseudo-classes

CSS Pseudo-class | Comments
selected | applies when the selected variable is true
determinate | applies when the indeterminate variable is false
indeterminate | applies when the indeterminate variable is true
Also has all pseudo‑classes of ButtonBase

Substructure

  • box — a StackPane
    • mark — a StackPane

CheckMenuItem

Pseudo-classes

CSS Pseudo-class | Comments
selected | applies if this item is selected

ChoiceBox

Style class: choice-box

The ChoiceBox control has all the properties and pseudo‑classes of Control

Substructure

  • open-button — Region
    • arrow — Region

ColorPicker

Style class: color-picker

The ColorPicker control has all the properties and pseudo‑classes of ComboBoxBase

CSS Property | Values | Default | Comments
-fx-color-label-visible | <boolean> | true |
Also has all properties of Control

Substructure

  • color display node — Label
  • arrow-button — StackPane
    • arrow — StackPane

ComboBox

Style class: combo-box

The ComboBox control has all the properties and pseudo‑classes of ComboBoxBase

Substructure

  • list-cell — a ListCell instance used to show the selection in the button area of a non-editable ComboBox
  • text-input — a TextField instance used to show the selection and allow input in the button area of an editable ComboBox
  • combo-box-popup — a PopupControl that is displayed when the button is pressed
    • list-view — a ListView
      • list-cell — a ListCell

ComboBoxBase

Style class: combo-box-base

The ComboBoxBase control has all the properties of Control

Substructure

  • arrow-button — a StackPane
    • arrow — a StackPane
CSS Pseudo-class | Comments
editable | applies when the editable variable is true
showing | applies when the showing variable is true
armed | applies when the armed variable is true

ContextMenu

Style class: context-menu

The ContextMenu class has all the properties of PopupControl.

The selector for a ContextMenu may be made more specific by using the selector for the control from which the ContextMenu was shown. For example,

.choice-box > .context-menu { ... }

Substructure

  • context-menu — a Region
    • scroll-arrow — a StackPane
      • menu-up-arrow — a StackPane
    • scroll-arrow — a StackPane
      • menu-down-arrow — a StackPane
    • * — a VBox
      • menu-item — a Region
        • label — a Label
        • left-container — a StackPane (for radio buttons and check boxes)
        • right-container — a StackPane (for pull-right menus)
          • arrow — a Region
        • graphic-container — a StackPane (for MenuItem graphic)

Control

The Control class has all the properties of Region

CSS Property | Values | Default | Comments
-fx-skin | <string> | null | The class name of the Control's Skin.
-fx-focus-traversable | <boolean> | true | Control sets the default value of the focusTraversable property to true. The default value of the focusTraversable property for the following controls is false: Accordion, Cell, Label, MenuBar, ProgressBar, ProgressIndicator, ScrollBar, ScrollPane, Separator, SplitPane, ToolBar.

DatePicker

Style class: date-picker

The DatePicker control has all the properties and pseudo‑classes of ComboBoxBase

CSS Property | Values | Default | Comments
-fx-show-week-numbers | <boolean> | true if the resource bundle property "DatePicker.showWeekNumbers" contains the country code. |
Also has all properties of Control

Substructure

  • date-picker-display-node — TextField

HTMLEditor

Style class: html-editor

The Hyperlink control has all the properties of Control.

Substructure

  • grid — GridPane (contains WebView)
    • top-toolbar — ToolBar
      • html-editor-cut — ToggleButton
      • html-editor-copy — ToggleButton
      • html-editor-paste — ToggleButton
      • html-editor-align-left — ToggleButton
      • html-editor-align-right — ToggleButton
      • html-editor-align-center — ToggleButton
      • html-editor-align-justify — ToggleButton
      • html-editor-outdent — ToggleButton
      • html-editor-indent — ToggleButton
      • html-editor-bullets — ToggleButton
      • html-editor-numbers — ToggleButton
    • web-view — WebView
    • bottom-toolbar — ToolBar
      • format-menu-button — ComboBox
      • font-family-menu-button — ComboBox
      • font-size-menu-button — ComboBox
      • html-editor-bold — ToggleButton
      • html-editor-italic — ToggleButton
      • html-editor-underline — ToggleButton
      • html-editor-strike — ToggleButton
      • html-editor-hr — ToggleButton
      • html-editor-foreground — ColorPicker
      • html-editor-background — ColorPicker

Hyperlink

Style class: hyperlink

The Hyperlink control has all the properties of ButtonBase.

CSS Property | Values | Default | Comments
-fx-cursor | [ null | crosshair | default | hand | move | e-resize | h-resize | ne-resize | nw-resize | n-resize | se-resize | sw-resize | s-resize | w-resize | v-resize | text | wait ] | <url> | hand | inherits

Pseudo-classes

CSS Pseudo-class | Comments
visited | applies when the visited variable is true
Also has all pseudo‑classes of ButtonBase

Substructure

  • label — Label

IndexedCell

Style class: indexed-cell

The IndexedCell control has all the properties of Cell.

Pseudo-classes

CSS Pseudo-class | Comments
even | applies if this cell's index is even
odd | applies if this cell's index is odd
Also has all pseudo‑classes of Cell

Label

Style class: label

Label has all the properties and pseudo‑class state of Labeled

Labeled

CSS Property | Values | Default | Comments
-fx-alignment | [ top-left | top-center | top-right | center-left | center | center-right bottom-left | bottom-center | bottom-right | baseline-left | baseline-center | baseline-right ] | center-left |
-fx-text-alignment | [ left | center | right | justify ] | left | text-align from CSS spec maps to textAlignment in JavaFX
-fx-text-overrun | [ center-ellipsis | center-word-ellipsis | clip | ellipsis | leading-ellipsis | leading-word-ellipsis | word-ellipsis ] | ellipsis |
-fx-wrap-text | <boolean> | false |
-fx-font | <font> | platform dependent | inherits The initial value is that of Font.getDefault()
-fx-underline | <boolean> | false |
-fx-graphic | <uri> | null |
-fx-content-display | [ top | right | bottom | left | center | right | graphic-only | text-only ] | left |
-fx-graphic-text-gap | <size> | 4 |
-fx-label-padding | <size> | <size> <size> <size> <size> | [0,0,0,0] |
-fx-text-fill | <paint> | black |
-fx-ellipsis-string | <string> | ... |
Also has properties of Control

ListCell

Style class: list-cell

The ListCell control has all the settable properties and pseudo‑classes of IndexedCell.

ListView

Style class: list-view

CSS Property | Values | Default | Comments
-fx-orientation | [ horizontal | vertical ] | vertical |

Pseudo-classes

CSS Pseudo-class | Comments
horizontal | applies if this ListView is horizontal
vertical | applies if this ListView is vertical

Substructure

    .list-view — the ListView<T>
      .virtual-flow — VirtualFlow
        .clipped-container — Region
          .sheet — Group
            .cell.indexed-cell.list-cell — ListCell<T>
          .scroll-bar — ScrollBar

Menu

Style class: menu

Pseudo-classes

CSS Pseudo-class | Comments
showing | applies if this Menu is showing
Also has all pseudo‑classes of Control

MenuBar

Style class: menu-bar

CSS Property | Values | Default | Comments
-fx-use-system-menu-bar | <boolean> | false |
Also has all properties of Control

MenuBar has all the pseudo‑class states of Control

Substructure

  • menu

MenuButton

Style class: menu-button

The MenuButton control has all the properties of ButtonBase

Pseudo-classes

CSS Pseudo-class | Comments
openvertically | applies if the openVertically variable is true
showing | applies if the showing variable is true
Also has all pseudo‑classes of Node

MenuItem

Style class: menu-item

Pagination

Style class: pagination

Pagination has all the pseudo‑class states of Control

CSS Property | Values | Default | Comments
-fx-max-page-indicator-count | <number> | 10 |
-fx-arrows-visible | <boolean> | true |
-fx-tooltip-visible | <boolean> | false | When set to true, a tooltip which shows the page number is set on the page indicators. This property controls whether or not the tooltip is visible on the page indicators and does not affect the visibility of the tooltip set or installed on the Pagination control itself.
-fx-page-information-visible | <boolean> | true |
-fx-page-information-alignment | [ top | bottom | left | right ] | bottom |
Also has all properties of Control

Substructure

  • page — StackPane
  • pagination-control — StackPane
    • leftArrowButton — Button
      • leftArrow — StackPane
    • rightArrowButton — Button
      • rightArrow — StackPane
    • bullet-button — ToggleButton
    • number-button — ToogleButton
    • page-information — Label

PasswordField

Style class: password-field

The PasswordField control has all the properties of TextField

PopupControl

PopupControl is also a PopupWindow and as such, its root node has the style-class .root.popup

ProgressBar

Style class: progress-bar

CSS Property | Values | Default | Comments
-fx-indeterminate-bar-length | <number> | 60 |
-fx-indeterminate-bar-escape | <boolean> | true |
-fx-indeterminate-bar-flip | <boolean> | true |
-fx-indeterminate-bar-animation-time | <number> | 2.0 |
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
determinate | applies if the indeterminate variable is false
indetermindate | applies if the indeterminate variable is true
Also has all pseudo‑classes of Control

Substructure

  • track — StackPane
    • bar — Region

ProgressIndicator

Style class: progress-indicator

CSS Property | Values | Default | Comments
-fx-indeterminate-segment-count | <number> | 8 |
-fx-progress-color | <paint> | null |
-fx-spin-enabled | <boolean> | false |
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
determinate | applies if the indeterminate variable is false
indetermindate | applies if the indeterminate variable is true
Also has all pseudo‑classes of Control

Substructure

  • indicator — StackPane
  • progress — StackPane
  • percentage — Text
  • tick — StackPane

RadioButton

Style class: radio-button

The RadioButton control has all the properties of ToggleButton

Substructure

  • radio — Region
    • dot — Region
  • label — Label

RadioMenuItem

Pseudo-classes

CSS Pseudo-class | Comments
selected | applies if this item is selected

ScrollBar

Style class: scroll-bar

CSS Property | Values | Default | Comments
-fx-orientation | [ horizontal | vertical ] | horizontal |
-fx-block-increment | <number> | 10 |
-fx-unit-increment | <number> | 1 |

Pseudo-classes

CSS Pseudo-class | Comments
vertical | applies if this ScrollBar is vertical
horizontal | applies if this ScrollBar is horizontal
Also has all pseudo‑classes of Control

Substructure

  • decrement-button — StackPane
    • decrement-arrow — StackPane
  • track — StackPane
  • thumb — StackPane
  • increment-button — StackPane
    • increment-arrow — StackPane

ScrollPane

Style class: scroll-pane

CSS Property | Values | Default | Comments
-fx-fit-to-width | <boolean> | false |
-fx-fit-to-height | <boolean> | false |
-fx-pannable | <boolean> | false |
-fx-hbar-policy | [ never | always | as-needed ] | as-needed |
-fx-vbar-policy | [ never | always | as-needed ] | as-needed |
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
pannable | applies if this ScrollPane is pannable
fitToWidth | applies if this ScrollPane is fitToWidth
fitToHeight | applies if this ScrollPane is fitToHeight
Also has all pseudo‑classes of Control

Substructure

  • viewport — StackPane
    • * — StackPane
      • The ScrollPane's content
  • scroll-bar:vertical — ScrollBar
  • scroll-bar:horizontall — ScrollBar
  • corner — StackPane

Separator

Style class: separator

CSS Property | Values | Default | Comments
-fx-orientation | [ horizontal | vertical ] | horizontal |
-fx-halignment | [ left | center | right ] | center |
-fx-valignment | [ top | center | baseline | bottom ] | center |
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
horizontal | applies if this Separator is horizontal
vertical | applies if this Separator is vertical
Also has all pseudo‑classes of Control

Substructure

  • line — Region

Spinner

Style class: spinner

Note that the default style class, "spinner", puts arrows on right, stacked vertically. The following style classes can also be used in combination with the default style class in order to control the layout of the Spinner.

style class | Comment
arrows-on-right-horizontal | The arrows are placed on the right of the Spinner, pointing horizontally (i.e. left and right)
arrows-on-left-vertical | The arrows are placed on the left of the Spinner, pointing vertically (i.e. up and down)
arrows-on-left-horizontal | The arrows are placed on the left of the Spinner, pointing horizontally (i.e. left and right)
split-arrows-vertical | The arrows are placed above and beneath the spinner, stretching to take the entire width
split-arrows-horizontal | The decrement arrow is placed on the left of the Spinner, and the increment on the right

CSS Property Values Default Comments
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class Comments
Also has all pseudo‑classes of Control

Substructure

  • text-field — TextField
  • increment-arrow-button — StackPane
    • increment-arrow — Region
  • decrement-arrow-button — StackPane
    • decrement-arrow — Region

Slider

Style class: slider

CSS Property | Values | Default | Comments
-fx-orientation | [ horizontal | vertical ] | horizontal |
-fx-show-tick-labels | <boolean> | false |
-fx-show-tick-marks | <boolean> | false |
-fx-major-tick-unit | <number> | 25 |
-fx-minor-tick-count | <integer> | 3 |
-fx-show-tick-labels | <boolean> | false |
-fx-snap-to-ticks | <boolean> | false |
-fx-block-increment | <integer> | 10 |
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
horizontal | applies if this Slider is horizontal
vertical | applies if this Slider is vertical
Also has all pseudo‑classes of Control

Substructure

  • axis — NumberAxis
  • track — Region
  • thumb — Region

SplitMenuButton

Style class: split-menu-button

CSS Property Values Default Comments
Also has all properties of MenuButton

SplitPane

Style class: split-pane

CSS Property | Values | Default | Comments
-fx-orientation | [ horizontal | vertical ] | horizontal |
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
horizontal | applies if this Slider is horizontal
vertical | applies if this Slider is vertical
Also has all pseudo‑classes of Control

Substructure

  • split-pane-divider — StackPane
    • vertical-grabber — StackPane
    • horizontal-grabber — StackPane

TabPane

Style class: tab-pane

Note: The styleclass is "tab-pane floating" if the TabPane is floating.

CSS Property | Values | Default | Comments
-fx-tab-min-width | <integer> | 0 |
-fx-tab-max-width | <integer> | Double.MAX_VALUE |
-fx-tab-min-height | <integer> | 0 |
-fx-tab-max-height | <integer> | Double.MAX_VALUE |
-fx-open-tab-animation | [ grow | none ] | grow | 'none' disables Tab opening animation
-fx-close-tab-animation | [ grow | none ] | grow | 'none' disables Tab closing animation
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
top | applies if the side is top
right | applies if the side is rght
bottom | applies if the side is bottom
left | applies if the side is left
Also has all pseudo‑classes of Control

Substructure

  • tab-header-area — StackPane
    • headers-region — StackPane
    • tab-header-background — StackPane
    • control-buttons-tab — StackPane
      • tab-down-button — Pane
        • arrow — StackPane
    • tab — Tab
      • tab-label — Label
      • tab-close-button — StackPane
  • tab-content-area — StackPane

TableColumnHeader

Style class: column-header

CSS Property | Values | Default | Comments
-fx-size | <size> | 20 | The table column header size.
Also has all properties of Region

Pseudo-classes

CSS Pseudo-class | Comments
last-visible | applies if this is the last visible column in the table.
Also has all pseudo‑classes of Node

Substructure

  • column-resize-line — Region
  • column-overlay — Region
  • placeholder — StackPane
  • column-header-background — StackPane
    • nested-column-header
      • column-header
    • filler — Region
    • show-hide-columns-button — StackPane
      • show-hide-column-image — StackPane
    • column-drag-header — StackPane
      • label — Label

TableView

Style class: table-view

CSS Property | Values | Default | Comments
-fx-fixed-cell-size | <size> | -1 | A value greater than zero sets the fixed cell size of the table. A value of zero or less disables fixed cell size.
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
cell-selection | applies if this TableView's selection model is cell selection
row-selection | applies if this TableView's selection model is row selection
Also has all pseudo‑classes of Node

Substructure

  • column-resize-line — Region
  • column-overlay — Region
  • placeholder — StackPane
  • column-header-background — StackPane
    • nested-column-header
      • column-header
    • filler — Region
    • show-hide-columns-button — StackPane
      • show-hide-column-image — StackPane
    • column-drag-header — StackPane
      • label — Label
  • table-column — TableColumn

TextArea

Style class: text-area

CSS Property | Values | Default | Comments
-fx-pref-column-count | number | 40 |
-fx-pref-row-count | number | 10 |
-fx-wrap-text | boolean | false |
Also has all properties of TextInputControl

Substructure

  • scroll-pane — ScrollPane
    • content — Region

TextInputControl

CSS Property | Values | Default | Comments
-fx-font | <font> | null | inherits
-fx-text-fill | <paint> | black |
-fx-prompt-text-fill | <paint> | gray |
-fx-highlight-fill | <paint> | dodgerblue |
-fx-highlight-text-fill | <paint> | white |
-fx-display-caret | <boolean> | true |
Also has Font Properties and all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
readonly | applies if this TextInputControl is not editable
Also has all pseudo‑classes of Control

TextField

Style class: text-field

CSS Property | Values | Default | Comments
-fx-alignment | [ top-left | top-center | top-right | center-left | center | center-right bottom-left | bottom-center | bottom-right | baseline-left | baseline-center | baseline-right ] | center-left |
-fx-pref-column-count | number | 12 |
Also has all properties of TextInputControl

TextField has all the pseudo‑class states of TextInputControl

TitledPane

CSS Property | Values | Default | Comments
-fx-animated | <boolean> | true |
-fx-collapsible | <boolean> | true |
Also has Font Properties and all properties of Labeled

Pseudo-classes

CSS Pseudo-class | Comments
expanded | applies if this TitledPane is expanded
collapsed | applies if this TitledPane is collapsed
Also has all pseudo‑classes of Labeled

Substructure

  • title — HBox
    • text — Label/li>
    • arrow-button — StackPane/li>
      • arrow — StackPane
  • content — StackPane/li>

ToggleButton

Style class: toggle-button

The ToggleButton control has all the properties of ButtonBase.

Pseudo-classes

CSS Pseudo-class | Comments
selected | applies if this ToggleButton is selected
Also has all pseudo‑classes of ButtonBase

ToolBar

Style class: tool-bar

CSS Property | Values | Default | Comments
-fx-orientation | [ horizontal | vertical ] | horizontal |
Also has all properties of Control

Pseudo-classes

CSS Pseudo-class | Comments
horizontal | applies if this ToolBar is horizontal
vertical | applies if this ToolBar is vertical
Also has all pseudo‑classes of Control

Substructure

  • tool-bar-overflow-button — StackPane
    • arrow — StackPane

Tooltip

Style class: tooltip

CSS Property | Values | Default | Comments
-fx-text-alignment | [ left | center | right | justify ] | left |
-fx-text-overrun | [ center-ellipsis | center-word-ellipsis | clip | ellipsis | leading-ellipsis | leading-word-ellipsis | word-ellipsis ] | ellipsis |
-fx-wrap-text | <boolean> | false |
-fx-graphic | <uri> | null |
-fx-content-display | [ top | right | bottom | left | center | right | graphic-only | text-only ] | left |
-fx-graphic-text-gap | <size> | 4 |
-fx-font | <font> | Font.DEFAULT | inherits
-fx-show-delay | <duration> | 1000ms |
-fx-show-duration | <duration> | 5000ms |
-fx-hide-delay | <duration> | 200ms |

Substructure

  • label — Label
  • page-corner — StackPane

TreeCell

Style class: tree-cell

CSS Property | Values | Default | Comments
-fx-indent | <size> | 10 | The amout of space to multiply by the treeItem.level to get the left margin
Also has all properties of IndexedCell

Pseudo-classes

CSS Pseudo-class | Comments
expanded | applies if this cell is expanded
collapsed | applies if this cell is not expanded
Also has all pseudo‑classes of IndexedCell

TreeTableCell

Style class: tree-table-cell

CSS Property Values Default Comments
Also has all properties of IndexedCell

Pseudo-classes

CSS Pseudo-class | Comments
last-visible | true if this is the last visible cell, typically the right-most cell in the TreeTableView
Also has all pseudo‑classes of IndexedCell

TreeView

Style class: tree-table-view

CSS Property | Values | Default | Comments
-fx-fixed-cell-size | <size> | Region.USE_COMPUTED_SIZE | If both -fx-cell-size and -fx-fixed-cell-size properties are specified in CSS, -fx-fixed-cell-size takes precedence.
Also has all properties and pseudo‑class state of Control

TreeView

Style class: tree-view

CSS Property | Values | Default | Comments
-fx-fixed-cell-size | <size> | Region.USE_COMPUTED_SIZE | If both -fx-cell-size and -fx-fixed-cell-size properties are specified in CSS, -fx-fixed-cell-size takes precedence.
Also has all properties and pseudo‑class state of Control

Charts

javafx.scene.chart

AreaChart

Style class | Comments | Properties
"chart-series-area-line series<i> default-color<j>" | Where <i> is the index of the series and <j> is the series’ color index. | Node
"chart-series-area-fill series<i> default-color<j>" | Where <i> is the index of the series and <j> is the series’ color index. | Path
"chart-area-symbol series<i> data<j> default-color<k>" | Where <i> is the index of the series, <j> is the index of the data within the series, and <k> is the series’ color index | Path
"chart-area-symbol series<i> area-legend-symbol default-color<j>" | Where <i> is the index of the series and <j> is the series’ color index | LegendItem

CSS Property Values Default Comments
Has all properties of XYChart

Axis

Style class: axis

CSS Property | Values | Default | Comments
-fx-side | Side | null |
-fx-tick-length | <size> | 8 |
-fx-tick-label-font | <font> | 8 system |
-fx-tick-label-fill | <paint> | black |
-fx-tick-label-gap | <size> | 3 |
-fx-tick-mark-visible | <boolean> | true |
-fx-tick-labels-visible | <boolean> | true |
Has all properties of Region

Substructure

  • axis-label — Text
  • axis-tick-mark — Path

BarChart

Style class | Comments | Properties
"bar-chart" |  |
"chart-bar series<i> data<j> default-color<k>" | Where <i> is the index of the series, <j> is the index of the data within the series, and <k> is the series’ color index. If the data value is negative, the "negative" style class is added; e.g., .negative.chart-bar. | Node
"chart-bar series<i> bar-legend-symbol default-color<j>" | Where <i> is the index of the series and <j> is the series’ color index | LegendItem

CSS Property | Values | Default | Comments
-fx-bar-gap | <number> | 4 |
-fx-category-gap | <number> | 10 |
Has all properties of XYChart

BubbleChart

Style class | Comments | Properties
"chart-bubble series<i> data<j> default-color<k>" | Where <i> is the index of the series, <j> is the index of the data within the series, and <k> is the series’ color index | Node
"chart-bubble series<i> bubble-legend-symbol default-color<j>" | Where <i> is the index of the series and <j> is the series’ color index | LegendItem

CSS Property Values Default Comments
Has all properties of XYChart

CategoryAxis

Style class: axis

CSS Property | Values | Default | Comments
-fx-start-margin | <number> | 5 | The margin between the axis start and the first tick-mark
-fx-end-margin | <number> | 5 | The margin between the axis start and the first tick-mark
-fx-gap-start-and-end | <boolean> | true | If this is true then half the space between ticks is left at the start and end
Has all properties of Axis

Chart

Style class: chart

CSS Property | Values | Default | Comments
-fx-legend-side | Side | bottom |
-fx-legend-visible | <boolean> | true |
-fx-title-side | Side | top |
Has all properties of Region

Substructure

  • chart-title — Label
  • chart-content — Pane

Legend

Style class: chart-legend

CSS Property Values Default Comments
Has all properties of Region

Substructure

  • chart-legend-item — Label
  • chart-legend-item-symbol — Node (the Label's graphic)

LineChart

Style class | Comments | Properties
"chart-series-line series<i> default-color<j>" | Where <i> is the index of the series and <j> is the series’ color index | Node
"chart-line-symbol series<i> data<j> default-color<k>" | Where <i> is the index of the series, <j> is the index of the data within the series, and <k> is the series’ color index | Node
"chart-line-symbol series<i> default-color<j>" | Where <i> is the index of the series and <j> is the series’ color index | LegendItem

CSS Property | Values | Default | Comments
-fx-create-symbols | <boolean> | true |
Has all properties of XYChart

NumberAxis

Style class: axis

CSS Property | Values | Default | Comments
-fx-tick-unit | <number> | 5 | The value between each major tick mark in data units.
Has all properties of ValueAxis

PieChart

Style class | Comments | Properties
"chart-pie data<i> default-color<j>" | Where <i> is the index of the data and <j> is the series’ color index. If the data value is negative, the "negative" style‑class is added; e.g., .negative.chart-pie. | Node
"chart-pie-label-line;" |  | Path
"chart-pie-label;" |  | Text
"pie-legend-symbol <i–th data item’s style‑class>" | Each item in the legend has the style‑class "pie-legend-symbol" plus the style‑class of the corresponding data item | LegendItem

CSS Property | Values | Default | Comments
-fx-clockwise | <boolean> | true |
-fx-pie-label-visible | <boolean> | true |
-fx-label-line-length | <size> | 20 |
-fx-start-angle | <number> | 0 |
Has all properties of Chart

ScatterChart

Style class | Comments | Properties
"chart-symbol series<i> data<j> default-color<k>" | Where <i> is the index of the series, <j> is the index of the data within the series, and <k> is the series’ color index | Node
 | The LegendItem symbols are assigned the style‑class of the first symbol of the series. | LegendItem

CSS Property Values Default Comments
Has all properties of XYChart

ValueAxis

Style class: axis

CSS Property | Values | Default | Comments
-fx-minor-tick-length | <size> | 5 |
-fx-minor-tick-count | <size> | 5 |
-fx-minor-tick-visible | <boolean> | true |
Has all properties of Axis

Substructure

  • axis-minor-tick-mark — Path

XYChart

Style class: set by sub-type

CSS Property | Values | Default | Comments
-fx-alternative-column-fill-visible | <boolean> | true |
-fx-alternative-row-fill-visible | <boolean> | true |
-fx-horizontal-grid-lines-visible | <boolean> | true |
-fx-horizontal-zero-line-visible | <boolean> | true |
-fx-vertical-grid-lines-visible | <boolean> | true |
-fx-vertical-zero-line-visible | <boolean> | true |
Has all properties of chart

Substructure

  • plot-content — Group
  • chart-plot-background — Region
  • chart-alternative-column-fill — Path
  • chart-alternative-row-fill — Path
  • chart-vertical-grid-lines — Path
  • chart-horizontal-grid-lines — Path
  • chart-vertical-zero-line — Line
  • chart-horizontal-zero-line — Line

References

[1] CSS 2.1: http://www.w3.org/TR/CSS21/

[2] CSS 3 work in progress http://www.w3.org/Style/CSS/current-work (May 2010).

[3] SVG Paths: http://www.w3.org/TR/SVG/paths.html

[4] CSS Backgrounds and Borders Module Level 3: http://www.w3.org/TR/css3-background/

[5] Uniform Resource Identifier (URI): Generic Syntax RFC-3986

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 2008, 2017, Oracle and/or its affiliates. All rights reserved.
DRAFT 9-ea


Blend (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Blend

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.Blend

  • public class Blend
extends Effect
    使用预定义的BlendMode之一将两个输入组合在一起的效果。

    例：

       Blend blend = new Blend(); blend.setMode(BlendMode.COLOR_BURN); ColorInput colorInput = new ColorInput(); colorInput.setPaint(Color.STEELBLUE); colorInput.setX(10); colorInput.setY(10); colorInput.setWidth(100); colorInput.setHeight(180); blend.setTopInput(colorInput); Rectangle rect = new Rectangle(); rect.setWidth(220); rect.setHeight(100); Stop[] stops = new Stop[]{new Stop(0, Color.LIGHTSTEELBLUE), new Stop(1, Color.PALEGREEN)}; LinearGradient lg = new LinearGradient(0, 0, 0.25, 0.25, true, CycleMethod.REFLECT, stops); rect.setFill(lg); Text text = new Text(); text.setX(15); text.setY(65); text.setFill(Color.PALEVIOLETRED); text.setText("COLOR_BURN"); text.setFont(Font.font(null, FontWeight.BOLD, 30)); Group g = new Group(); g.setEffect(blend); g.getChildren().addAll(rect, text);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Effect> bottomInput
      这个 Blend操作的底部输入。
      ObjectProperty<BlendMode> mode
      BlendMode用于将两个输入混合在一起。
      DoubleProperty opacity
      不透明度值，它在混合前用顶部输入进行调制。
      ObjectProperty<Effect> topInput
      这是 Blend操作的顶部输入。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Blend​()
      使用默认参数创建Blend的新实例。
      Blend​(BlendMode mode)
      使用指定的模式创建Blend的新实例。
      Blend​(BlendMode mode, Effect bottomInput, Effect topInput)
      使用指定的模式和底部和顶部输入创建Blend的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Effect> bottomInputProperty​()
      这个 Blend操作的底部输入。
      Effect getBottomInput​()
      获取属性bottomInput的值。
      BlendMode getMode​()
      获取属性模式的值。
      double getOpacity​()
      获取属性不透明度的值。
      Effect getTopInput​()
      获取属性topInput的值。
      ObjectProperty<BlendMode> modeProperty​()
      BlendMode用于将两个输入混合在一起。
      DoubleProperty opacityProperty​()
      不透明度值，它在混合前用顶部输入进行调制。
      void setBottomInput​(Effect value)
      设置属性bottomInput的值。
      void setMode​(BlendMode value)
      设置属性模式的值。
      void setOpacity​(double value)
      设置属性不透明度的值。
      void setTopInput​(Effect value)
      设置属性topInput的值。
      ObjectProperty<Effect> topInputProperty​()
      这个 Blend操作的最大输入。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • mode

        public final ObjectProperty<BlendMode> modeProperty
        BlendMode用于将两个输入混合在一起。
          Min: n/a
       Max: n/a
   Default: BlendMode.SRC_OVER
  Identity: n/a
        Default value:
        SRC_OVER
        另请参见：
        getMode() ， setMode(BlendMode)

      • opacity

        public final DoubleProperty opacityProperty
        不透明度值，它在混合前用顶部输入进行调制。
          Min: 0.0
       Max: 1.0
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0
        另请参见：
        getOpacity() ， setOpacity(double)

      • bottomInput

        public final ObjectProperty<Effect> bottomInputProperty
        这个Blend操作的底部输入。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getBottomInput() ， setBottomInput(Effect)

      • topInput

        public final ObjectProperty<Effect> topInputProperty
        这是Blend操作的顶部输入。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getTopInput() ， setTopInput(Effect)

    • 构造方法详细信息

      • Blend

        public Blend​()
        使用默认参数创建Blend的新实例。

      • Blend

        public Blend​(BlendMode mode)
        使用指定的模式创建Blend的新实例。
        参数
        mode - BlendMode用于将两个输入混合在一起
        从以下版本开始：
        JavaFX 2.1

      • Blend

        public Blend​(BlendMode mode,
             Effect bottomInput,
             Effect topInput)
        使用指定的模式和底部和顶部输入创建Blend的新实例。
        参数
        mode - BlendMode用于将两个输入混合在一起
        bottomInput - 此 Blend操作的底部输入
        topInput - 此 Blend操作的顶部输入
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setMode

        public final void setMode​(BlendMode value)
        设置属性模式的值。
        Property description:
        BlendMode用于将两个输入混合在一起。
          Min: n/a
       Max: n/a
   Default: BlendMode.SRC_OVER
  Identity: n/a
        Default value:
        SRC_OVER

      • getMode

        public final BlendMode getMode​()
        获取属性模式的值。
        Property description:
        BlendMode用于将两个输入混合在一起。
          Min: n/a
       Max: n/a
   Default: BlendMode.SRC_OVER
  Identity: n/a
        Default value:
        SRC_OVER

      • modeProperty

        public final ObjectProperty<BlendMode> modeProperty​()
        BlendMode用于将两个输入混合在一起。
          Min: n/a
       Max: n/a
   Default: BlendMode.SRC_OVER
  Identity: n/a
        Default value:
        SRC_OVER
        另请参见：
        getMode() ， setMode(BlendMode)

      • setOpacity

        public final void setOpacity​(double value)
        设置属性不透明度的值。
        Property description:
        不透明度值，它在混合前用顶部输入进行调制。
          Min: 0.0
       Max: 1.0
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0

      • getOpacity

        public final double getOpacity​()
        获取属性不透明度的值。
        Property description:
        不透明度值，它在混合前用顶部输入进行调制。
          Min: 0.0
       Max: 1.0
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0

      • opacityProperty

        public final DoubleProperty opacityProperty​()
        不透明度值，它在混合前用顶部输入进行调制。
          Min: 0.0
       Max: 1.0
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0
        另请参见：
        getOpacity() ， setOpacity(double)

      • setBottomInput

        public final void setBottomInput​(Effect value)
        设置属性bottomInput的值。
        Property description:
        这个Blend操作的底部输入。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getBottomInput

        public final Effect getBottomInput​()
        获取属性bottomInput的值。
        Property description:
        这个Blend操作的底部输入。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • bottomInputProperty

        public final ObjectProperty<Effect> bottomInputProperty​()
        这个Blend操作的底部输入。 如果设置为null或未指定，则连接Effect的Node的图形图像将用作输入。
        Default value:
        空值
        另请参见：
        getBottomInput() ， setBottomInput(Effect)

      • setTopInput

        public final void setTopInput​(Effect value)
        设置属性topInput的值。
        Property description:
        这个Blend操作的顶部输入。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getTopInput

        public final Effect getTopInput​()
        获取属性topInput的值。
        Property description:
        这是Blend操作的顶部输入。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • topInputProperty

        public final ObjectProperty<Effect> topInputProperty​()
        这是Blend操作的顶部输入。 如果设置为null ，或未指定，则将使用Effect附加的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getTopInput() ， setTopInput(Effect)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BlendMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Enum BlendMode

  • java.lang.Object
    • java.lang.Enum<BlendMode>
      • javafx.scene.effect.BlendMode
  • All Implemented Interfaces:
    Serializable ， Comparable<BlendMode>

    public enum BlendMode
extends Enum<BlendMode>
    混合模式定义混合效果的输入合成在一起的方式，或者如何将节点混合到场景的背景中。
      import javafx.scene.*;
import javafx.scene.effect.*;
import javafx.scene.paint.*;
import javafx.scene.shape.*;

Rectangle r = new Rectangle();
r.setX(50);
r.setY(50);
r.setWidth(50);
r.setHeight(50);
r.setFill(Color.BLUE);

Circle c = new Circle();
c.setFill(Color.rgb(255, 0, 0, 0.5));
c.setCenterX(50);
c.setCenterY(50);
c.setRadius(25);
c.setBlendMode(BlendMode.MULTIPLY);

Group g = new Group();
g.getChildren().add(r);
g.getChildren().add(c);
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ADD
      来自顶部输入的颜色和alpha分量被添加到从底部输入的颜色和alpha分量。
      BLUE
      底部输入的蓝色分量被顶部输入的蓝色分量替换; 其他颜色成分不受影响。
      COLOR_BURN
      底部输入颜色分量的倒数除以顶部输入颜色分量，然后将其全部反转以产生所得颜色。
      COLOR_DODGE
      底部输入颜色分量被顶部输入颜色分量的倒数除以产生所得到的颜色。
      DARKEN
      选择来自两个输入的颜色分量较暗以产生所得颜色。
      DIFFERENCE
      从较浅的输入中减去两个输入的颜色分量较暗，以产生最终的颜色。
      EXCLUSION
      将两个输入的颜色分量相乘并加倍，然后从底部输入颜色分量的和中减去，以产生所得到的颜色。
      GREEN
      底部输入的绿色分量被顶部输入的绿色分量替换; 其他颜色成分不受影响。
      HARD_LIGHT
      根据顶部输入颜色，输入颜色分量是相乘或屏蔽的。
      LIGHTEN
      来自两个输入的颜色分量的打火机被选择以产生所得到的颜色。
      MULTIPLY
      来自第一输入的颜色分量与来自第二输入的颜色分量相乘。
      OVERLAY
      根据底部输入颜色，输入颜色分量是相乘或屏蔽的。
      RED
      底部输入的红色分量被顶部输入的红色分量代替; 其他颜色成分不受影响。
      SCREEN
      来自两个输入的颜色分量被反转，彼此相乘，并且该结果再次被反转以产生所得到的颜色。
      SOFT_LIGHT
      根据顶部输入颜色，输入颜色分量要么变暗，要么变暗。
      SRC_ATOP
      位于底部输入内部的顶部输入的部分与底部输入混合。
      SRC_OVER
      顶部输入通过底部输入混合。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static BlendMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static BlendMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SRC_OVER

        public static final BlendMode SRC_OVER
        顶部输入通过底部输入混合。 （相当于波特 - 达夫“目的地来源”规则。）

      • SRC_ATOP

        public static final BlendMode SRC_ATOP
        位于底部输入内部的顶部输入的部分与底部输入混合。 （相当于Porter-Duff“源头目的地”规则。）

      • ADD

        public static final BlendMode ADD
        来自顶部输入的颜色和alpha分量被添加到从底部输入的颜色和alpha分量。 如果超过1.0的逻辑最大值，结果将被钳位为1.0。

        笔记：

        • 这种模式是可交换的（输入顺序无关紧要）。
        • 这种模式在成像软件包中有时被称为“线性闪避”。

      • MULTIPLY

        public static final BlendMode MULTIPLY
        来自第一输入的颜色分量与来自第二输入的颜色分量相乘。 根据SRC_OVER方程将α成分混合。

        笔记：

        • 这种模式是可交换的（输入顺序无关紧要）。
        • 这种模式与SCREEN模式的数学相反。
        • 所得颜色总是至少与输入颜色一样暗。
        • 使用完全黑色的顶部输入渲染产生黑色; 用完全白色的顶部输入渲染产生相当于底部输入的结果。

      • SCREEN

        public static final BlendMode SCREEN
        来自两个输入的颜色分量被反转，彼此相乘，并且该结果再次被反转以产生所得到的颜色。 根据SRC_OVER方程将α成分混合。

        笔记：

        • 这种模式是可交换的（输入顺序无关紧要）。
        • 这种模式与MULTIPLY模式的数学相反。
        • 所得到的颜色总是至少与任何一种输入颜色一样轻。
        • 用完全白色的顶部输入渲染产生白色; 用完全黑色的顶部输入渲染产生相当于底部输入的结果。

      • OVERLAY

        public static final BlendMode OVERLAY
        根据底部输入颜色，输入颜色分量是相乘或屏蔽的。 根据SRC_OVER方程将α分量混合。

        笔记：

        • 此模式是SCREEN和MULTIPLY的组合，具体取决于底部的输入颜色。
        • 这种模式与HARD_LIGHT模式的数学相反。
        • 在这种模式下，顶部输入颜色“覆盖”底部输入，同时保留后者的高光和阴影。

      • DARKEN

        public static final BlendMode DARKEN
        选择来自两个输入的颜色分量较暗以产生所得颜色。 根据SRC_OVER方程将α成分混合。

        笔记：

        • 这种模式是可交换的（输入顺序无关紧要）。
        • 这种模式与LIGHTEN模式的数学相反。

      • LIGHTEN

        public static final BlendMode LIGHTEN
        来自两个输入的颜色分量的打火机被选择以产生所得到的颜色。 根据SRC_OVER方程将α成分混合。

        笔记：

        • 这种模式是可交换的（输入顺序无关紧要）。
        • 这种模式与DARKEN模式的数学相反。

      • COLOR_DODGE

        public static final BlendMode COLOR_DODGE
        底部输入颜色分量被顶部输入颜色分量的倒数除以产生所得到的颜色。 根据SRC_OVER方程将α组分混合。

      • COLOR_BURN

        public static final BlendMode COLOR_BURN
        底部输入颜色分量的倒数除以顶部输入颜色分量，然后将其全部反转以产生所得颜色。 根据SRC_OVER方程将α成分混合。

      • HARD_LIGHT

        public static final BlendMode HARD_LIGHT
        根据顶部输入颜色，输入颜色分量是相乘或屏蔽的。 根据SRC_OVER方程将α成分混合。

        笔记：

        • 此模式是SCREEN和MULTIPLY的组合，具体取决于顶部输入颜色。
        • 这种模式与OVERLAY模式的数学相反。

      • SOFT_LIGHT

        public static final BlendMode SOFT_LIGHT
        根据顶部输入颜色，输入颜色分量要么变暗，要么变暗。 根据SRC_OVER方程将α成分混合。

        笔记：

        • 这种模式类似于OVERLAY ，但通常产生比OVERLAY “较轻”的结果。

      • DIFFERENCE

        public static final BlendMode DIFFERENCE
        从较浅的输入中减去两个输入的颜色分量较暗，以产生最终的颜色。 根据SRC_OVER等式混合α成分。

        笔记：

        • 这种模式是可交换的（输入顺序无关紧要）。
        • 该模式可用于反转底部输入图像的部分，或者快速比较两个图像（相等的像素将导致黑色）。
        • 用完全白色的顶部输入渲染反转底部输入; 用完全黑色的顶部输入渲染产生相当于底部输入的结果。

      • EXCLUSION

        public static final BlendMode EXCLUSION
        将两个输入的颜色分量相乘并加倍，然后从底部输入颜色分量的和中减去，以产生所得到的颜色。 根据SRC_OVER等式混合α成分。

        笔记：

        • 这种模式是可交换的（输入顺序无关紧要）。
        • 此模式可用于反转底部输入的部分。
        • 该模式产生的结果类似于DIFFERENCE ，除了对比度较低。
        • 用完全白色的顶部输入渲染反转底部输入; 用完全黑色的顶部输入渲染产生相当于底部输入的结果。

      • RED

        public static final BlendMode RED
        底部输入的红色分量被顶部输入的红色分量代替; 其他颜色成分不受影响。 根据SRC_OVER方程将α成分混合。

      • GREEN

        public static final BlendMode GREEN
        底部输入的绿色分量被顶部输入的绿色分量替换; 其他颜色成分不受影响。 根据SRC_OVER方程将α成分混合。

      • BLUE

        public static final BlendMode BLUE
        底部输入的蓝色分量被顶部输入的蓝色分量替换; 其他颜色成分不受影响。 根据SRC_OVER方程将α成分混合。

    • 方法详细信息

      • values

        public static BlendMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (BlendMode c : BlendMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static BlendMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Bloom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Bloom

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.Bloom

  • public class Bloom
extends Effect
    基于可配置的阈值，使得输入图像的较亮部分看起来发亮的高级效果。

    例：

       Bloom bloom = new Bloom(); bloom.setThreshold(0.1); Rectangle rect = new Rectangle(); rect.setX(10); rect.setY(10); rect.setWidth(160); rect.setHeight(80); rect.setFill(Color.DARKSLATEBLUE); Text text = new Text(); text.setText("Bloom!"); text.setFill(Color.ALICEBLUE); text.setFont(Font.font(null, FontWeight.BOLD, 40)); text.setX(25); text.setY(65); text.setEffect(bloom);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Effect> input
      这个输入为 Effect 。
      DoubleProperty threshold
      阈值控制将被发光的像素的最小亮度值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Bloom​()
      用默认参数创建一个新的Bloom实例。
      Bloom​(double threshold)
      以指定的阈值创建一个Bloom实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Effect getInput​()
      获取属性输入的值。
      double getThreshold​()
      获取属性阈值的值。
      ObjectProperty<Effect> inputProperty​()
      该输入为 Effect 。
      void setInput​(Effect value)
      设置属性输入的值。
      void setThreshold​(double value)
      设置属性阈值的值。
      DoubleProperty thresholdProperty​()
      阈值控制将被发光的像素的最小亮度值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        这个输入为Effect 。 如果设置为null ，或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • threshold

        public final DoubleProperty thresholdProperty
        阈值控制将被发光的像素的最小亮度值。
          Min: 0.0
       Max: 1.0
   Default: 0.3
  Identity: n/a
        Default value:
        0.3
        另请参见：
        getThreshold() ， setThreshold(double)

    • 构造方法详细信息

      • Bloom

        public Bloom​()
        用默认参数创建一个新的Bloom实例。

      • Bloom

        public Bloom​(double threshold)
        以指定的阈值创建一个Bloom实例。
        参数
        threshold - 绽放效应的阈值
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        该输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setThreshold

        public final void setThreshold​(double value)
        设置属性阈值的值。
        Property description:
        阈值控制将被发光的像素的最小亮度值。
          Min: 0.0
       Max: 1.0
   Default: 0.3
  Identity: n/a
        Default value:
        0.3

      • getThreshold

        public final double getThreshold​()
        获取属性阈值的值。
        Property description:
        阈值控制将被发光的像素的最小亮度值。
          Min: 0.0
       Max: 1.0
   Default: 0.3
  Identity: n/a
        Default value:
        0.3

      • thresholdProperty

        public final DoubleProperty thresholdProperty​()
        阈值控制将被发光的像素的最小亮度值。
          Min: 0.0
       Max: 1.0
   Default: 0.3
  Identity: n/a
        Default value:
        0.3
        另请参见：
        getThreshold() ， setThreshold(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BlurType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Enum BlurType

  • java.lang.Object
    • java.lang.Enum<BlurType>
      • javafx.scene.effect.BlurType
  • All Implemented Interfaces:
    Serializable ， Comparable<BlurType>

    public enum BlurType
extends Enum<BlurType>
    表示用于软化 Shadow效果的模糊算法的类型。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      GAUSSIAN
      高斯模糊内核用于以非常高的质量模糊阴影。
      ONE_PASS_BOX
      使用单个过滤器的单次通过来模糊阴影。
      THREE_PASS_BOX
      使用三次通过盒式滤波器来模糊阴影，其效果几乎与高斯滤波器一样平滑。
      TWO_PASS_BOX
      盒式过滤器的两次通过用于模糊阴影以获得稍微平滑的效果。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static BlurType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static BlurType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ONE_PASS_BOX

        public static final BlurType ONE_PASS_BOX
        使用单个过滤器的单次通过来模糊阴影。

      • TWO_PASS_BOX

        public static final BlurType TWO_PASS_BOX
        盒式过滤器的两次通过用于模糊阴影以获得稍微平滑的效果。

      • THREE_PASS_BOX

        public static final BlurType THREE_PASS_BOX
        使用三次通过盒式滤波器来模糊阴影，其效果几乎与高斯滤波器一样平滑。

      • GAUSSIAN

        public static final BlurType GAUSSIAN
        高斯模糊内核用于以非常高的质量模糊阴影。

    • 方法详细信息

      • values

        public static BlurType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (BlurType c : BlurType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static BlurType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


BoxBlur (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class BoxBlur

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.BoxBlur

  • public class BoxBlur
extends Effect
    使用简单的盒式过滤器内核的模糊效果，在两个维度上都有单独配置的大小，以及控制所产生的模糊质量的迭代参数。

    例：

       BoxBlur boxBlur = new BoxBlur(); boxBlur.setWidth(10); boxBlur.setHeight(3); boxBlur.setIterations(3); Text text = new Text(); text.setText("Blurry Text!"); text.setFill(Color.web("0x3b596d")); text.setFont(Font.font(null, FontWeight.BOLD, 50)); text.setX(10); text.setY(50); text.setEffect(boxBlur);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty height
      模糊效果的垂直尺寸。
      ObjectProperty<Effect> input
      这个输入为 Effect 。
      IntegerProperty iterations
      迭代模糊效果以提高其“质量”或“平滑度”的次数。
      DoubleProperty width
      模糊效果的水平维度。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BoxBlur​()
      使用默认参数创建一个新的BoxBlur实例。
      BoxBlur​(double width, double height, int iterations)
      创建一个新的具有指定宽度，高度和迭代的BoxBlur实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getHeight​()
      获取属性高度的值。
      Effect getInput​()
      获取属性输入的值。
      int getIterations​()
      获取属性迭代的值。
      double getWidth​()
      获取属性宽度的值。
      DoubleProperty heightProperty​()
      模糊效果的垂直尺寸。
      ObjectProperty<Effect> inputProperty​()
      这个输入为 Effect 。
      IntegerProperty iterationsProperty​()
      迭代模糊效果以提高其“质量”或“平滑度”的次数。
      void setHeight​(double value)
      设置属性高度的值。
      void setInput​(Effect value)
      设置属性输入的值。
      void setIterations​(int value)
      设置属性迭代的值。
      void setWidth​(double value)
      设置属性宽度的值。
      DoubleProperty widthProperty​()
      模糊效果的水平维度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        这个输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像用作输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • width

        public final DoubleProperty widthProperty
        模糊效果的水平维度。 给定像素的颜色信息将在以像素为中心的指定宽度的Box上扩展。 小于或等于1的值不会将颜色数据扩展到其起源的像素以外，因此不会有任何影响。
          Min:   0.0
       Max: 255.0
   Default:   5.0
  Identity:  <1.0
        Default value:
        5
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final DoubleProperty heightProperty
        模糊效果的垂直尺寸。 给定像素的颜色信息将跨越位于像素上方的指示高度的盒子扩展。 小于或等于1的值不会将颜色数据扩展到其起源的像素以外，因此不会有任何影响。
          Min:   0.0
       Max: 255.0
   Default:   5.0
  Identity:  <1.0
        Default value:
        5
        另请参见：
        getHeight() ， setHeight(double)

      • iterations

        public final IntegerProperty iterationsProperty
        迭代模糊效果以提高其“质量”或“平滑度”的次数。 将效果迭代3次将高斯模糊的质量逼近3％以内。
          Min:   0
       Max:   3
   Default:   1
  Identity:   0
        Default value:
        1
        另请参见：
        getIterations() ， setIterations(int)

    • 构造方法详细信息

      • BoxBlur

        public BoxBlur​()
        使用默认参数创建一个新的BoxBlur实例。

      • BoxBlur

        public BoxBlur​(double width,
               double height,
               int iterations)
        创建一个新的具有指定宽度，高度和迭代的BoxBlur实例。
        参数
        width - 模糊效果的水平维度
        height - 模糊效果的垂直维度
        iterations - 迭代模糊效果以提高其“质量”或“平滑度”的次数

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        模糊效果的水平维度。 给定像素的颜色信息将在以像素为中心的指定宽度的Box上扩展。 小于或等于1的值不会将颜色数据扩展到其起源的像素以外，因此不会有任何影响。
          Min:   0.0
       Max: 255.0
   Default:   5.0
  Identity:  <1.0
        Default value:
        5

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        模糊效果的水平维度。 给定像素的颜色信息将在以像素为中心的指定宽度的Box上扩展。 小于或等于1的值不会将颜色数据扩展到其起源的像素以外，因此不会有任何影响。
          Min:   0.0
       Max: 255.0
   Default:   5.0
  Identity:  <1.0
        Default value:
        5

      • widthProperty

        public final DoubleProperty widthProperty​()
        模糊效果的水平维度。 给定像素的颜色信息将在以像素为中心的指定宽度的Box上扩展。 小于或等于1的值不会将颜色数据扩展到其起源的像素以外，因此不会有任何影响。
          Min:   0.0
       Max: 255.0
   Default:   5.0
  Identity:  <1.0
        Default value:
        5
        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        模糊效果的垂直尺寸。 给定像素的颜色信息将跨越位于像素上方的指示高度的盒子扩展。 小于或等于1的值不会将颜色数据扩展到其起源的像素以外，因此不会有任何影响。
          Min:   0.0
       Max: 255.0
   Default:   5.0
  Identity:  <1.0
        Default value:
        5

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        模糊效果的垂直尺寸。 给定像素的颜色信息将跨越位于像素上方的指示高度的盒子扩展。 小于或等于1的值不会将颜色数据扩展到其起源的像素以外，因此不会有任何影响。
          Min:   0.0
       Max: 255.0
   Default:   5.0
  Identity:  <1.0
        Default value:
        5

      • heightProperty

        public final DoubleProperty heightProperty​()
        模糊效果的垂直尺寸。 给定像素的颜色信息将跨越位于像素上方的指示高度的盒子扩展。 小于或等于1的值不会将颜色数据扩展到其起源的像素以外，因此不会有任何影响。
          Min:   0.0
       Max: 255.0
   Default:   5.0
  Identity:  <1.0
        Default value:
        5
        另请参见：
        getHeight() ， setHeight(double)

      • setIterations

        public final void setIterations​(int value)
        设置属性迭代的值。
        Property description:
        迭代模糊效果以提高其“质量”或“平滑度”的次数。 将效果迭代3次将高斯模糊的质量逼近3％以内。
          Min:   0
       Max:   3
   Default:   1
  Identity:   0
        Default value:
        1

      • getIterations

        public final int getIterations​()
        获取属性迭代的值。
        Property description:
        迭代模糊效果以提高其“质量”或“平滑度”的次数。 将效果迭代3次将高斯模糊的质量逼近3％以内。
          Min:   0
       Max:   3
   Default:   1
  Identity:   0
        Default value:
        1

      • iterationsProperty

        public final IntegerProperty iterationsProperty​()
        迭代模糊效果以提高其“质量”或“平滑度”的次数。 将效果迭代3次将高斯模糊的质量逼近3％以内。
          Min:   0
       Max:   3
   Default:   1
  Identity:   0
        Default value:
        1
        另请参见：
        getIterations(), setIterations(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ColorAdjust (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class ColorAdjust

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.ColorAdjust

  • public class ColorAdjust
extends Effect
    允许每个像素调整色调，饱和度，亮度和对比度的效果。

    例：

       ColorAdjust colorAdjust = new ColorAdjust(); colorAdjust.setContrast(0.1); colorAdjust.setHue(-0.05); colorAdjust.setBrightness(0.1); colorAdjust.setSaturation(0.2); Image image = new Image("boat.jpg"); ImageView imageView = new ImageView(image); imageView.setFitWidth(200); imageView.setPreserveRatio(true); imageView.setEffect(colorAdjust);

    以上代码适用于此图像：

    产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty brightness
      亮度调节值。
      DoubleProperty contrast
      对比度调整值。
      DoubleProperty hue
      色调调整值。
      ObjectProperty<Effect> input
      这个输入为 Effect 。
      DoubleProperty saturation
      饱和度调整值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ColorAdjust​()
      使用默认参数创建一个新的ColorAdjust实例。
      ColorAdjust​(double hue, double saturation, double brightness, double contrast)
      以指定的色调，饱和度，亮度和对比度创建ColorAdjust的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty brightnessProperty​()
      亮度调节值。
      DoubleProperty contrastProperty​()
      对比度调整值。
      double getBrightness​()
      获取属性亮度的值。
      double getContrast​()
      获取属性对比的值。
      double getHue​()
      获取属性色调的值。
      Effect getInput​()
      获取属性输入的值。
      double getSaturation​()
      获取属性饱和度的值。
      DoubleProperty hueProperty​()
      色调调整值。
      ObjectProperty<Effect> inputProperty​()
      这个输入为 Effect 。
      DoubleProperty saturationProperty​()
      饱和度调整值。
      void setBrightness​(double value)
      设置属性亮度的值。
      void setContrast​(double value)
      设置属性对比度的值。
      void setHue​(double value)
      设置属性色调的值。
      void setInput​(Effect value)
      设置属性输入的值。
      void setSaturation​(double value)
      设置属性饱和度的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • hue

        public final DoubleProperty hueProperty
        色调调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0
        另请参见：
        getHue() ， setHue(double)

      • saturation

        public final DoubleProperty saturationProperty
        饱和度调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0
        另请参见：
        getSaturation() ， setSaturation(double)

      • brightness

        public final DoubleProperty brightnessProperty
        亮度调节值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0
        另请参见：
        getBrightness() ， setBrightness(double)

      • contrast

        public final DoubleProperty contrastProperty
        对比度调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0
        另请参见：
        getContrast() ， setContrast(double)

    • 构造方法详细信息

      • ColorAdjust

        public ColorAdjust​()
        使用默认参数创建一个新的ColorAdjust实例。

      • ColorAdjust

        public ColorAdjust​(double hue,
                   double saturation,
                   double brightness,
                   double contrast)
        以指定的色调，饱和度，亮度和对比度创建ColorAdjust的新实例。
        参数
        hue - 色调调整值
        saturation - 饱和度调整值
        brightness - 亮度调节值
        contrast - 对比度调整值
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        该输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setHue

        public final void setHue​(double value)
        设置属性色调的值。
        Property description:
        色调调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0

      • getHue

        public final double getHue​()
        获取属性色调的值。
        Property description:
        色调调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0

      • hueProperty

        public final DoubleProperty hueProperty​()
        色调调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0
        另请参见：
        getHue() ， setHue(double)

      • setSaturation

        public final void setSaturation​(double value)
        设置属性饱和度的值。
        Property description:
        饱和度调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0

      • getSaturation

        public final double getSaturation​()
        获取属性饱和度的值。
        Property description:
        饱和度调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0

      • saturationProperty

        public final DoubleProperty saturationProperty​()
        饱和度调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0
        另请参见：
        getSaturation() ， setSaturation(double)

      • setBrightness

        public final void setBrightness​(double value)
        设置属性亮度的值。
        Property description:
        亮度调节值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0

      • getBrightness

        public final double getBrightness​()
        获取属性亮度的值。
        Property description:
        亮度调节值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0

      • brightnessProperty

        public final DoubleProperty brightnessProperty​()
        亮度调节值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0
        另请参见：
        getBrightness() ， setBrightness(double)

      • setContrast

        public final void setContrast​(double value)
        设置属性对比度的值。
        Property description:
        对比度调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0

      • getContrast

        public final double getContrast​()
        获取属性对比的值。
        Property description:
        对比度调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0

      • contrastProperty

        public final DoubleProperty contrastProperty​()
        对比度调整值。
          Min: -1.0
       Max: +1.0
   Default:  0.0
  Identity:  0.0
        Default value:
        0.0
        另请参见：
        getContrast(), setContrast(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ColorInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class ColorInput

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.ColorInput

  • public class ColorInput
extends Effect
    使用给定的Paint填充（“淹没”）的矩形区域的效果。 这相当于将填充的矩形渲染到图像中并使用ImageInput效果，除了它更方便，并且可能更有效率。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty height
      相对于内容 Node的本地坐标空间设置要淹没的区域的高度。
      ObjectProperty<Paint> paint
      Paint用于洪水地区。
      DoubleProperty width
      相对于内容 Node的局部坐标空间设置要淹没的区域的宽度。
      DoubleProperty x
      相对于内容 Node的本地坐标空间设置要淹没的区域的x位置。
      DoubleProperty y
      相对于内容 Node的本地坐标空间设置要淹没的区域的y位置。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ColorInput​()
      使用默认参数创建一个新的ColorInput实例。
      ColorInput​(double x, double y, double width, double height, Paint paint)
      使用指定的x，y，width，height和paint创建一个ColorInput的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getHeight​()
      获取属性高度的值。
      Paint getPaint​()
      获取属性paint的值。
      double getWidth​()
      获取属性宽度的值。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      DoubleProperty heightProperty​()
      相对于内容 Node的局部坐标空间设置要淹没的区域的高度。
      ObjectProperty<Paint> paintProperty​()
      Paint用于洪水地区。
      void setHeight​(double value)
      设置属性高度的值。
      void setPaint​(Paint value)
      设置属性paint的值。
      void setWidth​(double value)
      设置属性宽度的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      DoubleProperty widthProperty​()
      相对于内容 Node的局部坐标空间设置要淹没的区域的宽度。
      DoubleProperty xProperty​()
      相对于内容 Node的本地坐标空间设置要淹没区域的x位置。
      DoubleProperty yProperty​()
      相对于内容 Node的局部坐标空间设置要淹没区域的y位置。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • paint

        public final ObjectProperty<Paint> paintProperty
        Paint用于洪水地区。
          Min: n/a
       Max: n/a
   Default: Color.RED
  Identity: n/a
        Default value:
        红
        另请参见：
        getPaint() ， setPaint(Paint)

      • x

        public final DoubleProperty xProperty
        相对于内容Node的局部坐标空间设置要淹没的区域的x位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        相对于内容Node的本地坐标空间设置要淹没的区域的y位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • width

        public final DoubleProperty widthProperty
        相对于内容Node的本地坐标空间设置要淹没的区域的宽度。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final DoubleProperty heightProperty
        相对于内容Node的局部坐标空间设置要淹没的区域的高度。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getHeight() ， setHeight(double)

    • 构造方法详细信息

      • ColorInput

        public ColorInput​()
        使用默认参数创建一个新的ColorInput实例。

      • ColorInput

        public ColorInput​(double x,
                  double y,
                  double width,
                  double height,
                  Paint paint)
        使用指定的x，y，width，height和paint创建一个ColorInput的新实例。
        参数
        x - 要淹没的地区的x位置
        y - 要淹没的地区的y位置
        width - 要淹没的区域的宽度
        height - 要淹没的地区的高度
        paint - Paint用于洪水地区
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setPaint

        public final void setPaint​(Paint value)
        设置属性paint的值。
        Property description:
        Paint用于洪水地区。
          Min: n/a
       Max: n/a
   Default: Color.RED
  Identity: n/a
        Default value:
        红

      • getPaint

        public final Paint getPaint​()
        获取属性paint的值。
        Property description:
        Paint用于洪水地区。
          Min: n/a
       Max: n/a
   Default: Color.RED
  Identity: n/a
        Default value:
        红

      • paintProperty

        public final ObjectProperty<Paint> paintProperty​()
        Paint用于洪水地区。
          Min: n/a
       Max: n/a
   Default: Color.RED
  Identity: n/a
        Default value:
        红
        另请参见：
        getPaint() ， setPaint(Paint)

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        相对于内容Node的本地坐标空间设置要淹没的区域的x位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        相对于内容Node的本地坐标空间设置要淹没的区域的x位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        相对于内容Node的局部坐标空间设置要淹没区域的x位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        相对于内容Node的本地坐标空间设置要淹没的区域的y位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        相对于内容Node的本地坐标空间设置要淹没的区域的y位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        相对于内容Node的局部坐标空间设置要淹没的区域的y位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        相对于内容Node的局部坐标空间设置要淹没的区域的宽度。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        相对于内容Node的局部坐标空间设置要淹没的区域的宽度。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • widthProperty

        public final DoubleProperty widthProperty​()
        相对于内容Node的局部坐标空间设置要淹没的区域的宽度。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        相对于内容Node的局部坐标空间设置要淹没的区域的高度。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        相对于内容Node的局部坐标空间设置要淹没的区域的高度。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • heightProperty

        public final DoubleProperty heightProperty​()
        相对于内容Node的局部坐标空间设置要淹没的区域的高度。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getHeight() ， setHeight(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DisplacementMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class DisplacementMap

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.DisplacementMap

  • public class DisplacementMap
extends Effect
    将每个像素移动由指定的FloatMap的前两个频带指定的距离的效果 。 对于输出中的每个像素， mapData的相应数据由scale和offset属性检索，缩放和偏移，再次按照源输入图像的大小进行缩放，并用作从目标像素的偏移量以检索像素数据从源输入。
      dst[x,y] = src[(x,y) + (offset+scale*map[x,y])*(srcw,srch)]
    值(0.0,&nbsp;0.0)将不指定像素数据的偏移量，而(0.5,&nbsp;0.5)的值将指定源图像大小的一半的偏移量。

    注意 ，映射是从目标像素到从其采样的源像素位置的偏移，这意味着用0.5所有值填充地图将使图像的尺寸将朝向左上方移位一半，因为每个目的地像素将包含来自下面和右侧的源像素的数据。

    另请注意，此效果不会调整输入事件的坐标或任何在Node上测量遏制的Node 。 当Node具有DisplacementMap效果时，鼠标选择和遏制方法的结果未定义。

    例：

       int width = 220; int height = 100; FloatMap floatMap = new FloatMap(); floatMap.setWidth(width); floatMap.setHeight(height); for (int i = 0; i < width; i++) { double v = (Math.sin(i / 20.0 * Math.PI) - 0.5) / 40.0; for (int j = 0; j < height; j++) { floatMap.setSamples(i, j, 0.0f, (float) v); } } DisplacementMap displacementMap = new DisplacementMap(); displacementMap.setMapData(floatMap); Text text = new Text(); text.setX(40.0); text.setY(80.0); text.setText("Wavy Text"); text.setFill(Color.web("0x3b596d")); text.setFont(Font.font(null, FontWeight.BOLD, 50)); text.setEffect(displacementMap);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Effect> input
      这个输入为 Effect 。
      ObjectProperty<FloatMap> mapData
      这个 Effect的地图数据。
      DoubleProperty offsetX
      FloatMap中的所有x坐标偏移值在被缩放之后被移位的偏移量。
      DoubleProperty offsetY
      FloatMap中的所有y坐标偏移值在被缩放之后被偏移的位移。
      DoubleProperty scaleX
      FloatMap中所有x坐标偏移值的比例因子相乘。
      DoubleProperty scaleY
      FloatMap中所有y坐标偏移值的比例因子相乘。
      BooleanProperty wrap
      是否定义从地图边缘外部获取的值是否“绕回”。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DisplacementMap​()
      使用默认参数创建DisplacementMap的新实例。
      DisplacementMap​(FloatMap mapData)
      使用指定的mapData创建DisplacementMap的新实例。
      DisplacementMap​(FloatMap mapData, double offsetX, double offsetY, double scaleX, double scaleY)
      使用指定的mapData，offsetX，offsetY，scaleX和scaleY创建一个新的DisplacementMap实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Effect getInput​()
      获取属性输入的值。
      FloatMap getMapData​()
      获取属性mapData的值。
      double getOffsetX​()
      获取属性offsetX的值。
      double getOffsetY​()
      获取属性offsetY的值。
      double getScaleX​()
      获取属性scaleX的值。
      double getScaleY​()
      获取属性scaleY的值。
      ObjectProperty<Effect> inputProperty​()
      该输入为 Effect 。
      boolean isWrap​()
      获取属性包装的值。
      ObjectProperty<FloatMap> mapDataProperty​()
      这个 Effect的地图数据。
      DoubleProperty offsetXProperty​()
      FloatMap中的所有x坐标偏移值在被缩放之后被偏移的位移。
      DoubleProperty offsetYProperty​()
      FloatMap中所有y坐标偏移值的偏移量在被缩放后都会移位。
      DoubleProperty scaleXProperty​()
      FloatMap中所有x坐标偏移值的比例因子相乘。
      DoubleProperty scaleYProperty​()
      FloatMap中所有y坐标偏移值的比例因子相乘。
      void setInput​(Effect value)
      设置属性输入的值。
      void setMapData​(FloatMap value)
      设置属性mapData的值。
      void setOffsetX​(double value)
      设置属性offsetX的值。
      void setOffsetY​(double value)
      设置属性offsetY的值。
      void setScaleX​(double value)
      设置属性scaleX的值。
      void setScaleY​(double value)
      设置属性scaleY的值。
      void setWrap​(boolean value)
      设置属性包装的值。
      BooleanProperty wrapProperty​()
      是否定义从地图边缘外部获取的值是否“绕回”。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        该输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • mapData

        public final ObjectProperty<FloatMap> mapDataProperty
        这个 Effect的地图数据。
        Default value:
        一张空地图
        另请参见：
        getMapData() ， setMapData(FloatMap)

      • scaleX

        public final DoubleProperty scaleXProperty
        FloatMap中所有x坐标偏移值的比例因子相乘。
          Min: n/a
       Max: n/a
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0
        另请参见：
        getScaleX() ， setScaleX(double)

      • scaleY

        public final DoubleProperty scaleYProperty
        FloatMap中所有y坐标偏移值的比例因子相乘。
          Min: n/a
       Max: n/a
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0
        另请参见：
        getScaleY() ， setScaleY(double)

      • offsetX

        public final DoubleProperty offsetXProperty
        FloatMap中的所有x坐标偏移值在被缩放之后被偏移的位移。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetX() ， setOffsetX(double)

      • offsetY

        public final DoubleProperty offsetYProperty
        FloatMap中所有y坐标偏移值的偏移量在被缩放后都会移位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetY() ， setOffsetY(double)

      • wrap

        public final BooleanProperty wrapProperty
        是否定义从地图边缘外部获取的值是否“绕回”。
          Min:  n/a
       Max:  n/a
   Default: false
  Identity:  n/a
        Default value:
        假
        另请参见：
        isWrap() ， setWrap(boolean)

    • 构造方法详细信息

      • DisplacementMap

        public DisplacementMap​()
        使用默认参数创建DisplacementMap的新实例。

      • DisplacementMap

        public DisplacementMap​(FloatMap mapData)
        使用指定的mapData创建DisplacementMap的新实例。
        参数
        mapData - 该位移图效果的地图数据
        从以下版本开始：
        JavaFX 2.1

      • DisplacementMap

        public DisplacementMap​(FloatMap mapData,
                       double offsetX,
                       double offsetY,
                       double scaleX,
                       double scaleY)
        使用指定的mapData，offsetX，offsetY，scaleX和scaleY创建一个新的DisplacementMap实例。
        参数
        mapData - 该位移图效果的地图数据
        offsetX -偏移量由所有的x在坐标偏移值 FloatMap它们被缩放后移位
        offsetY -所述通过其中所有的y坐标中的偏移值的偏移 FloatMap位移它们被缩放后
        scaleX -由所有的x在坐标偏移值的比例因子 FloatMap相乘
        scaleY -由这在所有y坐标，偏移值的比例因子 FloatMap相乘
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        该输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        该输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        该输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setMapData

        public final void setMapData​(FloatMap value)
        设置属性mapData的值。
        Property description:
        这个 Effect的地图数据。
        Default value:
        一张空地图

      • getMapData

        public final FloatMap getMapData​()
        获取属性mapData的值。
        Property description:
        这个 Effect的地图数据。
        Default value:
        一张空地图

      • mapDataProperty

        public final ObjectProperty<FloatMap> mapDataProperty​()
        该地图数据为 Effect 。
        Default value:
        一张空地图
        另请参见：
        getMapData() ， setMapData(FloatMap)

      • setScaleX

        public final void setScaleX​(double value)
        设置属性scaleX的值。
        Property description:
        FloatMap中所有x坐标偏移值的比例因子相乘。
          Min: n/a
       Max: n/a
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0

      • getScaleX

        public final double getScaleX​()
        获取属性scaleX的值。
        Property description:
        FloatMap中所有x坐标偏移值的比例因子相乘。
          Min: n/a
       Max: n/a
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0

      • scaleXProperty

        public final DoubleProperty scaleXProperty​()
        FloatMap中所有x坐标偏移值的比例因子相乘。
          Min: n/a
       Max: n/a
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0
        另请参见：
        getScaleX() ， setScaleX(double)

      • setScaleY

        public final void setScaleY​(double value)
        设置属性scaleY的值。
        Property description:
        FloatMap中所有y坐标偏移值的比例因子相乘。
          Min: n/a
       Max: n/a
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0

      • getScaleY

        public final double getScaleY​()
        获取属性scaleY的值。
        Property description:
        FloatMap中所有y坐标偏移值的比例因子相乘。
          Min: n/a
       Max: n/a
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0

      • scaleYProperty

        public final DoubleProperty scaleYProperty​()
        FloatMap中所有y坐标偏移值的比例因子相乘。
          Min: n/a
       Max: n/a
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0
        另请参见：
        getScaleY() ， setScaleY(double)

      • setOffsetX

        public final void setOffsetX​(double value)
        设置属性offsetX的值。
        Property description:
        FloatMap中的所有x坐标偏移值在被缩放之后被偏移的位移。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getOffsetX

        public final double getOffsetX​()
        获取属性offsetX的值。
        Property description:
        FloatMap中的所有x坐标偏移值在被缩放之后被偏移的位移。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • offsetXProperty

        public final DoubleProperty offsetXProperty​()
        FloatMap中的所有x坐标偏移值在被缩放之后被偏移的位移。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetX() ， setOffsetX(double)

      • setOffsetY

        public final void setOffsetY​(double value)
        设置属性offsetY的值。
        Property description:
        FloatMap中所有y坐标偏移值的偏移量在被缩放后都会移位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getOffsetY

        public final double getOffsetY​()
        获取属性offsetY的值。
        Property description:
        FloatMap中所有y坐标偏移值的偏移量在被缩放后都会移位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • offsetYProperty

        public final DoubleProperty offsetYProperty​()
        FloatMap中的所有y坐标偏移值的偏移在它们被缩放之后被移位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetY() ， setOffsetY(double)

      • setWrap

        public final void setWrap​(boolean value)
        设置属性包装的值。
        Property description:
        是否定义从地图边缘外部获取的值是否“绕回”。
          Min:  n/a
       Max:  n/a
   Default: false
  Identity:  n/a
        Default value:
        假

      • isWrap

        public final boolean isWrap​()
        获取属性包装的值。
        Property description:
        是否定义从地图边缘外部获取的值是否“绕回”。
          Min:  n/a
       Max:  n/a
   Default: false
  Identity:  n/a
        Default value:
        假

      • wrapProperty

        public final BooleanProperty wrapProperty​()
        是否定义从地图边缘外部获取的值是否“绕回”。
          Min:  n/a
       Max:  n/a
   Default: false
  Identity:  n/a
        Default value:
        假
        另请参见：
        isWrap() ， setWrap(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DropShadow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class DropShadow

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.DropShadow

  • public class DropShadow
extends Effect
    使用指定的颜色，半径和偏移量将给定内容的阴影呈现在内容后面的高级效果。

    例：

       DropShadow dropShadow = new DropShadow(); dropShadow.setRadius(5.0); dropShadow.setOffsetX(3.0); dropShadow.setOffsetY(3.0); dropShadow.setColor(Color.color(0.4, 0.5, 0.5)); Text text = new Text(); text.setEffect(dropShadow); text.setCache(true); text.setX(10.0); text.setY(70.0); text.setFill(Color.web("0x3b596d")); text.setText("JavaFX drop shadow..."); text.setFont(Font.font(null, FontWeight.BOLD, 40)); DropShadow dropShadow2 = new DropShadow(); dropShadow2.setOffsetX(6.0); dropShadow2.setOffsetY(4.0); Circle circle = new Circle(); circle.setEffect(dropShadow2); circle.setCenterX(50.0); circle.setCenterY(125.0); circle.setRadius(30.0); circle.setFill(Color.STEELBLUE); circle.setCache(true);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<BlurType> blurType
      用于模糊阴影的算法。
      ObjectProperty<Color> color
      阴影 Color 。
      DoubleProperty height
      阴影模糊内核的垂直尺寸。
      ObjectProperty<Effect> input
      这个输入为 Effect 。
      DoubleProperty offsetX
      x方向的阴影偏移量，以像素为单位。
      DoubleProperty offsetY
      y方向的阴影偏移，以像素为单位。
      DoubleProperty radius
      阴影模糊内核的半径。
      DoubleProperty spread
      阴影的传播。
      DoubleProperty width
      阴影模糊内核的水平尺寸。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DropShadow​()
      使用默认参数创建一个新的DropShadow实例。
      DropShadow​(double radius, double offsetX, double offsetY, Color color)
      以指定的半径，offsetX，offsetY和颜色创建一个新的DropShadow实例。
      DropShadow​(double radius, Color color)
      创建一个具有指定半径和颜色的DropShadow的新实例。
      DropShadow​(BlurType blurType, Color color, double radius, double spread, double offsetX, double offsetY)
      使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的DropShadow实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<BlurType> blurTypeProperty​()
      用于模糊阴影的算法。
      ObjectProperty<Color> colorProperty​()
      阴影 Color 。
      BlurType getBlurType​()
      获取属性blurType的值。
      Color getColor​()
      获取属性颜色的值。
      double getHeight​()
      获取属性高度的值。
      Effect getInput​()
      获取属性输入的值。
      double getOffsetX​()
      获取属性offsetX的值。
      double getOffsetY​()
      获取属性offsetY的值。
      double getRadius​()
      获取属性半径的值。
      double getSpread​()
      获取属性的价值。
      double getWidth​()
      获取属性宽度的值。
      DoubleProperty heightProperty​()
      阴影模糊内核的垂直尺寸。
      ObjectProperty<Effect> inputProperty​()
      该输入为 Effect 。
      DoubleProperty offsetXProperty​()
      x方向的阴影偏移量，以像素为单位。
      DoubleProperty offsetYProperty​()
      y方向的阴影偏移，以像素为单位。
      DoubleProperty radiusProperty​()
      阴影模糊内核的半径。
      void setBlurType​(BlurType value)
      设置属性blurType的值。
      void setColor​(Color value)
      设置属性颜色的值。
      void setHeight​(double value)
      设置属性高度的值。
      void setInput​(Effect value)
      设置属性输入的值。
      void setOffsetX​(double value)
      设置属性offsetX的值。
      void setOffsetY​(double value)
      设置属性offsetY的值。
      void setRadius​(double value)
      设置属性半径的值。
      void setSpread​(double value)
      设置属性扩展的值。
      void setWidth​(double value)
      设置属性宽度的值。
      DoubleProperty spreadProperty​()
      阴影的传播。
      DoubleProperty widthProperty​()
      阴影模糊内核的水平尺寸。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • radius

        public final DoubleProperty radiusProperty
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径等同于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)

      • width

        public final DoubleProperty widthProperty
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊影响。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final DoubleProperty heightProperty
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getHeight() ， setHeight(double)

      • blurType

        public final ObjectProperty<BlurType> blurTypeProperty
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX
        另请参见：
        getBlurType() ， setBlurType(BlurType)

      • spread

        public final DoubleProperty spreadProperty
        阴影的传播。 扩散是源材料的贡献率为100％的半径部分。 半径的剩余部分将具有由模糊核心控制的贡献。 0.0的传播将导致完全由模糊算法确定的阴影的分布。 1.0的传播将导致源材料不透明度向外延伸到半径极限，并在半径处具有非常尖锐的透明度截止。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getSpread() ， setSpread(double)

      • color

        public final ObjectProperty<Color> colorProperty
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色
        另请参见：
        getColor() ， setColor(Color)

      • offsetX

        public final DoubleProperty offsetXProperty
        x方向的阴影偏移量，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetX() ， setOffsetX(double)

      • offsetY

        public final DoubleProperty offsetYProperty
        y方向的阴影偏移，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetY() ， setOffsetY(double)

    • 构造方法详细信息

      • DropShadow

        public DropShadow​()
        使用默认参数创建一个新的DropShadow实例。

      • DropShadow

        public DropShadow​(double radius,
                  Color color)
        创建一个具有指定半径和颜色的DropShadow的新实例。
        参数
        radius - 影子模糊内核的半径
        color - 阴影 Color
        从以下版本开始：
        JavaFX 2.1

      • DropShadow

        public DropShadow​(double radius,
                  double offsetX,
                  double offsetY,
                  Color color)
        以指定的半径，offsetX，offsetY和颜色创建一个新的DropShadow实例。
        参数
        radius - 影子模糊内核的半径
        offsetX - x方向的阴影偏移
        offsetY - y方向的阴影偏移
        color - 影子 Color
        从以下版本开始：
        JavaFX 2.1

      • DropShadow

        public DropShadow​(BlurType blurType,
                  Color color,
                  double radius,
                  double spread,
                  double offsetX,
                  double offsetY)
        使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的DropShadow实例。
        参数
        blurType - 用于模糊阴影的算法
        color - 阴影 Color
        radius - 影子模糊内核的半径
        spread - 源材料的贡献率为100％的半径部分
        offsetX - x方向上的阴影偏移
        offsetY - y方向的阴影偏移
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        这个Effect的输入。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则将使用Effect连接的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        这个输入为Effect 。 如果设置为null或未指定，则连接Effect的Node的图形图像将用作输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setRadius

        public final void setRadius​(double value)
        设置属性半径的值。
        Property description:
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径等同于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0

      • getRadius

        public final double getRadius​()
        获取属性半径的值。
        Property description:
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径相当于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0

      • radiusProperty

        public final DoubleProperty radiusProperty​()
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径相当于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊影响。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • widthProperty

        public final DoubleProperty widthProperty​()
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊影响。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • heightProperty

        public final DoubleProperty heightProperty​()
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getHeight() ， setHeight(double)

      • setBlurType

        public final void setBlurType​(BlurType value)
        设置属性blurType的值。
        Property description:
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX

      • getBlurType

        public final BlurType getBlurType​()
        获取属性blurType的值。
        Property description:
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX

      • blurTypeProperty

        public final ObjectProperty<BlurType> blurTypeProperty​()
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX
        另请参见：
        getBlurType() ， setBlurType(BlurType)

      • setSpread

        public final void setSpread​(double value)
        设置属性扩展的值。
        Property description:
        阴影的传播。 扩散是源材料的贡献率为100％的半径部分。 半径的剩余部分将具有由模糊核心控制的贡献。 0.0的传播将导致完全由模糊算法确定的阴影的分布。 1.0的传播将导致源材料不透明度向外延伸到半径极限，并在半径处具有非常尖锐的透明度截止。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getSpread

        public final double getSpread​()
        获取属性的价值。
        Property description:
        阴影的传播。 扩散是源材料的贡献率为100％的半径部分。 半径的剩余部分将具有由模糊核心控制的贡献。 0.0的传播将导致完全由模糊算法确定的阴影的分布。 1.0的传播将导致源材料不透明度向外延伸至半径极限，并且在半径处具有非常尖锐的透明度截止。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • spreadProperty

        public final DoubleProperty spreadProperty​()
        阴影的传播。 扩散是源材料的贡献率为100％的半径部分。 半径的剩余部分将具有由模糊核心控制的贡献。 0.0的传播将导致完全由模糊算法确定的阴影的分布。 1.0的传播将导致源材料不透明度向外的稳定增长到半径极限，并且在半径处具有非常尖锐的透明度截止。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getSpread() ， setSpread(double)

      • setColor

        public final void setColor​(Color value)
        设置属性颜色的值。
        Property description:
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色

      • getColor

        public final Color getColor​()
        获取属性颜色的值。
        Property description:
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色

      • colorProperty

        public final ObjectProperty<Color> colorProperty​()
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色
        另请参见：
        getColor() ， setColor(Color)

      • setOffsetX

        public final void setOffsetX​(double value)
        设置属性offsetX的值。
        Property description:
        x方向的阴影偏移量，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getOffsetX

        public final double getOffsetX​()
        获取属性offsetX的值。
        Property description:
        x方向的阴影偏移量，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • offsetXProperty

        public final DoubleProperty offsetXProperty​()
        x方向的阴影偏移量，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetX() ， setOffsetX(double)

      • setOffsetY

        public final void setOffsetY​(double value)
        设置属性offsetY的值。
        Property description:
        y方向的阴影偏移，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getOffsetY

        public final double getOffsetY​()
        获取属性offsetY的值。
        Property description:
        y方向的阴影偏移，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • offsetYProperty

        public final DoubleProperty offsetYProperty​()
        y方向的阴影偏移，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetY(), setOffsetY(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Effect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Effect

  • java.lang.Object
    • javafx.scene.effect.Effect
  • 已知直接子类：
    Blend ， Bloom ， BoxBlur ， ColorAdjust ， ColorInput ， DisplacementMap ， DropShadow ， GaussianBlur ， Glow ， ImageInput ， InnerShadow ， Lighting ， MotionBlur ， PerspectiveTransform ， Reflection ， SepiaTone ， Shadow

    public abstract class Effect
extends Object
    所有效果实现的抽象基类。 效果是产生图像的图形算法，通常作为源图像的修改。 通过设置Node.effect属性，效果可以与场景图Node相关联。 某些效果会改变源像素的颜色属性（例如ColorAdjust ），其他效果会将多个图像组合在一起（如Blend ），而另外一些则会扭曲或移动源图像周围的像素（如DisplacementMap或PerspectiveTransform ）。 所有效果至少有一个输入被定义，并且输入可以被设置为另一个效果，以将效果链接在一起并组合它们的结果，或者可以不指定这种效果，在这种情况下，效果将对附加的节点的图形呈现进行操作至。

    注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.EFFECT 。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Effect​()
      创建一个新的效果。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Effect

        protected Effect​()
        创建一个新的效果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FloatMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class FloatMap

  • java.lang.Object
    • javafx.scene.effect.FloatMap

  • public class FloatMap
extends Object
    包含浮点数据的缓冲区，用作DisplacementMap等效果的参数。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      IntegerProperty height
      地图的高度，以像素为单位。
      IntegerProperty width
      地图的宽度，以像素为单位。

    • 构造方法摘要

      构造方法
      Constructor 描述
      FloatMap​()
      使用默认参数创建一个新的FloatMap实例。
      FloatMap​(int width, int height)
      以指定的宽度和高度创建一个新的FloatMap实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getHeight​()
      获取属性高度的值。
      int getWidth​()
      获取属性宽度的值。
      IntegerProperty heightProperty​()
      地图的高度，以像素为单位。
      void setHeight​(int value)
      设置属性高度的值。
      void setSample​(int x, int y, int band, float s)
      在给定（x，y）位置设置特定频段的样本。
      void setSamples​(int x, int y, float s0)
      在给定（x，y）位置设置第一个频带的样本。
      void setSamples​(int x, int y, float s0, float s1)
      在给定（x，y）位置设置前两个频带的样本。
      void setSamples​(int x, int y, float s0, float s1, float s2)
      在给定（x，y）位置设置前三个频带的样本。
      void setSamples​(int x, int y, float s0, float s1, float s2, float s3)
      在给定（x，y）位置设置四个频带中的每个频带的样本。
      void setWidth​(int value)
      设置属性宽度的值。
      IntegerProperty widthProperty​()
      地图的宽度，以像素为单位。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • width

        public final IntegerProperty widthProperty
        地图的宽度，以像素为单位。
          Min:    1
       Max: 4096
   Default:    1
  Identity:  n/a
        Default value:
        1
        另请参见：
        getWidth() ， setWidth(int)

      • height

        public final IntegerProperty heightProperty
        地图的高度，以像素为单位。
          Min:    1
       Max: 4096
   Default:    1
  Identity:  n/a
        Default value:
        1
        另请参见：
        getHeight() ， setHeight(int)

    • 构造方法详细信息

      • FloatMap

        public FloatMap​()
        使用默认参数创建一个新的FloatMap实例。

      • FloatMap

        public FloatMap​(int width,
                int height)
        以指定的宽度和高度创建一个新的FloatMap实例。
        参数
        width - 地图的宽度，以像素为单位
        height - 地图的高度（以像素为单位）
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setWidth

        public final void setWidth​(int value)
        设置属性宽度的值。
        Property description:
        地图的宽度，以像素为单位。
          Min:    1
       Max: 4096
   Default:    1
  Identity:  n/a
        Default value:
        1

      • getWidth

        public final int getWidth​()
        获取属性宽度的值。
        Property description:
        地图的宽度，以像素为单位。
          Min:    1
       Max: 4096
   Default:    1
  Identity:  n/a
        Default value:
        1

      • widthProperty

        public final IntegerProperty widthProperty​()
        地图的宽度，以像素为单位。
          Min:    1
       Max: 4096
   Default:    1
  Identity:  n/a
        Default value:
        1
        另请参见：
        getWidth() ， setWidth(int)

      • setHeight

        public final void setHeight​(int value)
        设置属性高度的值。
        Property description:
        地图的高度，以像素为单位。
          Min:    1
       Max: 4096
   Default:    1
  Identity:  n/a
        Default value:
        1

      • getHeight

        public final int getHeight​()
        获取属性高度的值。
        Property description:
        地图的高度，以像素为单位。
          Min:    1
       Max: 4096
   Default:    1
  Identity:  n/a
        Default value:
        1

      • heightProperty

        public final IntegerProperty heightProperty​()
        地图的高度，以像素为单位。
          Min:    1
       Max: 4096
   Default:    1
  Identity:  n/a
        Default value:
        1
        另请参见：
        getHeight() ， setHeight(int)

      • setSample

        public void setSample​(int x,
                      int y,
                      int band,
                      float s)
        在给定（x，y）位置设置特定频段的样本。
        参数
        x - x位置
        y - y位置
        band - 要设置的频带（必须为0,1,2或3）
        s - 要设置的样本值

      • setSamples

        public void setSamples​(int x,
                       int y,
                       float s0)
        在给定（x，y）位置设置第一个频带的样本。
        参数
        x - x位置
        y - y位置
        s0 - 为第一个频带设置的采样值

      • setSamples

        public void setSamples​(int x,
                       int y,
                       float s0,
                       float s1)
        在给定（x，y）位置设置前两个频带的样本。
        参数
        x - x位置
        y - y位置
        s0 - 为第一个频带设置的采样值
        s1 - 为第二个频带设置的采样值

      • setSamples

        public void setSamples​(int x,
                       int y,
                       float s0,
                       float s1,
                       float s2)
        在给定（x，y）位置设置前三个频带的样本。
        参数
        x - x位置
        y - y位置
        s0 - 为第一个频带设置的采样值
        s1 - 为第二个频带设置的采样值
        s2 - 为第三个频带设置的采样值

      • setSamples

        public void setSamples​(int x,
                       int y,
                       float s0,
                       float s1,
                       float s2,
                       float s3)
        在给定（x，y）位置设置四个频带中的每个频带的样本。
        参数
        x - x位置
        y - y位置
        s0 - 为第一个频带设置的采样值
        s1 - 为第二个频带设置的采样值
        s2 - 为第三个频带设置的采样值
        s3 - the sample value to set for the fourth band
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GaussianBlur (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class GaussianBlur

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.GaussianBlur

  • public class GaussianBlur
extends Effect
    使用高斯卷积核的模糊效果，具有可配置的半径。

    例：

       Text text = new Text(); text.setText("Blurry Text!"); text.setFill(Color.web("0x3b596d")); text.setFont(Font.font(null, FontWeight.BOLD, 50)); text.setX(10); text.setY(50); text.setEffect(new GaussianBlur());

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Effect> input
      这个输入为 Effect 。
      DoubleProperty radius
      模糊内核的半径。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GaussianBlur​()
      用默认参数创建一个新的GaussianBlur实例。
      GaussianBlur​(double radius)
      用指定的半径创建一个新的GaussianBlur实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Effect getInput​()
      获取属性输入的值。
      double getRadius​()
      获取属性半径的值。
      ObjectProperty<Effect> inputProperty​()
      这个输入为 Effect 。
      DoubleProperty radiusProperty​()
      模糊内核的半径。
      void setInput​(Effect value)
      设置属性输入的值。
      void setRadius​(double value)
      设置属性半径的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        这个输入为Effect 。 如果设置为null或未指定，则连接Effect的Node的图形图像将用作输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • radius

        public final DoubleProperty radiusProperty
        模糊内核的半径。
          Min:  0.0
       Max: 63.0
   Default: 10.0
  Identity:  0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)

    • 构造方法详细信息

      • GaussianBlur

        public GaussianBlur​()
        用默认参数创建一个新的GaussianBlur实例。

      • GaussianBlur

        public GaussianBlur​(double radius)
        用指定的半径创建一个新的GaussianBlur实例。
        参数
        radius - 模糊内核的半径
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setRadius

        public final void setRadius​(double value)
        设置属性半径的值。
        Property description:
        模糊内核的半径。
          Min:  0.0
       Max: 63.0
   Default: 10.0
  Identity:  0.0
        Default value:
        10.0

      • getRadius

        public final double getRadius​()
        获取属性半径的值。
        Property description:
        模糊内核的半径。
          Min:  0.0
       Max: 63.0
   Default: 10.0
  Identity:  0.0
        Default value:
        10.0

      • radiusProperty

        public final DoubleProperty radiusProperty​()
        模糊内核的半径。
          Min:  0.0
       Max: 63.0
   Default: 10.0
  Identity:  0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Glow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Glow

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.Glow

  • public class Glow
extends Effect
    基于可配置的阈值，使输入图像看起来发亮的高级效果。

    例：

       Image image = new Image("boat.jpg"); ImageView imageView = new ImageView(image); imageView.setFitWidth(200); imageView.setPreserveRatio(true); imageView.setEffect(new Glow(0.8));

    以上代码适用于此图像：

    产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Effect> input
      这个输入为 Effect 。
      DoubleProperty level
      水平值，用于控制发光效果的强度。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Glow​()
      使用默认参数创建一个新的Glow实例。
      Glow​(double level)
      创建一个新的具有指定级别的Glow实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Effect getInput​()
      获取属性输入的值。
      double getLevel​()
      获取属性级别的值。
      ObjectProperty<Effect> inputProperty​()
      这个输入为 Effect 。
      DoubleProperty levelProperty​()
      水平值，用于控制发光效果的强度。
      void setInput​(Effect value)
      设置属性输入的值。
      void setLevel​(double value)
      设置属性级别的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • level

        public final DoubleProperty levelProperty
        水平值，用于控制发光效果的强度。
          Min: 0.0
       Max: 1.0
   Default: 0.3
  Identity: 0.0
        Default value:
        0.3
        另请参见：
        getLevel() ， setLevel(double)

    • 构造方法详细信息

      • Glow

        public Glow​()
        使用默认参数创建一个新的Glow实例。

      • Glow

        public Glow​(double level)
        创建一个新的具有指定级别的Glow实例。
        参数
        level - 控制发光效果强度的电平值

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null ，或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        该输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setLevel

        public final void setLevel​(double value)
        设置属性级别的值。
        Property description:
        水平值，用于控制发光效果的强度。
          Min: 0.0
       Max: 1.0
   Default: 0.3
  Identity: 0.0
        Default value:
        0.3

      • getLevel

        public final double getLevel​()
        获取属性级别的值。
        Property description:
        水平值，用于控制发光效果的强度。
          Min: 0.0
       Max: 1.0
   Default: 0.3
  Identity: 0.0
        Default value:
        0.3

      • levelProperty

        public final DoubleProperty levelProperty​()
        水平值，用于控制发光效果的强度。
          Min: 0.0
       Max: 1.0
   Default: 0.3
  Identity: 0.0
        Default value:
        0.3
        另请参见：
        getLevel() ， setLevel(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class ImageInput

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.ImageInput

  • public class ImageInput
extends Effect
    一种源效果，只是将给定的 Image通过未修改，作为输入到另一个 Effect 。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Image> source
      来源 Image 。
      DoubleProperty x
      相对于内容 Node的本地坐标空间设置源图像的x位置。
      DoubleProperty y
      设置源图像的y位置，相对于内容 Node的局部坐标空间。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageInput​()
      使用默认参数创建一个新的ImageInput实例。
      ImageInput​(Image source)
      使用指定的源创建一个新的ImageInput实例。
      ImageInput​(Image source, double x, double y)
      使用指定的源x和y创建一个新的ImageInput实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Image getSource​()
      获取属性源的值。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      void setSource​(Image value)
      设置属性源的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      ObjectProperty<Image> sourceProperty​()
      来源 Image 。
      DoubleProperty xProperty​()
      相对于内容 Node的本地坐标空间设置源图像的x位置。
      DoubleProperty yProperty​()
      相对于内容 Node的本地坐标空间设置源图像的y位置。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • source

        public final ObjectProperty<Image> sourceProperty
        来源 Image 。
        另请参见：
        getSource() ， setSource(Image)

      • x

        public final DoubleProperty xProperty
        相对于内容Node的本地坐标空间设置源图像的x位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        设置源图像的y位置，相对于内容Node的本地坐标空间。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

    • 构造方法详细信息

      • ImageInput

        public ImageInput​()
        使用默认参数创建一个新的ImageInput实例。

      • ImageInput

        public ImageInput​(Image source)
        使用指定的源创建一个新的ImageInput实例。
        参数
        source - 来源 Image 。
        从以下版本开始：
        JavaFX 2.1

      • ImageInput

        public ImageInput​(Image source,
                  double x,
                  double y)
        使用指定的源x和y创建一个新的ImageInput实例。
        参数
        source - 来源 Image 。
        x - 源图像的x位置
        y - 源图像的y位置
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setSource

        public final void setSource​(Image value)
        设置属性源的值。
        Property description:
        来源 Image 。

      • getSource

        public final Image getSource​()
        获取属性源的值。
        Property description:
        来源 Image 。

      • sourceProperty

        public final ObjectProperty<Image> sourceProperty​()
        来源 Image 。
        另请参见：
        getSource() ， setSource(Image)

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        相对于内容Node的本地坐标空间设置源图像的x位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        相对于内容Node的本地坐标空间设置源图像的x位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        相对于内容Node的本地坐标空间设置源图像的x位置。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        设置源图像的y位置，相对于内容Node的局部坐标空间。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        设置源图像的y位置，相对于内容Node的局部坐标空间。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        设置源图像的y位置，相对于内容Node的局部坐标空间。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InnerShadow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class InnerShadow

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.InnerShadow

  • public class InnerShadow
extends Effect
    使用指定的颜色，半径和偏移量在给定内容的边缘内部呈现阴影的高级效果。

    例：

       InnerShadow innerShadow = new InnerShadow(); innerShadow.setOffsetX(4); innerShadow.setOffsetY(4); innerShadow.setColor(Color.web("0x3b596d")); Text text = new Text(); text.setEffect(innerShadow); text.setX(20); text.setY(100); text.setText("InnerShadow"); text.setFill(Color.ALICEBLUE); text.setFont(Font.font(null, FontWeight.BOLD, 50));

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<BlurType> blurType
      用于模糊阴影的算法。
      DoubleProperty choke
      阴影的cho子。
      ObjectProperty<Color> color
      阴影 Color 。
      DoubleProperty height
      阴影模糊内核的垂直尺寸。
      ObjectProperty<Effect> input
      该输入为 Effect 。
      DoubleProperty offsetX
      x方向的阴影偏移量，以像素为单位。
      DoubleProperty offsetY
      y方向的阴影偏移，以像素为单位。
      DoubleProperty radius
      阴影模糊内核的半径。
      DoubleProperty width
      阴影模糊内核的水平尺寸。

    • 构造方法摘要

      构造方法
      Constructor 描述
      InnerShadow​()
      使用默认参数创建一个新的InnerShadow实例。
      InnerShadow​(double radius, double offsetX, double offsetY, Color color)
      创建一个新的具有指定半径，offsetX，offsetY和color的InnerShadow实例。
      InnerShadow​(double radius, Color color)
      创建一个新的具有指定半径和颜色的InnerShadow实例。
      InnerShadow​(BlurType blurType, Color color, double radius, double choke, double offsetX, double offsetY)
      使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的InnerShadow实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<BlurType> blurTypeProperty​()
      用于模糊阴影的算法。
      DoubleProperty chokeProperty​()
      阴影的cho子。
      ObjectProperty<Color> colorProperty​()
      阴影 Color 。
      BlurType getBlurType​()
      获取属性blurType的值。
      double getChoke​()
      获取属性阻塞的值。
      Color getColor​()
      获取属性颜色的值。
      double getHeight​()
      获取属性高度的值。
      Effect getInput​()
      获取属性输入的值。
      double getOffsetX​()
      获取属性offsetX的值。
      double getOffsetY​()
      获取属性offsetY的值。
      double getRadius​()
      获取属性半径的值。
      double getWidth​()
      获取属性宽度的值。
      DoubleProperty heightProperty​()
      阴影模糊内核的垂直尺寸。
      ObjectProperty<Effect> inputProperty​()
      这个输入为 Effect 。
      DoubleProperty offsetXProperty​()
      x方向的阴影偏移量，以像素为单位。
      DoubleProperty offsetYProperty​()
      y方向的阴影偏移，以像素为单位。
      DoubleProperty radiusProperty​()
      阴影模糊内核的半径。
      void setBlurType​(BlurType value)
      设置属性blurType的值。
      void setChoke​(double value)
      设置属性阻塞的值。
      void setColor​(Color value)
      设置属性颜色的值。
      void setHeight​(double value)
      设置属性高度的值。
      void setInput​(Effect value)
      设置属性输入的值。
      void setOffsetX​(double value)
      设置属性offsetX的值。
      void setOffsetY​(double value)
      设置属性offsetY的值。
      void setRadius​(double value)
      设置属性半径的值。
      void setWidth​(double value)
      设置属性宽度的值。
      DoubleProperty widthProperty​()
      阴影模糊内核的水平尺寸。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        该输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • radius

        public final DoubleProperty radiusProperty
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径等同于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)

      • width

        public final DoubleProperty widthProperty
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final DoubleProperty heightProperty
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getHeight() ， setHeight(double)

      • blurType

        public final ObjectProperty<BlurType> blurTypeProperty
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX
        另请参见：
        getBlurType() ， setBlurType(BlurType)

      • choke

        public final DoubleProperty chokeProperty
        阴影的cho子。 扼流圈是源材料的贡献率为100％的半径部分。 半径的剩余部分将具有由模糊核心控制的贡献。 0.0的扼流圈将导致完全由模糊算法确定的阴影的分布。 1.0的扼流圈将导致从半径的边缘到极限的阴影内部的固体增长，其中半径内的透明度非常尖锐。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getChoke() ， setChoke(double)

      • color

        public final ObjectProperty<Color> colorProperty
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色
        另请参见：
        getColor() ， setColor(Color)

      • offsetX

        public final DoubleProperty offsetXProperty
        x方向的阴影偏移量，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetX() ， setOffsetX(double)

      • offsetY

        public final DoubleProperty offsetYProperty
        y方向的阴影偏移，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetY() ， setOffsetY(double)

    • 构造方法详细信息

      • InnerShadow

        public InnerShadow​()
        使用默认参数创建一个新的InnerShadow实例。

      • InnerShadow

        public InnerShadow​(double radius,
                   Color color)
        创建一个新的具有指定半径和颜色的InnerShadow实例。
        参数
        radius - 影子模糊内核的半径
        color - 影子 Color

      • InnerShadow

        public InnerShadow​(double radius,
                   double offsetX,
                   double offsetY,
                   Color color)
        创建一个新的具有指定半径，offsetX，offsetY和color的InnerShadow实例。
        参数
        radius - 影子模糊内核的半径
        offsetX - x方向的阴影偏移
        offsetY - y方向的阴影偏移
        color - 影子 Color

      • InnerShadow

        public InnerShadow​(BlurType blurType,
                   Color color,
                   double radius,
                   double choke,
                   double offsetX,
                   double offsetY)
        使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的InnerShadow实例。
        参数
        blurType - 用于模糊阴影的算法
        color - 阴影 Color
        radius - 阴影模糊内核的半径
        choke - 源材料的贡献率为100％的半径部分
        offsetX - x方向的阴影偏移
        offsetY - y方向的阴影偏移
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        该输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像用作输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        该输入为Effect 。 如果设置为null ，或未指定，所述的图形图像Node到的Effect附着将被用作输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setRadius

        public final void setRadius​(double value)
        设置属性半径的值。
        Property description:
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径相当于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0

      • getRadius

        public final double getRadius​()
        获取属性半径的值。
        Property description:
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径相当于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0

      • radiusProperty

        public final DoubleProperty radiusProperty​()
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径相当于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • widthProperty

        public final DoubleProperty widthProperty​()
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • heightProperty

        public final DoubleProperty heightProperty​()
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getHeight() ， setHeight(double)

      • setBlurType

        public final void setBlurType​(BlurType value)
        设置属性blurType的值。
        Property description:
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX

      • getBlurType

        public final BlurType getBlurType​()
        获取属性blurType的值。
        Property description:
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX

      • blurTypeProperty

        public final ObjectProperty<BlurType> blurTypeProperty​()
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX
        另请参见：
        getBlurType() ， setBlurType(BlurType)

      • setChoke

        public final void setChoke​(double value)
        设置属性阻塞的值。
        Property description:
        阴影的cho子。 扼流圈是源材料的贡献率为100％的半径部分。 半径的剩余部分将具有由模糊核心控制的贡献。 0.0的扼流圈将导致完全由模糊算法确定的阴影的分布。 1.0的扼流圈将导致从半径的边缘到极限的阴影内部的固体增长，其中半径内的透明度非常尖锐。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getChoke

        public final double getChoke​()
        获取属性阻塞的值。
        Property description:
        阴影的cho子。 扼流圈是源材料的贡献率为100％的半径部分。 半径的剩余部分将具有由模糊核心控制的贡献。 0.0的扼流圈将导致完全由模糊算法确定的阴影的分布。 1.0的扼流圈将导致从半径的边缘到极限的阴影内部的固体增长，其中半径内部的透明度非常尖锐。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • chokeProperty

        public final DoubleProperty chokeProperty​()
        阴影的cho子。 扼流圈是源材料的贡献率为100％的半径部分。 半径的剩余部分将具有由模糊核心控制的贡献。 0.0的扼流圈将导致完全由模糊算法确定的阴影的分布。 1.0的扼流圈将导致从半径的边缘到极限的阴影内部的固体增长，其中半径内部的透明度非常尖锐。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getChoke() ， setChoke(double)

      • setColor

        public final void setColor​(Color value)
        设置属性颜色的值。
        Property description:
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色

      • getColor

        public final Color getColor​()
        获取属性颜色的值。
        Property description:
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色

      • colorProperty

        public final ObjectProperty<Color> colorProperty​()
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色
        另请参见：
        getColor() ， setColor(Color)

      • setOffsetX

        public final void setOffsetX​(double value)
        设置属性offsetX的值。
        Property description:
        x方向的阴影偏移量，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getOffsetX

        public final double getOffsetX​()
        获取属性offsetX的值。
        Property description:
        x方向的阴影偏移量，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • offsetXProperty

        public final DoubleProperty offsetXProperty​()
        x方向的阴影偏移量，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetX() ， setOffsetX(double)

      • setOffsetY

        public final void setOffsetY​(double value)
        设置属性offsetY的值。
        Property description:
        y方向的阴影偏移，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getOffsetY

        public final double getOffsetY​()
        获取属性offsetY的值。
        Property description:
        y方向的阴影偏移，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • offsetYProperty

        public final DoubleProperty offsetYProperty​()
        y方向的阴影偏移，以像素为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getOffsetY() ， setOffsetY(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.effect (Java SE 9 & JDK 9 )

javafx.scene.effect

Classes

  • Blend
  • Bloom
  • BoxBlur
  • ColorAdjust
  • ColorInput
  • DisplacementMap
  • DropShadow
  • Effect
  • FloatMap
  • GaussianBlur
  • Glow
  • ImageInput
  • InnerShadow
  • Light
  • Light.Distant
  • Light.Point
  • Light.Spot
  • Lighting
  • MotionBlur
  • PerspectiveTransform
  • Reflection
  • SepiaTone
  • Shadow

Enums

  • BlendMode
  • BlurType


javafx.scene.effect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene.effect

提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。

效果是产生图像的图形算法，通常作为源图像的修改。 通过设置effect属性，效果可以与场景图Node相关联。 某些效果会改变源像素的颜色属性（例如ColorAdjust ），其他效果会将多个图像组合在一起（例如Blend ），而其他效果还会扭曲或移动源图像周围的像素（如DisplacementMap或PerspectiveTransform ）。 所有效果至少有一个输入被定义，并且输入可以被设置为另一个效果，以将效果链接在一起并组合它们的结果，或者可以不指定这种效果，在这种情况下，效果将对附加的节点的图形呈现进行操作至。

  • 类摘要
    Class 描述
    Blend
    使用预定义的BlendMode之一将两个输入组合在一起的效果。
    Bloom
    基于可配置的阈值，使得输入图像的较亮部分看起来发亮的高级效果。
    BoxBlur
    使用简单的盒式过滤器内核的模糊效果，在两个维度上都有单独配置的大小，以及控制所产生的模糊质量的迭代参数。
    ColorAdjust
    允许每个像素调整色调，饱和度，亮度和对比度的效果。
    ColorInput
    使用给定的 Paint填充（“淹没”）的矩形区域的效果。
    DisplacementMap
    将每个像素移动由指定的FloatMap的前两个频带指定的距离的效果 。
    DropShadow
    使用指定的颜色，半径和偏移量将给定内容的阴影呈现在内容后面的高级效果。
    Effect
    所有效果实现的抽象基类。
    FloatMap
    包含浮点数据的缓冲区，用作DisplacementMap等效果的参数。
    GaussianBlur
    使用高斯卷积核的模糊效果，具有可配置的半径。
    Glow
    基于可配置的阈值，使输入图像看起来发亮的高级效果。
    ImageInput
    一种源效果，只是将给定的 Image通过未修改，作为输入到另一个 Effect 。
    InnerShadow
    使用指定的颜色，半径和偏移量在给定内容的边缘内部呈现阴影的高级效果。
    Light
    所有轻型实现的抽象基类。
    Light.Distant
    代表遥远的光源。
    Light.Point
    表示3D空间中给定位置的光源。
    Light.Spot
    在3D空间中的给定位置表示点光源，具有可配置的方向和焦点。
    Lighting
    模拟照亮给定内容的光源的效果，可用于给平坦物体更逼真的三维外观。
    MotionBlur
    使用高斯卷积核的运动模糊效果，具有可配置的半径和角度。
    PerspectiveTransform
    提供输入内容的非仿射变换的效果。
    Reflection
    将输入的反映版本呈现在实际输入内容之下的效果。
    SepiaTone
    一个过滤器，产生棕褐色调效果，类似于古董照片。
    Shadow
    产生具有模糊边缘的输入的单色副本的效果。
  • 枚举摘要
    Enum 描述
    BlendMode
    混合模式定义混合效果的输入合成在一起的方式，或者如何将节点混合到场景的背景中。
    BlurType
    表示用于软化 Shadow效果的模糊算法的类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.effect Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.effect

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.Blend
      • javafx.scene.effect.Bloom
      • javafx.scene.effect.BoxBlur
      • javafx.scene.effect.ColorAdjust
      • javafx.scene.effect.ColorInput
      • javafx.scene.effect.DisplacementMap
      • javafx.scene.effect.DropShadow
      • javafx.scene.effect.GaussianBlur
      • javafx.scene.effect.Glow
      • javafx.scene.effect.ImageInput
      • javafx.scene.effect.InnerShadow
      • javafx.scene.effect.Lighting
      • javafx.scene.effect.MotionBlur
      • javafx.scene.effect.PerspectiveTransform
      • javafx.scene.effect.Reflection
      • javafx.scene.effect.SepiaTone
      • javafx.scene.effect.Shadow
    • javafx.scene.effect.FloatMap
    • javafx.scene.effect.Light
      • javafx.scene.effect.Light.Distant
      • javafx.scene.effect.Light.Point
        • javafx.scene.effect.Light.Spot

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.effect.BlendMode
      • javafx.scene.effect.BlurType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Light (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Light

  • java.lang.Object
    • javafx.scene.effect.Light
  • 已知直接子类：
    Light.Distant ， Light.Point

    public abstract class Light
extends Object
    所有轻型实现的抽象基类。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Color> color
      光源的颜色。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Light.Distant
      代表遥远的光源。
      static class  Light.Point
      表示3D空间中给定位置的光源。
      static class  Light.Spot
      在3D空间中的给定位置表示点光源，具有可配置的方向和焦点。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Light​()
      创造一个新的光。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Color> colorProperty​()
      光源的颜色。
      Color getColor​()
      获取属性颜色的值。
      void setColor​(Color value)
      设置属性颜色的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • color

        public final ObjectProperty<Color> colorProperty
        光源的颜色。
          Min: n/a
       Max: n/a
   Default: Color.WHITE
  Identity: n/a
        Default value:
        白色
        另请参见：
        getColor() ， setColor(Color)

    • 构造方法详细信息

      • Light

        protected Light​()
        创造一个新的光。

    • 方法详细信息

      • setColor

        public final void setColor​(Color value)
        设置属性颜色的值。
        Property description:
        光源的颜色。
          Min: n/a
       Max: n/a
   Default: Color.WHITE
  Identity: n/a
        Default value:
        白色

      • getColor

        public final Color getColor​()
        获取属性颜色的值。
        Property description:
        光源的颜色。
          Min: n/a
       Max: n/a
   Default: Color.WHITE
  Identity: n/a
        Default value:
        白色

      • colorProperty

        public final ObjectProperty<Color> colorProperty​()
        光源的颜色。
          Min: n/a
       Max: n/a
   Default: Color.WHITE
  Identity: n/a
        Default value:
        白色
        另请参见：
        getColor() ， setColor(Color)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Light.Distant (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Light.Distant

  • java.lang.Object
    • javafx.scene.effect.Light
      • javafx.scene.effect.Light.Distant
  • Enclosing class:
    Light

    public static class Light.Distant
extends Light
    代表遥远的光源。

    例：

       Light.Distant light = new Light.Distant(); light.setAzimuth(45.0); light.setElevation(30.0); Lighting lighting = new Lighting(); lighting.setLight(light); lighting.setSurfaceScale(5.0); Text text = new Text(); text.setText("Distant"); text.setFill(Color.STEELBLUE); text.setFont(Font.font("null", FontWeight.BOLD, 80)); text.setX(10.0f); text.setY(10.0f); text.setTextOrigin(VPos.TOP); text.setEffect(lighting); Rectangle rect = new Rectangle(300,150); rect.setFill(Color.ALICEBLUE); rect.setEffect(lighting);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty azimuth
      光的方位角。
      DoubleProperty elevation
      光的高度。

      • Properties inherited from class javafx.scene.effect.Light

        color

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.effect.Light

        Light.Distant, Light.Point, Light.Spot

    • 构造方法摘要

      构造方法
      Constructor 描述
      Distant​()
      使用默认参数创建一个新的遥控灯实例。
      Distant​(double azimuth, double elevation, Color color)
      创建一个新的具有指定方位角，高程和颜色的远光的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty azimuthProperty​()
      光的方位角。
      DoubleProperty elevationProperty​()
      光的高度。
      double getAzimuth​()
      获取属性方位角的值。
      double getElevation​()
      获取属性高程的值。
      void setAzimuth​(double value)
      设置属性方位角的值。
      void setElevation​(double value)
      设置属性高程的值。

      • Methods inherited from class javafx.scene.effect.Light

        colorProperty, getColor, setColor

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • azimuth

        public final DoubleProperty azimuthProperty
        光的方位角。 方位角是XY平面上光源的方向角，以度为单位。
          Min:  n/a
       Max:  n/a
   Default: 45.0
  Identity:  n/a
        Default value:
        45.0
        另请参见：
        getAzimuth() ， setAzimuth(double)

      • elevation

        public final DoubleProperty elevationProperty
        光的高度。 仰角是YZ平面光源的方向角，以度为单位。
          Min:  n/a
       Max:  n/a
   Default: 45.0
  Identity:  n/a
        Default value:
        45.0
        另请参见：
        getElevation() ， setElevation(double)

    • 构造方法详细信息

      • Distant

        public Distant​()
        使用默认参数创建一个新的遥控灯实例。

      • Distant

        public Distant​(double azimuth,
               double elevation,
               Color color)
        创建一个新的具有指定方位角，高程和颜色的远光的实例。
        参数
        azimuth - 光的方位角
        elevation - 光的高度
        color - 光的颜色
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setAzimuth

        public final void setAzimuth​(double value)
        设置属性方位角的值。
        Property description:
        光的方位角。 方位角是XY平面上光源的方向角，以度为单位。
          Min:  n/a
       Max:  n/a
   Default: 45.0
  Identity:  n/a
        Default value:
        45.0

      • getAzimuth

        public final double getAzimuth​()
        获取属性方位角的值。
        Property description:
        光的方位角。 方位角是XY平面上光源的方向角，以度为单位。
          Min:  n/a
       Max:  n/a
   Default: 45.0
  Identity:  n/a
        Default value:
        45.0

      • azimuthProperty

        public final DoubleProperty azimuthProperty​()
        光的方位角。 方位角是XY平面上光源的方向角，以度为单位。
          Min:  n/a
       Max:  n/a
   Default: 45.0
  Identity:  n/a
        Default value:
        45.0
        另请参见：
        getAzimuth() ， setAzimuth(double)

      • setElevation

        public final void setElevation​(double value)
        设置属性高程的值。
        Property description:
        光的高度。 仰角是YZ平面光源的方向角，以度为单位。
          Min:  n/a
       Max:  n/a
   Default: 45.0
  Identity:  n/a
        Default value:
        45.0

      • getElevation

        public final double getElevation​()
        获取属性高程的值。
        Property description:
        光的高度。 仰角是YZ平面光源的方向角，以度为单位。
          Min:  n/a
       Max:  n/a
   Default: 45.0
  Identity:  n/a
        Default value:
        45.0

      • elevationProperty

        public final DoubleProperty elevationProperty​()
        光的高度。 仰角是YZ平面光源的方向角，以度为单位。
          Min:  n/a
       Max:  n/a
   Default: 45.0
  Identity:  n/a
        Default value:
        45.0
        另请参见：
        getElevation(), setElevation(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Light.Point (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Light.Point

  • java.lang.Object
    • javafx.scene.effect.Light
      • javafx.scene.effect.Light.Point
  • 已知直接子类：
    Light.Spot
    Enclosing class:
    Light

    public static class Light.Point
extends Light
    表示3D空间中给定位置的光源。

    例：

       Light.Point light = new Light.Point(); light.setX(100); light.setY(100); light.setZ(50); Lighting lighting = new Lighting(); lighting.setLight(light); lighting.setSurfaceScale(5.0); Text text = new Text(); text.setText("Point"); text.setFill(Color.STEELBLUE); text.setFont(Font.font(null, FontWeight.BOLD, 80)); text.setX(10.0); text.setY(10.0); text.setTextOrigin(VPos.TOP); Rectangle rect = new Rectangle(250, 150); rect.setFill(Color.ALICEBLUE); rect.setEffect(lighting); text.setEffect(lighting);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty x
      光位置的x坐标。
      DoubleProperty y
      光位置的y坐标。
      DoubleProperty z
      光位置的z坐标。

      • Properties inherited from class javafx.scene.effect.Light

        color

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.effect.Light

        Light.Distant, Light.Point, Light.Spot

    • 构造方法摘要

      构造方法
      Constructor 描述
      Point​()
      使用默认参数创建点光源的新实例。
      Point​(double x, double y, double z, Color color)
      用指定的x，y，x和color创建一个新的点光实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      double getZ​()
      获取属性z的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      void setZ​(double value)
      设置属性z的值。
      DoubleProperty xProperty​()
      光位置的x坐标。
      DoubleProperty yProperty​()
      光位置的y坐标。
      DoubleProperty zProperty​()
      光位置的z坐标。

      • Methods inherited from class javafx.scene.effect.Light

        colorProperty, getColor, setColor

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • x

        public final DoubleProperty xProperty
        光位置的x坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        光位置的y坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • z

        public final DoubleProperty zProperty
        光位置的z坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getZ() ， setZ(double)

    • 构造方法详细信息

      • Point

        public Point​()
        使用默认参数创建点光源的新实例。

      • Point

        public Point​(double x,
             double y,
             double z,
             Color color)
        用指定的x，y，x和color创建一个新的点光实例。
        参数
        x - 光位置的x坐标
        y - 光位置的y坐标
        z - 光位置的z坐标
        color - 光的颜色
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        光位置的x坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        光位置的x坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        光位置的x坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        光位置的y坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        光位置的y坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        光位置的y坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • setZ

        public final void setZ​(double value)
        设置属性z的值。
        Property description:
        光位置的z坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • getZ

        public final double getZ​()
        获取属性z的值。
        Property description:
        光位置的z坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • zProperty

        public final DoubleProperty zProperty​()
        光位置的z坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getZ(), setZ(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Light.Spot (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Light.Spot

  • java.lang.Object
    • javafx.scene.effect.Light
      • javafx.scene.effect.Light.Point
        • javafx.scene.effect.Light.Spot
  • Enclosing class:
    Light

    public static class Light.Spot
extends Light.Point
    在3D空间中的给定位置表示点光源，具有可配置的方向和焦点。

    例：

       Light.Spot light = new Light.Spot(); light.setX(150); light.setY(100); light.setZ(80); light.setPointsAtX(0); light.setPointsAtY(0); light.setPointsAtZ(-50); light.setSpecularExponent(2); Lighting lighting = new Lighting(); lighting.setLight(light); lighting.setSurfaceScale(5.0); Text text = new Text(); text.setText("Spot"); text.setFill(Color.STEELBLUE); text.setFont(Font.font(null, FontWeight.BOLD, 80)); text.setX(10.0); text.setY(10.0); text.setTextOrigin(VPos.TOP); text.setEffect(lighting); Rectangle rect = new Rectangle(200, 150); rect.setFill(Color.ALICEBLUE); rect.setEffect(lighting);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty pointsAtX
      该光的方向矢量的x坐标。
      DoubleProperty pointsAtY
      该光的方向矢量的y坐标。
      DoubleProperty pointsAtZ
      该光的方向矢量的z坐标。
      DoubleProperty specularExponent
      镜面指数，控制这个光源的焦点。

      • Properties inherited from class javafx.scene.effect.Light

        color

      • Properties inherited from class javafx.scene.effect.Light.Point

        x, y, z

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.effect.Light

        Light.Distant, Light.Point, Light.Spot

    • 构造方法摘要

      构造方法
      Constructor 描述
      Spot​()
      使用默认参数创建一个新的Spotlight实例。
      Spot​(double x, double y, double z, double specularExponent, Color color)
      使用指定的x，y，z，specularExponent和color创建一个新的Spotlight实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getPointsAtX​()
      获取属性pointsAtX的值。
      double getPointsAtY​()
      获取属性点的值。
      double getPointsAtZ​()
      获取属性点AtZ的值。
      double getSpecularExponent​()
      获取属性specularExponent的值。
      DoubleProperty pointsAtXProperty​()
      该光的方向矢量的x坐标。
      DoubleProperty pointsAtYProperty​()
      该光的方向矢量的y坐标。
      DoubleProperty pointsAtZProperty​()
      该光的方向矢量的z坐标。
      void setPointsAtX​(double value)
      设置属性pointsAtX的值。
      void setPointsAtY​(double value)
      设置属性点的值。
      void setPointsAtZ​(double value)
      设置属性点AtZ的值。
      void setSpecularExponent​(double value)
      设置属性specularExponent的值。
      DoubleProperty specularExponentProperty​()
      镜面指数，控制这个光源的焦点。

      • Methods inherited from class javafx.scene.effect.Light

        colorProperty, getColor, setColor

      • Methods inherited from class javafx.scene.effect.Light.Point

        getX, getY, getZ, setX, setY, setZ, xProperty, yProperty, zProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • pointsAtX

        public final DoubleProperty pointsAtXProperty
        该光的方向矢量的x坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getPointsAtX() ， setPointsAtX(double)

      • pointsAtY

        public final DoubleProperty pointsAtYProperty
        该光的方向矢量的y坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getPointsAtY() ， setPointsAtY(double)

      • pointsAtZ

        public final DoubleProperty pointsAtZProperty
        该光的方向矢量的z坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getPointsAtZ() ， setPointsAtZ(double)

      • specularExponent

        public final DoubleProperty specularExponentProperty
        镜面指数，控制这个光源的焦点。
          Min: 0.0
       Max: 4.0
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0
        另请参见：
        getSpecularExponent() ， setSpecularExponent(double)

    • 构造方法详细信息

      • Spot

        public Spot​()
        使用默认参数创建一个新的Spotlight实例。

      • Spot

        public Spot​(double x,
            double y,
            double z,
            double specularExponent,
            Color color)
        使用指定的x，y，z，specularExponent和color创建一个新的Spotlight实例。
        参数
        x - 光位置的x坐标
        y - 光位置的y坐标
        z - 光位置的z坐标
        specularExponent - 镜面指数，用于控制光源的焦点
        color - 光的颜色
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setPointsAtX

        public final void setPointsAtX​(double value)
        设置属性pointsAtX的值。
        Property description:
        该光的方向矢量的x坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • getPointsAtX

        public final double getPointsAtX​()
        获取属性pointsAtX的值。
        Property description:
        该光的方向矢量的x坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • pointsAtXProperty

        public final DoubleProperty pointsAtXProperty​()
        该光的方向矢量的x坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getPointsAtX() ， setPointsAtX(double)

      • setPointsAtY

        public final void setPointsAtY​(double value)
        设置属性点的值。
        Property description:
        该光的方向矢量的y坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • getPointsAtY

        public final double getPointsAtY​()
        获取属性点的值。
        Property description:
        该光的方向矢量的y坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • pointsAtYProperty

        public final DoubleProperty pointsAtYProperty​()
        该光的方向矢量的y坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getPointsAtY() ， setPointsAtY(double)

      • setPointsAtZ

        public final void setPointsAtZ​(double value)
        设置属性点AtZ的值。
        Property description:
        该光的方向矢量的z坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • getPointsAtZ

        public final double getPointsAtZ​()
        获取属性点AtZ的值。
        Property description:
        该光的方向矢量的z坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • pointsAtZProperty

        public final DoubleProperty pointsAtZProperty​()
        该光的方向矢量的z坐标。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getPointsAtZ() ， setPointsAtZ(double)

      • setSpecularExponent

        public final void setSpecularExponent​(double value)
        设置属性specularExponent的值。
        Property description:
        镜面指数，控制这个光源的焦点。
          Min: 0.0
       Max: 4.0
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0

      • getSpecularExponent

        public final double getSpecularExponent​()
        获取属性specularExponent的值。
        Property description:
        镜面指数，控制这个光源的焦点。
          Min: 0.0
       Max: 4.0
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0

      • specularExponentProperty

        public final DoubleProperty specularExponentProperty​()
        镜面指数，控制这个光源的焦点。
          Min: 0.0
       Max: 4.0
   Default: 1.0
  Identity: 1.0
        Default value:
        1.0
        另请参见：
        getSpecularExponent() ， setSpecularExponent(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Lighting (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Lighting

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.Lighting

  • public class Lighting
extends Effect
    模拟照亮给定内容的光源的效果，可用于给平坦物体更逼真的三维外观。

    例：

       Light.Distant light = new Light.Distant(); light.setAzimuth(-135.0); Lighting lighting = new Lighting(); lighting.setLight(light); lighting.setSurfaceScale(5.0); Text text = new Text(); text.setText("JavaFX!"); text.setFill(Color.STEELBLUE); text.setFont(Font.font(null, FontWeight.BOLD, 60)); text.setX(10.0); text.setY(10.0); text.setTextOrigin(VPos.TOP); text.setEffect(lighting);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Effect> bumpInput
      可选的凹凸贴图输入。
      ObjectProperty<Effect> contentInput
      内容输入为 Effect 。
      DoubleProperty diffuseConstant
      漫反射常数。
      ObjectProperty<Light> light
      该光源为这 Lighting效果。
      DoubleProperty specularConstant
      镜面常数。
      DoubleProperty specularExponent
      镜面指数。
      DoubleProperty surfaceScale
      表面比例因子。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Lighting​()
      使用默认参数创建一个新的照明实例。
      Lighting​(Light light)
      用指定的光线创建一个新的照明实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Effect> bumpInputProperty​()
      可选的凹凸贴图输入。
      ObjectProperty<Effect> contentInputProperty​()
      内容输入为 Effect 。
      DoubleProperty diffuseConstantProperty​()
      漫反射常数。
      Effect getBumpInput​()
      获取属性bumpInput的值。
      Effect getContentInput​()
      获取属性contentInput的值。
      double getDiffuseConstant​()
      获取属性diffuseConstant的值。
      Light getLight​()
      获取属性灯的值。
      double getSpecularConstant​()
      获取属性specularConstant的值。
      double getSpecularExponent​()
      获取属性specularExponent的值。
      double getSurfaceScale​()
      获取属性surfaceScale的值。
      ObjectProperty<Light> lightProperty​()
      光源为这 Lighting效果。
      void setBumpInput​(Effect value)
      设置属性bumpInput的值。
      void setContentInput​(Effect value)
      设置属性contentInput的值。
      void setDiffuseConstant​(double value)
      设置属性diffuseConstant的值。
      void setLight​(Light value)
      设置属性灯的值。
      void setSpecularConstant​(double value)
      设置属性specularConstant的值。
      void setSpecularExponent​(double value)
      设置属性specularExponent的值。
      void setSurfaceScale​(double value)
      设置属性surfaceScale的值。
      DoubleProperty specularConstantProperty​()
      镜面常数。
      DoubleProperty specularExponentProperty​()
      镜面指数。
      DoubleProperty surfaceScaleProperty​()
      表面比例因子。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • light

        public final ObjectProperty<Light> lightProperty
        这个光源为这个 Lighting效果。
        另请参见：
        getLight() ， setLight(Light)

      • bumpInput

        public final ObjectProperty<Effect> bumpInputProperty
        可选的凹凸贴图输入。 如果未指定，则会从默认输入自动生成凹凸贴图。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像生成默认凹凸贴图。
        Default value:
        半径为10的阴影效果
        另请参见：
        getBumpInput() ， setBumpInput(Effect)

      • contentInput

        public final ObjectProperty<Effect> contentInputProperty
        内容输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getContentInput() ， setContentInput(Effect)

      • diffuseConstant

        public final DoubleProperty diffuseConstantProperty
        漫反射常数。
          Min: 0.0
       Max: 2.0
   Default: 1.0
  Identity: n/a
        Default value:
        1.0
        另请参见：
        getDiffuseConstant() ， setDiffuseConstant(double)

      • specularConstant

        public final DoubleProperty specularConstantProperty
        镜面常数。
          Min: 0.0
       Max: 2.0
   Default: 0.3
  Identity: n/a
        Default value:
        0.3
        另请参见：
        getSpecularConstant() ， setSpecularConstant(double)

      • specularExponent

        public final DoubleProperty specularExponentProperty
        镜面指数。
          Min:  0.0
       Max: 40.0
   Default: 20.0
  Identity:  n/a
        Default value:
        20.0
        另请参见：
        getSpecularExponent() ， setSpecularExponent(double)

      • surfaceScale

        public final DoubleProperty surfaceScaleProperty
        表面比例因子。
          Min:  0.0
       Max: 10.0
   Default:  1.5
  Identity:  n/a
        Default value:
        1.5
        另请参见：
        getSurfaceScale() ， setSurfaceScale(double)

    • 构造方法详细信息

      • Lighting

        public Lighting​()
        使用默认参数创建一个新的照明实例。

      • Lighting

        public Lighting​(Light light)
        用指定的光线创建一个新的照明实例。
        参数
        light - 这个 Lighting效果的光源
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setLight

        public final void setLight​(Light value)
        设置属性灯的值。
        Property description:
        这个光源为这个 Lighting效果。

      • getLight

        public final Light getLight​()
        获取属性灯的值。
        Property description:
        这个光源为这个 Lighting效果。

      • lightProperty

        public final ObjectProperty<Light> lightProperty​()
        这个光源为这个 Lighting效果。
        另请参见：
        getLight() ， setLight(Light)

      • setBumpInput

        public final void setBumpInput​(Effect value)
        设置属性bumpInput的值。
        Property description:
        可选的凹凸贴图输入。 如果未指定，则会从默认输入自动生成凹凸贴图。 如果设置为null或未指定，则将使用Effect附带的Node的图形图像生成默认凹凸贴图。
        Default value:
        半径为10的阴影效果

      • getBumpInput

        public final Effect getBumpInput​()
        获取属性bumpInput的值。
        Property description:
        可选的凹凸贴图输入。 如果未指定，则会从默认输入自动生成凹凸贴图。 如果设置为null或未指定，则Effect附带的Node的图形图像将用于生成默认凹凸贴图。
        Default value:
        半径为10的阴影效果

      • bumpInputProperty

        public final ObjectProperty<Effect> bumpInputProperty​()
        可选的凹凸贴图输入。 如果未指定，则会从默认输入自动生成凹凸贴图。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像生成默认凹凸贴图。
        Default value:
        半径为10的阴影效果
        另请参见：
        getBumpInput() ， setBumpInput(Effect)

      • setContentInput

        public final void setContentInput​(Effect value)
        设置属性contentInput的值。
        Property description:
        内容输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像用作输入。
        Default value:
        空值

      • getContentInput

        public final Effect getContentInput​()
        获取属性contentInput的值。
        Property description:
        内容输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • contentInputProperty

        public final ObjectProperty<Effect> contentInputProperty​()
        内容输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getContentInput() ， setContentInput(Effect)

      • setDiffuseConstant

        public final void setDiffuseConstant​(double value)
        设置属性diffuseConstant的值。
        Property description:
        漫反射常数。
          Min: 0.0
       Max: 2.0
   Default: 1.0
  Identity: n/a
        Default value:
        1.0

      • getDiffuseConstant

        public final double getDiffuseConstant​()
        获取属性diffuseConstant的值。
        Property description:
        漫反射常数。
          Min: 0.0
       Max: 2.0
   Default: 1.0
  Identity: n/a
        Default value:
        1.0

      • diffuseConstantProperty

        public final DoubleProperty diffuseConstantProperty​()
        漫反射常数。
          Min: 0.0
       Max: 2.0
   Default: 1.0
  Identity: n/a
        Default value:
        1.0
        另请参见：
        getDiffuseConstant() ， setDiffuseConstant(double)

      • setSpecularConstant

        public final void setSpecularConstant​(double value)
        设置属性specularConstant的值。
        Property description:
        镜面常数。
          Min: 0.0
       Max: 2.0
   Default: 0.3
  Identity: n/a
        Default value:
        0.3

      • getSpecularConstant

        public final double getSpecularConstant​()
        获取属性specularConstant的值。
        Property description:
        镜面常数。
          Min: 0.0
       Max: 2.0
   Default: 0.3
  Identity: n/a
        Default value:
        0.3

      • specularConstantProperty

        public final DoubleProperty specularConstantProperty​()
        镜面常数。
          Min: 0.0
       Max: 2.0
   Default: 0.3
  Identity: n/a
        Default value:
        0.3
        另请参见：
        getSpecularConstant() ， setSpecularConstant(double)

      • setSpecularExponent

        public final void setSpecularExponent​(double value)
        设置属性specularExponent的值。
        Property description:
        镜面指数。
          Min:  0.0
       Max: 40.0
   Default: 20.0
  Identity:  n/a
        Default value:
        20.0

      • getSpecularExponent

        public final double getSpecularExponent​()
        获取属性specularExponent的值。
        Property description:
        镜面指数。
          Min:  0.0
       Max: 40.0
   Default: 20.0
  Identity:  n/a
        Default value:
        20.0

      • specularExponentProperty

        public final DoubleProperty specularExponentProperty​()
        镜面指数。
          Min:  0.0
       Max: 40.0
   Default: 20.0
  Identity:  n/a
        Default value:
        20.0
        另请参见：
        getSpecularExponent() ， setSpecularExponent(double)

      • setSurfaceScale

        public final void setSurfaceScale​(double value)
        设置属性surfaceScale的值。
        Property description:
        表面比例因子。
          Min:  0.0
       Max: 10.0
   Default:  1.5
  Identity:  n/a
        Default value:
        1.5

      • getSurfaceScale

        public final double getSurfaceScale​()
        获取属性surfaceScale的值。
        Property description:
        表面比例因子。
          Min:  0.0
       Max: 10.0
   Default:  1.5
  Identity:  n/a
        Default value:
        1.5

      • surfaceScaleProperty

        public final DoubleProperty surfaceScaleProperty​()
        表面比例因子。
          Min:  0.0
       Max: 10.0
   Default:  1.5
  Identity:  n/a
        Default value:
        1.5
        另请参见：
        getSurfaceScale() ， setSurfaceScale(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MotionBlur (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class MotionBlur

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.MotionBlur

  • public class MotionBlur
extends Effect
    使用高斯卷积核的运动模糊效果，具有可配置的半径和角度。

    例：

       MotionBlur motionBlur = new MotionBlur(); motionBlur.setRadius(30); motionBlur.setAngle(-15.0); Text text = new Text(); text.setX(20.0); text.setY(100.0); text.setText("Motion!"); text.setFill(Color.web("0x3b596d")); text.setFont(Font.font(null, FontWeight.BOLD, 60)); text.setEffect(motionBlur);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty angle
      运动效果的角度，以度为单位。
      ObjectProperty<Effect> input
      该输入为 Effect 。
      DoubleProperty radius
      模糊内核的半径。

    • 构造方法摘要

      构造方法
      Constructor 描述
      MotionBlur​()
      使用默认参数创建MotionBlur的新实例。
      MotionBlur​(double angle, double radius)
      以指定的角度和半径创建MotionBlur的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty angleProperty​()
      运动效果的角度，以度为单位。
      double getAngle​()
      获取属性角度的值。
      Effect getInput​()
      获取属性输入的值。
      double getRadius​()
      获取属性半径的值。
      ObjectProperty<Effect> inputProperty​()
      这个输入为 Effect 。
      DoubleProperty radiusProperty​()
      模糊内核的半径。
      void setAngle​(double value)
      设置属性角度的值。
      void setInput​(Effect value)
      设置属性输入的值。
      void setRadius​(double value)
      设置属性半径的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        这个Effect的输入。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • radius

        public final DoubleProperty radiusProperty
        模糊内核的半径。
          Min:  0.0
       Max: 63.0
   Default: 10.0
  Identity:  0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)

      • angle

        public final DoubleProperty angleProperty
        运动效果的角度，以度为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getAngle() ， setAngle(double)

    • 构造方法详细信息

      • MotionBlur

        public MotionBlur​()
        使用默认参数创建MotionBlur的新实例。

      • MotionBlur

        public MotionBlur​(double angle,
                  double radius)
        以指定的角度和半径创建MotionBlur的新实例。
        参数
        angle - 运动效果的角度，以度为单位
        radius - 模糊内核的半径
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则将使用附加Effect的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        这个输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像用作输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setRadius

        public final void setRadius​(double value)
        设置属性半径的值。
        Property description:
        模糊内核的半径。
          Min:  0.0
       Max: 63.0
   Default: 10.0
  Identity:  0.0
        Default value:
        10.0

      • getRadius

        public final double getRadius​()
        获取属性半径的值。
        Property description:
        模糊内核的半径。
          Min:  0.0
       Max: 63.0
   Default: 10.0
  Identity:  0.0
        Default value:
        10.0

      • radiusProperty

        public final DoubleProperty radiusProperty​()
        模糊内核的半径。
          Min:  0.0
       Max: 63.0
   Default: 10.0
  Identity:  0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)

      • setAngle

        public final void setAngle​(double value)
        设置属性角度的值。
        Property description:
        运动效果的角度，以度为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • getAngle

        public final double getAngle​()
        获取属性角度的值。
        Property description:
        运动效果的角度，以度为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0

      • angleProperty

        public final DoubleProperty angleProperty​()
        运动效果的角度，以度为单位。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: n/a
        Default value:
        0.0
        另请参见：
        getAngle() ， setAngle(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PerspectiveTransform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class PerspectiveTransform

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.PerspectiveTransform

  • public class PerspectiveTransform
extends Effect
    提供输入内容的非仿射变换的效果。 最通常的是PerspectiveTransform用于为其他二维内容提供“人造”三维效果。

    透视变换能够将任意四边形映射到另一个任意四边形，同时保持线的平直度。 与仿射变换不同，源中的线的并行性不一定在输出中保留。

    请注意，此效果不会调整输入事件的坐标或任何在Node上测量遏制的Node 。 当Node具有PerspectiveTransform效果时，鼠标选择和遏制方法的结果未定义。

    例：

       PerspectiveTransform perspectiveTrasform = new PerspectiveTransform(); perspectiveTrasform.setUlx(10.0); perspectiveTrasform.setUly(10.0); perspectiveTrasform.setUrx(310.0); perspectiveTrasform.setUry(40.0); perspectiveTrasform.setLrx(310.0); perspectiveTrasform.setLry(60.0); perspectiveTrasform.setLlx(10.0); perspectiveTrasform.setLly(90.0); Group g = new Group(); g.setEffect(perspectiveTrasform); g.setCache(true); Rectangle rect = new Rectangle(); rect.setX(10.0); rect.setY(10.0); rect.setWidth(280.0); rect.setHeight(80.0); rect.setFill(Color.web("0x3b596d")); Text text = new Text(); text.setX(20.0); text.setY(65.0); text.setText("Perspective"); text.setFill(Color.ALICEBLUE); text.setFont(Font.font(null, FontWeight.BOLD, 36)); g.getChildren().addAll(rect, text);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Effect> input
      该输入为 Effect 。
      DoubleProperty llx
      源的左下角映射到的输出位置的x坐标。
      DoubleProperty lly
      源的左下角映射到的输出位置的y坐标。
      DoubleProperty lrx
      源映射到其右下角的输出位置的x坐标。
      DoubleProperty lry
      映射源的右下角的输出位置的y坐标。
      DoubleProperty ulx
      源的左上角映射到的输出位置的x坐标。
      DoubleProperty uly
      源的左上角映射到的输出位置的y坐标。
      DoubleProperty urx
      源映射到其右上角的输出位置的x坐标。
      DoubleProperty ury
      映射源的右上角的输出位置的y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PerspectiveTransform​()
      使用默认参数创建PerspectiveTransform的新实例。
      PerspectiveTransform​(double ulx, double uly, double urx, double ury, double lrx, double lry, double llx, double lly)
      用指定的ulx，uly，urx，ury，lrx，lry，llx和lly创建一个PerspectiveTransform的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Effect getInput​()
      获取属性输入的值。
      double getLlx​()
      获取属性llx的值。
      double getLly​()
      获取属性lly的值。
      double getLrx​()
      获取属性lrx的值。
      double getLry​()
      获取属性lry的值。
      double getUlx​()
      获取属性ulx的值。
      double getUly​()
      获取属性的值。
      double getUrx​()
      获取属性urx的值。
      double getUry​()
      获取财产的价值。
      ObjectProperty<Effect> inputProperty​()
      该输入为 Effect 。
      DoubleProperty llxProperty​()
      源的左下角映射到的输出位置的x坐标。
      DoubleProperty llyProperty​()
      源的左下角映射到的输出位置的y坐标。
      DoubleProperty lrxProperty​()
      源映射到其右下角的输出位置的x坐标。
      DoubleProperty lryProperty​()
      映射源的右下角的输出位置的y坐标。
      void setInput​(Effect value)
      设置属性输入的值。
      void setLlx​(double value)
      设置属性llx的值。
      void setLly​(double value)
      设置属性lly的值。
      void setLrx​(double value)
      设置属性lrx的值。
      void setLry​(double value)
      设置属性lry的值。
      void setUlx​(double value)
      设置属性ulx的值。
      void setUly​(double value)
      设置属性uly的值。
      void setUrx​(double value)
      设置属性urx的值。
      void setUry​(double value)
      设置属性的值。
      DoubleProperty ulxProperty​()
      源的左上角映射到的输出位置的x坐标。
      DoubleProperty ulyProperty​()
      源的左上角映射到的输出位置的y坐标。
      DoubleProperty urxProperty​()
      源映射到其右上角的输出位置的x坐标。
      DoubleProperty uryProperty​()
      映射源的右上角的输出位置的y坐标。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        该输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • ulx

        public final DoubleProperty ulxProperty
        源的左上角映射到的输出位置的x坐标。
        Default value:
        0.0
        另请参见：
        getUlx() ， setUlx(double)

      • uly

        public final DoubleProperty ulyProperty
        源的左上角映射到的输出位置的y坐标。
        Default value:
        0.0
        另请参见：
        getUly() ， setUly(double)

      • urx

        public final DoubleProperty urxProperty
        源映射到其右上角的输出位置的x坐标。
        Default value:
        0.0
        另请参见：
        getUrx() ， setUrx(double)

      • ury

        public final DoubleProperty uryProperty
        映射源的右上角的输出位置的y坐标。
        Default value:
        0.0
        另请参见：
        getUry() ， setUry(double)

      • lrx

        public final DoubleProperty lrxProperty
        源映射到其右下角的输出位置的x坐标。
        Default value:
        0.0
        另请参见：
        getLrx() ， setLrx(double)

      • lry

        public final DoubleProperty lryProperty
        映射源的右下角的输出位置的y坐标。
        Default value:
        0.0
        另请参见：
        getLry() ， setLry(double)

      • llx

        public final DoubleProperty llxProperty
        源的左下角映射到的输出位置的x坐标。
        Default value:
        0.0
        另请参见：
        getLlx() ， setLlx(double)

      • lly

        public final DoubleProperty llyProperty
        源的左下角映射到的输出位置的y坐标。
        Default value:
        0.0
        另请参见：
        getLly() ， setLly(double)

    • 构造方法详细信息

      • PerspectiveTransform

        public PerspectiveTransform​()
        使用默认参数创建PerspectiveTransform的新实例。

      • PerspectiveTransform

        public PerspectiveTransform​(double ulx,
                            double uly,
                            double urx,
                            double ury,
                            double lrx,
                            double lry,
                            double llx,
                            double lly)
        用指定的ulx，uly，urx，ury，lrx，lry，llx和lly创建一个PerspectiveTransform的新实例。
        参数
        ulx - 左上角的x坐标
        uly - 左上角的y坐标
        urx - 右上角的x坐标
        ury - 右上角的y坐标
        lrx - 右下角的x坐标
        lry - 右下角的y坐标
        llx - 左下角的x坐标
        lly - 左下角的y坐标
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        该输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则连接Effect的Node的图形图像将用作输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        这个输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像用作输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setUlx

        public final void setUlx​(double value)
        设置属性ulx的值。
        Property description:
        源的左上角映射到的输出位置的x坐标。
        Default value:
        0.0

      • getUlx

        public final double getUlx​()
        获取属性ulx的值。
        Property description:
        源的左上角映射到的输出位置的x坐标。
        Default value:
        0.0

      • ulxProperty

        public final DoubleProperty ulxProperty​()
        源的左上角映射到的输出位置的x坐标。
        Default value:
        0.0
        另请参见：
        getUlx() ， setUlx(double)

      • setUly

        public final void setUly​(double value)
        设置属性uly的值。
        Property description:
        源的左上角映射到的输出位置的y坐标。
        Default value:
        0.0

      • getUly

        public final double getUly​()
        获取属性的值。
        Property description:
        源的左上角映射到的输出位置的y坐标。
        Default value:
        0.0

      • ulyProperty

        public final DoubleProperty ulyProperty​()
        源的左上角映射到的输出位置的y坐标。
        Default value:
        0.0
        另请参见：
        getUly() ， setUly(double)

      • setUrx

        public final void setUrx​(double value)
        设置属性urx的值。
        Property description:
        源映射到其右上角的输出位置的x坐标。
        Default value:
        0.0

      • getUrx

        public final double getUrx​()
        获取属性urx的值。
        Property description:
        源映射到其右上角的输出位置的x坐标。
        Default value:
        0.0

      • urxProperty

        public final DoubleProperty urxProperty​()
        源映射到其右上角的输出位置的x坐标。
        Default value:
        0.0
        另请参见：
        getUrx() ， setUrx(double)

      • setUry

        public final void setUry​(double value)
        设置属性的值。
        Property description:
        映射源的右上角的输出位置的y坐标。
        Default value:
        0.0

      • getUry

        public final double getUry​()
        获取财产的价值。
        Property description:
        映射源的右上角的输出位置的y坐标。
        Default value:
        0.0

      • uryProperty

        public final DoubleProperty uryProperty​()
        映射源的右上角的输出位置的y坐标。
        Default value:
        0.0
        另请参见：
        getUry() ， setUry(double)

      • setLrx

        public final void setLrx​(double value)
        设置属性lrx的值。
        Property description:
        源映射到其右下角的输出位置的x坐标。
        Default value:
        0.0

      • getLrx

        public final double getLrx​()
        获取属性lrx的值。
        Property description:
        源映射到其右下角的输出位置的x坐标。
        Default value:
        0.0

      • lrxProperty

        public final DoubleProperty lrxProperty​()
        源映射到其右下角的输出位置的x坐标。
        Default value:
        0.0
        另请参见：
        getLrx() ， setLrx(double)

      • setLry

        public final void setLry​(double value)
        设置属性lry的值。
        Property description:
        映射源的右下角的输出位置的y坐标。
        Default value:
        0.0

      • getLry

        public final double getLry​()
        获取属性lry的值。
        Property description:
        映射源的右下角的输出位置的y坐标。
        Default value:
        0.0

      • lryProperty

        public final DoubleProperty lryProperty​()
        映射源的右下角的输出位置的y坐标。
        Default value:
        0.0
        另请参见：
        getLry() ， setLry(double)

      • setLlx

        public final void setLlx​(double value)
        设置属性llx的值。
        Property description:
        源的左下角映射到的输出位置的x坐标。
        Default value:
        0.0

      • getLlx

        public final double getLlx​()
        获取属性llx的值。
        Property description:
        源的左下角映射到的输出位置的x坐标。
        Default value:
        0.0

      • llxProperty

        public final DoubleProperty llxProperty​()
        源的左下角映射到的输出位置的x坐标。
        Default value:
        0.0
        另请参见：
        getLlx() ， setLlx(double)

      • setLly

        public final void setLly​(double value)
        设置属性lly的值。
        Property description:
        源的左下角映射到的输出位置的y坐标。
        Default value:
        0.0

      • getLly

        public final double getLly​()
        获取属性lly的值。
        Property description:
        源的左下角映射到的输出位置的y坐标。
        Default value:
        0.0

      • llyProperty

        public final DoubleProperty llyProperty​()
        源的左下角映射到的输出位置的y坐标。
        Default value:
        0.0
        另请参见：
        getLly() ， setLly(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Reflection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Reflection

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.Reflection

  • public class Reflection
extends Effect
    将输入的反映版本呈现在实际输入内容之下的效果。

    请注意，安装Reflection效果的Node的反射将不会响应鼠标事件或Node上的遏制方法。

    例：

       Reflection reflection = new Reflection(); reflection.setFraction(0.7); Text text = new Text(); text.setX(10.0); text.setY(50.0); text.setCache(true); text.setText("Reflections on JavaFX..."); text.setFill(Color.web("0x3b596d")); text.setFont(Font.font(null, FontWeight.BOLD, 40)); text.setEffect(reflection);

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty bottomOpacity
      底部的不透明度值，它是底部极端反射的不透明度。
      DoubleProperty fraction
      在反射中可见的输入分数。
      ObjectProperty<Effect> input
      这个输入为 Effect 。
      DoubleProperty topOffset
      顶部偏移调整，即输入底部与反射顶部之间的距离。
      DoubleProperty topOpacity
      最高的不透明度值是反射在其顶端极端的不透明度。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Reflection​()
      使用默认参数创建一个新的Reflection实例。
      Reflection​(double topOffset, double fraction, double topOpacity, double bottomOpacity)
      使用指定的topOffset，fraction，topOpacity和bottomOpacity创建一个新的Reflection实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty bottomOpacityProperty​()
      底部的不透明度值，它是底部极端反射的不透明度。
      DoubleProperty fractionProperty​()
      在反射中可见的输入分数。
      double getBottomOpacity​()
      获取属性bottomOpacity的值。
      double getFraction​()
      获取属性分数的值。
      Effect getInput​()
      获取属性输入的值。
      double getTopOffset​()
      获取属性topOffset的值。
      double getTopOpacity​()
      获取属性topOpacity的值。
      ObjectProperty<Effect> inputProperty​()
      这个输入为 Effect 。
      void setBottomOpacity​(double value)
      设置属性bottomOpacity的值。
      void setFraction​(double value)
      设置属性分数的值。
      void setInput​(Effect value)
      设置属性输入的值。
      void setTopOffset​(double value)
      设置属性topOffset的值。
      void setTopOpacity​(double value)
      设置属性topOpacity的值。
      DoubleProperty topOffsetProperty​()
      顶部偏移调整，即输入底部与反射顶部之间的距离。
      DoubleProperty topOpacityProperty​()
      最高的不透明度值是反射在其顶端极端的不透明度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • topOffset

        public final DoubleProperty topOffsetProperty
        顶部偏移调整，即输入底部与反射顶部之间的距离。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getTopOffset() ， setTopOffset(double)

      • topOpacity

        public final DoubleProperty topOpacityProperty
        最高的不透明度值是反射在其顶端极端的不透明度。
          Min: 0.0
       Max: 1.0
   Default: 0.5
  Identity: 1.0
        Default value:
        0.5
        另请参见：
        getTopOpacity() ， setTopOpacity(double)

      • bottomOpacity

        public final DoubleProperty bottomOpacityProperty
        底部的不透明度值，它是底部极端反射的不透明度。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 1.0
        Default value:
        0.0
        另请参见：
        getBottomOpacity() ， setBottomOpacity(double)

      • fraction

        public final DoubleProperty fractionProperty
        在反射中可见的输入分数。 例如，值为0.5意味着只有输入的下半部分在反射中才可见。
          Min: 0.0
       Max: 1.0
   Default: 0.75
  Identity: 1.0
        Default value:
        0.75
        另请参见：
        getFraction() ， setFraction(double)

    • 构造方法详细信息

      • Reflection

        public Reflection​()
        使用默认参数创建一个新的Reflection实例。

      • Reflection

        public Reflection​(double topOffset,
                  double fraction,
                  double topOpacity,
                  double bottomOpacity)
        使用指定的topOffset，fraction，topOpacity和bottomOpacity创建一个新的Reflection实例。
        参数
        topOffset - 输入底部和反射顶部之间的距离
        fraction - 反射中可见的输入分数
        topOpacity - 反射在其顶端的不透明度
        bottomOpacity - 底部极端反射的不透明度
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        该输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        这个Effect的输入。 如果设置为null或未指定， Effect连接Effect的Node的图形图像用作输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setTopOffset

        public final void setTopOffset​(double value)
        设置属性topOffset的值。
        Property description:
        顶部偏移调整，即输入底部与反射顶部之间的距离。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • getTopOffset

        public final double getTopOffset​()
        获取属性topOffset的值。
        Property description:
        顶部偏移调整，即输入底部与反射顶部之间的距离。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0

      • topOffsetProperty

        public final DoubleProperty topOffsetProperty​()
        顶部偏移调整，即输入底部与反射顶部之间的距离。
          Min: n/a
       Max: n/a
   Default: 0.0
  Identity: 0.0
        Default value:
        0.0
        另请参见：
        getTopOffset() ， setTopOffset(double)

      • setTopOpacity

        public final void setTopOpacity​(double value)
        设置属性topOpacity的值。
        Property description:
        最高的不透明度值是反射在其顶端极端的不透明度。
          Min: 0.0
       Max: 1.0
   Default: 0.5
  Identity: 1.0
        Default value:
        0.5

      • getTopOpacity

        public final double getTopOpacity​()
        获取属性topOpacity的值。
        Property description:
        最高的不透明度值是反射在其顶端极端的不透明度。
          Min: 0.0
       Max: 1.0
   Default: 0.5
  Identity: 1.0
        Default value:
        0.5

      • topOpacityProperty

        public final DoubleProperty topOpacityProperty​()
        最高的不透明度值是反射在其顶端极端的不透明度。
          Min: 0.0
       Max: 1.0
   Default: 0.5
  Identity: 1.0
        Default value:
        0.5
        另请参见：
        getTopOpacity() ， setTopOpacity(double)

      • setBottomOpacity

        public final void setBottomOpacity​(double value)
        设置属性bottomOpacity的值。
        Property description:
        底部的不透明度值，它是底部极端反射的不透明度。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 1.0
        Default value:
        0.0

      • getBottomOpacity

        public final double getBottomOpacity​()
        获取属性bottomOpacity的值。
        Property description:
        底部的不透明度值，它是底部极端反射的不透明度。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 1.0
        Default value:
        0.0

      • bottomOpacityProperty

        public final DoubleProperty bottomOpacityProperty​()
        底部的不透明度值，它是底部极端反射的不透明度。
          Min: 0.0
       Max: 1.0
   Default: 0.0
  Identity: 1.0
        Default value:
        0.0
        另请参见：
        getBottomOpacity() ， setBottomOpacity(double)

      • setFraction

        public final void setFraction​(double value)
        设置属性分数的值。
        Property description:
        在反射中可见的输入分数。 例如，值为0.5意味着只有输入的下半部分在反射中才可见。
          Min: 0.0
       Max: 1.0
   Default: 0.75
  Identity: 1.0
        Default value:
        0.75

      • getFraction

        public final double getFraction​()
        获取属性分数的值。
        Property description:
        在反射中可见的输入分数。 例如，值为0.5意味着只有输入的下半部分在反射中才可见。
          Min: 0.0
       Max: 1.0
   Default: 0.75
  Identity: 1.0
        Default value:
        0.75

      • fractionProperty

        public final DoubleProperty fractionProperty​()
        在反射中可见的输入分数。 例如，值为0.5意味着只有输入的下半部分在反射中才可见。
          Min: 0.0
       Max: 1.0
   Default: 0.75
  Identity: 1.0
        Default value:
        0.75
        另请参见：
        getFraction(), setFraction(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SepiaTone (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class SepiaTone

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.SepiaTone

  • public class SepiaTone
extends Effect
    一个过滤器，产生棕褐色调效果，类似于古董照片。

    例：

       SepiaTone sepiaTone = new SepiaTone(); sepiaTone.setLevel(0.7); Image image = new Image("boat.jpg"); ImageView imageView = new ImageView(image); imageView.setFitWidth(200); imageView.setPreserveRatio(true); imageView.setEffect(sepiaTone);

    以上代码适用于此图像：

    产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Effect> input
      该输入为 Effect 。
      DoubleProperty level
      水平值，其控制棕褐色效果的强度。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SepiaTone​()
      使用默认参数创建一个新的SepiaTone实例。
      SepiaTone​(double level)
      以指定级别创建一个新的SepiaTone实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Effect getInput​()
      获取属性输入的值。
      double getLevel​()
      获取属性级别的值。
      ObjectProperty<Effect> inputProperty​()
      该输入为 Effect 。
      DoubleProperty levelProperty​()
      水平值，其控制棕褐色效果的强度。
      void setInput​(Effect value)
      设置属性输入的值。
      void setLevel​(double value)
      设置属性级别的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        该输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • level

        public final DoubleProperty levelProperty
        水平值，其控制棕褐色效果的强度。
          Min: 0.0f
       Max: 1.0f
   Default: 1.0f
  Identity: 0.0f
        Default value:
        1.0F
        另请参见：
        getLevel() ， setLevel(double)

    • 构造方法详细信息

      • SepiaTone

        public SepiaTone​()
        使用默认参数创建一个新的SepiaTone实例。

      • SepiaTone

        public SepiaTone​(double level)
        以指定级别创建一个新的SepiaTone实例。
        参数
        level - 级别值，用于控制效果的强度
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则连接Effect的Node的图形图像将用作输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        该输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像用作输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        该输入为Effect 。 如果设置为null或未指定， Effect连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setLevel

        public final void setLevel​(double value)
        设置属性级别的值。
        Property description:
        水平值，其控制棕褐色效果的强度。
          Min: 0.0f
       Max: 1.0f
   Default: 1.0f
  Identity: 0.0f
        Default value:
        1.0F

      • getLevel

        public final double getLevel​()
        获取属性级别的值。
        Property description:
        水平值，其控制棕褐色效果的强度。
          Min: 0.0f
       Max: 1.0f
   Default: 1.0f
  Identity: 0.0f
        Default value:
        1.0F

      • levelProperty

        public final DoubleProperty levelProperty​()
        水平值，其控制棕褐色效果的强度。
          Min: 0.0f
       Max: 1.0f
   Default: 1.0f
  Identity: 0.0f
        Default value:
        1.0F
        另请参见：
        getLevel() ， setLevel(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Shadow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.effect

Class Shadow

  • java.lang.Object
    • javafx.scene.effect.Effect
      • javafx.scene.effect.Shadow

  • public class Shadow
extends Effect
    产生具有模糊边缘的输入的单色副本的效果。 这种效果主要与其默认的黑色一起使用，以将其与原始图像组合以创建阴影。 它也可以与浅色一起使用，并与原件一起创造发光效果。 DropShadow效果是一种效用效果，它将这个Shadow效果与原始图形结合起来，以便于将阴影添加到现有的场景图Node ，具有单一效果。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<BlurType> blurType
      用于模糊阴影的算法。
      ObjectProperty<Color> color
      阴影 Color 。
      DoubleProperty height
      阴影模糊内核的垂直尺寸。
      ObjectProperty<Effect> input
      这个输入为 Effect 。
      DoubleProperty radius
      阴影模糊内核的半径。
      DoubleProperty width
      阴影模糊内核的水平尺寸。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Shadow​()
      使用默认参数创建一个新的Shadow实例。
      Shadow​(double radius, Color color)
      用指定的半径和颜色创建一个新的Shadow实例。
      Shadow​(BlurType blurType, Color color, double radius)
      用指定的blurType，color，radius创建一个新的Shadow实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<BlurType> blurTypeProperty​()
      用于模糊阴影的算法。
      ObjectProperty<Color> colorProperty​()
      阴影 Color 。
      BlurType getBlurType​()
      获取属性blurType的值。
      Color getColor​()
      获取属性颜色的值。
      double getHeight​()
      获取属性高度的值。
      Effect getInput​()
      获取属性输入的值。
      double getRadius​()
      获取属性半径的值。
      double getWidth​()
      获取属性宽度的值。
      DoubleProperty heightProperty​()
      阴影模糊内核的垂直尺寸。
      ObjectProperty<Effect> inputProperty​()
      这个输入为 Effect 。
      DoubleProperty radiusProperty​()
      阴影模糊内核的半径。
      void setBlurType​(BlurType value)
      设置属性blurType的值。
      void setColor​(Color value)
      设置属性颜色的值。
      void setHeight​(double value)
      设置属性高度的值。
      void setInput​(Effect value)
      设置属性输入的值。
      void setRadius​(double value)
      设置属性半径的值。
      void setWidth​(double value)
      设置属性宽度的值。
      DoubleProperty widthProperty​()
      阴影模糊内核的水平尺寸。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • input

        public final ObjectProperty<Effect> inputProperty
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • radius

        public final DoubleProperty radiusProperty
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径等同于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)

      • width

        public final DoubleProperty widthProperty
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final DoubleProperty heightProperty
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getHeight() ， setHeight(double)

      • blurType

        public final ObjectProperty<BlurType> blurTypeProperty
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX
        另请参见：
        getBlurType() ， setBlurType(BlurType)

      • color

        public final ObjectProperty<Color> colorProperty
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色
        另请参见：
        getColor() ， setColor(Color)

    • 构造方法详细信息

      • Shadow

        public Shadow​()
        使用默认参数创建一个新的Shadow实例。

      • Shadow

        public Shadow​(double radius,
              Color color)
        用指定的半径和颜色创建一个新的Shadow实例。
        参数
        radius - 影子模糊内核的半径
        color - 阴影 Color
        从以下版本开始：
        JavaFX 2.1

      • Shadow

        public Shadow​(BlurType blurType,
              Color color,
              double radius)
        用指定的blurType，color，radius创建一个新的Shadow实例。
        参数
        blurType - 用于模糊阴影的算法
        color - 阴影 Color
        radius - 影子模糊内核的半径
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setInput

        public final void setInput​(Effect value)
        设置属性输入的值。
        Property description:
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • getInput

        public final Effect getInput​()
        获取属性输入的值。
        Property description:
        该输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值

      • inputProperty

        public final ObjectProperty<Effect> inputProperty​()
        这个输入为Effect 。 如果设置为null或未指定，则将使用连接Effect的Node的图形图像作为输入。
        Default value:
        空值
        另请参见：
        getInput() ， setInput(Effect)

      • setRadius

        public final void setRadius​(double value)
        设置属性半径的值。
        Property description:
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径相当于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0

      • getRadius

        public final double getRadius​()
        获取属性半径的值。
        Property description:
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径相当于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0

      • radiusProperty

        public final DoubleProperty radiusProperty​()
        阴影模糊内核的半径。 该属性控制阴影扩散到源像素的每一侧的距离。 设置半径相当于将width和height属性设置为值(2 * radius + 1) 。
          Min:   0.0
       Max: 127.0
   Default:  10.0
  Identity:   0.0
        Default value:
        10.0
        另请参见：
        getRadius() ， setRadius(double)

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊影响。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • widthProperty

        public final DoubleProperty widthProperty​()
        阴影模糊内核的水平尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的水平尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0

      • heightProperty

        public final DoubleProperty heightProperty​()
        阴影模糊内核的垂直尺寸。 该属性控制通过模糊算法分布单个像素的阴影的总区域的垂直尺寸。 小于1.0值不会分布在原始像素之外，因此对阴影没有模糊效果。
          Min:   0.0
       Max: 255.0
   Default:  21.0
  Identity:  <1.0
        Default value:
        21.0
        另请参见：
        getHeight() ， setHeight(double)

      • setBlurType

        public final void setBlurType​(BlurType value)
        设置属性blurType的值。
        Property description:
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX

      • getBlurType

        public final BlurType getBlurType​()
        获取属性blurType的值。
        Property description:
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX

      • blurTypeProperty

        public final ObjectProperty<BlurType> blurTypeProperty​()
        用于模糊阴影的算法。
          Min: n/a
       Max: n/a
   Default: BlurType.THREE_PASS_BOX
  Identity: n/a
        Default value:
        THREE_PASS_BOX
        另请参见：
        getBlurType() ， setBlurType(BlurType)

      • setColor

        public final void setColor​(Color value)
        设置属性颜色的值。
        Property description:
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色

      • getColor

        public final Color getColor​()
        获取属性颜色的值。
        Property description:
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色

      • colorProperty

        public final ObjectProperty<Color> colorProperty​()
        阴影Color 。
          Min: n/a
       Max: n/a
   Default: Color.BLACK
  Identity: n/a
        Default value:
        黑色
        另请参见：
        getColor() ， setColor(Color)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.effect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.effect

  • Packages that use javafx.scene.effect
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
  • Classes in javafx.scene.effect used by javafx.css
    Class 描述
    Effect
    所有效果实现的抽象基类。
  • Classes in javafx.scene.effect used by javafx.css.converter
    Class 描述
    Effect
    所有效果实现的抽象基类。
  • Classes in javafx.scene.effect used by javafx.scene
    Class 描述
    BlendMode
    混合模式定义混合效果的输入合成在一起的方式，或者如何将节点混合到场景的背景中。
    Effect
    所有效果实现的抽象基类。
  • Classes in javafx.scene.effect used by javafx.scene.canvas
    Class 描述
    BlendMode
    混合模式定义混合效果的输入合成在一起的方式，或者如何将节点混合到场景的背景中。
    Effect
    所有效果实现的抽象基类。
  • Classes in javafx.scene.effect used by javafx.scene.effect
    Class 描述
    BlendMode
    混合模式定义混合效果的输入合成在一起的方式，或者如何将节点混合到场景的背景中。
    BlurType
    表示用于软化 Shadow效果的模糊算法的类型。
    Effect
    所有效果实现的抽象基类。
    FloatMap
    包含浮点数据的缓冲区，用作DisplacementMap等效果参数。
    Light
    所有轻型实现的抽象基类。
    Light.Point
    表示3D空间中给定位置的光源。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Blend (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Blend

No usage of javafx.scene.effect.Blend
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.BlendMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.BlendMode

  • Packages that use BlendMode
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。

    • Uses of BlendMode in javafx.scene

      Methods in javafx.scene that return BlendMode
      Modifier and Type 方法 描述
      BlendMode Node.getBlendMode​()
      获取属性blendMode的值。
      Methods in javafx.scene that return types with arguments of type BlendMode
      Modifier and Type 方法 描述
      ObjectProperty<BlendMode> Node.blendModeProperty​()
      BlendMode用于将此单个节点混合到其后面的场景中。
      Methods in javafx.scene with parameters of type BlendMode
      Modifier and Type 方法 描述
      void Node.setBlendMode​(BlendMode value)
      设置blendMode属性的值。

    • Uses of BlendMode in javafx.scene.canvas

      Methods in javafx.scene.canvas that return BlendMode
      Modifier and Type 方法 描述
      BlendMode GraphicsContext.getGlobalBlendMode​()
      获取全局混合模式。
      Methods in javafx.scene.canvas with parameters of type BlendMode
      Modifier and Type 方法 描述
      void GraphicsContext.setGlobalBlendMode​(BlendMode op)
      设置全局混合模式。

    • Uses of BlendMode in javafx.scene.effect

      Methods in javafx.scene.effect that return BlendMode
      Modifier and Type 方法 描述
      BlendMode Blend.getMode​()
      获取属性模式的值。
      static BlendMode BlendMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static BlendMode[] BlendMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.effect that return types with arguments of type BlendMode
      Modifier and Type 方法 描述
      ObjectProperty<BlendMode> Blend.modeProperty​()
      BlendMode用于将两个输入混合在一起。
      Methods in javafx.scene.effect with parameters of type BlendMode
      Modifier and Type 方法 描述
      void Blend.setMode​(BlendMode value)
      设置属性模式的值。
      Constructors in javafx.scene.effect with parameters of type BlendMode
      Constructor 描述
      Blend​(BlendMode mode)
      使用指定的模式创建Blend的新实例。
      Blend​(BlendMode mode, Effect bottomInput, Effect topInput)
      使用指定的模式和底部和顶部输入创建Blend的新实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Bloom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Bloom

No usage of javafx.scene.effect.Bloom
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.BlurType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.BlurType

  • Packages that use BlurType
    软件包 描述
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。

    • Uses of BlurType in javafx.scene.effect

      Methods in javafx.scene.effect that return BlurType
      Modifier and Type 方法 描述
      BlurType DropShadow.getBlurType​()
      获取属性blurType的值。
      BlurType InnerShadow.getBlurType​()
      获取属性blurType的值。
      BlurType Shadow.getBlurType​()
      获取属性blurType的值。
      static BlurType BlurType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static BlurType[] BlurType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.effect that return types with arguments of type BlurType
      Modifier and Type 方法 描述
      ObjectProperty<BlurType> DropShadow.blurTypeProperty​()
      用于模糊阴影的算法。
      ObjectProperty<BlurType> InnerShadow.blurTypeProperty​()
      用于模糊阴影的算法。
      ObjectProperty<BlurType> Shadow.blurTypeProperty​()
      用于模糊阴影的算法。
      Methods in javafx.scene.effect with parameters of type BlurType
      Modifier and Type 方法 描述
      void DropShadow.setBlurType​(BlurType value)
      设置属性blurType的值。
      void InnerShadow.setBlurType​(BlurType value)
      设置属性blurType的值。
      void Shadow.setBlurType​(BlurType value)
      设置属性blurType的值。
      Constructors in javafx.scene.effect with parameters of type BlurType
      Constructor 描述
      DropShadow​(BlurType blurType, Color color, double radius, double spread, double offsetX, double offsetY)
      使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的DropShadow实例。
      InnerShadow​(BlurType blurType, Color color, double radius, double choke, double offsetX, double offsetY)
      使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的InnerShadow实例。
      Shadow​(BlurType blurType, Color color, double radius)
      用指定的blurType，color，radius创建一个新的Shadow实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.BoxBlur (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.BoxBlur

No usage of javafx.scene.effect.BoxBlur
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.ColorAdjust (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.ColorAdjust

No usage of javafx.scene.effect.ColorAdjust
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.ColorInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.ColorInput

No usage of javafx.scene.effect.ColorInput
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.DisplacementMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.DisplacementMap

No usage of javafx.scene.effect.DisplacementMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.DropShadow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.DropShadow

No usage of javafx.scene.effect.DropShadow
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Effect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Effect

  • Packages that use Effect
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。

    • Uses of Effect in javafx.css

      Methods in javafx.css with type parameters of type Effect
      Modifier and Type 方法 描述
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，Effect>，初始值为null，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，Effect>，并将标志默认为false。
      <E extends Effect>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Effect>并继承标志。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function)
      创建一个StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue)
      创建一个具有初始值的StyleableProperty <Effect>。
      <E extends Effect>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Effect>并继承标志。
      Methods in javafx.css that return types with arguments of type Effect
      Modifier and Type 方法 描述
      StyleableProperty<Effect> StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty)
      创建一个StyleableProperty <Effect>使用之前创建的CssMetaData给定的 cssProperty 。
      static StyleConverter<ParsedValue[],Effect> StyleConverter.getEffectConverter​()
      返回一个 StyleConverter ，一个解析后的表示转换 Effect至 Effect

    • Uses of Effect in javafx.css.converter

      Methods in javafx.css.converter that return Effect
      Modifier and Type | 方法 | 描述
      Effect | EffectConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      Effect | EffectConverter.DropShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      Effect | EffectConverter.InnerShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      Methods in javafx.css.converter that return types with arguments of type Effect
      Modifier and Type | 方法 | 描述
      static StyleConverter<ParsedValue[],Effect> | EffectConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Effect
      Modifier and Type | 方法 | 描述
      Effect | EffectConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      Effect | EffectConverter.DropShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      Effect | EffectConverter.InnerShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)

    • Uses of Effect in javafx.scene

      Methods in javafx.scene that return Effect
      Modifier and Type 方法 描述
      Effect Node.getEffect​()
      获取属性效果的值。
      Methods in javafx.scene that return types with arguments of type Effect
      Modifier and Type 方法 描述
      ObjectProperty<Effect> Node.effectProperty​()
      指定应用于此 Node的效果。
      Methods in javafx.scene with parameters of type Effect
      Modifier and Type 方法 描述
      void Node.setEffect​(Effect value)
      设置属性效果的值。

    • Uses of Effect in javafx.scene.canvas

      Methods in javafx.scene.canvas that return Effect
      Modifier and Type 方法 描述
      Effect GraphicsContext.getEffect​(Effect e)
      获取下一次绘图调用后应用的效果的副本。
      Methods in javafx.scene.canvas with parameters of type Effect
      Modifier and Type 方法 描述
      void GraphicsContext.applyEffect​(Effect e)
      将给定的效果应用于画布的整个边界，并将结果存储回同一个画布。
      Effect GraphicsContext.getEffect​(Effect e)
      获取下一次绘图调用后应用的效果的副本。
      void GraphicsContext.setEffect​(Effect e)
      设置在下一次绘图调用后应用的效果，或设置为禁用效果的效果。

    • Uses of Effect in javafx.scene.effect

      Subclasses of Effect in javafx.scene.effect
      Modifier and Type Class 描述
      class  Blend
      使用预定义的BlendMode之一将两个输入组合在一起的效果。
      class  Bloom
      基于可配置的阈值，使得输入图像的较亮部分看起来发亮的高级效果。
      class  BoxBlur
      使用简单的盒式过滤器内核的模糊效果，在两个维度上都有单独配置的大小，以及控制所产生的模糊质量的迭代参数。
      class  ColorAdjust
      允许每个像素调整色调，饱和度，亮度和对比度的效果。
      class  ColorInput
      使用给定的 Paint填充（“淹没”）的矩形区域的效果。
      class  DisplacementMap
      将每个像素移动由指定的FloatMap的前两个频带指定的距离的效果 。
      class  DropShadow
      使用指定的颜色，半径和偏移量将给定内容的阴影呈现在内容后面的高级效果。
      class  GaussianBlur
      使用高斯卷积核的模糊效果，具有可配置的半径。
      class  Glow
      基于可配置的阈值，使输入图像看起来发亮的高级效果。
      class  ImageInput
      一种源代码效果，简单地将给定的 Image通过，未经修改，作为输入到另一个 Effect 。
      class  InnerShadow
      使用指定的颜色，半径和偏移量在给定内容的边缘内部呈现阴影的高级效果。
      class  Lighting
      模拟照亮给定内容的光源的效果，可用于给平坦物体更逼真的三维外观。
      class  MotionBlur
      使用高斯卷积核的运动模糊效果，具有可配置的半径和角度。
      class  PerspectiveTransform
      提供输入内容的非仿射变换的效果。
      class  Reflection
      将输入的反映版本呈现在实际输入内容之下的效果。
      class  SepiaTone
      一个过滤器，产生棕褐色调效果，类似于古董照片。
      class  Shadow
      产生具有模糊边缘的输入的单色副本的效果。
      Methods in javafx.scene.effect that return Effect
      Modifier and Type 方法 描述
      Effect Blend.getBottomInput​()
      获取属性bottomInput的值。
      Effect Lighting.getBumpInput​()
      获取属性bumpInput的值。
      Effect Lighting.getContentInput​()
      获取属性contentInput的值。
      Effect Bloom.getInput​()
      获取属性输入的值。
      Effect BoxBlur.getInput​()
      获取属性输入的值。
      Effect ColorAdjust.getInput​()
      获取属性输入的值。
      Effect DisplacementMap.getInput​()
      获取属性输入的值。
      Effect DropShadow.getInput​()
      获取属性输入的值。
      Effect GaussianBlur.getInput​()
      获取属性输入的值。
      Effect Glow.getInput​()
      获取属性输入的值。
      Effect InnerShadow.getInput​()
      获取属性输入的值。
      Effect MotionBlur.getInput​()
      获取属性输入的值。
      Effect PerspectiveTransform.getInput​()
      获取属性输入的值。
      Effect Reflection.getInput​()
      获取属性输入的值。
      Effect SepiaTone.getInput​()
      获取属性输入的值。
      Effect Shadow.getInput​()
      获取属性输入的值。
      Effect Blend.getTopInput​()
      获取属性topInput的值。
      Methods in javafx.scene.effect that return types with arguments of type Effect
      Modifier and Type 方法 描述
      ObjectProperty<Effect> Blend.bottomInputProperty​()
      这个 Blend操作的底部输入。
      ObjectProperty<Effect> Lighting.bumpInputProperty​()
      可选的凹凸贴图输入。
      ObjectProperty<Effect> Lighting.contentInputProperty​()
      内容输入为 Effect 。
      ObjectProperty<Effect> Bloom.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> BoxBlur.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> ColorAdjust.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> DisplacementMap.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> DropShadow.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> GaussianBlur.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> Glow.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> InnerShadow.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> MotionBlur.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> PerspectiveTransform.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> Reflection.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> SepiaTone.inputProperty​()
      这个输入为 Effect 。
      ObjectProperty<Effect> Shadow.inputProperty​()
      该输入为 Effect 。
      ObjectProperty<Effect> Blend.topInputProperty​()
      这个 Blend操作的顶部输入。
      Methods in javafx.scene.effect with parameters of type Effect
      Modifier and Type 方法 描述
      void Blend.setBottomInput​(Effect value)
      设置属性bottomInput的值。
      void Lighting.setBumpInput​(Effect value)
      设置属性bumpInput的值。
      void Lighting.setContentInput​(Effect value)
      设置属性contentInput的值。
      void Bloom.setInput​(Effect value)
      设置属性输入的值。
      void BoxBlur.setInput​(Effect value)
      设置属性输入的值。
      void ColorAdjust.setInput​(Effect value)
      设置属性输入的值。
      void DisplacementMap.setInput​(Effect value)
      设置属性输入的值。
      void DropShadow.setInput​(Effect value)
      设置属性输入的值。
      void GaussianBlur.setInput​(Effect value)
      设置属性输入的值。
      void Glow.setInput​(Effect value)
      设置属性输入的值。
      void InnerShadow.setInput​(Effect value)
      设置属性输入的值。
      void MotionBlur.setInput​(Effect value)
      设置属性输入的值。
      void PerspectiveTransform.setInput​(Effect value)
      设置属性输入的值。
      void Reflection.setInput​(Effect value)
      设置属性输入的值。
      void SepiaTone.setInput​(Effect value)
      设置属性输入的值。
      void Shadow.setInput​(Effect value)
      设置属性输入的值。
      void Blend.setTopInput​(Effect value)
      设置属性topInput的值。
      Constructors in javafx.scene.effect with parameters of type Effect
      Constructor 描述
      Blend​(BlendMode mode, Effect bottomInput, Effect topInput)
      使用指定的模式和底部和顶部输入创建Blend的新实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.FloatMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.FloatMap

  • Packages that use FloatMap
    软件包 描述
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。

    • Uses of FloatMap in javafx.scene.effect

      Methods in javafx.scene.effect that return FloatMap
      Modifier and Type 方法 描述
      FloatMap DisplacementMap.getMapData​()
      获取属性mapData的值。
      Methods in javafx.scene.effect that return types with arguments of type FloatMap
      Modifier and Type 方法 描述
      ObjectProperty<FloatMap> DisplacementMap.mapDataProperty​()
      这个 Effect的地图数据。
      Methods in javafx.scene.effect with parameters of type FloatMap
      Modifier and Type 方法 描述
      void DisplacementMap.setMapData​(FloatMap value)
      设置属性mapData的值。
      Constructors in javafx.scene.effect with parameters of type FloatMap
      Constructor 描述
      DisplacementMap​(FloatMap mapData)
      使用指定的mapData创建DisplacementMap的新实例。
      DisplacementMap​(FloatMap mapData, double offsetX, double offsetY, double scaleX, double scaleY)
      使用指定的mapData，offsetX，offsetY，scaleX和scaleY创建一个新的DisplacementMap实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.GaussianBlur (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.GaussianBlur

No usage of javafx.scene.effect.GaussianBlur
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Glow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Glow

No usage of javafx.scene.effect.Glow
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.ImageInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.ImageInput

No usage of javafx.scene.effect.ImageInput
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.InnerShadow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.InnerShadow

No usage of javafx.scene.effect.InnerShadow
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Light (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Light

  • Packages that use Light
    软件包 描述
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。

    • Uses of Light in javafx.scene.effect

      Subclasses of Light in javafx.scene.effect
      Modifier and Type Class 描述
      static class  Light.Distant
      代表遥远的光源。
      static class  Light.Point
      表示3D空间中给定位置的光源。
      static class  Light.Spot
      在3D空间中的给定位置表示点光源，具有可配置的方向和焦点。
      Methods in javafx.scene.effect that return Light
      Modifier and Type 方法 描述
      Light Lighting.getLight​()
      获取属性灯的值。
      Methods in javafx.scene.effect that return types with arguments of type Light
      Modifier and Type 方法 描述
      ObjectProperty<Light> Lighting.lightProperty​()
      这个光源为这 Lighting效果。
      Methods in javafx.scene.effect with parameters of type Light
      Modifier and Type 方法 描述
      void Lighting.setLight​(Light value)
      设置属性灯的值。
      Constructors in javafx.scene.effect with parameters of type Light
      Constructor 描述
      Lighting​(Light light)
      用指定的光线创建一个新的照明实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Light.Distant (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Light.Distant

No usage of javafx.scene.effect.Light.Distant
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Light.Point (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Light.Point

  • Packages that use Light.Point
    软件包 描述
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。

    • Uses of Light.Point in javafx.scene.effect

      Subclasses of Light.Point in javafx.scene.effect
      Modifier and Type Class 描述
      static class  Light.Spot
      在3D空间中的给定位置表示点光源，具有可配置的方向和焦点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Light.Spot (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Light.Spot

No usage of javafx.scene.effect.Light.Spot
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Lighting (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Lighting

No usage of javafx.scene.effect.Lighting
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.MotionBlur (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.MotionBlur

No usage of javafx.scene.effect.MotionBlur
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.PerspectiveTransform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.PerspectiveTransform

No usage of javafx.scene.effect.PerspectiveTransform
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Reflection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Reflection

No usage of javafx.scene.effect.Reflection
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.SepiaTone (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.SepiaTone

No usage of javafx.scene.effect.SepiaTone
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.effect.Shadow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.effect.Shadow

No usage of javafx.scene.effect.Shadow
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Image (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.image

Class Image

  • java.lang.Object
    • javafx.scene.image.Image
  • 已知直接子类：
    WritableImage

    public class Image
extends Object
    Image类表示图形图像，用于从指定的URL加载图像。

    支持的图像格式有：

    • BMP
    • GIF
    • JPEG
    • PNG

    图像可以在加载时调整大小（例如减少图像消耗的内存量）。 应用程序可以指定缩放时使用的过滤质量，以及是否保留原始图像的宽高比。

    URL支持的所有URL都可以传递给构造函数。 如果传递的字符串不是有效的URL，而是路径，那么在这种情况下，在类路径上搜索映像。

    使用ImageView显示加载此类的图像。 相同的Image实例可以由多个ImageView s显示。

    加载图像的示例代码。

      import javafx.scene.image.Image;

// load an image in background, displaying a placeholder while it's loading
// (assuming there's an ImageView node somewhere displaying this image)
// The image is located in default package of the classpath
Image image1 = new Image("/flower.png", true);

// load an image and resize it to 100x150 without preserving its original
// aspect ratio
// The image is located in my.res package of the classpath
Image image2 = new Image("my/res/flower.png", 100, 150, false, false);

// load an image and resize it to width of 100 while preserving its
// original aspect ratio, using faster filtering method
// The image is downloaded from the supplied URL through http protocol
Image image3 = new Image("http://sample.com/res/flower.png", 100, 0, false, false);

// load an image and resize it only in one dimension, to the height of 100 and
// the original width, without preserving original aspect ratio
// The image is located in the current working directory
Image image4 = new Image("file:flower.png", 0, 100, false, false);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty error
      指示在加载图像时是否检测到错误。
      ReadOnlyObjectProperty<异常> exception
      导致图像加载失败的异常。
      ReadOnlyDoubleProperty height
      图像高度或 0如果图像加载失败。
      ReadOnlyDoubleProperty progress
      已完成图像加载的大致百分比。
      ReadOnlyDoubleProperty width
      图像宽度或 0如果图像加载失败。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Image​(InputStream is)
      构造一个 Image并从指定的输入流中加载内容。
      Image​(InputStream is, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构建新的 Image 。
      Image​(String url)
      构造一个 Image其中包含从指定的url加载的内容。
      Image​(String url, boolean backgroundLoading)
      使用指定的参数构建新的 Image 。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      构造新的 Image与指定的参数。
      Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth, boolean backgroundLoading)
      使用指定的参数构建新的 Image 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void cancel​()
      取消此图像的后台加载。
      ReadOnlyBooleanProperty errorProperty​()
      指示在加载图像时是否检测到错误。
      ReadOnlyObjectProperty<异常> exceptionProperty​()
      导致图像加载失败的异常。
      异常 getException​()
      获取属性异常的值。
      double getHeight​()
      获取属性高度的值。
      PixelReader getPixelReader​()
      该方法返回一个 PixelReader ，如果图像可读，则可以访问该图像的像素。
      double getProgress​()
      获取属性进度的值。
      double getRequestedHeight​()
      获取必要时调整大小的源图像的边界框的高度。
      double getRequestedWidth​()
      获取必要时调整大小的源图像的边界框的宽度。
      String getUrl​()
      返回用于获取Image实例中包含的像素数据的URL，如果在构造函数中指定。
      double getWidth​()
      获取属性宽度的值。
      ReadOnlyDoubleProperty heightProperty​()
      图像高度或 0如果图像加载失败。
      boolean isBackgroundLoading​()
      指示图像是否在后台加载。
      boolean isError​()
      获取属性错误的值。
      boolean isPreserveRatio​()
      指示当缩放以适应 width和 height提供的边界框内的图像时是否保留原始图像的 height 。
      boolean isSmooth​()
      指示当缩放此图像以适应 width和 height提供的边框内时是否使用更好的质量过滤算法或更快的过滤算法。
      ReadOnlyDoubleProperty progressProperty​()
      已完成图像加载的大致百分比。
      ReadOnlyDoubleProperty widthProperty​()
      图像宽度或 0如果图像加载失败。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • progress

        public final ReadOnlyDoubleProperty progressProperty
        已完成图像加载的大致百分比。 0和1之间的正值，其中0为0％，1为100％。
        Default value:
        0
        另请参见：
        getProgress()

      • width

        public final ReadOnlyDoubleProperty widthProperty
        图像宽度或0如果图像加载失败。 图像正在加载时，设置为0 。
        另请参见：
        getWidth()

      • height

        public final ReadOnlyDoubleProperty heightProperty
        图像高度或0如果图像加载失败。 图像正在加载时，设置为0 。
        另请参见：
        getHeight()

      • error

        public final ReadOnlyBooleanProperty errorProperty
        指示在加载图像时是否检测到错误。
        Default value:
        假
        另请参见：
        isError()

      • exception

        public final ReadOnlyObjectProperty<异常> exceptionProperty
        导致图像加载失败的异常。 仅当error属性设置为true才包含非空值。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getException()

    • 构造方法详细信息

      • Image

        public Image​(String url)
        构造一个 Image其中内容从指定的URL载入。
        参数
        url - 表示用于获取像素数据的URL的字符串
        异常
        NullPointerException - 如果URL为null
        IllegalArgumentException - 如果网址无效或不受支持

      • Image

        public Image​(String url,
             boolean backgroundLoading)
        使用指定的参数构建新的 Image 。
        参数
        url - 表示获取像素数据时使用的URL的字符串
        backgroundLoading - 指示图像是否在后台加载
        异常
        NullPointerException - 如果URL为空
        IllegalArgumentException - 如果网址无效或不受支持

      • Image

        public Image​(String url,
             double requestedWidth,
             double requestedHeight,
             boolean preserveRatio,
             boolean smooth)
        使用指定的参数构建新的 Image 。
        参数
        url - 表示用于获取像素数据的URL的字符串
        requestedWidth - 图像的边框宽度
        requestedHeight - 图像的边框高度
        preserveRatio - 指示当缩放以适应指定边界框内的图像时是否保留原始图像的宽高比
        smooth - 指示是否使用更好的质量过滤算法或更快的缩放此图像以适应指定的边界框
        异常
        NullPointerException - 如果URL为空
        IllegalArgumentException - 如果网址无效或不受支持

      • Image

        public Image​(String url,
             double requestedWidth,
             double requestedHeight,
             boolean preserveRatio,
             boolean smooth,
             boolean backgroundLoading)
        构造新的Image与指定的参数。 没有方案的url是相对于classpath来处理的，url的方案根据方案进行处理，使用URL.openStream()
        参数
        url - 表示用于获取像素数据的URL的字符串
        requestedWidth - 图像的边框宽度
        requestedHeight - 图像的边框高度
        preserveRatio - 表示当缩放以适应指定边框内的图像时是否保留原始图像的宽高比
        smooth - 指示是否使用更好的质量过滤算法或更快的缩放此图像以适应指定的边界框
        backgroundLoading - 指示图像是否在后台加载
        异常
        NullPointerException - 如果URL为null
        IllegalArgumentException - 如果网址无效或不受支持

      • Image

        public Image​(InputStream is)
        构造一个 Image并从指定的输入流中加载内容。
        参数
        is - 从中加载图像的流
        异常
        NullPointerException - 如果输入流为空

      • Image

        public Image​(InputStream is,
             double requestedWidth,
             double requestedHeight,
             boolean preserveRatio,
             boolean smooth)
        使用指定的参数构建新的 Image 。
        参数
        is - 加载图像的流
        requestedWidth - 图像的边框宽度
        requestedHeight - 图像的边框高度
        preserveRatio - 表示当缩放以适应指定边框内的图像时是否保留原始图像的宽高比
        smooth - 指示当缩放此图像以适应指定的边界框内时是否使用更好的质量过滤算法或更快的过滤算法
        异常
        NullPointerException - 如果输入流为空

    • 方法详细信息

      • getUrl

        public final String getUrl​()
        返回用于获取Image实例中包含的像素数据的URL，如果在构造函数中指定。 如果构造函数中没有提供url（例如，如果图像是由InputStream构造的），则此方法将返回null。
        结果
        一个包含用于获取此Image实例的像素数据的URL的字符串。
        从以下版本开始：
        9

      • getProgress

        public final double getProgress​()
        获取属性进度的值。
        Property description:
        已完成图像加载的大致百分比。 0和1之间的正值，其中0为0％，1为100％。
        Default value:
        0

      • progressProperty

        public final ReadOnlyDoubleProperty progressProperty​()
        已完成图像加载的大致百分比。 0和1之间的正值，其中0为0％，1为100％。
        Default value:
        0
        另请参见：
        getProgress()

      • getRequestedWidth

        public final double getRequestedWidth​()
        获取必要时调整大小的源图像的边界框的宽度。 如果设置为值<= 0 ，则将使用图像的固有宽度。

        见preserveRatio对图像的互动信息requestedWidth ， requestedHeight和preserveRatio属性。

        结果
        请求的宽度

      • getRequestedHeight

        public final double getRequestedHeight​()
        获取必要时调整大小的源图像的边界框的高度。 如果设置为值<= 0 ，则将使用图像的固有高度。

        见preserveRatio对图像的互动信息requestedWidth ， requestedHeight和preserveRatio属性。

        结果
        请求的高度

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        图像宽度或0如果图像加载失败。 当图像正在加载时，它设置为0 。

      • widthProperty

        public final ReadOnlyDoubleProperty widthProperty​()
        图像宽度或0如果图像加载失败。 图像正在加载时，设置为0 。
        另请参见：
        getWidth()

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        图像高度或0如果图像加载失败。 当图像正在加载时，它设置为0 。

      • heightProperty

        public final ReadOnlyDoubleProperty heightProperty​()
        图像高度或0如果图像加载失败。 图像正在加载时，设置为0 。
        另请参见：
        getHeight()

      • isPreserveRatio

        public final boolean isPreserveRatio​()
        指示当缩放以适应width和height提供的边框内的图像时是否保留原始图像的height 。

        如果设置为true ， Image下列方式影响此Image的尺寸：

        • 如果仅设置了width ，则将高度缩放以保持比例
        • 如果仅设置height ，则将缩放宽度以保持比例
        • 如果两者都被设置，它们都可以被缩放以便在宽度乘以高度矩形的同时保持原始宽高比
        报告的width和height可能与初始设置值不同，如果需要调整以保持宽高比。 如果未设置或设置为false ，它将以以下方式影响此ImageView的尺寸：
        • 如果仅设置了width ，则图像的宽度将缩放匹配，高度不变;
        • 如果仅设置了height ，则图像的高度被缩放以匹配，高度不变;
        • 如果两者都设置，则图像被缩放以匹配两者。
        结果
        如果在缩放以适应由 width和 height提供的边界框内的图像时要保留原始图像的纵横比， width height 。

      • isSmooth

        public final boolean isSmooth​()
        指示是否使用更好的质量过滤算法或更快的过滤算法缩放此图像以适合width和height提供的边界框内。

        如果没有初始化或设置为true将使用更好的质量过滤，否则将使用更快更低质量的过滤。

        结果
        如果使用更好的质量（但较慢）的滤波算法进行缩放以适合由 width和 height提供的边界框内， width height 。

      • isBackgroundLoading

        public final boolean isBackgroundLoading​()
        指示图像是否在后台加载。
        结果
        如果图像在后台加载，则为true

      • isError

        public final boolean isError​()
        获取属性错误的值。
        Property description:
        指示在加载图像时是否检测到错误。
        Default value:
        假

      • errorProperty

        public final ReadOnlyBooleanProperty errorProperty​()
        指示在加载图像时是否检测到错误。
        Default value:
        假
        另请参见：
        isError()

      • getException

        public final 异常 getException​()
        获取属性异常的值。
        Property description:
        导致图像加载失败的异常。 仅当error属性设置为true才包含非空值。
        从以下版本开始：
        JavaFX 8.0

      • exceptionProperty

        public final ReadOnlyObjectProperty<异常> exceptionProperty​()
        导致图像加载失败的异常。 仅当error属性设置为true才包含非空值。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getException()

      • cancel

        public void cancel​()
        取消此图像的后台加载。

        如果此图像未在后台加载或加载已完成，则不起作用。

      • getPixelReader

        public final PixelReader getPixelReader​()
        该方法返回一个PixelReader ，如果图像可读，则可以访问该图像的像素。 如果此方法返回null，则此映像此时不支持读取。 如果图像从源加载并且仍然不完整，则该方法将返回null {进度仍然<1.0）或者是否存在错误。 此方法也可能以不支持读取和写入像素的格式为某些图像返回null。
        结果
        用于读取图像的像素数据的 PixelReader
        从以下版本开始：
        JavaFX 2.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.image

Class ImageView

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.image.ImageView
  • All Implemented Interfaces:
    Styleable ， EventTarget

    @DefaultProperty("image")
public class ImageView
extends Node
    ImageView是一个Node用于绘制加载Image类的图像。

    此类允许调整显示图像的大小（有或没有保留原始宽高比），并将源视频窗口指定为限制ImageView显示的像素的视口。

    显示图像的示例代码

       import javafx.application.Application; import javafx.geometry.Rectangle2D; import javafx.scene.Group; import javafx.scene.Scene; import javafx.scene.image.Image; import javafx.scene.image.ImageView; import javafx.scene.layout.HBox; import javafx.scene.paint.Color; import javafx.stage.Stage; public class HelloImageView extends Application { @Override public void start(Stage stage) { // load the image Image image = new Image("flower.png"); // simple displays ImageView the image as is ImageView iv1 = new ImageView(); iv1.setImage(image); // resizes the image to have width of 100 while preserving the ratio and using // higher quality filtering method; this ImageView is also cached to // improve performance ImageView iv2 = new ImageView(); iv2.setImage(image); iv2.setFitWidth(100); iv2.setPreserveRatio(true); iv2.setSmooth(true); iv2.setCache(true); // defines a viewport into the source image (achieving a "zoom" effect) and // displays it rotated ImageView iv3 = new ImageView(); iv3.setImage(image); Rectangle2D viewportRect = new Rectangle2D(40, 35, 110, 110); iv3.setViewport(viewportRect); iv3.setRotate(90); Group root = new Group(); Scene scene = new Scene(root); scene.setFill(Color.BLACK); HBox box = new HBox(); box.getChildren().add(iv1); box.getChildren().add(iv2); box.getChildren().add(iv3); root.getChildren().add(box); stage.setTitle("ImageView"); stage.setWidth(415); stage.setHeight(200); stage.setScene(scene); stage.sizeToScene(); stage.show(); } public static void main(String[] args) { Application.launch(args); } }

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty fitHeight
      根据需要调整大小的源图像的边界框的高度。
      DoubleProperty fitWidth
      根据需要调整源图像大小的边框的宽度。
      ObjectProperty<Image> image
      Image要画ImageView 。
      BooleanProperty preserveRatio
      指示当缩放以适应拟合边界框内的图像时是否保留源图像的宽高比。
      BooleanProperty smooth
      指示当转换或缩放源图像以适应 fitWidth和 fitHeight提供的边界框内时是否使用更好的质量过滤算法或更快的过滤算法。
      ObjectProperty<Rectangle2D> viewport
      矩形视口进入图像。
      DoubleProperty x
      当前的x坐标 ImageView起源。
      DoubleProperty y
      当前y坐标的 ImageView起源。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static boolean SMOOTH_DEFAULT
      平台相关的默认值为 smooth属性。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageView​()
      分配一个新的ImageView对象。
      ImageView​(String url)
      分配一个新的ImageView对象，并从指定的URL加载图像。
      ImageView​(Image image)
      使用给定的图像分配一个新的ImageView对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      DoubleProperty fitHeightProperty​()
      根据需要调整大小的源图像的边界框的高度。
      DoubleProperty fitWidthProperty​()
      根据需要调整源图像大小的边框的宽度。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      double getFitHeight​()
      获取属性fitHeight的值。
      double getFitWidth​()
      获取属性fitWidth的值。
      Image getImage​()
      获取属性映像的值。
      Rectangle2D getViewport​()
      获取属性视口的值。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      ObjectProperty<Image> imageProperty​()
      Image将由这ImageView画。
      boolean isPreserveRatio​()
      获取属性preserveRatio的值。
      boolean isSmooth​()
      获取属性的值平滑。
      BooleanProperty preserveRatioProperty​()
      指示当缩放以适应拟合边界框内的图像时是否保留源图像的宽高比。
      void setFitHeight​(double value)
      设置属性fitHeight的值。
      void setFitWidth​(double value)
      设置属性fitWidth的值。
      void setImage​(Image value)
      设置属性图像的值。
      void setPreserveRatio​(boolean value)
      设置属性preserveRatio的值。
      void setSmooth​(boolean value)
      设置属性的值平滑。
      void setViewport​(Rectangle2D value)
      设置属性视口的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      BooleanProperty smoothProperty​()
      指示当转换或缩放源图像以适应 fitWidth和 fitHeight提供的边界框内时是否使用更好的质量过滤算法或更快的过滤算法。
      ObjectProperty<Rectangle2D> viewportProperty​()
      矩形视口进入图像。
      DoubleProperty xProperty​()
      当前x坐标 ImageView起源。
      DoubleProperty yProperty​()
      目前的y坐标为 ImageView起源。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • image

        public final ObjectProperty<Image> imageProperty
        这个Image要画ImageView 。
        Default value:
        空值
        另请参见：
        getImage() ， setImage(Image)

      • x

        public final DoubleProperty xProperty
        当前的x坐标 ImageView起源。
        Default value:
        0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        当前y坐标的 ImageView起源。
        Default value:
        0
        另请参见：
        getY() ， setY(double)

      • fitWidth

        public final DoubleProperty fitWidthProperty
        根据需要调整源图像大小的边框的宽度。 如果设置为值<= 0，则图像的固有宽度将用作fitWidth 。

        见preserveRatio的图像视图的之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        Default value:
        0
        另请参见：
        getFitWidth() ， setFitWidth(double)

      • fitHeight

        public final DoubleProperty fitHeightProperty
        根据需要调整大小的源图像的边界框的高度。 如果设置为值<= 0，则图像的固有高度将用作fitHeight 。

        见preserveRatio的图像视图的之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        Default value:
        0
        另请参见：
        getFitHeight() ， setFitHeight(double)

      • preserveRatio

        public final BooleanProperty preserveRatioProperty
        指示当缩放以适应拟合边界框内的图像时是否保留源图像的宽高比。

        如果设置为true ， ImageView下列方式影响此ImageView的尺寸*

        • 如果只设置了fitWidth ，则高度被缩放以保持比例
        • 如果仅设置fitHeight ，则将缩放宽度以保持比例
        • 如果两者都被设置，它们都可以被缩放以便在宽度乘以高度矩形的同时保持原始宽高比
        如果未设置或设置为false ， ImageView以下方式影响此ImageView的尺寸*
        • 如果仅设置fitWidth ，图像的视图宽度将缩放匹配，高度不变;
        • 如果仅设置fitHeight ，则图像的视图高度被缩放以匹配，高度不变;
        • 如果两者都设置，则图像视图被缩放以匹配两者。
        请注意，由节点边界报告的节点的尺寸将等于缩放图像的大小，并保证包含在fitWidth x fitHeight绑定框中。
        Default value:
        假
        另请参见：
        isPreserveRatio() ， setPreserveRatio(boolean)

      • smooth

        public final BooleanProperty smoothProperty
        指示当转换或缩放源图像以适应fitWidth和fitHeight提供的边界框内时是否使用更好的质量过滤算法或更快的过滤算法。

        如果设置为true将使用更好的质量过滤，如果设置为false ，将使用较快的质量过滤。

        默认值取决于平台配置。

        Default value:
        平台依赖性
        另请参见：
        isSmooth() ， setSmooth(boolean)

      • viewport

        public final ObjectProperty<Rectangle2D> viewportProperty
        矩形视口进入图像。 在缩放或任何其他转换之前，视口在图像的坐标中指定。

        如果viewport为null ，则显示整个图像。 如果viewport为非null ，则仅显示落在视口内的图像部分。 如果图像未完全覆盖视口，则视口的任何剩余区域将为空。

        Default value:
        空值
        另请参见：
        getViewport() ， setViewport(Rectangle2D)

    • 字段详细信息

      • SMOOTH_DEFAULT

        public static final boolean SMOOTH_DEFAULT
        平台相关的默认值为 smooth属性。

    • 构造方法详细信息

      • ImageView

        public ImageView​()
        分配一个新的ImageView对象。

      • ImageView

        public ImageView​(String url)
        分配一个新的ImageView对象，并从指定的URL加载图像。

        该new ImageView(url)具有相同的效果new ImageView(new Image(url)) 。

        参数
        url - 表示加载图像的URL的字符串
        异常
        NullPointerException - 如果URL为null
        IllegalArgumentException - 如果网址无效或不受支持
        从以下版本开始：
        JavaFX 2.1

      • ImageView

        public ImageView​(Image image)
        使用给定的图像分配一个新的ImageView对象。
        参数
        image - ImageView使用的图像

    • 方法详细信息

      • setImage

        public final void setImage​(Image value)
        设置属性图像的值。
        Property description:
        Image要画ImageView 。
        Default value:
        空值

      • getImage

        public final Image getImage​()
        获取属性映像的值。
        Property description:
        Image将由这ImageView画。
        Default value:
        空值

      • imageProperty

        public final ObjectProperty<Image> imageProperty​()
        Image要画ImageView 。
        Default value:
        空值
        另请参见：
        getImage() ， setImage(Image)

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        当前的x坐标 ImageView起源。
        Default value:
        0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        当前的x坐标 ImageView起源。
        Default value:
        0

      • xProperty

        public final DoubleProperty xProperty​()
        当前的x坐标 ImageView起源。
        Default value:
        0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        目前的y坐标为 ImageView起源。
        Default value:
        0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        目前的y坐标为 ImageView起源。
        Default value:
        0

      • yProperty

        public final DoubleProperty yProperty​()
        目前的y坐标为 ImageView起源。
        Default value:
        0
        另请参见：
        getY() ， setY(double)

      • setFitWidth

        public final void setFitWidth​(double value)
        设置属性fitWidth的值。
        Property description:
        根据需要调整源图像大小的边框的宽度。 如果设置为值<= 0，则图像的固有宽度将用作fitWidth 。

        见preserveRatio的图像视图的之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        Default value:
        0

      • getFitWidth

        public final double getFitWidth​()
        获取属性fitWidth的值。
        Property description:
        根据需要调整源图像大小的边框的宽度。 如果设置为值<= 0，则图像的固有宽度将用作fitWidth 。

        见preserveRatio的图像视图的之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        Default value:
        0

      • fitWidthProperty

        public final DoubleProperty fitWidthProperty​()
        根据需要调整源图像大小的边框的宽度。 如果设置为值<= 0，则图像的固有宽度将用作fitWidth 。

        见preserveRatio的图像视图的之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        Default value:
        0
        另请参见：
        getFitWidth() ， setFitWidth(double)

      • setFitHeight

        public final void setFitHeight​(double value)
        设置属性fitHeight的值。
        Property description:
        根据需要调整大小的源图像的边界框的高度。 如果设置为<= 0，则图像的固有高度将用作fitHeight 。

        见preserveRatio的图像视图的之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        Default value:
        0

      • getFitHeight

        public final double getFitHeight​()
        获取属性fitHeight的值。
        Property description:
        根据需要调整大小的源图像的边界框的高度。 如果设置为值<= 0，则图像的固有高度将用作fitHeight 。

        见preserveRatio的图像视图的之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        Default value:
        0

      • fitHeightProperty

        public final DoubleProperty fitHeightProperty​()
        根据需要调整大小的源图像的边界框的高度。 如果设置为值<= 0，则图像的固有高度将用作fitHeight 。

        见preserveRatio的图像视图的之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        Default value:
        0
        另请参见：
        getFitHeight() ， setFitHeight(double)

      • setPreserveRatio

        public final void setPreserveRatio​(boolean value)
        设置属性preserveRatio的值。
        Property description:
        指示当缩放以适应拟合边界框内的图像时是否保留源图像的宽高比。

        如果设置为true ， ImageView下列方式影响此ImageView的尺寸*

        • 如果仅设置了fitWidth ，则将高度缩放以保持比例
        • 如果仅设置fitHeight ，则将缩放宽度以保持比例
        • 如果两者都被设置，它们都可以被缩放以便在宽度乘以高度矩形的同时保持原始宽高比
        如果未设置或设置为false ， ImageView以下方式影响此ImageView的尺寸*
        • 如果仅设置了fitWidth ，则图像的视图宽度将缩放匹配，高度不变;
        • 如果仅设置了fitHeight ，则图像的视图高度被缩放匹配，高度不变;
        • 如果两者都设置，则图像视图被缩放以匹配两者。
        请注意，由节点的边界报告的节点的尺寸将等于缩放图像的大小，并保证包含在fitWidth x fitHeight绑定框中。
        Default value:
        假

      • isPreserveRatio

        public final boolean isPreserveRatio​()
        获取属性preserveRatio的值。
        Property description:
        指示当缩放以适应拟合边界框内的图像时是否保留源图像的宽高比。

        如果设置为true ， ImageView以下方式影响此ImageView的尺寸*

        • 如果仅设置fitWidth ，则高度被缩放以保持比例
        • 如果仅设置fitHeight ，则将缩放宽度以保持比例
        • 如果两者都被设置，它们都可以被缩放以便在宽度乘以高度矩形的同时保持原始宽高比
        如果未设置或设置为false ， ImageView以下方式影响此ImageView的尺寸*
        • 如果仅设置fitWidth ，则图像的视图宽度缩放匹配，高度不变;
        • 如果仅设置fitHeight ，则图像的视图高度被缩放以匹配，高度不变;
        • 如果两者都设置，则图像视图被缩放以匹配两者。
        请注意，由节点边界报告的节点的尺寸将等于缩放图像的大小，并保证包含在fitWidth x fitHeight绑定框中。
        Default value:
        假

      • preserveRatioProperty

        public final BooleanProperty preserveRatioProperty​()
        指示当缩放以适应拟合边界框内的图像时是否保留源图像的宽高比。

        如果设置为true ， ImageView下列方式影响此ImageView的尺寸*

        • 如果仅设置了fitWidth ，则将高度缩放以保持比例
        • 如果仅设置fitHeight ，则将缩放宽度以保持比例
        • 如果两者都被设置，它们都可以被缩放以便在宽度乘以高度矩形的同时保持原始宽高比
        如果未设置或设置为false ， ImageView以下方式影响此ImageView的尺寸*
        • 如果仅设置fitWidth ，图像的视图宽度将缩放匹配，高度不变;
        • 如果仅设置fitHeight ，则图像的视图高度将缩放匹配，高度不变;
        • 如果两者都设置，则图像视图被缩放以匹配两者。
        请注意，由节点边界报告的节点的尺寸将等于缩放图像的大小，并保证包含在fitWidth x fitHeight绑定框中。
        Default value:
        假
        另请参见：
        isPreserveRatio() ， setPreserveRatio(boolean)

      • setSmooth

        public final void setSmooth​(boolean value)
        设置属性的值平滑。
        Property description:
        指示当转换或缩放源图像以适应fitWidth和fitHeight提供的边界框内时，是否使用更好的质量过滤算法或更快的过滤算法。

        如果设置为true将使用更好的质量过滤，如果设置为false ， false使用较快的质量过滤。

        默认值取决于平台配置。

        Default value:
        平台依赖性

      • isSmooth

        public final boolean isSmooth​()
        获取属性的值平滑。
        Property description:
        指示当转换或缩放源图像以适应fitWidth和fitHeight提供的边界框内时是否使用更好的质量过滤算法或更快的过滤算法。

        如果设置为true将使用更好的质量过滤，如果设置为false ，将使用较快的质量过滤。

        默认值取决于平台配置。

        Default value:
        平台依赖性

      • smoothProperty

        public final BooleanProperty smoothProperty​()
        指示当转换或缩放源图像以适应fitWidth和fitHeight提供的边界框内时，是否使用更好的质量过滤算法或更快的过滤算法。

        如果设置为true将使用更好的质量过滤，如果设置为false更快，但将使用较低质量的过滤。

        默认值取决于平台配置。

        Default value:
        平台依赖性
        另请参见：
        isSmooth() ， setSmooth(boolean)

      • setViewport

        public final void setViewport​(Rectangle2D value)
        设置属性视口的值。
        Property description:
        矩形视口进入图像。 在缩放或任何其他转换之前，视口在图像的坐标中指定。

        如果viewport为null ，则显示整个图像。 如果viewport为非null ，则仅显示属于视口内的图像部分。 如果图像未完全覆盖视口，则视口的任何剩余区域将为空。

        Default value:
        空值

      • getViewport

        public final Rectangle2D getViewport​()
        获取属性视口的值。
        Property description:
        矩形视口进入图像。 在缩放或任何其他转换之前，视口在图像的坐标中指定。

        如果viewport为null ，则显示整个图像。 如果viewport为非null ，则仅显示落在视口内的图像部分。 如果图像未完全覆盖视口，则视口的任何剩余区域将为空。

        Default value:
        空值

      • viewportProperty

        public final ObjectProperty<Rectangle2D> viewportProperty​()
        矩形视口进入图像。 在缩放或任何其他转换之前，视口在图像的坐标中指定。

        如果viewport为null ，则显示整个图像。 如果viewport是非null ，则仅显示落在视口内的图像部分。 如果图像未完全覆盖视口，则视口的任何剩余区域将为空。

        Default value:
        空值
        另请参见：
        getViewport() ， setViewport(Rectangle2D)

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Node
        结果
        与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javafx.scene.image (Java SE 9 & JDK 9 )

javafx.scene.image

Interfaces

  • PixelReader
  • PixelWriter

Classes

  • Image
  • ImageView
  • PixelFormat
  • WritableImage
  • WritablePixelFormat

Enums

  • PixelFormat.Type


javafx.scene.image (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene.image

提供加载和显示图像的一组类。

  • Image类用于加载图像（同步或异步）。 图像可以在加载时调整大小，并且可以使用指定的过滤质量执行调整大小，并具有保留图像原始宽高比的选项。
  • ImageView是一个Node用于显示加载Image类的图像。 它允许显示源图像的动态缩放和/或裁剪视图。 缩放可以用指定的过滤质量执行，并具有保留图像原始宽高比的选项。
  • 接口摘要
    接口 描述
    PixelReader
    该界面定义了从Image或包含像素的其他表面中检索像素数据的方法。
    PixelWriter
    该界面定义了用于写入WritableImage或包含可写入像素的其他表面的像素数据的方法。
  • 类摘要
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
    ImageView
    ImageView是一个Node用于绘制图像加载Image类。
    PixelFormat<T extends Buffer>
    PixelFormat对象定义给定格式的像素的数据布局。
    WritableImage
    WritableImage类表示由应用程序提供的像素构建的自定义图形图像，可能来自任何数量来源的 PixelReader对象，包括从文件或URL读取的图像。
    WritablePixelFormat<T extends Buffer>
    表示可以存储全色的像素格式的对象PixelFormat可以用作从任意图像写入像素数据的目的地格式。
  • 枚举摘要
    Enum 描述
    PixelFormat.Type
    一个枚举，描述由PixelFormat管理的单个像素的阵列存储格式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.image Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.image

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.image.Image
      • javafx.scene.image.WritableImage
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.image.ImageView
    • javafx.scene.image.PixelFormat<T>
      • javafx.scene.image.WritablePixelFormat<T>

Interface Hierarchy

  • javafx.scene.image.PixelReader
  • javafx.scene.image.PixelWriter

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.image.PixelFormat.Type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


PixelFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.image

Class PixelFormat<T extends Buffer>

  • java.lang.Object
    • javafx.scene.image.PixelFormat<T>
  • 已知直接子类：
    WritablePixelFormat

    public abstract class PixelFormat<T extends Buffer>
extends Object
    A PixelFormat对象定义给定格式的像素的数据布局。
    从以下版本开始：
    JavaFX 2.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  PixelFormat.Type
      一个枚举，描述由PixelFormat管理的单个像素的阵列存储格式。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static PixelFormat<ByteBuffer> createByteIndexedInstance​(int[] colors)
      创建描述像素布局的 PixelFormat实例，将像素存储为单个字节，表示索引到 INT_ARGB格式的 非预乘颜色值的指定查找表中。
      static PixelFormat<ByteBuffer> createByteIndexedPremultipliedInstance​(int[] colors)
      创建描述像素布局的 PixelFormat实例，将像素存储为单个字节，表示 INT_ARGB_PRE格式的 预乘颜色值的指定查找表中的 索引 。
      abstract int getArgb​(T buf, int x, int y, int scanlineStride)
      从指定坐标的缓冲区读取像素数据，并将其转换为 INT_ARGB格式的颜色的32位整数表示形式。
      static WritablePixelFormat<ByteBuffer> getByteBgraInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中存储在相邻字节中的像素与 非预乘数组件按照增加索引的顺序存储：蓝色，绿色，红色，alpha。
      static WritablePixelFormat<ByteBuffer> getByteBgraPreInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中存储在相邻字节中的像素，其中 预乘数组件以增加的索引：蓝色，绿色，红色，alpha的顺序存储。
      static PixelFormat<ByteBuffer> getByteRgbInstance​()
      返回描述像素布局的 PixelFormat实例，其中存储在相邻字节中的像素的颜色分量按照增加的索引顺序存储：红色，绿色和蓝色。
      static WritablePixelFormat<IntBuffer> getIntArgbInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其像素存储在32位整数中， 非预乘数组件按顺序存储，从MSb到LSb：alpha，红，绿，蓝。
      static WritablePixelFormat<IntBuffer> getIntArgbPreInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其像素存储在32位整数中， 预乘数组按顺序存储，从MSb到LSb：alpha，红，绿，蓝。
      PixelFormat.Type getType​()
      返回表示由此 PixelFormat对象管理的像素的存储格式的枚举。
      abstract boolean isPremultiplied​()
      如果通过此格式解码（或编码）的颜色分量被alpha分量预乘以更有效的混合计算，则返回true。
      abstract boolean isWritable​()
      如果此 PixelFormat对象可以将颜色信息转换为像素表示，则返回true。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getIntArgbInstance

        public static WritablePixelFormat<IntBuffer> getIntArgbInstance​()
        返回描述像素布局的WritablePixelFormat实例，其中以32位整数存储的像素与非预乘数组件按顺序存储，从MSb到LSb：alpha，red，green，blue。

        可以使用以下示例代码对此格式的像素进行解码：

           int pixel = array[rowstart + x]; int alpha = ((pixel >> 24) & 0xff); int red = ((pixel >> 16) & 0xff); int green = ((pixel >> 8) & 0xff); int blue = ((pixel >> ) & 0xff);
        结果
        描述指示的像素格式的 WritabelPixelFormat<IntBuffer>

      • getIntArgbPreInstance

        public static WritablePixelFormat<IntBuffer> getIntArgbPreInstance​()
        返回描述像素布局的WritablePixelFormat实例，其中以32位整数存储的像素，其中预乘数组件按顺序存储，从MSb到LSb：alpha，红，绿，蓝。

        可以使用以下示例代码对此格式的像素进行解码：

           int pixel = array[rowstart + x]; int alpha = ((pixel >> 24) & 0xff); int red = ((pixel >> 16) & 0xff); int green = ((pixel >> 8) & 0xff); int blue = ((pixel >> ) & 0xff);
        结果
        描述指示的像素格式的 WritabelPixelFormat<IntBuffer>

      • getByteBgraInstance

        public static WritablePixelFormat<ByteBuffer> getByteBgraInstance​()
        返回描述像素布局的WritablePixelFormat实例，其中存储在相邻字节中的像素， 非预乘数组件以增加的索引：蓝色，绿色，红色，alpha的顺序存储。

        可以使用以下示例代码对此格式的像素进行解码：

           int i = rowstart + x * 4; int blue = (array[i+0] & 0xff); int green = (array[i+1] & 0xff); int red = (array[i+2] & 0xff); int alpha = (array[i+3] & 0xff);
        结果
        描述指示的像素格式的 WritablePixelFormat<ByteBuffer>

      • getByteBgraPreInstance

        public static WritablePixelFormat<ByteBuffer> getByteBgraPreInstance​()
        返回描述像素布局的WritablePixelFormat实例，其中存储在相邻字节中的像素，其中预乘数组件以增加的索引：蓝色，绿色，红色，alpha的顺序存储。

        可以使用以下示例代码对此格式的像素进行解码：

           int i = rowstart + x * 4; int blue = (array[i+0] & 0xff); int green = (array[i+1] & 0xff); int red = (array[i+2] & 0xff); int alpha = (array[i+3] & 0xff);
        结果
        描述指示的像素格式的 WritablePixelFormat<ByteBuffer>

      • getByteRgbInstance

        public static PixelFormat<ByteBuffer> getByteRgbInstance​()
        返回描述像素布局的PixelFormat实例，其中存储在相邻字节中的像素的颜色分量按照增加的索引顺序存储：红色，绿色和蓝色。

        可以使用以下示例代码对此格式的像素进行解码：

           int i = rowstart + x * 3; int red = (array[i+0] & 0xff); int green = (array[i+1] & 0xff); int blue = (array[i+2] & 0xff);
        结果
        描述指示的像素格式的 PixelFormat<ByteBuffer>

      • createByteIndexedPremultipliedInstance

        public static PixelFormat<ByteBuffer> createByteIndexedPremultipliedInstance​(int[] colors)
        创建描述像素布局的PixelFormat实例，其中像素存储为单个字节，表示INT_ARGB_PRE格式的预乘颜色值的指定查找表中的索引 。

        可以使用以下示例代码对此格式的像素进行解码：

           int pixel = array[rowstart + x] &amp; 0xff; int argb = colors[pixel]; int alpha = ((argb >> 24) & 0xff); int red = ((argb >> 16) & 0xff); int green = ((argb >> 8) & 0xff); int blue = ((argb ) & 0xff);
        参数
        colors - INT_ARGB_PRE格式的 int[]阵列的32位颜色值
        结果
        a PixelFormat<ByteBuffer>描述指定的像素格式与指定的预乘颜色列表

      • createByteIndexedInstance

        public static PixelFormat<ByteBuffer> createByteIndexedInstance​(int[] colors)
        创建描述像素布局的PixelFormat实例，其中像素存储为单个字节，表示索引到INT_ARGB格式的非预乘颜色值的指定查找表中。

        可以使用以下示例代码对此格式的像素进行解码：

           int pixel = array[rowstart + x] &amp; 0xff; int argb = colors[pixel]; int alpha = ((argb >> 24) & 0xff); int red = ((argb >> 16) & 0xff); int green = ((argb >> 8) & 0xff); int blue = ((argb ) & 0xff);
        参数
        colors - int[] INT_ARGB格式的32位颜色值的 int[]数组
        结果
        一个 PixelFormat<ByteBuffer>描述指定的像素格式与指定的非预乘颜色列表

      • getType

        public PixelFormat.Type getType​()
        返回表示由此 PixelFormat对象管理的像素的存储格式的枚举。
        结果
        Type枚举的像素

      • isWritable

        public abstract boolean isWritable​()
        如果这个 PixelFormat对象可以将颜色信息转换为像素表示，则返回true。
        结果
        如果这个 PixelFormat可以将颜色转换为像素数据， PixelFormat true

      • isPremultiplied

        public abstract boolean isPremultiplied​()
        如果通过此格式解码（或编码）的颜色分量被alpha分量预乘以更有效的混合计算，则返回true。
        结果
        如果被管理的颜色组件被alpha预乘，则为true

      • getArgb

        public abstract int getArgb​(T buf,
                            int x,
                            int y,
                            int scanlineStride)
        从指定坐标的缓冲区读取像素数据，并将其转换为INT_ARGB格式的颜色的32位整数表示形式。 32位整数将包含从最高有效字节到最低有效字节的ARGB顺序的单独8位字段中的4种颜色分量。 缓冲器应该位于像素数据的开始处，使得buf.get(0)将返回坐标(0, 0)处的像素的像素信息。 scanlineStride参数定义了从一行开始处的像素数据到下一个较高Y坐标处紧随其后的行开始处的像素数据的距离。 通常， scanlineStride与图像的宽度乘以每像素的数据元素数（在整数和索引格式的情况下为1，在字节格式的情况下为3或4），但某些图像可能在行之间进一步填充以进行对准或其他目的。

        可以使用以下示例代码从返回的整数中提取颜色分量：

          int alpha = ((retval >> 24) & 0xff);
     int red   = ((retval >> 16) & 0xff);
     int green = ((retval >>  8) & 0xff);
     int blue  = ((retval      ) & 0xff);
        参数
        buf - 像素数据的缓冲区
        x - 要读取的像素的X坐标
        y - 要读取的像素的Y坐标
        scanlineStride - 缓冲区中相邻像素行开始之间的缓冲元素数
        结果
        a 32-bit value with the color of the pixel in a format similar to the INT_ARGB pixel format
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PixelFormat.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.image

Enum PixelFormat.Type

  • java.lang.Object
    • java.lang.Enum<PixelFormat.Type>
      • javafx.scene.image.PixelFormat.Type
  • All Implemented Interfaces:
    Serializable ， Comparable<PixelFormat.Type>
    Enclosing class:
    PixelFormat < T extends Buffer >

    public static enum PixelFormat.Type
extends Enum<PixelFormat.Type>
    一个枚举，描述由PixelFormat管理的单个像素的阵列存储格式。
    从以下版本开始：
    JavaFX 2.2

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BYTE_BGRA
      像素被存储在相邻的字节中，非预乘数组件以增加的索引顺序存储：蓝色，绿色，红色，α。
      BYTE_BGRA_PRE
      像素被存储在相邻的字节中，其中预乘数分量按照增加的索引的顺序存储：蓝色，绿色，红色，α。
      BYTE_INDEXED
      像素颜色由存储在像素阵列中的字节索引引用，该字节被解释为由 PixelFormat对象提供的颜色列表中的无符号索引。
      BYTE_RGB
      不透明像素存储在相邻字节中，颜色分量按照增加的索引顺序存储：红，绿，蓝。
      INT_ARGB
      像素以32位整数存储，非预分量按顺序存储，从MSb到LSb：alpha，红，绿，蓝。
      INT_ARGB_PRE
      像素以32位整数存储，预分量按顺序存储，从MSb到LSb：alpha，红，绿，蓝。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PixelFormat.Type valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PixelFormat.Type[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • INT_ARGB_PRE

        public static final PixelFormat.Type INT_ARGB_PRE
        像素以32位整数存储，预分量按顺序存储，从MSb到LSb：alpha，红，绿，蓝。

      • INT_ARGB

        public static final PixelFormat.Type INT_ARGB
        像素以32位整数存储，非预分量按顺序存储，从MSb到LSb：alpha，红，绿，蓝。

      • BYTE_BGRA_PRE

        public static final PixelFormat.Type BYTE_BGRA_PRE
        像素被存储在相邻的字节中，其中预乘数分量按照增加的索引的顺序存储：蓝色，绿色，红色，α。

      • BYTE_BGRA

        public static final PixelFormat.Type BYTE_BGRA
        像素被存储在相邻的字节中，非预乘数组件以增加的索引顺序存储：蓝色，绿色，红色，α。

      • BYTE_RGB

        public static final PixelFormat.Type BYTE_RGB
        不透明像素存储在相邻字节中，颜色分量按照增加的索引顺序存储：红，绿，蓝。

      • BYTE_INDEXED

        public static final PixelFormat.Type BYTE_INDEXED
        像素颜色由存储在像素阵列中的字节索引引用，该字节被解释为由 PixelFormat对象提供的颜色列表中的无符号索引。

    • 方法详细信息

      • values

        public static PixelFormat.Type[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PixelFormat.Type c : PixelFormat.Type.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PixelFormat.Type valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PixelReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.image

Interface PixelReader

  • public interface PixelReader
    该接口定义从Image或包含像素的其他表面检索像素数据的方法。
    从以下版本开始：
    JavaFX 2.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getArgb​(int x, int y)
      从表面的指定坐标读取像素颜色的32位整数表示形式。
      Color getColor​(int x, int y)
      从表面的指定坐标读取像素的颜色，并将该值作为Color对象返回。
      PixelFormat getPixelFormat​()
      该方法返回表面存储其像素的 PixelFormat ，或大致相当的像素格式，为了读取它们，可以轻松地转换其像素。
      void getPixels​(int x, int y, int w, int h, WritablePixelFormat<ByteBuffer> pixelformat, byte[] buffer, int offset, int scanlineStride)
      将像素数据从表面的矩形区域读入指定的字节数组。
      void getPixels​(int x, int y, int w, int h, WritablePixelFormat<IntBuffer> pixelformat, int[] buffer, int offset, int scanlineStride)
      将像素数据从表面的矩形区域读入指定的int数组。
      <T extends Buffer>
      void             		getPixels​(int x, int y, int w, int h, WritablePixelFormat<T> pixelformat, T buffer, int scanlineStride)
      将像素数据从表面的矩形区域读入指定的缓冲区。

    • 方法详细信息

      • getPixelFormat

        PixelFormat getPixelFormat​()
        该方法返回 PixelFormat ，其中表面存储其像素，或大致相等的像素格式，为了读取它们，可以轻松地将其像素转换。
        结果
        最好描述底层像素的 PixelFormat

      • getArgb

        int getArgb​(int x,
            int y)
        从表面的指定坐标读取像素颜色的32位整数表示形式。 32位整数将包含从最高有效字节到最低有效字节的ARGB顺序的单独8位字段中的4种颜色分量。
        参数
        x - 要读取的像素颜色的X坐标
        y - 要读取的像素颜色的Y坐标
        结果
        由 INT_ARGB PixelFormat类型描述的格式的32位表示形式。

      • getColor

        Color getColor​(int x,
               int y)
        从表面的指定坐标读取像素的颜色，并将该值作为Color对象返回。
        参数
        x - 要读取的像素颜色的X坐标
        y - 要读取的像素颜色的Y坐标
        结果
        Color对象表示指示像素的颜色

      • getPixels

        <T extends Buffer> void getPixels​(int x,
                                  int y,
                                  int w,
                                  int h,
                                  WritablePixelFormat<T> pixelformat,
                                  T buffer,
                                  int scanlineStride)
        将像素数据从表面的矩形区域读入指定的缓冲区。 用于缓冲区中的像素的格式由PixelFormat对象定义，并且将根据需要执行像素格式转换，以指定的格式存储数据。 假设缓冲器被定位到来自位置(x, y)处的图像像素的第一像素数据将被存储的位置。 一行的像素数据将被存储在缓冲区内的相邻位置，尽可能紧密地填充以增加X坐标。 相邻行的像素数据将被彼此偏移由scanlineStride定义的缓冲数据元素的scanlineStride 。
        参数类型
        T - 缓冲区的类型
        参数
        x - 要读取的矩形区域的X坐标
        y - 要读取的矩形区域的Y坐标
        w - 要读取的矩形区域的宽度
        h - 要读取的矩形区域的高度
        pixelformat - PixelFormat对象定义将像素存储到缓冲区中的格式
        buffer - 适合指定的 PixelFormat对象的缓冲区
        scanlineStride - 缓冲区中一行数据开始到下一行数据开始的像素数据之间的距离。

      • getPixels

        void getPixels​(int x,
               int y,
               int w,
               int h,
               WritablePixelFormat<ByteBuffer> pixelformat,
               byte[] buffer,
               int offset,
               int scanlineStride)
        将像素数据从表面的矩形区域读入指定的字节数组。 用于缓冲区中像素的格式由PixelFormat对象定义，像素格式转换将根据需要执行，以指定格式存储数据。 pixelformat必须是兼容的PixelFormat<ByteBuffer>类型。 位置(x, y)处的第一个像素的数据将被读入由offset参数指定的数组索引。 一行的像素数据将被存储在尽可能紧凑地堆叠的阵列中的相邻位置，以增加X坐标。 相邻行的像素数据将通过由scanlineStride定义的字节数组元素的数量彼此偏移。
        参数
        x - 要读取的矩形区域的X坐标
        y - 要读取的矩形区域的Y坐标
        w - 要读取的矩形区域的宽度
        h - 要读取的矩形区域的高度
        pixelformat - PixelFormat<ByteBuffer>对象定义将像素存储到缓冲区中的字节格式
        buffer - 用于存储返回的像素数据的字节数组
        offset - 将偏移量存入 buffer以存储第一个像素数据
        scanlineStride - 缓冲区中的一行数据开始到下一行数据的开始的像素数据之间的距离

      • getPixels

        void getPixels​(int x,
               int y,
               int w,
               int h,
               WritablePixelFormat<IntBuffer> pixelformat,
               int[] buffer,
               int offset,
               int scanlineStride)
        将像素数据从表面的矩形区域读入指定的int数组。 用于缓冲区中的像素的格式由PixelFormat对象定义，并且将根据需要执行像素格式转换，以指定的格式存储数据。 pixelformat必须是兼容的PixelFormat<IntBuffer>类型。 位置(x, y)处的第一个像素的数据将被读入由offset参数指定的数组索引。 一行的像素数据将被存储在尽可能紧凑地堆叠的阵列中的相邻位置，以增加X坐标。 相邻行的像素数据将通过由scanlineStride定义的int数组元素的数量彼此偏移。
        参数
        x - 要读取的矩形区域的X坐标
        y - 要读取的矩形区域的Y坐标
        w - 要读取的矩形区域的宽度
        h - 要读取的矩形区域的高度
        pixelformat - PixelFormat<IntBuffer>对象定义将格式存储在缓冲区中的int格式
        buffer - 用于存储返回的像素数据的int数组
        offset - 偏移到 buffer存储第一个像素数据
        scanlineStride - 缓冲区中的一行数据开始到下一行数据的开始的像素数据之间的距离
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PixelWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.image

Interface PixelWriter

  • public interface PixelWriter
    该界面定义了用于写入WritableImage或包含可写入像素的其他表面的像素数据的方法。
    从以下版本开始：
    JavaFX 2.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      PixelFormat getPixelFormat​()
      该方法返回表面存储其像素的 PixelFormat ，或大致相当的像素格式，从而可以轻松地将像素转换为用于编写它们的像素。
      void setArgb​(int x, int y, int argb)
      将颜色的像素数据存储到表面的指定坐标。
      void setColor​(int x, int y, Color c)
      将Color的像素数据存储到表面的指定坐标。
      void setPixels​(int x, int y, int w, int h, PixelFormat<ByteBuffer> pixelformat, byte[] buffer, int offset, int scanlineStride)
      将来自字节数组的像素数据存储到表面的矩形区域中。
      void setPixels​(int x, int y, int w, int h, PixelFormat<IntBuffer> pixelformat, int[] buffer, int offset, int scanlineStride)
      将来自int数组的像素数据存储到表面的矩形区域中。
      <T extends Buffer>
      void             		setPixels​(int x, int y, int w, int h, PixelFormat<T> pixelformat, T buffer, int scanlineStride)
      将像素数据从缓冲区存储到表面的矩形区域。
      void setPixels​(int dstx, int dsty, int w, int h, PixelReader reader, int srcx, int srcy)
      将从 PixelReader实例检索的像素数据存储到表面的矩形区域中。

    • 方法详细信息

      • getPixelFormat

        PixelFormat getPixelFormat​()
        该方法返回表面存储其像素的 PixelFormat ，或者大致等效的像素格式，从而可以轻松地将像素转换为用于编写它们的像素。
        结果
        最好描述底层像素的 PixelFormat

      • setArgb

        void setArgb​(int x,
             int y,
             int argb)
        将颜色的像素数据存储到表面的指定坐标。 32位整数argb参数应包含从最高有效字节到最低有效字节的ARGB顺序的单独8位字段中的4种颜色分量。
        参数
        x - 要写入的像素颜色的X坐标
        y - 要写入的像素颜色的Y坐标
        argb - 要写入的颜色信息，以 INT_ARGB PixelFormat类型描述的格式指定。

      • setColor

        void setColor​(int x,
              int y,
              Color c)
        将Color的像素数据存储到表面的指定坐标。
        参数
        x - 要写入的像素颜色的X坐标
        y - 要写入的像素颜色的Y坐标
        c - 要写入或无效的颜色
        异常
        NullPointerException - 如果 color是 null

      • setPixels

        <T extends Buffer> void setPixels​(int x,
                                  int y,
                                  int w,
                                  int h,
                                  PixelFormat<T> pixelformat,
                                  T buffer,
                                  int scanlineStride)
        将像素数据从缓冲区存储到表面的矩形区域。 缓冲区中的像素的格式由PixelFormat对象定义，像素格式转换将根据需要执行，以将数据存储到表面。 假设缓冲器被定位到位于位置(x, y)的表面像素中要存储的第一像素数据的位置。 一行的像素数据将从缓冲区内的相邻位置读取，尽可能紧凑地增加X坐标。 相邻行的像素数据将通过由scanlineStride定义的缓冲区数据元素的数量彼此偏移。
        参数类型
        T - 缓冲区的类型
        参数
        x - 要写入的矩形区域的X坐标
        y - 要写入的矩形区域的Y坐标
        w - 要写入的矩形区域的宽度
        h - 要写入的矩形区域的高度
        pixelformat - PixelFormat对象定义从缓冲区读取像素的格式
        buffer - 适合指定的 PixelFormat对象的缓冲区
        scanlineStride - 用于将缓冲区中的一行数据开始到下一行数据的开始的像素数据之间的距离。
        异常
        NullPointerException - 如果 pixelformat或 buffer是 null

      • setPixels

        void setPixels​(int x,
               int y,
               int w,
               int h,
               PixelFormat<ByteBuffer> pixelformat,
               byte[] buffer,
               int offset,
               int scanlineStride)
        将来自字节数组的像素数据存储到表面的矩形区域中。 缓冲区中的像素的格式由PixelFormat对象定义，像素格式转换将根据需要执行，以将数据存储到表面。 pixelformat必须是兼容的PixelFormat<ByteBuffer>类型。 位置(x, y)处的第一个像素的数据将从offset参数指定的数组索引读取。 一行中的像素数据将从数组中紧邻的数组中的相邻位置读取，以增加X坐标。 相邻行的像素数据将被读取由scanlineStride定义的字节数组元素的数量彼此偏移。
        参数
        x - 要写入的矩形区域的X坐标
        y - 要写入的矩形区域的Y坐标
        w - 要写入的矩形区域的宽度
        h - 要写入的矩形区域的高度
        pixelformat - PixelFormat<ByteBuffer>对象定义从缓冲区读取像素的字节格式
        buffer - 一个包含要存储的像素数据的字节数组
        offset - 偏移到 buffer读取第一个像素数据
        scanlineStride - 用于将缓冲器中的一行数据开始到下一行数据的开始的像素数据之间的距离
        异常
        NullPointerException - 如果 pixelformat或 buffer是 null

      • setPixels

        void setPixels​(int x,
               int y,
               int w,
               int h,
               PixelFormat<IntBuffer> pixelformat,
               int[] buffer,
               int offset,
               int scanlineStride)
        将来自int数组的像素数据存储到表面的矩形区域中。 缓冲区中的像素的格式由PixelFormat对象定义，像素格式转换将根据需要执行，以将数据存储到表面。 pixelformat必须是兼容的PixelFormat<IntBuffer>类型。 位置(x, y)的第一个像素的数据将从offset参数指定的数组索引读取。 一行中的像素数据将从数组中紧邻的数组中的相邻位置读取，以增加X坐标。 相邻行的像素数据将通过由scanlineStride定义的int数组元素的数量彼此偏移。
        参数
        x - 要写入的矩形区域的X坐标
        y - 要写入的矩形区域的Y坐标
        w - 要写入的矩形区域的宽度
        h - 要写入的矩形区域的高度
        pixelformat - PixelFormat<IntBuffer>对象定义从缓冲区读取像素的int格式
        buffer - 一个用于包含要存储的像素数据的int数组
        offset - 偏移到 buffer读取第一个像素数据
        scanlineStride - 用于将缓冲器中的一行数据开始到下一行数据的开始的像素数据之间的距离
        异常
        NullPointerException - 如果 pixelformat或 buffer是 null

      • setPixels

        void setPixels​(int dstx,
               int dsty,
               int w,
               int h,
               PixelReader reader,
               int srcx,
               int srcy)
        将从PixelReader实例检索的像素数据存储到表面的矩形区域中。 (dstx, dsty)表面像素的数据将从reader从其位置(srcx, srcy) 。 该方法执行语义上相当于（尽管可能比该伪代码快得多）的操作：
          for (int y = 0; y < h, y++) {
         for (int x = 0; x < w; x++) {
             setArgb(dstx + x, dsty + y,
                     reader.getArgb(srcx + x, srcy + y));
         }
     }
        参数
        dstx - 要写入的矩形区域的X坐标
        dsty - 要写入的矩形区域的Y坐标
        w - 要写入的矩形区域的宽度
        h - 要写入的矩形区域的高度
        reader - PixelReader用于获取像素数据写入
        srcx - 要从 reader读取的数据的X坐标
        srcy - 要从 reader读取的数据的Y坐标
        异常
        NullPointerException - 如果 reader是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.image (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.image

  • Packages that use javafx.scene.image
    软件包 描述
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.stage
    提供JavaFX内容的顶级容器类。
  • Classes in javafx.scene.image used by javafx.embed.swing
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
    WritableImage
    WritableImage类代表由应用程序提供的像素构建的自定义图形图像，可能来自任何数量来源的 PixelReader对象，包括从文件或URL读取的图像。
  • Classes in javafx.scene.image used by javafx.scene
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
    WritableImage
    WritableImage类表示由应用程序提供的像素构建的自定义图形图像，可能来自任何数量来源的 PixelReader对象，包括从文件或URL读取的图像。
  • Classes in javafx.scene.image used by javafx.scene.canvas
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
    PixelWriter
    该界面定义了用于写入WritableImage或包含可写入像素的其他表面的像素数据的方法。
  • Classes in javafx.scene.image used by javafx.scene.effect
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
  • Classes in javafx.scene.image used by javafx.scene.image
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
    PixelFormat
    PixelFormat对象定义给定格式的像素的数据布局。
    PixelFormat.Type
    一个枚举，描述由PixelFormat管理的单个像素的阵列存储格式。
    PixelReader
    该界面定义了从Image或包含像素的其他表面中检索像素数据的方法。
    PixelWriter
    该界面定义了用于写入WritableImage或包含可写入像素的其他表面的像素数据的方法。
    WritablePixelFormat
    表示可以存储全色的像素格式的PixelFormat对象可以用作从任意图像写入像素数据的目的地格式。
  • Classes in javafx.scene.image used by javafx.scene.input
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
  • Classes in javafx.scene.image used by javafx.scene.layout
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
  • Classes in javafx.scene.image used by javafx.scene.paint
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
  • Classes in javafx.scene.image used by javafx.stage
    Class 描述
    Image
    Image类表示图形图像，用于从指定的URL加载图像。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


WritableImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.image

Class WritableImage

  • java.lang.Object
    • javafx.scene.image.Image
      • javafx.scene.image.WritableImage

  • public class WritableImage
extends Image
    WritableImage类表示由应用程序提供的像素构建的自定义图形图像，可能来自任何数量来源的 PixelReader对象，包括从文件或URL读取的图像。
    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      • Properties inherited from class javafx.scene.image.Image

        error, exception, height, progress, width

    • 构造方法摘要

      构造方法
      Constructor 描述
      WritableImage​(int width, int height)
      构造指定尺寸的空图像。
      WritableImage​(PixelReader reader, int width, int height)
      构造指定尺寸的图像，从指定的PixelReader初始化。
      WritableImage​(PixelReader reader, int x, int y, int width, int height)
      构建指定尺寸的图像，从PixelReader的指定区域初始化。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PixelWriter getPixelWriter​()
      该方法返回一个 PixelWriter ，它提供访问以写入图像的像素。

      • Methods inherited from class javafx.scene.image.Image

        cancel, errorProperty, exceptionProperty, getException, getHeight, getPixelReader, getProgress, getRequestedHeight, getRequestedWidth, getUrl, getWidth, heightProperty, isBackgroundLoading, isError, isPreserveRatio, isSmooth, progressProperty, widthProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WritableImage

        public WritableImage​(int width,
                     int height)
        构造指定尺寸的空图像。 图像最初将填充透明像素。 以这种方式构建的图像将始终是可读写的，所以相应的getPixelReader（）和getPixelWriter（）将始终返回有效的对象。 尺寸必须为正数(> 0) 。
        参数
        width - 可写图像的所需宽度
        height - 所需图像的期望高度
        异常
        IllegalArgumentException - 如果任一维为负或为零。

      • WritableImage

        public WritableImage​(PixelReader reader,
                     int width,
                     int height)
        构造指定尺寸的图像，从指定的PixelReader初始化。 图像最初将填充从PixelReader返回的PixelReader 。 如果PixelReader访问不包含必需数量的像素行和列的曲面，则将抛出ArrayIndexOutOfBoundsException 。 以这种方式构建的图像将始终是可读写的，所以相应的getPixelReader（）和getPixelWriter（）将始终返回有效的对象。 尺寸必须为正数(> 0) 。
        参数
        reader - 从 PixelReader构建
        width - width图像的期望宽度和要从 reader读取的区域的宽度
        height - 所需图像的期望高度和要从 reader读取的区域的宽度
        异常
        ArrayIndexOutOfBoundsException - 如果 reader不访问至少所请求尺寸的曲面
        IllegalArgumentException - 如果任一维为负或为零。

      • WritableImage

        public WritableImage​(PixelReader reader,
                     int x,
                     int y,
                     int width,
                     int height)
        构造指定尺寸的图像，从PixelReader的指定区域初始化。 最初将使用从指定区域的PixelReader返回的数据填充图像。 如果PixelReader访问不包含必需数量的像素行和列的曲面，则将抛出ArrayIndexOutOfBoundsException 。 以这种方式构建的图像将始终是可读写的，所以相应的getPixelReader（）和getPixelWriter（）将始终返回有效的对象。 尺寸必须为正数(> 0) 。
        参数
        reader - 从 PixelReader构建
        x - 要从 reader读取的区域的左上角的X坐标
        y - 要从 reader读取的区域的左上角的Y坐标
        width - width图像的期望宽度和要从 reader读取的区域的宽度
        height - 所需图像的期望高度和要从 reader读取的区域的宽度
        异常
        ArrayIndexOutOfBoundsException - 如果 reader不访问至少包含指定区域的表面
        IllegalArgumentException - 如果任一维为负或为零。

    • 方法详细信息

      • getPixelWriter

        public final PixelWriter getPixelWriter​()
        该方法返回一个 PixelWriter ，它提供访问以写入图像的像素。
        结果
        用于将像素写入图像的 PixelWriter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WritablePixelFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.image

Class WritablePixelFormat<T extends Buffer>

  • java.lang.Object
    • javafx.scene.image.PixelFormat<T>
      • javafx.scene.image.WritablePixelFormat<T>

  • public abstract class WritablePixelFormat<T extends Buffer>
extends PixelFormat<T>
    表示可以存储全色的像素格式的对象PixelFormat可以用作从任意图像写入像素数据的目的地格式。
    从以下版本开始：
    JavaFX 2.2

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.image.PixelFormat

        PixelFormat.Type

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean isWritable​()
      如果此 PixelFormat对象可以将颜色信息转换为像素表示，则返回true。
      abstract void setArgb​(T buf, int x, int y, int scanlineStride, int argb)
      在指定的坐标处存储表示指定的32位整数表示的适当像素数据在缓冲区中的颜色。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.image.PixelFormat

        createByteIndexedInstance, createByteIndexedPremultipliedInstance, getArgb, getByteBgraInstance, getByteBgraPreInstance, getByteRgbInstance, getIntArgbInstance, getIntArgbPreInstance, getType, isPremultiplied

    • 方法详细信息

      • isWritable

        public boolean isWritable​()
        说明从类别复制PixelFormat
        如果此 PixelFormat对象可以将颜色信息转换为像素表示，则返回true。
        Specified by:
        isWritable在 PixelFormat<T extends Buffer>
        结果
        如果这个 PixelFormat可以将颜色转换为像素数据， PixelFormat true

      • setArgb

        public abstract void setArgb​(T buf,
                             int x,
                             int y,
                             int scanlineStride,
                             int argb)
        在指定的坐标处存储表示指定的32位整数表示的适当像素数据在缓冲区中的颜色。 32位整数将包含从最高有效字节到最低有效字节的ARGB顺序的单独8位字段中的4种颜色分量。 缓冲器应该位于像素数据的开始处，使得buf.get(0)将返回坐标(0, 0)处的像素的像素信息。 scanlineStride参数定义了从一行开始处的像素数据到下一个较高Y坐标处紧随其后的行开始处的像素数据的距离。 通常， scanlineStride与图像的宽度相乘乘以每像素的数据元素数（在整数和索引格式的情况下为1，在字节格式的情况下为3或4），但某些图像可能在行之间进一步填充以进行对准或其他目的。

        颜色分量可以使用以下示例代码组成整数：

          int argb = ((alpha << 24) |
                 (red   << 16) |
                 (green <<  8) |
                 (blue       );
        参数
        buf - 像素数据的缓冲区
        x - 要读取的像素的X坐标
        y - 要读取的像素的Y坐标
        scanlineStride - 缓冲区中相邻像素行开始之间的缓冲元素数
        argb - 一个32位值，其颜色将以类似于 Type.INT_ARGB像素格式的格式存储在像素中
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.scene.image.Image (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.image.Image

  • Packages that use Image
    软件包 描述
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of Image in javafx.embed.swing

      Methods in javafx.embed.swing with parameters of type Image
      Modifier and Type 方法 描述
      static BufferedImage SwingFXUtils.fromFXImage​(Image img, BufferedImage bimg)
      快照指定的JavaFX Image对象，并将其像素的副本存储到一个BufferedImage对象中，如果需要创建一个新对象。

    • Uses of Image in javafx.scene

      Methods in javafx.scene that return Image
      Modifier and Type 方法 描述
      Image ImageCursor.getImage​()
      获取属性映像的值。
      Methods in javafx.scene that return types with arguments of type Image
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Image> ImageCursor.imageProperty​()
      光标激活时显示的图像。
      Methods in javafx.scene with parameters of type Image
      Modifier and Type 方法 描述
      static ImageCursor ImageCursor.chooseBestCursor​(Image[] images, double hotspotX, double hotspotY)
      从指定的图像之一创建自定义图像光标。
      Constructors in javafx.scene with parameters of type Image
      Constructor 描述
      ImageCursor​(Image image)
      从指定的图像构造一个 ImageCursor 。
      ImageCursor​(Image image, double hotspotX, double hotspotY)
      从指定的图像和热点坐标构造一个 ImageCursor 。

    • Uses of Image in javafx.scene.canvas

      Methods in javafx.scene.canvas with parameters of type Image
      Modifier and Type 方法 描述
      void GraphicsContext.drawImage​(Image img, double x, double y)
      使用给定图像的宽度和高度在给定的x，y位置绘制图像。
      void GraphicsContext.drawImage​(Image img, double x, double y, double w, double h)
      将图像绘制到画布的给定目标矩形中。
      void GraphicsContext.drawImage​(Image img, double sx, double sy, double sw, double sh, double dx, double dy, double dw, double dh)
      将给定图像的指定源矩形绘制到Canvas的给定目标矩形。

    • Uses of Image in javafx.scene.effect

      Methods in javafx.scene.effect that return Image
      Modifier and Type 方法 描述
      Image ImageInput.getSource​()
      获取属性源的值。
      Methods in javafx.scene.effect that return types with arguments of type Image
      Modifier and Type 方法 描述
      ObjectProperty<Image> ImageInput.sourceProperty​()
      来源 Image 。
      Methods in javafx.scene.effect with parameters of type Image
      Modifier and Type 方法 描述
      void ImageInput.setSource​(Image value)
      设置属性源的值。
      Constructors in javafx.scene.effect with parameters of type Image
      Constructor 描述
      ImageInput​(Image source)
      使用指定的源创建一个新的ImageInput实例。
      ImageInput​(Image source, double x, double y)
      使用指定的源x和y创建一个新的ImageInput实例。

    • Uses of Image in javafx.scene.image

      Subclasses of Image in javafx.scene.image
      Modifier and Type Class 描述
      class  WritableImage
      WritableImage类表示由应用程序提供的像素构建的自定义图形图像，可能来自任何数量来源的 PixelReader对象，包括从文件或URL读取的图像。
      Methods in javafx.scene.image that return Image
      Modifier and Type 方法 描述
      Image ImageView.getImage​()
      获取属性映像的值。
      Methods in javafx.scene.image that return types with arguments of type Image
      Modifier and Type 方法 描述
      ObjectProperty<Image> ImageView.imageProperty​()
      Image要画ImageView 。
      Methods in javafx.scene.image with parameters of type Image
      Modifier and Type 方法 描述
      void ImageView.setImage​(Image value)
      设置属性图像的值。
      Constructors in javafx.scene.image with parameters of type Image
      Constructor 描述
      ImageView​(Image image)
      使用给定的图像分配一个新的ImageView对象。

    • Uses of Image in javafx.scene.input

      Methods in javafx.scene.input that return Image
      Modifier and Type 方法 描述
      Image Dragboard.getDragView​()
      获取用作拖动视图的图像。
      Image Clipboard.getImage​()
      从先前已注册的剪贴板获取图像。
      Image ClipboardContent.getImage​()
      从 ClipboardContent获取图像，以前已被放置。
      Methods in javafx.scene.input with parameters of type Image
      Modifier and Type 方法 描述
      boolean ClipboardContent.putImage​(Image i)
      将图像放入 ClipboardContent 。
      void Dragboard.setDragView​(Image image)
      设置拖放手势中传输的数据的视觉表示。
      void Dragboard.setDragView​(Image image, double offsetX, double offsetY)
      设置拖放手势中传输的数据的视觉表示。

    • Uses of Image in javafx.scene.layout

      Methods in javafx.scene.layout that return Image
      Modifier and Type 方法 描述
      Image BackgroundImage.getImage​()
      要使用的图像。
      Image BorderImage.getImage​()
      要使用的图像。
      Constructors in javafx.scene.layout with parameters of type Image
      Constructor 描述
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。

    • Uses of Image in javafx.scene.paint

      Methods in javafx.scene.paint that return Image
      Modifier and Type 方法 描述
      Image PhongMaterial.getBumpMap​()
      获取属性bumpMap的值。
      Image PhongMaterial.getDiffuseMap​()
      获取属性diffuseMap的值。
      Image ImagePattern.getImage​()
      获取要用作油漆的图像。
      Image PhongMaterial.getSelfIlluminationMap​()
      获取属性selfIlluminationMap的值。
      Image PhongMaterial.getSpecularMap​()
      获取属性specularMap的值。
      Methods in javafx.scene.paint that return types with arguments of type Image
      Modifier and Type 方法 描述
      ObjectProperty<Image> PhongMaterial.bumpMapProperty​()
      这个PhongMaterial的凹凸贴图，这是一个正常的地图，存储为RGB Image 。
      ObjectProperty<Image> PhongMaterial.diffuseMapProperty​()
      这个 PhongMaterial的漫反射图。
      ObjectProperty<Image> PhongMaterial.selfIlluminationMapProperty​()
      这个自拍照片 PhongMaterial 。
      ObjectProperty<Image> PhongMaterial.specularMapProperty​()
      这个 PhongMaterial的镜面地图。
      Methods in javafx.scene.paint with parameters of type Image
      Modifier and Type 方法 描述
      void PhongMaterial.setBumpMap​(Image value)
      设置属性bumpMap的值。
      void PhongMaterial.setDiffuseMap​(Image value)
      设置propertyMap属性的值。
      void PhongMaterial.setSelfIlluminationMap​(Image value)
      设置属性selfIlluminationMap的值。
      void PhongMaterial.setSpecularMap​(Image value)
      设置属性specularMap的值。
      Constructors in javafx.scene.paint with parameters of type Image
      Constructor 描述
      ImagePattern​(Image image)
      从指定的图像创建一个新的ImagePattern实例。
      ImagePattern​(Image image, double x, double y, double width, double height, boolean proportional)
      创建一个新的ImagePattern实例。
      PhongMaterial​(Color diffuseColor, Image diffuseMap, Image specularMap, Image bumpMap, Image selfIlluminationMap)
      使用指定的颜色和图像为其 diffuseColor属性创建 PhongMaterial类的新实例。

    • Uses of Image in javafx.stage

      Methods in javafx.stage that return types with arguments of type Image
      Modifier and Type 方法 描述
      ObservableList<Image> Stage.getIcons​()
      Gets the icon images to be used in the window decorations and when minimized.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.image.ImageView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.image.ImageView

No usage of javafx.scene.image.ImageView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.image.PixelFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.image.PixelFormat

  • Packages that use PixelFormat
    软件包 描述
    javafx.scene.image
    提供加载和显示图像的一组类。

    • Uses of PixelFormat in javafx.scene.image

      Subclasses of PixelFormat in javafx.scene.image
      Modifier and Type Class 描述
      class  WritablePixelFormat<T extends Buffer>
      表示可以存储全色的像素格式的对象PixelFormat可以用作从任意图像写入像素数据的目的地格式。
      Methods in javafx.scene.image that return PixelFormat
      Modifier and Type 方法 描述
      static PixelFormat<ByteBuffer> PixelFormat.createByteIndexedInstance​(int[] colors)
      创建描述像素布局的 PixelFormat实例，将像素存储为单个字节，表示索引到 INT_ARGB格式的 非预乘颜色值的指定查找表中。
      static PixelFormat<ByteBuffer> PixelFormat.createByteIndexedPremultipliedInstance​(int[] colors)
      创建描述像素布局的 PixelFormat实例，将像素存储为单字节，表示索引到 INT_ARGB_PRE格式的 预乘颜色值的指定查找表中。
      static PixelFormat<ByteBuffer> PixelFormat.getByteRgbInstance​()
      返回描述像素布局的 PixelFormat实例，其中存储在相邻字节中的像素的颜色分量按照增加的索引顺序存储：红色，绿色和蓝色。
      PixelFormat PixelReader.getPixelFormat​()
      该方法返回表面存储其像素的 PixelFormat ，或大致相当的像素格式，为了阅读它们，可以轻松地转换其像素。
      PixelFormat PixelWriter.getPixelFormat​()
      该方法返回表面存储其像素的 PixelFormat ，或大致相当的像素格式，从而可以轻松地将像素转换为用于编写它们的像素。
      Methods in javafx.scene.image with parameters of type PixelFormat
      Modifier and Type 方法 描述
      void PixelWriter.setPixels​(int x, int y, int w, int h, PixelFormat<ByteBuffer> pixelformat, byte[] buffer, int offset, int scanlineStride)
      将来自字节数组的像素数据存储到表面的矩形区域中。
      void PixelWriter.setPixels​(int x, int y, int w, int h, PixelFormat<IntBuffer> pixelformat, int[] buffer, int offset, int scanlineStride)
      将来自int数组的像素数据存储到表面的矩形区域中。
      <T extends Buffer>
      void             		PixelWriter.setPixels​(int x, int y, int w, int h, PixelFormat<T> pixelformat, T buffer, int scanlineStride)
      将像素数据从缓冲区存储到表面的矩形区域。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.image.PixelFormat.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.image.PixelFormat.Type

  • Packages that use PixelFormat.Type
    软件包 描述
    javafx.scene.image
    提供加载和显示图像的一组类。

    • Uses of PixelFormat.Type in javafx.scene.image

      Methods in javafx.scene.image that return PixelFormat.Type
      Modifier and Type 方法 描述
      PixelFormat.Type PixelFormat.getType​()
      返回表示此 PixelFormat对象管理的像素的存储格式的枚举。
      static PixelFormat.Type PixelFormat.Type.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PixelFormat.Type[] PixelFormat.Type.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.image.WritableImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.image.WritableImage

  • Packages that use WritableImage
    软件包 描述
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of WritableImage in javafx.embed.swing

      Methods in javafx.embed.swing that return WritableImage
      Modifier and Type 方法 描述
      static WritableImage SwingFXUtils.toFXImage​(BufferedImage bimg, WritableImage wimg)
      快照指定的BufferedImage并将其像素的副本存储到JavaFX Image对象中，如果需要，创建一个新对象。
      Methods in javafx.embed.swing with parameters of type WritableImage
      Modifier and Type 方法 描述
      static WritableImage SwingFXUtils.toFXImage​(BufferedImage bimg, WritableImage wimg)
      快照指定的BufferedImage并将其像素的副本存储到JavaFX Image对象中，如果需要，创建一个新对象。

    • Uses of WritableImage in javafx.scene

      Methods in javafx.scene that return WritableImage
      Modifier and Type 方法 描述
      WritableImage SnapshotResult.getImage​()
      获取快照操作生成的图像。
      WritableImage Node.snapshot​(SnapshotParameters params, WritableImage image)
      获取该节点的快照，并在渲染图像准备就绪时返回。
      WritableImage Scene.snapshot​(WritableImage image)
      拍摄此场景的快照，并在渲染图像准备就绪时返回。
      Methods in javafx.scene with parameters of type WritableImage
      Modifier and Type 方法 描述
      WritableImage Node.snapshot​(SnapshotParameters params, WritableImage image)
      获取该节点的快照，并在渲染图像准备就绪时返回。
      void Node.snapshot​(Callback<SnapshotResult,Void> callback, SnapshotParameters params, WritableImage image)
      在下一帧获取该节点的快照，并在映像准备就绪时调用指定的回调方法。
      WritableImage Scene.snapshot​(WritableImage image)
      拍摄此场景的快照，并在渲染图像准备就绪时返回。
      void Scene.snapshot​(Callback<SnapshotResult,Void> callback, WritableImage image)
      在下一帧拍摄此场景的快照，并在图像准备就绪时调用指定的回调方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.image.WritablePixelFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.image.WritablePixelFormat

  • Packages that use WritablePixelFormat
    软件包 描述
    javafx.scene.image
    提供加载和显示图像的一组类。

    • Uses of WritablePixelFormat in javafx.scene.image

      Methods in javafx.scene.image that return WritablePixelFormat
      Modifier and Type 方法 描述
      static WritablePixelFormat<ByteBuffer> PixelFormat.getByteBgraInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中存储在相邻字节中的像素与 非预乘数组件按照增加索引的顺序存储：蓝色，绿色，红色，alpha。
      static WritablePixelFormat<ByteBuffer> PixelFormat.getByteBgraPreInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中存储在相邻字节中的像素，其中 预乘数组件以增加的索引：蓝色，绿色，红色，alpha的顺序存储。
      static WritablePixelFormat<IntBuffer> PixelFormat.getIntArgbInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中以32位整数存储的像素与 非预乘数组件按顺序存储，从MSb到LSb：alpha，red，green，blue。
      static WritablePixelFormat<IntBuffer> PixelFormat.getIntArgbPreInstance​()
      返回描述像素布局的 WritablePixelFormat实例，其中以32位整数存储的像素， 预乘数组件按顺序存储，从MSb到LSb：alpha，red，green，blue。
      Methods in javafx.scene.image with parameters of type WritablePixelFormat
      Modifier and Type 方法 描述
      void PixelReader.getPixels​(int x, int y, int w, int h, WritablePixelFormat<ByteBuffer> pixelformat, byte[] buffer, int offset, int scanlineStride)
      将像素数据从表面的矩形区域读入指定的字节数组。
      void PixelReader.getPixels​(int x, int y, int w, int h, WritablePixelFormat<IntBuffer> pixelformat, int[] buffer, int offset, int scanlineStride)
      将像素数据从表面的矩形区域读入指定的int数组。
      <T extends Buffer>
      void             		PixelReader.getPixels​(int x, int y, int w, int h, WritablePixelFormat<T> pixelformat, T buffer, int scanlineStride)
      将像素数据从表面的矩形区域读入指定的缓冲区。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.scene.image.PixelReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.scene.image.PixelReader

  • Packages that use PixelReader
    软件包 描述
    javafx.scene.image
    提供加载和显示图像的一组类。

    • Uses of PixelReader in javafx.scene.image

      Methods in javafx.scene.image that return PixelReader
      Modifier and Type 方法 描述
      PixelReader Image.getPixelReader​()
      此方法返回一个 PixelReader ，如果图像可读，则可以访问该图像的像素。
      Methods in javafx.scene.image with parameters of type PixelReader
      Modifier and Type 方法 描述
      void PixelWriter.setPixels​(int dstx, int dsty, int w, int h, PixelReader reader, int srcx, int srcy)
      将从 PixelReader实例检索的像素数据存储到表面的矩形区域中。
      Constructors in javafx.scene.image with parameters of type PixelReader
      Constructor 描述
      WritableImage​(PixelReader reader, int width, int height)
      构造指定尺寸的图像，从指定的PixelReader初始化。
      WritableImage​(PixelReader reader, int x, int y, int width, int height)
      构建指定尺寸的图像，从PixelReader的指定区域初始化。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.scene.image.PixelWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.scene.image.PixelWriter

  • Packages that use PixelWriter
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.image
    提供加载和显示图像的一组类。

    • Uses of PixelWriter in javafx.scene.canvas

      Methods in javafx.scene.canvas that return PixelWriter
      Modifier and Type 方法 描述
      PixelWriter GraphicsContext.getPixelWriter​()
      返回一个PixelWriter对象，可用于修改与此GraphicsContext相关联的Canvas的像素。

    • Uses of PixelWriter in javafx.scene.image

      Methods in javafx.scene.image that return PixelWriter
      Modifier and Type 方法 描述
      PixelWriter WritableImage.getPixelWriter​()
      该方法返回一个 PixelWriter ，它提供访问以写入图像的像素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Clipboard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class Clipboard

  • java.lang.Object
    • javafx.scene.input.Clipboard
  • 已知直接子类：
    Dragboard

    public class Clipboard
extends Object
    表示操作系统剪贴板，数据可能在例如剪切，复制和粘贴操作期间放置。

    要访问常规系统剪贴板，请使用以下代码：

       Clipboard clipboard = Clipboard.getSystemClipboard();

    在应用程序中只有一个实例的系统剪贴板，所以如果你这样选择的话，将其引用到某个地方是完全可以接受的。

    剪贴板的作用是在任何一个时间在剪贴板上单个概念项目的概念，尽管它可能会以不同的格式放置在剪贴板上。 例如，用户可以在HTML编辑器中选择文本，然后按ctrl + c或cmd + c将其复制。 在这种情况下，剪贴板上可能会以HTML和纯文本形式提供相同的文字。 剪贴板上有两个数据副本，但它们都代表相同的数据。

    使用setContent(java.util.Map<javafx.scene.input.DataFormat, java.lang.Object>)方法在剪贴板上指定内容。 首先，构建一个ClipboardContent对象，然后调用setContent。 每次调用setContent时，剪贴板上的任何先前数据将被清除，并替换为此新内容。

       final Clipboard clipboard = Clipboard.getSystemClipboard(); final ClipboardContent content = new ClipboardContent(); content.putString("Some text"); content.putHtml("<b>Some</b> text"); clipboard.setContent(content);

    ClipboardContent类只是一个地图，方便处理添加到剪贴板的常用数据类型。

    由于相同数据的多个表示可能存在于剪贴板上，并且由于不同的应用程序具有用于处理不同内容类型的不同功能，所以重要的是在剪贴板上放置尽可能多的数据表示，以便于外部应用程序。 请注意，有时操作系统在某些情况下可能会有所帮助，并为您添加多种类型。 例如，当您指定RTF类型时，Mac可能会为您设置纯文本字符串。 如何和在什么情况下发生这种情况超出了本规范的范围，请参阅您的操作系统文档。

    从剪贴板读取数据时，首先要查找最丰富的支持类型很重要。 例如，如果我有一个支持嵌入图像和媒体格式的文本文档，当从剪贴板粘贴内容时，我应该首先检查内容是否可以表示为媒体或图像。 如果没有，那么我可以检查文档类型支持的RTF或HTML或任何富文本格式。 如果没有，那么我可能只需要一个String。

    或者，例如，如果我有一个纯文本文档，那么我会简单地获得一个String表示，并使用它，如果可用。 我可以检查看剪贴板是否有“hasHtml”或“hasString”。

       if (clipboard.hasString()) { ... }

    除了普通或内置的类型，您可以将任意数据放入剪贴板（假定它是可序列化的）。

    内容类型由DataFormat对象定义。 DataFormat类定义了一个不可变对象，并且有许多常用DataFormat类型的静态final字段。 当然，应用程序特定的DataFormat类型也可以被声明和使用。 以下两个方法是等效的（第二个调用将覆盖第一个！）

       ClipboardContent content = new ClipboardContent(); content.putString("some text"); content.put(DataFormat.PLAIN_TEXT, "other text");

    在没有自己的窗口系统的嵌入式平台上，从Clipboard.getSystemClipboard（）返回的剪贴板可能无法从JavaFX应用程序外部访问。

    如果存在安全管理员，应用程序必须具有FXPermission “ accessClipboard ”，以便从Clipboard.getSystemClipboard（）返回的剪贴板可从JavaFX应用程序外部访问。 为了与以前版本的JDK兼容，等效的AWTPermission “ AWTPermission ”还将允许FX剪贴板从JavaFX应用程序外部访问。

    如果应用程序没有权限，或者平台不支持共享剪贴板，则Clipboard.getSystemClipboard（）返回的剪贴板可用于在一个JavaFX应用程序的不同部分之间交换数据，但不能用于在多个应用程序之间交换数据。

    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      清除任何和所有内容的剪贴板。
      Object getContent​(DataFormat dataFormat)
      返回给定类型的此剪贴板中存储的内容，如果没有此类型的内容，则返回null。
      Set<DataFormat> getContentTypes​()
      获取此剪贴板实例上具有已在剪贴板上注册的关联数据的DataFormat类型集。
      List<File> getFiles​()
      从先前已注册的剪贴板获取文件列表。
      String getHtml​()
      从以前注册的剪贴板获取HTML文本字符串。
      Image getImage​()
      从先前已注册的剪贴板获取图像。
      String getRtf​()
      从以前注册的剪贴板获取RTF文本字符串。
      String getString​()
      从以前注册的剪贴板中获取纯文本字符串。
      static Clipboard getSystemClipboard​()
      获取当前系统剪贴板，通过该剪贴板可以存储和检索数据。
      String getUrl​()
      从先前已注册的剪贴板获取URL字符串。
      boolean hasContent​(DataFormat dataFormat)
      测试给定DataFormat类型的此剪贴板上是否有任何内容。
      boolean hasFiles​()
      获取文件列表（DataFormat.FILES）是否已在此剪贴板上注册。
      boolean hasHtml​()
      获取HTML文本String（DataFormat.HTML）是否已在此剪贴板上注册。
      boolean hasImage​()
      获取图像（DataFormat.IMAGE）是否已在此剪贴板上注册。
      boolean hasRtf​()
      获取RTF字符串（DataFormat.RTF）是否已在此剪贴板上注册。
      boolean hasString​()
      获取是否在此剪贴板上注册了纯文本String（DataFormat.PLAIN_TEXT）。
      boolean hasUrl​()
      获取是否在此剪贴板上注册了一个url String（DataFormat.URL）。
      boolean setContent​(Map<DataFormat,Object> content)
      将内容放在剪贴板上。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getSystemClipboard

        public static Clipboard getSystemClipboard​()
        获取当前系统剪贴板，通过该剪贴板可以存储和检索数据。 JavaFX应用程序只有一个系统剪贴板。
        结果
        单个系统剪贴板，用于剪切/复制/粘贴操作

      • clear

        public final void clear​()
        清除任何和所有内容的剪贴板。 任何后续调用getContentTypes()返回把更多的内容在剪贴板将导致空集之前。

      • getContentTypes

        public final Set<DataFormat> getContentTypes​()
        获取此剪贴板实例上具有已在剪贴板上注册的关联数据的DataFormat类型集。 这个集合永远是非空和不可变的。 如果剪贴板随后被修改，则此返回的集合不会更新。
        结果
        一个非空的不可变的内容类型集合。

      • setContent

        public final boolean setContent​(Map<DataFormat,Object> content)
        将内容放在剪贴板上。 此调用将始终导致从剪贴板中清除所有以前的内容，并将其替换为提供的ClipboardContent映射中指定的任何内容。
        参数
        content - 放在剪贴板上的内容。 如果为空，则剪贴板将被清除，不会添加新内容。
        结果
        如果成功则为true，如果内容无法添加，则为false。
        异常
        NullPointerException - 如果为任何格式传递空数据引用

      • getContent

        public final Object getContent​(DataFormat dataFormat)
        返回给定类型的此剪贴板中存储的内容，如果没有此类型的内容，则返回null。
        参数
        dataFormat - 格式类型
        结果
        与此类型相关联的内容，如果没有，则为null

      • hasContent

        public final boolean hasContent​(DataFormat dataFormat)
        测试给定DataFormat类型的此剪贴板上是否有任何内容。
        参数
        dataFormat - 格式类型
        结果
        如果此剪贴板上有内容，则为true

      • hasString

        public final boolean hasString​()
        获取是否在此剪贴板上注册了纯文本String（DataFormat.PLAIN_TEXT）。
        结果
        如果 hasContent(DataFormat.PLAIN_TEXT)返回true，则返回true，否则返回false

      • getString

        public final String getString​()
        从以前注册的剪贴板中获取纯文本字符串。 这相当于调用getContent(DataFormat.PLAIN_TEXT) 。 如果不存在这样的条目，则返回null。
        结果
        与DataFormat.PLAIN_TEXT相关联的剪贴板上的字符串，如果没有，则为null。

      • hasUrl

        public final boolean hasUrl​()
        获取是否在此剪贴板上注册了一个url String（DataFormat.URL）。
        结果
        如果hasContent（DataFormat.URL）返回true，则返回true，否则返回false

      • getUrl

        public final String getUrl​()
        从先前已注册的剪贴板获取URL字符串。 这相当于调用getContent(DataFormat.URL) 。 如果不存在这样的条目，则返回null。
        结果
        与DataFormat.URL相关联的剪贴板上的字符串，如果没有，则为null。

      • hasHtml

        public final boolean hasHtml​()
        获取HTML文本String（DataFormat.HTML）是否已在此剪贴板上注册。
        结果
        如果 hasContent(DataFormat.HTML)返回true，则返回true，否则返回false

      • getHtml

        public final String getHtml​()
        从以前注册的剪贴板获取HTML文本字符串。 这相当于调用getContent(DataFormat.HTML) 。 如果不存在这样的条目，则返回null。
        结果
        与DataFormat.HTML相关联的剪贴板上的字符串，如果没有，则为null。

      • hasRtf

        public final boolean hasRtf​()
        获取RTF字符串（DataFormat.RTF）是否已在此剪贴板上注册。
        结果
        如果hasContent（DataFormat.RTF）返回true，则返回true，否则返回false

      • getRtf

        public final String getRtf​()
        从以前注册的剪贴板获取RTF文本字符串。 这相当于调用getContent(DataFormat.RTF) 。 如果不存在这样的条目，则返回null。
        结果
        与DataFormat.RTF关联的剪贴板上的字符串，如果没有，则为null。

      • hasImage

        public final boolean hasImage​()
        获取图像（DataFormat.IMAGE）是否已在此剪贴板上注册。
        结果
        如果hasContent（DataFormat.IMAGE）返回true，则返回true，否则返回false

      • getImage

        public final Image getImage​()
        从先前已注册的剪贴板获取图像。 这相当于调用getContent(DataFormat.IMAGE) 。 如果不存在这样的条目，则返回null。
        结果
        与DataFormat.IMAGE相关联的剪贴板上的图像，如果没有，则为null。

      • hasFiles

        public final boolean hasFiles​()
        获取文件列表（DataFormat.FILES）是否已在此剪贴板上注册。
        结果
        如果hasContent（DataFormat.FILES）返回true，则返回true，否则返回false

      • getFiles

        public final List<File> getFiles​()
        从先前已注册的剪贴板获取文件列表。 这相当于调用getContent(DataFormat.FILES) 。 如果不存在这样的条目，则返回null。
        结果
        与DataFormat.FILES关联的剪贴板上的文件列表，如果没有，则为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClipboardContent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class ClipboardContent

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.HashMap<DataFormat,Object>
        • javafx.scene.input.ClipboardContent
  • All Implemented Interfaces:
    Serializable ， Cloneable ， Map<DataFormat,Object>

    public class ClipboardContent
extends HashMap<DataFormat,Object>
    数据容器Clipboard数据。 它可以容纳多种数据格式的数据。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClipboardContent​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      List<File> getFiles​()
      从 ClipboardContent获取的文件列表。
      String getHtml​()
      从以前已经放置的 ClipboardContent获取HTML字符串。
      Image getImage​()
      从 ClipboardContent获取图像，以前已被放置。
      String getRtf​()
      从 ClipboardContent获取RTF字符串。
      String getString​()
      从以前已经放置的 ClipboardContent获取纯文本字符串。
      String getUrl​()
      获取先前已被放置的 ClipboardContent的URL字符串。
      boolean hasFiles​()
      获取文件列表（ DataFormat.FILES ）是否已被放入此 ClipboardContent 。
      boolean hasHtml​()
      获取HTML字符串（ DataFormat.HTML ）是否已被放入此 ClipboardContent 。
      boolean hasImage​()
      获取图像（ DataFormat.IMAGE ）是否已被放入此 ClipboardContent 。
      boolean hasRtf​()
      获取RTF字符串（ DataFormat.RTF ）是否已被放入此 ClipboardContent 。
      boolean hasString​()
      获取是否将纯文本字符串（ DataFormat.PLAIN_TEXT ）放入此 ClipboardContent 。
      boolean hasUrl​()
      获取是否 DataFormat.URL URL字符串（ DataFormat.URL ）放入此 ClipboardContent 。
      boolean putFiles​(List<File> files)
      将文件列表放入 ClipboardContent 。
      boolean putFilesByPath​(List<String> filePaths)
      根据文件路径将文件列表放入 ClipboardContent 。
      boolean putHtml​(String html)
      将一个HTML字符串放入 ClipboardContent 。
      boolean putImage​(Image i)
      将图像放入 ClipboardContent 。
      boolean putRtf​(String rtf)
      将RTF字符串放入 ClipboardContent 。
      boolean putString​(String s)
      将纯文本字符串放入 ClipboardContent 。
      boolean putUrl​(String url)
      将一个URL字符串放入 ClipboardContent 。

      • Methods inherited from class java.util.AbstractMap

        equals, hashCode, toString

      • Methods inherited from class java.util.HashMap

        clear, clone, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entrySet, forEach, get, getOrDefault, isEmpty, keySet, merge, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

      • Methods inherited from interface java.util.Map

        entry, equals, hashCode, of, of, of, of, of, of, of, of, of, of, of, ofEntries

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ClipboardContent

        public ClipboardContent​()

    • 方法详细信息

      • hasString

        public final boolean hasString​()
        获取是否将纯文本字符串（ DataFormat.PLAIN_TEXT ）放入此 ClipboardContent 。
        结果
        如果 containsKey(DataFormat.PLAIN_TEXT)返回true，则返回true，否则返回false

      • putString

        public final boolean putString​(String s)
        将纯文本字符串放入ClipboardContent 。 这相当于调用put(DataFormat.PLAIN_TEXT, s) 。 将此值设置为null可以有效地从ClipboardContent清除它。
        参数
        s - 要放置的字符串。 这可能是空的。
        结果
        总是真的（字符串总是成功放置）

      • getString

        public final String getString​()
        从以前放置的ClipboardContent获取纯文本字符串。 这相当于调用get(DataFormat.PLAIN_TEXT) 。 如果不存在这样的条目，则返回null。
        结果
        在字符串 ClipboardContent关联 DataFormat.PLAIN_TEXT或null如果没有一个。

      • hasUrl

        public final boolean hasUrl​()
        获取一个URL字符串（ DataFormat.URL ）是否已被放入此 ClipboardContent 。
        结果
        如果 containsKey(DataFormat.URL)返回true，则返回true，否则返回false

      • putUrl

        public final boolean putUrl​(String url)
        将一个URL字符串放入ClipboardContent 。 这相当于调用put(DataFormat.URL, url) 。 将此值设置为null可以有效地将其从ClipboardContent清除。
        参数
        url - 要放置的字符串。 这可能是空的。
        结果
        始终为真（URL始终成功放置）

      • getUrl

        public final String getUrl​()
        从先前已被放置的ClipboardContent获取URL字符串。 这相当于调用get(DataFormat.URL) 。 如果不存在这样的条目，则返回null。
        结果
        在字符串 ClipboardContent关联 DataFormat.URL或null如果没有一个。

      • hasHtml

        public final boolean hasHtml​()
        获取HTML字符串（ DataFormat.HTML ）是否已被放入此 ClipboardContent 。
        结果
        如果 containsKey(DataFormat.HTML)返回true，则返回true，否则返回false

      • putHtml

        public final boolean putHtml​(String html)
        将一个HTML字符串放入ClipboardContent 。 这相当于调用put(DataFormat.HTML, html) 。 将此值设置为null可以有效地从ClipboardContent清除它。
        参数
        html - 要放置的字符串。 这可能是空的。
        结果
        总是真的（HTML总是成功放置）

      • getHtml

        public final String getHtml​()
        从先前已经放置的ClipboardContent获取HTML字符串。 这相当于调用get(DataFormat.HTML) 。 如果不存在这样的条目，则返回null。
        结果
        在字符串 ClipboardContent关联 DataFormat.HTML或null如果没有一个。

      • hasRtf

        public final boolean hasRtf​()
        获取RTF字符串（ DataFormat.RTF ）是否已被放入此 ClipboardContent 。
        结果
        如果 containsKey(DataFormat.RTF)返回true，则返回true，否则返回false

      • putRtf

        public final boolean putRtf​(String rtf)
        将一个RTF字符串放入ClipboardContent 。 这相当于调用put(DataFormat.RTF, rtf) 。 将此值设置为null可以有效地将其从ClipboardContent清除。
        参数
        rtf - 要放置的字符串。 这可能是空的。
        结果
        总是真的（RTF总是成功放置）

      • getRtf

        public final String getRtf​()
        从以前放置的ClipboardContent获取RTF字符串。 这相当于调用get(DataFormat.RTF) 。 如果不存在这样的条目，则返回null。
        结果
        在字符串 ClipboardContent关联 DataFormat.RTF或null如果没有一个。

      • hasImage

        public final boolean hasImage​()
        获取图像（ DataFormat.IMAGE ）是否已被放入此 ClipboardContent 。
        结果
        如果 containsKey(DataFormat.IMAGE)返回true，则返回true，否则返回false

      • putImage

        public final boolean putImage​(Image i)
        将图像放入ClipboardContent 。 这相当于调用put(DataFormat.IMAGE, i) 。 将此值设置为null可以有效地从ClipboardContent清除它。 当以这种方式将图像放置在剪贴板上时，将依赖于操作系统的图像加载到剪贴板上（例如Mac上的TIFF或Windows上的DIB）。
        参数
        i - 要放置的图像。 这可能是空的。
        结果
        总是真的（图像总是成功放置）

      • getImage

        public final Image getImage​()
        从ClipboardContent获取图像，以前已经被放置。 这相当于调用get(DataFormat.IMAGE) 。 如果不存在这样的条目，则返回null。
        结果
        在图像 ClipboardContent关联 DataFormat.IMAGE或null如果没有一个。

      • hasFiles

        public final boolean hasFiles​()
        获取文件列表（ DataFormat.FILES ）是否已被放置到此 ClipboardContent 。
        结果
        如果 containsKey(DataFormat.FILES)返回true，则返回true，否则返回false

      • putFiles

        public final boolean putFiles​(List<File> files)
        将文件列表放入ClipboardContent 。 这相当于调用put(DataFormat.FILES, files) 。 将此值设置为null可以有效地将其从ClipboardContent清除。
        参数
        files - 要放置的文件。 这可能是空的。
        结果
        始终为真（文件始终成功放置）

      • putFilesByPath

        public final boolean putFilesByPath​(List<String> filePaths)
        根据文件路径将文件列表放入ClipboardContent 。 这只是构建文件列表并调用putFiles(java.util.List<java.io.File>)方法的方便方法。
        参数
        filePaths - 要放置的文件。 这可能是空的。
        结果
        始终为真（文件始终成功放置）

      • getFiles

        public final List<File> getFiles​()
        从ClipboardContent获取以前已经被放置的文件列表。 这相当于调用get(DataFormat.FILES) 。 如果不存在这样的条目，则返回null。
        结果
        文件在列表 ClipboardContent关联 DataFormat.FILES或null如果没有一个。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ContextMenuEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class ContextMenuEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.ContextMenuEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class ContextMenuEvent
extends InputEvent
    当用户请求上下文菜单时，会发生此事件。 上下文菜单可以由鼠标或键盘触发。 用于请求菜单的鼠标或键盘事件的确切顺序是特定于平台的。 例如，在Windows上，Shift + F10请求一个上下文菜单。

    事件坐标包含上下文菜单的默认位置。 对于鼠标触发的事件，它是鼠标光标的位置，对于键盘触发的事件，它是当前焦点所有者（这是事件的目标）范围内的一点。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<ContextMenuEvent> ANY
      所有上下文菜单事件类型的常用超类型。
      static EventType<ContextMenuEvent> CONTEXT_MENU_REQUESTED
      当请求上下文菜单时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ContextMenuEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      EventType<ContextMenuEvent> getEventType​()
      获取此事件的事件类型。
      PickResult getPickResult​()
      返回有关选择的信息。
      double getSceneX​()
      返回事件相对于包含ContextMenuEvent源的 Scene的原点的水平位置。
      double getSceneY​()
      返回事件相对于包含ContextMenuEvent源的 Scene的原点的垂直位置。
      double getScreenX​()
      返回事件的绝对水平位置。
      double getScreenY​()
      返回事件的绝对垂直位置。
      double getX​()
      事件的水平位置相对于ContextMenuEvent的来源的原点。
      double getY​()
      事件的相对于ContextMenuEvent源的起始位置的垂直位置。
      double getZ​()
      事件的相对于MouseEvent源的来源的深度位置。
      boolean isKeyboardTrigger​()
      确定此事件是源自键盘。
      String toString​()
      返回此 ContextMenuEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • CONTEXT_MENU_REQUESTED

        public static final EventType<ContextMenuEvent> CONTEXT_MENU_REQUESTED
        当请求上下文菜单时，会发生此事件。

      • ANY

        public static final EventType<ContextMenuEvent> ANY
        所有上下文菜单事件类型的常用超类型。
        从以下版本开始：
        JavaFX 8.0

    • 构造方法详细信息

      • ContextMenuEvent

        public ContextMenuEvent​(Object source,
                        EventTarget target,
                        EventType<ContextMenuEvent> eventType,
                        double x,
                        double y,
                        double screenX,
                        double screenY,
                        boolean keyboardTrigger,
                        PickResult pickResult)
        构造新的ContextMenu事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        x - 相对于场景的x
        y - 相对于现场的y
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        keyboardTrigger - 如果此事件是由键盘触发的， keyboardTrigger true。
        pickResult - 挑结果。 可以为null，在这种情况下，基于场景坐标和目标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

      • ContextMenuEvent

        public ContextMenuEvent​(EventType<ContextMenuEvent> eventType,
                        double x,
                        double y,
                        double screenX,
                        double screenY,
                        boolean keyboardTrigger,
                        PickResult pickResult)
        构造具有空源和目标的新ContextMenu事件。
        参数
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        keyboardTrigger - 如果此事件是由键盘触发的， keyboardTrigger true。
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • copyFor

        public ContextMenuEvent copyFor​(Object newSource,
                                EventTarget newTarget)
        描述从类别复制Event
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • getEventType

        public EventType<ContextMenuEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 InputEvent
        结果
        事件类型

      • isKeyboardTrigger

        public boolean isKeyboardTrigger​()
        确定此事件是源自键盘。
        结果
        如果事件是由键盘造成的，则为true

      • getX

        public final double getX​()
        事件的水平位置相对于ContextMenuEvent的来源的原点。 有关此事件的协调语义的更多信息，请参阅ContextMenuEvent的一般说明。
        结果
        事件的水平位置相对于ContextMenuEvent的源的起点。

      • getY

        public final double getY​()
        事件的相对于ContextMenuEvent源的起始位置的垂直位置。 有关此事件的协调语义的更多信息，请参阅ContextMenuEvent的一般说明。
        结果
        事件相对于ContextMenuEvent源的起点的垂直位置。

      • getZ

        public final double getZ​()
        事件的相对于MouseEvent源的来源的深度位置。
        结果
        事件的相对于MouseEvent源的起点的深度位置。
        从以下版本开始：
        JavaFX 8.0

      • getScreenX

        public final double getScreenX​()
        返回事件的绝对水平位置。 有关此事件的协调语义的更多信息，请参阅ContextMenuEvent的一般说明。
        结果
        绝对水平位置的事件

      • getScreenY

        public final double getScreenY​()
        返回事件的绝对垂直位置。 有关此事件的协调语义的更多信息，请参阅ContextMenuEvent的一般说明。
        结果
        事件的绝对垂直位置

      • getSceneX

        public final double getSceneX​()
        返回事件相对于包含ContextMenuEvent源的Scene的原点的水平位置。 如果节点不在一个Scene ，那么该值相对于ContextMenuEvent节点最根的父节点的boundsInParent。 有关此事件的协调语义的更多信息，请参阅ContextMenuEvent的一般说明。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        事件的水平位置相对于包含ContextMenuEvent的源的 Scene的原点

      • getSceneY

        public final double getSceneY​()
        返回事件相对于包含ContextMenuEvent源的Scene的原点的垂直位置。 如果节点不在一个Scene ，那么该值是相对于ContextMenuEvent节点最根的父节点的boundsInParent。 有关此事件的协调语义的更多信息，请参阅ContextMenuEvent的一般说明。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        事件的垂直位置相对于包含ContextMenuEvent的源的 Scene的原点

      • getPickResult

        public final PickResult getPickResult​()
        返回有关选择的信息。
        结果
        新的PickResult对象包含有关选择的信息
        从以下版本开始：
        JavaFX 8.0

      • toString

        public String toString​()
        返回此 ContextMenuEvent对象的字符串表示形式。
        重写：
        toString EventObject
        结果
        这个 ContextMenuEvent对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DataFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class DataFormat

  • java.lang.Object
    • javafx.scene.input.DataFormat

  • public class DataFormat
extends Object
    数据格式标识符用作识别存储在剪贴板/拖板上的数据的手段。
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static DataFormat FILES
      表示文件列表。
      static DataFormat HTML
      表示HTML格式的字符串。
      static DataFormat IMAGE
      一种特殊的平台特定图像类型，例如通常用于剪贴板并与其他应用程序广泛互操作。
      static DataFormat PLAIN_TEXT
      表示纯文本字符串。
      static DataFormat RTF
      表示RTF格式的字符串
      static DataFormat URL
      表示一个编码为String的URL

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataFormat​(String... ids)
      创建一个新的DataFormat，指定与此数据格式相关联的ids集。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      Set<String> getIdentifiers​()
      获取此DataFormat的不可修改的标识符集。
      int hashCode​()
      返回此 DataFormat对象的哈希码。
      static DataFormat lookupMimeType​(String mimeType)
      查找之前使用给定的MIME类型创建的DataFormat作为其IDID之一。
      String toString​()
      返回此 DataFormat对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • PLAIN_TEXT

        public static final DataFormat PLAIN_TEXT
        表示纯文本字符串。

      • HTML

        public static final DataFormat HTML
        表示HTML格式的字符串。

      • RTF

        public static final DataFormat RTF
        表示RTF格式的字符串

      • URL

        public static final DataFormat URL
        表示一个编码为String的URL

      • IMAGE

        public static final DataFormat IMAGE
        一种特殊的平台特定图像类型，例如通常用于剪贴板并与其他应用程序广泛互操作。 例如，在Mac上，这可能最终是一个TIFF，而在Windows上它可能是一个DIB（与设备无关的位图）。

      • FILES

        public static final DataFormat FILES
        表示文件列表。

    • 构造方法详细信息

      • DataFormat

        public DataFormat​(String... ids)
        创建一个新的DataFormat，指定与此数据格式相关联的ids集。 通常，ids是一种或多种MIME类型。 对于每个ID，与此DataFormat关联的任何数据将被注册在剪贴板上。 例如，假设我有以下几个：
           DataFormat fmt = new DataFormat("text/foo", "text/bar"); Clipboard clipboard = Clipboard.getSystemClipboard(); ClipboardContent content = new ClipboardContent(); content.put(fmt, "Hello"); clipboard.setContent(content);
        使用上面的代码，如果我要在剪贴板上看，我会在剪贴板上找到“text / foo”和“text / bar”两个字符串“Hello”。

        请注意，在某些情况下，ID可能受到平台限制。 例如，Swing需要一个mime类型，所以如果一个id不是“type / subtype”格式，则不可能将数据从/ 拖到JFXPanel 。

        参数
        ids - 用于在剪贴板上表示此DataFormat的一组ids。
        异常
        IllegalArgumentException - 如果给定的MIME类型之一已经分配给另一个DataFormat。

    • 方法详细信息

      • getIdentifiers

        public final Set<String> getIdentifiers​()
        获取此DataFormat的不可修改的标识符集。
        结果
        一个不可修改的集，从不为空。

      • toString

        public String toString​()
        返回此 DataFormat对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 DataFormat对象的字符串表示形式。

      • hashCode

        public int hashCode​()
        返回此 DataFormat对象的哈希码。
        重写：
        hashCode Object
        结果
        这个 DataFormat对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果这个对象等于obj参数; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • lookupMimeType

        public static DataFormat lookupMimeType​(String mimeType)
        查找之前使用给定的MIME类型创建的DataFormat作为其IDID之一。
        参数
        mimeType - 如果为null或空字符串，则返回null。
        结果
        匹配的DataFormat
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Dragboard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class Dragboard

  • java.lang.Object
    • javafx.scene.input.Clipboard
      • javafx.scene.input.Dragboard

  • public final class Dragboard
extends Clipboard
    一个拖放具体的Clipboard 。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Image getDragView​()
      获取用作拖动视图的图像。
      double getDragViewOffsetX​()
      获取拖动视图图像光标的x位置。
      double getDragViewOffsetY​()
      获取拖动视图图像光标的y位置。
      Set<TransferMode> getTransferModes​()
      获取由此拖动操作的源支持的一组传输模式。
      void setDragView​(Image image)
      设置拖放手势中传输的数据的视觉表示。
      void setDragView​(Image image, double offsetX, double offsetY)
      设置拖放手势中传输的数据的视觉表示。
      void setDragViewOffsetX​(double offsetX)
      设置拖动视图图像光标的x位置。
      void setDragViewOffsetY​(double offsetY)
      设置拖动视图图像光标的y位置。

      • Methods inherited from class javafx.scene.input.Clipboard

        clear, getContent, getContentTypes, getFiles, getHtml, getImage, getRtf, getString, getSystemClipboard, getUrl, hasContent, hasFiles, hasHtml, hasImage, hasRtf, hasString, hasUrl, setContent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getTransferModes

        public final Set<TransferMode> getTransferModes​()
        获取由此拖动操作的源支持的一组传输模式。
        结果
        一组支持的传输模式

      • setDragView

        public void setDragView​(Image image,
                        double offsetX,
                        double offsetY)
        设置拖放手势中传输的数据的视觉表示。 使用给定的图像进行拖动视图，其中offsetX和offsetY指定图像上的光标位置。 只有在DRAG_DETECTED处理程序中启动拖放操作时才应该调用此方法，在其他时候调用它不会有任何影响。
        参数
        image - 用于拖动视图的图像
        offsetX - 光标在图像上的x位置
        offsetY - 光标在图像上的y位置
        从以下版本开始：
        JavaFX 8.0

      • setDragView

        public void setDragView​(Image image)
        设置拖放手势中传输的数据的视觉表示。 只有在DRAG_DETECTED处理程序中启动拖放操作时才应该调用此方法，在其他时候调用它不会有任何影响。
        参数
        image - 用于拖动视图的图像
        从以下版本开始：
        JavaFX 8.0

      • setDragViewOffsetX

        public void setDragViewOffsetX​(double offsetX)
        设置拖动视图图像光标的x位置。 只有在DRAG_DETECTED处理程序中启动拖放操作时才应该调用此方法，在其他时候调用它不会有任何影响。
        参数
        offsetX - 光标在图像上的x位置
        从以下版本开始：
        JavaFX 8.0

      • setDragViewOffsetY

        public void setDragViewOffsetY​(double offsetY)
        设置拖动视图图像光标的y位置。 只有在DRAG_DETECTED处理程序中启动拖放操作时才应该调用此方法，在其他时候调用它不会有任何影响。
        参数
        offsetY - 光标在图像上的y位置
        从以下版本开始：
        JavaFX 8.0

      • getDragView

        public Image getDragView​()
        获取用作拖动视图的图像。 只有在DRAG_DETECTED处理程序中启动拖放操作时，此方法才返回有意义的值，在其他时间返回null。
        结果
        该图像用作拖动视图
        从以下版本开始：
        JavaFX 8.0

      • getDragViewOffsetX

        public double getDragViewOffsetX​()
        获取拖动视图图像光标的x位置。 该方法仅在DRAG_DETECTED处理程序中启动拖放操作时才返回有意义的值，在其他时间返回0。
        结果
        x光标在图像上的位置
        从以下版本开始：
        JavaFX 8.0

      • getDragViewOffsetY

        public double getDragViewOffsetY​()
        获取拖动视图图像光标的y位置。 该方法仅在DRAG_DETECTED处理程序中启动拖放操作时才返回有意义的值，在其他时间返回0。
        结果
        y光标在图像上的位置
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DragEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class DragEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.DragEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class DragEvent
extends InputEvent
    拖动事件在拖放手势时替换鼠标事件。 压力释放和拖放手势之间的区别描述于MouseEvent 。

    可以通过调用DRAG_DETECTED事件处理程序中的startDragAndDrop() （节点或场景）来启动拖放手势。 此时将要传输的数据放置到dragBoard 。

    拖动输入/退出事件的行为与鼠标输入/退出事件类似，请参阅MouseEvent概述。

    拖动源：启动拖放手势

    当检测到拖动手势时，应用程序可以决定是否启动拖放手势，或者继续按下按钮释放手势。

    默认拖动检测机制使用鼠标移动与按下的按钮结合滞后。 应用程序可以增加此行为。 每个MOUSE_PRESSED和MOUSE_DRAGGED事件都有一个dragDetect标志，用于确定是否检测到拖动手势。 该标志的默认值取决于默认检测机制，可以通过调用事件处理程序中的setDragDetect()进行修改。 当处理其中一个事件以dragDetect标志设置为true结束时，将DRAG_DETECTED MouseEvent发送到潜在的手势源（按下鼠标按钮的对象）。 此事件通知手势检测。

    在DRAG_DETECTED事件处理程序中，如果在节点或场景上调用startDragAndDrop()方法，并将拖动的数据提供给所返回的Dragboard ，则startDragAndDrop()所调用的对象视为手势源，并启动拖放手势。 Dragboard具有系统剪贴板功能，特别用于拖放数据传输。

    startDragAndDrop()方法需要一组由手势源支持的TransferMode 。 例如，只传递TransferMode.COPY表示手势源仅允许复制数据，而不是移动或引用。

    以下示例显示了一个简单的拖放源：

      Rectangle rect = new Rectangle(100, 100);
rect.setOnDragDetected(new EventHandler<MouseEvent>() {
    @Override public void handle(MouseEvent event) {
        Dragboard db = startDragAndDrop(TransferMode.ANY);
        ClipboardContent content = new ClipboardContent();
        content.putString("Hello!");
        db.setContent(content);
        event.consume();
    }
});

    潜在下降目标

    拖放手势已被启动之后，任何物体（ Node ， Scene在其上拖动鼠标）是一种潜在的放置目标。

    当鼠标拖动到潜在的下降目标的边界时，潜在的目标将获得一个DRAG_ENTERED事件。 当鼠标拖动到潜在目标的边界之外时，它会获得DRAG_EXITED事件。 还有起泡的DRAG_ENTERED_TARGET和DRAG_EXITED_TARGET变种。 他们的行为与鼠标输入/退出事件相似，请参阅MouseEvent概述。

    潜在的投放目标可以决定改变其外观，让用户知道拖放的数据可以丢弃。 这可以在DRAG_OVER事件处理程序中，基于鼠标的位置来完成。 另一个选择是在DRAG_ENTERED和DRAG_EXITED处理程序中更改潜在目标的外观。

    在DRAG_OVER事件处理程序中，潜在的丢弃目标具有使其知道它是实际目标的能力。 这是通过调用acceptTransferModes(TransferMode...)的事件，通过传输模式，它愿意接受。 如果在事件传送期间没有被调用 ，或者如果手势源不支持所传送的传送模式，则潜在的丢弃目标不被认为是实际的丢弃目标 。

    通过致电acceptTransferModes(TransferMode...)决定天气接受事件时，应考虑Dragboard上可用的数据类型。 访问Dragboard由getDragboard()提供。

    当接受一个事件时，潜在的手势目标决定哪一个TransferMode被接受。 要做出决定，可以使用DragBoard.getTransferModes() （由手势源支持的传输模式的集合）和DragEvent.getTransferMode() （由平台发布的默认传输模式，由关键修饰符驱动）。 将更多的传输模式传递到acceptTransferModes(TransferMode...)方法是acceptTransferModes(TransferMode...) 。 在这种情况下，它代表应用程序做出决定（如果手势源支持并由手势目标接受，则选择默认模式，否则选择支持和接受的最常见模式）。 DRAG_DROPPED事件的getTransferMode()稍后报告DRAG_OVER事件处理程序接受的传输模式。

    当鼠标按钮被释放时，拖放手势结束。 如果这种情况发生在通过手势源支持的传输模式接受的DRAG_OVER事件的手势目标上， DRAG_OVER将DRAG_DROPPED事件发送到手势目标。 在其处理程序中，手势目标可以访问拖板上的数据。 数据传输（或决定不传输）后，手势需要通过调用setDropCompleted(Boolean)完成。 Boolean参数表示数据是否已成功传输。 如果没有被调用，手势被认为是不成功的。

    以下示例显示了文本数据的简单拖放目标：

      Rectangle rect = new Rectangle(100, 100);

rect.setOnDragOver(new EventHandler<DragEvent>() {
    @Override public void handle(DragEvent event) {
        Dragboard db = event.getDragboard();
        if (db.hasString()) {
            event.acceptTransferModes(TransferMode.COPY_OR_MOVE);
        }
        event.consume();
    }
});

rect.setOnDragDropped(new EventHandler<DragEvent>() {
    @Override public void handle(DragEvent event) {
        Dragboard db = event.getDragboard();
        boolean success = false;
        if (db.hasString()) {
            System.out.println("Dropped: " + db.getString());
            success = true;
        }
        event.setDropCompleted(success);
        event.consume();
    }
});

    拖动源：完成拖放手势

    手势完成后，无论成功或不成功的数据传输或被取消， DRAG_DONE事件都将发送到手势源。 事件的getTransferMode()方法向手势源指示数据传输是如何完成的。 如果传输模式具有值MOVE ，则允许源清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 如果它的值为null ，则拖放手势将结束，而不会传输任何数据。 这可能是因为不是放置目标的节点上的鼠标释放事件，或者用户按ESC键取消拖放手势，或者通过手势目标报告不成功的数据传输。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<DragEvent> ANY
      所有拖动事件类型的常用超类型。
      static EventType<DragEvent> DRAG_DONE
      数据丢弃在放置目标上之后，这种事件就发生在拖放手势源上。
      static EventType<DragEvent> DRAG_DROPPED
      当在拖放目标上拖放手势时释放鼠标按钮时，会发生此事件。
      static EventType<DragEvent> DRAG_ENTERED
      当拖动手势进入节点时，会发生此事件。
      static EventType<DragEvent> DRAG_ENTERED_TARGET
      当拖动手势进入节点时，会发生此事件。
      static EventType<DragEvent> DRAG_EXITED
      当拖动手势退出节点时，会发生此事件。
      static EventType<DragEvent> DRAG_EXITED_TARGET
      当拖动手势退出节点时，会发生此事件。
      static EventType<DragEvent> DRAG_OVER
      当拖动手势在该节点内进行时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void acceptTransferModes​(TransferMode... transferModes)
      接受这个 DragEvent ，选择拖放操作的传输模式。
      DragEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      DragEvent copyFor​(Object source, EventTarget target, Object gestureSource, Object gestureTarget, EventType<DragEvent> eventType)
      创建给定字段替换的给定拖动事件的副本。
      DragEvent copyFor​(Object source, EventTarget target, EventType<DragEvent> type)
      创建给定字段替换的给定拖动事件的副本。
      TransferMode getAcceptedTransferMode​()
      获得潜在目标接受的传输模式。
      Object getAcceptingObject​()
      接受拖动的对象。
      Dragboard getDragboard​()
      可用于传输数据的拖板。
      EventType<DragEvent> getEventType​()
      获取此事件的事件类型。
      Object getGestureSource​()
      拖放手势的源对象。
      Object getGestureTarget​()
      拖放手势的目标对象。
      PickResult getPickResult​()
      返回有关选择的信息。
      double getSceneX​()
      返回事件相对于包含DragEvent源的 Scene的原点的水平位置。
      double getSceneY​()
      返回事件相对于包含DragEvent源的 Scene的原点的垂直位置。
      double getScreenX​()
      返回事件的绝对水平位置。
      double getScreenY​()
      返回事件的绝对垂直位置。
      TransferMode getTransferMode​()
      数据传输模式。
      double getX​()
      事件相对于DragEvent源的原点的水平位置。
      double getY​()
      事件相对于DragEvent源的原点的垂直位置。
      double getZ​()
      事件的相对于MouseEvent源的来源的深度位置。
      boolean isAccepted​()
      表示此事件是否已被接受。
      boolean isDropCompleted​()
      是否 setDropCompleted(true)已被呼吁这个事件。
      void setDropCompleted​(boolean isTransferDone)
      表示在 DRAG_DROPPED事件处理程序中， DragEvent传输处理已成功完成。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<DragEvent> ANY
        所有拖动事件类型的常用超类型。

      • DRAG_ENTERED_TARGET

        public static final EventType<DragEvent> DRAG_ENTERED_TARGET
        当拖动手势进入节点时，会发生此事件。 这是冒泡的变体，它也被传递给输入节点的所有父母（除非被消耗）。 当不希望有关输入节点子节点的通知时，应使用DRAG_ENTERED事件处理程序。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling which is similar

      • DRAG_ENTERED

        public static final EventType<DragEvent> DRAG_ENTERED
        当拖动手势进入节点时，会发生此事件。 此事件类型仅传递到输入的节点，如果父母要过滤或获取冒泡事件，则需要使用DRAG_ENTERED_TARGET 。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling which is similar

      • DRAG_EXITED_TARGET

        public static final EventType<DragEvent> DRAG_EXITED_TARGET
        当拖动手势退出节点时，会发生此事件。 这是冒泡的变体，它也被传递给受影响的节点的所有父母（除非被消耗）。 当不希望有关退出某些节点的子节点的通知时，应使用DRAG_EXITED事件处理程序。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling which is similar

      • DRAG_EXITED

        public static final EventType<DragEvent> DRAG_EXITED
        当拖动手势退出节点时，会发生此事件。 此事件类型仅传递到退出的节点，如果父节点要过滤它或获取冒泡事件，则需要使用DRAG_EXITED_TARGET 。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling which is similar

      • DRAG_OVER

        public static final EventType<DragEvent> DRAG_OVER
        当拖动手势在该节点内进行时，会发生此事件。

      • DRAG_DROPPED

        public static final EventType<DragEvent> DRAG_DROPPED
        当在拖放目标上拖放手势时释放鼠标按钮时，会发生此事件。 DragEvent的dragboard中的数据传输应该发生在这个事件的处理程序中。

      • DRAG_DONE

        public static final EventType<DragEvent> DRAG_DONE
        数据丢弃在放置目标上之后，这种事件就发生在拖放手势源上。 事件的transferMode显示刚刚发生的下降目标。 如果transferMode具有值MOVE ，则源可以清除其数据。 清除源的数据给用户通过拖放手势移动了数据的适当外观。 甲transferMode具有值NONE指示拖放手势期间没有数据被转移。

    • 构造方法详细信息

      • DragEvent

        public DragEvent​(Object source,
                 EventTarget target,
                 EventType<DragEvent> eventType,
                 Dragboard dragboard,
                 double x,
                 double y,
                 double screenX,
                 double screenY,
                 TransferMode transferMode,
                 Object gestureSource,
                 Object gestureTarget,
                 PickResult pickResult)
        构造新的DragEvent事件。 对于DRAG_DROPPED和DRAG_DONE事件类型， accepted状态和acceptedTransferMode根据通过的transferMode进行设置。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        dragboard - 事件的拖板。
        x - 相对于场景的x。
        y - 相对于场景的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        transferMode - 事件的传输模式。
        gestureSource - 事件的DnD手势的来源。
        gestureTarget - 事件的DnD手势的目标。
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标和目标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

      • DragEvent

        public DragEvent​(EventType<DragEvent> eventType,
                 Dragboard dragboard,
                 double x,
                 double y,
                 double screenX,
                 double screenY,
                 TransferMode transferMode,
                 Object gestureSource,
                 Object gestureTarget,
                 PickResult pickResult)
        构造具有空源和目标的新的DragEvent事件。
        参数
        eventType - 事件的类型。
        dragboard - 事件的拖板。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        transferMode - 事件的传输模式。
        gestureSource - 事件的DnD手势的来源。
        gestureTarget - 事件的DnD手势的目标。
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • copyFor

        public DragEvent copyFor​(Object source,
                         EventTarget target,
                         Object gestureSource,
                         Object gestureTarget,
                         EventType<DragEvent> eventType)
        创建给定字段替换的给定拖动事件的副本。
        参数
        source - 复制事件的新来源
        target - 复制事件的新目标
        gestureSource - 新的手势源。
        gestureTarget - 新的手势目标。
        eventType - 新的eventType
        结果
        事件副本与字段
        从以下版本开始：
        JavaFX 8.0

      • copyFor

        public DragEvent copyFor​(Object newSource,
                         EventTarget newTarget)
        描述从类复制： Event
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • copyFor

        public DragEvent copyFor​(Object source,
                         EventTarget target,
                         EventType<DragEvent> type)
        创建给定字段替换的给定拖动事件的副本。
        参数
        source - 复制事件的来源
        target - 复制事件的目标
        type - 事件类型
        结果
        事件副本与字段
        从以下版本开始：
        JavaFX 8.0

      • getEventType

        public EventType<DragEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 InputEvent
        结果
        事件类型

      • getX

        public final double getX​()
        事件相对于DragEvent源的原点的水平位置。
        结果
        事件的水平位置相对于DragEvent的来源的起点

      • getY

        public final double getY​()
        事件相对于DragEvent源的原点的垂直位置。
        结果
        事件相对于DragEvent源的起点的垂直位置

      • getZ

        public final double getZ​()
        事件的相对于MouseEvent源的来源的深度位置。
        结果
        事件的相对于MouseEvent源的起点的深度位置
        从以下版本开始：
        JavaFX 8.0

      • getScreenX

        public final double getScreenX​()
        返回事件的绝对水平位置。
        结果
        绝对水平位置的事件

      • getScreenY

        public final double getScreenY​()
        返回事件的绝对垂直位置。
        结果
        事件的绝对垂直位置

      • getSceneX

        public final double getSceneX​()
        返回事件相对于包含DragEvent源的Scene的原点的水平位置。 如果节点不在一个Scene ，那么该值相对于DragEvent节点最根的父节点的boundsInParent。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        事件的水平位置相对于包含DragEvent源的 Scene的原点

      • getSceneY

        public final double getSceneY​()
        返回事件相对于包含DragEvent源的Scene的原点的垂直位置。 如果节点不在一个Scene ，则该值相对于DragEvent节点最根本父级的boundsInParent。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        事件的垂直位置相对于包含DragEvent源的 Scene的原点

      • getPickResult

        public final PickResult getPickResult​()
        返回有关选择的信息。
        结果
        新的PickResult对象包含有关选择的信息
        从以下版本开始：
        JavaFX 8.0

      • getGestureSource

        public final Object getGestureSource​()
        拖放手势的源对象。 手势源是开始拖放操作的对象。 在手势来自另一应用的情况下，值null是有效的。
        结果
        源对象的拖放手势

      • getGestureTarget

        public final Object getGestureTarget​()
        拖放手势的目标对象。 手势目标是接受拖动事件的对象。 值null在拖放手势已被取消或完成而没有发生转移或目前没有事件目标接受拖动事件的情况下有效。
        结果
        拖放手势的目标对象

      • getTransferMode

        public final TransferMode getTransferMode​()
        数据传输模式。 在执行数据传输之前，这是系统根据诸如用户持有某些修饰符的输入事件设置的默认传输模式。 在数据传输的时候（在DRAG_DROPPED事件中）它决定了以前的DRAG_OVER处理程序接受的传输模式。 数据传输后（DRAG_DONE事件）确定传输完成的实际模式。
        结果
        数据传输模式

      • isAccepted

        public final boolean isAccepted​()
        表示此事件是否已被接受。
        Default value:
        假
        结果
        这个事件是否被接受
        另请参见：
        acceptTransferModes(javafx.scene.input.TransferMode...)

      • getAcceptedTransferMode

        public final TransferMode getAcceptedTransferMode​()
        获得潜在目标接受的传输模式。
        结果
        潜在目标接受的转移模式

      • getAcceptingObject

        public final Object getAcceptingObject​()
        接受拖动的对象。
        结果
        接受拖动的对象
        从以下版本开始：
        JavaFX 8.0

      • getDragboard

        public final Dragboard getDragboard​()
        可用于传输数据的拖板。 数据可以放在DRAG_DETECTED鼠标事件的处理程序的这个DRAG_DETECTED 。 可以从DRAG_DROPPED事件的处理程序中的这个拖板复制数据。
        结果
        可用于传输数据的拖板

      • acceptTransferModes

        public void acceptTransferModes​(TransferMode... transferModes)
        接受这个DragEvent ，选择拖放操作的传输模式。 用于指示从DRAG_OVER事件处理程序接收此事件的潜在丢弃目标是丢弃目标。

        它接受传递到此方法并由手势源支持的传输模式之一。 如果可能，它接受默认传输模式，否则是最常见的可接受模式之一。

        参数
        transferModes - 丢弃操作的传输模式。

      • setDropCompleted

        public void setDropCompleted​(boolean isTransferDone)
        表示在DRAG_DROPPED事件处理程序中， DragEvent传输处理已成功完成。 此电话后可能会发生dragboard访问。
        参数
        isTransferDone - true表示传输成功。
        异常
        IllegalStateException - 如果这不是DRAG_DROPPED事件

      • isDropCompleted

        public boolean isDropCompleted​()
        是否 setDropCompleted(true)已被呼吁这个事件。
        结果
        如果已经调用了 setDropCompleted(true) true
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


GestureEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class GestureEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.GestureEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    RotateEvent ， ScrollEvent ， SwipeEvent ， ZoomEvent

    public class GestureEvent
extends InputEvent
    表示手势输入的事件。 手势通常由直接（触摸屏）或间接（轨迹板）触摸事件引起。

    手势的传递取决于底层平台和连接的输入设备的功能。 例如在具有鼠标和键盘的PC上，没有办法产生旋转手势。

    从以下版本开始：
    JavaFX 2.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<GestureEvent> ANY
      所有手势的常用超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType)
      已过时。
      不要使用这个构造函数。 构造空事件。
      protected GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)
      构建新的GestureEvent事件。
      protected GestureEvent​(EventType<? extends GestureEvent> eventType)
      已过时。
      不要使用这个构造函数。 构造空事件。
      protected GestureEvent​(EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)
      构造新的GestureEvent事件，具有空源和目标

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      GestureEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      EventType<? extends GestureEvent> getEventType​()
      获取此事件的事件类型。
      PickResult getPickResult​()
      返回有关选择的信息。
      double getSceneX​()
      获取事件相对于包含事件源的 Scene的原点的水平位置。
      double getSceneY​()
      获取事件相对于包含事件源的 Scene的原点的垂直位置。
      double getScreenX​()
      获取事件的绝对水平位置。
      double getScreenY​()
      获取事件的绝对垂直位置。
      double getX​()
      获取事件相对于事件源的原点的水平位置。
      double getY​()
      获取事件相对于事件源的原点的垂直位置。
      double getZ​()
      事件的相对于MouseEvent源的来源的深度位置。
      boolean isAltDown​()
      指示此事件的Alt修饰符是否关闭。
      boolean isControlDown​()
      指示此事件的“控制”修饰符是否关闭。
      boolean isDirect​()
      指示此手势是由直接或间接输入设备引起的。
      boolean isInertia​()
      指示此事件是否表示已经完成的手势的惯性。
      boolean isMetaDown​()
      表示Meta修饰符在此事件中是否关闭。
      boolean isShiftDown​()
      指示此事件的Shift修饰符是否关闭。
      boolean isShortcutDown​()
      指示主机平台公共快捷方式修饰符在此事件上是否关闭。
      String toString​()
      返回此 GestureEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<GestureEvent> ANY
        所有手势的常用超类型。

    • 构造方法详细信息

      • GestureEvent

        @Deprecated(since="8")
protected GestureEvent​(EventType<? extends GestureEvent> eventType)
        已过时。 不要使用这个构造函数。 构造空事件。
        创建一个新的实例 GestureEvent 。
        参数
        eventType - 事件类型

      • GestureEvent

        @Deprecated(since="8")
protected GestureEvent​(Object source,
                       EventTarget target,
                       EventType<? extends GestureEvent> eventType)
        已过时。 不要使用这个构造函数。 构造空事件。
        创建一个新的 GestureEvent实例。
        参数
        source - 事件源
        target - 事件目标
        eventType - 事件的类型

      • GestureEvent

        protected GestureEvent​(Object source,
                       EventTarget target,
                       EventType<? extends GestureEvent> eventType,
                       double x,
                       double y,
                       double screenX,
                       double screenY,
                       boolean shiftDown,
                       boolean controlDown,
                       boolean altDown,
                       boolean metaDown,
                       boolean direct,
                       boolean inertia,
                       PickResult pickResult)
        构建新的GestureEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按Alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见isDirect()
        inertia - 如果表示已经完成的手势的惯性。
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标和目标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

      • GestureEvent

        protected GestureEvent​(EventType<? extends GestureEvent> eventType,
                       double x,
                       double y,
                       double screenX,
                       double screenY,
                       boolean shiftDown,
                       boolean controlDown,
                       boolean altDown,
                       boolean metaDown,
                       boolean direct,
                       boolean inertia,
                       PickResult pickResult)
        构造新的GestureEvent事件，具有空源和目标
        参数
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见isDirect()
        inertia - 如果表示已经完成的手势的惯性。
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • copyFor

        public GestureEvent copyFor​(Object newSource,
                            EventTarget newTarget)
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被NULL_SOURCE_TARGET值替换。
        重写：
        copyFor Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • getX

        public final double getX​()
        获取事件相对于事件源的原点的水平位置。
        结果
        事件相对于事件来源的水平位置。
        另请参见：
        isDirect()

      • getY

        public final double getY​()
        获取事件相对于事件源的原点的垂直位置。
        结果
        事件相对于事件来源的垂直位置。
        另请参见：
        isDirect()

      • getZ

        public final double getZ​()
        事件的相对于MouseEvent源的来源的深度位置。
        结果
        事件的相对于MouseEvent源的起点的深度位置。
        从以下版本开始：
        JavaFX 8.0

      • getScreenX

        public final double getScreenX​()
        获取事件的绝对水平位置。
        结果
        事件的绝对水平位置
        另请参见：
        isDirect()

      • getScreenY

        public final double getScreenY​()
        获取事件的绝对垂直位置。
        结果
        事件的绝对垂直位置
        另请参见：
        isDirect()

      • getSceneX

        public final double getSceneX​()
        获取事件相对于包含事件源的Scene的原点的水平位置。 如果节点不在一个Scene ，则该值相对于该事件节点的根最多父节点的boundsInParent。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        事件相对于包含事件源的 Scene的原点的水平位置
        另请参见：
        isDirect()

      • getSceneY

        public final double getSceneY​()
        获取事件相对于包含事件源的Scene的原点的垂直位置。 如果节点不在一个Scene ，则该值相对于该事件节点的最大父节点的boundsInParent。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        事件的垂直位置相对于包含事件源的 Scene的原点
        另请参见：
        isDirect()

      • isShiftDown

        public final boolean isShiftDown​()
        指示此事件的Shift修饰符是否关闭。
        结果
        如果Shift修饰符关闭此事件，则为true

      • isControlDown

        public final boolean isControlDown​()
        指示此事件的“控制”修饰符是否关闭。
        结果
        如果Control修饰符在此事件中关闭，则为true

      • isAltDown

        public final boolean isAltDown​()
        指示此事件的Alt修饰符是否关闭。
        结果
        如果Alt修饰符关闭此事件，则为true

      • isMetaDown

        public final boolean isMetaDown​()
        表示Meta修饰符在此事件中是否关闭。
        结果
        如果Meta修饰符关闭此事件，则为true

      • isDirect

        public final boolean isDirect​()
        指示此手势是由直接或间接输入设备引起的。 使用直接输入设备，手势直接在具体坐标处执行，典型的例子是触摸屏。 使用间接设备，间接执行手势，通常将鼠标光标位置用作手势坐标，典型的示例是轨迹。
        结果
        如果此事件是由直接输入设备引起的，则为true

      • isInertia

        public boolean isInertia​()
        指示此事件是否表示已经完成的手势的惯性。
        结果
        如果这是惯性事件，则为真

      • getPickResult

        public final PickResult getPickResult​()
        返回有关选择的信息。
        结果
        新的PickResult对象包含有关选择的信息
        从以下版本开始：
        JavaFX 8.0

      • isShortcutDown

        public final boolean isShortcutDown​()
        指示主机平台公共快捷方式修饰符在此事件上是否关闭。 这个常用的快捷键修饰符是修改器键，通常用于主机平台上的快捷方式。 它在Windows上为例如control和Mac上的meta （命令键）。
        结果
        true如果快捷键修饰符关闭，否则为 false

      • toString

        public String toString​()
        返回此 GestureEvent对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        这个 GestureEvent对象的字符串表示形式。

      • getEventType

        public EventType<? extends GestureEvent> getEventType​()
        描述从类别复制Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 InputEvent
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


InputEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class InputEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    ContextMenuEvent ， DragEvent ， GestureEvent ， InputMethodEvent ， KeyEvent ， MouseEvent ， TouchEvent

    public class InputEvent
extends Event
    指示用户输入的事件。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<InputEvent> ANY
      所有输入事件类型的常用超类型。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      InputEvent​(Object source, EventTarget target, EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
      InputEvent​(EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      EventType<? extends InputEvent> getEventType​()
      获取此事件的事件类型。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<InputEvent> ANY
        所有输入事件类型的常用超类型。

    • 构造方法详细信息

      • InputEvent

        public InputEvent​(EventType<? extends InputEvent> eventType)
        创建新的InputEvent实例。
        参数
        eventType - 事件类型

      • InputEvent

        public InputEvent​(Object source,
                  EventTarget target,
                  EventType<? extends InputEvent> eventType)
        创建新的InputEvent实例。
        参数
        source - 事件源
        target - 事件目标
        eventType - 事件的类型

    • 方法详细信息

      • getEventType

        public EventType<? extends InputEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 Event
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


InputMethodEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class InputMethodEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.InputMethodEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class InputMethodEvent
extends InputEvent
    一个表示底层输入法在Node中通知其文本更改的事件 。

    此事件被传递到扩展TextInputControl的Node对象，当组合文本（组合文本）生成/更改/删除时，输入法提交结果文本或输入方法插入符位置更改。

    在接收到此事件时，应用程序应该向用户显示具有任何视觉反馈属性的合成文本。

    注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.INPUT_METHOD 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<InputMethodEvent> ANY
      所有输入法事件类型的公共超类型。
      static EventType<InputMethodEvent> INPUT_METHOD_TEXT_CHANGED
      InputMethodEvent唯一有效的EventType。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造具有空源和目标的新的InputMethodEvent事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      InputMethodEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      int getCaretPosition​()
      组合文本中的输入法插入位置。
      String getCommitted​()
      作为组合的结果，获取输入法提交的文本。
      ObservableList<InputMethodTextRun> getComposed​()
      获取组合下的文本。
      EventType<InputMethodEvent> getEventType​()
      获取此事件的事件类型。
      String toString​()
      返回此 InputMethodEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INPUT_METHOD_TEXT_CHANGED

        public static final EventType<InputMethodEvent> INPUT_METHOD_TEXT_CHANGED
        InputMethodEvent唯一有效的EventType。

      • ANY

        public static final EventType<InputMethodEvent> ANY
        所有输入法事件类型的公共超类型。
        从以下版本开始：
        JavaFX 8.0

    • 构造方法详细信息

      • InputMethodEvent

        public InputMethodEvent​(Object source,
                        EventTarget target,
                        EventType<InputMethodEvent> eventType,
                        List<InputMethodTextRun> composed,
                        String committed,
                        int caretPosition)
        构造新的InputMethodEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        composed - 组成下的文字
        committed - 由于组合而提交的文本
        caretPosition - 插入符号的当前位置。
        从以下版本开始：
        JavaFX 8.0

      • InputMethodEvent

        public InputMethodEvent​(EventType<InputMethodEvent> eventType,
                        List<InputMethodTextRun> composed,
                        String committed,
                        int caretPosition)
        构造具有空源和目标的新的InputMethodEvent事件。
        参数
        eventType - 事件的类型。
        composed - 组成下的文字
        committed - 由于组合而提交的文本
        caretPosition - 插入符号的当前位置。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getComposed

        public final ObservableList<InputMethodTextRun> getComposed​()
        获取组合下的文本。 应该使用适当的视觉反馈显示此文本，表示每次运行时附带的InputMethodHighlight 。
        结果
        组成文字

      • getCommitted

        public final String getCommitted​()
        作为组合的结果，获取输入法提交的文本。
        结果
        承诺文本

      • getCaretPosition

        public final int getCaretPosition​()
        组合文本中的输入法插入位置。 如果位置为-1，则插入符号应该是不可见的。
        结果
        组合文本中的输入法插入位置

      • toString

        public String toString​()
        返回此 InputMethodEvent对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        这个 InputMethodEvent对象的字符串表示形式。

      • copyFor

        public InputMethodEvent copyFor​(Object newSource,
                                EventTarget newTarget)
        描述从类复制： Event
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • getEventType

        public EventType<InputMethodEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 InputEvent
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


InputMethodHighlight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Enum InputMethodHighlight

  • java.lang.Object
    • java.lang.Enum<InputMethodHighlight>
      • javafx.scene.input.InputMethodHighlight
  • All Implemented Interfaces:
    Serializable ， Comparable<InputMethodHighlight>

    public enum InputMethodHighlight
extends Enum<InputMethodHighlight>
    包含输入法文本的枚举突出显示。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      SELECTED_CONVERTED
      用于所选转换输入法文本的突出显示
      SELECTED_RAW
      用于所选原始输入法文本的突出显示
      UNSELECTED_CONVERTED
      用于未选择的转换输入法文本的突出显示
      UNSELECTED_RAW
      用于未选择的原始输入法文本的突出显示

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static InputMethodHighlight valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static InputMethodHighlight[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNSELECTED_RAW

        public static final InputMethodHighlight UNSELECTED_RAW
        用于未选择的原始输入法文本的突出显示

      • SELECTED_RAW

        public static final InputMethodHighlight SELECTED_RAW
        用于所选原始输入法文本的突出显示

      • UNSELECTED_CONVERTED

        public static final InputMethodHighlight UNSELECTED_CONVERTED
        用于未选择的转换输入法文本的突出显示

      • SELECTED_CONVERTED

        public static final InputMethodHighlight SELECTED_CONVERTED
        用于所选转换输入法文本的突出显示

    • 方法详细信息

      • values

        public static InputMethodHighlight[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (InputMethodHighlight c : InputMethodHighlight.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static InputMethodHighlight valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


InputMethodRequests (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Interface InputMethodRequests

  • public interface InputMethodRequests
    InputMethodRequests定义文本编辑节点必须处理的请求以便处理输入法。 节点可以自己实现这个接口，也可以使用实现它的单独的对象。 必须从节点的getInputMethodRequests方法返回实现此接口的对象。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void cancelLatestCommittedText​()
      从文本编辑节点获取最新提交的文本，并将其从节点的文本正文中删除。
      int getLocationOffset​(int x, int y)
      获取屏幕上指定的绝对x和y坐标的组合文本中的偏移量。
      String getSelectedText​()
      从文本编辑节点获取当前选定的文本。
      Point2D getTextLocation​(int offset)
      获取当前组合文本中指定偏移量的位置，或者在提交文本中获取选择的位置。

    • 方法详细信息

      • getTextLocation

        Point2D getTextLocation​(int offset)
        获取当前组合文本中指定偏移量的位置，或者在提交文本中获取选择的位置。 例如，该信息用于将候选窗口放置在合成文本附近，或者在将插入提交文本的位置附近的合成窗口。
        参数
        offset - 组合文本中的偏移量，如果有合成文本; 否则为空
        结果
        表示偏移的屏幕位置的点

      • getLocationOffset

        int getLocationOffset​(int x,
                      int y)
        获取屏幕上指定的绝对x和y坐标的组合文本中的偏移量。 此信息用于处理鼠标点击和鼠标光标。 偏移量相对于组合文本，因此offset 0表示组合文本的开头。
        参数
        x - 屏幕上的绝对x坐标
        y - 屏幕上的绝对y坐标
        结果
        组合文本中的偏移量。

      • cancelLatestCommittedText

        void cancelLatestCommittedText​()
        从文本编辑节点获取最新提交的文本，并将其从节点的文本正文中删除。 这用于一些输入方法中的“撤消提交”功能，其中提交的文本将恢复到其先前的组合状态。 组合文本将使用InputMethodEvent发送到节点。

      • getSelectedText

        String getSelectedText​()
        从文本编辑节点获取当前选定的文本。 这可以用于各种目的。 其中一个是一些输入法中的“再转换”功能。 在这种情况下，输入法通常会发送一个输入法事件来替换所选择的文本与组合文本。 根据输入法的功能，这可能是所选文本的原始组合文本，文本中任何位置输入的最新合成文本，或从选定文本转换回来的文本版本。
        结果
        最新提交的文本，如果不支持“撤消提交”功能，则为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InputMethodTextRun (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class InputMethodTextRun

  • java.lang.Object
    • javafx.scene.input.InputMethodTextRun
  • All Implemented Interfaces:
    Serializable

    public class InputMethodTextRun
extends Object
implements Serializable
    表示单个运行，其中字符在输入法文本中具有相同的高亮集。

    注意：这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.INPUT_METHOD 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InputMethodTextRun​(String text, InputMethodHighlight highlight)
      构造输入法的单个文本运行。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      InputMethodHighlight getHighlight​()
      获取用于显示此文本的高亮。
      String getText​()
      获取此运行中的文本。
      String toString​()
      返回此 InputMethodTextRun对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InputMethodTextRun

        public InputMethodTextRun​(String text,
                          InputMethodHighlight highlight)
        构造输入法的单个文本运行。
        参数
        text - 文本中的文本运行
        highlight - 文字的突出显示
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getText

        public final String getText​()
        获取此运行中的文本。
        结果
        这个运行中的文本

      • getHighlight

        public final InputMethodHighlight getHighlight​()
        获取用于显示此文本的高亮。
        结果
        用于显示此文本的突出显示

      • toString

        public String toString​()
        返回此 InputMethodTextRun对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of this InputMethodTextRun object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.input (Java SE 9 & JDK 9 )

javafx.scene.input

Interfaces

  • InputMethodRequests

Classes

  • Clipboard
  • ClipboardContent
  • ContextMenuEvent
  • DataFormat
  • Dragboard
  • DragEvent
  • GestureEvent
  • InputEvent
  • InputMethodEvent
  • InputMethodTextRun
  • KeyCharacterCombination
  • KeyCodeCombination
  • KeyCombination
  • KeyCombination.Modifier
  • KeyEvent
  • Mnemonic
  • MouseDragEvent
  • MouseEvent
  • PickResult
  • RotateEvent
  • ScrollEvent
  • SwipeEvent
  • TouchEvent
  • TouchPoint
  • ZoomEvent

Enums

  • InputMethodHighlight
  • KeyCode
  • KeyCombination.ModifierValue
  • MouseButton
  • ScrollEvent.HorizontalTextScrollUnits
  • ScrollEvent.VerticalTextScrollUnits
  • TouchPoint.State
  • TransferMode


javafx.scene.input (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene.input

提供一组用于鼠标和键盘输入事件处理的类。

  • 接口摘要
    接口 描述
    InputMethodRequests
    InputMethodRequests定义文本编辑节点必须处理的请求以便处理输入法。
  • 类摘要
    Class 描述
    Clipboard
    表示操作系统剪贴板，数据可能在例如剪切，复制和粘贴操作期间放置。
    ClipboardContent
    数据容器Clipboard数据。
    ContextMenuEvent
    当用户请求上下文菜单时，会发生此事件。
    DataFormat
    数据格式标识符用作识别存储在剪贴板/拖板上的数据的手段。
    Dragboard
    一个拖放具体的Clipboard 。
    DragEvent
    拖动事件在拖放手势时替换鼠标事件。
    GestureEvent
    表示手势输入的事件。
    InputEvent
    指示用户输入的事件。
    InputMethodEvent
    一个表示底层输入法在Node中通知其文本更改的事件 。
    InputMethodTextRun
    表示单个运行，其中字符在输入法文本中具有相同的高亮集。
    KeyCharacterCombination
    该类表示主键由其字符指定的组合键。
    KeyCodeCombination
    该类代表其主键由其 KeyCode指定的组合键。
    KeyCombination
    表示在键盘快捷键中使用的键组合。
    KeyCombination.Modifier
    此类表示一对修饰符键及其值。
    KeyEvent
    一个事件表明一个击键发生在一个Node 。
    Mnemonic
    创建助记符时使用此类。
    MouseDragEvent
    鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
    MouseEvent
    当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。
    PickResult
    包含pick事件结果的容器对象
    RotateEvent
    旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
    ScrollEvent
    滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。
    SwipeEvent
    滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。
    TouchEvent
    触摸事件表示触摸屏操作。
    TouchPoint
    触摸点表示多点触摸动作的单个点，通常一个手指触摸屏幕。
    ZoomEvent
    缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。
  • 枚举摘要
    Enum 描述
    InputMethodHighlight
    包含输入法文本的枚举突出显示。
    KeyCode
    KeyEvent对象的关键码集。
    KeyCombination.ModifierValue
    ModifierValue指定修改键的状态。
    MouseButton
    按钮名称映射
    ScrollEvent.HorizontalTextScrollUnits
    水平文本滚动单元。
    ScrollEvent.VerticalTextScrollUnits
    垂直的基于文本的滚动单元。
    TouchPoint.State
    表示触摸点的当前状态
    TransferMode
    描述了相对于拖放手势的数据传输模式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.input Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.input

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • javafx.scene.input.ClipboardContent
    • javafx.scene.input.Clipboard
      • javafx.scene.input.Dragboard
    • javafx.scene.input.DataFormat
    • java.util.EventObject (implements java.io.Serializable)
      • javafx.event.Event (implements java.lang.Cloneable)
        • javafx.scene.input.InputEvent
          • javafx.scene.input.ContextMenuEvent
          • javafx.scene.input.DragEvent
          • javafx.scene.input.GestureEvent
            • javafx.scene.input.RotateEvent
            • javafx.scene.input.ScrollEvent
            • javafx.scene.input.SwipeEvent
            • javafx.scene.input.ZoomEvent
          • javafx.scene.input.InputMethodEvent
          • javafx.scene.input.KeyEvent
          • javafx.scene.input.MouseEvent
            • javafx.scene.input.MouseDragEvent
          • javafx.scene.input.TouchEvent
    • javafx.scene.input.InputMethodTextRun (implements java.io.Serializable)
    • javafx.scene.input.KeyCombination
      • javafx.scene.input.KeyCharacterCombination
      • javafx.scene.input.KeyCodeCombination
    • javafx.scene.input.KeyCombination.Modifier
    • javafx.scene.input.Mnemonic
    • javafx.scene.input.PickResult
    • javafx.scene.input.TouchPoint (implements java.io.Serializable)

Interface Hierarchy

  • javafx.scene.input.InputMethodRequests

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.input.InputMethodHighlight
      • javafx.scene.input.KeyCode
      • javafx.scene.input.KeyCombination.ModifierValue
      • javafx.scene.input.MouseButton
      • javafx.scene.input.ScrollEvent.HorizontalTextScrollUnits
      • javafx.scene.input.ScrollEvent.VerticalTextScrollUnits
      • javafx.scene.input.TouchPoint.State
      • javafx.scene.input.TransferMode
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


KeyCharacterCombination (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class KeyCharacterCombination

  • java.lang.Object
    • javafx.scene.input.KeyCombination
      • javafx.scene.input.KeyCharacterCombination

  • public final class KeyCharacterCombination
extends KeyCombination
    该类表示主键由其字符指定的组合键。 这种按键组合取决于用户在按键组合匹配时配置的键盘功能布局。
    从以下版本开始：
    JavaFX 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.input.KeyCombination

        KeyCombination.Modifier, KeyCombination.ModifierValue

    • Field Summary

      • Fields inherited from class javafx.scene.input.KeyCombination

        ALT_ANY, ALT_DOWN, CONTROL_ANY, CONTROL_DOWN, META_ANY, META_DOWN, NO_MATCH, SHIFT_ANY, SHIFT_DOWN, SHORTCUT_ANY, SHORTCUT_DOWN

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyCharacterCombination​(String character, KeyCombination.Modifier... modifiers)
      为指定的主键字符和指定的修饰符列表构造一个 KeyCharacterCombination 。
      KeyCharacterCombination​(String character, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键字符构建一个 KeyCharacterCombination ，并显式指定所有修改键。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      测试这个 KeyCharacterCombination是否等于指定的对象。
      String getCharacter​()
      获取与该组合关联的关键字符。
      String getDisplayText​()
      返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。
      String getName​()
      返回此 KeyCharacterCombination的字符串表示 KeyCharacterCombination 。
      int hashCode​()
      返回此 KeyCharacterCombination的哈希码值。
      boolean match​(KeyEvent event)
      测试此组合是否与给定的 KeyEvent组合键匹配。

      • Methods inherited from class javafx.scene.input.KeyCombination

        getAlt, getControl, getMeta, getShift, getShortcut, keyCombination, toString, valueOf

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • KeyCharacterCombination

        public KeyCharacterCombination​(String character,
                               KeyCombination.ModifierValue shift,
                               KeyCombination.ModifierValue control,
                               KeyCombination.ModifierValue alt,
                               KeyCombination.ModifierValue meta,
                               KeyCombination.ModifierValue shortcut)
        为指定的主键字符构建一个KeyCharacterCombination ，并显式指定所有修改键。 每个修饰键可设置为PRESSED ， RELEASED或者IGNORED 。
        参数
        character - 主键字符
        shift -的价值 shift修改键
        control - control修改键的值
        alt - alt修饰键的值
        meta - meta修饰键的值
        shortcut - 修改键值 shortcut

      • KeyCharacterCombination

        public KeyCharacterCombination​(String character,
                               KeyCombination.Modifier... modifiers)
        为指定的主键字符和指定的修饰符列表构造一个KeyCharacterCombination 。 未明确列出的所有修饰键都设置为默认值RELEASED 。

        所有可能修改默认修饰符值的修饰符都定义为KeyCombination类中的KeyCombination 。

        参数
        character - 主键字符
        modifiers - 修饰键列表及其对应的值

    • 方法详细信息

      • getCharacter

        public final String getCharacter​()
        获取与该组合关联的关键字符。
        结果
        与此组合关键字的关键字

      • match

        public boolean match​(KeyEvent event)
        测试此键组合是否与给定的KeyEvent组合键匹配。 该对象的关键特征首先被转换为能够产生当前键盘布局中的字符的键码，然后将所得到的键码与修改键一起匹配来自KeyEvent的键码和键修饰符。 这意味着，该方法可以返回true只为KEY_PRESSED个KEY_RELEASED事件，但不为KEY_TYPED的事件，不具有有效键代码。
        重写：
        match在 KeyCombination类
        参数
        event - 关键事件
        结果
        true如果键组合匹配，否则为 false

      • getName

        public String getName​()
        返回此KeyCharacterCombination的字符串表示KeyCharacterCombination 。

        字符串表示由加上字符分隔的部分组成。 每个部分指定一个修饰符键或主键。

        修饰符键部分包含修改键的KeyCode名称。 可以使用Ignored关键字作为前缀。 非前缀修饰符键意味着其PRESSED值，而前缀版本意味着IGNORED值。 如果在字符串中没有指定一些修饰符键，则表示它具有默认值RELEASED 。

        主键部分包含用单引号括起来的主键字符，是返回字符串中的最后一部分。

        重写：
        getName在 KeyCombination
        结果
        该字符串表示为 KeyCharacterCombination

      • getDisplayText

        public String getDisplayText​()
        返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。
        重写：
        getDisplayText在 KeyCombination
        结果
        这个 KeyCombination字符串表示，适合在用户界面中显示。

      • equals

        public boolean equals​(Object obj)
        测试这个 KeyCharacterCombination是否等于指定的对象。
        重写：
        equals KeyCombination
        参数
        obj - 要比较的对象
        结果
        true如果对象相等，否则为 false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 KeyCharacterCombination的哈希码值。
        重写：
        hashCode在 KeyCombination
        结果
        哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyCode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Enum KeyCode

  • java.lang.Object
    • java.lang.Enum<KeyCode>
      • javafx.scene.input.KeyCode
  • All Implemented Interfaces:
    Serializable ， Comparable<KeyCode>

    public enum KeyCode
extends Enum<KeyCode>
    KeyEvent对象的关键码集。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      A
      常数为 A键。
      ACCEPT
      接受或提交功能键的常数。
      ADD
      常数为 Add键。
      AGAIN
      常数为 Again键。
      ALL_CANDIDATES
      所有候选人的常数功能键。
      ALPHANUMERIC
      字母数字功能键的常数。
      ALT
      常数为 Alt键。
      ALT_GRAPH
      AltGraph功能键的常数。
      AMPERSAND
      常数为 Ampersand键。
      ASTERISK
      常数为 Asterisk键。
      AT
      “@”键的常数。
      B
      常数为 B键。
      BACK_QUOTE
      常数为 Back Quote键。
      BACK_SLASH
      常数为斜杠，“\”
      BACK_SPACE
      常数为 Backspace键。
      BEGIN
      常数为开始键。
      BRACELEFT
      常数为 Left Brace键。
      BRACERIGHT
      常数为 Right Brace键。
      C
      常数为 C键。
      CANCEL
      常数为 Cancel键。
      CAPS
      常数为 Caps Lock键。
      CHANNEL_DOWN
      常数为 Channel Down键。
      CHANNEL_UP
      常数为 Channel Up键。
      CIRCUMFLEX
      常数为“^”键。
      CLEAR
      常数为 Clear键。
      CLOSE_BRACKET
      关闭括号键的常数，“]”
      CODE_INPUT
      代码输入功能键的常数。
      COLON
      “：”键的常数。
      COLORED_KEY_0
      常数为 Colored Key 0键。
      COLORED_KEY_1
      常数为 Colored Key 1键。
      COLORED_KEY_2
      常数为 Colored Key 2键。
      COLORED_KEY_3
      常数为 Colored Key 3关键。
      COMMA
      常数为逗号键“，”
      COMMAND
      苹果的常数 Command键。
      COMPOSE
      输入法/常规键的常数。
      CONTEXT_MENU
      Microsoft Windows上下文菜单键的常数。
      CONTROL
      常数为 Ctrl键。
      CONVERT
      转换功能键的常数。
      COPY
      常数为 Copy键。
      CUT
      常数为 Cut关键。
      D
      常数为 D键。
      DEAD_ABOVEDOT
      常数为 Dead Abovedot键。
      DEAD_ABOVERING
      常数为 Dead Abovering键。
      DEAD_ACUTE
      常数为 Dead Acute关键。
      DEAD_BREVE
      常数为 Dead Breve键。
      DEAD_CARON
      常数为 Dead Caron键。
      DEAD_CEDILLA
      常数为 Dead Cedilla键。
      DEAD_CIRCUMFLEX
      常数为 Dead Circumflex键。
      DEAD_DIAERESIS
      常数为 Dead Diaeresis键。
      DEAD_DOUBLEACUTE
      常数为 Dead Doubleacute键。
      DEAD_GRAVE
      常数为 Dead Grave键。
      DEAD_IOTA
      常数为 Dead Iota键。
      DEAD_MACRON
      常数为 Dead Macron关键。
      DEAD_OGONEK
      常数为 Dead Ogonek键。
      DEAD_SEMIVOICED_SOUND
      常数为 Dead Semivoiced Sound键。
      DEAD_TILDE
      常数为 Dead Tilde键。
      DEAD_VOICED_SOUND
      常数为 Dead Voiced Sound键。
      DECIMAL
      常数为 Decimal键。
      DELETE
      常数为 Delete键。
      DIGIT0
      常数为 0键。
      DIGIT1
      常数为 1关键。
      DIGIT2
      常数为 2键。
      DIGIT3
      常数为 3键。
      DIGIT4
      常数为 4键。
      DIGIT5
      常数为 5键。
      DIGIT6
      常数为 6键。
      DIGIT7
      常数为 7键。
      DIGIT8
      常数为 8键。
      DIGIT9
      常数为 9键。
      DIVIDE
      常数为 Divide键。
      DOLLAR
      “$”键的常数。
      DOWN
      常数为非numpad 向下箭头键。
      E
      常数为 E键。
      EJECT_TOGGLE
      常数为 Eject键。
      END
      常数为 End键。
      ENTER
      常数为 Enter键。
      EQUALS
      等于键的常数，“=”
      ESCAPE
      常数为 Esc键。
      EURO_SIGN
      欧元货币符号键的常数。
      EXCLAMATION_MARK
      常数为“！”
      F
      常数为 F键。
      F1
      常数为F1功能键。
      F10
      常数为F10功能键。
      F11
      常数为F11功能键。
      F12
      F12功能键的常数。
      F13
      F13功能键的常数。
      F14
      F14功能键的常数。
      F15
      F15功能键的常数。
      F16
      F16功能键的常数。
      F17
      F17功能键的常数。
      F18
      F18功能键的常数。
      F19
      F19功能键的常数。
      F2
      F2功能键的常数。
      F20
      F20功能键的常数。
      F21
      F21功能键的常数。
      F22
      F22功能键的常数。
      F23
      F23功能键的常数。
      F24
      F24功能键的常数。
      F3
      F3功能键的常数。
      F4
      F4功能键的常数。
      F5
      F5功能键的常数。
      F6
      常数为F6功能键。
      F7
      F7功能键的常数。
      F8
      F8功能键的常数。
      F9
      常数为F9功能键。
      FAST_FWD
      常数为 Fast Forward键。
      FINAL
      用于亚洲键盘的输入法支持常数。
      FIND
      常数为 Find键。
      FULL_WIDTH
      全角字符的常量功能键。
      G
      常数为 G键。
      GAME_A
      常数为 Game A键。
      GAME_B
      常数为 Game B键。
      GAME_C
      常数为 Game C键。
      GAME_D
      常数为 Game D键。
      GREATER
      常数为 Greater键。
      H
      常数为 H键。
      HALF_WIDTH
      半角字符功能键的常数。
      HELP
      常数为 帮助键。
      HIRAGANA
      平假名功能键的常数。
      HOME
      常数为 Home键。
      I
      常数为 I键。
      INFO
      常数为 Info键。
      INPUT_METHOD_ON_OFF
      输入法/常规键的常数。
      INSERT
      常数为 Insert键。
      INVERTED_EXCLAMATION_MARK
      反转感叹号的常数。
      J
      常数为 J键。
      JAPANESE_HIRAGANA
      日文 - 平假名功能键的常数。
      JAPANESE_KATAKANA
      日本片假名功能键的常数。
      JAPANESE_ROMAN
      日常罗马功能键的常数。
      K
      常数为 K键。
      KANA
      常数为 Kana键。
      KANA_LOCK
      锁定假名功能键的常数。
      KANJI
      常数为 Kanji键。
      KATAKANA
      片假名功能键的常数。
      KP_DOWN
      常数为数字键盘 向下箭头键。
      KP_LEFT
      常数为数字键盘 左箭头键。
      KP_RIGHT
      数字键盘 右箭头键的常数。
      KP_UP
      常数为数字键盘 向上箭头键。
      L
      常数为 L键。
      LEFT
      常数为非numpad 左箭头键。
      LEFT_PARENTHESIS
      常数为“（”键。
      LESS
      常数为 Less键。
      M
      常数为 M键。
      META
      常数为 Meta键。
      MINUS
      常数为减号，“ - ”
      MODECHANGE
      常数为 Mode Change键。
      MULTIPLY
      常数为 Multiply键。
      MUTE
      常数为 Mute键。
      N
      常数为 N键。
      NONCONVERT
      不转换功能键的常数。
      NUM_LOCK
      常数为 Num Lock键。
      NUMBER_SIGN
      “＃”键的常数。
      NUMPAD0
      常数为 Numpad 0键。
      NUMPAD1
      常数为 Numpad 1键。
      NUMPAD2
      常数为 Numpad 2键。
      NUMPAD3
      常数为 Numpad 3键。
      NUMPAD4
      常数为 Numpad 4键。
      NUMPAD5
      常数为 Numpad 5键。
      NUMPAD6
      常数为 Numpad 6键。
      NUMPAD7
      常数为 Numpad 7键。
      NUMPAD8
      常数为 Numpad 8键。
      NUMPAD9
      常数为 Numpad 9键。
      O
      常数为 O键。
      OPEN_BRACKET
      常数为打开括号的键，“[”
      P
      常数为 P键。
      PAGE_DOWN
      常数为 Page Down键。
      PAGE_UP
      常数为 Page Up键。
      PASTE
      常数为 Paste键。
      PAUSE
      常数为 Pause键。
      PERIOD
      期间关键的常数“”。
      PLAY
      常数为 Play键。
      PLUS
      常数为“+”键。
      POUND
      常数为 Pound键。
      POWER
      常数为 Power键。
      PREVIOUS_CANDIDATE
      上一个候选功能键的常数。
      PRINTSCREEN
      常数为 Print Screen键。
      PROPS
      常数为 Properties键。
      Q
      常数为 Q键。
      QUOTE
      常数为 Quote键。
      QUOTEDBL
      常数为 Double Quote键。
      R
      常数为 R键。
      RECORD
      常数为 Record键。
      REWIND
      常数为 Rewind键。
      RIGHT
      常数为非numpad 右箭头键。
      RIGHT_PARENTHESIS
      常数为“）”键。
      ROMAN_CHARACTERS
      罗马字符功能键的常数。
      S
      常数为 S键。
      SCROLL_LOCK
      常数为 Scroll Lock键。
      SEMICOLON
      常数为分号键，“;”
      SEPARATOR
      Numpad Separator键的常数。
      SHIFT
      常数为 Shift键。
      SHORTCUT
      常数为 Shortcut键。
      SLASH
      正斜杠的常数为“/”
      SOFTKEY_0
      常数为 Softkey 0键。
      SOFTKEY_1
      常数为 Softkey 1键。
      SOFTKEY_2
      常数为 Softkey 2键。
      SOFTKEY_3
      常数为 Softkey 3键。
      SOFTKEY_4
      常数为 Softkey 4键。
      SOFTKEY_5
      常数为 Softkey 5键。
      SOFTKEY_6
      常数为 Softkey 6键。
      SOFTKEY_7
      常数为 Softkey 7键。
      SOFTKEY_8
      常数为 Softkey 8键。
      SOFTKEY_9
      常数为 Softkey 9键。
      SPACE
      常数为 Space键。
      STAR
      常数为 Star键。
      STOP
      常数为 Stop键。
      SUBTRACT
      常数为 Subtract键。
      T
      常数为 T键。
      TAB
      常数为 Tab键。
      TRACK_NEXT
      常数为 Next Track键。
      TRACK_PREV
      常数为 Previous Track键。
      U
      常数为 U键。
      UNDEFINED
      该值用于表示keyCode未知。
      UNDERSCORE
      常量为“_”键。
      UNDO
      常数为 Undo键。
      UP
      常数为非numpad 向上箭头键。
      V
      常数为 V键。
      VOLUME_DOWN
      常数为 Volume Down键。
      VOLUME_UP
      常数为 Volume Up键。
      W
      常数为 W键。
      WINDOWS
      Microsoft Windows“Windows”键的常数。
      X
      常数为 X键。
      Y
      常数为 Y键。
      Z
      常数为 Z键。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getChar​()
      返回此键代码的字符元素，这只是 getCode()返回的底层平台代码的 映射 。
      int getCode​()
      返回用于表示密钥代码中的 character的底层平台代码。
      static KeyCode getKeyCode​(String name)
      解析一个键的文本表示。
      String getName​()
      获取此密钥代码的名称。
      boolean isArrowKey​()
      左，右，上，下键（包括键盘箭头）
      boolean isDigitKey​()
      所有数字键（包括键盘数字）
      boolean isFunctionKey​()
      F1，F2等功能键
      boolean isKeypadKey​()
      键盘上的所有键
      boolean isLetterKey​()
      所有键与字母
      boolean isMediaKey​()
      所有多媒体键（通道上/下，音量控制等）
      boolean isModifierKey​()
      可以作为修饰符的键
      boolean isNavigationKey​()
      导航键是箭头键和Page Down，Page Up，Home，End（包括键盘键）
      boolean isWhitespaceKey​()
      空格，制表符并输入
      static KeyCode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static KeyCode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ENTER

        public static final KeyCode ENTER
        常数为 Enter键。

      • BACK_SPACE

        public static final KeyCode BACK_SPACE
        常数为 Backspace键。

      • TAB

        public static final KeyCode TAB
        常数为 Tab键。

      • CANCEL

        public static final KeyCode CANCEL
        常数为 Cancel键。

      • CLEAR

        public static final KeyCode CLEAR
        常数为 Clear键。

      • SHIFT

        public static final KeyCode SHIFT
        常数为 Shift键。

      • CONTROL

        public static final KeyCode CONTROL
        常数为 Ctrl键。

      • ALT

        public static final KeyCode ALT
        常数为 Alt键。

      • PAUSE

        public static final KeyCode PAUSE
        常数为 Pause键。

      • CAPS

        public static final KeyCode CAPS
        常数为 Caps Lock键。

      • ESCAPE

        public static final KeyCode ESCAPE
        常数为 Esc键。

      • SPACE

        public static final KeyCode SPACE
        常数为 Space键。

      • PAGE_UP

        public static final KeyCode PAGE_UP
        常数为 Page Up键。

      • PAGE_DOWN

        public static final KeyCode PAGE_DOWN
        常数为 Page Down键。

      • END

        public static final KeyCode END
        常数为 End键。

      • HOME

        public static final KeyCode HOME
        常数为 Home键。

      • LEFT

        public static final KeyCode LEFT
        常数为非numpad 左箭头键。

      • UP

        public static final KeyCode UP
        常数为非numpad 向上箭头键。

      • RIGHT

        public static final KeyCode RIGHT
        常数为非numpad 右箭头键。

      • DOWN

        public static final KeyCode DOWN
        常数为非numpad 向下箭头键。

      • COMMA

        public static final KeyCode COMMA
        常数为逗号键“，”

      • MINUS

        public static final KeyCode MINUS
        常数为减号，“ - ”

      • PERIOD

        public static final KeyCode PERIOD
        期间关键的常数“”。

      • SLASH

        public static final KeyCode SLASH
        正斜杠的常数为“/”

      • DIGIT0

        public static final KeyCode DIGIT0
        常数为 0键。

      • DIGIT1

        public static final KeyCode DIGIT1
        常数为 1键。

      • DIGIT2

        public static final KeyCode DIGIT2
        常数为 2键。

      • DIGIT3

        public static final KeyCode DIGIT3
        常数为 3键。

      • DIGIT4

        public static final KeyCode DIGIT4
        常数为 4键。

      • DIGIT5

        public static final KeyCode DIGIT5
        常数为 5键。

      • DIGIT6

        public static final KeyCode DIGIT6
        常数为 6键。

      • DIGIT7

        public static final KeyCode DIGIT7
        常数为 7关键。

      • DIGIT8

        public static final KeyCode DIGIT8
        常数为 8键。

      • DIGIT9

        public static final KeyCode DIGIT9
        常数为 9键。

      • SEMICOLON

        public static final KeyCode SEMICOLON
        常数为分号键，“;”

      • EQUALS

        public static final KeyCode EQUALS
        等于键的常数，“=”

      • A

        public static final KeyCode A
        常数为 A键。

      • B

        public static final KeyCode B
        常数为 B关键。

      • C

        public static final KeyCode C
        常数为 C键。

      • D

        public static final KeyCode D
        常数为 D键。

      • E

        public static final KeyCode E
        常数为 E键。

      • F

        public static final KeyCode F
        常数为 F键。

      • G

        public static final KeyCode G
        常数为 G键。

      • H

        public static final KeyCode H
        常数为 H键。

      • I

        public static final KeyCode I
        常数为 I键。

      • J

        public static final KeyCode J
        常数为 J键。

      • K

        public static final KeyCode K
        常数为 K键。

      • L

        public static final KeyCode L
        常数为 L键。

      • M

        public static final KeyCode M
        常数为 M关键。

      • N

        public static final KeyCode N
        常数为 N键。

      • O

        public static final KeyCode O
        常数为 O键。

      • P

        public static final KeyCode P
        常数为 P键。

      • Q

        public static final KeyCode Q
        常数为 Q键。

      • R

        public static final KeyCode R
        常数为 R键。

      • S

        public static final KeyCode S
        常数为 S键。

      • T

        public static final KeyCode T
        常数为 T键。

      • U

        public static final KeyCode U
        常数为 U键。

      • V

        public static final KeyCode V
        常数为 V键。

      • W

        public static final KeyCode W
        常数为 W键。

      • X

        public static final KeyCode X
        常数为 X键。

      • Y

        public static final KeyCode Y
        常数为 Y键。

      • Z

        public static final KeyCode Z
        常数为 Z键。

      • OPEN_BRACKET

        public static final KeyCode OPEN_BRACKET
        常数为打开括号的键，“[”

      • BACK_SLASH

        public static final KeyCode BACK_SLASH
        常数为斜杠，“\”

      • CLOSE_BRACKET

        public static final KeyCode CLOSE_BRACKET
        关闭括号键的常数，“]”

      • NUMPAD0

        public static final KeyCode NUMPAD0
        常数为 Numpad 0键。

      • NUMPAD1

        public static final KeyCode NUMPAD1
        常数为 Numpad 1键。

      • NUMPAD2

        public static final KeyCode NUMPAD2
        常数为 Numpad 2键。

      • NUMPAD3

        public static final KeyCode NUMPAD3
        常数为 Numpad 3键。

      • NUMPAD4

        public static final KeyCode NUMPAD4
        常数为 Numpad 4键。

      • NUMPAD5

        public static final KeyCode NUMPAD5
        常数为 Numpad 5键。

      • NUMPAD6

        public static final KeyCode NUMPAD6
        常数为 Numpad 6键。

      • NUMPAD7

        public static final KeyCode NUMPAD7
        常数为 Numpad 7键。

      • NUMPAD8

        public static final KeyCode NUMPAD8
        常数为 Numpad 8键。

      • NUMPAD9

        public static final KeyCode NUMPAD9
        常数为 Numpad 9键。

      • MULTIPLY

        public static final KeyCode MULTIPLY
        常数为 Multiply键。

      • ADD

        public static final KeyCode ADD
        常数为 Add键。

      • SEPARATOR

        public static final KeyCode SEPARATOR
        Numpad Separator键的常数。

      • SUBTRACT

        public static final KeyCode SUBTRACT
        常数为 Subtract键。

      • DECIMAL

        public static final KeyCode DECIMAL
        常数为 Decimal键。

      • DIVIDE

        public static final KeyCode DIVIDE
        常数为 Divide键。

      • DELETE

        public static final KeyCode DELETE
        常数为 Delete键。

      • NUM_LOCK

        public static final KeyCode NUM_LOCK
        常数为 Num Lock键。

      • SCROLL_LOCK

        public static final KeyCode SCROLL_LOCK
        常数为 Scroll Lock键。

      • F1

        public static final KeyCode F1
        常数为F1功能键。

      • F2

        public static final KeyCode F2
        F2功能键的常数。

      • F3

        public static final KeyCode F3
        F3功能键的常数。

      • F4

        public static final KeyCode F4
        F4功能键的常数。

      • F5

        public static final KeyCode F5
        F5功能键的常数。

      • F6

        public static final KeyCode F6
        常数为F6功能键。

      • F7

        public static final KeyCode F7
        F7功能键的常数。

      • F8

        public static final KeyCode F8
        F8功能键的常数。

      • F9

        public static final KeyCode F9
        常数为F9功能键。

      • F10

        public static final KeyCode F10
        常数为F10功能键。

      • F11

        public static final KeyCode F11
        常数为F11功能键。

      • F12

        public static final KeyCode F12
        F12功能键的常数。

      • F13

        public static final KeyCode F13
        F13功能键的常数。

      • F14

        public static final KeyCode F14
        F14功能键的常数。

      • F15

        public static final KeyCode F15
        F15功能键的常数。

      • F16

        public static final KeyCode F16
        F16功能键的常数。

      • F17

        public static final KeyCode F17
        F17功能键的常数。

      • F18

        public static final KeyCode F18
        F18功能键的常数。

      • F19

        public static final KeyCode F19
        F19功能键的常数。

      • F20

        public static final KeyCode F20
        F20功能键的常数。

      • F21

        public static final KeyCode F21
        F21功能键的常数。

      • F22

        public static final KeyCode F22
        F22功能键的常数。

      • F23

        public static final KeyCode F23
        F23功能键的常数。

      • F24

        public static final KeyCode F24
        F24功能键的常数。

      • PRINTSCREEN

        public static final KeyCode PRINTSCREEN
        常数为 Print Screen键。

      • INSERT

        public static final KeyCode INSERT
        常数为 Insert键。

      • HELP

        public static final KeyCode HELP
        常数为 帮助键。

      • META

        public static final KeyCode META
        常数为 Meta键。

      • BACK_QUOTE

        public static final KeyCode BACK_QUOTE
        常数为 Back Quote键。

      • QUOTE

        public static final KeyCode QUOTE
        常数为 Quote键。

      • KP_UP

        public static final KeyCode KP_UP
        常数为数字键盘 向上箭头键。

      • KP_DOWN

        public static final KeyCode KP_DOWN
        常数为数字键盘 向下箭头键。

      • KP_LEFT

        public static final KeyCode KP_LEFT
        常数为数字键盘 左箭头键。

      • KP_RIGHT

        public static final KeyCode KP_RIGHT
        数字键盘 右箭头键的常数。

      • DEAD_GRAVE

        public static final KeyCode DEAD_GRAVE
        常数为 Dead Grave键。

      • DEAD_ACUTE

        public static final KeyCode DEAD_ACUTE
        常数为 Dead Acute键。

      • DEAD_CIRCUMFLEX

        public static final KeyCode DEAD_CIRCUMFLEX
        常数为 Dead Circumflex键。

      • DEAD_TILDE

        public static final KeyCode DEAD_TILDE
        常数为 Dead Tilde键。

      • DEAD_MACRON

        public static final KeyCode DEAD_MACRON
        常数为 Dead Macron键。

      • DEAD_BREVE

        public static final KeyCode DEAD_BREVE
        常数为 Dead Breve键。

      • DEAD_ABOVEDOT

        public static final KeyCode DEAD_ABOVEDOT
        常数为 Dead Abovedot键。

      • DEAD_DIAERESIS

        public static final KeyCode DEAD_DIAERESIS
        常数为 Dead Diaeresis键。

      • DEAD_ABOVERING

        public static final KeyCode DEAD_ABOVERING
        常数为 Dead Abovering键。

      • DEAD_DOUBLEACUTE

        public static final KeyCode DEAD_DOUBLEACUTE
        常数为 Dead Doubleacute键。

      • DEAD_CARON

        public static final KeyCode DEAD_CARON
        常数为 Dead Caron键。

      • DEAD_CEDILLA

        public static final KeyCode DEAD_CEDILLA
        常数为 Dead Cedilla键。

      • DEAD_OGONEK

        public static final KeyCode DEAD_OGONEK
        常数为 Dead Ogonek键。

      • DEAD_IOTA

        public static final KeyCode DEAD_IOTA
        常数为 Dead Iota键。

      • DEAD_VOICED_SOUND

        public static final KeyCode DEAD_VOICED_SOUND
        常数为 Dead Voiced Sound键。

      • DEAD_SEMIVOICED_SOUND

        public static final KeyCode DEAD_SEMIVOICED_SOUND
        常数为 Dead Semivoiced Sound键。

      • AMPERSAND

        public static final KeyCode AMPERSAND
        常数为 Ampersand键。

      • ASTERISK

        public static final KeyCode ASTERISK
        常数为 Asterisk键。

      • QUOTEDBL

        public static final KeyCode QUOTEDBL
        常数为 Double Quote键。

      • LESS

        public static final KeyCode LESS
        常数为 Less键。

      • GREATER

        public static final KeyCode GREATER
        常数为 Greater键。

      • BRACELEFT

        public static final KeyCode BRACELEFT
        常数为 Left Brace键。

      • BRACERIGHT

        public static final KeyCode BRACERIGHT
        常数为 Right Brace键。

      • AT

        public static final KeyCode AT
        “@”键的常数。

      • COLON

        public static final KeyCode COLON
        “：”键的常数。

      • CIRCUMFLEX

        public static final KeyCode CIRCUMFLEX
        常数为“^”键。

      • DOLLAR

        public static final KeyCode DOLLAR
        “$”键的常数。

      • EURO_SIGN

        public static final KeyCode EURO_SIGN
        欧元货币符号键的常数。

      • EXCLAMATION_MARK

        public static final KeyCode EXCLAMATION_MARK
        常数为“！” 键。

      • INVERTED_EXCLAMATION_MARK

        public static final KeyCode INVERTED_EXCLAMATION_MARK
        反转感叹号的常数。

      • LEFT_PARENTHESIS

        public static final KeyCode LEFT_PARENTHESIS
        常数为“（”键。

      • NUMBER_SIGN

        public static final KeyCode NUMBER_SIGN
        “＃”键的常数。

      • PLUS

        public static final KeyCode PLUS
        常数为“+”键。

      • RIGHT_PARENTHESIS

        public static final KeyCode RIGHT_PARENTHESIS
        常数为“）”键。

      • UNDERSCORE

        public static final KeyCode UNDERSCORE
        常量为“_”键。

      • WINDOWS

        public static final KeyCode WINDOWS
        Microsoft Windows“Windows”键的常数。 它用于键盘的左右两个版本。

      • CONTEXT_MENU

        public static final KeyCode CONTEXT_MENU
        Microsoft Windows上下文菜单键的常数。

      • FINAL

        public static final KeyCode FINAL
        用于亚洲键盘的输入法支持常数。

      • CONVERT

        public static final KeyCode CONVERT
        转换功能键的常数。

      • NONCONVERT

        public static final KeyCode NONCONVERT
        不转换功能键的常数。

      • ACCEPT

        public static final KeyCode ACCEPT
        接受或提交功能键的常数。

      • MODECHANGE

        public static final KeyCode MODECHANGE
        常数为 Mode Change键。

      • KANA

        public static final KeyCode KANA
        常数为 Kana键。

      • KANJI

        public static final KeyCode KANJI
        常数为 Kanji键。

      • ALPHANUMERIC

        public static final KeyCode ALPHANUMERIC
        字母数字功能键的常数。

      • KATAKANA

        public static final KeyCode KATAKANA
        片假名功能键的常数。

      • HIRAGANA

        public static final KeyCode HIRAGANA
        平假名功能键的常数。

      • FULL_WIDTH

        public static final KeyCode FULL_WIDTH
        全角字符的常量功能键。

      • HALF_WIDTH

        public static final KeyCode HALF_WIDTH
        半角字符功能键的常数。

      • ROMAN_CHARACTERS

        public static final KeyCode ROMAN_CHARACTERS
        罗马字符功能键的常数。

      • ALL_CANDIDATES

        public static final KeyCode ALL_CANDIDATES
        所有候选人的常数功能键。

      • PREVIOUS_CANDIDATE

        public static final KeyCode PREVIOUS_CANDIDATE
        上一个候选功能键的常数。

      • CODE_INPUT

        public static final KeyCode CODE_INPUT
        代码输入功能键的常数。

      • JAPANESE_KATAKANA

        public static final KeyCode JAPANESE_KATAKANA
        日本片假名功能键的常数。 该键切换到日文输入法，并选择其片假名输入模式。

      • JAPANESE_HIRAGANA

        public static final KeyCode JAPANESE_HIRAGANA
        日文 - 平假名功能键的常数。 此键切换到日语输入法，并选择其平假名输入模式。

      • JAPANESE_ROMAN

        public static final KeyCode JAPANESE_ROMAN
        日常罗马功能键的常数。 该键切换到日语输入法，并选择其Roman-Direct输入模式。

      • KANA_LOCK

        public static final KeyCode KANA_LOCK
        锁定假名功能键的常数。 该键将键盘锁定到假名布局。

      • INPUT_METHOD_ON_OFF

        public static final KeyCode INPUT_METHOD_ON_OFF
        输入法/常规键的常数。

      • CUT

        public static final KeyCode CUT
        常数为 Cut键。

      • COPY

        public static final KeyCode COPY
        常数为 Copy键。

      • PASTE

        public static final KeyCode PASTE
        常数为 Paste键。

      • UNDO

        public static final KeyCode UNDO
        常数为 Undo键。

      • AGAIN

        public static final KeyCode AGAIN
        常数为 Again键。

      • FIND

        public static final KeyCode FIND
        常数为 Find键。

      • PROPS

        public static final KeyCode PROPS
        常数为 Properties键。

      • STOP

        public static final KeyCode STOP
        常数为 Stop键。

      • COMPOSE

        public static final KeyCode COMPOSE
        输入法/常规键的常数。

      • ALT_GRAPH

        public static final KeyCode ALT_GRAPH
        AltGraph功能键的常数。

      • BEGIN

        public static final KeyCode BEGIN
        常数为开始键。

      • UNDEFINED

        public static final KeyCode UNDEFINED
        该值用于表示keyCode未知。 键类型事件没有keyCode值; 该值被替代使用。

      • SOFTKEY_0

        public static final KeyCode SOFTKEY_0
        常数为 Softkey 0键。

      • SOFTKEY_1

        public static final KeyCode SOFTKEY_1
        常数为 Softkey 1键。

      • SOFTKEY_2

        public static final KeyCode SOFTKEY_2
        常数为 Softkey 2键。

      • SOFTKEY_3

        public static final KeyCode SOFTKEY_3
        常数为 Softkey 3关键。

      • SOFTKEY_4

        public static final KeyCode SOFTKEY_4
        常数为 Softkey 4键。

      • SOFTKEY_5

        public static final KeyCode SOFTKEY_5
        常数为 Softkey 5键。

      • SOFTKEY_6

        public static final KeyCode SOFTKEY_6
        常数为 Softkey 6键。

      • SOFTKEY_7

        public static final KeyCode SOFTKEY_7
        常数为 Softkey 7键。

      • SOFTKEY_8

        public static final KeyCode SOFTKEY_8
        常数为 Softkey 8键。

      • SOFTKEY_9

        public static final KeyCode SOFTKEY_9
        常数为 Softkey 9键。

      • GAME_A

        public static final KeyCode GAME_A
        常数为 Game A键。

      • GAME_B

        public static final KeyCode GAME_B
        常数为 Game B键。

      • GAME_C

        public static final KeyCode GAME_C
        常数为 Game C键。

      • GAME_D

        public static final KeyCode GAME_D
        常数为 Game D键。

      • STAR

        public static final KeyCode STAR
        常数为 Star键。

      • POUND

        public static final KeyCode POUND
        常数为 Pound键。

      • POWER

        public static final KeyCode POWER
        常数为 Power键。

      • INFO

        public static final KeyCode INFO
        常数为 Info键。

      • COLORED_KEY_0

        public static final KeyCode COLORED_KEY_0
        常数为 Colored Key 0键。

      • COLORED_KEY_1

        public static final KeyCode COLORED_KEY_1
        常数为 Colored Key 1键。

      • COLORED_KEY_2

        public static final KeyCode COLORED_KEY_2
        常数为 Colored Key 2键。

      • COLORED_KEY_3

        public static final KeyCode COLORED_KEY_3
        常数为 Colored Key 3键。

      • EJECT_TOGGLE

        public static final KeyCode EJECT_TOGGLE
        常数为 Eject关键。

      • PLAY

        public static final KeyCode PLAY
        常数为 Play键。

      • RECORD

        public static final KeyCode RECORD
        常数为 Record键。

      • FAST_FWD

        public static final KeyCode FAST_FWD
        常数为 Fast Forward键。

      • REWIND

        public static final KeyCode REWIND
        常数为 Rewind键。

      • TRACK_PREV

        public static final KeyCode TRACK_PREV
        常数为 Previous Track键。

      • TRACK_NEXT

        public static final KeyCode TRACK_NEXT
        常数为 Next Track键。

      • CHANNEL_UP

        public static final KeyCode CHANNEL_UP
        常数为 Channel Up键。

      • CHANNEL_DOWN

        public static final KeyCode CHANNEL_DOWN
        常数为 Channel Down键。

      • VOLUME_UP

        public static final KeyCode VOLUME_UP
        常数为 Volume Up键。

      • VOLUME_DOWN

        public static final KeyCode VOLUME_DOWN
        常数为 Volume Down键。

      • MUTE

        public static final KeyCode MUTE
        常数为 Mute键。

      • COMMAND

        public static final KeyCode COMMAND
        苹果的常数 Command键。
        从以下版本开始：
        JavaFX 2.1

      • SHORTCUT

        public static final KeyCode SHORTCUT
        常数为 Shortcut键。

    • 方法详细信息

      • values

        public static KeyCode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (KeyCode c : KeyCode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static KeyCode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • isFunctionKey

        public final boolean isFunctionKey​()
        F1，F2等功能键
        结果
        如果此键代码对应于功能键，则为true
        从以下版本开始：
        JavaFX 2.2

      • isNavigationKey

        public final boolean isNavigationKey​()
        导航键是箭头键和Page Down，Page Up，Home，End（包括键盘键）
        结果
        如果该键代码对应于导航键，则为真
        从以下版本开始：
        JavaFX 2.2

      • isArrowKey

        public final boolean isArrowKey​()
        左，右，上，下键（包括键盘箭头）
        结果
        如果此键代码对应于箭头键，则为true
        从以下版本开始：
        JavaFX 2.2

      • isModifierKey

        public final boolean isModifierKey​()
        可以作为修饰符的键
        结果
        如果此键代码对应于修饰键，则为true
        从以下版本开始：
        JavaFX 2.2

      • isLetterKey

        public final boolean isLetterKey​()
        所有键与字母
        结果
        如果此键码对应于字母键，则为true
        从以下版本开始：
        JavaFX 2.2

      • isDigitKey

        public final boolean isDigitKey​()
        所有数字键（包括键盘数字）
        结果
        如果此键码对应于数字键，则为真
        从以下版本开始：
        JavaFX 2.2

      • isKeypadKey

        public final boolean isKeypadKey​()
        键盘上的所有键
        结果
        如果该键码对应于键盘键，则为真
        从以下版本开始：
        JavaFX 2.2

      • isWhitespaceKey

        public final boolean isWhitespaceKey​()
        空格，制表符并输入
        结果
        如果此密钥代码对应于空格键，则为true
        从以下版本开始：
        JavaFX 2.2

      • isMediaKey

        public final boolean isMediaKey​()
        所有多媒体键（通道上/下，音量控制等）
        结果
        如果此键码对应于媒体密钥，则为true
        从以下版本开始：
        JavaFX 2.2

      • getName

        public final String getName​()
        获取此密钥代码的名称。
        结果
        此密钥代码的名称

      • getChar

        public final String getChar​()
        返回此键代码的字符元素，这只是 getCode()返回的底层平台代码的 映射 。
        结果
        这个键码的字符元素
        从以下版本开始：
        9

      • getCode

        public final int getCode​()
        返回用于表示关键代码中的 character的底层平台代码。
        结果
        底层平台代码用于代表关键代码中的 character
        从以下版本开始：
        9

      • getKeyCode

        public static KeyCode getKeyCode​(String name)
        解析一个键的文本表示。
        参数
        name - 密钥的文本表示
        结果
        具有给定名称的键的KeyCode，如果字符串未知，则为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


KeyCodeCombination (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class KeyCodeCombination

  • java.lang.Object
    • javafx.scene.input.KeyCombination
      • javafx.scene.input.KeyCodeCombination

  • public final class KeyCodeCombination
extends KeyCombination
    该类表示其主键由其KeyCode指定的组合键。 这种按键组合独立于键组合匹配时由用户配置的键盘功能布局。
    从以下版本开始：
    JavaFX 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.scene.input.KeyCombination

        KeyCombination.Modifier, KeyCombination.ModifierValue

    • Field Summary

      • Fields inherited from class javafx.scene.input.KeyCombination

        ALT_ANY, ALT_DOWN, CONTROL_ANY, CONTROL_DOWN, META_ANY, META_DOWN, NO_MATCH, SHIFT_ANY, SHIFT_DOWN, SHORTCUT_ANY, SHORTCUT_DOWN

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyCodeCombination​(KeyCode code, KeyCombination.Modifier... modifiers)
      为指定的主键和指定的修饰符列表构造一个 KeyCodeCombination 。
      KeyCodeCombination​(KeyCode code, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      测试这个 KeyCodeCombination是否等于指定的对象。
      KeyCode getCode​()
      获取与该组合关联的键码。
      String getDisplayText​()
      返回适合在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。
      String getName​()
      返回此 KeyCodeCombination的字符串表示 KeyCodeCombination 。
      int hashCode​()
      返回此 KeyCodeCombination的哈希码值。
      boolean match​(KeyEvent event)
      测试此组合是否与给定的 KeyEvent组合键匹配。

      • Methods inherited from class javafx.scene.input.KeyCombination

        getAlt, getControl, getMeta, getShift, getShortcut, keyCombination, toString, valueOf

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • KeyCodeCombination

        public KeyCodeCombination​(KeyCode code,
                          KeyCombination.ModifierValue shift,
                          KeyCombination.ModifierValue control,
                          KeyCombination.ModifierValue alt,
                          KeyCombination.ModifierValue meta,
                          KeyCombination.ModifierValue shortcut)
        为指定的主键构建一个KeyCodeCombination ，并显式指定所有修改键。 每个修饰键可设置为PRESSED ， RELEASED或者IGNORED 。
        参数
        code - 主键的键码
        shift - 修改键值 shift
        control - control修改键的值
        alt - 修改键值 alt
        meta - 修改键值 meta
        shortcut - 修改键值 shortcut

      • KeyCodeCombination

        public KeyCodeCombination​(KeyCode code,
                          KeyCombination.Modifier... modifiers)
        为指定的主键和指定的修饰符列表构造一个KeyCodeCombination 。 未明确列出的所有修饰键都设置为默认值RELEASED 。

        所有可能修改默认修饰符值的修饰符都定义为KeyCombination类中的KeyCombination 。

        参数
        code - 主键的键码
        modifiers - 修饰键的列表及其对应的值

    • 方法详细信息

      • getCode

        public final KeyCode getCode​()
        获取与该组合关联的键码。
        结果
        与该组合键相关的键码

      • match

        public boolean match​(KeyEvent event)
        测试此键组合是否与给定的KeyEvent组合键匹配。 它仅在测试中使用KeyEvent的键代码和修改键的状态。 这意味着该方法只能为KEY_PRESSED和KEY_RELEASED事件返回true ，但不能KEY_TYPED没有有效密钥代码的KEY_TYPED事件。
        重写：
        match在 KeyCombination
        参数
        event - 关键事件
        结果
        true如果键组合匹配，否则为 false

      • getName

        public String getName​()
        返回此KeyCodeCombination的字符串表示KeyCodeCombination 。

        字符串表示由加上字符分隔的部分组成。 每个部分指定一个修饰符键或主键。

        修饰符键部分包含修改键的KeyCode名称。 可以使用Ignored关键字作为前缀。 非前缀修饰符键意味着其PRESSED值，而前缀版本意味着IGNORED值。 如果在字符串中没有指定某些修饰符键，则表示它具有默认值RELEASED 。

        主键部分包含主键的键代码名称，是返回字符串中的最后一部分。

        重写：
        getName在 KeyCombination
        结果
        这个 KeyCodeCombination的字符串表示

      • getDisplayText

        public String getDisplayText​()
        返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。
        重写：
        getDisplayText在 KeyCombination
        结果
        这个 KeyCombination字符串表示，适合在用户界面中显示。

      • equals

        public boolean equals​(Object obj)
        测试这个 KeyCodeCombination是否等于指定的对象。
        重写：
        equals在 KeyCombination
        参数
        obj - 要比较的对象
        结果
        true如果对象相等，否则为 false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 KeyCodeCombination的哈希码值。
        重写：
        hashCode在 KeyCombination
        结果
        哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyCombination (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class KeyCombination

  • java.lang.Object
    • javafx.scene.input.KeyCombination
  • 已知直接子类：
    KeyCharacterCombination ， KeyCodeCombination

    public abstract class KeyCombination
extends Object
    表示在键盘快捷键中使用的键组合。 键组合包括一个主键和一组修饰键。 主键可以由其键码 - KeyCodeCombination或键 - KeyCharacterCombination 。 甲修改键是shift ， control ， alt ， meta或shortcut ，并且可以被定义为DOWN ， UP或ANY 。

    shortcut修饰符用于表示主机平台上的键盘快捷键常用的修饰符键。 例如，这是control在Windows和meta在Mac（命令键）。 通过使用shortcut键修饰符开发人员可以创建独立于平台的快捷方式。 因此，“快捷键+ C”组合键在Windows内部处理为“Ctrl + C”，Mac处理器为“Meta + C”。

    从以下版本开始：
    JavaFX 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  KeyCombination.Modifier
      此类表示一对修饰符键及其值。
      static class  KeyCombination.ModifierValue
      ModifierValue指定修饰键的状态。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static KeyCombination.Modifier ALT_ANY
      指定 alt键的 alt可以是向上还是向下。
      static KeyCombination.Modifier ALT_DOWN
      指定 alt键的 alt必须关闭。
      static KeyCombination.Modifier CONTROL_ANY
      修饰符指定 control键可以是向上还是向下。
      static KeyCombination.Modifier CONTROL_DOWN
      指定 control键的 control必须关闭。
      static KeyCombination.Modifier META_ANY
      修饰符指定 meta键可以是向上还是向下。
      static KeyCombination.Modifier META_DOWN
      指定 meta键的 meta必须关闭。
      static KeyCombination NO_MATCH
      与任何事件匹配的KeyCombination。
      static KeyCombination.Modifier SHIFT_ANY
      修饰符指定 shift键可以是向上还是向下。
      static KeyCombination.Modifier SHIFT_DOWN
      修饰符指定 shift键必须关闭。
      static KeyCombination.Modifier SHORTCUT_ANY
      修饰符指定 shortcut键可以是向上还是向下。
      static KeyCombination.Modifier SHORTCUT_DOWN
      指定 shortcut键的 shortcut必须关闭。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected KeyCombination​(KeyCombination.Modifier... modifiers)
      构造具有指定的修饰符列表的 KeyCombination 。
      protected KeyCombination​(KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      构造一个 KeyCombination ，具有所有修饰键的显式规范。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      测试这个 KeyCombination是否等于指定的对象。
      KeyCombination.ModifierValue getAlt​()
      alt键的状态在这个组合键上。
      KeyCombination.ModifierValue getControl​()
      control键的状态在这个组合键上。
      String getDisplayText​()
      返回适合在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。
      KeyCombination.ModifierValue getMeta​()
      meta键的这个组合状态。
      String getName​()
      返回此 KeyCombination的字符串表示 KeyCombination 。
      KeyCombination.ModifierValue getShift​()
      shift这个键组合的状态。
      KeyCombination.ModifierValue getShortcut​()
      shortcut键的状态在这个组合键。
      int hashCode​()
      返回此 KeyCombination的哈希码值。
      static KeyCombination keyCombination​(String name)
      从指定的字符串构造一个新的 KeyCombination 。
      boolean match​(KeyEvent event)
      测试此组合是否与给定的 KeyEvent中的组合相匹配。
      String toString​()
      返回此对象的字符串表示形式。
      static KeyCombination valueOf​(String value)
      从指定的字符串构造一个新的 KeyCombination 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SHIFT_DOWN

        public static final KeyCombination.Modifier SHIFT_DOWN
        指定 shift键的 shift必须关闭。

      • SHIFT_ANY

        public static final KeyCombination.Modifier SHIFT_ANY
        修饰符指定 shift键可以是向上还是向下。

      • CONTROL_DOWN

        public static final KeyCombination.Modifier CONTROL_DOWN
        指定 control键的 control必须关闭。

      • CONTROL_ANY

        public static final KeyCombination.Modifier CONTROL_ANY
        修饰符指定 control键可以是向上还是向下。

      • ALT_DOWN

        public static final KeyCombination.Modifier ALT_DOWN
        指定 alt键的 alt必须关闭。

      • ALT_ANY

        public static final KeyCombination.Modifier ALT_ANY
        指定 alt键的 alt可以是向上还是向下。

      • META_DOWN

        public static final KeyCombination.Modifier META_DOWN
        指定 meta键的 meta必须关闭。

      • META_ANY

        public static final KeyCombination.Modifier META_ANY
        修饰符指定 meta键可以是向上还是向下。

      • SHORTCUT_DOWN

        public static final KeyCombination.Modifier SHORTCUT_DOWN
        指定 shortcut键的 shortcut必须关闭。

      • SHORTCUT_ANY

        public static final KeyCombination.Modifier SHORTCUT_ANY
        指定 shortcut键的 shortcut可以是向上还是向下。

      • NO_MATCH

        public static final KeyCombination NO_MATCH
        与任何事件匹配的KeyCombination。

    • 构造方法详细信息

      • KeyCombination

        protected KeyCombination​(KeyCombination.ModifierValue shift,
                         KeyCombination.ModifierValue control,
                         KeyCombination.ModifierValue alt,
                         KeyCombination.ModifierValue meta,
                         KeyCombination.ModifierValue shortcut)
        构造一个KeyCombination ，具有所有修饰键的显式规范。 每个修饰键可设置为DOWN ， UP或者ANY 。
        参数
        shift - shift修饰键的值
        control - 修改键值 control
        alt - 修改键值 alt
        meta - meta修饰键的值
        shortcut - 修改键值 shortcut

      • KeyCombination

        protected KeyCombination​(KeyCombination.Modifier... modifiers)
        构造具有指定的修饰符列表的KeyCombination 。 未明确列出的所有修饰键都设置为默认值UP 。

        所有可能修改默认修饰符值的修饰符都定义为KeyCombination类中的KeyCombination 。

        参数
        modifiers - 修饰键列表及其相应的值

    • 方法详细信息

      • getShift

        public final KeyCombination.ModifierValue getShift​()
        shift键的这个组合状态。
        结果
        shift键的状态在这个组合键上

      • getControl

        public final KeyCombination.ModifierValue getControl​()
        control关键在这个组合的状态。
        结果
        control键的状态在这个组合键上

      • getAlt

        public final KeyCombination.ModifierValue getAlt​()
        alt键的状态在这个组合键上。
        结果
        alt键的状态在这个组合键上。

      • getMeta

        public final KeyCombination.ModifierValue getMeta​()
        meta键的状态在这个组合键上。
        结果
        meta键的状态在这个组合键上

      • getShortcut

        public final KeyCombination.ModifierValue getShortcut​()
        shortcut键的状态在这个组合键上。
        结果
        这个密钥组合中的 shortcut密钥的状态

      • match

        public boolean match​(KeyEvent event)
        测试此组合是否与给定的KeyEvent中的组合相匹配。

        在KeyCombination类中实现此方法仅使用修饰键进行部分测试。 这个方法在子类中被覆盖，以便在测试中包含主键。

        参数
        event - 关键事件
        结果
        true如果键组合匹配，否则为 false

      • getName

        public String getName​()
        返回此KeyCombination的字符串表示KeyCombination 。

        字符串表示由加上字符分隔的部分组成。 每个部分指定一个修饰符键或主键。

        修饰符键部分包含修改键的KeyCode名称。 可以使用Ignored关键词作为前缀。 非前缀修饰符键意味着其DOWN值，而前缀版本意味着ANY （忽略）值。 如果没有在字符串中指定一些修饰符键，则表示它具有默认值UP 。

        密钥组合字符串的主键部分的格式取决于KeyCombination子类。 这无论是对关键代码名称KeyCodeCombination或单引号键字符KeyCharacterCombination 。

        KeyCombination字符串表示的示例：

          "Ctrl+Alt+Q"
"Ignore Shift+Ctrl+A"
"Alt+'w'"
        结果
        该字符串表示为 KeyCombination

      • getDisplayText

        public String getDisplayText​()
        返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。
        结果
        这个 KeyCombination字符串表示，适合在用户界面中显示。
        从以下版本开始：
        JavaFX 8u20

      • equals

        public boolean equals​(Object obj)
        测试这个 KeyCombination是否等于指定的对象。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        true如果对象相等，否则为 false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 KeyCombination的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此对象的字符串表示形式。 实现返回getName()调用的结果。
        重写：
        toString在 Object
        结果
        该字符串表示为 KeyCombination

      • valueOf

        public static KeyCombination valueOf​(String value)
        从指定的字符串构造一个新的KeyCombination 。 字符串的格式应与getName方法相同。

        如果主键区字符串用单引号引用，则该方法将为未引用的子字符串创建一个新的KeyCharacterCombination 。 否则它会找到与主键区字符串相对应的名称的键码，并KeyCodeCombination创建一个KeyCodeCombination 。 如果这不能完成，可以KeyCharacterCombination为KeyCharacterCombination 。

        参数
        value - 表示所请求的组合键的字符串
        结果
        构建了 KeyCombination
        从以下版本开始：
        JavaFX 2.1

      • keyCombination

        public static KeyCombination keyCombination​(String name)
        从指定的字符串构造一个新的KeyCombination 。 该方法简单地委托给valueOf(String) 。
        参数
        name - 表示请求的密钥组合的字符串
        结果
        构建了 KeyCombination
        另请参见：
        valueOf(String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


KeyCombination.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class KeyCombination.Modifier

  • java.lang.Object
    • javafx.scene.input.KeyCombination.Modifier
  • Enclosing class:
    KeyCombination

    public static final class KeyCombination.Modifier
extends Object
    此类表示一对修饰符键及其值。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      KeyCode getKey​()
      获取此 Modifier的修改键。
      KeyCombination.ModifierValue getValue​()
      获取此 Modifier的修饰符值。
      String toString​()
      返回修饰符的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getKey

        public KeyCode getKey​()
        获取此 Modifier的修饰键。
        结果
        修饰键

      • getValue

        public KeyCombination.ModifierValue getValue​()
        获取此 Modifier的修饰符值。
        结果
        修饰符值

      • toString

        public String toString​()
        返回修饰符的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of the modifier
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyCombination.ModifierValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Enum KeyCombination.ModifierValue

  • java.lang.Object
    • java.lang.Enum<KeyCombination.ModifierValue>
      • javafx.scene.input.KeyCombination.ModifierValue
  • All Implemented Interfaces:
    Serializable ， Comparable<KeyCombination.ModifierValue>
    Enclosing class:
    KeyCombination

    public static enum KeyCombination.ModifierValue
extends Enum<KeyCombination.ModifierValue>
    ModifierValue指定修饰键的状态。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ANY
      常数，表示修饰键可以是向上还是向下。
      DOWN
      表示修饰符键必须关闭的常数。
      UP
      表示修饰符键必须为常数的常数。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static KeyCombination.ModifierValue valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static KeyCombination.ModifierValue[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DOWN

        public static final KeyCombination.ModifierValue DOWN
        表示修饰符键必须关闭的常数。

      • UP

        public static final KeyCombination.ModifierValue UP
        表示修饰符键必须为常数的常数。

      • ANY

        public static final KeyCombination.ModifierValue ANY
        常数，表示修饰键可以是向上还是向下。

    • 方法详细信息

      • values

        public static KeyCombination.ModifierValue[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (KeyCombination.ModifierValue c : KeyCombination.ModifierValue.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static KeyCombination.ModifierValue valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


KeyEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class KeyEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.KeyEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class KeyEvent
extends InputEvent
    一个事件，表示击键发生在一个Node 。

    当按下，释放或键入键时，会生成此事件。 这取决于它被传递给事件的类型onKeyPressed ， onKeyTyped或者onKeyReleased功能。

    “键型”事件较高级，通常不依赖于平台或键盘布局。 它们在输入Unicode字符时生成，并且是查找字符输入的首选方式。 在最简单的情况下，键型事件由一个按键（例如'a'）产生。 然而，通常，字符由一系列按键（例如，SHIFT +'a'）产生，并且从按键事件到键类型事件的映射可以是多对一或多对多。 主要版本通常不需要生成键入类型的事件，但有些情况下键盘事件不会生成，直到键被释放（例如，通过Windows中的Alt-Numpad方法输入ASCII序列）。 不生成不产生Unicode字符的键（例如，操作键，修饰键等）的键类型事件。

    character变量始终包含有效的Unicode字符或CHAR_UNDEFINED。 字符输入由键类型事件报告; 按键和按键释放事件不一定与字符输入相关联。 因此， character变量保证仅对键类型事件有意义。

    对于按键和键释放事件， code变量包含事件的关键代码。 对于键类型事件， code变量始终包含KeyCode.UNDEFINED 。

    “按键”和“按键释放”事件较低级别，取决于平台和键盘布局。 它们是按键或释放键生成的，是找出不产生字符输入的键的唯一方法（例如，操作键，修改键等）。 按下或释放的键由代码变量指示，其中包含虚拟键代码。

    对于触发上下文菜单，请参阅ContextMenuEvent 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<KeyEvent> ANY
      所有关键事件类型的常用超类型。
      static String CHAR_UNDEFINED
      KEY_PRESSED和KEY_RELEASED事件不映射到一个有效的Unicode字符使用它作为keyChar值。
      static EventType<KeyEvent> KEY_PRESSED
      当按下键时，会发生此事件。
      static EventType<KeyEvent> KEY_RELEASED
      当一个键被释放时，会发生这种情况。
      static EventType<KeyEvent> KEY_TYPED
      当字符生成键被键入（按下并释放）时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      KeyEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      KeyEvent copyFor​(Object source, EventTarget target, EventType<KeyEvent> type)
      用给定的字段替换给定事件的副本。
      String getCharacter​()
      与键类型事件相关联的Unicode字符或字符序列。
      KeyCode getCode​()
      与该键中的键相关的键代码按下或键释放事件。
      EventType<KeyEvent> getEventType​()
      获取此事件的事件类型。
      String getText​()
      描述按键和键释放事件的键代码的字符串，如“HOME”，“F1”或“A”。
      boolean isAltDown​()
      返回此事件的Alt修饰符是否关闭。
      boolean isControlDown​()
      返回此修改器是否关闭此事件。
      boolean isMetaDown​()
      返回Meta修饰符在此事件上是否关闭。
      boolean isShiftDown​()
      返回此事件的Shift修饰符是否关闭。
      boolean isShortcutDown​()
      返回主机平台常用快捷方式修饰符是否在此事件上关闭。
      String toString​()
      返回此 KeyEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<KeyEvent> ANY
        所有关键事件类型的常用超类型。

      • KEY_PRESSED

        public static final EventType<KeyEvent> KEY_PRESSED
        当按下键时，会发生此事件。

      • KEY_RELEASED

        public static final EventType<KeyEvent> KEY_RELEASED
        当一个键被释放时，会发生这种情况。

      • KEY_TYPED

        public static final EventType<KeyEvent> KEY_TYPED
        当字符生成键被键入（按下并释放）时，会发生此事件。 该事件包含character字段包含的类型字符串， code和text字段不被使用。

      • CHAR_UNDEFINED

        public static final String CHAR_UNDEFINED
        KEY_PRESSED和KEY_RELEASED事件不映射到一个有效的Unicode字符使用它作为keyChar值。

    • 构造方法详细信息

      • KeyEvent

        public KeyEvent​(Object source,
                EventTarget target,
                EventType<KeyEvent> eventType,
                String character,
                String text,
                KeyCode code,
                boolean shiftDown,
                boolean controlDown,
                boolean altDown,
                boolean metaDown)
        从指定的参数构造一个新的 KeyEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        character - 与事件关联的字符或序列
        text - 描述键码的字符串
        code - 整数键码
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按Alt修饰符， altDown true。
        metaDown - 如果按下元修饰符， metaDown true。
        从以下版本开始：
        JavaFX 8.0

      • KeyEvent

        public KeyEvent​(EventType<KeyEvent> eventType,
                String character,
                String text,
                KeyCode code,
                boolean shiftDown,
                boolean controlDown,
                boolean altDown,
                boolean metaDown)
        从指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
        参数
        eventType - 事件的类型。
        character - 与事件关联的字符或字符序列
        text - 描述密钥代码的字符串
        code - 整数关键码
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getCharacter

        public final String getCharacter​()
        与键类型事件相关联的Unicode字符或字符序列。 如果密钥从基本多语言平面外部产生单个Unicode字符，则需要由Java中的相应代理对编码，或者如果密钥产生多个Unicode字符本身，则包含多个元素。

        例如， character将通过按SHIFT +'a'生成的键类型事件的值为“A”。 对于按键和按键释放事件， character始终为CHAR_UNDEFINED 。

        结果
        与键类型事件相关联的Unicode字符

      • getText

        public final String getText​()
        描述按键和键释放事件的键代码的字符串，如“HOME”，“F1”或“A”。 对于键类型的事件， text始终为空字符串。
        结果
        描述键码的字符串

      • getCode

        public final KeyCode getCode​()
        与该键中的键相关的键代码按下或键释放事件。 对于键型事件， code始终为KeyCode.UNDEFINED 。
        结果
        与此事件中的键相关的键代码， KeyCode.UNDEFINED用于键类型事件

      • isShiftDown

        public final boolean isShiftDown​()
        返回此事件的Shift修饰符是否关闭。
        结果
        Shift修饰符是否关闭此事件。

      • isControlDown

        public final boolean isControlDown​()
        返回此修改器是否关闭此事件。
        结果
        此修改器是否关闭此事件。

      • isAltDown

        public final boolean isAltDown​()
        返回此事件的Alt修饰符是否关闭。
        结果
        此修改器是否关闭此事件。

      • isMetaDown

        public final boolean isMetaDown​()
        返回Meta修饰符在此事件上是否关闭。
        结果
        Meta修饰符是否关闭此事件。

      • isShortcutDown

        public final boolean isShortcutDown​()
        返回主机平台常用快捷方式修饰符是否在此事件上关闭。 这个常用的快捷键修饰符是修改器键，通常用于主机平台上的快捷方式。 它例如control在Windows和meta在Mac（命令键）。
        结果
        true如果快捷键修饰符关闭，否则为 false

      • toString

        public String toString​()
        返回此 KeyEvent对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        这个 KeyEvent对象的字符串表示形式。

      • copyFor

        public KeyEvent copyFor​(Object newSource,
                        EventTarget newTarget)
        描述从类别复制： Event
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • copyFor

        public KeyEvent copyFor​(Object source,
                        EventTarget target,
                        EventType<KeyEvent> type)
        用给定的字段替换给定事件的副本。
        参数
        source - 复制事件的新来源
        target - 复制事件的新目标
        type - 新事件类型。
        结果
        事件副本与字段被替换
        从以下版本开始：
        JavaFX 8.0

      • getEventType

        public EventType<KeyEvent> getEventType​()
        描述从类别复制： Event
        获取此事件的事件类型。 相同的Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 InputEvent
        结果
        the event type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Mnemonic (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class Mnemonic

  • java.lang.Object
    • javafx.scene.input.Mnemonic

  • public class Mnemonic
extends Object
    创建助记符时使用此类。 助记符是由Node和KeyCombination构成的 。 当一个助记符在Scene上注册，并且KeyCombination到达没有消息的场景时，目标节点将被发送一个ActionEvent 。

    控件在添加助记符时应使用其助记符分配属性。

    助记符不会显示在所有平台上，但api仍然存在。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      Mnemonic​(Node node, KeyCombination keyCombination)
      构造一个Mnemonic与指定的目标Node和触发器KeyCombination 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void fire​()
      火ActionEvent
      KeyCombination getKeyCombination​()
      返回KeyCombination
      Node getNode​()
      返回Node
      void setKeyCombination​(KeyCombination keyCombination)
      设置KeyCombination
      void setNode​(Node node)
      设置Node

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Mnemonic

        public Mnemonic​(Node node,
                KeyCombination keyCombination)
        构造一个Mnemonic与指定的目标Node和触发器KeyCombination 。
        参数
        node - Node将会收到ActionEvent 。
        keyCombination - 将触发助记符的KeyCombination 。

    • 方法详细信息

      • getKeyCombination

        public KeyCombination getKeyCombination​()
        返回KeyCombination
        结果
        KeyCombination

      • setKeyCombination

        public void setKeyCombination​(KeyCombination keyCombination)
        设置KeyCombination
        参数
        keyCombination - KeyCombination

      • getNode

        public Node getNode​()
        返回Node
        结果
        Node

      • setNode

        public void setNode​(Node node)
        设置Node
        参数
        node - Node
        从以下版本开始：
        JavaFX 2.2

      • fire

        public void fire​()
        火ActionEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MouseButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Enum MouseButton

  • java.lang.Object
    • java.lang.Enum<MouseButton>
      • javafx.scene.input.MouseButton
  • All Implemented Interfaces:
    Serializable ， Comparable<MouseButton>

    public enum MouseButton
extends Enum<MouseButton>
    按钮名称映射
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      MIDDLE
      表示中间（按钮2）鼠标按钮。
      NONE
      不表示按钮
      PRIMARY
      代表主要（按钮1，通常是左）鼠标按钮。
      SECONDARY
      代表第二（按钮3，通常是右）鼠标按钮。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static MouseButton valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MouseButton[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NONE

        public static final MouseButton NONE
        不表示按钮

      • PRIMARY

        public static final MouseButton PRIMARY
        代表主要（按钮1，通常是左）鼠标按钮。

      • MIDDLE

        public static final MouseButton MIDDLE
        表示中间（按钮2）鼠标按钮。

      • SECONDARY

        public static final MouseButton SECONDARY
        代表第二（按钮3，通常是右）鼠标按钮。

    • 方法详细信息

      • values

        public static MouseButton[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (MouseButton c : MouseButton.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static MouseButton valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


MouseDragEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class MouseDragEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.MouseEvent
            • javafx.scene.input.MouseDragEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class MouseDragEvent
extends MouseEvent
    鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。 不同手势类型之间的差异描述于MouseEvent 。

    可以通过调用DRAG_DETECTED事件处理程序内部的一个节点或场景上的startFullDrag()来启动全按下拖动手势。 此呼叫激活在拖动手势期间将MouseDragEvent s传递到光标下的节点。

    当您拖动节点时，它仍然在光标下，因此在整个手势期间它被认为是潜在的手势目标。 如果您需要将节点拖到另一个节点并让另一个节点知道该节点，则需要确保将被拖动节点下的节点作为潜在的手势目标。 您可以通过调用实现这个setMouseTransparent(true)在拖动节点上MOUSE_PRESSED处理程序，并在返回回假MOUSE_RELEASED处理程序。 这样，拖动节点下的节点将接收到MouseDragEvent s，而所有的MouseEvent都将被传送到（当前的鼠标透明）手势源。

    输入/退出的事件与鼠标输入/退出事件的行为类似，请参阅MouseEvent概述。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<MouseDragEvent> ANY
      所有鼠标事件类型的常用超类型。
      static EventType<MouseDragEvent> MOUSE_DRAG_ENTERED
      当手势进入节点时，会发生此事件。
      static EventType<MouseDragEvent> MOUSE_DRAG_ENTERED_TARGET
      当手势进入节点时，会发生此事件。
      static EventType<MouseDragEvent> MOUSE_DRAG_EXITED
      当手势退出节点时，会发生此事件。
      static EventType<MouseDragEvent> MOUSE_DRAG_EXITED_TARGET
      当手势退出节点时，会发生此事件。
      static EventType<MouseDragEvent> MOUSE_DRAG_OVER
      当该节点内的手势进行时，会发生此事件。
      static EventType<MouseDragEvent> MOUSE_DRAG_RELEASED
      当手势在该节点上结束（通过释放鼠标按钮）时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

      • Fields inherited from class javafx.scene.input.MouseEvent

        DRAG_DETECTED, MOUSE_CLICKED, MOUSE_DRAGGED, MOUSE_ENTERED, MOUSE_ENTERED_TARGET, MOUSE_EXITED, MOUSE_EXITED_TARGET, MOUSE_MOVED, MOUSE_PRESSED, MOUSE_RELEASED

    • 构造方法摘要

      构造方法
      Constructor 描述
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MouseDragEvent copyFor​(Object newSource, EventTarget newTarget)
      将此事件复制到不同的来源和目标。
      MouseDragEvent copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> type)
      用给定的字段替换给定事件的副本。
      EventType<MouseDragEvent> getEventType​()
      获取此事件的事件类型。
      Object getGestureSource​()
      返回正在进行的手势的源对象。
      String toString​()
      返回此 MouseDragEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class javafx.scene.input.MouseEvent

        copyForMouseDragEvent, getButton, getClickCount, getPickResult, getSceneX, getSceneY, getScreenX, getScreenY, getX, getY, getZ, isAltDown, isControlDown, isDragDetect, isMetaDown, isMiddleButtonDown, isPopupTrigger, isPrimaryButtonDown, isSecondaryButtonDown, isShiftDown, isShortcutDown, isStillSincePress, isSynthesized, setDragDetect

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<MouseDragEvent> ANY
        所有鼠标事件类型的常用超类型。

      • MOUSE_DRAG_OVER

        public static final EventType<MouseDragEvent> MOUSE_DRAG_OVER
        当该节点内的手势进行时，会发生此事件。

      • MOUSE_DRAG_RELEASED

        public static final EventType<MouseDragEvent> MOUSE_DRAG_RELEASED
        当手势在该节点上结束（通过释放鼠标按钮）时，会发生此事件。

      • MOUSE_DRAG_ENTERED_TARGET

        public static final EventType<MouseDragEvent> MOUSE_DRAG_ENTERED_TARGET
        当手势进入节点时，会发生此事件。 这是冒泡的变体，它也被传递给输入节点的所有父母（除非被消耗）。 当不希望有关鼠标进入某些节点的子节点的通知时，应使用MOUSE_DRAG_ENTERED事件处理程序。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling which is similar

      • MOUSE_DRAG_ENTERED

        public static final EventType<MouseDragEvent> MOUSE_DRAG_ENTERED
        当手势进入节点时，会发生此事件。 此事件类型仅传递到输入的节点，如果父母要过滤或获取冒泡事件，则需要使用MOUSE_DRAG_ENTERED_TARGET 。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling which is similar

      • MOUSE_DRAG_EXITED_TARGET

        public static final EventType<MouseDragEvent> MOUSE_DRAG_EXITED_TARGET
        当手势退出节点时，会发生此事件。 这是冒泡的变体，它也被传递给退出节点的所有父母（除非被消耗）。 当不希望有关鼠标退出某些节点的子节点的通知时，应使用MOUSE_DRAG_EXITED事件处理程序。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling which is similar

      • MOUSE_DRAG_EXITED

        public static final EventType<MouseDragEvent> MOUSE_DRAG_EXITED
        当手势退出节点时，会发生此事件。 此事件类型仅传递到退出的节点，如果父节点要过滤或获取冒泡事件，则需要使用MOUSE_DRAG_EXITED_TARGET 。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling which is similar

    • 构造方法详细信息

      • MouseDragEvent

        public MouseDragEvent​(Object source,
                      EventTarget target,
                      EventType<MouseDragEvent> eventType,
                      double x,
                      double y,
                      double screenX,
                      double screenY,
                      MouseButton button,
                      int clickCount,
                      boolean shiftDown,
                      boolean controlDown,
                      boolean altDown,
                      boolean metaDown,
                      boolean primaryButtonDown,
                      boolean middleButtonDown,
                      boolean secondaryButtonDown,
                      boolean synthesized,
                      boolean popupTrigger,
                      PickResult pickResult,
                      Object gestureSource)
        构造新的MouseDragEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于场景的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        button - 使用鼠标按钮
        clickCount - 点击次数
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        primaryButtonDown - 如果按下主按钮， primaryButtonDown true。
        middleButtonDown - 如果按下中间按钮， middleButtonDown true。
        secondaryButtonDown - 如果按下辅助按钮， secondaryButtonDown true。
        synthesized - 如果这个事件是合成的
        popupTrigger - 此事件是否表示当前平台的弹出式触发器
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标和目标构建不带任何其他值的2D选取结果
        gestureSource - 正在进行的手势的源对象。
        从以下版本开始：
        JavaFX 8.0

      • MouseDragEvent

        public MouseDragEvent​(EventType<MouseDragEvent> eventType,
                      double x,
                      double y,
                      double screenX,
                      double screenY,
                      MouseButton button,
                      int clickCount,
                      boolean shiftDown,
                      boolean controlDown,
                      boolean altDown,
                      boolean metaDown,
                      boolean primaryButtonDown,
                      boolean middleButtonDown,
                      boolean secondaryButtonDown,
                      boolean synthesized,
                      boolean popupTrigger,
                      PickResult pickResult,
                      Object gestureSource)
        构造具有null源和目标的新的MouseDragEvent事件。
        参数
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        button - 使用鼠标按钮
        clickCount - 点击次数
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        primaryButtonDown - 如果主按钮被按下， primaryButtonDown true。
        middleButtonDown - 如果按下中间按钮， middleButtonDown true。
        secondaryButtonDown - 如果按下辅助按钮， secondaryButtonDown true。
        synthesized - 如果这个事件是合成的
        popupTrigger - 此事件是否表示当前平台的弹出式触发器
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        gestureSource - 持续手势的源对象。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getGestureSource

        public Object getGestureSource​()
        返回正在进行的手势的源对象。 手势源是开始完全按下 - 拖动释放手势的对象（正在调用startFullDrag方法）。
        结果
        手势的源对象。

      • toString

        public String toString​()
        返回此 MouseDragEvent对象的字符串表示形式。
        重写：
        toString在 MouseEvent
        结果
        这个 MouseDragEvent对象的字符串表示形式。

      • copyFor

        public MouseDragEvent copyFor​(Object newSource,
                              EventTarget newTarget)
        描述从类复制： MouseEvent
        将此事件复制到不同的来源和目标。 在大多数情况下，您不需要使用此方法，它在您触发事件时自动调用。
        重写：
        copyFor在 MouseEvent
        参数
        newSource - 新事件来源
        newTarget - 新事件目标
        结果
        该事件的副本用于不同的来源和目标

      • copyFor

        public MouseDragEvent copyFor​(Object newSource,
                              EventTarget newTarget,
                              EventType<? extends MouseEvent> type)
        描述从类复制： MouseEvent
        用给定的字段替换给定事件的副本。
        重写：
        copyFor MouseEvent
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        type - 新的eventType
        结果
        事件副本与字段被替换

      • getEventType

        public EventType<MouseDragEvent> getEventType​()
        描述从类别复制Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 MouseEvent
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


MouseEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class MouseEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.MouseEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    MouseDragEvent

    public class MouseEvent
extends InputEvent
    当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。

    鼠标（指针的）位置相对于多个坐标系可用：X，Y -相对于所述的MouseEvent的节点，sceneX，sceneY的原点-相对于至原点Scene包含节点，screenX，screenY -相对于包含鼠标指针的屏幕原点。

    拖动手势

    拖动手势有三种类型。 它们都是由鼠标按下事件发起的，并且由于鼠标释放事件而终止，源节点决定将发生哪个手势。

    简单的按压拖动手势是默认的。 它最好用于允许更改形状的大小，拖动它等等。 整个按压拖动手势被传送到一个节点。 当按下鼠标按钮时，选择最上面的节点，并将所有后续的鼠标事件传递到同一个节点，直到按钮被释放。 如果从这些事件生成鼠标点击事件，它仍然传递到同一个节点。

    在简单的按压拖放手势期间，其他节点不涉及，不会得到任何事件。 如果这些节点需要参与手势，则必须激活全按压释放手势。 这种手势最适合用于通过“导线”连接节点，将节点拖动到其他节点等。这种手势类型在MouseDragEvent中更加详细地描述，其中包含传递给手势目标的事件。

    第三种手势类型是平台支持的拖放手势。 它最适合传输数据，也可以在（不一定是FX）应用程序之间工作。 这种手势类型在DragEvent更详细地描述。

    简而言之，当按下鼠标按钮时，将自动激活简单的按压拖动手势，并将所有MouseEvent传送到手势源。 当你开始拖动，最终DRAG_DETECTED事件到达。 在其处理程序中，您可以通过在节点或场景上调用startFullDrag方法启动完全按下 - 拖动释放手势 - 将MouseDragEvent开始传送到手势目标，也可以通过在节点上调用startDragAndDrop方法开始拖放手势或场景 - 系统切换到拖放模式，而DragEvent开始被传送，而不是MouseEvent 。 如果您不调用任何这些方法，则继续简单的按下 - 拖动释放手势。

    请注意，通过触摸屏拖曳手指会产生鼠标拖动事件，但也会滚动手势事件。 如果这意味着应用程序中的冲突（物理拖动操作由两个不同的处理程序处理），则可以使用isSynthesized()方法来检测问题，并使拖动处理程序相应地进行操作。

    鼠标进入/退出处理

    当鼠标进入节点时，节点获取MOUSE_ENTERED事件，当它离开时，它会获得MOUSE_EXITED事件。 这些事件仅传递到输入/退出的节点，并且似乎没有通过捕获/冒泡阶段。 这是最常见的用例。

    当捕获或鼓泡是期望的，有MOUSE_ENTERED_TARGET / MOUSE_EXITED_TARGET事件。 这些事件通常通过捕获/冒泡阶段。 这意味着当鼠标输入父本身或其某些孩子时，父母可能会收到MOUSE_ENTERED_TARGET事件。 为了区分这两种情况，事件目标可以与节点相等地进行测试。

    这两种类型的紧密连接： MOUSE_ENTERED / MOUSE_EXITED是亚型MOUSE_ENTERED_TARGET / MOUSE_EXITED_TARGET 。 在拍摄阶段， MOUSE_ENTERED_TARGET交给了父母。 当事件传递到事件目标（实际输入的节点）时，其类型切换到MOUSE_ENTERED 。 然后将类型切换回MOUSE_ENTERED_TARGET进行冒泡阶段。 它仍然是一个事件，只是切换类型，所以如果它被过滤或消费，它会影响两个事件的变体。 由于子类型关系，一个MOUSE_ENTERED_TARGET事件处理程序将收到目标上的MOUSE_ENTERED事件。

    笔记

    • 触发上下文菜单请参阅ContextMenuEvent 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<MouseEvent> ANY
      所有鼠标事件类型的常用超类型。
      static EventType<MouseEvent> DRAG_DETECTED
      该事件被传递到被识别为拖动手势的源的节点。
      static EventType<MouseEvent> MOUSE_CLICKED
      当单击鼠标按钮（在同一节点上按下并释放）时，会发生此事件。
      static EventType<MouseEvent> MOUSE_DRAGGED
      当鼠标按下按钮移动时，会发生此事件。
      static EventType<MouseEvent> MOUSE_ENTERED
      当鼠标进入节点时，会发生此事件。
      static EventType<MouseEvent> MOUSE_ENTERED_TARGET
      当鼠标进入节点时，会发生此事件。
      static EventType<MouseEvent> MOUSE_EXITED
      当鼠标退出节点时，会发生此事件。
      static EventType<MouseEvent> MOUSE_EXITED_TARGET
      当鼠标退出节点时，会发生此事件。
      static EventType<MouseEvent> MOUSE_MOVED
      当鼠标在节点内移动并且没有按钮被按下时，会发生此事件。
      static EventType<MouseEvent> MOUSE_PRESSED
      当按下鼠标按钮时，会发生此事件。
      static EventType<MouseEvent> MOUSE_RELEASED
      当鼠标按钮被释放时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MouseEvent copyFor​(Object newSource, EventTarget newTarget)
      将此事件复制到不同的来源和目标。
      MouseEvent copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> eventType)
      用给定的字段替换给定事件的副本。
      static MouseDragEvent copyForMouseDragEvent​(MouseEvent e, Object source, EventTarget target, EventType<MouseDragEvent> type, Object gestureSource, PickResult pickResult)
      创建MouseDragEvent类型的鼠标事件的副本
      MouseButton getButton​()
      哪个，如果有的话，鼠标按钮是负责这个事件。
      int getClickCount​()
      返回与此事件关联的鼠标点击数。
      EventType<? extends MouseEvent> getEventType​()
      获取此事件的事件类型。
      PickResult getPickResult​()
      返回有关选择的信息。
      double getSceneX​()
      返回事件相对于包含MouseEvent源的 Scene的原点的水平位置。
      double getSceneY​()
      返回事件相对于包含MouseEvent源的 Scene的原点的垂直位置。
      double getScreenX​()
      返回事件的绝对水平位置。
      double getScreenY​()
      返回事件的绝对垂直位置。
      double getX​()
      事件的水平位置相对于MouseEvent源的来源。
      double getY​()
      事件相对于MouseEvent来源的垂直位置。
      double getZ​()
      事件的相对于MouseEvent源的来源的深度位置。
      boolean isAltDown​()
      此修改器是否关闭此事件。
      boolean isControlDown​()
      Control修饰符是否关闭此事件。
      boolean isDragDetect​()
      确定此事件是否将跟随 DRAG_DETECTED事件。
      boolean isMetaDown​()
      Meta修饰符在此事件中是否关闭。
      boolean isMiddleButtonDown​()
      如果当前按下中间按钮（按钮2），则返回 true 。
      boolean isPopupTrigger​()
      如果此鼠标事件是平台的弹出菜单触发事件，则返回 true 。
      boolean isPrimaryButtonDown​()
      如果主按钮（按钮1，通常是左））当前被按下，则返回 true 。
      boolean isSecondaryButtonDown​()
      如果二级按钮（按钮1，通常是右））当前被按下，则返回 true 。
      boolean isShiftDown​()
      Shift修饰符是否关闭此事件。
      boolean isShortcutDown​()
      返回主机平台常用快捷方式修饰符是否在此事件上关闭。
      boolean isStillSincePress​()
      指示鼠标光标是否停留在系统提供的滞后区域内，因为在此事件之前发生的上次按下的事件。
      boolean isSynthesized​()
      指示此事件是否使用触摸屏而不是通常的鼠标事件源设备（如鼠标或跟踪板）进行合成。
      void setDragDetect​(boolean dragDetect)
      增强拖动检测行为。
      String toString​()
      返回此 MouseEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<MouseEvent> ANY
        所有鼠标事件类型的常用超类型。

      • MOUSE_PRESSED

        public static final EventType<MouseEvent> MOUSE_PRESSED
        当按下鼠标按钮时，会发生此事件。 这将激活按下 - 拖动释放手势，因此直到按钮被释放的所有后续的鼠标事件被传递到同一个节点。

      • MOUSE_RELEASED

        public static final EventType<MouseEvent> MOUSE_RELEASED
        当鼠标按钮被释放时，会发生此事件。 它被传递到已经按下按钮的相同节点，该按钮激活了按压 - 释放手势。

      • MOUSE_CLICKED

        public static final EventType<MouseEvent> MOUSE_CLICKED
        当单击鼠标按钮（在同一节点上按下并释放）时，会发生此事件。 此事件为任何节点提供类似按钮的行为。 请注意，即使长时间的拖放也可以生成点击事件（它被传递到鼠标被按下并释放的最顶端的节点）。

      • MOUSE_ENTERED_TARGET

        public static final EventType<MouseEvent> MOUSE_ENTERED_TARGET
        当鼠标进入节点时，会发生此事件。 这是冒泡的变体，它也被传递给输入节点的所有父母（除非被消耗）。 当不希望有关鼠标进入某些节点的子节点的通知时，应使用MOUSE_ENTERED事件处理程序。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling

      • MOUSE_ENTERED

        public static final EventType<MouseEvent> MOUSE_ENTERED
        当鼠标进入节点时，会发生此事件。 此事件类型仅传递到输入的节点，如果父母要过滤或获取冒泡事件，则需要使用MOUSE_ENTERED_TARGET 。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling

      • MOUSE_EXITED_TARGET

        public static final EventType<MouseEvent> MOUSE_EXITED_TARGET
        当鼠标退出节点时，会发生此事件。 这是冒泡的变体，它也被传递给退出节点的所有父母（除非被消耗）。 当不希望有关鼠标退出某些节点的子节点的通知时，应使用MOUSE_EXITED事件处理程序。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling

      • MOUSE_EXITED

        public static final EventType<MouseEvent> MOUSE_EXITED
        当鼠标退出节点时，会发生此事件。 此事件类型仅传递到退出的节点，如果父节点要过滤或获取冒泡事件，则需要使用MOUSE_EXITED_TARGET 。
        另请参见：
        MouseEvent for more information about mouse entered/exited handling

      • MOUSE_MOVED

        public static final EventType<MouseEvent> MOUSE_MOVED
        当鼠标在节点内移动并且没有按钮被按下时，会发生此事件。 如果按下任何鼠标按钮，则会发生MOUSE_DRAGGED事件。

      • MOUSE_DRAGGED

        public static final EventType<MouseEvent> MOUSE_DRAGGED
        当鼠标按下按钮移动时，会发生此事件。 它被传递到已经按下按钮的相同节点，该按钮激活了按压 - 释放手势。 无论鼠标在节点的边界内，都会传送它。

      • DRAG_DETECTED

        public static final EventType<MouseEvent> DRAG_DETECTED
        该事件被传递到被识别为拖动手势的源的节点。 这个事件的处理程序是唯一可以启动全按下拖动手势或拖放手势的地方（通过调用startFullDrag()的startDragAndDrop()方法）。 如果没有一个人被调用，简单的按压拖动手势将继续。

        请注意，他的事件是基于将鼠标拖到特定于平台的距离阈值上生成的。 您可以通过任何MOUSE_PRESSED或MOUSE_DRAGGED事件调用setDragDetect方法修改此行为。

        另请参见：
        MouseEvent for more details about simple press-drag-release gestures ， MouseDragEvent for more details about full press-drag-release gestures ， DragEvent for more details about drag and drop gestures

    • 构造方法详细信息

      • MouseEvent

        public MouseEvent​(EventType<? extends MouseEvent> eventType,
                  double x,
                  double y,
                  double screenX,
                  double screenY,
                  MouseButton button,
                  int clickCount,
                  boolean shiftDown,
                  boolean controlDown,
                  boolean altDown,
                  boolean metaDown,
                  boolean primaryButtonDown,
                  boolean middleButtonDown,
                  boolean secondaryButtonDown,
                  boolean synthesized,
                  boolean popupTrigger,
                  boolean stillSincePress,
                  PickResult pickResult)
        构造具有null源和目标的新的MouseEvent事件。
        参数
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于场景的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        button - 使用鼠标按钮
        clickCount - 点击次数
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按Alt修饰符， altDown true。
        metaDown - 如果按下元修饰符， metaDown true。
        primaryButtonDown - 如果按下主按钮， primaryButtonDown true。
        middleButtonDown - 如果按下中间按钮， middleButtonDown true。
        secondaryButtonDown - 如果辅助按钮被按下， secondaryButtonDown true。
        synthesized - 如果这个事件是合成的
        popupTrigger - 此事件是否表示当前平台的弹出式触发器
        stillSincePress - 见 isStillSincePress()
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

      • MouseEvent

        public MouseEvent​(Object source,
                  EventTarget target,
                  EventType<? extends MouseEvent> eventType,
                  double x,
                  double y,
                  double screenX,
                  double screenY,
                  MouseButton button,
                  int clickCount,
                  boolean shiftDown,
                  boolean controlDown,
                  boolean altDown,
                  boolean metaDown,
                  boolean primaryButtonDown,
                  boolean middleButtonDown,
                  boolean secondaryButtonDown,
                  boolean synthesized,
                  boolean popupTrigger,
                  boolean stillSincePress,
                  PickResult pickResult)
        构造新的MouseEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        x - 相对于源的x。 如果source == null或source不是Node，则应该在场景坐标中。
        y - 相对于源的y。 如果source == null或source不是Node，则应该在场景坐标中。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        button - 使用鼠标按钮
        clickCount - 点击次数
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下元修饰符， metaDown true。
        primaryButtonDown - 如果按下主按钮， primaryButtonDown true。
        middleButtonDown - 如果按下中间按钮， middleButtonDown true。
        secondaryButtonDown - 如果按下辅助按钮， secondaryButtonDown true。
        synthesized - 如果这个事件是合成的
        popupTrigger - 此事件是否表示当前平台的弹出式触发器
        stillSincePress - 见 isStillSincePress()
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标和目标构建不带任何其他值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getEventType

        public EventType<? extends MouseEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 InputEvent
        结果
        事件类型

      • copyFor

        public MouseEvent copyFor​(Object newSource,
                          EventTarget newTarget)
        将此事件复制到不同的来源和目标。 在大多数情况下，您不需要使用此方法，它在您触发事件时自动调用。
        重写：
        copyFor在 Event
        参数
        newSource - 新事件来源
        newTarget - 新事件目标
        结果
        该事件的副本用于不同的来源和目标

      • copyFor

        public MouseEvent copyFor​(Object newSource,
                          EventTarget newTarget,
                          EventType<? extends MouseEvent> eventType)
        用给定的字段替换给定事件的副本。
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        eventType - 新的eventType
        结果
        事件副本与字段被替换
        从以下版本开始：
        JavaFX 8.0

      • copyForMouseDragEvent

        public static MouseDragEvent copyForMouseDragEvent​(MouseEvent e,
                                                   Object source,
                                                   EventTarget target,
                                                   EventType<MouseDragEvent> type,
                                                   Object gestureSource,
                                                   PickResult pickResult)
        创建MouseDragEvent类型的鼠标事件的副本
        参数
        e - 要复制的鼠标事件
        source - 复制事件的新来源
        target - 复制事件的新目标
        type - 新的MouseDragEvent类型
        gestureSource - 手势的新来源
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        结果
        由MouseEvent创建的新MouseDragEvent
        从以下版本开始：
        JavaFX 8.0

      • isDragDetect

        public boolean isDragDetect​()
        确定此事件是否会后跟DRAG_DETECTED事件。 它只对MOUSE_PRESSED和MOUSE_DRAGGED事件有效。
        结果
        如果 DRAG_DETECTED事件跟随， DRAG_DETECTED true

      • setDragDetect

        public void setDragDetect​(boolean dragDetect)
        增强拖动检测行为。 该值表示此事件是否将跟随DRAG_DETECTED事件。 它只对MOUSE_PRESSED和MOUSE_DRAGGED事件有效。
        参数
        dragDetect - 是否会跟随 DRAG_DETECTED事件

      • getX

        public final double getX​()
        事件的水平位置相对于MouseEvent源的来源。
        结果
        事件的水平位置相对于MouseEvent源的来源。

      • getY

        public final double getY​()
        事件相对于MouseEvent来源的垂直位置。
        结果
        事件相对于MouseEvent源的原点的垂直位置。

      • getZ

        public final double getZ​()
        事件的相对于MouseEvent源的来源的深度位置。
        结果
        事件的相对于MouseEvent源的起点的深度位置。
        从以下版本开始：
        JavaFX 8.0

      • getScreenX

        public final double getScreenX​()
        返回事件的绝对水平位置。
        结果
        绝对水平位置的事件

      • getScreenY

        public final double getScreenY​()
        返回事件的绝对垂直位置。
        结果
        事件的绝对垂直位置

      • getSceneX

        public final double getSceneX​()
        返回事件相对于包含MouseEvent源的Scene的原点的水平位置。 如果节点不在一个Scene ，则该值相对于MouseEvent节点最根的父节点的boundsInParent。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        事件的水平位置相对于包含MouseEvent源的 Scene的原点

      • getSceneY

        public final double getSceneY​()
        返回事件相对于包含MouseEvent源的Scene的原点的垂直位置。 如果节点不在一个Scene ，则该值相对于MouseEvent节点的最根本父属的boundsInParent。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        事件的垂直位置相对于包含MouseEvent源的 Scene的原点

      • getButton

        public final MouseButton getButton​()
        哪个，如果有的话，鼠标按钮是负责这个事件。
        结果
        状态变化导致此事件的鼠标按钮

      • getClickCount

        public final int getClickCount​()
        返回与此事件关联的鼠标点击数。 所有MOUSE_MOVED事件的clickCount值等于0.该值随MOUSE_PRESSED事件增加，并保持与所有后续事件相同，直到MOUSE_RELEASED，包括后续生成的MOUSE_CLICKED事件。 如果两个后续按钮之间的所有事件都发生在小区域和小时间（根据本地操作系统配置），则该值将增加到高于1的数字。
        结果
        与此事件关联的鼠标点击次数

      • isStillSincePress

        public final boolean isStillSincePress​()
        指示鼠标光标是否停留在系统提供的滞后区域内，因为在此事件之前发生的上次按下的事件。

        无论按压和释放之间的鼠标移动如何，如果鼠标都被按下并释放，则会为节点生成点击事件。 如果节点想要在简单的点击和鼠标拖动上做出不同的反应，它应该使用系统提供的短距离阈值来确定点击和拖动（用户通常在点击期间执行无意的微小移动）。 通过忽略所有拖动可以轻松实现，方法返回true ，忽略所有点击，此方法返回false 。

        结果
        如果在此事件之前发生的最后一次按下的事件，如果没有显着的鼠标移动（系统滞后区域以外），则为true。

      • isShiftDown

        public final boolean isShiftDown​()
        Shift修饰符是否关闭此事件。
        结果
        如果Shift修饰符关闭此事件，则为true

      • isControlDown

        public final boolean isControlDown​()
        Control修饰符是否关闭此事件。
        结果
        如果Control修饰符在此事件中关闭，则为true

      • isAltDown

        public final boolean isAltDown​()
        此修改器是否关闭此事件。
        结果
        如果Alt修饰符关闭此事件，则为true

      • isMetaDown

        public final boolean isMetaDown​()
        Meta修饰符在此事件中是否关闭。
        结果
        如果Meta修饰符关闭此事件，则为true

      • isSynthesized

        public boolean isSynthesized​()
        指示此事件是否使用触摸屏而不是通常的鼠标事件源设备（如鼠标或跟踪板）进行合成。 当手指被拖动到触摸屏上时，产生滚动手势和鼠标拖动。 如果它在应用程序中导致冲突，则可以使用该标志来分辨通常的鼠标从拖动已经作为滚动事件处理的触摸屏拖动。
        结果
        如果此事件是使用触摸屏合成的，则为true
        从以下版本开始：
        JavaFX 2.2

      • isShortcutDown

        public final boolean isShortcutDown​()
        返回主机平台常用快捷方式修饰符是否在此事件上关闭。 这个常用的快捷键修饰符是修改器键，通常用于主机平台上的快捷方式。 它例如control在Windows和meta在Mac（命令键）。
        结果
        true如果快捷方式修饰符已关闭，否则为 false

      • isPopupTrigger

        public final boolean isPopupTrigger​()
        如果此鼠标事件是平台的弹出菜单触发器事件，则返回true 。

        注意 ：弹出菜单在不同的系统上触发不同。 因此， popupTrigger应检查onMousePressed和mouseReleased以获得正确的跨平台功能。

        结果
        true如果这个鼠标事件是平台的弹出菜单触发事件
        从以下版本开始：
        JavaFX 8.0

      • isPrimaryButtonDown

        public final boolean isPrimaryButtonDown​()
        如果主按钮（按钮1，通常是左））当前按下，则返回true 。 请注意，这与getButton()方法不同，该方法指示哪个按钮按钮负责此事件，而此方法指示是否按下主按钮。
        结果
        true如果主按钮（按钮1，通常是左）当前被按下

      • isSecondaryButtonDown

        public final boolean isSecondaryButtonDown​()
        如果二级按钮（按钮1，通常是右））当前被按下，则返回true 。 请注意，这与getButton()方法不同，该方法指示哪个按钮按钮负责此事件，而此方法指示是否按下辅助按钮。
        结果
        true如果辅助按钮（按钮3，通常是右）当前被按下

      • isMiddleButtonDown

        public final boolean isMiddleButtonDown​()
        如果当前按下中间按钮（按钮2），则返回true 。 请注意，这与getButton()方法不同，该方法指示哪个按钮按钮负责此事件，而此方法指示中间按钮是否被按下。
        结果
        true如果中间按钮（按钮2）当前被按下

      • toString

        public String toString​()
        返回此 MouseEvent对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        这个 MouseEvent对象的字符串表示形式。

      • getPickResult

        public final PickResult getPickResult​()
        返回有关选择的信息。
        结果
        新的PickResult对象包含有关选择的信息
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PickResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class PickResult

  • java.lang.Object
    • javafx.scene.input.PickResult

  • public class PickResult
extends Object
    包含pick事件结果的容器对象
    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int FACE_UNDEFINED
      一个未定义的脸。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PickResult​(EventTarget target, double sceneX, double sceneY)
      为不需要额外信息的2D情况创建选择结果。
      PickResult​(Node node, Point3D point, double distance)
      为非3d形状的目标创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point2D texCoord)
      创建一个新的PickResult实例。
      PickResult​(Node node, Point3D point, double distance, int face, Point3D normal, Point2D texCoord)
      创建一个新的PickResult实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getIntersectedDistance​()
      返回相机位置和相交点之间的相交距离。
      int getIntersectedFace​()
      返回所选节点的相交面，如果节点没有用户指定的面或被选中的边界，则返回FACE_UNDEFINED。
      Node getIntersectedNode​()
      返回相交的节点。
      Point3D getIntersectedNormal​()
      返回所选择的3D形状的相交法线。
      Point3D getIntersectedPoint​()
      返回所选节点的局部坐标中的相交点。
      Point2D getIntersectedTexCoord​()
      返回所选3D形状的相交纹理坐标。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • FACE_UNDEFINED

        public static final int FACE_UNDEFINED
        一个未定义的脸。 如果所选节点没有用户指定的面，则该值用于相交面。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • PickResult

        public PickResult​(Node node,
                  Point3D point,
                  double distance,
                  int face,
                  Point2D texCoord)
        创建一个新的PickResult实例。
        参数
        node - 相交节点
        point - point节点的局部坐标中的相交点
        distance - 摄像机位置与拾取的节点之间的相交距离
        face - face节点的相交面
        texCoord - texCoord节点的相交纹理坐标

      • PickResult

        public PickResult​(Node node,
                  Point3D point,
                  double distance,
                  int face,
                  Point3D normal,
                  Point2D texCoord)
        创建一个新的PickResult实例。
        参数
        node - 相交节点
        point - point节点的局部坐标中的相交点
        distance - 摄像机位置与拾取的节点之间的相交距离
        face - face节点的相交面
        texCoord - texCoord节点的相交纹理坐标
        normal - normal节点的相交法线
        从以下版本开始：
        JavaFX 8u40

      • PickResult

        public PickResult​(Node node,
                  Point3D point,
                  double distance)
        为非3d形状的目标创建一个新的PickResult实例。 将面设置为FACE_UNDEFINED，将texCoord设置为null。
        参数
        node - 相交节点
        point - point节点的局部坐标中的相交点
        distance - 摄像机位置与拾取的节点之间的相交距离

      • PickResult

        public PickResult​(EventTarget target,
                  double sceneX,
                  double sceneY)
        为不需要额外信息的2D情况创建选择结果。 将给定的场景坐标转换为目标的局部坐标空间，并将该值存储为相交点。 将相交节点设置为给定目标，距离为1.0，面向FACE_UNDEFINED和texCoord为null。
        参数
        target - 被挑选的目标（在场景的情况下为空）
        sceneX - 场景X坐标
        sceneY - 场景Y坐标

    • 方法详细信息

      • getIntersectedNode

        public final Node getIntersectedNode​()
        返回相交的节点。 如果与任何节点没有交集并且选择了场景，则返回null。
        结果
        所选节点，如果没有选择节点，则为null

      • getIntersectedPoint

        public final Point3D getIntersectedPoint​()
        返回所选节点的局部坐标中的相交点。 如果没有选择节点，则返回与投影平面相交的点。
        结果
        新的Point3D呈现交点

      • getIntersectedDistance

        public final double getIntersectedDistance​()
        返回相机位置和相交点之间的相交距离。
        结果
        从相机到交叉点的距离

      • getIntersectedFace

        public final int getIntersectedFace​()
        返回所选节点的相交面，如果节点没有用户指定的面或被选中的边界，则返回FACE_UNDEFINED。
        结果
        被挑选的脸

      • getIntersectedNormal

        public final Point3D getIntersectedNormal​()
        返回所选择的3D形状的相交法线。 如果拾取的目标不是Shape3D或pickOnBounds == true，则返回null。
        结果
        一个新的Point3D呈现相交正常
        从以下版本开始：
        JavaFX 8u40

      • getIntersectedTexCoord

        public final Point2D getIntersectedTexCoord​()
        返回所选3D形状的相交纹理坐标。 如果拾取的目标不是Shape3D或pickOnBounds == true，则返回null。
        结果
        一个新的Point2D展示了相互交织的TexCoord

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RotateEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class RotateEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.GestureEvent
            • javafx.scene.input.RotateEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class RotateEvent
extends GestureEvent
    旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。

    该事件被传送到在手势开始时在手势坐标上选择的最顶端的节点 - 即使坐标在手势期间改变，也将整个手势传送到同一节点。

    事件提供两个值： angle是这个事件的旋转角度， totalAngle是整个手势的旋转角度。 两个值都以度为单位，并且在添加到节点的rotate属性值（顺时针旋转的正值）时工作良好。

    作为所有手势，旋转可以是直接的（直接在具体的坐标处直接执行在触摸屏上 - 所有触摸中的中心点通常用作手势坐标）或间接（间接执行在跟踪板上 - 鼠标光标位置是通常用作手势坐标）。

    手势的ROTATE事件被ROTATION_STARTED和ROTATION_FINISHED事件ROTATION_FINISHED 。 如果转动惯量是活跃在给定的平台上，一些ROTATE事件与isInertia()返回true可以来后ROTATION_FINISHED 。

    从以下版本开始：
    JavaFX 2.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<RotateEvent> ANY
      所有旋转事件类型的公共超类型。
      static EventType<RotateEvent> ROTATE
      当用户执行旋转手势（例如将两个手指彼此拖动时）发生此事件。
      static EventType<RotateEvent> ROTATION_FINISHED
      当旋转手势结束时，会发生此事件。
      static EventType<RotateEvent> ROTATION_STARTED
      当检测到旋转手势时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      RotateEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      RotateEvent copyFor​(Object newSource, EventTarget newTarget, EventType<RotateEvent> type)
      用给定的字段替换给定事件的副本。
      double getAngle​()
      获取此事件的旋转角度。
      EventType<RotateEvent> getEventType​()
      获取此事件的事件类型。
      double getTotalAngle​()
      获取此手势的累积旋转角度。
      String toString​()
      返回此 RotateEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class javafx.scene.input.GestureEvent

        getPickResult, getSceneX, getSceneY, getScreenX, getScreenY, getX, getY, getZ, isAltDown, isControlDown, isDirect, isInertia, isMetaDown, isShiftDown, isShortcutDown

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<RotateEvent> ANY
        所有旋转事件类型的公共超类型。

      • ROTATE

        public static final EventType<RotateEvent> ROTATE
        当用户执行旋转手势（例如将两个手指彼此拖动时）发生此事件。

      • ROTATION_STARTED

        public static final EventType<RotateEvent> ROTATION_STARTED
        当检测到旋转手势时，会发生此事件。

      • ROTATION_FINISHED

        public static final EventType<RotateEvent> ROTATION_FINISHED
        当旋转手势结束时，会发生此事件。

    • 构造方法详细信息

      • RotateEvent

        public RotateEvent​(Object source,
                   EventTarget target,
                   EventType<RotateEvent> eventType,
                   double x,
                   double y,
                   double screenX,
                   double screenY,
                   boolean shiftDown,
                   boolean controlDown,
                   boolean altDown,
                   boolean metaDown,
                   boolean direct,
                   boolean inertia,
                   double angle,
                   double totalAngle,
                   PickResult pickResult)
        构造新的RotateEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见GestureEvent.isDirect()
        inertia - 如果表示已经完成的手势的惯性。
        angle - 旋转角度
        totalAngle - 累积旋转角度
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标和目标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

      • RotateEvent

        public RotateEvent​(EventType<RotateEvent> eventType,
                   double x,
                   double y,
                   double screenX,
                   double screenY,
                   boolean shiftDown,
                   boolean controlDown,
                   boolean altDown,
                   boolean metaDown,
                   boolean direct,
                   boolean inertia,
                   double angle,
                   double totalAngle,
                   PickResult pickResult)
        构造具有null源和目标的新的RotateEvent事件
        参数
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见GestureEvent.isDirect()
        inertia - 如果表示已经完成的手势的惯性。
        angle - 旋转角度
        totalAngle - 累积旋转角度
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getAngle

        public double getAngle​()
        获取此事件的旋转角度。 角度以度为单位，并且在添加到节点的rotate属性值（顺时针旋转的正值）时工作良好。
        结果
        这个事件的旋转角度

      • getTotalAngle

        public double getTotalAngle​()
        获取此手势的累积旋转角度。 角度以度为单位，并且在添加到节点的rotate属性值（顺时针旋转的正值）时工作良好。
        结果
        这个手势的累积旋转角度

      • toString

        public String toString​()
        返回此 RotateEvent对象的字符串表示形式。
        重写：
        toString在 GestureEvent
        结果
        这个 RotateEvent对象的字符串表示形式。

      • copyFor

        public RotateEvent copyFor​(Object newSource,
                           EventTarget newTarget)
        描述从类别复制： GestureEvent
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 GestureEvent
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • copyFor

        public RotateEvent copyFor​(Object newSource,
                           EventTarget newTarget,
                           EventType<RotateEvent> type)
        用给定的字段替换给定事件的副本。
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        type - 新的eventType
        结果
        事件副本与字段被替换
        从以下版本开始：
        JavaFX 8.0

      • getEventType

        public EventType<RotateEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 GestureEvent
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ScrollEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class ScrollEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.GestureEvent
            • javafx.scene.input.ScrollEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class ScrollEvent
extends GestureEvent
    滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。

    当通过触摸手势（例如在触摸屏上拖动手指）产生滚动时，它被SCROLL_STARTED和SCROLL_FINISHED事件包围。 在滚动期间更改涉及的触摸点数量被认为是新的手势，因此每次touchCount更改时都会传送一对SCROLL_FINISHED和SCROLL_STARTED通知。 当滚动是由鼠标滚轮旋转引起的，只有一次性SCROLL事件被传递，而没有启动/完成的环境。 如果在给定的平台上滚动惯性激活，则SCROLL事件isInertia()返回true可以在SCROLL_FINISHED之后。

    该事件被传送到在手势开始时在手势坐标上选择的最顶端的节点 - 即使坐标在手势期间改变，也将整个手势传送到同一节点。 对于鼠标滚轮旋转，事件被传递到在鼠标光标位置拾取的最顶层节点。 交付与当前焦点所有者无关。

    该事件提供两种不同类型的滚动值：基于像素和基于字符/线的。 基本的deltaX和deltaY值用作滚动的像素数（ totalDeltaX和totalDeltaY包含整个手势的累积值，鼠标滚轮的零）给出合理的结果。 对于滚动文本（或其他基于行的内容作为表），如果可用，应使用textDelta值。 textDeltaXUnits和textDeltaYUnits确定如何解释textDeltaX和textDeltaY值。 如果单位设置为NONE ，则基于文本的值不可用（不由底层平台提供），并且需要使用基于像素的值。

    作为所有手势，滚动可以是直接的（直接在具体的坐标上直接执行，如在触摸屏上 - 所有触摸中的中心点通常用作手势坐标）或间接（间接执行在跟踪板或鼠标 - 鼠标光标位置通常用作手势坐标）。

    例如，滚动图形节点可以通过以下代码实现：

       node.setOnScroll(new EventHandler<ScrollEvent>() { @Override public void handle(ScrollEvent event) { node.setTranslateX(node.getTranslateX() + event.getDeltaX()); node.setTranslateY(node.getTranslateY() + event.getDeltaY()); } });

    根据所有平台上的系统设置，基于文本的组件的滚动事件处理程序应包含以下逻辑：

       switch(event.getTextDeltaYUnits()) { case LINES: // scroll about event.getTextDeltaY() lines break; case PAGES: // scroll about event.getTextDeltaY() pages break; case NONE: // scroll about event.getDeltaY() pixels break; }
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ScrollEvent.HorizontalTextScrollUnits
      水平文本滚动单元。
      static class  ScrollEvent.VerticalTextScrollUnits
      垂直的基于文本的滚动单元。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<ScrollEvent> ANY
      所有滚动事件类型的常用超类型。
      static EventType<ScrollEvent> SCROLL
      当用户执行滚动操作（例如旋转鼠标滚轮或在触摸屏上拖动手指）时，会发生此事件。
      static EventType<ScrollEvent> SCROLL_FINISHED
      当滚动手势结束时，会发生此事件。
      static EventType<ScrollEvent> SCROLL_STARTED
      当检测到滚动手势时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ScrollEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      ScrollEvent copyFor​(Object newSource, EventTarget newTarget, EventType<ScrollEvent> type)
      用给定的字段替换给定事件的副本。
      double getDeltaX​()
      获取水平滚动量。
      double getDeltaY​()
      获取垂直滚动量。
      EventType<ScrollEvent> getEventType​()
      获取此事件的事件类型。
      double getMultiplierX​()
      获取用于将鼠标滚轮旋转单位转换为像素的乘数
      double getMultiplierY​()
      获取用于将鼠标滚轮旋转单位转换为像素的乘数
      double getTextDeltaX​()
      获取基于水平文本的滚动量。
      ScrollEvent.HorizontalTextScrollUnits getTextDeltaXUnits​()
      获取基于文本滚动的水平滚动单位。
      double getTextDeltaY​()
      获取垂直的基于文本的滚动量。
      ScrollEvent.VerticalTextScrollUnits getTextDeltaYUnits​()
      获取基于文本滚动的垂直滚动单位。
      double getTotalDeltaX​()
      获取整个手势的累积水平滚动量。
      double getTotalDeltaY​()
      获取整个手势的累积垂直滚动量。
      int getTouchCount​()
      获得导致此事件的触摸点数。
      String toString​()
      返回此 ScrollEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class javafx.scene.input.GestureEvent

        getPickResult, getSceneX, getSceneY, getScreenX, getScreenY, getX, getY, getZ, isAltDown, isControlDown, isDirect, isInertia, isMetaDown, isShiftDown, isShortcutDown

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<ScrollEvent> ANY
        所有滚动事件类型的常用超类型。

      • SCROLL

        public static final EventType<ScrollEvent> SCROLL
        当用户执行滚动操作（例如旋转鼠标滚轮或在触摸屏上拖动手指）时，会发生此事件。

      • SCROLL_STARTED

        public static final EventType<ScrollEvent> SCROLL_STARTED
        当检测到滚动手势时，会发生此事件。 鼠标滚轮不会发生。
        从以下版本开始：
        JavaFX 2.2

      • SCROLL_FINISHED

        public static final EventType<ScrollEvent> SCROLL_FINISHED
        当滚动手势结束时，会发生此事件。 鼠标滚轮不会发生。
        从以下版本开始：
        JavaFX 2.2

    • 构造方法详细信息

      • ScrollEvent

        public ScrollEvent​(Object source,
                   EventTarget target,
                   EventType<ScrollEvent> eventType,
                   double x,
                   double y,
                   double screenX,
                   double screenY,
                   boolean shiftDown,
                   boolean controlDown,
                   boolean altDown,
                   boolean metaDown,
                   boolean direct,
                   boolean inertia,
                   double deltaX,
                   double deltaY,
                   double totalDeltaX,
                   double totalDeltaY,
                   ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits,
                   double textDeltaX,
                   ScrollEvent.VerticalTextScrollUnits textDeltaYUnits,
                   double textDeltaY,
                   int touchCount,
                   PickResult pickResult)
        构造新的ScrollEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见GestureEvent.isDirect()
        inertia - 如果表示已经完成的手势的惯性。
        deltaX - 水平滚动量
        deltaY - 垂直滚动量
        totalDeltaX - 累积水平滚动量
        totalDeltaY - 累积垂直滚动量
        textDeltaXUnits - 水平文本滚动量单位
        textDeltaX - 水平文本滚动量
        textDeltaYUnits - 垂直文本滚动量单位
        textDeltaY - 垂直文本滚动量
        touchCount - 接触点数
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标和目标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

      • ScrollEvent

        public ScrollEvent​(EventType<ScrollEvent> eventType,
                   double x,
                   double y,
                   double screenX,
                   double screenY,
                   boolean shiftDown,
                   boolean controlDown,
                   boolean altDown,
                   boolean metaDown,
                   boolean direct,
                   boolean inertia,
                   double deltaX,
                   double deltaY,
                   double totalDeltaX,
                   double totalDeltaY,
                   ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits,
                   double textDeltaX,
                   ScrollEvent.VerticalTextScrollUnits textDeltaYUnits,
                   double textDeltaY,
                   int touchCount,
                   PickResult pickResult)
        构造具有null源和目标的新的ScrollEvent事件
        参数
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见GestureEvent.isDirect()
        inertia - 如果表示已经完成的手势的惯性。
        deltaX - 水平滚动量
        deltaY - 垂直滚动量
        totalDeltaX - 累积水平滚动量
        totalDeltaY - 累积垂直滚动量
        textDeltaXUnits - 水平文本滚动量单位
        textDeltaX - 水平文本滚动量
        textDeltaYUnits - 垂直文本滚动量单位
        textDeltaY - 垂直文本滚动量
        touchCount - 接触点数
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

      • ScrollEvent

        public ScrollEvent​(EventType<ScrollEvent> eventType,
                   double x,
                   double y,
                   double screenX,
                   double screenY,
                   boolean shiftDown,
                   boolean controlDown,
                   boolean altDown,
                   boolean metaDown,
                   boolean direct,
                   boolean inertia,
                   double deltaX,
                   double deltaY,
                   double totalDeltaX,
                   double totalDeltaY,
                   double multiplierX,
                   double multiplierY,
                   ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits,
                   double textDeltaX,
                   ScrollEvent.VerticalTextScrollUnits textDeltaYUnits,
                   double textDeltaY,
                   int touchCount,
                   PickResult pickResult)
        构造具有null源和目标的新的ScrollEvent事件
        参数
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于场景的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见GestureEvent.isDirect()
        inertia - 如果表示已经完成的手势的惯性。
        deltaX - 水平滚动量
        deltaY - 垂直滚动量
        totalDeltaX - 累积水平滚动量
        totalDeltaY - 累积垂直滚动量
        multiplierX - 用于将轮转换为像素的X乘数
        multiplierY - 用于将轮转动转换为像素的Y乘数
        textDeltaXUnits - 水平文本滚动量单位
        textDeltaX - 水平文本滚动量
        textDeltaYUnits - 垂直文本滚动量单位
        textDeltaY - 垂直文本滚动量
        touchCount - 接触点数
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getDeltaX

        public double getDeltaX​()
        获取水平滚动量。 该值应解释为要滚动的像素数。 当滚动基于文本的内容时，应首先考虑textDeltaX和textDeltaXUnits值。

        该值的符号与坐标系相反（当您向右滚动时，内容实际上需要向左）。 所以返回的值可以简单地添加到内容的X坐标。

        结果
        水平滚动的像素数

      • getDeltaY

        public double getDeltaY​()
        获取垂直滚动量。 该值应解释为要滚动的像素数。 当滚动基于行的内容时，应首先考虑textDeltaY和textDeltaYUnits值。

        该值的符号与坐标系相反（当您向下滚动时，内容实际上需要上升）。 所以返回的值可以简单地添加到内容的Y坐标中。

        结果
        垂直滚动的像素数

      • getTotalDeltaX

        public double getTotalDeltaX​()
        获取整个手势的累积水平滚动量。 该值应被解释为相对于手势开始时的状态滚动的像素数。 包含鼠标滚轮滚动的零。

        该值的符号与坐标系相反（当您向右滚动时，内容实际上需要向左）。 所以返回的值可以简单地添加到内容的X坐标中。

        结果
        手势期间水平滚动的像素数
        从以下版本开始：
        JavaFX 2.2

      • getTotalDeltaY

        public double getTotalDeltaY​()
        获取整个手势的累积垂直滚动量。 该值应被解释为相对于手势开始时的状态滚动的像素数。 包含鼠标滚轮滚动的零。

        该值的符号与坐标系相反（当您向下滚动时，内容实际上需要上升）。 所以返回的值可以简单地添加到内容的Y坐标中。

        结果
        在手势期间垂直滚动的像素数
        从以下版本开始：
        JavaFX 2.2

      • getTextDeltaXUnits

        public ScrollEvent.HorizontalTextScrollUnits getTextDeltaXUnits​()
        获取基于文本滚动的水平滚动单位。 返回值表示如何解释getTextDeltaX()值。 如果返回值为NONE ，则基于文本的滚动值不可用，需要使用基于像素的getDeltaX()值。
        结果
        用于基于文本的滚动的水平滚动单位

      • getTextDeltaYUnits

        public ScrollEvent.VerticalTextScrollUnits getTextDeltaYUnits​()
        获取基于文本滚动的垂直滚动单位。 返回值表示如何解释getTextDeltaY()值。 如果返回值为NONE ，则基于文本的滚动值不可用，需要使用基于像素的getDeltaY()值。
        结果
        用于基于文本滚动的垂直滚动单位

      • getTextDeltaX

        public double getTextDeltaX​()
        获取基于水平文本的滚动量。 该值应根据getTextDeltaXUnits()值进行解释。
        结果
        水平滚动的单位数量，如果基于文本的水平滚动数据不可用，则 getTextDeltaXUnits()返回 NONE

      • getTextDeltaY

        public double getTextDeltaY​()
        获取垂直的基于文本的滚动量。 该值应根据getTextDeltaYUnits()值进行解释。
        结果
        垂直滚动的单位数量，如果基于文本的垂直滚动数据不可用，则 getTextDeltaYUnits()返回 NONE

      • getTouchCount

        public int getTouchCount​()
        获得导致此事件的触摸点数。 对于非触摸源设备作为鼠标滚轮和手势完成后的惯性事件返回零。
        结果
        导致此事件的触点数
        从以下版本开始：
        JavaFX 2.2

      • getMultiplierX

        public double getMultiplierX​()
        获取用于将鼠标滚轮旋转单位转换为像素的乘数
        结果
        x乘数
        从以下版本开始：
        JavaFX 8.0

      • getMultiplierY

        public double getMultiplierY​()
        获取用于将鼠标滚轮旋转单位转换为像素的乘数
        结果
        y乘数
        从以下版本开始：
        JavaFX 8.0

      • toString

        public String toString​()
        返回此 ScrollEvent对象的字符串表示形式。
        重写：
        toString在 GestureEvent
        结果
        这个 ScrollEvent对象的字符串表示形式。

      • copyFor

        public ScrollEvent copyFor​(Object newSource,
                           EventTarget newTarget)
        说明从类别GestureEvent复制
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 GestureEvent
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • copyFor

        public ScrollEvent copyFor​(Object newSource,
                           EventTarget newTarget,
                           EventType<ScrollEvent> type)
        用给定的字段替换给定事件的副本。
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        type - 新的eventType
        结果
        事件副本与字段被替换
        从以下版本开始：
        JavaFX 8.0

      • getEventType

        public EventType<ScrollEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 GestureEvent
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ScrollEvent.HorizontalTextScrollUnits (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Enum ScrollEvent.HorizontalTextScrollUnits

  • java.lang.Object
    • java.lang.Enum<ScrollEvent.HorizontalTextScrollUnits>
      • javafx.scene.input.ScrollEvent.HorizontalTextScrollUnits
  • All Implemented Interfaces:
    Serializable ， Comparable<ScrollEvent.HorizontalTextScrollUnits>
    Enclosing class:
    ScrollEvent

    public static enum ScrollEvent.HorizontalTextScrollUnits
extends Enum<ScrollEvent.HorizontalTextScrollUnits>
    水平文本滚动单元。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CHARACTERS
      水平文本滚动量是要滚动的字符数。
      NONE
      基于水平文本的滚动数据不可用（不由底层平台提供）。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ScrollEvent.HorizontalTextScrollUnits valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ScrollEvent.HorizontalTextScrollUnits[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NONE

        public static final ScrollEvent.HorizontalTextScrollUnits NONE
        基于水平文本的滚动数据不可用（不由底层平台提供）。

      • CHARACTERS

        public static final ScrollEvent.HorizontalTextScrollUnits CHARACTERS
        水平文本滚动量是要滚动的字符数。

    • 方法详细信息

      • values

        public static ScrollEvent.HorizontalTextScrollUnits[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ScrollEvent.HorizontalTextScrollUnits c : ScrollEvent.HorizontalTextScrollUnits.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ScrollEvent.HorizontalTextScrollUnits valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ScrollEvent.VerticalTextScrollUnits (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Enum ScrollEvent.VerticalTextScrollUnits

  • java.lang.Object
    • java.lang.Enum<ScrollEvent.VerticalTextScrollUnits>
      • javafx.scene.input.ScrollEvent.VerticalTextScrollUnits
  • All Implemented Interfaces:
    Serializable ， Comparable<ScrollEvent.VerticalTextScrollUnits>
    Enclosing class:
    ScrollEvent

    public static enum ScrollEvent.VerticalTextScrollUnits
extends Enum<ScrollEvent.VerticalTextScrollUnits>
    垂直的基于文本的滚动单元。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      LINES
      垂直的基于文本的滚动量是要滚动的行数。
      NONE
      垂直的基于文本的滚动数据不可用（不由底层平台提供）。
      PAGES
      垂直的基于文本的滚动量是要滚动的页面数。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ScrollEvent.VerticalTextScrollUnits valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ScrollEvent.VerticalTextScrollUnits[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NONE

        public static final ScrollEvent.VerticalTextScrollUnits NONE
        垂直的基于文本的滚动数据不可用（不由底层平台提供）。

      • LINES

        public static final ScrollEvent.VerticalTextScrollUnits LINES
        垂直的基于文本的滚动量是要滚动的行数。

      • PAGES

        public static final ScrollEvent.VerticalTextScrollUnits PAGES
        垂直的基于文本的滚动量是要滚动的页面数。

    • 方法详细信息

      • values

        public static ScrollEvent.VerticalTextScrollUnits[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ScrollEvent.VerticalTextScrollUnits c : ScrollEvent.VerticalTextScrollUnits.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ScrollEvent.VerticalTextScrollUnits valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


SwipeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class SwipeEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.GestureEvent
            • javafx.scene.input.SwipeEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class SwipeEvent
extends GestureEvent
    滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。

    与其他手势不同，滑动手势不是持续的 - 整个手势只产生一个事件。 事件被传递到在手势坐标上挑选的最顶层节点。

    滑动手势根据移动方向有四种类型。 手势可以由任意数量的触摸点执行，数字由getTouchCount()提供。

    请注意，滑动和滚动手势不是排他的。 单次触摸屏操作可以导致两种手势被传送。

    请注意，产生滑动的能力取决于所使用的输入设备和底层平台的功能和设置（特别是没有触摸屏用户可以显着减少滑动）。

    作为所有手势，滑动可以是直接的（直接在具体的坐标处执行，如在触摸屏上 - 手势的中心用作手势坐标）或间接（间接执行在跟踪板上 - 鼠标光标位置通常用作这种情况下的手势坐标）。

    从以下版本开始：
    JavaFX 2.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<SwipeEvent> ANY
      所有滑动事件类型的常用超类型。
      static EventType<SwipeEvent> SWIPE_DOWN
      当用户执行向下滑动手势时，会发生此事件。
      static EventType<SwipeEvent> SWIPE_LEFT
      当用户执行向左滑动手势时，会发生此事件。
      static EventType<SwipeEvent> SWIPE_RIGHT
      当用户执行向右滑动手势时，会发生此事件。
      static EventType<SwipeEvent> SWIPE_UP
      当用户执行向上滑动手势时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SwipeEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      SwipeEvent copyFor​(Object newSource, EventTarget newTarget, EventType<SwipeEvent> type)
      用给定的字段替换给定事件的副本。
      EventType<SwipeEvent> getEventType​()
      获取此事件的事件类型。
      int getTouchCount​()
      获得导致此事件的触摸点数。
      String toString​()
      返回此 SwipeEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class javafx.scene.input.GestureEvent

        getPickResult, getSceneX, getSceneY, getScreenX, getScreenY, getX, getY, getZ, isAltDown, isControlDown, isDirect, isInertia, isMetaDown, isShiftDown, isShortcutDown

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<SwipeEvent> ANY
        所有滑动事件类型的常用超类型。

      • SWIPE_LEFT

        public static final EventType<SwipeEvent> SWIPE_LEFT
        当用户执行向左滑动手势时，会发生此事件。

      • SWIPE_RIGHT

        public static final EventType<SwipeEvent> SWIPE_RIGHT
        当用户执行向右滑动手势时，会发生此事件。

      • SWIPE_UP

        public static final EventType<SwipeEvent> SWIPE_UP
        当用户执行向上滑动手势时，会发生此事件。

      • SWIPE_DOWN

        public static final EventType<SwipeEvent> SWIPE_DOWN
        当用户执行向下滑动手势时，会发生此事件。

    • 构造方法详细信息

      • SwipeEvent

        public SwipeEvent​(Object source,
                  EventTarget target,
                  EventType<SwipeEvent> eventType,
                  double x,
                  double y,
                  double screenX,
                  double screenY,
                  boolean shiftDown,
                  boolean controlDown,
                  boolean altDown,
                  boolean metaDown,
                  boolean direct,
                  int touchCount,
                  PickResult pickResult)
        构造新的SwipeEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见GestureEvent.isDirect()
        touchCount - 接触点数
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标和目标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

      • SwipeEvent

        public SwipeEvent​(EventType<SwipeEvent> eventType,
                  double x,
                  double y,
                  double screenX,
                  double screenY,
                  boolean shiftDown,
                  boolean controlDown,
                  boolean altDown,
                  boolean metaDown,
                  boolean direct,
                  int touchCount,
                  PickResult pickResult)
        构造具有null源和目标的新的SwipeEvent事件。
        参数
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于场景的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见GestureEvent.isDirect()
        touchCount - 接触点数
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getTouchCount

        public int getTouchCount​()
        获得导致此事件的触摸点数。
        结果
        导致此事件的触点数

      • toString

        public String toString​()
        返回此 SwipeEvent对象的字符串表示形式。
        重写：
        toString GestureEvent
        结果
        这个 SwipeEvent对象的字符串表示形式。

      • copyFor

        public SwipeEvent copyFor​(Object newSource,
                          EventTarget newTarget)
        说明从类别复制GestureEvent
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 GestureEvent
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • copyFor

        public SwipeEvent copyFor​(Object newSource,
                          EventTarget newTarget,
                          EventType<SwipeEvent> type)
        用给定的字段替换给定事件的副本。
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        type - 新的eventType
        结果
        事件副本与字段被替换
        从以下版本开始：
        JavaFX 8.0

      • getEventType

        public EventType<SwipeEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 GestureEvent
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TouchEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class TouchEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.TouchEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class TouchEvent
extends InputEvent
    触摸事件表示触摸屏操作。 它包含有关每个特定触摸点的详细信息。

    触摸点表示单个触摸的手指，并具有其位置，状态（按下/移动/释放/静止）以及在单个手势范围内唯一的ID。 详细参考见TouchPoint 。

    对于每个多点触摸动作，产生一组触摸事件 - 对于每个触摸点一。 事件类型对应于其触点状态。 每个事件还包含所有接触点的列表。 该设计允许从一个地方处理复杂的多点触摸动作，同时保持可以分别过滤/消耗每个触摸点。 要识别属于单个集合的事件是getEventSetId()方法。

    每个触摸点 - 类似于鼠标拖动 - 传递到单个节点上被按下，无论它在哪里移动。 可以通过使用TouchPoint文档中描述的抓取机制来更改此行为。

    从以下版本开始：
    JavaFX 2.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<TouchEvent> ANY
      所有触摸事件类型的常用超类型。
      static EventType<TouchEvent> TOUCH_MOVED
      触摸点移动时会发生此事件。
      static EventType<TouchEvent> TOUCH_PRESSED
      当按下触摸点（第一次触摸）时，会发生此事件。
      static EventType<TouchEvent> TOUCH_RELEASED
      当触发点被释放时，会发生此事件。
      static EventType<TouchEvent> TOUCH_STATIONARY
      当按住触摸点并静止（不移动）时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TouchEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      TouchEvent copyFor​(Object newSource, EventTarget newTarget, EventType<TouchEvent> type)
      用给定的字段替换给定事件的副本。
      int getEventSetId​()
      获取表示相同多点触摸动作的一组触摸事件的顺序号。
      EventType<TouchEvent> getEventType​()
      获取此事件的事件类型。
      int getTouchCount​()
      返回此触摸事件集所表示的触摸点数。
      TouchPoint getTouchPoint​()
      获取此事件的触点。
      List<TouchPoint> getTouchPoints​()
      获取由这组触摸事件表示的所有触摸点，包括此事件的触摸点。
      boolean isAltDown​()
      此修改器是否关闭此事件。
      boolean isControlDown​()
      Control修饰符是否关闭此事件。
      boolean isMetaDown​()
      Meta修饰符在此事件中是否关闭。
      boolean isShiftDown​()
      Shift修饰符是否关闭此事件。
      String toString​()
      返回此 TouchEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<TouchEvent> ANY
        所有触摸事件类型的常用超类型。

      • TOUCH_PRESSED

        public static final EventType<TouchEvent> TOUCH_PRESSED
        当按下触摸点（第一次触摸）时，会发生此事件。

      • TOUCH_MOVED

        public static final EventType<TouchEvent> TOUCH_MOVED
        触摸点移动时会发生此事件。

      • TOUCH_RELEASED

        public static final EventType<TouchEvent> TOUCH_RELEASED
        当触发点被释放时，会发生此事件。

      • TOUCH_STATIONARY

        public static final EventType<TouchEvent> TOUCH_STATIONARY
        当按住触摸点并静止（不移动）时，会发生此事件。

    • 构造方法详细信息

      • TouchEvent

        public TouchEvent​(Object source,
                  EventTarget target,
                  EventType<TouchEvent> eventType,
                  TouchPoint touchPoint,
                  List<TouchPoint> touchPoints,
                  int eventSetId,
                  boolean shiftDown,
                  boolean controlDown,
                  boolean altDown,
                  boolean metaDown)
        构建新的TouchEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        touchPoint - 这个事件的接触点
        touchPoints - 多点触摸动作的触摸点集
        eventSetId - 设置多点触摸动作的ID
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按Alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        从以下版本开始：
        JavaFX 8.0

      • TouchEvent

        public TouchEvent​(EventType<TouchEvent> eventType,
                  TouchPoint touchPoint,
                  List<TouchPoint> touchPoints,
                  int eventSetId,
                  boolean shiftDown,
                  boolean controlDown,
                  boolean altDown,
                  boolean metaDown)
        构造具有null源和目标的新的TouchEvent事件。
        参数
        eventType - 事件的类型。
        touchPoint - 这个事件的接触点
        touchPoints - 多点触摸动作的触摸点集
        eventSetId - 设置多点触摸动作的ID
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按Alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getTouchCount

        public int getTouchCount​()
        返回此触摸事件集所表示的触摸点数。 返回的数字与touchPoints列表的大小相匹配。
        结果
        由触摸事件设置的触摸点数。

      • copyFor

        public TouchEvent copyFor​(Object newSource,
                          EventTarget newTarget)
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • copyFor

        public TouchEvent copyFor​(Object newSource,
                          EventTarget newTarget,
                          EventType<TouchEvent> type)
        用给定的字段替换给定事件的副本。
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        type - 新的eventType
        结果
        事件副本与字段被替换
        从以下版本开始：
        JavaFX 8.0

      • getEventType

        public EventType<TouchEvent> getEventType​()
        说明从类别复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 InputEvent
        结果
        事件类型

      • getEventSetId

        public final int getEventSetId​()
        获取表示相同多点触摸动作的一组触摸事件的顺序号。 对于多点触控用户动作，可能存在触摸点的数量; 它们中的每一个产生触摸事件，每个触摸事件携带相同的触摸点列表，并且它们都从该方法返回相同的数字。 那么一些接触点的状态发生变化，新的一组事件就有了新的id。 该ID保证在一个手势的范围内是顺序和唯一的（当所有触摸点被释放时复位）。
        结果
        事件设置的顺序ID在手势范围内是唯一的

      • isShiftDown

        public final boolean isShiftDown​()
        Shift修饰符是否关闭此事件。
        结果
        如果Shift修饰符关闭此事件，则为true

      • isControlDown

        public final boolean isControlDown​()
        Control修饰符是否关闭此事件。
        结果
        如果Control修饰符在此事件中关闭，则为true

      • isAltDown

        public final boolean isAltDown​()
        此修改器是否关闭此事件。
        结果
        如果Alt修饰符关闭此事件，则为true

      • isMetaDown

        public final boolean isMetaDown​()
        Meta修饰符在此事件中是否关闭。
        结果
        如果Meta修饰符关闭此事件，则为true

      • getTouchPoint

        public TouchPoint getTouchPoint​()
        获取此事件的触点。
        结果
        触碰此事件

      • getTouchPoints

        public List<TouchPoint> getTouchPoints​()
        获取由这组触摸事件表示的所有触摸点，包括此事件的触摸点。 该列表是不可修改的，并按其ID进行排序，这意味着它也按照被按下的时间排序。 为了区分属于节点的触摸点和不相关的触摸点，可以使用TouchPoint的belongsTo方法。
        结果
        所有当前的接触点在一个不可修改的列表

      • toString

        public String toString​()
        返回此 TouchEvent对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        这个 TouchEvent对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TouchPoint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class TouchPoint

  • java.lang.Object
    • javafx.scene.input.TouchPoint
  • All Implemented Interfaces:
    Serializable

    public final class TouchPoint
extends Object
implements Serializable
    触摸点表示多点触摸动作的单个点，通常一个手指触摸屏幕。 它包含在TouchEvent中 。

    触摸点具有坐标，状态（见TouchPoint.State ）和ID。 ID是单个多点触摸手势范围内唯一的该触摸点的顺序号。

    默认情况下，每个触摸点在其整个轨迹中传递到单个节点 - 被按下的节点。 有一个抓住API来修改此行为。 上述表示当按下触摸点时，它被按压坐标上最顶端的节点自动抓取。 任何时候手势grab()和ungrab()方法都可以用来改变事件传递目标。 当被不同的节点抓住时，它将被下一次针对它; 当未解密时，它将始终定位到当前位置上最顶端的节点。

    从以下版本开始：
    JavaFX 2.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TouchPoint.State
      表示触摸点的当前状态

    • 构造方法摘要

      构造方法
      Constructor 描述
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean belongsTo​(EventTarget target)
      区分目标在给定节点或其某些孩子的触摸点之间的接触点，指向其他地方。
      EventTarget getGrabbed​()
      获得抓住这个接触点的事件目标。
      int getId​()
      获取此接触点的标识符。
      PickResult getPickResult​()
      返回有关选择的信息。
      double getSceneX​()
      获取触摸点的相对原点的水平位置 Scene包含TouchEvent的来源。
      double getSceneY​()
      获取触摸点的相对原点的垂直位置 Scene包含TouchEvent的来源。
      double getScreenX​()
      获取触摸点的绝对水平位置。
      double getScreenY​()
      获取触摸点的绝对垂直位置。
      TouchPoint.State getState​()
      获取此触点的状态
      EventTarget getTarget​()
      获取触发此触摸点触发事件的事件目标。
      double getX​()
      获取触摸点相对于TouchEvent源的原点的水平位置。
      double getY​()
      获取触摸点相对于TouchEvent源的原点的垂直位置。
      double getZ​()
      事件的相对于MouseEvent源的来源的深度位置。
      void grab​()
      抓住这个接触点的当前事件来源。
      void grab​(EventTarget target)
      按照给定的目标抓住这个接触点。
      String toString​()
      返回此 TouchPoint对象的字符串表示形式。
      void ungrab​()
      从目标中解开这个接触点。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TouchPoint

        public TouchPoint​(int id,
                  TouchPoint.State state,
                  double x,
                  double y,
                  double screenX,
                  double screenY,
                  EventTarget target,
                  PickResult pickResult)
        创建TouchPoint的新实例。
        参数
        id - 新的接触点的ID
        state - 新的接触点的状态
        x - 相对于场景的x。
        y - 相对于现场的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        target - 节点或其他事件目标。
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标和目标构建不带任何其他值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • belongsTo

        public boolean belongsTo​(EventTarget target)
        区分目标在给定节点或其某些孩子的触摸点之间的接触点，指向其他地方。 这允许测试由一个触摸事件承载的与给定节点的相关性的所有触摸点。
        参数
        target - 要测试的节点或其他事件目标
        结果
        如果此接触点针对给定目标或其某些子项，则为true

      • getGrabbed

        public EventTarget getGrabbed​()
        获得抓住这个接触点的事件目标。
        结果
        当前抓住的目标，如果接触点未被解除，则为null

      • grab

        public void grab​()
        抓住这个接触点的当前事件来源。 包含此触点的下一个事件将被定位到事件处理程序称为此方法的同一节点。

      • grab

        public void grab​(EventTarget target)
        按照给定的目标抓住这个接触点。 包含该接触点的下一个事件将被定向到它。
        参数
        target - 抓住接触点的目标

      • ungrab

        public void ungrab​()
        从目标中解开这个接触点。 由于下一个事件，这个触摸点将被传送到在其相应位置上选择的最顶端的节点，直到再次被抓住或释放。

      • getId

        public final int getId​()
        获取此接触点的标识符。 该数字在一个多点触摸手势的范围内是连续的和唯一的。 第一个按下的触摸点的编号为1 ，每个随后按下的触摸点将获得下一个序号，直到所有触摸点被释放并且计数器被复位。
        结果
        该接触点的标识符。

      • getState

        public final TouchPoint.State getState​()
        获取此触点的状态
        结果
        这个接触点的状态

      • getX

        public final double getX​()
        获取触摸点相对于TouchEvent源的原点的水平位置。
        结果
        触摸点相对于TouchEvent源的原点的水平位置。

      • getY

        public final double getY​()
        获取触摸点相对于TouchEvent源的原点的垂直位置。
        结果
        触摸点相对于TouchEvent源的原点的垂直位置。

      • getZ

        public final double getZ​()
        事件的相对于MouseEvent源的来源的深度位置。
        结果
        事件的相对于MouseEvent源的起点的深度位置。
        从以下版本开始：
        JavaFX 8.0

      • getScreenX

        public final double getScreenX​()
        获取触摸点的绝对水平位置。
        结果
        触摸点的绝对水平位置

      • getScreenY

        public final double getScreenY​()
        获取触摸点的绝对垂直位置。
        结果
        触摸点的绝对垂直位置

      • getSceneX

        public final double getSceneX​()
        获取触摸点的相对原点的水平位置Scene包含TouchEvent的来源。 如果节点不在一个Scene ，那么该值是相对于TouchEvent节点最根的父节点的boundsInParent。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        触摸点的相对于原点的水平位置 Scene包含TouchEvent的源

      • getSceneY

        public final double getSceneY​()
        获取触摸点的相对原点的垂直位置Scene包含TouchEvent的来源。 如果节点不在一个Scene ，那么该值是相对于TouchEvent节点最根的父节点的boundsInParent。 请注意，在3D场景中，这表示应用投影变换后的平面坐标。
        结果
        触摸点的相对于原点的垂直位置 Scene包含TouchEvent的源

      • getPickResult

        public final PickResult getPickResult​()
        返回有关选择的信息。
        结果
        新的PickResult对象包含有关选择的信息
        从以下版本开始：
        JavaFX 8.0

      • getTarget

        public EventTarget getTarget​()
        获取触发此触摸点触发事件的事件目标。
        结果
        此接触点的事件目标

      • toString

        public String toString​()
        返回此 TouchPoint对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 TouchPoint对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TouchPoint.State (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Enum TouchPoint.State

  • java.lang.Object
    • java.lang.Enum<TouchPoint.State>
      • javafx.scene.input.TouchPoint.State
  • All Implemented Interfaces:
    Serializable ， Comparable<TouchPoint.State>
    Enclosing class:
    TouchPoint

    public static enum TouchPoint.State
extends Enum<TouchPoint.State>
    表示触摸点的当前状态
    从以下版本开始：
    JavaFX 2.2

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      MOVED
      触摸点已移动
      PRESSED
      触摸点刚刚被按下（第一次触摸）
      RELEASED
      接触点已被释放
      STATIONARY
      触摸点保持按压并静止（不移动）

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TouchPoint.State valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TouchPoint.State[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PRESSED

        public static final TouchPoint.State PRESSED
        触摸点刚刚被按下（第一次触摸）

      • MOVED

        public static final TouchPoint.State MOVED
        触摸点已移动

      • STATIONARY

        public static final TouchPoint.State STATIONARY
        触摸点保持按压并静止（不移动）

      • RELEASED

        public static final TouchPoint.State RELEASED
        接触点已被释放

    • 方法详细信息

      • values

        public static TouchPoint.State[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TouchPoint.State c : TouchPoint.State.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TouchPoint.State valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TransferMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • Field |
  • 方法
  • 详细信息：
  • Enum Constants |
  • Field |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Enum TransferMode

  • java.lang.Object
    • java.lang.Enum<TransferMode>
      • javafx.scene.input.TransferMode
  • All Implemented Interfaces:
    Serializable ， Comparable<TransferMode>

    public enum TransferMode
extends Enum<TransferMode>
    描述了相对于拖放手势的数据传输模式。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      COPY
      表示支持或打算复制数据。
      LINK
      表示支持或预期数据的链接。
      MOVE
      表示支持或打算移动数据。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static TransferMode[] ANY
      数组包含所有传输模式。
      static TransferMode[] COPY_OR_MOVE
      包含传输模式的数组COPY和MOVE。
      static TransferMode[] NONE
      空数组传输模式。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TransferMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TransferMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • COPY

        public static final TransferMode COPY
        表示支持或打算复制数据。

      • MOVE

        public static final TransferMode MOVE
        表示支持或打算移动数据。

      • LINK

        public static final TransferMode LINK
        表示支持或预期数据的链接。

    • 字段详细信息

      • ANY

        public static final TransferMode[] ANY
        数组包含所有传输模式。 这是一个方便常数，用于startDragAndDrop和DragEvent.acceptTransferModes()电话。

      • COPY_OR_MOVE

        public static final TransferMode[] COPY_OR_MOVE
        包含传输模式的数组COPY和MOVE。 这是一个方便常数，用于startDragAndDrop和DragEvent.acceptTransferModes()电话。

      • NONE

        public static final TransferMode[] NONE
        空数组传输模式。 这是一个方便常数，用于startDragAndDrop和DragEvent.acceptTransferModes()电话。

    • 方法详细信息

      • values

        public static TransferMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TransferMode c : TransferMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TransferMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • Field |
  • 方法
  • 详细信息：
  • Enum Constants |
  • Field |
  • 方法


Uses of Package javafx.scene.input (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.input

  • Packages that use javafx.scene.input
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.stage
    提供JavaFX内容的顶级容器类。
  • Classes in javafx.scene.input used by javafx.scene
    Class 描述
    ContextMenuEvent
    当用户请求上下文菜单时，会发生此事件。
    Dragboard
    一个拖放具体的Clipboard 。
    DragEvent
    拖动事件在拖放手势时替换鼠标事件。
    InputMethodEvent
    一个表示底层输入法在Node中通知其文本更改的事件 。
    InputMethodRequests
    InputMethodRequests定义文本编辑节点必须处理的请求以便处理输入法。
    KeyCombination
    表示在键盘快捷键中使用的键组合。
    KeyEvent
    一个事件，表明一个击键发生在一个Node 。
    Mnemonic
    创建助记符时使用此类。
    MouseDragEvent
    鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
    MouseEvent
    当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。
    RotateEvent
    旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
    ScrollEvent
    滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。
    SwipeEvent
    滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。
    TouchEvent
    触摸事件表示触摸屏操作。
    TransferMode
    描述了相对于拖放手势的数据传输模式。
    ZoomEvent
    缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。
  • Classes in javafx.scene.input used by javafx.scene.control
    Class 描述
    KeyCombination
    表示在键盘快捷键中使用的键组合。
  • Classes in javafx.scene.input used by javafx.scene.control.skin
    Class 描述
    InputMethodEvent
    一个表示底层输入法在Node中通知其文本更改的事件 。
  • Classes in javafx.scene.input used by javafx.scene.input
    Class 描述
    Clipboard
    表示操作系统剪贴板，数据可能在例如剪切，复制和粘贴操作期间放置。
    ContextMenuEvent
    当用户请求上下文菜单时，会发生此事件。
    DataFormat
    数据格式标识符用作识别存储在剪贴板/拖板上的数据的手段。
    Dragboard
    一个拖放具体的Clipboard 。
    DragEvent
    拖动事件在拖放手势时替换鼠标事件。
    GestureEvent
    表示手势输入的事件。
    InputEvent
    指示用户输入的事件。
    InputMethodEvent
    一个表示底层输入法在Node中通知其文本更改的事件 。
    InputMethodHighlight
    包含输入法文本的枚举突出显示。
    InputMethodTextRun
    表示单个运行，其中字符在输入法文本中具有相同的高亮集。
    KeyCode
    KeyEvent对象的关键码集。
    KeyCombination
    表示在键盘快捷键中使用的键组合。
    KeyCombination.Modifier
    此类表示一对修饰符键及其值。
    KeyCombination.ModifierValue
    ModifierValue指定修饰键的状态。
    KeyEvent
    一个表示在Node发生击键的事件。
    MouseButton
    按钮名称映射
    MouseDragEvent
    鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
    MouseEvent
    当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。
    PickResult
    包含pick事件结果的容器对象
    RotateEvent
    旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
    ScrollEvent
    滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。
    ScrollEvent.HorizontalTextScrollUnits
    水平文本滚动单元。
    ScrollEvent.VerticalTextScrollUnits
    垂直的基于文本的滚动单元。
    SwipeEvent
    滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。
    TouchEvent
    触摸事件表示触摸屏操作。
    TouchPoint
    触摸点表示多点触摸动作的单个点，通常一个手指触摸屏幕。
    TouchPoint.State
    表示触摸点的当前状态
    TransferMode
    描述了相对于拖放手势的数据传输模式。
    ZoomEvent
    缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。
  • Classes in javafx.scene.input used by javafx.stage
    Class 描述
    KeyCombination
    表示在键盘快捷键中使用的键组合。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ZoomEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.input

Class ZoomEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.input.InputEvent
          • javafx.scene.input.GestureEvent
            • javafx.scene.input.ZoomEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class ZoomEvent
extends GestureEvent
    缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。

    该事件被传送到在手势开始时在手势坐标上选择的最顶端的节点 - 即使坐标在手势期间改变，也将整个手势传送到同一节点。

    该事件提供两个值： zoomFactor是该事件的缩放量， totalZoomFactor是整个手势的缩放量。 当与节点的scale属性（值大于1进行放大）相乘时，值将很好地工作。

    作为所有手势，缩放可以是直接的（直接在具体坐标处直接执行在触摸屏上 - 所有触摸中的中心点通常用作手势坐标）或间接（间接执行在跟踪板上 - 鼠标光标位置是通常用作手势坐标）。

    手势的ZOOM事件被ZOOM_STARTED和ZOOM_FINISHED事件ZOOM_FINISHED 。 如果在缩放惯性是活跃在给定的平台上，一些ZOOM事件与isInertia()返回true可以来后ZOOM_FINISHED 。

    从以下版本开始：
    JavaFX 2.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<ZoomEvent> ANY
      所有缩放事件类型的常用超类型。
      static EventType<ZoomEvent> ZOOM
      当用户执行缩放手势（例如拖动两根手指）时，会发生此事件。
      static EventType<ZoomEvent> ZOOM_FINISHED
      当缩放手势结束时，会发生此事件。
      static EventType<ZoomEvent> ZOOM_STARTED
      当检测到缩放手势时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ZoomEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      ZoomEvent copyFor​(Object newSource, EventTarget newTarget, EventType<ZoomEvent> type)
      用给定的字段替换给定事件的副本。
      EventType<ZoomEvent> getEventType​()
      获取此事件的事件类型。
      double getTotalZoomFactor​()
      获取此手势的缩放量。
      double getZoomFactor​()
      获取此事件的缩放量。
      String toString​()
      返回此 ZoomEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class javafx.scene.input.GestureEvent

        getPickResult, getSceneX, getSceneY, getScreenX, getScreenY, getX, getY, getZ, isAltDown, isControlDown, isDirect, isInertia, isMetaDown, isShiftDown, isShortcutDown

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<ZoomEvent> ANY
        所有缩放事件类型的常用超类型。

      • ZOOM

        public static final EventType<ZoomEvent> ZOOM
        当用户执行缩放手势（例如拖动两根手指）时，会发生此事件。

      • ZOOM_STARTED

        public static final EventType<ZoomEvent> ZOOM_STARTED
        当检测到缩放手势时，会发生此事件。

      • ZOOM_FINISHED

        public static final EventType<ZoomEvent> ZOOM_FINISHED
        当缩放手势结束时，会发生此事件。

    • 构造方法详细信息

      • ZoomEvent

        public ZoomEvent​(Object source,
                 EventTarget target,
                 EventType<ZoomEvent> eventType,
                 double x,
                 double y,
                 double screenX,
                 double screenY,
                 boolean shiftDown,
                 boolean controlDown,
                 boolean altDown,
                 boolean metaDown,
                 boolean direct,
                 boolean inertia,
                 double zoomFactor,
                 double totalZoomFactor,
                 PickResult pickResult)
        构造新的ZoomEvent事件。
        参数
        source - 事件的来源。 可以为null。
        target - 事件的目标。 可以为null。
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于场景的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按住alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 参见GestureEvent.isDirect()
        inertia - 如果表示已经完成的手势的惯性。
        zoomFactor - 缩放量
        totalZoomFactor - 累积缩放量
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标和目标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

      • ZoomEvent

        public ZoomEvent​(EventType<ZoomEvent> eventType,
                 double x,
                 double y,
                 double screenX,
                 double screenY,
                 boolean shiftDown,
                 boolean controlDown,
                 boolean altDown,
                 boolean metaDown,
                 boolean direct,
                 boolean inertia,
                 double zoomFactor,
                 double totalZoomFactor,
                 PickResult pickResult)
        构造具有null源和目标的新的ZoomEvent事件。
        参数
        eventType - 事件的类型。
        x - 相对于场景的x。
        y - 相对于场景的y。
        screenX - 相对于屏幕的x坐标。
        screenY - 相对于屏幕的y坐标。
        shiftDown - 如果按shift键， shiftDown true。
        controlDown - 如果按下控制修饰符， controlDown true。
        altDown - 如果按Alt修饰符， altDown true。
        metaDown - 如果按下了元修饰符， metaDown true。
        direct - 如果事件是由直接输入设备引起的， direct true。 见GestureEvent.isDirect()
        inertia - 如果表示已经完成的手势的惯性。
        zoomFactor - 缩放量
        totalZoomFactor - 累积缩放量
        pickResult - 选择结果。 可以为null，在这种情况下，基于场景坐标构建没有任何进一步值的2D选取结果
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getZoomFactor

        public double getZoomFactor​()
        获取此事件的缩放量。 当与节点的scale属性（大于1的缩放值， 0和1之间的值缩小）相乘时，因子值将很好地工作。
        结果
        此事件的缩放量

      • getTotalZoomFactor

        public double getTotalZoomFactor​()
        获取此手势的缩放量。 当与节点的scale属性（大于1的缩放值， 0和1之间的值用于缩小）相乘时，因子值将很好地工作。
        结果
        此手势的累积缩放量

      • toString

        public String toString​()
        返回此 ZoomEvent对象的字符串表示形式。
        重写：
        toString类 GestureEvent
        结果
        这个 ZoomEvent对象的字符串表示形式。

      • copyFor

        public ZoomEvent copyFor​(Object newSource,
                         EventTarget newTarget)
        说明从类别复制GestureEvent
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 GestureEvent
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • copyFor

        public ZoomEvent copyFor​(Object newSource,
                         EventTarget newTarget,
                         EventType<ZoomEvent> type)
        用给定的字段替换给定事件的副本。
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        type - 新的eventType
        结果
        事件副本与字段被替换
        从以下版本开始：
        JavaFX 8.0

      • getEventType

        public EventType<ZoomEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 GestureEvent
        结果
        事件类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Class javafx.scene.input.Clipboard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.Clipboard

  • Packages that use Clipboard
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of Clipboard in javafx.scene.input

      Subclasses of Clipboard in javafx.scene.input
      Modifier and Type Class 描述
      class  Dragboard
      一个拖放具体的Clipboard 。
      Methods in javafx.scene.input that return Clipboard
      Modifier and Type 方法 描述
      static Clipboard Clipboard.getSystemClipboard​()
      获取当前系统剪贴板，通过该剪贴板可以存储和检索数据。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.ClipboardContent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.ClipboardContent

No usage of javafx.scene.input.ClipboardContent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.ContextMenuEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.ContextMenuEvent

  • Packages that use ContextMenuEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of ContextMenuEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type ContextMenuEvent
      Modifier and Type 方法 描述
      EventHandler<? super ContextMenuEvent> Node.getOnContextMenuRequested​()
      获取属性onContextMenuRequested的值。
      EventHandler<? super ContextMenuEvent> Scene.getOnContextMenuRequested​()
      获取属性onContextMenuRequested的值。
      ObjectProperty<EventHandler<? super ContextMenuEvent>> Node.onContextMenuRequestedProperty​()
      定义在 Node上请求上下文菜单时要调用的函数。
      ObjectProperty<EventHandler<? super ContextMenuEvent>> Scene.onContextMenuRequestedProperty​()
      定义当这个 Scene点击（按下和释放）鼠标按钮时调用的功能。
      Method parameters in javafx.scene with type arguments of type ContextMenuEvent
      Modifier and Type 方法 描述
      void Node.setOnContextMenuRequested​(EventHandler<? super ContextMenuEvent> value)
      设置属性onContextMenuRequested的值。
      void Scene.setOnContextMenuRequested​(EventHandler<? super ContextMenuEvent> value)
      设置属性onContextMenuRequested的值。

    • Uses of ContextMenuEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type ContextMenuEvent
      Modifier and Type Field 描述
      static EventType<ContextMenuEvent> ContextMenuEvent.ANY
      所有上下文菜单事件类型的常用超类型。
      static EventType<ContextMenuEvent> ContextMenuEvent.CONTEXT_MENU_REQUESTED
      当请求上下文菜单时，会发生此事件。
      Methods in javafx.scene.input that return ContextMenuEvent
      Modifier and Type | 方法 | 描述
      ContextMenuEvent | ContextMenuEvent.copyFor​(Object newSource, EventTarget newTarget)
      Methods in javafx.scene.input that return types with arguments of type ContextMenuEvent
      Modifier and Type | 方法 | 描述
      EventType<ContextMenuEvent> | ContextMenuEvent.getEventType​()
      Constructor parameters in javafx.scene.input with type arguments of type ContextMenuEvent
      Constructor 描述
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.DataFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.DataFormat

  • Packages that use DataFormat
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of DataFormat in javafx.scene.input

      Fields in javafx.scene.input declared as DataFormat
      Modifier and Type Field 描述
      static DataFormat DataFormat.FILES
      表示文件列表。
      static DataFormat DataFormat.HTML
      表示HTML格式的字符串。
      static DataFormat DataFormat.IMAGE
      一种特殊的平台特定图像类型，例如通常用于剪贴板并与其他应用程序广泛互操作。
      static DataFormat DataFormat.PLAIN_TEXT
      表示纯文本字符串。
      static DataFormat DataFormat.RTF
      表示RTF格式的字符串
      static DataFormat DataFormat.URL
      表示一个编码为String的URL
      Methods in javafx.scene.input that return DataFormat
      Modifier and Type 方法 描述
      static DataFormat DataFormat.lookupMimeType​(String mimeType)
      查找之前使用给定的MIME类型创建的DataFormat作为其IDID之一。
      Methods in javafx.scene.input that return types with arguments of type DataFormat
      Modifier and Type 方法 描述
      Set<DataFormat> Clipboard.getContentTypes​()
      获取此剪贴板实例上具有已在剪贴板上注册的关联数据的DataFormat类型集。
      Methods in javafx.scene.input with parameters of type DataFormat
      Modifier and Type 方法 描述
      Object Clipboard.getContent​(DataFormat dataFormat)
      返回给定类型的此剪贴板中存储的内容，如果没有此类型的内容，则返回null。
      boolean Clipboard.hasContent​(DataFormat dataFormat)
      测试给定DataFormat类型的此剪贴板上是否有任何内容。
      Method parameters in javafx.scene.input with type arguments of type DataFormat
      Modifier and Type 方法 描述
      boolean Clipboard.setContent​(Map<DataFormat,Object> content)
      将内容放在剪贴板上。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.Dragboard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.Dragboard

  • Packages that use Dragboard
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of Dragboard in javafx.scene

      Methods in javafx.scene that return Dragboard
      Modifier and Type 方法 描述
      Dragboard Node.startDragAndDrop​(TransferMode... transferModes)
      确认一个潜在的拖放手势，在这 Node被认可。
      Dragboard Scene.startDragAndDrop​(TransferMode... transferModes)
      确认一个潜在的拖放手势，在这 Scene被认可。

    • Uses of Dragboard in javafx.scene.input

      Methods in javafx.scene.input that return Dragboard
      Modifier and Type 方法 描述
      Dragboard DragEvent.getDragboard​()
      可用于传输数据的拖板。
      Constructors in javafx.scene.input with parameters of type Dragboard
      Constructor 描述
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      Constructs new DragEvent event with empty source and target.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.DragEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.DragEvent

  • Packages that use DragEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of DragEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type DragEvent
      Modifier and Type 方法 描述
      EventHandler<? super DragEvent> Node.getOnDragDone​()
      获取属性onDragDone的值。
      EventHandler<? super DragEvent> Scene.getOnDragDone​()
      获取属性onDragDone的值。
      EventHandler<? super DragEvent> Node.getOnDragDropped​()
      获取属性onDragDropped的值。
      EventHandler<? super DragEvent> Scene.getOnDragDropped​()
      获取属性onDragDropped的值。
      EventHandler<? super DragEvent> Node.getOnDragEntered​()
      获取属性onDragEntered的值。
      EventHandler<? super DragEvent> Scene.getOnDragEntered​()
      获取属性onDragEntered的值。
      EventHandler<? super DragEvent> Node.getOnDragExited​()
      获取属性onDragExited的值。
      EventHandler<? super DragEvent> Scene.getOnDragExited​()
      获取属性onDragExited的值。
      EventHandler<? super DragEvent> Node.getOnDragOver​()
      获取属性onDragOver的值。
      EventHandler<? super DragEvent> Scene.getOnDragOver​()
      获取属性onDragOver的值。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragDoneProperty​()
      定义当这个 Node是一个拖放手势源后的数据被放在放置目标上时被调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragDoneProperty​()
      定义当 Scene在其数据放在放置目标上之后是拖放手势源时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragDroppedProperty​()
      定义在拖放手势时，在 Node上释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragDroppedProperty​()
      定义在拖放手势时，在此 Scene上释放鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragEnteredProperty​()
      定义当拖动手势进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragEnteredProperty​()
      定义当拖动手势进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragExitedProperty​()
      定义当拖动手势退出 Node时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragExitedProperty​()
      定义当拖动手势退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Node.onDragOverProperty​()
      当这个 Node拖动手势进行时，定义要调用的函数。
      ObjectProperty<EventHandler<? super DragEvent>> Scene.onDragOverProperty​()
      定义当这个 Scene拖动手势进度时要调用的函数。
      Method parameters in javafx.scene with type arguments of type DragEvent
      Modifier and Type 方法 描述
      void Node.setOnDragDone​(EventHandler<? super DragEvent> value)
      设置属性onDragDone的值。
      void Scene.setOnDragDone​(EventHandler<? super DragEvent> value)
      设置属性onDragDone的值。
      void Node.setOnDragDropped​(EventHandler<? super DragEvent> value)
      设置属性onDragDropped的值。
      void Scene.setOnDragDropped​(EventHandler<? super DragEvent> value)
      设置属性onDragDropped的值。
      void Node.setOnDragEntered​(EventHandler<? super DragEvent> value)
      设置属性onDragEntered的值。
      void Scene.setOnDragEntered​(EventHandler<? super DragEvent> value)
      设置属性onDragEntered的值。
      void Node.setOnDragExited​(EventHandler<? super DragEvent> value)
      设置属性onDragExited的值。
      void Scene.setOnDragExited​(EventHandler<? super DragEvent> value)
      设置属性onDragExited的值。
      void Node.setOnDragOver​(EventHandler<? super DragEvent> value)
      设置属性onDragOver的值。
      void Scene.setOnDragOver​(EventHandler<? super DragEvent> value)
      设置属性onDragOver的值。

    • Uses of DragEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type DragEvent
      Modifier and Type Field 描述
      static EventType<DragEvent> DragEvent.ANY
      所有拖动事件类型的常用超类型。
      static EventType<DragEvent> DragEvent.DRAG_DONE
      数据丢弃在放置目标上之后，这种事件就发生在拖放手势源上。
      static EventType<DragEvent> DragEvent.DRAG_DROPPED
      当在拖放目标上拖放手势时释放鼠标按钮时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_ENTERED
      当拖动手势进入节点时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_ENTERED_TARGET
      当拖动手势进入节点时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_EXITED
      当拖动手势退出节点时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_EXITED_TARGET
      当拖动手势退出节点时，会发生此事件。
      static EventType<DragEvent> DragEvent.DRAG_OVER
      当拖动手势在该节点内进行时，会发生此事件。
      Methods in javafx.scene.input that return DragEvent
      Modifier and Type | 方法 | 描述
      DragEvent | DragEvent.copyFor​(Object newSource, EventTarget newTarget)
      DragEvent DragEvent.copyFor​(Object source, EventTarget target, Object gestureSource, Object gestureTarget, EventType<DragEvent> eventType)
      创建给定字段替换的给定拖动事件的副本。
      DragEvent DragEvent.copyFor​(Object source, EventTarget target, EventType<DragEvent> type)
      创建给定字段替换的给定拖动事件的副本。
      Methods in javafx.scene.input that return types with arguments of type DragEvent
      Modifier and Type | 方法 | 描述
      EventType<DragEvent> | DragEvent.getEventType​()
      Method parameters in javafx.scene.input with type arguments of type DragEvent
      Modifier and Type 方法 描述
      DragEvent DragEvent.copyFor​(Object source, EventTarget target, Object gestureSource, Object gestureTarget, EventType<DragEvent> eventType)
      创建给定字段替换的给定拖动事件的副本。
      DragEvent DragEvent.copyFor​(Object source, EventTarget target, EventType<DragEvent> type)
      创建给定字段替换的给定拖动事件的副本。
      Constructor parameters in javafx.scene.input with type arguments of type DragEvent
      Constructor 描述
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.GestureEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.GestureEvent

  • Packages that use GestureEvent
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of GestureEvent in javafx.scene.input

      Subclasses of GestureEvent in javafx.scene.input
      Modifier and Type Class 描述
      class  RotateEvent
      旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
      class  ScrollEvent
      滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。
      class  SwipeEvent
      滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。
      class  ZoomEvent
      缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。
      Fields in javafx.scene.input with type parameters of type GestureEvent
      Modifier and Type Field 描述
      static EventType<GestureEvent> GestureEvent.ANY
      所有手势的常用超类型。
      Methods in javafx.scene.input that return GestureEvent
      Modifier and Type 方法 描述
      GestureEvent GestureEvent.copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      Methods in javafx.scene.input that return types with arguments of type GestureEvent
      Modifier and Type | 方法 | 描述
      EventType<? extends GestureEvent> | GestureEvent.getEventType​()
      Constructor parameters in javafx.scene.input with type arguments of type GestureEvent
      Constructor 描述
      GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType)
      已过时。
      不要使用这个构造函数。 构造空事件。
      GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)
      构建新的GestureEvent事件。
      GestureEvent​(EventType<? extends GestureEvent> eventType)
      已过时。
      不要使用这个构造函数。 构造空事件。
      GestureEvent​(EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)
      Constructs new GestureEvent event with empty source and target
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.InputEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.InputEvent

  • Packages that use InputEvent
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of InputEvent in javafx.scene.input

      Subclasses of InputEvent in javafx.scene.input
      Modifier and Type Class 描述
      class  ContextMenuEvent
      当用户请求上下文菜单时，会发生此事件。
      class  DragEvent
      拖动事件在拖放手势时替换鼠标事件。
      class  GestureEvent
      表示手势输入的事件。
      class  InputMethodEvent
      一个表示底层输入法在Node中通知其文本更改的事件 。
      class  KeyEvent
      一个事件，表示一个击键发生在一个Node 。
      class  MouseDragEvent
      鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
      class  MouseEvent
      当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。
      class  RotateEvent
      旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
      class  ScrollEvent
      滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。
      class  SwipeEvent
      滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。
      class  TouchEvent
      触摸事件表示触摸屏操作。
      class  ZoomEvent
      缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。
      Fields in javafx.scene.input with type parameters of type InputEvent
      Modifier and Type Field 描述
      static EventType<InputEvent> InputEvent.ANY
      所有输入事件类型的常用超类型。
      Methods in javafx.scene.input that return types with arguments of type InputEvent
      Modifier and Type | 方法 | 描述
      EventType<? extends InputEvent> | InputEvent.getEventType​()
      Constructor parameters in javafx.scene.input with type arguments of type InputEvent
      Constructor 描述
      InputEvent​(Object source, EventTarget target, EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
      InputEvent​(EventType<? extends InputEvent> eventType)
      创建新的InputEvent实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.InputMethodEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.InputMethodEvent

  • Packages that use InputMethodEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of InputMethodEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type InputMethodEvent
      Modifier and Type 方法 描述
      EventHandler<? super InputMethodEvent> Node.getOnInputMethodTextChanged​()
      获取onInputMethodTextChanged属性的值。
      EventHandler<? super InputMethodEvent> Scene.getOnInputMethodTextChanged​()
      获取onInputMethodTextChanged属性的值。
      ObjectProperty<EventHandler<? super InputMethodEvent>> Node.onInputMethodTextChangedProperty​()
      当这个 Node具有输入焦点并且输入法文本已经改变时，定义要调用的函数。
      ObjectProperty<EventHandler<? super InputMethodEvent>> Scene.onInputMethodTextChangedProperty​()
      当这个 Node具有输入焦点并且输入法文本已经改变时，定义要调用的函数。
      Method parameters in javafx.scene with type arguments of type InputMethodEvent
      Modifier and Type 方法 描述
      void Node.setOnInputMethodTextChanged​(EventHandler<? super InputMethodEvent> value)
      设置属性onInputMethodTextChanged的值。
      void Scene.setOnInputMethodTextChanged​(EventHandler<? super InputMethodEvent> value)
      设置属性onInputMethodTextChanged的值。

    • Uses of InputMethodEvent in javafx.scene.control.skin

      Methods in javafx.scene.control.skin with parameters of type InputMethodEvent
      Modifier and Type | 方法 | 描述
      protected void | TextInputControlSkin.handleInputMethodEvent​(InputMethodEvent event)

    • Uses of InputMethodEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type InputMethodEvent
      Modifier and Type Field 描述
      static EventType<InputMethodEvent> InputMethodEvent.ANY
      所有输入法事件类型的公共超类型。
      static EventType<InputMethodEvent> InputMethodEvent.INPUT_METHOD_TEXT_CHANGED
      InputMethodEvent唯一有效的EventType。
      Methods in javafx.scene.input that return InputMethodEvent
      Modifier and Type | 方法 | 描述
      InputMethodEvent | InputMethodEvent.copyFor​(Object newSource, EventTarget newTarget)
      Methods in javafx.scene.input that return types with arguments of type InputMethodEvent
      Modifier and Type | 方法 | 描述
      EventType<InputMethodEvent> | InputMethodEvent.getEventType​()
      Constructor parameters in javafx.scene.input with type arguments of type InputMethodEvent
      Constructor 描述
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      Constructs new InputMethodEvent event with empty source and target.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.InputMethodHighlight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.InputMethodHighlight

  • Packages that use InputMethodHighlight
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of InputMethodHighlight in javafx.scene.input

      Methods in javafx.scene.input that return InputMethodHighlight
      Modifier and Type 方法 描述
      InputMethodHighlight InputMethodTextRun.getHighlight​()
      获取用于显示此文本的高亮。
      static InputMethodHighlight InputMethodHighlight.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static InputMethodHighlight[] InputMethodHighlight.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.input with parameters of type InputMethodHighlight
      Constructor 描述
      InputMethodTextRun​(String text, InputMethodHighlight highlight)
      构造输入法的单个文本运行。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.InputMethodTextRun (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.InputMethodTextRun

  • Packages that use InputMethodTextRun
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of InputMethodTextRun in javafx.scene.input

      Methods in javafx.scene.input that return types with arguments of type InputMethodTextRun
      Modifier and Type 方法 描述
      ObservableList<InputMethodTextRun> InputMethodEvent.getComposed​()
      获取组合下的文本。
      Constructor parameters in javafx.scene.input with type arguments of type InputMethodTextRun
      Constructor 描述
      InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造新的InputMethodEvent事件。
      InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)
      构造具有空源和目标的新的InputMethodEvent事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.KeyCharacterCombination (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.KeyCharacterCombination

No usage of javafx.scene.input.KeyCharacterCombination
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.KeyCode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.KeyCode

  • Packages that use KeyCode
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of KeyCode in javafx.scene.input

      Methods in javafx.scene.input that return KeyCode
      Modifier and Type 方法 描述
      KeyCode KeyCodeCombination.getCode​()
      获取与该组合关联的键码。
      KeyCode KeyEvent.getCode​()
      与该键中的键相关的键代码按下或键释放事件。
      KeyCode KeyCombination.Modifier.getKey​()
      获取此 Modifier的修饰键。
      static KeyCode KeyCode.getKeyCode​(String name)
      解析一个键的文本表示。
      static KeyCode KeyCode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static KeyCode[] KeyCode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.input with parameters of type KeyCode
      Constructor 描述
      KeyCodeCombination​(KeyCode code, KeyCombination.Modifier... modifiers)
      为指定的主键和指定的修饰符列表构造一个 KeyCodeCombination 。
      KeyCodeCombination​(KeyCode code, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构建一个新的 KeyEvent事件，其中包含一个 null源和目标。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.KeyCodeCombination (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.KeyCodeCombination

No usage of javafx.scene.input.KeyCodeCombination
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.KeyCombination (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.KeyCombination

  • Packages that use KeyCombination
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of KeyCombination in javafx.scene

      Methods in javafx.scene that return types with arguments of type KeyCombination
      Modifier and Type 方法 描述
      ObservableMap<KeyCombination,Runnable> Scene.getAccelerators​()
      获取此 Scene的加速器列表。
      ObservableMap<KeyCombination,ObservableList<Mnemonic>> Scene.getMnemonics​()
      获取 Scene的助记符列表。

    • Uses of KeyCombination in javafx.scene.control

      Methods in javafx.scene.control that return KeyCombination
      Modifier and Type 方法 描述
      KeyCombination MenuItem.getAccelerator​()
      获取属性加速器的值。
      Methods in javafx.scene.control that return types with arguments of type KeyCombination
      Modifier and Type 方法 描述
      ObjectProperty<KeyCombination> MenuItem.acceleratorProperty​()
      加速器属性使得能够在一个击键中访问关联的动作。
      Methods in javafx.scene.control with parameters of type KeyCombination
      Modifier and Type 方法 描述
      void MenuItem.setAccelerator​(KeyCombination value)
      设置属性加速器的值。

    • Uses of KeyCombination in javafx.scene.input

      Subclasses of KeyCombination in javafx.scene.input
      Modifier and Type Class 描述
      class  KeyCharacterCombination
      该类表示主键由其字符指定的组合键。
      class  KeyCodeCombination
      该类代表其主键由其 KeyCode指定的组合键。
      Fields in javafx.scene.input declared as KeyCombination
      Modifier and Type Field 描述
      static KeyCombination KeyCombination.NO_MATCH
      与任何事件匹配的KeyCombination。
      Methods in javafx.scene.input that return KeyCombination
      Modifier and Type 方法 描述
      KeyCombination Mnemonic.getKeyCombination​()
      返回KeyCombination
      static KeyCombination KeyCombination.keyCombination​(String name)
      从指定的字符串构造一个新的 KeyCombination 。
      static KeyCombination KeyCombination.valueOf​(String value)
      从指定的字符串构造一个新的 KeyCombination 。
      Methods in javafx.scene.input with parameters of type KeyCombination
      Modifier and Type 方法 描述
      void Mnemonic.setKeyCombination​(KeyCombination keyCombination)
      设置KeyCombination
      Constructors in javafx.scene.input with parameters of type KeyCombination
      Constructor 描述
      Mnemonic​(Node node, KeyCombination keyCombination)
      构造一个Mnemonic与指定的目标Node和触发器KeyCombination 。

    • Uses of KeyCombination in javafx.stage

      Methods in javafx.stage that return KeyCombination
      Modifier and Type 方法 描述
      KeyCombination Stage.getFullScreenExitKeyCombination​()
      获取用于退出全屏模式的当前顺序。
      Methods in javafx.stage that return types with arguments of type KeyCombination
      Modifier and Type 方法 描述
      ObjectProperty<KeyCombination> Stage.fullScreenExitKeyProperty​()
      获取全屏幕退出组合键的属性。
      Methods in javafx.stage with parameters of type KeyCombination
      Modifier and Type 方法 描述
      void Stage.setFullScreenExitKeyCombination​(KeyCombination keyCombination)
      指定将允许用户退出全屏模式的KeyCombination。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.KeyCombination.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.KeyCombination.Modifier

  • Packages that use KeyCombination.Modifier
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of KeyCombination.Modifier in javafx.scene.input

      Fields in javafx.scene.input declared as KeyCombination.Modifier
      Modifier and Type Field 描述
      static KeyCombination.Modifier KeyCombination.ALT_ANY
      修饰符指定 alt键可以是向上还是向下。
      static KeyCombination.Modifier KeyCombination.ALT_DOWN
      指定 alt密钥的 alt必须关闭。
      static KeyCombination.Modifier KeyCombination.CONTROL_ANY
      修饰符指定 control键可以是向上还是向下。
      static KeyCombination.Modifier KeyCombination.CONTROL_DOWN
      指定 control密钥的 control必须处于关闭状态。
      static KeyCombination.Modifier KeyCombination.META_ANY
      修饰符指定 meta键可以是向上还是向下。
      static KeyCombination.Modifier KeyCombination.META_DOWN
      指定 meta密钥必须为关闭的修饰符。
      static KeyCombination.Modifier KeyCombination.SHIFT_ANY
      指定 shift键的 shift可以是向上还是向下。
      static KeyCombination.Modifier KeyCombination.SHIFT_DOWN
      修饰符指定 shift键必须关闭。
      static KeyCombination.Modifier KeyCombination.SHORTCUT_ANY
      修饰符指定 shortcut键可以是向上还是向下。
      static KeyCombination.Modifier KeyCombination.SHORTCUT_DOWN
      指定 shortcut键的 shortcut必须关闭。
      Constructors in javafx.scene.input with parameters of type KeyCombination.Modifier
      Constructor 描述
      KeyCharacterCombination​(String character, KeyCombination.Modifier... modifiers)
      为指定的主键字符和指定的修饰符列表构造一个 KeyCharacterCombination 。
      KeyCodeCombination​(KeyCode code, KeyCombination.Modifier... modifiers)
      为指定的主键和指定的修饰符列表构造一个 KeyCodeCombination 。
      KeyCombination​(KeyCombination.Modifier... modifiers)
      构造具有指定的修饰符列表的 KeyCombination 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.KeyCombination.ModifierValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.KeyCombination.ModifierValue

  • Packages that use KeyCombination.ModifierValue
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of KeyCombination.ModifierValue in javafx.scene.input

      Methods in javafx.scene.input that return KeyCombination.ModifierValue
      Modifier and Type 方法 描述
      KeyCombination.ModifierValue KeyCombination.getAlt​()
      alt键的状态在这个组合键上。
      KeyCombination.ModifierValue KeyCombination.getControl​()
      control键的状态在这个组合键上。
      KeyCombination.ModifierValue KeyCombination.getMeta​()
      meta键的状态在这个组合键上。
      KeyCombination.ModifierValue KeyCombination.getShift​()
      shift键的这个组合状态。
      KeyCombination.ModifierValue KeyCombination.getShortcut​()
      shortcut键的状态在这个组合键上。
      KeyCombination.ModifierValue KeyCombination.Modifier.getValue​()
      获取此 Modifier的修饰符值。
      static KeyCombination.ModifierValue KeyCombination.ModifierValue.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static KeyCombination.ModifierValue[] KeyCombination.ModifierValue.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.input with parameters of type KeyCombination.ModifierValue
      Constructor 描述
      KeyCharacterCombination​(String character, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键字符构建一个 KeyCharacterCombination ，并显式指定所有修饰键。
      KeyCodeCombination​(KeyCode code, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。
      KeyCombination​(KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)
      构造一个 KeyCombination ，具有所有修饰键的显式规范。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.KeyEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.KeyEvent

  • Packages that use KeyEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of KeyEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type KeyEvent
      Modifier and Type 方法 描述
      EventHandler<? super KeyEvent> Node.getOnKeyPressed​()
      获取属性onKeyPressed的值。
      EventHandler<? super KeyEvent> Scene.getOnKeyPressed​()
      获取属性onKeyPressed的值。
      EventHandler<? super KeyEvent> Node.getOnKeyReleased​()
      获取属性onKeyReleased的值。
      EventHandler<? super KeyEvent> Scene.getOnKeyReleased​()
      获取属性onKeyReleased的值。
      EventHandler<? super KeyEvent> Node.getOnKeyTyped​()
      获取属性onKeyTyped的值。
      EventHandler<? super KeyEvent> Scene.getOnKeyTyped​()
      获取属性onKeyTyped的值。
      ObjectProperty<EventHandler<? super KeyEvent>> Node.onKeyPressedProperty​()
      定义当此 Node或其子项 Node具有输入焦点并按下键时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Scene.onKeyPressedProperty​()
      当 Node有 Scene有输入焦点并按下一个键时，定义要调用的功能。
      ObjectProperty<EventHandler<? super KeyEvent>> Node.onKeyReleasedProperty​()
      定义当这个 Node或其子代 Node具有输入焦点并且键被释放时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Scene.onKeyReleasedProperty​()
      定义要调用的函数，当一些 Node如此 Scene具有输入焦点和重点已经释放。
      ObjectProperty<EventHandler<? super KeyEvent>> Node.onKeyTypedProperty​()
      定义当这个 Node或其子代 Node具有输入焦点并键入了一个键时要调用的函数。
      ObjectProperty<EventHandler<? super KeyEvent>> Scene.onKeyTypedProperty​()
      定义当这个 Scene某些 Node具有输入焦点并键入了一个键时要调用的函数。
      Methods in javafx.scene with parameters of type KeyEvent
      Modifier and Type | 方法 | 描述
      void | Scene.processKeyEvent​(KeyEvent e)
      Method parameters in javafx.scene with type arguments of type KeyEvent
      Modifier and Type 方法 描述
      void Node.setOnKeyPressed​(EventHandler<? super KeyEvent> value)
      设置属性onKeyPressed的值。
      void Scene.setOnKeyPressed​(EventHandler<? super KeyEvent> value)
      设置属性onKeyPressed的值。
      void Node.setOnKeyReleased​(EventHandler<? super KeyEvent> value)
      设置属性onKeyReleased的值。
      void Scene.setOnKeyReleased​(EventHandler<? super KeyEvent> value)
      设置属性onKeyReleased的值。
      void Node.setOnKeyTyped​(EventHandler<? super KeyEvent> value)
      设置属性onKeyTyped的值。
      void Scene.setOnKeyTyped​(EventHandler<? super KeyEvent> value)
      设置属性onKeyTyped的值。

    • Uses of KeyEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type KeyEvent
      Modifier and Type Field 描述
      static EventType<KeyEvent> KeyEvent.ANY
      所有关键事件类型的常用超类型。
      static EventType<KeyEvent> KeyEvent.KEY_PRESSED
      当按下键时，会发生此事件。
      static EventType<KeyEvent> KeyEvent.KEY_RELEASED
      当一个键被释放时，会发生这种情况。
      static EventType<KeyEvent> KeyEvent.KEY_TYPED
      当字符生成键被键入（按下并释放）时，会发生此事件。
      Methods in javafx.scene.input that return KeyEvent
      Modifier and Type | 方法 | 描述
      KeyEvent | KeyEvent.copyFor​(Object newSource, EventTarget newTarget)
      KeyEvent KeyEvent.copyFor​(Object source, EventTarget target, EventType<KeyEvent> type)
      用给定的字段替换给定事件的副本。
      Methods in javafx.scene.input that return types with arguments of type KeyEvent
      Modifier and Type | 方法 | 描述
      EventType<KeyEvent> | KeyEvent.getEventType​()
      Methods in javafx.scene.input with parameters of type KeyEvent
      Modifier and Type 方法 描述
      boolean KeyCharacterCombination.match​(KeyEvent event)
      测试此组合是否与给定的 KeyEvent组合键匹配。
      boolean KeyCodeCombination.match​(KeyEvent event)
      测试此组合是否与给定的 KeyEvent组合键匹配。
      boolean KeyCombination.match​(KeyEvent event)
      测试此组合是否与给定的 KeyEvent中的组合相匹配。
      Method parameters in javafx.scene.input with type arguments of type KeyEvent
      Modifier and Type 方法 描述
      KeyEvent KeyEvent.copyFor​(Object source, EventTarget target, EventType<KeyEvent> type)
      用给定的字段替换给定事件的副本。
      Constructor parameters in javafx.scene.input with type arguments of type KeyEvent
      Constructor 描述
      KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      从指定的参数构造一个新的 KeyEvent事件。
      KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      Constructs a new KeyEvent event from the specified parameters, with a null source and target.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.Mnemonic (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.Mnemonic

  • Packages that use Mnemonic
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of Mnemonic in javafx.scene

      Methods in javafx.scene that return types with arguments of type Mnemonic
      Modifier and Type 方法 描述
      ObservableMap<KeyCombination,ObservableList<Mnemonic>> Scene.getMnemonics​()
      获取 Scene的助记符列表。
      Methods in javafx.scene with parameters of type Mnemonic
      Modifier and Type 方法 描述
      void Scene.addMnemonic​(Mnemonic m)
      注册指定的助记符。
      void Scene.removeMnemonic​(Mnemonic m)
      取消注册指定的助记符。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.MouseButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.MouseButton

  • Packages that use MouseButton
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of MouseButton in javafx.scene.input

      Methods in javafx.scene.input that return MouseButton
      Modifier and Type 方法 描述
      MouseButton MouseEvent.getButton​()
      哪个，如果有的话，鼠标按钮是负责这个事件。
      static MouseButton MouseButton.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MouseButton[] MouseButton.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.input with parameters of type MouseButton
      Constructor 描述
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.MouseDragEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.MouseDragEvent

  • Packages that use MouseDragEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of MouseDragEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type MouseDragEvent
      Modifier and Type 方法 描述
      EventHandler<? super MouseDragEvent> Node.getOnMouseDragEntered​()
      获取属性onMouseDragEntered的值。
      EventHandler<? super MouseDragEvent> Scene.getOnMouseDragEntered​()
      获取属性onMouseDragEntered的值。
      EventHandler<? super MouseDragEvent> Node.getOnMouseDragExited​()
      获取属性onMouseDragExited的值。
      EventHandler<? super MouseDragEvent> Scene.getOnMouseDragExited​()
      获取属性onMouseDragExited的值。
      EventHandler<? super MouseDragEvent> Node.getOnMouseDragOver​()
      获取属性onMouseDragOver的值。
      EventHandler<? super MouseDragEvent> Scene.getOnMouseDragOver​()
      获取属性onMouseDragOver的值。
      EventHandler<? super MouseDragEvent> Node.getOnMouseDragReleased​()
      获取属性onMouseDragReleased的值。
      EventHandler<? super MouseDragEvent> Scene.getOnMouseDragReleased​()
      获取属性onMouseDragReleased的值。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragEnteredProperty​()
      定义当全按压拖动手势进入此 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragEnteredProperty​()
      定义当全按压拖动手势进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragExitedProperty​()
      定义当完全按下 - 拖动释放手势离开这个 Node时要调用的函数。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragExitedProperty​()
      定义当完全按下 - 拖动释放手势退出 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragOverProperty​()
      定义当这个 Node内完全按下 - 拖动释放手势时，要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragOverProperty​()
      定义当这个 Scene完全按下 - 拖动释放手势进行时要调用的函数。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Node.onMouseDragReleasedProperty​()
      定义当这个 Node完全按下 - 拖动释放手势结束（通过释放鼠标按钮）时要调用的功能。
      ObjectProperty<EventHandler<? super MouseDragEvent>> Scene.onMouseDragReleasedProperty​()
      定义当完全按下 - 释放手势在此 Scene内结束时要调用的功能。
      Method parameters in javafx.scene with type arguments of type MouseDragEvent
      Modifier and Type 方法 描述
      void Node.setOnMouseDragEntered​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragEntered的值。
      void Scene.setOnMouseDragEntered​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragEntered的值。
      void Node.setOnMouseDragExited​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragExited的值。
      void Scene.setOnMouseDragExited​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragExited的值。
      void Node.setOnMouseDragOver​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragOver的值。
      void Scene.setOnMouseDragOver​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragOver的值。
      void Node.setOnMouseDragReleased​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragReleased的值。
      void Scene.setOnMouseDragReleased​(EventHandler<? super MouseDragEvent> value)
      设置属性onMouseDragReleased的值。

    • Uses of MouseDragEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type MouseDragEvent
      Modifier and Type Field 描述
      static EventType<MouseDragEvent> MouseDragEvent.ANY
      所有鼠标事件类型的常用超类型。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_ENTERED
      当手势进入节点时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_ENTERED_TARGET
      当手势进入节点时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_EXITED
      当手势退出节点时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_EXITED_TARGET
      当手势退出节点时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_OVER
      当该节点内的手势进行时，会发生此事件。
      static EventType<MouseDragEvent> MouseDragEvent.MOUSE_DRAG_RELEASED
      当手势在该节点上结束（通过释放鼠标按钮）时，会发生此事件。
      Methods in javafx.scene.input that return MouseDragEvent
      Modifier and Type | 方法 | 描述
      MouseDragEvent | MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget)
      MouseDragEvent | MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> type)
      static MouseDragEvent MouseEvent.copyForMouseDragEvent​(MouseEvent e, Object source, EventTarget target, EventType<MouseDragEvent> type, Object gestureSource, PickResult pickResult)
      创建MouseDragEvent类型的鼠标事件的副本
      Methods in javafx.scene.input that return types with arguments of type MouseDragEvent
      Modifier and Type | 方法 | 描述
      EventType<MouseDragEvent> | MouseDragEvent.getEventType​()
      Method parameters in javafx.scene.input with type arguments of type MouseDragEvent
      Modifier and Type 方法 描述
      static MouseDragEvent MouseEvent.copyForMouseDragEvent​(MouseEvent e, Object source, EventTarget target, EventType<MouseDragEvent> type, Object gestureSource, PickResult pickResult)
      创建MouseDragEvent类型的鼠标事件的副本
      Constructor parameters in javafx.scene.input with type arguments of type MouseDragEvent
      Constructor 描述
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      Constructs new MouseDragEvent event with null source and target.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.MouseEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.MouseEvent

  • Packages that use MouseEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of MouseEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type MouseEvent
      Modifier and Type 方法 描述
      EventHandler<? super MouseEvent> Node.getOnDragDetected​()
      获取属性onDragDetected的值。
      EventHandler<? super MouseEvent> Scene.getOnDragDetected​()
      获取属性onDragDetected的值。
      EventHandler<? super MouseEvent> Node.getOnMouseClicked​()
      获取属性onMouseClicked的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseClicked​()
      获取属性onMouseClicked的值。
      EventHandler<? super MouseEvent> Node.getOnMouseDragged​()
      获取属性onMouseDragged的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseDragged​()
      获取属性onMouseDragged的值。
      EventHandler<? super MouseEvent> Node.getOnMouseEntered​()
      获取属性onMouseEntered的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseEntered​()
      获取属性onMouseEntered的值。
      EventHandler<? super MouseEvent> Node.getOnMouseExited​()
      获取属性onMouseExited的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseExited​()
      获取属性onMouseExited的值。
      EventHandler<? super MouseEvent> Node.getOnMouseMoved​()
      获取属性onMouseMoved的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseMoved​()
      获取属性onMouseMoved的值。
      EventHandler<? super MouseEvent> Node.getOnMousePressed​()
      获取属性onMousePressed的值。
      EventHandler<? super MouseEvent> Scene.getOnMousePressed​()
      获取属性onMousePressed的值。
      EventHandler<? super MouseEvent> Node.getOnMouseReleased​()
      获取属性onMouseReleased的值。
      EventHandler<? super MouseEvent> Scene.getOnMouseReleased​()
      获取属性onMouseReleased的值。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onDragDetectedProperty​()
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onDragDetectedProperty​()
      定义检测到拖动手势时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseClickedProperty​()
      定义当这个 Node上点击（按下并释放）鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseClickedProperty​()
      定义当这个 Scene点击（按下并释放）鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseDraggedProperty​()
      定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseDraggedProperty​()
      定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseEnteredProperty​()
      定义当鼠标进入 Node时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseEnteredProperty​()
      定义当鼠标进入 Scene时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseExitedProperty​()
      定义当鼠标退出 Node时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseExitedProperty​()
      定义当鼠标退出 Scene时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseMovedProperty​()
      定义当这个 Node鼠标光标移动时调用的功能，但没有按钮被按下。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseMovedProperty​()
      定义当这个 Scene鼠标光标移动时调用的功能，但没有按钮被按下。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMousePressedProperty​()
      定义在 Node上按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMousePressedProperty​()
      定义在 Scene上按下鼠标按钮时要调用的功能。
      ObjectProperty<EventHandler<? super MouseEvent>> Node.onMouseReleasedProperty​()
      定义当这个 Node释放鼠标按钮时要调用的函数。
      ObjectProperty<EventHandler<? super MouseEvent>> Scene.onMouseReleasedProperty​()
      定义当这个 Scene释放鼠标按钮时要调用的函数。
      Method parameters in javafx.scene with type arguments of type MouseEvent
      Modifier and Type 方法 描述
      void Node.setOnDragDetected​(EventHandler<? super MouseEvent> value)
      设置属性onDragDetected的值。
      void Scene.setOnDragDetected​(EventHandler<? super MouseEvent> value)
      设置属性onDragDetected的值。
      void Node.setOnMouseClicked​(EventHandler<? super MouseEvent> value)
      设置属性onMouseClicked的值。
      void Scene.setOnMouseClicked​(EventHandler<? super MouseEvent> value)
      设置属性onMouseClicked的值。
      void Node.setOnMouseDragged​(EventHandler<? super MouseEvent> value)
      设置属性onMouseDragged的值。
      void Scene.setOnMouseDragged​(EventHandler<? super MouseEvent> value)
      设置属性onMouseDragged的值。
      void Node.setOnMouseEntered​(EventHandler<? super MouseEvent> value)
      设置属性onMouseEntered的值。
      void Scene.setOnMouseEntered​(EventHandler<? super MouseEvent> value)
      设置属性onMouseEntered的值。
      void Node.setOnMouseExited​(EventHandler<? super MouseEvent> value)
      设置属性onMouseExited的值。
      void Scene.setOnMouseExited​(EventHandler<? super MouseEvent> value)
      设置属性onMouseExited的值。
      void Node.setOnMouseMoved​(EventHandler<? super MouseEvent> value)
      设置属性onMouseMoved的值。
      void Scene.setOnMouseMoved​(EventHandler<? super MouseEvent> value)
      设置属性onMouseMoved的值。
      void Node.setOnMousePressed​(EventHandler<? super MouseEvent> value)
      设置属性onMousePressed的值。
      void Scene.setOnMousePressed​(EventHandler<? super MouseEvent> value)
      设置属性onMousePressed的值。
      void Node.setOnMouseReleased​(EventHandler<? super MouseEvent> value)
      设置属性onMouseReleased的值。
      void Scene.setOnMouseReleased​(EventHandler<? super MouseEvent> value)
      设置属性onMouseReleased的值。

    • Uses of MouseEvent in javafx.scene.input

      Subclasses of MouseEvent in javafx.scene.input
      Modifier and Type Class 描述
      class  MouseDragEvent
      鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
      Fields in javafx.scene.input with type parameters of type MouseEvent
      Modifier and Type Field 描述
      static EventType<MouseEvent> MouseEvent.ANY
      所有鼠标事件类型的常用超类型。
      static EventType<MouseEvent> MouseEvent.DRAG_DETECTED
      该事件被传递到被识别为拖动手势的源的节点。
      static EventType<MouseEvent> MouseEvent.MOUSE_CLICKED
      当单击鼠标按钮（在同一节点上按下并释放）时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_DRAGGED
      当鼠标按下按钮移动时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_ENTERED
      当鼠标进入节点时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_ENTERED_TARGET
      当鼠标进入节点时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_EXITED
      当鼠标退出节点时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_EXITED_TARGET
      当鼠标退出节点时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_MOVED
      当鼠标在节点内移动并且没有按钮被按下时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_PRESSED
      当按下鼠标按钮时，会发生此事件。
      static EventType<MouseEvent> MouseEvent.MOUSE_RELEASED
      当鼠标按钮被释放时，会发生此事件。
      Methods in javafx.scene.input that return MouseEvent
      Modifier and Type 方法 描述
      MouseEvent MouseEvent.copyFor​(Object newSource, EventTarget newTarget)
      将此事件复制到不同的来源和目标。
      MouseEvent MouseEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> eventType)
      用给定的字段替换给定事件的副本。
      Methods in javafx.scene.input that return types with arguments of type MouseEvent
      Modifier and Type | 方法 | 描述
      EventType<? extends MouseEvent> | MouseEvent.getEventType​()
      Methods in javafx.scene.input with parameters of type MouseEvent
      Modifier and Type 方法 描述
      static MouseDragEvent MouseEvent.copyForMouseDragEvent​(MouseEvent e, Object source, EventTarget target, EventType<MouseDragEvent> type, Object gestureSource, PickResult pickResult)
      创建MouseDragEvent类型的鼠标事件的副本
      Method parameters in javafx.scene.input with type arguments of type MouseEvent
      Modifier and Type | 方法 | 描述
      MouseDragEvent | MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> type)
      MouseEvent MouseEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> eventType)
      用给定的字段替换给定事件的副本。
      Constructor parameters in javafx.scene.input with type arguments of type MouseEvent
      Constructor 描述
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.PickResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.PickResult

  • Packages that use PickResult
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of PickResult in javafx.scene.input

      Methods in javafx.scene.input that return PickResult
      Modifier and Type 方法 描述
      PickResult ContextMenuEvent.getPickResult​()
      返回有关选择的信息。
      PickResult DragEvent.getPickResult​()
      返回有关选择的信息。
      PickResult GestureEvent.getPickResult​()
      返回有关选择的信息。
      PickResult MouseEvent.getPickResult​()
      返回有关选择的信息。
      PickResult TouchPoint.getPickResult​()
      返回有关选择的信息。
      Methods in javafx.scene.input with parameters of type PickResult
      Modifier and Type 方法 描述
      static MouseDragEvent MouseEvent.copyForMouseDragEvent​(MouseEvent e, Object source, EventTarget target, EventType<MouseDragEvent> type, Object gestureSource, PickResult pickResult)
      创建MouseDragEvent类型的鼠标事件的副本
      Constructors in javafx.scene.input with parameters of type PickResult
      Constructor 描述
      ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造新的ContextMenu事件。
      ContextMenuEvent​(EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)
      构造具有空源和目标的新ContextMenu事件。
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
      GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)
      构建新的GestureEvent事件。
      GestureEvent​(EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)
      构造新的GestureEvent事件，具有空源和目标
      MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造新的MouseDragEvent事件。
      MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)
      构造具有null源和目标的新的MouseDragEvent事件。
      MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造新的MouseEvent事件。
      MouseEvent​(EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)
      构造具有null源和目标的新的MouseEvent事件。
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.RotateEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.RotateEvent

  • Packages that use RotateEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of RotateEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type RotateEvent
      Modifier and Type 方法 描述
      EventHandler<? super RotateEvent> Node.getOnRotate​()
      获取属性onRotate的值。
      EventHandler<? super RotateEvent> Scene.getOnRotate​()
      获取属性onRotate的值。
      EventHandler<? super RotateEvent> Node.getOnRotationFinished​()
      获取属性onRotationFinished的值。
      EventHandler<? super RotateEvent> Scene.getOnRotationFinished​()
      获取属性onRotationFinished的值。
      EventHandler<? super RotateEvent> Node.getOnRotationStarted​()
      获取属性onRotationStarted的值。
      EventHandler<? super RotateEvent> Scene.getOnRotationStarted​()
      获取属性onRotationStarted的值。
      ObjectProperty<EventHandler<? super RotateEvent>> Node.onRotateProperty​()
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> Scene.onRotateProperty​()
      定义当用户执行旋转操作时要调用的函数。
      ObjectProperty<EventHandler<? super RotateEvent>> Node.onRotationFinishedProperty​()
      定义旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Scene.onRotationFinishedProperty​()
      定义当旋转手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Node.onRotationStartedProperty​()
      定义检测到旋转手势时要调用的功能。
      ObjectProperty<EventHandler<? super RotateEvent>> Scene.onRotationStartedProperty​()
      定义检测到旋转手势时要调用的功能。
      Method parameters in javafx.scene with type arguments of type RotateEvent
      Modifier and Type 方法 描述
      void Node.setOnRotate​(EventHandler<? super RotateEvent> value)
      设置属性onRotate的值。
      void Scene.setOnRotate​(EventHandler<? super RotateEvent> value)
      设置属性onRotate的值。
      void Node.setOnRotationFinished​(EventHandler<? super RotateEvent> value)
      设置属性onRotationFinished的值。
      void Scene.setOnRotationFinished​(EventHandler<? super RotateEvent> value)
      设置属性onRotationFinished的值。
      void Node.setOnRotationStarted​(EventHandler<? super RotateEvent> value)
      设置属性onRotationStarted的值。
      void Scene.setOnRotationStarted​(EventHandler<? super RotateEvent> value)
      设置属性onRotationStarted的值。

    • Uses of RotateEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type RotateEvent
      Modifier and Type Field 描述
      static EventType<RotateEvent> RotateEvent.ANY
      所有旋转事件类型的公共超类型。
      static EventType<RotateEvent> RotateEvent.ROTATE
      当用户执行旋转手势（例如将两个手指彼此拖动时）发生此事件。
      static EventType<RotateEvent> RotateEvent.ROTATION_FINISHED
      当旋转手势结束时，会发生此事件。
      static EventType<RotateEvent> RotateEvent.ROTATION_STARTED
      当检测到旋转手势时，会发生此事件。
      Methods in javafx.scene.input that return RotateEvent
      Modifier and Type | 方法 | 描述
      RotateEvent | RotateEvent.copyFor​(Object newSource, EventTarget newTarget)
      RotateEvent RotateEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<RotateEvent> type)
      用给定的字段替换给定事件的副本。
      Methods in javafx.scene.input that return types with arguments of type RotateEvent
      Modifier and Type | 方法 | 描述
      EventType<RotateEvent> | RotateEvent.getEventType​()
      Method parameters in javafx.scene.input with type arguments of type RotateEvent
      Modifier and Type 方法 描述
      RotateEvent RotateEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<RotateEvent> type)
      用给定的字段替换给定事件的副本。
      Constructor parameters in javafx.scene.input with type arguments of type RotateEvent
      Constructor 描述
      RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造新的RotateEvent事件。
      RotateEvent​(EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)
      构造具有null源和目标的新的RotateEvent事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.ScrollEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.ScrollEvent

  • Packages that use ScrollEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of ScrollEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type ScrollEvent
      Modifier and Type 方法 描述
      EventHandler<? super ScrollEvent> Node.getOnScroll​()
      获取属性onScroll的值。
      EventHandler<? super ScrollEvent> Scene.getOnScroll​()
      获取属性onScroll的值。
      EventHandler<? super ScrollEvent> Node.getOnScrollFinished​()
      获取属性onScrollFinished的值。
      EventHandler<? super ScrollEvent> Scene.getOnScrollFinished​()
      获取属性onScrollFinished的值。
      EventHandler<? super ScrollEvent> Node.getOnScrollStarted​()
      获取属性onScrollStarted的值。
      EventHandler<? super ScrollEvent> Scene.getOnScrollStarted​()
      获取属性onScrollStarted的值。
      ObjectProperty<EventHandler<? super ScrollEvent>> Node.onScrollFinishedProperty​()
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Scene.onScrollFinishedProperty​()
      定义当滚动手势结束时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Node.onScrollProperty​()
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Scene.onScrollProperty​()
      定义当用户执行滚动操作时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Node.onScrollStartedProperty​()
      定义检测到滚动手势时要调用的函数。
      ObjectProperty<EventHandler<? super ScrollEvent>> Scene.onScrollStartedProperty​()
      定义检测到滚动手势时要调用的函数。
      Method parameters in javafx.scene with type arguments of type ScrollEvent
      Modifier and Type 方法 描述
      void Node.setOnScroll​(EventHandler<? super ScrollEvent> value)
      设置属性onScroll的值。
      void Scene.setOnScroll​(EventHandler<? super ScrollEvent> value)
      设置属性onScroll的值。
      void Node.setOnScrollFinished​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollFinished的值。
      void Scene.setOnScrollFinished​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollFinished的值。
      void Node.setOnScrollStarted​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollStarted的值。
      void Scene.setOnScrollStarted​(EventHandler<? super ScrollEvent> value)
      设置属性onScrollStarted的值。

    • Uses of ScrollEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type ScrollEvent
      Modifier and Type Field 描述
      static EventType<ScrollEvent> ScrollEvent.ANY
      所有滚动事件类型的常用超类型。
      static EventType<ScrollEvent> ScrollEvent.SCROLL
      当用户执行滚动操作（例如旋转鼠标滚轮或在触摸屏上拖动手指）时，会发生此事件。
      static EventType<ScrollEvent> ScrollEvent.SCROLL_FINISHED
      当滚动手势结束时，会发生此事件。
      static EventType<ScrollEvent> ScrollEvent.SCROLL_STARTED
      当检测到滚动手势时，会发生此事件。
      Methods in javafx.scene.input that return ScrollEvent
      Modifier and Type | 方法 | 描述
      ScrollEvent | ScrollEvent.copyFor​(Object newSource, EventTarget newTarget)
      ScrollEvent ScrollEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ScrollEvent> type)
      用给定的字段替换给定事件的副本。
      Methods in javafx.scene.input that return types with arguments of type ScrollEvent
      Modifier and Type | 方法 | 描述
      EventType<ScrollEvent> | ScrollEvent.getEventType​()
      Method parameters in javafx.scene.input with type arguments of type ScrollEvent
      Modifier and Type 方法 描述
      ScrollEvent ScrollEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ScrollEvent> type)
      用给定的字段替换给定事件的副本。
      Constructor parameters in javafx.scene.input with type arguments of type ScrollEvent
      Constructor 描述
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.ScrollEvent.HorizontalTextScrollUnits (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.ScrollEvent.HorizontalTextScrollUnits

  • Packages that use ScrollEvent.HorizontalTextScrollUnits
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of ScrollEvent.HorizontalTextScrollUnits in javafx.scene.input

      Methods in javafx.scene.input that return ScrollEvent.HorizontalTextScrollUnits
      Modifier and Type 方法 描述
      ScrollEvent.HorizontalTextScrollUnits ScrollEvent.getTextDeltaXUnits​()
      获取基于文本滚动的水平滚动单位。
      static ScrollEvent.HorizontalTextScrollUnits ScrollEvent.HorizontalTextScrollUnits.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ScrollEvent.HorizontalTextScrollUnits[] ScrollEvent.HorizontalTextScrollUnits.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.input with parameters of type ScrollEvent.HorizontalTextScrollUnits
      Constructor 描述
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      Constructs new ScrollEvent event with null source and target
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.ScrollEvent.VerticalTextScrollUnits (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.ScrollEvent.VerticalTextScrollUnits

  • Packages that use ScrollEvent.VerticalTextScrollUnits
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of ScrollEvent.VerticalTextScrollUnits in javafx.scene.input

      Methods in javafx.scene.input that return ScrollEvent.VerticalTextScrollUnits
      Modifier and Type 方法 描述
      ScrollEvent.VerticalTextScrollUnits ScrollEvent.getTextDeltaYUnits​()
      获取基于文本滚动的垂直滚动单位。
      static ScrollEvent.VerticalTextScrollUnits ScrollEvent.VerticalTextScrollUnits.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ScrollEvent.VerticalTextScrollUnits[] ScrollEvent.VerticalTextScrollUnits.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.input with parameters of type ScrollEvent.VerticalTextScrollUnits
      Constructor 描述
      ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造新的ScrollEvent事件。
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, double multiplierX, double multiplierY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的ScrollEvent事件
      ScrollEvent​(EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)
      Constructs new ScrollEvent event with null source and target
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.SwipeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.SwipeEvent

  • Packages that use SwipeEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of SwipeEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type SwipeEvent
      Modifier and Type 方法 描述
      EventHandler<? super SwipeEvent> Node.getOnSwipeDown​()
      获取属性onSwipeDown的值。
      EventHandler<? super SwipeEvent> Scene.getOnSwipeDown​()
      获取属性onSwipeDown的值。
      EventHandler<? super SwipeEvent> Node.getOnSwipeLeft​()
      获取属性onSwipeLeft的值。
      EventHandler<? super SwipeEvent> Scene.getOnSwipeLeft​()
      获取属性onSwipeLeft的值。
      EventHandler<? super SwipeEvent> Node.getOnSwipeRight​()
      获取属性onSwipeRight的值。
      EventHandler<? super SwipeEvent> Scene.getOnSwipeRight​()
      获取属性onSwipeRight的值。
      EventHandler<? super SwipeEvent> Node.getOnSwipeUp​()
      获取属性onSwipeUp的值。
      EventHandler<? super SwipeEvent> Scene.getOnSwipeUp​()
      获取属性onSwipeUp的值。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeDownProperty​()
      定义当在该节点上居中的向下滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeDownProperty​()
      定义当在此场景中发生向下滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeLeftProperty​()
      定义当以该节点为中心的向左滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeLeftProperty​()
      定义当在此场景中发生向左滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeRightProperty​()
      定义当以该节点为中心的向右滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeRightProperty​()
      定义当在此场景中发生向右滑动手势时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Node.onSwipeUpProperty​()
      定义当在该节点上居中的向上滑动手势发生时要调用的功能。
      ObjectProperty<EventHandler<? super SwipeEvent>> Scene.onSwipeUpProperty​()
      定义当在此场景中发生向上滑动手势时要调用的功能。
      Method parameters in javafx.scene with type arguments of type SwipeEvent
      Modifier and Type 方法 描述
      void Node.setOnSwipeDown​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeDown的值。
      void Scene.setOnSwipeDown​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeDown的值。
      void Node.setOnSwipeLeft​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeLeft的值。
      void Scene.setOnSwipeLeft​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeLeft的值。
      void Node.setOnSwipeRight​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeRight的值。
      void Scene.setOnSwipeRight​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeRight的值。
      void Node.setOnSwipeUp​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeUp的值。
      void Scene.setOnSwipeUp​(EventHandler<? super SwipeEvent> value)
      设置属性onSwipeUp的值。

    • Uses of SwipeEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type SwipeEvent
      Modifier and Type Field 描述
      static EventType<SwipeEvent> SwipeEvent.ANY
      所有滑动事件类型的常用超类型。
      static EventType<SwipeEvent> SwipeEvent.SWIPE_DOWN
      当用户执行向下滑动手势时，会发生此事件。
      static EventType<SwipeEvent> SwipeEvent.SWIPE_LEFT
      当用户执行向左滑动手势时，会发生此事件。
      static EventType<SwipeEvent> SwipeEvent.SWIPE_RIGHT
      当用户执行向右滑动手势时，会发生此事件。
      static EventType<SwipeEvent> SwipeEvent.SWIPE_UP
      当用户执行向上滑动手势时，会发生此事件。
      Methods in javafx.scene.input that return SwipeEvent
      Modifier and Type | 方法 | 描述
      SwipeEvent | SwipeEvent.copyFor​(Object newSource, EventTarget newTarget)
      SwipeEvent SwipeEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<SwipeEvent> type)
      用给定的字段替换给定事件的副本。
      Methods in javafx.scene.input that return types with arguments of type SwipeEvent
      Modifier and Type | 方法 | 描述
      EventType<SwipeEvent> | SwipeEvent.getEventType​()
      Method parameters in javafx.scene.input with type arguments of type SwipeEvent
      Modifier and Type 方法 描述
      SwipeEvent SwipeEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<SwipeEvent> type)
      用给定的字段替换给定事件的副本。
      Constructor parameters in javafx.scene.input with type arguments of type SwipeEvent
      Constructor 描述
      SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造新的SwipeEvent事件。
      SwipeEvent​(EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)
      构造具有null源和目标的新的SwipeEvent事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.TouchEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.TouchEvent

  • Packages that use TouchEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of TouchEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type TouchEvent
      Modifier and Type 方法 描述
      EventHandler<? super TouchEvent> Node.getOnTouchMoved​()
      获取onTouchMoved属性的值。
      EventHandler<? super TouchEvent> Scene.getOnTouchMoved​()
      获取onTouchMoved属性的值。
      EventHandler<? super TouchEvent> Node.getOnTouchPressed​()
      获取onTouchPressed属性的值。
      EventHandler<? super TouchEvent> Scene.getOnTouchPressed​()
      获取onTouchPressed属性的值。
      EventHandler<? super TouchEvent> Node.getOnTouchReleased​()
      获取onTouchReleased属性的值。
      EventHandler<? super TouchEvent> Scene.getOnTouchReleased​()
      获取onTouchReleased属性的值。
      EventHandler<? super TouchEvent> Node.getOnTouchStationary​()
      获取属性onTouchStationary的值。
      EventHandler<? super TouchEvent> Scene.getOnTouchStationary​()
      获取属性onTouchStationary的值。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchMovedProperty​()
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchMovedProperty​()
      定义当触摸点移动时要调用的函数。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchPressedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchPressedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchReleasedProperty​()
      定义触发点释放时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchReleasedProperty​()
      定义当按下新的触摸点时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Node.onTouchStationaryProperty​()
      定义当触摸点保持按下并静止时要调用的功能。
      ObjectProperty<EventHandler<? super TouchEvent>> Scene.onTouchStationaryProperty​()
      定义当触摸点保持按下并静止时要调用的功能。
      Method parameters in javafx.scene with type arguments of type TouchEvent
      Modifier and Type 方法 描述
      void Node.setOnTouchMoved​(EventHandler<? super TouchEvent> value)
      设置属性onTouchMoved的值。
      void Scene.setOnTouchMoved​(EventHandler<? super TouchEvent> value)
      设置属性onTouchMoved的值。
      void Node.setOnTouchPressed​(EventHandler<? super TouchEvent> value)
      设置属性onTouchPressed的值。
      void Scene.setOnTouchPressed​(EventHandler<? super TouchEvent> value)
      设置属性onTouchPressed的值。
      void Node.setOnTouchReleased​(EventHandler<? super TouchEvent> value)
      设置属性onTouchReleased的值。
      void Scene.setOnTouchReleased​(EventHandler<? super TouchEvent> value)
      设置属性onTouchReleased的值。
      void Node.setOnTouchStationary​(EventHandler<? super TouchEvent> value)
      设置属性onTouchStationary的值。
      void Scene.setOnTouchStationary​(EventHandler<? super TouchEvent> value)
      设置属性onTouchStationary的值。

    • Uses of TouchEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type TouchEvent
      Modifier and Type Field 描述
      static EventType<TouchEvent> TouchEvent.ANY
      所有触摸事件类型的常用超类型。
      static EventType<TouchEvent> TouchEvent.TOUCH_MOVED
      触摸点移动时会发生此事件。
      static EventType<TouchEvent> TouchEvent.TOUCH_PRESSED
      当按下触摸点（第一次触摸）时，会发生此事件。
      static EventType<TouchEvent> TouchEvent.TOUCH_RELEASED
      当触发点被释放时，会发生此事件。
      static EventType<TouchEvent> TouchEvent.TOUCH_STATIONARY
      当按住触摸点并静止（不移动）时，会发生此事件。
      Methods in javafx.scene.input that return TouchEvent
      Modifier and Type 方法 描述
      TouchEvent TouchEvent.copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      TouchEvent TouchEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<TouchEvent> type)
      用给定的字段替换给定事件的副本。
      Methods in javafx.scene.input that return types with arguments of type TouchEvent
      Modifier and Type | 方法 | 描述
      EventType<TouchEvent> | TouchEvent.getEventType​()
      Method parameters in javafx.scene.input with type arguments of type TouchEvent
      Modifier and Type 方法 描述
      TouchEvent TouchEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<TouchEvent> type)
      用给定的字段替换给定事件的副本。
      Constructor parameters in javafx.scene.input with type arguments of type TouchEvent
      Constructor 描述
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.TouchPoint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.TouchPoint

  • Packages that use TouchPoint
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of TouchPoint in javafx.scene.input

      Methods in javafx.scene.input that return TouchPoint
      Modifier and Type 方法 描述
      TouchPoint TouchEvent.getTouchPoint​()
      获取此事件的触点。
      Methods in javafx.scene.input that return types with arguments of type TouchPoint
      Modifier and Type 方法 描述
      List<TouchPoint> TouchEvent.getTouchPoints​()
      获取由这组触摸事件表示的所有触摸点，包括此事件的触摸点。
      Constructors in javafx.scene.input with parameters of type TouchPoint
      Constructor 描述
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构造具有null源和目标的新的TouchEvent事件。
      Constructor parameters in javafx.scene.input with type arguments of type TouchPoint
      Constructor 描述
      TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      构建新的TouchEvent事件。
      TouchEvent​(EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)
      Constructs new TouchEvent event with null source and target.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.TouchPoint.State (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.TouchPoint.State

  • Packages that use TouchPoint.State
    软件包 描述
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of TouchPoint.State in javafx.scene.input

      Methods in javafx.scene.input that return TouchPoint.State
      Modifier and Type 方法 描述
      TouchPoint.State TouchPoint.getState​()
      获取此触点的状态
      static TouchPoint.State TouchPoint.State.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TouchPoint.State[] TouchPoint.State.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.input with parameters of type TouchPoint.State
      Constructor 描述
      TouchPoint​(int id, TouchPoint.State state, double x, double y, double screenX, double screenY, EventTarget target, PickResult pickResult)
      创建TouchPoint的新实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.TransferMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.TransferMode

  • Packages that use TransferMode
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of TransferMode in javafx.scene

      Methods in javafx.scene with parameters of type TransferMode
      Modifier and Type 方法 描述
      Dragboard Node.startDragAndDrop​(TransferMode... transferModes)
      确认一个潜在的拖放手势，在这 Node被认可。
      Dragboard Scene.startDragAndDrop​(TransferMode... transferModes)
      确认一个潜在的拖放手势，在这 Scene被认可。

    • Uses of TransferMode in javafx.scene.input

      Fields in javafx.scene.input declared as TransferMode
      Modifier and Type Field 描述
      static TransferMode[] TransferMode.ANY
      数组包含所有传输模式。
      static TransferMode[] TransferMode.COPY_OR_MOVE
      包含传输模式的数组COPY和MOVE。
      static TransferMode[] TransferMode.NONE
      空数组传输模式。
      Methods in javafx.scene.input that return TransferMode
      Modifier and Type 方法 描述
      TransferMode DragEvent.getAcceptedTransferMode​()
      获得潜在目标接受的传输模式。
      TransferMode DragEvent.getTransferMode​()
      数据传输模式。
      static TransferMode TransferMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TransferMode[] TransferMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.input that return types with arguments of type TransferMode
      Modifier and Type 方法 描述
      Set<TransferMode> Dragboard.getTransferModes​()
      获取由此拖动操作的源支持的一组传输模式。
      Methods in javafx.scene.input with parameters of type TransferMode
      Modifier and Type 方法 描述
      void DragEvent.acceptTransferModes​(TransferMode... transferModes)
      接受这个 DragEvent ，选择放置操作的传输模式。
      Constructors in javafx.scene.input with parameters of type TransferMode
      Constructor 描述
      DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造新的DragEvent事件。
      DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)
      构造具有空源和目标的新的DragEvent事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.input.ZoomEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.input.ZoomEvent

  • Packages that use ZoomEvent
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。

    • Uses of ZoomEvent in javafx.scene

      Methods in javafx.scene that return types with arguments of type ZoomEvent
      Modifier and Type 方法 描述
      EventHandler<? super ZoomEvent> Node.getOnZoom​()
      获取属性onZoom的值。
      EventHandler<? super ZoomEvent> Scene.getOnZoom​()
      获取属性onZoom的值。
      EventHandler<? super ZoomEvent> Node.getOnZoomFinished​()
      获取属性onZoomFinished的值。
      EventHandler<? super ZoomEvent> Scene.getOnZoomFinished​()
      获取属性onZoomFinished的值。
      EventHandler<? super ZoomEvent> Node.getOnZoomStarted​()
      获取属性onZoomStarted的值。
      EventHandler<? super ZoomEvent> Scene.getOnZoomStarted​()
      获取属性onZoomStarted的值。
      ObjectProperty<EventHandler<? super ZoomEvent>> Node.onZoomFinishedProperty​()
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Scene.onZoomFinishedProperty​()
      定义当缩放手势结束时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Node.onZoomProperty​()
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> Scene.onZoomProperty​()
      定义当用户执行缩放操作时要调用的函数。
      ObjectProperty<EventHandler<? super ZoomEvent>> Node.onZoomStartedProperty​()
      定义检测到缩放手势时要调用的功能。
      ObjectProperty<EventHandler<? super ZoomEvent>> Scene.onZoomStartedProperty​()
      定义检测到缩放手势时要调用的功能。
      Method parameters in javafx.scene with type arguments of type ZoomEvent
      Modifier and Type 方法 描述
      void Node.setOnZoom​(EventHandler<? super ZoomEvent> value)
      设置Zoom上的属性值。
      void Scene.setOnZoom​(EventHandler<? super ZoomEvent> value)
      设置Zoom上的属性值。
      void Node.setOnZoomFinished​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomFinished的值。
      void Scene.setOnZoomFinished​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomFinished的值。
      void Node.setOnZoomStarted​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomStarted的值。
      void Scene.setOnZoomStarted​(EventHandler<? super ZoomEvent> value)
      设置属性onZoomStarted的值。

    • Uses of ZoomEvent in javafx.scene.input

      Fields in javafx.scene.input with type parameters of type ZoomEvent
      Modifier and Type Field 描述
      static EventType<ZoomEvent> ZoomEvent.ANY
      所有缩放事件类型的常用超类型。
      static EventType<ZoomEvent> ZoomEvent.ZOOM
      当用户执行缩放手势（例如拖动两根手指）时，会发生此事件。
      static EventType<ZoomEvent> ZoomEvent.ZOOM_FINISHED
      当缩放手势结束时，会发生此事件。
      static EventType<ZoomEvent> ZoomEvent.ZOOM_STARTED
      当检测到缩放手势时，会发生此事件。
      Methods in javafx.scene.input that return ZoomEvent
      Modifier and Type | 方法 | 描述
      ZoomEvent | ZoomEvent.copyFor​(Object newSource, EventTarget newTarget)
      ZoomEvent ZoomEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ZoomEvent> type)
      用给定的字段替换给定事件的副本。
      Methods in javafx.scene.input that return types with arguments of type ZoomEvent
      Modifier and Type | 方法 | 描述
      EventType<ZoomEvent> | ZoomEvent.getEventType​()
      Method parameters in javafx.scene.input with type arguments of type ZoomEvent
      Modifier and Type 方法 描述
      ZoomEvent ZoomEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ZoomEvent> type)
      用给定的字段替换给定事件的副本。
      Constructor parameters in javafx.scene.input with type arguments of type ZoomEvent
      Constructor 描述
      ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造新的ZoomEvent事件。
      ZoomEvent​(EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)
      构造具有null源和目标的新的ZoomEvent事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.scene.input.InputMethodRequests (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.scene.input.InputMethodRequests

  • Packages that use InputMethodRequests
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。

    • Uses of InputMethodRequests in javafx.scene

      Methods in javafx.scene that return InputMethodRequests
      Modifier and Type 方法 描述
      InputMethodRequests Node.getInputMethodRequests​()
      获取属性inputMethodRequests的值。
      Methods in javafx.scene that return types with arguments of type InputMethodRequests
      Modifier and Type 方法 描述
      ObjectProperty<InputMethodRequests> Node.inputMethodRequestsProperty​()
      属性保存InputMethodRequests。
      Methods in javafx.scene with parameters of type InputMethodRequests
      Modifier and Type 方法 描述
      void Node.setInputMethodRequests​(InputMethodRequests value)
      设置属性inputMethodRequests的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AnchorPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class AnchorPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.AnchorPane
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class AnchorPane
extends Pane
    AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。 如果锚定窗格具有边框和/或填充集合，则偏移量将从这些插值的内边缘测量。

    无论孩子的可见财产价值如何，AnchorPane都会安排每个被管理的孩子; 所有布局计算都忽略非托管孩子。

    AnchorPanes可能使用CSS来设计背景和边框。 有关详细信息，请参阅Region超类。

    锚定约束

    该应用程序为每个小孩设置锚点约束，以在一侧或多侧配置锚点。 如果一个孩子被固定在相对侧（并且可调整大小）上，则锚点窗格将调整其大小以保持两个偏移量，否则锚点窗格将调整为其首选大小。 如果在前一种情况下（锚定在对面），并且小孩不能调整大小，那么只有顶部/左侧的锚点才能被履行。 AnchorPane提供静态方法来设置每个锚约束。

    AnchorPane Constraint Table Constraint Type Description topAnchor double distance from the anchor pane's top insets to the child's top edge. leftAnchor double distance from the anchor pane's left insets to the child's left edge. bottomAnchor double distance from the anchor pane's bottom insets to the child's bottom edge. rightAnchor double distance from the anchor pane's right insets to the child's right edge.

    AnchorPane示例：

       AnchorPane anchorPane = new AnchorPane(); // List should stretch as anchorPane is resized ListView list = new ListView();  AnchorPane.setTopAnchor(list, 10.0); AnchorPane.setLeftAnchor(list, 10.0); AnchorPane.setRightAnchor(list, 65.0); // Button will float on right edge Button button = new Button("Add"); AnchorPane.setTopAnchor(button, 10.0); AnchorPane.setRightAnchor(button, 10.0); anchorPane.getChildren().addAll(list, button);

    可调整范围

    锚定窗格的父级将在布局期间在锚定窗格的可调整大小范围内调整锚定窗格的大小。 默认情况下，锚窗格根据其内容计算该范围，如下表所示。

    AnchorPane Resize Table width height minimum left/right insets plus width required to display children anchored at left/right with at least their min widths top/bottom insets plus height required to display children anchored at top/bottom with at least their min heights preferred left/right insets plus width required to display children anchored at left/right with at least their pref widths top/bottom insets plus height required to display children anchored at top/bottom with at least their pref heights maximum Double.MAX_VALUE Double.MAX_VALUE

    锚定窗格的无界最大宽度和高度是对父级的指示，可以将其调整大小超出其首选大小，以填充分配给它的任何空间。

    AnchorPane提供了直接设置尺寸范围的属性。 这些属性默认为哨兵值Region.USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       anchorPane.setPrefSize(300, 300);
    应用程序可以通过将这些属性设置回Region.USE_COMPUTED_SIZE来还原计算值。

    AnchorPane默认情况下不剪切其内容，因此如果锚定窗格的大小小于其首选大小，则儿童边界可能会延伸到其自己的边界之外。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      AnchorPane​()
      创建AnchorPane布局。
      AnchorPane​(Node... children)
      与给定的孩子创建AnchorPane布局。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static void clearConstraints​(Node child)
      从子节点中删除所有锚窗格约束。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      static Double getBottomAnchor​(Node child)
      如果设置，返回小孩的底部锚约束。
      static Double getLeftAnchor​(Node child)
      如果设置，返回小孩的左锚约束。
      static Double getRightAnchor​(Node child)
      如果设置，返回小孩的右侧锚点约束。
      static Double getTopAnchor​(Node child)
      如果设置，返回小孩的顶部锚约束。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      static void setBottomAnchor​(Node child, Double value)
      设置锚定窗格包含的小孩的底部锚点。
      static void setLeftAnchor​(Node child, Double value)
      设置锚定窗格所包含的小孩的左侧锚点。
      static void setRightAnchor​(Node child, Double value)
      为锚定窗格包含的小孩设置正确的锚点。
      static void setTopAnchor​(Node child, Double value)
      设置锚定窗格包含的小孩的顶部锚点。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getClassCssMetaData, getCssMetaData, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • AnchorPane

        public AnchorPane​()
        创建AnchorPane布局。

      • AnchorPane

        public AnchorPane​(Node... children)
        与给定的孩子创建AnchorPane布局。
        参数
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setTopAnchor

        public static void setTopAnchor​(Node child,
                                Double value)
        设置锚定窗格包含的小孩的顶部锚点。 如果设置了，锚定窗格将保持小孩的大小和位置，使其顶部始终被锚定窗格的顶部内容边缘偏移。 将值设置为null将删除约束。
        参数
        child - 锚点窗格的子节点
        value - 从锚定窗格顶部的偏移量

      • getTopAnchor

        public static Double getTopAnchor​(Node child)
        如果设置，返回小孩的顶部锚约束。
        参数
        child - 锚点窗格的子节点
        结果
        从锚定窗格顶部的偏移量，如果没有设置顶部锚点，则为null

      • setLeftAnchor

        public static void setLeftAnchor​(Node child,
                                 Double value)
        设置锚定窗格所包含的小孩的左侧锚点。 如果设置，锚定窗格将保持小孩的大小和位置，使其左侧始终从锚点窗格的左侧内容边缘偏移量。 将值设置为null将删除约束。
        参数
        child - 锚点窗格的子节点
        value - 锚定窗格左侧的偏移量

      • getLeftAnchor

        public static Double getLeftAnchor​(Node child)
        如果设置，返回小孩的左锚约束。
        参数
        child - 锚点窗格的子节点
        结果
        从锚定窗格左侧的偏移量，如果未设置左侧锚点，则为null

      • setBottomAnchor

        public static void setBottomAnchor​(Node child,
                                   Double value)
        设置锚定窗格包含的小孩的底部锚点。 如果设置，锚定窗格将保持小孩的大小和位置，使其底部总是从锚定窗格的底部内容边缘偏移该量。 将值设置为null将删除约束。
        参数
        child - 锚点窗格的子节点
        value - 从锚定窗格底部的偏移量

      • getBottomAnchor

        public static Double getBottomAnchor​(Node child)
        如果设置，返回小孩的底部锚约束。
        参数
        child - 锚点窗格的子节点
        结果
        从锚定窗格底部的偏移量，如果没有设置底部锚点，则为null

      • setRightAnchor

        public static void setRightAnchor​(Node child,
                                  Double value)
        为锚定窗格包含的小孩设置正确的锚点。 如果设置，锚窗格将保持小孩的大小和位置，使其正确始终从锚点窗格的正确内容边缘偏移量。 将值设置为null将删除约束。
        参数
        child - 锚点窗格的子节点
        value - 锚定窗格右侧的偏移量

      • getRightAnchor

        public static Double getRightAnchor​(Node child)
        如果设置，返回小孩的右侧锚点约束。
        参数
        child - 锚点窗格的子节点
        结果
        从锚定窗格右侧的偏移量，如果没有设置右侧锚点，则为null

      • clearConstraints

        public static void clearConstraints​(Node child)
        从子节点中删除所有锚窗格约束。
        参数
        child - 子节点

      • computeMinWidth

        protected double computeMinWidth​(double height)
        描述从类复制： Region
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        描述从类复制： Region
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        描述从类复制： Region
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        描述从类别复制： Region
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Parent
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Background (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class Background

  • java.lang.Object
    • javafx.scene.layout.Background

  • public final class Background
extends Object
    背景Region 。 背景是一个不可变的对象，它封装了渲染Region的背景所需的整个数据集。 因为这个类是不可变的，你可以在许多不同的地区自由地使用相同的背景。 请参阅JavaFX CSS Reference Guide有关为区域背景设置样式的CSS规则的完整说明。

    每个背景由fills和/或images组成 。 这两个列表都不会为空，但是两者都可能为空。 每个定义的BackgroundFill按顺序呈现，其次是每个定义的BackgroundImage 。

    背景的outsets定义了一个区域的绘图区域的任何扩展，这是需要考虑所有背景图。 由于所有BackgroundImages被剪切到绘图区域，并且不定义它们，所以这些外部部分由本背景指定的BackgroundFill（如果有的话）严格定义。 外部值是严格非负的。

    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Background EMPTY
      一个空的背景，使用而不是null。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Background​(List<BackgroundFill> fills, List<BackgroundImage> images)
      创建一个新的背景提供两个列表，一个用于背景填充，一个用于背景图像。
      Background​(BackgroundFill... fills)
      通过提供一个BackgroundFill数组创建一个新的背景。
      Background​(BackgroundFill[] fills, BackgroundImage[] images)
      通过提供两个阵列创建一个新的背景，一个用于背景填充，另一个用于背景图像。
      Background​(BackgroundImage... images)
      通过提供一个BackgroundImages数组创建一个新的背景。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<BackgroundFill> getFills​()
      BackgroundFill的列表，它们一起定义了该背景的填充部分。
      List<BackgroundImage> getImages​()
      BackgroundImages的列表，它们一起定义了此Background的图像部分。
      Insets getOutsets​()
      这个背景的外在。
      int hashCode​()
      返回对象的哈希码值。
      boolean isEmpty​()
      获取背景是否为空。
      boolean isFillPercentageBased​()
      获取此背景的填充是基于百分比（即相对于被定制的区域的大小）。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • EMPTY

        public static final Background EMPTY
        一个空的背景，使用而不是null。

    • 构造方法详细信息

      • Background

        public Background​(BackgroundFill... fills)
        通过提供一个BackgroundFill数组创建一个新的背景。 该数组可能为空，或者可能包含空值。 任何空值都将被忽略，不会对fills或outsets做出贡献。
        参数
        fills - 填写。 这可能为null，并且可能包含null。 任何包含的空值将被过滤掉，不包括在最终的填充列表中。 空数组变为空列表。

      • Background

        public Background​(BackgroundImage... images)
        通过提供一个BackgroundImages数组创建一个新的背景。 该数组可能为空，或者可能包含空值。 任何空值都将被忽略，不会对images做出贡献。
        参数
        images - 图像。 这可能为null，并且可能包含null。 任何包含的空值被过滤掉，不包括在最终的图像列表中。 空数组变为空列表。

      • Background

        public Background​(List<BackgroundFill> fills,
                  List<BackgroundImage> images)
        创建一个新的背景提供两个列表，一个用于背景填充，一个用于背景图像。 任一列表可能为null，并且可能包含null。 这些列表中的任何空值将被忽略，不会有助于fills ， images ，或outsets 。
        参数
        fills - 填写。 这可能为null，并且可能包含null。 任何包含的空值将被过滤掉，不包括在最终的填充列表中。 空列表变为空列表。
        images - 图像。 这可能为null，并且可能包含null。 任何包含的空值被过滤掉，不包括在最终的图像列表中。 空列表变为空列表。

      • Background

        public Background​(BackgroundFill[] fills,
                  BackgroundImage[] images)
        通过提供两个阵列创建一个新的背景，一个用于背景填充，另一个用于背景图像。 数组可能为空，并且可能包含空值。 在这些阵列的任何空值将被忽略，不会有助于fills ， images ，或outsets 。
        参数
        fills - 填写。 这可能为null，并且可能包含null。 任何包含的空值将被过滤掉，不包括在最终的填充列表中。 空数组变为空列表。
        images - 图像。 这可能为null，并且可能包含null。 任何包含的空值被过滤掉，不包括在最终的图像列表中。 空数组变为空列表。

    • 方法详细信息

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。

      • getFills

        public final List<BackgroundFill> getFills​()
        BackgroundFill的列表，它们一起定义了该背景的填充部分。 该列表是不可修改的和不可变的。 它永远不会为空。 此列表的元素也不会为空。
        结果
        BackgroundFill的列表

      • getImages

        public final List<BackgroundImage> getImages​()
        BackgroundImages的列表，它们一起定义了此Background的图像部分。 该列表是不可修改的和不可变的。 它永远不会为空。 此列表的元素也不会为空。
        结果
        BackgroundImages的列表

      • getOutsets

        public final Insets getOutsets​()
        这个背景的外在。 这表示将在背景中进行所有绘图的最大的边框矩形。 外界永远不会是负面的，代表距离区域边缘的距离。 任何将超出外界的BackgroundImages将被剪辑。 只有背景资料有助于外援。
        结果
        外人

      • isEmpty

        public final boolean isEmpty​()
        获取背景是否为空。 如果没有填充或图像，则为空。
        结果
        如果背景为空，则为true，否则为false。

      • isFillPercentageBased

        public boolean isFillPercentageBased​()
        获取此背景的填充是基于百分比（即相对于被定制的区域的大小）。 具体来说，如果此背景上的任何填充上的任何CornerRadii具有基于百分比的半径，则返回true。
        结果
        如果此背景上任何BackgroundFill的任何CornerRadii的任何CornerRadii将返回true，否则为true。
        从以下版本开始：
        JavaFX 8.0

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 用于比较的参考对象。
        结果
        true如果该对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如由HashMap提供的那样 。

        hashCode的总合同是：

        • 在执行Java应用程序时，无论何时在同一对象上多次调用该对象， hashCode方法必须始终返回相同的整数，前提是修改了equals对象中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每一个上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


BackgroundFill (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class BackgroundFill

  • java.lang.Object
    • javafx.scene.layout.BackgroundFill

  • public final class BackgroundFill
extends Object
    填充和关联的属性，指示如何填充Region的背景。 因为BackgroundFill是一个不可变的对象，它可以安全地用在任何缓存中，并且可以安全地在多个区域之间重复使用或在同一个区域重复使用。

    所有BackgroundFill都按顺序绘制。

    当应用于具有定义形状的区域时，角半径被忽略。

    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      BackgroundFill​(Paint fill, CornerRadii radii, Insets insets)
      使用指定的填充，半径和插入创建一个新的BackgroundFill。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      Paint getFill​()
      油漆用于填充Region的背景。
      Insets getInsets​()
      Insets用于填充。
      CornerRadii getRadii​()
      用于表示BackgroundFill的四个半径的Radii。
      int hashCode​()
      返回对象的哈希码值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BackgroundFill

        public BackgroundFill​(Paint fill,
                      CornerRadii radii,
                      Insets insets)
        使用指定的填充，半径和插入创建一个新的BackgroundFill。 空值是可以接受的，但默认值将用于代替任何空值。
        参数
        fill - 任何油漆。 如果为null，则使用值Color.TRANSPARENT。
        radii - 角落里的半径。 如果为空，则使用Radii.EMPTY值。
        insets - 插图。 如果为null，则使用值Insets.EMPTY。

    • 方法详细信息

      • getFill

        public final Paint getFill​()
        油漆用于填充Region的背景。 该值永远不会为空。
        结果
        油漆用于填充Region的背景

      • getRadii

        public final CornerRadii getRadii​()
        用于表示BackgroundFill的四个半径的Radii。 因此，可以独立地指定每个角落。 这将永远不会为空。 半径值永远不会为负数。
        结果
        用于表示BackgroundFill的四个半径的Radii

      • getInsets

        public final Insets getInsets​()
        Insets用于填充。 每个插图表示与该区域的距离开始绘制的距离。 插图永远不会为空，但是为了将边框定位到区域的自然界限（即，（0，0，宽度，高度））之外，值可能为负。
        结果
        Insets用于填充

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 用于比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则hashCode两个对象中的每个对象调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BackgroundImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class BackgroundImage

  • java.lang.Object
    • javafx.scene.layout.BackgroundImage

  • public final class BackgroundImage
extends Object
    定义描述如何将图像呈现为背景的属性Region 。 一个BackgroundImage必须指定一个图像（它不能为null）。 repeatX和repeatY属性定义了如何在每个方向上重复图像。 position属性定义如何在Region上定位图像，而size属性定义了Region上的图像大小。 例如， size可能被定义为cover = true ，这意味着图像应该被拉伸以覆盖整个区域的渲染表面。

    因为BackgroundImage是不可变的，它可以安全地用于任何缓存，并且可以安全地在多个区域之间重用。

    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      Image getImage​()
      要使用的图像。
      BackgroundPosition getPosition​()
      这个BackgroundImage相对于Region的位置。
      BackgroundRepeat getRepeatX​()
      以什么方式（如果有的话）表示背景图像将沿着该区域的x轴重复。
      BackgroundRepeat getRepeatY​()
      以什么方式（如果有的话）表示背景图像将沿着该区域的y轴重复。
      BackgroundSize getSize​()
      该图像相对于Region的大小。
      int hashCode​()
      返回对象的哈希码值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BackgroundImage

        public BackgroundImage​(Image image,
                       BackgroundRepeat repeatX,
                       BackgroundRepeat repeatY,
                       BackgroundPosition position,
                       BackgroundSize size)
        创建一个新的BackgroundImage。 必须指定image 。
        参数
        image - 要使用的图像。 这不能为空。
        repeatX - x轴的BackgroundRepeat。 如果为空，则此值默认为REPEAT。
        repeatY - y轴的BackgroundRepeat。 如果为空，则此值默认为REPEAT。
        position - 要使用的BackgroundPosition。 如果为空，则默认为BackgroundPosition.DEFAULT。
        size - BackgroundSize。 如果为空，则默认为BackgroundSize.DEFAULT。

    • 方法详细信息

      • getImage

        public final Image getImage​()
        要使用的图像。 这将永远不会为空。 如果此图像无法加载，则在渲染时将会跳过整个BackgroundImage。
        结果
        要使用的图像

      • getRepeatX

        public final BackgroundRepeat getRepeatX​()
        以什么方式（如果有的话）表示背景图像将沿着该区域的x轴重复。 这将永远不会为空。
        结果
        BackgroundRepeat指示背景图像是否沿着该区域的x轴重复

      • getRepeatY

        public final BackgroundRepeat getRepeatY​()
        以什么方式（如果有的话）表示背景图像将沿着该区域的y轴重复。 这将永远不会为空。
        结果
        BackgroundRepeat指示背景图像是否沿着该区域的y轴重复

      • getPosition

        public final BackgroundPosition getPosition​()
        这个BackgroundImage相对于Region的位置。 请注意，该区域背景区域之外的任何位置将被剪切。
        结果
        这个BackgroundImage相对于Region的位置

      • getSize

        public final BackgroundSize getSize​()
        该图像相对于Region的大小。
        结果
        该图像相对于Region的大小

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        equals方法在对象上实现最Object的可能的等价关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如由HashMap提供的那样 。

        hashCode的一般合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了equals对象中的比较信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在这两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BackgroundPosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class BackgroundPosition

  • java.lang.Object
    • javafx.scene.layout.BackgroundPosition

  • public class BackgroundPosition
extends Object
    表示的位置BackgroundImage的内Region的绘图区域。

    BackgroundImage可以沿着水平轴线从左侧或右侧定位，也可以沿垂直轴线从顶侧或底侧定位。 horizontalSide和verticalSide属性定义了其余属性与哪一方有关。 horizontalPosition指定了BackgroundImage与Region对应的一边的距离，而horizontalAsPercentage则指定是否为文字值或百分比。 存在用于指定相对于垂直轴的大小的类似属性。

    例如，假设我有一个背景位置，其中horizontalSide是Side.RIGHT为horizontalPosition和horizontalAsPercentage的true 。 在这种情况下，BackgroundImage的右侧将是Region区域右边缘宽度的5％。

    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static BackgroundPosition CENTER
      一个将背景图像中心的BackgroundPosition。
      static BackgroundPosition DEFAULT
      任何BackgroundImage的默认BackgroundPosition。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BackgroundPosition​(Side horizontalSide, double horizontalPosition, boolean horizontalAsPercentage, Side verticalSide, double verticalPosition, boolean verticalAsPercentage)
      创建一个新的BackgroundPosition。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      double getHorizontalPosition​()
      指示背景图像相对于由 horizontalSide属性指示的一侧的区域的位置的值。
      Side getHorizontalSide​()
      背景图像被锚定在水平轴的一侧。
      double getVerticalPosition​()
      表示BackgroundImage相对于由 verticalSide属性指示的一侧的区域的位置的值。
      Side getVerticalSide​()
      沿着垂直轴的SideMap背景。
      int hashCode​()
      返回对象的哈希码值。
      boolean isHorizontalAsPercentage​()
      指定 horizontalPosition是否应解释为文字数字或百分比。
      boolean isVerticalAsPercentage​()
      指定 verticalPosition是否应解释为文字数字或百分比。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT

        public static final BackgroundPosition DEFAULT
        任何BackgroundImage的默认BackgroundPosition。 默认值为没有插入，并被定义为0％和0％。 也就是说，位置在左上角。

      • CENTER

        public static final BackgroundPosition CENTER
        一个将背景图像中心的BackgroundPosition。

    • 构造方法详细信息

      • BackgroundPosition

        public BackgroundPosition​(Side horizontalSide,
                          double horizontalPosition,
                          boolean horizontalAsPercentage,
                          Side verticalSide,
                          double verticalPosition,
                          boolean verticalAsPercentage)
        创建一个新的BackgroundPosition。
        参数
        horizontalSide - 水平面必须为null，LEFT或RIGHT。 如果为空，则使用LEFT。 如果指定了TOP或BOTTOM，则抛出IllegalArgumentException。
        horizontalPosition - 水平位置值。
        horizontalAsPercentage - 是否将水平位置解读为小数或百分比
        verticalSide - 垂直面必须为null，TOP或BOTTOM。 如果为空，则将使用TOP。 如果指定了LEFT或RIGHT，则抛出IllegalArgumentException。
        verticalPosition - 垂直位置值。
        verticalAsPercentage - 是否将垂直位置解释为十进制或百分比

    • 方法详细信息

      • getHorizontalSide

        public final Side getHorizontalSide​()
        背景图像被锚定在水平轴的一侧。 这只会是LEFT或RIGHT，从不为null。
        结果
        沿着ImageImage所锚定的水平轴的Side

      • getVerticalSide

        public final Side getVerticalSide​()
        沿着垂直轴的SideMap背景。 这只会是TOP或BOTTOM，永远不会为空。
        结果
        沿着垂直轴的Side，SideMap被锚定到

      • getHorizontalPosition

        public final double getHorizontalPosition​()
        表示BackgroundImage相对于由horizontalSide属性指示的一侧的区域的位置的值。 此值为字面值或百分比，具体取决于horizontalAsPercentage属性。 负值是可以接受的。
        结果
        BackgroundImage的水平位置

      • getVerticalPosition

        public final double getVerticalPosition​()
        表示BackgroundImage相对于由verticalSide属性指示的一侧的区域的位置的值。 该值是文字或百分比，具体取决于verticalAsPercentage属性。 负值是可以接受的。
        结果
        BackgroundImage的垂直位置

      • isHorizontalAsPercentage

        public final boolean isHorizontalAsPercentage​()
        指定 horizontalPosition是否应解释为文字数字或百分比。
        结果
        如果horizontalPosition应解释为百分比，则为true

      • isVerticalAsPercentage

        public final boolean isVerticalAsPercentage​()
        指定 verticalPosition是否应解释为文字数字或百分比。
        结果
        如果verticalPosition应解释为百分比，则为true

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该方法， hashCode方法必须始终返回相同的整数，前提是修改了equals对象中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在这两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


BackgroundRepeat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Enum BackgroundRepeat

  • java.lang.Object
    • java.lang.Enum<BackgroundRepeat>
      • javafx.scene.layout.BackgroundRepeat
  • All Implemented Interfaces:
    Serializable ， Comparable<BackgroundRepeat>

    public enum BackgroundRepeat
extends Enum<BackgroundRepeat>
    枚举在背景中重复图像的选项
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NO_REPEAT
      图像放置一次，不重复
      REPEAT
      根据需要经常重复图像以覆盖该区域。
      ROUND
      经常重复图像将适合该区域内。
      SPACE
      经常重复图像，以适合该区域内而不被剪裁，然后将图像间隔开以填充该区域。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static BackgroundRepeat valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static BackgroundRepeat[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • REPEAT

        public static final BackgroundRepeat REPEAT
        根据需要经常重复图像以覆盖该区域。

      • SPACE

        public static final BackgroundRepeat SPACE
        经常重复图像，以适合该区域内而不被剪裁，然后将图像间隔开以填充该区域。 第一个和最后一个图像触摸该区域的边缘。

      • ROUND

        public static final BackgroundRepeat ROUND
        经常重复图像将适合该区域内。 如果它不适合多次，它的大小减少到它。

      • NO_REPEAT

        public static final BackgroundRepeat NO_REPEAT
        图像放置一次，不重复

    • 方法详细信息

      • values

        public static BackgroundRepeat[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (BackgroundRepeat c : BackgroundRepeat.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static BackgroundRepeat valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


BackgroundSize (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class BackgroundSize

  • java.lang.Object
    • javafx.scene.layout.BackgroundSize

  • public final class BackgroundSize
extends Object
    定义BackgroundImage应该填充的区域的大小相对于其样式的Region。 有几个属性的值优先于其他属性。 特别是有4个关键属性， width ， height ， contain ，和cover 。 宽度和高度都是彼此独立的，但两者都与包含和覆盖相互作用。

    从CSS规范中， cover定义为：

    Scale the image, while preserving its intrinsic aspect ratio (if any), to the smallest size such that both its width and its height can completely cover the background positioning area.
    contain被定义为：
    Scale the image, while preserving its intrinsic aspect ratio (if any), to the largest size such that both its width and its height can fit inside the background positioning area.
    宽度和高度都指定（绝对值或百分比）要使用的大小。 这两个属性只适用于cover和contains都是false。 如果封面和包含均为真，则将使用cover 。

    宽度和高度也可以设置为AUTO ，表示该区域的大小应使用图像的本征大小，或者如果不能确定，则为100％。

    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double AUTO
      从CSS规范中：通过使用图像的内在比例和其他维度的大小，或使用图像的本征大小，或者将图像的本征大小视为100％，可以解析一个维度的“自动”值。
      static BackgroundSize DEFAULT
      当未定义显式大小时，BackgroundImages使用的默认BackgroundSize。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BackgroundSize​(double width, double height, boolean widthAsPercentage, boolean heightAsPercentage, boolean contain, boolean cover)
      创建一个新的BackgroundSize。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      double getHeight​()
      相关联的BackgroundImage应该呈现的区域内的区域的高度。
      double getWidth​()
      相关联的BackgroundImage应该呈现的区域内的区域的宽度。
      int hashCode​()
      返回对象的哈希码值。
      boolean isContain​()
      如果为真，则缩放图像，同时将其固有长宽比（如果有的话）保持为最大尺寸，使其宽度和高度都可以适合背景定位区域。
      boolean isCover​()
      如果为真，则缩放图像，同时将其固有长宽比（如果有的话）保留为最小尺寸，使其宽度和高度都可以完全覆盖背景定位区域。
      boolean isHeightAsPercentage​()
      指定 height包含的值是否应解释为百分比或正常值。
      boolean isWidthAsPercentage​()
      指定 width包含的值是否应解释为百分比或正常值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • AUTO

        public static final double AUTO
        从CSS规范：
        An "auto" value for one dimension is resolved by using the image's intrinsic ratio and the size of the other dimension, or failing that, using the image's intrinsic size, or failing that, treating it as 100%.

        If both values are "auto" then the intrinsic width and/or height of the image should be used, if any, the missing dimension (if any) behaving as "auto" as described above. If the image has neither an intrinsic width nor an intrinsic height, its size is determined as for "contain".

        当设置为AUTO时，将忽略widthAsPercentage和heightAsPercentage的值。
        另请参见：
        Constant Field Values

      • DEFAULT

        public static final BackgroundSize DEFAULT
        当未定义显式大小时，BackgroundImages使用的默认BackgroundSize。 默认情况下，BackgroundSize对于宽度和高度是AUTO，AUTO，既不覆盖也不包含。

    • 构造方法详细信息

      • BackgroundSize

        public BackgroundSize​(double width,
                      double height,
                      boolean widthAsPercentage,
                      boolean heightAsPercentage,
                      boolean contain,
                      boolean cover)
        创建一个新的BackgroundSize。
        参数
        width - 宽度。 不能小于0，除了AUTO的值。
        height - 高度。 不能小于0，除了AUTO的值。
        widthAsPercentage - 是否将宽度解释为百分比
        heightAsPercentage - 是否将高度解释为百分比
        contain - 图像的尺寸是否应该最大限度地适合该区域
        cover - 图像的大小是否应该覆盖“区域”

    • 方法详细信息

      • getWidth

        public final double getWidth​()
        相关联的BackgroundImage应该呈现的区域内的区域的宽度。 如果设置为AUTO，则忽略widthAsPercentage 。 如果指定了contain或cover则此值cover 。 该值不能为负值，除非设置为AUTO值。
        结果
        在相关联的BackgroundImage应该呈现的区域内的区域的宽度

      • getHeight

        public final double getHeight​()
        相关联的BackgroundImage应该呈现的区域内的区域的高度。 如果设置为AUTO，则忽略heightAsPercentage 。 如果指定了contain或cover则此值cover 。 该值不能为负值，除非设置为AUTO值。
        结果
        相关联的BackgroundImage应该呈现的区域内的区域的高度

      • isWidthAsPercentage

        public final boolean isWidthAsPercentage​()
        指定 width包含的值是否应解释为百分比或正常值。
        结果
        如果宽度应解释为百分比，则为true

      • isHeightAsPercentage

        public final boolean isHeightAsPercentage​()
        指定 height包含的值是否应解释为百分比或正常值。
        结果
        如果高度应解释为百分比，则为true

      • isContain

        public final boolean isContain​()
        如果为真，则缩放图像，同时将其固有长宽比（如果有的话）保持为最大尺寸，使其宽度和高度都可以适合背景定位区域。
        结果
        如果图像可以适合背景定位区域，则为true

      • isCover

        public final boolean isCover​()
        如果为真，则缩放图像，同时将其固有长宽比（如果有的话）保留为最小尺寸，使其宽度和高度都可以完全覆盖背景定位区域。
        结果
        如果图像可以完全覆盖背景定位区域，则为true

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用相同的对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每一个上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每一个上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Border (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class Border

  • java.lang.Object
    • javafx.scene.layout.Border

  • public final class Border
extends Object
    边界Region 。 边框是一个不可变的对象，它封装了渲染区域边框所需的整个数据集。 因为这个类是不可变的，你可以在许多不同的地区自由地重用同一个边框。 请参阅JavaFX CSS Reference Guide有关为区域设置边框的CSS规则的完整说明。

    每个边界由strokes和/或images组成 。 这两个列表都不会为空，但是两者都可能为空。 渲染时，如果没有指定图像，或者没有图像成功加载，则所有笔画都将按顺序呈现。 如果任何图像被指定并成功加载，则不会绘制任何笔画，尽管它们仍然会为边框的insets和outsets做出贡献。

    边界的outsets定义了一个区域的绘图区域的任何扩展，这对于所有边框绘图和定位都是必要的。 这些外观由本边界指定的BorderStroke和BorderImage定义。 Outsets是严格非负的。

    getInsets()用于定义所有边框的最内边缘。 它也始终是非负的。 该地区使用Background和边界和Region's padding的插图来确定区域insets ，该区域定义了该区域的任何儿童的内容区域。 用背景和本区域的宽度和高度的outsets在一起的边界的outsets限定的区域（这反过来又有助于的几何边界layoutBounds ， boundsInLocal ，和boundsInParent ）。

    如果您想要使用图像对区域进行蒙皮，常常使用边框，通常与9贴片缩放技术结合使用。 在这种情况下，您还可以指定仅在由于某种原因导致图像加载失败时才使用的触摸边框。

    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Border EMPTY
      空的边框，使用而不是null。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Border​(List<BorderStroke> strokes, List<BorderImage> images)
      通过提供BorderStrokes和BorderImages列表创建一个新的边框。
      Border​(BorderImage... images)
      通过提供一个BorderImages数组创建一个新的边框。
      Border​(BorderStroke... strokes)
      通过提供一个BorderStrokes数组创建一个新的边框。
      Border​(BorderStroke[] strokes, BorderImage[] images)
      通过提供一系列BorderStrokes和BorderImages创建一个新的边框。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<BorderImage> getImages​()
      BorderImages的列表，它们一起定义要使用的图像，而不是此边框的笔画。
      Insets getInsets​()
      插图定义从区域边缘到边框最里边缘的距离，如果该距离是非负的。
      Insets getOutsets​()
      边框外部定义要绘制的边框的最外边缘。
      List<BorderStroke> getStrokes​()
      BorderStrokes列表，它们一起定义了此边框的划线部分。
      int hashCode​()
      返回对象的哈希码值。
      boolean isEmpty​()
      获取边框是否为空。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • EMPTY

        public static final Border EMPTY
        空的边框，使用而不是null。

    • 构造方法详细信息

      • Border

        public Border​(BorderStroke... strokes)
        通过提供一个BorderStrokes数组创建一个新的边框。 该数组可能为空，或者可能包含空值。 任何空值将被忽略，不会对strokes或outsets或insets做出贡献。
        参数
        strokes - 笔画。 这可能为null，并且可能包含null。 任何包含的空值被过滤掉，不包括在最终的笔画列表中。 空数组变为空列表。 如果指定了笔画和图像，并且如果指定的任何一个图像成功加载，则不显示笔画。 以这种方式，在图像加载失败的情况下，笔画可以被定义为回退。

      • Border

        public Border​(BorderImage... images)
        通过提供一个BorderImages数组创建一个新的边框。 该数组可能为空，或者可能包含空值。 任何空值都将被忽略，不会对images或outsets或insets做出贡献。
        参数
        images - 图像。 这可能为null，并且可能包含null。 任何包含的空值被过滤掉，不包括在最终的图像列表中。 空数组变为空列表。

      • Border

        public Border​(List<BorderStroke> strokes,
              List<BorderImage> images)
        通过提供BorderStrokes和BorderImages列表创建一个新的边框。 这些列表可能为空，或者可能包含空值。 任何空值将被忽略，不会有助于strokes或者images ， outsets ，或insets 。
        参数
        strokes - 笔画。 这可能为null，并且可能包含null。 任何包含的空值被过滤掉，不包括在最终的笔画列表中。 空数组变为空列表。 如果指定了笔画和图像，并且如果指定的任何一个图像成功加载，则不显示笔画。 以这种方式，在图像加载失败的情况下，笔画可以被定义为回退。
        images - 图像。 这可能为null，并且可能包含null。 任何包含的空值被过滤掉，不包括在最终的图像列表中。 空数组变为空列表。

      • Border

        public Border​(BorderStroke[] strokes,
              BorderImage[] images)
        通过提供一系列BorderStrokes和BorderImages创建一个新的边框。 这些数组可能为空，或者可能包含空值。 任何空值将被忽略，不会有助于strokes或者images ， outsets ，或insets 。
        参数
        strokes - 笔画。 这可能为null，并且可能包含null。 任何包含的空值被过滤掉，不包括在最终的笔画列表中。 空数组变为空列表。 如果指定了笔画和图像，并且如果指定的任何一个图像成功加载，则不显示笔画。 以这种方式，在图像加载失败的情况下，笔画可以被定义为回退。
        images - 图像。 这可能为null，并且可能包含null。 任何包含的空值被过滤掉，不包括在最终的图像列表中。 空数组变为空列表。

    • 方法详细信息

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。

      • getStrokes

        public final List<BorderStroke> getStrokes​()
        BorderStrokes列表，它们一起定义了此边框的划线部分。 该列表是不可修改的和不可变的。 它永远不会为空。 它将永远不会包含任何null元素。
        结果
        BorderStrokes的列表，它们一起定义了该边框的抚摸部分

      • getImages

        public final List<BorderImage> getImages​()
        BorderImages的列表，它们一起定义要使用的图像，而不是此边框的笔画。 如果指定了此列表，并且其中至少有一个映像成功加载，则不会绘制任何指定的strokes 。 如果此列表为空或加载中没有图像成功，则绘制任何指定的strokes 。

        该列表是不可修改的和不可变的。 它永远不会为空。 它将永远不会包含任何null元素。

        结果
        BorderImages的列表，它们一起定义要使用的图像，而不是此边框的笔画

      • getOutsets

        public final Insets getOutsets​()
        边框外部定义要绘制的边框的最外边缘。 这些外来人物的价值观是严格非负的。
        结果
        边框的外部定义要绘制的边框的最外边缘

      • getInsets

        public final Insets getInsets​()
        插图定义从区域边缘到边框最里边缘的距离，如果该距离是非负的。 这些外来人物的价值观是严格非负的。
        结果
        插图定义了从区域边缘到边框最内边缘的距离

      • isEmpty

        public final boolean isEmpty​()
        获取边框是否为空。 如果没有笔画或图像，则为空。
        结果
        如果边框为空，则为true，否则为false。

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，当覆盖该方法时，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap所提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一个对象， hashCode方法必须始终返回相同的整数，前提是修改了equals对象中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


BorderImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class BorderImage

  • java.lang.Object
    • javafx.scene.layout.BorderImage

  • public class BorderImage
extends Object
    定义描述如何将图像呈现为某个区域的边框的属性。 BorderImage必须指定一个图像（不能为null）。 repeatX和repeatY属性定义了如何在每个方向上重复图像。 slices属性定义了如何分割图像，以便可以在区域上展开，而widths定义区域中填充边框图像的区域。 最后， outsets界定边界从边界边缘向外延伸的距离。 BorderImage的外部事件有助于边界的外界，从而有助于区域的界限。

    因为BorderImage是不可变的，它可以安全地用在任何缓存中，并且可以安全地在多个区域之间重用。

    当应用于具有定义形状的区域时，将忽略BorderImage。

    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      Image getImage​()
      要使用的图像。
      Insets getInsets​()
      BorderImage的内容定义边框相对于区域边缘的位置。
      BorderRepeat getRepeatX​()
      以什么方式（如果有的话）表示边框图像将沿着该区域的x轴重复。
      BorderRepeat getRepeatY​()
      以什么方式（如果有的话）表示边框图像将沿着该区域的y轴重复。
      BorderWidths getSlices​()
      定义图像的切片。
      BorderWidths getWidths​()
      每侧边框的宽度。
      int hashCode​()
      返回对象的哈希码值。
      boolean isFilled​()
      指定是否应绘制中心补丁（由左，右，上，下切片定义）。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BorderImage

        public BorderImage​(Image image,
                   BorderWidths widths,
                   Insets insets,
                   BorderWidths slices,
                   boolean filled,
                   BorderRepeat repeatX,
                   BorderRepeat repeatY)
        创建一个新的BorderImage。 必须指定映像或抛出NullPointerException。
        参数
        image - 要使用的图像。 这不能为空。
        widths - 每个维度中边框的宽度。 一个空值导致Insets.EMPTY。
        insets - 相对于该地区放置边框的插图。 一个空值导致Insets.EMPTY。
        slices - 图像的切片。 如果为null，则默认为BorderImageSlices.DEFAULT
        filled - 指示是否应绘制中心补丁的标志
        repeatX - x方向上边框图像的重复值。 如果为空，则默认为STRETCH。
        repeatY - y方向上边框图像的重复值。 如果为null，则默认为与repeatX相同的值。

    • 方法详细信息

      • getImage

        public final Image getImage​()
        要使用的图像。 这将永远不会为空。 如果此图像无法加载，则会在渲染时跳过整个BorderImage，并且不会对任何边界或其他计算做出贡献。
        结果
        要使用的图像

      • getRepeatX

        public final BorderRepeat getRepeatX​()
        以什么方式（如果有的话）表示边框图像将沿着该区域的x轴重复。 如果未指定，则默认值为STRETCH。
        结果
        BorderRepeat，指示边框图像是否沿着该区域的x轴重复

      • getRepeatY

        public final BorderRepeat getRepeatY​()
        以什么方式（如果有的话）表示边框图像将沿着该区域的y轴重复。 如果未指定，则默认值为STRETCH。
        结果
        BorderRepeat，指示边框图像是否沿着该区域的y轴重复

      • getWidths

        public final BorderWidths getWidths​()
        每侧边框的宽度。 这些可以被定义为绝对宽度或区域大小的百分比， BorderWidths了解更多详细信息。 如果为空，则默认为1像素宽。
        结果
        每边边框的BorderWidths

      • getSlices

        public final BorderWidths getSlices​()
        定义图像的切片。 JavaFX使用4切片方案，其中切片将图像分成9个补丁。 左上角的修补程序定义了边框的左上角。 顶部修补程序定义了顶部边框，并且构成该修补程序的图像被水平拉伸（或为repeatX定义的任何内容）以填充所有所需的空间。 右上角的修补程序在右上角，右侧的修补程序是垂直的（或任何为repeatY定义的），以填充所有必需的空间。 等等。 在每个维度中，中心补丁被拉伸（或者针对repeatX，repeatY定义）。 默认情况下，中心被省略（即：未示出），虽然一个BorderImageSlices值true为filled属性将导致要绘制的中心。 此属性的默认值将导致BorderImageSlices.DEFAULT，它是100％的边框图像片段
        结果
        定义图像切片的BorderWidths
        另请参见：
        border-image-slice

      • isFilled

        public final boolean isFilled​()
        指定是否应绘制中心补丁（由左，右，上，下切片定义）。
        结果
        如果中间补丁应该绘制，则为true

      • getInsets

        public final Insets getInsets​()
        BorderImage的内容定义边框相对于区域边缘的位置。 该值永远不会为空。
        结果
        BorderImage的插图

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖该方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        如果此对象与obj参数相同， true ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，例如由HashMap提供的那些 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每一个上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BorderPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class BorderPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.BorderPane
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class BorderPane
extends Pane
    BorderPane在上，左，右，底部和中间位置摆放孩子。

    顶部和底部的孩子将被调整到首选高度，并扩展边框的宽度。 左右孩子将被调整到其首选宽度并延长顶部和底部节点之间的长度。 并且中心节点将被调整大小以填补中间的可用空间。 任何职位都可能为空。 例：
       BorderPane borderPane = new BorderPane(); ToolBar toolbar = new ToolBar(); HBox statusbar = new HBox(); Node appContent = new AppContentNode(); borderPane.setTop(toolbar); borderPane.setCenter(appContent); borderPane.setBottom(statusbar);

    Borderpanes可能采用背景和边框风格，使用CSS。 有关详细信息，请参阅Region超类。

    BorderPane尊重其孩子的最小，首选和最大尺寸。 如果孩子的可调整范围阻止它被调整大小以适应其位置，则它将使用默认对齐方式相对于空格进行对齐，如下所示：

    • 顶部：Pos.TOP_LEFT
    • bottom：Pos.BOTTOM_LEFT
    • 左：Pos.TOP_LEFT
    • 右：POS.TOP_RIGHT
    • 中心：Pos.CENTER
    有关如何自定义这些对齐方式，请参阅“可选布局约束”。

    BorderPane将每个孩子置于五个职位，不管孩子的可见财产价值如何; 非托管儿童被忽视。

    可调整范围

    BorderPane通常用作Scene的根，在这种情况下，它的大小将跟踪场景的大小。 如果应用程序尚未直接设置场景或舞台大小，场景大小将被初始化为边框窗格的首选大小。 但是，如果边框窗格具有除场景之外的父级，则该父级将在布局期间在边框窗格的可调整范围内调整边框的大小。 默认情况下，边框窗格根据其内容计算此范围，如下表所示。

    BorderPane Resize Table width height minimum left/right insets plus width required to display right/left children at their pref widths and top/bottom/center with at least their min widths top/bottom insets plus height required to display top/bottom children at their pref heights and left/right/center with at least their min heights preferred left/right insets plus width required to display top/right/bottom/left/center children with at least their pref widths top/bottom insets plus height required to display top/right/bottom/left/center children with at least their pref heights maximum Double.MAX_VALUE Double.MAX_VALUE

    边框窗格的无界最大宽度和高度是指示父级可以将其调整大小超出其首选大小，以填充分配给它的空间。

    BorderPane提供直接设置尺寸范围的属性。 这些属性默认为哨兵值Region.USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       borderPane.setPrefSize(500,400);
    应用程序可以通过将这些属性设置回Region.USE_COMPUTED_SIZE来还原计算值。

    BorderPane在默认情况下不剪切其内容，因此如果孩子的最小大小阻止其适合其空间，儿童的边界可能会延伸到其自己的界限之外。

    可选布局限制

    应用程序可以设置对个别孩子的限制，以自定义BorderPane的布局。 对于每个约束，BorderPane提供了一种静态方法，用于在孩子上设置它。

    BorderPane Constraint Table Constraint Type Description alignment javafx.geometry.Pos The alignment of the child within its area of the border pane. margin javafx.geometry.Insets Margin space around the outside of the child.

    例：

       ListView list = new ListView(); BorderPane.setAlignment(list, Pos.TOP_LEFT); BorderPane.setMargin(list, new Insets(12,12,12,12)); borderPane.setCenter(list);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Node> bottom
      节点放置在此边框的底部边缘。
      ObjectProperty<Node> center
      节点放置在此边框窗格的中心。
      ObjectProperty<Node> left
      节点位于此边框的左边缘。
      ObjectProperty<Node> right
      放置在该边框窗格右边缘的节点。
      ObjectProperty<Node> top
      节点放置在此边框的顶部边缘。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      BorderPane​()
      创建BorderPane布局。
      BorderPane​(Node center)
      创建一个BorderPane布局，给定的Node作为BorderPane的中心。
      BorderPane​(Node center, Node top, Node right, Node bottom, Node left)
      创建BorderPane布局，其中给定的节点用于边框中每个主要布局区域。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Node> bottomProperty​()
      节点放置在此边框的底部边缘。
      ObjectProperty<Node> centerProperty​()
      节点放置在此边框窗格的中心。
      static void clearConstraints​(Node child)
      从子节点中删除所有边框窗格约束。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      static Pos getAlignment​(Node child)
      如果设置，返回小孩的对齐约束。
      Node getBottom​()
      获取属性底部的值。
      Node getCenter​()
      获取物业中心的价值。
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      Node getLeft​()
      获取剩下的属性的值。
      static Insets getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      Node getRight​()
      获取产权的价值。
      Node getTop​()
      获取属性顶部的值。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      ObjectProperty<Node> leftProperty​()
      节点位于此边框的左边缘。
      ObjectProperty<Node> rightProperty​()
      放置在该边框窗格右边缘的节点。
      static void setAlignment​(Node child, Pos value)
      设置边框窗格中包含的子对象。
      void setBottom​(Node value)
      设置属性值的底部。
      void setCenter​(Node value)
      设置物业中心的价值。
      void setLeft​(Node value)
      设置剩余属性的值。
      static void setMargin​(Node child, Insets value)
      设置由边框窗格包含的小孩的边距。
      void setRight​(Node value)
      设置属性的值。
      void setTop​(Node value)
      设置属性顶部的值。
      ObjectProperty<Node> topProperty​()
      节点放置在此边框的顶部边缘。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getClassCssMetaData, getCssMetaData, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • center

        public final ObjectProperty<Node> centerProperty
        节点放置在此边框窗格的中心。 如果可调整大小，它将被调整大小，填充顶部，底部，左侧和右侧节点之间的边框窗格的中心。 如果节点不能调整大小以填充中心空间（它不可调整大小或其最大大小阻止它），那么它将被中心对齐，除非已设置小孩的对齐约束。
        另请参见：
        getCenter() ， setCenter(Node)

      • top

        public final ObjectProperty<Node> topProperty
        节点放置在此边框的顶部边缘。 如果可调整大小，它将被调整到其首选高度，并且其宽度将跨越边框窗格的宽度。 如果节点无法调整大小以填充顶部空间（不可调整大小或其最大大小阻止它），则它将在空间中左对齐，除非已设置小孩的对齐约束。
        另请参见：
        getTop() ， setTop(Node)

      • bottom

        public final ObjectProperty<Node> bottomProperty
        节点放置在此边框的底部边缘。 如果可调整大小，它将被调整到其首选高度，并且其宽度将跨越边框窗格的宽度。 如果节点无法调整大小以填满底部空间（不可调整大小或其最大大小阻止它），那么它将在空间内左对齐，除非已设置小孩的对齐约束。
        另请参见：
        getBottom() ， setBottom(Node)

      • left

        public final ObjectProperty<Node> leftProperty
        节点位于此边框的左边缘。 如果可调整大小，它将被调整为首选宽度，它的高度将跨越顶部和底部节点之间的边框窗格的高度。 如果节点无法调整大小以填充左侧空间（不可调整大小或其最大大小阻止它），则它将在空间中左对齐，除非已设置子对齐约束。
        另请参见：
        getLeft() ， setLeft(Node)

      • right

        public final ObjectProperty<Node> rightProperty
        放置在该边框窗格右边缘的节点。 如果可调整大小，它将被调整为首选宽度，它的高度将跨越顶部和底部节点之间的边框窗格的高度。 如果节点无法调整大小以填充正确的空间（不可调整大小或其最大大小阻止它），那么它将在空间内对齐，除非已设置小孩的对齐约束。
        另请参见：
        getRight() ， setRight(Node)

    • 构造方法详细信息

      • BorderPane

        public BorderPane​()
        创建BorderPane布局。

      • BorderPane

        public BorderPane​(Node center)
        创建一个BorderPane布局，给定的Node作为BorderPane的中心。
        参数
        center - 要设置为BorderPane中心的节点。
        从以下版本开始：
        JavaFX 8.0

      • BorderPane

        public BorderPane​(Node center,
                  Node top,
                  Node right,
                  Node bottom,
                  Node left)
        创建BorderPane布局，其中给定的节点用于边框中每个主要布局区域。 顶部，右侧，底部和左侧节点按顺时针方向列出。
        参数
        center - 要设置为BorderPane中心的节点。
        top - 要设置为BorderPane顶部的节点。
        right - 要设置为BorderPane右侧的节点。
        bottom - 要设置为BorderPane底部的节点。
        left - 要设置为BorderPane左侧的节点。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setAlignment

        public static void setAlignment​(Node child,
                                Pos value)
        设置边框窗格中包含的子对象。 如果设置，将覆盖边框窗格的小孩位置的默认对齐方式。 将值设置为null将删除约束。
        参数
        child - 边框窗格的子节点
        value - 孩子的对齐位置

      • getAlignment

        public static Pos getAlignment​(Node child)
        如果设置，返回小孩的对齐约束。
        参数
        child - 边框窗格的子节点
        结果
        小孩的对齐位置，如果没有设置对齐，则为空

      • setMargin

        public static void setMargin​(Node child,
                             Insets value)
        设置由边框窗格包含的小孩的边距。 如果设置，边框窗格将其周围留有边框空间。 将值设置为null将删除约束。
        参数
        child - 边框窗格的子节点
        value - 孩子周围的空间

      • getMargin

        public static Insets getMargin​(Node child)
        如果设置，返回小孩的边距约束。
        参数
        child - 边框窗格的子节点
        结果
        小孩的保证金，如果没有设置保证金，则为null

      • clearConstraints

        public static void clearConstraints​(Node child)
        从子节点中删除所有边框窗格约束。
        参数
        child - 子节点

      • centerProperty

        public final ObjectProperty<Node> centerProperty​()
        节点放置在此边框窗格的中心。 如果可调整大小，它将被调整大小，填充顶部，底部，左侧和右侧节点之间的边框窗格的中心。 如果节点不能调整大小以填充中心空间（它不可调整大小或其最大大小阻止它），那么它将被中心对齐，除非已设置小孩的对齐约束。
        另请参见：
        getCenter() ， setCenter(Node)

      • setCenter

        public final void setCenter​(Node value)
        设置物业中心的价值。
        Property description:
        节点放置在此边框窗格的中心。 如果可调整大小，它将被调整大小，填充顶部，底部，左侧和右侧节点之间的边框窗格的中心。 如果节点不能调整大小以填充中心空间（它不可调整大小或其最大大小阻止它），那么它将被中心对齐，除非已设置小孩的对齐约束。

      • getCenter

        public final Node getCenter​()
        获取物业中心的价值。
        Property description:
        节点放置在此边框窗格的中心。 如果可调整大小，它将被调整大小，填充顶部，底部，左侧和右侧节点之间的边框窗格的中心。 如果节点不能调整大小以填充中心空间（它不可调整大小或其最大大小阻止它），那么它将被中心对齐，除非已设置小孩的对齐约束。

      • topProperty

        public final ObjectProperty<Node> topProperty​()
        节点放置在此边框的顶部边缘。 如果可调整大小，它将被调整到其首选高度，并且其宽度将跨越边框窗格的宽度。 如果节点无法调整大小以填充顶部空间（不可调整大小或其最大大小阻止它），则它将在空间中左对齐，除非已设置小孩的对齐约束。
        另请参见：
        getTop() ， setTop(Node)

      • setTop

        public final void setTop​(Node value)
        设置属性顶部的值。
        Property description:
        节点放置在此边框的顶部边缘。 如果可调整大小，它将被调整到其首选高度，并且其宽度将跨越边框窗格的宽度。 如果节点无法调整大小以填充顶部空间（不可调整大小或其最大大小阻止它），则它将在空间中左对齐，除非已设置小孩的对齐约束。

      • getTop

        public final Node getTop​()
        获取属性顶部的值。
        Property description:
        节点放置在此边框的顶部边缘。 如果可调整大小，它将被调整到其首选高度，并且其宽度将跨越边框窗格的宽度。 如果节点无法调整大小以填充顶部空间（不可调整大小或其最大大小阻止它），则它将在空间中左对齐，除非已设置小孩的对齐约束。

      • bottomProperty

        public final ObjectProperty<Node> bottomProperty​()
        节点放置在此边框的底部边缘。 如果可调整大小，它将被调整到其首选高度，并且其宽度将跨越边框窗格的宽度。 如果节点无法调整大小以填满底部空间（不可调整大小或其最大大小阻止它），那么它将在空间内左对齐，除非已设置小孩的对齐约束。
        另请参见：
        getBottom() ， setBottom(Node)

      • setBottom

        public final void setBottom​(Node value)
        设置属性值的底部。
        Property description:
        节点放置在此边框的底部边缘。 如果可调整大小，它将被调整到其首选高度，并且其宽度将跨越边框窗格的宽度。 如果节点无法调整大小以填满底部空间（不可调整大小或其最大大小阻止它），那么它将在空间内左对齐，除非已设置小孩的对齐约束。

      • getBottom

        public final Node getBottom​()
        获取属性底部的值。
        Property description:
        节点放置在此边框的底部边缘。 如果可调整大小，它将被调整到其首选高度，并且其宽度将跨越边框窗格的宽度。 如果节点无法调整大小以填满底部空间（不可调整大小或其最大大小阻止它），那么它将在空间内左对齐，除非已设置小孩的对齐约束。

      • leftProperty

        public final ObjectProperty<Node> leftProperty​()
        节点位于此边框的左边缘。 如果可调整大小，它将被调整为首选宽度，它的高度将跨越顶部和底部节点之间的边框窗格的高度。 如果节点无法调整大小以填充左侧空间（不可调整大小或其最大大小阻止它），则它将在空间中左对齐，除非已设置子对齐约束。
        另请参见：
        getLeft() ， setLeft(Node)

      • setLeft

        public final void setLeft​(Node value)
        设置剩余属性的值。
        Property description:
        节点位于此边框的左边缘。 如果可调整大小，它将被调整为首选宽度，它的高度将跨越顶部和底部节点之间的边框窗格的高度。 如果节点无法调整大小以填充左侧空间（不可调整大小或其最大大小阻止它），则它将在空间中左对齐，除非已设置子对齐约束。

      • getLeft

        public final Node getLeft​()
        获取剩下的属性的值。
        Property description:
        节点位于此边框的左边缘。 如果可调整大小，它将被调整为首选宽度，它的高度将跨越顶部和底部节点之间的边框窗格的高度。 如果节点无法调整大小以填充左侧空间（不可调整大小或其最大大小阻止它），则它将在空间中左对齐，除非已设置子对齐约束。

      • rightProperty

        public final ObjectProperty<Node> rightProperty​()
        放置在该边框窗格右边缘的节点。 如果可调整大小，它将被调整为首选宽度，它的高度将跨越顶部和底部节点之间的边框窗格的高度。 如果节点无法调整大小以填充正确的空间（不可调整大小或其最大大小阻止它），那么它将在空间内对齐，除非已设置小孩的对齐约束。
        另请参见：
        getRight() ， setRight(Node)

      • setRight

        public final void setRight​(Node value)
        设置属性的值。
        Property description:
        放置在该边框窗格右边缘的节点。 如果可调整大小，它将被调整为首选宽度，它的高度将跨越顶部和底部节点之间的边框窗格的高度。 如果节点无法调整大小以填充正确的空间（不可调整大小或其最大大小阻止它），那么它将在空间内对齐，除非已设置小孩的对齐约束。

      • getRight

        public final Node getRight​()
        获取产权的价值。
        Property description:
        放置在该边框窗格右边缘的节点。 如果可调整大小，它将被调整为首选宽度，它的高度将跨越顶部和底部节点之间的边框窗格的高度。 如果节点无法调整大小以填充正确的空间（不可调整大小或其最大大小阻止它），那么它将在空间内对齐，除非已设置小孩的对齐约束。

      • getContentBias

        public Orientation getContentBias​()
        描述从类复制： Node
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        重写：
        getContentBias在 Node
        结果
        除非中心，右，底，左或顶部有内容偏见。
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • computeMinWidth

        protected double computeMinWidth​(double height)
        描述从类别复制： Region
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        描述从类复制： Region
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        描述从类复制： Region
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        描述从类复制： Region
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果首选的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Parent
        在布局传递期间调用这个Parent的孩子进行布局。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BorderRepeat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Enum BorderRepeat

  • java.lang.Object
    • java.lang.Enum<BorderRepeat>
      • javafx.scene.layout.BorderRepeat
  • All Implemented Interfaces:
    Serializable ， Comparable<BorderRepeat>

    public enum BorderRepeat
extends Enum<BorderRepeat>
    枚举指示边框图像的重复规则。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      REPEAT
      图像被平铺（重复）填补该区域。
      ROUND
      图像被平铺（重复）并重新缩放（如果需要），以填充整个区域的区域。
      SPACE
      图像被平铺（重复）以填充整个区域的瓷砖，并且任何额外的空间分布在瓷砖周围。
      STRETCH
      图像被拉伸以填满该区域。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static BorderRepeat valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static BorderRepeat[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • STRETCH

        public static final BorderRepeat STRETCH
        图像被拉伸以填满该区域。

      • REPEAT

        public static final BorderRepeat REPEAT
        图像被平铺（重复）填补该区域。

      • ROUND

        public static final BorderRepeat ROUND
        图像被平铺（重复）并重新缩放（如果需要），以填充整个区域的区域。

      • SPACE

        public static final BorderRepeat SPACE
        图像被平铺（重复）以填充整个区域的瓷砖，并且任何额外的空间分布在瓷砖周围。

    • 方法详细信息

      • values

        public static BorderRepeat[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (BorderRepeat c : BorderRepeat.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static BorderRepeat valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


BorderStroke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class BorderStroke

  • java.lang.Object
    • javafx.scene.layout.BorderStroke

  • public class BorderStroke
extends Object
    定义用于对区域进行样式设置的边框上使用的笔画。 笔画是一个基于向量的渲染，概述了边界区域。 它可以从区域的边缘插入（或开始），并在计算区域的插值（用于定义内容区域）时考虑笔画的值。 当使用BorderImages时，笔画视觉效果不会被使用。

    当应用于具有定义形状的区域时，将使用top的边框宽度和划线信息，而其他属性将被忽略。

    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static BorderWidths DEFAULT_WIDTHS
      默认Insets与BorderStroke一起使用，否则不定义任何内容。
      static BorderWidths MEDIUM
      指定“medium”时的默认值
      static BorderWidths THICK
      指定“thick”时的默认值
      static BorderWidths THIN
      指定“thin”时的默认插入。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      Paint getBottomStroke​()
      定义此边框底部的填充。
      BorderStrokeStyle getBottomStyle​()
      定义此边框底部的样式。
      Insets getInsets​()
      定义BorderStroke的每一边的插图。
      Paint getLeftStroke​()
      定义此边框左侧的填充。
      BorderStrokeStyle getLeftStyle​()
      定义此边框左侧的样式。
      CornerRadii getRadii​()
      定义此BorderStroke的每个角落的半径。
      Paint getRightStroke​()
      定义此边框右侧的填充。
      BorderStrokeStyle getRightStyle​()
      定义此边框右侧的样式。
      Paint getTopStroke​()
      定义此边框顶部的填充。
      BorderStrokeStyle getTopStyle​()
      定义此边框顶部的样式。
      BorderWidths getWidths​()
      定义BorderStroke的每一边的厚度。
      int hashCode​()
      返回对象的哈希码值。
      boolean isStrokeUniform​()
      均匀的笔触具有相同颜色，宽度和风格的全部（顶，底，左，右）笔画

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • THIN

        public static final BorderWidths THIN
        指定“thin”时的默认插入。

      • MEDIUM

        public static final BorderWidths MEDIUM
        指定“medium”时的默认值

      • THICK

        public static final BorderWidths THICK
        指定“thick”时的默认值

      • DEFAULT_WIDTHS

        public static final BorderWidths DEFAULT_WIDTHS
        默认Insets与BorderStroke一起使用，否则不定义任何内容。

    • 构造方法详细信息

      • BorderStroke

        public BorderStroke​(Paint stroke,
                    BorderStrokeStyle style,
                    CornerRadii radii,
                    BorderWidths widths)
        创建一个新的BorderStroke。
        参数
        stroke - 用于各方的笔触。 如果为空，我们默认为Color.BLACK。
        style - 用于各方的风格。 如果为空，我们默认为BorderStrokeStyle.NONE
        radii - 要使用的半径。 如果为空，我们默认为CornerRadii.EMPTY
        widths - 要使用的宽度。 如果为空，我们默认为DEFAULT_WIDTHS

      • BorderStroke

        public BorderStroke​(Paint stroke,
                    BorderStrokeStyle style,
                    CornerRadii radii,
                    BorderWidths widths,
                    Insets insets)
        创建一个新的BorderStroke。
        参数
        stroke - 用于各方的笔触。 如果为空，我们默认为Color.BLACK。
        style - 各方面使用的风格。 如果为空，我们默认为BorderStrokeStyle.NONE
        radii - 要使用的半径。 如果为空，我们默认为CornerRadii.EMPTY
        widths - 要使用的宽度。 如果为空，我们默认为DEFAULT_WIDTHS
        insets - 表示相对于区域边缘绘制边框的插图。

      • BorderStroke

        public BorderStroke​(Paint topStroke,
                    Paint rightStroke,
                    Paint bottomStroke,
                    Paint leftStroke,
                    BorderStrokeStyle topStyle,
                    BorderStrokeStyle rightStyle,
                    BorderStrokeStyle bottomStyle,
                    BorderStrokeStyle leftStyle,
                    CornerRadii radii,
                    BorderWidths widths,
                    Insets insets)
        创建一个新的BorderStroke，指定所有构造参数。
        参数
        topStroke - 顶部使用的填充。 如果为空，则默认为黑色。
        rightStroke - 在右侧使用的填充。 如果为null，则默认为与topStroke相同的值
        bottomStroke - 底部使用的填充。 如果为null，则默认值与bottomStroke的值相同
        leftStroke - 在左边使用的填充。 如果为null，则默认为与rightStroke相同的值
        topStyle - 顶部使用的风格。 如果为null，则默认为BorderStrokeStyle.NONE
        rightStyle - 右侧使用的风格。 如果为null，则默认为与topStyle相同的值
        bottomStyle - 底部使用的风格。 如果为null，则默认为与topStyle相同的值
        leftStyle - 左侧使用的风格。 如果为null，则默认为与rightStyle相同的值
        radii - 半径。 如果为null，则使用CornerRadii.EMPTY我们默认为方角
        widths - 每边的厚度。 如果为空，我们默认为DEFAULT_WIDTHS。
        insets - 表示相对于区域边缘绘制边框的插图。

    • 方法详细信息

      • getTopStroke

        public final Paint getTopStroke​()
        定义此边框顶部的填充。
        Default value:
        黑色
        结果
        填补这边界的顶端

      • getRightStroke

        public final Paint getRightStroke​()
        定义此边框右侧的填充。 如果是null那么使用topFill。
        Default value:
        null =与topFill相同
        结果
        这边框的右边的填充

      • getBottomStroke

        public final Paint getBottomStroke​()
        定义此边框底部的填充。 如果是null那么使用topFill。
        Default value:
        null =与topFill相同
        结果
        填充这边框的底面

      • getLeftStroke

        public final Paint getLeftStroke​()
        定义此边框左侧的填充。 如果是null则使用rightFill。
        Default value:
        null = same sa rightFill
        结果
        这个边框的左边的填充

      • getTopStyle

        public final BorderStrokeStyle getTopStyle​()
        定义此边框顶部的样式。
        Default value:
        没有
        结果
        这边界的顶端风格

      • getRightStyle

        public final BorderStrokeStyle getRightStyle​()
        定义此边框右侧的样式。 如果是null则使用topStyle;
        Default value:
        null =与topStyle相同
        结果
        这边界右边的风格

      • getBottomStyle

        public final BorderStrokeStyle getBottomStyle​()
        定义此边框底部的样式。 如果是null则使用topStyle; 使用BorderStyle.NONE设置边框没有边框样式。
        Default value:
        null =与topStyle相同
        结果
        这边框底部的风格

      • getLeftStyle

        public final BorderStrokeStyle getLeftStyle​()
        定义此边框左侧的样式。 如果是null则使用rightStyle。 使用BorderStyle.NONE设置边框没有边框样式。
        Default value:
        null =与rightStyle相同
        结果
        这边界的左边的风格

      • getWidths

        public final BorderWidths getWidths​()
        定义BorderStroke的每一边的厚度。 这将永远不会为null，默认为DEFAULT_WIDTHS。
        结果
        BorderStroke的每一边的厚度

      • getInsets

        public final Insets getInsets​()
        定义BorderStroke的每一边的插图。 这将永远不会为null，默认为EMPTY。
        结果
        BorderStroke每边的插图

      • getRadii

        public final CornerRadii getRadii​()
        定义此BorderStroke的每个角落的半径。 这将永远不会为null，默认为CornerRadii.EMPTY。
        结果
        这个BorderStroke的每个角落的半径

      • isStrokeUniform

        public final boolean isStrokeUniform​()
        均匀的笔触具有相同颜色，宽度和风格的全部（顶，底，左，右）笔画
        结果
        如果边界冲程如上所述是均匀的，则为真

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        如果此对象与obj参数相同， true ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 只要在执行Java应用程序时多次在同一个对象上调用该方法，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中没有使用的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


BorderStrokeStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class BorderStrokeStyle

  • java.lang.Object
    • javafx.scene.layout.BorderStrokeStyle

  • public final class BorderStrokeStyle
extends Object
    定义在BorderStroke的一边使用的笔触风格。 有几种预定义样式，虽然这些预定义样式的属性可能与用于最终绘制它们的设置不匹配。 或者您可以创建一个新的BorderStrokeStyle并手动定义每个笔画设置，类似于任何Shape 。
    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static BorderStrokeStyle DASHED
      用于抚摸的预定义虚线图案
      static BorderStrokeStyle DOTTED
      用于抚摸的预定点缀图案
      static BorderStrokeStyle NONE
      表示不应绘制中风。
      static BorderStrokeStyle SOLID
      用于抚摸的预定义实线

    • 构造方法摘要

      构造方法
      Constructor 描述
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      List<Double> getDashArray​()
      定义表示短划线段长度的数组。
      double getDashOffset​()
      定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。
      StrokeLineCap getLineCap​()
      如此端盖风格 Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并 StrokeLineCap.SQUARE 。
      StrokeLineJoin getLineJoin​()
      定义路径段相遇时应用的装饰。
      double getMiterLimit​()
      定义 StrokeLineJoin.MITER行连接样式的限制。
      StrokeType getType​()
      定义将strokeWidth应用于形状边界的方向（内部，外部或两者）。
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NONE

        public static final BorderStrokeStyle NONE
        表示不应绘制中风。

      • DOTTED

        public static final BorderStrokeStyle DOTTED
        用于抚摸的预定点缀图案

      • DASHED

        public static final BorderStrokeStyle DASHED
        用于抚摸的预定义虚线图案

      • SOLID

        public static final BorderStrokeStyle SOLID
        用于抚摸的预定义实线

    • 构造方法详细信息

      • BorderStrokeStyle

        public BorderStrokeStyle​(StrokeType type,
                         StrokeLineJoin lineJoin,
                         StrokeLineCap lineCap,
                         double miterLimit,
                         double dashOffset,
                         List<Double> dashArray)
        创建一个新的BorderStrokeStyle。
        参数
        type - 中风的类型，无论是在边界线上呈现OUTSIDE，INSIDE还是CENTERED。 如果为空，则默认为CENTERED。
        lineJoin - 线连接。 如果为空，则默认为MITER
        lineCap - 线帽。 如果为空，则默认为BUTT。
        miterLimit - 斜角极限。 10是一个很好的默认值。
        dashOffset - dashOffset。 0是一个很好的默认值。
        dashArray - 破折号数组。 如果为空，则默认为空列表。

    • 方法详细信息

      • getType

        public final StrokeType getType​()
        定义将strokeWidth应用于形状边界的方向（内部，外部或两者）。
        Default value:
        CENTERED
        结果
        将strokeWidth应用于形状边界的方向

      • getLineJoin

        public final StrokeLineJoin getLineJoin​()
        定义路径段相遇时应用的装饰。 值必须具有以下值之一： StrokeLineJoin.BEVEL ， StrokeLineJoin.MITER ，并StrokeLineJoin.ROUND 。
        Default value:
        迈特
        结果
        道路段遇到的装饰

      • getLineCap

        public final StrokeLineCap getLineCap​()
        如此端盖风格 Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并 StrokeLineCap.SQUARE 。
        Default value:
        广场
        结果
        端帽风格

      • getMiterLimit

        public final double getMiterLimit​()
        定义 StrokeLineJoin.MITER线连接样式的限制。
        Default value:
        10
        结果
        StrokeLineJoin.MITER线连接样式的限制

      • getDashOffset

        public final double getDashOffset​()
        定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。 换句话说，虚线阶段定义了冲击模式中对应于笔画开头的点。
        Default value:
        0
        结果
        偏移到破折号的模式

      • getDashArray

        public final List<Double> getDashArray​()
        定义表示短划线段长度的数组。 数组中的备用条目表示破折号的不透明和透明段的用户空间长度。 当笔沿着要抚摸的Shape的轮廓移动时，笔的行进的用户空间距离被累积。 距离值用于索引到仪表盘阵列中。 当笔的当前累积距离映射到仪表阵列的偶数元素时，笔是不透明的，否则为透明度。 空的dashArray表示没有空格的实线。
        Default value:
        空
        结果
        该数组表示短划线段的长度

      • toString

        public String toString​()
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串“ toString代表”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如由HashMap提供的那样 。

        hashCode的总合同是：

        • 在Java应用程序执行期间，无论何时在同一个对象上多次调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


BorderWidths (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class BorderWidths

  • java.lang.Object
    • javafx.scene.layout.BorderWidths

  • public final class BorderWidths
extends Object
    定义四个组件（顶部，右侧，底部和左侧）的宽度。 每个宽度被定义为非负值。 此值可能取决于为值被解释或者作为文字值，或作为区域的宽度或高度的百分比， topAsPercentage ， rightAsPercentage ， bottomAsPercentage ， leftAsPercentage 。 顶部，右侧，底部和左侧唯一允许的负值为AUTO 。

    因为BorderWidths是不可变的，所以它可以安全地用在任何缓存中，并且可以安全地在多个区域之间重用。

    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double AUTO
      当BorderStroke使用时，AUTO的值被解释为对应的 BorderStroke.MEDIUM的值。
      static BorderWidths DEFAULT
      指定null时由BorderImage使用的默认BorderWidth。
      static BorderWidths EMPTY
      一组空的宽度，使得所有值都为0，并且是文字值。
      static BorderWidths FULL
      一组宽度，表示每边100％。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BorderWidths​(double width)
      使用所有四个边框的给定宽度创建一个新的BorderWidth，并将此宽度视为文字值，而不是百分比。
      BorderWidths​(double top, double right, double bottom, double left)
      创建一个新的BorderWidths，具有指定的顶部，右侧，底部和左侧的宽度。
      BorderWidths​(double top, double right, double bottom, double left, boolean topAsPercentage, boolean rightAsPercentage, boolean bottomAsPercentage, boolean leftAsPercentage)
      创建一个新的BorderWidths。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      double getBottom​()
      非负值（ AUTO除外 ），表示边框底部的边框厚度。
      double getLeft​()
      非负值（ AUTO除外 ），表示边框左侧的边框厚度。
      double getRight​()
      非负值（ AUTO除外 ），表示边框右侧的边框厚度。
      double getTop​()
      非负值（ AUTO除外 ），表示边框顶部的边框厚度。
      int hashCode​()
      返回对象的哈希码值。
      boolean isBottomAsPercentage​()
      指定 bottom属性是否应解释为区域高度的百分比（ true ）（ false ）。
      boolean isLeftAsPercentage​()
      指定 left属性是否应解释为区域宽度的百分比（ true ）（ false ）。
      boolean isRightAsPercentage​()
      指定 right属性是否应解释为区域宽度的百分比（ true ）（ false ）。
      boolean isTopAsPercentage​()
      指定 top属性是否应解释为区域高度的百分比（ true ）（ false ）。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • AUTO

        public static final double AUTO
        当BorderStroke使用时，AUTO的值被解释为对应的BorderStroke.MEDIUM的值。 当与BorderImage一起使用时，AUTO的值意味着从BorderStroke读取相应的值，而不是手动指定。
        另请参见：
        Constant Field Values

      • DEFAULT

        public static final BorderWidths DEFAULT
        指定null时由BorderImage使用的默认BorderWidth。 此宽度是单个1像素顶部，右侧，底部和左侧，全部解释为文字值。

      • EMPTY

        public static final BorderWidths EMPTY
        一组空的宽度，使得所有值都为0，并且是文字值。

      • FULL

        public static final BorderWidths FULL
        一组宽度，表示每边100％。

    • 构造方法详细信息

      • BorderWidths

        public BorderWidths​(double width)
        使用所有四个边框的给定宽度创建一个新的BorderWidth，并将此宽度视为文字值，而不是百分比。
        参数
        width - 边框宽度。 这不能是负面的。

      • BorderWidths

        public BorderWidths​(double top,
                    double right,
                    double bottom,
                    double left)
        创建一个新的BorderWidths，具有指定的顶部，右侧，底部和左侧的宽度。 这些值都不是负数。 这些值中的每一个都被解释为文字值，而不是百分比。
        参数
        top - 顶部边框的厚度。 必须是非负数。
        right - 右边边框的厚度。 必须是非负数。
        bottom - 底部边框的厚度。 必须是非负数。
        left - 左边边框的厚度。 必须是非负数。

      • BorderWidths

        public BorderWidths​(double top,
                    double right,
                    double bottom,
                    double left,
                    boolean topAsPercentage,
                    boolean rightAsPercentage,
                    boolean bottomAsPercentage,
                    boolean leftAsPercentage)
        创建一个新的BorderWidths。 的值的无为top ， right ， bottom ，或left可以是非负的。
        参数
        top - 顶部边框的厚度。 必须是非负数。
        right - 右边边框的厚度。 必须是非负数。
        bottom - 底部边框的厚度。 必须是非负数。
        left - 左边边框的厚度。 必须是非负数。
        topAsPercentage - 顶部是否应被视为百分比。
        rightAsPercentage - 是否将权利视为百分比。
        bottomAsPercentage - 底部是否应被视为百分比。
        leftAsPercentage - 左边是否应该被视为百分比。

    • 方法详细信息

      • getTop

        public final double getTop​()
        非负值（ AUTO除外 ），表示边框顶部的边框厚度。 该值可以是字面值，也可以根据topAsPercentage属性的值作为百分比对待。
        结果
        边框顶部的边框厚度

      • getRight

        public final double getRight​()
        非负值（ AUTO除外 ），表示边框右侧的边框厚度。 该值可以是字面值，也可以根据rightAsPercentage属性的值作为百分比对待。
        结果
        边界边界厚度在边界的右边

      • getBottom

        public final double getBottom​()
        非负值（ AUTO除外 ），表示边框底部的边框厚度。 该值可以是字面值，也可以根据bottomAsPercentage属性的值作为百分比对待。
        结果
        边框底部的边框厚度

      • getLeft

        public final double getLeft​()
        非负值（ AUTO除外 ），表示边框左侧的边框厚度。 该值可以是字面值，也可以根据leftAsPercentage属性的值作为百分比对待。
        结果
        边界左边的厚度

      • isTopAsPercentage

        public final boolean isTopAsPercentage​()
        指定 top属性是否应解释为区域高度的百分比（ true ）（ false ）。
        结果
        如果top应该被解释为区域高度的百分比，则为true，否则为false

      • isRightAsPercentage

        public final boolean isRightAsPercentage​()
        指定 right属性是否应解释为区域宽度的百分比（ true ）（ false ）。
        结果
        如果正确的话应该被解释为区域宽度的百分比，否则为false

      • isBottomAsPercentage

        public final boolean isBottomAsPercentage​()
        指定 bottom属性是否应解释为区域高度的百分比（ true ）（ false ）。
        结果
        如果底部应解释为区域高度的百分比，则为true，否则为false

      • isLeftAsPercentage

        public final boolean isLeftAsPercentage​()
        指定 left属性是否应解释为区域宽度的百分比（ true ）（ false ）。
        结果
        如果剩下的话应该被解释为区域宽度的百分比，否则为false

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，当覆盖该方法时，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode类 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ColumnConstraints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class ColumnConstraints

  • java.lang.Object
    • javafx.scene.layout.ConstraintsBase
      • javafx.scene.layout.ColumnConstraints

  • public class ColumnConstraints
extends ConstraintsBase
    为GridPane中的列定义可选布局约束。 如果在Gridpane中为列添加ColumnConstraints对象，则在计算列的宽度和布局时，网格板将使用这些约束值。

    例如，创建一个具有100个像素宽的5列的GridPane：

       GridPane gridpane = new GridPane(); for (int i = 0; i < 5; i++) { ColumnConstraints column = new ColumnConstraints(100); gridpane.getColumnConstraints().add(column); }
    或者，要创建一个GridPane，其中列占据25％，50％，25％的宽度：
       GridPane gridpane = new GridPane(); ColumnConstraints col1 = new ColumnConstraints(); col1.setPercentWidth(25); ColumnConstraints col2 = new ColumnConstraints(); col2.setPercentWidth(50); ColumnConstraints col3 = new ColumnConstraints(); col3.setPercentWidth(25); gridpane.getColumnConstraints().addAll(col1,col2,col3);
    请注意，添加一个空的ColumnConstraints对象具有不设置任何约束的作用，使GridPane仅基于其内容的大小偏好和约束来计算列的布局。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty fillWidth
      列的横向填充策略。
      ObjectProperty<HPos> halignment
      列的水平对齐。
      ObjectProperty<Priority> hgrow
      该列的横向增长优先级。
      DoubleProperty maxWidth
      列的最大宽度。
      DoubleProperty minWidth
      列的最小宽度。
      DoubleProperty percentWidth
      列的宽度百分比。
      DoubleProperty prefWidth
      列的首选宽度。

    • Field Summary

      • Fields inherited from class javafx.scene.layout.ConstraintsBase

        CONSTRAIN_TO_PREF

    • 构造方法摘要

      构造方法
      Constructor 描述
      ColumnConstraints​()
      创建一个没有设置属性的列约束对象。
      ColumnConstraints​(double width)
      创建具有固定宽度的列约束对象。
      ColumnConstraints​(double minWidth, double prefWidth, double maxWidth)
      创建具有固定大小范围的列约束对象。
      ColumnConstraints​(double minWidth, double prefWidth, double maxWidth, Priority hgrow, HPos halignment, boolean fillWidth)
      创建具有固定大小范围，水平增长优先级，水平对齐和水平填充行为的列约束对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanProperty fillWidthProperty​()
      列的横向填充策略。
      HPos getHalignment​()
      获取属性暂停的值。
      Priority getHgrow​()
      获取属性hgrow的值。
      double getMaxWidth​()
      获取属性maxWidth的值。
      double getMinWidth​()
      获取属性minWidth的值。
      double getPercentWidth​()
      获取属性percentWidth的值。
      double getPrefWidth​()
      获取属性prefWidth的值。
      ObjectProperty<HPos> halignmentProperty​()
      列的水平对齐。
      ObjectProperty<Priority> hgrowProperty​()
      该列的横向增长优先级。
      boolean isFillWidth​()
      获取属性fillWidth的值。
      DoubleProperty maxWidthProperty​()
      列的最大宽度。
      DoubleProperty minWidthProperty​()
      列的最小宽度。
      DoubleProperty percentWidthProperty​()
      列的宽度百分比。
      DoubleProperty prefWidthProperty​()
      列的首选宽度。
      void setFillWidth​(boolean value)
      设置属性fillWidth的值。
      void setHalignment​(HPos value)
      设置属性暂停的值。
      void setHgrow​(Priority value)
      设置属性hgrow的值。
      void setMaxWidth​(double value)
      设置属性maxWidth的值。
      void setMinWidth​(double value)
      设置属性minWidth的值。
      void setPercentWidth​(double value)
      设置属性percentWidth的值。
      void setPrefWidth​(double value)
      设置属性prefWidth的值。
      String toString​()
      返回此 ColumnConstraints对象的字符串表示形式。

      • Methods inherited from class javafx.scene.layout.ConstraintsBase

        requestLayout

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • minWidth

        public final DoubleProperty minWidthProperty
        列的最小宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最小宽度将被计算为列内容的最大最小宽度。

        另请参见：
        getMinWidth() ， setMinWidth(double)

      • prefWidth

        public final DoubleProperty prefWidthProperty
        列的首选宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着首选宽度将被计算为列内容的最大首选宽度。

        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • maxWidth

        public final DoubleProperty maxWidthProperty
        列的最大宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最大宽度将被计算为列内容的最小最大宽度。

        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • percentWidth

        public final DoubleProperty percentWidthProperty
        列的宽度百分比。 如果设置为大于0的值，则该列将被调整为网格窗口可用宽度的百分比，其他大小约束（minWidth，prefWidth，maxWidth，hgrow）将被忽略。 默认值为-1，表示该百分比将被忽略。
        另请参见：
        getPercentWidth() ， setPercentWidth(double)

      • hgrow

        public final ObjectProperty<Priority> hgrowProperty
        该列的横向增长优先级。 如果设置，则如果格网尺寸大于其首选宽度，则网格将使用此优先级来确定该列是否应该被赋予任何额外的宽度。 如果设置percentWidth，则忽略此属性。

        此默认值为null，这意味着列的增长优先级将从内容节点上设置的最大增长优先级派生。

        另请参见：
        getHgrow() ， setHgrow(Priority)

      • halignment

        public final ObjectProperty<HPos> halignmentProperty
        列的水平对齐。 如果设置，将是列中包含的节点的默认水平对齐方式。

        默认值为null，这意味着列对齐将返回到在gridpane上设置的默认挂起。

        另请参见：
        getHalignment() ， setHalignment(HPos)

      • fillWidth

        public final BooleanProperty fillWidthProperty
        列的横向填充策略。 网格板将使用此属性来确定列中包含的节点是否应扩展以填充列或保持为其首选宽度。

        默认值为true。

        另请参见：
        isFillWidth() ， setFillWidth(boolean)

    • 构造方法详细信息

      • ColumnConstraints

        public ColumnConstraints​()
        创建一个没有设置属性的列约束对象。

      • ColumnConstraints

        public ColumnConstraints​(double width)
        创建具有固定宽度的列约束对象。 这是为了将首选宽度约束设置为固定值，并将minWidth和maxWidth约束设置为USE_PREF_SIZE标志，以确保该列始终为该宽度。
        参数
        width - 列的宽度

      • ColumnConstraints

        public ColumnConstraints​(double minWidth,
                         double prefWidth,
                         double maxWidth)
        创建具有固定大小范围的列约束对象。 这是设置最小，优选和最大宽度限制的便利。
        参数
        minWidth - 最小宽度
        prefWidth - 首选宽度
        maxWidth - 最大宽度

      • ColumnConstraints

        public ColumnConstraints​(double minWidth,
                         double prefWidth,
                         double maxWidth,
                         Priority hgrow,
                         HPos halignment,
                         boolean fillWidth)
        创建具有固定大小范围，水平增长优先级，水平对齐和水平填充行为的列约束对象。
        参数
        minWidth - 最小宽度
        prefWidth - 首选宽度
        maxWidth - 最大宽度
        hgrow - 横向增长优先级
        halignment - 水平对齐
        fillWidth - 水平填充行为

    • 方法详细信息

      • setMinWidth

        public final void setMinWidth​(double value)
        设置属性minWidth的值。
        Property description:
        列的最小宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最小宽度将被计算为列内容的最大最小宽度。

      • getMinWidth

        public final double getMinWidth​()
        获取属性minWidth的值。
        Property description:
        列的最小宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最小宽度将被计算为列内容的最大最小宽度。

      • minWidthProperty

        public final DoubleProperty minWidthProperty​()
        列的最小宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最小宽度将被计算为列内容的最大最小宽度。

        另请参见：
        getMinWidth() ， setMinWidth(double)

      • setPrefWidth

        public final void setPrefWidth​(double value)
        设置属性prefWidth的值。
        Property description:
        列的首选宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着首选宽度将被计算为列内容的最大首选宽度。

      • getPrefWidth

        public final double getPrefWidth​()
        获取属性prefWidth的值。
        Property description:
        列的首选宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着首选宽度将被计算为列内容的最大首选宽度。

      • prefWidthProperty

        public final DoubleProperty prefWidthProperty​()
        列的首选宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着首选宽度将被计算为列内容的最大首选宽度。

        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • setMaxWidth

        public final void setMaxWidth​(double value)
        设置属性maxWidth的值。
        Property description:
        列的最大宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最大宽度将被计算为列内容的最小最大宽度。

      • getMaxWidth

        public final double getMaxWidth​()
        获取属性maxWidth的值。
        Property description:
        列的最大宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最大宽度将被计算为列内容的最小最大宽度。

      • maxWidthProperty

        public final DoubleProperty maxWidthProperty​()
        列的最大宽度。 如果设置percentWidth，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最大宽度将被计算为列内容的最小最大宽度。

        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • setPercentWidth

        public final void setPercentWidth​(double value)
        设置属性percentWidth的值。
        Property description:
        列的宽度百分比。 如果设置为大于0的值，则该列将被调整为网格窗口可用宽度的百分比，其他大小约束（minWidth，prefWidth，maxWidth，hgrow）将被忽略。 默认值为-1，表示该百分比将被忽略。

      • getPercentWidth

        public final double getPercentWidth​()
        获取属性percentWidth的值。
        Property description:
        列的宽度百分比。 如果设置为大于0的值，则该列将被调整为网格窗口可用宽度的百分比，其他大小约束（minWidth，prefWidth，maxWidth，hgrow）将被忽略。 默认值为-1，表示该百分比将被忽略。

      • percentWidthProperty

        public final DoubleProperty percentWidthProperty​()
        列的宽度百分比。 如果设置为大于0的值，则该列将被调整为网格窗口可用宽度的百分比，其他大小约束（minWidth，prefWidth，maxWidth，hgrow）将被忽略。 默认值为-1，表示该百分比将被忽略。
        另请参见：
        getPercentWidth() ， setPercentWidth(double)

      • setHgrow

        public final void setHgrow​(Priority value)
        设置属性hgrow的值。
        Property description:
        该列的横向增长优先级。 如果设置，则如果格网尺寸大于其首选宽度，则网格将使用此优先级来确定该列是否应该被赋予任何额外的宽度。 如果设置percentWidth，则忽略此属性。

        此默认值为null，这意味着列的增长优先级将从内容节点上设置的最大增长优先级派生。

      • getHgrow

        public final Priority getHgrow​()
        获取属性hgrow的值。
        Property description:
        该列的横向增长优先级。 如果设置，则如果格网尺寸大于其首选宽度，则网格将使用此优先级来确定该列是否应该被赋予任何额外的宽度。 如果设置percentWidth，则忽略此属性。

        此默认值为null，这意味着列的增长优先级将从内容节点上设置的最大增长优先级派生。

      • hgrowProperty

        public final ObjectProperty<Priority> hgrowProperty​()
        该列的横向增长优先级。 如果设置，则如果格网尺寸大于其首选宽度，则网格将使用此优先级来确定该列是否应该被赋予任何额外的宽度。 如果设置percentWidth，则忽略此属性。

        此默认值为null，这意味着列的增长优先级将从内容节点上设置的最大增长优先级派生。

        另请参见：
        getHgrow() ， setHgrow(Priority)

      • setHalignment

        public final void setHalignment​(HPos value)
        设置属性暂停的值。
        Property description:
        列的水平对齐。 如果设置，将是列中包含的节点的默认水平对齐方式。

        默认值为null，这意味着列对齐将返回到在gridpane上设置的默认挂起。

      • getHalignment

        public final HPos getHalignment​()
        获取属性暂停的值。
        Property description:
        列的水平对齐。 如果设置，将是列中包含的节点的默认水平对齐方式。

        默认值为null，这意味着列对齐将返回到在gridpane上设置的默认挂起。

      • halignmentProperty

        public final ObjectProperty<HPos> halignmentProperty​()
        列的水平对齐。 如果设置，将是列中包含的节点的默认水平对齐方式。

        默认值为null，这意味着列对齐将返回到在gridpane上设置的默认挂起。

        另请参见：
        getHalignment() ， setHalignment(HPos)

      • setFillWidth

        public final void setFillWidth​(boolean value)
        设置属性fillWidth的值。
        Property description:
        列的横向填充策略。 网格板将使用此属性来确定列中包含的节点是否应扩展以填充列或保持为其首选宽度。

        默认值为true。

      • isFillWidth

        public final boolean isFillWidth​()
        获取属性fillWidth的值。
        Property description:
        列的横向填充策略。 网格板将使用此属性来确定列中包含的节点是否应扩展以填充列或保持为其首选宽度。

        默认值为true。

      • fillWidthProperty

        public final BooleanProperty fillWidthProperty​()
        列的横向填充策略。 网格板将使用此属性来确定列中包含的节点是否应扩展以填充列或保持为其首选宽度。

        默认值为true。

        另请参见：
        isFillWidth() ， setFillWidth(boolean)

      • toString

        public String toString​()
        返回此 ColumnConstraints对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这是 ColumnConstraints对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConstraintsBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class ConstraintsBase

  • java.lang.Object
    • javafx.scene.layout.ConstraintsBase
  • 已知直接子类：
    ColumnConstraints ， RowConstraints

    public abstract class ConstraintsBase
extends Object
    用于定义节点特定布局约束的基类。 如果区域类需要定义自己的布局约束集，则区域类可以创建此类的扩展。
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double CONSTRAIN_TO_PREF
      如果设置为最大值，则表示pref值应该用作最大值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void requestLayout​()
      在与此约束对象相关联的布局父项上调用requestLayout。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • CONSTRAIN_TO_PREF

        public static final double CONSTRAIN_TO_PREF
        如果设置为最大值，则表示pref值应该用作最大值。 这允许应用程序将可调整大小的节点的大小（通常具有无限大的最大值）限制为其首选大小。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • requestLayout

        protected void requestLayout​()
        在与此约束对象相关联的布局父项上调用requestLayout。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


CornerRadii (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class CornerRadii

  • java.lang.Object
    • javafx.scene.layout.CornerRadii

  • public class CornerRadii
extends Object
    定义BorderStroke的四个角中的每一个的半径。 CornerRadii类是不可变的，因此可以在多个BorderStrokes上重用。 该类定义了8个不同的值，对应于4个四分之一椭圆的水平和垂直分量，这反过来限定了BorderStroke的拐角的曲率。
    从以下版本开始：
    JavaFX 8.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static CornerRadii EMPTY
      一个完全为空的CornerRadii，表示方角。

    • 构造方法摘要

      构造方法
      Constructor 描述
      CornerRadii​(double radius)
      为所有角落的所有组件创建一个具有单个均匀半径值的新CornerRadii。
      CornerRadii​(double radius, boolean asPercent)
      为每个角创建一个具有给定半径的新CornerRadii。
      CornerRadii​(double topLeft, double topRight, double bottomRight, double bottomLeft, boolean asPercent)
      为每个角落创建一个均匀而独立的半径的新CornerRadii。
      CornerRadii​(double topLeftHorizontalRadius, double topLeftVerticalRadius, double topRightVerticalRadius, double topRightHorizontalRadius, double bottomRightHorizontalRadius, double bottomRightVerticalRadius, double bottomLeftVerticalRadius, double bottomLeftHorizontalRadius, boolean topLeftHorizontalRadiusAsPercent, boolean topLeftVerticalRadiusAsPercent, boolean topRightVerticalRadiusAsPercent, boolean topRightHorizontalRadiusAsPercent, boolean bottomRightHorizontalRadiusAsPercent, boolean bottomRightVerticalRadiusAsPercent, boolean bottomLeftVerticalRadiusAsPercent, boolean bottomLeftHorizontalRadiusAsPercent)
      创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      double getBottomLeftHorizontalRadius​()
      左下角的水平半径的长度。
      double getBottomLeftVerticalRadius​()
      左下角的垂直半径的长度。
      double getBottomRightHorizontalRadius​()
      右下角水平半径的长度。
      double getBottomRightVerticalRadius​()
      右下角垂直半径的长度。
      double getTopLeftHorizontalRadius​()
      左上角水平半径的长度。
      double getTopLeftVerticalRadius​()
      左上角垂直半径的长度。
      double getTopRightHorizontalRadius​()
      右上角水平半径的长度。
      double getTopRightVerticalRadius​()
      右上角垂直半径的长度。
      int hashCode​()
      返回对象的哈希码值。
      boolean isBottomLeftHorizontalRadiusAsPercentage​()
      指示是否将 bottomLeftHorizontalRadius解释为值或百分比。
      boolean isBottomLeftVerticalRadiusAsPercentage​()
      指示是否将 bottomLeftVerticalRadius解释为值或百分比。
      boolean isBottomRightHorizontalRadiusAsPercentage​()
      指示是否将 bottomRightHorizontalRadius解释为值或百分比。
      boolean isBottomRightVerticalRadiusAsPercentage​()
      表示是否将 bottomRightVerticalRadius解释为值或百分比。
      boolean isTopLeftHorizontalRadiusAsPercentage​()
      指示 topLeftHorizontalRadius是否被解释为值或百分比。
      boolean isTopLeftVerticalRadiusAsPercentage​()
      表示是否将 topLeftVerticalRadius解释为值或百分比。
      boolean isTopRightHorizontalRadiusAsPercentage​()
      指示是否将 topRightHorizontalRadius解释为值或百分比。
      boolean isTopRightVerticalRadiusAsPercentage​()
      指示是否将 topRightVerticalRadius解释为值或百分比。
      boolean isUniform​()
      指示每个拐角半径是否完全相同，并且每个角半径均为基于百分比或不均匀。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • EMPTY

        public static final CornerRadii EMPTY
        一个完全为空的CornerRadii，表示方角。 这是BorderStroke的半径的默认值。

    • 构造方法详细信息

      • CornerRadii

        public CornerRadii​(double radius)
        为所有角落的所有组件创建一个具有单个均匀半径值的新CornerRadii。 此构造函数将创建CornerRadii，以使所有值都不是百分比。
        参数
        radius - 每个角落的半径。 不允许使用负值。

      • CornerRadii

        public CornerRadii​(double radius,
                   boolean asPercent)
        为每个角创建一个具有给定半径的新CornerRadii。 该值被解释为基于asPercent参数的百分比。
        参数
        radius - 每个角落的半径。 不允许使用负值。
        asPercent - 半径是否应解释为百分比。

      • CornerRadii

        public CornerRadii​(double topLeft,
                   double topRight,
                   double bottomRight,
                   double bottomLeft,
                   boolean asPercent)
        为每个角落创建一个均匀而独立的半径的新CornerRadii。 也就是说，可以独立地指定每个角，但是每个角的水平和垂直分量是均匀的。
        参数
        topLeft - 左上角的半径。 负数不允许。
        topRight - 右上角的半径。 负数不允许。
        bottomRight - 右下角的半径。 负数不允许。
        bottomLeft - bottomLeft的半径。 负数不允许。
        asPercent - 是否应将所有四个半径视为值或百分比

      • CornerRadii

        public CornerRadii​(double topLeftHorizontalRadius,
                   double topLeftVerticalRadius,
                   double topRightVerticalRadius,
                   double topRightHorizontalRadius,
                   double bottomRightHorizontalRadius,
                   double bottomRightVerticalRadius,
                   double bottomLeftVerticalRadius,
                   double bottomLeftHorizontalRadius,
                   boolean topLeftHorizontalRadiusAsPercent,
                   boolean topLeftVerticalRadiusAsPercent,
                   boolean topRightVerticalRadiusAsPercent,
                   boolean topRightHorizontalRadiusAsPercent,
                   boolean bottomRightHorizontalRadiusAsPercent,
                   boolean bottomRightVerticalRadiusAsPercent,
                   boolean bottomLeftVerticalRadiusAsPercent,
                   boolean bottomLeftHorizontalRadiusAsPercent)
        创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。
        参数
        topLeftHorizontalRadius - 左上角的水平半径的长度
        topLeftVerticalRadius - 左上角的垂直半径的长度
        topRightVerticalRadius - 右上角垂直半径的长度
        topRightHorizontalRadius - 右上角水平半径的长度
        bottomRightHorizontalRadius - 右下角水平半径的长度
        bottomRightVerticalRadius - 右下角垂直半径的长度
        bottomLeftVerticalRadius - 左下角的垂直半径的长度
        bottomLeftHorizontalRadius - 左下角的水平半径的长度
        topLeftHorizontalRadiusAsPercent - 左上角的水平半径是否为百分比
        topLeftVerticalRadiusAsPercent - 左上角的垂直半径是否为百分比
        topRightVerticalRadiusAsPercent - 右上角的垂直半径是否为百分比
        topRightHorizontalRadiusAsPercent - 右上角的水平半径是百分比
        bottomRightHorizontalRadiusAsPercent - 右下角的水平半径是百分比
        bottomRightVerticalRadiusAsPercent - 右下角的垂直半径是百分比
        bottomLeftVerticalRadiusAsPercent - bottomLeftVerticalRadiusAsPercent的垂直半径是否为百分比
        bottomLeftHorizontalRadiusAsPercent - bottomLeftHorizontalRadiusAsPercent的水平半径是百分比

    • 方法详细信息

      • getTopLeftHorizontalRadius

        public final double getTopLeftHorizontalRadius​()
        左上角水平半径的长度。
        结果
        左上角的水平半径的长度

      • getTopLeftVerticalRadius

        public final double getTopLeftVerticalRadius​()
        左上角垂直半径的长度。
        结果
        左上角垂直半径的长度

      • getTopRightVerticalRadius

        public final double getTopRightVerticalRadius​()
        右上角垂直半径的长度。
        结果
        右上角垂直半径的长度

      • getTopRightHorizontalRadius

        public final double getTopRightHorizontalRadius​()
        右上角水平半径的长度。
        结果
        右上角水平半径的长度

      • getBottomRightHorizontalRadius

        public final double getBottomRightHorizontalRadius​()
        右下角水平半径的长度。
        结果
        右下角水平半径的长度

      • getBottomRightVerticalRadius

        public final double getBottomRightVerticalRadius​()
        右下角垂直半径的长度。
        结果
        右下角垂直半径的长度

      • getBottomLeftVerticalRadius

        public final double getBottomLeftVerticalRadius​()
        左下角的垂直半径的长度。
        结果
        左下角的垂直半径的长度

      • getBottomLeftHorizontalRadius

        public final double getBottomLeftHorizontalRadius​()
        左下角的水平半径的长度。
        结果
        左下角的水平半径的长度

      • isTopLeftHorizontalRadiusAsPercentage

        public final boolean isTopLeftHorizontalRadiusAsPercentage​()
        指示是否将 topLeftHorizontalRadius解释为值或百分比。
        结果
        如果真正的topLeftHorizontalRadius是百分比，否则是一个值

      • isTopLeftVerticalRadiusAsPercentage

        public final boolean isTopLeftVerticalRadiusAsPercentage​()
        指示 topLeftVerticalRadius是否被解释为值或百分比。
        结果
        如果true topLeftVerticalRadius是百分比，否则为一个值

      • isTopRightVerticalRadiusAsPercentage

        public final boolean isTopRightVerticalRadiusAsPercentage​()
        指示是否将 topRightVerticalRadius解释为值或百分比。
        结果
        如果真正的topRightVerticalRadius是百分比，否则是一个值

      • isTopRightHorizontalRadiusAsPercentage

        public final boolean isTopRightHorizontalRadiusAsPercentage​()
        指示是否将 topRightHorizontalRadius解释为值或百分比。
        结果
        如果真正的topRightHorizontalRadius是百分比，否则是一个值

      • isBottomRightHorizontalRadiusAsPercentage

        public final boolean isBottomRightHorizontalRadiusAsPercentage​()
        指示是否将 bottomRightHorizontalRadius解释为值或百分比。
        结果
        如果true bottomRightHorizontalRadius是百分比，否则为一个值

      • isBottomRightVerticalRadiusAsPercentage

        public final boolean isBottomRightVerticalRadiusAsPercentage​()
        表示是否将 bottomRightVerticalRadius解释为值或百分比。
        结果
        如果true bottomRightVerticalRadius是百分比，否则为一个值

      • isBottomLeftVerticalRadiusAsPercentage

        public final boolean isBottomLeftVerticalRadiusAsPercentage​()
        指示是否将 bottomLeftVerticalRadius解释为值或百分比。
        结果
        如果true bottomLeftVerticalRadius是百分比，否则为一个值

      • isBottomLeftHorizontalRadiusAsPercentage

        public final boolean isBottomLeftHorizontalRadiusAsPercentage​()
        表示是否将 bottomLeftHorizontalRadius解释为值或百分比。
        结果
        如果真正的bottomLeftHorizontalRadius是百分比，否则是一个值

      • isUniform

        public final boolean isUniform​()
        指示每个拐角半径是否完全相同，并且每个角半径均为基于百分比或不均匀。
        结果
        如果真实，每个拐角半径均匀地基于百分比，否则不是

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，当覆盖该方法时，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如由HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals对比中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


FlowPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class FlowPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.FlowPane
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class FlowPane
extends Pane
    FlowPane将其孩子摆放在流过玻璃边界的流中。

    水平flowpane（默认）将以行布局节点，以flowpane的宽度包装。 一个垂直的flowpane在柱子上铺设节点，以流片的高度包裹。 如果flowpane有一个边框和/或填充集，内容将在这些插入内流动。

    FlowPane的prefWrapLength属性建立它的首选宽度（水平）或首选高度（垂直）。 如果默认值（400）不够，应用程序应设置prefWrapLength。 请注意，prefWrapLength仅用于计算首选大小，可能不会反映实际的包装尺寸，跟踪实际尺寸。

    alignment属性控制行和列如何在flowpane的范围内对齐，并且默认为Pos.TOP_LEFT。 还可以通过为垂直的水平或列对齐设置rowValignment来控制行和列中节点的对齐。

    水平流花的例子：

       Image images[] = { ... }; FlowPane flow = new FlowPane(); flow.setVgap(8); flow.setHgap(4); flow.setPrefWrapLength(300); // preferred width = 300 for (int i = 0; i < images.length; i++) { flow.getChildren().add(new ImageView(image[i]); }

    垂直风车的例子：

       FlowPane flow = new FlowPane(Orientation.VERTICAL); flow.setColumnHalignment(HPos.LEFT); // align labels on left flow.setPrefWrapLength(200); // preferred height = 200 for (int i = 0; i < titles.size(); i++) { flow.getChildren().add(new Label(titles[i]); }

    FlowPane为每个被管理的小孩提供了无论儿童的可见属性值如何; 所有布局计算都忽略非托管孩子。

    FlowPane可能使用CSS来设计背景和边框。 有关详细信息，请参阅Region超类。

    可调整范围

    Flowpane的父级将在布局期间在flowpane的可调整大小范围内调整flowpane的大小。 默认情况下，flowpane将根据下表中概述的内容计算此范围。

    Horizontal width height minimum left/right insets plus largest of children's pref widths top/bottom insets plus height required to display all children at their preferred heights when wrapped at a specified width preferred left/right insets plus prefWrapLength top/bottom insets plus height required to display all children at their pref heights when wrapped at a specified width maximum Double.MAX_VALUE Double.MAX_VALUE

    Vertical width height minimum left/right insets plus width required to display all children at their preferred widths when wrapped at a specified height top/bottom insets plus largest of children's pref heights preferred left/right insets plus width required to display all children at their pref widths when wrapped at the specified height top/bottom insets plus prefWrapLength maximum Double.MAX_VALUE Double.MAX_VALUE

    Flowpane的无界最大宽度和高度是对父母的指示，它可以调整大小超过其首选大小，以填充分配给它的任何空间。

    FlowPane提供了直接设置大小范围的属性。 这些属性默认为哨兵值Region.USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       <b>flowpane.setMaxWidth(500);</b>
    应用程序可以通过将这些属性设置回Region.USE_COMPUTED_SIZE来还原计算值。

    FlowPane在默认情况下不剪切其内容，因此如果小孩的pref大小大于空间flowpane必须为其分配的空间，则儿童边界可能会扩展到其自己的边界之外。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Pos> alignment
      Flowpane的内容在其宽度和高度之间的整体对齐。
      ObjectProperty<HPos> columnHalignment
      垂直花式板的每列内的节点的水平对齐。
      DoubleProperty hgap
      水平流图中每个节点之间的水平空间量或垂直流动叶片中的列间空间量。
      ObjectProperty<Orientation> orientation
      这个流面的方向。
      DoubleProperty prefWrapLength
      其中内容应包装在水平花式板中的优选宽度或其中内容应包装在垂直透光板中的优选高度。
      ObjectProperty<VPos> rowValignment
      水平流花线每行内的节点垂直对齐。
      DoubleProperty vgap
      垂直花式板中每个节点之间的垂直空间量或水平流动叶片中的行间距。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      FlowPane​()
      使用hgap / vgap = 0创建一个水平FlowPane布局。
      FlowPane​(double hgap, double vgap)
      使用指定的hgap / vgap创建一个水平FlowPane布局。
      FlowPane​(double hgap, double vgap, Node... children)
      使用指定的hgap / vgap创建一个水平FlowPane布局。
      FlowPane​(Orientation orientation)
      使用指定的方向创建一个FlowPane布局，并创建hgap / vgap = 0。
      FlowPane​(Orientation orientation, double hgap, double vgap)
      使用指定的方向和hgap / vgap创建FlowPane布局。
      FlowPane​(Orientation orientation, double hgap, double vgap, Node... children)
      使用指定的方向和hgap / vgap创建FlowPane布局。
      FlowPane​(Orientation orientation, Node... children)
      使用指定的方向创建一个FlowPane布局，并创建hgap / vgap = 0。
      FlowPane​(Node... children)
      使用hgap / vgap = 0创建一个水平FlowPane布局。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Pos> alignmentProperty​()
      Flowpane的内容在其宽度和高度之间的整体对齐。
      static void clearConstraints​(Node child)
      从子节点中删除所有flowpane约束。
      ObjectProperty<HPos> columnHalignmentProperty​()
      垂直花式板的每列内的节点的水平对齐。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double forWidth)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double forHeight)
      计算给定高度的该区域的首选宽度。
      Pos getAlignment​()
      获取属性对齐的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      HPos getColumnHalignment​()
      获取属性columnHalignment的值。
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      double getHgap​()
      获取属性hgap的值。
      static Insets getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      Orientation getOrientation​()
      获取属性方向的值。
      double getPrefWrapLength​()
      获取属性prefWrapLength的值。
      VPos getRowValignment​()
      获取属性rowValignment的值。
      double getVgap​()
      获取属性vgap的值。
      DoubleProperty hgapProperty​()
      水平流图中每个节点之间的水平空间量或垂直流动叶片中的列间空间量。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      ObjectProperty<Orientation> orientationProperty​()
      这个流面的方向。
      DoubleProperty prefWrapLengthProperty​()
      其中内容应包装在水平花式板中的优选宽度或其中内容应包装在垂直透光板中的优选高度。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。
      ObjectProperty<VPos> rowValignmentProperty​()
      水平流花线每行内的节点垂直对齐。
      void setAlignment​(Pos value)
      设置属性对齐的值。
      void setColumnHalignment​(HPos value)
      设置属性columnHalignment的值。
      void setHgap​(double value)
      设置属性hgap的值。
      static void setMargin​(Node child, Insets value)
      设置一个flowpane包含的孩子的边距。
      void setOrientation​(Orientation value)
      设置属性方向的值。
      void setPrefWrapLength​(double value)
      设置属性prefWrapLength的值。
      void setRowValignment​(VPos value)
      设置属性rowValignment的值。
      void setVgap​(double value)
      设置属性vgap的值。
      DoubleProperty vgapProperty​()
      垂直花式板中每个节点之间的垂直空间量或水平流动叶片中的行间距。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • orientation

        public final ObjectProperty<Orientation> orientationProperty
        这个流面的方向。 一个水平的花盆将孩子们从左到右放置在包围在流光溢出的宽度边界处。 垂直的花盆将儿童从上至下放置，以流光飞溅的高度包裹。 默认为水平。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • hgap

        public final DoubleProperty hgapProperty
        水平流图中每个节点之间的水平空间量或垂直流动叶片中的列间空间量。
        另请参见：
        getHgap() ， setHgap(double)

      • vgap

        public final DoubleProperty vgapProperty
        垂直花式板中每个节点之间的垂直空间量或水平流动叶片中的行间距。
        另请参见：
        getVgap() ， setVgap(double)

      • prefWrapLength

        public final DoubleProperty prefWrapLengthProperty
        其中内容应包装在水平花式板中的优选宽度或其中内容应包装在垂直透光板中的优选高度。

        此值仅用于计算flowpane的首选大小，并且可能不反映实际的宽度或高度，如果flowpane调整为除了其优选大小之外的其他值，则可能会发生变化。

        应用程序应初始化此值以定义用于包装内容的合理范围。

        另请参见：
        getPrefWrapLength() ， setPrefWrapLength(double)

      • alignment

        public final ObjectProperty<Pos> alignmentProperty
        Flowpane的内容在其宽度和高度之间的整体对齐。

        对于水平流动叶片，每行将使用对齐方式的hpos值在Flowpane的宽度内对齐，并且行将使用对齐方式的vpos值在flowpane的高度内对齐。

        对于垂直的flowpane，每列将使用对齐的vpos值在Flowpane的高度内对齐，并且列将使用alignment的hpos值在Flowpane的宽度内对齐。

        另请参见：
        getAlignment() ， setAlignment(Pos)

      • columnHalignment

        public final ObjectProperty<HPos> columnHalignmentProperty
        垂直花式板的每列内的节点的水平对齐。 水平流路的属性被忽略。
        另请参见：
        getColumnHalignment() ， setColumnHalignment(HPos)

      • rowValignment

        public final ObjectProperty<VPos> rowValignmentProperty
        水平流花线每行内的节点垂直对齐。 如果此属性设置为VPos.BASELINE，则flowpane将始终将小孩的大小调整为其首选高度，而不是扩展高度以填充行高。 对于垂直流路，该属性被忽略。
        另请参见：
        getRowValignment() ， setRowValignment(VPos)

    • 构造方法详细信息

      • FlowPane

        public FlowPane​()
        使用hgap / vgap = 0创建一个水平FlowPane布局。

      • FlowPane

        public FlowPane​(Orientation orientation)
        使用指定的方向创建一个FlowPane布局，并创建hgap / vgap = 0。
        参数
        orientation - 瓦片应流动和包裹的方向

      • FlowPane

        public FlowPane​(double hgap,
                double vgap)
        使用指定的hgap / vgap创建一个水平FlowPane布局。
        参数
        hgap - 每个图块之间的水平空间量
        vgap - 每个图块之间的垂直空间量

      • FlowPane

        public FlowPane​(Orientation orientation,
                double hgap,
                double vgap)
        使用指定的方向和hgap / vgap创建FlowPane布局。
        参数
        orientation - 瓦片应该流动和包裹的方向
        hgap - 每个图块之间的水平空间量
        vgap - 每个图块之间的垂直空间量

      • FlowPane

        public FlowPane​(Node... children)
        使用hgap / vgap = 0创建一个水平FlowPane布局。
        参数
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

      • FlowPane

        public FlowPane​(Orientation orientation,
                Node... children)
        使用指定的方向创建一个FlowPane布局，并创建hgap / vgap = 0。
        参数
        orientation - 瓦片应该流动和包裹的方向
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

      • FlowPane

        public FlowPane​(double hgap,
                double vgap,
                Node... children)
        使用指定的hgap / vgap创建一个水平FlowPane布局。
        参数
        hgap - 每个图块之间的水平空间量
        vgap - 每个图块之间的垂直空间量
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

      • FlowPane

        public FlowPane​(Orientation orientation,
                double hgap,
                double vgap,
                Node... children)
        使用指定的方向和hgap / vgap创建FlowPane布局。
        参数
        orientation - 瓦片应该流动和包裹的方向
        hgap - 每个图块之间的水平空间量
        vgap - 每个图块之间的垂直空间量
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setMargin

        public static void setMargin​(Node child,
                             Insets value)
        设置一个flowpane包含的孩子的边距。 如果设置，flowpane将其周围的边距空间布局。 将值设置为null将删除约束。
        参数
        child - child的子节点
        value - 孩子周围的空间

      • getMargin

        public static Insets getMargin​(Node child)
        如果设置，返回小孩的边距约束。
        参数
        child - child的子节点
        结果
        小孩的保证金，如果没有设置保证金，则为null

      • clearConstraints

        public static void clearConstraints​(Node child)
        从子节点中删除所有flowpane约束。
        参数
        child - 子节点

      • orientationProperty

        public final ObjectProperty<Orientation> orientationProperty​()
        这个流面的方向。 一个水平的花盆将孩子们从左到右放置在包围在流光溢出的宽度边界处。 垂直的花盆将儿童从上至下放置，以流光飞溅的高度包裹。 默认为水平。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • setOrientation

        public final void setOrientation​(Orientation value)
        设置属性方向的值。
        Property description:
        这个流面的方向。 一个水平的花盆将孩子们从左到右放置在包围在流光溢出的宽度边界处。 垂直的花盆将儿童从上至下放置，以流光飞溅的高度包裹。 默认为水平。

      • getOrientation

        public final Orientation getOrientation​()
        获取属性方向的值。
        Property description:
        这个流面的方向。 一个水平的花盆将孩子们从左到右放置在包围在流光溢出的宽度边界处。 垂直的花盆将儿童从上至下放置，以流光飞溅的高度包裹。 默认为水平。

      • hgapProperty

        public final DoubleProperty hgapProperty​()
        水平流图中每个节点之间的水平空间量或垂直流动叶片中的列间空间量。
        另请参见：
        getHgap() ， setHgap(double)

      • setHgap

        public final void setHgap​(double value)
        设置属性hgap的值。
        Property description:
        水平流图中每个节点之间的水平空间量或垂直流动叶片中的列间空间量。

      • getHgap

        public final double getHgap​()
        获取属性hgap的值。
        Property description:
        水平流图中每个节点之间的水平空间量或垂直流动叶片中的列间空间量。

      • vgapProperty

        public final DoubleProperty vgapProperty​()
        垂直花式板中每个节点之间的垂直空间量或水平流动叶片中的行间距。
        另请参见：
        getVgap() ， setVgap(double)

      • setVgap

        public final void setVgap​(double value)
        设置属性vgap的值。
        Property description:
        垂直花式板中每个节点之间的垂直空间量或水平流动叶片中的行间距。

      • getVgap

        public final double getVgap​()
        获取属性vgap的值。
        Property description:
        垂直花式板中每个节点之间的垂直空间量或水平流动叶片中的行间距。

      • prefWrapLengthProperty

        public final DoubleProperty prefWrapLengthProperty​()
        其中内容应包装在水平花式板中的优选宽度或其中内容应包装在垂直透光板中的优选高度。

        此值仅用于计算flowpane的首选大小，并且可能不反映实际的宽度或高度，如果flowpane调整为除了其优选大小之外的其他值，则可能会发生变化。

        应用程序应初始化此值以定义用于包装内容的合理范围。

        另请参见：
        getPrefWrapLength() ， setPrefWrapLength(double)

      • setPrefWrapLength

        public final void setPrefWrapLength​(double value)
        设置属性prefWrapLength的值。
        Property description:
        其中内容应包装在水平花式板中的优选宽度或其中内容应包装在垂直透光板中的优选高度。

        此值仅用于计算flowpane的首选大小，并且可能不反映实际的宽度或高度，如果flowpane调整为除了其优选大小之外的其他值，则可能会发生变化。

        应用程序应初始化此值以定义用于包装内容的合理范围。

      • getPrefWrapLength

        public final double getPrefWrapLength​()
        获取属性prefWrapLength的值。
        Property description:
        其中内容应包装在水平花式板中的优选宽度或其中内容应包装在垂直透光板中的优选高度。

        此值仅用于计算flowpane的首选大小，并且可能不反映实际的宽度或高度，如果flowpane调整为除了其优选大小之外的其他值，则可能会发生变化。

        应用程序应初始化此值以定义用于包装内容的合理范围。

      • alignmentProperty

        public final ObjectProperty<Pos> alignmentProperty​()
        Flowpane的内容在其宽度和高度之间的整体对齐。

        对于水平流动叶片，每行将使用对齐方式的hpos值在Flowpane的宽度内对齐，并且行将使用对齐方式的vpos值在flowpane的高度内对齐。

        对于垂直的flowpane，每列将使用对齐的vpos值在Flowpane的高度内对齐，并且列将使用alignment的hpos值在Flowpane的宽度内对齐。

        另请参见：
        getAlignment() ， setAlignment(Pos)

      • setAlignment

        public final void setAlignment​(Pos value)
        设置属性对齐的值。
        Property description:
        Flowpane的内容在其宽度和高度之间的整体对齐。

        对于水平流动叶片，每行将使用对齐方式的hpos值在Flowpane的宽度内对齐，并且行将使用对齐方式的vpos值在flowpane的高度内对齐。

        对于垂直的flowpane，每列将使用对齐的vpos值在Flowpane的高度内对齐，并且列将使用alignment的hpos值在Flowpane的宽度内对齐。

      • getAlignment

        public final Pos getAlignment​()
        获取属性对齐的值。
        Property description:
        Flowpane的内容在其宽度和高度之间的整体对齐。

        对于水平流动叶片，每行将使用对齐方式的hpos值在Flowpane的宽度内对齐，并且行将使用对齐方式的vpos值在flowpane的高度内对齐。

        对于垂直的flowpane，每列将使用对齐的vpos值在Flowpane的高度内对齐，并且列将使用alignment的hpos值在Flowpane的宽度内对齐。

      • columnHalignmentProperty

        public final ObjectProperty<HPos> columnHalignmentProperty​()
        垂直花式板的每列内的节点的水平对齐。 水平流路的属性被忽略。
        另请参见：
        getColumnHalignment() ， setColumnHalignment(HPos)

      • setColumnHalignment

        public final void setColumnHalignment​(HPos value)
        设置属性columnHalignment的值。
        Property description:
        垂直花式板的每列内的节点的水平对齐。 水平流路的属性被忽略。

      • getColumnHalignment

        public final HPos getColumnHalignment​()
        获取属性columnHalignment的值。
        Property description:
        垂直花式板的每列内的节点的水平对齐。 水平流路的属性被忽略。

      • rowValignmentProperty

        public final ObjectProperty<VPos> rowValignmentProperty​()
        水平流花线每行内的节点垂直对齐。 如果此属性设置为VPos.BASELINE，则flowpane将始终将小孩的大小调整为其首选高度，而不是扩展高度以填充行高。 对于垂直流路，该属性被忽略。
        另请参见：
        getRowValignment() ， setRowValignment(VPos)

      • setRowValignment

        public final void setRowValignment​(VPos value)
        设置属性rowValignment的值。
        Property description:
        水平流花线每行内的节点垂直对齐。 如果此属性设置为VPos.BASELINE，则flowpane将始终将小孩的大小调整为其首选高度，而不是扩展高度以填充行高。 对于垂直流路，该属性被忽略。

      • getRowValignment

        public final VPos getRowValignment​()
        获取属性rowValignment的值。
        Property description:
        水平流花线每行内的节点垂直对齐。 如果此属性设置为VPos.BASELINE，则flowpane将始终将小孩的大小调整为其首选高度，而不是扩展高度以填充行高。 对于垂直流路，该属性被忽略。

      • getContentBias

        public Orientation getContentBias​()
        描述从类复制： Node
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        重写：
        getContentBias在 Node
        结果
        width / height依赖的方向，如果没有则为null
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • computeMinWidth

        protected double computeMinWidth​(double height)
        描述从类复制： Region
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于它应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        描述从类复制： Region
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于它应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double forHeight)
        描述从类复制： Region
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        forHeight - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double forWidth)
        描述从类复制： Region
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        forWidth - 如果偏好的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • requestLayout

        public void requestLayout​()
        描述从类复制： Parent
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果此父对象是布局根或非托管，则将直接添加到场景的脏布局列表中，否则将调用requestParentLayout。

        重写：
        requestLayout在 Parent

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Parent
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GridPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class GridPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.GridPane
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class GridPane
extends Pane
    GridPane将其孩子放在一个灵活的行和列格网中。 如果设置了边框和/或填充，则其内容将被放置在这些插入内。

    孩子可以放置在网格中的任何位置，并且可以跨越多行/列。 孩子可以在行/列之间自由地重叠，并且它们的堆叠顺序将由格架子的子列表（后面的第0个节点，前面的最后一个节点）的顺序来定义。

    GridPane可能使用CSS来设计背景和边框。 有关详细信息，请参阅Region超类。

    网格限制

    网格中的小孩位置由布局约束定义：

    Grid Constraint Table Constraint Type Description columnIndex integer column where child's layout area starts. rowIndex integer row where child's layout area starts. columnSpan integer the number of columns the child's layout area spans horizontally. rowSpan integer the number of rows the child's layout area spans vertically.

    如果没有显式设置行/列索引，那么子进程将被放置在第一行/列中。 如果行/列跨度未设置，它们将默认为1.可以动态更改子对象的位置约束，并且格子窗格将相应更新。

    不需要前面指定行/列的总数，因为网格将自动展开/收缩网格以适应内容。

    要使用GridPane，应用程序需要设置子对象的布局约束，并将这些子项添加到gridpane实例中。 在GridPane类上使用静态setter方法设置限制：

       GridPane gridpane = new GridPane(); // Set one constraint at a time... // Places the button at the first row and second column Button button = new Button(); GridPane.setRowIndex(button, 0); GridPane.setColumnIndex(button, 1); // or convenience methods set more than one constraint at once... Label label = new Label(); GridPane.setConstraints(label, 2, 0); // column=2 row=0 // don't forget to add children to gridpane gridpane.getChildren().addAll(button, label);
    应用程序还可以使用方便的方法，它们结合设置约束和添加子项的步骤：
       GridPane gridpane = new GridPane(); gridpane.add(new Button(), 1, 0); // column=1 row=0 gridpane.add(new Label(), 2, 0); // column=2 row=0

    行/列尺寸

    默认情况下，行和列的大小适合其内容; 一列将足够宽以容纳最宽的小孩，一行足够高以适合最高的孩子。但是，如果应用程序需要显式控制行或列的大小，则可以通过添加RowConstraints和ColumnConstraints对象来指定那些指标。 例如，要创建一个具有两个固定宽度列的网格：
       GridPane gridpane = new GridPane(); gridpane.getColumnConstraints().add(new ColumnConstraints(100)); // column 0 is 100 wide gridpane.getColumnConstraints().add(new ColumnConstraints(200)); // column 1 is 200 wide
    默认情况下，格栅将行/列调整为其首选大小（由内容计算或固定），即使格网尺寸大于其首选大小。 如果应用程序需要特定的行或列来增长，如果有额外的空间，它可能会设置它在RowConstraints或ColumnConstraints对象上的优先级。 例如：
       GridPane gridpane = new GridPane(); ColumnConstraints column1 = new ColumnConstraints(100,100,Double.MAX_VALUE); column1.setHgrow(Priority.ALWAYS); ColumnConstraints column2 = new ColumnConstraints(100); gridpane.getColumnConstraints().addAll(column1, column2); // first column gets any extra width

    注意：跨多个行/列的节点也将与首选大小相同。 受影响的行/列按照以下优先级调整大小：增加优先级，最后一行。 这是关于行/列的约束。

    百分比大小

    或者，RowConstraints和ColumnConstraints允许将大小指定为gridpane可用空间的百分比：
       GridPane gridpane = new GridPane(); ColumnConstraints column1 = new ColumnConstraints(); column1.setPercentWidth(50); ColumnConstraints column2 = new ColumnConstraints(); column2.setPercentWidth(50); gridpane.getColumnConstraints().addAll(column1, column2); // each get 50% of width
    如果在行/列上设置了一个百分比值，那么该值将取决于先前的值，并且行/列的min，pref，max和grow约束将被忽略。

    请注意，如果widthPercent（或heightPercent）值的总和大于100，则该值将被视为权重。 例如，如果3列的宽度百分比为50，则每个列将分配格栅的可用宽度的1/3（50 /（50 + 50 + 50））。

    混合尺寸类型

    应用程序可以自由地混合行/列的大小类型（从内容，固定或百分比计算）。 根据网格空间可用空间的百分比（大小减去插页和间距），行/列百分比始终首先被分配空间。 给定其最小，优选和最大大小的剩余空间将分配给行/列，并增加优先级。

    可调整范围

    格栅图的父级将在布局期间在格栅图的可调整范围内调整格栅的大小。 默认情况下，网格窗格根据其内容和行/列约束计算此范围，如下表所示。

    GridPane Resize Table width height minimum left/right insets plus the sum of each column's min width. top/bottom insets plus the sum of each row's min height. preferred left/right insets plus the sum of each column's pref width. top/bottom insets plus the sum of each row's pref height. maximum Double.MAX_VALUE Double.MAX_VALUE

    网格板的无界最大宽度和高度是父级的指示，可以将其调整大小超出其首选大小，以填充分配给它的空间。

    GridPane提供了直接设置尺寸范围的属性。 这些属性默认为哨兵值USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       gridpane.setPrefSize(300, 300); // never size the gridpane larger than its preferred size: gridpane.setMaxSize(Region.USE_COMPUTED_SIZE, Region.USE_COMPUTED_SIZE);
    应用程序可以通过将这些属性设置回USE_COMPUTED_SIZE来恢复计算值。

    默认情况下，GridPane不会剪切其内容，因此如果孩子的最小大小阻止其适合其空间，则儿童边界可能会延伸到其自己的界限之外。

    可选布局限制

    应用程序可以设置对孩子的附加限制，以定制小孩在由行/列索引/跨度建立的布局区域内的大小和位置：

    GridPane Constraint Table Constraint Type Description halignment javafx.geometry.HPos The horizontal alignment of the child within its layout area. valignment javafx.geometry.VPos The vertical alignment of the child within its layout area. hgrow javafx.scene.layout.Priority The horizontal grow priority of the child. vgrow javafx.scene.layout.Priority The vertical grow priority of the child. margin javafx.geometry.Insets Margin space around the outside of the child.

    默认情况下，其布局区域中的子对象由行和列的对齐方法定义。 如果在子对象上设置了一个单独的对齐约束，那么该对齐方式将仅覆盖该子对象的行/列对齐方式。 同一行或列中其他子项的对齐方式不会受到影响。

    另一方面，成长优先级只能应用于整个行或列。 因此，如果在单个子项上设置成长优先级约束，则将用于计算包含行/列的默认增长优先级。 如果在RowConstraint或ColumnConstraint对象上直接设置成长优先级，则它将覆盖从内容计算的值。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Pos> alignment
      格栅在格栅宽度和高度内的对齐方式。
      BooleanProperty gridLinesVisible
      仅用于调试目的：控制是否显示行是否显示网格板的行和列。
      DoubleProperty hgap
      列之间的水平间隙的宽度。
      DoubleProperty vgap
      行之间的垂直间隙的高度。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int REMAINING
      可以在子行的行/列跨度约束上设置Sentinel值，以指示它应该跨剩余的行/列。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      GridPane​()
      使用hgap / vgap = 0和TOP_LEFT对齐创建一个GridPane布局。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      void add​(Node child, int columnIndex, int rowIndex)
      在指定的列，行位置向子窗格添加一个小孩。
      void add​(Node child, int columnIndex, int rowIndex, int colspan, int rowspan)
      在指定的列，行位置和跨度向窗格中添加一个小孩。
      void addColumn​(int columnIndex, Node... children)
      将指定节点顺序放置在网格的给定列中的便利方法。
      void addRow​(int rowIndex, Node... children)
      将指定节点顺序放置在网格的给定行中的便利方法。
      ObjectProperty<Pos> alignmentProperty​()
      格栅在格栅宽度和高度内的对齐方式。
      static void clearConstraints​(Node child)
      从子节点中删除所有网格框约束。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      Pos getAlignment​()
      获取属性对齐的值。
      Bounds getCellBounds​(int columnIndex, int rowIndex)
      返回指定列和行位置的单元格的边界。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      ObservableList<ColumnConstraints> getColumnConstraints​()
      返回列约束列表。
      int getColumnCount​()
      返回此GridPane中的列数。
      static Integer getColumnIndex​(Node child)
      如果设置，则返回小孩的列索引约束。
      static Integer getColumnSpan​(Node child)
      如果设置，则返回小孩的列跨度约束。
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      static HPos getHalignment​(Node child)
      如果设置，返回小孩的暂停约束。
      double getHgap​()
      获取属性hgap的值。
      static Priority getHgrow​(Node child)
      如果设置，返回小孩的hgrow约束。
      static Insets getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      ObservableList<RowConstraints> getRowConstraints​()
      返回行约束列表。
      int getRowCount​()
      返回此GridPane中的行数。
      static Integer getRowIndex​(Node child)
      如果设置，返回小孩的行索引约束。
      static Integer getRowSpan​(Node child)
      如果设置，返回小孩的行跨限制。
      static VPos getValignment​(Node child)
      如果设置，则返回小孩的对齐约束。
      double getVgap​()
      获取属性vgap的值。
      static Priority getVgrow​(Node child)
      如果设置，则返回小孩的vgrow约束。
      BooleanProperty gridLinesVisibleProperty​()
      仅用于调试目的：控制是否显示行是否显示网格板的行和列。
      DoubleProperty hgapProperty​()
      列之间的水平间隙的宽度。
      static Boolean isFillHeight​(Node child)
      如果设置，返回小孩的垂直填充策略
      static Boolean isFillWidth​(Node child)
      如果设置，返回小孩的横向填充策略
      boolean isGridLinesVisible​()
      获取属性gridLinesVisible的值。
      protected void layoutChildren​()
      在布局传递期间调用这个 Parent的孩子。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。
      void setAlignment​(Pos value)
      设置属性对齐的值。
      static void setColumnIndex​(Node child, Integer value)
      设置子窗格的列索引，当窗格包含时，它将从网格窗的该列开始定位。
      static void setColumnSpan​(Node child, Integer value)
      设置子窗格包含的网格窗格的列跨度，以便它横跨该列数列。
      static void setConstraints​(Node child, int columnIndex, int rowIndex)
      设置子窗格中包含的列，行排列。
      static void setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan)
      设置子网格中包含的列，列，列跨度和行跨度值。
      static void setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment)
      设置网格位置，跨度和子对齐方式。
      static void setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow)
      设置网格位置，跨度和子对齐方式。
      static void setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow, Insets margin)
      设置网格位置，跨度，对齐方式，增加优先级，以及子窗格包含在网格中时的边距。
      static void setFillHeight​(Node child, Boolean value)
      设置子窗格包含的窗格的垂直填充策略。
      static void setFillWidth​(Node child, Boolean value)
      设置子窗格的水平填充策略。
      void setGridLinesVisible​(boolean value)
      设置属性gridLinesVisible的值。
      static void setHalignment​(Node child, HPos value)
      设置子窗格的水平对齐方式。
      void setHgap​(double value)
      设置属性hgap的值。
      static void setHgrow​(Node child, Priority value)
      设置子格中包含的网格的水平增长优先级。
      static void setMargin​(Node child, Insets value)
      设置子窗格包含的格子的边距。
      static void setRowIndex​(Node child, Integer value)
      设置子窗格的行索引，当窗格包含时，它将从网格的该行开始定位。
      static void setRowSpan​(Node child, Integer value)
      设置子窗格包含的格子行的行跨度，以便它垂直跨越该行数。
      static void setValignment​(Node child, VPos value)
      设置子窗格的垂直对齐方式。
      void setVgap​(double value)
      设置属性vgap的值。
      static void setVgrow​(Node child, Priority value)
      设置子格中包含的网格的垂直成长优先级。
      String toString​()
      返回此 GridPane对象的字符串表示形式。
      DoubleProperty vgapProperty​()
      行之间的垂直间隙的高度。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • hgap

        public final DoubleProperty hgapProperty
        列之间的水平间隙的宽度。
        另请参见：
        getHgap() ， setHgap(double)

      • vgap

        public final DoubleProperty vgapProperty
        行之间的垂直间隙的高度。
        另请参见：
        getVgap() ， setVgap(double)

      • alignment

        public final ObjectProperty<Pos> alignmentProperty
        格栅在格栅宽度和高度内的对齐方式。
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • gridLinesVisible

        public final BooleanProperty gridLinesVisibleProperty
        仅用于调试目的：控制是否显示行是否显示网格板的行和列。 默认值为false 。
        另请参见：
        isGridLinesVisible() ， setGridLinesVisible(boolean)

    • 字段详细信息

      • REMAINING

        public static final int REMAINING
        可以在子行的行/列跨度约束上设置Sentinel值，以指示它应该跨剩余的行/列。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • GridPane

        public GridPane​()
        使用hgap / vgap = 0和TOP_LEFT对齐创建一个GridPane布局。

    • 方法详细信息

      • setRowIndex

        public static void setRowIndex​(Node child,
                               Integer value)
        设置子窗格的行索引，当窗格包含时，它将从网格的该行开始定位。 如果一个网格窗口小孩没有设置行索引，它将被定位在第一行。 将值设置为null将删除约束。
        参数
        child - child的子节点
        value - 小孩的行索引

      • getRowIndex

        public static Integer getRowIndex​(Node child)
        如果设置，返回小孩的行索引约束。
        参数
        child - child的子节点
        结果
        子行的行索引，如果没有设置行索引，则为null

      • setColumnIndex

        public static void setColumnIndex​(Node child,
                                  Integer value)
        设置子窗格的列索引，当窗格包含时，它将从网格窗的该列开始定位。 如果一个网格窗口小孩没有设置列索引，它将被放置在第一列中。 将值设置为null将删除约束。
        参数
        child - child的子节点
        value - 小孩的列索引

      • getColumnIndex

        public static Integer getColumnIndex​(Node child)
        如果设置，则返回小孩的列索引约束。
        参数
        child - child的子节点
        结果
        子列的列索引，如果没有设置列索引，则为null

      • setRowSpan

        public static void setRowSpan​(Node child,
                              Integer value)
        设置子窗格包含的格子行的行跨度，以便它垂直跨越该行数。 这可能设置为REMAINING，这将导致跨度延伸到所有剩余的行。

        如果网格框小孩没有设置行跨度，则它将默认跨越一行。 将值设置为null将删除约束。

        参数
        child - child的子节点
        value - 孩子的行跨度

      • getRowSpan

        public static Integer getRowSpan​(Node child)
        如果设置，返回小孩的行跨限制。
        参数
        child - child的子节点
        结果
        子行的行跨度，如果没有设置行跨度，则为null

      • setColumnSpan

        public static void setColumnSpan​(Node child,
                                 Integer value)
        设置子窗格包含的网格窗格的列跨度，以便它横跨该列数列。 这可能设置为REMAINING，这将导致跨度延伸到所有剩余的列。

        如果一个网格框子项没有设置列范围，它将默认为跨越一列。 将值设置为null将删除约束。

        参数
        child - child的子节点
        value - 小孩的列跨度

      • getColumnSpan

        public static Integer getColumnSpan​(Node child)
        如果设置，则返回小孩的列跨度约束。
        参数
        child - child的子节点
        结果
        子列的列范围，如果没有设置列跨距，则为null

      • setMargin

        public static void setMargin​(Node child,
                             Insets value)
        设置子窗格包含的格子的边距。 如果设置，格栅将其周围的边缘空间放置。 将值设置为null将删除约束。
        参数
        child - child的子节点
        value - 孩子周围的空间

      • getMargin

        public static Insets getMargin​(Node child)
        如果设置，返回小孩的边距约束。
        参数
        child - child的子节点
        结果
        小孩的保证金，如果没有设置保证金，则为null

      • setHalignment

        public static void setHalignment​(Node child,
                                 HPos value)
        设置子窗格的水平对齐方式。 如果设置，将覆盖网格板的默认水平对齐。 将值设置为null将删除约束。
        参数
        child - child的子节点
        value - 孩子的水平线对齐

      • getHalignment

        public static HPos getHalignment​(Node child)
        如果设置，返回小孩的暂停约束。
        参数
        child - child的子节点
        结果
        子项的水平对齐方式，如果未设置对齐，则为空

      • setValignment

        public static void setValignment​(Node child,
                                 VPos value)
        设置子窗格的垂直对齐方式。 如果设置，将覆盖网格板的默认垂直对齐方式。 将值设置为null将删除约束。
        参数
        child - child的子节点
        value - 孩子的垂直对齐方式

      • getValignment

        public static VPos getValignment​(Node child)
        如果设置，则返回小孩的对齐约束。
        参数
        child - child的子节点
        结果
        儿童的垂直对齐方式，如果没有设置对齐，则为空

      • setHgrow

        public static void setHgrow​(Node child,
                            Priority value)
        设置子格中包含的网格的水平增长优先级。 如果设置，如果格网尺寸大于其首选宽度，则网格将使用优先级来分配子级额外的水平空间。 将值设置为null将删除约束。
        参数
        child - child的孩子
        value - 小孩的横向成长优先级

      • getHgrow

        public static Priority getHgrow​(Node child)
        如果设置，返回小孩的hgrow约束。
        参数
        child - child的子节点
        结果
        子级的水平增长优先级，如果没有设置优先级，则为null

      • setVgrow

        public static void setVgrow​(Node child,
                            Priority value)
        设置子格中包含的网格的垂直成长优先级。 如果设置，如果网格尺寸大于其首选高度，则格栅将使用优先级来分配子级额外的垂直空间。 将值设置为null将删除约束。
        参数
        child - child的孩子
        value - 孩子的垂直成长优先级

      • getVgrow

        public static Priority getVgrow​(Node child)
        如果设置，则返回小孩的vgrow约束。
        参数
        child - child的子节点
        结果
        该小孩的垂直成长优先级，如果没有设置优先级，则为null

      • setFillWidth

        public static void setFillWidth​(Node child,
                                Boolean value)
        设置子窗格的水平填充策略。 如果设置，则网格将使用策略来确定是否应扩展节点以填充列或调整为其首选宽度。 将值设置为null将删除约束。 如果没有为节点或列指定值，则默认值为true。
        参数
        child - child的子节点
        value - 水平填充策略或未设置的null
        从以下版本开始：
        JavaFX 8.0

      • isFillWidth

        public static Boolean isFillWidth​(Node child)
        如果设置，返回小孩的横向填充策略
        参数
        child - child的子节点
        结果
        小孩的横向填充策略，如果没有设置策略，则为null
        从以下版本开始：
        JavaFX 8.0

      • setFillHeight

        public static void setFillHeight​(Node child,
                                 Boolean value)
        设置子窗格包含的窗格的垂直填充策略。 如果设置，格栅将使用策略来确定是否应扩展节点以填充行或调整为其首选高度。 将值设置为null将删除约束。 如果没有为节点或行指定值，则默认值为true。
        参数
        child - child的子节点
        value - 垂直填充策略或未设置的null
        从以下版本开始：
        JavaFX 8.0

      • isFillHeight

        public static Boolean isFillHeight​(Node child)
        如果设置，返回小孩的垂直填充策略
        参数
        child - child的子节点
        结果
        子项的垂直填充策略，如果没有设置策略，则为null
        从以下版本开始：
        JavaFX 8.0

      • setConstraints

        public static void setConstraints​(Node child,
                                  int columnIndex,
                                  int rowIndex)
        设置子窗格中包含的列，行排列。
        参数
        child - child的子节点
        columnIndex - 小孩的列索引位置
        rowIndex - 小孩的行索引位置

      • setConstraints

        public static void setConstraints​(Node child,
                                  int columnIndex,
                                  int rowIndex,
                                  int columnspan,
                                  int rowspan)
        设置子网格中包含的列，列，列跨度和行跨度值。
        参数
        child - child的子节点
        columnIndex - 小孩的列索引位置
        rowIndex - 小孩的行索引位置
        columnspan - 小孩应跨越的列数
        rowspan - 孩子应该跨越的行数

      • setConstraints

        public static void setConstraints​(Node child,
                                  int columnIndex,
                                  int rowIndex,
                                  int columnspan,
                                  int rowspan,
                                  HPos halignment,
                                  VPos valignment)
        设置网格位置，跨度和子对齐方式。
        参数
        child - child的子节点
        columnIndex - 小孩的列索引位置
        rowIndex - 小孩的行索引位置
        columnspan - 孩子应跨越的列数
        rowspan - 孩子应该跨越的行数
        halignment - 孩子的水平对齐
        valignment - 孩子的垂直对齐

      • setConstraints

        public static void setConstraints​(Node child,
                                  int columnIndex,
                                  int rowIndex,
                                  int columnspan,
                                  int rowspan,
                                  HPos halignment,
                                  VPos valignment,
                                  Priority hgrow,
                                  Priority vgrow)
        设置网格位置，跨度和子对齐方式。
        参数
        child - child的子节点
        columnIndex - 小孩的列索引位置
        rowIndex - 小孩的行索引位置
        columnspan - 小孩应跨越的列数
        rowspan - 孩子应该跨越的行数
        halignment - 孩子的水平对齐
        valignment - 孩子的垂直对齐
        hgrow - 小孩的横向成长优先级
        vgrow - 小孩的垂直成长优先级

      • setConstraints

        public static void setConstraints​(Node child,
                                  int columnIndex,
                                  int rowIndex,
                                  int columnspan,
                                  int rowspan,
                                  HPos halignment,
                                  VPos valignment,
                                  Priority hgrow,
                                  Priority vgrow,
                                  Insets margin)
        设置网格位置，跨度，对齐方式，增加优先级，以及子窗格包含在网格中时的边距。
        参数
        child - child的子节点
        columnIndex - 小孩的列索引位置
        rowIndex - 小孩的行索引位置
        columnspan - 孩子应跨越的列数
        rowspan - 孩子应该跨越的行数
        halignment - 孩子的水平对齐
        valignment - 孩子的垂直对齐
        hgrow - 小孩的横向成长优先级
        vgrow - 孩子的垂直成长优先级
        margin - 孩子周围的空间

      • clearConstraints

        public static void clearConstraints​(Node child)
        从子节点中删除所有网格框约束。
        参数
        child - 子节点

      • hgapProperty

        public final DoubleProperty hgapProperty​()
        列之间的水平间隙的宽度。
        另请参见：
        getHgap() ， setHgap(double)

      • setHgap

        public final void setHgap​(double value)
        设置属性hgap的值。
        Property description:
        列之间的水平间隙的宽度。

      • getHgap

        public final double getHgap​()
        获取属性hgap的值。
        Property description:
        列之间的水平间隙的宽度。

      • vgapProperty

        public final DoubleProperty vgapProperty​()
        行之间的垂直间隙的高度。
        另请参见：
        getVgap() ， setVgap(double)

      • setVgap

        public final void setVgap​(double value)
        设置属性vgap的值。
        Property description:
        行之间的垂直间隙的高度。

      • getVgap

        public final double getVgap​()
        获取属性vgap的值。
        Property description:
        行之间的垂直间隙的高度。

      • alignmentProperty

        public final ObjectProperty<Pos> alignmentProperty​()
        格栅在格栅宽度和高度内的对齐方式。
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • setAlignment

        public final void setAlignment​(Pos value)
        设置属性对齐的值。
        Property description:
        格栅在格栅宽度和高度内的对齐方式。

      • getAlignment

        public final Pos getAlignment​()
        获取属性对齐的值。
        Property description:
        格栅在格栅宽度和高度内的对齐方式。

      • gridLinesVisibleProperty

        public final BooleanProperty gridLinesVisibleProperty​()
        仅用于调试目的：控制是否显示行是否显示网格板的行和列。 默认值为false 。
        另请参见：
        isGridLinesVisible() ， setGridLinesVisible(boolean)

      • setGridLinesVisible

        public final void setGridLinesVisible​(boolean value)
        设置属性gridLinesVisible的值。
        Property description:
        仅用于调试目的：控制是否显示行是否显示网格板的行和列。 默认值为false 。

      • isGridLinesVisible

        public final boolean isGridLinesVisible​()
        获取属性gridLinesVisible的值。
        Property description:
        仅用于调试目的：控制是否显示行是否显示网格板的行和列。 默认值为false 。

      • getRowConstraints

        public final ObservableList<RowConstraints> getRowConstraints​()
        返回行约束列表。 可以添加行约束以显式控制单个行大小和布局行为。 如果未设置，则基于内容计算行大小和布局行为。 ObservableList中的索引表示行号，因此第一行的行约束位于0的位置。
        结果
        行约束列表

      • getColumnConstraints

        public final ObservableList<ColumnConstraints> getColumnConstraints​()
        返回列约束列表。 可以添加列约束以显式控制各个列的大小和布局行为。 如果未设置，则基于内容计算列大小和布局行为。 ObservableList中的索引表示列号，因此第一列的列约束位于0。
        结果
        列约束列表

      • add

        public void add​(Node child,
                int columnIndex,
                int rowIndex)
        在指定的列，行位置向子窗格添加一个小孩。 这种方便的方法将设置子窗格中的网格列和行约束。
        参数
        child - 节点正被添加到 child
        columnIndex - columnIndex内小孩的列索引位置，从0开始计数
        rowIndex - rowIndex内小孩的行索引位置，从0开始计数

      • add

        public void add​(Node child,
                int columnIndex,
                int rowIndex,
                int colspan,
                int rowspan)
        在指定的列，行位置和跨度向窗格中添加一个小孩。 这种方便的方法将设置孩子的网格列，行和跨度约束。
        参数
        child - 要添加到 child的节点
        columnIndex - columnIndex内小孩的列索引位置，从0开始计数
        rowIndex - rowIndex内小孩的行索引位置，从0开始计数
        colspan - 孩子的布局区域应该跨越的列数
        rowspan - 孩子的布局区域应该跨越的行数

      • addRow

        public void addRow​(int rowIndex,
                   Node... children)
        将指定节点顺序放置在网格的给定行中的便利方法。 如果行已经包含节点，则指定的节点将被附加到该行。 例如，第一个节点将位于[列，行]，第二个位于[列+ 1，行]等。此方法将在节点上设置适当的网格列/列约束，并将节点添加到格栅的孩子序列。
        参数
        rowIndex - rowIndex内的子项的行索引位置
        children - 要在网格中添加为一行的节点

      • addColumn

        public void addColumn​(int columnIndex,
                      Node... children)
        将指定节点顺序放置在网格的给定列中的便利方法。 如果列已经包含节点，则指定的节点将附加到列。 例如，第一个节点将位于[列，行]，第二个位于[列，行+ 1]等。此方法将在节点上设置适当的网格列/列约束，并将节点添加到格栅的孩子序列。
        参数
        columnIndex - columnIndex的列索引位置
        children - 要在网格中添加为列的节点

      • computeMinWidth

        protected double computeMinWidth​(double height)
        描述从类复制： Region
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        描述从类复制： Region
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        描述从类复制： Region
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        描述从类复制： Region
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • getContentBias

        public Orientation getContentBias​()
        描述从类： Node复制
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        重写：
        getContentBias在 Node
        结果
        除非其一个孩子有内容偏见，否则为null。
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • requestLayout

        public void requestLayout​()
        描述从类复制： Parent
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果此父对象是布局根或非托管，则将直接添加到场景的脏布局列表中，否则将调用requestParentLayout。

        重写：
        requestLayout在 Parent

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Parent
        在布局传递过程中调用这个Parent的孩子进行布局。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • toString

        public String toString​()
        返回此 GridPane对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这是一个 GridPane对象的字符串表示形式。

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getRowCount

        public final int getRowCount​()
        返回此GridPane中的行数。
        结果
        行数
        从以下版本开始：
        9

      • getColumnCount

        public final int getColumnCount​()
        返回此GridPane中的列数。
        结果
        列数
        从以下版本开始：
        9

      • getCellBounds

        public final Bounds getCellBounds​(int columnIndex,
                                  int rowIndex)
        返回指定列和行位置的单元格的边界。
        参数
        columnIndex - 此GridPane中单元格的列索引位置，从0开始计数
        rowIndex - 此GridPane中单元格的行索引位置，从0开始计数
        结果
        columnIndex和rowIndex上的单元格的边界。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


HBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class HBox

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.HBox
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class HBox
extends Pane
    HBox将孩子放在一排水平排列中。 如果hbox有一个边框和/或填充集合，那么这些内容将被放置在这些插入内。

    HBox示例：

       HBox hbox = new HBox(8); // spacing = 8 hbox.getChildren().addAll(new Label("Name:), new TextBox());
    HBox将调整小孩的大小（如果可调整大小）到其首选宽度，并使用其fillHeight属性来确定是否调整其高度大小以填充自己的高度或将其高度保持为首选（fillHeight默认为true）。 内容的对齐由对齐属性控制，默认为Pos.TOP_LEFT。

    如果一个hbox被调整大于其首选宽度，默认情况下，它将保持孩子的首选宽度，留下额外的空间。 如果一个应用程序希望有一个或多个孩子被分配到额外的空间，那么它可以可选地为孩子设置一个限制。 有关详细信息，请参阅“可选布局约束”。

    无论孩子的可见财产价值如何，HBox都会列出每个被管理的孩子; 非托管儿童被忽视。

    可调整范围

    hbox的父母将在布局期间调整hbox可调整大小范围内的hbox。 默认情况下，hbox根据其内容计算该范围，如下表所示。

    HBox Resize Table width height minimum left/right insets plus the sum of each child's min width plus spacing between each child. top/bottom insets plus the largest of the children's min heights. preferred left/right insets plus the sum of each child's pref width plus spacing between each child. top/bottom insets plus the largest of the children's pref heights. maximum Double.MAX_VALUE Double.MAX_VALUE

    hbox的无界最大宽度和高度表示父级可以将其调整大小超出其首选大小，以填充分配给它的空间。

    HBox提供直接设置尺寸范围的属性。 这些属性默认为哨兵值USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       hbox.setPrefWidth(400);
    应用程序可以通过将这些属性设置回USE_COMPUTED_SIZE来恢复计算值。

    HBox在默认情况下不剪切其内容，因此如果孩子的最小大小阻止其在hbox中的适合，儿童的边界可能会延伸到自己的界限之外。

    可选布局限制

    应用程序可能会对个别孩子设置约束，以定制HBox的布局。 对于每个约束，HBox提供了一种用于在孩子上设置它的静态方法。

    HBox Constraint Table Constraint Type Description hgrow javafx.scene.layout.Priority The horizontal grow priority for the child. margin javafx.geometry.Insets Margin space around the outside of the child.

    例如，如果hbox需要将TextField分配给所有额外的空间：

       HBox hbox = new HBox(); TextField field = new TextField(); HBox.setHgrow(field, Priority.ALWAYS); hbox.getChildren().addAll(new Label("Search:"), field, new Button("Go"));
    如果多个孩子具有相同的成长优先级设置，那么hbox将为每个孩子分配等量的空间。 HBox只能使一个孩子达到最大宽度，所以如果孩子的最大宽度不是Double.MAX_VALUE，应用程序可能需要重写max才能使其增长。 例如：
       HBox hbox = new HBox(); Button button1 = new Button("Add"); Button button2 = new Button("Remove"); HBox.setHgrow(button1, Priority.ALWAYS); HBox.setHgrow(button2, Priority.ALWAYS); button1.setMaxWidth(Double.MAX_VALUE); button2.setMaxWidth(Double.MAX_VALUE); hbox.getChildren().addAll(button1, button2);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Pos> alignment
      孩子们在hbox的宽度和高度之间的整体对齐。
      BooleanProperty fillHeight
      是否调整大小的小孩将被调整大小以填充hbox的全部高度，或者调整大小至其首选高度，并根据 alignment vpos值对齐。
      DoubleProperty spacing
      hbox中每个孩子之间的水平空间量。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      HBox​()
      创建一个间距= 0的HBox布局。
      HBox​(double spacing)
      创建一个具有指定间隔的HBox布局。
      HBox​(double spacing, Node... children)
      创建一个具有指定间隔的HBox布局。
      HBox​(Node... children)
      创建一个间距= 0的HBox布局。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Pos> alignmentProperty​()
      孩子们在hbox的宽度和高度之间的整体对齐。
      static void clearConstraints​(Node child)
      从子节点中删除所有hbox约束。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      BooleanProperty fillHeightProperty​()
      是否调整大小的小孩将被调整大小以填补hbox的全部高度，或者调整大小到其首选高度，并根据 alignment vpos值对齐。
      Pos getAlignment​()
      获取属性对齐的值。
      double getBaselineOffset​()
      基于第一个受管理的子节点计算基线偏移量。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      static Priority getHgrow​(Node child)
      如果设置，返回小孩的hgrow约束。
      static Insets getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      double getSpacing​()
      获取属性间距的值。
      boolean isFillHeight​()
      获取属性fillHeight的值。
      protected void layoutChildren​()
      在布局传递期间调用这个 Parent的孩子。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。
      void setAlignment​(Pos value)
      设置属性对齐的值。
      void setFillHeight​(boolean value)
      设置属性fillHeight的值。
      static void setHgrow​(Node child, Priority value)
      设置由hbox包含的小孩的横向增长优先级。
      static void setMargin​(Node child, Insets value)
      设置hbox包含的小孩的边距。
      void setSpacing​(double value)
      设置属性间距的值。
      DoubleProperty spacingProperty​()
      hbox中每个孩子之间的水平空间量。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • spacing

        public final DoubleProperty spacingProperty
        hbox中每个孩子之间的水平空间量。
        另请参见：
        getSpacing() ， setSpacing(double)

      • alignment

        public final ObjectProperty<Pos> alignmentProperty
        孩子们在hbox的宽度和高度之间的整体对齐。
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • fillHeight

        public final BooleanProperty fillHeightProperty
        是否调整大小的小孩将被调整大小以填补hbox的全部高度，或者调整大小到其首选高度，并根据alignment vpos值对齐。 请注意，如果hbox垂直对齐方式设置为“基线”，则此属性将被忽略，并且子项将被调整为其首选高度。
        另请参见：
        isFillHeight() ， setFillHeight(boolean)

    • 构造方法详细信息

      • HBox

        public HBox​()
        创建一个间距= 0的HBox布局。

      • HBox

        public HBox​(double spacing)
        创建一个具有指定间隔的HBox布局。
        参数
        spacing - 每个孩子之间的水平空间量

      • HBox

        public HBox​(Node... children)
        创建一个间距= 0的HBox布局。
        参数
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

      • HBox

        public HBox​(double spacing,
            Node... children)
        创建一个具有指定间隔的HBox布局。
        参数
        spacing - 每个孩子之间的水平空间量
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setHgrow

        public static void setHgrow​(Node child,
                            Priority value)
        设置由hbox包含的小孩的横向增长优先级。 如果设置，如果hbox被调整大于其首选宽度，则hbox将使用优先级来分配额外的空间。 如果多个hbox儿童具有相同的横向增长优先级，那么它们之间的间隔时间将会相同。 如果孩子没有设置水平增长优先级，则hbox将永远不会为其分配额外的水平空间（如果可用）。 将值设置为null将删除约束。
        参数
        child - 一个hbox的孩子
        value - 小孩的横向成长优先级

      • getHgrow

        public static Priority getHgrow​(Node child)
        如果设置，返回小孩的hgrow约束。
        参数
        child - hbox的子节点
        结果
        子级的水平增长优先级，如果没有设置优先级，则为null

      • setMargin

        public static void setMargin​(Node child,
                             Insets value)
        设置hbox包含的小孩的边距。 如果设置，hbox将布局孩子周围的边距空间。 将值设置为null将删除约束。
        参数
        child - hbox的子模式
        value - 孩子周围的空间

      • getMargin

        public static Insets getMargin​(Node child)
        如果设置，返回小孩的边距约束。
        参数
        child - hbox的子节点
        结果
        小孩的保证金，如果没有设置保证金，则为null

      • clearConstraints

        public static void clearConstraints​(Node child)
        从子节点中删除所有hbox约束。
        参数
        child - 子节点

      • spacingProperty

        public final DoubleProperty spacingProperty​()
        hbox中每个孩子之间的水平空间量。
        另请参见：
        getSpacing() ， setSpacing(double)

      • setSpacing

        public final void setSpacing​(double value)
        设置属性间距的值。
        Property description:
        hbox中每个孩子之间的水平空间量。

      • getSpacing

        public final double getSpacing​()
        获取属性间距的值。
        Property description:
        hbox中每个孩子之间的水平空间量。

      • alignmentProperty

        public final ObjectProperty<Pos> alignmentProperty​()
        孩子们在hbox的宽度和高度之间的整体对齐。
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • setAlignment

        public final void setAlignment​(Pos value)
        设置属性对齐的值。
        Property description:
        孩子们在hbox的宽度和高度之间的整体对齐。

      • getAlignment

        public final Pos getAlignment​()
        获取属性对齐的值。
        Property description:
        孩子们在hbox的宽度和高度之间的整体对齐。

      • fillHeightProperty

        public final BooleanProperty fillHeightProperty​()
        是否调整大小的小孩将被调整大小以填充hbox的全部高度，或者调整大小至其首选高度，并根据alignment vpos值对齐。 请注意，如果hbox垂直对齐方式设置为“基线”，则此属性将被忽略，并且子项将被调整为其首选高度。
        另请参见：
        isFillHeight() ， setFillHeight(boolean)

      • setFillHeight

        public final void setFillHeight​(boolean value)
        设置属性fillHeight的值。
        Property description:
        无论是否可调整大小的孩子将被调整，以填补横向盒的整个高度或根据被调整到其首选高度和排列alignment VPOS值。 请注意，如果hbox垂直对齐方式设置为“基线”，则此属性将被忽略，并且子项将被调整为其首选高度。

      • isFillHeight

        public final boolean isFillHeight​()
        获取属性fillHeight的值。
        Property description:
        无论是否可调整大小的孩子将被调整，以填补横向盒的整个高度或根据被调整到其首选高度和排列alignment VPOS值。 请注意，如果hbox垂直对齐方式设置为“基线”，则此属性将被忽略，并且子项将被调整为其首选高度。

      • getContentBias

        public Orientation getContentBias​()
        描述从类复制： Node
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        重写：
        getContentBias在 Node
        结果
        除非其一个孩子有内容偏见，否则为null。
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • computeMinWidth

        protected double computeMinWidth​(double height)
        描述从类复制： Region
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        描述从类别复制Region
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        描述从类复制： Region
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        描述从类复制： Region
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果首选高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • requestLayout

        public void requestLayout​()
        描述从类复制： Parent
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果此父对象是布局根或非托管，则将直接添加到场景的脏布局列表中，否则将调用requestParentLayout。

        重写：
        requestLayout在 Parent

      • getBaselineOffset

        public double getBaselineOffset​()
        描述从类复制： Parent
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        getBaselineOffset在 Parent
        结果
        基线偏移

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Parent
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.layout (Java SE 9 & JDK 9 )

javafx.scene.layout

Classes

  • AnchorPane
  • Background
  • BackgroundFill
  • BackgroundImage
  • BackgroundPosition
  • BackgroundSize
  • Border
  • BorderImage
  • BorderPane
  • BorderStroke
  • BorderStrokeStyle
  • BorderWidths
  • ColumnConstraints
  • ConstraintsBase
  • CornerRadii
  • FlowPane
  • GridPane
  • HBox
  • Pane
  • Region
  • RowConstraints
  • StackPane
  • TilePane
  • VBox

Enums

  • BackgroundRepeat
  • BorderRepeat
  • Priority


javafx.scene.layout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene.layout

提供类来支持用户界面布局。 每个布局窗格类都支持其子项的不同布局策略，应用程序可以嵌套这些布局窗格，以在用户界面中实现所需的布局结构。 一旦将节点添加到其中一个布局窗格中，窗格将自动管理节点的布局，因此应用程序不应直接放置或调整节点大小; 有关详细信息，请参阅“节点可重定向”。

场景图布局机制

一旦应用程序创建并显示Scene ，场景图布局机制由系统自动驱动。 场景图检测影响布局的动态节点变化（例如大小或内容的变化），并调用requestLayout() ，其将该分支标记为需要的布局，使得在下一个脉冲上，在该分支上执行自上而下的布局通过在该分支的根上调用layout() 。 在布局通过期间，将对每个父项调用layoutChildren()回调方法来布局其子项。 该机制旨在通过确保多个布局请求在一次通过中合并和处理而不是在每次更改时执行重新布局来最大化布局效率。 因此，应用程序不应直接在节点上调用布局。

节点可重定向

场景图支持可调节大小和不可调整大小的节点类。 该isResizable()上方法Node返回是否一个给定的节点是可调整大小或没有。 可调整大小的节点类是支持可接受大小（最小<= preferred <= maximum）范围的类，允许其父级在布局期间将其调整到该范围内，给定父级自己的布局策略和兄弟节点的布局需求。 Node支持以下布局代码方法来确定节点的可调整大小范围：

   public Orientation getContentBias() public double minWidth(double height) public double minHeight(double width) public double prefWidth(double height) public double prefHeight(double width) public double maxWidth(double height) public double maxHeight(double width)

另一方面， 不可调整大小的节点类没有一致的调整大小的API，因此在布局期间，父节点不会调整其大小。 应用程序必须通过在每个实例上设置适当的属性来建立不可调整节点的大小。 这些类返回当前的min，pref和max的布局边界，而resize()方法成为无操作。

可调整大小的类： Region ， Control ， WebView
不可调整大小类： Group ， Shape ， Text

例如，一个Button控件（可调整大小的）计算其最小，最小和最大大小，其父级将在布局期间使用它来调整其大小，因此应用程序只需要配置其内容和属性：

   Button button = new Button("Apply");
然而，Circle（不可调整大小）不能由其父级调整大小，因此应用程序需要设置适当的几何属性来确定其大小：
   Circle circle = new Circle(); circle.setRadius(50);

可调整范围

每个可调整大小的节点类根据自己的内容和属性设置（它是“内在”大小范围）来计算适当的最小，最小和最大大小。 一些可调整大小的类具有无限大的最大大小（所有布局窗格），而另一些具有最大大小，默认被锁定到其首选大小（按钮）（有关每个类的默认范围，请参阅各个类文档）。 虽然这些默认值适用于常见用法，但应用程序通常需要显式更改或设置节点的可调整大小范围才能实现某些布局。 可调整大小的类提供用于覆盖最小，最小和最大大小的属性。

例如，要覆盖ListView的首选大小：

   listview.setPrefSize(200,300);

或者，要更改按钮的最大宽度，因此它将会更大的宽度来填充空格：

   button.setMaxWidth(Double.MAX_VALUE);

对于逆情况，应用程序需要将节点的最小或最大大小钳制为首选：

   listview.setMaxSize(Region.USE_PREF_SIZE, Region.USE_PREF_SIZE);
最后，如果应用程序需要恢复本机计算的值：
   listview.setPrefSize(Region.USE_COMPUTED_SIZE, Region.USE_COMPUTED_SIZE);

CSS样式和节点大小

应用程序无法可靠地查询可调整大小的节点的边界，直到它被添加到场景中，因为该节点的大小可能取决于CSS。 这是因为CSS用于创建一个影响其优先大小（字体，填充，边框等）的节点的许多方面，因此节点不能被布局（调整大小），直到应用CSS并且父级可以访问有效大小范围指标。 这对于控件（以及包含它们的所有窗格）始终是正确的，因为它们依赖CSS作为其默认样式，即使没有设置用户级样式表。 样式表设置在场景级别，这意味着在节点的包围场景已初始化之前，甚至无法确定样式。 一旦场景被初始化，CSS将在布局通过之前应用于每个脉冲上的节点（需要时）。

视觉界限与布局界限

图形丰富的用户界面通常需要区分节点的视觉边界和用于布局的边界。 例如，文本节点的字符字形的紧密的视觉边界对于布局将不起作用，因为文本将不会对齐，并且引导/尾随空格将被打折。 此外，有时应用程序希望应用影响和转换到节点，而不会影响周围的布局（弹跳，抖动，阴影，发光等）。 为了支持这种区别在场景图中， Node提供layoutBounds属性来定义节点的“逻辑”边界布局和boundsInParent定义可视边界，一旦所有的效果，夹持，和转换已经被应用。

对于给定的节点，这两个边界的属性通常会有所不同， layoutBounds根据节点类别的不同而不同：

Bounds Computation Table Node Type Layout Bounds Shape,ImageView Includes geometric bounds (geometry plus stroke). Does NOT include effect, clip, or any transforms. Text logical bounds based on the font height and content width, including white space. can be configured to be tight bounds around chars glyphs by setting boundsType. Does NOT include effect, clip, or any transforms. Region, Control, WebView always [0,0 width x height] regardless of visual bounds, which might be larger or smaller than layout bounds. Group Union of all visible childrens' visual bounds (boundsInParent) Does NOT include effect, clip, or transforms set directly on group, however DOES include effect, clip, transforms set on individual children since those are included in the child's boundsInParent.

所以例如，如果一个DropShadow被添加到一个形状，默认情况下，这个阴影不会被考虑到布局中。 或者，如果使用ScaleTransition来脉冲按钮的大小，则该脉冲动画不会打扰该按钮周围的布局。 如果应用程序希望将效果，剪辑或变换考虑到节点的布局中，则应将该节点包装在组中。

  • 类摘要
    Class 描述
    AnchorPane
    AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。
    Background
    背景Region 。
    BackgroundFill
    填充和相关属性，指导如何填补Region的背景。
    BackgroundImage
    定义描述如何将图像呈现为背景的属性Region 。
    BackgroundPosition
    表示的位置BackgroundImage的内Region的绘图区域。
    BackgroundSize
    定义BackgroundImage应该填充的区域的大小相对于其样式的Region。
    Border
    边界一个Region 。
    BorderImage
    定义描述如何将图像呈现为某个区域的边框的属性。
    BorderPane
    BorderPane在上，左，右，底部和中间位置摆放孩子。
    BorderStroke
    定义用于对区域进行样式设置的边框上使用的笔画。
    BorderStrokeStyle
    定义在BorderStroke的一边使用的笔触风格。
    BorderWidths
    定义四个组件（顶部，右侧，底部和左侧）的宽度。
    ColumnConstraints
    为GridPane中的列定义可选布局约束。
    ConstraintsBase
    用于定义节点特定布局约束的基类。
    CornerRadii
    定义BorderStroke的四个角中的每一个的半径。
    FlowPane
    FlowPane将其孩子摆放在流过玻璃边界的流中。
    GridPane
    GridPane将其孩子放在一个灵活的行和列格网中。
    HBox
    HBox将孩子放在一排水平排列中。
    Pane
    布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
    Region
    Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
    RowConstraints
    为GridPane中的行定义可选布局约束。
    StackPane
    StackPane将它的孩子放在一个靠前的堆叠中。
    TilePane
    TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。
    VBox
    VBox把孩子放在一个垂直的立柱上。
  • 枚举摘要
    Enum 描述
    BackgroundRepeat
    枚举在背景中重复图像的选项
    BorderRepeat
    枚举指示边框图像的重复规则。
    Priority
    用于确定给定节点的布局区域在其区域具有更多（或更少）空间可用并且多个节点竞争该空间时的增长（或收缩）优先级的枚举。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.layout Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.layout

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.layout.Background
    • javafx.scene.layout.BackgroundFill
    • javafx.scene.layout.BackgroundImage
    • javafx.scene.layout.BackgroundPosition
    • javafx.scene.layout.BackgroundSize
    • javafx.scene.layout.Border
    • javafx.scene.layout.BorderImage
    • javafx.scene.layout.BorderStroke
    • javafx.scene.layout.BorderStrokeStyle
    • javafx.scene.layout.BorderWidths
    • javafx.scene.layout.ConstraintsBase
      • javafx.scene.layout.ColumnConstraints
      • javafx.scene.layout.RowConstraints
    • javafx.scene.layout.CornerRadii
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.AnchorPane
            • javafx.scene.layout.BorderPane
            • javafx.scene.layout.FlowPane
            • javafx.scene.layout.GridPane
            • javafx.scene.layout.HBox
            • javafx.scene.layout.StackPane
            • javafx.scene.layout.TilePane
            • javafx.scene.layout.VBox

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.layout.BackgroundRepeat
      • javafx.scene.layout.BorderRepeat
      • javafx.scene.layout.Priority
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Pane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class Pane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    AnchorPane ， BorderPane ， DialogPane ， FlowPane ， GridPane ， HBox ， PopupControl.CSSBridge ， StackPane ， TextFlow ， TilePane ， VBox

    @DefaultProperty("children")
public class Pane
extends Region
    布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。

    该类可以直接用于需要儿童的绝对定位的情况，因为它不执行布局，而不是调整大小可调整大小的儿童到其首选的大小。 应用程序负责定位孩子，因为窗格在布局期间单独放置位置。 例如：

       Pane canvas = new Pane(); canvas.setStyle("-fx-background-color: black;"); canvas.setPrefSize(200,200); Circle circle = new Circle(50,Color.BLUE); circle.relocate(20, 20); Rectangle rectangle = new Rectangle(100,100,Color.RED); rectangle.relocate(70,70); canvas.getChildren().addAll(circle,rectangle);

    注意：如果一个应用程序需要孩子在父母中保持对齐（居中，位于左上角等），那么应该使用一个StackPane 。

    无论儿童的可见属性值如何，窗格都会调整每个被管理的小孩的大小; 所有布局计算都忽略非托管孩子。

    可调整范围

    窗格的父级将在布局期间在窗格的可调整大小范围内调整窗格的大小。 默认情况下，窗格根据其内容计算此范围，如下表所示：

    Pane Resize Table width height minimum left plus right insets. top plus bottom insets. preferred width required to encompass each child at its current x location and preferred width. height required to encompass each child at its current y location and preferred height. maximum Double.MAX_VALUE Double.MAX_VALUE

    窗格的无界最大宽度和高度表示父级可以将其调整大小超出其首选大小，以填充分配给它的空间。

    窗格提供直接设置尺寸范围的属性。 这些属性默认为哨兵值Region.USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       pane.setPrefSize(500,400);
    应用程序可以通过将这些属性设置回Region.USE_COMPUTED_SIZE来还原计算值。

    窗格默认情况下不剪切其内容，因此儿童的边界可能会延伸到自己的界限之外，无论是儿童位于负坐标还是窗格被调整为小于其首选大小。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Pane​()
      创建一个窗格布局。
      Pane​(Node... children)
      创建一个窗格布局。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<Node> getChildren​()
      获取这个 Parent的孩子列表。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, layoutChildren, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getBackground, getBorder, getClassCssMetaData, getCssMetaData, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • Pane

        public Pane​()
        创建一个窗格布局。

      • Pane

        public Pane​(Node... children)
        创建一个窗格布局。
        参数
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • getChildren

        public ObservableList<Node> getChildren​()
        描述从类复制： Parent
        获取这个Parent的孩子列表。

        有关设置Parent的子列表的场景图结构限制，请参阅Node的课程文档。 如果对子列表的更改违反了这些限制，则忽略该更改，并恢复子列表的先前值。 在这种情况下抛出一个IllegalArgumentException 。

        如果这个Parent节点被连接到Scene连接到Window被showning（ Window.isShowing() ），那么其子女的名单必须只在JavaFX应用程序线程修改。 如果违反限制，则抛出IllegalStateException 。

        注意子类：如果您重写此方法，则必须从实现中返回调用此超级方法的结果。 从任何getChildren（）实现返回的实际列表实例必须是由此父项所拥有和管理的列表。 推翻这种方法的唯一典型的目的是推广这种方法。

        重写：
        getChildren在 Parent
        结果
        可修改的儿童名单。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Priority (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Enum Priority

  • java.lang.Object
    • java.lang.Enum<Priority>
      • javafx.scene.layout.Priority
  • All Implemented Interfaces:
    Serializable ， Comparable<Priority>

    public enum Priority
extends Enum<Priority>
    用于确定给定节点的布局区域在其区域具有更多（或更少）空间可用并且多个节点竞争该空间时的增长（或收缩）优先级的枚举。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALWAYS
      布局区域将始终尝试增长（或缩小），与其他布局面积（或缩小）为一致的空间共享增加（或减小）。
      NEVER
      当区域可用空间有所增加（或减少）时，布局区域将永远不会增长（或缩小）。
      SOMETIMES
      如果没有其他布局区域随着增长（或缩小）设置为始终，或者这些布局区域没有吸收所有增加（或减少）空间，则将与其他布局区域的空间分配空间的增加（或减小）有时。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Priority max​(Priority a, Priority b)
      回收两个优先级较高的便利方法。
      static Priority min​(Priority a, Priority b)
      方便返回两个优先级较低的方法。
      static Priority valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Priority[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ALWAYS

        public static final Priority ALWAYS
        布局区域将始终尝试增长（或缩小），与其他布局面积（或缩小）为一致的空间共享增加（或减小）。

      • SOMETIMES

        public static final Priority SOMETIMES
        如果没有其他布局区域随着增长（或缩小）设置为始终，或者这些布局区域没有吸收所有增加（或减少）空间，则将与其他布局区域的空间分配空间的增加（或减小）有时。

      • NEVER

        public static final Priority NEVER
        当区域可用空间有所增加（或减少）时，布局区域将永远不会增长（或缩小）。

    • 方法详细信息

      • values

        public static Priority[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Priority c : Priority.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Priority valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • max

        public static Priority max​(Priority a,
                           Priority b)
        回收两个优先级较高的便利方法。
        参数
        a - 第一优先
        b - 第二优先
        结果
        最高的两个优先事项

      • min

        public static Priority min​(Priority a,
                           Priority b)
        方便返回两个优先级较低的方法。
        参数
        a - 第一优先
        b - 第二优先
        结果
        较低的两个优先事项
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Region (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class Region

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    Axis ， Chart ， Control ， Pane ， TableColumnHeader ， VirtualFlow

    public class Region
extends Parent
    Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。 它是一个可调整大小的父节点，可以从CSS样式。 它可以有多个背景和边界。 它旨在支持与JavaFX相关的背景和边框CSS3规范。 完整的规格可在the W3C 。

    每个区域都有其布局边界，它们被指定为（0,0，width，height）。 一个地区可能会超出这些范围。 区域的内容区域是其孩子的布局占用的区域。 默认情况下，该区域与区域的布局边界相同，但可以通过边框的属性（使用BorderStrokes或BorderImages）和填充来修改。 填充可以是负的，使得区域的内容区域可能延伸超出区域的布局边界，但不影响布局边界。

    区域有一个背景和一个边框，尽管这两个或者两个可能是空的。 区域背景由零个或多个BackgroundFill以及零个或多个BackgroundImages组成。 同样地，一个区域的边界由它的Border定义，它由零个或多个BorderStrokes和零个或多个BorderImages组成。 所有的BackgroundFill都先绘制，其次是BackgroundImages，BorderStrokes，最后是BorderImages。 内容绘制在所有背景和边框之上。 如果存在BorderImage（并且正确加载了所有图像），则实际上不绘制BorderStrokes，尽管它们被考虑用于计算内容区域的位置（请参阅BorderStroke的stroke width属性）。 这些语义符合CSS3规范。 这些语义的目的是允许应用程序指定在ImageStroke无法下载或加载的情况下显示的后备BorderStroke。

    默认情况下，区域显示为矩形。 BackgroundFill半径可能会导致Rectangle显示为四舍五入。 这不仅影响视觉效果看起来像圆角的矩形，而且还会导致区域的选取行为像圆角矩形，从而忽略角半径之外的位置。 一个区域可以使用任何形状，但是，通过指定shape属性。 如果指定了一个形状，那么所有的BackgroundFill，BackgroundImages和BorderStrokes将被应用于形状。 BorderImages不用于具有指定形状的区域。

    具有形状的区域

    虽然区域的布局界限不受任何边框或背景影响，但区域内容区域和区域的选区也是如此。 该区域的insets定义了布局边界的边缘与内容区域的边缘之间的距离。 例如，如果区域布局界限为（x = 0，y = 0，width = 200，height = 100），并且插图为（top = 10，right = 20，bottom = 30，left = 40）内容区域界限为（x = 40，y = 10，width = 140，height = 60）。 布置其子女的区域子类应该计算并遵守这些内容区域边界。

    默认情况下，Region继承其超类的布局行为，即Parent ，这意味着它会将任何可调整大小的子节点的大小调整到其首选大小，但不会重新定位它们。 如果应用程序需要更具体的布局行为，那么它应该使用的地区的一个子类： StackPane ， HBox ， VBox ， TilePane ， FlowPane ， BorderPane ， GridPane ，或AnchorPane 。

    为了实现更自定义布局，区域子类必须覆盖computePrefWidth ， computePrefHeight ，并layoutChildren 。 请注意， layoutChildren在执行自上而下的布局传递时由场景图自动调用，不应由region子类直接调用。

    区域子类，其布局自己的孩子会通过设置定位节点二百七十○万七千一百十六亿二千一百五十三万三千六百三十三 / 二七零七一一六二一五四五四七六并不会改变二百七十�鐾蚱咔б话偈�六亿二千一百五十六万一千二百六十六 / 二百七十万七千一百十六亿二千一百五十七万三千一百零九 ，这些将被保留调整和动画。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Background> background
      该区域的背景由零个或多个BackgroundFill组成，以及零个或多个BackgroundImages。
      ObjectProperty<Border> border
      该区域的边界由零个或多个BorderStrokes组成，零个或多个BorderImages。
      BooleanProperty cacheShape
      定义对系统的提示，指出用于定义区域背景的Shape是稳定的，可以从缓存中受益。
      BooleanProperty centerShape
      定义形状是否位于区域的宽度或高度内。
      ReadOnlyDoubleProperty height
      这个可调节大小的节点的高度。
      ReadOnlyObjectProperty<Insets> insets
      区域的插图定义从区域边缘（其布局边界，或（0,0，宽度，高度））到内容区域边缘的距离。
      DoubleProperty maxHeight
      覆盖该地区计算出的最大高度的属性。
      DoubleProperty maxWidth
      覆盖该地区计算出的最大宽度的属性。
      DoubleProperty minHeight
      覆盖该地区计算最小高度的属性。
      DoubleProperty minWidth
      覆盖该地区计算出的最小宽度的属性。
      ObjectProperty<Insets> opaqueInsets
      定义绘制完全不透明像素的区域的面积。
      ObjectProperty<Insets> padding
      顶部，右侧，底部和左侧填充该区域的内容。
      DoubleProperty prefHeight
      覆盖该地区计算的首选高度的属性。
      DoubleProperty prefWidth
      覆盖该地区计算的首选宽度的属性。
      BooleanProperty scaleShape
      指定是否将形状（如果已定义）缩放以匹配“区域”的大小。
      ObjectProperty<Shape> shape
      指定时， Shape将导致该区域被渲染为指定的形状而不是圆角矩形。
      BooleanProperty snapToPixel
      定义此区域是否将其子项的位置，间距和大小值调整为像素边界。
      ReadOnlyDoubleProperty width
      这个可调节大小的节点的宽度。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double USE_COMPUTED_SIZE
      这可以传递给一个地区的哨兵值 setMinWidth ， setMinHeight ， setPrefWidth ， setPrefHeight ， setMaxWidth ， setMaxHeight种方法重置区域的大小限制回到它的内在的大小由归国 computeMinWidth ， computeMinHeight ， computePrefWidth ， computePrefHeight ， computeMaxWidth ，或 computeMaxHeight 。
      static double USE_PREF_SIZE
      其可以被传递给一个地区的定点值 setMinWidth ， setMinHeight ， setMaxWidth或 setMaxHeight方法，以指示优选的尺寸应该用于该最大和/或最小约束。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Region​()
      创建一个空的背景和空的Border的新区域。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Background> backgroundProperty​()
      该区域的背景由零个或多个BackgroundFill组成，以及零个或多个BackgroundImages。
      ObjectProperty<Border> borderProperty​()
      该区域的边界由零个或多个BorderStrokes组成，零个或多个BorderImages。
      BooleanProperty cacheShapeProperty​()
      定义对系统的提示，指出用于定义区域背景的Shape是稳定的，可以从缓存中受益。
      BooleanProperty centerShapeProperty​()
      定义形状是否位于区域的宽度或高度内。
      protected double computeMaxHeight​(double width)
      计算该区域的最大高度。
      protected double computeMaxWidth​(double height)
      计算此区域的最大宽度。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      Background getBackground​()
      获取属性背景的值。
      Border getBorder​()
      获取属性边框的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      double getHeight​()
      获取属性高度的值。
      Insets getInsets​()
      获取属性插值的值。
      double getMaxHeight​()
      获取属性maxHeight的值。
      double getMaxWidth​()
      获取属性maxWidth的值。
      double getMinHeight​()
      获取属性minHeight的值。
      double getMinWidth​()
      获取属性minWidth的值。
      Insets getOpaqueInsets​()
      获取属性opaqueInsets的值。
      Insets getPadding​()
      获取属性填充的值。
      double getPrefHeight​()
      获取属性prefHeight的值。
      double getPrefWidth​()
      获取属性prefWidth的值。
      Shape getShape​()
      获取属性形状的值。
      String getUserAgentStylesheet​()
      实现可以通过覆盖此方法来为该Region及其子项指定其自己的用户代理样式。
      double getWidth​()
      获取属性宽度的值。
      ReadOnlyDoubleProperty heightProperty​()
      这个可调节大小的节点的高度。
      ReadOnlyObjectProperty<Insets> insetsProperty​()
      区域的插图定义从区域边缘（其布局边界，或（0,0，宽度，高度））到内容区域边缘的距离。
      boolean isCacheShape​()
      获取属性cacheShape的值。
      boolean isCenterShape​()
      获取属性centerShape的值。
      boolean isResizable​()
      返回 true因为所有地区都可调整大小。
      boolean isScaleShape​()
      获取属性scaleShape的值。
      boolean isSnapToPixel​()
      获取属性snapToPixel的值。
      protected void layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, boolean fillWidth, boolean fillHeight, HPos halignment, VPos valignment, boolean isSnapToPixel)
      其中规定了儿童的它的区域内的工具方法的父通过定义 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      protected void layoutInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment)
      其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      double maxHeight​(double width)
      在布局期间调用以确定此节点的最大高度。
      DoubleProperty maxHeightProperty​()
      覆盖该地区计算出的最大高度的属性。
      double maxWidth​(double height)
      在布局期间调用以确定此节点的最大宽度。
      DoubleProperty maxWidthProperty​()
      覆盖该地区计算出的最大宽度的属性。
      double minHeight​(double width)
      在布局期间调用以确定此节点的最小高度。
      DoubleProperty minHeightProperty​()
      覆盖该地区计算最小高度的属性。
      double minWidth​(double height)
      在布局期间调用以确定此节点的最小宽度。
      DoubleProperty minWidthProperty​()
      覆盖该地区计算出的最小宽度的属性。
      ObjectProperty<Insets> opaqueInsetsProperty​()
      定义绘制完全不透明像素的区域的面积。
      ObjectProperty<Insets> paddingProperty​()
      顶部，右侧，底部和左侧填充该区域的内容。
      protected void positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, HPos halignment, VPos valignment)
      通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      static void positionInArea​(Node child, double areaX, double areaY, double areaWidth, double areaHeight, double areaBaselineOffset, Insets margin, HPos halignment, VPos valignment, boolean isSnapToPixel)
      通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
      double prefHeight​(double width)
      在布局期间调用以确定此节点的首选高度。
      DoubleProperty prefHeightProperty​()
      覆盖该地区计算的首选高度的属性。
      double prefWidth​(double height)
      在布局期间调用以确定此节点的首选宽度。
      DoubleProperty prefWidthProperty​()
      覆盖该地区计算的首选宽度的属性。
      void resize​(double width, double height)
      在布局期间由区域的父项调用以设置区域的宽度和高度。
      BooleanProperty scaleShapeProperty​()
      指定是否将形状（如果已定义）缩放以匹配“区域”的大小。
      void setBackground​(Background value)
      设置属性背景的值。
      void setBorder​(Border value)
      设置属性边框的值。
      void setCacheShape​(boolean value)
      设置属性cacheShape的值。
      void setCenterShape​(boolean value)
      设置属性centerShape的值。
      protected void setHeight​(double value)
      设置属性高度的值。
      void setMaxHeight​(double value)
      设置属性maxHeight的值。
      void setMaxSize​(double maxWidth, double maxHeight)
      覆盖区域计算的最大宽度和高度的便捷方法。
      void setMaxWidth​(double value)
      设置属性maxWidth的值。
      void setMinHeight​(double value)
      设置属性minHeight的值。
      void setMinSize​(double minWidth, double minHeight)
      覆盖区域计算的最小宽度和高度的便利方法。
      void setMinWidth​(double value)
      设置属性minWidth的值。
      void setOpaqueInsets​(Insets value)
      设置属性opaqueInsets的值。
      void setPadding​(Insets value)
      设置属性填充的值。
      void setPrefHeight​(double value)
      设置属性prefHeight的值。
      void setPrefSize​(double prefWidth, double prefHeight)
      覆盖区域计算的首选宽度和高度的便捷方法。
      void setPrefWidth​(double value)
      设置属性prefWidth的值。
      void setScaleShape​(boolean value)
      设置属性scaleShape的值。
      void setShape​(Shape value)
      设置属性形状的值。
      void setSnapToPixel​(boolean value)
      设置属性snapToPixel的值。
      protected void setWidth​(double value)
      设置属性宽度的值。
      ObjectProperty<Shape> shapeProperty​()
      指定时， Shape将使区域呈现为指定的形状，而不是圆角矩形。
      double snappedBottomInset​()
      获取底部插图的实用方法，其中包括填充和边框插入。
      double snappedLeftInset​()
      获取包含填充和边框插入的左边插图的实用方法。
      double snappedRightInset​()
      获取正确的插图的实用方法，包括填充和边框插入。
      double snappedTopInset​()
      获取包含填充和边框插入的顶层插图的实用方法。
      protected double snapPosition​(double value)
      已过时。
      替换为snapPositionX()和snapPositionY()
      double snapPositionX​(double value)
      如果此区域的snapToPixel属性为true，则返回一个舍入为水平方向最近像素的值，否则返回相同的值。
      double snapPositionY​(double value)
      如果该区域的snapToPixel属性为true，则返回一个四舍五入到垂直方向上最近的像素的值，否则返回相同的值。
      protected double snapSize​(double value)
      已过时。
      由snapSizeX()和snapSizeY()
      double snapSizeX​(double value)
      如果此区域的snapToPixel属性为true，则返回一个值，该值将被忽略到水平方向上最近的像素，否则返回相同的值。
      double snapSizeY​(double value)
      如果此区域的snapToPixel属性为true，则返回一个值，该值将被忽略到垂直方向上最近的像素，否则返回相同的值。
      protected double snapSpace​(double value)
      已过时。
      由snapSpaceX()和snapSpaceY()取代
      double snapSpaceX​(double value)
      如果此区域的snapToPixel属性为true，则返回一个舍入为水平方向最近像素的值，否则返回相同的值。
      double snapSpaceY​(double value)
      如果该区域的snapToPixel属性为true，则返回一个四舍五入到垂直方向上最近的像素的值，否则返回相同的值。
      BooleanProperty snapToPixelProperty​()
      定义此区域是否将其子项的位置，间距和大小值调整为像素边界。
      ReadOnlyDoubleProperty widthProperty​()
      这个可调节大小的节点的宽度。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, layoutChildren, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • snapToPixel

        public final BooleanProperty snapToPixelProperty
        定义此区域是否将其子项的位置，间距和大小值调整为像素边界。 这默认为true，这通常是预期的行为，以便具有清晰的用户界面。 值为false将允许分数对齐，这可能导致“模糊”的边界。
        另请参见：
        isSnapToPixel() ， setSnapToPixel(boolean)

      • padding

        public final ObjectProperty<Insets> paddingProperty
        顶部，右侧，底部和左侧填充该区域的内容。 该空间将包含在该区域的最小和优选大小的计算中。 默认填充为Insets.EMPTY。 应避免将值设置为null。
        另请参见：
        getPadding() ， setPadding(Insets)

      • background

        public final ObjectProperty<Background> backgroundProperty
        该区域的背景由零个或多个BackgroundFill组成，以及零个或多个BackgroundImages。 背景可能是空的，它既没有填充也没有图像，并且在语义上等同于null。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getBackground() ， setBackground(Background)

      • border

        public final ObjectProperty<Border> borderProperty
        该区域的边界由零个或多个BorderStrokes组成，零个或多个BorderImages。 边框可以是空的，它既没有笔画也没有图像，并且在语义上等同于null。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getBorder() ， setBorder(Border)

      • opaqueInsets

        public final ObjectProperty<Insets> opaqueInsetsProperty
        定义绘制完全不透明像素的区域的面积。 这用于各种性能优化。 该区域内的像素必须完全不透明，否则会产生渲染伪像。 应用程序的责任是通过代码或通过CSS来确保opaqueInsets对于区域的背景和边界是正确的。 每个插值的值必须是实数，而不是NaN或Infinity。 如果没有已知的insets存在，那么opaqueInsets应该设置为null。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOpaqueInsets() ， setOpaqueInsets(Insets)

      • insets

        public final ReadOnlyObjectProperty<Insets> insetsProperty
        区域的插图定义从区域边缘（其布局边界，或（0,0，宽度，高度））到内容区域边缘的距离。 所有子节点都应该布置在内容区域内。 插值是根据已指定的边框（如果有的话）以及填充来计算的。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getInsets()

      • width

        public final ReadOnlyDoubleProperty widthProperty
        这个可调节大小的节点的宽度。 此属性在布局期间由区域的父级设置，可能不由应用程序设置。 如果应用程序需要明确地控制的区域的大小，它应通过将覆盖其优选尺寸范围minWidth ， prefWidth ，和maxWidth性质。
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final ReadOnlyDoubleProperty heightProperty
        这个可调节大小的节点的高度。 此属性在布局期间由区域的父级设置，可能不由应用程序设置。 如果应用程序需要明确地控制的区域的大小，它应通过将覆盖其优选尺寸范围minHeight ， prefHeight ，和maxHeight性质。
        另请参见：
        getHeight() ， setHeight(double)

      • minWidth

        public final DoubleProperty minWidthProperty
        覆盖该地区计算出的最小宽度的属性。 只有当区域内部计算的最小宽度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着minWidth(forHeight)将返回区域内部计算的最小宽度。

        将此值设置为USE_PREF_SIZE标志将导致minWidth(forHeight)返回区域的首选宽度，使应用程序可以轻松限制区域的可重定位。

        另请参见：
        getMinWidth() ， setMinWidth(double)

      • minHeight

        public final DoubleProperty minHeightProperty
        覆盖该地区计算最小高度的属性。 只有当区域的内部计算的最小高度不符合应用程序的布局需要时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着minHeight(forWidth)将返回区域内部计算的最小高度。

        将此值设置为USE_PREF_SIZE标志将导致minHeight(forWidth)返回区域的首选高度，从而使应用程序能够轻松限制区域的可minHeight(forWidth)性。

        另请参见：
        getMinHeight() ， setMinHeight(double)

      • prefWidth

        public final DoubleProperty prefWidthProperty
        覆盖该地区计算的首选宽度的属性。 只有当区域内部计算的首选宽度不符合应用程序的布局需要时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefWidth(forHeight)将返回区域内部计算的首选宽度。

        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • prefHeight

        public final DoubleProperty prefHeightProperty
        覆盖该地区计算的首选高度的属性。 只有当区域内部计算的首选高度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefHeight(forWidth)将返回区域内部计算的首选宽度。

        另请参见：
        getPrefHeight() ， setPrefHeight(double)

      • maxWidth

        public final DoubleProperty maxWidthProperty
        覆盖该地区计算出的最大宽度的属性。 只有当区域的内部计算的最大宽度不符合应用程序的布局需要时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxWidth(forHeight)将返回区域内部计算的最大宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxWidth(forHeight)返回区域的首选宽度，使应用程序能够轻松限制区域的可getMaxWidth(forHeight)性。

        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • maxHeight

        public final DoubleProperty maxHeightProperty
        覆盖该地区计算出的最大高度的属性。 只有当区域内部计算的最大高度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxHeight(forWidth)将返回区域内部计算的最大高度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxHeight(forWidth)返回区域的首选高度，使应用程序能够轻松限制区域的可重定位。

        另请参见：
        getMaxHeight() ， setMaxHeight(double)

      • shape

        public final ObjectProperty<Shape> shapeProperty
        指定时， Shape将导致该区域被渲染为指定的形状而不是圆角矩形。 当为空时，Region将被渲染为圆角矩形。 当渲染为Shape时，任何背景都用于填充形状，尽管任何背景插入将被忽略，如背景半径。 定义的任何BorderStrokes用于抚摸形状。 任何BorderImages都被忽略。
        Default value:
        空值
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getShape() ， setShape(Shape)

      • scaleShape

        public final BooleanProperty scaleShapeProperty
        指定是否将形状（如果已定义）缩放以匹配“区域”的大小。 true表示形状被缩放以适应区域的大小， false表示形状为其源尺寸，其定位取决于centerShape的值。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isScaleShape() ， setScaleShape(boolean)

      • centerShape

        public final BooleanProperty centerShapeProperty
        定义形状是否位于区域的宽度或高度内。 true表示以区域宽度和高度为中心的形状， false表示形状位于其源位置。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isCenterShape() ， setCenterShape(boolean)

      • cacheShape

        public final BooleanProperty cacheShapeProperty
        定义对系统的提示，指出用于定义区域背景的Shape是稳定的，可以从缓存中受益。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isCacheShape() ， setCacheShape(boolean)

    • 字段详细信息

      • USE_PREF_SIZE

        public static final double USE_PREF_SIZE
        其可以被传递给一个地区的定点值 setMinWidth ， setMinHeight ， setMaxWidth或 setMaxHeight方法，以指示优选的尺寸应该用于该最大和/或最小约束。
        另请参见：
        Constant Field Values

      • USE_COMPUTED_SIZE

        public static final double USE_COMPUTED_SIZE
        这可以传递给一个地区的哨兵值 setMinWidth ， setMinHeight ， setPrefWidth ， setPrefHeight ， setMaxWidth ， setMaxHeight种方法重置区域的大小限制回到它的内在的大小由归国 computeMinWidth ， computeMinHeight ， computePrefWidth ， computePrefHeight ， computeMaxWidth ，或 computeMaxHeight 。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Region

        public Region​()
        创建一个空的背景和空的Border的新区域。 区域默认为将pickOnBounds设置为true，这意味着在Region区域内的边界内发生的任何选择（鼠标选择或触摸拾取等）将返回true，而不管该区域是填充还是透明。

    • 方法详细信息

      • isSnapToPixel

        public final boolean isSnapToPixel​()
        获取属性snapToPixel的值。
        Property description:
        定义此区域是否将其子项的位置，间距和大小值调整为像素边界。 这默认为true，这通常是预期的行为，以便具有清晰的用户界面。 值为false将允许分数对齐，这可能导致“模糊”的边界。

      • setSnapToPixel

        public final void setSnapToPixel​(boolean value)
        设置属性snapToPixel的值。
        Property description:
        定义此区域是否将其子项的位置，间距和大小值调整为像素边界。 这默认为true，这通常是预期的行为，以便具有清晰的用户界面。 值为false将允许分数对齐，这可能导致“模糊”的边界。

      • snapToPixelProperty

        public final BooleanProperty snapToPixelProperty​()
        定义此区域是否将其子项的位置，间距和大小值调整为像素边界。 这默认为true，这通常是预期的行为，以便具有清晰的用户界面。 值为false将允许分数对齐，这可能导致“模糊”的边界。
        另请参见：
        isSnapToPixel() ， setSnapToPixel(boolean)

      • setPadding

        public final void setPadding​(Insets value)
        设置属性填充的值。
        Property description:
        顶部，右侧，底部和左侧填充该区域的内容。 该空间将包含在该区域的最小和优选大小的计算中。 默认填充为Insets.EMPTY。 应避免将值设置为null。

      • getPadding

        public final Insets getPadding​()
        获取属性填充的值。
        Property description:
        顶部，右侧，底部和左侧填充该区域的内容。 该空间将包含在该区域的最小和优选大小的计算中。 默认填充为Insets.EMPTY。 应避免将值设置为null。

      • paddingProperty

        public final ObjectProperty<Insets> paddingProperty​()
        顶部，右侧，底部和左侧填充该区域的内容。 该空间将包含在该区域的最小和优选大小的计算中。 默认填充为Insets.EMPTY。 应避免将值设置为null。
        另请参见：
        getPadding() ， setPadding(Insets)

      • setBackground

        public final void setBackground​(Background value)
        设置属性背景的值。
        Property description:
        该区域的背景由零个或多个BackgroundFill组成，以及零个或多个BackgroundImages。 背景可能是空的，它既没有填充也没有图像，并且在语义上等同于null。
        从以下版本开始：
        JavaFX 8.0

      • getBackground

        public final Background getBackground​()
        获取属性背景的值。
        Property description:
        该区域的背景由零个或多个BackgroundFill组成，以及零个或多个BackgroundImages。 背景可能是空的，它既没有填充也没有图像，并且在语义上等同于null。
        从以下版本开始：
        JavaFX 8.0

      • backgroundProperty

        public final ObjectProperty<Background> backgroundProperty​()
        该区域的背景由零个或多个BackgroundFill组成，以及零个或多个BackgroundImages。 背景可能是空的，它既没有填充也没有图像，并且在语义上等同于null。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getBackground() ， setBackground(Background)

      • setBorder

        public final void setBorder​(Border value)
        设置属性边框的值。
        Property description:
        该区域的边界由零个或多个BorderStrokes组成，零个或多个BorderImages。 边框可以是空的，它既没有笔画也没有图像，并且在语义上等同于null。
        从以下版本开始：
        JavaFX 8.0

      • getBorder

        public final Border getBorder​()
        获取属性边框的值。
        Property description:
        该区域的边界由零个或多个BorderStrokes组成，零个或多个BorderImages。 边框可以是空的，它既没有笔画也没有图像，并且在语义上等同于null。
        从以下版本开始：
        JavaFX 8.0

      • borderProperty

        public final ObjectProperty<Border> borderProperty​()
        该区域的边界由零个或多个BorderStrokes组成，零个或多个BorderImages。 边框可以是空的，它既没有笔画也没有图像，并且在语义上等同于null。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getBorder() ， setBorder(Border)

      • opaqueInsetsProperty

        public final ObjectProperty<Insets> opaqueInsetsProperty​()
        定义绘制完全不透明像素的区域的面积。 这用于各种性能优化。 该区域内的像素必须完全不透明，否则会产生渲染伪像。 应用程序的责任是通过代码或通过CSS来确保opaqueInsets对于区域的背景和边界是正确的。 每个插值的值必须是实数，而不是NaN或Infinity。 如果没有已知的insets存在，那么opaqueInsets应该设置为null。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOpaqueInsets() ， setOpaqueInsets(Insets)

      • setOpaqueInsets

        public final void setOpaqueInsets​(Insets value)
        设置属性opaqueInsets的值。
        Property description:
        定义绘制完全不透明像素的区域的面积。 这用于各种性能优化。 该区域内的像素必须完全不透明，否则会产生渲染伪像。 应用程序的责任是通过代码或通过CSS来确保opaqueInsets对于区域的背景和边界是正确的。 每个插值的值必须是实数，而不是NaN或Infinity。 如果没有已知的insets存在，那么opaqueInsets应该设置为null。
        从以下版本开始：
        JavaFX 8.0

      • getOpaqueInsets

        public final Insets getOpaqueInsets​()
        获取属性opaqueInsets的值。
        Property description:
        定义绘制完全不透明像素的区域的面积。 这用于各种性能优化。 该区域内的像素必须完全不透明，否则会产生渲染伪像。 应用程序的责任是通过代码或通过CSS来确保opaqueInsets对于区域的背景和边界是正确的。 每个插值的值必须是实数，而不是NaN或Infinity。 如果没有已知的insets存在，那么opaqueInsets应该设置为null。
        从以下版本开始：
        JavaFX 8.0

      • getInsets

        public final Insets getInsets​()
        获取属性插值的值。
        Property description:
        区域的插图定义从区域边缘（其布局边界，或（0,0，宽度，高度））到内容区域边缘的距离。 所有子节点都应该布置在内容区域内。 插值是根据已指定的边框（如果有的话）以及填充来计算的。
        从以下版本开始：
        JavaFX 8.0

      • insetsProperty

        public final ReadOnlyObjectProperty<Insets> insetsProperty​()
        区域的插图定义从区域边缘（其布局边界，或（0,0，宽度，高度））到内容区域边缘的距离。 所有子节点都应该布置在内容区域内。 插值是根据已指定的边框（如果有的话）以及填充来计算的。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getInsets()

      • setWidth

        protected void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        这个可调节大小的节点的宽度。 此属性在布局期间由区域的父级设置，可能不由应用程序设置。 如果应用程序需要明确地控制的区域的大小，它应通过将覆盖其优选尺寸范围minWidth ， prefWidth ，和maxWidth性质。

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        这个可调节大小的节点的宽度。 此属性在布局期间由区域的父级设置，可能不由应用程序设置。 如果应用程序需要明确地控制的区域的大小，它应通过将覆盖其优选尺寸范围minWidth ， prefWidth ，和maxWidth性质。

      • widthProperty

        public final ReadOnlyDoubleProperty widthProperty​()
        这个可调节大小的节点的宽度。 此属性在布局期间由区域的父级设置，可能不由应用程序设置。 如果应用程序需要明确地控制的区域的大小，它应通过将覆盖其优选尺寸范围minWidth ， prefWidth ，和maxWidth性质。
        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        protected void setHeight​(double value)
        设置属性高度的值。
        Property description:
        这个可调节大小的节点的高度。 此属性在布局期间由区域的父级设置，可能不由应用程序设置。 如果应用程序需要明确地控制的区域的大小，它应通过将覆盖其优选尺寸范围minHeight ， prefHeight ，和maxHeight性质。

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        这个可调节大小的节点的高度。 此属性在布局期间由区域的父级设置，可能不由应用程序设置。 如果应用程序需要明确地控制的区域的大小，它应通过将覆盖其优选尺寸范围minHeight ， prefHeight ，和maxHeight性质。

      • heightProperty

        public final ReadOnlyDoubleProperty heightProperty​()
        这个可调节大小的节点的高度。 此属性在布局期间由区域的父级设置，可能不由应用程序设置。 如果应用程序需要明确地控制的区域的大小，它应通过将覆盖其优选尺寸范围minHeight ， prefHeight ，和maxHeight性质。
        另请参见：
        getHeight() ， setHeight(double)

      • setMinWidth

        public final void setMinWidth​(double value)
        设置属性minWidth的值。
        Property description:
        覆盖该地区计算出的最小宽度的属性。 只有当区域内部计算的最小宽度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着minWidth(forHeight)将返回区域内部计算的最小宽度。

        将此值设置为USE_PREF_SIZE标志将导致minWidth(forHeight)返回区域的首选宽度，使应用程序能够轻松地限制区域的可重定位。

      • getMinWidth

        public final double getMinWidth​()
        获取属性minWidth的值。
        Property description:
        覆盖该地区计算出的最小宽度的属性。 只有当区域内部计算的最小宽度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着minWidth(forHeight)将返回区域内部计算的最小宽度。

        将此值设置为USE_PREF_SIZE标志将导致minWidth(forHeight)返回区域的首选宽度，使应用程序能够轻松限制区域的可重定位。

      • minWidthProperty

        public final DoubleProperty minWidthProperty​()
        覆盖该地区计算出的最小宽度的属性。 只有当区域内部计算的最小宽度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着minWidth(forHeight)将返回区域内部计算的最小宽度。

        将此值设置为USE_PREF_SIZE标志将导致minWidth(forHeight)返回区域的首选宽度，使应用程序能够轻松限制区域的可重定位。

        另请参见：
        getMinWidth() ， setMinWidth(double)

      • setMinHeight

        public final void setMinHeight​(double value)
        设置属性minHeight的值。
        Property description:
        覆盖该地区计算最小高度的属性。 只有当区域的内部计算的最小高度不符合应用程序的布局需要时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着minHeight(forWidth)将返回区域内部计算的最小高度。

        将此值设置为USE_PREF_SIZE标志将导致minHeight(forWidth)返回区域的首选高度，使应用程序能够轻松限制区域的可重定位。

      • getMinHeight

        public final double getMinHeight​()
        获取属性minHeight的值。
        Property description:
        覆盖该地区计算最小高度的属性。 只有当区域的内部计算的最小高度不符合应用程序的布局需要时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着minHeight(forWidth)将返回区域内部计算的最小高度。

        将此值设置为USE_PREF_SIZE标志将导致minHeight(forWidth)返回区域的首选高度，使应用程序能够轻松限制区域的可重定位。

      • minHeightProperty

        public final DoubleProperty minHeightProperty​()
        覆盖该地区计算最小高度的属性。 只有当区域的内部计算的最小高度不符合应用程序的布局需要时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着minHeight(forWidth)将返回区域内部计算的最小高度。

        将此值设置为USE_PREF_SIZE标志将导致minHeight(forWidth)返回区域的首选高度，从而使应用程序能够轻松限制区域的可minHeight(forWidth)性。

        另请参见：
        getMinHeight() ， setMinHeight(double)

      • setMinSize

        public void setMinSize​(double minWidth,
                       double minHeight)
        覆盖区域计算的最小宽度和高度的便利方法。 只有当区域的内部计算的最小大小不符合应用程序的布局需求时，才应该调用此方法。
        参数
        minWidth - 最小宽度的覆盖值
        minHeight - 最小高度的覆盖值
        另请参见：
        setMinWidth(double) ， setMinHeight(double)

      • setPrefWidth

        public final void setPrefWidth​(double value)
        设置属性prefWidth的值。
        Property description:
        覆盖该地区计算的首选宽度的属性。 只有当区域内部计算的首选宽度不符合应用程序的布局需要时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefWidth(forHeight)将返回区域内部计算的首选宽度。

      • getPrefWidth

        public final double getPrefWidth​()
        获取属性prefWidth的值。
        Property description:
        覆盖该地区计算的首选宽度的属性。 只有当区域内部计算的首选宽度不符合应用程序的布局需要时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefWidth(forHeight)将返回区域内部计算的首选宽度。

      • prefWidthProperty

        public final DoubleProperty prefWidthProperty​()
        覆盖该地区计算的首选宽度的属性。 只有当区域内部计算的首选宽度不符合应用程序的布局需要时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefWidth(forHeight)将返回区域内部计算的首选宽度。

        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • setPrefHeight

        public final void setPrefHeight​(double value)
        设置属性prefHeight的值。
        Property description:
        覆盖该地区计算的首选高度的属性。 只有当区域内部计算的首选高度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefHeight(forWidth)将返回区域内部计算的首选宽度。

      • getPrefHeight

        public final double getPrefHeight​()
        获取属性prefHeight的值。
        Property description:
        覆盖该地区计算的首选高度的属性。 只有当区域内部计算的首选高度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefHeight(forWidth)将返回区域内部计算的首选宽度。

      • prefHeightProperty

        public final DoubleProperty prefHeightProperty​()
        覆盖该地区计算的首选高度的属性。 只有当区域内部计算的首选高度不符合应用程序的布局需求时，才应该设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getPrefHeight(forWidth)将返回区域内部计算的首选宽度。

        另请参见：
        getPrefHeight() ， setPrefHeight(double)

      • setPrefSize

        public void setPrefSize​(double prefWidth,
                        double prefHeight)
        覆盖区域计算的首选宽度和高度的便捷方法。 只有当该区域的内部计算的首选大小不符合应用程序的布局需求时，才应该调用此方法。
        参数
        prefWidth - 优先宽度的覆盖值
        prefHeight - 首选高度的覆盖值
        另请参见：
        setPrefWidth(double) ， setPrefHeight(double)

      • setMaxWidth

        public final void setMaxWidth​(double value)
        设置属性maxWidth的值。
        Property description:
        覆盖该地区计算出的最大宽度的属性。 只有当区域的内部计算的最大宽度不符合应用程序的布局需要时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxWidth(forHeight)将返回区域内部计算的最大宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxWidth(forHeight)返回区域的首选宽度，使应用程序能够轻松限制区域的可重定位。

      • getMaxWidth

        public final double getMaxWidth​()
        获取属性maxWidth的值。
        Property description:
        覆盖该地区计算出的最大宽度的属性。 只有当区域的内部计算的最大宽度不符合应用程序的布局需要时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxWidth(forHeight)将返回区域内部计算的最大宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxWidth(forHeight)返回区域的首选宽度，使应用程序能够轻松限制区域的可重定位。

      • maxWidthProperty

        public final DoubleProperty maxWidthProperty​()
        覆盖该地区计算出的最大宽度的属性。 只有当区域的内部计算的最大宽度不符合应用程序的布局需要时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxWidth(forHeight)将返回区域内部计算的最大宽度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxWidth(forHeight)返回区域的首选宽度，使应用程序能够轻松限制区域的可重定位。

        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • setMaxHeight

        public final void setMaxHeight​(double value)
        设置属性maxHeight的值。
        Property description:
        覆盖该地区计算出的最大高度的属性。 只有当区域内部计算的最大高度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxHeight(forWidth)将返回区域内部计算的最大高度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxHeight(forWidth)返回该区域的首选高度，从而使应用程序能够轻松地限制该区域的可getMaxHeight(forWidth)性。

      • getMaxHeight

        public final double getMaxHeight​()
        获取属性maxHeight的值。
        Property description:
        覆盖该地区计算出的最大高度的属性。 只有当区域内部计算的最大高度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxHeight(forWidth)将返回区域内部计算的最大高度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxHeight(forWidth)返回该区域的首选高度，从而使应用程序能够轻松限制区域的可getMaxHeight(forWidth)性。

      • maxHeightProperty

        public final DoubleProperty maxHeightProperty​()
        覆盖该地区计算出的最大高度的属性。 只有当区域内部计算的最大高度不符合应用程序的布局需求时，才应设置此值。

        默认为USE_COMPUTED_SIZE标志，这意味着getMaxHeight(forWidth)将返回区域内部计算的最大高度。

        将此值设置为USE_PREF_SIZE标志将导致getMaxHeight(forWidth)返回区域的首选高度，使应用程序能够轻松限制区域的可getMaxHeight(forWidth)性。

        另请参见：
        getMaxHeight() ， setMaxHeight(double)

      • setMaxSize

        public void setMaxSize​(double maxWidth,
                       double maxHeight)
        覆盖区域计算的最大宽度和高度的便捷方法。 只有当区域的内部计算的最大大小不符合应用程序的布局需求时，才应该调用此方法。
        参数
        maxWidth - 最大宽度的覆盖值
        maxHeight - 最大高度的覆盖值
        另请参见：
        setMaxWidth(double) ， setMaxHeight(double)

      • getShape

        public final Shape getShape​()
        获取属性形状的值。
        Property description:
        指定时， Shape将使该区域呈现为指定的形状，而不是圆角矩形。 当为空时，Region将被渲染为圆角矩形。 当渲染为Shape时，任何背景都用于填充形状，尽管任何背景插入将被忽略，如背景半径。 定义的任何BorderStrokes用于抚摸形状。 任何BorderImages都被忽略。
        Default value:
        空值
        从以下版本开始：
        JavaFX 8.0

      • setShape

        public final void setShape​(Shape value)
        设置属性形状的值。
        Property description:
        指定时， Shape将导致该区域被渲染为指定的形状而不是圆角矩形。 当为空时，Region将被渲染为圆角矩形。 当渲染为Shape时，任何背景都用于填充形状，尽管任何背景插入将被忽略，如背景半径。 定义的任何BorderStrokes用于抚摸形状。 任何BorderImages都被忽略。
        Default value:
        空值
        从以下版本开始：
        JavaFX 8.0

      • shapeProperty

        public final ObjectProperty<Shape> shapeProperty​()
        指定时， Shape将导致该区域被渲染为指定的形状而不是圆角矩形。 当为空时，Region将被渲染为圆角矩形。 当渲染为Shape时，任何背景都用于填充形状，尽管任何背景插入将被忽略，如背景半径。 定义的任何BorderStrokes用于抚摸形状。 任何BorderImages都被忽略。
        Default value:
        空值
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getShape() ， setShape(Shape)

      • setScaleShape

        public final void setScaleShape​(boolean value)
        设置属性scaleShape的值。
        Property description:
        指定是否将形状（如果已定义）缩放以匹配“区域”的大小。 true表示形状缩放以适应区域的大小， false表示形状为其源尺寸，其定位取决于centerShape的值。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0

      • isScaleShape

        public final boolean isScaleShape​()
        获取属性scaleShape的值。
        Property description:
        指定是否将形状（如果已定义）缩放以匹配“区域”的大小。 true表示形状缩放以适应区域的大小， false表示形状为其源尺寸，其定位取决于centerShape的值。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0

      • scaleShapeProperty

        public final BooleanProperty scaleShapeProperty​()
        指定是否将形状（如果已定义）缩放以匹配“区域”的大小。 true是指缩放形状以适应区域的大小， false表示形状为其源尺寸，其定位取决于centerShape的值。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isScaleShape() ， setScaleShape(boolean)

      • setCenterShape

        public final void setCenterShape​(boolean value)
        设置属性centerShape的值。
        Property description:
        定义形状是否位于区域的宽度或高度内。 true是指以区域宽度和高度为中心的形状， false表示形状位于其源位置。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0

      • isCenterShape

        public final boolean isCenterShape​()
        获取属性centerShape的值。
        Property description:
        定义形状是否位于区域的宽度或高度内。 true是指以区域宽度和高度为中心的形状， false表示形状位于其源位置。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0

      • centerShapeProperty

        public final BooleanProperty centerShapeProperty​()
        定义形状是否位于区域的宽度或高度内。 true是指以区域宽度和高度为中心的形状， false表示形状位于其源位置。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isCenterShape() ， setCenterShape(boolean)

      • setCacheShape

        public final void setCacheShape​(boolean value)
        设置属性cacheShape的值。
        Property description:
        定义对系统的提示，指出用于定义区域背景的Shape是稳定的，可以从缓存中受益。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0

      • isCacheShape

        public final boolean isCacheShape​()
        获取属性cacheShape的值。
        Property description:
        定义对系统的提示，指出用于定义区域背景的Shape是稳定的，可以从缓存中受益。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0

      • cacheShapeProperty

        public final BooleanProperty cacheShapeProperty​()
        定义对系统的提示，指出用于定义区域背景的Shape是稳定的，可以从缓存中受益。
        Default value:
        真正
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isCacheShape() ， setCacheShape(boolean)

      • isResizable

        public boolean isResizable​()
        由于所有地区都可调整大小，因此返回 true 。
        重写：
        isResizable在 Node
        结果
        该布局期间该节点是否可以由其父节点调整大小
        另请参见：
        Node.getContentBias() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double) ，
Node.resize(double, double) ，
Node.getLayoutBounds()

      • resize

        public void resize​(double width,
                   double height)
        在布局期间由区域的父项调用以设置区域的宽度和高度。 应用程序不应直接调用此方法 。 如果应用程序需要直接设置区域的大小，它应该通过调用覆盖其尺寸限制setMinSize() ， setPrefSize() ，或setMaxSize() ，它的布局过程中父将尊重那些覆盖。
        重写：
        resize在 Node
        参数
        width - 目标布局的边界宽度
        height - 目标布局界限高度
        另请参见：
        Node.isResizable() ，
Node.getContentBias() ，
Node.autosize() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double) ，
Node.getLayoutBounds()

      • minWidth

        public final double minWidth​(double height)
        在布局期间调用以确定此节点的最小宽度。 从computeMinWidth(forHeight)返回值，除非应用程序通过设置minWidth属性来覆盖最小宽度。
        重写：
        minWidth在 Parent
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        在布局期间该节点应该调整大小的最小宽度
        另请参见：
        setMinWidth(double)

      • minHeight

        public final double minHeight​(double width)
        在布局期间调用以确定此节点的最小高度。 从computeMinHeight(forWidth)返回值，除非应用程序通过设置minHeight属性来覆盖最小高度。
        重写：
        minHeight在 Parent
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        在布局期间该节点应该调整大小的最小高度
        另请参见：
        setMinHeight(double)

      • prefWidth

        public final double prefWidth​(double height)
        在布局期间调用以确定此节点的首选宽度。 返回值为computePrefWidth(forHeight)除非应用程序通过设置prefWidth属性来覆盖首选宽度。
        重写：
        prefWidth在 Parent
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        在布局期间该节点应该调整大小的首选宽度
        另请参见：
        setPrefWidth(double)

      • prefHeight

        public final double prefHeight​(double width)
        在布局期间调用以确定此节点的首选高度。 从computePrefHeight(forWidth)返回值，除非应用程序通过设置prefHeight属性来覆盖首选高度。
        重写：
        prefHeight在 Parent
        参数
        width - 如果首选的高度取决于应该使用的宽度
        结果
        在布局期间该节点应该调整大小的首选高度
        另请参见：
        setPrefHeight(double)

      • maxWidth

        public final double maxWidth​(double height)
        在布局期间调用以确定此节点的最大宽度。 从computeMaxWidth(forHeight)返回值，除非应用程序通过设置maxWidth属性来覆盖最大宽度。
        重写：
        maxWidth在 Node
        参数
        height - 如果最大宽度取决于它应该使用的高度
        结果
        在布局期间该节点应该调整大小的最大宽度
        另请参见：
        setMaxWidth(double)

      • maxHeight

        public final double maxHeight​(double width)
        在布局期间调用以确定此节点的最大高度。 从computeMaxHeight(forWidth)返回值，除非应用程序通过设置maxHeight属性来覆盖最大高度。
        重写：
        maxHeight在 Node
        参数
        width - 如果最大高度取决于应该使用的宽度
        结果
        在布局期间该节点应该调整大小的最大高度
        另请参见：
        setMaxHeight(double)

      • computeMinWidth

        protected double computeMinWidth​(double height)
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Parent
        参数
        height - 如果最小宽度取决于它应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Parent
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Parent
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Parent
        参数
        width - 如果首选的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • computeMaxWidth

        protected double computeMaxWidth​(double height)
        计算此区域的最大宽度。 默认情况下返回Double.MAX_VALUE。 区域子类可以覆盖此方法，以根据其内容和布局策略返回不同的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        参数
        height - 区域的高度，以防该值可能决定最大宽度
        结果
        该区域的计算最大宽度

      • computeMaxHeight

        protected double computeMaxHeight​(double width)
        计算该区域的最大高度。 默认情况下返回Double.MAX_VALUE。 区域子类可以覆盖此方法以根据其内容和布局策略返回不同的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        参数
        width - 区域的宽度，以防该值可能指定最大高度
        结果
        计算出该区域的最大高度

      • snapSpace

        @Deprecated(since="9")
protected double snapSpace​(double value)
        已过时。 由snapSpaceX()和snapSpaceY()取代
        如果该区域的snapToPixel属性为false，则此方法返回相同的值，否则它会尝试将值舍入到最近的像素，但是由于没有指示值是垂直还是水平测量，因此可能会被捕捉到具有不同水平和垂直刻度的屏幕上错误的像素尺寸公制。
        参数
        value - 要捕获的空间值
        结果
        值舍入到最近的像素

      • snapSpaceX

        public double snapSpaceX​(double value)
        如果此区域的snapToPixel属性为true，则返回一个舍入为水平方向最近像素的值，否则返回相同的值。
        参数
        value - 要拍摄的空间值
        结果
        值舍入到最近的像素
        从以下版本开始：
        9

      • snapSpaceY

        public double snapSpaceY​(double value)
        如果该区域的snapToPixel属性为true，则返回一个四舍五入到垂直方向上最近的像素的值，否则返回相同的值。
        参数
        value - 要拍摄的空间值
        结果
        值舍入到最近的像素
        从以下版本开始：
        9

      • snapSize

        @Deprecated(since="9")
protected double snapSize​(double value)
        已过时。 替换为snapSizeX()和snapSizeY()
        如果该区域的snapToPixel属性为false，则此方法返回相同的值，否则它会尝试将值舍弃为最近的像素，但是由于没有指示值是垂直还是水平测量，因此可能会被捕捉到具有不同水平和垂直刻度的屏幕上错误的像素尺寸公制。
        参数
        value - 要拍摄的大小值
        结果
        值被忽略到最近的像素

      • snapSizeX

        public double snapSizeX​(double value)
        如果此区域的snapToPixel属性为true，则返回一个值，该值将被忽略到水平方向上最近的像素，否则返回相同的值。
        参数
        value - 要拍摄的大小值
        结果
        值被忽略到最近的像素
        从以下版本开始：
        9

      • snapSizeY

        public double snapSizeY​(double value)
        如果此区域的snapToPixel属性为true，则返回一个值，该值将被忽略到垂直方向上最近的像素，否则返回相同的值。
        参数
        value - 要拍摄的大小值
        结果
        值被忽略到最近的像素
        从以下版本开始：
        9

      • snapPosition

        @Deprecated(since="9")
protected double snapPosition​(double value)
        已过时。 替换为snapPositionX()和snapPositionY()
        如果该区域的snapToPixel属性为false，则此方法返回相同的值，否则它会尝试将值舍入到最近的像素，但是由于没有指示值是垂直还是水平测量，因此可能会被捕捉到具有不同水平和垂直刻度的屏幕上错误的像素尺寸公制。
        参数
        value - 要 value的位置值
        结果
        值舍入到最近的像素

      • snapPositionX

        public double snapPositionX​(double value)
        如果此区域的snapToPixel属性为true，则返回一个舍入为水平方向最近像素的值，否则返回相同的值。
        参数
        value - 要 value的位置值
        结果
        值舍入到最近的像素
        从以下版本开始：
        9

      • snapPositionY

        public double snapPositionY​(double value)
        如果该区域的snapToPixel属性为true，则返回一个四舍五入到垂直方向上最近的像素的值，否则返回相同的值。
        参数
        value - 要 value的位置值
        结果
        值舍入到最近的像素
        从以下版本开始：
        9

      • snappedTopInset

        public final double snappedTopInset​()
        获取包含填充和边框插入的顶层插图的实用方法。 如果isSnapToPixel（）为true，则拍摄到整个像素。
        结果
        圆顶顶
        从以下版本开始：
        JavaFX 8.0

      • snappedBottomInset

        public final double snappedBottomInset​()
        获取底部插图的实用方法，其中包括填充和边框插入。 如果isSnapToPixel（）为true，则拍摄到整个像素。
        结果
        倒圆角的底部
        从以下版本开始：
        JavaFX 8.0

      • snappedLeftInset

        public final double snappedLeftInset​()
        获取包含填充和边框插入的左边插图的实用方法。 如果isSnapToPixel（）为true，则拍摄到整个像素。
        结果
        向左舍入
        从以下版本开始：
        JavaFX 8.0

      • snappedRightInset

        public final double snappedRightInset​()
        获取正确的插图的实用方法，包括填充和边框插入。 如果isSnapToPixel（）为true，则拍摄到整个像素。
        结果
        圆形插图正确
        从以下版本开始：
        JavaFX 8.0

      • positionInArea

        protected void positionInArea​(Node child,
                              double areaX,
                              double areaY,
                              double areaWidth,
                              double areaHeight,
                              double areaBaselineOffset,
                              HPos halignment,
                              VPos valignment)
        通过定义哪个位置该区域的区域内的子工具方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        此功能不调整节点和使用节点的布局界限的宽度和高度，以决定应如何定位的区域内。

        如果垂直对齐是VPos.BASELINE那么它将定位节点，使其自己的基线与baselineOffset传递的基线对齐，否则基线参数将被忽略。

        如果该区域的snapToPixel为true ，那么x / y位置值将舍入为最接近的像素边界。

        参数
        child - 孩子被定位在这个区域内
        areaX - 相对于该区域的布局区域的水平偏移
        areaY - 相对于该区域的布局区域的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果VPos为基线，则使用的基线偏移量
        halignment - 区域内儿童的水平对齐方式
        valignment - 区域内儿童的垂直对齐方式

      • positionInArea

        public static void positionInArea​(Node child,
                                  double areaX,
                                  double areaY,
                                  double areaWidth,
                                  double areaHeight,
                                  double areaBaselineOffset,
                                  Insets margin,
                                  HPos halignment,
                                  VPos valignment,
                                  boolean isSnapToPixel)
        通过定义哪个位置该区域的区域内的子工具方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        此功能不调整节点和使用节点的布局界限的宽度和高度，以决定应如何定位的区域内。

        如果垂直对齐是VPos.BASELINE那么它将定位节点，使其自己的基线与baselineOffset传递的基线对齐，否则基线参数将被忽略。

        如果该区域的snapToPixel是true ，则x / y位置值将被舍入到最接近的像素边界。

        如果margin为非空值，则该空间将在布局区域内的小孩周围分配。 保证金可能为空。

        参数
        child - 孩子被定位在这个区域内
        areaX - 相对于该区域的布局区域的水平偏移
        areaY - 相对于该区域的布局区域的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果VPos为基线，则使用的基线偏移量
        margin - 要在孩子周围分配的空间余量
        halignment - 区域内儿童的水平对齐
        valignment - 区域内儿童的垂直对齐方式
        isSnapToPixel - 是否将尺寸和位置 isSnapToPixel到像素
        从以下版本开始：
        JavaFX 8.0

      • layoutInArea

        protected void layoutInArea​(Node child,
                            double areaX,
                            double areaY,
                            double areaWidth,
                            double areaHeight,
                            double areaBaselineOffset,
                            HPos halignment,
                            VPos valignment)
        其中规定了子由所限定的本地区的区域内实用方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        如果孩子可调整大小，则该方法将调整其大小以填充指定的区域，除非该节点的最大大小阻止它。 如果节点的最大大小偏好小于区域大小，则将使用最大大小。 如果节点的最大值大于区域大小，则节点将被调整大小以适合该区域，除非它的最小大小阻止它。

        如果孩子有一个非空的contentBias，那么这个方法将在调整小孩时使用它。 如果contentBias是水平的，它将首先将其宽度设置为区域的宽度（直到孩子的最大宽度限制），然后传递该值以计算孩子的高度。 如果孩子的contentBias是垂直的，那么它将把它的高度设置为区域高度（最高到孩子的最大高度限制），并传递该高度来计算孩子的宽度。 如果孩子的contentBias为null，那么它的width和height没有彼此的依赖关系。

        如果孩子不能调整大小（Shape，Group等），那么它只能被定位，而不是调整大小。

        如果小孩的大小与区域的大小不同（由于它不是可调整大小，或者是调整大小偏好设置），那么这个函数将使用水平和垂直对齐值来对齐节点。 如果取值为VPos.BASELINE则节点的基线将与区域基线偏移参数对齐，否则基线参数将被忽略。

        如果该区域的snapToPixel是true ，则所得到的x，y值将被舍入到其最近的像素边界，并且宽/高值将被忽略到下一个像素边界。

        参数
        child - 孩子被定位在这个区域内
        areaX - 相对于该区域的布局区域的水平偏移
        areaY - 相对于该区域的布局区域的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果 areaBaselineOffset为基线，则使用的基线偏移量
        halignment - 区域内儿童的水平对齐
        valignment - 区域内儿童的垂直对齐方式

      • layoutInArea

        protected void layoutInArea​(Node child,
                            double areaX,
                            double areaY,
                            double areaWidth,
                            double areaHeight,
                            double areaBaselineOffset,
                            Insets margin,
                            HPos halignment,
                            VPos valignment)
        其中规定了子由所限定的本地区的区域内实用方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        如果孩子可调整大小，则该方法将调整其大小以填充指定的区域，除非该节点的最大大小阻止它。 如果节点的最大大小偏好小于区域大小，则将使用最大大小。 如果节点的最大值大于区域大小，则节点将被调整大小以适合该区域，除非它的最小大小阻止它。

        如果孩子有一个非空的contentBias，那么这个方法将在调整小孩时使用它。 如果contentBias是水平的，它将首先将其宽度设置为区域的宽度（直到孩子的最大宽度限制），然后传递该值以计算孩子的高度。 如果孩子的contentBias是垂直的，那么它将把它的高度设置为区域高度（最高到孩子的最大高度限制），并传递该高度来计算孩子的宽度。 如果孩子的contentBias为null，那么它的width和height没有彼此的依赖关系。

        如果孩子不能调整大小（Shape，Group等），那么它只能被定位，而不是调整大小。

        如果小孩的大小与区域的大小不同（由于它不是可调整大小，或者是调整大小偏好设置），那么这个函数将使用水平和垂直对齐值来对齐节点。 如果取值为VPos.BASELINE则节点的基线将与区域基线偏移参数对齐，否则基线参数将被忽略。

        如果margin为非空值，则该空间将在布局区域内的小孩周围分配。 保证金可能为空。

        如果该区域的snapToPixel是true ，则所得到的x，y值将被舍入到其最近的像素边界，并且宽度/高度值将被忽略到下一个像素边界。

        参数
        child - 孩子被定位在这个区域内
        areaX - 相对于该区域的布局区域的水平偏移
        areaY - 相对于该区域的布局区域的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果VPos为BASELINE，则使用的基线偏移量
        margin - 要分配在孩子周围的空间余量
        halignment - 区域内儿童的水平对齐
        valignment - 区域内儿童的垂直对齐方式

      • layoutInArea

        protected void layoutInArea​(Node child,
                            double areaX,
                            double areaY,
                            double areaWidth,
                            double areaHeight,
                            double areaBaselineOffset,
                            Insets margin,
                            boolean fillWidth,
                            boolean fillHeight,
                            HPos halignment,
                            VPos valignment)
        其中规定了子由所限定的本地区的区域内实用方法areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        如果小孩可调整大小，则此方法将使用fillWidth和fillHeight来确定是否调整其大小以填充该区域或将孩子保持在其首选的尺寸。 如果fillWidth / fillHeight为true，那么此方法将仅调整小孩的大小，直到其最大大小限制。 如果节点的最大大小偏好小于区域大小，则将使用最大大小。 如果节点的最大值大于区域大小，则节点将被调整大小以适合该区域，除非它的最小大小阻止它。

        如果孩子有一个非空的contentBias，那么这个方法将在调整小孩时使用它。 如果contentBias是水平的，它将首先设置它的宽度，然后传递该值来计算孩子的高度。 如果child的contentBias是垂直的，那么它将首先设置它的高度，并传递该值来计算孩子的宽度。 如果孩子的contentBias为null，那么它的width和height没有彼此的依赖关系。

        如果孩子不能调整大小（Shape，Group等），那么它只能被定位，而不是调整大小。

        如果小孩的大小与区域的大小不同（由于它不是可调整大小，或者是调整大小偏好设置），那么这个函数将使用水平和垂直对齐值来对齐节点。 如果取值为VPos.BASELINE则节点的基线将与区域基线偏移参数对齐，否则基线参数将被忽略。

        如果margin为非空值，则该空间将在布局区域内的小孩周围分配。 保证金可能为空。

        如果snapToPixel为该区域的true ，则所得到的x，y值将舍入为最接近的像素边界，宽/高值将被忽略到下一个像素边界。

        参数
        child - 孩子被定位在这个区域内
        areaX - 相对于该区域的布局区域的水平偏移
        areaY - 相对于该区域的布局区域的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果VPOS为BASELINE，则使用的基线偏移量
        margin - 要分配给孩子的空间余量
        fillWidth - 小孩是否应调整大小以填补面积宽度或保持其首选宽度
        fillHeight - 小孩是否应该调整大小以填补区域高度或保持在其首选高度
        halignment - 区域内儿童的水平对齐
        valignment - 区域内儿童的垂直对齐方式

      • layoutInArea

        public static void layoutInArea​(Node child,
                                double areaX,
                                double areaY,
                                double areaWidth,
                                double areaHeight,
                                double areaBaselineOffset,
                                Insets margin,
                                boolean fillWidth,
                                boolean fillHeight,
                                HPos halignment,
                                VPos valignment,
                                boolean isSnapToPixel)
        其中规定了儿童的它的区域内的工具方法的父通过定义areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。

        如果孩子可调整大小，则此方法将使用fillWidth和fillHeight来确定是否调整其大小以填充该区域或将孩子保持在其首选的尺寸。 如果fillWidth / fillHeight为true，那么此方法将仅调整小孩的大小，直到其最大大小限制。 如果节点的最大大小偏好小于区域大小，则将使用最大大小。 如果节点的最大值大于区域大小，则节点将被调整大小以适合该区域，除非它的最小大小阻止它。

        如果孩子有一个非空的contentBias，那么这个方法将在调整小孩时使用它。 如果contentBias是水平的，它将首先设置它的宽度，然后传递该值来计算孩子的高度。 如果child的contentBias是垂直的，那么它将首先设置它的高度，并传递该值来计算孩子的宽度。 如果孩子的contentBias为null，那么它的width和height没有彼此的依赖关系。

        如果孩子不能调整大小（Shape，Group等），那么它只能被定位，而不是调整大小。

        如果小孩的大小与区域的大小不同（由于它不是可调整大小，或者是调整大小偏好设置），那么这个函数将使用水平和垂直对齐值来对齐节点。 如果取值为VPos.BASELINE则节点的基线将与区域基线偏移参数对齐，否则基线参数将被忽略。

        如果margin为非空，则该空间将在布局区域内的小孩周围分配。 保证金可能为空。

        如果snapToPixel是该区域的true ，则所得到的x，y值将被舍入到其最近的像素边界，并且宽/高值将被忽略到下一个像素边界。

        参数
        child - 孩子被定位在这个区域内
        areaX - 相对于该区域的布局区域的水平偏移量
        areaY - 相对于该区域的布局区域的垂直偏移
        areaWidth - 布局区域的宽度
        areaHeight - 布局区域的高度
        areaBaselineOffset - 如果VPos为基线，则使用的基线偏移量
        margin - 要在孩子周围分配的空间余量
        fillWidth - 小孩是否应调整大小以填补面积宽度或保持其首选宽度
        fillHeight - 儿童是否应该调整大小以填补区域高度或保持其首选高度
        halignment - 区域内儿童的水平对齐方式
        valignment - 区域内儿童的垂直对齐方式
        isSnapToPixel - 是否将像素的大小和位置 isSnapToPixel
        从以下版本开始：
        JavaFX 8.0

      • getUserAgentStylesheet

        public String getUserAgentStylesheet​()
        实现可以通过覆盖此方法来为该Region及其子项指定其自己的用户代理样式。 除了正在使用的用户代理样式表之外，还使用了这些样式。 这为第三方提供了引入自定义控件样式的机制。

        URL是[scheme：] [// authority] [path]形式的分层URI。 如果URL没有[scheme：]组件，则该URL仅被认为是[path]组件。 [path]的任何前导的'/'字符被忽略，并且[path]被视为相对于应用程序的类路径的根的路径。

        覆盖此方法的子类不应对其调用的数量和频率采取任何特定的实现方法。 因此，非常不鼓励尝试任何类型的动态实现（即返回不同的用户代理样式表值），因为这种方法将被调用甚至无法保证。 一些JavaFX CSS实现可能会选择缓存这个响应无限期的时间，因此在调用此方法时应该不会期望。

           package com.example.javafx.app; import javafx.application.Application; import javafx.scene.Group; import javafx.scene.Scene; import javafx.stage.Stage; public class MyApp extends Application { @Override public void start(Stage stage) { Scene scene = new Scene(new Group()); scene.getStylesheets().add("/com/example/javafx/app/mystyles.css"); stage.setScene(scene); stage.show(); } public static void main(String[] args) { launch(args); } }
        有关使用CSS与场景图的其他信息，请参阅CSS Reference Guide 。
        结果
        字符串URL
        从以下版本开始：
        JavaFX 8u40

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Node
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RowConstraints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class RowConstraints

  • java.lang.Object
    • javafx.scene.layout.ConstraintsBase
      • javafx.scene.layout.RowConstraints

  • public class RowConstraints
extends ConstraintsBase
    为GridPane中的行定义可选布局约束。 如果为栅格中的行添加了RowConstraints对象，则在计算行的高度和布局时，网格板将使用这些约束值。

    例如，要创建一个10行高50像素的GridPane：

       GridPane gridpane = new GridPane(); for (int i = 0; i < 10; i++) { RowConstraints row = new RowConstraints(50); gridpane.getRowConstraints().add(row); }
    或者，要创建一个GridPane，其中行的宽度为25％，50％，25％
       GridPane gridpane = new GridPane(); RowConstraints row1 = new RowConstraints(); row1.setPercentWidth(25); RowConstraints row2 = new RowConstraints(); row2.setPercentWidth(50); RowConstraints row3 = new RowConstraints(); row3.setPercentWidth(25); gridpane.getRowConstraints().addAll(row1,row2,row3);
    请注意，添加一个空RowConstraints对象的效果是没有设置任何约束，使GridPane仅仅根据其内容的大小偏好和约束计算行的布局。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty fillHeight
      行的垂直填充策略。
      DoubleProperty maxHeight
      行的最大高度。
      DoubleProperty minHeight
      行的最小高度。
      DoubleProperty percentHeight
      行的高度百分比。
      DoubleProperty prefHeight
      行的首选高度。
      ObjectProperty<VPos> valignment
      行的垂直对齐方式。
      ObjectProperty<Priority> vgrow
      该行的垂直成长优先级。

    • Field Summary

      • Fields inherited from class javafx.scene.layout.ConstraintsBase

        CONSTRAIN_TO_PREF

    • 构造方法摘要

      构造方法
      Constructor 描述
      RowConstraints​()
      创建没有设置属性的行约束对象。
      RowConstraints​(double height)
      创建具有固定高度的行约束对象。
      RowConstraints​(double minHeight, double prefHeight, double maxHeight)
      创建具有固定大小范围的行约束对象。
      RowConstraints​(double minHeight, double prefHeight, double maxHeight, Priority vgrow, VPos valignment, boolean fillHeight)
      创建具有固定大小范围，垂直增长优先级，垂直对齐和垂直填充行为的行约束对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanProperty fillHeightProperty​()
      行的垂直填充策略。
      double getMaxHeight​()
      获取属性maxHeight的值。
      double getMinHeight​()
      获取属性minHeight的值。
      double getPercentHeight​()
      获取属性percentHeight的值。
      double getPrefHeight​()
      获取属性prefHeight的值。
      VPos getValignment​()
      获取属性对齐的值。
      Priority getVgrow​()
      获取属性vgrow的值。
      boolean isFillHeight​()
      获取属性fillHeight的值。
      DoubleProperty maxHeightProperty​()
      行的最大高度。
      DoubleProperty minHeightProperty​()
      行的最小高度。
      DoubleProperty percentHeightProperty​()
      行的高度百分比。
      DoubleProperty prefHeightProperty​()
      行的首选高度。
      void setFillHeight​(boolean value)
      设置属性fillHeight的值。
      void setMaxHeight​(double value)
      设置属性maxHeight的值。
      void setMinHeight​(double value)
      设置属性minHeight的值。
      void setPercentHeight​(double value)
      设置属性percentHeight的值。
      void setPrefHeight​(double value)
      设置属性prefHeight的值。
      void setValignment​(VPos value)
      设置属性对齐的值。
      void setVgrow​(Priority value)
      设置属性vgrow的值。
      String toString​()
      返回此 RowConstraints对象的字符串表示形式。
      ObjectProperty<VPos> valignmentProperty​()
      行的垂直对齐方式。
      ObjectProperty<Priority> vgrowProperty​()
      该行的垂直成长优先级。

      • Methods inherited from class javafx.scene.layout.ConstraintsBase

        requestLayout

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • minHeight

        public final DoubleProperty minHeightProperty
        行的最小高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最小高度将被计算为该行内容的最大最小高度。

        另请参见：
        getMinHeight() ， setMinHeight(double)

      • prefHeight

        public final DoubleProperty prefHeightProperty
        行的首选高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着首选高度将被计算为该行内容的最大首选高度。

        另请参见：
        getPrefHeight() ， setPrefHeight(double)

      • maxHeight

        public final DoubleProperty maxHeightProperty
        行的最大高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最大高度将被计算为行内容的最小最大高度。

        另请参见：
        getMaxHeight() ， setMaxHeight(double)

      • percentHeight

        public final DoubleProperty percentHeightProperty
        行的高度百分比。 如果设置为大于0的值，则该行将调整为可用网格高度的百分比，并忽略其他大小约束（minHeight，prefHeight，maxHeight，vgrow）。 默认值为-1，表示该百分比将被忽略。
        另请参见：
        getPercentHeight() ， setPercentHeight(double)

      • vgrow

        public final ObjectProperty<Priority> vgrowProperty
        该行的垂直成长优先级。 如果设置，则如果格网尺寸大于其首选高度，则网格板将使用此优先级来确定该行是否应该被赋予任何额外的高度。 如果设置percentHeight，则忽略此属性。

        此默认值为null，这意味着该行的增长优先级将从内容节点上设置的最大增长优先级派生。

        另请参见：
        getVgrow() ， setVgrow(Priority)

      • valignment

        public final ObjectProperty<VPos> valignmentProperty
        行的垂直对齐方式。 如果设置，将是行中包含的节点的默认垂直对齐方式。 如果此属性设置为VPos.BASELINE，则fillHeight属性将被忽略，并且节点将始终调整为其首选高度。
        另请参见：
        getValignment() ， setValignment(VPos)

      • fillHeight

        public final BooleanProperty fillHeightProperty
        行的垂直填充策略。 网格板将使用此属性来确定包含在行内的节点是否应该被扩展以填充行的高度或保持为其首选高度。

        默认值为true。

        另请参见：
        isFillHeight() ， setFillHeight(boolean)

    • 构造方法详细信息

      • RowConstraints

        public RowConstraints​()
        创建没有设置属性的行约束对象。

      • RowConstraints

        public RowConstraints​(double height)
        创建具有固定高度的行约束对象。 这样可以方便的将首选高度约束设置为固定值，将MinHeight和maxHeight约束设置为USE_PREF_SIZE标志，以确保该行始终为该高度。
        参数
        height - 行的高度

      • RowConstraints

        public RowConstraints​(double minHeight,
                      double prefHeight,
                      double maxHeight)
        创建具有固定大小范围的行约束对象。 这是设置最小，优选和最大高度限制的便利。
        参数
        minHeight - 最小高度
        prefHeight - 优选的高度
        maxHeight - 最大高度

      • RowConstraints

        public RowConstraints​(double minHeight,
                      double prefHeight,
                      double maxHeight,
                      Priority vgrow,
                      VPos valignment,
                      boolean fillHeight)
        创建具有固定大小范围，垂直增长优先级，垂直对齐和垂直填充行为的行约束对象。
        参数
        minHeight - 最小高度
        prefHeight - 优选的高度
        maxHeight - 最大高度
        vgrow - 垂直成长优先
        valignment - 垂直对齐
        fillHeight - 垂直填充行为

    • 方法详细信息

      • setMinHeight

        public final void setMinHeight​(double value)
        设置属性minHeight的值。
        Property description:
        行的最小高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最小高度将被计算为该行内容的最大最小高度。

      • getMinHeight

        public final double getMinHeight​()
        获取属性minHeight的值。
        Property description:
        行的最小高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最小高度将被计算为该行内容的最大最小高度。

      • minHeightProperty

        public final DoubleProperty minHeightProperty​()
        行的最小高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最小高度将被计算为该行内容的最大最小高度。

        另请参见：
        getMinHeight() ， setMinHeight(double)

      • setPrefHeight

        public final void setPrefHeight​(double value)
        设置属性prefHeight的值。
        Property description:
        行的首选高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着首选高度将被计算为该行内容的最大首选高度。

      • getPrefHeight

        public final double getPrefHeight​()
        获取属性prefHeight的值。
        Property description:
        行的首选高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着首选高度将被计算为该行内容的最大首选高度。

      • prefHeightProperty

        public final DoubleProperty prefHeightProperty​()
        行的首选高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着首选高度将被计算为该行内容的最大首选高度。

        另请参见：
        getPrefHeight() ， setPrefHeight(double)

      • setMaxHeight

        public final void setMaxHeight​(double value)
        设置属性maxHeight的值。
        Property description:
        行的最大高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最大高度将被计算为行内容的最小最大高度。

      • getMaxHeight

        public final double getMaxHeight​()
        获取属性maxHeight的值。
        Property description:
        行的最大高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最大高度将被计算为行内容的最小最大高度。

      • maxHeightProperty

        public final DoubleProperty maxHeightProperty​()
        行的最大高度。 如果设置percentHeight，则忽略此属性。

        默认值为USE_COMPUTED_SIZE，这意味着最大高度将被计算为行内容的最小最大高度。

        另请参见：
        getMaxHeight() ， setMaxHeight(double)

      • setPercentHeight

        public final void setPercentHeight​(double value)
        设置属性percentHeight的值。
        Property description:
        行的高度百分比。 如果设置为大于0的值，则该行将调整为可用网格高度的百分比，并忽略其他大小约束（minHeight，prefHeight，maxHeight，vgrow）。 默认值为-1，表示该百分比将被忽略。

      • getPercentHeight

        public final double getPercentHeight​()
        获取属性percentHeight的值。
        Property description:
        行的高度百分比。 如果设置为大于0的值，则该行将调整为可用网格高度的百分比，并忽略其他大小约束（minHeight，prefHeight，maxHeight，vgrow）。 默认值为-1，表示该百分比将被忽略。

      • percentHeightProperty

        public final DoubleProperty percentHeightProperty​()
        行的高度百分比。 如果设置为大于0的值，则该行将调整为可用网格高度的百分比，并忽略其他大小约束（minHeight，prefHeight，maxHeight，vgrow）。 默认值为-1，表示该百分比将被忽略。
        另请参见：
        getPercentHeight() ， setPercentHeight(double)

      • setVgrow

        public final void setVgrow​(Priority value)
        设置属性vgrow的值。
        Property description:
        该行的垂直成长优先级。 如果设置，则如果格网尺寸大于其首选高度，则网格板将使用此优先级来确定该行是否应该被赋予任何额外的高度。 如果设置percentHeight，则忽略此属性。

        此默认值为null，这意味着该行的增长优先级将从内容节点上设置的最大增长优先级派生。

      • getVgrow

        public final Priority getVgrow​()
        获取属性vgrow的值。
        Property description:
        该行的垂直成长优先级。 如果设置，则如果格网尺寸大于其首选高度，则网格板将使用此优先级来确定该行是否应该被赋予任何额外的高度。 如果设置percentHeight，则忽略此属性。

        此默认值为null，这意味着该行的增长优先级将从内容节点上设置的最大增长优先级派生。

      • vgrowProperty

        public final ObjectProperty<Priority> vgrowProperty​()
        该行的垂直成长优先级。 如果设置，则如果格网尺寸大于其首选高度，则网格板将使用此优先级来确定该行是否应该被赋予任何额外的高度。 如果设置percentHeight，则忽略此属性。

        此默认值为null，这意味着该行的增长优先级将从内容节点上设置的最大增长优先级派生。

        另请参见：
        getVgrow() ， setVgrow(Priority)

      • setValignment

        public final void setValignment​(VPos value)
        设置属性对齐的值。
        Property description:
        行的垂直对齐方式。 如果设置，将是行中包含的节点的默认垂直对齐方式。 如果此属性设置为VPos.BASELINE，则fillHeight属性将被忽略，并且节点将始终调整为其首选高度。

      • getValignment

        public final VPos getValignment​()
        获取属性对齐的值。
        Property description:
        行的垂直对齐方式。 如果设置，将是行中包含的节点的默认垂直对齐方式。 如果此属性设置为VPos.BASELINE，则fillHeight属性将被忽略，并且节点将始终调整为其首选高度。

      • valignmentProperty

        public final ObjectProperty<VPos> valignmentProperty​()
        行的垂直对齐方式。 如果设置，将是行中包含的节点的默认垂直对齐方式。 如果此属性设置为VPos.BASELINE，则fillHeight属性将被忽略，并且节点将始终调整为其首选高度。
        另请参见：
        getValignment() ， setValignment(VPos)

      • setFillHeight

        public final void setFillHeight​(boolean value)
        设置属性fillHeight的值。
        Property description:
        行的垂直填充策略。 网格板将使用此属性来确定包含在行内的节点是否应该被扩展以填充行的高度或保持为其首选高度。

        默认值为true。

      • isFillHeight

        public final boolean isFillHeight​()
        获取属性fillHeight的值。
        Property description:
        行的垂直填充策略。 网格板将使用此属性来确定包含在行内的节点是否应该被扩展以填充行的高度或保持为其首选高度。

        默认值为true。

      • fillHeightProperty

        public final BooleanProperty fillHeightProperty​()
        行的垂直填充策略。 网格板将使用此属性来确定包含在行内的节点是否应该被扩展以填充行的高度或保持为其首选高度。

        默认值为true。

        另请参见：
        isFillHeight() ， setFillHeight(boolean)

      • toString

        public String toString​()
        返回此 RowConstraints对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这是 RowConstraints对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StackPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class StackPane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.StackPane
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    TableHeaderRow

    public class StackPane
extends Pane
    StackPane将它的孩子放在一个靠前的堆叠中。

    孩子的z顺序由孩子列表的顺序定义，第0个孩子是顶部的最后一个孩子。 如果设置了一个边框和/或填充，孩子们将被放在这些插图中。

    stackpane将尝试调整每个孩子的大小以填补其内容区域。 如果孩子的大小不能填满stackpane（或者是因为它不能调整大小或者阻止它的最大大小），那么它将使用对齐属性对齐，该对齐属性默认为Pos.CENTER。

    StackPane示例：

       StackPane stack = new StackPane(); stack.getChildren().addAll(new Rectangle(100,100,Color.BLUE), new Label("Go!));

    无论孩子的可见属性值如何，StackPane都会放置每个被管理的小孩; 非托管儿童被忽视。

    StackPane可能使用CSS来设计背景和边框。 详见Region 。

    可调整范围

    stackpane的父级将在布局期间在stackpane的可调整大小范围内调整堆栈堆栈的大小。 默认情况下，stackpane将根据其内容计算此范围，如下表所示。

    StackPane Resize Table width height minimum left/right insets plus the largest of the children's min widths. top/bottom insets plus the largest of the children's min heights. preferred left/right insets plus the largest of the children's pref widths. top/bottom insets plus the largest of the children's pref heights. maximum Double.MAX_VALUE Double.MAX_VALUE

    stackpane的无界最大宽度和高度表示父级可以将其调整大小超出其首选大小，以填充分配给它的空间。

    StackPane提供了直接设置尺寸范围的属性。 这些属性默认为哨兵值USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       // ensure stackpane is never resized beyond it's preferred size stackpane.setMaxSize(Region.USE_PREF_SIZE, Region.USE_PREF_SIZE);
    应用程序可以通过将这些属性设置回USE_COMPUTED_SIZE来恢复计算值。

    默认情况下，StackPane不会剪切其内容，所以如果孩子的最小大小阻止它在文件夹中适合，那么儿童的边界可能会延伸到自己的边界之外。

    可选布局限制

    应用程序可以设置对各个孩子的约束，以自定义StackPane的布局。 对于每个约束，StackPane提供了一个静态方法来设置它在孩子上。

    StackPane Constraint Table Constraint Type Description alignment javafx.geometry.Pos The alignment of the child within the stackpane. margin javafx.geometry.Insets Margin space around the outside of the child.

    例子：

       // Align the title Label at the bottom-center of the stackpane Label title = new Label(); StackPane.setAlignment(title, Pos.BOTTOM_CENTER); stackpane.getChildren.addAll(new ImageView(...), title); // Create an 8 pixel margin around a listview in the stackpane ListView list = new ListView(); StackPane.setMargin(list, new Insets(8,8,8,8); stackpane.getChildren().add(list);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Pos> alignment
      在stackpane的宽度和高度内的子项的默认对齐方式。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      StackPane​()
      使用默认CENTER对齐方式创建StackPane布局。
      StackPane​(Node... children)
      使用默认CENTER对齐方式创建StackPane布局。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Pos> alignmentProperty​()
      在stackpane的宽度和高度内的子项的默认对齐方式。
      static void clearConstraints​(Node child)
      从子节点中删除所有stackpane约束。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      Pos getAlignment​()
      获取属性对齐的值。
      static Pos getAlignment​(Node child)
      如果设置，返回小孩的对齐约束。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      static Insets getMargin​(Node child)
      如果设置，返回小孩的边距约束。
      protected void layoutChildren​()
      在布局传递期间调用这个 Parent的孩子。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。
      void setAlignment​(Pos value)
      设置属性对齐的值。
      static void setAlignment​(Node child, Pos value)
      设置子堆栈的对齐方式。
      static void setMargin​(Node child, Insets value)
      设置一个堆栈包含的小孩的边距。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • alignment

        public final ObjectProperty<Pos> alignmentProperty
        在stackpane的宽度和高度内的子项的默认对齐方式。 这可以通过设置孩子的对齐约束来覆盖个别孩子。
        另请参见：
        getAlignment() ， setAlignment(Pos)

    • 构造方法详细信息

      • StackPane

        public StackPane​()
        使用默认CENTER对齐方式创建StackPane布局。

      • StackPane

        public StackPane​(Node... children)
        使用默认CENTER对齐方式创建StackPane布局。
        参数
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setAlignment

        public static void setAlignment​(Node child,
                                Pos value)
        设置子堆栈的对齐方式。 如果设置，将覆盖stackpane的默认对齐方式。 将值设置为null将删除约束。
        参数
        child - child的子节点
        value - 孩子的对齐位置

      • getAlignment

        public static Pos getAlignment​(Node child)
        如果设置，返回小孩的对齐约束。
        参数
        child - child的子节点
        结果
        小孩的对齐位置，如果没有设置对齐，则为空

      • setMargin

        public static void setMargin​(Node child,
                             Insets value)
        设置一个堆栈包含的小孩的边距。 如果设置，stackpane将布局孩子周围的边距空间。 将值设置为null将删除约束。
        参数
        child - child的子节点
        value - 孩子周围的空间

      • getMargin

        public static Insets getMargin​(Node child)
        如果设置，返回小孩的边距约束。
        参数
        child - child的子节点
        结果
        小孩的保证金，如果没有设置保证金，则为null

      • clearConstraints

        public static void clearConstraints​(Node child)
        从子节点中删除所有stackpane约束。
        参数
        child - 子节点

      • alignmentProperty

        public final ObjectProperty<Pos> alignmentProperty​()
        在stackpane的宽度和高度内的子项的默认对齐方式。 这可以通过设置孩子的对齐约束来覆盖个别孩子。
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • setAlignment

        public final void setAlignment​(Pos value)
        设置属性对齐的值。
        Property description:
        在stackpane的宽度和高度内的子项的默认对齐方式。 这可以通过设置孩子的对齐约束来覆盖个别孩子。

      • getAlignment

        public final Pos getAlignment​()
        获取属性对齐的值。
        Property description:
        在stackpane的宽度和高度内的子项的默认对齐方式。 这可以通过设置孩子的对齐约束来覆盖个别孩子。

      • getContentBias

        public Orientation getContentBias​()
        描述从类别复制： Node
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        重写：
        getContentBias在 Node
        结果
        被管理子项的第一个非空的contentBias，如果没有被管理的孩子有内容偏差，则为null。
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • computeMinWidth

        protected double computeMinWidth​(double height)
        描述从类复制： Region
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        描述从类复制： Region
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        描述从类复制： Region
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        描述从类复制： Region
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • requestLayout

        public void requestLayout​()
        描述从类复制： Parent
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果此父对象是布局根或非托管，则将直接添加到场景的脏布局列表中，否则将调用requestParentLayout。

        重写：
        requestLayout在 Parent

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Parent
        在布局传递期间调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TilePane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class TilePane

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.TilePane
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class TilePane
extends Pane
    TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。

    水平tilepane（默认）将以行的方式平铺节点，以瓦片宽度包装。 垂直tilepane将在列中平铺节点，以tilepane的高度包装。

    每个“瓷砖”的大小默认为涵盖瓦楞纸板儿童的最大优选宽度和高度所需的大小，并且瓦楞纸板将根据需要重新计算拼贴块的大小，以便在更改时适应其子代的最大优选大小。 应用程序还可以通过将prefTileWidth / prefTileHeight属性设置为除USE_COMPUTED_SIZE（默认值）之外的值来直接控制瓦片的大小。

    应用程序应初始化prefColumns （水平）或prefRows （垂直），以建立tilepane的首选大小（任意默认值为5）。 请注意，prefColumns / prefRows仅用于计算首选大小，可能不反映实际的行数或列数，这可能会随着tilepane的大小调整而改变，并且tile将以实际边界包装。

    对齐属性控制行和列如何在tilepane的边界内对齐，并且默认为Pos.TOP_LEFT。 还可以通过设置tileAlignment来控制各个图块中的节点对齐，默认为Pos.CENTER。

    水平tilepane示例：

       TilePane tile = new TilePane(); tile.setHgap(8); tile.setPrefColumns(4); for (int i = 0; i < 20; i++) { tile.getChildren().add(new ImageView(...)); }

    垂直TilePane示例：

       TilePane tile = new TilePane(Orientation.VERTICAL); tile.setTileAlignment(Pos.CENTER_LEFT); tile.setPrefRows(10); for (int i = 0; i < 50; i++) { tile.getChildren().add(new ImageView(...)); }
    TilePane将尝试调整每个孩子的大小以填充其图块。 如果孩子的大小不能填满瓷砖（因为它不是可调整大小或阻止它的大小限制），那么它将使用tileAlignment在瓷砖内对齐。

    可调整范围

    tilepane的父级将在布局期间在tilepane的可调整大小的范围内调整tilepane的大小。 默认情况下，tilepane将基于其内容计算此范围，如下表所示。

    Horizontal width height minimum left/right insets plus the tile width. top/bottom insets plus height required to display all tiles when wrapped at a specified width with a vgap between each row. preferred left/right insets plus prefColumns multiplied by the tile width. top/bottom insets plus height required to display all tiles when wrapped at a specified width with a vgap between each row. maximum Double.MAX_VALUE Double.MAX_VALUE

    Vertical width height minimum left/right insets plus width required to display all tiles when wrapped at a specified height with an hgap between each column. top/bottom insets plus the tile height. preferred left/right insets plus width required to display all tiles when wrapped at the specified height with an hgap between each column. top/bottom insets plus prefRows multiplied by the tile height. maximum Double.MAX_VALUE Double.MAX_VALUE

    瓦楞纸板的无界最大宽度和高度是对父母的指示，它可以调整大小超出其首选尺寸，以填充分配给它的任何空间。

    TilePane提供了直接设置尺寸范围的属性。 这些属性默认为哨兵值Region.USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       <b>tilepane.setMaxWidth(500);</b>
    应用程序可以通过将这些属性设置回Region.USE_COMPUTED_SIZE来还原计算值。

    默认情况下，TilePane不会剪切其内容，因此如果孩子的pref大小阻止其贴合在其图块中，则儿童的边界可能会延伸到图块之外（也可能是tilepane边界）。 另外，如果tilepane的大小小于其首选大小，则可能无法将所有的tile都放在其边界内，并且内容将在外部扩展。

    可选布局限制

    应用程序可以设置对各个孩子的约束，以自定义TilePane的布局。 对于每个约束，TilePane提供了一种静态方法，用于在孩子上设置它。

    TilePane Constraint Table Constraint Type Description alignment javafx.geometry.Pos The alignment of the child within its tile. margin javafx.geometry.Insets Margin space around the outside of the child.

    例：

       TilePane tilepane = new TilePane(); for (int i = 0; i < 20; i++) { Label title = new Label(imageTitle[i]): Imageview imageview = new ImageView(new Image(imageName[i])); TilePane.setAlignment(label, Pos.BOTTOM_RIGHT); tilepane.getChildren().addAll(title, imageview); }
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Pos> alignment
      瓦楞纸板内容在其宽度和高度之间的整体对齐。
      DoubleProperty hgap
      一行中每个图块之间的水平空间量。
      ObjectProperty<Orientation> orientation
      这个瓦片的方向。
      IntegerProperty prefColumns
      水平瓦片的首选列数。
      IntegerProperty prefRows
      垂直瓦片的首选行数。
      DoubleProperty prefTileHeight
      每个瓷砖的首选高度。
      DoubleProperty prefTileWidth
      每个瓷砖的首选宽度。
      ObjectProperty<Pos> tileAlignment
      每个孩子在其图块中的默认对齐方式。
      ReadOnlyDoubleProperty tileHeight
      每个瓷砖的实际高度。
      ReadOnlyDoubleProperty tileWidth
      每个瓷砖的实际宽度。
      DoubleProperty vgap
      列中每个图块之间的垂直空间量。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TilePane​()
      创建一个水平的TilePane布局，其中prefColumn = 5和hgap / vgap = 0。
      TilePane​(double hgap, double vgap)
      创建一个水平的TilePane布局，其中prefColumn = 5和指定的hgap / vgap。
      TilePane​(double hgap, double vgap, Node... children)
      创建一个水平的TilePane布局，其中prefColumn = 5和指定的hgap / vgap。
      TilePane​(Orientation orientation)
      创建具有指定方向的TilePane布局，prefColumn / prefRows = 5和hgap / vgap = 0。
      TilePane​(Orientation orientation, double hgap, double vgap)
      使用指定的方向hgap / vgap和prefRows / prefColumns = 5创建TilePane布局。
      TilePane​(Orientation orientation, double hgap, double vgap, Node... children)
      使用指定的方向hgap / vgap和prefRows / prefColumns = 5创建TilePane布局。
      TilePane​(Orientation orientation, Node... children)
      创建具有指定方向的TilePane布局，prefColumn / prefRows = 5和hgap / vgap = 0。
      TilePane​(Node... children)
      创建一个水平的TilePane布局，其中prefColumn = 5和hgap / vgap = 0。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Pos> alignmentProperty​()
      瓦楞纸板内容在其宽度和高度之间的整体对齐。
      static void clearConstraints​(Node child)
      从子节点中删除所有瓦楞纸板约束。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double forWidth)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double forHeight)
      计算给定高度的该区域的首选宽度。
      Pos getAlignment​()
      获取属性对齐的值。
      static Pos getAlignment​(Node node)
      如果设置，返回小孩的对齐约束。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
      double getHgap​()
      获取属性hgap的值。
      static Insets getMargin​(Node node)
      如果设置，返回小孩的边距约束。
      Orientation getOrientation​()
      获取属性方向的值。
      int getPrefColumns​()
      获取属性prefColumns的值。
      int getPrefRows​()
      获取属性prefRows的值。
      double getPrefTileHeight​()
      获取属性prefTileHeight的值。
      double getPrefTileWidth​()
      获取属性prefTileWidth的值。
      Pos getTileAlignment​()
      获取属性tileAlignment的值。
      double getTileHeight​()
      获取属性tileHeight的值。
      double getTileWidth​()
      获取属性tileWidth的值。
      double getVgap​()
      获取属性vgap的值。
      DoubleProperty hgapProperty​()
      一行中每个图块之间的水平空间量。
      protected void layoutChildren​()
      在布局传递期间调用这个 Parent来布局孩子。
      ObjectProperty<Orientation> orientationProperty​()
      这个瓦片的方向。
      IntegerProperty prefColumnsProperty​()
      水平瓦片的首选列数。
      IntegerProperty prefRowsProperty​()
      垂直瓦片的首选行数。
      DoubleProperty prefTileHeightProperty​()
      每个瓷砖的首选高度。
      DoubleProperty prefTileWidthProperty​()
      每个瓷砖的首选宽度。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。
      void setAlignment​(Pos value)
      设置属性对齐的值。
      static void setAlignment​(Node node, Pos value)
      设置小屋的对齐方式，包含在tilepane中。
      void setHgap​(double value)
      设置属性hgap的值。
      static void setMargin​(Node node, Insets value)
      设置小孩的边框，当包含一个瓦楞纸板时。
      void setOrientation​(Orientation value)
      设置属性方向的值。
      void setPrefColumns​(int value)
      设置属性prefColumns的值。
      void setPrefRows​(int value)
      设置属性prefRows的值。
      void setPrefTileHeight​(double value)
      设置属性prefTileHeight的值。
      void setPrefTileWidth​(double value)
      设置属性prefTileWidth的值。
      void setTileAlignment​(Pos value)
      设置属性tileAlignment的值。
      void setVgap​(double value)
      设置属性vgap的值。
      ObjectProperty<Pos> tileAlignmentProperty​()
      每个孩子在其图块中的默认对齐方式。
      ReadOnlyDoubleProperty tileHeightProperty​()
      每个瓷砖的实际高度。
      ReadOnlyDoubleProperty tileWidthProperty​()
      每个瓷砖的实际宽度。
      DoubleProperty vgapProperty​()
      列中每个图块之间的垂直空间量。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • orientation

        public final ObjectProperty<Orientation> orientationProperty
        这个瓦片的方向。 一个水平的瓦楞纸板将瓷砖中的孩子从左到右放置在瓦楞纸板的宽度边界处。 垂直的瓦楞纸板将儿童放在瓷砖中，从上到下，包裹在瓦砾的高度。 默认为水平。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • prefRows

        public final IntegerProperty prefRowsProperty
        垂直瓦片的首选行数。 该值仅用于计算瓦楞纸板的首选尺寸，并且可能不反映实际的行数，如果将tilepane调整为除其首选高度之外的其他值，则可能会改变。 对于水平瓦片，忽略此属性。

        建议应用程序初始化此值作为垂直瓦片。

        另请参见：
        getPrefRows() ， setPrefRows(int)

      • prefColumns

        public final IntegerProperty prefColumnsProperty
        水平瓦片的首选列数。 该值仅用于计算瓦楞纸板的首选尺寸，并且可能不反映实际的行数，如果将tilepane调整为除其首选高度之外的其他值，则可能会改变。 对于垂直图块，忽略此属性。

        建议应用程序为水平瓦片初始化此值。

        另请参见：
        getPrefColumns() ， setPrefColumns(int)

      • prefTileWidth

        public final DoubleProperty prefTileWidthProperty
        每个瓷砖的首选宽度。 如果等于USE_COMPUTED_SIZE（默认值），当儿童的首选大小更改以适应最宽的孩子时，tile tile将自动重新计算瓦片宽度wlll。 如果应用程序将此属性设置为大于0的值，则tile将被设置为该宽度，并且tilepane将尝试调整小孩大小以适应该宽度（如果它们可调整大小，并且最小 - 最大宽度范围允许）。
        另请参见：
        getPrefTileWidth() ， setPrefTileWidth(double)

      • prefTileHeight

        public final DoubleProperty prefTileHeightProperty
        每个瓷砖的首选高度。 如果等于USE_COMPUTED_SIZE（默认值），当儿童的首选大小更改为容纳最高的孩子时，tile tile会自动重新计算瓦片高度wll。 如果应用程序将此属性设置为大于0的值，则tile将被设置为该高度，并且tilepane将尝试调整儿童大小以适应该高度（如果它们可调整大小，并且其最小 - 最大高度范围允许）。
        另请参见：
        getPrefTileHeight() ， setPrefTileHeight(double)

      • tileWidth

        public final ReadOnlyDoubleProperty tileWidthProperty
        每个瓷砖的实际宽度。 此属性为只读。
        另请参见：
        getTileWidth()

      • tileHeight

        public final ReadOnlyDoubleProperty tileHeightProperty
        每个瓷砖的实际高度。 此属性为只读。
        另请参见：
        getTileHeight()

      • hgap

        public final DoubleProperty hgapProperty
        一行中每个图块之间的水平空间量。
        另请参见：
        getHgap() ， setHgap(double)

      • vgap

        public final DoubleProperty vgapProperty
        列中每个图块之间的垂直空间量。
        另请参见：
        getVgap() ， setVgap(double)

      • alignment

        public final ObjectProperty<Pos> alignmentProperty
        瓦楞纸板内容在其宽度和高度之间的整体对齐。

        对于水平瓦片，每行将使用对齐方式的hpos值在tilepane的宽度内对齐，并使用对齐方式的vpos值在各个tilepane的高度内对齐行。

        对于垂直瓦片，每列将使用对齐的vpos值在tilepane的高度内对齐，并且列将使用对齐的hpos值在tilepane的宽度内对齐。

        另请参见：
        getAlignment() ， setAlignment(Pos)

      • tileAlignment

        public final ObjectProperty<Pos> tileAlignmentProperty
        每个孩子在其图块中的默认对齐方式。 这可以通过设置孩子的对齐约束来覆盖个别孩子。
        另请参见：
        getTileAlignment() ， setTileAlignment(Pos)

    • 构造方法详细信息

      • TilePane

        public TilePane​()
        创建一个水平的TilePane布局，其中prefColumn = 5和hgap / vgap = 0。

      • TilePane

        public TilePane​(Orientation orientation)
        创建具有指定方向的TilePane布局，prefColumn / prefRows = 5和hgap / vgap = 0。
        参数
        orientation - 瓦片应该流动和包裹的方向

      • TilePane

        public TilePane​(double hgap,
                double vgap)
        创建一个水平的TilePane布局，其中prefColumn = 5和指定的hgap / vgap。
        参数
        hgap - 每个图块之间的水平空间量
        vgap - 每个图块之间的垂直空间量

      • TilePane

        public TilePane​(Orientation orientation,
                double hgap,
                double vgap)
        使用指定的方向hgap / vgap和prefRows / prefColumns = 5创建TilePane布局。
        参数
        orientation - 瓦片应该流动和包裹的方向
        hgap - 每个图块之间的水平空间量
        vgap - 每个图块之间的垂直空间量

      • TilePane

        public TilePane​(Node... children)
        创建一个水平的TilePane布局，其中prefColumn = 5和hgap / vgap = 0。
        参数
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

      • TilePane

        public TilePane​(Orientation orientation,
                Node... children)
        创建具有指定方向的TilePane布局，prefColumn / prefRows = 5和hgap / vgap = 0。
        参数
        orientation - 瓦片应该流动和包裹的方向
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

      • TilePane

        public TilePane​(double hgap,
                double vgap,
                Node... children)
        创建一个水平的TilePane布局，其中prefColumn = 5和指定的hgap / vgap。
        参数
        hgap - 每个图块之间的水平空间量
        vgap - 每个图块之间的垂直空间量
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

      • TilePane

        public TilePane​(Orientation orientation,
                double hgap,
                double vgap,
                Node... children)
        使用指定的方向hgap / vgap和prefRows / prefColumns = 5创建TilePane布局。
        参数
        orientation - 瓦片应该流动和包裹的方向
        hgap - 每个图块之间的水平空间量
        vgap - 每个图块之间的垂直空间量
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setAlignment

        public static void setAlignment​(Node node,
                                Pos value)
        设置小屋的对齐方式，包含在tilepane中。 如果设置，将覆盖其“tile”中的小孩的tilepane的默认对齐方式。 将值设置为null将删除约束。
        参数
        node - node的子节点
        value - 孩子的对齐位置

      • getAlignment

        public static Pos getAlignment​(Node node)
        如果设置，返回小孩的对齐约束。
        参数
        node - node的子节点
        结果
        小孩的对齐位置，如果没有设置对齐，则为空

      • setMargin

        public static void setMargin​(Node node,
                             Insets value)
        设置小孩的边框，当包含一个瓦楞纸板时。 如果设置，tilepane将布局孩子周围的边距空间。 将值设置为null将删除约束。
        参数
        node - node的子节点
        value - 孩子周围的空间

      • getMargin

        public static Insets getMargin​(Node node)
        如果设置，返回小孩的边距约束。
        参数
        node - node的子节点
        结果
        小孩的保证金，如果没有设置保证金，则为null

      • clearConstraints

        public static void clearConstraints​(Node child)
        从子节点中删除所有瓦楞纸板约束。
        参数
        child - 子节点

      • orientationProperty

        public final ObjectProperty<Orientation> orientationProperty​()
        这个瓦片的方向。 一个水平的瓦楞纸板将瓷砖中的孩子从左到右放置在瓦楞纸板的宽度边界处。 垂直的瓦楞纸板将儿童放在瓷砖中，从上到下，包裹在瓦砾的高度。 默认为水平。
        另请参见：
        getOrientation() ， setOrientation(Orientation)

      • setOrientation

        public final void setOrientation​(Orientation value)
        设置属性方向的值。
        Property description:
        这个瓦片的方向。 一个水平的瓦楞纸板将瓷砖中的孩子从左到右放置在瓦楞纸板的宽度边界处。 垂直的瓦楞纸板将儿童放在瓷砖中，从上到下，包裹在瓦砾的高度。 默认为水平。

      • getOrientation

        public final Orientation getOrientation​()
        获取属性方向的值。
        Property description:
        这个瓦片的方向。 一个水平的瓦楞纸板将瓷砖中的孩子从左到右放置在瓦楞纸板的宽度边界处。 垂直的瓦楞纸板将儿童放在瓷砖中，从上到下，包裹在瓦砾的高度。 默认为水平。

      • prefRowsProperty

        public final IntegerProperty prefRowsProperty​()
        垂直瓦片的首选行数。 该值仅用于计算瓦楞纸板的首选尺寸，并且可能不反映实际的行数，如果将tilepane调整为除其首选高度之外的其他值，则可能会改变。 对于水平瓦片，忽略此属性。

        建议应用程序初始化此值作为垂直瓦片。

        另请参见：
        getPrefRows() ， setPrefRows(int)

      • setPrefRows

        public final void setPrefRows​(int value)
        设置属性prefRows的值。
        Property description:
        垂直瓦片的首选行数。 该值仅用于计算瓦楞纸板的首选尺寸，并且可能不反映实际的行数，如果将tilepane调整为除其首选高度之外的其他值，则可能会改变。 对于水平瓦片，忽略此属性。

        建议应用程序初始化此值作为垂直瓦片。

      • getPrefRows

        public final int getPrefRows​()
        获取属性prefRows的值。
        Property description:
        垂直瓦片的首选行数。 该值仅用于计算瓦楞纸板的首选尺寸，并且可能不反映实际的行数，如果将tilepane调整为除其首选高度之外的其他值，则可能会改变。 对于水平瓦片，忽略此属性。

        建议应用程序初始化此值作为垂直瓦片。

      • prefColumnsProperty

        public final IntegerProperty prefColumnsProperty​()
        水平瓦片的首选列数。 该值仅用于计算瓦楞纸板的首选尺寸，并且可能不反映实际的行数，如果将tilepane调整为除其首选高度之外的其他值，则可能会改变。 对于垂直图块，忽略此属性。

        建议应用程序为水平瓦片初始化此值。

        另请参见：
        getPrefColumns() ， setPrefColumns(int)

      • setPrefColumns

        public final void setPrefColumns​(int value)
        设置属性prefColumns的值。
        Property description:
        水平瓦片的首选列数。 该值仅用于计算瓦楞纸板的首选尺寸，并且可能不反映实际的行数，如果将tilepane调整为除其首选高度之外的其他值，则可能会改变。 对于垂直图块，忽略此属性。

        建议应用程序为水平瓦片初始化此值。

      • getPrefColumns

        public final int getPrefColumns​()
        获取属性prefColumns的值。
        Property description:
        水平瓦片的首选列数。 该值仅用于计算瓦楞纸板的首选尺寸，并且可能不反映实际的行数，如果将tilepane调整为除其首选高度之外的其他值，则可能会改变。 对于垂直图块，忽略此属性。

        建议应用程序为水平瓦片初始化此值。

      • prefTileWidthProperty

        public final DoubleProperty prefTileWidthProperty​()
        每个瓷砖的首选宽度。 如果等于USE_COMPUTED_SIZE（默认值），当儿童的首选大小更改以适应最宽的孩子时，tile tile将自动重新计算瓦片宽度wlll。 如果应用程序将此属性设置为大于0的值，则tile将被设置为该宽度，并且tilepane将尝试调整小孩大小以适应该宽度（如果它们可调整大小，并且最小 - 最大宽度范围允许）。
        另请参见：
        getPrefTileWidth() ， setPrefTileWidth(double)

      • setPrefTileWidth

        public final void setPrefTileWidth​(double value)
        设置属性prefTileWidth的值。
        Property description:
        每个瓷砖的首选宽度。 如果等于USE_COMPUTED_SIZE（默认值），当儿童的首选大小更改以适应最宽的孩子时，tile tile将自动重新计算瓦片宽度wlll。 如果应用程序将此属性设置为大于0的值，则tile将被设置为该宽度，并且tilepane将尝试调整小孩大小以适应该宽度（如果它们可调整大小，并且最小 - 最大宽度范围允许）。

      • getPrefTileWidth

        public final double getPrefTileWidth​()
        获取属性prefTileWidth的值。
        Property description:
        每个瓷砖的首选宽度。 如果等于USE_COMPUTED_SIZE（默认值），当儿童的首选大小更改以适应最宽的孩子时，tile tile将自动重新计算瓦片宽度wlll。 如果应用程序将此属性设置为大于0的值，则tile将被设置为该宽度，并且tilepane将尝试调整小孩大小以适应该宽度（如果它们可调整大小，并且最小 - 最大宽度范围允许）。

      • prefTileHeightProperty

        public final DoubleProperty prefTileHeightProperty​()
        每个瓷砖的首选高度。 如果等于USE_COMPUTED_SIZE（默认值），当儿童的首选大小更改为容纳最高的孩子时，tile tile会自动重新计算瓦片高度wll。 如果应用程序将此属性设置为大于0的值，则tile将被设置为该高度，并且tilepane将尝试调整儿童大小以适应该高度（如果它们可调整大小，并且其最小 - 最大高度范围允许）。
        另请参见：
        getPrefTileHeight() ， setPrefTileHeight(double)

      • setPrefTileHeight

        public final void setPrefTileHeight​(double value)
        设置属性prefTileHeight的值。
        Property description:
        每个瓷砖的首选高度。 如果等于USE_COMPUTED_SIZE（默认值），当儿童的首选大小更改为容纳最高的孩子时，tile tile会自动重新计算瓦片高度wll。 如果应用程序将此属性设置为大于0的值，则tile将被设置为该高度，并且tilepane将尝试调整儿童大小以适应该高度（如果它们可调整大小，并且其最小 - 最大高度范围允许）。

      • getPrefTileHeight

        public final double getPrefTileHeight​()
        获取属性prefTileHeight的值。
        Property description:
        每个瓷砖的首选高度。 如果等于USE_COMPUTED_SIZE（默认值），当儿童的首选大小更改为容纳最高的孩子时，tile tile会自动重新计算瓦片高度wll。 如果应用程序将此属性设置为大于0的值，则tile将被设置为该高度，并且tilepane将尝试调整儿童大小以适应该高度（如果它们可调整大小，并且其最小 - 最大高度范围允许）。

      • tileWidthProperty

        public final ReadOnlyDoubleProperty tileWidthProperty​()
        每个瓷砖的实际宽度。 此属性为只读。
        另请参见：
        getTileWidth()

      • getTileWidth

        public final double getTileWidth​()
        获取属性tileWidth的值。
        Property description:
        每个瓷砖的实际宽度。 此属性为只读。

      • tileHeightProperty

        public final ReadOnlyDoubleProperty tileHeightProperty​()
        每个瓷砖的实际高度。 此属性为只读。
        另请参见：
        getTileHeight()

      • getTileHeight

        public final double getTileHeight​()
        获取属性tileHeight的值。
        Property description:
        每个瓷砖的实际高度。 此属性为只读。

      • hgapProperty

        public final DoubleProperty hgapProperty​()
        一行中每个图块之间的水平空间量。
        另请参见：
        getHgap() ， setHgap(double)

      • setHgap

        public final void setHgap​(double value)
        设置属性hgap的值。
        Property description:
        一行中每个图块之间的水平空间量。

      • getHgap

        public final double getHgap​()
        获取属性hgap的值。
        Property description:
        一行中每个图块之间的水平空间量。

      • vgapProperty

        public final DoubleProperty vgapProperty​()
        列中每个图块之间的垂直空间量。
        另请参见：
        getVgap() ， setVgap(double)

      • setVgap

        public final void setVgap​(double value)
        设置属性vgap的值。
        Property description:
        列中每个图块之间的垂直空间量。

      • getVgap

        public final double getVgap​()
        获取属性vgap的值。
        Property description:
        列中每个图块之间的垂直空间量。

      • alignmentProperty

        public final ObjectProperty<Pos> alignmentProperty​()
        瓦楞纸板内容在其宽度和高度之间的整体对齐。

        对于水平瓦片，每行将使用对齐方式的hpos值在tilepane的宽度内对齐，并使用对齐方式的vpos值在各个tilepane的高度内对齐行。

        对于垂直瓦片，每列将使用对齐的vpos值在tilepane的高度内对齐，并且列将使用对齐的hpos值在tilepane的宽度内对齐。

        另请参见：
        getAlignment() ， setAlignment(Pos)

      • setAlignment

        public final void setAlignment​(Pos value)
        设置属性对齐的值。
        Property description:
        瓦楞纸板内容在其宽度和高度之间的整体对齐。

        对于水平瓦片，每行将使用对齐方式的hpos值在tilepane的宽度内对齐，并使用对齐方式的vpos值在各个tilepane的高度内对齐行。

        对于垂直瓦片，每列将使用对齐的vpos值在tilepane的高度内对齐，并且列将使用对齐的hpos值在tilepane的宽度内对齐。

      • getAlignment

        public final Pos getAlignment​()
        获取属性对齐的值。
        Property description:
        瓦楞纸板内容在其宽度和高度之间的整体对齐。

        对于水平瓦片，每行将使用对齐方式的hpos值在tilepane的宽度内对齐，并使用对齐方式的vpos值在各个tilepane的高度内对齐行。

        对于垂直瓦片，每列将使用对齐的vpos值在tilepane的高度内对齐，并且列将使用对齐的hpos值在tilepane的宽度内对齐。

      • tileAlignmentProperty

        public final ObjectProperty<Pos> tileAlignmentProperty​()
        每个孩子在其图块中的默认对齐方式。 这可以通过设置孩子的对齐约束来覆盖个别孩子。
        另请参见：
        getTileAlignment() ， setTileAlignment(Pos)

      • setTileAlignment

        public final void setTileAlignment​(Pos value)
        设置属性tileAlignment的值。
        Property description:
        每个孩子在其图块中的默认对齐方式。 这可以通过设置孩子的对齐约束来覆盖个别孩子。

      • getTileAlignment

        public final Pos getTileAlignment​()
        获取属性tileAlignment的值。
        Property description:
        每个孩子在其图块中的默认对齐方式。 这可以通过设置孩子的对齐约束来覆盖个别孩子。

      • getContentBias

        public Orientation getContentBias​()
        描述从类复制： Node
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        重写：
        getContentBias在 Node
        结果
        width / height依赖的方向，如果没有则为null
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • requestLayout

        public void requestLayout​()
        描述从类复制： Parent
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果此父对象是布局根或非托管，则将直接添加到场景的脏布局列表中，否则将调用requestParentLayout。

        重写：
        requestLayout在 Parent

      • computeMinWidth

        protected double computeMinWidth​(double height)
        描述从类复制： Region
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于它应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        描述从类复制： Region
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于它应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double forHeight)
        描述从类： Region复制
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        forHeight - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double forWidth)
        描述从类别复制： Region
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        forWidth - 如果首选高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Parent
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.layout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.layout

  • Packages that use javafx.scene.layout
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
  • Classes in javafx.scene.layout used by javafx.scene.chart
    Class 描述
    Region
    Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
  • Classes in javafx.scene.layout used by javafx.scene.control
    Class 描述
    Pane
    布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
    Region
    Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
  • Classes in javafx.scene.layout used by javafx.scene.control.cell
    Class 描述
    Region
    Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
  • Classes in javafx.scene.layout used by javafx.scene.control.skin
    Class 描述
    Pane
    布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
    Region
    Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
    StackPane
    StackPane将它的孩子放在一个靠前的堆叠中。
  • Classes in javafx.scene.layout used by javafx.scene.layout
    Class 描述
    Background
    背景Region 。
    BackgroundFill
    填充和相关属性指示如何填充Region的背景。
    BackgroundImage
    定义描述如何将图像呈现为背景的属性Region 。
    BackgroundPosition
    表示的位置BackgroundImage的内Region的绘图区域。
    BackgroundRepeat
    枚举在背景中重复图像的选项
    BackgroundSize
    定义BackgroundImage应该填充的区域的大小相对于其样式的Region。
    Border
    边界的一个Region 。
    BorderImage
    定义描述如何将图像呈现为某个区域的边框的属性。
    BorderRepeat
    枚举指示边框图像的重复规则。
    BorderStroke
    定义用于对区域进行样式设置的边框上使用的笔画。
    BorderStrokeStyle
    定义在BorderStroke的一边使用的笔触风格。
    BorderWidths
    定义四个组件（顶部，右侧，底部和左侧）的宽度。
    ColumnConstraints
    为GridPane中的列定义可选布局约束。
    ConstraintsBase
    用于定义节点特定布局约束的基类。
    CornerRadii
    定义BorderStroke的四个角中的每一个的半径。
    Pane
    布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
    Priority
    用于确定给定节点的布局区域在其区域具有更多（或更少）空间可用并且多个节点竞争该空间时的增长（或收缩）优先级的枚举。
    Region
    Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
    RowConstraints
    为GridPane中的行定义可选布局约束。
  • Classes in javafx.scene.layout used by javafx.scene.text
    Class 描述
    Pane
    布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
    Region
    Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
  • Classes in javafx.scene.layout used by javafx.scene.web
    Class 描述
    Region
    Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


VBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.layout

Class VBox

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.layout.VBox
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class VBox
extends Pane
    VBox把孩子放在一个垂直的立柱上。 如果vbox有一个边框和/或填充集，那么这些内容将被放置在这些插入内。

    VBox示例：

       VBox vbox = new VBox(8); // spacing = 8 vbox.getChildren().addAll(new Button("Cut"), new Button("Copy"), new Button("Paste"));
    VBox将调整小孩的大小（如果可调整大小）到其首选高度，并使用其fillWidth属性来确定是否调整其宽度的大小以填充自己的宽度或将其宽度保持为首选（fillWidth默认为true）。 内容的对齐由alignment属性控制，默认为Pos.TOP_LEFT。

    如果vbox的大小大于其首选高度，默认情况下会使孩子保持其首选高度，留下额外的空间。 如果一个应用程序希望有一个或多个孩子被分配到额外的空间，它可以可选地为孩子设置一个vgrow约束。 有关详细信息，请参阅“可选布局约束”。

    不管孩子的可见财产价值如何，VBox都规定了每个被管理的孩子; 非托管儿童被忽视。

    可调整范围

    vbox的父级将在布局期间调整vbox可调整大小范围内的vbox大小。 默认情况下，vbox根据其内容计算该范围，如下表所示。

    VBox Resize Table width height minimum left/right insets plus the largest of the children's min widths. top/bottom insets plus the sum of each child's min height plus spacing between each child. preferred left/right insets plus the largest of the children's pref widths. top/bottom insets plus the sum of each child's pref height plus spacing between each child. maximum Double.MAX_VALUE Double.MAX_VALUE

    vbox的无界最大宽度和高度表示父级可以将其调整大小超出其首选大小，以填充分配给它的空间。

    VBox提供了直接设置大小范围的属性。 这些属性默认为哨兵值USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       vbox.setPrefWidth(400);
    应用程序可以通过将这些属性设置回USE_COMPUTED_SIZE来恢复计算值。

    默认情况下，VBox不会剪切其内容，所以如果孩子的最小大小阻止其在vbox中的适配，那么儿童边界可能会延伸到自己的边界之外。

    可选布局限制

    一个应用程序可以设置对个别孩子的约束，以定制VBox的布局。 对于每个约束，VBox提供了一种静态方法，用于在孩子上设置它。

    VBox Constraint Table Constraint Type Description vgrow javafx.scene.layout.Priority The vertical grow priority for the child. margin javafx.geometry.Insets Margin space around the outside of the child.

    例如，如果vbox需要将ListView分配给所有额外的空间：

       VBox vbox = new VBox(); ListView list = new ListView(); VBox.setVgrow(list, Priority.ALWAYS); vbox.getChildren().addAll(new Label("Names:"), list);
    如果多个孩子具有相同的成长优先级设置，则vbox将为每个孩子分配等量的空间。 VBox只会使一个孩子达到最大高度，所以如果孩子的最大高度不是Double.MAX_VALUE，则应用程序可能需要重写max才能使其增长。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Pos> alignment
      孩子们在vbox的宽度和高度之间的整体对齐。
      BooleanProperty fillWidth
      是否调整大小的小孩将被调整大小以填充vbox的全部宽度，或者调整大小为其首选宽度，并根据 alignment hpos值对齐。
      DoubleProperty spacing
      vbox中每个孩子之间的垂直空间量。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      VBox​()
      创建一个间距= 0并在TOP_LEFT对齐的VBox布局。
      VBox​(double spacing)
      创建一个VBox布局，并指定子间间距。
      VBox​(double spacing, Node... children)
      创建一个VBox布局，其间指定间隔。
      VBox​(Node... children)
      创建一个间距= 0的VBox布局。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Pos> alignmentProperty​()
      孩子们在vbox的宽度和高度之间的整体对齐。
      static void clearConstraints​(Node child)
      从子节点中删除所有vbox约束。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computeMinWidth​(double height)
      计算该区域的最小宽度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      BooleanProperty fillWidthProperty​()
      是否调整大小的小孩将被调整大小以填满vbox的全部宽度，或者按照 alignment hpos值进行调整。
      Pos getAlignment​()
      获取属性对齐的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      static Insets getMargin​(Node child)
      如果设置，返回小孩的边距属性。
      double getSpacing​()
      获取属性间距的值。
      static Priority getVgrow​(Node child)
      如果设置，返回小孩的vgrow属性。
      boolean isFillWidth​()
      获取属性fillWidth的值。
      protected void layoutChildren​()
      在布局传递期间调用这个 Parent的孩子进行布局。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。
      void setAlignment​(Pos value)
      设置属性对齐的值。
      void setFillWidth​(boolean value)
      设置属性fillWidth的值。
      static void setMargin​(Node child, Insets value)
      设置由vbox包含的小孩的边距。
      void setSpacing​(double value)
      设置属性间距的值。
      static void setVgrow​(Node child, Priority value)
      设置由vbox包含的小孩的垂直成长优先级。
      DoubleProperty spacingProperty​()
      vbox中每个孩子之间的垂直空间量。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, queryAccessibleAttribute, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • spacing

        public final DoubleProperty spacingProperty
        vbox中每个孩子之间的垂直空间量。
        另请参见：
        getSpacing() ， setSpacing(double)

      • alignment

        public final ObjectProperty<Pos> alignmentProperty
        孩子们在vbox的宽度和高度之间的整体对齐。
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • fillWidth

        public final BooleanProperty fillWidthProperty
        是否调整大小的小孩将被调整大小以填满vbox的全部宽度，或者调整大小至其首选宽度，并根据 alignment hpos值对齐。
        另请参见：
        isFillWidth() ， setFillWidth(boolean)

    • 构造方法详细信息

      • VBox

        public VBox​()
        创建一个间距= 0并在TOP_LEFT对齐的VBox布局。

      • VBox

        public VBox​(double spacing)
        创建一个VBox布局，并指定子间间距。
        参数
        spacing - 每个孩子之间的垂直空间量

      • VBox

        public VBox​(Node... children)
        创建一个间距= 0的VBox布局。
        参数
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

      • VBox

        public VBox​(double spacing,
            Node... children)
        创建一个VBox布局，其间指定间隔。
        参数
        spacing - 每个孩子之间的水平空间量
        children - 此窗格的初始子项集。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setVgrow

        public static void setVgrow​(Node child,
                            Priority value)
        设置由vbox包含的小孩的垂直成长优先级。 如果设置，vbox将使用优先级来分配额外的空间，如果vbox的大小大于其首选高度。 如果多个vbox小孩具有相同的垂直成长优先级，那么额外的空间将在它们之间平均分配。 如果没有对子进行垂直增长优先级设置，则vbox将永远不会为其分配额外的垂直空间（如果可用）。 将值设置为null将删除约束。
        参数
        child - vbox的孩子
        value - 孩子的横向成长优先级

      • getVgrow

        public static Priority getVgrow​(Node child)
        如果设置，返回小孩的vgrow属性。
        参数
        child - vbox的子节点
        结果
        该小孩的垂直成长优先级，如果没有设置优先级，则为null

      • setMargin

        public static void setMargin​(Node child,
                             Insets value)
        设置由vbox包含的小孩的边距。 如果设置，vbox将布局孩子，使其周围具有边缘空间。 将值设置为null将删除约束。
        参数
        child - vbox的子模式
        value - 孩子周围的空间

      • getMargin

        public static Insets getMargin​(Node child)
        如果设置，返回小孩的边距属性。
        参数
        child - vbox的子节点
        结果
        小孩的保证金，如果没有设置保证金，则为null

      • clearConstraints

        public static void clearConstraints​(Node child)
        从子节点中删除所有vbox约束。
        参数
        child - 子节点

      • spacingProperty

        public final DoubleProperty spacingProperty​()
        vbox中每个孩子之间的垂直空间量。
        另请参见：
        getSpacing() ， setSpacing(double)

      • setSpacing

        public final void setSpacing​(double value)
        设置属性间距的值。
        Property description:
        vbox中每个孩子之间的垂直空间量。

      • getSpacing

        public final double getSpacing​()
        获取属性间距的值。
        Property description:
        vbox中每个孩子之间的垂直空间量。

      • alignmentProperty

        public final ObjectProperty<Pos> alignmentProperty​()
        孩子们在vbox的宽度和高度之间的整体对齐。
        另请参见：
        getAlignment() ， setAlignment(Pos)

      • setAlignment

        public final void setAlignment​(Pos value)
        设置属性对齐的值。
        Property description:
        孩子们在vbox的宽度和高度之间的整体对齐。

      • getAlignment

        public final Pos getAlignment​()
        获取属性对齐的值。
        Property description:
        孩子们在vbox的宽度和高度之间的整体对齐。

      • fillWidthProperty

        public final BooleanProperty fillWidthProperty​()
        是否调整大小的小孩将被调整大小以填充vbox的全部宽度或被调整到其首选宽度，并根据 alignment hpos值对齐。
        另请参见：
        isFillWidth() ， setFillWidth(boolean)

      • setFillWidth

        public final void setFillWidth​(boolean value)
        设置属性fillWidth的值。
        Property description:
        是否调整大小的小孩将被调整大小以填满vbox的全部宽度，或者调整大小至其首选宽度，并根据 alignment hpos值对齐。

      • isFillWidth

        public final boolean isFillWidth​()
        获取属性fillWidth的值。
        Property description:
        是否调整大小的小孩将被调整大小以填满vbox的全部宽度，或者调整大小至其首选宽度，并根据 alignment hpos值对齐。

      • getContentBias

        public Orientation getContentBias​()
        描述从类复制： Node
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        重写：
        getContentBias在 Node
        结果
        除非其一个孩子有内容偏见，否则为null。
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • computeMinWidth

        protected double computeMinWidth​(double height)
        描述从类复制： Region
        计算该区域的最小宽度。 默认情况下返回左和右插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computeMinWidth在 Region
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        计算出该区域的最小宽度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        描述从类复制： Region
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • computePrefWidth

        protected double computePrefWidth​(double height)
        描述从类复制： Region
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        描述从类复制： Region
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果首选的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • requestLayout

        public void requestLayout​()
        描述从类复制： Parent
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果此父对象是布局根或非托管，则将直接添加到场景的脏布局列表中，否则将调用requestParentLayout。

        重写：
        requestLayout在 Parent

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Parent
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.scene.layout.AnchorPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.AnchorPane

No usage of javafx.scene.layout.AnchorPane
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.Background (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.Background

  • Packages that use Background
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of Background in javafx.scene.layout

      Fields in javafx.scene.layout declared as Background
      Modifier and Type Field 描述
      static Background Background.EMPTY
      一个空的背景，使用而不是null。
      Methods in javafx.scene.layout that return Background
      Modifier and Type 方法 描述
      Background Region.getBackground​()
      获取属性背景的值。
      Methods in javafx.scene.layout that return types with arguments of type Background
      Modifier and Type 方法 描述
      ObjectProperty<Background> Region.backgroundProperty​()
      该区域的背景由零个或多个BackgroundFill组成，以及零个或多个BackgroundImages。
      Methods in javafx.scene.layout with parameters of type Background
      Modifier and Type 方法 描述
      void Region.setBackground​(Background value)
      设置属性背景的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BackgroundFill (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BackgroundFill

  • Packages that use BackgroundFill
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BackgroundFill in javafx.scene.layout

      Methods in javafx.scene.layout that return types with arguments of type BackgroundFill
      Modifier and Type 方法 描述
      List<BackgroundFill> Background.getFills​()
      BackgroundFill的列表，它们一起定义了该背景的填充部分。
      Constructors in javafx.scene.layout with parameters of type BackgroundFill
      Constructor 描述
      Background​(BackgroundFill... fills)
      通过提供一个BackgroundFill数组创建一个新的背景。
      Background​(BackgroundFill[] fills, BackgroundImage[] images)
      通过提供两个阵列创建一个新的背景，一个用于背景填充，另一个用于背景图像。
      Constructor parameters in javafx.scene.layout with type arguments of type BackgroundFill
      Constructor 描述
      Background​(List<BackgroundFill> fills, List<BackgroundImage> images)
      创建一个新的背景提供两个列表，一个用于背景填充，一个用于背景图像。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BackgroundImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BackgroundImage

  • Packages that use BackgroundImage
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BackgroundImage in javafx.scene.layout

      Methods in javafx.scene.layout that return types with arguments of type BackgroundImage
      Modifier and Type 方法 描述
      List<BackgroundImage> Background.getImages​()
      BackgroundImages的列表，它们一起定义了此Background的图像部分。
      Constructors in javafx.scene.layout with parameters of type BackgroundImage
      Constructor 描述
      Background​(BackgroundFill[] fills, BackgroundImage[] images)
      通过提供两个阵列创建一个新的背景，一个用于背景填充，另一个用于背景图像。
      Background​(BackgroundImage... images)
      通过提供一个BackgroundImages数组创建一个新的背景。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BackgroundPosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BackgroundPosition

  • Packages that use BackgroundPosition
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BackgroundPosition in javafx.scene.layout

      Fields in javafx.scene.layout declared as BackgroundPosition
      Modifier and Type Field 描述
      static BackgroundPosition BackgroundPosition.CENTER
      一个将背景图像中心的BackgroundPosition。
      static BackgroundPosition BackgroundPosition.DEFAULT
      任何BackgroundImage的默认BackgroundPosition。
      Methods in javafx.scene.layout that return BackgroundPosition
      Modifier and Type 方法 描述
      BackgroundPosition BackgroundImage.getPosition​()
      这个BackgroundImage相对于Region的位置。
      Constructors in javafx.scene.layout with parameters of type BackgroundPosition
      Constructor 描述
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BackgroundRepeat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BackgroundRepeat

  • Packages that use BackgroundRepeat
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BackgroundRepeat in javafx.scene.layout

      Methods in javafx.scene.layout that return BackgroundRepeat
      Modifier and Type 方法 描述
      BackgroundRepeat BackgroundImage.getRepeatX​()
      以什么方式（如果有的话）表示背景图像将沿着该区域的x轴重复。
      BackgroundRepeat BackgroundImage.getRepeatY​()
      以什么方式（如果有的话）表示背景图像将沿着该区域的y轴重复。
      static BackgroundRepeat BackgroundRepeat.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static BackgroundRepeat[] BackgroundRepeat.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.layout with parameters of type BackgroundRepeat
      Constructor 描述
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BackgroundSize (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BackgroundSize

  • Packages that use BackgroundSize
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BackgroundSize in javafx.scene.layout

      Fields in javafx.scene.layout declared as BackgroundSize
      Modifier and Type Field 描述
      static BackgroundSize BackgroundSize.DEFAULT
      当未定义显式大小时，BackgroundImages使用的默认BackgroundSize。
      Methods in javafx.scene.layout that return BackgroundSize
      Modifier and Type 方法 描述
      BackgroundSize BackgroundImage.getSize​()
      该图像相对于Region的大小。
      Constructors in javafx.scene.layout with parameters of type BackgroundSize
      Constructor 描述
      BackgroundImage​(Image image, BackgroundRepeat repeatX, BackgroundRepeat repeatY, BackgroundPosition position, BackgroundSize size)
      创建一个新的BackgroundImage。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.Border (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.Border

  • Packages that use Border
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of Border in javafx.scene.layout

      Fields in javafx.scene.layout declared as Border
      Modifier and Type Field 描述
      static Border Border.EMPTY
      空的边框，使用而不是null。
      Methods in javafx.scene.layout that return Border
      Modifier and Type 方法 描述
      Border Region.getBorder​()
      获取属性边框的值。
      Methods in javafx.scene.layout that return types with arguments of type Border
      Modifier and Type 方法 描述
      ObjectProperty<Border> Region.borderProperty​()
      该区域的边界由零个或多个BorderStrokes组成，零个或多个BorderImages。
      Methods in javafx.scene.layout with parameters of type Border
      Modifier and Type 方法 描述
      void Region.setBorder​(Border value)
      设置属性边框的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BorderImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BorderImage

  • Packages that use BorderImage
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BorderImage in javafx.scene.layout

      Methods in javafx.scene.layout that return types with arguments of type BorderImage
      Modifier and Type 方法 描述
      List<BorderImage> Border.getImages​()
      BorderImages的列表，它们一起定义要使用的图像，而不是此边框的笔画。
      Constructors in javafx.scene.layout with parameters of type BorderImage
      Constructor 描述
      Border​(BorderImage... images)
      通过提供一个BorderImages数组创建一个新的边框。
      Border​(BorderStroke[] strokes, BorderImage[] images)
      通过提供一系列BorderStrokes和BorderImages创建一个新的边框。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BorderPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BorderPane

No usage of javafx.scene.layout.BorderPane
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BorderRepeat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BorderRepeat

  • Packages that use BorderRepeat
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BorderRepeat in javafx.scene.layout

      Methods in javafx.scene.layout that return BorderRepeat
      Modifier and Type 方法 描述
      BorderRepeat BorderImage.getRepeatX​()
      以什么方式（如果有的话）表示边框图像将沿着该区域的x轴重复。
      BorderRepeat BorderImage.getRepeatY​()
      以什么方式（如果有的话）表示边框图像将沿着该区域的y轴重复。
      static BorderRepeat BorderRepeat.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static BorderRepeat[] BorderRepeat.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.layout with parameters of type BorderRepeat
      Constructor 描述
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BorderStroke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BorderStroke

  • Packages that use BorderStroke
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BorderStroke in javafx.scene.layout

      Methods in javafx.scene.layout that return types with arguments of type BorderStroke
      Modifier and Type 方法 描述
      List<BorderStroke> Border.getStrokes​()
      BorderStrokes列表，它们一起定义了此边框的划线部分。
      Constructors in javafx.scene.layout with parameters of type BorderStroke
      Constructor 描述
      Border​(BorderStroke... strokes)
      通过提供一个BorderStrokes数组创建一个新的边框。
      Border​(BorderStroke[] strokes, BorderImage[] images)
      通过提供一系列BorderStrokes和BorderImages创建一个新的边框。
      Constructor parameters in javafx.scene.layout with type arguments of type BorderStroke
      Constructor 描述
      Border​(List<BorderStroke> strokes, List<BorderImage> images)
      通过提供BorderStrokes和BorderImages列表创建一个新的边框。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BorderStrokeStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BorderStrokeStyle

  • Packages that use BorderStrokeStyle
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BorderStrokeStyle in javafx.scene.layout

      Fields in javafx.scene.layout declared as BorderStrokeStyle
      Modifier and Type Field 描述
      static BorderStrokeStyle BorderStrokeStyle.DASHED
      用于抚摸的预定义虚线图案
      static BorderStrokeStyle BorderStrokeStyle.DOTTED
      用于抚摸的预定点缀图案
      static BorderStrokeStyle BorderStrokeStyle.NONE
      表示不应绘制中风。
      static BorderStrokeStyle BorderStrokeStyle.SOLID
      用于抚摸的预定义实线
      Methods in javafx.scene.layout that return BorderStrokeStyle
      Modifier and Type 方法 描述
      BorderStrokeStyle BorderStroke.getBottomStyle​()
      定义此边框底部的样式。
      BorderStrokeStyle BorderStroke.getLeftStyle​()
      定义此边框左侧的样式。
      BorderStrokeStyle BorderStroke.getRightStyle​()
      定义此边框右侧的样式。
      BorderStrokeStyle BorderStroke.getTopStyle​()
      定义此边框顶部的样式。
      Constructors in javafx.scene.layout with parameters of type BorderStrokeStyle
      Constructor 描述
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.BorderWidths (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.BorderWidths

  • Packages that use BorderWidths
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of BorderWidths in javafx.scene.layout

      Fields in javafx.scene.layout declared as BorderWidths
      Modifier and Type Field 描述
      static BorderWidths BorderWidths.DEFAULT
      指定null时由BorderImage使用的默认BorderWidth。
      static BorderWidths BorderStroke.DEFAULT_WIDTHS
      默认Insets与BorderStroke一起使用，否则不定义任何内容。
      static BorderWidths BorderWidths.EMPTY
      一组空的宽度，使得所有值都为0，并且是文字值。
      static BorderWidths BorderWidths.FULL
      一组宽度，表示每边100％。
      static BorderWidths BorderStroke.MEDIUM
      指定“medium”时的默认值
      static BorderWidths BorderStroke.THICK
      指定“thick”时的默认值
      static BorderWidths BorderStroke.THIN
      指定“thin”时的默认插入。
      Methods in javafx.scene.layout that return BorderWidths
      Modifier and Type 方法 描述
      BorderWidths BorderImage.getSlices​()
      定义图像的切片。
      BorderWidths BorderImage.getWidths​()
      每侧边框的宽度。
      BorderWidths BorderStroke.getWidths​()
      定义BorderStroke的每一边的厚度。
      Constructors in javafx.scene.layout with parameters of type BorderWidths
      Constructor 描述
      BorderImage​(Image image, BorderWidths widths, Insets insets, BorderWidths slices, boolean filled, BorderRepeat repeatX, BorderRepeat repeatY)
      创建一个新的BorderImage。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.ColumnConstraints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.ColumnConstraints

  • Packages that use ColumnConstraints
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of ColumnConstraints in javafx.scene.layout

      Methods in javafx.scene.layout that return types with arguments of type ColumnConstraints
      Modifier and Type 方法 描述
      ObservableList<ColumnConstraints> GridPane.getColumnConstraints​()
      返回列约束列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.ConstraintsBase (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.ConstraintsBase

  • Packages that use ConstraintsBase
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of ConstraintsBase in javafx.scene.layout

      Subclasses of ConstraintsBase in javafx.scene.layout
      Modifier and Type Class 描述
      class  ColumnConstraints
      为GridPane中的列定义可选布局约束。
      class  RowConstraints
      为GridPane中的行定义可选布局约束。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.CornerRadii (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.CornerRadii

  • Packages that use CornerRadii
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of CornerRadii in javafx.scene.layout

      Fields in javafx.scene.layout declared as CornerRadii
      Modifier and Type Field 描述
      static CornerRadii CornerRadii.EMPTY
      一个完全为空的CornerRadii，表示方角。
      Methods in javafx.scene.layout that return CornerRadii
      Modifier and Type 方法 描述
      CornerRadii BackgroundFill.getRadii​()
      用于表示BackgroundFill的四个半径的Radii。
      CornerRadii BorderStroke.getRadii​()
      定义此BorderStroke的每个角落的半径。
      Constructors in javafx.scene.layout with parameters of type CornerRadii
      Constructor 描述
      BackgroundFill​(Paint fill, CornerRadii radii, Insets insets)
      使用指定的填充，半径和插入创建一个新的BackgroundFill。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.FlowPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.FlowPane

No usage of javafx.scene.layout.FlowPane
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.GridPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.GridPane

No usage of javafx.scene.layout.GridPane
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.HBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.HBox

No usage of javafx.scene.layout.HBox
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.Pane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.Pane

  • Packages that use Pane
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of Pane in javafx.scene.control

      Subclasses of Pane in javafx.scene.control
      Modifier and Type Class 描述
      class  DialogPane
      DialogPane应该被认为是在一个Dialog实例中显示的根节点 。
      protected class  PopupControl.CSSBridge
      弹出窗口和场景图之间的链接。

    • Uses of Pane in javafx.scene.control.skin

      Subclasses of Pane in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  TableHeaderRow
      负责绘制整列列标题的区域。

    • Uses of Pane in javafx.scene.layout

      Subclasses of Pane in javafx.scene.layout
      Modifier and Type Class 描述
      class  AnchorPane
      AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。
      class  BorderPane
      BorderPane在上，左，右，底部和中间位置摆放孩子。
      class  FlowPane
      FlowPane将其孩子摆放在流过玻璃边界的流中。
      class  GridPane
      GridPane将其孩子放在一个灵活的行和列格网中。
      class  HBox
      HBox将孩子放在一排水平排列中。
      class  StackPane
      StackPane将它的孩子放在一个靠前的堆叠中。
      class  TilePane
      TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。
      class  VBox
      VBox把孩子放在一个垂直的立柱上。

    • Uses of Pane in javafx.scene.text

      Subclasses of Pane in javafx.scene.text
      Modifier and Type Class 描述
      class  TextFlow
      TextFlow是设计用于布置富文本的特殊布局。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.Priority (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.Priority

  • Packages that use Priority
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of Priority in javafx.scene.layout

      Methods in javafx.scene.layout that return Priority
      Modifier and Type 方法 描述
      Priority ColumnConstraints.getHgrow​()
      获取属性hgrow的值。
      static Priority GridPane.getHgrow​(Node child)
      如果设置，返回小孩的hgrow约束。
      static Priority HBox.getHgrow​(Node child)
      如果设置，返回小孩的hgrow约束。
      static Priority GridPane.getVgrow​(Node child)
      如果设置，则返回小孩的vgrow约束。
      Priority RowConstraints.getVgrow​()
      获取属性vgrow的值。
      static Priority VBox.getVgrow​(Node child)
      如果设置，返回小孩的vgrow属性。
      static Priority Priority.max​(Priority a, Priority b)
      回收两个优先级较高的便利方法。
      static Priority Priority.min​(Priority a, Priority b)
      方便返回两个优先级较低的方法。
      static Priority Priority.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Priority[] Priority.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.layout that return types with arguments of type Priority
      Modifier and Type 方法 描述
      ObjectProperty<Priority> ColumnConstraints.hgrowProperty​()
      该列的横向增长优先级。
      ObjectProperty<Priority> RowConstraints.vgrowProperty​()
      该行的垂直成长优先级。
      Methods in javafx.scene.layout with parameters of type Priority
      Modifier and Type 方法 描述
      static Priority Priority.max​(Priority a, Priority b)
      回收两个优先级较高的便利方法。
      static Priority Priority.min​(Priority a, Priority b)
      方便返回两个优先级较低的方法。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow)
      设置网格位置，跨度和子对齐方式。
      static void GridPane.setConstraints​(Node child, int columnIndex, int rowIndex, int columnspan, int rowspan, HPos halignment, VPos valignment, Priority hgrow, Priority vgrow, Insets margin)
      设置网格位置，跨度，对齐方式，增加优先级，以及子窗格包含在网格中时的边距。
      void ColumnConstraints.setHgrow​(Priority value)
      设置属性hgrow的值。
      static void GridPane.setHgrow​(Node child, Priority value)
      设置子格中包含的网格的水平增长优先级。
      static void HBox.setHgrow​(Node child, Priority value)
      设置由hbox包含的小孩的横向增长优先级。
      static void GridPane.setVgrow​(Node child, Priority value)
      设置子格中包含的网格的垂直成长优先级。
      void RowConstraints.setVgrow​(Priority value)
      设置属性vgrow的值。
      static void VBox.setVgrow​(Node child, Priority value)
      设置由vbox包含的小孩的垂直成长优先级。
      Constructors in javafx.scene.layout with parameters of type Priority
      Constructor 描述
      ColumnConstraints​(double minWidth, double prefWidth, double maxWidth, Priority hgrow, HPos halignment, boolean fillWidth)
      创建具有固定大小范围，水平增长优先级，水平对齐和水平填充行为的列约束对象。
      RowConstraints​(double minHeight, double prefHeight, double maxHeight, Priority vgrow, VPos valignment, boolean fillHeight)
      Creates a row constraint object with a fixed size range, vertical grow priority, vertical alignment, and vertical fill behavior.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.Region (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.Region

  • Packages that use Region
    软件包 描述
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of Region in javafx.scene.chart

      Subclasses of Region in javafx.scene.chart
      Modifier and Type Class 描述
      class  AreaChart<X,Y>
      AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
      class  Axis<T>
      JavaFX中所有轴的基类，表示在图表区域上绘制的轴。
      class  BarChart<X,Y>
      绘制一个指示类别数据值的条形图。
      class  BubbleChart<X,Y>
      为一系列数据点绘制气泡的图表类型。
      class  CategoryAxis
      一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。
      class  Chart
      所有图表的基础类。
      class  LineChart<X,Y>
      线图绘制了连接数据点的行。
      class  NumberAxis
      一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
      class  PieChart
      显示PieChart。
      class  ScatterChart<X,Y>
      绘制一系列数据点符号的图表类型。
      class  StackedAreaChart<X,Y>
      StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。
      class  StackedBarChart<X,Y>
      StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。
      class  ValueAxis<T extends Number>
      数据定义为数字的轴。
      class  XYChart<X,Y>
      所有2轴图的图表基类。

    • Uses of Region in javafx.scene.control

      Subclasses of Region in javafx.scene.control
      Modifier and Type Class 描述
      class  Accordion
      手风琴是一组TitlePanes 。
      class  Button
      一个简单的按钮控件。
      class  ButtonBar
      ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。
      class  ButtonBase
      按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
      class  Cell<T>
      细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。
      class  CheckBox
      三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。
      class  ChoiceBox<T>
      ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。
      class  ColorPicker
      ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。
      class  ComboBox<T>
      为ComboBox最常见形式的ComboBoxBase抽象类的实现，向用户提供弹出列表，以提供他们可以选择的选项。
      class  ComboBoxBase<T>
      ComboBox类控件的抽象基类。
      class  Control
      所有用户界面控件的基类。
      class  DateCell
      DateCell由DatePicker用于在日历月中呈现单个网格单元格。
      class  DatePicker
      DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
      class  DialogPane
      DialogPane应该被认为是在一个Dialog实例中显示的根节点 。
      class  Hyperlink
      一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
      class  IndexedCell<T>
      一个Cell的实现，其中包含一个索引属性，该属性映射到可视化的底层的数据模型中。
      class  Label
      标签是不可编辑的文本控件。
      class  Labeled
      标签Control是与其用户界面的一部分相关联的文本内容。
      class  ListCell<T>
      在ListView实例中使用的Cell类型。
      class  ListView<T>
      ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
      class  MenuBar
      MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。
      class  MenuButton
      MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
      class  Pagination
      分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
      class  PasswordField
      掩码输入字符的文本字段。
      protected class  PopupControl.CSSBridge
      弹出窗口和场景图之间的链接。
      class  ProgressBar
      ProgressIndator的专业化表示为横杠。
      class  ProgressIndicator
      用于指示进度的循环控制，无限（也称为不确定）或有限。
      class  RadioButton
      RadioButtons创建一系列只能选择一个项目的项目。
      class  ScrollBar
      具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。
      class  ScrollPane
      提供其内容的滚动，剪切视口的控件。
      class  Separator
      水平或垂直分隔线。
      class  Slider
      滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。
      class  Spinner<T>
      单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。
      class  SplitMenuButton
      SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。
      class  SplitPane
      具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。
      class  TableCell<S,T>
      在TableView中表示单行/列交集。
      class  TableRow<T>
      TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。
      class  TableView<S>
      TableView控件旨在可视化无限数量的数据行，分为列。
      class  TabPane
      允许在一组Tabs之间切换的控件 。
      class  TextArea
      文本输入组件，允许用户输入多行纯文本。
      class  TextField
      文本输入组件，允许用户输入一行未格式化的文本。
      class  TextInputControl
      文本输入控件的抽象基类。
      class  TitledPane
      TitledPane是一个可以打开和关闭的标题的面板。
      class  ToggleButton
      A ToggleButton是具有选择能力的专业控制。
      class  ToolBar
      ToolBar是一个可以水平或垂直显示项目的控件。
      class  TreeCell<T>
      Cell类型与TreeView控件一起使用。
      class  TreeTableCell<S,T>
      在TreeTableView中表示单行/列交集。
      class  TreeTableRow<T>
      TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。
      class  TreeTableView<S>
      TreeTableView控件旨在可视化无限数量的数据行，分为列。
      class  TreeView<T>
      TreeView控件提供了一个到根的视图（类型为TreeItem ）。

    • Uses of Region in javafx.scene.control.cell

      Subclasses of Region in javafx.scene.control.cell
      Modifier and Type Class 描述
      class  CheckBoxListCell<T>
      一个包含一个ListCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTableCell<S,T>
      一个包含一个TableCell实现的类，可以在单元格内绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。
      class  CheckBoxTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格中绘制一个CheckBox节点，并支持常见的交互（ 稍后更详细地讨论）。
      class  CheckBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，它在单元格内绘制一个CheckBox节点，可选地带有一个标签，表示复选框代表什么。
      class  ChoiceBoxListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。
      class  ChoiceBoxTreeTableCell<S,T>
      一个包含一个TreeTableCell实现的类，它在单元格内绘制一个ChoiceBox节点。
      class  ComboBoxListCell<T>
      一个包含ListCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  ComboBoxTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeCell<T>
      一个包含TreeCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  ComboBoxTreeTableCell<S,T>
      一个包含TreeTableCell实现的类，在该单元格内绘制一个ComboBox节点。
      class  ProgressBarTableCell<S>
      一个包含TableCell实现的类，在该单元格内绘制一个ProgressBar节点。
      class  ProgressBarTreeTableCell<S>
      一个包含TreeTableCell实现的类，在该单元格内绘制一个ProgressBar节点。
      class  TextFieldListCell<T>
      一个包含一个ListCell实现的类，它在单元格内绘制一个TextField节点。
      class  TextFieldTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个TextField节点。
      class  TextFieldTreeCell<T>
      一个包含一个TreeCell实现的类，它在单元格中绘制一个TextField节点。
      class  TextFieldTreeTableCell<S,T>
      一个包含TableCell实现的类，在该单元格内绘制一个TextField节点。

    • Uses of Region in javafx.scene.control.skin

      Subclasses of Region in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  NestedTableColumnHeader
      此类用于构造TableView的头。
      class  TableColumnHeader
      负责绘制单列标题的区域。
      class  TableHeaderRow
      负责绘制整列列标题的区域。
      class  VirtualFlow<T extends IndexedCell>
      使用基于单元的机制实现虚拟化容器。

    • Uses of Region in javafx.scene.layout

      Subclasses of Region in javafx.scene.layout
      Modifier and Type Class 描述
      class  AnchorPane
      AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。
      class  BorderPane
      BorderPane在上，左，右，底部和中间位置摆放孩子。
      class  FlowPane
      FlowPane将其孩子摆放在流过玻璃边界的流中。
      class  GridPane
      GridPane将其孩子放在一个灵活的行和列格网中。
      class  HBox
      HBox将孩子放在一排水平排列中。
      class  Pane
      布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
      class  StackPane
      StackPane将它的孩子放在一个靠前的堆叠中。
      class  TilePane
      TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。
      class  VBox
      VBox把孩子放在一个垂直的立柱上。

    • Uses of Region in javafx.scene.text

      Subclasses of Region in javafx.scene.text
      Modifier and Type Class 描述
      class  TextFlow
      TextFlow是设计用于布置富文本的特殊布局。

    • Uses of Region in javafx.scene.web

      Subclasses of Region in javafx.scene.web
      Modifier and Type Class 描述
      class  HTMLEditor
      允许用户编辑文本并将样式应用于此文本的控件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.RowConstraints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.RowConstraints

  • Packages that use RowConstraints
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。

    • Uses of RowConstraints in javafx.scene.layout

      Methods in javafx.scene.layout that return types with arguments of type RowConstraints
      Modifier and Type 方法 描述
      ObservableList<RowConstraints> GridPane.getRowConstraints​()
      返回行约束列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.StackPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.StackPane

  • Packages that use StackPane
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

    • Uses of StackPane in javafx.scene.control.skin

      Subclasses of StackPane in javafx.scene.control.skin
      Modifier and Type Class 描述
      class  TableHeaderRow
      负责绘制整列列标题的区域。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.TilePane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.TilePane

No usage of javafx.scene.layout.TilePane
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.layout.VBox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.layout.VBox

No usage of javafx.scene.layout.VBox
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AudioClip (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class AudioClip

  • java.lang.Object
    • javafx.scene.media.AudioClip

  • public final class AudioClip
extends Object
    AudioClip表示可以以最小延迟播放的音频段。 剪辑的加载类似于Media对象，但具有不同的行为，例如，一个Media无法自己播放。 AudioClip也可立即使用。 播放行为是火而忘记的：一次播放方法被称为唯一可操作的控件是stop() 。 一个AudioClip也可以同时播放多次。 要使用Media完成相同的任务，必须为并行播放的每个声音创建一个新的MediaPlayer对象。 Media对象更适合长时间播放的声音。 这主要是因为AudioClip在内存中存储了整个声音的原始，未压缩音频数据，对于长音频剪辑来说，这可能相当大。 A MediaPlayer将只有足够的解压缩音频数据在内存中预先播放短时间，因此对于较长的剪辑而言，特别是如果它们被压缩，则可以更高的内存效率。

    使用示例

       AudioClip plonkSound = new AudioClip("http://somehost/path/plonk.aiff"); plonkSound.play();
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty balance
      剪辑的相对左右音量级别。
      IntegerProperty cycleCount
      当 调用play()时剪辑的播放 次数 。
      DoubleProperty pan
      剪辑的相对“中心”。
      IntegerProperty priority
      剪辑相对于其他剪辑的相对优先级。
      DoubleProperty rate
      剪辑播放的相对速率。
      DoubleProperty volume
      剪辑播放的相对音量级别。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int INDEFINITE
      当 cycleCount设置为此值时， AudioClip将连续循环，直到停止。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AudioClip​(String source)
      从提供的源URL创建一个 AudioClip 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty balanceProperty​()
      剪辑的相对左右音量级别。
      IntegerProperty cycleCountProperty​()
      调用 play()时播放剪辑的次数。
      double getBalance​()
      获取此剪辑的默认平衡级别。
      int getCycleCount​()
      获取默认循环计数。
      double getPan​()
      获取默认的平移值。
      int getPriority​()
      获取默认播放优先级。
      double getRate​()
      获取默认播放速度。
      String getSource​()
      获取用于创建此源的源URL AudioClip 。
      double getVolume​()
      获取默认音量级别。
      boolean isPlaying​()
      指示这个 AudioClip是否正在播放。
      DoubleProperty panProperty​()
      剪辑的相对“中心”。
      void play​()
      使用所有默认参数播放 AudioClip 。
      void play​(double volume)
      使用除卷外的所有默认参数播放 AudioClip 。
      void play​(double volume, double balance, double rate, double pan, int priority)
      使用给定的参数播放 AudioClip 。
      IntegerProperty priorityProperty​()
      剪辑相对于其他剪辑的相对优先级。
      DoubleProperty rateProperty​()
      剪辑播放的相对速率。
      void setBalance​(double balance)
      设置默认平衡级别。
      void setCycleCount​(int count)
      设置默认循环计数。
      void setPan​(double pan)
      设置默认的平移值。
      void setPriority​(int priority)
      设置默认播放优先级。
      void setRate​(double rate)
      设置默认回放速率。
      void setVolume​(double value)
      设置默认音量级别。
      void stop​()
      立即停止这个 AudioClip所有播放。
      DoubleProperty volumeProperty​()
      剪辑播放的相对音量级别。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • volume

        public DoubleProperty volumeProperty
        剪辑播放的相对音量级别。 有效范围为0.0（静音）至1.0（全音量）。 值在内部被钳位到该范围，所以超出此范围的值将不会产生额外的影响。 音量由衰减控制，因此低于1.0的值将相应地降低声级。
        另请参见：
        getVolume() ， setVolume(double)

      • balance

        public DoubleProperty balanceProperty
        剪辑的相对左右音量级别。 有效范围是-1.0到1.0，其中-1.0给左声道全音量，而右声道静音，0.0给两个声道全音量，而1.0则向右声道提供全音量并使左声道静音。 超出此范围的值在内部夹紧。
        另请参见：
        getBalance() ， setBalance(double)

      • rate

        public DoubleProperty rateProperty
        剪辑播放的相对速率。 有效范围为0.125（1/8速）至8.0（8倍速）; 超出此范围的值在内部夹紧。 剪辑的正常播放为1.0; 任何其他费率将相应地影响音调和持续时间。
        另请参见：
        getRate() ， setRate(double)

      • pan

        public DoubleProperty panProperty
        剪辑的相对“中心”。 平移值0.0为正常播放剪辑，其中-1.0平移将剪辑完全移动到左声道，并且1.0完全移动到右声道。 与平衡不同，此设置将两个通道混合，因此通道都不会丢失数据。 在单声道剪辑上设置平移与设置平衡具有相同的效果，但CPU开销成本高得多，因此不建议使用单声道剪辑。
        另请参见：
        getPan() ， setPan(double)

      • priority

        public IntegerProperty priorityProperty
        剪辑相对于其他剪辑的相对优先级。 当超过最大允许剪辑次数时，此值用于确定要删除的剪辑。 优先级越低，剪辑越有可能被停止并从其占用的混音器通道中移除。 有效范围是任意整数; 没有限制。 所有剪辑的默认优先级为零，直到更改为止。 可以播放的同时声音的数量是实现的，也可能取决于系统。
        另请参见：
        getPriority() ， setPriority(int)

      • cycleCount

        public IntegerProperty cycleCountProperty
        当调用play()时剪辑的播放次数 。 一个循环数量为1次，只有一次，一次循环次数为2次，依次为2次。 有效范围为1或以上，但将其设置为INDEFINITE将导致剪辑继续循环，直到调用stop() 。
        另请参见：
        getCycleCount() ， setCycleCount(int)

    • 字段详细信息

      • INDEFINITE

        public static final int INDEFINITE
        当cycleCount设置为此值时， AudioClip将连续循环，直到停止。 该值与MediaPlayer.INDEFINITE和Animation.INDEFINITE同义，这些值可以互换使用。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • AudioClip

        public AudioClip​(String source)
        从提供的源URL创建一个 AudioClip 。
        参数
        source - 从中加载音频剪辑的URL字符串。 这可以是HTTP，HTTPS，FILE或JAR源。
        异常
        NullPointerException - 如果参数是 null 。
        IllegalArgumentException - 如果参数违反了 RFC 2396 。
        MediaException - 加载媒体时是否还有其他问题。

    • 方法详细信息

      • getSource

        public String getSource​()
        获取用于创建此 AudioClip的源URL。
        结果
        源URL提供给构造函数

      • setVolume

        public final void setVolume​(double value)
        设置默认音量级别。 新设置只会在后续播放中生效。
        参数
        value - 此剪辑的新的默认音量级别
        另请参见：
        volume

      • getVolume

        public final double getVolume​()
        获取默认音量级别。
        结果
        此剪辑的默认音量级别
        另请参见：
        volume

      • volumeProperty

        public DoubleProperty volumeProperty​()
        剪辑播放的相对音量级别。 有效范围为0.0（静音）至1.0（全音量）。 值在内部被钳位到该范围，所以超出此范围的值将不会产生额外的影响。 音量由衰减控制，因此低于1.0的值将相应地降低声级。
        另请参见：
        getVolume() ， setVolume(double)

      • setBalance

        public void setBalance​(double balance)
        设置默认平衡级别。 新值只会影响后续的播放。
        参数
        balance - 新的默认余额
        另请参见：
        balance

      • getBalance

        public double getBalance​()
        获取此剪辑的默认平衡级别。
        结果
        此剪辑的默认余额
        另请参见：
        balance

      • balanceProperty

        public DoubleProperty balanceProperty​()
        剪辑的相对左右音量级别。 有效范围是-1.0到1.0，其中-1.0给左声道全音量，而右声道静音，0.0给两个声道全音量，而1.0则向右声道提供全音量并使左声道静音。 超出此范围的值在内部夹紧。
        另请参见：
        getBalance() ， setBalance(double)

      • setRate

        public void setRate​(double rate)
        设置默认回放速率。 新值只会影响后续的播放。
        参数
        rate - 新的默认播放速率
        另请参见：
        rate

      • getRate

        public double getRate​()
        获取默认播放速度。
        结果
        此剪辑的默认播放速率
        另请参见：
        rate

      • rateProperty

        public DoubleProperty rateProperty​()
        剪辑播放的相对速率。 有效范围为0.125（1/8速）至8.0（8倍速）; 超出此范围的值在内部夹紧。 剪辑的正常播放为1.0; 任何其他费率将相应地影响音调和持续时间。
        另请参见：
        getRate() ， setRate(double)

      • setPan

        public void setPan​(double pan)
        设置默认的平移值。 新值只会影响后续的播放。
        参数
        pan - 新的默认平移值
        另请参见：
        pan

      • getPan

        public double getPan​()
        获取默认的平移值。
        结果
        该剪辑的默认平移值
        另请参见：
        pan

      • panProperty

        public DoubleProperty panProperty​()
        剪辑的相对“中心”。 平移值0.0为正常播放剪辑，其中-1.0平移将剪辑完全移动到左声道，并且1.0完全移动到右声道。 与平衡不同，此设置将两个通道混合，因此通道都不会丢失数据。 在单声道剪辑上设置平移与设置平衡具有相同的效果，但CPU开销成本高得多，因此不建议使用单声道剪辑。
        另请参见：
        getPan() ， setPan(double)

      • setPriority

        public void setPriority​(int priority)
        设置默认播放优先级。 新值只会影响后续的播放。
        参数
        priority - 新的默认播放优先级
        另请参见：
        priority

      • getPriority

        public int getPriority​()
        获取默认播放优先级。
        结果
        此剪辑的默认播放优先级
        另请参见：
        priority

      • priorityProperty

        public IntegerProperty priorityProperty​()
        剪辑相对于其他剪辑的相对优先级。 当超过最大允许剪辑次数时，此值用于确定要删除的剪辑。 优先级越低，剪辑越有可能被停止并从其占用的混音器通道中移除。 有效范围是任意整数; 没有限制。 所有剪辑的默认优先级为零，直到更改为止。 可以播放的同时声音的数量是实现的，也可能取决于系统。
        另请参见：
        getPriority() ， setPriority(int)

      • setCycleCount

        public void setCycleCount​(int count)
        设置默认循环计数。 新值只会影响后续的播放。
        参数
        count - 此剪辑的新默认循环计数
        另请参见：
        cycleCount

      • getCycleCount

        public int getCycleCount​()
        获取默认循环计数。
        结果
        该音频剪辑的默认cycleCount
        另请参见：
        cycleCount

      • cycleCountProperty

        public IntegerProperty cycleCountProperty​()
        当调用play()时剪辑的播放次数 。 一个循环数量为1次，只有一次，一次循环次数为2次，依次为2次。 有效范围是1或以上，但将其设置为INDEFINITE将导致剪辑继续循环，直到调用stop() 。
        另请参见：
        getCycleCount() ， setCycleCount(int)

      • play

        public void play​()
        使用所有默认参数播放 AudioClip 。

      • play

        public void play​(double volume)
        使用除卷外的所有默认参数播放AudioClip 。 此方法不会修改剪辑的默认参数。
        参数
        volume - 播放剪辑的音量级别

      • play

        public void play​(double volume,
                 double balance,
                 double rate,
                 double pan,
                 int priority)
        使用给定的参数播放AudioClip 。 由其关联属性指定的范围之外的值被夹紧。 此方法不会修改剪辑的默认参数。
        参数
        volume - 播放此剪辑的音量级别。 有效音量范围为0.0到1.0，其中0.0被有效地静音，1.0是满量程。
        balance - 立体声效果的左/右平衡或相对通道音量。
        rate - 播放速率倍增器。 1.0将以正常速率播放，而2.0将以一倍的速度播放。
        pan - 将左/右移位应用于剪辑。 平移值-1.0表示全左通道，1.0表示全通道，0.0表示无效。
        priority - 音频效果优先。 如果尝试同时播放太多效果，则优先级较低的效果将首先下降。

      • isPlaying

        public boolean isPlaying​()
        说明这个AudioClip是否在播放。 如果这返回true，那么play()已经被调用了至少一次，它仍在播放。
        结果
        如果任何混音器通道将此片段排队，则为真，否则为false

      • stop

        public void stop​()
        Immediately stop all playback of this AudioClip.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AudioEqualizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class AudioEqualizer

  • java.lang.Object
    • javafx.scene.media.AudioEqualizer

  • public final class AudioEqualizer
extends Object
    AudioEqualizer类为媒体播放器提供音频均衡控制。 它包含ObservableList的EqualizerBand元素。 每个AudioEqualizer实例连接到一个MediaPlayer ，可以使用MediaPlayer.getAudioEqualizer方法获得。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MediaPlayer ， EqualizerBand

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty enabled
      启用或禁用 AudioEqualizer 。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int MAX_NUM_BANDS
      AudioEqualizer可能包含的最大频带数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanProperty enabledProperty​()
      启用或禁用 AudioEqualizer 。
      ObservableList<EqualizerBand> getBands​()
      ObservableList包含EqualizerBand元素。
      boolean isEnabled​()
      获取启用属性的值。
      void setEnabled​(boolean value)
      设置启用属性的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • enabled

        public BooleanProperty enabledProperty
        启用或禁用AudioEqualizer 。 如果启用的属性设置为false ，则在播放期间保留AudioEqualizer设置，但不考虑其设置，这相当于将所有EqualizerBand.gain属性设置为零。
        Default value:
        true
        另请参见：
        isEnabled() ， setEnabled(boolean)

    • 字段详细信息

      • MAX_NUM_BANDS

        public static final int MAX_NUM_BANDS
        AudioEqualizer可能包含的最大频带数。 在当前的实现中，该值为64 。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getBands

        public final ObservableList<EqualizerBand> getBands​()
        ObservableList包含EqualizerBand个元素。 可以通过添加或删除EqualizerBand元素来更改序列的内容。 添加元素时，用户必须准备好捕获IllegalArgumentException，因为如果新添加的实例无效，可以否决内部列表的任何更改。

        有效的EqualizerBand实例的约束是：

        • EqualizerBand.centerFrequency > 0
        • EqualizerBand.bandwidth > 0
        • EqualizerBand.MIN_GAIN个 â‰¤ EqualizerBand.gain â‰¤ EqualizerBand.MAX_GAIN

        默认的乐队组如下表所示; 所有频带具有单位增益（0dB）。

        AudioEqualizer Band Table Band Index Center Frequency (Hz) Bandwidth (Hz) 0 32 19 1 64 39 2 125 78 3 250 156 4 500 312 5 1000 625 6 2000 1250 7 4000 2500 8 8000 5000 9 16000 10000
        结果
        ObservableList包含EqualizerBand个元素。

      • setEnabled

        public final void setEnabled​(boolean value)
        设置启用属性的值。
        Property description:
        启用或禁用AudioEqualizer 。 如果启用的属性设置为false ，则在播放期间保留AudioEqualizer设置，但不考虑设置，这相当于将所有EqualizerBand.gain属性设置为零。
        Default value:
        true

      • isEnabled

        public final boolean isEnabled​()
        获取启用属性的值。
        Property description:
        启用或禁用AudioEqualizer 。 如果启用的属性设置为false ，则在播放期间保留AudioEqualizer设置，但不考虑其中的设置，这相当于将所有EqualizerBand.gain属性设置为零。
        Default value:
        true

      • enabledProperty

        public BooleanProperty enabledProperty​()
        启用或禁用AudioEqualizer 。 如果启用的属性设置为false ，则在播放期间保留AudioEqualizer设置，但不考虑其中的设置，这相当于将所有EqualizerBand.gain属性设置为零。
        Default value:
        true
        另请参见：
        isEnabled(), setEnabled(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AudioSpectrumListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Interface AudioSpectrumListener

  • public interface AudioSpectrumListener
    音频频谱回调接口。 观察者接收音频频谱的定期更新。 单个观察者可附连到一个给定的MediaPlayer使用MediaPlayer.setAudioSpectrumListener(javafx.scene.media.AudioSpectrumListener) 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MediaPlayer

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void spectrumDataUpdate​(double timestamp, double duration, float[] magnitudes, float[] phases)
      向观察者通知可用于音频频谱的新数据。

    • 方法详细信息

      • spectrumDataUpdate

        void spectrumDataUpdate​(double timestamp,
                        double duration,
                        float[] magnitudes,
                        float[] phases)
        向观察者通知可用于音频频谱的新数据。

        更新所述通知周期可使用设置MediaPlayer.setAudioSpectrumInterval(double) ，并且经由带和灵敏度阈值的数量MediaPlayer.setAudioSpectrumNumBands(int)和MediaPlayer.setAudioSpectrumThreshold(int)分别。 默认值为0.1秒， 128频段，灵敏度阈值为-60.0 dB。

        传递给侦听器的数组应被视为只读，因为底层实现可能会重新使用它们。

        参数
        timestamp - 以秒为单位的事件时间戳。
        duration - 以秒为单位计算频谱的持续时间。
        magnitudes - 包含每个频带的非正谱幅度（以dB为单位）的阵列（dB）。 数组的大小等于带的数量，应该被认为是只读的。
        phases -包含相在范围[阵列Math.PI ， Math.PI ]针对每个频带。 数组的大小等于带的数量，应该被认为是只读的。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AudioTrack (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class AudioTrack

  • java.lang.Object
    • javafx.scene.media.Track
      • javafx.scene.media.AudioTrack

  • public final class AudioTrack
extends Track
    A Track描述了音轨。 音频轨道可以例如是数字音乐中的唯一轨迹或视听媒体资源中的几个轨道之一。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      String getLanguage​()
      已过时。
      改用Track.getLocale() 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.media.Track

        getLocale, getMetadata, getName, getTrackID, toString

    • 方法详细信息

      • getLanguage

        @Deprecated
public final String getLanguage​()
        已过时。 改用Track.getLocale() 。
        检索音轨的语言。 IANA语言代码可能是例如英语的“en”或俄语的“ru”。 所有注册的IANA语言代码的列表可在IANA Language Subtag Registry中找到 。
        结果
        the IANA language code or null.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EqualizerBand (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class EqualizerBand

  • java.lang.Object
    • javafx.scene.media.EqualizerBand

  • public final class EqualizerBand
extends Object
    所述EqualizerBand类提供了在每个频带控制AudioEqualizer 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    AudioEqualizer

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty bandwidth
      带的带宽以赫兹为单位。
      DoubleProperty centerFrequency
      乐队的中心频率为赫兹。
      DoubleProperty gain
      应用于该频带的频率的增益。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double MAX_GAIN
      最大可能的增益值。
      static double MIN_GAIN
      最小可能的增益值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      EqualizerBand​()
      默认构造函数 EqualizerBand 。
      EqualizerBand​(double centerFrequency, double bandwidth, double gain)
      自定义 EqualizerBand构造函数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty bandwidthProperty​()
      带的带宽以赫兹为单位。
      DoubleProperty centerFrequencyProperty​()
      乐队的中心频率为赫兹。
      DoubleProperty gainProperty​()
      应用于该频带的频率的增益。
      double getBandwidth​()
      检索频带的带宽。
      double getCenterFrequency​()
      检索乐队的中心频率。
      double getGain​()
      检索应用于乐队的增益。
      void setBandwidth​(double value)
      设置频带的带宽为赫兹。
      void setCenterFrequency​(double value)
      设定赫兹频带上的中心频率。
      void setGain​(double value)
      以dB为单位设置频带的增益。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • centerFrequency

        public DoubleProperty centerFrequencyProperty
        乐队的中心频率为赫兹。 默认值为0.0 Hz。
        另请参见：
        getCenterFrequency() ， setCenterFrequency(double)

      • bandwidth

        public DoubleProperty bandwidthProperty
        带的带宽以赫兹为单位。 默认值为0.0 Hz。
        另请参见：
        getBandwidth() ， setBandwidth(double)

      • gain

        public DoubleProperty gainProperty
        应用于该频带的频率的增益。 默认值为0.0 dB。
        另请参见：
        getGain() ， setGain(double)

    • 字段详细信息

      • MIN_GAIN

        public static final double MIN_GAIN
        最小可能的增益值。 在当前实现中，该值为-24.0 dB。
        另请参见：
        Constant Field Values

      • MAX_GAIN

        public static final double MAX_GAIN
        最大可能的增益值。 在当前实现中，该值为12.0 dB。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • EqualizerBand

        public EqualizerBand​()
        默认构造函数EqualizerBand 。 它创建一个实例centerFrequency ， bandwidth和gain设置为0。

      • EqualizerBand

        public EqualizerBand​(double centerFrequency,
                     double bandwidth,
                     double gain)
        自定义EqualizerBand构造函数。 它创建从一个实例centerFrequency ， bandwidth和gain参数。 gain指定要应用于频带中心频率的放大量（ gain > 0.0 dB）或衰减（ gain < 0.0 dB）。 带宽是均衡器传递函数的上边缘和下边缘之间的频率扩展，其具有峰值的一半dB增益（中心频率）。
        参数
        centerFrequency - 以赫兹表示频带的中心频率的正值。
        bandwidth - 指定以赫兹为单位的带宽的正值。
        gain -以分贝的增益，以在范围[被施加到带 MIN_GAIN ， MAX_GAIN ]分贝。

    • 方法详细信息

      • setCenterFrequency

        public final void setCenterFrequency​(double value)
        设定赫兹频带上的中心频率。
        参数
        value - 必须以Hz为正值的中心频率。

      • getCenterFrequency

        public final double getCenterFrequency​()
        检索乐队的中心频率。
        结果
        赫兹频带中心频率。

      • centerFrequencyProperty

        public DoubleProperty centerFrequencyProperty​()
        乐队的中心频率为赫兹。 默认值为0.0 Hz。
        另请参见：
        getCenterFrequency() ， setCenterFrequency(double)

      • setBandwidth

        public final void setBandwidth​(double value)
        设置频带的带宽为赫兹。
        参数
        value - 必须以Hz为单位的带宽。

      • getBandwidth

        public final double getBandwidth​()
        检索频带的带宽。
        结果
        带的带宽在赫兹。

      • bandwidthProperty

        public DoubleProperty bandwidthProperty​()
        带的带宽以赫兹为单位。 默认值为0.0 Hz。
        另请参见：
        getBandwidth() ， setBandwidth(double)

      • setGain

        public final void setGain​(double value)
        以dB为单位设置频带的增益。 增益属性限制在MIN_GAIN至MAX_GAIN之间 。
        参数
        value -在范围[增益 MIN_GAIN ， MAX_GAIN 。

      • getGain

        public final double getGain​()
        检索应用于乐队的增益。
        结果
        以dB为单位的频带增益。

      • gainProperty

        public DoubleProperty gainProperty​()
        应用于该频带的频率的增益。 默认值为0.0 dB。
        另请参见：
        getGain() ， setGain(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javafx.scene.media (Java SE 9 & JDK 9 )

javafx.scene.media

Interfaces

  • AudioSpectrumListener

Classes

  • AudioClip
  • AudioEqualizer
  • AudioTrack
  • EqualizerBand
  • Media
  • MediaErrorEvent
  • MediaMarkerEvent
  • MediaPlayer
  • MediaView
  • SubtitleTrack
  • Track
  • VideoTrack

Enums

  • MediaException.Type
  • MediaPlayer.Status

Exceptions

  • MediaException


javafx.scene.media (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.media

Package javafx.scene.media

提供用于将音频和视频集成到Java FX应用程序中的一组类。 此软件包的主要用途是媒体播放。 有媒体包三个主要类别： Media ， MediaPlayer ，并MediaView 。

内容

  1. Supported Media Types
  2. Supported Protocols
  3. Supported Metadata Tags
  4. Playing Media in Java FX

支持的媒体类型

Java FX支持多种不同的媒体类型。 媒体类型被认为是容器格式和一个或多个编码的组合。 在某些情况下，容器格式可能只是包含编码数据的基本流。

支持的编码类型

编码类型指定如何存储采样的音频或视频数据。 通常编码类型意味着特定的压缩算法。 下表列出了Java FX Media支持的编码类型。

Media Encoding Table Encoding Type Description AAC Audio Advanced Audio Coding audio compression MP3 Audio Raw MPEG-1, 2, and 2.5 audio; layers I, II, and III; all supported combinations of sampling frequencies and bit rates. Note: File must contain at least 3 MP3 frames. PCM Audio Uncompressed, raw audio samples H.264/AVC Video H.264/MPEG-4 Part 10 / AVC (Advanced Video Coding) video compression VP6 (*) Video On2 VP6 video compression

（*）自JDK 9起，VP6视频编码已被弃用。

支持的容器类型

容器类型指定用于存储编码音频，视频和其他媒体数据的文件格式。 每个容器类型与一个或多个MIME类型，文件扩展名和文件签名（文件中的初始字节）相关联。 下表显示了Java FX Media支持的容器和编码类型的组合。

Media Container / Encoding Types Table Container Description Video Encoding Audio Encoding MIME Type File Extension AIFF Audio Interchange File Format N/A PCM audio/x-aiff .aif, .aiff FXM, FLV (*) FX Media, Flash Video VP6 MP3 video/x-javafx, video/x-flv .fxm, .flv HLS (**) MP2T HTTP Live Streaming (audiovisual) H.264/AVC AAC application/vnd.apple.mpegurl, audio/mpegurl .m3u8 HLS (**) MP3 HTTP Live Streaming (audio-only) N/A MP3 application/vnd.apple.mpegurl, audio/mpegurl .m3u8 MP3 MPEG-1, 2, 2.5 raw audio stream possibly with ID3 metadata v2.3 or v2.4 N/A MP3 audio/mpeg .mp3 MP4 MPEG-4 Part 14 H.264/AVC AAC video/mp4, audio/x-m4a, video/x-m4v .mp4, .m4a, .m4v WAV Waveform Audio Format N/A PCM audio/x-wav .wav

（*）自JDK 9起，FXM和FLV容器已弃用。
（**）HLS是一个协议而不是一个容器类型，但是这里包含了类似的属性。

支持的协议

Supported Protocols Table Protocol Description Reference FILE Protocol for URI representation of local files java.net.URI HTTP Hypertext transfer protocol for representation of remote files java.net.URI HTTPS Hypertext transfer protocol secure for representation of remote files java.net.URI JAR Representation of media entries in files accessible via the FILE, HTTP or HTTPS protocols java.net.JarURLConnection HTTP Live Streaming (HLS) Playlist-based media streaming via HTTP or HTTPS Internet-Draft: HTTP Live Streaming

通过HTTP播放MPEG-4

建议通过HTTP或HTTPS进行播放的MPEG-4媒体进行格式化，以使解码流所需的标头显示在文件的开头。 否则播放可能会停止，直到整个文件被下载。

HTTP直播（HLS）

HLS播放处理具有以下特征的源：

  • 按需播放列表和现场播放列表。
  • 基本MP3音频流（音频/ mpegurl）和复用MP2T流（应用程序/ vnd.apple.mpegurl）与一个AAC音频和一个H.264 / AVC视频轨道。
  • 整数或浮动时间的播放列表。

不符合此基本资料的来源不能保证被处理。 播放列表包含关于包括源的流的信息，并且在回放开始时被下载。 根据网络条件自动处理备用流，比特率和视频分辨率之间的切换。

支持的元数据标签

媒体容器还可以包括描述文件中的媒体的某些元数据。 Java FX Media API通过Media.getMetadata()方法使元数据可用。 该映射中的键被称为标签 ，下表列出了Java FX Media支持的标签。 请注意，给定媒体源可用的标签取决于实际存储在该源中的元数据，即，并非所有标签都可用。 "Metadata Keys and Tags Table Container Tag (type String) Type Description FXM, FLV audio codec java.lang.String The encoder used for the audio track. FXM, FLV duration javafx.util.Duration The duration of the media. FXM, FLV video codec java.lang.String The encoder used for the video track. FXM, FLV width java.lang.Integer The width in pixels of the video track. FXM, FLV height java.lang.Integer The height in pixels of the video track. FXM, FLV framerate java.lang.Double The video frame rate in frames per second. FXM, FLV creationdate java.lang.String The date when the video was created. FXM, FLV, MP3 raw metadata Map<String,ByteBuffer> The raw metadata according to the appropriate media specification. The key "ID3" maps to MP3 ID3v2 metadata and "FLV" to the FLV onMetadata marker content. MP3 album artist java.lang.String The artist for the overall album, possibly "Various Artists" for compilations. MP3 album java.lang.String The name of the album. MP3 artist java.lang.String The artist of the track. MP3 comment-N java.lang.String A comment where N is a 0-relative index. Comment format: ContentDescription[lng]=Comment MP3 composer java.lang.String The composer of the track. MP3 year java.lang.Integer The year the track was recorded. MP3 disc count java.lang.Integer The number of discs in the album. MP3 disc number java.lang.Integer The 1-relative index of the disc on which this track appears. MP3 duration javafx.util.Duration The duration of the track. MP3 genre java.lang.String The genre of the track, for example, "Classical," "Darkwave," or "Jazz." MP3 image javafx.scene.image.Image The album cover. MP3 title java.lang.String The name of the track. MP3 track count java.lang.Integer The number of tracks on the album. MP3 track number java.lang.Integer The 1-relative index of this track on the disc.

在Java FX中播放媒体

基本播放

在Java FX中播放媒体所需的基本步骤是：

  1. 为所需的媒体源创建一个Media对象。
  2. 创建MediaPlayer从对象Media对象。
  3. 创建一个MediaView对象。
  4. 将MediaPlayer添加到MediaView 。
  5. 将MediaView添加到场景图。
  6. 调用MediaPlayer.play() 。
上述步骤由MediaView类文档中的示例代码说明。 应该注意的一些事情是：
  • 一个Media对象可以在多个MediaPlayer之间共享。
  • 一个MediaPlayer可以共享MediaView multiple MediaView s。
  • 媒体可以由MediaPlayer直接播放，而不需要创建MediaView尽管需要显示视图。
  • 取而代之的MediaPlayer.play() ， MediaPlayer.setAutoPlay(true)可用于要求打尽快启动。
  • MediaPlayer具有MediaPlayer.Status定义的几个操作状态。
  • 可以使用AudioClip播放音频媒体（推荐用于短片段的低延迟播放）。

错误处理

使用Java FX Media的错误可能是同步或异步的。 一般来说，同步错误将自动显示为Java 异常 ，异步错误将导致设置Java FX属性。 在后一种情况下，可能会直接观察到error属性，注册了onError回调，或者可能两者。

同步错误的主要来源是Media()和MediaPlayer() 。 异步错误属性是Media.error和MediaPlayer.error ，和异步错误回调Media.onError ， MediaPlayer.onError ，和MediaView.onError 。

某些错误可能会重复。 例如，一个MediaPlayer将传播一个与其相关联的Media遇到的错误，以及一个MediaPlayer到其所有相关联的MediaView的错误。 因此，根据监视哪些属性，有可能接收到给定错误发生的多个通知。

以下代码片段说明了使用介质进行的错误处理：

   String source; Media media; MediaPlayer mediaPlayer; MediaView mediaView; try { media = new Media(source); if (media.getError() == null) { media.setOnError(new Runnable() { public void run() { // Handle asynchronous error in Media object. } }); try { mediaPlayer = new MediaPlayer(media); if (mediaPlayer.getError() == null) { mediaPlayer.setOnError(new Runnable() { public void run() { // Handle asynchronous error in MediaPlayer object. } }); mediaView = new MediaView(mediaPlayer); mediaView.setOnError(new EventHandler<MediaErrorEvent>() { public void handle(MediaErrorEvent t) { // Handle asynchronous error in MediaView. } }); } else { // Handle synchronous error creating MediaPlayer. } } catch (Exception mediaPlayerException) { // Handle exception in MediaPlayer constructor. } } else { // Handle synchronous error creating Media. } } catch (Exception mediaException) { // Handle exception in Media constructor. }
  • 接口摘要
    接口 描述
    AudioSpectrumListener
    音频频谱回调接口。
  • 类摘要
    Class 描述
    AudioClip
    AudioClip表示可以以最小延迟播放的音频段。
    AudioEqualizer
    AudioEqualizer类为媒体播放器提供音频均衡控制。
    AudioTrack
    A Track描述了音轨。
    EqualizerBand
    所述EqualizerBand类提供了在每个频带控制AudioEqualizer 。
    Media
    Media类代表媒体资源。
    MediaErrorEvent
    一个Event表示在处理媒体时发生错误。
    MediaMarkerEvent
    代表媒体标记的ActionEvent 。
    MediaPlayer
    MediaPlayer课程提供播放媒体的控制。
    MediaView
    A Node ，提供Media由MediaPlayer播放的视图 。
    SubtitleTrack
    A Track ，其包含要覆盖视频轨道的字幕或字幕数据。
    Track
    表示媒体资源中包含的曲目的类。
    VideoTrack
    A Track描述了视频轨道。
  • 枚举摘要
    Enum 描述
    MediaException.Type
    描述错误类别的枚举。
    MediaPlayer.Status
    枚举描述不同状态值的一个MediaPlayer 。
  • 异常摘要
    异常 描述
    MediaException
    甲MediaException描述了在运行时错误条件Media ， MediaPlayer或MediaView 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.media Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.media

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.media.AudioClip
    • javafx.scene.media.AudioEqualizer
    • javafx.scene.media.EqualizerBand
    • java.util.EventObject (implements java.io.Serializable)
      • javafx.event.Event (implements java.lang.Cloneable)
        • javafx.event.ActionEvent
          • javafx.scene.media.MediaMarkerEvent
        • javafx.scene.media.MediaErrorEvent
    • javafx.scene.media.Media
    • javafx.scene.media.MediaPlayer
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.media.MediaView
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • javafx.scene.media.MediaException
    • javafx.scene.media.Track
      • javafx.scene.media.AudioTrack
      • javafx.scene.media.SubtitleTrack
      • javafx.scene.media.VideoTrack

Interface Hierarchy

  • javafx.scene.media.AudioSpectrumListener

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.media.MediaException.Type
      • javafx.scene.media.MediaPlayer.Status
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Media (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class Media

  • java.lang.Object
    • javafx.scene.media.Media

  • public final class Media
extends Object
    Media类代表媒体资源。 它是从源URI的字符串形式实例化的。 关于媒体的信息，例如持续时间，元数据，曲目和视频分辨率可以从Media实例获得。 媒体信息是异步获取的，因此不一定可以在类实例化之后立即获得。 然而，如果实例已与MediaPlayer相关联，并且该播放器已转换为MediaPlayer.Status.READY状态，则所有信息都可用。 要添加元数据或Track的通知，观察员可以分别注册getMetadata()和getTracks()返回的集合。

    相同的Media对象可以在多个MediaPlayer对象之间共享。 这样的共享实例可以管理要由所有玩家使用的源媒体数据的单个副本，或者可能需要针对每个玩家的单独的数据副本。 然而，实现的选择不会对界面级别的玩家行为产生任何影响。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MediaPlayer ， MediaException

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<Duration> duration
      源介质的持续时间（以秒为单位）。
      ReadOnlyObjectProperty<MediaException> error
      发生错误时将属性设置为MediaException值。
      ReadOnlyIntegerProperty height
      源媒体的像素高度。
      ObjectProperty<Runnable> onError
      发生错误时调用事件处理程序。
      ReadOnlyIntegerProperty width
      源媒体的像素宽度。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Media​(String source)
      构造一个 Media实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Duration> durationProperty​()
      源介质的持续时间（以秒为单位）。
      ReadOnlyObjectProperty<MediaException> errorProperty​()
      发生错误时将属性设置为MediaException值。
      Duration getDuration​()
      检索介质的持续时间（以秒为单位）。
      MediaException getError​()
      返回媒体中遇到的任何错误。
      int getHeight​()
      检索媒体的像素高度。
      ObservableMap<String,Duration> getMarkers​()
      检索此 Media实例上定义的标记。
      ObservableMap<String,Object> getMetadata​()
      检索此媒体源中包含的元数据。
      Runnable getOnError​()
      如果发生错误，则检索要调用的错误处理程序。
      String getSource​()
      检索媒体的源URI。
      ObservableList<Track> getTracks​()
      检索此媒体源中包含的曲目。
      int getWidth​()
      检索媒体的像素宽度。
      ReadOnlyIntegerProperty heightProperty​()
      源媒体的像素高度。
      ObjectProperty<Runnable> onErrorProperty​()
      发生错误时调用事件处理程序。
      void setOnError​(Runnable value)
      设置发生错误时调用的事件处理程序。
      ReadOnlyIntegerProperty widthProperty​()
      源媒体的像素宽度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • error

        public ReadOnlyObjectProperty<MediaException> errorProperty
        发生错误时将属性设置为MediaException值。 如果error是非null ，则介质无法加载，不可用。 如果onError为非null ，则在设置error属性时将调用它。
        另请参见：
        getError()

      • onError

        public ObjectProperty<Runnable> onErrorProperty
        发生错误时调用事件处理程序。 如果格式错误或无效的URL传递给构造函数或访问URL时出现问题，则会发生这种情况。
        另请参见：
        getOnError() ， setOnError(Runnable)

      • width

        public ReadOnlyIntegerProperty widthProperty
        源媒体的像素宽度。 如果媒体没有宽度，例如播放音频时，或如果流媒体可能会出现宽度当前未知，则可能为零。
        另请参见：
        getWidth()

      • height

        public ReadOnlyIntegerProperty heightProperty
        源媒体的像素高度。 如果媒体没有高度，例如播放音频时，或如果当前未知的高度可能会与流媒体有关，则这可能为零。
        另请参见：
        getHeight()

      • duration

        public ReadOnlyObjectProperty<Duration> durationProperty
        源介质的持续时间（以秒为单位）。 如果媒体持续时间未知，则此属性值将为Duration.UNKNOWN 。
        另请参见：
        getDuration()

    • 构造方法详细信息

      • Media

        public Media​(String source)
        构造一个Media实例。 这是指定媒体源的唯一方法。 来源必须代表有效的URI并且是不可变的。 只支持HTTP，HTTPS，FILE和JAR URL 。 如果提供的URL无效，则会抛出异常。 如果发生异步错误，将会设置error属性。 听这个属性被通知任何这样的错误。

        如果源使用非阻塞协议（如FILE），那么立即可以检测到的任何问题将导致抛出MediaException 。 这些问题包括媒体无法访问或不受支持的格式。 然而，如果使用了诸如HTTP之类的潜在的阻塞协议，则连接将被异步初始化，以便通过设置error属性来发出这些错误信号。

        约束：

        • 提供的URI必须符合java.net.URI要求的RFC-2396。
        • 只支持HTTP，HTTPS，FILE和JAR URI。

        有关URI格式的更多信息，请参阅java.net.URI 。 JAR URL语法在java.net.JarURLConnection中指定。

        参数
        source - 源媒体的URI。
        异常
        NullPointerException - 如果URI字符串是 null 。
        IllegalArgumentException - 如果URI字符串不符合RFC-2396或（如果适用）Jar URL规范，或者是不符合SSL规定的表单，不能修改为兼容表单。
        IllegalArgumentException - 如果URI字符串具有 null方案。
        UnsupportedOperationException - 如果不支持为源指定的协议。
        MediaException - 如果无法连接媒体源（类型 MediaException.Type.MEDIA_INACCESSIBLE ）或不支持（类型 MediaException.Type.MEDIA_UNSUPPORTED ）。

    • 方法详细信息

      • getError

        public final MediaException getError​()
        返回媒体中遇到的任何错误。
        结果
        一个MediaException或null如果没有错误。

      • errorProperty

        public ReadOnlyObjectProperty<MediaException> errorProperty​()
        发生错误时将属性设置为MediaException值。 如果error为非null ，则介质无法加载且不可用。 如果onError是非null ，则在设置error属性时将被调用。
        另请参见：
        getError()

      • setOnError

        public final void setOnError​(Runnable value)
        设置发生错误时调用的事件处理程序。
        参数
        value - 错误事件处理程序。

      • getOnError

        public final Runnable getOnError​()
        如果发生错误，则检索要调用的错误处理程序。
        结果
        错误处理程序或 null如果没有定义）。

      • onErrorProperty

        public ObjectProperty<Runnable> onErrorProperty​()
        发生错误时调用事件处理程序。 如果格式错误或无效的URL传递给构造函数或访问URL时出现问题，则会发生这种情况。
        另请参见：
        getOnError() ， setOnError(Runnable)

      • getMetadata

        public final ObservableMap<String,Object> getMetadata​()
        检索此媒体源中包含的元数据。 如果没有元数据，则返回的ObservableMap将为空。
        结果
        该媒体源中包含的元数据。

      • getWidth

        public final int getWidth​()
        检索媒体的像素宽度。
        结果
        介质宽度或如果宽度未定义或未知，则为零。

      • widthProperty

        public ReadOnlyIntegerProperty widthProperty​()
        源媒体的像素宽度。 如果媒体没有宽度，例如播放音频时，或如果流媒体可能会出现宽度当前未知，则可能为零。
        另请参见：
        getWidth()

      • getHeight

        public final int getHeight​()
        检索媒体的像素高度。
        结果
        介质高度或零，如果高度未定义或未知。

      • heightProperty

        public ReadOnlyIntegerProperty heightProperty​()
        源媒体的像素高度。 如果媒体没有高度，例如播放音频时，或如果当前未知的高度可能会与流媒体有关，则这可能为零。
        另请参见：
        getHeight()

      • getDuration

        public final Duration getDuration​()
        检索介质的持续时间（以秒为单位）。
        结果
        媒体持续时间 Duration.UNKNOWN如果未知，或 Duration.INDEFINITE的直播流

      • durationProperty

        public ReadOnlyObjectProperty<Duration> durationProperty​()
        源介质的持续时间（以秒为单位）。 如果媒体持续时间未知，则此属性值将为Duration.UNKNOWN 。
        另请参见：
        getDuration()

      • getTracks

        public final ObservableList<Track> getTracks​()
        检索此媒体源中包含的曲目。 如果没有轨道，返回的ObservableList将为空。
        结果
        该媒体源中包含的曲目。

      • getMarkers

        public final ObservableMap<String,Duration> getMarkers​()
        检索此Media实例上定义的标记。 如果没有标记，返回的ObservableMap将为空。 可以通过在返回的Map插入条目来添加编程标记。
        结果
        在此媒体源上定义的标记。

      • getSource

        public String getSource​()
        检索媒体的源URI。
        结果
        媒体源URI为String 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MediaErrorEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class MediaErrorEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.media.MediaErrorEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class MediaErrorEvent
extends Event
    一个Event代表在处理媒体时发生错误。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<MediaErrorEvent> MEDIA_ERROR
      唯一有效的事件类型为 MediaErrorEvent 。

      • Fields inherited from class javafx.event.Event

        ANY, consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MediaErrorEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      EventType<MediaErrorEvent> getEventType​()
      获取此事件的事件类型。
      MediaException getMediaError​()
      检索与此事件相关联的错误。
      String toString​()
      检索事件的 String表示。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MEDIA_ERROR

        public static final EventType<MediaErrorEvent> MEDIA_ERROR
        唯一有效的事件类型为 MediaErrorEvent 。

    • 方法详细信息

      • getMediaError

        public MediaException getMediaError​()
        检索与此事件相关联的错误。
        结果
        MediaException

      • toString

        public String toString​()
        检索事件的 String表示。
        重写：
        toString在 EventObject
        结果
        这个EventObject的一个String表示形式。

      • copyFor

        public MediaErrorEvent copyFor​(Object newSource,
                               EventTarget newTarget)
        描述从类复制： Event
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor中的 Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • getEventType

        public EventType<MediaErrorEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType中的 Event
        结果
        the event type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


MediaException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class MediaException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javafx.scene.media.MediaException
  • All Implemented Interfaces:
    Serializable

    public final class MediaException
extends RuntimeException
    甲MediaException描述了在运行时错误条件Media ， MediaPlayer或MediaView 。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Media.onErrorProperty() ， MediaView.onErrorProperty() ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  MediaException.Type
      描述错误类别的枚举。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MediaException.Type getType​()
      检索此错误所在的类别。
      String toString​()
      返回此 MediaException对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

    • 方法详细信息

      • getType

        public MediaException.Type getType​()
        检索此错误所在的类别。
        结果
        这种错误的类型

      • toString

        public String toString​()
        返回此 MediaException对象的字符串表示形式。
        重写：
        toString在 Throwable
        结果
        这是一个 MediaException对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MediaException.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Enum MediaException.Type

  • java.lang.Object
    • java.lang.Enum<MediaException.Type>
      • javafx.scene.media.MediaException.Type
  • All Implemented Interfaces:
    Serializable ， Comparable<MediaException.Type>
    Enclosing class:
    MediaException

    public static enum MediaException.Type
extends Enum<MediaException.Type>
    描述错误类别的枚举。 一些不同的实际异常可能属于同一类别。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      MEDIA_CORRUPTED
      表示发生错误：媒体似乎无效或损坏。
      MEDIA_INACCESSIBLE
      表示发生错误：虽然媒体可能存在，但它是不可访问的。
      MEDIA_UNAVAILABLE
      表示发生错误：介质不存在或不可用。
      MEDIA_UNSPECIFIED
      表示尚未指定介质。
      MEDIA_UNSUPPORTED
      表示此平台不支持此媒体类型。
      OPERATION_UNSUPPORTED
      表示此平台不支持在介质上执行的操作。
      PLAYBACK_ERROR
      表示不属于任何其他预定义类别的播放错误。
      PLAYBACK_HALTED
      表示导致停止播放的不可恢复的错误。
      UNKNOWN
      表示由于未知原因而发生错误。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static MediaException.Type valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MediaException.Type[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MEDIA_CORRUPTED

        public static final MediaException.Type MEDIA_CORRUPTED
        表示发生错误：媒体似乎无效或损坏。

      • MEDIA_INACCESSIBLE

        public static final MediaException.Type MEDIA_INACCESSIBLE
        表示发生错误：虽然媒体可能存在，但它是不可访问的。

      • MEDIA_UNAVAILABLE

        public static final MediaException.Type MEDIA_UNAVAILABLE
        表示发生错误：介质不存在或不可用。 此错误可能是在浏览器中运行时防止访问的安全设置的结果。

      • MEDIA_UNSPECIFIED

        public static final MediaException.Type MEDIA_UNSPECIFIED
        表示尚未指定介质。

      • MEDIA_UNSUPPORTED

        public static final MediaException.Type MEDIA_UNSUPPORTED
        表示此平台不支持此媒体类型。

      • OPERATION_UNSUPPORTED

        public static final MediaException.Type OPERATION_UNSUPPORTED
        表示此平台不支持在介质上执行的操作。

      • PLAYBACK_ERROR

        public static final MediaException.Type PLAYBACK_ERROR
        表示不属于任何其他预定义类别的播放错误。

      • PLAYBACK_HALTED

        public static final MediaException.Type PLAYBACK_HALTED
        表示导致停止播放的不可恢复的错误。

      • UNKNOWN

        public static final MediaException.Type UNKNOWN
        表示由于未知原因而发生错误。

    • 方法详细信息

      • values

        public static MediaException.Type[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (MediaException.Type c : MediaException.Type.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static MediaException.Type valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


MediaMarkerEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class MediaMarkerEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.event.ActionEvent
          • javafx.scene.media.MediaMarkerEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class MediaMarkerEvent
extends ActionEvent
    代表媒体标记的ActionEvent 。 一个标记被添加到一个Media ，然后由一个MediaPlayer播放 。 当播放位置到达标记的位置时触发事件。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    MediaPlayer.onMarker ， Serialized Form

    • Field Summary

      • Fields inherited from class javafx.event.ActionEvent

        ACTION, ANY

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Pair<String,Duration> getMarker​()
      检索事件代表的标记。

      • Methods inherited from class javafx.event.ActionEvent

        copyFor, getEventType

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getMarker

        public Pair<String,Duration> getMarker​()
        检索事件代表的标记。
        结果
        the value of the marker.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MediaPlayer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class MediaPlayer

  • java.lang.Object
    • javafx.scene.media.MediaPlayer

  • public final class MediaPlayer
extends Object
    MediaPlayer类提供播放媒体的控件。 它与Media和MediaView类结合使用以显示和控制媒体播放。 MediaPlayer不包含任何视觉元素，所以必须与MediaView类一起使用，以查看可能存在的任何视频轨道。

    MediaPlayer提供pause() ， play() ， stop()和seek()控制以及所述rate个autoPlay适用于所有类型的媒体属性。 它还提供了balance ， mute和volume性质，这控制音频重放特性。 通过与播放器相关联的AudioEqualizer可以进一步控制音频质量。 通过注册AudioSpectrumListener可以观察到音频播放的频率描述符。 关于重放位置，速率和缓存信息可以从获得currentTime ， currentRate ，和bufferProgressTime性质分别。 媒体标记通知由注册为onMarker属性的事件处理程序接收。

    对于有限持续时间的媒体，播放可以位于0.0与媒体持续时间之间的任何时间点。 MediaPlayer通过添加startTime和stopTime属性来优化此定义，该属性实际上定义了时间位置限制为[startTime,stopTime]的虚拟媒体源。 媒体播放开始于startTime并继续到stopTime 。 由这两个端点所定义的间隔被称为具有持续时间是停止的差和开始时间的循环 。 该循环可以设置为重复特定的或不定期的次数。 媒体播放的总持续时间是周期持续时间和播放次数的乘积。 如果达到循环的停止时间并重新播放周期，则调用注册在onRepeat属性中的事件处理程序。 如果达到停止时间并且不重复循环，则调用注册到onEndOfMedia属性的事件处理程序。 目前正在播放的循环的零相关指数由currentCount维护。

    MediaPlayer的操作MediaPlayer是异步的。 播放器不准备立即响应命令，直到其状态转变为MediaPlayer.Status.READY ，这通常在媒体前贴片完成时发生。 在播放器状态为READY之前发出的一些请求将在输入该状态时生效。 这些包括调用play()无居间调用pause()或stop()的前READY过渡，以及设置任何的autoPlay ， balance ， mute ， rate ， startTime ， stopTime ，和volume性质。

    可以监视status属性以使应用程序知道播放器状态更改，如果在输入特定状态时应采取措施，则可以通过属性（如onReady）注册回调函数。 还有error和onError属性，分别可以在发生错误时进行监视并对其作出响应。

    相同的MediaPlayer对象可以在多个MediaView之间共享。 这不会影响玩家本身。 特别地，视图的属性设置不会对媒体播放产生任何影响。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Media ， MediaView

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty audioSpectrumInterval
      频谱更新之间的间隔（秒）。
      ObjectProperty<AudioSpectrumListener> audioSpectrumListener
      用于音频频谱更新的监听器。
      IntegerProperty audioSpectrumNumBands
      音频频谱中的频带数。
      IntegerProperty audioSpectrumThreshold
      灵敏度阈值以分贝为单位; 必须是非积极的。
      BooleanProperty autoPlay
      是否应尽快开始播放。
      DoubleProperty balance
      音频输出的平衡或左右设置。
      ReadOnlyObjectProperty<Duration> bufferProgressTime
      当前的缓冲位置指示可以播放多少媒体，而不会停止 MediaPlayer 。
      ReadOnlyIntegerProperty currentCount
      完成播放周期的次数。
      ReadOnlyDoubleProperty currentRate
      当前的播放速度，无论设置如何。
      ReadOnlyObjectProperty<Duration> currentTime
      当前媒体播放时间。
      IntegerProperty cycleCount
      媒体播放的次数。
      ReadOnlyObjectProperty<Duration> cycleDuration
      这个玩家的 startTime和 stopTime之间的时间量。
      ReadOnlyObjectProperty<MediaException> error
      如果发生错误，Observable属性设置为 MediaException 。
      BooleanProperty mute
      播放器音频是否静音
      ObjectProperty<Runnable> onEndOfMedia
      当播放器 currentTime达到 stopTime时调用事件处理程序。
      ObjectProperty<Runnable> onError
      发生错误时调用事件处理程序。
      ObjectProperty<Runnable> onHalted
      事件处理程序在状态更改为 HALTED时调用。
      ObjectProperty<EventHandler<MediaMarkerEvent>> onMarker
      当播放器 currentTime到达媒体标记时调用事件处理程序。
      ObjectProperty<Runnable> onPaused
      事件处理程序在状态更改为 PAUSED时调用。
      ObjectProperty<Runnable> onPlaying
      事件处理程序在状态更改为 PLAYING时调用。
      ObjectProperty<Runnable> onReady
      事件处理程序在状态更改为 READY时调用。
      ObjectProperty<Runnable> onRepeat
      当玩家的事件处理函数调用 currentTime达到 stopTime ， 将被重复。
      ObjectProperty<Runnable> onStalled
      当状态更改为 STALLED时调用事件处理程序。
      ObjectProperty<Runnable> onStopped
      当状态更改为 STOPPED时调用事件处理程序。
      DoubleProperty rate
      要播放媒体的速度。
      ObjectProperty<Duration> startTime
      媒体应该开始播放的时间偏移，或重复播放时重新启动。
      ReadOnlyObjectProperty<MediaPlayer.Status> status
      MediaPlayer的当前状态。
      ObjectProperty<Duration> stopTime
      重播时媒体应停止播放或重新启动的时间偏移。
      ReadOnlyObjectProperty<Duration> totalDuration
      播放时间的总量，如果允许玩，直到完成。
      DoubleProperty volume
      要播放媒体的音量。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  MediaPlayer.Status
      描述一个MediaPlayer的不同状态值的枚举 。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int INDEFINITE
      表示有效无限数量的回放周期的值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      MediaPlayer​(Media media)
      为特定媒体创建播放器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty audioSpectrumIntervalProperty​()
      频谱更新之间的间隔（秒）。
      ObjectProperty<AudioSpectrumListener> audioSpectrumListenerProperty​()
      用于音频频谱更新的监听器。
      IntegerProperty audioSpectrumNumBandsProperty​()
      音频频谱中的频带数。
      IntegerProperty audioSpectrumThresholdProperty​()
      灵敏度阈值以分贝为单位; 必须是非积极的。
      BooleanProperty autoPlayProperty​()
      是否应尽快开始播放。
      DoubleProperty balanceProperty​()
      音频输出的平衡或左右设置。
      ReadOnlyObjectProperty<Duration> bufferProgressTimeProperty​()
      当前的缓冲位置指示可以播放多少媒体，而不会停止 MediaPlayer 。
      ReadOnlyIntegerProperty currentCountProperty​()
      完成播放周期的次数。
      ReadOnlyDoubleProperty currentRateProperty​()
      当前的播放速度，无论设置如何。
      ReadOnlyObjectProperty<Duration> currentTimeProperty​()
      当前媒体播放时间。
      IntegerProperty cycleCountProperty​()
      媒体播放的次数。
      ReadOnlyObjectProperty<Duration> cycleDurationProperty​()
      这个玩家的 startTime和 stopTime之间的时间量。
      void dispose​()
      释放与播放器相关的所有资源。
      ReadOnlyObjectProperty<MediaException> errorProperty​()
      如果发生错误，Observable属性设置为 MediaException 。
      AudioEqualizer getAudioEqualizer​()
      检索与此播放器相关联的AudioEqualizer 。
      double getAudioSpectrumInterval​()
      检索音频频谱通知间隔的值，单位为秒。
      AudioSpectrumListener getAudioSpectrumListener​()
      检索音频频谱的听众。
      int getAudioSpectrumNumBands​()
      检索音频频谱中的频带数。
      int getAudioSpectrumThreshold​()
      以分贝取回音频频谱阈值。
      double getBalance​()
      检索音频平衡。
      Duration getBufferProgressTime​()
      检索 bufferProgressTime的值。
      int getCurrentCount​()
      检索当前周期的索引。
      double getCurrentRate​()
      检索当前播放速率。
      Duration getCurrentTime​()
      检索当前媒体时间。
      int getCycleCount​()
      检索周期数。
      Duration getCycleDuration​()
      以秒为单位检索循环持续时间。
      MediaException getError​()
      检索 error属性的值或 null如果没有错误。
      Media getMedia​()
      检索正在播放的Media实例。
      Runnable getOnEndOfMedia​()
      检索媒体事件处理程序的结束。
      Runnable getOnError​()
      检索错误的事件处理程序。
      Runnable getOnHalted​()
      检索 MediaPlayer.Status.HALTED事件处理程序。
      EventHandler<MediaMarkerEvent> getOnMarker​()
      检索标记事件处理程序。
      Runnable getOnPaused​()
      检索 MediaPlayer.Status.PAUSED事件处理程序。
      Runnable getOnPlaying​()
      检索 MediaPlayer.Status.PLAYING事件处理程序。
      Runnable getOnReady​()
      检索 MediaPlayer.Status.READY事件处理程序。
      Runnable getOnRepeat​()
      检索重复事件处理程序。
      Runnable getOnStalled​()
      检索 MediaPlayer.Status.STALLED事件处理程序。
      Runnable getOnStopped​()
      检索 MediaPlayer.Status.STOPPED事件处理程序。
      double getRate​()
      检索播放速度。
      Duration getStartTime​()
      检索开始时间。
      MediaPlayer.Status getStatus​()
      检索当前播放器的状态。
      Duration getStopTime​()
      检索停止时间。
      Duration getTotalDuration​()
      检索总播放持续时间，包括所有周期（重复）。
      double getVolume​()
      检索音频播放音量。
      boolean isAutoPlay​()
      检索 autoPlay属性值。
      boolean isMute​()
      检索 muteProperty()的价值。
      BooleanProperty muteProperty​()
      播放器音频是否静音
      ObjectProperty<Runnable> onEndOfMediaProperty​()
      当播放器 currentTime达到 stopTime时调用事件处理程序。
      ObjectProperty<Runnable> onErrorProperty​()
      发生错误时调用事件处理程序。
      ObjectProperty<Runnable> onHaltedProperty​()
      事件处理程序在状态更改为 HALTED时调用。
      ObjectProperty<EventHandler<MediaMarkerEvent>> onMarkerProperty​()
      当播放器 currentTime到达媒体标记时调用事件处理程序。
      ObjectProperty<Runnable> onPausedProperty​()
      事件处理程序在状态更改为 PAUSED时调用。
      ObjectProperty<Runnable> onPlayingProperty​()
      当状态更改为 PLAYING时调用事件处理程序。
      ObjectProperty<Runnable> onReadyProperty​()
      事件处理程序在状态更改为 READY时调用。
      ObjectProperty<Runnable> onRepeatProperty​()
      当玩家的事件处理函数调用 currentTime达到 stopTime ， 将被重复。
      ObjectProperty<Runnable> onStalledProperty​()
      事件处理程序在状态更改为 STALLED时调用。
      ObjectProperty<Runnable> onStoppedProperty​()
      当状态更改为 STOPPED时调用事件处理程序。
      void pause​()
      暂停播放器
      void play​()
      开始播放媒体。
      DoubleProperty rateProperty​()
      要播放媒体的速度。
      void seek​(Duration seekTime)
      寻找播放器一个新的播放时间。
      void setAudioSpectrumInterval​(double value)
      设置音频频谱通知间隔的值，单位为秒。
      void setAudioSpectrumListener​(AudioSpectrumListener listener)
      设置音频频谱的听众。
      void setAudioSpectrumNumBands​(int value)
      设置音频频谱中的频带数。
      void setAudioSpectrumThreshold​(int value)
      以分贝设置音频频谱阈值。
      void setAutoPlay​(boolean value)
      设置 autoPlay属性值。
      void setBalance​(double value)
      设置音频平衡。
      void setCycleCount​(int value)
      设置周期数。
      void setMute​(boolean value)
      设置值为 muteProperty() 。
      void setOnEndOfMedia​(Runnable value)
      设置媒体事件处理程序的结束。
      void setOnError​(Runnable value)
      设置发生错误时调用的事件处理程序。
      void setOnHalted​(Runnable value)
      设置 MediaPlayer.Status.HALTED事件处理程序。
      void setOnMarker​(EventHandler<MediaMarkerEvent> onMarker)
      设置标记事件处理程序。
      void setOnPaused​(Runnable value)
      设置 MediaPlayer.Status.PAUSED事件处理程序。
      void setOnPlaying​(Runnable value)
      设置 MediaPlayer.Status.PLAYING事件处理程序。
      void setOnReady​(Runnable value)
      设置 MediaPlayer.Status.READY事件处理程序。
      void setOnRepeat​(Runnable value)
      设置重复事件处理程序。
      void setOnStalled​(Runnable value)
      设置 MediaPlayer.Status.STALLED事件处理程序。
      void setOnStopped​(Runnable value)
      设置 MediaPlayer.Status.STOPPED事件处理程序。
      void setRate​(double value)
      将播放速度设置为提供的值。
      void setStartTime​(Duration value)
      设置开始时间。
      void setStopTime​(Duration value)
      设置停止时间。
      void setVolume​(double value)
      设置音频播放音量。
      ObjectProperty<Duration> startTimeProperty​()
      媒体应该开始播放的时间偏移，或重复播放时重新启动。
      ReadOnlyObjectProperty<MediaPlayer.Status> statusProperty​()
      MediaPlayer的当前状态。
      void stop​()
      停止播放媒体。
      ObjectProperty<Duration> stopTimeProperty​()
      重播时媒体应停止播放或重新启动的时间偏移。
      ReadOnlyObjectProperty<Duration> totalDurationProperty​()
      播放时间的总量，如果允许玩，直到完成。
      DoubleProperty volumeProperty​()
      要播放媒体的音量。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • error

        public ReadOnlyObjectProperty<MediaException> errorProperty
        如果发生错误，Observable属性设置为 MediaException 。
        另请参见：
        getError()

      • onError

        public ObjectProperty<Runnable> onErrorProperty
        发生错误时调用事件处理程序。
        另请参见：
        getOnError() ， setOnError(Runnable)

      • autoPlay

        public BooleanProperty autoPlayProperty
        是否应尽快开始播放。 对于新的玩家来说，一旦玩家达到就绪状态，这个玩家就会发生这种情况。 默认值为false 。
        另请参见：
        isAutoPlay() ， setAutoPlay(boolean)

      • rate

        public DoubleProperty rateProperty
        要播放媒体的速度。 例如， 1.0的频率以其正常（编码）播放速率播放媒体， 2.0以正常速率的两倍播放等。目前支持的频率范围是[0.0, 8.0] 。 默认值为1.0 。
        另请参见：
        getRate() ， setRate(double)

      • currentRate

        public ReadOnlyDoubleProperty currentRateProperty
        当前的播放速度，无论设置如何。 例如，如果rate设置为1.0，播放器暂停或停止，则currentRate将为零。
        另请参见：
        getCurrentRate()

      • volume

        public DoubleProperty volumeProperty
        要播放媒体的音量。 有效值范围为[0.0 1.0] ，其中0.0为听不到， 1.0为全音量，为默认值。
        另请参见：
        getVolume() ， setVolume(double)

      • balance

        public DoubleProperty balanceProperty
        音频输出的平衡或左右设置。 有效的值的范围是[-1.0, 1.0]与-1.0充满左， 0.0中心，和1.0充分权利。 默认值为0.0 。
        另请参见：
        getBalance() ， setBalance(double)

      • startTime

        public ObjectProperty<Duration> startTimeProperty
        媒体应该开始播放的时间偏移，或重复播放时重新启动。 当播放停止时，当前时间被重置为该值。 如果该值为正，则播放前第一次播放媒体可能会有延迟，除非播放位置可以设置为媒体内的任意时间。 这可能例如对于不包含视频流中的帧内偏移的查找表的视频而言。 在这种情况下，视频帧将需要被跳过直到达到开始时间之前的第一帧内的位置。 默认值为Duration.ZERO 。

        约束： 0 ≤ startTime < stopTime

        另请参见：
        getStartTime() ， setStartTime(Duration)

      • stopTime

        public ObjectProperty<Duration> stopTimeProperty
        重播时媒体应停止播放或重新启动的时间偏移。 默认值为getMedia().getDuration() 。

        约束： startTime < stopTime ≤ Media.duration

        另请参见：
        getStopTime() ， setStopTime(Duration)

      • cycleDuration

        public ReadOnlyObjectProperty<Duration> cycleDurationProperty
        这个玩家的startTime和stopTime之间的时间量。 对于媒体的总持续时间使用Media.duration属性。
        另请参见：
        getCycleDuration()

      • totalDuration

        public ReadOnlyObjectProperty<Duration> totalDurationProperty
        播放时间的总量，如果允许玩，直到完成。 如果cycleCount设置为INDEFINITE那么这也将是INDEFINITE。 如果Media持续时间为UNKNOWN，则同样为UNKNOWN。 否则，总持续时间将是cycleDuration和cycleCount的乘积。
        另请参见：
        getTotalDuration()

      • currentTime

        public ReadOnlyObjectProperty<Duration> currentTimeProperty
        当前媒体播放时间。 此属性为只读：使用seek(javafx.util.Duration)将播放更改为不同的流位置。
        另请参见：
        getCurrentTime()

      • status

        public ReadOnlyObjectProperty<MediaPlayer.Status> statusProperty
        MediaPlayer的当前状态。
        另请参见：
        getStatus()

      • bufferProgressTime

        public ReadOnlyObjectProperty<Duration> bufferProgressTimeProperty
        当前的缓冲位置指示可以播放多少媒体，而不会停止MediaPlayer 。 这适用于缓冲流，例如从网络连接读取的流，而不是本地文件。

        寻求超出bufferProgressTime的位置可能会导致播放中轻微的暂停，直到缓冲足够允许回放的数据量。

        另请参见：
        getBufferProgressTime()

      • cycleCount

        public IntegerProperty cycleCountProperty
        媒体播放的次数。 默认情况下， cycleCount设置为1这意味着媒体只能播放一次。 将cycleCount设置为大于1的值将导致介质播放给定次数或直到停止。 如果设置为INDEFINITE ，播放将重复，直到调用stop（）或pause（）为止。

        约束： cycleCount ≥ 1

        另请参见：
        getCycleCount() ， setCycleCount(int)

      • currentCount

        public ReadOnlyIntegerProperty currentCountProperty
        完成播放周期的次数。 在第一次通过时，值应为0.在第二遍，值应为1，依此类推。 在追加到startTime之前 ，即在达到stopTime或媒体结束时，它在每个周期结束时递增 。
        另请参见：
        getCurrentCount()

      • mute

        public BooleanProperty muteProperty
        播放器音频是否静音 值true表示音频未生成。 该属性的值对volume没有影响，即如果音频静音，然后未静音，音频播放将以相同的可听级别恢复，当然volume属性尚未被修改。 默认值为false 。
        另请参见：
        isMute() ， setMute(boolean)

      • onMarker

        public ObjectProperty<EventHandler<MediaMarkerEvent>> onMarkerProperty
        当播放器 currentTime到达媒体标记时调用事件处理程序。
        另请参见：
        getOnMarker() ， setOnMarker(EventHandler)

      • onEndOfMedia

        public ObjectProperty<Runnable> onEndOfMediaProperty
        当播放器 currentTime达到 stopTime时调用事件处理程序。
        另请参见：
        getOnEndOfMedia() ， setOnEndOfMedia(Runnable)

      • onReady

        public ObjectProperty<Runnable> onReadyProperty
        事件处理程序在状态更改为 READY时调用。
        另请参见：
        getOnReady() ， setOnReady(Runnable)

      • onPlaying

        public ObjectProperty<Runnable> onPlayingProperty
        事件处理程序在状态更改为 PLAYING时调用。
        另请参见：
        getOnPlaying() ， setOnPlaying(Runnable)

      • onPaused

        public ObjectProperty<Runnable> onPausedProperty
        当状态更改为 PAUSED时调用事件处理程序。
        另请参见：
        getOnPaused() ， setOnPaused(Runnable)

      • onStopped

        public ObjectProperty<Runnable> onStoppedProperty
        当状态更改为 STOPPED时调用事件处理程序。
        另请参见：
        getOnStopped() ， setOnStopped(Runnable)

      • onHalted

        public ObjectProperty<Runnable> onHaltedProperty
        事件处理程序在状态更改为 HALTED时调用。
        另请参见：
        getOnHalted() ， setOnHalted(Runnable)

      • onRepeat

        public ObjectProperty<Runnable> onRepeatProperty
        当玩家的事件处理函数调用currentTime达到stopTime ， 将被重复。 此回调是在寻求回到startTime之前进行的。
        另请参见：
        getOnRepeat() ， setOnRepeat(Runnable)

      • onStalled

        public ObjectProperty<Runnable> onStalledProperty
        当状态更改为 STALLED时调用事件处理程序。
        另请参见：
        getOnStalled() ， setOnStalled(Runnable)

      • audioSpectrumNumBands

        public IntegerProperty audioSpectrumNumBandsProperty
        音频频谱中的频带数。 默认值为128; 最小值为2.音频信号的频率范围将分为指定数量的频率仓。 例如，典型的数字音乐信号的频率范围为[0.0, 22050] 。 如果在这种情况下光谱带的数量设置为10，则频谱中每个频率仓的宽度将为2205 ，最低频率仓的下限等于0.0 。
        另请参见：
        getAudioSpectrumNumBands() ， setAudioSpectrumNumBands(int)

      • audioSpectrumInterval

        public DoubleProperty audioSpectrumIntervalProperty
        频谱更新之间的间隔（秒）。 默认值为0.1秒。
        另请参见：
        getAudioSpectrumInterval() ， setAudioSpectrumInterval(double)

      • audioSpectrumThreshold

        public IntegerProperty audioSpectrumThresholdProperty
        灵敏度阈值以分贝为单位; 必须是非积极的。 相对于给定光谱带中的峰值频率低于此阈值的值将被设置为阈值的值。 默认值为-60 dB。
        另请参见：
        getAudioSpectrumThreshold() ， setAudioSpectrumThreshold(int)

      • audioSpectrumListener

        public ObjectProperty<AudioSpectrumListener> audioSpectrumListenerProperty
        用于音频频谱更新的监听器。 当听众注册时，音频频谱计算被启用; 删除侦听器后，计算被禁用。 只有一个监听器可能被注册，所以如果需要多个观察者，则必须转发事件。

        例如， AudioSpectrumListener可能有用于绘制正在播放的音频的频谱或生成音乐可视化器的波形。

        另请参见：
        getAudioSpectrumListener() ， setAudioSpectrumListener(AudioSpectrumListener)

    • 字段详细信息

      • INDEFINITE

        public static final int INDEFINITE
        表示有效无限数量的回放周期的值。 当cycleCount设置为此值时，播放器将重播Media直到停止或暂停。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • MediaPlayer

        public MediaPlayer​(Media media)
        为特定媒体创建播放器。 这是将Media对象与MediaPlayer关联的唯一方法：一旦播放器被创建，它就无法更改。 在构造函数中同步发生的错误将导致抛出异常。 异步发生的错误将导致error属性被设置，因此任何onError回调被调用。

        创建时，播放器的status将为MediaPlayer.Status.UNKNOWN 。 一旦status已经转换为MediaPlayer.Status.READY ，玩家将处于可用状态。 播放器创建与其进入READY状态之间的时间量可能会有所不同，具体取决于例如媒体是通过网络连接还是从本地文件系统读取。

        参数
        media - 媒体玩。
        异常
        NullPointerException - 如果媒体是 null 。
        MediaException - 如果在构造函数中发生任何同步错误。

    • 方法详细信息

      • getAudioEqualizer

        public final AudioEqualizer getAudioEqualizer​()
        检索与此播放器相关联的AudioEqualizer 。
        结果
        AudioEqualizer或 null如果玩家被处置。

      • getError

        public final MediaException getError​()
        检索 error属性的值或 null如果没有错误。
        结果
        一个 MediaException或 null 。

      • errorProperty

        public ReadOnlyObjectProperty<MediaException> errorProperty​()
        如果发生错误，Observable属性设置为 MediaException 。
        另请参见：
        getError()

      • setOnError

        public final void setOnError​(Runnable value)
        设置发生错误时调用的事件处理程序。
        参数
        value - 事件处理程序或 null 。

      • getOnError

        public final Runnable getOnError​()
        检索错误的事件处理程序。
        结果
        事件处理程序。

      • onErrorProperty

        public ObjectProperty<Runnable> onErrorProperty​()
        发生错误时调用事件处理程序。
        另请参见：
        getOnError() ， setOnError(Runnable)

      • getMedia

        public final Media getMedia​()
        检索正在播放的Media实例。
        结果
        Media对象。

      • setAutoPlay

        public final void setAutoPlay​(boolean value)
        设置 autoPlay属性值。
        参数
        value - 是否启用自动播放

      • isAutoPlay

        public final boolean isAutoPlay​()
        检索 autoPlay属性值。
        结果
        价值。

      • autoPlayProperty

        public BooleanProperty autoPlayProperty​()
        是否应尽快开始播放。 对于新的玩家来说，一旦玩家达到就绪状态，这个玩家就会发生这种情况。 默认值为false 。
        另请参见：
        isAutoPlay() ， setAutoPlay(boolean)

      • play

        public void play​()
        开始播放媒体。 如果先前已暂停，则播放将恢复暂停。 如果播放停止，播放从startTime开始。 当玩实际启动时， status将设置为MediaPlayer.Status.PLAYING 。

      • pause

        public void pause​()
        暂停播放器 一旦播放器实际上暂停， status将被设置为MediaPlayer.Status.PAUSED 。

      • stop

        public void stop​()
        停止播放媒体。 此操作将播放重置为startTime ，并将currentCount重置为零。 一旦玩家实际停牌 ， status将被设置为MediaPlayer.Status.STOPPED 。 唯一转换出STOPPED状态是MediaPlayer.Status.PAUSED和MediaPlayer.Status.PLAYING调用之后发生pause()或play()分别。 停止播放时，播放器不会响应seek(javafx.util.Duration)要求的播放位置更改。

      • setRate

        public final void setRate​(double value)
        将播放速度设置为提供的值。 其效果将被钳位在[0.0, 8.0]范围内。 如果媒体持续时间为Duration.INDEFINITE，则调用此方法将不起作用 。
        参数
        value - 播放速度

      • getRate

        public final double getRate​()
        检索播放速度。
        结果
        播放速度

      • rateProperty

        public DoubleProperty rateProperty​()
        要播放媒体的速度。 例如， 1.0的频率以其正常（编码）播放速率播放媒体， 2.0以正常速率的两倍播放，等等。目前支持的频率范围是[0.0, 8.0] 。 默认值为1.0 。
        另请参见：
        getRate() ， setRate(double)

      • getCurrentRate

        public final double getCurrentRate​()
        检索当前播放速率。
        结果
        目前的汇率

      • currentRateProperty

        public ReadOnlyDoubleProperty currentRateProperty​()
        当前的播放速度，无论设置如何。 例如，如果rate设置为1.0，播放器暂停或停止，则currentRate将为零。
        另请参见：
        getCurrentRate()

      • setVolume

        public final void setVolume​(double value)
        设置音频播放音量。 其效果将被夹紧到[0.0, 1.0]的范围内。
        参数
        value - 音量

      • getVolume

        public final double getVolume​()
        检索音频播放音量。 默认值为1.0 。
        结果
        音频音量

      • volumeProperty

        public DoubleProperty volumeProperty​()
        要播放媒体的音量。 有效值范围为[0.0 1.0] ，其中0.0为听不到， 1.0为全音量，为默认值。
        另请参见：
        getVolume() ， setVolume(double)

      • setBalance

        public final void setBalance​(double value)
        设置音频平衡。 其效果将被夹紧到[-1.0, 1.0]的范围内。
        参数
        value - 余额

      • getBalance

        public final double getBalance​()
        检索音频平衡。
        结果
        音频平衡

      • balanceProperty

        public DoubleProperty balanceProperty​()
        音频输出的平衡或左右设置。 有效的值的范围是[-1.0, 1.0]与-1.0充满左， 0.0中心，和1.0充分权利。 默认值为0.0 。
        另请参见：
        getBalance() ， setBalance(double)

      • setStartTime

        public final void setStartTime​(Duration value)
        设置开始时间。 其效果将被钳位在[Duration.ZERO, stopTime)范围内。 如果媒体持续时间为Duration.INDEFINITE，则调用此方法将不起作用 。
        参数
        value - 开始时间

      • getStartTime

        public final Duration getStartTime​()
        检索开始时间。 默认值为Duration.ZERO 。
        结果
        开始时间

      • startTimeProperty

        public ObjectProperty<Duration> startTimeProperty​()
        媒体应该开始播放的时间偏移，或重复播放时重新启动。 当播放停止时，当前时间被重置为该值。 如果该值为正，则播放前第一次播放媒体可能会有延迟，除非播放位置可以设置为媒体内的任意时间。 这可能例如对于不包含视频流中的帧内偏移的查找表的视频而言。 在这种情况下，视频帧将需要被跳过直到达到开始时间之前的第一帧内的位置。 默认值为Duration.ZERO 。

        约束： 0 ≤ startTime < stopTime

        另请参见：
        getStartTime() ， setStartTime(Duration)

      • setStopTime

        public final void setStopTime​(Duration value)
        设置停止时间。 其效果将被钳制到(startTime, Media.duration]范围内。 如果媒体持续时间为Duration.INDEFINITE，则调用此方法将不起作用 。
        参数
        value - 停车时间

      • getStopTime

        public final Duration getStopTime​()
        检索停止时间。 默认值为getMedia().getDuration() 。 请注意，如果媒体初始化未完成，则Media.duration可能具有值Duration.UNKNOWN 。
        结果
        停止时间

      • stopTimeProperty

        public ObjectProperty<Duration> stopTimeProperty​()
        重播时媒体应停止播放或重新启动的时间偏移。 默认值为getMedia().getDuration() 。

        约束： startTime < stopTime ≤ Media.duration

        另请参见：
        getStopTime() ， setStopTime(Duration)

      • getCycleDuration

        public final Duration getCycleDuration​()
        以秒为单位检索循环持续时间。
        结果
        循环持续时间

      • cycleDurationProperty

        public ReadOnlyObjectProperty<Duration> cycleDurationProperty​()
        该玩家的startTime和stopTime之间的时间量。 对于媒体的总持续时间使用Media.duration属性。
        另请参见：
        getCycleDuration()

      • getTotalDuration

        public final Duration getTotalDuration​()
        检索总播放持续时间，包括所有周期（重复）。
        结果
        总播放时间

      • totalDurationProperty

        public ReadOnlyObjectProperty<Duration> totalDurationProperty​()
        播放时间的总量，如果允许玩，直到完成。 如果cycleCount设置为INDEFINITE那么这也将是INDEFINITE。 如果Media持续时间为UNKNOWN，则同样为UNKNOWN。 否则，总持续时间将是cycleDuration和cycleCount的乘积。
        另请参见：
        getTotalDuration()

      • getCurrentTime

        public final Duration getCurrentTime​()
        检索当前媒体时间。
        结果
        当前媒体时间

      • currentTimeProperty

        public ReadOnlyObjectProperty<Duration> currentTimeProperty​()
        当前媒体播放时间。 此属性为只读：使用seek(javafx.util.Duration)将播放更改为不同的流位置。
        另请参见：
        getCurrentTime()

      • seek

        public void seek​(Duration seekTime)
        寻找播放器一个新的播放时间。 当播放器状态为MediaPlayer.Status.STOPPED或媒体持续时间为Duration.INDEFINITE时，调用此方法将不起作用 。

        seek()的行为约束如下，其中开始时间和停止时间分别表示媒体播放的有效下限和上限：

        MediaPlayer Seek Table seekTime seek position null no change Duration.UNKNOWN no change Duration.INDEFINITE stop time seekTime < start time start time seekTime > stop time stop time start time ≤ seekTime ≤ stop time seekTime
        参数
        seekTime - 请求的播放时间

      • getStatus

        public final MediaPlayer.Status getStatus​()
        检索当前播放器的状态。
        结果
        播放状态

      • statusProperty

        public ReadOnlyObjectProperty<MediaPlayer.Status> statusProperty​()
        MediaPlayer的当前状态。
        另请参见：
        getStatus()

      • getBufferProgressTime

        public final Duration getBufferProgressTime​()
        检索 bufferProgressTime的价值。
        结果
        缓冲进度时间

      • bufferProgressTimeProperty

        public ReadOnlyObjectProperty<Duration> bufferProgressTimeProperty​()
        当前的缓冲位置指示可以播放多少媒体，而不会停止MediaPlayer 。 这适用于缓冲流，例如从网络连接读取的流，而不是本地文件。

        寻求超出bufferProgressTime的位置可能会导致播放中轻微的暂停，直到足够数量的允许播放恢复的数据被缓存。

        另请参见：
        getBufferProgressTime()

      • setCycleCount

        public final void setCycleCount​(int value)
        设置周期数。 其影响将限制在[1,Integer.MAX_VALUE] 。 如果媒体持续时间为Duration.INDEFINITE，则调用此方法将不起作用 。
        参数
        value - 周期数

      • getCycleCount

        public final int getCycleCount​()
        检索周期数。
        结果
        周期数。

      • cycleCountProperty

        public IntegerProperty cycleCountProperty​()
        媒体播放的次数。 默认情况下， cycleCount设置为1这意味着媒体只能播放一次。 将cycleCount设置为大于1的值将导致介质播放给定次数或直到停止。 如果设置为INDEFINITE ，播放将重复，直到调用stop（）或pause（）为止。

        约束： cycleCount ≥ 1

        另请参见：
        getCycleCount() ， setCycleCount(int)

      • getCurrentCount

        public final int getCurrentCount​()
        检索当前周期的索引。
        结果
        当前周期指数

      • currentCountProperty

        public ReadOnlyIntegerProperty currentCountProperty​()
        完成播放周期的次数。 在第一次通过时，值应为0.在第二遍，值应为1，依此类推。 在追加到startTime之前 ，即在达到stopTime或媒体结束时， 它将在每个循环结束时递增 。
        另请参见：
        getCurrentCount()

      • setMute

        public final void setMute​(boolean value)
        设置值为 muteProperty() 。
        参数
        value - mute设置

      • isMute

        public final boolean isMute​()
        检索 muteProperty()值。
        结果
        静音设置

      • muteProperty

        public BooleanProperty muteProperty​()
        播放器音频是否静音 值true表示音频未生成。 该属性的值对volume没有影响，即如果音频静音，然后解除静音，音频播放将恢复到相同的声音级别，当然volume属性没有被修改。 默认值为false 。
        另请参见：
        isMute() ， setMute(boolean)

      • setOnMarker

        public final void setOnMarker​(EventHandler<MediaMarkerEvent> onMarker)
        设置标记事件处理程序。
        参数
        onMarker - 标记事件处理程序。

      • getOnMarker

        public final EventHandler<MediaMarkerEvent> getOnMarker​()
        检索标记事件处理程序。
        结果
        标记事件处理程序。

      • onMarkerProperty

        public ObjectProperty<EventHandler<MediaMarkerEvent>> onMarkerProperty​()
        当播放器 currentTime到达媒体标记时调用事件处理程序。
        另请参见：
        getOnMarker() ， setOnMarker(EventHandler)

      • setOnEndOfMedia

        public final void setOnEndOfMedia​(Runnable value)
        设置媒体事件处理程序的结束。
        参数
        value - 事件处理程序或 null 。

      • getOnEndOfMedia

        public final Runnable getOnEndOfMedia​()
        检索媒体事件处理程序的结束。
        结果
        事件处理程序或 null 。

      • onEndOfMediaProperty

        public ObjectProperty<Runnable> onEndOfMediaProperty​()
        当播放器 currentTime达到 stopTime时调用事件处理程序。
        另请参见：
        getOnEndOfMedia() ， setOnEndOfMedia(Runnable)

      • setOnReady

        public final void setOnReady​(Runnable value)
        设置 MediaPlayer.Status.READY事件处理程序。
        参数
        value - 事件处理程序或 null 。

      • getOnReady

        public final Runnable getOnReady​()
        检索 MediaPlayer.Status.READY事件处理程序。
        结果
        事件处理程序或 null 。

      • onReadyProperty

        public ObjectProperty<Runnable> onReadyProperty​()
        事件处理程序在状态更改为 READY时调用。
        另请参见：
        getOnReady() ， setOnReady(Runnable)

      • setOnPlaying

        public final void setOnPlaying​(Runnable value)
        设置 MediaPlayer.Status.PLAYING事件处理程序。
        参数
        value - 事件处理程序或 null 。

      • getOnPlaying

        public final Runnable getOnPlaying​()
        检索 MediaPlayer.Status.PLAYING事件处理程序。
        结果
        事件处理程序或 null 。

      • onPlayingProperty

        public ObjectProperty<Runnable> onPlayingProperty​()
        事件处理程序在状态更改为 PLAYING时调用。
        另请参见：
        getOnPlaying() ， setOnPlaying(Runnable)

      • setOnPaused

        public final void setOnPaused​(Runnable value)
        设置 MediaPlayer.Status.PAUSED事件处理程序。
        参数
        value - 事件处理程序或 null 。

      • getOnPaused

        public final Runnable getOnPaused​()
        检索 MediaPlayer.Status.PAUSED事件处理程序。
        结果
        事件处理程序或 null 。

      • onPausedProperty

        public ObjectProperty<Runnable> onPausedProperty​()
        事件处理程序在状态更改为 PAUSED时调用。
        另请参见：
        getOnPaused() ， setOnPaused(Runnable)

      • setOnStopped

        public final void setOnStopped​(Runnable value)
        设置 MediaPlayer.Status.STOPPED事件处理程序。
        参数
        value - 事件处理程序或 null 。

      • getOnStopped

        public final Runnable getOnStopped​()
        检索 MediaPlayer.Status.STOPPED事件处理程序。
        结果
        事件处理程序或 null 。

      • onStoppedProperty

        public ObjectProperty<Runnable> onStoppedProperty​()
        事件处理程序在状态更改为 STOPPED时调用。
        另请参见：
        getOnStopped() ， setOnStopped(Runnable)

      • setOnHalted

        public final void setOnHalted​(Runnable value)
        设置 MediaPlayer.Status.HALTED事件处理程序。
        参数
        value - 事件处理程序或 null 。

      • getOnHalted

        public final Runnable getOnHalted​()
        检索 MediaPlayer.Status.HALTED事件处理程序。
        结果
        事件处理程序或 null 。

      • onHaltedProperty

        public ObjectProperty<Runnable> onHaltedProperty​()
        当状态更改为 HALTED时调用事件处理程序。
        另请参见：
        getOnHalted() ， setOnHalted(Runnable)

      • setOnRepeat

        public final void setOnRepeat​(Runnable value)
        设置重复事件处理程序。
        参数
        value - 事件处理程序或 null 。

      • getOnRepeat

        public final Runnable getOnRepeat​()
        检索重复事件处理程序。
        结果
        事件处理程序或 null 。

      • onRepeatProperty

        public ObjectProperty<Runnable> onRepeatProperty​()
        当玩家的事件处理函数调用currentTime达到stopTime ， 将被重复。 此回调是在寻求回到startTime之前进行的。
        另请参见：
        getOnRepeat() ， setOnRepeat(Runnable)

      • setOnStalled

        public final void setOnStalled​(Runnable value)
        设置 MediaPlayer.Status.STALLED事件处理程序。
        参数
        value - 事件处理程序或 null 。

      • getOnStalled

        public final Runnable getOnStalled​()
        检索 MediaPlayer.Status.STALLED事件处理程序。
        结果
        事件处理程序或 null 。

      • onStalledProperty

        public ObjectProperty<Runnable> onStalledProperty​()
        当状态更改为 STALLED时调用事件处理程序。
        另请参见：
        getOnStalled() ， setOnStalled(Runnable)

      • setAudioSpectrumNumBands

        public final void setAudioSpectrumNumBands​(int value)
        设置音频频谱中的频带数。
        参数
        value - 光谱带数; value必须是¥2

      • getAudioSpectrumNumBands

        public final int getAudioSpectrumNumBands​()
        检索音频频谱中的频带数。
        结果
        光谱带的数量。

      • audioSpectrumNumBandsProperty

        public IntegerProperty audioSpectrumNumBandsProperty​()
        音频频谱中的频带数。 默认值为128; 最小值为2.音频信号的频率范围将分为指定数量的频率仓。 例如，典型的数字音乐信号的频率范围为[0.0, 22050] 。 如果在这种情况下光谱带的数量设置为10，则频谱中每个频率仓的宽度将为2205 ，最低频率仓的下限等于0.0 。
        另请参见：
        getAudioSpectrumNumBands() ， setAudioSpectrumNumBands(int)

      • setAudioSpectrumInterval

        public final void setAudioSpectrumInterval​(double value)
        设置音频频谱通知间隔的值，单位为秒。
        参数
        value - 指定频谱更新间隔的正值

      • getAudioSpectrumInterval

        public final double getAudioSpectrumInterval​()
        检索音频频谱通知间隔的值，单位为秒。
        结果
        光谱更新间隔

      • audioSpectrumIntervalProperty

        public DoubleProperty audioSpectrumIntervalProperty​()
        频谱更新之间的间隔（秒）。 默认值为0.1秒。
        另请参见：
        getAudioSpectrumInterval() ， setAudioSpectrumInterval(double)

      • setAudioSpectrumThreshold

        public final void setAudioSpectrumThreshold​(int value)
        以分贝设置音频频谱阈值。
        参数
        value - 以dB为单位的频谱阈值; 必须是0 。

      • getAudioSpectrumThreshold

        public final int getAudioSpectrumThreshold​()
        以分贝取回音频频谱阈值。
        结果
        光谱阈值以dB为单位

      • audioSpectrumThresholdProperty

        public IntegerProperty audioSpectrumThresholdProperty​()
        灵敏度阈值以分贝为单位; 必须是非积极的。 相对于给定光谱带中的峰值频率低于此阈值的值将被设置为阈值的值。 默认值为-60 dB。
        另请参见：
        getAudioSpectrumThreshold() ， setAudioSpectrumThreshold(int)

      • setAudioSpectrumListener

        public final void setAudioSpectrumListener​(AudioSpectrumListener listener)
        设置音频频谱的听众。
        参数
        listener - 频谱侦听器或 null 。

      • getAudioSpectrumListener

        public final AudioSpectrumListener getAudioSpectrumListener​()
        检索音频频谱的听众。
        结果
        光谱侦听器或 null

      • audioSpectrumListenerProperty

        public ObjectProperty<AudioSpectrumListener> audioSpectrumListenerProperty​()
        用于音频频谱更新的监听器。 当听众注册时，音频频谱计算被启用; 删除侦听器后，计算被禁用。 只有一个监听器可能被注册，所以如果需要多个观察者，则必须转发事件。

        例如， AudioSpectrumListener可能是有用的，例如绘制正在播放的音频的频谱或产生音乐可视化器的波形。

        另请参见：
        getAudioSpectrumListener() ， setAudioSpectrumListener(AudioSpectrumListener)

      • dispose

        public void dispose​()
        释放与播放器相关的所有资源。 调用此函数后不要使用播放器。 此方法完成后，播放器将转换为MediaPlayer.Status.DISPOSED 。 该方法可以随时调用和关于当前播放器的状态。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


MediaPlayer.Status (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Enum MediaPlayer.Status

  • java.lang.Object
    • java.lang.Enum<MediaPlayer.Status>
      • javafx.scene.media.MediaPlayer.Status
  • All Implemented Interfaces:
    Serializable ， Comparable<MediaPlayer.Status>
    Enclosing class:
    MediaPlayer

    public static enum MediaPlayer.Status
extends Enum<MediaPlayer.Status>
    描述MediaPlayer的不同状态值的枚举 。

    主席MediaPlayer状态转换如下表所示：

    MediaPlayer Status Transition Table Current \ Next READY PAUSED PLAYING STALLED STOPPED UNKNOWN pre-roll READY autoplay; play() PAUSED play() stop() PLAYING pause() buffering data stop() STALLED pause() data buffered stop() STOPPED pause() play()

    表格行表示播放器的当前状态，列表示播放器的下一个状态。 给定行和列的交点处的单元格列出了可能导致从行状态到列状态的转换的事件。 空单元代表不可能的过渡。 转换为UNKNOWN以及从HALTED状态转换为故意未列表。 UNKNOWN是播放器在媒体源预先滚动之前的初始状态，一旦退出就不能输入。 HALTED是发生错误时输入的终端状态，可能会从任何其他状态转换而不退出。

    主要的MediaPlayer状态值和转换如下图所示：

    MediaPlayer状态图

    到达媒体的最后（或stopTime如果这是定义），而播放不会导致状态从PLAYING更改。 因此，例如，如果媒体被播放到其结束，然后执行媒体内的较早时间的手动寻找，则播放将从新的媒体时间继续。

    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DISPOSED
      调用dispose（）方法后的播放器的状态。
      HALTED
      发生严重错误的玩家状态。
      PAUSED
      播放暂停时播放器的状态
      PLAYING
      播放器正在播放时的状态。
      READY
      玩家的状态一旦准备好玩。
      STALLED
      数据进入缓冲区的播放器的状态已经放慢或停止，并且播放缓冲区没有足够的数据来继续播放。
      STOPPED
      播放停止时播放器的状态。
      UNKNOWN
      播放器立即创建后的状态。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static MediaPlayer.Status valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MediaPlayer.Status[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNKNOWN

        public static final MediaPlayer.Status UNKNOWN
        播放器立即创建后的状态。 在这种状态下，财产价值不可靠，不应该考虑。 此外，在此状态下发送给播放器的命令将被缓冲，直到媒体完全加载并准备播放。

      • READY

        public static final MediaPlayer.Status READY
        玩家的状态一旦准备好玩。 当电影加载并预先滚动时，此状态仅输入一次。

      • PAUSED

        public static final MediaPlayer.Status PAUSED
        播放暂停时播放器的状态 要求播放器重新播放将导致播放器停止播放。

      • PLAYING

        public static final MediaPlayer.Status PLAYING
        播放器正在播放时的状态。

      • STOPPED

        public static final MediaPlayer.Status STOPPED
        播放停止时播放器的状态。 要求播放器重新播放将使其从头开始播放。

      • STALLED

        public static final MediaPlayer.Status STALLED
        数据进入缓冲区的播放器的状态已经放慢或停止，并且播放缓冲区没有足够的数据来继续播放。 当缓冲足够的数据以恢复播放时，播放将自动继续。 如果在此状态下暂停或停止，则缓冲将继续，但是当缓冲足够的数据时播放将不会自动恢复。

      • HALTED

        public static final MediaPlayer.Status HALTED
        发生严重错误的玩家状态。 此状态表示此播放器无法继续播放。 播放器不再运行，应该创建一个新的播放器。

      • DISPOSED

        public static final MediaPlayer.Status DISPOSED
        调用dispose（）方法后的播放器的状态。 这种状态表示玩家被处置，所有资源都是免费的，玩家不应该再次使用。 Media和MediaView可以重用与配置的玩家相关联的对象。
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • values

        public static MediaPlayer.Status[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (MediaPlayer.Status c : MediaPlayer.Status.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static MediaPlayer.Status valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


MediaView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class MediaView

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.media.MediaView
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class MediaView
extends Node
    甲Node提供的视图Media由正在播放MediaPlayer 。

    以下代码片段提供了一个显示视频的Application.start()方法的简单示例：

       public void start(Stage stage) { // Create and set the Scene. Scene scene = new Scene(new Group(), 540, 209); stage.setScene(scene); // Name and display the Stage. stage.setTitle("Hello Media"); stage.show(); // Create the media source. String source = getParameters().getRaw().get(0); Media media = new Media(source); // Create the player and set to play automatically. MediaPlayer mediaPlayer = new MediaPlayer(media); mediaPlayer.setAutoPlay(true); // Create the view and add it to the Scene. MediaView mediaView = new MediaView(mediaPlayer); ((Group) scene.getRoot()).getChildren().add(mediaView); }
    上述代码将显示为：

    你好媒体
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty fitHeight
      确定必要时调整大小的源介质的边界框的高度。
      DoubleProperty fitWidth
      确定根据需要调整大小的源介质的边界框的宽度。
      ObjectProperty<MediaPlayer> mediaPlayer
      mediaPlayer的输出将由此视图处理。
      ObjectProperty<EventHandler<MediaErrorEvent>> onError
      当这个 MediaView发生错误时调用事件处理程序。
      BooleanProperty preserveRatio
      是否在将其缩放以适应节点时保留介质的宽高比（宽/高）。
      BooleanProperty smooth
      如果设置为 true则在将此视频缩放以适应 fitWidth和 fitHeight提供的边界框内或当转换时，将使用更好的质量过滤算法。
      ObjectProperty<Rectangle2D> viewport
      指定一个矩形视口到媒体框架。
      DoubleProperty x
      定义 MediaView原点的当前x坐标。
      DoubleProperty y
      定义 MediaView起始点的当前y坐标。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      MediaView​()
      创建一个MediaView实例，没有关联的MediaPlayer 。
      MediaView​(MediaPlayer mediaPlayer)
      创建一个与指定的MediaPlayer相关联的MediaView实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty fitHeightProperty​()
      确定必要时调整大小的源介质的边界框的高度。
      DoubleProperty fitWidthProperty​()
      确定根据需要调整大小的源介质的边界框的宽度。
      double getFitHeight​()
      检索调整大小的媒体的边框的高度。
      double getFitWidth​()
      检索调整大小的媒体的边框的宽度。
      MediaPlayer getMediaPlayer​()
      检索 MediaPlayer其视图正在处理其输出。
      EventHandler<MediaErrorEvent> getOnError​()
      检索错误事件处理程序。
      Rectangle2D getViewport​()
      将矩形视口检索到媒体框架中。
      double getX​()
      检索 MediaView原点的x坐标。
      double getY​()
      检索 MediaView起源的y坐标。
      boolean isPreserveRatio​()
      返回在缩放时是否保留媒体宽高比。
      boolean isSmooth​()
      返回是否在缩放时平滑媒体。
      ObjectProperty<MediaPlayer> mediaPlayerProperty​()
      mediaPlayer的输出将由此视图处理。
      ObjectProperty<EventHandler<MediaErrorEvent>> onErrorProperty​()
      当这个 MediaView发生错误时调用事件处理程序。
      BooleanProperty preserveRatioProperty​()
      是否在将其缩放以适应节点时保留介质的宽高比（宽/高）。
      void setFitHeight​(double value)
      设置调整大小的介质的边界框的高度。
      void setFitWidth​(double value)
      设置调整大小的介质的边界框的宽度。
      void setMediaPlayer​(MediaPlayer value)
      设置 MediaPlayer的输出将由此视图处理。
      void setOnError​(EventHandler<MediaErrorEvent> value)
      设置错误事件处理程序。
      void setPreserveRatio​(boolean value)
      设置缩放时是否保留媒体宽高比。
      void setSmooth​(boolean value)
      设置缩放时是否平滑媒体。
      void setViewport​(Rectangle2D value)
      将矩形视口设置到媒体框架中。
      void setX​(double value)
      设置 MediaView原点的x坐标。
      void setY​(double value)
      设置 MediaView原点的y坐标。
      BooleanProperty smoothProperty​()
      如果设置为 true则在将此视频缩放到 fitWidth和 fitHeight提供的边界框内或当转换时，将使用更好的质量过滤算法。
      ObjectProperty<Rectangle2D> viewportProperty​()
      指定一个矩形视口到媒体框架。
      DoubleProperty xProperty​()
      定义 MediaView原点的当前x坐标。
      DoubleProperty yProperty​()
      定义 MediaView原点的当前y坐标。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • mediaPlayer

        public final ObjectProperty<MediaPlayer> mediaPlayerProperty
        mediaPlayer的输出将由此视图处理。 设置这个值不影响状态MediaPlayer ，例如，如果MediaPlayer被设置之前打mediaPlayer然后它会继续播放。
        另请参见：
        getMediaPlayer() ， setMediaPlayer(MediaPlayer)

      • onError

        public final ObjectProperty<EventHandler<MediaErrorEvent>> onErrorProperty
        当这个 MediaView发生错误时调用事件处理程序。
        另请参见：
        getOnError() ， setOnError(EventHandler)

      • preserveRatio

        public final BooleanProperty preserveRatioProperty
        是否在将其缩放以适应节点时保留介质的宽高比（宽/高）。 如果宽高比不被保留，则介质将在两个维度上被拉伸或剪切以适应节点的尺寸。 默认值为true 。
        另请参见：
        isPreserveRatio() ， setPreserveRatio(boolean)

      • smooth

        public final BooleanProperty smoothProperty
        如果设置为true将缩放此视频以适应fitWidth和fitHeight提供的边界框内或转换时使用更好的质量过滤算法。 如果设置为false将使用更快的质量过滤。 默认值取决于平台配置。
        另请参见：
        isSmooth() ， setSmooth(boolean)

      • x

        public final DoubleProperty xProperty
        定义 MediaView来源的当前x坐标。
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义 MediaView起始点的当前y坐标。
        另请参见：
        getY() ， setY(double)

      • fitWidth

        public final DoubleProperty fitWidthProperty
        确定根据需要调整大小的源介质的边界框的宽度。 如果是value ≤ 0 ，则边界框的宽度将被设置为媒体的自然宽度，但是fitWidth将被设置为提供的参数，即使非正。

        见preserveRatio对媒体的看法之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        另请参见：
        getFitWidth() ， setFitWidth(double)

      • fitHeight

        public final DoubleProperty fitHeightProperty
        确定必要时调整大小的源介质的边界框的高度。 如果是value ≤ 0 ，则边框的高度将被设置为介质的自然高度，但即使非正值，也会将fitHeight设置为提供的参数。

        见preserveRatio对媒体的看法之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        另请参见：
        getFitHeight() ， setFitHeight(double)

      • viewport

        public final ObjectProperty<Rectangle2D> viewportProperty
        指定一个矩形视口到媒体框架。 视口是在媒体框架的坐标中指定的矩形。 缩放之前的结果范围将是视口的大小。 显示的图像将包括框架和视口的交点。 视口可以超过帧的大小，但只显示交叉路口。 将viewport设置为null将清除视口。
        另请参见：
        getViewport() ， setViewport(Rectangle2D)

    • 构造方法详细信息

      • MediaView

        public MediaView​()
        创建一个MediaView实例，无关联MediaPlayer 。

      • MediaView

        public MediaView​(MediaPlayer mediaPlayer)
        创建一个与指定的MediaPlayer相关联的MediaView实例。 相当于
           MediaPlayer player; // initialization omitted MediaView view = new MediaView(); view.setMediaPlayer(player);
        参数
        mediaPlayer - MediaPlayer的播放是通过这个类观看的。

    • 方法详细信息

      • setMediaPlayer

        public final void setMediaPlayer​(MediaPlayer value)
        设置 MediaPlayer其输出将由此视图处理。
        参数
        value - 相关的 MediaPlayer 。

      • getMediaPlayer

        public final MediaPlayer getMediaPlayer​()
        检索该视图处理其输出的 MediaPlayer 。
        结果
        相关联的 MediaPlayer 。

      • mediaPlayerProperty

        public final ObjectProperty<MediaPlayer> mediaPlayerProperty​()
        mediaPlayer的输出将由此视图处理。 设置此值不影响MediaPlayer的状态，例如，如果MediaPlayer在设置mediaPlayer之前播放，则将继续播放。
        另请参见：
        getMediaPlayer() ， setMediaPlayer(MediaPlayer)

      • setOnError

        public final void setOnError​(EventHandler<MediaErrorEvent> value)
        设置错误事件处理程序。
        参数
        value - 错误事件处理程序。

      • getOnError

        public final EventHandler<MediaErrorEvent> getOnError​()
        检索错误事件处理程序。
        结果
        错误事件处理程序。

      • onErrorProperty

        public final ObjectProperty<EventHandler<MediaErrorEvent>> onErrorProperty​()
        当这个 MediaView发生错误时调用事件处理程序。
        另请参见：
        getOnError() ， setOnError(EventHandler)

      • setPreserveRatio

        public final void setPreserveRatio​(boolean value)
        设置缩放时是否保留媒体宽高比。
        参数
        value - 是否保留媒体宽高比。

      • isPreserveRatio

        public final boolean isPreserveRatio​()
        返回在缩放时是否保留媒体宽高比。
        结果
        是否保留媒体宽高比。

      • preserveRatioProperty

        public final BooleanProperty preserveRatioProperty​()
        是否在将其缩放以适应节点时保留介质的宽高比（宽/高）。 如果宽高比不被保留，则介质将在两个维度上被拉伸或剪切以适应节点的尺寸。 默认值为true 。
        另请参见：
        isPreserveRatio() ， setPreserveRatio(boolean)

      • setSmooth

        public final void setSmooth​(boolean value)
        设置缩放时是否平滑媒体。
        参数
        value - 是否平滑媒体。

      • isSmooth

        public final boolean isSmooth​()
        返回是否在缩放时平滑媒体。
        结果
        是否平滑媒体

      • smoothProperty

        public final BooleanProperty smoothProperty​()
        如果设置为true ，则缩放此视频以适应fitWidth和fitHeight提供的边界框中或当转换时将使用更好的质量过滤算法。 如果设置为false将使用更快，但质量较差的过滤。 默认值取决于平台配置。
        另请参见：
        isSmooth() ， setSmooth(boolean)

      • setX

        public final void setX​(double value)
        设置 MediaView原点的x坐标。
        参数
        value - 视图原点的x坐标。

      • getX

        public final double getX​()
        检索 MediaView原点的x坐标。
        结果
        视图原点的x坐标。

      • xProperty

        public final DoubleProperty xProperty​()
        定义 MediaView原点的当前x坐标。
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置 MediaView原点的y坐标。
        参数
        value - 视图原点的y坐标。

      • getY

        public final double getY​()
        检索 MediaView起源的y坐标。
        结果
        视图的原点的y坐标。

      • yProperty

        public final DoubleProperty yProperty​()
        定义 MediaView起始点的当前y坐标。
        另请参见：
        getY() ， setY(double)

      • setFitWidth

        public final void setFitWidth​(double value)
        设置调整大小的介质的边界框的宽度。
        参数
        value - 调整大小的介质的宽度。

      • getFitWidth

        public final double getFitWidth​()
        检索调整大小的媒体的边框的宽度。
        结果
        调整大小的媒体的高度。

      • fitWidthProperty

        public final DoubleProperty fitWidthProperty​()
        确定根据需要调整大小的源介质的边界框的宽度。 如果是value ≤ 0 ，则边界框的宽度将被设置为介质的自然宽度，但是即使非正值，也会将fitWidth设置为提供的参数。

        见preserveRatio对媒体的看法之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        另请参见：
        getFitWidth() ， setFitWidth(double)

      • setFitHeight

        public final void setFitHeight​(double value)
        设置调整大小的介质的边界框的高度。
        参数
        value - 调整大小的媒体的高度。

      • getFitHeight

        public final double getFitHeight​()
        检索调整大小的媒体的边框的高度。
        结果
        调整大小的媒体的高度。

      • fitHeightProperty

        public final DoubleProperty fitHeightProperty​()
        确定必要时调整大小的源介质的边界框的高度。 如果是value ≤ 0 ，则边界框的高度将被设置为介质的自然高度，但是即使非正值，也会将fitHeight设置为提供的参数。

        见preserveRatio对媒体的看法之间的互动信息fitWidth ， fitHeight和preserveRatio属性。

        另请参见：
        getFitHeight() ， setFitHeight(double)

      • setViewport

        public final void setViewport​(Rectangle2D value)
        将矩形视口设置到媒体框架中。
        参数
        value - 矩形视口。

      • getViewport

        public final Rectangle2D getViewport​()
        将矩形视口检索到媒体框架中。
        结果
        矩形视口。

      • viewportProperty

        public final ObjectProperty<Rectangle2D> viewportProperty​()
        指定一个矩形视口到媒体框架。 视口是在媒体框架的坐标中指定的矩形。 缩放之前的结果范围将是视口的大小。 显示的图像将包括框架和视口的交点。 视口可以超过帧的大小，但只显示交叉路口。 将viewport设置为null可以清除视口。
        另请参见：
        getViewport() ， setViewport(Rectangle2D)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SubtitleTrack (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class SubtitleTrack

  • java.lang.Object
    • javafx.scene.media.Track
      • javafx.scene.media.SubtitleTrack

  • public class SubtitleTrack
extends Track
    A Track ，其包含要覆盖视频轨道的副标题或字幕数据。
    从以下版本开始：
    JavaFX 8.0

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.media.Track

        getLocale, getMetadata, getName, getTrackID, toString
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Track (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class Track

  • java.lang.Object
    • javafx.scene.media.Track
  • 已知直接子类：
    AudioTrack ， SubtitleTrack ， VideoTrack

    public abstract class Track
extends Object
    表示媒体资源中包含的曲目的类。 媒体资源可以具有多个平行的轨道，例如具有不同语言的多个音轨的视频轨道。 可以从该类的现有子类推断系统支持的轨道类型。 并非所有媒体资源都将包含每种支持类型的轨道，而给定轨道的时间间隔不一定与包含媒体的时间间隔相当。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Locale getLocale​()
      Locale指定Track内容格式化的语言以及可能的国家/地区。
      Map<String,Object> getMetadata​()
      String getName​()
      检索轨道的名称。
      long getTrackID​()
      获取由媒体容器格式定义的曲目ID。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getName

        public final String getName​()
        检索轨道的名称。
        结果
        曲目名称或 null 。

      • getLocale

        public final Locale getLocale​()
        Locale指定Track内容被格式化的语言以及可能的国家。 对于AudioTrack s这将是所使用的语言，对于SubtitleTrack这将是字幕中提供的语言。 不是所有的Track都将有一个关联的语言，在这种情况下，这个方法将返回null。
        结果
        Track的语言信息或null
        从以下版本开始：
        JavaFX 8.0

      • getTrackID

        public final long getTrackID​()
        获取由媒体容器格式定义的曲目ID。 每个Track的ID必须是唯一的源Media 。
        结果
        Track的独特ID
        从以下版本开始：
        JavaFX 8.0

      • getMetadata

        public final Map<String,Object> getMetadata​()
        结果
        一个包含此 Track所有已知元数据的地图
        从以下版本开始：
        JavaFX 8.0

      • toString

        public final String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.media (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.media

  • Packages that use javafx.scene.media
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
  • Classes in javafx.scene.media used by javafx.scene.media
    Class 描述
    AudioEqualizer
    AudioEqualizer类为媒体播放器提供音频均衡控制。
    AudioSpectrumListener
    音频频谱回调接口。
    EqualizerBand
    所述EqualizerBand类提供了在每个频带控制AudioEqualizer 。
    Media
    Media类代表媒体资源。
    MediaErrorEvent
    一个Event表示处理媒体时发生错误。
    MediaException
    甲MediaException描述了在运行时错误条件Media ， MediaPlayer或MediaView 。
    MediaException.Type
    描述错误类别的枚举。
    MediaMarkerEvent
    一个ActionEvent代表媒体标记。
    MediaPlayer
    MediaPlayer课程提供播放媒体的控件。
    MediaPlayer.Status
    描述MediaPlayer的不同状态值的枚举 。
    Track
    表示媒体资源中包含的曲目的类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


VideoTrack (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.media
软件包 javafx.scene.media

Class VideoTrack

  • java.lang.Object
    • javafx.scene.media.Track
      • javafx.scene.media.VideoTrack

  • public final class VideoTrack
extends Track
    描述视频轨道的Track 。 这通常是视听媒体资源中独特的视觉轨迹。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getHeight​()
      检索轨道的高度。
      int getWidth​()
      检索轨道的宽度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.media.Track

        getLocale, getMetadata, getName, getTrackID, toString

    • 方法详细信息

      • getWidth

        public final int getWidth​()
        检索轨道的宽度。
        结果
        轨道宽度。

      • getHeight

        public final int getHeight​()
        检索轨道的高度。
        结果
        轨道高度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.scene.media.AudioClip (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.AudioClip

No usage of javafx.scene.media.AudioClip
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.AudioEqualizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.AudioEqualizer

  • Packages that use AudioEqualizer
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of AudioEqualizer in javafx.scene.media

      Methods in javafx.scene.media that return AudioEqualizer
      Modifier and Type 方法 描述
      AudioEqualizer MediaPlayer.getAudioEqualizer​()
      检索与此播放器相关联的AudioEqualizer 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.AudioTrack (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.AudioTrack

No usage of javafx.scene.media.AudioTrack
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.EqualizerBand (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.EqualizerBand

  • Packages that use EqualizerBand
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of EqualizerBand in javafx.scene.media

      Methods in javafx.scene.media that return types with arguments of type EqualizerBand
      Modifier and Type 方法 描述
      ObservableList<EqualizerBand> AudioEqualizer.getBands​()
      ObservableList包含EqualizerBand元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.Media (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.Media

  • Packages that use Media
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of Media in javafx.scene.media

      Methods in javafx.scene.media that return Media
      Modifier and Type 方法 描述
      Media MediaPlayer.getMedia​()
      检索正在播放的Media实例。
      Constructors in javafx.scene.media with parameters of type Media
      Constructor 描述
      MediaPlayer​(Media media)
      为特定媒体创建播放器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.MediaErrorEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.MediaErrorEvent

  • Packages that use MediaErrorEvent
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of MediaErrorEvent in javafx.scene.media

      Fields in javafx.scene.media with type parameters of type MediaErrorEvent
      Modifier and Type Field 描述
      static EventType<MediaErrorEvent> MediaErrorEvent.MEDIA_ERROR
      唯一有效的事件类型为 MediaErrorEvent 。
      Methods in javafx.scene.media that return MediaErrorEvent
      Modifier and Type | 方法 | 描述
      MediaErrorEvent | MediaErrorEvent.copyFor​(Object newSource, EventTarget newTarget)
      Methods in javafx.scene.media that return types with arguments of type MediaErrorEvent
      Modifier and Type | 方法 | 描述
      EventType<MediaErrorEvent> | MediaErrorEvent.getEventType​()
      EventHandler<MediaErrorEvent> MediaView.getOnError​()
      检索错误事件处理程序。
      ObjectProperty<EventHandler<MediaErrorEvent>> MediaView.onErrorProperty​()
      当这个 MediaView发生错误时调用事件处理程序。
      Method parameters in javafx.scene.media with type arguments of type MediaErrorEvent
      Modifier and Type 方法 描述
      void MediaView.setOnError​(EventHandler<MediaErrorEvent> value)
      设置错误事件处理程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.MediaException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.MediaException

  • Packages that use MediaException
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of MediaException in javafx.scene.media

      Methods in javafx.scene.media that return MediaException
      Modifier and Type 方法 描述
      MediaException Media.getError​()
      返回媒体中遇到的任何错误。
      MediaException MediaPlayer.getError​()
      检索 error属性的值或 null如果没有错误。
      MediaException MediaErrorEvent.getMediaError​()
      检索与此事件相关联的错误。
      Methods in javafx.scene.media that return types with arguments of type MediaException
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<MediaException> Media.errorProperty​()
      发生错误时将属性设置为MediaException值。
      ReadOnlyObjectProperty<MediaException> MediaPlayer.errorProperty​()
      如果发生错误，Observable属性设置为 MediaException 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.MediaException.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.MediaException.Type

  • Packages that use MediaException.Type
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of MediaException.Type in javafx.scene.media

      Methods in javafx.scene.media that return MediaException.Type
      Modifier and Type 方法 描述
      MediaException.Type MediaException.getType​()
      检索此错误所在的类别。
      static MediaException.Type MediaException.Type.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MediaException.Type[] MediaException.Type.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.MediaMarkerEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.MediaMarkerEvent

  • Packages that use MediaMarkerEvent
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of MediaMarkerEvent in javafx.scene.media

      Methods in javafx.scene.media that return types with arguments of type MediaMarkerEvent
      Modifier and Type 方法 描述
      EventHandler<MediaMarkerEvent> MediaPlayer.getOnMarker​()
      检索标记事件处理程序。
      ObjectProperty<EventHandler<MediaMarkerEvent>> MediaPlayer.onMarkerProperty​()
      当播放器 currentTime到达媒体标记时调用事件处理程序。
      Method parameters in javafx.scene.media with type arguments of type MediaMarkerEvent
      Modifier and Type 方法 描述
      void MediaPlayer.setOnMarker​(EventHandler<MediaMarkerEvent> onMarker)
      设置标记事件处理程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.MediaPlayer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.MediaPlayer

  • Packages that use MediaPlayer
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of MediaPlayer in javafx.scene.media

      Methods in javafx.scene.media that return MediaPlayer
      Modifier and Type 方法 描述
      MediaPlayer MediaView.getMediaPlayer​()
      检索 MediaPlayer其视图正在处理其输出。
      Methods in javafx.scene.media that return types with arguments of type MediaPlayer
      Modifier and Type 方法 描述
      ObjectProperty<MediaPlayer> MediaView.mediaPlayerProperty​()
      mediaPlayer的输出将由此视图处理。
      Methods in javafx.scene.media with parameters of type MediaPlayer
      Modifier and Type 方法 描述
      void MediaView.setMediaPlayer​(MediaPlayer value)
      设置 MediaPlayer其输出将由此视图处理。
      Constructors in javafx.scene.media with parameters of type MediaPlayer
      Constructor 描述
      MediaView​(MediaPlayer mediaPlayer)
      创建与指定的MediaPlayer相关联的MediaView实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.MediaPlayer.Status (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.MediaPlayer.Status

  • Packages that use MediaPlayer.Status
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of MediaPlayer.Status in javafx.scene.media

      Methods in javafx.scene.media that return MediaPlayer.Status
      Modifier and Type 方法 描述
      MediaPlayer.Status MediaPlayer.getStatus​()
      检索当前播放器的状态。
      static MediaPlayer.Status MediaPlayer.Status.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MediaPlayer.Status[] MediaPlayer.Status.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.media that return types with arguments of type MediaPlayer.Status
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<MediaPlayer.Status> MediaPlayer.statusProperty​()
      MediaPlayer的当前状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.MediaView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.MediaView

No usage of javafx.scene.media.MediaView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.SubtitleTrack (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.SubtitleTrack

No usage of javafx.scene.media.SubtitleTrack
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.Track (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.Track

  • Packages that use Track
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of Track in javafx.scene.media

      Subclasses of Track in javafx.scene.media
      Modifier and Type Class 描述
      class  AudioTrack
      描述音轨的A Track 。
      class  SubtitleTrack
      A Track ，其包含要覆盖视频轨道的副标题或字幕数据。
      class  VideoTrack
      描述视频轨道的Track 。
      Methods in javafx.scene.media that return types with arguments of type Track
      Modifier and Type 方法 描述
      ObservableList<Track> Media.getTracks​()
      检索此媒体源中包含的曲目。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.media.VideoTrack (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.media.VideoTrack

No usage of javafx.scene.media.VideoTrack
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.scene.media.AudioSpectrumListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.scene.media.AudioSpectrumListener

  • Packages that use AudioSpectrumListener
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of AudioSpectrumListener in javafx.scene.media

      Methods in javafx.scene.media that return AudioSpectrumListener
      Modifier and Type 方法 描述
      AudioSpectrumListener MediaPlayer.getAudioSpectrumListener​()
      检索音频频谱的听众。
      Methods in javafx.scene.media that return types with arguments of type AudioSpectrumListener
      Modifier and Type 方法 描述
      ObjectProperty<AudioSpectrumListener> MediaPlayer.audioSpectrumListenerProperty​()
      用于音频频谱更新的监听器。
      Methods in javafx.scene.media with parameters of type AudioSpectrumListener
      Modifier and Type 方法 描述
      void MediaPlayer.setAudioSpectrumListener​(AudioSpectrumListener listener)
      设置音频频谱的听众。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Color (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.paint

Class Color

  • java.lang.Object
    • javafx.scene.paint.Paint
      • javafx.scene.paint.Color
  • All Implemented Interfaces:
    Interpolatable<Color>

    public final class Color
extends Paint
implements Interpolatable<Color>
    Color类用于将颜色封装在默认的sRGB颜色空间中。 每个颜色的隐含alpha值为1.0或构造函数中提供的一个显式的Alpha值。 alpha值定义了颜色的透明度，可以用0.0-1.0或0-255范围内的双重值表示。 alpha值为1.0或255表示颜色完全不透明，alpha值为0或0.0表示颜色完全透明。 当使用显式alpha构造Color或获取Color的颜色/ alpha分量时，颜色分量决不会被alpha分量预乘。

    Color可以使用构造函数或几个实用方法之一创建。 以下代码行都创建相同的蓝色：

       Color c = Color.BLUE; //use the blue constant Color c = new Color(0,0,1,1.0); // standard constructor, use 0->1.0 values, explicit alpha of 1.0 Color c = Color.color(0,0,1.0); //use 0->1.0 values. implicit alpha of 1.0 Color c = Color.color(0,0,1.0,1.0); //use 0->1.0 values, explicit alpha of 1.0 Color c = Color.rgb(0,0,255); //use 0->255 integers, implicit alpha of 1.0 Color c = Color.rgb(0,0,255,1.0); //use 0->255 integers, explicit alpha of 1.0 Color c = Color.hsb(270,1.0,1.0); //hue = 270, saturation & value = 1.0. inplicit alpha of 1.0 Color c = Color.hsb(270,1.0,1.0,1.0); //hue = 270, saturation & value = 1.0, explicit alpha of 1.0 Color c = Color.web("0x0000FF",1.0);// blue as a hex web value, explicit alpha Color c = Color.web("0x0000FF");// blue as a hex web value, implicit alpha Color c = Color.web("0x00F");// blue as a short hex web value, implicit alpha Color c = Color.web("#0000FF",1.0);// blue as a hex web value, explicit alpha Color c = Color.web("#0000FF");// blue as a hex web value, implicit alpha Color c = Color.web("#00F");// blue as a short hex web value, implicit alpha Color c = Color.web("0000FF",1.0);// blue as a hex web value, explicit alpha Color c = Color.web("0000FF");// blue as a hex web value, implicit alpha Color c = Color.web("00F");// blue as a short hex web value, implicit alpha Color c = Color.web("rgba(0,0,255,1.0)");// blue as an rgb web value, explicit alpha Color c = Color.web("rgb(0,0,255)");// blue as an rgb web value, implicit alpha Color c = Color.web("rgba(0,0,100%,1.0)");// blue as an rgb percent web value, explicit alpha Color c = Color.web("rgb(0,0,100%)");// blue as an rgb percent web value, implicit alpha Color c = Color.web("hsla(270,100%,100%,1.0)");// blue as an hsl web value, explicit alpha Color c = Color.web("hsl(270,100%,100%)");// blue as an hsl web value, implicit alpha

    如果任何值超出范围，创建Color将抛出IllegalArgumentException 。

    例如：

       Rectangle rec1 = new Rectangle(5, 5, 50, 40); rec1.setFill(Color.RED); rec1.setStroke(Color.GREEN); rec1.setStrokeWidth(3); Rectangle rec2 = new Rectangle(65, 5, 50, 40); rec2.setFill(Color.rgb(91, 127, 255)); rec2.setStroke(Color.hsb(40, 0.7, 0.8)); rec2.setStrokeWidth(3);
    从以下版本开始：
    JavaFX 2.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Color ALICEBLUE
      颜色为蓝绿色，RGB值为＃F0F8FF
      static Color ANTIQUEWHITE
      颜色古色古香的白色，RGB值为＃FAEBD7
      static Color AQUA
      颜色水彩，RGB值为＃00FFFF
      static Color AQUAMARINE
      RGB值为＃7FFFD4的彩色海蓝宝石
      static Color AZURE
      RGB值为＃F0FFFF的颜色天蓝色
      static Color BEIGE
      颜色米色，RGB值为＃F5F5DC
      static Color BISQUE
      RGB值为＃FFE4C4的彩色色差
      static Color BLACK
      颜色为黑色，RGB值为＃000000
      static Color BLANCHEDALMOND
      颜色变白的杏仁，RGB值为#FFEBCD
      static Color BLUE
      颜色蓝色，RGB值为＃0000FF
      static Color BLUEVIOLET
      RGB值为＃8A2BE2的蓝色紫色
      static Color BROWN
      颜色棕色，RGB值为＃A52A2A
      static Color BURLYWOOD
      颜色粗糙的木材，RGB值为＃DEB887
      static Color CADETBLUE
      颜色学员蓝色，RGB值为＃5F9EA0
      static Color CHARTREUSE
      RGB值为＃7FFF00的颜色表格
      static Color CHOCOLATE
      颜色巧克力，RGB值为＃D2691E
      static Color CORAL
      颜色珊瑚，RGB值为＃FF7F50
      static Color CORNFLOWERBLUE
      颜色矢车菊蓝色，RGB值为＃6495ED
      static Color CORNSILK
      具有RGB值为＃FFF8DC的颜色cornsilk
      static Color CRIMSON
      颜色深红色，RGB值为＃DC143C
      static Color CYAN
      颜色青色，RGB值为＃00FFFF
      static Color DARKBLUE
      颜色深蓝色，RGB值为＃00008B
      static Color DARKCYAN
      颜色深蓝色，RGB值为＃008B8B
      static Color DARKGOLDENROD
      颜色深黄色，RGB值为＃B8860B
      static Color DARKGRAY
      颜色深灰色，RGB值为＃A9A9A9
      static Color DARKGREEN
      颜色深绿色，RGB值为＃006400
      static Color DARKGREY
      颜色深灰色，RGB值为＃A9A9A9
      static Color DARKKHAKI
      颜色深色卡其色，RGB值为＃BDB76B
      static Color DARKMAGENTA
      RGB值为＃8B008B的深色洋红色
      static Color DARKOLIVEGREEN
      颜色深绿橄榄绿，RGB值为＃556B2F
      static Color DARKORANGE
      颜色深橙色，RGB值为＃FF8C00
      static Color DARKORCHID
      颜色深蓝色，RGB值为＃9932CC
      static Color DARKRED
      颜色深红色，RGB值为＃8B0000
      static Color DARKSALMON
      颜色深色鲑鱼，RGB值为＃E9967A
      static Color DARKSEAGREEN
      颜色深绿色，RGB值为＃8FBC8F
      static Color DARKSLATEBLUE
      颜色深蓝色，RGB值为＃483D8B
      static Color DARKSLATEGRAY
      颜色深灰色，RGB值为＃2F4F4F
      static Color DARKSLATEGREY
      颜色深灰色，RGB值为＃2F4F4F
      static Color DARKTURQUOISE
      颜色深蓝绿色，RGB值为＃00CED1
      static Color DARKVIOLET
      颜色深紫色，RGB值为＃9400D3
      static Color DEEPPINK
      颜色深粉红色，RGB值为＃FF1493
      static Color DEEPSKYBLUE
      颜色深蓝色，RGB值为＃00BFFF
      static Color DIMGRAY
      颜色变暗，RGB值为＃696969
      static Color DIMGREY
      颜色变暗，RGB值为＃696969
      static Color DODGERBLUE
      颜色闪烁蓝色，RGB值为＃1E90FF
      static Color FIREBRICK
      颜色耐火砖，RGB值为＃B22222
      static Color FLORALWHITE
      颜色花白色，RGB值为＃FFFAF0
      static Color FORESTGREEN
      颜色森林绿色，RGB值为＃228B22
      static Color FUCHSIA
      颜色紫红色，RGB值为＃FF00FF
      static Color GAINSBORO
      RGB值为#DCDCDC的彩色增益
      static Color GHOSTWHITE
      颜色为Ghost的白色，RGB值为＃F8F8FF
      static Color GOLD
      彩色金色，RGB值为＃FFD700
      static Color GOLDENROD
      颜色金色，RGB值为＃DAA520
      static Color GRAY
      颜色为灰色，RGB值为＃808080
      static Color GREEN
      颜色绿色，RGB值为＃008000
      static Color GREENYELLOW
      颜色为绿色黄色，RGB值为＃ADFF2F
      static Color GREY
      颜色为灰色，RGB值为＃808080
      static Color HONEYDEW
      彩色蜜汁，RGB值为＃F0FFF0
      static Color HOTPINK
      颜色热粉红色，RGB值为＃FF69B4
      static Color INDIANRED
      彩色印度红色，RGB值为＃CD5C5C
      static Color INDIGO
      RGB值为＃4B0082的彩色靛蓝
      static Color IVORY
      颜色象牙，RGB值为＃FFFFF0
      static Color KHAKI
      颜色卡其色，RGB值为＃F0E68C
      static Color LAVENDER
      彩色薰衣草，RGB值为＃E6E6FA
      static Color LAVENDERBLUSH
      颜色薰衣草腮红，RGB值为＃FFF0F5
      static Color LAWNGREEN
      颜色草坪绿色，RGB值为＃7CFC00
      static Color LEMONCHIFFON
      颜色柠檬雪纺，RGB值为#FFFACD
      static Color LIGHTBLUE
      颜色浅蓝色，RGB值为＃ADD8E6
      static Color LIGHTCORAL
      彩色珊瑚，RGB值为＃F08080
      static Color LIGHTCYAN
      颜色浅蓝色，RGB值为＃E0FFFF
      static Color LIGHTGOLDENRODYELLOW
      颜色浅黄色，RGB值为#FAFAD2
      static Color LIGHTGRAY
      颜色浅灰色，RGB值为＃D3D3D3
      static Color LIGHTGREEN
      颜色浅绿色，RGB值为＃90EE90
      static Color LIGHTGREY
      颜色浅灰色，RGB值为＃D3D3D3
      static Color LIGHTPINK
      颜色浅粉红色，RGB值为＃FFB6C1
      static Color LIGHTSALMON
      RGB值为＃FFA07A的彩色三文鱼
      static Color LIGHTSEAGREEN
      颜色浅绿色，RGB值为＃20B2AA
      static Color LIGHTSKYBLUE
      彩色天空蓝色，RGB值为＃87CEFA
      static Color LIGHTSLATEGRAY
      颜色浅灰色，RGB值为＃778899
      static Color LIGHTSLATEGREY
      颜色浅灰色，RGB值为＃778899
      static Color LIGHTSTEELBLUE
      颜色浅蓝色，RGB值为＃B0C4DE
      static Color LIGHTYELLOW
      颜色浅黄色，RGB值为＃FFFFE0
      static Color LIME
      RGB灰度值为＃00FF00
      static Color LIMEGREEN
      灰绿色，RGB值为＃32CD32
      static Color LINEN
      颜色亚麻布，RGB值为#FAF0E6
      static Color MAGENTA
      颜色洋红色，RGB值为＃FF00FF
      static Color MAROON
      颜色栗色，RGB值为＃800000
      static Color MEDIUMAQUAMARINE
      彩色介质海蓝宝石，RGB值为＃66CDAA
      static Color MEDIUMBLUE
      颜色中等蓝色，RGB值为＃0000CD
      static Color MEDIUMORCHID
      颜色中等兰花，RGB值为＃BA55D3
      static Color MEDIUMPURPLE
      颜色中等紫色，RGB值为＃9370DB
      static Color MEDIUMSEAGREEN
      彩色中型海绿，RGB值为＃3CB371
      static Color MEDIUMSLATEBLUE
      彩色介质为蓝色，RGB值为＃7B68EE
      static Color MEDIUMSPRINGGREEN
      彩色介质弹簧绿色，RGB值为＃00FA9A
      static Color MEDIUMTURQUOISE
      颜色介质绿松石，RGB值为＃48D1CC
      static Color MEDIUMVIOLETRED
      颜色中等紫色，RGB值为＃C71585
      static Color MIDNIGHTBLUE
      颜色为午夜蓝色，RGB值为＃191970
      static Color MINTCREAM
      颜色薄荷奶油，RGB值为＃F5FFFA
      static Color MISTYROSE
      颜色朦胧，RGB值为＃FFE4E1
      static Color MOCCASIN
      颜色莫卡辛，RGB值为＃FFE4B5
      static Color NAVAJOWHITE
      颜色navajo白色，RGB值为#FFDEAD
      static Color NAVY
      RGB值为＃000080的彩色海军
      static Color OLDLACE
      颜色旧花边，RGB值为＃FDF5E6
      static Color OLIVE
      颜色橄榄，RGB值为＃808000
      static Color OLIVEDRAB
      彩色橄榄色，RGB值为＃6B8E23
      static Color ORANGE
      颜色为橙色，RGB值为＃FFA500
      static Color ORANGERED
      颜色橙红色，RGB值为＃FF4500
      static Color ORCHID
      颜色兰花，RGB值为＃DA70D6
      static Color PALEGOLDENROD
      颜色淡黄色，RGB值为＃EEE8AA
      static Color PALEGREEN
      颜色淡绿色，RGB值为＃98FB98
      static Color PALETURQUOISE
      颜色淡绿色，RGB值为#AFEEEE
      static Color PALEVIOLETRED
      颜色为淡紫色，RGB值为＃DB7093
      static Color PAPAYAWHIP
      颜色番木瓜鞭，RGB值为＃FFEFD5
      static Color PEACHPUFF
      彩色桃红色，其值为＃FFDAB9
      static Color PERU
      颜色为紫色，RGB值为＃CD853F
      static Color PINK
      颜色粉红色，RGB值为＃FFC0CB
      static Color PLUM
      颜色李子，RGB值为＃DDA0DD
      static Color POWDERBLUE
      彩色蓝色，RGB值为＃B0E0E6
      static Color PURPLE
      颜色为紫色，RGB值为＃800080
      static Color RED
      颜色红色，RGB值为＃FF0000
      static Color ROSYBROWN
      颜色玫瑰色棕色，RGB值为＃BC8F8F
      static Color ROYALBLUE
      颜色为皇家蓝色，RGB值为＃4169E1
      static Color SADDLEBROWN
      颜色马鞍棕色，RGB值为＃8B4513
      static Color SALMON
      颜色三文鱼的RGB值为＃FA8072
      static Color SANDYBROWN
      颜色沙棕色，RGB值为＃F4A460
      static Color SEAGREEN
      颜色海绿色，RGB值为＃2E8B57
      static Color SEASHELL
      颜色海壳，RGB值为＃FFF5EE
      static Color SIENNA
      颜色赭色，RGB值为＃A0522D
      static Color SILVER
      颜色银，RGB值为＃C0C0C0
      static Color SKYBLUE
      颜色天蓝色，RGB值为＃87CEEB
      static Color SLATEBLUE
      颜色为蓝色，RGB值为＃6A5ACD
      static Color SLATEGRAY
      颜色为灰色，RGB值为＃708090
      static Color SLATEGREY
      颜色为灰色，RGB值为＃708090
      static Color SNOW
      RGB值为#FFFAFA的彩色雪
      static Color SPRINGGREEN
      颜色为绿色，RGB值为＃00FF7F
      static Color STEELBLUE
      颜色钢蓝色，RGB值为＃4682B4
      static Color TAN
      颜色为棕褐色，RGB值为＃D2B48C
      static Color TEAL
      颜色深蓝色，RGB值为＃008080
      static Color THISTLE
      颜色蓟，RGB值为＃D8BFD8
      static Color TOMATO
      颜色番茄，RGB值为＃FF6347
      static Color TRANSPARENT
      ARGB值为＃00000000的完全透明的颜色。
      static Color TURQUOISE
      颜色绿松石，RGB值为＃40E0D0
      static Color VIOLET
      颜色紫色，RGB值为＃EE82EE
      static Color WHEAT
      RGB值为＃F5DEB3的彩色小麦
      static Color WHITE
      颜色为白色，RGB值为#FFFFFF
      static Color WHITESMOKE
      彩色白色烟雾，RGB值为＃F5F5F5
      static Color YELLOW
      颜色为黄色，RGB值为＃FFFF00
      static Color YELLOWGREEN
      颜色黄绿色，RGB值为＃9ACD32

    • 构造方法摘要

      构造方法
      Constructor 描述
      Color​(double red, double green, double blue, double opacity)
      创建一个新的颜色实例

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Color brighter​()
      创建一个这种颜色更亮的新颜色。
      static Color color​(double red, double green, double blue)
      使用指定的红色，绿色和蓝色值创建不透明的sRGB颜色，范围为 0.0-1.0 。
      static Color color​(double red, double green, double blue, double opacity)
      使用指定的红色，绿色和蓝色值创建sRGB颜色，范围为 0.0-1.0和给定的不透明度。
      Color darker​()
      创建一个这种颜色较暗版本的新颜色。
      Color deriveColor​(double hueShift, double saturationFactor, double brightnessFactor, double opacityFactor)
      基于这个 Color创建一个新的 Color ， Color了色调，饱和度，亮度和不透明度值。
      Color desaturate​()
      创建一个不太饱和的Color颜色的新颜色。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      double getBlue​()
      Color的蓝色成分，范围 0.0-1.0 。
      double getBrightness​()
      获取此 Color的亮度分量。
      double getGreen​()
      Color的绿色成分，范围 0.0-1.0 。
      double getHue​()
      获取此 Color的色调分量。
      double getOpacity​()
      对的不透明度 Color ，范围为 0.0-1.0 。
      double getRed​()
      所述的红色分量 Color ，在范围 0.0-1.0 。
      double getSaturation​()
      获取此 Color的饱和分量。
      static Color gray​(double gray)
      创建不透明的灰色。
      static Color gray​(double gray, double opacity)
      创建灰色。
      static Color grayRgb​(int gray)
      这是 rgb(gray, gray, gray)的快捷方式。
      static Color grayRgb​(int gray, double opacity)
      这是 rgb(gray, gray, gray, opacity)的快捷方式。
      Color grayscale​()
      创建一个与此颜色相当的灰度等级的新颜色。
      int hashCode​()
      返回此 Color对象的哈希码。
      static Color hsb​(double hue, double saturation, double brightness)
      根据HSB颜色模型中的指定值创建不透明的 Color 。
      static Color hsb​(double hue, double saturation, double brightness, double opacity)
      根据HSB颜色模型中的指定值和给定的不透明度创建 Color 。
      Color interpolate​(Color endValue, double t)
      该函数计算 0.0和 1.0之间的分数 t的内插值。
      Color invert​()
      创建一个反映此颜色的新颜色。
      boolean isOpaque​()
      获取此Paint是否完全不透明。
      static Color rgb​(int red, int green, int blue)
      使用指定的RGB值创建不透明的sRGB颜色，范围为 0-255 。
      static Color rgb​(int red, int green, int blue, double opacity)
      使用指定的RGB值创建sRGB颜色，范围为 0-255 ，以及给定的不透明度。
      Color saturate​()
      创建一个这个颜色的更饱和版本的新颜色。
      String toString​()
      返回此 Color的字符串表示 Color 。
      static Color valueOf​(String value)
      从字符串表示形式创建颜色值。
      static Color web​(String colorString)
      创建使用HTML或CSS属性字符串指定的RGB颜色。
      static Color web​(String colorString, double opacity)
      创建使用HTML或CSS属性字符串指定的RGB颜色。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TRANSPARENT

        public static final Color TRANSPARENT
        ARGB值为＃00000000的完全透明的颜色。

      • ALICEBLUE

        public static final Color ALICEBLUE
        颜色为蓝绿色，RGB值为＃F0F8FF

      • ANTIQUEWHITE

        public static final Color ANTIQUEWHITE
        颜色古色古香的白色，RGB值为＃FAEBD7

      • AQUA

        public static final Color AQUA
        颜色水彩，RGB值为＃00FFFF

      • AQUAMARINE

        public static final Color AQUAMARINE
        RGB值为＃7FFFD4的彩色海蓝宝石

      • AZURE

        public static final Color AZURE
        RGB值为＃F0FFFF的颜色天蓝色

      • BEIGE

        public static final Color BEIGE
        颜色米色，RGB值为＃F5F5DC

      • BISQUE

        public static final Color BISQUE
        RGB值为＃FFE4C4的彩色色差

      • BLACK

        public static final Color BLACK
        颜色为黑色，RGB值为＃000000

      • BLANCHEDALMOND

        public static final Color BLANCHEDALMOND
        颜色变白的杏仁，RGB值为#FFEBCD

      • BLUE

        public static final Color BLUE
        颜色蓝色，RGB值为＃0000FF

      • BLUEVIOLET

        public static final Color BLUEVIOLET
        RGB值为＃8A2BE2的蓝色紫色

      • BROWN

        public static final Color BROWN
        颜色棕色，RGB值为＃A52A2A

      • BURLYWOOD

        public static final Color BURLYWOOD
        颜色粗糙的木材，RGB值为＃DEB887

      • CADETBLUE

        public static final Color CADETBLUE
        颜色学员蓝色，RGB值为＃5F9EA0

      • CHARTREUSE

        public static final Color CHARTREUSE
        RGB值为＃7FFF00的颜色表格

      • CHOCOLATE

        public static final Color CHOCOLATE
        颜色巧克力，RGB值为＃D2691E

      • CORAL

        public static final Color CORAL
        颜色珊瑚，RGB值为＃FF7F50

      • CORNFLOWERBLUE

        public static final Color CORNFLOWERBLUE
        颜色矢车菊蓝色，RGB值为＃6495ED

      • CORNSILK

        public static final Color CORNSILK
        具有RGB值为＃FFF8DC的颜色cornsilk

      • CRIMSON

        public static final Color CRIMSON
        颜色深红色，RGB值为＃DC143C

      • CYAN

        public static final Color CYAN
        颜色青色，RGB值为＃00FFFF

      • DARKBLUE

        public static final Color DARKBLUE
        颜色深蓝色，RGB值为＃00008B

      • DARKCYAN

        public static final Color DARKCYAN
        颜色深蓝色，RGB值为＃008B8B

      • DARKGOLDENROD

        public static final Color DARKGOLDENROD
        颜色深黄色，RGB值为＃B8860B

      • DARKGRAY

        public static final Color DARKGRAY
        颜色深灰色，RGB值为＃A9A9A9

      • DARKGREEN

        public static final Color DARKGREEN
        颜色深绿色，RGB值为＃006400

      • DARKGREY

        public static final Color DARKGREY
        颜色深灰色，RGB值为＃A9A9A9

      • DARKKHAKI

        public static final Color DARKKHAKI
        颜色深色卡其色，RGB值为＃BDB76B

      • DARKMAGENTA

        public static final Color DARKMAGENTA
        RGB值为＃8B008B的深色洋红色

      • DARKOLIVEGREEN

        public static final Color DARKOLIVEGREEN
        颜色深绿橄榄绿，RGB值为＃556B2F

      • DARKORANGE

        public static final Color DARKORANGE
        颜色深橙色，RGB值为＃FF8C00

      • DARKORCHID

        public static final Color DARKORCHID
        颜色深蓝色，RGB值为＃9932CC

      • DARKRED

        public static final Color DARKRED
        颜色深红色，RGB值为＃8B0000

      • DARKSALMON

        public static final Color DARKSALMON
        颜色深色鲑鱼，RGB值为＃E9967A

      • DARKSEAGREEN

        public static final Color DARKSEAGREEN
        颜色深绿色，RGB值为＃8FBC8F

      • DARKSLATEBLUE

        public static final Color DARKSLATEBLUE
        颜色深蓝色，RGB值为＃483D8B

      • DARKSLATEGRAY

        public static final Color DARKSLATEGRAY
        颜色深灰色，RGB值为＃2F4F4F

      • DARKSLATEGREY

        public static final Color DARKSLATEGREY
        颜色深灰色，RGB值为＃2F4F4F

      • DARKTURQUOISE

        public static final Color DARKTURQUOISE
        颜色深蓝绿色，RGB值为＃00CED1

      • DARKVIOLET

        public static final Color DARKVIOLET
        颜色深紫色，RGB值为＃9400D3

      • DEEPPINK

        public static final Color DEEPPINK
        颜色深粉红色，RGB值为＃FF1493

      • DEEPSKYBLUE

        public static final Color DEEPSKYBLUE
        颜色深蓝色，RGB值为＃00BFFF

      • DIMGRAY

        public static final Color DIMGRAY
        颜色变暗，RGB值为＃696969

      • DIMGREY

        public static final Color DIMGREY
        颜色变暗，RGB值为＃696969

      • DODGERBLUE

        public static final Color DODGERBLUE
        颜色闪烁蓝色，RGB值为＃1E90FF

      • FIREBRICK

        public static final Color FIREBRICK
        颜色耐火砖，RGB值为＃B22222

      • FLORALWHITE

        public static final Color FLORALWHITE
        颜色花白色，RGB值为＃FFFAF0

      • FORESTGREEN

        public static final Color FORESTGREEN
        颜色森林绿色，RGB值为＃228B22

      • FUCHSIA

        public static final Color FUCHSIA
        颜色紫红色，RGB值为＃FF00FF

      • GAINSBORO

        public static final Color GAINSBORO
        RGB值为#DCDCDC的彩色增益

      • GHOSTWHITE

        public static final Color GHOSTWHITE
        颜色为Ghost的白色，RGB值为＃F8F8FF

      • GOLD

        public static final Color GOLD
        彩色金色，RGB值为＃FFD700

      • GOLDENROD

        public static final Color GOLDENROD
        颜色金色，RGB值为＃DAA520

      • GRAY

        public static final Color GRAY
        颜色为灰色，RGB值为＃808080

      • GREEN

        public static final Color GREEN
        颜色绿色，RGB值为＃008000

      • GREENYELLOW

        public static final Color GREENYELLOW
        颜色为绿色黄色，RGB值为＃ADFF2F

      • GREY

        public static final Color GREY
        颜色为灰色，RGB值为＃808080

      • HONEYDEW

        public static final Color HONEYDEW
        彩色蜜汁，RGB值为＃F0FFF0

      • HOTPINK

        public static final Color HOTPINK
        颜色热粉红色，RGB值为＃FF69B4

      • INDIANRED

        public static final Color INDIANRED
        彩色印度红色，RGB值为＃CD5C5C

      • INDIGO

        public static final Color INDIGO
        RGB值为＃4B0082的彩色靛蓝

      • IVORY

        public static final Color IVORY
        颜色象牙，RGB值为＃FFFFF0

      • KHAKI

        public static final Color KHAKI
        颜色卡其色，RGB值为＃F0E68C

      • LAVENDER

        public static final Color LAVENDER
        彩色薰衣草，RGB值为＃E6E6FA

      • LAVENDERBLUSH

        public static final Color LAVENDERBLUSH
        颜色薰衣草腮红，RGB值为＃FFF0F5

      • LAWNGREEN

        public static final Color LAWNGREEN
        颜色草坪绿色，RGB值为＃7CFC00

      • LEMONCHIFFON

        public static final Color LEMONCHIFFON
        颜色柠檬雪纺，RGB值为#FFFACD

      • LIGHTBLUE

        public static final Color LIGHTBLUE
        颜色浅蓝色，RGB值为＃ADD8E6

      • LIGHTCORAL

        public static final Color LIGHTCORAL
        彩色珊瑚，RGB值为＃F08080

      • LIGHTCYAN

        public static final Color LIGHTCYAN
        颜色浅蓝色，RGB值为＃E0FFFF

      • LIGHTGOLDENRODYELLOW

        public static final Color LIGHTGOLDENRODYELLOW
        颜色浅黄色，RGB值为#FAFAD2

      • LIGHTGRAY

        public static final Color LIGHTGRAY
        颜色浅灰色，RGB值为＃D3D3D3

      • LIGHTGREEN

        public static final Color LIGHTGREEN
        颜色浅绿色，RGB值为＃90EE90

      • LIGHTGREY

        public static final Color LIGHTGREY
        颜色浅灰色，RGB值为＃D3D3D3

      • LIGHTPINK

        public static final Color LIGHTPINK
        颜色浅粉红色，RGB值为＃FFB6C1

      • LIGHTSALMON

        public static final Color LIGHTSALMON
        RGB值为＃FFA07A的彩色三文鱼

      • LIGHTSEAGREEN

        public static final Color LIGHTSEAGREEN
        颜色浅绿色，RGB值为＃20B2AA

      • LIGHTSKYBLUE

        public static final Color LIGHTSKYBLUE
        彩色天空蓝色，RGB值为＃87CEFA

      • LIGHTSLATEGRAY

        public static final Color LIGHTSLATEGRAY
        颜色浅灰色，RGB值为＃778899

      • LIGHTSLATEGREY

        public static final Color LIGHTSLATEGREY
        颜色浅灰色，RGB值为＃778899

      • LIGHTSTEELBLUE

        public static final Color LIGHTSTEELBLUE
        颜色浅蓝色，RGB值为＃B0C4DE

      • LIGHTYELLOW

        public static final Color LIGHTYELLOW
        颜色浅黄色，RGB值为＃FFFFE0

      • LIME

        public static final Color LIME
        RGB灰度值为＃00FF00

      • LIMEGREEN

        public static final Color LIMEGREEN
        灰绿色，RGB值为＃32CD32

      • LINEN

        public static final Color LINEN
        颜色亚麻布，RGB值为#FAF0E6

      • MAGENTA

        public static final Color MAGENTA
        颜色洋红色，RGB值为＃FF00FF

      • MAROON

        public static final Color MAROON
        颜色栗色，RGB值为＃800000

      • MEDIUMAQUAMARINE

        public static final Color MEDIUMAQUAMARINE
        彩色介质海蓝宝石，RGB值为＃66CDAA

      • MEDIUMBLUE

        public static final Color MEDIUMBLUE
        颜色中等蓝色，RGB值为＃0000CD

      • MEDIUMORCHID

        public static final Color MEDIUMORCHID
        颜色中等兰花，RGB值为＃BA55D3

      • MEDIUMPURPLE

        public static final Color MEDIUMPURPLE
        颜色中等紫色，RGB值为＃9370DB

      • MEDIUMSEAGREEN

        public static final Color MEDIUMSEAGREEN
        彩色中型海绿，RGB值为＃3CB371

      • MEDIUMSLATEBLUE

        public static final Color MEDIUMSLATEBLUE
        彩色介质为蓝色，RGB值为＃7B68EE

      • MEDIUMSPRINGGREEN

        public static final Color MEDIUMSPRINGGREEN
        彩色介质弹簧绿色，RGB值为＃00FA9A

      • MEDIUMTURQUOISE

        public static final Color MEDIUMTURQUOISE
        颜色介质绿松石，RGB值为＃48D1CC

      • MEDIUMVIOLETRED

        public static final Color MEDIUMVIOLETRED
        颜色中等紫色，RGB值为＃C71585

      • MIDNIGHTBLUE

        public static final Color MIDNIGHTBLUE
        颜色为午夜蓝色，RGB值为＃191970

      • MINTCREAM

        public static final Color MINTCREAM
        颜色薄荷奶油，RGB值为＃F5FFFA

      • MISTYROSE

        public static final Color MISTYROSE
        颜色朦胧，RGB值为＃FFE4E1

      • MOCCASIN

        public static final Color MOCCASIN
        颜色莫卡辛，RGB值为＃FFE4B5

      • NAVAJOWHITE

        public static final Color NAVAJOWHITE
        颜色navajo白色，RGB值为#FFDEAD

      • NAVY

        public static final Color NAVY
        RGB值为＃000080的彩色海军

      • OLDLACE

        public static final Color OLDLACE
        颜色旧花边，RGB值为＃FDF5E6

      • OLIVE

        public static final Color OLIVE
        颜色橄榄，RGB值为＃808000

      • OLIVEDRAB

        public static final Color OLIVEDRAB
        彩色橄榄色，RGB值为＃6B8E23

      • ORANGE

        public static final Color ORANGE
        颜色为橙色，RGB值为＃FFA500

      • ORANGERED

        public static final Color ORANGERED
        颜色橙红色，RGB值为＃FF4500

      • ORCHID

        public static final Color ORCHID
        颜色兰花，RGB值为＃DA70D6

      • PALEGOLDENROD

        public static final Color PALEGOLDENROD
        颜色淡黄色，RGB值为＃EEE8AA

      • PALEGREEN

        public static final Color PALEGREEN
        颜色淡绿色，RGB值为＃98FB98

      • PALETURQUOISE

        public static final Color PALETURQUOISE
        颜色淡绿色，RGB值为#AFEEEE

      • PALEVIOLETRED

        public static final Color PALEVIOLETRED
        颜色为淡紫色，RGB值为＃DB7093

      • PAPAYAWHIP

        public static final Color PAPAYAWHIP
        颜色番木瓜鞭，RGB值为＃FFEFD5

      • PEACHPUFF

        public static final Color PEACHPUFF
        彩色桃红色，其值为＃FFDAB9

      • PERU

        public static final Color PERU
        颜色为紫色，RGB值为＃CD853F

      • PINK

        public static final Color PINK
        颜色粉红色，RGB值为＃FFC0CB

      • PLUM

        public static final Color PLUM
        颜色李子，RGB值为＃DDA0DD

      • POWDERBLUE

        public static final Color POWDERBLUE
        彩色蓝色，RGB值为＃B0E0E6

      • PURPLE

        public static final Color PURPLE
        颜色为紫色，RGB值为＃800080

      • RED

        public static final Color RED
        颜色红色，RGB值为＃FF0000

      • ROSYBROWN

        public static final Color ROSYBROWN
        颜色玫瑰色棕色，RGB值为＃BC8F8F

      • ROYALBLUE

        public static final Color ROYALBLUE
        颜色为皇家蓝色，RGB值为＃4169E1

      • SADDLEBROWN

        public static final Color SADDLEBROWN
        颜色马鞍棕色，RGB值为＃8B4513

      • SALMON

        public static final Color SALMON
        颜色三文鱼的RGB值为＃FA8072

      • SANDYBROWN

        public static final Color SANDYBROWN
        颜色沙棕色，RGB值为＃F4A460

      • SEAGREEN

        public static final Color SEAGREEN
        颜色海绿色，RGB值为＃2E8B57

      • SEASHELL

        public static final Color SEASHELL
        颜色海壳，RGB值为＃FFF5EE

      • SIENNA

        public static final Color SIENNA
        颜色赭色，RGB值为＃A0522D

      • SILVER

        public static final Color SILVER
        颜色银，RGB值为＃C0C0C0

      • SKYBLUE

        public static final Color SKYBLUE
        颜色天蓝色，RGB值为＃87CEEB

      • SLATEBLUE

        public static final Color SLATEBLUE
        颜色为蓝色，RGB值为＃6A5ACD

      • SLATEGRAY

        public static final Color SLATEGRAY
        颜色为灰色，RGB值为＃708090

      • SLATEGREY

        public static final Color SLATEGREY
        颜色为灰色，RGB值为＃708090

      • SNOW

        public static final Color SNOW
        RGB值为#FFFAFA的彩色雪

      • SPRINGGREEN

        public static final Color SPRINGGREEN
        颜色为绿色，RGB值为＃00FF7F

      • STEELBLUE

        public static final Color STEELBLUE
        颜色钢蓝色，RGB值为＃4682B4

      • TAN

        public static final Color TAN
        颜色为棕褐色，RGB值为＃D2B48C

      • TEAL

        public static final Color TEAL
        颜色深蓝色，RGB值为＃008080

      • THISTLE

        public static final Color THISTLE
        颜色蓟，RGB值为＃D8BFD8

      • TOMATO

        public static final Color TOMATO
        颜色番茄，RGB值为＃FF6347

      • TURQUOISE

        public static final Color TURQUOISE
        颜色绿松石，RGB值为＃40E0D0

      • VIOLET

        public static final Color VIOLET
        颜色紫色，RGB值为＃EE82EE

      • WHEAT

        public static final Color WHEAT
        RGB值为＃F5DEB3的彩色小麦

      • WHITE

        public static final Color WHITE
        颜色为白色，RGB值为#FFFFFF

      • WHITESMOKE

        public static final Color WHITESMOKE
        彩色白色烟雾，RGB值为＃F5F5F5

      • YELLOW

        public static final Color YELLOW
        颜色为黄色，RGB值为＃FFFF00

      • YELLOWGREEN

        public static final Color YELLOWGREEN
        颜色黄绿色，RGB值为＃9ACD32

    • 构造方法详细信息

      • Color

        public Color​(double red,
             double green,
             double blue,
             double opacity)
        创建一个新的颜色实例
        参数
        red - 红色成分从 0到 1
        green - 绿色成分从 0到 1
        blue - 蓝色成分从 0到 1
        opacity - 不透明度范围从 0到 1

    • 方法详细信息

      • color

        public static Color color​(double red,
                          double green,
                          double blue,
                          double opacity)
        使用指定的红色，绿色和蓝色值创建sRGB颜色，范围为 0.0-1.0 ，以及给定的不透明度。
        参数
        red - 红色组件，范围 0.0-1.0
        green - 绿色组件，范围 0.0-1.0
        blue - 蓝色分量，范围 0.0-1.0
        opacity - 不透明度组件，范围 0.0-1.0
        结果
        Color
        异常
        IllegalArgumentException - 如果任何值超出范围

      • color

        public static Color color​(double red,
                          double green,
                          double blue)
        使用指定的红色，绿色和蓝色值创建不透明的sRGB颜色，范围为 0.0-1.0 。
        参数
        red - 红色分量，范围 0.0-1.0
        green - 绿色组件，范围 0.0-1.0
        blue - 蓝色组件，范围 0.0-1.0
        结果
        Color
        异常
        IllegalArgumentException - 如果任何值超出范围

      • rgb

        public static Color rgb​(int red,
                        int green,
                        int blue,
                        double opacity)
        使用指定的RGB值创建一个sRGB颜色，范围为 0-255 ，以及给定的不透明度。
        参数
        red - 红色分量，范围 0-255
        green - 绿色组件，范围 0-255
        blue - 蓝色组件，范围 0-255
        opacity - 不透明度组件，范围 0.0-1.0
        结果
        Color
        异常
        IllegalArgumentException - 如果任何值超出范围

      • rgb

        public static Color rgb​(int red,
                        int green,
                        int blue)
        使用指定的RGB值创建不透明的sRGB颜色，范围为 0-255 。
        参数
        red - 红色组件，范围 0-255
        green - 绿色组件，范围 0-255
        blue - 蓝色组件，范围 0-255
        结果
        Color
        异常
        IllegalArgumentException - 如果任何值超出范围

      • grayRgb

        public static Color grayRgb​(int gray)
        这是 rgb(gray, gray, gray)的快捷方式。
        参数
        gray - 灰色组件，范围 0-255
        结果
        Color

      • grayRgb

        public static Color grayRgb​(int gray,
                            double opacity)
        这是 rgb(gray, gray, gray, opacity)的快捷方式。
        参数
        gray - 灰色组件，范围 0-255
        opacity - 不透明度组件，范围 0.0-1.0
        结果
        Color

      • gray

        public static Color gray​(double gray,
                         double opacity)
        创建灰色。
        参数
        gray - 颜色在灰度范围 0.0 （黑色） - 1.0 （白色）。
        opacity - 不透明度组件，范围 0.0-1.0
        结果
        Color
        异常
        IllegalArgumentException - 如果任何值超出范围

      • gray

        public static Color gray​(double gray)
        创建不透明的灰色。
        参数
        gray - 颜色在灰度范围 0.0 （黑色） - 1.0 （白色）。
        结果
        Color
        异常
        IllegalArgumentException - 如果任何值超出范围

      • hsb

        public static Color hsb​(double hue,
                        double saturation,
                        double brightness,
                        double opacity)
        根据HSB颜色模型中的指定值和给定的不透明度创建 Color 。
        参数
        hue - 色调，以度为单位
        saturation - 饱和度， 0.0 to 1.0
        brightness - 亮度， 0.0 to 1.0
        opacity - 不透明度， 0.0 to 1.0
        结果
        Color
        异常
        IllegalArgumentException -如果 saturation ， brightness或 opacity超出范围

      • hsb

        public static Color hsb​(double hue,
                        double saturation,
                        double brightness)
        根据HSB颜色模型中的指定值创建不透明的 Color 。
        参数
        hue - 色调，以度为单位
        saturation - 饱和度， 0.0 to 1.0
        brightness - 亮度， 0.0 to 1.0
        结果
        Color
        异常
        IllegalArgumentException - 如果 saturation或 brightness超出范围

      • web

        public static Color web​(String colorString,
                        double opacity)
        创建使用HTML或CSS属性字符串指定的RGB颜色。

        此方法支持以下格式：

        • 任何标准的HTML颜色名称
        • HTML长或短格式的十六进制字符串，带有可选的十六进制alpha通道。 十六进制值可以由前面"0x"或"#"和可以是2位的范围00到0xFF或范围内的单个数字0到F 。
        • 一个rgb(r,g,b)或rgba(r,g,b,a)格式字符串。 每个的r ， g ，或b值可以从0到255的整数或浮点百分比值从0.0到100.0接着百分比（ % ）字符。 alpha分量（如果存在）是0.0到1.0的浮点值。 数字之前或之后以及百分比数和百分号之间允许使用空格（ % ）。
        • 一个hsl(h,s,l)或hsla(h,s,l,a)格式字符串。 h值是从0.0到360.0的浮点数，表示色轮上的色调角度，以0.0或360.0表示红色， 120.0表示绿色， 240.0表示蓝色。 所述s值表示为从灰色（浮点百分比所需的颜色的饱和度0.0 ）的完全饱和的颜色（ 100.0 ）和l值表示为从一个浮点百分比所需要的颜色的所希望的亮度或亮度黑色（ 0.0 ）到全亮度的颜色（ 100.0 ）。 alpha分量（如果存在）是0.0到1.0的浮点值。 在数字之前或之后以及百分比数和百分号之间允许使用空格（ % ）。

        对于没有alpha组件和命名颜色的格式，根据opacity参数设置不透明度。 对于使用alpha组件指定的颜色，生成的不透明度是解析的alpha组件和opacity参数的组合，因此通过指定透明度，透明颜色变得更加透明。

        例子：

        Web Color Format Table Web Format String Equivalent constructor or factory call Color.web("orange", 0.5); new Color(1.0, 0xA5/255.0, 0.0, 0.5) Color.web("0xff66cc33", 0.5); new Color(1.0, 0.4, 0.8, 0.1) Color.web("0xff66cc", 0.5); new Color(1.0, 0.4, 0.8, 0.5) Color.web("#ff66cc", 0.5); new Color(1.0, 0.4, 0.8, 0.5) Color.web("#f68", 0.5); new Color(1.0, 0.4, 0.8, 0.5) Color.web("rgb(255,102,204)", 0.5); new Color(1.0, 0.4, 0.8, 0.5) Color.web("rgb(100%,50%,50%)", 0.5); new Color(1.0, 0.5, 0.5, 0.5) Color.web("rgb(255,50%,50%,0.25)", 0.5); new Color(1.0, 0.5, 0.5, 0.125) Color.web("hsl(240,100%,100%)", 0.5); Color.hsb(240.0, 1.0, 1.0, 0.5) Color.web("hsla(120,0%,0%,0.25)", 0.5); Color.hsb(120.0, 0.0, 0.0, 0.125)
        参数
        colorString - 以支持的格式之一的颜色的名称或数字表示
        opacity - 不透明度组件的范围从0.0（透明）到1.0（不透明）
        结果
        用colorString指定的RGB颜色
        异常
        NullPointerException - 如果 colorString是 null
        IllegalArgumentException - 如果 colorString指定不支持的颜色名称或包含非法数值

      • web

        public static Color web​(String colorString)
        创建使用HTML或CSS属性字符串指定的RGB颜色。

        此方法支持以下格式：

        • 任何标准的HTML颜色名称
        • HTML长或短格式的十六进制字符串，带有可选的十六进制alpha通道。 十六进制值可以由前面"0x"或"#"和可以是2位的范围00到0xFF或范围内的单个数字0到F 。
        • 一个rgb(r,g,b)或rgba(r,g,b,a)格式字符串。 每个的r ， g ，或b值可以从0到255的整数或浮点百分比值从0.0到100.0接着百分比（ % ）字符。 alpha分量（如果存在）是0.0到1.0的浮点值。 数字之前或之后以及百分比数与百分号之间允许使用空格（ % ）。
        • 一个hsl(h,s,l)或hsla(h,s,l,a)格式字符串。 所述h值是从0.0到360.0浮点数表示以度为单位上的色轮的色相角与0.0或360.0表示红色， 120.0代表绿色和240.0代表蓝色。 所述s值表示为从灰色（浮点百分比所需的颜色的饱和度0.0 ）的完全饱和的颜色（ 100.0 ）和l值表示为从一个浮点百分比所需要的颜色的所希望的亮度或亮度黑色（ 0.0 ）到全亮度的颜色（ 100.0 ）。 alpha分量（如果存在）是0.0到1.0的浮点值。 在数字之前或之后以及百分比数和百分号之间允许使用空格（ % ）。

        例子：

        Web Color Format Table Web Format String Equivalent constant or factory call Color.web("orange"); Color.ORANGE Color.web("0xff668840"); Color.rgb(255, 102, 136, 0.25) Color.web("0xff6688"); Color.rgb(255, 102, 136, 1.0) Color.web("#ff6688"); Color.rgb(255, 102, 136, 1.0) Color.web("#f68"); Color.rgb(255, 102, 136, 1.0) Color.web("rgb(255,102,136)"); Color.rgb(255, 102, 136, 1.0) Color.web("rgb(100%,50%,50%)"); Color.rgb(255, 128, 128, 1.0) Color.web("rgb(255,50%,50%,0.25)"); Color.rgb(255, 128, 128, 0.25) Color.web("hsl(240,100%,100%)"); Color.hsb(240.0, 1.0, 1.0, 1.0) Color.web("hsla(120,0%,0%,0.25)"); Color.hsb(120.0, 0.0, 0.0, 0.25)
        参数
        colorString - 以支持的格式之一的颜色的名称或数字表示
        结果
        一种RGB颜色
        异常
        NullPointerException - 如果 colorString是 null
        IllegalArgumentException - 如果 colorString指定不支持的颜色名称或包含非法数值

      • valueOf

        public static Color valueOf​(String value)
        从字符串表示形式创建颜色值。 字符串表示形式与web(String)中的格式相同。
        参数
        value - 要转换的字符串
        结果
        一个 Color对象，保存由字符串参数表示的值
        异常
        NullPointerException - 如果 value是 null
        IllegalArgumentException - 如果 value指定不支持的颜色名称或非法十六进制值
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        web(String)

      • getHue

        public double getHue​()
        获取此 Color的色相分量。
        结果
        色相值范围在 0.0-360.0范围内。

      • getSaturation

        public double getSaturation​()
        获取此 Color的饱和度分量。
        结果
        饱和度值范围在 0.0-1.0范围内。

      • getBrightness

        public double getBrightness​()
        获取此 Color的亮度分量。
        结果
        亮度值范围在 0.0-1.0范围内。

      • deriveColor

        public Color deriveColor​(double hueShift,
                         double saturationFactor,
                         double brightnessFactor,
                         double opacityFactor)
        基于这个Color创建一个新的Color ，其色调，饱和度，亮度和不透明度值被改变。 色相偏移给定值并归一化为其自然范围，其他分量的值乘以给定因子并剪切到其范围内。 通过使用任意非常小的源亮度而不是零，允许增加黑色的亮度。
        参数
        hueShift - 色相偏移
        saturationFactor - 饱和因子
        brightnessFactor - 亮度因子
        opacityFactor - 亮度因子
        结果
        基于 Color基于这个 Color ，色调，饱和度，亮度和不透明度值都改变了。

      • brighter

        public Color brighter​()
        创建一个这种颜色更亮的新颜色。
        结果
        一种颜色是这种颜色的更亮的版本

      • darker

        public Color darker​()
        创建一个这种颜色较暗版本的新颜色。
        结果
        一种颜色是这种颜色的较暗版本

      • saturate

        public Color saturate​()
        创建一个这个颜色的更饱和版本的新颜色。
        结果
        一种颜色是这种颜色的更饱和版本

      • desaturate

        public Color desaturate​()
        创建一个不太饱和的Color颜色的新颜色。
        结果
        一种颜色是这种颜色的较不饱和的版本

      • grayscale

        public Color grayscale​()
        创建一个与此颜色相当的灰度等级的新颜色。 不透明度被保留。
        结果
        一种与此颜色相当的灰度等级的颜色

      • invert

        public Color invert​()
        创建一个反映此颜色的新颜色。 不透明度被保留。
        结果
        一种颜色是这种颜色的反转

      • getRed

        public final double getRed​()
        红色组件 Color ，范围 0.0-1.0 。
        Default value:
        0.0
        结果
        红色组件 Color ，范围 0.0-1.0

      • getGreen

        public final double getGreen​()
        Color的绿色组件，范围 0.0-1.0 。
        Default value:
        0.0
        结果
        所述的绿色分量 Color ，在范围 0.0-1.0

      • getBlue

        public final double getBlue​()
        该蓝色成分为 Color ，范围为 0.0-1.0 。
        Default value:
        0.0
        结果
        蓝色成分为 Color ，范围为 0.0-1.0

      • getOpacity

        public final double getOpacity​()
        对的不透明度 Color ，范围为 0.0-1.0 。
        Default value:
        1.0
        结果
        所述的不透明度 Color ，在范围 0.0-1.0

      • isOpaque

        public final boolean isOpaque​()
        获取此Paint是否完全不透明。 不透明的油漆是其任何颜色都没有阿尔法成分的油漆。 油漆可能是不透明的，但是如果不能容易地确定涂料是否实际上是不透明的，则返回假。 例如，ImagePattern可能无法廉价地确定其不透明度。
        Specified by:
        isOpaque在 Paint
        结果
        如果油漆是不透明的，则为真，如果不透明或不能确定则为假。
        从以下版本开始：
        JavaFX 8.0

      • interpolate

        public Color interpolate​(Color endValue,
                         double t)
        该函数计算0.0和1.0之间的分数t的内插值。 当t = 1.0时，返回endVal 。
        Specified by:
        interpolate在接口 Interpolatable<Color>
        参数
        endValue - 目标值
        t - 0.0和 1.0之间的分数
        结果
        内插值

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象等于obj参数; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 Color对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 Color对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此Color的字符串表示Color 。 此方法仅用于信息目的。 返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但不能为null 。
        重写：
        toString在 Object
        结果
        字符串表示
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


CycleMethod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.paint

Enum CycleMethod

  • java.lang.Object
    • java.lang.Enum<CycleMethod>
      • javafx.scene.paint.CycleMethod
  • All Implemented Interfaces:
    Serializable ， Comparable<CycleMethod>

    public enum CycleMethod
extends Enum<CycleMethod>
    该枚举定义了以下方法梯度边界之外绘制时使用的一个： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NO_CYCLE
      定义使用终端颜色填充剩余区域的循环方法。
      REFLECT
      定义反映渐变颜色的循环方法，从头到尾，从头到尾，填充剩余的区域。
      REPEAT
      定义重复渐变颜色以填充剩余区域的循环方法。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static CycleMethod valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CycleMethod[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NO_CYCLE

        public static final CycleMethod NO_CYCLE
        定义使用终端颜色填充剩余区域的循环方法。

      • REFLECT

        public static final CycleMethod REFLECT
        定义反映渐变颜色的循环方法，从头到尾，从头到尾，填充剩余的区域。

      • REPEAT

        public static final CycleMethod REPEAT
        定义重复渐变颜色以填充剩余区域的循环方法。

    • 方法详细信息

      • values

        public static CycleMethod[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (CycleMethod c : CycleMethod.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static CycleMethod valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ImagePattern (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.paint

Class ImagePattern

  • java.lang.Object
    • javafx.scene.paint.Paint
      • javafx.scene.paint.ImagePattern

  • public final class ImagePattern
extends Paint

    ImagePattern类用图像模式填充形状。 用户可以指定锚定矩形，该矩形定义图像相对于形状的左上角的位置，宽度和高度。 如果形状延伸出锚定矩形，图像将被平铺。

    如果将proportional变量设置为true（默认值），则应该相对于单位平方（0.0-> 1.0）指定锚矩形，并将横跨形状进行拉伸。 如果将proportional变量设置为false，则应在形状的局部坐标系中指定锚矩形，并且图像将被拉伸以适合锚矩形。 锚矩形不会在整个形状上伸展。

    下面的例子演示了使用proportional变量。 顶行上的形状使用比例坐标（默认值）来指定锚矩形。 底行上的形状使用绝对坐标。 花图像被拉伸以填充整个三角形形状，而点图案图像被平铺在圆形内。

       import javafx.scene.Scene; import javafx.scene.image.Image; import javafx.scene.paint.ImagePattern; import javafx.scene.shape.Circle; import javafx.scene.shape.Polygon; import javafx.stage.Stage; public class HelloImagePattern extends Application { private static final String flowerURL = "file:flower.png"; private static final String dotsURL = "file:dots.png"; @Override public void start(Stage stage) { stage.setTitle("Image Pattern"); Group root = new Group(); Scene scene = new Scene(root, 600, 450); Image dots = new Image(dotsURL); Image flower = new Image(flowerURL); Polygon p = new Polygon(); p.setLayoutX(10); p.setLayoutY(10); p.getPoints().add(50.0); p.getPoints().add(0.0); p.getPoints().add(100.0); p.getPoints().add(100.0); p.getPoints().add(0.0); p.getPoints().add(100.0); p.setFill(new ImagePattern(flower, 0, 0, 1, 1, true)); root.getChildren().add(p); Polygon p2 = new Polygon(); p2.setLayoutX(10); p2.setLayoutY(120); p2.getPoints().add(50.0); p2.getPoints().add(0.0); p2.getPoints().add(100.0); p2.getPoints().add(100.0); p2.getPoints().add(0.0); p2.getPoints().add(100.0); p2.setFill(new ImagePattern(flower, 0, 0, 100, 100, false)); root.getChildren().add(p2); Circle circ = new Circle(50); circ.setTranslateX(120); circ.setTranslateY(10); circ.setCenterX(50); circ.setCenterY(50); circ.setFill(new ImagePattern(dots, 0.2, 0.2, 0.4, 0.4, true)); root.getChildren().add(circ); Circle circ2 = new Circle(50); circ2.setTranslateX(120); circ2.setTranslateY(10); circ2.setCenterX(50); circ2.setCenterY(50); circ2.setFill(new ImagePattern(dots, 20, 20, 40, 40, false)); root.getChildren().add(circ2); stage.setScene(scene); stage.show(); }

    以上代码产生以下内容：

    从以下版本开始：
    JavaFX 2.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImagePattern​(Image image)
      从指定的图像创建一个新的ImagePattern实例。
      ImagePattern​(Image image, double x, double y, double width, double height, boolean proportional)
      创建一个新的ImagePattern实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getHeight​()
      获取锚矩形的高度。
      Image getImage​()
      获取要用作油漆的图像。
      double getWidth​()
      获取锚矩形的宽度。
      double getX​()
      获取锚矩形的x原点。
      double getY​()
      获取锚矩形的y原点。
      boolean isOpaque​()
      获取此Paint是否完全不透明。
      boolean isProportional​()
      获取一个布尔值，指示开始和结束位置是成比例还是绝对。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.paint.Paint

        valueOf

    • 构造方法详细信息

      • ImagePattern

        public ImagePattern​(Image image)
        从指定的图像创建一个新的ImagePattern实例。 默认值用于所有其他参数。
        参数
        image - 用作油漆的图像。
        异常
        NullPointerException - 如果图像为空。
        IllegalArgumentException - 如果图像未完成加载，即进度为<1。

      • ImagePattern

        public ImagePattern​(Image image,
                    double x,
                    double y,
                    double width,
                    double height,
                    boolean proportional)
        创建一个新的ImagePattern实例。
        参数
        image - 用作油漆的图像。
        x - 锚矩形的x原点。
        y - 锚矩形的y原点。
        width - 锚矩形的宽度。
        height - 锚矩形的高度。
        proportional - 坐标是否与ImagePattern填充的形状成比例
        异常
        NullPointerException - 如果图像为空。
        IllegalArgumentException - 如果图像未完成加载，即进度是<1。

    • 方法详细信息

      • getImage

        public final Image getImage​()
        获取要用作油漆的图像。
        结果
        图像用作油漆。

      • getX

        public final double getX​()
        获取锚矩形的x原点。
        Default value:
        0.0
        结果
        锚矩形的x原点。

      • getY

        public final double getY​()
        获取锚矩形的y原点。
        Default value:
        0.0
        结果
        锚矩形的y原点。

      • getWidth

        public final double getWidth​()
        获取锚矩形的宽度。
        Default value:
        1.0
        结果
        新新新新旗新新新新旗新新旗旗新新新新旗新新旗旗新新旗新新200新新新

      • getHeight

        public final double getHeight​()
        获取锚矩形的高度。
        Default value:
        1.0
        结果
        锚矩形的高度。

      • isProportional

        public final boolean isProportional​()
        获取一个布尔值，指示开始和结束位置是成比例还是绝对。 如果该标志为真，则两个端点在坐标空间中定义，其中[0..1]范围内的[0..1]被缩放以映射到图案填充的形状的边界上。 如果该标志为假，则在该节点的本地坐标系中指定坐标。
        Default value:
        真正
        结果
        布尔值，如果此颜色成比例，则为true。

      • isOpaque

        public final boolean isOpaque​()
        描述从类别复制Paint
        获取此Paint是否完全不透明。 不透明的油漆是其任何颜色都没有阿尔法成分的油漆。 油漆可能是不透明的，但是如果不能容易地确定涂料是否实际上是不透明的，则返回假。 例如，ImagePattern可能无法廉价地确定其不透明度。
        Specified by:
        isOpaque在 Paint
        结果
        如果油漆是不透明的，则为真，如果不透明或不能确定则为假。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.paint (Java SE 9 & JDK 9 )

javafx.scene.paint

Classes

  • Color
  • ImagePattern
  • LinearGradient
  • Material
  • Paint
  • PhongMaterial
  • RadialGradient
  • Stop

Enums

  • CycleMethod


javafx.scene.paint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene.paint

提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

  • 类摘要
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
    ImagePattern
    ImagePattern类用图像模式填充形状。
    LinearGradient
    LinearGradient类用线性颜色渐变模式填充形状。
    Material
    用于表示3D表面材质的基类。
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
    PhongMaterial
    PhongMaterial类提供了代表Phong阴影材料的属性的定义。
    RadialGradient
    RadialGradient类提供了一种填充圆形径向颜色渐变图案的形状的方法。
    Stop
    定义渐变颜色斜坡的一个元素。
  • 枚举摘要
    Enum 描述
    CycleMethod
    该枚举定义了以下方法梯度边界之外绘制时使用的一个： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.paint Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.paint

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.paint.Material
      • javafx.scene.paint.PhongMaterial
    • javafx.scene.paint.Paint
      • javafx.scene.paint.Color (implements javafx.animation.Interpolatable<T>)
      • javafx.scene.paint.ImagePattern
      • javafx.scene.paint.LinearGradient
      • javafx.scene.paint.RadialGradient
    • javafx.scene.paint.Stop

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.paint.CycleMethod
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LinearGradient (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.paint

Class LinearGradient

  • java.lang.Object
    • javafx.scene.paint.Paint
      • javafx.scene.paint.LinearGradient

  • public final class LinearGradient
extends Paint

    LinearGradient类用线性颜色渐变模式填充形状。 用户可以指定两个或多个渐变颜色，并且此“绘画”将在每个颜色之间提供插值。

    该应用程序提供了一个Stop s的数组，指定如何沿渐变分布颜色。 Stop#offset变量的范围必须为0.0到1.0，并且像梯度的关键帧一样起作用。 偏移标记了渐变应该是一个特定的颜色。

    如果比例变量设置为真，则应该相对于单位平方（0.0-> 1.0）指定渐变的起始点和终点，并且将跨越形状拉伸。 如果比例变量设置为false，则应在形状的局部坐标系中指定起点和终点，并且渐变不会被拉伸。

    下面示例中的两个填充矩形将呈现相同的。 左边的一个使用比例坐标来指定渐变的终点。 右边的一个使用绝对坐标。 它们都用从黑色到红色的水平渐变填充指定的矩形

      // object bounding box relative (proportional = true)
Stop[] stops = new Stop[] { new Stop(0, Color.BLACK), new Stop(1, Color.RED)};
LinearGradient lg1 = new LinearGradient(0, 0, 1, 0, true, CycleMethod.NO_CYCLE, stops);
Rectangle r1 = new Rectangle(0, 0, 100, 100);
r1.setFill(lg1);

// user space relative (proportional: = false)
LinearGradient lg2 = new LinearGradient(125, 0, 225, 0, false, CycleMethod.NO_CYCLE, stops);
Rectangle r2 = new Rectangle(125, 0, 100, 100);
r2.setFill(lg2);
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      CycleMethod getCycleMethod​()
      定义了下面的循环方法的被施加到 LinearGradient ： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。
      double getEndX​()
      定义渐变轴终点的X坐标。
      double getEndY​()
      定义渐变轴终点的Y坐标。
      double getStartX​()
      定义渐变轴起始点的X坐标。
      double getStartY​()
      定义渐变轴起始点的Y坐标。
      List<Stop> getStops​()
      2个或多个 Stop值的序列，指定如何沿梯度分布颜色。
      int hashCode​()
      返回此 LinearGradient对象的哈希码。
      boolean isOpaque​()
      获取此Paint是否完全不透明。
      boolean isProportional​()
      指示开始和结束位置是成比例还是绝对。
      String toString​()
      返回此 LinearGradient对象的字符串表示形式。
      static LinearGradient valueOf​(String value)
      从字符串表示形成线性渐变值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LinearGradient

        public LinearGradient​(double startX,
                      double startY,
                      double endX,
                      double endY,
                      boolean proportional,
                      CycleMethod cycleMethod,
                      Stop... stops)
        创建一个新的LinearGradient实例。
        参数
        startX - 渐变轴起始点的X坐标
        startY - 渐变轴起始点的Y坐标
        endX - 渐变轴终点的X坐标
        endY - 渐变轴终点的Y坐标
        proportional - 坐标是否与该渐变填充的形状成正比
        cycleMethod - 循环方法应用于梯度
        stops - 梯度的颜色规格

      • LinearGradient

        public LinearGradient​(double startX,
                      double startY,
                      double endX,
                      double endY,
                      boolean proportional,
                      CycleMethod cycleMethod,
                      List<Stop> stops)
        创建一个新的LinearGradient实例。
        参数
        startX - 渐变轴起始点的X坐标
        startY - 渐变轴起始点的Y坐标
        endX - 渐变轴终点的X坐标
        endY - 渐变轴终点的Y坐标
        proportional - 坐标是否与该渐变填充的形状成正比
        cycleMethod - 应用于梯度的循环方法
        stops - 梯度的颜色规格

    • 方法详细信息

      • getStartX

        public final double getStartX​()
        定义渐变轴起始点的X坐标。 如果比例为真（默认值），此值指定单位平方的点，该点将被缩放以匹配渐变填充的形状的大小。 （
        Default value:
        0.0
        结果
        梯度轴起始点的X坐标

      • getStartY

        public final double getStartY​()
        定义渐变轴起始点的Y坐标。 如果比例为真（默认值），此值指定单位平方的点，该点将被缩放以匹配渐变填充的形状的大小。
        Default value:
        0.0
        结果
        梯度轴起始点的Y坐标

      • getEndX

        public final double getEndX​()
        定义渐变轴终点的X坐标。 如果比例为真（默认值），此值指定单位平方的点，该点将被缩放以匹配渐变填充的形状的大小。
        Default value:
        1.0
        结果
        梯度轴终点的X坐标

      • getEndY

        public final double getEndY​()
        定义渐变轴终点的Y坐标。 如果比例为真（默认值），此值指定单位平方的点，该点将被缩放以匹配渐变填充的形状的大小。
        Default value:
        1.0
        结果
        梯度轴终点的Y坐标

      • isProportional

        public final boolean isProportional​()
        指示开始和结束位置是成比例还是绝对。 如果此标志为真，则两个端点在坐标空间中定义，其中[0..1]范围内的[0..1]被缩放以映射到渐变填充的形状的边界上。 如果该标志为假，则在该节点的本地坐标系中指定坐标。
        Default value:
        真正
        结果
        如果真正的开始和结束位置成比例，否则为绝对值

      • getCycleMethod

        public final CycleMethod getCycleMethod​()
        定义了下面的循环方法的被施加到 LinearGradient ： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。
        Default value:
        NO_CYCLE
        结果
        该循环方法应用于该线性梯度

      • getStops

        public final List<Stop> getStops​()
        2个或更多个Stop值的序列，指定如何沿渐变分布颜色。 这些值必须在0.0到1.0的范围内。 它们像梯度的关键帧一样起作用：它们标示渐变应该是一个特定的颜色。

        序列中的每个停止位都必须具有大于序列中前一个停止位置的偏移量。

        该列表是不可修改的，并将在每次修改尝试时抛出UnsupportedOperationException 。

        Default value:
        空
        结果
        停止值列表

      • isOpaque

        public final boolean isOpaque​()
        获取此Paint是否完全不透明。 不透明的油漆是其任何颜色都没有阿尔法成分的油漆。 油漆可能是不透明的，但是如果不能容易地确定涂料是否实际上是不透明的，则返回假。 例如，ImagePattern可能无法廉价地确定其不透明度。
        Specified by:
        isOpaque在 Paint
        结果
        如果油漆是不透明的，则为真，如果不透明或不能确定则为假。
        从以下版本开始：
        JavaFX 8.0

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象等于obj参数; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 LinearGradient对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 LinearGradient对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此 LinearGradient对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这是 LinearGradient对象的字符串表示形式。

      • valueOf

        public static LinearGradient valueOf​(String value)
        从字符串表示形成线性渐变值。

        字符串表示的格式基于线性渐变的JavaFX CSS规范

          linear-gradient( [ [from <point> to <point>| [ to <side-or-corner>], ]? [ [ repeat | reflect ], ]? <color-stop>[, <color-stop>]+)
        哪里
          <side-or-corner> = [left | right] || [top | bottom]
 <point> = [ [ <length> <length> ] | [ <percentage> | <percentage> ] ]
 <color-stop> = [ <color> [ <percentage> | <length>]? ]

        目前的长度只能用px来指定，单位的规格可以不理。 颜色表示的格式是Color.web(String color)中使用的格式 。 线性梯度关键字可以被忽略。 有关字符串表示形式的其他信息，请参阅CSS Reference Guide 。

        例子：
           LinearGradient g = LinearGradient.valueOf("linear-gradient(from 0% 0% to 100% 100%, red 0% , blue 30%, black 100%)"); LinearGradient g = LinearGradient.valueOf("from 0% 0% to 100% 100%, red 0% , blue 30%, black 100%"); LinearGradient g = LinearGradient.valueOf("linear-gradient(from 0px 0px to 200px 0px, #00ff00 0%, 0xff0000 50%, 0x1122ff40 100%)"); LinearGradient g = LinearGradient.valueOf("from 0px 0px to 200px 0px, #00ff00 0%, 0xff0000 50%, 0x1122ff40 100%");
        参数
        value - 要转换的字符串
        结果
        一个 LinearGradient对象，保存由字符串参数表示的值。
        异常
        NullPointerException - 如果 value是 null
        IllegalArgumentException - 如果 value无法解析
        从以下版本开始：
        JavaFX 2.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Material (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.paint

Class Material

  • java.lang.Object
    • javafx.scene.paint.Material
  • 已知直接子类：
    PhongMaterial

    public abstract class Material
extends Object
    用于表示3D表面材质的基类。 请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。
    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | Material​()

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Material

        protected Material​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Paint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.paint

Class Paint

  • java.lang.Object
    • javafx.scene.paint.Paint
  • 已知直接子类：
    Color ， ImagePattern ， LinearGradient ， RadialGradient

    public abstract class Paint
extends Object
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract boolean isOpaque​()
      获取此Paint是否完全不透明。
      static Paint valueOf​(String value)
      从字符串表示形式创建一个绘制值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • isOpaque

        public abstract boolean isOpaque​()
        获取此Paint是否完全不透明。 不透明的油漆是其任何颜色都没有阿尔法成分的油漆。 油漆可能是不透明的，但是如果不能容易地确定涂料是否实际上是不透明的，则返回假。 例如，ImagePattern可能无法廉价地确定其不透明度。
        结果
        如果油漆是不透明的，则为真，如果不透明或不能确定则为假。
        从以下版本开始：
        JavaFX 8.0

      • valueOf

        public static Paint valueOf​(String value)
        从字符串表示形式创建一个绘制值。 确认代表字符串Color ， RadialGradient或者LinearGradient 。 指定LinearGradient的字符串必须以线性梯度关键字和字符串开头，指定RadialGradient必须以径向渐变开头。
        参数
        value - 要转换的字符串
        结果
        一个 Color ， RadialGradient或 LinearGradient物体保持由字符串参数所表示的值。
        异常
        NullPointerException - 如果 value是 null
        IllegalArgumentException - 如果 value无法解析
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        Color.valueOf(String) ，
LinearGradient.valueOf(String) ，
RadialGradient.valueOf(String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PhongMaterial (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.paint

Class PhongMaterial

  • java.lang.Object
    • javafx.scene.paint.Material
      • javafx.scene.paint.PhongMaterial

  • public class PhongMaterial
extends Material
    PhongMaterial类提供了代表Phong阴影材料的属性的定义。 它描述了光与其应用的Mesh的表面的相互作用。 PhongMaterial根据漫反射和镜面反射光以及环境和自身照明条件反射光。 几何表面上的点的颜色是这四个分量的数学函数。

    颜色由以下等式计算：

       for each ambient light source i { ambient += lightColor[i] } for each point light source i { diffuse += (L[i] . N) * lightColor[i] specular += ((R[i] . V) ^ (specularPower * intensity(specularMap))) * lightColor[i] } color = (ambient + diffuse) * diffuseColor * diffuseMap + specular * specularColor * specularMap + selfIlluminationMap
    其中lightColor[i]是光源i的颜色，
    L[i]是从表面到光源i的矢量，
    N是正常的向量（如果存在，则将其加入到bumpMap中）
    R[i]是关于表面法线的L [i]的归一化反射矢量，
    V是归一化视图向量。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    AmbientLight ， PointLight

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Image> bumpMap
      这个PhongMaterial的凹凸贴图，这是一个正常的地图，存储为RGB Image 。
      ObjectProperty<Color> diffuseColor
      这个漫反射颜色的这个 PhongMaterial 。
      ObjectProperty<Image> diffuseMap
      这个漫反射图 PhongMaterial 。
      ObjectProperty<Image> selfIlluminationMap
      这个自拍照片 PhongMaterial 。
      ObjectProperty<Color> specularColor
      这个镜面颜色是 PhongMaterial 。
      ObjectProperty<Image> specularMap
      这个 PhongMaterial的镜面图。
      DoubleProperty specularPower
      这镜子的力量这 PhongMaterial 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PhongMaterial​()
      创建一个新的实例 PhongMaterial类与默认Color.WHITE diffuseColor属性。
      PhongMaterial​(Color diffuseColor)
      使用指定的颜色为其 diffuseColor属性创建一个新的实例 PhongMaterial类。
      PhongMaterial​(Color diffuseColor, Image diffuseMap, Image specularMap, Image bumpMap, Image selfIlluminationMap)
      使用指定的颜色和图像为其 diffuseColor属性创建 PhongMaterial类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Image> bumpMapProperty​()
      这个PhongMaterial的凹凸贴图，这是一个保存为RGB Image的法线贴图。
      ObjectProperty<Color> diffuseColorProperty​()
      这个漫反射的颜色 PhongMaterial 。
      ObjectProperty<Image> diffuseMapProperty​()
      这个漫反射图 PhongMaterial 。
      Image getBumpMap​()
      获取属性bumpMap的值。
      Color getDiffuseColor​()
      获取属性diffuseColor的值。
      Image getDiffuseMap​()
      获取属性diffuseMap的值。
      Image getSelfIlluminationMap​()
      获取属性selfIlluminationMap的值。
      Color getSpecularColor​()
      获取属性specularColor的值。
      Image getSpecularMap​()
      获取属性specularMap的值。
      double getSpecularPower​()
      获取属性specularPower的值。
      ObjectProperty<Image> selfIlluminationMapProperty​()
      这个自拍照片 PhongMaterial 。
      void setBumpMap​(Image value)
      设置属性bumpMap的值。
      void setDiffuseColor​(Color value)
      设置属性diffuseColor的值。
      void setDiffuseMap​(Image value)
      设置propertyMap属性的值。
      void setSelfIlluminationMap​(Image value)
      设置属性selfIlluminationMap的值。
      void setSpecularColor​(Color value)
      设置属性specularColor的值。
      void setSpecularMap​(Image value)
      设置属性specularMap的值。
      void setSpecularPower​(double value)
      设置属性specularPower的值。
      ObjectProperty<Color> specularColorProperty​()
      这镜子的颜色 PhongMaterial 。
      ObjectProperty<Image> specularMapProperty​()
      这个 PhongMaterial的镜面图。
      DoubleProperty specularPowerProperty​()
      这个镜面的力量这个 PhongMaterial 。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • diffuseColor

        public final ObjectProperty<Color> diffuseColorProperty
        这个漫反射颜色 PhongMaterial 。
        Default value:
        Color.WHITE
        另请参见：
        getDiffuseColor() ， setDiffuseColor(Color)

      • specularColor

        public final ObjectProperty<Color> specularColorProperty
        这个镜面颜色是 PhongMaterial 。
        Default value:
        空值
        另请参见：
        getSpecularColor() ， setSpecularColor(Color)

      • specularPower

        public final DoubleProperty specularPowerProperty
        这镜子的力量这个 PhongMaterial 。
        Default value:
        32.0
        另请参见：
        getSpecularPower() ， setSpecularPower(double)

      • diffuseMap

        public final ObjectProperty<Image> diffuseMapProperty
        这个漫反射图 PhongMaterial 。
        Default value:
        空值
        另请参见：
        getDiffuseMap() ， setDiffuseMap(Image)

      • specularMap

        public final ObjectProperty<Image> specularMapProperty
        这个 PhongMaterial的镜面图。
        Default value:
        空值
        另请参见：
        getSpecularMap() ， setSpecularMap(Image)

      • bumpMap

        public final ObjectProperty<Image> bumpMapProperty
        这个PhongMaterial的凹凸贴图，这是一个存储为RGB Image的法线贴图。
        Default value:
        空值
        另请参见：
        getBumpMap() ， setBumpMap(Image)

      • selfIlluminationMap

        public final ObjectProperty<Image> selfIlluminationMapProperty
        这个 PhongMaterial的自我照明图。
        Default value:
        空值
        另请参见：
        getSelfIlluminationMap() ， setSelfIlluminationMap(Image)

    • 构造方法详细信息

      • PhongMaterial

        public PhongMaterial​()
        使用默认的Color.WHITE diffuseColor属性创建一个 PhongMaterial类的新实例。

      • PhongMaterial

        public PhongMaterial​(Color diffuseColor)
        使用指定的颜色为其 diffuseColor属性创建一个 PhongMaterial类的新实例。
        参数
        diffuseColor - diffuseColor属性的颜色

      • PhongMaterial

        public PhongMaterial​(Color diffuseColor,
                     Image diffuseMap,
                     Image specularMap,
                     Image bumpMap,
                     Image selfIlluminationMap)
        使用指定的颜色和图像为其 diffuseColor属性创建一个 PhongMaterial类的新实例。
        参数
        diffuseColor - diffuseColor属性的颜色
        diffuseMap - diffuseMap属性的图像
        specularMap - specularMap属性的图像
        bumpMap - bumpMap属性的图像
        selfIlluminationMap - selfIlluminationMap属性的图像

    • 方法详细信息

      • setDiffuseColor

        public final void setDiffuseColor​(Color value)
        设置属性diffuseColor的值。
        Property description:
        这个漫反射的颜色 PhongMaterial 。
        Default value:
        Color.WHITE

      • getDiffuseColor

        public final Color getDiffuseColor​()
        获取属性diffuseColor的值。
        Property description:
        这个漫反射的颜色 PhongMaterial 。
        Default value:
        Color.WHITE

      • diffuseColorProperty

        public final ObjectProperty<Color> diffuseColorProperty​()
        这个漫反射的颜色这个 PhongMaterial 。
        Default value:
        Color.WHITE
        另请参见：
        getDiffuseColor() ， setDiffuseColor(Color)

      • setSpecularColor

        public final void setSpecularColor​(Color value)
        设置属性specularColor的值。
        Property description:
        这个镜面颜色 PhongMaterial 。
        Default value:
        空值

      • getSpecularColor

        public final Color getSpecularColor​()
        获取属性specularColor的值。
        Property description:
        这镜子的颜色 PhongMaterial 。
        Default value:
        空值

      • specularColorProperty

        public final ObjectProperty<Color> specularColorProperty​()
        这镜子的颜色 PhongMaterial 。
        Default value:
        空值
        另请参见：
        getSpecularColor() ， setSpecularColor(Color)

      • setSpecularPower

        public final void setSpecularPower​(double value)
        设置属性specularPower的值。
        Property description:
        这镜子的力量这个 PhongMaterial 。
        Default value:
        32.0

      • getSpecularPower

        public final double getSpecularPower​()
        获取属性specularPower的值。
        Property description:
        这镜子的力量这个 PhongMaterial 。
        Default value:
        32.0

      • specularPowerProperty

        public final DoubleProperty specularPowerProperty​()
        这镜子的力量这 PhongMaterial 。
        Default value:
        32.0
        另请参见：
        getSpecularPower() ， setSpecularPower(double)

      • setDiffuseMap

        public final void setDiffuseMap​(Image value)
        设置propertyMap属性的值。
        Property description:
        这个漫反射图 PhongMaterial 。
        Default value:
        空值

      • getDiffuseMap

        public final Image getDiffuseMap​()
        获取属性diffuseMap的值。
        Property description:
        这个漫反射图 PhongMaterial 。
        Default value:
        空值

      • diffuseMapProperty

        public final ObjectProperty<Image> diffuseMapProperty​()
        这个漫反射图 PhongMaterial 。
        Default value:
        空值
        另请参见：
        getDiffuseMap() ， setDiffuseMap(Image)

      • setSpecularMap

        public final void setSpecularMap​(Image value)
        设置属性specularMap的值。
        Property description:
        这个 PhongMaterial的镜面图。
        Default value:
        空值

      • getSpecularMap

        public final Image getSpecularMap​()
        获取属性specularMap的值。
        Property description:
        这个 PhongMaterial的镜面图。
        Default value:
        空值

      • specularMapProperty

        public final ObjectProperty<Image> specularMapProperty​()
        这个 PhongMaterial的镜面图。
        Default value:
        空值
        另请参见：
        getSpecularMap() ， setSpecularMap(Image)

      • setBumpMap

        public final void setBumpMap​(Image value)
        设置属性bumpMap的值。
        Property description:
        这个PhongMaterial的凹凸贴图，这是一个保存为RGB Image的法线贴图。
        Default value:
        空值

      • getBumpMap

        public final Image getBumpMap​()
        获取属性bumpMap的值。
        Property description:
        这个PhongMaterial的凹凸贴图，这是一个保存为RGB Image的普通地图。
        Default value:
        空值

      • bumpMapProperty

        public final ObjectProperty<Image> bumpMapProperty​()
        这个PhongMaterial的凹凸贴图，它是一个存储为RGB Image的法线贴图。
        Default value:
        空值
        另请参见：
        getBumpMap() ， setBumpMap(Image)

      • setSelfIlluminationMap

        public final void setSelfIlluminationMap​(Image value)
        设置属性selfIlluminationMap的值。
        Property description:
        这个自拍照片 PhongMaterial 。
        Default value:
        空值

      • getSelfIlluminationMap

        public final Image getSelfIlluminationMap​()
        获取属性selfIlluminationMap的值。
        Property description:
        这个自拍照片 PhongMaterial 。
        Default value:
        空值

      • selfIlluminationMapProperty

        public final ObjectProperty<Image> selfIlluminationMapProperty​()
        这个自拍照片 PhongMaterial 。
        Default value:
        空值
        另请参见：
        getSelfIlluminationMap() ， setSelfIlluminationMap(Image)

      • toString

        public String toString​()
        描述从类复制Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RadialGradient (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.paint

Class RadialGradient

  • java.lang.Object
    • javafx.scene.paint.Paint
      • javafx.scene.paint.RadialGradient

  • public final class RadialGradient
extends Paint
    RadialGradient类提供了一种填充圆形径向颜色渐变图案的形状的方法。 用户可以指定2种或更多种渐变颜色，而这种颜色将在每种颜色之间提供插值。

    用户必须指定控制渐变图案的圆，它由中心点和半径定义。 用户还可以在该圆内指定单独的焦点，该点控制渐变的第一个颜色的位置。 默认情况下，焦点设置为圆的中心。

    中心和半径相对于单位平方来指定，除非proportional变量为false。 默认比例为true，渐变将缩放以填充其应用的任何形状。 焦点总是相对于中心点指定相对于半径的角度和距离。

    此画面将渐变的第一个颜色映射到焦点，并将最后一个颜色映射到圆周边，为用户指定的任何中间颜色顺利插入。 因此，从焦点到圆周绘制的任何线将跨越所有渐变颜色。

    对焦距离将被夹紧到(-1, 1)范围内，使焦点始终严格在圆内。

    该应用程序提供了一个Stop s的数组，指定如何沿渐变分布颜色。 Stop#offset变量的范围必须为0.0到1.0，并且像梯度的关键帧一样起作用。 它们标记渐变应该是一个特定的颜色。

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      double getCenterX​()
      定义定义渐变的圆的中心点的X坐标。
      double getCenterY​()
      定义定义渐变的圆的中心点的X坐标。
      CycleMethod getCycleMethod​()
      定义应用于 RadialGradient的循环方法。
      double getFocusAngle​()
      定义从渐变的中心到第一个颜色映射到的对焦点的角度（以度为单位）。
      double getFocusDistance​()
      定义从渐变的中心到第一个颜色映射到的对焦点的距离。
      double getRadius​()
      指定定义颜色渐变范围的圆的半径。
      List<Stop> getStops​()
      2个或多个 Stop值的序列，指定如何沿着渐变分布颜色。
      int hashCode​()
      返回此 RadialGradient对象的哈希码。
      boolean isOpaque​()
      获取此Paint是否完全不透明。
      boolean isProportional​()
      指示中心和半径值是正比还是绝对。
      String toString​()
      返回此 RadialGradient对象的字符串表示形式。
      static RadialGradient valueOf​(String value)
      从字符串表示形成径向渐变值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RadialGradient

        public RadialGradient​(double focusAngle,
                      double focusDistance,
                      double centerX,
                      double centerY,
                      double radius,
                      boolean proportional,
                      CycleMethod cycleMethod,
                      Stop... stops)
        创建一个新的RadialGradient实例。
        参数
        focusAngle - 从渐变的中心到第一个颜色映射到的对焦点的角度角度
        focusDistance - 从渐变中心到第一个颜色映射到的对焦点的距离
        centerX - 渐变圆的中心点的X坐标
        centerY - 渐变圆的中心点的Y坐标
        radius - 定义颜色渐变范围的圆的半径
        proportional - 坐标和尺寸是否与该渐变填充的形状成比例
        cycleMethod - 应用于渐变的循环方法
        stops - 梯度的颜色规格

      • RadialGradient

        public RadialGradient​(double focusAngle,
                      double focusDistance,
                      double centerX,
                      double centerY,
                      double radius,
                      boolean proportional,
                      CycleMethod cycleMethod,
                      List<Stop> stops)
        创建一个新的RadialGradient实例。
        参数
        focusAngle - 从渐变中心到第一个颜色映射到的对焦点的角度角度
        focusDistance - 从渐变的中心到第一个颜色映射到的对焦点的距离
        centerX - 渐变圆的中心点的X坐标
        centerY - 渐变圆的中心点的Y坐标
        radius - 定义颜色渐变范围的圆的半径
        proportional - 坐标和大小是否与该渐变填充的形状成比例
        cycleMethod - 循环方法应用于梯度
        stops - 梯度的颜色规格

    • 方法详细信息

      • getFocusAngle

        public final double getFocusAngle​()
        定义从渐变的中心到第一个颜色映射到的对焦点的角度（以度为单位）。
        结果
        从渐变的中心到第一个颜色映射到的对焦点的角度

      • getFocusDistance

        public final double getFocusDistance​()
        定义从渐变的中心到第一个颜色映射到的对焦点的距离。 距离为0.0将在渐变圆的中心。 距离为1.0将在渐变圆的圆周上。
        结果
        从渐变的中心到第一个颜色映射到的焦点的距离

      • getCenterX

        public final double getCenterX​()
        定义定义渐变的圆的中心点的X坐标。 如果比例为真（默认值），此值指定单位平方的点，该点将被缩放以匹配渐变填充的形状的大小。 渐变的最后一个颜色被映射到该圆的周长。
        Default value:
        0.0
        结果
        定义渐变的圆的中心点的X坐标

      • getCenterY

        public final double getCenterY​()
        定义定义渐变的圆的中心点的X坐标。 如果比例为真（默认值），此值指定单位平方的点，该点将被缩放以匹配渐变填充的形状的大小。 渐变的最后一个颜色被映射到该圆的周长。
        Default value:
        0.0
        结果
        定义渐变的圆的中心点的X坐标

      • getRadius

        public final double getRadius​()
        指定定义颜色渐变范围的圆的半径。 如果比例为真（默认值），此值指定相对于单位平方的尺寸，该尺寸将缩放以匹配渐变填充的形状的大小。
        Default value:
        1.0
        结果
        圆的半径定义颜色渐变的范围

      • isProportional

        public final boolean isProportional​()
        指示中心和半径值是正比还是绝对。 如果该标志为真，则中心点和半径在坐标空间中定义，其坐标范围为[0..1] ，以映射到渐变填充的形状边界。 如果该标志为假，则在节点的本地坐标系中指定中心坐标和半径。
        Default value:
        真正
        结果
        如果中心和半径值成正比，则为真，否则为绝对值

      • getCycleMethod

        public final CycleMethod getCycleMethod​()
        定义应用于RadialGradient的循环方法。 一： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或CycleMethod.REPEAT 。
        Default value:
        NO_CYCLE
        结果
        循环方法应用于该径向梯度

      • getStops

        public final List<Stop> getStops​()
        2个或多个Stop值的序列，用于指定如何沿梯度分布颜色。 这些值必须在0.0到1.0的范围内。 它们像渐变中的关键帧一样起作用：它们标示渐变应该是一个特定的颜色。

        序列中的每个停止位都必须具有大于序列中前一个停止位置的偏移量。

        列表是不可修改的，每次修改尝试都会抛出UnsupportedOperationException 。

        Default value:
        空
        结果
        停止值列表

      • isOpaque

        public final boolean isOpaque​()
        获取此Paint是否完全不透明。 不透明的油漆是其任何颜色都没有阿尔法成分的油漆。 油漆可能是不透明的，但是如果不能容易地确定涂料是否实际上是不透明的，则返回假。 例如，ImagePattern可能无法廉价地确定其不透明度。
        Specified by:
        isOpaque在 Paint
        结果
        如果油漆是不透明的，则为真，如果不透明或不能确定则为假。
        从以下版本开始：
        JavaFX 8.0

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象等于obj参数; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 RadialGradient对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 RadialGradient对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此 RadialGradient对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 RadialGradient对象的字符串表示形式。

      • valueOf

        public static RadialGradient valueOf​(String value)
        从字符串表示形成径向渐变值。

        字符串表示形式基于径向渐变的JavaFX CSS规范

          radial-gradient([focus-angle <angle>, ]?
                 [focus-distance <percentage>, ]?
                 [center <point>, ]?
                 radius [<length> | <percentage>],
                 [[repeat | reflect],]?
                 <color-stop>[, <color-stop>]+)
        哪里
          <point> = [ [ <length> <length> ] | [ <percentage> | <percentage> ] ]
 <color-stop> = [ <color> [ <percentage> | <length>]? ]

        目前的长度只能用px来指定，单位的规格可以不理。 颜色表示的格式是Color.web(String color)中使用的格式 。 径向渐变关键字可以被忽略。 有关字符串表示形式的其他信息，请参阅CSS Reference Guide 。

        例子：
           RadialGradient g = RadialGradient.valueOf("radial-gradient(center 100px 100px, radius 200px, red 0%, blue 30%, black 100%)"); RadialGradient g = RadialGradient.valueOf("center 100px 100px, radius 200px, red 0%, blue 30%, black 100%"); RadialGradient g = RadialGradient.valueOf("radial-gradient(center 50% 50%, radius 50%, cyan, violet 75%, magenta)"); RadialGradient g = RadialGradient.valueOf("center 50% 50%, radius 50%, cyan, violet 75%, magenta");
        参数
        value - 要转换的字符串
        结果
        一个 RadialGradient对象，保存由string参数表示的值。
        异常
        NullPointerException - 如果 value是 null
        IllegalArgumentException - 如果 value无法解析
        从以下版本开始：
        JavaFX 2.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Stop (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.paint

Class Stop

  • java.lang.Object
    • javafx.scene.paint.Stop

  • public final class Stop
extends Object
    定义渐变颜色斜坡的一个元素。 有关详细信息，请参阅javafx.scene.paint.LinearGradient和javafx.scene.paint.RadialGradient 。

    例：

       // object bounding box relative (proportional:true, default) Stop[] stops = { new Stop(0, Color.WHITE), new Stop(1, Color.BLACK)}; LinearGradient lg = new LinearGradient(0, 0, 1, 0, true, CycleMethod.No_CYCLE, stops); Rectangle r = new Rectangle(); r.setFill(lg);
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      Stop​(double offset, Color color)
      创建一个新的Stop实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      Color getColor​()
      获取此偏移量的渐变颜色。
      double getOffset​()
      获取一个范围从 0到 1 ，表示放置此梯度停止的位置。
      int hashCode​()
      返回此 Stop对象的哈希码。
      String toString​()
      返回此 Stop对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Stop

        public Stop​(double offset,
            Color color)
        创建一个新的Stop实例。
        参数
        offset - 止损位置（从 0到 1
        color - 停止的颜色

    • 方法详细信息

      • getOffset

        public final double getOffset​()
        获取一个范围从0到1 ，表示放置此梯度停止的位置。 对于线性梯度， offset变量表示沿梯度向量的位置。 对于径向梯度，它表示从焦点到最外/最大圆的边缘的百分比距离。
        结果
        停止位置在坡度范围内（从 0到 1 ）

      • getColor

        public final Color getColor​()
        获取此偏移量的渐变颜色。
        结果
        这个偏移的渐变颜色

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象等于obj参数; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 Stop对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 Stop对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此 Stop对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 Stop对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.paint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.paint

  • Packages that use javafx.scene.paint
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
  • Classes in javafx.scene.paint used by javafx.animation
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
  • Classes in javafx.scene.paint used by javafx.css
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
  • Classes in javafx.scene.paint used by javafx.css.converter
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
    Stop
    定义渐变颜色斜坡的一个元素。
  • Classes in javafx.scene.paint used by javafx.scene
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
  • Classes in javafx.scene.paint used by javafx.scene.canvas
    Class 描述
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
  • Classes in javafx.scene.paint used by javafx.scene.chart
    Class 描述
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
  • Classes in javafx.scene.paint used by javafx.scene.control
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
  • Classes in javafx.scene.paint used by javafx.scene.control.skin
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
  • Classes in javafx.scene.paint used by javafx.scene.effect
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
  • Classes in javafx.scene.paint used by javafx.scene.image
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
  • Classes in javafx.scene.paint used by javafx.scene.layout
    Class 描述
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
  • Classes in javafx.scene.paint used by javafx.scene.paint
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中。
    CycleMethod
    该枚举定义了以下方法梯度边界之外绘制时使用的一个： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。
    LinearGradient
    LinearGradient类用线性颜色渐变模式填充形状。
    Material
    用于表示3D表面材质的基类。
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
    RadialGradient
    RadialGradient类提供了一种填充圆形径向颜色渐变图案的形状的方法。
    Stop
    定义渐变颜色斜坡的一个元素。
  • Classes in javafx.scene.paint used by javafx.scene.shape
    Class 描述
    Material
    用于表示3D表面材质的基类。
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
  • Classes in javafx.scene.paint used by javafx.scene.text
    Class 描述
    Paint
    用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.paint.Color (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.paint.Color

  • Packages that use Color
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

    • Uses of Color in javafx.animation

      Methods in javafx.animation that return Color
      Modifier and Type 方法 描述
      Color FillTransition.getFromValue​()
      获取属性fromValue的值。
      Color StrokeTransition.getFromValue​()
      获取属性fromValue的值。
      Color FillTransition.getToValue​()
      获取属性值到值。
      Color StrokeTransition.getToValue​()
      获取属性值到值。
      Methods in javafx.animation that return types with arguments of type Color
      Modifier and Type 方法 描述
      ObjectProperty<Color> FillTransition.fromValueProperty​()
      指定此 FillTransition的起始颜色值。
      ObjectProperty<Color> StrokeTransition.fromValueProperty​()
      指定此 StrokeTransition的起始颜色值。
      ObjectProperty<Color> FillTransition.toValueProperty​()
      指定此 FillTransition的停止颜色值。
      ObjectProperty<Color> StrokeTransition.toValueProperty​()
      指定此 StrokeTransition的停止颜色值。
      Methods in javafx.animation with parameters of type Color
      Modifier and Type 方法 描述
      void FillTransition.setFromValue​(Color value)
      设置属性fromValue的值。
      void StrokeTransition.setFromValue​(Color value)
      设置属性fromValue的值。
      void FillTransition.setToValue​(Color value)
      将属性的值设置为Value。
      void StrokeTransition.setToValue​(Color value)
      将属性的值设置为Value。
      Constructors in javafx.animation with parameters of type Color
      Constructor 描述
      FillTransition​(Duration duration, Color fromValue, Color toValue)
      构造函数为 FillTransition
      FillTransition​(Duration duration, Shape shape, Color fromValue, Color toValue)
      构造函数 FillTransition
      StrokeTransition​(Duration duration, Color fromValue, Color toValue)
      构造函数为 StrokeTransition
      StrokeTransition​(Duration duration, Shape shape, Color fromValue, Color toValue)
      构造函数为 StrokeTransition

    • Uses of Color in javafx.css

      Methods in javafx.css that return types with arguments of type Color
      Modifier and Type 方法 描述
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function)
      创建一个CssMetaData <S，Color>，初始值为Color.BLACK，并继承标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Color>并继承标志。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty)
      使用之前创建的CssMetaData为给定的 cssProperty创建一个StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function)
      创建一个StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建一个具有初始值的StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Color>并继承标志。
      static StyleConverter<String,Color> StyleConverter.getColorConverter​()
      返回一个 StyleConverter ，将Web颜色的String表示形式转换为 Color 。
      Methods in javafx.css with parameters of type Color
      Modifier and Type 方法 描述
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Color>并继承标志。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建一个具有初始值的StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Color>并继承标志。
      Method parameters in javafx.css with type arguments of type Color
      Modifier and Type 方法 描述
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function)
      创建一个CssMetaData <S，Color>，初始值为Color.BLACK，并继承标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。
      CssMetaData<S,Color> StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Color>并继承标志。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function)
      创建一个StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue)
      创建一个具有初始值的StyleableProperty <Color>。
      StyleableProperty<Color> StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Color>并继承标志。

    • Uses of Color in javafx.css.converter

      Methods in javafx.css.converter that return Color
      Modifier and Type | 方法 | 描述
      Color | ColorConverter.convert​(ParsedValue<String,Color> value, Font font)
      Color | DeriveColorConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)
      Color | LadderConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)
      Methods in javafx.css.converter that return types with arguments of type Color
      Modifier and Type | 方法 | 描述
      static StyleConverter<String,Color> | ColorConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Color
      Modifier and Type | 方法 | 描述
      Color | ColorConverter.convert​(ParsedValue<String,Color> value, Font font)
      Color | DeriveColorConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)
      Color | LadderConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)

    • Uses of Color in javafx.scene

      Methods in javafx.scene that return Color
      Modifier and Type 方法 描述
      Color LightBase.getColor​()
      获取属性颜色的值。
      Methods in javafx.scene that return types with arguments of type Color
      Modifier and Type 方法 描述
      ObjectProperty<Color> LightBase.colorProperty​()
      指定光源的颜色。
      Methods in javafx.scene with parameters of type Color
      Modifier and Type 方法 描述
      void LightBase.setColor​(Color value)
      设置属性颜色的值。
      Constructors in javafx.scene with parameters of type Color
      Constructor 描述
      AmbientLight​(Color color)
      使用指定的颜色创建一个新的 AmbientLight类的实例。
      LightBase​(Color color)
      使用指定的颜色创建一个新的 LightBase类的实例。
      PointLight​(Color color)
      使用指定的颜色创建 PointLight类的新实例。

    • Uses of Color in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type Color
      Modifier and Type 方法 描述
      ObservableList<Color> ColorPicker.getCustomColors​()
      获取用户添加到调色板的自定义颜色列表。
      Constructors in javafx.scene.control with parameters of type Color
      Constructor 描述
      ColorPicker​(Color color)
      创建一个ColorPicker实例，并将所选颜色设置为给定的颜色。

    • Uses of Color in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return types with arguments of type Color
      Modifier and Type 方法 描述
      protected StringConverter<Color> ColorPickerSkin.getConverter​()
      子类负责获取转换器。

    • Uses of Color in javafx.scene.effect

      Methods in javafx.scene.effect that return Color
      Modifier and Type 方法 描述
      Color DropShadow.getColor​()
      获取属性颜色的值。
      Color InnerShadow.getColor​()
      获取属性颜色的值。
      Color Light.getColor​()
      获取属性颜色的值。
      Color Shadow.getColor​()
      获取属性颜色的值。
      Methods in javafx.scene.effect that return types with arguments of type Color
      Modifier and Type 方法 描述
      ObjectProperty<Color> DropShadow.colorProperty​()
      阴影 Color 。
      ObjectProperty<Color> InnerShadow.colorProperty​()
      阴影 Color 。
      ObjectProperty<Color> Light.colorProperty​()
      光源的颜色。
      ObjectProperty<Color> Shadow.colorProperty​()
      阴影 Color 。
      Methods in javafx.scene.effect with parameters of type Color
      Modifier and Type 方法 描述
      void DropShadow.setColor​(Color value)
      设置属性颜色的值。
      void InnerShadow.setColor​(Color value)
      设置属性颜色的值。
      void Light.setColor​(Color value)
      设置属性颜色的值。
      void Shadow.setColor​(Color value)
      设置属性颜色的值。
      Constructors in javafx.scene.effect with parameters of type Color
      Constructor 描述
      Distant​(double azimuth, double elevation, Color color)
      创建一个新的具有指定方位角，高程和颜色的远光的实例。
      DropShadow​(double radius, double offsetX, double offsetY, Color color)
      以指定的半径，offsetX，offsetY和颜色创建一个新的DropShadow实例。
      DropShadow​(double radius, Color color)
      创建一个具有指定半径和颜色的DropShadow的新实例。
      DropShadow​(BlurType blurType, Color color, double radius, double spread, double offsetX, double offsetY)
      使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的DropShadow实例。
      InnerShadow​(double radius, double offsetX, double offsetY, Color color)
      创建一个新的具有指定半径，offsetX，offsetY和color的InnerShadow实例。
      InnerShadow​(double radius, Color color)
      创建一个新的具有指定半径和颜色的InnerShadow实例。
      InnerShadow​(BlurType blurType, Color color, double radius, double choke, double offsetX, double offsetY)
      使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的InnerShadow实例。
      Point​(double x, double y, double z, Color color)
      用指定的x，y，x和color创建一个新的点光实例。
      Shadow​(double radius, Color color)
      用指定的半径和颜色创建一个新的Shadow实例。
      Shadow​(BlurType blurType, Color color, double radius)
      用指定的blurType，color，radius创建一个新的Shadow实例。
      Spot​(double x, double y, double z, double specularExponent, Color color)
      使用指定的x，y，z，specularExponent和color创建一个新的Spotlight实例。

    • Uses of Color in javafx.scene.image

      Methods in javafx.scene.image that return Color
      Modifier and Type 方法 描述
      Color PixelReader.getColor​(int x, int y)
      从表面的指定坐标读取像素的颜色，并将该值作为Color对象返回。
      Methods in javafx.scene.image with parameters of type Color
      Modifier and Type 方法 描述
      void PixelWriter.setColor​(int x, int y, Color c)
      将Color的像素数据存储到表面的指定坐标。

    • Uses of Color in javafx.scene.paint

      Fields in javafx.scene.paint declared as Color
      Modifier and Type Field 描述
      static Color Color.ALICEBLUE
      颜色为蓝绿色，RGB值为＃F0F8FF
      static Color Color.ANTIQUEWHITE
      颜色古色古香的白色，RGB值为＃FAEBD7
      static Color Color.AQUA
      颜色水彩，RGB值为＃00FFFF
      static Color Color.AQUAMARINE
      RGB值为＃7FFFD4的彩色海蓝宝石
      static Color Color.AZURE
      RGB值为＃F0FFFF的颜色天蓝色
      static Color Color.BEIGE
      颜色米色，RGB值为＃F5F5DC
      static Color Color.BISQUE
      RGB值为＃FFE4C4的彩色色差
      static Color Color.BLACK
      颜色为黑色，RGB值为＃000000
      static Color Color.BLANCHEDALMOND
      颜色变白的杏仁，RGB值为#FFEBCD
      static Color Color.BLUE
      颜色蓝色，RGB值为＃0000FF
      static Color Color.BLUEVIOLET
      RGB值为＃8A2BE2的蓝色紫色
      static Color Color.BROWN
      颜色棕色，RGB值为＃A52A2A
      static Color Color.BURLYWOOD
      颜色粗糙的木材，RGB值为＃DEB887
      static Color Color.CADETBLUE
      颜色学员蓝色，RGB值为＃5F9EA0
      static Color Color.CHARTREUSE
      RGB值为＃7FFF00的颜色表格
      static Color Color.CHOCOLATE
      颜色巧克力，RGB值为＃D2691E
      static Color Color.CORAL
      颜色珊瑚，RGB值为＃FF7F50
      static Color Color.CORNFLOWERBLUE
      颜色矢车菊蓝色，RGB值为＃6495ED
      static Color Color.CORNSILK
      具有RGB值为＃FFF8DC的颜色cornsilk
      static Color Color.CRIMSON
      颜色深红色，RGB值为＃DC143C
      static Color Color.CYAN
      颜色青色，RGB值为＃00FFFF
      static Color Color.DARKBLUE
      颜色深蓝色，RGB值为＃00008B
      static Color Color.DARKCYAN
      颜色深蓝色，RGB值为＃008B8B
      static Color Color.DARKGOLDENROD
      颜色深黄色，RGB值为＃B8860B
      static Color Color.DARKGRAY
      颜色深灰色，RGB值为＃A9A9A9
      static Color Color.DARKGREEN
      颜色深绿色，RGB值为＃006400
      static Color Color.DARKGREY
      颜色深灰色，RGB值为＃A9A9A9
      static Color Color.DARKKHAKI
      颜色深色卡其色，RGB值为＃BDB76B
      static Color Color.DARKMAGENTA
      RGB值为＃8B008B的深色洋红色
      static Color Color.DARKOLIVEGREEN
      颜色深绿橄榄绿，RGB值为＃556B2F
      static Color Color.DARKORANGE
      颜色深橙色，RGB值为＃FF8C00
      static Color Color.DARKORCHID
      颜色深蓝色，RGB值为＃9932CC
      static Color Color.DARKRED
      颜色深红色，RGB值为＃8B0000
      static Color Color.DARKSALMON
      颜色深色鲑鱼，RGB值为＃E9967A
      static Color Color.DARKSEAGREEN
      颜色深绿色，RGB值为＃8FBC8F
      static Color Color.DARKSLATEBLUE
      颜色深蓝色，RGB值为＃483D8B
      static Color Color.DARKSLATEGRAY
      颜色深灰色，RGB值为＃2F4F4F
      static Color Color.DARKSLATEGREY
      颜色深灰色，RGB值为＃2F4F4F
      static Color Color.DARKTURQUOISE
      颜色深蓝绿色，RGB值为＃00CED1
      static Color Color.DARKVIOLET
      颜色深紫色，RGB值为＃9400D3
      static Color Color.DEEPPINK
      颜色深粉红色，RGB值为＃FF1493
      static Color Color.DEEPSKYBLUE
      颜色深蓝色，RGB值为＃00BFFF
      static Color Color.DIMGRAY
      颜色变暗，RGB值为＃696969
      static Color Color.DIMGREY
      颜色变暗，RGB值为＃696969
      static Color Color.DODGERBLUE
      颜色闪烁蓝色，RGB值为＃1E90FF
      static Color Color.FIREBRICK
      颜色耐火砖，RGB值为＃B22222
      static Color Color.FLORALWHITE
      颜色花白色，RGB值为＃FFFAF0
      static Color Color.FORESTGREEN
      颜色森林绿色，RGB值为＃228B22
      static Color Color.FUCHSIA
      颜色紫红色，RGB值为＃FF00FF
      static Color Color.GAINSBORO
      RGB值为#DCDCDC的彩色增益
      static Color Color.GHOSTWHITE
      颜色为Ghost的白色，RGB值为＃F8F8FF
      static Color Color.GOLD
      彩色金色，RGB值为＃FFD700
      static Color Color.GOLDENROD
      颜色金色，RGB值为＃DAA520
      static Color Color.GRAY
      颜色为灰色，RGB值为＃808080
      static Color Color.GREEN
      颜色绿色，RGB值为＃008000
      static Color Color.GREENYELLOW
      颜色为绿色黄色，RGB值为＃ADFF2F
      static Color Color.GREY
      颜色为灰色，RGB值为＃808080
      static Color Color.HONEYDEW
      彩色蜜汁，RGB值为＃F0FFF0
      static Color Color.HOTPINK
      颜色热粉红色，RGB值为＃FF69B4
      static Color Color.INDIANRED
      彩色印度红色，RGB值为＃CD5C5C
      static Color Color.INDIGO
      RGB值为＃4B0082的彩色靛蓝
      static Color Color.IVORY
      颜色象牙，RGB值为＃FFFFF0
      static Color Color.KHAKI
      颜色卡其色，RGB值为＃F0E68C
      static Color Color.LAVENDER
      彩色薰衣草，RGB值为＃E6E6FA
      static Color Color.LAVENDERBLUSH
      颜色薰衣草腮红，RGB值为＃FFF0F5
      static Color Color.LAWNGREEN
      颜色草坪绿色，RGB值为＃7CFC00
      static Color Color.LEMONCHIFFON
      颜色柠檬雪纺，RGB值为#FFFACD
      static Color Color.LIGHTBLUE
      颜色浅蓝色，RGB值为＃ADD8E6
      static Color Color.LIGHTCORAL
      彩色珊瑚，RGB值为＃F08080
      static Color Color.LIGHTCYAN
      颜色浅蓝色，RGB值为＃E0FFFF
      static Color Color.LIGHTGOLDENRODYELLOW
      颜色浅黄色，RGB值为#FAFAD2
      static Color Color.LIGHTGRAY
      颜色浅灰色，RGB值为＃D3D3D3
      static Color Color.LIGHTGREEN
      颜色浅绿色，RGB值为＃90EE90
      static Color Color.LIGHTGREY
      颜色浅灰色，RGB值为＃D3D3D3
      static Color Color.LIGHTPINK
      颜色浅粉红色，RGB值为＃FFB6C1
      static Color Color.LIGHTSALMON
      RGB值为＃FFA07A的彩色三文鱼
      static Color Color.LIGHTSEAGREEN
      颜色浅绿色，RGB值为＃20B2AA
      static Color Color.LIGHTSKYBLUE
      彩色天空蓝色，RGB值为＃87CEFA
      static Color Color.LIGHTSLATEGRAY
      颜色浅灰色，RGB值为＃778899
      static Color Color.LIGHTSLATEGREY
      颜色浅灰色，RGB值为＃778899
      static Color Color.LIGHTSTEELBLUE
      颜色浅蓝色，RGB值为＃B0C4DE
      static Color Color.LIGHTYELLOW
      颜色浅黄色，RGB值为＃FFFFE0
      static Color Color.LIME
      RGB灰度值为＃00FF00
      static Color Color.LIMEGREEN
      灰绿色，RGB值为＃32CD32
      static Color Color.LINEN
      颜色亚麻布，RGB值为#FAF0E6
      static Color Color.MAGENTA
      颜色洋红色，RGB值为＃FF00FF
      static Color Color.MAROON
      颜色栗色，RGB值为＃800000
      static Color Color.MEDIUMAQUAMARINE
      彩色介质海蓝宝石，RGB值为＃66CDAA
      static Color Color.MEDIUMBLUE
      颜色中等蓝色，RGB值为＃0000CD
      static Color Color.MEDIUMORCHID
      颜色中等兰花，RGB值为＃BA55D3
      static Color Color.MEDIUMPURPLE
      颜色中等紫色，RGB值为＃9370DB
      static Color Color.MEDIUMSEAGREEN
      彩色中型海绿，RGB值为＃3CB371
      static Color Color.MEDIUMSLATEBLUE
      彩色介质为蓝色，RGB值为＃7B68EE
      static Color Color.MEDIUMSPRINGGREEN
      彩色介质弹簧绿色，RGB值为＃00FA9A
      static Color Color.MEDIUMTURQUOISE
      颜色介质绿松石，RGB值为＃48D1CC
      static Color Color.MEDIUMVIOLETRED
      颜色中等紫色，RGB值为＃C71585
      static Color Color.MIDNIGHTBLUE
      颜色为午夜蓝色，RGB值为＃191970
      static Color Color.MINTCREAM
      颜色薄荷奶油，RGB值为＃F5FFFA
      static Color Color.MISTYROSE
      颜色朦胧，RGB值为＃FFE4E1
      static Color Color.MOCCASIN
      颜色莫卡辛，RGB值为＃FFE4B5
      static Color Color.NAVAJOWHITE
      颜色navajo白色，RGB值为#FFDEAD
      static Color Color.NAVY
      RGB值为＃000080的彩色海军
      static Color Color.OLDLACE
      颜色旧花边，RGB值为＃FDF5E6
      static Color Color.OLIVE
      颜色橄榄，RGB值为＃808000
      static Color Color.OLIVEDRAB
      彩色橄榄色，RGB值为＃6B8E23
      static Color Color.ORANGE
      颜色为橙色，RGB值为＃FFA500
      static Color Color.ORANGERED
      颜色橙红色，RGB值为＃FF4500
      static Color Color.ORCHID
      颜色兰花，RGB值为＃DA70D6
      static Color Color.PALEGOLDENROD
      颜色淡黄色，RGB值为＃EEE8AA
      static Color Color.PALEGREEN
      颜色淡绿色，RGB值为＃98FB98
      static Color Color.PALETURQUOISE
      颜色淡绿色，RGB值为#AFEEEE
      static Color Color.PALEVIOLETRED
      颜色为淡紫色，RGB值为＃DB7093
      static Color Color.PAPAYAWHIP
      颜色番木瓜鞭，RGB值为＃FFEFD5
      static Color Color.PEACHPUFF
      彩色桃红色，其值为＃FFDAB9
      static Color Color.PERU
      颜色为紫色，RGB值为＃CD853F
      static Color Color.PINK
      颜色粉红色，RGB值为＃FFC0CB
      static Color Color.PLUM
      颜色李子，RGB值为＃DDA0DD
      static Color Color.POWDERBLUE
      彩色蓝色，RGB值为＃B0E0E6
      static Color Color.PURPLE
      颜色为紫色，RGB值为＃800080
      static Color Color.RED
      颜色红色，RGB值为＃FF0000
      static Color Color.ROSYBROWN
      颜色玫瑰色棕色，RGB值为＃BC8F8F
      static Color Color.ROYALBLUE
      颜色为皇家蓝色，RGB值为＃4169E1
      static Color Color.SADDLEBROWN
      颜色马鞍棕色，RGB值为＃8B4513
      static Color Color.SALMON
      颜色三文鱼的RGB值为＃FA8072
      static Color Color.SANDYBROWN
      颜色沙棕色，RGB值为＃F4A460
      static Color Color.SEAGREEN
      颜色海绿色，RGB值为＃2E8B57
      static Color Color.SEASHELL
      颜色海壳，RGB值为＃FFF5EE
      static Color Color.SIENNA
      颜色赭色，RGB值为＃A0522D
      static Color Color.SILVER
      颜色银，RGB值为＃C0C0C0
      static Color Color.SKYBLUE
      颜色天蓝色，RGB值为＃87CEEB
      static Color Color.SLATEBLUE
      颜色为蓝色，RGB值为＃6A5ACD
      static Color Color.SLATEGRAY
      颜色为灰色，RGB值为＃708090
      static Color Color.SLATEGREY
      颜色为灰色，RGB值为＃708090
      static Color Color.SNOW
      RGB值为#FFFAFA的彩色雪
      static Color Color.SPRINGGREEN
      颜色为绿色，RGB值为＃00FF7F
      static Color Color.STEELBLUE
      颜色钢蓝色，RGB值为＃4682B4
      static Color Color.TAN
      颜色为棕褐色，RGB值为＃D2B48C
      static Color Color.TEAL
      颜色深蓝色，RGB值为＃008080
      static Color Color.THISTLE
      颜色蓟，RGB值为＃D8BFD8
      static Color Color.TOMATO
      颜色番茄，RGB值为＃FF6347
      static Color Color.TRANSPARENT
      ARGB值为＃00000000的完全透明的颜色。
      static Color Color.TURQUOISE
      颜色绿松石，RGB值为＃40E0D0
      static Color Color.VIOLET
      颜色紫色，RGB值为＃EE82EE
      static Color Color.WHEAT
      RGB值为＃F5DEB3的彩色小麦
      static Color Color.WHITE
      颜色为白色，RGB值为#FFFFFF
      static Color Color.WHITESMOKE
      彩色白色烟雾，RGB值为＃F5F5F5
      static Color Color.YELLOW
      颜色为黄色，RGB值为＃FFFF00
      static Color Color.YELLOWGREEN
      颜色黄绿色，RGB值为＃9ACD32
      Methods in javafx.scene.paint that return Color
      Modifier and Type 方法 描述
      Color Color.brighter​()
      创建一个这种颜色更亮的新颜色。
      static Color Color.color​(double red, double green, double blue)
      使用指定的红色，绿色和蓝色值创建不透明的sRGB颜色，范围为 0.0-1.0 。
      static Color Color.color​(double red, double green, double blue, double opacity)
      使用指定的红色，绿色和蓝色值创建sRGB颜色，范围 0.0-1.0和给定的不透明度。
      Color Color.darker​()
      创建一个这种颜色较暗版本的新颜色。
      Color Color.deriveColor​(double hueShift, double saturationFactor, double brightnessFactor, double opacityFactor)
      基于这个 Color创建一个新的 Color ，其色调，饱和度，亮度和不透明度值被改变。
      Color Color.desaturate​()
      创建一个不太饱和的Color颜色的新颜色。
      Color Stop.getColor​()
      获取此偏移量的渐变颜色。
      Color PhongMaterial.getDiffuseColor​()
      获取属性diffuseColor的值。
      Color PhongMaterial.getSpecularColor​()
      获取属性specularColor的值。
      static Color Color.gray​(double gray)
      创建不透明的灰色。
      static Color Color.gray​(double gray, double opacity)
      创建灰色。
      static Color Color.grayRgb​(int gray)
      这是 rgb(gray, gray, gray)的快捷方式。
      static Color Color.grayRgb​(int gray, double opacity)
      这是 rgb(gray, gray, gray, opacity)的快捷方式。
      Color Color.grayscale​()
      创建一个与此颜色相当的灰度等级的新颜色。
      static Color Color.hsb​(double hue, double saturation, double brightness)
      根据HSB颜色模型中的指定值创建不透明的 Color 。
      static Color Color.hsb​(double hue, double saturation, double brightness, double opacity)
      根据HSB颜色模型中指定的值和给定的不透明度创建 Color 。
      Color Color.interpolate​(Color endValue, double t)
      该函数计算 0.0与 1.0之间的分数 t的内插值。
      Color Color.invert​()
      创建一个反映此颜色的新颜色。
      static Color Color.rgb​(int red, int green, int blue)
      使用指定的RGB值创建不透明的sRGB颜色，范围为 0-255 。
      static Color Color.rgb​(int red, int green, int blue, double opacity)
      使用指定的RGB值创建sRGB颜色，范围为 0-255 ，以及给定的不透明度。
      Color Color.saturate​()
      创建一个这个颜色的更饱和版本的新颜色。
      static Color Color.valueOf​(String value)
      从字符串表示形式创建颜色值。
      static Color Color.web​(String colorString)
      创建使用HTML或CSS属性字符串指定的RGB颜色。
      static Color Color.web​(String colorString, double opacity)
      创建使用HTML或CSS属性字符串指定的RGB颜色。
      Methods in javafx.scene.paint that return types with arguments of type Color
      Modifier and Type 方法 描述
      ObjectProperty<Color> PhongMaterial.diffuseColorProperty​()
      这个漫反射的颜色 PhongMaterial 。
      ObjectProperty<Color> PhongMaterial.specularColorProperty​()
      这个镜面颜色是 PhongMaterial 。
      Methods in javafx.scene.paint with parameters of type Color
      Modifier and Type 方法 描述
      Color Color.interpolate​(Color endValue, double t)
      该函数计算 0.0和 1.0之间的分数 t的内插值。
      void PhongMaterial.setDiffuseColor​(Color value)
      设置属性diffuseColor的值。
      void PhongMaterial.setSpecularColor​(Color value)
      设置属性specularColor的值。
      Constructors in javafx.scene.paint with parameters of type Color
      Constructor 描述
      PhongMaterial​(Color diffuseColor)
      使用指定的颜色为其 diffuseColor属性创建一个新的实例 PhongMaterial类。
      PhongMaterial​(Color diffuseColor, Image diffuseMap, Image specularMap, Image bumpMap, Image selfIlluminationMap)
      使用指定的颜色和图像为其 diffuseColor属性创建一个新的实例 PhongMaterial类。
      Stop​(double offset, Color color)
      创建一个新的Stop实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.paint.CycleMethod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.paint.CycleMethod

  • Packages that use CycleMethod
    软件包 描述
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

    • Uses of CycleMethod in javafx.scene.paint

      Methods in javafx.scene.paint that return CycleMethod
      Modifier and Type 方法 描述
      CycleMethod LinearGradient.getCycleMethod​()
      定义了下面的循环方法的被施加到 LinearGradient ： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。
      CycleMethod RadialGradient.getCycleMethod​()
      定义应用于 RadialGradient的循环方法。
      static CycleMethod CycleMethod.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CycleMethod[] CycleMethod.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in javafx.scene.paint with parameters of type CycleMethod
      Constructor 描述
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.paint.ImagePattern (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.paint.ImagePattern

No usage of javafx.scene.paint.ImagePattern
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.paint.LinearGradient (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.paint.LinearGradient

  • Packages that use LinearGradient
    软件包 描述
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

    • Uses of LinearGradient in javafx.scene.paint

      Methods in javafx.scene.paint that return LinearGradient
      Modifier and Type 方法 描述
      static LinearGradient LinearGradient.valueOf​(String value)
      从字符串表示形成线性渐变值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.paint.Material (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.paint.Material

  • Packages that use Material
    软件包 描述
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of Material in javafx.scene.paint

      Subclasses of Material in javafx.scene.paint
      Modifier and Type Class 描述
      class  PhongMaterial
      PhongMaterial类提供了代表Phong阴影材料的属性的定义。

    • Uses of Material in javafx.scene.shape

      Methods in javafx.scene.shape that return Material
      Modifier and Type 方法 描述
      Material Shape3D.getMaterial​()
      获取物业资料的价值。
      Methods in javafx.scene.shape that return types with arguments of type Material
      Modifier and Type 方法 描述
      ObjectProperty<Material> Shape3D.materialProperty​()
      定义材料 Shape3D 。
      Methods in javafx.scene.shape with parameters of type Material
      Modifier and Type 方法 描述
      void Shape3D.setMaterial​(Material value)
      设置属性材质的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.paint.Paint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.paint.Paint

  • Packages that use Paint
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of Paint in javafx.css

      Methods in javafx.css that return types with arguments of type Paint
      Modifier and Type 方法 描述
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function)
      使用Color.BLACK的初始值创建一个CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Paint>并继承标志。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function)
      创建一个StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建一个具有初始值的StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Paint>并继承标志。
      static StyleConverter<ParsedValue<?,Paint>,Paint> StyleConverter.getPaintConverter​()
      返回一个 StyleConverter ，其转换解析后的表示 Paint为 Paint 。
      static StyleConverter<ParsedValue<?,Paint>,Paint> StyleConverter.getPaintConverter​()
      返回一个 StyleConverter ，其转换解析后的表示 Paint为 Paint 。
      Methods in javafx.css with parameters of type Paint
      Modifier and Type 方法 描述
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Paint>并继承标志。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建一个具有初始值的StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Paint>并继承标志。
      Method parameters in javafx.css with type arguments of type Paint
      Modifier and Type 方法 描述
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function)
      使用Color.BLACK的初始值创建一个CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。
      CssMetaData<S,Paint> StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      用初始值创建一个CssMetaData <S，Paint>并继承标志。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function)
      创建一个StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue)
      创建一个具有初始值的StyleableProperty <Paint>。
      StyleableProperty<Paint> StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Paint>并继承标志。

    • Uses of Paint in javafx.css.converter

      Methods in javafx.css.converter that return Paint
      Modifier and Type | 方法 | 描述
      Paint | PaintConverter.convert​(ParsedValue<ParsedValue<?,Paint>,Paint> value, Font font)
      Paint | PaintConverter.ImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.LinearGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.RadialGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.RepeatingImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint[] | PaintConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<?,Paint>[],Paint[]> value, Font font)
      Methods in javafx.css.converter that return types with arguments of type Paint
      Modifier and Type | 方法 | 描述
      static StyleConverter<ParsedValue<?,Paint>,Paint> | PaintConverter.getInstance​()
      static StyleConverter<ParsedValue<?,Paint>,Paint> | PaintConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Paint
      Modifier and Type | 方法 | 描述
      Paint | PaintConverter.convert​(ParsedValue<ParsedValue<?,Paint>,Paint> value, Font font)
      Paint | PaintConverter.convert​(ParsedValue<ParsedValue<?,Paint>,Paint> value, Font font)
      Paint | PaintConverter.ImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.LinearGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.RadialGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.RepeatingImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)

    • Uses of Paint in javafx.scene

      Methods in javafx.scene that return Paint
      Modifier and Type 方法 描述
      Paint Scene.getFill​()
      获取属性填充的值。
      Paint SnapshotParameters.getFill​()
      获取当前填充。
      Paint SubScene.getFill​()
      获取属性填充的值。
      Methods in javafx.scene that return types with arguments of type Paint
      Modifier and Type 方法 描述
      ObjectProperty<Paint> Scene.fillProperty​()
      定义此 Scene的背景填充。
      ObjectProperty<Paint> SubScene.fillProperty​()
      定义此 SubScene的背景填充。
      Methods in javafx.scene with parameters of type Paint
      Modifier and Type 方法 描述
      void Scene.setFill​(Paint value)
      设置属性填充的值。
      void SnapshotParameters.setFill​(Paint fill)
      将填充设置为指定的值。
      void SubScene.setFill​(Paint value)
      设置属性填充的值。
      Constructors in javafx.scene with parameters of type Paint
      Constructor 描述
      Scene​(Parent root, double width, double height, Paint fill)
      创建具有特定大小和填充的特定根节点的场景。
      Scene​(Parent root, Paint fill)
      为具有填充的特定根节点创建场景。

    • Uses of Paint in javafx.scene.canvas

      Methods in javafx.scene.canvas that return Paint
      Modifier and Type 方法 描述
      Paint GraphicsContext.getFill​()
      获取当前的填充颜色属性。
      Paint GraphicsContext.getStroke​()
      获取当前行程。
      Methods in javafx.scene.canvas with parameters of type Paint
      Modifier and Type 方法 描述
      void GraphicsContext.setFill​(Paint p)
      设置当前填充绘图属性。
      void GraphicsContext.setStroke​(Paint p)
      设置当前笔画paint属性。

    • Uses of Paint in javafx.scene.chart

      Methods in javafx.scene.chart that return Paint
      Modifier and Type 方法 描述
      Paint Axis.getTickLabelFill​()
      获取属性tickLabelFill的值。
      Methods in javafx.scene.chart that return types with arguments of type Paint
      Modifier and Type 方法 描述
      ObjectProperty<Paint> Axis.tickLabelFillProperty​()
      填写所有刻度标签
      Methods in javafx.scene.chart with parameters of type Paint
      Modifier and Type 方法 描述
      void Axis.setTickLabelFill​(Paint value)
      设置属性tickLabelFill的值。

    • Uses of Paint in javafx.scene.control

      Methods in javafx.scene.control that return Paint
      Modifier and Type 方法 描述
      Paint Labeled.getTextFill​()
      获取属性textFill的值。
      Methods in javafx.scene.control that return types with arguments of type Paint
      Modifier and Type 方法 描述
      ObjectProperty<Paint> Labeled.textFillProperty​()
      Paint用于填写文字。
      Methods in javafx.scene.control with parameters of type Paint
      Modifier and Type 方法 描述
      void Labeled.setTextFill​(Paint value)
      设置属性textFill的值。

    • Uses of Paint in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return Paint
      Modifier and Type 方法 描述
      protected Paint TextInputControlSkin.getHighlightFill​()
      获取属性highlightFill的值。
      protected Paint TextInputControlSkin.getHighlightTextFill​()
      获取属性highlightTextFill的值。
      protected Paint TextInputControlSkin.getPromptTextFill​()
      获取属性promptTextFill的值。
      protected Paint TextInputControlSkin.getTextFill​()
      获取属性textFill的值。
      Methods in javafx.scene.control.skin that return types with arguments of type Paint
      Modifier and Type | 方法 | 描述
      protected ObjectProperty<Paint> TextInputControlSkin.highlightFillProperty​()
      突出显示时用于文本的填充。
      protected ObjectProperty<Paint> | TextInputControlSkin.highlightTextFillProperty​()
      protected ObjectProperty<Paint> | TextInputControlSkin.promptTextFillProperty​()
      protected ObjectProperty<Paint> TextInputControlSkin.textFillProperty​()
      在正常条件下用于文本的填充
      Methods in javafx.scene.control.skin with parameters of type Paint
      Modifier and Type 方法 描述
      protected void TextInputControlSkin.setHighlightFill​(Paint value)
      填充 Paint用于所选文本的背景。
      protected void TextInputControlSkin.setHighlightTextFill​(Paint value)
      填充 Paint用于所选文本的前景。
      protected void TextInputControlSkin.setPromptTextFill​(Paint value)
      填充 Paint用于前景提示文本颜色。
      protected void TextInputControlSkin.setTextFill​(Paint value)
      填充 Paint用于前景文字颜色。

    • Uses of Paint in javafx.scene.effect

      Methods in javafx.scene.effect that return Paint
      Modifier and Type 方法 描述
      Paint ColorInput.getPaint​()
      获取属性paint的值。
      Methods in javafx.scene.effect that return types with arguments of type Paint
      Modifier and Type 方法 描述
      ObjectProperty<Paint> ColorInput.paintProperty​()
      Paint用于洪水地区。
      Methods in javafx.scene.effect with parameters of type Paint
      Modifier and Type 方法 描述
      void ColorInput.setPaint​(Paint value)
      设置属性paint的值。
      Constructors in javafx.scene.effect with parameters of type Paint
      Constructor 描述
      ColorInput​(double x, double y, double width, double height, Paint paint)
      使用指定的x，y，width，height和paint创建一个ColorInput的新实例。

    • Uses of Paint in javafx.scene.layout

      Methods in javafx.scene.layout that return Paint
      Modifier and Type 方法 描述
      Paint BorderStroke.getBottomStroke​()
      定义此边框底部的填充。
      Paint BackgroundFill.getFill​()
      油漆用于填充Region的背景。
      Paint BorderStroke.getLeftStroke​()
      定义此边框左侧的填充。
      Paint BorderStroke.getRightStroke​()
      定义此边框右侧的填充。
      Paint BorderStroke.getTopStroke​()
      定义此边框顶部的填充。
      Constructors in javafx.scene.layout with parameters of type Paint
      Constructor 描述
      BackgroundFill​(Paint fill, CornerRadii radii, Insets insets)
      使用指定的填充，半径和插入创建一个新的BackgroundFill。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths)
      创建一个新的BorderStroke。
      BorderStroke​(Paint stroke, BorderStrokeStyle style, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke。
      BorderStroke​(Paint topStroke, Paint rightStroke, Paint bottomStroke, Paint leftStroke, BorderStrokeStyle topStyle, BorderStrokeStyle rightStyle, BorderStrokeStyle bottomStyle, BorderStrokeStyle leftStyle, CornerRadii radii, BorderWidths widths, Insets insets)
      创建一个新的BorderStroke，指定所有构造参数。

    • Uses of Paint in javafx.scene.paint

      Subclasses of Paint in javafx.scene.paint
      Modifier and Type Class 描述
      class  Color
      Color类用于将颜色封装在默认的sRGB颜色空间中。
      class  ImagePattern
      ImagePattern类填充具有图像模式的形状。
      class  LinearGradient
      LinearGradient类用线性颜色渐变模式填充形状。
      class  RadialGradient
      RadialGradient类提供了一种填充圆形径向颜色渐变图案的形状的方法。
      Methods in javafx.scene.paint that return Paint
      Modifier and Type 方法 描述
      static Paint Paint.valueOf​(String value)
      从字符串表示形式创建一个绘制值。

    • Uses of Paint in javafx.scene.shape

      Methods in javafx.scene.shape that return Paint
      Modifier and Type 方法 描述
      Paint Shape.getFill​()
      获取属性填充的值。
      Paint Shape.getStroke​()
      获取属性笔画的值。
      Methods in javafx.scene.shape that return types with arguments of type Paint
      Modifier and Type 方法 描述
      ObjectProperty<Paint> Shape.fillProperty​()
      使用 Paint上下文的设置定义填充 Shape内部的参数。
      ObjectProperty<Paint> Shape.strokeProperty​()
      使用指定的 Paint的设置定义围绕 Shape轮廓绘制的笔触的参数。
      Methods in javafx.scene.shape with parameters of type Paint
      Modifier and Type 方法 描述
      void Shape.setFill​(Paint value)
      设置属性填充的值。
      void Shape.setStroke​(Paint value)
      设置属性笔画的值。
      Constructors in javafx.scene.shape with parameters of type Paint
      Constructor 描述
      Circle​(double centerX, double centerY, double radius, Paint fill)
      创建一个新的具有指定位置，半径和填充的Circle实例。
      Circle​(double radius, Paint fill)
      创建一个新的具有指定半径的Circle实例并填充。
      Rectangle​(double width, double height, Paint fill)
      用给定的大小和填充创建一个新的Rectangle实例。

    • Uses of Paint in javafx.scene.text

      Methods in javafx.scene.text that return Paint
      Modifier and Type 方法 描述
      Paint Text.getSelectionFill​()
      获取属性selectionFill的值。
      Methods in javafx.scene.text that return types with arguments of type Paint
      Modifier and Type 方法 描述
      ObjectProperty<Paint> Text.selectionFillProperty​()
      所选文字的填充颜色。
      Methods in javafx.scene.text with parameters of type Paint
      Modifier and Type 方法 描述
      void Text.setSelectionFill​(Paint paint)
      Sets the value of the property selectionFill.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.paint.PhongMaterial (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.paint.PhongMaterial

No usage of javafx.scene.paint.PhongMaterial
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.paint.RadialGradient (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.paint.RadialGradient

  • Packages that use RadialGradient
    软件包 描述
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

    • Uses of RadialGradient in javafx.scene.paint

      Methods in javafx.scene.paint that return RadialGradient
      Modifier and Type 方法 描述
      static RadialGradient RadialGradient.valueOf​(String value)
      从字符串表示形成径向渐变值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.paint.Stop (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.paint.Stop

  • Packages that use Stop
    软件包 描述
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

    • Uses of Stop in javafx.css.converter

      Methods in javafx.css.converter that return Stop
      Modifier and Type | 方法 | 描述
      Stop | StopConverter.convert​(ParsedValue<ParsedValue[],Stop> value, Font font)
      Method parameters in javafx.css.converter with type arguments of type Stop
      Modifier and Type | 方法 | 描述
      Stop | StopConverter.convert​(ParsedValue<ParsedValue[],Stop> value, Font font)

    • Uses of Stop in javafx.scene.paint

      Methods in javafx.scene.paint that return types with arguments of type Stop
      Modifier and Type 方法 描述
      List<Stop> LinearGradient.getStops​()
      2个或多个 Stop值的序列，指定如何沿渐变分布颜色。
      List<Stop> RadialGradient.getStops​()
      2个或多个 Stop值的序列，用于指定如何沿渐变分布颜色。
      Constructors in javafx.scene.paint with parameters of type Stop
      Constructor 描述
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的LinearGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, Stop... stops)
      创建一个新的RadialGradient实例。
      Constructor parameters in javafx.scene.paint with type arguments of type Stop
      Constructor 描述
      LinearGradient​(double startX, double startY, double endX, double endY, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的LinearGradient实例。
      RadialGradient​(double focusAngle, double focusDistance, double centerX, double centerY, double radius, boolean proportional, CycleMethod cycleMethod, List<Stop> stops)
      创建一个新的RadialGradient实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Arc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Arc

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.Arc
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Arc
extends Shape
    所述Arc类表示2D弧对象，由中心点限定的，起始角度（度），角度范围（以度数表示的弧的长度），和一弧型（ ArcType.OPEN ， ArcType.CHORD ，或ArcType.ROUND ）。

    示例用法：以下代码创建以50,50为中心的圆弧，半径为25，并从角度45延伸到角度315（270度长），并且是圆形的。

      import javafx.scene.shape.*;

Arc arc = new Arc();
arc.setCenterX(50.0f);
arc.setCenterY(50.0f);
arc.setRadiusX(25.0f);
arc.setRadiusY(25.0f);
arc.setStartAngle(45.0f);
arc.setLength(270.0f);
arc.setType(ArcType.ROUND);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty centerX
      定义圆弧中心点的X坐标。
      DoubleProperty centerY
      定义圆弧中心点的Y坐标。
      DoubleProperty length
      以弧度定义弧的角度范围。
      DoubleProperty radiusX
      定义整个椭圆的整体宽度（水平半径），其中该弧是部分截面。
      DoubleProperty radiusY
      定义整个椭圆的整体高度（垂直半径），其中该弧是部分截面。
      DoubleProperty startAngle
      以弧度定义圆弧的起始角度。
      ObjectProperty<ArcType> type
      定义闭合类型弧： ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND 。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Arc​()
      创建一个空的实例Arc。
      Arc​(double centerX, double centerY, double radiusX, double radiusY, double startAngle, double length)
      创建一个新的Arc实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty centerXProperty​()
      定义圆弧中心点的X坐标。
      DoubleProperty centerYProperty​()
      定义圆弧中心点的Y坐标。
      double getCenterX​()
      获取属性centerX的值。
      double getCenterY​()
      获取属性centerY的值。
      double getLength​()
      获取属性长度的值。
      double getRadiusX​()
      获取属性radiusX的值。
      double getRadiusY​()
      获取属性radiusY的值。
      double getStartAngle​()
      获取属性startAngle的值。
      ArcType getType​()
      获取属性类型的值。
      DoubleProperty lengthProperty​()
      以弧度定义弧的角度范围。
      DoubleProperty radiusXProperty​()
      定义整个椭圆的整体宽度（水平半径），其中该弧是部分截面。
      DoubleProperty radiusYProperty​()
      定义整个椭圆的整体高度（垂直半径），其中该弧是部分截面。
      void setCenterX​(double value)
      设置属性centerX的值。
      void setCenterY​(double value)
      设置属性centerY的值。
      void setLength​(double value)
      设置属性长度的值。
      void setRadiusX​(double value)
      设置属性radiusX的值。
      void setRadiusY​(double value)
      设置属性radiusY的值。
      void setStartAngle​(double value)
      设置属性startAngle的值。
      void setType​(ArcType value)
      设置属性类型的值。
      DoubleProperty startAngleProperty​()
      以弧度定义圆弧的起始角度。
      String toString​()
      返回此 Arc对象的字符串表示形式。
      ObjectProperty<ArcType> typeProperty​()
      定义闭合类型弧： ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND 。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • centerX

        public final DoubleProperty centerXProperty
        定义圆弧中心点的X坐标。
        Default value:
        0.0
        另请参见：
        getCenterX() ， setCenterX(double)

      • centerY

        public final DoubleProperty centerYProperty
        定义圆弧中心点的Y坐标。
        Default value:
        0.0
        另请参见：
        getCenterY() ， setCenterY(double)

      • radiusX

        public final DoubleProperty radiusXProperty
        定义整个椭圆的整体宽度（水平半径），其中该弧是部分截面。
        Default value:
        0.0
        另请参见：
        getRadiusX() ， setRadiusX(double)

      • radiusY

        public final DoubleProperty radiusYProperty
        定义整个椭圆的整体高度（垂直半径），其中该弧是部分截面。
        Default value:
        0.0
        另请参见：
        getRadiusY() ， setRadiusY(double)

      • startAngle

        public final DoubleProperty startAngleProperty
        以弧度定义圆弧的起始角度。
        Default value:
        0.0
        另请参见：
        getStartAngle() ， setStartAngle(double)

      • length

        public final DoubleProperty lengthProperty
        以弧度定义弧的角度范围。
        Default value:
        0.0
        另请参见：
        getLength() ， setLength(double)

      • type

        public final ObjectProperty<ArcType> typeProperty
        定义闭合类型弧： ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND 。
        Default value:
        打开
        另请参见：
        getType() ， setType(ArcType)

    • 构造方法详细信息

      • Arc

        public Arc​()
        创建一个空的实例Arc。

      • Arc

        public Arc​(double centerX,
           double centerY,
           double radiusX,
           double radiusY,
           double startAngle,
           double length)
        创建一个新的Arc实例。
        参数
        centerX - 圆弧中心点的X坐标
        centerY - 圆弧中心点的Y坐标
        radiusX - 整个椭圆的整体宽度（水平半径），其圆弧为部分截面
        radiusY - 整个椭圆的整体高度（垂直半径），其圆弧为部分剖面
        startAngle - 圆弧的起始角度，以度为单位
        length - 弧度的角度范围

    • 方法详细信息

      • setCenterX

        public final void setCenterX​(double value)
        设置属性centerX的值。
        Property description:
        定义圆弧中心点的X坐标。
        Default value:
        0.0

      • getCenterX

        public final double getCenterX​()
        获取属性centerX的值。
        Property description:
        定义圆弧中心点的X坐标。
        Default value:
        0.0

      • centerXProperty

        public final DoubleProperty centerXProperty​()
        定义圆弧中心点的X坐标。
        Default value:
        0.0
        另请参见：
        getCenterX() ， setCenterX(double)

      • setCenterY

        public final void setCenterY​(double value)
        设置属性centerY的值。
        Property description:
        定义圆弧中心点的Y坐标。
        Default value:
        0.0

      • getCenterY

        public final double getCenterY​()
        获取属性centerY的值。
        Property description:
        定义圆弧中心点的Y坐标。
        Default value:
        0.0

      • centerYProperty

        public final DoubleProperty centerYProperty​()
        定义圆弧中心点的Y坐标。
        Default value:
        0.0
        另请参见：
        getCenterY() ， setCenterY(double)

      • setRadiusX

        public final void setRadiusX​(double value)
        设置属性radiusX的值。
        Property description:
        定义整个椭圆的整体宽度（水平半径），其中该弧是部分截面。
        Default value:
        0.0

      • getRadiusX

        public final double getRadiusX​()
        获取属性radiusX的值。
        Property description:
        定义整个椭圆的整体宽度（水平半径），其中该弧是部分截面。
        Default value:
        0.0

      • radiusXProperty

        public final DoubleProperty radiusXProperty​()
        定义整个椭圆的整体宽度（水平半径），其中该弧是部分截面。
        Default value:
        0.0
        另请参见：
        getRadiusX() ， setRadiusX(double)

      • setRadiusY

        public final void setRadiusY​(double value)
        设置属性radiusY的值。
        Property description:
        定义整个椭圆的整体高度（垂直半径），其中该弧是部分截面。
        Default value:
        0.0

      • getRadiusY

        public final double getRadiusY​()
        获取属性radiusY的值。
        Property description:
        定义整个椭圆的整体高度（垂直半径），其中该弧是部分截面。
        Default value:
        0.0

      • radiusYProperty

        public final DoubleProperty radiusYProperty​()
        定义整个椭圆的整体高度（垂直半径），其中该弧是部分截面。
        Default value:
        0.0
        另请参见：
        getRadiusY() ， setRadiusY(double)

      • setStartAngle

        public final void setStartAngle​(double value)
        设置属性startAngle的值。
        Property description:
        以弧度定义圆弧的起始角度。
        Default value:
        0.0

      • getStartAngle

        public final double getStartAngle​()
        获取属性startAngle的值。
        Property description:
        以弧度定义圆弧的起始角度。
        Default value:
        0.0

      • startAngleProperty

        public final DoubleProperty startAngleProperty​()
        以弧度定义圆弧的起始角度。
        Default value:
        0.0
        另请参见：
        getStartAngle() ， setStartAngle(double)

      • setLength

        public final void setLength​(double value)
        设置属性长度的值。
        Property description:
        以弧度定义弧的角度范围。
        Default value:
        0.0

      • getLength

        public final double getLength​()
        获取属性长度的值。
        Property description:
        以弧度定义弧的角度范围。
        Default value:
        0.0

      • lengthProperty

        public final DoubleProperty lengthProperty​()
        以弧度定义弧的角度范围。
        Default value:
        0.0
        另请参见：
        getLength() ， setLength(double)

      • setType

        public final void setType​(ArcType value)
        设置属性类型的值。
        Property description:
        定义闭合类型弧： ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND 。
        Default value:
        打开

      • getType

        public final ArcType getType​()
        获取属性类型的值。
        Property description:
        定义闭合类型弧： ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND 。
        Default value:
        打开

      • typeProperty

        public final ObjectProperty<ArcType> typeProperty​()
        定义闭合类型弧： ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND 。
        Default value:
        打开
        另请参见：
        getType() ， setType(ArcType)

      • toString

        public String toString​()
        返回此 Arc对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这个 Arc对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ArcTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class ArcTo

  • java.lang.Object
    • javafx.scene.shape.PathElement
      • javafx.scene.shape.ArcTo

  • public class ArcTo
extends PathElement
    一个路径元素，它使用指定的半径从前一个坐标到指定的x和y坐标形成弧。

    有关路径元素的更多信息，请参阅Path和PathElement类。

    例：

      import javafx.scene.shape.*;

Path path = new Path();

MoveTo moveTo = new MoveTo();
moveTo.setX(0.0);
moveTo.setY(0.0);

ArcTo arcTo = new ArcTo();
arcTo.setX(50.0);
arcTo.setY(50.0);
arcTo.setRadiusX(50.0);
arcTo.setRadiusY(50.0);

path.getElements().add(moveTo);
path.getElements().add(arcTo);

    下radiusX radiusY和xAxisRotation参数： radiusX是全椭圆的水平半径，其圆弧为部分截面， radiusY为其垂直半径。 xAxisRotation以椭圆为xAxisRotation定义椭圆的旋转。

    在大多数情况下，从起点到给定的终点坐标有四个选择。 它们可以区分为largeArcFlag和sweepFlag参数。 largeArcFlag == true表示将绘制大于180度的弧。 sweepFlag == true意味着电弧将以正角方向绘制 - 即椭圆公式中的角度将从[fromX, fromY]增加到[x,y] 。 以下图像显示了此行为：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty largeArcFlag
      大弧标志。
      DoubleProperty radiusX
      用于电弧的水平半径。
      DoubleProperty radiusY
      用于电弧的垂直半径。
      BooleanProperty sweepFlag
      扫旗
      DoubleProperty XAxisRotation
      x轴旋转度。
      DoubleProperty x
      x坐标到弧。
      DoubleProperty y
      y坐标到弧。

      • Properties inherited from class javafx.scene.shape.PathElement

        absolute

    • 构造方法摘要

      构造方法
      Constructor 描述
      ArcTo​()
      创建一个空的ArcTo实例。
      ArcTo​(double radiusX, double radiusY, double xAxisRotation, double x, double y, boolean largeArcFlag, boolean sweepFlag)
      创建一个新的ArcTo实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getRadiusX​()
      获取属性radiusX的值。
      double getRadiusY​()
      获取属性radiusY的值。
      double getX​()
      获取属性x的值。
      double getXAxisRotation​()
      以度数获取x轴旋转。
      double getY​()
      获取属性y的值。
      boolean isLargeArcFlag​()
      获取属性largeArcFlag的值。
      boolean isSweepFlag​()
      获取属性sweepFlag的值。
      BooleanProperty largeArcFlagProperty​()
      大弧标志。
      DoubleProperty radiusXProperty​()
      用于电弧的水平半径。
      DoubleProperty radiusYProperty​()
      用于电弧的垂直半径。
      void setLargeArcFlag​(boolean value)
      设置属性largeArcFlag的值。
      void setRadiusX​(double value)
      设置属性radiusX的值。
      void setRadiusY​(double value)
      设置属性radiusY的值。
      void setSweepFlag​(boolean value)
      设置属性sweepFlag的值。
      void setX​(double value)
      设置属性x的值。
      void setXAxisRotation​(double value)
      以度为单位设置x轴旋转。
      void setY​(double value)
      设置属性y的值。
      BooleanProperty sweepFlagProperty​()
      扫旗
      String toString​()
      返回此 ArcTo对象的字符串表示形式。
      DoubleProperty XAxisRotationProperty​()
      x轴旋转度。
      DoubleProperty xProperty​()
      x坐标到弧。
      DoubleProperty yProperty​()
      y坐标到弧。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.PathElement

        absoluteProperty, isAbsolute, setAbsolute

    • Property Detail

      • radiusX

        public final DoubleProperty radiusXProperty
        用于电弧的水平半径。
        Default value:
        0.0
        另请参见：
        getRadiusX() ， setRadiusX(double)

      • radiusY

        public final DoubleProperty radiusYProperty
        用于电弧的垂直半径。
        Default value:
        0.0
        另请参见：
        getRadiusY() ， setRadiusY(double)

      • XAxisRotation

        public final DoubleProperty XAxisRotationProperty
        x轴旋转度。
        另请参见：
        getXAxisRotation() ， setXAxisRotation(double)

      • largeArcFlag

        public final BooleanProperty largeArcFlagProperty
        大弧标志。
        Default value:
        假
        另请参见：
        isLargeArcFlag() ， setLargeArcFlag(boolean)

      • sweepFlag

        public final BooleanProperty sweepFlagProperty
        扫旗
        Default value:
        假
        另请参见：
        isSweepFlag() ， setSweepFlag(boolean)

      • x

        public final DoubleProperty xProperty
        x坐标到弧。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        y坐标到弧。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

    • 构造方法详细信息

      • ArcTo

        public ArcTo​()
        创建一个空的ArcTo实例。

      • ArcTo

        public ArcTo​(double radiusX,
             double radiusY,
             double xAxisRotation,
             double x,
             double y,
             boolean largeArcFlag,
             boolean sweepFlag)
        创建一个新的ArcTo实例。
        参数
        radiusX - 电弧的水平半径
        radiusY - 圆弧的垂直半径
        xAxisRotation - 以度为单位的x轴旋转
        x - 电弧端点的水平位置
        y - 电弧终点的垂直位置
        largeArcFlag - 大arg标志：确定要使用的弧（大/小）
        sweepFlag - 扫描标志：确定要使用的弧（方向）

    • 方法详细信息

      • setRadiusX

        public final void setRadiusX​(double value)
        设置属性radiusX的值。
        Property description:
        用于电弧的水平半径。
        Default value:
        0.0

      • getRadiusX

        public final double getRadiusX​()
        获取属性radiusX的值。
        Property description:
        用于电弧的水平半径。
        Default value:
        0.0

      • radiusXProperty

        public final DoubleProperty radiusXProperty​()
        用于电弧的水平半径。
        Default value:
        0.0
        另请参见：
        getRadiusX() ， setRadiusX(double)

      • setRadiusY

        public final void setRadiusY​(double value)
        设置属性radiusY的值。
        Property description:
        用于电弧的垂直半径。
        Default value:
        0.0

      • getRadiusY

        public final double getRadiusY​()
        获取属性radiusY的值。
        Property description:
        用于电弧的垂直半径。
        Default value:
        0.0

      • radiusYProperty

        public final DoubleProperty radiusYProperty​()
        用于电弧的垂直半径。
        Default value:
        0.0
        另请参见：
        getRadiusY() ， setRadiusY(double)

      • setXAxisRotation

        public final void setXAxisRotation​(double value)
        以度为单位设置x轴旋转。
        参数
        value - 以度为单位的x轴旋转。

      • getXAxisRotation

        public final double getXAxisRotation​()
        以度数获取x轴旋转。
        结果
        x轴旋转度。

      • XAxisRotationProperty

        public final DoubleProperty XAxisRotationProperty​()
        x轴旋转度。
        另请参见：
        getXAxisRotation() ， setXAxisRotation(double)

      • setLargeArcFlag

        public final void setLargeArcFlag​(boolean value)
        设置属性largeArcFlag的值。
        Property description:
        大弧标志。
        Default value:
        假

      • isLargeArcFlag

        public final boolean isLargeArcFlag​()
        获取属性largeArcFlag的值。
        Property description:
        大弧标志。
        Default value:
        假

      • largeArcFlagProperty

        public final BooleanProperty largeArcFlagProperty​()
        大弧标志。
        Default value:
        假
        另请参见：
        isLargeArcFlag() ， setLargeArcFlag(boolean)

      • setSweepFlag

        public final void setSweepFlag​(boolean value)
        设置属性sweepFlag的值。
        Property description:
        扫旗
        Default value:
        假

      • isSweepFlag

        public final boolean isSweepFlag​()
        获取属性sweepFlag的值。
        Property description:
        扫旗
        Default value:
        假

      • sweepFlagProperty

        public final BooleanProperty sweepFlagProperty​()
        扫旗
        Default value:
        假
        另请参见：
        isSweepFlag() ， setSweepFlag(boolean)

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        x坐标到弧。
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        x坐标到弧。
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        x坐标到弧。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        y坐标到弧。
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        y坐标到弧。
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        y坐标到弧。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • toString

        public String toString​()
        返回此 ArcTo对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ArcTo对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ArcType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Enum ArcType

  • java.lang.Object
    • java.lang.Enum<ArcType>
      • javafx.scene.shape.ArcType
  • All Implemented Interfaces:
    Serializable ， Comparable<ArcType>

    public enum ArcType
extends Enum<ArcType>
    ArcType指定Arc对象的关闭类型。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CHORD
      通过从弧段开始绘制直线段到弧段的末端，关闭电弧的闭合类型。
      OPEN
      用于开弧的闭合类型，没有连接弧段两端的路段。
      ROUND
      通过将直线段从弧段开始到完全椭圆的中心并从该点到弧段的末端将闭合类型关闭。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ArcType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ArcType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • OPEN

        public static final ArcType OPEN
        用于开弧的闭合类型，没有连接弧段两端的路段。

      • CHORD

        public static final ArcType CHORD
        通过从弧段开始绘制直线段到弧段的末端，关闭电弧的闭合类型。

      • ROUND

        public static final ArcType ROUND
        通过将直线段从弧段开始到完全椭圆的中心并从该点到弧段的末端将闭合类型关闭。

    • 方法详细信息

      • values

        public static ArcType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ArcType c : ArcType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ArcType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Box (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Box

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape3D
        • javafx.scene.shape.Box
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Box
extends Shape3D
    Box类定义了具有指定大小的3维框。 A Box是用给定的深度，宽度和高度创建的3D几何图元。 它以起源为中心。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty depth
      定义Box的深度或Z尺寸。
      DoubleProperty height
      定义Box的高度或Y尺寸。
      DoubleProperty width
      定义Box的宽度或X尺寸。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape3D

        cullFace, drawMode, material

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double DEFAULT_SIZE
      创建一个尺寸为2×2的新实例 Box 。

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Box​()
      Box​(double width, double height, double depth)
      根据深度创建尺寸宽度为 Box的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty depthProperty​()
      定义Box的深度或Z尺寸。
      double getDepth​()
      获取属性深度的值。
      double getHeight​()
      获取属性高度的值。
      double getWidth​()
      获取属性宽度的值。
      DoubleProperty heightProperty​()
      定义Box的高度或Y尺寸。
      void setDepth​(double value)
      设置属性深度的值。
      void setHeight​(double value)
      设置属性高度的值。
      void setWidth​(double value)
      设置属性宽度的值。
      DoubleProperty widthProperty​()
      定义Box的宽度或X尺寸。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape3D

        cullFaceProperty, drawModeProperty, getCullFace, getDrawMode, getMaterial, materialProperty, setCullFace, setDrawMode, setMaterial

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • depth

        public final DoubleProperty depthProperty
        定义Box的深度或Z尺寸。
        Default value:
        2.0
        另请参见：
        getDepth() ， setDepth(double)

      • height

        public final DoubleProperty heightProperty
        定义Box的高度或Y尺寸。
        Default value:
        2.0
        另请参见：
        getHeight() ， setHeight(double)

      • width

        public final DoubleProperty widthProperty
        定义Box的宽度或X尺寸。
        Default value:
        2.0
        另请参见：
        getWidth() ， setWidth(double)

    • 字段详细信息

      • DEFAULT_SIZE

        public static final double DEFAULT_SIZE
        创建一个新的实例 Box的维度2乘以2。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Box

        public Box​()

      • Box

        public Box​(double width,
           double height,
           double depth)
        按深度创建尺寸宽度的新实例 Box 。
        参数
        width - 这个框的宽度
        height - 这个盒子的高度
        depth - 这个盒子的深度

    • 方法详细信息

      • setDepth

        public final void setDepth​(double value)
        设置属性深度的值。
        Property description:
        定义Box的深度或Z尺寸。
        Default value:
        2.0

      • getDepth

        public final double getDepth​()
        获取属性深度的值。
        Property description:
        定义Box的深度或Z尺寸。
        Default value:
        2.0

      • depthProperty

        public final DoubleProperty depthProperty​()
        定义Box的深度或Z尺寸。
        Default value:
        2.0
        另请参见：
        getDepth() ， setDepth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        定义Box的高度或Y尺寸。
        Default value:
        2.0

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        定义Box的高度或Y尺寸。
        Default value:
        2.0

      • heightProperty

        public final DoubleProperty heightProperty​()
        定义Box的高度或Y尺寸。
        Default value:
        2.0
        另请参见：
        getHeight() ， setHeight(double)

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        定义Box的宽度或X尺寸。
        Default value:
        2.0

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        定义Box的宽度或X尺寸。
        Default value:
        2.0

      • widthProperty

        public final DoubleProperty widthProperty​()
        定义Box的宽度或X尺寸。
        Default value:
        2.0
        另请参见：
        getWidth() ， setWidth(double)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Circle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Circle

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.Circle
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Circle
extends Shape
    Circle类创建一个新的圆，其中指定的半径和中心位置以像素为单位。

    使用示例 以下代码创建一个以（100,100）为中心的半径为50像素的圆。

       import javafx.scene.shape.Circle; Circle circle = new Circle(); circle.setCenterX(100.0f); circle.setCenterY(100.0f); circle.setRadius(50.0f);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty centerX
      以像素为单位定义圆心的水平位置。
      DoubleProperty centerY
      定义圆心的垂直位置，以像素为单位。
      DoubleProperty radius
      定义圆的半径，以像素为单位。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Circle​()
      创建一个空的Circle实例。
      Circle​(double radius)
      用指定的半径创建一个新的Circle实例。
      Circle​(double centerX, double centerY, double radius)
      用指定的位置和半径创建一个新的Circle实例。
      Circle​(double centerX, double centerY, double radius, Paint fill)
      创建一个新的具有指定位置，半径和填充的Circle实例。
      Circle​(double radius, Paint fill)
      创建一个新的具有指定半径的Circle实例并填充。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty centerXProperty​()
      以像素为单位定义圆心的水平位置。
      DoubleProperty centerYProperty​()
      定义圆心的垂直位置，以像素为单位。
      double getCenterX​()
      获取属性centerX的值。
      double getCenterY​()
      获取属性centerY的值。
      double getRadius​()
      获取属性半径的值。
      DoubleProperty radiusProperty​()
      定义圆的半径，以像素为单位。
      void setCenterX​(double value)
      设置属性centerX的值。
      void setCenterY​(double value)
      设置属性centerY的值。
      void setRadius​(double value)
      设置属性半径的值。
      String toString​()
      返回此 Circle对象的字符串表示形式。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • centerX

        public final DoubleProperty centerXProperty
        以像素为单位定义圆心的水平位置。
        Default value:
        0.0
        另请参见：
        getCenterX() ， setCenterX(double)

      • centerY

        public final DoubleProperty centerYProperty
        定义圆心的垂直位置，以像素为单位。
        Default value:
        0.0
        另请参见：
        getCenterY() ， setCenterY(double)

      • radius

        public final DoubleProperty radiusProperty
        定义圆的半径，以像素为单位。
        Default value:
        0.0
        另请参见：
        getRadius() ， setRadius(double)

    • 构造方法详细信息

      • Circle

        public Circle​(double radius)
        用指定的半径创建一个新的Circle实例。
        参数
        radius - 以像素为单位的圆的半径

      • Circle

        public Circle​(double radius,
              Paint fill)
        创建一个新的具有指定半径的Circle实例并填充。
        参数
        radius - 圆的半径
        fill - 确定如何填充圆的内部

      • Circle

        public Circle​()
        创建一个空的Circle实例。

      • Circle

        public Circle​(double centerX,
              double centerY,
              double radius)
        用指定的位置和半径创建一个新的Circle实例。
        参数
        centerX - 圆的中心的水平位置（以像素为单位）
        centerY - 圆的中心的垂直位置，以像素为单位
        radius - 圆的半径，以像素为单位

      • Circle

        public Circle​(double centerX,
              double centerY,
              double radius,
              Paint fill)
        创建一个新的具有指定位置，半径和填充的Circle实例。
        参数
        centerX - 圆的中心的水平位置（以像素为单位）
        centerY - centerY的垂直位置，以像素为单位
        radius - 圆的半径，以像素为单位
        fill - 确定如何填充圆的内部

    • 方法详细信息

      • setCenterX

        public final void setCenterX​(double value)
        设置属性centerX的值。
        Property description:
        以像素为单位定义圆心的水平位置。
        Default value:
        0.0

      • getCenterX

        public final double getCenterX​()
        获取属性centerX的值。
        Property description:
        以像素为单位定义圆心的水平位置。
        Default value:
        0.0

      • centerXProperty

        public final DoubleProperty centerXProperty​()
        以像素为单位定义圆心的水平位置。
        Default value:
        0.0
        另请参见：
        getCenterX() ， setCenterX(double)

      • setCenterY

        public final void setCenterY​(double value)
        设置属性centerY的值。
        Property description:
        定义圆心的垂直位置，以像素为单位。
        Default value:
        0.0

      • getCenterY

        public final double getCenterY​()
        获取属性centerY的值。
        Property description:
        定义圆心的垂直位置，以像素为单位。
        Default value:
        0.0

      • centerYProperty

        public final DoubleProperty centerYProperty​()
        定义圆心的垂直位置，以像素为单位。
        Default value:
        0.0
        另请参见：
        getCenterY() ， setCenterY(double)

      • setRadius

        public final void setRadius​(double value)
        设置属性半径的值。
        Property description:
        定义圆的半径，以像素为单位。
        Default value:
        0.0

      • getRadius

        public final double getRadius​()
        获取属性半径的值。
        Property description:
        定义圆的半径，以像素为单位。
        Default value:
        0.0

      • radiusProperty

        public final DoubleProperty radiusProperty​()
        定义圆的半径，以像素为单位。
        Default value:
        0.0
        另请参见：
        getRadius() ， setRadius(double)

      • toString

        public String toString​()
        返回此 Circle对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这是一个 Circle对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClosePath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class ClosePath

  • java.lang.Object
    • javafx.scene.shape.PathElement
      • javafx.scene.shape.ClosePath

  • public class ClosePath
extends PathElement
    关闭当前路径的路径元素。

    有关路径元素的更多信息，请参阅Path和PathElement类。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.shape.PathElement

        absolute

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClosePath​()
      创建一个空的ClosePath实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回此 ArcTo对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.PathElement

        absoluteProperty, isAbsolute, setAbsolute

    • 构造方法详细信息

      • ClosePath

        public ClosePath​()
        创建一个空的ClosePath实例。

    • 方法详细信息

      • toString

        public String toString​()
        返回此 ArcTo对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 ArcTo对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CubicCurve (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class CubicCurve

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.CubicCurve
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class CubicCurve
extends Shape

    CubiCurve类定义了（x，y）坐标空间中的三次Bézier参数曲线段。 绘制与指定坐标(startX, startY)和(endX, enfY)两者相交的曲线，使用指定点(controlX1, controlY1)和(controlX2, controlY2)作为Bζ控制点。 例：

      import javafx.scene.shape.*;

CubicCurve cubic = new CubicCurve();
cubic.setStartX(0.0f);
cubic.setStartY(50.0f);
cubic.setControlX1(25.0f);
cubic.setControlY1(0.0f);
cubic.setControlX2(75.0f);
cubic.setControlY2(100.0f);
cubic.setEndX(100.0f);
cubic.setEndY(50.0f);
}
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty controlX1
      定义三次曲线段的第一个控制点的X坐标。
      DoubleProperty controlX2
      定义三次曲线段的第二个控制点的X坐标。
      DoubleProperty controlY1
      定义三次曲线段的第一个控制点的Y坐标。
      DoubleProperty controlY2
      定义三次曲线段的第二个控制点的Y坐标。
      DoubleProperty endX
      定义三次曲线段终点的X坐标。
      DoubleProperty endY
      定义三次曲线段终点的Y坐标。
      DoubleProperty startX
      定义三次曲线段起始点的X坐标。
      DoubleProperty startY
      定义三次曲线段起始点的Y坐标。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      CubicCurve​()
      创建一个空的CubicCurve实例。
      CubicCurve​(double startX, double startY, double controlX1, double controlY1, double controlX2, double controlY2, double endX, double endY)
      创建一个新的CubicCurve实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty controlX1Property​()
      定义三次曲线段的第一个控制点的X坐标。
      DoubleProperty controlX2Property​()
      定义三次曲线段的第二个控制点的X坐标。
      DoubleProperty controlY1Property​()
      定义三次曲线段的第一个控制点的Y坐标。
      DoubleProperty controlY2Property​()
      定义三次曲线段的第二个控制点的Y坐标。
      DoubleProperty endXProperty​()
      定义三次曲线段终点的X坐标。
      DoubleProperty endYProperty​()
      定义三次曲线段终点的Y坐标。
      double getControlX1​()
      获取属性controlX1的值。
      double getControlX2​()
      获取属性controlX2的值。
      double getControlY1​()
      获取属性controlY1的值。
      double getControlY2​()
      获取属性controlY2的值。
      double getEndX​()
      获取属性endX的值。
      double getEndY​()
      获取属性endY的值。
      double getStartX​()
      获取属性startX的值。
      double getStartY​()
      获取属性startY的值。
      void setControlX1​(double value)
      设置属性controlX1的值。
      void setControlX2​(double value)
      设置属性controlX2的值。
      void setControlY1​(double value)
      设置属性controlY1的值。
      void setControlY2​(double value)
      设置属性controlY2的值。
      void setEndX​(double value)
      设置属性endX的值。
      void setEndY​(double value)
      设置属性endY的值。
      void setStartX​(double value)
      设置属性startX的值。
      void setStartY​(double value)
      设置属性startY的值。
      DoubleProperty startXProperty​()
      定义三次曲线段起始点的X坐标。
      DoubleProperty startYProperty​()
      定义三次曲线段起始点的Y坐标。
      String toString​()
      返回此 CubicCurve对象的字符串表示形式。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • startX

        public final DoubleProperty startXProperty
        定义三次曲线段起始点的X坐标。
        Default value:
        0.0
        另请参见：
        getStartX() ， setStartX(double)

      • startY

        public final DoubleProperty startYProperty
        定义三次曲线段起始点的Y坐标。
        Default value:
        0.0
        另请参见：
        getStartY() ， setStartY(double)

      • controlX1

        public final DoubleProperty controlX1Property
        定义三次曲线段的第一个控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX1() ， setControlX1(double)

      • controlY1

        public final DoubleProperty controlY1Property
        定义三次曲线段的第一个控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY1() ， setControlY1(double)

      • controlX2

        public final DoubleProperty controlX2Property
        定义三次曲线段的第二个控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX2() ， setControlX2(double)

      • controlY2

        public final DoubleProperty controlY2Property
        定义三次曲线段的第二个控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY2() ， setControlY2(double)

      • endX

        public final DoubleProperty endXProperty
        定义三次曲线段终点的X坐标。
        Default value:
        0.0
        另请参见：
        getEndX() ， setEndX(double)

      • endY

        public final DoubleProperty endYProperty
        定义三次曲线段终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getEndY() ， setEndY(double)

    • 构造方法详细信息

      • CubicCurve

        public CubicCurve​()
        创建一个空的CubicCurve实例。

      • CubicCurve

        public CubicCurve​(double startX,
                  double startY,
                  double controlX1,
                  double controlY1,
                  double controlX2,
                  double controlY2,
                  double endX,
                  double endY)
        创建一个新的CubicCurve实例。
        参数
        startX - startX的X坐标
        startY - startY的Y坐标
        controlX1 - 第一个控制点的X坐标
        controlY1 - 第一个控制点的Y坐标
        controlX2 - 第二个控制点的X坐标
        controlY2 - 第二个控制点的Y坐标
        endX - 终点的X坐标
        endY - 终点的Y坐标
        从以下版本开始：
        JavaFX 2.1

    • 方法详细信息

      • setStartX

        public final void setStartX​(double value)
        设置属性startX的值。
        Property description:
        定义三次曲线段起始点的X坐标。
        Default value:
        0.0

      • getStartX

        public final double getStartX​()
        获取属性startX的值。
        Property description:
        定义三次曲线段起始点的X坐标。
        Default value:
        0.0

      • startXProperty

        public final DoubleProperty startXProperty​()
        定义三次曲线段起始点的X坐标。
        Default value:
        0.0
        另请参见：
        getStartX() ， setStartX(double)

      • setStartY

        public final void setStartY​(double value)
        设置属性startY的值。
        Property description:
        定义三次曲线段起始点的Y坐标。
        Default value:
        0.0

      • getStartY

        public final double getStartY​()
        获取属性startY的值。
        Property description:
        定义三次曲线段起始点的Y坐标。
        Default value:
        0.0

      • startYProperty

        public final DoubleProperty startYProperty​()
        定义三次曲线段起始点的Y坐标。
        Default value:
        0.0
        另请参见：
        getStartY() ， setStartY(double)

      • setControlX1

        public final void setControlX1​(double value)
        设置属性controlX1的值。
        Property description:
        定义三次曲线段的第一个控制点的X坐标。
        Default value:
        0.0

      • getControlX1

        public final double getControlX1​()
        获取属性controlX1的值。
        Property description:
        定义三次曲线段的第一个控制点的X坐标。
        Default value:
        0.0

      • controlX1Property

        public final DoubleProperty controlX1Property​()
        定义三次曲线段的第一个控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX1() ， setControlX1(double)

      • setControlY1

        public final void setControlY1​(double value)
        设置属性controlY1的值。
        Property description:
        定义三次曲线段的第一个控制点的Y坐标。
        Default value:
        0.0

      • getControlY1

        public final double getControlY1​()
        获取属性controlY1的值。
        Property description:
        定义三次曲线段的第一个控制点的Y坐标。
        Default value:
        0.0

      • controlY1Property

        public final DoubleProperty controlY1Property​()
        定义三次曲线段的第一个控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY1() ， setControlY1(double)

      • setControlX2

        public final void setControlX2​(double value)
        设置属性controlX2的值。
        Property description:
        定义三次曲线段的第二个控制点的X坐标。
        Default value:
        0.0

      • getControlX2

        public final double getControlX2​()
        获取属性controlX2的值。
        Property description:
        定义三次曲线段的第二个控制点的X坐标。
        Default value:
        0.0

      • controlX2Property

        public final DoubleProperty controlX2Property​()
        定义三次曲线段的第二个控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX2() ， setControlX2(double)

      • setControlY2

        public final void setControlY2​(double value)
        设置属性controlY2的值。
        Property description:
        定义三次曲线段的第二个控制点的Y坐标。
        Default value:
        0.0

      • getControlY2

        public final double getControlY2​()
        获取属性controlY2的值。
        Property description:
        定义三次曲线段的第二个控制点的Y坐标。
        Default value:
        0.0

      • controlY2Property

        public final DoubleProperty controlY2Property​()
        定义三次曲线段的第二个控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY2() ， setControlY2(double)

      • setEndX

        public final void setEndX​(double value)
        设置属性endX的值。
        Property description:
        定义三次曲线段终点的X坐标。
        Default value:
        0.0

      • getEndX

        public final double getEndX​()
        获取属性endX的值。
        Property description:
        定义三次曲线段终点的X坐标。
        Default value:
        0.0

      • endXProperty

        public final DoubleProperty endXProperty​()
        定义三次曲线段终点的X坐标。
        Default value:
        0.0
        另请参见：
        getEndX() ， setEndX(double)

      • setEndY

        public final void setEndY​(double value)
        设置属性endY的值。
        Property description:
        定义三次曲线段终点的Y坐标。
        Default value:
        0.0

      • getEndY

        public final double getEndY​()
        获取属性endY的值。
        Property description:
        定义三次曲线段终点的Y坐标。
        Default value:
        0.0

      • endYProperty

        public final DoubleProperty endYProperty​()
        定义三次曲线段终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getEndY() ， setEndY(double)

      • toString

        public String toString​()
        返回此 CubicCurve对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这个 CubicCurve对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CubicCurveTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class CubicCurveTo

  • java.lang.Object
    • javafx.scene.shape.PathElement
      • javafx.scene.shape.CubicCurveTo

  • public class CubicCurveTo
extends PathElement
    通过使用指定点(controlX1,controlY1)和(controlX2,controlY2)作为Bézier控制点(controlX1,controlY1)与当前坐标和指定坐标(x,y)相交的立方Bier曲线，创建由三个新点定义的曲线路径元素。 所有坐标均以双精度指定。

    有关路径元素的更多信息，请参阅Path和PathElement类。

    例：

      import javafx.scene.shape.*;

Path path = new Path();

MoveTo moveTo = new MoveTo();
moveTo.setX(0.0f);
moveTo.setY(0.0f);

CubicCurveTo cubicTo = new CubicCurveTo();
cubicTo.setControlX1(0.0f);
cubicTo.setControlY1(0.0f);
cubicTo.setControlX2(100.0f);
cubicTo.setControlY2(100.0f);
cubicTo.setX(100.0f);
cubicTo.setY(50.0f);

path.getElements().add(moveTo);
path.getElements().add(cubicTo);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty controlX1
      定义第一个Bézier控制点的X坐标。
      DoubleProperty controlX2
      定义第二个Bézier控制点的X坐标。
      DoubleProperty controlY1
      定义第一个Bézier控制点的Y坐标。
      DoubleProperty controlY2
      定义第二个Bézier控制点的Y坐标。
      DoubleProperty x
      定义最终终点的X坐标。
      DoubleProperty y
      定义最终终点的Y坐标。

      • Properties inherited from class javafx.scene.shape.PathElement

        absolute

    • 构造方法摘要

      构造方法
      Constructor 描述
      CubicCurveTo​()
      创建一个空的CubicCurveTo实例。
      CubicCurveTo​(double controlX1, double controlY1, double controlX2, double controlY2, double x, double y)
      创建一个新的CubicCurveTo实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty controlX1Property​()
      定义第一个Bézier控制点的X坐标。
      DoubleProperty controlX2Property​()
      定义第二个Bézier控制点的X坐标。
      DoubleProperty controlY1Property​()
      定义第一个Bézier控制点的Y坐标。
      DoubleProperty controlY2Property​()
      定义第二个Bézier控制点的Y坐标。
      double getControlX1​()
      获取属性controlX1的值。
      double getControlX2​()
      获取属性controlX2的值。
      double getControlY1​()
      获取属性controlY1的值。
      double getControlY2​()
      获取属性controlY2的值。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      void setControlX1​(double value)
      设置属性controlX1的值。
      void setControlX2​(double value)
      设置属性controlX2的值。
      void setControlY1​(double value)
      设置属性controlY1的值。
      void setControlY2​(double value)
      设置属性controlY2的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      String toString​()
      返回此 CubicCurveTo对象的字符串表示形式。
      DoubleProperty xProperty​()
      定义最终终点的X坐标。
      DoubleProperty yProperty​()
      定义最终终点的Y坐标。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.PathElement

        absoluteProperty, isAbsolute, setAbsolute

    • Property Detail

      • controlX1

        public final DoubleProperty controlX1Property
        定义第一个Bézier控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX1() ， setControlX1(double)

      • controlY1

        public final DoubleProperty controlY1Property
        定义第一个Bézier控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY1() ， setControlY1(double)

      • controlX2

        public final DoubleProperty controlX2Property
        定义第二个Bézier控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX2() ， setControlX2(double)

      • controlY2

        public final DoubleProperty controlY2Property
        定义第二个Bézier控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY2() ， setControlY2(double)

      • x

        public final DoubleProperty xProperty
        定义最终终点的X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义最终终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

    • 构造方法详细信息

      • CubicCurveTo

        public CubicCurveTo​()
        创建一个空的CubicCurveTo实例。

      • CubicCurveTo

        public CubicCurveTo​(double controlX1,
                    double controlY1,
                    double controlX2,
                    double controlY2,
                    double x,
                    double y)
        创建一个新的CubicCurveTo实例。
        参数
        controlX1 - 第一个Bézier控制点的X坐标
        controlY1 - 第一个Bézier控制点的Y坐标
        controlX2 - 第二个Bézier控制点的X坐标
        controlY2 - 第二个Bézier控制点的Y坐标
        x - 最终终点的X坐标
        y - 最终终点的Y坐标

    • 方法详细信息

      • setControlX1

        public final void setControlX1​(double value)
        设置属性controlX1的值。
        Property description:
        定义第一个Bézier控制点的X坐标。
        Default value:
        0.0

      • getControlX1

        public final double getControlX1​()
        获取属性controlX1的值。
        Property description:
        定义第一个Bézier控制点的X坐标。
        Default value:
        0.0

      • controlX1Property

        public final DoubleProperty controlX1Property​()
        定义第一个Bézier控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX1() ， setControlX1(double)

      • setControlY1

        public final void setControlY1​(double value)
        设置属性controlY1的值。
        Property description:
        定义第一个Bézier控制点的Y坐标。
        Default value:
        0.0

      • getControlY1

        public final double getControlY1​()
        获取属性controlY1的值。
        Property description:
        定义第一个Bézier控制点的Y坐标。
        Default value:
        0.0

      • controlY1Property

        public final DoubleProperty controlY1Property​()
        定义第一个Bézier控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY1() ， setControlY1(double)

      • setControlX2

        public final void setControlX2​(double value)
        设置属性controlX2的值。
        Property description:
        定义第二个Bézier控制点的X坐标。
        Default value:
        0.0

      • getControlX2

        public final double getControlX2​()
        获取属性controlX2的值。
        Property description:
        定义第二个Bézier控制点的X坐标。
        Default value:
        0.0

      • controlX2Property

        public final DoubleProperty controlX2Property​()
        定义第二个Bézier控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX2() ， setControlX2(double)

      • setControlY2

        public final void setControlY2​(double value)
        设置属性controlY2的值。
        Property description:
        定义第二个Bézier控制点的Y坐标。
        Default value:
        0.0

      • getControlY2

        public final double getControlY2​()
        获取属性controlY2的值。
        Property description:
        定义第二个Bézier控制点的Y坐标。
        Default value:
        0.0

      • controlY2Property

        public final DoubleProperty controlY2Property​()
        定义第二个Bézier控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY2() ， setControlY2(double)

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义最终终点的X坐标。
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义最终终点的X坐标。
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        定义最终终点的X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义最终终点的Y坐标。
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义最终终点的Y坐标。
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        定义最终终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • toString

        public String toString​()
        返回此 CubicCurveTo对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 CubicCurveTo对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CullFace (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Enum CullFace

  • java.lang.Object
    • java.lang.Enum<CullFace>
      • javafx.scene.shape.CullFace
  • All Implemented Interfaces:
    Serializable ， Comparable<CullFace>

    public enum CullFace
extends Enum<CullFace>
    面部剔除设置与 Shape3D.cullFace一起使用
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    Shape3D.cullFaceProperty()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BACK
      剔除所有背面的多边形。
      FRONT
      剔除所有面向前的多边形。
      NONE
      不要进行任何脸剔除。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static CullFace valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CullFace[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NONE

        public static final CullFace NONE
        不要进行任何脸剔除。

      • BACK

        public static final CullFace BACK
        剔除所有背面的多边形。 BACK定义为顺时针缠绕顺序。

      • FRONT

        public static final CullFace FRONT
        剔除所有面向前的多边形。 FRONT定义为逆时针缠绕顺序。

    • 方法详细信息

      • values

        public static CullFace[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (CullFace c : CullFace.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static CullFace valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Cylinder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Cylinder

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape3D
        • javafx.scene.shape.Cylinder
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Cylinder
extends Shape3D
    Cylinder类定义了具有指定大小的3维圆柱体。 A Cylinder是用给定的半径和高度创建的3D几何图元。 它以起源为中心。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty height
      定义气缸的高度或Y尺寸。
      DoubleProperty radius
      定义圆柱体Z平面中的半径。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape3D

        cullFace, drawMode, material

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Cylinder​()
      创建一个新的实例 Cylinder ，半径为1.0，高度为2.0。
      Cylinder​(double radius, double height)
      创建一个给定半径和高度的新实例 Cylinder 。
      Cylinder​(double radius, double height, int divisions)
      创建一个给定半径，高度和分割的新实例 Cylinder 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getDivisions​()
      检索用于生成此气瓶的分区属性。
      double getHeight​()
      获取属性高度的值。
      double getRadius​()
      获取属性半径的值。
      DoubleProperty heightProperty​()
      定义气缸的高度或Y尺寸。
      DoubleProperty radiusProperty​()
      定义圆柱体Z平面中的半径。
      void setHeight​(double value)
      设置属性高度的值。
      void setRadius​(double value)
      设置属性半径的值。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape3D

        cullFaceProperty, drawModeProperty, getCullFace, getDrawMode, getMaterial, materialProperty, setCullFace, setDrawMode, setMaterial

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • height

        public final DoubleProperty heightProperty
        定义气缸的高度或Y尺寸。
        Default value:
        2.0
        另请参见：
        getHeight() ， setHeight(double)

      • radius

        public final DoubleProperty radiusProperty
        定义圆柱体Z平面中的半径。
        Default value:
        1.0
        另请参见：
        getRadius() ， setRadius(double)

    • 构造方法详细信息

      • Cylinder

        public Cylinder​()
        创建一个新的实例，为Cylinder ，半径为1.0，高度为2.0。 分辨率默认为沿X和Z轴的15个分割。

      • Cylinder

        public Cylinder​(double radius,
                double height)
        创建一个给定半径和高度的新实例Cylinder 。 分辨率默认为沿X和Z轴的15个分割。
        参数
        radius - 半径
        height - 身高

      • Cylinder

        public Cylinder​(double radius,
                double height,
                int divisions)
        创建给定半径，高度和分割的新实例Cylinder 。 分辨率默认为沿X和Z轴的15个分割。 请注意，分数应至少为3.任何小于该值的值将被钳制为3。
        参数
        radius - 半径
        height - 身高
        divisions - 分部

    • 方法详细信息

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        定义气缸的高度或Y尺寸。
        Default value:
        2.0

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        定义气缸的高度或Y尺寸。
        Default value:
        2.0

      • heightProperty

        public final DoubleProperty heightProperty​()
        定义气缸的高度或Y尺寸。
        Default value:
        2.0
        另请参见：
        getHeight() ， setHeight(double)

      • setRadius

        public final void setRadius​(double value)
        设置属性半径的值。
        Property description:
        定义圆柱体Z平面中的半径。
        Default value:
        1.0

      • getRadius

        public final double getRadius​()
        获取属性半径的值。
        Property description:
        定义圆柱体Z平面中的半径。
        Default value:
        1.0

      • radiusProperty

        public final DoubleProperty radiusProperty​()
        定义圆柱体Z平面中的半径。
        Default value:
        1.0
        另请参见：
        getRadius() ， setRadius(double)

      • getDivisions

        public int getDivisions​()
        检索用于生成此气瓶的分区属性。
        结果
        the divisions attribute.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DrawMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Enum DrawMode

  • java.lang.Object
    • java.lang.Enum<DrawMode>
      • javafx.scene.shape.DrawMode
  • All Implemented Interfaces:
    Serializable ， Comparable<DrawMode>

    public enum DrawMode
extends Enum<DrawMode>
    定义与 Shape3D.drawMode使用时如何绘制多边形
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    Shape3D.drawModeProperty()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      FILL
      通过填充多边形的内部渲染多边形原语。
      LINE
      将多边形原语渲染为在多边形的连续顶点之间绘制的线条。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static DrawMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DrawMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LINE

        public static final DrawMode LINE
        将多边形原语渲染为在多边形的连续顶点之间绘制的线条。

      • FILL

        public static final DrawMode FILL
        通过填充多边形的内部渲染多边形原语。

    • 方法详细信息

      • values

        public static DrawMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (DrawMode c : DrawMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static DrawMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Ellipse (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Ellipse

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.Ellipse
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Ellipse
extends Shape
    Ellipse类创建一个新的椭圆，具有指定的大小和位置（以像素为单位）
      import javafx.scene.shape.*;

Ellipse ellipse = new Ellipse(); {
ellipse.setCenterX(50.0f);
ellipse.setCenterY(50.0f);
ellipse.setRadiusX(50.0f);
ellipse.setRadiusY(25.0f);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty centerX
      定义椭圆中心的水平位置（以像素为单位）。
      DoubleProperty centerY
      定义椭圆中心的垂直位置（以像素为单位）。
      DoubleProperty radiusX
      定义椭圆的宽度（以像素为单位）。
      DoubleProperty radiusY
      以像素为单位定义椭圆的高度。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Ellipse​()
      创建一个空的椭圆实例。
      Ellipse​(double radiusX, double radiusY)
      创建给定大小的椭圆实例。
      Ellipse​(double centerX, double centerY, double radiusX, double radiusY)
      创建给定位置和大小的椭圆实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty centerXProperty​()
      定义椭圆中心的水平位置（以像素为单位）。
      DoubleProperty centerYProperty​()
      定义椭圆中心的垂直位置（以像素为单位）。
      double getCenterX​()
      获取属性centerX的值。
      double getCenterY​()
      获取属性centerY的值。
      double getRadiusX​()
      获取属性radiusX的值。
      double getRadiusY​()
      获取属性radiusY的值。
      DoubleProperty radiusXProperty​()
      定义椭圆的宽度（以像素为单位）。
      DoubleProperty radiusYProperty​()
      以像素为单位定义椭圆的高度。
      void setCenterX​(double value)
      设置属性centerX的值。
      void setCenterY​(double value)
      设置属性centerY的值。
      void setRadiusX​(double value)
      设置属性radiusX的值。
      void setRadiusY​(double value)
      设置属性radiusY的值。
      String toString​()
      返回此 Ellipse对象的字符串表示形式。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • centerX

        public final DoubleProperty centerXProperty
        定义椭圆中心的水平位置（以像素为单位）。
        Default value:
        0.0
        另请参见：
        getCenterX() ， setCenterX(double)

      • centerY

        public final DoubleProperty centerYProperty
        定义椭圆中心的垂直位置（以像素为单位）。
        Default value:
        0.0
        另请参见：
        getCenterY() ， setCenterY(double)

      • radiusX

        public final DoubleProperty radiusXProperty
        定义椭圆的宽度（以像素为单位）。
        Default value:
        0.0
        另请参见：
        getRadiusX() ， setRadiusX(double)

      • radiusY

        public final DoubleProperty radiusYProperty
        以像素为单位定义椭圆的高度。
        Default value:
        0.0
        另请参见：
        getRadiusY() ， setRadiusY(double)

    • 构造方法详细信息

      • Ellipse

        public Ellipse​()
        创建一个空的椭圆实例。

      • Ellipse

        public Ellipse​(double radiusX,
               double radiusY)
        创建给定大小的椭圆实例。
        参数
        radiusX - 椭圆的水平半径，以像素为单位
        radiusY - 椭圆的垂直半径，以像素为单位

      • Ellipse

        public Ellipse​(double centerX,
               double centerY,
               double radiusX,
               double radiusY)
        创建给定位置和大小的椭圆实例。
        参数
        centerX - 椭圆中心的水平位置（以像素为单位）
        centerY - 椭圆中心的垂直位置（以像素为单位）
        radiusX - 椭圆的水平半径，以像素为单位
        radiusY - 椭圆的垂直半径，以像素为单位

    • 方法详细信息

      • setCenterX

        public final void setCenterX​(double value)
        设置属性centerX的值。
        Property description:
        定义椭圆中心的水平位置（以像素为单位）。
        Default value:
        0.0

      • getCenterX

        public final double getCenterX​()
        获取属性centerX的值。
        Property description:
        定义椭圆中心的水平位置（以像素为单位）。
        Default value:
        0.0

      • centerXProperty

        public final DoubleProperty centerXProperty​()
        定义椭圆中心的水平位置（以像素为单位）。
        Default value:
        0.0
        另请参见：
        getCenterX() ， setCenterX(double)

      • setCenterY

        public final void setCenterY​(double value)
        设置属性centerY的值。
        Property description:
        定义椭圆中心的垂直位置（以像素为单位）。
        Default value:
        0.0

      • getCenterY

        public final double getCenterY​()
        获取属性centerY的值。
        Property description:
        定义椭圆中心的垂直位置（以像素为单位）。
        Default value:
        0.0

      • centerYProperty

        public final DoubleProperty centerYProperty​()
        定义椭圆中心的垂直位置（以像素为单位）。
        Default value:
        0.0
        另请参见：
        getCenterY() ， setCenterY(double)

      • setRadiusX

        public final void setRadiusX​(double value)
        设置属性radiusX的值。
        Property description:
        定义椭圆的宽度（以像素为单位）。
        Default value:
        0.0

      • getRadiusX

        public final double getRadiusX​()
        获取属性radiusX的值。
        Property description:
        定义椭圆的宽度（以像素为单位）。
        Default value:
        0.0

      • radiusXProperty

        public final DoubleProperty radiusXProperty​()
        定义椭圆的宽度（以像素为单位）。
        Default value:
        0.0
        另请参见：
        getRadiusX() ， setRadiusX(double)

      • setRadiusY

        public final void setRadiusY​(double value)
        设置属性radiusY的值。
        Property description:
        以像素为单位定义椭圆的高度。
        Default value:
        0.0

      • getRadiusY

        public final double getRadiusY​()
        获取属性radiusY的值。
        Property description:
        以像素为单位定义椭圆的高度。
        Default value:
        0.0

      • radiusYProperty

        public final DoubleProperty radiusYProperty​()
        以像素为单位定义椭圆的高度。
        Default value:
        0.0
        另请参见：
        getRadiusY() ， setRadiusY(double)

      • toString

        public String toString​()
        返回此 Ellipse对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这是 Ellipse对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FillRule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Enum FillRule

  • java.lang.Object
    • java.lang.Enum<FillRule>
      • javafx.scene.shape.FillRule
  • All Implemented Interfaces:
    Serializable ， Comparable<FillRule>

    public enum FillRule
extends Enum<FillRule>
    用于确定路径内部的填充规则。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      EVEN_ODD
      定义用于确定路径内部的偶数填充规则。
      NON_ZERO
      定义用于确定路径内部的非零填充规则。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FillRule valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FillRule[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • EVEN_ODD

        public static final FillRule EVEN_ODD
        定义用于确定路径内部的偶数填充规则。 奇数规则规定，如果从该点到无穷远的任何方向绘制的射线被路径段奇数次穿过，则点位于路径内。

      • NON_ZERO

        public static final FillRule NON_ZERO
        定义用于确定路径内部的非零填充规则。 非零规则规定如果从该点到无穷远的任何方向绘制的光线在顺时针方向上比路顺序段顺时针方向超过顺时针方向，则该点位于路径内。

    • 方法详细信息

      • values

        public static FillRule[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (FillRule c : FillRule.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static FillRule valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


HLineTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class HLineTo

  • java.lang.Object
    • javafx.scene.shape.PathElement
      • javafx.scene.shape.HLineTo

  • public class HLineTo
extends PathElement
    创建从当前点到x的水平线路元素。

    有关路径元素的更多信息，请参阅Path和PathElement类。

    例：

      import javafx.scene.shape.*;

Path path = new Path();
path.getElements().add(new MoveTo(0.0f, 0.0f));
path.getElements().add(new HLineTo(80.0f));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty x
      定义X坐标。

      • Properties inherited from class javafx.scene.shape.PathElement

        absolute

    • 构造方法摘要

      构造方法
      Constructor 描述
      HLineTo​()
      创建一个空的HLineTo实例。
      HLineTo​(double x)
      创建一个HLineTo的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getX​()
      获取属性x的值。
      void setX​(double value)
      设置属性x的值。
      String toString​()
      返回此 HLineTo对象的字符串表示形式。
      DoubleProperty xProperty​()
      定义X坐标。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.PathElement

        absoluteProperty, isAbsolute, setAbsolute

    • Property Detail

      • x

        public final DoubleProperty xProperty
        定义X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

    • 构造方法详细信息

      • HLineTo

        public HLineTo​()
        创建一个空的HLineTo实例。

      • HLineTo

        public HLineTo​(double x)
        创建一个HLineTo的实例。
        参数
        x - 要水平坐标线

    • 方法详细信息

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义X坐标。
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义X坐标。
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        定义X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • toString

        public String toString​()
        返回此 HLineTo对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 HLineTo对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.shape (Java SE 9 & JDK 9 )

javafx.scene.shape

Interfaces

  • ObservableFaceArray

Classes

  • Arc
  • ArcTo
  • Box
  • Circle
  • ClosePath
  • CubicCurve
  • CubicCurveTo
  • Cylinder
  • Ellipse
  • HLineTo
  • Line
  • LineTo
  • Mesh
  • MeshView
  • MoveTo
  • Path
  • PathElement
  • Polygon
  • Polyline
  • QuadCurve
  • QuadCurveTo
  • Rectangle
  • Shape
  • Shape3D
  • Sphere
  • SVGPath
  • TriangleMesh
  • VertexFormat
  • VLineTo

Enums

  • ArcType
  • CullFace
  • DrawMode
  • FillRule
  • StrokeLineCap
  • StrokeLineJoin
  • StrokeType


javafx.scene.shape (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene.shape

提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

  • 接口摘要
    接口 描述
    ObservableFaceArray
    ObservableFaceArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
  • 类摘要
    Class 描述
    Arc
    所述 Arc类表示2D弧对象，由中心点限定的，起始角度（度），角度范围（以度数表示的弧的长度），和一弧型（ ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND ）。
    ArcTo
    一个路径元素，它使用指定的半径从前一个坐标到指定的x和y坐标形成弧。
    Box
    Box类定义了具有指定大小的3维框。
    Circle
    Circle类创建一个具有指定半径和中心位置的新圆圈，以像素为单位。
    ClosePath
    关闭当前路径的路径元素。
    CubicCurve
    CubiCurve类定义了（x，y）坐标空间中的三次Bézier参数曲线段。
    CubicCurveTo
    通过绘制与当前坐标和指定坐标 (x,y)相交的立方Bier曲线，使用指定点 (controlX1,controlY1)和 (controlX2,controlY2)作为Bézier控制点，创建由三个新点定义的曲线路径元素。
    Cylinder
    Cylinder类定义了具有指定尺寸的3维圆柱体。
    Ellipse
    Ellipse类创建一个新的椭圆，具有指定的大小和位置（以像素为单位）
    HLineTo
    创建从当前点到x的水平线路元素。
    Line
    此行表示 (x,y)坐标空间中的线段。
    LineTo
    通过从当前坐标绘制直线到新坐标来创建线路元素。
    Mesh
    用于表示3D几何表面的基类。
    MeshView
    MeshView类定义了具有指定3D网格数据的曲面。
    MoveTo
    通过移动到指定的坐标来创建对路径的补充。
    Path
    Path类代表一个简单的形状，并提供了基本构建和管理几何路径所需的设施。
    PathElement
    所述PathElement类表示的一个抽象元素Path能够表示像直线，圆弧，二次曲线，三次曲线等的任何几何对象
    Polygon
    创建由x，y坐标数组定义的多边形。
    Polyline
    创建折线，由分段点数组定义。
    QuadCurve
    Quadcurve类定义了（x，y）坐标空间中的二次Bézier参数曲线段。
    QuadCurveTo
    通过绘制与当前坐标和指定坐标 (x, y)相交的二次曲线曲线，使用指定点 (controlX, controlY)作为Bézier控制点，创建由两个新点定义的曲线路径元素。
    Rectangle
    Rectangle类定义了一个具有指定大小和位置的矩形。
    Shape
    Shape类提供了表示某种形式的几何形状的对象的常用属性的定义。
    Shape3D
    Shape3D基类为表示某种形式的3D几何形状的对象提供了常用属性的定义。
    Sphere
    Sphere类定义了具有指定大小的三维球体。
    SVGPath
    SVGPath类表示通过从String解析SVG路径数据构建的简单形状。
    TriangleMesh
    定义一个3D三角形网格，其包含相关联的 VertexFormat和一组独立的顶点组件阵列，例如点，法线，纹理坐标和定义网格的各个三角形的面阵列。
    VertexFormat
    定义网格中顶点的格式。
    VLineTo
    创建从当前点到y的垂直线路元素。
  • 枚举摘要
    Enum 描述
    ArcType
    ArcType指定Arc对象的关闭类型。
    CullFace
    面部剔除设置用于 Shape3D.cullFace
    DrawMode
    定义与 Shape3D.drawMode使用时如何绘制多边形
    FillRule
    用于确定路径内部的填充规则。
    StrokeLineCap
    定义 Shape的端帽样式。
    StrokeLineJoin
    定义一个 Shape的线连接样式。
    StrokeType
    定义在Shape节点的边界周围画画的位置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.shape Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.shape

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.shape.Mesh
      • javafx.scene.shape.TriangleMesh
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.shape.Shape
        • javafx.scene.shape.Arc
        • javafx.scene.shape.Circle
        • javafx.scene.shape.CubicCurve
        • javafx.scene.shape.Ellipse
        • javafx.scene.shape.Line
        • javafx.scene.shape.Path
        • javafx.scene.shape.Polygon
        • javafx.scene.shape.Polyline
        • javafx.scene.shape.QuadCurve
        • javafx.scene.shape.Rectangle
        • javafx.scene.shape.SVGPath
      • javafx.scene.shape.Shape3D
        • javafx.scene.shape.Box
        • javafx.scene.shape.Cylinder
        • javafx.scene.shape.MeshView
        • javafx.scene.shape.Sphere
    • javafx.scene.shape.PathElement
      • javafx.scene.shape.ArcTo
      • javafx.scene.shape.ClosePath
      • javafx.scene.shape.CubicCurveTo
      • javafx.scene.shape.HLineTo
      • javafx.scene.shape.LineTo
      • javafx.scene.shape.MoveTo
      • javafx.scene.shape.QuadCurveTo
      • javafx.scene.shape.VLineTo
    • javafx.scene.shape.VertexFormat

Interface Hierarchy

  • javafx.beans.Observable
    • javafx.collections.ObservableArray<T>
      • javafx.collections.ObservableIntegerArray
        • javafx.scene.shape.ObservableFaceArray

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.shape.ArcType
      • javafx.scene.shape.CullFace
      • javafx.scene.shape.DrawMode
      • javafx.scene.shape.FillRule
      • javafx.scene.shape.StrokeLineCap
      • javafx.scene.shape.StrokeLineJoin
      • javafx.scene.shape.StrokeType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Line (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Line

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.Line
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Line
extends Shape
    此行代表(x,y)坐标空间中的一个线段。 例：
      import javafx.scene.shape.*;

Line line = new Line();
line.setStartX(0.0f);
line.setStartY(0.0f);
line.setEndX(100.0f);
line.setEndY(100.0f);
}
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty endX
      线段终点的X坐标。
      DoubleProperty endY
      线段终点的Y坐标。
      DoubleProperty startX
      线段起始点的X坐标。
      DoubleProperty startY
      线段起始点的Y坐标。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Line​()
      创建一个空的实例的线。
      Line​(double startX, double startY, double endX, double endY)
      创建一个新的Line实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty endXProperty​()
      线段终点的X坐标。
      DoubleProperty endYProperty​()
      线段终点的Y坐标。
      double getEndX​()
      获取属性endX的值。
      double getEndY​()
      获取属性endY的值。
      double getStartX​()
      获取属性startX的值。
      double getStartY​()
      获取属性startY的值。
      void setEndX​(double value)
      设置属性endX的值。
      void setEndY​(double value)
      设置属性endY的值。
      void setStartX​(double value)
      设置属性startX的值。
      void setStartY​(double value)
      设置属性startY的值。
      DoubleProperty startXProperty​()
      线段起始点的X坐标。
      DoubleProperty startYProperty​()
      线段起始点的Y坐标。
      String toString​()
      返回此 Line对象的字符串表示形式。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • startX

        public final DoubleProperty startXProperty
        线段起始点的X坐标。
        Default value:
        0.0
        另请参见：
        getStartX() ， setStartX(double)

      • startY

        public final DoubleProperty startYProperty
        线段起始点的Y坐标。
        Default value:
        0.0
        另请参见：
        getStartY() ， setStartY(double)

      • endX

        public final DoubleProperty endXProperty
        线段终点的X坐标。
        Default value:
        0.0
        另请参见：
        getEndX() ， setEndX(double)

      • endY

        public final DoubleProperty endYProperty
        线段终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getEndY() ， setEndY(double)

    • 构造方法详细信息

      • Line

        public Line​()
        创建一个空的实例的线。

      • Line

        public Line​(double startX,
            double startY,
            double endX,
            double endY)
        创建一个新的Line实例。
        参数
        startX - startX的水平坐标
        startY - startY的垂直坐标
        endX - 线段终点的水平坐标
        endY - 线段终点的垂直坐标

    • 方法详细信息

      • setStartX

        public final void setStartX​(double value)
        设置属性startX的值。
        Property description:
        线段起始点的X坐标。
        Default value:
        0.0

      • getStartX

        public final double getStartX​()
        获取属性startX的值。
        Property description:
        线段起始点的X坐标。
        Default value:
        0.0

      • startXProperty

        public final DoubleProperty startXProperty​()
        线段起始点的X坐标。
        Default value:
        0.0
        另请参见：
        getStartX() ， setStartX(double)

      • setStartY

        public final void setStartY​(double value)
        设置属性startY的值。
        Property description:
        线段起始点的Y坐标。
        Default value:
        0.0

      • getStartY

        public final double getStartY​()
        获取属性startY的值。
        Property description:
        线段起始点的Y坐标。
        Default value:
        0.0

      • startYProperty

        public final DoubleProperty startYProperty​()
        线段起始点的Y坐标。
        Default value:
        0.0
        另请参见：
        getStartY() ， setStartY(double)

      • setEndX

        public final void setEndX​(double value)
        设置属性endX的值。
        Property description:
        线段终点的X坐标。
        Default value:
        0.0

      • getEndX

        public final double getEndX​()
        获取属性endX的值。
        Property description:
        线段终点的X坐标。
        Default value:
        0.0

      • endXProperty

        public final DoubleProperty endXProperty​()
        线段终点的X坐标。
        Default value:
        0.0
        另请参见：
        getEndX() ， setEndX(double)

      • setEndY

        public final void setEndY​(double value)
        设置属性endY的值。
        Property description:
        线段终点的Y坐标。
        Default value:
        0.0

      • getEndY

        public final double getEndY​()
        获取属性endY的值。
        Property description:
        线段终点的Y坐标。
        Default value:
        0.0

      • endYProperty

        public final DoubleProperty endYProperty​()
        线段终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getEndY() ， setEndY(double)

      • toString

        public String toString​()
        返回此 Line对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        a string representation of this Line object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LineTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class LineTo

  • java.lang.Object
    • javafx.scene.shape.PathElement
      • javafx.scene.shape.LineTo

  • public class LineTo
extends PathElement
    通过从当前坐标绘制直线到新坐标来创建线路元素。

    有关路径元素的更多信息，请参阅Path和PathElement类。

    例：

      import javafx.scene.shape.*;

Path path = new Path();
path.getElements().add(new MoveTo(0.0f, 50.0f));
path.getElements().add(new LineTo(100.0f, 100.0f));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty x
      定义X坐标。
      DoubleProperty y
      定义Y坐标。

      • Properties inherited from class javafx.scene.shape.PathElement

        absolute

    • 构造方法摘要

      构造方法
      Constructor 描述
      LineTo​()
      创建一个空的LineTo实例。
      LineTo​(double x, double y)
      创建LineTo的新功能。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      String toString​()
      返回此 LineTo对象的字符串表示形式。
      DoubleProperty xProperty​()
      定义X坐标。
      DoubleProperty yProperty​()
      定义Y坐标。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.PathElement

        absoluteProperty, isAbsolute, setAbsolute

    • Property Detail

      • x

        public final DoubleProperty xProperty
        定义X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

    • 构造方法详细信息

      • LineTo

        public LineTo​()
        创建一个空的LineTo实例。

      • LineTo

        public LineTo​(double x,
              double y)
        创建LineTo的新功能。
        参数
        x - 线端点的水平坐标
        y - 线终点的垂直坐标

    • 方法详细信息

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义X坐标。
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义X坐标。
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        定义X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义Y坐标。
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义Y坐标。
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        定义Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • toString

        public String toString​()
        返回此 LineTo对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 LineTo对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Mesh (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Mesh

  • java.lang.Object
    • javafx.scene.shape.Mesh
  • 已知直接子类：
    TriangleMesh

    public abstract class Mesh
extends Object
    用于表示3D几何表面的基类。 请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。
    从以下版本开始：
    JavaFX 8.0

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | Mesh​()

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Mesh

        protected Mesh​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MeshView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class MeshView

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape3D
        • javafx.scene.shape.MeshView
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class MeshView
extends Shape3D
    MeshView类定义了一个具有指定3D网格数据的曲面。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Mesh> mesh
      指定此 MeshView的3D网格数据。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape3D

        cullFace, drawMode, material

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      MeshView​()
      创建一个新的实例 MeshView类。
      MeshView​(Mesh mesh)
      创建一个具有指定的 Mesh表面的新实例 MeshView类。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Mesh getMesh​()
      获取属性网格的值。
      ObjectProperty<Mesh> meshProperty​()
      指定此 MeshView的3D网格数据。
      void setMesh​(Mesh value)
      设置属性网格的值。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape3D

        cullFaceProperty, drawModeProperty, getCullFace, getDrawMode, getMaterial, materialProperty, setCullFace, setDrawMode, setMaterial

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • mesh

        public final ObjectProperty<Mesh> meshProperty
        指定此 MeshView的3D网格数据。
        Default value:
        空值
        另请参见：
        getMesh() ， setMesh(Mesh)

    • 构造方法详细信息

      • MeshView

        public MeshView​()
        创建一个新的 MeshView实例。

      • MeshView

        public MeshView​(Mesh mesh)
        创建一个具有指定的 Mesh表面的新实例 MeshView类。
        参数
        mesh - 网格表面

    • 方法详细信息

      • setMesh

        public final void setMesh​(Mesh value)
        设置属性网格的值。
        Property description:
        指定此 MeshView的3D网格数据。
        Default value:
        空值

      • getMesh

        public final Mesh getMesh​()
        获取属性网格的值。
        Property description:
        指定此 MeshView的3D网格数据。
        Default value:
        空值

      • meshProperty

        public final ObjectProperty<Mesh> meshProperty​()
        指定此 MeshView的3D网格数据。
        Default value:
        空值
        另请参见：
        getMesh() ， setMesh(Mesh)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MoveTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class MoveTo

  • java.lang.Object
    • javafx.scene.shape.PathElement
      • javafx.scene.shape.MoveTo

  • public class MoveTo
extends PathElement
    通过移动到指定的坐标来创建对路径的补充。

    有关路径元素的更多信息，请参阅Path和PathElement类。

    例：

      import javafx.scene.shape.*;

Path path = new Path();
path.getElements().add(new MoveTo(0.0f, 0.0f));
path.getElements().add(new LineTo(100.0f, 100.0f));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty x
      定义指定的X坐标。
      DoubleProperty y
      定义指定的Y坐标。

      • Properties inherited from class javafx.scene.shape.PathElement

        absolute

    • 构造方法摘要

      构造方法
      Constructor 描述
      MoveTo​()
      创建一个空的MoveTo实例。
      MoveTo​(double x, double y)
      创建一个新的MoveTo实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      String toString​()
      返回此 MoveTo对象的字符串表示形式。
      DoubleProperty xProperty​()
      定义指定的X坐标。
      DoubleProperty yProperty​()
      定义指定的Y坐标。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.PathElement

        absoluteProperty, isAbsolute, setAbsolute

    • Property Detail

      • x

        public final DoubleProperty xProperty
        定义指定的X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义指定的Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

    • 构造方法详细信息

      • MoveTo

        public MoveTo​()
        创建一个空的MoveTo实例。

      • MoveTo

        public MoveTo​(double x,
              double y)
        创建一个新的MoveTo实例。
        参数
        x - 移动到的水平坐标
        y - 要移动的垂直坐标

    • 方法详细信息

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义指定的X坐标。
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义指定的X坐标。
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        定义指定的X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义指定的Y坐标。
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义指定的Y坐标。
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        定义指定的Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • toString

        public String toString​()
        返回此 MoveTo对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 MoveTo对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ObservableFaceArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Interface ObservableFaceArray

  • All Superinterfaces:
    Observable ， ObservableArray<ObservableIntegerArray> ， ObservableIntegerArray

    public interface ObservableFaceArray
extends ObservableIntegerArray
    ObservableFaceArray是一个int[]数组，允许侦听器在发生变化时跟踪它们。 为了跟踪更改，内部阵列被封装，并且没有从外部可用的直接访问。 支持批量操作，但它们总是执行数据范围的副本。 定义TriangleMesh的面时使用此类 。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    ArrayChangeListener

    • 方法摘要

      • Methods inherited from interface javafx.beans.Observable

        addListener, removeListener

      • Methods inherited from interface javafx.collections.ObservableArray

        addListener, clear, ensureCapacity, removeListener, resize, size, trimToSize

      • Methods inherited from interface javafx.collections.ObservableIntegerArray

        addAll, addAll, addAll, addAll, copyTo, copyTo, get, set, set, set, setAll, setAll, setAll, setAll, toArray, toArray
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Path (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Path

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.Path
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Path
extends Shape
    Path类代表了一个简单的形状，并提供了基本构造和管理几何路径所需的设施。 例：
      import javafx.scene.shape.*;

Path path = new Path();

MoveTo moveTo = new MoveTo();
moveTo.setX(0.0f);
moveTo.setY(0.0f);

HLineTo hLineTo = new HLineTo();
hLineTo.setX(70.0f);

QuadCurveTo quadCurveTo = new QuadCurveTo();
quadCurveTo.setX(120.0f);
quadCurveTo.setY(60.0f);
quadCurveTo.setControlX(100.0f);
quadCurveTo.setControlY(0.0f);

LineTo lineTo = new LineTo();
lineTo.setX(175.0f);
lineTo.setY(55.0f);

ArcTo arcTo = new ArcTo();
arcTo.setX(50.0f);
arcTo.setY(50.0f);
arcTo.setRadiusX(50.0f);
arcTo.setRadiusY(50.0f);

path.getElements().add(moveTo);
path.getElements().add(hLineTo);
path.getElements().add(quadCurveTo);
path.getElements().add(lineTo);
path.getElements().add(arcTo);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<FillRule> fillRule
      定义用于确定路径内部的填充规则常数。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Path​()
      创建一个空的路径实例。
      Path​(Collection<? extends PathElement> elements)
      创建路径的新实例
      Path​(PathElement... elements)
      创建一个新的路径实例

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<FillRule> fillRuleProperty​()
      定义用于确定路径内部的填充规则常数。
      ObservableList<PathElement> getElements​()
      获取此路径的路径元素的可观察列表。
      FillRule getFillRule​()
      获取属性fillRule的值。
      void setFillRule​(FillRule value)
      设置属性fillRule的值。
      String toString​()
      返回此 Path对象的字符串表示形式。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • fillRule

        public final ObjectProperty<FillRule> fillRuleProperty
        定义用于确定路径内部的填充规则常数。 该值必须是以下常量之一： FillRile.EVEN_ODD或FillRule.NON_ZERO 。 默认值为FillRule.NON_ZERO 。
        Default value:
        FillRule.NON_ZERO
        另请参见：
        getFillRule() ， setFillRule(FillRule)

    • 构造方法详细信息

      • Path

        public Path​()
        创建一个空的路径实例。

      • Path

        public Path​(PathElement... elements)
        创建一个新的路径实例
        参数
        elements - 路径的元素
        从以下版本开始：
        JavaFX 2.1

      • Path

        public Path​(Collection<? extends PathElement> elements)
        创建路径的新实例
        参数
        elements - 路径元素的集合
        从以下版本开始：
        JavaFX 2.2

    • 方法详细信息

      • setFillRule

        public final void setFillRule​(FillRule value)
        设置属性fillRule的值。
        Property description:
        定义用于确定路径内部的填充规则常数。 该值必须是以下常量之一： FillRile.EVEN_ODD或FillRule.NON_ZERO 。 默认值为FillRule.NON_ZERO 。
        Default value:
        FillRule.NON_ZERO

      • getFillRule

        public final FillRule getFillRule​()
        获取属性fillRule的值。
        Property description:
        定义用于确定路径内部的填充规则常数。 该值必须是以下常量之一： FillRile.EVEN_ODD或FillRule.NON_ZERO 。 默认值为FillRule.NON_ZERO 。
        Default value:
        FillRule.NON_ZERO

      • fillRuleProperty

        public final ObjectProperty<FillRule> fillRuleProperty​()
        定义用于确定路径内部的填充规则常数。 该值必须是以下常数之一： FillRile.EVEN_ODD或FillRule.NON_ZERO 。 默认值为FillRule.NON_ZERO 。
        Default value:
        FillRule.NON_ZERO
        另请参见：
        getFillRule() ， setFillRule(FillRule)

      • getElements

        public final ObservableList<PathElement> getElements​()
        获取此路径的路径元素的可观察列表。
        结果
        这个路径的元素

      • toString

        public String toString​()
        返回此 Path对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这是一个 Path对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PathElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class PathElement

  • java.lang.Object
    • javafx.scene.shape.PathElement
  • 已知直接子类：
    ArcTo ， ClosePath ， CubicCurveTo ， HLineTo ， LineTo ， MoveTo ， QuadCurveTo ， VLineTo

    public abstract class PathElement
extends Object
    所述PathElement类表示的一个抽象元素Path能够表示像直线，圆弧，二次曲线，三次曲线等的任何几何对象
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty absolute
      指示路径坐标是绝对还是相对的标志。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PathElement​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BooleanProperty absoluteProperty​()
      指示路径坐标是绝对还是相对的标志。
      boolean isAbsolute​()
      获取属性的值绝对值。
      void setAbsolute​(boolean value)
      设置属性的值绝对值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • absolute

        public final BooleanProperty absoluteProperty
        指示路径坐标是绝对还是相对的标志。 值为true表示坐标为绝对值。 值为false表示此PathElement中的值被添加到先前的PathElement的坐标以计算实际坐标。
        Default value:
        真正
        另请参见：
        isAbsolute() ， setAbsolute(boolean)

    • 构造方法详细信息

      • PathElement

        public PathElement​()

    • 方法详细信息

      • setAbsolute

        public final void setAbsolute​(boolean value)
        设置属性的值绝对值。
        Property description:
        指示路径坐标是绝对还是相对的标志。 值为true表示坐标为绝对值。 值为false表示此PathElement中的值被添加到先前的PathElement的坐标以计算实际坐标。
        Default value:
        真正

      • isAbsolute

        public final boolean isAbsolute​()
        获取属性的值绝对值。
        Property description:
        指示路径坐标是绝对还是相对的标志。 值为true表示坐标为绝对值。 值为false表示此PathElement中的值被添加到先前的PathElement的坐标以计算实际坐标。
        Default value:
        真正

      • absoluteProperty

        public final BooleanProperty absoluteProperty​()
        指示路径坐标是绝对还是相对的标志。 值为true表示坐标为绝对值。 值为false表示此PathElement中的值被添加到先前的PathElement的坐标以计算实际坐标。
        Default value:
        真正
        另请参见：
        isAbsolute(), setAbsolute(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Polygon (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Polygon

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.Polygon
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Polygon
extends Shape
    创建由x，y坐标数组定义的多边形。 Polygon类与Polyline类相似，但Polyline类未自动关闭。
      import javafx.scene.shape.*;

Polygon polygon = new Polygon();
polygon.getPoints().addAll(new Double[]{
    0.0, 0.0,
    20.0, 10.0,
    10.0, 20.0 });
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Polygon​()
      创建一个空的Polygon实例。
      Polygon​(double... points)
      创建一个新的多边形实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<Double> getPoints​()
      获取 Polygon顶点的坐标。
      String toString​()
      返回此 Polygon对象的字符串表示形式。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • Polygon

        public Polygon​()
        创建一个空的Polygon实例。

      • Polygon

        public Polygon​(double... points)
        创建一个新的多边形实例。
        参数
        points - 多边形顶点的坐标

    • 方法详细信息

      • getPoints

        public final ObservableList<Double> getPoints​()
        获取 Polygon顶点的坐标。
        结果
        这个可观察的顶点列表 Polygon

      • toString

        public String toString​()
        返回此 Polygon对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这个 Polygon对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Polyline (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Polyline

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.Polyline
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Polyline
extends Shape
    创建折线，由分段点数组定义。 Polyline类与Polygon类类似，但它不会自动关闭。
      import javafx.scene.shape.*;

Polyline polyline = new Polyline();
polyline.getPoints().addAll(new Double[]{
    0.0, 0.0,
    20.0, 10.0,
    10.0, 20.0 });
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Polyline​()
      创建一个空的Polyline实例。
      Polyline​(double... points)
      创建一个新的Polyline实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<Double> getPoints​()
      获取 PolyLine段的坐标。
      String toString​()
      返回此 Polyline对象的字符串表示形式。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • Polyline

        public Polyline​()
        创建一个空的Polyline实例。

      • Polyline

        public Polyline​(double... points)
        创建一个新的Polyline实例。
        参数
        points - 折线段的坐标

    • 方法详细信息

      • getPoints

        public final ObservableList<Double> getPoints​()
        获取 PolyLine段的坐标。
        结果
        构成这个 PolyLine段的点的可观察列表

      • toString

        public String toString​()
        返回此 Polyline对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这是一个 Polyline对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


QuadCurve (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class QuadCurve

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.QuadCurve
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class QuadCurve
extends Shape
    Quadcurve类定义了（x，y）坐标空间中的二次Bézier参数曲线段。 绘制与指定坐标(startX, startY)和(endX, enfY)相交的曲线，使用指定点(controlX, controlY)作为BÃ©zier控制点。
      import javafx.scene.shape.*;

QuadCurve quad = new QuadCurve();
quad.setStartX(0.0f);
quad.setStartY(50.0f);
quad.setEndX(50.0f);
quad.setEndY(50.0f);
quad.setControlX(25.0f);
quad.setControlY(0.0f);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty controlX
      定义二次曲线段的控制点的X坐标。
      DoubleProperty controlY
      定义二次曲线段控制点的Y坐标。
      DoubleProperty endX
      定义二次曲线段终点的X坐标。
      DoubleProperty endY
      定义二次曲线段终点的Y坐标。
      DoubleProperty startX
      定义二次曲线段起始点的X坐标。
      DoubleProperty startY
      定义二次曲线段起始点的Y坐标。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      QuadCurve​()
      创建一个空的QuadCurve实例。
      QuadCurve​(double startX, double startY, double controlX, double controlY, double endX, double endY)
      创建一个新的QuadCurve实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty controlXProperty​()
      定义二次曲线段的控制点的X坐标。
      DoubleProperty controlYProperty​()
      定义二次曲线段控制点的Y坐标。
      DoubleProperty endXProperty​()
      定义二次曲线段终点的X坐标。
      DoubleProperty endYProperty​()
      定义二次曲线段终点的Y坐标。
      double getControlX​()
      获取属性controlX的值。
      double getControlY​()
      获取属性controlY的值。
      double getEndX​()
      获取属性endX的值。
      double getEndY​()
      获取属性endY的值。
      double getStartX​()
      获取属性startX的值。
      double getStartY​()
      获取属性startY的值。
      void setControlX​(double value)
      设置属性controlX的值。
      void setControlY​(double value)
      设置属性controlY的值。
      void setEndX​(double value)
      设置属性endX的值。
      void setEndY​(double value)
      设置属性endY的值。
      void setStartX​(double value)
      设置属性startX的值。
      void setStartY​(double value)
      设置属性startY的值。
      DoubleProperty startXProperty​()
      定义二次曲线段起始点的X坐标。
      DoubleProperty startYProperty​()
      定义二次曲线段起始点的Y坐标。
      String toString​()
      返回此 QuadCurve对象的字符串表示形式。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • startX

        public final DoubleProperty startXProperty
        定义二次曲线段起始点的X坐标。
        Default value:
        0.0
        另请参见：
        getStartX() ， setStartX(double)

      • startY

        public final DoubleProperty startYProperty
        定义二次曲线段起始点的Y坐标。
        Default value:
        0.0
        另请参见：
        getStartY() ， setStartY(double)

      • controlX

        public final DoubleProperty controlXProperty
        定义二次曲线段的控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX() ， setControlX(double)

      • controlY

        public final DoubleProperty controlYProperty
        定义二次曲线段控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY() ， setControlY(double)

      • endX

        public final DoubleProperty endXProperty
        定义二次曲线段终点的X坐标。
        Default value:
        0.0
        另请参见：
        getEndX() ， setEndX(double)

      • endY

        public final DoubleProperty endYProperty
        定义二次曲线段终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getEndY() ， setEndY(double)

    • 构造方法详细信息

      • QuadCurve

        public QuadCurve​()
        创建一个空的QuadCurve实例。

      • QuadCurve

        public QuadCurve​(double startX,
                 double startY,
                 double controlX,
                 double controlY,
                 double endX,
                 double endY)
        创建一个新的QuadCurve实例。
        参数
        startX - startX的X坐标
        startY - startY的Y坐标
        controlX - 控制点的X坐标
        controlY - 控制点的Y坐标
        endX - 终点的X坐标
        endY - 终点的Y坐标

    • 方法详细信息

      • setStartX

        public final void setStartX​(double value)
        设置属性startX的值。
        Property description:
        定义二次曲线段起始点的X坐标。
        Default value:
        0.0

      • getStartX

        public final double getStartX​()
        获取属性startX的值。
        Property description:
        定义二次曲线段起始点的X坐标。
        Default value:
        0.0

      • startXProperty

        public final DoubleProperty startXProperty​()
        定义二次曲线段起始点的X坐标。
        Default value:
        0.0
        另请参见：
        getStartX() ， setStartX(double)

      • setStartY

        public final void setStartY​(double value)
        设置属性startY的值。
        Property description:
        定义二次曲线段起始点的Y坐标。
        Default value:
        0.0

      • getStartY

        public final double getStartY​()
        获取属性startY的值。
        Property description:
        定义二次曲线段起始点的Y坐标。
        Default value:
        0.0

      • startYProperty

        public final DoubleProperty startYProperty​()
        定义二次曲线段起始点的Y坐标。
        Default value:
        0.0
        另请参见：
        getStartY() ， setStartY(double)

      • setControlX

        public final void setControlX​(double value)
        设置属性controlX的值。
        Property description:
        定义二次曲线段的控制点的X坐标。
        Default value:
        0.0

      • getControlX

        public final double getControlX​()
        获取属性controlX的值。
        Property description:
        定义二次曲线段的控制点的X坐标。
        Default value:
        0.0

      • controlXProperty

        public final DoubleProperty controlXProperty​()
        定义二次曲线段的控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX() ， setControlX(double)

      • setControlY

        public final void setControlY​(double value)
        设置属性controlY的值。
        Property description:
        定义二次曲线段控制点的Y坐标。
        Default value:
        0.0

      • getControlY

        public final double getControlY​()
        获取属性controlY的值。
        Property description:
        定义二次曲线段控制点的Y坐标。
        Default value:
        0.0

      • controlYProperty

        public final DoubleProperty controlYProperty​()
        定义二次曲线段控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY() ， setControlY(double)

      • setEndX

        public final void setEndX​(double value)
        设置属性endX的值。
        Property description:
        定义二次曲线段终点的X坐标。
        Default value:
        0.0

      • getEndX

        public final double getEndX​()
        获取属性endX的值。
        Property description:
        定义二次曲线段终点的X坐标。
        Default value:
        0.0

      • endXProperty

        public final DoubleProperty endXProperty​()
        定义二次曲线段终点的X坐标。
        Default value:
        0.0
        另请参见：
        getEndX() ， setEndX(double)

      • setEndY

        public final void setEndY​(double value)
        设置属性endY的值。
        Property description:
        定义二次曲线段终点的Y坐标。
        Default value:
        0.0

      • getEndY

        public final double getEndY​()
        获取属性endY的值。
        Property description:
        定义二次曲线段终点的Y坐标。
        Default value:
        0.0

      • endYProperty

        public final DoubleProperty endYProperty​()
        定义二次曲线段终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getEndY() ， setEndY(double)

      • toString

        public String toString​()
        返回此 QuadCurve对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这个 QuadCurve对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


QuadCurveTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class QuadCurveTo

  • java.lang.Object
    • javafx.scene.shape.PathElement
      • javafx.scene.shape.QuadCurveTo

  • public class QuadCurveTo
extends PathElement
    通过绘制与当前坐标和指定坐标(x, y)相交的二次曲线曲线，使用指定点(controlX, controlY)作为Bézier控制点，创建由两个新点定义的曲线路径元素。 所有坐标均以双精度指定。

    有关路径元素的更多信息，请参阅Path和PathElement类。

    例：

      import javafx.scene.shape.*;

Path path = new Path();

MoveTo moveTo = new MoveTo();
moveTo.setX(0.0f);
moveTo.setY(50.0f);

QuadCurveTo quadTo = new QuadCurveTo();
quadTo.setControlX(25.0f);
quadTo.setControlY(0.0f);
quadTo.setX(50.0f);
quadTo.setY(50.0f);

path.getElements().add(moveTo);
path.getElements().add(cubicTo);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty controlX
      定义二次控制点的X坐标。
      DoubleProperty controlY
      定义二次控制点的Y坐标。
      DoubleProperty x
      定义最终终点的X坐标。
      DoubleProperty y
      定义最终终点的Y坐标。

      • Properties inherited from class javafx.scene.shape.PathElement

        absolute

    • 构造方法摘要

      构造方法
      Constructor 描述
      QuadCurveTo​()
      创建一个空的QuadCurveTo实例。
      QuadCurveTo​(double controlX, double controlY, double x, double y)
      创建一个新的QuadCurveTo实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty controlXProperty​()
      定义二次控制点的X坐标。
      DoubleProperty controlYProperty​()
      定义二次控制点的Y坐标。
      double getControlX​()
      获取属性controlX的值。
      double getControlY​()
      获取属性controlY的值。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      void setControlX​(double value)
      设置属性controlX的值。
      void setControlY​(double value)
      设置属性controlY的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      String toString​()
      返回此 CubicCurveTo对象的字符串表示形式。
      DoubleProperty xProperty​()
      定义最终终点的X坐标。
      DoubleProperty yProperty​()
      定义最终终点的Y坐标。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.PathElement

        absoluteProperty, isAbsolute, setAbsolute

    • Property Detail

      • controlX

        public final DoubleProperty controlXProperty
        定义二次控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX() ， setControlX(double)

      • controlY

        public final DoubleProperty controlYProperty
        定义二次控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY() ， setControlY(double)

      • x

        public final DoubleProperty xProperty
        定义最终终点的X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义最终终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

    • 构造方法详细信息

      • QuadCurveTo

        public QuadCurveTo​()
        创建一个空的QuadCurveTo实例。

      • QuadCurveTo

        public QuadCurveTo​(double controlX,
                   double controlY,
                   double x,
                   double y)
        创建一个新的QuadCurveTo实例。
        参数
        controlX - 二次控制点的X坐标
        controlY - 二次控制点的Y坐标
        x - 最终终点的X坐标
        y - 最终终点的Y坐标

    • 方法详细信息

      • setControlX

        public final void setControlX​(double value)
        设置属性controlX的值。
        Property description:
        定义二次控制点的X坐标。
        Default value:
        0.0

      • getControlX

        public final double getControlX​()
        获取属性controlX的值。
        Property description:
        定义二次控制点的X坐标。
        Default value:
        0.0

      • controlXProperty

        public final DoubleProperty controlXProperty​()
        定义二次控制点的X坐标。
        Default value:
        0.0
        另请参见：
        getControlX() ， setControlX(double)

      • setControlY

        public final void setControlY​(double value)
        设置属性controlY的值。
        Property description:
        定义二次控制点的Y坐标。
        Default value:
        0.0

      • getControlY

        public final double getControlY​()
        获取属性controlY的值。
        Property description:
        定义二次控制点的Y坐标。
        Default value:
        0.0

      • controlYProperty

        public final DoubleProperty controlYProperty​()
        定义二次控制点的Y坐标。
        Default value:
        0.0
        另请参见：
        getControlY() ， setControlY(double)

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义最终终点的X坐标。
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义最终终点的X坐标。
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        定义最终终点的X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义最终终点的Y坐标。
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义最终终点的Y坐标。
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        定义最终终点的Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • toString

        public String toString​()
        返回此 CubicCurveTo对象的字符串表示形式。
        重写：
        toString中的 Object
        结果
        这个 CubicCurveTo对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Rectangle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Rectangle

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.Rectangle
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Rectangle
extends Shape
    Rectangle类定义了一个具有指定大小和位置的矩形。 默认情况下，矩形具有尖角。 可以通过将arcWidth和arcHeight属性设置为正值(> 0.0)来指定圆角。

    示例代码：以下代码创建一个带20个像素圆角的矩形。

      import javafx.scene.shape.*;

Rectangle r = new Rectangle();
r.setX(50);
r.setY(50);
r.setWidth(200);
r.setHeight(100);
r.setArcWidth(20);
r.setArcHeight(20);
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty arcHeight
      定义矩形四角的圆弧的垂直直径。
      DoubleProperty arcWidth
      定义矩形四角的圆弧的水平直径。
      DoubleProperty height
      定义矩形的高度。
      DoubleProperty width
      定义矩形的宽度。
      DoubleProperty x
      定义矩形左上角的X坐标。
      DoubleProperty y
      定义矩形左上角的Y坐标。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Rectangle​()
      创建一个空的Rectangle实例。
      Rectangle​(double width, double height)
      用给定的大小创建一个新的Rectangle实例。
      Rectangle​(double x, double y, double width, double height)
      用给定的位置和大小创建一个新的Rectangle实例。
      Rectangle​(double width, double height, Paint fill)
      用给定的大小和填充创建一个新的Rectangle实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      DoubleProperty arcHeightProperty​()
      定义矩形四角的圆弧的垂直直径。
      DoubleProperty arcWidthProperty​()
      定义矩形四角的圆弧的水平直径。
      double getArcHeight​()
      获取属性arcHeight的值。
      double getArcWidth​()
      获取属性arcWidth的值。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      double getHeight​()
      获取属性高度的值。
      double getWidth​()
      获取属性宽度的值。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      DoubleProperty heightProperty​()
      定义矩形的高度。
      void setArcHeight​(double value)
      设置属性arcHeight的值。
      void setArcWidth​(double value)
      设置属性arcWidth的值。
      void setHeight​(double value)
      设置属性高度的值。
      void setWidth​(double value)
      设置属性宽度的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      String toString​()
      返回此 Rectangle对象的字符串表示形式。
      DoubleProperty widthProperty​()
      定义矩形的宽度。
      DoubleProperty xProperty​()
      定义矩形左上角的X坐标。
      DoubleProperty yProperty​()
      定义矩形左上角的Y坐标。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • x

        public final DoubleProperty xProperty
        定义矩形左上角的X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义矩形左上角的Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • width

        public final DoubleProperty widthProperty
        定义矩形的宽度。
        Default value:
        0.0
        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final DoubleProperty heightProperty
        定义矩形的高度。
        Default value:
        0.0
        另请参见：
        getHeight() ， setHeight(double)

      • arcWidth

        public final DoubleProperty arcWidthProperty
        定义矩形四角的圆弧的水平直径。 当且仅当弧宽和弧高度属性都大于0.0时，矩形将具有圆角。
        Default value:
        0.0
        另请参见：
        getArcWidth() ， setArcWidth(double)

      • arcHeight

        public final DoubleProperty arcHeightProperty
        定义矩形四角的圆弧的垂直直径。 当且仅当弧宽和弧高度属性都大于0.0时，矩形将具有圆角。
        Default value:
        0.0
        另请参见：
        getArcHeight() ， setArcHeight(double)

    • 构造方法详细信息

      • Rectangle

        public Rectangle​()
        创建一个空的Rectangle实例。

      • Rectangle

        public Rectangle​(double width,
                 double height)
        用给定的大小创建一个新的Rectangle实例。
        参数
        width - 矩形的宽度
        height - 矩形的高度

      • Rectangle

        public Rectangle​(double width,
                 double height,
                 Paint fill)
        用给定的大小和填充创建一个新的Rectangle实例。
        参数
        width - 矩形的宽度
        height - 矩形的高度
        fill - 确定如何填充矩形的内部

      • Rectangle

        public Rectangle​(double x,
                 double y,
                 double width,
                 double height)
        用给定的位置和大小创建一个新的Rectangle实例。
        参数
        x - 矩形的水平位置
        y - 矩形的垂直位置
        width - 矩形的宽度
        height - 矩形的高度

    • 方法详细信息

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义矩形左上角的X坐标。
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义矩形左上角的X坐标。
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        定义矩形左上角的X坐标。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义矩形左上角的Y坐标。
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义矩形左上角的Y坐标。
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        定义矩形左上角的Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        定义矩形的宽度。
        Default value:
        0.0

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        定义矩形的宽度。
        Default value:
        0.0

      • widthProperty

        public final DoubleProperty widthProperty​()
        定义矩形的宽度。
        Default value:
        0.0
        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        定义矩形的高度。
        Default value:
        0.0

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        定义矩形的高度。
        Default value:
        0.0

      • heightProperty

        public final DoubleProperty heightProperty​()
        定义矩形的高度。
        Default value:
        0.0
        另请参见：
        getHeight() ， setHeight(double)

      • setArcWidth

        public final void setArcWidth​(double value)
        设置属性arcWidth的值。
        Property description:
        定义矩形四角的圆弧的水平直径。 当且仅当弧宽和弧高度属性都大于0.0时，矩形将具有圆角。
        Default value:
        0.0

      • getArcWidth

        public final double getArcWidth​()
        获取属性arcWidth的值。
        Property description:
        定义矩形四角的圆弧的水平直径。 当且仅当弧宽和弧高度属性都大于0.0时，矩形将具有圆角。
        Default value:
        0.0

      • arcWidthProperty

        public final DoubleProperty arcWidthProperty​()
        定义矩形四角的圆弧的水平直径。 当且仅当弧宽和弧高度属性都大于0.0时，矩形将具有圆角。
        Default value:
        0.0
        另请参见：
        getArcWidth() ， setArcWidth(double)

      • setArcHeight

        public final void setArcHeight​(double value)
        设置属性arcHeight的值。
        Property description:
        定义矩形四角的圆弧的垂直直径。 当且仅当弧宽和弧高度属性都大于0.0时，矩形将具有圆角。
        Default value:
        0.0

      • getArcHeight

        public final double getArcHeight​()
        获取属性arcHeight的值。
        Property description:
        定义矩形四角的圆弧的垂直直径。 当且仅当弧宽和弧高度属性都大于0.0时，矩形将具有圆角。
        Default value:
        0.0

      • arcHeightProperty

        public final DoubleProperty arcHeightProperty​()
        定义矩形四角的圆弧的垂直直径。 当且仅当弧宽和弧高度属性都大于0.0时，矩形将具有圆角。
        Default value:
        0.0
        另请参见：
        getArcHeight() ， setArcHeight(double)

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Shape
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • toString

        public String toString​()
        返回此 Rectangle对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这是一个 Rectangle对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Shape3D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Shape3D

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape3D
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    Box ， Cylinder ， MeshView ， Sphere

    public abstract class Shape3D
extends Node
    Shape3D基类为表示某种形式的3D几何形状的对象提供了常用属性的定义。 这些属性包括：
    • Material应用于形状或形状轮廓的可填充内部（见setMaterial(javafx.scene.paint.Material) ）。
    • 绘制模型属性定义如何渲染其几何（参见setDrawMode(javafx.scene.shape.DrawMode) ）。
    • 脸剔除属性定义了哪一个面对剔除（见setCullFace(javafx.scene.shape.CullFace) ）。
    请注意，这是一个条件功能。 有关详细信息，请参阅ConditionalFeature.SCENE3D 。

    应用程序不应该直接扩展Shape3D类。 否则可能导致抛出UnsupportedOperationException异常。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<CullFace> cullFace
      定义cullFace这 Shape3D 。
      ObjectProperty<DrawMode> drawMode
      定义用于渲染 Shape3D的绘制模式。
      ObjectProperty<Material> material
      定义材料 Shape3D 。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | Shape3D​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<CullFace> cullFaceProperty​()
      定义cullFace这 Shape3D 。
      ObjectProperty<DrawMode> drawModeProperty​()
      定义用于渲染 Shape3D的绘制模式。
      CullFace getCullFace​()
      获取属性cullFace的值。
      DrawMode getDrawMode​()
      获取属性drawMode的值。
      Material getMaterial​()
      获取物业资料的价值。
      ObjectProperty<Material> materialProperty​()
      定义材料 Shape3D 。
      void setCullFace​(CullFace value)
      设置属性cullFace的值。
      void setDrawMode​(DrawMode value)
      设置属性drawMode的值。
      void setMaterial​(Material value)
      设置属性材质的值。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • material

        public final ObjectProperty<Material> materialProperty
        定义材料Shape3D 。 默认资料为null。 如果Material为null，则使用Color.LIGHTGRAY的漫反射颜色的PhongMaterial进行渲染。
        Default value:
        空值
        另请参见：
        getMaterial() ， setMaterial(Material)

      • drawMode

        public final ObjectProperty<DrawMode> drawModeProperty
        定义绘制模式用于渲染Shape3D 。 DrawMode.LINE在嵌入式平台上不可用。 如果drawMode设置为DrawMode.LINE的嵌入式平台上的默认值DrawMode.FILL将被用来代替。
        Default value:
        DrawMode.FILL
        另请参见：
        getDrawMode() ， setDrawMode(DrawMode)

      • cullFace

        public final ObjectProperty<CullFace> cullFaceProperty
        定义cullFace这 Shape3D 。
        Default value:
        CullFace.BACK
        另请参见：
        getCullFace() ， setCullFace(CullFace)

    • 构造方法详细信息

      • Shape3D

        protected Shape3D​()

    • 方法详细信息

      • setMaterial

        public final void setMaterial​(Material value)
        设置属性材质的值。
        Property description:
        定义材料Shape3D 。 默认资料为null。 如果Material为null，则使用Color.LIGHTGRAY的漫反射颜色的PhongMaterial进行渲染。
        Default value:
        空值

      • getMaterial

        public final Material getMaterial​()
        获取物业资料的价值。
        Property description:
        定义材料Shape3D 。 默认资料为null。 如果Material为null，则使用Color.LIGHTGRAY的漫反射颜色的PhongMaterial进行渲染。
        Default value:
        空值

      • materialProperty

        public final ObjectProperty<Material> materialProperty​()
        定义材料Shape3D 。 默认资料为null。 如果Material为null，则使用Color.LIGHTGRAY的漫反射颜色的PhongMaterial进行渲染。
        Default value:
        空值
        另请参见：
        getMaterial() ， setMaterial(Material)

      • setDrawMode

        public final void setDrawMode​(DrawMode value)
        设置属性drawMode的值。
        Property description:
        定义用于渲染Shape3D的绘制模式。 DrawMode.LINE在嵌入式平台上不可用。 如果drawMode设置为DrawMode.LINE的嵌入式平台上的默认值DrawMode.FILL将被用来代替。
        Default value:
        DrawMode.FILL

      • getDrawMode

        public final DrawMode getDrawMode​()
        获取属性drawMode的值。
        Property description:
        定义用于渲染Shape3D的绘制模式。 DrawMode.LINE在嵌入式平台上不可用。 如果drawMode设置为DrawMode.LINE的嵌入式平台上的默认值DrawMode.FILL将被用来代替。
        Default value:
        DrawMode.FILL

      • drawModeProperty

        public final ObjectProperty<DrawMode> drawModeProperty​()
        定义绘制模式用于渲染Shape3D 。 DrawMode.LINE在嵌入式平台上不可用。 如果drawMode设置为DrawMode.LINE的嵌入式平台上的默认值DrawMode.FILL将被用来代替。
        Default value:
        DrawMode.FILL
        另请参见：
        getDrawMode() ， setDrawMode(DrawMode)

      • setCullFace

        public final void setCullFace​(CullFace value)
        设置属性cullFace的值。
        Property description:
        定义cullFace这 Shape3D 。
        Default value:
        CullFace.BACK

      • getCullFace

        public final CullFace getCullFace​()
        获取属性cullFace的值。
        Property description:
        定义cullFace这 Shape3D 。
        Default value:
        CullFace.BACK

      • cullFaceProperty

        public final ObjectProperty<CullFace> cullFaceProperty​()
        定义cullFace这 Shape3D 。
        Default value:
        CullFace.BACK
        另请参见：
        getCullFace() ， setCullFace(CullFace)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Shape (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Shape

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
  • All Implemented Interfaces:
    Styleable ， EventTarget
    已知直接子类：
    Arc ， Circle ， CubicCurve ， Ellipse ， Line ， Path ， Polygon ， Polyline ， QuadCurve ， Rectangle ， SVGPath ， Text

    public abstract class Shape
extends Node
    Shape类为表示某种形式的几何形状的对象提供了常见属性的定义。 这些属性包括：
    • Paint应用于形状的可填充内部（见setFill ）。
    • 的Paint要被施加到行程中的形状的轮廓（参见setStroke ）。
    • 中风的装饰性，包括：
      • 边框行程的宽度。
      • 是否将边框作为外形填充到形状的边缘，作为沿着边框内部的内部边缘，或者沿着跨越边界的宽的路径跨越其内部和外部（参见StrokeType ）。
      • 路径段和路径未封闭端之间的连接的装饰风格。
      • 冲击属性。

    应用程序不应该直接扩展Shape类。 否则可能导致抛出UnsupportedOperationException异常。

    与坐标系的交互

    大多数节点往往只应用整数翻译，而且常常使用整数坐标来定义。 对于这种常见情况，直线边缘的形状的填充倾向于变脆，因为它们与落在整数设备坐标上的像素之间的裂缝排列，因此倾向于自然地覆盖整个像素。

    另一方面，抚摸这些相同的形状通常会导致模糊的轮廓，因为默认的抚摸属性既指定了默认行程宽度也是1.0坐标，这些坐标通常映射到正好1个设备像素，并且笔画应该跨越形状的边界，在边界两边下降一半。 由于许多常见形状的边界倾向于直接落在整数坐标上，并且这些整数坐标经常精确地映射到整数设备位置，所以边界倾向于导致形状边界任一侧上的像素行和列的50％覆盖而不是100％的覆盖在一个或另一个。 因此，填充物通常可以是清脆的，但是中风通常是模糊的。

    避免这些模糊轮廓的两个常见解决方案是使用更宽的笔画来覆盖更多的像素 - 通常如果没有刻度变换有效，通常笔触宽度为2.0，或者指定StrokeType.INSIDE或StrokeType.OUTSIDE笔触样式将默认单个单位笔画偏置在形状边框的内部或外部的完整像素行或列之一上。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Paint> fill
      使用 Paint上下文的设置定义填充 Shape内部的参数。
      BooleanProperty smooth
      定义 Shape是否使用抗锯齿提示。
      DoubleProperty strokeDashOffset
      定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。
      ObjectProperty<StrokeLineCap> strokeLineCap
      如此端盖风格 Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并 StrokeLineCap.SQUARE 。
      ObjectProperty<StrokeLineJoin> strokeLineJoin
      定义路径段相遇时应用的装饰。
      DoubleProperty strokeMiterLimit
      定义 StrokeLineJoin.MITER线连接样式的限制。
      ObjectProperty<Paint> stroke
      使用指定的 Paint的设置定义 Shape轮廓周围绘制的笔画参数。
      ObjectProperty<StrokeType> strokeType
      定义将strokeWidth应用于形状边界的方向（内部，中心或外部）。
      DoubleProperty strokeWidth
      定义方形笔线宽度。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Shape​()
      创建一个空的Shape实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ObjectProperty<Paint> fillProperty​()
      使用 Paint上下文的设置定义填充 Shape内部的参数。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      Paint getFill​()
      获取属性填充的值。
      Paint getStroke​()
      获取属性笔画的值。
      ObservableList<Double> getStrokeDashArray​()
      定义表示短划线段长度的数组。
      double getStrokeDashOffset​()
      获取属性strokeDashOffset的值。
      StrokeLineCap getStrokeLineCap​()
      获取属性strokeLineCap的值。
      StrokeLineJoin getStrokeLineJoin​()
      获取属性strokeLineJoin的值。
      double getStrokeMiterLimit​()
      获取属性strokeMiterLimit的值。
      StrokeType getStrokeType​()
      获取属性strokeType的值。
      double getStrokeWidth​()
      获取属性strokeWidth的值。
      static Shape intersect​(Shape shape1, Shape shape2)
      返回一个新的 Shape ，它被创建为指定输入形状的交集。
      boolean isSmooth​()
      获取属性的值平滑。
      void setFill​(Paint value)
      设置属性填充的值。
      void setSmooth​(boolean value)
      设置属性的值平滑。
      void setStroke​(Paint value)
      设置属性笔画的值。
      void setStrokeDashOffset​(double value)
      设置属性strokeDashOffset的值。
      void setStrokeLineCap​(StrokeLineCap value)
      设置属性strokeLineCap的值。
      void setStrokeLineJoin​(StrokeLineJoin value)
      设置属性strokeLineJoin的值。
      void setStrokeMiterLimit​(double value)
      设置属性strokeMiterLimit的值。
      void setStrokeType​(StrokeType value)
      设置属性strokeType的值。
      void setStrokeWidth​(double value)
      设置属性strokeWidth的值。
      BooleanProperty smoothProperty​()
      定义 Shape是否使用抗锯齿提示。
      DoubleProperty strokeDashOffsetProperty​()
      定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。
      ObjectProperty<StrokeLineCap> strokeLineCapProperty​()
      如此端盖风格 Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并 StrokeLineCap.SQUARE 。
      ObjectProperty<StrokeLineJoin> strokeLineJoinProperty​()
      定义路径段相遇时应用的装饰。
      DoubleProperty strokeMiterLimitProperty​()
      定义 StrokeLineJoin.MITER线连接样式的限制。
      ObjectProperty<Paint> strokeProperty​()
      使用指定的 Paint的设置定义围绕 Shape轮廓绘制的笔画的参数。
      ObjectProperty<StrokeType> strokeTypeProperty​()
      定义将strokeWidth应用于形状边界的方向（内部，中心或外部）。
      DoubleProperty strokeWidthProperty​()
      定义方形笔线宽度。
      static Shape subtract​(Shape shape1, Shape shape2)
      返回一个新的 Shape ，它是通过从第一个形状中减去指定的第二个形状创建的。
      static Shape union​(Shape shape1, Shape shape2)
      返回一个新的 Shape ，它被创建为指定输入形状的并集。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • strokeType

        public final ObjectProperty<StrokeType> strokeTypeProperty
        定义将strokeWidth应用于形状边界的方向（内部，中心或外部）。

        该图像显示没有笔画的形状，并且内部，中心和外部具有较厚的笔画。

        Default value:
        CENTERED
        另请参见：
        getStrokeType() ， setStrokeType(StrokeType)

      • strokeWidth

        public final DoubleProperty strokeWidthProperty
        定义方形笔线宽度。 值0.0表示发丝中风。 小于0.0的值将被视为0.0。
        Default value:
        1.0
        另请参见：
        getStrokeWidth() ， setStrokeWidth(double)

      • strokeLineJoin

        public final ObjectProperty<StrokeLineJoin> strokeLineJoinProperty
        定义路径段相遇时应用的装饰。 值必须具有以下值之一： StrokeLineJoin.MITER ， StrokeLineJoin.BEVEL ，并StrokeLineJoin.ROUND 。 图像显示使用上述顺序的值的形状。

        Default value:
        迈特
        另请参见：
        getStrokeLineJoin() ， setStrokeLineJoin(StrokeLineJoin)

      • strokeLineCap

        public final ObjectProperty<StrokeLineCap> strokeLineCapProperty
        如此端盖风格Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并StrokeLineCap.SQUARE 。 图像显示使用上述顺序的值的行。

        Default value:
        广场
        另请参见：
        getStrokeLineCap() ， setStrokeLineCap(StrokeLineCap)

      • strokeMiterLimit

        public final DoubleProperty strokeMiterLimitProperty
        定义StrokeLineJoin.MITER线连接样式的限制。 小于1.0的值将被视为1.0。

        该图像演示了行为。 计算斜角长度（ A ）作为关节的最内侧点到最外侧点的距离，以行程宽度为单位。 如果斜角长度大于给定斜角极限，则在形状边缘切割斜角（ B ）。 对于图像中的情况，这意味着对于小于B的极限值，斜角将被切割为4.65 。

        Default value:
        10.0
        另请参见：
        getStrokeMiterLimit() ， setStrokeMiterLimit(double)

      • strokeDashOffset

        public final DoubleProperty strokeDashOffsetProperty
        定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。 换句话说，虚线阶段定义了冲击模式中对应于笔画开头的点。

        该图像显示具有仪表阵列[25, 20, 5, 20]的行程和具有相同图案和偏移量45的行程，其移动关于第一虚线段的长度的模式和随后的空间。

        Default value:
        0
        另请参见：
        getStrokeDashOffset() ， setStrokeDashOffset(double)

      • fill

        public final ObjectProperty<Paint> fillProperty
        使用Paint上下文的设置定义填充Shape内部的参数。 除Line，Polyline和Path之外的所有形状的默认值为Color.BLACK 。 这些形状的默认值为null 。
        另请参见：
        getFill() ， setFill(Paint)

      • stroke

        public final ObjectProperty<Paint> strokeProperty
        使用指定的Paint的设置定义围绕Shape轮廓绘制的笔触的参数。 除Line，Polyline和Path之外的所有形状的默认值为null 。 这些形状的默认值为Color.BLACK 。
        另请参见：
        getStroke() ， setStroke(Paint)

      • smooth

        public final BooleanProperty smoothProperty
        定义Shape是否使用抗锯齿提示。 如果值等于true，则应用渲染提示。
        Default value:
        真正
        另请参见：
        isSmooth() ， setSmooth(boolean)

    • 构造方法详细信息

      • Shape

        public Shape​()
        创建一个空的Shape实例。

    • 方法详细信息

      • setStrokeType

        public final void setStrokeType​(StrokeType value)
        设置属性strokeType的值。
        Property description:
        定义将strokeWidth应用于形状边界的方向（内部，中心或外部）。

        该图像显示没有笔画的形状，并且内部，中心和外部具有较厚的笔画。

        Default value:
        CENTERED

      • getStrokeType

        public final StrokeType getStrokeType​()
        获取属性strokeType的值。
        Property description:
        定义将strokeWidth应用于形状边界的方向（内部，中心或外部）。

        该图像显示没有笔画的形状，并且内部，中心和外部具有较厚的笔画。

        Default value:
        CENTERED

      • strokeTypeProperty

        public final ObjectProperty<StrokeType> strokeTypeProperty​()
        定义将strokeWidth应用于形状边界的方向（内部，中心或外部）。

        该图像显示没有笔画的形状，并且内部，中心和外部具有较厚的笔画。

        Default value:
        CENTERED
        另请参见：
        getStrokeType() ， setStrokeType(StrokeType)

      • setStrokeWidth

        public final void setStrokeWidth​(double value)
        设置属性strokeWidth的值。
        Property description:
        定义方形笔线宽度。 值0.0表示发丝中风。 小于0.0的值将被视为0.0。
        Default value:
        1.0

      • getStrokeWidth

        public final double getStrokeWidth​()
        获取属性strokeWidth的值。
        Property description:
        定义方形笔线宽度。 值0.0表示发丝中风。 小于0.0的值将被视为0.0。
        Default value:
        1.0

      • strokeWidthProperty

        public final DoubleProperty strokeWidthProperty​()
        定义方形笔线宽度。 值0.0表示发丝中风。 小于0.0的值将被视为0.0。
        Default value:
        1.0
        另请参见：
        getStrokeWidth() ， setStrokeWidth(double)

      • setStrokeLineJoin

        public final void setStrokeLineJoin​(StrokeLineJoin value)
        设置属性strokeLineJoin的值。
        Property description:
        定义路径段相遇时应用的装饰。 值必须具有以下值之一： StrokeLineJoin.MITER ， StrokeLineJoin.BEVEL ，并StrokeLineJoin.ROUND 。 图像显示使用上述顺序的值的形状。

        Default value:
        迈特

      • getStrokeLineJoin

        public final StrokeLineJoin getStrokeLineJoin​()
        获取属性strokeLineJoin的值。
        Property description:
        定义路径段相遇时应用的装饰。 值必须具有以下值之一： StrokeLineJoin.MITER ， StrokeLineJoin.BEVEL ，并StrokeLineJoin.ROUND 。 图像显示使用上述顺序的值的形状。

        Default value:
        迈特

      • strokeLineJoinProperty

        public final ObjectProperty<StrokeLineJoin> strokeLineJoinProperty​()
        定义路径段相遇时应用的装饰。 值必须具有以下值之一： StrokeLineJoin.MITER ， StrokeLineJoin.BEVEL ，并StrokeLineJoin.ROUND 。 图像显示使用上述顺序的值的形状。

        Default value:
        迈特
        另请参见：
        getStrokeLineJoin() ， setStrokeLineJoin(StrokeLineJoin)

      • setStrokeLineCap

        public final void setStrokeLineCap​(StrokeLineCap value)
        设置属性strokeLineCap的值。
        Property description:
        如此端盖风格Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并StrokeLineCap.SQUARE 。 图像显示使用上述顺序的值的行。

        Default value:
        广场

      • getStrokeLineCap

        public final StrokeLineCap getStrokeLineCap​()
        获取属性strokeLineCap的值。
        Property description:
        如此端盖风格Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并StrokeLineCap.SQUARE 。 图像显示使用上述顺序的值的行。

        Default value:
        广场

      • strokeLineCapProperty

        public final ObjectProperty<StrokeLineCap> strokeLineCapProperty​()
        如此端盖风格Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并StrokeLineCap.SQUARE 。 图像显示使用上述顺序的值的行。

        Default value:
        广场
        另请参见：
        getStrokeLineCap() ， setStrokeLineCap(StrokeLineCap)

      • setStrokeMiterLimit

        public final void setStrokeMiterLimit​(double value)
        设置属性strokeMiterLimit的值。
        Property description:
        定义StrokeLineJoin.MITER线连接样式的限制。 小于1.0的值将被视为1.0。

        该图像演示了行为。 计算斜角长度（ A ）作为关节的最内侧点到最外侧点的距离，以行程宽度为单位。 如果斜角长度大于给定斜角极限，则在形状边缘切割斜角（ B ）。 对于图像中的情况，这意味着对于小于B的极限值，斜角将被切割为4.65 。

        Default value:
        10.0

      • getStrokeMiterLimit

        public final double getStrokeMiterLimit​()
        获取属性strokeMiterLimit的值。
        Property description:
        定义StrokeLineJoin.MITER线连接样式的限制。 小于1.0的值将被视为1.0。

        该图像演示了行为。 计算斜角长度（ A ）作为关节的最内侧点到最外侧点的距离，以行程宽度为单位。 如果斜角长度大于给定斜角极限，则在形状边缘切割斜角（ B ）。 对于图像中的情况，这意味着对于小于B的极限值，斜角将被切割为4.65 。

        Default value:
        10.0

      • strokeMiterLimitProperty

        public final DoubleProperty strokeMiterLimitProperty​()
        定义StrokeLineJoin.MITER线连接样式的限制。 小于1.0的值将被视为1.0。

        该图像演示了行为。 计算斜角长度（ A ）作为关节的最内侧点到最外侧点的距离，以行程宽度为单位。 如果斜角长度大于给定斜角极限，则在形状边缘切割斜角（ B ）。 对于图像中的情况，这意味着对于小于B的极限值，斜角将被切割为4.65 。

        Default value:
        10.0
        另请参见：
        getStrokeMiterLimit() ， setStrokeMiterLimit(double)

      • setStrokeDashOffset

        public final void setStrokeDashOffset​(double value)
        设置属性strokeDashOffset的值。
        Property description:
        定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。 换句话说，虚线阶段定义了冲击模式中对应于笔画开头的点。

        该图像显示具有仪表阵列[25, 20, 5, 20]的行程和具有相同图案和偏移量45的行程，其移动关于第一虚线段的长度和随后的空间的图案。

        Default value:
        0

      • getStrokeDashOffset

        public final double getStrokeDashOffset​()
        获取属性strokeDashOffset的值。
        Property description:
        定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。 换句话说，虚线阶段定义了冲击模式中对应于笔画开头的点。

        该图像显示具有仪表阵列[25, 20, 5, 20]的冲程和具有相同图案和偏移的45 ，其移动关于第一虚线段的长度和随后的空间的图案。

        Default value:
        0

      • strokeDashOffsetProperty

        public final DoubleProperty strokeDashOffsetProperty​()
        定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。 换句话说，虚线阶段定义了冲击模式中对应于笔画开头的点。

        该图像显示具有仪表阵列[25, 20, 5, 20]的冲程和具有相同图案和偏移的45 ，其移动关于第一虚线段的长度和随后的空间的图案。

        Default value:
        0
        另请参见：
        getStrokeDashOffset() ， setStrokeDashOffset(double)

      • getStrokeDashArray

        public final ObservableList<Double> getStrokeDashArray​()
        定义表示短划线段长度的数组。 数组中的备用条目表示破折号的不透明和透明段的用户空间长度。 当笔沿着要抚摸的Shape的轮廓移动时，笔的行进的用户空间距离被累积。 距离值用于索引到仪表盘阵列中。 当笔的当前累积距离映射到仪表阵列的偶数元素（从0计数）时，笔是不透明的，否则为透明度。

        空的strokeDashArray表示没有空格的实线。 奇数长度strokeDashArray的行为与通过连续两次隐含地重复指示的奇数长度数组构造的偶数长度数组相同（ [20, 5, 15]表现为[20, 5, 15, 20, 5, 15] ）。

        请注意，每个破折号段将被当前行程行上限指定的装饰上限。

        该图像示出与中风虚线数组的形状[25, 20, 5, 20]和用于笔画线盖3个不同的值： StrokeLineCap.BUTT ， StrokeLineCap.SQUARE （默认值），并且StrokeLineCap.ROUND

        Default value:
        空
        结果
        该数组表示短划线段的长度

      • setFill

        public final void setFill​(Paint value)
        设置属性填充的值。
        Property description:
        使用Paint上下文的设置定义填充Shape内部的参数。 除Line，Polyline和Path之外的所有形状的默认值为Color.BLACK 。 这些形状的默认值为null 。

      • getFill

        public final Paint getFill​()
        获取属性填充的值。
        Property description:
        使用Paint上下文的设置定义填充Shape内部的参数。 除Line，Polyline和Path之外的所有形状的默认值为Color.BLACK 。 这些形状的默认值为null 。

      • fillProperty

        public final ObjectProperty<Paint> fillProperty​()
        使用Paint上下文的设置定义填充Shape内部的参数。 除Line，Polyline和Path之外的所有形状的默认值为Color.BLACK 。 这些形状的默认值为null 。
        另请参见：
        getFill() ， setFill(Paint)

      • setStroke

        public final void setStroke​(Paint value)
        设置属性笔画的值。
        Property description:
        使用指定的Paint的设置定义围绕Shape轮廓绘制的笔触的参数。 除Line，Polyline和Path之外的所有形状的默认值为null 。 这些形状的默认值为Color.BLACK 。

      • getStroke

        public final Paint getStroke​()
        获取属性笔画的值。
        Property description:
        使用指定的Paint的设置定义围绕Shape轮廓绘制的笔触的参数。 除Line，Polyline和Path之外的所有形状的默认值为null 。 这些形状的默认值为Color.BLACK 。

      • strokeProperty

        public final ObjectProperty<Paint> strokeProperty​()
        使用指定的Paint的设置定义围绕Shape轮廓绘制的笔触的参数。 除Line，Polyline和Path之外的所有形状的默认值为null 。 这些形状的默认值为Color.BLACK 。
        另请参见：
        getStroke() ， setStroke(Paint)

      • setSmooth

        public final void setSmooth​(boolean value)
        设置属性的值平滑。
        Property description:
        定义Shape是否使用抗锯齿提示。 如果值等于true，则应用渲染提示。
        Default value:
        真正

      • isSmooth

        public final boolean isSmooth​()
        获取属性的值平滑。
        Property description:
        定义Shape是否使用抗锯齿提示。 如果值等于true，则应用渲染提示。
        Default value:
        真正

      • smoothProperty

        public final BooleanProperty smoothProperty​()
        定义Shape是否使用抗锯齿提示。 如果值等于true，则应用渲染提示。
        Default value:
        真正
        另请参见：
        isSmooth() ， setSmooth(boolean)

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Node
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • union

        public static Shape union​(Shape shape1,
                          Shape shape2)
        返回一个新的Shape ，它被创建为指定输入形状的并集。

        该操作适用于输入形状占据的几何区域。 对于单个Shape ，如果形状具有非空填充，则该区域包括填充所占据的面积，以及如果形状具有非空行程，则该区域由笔画占据的面积。 所以这个区域是空的一个形状与null笔画和null填充。 由操作考虑的输入形状的区域与用于填充或冲程的油漆的类型和构造无关。 在最终操作之前，将输入形状的区域变换到它们各自最顶层的父节点的父坐标空间。

        所得到的形状将包括任何输入形状中包含的区域。

          shape1       +       shape2       =       result
   +----------------+   +----------------+   +----------------+
   |################|   |################|   |################|
   |##############  |   |  ##############|   |################|
   |############    |   |    ############|   |################|
   |##########      |   |      ##########|   |################|
   |########        |   |        ########|   |################|
   |######          |   |          ######|   |######    ######|
   |####            |   |            ####|   |####        ####|
   |##              |   |              ##|   |##            ##|
   +----------------+   +----------------+   +----------------+
        参数
        shape1 - 第一个形状
        shape2 - 第二个形状
        结果
        创建的 Shape

      • subtract

        public static Shape subtract​(Shape shape1,
                             Shape shape2)
        返回一个新的Shape ，它是通过从第一个形状中减去指定的第二个形状而创建的。

        该操作适用于输入形状占据的几何区域。 对于单个Shape ，如果形状具有非空填充，则该区域包括填充所占据的面积，以及如果形状具有非空行程，则该区域被行程占据的区域。 所以这个区域是空的一个形状与null笔画和null填充。 由操作考虑的输入形状的区域与用于填充或冲程的油漆的类型和构造无关。 在最终操作之前，将输入形状的区域变换到它们各自最顶层的父节点的父坐标空间。

        所形成的形状将包括只包含在第一形状而不是第二形状的区域。

          shape1       -       shape2       =       result
   +----------------+   +----------------+   +----------------+
   |################|   |################|   |                |
   |##############  |   |  ##############|   |##              |
   |############    |   |    ############|   |####            |
   |##########      |   |      ##########|   |######          |
   |########        |   |        ########|   |########        |
   |######          |   |          ######|   |######          |
   |####            |   |            ####|   |####            |
   |##              |   |              ##|   |##              |
   +----------------+   +----------------+   +----------------+
        参数
        shape1 - 第一个形状
        shape2 - 第二个形状
        结果
        创建的 Shape

      • intersect

        public static Shape intersect​(Shape shape1,
                              Shape shape2)
        返回一个新的Shape ，它被创建为指定输入形状的交集。

        该操作适用于输入形状占据的几何区域。 对于单个Shape ，如果形状具有非空填充，则该区域包括填充所占据的面积，以及如果形状具有非空行程，则占据该区域的区域。 所以这个区域是空的一个形状与null笔画和null填充。 由操作考虑的输入形状的区域与用于填充或冲程的油漆的类型和构造无关。 在最终操作之前，将输入形状的区域变换到它们各自最顶层的父节点的父坐标空间。

        所得到的形状将仅包括包含在两个输入形状中的区域。

          shape1       +       shape2       =       result
   +----------------+   +----------------+   +----------------+
   |################|   |################|   |################|
   |##############  |   |  ##############|   |  ############  |
   |############    |   |    ############|   |    ########    |
   |##########      |   |      ##########|   |      ####      |
   |########        |   |        ########|   |                |
   |######          |   |          ######|   |                |
   |####            |   |            ####|   |                |
   |##              |   |              ##|   |                |
   +----------------+   +----------------+   +----------------+
        参数
        shape1 - 第一个形状
        shape2 - 第二个形状
        结果
        the created Shape
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Sphere (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class Sphere

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape3D
        • javafx.scene.shape.Sphere
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class Sphere
extends Shape3D
    Sphere类定义了具有指定大小的三维球体。 A Sphere是用给定半径创建的3D几何图元。 它以起源为中心。
    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty radius
      定义球体的半径。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape3D

        cullFace, drawMode, material

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Sphere​()
      创建半径为1.0的新实例 Sphere 。
      Sphere​(double radius)
      以给定的半径创建一个新的实例 Sphere 。
      Sphere​(double radius, int divisions)
      创建具有给定半径和分割数的新实例 Sphere 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getDivisions​()
      检索用于生成此球体的分区属性。
      double getRadius​()
      获取属性半径的值。
      DoubleProperty radiusProperty​()
      定义球体的半径。
      void setRadius​(double value)
      设置属性半径的值。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClassCssMetaData, getClip, getContentBias, getCssMetaData, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape3D

        cullFaceProperty, drawModeProperty, getCullFace, getDrawMode, getMaterial, materialProperty, setCullFace, setDrawMode, setMaterial

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • radius

        public final DoubleProperty radiusProperty
        定义球体的半径。
        Default value:
        1.0
        另请参见：
        getRadius() ， setRadius(double)

    • 构造方法详细信息

      • Sphere

        public Sphere​()
        创建半径为1.0的新实例Sphere 。 分辨率默认为沿球体轴的64个分区。

      • Sphere

        public Sphere​(double radius)
        创建一个具有给定半径的新实例Sphere 。 分辨率默认为沿球体轴的64个分区。
        参数
        radius - 半径

      • Sphere

        public Sphere​(double radius,
              int divisions)
        创建具有给定半径和分割数的新实例Sphere 。 分辨率是根据球轴的细分数来定义的。 更多的分裂导致更细的细密的物体。 请注意，分区应至少为1.任何小于该值的值将被钳制为1。
        参数
        radius - 半径
        divisions - 部门

    • 方法详细信息

      • setRadius

        public final void setRadius​(double value)
        设置属性半径的值。
        Property description:
        定义球体的半径。
        Default value:
        1.0

      • getRadius

        public final double getRadius​()
        获取属性半径的值。
        Property description:
        定义球体的半径。
        Default value:
        1.0

      • radiusProperty

        public final DoubleProperty radiusProperty​()
        定义球体的半径。
        Default value:
        1.0
        另请参见：
        getRadius() ， setRadius(double)

      • getDivisions

        public int getDivisions​()
        检索用于生成此球体的分区属性。
        结果
        the divisions attribute.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StrokeLineCap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Enum StrokeLineCap

  • java.lang.Object
    • java.lang.Enum<StrokeLineCap>
      • javafx.scene.shape.StrokeLineCap
  • All Implemented Interfaces:
    Serializable ， Comparable<StrokeLineCap>

    public enum StrokeLineCap
extends Enum<StrokeLineCap>
    定义一个 Shape的端帽样式。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BUTT
      结束未封闭的子路径和划线段，没有添加装饰。
      ROUND
      用圆形装饰结束未封闭的子路径和划线段，半圆形的半径等于笔宽的一半。
      SQUARE
      结束未封闭的子路径和划线段，其中方块投影延伸超出段的末端至等于线宽一半的距离。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static StrokeLineCap valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StrokeLineCap[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SQUARE

        public static final StrokeLineCap SQUARE
        结束未封闭的子路径和划线段，其中方块投影延伸超出段的末端至等于线宽一半的距离。

      • BUTT

        public static final StrokeLineCap BUTT
        结束未封闭的子路径和划线段，没有添加装饰。

      • ROUND

        public static final StrokeLineCap ROUND
        用圆形装饰结束未封闭的子路径和划线段，半圆形的半径等于笔宽的一半。

    • 方法详细信息

      • values

        public static StrokeLineCap[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (StrokeLineCap c : StrokeLineCap.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static StrokeLineCap valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


StrokeLineJoin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Enum StrokeLineJoin

  • java.lang.Object
    • java.lang.Enum<StrokeLineJoin>
      • javafx.scene.shape.StrokeLineJoin
  • All Implemented Interfaces:
    Serializable ， Comparable<StrokeLineJoin>

    public enum StrokeLineJoin
extends Enum<StrokeLineJoin>
    定义一个 Shape的行连接样式。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BEVEL
      通过连接其广泛轮廓的外角与直线段来连接路段。
      MITER
      通过延伸它们的外边缘直到它们相遇来连接路段。
      ROUND
      通过以半角宽度的半径舍入角落来连接路径段。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static StrokeLineJoin valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StrokeLineJoin[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MITER

        public static final StrokeLineJoin MITER
        通过延伸它们的外边缘直到它们相遇来连接路段。

      • BEVEL

        public static final StrokeLineJoin BEVEL
        通过连接其广泛轮廓的外角与直线段来连接路段。

      • ROUND

        public static final StrokeLineJoin ROUND
        通过以半角宽度的半径舍入角落来连接路径段。

    • 方法详细信息

      • values

        public static StrokeLineJoin[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (StrokeLineJoin c : StrokeLineJoin.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static StrokeLineJoin valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


StrokeType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Enum StrokeType

  • java.lang.Object
    • java.lang.Enum<StrokeType>
      • javafx.scene.shape.StrokeType
  • All Implemented Interfaces:
    Serializable ， Comparable<StrokeType>

    public enum StrokeType
extends Enum<StrokeType>
    定义在Shape节点的边界周围画画的位置。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Shape

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CENTERED
      行程由加厚的边界施加Shape通过的一半的距离节点strokeWidth在边界的任一侧上。
      INSIDE
      通过将封闭的Shape节点的边界延伸到其内部由strokeWidth指定的距离来应用行程 。
      OUTSIDE
      通过将Shape节点之外的边界的边界延伸到其内部的距离strokeWidth指定的距离来应用冲程 。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static StrokeType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StrokeType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • INSIDE

        public static final StrokeType INSIDE
        通过将关闭的Shape节点的边界延伸到其内部由strokeWidth指定的距离来应用冲程 。 由于INSIDE的定义取决于填充内部的形状，此StrokeType未定义为未封闭的形状。

        该图像显示没有笔触的形状，并且具有相同的形状并且具有较厚的内部笔画。

      • OUTSIDE

        public static final StrokeType OUTSIDE
        通过将270718618292812节点外边缘的边界延伸strokeWidth指定的距离来应用中风 。 由于OUTSIDE的定义取决于形状的填充内部，因此StrokeType未定义为未封闭的形状。

        该图像显示没有笔触的形状，并且具有与外部笔画厚度相同的形状。

      • CENTERED

        public static final StrokeType CENTERED
        行程由加厚的边界施加Shape通过的一半的距离节点strokeWidth在边界的任一侧上。 由于CENETERED的定义与形状的任何内部的位置是对称的和不可知的，所以它可以用于闭合或非闭合形状。

        该图像显示没有笔触的形状，并且具有应用厚中心行程的相同形状。

    • 方法详细信息

      • values

        public static StrokeType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (StrokeType c : StrokeType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static StrokeType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


SVGPath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class SVGPath

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.shape.SVGPath
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class SVGPath
extends Shape
    SVGPath类表示通过从String解析SVG路径数据构建的简单形状。
      import javafx.scene.shape.*;

SVGPath svg = new SVGPath();
svg.setContent("M40,60 C42,48 44,30 25,32");
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      StringProperty content
      定义SVG路径编码字符串，如下所示： http://www.w3.org/TR/SVG/paths.html 。
      ObjectProperty<FillRule> fillRule
      定义用于确定路径内部的填充规则常数。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      SVGPath​()
      创建一个空的SVGPath实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      StringProperty contentProperty​()
      定义SVG路径编码字符串，如下所示： http://www.w3.org/TR/SVG/paths.html 。
      ObjectProperty<FillRule> fillRuleProperty​()
      定义用于确定路径内部的填充规则常数。
      String getContent​()
      获取属性内容的值。
      FillRule getFillRule​()
      获取属性fillRule的值。
      void setContent​(String value)
      设置属性内容的值。
      void setFillRule​(FillRule value)
      设置属性fillRule的值。
      String toString​()
      返回此 SVGPath对象的字符串表示形式。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBaselineOffset, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, queryAccessibleAttribute, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getClassCssMetaData, getCssMetaData, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • fillRule

        public final ObjectProperty<FillRule> fillRuleProperty
        定义用于确定路径内部的填充规则常数。 该值必须是以下常量之一： FillRile.EVEN_ODD或FillRule.NON_ZERO 。 默认值为FillRule.NON_ZERO 。
        Default value:
        FillRule.NON_ZERO
        另请参见：
        getFillRule() ， setFillRule(FillRule)

      • content

        public final StringProperty contentProperty
        定义SVG路径编码字符串，如下所示： http://www.w3.org/TR/SVG/paths.html 。
        Default value:
        空字符串
        另请参见：
        getContent() ， setContent(String)

    • 构造方法详细信息

      • SVGPath

        public SVGPath​()
        创建一个空的SVGPath实例。

    • 方法详细信息

      • setFillRule

        public final void setFillRule​(FillRule value)
        设置属性fillRule的值。
        Property description:
        定义用于确定路径内部的填充规则常数。 该值必须是以下常数之一： FillRile.EVEN_ODD或FillRule.NON_ZERO 。 默认值为FillRule.NON_ZERO 。
        Default value:
        FillRule.NON_ZERO

      • getFillRule

        public final FillRule getFillRule​()
        获取属性fillRule的值。
        Property description:
        定义用于确定路径内部的填充规则常数。 该值必须是以下常量之一： FillRile.EVEN_ODD或FillRule.NON_ZERO 。 默认值为FillRule.NON_ZERO 。
        Default value:
        FillRule.NON_ZERO

      • fillRuleProperty

        public final ObjectProperty<FillRule> fillRuleProperty​()
        定义用于确定路径内部的填充规则常数。 该值必须是以下常量之一： FillRile.EVEN_ODD或FillRule.NON_ZERO 。 默认值为FillRule.NON_ZERO 。
        Default value:
        FillRule.NON_ZERO
        另请参见：
        getFillRule() ， setFillRule(FillRule)

      • setContent

        public final void setContent​(String value)
        设置属性内容的值。
        Property description:
        定义SVG路径编码字符串，如下所示： http://www.w3.org/TR/SVG/paths.html 。
        Default value:
        空字符串

      • getContent

        public final String getContent​()
        获取属性内容的值。
        Property description:
        定义SVG路径编码字符串，如下所示： http://www.w3.org/TR/SVG/paths.html 。
        Default value:
        空字符串

      • contentProperty

        public final StringProperty contentProperty​()
        定义SVG路径编码字符串，如下所示： http://www.w3.org/TR/SVG/paths.html 。
        Default value:
        空字符串
        另请参见：
        getContent() ， setContent(String)

      • toString

        public String toString​()
        返回此 SVGPath对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这是一个 SVGPath对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TriangleMesh (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class TriangleMesh

  • java.lang.Object
    • javafx.scene.shape.Mesh
      • javafx.scene.shape.TriangleMesh

  • public class TriangleMesh
extends Mesh
    定义一个三角形三角形网格，由其相关联的VertexFormat和一组独立的顶点组件阵列组成，例如点，法线，纹理坐标和定义网格的各个三角形的面阵列。

    注意，方法名称和方法描述中使用的术语点实际上是指代表单个顶点的位置的空间中的3D点（x，y，z）。 术语点（复数）用于指示多个顶点的3D点集合。 类似地，术语“法线”用于表示代表单个顶点方向的空间中的三维向量（nx，ny，nz）。 术语“常数”（复数）用于指示多个顶点的3D向量集合。 术语texCoord用于指示单个顶点的单对2D纹理坐标（u，v），而术语texCoords（复数）用于指示多个顶点的纹理坐标集合。 最后，术语face用于指示3组交织点，法线（可选，取决于相关联的VertexFormat）和纹理坐标，它们一起表示单个三角形的几何拓扑，而术语“面（多）”用于指示三角形组（每个由一个面代表）。

    例如，表示使用2个三角形的单个纹理矩形的面为VertexFormat.POINT_TEXCOORD的面具有以下数据顺序：

    p0，t0，p1，t1，p3，t3，//纹理矩形的第一个三角形

    p1，t1，p2，t2，p3，t3 //纹理矩形的第二个三角形

    ]

    而表示使用2个三角形的单个纹理矩形的面为VertexFormat.POINT_NORMAL_TEXCOORD的面具有以下数据顺序：

    p0，n0，t0，p1，n1，t1，p3，n3，t3，//纹理矩形的第一个三角形

    p1，n1，t1，p2，n2，t2，p3，n3，t3 //纹理矩形的第二个三角形

    ]

    其中p0，p1，p2和p3是点阵列中的索引，n0，n1，n2和n3是法线阵列中的索引，t0，t1，t2和t3是texCoords阵列的索引。

    三角形有一个正面和背面。 三角形顶点的绕组顺序决定了哪一面是前脸。 JavaFX选择逆时针（或右手规则）卷绕顺序作为正面。 默认情况下，仅渲染三角形的正面。 有关详细信息，请参阅CullFace 。

    的长度points ， normals和texCoords必须由3,3，和2分别整除。 的长度faces ，如果它是必须是整除6 VertexFormat.POINT_TEXCOORD否则它必须是整除9，如果它是VertexFormat.POINT_NORMAL_TEXCOORD 。 面数组中的值必须在点索引的点数组中的顶点数（0到点。长度/ 3 - 1）的范围内，在法线数组（0）中的顶点数范围内对于正常索引，并且在纹理坐标索引的texCoords数组（0到texCoords.length / 2 - 1）中的顶点数量的范围内，对于normals.length / 3 - 1）。

    如果任何数组长度无效或面阵列中的任何值超出范围，则记录器将记录警告，并且网格不会被渲染（并且将具有空的边界）。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<VertexFormat> vertexFormat
      指定此 TriangleMesh的顶点格式， VertexFormat.POINT_TEXCOORD或 VertexFormat.POINT_NORMAL_TEXCOORD 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TriangleMesh​()
      使用默认的 VertexFormat.POINT_TEXCOORD格式类型创建一个 TriangleMesh类的新实例。
      TriangleMesh​(VertexFormat vertexFormat)
      使用指定的 VertexFormat创建一个 TriangleMesh类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getFaceElementSize​()
      返回表示面部的元素数。
      ObservableFaceArray getFaces​()
      获取 faces阵列，索引到 points ， normals （可选，如果它是一个 VertexFormat.POINT_NORMAL_TEXCOORD目）和 texCoords阵列，此的 TriangleMesh 。
      ObservableIntegerArray getFaceSmoothingGroups​()
      获取此 TriangleMesh的 faceSmoothingGroups数组。
      int getNormalElementSize​()
      返回表示法线的元素数。
      ObservableFloatArray getNormals​()
      获取 normals阵列如此 TriangleMesh 。
      int getPointElementSize​()
      返回表示点的元素数。
      ObservableFloatArray getPoints​()
      获取 points这个 TriangleMesh数组。
      int getTexCoordElementSize​()
      返回表示纹理坐标的元素数。
      ObservableFloatArray getTexCoords​()
      获取此 TriangleMesh的 texCoords数组。
      VertexFormat getVertexFormat​()
      获取属性vertexFormat的值。
      void setVertexFormat​(VertexFormat value)
      设置属性vertexFormat的值。
      ObjectProperty<VertexFormat> vertexFormatProperty​()
      指定 TriangleMesh的顶点格式， VertexFormat.POINT_TEXCOORD或 VertexFormat.POINT_NORMAL_TEXCOORD 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • vertexFormat

        public final ObjectProperty<VertexFormat> vertexFormatProperty
        指定 TriangleMesh的顶点格式， VertexFormat.POINT_TEXCOORD或 VertexFormat.POINT_NORMAL_TEXCOORD 。
        Default value:
        VertexFormat.POINT_TEXCOORD
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getVertexFormat() ， setVertexFormat(VertexFormat)

    • 构造方法详细信息

      • TriangleMesh

        public TriangleMesh​()
        使用默认的 VertexFormat.POINT_TEXCOORD格式类型创建一个 TriangleMesh类的新实例。

      • TriangleMesh

        public TriangleMesh​(VertexFormat vertexFormat)
        使用指定的 VertexFormat创建一个新的 TriangleMesh类的实例。
        参数
        vertexFormat - 指定顶点格式类型。
        从以下版本开始：
        JavaFX 8u40

    • 方法详细信息

      • setVertexFormat

        public final void setVertexFormat​(VertexFormat value)
        设置属性vertexFormat的值。
        Property description:
        指定 TriangleMesh的顶点格式， VertexFormat.POINT_TEXCOORD或 VertexFormat.POINT_NORMAL_TEXCOORD 。
        Default value:
        VertexFormat.POINT_TEXCOORD
        从以下版本开始：
        JavaFX 8u40

      • getVertexFormat

        public final VertexFormat getVertexFormat​()
        获取属性vertexFormat的值。
        Property description:
        指定 TriangleMesh的顶点格式， VertexFormat.POINT_TEXCOORD或 VertexFormat.POINT_NORMAL_TEXCOORD 。
        Default value:
        VertexFormat.POINT_TEXCOORD
        从以下版本开始：
        JavaFX 8u40

      • vertexFormatProperty

        public final ObjectProperty<VertexFormat> vertexFormatProperty​()
        指定 TriangleMesh的顶点格式， VertexFormat.POINT_TEXCOORD或 VertexFormat.POINT_NORMAL_TEXCOORD 。
        Default value:
        VertexFormat.POINT_TEXCOORD
        从以下版本开始：
        JavaFX 8u40
        另请参见：
        getVertexFormat() ， setVertexFormat(VertexFormat)

      • getPointElementSize

        public final int getPointElementSize​()
        返回表示点的元素数。
        结果
        元素数量

      • getNormalElementSize

        public final int getNormalElementSize​()
        返回表示法线的元素数。
        结果
        元素数量
        从以下版本开始：
        JavaFX 8u40

      • getTexCoordElementSize

        public final int getTexCoordElementSize​()
        返回表示纹理坐标的元素数。
        结果
        元素数量

      • getFaceElementSize

        public final int getFaceElementSize​()
        返回表示面部的元素数。
        结果
        元素数量

      • getPoints

        public final ObservableFloatArray getPoints​()
        获取 points这个 TriangleMesh数组。
        结果
        points数组，其中每个点由3个浮点值x，y和z按顺序表示。

      • getNormals

        public final ObservableFloatArray getNormals​()
        获取 normals这个 TriangleMesh数组。
        结果
        normals数组，其中每个法线按顺序由3个浮点值nx，ny和nz表示。
        从以下版本开始：
        JavaFX 8u40

      • getTexCoords

        public final ObservableFloatArray getTexCoords​()
        获取texCoords阵列如此TriangleMesh 。 坐标是比例的，所以纹理的左上角是[0,0]，右下角是[1,1]。
        结果
        texCoord数组，其中每个纹理坐标由2个浮点值表示：u和v， texCoord顺序。

      • getFaces

        public final ObservableFaceArray getFaces​()
        获取faces阵列，索引到points ， normals （可选，如果它是一个VertexFormat.POINT_NORMAL_TEXCOORD目）和texCoords阵列，此的TriangleMesh 。 所有指数都是按照要点，法线或texCoords阵列而不是单个浮标的要素。
        结果
        faces数组，其中每个面都是3 * VertexFormat.getVertexIndexSize()整数。

      • getFaceSmoothingGroups

        public final ObservableIntegerArray getFaceSmoothingGroups​()
        获取faceSmoothingGroups阵列TriangleMesh 。 平滑影响网格呈现的方式，但不影响其几何。 脸部平滑组值用于控制相邻面之间的平滑。

        脸部平滑组值由位阵列表示，最多可以有32个独特的组; （1 << 0）〜（1 << 31）。 脸部平滑组值可以从0（无平滑组）到所有32组的范围。 脸可以属于零个或多个平滑组。 如果设置了位N，则表示组N的成员，例如，组| =（1 << N）。 值为0表示没有平滑组或硬边。 当相邻的一对面共享平滑组时，应用平滑。 否则，脸部之间呈现硬边缘。

        空的faceSmoothingGroups意味着该网格中的所有面都具有平滑组值1。

        如果faceSmoothingGroups不为空，则其大小必须等于面数。

        这faceSmoothingGroups在它没有影响TriangleMesh如果是VertexFormat.POINT_NORMAL_TEXCOORD格式。

        结果
        该 faceSmoothingGroups阵列的 TriangleMesh
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.shape (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.shape

  • Packages that use javafx.scene.shape
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
  • Classes in javafx.scene.shape used by javafx.animation
    Class 描述
    Shape
    Shape类为表示某种形状的几何形状的对象提供了常见属性的定义。
  • Classes in javafx.scene.shape used by javafx.css.converter
    Class 描述
    Shape
    Shape类提供了表示某种形式的几何形状的对象的常用属性的定义。
  • Classes in javafx.scene.shape used by javafx.scene.canvas
    Class 描述
    ArcType
    ArcType指定Arc对象的关闭类型。
    FillRule
    用于确定路径内部的填充规则。
    StrokeLineCap
    定义 Shape的端帽样式。
    StrokeLineJoin
    定义一个 Shape的线连接样式。
  • Classes in javafx.scene.shape used by javafx.scene.control.skin
    Class 描述
    PathElement
    所述PathElement类表示的一个抽象元素Path能够表示像直线，圆弧，二次曲线，三次曲线等的任何几何对象
  • Classes in javafx.scene.shape used by javafx.scene.layout
    Class 描述
    Shape
    Shape类为表示某种形式的几何形状的对象提供了常见属性的定义。
    StrokeLineCap
    定义一个 Shape的端帽样式。
    StrokeLineJoin
    定义一个 Shape的线连接样式。
    StrokeType
    定义在Shape节点的边界周围画画的位置。
  • Classes in javafx.scene.shape used by javafx.scene.shape
    Class 描述
    ArcType
    ArcType指定Arc对象的关闭类型。
    CullFace
    面部剔除设置与 Shape3D.cullFace一起使用
    DrawMode
    定义与 Shape3D.drawMode使用时如何绘制多边形
    FillRule
    用于确定路径内部的填充规则。
    Mesh
    用于表示3D几何表面的基类。
    ObservableFaceArray
    ObservableFaceArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
    PathElement
    所述PathElement类表示的一个抽象元素Path能够表示像直线，圆弧，二次曲线，三次曲线等的任何几何对象
    Shape
    Shape类为表示某种形式的几何形状的对象提供了常用属性的定义。
    Shape3D
    Shape3D基类为表示某种形式的3D几何形状的对象提供了常见属性的定义。
    StrokeLineCap
    定义一个 Shape的端帽样式。
    StrokeLineJoin
    定义一个 Shape的行连接样式。
    StrokeType
    定义在Shape节点的边界周围画画的位置。
    VertexFormat
    定义网格中顶点的格式。
  • Classes in javafx.scene.shape used by javafx.scene.text
    Class 描述
    PathElement
    所述PathElement类表示的一个抽象元素Path能够表示像直线，圆弧，二次曲线，三次曲线等的任何几何对象
    Shape
    Shape类为表示某种形状的几何形状的对象提供了常用属性的定义。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


VertexFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class VertexFormat

  • java.lang.Object
    • javafx.scene.shape.VertexFormat

  • public final class VertexFormat
extends Object
    定义网格中顶点的格式。 顶点由点阵，法线（可选）和纹理坐标组成。
    从以下版本开始：
    JavaFX 8u40

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static VertexFormat POINT_NORMAL_TEXCOORD
      指定由点，法线和纹理坐标组成的顶点的格式。
      static VertexFormat POINT_TEXCOORD
      指定由点和纹理坐标组成的顶点的格式。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getNormalIndexOffset​()
      返回顶点中正常分量的面阵列中的索引偏移量。
      int getPointIndexOffset​()
      返回顶点中点分量的面阵列中的索引偏移量。
      int getTexCoordIndexOffset​()
      返回顶点内的纹理坐标组件的面阵列中的索引偏移量。
      int getVertexIndexSize​()
      返回表示顶点的组件索引数。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • POINT_TEXCOORD

        public static final VertexFormat POINT_TEXCOORD
        指定由点和纹理坐标组成的顶点的格式。

      • POINT_NORMAL_TEXCOORD

        public static final VertexFormat POINT_NORMAL_TEXCOORD
        指定由点，法线和纹理坐标组成的顶点的格式。

    • 方法详细信息

      • getVertexIndexSize

        public int getVertexIndexSize​()
        返回表示顶点的组件索引数。 例如，POINT_TEXCOORD顶点由2个索引组成，一个用于点分量，另一个用于纹理坐标组件。 所以它的价值将是2。
        结果
        组件索引的数量

      • getPointIndexOffset

        public int getPointIndexOffset​()
        返回顶点中点分量的面阵列中的索引偏移量。
        结果
        偏移到点分量。

      • getNormalIndexOffset

        public int getNormalIndexOffset​()
        返回顶点中正常分量的面阵列中的索引偏移量。
        结果
        偏移到正常分量。

      • getTexCoordIndexOffset

        public int getTexCoordIndexOffset​()
        返回顶点内的纹理坐标组件的面阵列中的索引偏移量。
        结果
        纹理坐标组件的偏移量。

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


VLineTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.shape

Class VLineTo

  • java.lang.Object
    • javafx.scene.shape.PathElement
      • javafx.scene.shape.VLineTo

  • public class VLineTo
extends PathElement
    创建从当前点到y的垂直线路元素。

    有关路径元素的更多信息，请参阅Path和PathElement类。

    例：

      import javafx.scene.shape.*;

Path path = new Path();
path.getElements().add(new MoveTo(50.0f, 0.0f));
path.getElements().add(new VLineTo(50.0f));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty y
      定义Y坐标。

      • Properties inherited from class javafx.scene.shape.PathElement

        absolute

    • 构造方法摘要

      构造方法
      Constructor 描述
      VLineTo​()
      创建一个空的VLineTo实例。
      VLineTo​(double y)
      创建一个VLineTo的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getY​()
      获取属性y的值。
      void setY​(double value)
      设置属性y的值。
      String toString​()
      返回此 VLineTo对象的字符串表示形式。
      DoubleProperty yProperty​()
      定义Y坐标。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.PathElement

        absoluteProperty, isAbsolute, setAbsolute

    • Property Detail

      • y

        public final DoubleProperty yProperty
        定义Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

    • 构造方法详细信息

      • VLineTo

        public VLineTo​()
        创建一个空的VLineTo实例。

      • VLineTo

        public VLineTo​(double y)
        创建一个VLineTo的实例。
        参数
        y - 垂直坐标到

    • 方法详细信息

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义Y坐标。
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义Y坐标。
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        定义Y坐标。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • toString

        public String toString​()
        返回此 VLineTo对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 VLineTo对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.scene.shape.Arc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Arc

No usage of javafx.scene.shape.Arc
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.ArcTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.ArcTo

No usage of javafx.scene.shape.ArcTo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.ArcType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.ArcType

  • Packages that use ArcType
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of ArcType in javafx.scene.canvas

      Methods in javafx.scene.canvas with parameters of type ArcType
      Modifier and Type 方法 描述
      void GraphicsContext.fillArc​(double x, double y, double w, double h, double startAngle, double arcExtent, ArcType closure)
      使用当前的填充油漆填充弧。
      void GraphicsContext.strokeArc​(double x, double y, double w, double h, double startAngle, double arcExtent, ArcType closure)
      使用当前笔画绘制弧。

    • Uses of ArcType in javafx.scene.shape

      Methods in javafx.scene.shape that return ArcType
      Modifier and Type 方法 描述
      ArcType Arc.getType​()
      获取属性类型的值。
      static ArcType ArcType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ArcType[] ArcType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.shape that return types with arguments of type ArcType
      Modifier and Type 方法 描述
      ObjectProperty<ArcType> Arc.typeProperty​()
      定义闭合类型弧： OPEN ， CHORD ，或 ROUND 。
      Methods in javafx.scene.shape with parameters of type ArcType
      Modifier and Type 方法 描述
      void Arc.setType​(ArcType value)
      设置属性类型的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Box (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Box

No usage of javafx.scene.shape.Box
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Circle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Circle

No usage of javafx.scene.shape.Circle
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.ClosePath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.ClosePath

No usage of javafx.scene.shape.ClosePath
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.CubicCurve (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.CubicCurve

No usage of javafx.scene.shape.CubicCurve
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.CubicCurveTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.CubicCurveTo

No usage of javafx.scene.shape.CubicCurveTo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.CullFace (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.CullFace

  • Packages that use CullFace
    软件包 描述
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of CullFace in javafx.scene.shape

      Methods in javafx.scene.shape that return CullFace
      Modifier and Type 方法 描述
      CullFace Shape3D.getCullFace​()
      获取属性cullFace的值。
      static CullFace CullFace.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static CullFace[] CullFace.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.shape that return types with arguments of type CullFace
      Modifier and Type 方法 描述
      ObjectProperty<CullFace> Shape3D.cullFaceProperty​()
      定义cullFace这 Shape3D 。
      Methods in javafx.scene.shape with parameters of type CullFace
      Modifier and Type 方法 描述
      void Shape3D.setCullFace​(CullFace value)
      设置属性cullFace的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Cylinder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Cylinder

No usage of javafx.scene.shape.Cylinder
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.DrawMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.DrawMode

  • Packages that use DrawMode
    软件包 描述
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of DrawMode in javafx.scene.shape

      Methods in javafx.scene.shape that return DrawMode
      Modifier and Type 方法 描述
      DrawMode Shape3D.getDrawMode​()
      获取属性drawMode的值。
      static DrawMode DrawMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DrawMode[] DrawMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.shape that return types with arguments of type DrawMode
      Modifier and Type 方法 描述
      ObjectProperty<DrawMode> Shape3D.drawModeProperty​()
      定义用于渲染 Shape3D的绘制模式。
      Methods in javafx.scene.shape with parameters of type DrawMode
      Modifier and Type 方法 描述
      void Shape3D.setDrawMode​(DrawMode value)
      设置属性drawMode的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Ellipse (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Ellipse

No usage of javafx.scene.shape.Ellipse
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.FillRule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.FillRule

  • Packages that use FillRule
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of FillRule in javafx.scene.canvas

      Methods in javafx.scene.canvas that return FillRule
      Modifier and Type 方法 描述
      FillRule GraphicsContext.getFillRule​()
      获取填充规则属性，以确定填充和剪辑操作中路径的内部。
      Methods in javafx.scene.canvas with parameters of type FillRule
      Modifier and Type 方法 描述
      void GraphicsContext.setFillRule​(FillRule fillRule)
      设置填充规则属性以确定填充或剪辑操作中路径的内部。

    • Uses of FillRule in javafx.scene.shape

      Methods in javafx.scene.shape that return FillRule
      Modifier and Type 方法 描述
      FillRule Path.getFillRule​()
      获取属性fillRule的值。
      FillRule SVGPath.getFillRule​()
      获取属性fillRule的值。
      static FillRule FillRule.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FillRule[] FillRule.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.shape that return types with arguments of type FillRule
      Modifier and Type 方法 描述
      ObjectProperty<FillRule> Path.fillRuleProperty​()
      定义用于确定路径内部的填充规则常数。
      ObjectProperty<FillRule> SVGPath.fillRuleProperty​()
      定义用于确定路径内部的填充规则常数。
      Methods in javafx.scene.shape with parameters of type FillRule
      Modifier and Type 方法 描述
      void Path.setFillRule​(FillRule value)
      设置属性fillRule的值。
      void SVGPath.setFillRule​(FillRule value)
      设置属性fillRule的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.HLineTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.HLineTo

No usage of javafx.scene.shape.HLineTo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Line (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Line

No usage of javafx.scene.shape.Line
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.LineTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.LineTo

No usage of javafx.scene.shape.LineTo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Mesh (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Mesh

  • Packages that use Mesh
    软件包 描述
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of Mesh in javafx.scene.shape

      Subclasses of Mesh in javafx.scene.shape
      Modifier and Type Class 描述
      class  TriangleMesh
      定义一个三角形三角形网格，由其相关联的 VertexFormat和一组独立的顶点组件阵列组成，例如点，法线，纹理坐标和定义网格的各个三角形的面阵列。
      Methods in javafx.scene.shape that return Mesh
      Modifier and Type 方法 描述
      Mesh MeshView.getMesh​()
      获取属性网格的值。
      Methods in javafx.scene.shape that return types with arguments of type Mesh
      Modifier and Type 方法 描述
      ObjectProperty<Mesh> MeshView.meshProperty​()
      指定此 MeshView的3D网格数据。
      Methods in javafx.scene.shape with parameters of type Mesh
      Modifier and Type 方法 描述
      void MeshView.setMesh​(Mesh value)
      设置属性网格的值。
      Constructors in javafx.scene.shape with parameters of type Mesh
      Constructor 描述
      MeshView​(Mesh mesh)
      创建一个具有指定的 Mesh表面的新实例 MeshView类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.MeshView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.MeshView

No usage of javafx.scene.shape.MeshView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.MoveTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.MoveTo

No usage of javafx.scene.shape.MoveTo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Path (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Path

No usage of javafx.scene.shape.Path
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.PathElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.PathElement

  • Packages that use PathElement
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of PathElement in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return PathElement
      Modifier and Type | 方法 | 描述
      protected PathElement[] | TextAreaSkin.getRangeShape​(int start, int end)
      protected PathElement[] | TextFieldSkin.getRangeShape​(int start, int end)
      protected abstract PathElement[] | TextInputControlSkin.getRangeShape​(int start, int end)
      protected PathElement[] | TextAreaSkin.getUnderlineShape​(int start, int end)
      protected PathElement[] | TextFieldSkin.getUnderlineShape​(int start, int end)
      protected abstract PathElement[] | TextInputControlSkin.getUnderlineShape​(int start, int end)

    • Uses of PathElement in javafx.scene.shape

      Subclasses of PathElement in javafx.scene.shape
      Modifier and Type Class 描述
      class  ArcTo
      一个路径元素，它使用指定的半径从前一个坐标到指定的x和y坐标形成弧。
      class  ClosePath
      关闭当前路径的路径元素。
      class  CubicCurveTo
      通过使用指定点 (controlX1,controlY1)和 (controlX2,controlY2) (controlX1,controlY1)与当前坐标和指定坐标 (x,y)相交的立方Bier曲线，创建由三个新点定义的曲线路径元素。
      class  HLineTo
      创建从当前点到x的水平线路元素。
      class  LineTo
      通过从当前坐标绘制直线到新坐标来创建线路元素。
      class  MoveTo
      通过移动到指定的坐标来创建对路径的补充。
      class  QuadCurveTo
      通过绘制与当前坐标和指定坐标 (x, y)相交的二次曲线曲线，使用指定点 (controlX, controlY)作为Bézier控制点，创建由两个新点定义的曲线路径元素。
      class  VLineTo
      创建从当前点到y的垂直线路元素。
      Methods in javafx.scene.shape that return types with arguments of type PathElement
      Modifier and Type 方法 描述
      ObservableList<PathElement> Path.getElements​()
      获取此路径的路径元素的可观察列表。
      Constructors in javafx.scene.shape with parameters of type PathElement
      Constructor 描述
      Path​(PathElement... elements)
      创建一个新的路径实例
      Constructor parameters in javafx.scene.shape with type arguments of type PathElement
      Constructor 描述
      Path​(Collection<? extends PathElement> elements)
      创建路径的新实例

    • Uses of PathElement in javafx.scene.text

      Methods in javafx.scene.text that return PathElement
      Modifier and Type 方法 描述
      PathElement[] Text.caretShape​(int charIndex, boolean caretBias)
      在给定的索引和偏倚上返回插入符号的形状。
      PathElement[] TextFlow.caretShape​(int charIndex, boolean leading)
      以局部坐标返回插入符号的形状。
      PathElement[] Text.getCaretShape​()
      在本地坐标中插入符号的形状。
      PathElement[] Text.getSelectionShape​()
      局部坐标选择形状。
      PathElement[] Text.rangeShape​(int start, int end)
      返回局部坐标中文本范围的形状。
      PathElement[] TextFlow.rangeShape​(int start, int end)
      返回局部坐标中文本范围的形状。
      PathElement[] Text.underlineShape​(int start, int end)
      返回局部坐标下划线的形状。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Polygon (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Polygon

No usage of javafx.scene.shape.Polygon
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Polyline (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Polyline

No usage of javafx.scene.shape.Polyline
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.QuadCurve (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.QuadCurve

No usage of javafx.scene.shape.QuadCurve
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.QuadCurveTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.QuadCurveTo

No usage of javafx.scene.shape.QuadCurveTo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Rectangle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Rectangle

No usage of javafx.scene.shape.Rectangle
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Shape3D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Shape3D

  • Packages that use Shape3D
    软件包 描述
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of Shape3D in javafx.scene.shape

      Subclasses of Shape3D in javafx.scene.shape
      Modifier and Type Class 描述
      class  Box
      Box类定义了具有指定大小的3维框。
      class  Cylinder
      Cylinder类定义了具有指定大小的3维圆柱体。
      class  MeshView
      MeshView类定义了一个具有指定3D网格数据的曲面。
      class  Sphere
      Sphere类定义了具有指定大小的三维球体。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Shape (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Shape

  • Packages that use Shape
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of Shape in javafx.animation

      Methods in javafx.animation that return Shape
      Modifier and Type 方法 描述
      Shape PathTransition.getPath​()
      获取属性路径的值。
      Shape FillTransition.getShape​()
      获取属性形状的值。
      Shape StrokeTransition.getShape​()
      获取属性形状的值。
      Methods in javafx.animation that return types with arguments of type Shape
      Modifier and Type 方法 描述
      ObjectProperty<Shape> PathTransition.pathProperty​()
      大纲节点应该被动画的形状。
      ObjectProperty<Shape> FillTransition.shapeProperty​()
      目标形状为 FillTransition 。
      ObjectProperty<Shape> StrokeTransition.shapeProperty​()
      目标形状为 StrokeTransition 。
      Methods in javafx.animation with parameters of type Shape
      Modifier and Type 方法 描述
      void PathTransition.setPath​(Shape value)
      设置属性路径的值。
      void FillTransition.setShape​(Shape value)
      设置属性形状的值。
      void StrokeTransition.setShape​(Shape value)
      设置属性形状的值。
      Constructors in javafx.animation with parameters of type Shape
      Constructor 描述
      FillTransition​(Duration duration, Shape shape)
      构造函数 FillTransition
      FillTransition​(Duration duration, Shape shape, Color fromValue, Color toValue)
      构造函数为 FillTransition
      PathTransition​(Duration duration, Shape path)
      构造函数为 PathTransition 。
      PathTransition​(Duration duration, Shape path, Node node)
      构造函数为 PathTransition 。
      StrokeTransition​(Duration duration, Shape shape)
      构造函数为 StrokeTransition
      StrokeTransition​(Duration duration, Shape shape, Color fromValue, Color toValue)
      构造函数为 StrokeTransition

    • Uses of Shape in javafx.css.converter

      Methods in javafx.css.converter that return Shape
      Modifier and Type | 方法 | 描述
      Shape | ShapeConverter.convert​(ParsedValue<String,Shape> value, Font font)
      Methods in javafx.css.converter that return types with arguments of type Shape
      Modifier and Type | 方法 | 描述
      static StyleConverter<String,Shape> | ShapeConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Shape
      Modifier and Type | 方法 | 描述
      Shape | ShapeConverter.convert​(ParsedValue<String,Shape> value, Font font)

    • Uses of Shape in javafx.scene.layout

      Methods in javafx.scene.layout that return Shape
      Modifier and Type 方法 描述
      Shape Region.getShape​()
      获取属性形状的值。
      Methods in javafx.scene.layout that return types with arguments of type Shape
      Modifier and Type 方法 描述
      ObjectProperty<Shape> Region.shapeProperty​()
      指定时， Shape将导致该区域被渲染为指定的形状而不是圆角矩形。
      Methods in javafx.scene.layout with parameters of type Shape
      Modifier and Type 方法 描述
      void Region.setShape​(Shape value)
      设置属性形状的值。

    • Uses of Shape in javafx.scene.shape

      Subclasses of Shape in javafx.scene.shape
      Modifier and Type Class 描述
      class  Arc
      所述 Arc类表示2D弧对象，由中心点限定的，起始角度（度），角度范围（以度数表示的弧的长度），和一弧型（ ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND ）。
      class  Circle
      Circle课程创建一个新的圆圈，其中指定的半径和中心位置以像素为单位。
      class  CubicCurve
      CubiCurve类定义了（x，y）坐标空间中的三次Bézier参数曲线段。
      class  Ellipse
      Ellipse类创建一个具有指定大小和位置（以像素为单位）的新椭圆
      class  Line
      此行代表 (x,y)坐标空间中的一个线段。
      class  Path
      Path类代表一个简单的形状，并提供基本构造和管理几何路径所需的设施。
      class  Polygon
      创建由x，y坐标数组定义的多边形。
      class  Polyline
      创建折线，由分段点数组定义。
      class  QuadCurve
      Quadcurve类定义了（x，y）坐标空间中的二次Bézier参数曲线段。
      class  Rectangle
      Rectangle类定义了一个具有指定大小和位置的矩形。
      class  SVGPath
      SVGPath类表示通过从String解析SVG路径数据构建的简单形状。
      Methods in javafx.scene.shape that return Shape
      Modifier and Type 方法 描述
      static Shape Shape.intersect​(Shape shape1, Shape shape2)
      返回一个新的 Shape ，它被创建为指定的输入形状的交集。
      static Shape Shape.subtract​(Shape shape1, Shape shape2)
      返回一个新的 Shape ，它是通过从第一个形状中减去指定的第二个形状而创建的。
      static Shape Shape.union​(Shape shape1, Shape shape2)
      返回一个新的 Shape ，它被创建为指定输入形状的并集。
      Methods in javafx.scene.shape with parameters of type Shape
      Modifier and Type 方法 描述
      static Shape Shape.intersect​(Shape shape1, Shape shape2)
      返回一个新的 Shape ，它被创建为指定输入形状的交集。
      static Shape Shape.subtract​(Shape shape1, Shape shape2)
      返回一个新的 Shape ，它是通过从第一个形状中减去指定的第二个形状而创建的。
      static Shape Shape.union​(Shape shape1, Shape shape2)
      返回一个新的 Shape ，它被创建为指定输入形状的并集。

    • Uses of Shape in javafx.scene.text

      Subclasses of Shape in javafx.scene.text
      Modifier and Type Class 描述
      class  Text
      Text类定义了一个显示文本的节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.Sphere (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.Sphere

No usage of javafx.scene.shape.Sphere
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.StrokeLineCap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.StrokeLineCap

  • Packages that use StrokeLineCap
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of StrokeLineCap in javafx.scene.canvas

      Methods in javafx.scene.canvas that return StrokeLineCap
      Modifier and Type 方法 描述
      StrokeLineCap GraphicsContext.getLineCap​()
      获取当前行程线上限。
      Methods in javafx.scene.canvas with parameters of type StrokeLineCap
      Modifier and Type 方法 描述
      void GraphicsContext.setLineCap​(StrokeLineCap cap)
      设置当前行程行上限。

    • Uses of StrokeLineCap in javafx.scene.layout

      Methods in javafx.scene.layout that return StrokeLineCap
      Modifier and Type 方法 描述
      StrokeLineCap BorderStrokeStyle.getLineCap​()
      如此端盖风格 Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并 StrokeLineCap.SQUARE 。
      Constructors in javafx.scene.layout with parameters of type StrokeLineCap
      Constructor 描述
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。

    • Uses of StrokeLineCap in javafx.scene.shape

      Methods in javafx.scene.shape that return StrokeLineCap
      Modifier and Type 方法 描述
      StrokeLineCap Shape.getStrokeLineCap​()
      获取属性strokeLineCap的值。
      static StrokeLineCap StrokeLineCap.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StrokeLineCap[] StrokeLineCap.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.shape that return types with arguments of type StrokeLineCap
      Modifier and Type 方法 描述
      ObjectProperty<StrokeLineCap> Shape.strokeLineCapProperty​()
      如此端盖风格 Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并 StrokeLineCap.SQUARE 。
      Methods in javafx.scene.shape with parameters of type StrokeLineCap
      Modifier and Type 方法 描述
      void Shape.setStrokeLineCap​(StrokeLineCap value)
      设置属性strokeLineCap的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.StrokeLineJoin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.StrokeLineJoin

  • Packages that use StrokeLineJoin
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of StrokeLineJoin in javafx.scene.canvas

      Methods in javafx.scene.canvas that return StrokeLineJoin
      Modifier and Type 方法 描述
      StrokeLineJoin GraphicsContext.getLineJoin​()
      获取当前笔划行连接。
      Methods in javafx.scene.canvas with parameters of type StrokeLineJoin
      Modifier and Type 方法 描述
      void GraphicsContext.setLineJoin​(StrokeLineJoin join)
      设置当前笔画行连接。

    • Uses of StrokeLineJoin in javafx.scene.layout

      Methods in javafx.scene.layout that return StrokeLineJoin
      Modifier and Type 方法 描述
      StrokeLineJoin BorderStrokeStyle.getLineJoin​()
      定义路径段相遇时应用的装饰。
      Constructors in javafx.scene.layout with parameters of type StrokeLineJoin
      Constructor 描述
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。

    • Uses of StrokeLineJoin in javafx.scene.shape

      Methods in javafx.scene.shape that return StrokeLineJoin
      Modifier and Type 方法 描述
      StrokeLineJoin Shape.getStrokeLineJoin​()
      获取属性strokeLineJoin的值。
      static StrokeLineJoin StrokeLineJoin.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StrokeLineJoin[] StrokeLineJoin.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.shape that return types with arguments of type StrokeLineJoin
      Modifier and Type 方法 描述
      ObjectProperty<StrokeLineJoin> Shape.strokeLineJoinProperty​()
      定义路径段相遇时应用的装饰。
      Methods in javafx.scene.shape with parameters of type StrokeLineJoin
      Modifier and Type 方法 描述
      void Shape.setStrokeLineJoin​(StrokeLineJoin value)
      设置属性strokeLineJoin的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.StrokeType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.StrokeType

  • Packages that use StrokeType
    软件包 描述
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of StrokeType in javafx.scene.layout

      Methods in javafx.scene.layout that return StrokeType
      Modifier and Type 方法 描述
      StrokeType BorderStrokeStyle.getType​()
      定义将strokeWidth应用于形状边界的方向（内部，外部或两者）。
      Constructors in javafx.scene.layout with parameters of type StrokeType
      Constructor 描述
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。

    • Uses of StrokeType in javafx.scene.shape

      Methods in javafx.scene.shape that return StrokeType
      Modifier and Type 方法 描述
      StrokeType Shape.getStrokeType​()
      获取属性strokeType的值。
      static StrokeType StrokeType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StrokeType[] StrokeType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.shape that return types with arguments of type StrokeType
      Modifier and Type 方法 描述
      ObjectProperty<StrokeType> Shape.strokeTypeProperty​()
      定义将strokeWidth应用于形状边界的方向（内部，中心或外部）。
      Methods in javafx.scene.shape with parameters of type StrokeType
      Modifier and Type 方法 描述
      void Shape.setStrokeType​(StrokeType value)
      设置属性strokeType的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.SVGPath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.SVGPath

No usage of javafx.scene.shape.SVGPath
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.TriangleMesh (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.TriangleMesh

No usage of javafx.scene.shape.TriangleMesh
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.VertexFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.VertexFormat

  • Packages that use VertexFormat
    软件包 描述
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of VertexFormat in javafx.scene.shape

      Fields in javafx.scene.shape declared as VertexFormat
      Modifier and Type Field 描述
      static VertexFormat VertexFormat.POINT_NORMAL_TEXCOORD
      指定由点，法线和纹理坐标组成的顶点的格式。
      static VertexFormat VertexFormat.POINT_TEXCOORD
      指定由点和纹理坐标组成的顶点的格式。
      Methods in javafx.scene.shape that return VertexFormat
      Modifier and Type 方法 描述
      VertexFormat TriangleMesh.getVertexFormat​()
      获取属性vertexFormat的值。
      Methods in javafx.scene.shape that return types with arguments of type VertexFormat
      Modifier and Type 方法 描述
      ObjectProperty<VertexFormat> TriangleMesh.vertexFormatProperty​()
      指定 TriangleMesh的顶点格式， VertexFormat.POINT_TEXCOORD或 VertexFormat.POINT_NORMAL_TEXCOORD 。
      Methods in javafx.scene.shape with parameters of type VertexFormat
      Modifier and Type 方法 描述
      void TriangleMesh.setVertexFormat​(VertexFormat value)
      设置属性vertexFormat的值。
      Constructors in javafx.scene.shape with parameters of type VertexFormat
      Constructor 描述
      TriangleMesh​(VertexFormat vertexFormat)
      Creates a new instance of TriangleMesh class with the specified VertexFormat.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.shape.VLineTo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.shape.VLineTo

No usage of javafx.scene.shape.VLineTo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.scene.shape.ObservableFaceArray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.scene.shape.ObservableFaceArray

  • Packages that use ObservableFaceArray
    软件包 描述
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

    • Uses of ObservableFaceArray in javafx.scene.shape

      Methods in javafx.scene.shape that return ObservableFaceArray
      Modifier and Type 方法 描述
      ObservableFaceArray TriangleMesh.getFaces​()
      获取 faces阵列，索引到 points ， normals （可选，如果它是一个 VertexFormat.POINT_NORMAL_TEXCOORD目）和 texCoords阵列，此的 TriangleMesh 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Font (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.text

Class Font

  • java.lang.Object
    • javafx.scene.text.Font

  • public final class Font
extends Object

    Font类表示字体，用于在屏幕上呈现文本。

    Font的大小被描述为以大约1/72英寸的真实世界测量的点来指定。

    鉴于字体缩放与渲染变换为由的变换属性决定Node使用Font及其祖先，规模实际上是相对于局部坐标节点，应提供的空间坐标类似的尺寸来看，如果在节点的环境中不存在缩放变换。 请注意，默认坐标系指定的实际距离仅将点大小作为经验法则，通常默认为大多数显示器的屏幕像素。

    有关详细信息，请参阅Node有关默认坐标系的更多信息

    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      Font​(double size)
      使用默认面“System”构造一个字体。
      Font​(String name, double size)
      使用指定的正面名称和大小构造字体

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      static Font font​(double size)
      根据默认的字体系列名称和给定的字体大小搜索适当的字体。
      static Font font​(String family)
      根据给定的字体系列名称和默认字体大小搜索适当的字体。
      static Font font​(String family, double size)
      根据字体系列名称和大小搜索适当的字体。
      static Font font​(String family, FontPosture posture, double size)
      根据字体系列名称和姿势样式，搜索适合的字体。
      static Font font​(String family, FontWeight weight, double size)
      根据字体系列名称和体重样式搜索适当的字体。
      static Font font​(String family, FontWeight weight, FontPosture posture, double size)
      根据字体系列名称，体重和姿势样式搜索适当的字体。
      static Font getDefault​()
      获取将来自“系统”系列的默认字体，通常为“常规”样式，并且具有与用户桌面环境一致的大小，至可以确定的程度。
      static List<String> getFamilies​()
      获取用户系统上安装的所有字体，包括任何应用程序字体或SDK字体。
      String getFamily​()
      返回此字体的系列。
      static List<String> getFontNames​()
      获取用户系统上安装的所有字体的名称，包括任何应用程序字体和SDK字体。
      static List<String> getFontNames​(String family)
      获取用户系统上安装的指定字体系列中所有字体的名称，包括任何应用程序字体和SDK字体。
      String getName​()
      完整的字体名称。
      double getSize​()
      该字体的点大小。
      String getStyle​()
      描述字体系列中的样式的字体指定字符串。
      int hashCode​()
      返回此 Font对象的哈希码。
      static Font loadFont​(InputStream in, double size)
      从指定的输入流加载字体资源。
      static Font loadFont​(String urlStr, double size)
      从指定的URL加载字体资源。
      static Font[] loadFonts​(InputStream in, double size)
      从指定的输入流中加载字体资源。
      static Font[] loadFonts​(String urlStr, double size)
      从指定的URL加载字体资源。
      String toString​()
      将此 Font对象转换为 String表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Font

        public Font​(double size)
        使用默认面“System”构造一个字体。 使用的底层字体由基于当前UI环境的典型UI字体的实现来确定。
        参数
        size - 要使用的字体大小

      • Font

        public Font​(String name,
            double size)
        使用指定的正面名称和大小构造字体
        参数
        name - 字体的全名。
        size - 要使用的字体大小

    • 方法详细信息

      • getDefault

        public static Font getDefault​()
        获取将来自“系统”系列的默认字体，通常为“常规”样式，并且具有与用户桌面环境一致的大小，至可以确定的程度。
        结果
        默认字体。

      • getFamilies

        public static List<String> getFamilies​()
        获取用户系统上安装的所有字体，包括任何应用程序字体或SDK字体。 此调用具有性能注意事项，因为查找所有字体可能是第一次昂贵的操作。
        结果
        该列表包含所有可用的字体系列。

      • getFontNames

        public static List<String> getFontNames​()
        获取用户系统上安装的所有字体的名称，包括任何应用程序字体和SDK字体。 此调用具有性能注意事项，因为查找所有字体可能是第一次昂贵的操作。
        结果
        该列表包含所有可用的字体。

      • getFontNames

        public static List<String> getFontNames​(String family)
        获取用户系统上安装的指定字体系列中所有字体的名称，包括任何应用程序字体和SDK字体。 此调用具有性能注意事项，因为查找所有字体可能是第一次昂贵的操作。
        参数
        family - 字体系列
        结果
        包含给定家庭字体的列表。

      • font

        public static Font font​(String family,
                        FontWeight weight,
                        FontPosture posture,
                        double size)
        根据字体系列名称，体重和姿势样式搜索适当的字体。 这种方法不能保证返回一个特定的字体，但是最好找到一个符合指定要求的字体。

        家庭的空值或空值允许实现选择任何合适的字体。

        参数
        family - 字体的家庭
        weight - 字体的重量
        posture - 字体的姿势或姿势
        size - 字体的点大小。 这可以是小数值，但不能为负数。 如果大小为<0，将使用默认大小。
        结果
        最符合规定要求的字体。

      • font

        public static Font font​(String family,
                        FontWeight weight,
                        double size)
        根据字体系列名称和体重样式搜索适当的字体。 这种方法不能保证返回一个特定的字体，但是最好找到一个符合指定要求的字体。 家庭的空值或空值允许实现选择任何合适的字体。
        参数
        family - 字体的家庭
        weight - 字体的重量
        size - 字体的点大小。 这可以是小数值，但不能为负数。 如果大小为<0，将使用默认大小。
        结果
        最符合规定要求的字体。

      • font

        public static Font font​(String family,
                        FontPosture posture,
                        double size)
        根据字体系列名称和姿势样式，搜索适合的字体。 这种方法不能保证返回一个特定的字体，但是最好找到一个符合指定要求的字体。 家庭的空值或空值允许实现选择任何合适的字体。
        参数
        family - 字体的家庭
        posture - 字体的姿势或姿势
        size - 字体的点大小。 这可以是小数值，但不能为负数。 如果大小为<0，将使用默认大小。
        结果
        最符合规定要求的字体。

      • font

        public static Font font​(String family,
                        double size)
        根据字体系列名称和大小搜索适当的字体。 这种方法不能保证返回一个特定的字体，但是最好找到一个符合指定要求的字体。 家庭的空值或空值允许实现选择任何合适的字体。
        参数
        family - 字体的家庭
        size - 字体的点大小。 这可以是小数值，但不能为负数。 如果大小为<0，将使用默认大小。
        结果
        最符合规定要求的字体。

      • font

        public static Font font​(String family)
        根据给定的字体系列名称和默认字体大小搜索适当的字体。 这种方法不能保证返回一个特定的字体，但是最好找到一个符合指定要求的字体。 家庭的空值或空值允许实现选择任何合适的字体。
        参数
        family - 字体的家庭
        结果
        最符合规定要求的字体。

      • font

        public static Font font​(double size)
        根据默认的字体系列名称和给定的字体大小搜索适当的字体。 这种方法不能保证返回一个特定的字体，但是最好找到一个符合指定要求的字体。
        参数
        size - 字体的点大小。 这可以是小数值，但不能为负数。 如果大小为<0，将使用默认大小。
        结果
        最符合规定要求的字体。

      • getName

        public final String getName​()
        完整的字体名称。 该名称包括该系列中的家族名称和风格变体。 例如，对于简单的Arial字体，这将是“Arial Regular”，而对于粗体Arial字体，这将是“Arial Bold”。 加载字体时要使用的精确名称在每个字体文件中被定义为完整的字体名称。 例如，“Proxima Nova ExtraCondensed Bold Italic”将指具体的Proxima Nova字体。 空或空名称允许实现选择任何合适的字体。

        通过Font.loadFont() ，JavaFX运行时交付的字体和系统安装的字体，可以通过单一的统一方式来加载所有应用程序，只需通过指定要加载的字体的全名来创建字体，如果不能找到特定的字体，则将使用后备或默认字体，“名称”将被更新以反映正在使用的字体的实际名称。可以通过使用您尝试加载的名称检查字体的名称来发现加载失败条件。

        请注意，如果您希望通过字体系列和样式找到字体，则可以使用此类中定义的font(java.lang.String, javafx.scene.text.FontWeight, javafx.scene.text.FontPosture, double)工厂方法之一。

        Default value:
        空字符串
        结果
        完整的字体名称

      • getFamily

        public final String getFamily​()
        返回此字体的系列。
        结果
        这个字体的家族。

      • getStyle

        public final String getStyle​()
        描述字体系列中的样式的字体指定字符串。
        结果
        此字体的样式名称。

      • getSize

        public final double getSize​()
        该字体的点大小。 这可能是一个小数值，如11.5 。 如果指定的值为<0，则将使用默认大小。
        Default value:
        12
        结果
        该字体的点大小

      • loadFont

        public static Font loadFont​(String urlStr,
                            double size)
        从指定的URL加载字体资源。 如果加载成功，使得该位置是可读的，并且它表示支持的字体格式，那么将返回一个Font对象。

        如果存在安全管理员，应用程序必须同时具有从指定的URL位置读取的权限和FXPermission “loadFont”的权限 。 如果应用程序没有从指定的URL位置读取的权限，则返回null。 如果应用程序没有“loadFont”权限，那么该方法将返回具有指定字体大小的默认系统字体。

        任何失败，例如格式不正确的网址无法从资源中找到或读取，或者如果它不表示字体，将导致返回null 。 应用程序有责任在使用前进行检查。

        在成功（非空）返回时，字体将被注册到FX图形系统，以便通过可用的构造函数和工厂方法创建，并且应用程序应该以这种方式使用它，而不是再次调用此方法，这将重复开销下载并安装字体。

        字体size参数是一个方便，因此在典型的使用情况下，应用程序可以直接使用返回的（非空）字体，而不需要通过构造函数创建一个字体。 无效的大小是<= 0的大小，并将导致默认大小。

        如果URL表示本地磁盘文件，则不执行任何复制，并且字体文件需要在应用程序的生命周期中持续存在。 以任何方式更新文件将导致未指定和可能的不良行为。

        参数
        urlStr - 从中加载字体，指定为字符串。
        size - 返回的字体。
        结果
        字体，如果无法创建字体，则为null。

      • loadFonts

        public static Font[] loadFonts​(String urlStr,
                               double size)
        从指定的URL加载字体资源。 如果加载成功，使得位置可读，并且它表示支持的字体格式，则将返回Font的数组。

        此方法的用例是从TrueType集合（TTC）加载所有字体。

        如果存在安全管理员，应用程序必须同时具有从指定的URL位置读取的权限和FXPermission “loadFont”的权限 。 如果应用程序没有从指定的URL位置读取的权限，则返回null。 如果应用程序没有“loadFont”权限，那么此方法将返回一个元素的数组，该元素是具有指定字体大小的默认系统字体。

        任何失败，例如格式不正确的网址无法找到资源或从资源中读取，或者如果它不表示字体，将导致一个null返回。 应用程序有责任在使用前进行检查。

        在成功（非空）返回时，字体将被注册到FX图形系统，以便通过可用的构造函数和工厂方法创建，并且应用程序应该以这种方式使用它，而不是再次调用此方法，这将重复开销下载并安装字体。

        字体size参数是方便的，因此在典型的使用情况下，应用程序可以直接使用返回（非空）字体，而不需要通过构造函数创建一个字体。 无效的大小是<= 0的大小，并将导致默认大小。

        如果URL表示本地磁盘文件，则不执行任何复制，并且字体文件需要在应用程序的生命周期中持续存在。 以任何方式更新文件将导致未指定和可能的不良行为。

        参数
        urlStr - 从中加载字体，指定为字符串。
        size - 返回的字体。
        结果
        字体数组，如果无法创建字体，则为null。
        从以下版本开始：
        9

      • loadFont

        public static Font loadFont​(InputStream in,
                            double size)
        从指定的输入流加载字体资源。 如果加载成功，使流可以完全读取，并且它表示支持的字体格式，则将返回一个Font对象。

        如果存在安全管理员，应用程序必须具有“ loadFont ”FXPermission。 如果应用程序没有权限，则该方法将返回具有指定字体大小的默认系统字体。

        任何失败（如缩写输入）或不支持的字体格式都会导致返回null 。 应用程序有责任在使用前进行检查。

        在成功（非空）返回时，字体将被注册到FX图形系统，以便通过可用的构造函数和工厂方法创建，并且应用程序应该以这种方式使用它，而不是再次调用此方法，这将重复开销重新阅读和安装字体。

        字体size参数是方便的，因此在典型的使用情况下，应用程序可以直接使用返回（非空）字体，而不需要通过构造函数创建一个字体。 无效的大小是<= 0的大小，并将导致默认大小。

        此方法不关闭输入流。

        参数
        in - 加载字体的流。
        size - 返回的字体。
        结果
        字体，如果无法创建字体，则为null。

      • loadFonts

        public static Font[] loadFonts​(InputStream in,
                               double size)
        从指定的输入流中加载字体资源。 如果加载成功，使流可以完全读取，并且它代表支持的字体格式，那么将返回一个Font的数组。

        此方法的用例是从TrueType集合（TTC）加载所有字体。

        如果存在安全管理员，应用程序必须具有“ loadFont ”FXPermission。 如果应用程序没有权限，则该方法将返回具有指定字体大小的默认系统字体。

        任何失败（如缩写输入）或不支持的字体格式都将导致返回null 。 应用程序有责任在使用前进行检查。

        在成功（非空）返回时，字体将被注册到FX图形系统，以便通过可用的构造函数和工厂方法创建，并且应用程序应该以这种方式使用它，而不是再次调用此方法，这将重复开销重新阅读和安装字体。

        字体size参数是一个方便，因此在典型的使用情况下，应用程序可以直接使用返回（非空）字体，而不需要通过构造函数重新创建。 无效的大小是<= 0的大小，并将导致默认大小。

        此方法不关闭输入流。

        参数
        in - 加载字体的流。
        size - 返回的字体。
        结果
        字体数组，如果无法创建字体，则为null。
        从以下版本开始：
        9

      • toString

        public String toString​()
        将此Font对象转换为String表示形式。 字符串表示仅供参考，并将更改。 不要将此字符串表示用于任何程序目的。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象等于obj参数; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 Font对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 Font对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FontPosture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.text

Enum FontPosture

  • java.lang.Object
    • java.lang.Enum<FontPosture>
      • javafx.scene.text.FontPosture
  • All Implemented Interfaces:
    Serializable ， Comparable<FontPosture>

    public enum FontPosture
extends Enum<FontPosture>
    指定字体是否为斜体
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ITALIC
      代表斜体
      REGULAR
      代表常规。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FontPosture findByName​(String name)
      以其名称返回 FontPosture 。
      static FontPosture valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FontPosture[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • REGULAR

        public static final FontPosture REGULAR
        代表常规。

      • ITALIC

        public static final FontPosture ITALIC
        代表斜体

    • 方法详细信息

      • values

        public static FontPosture[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (FontPosture c : FontPosture.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static FontPosture valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • findByName

        public static FontPosture findByName​(String name)
        以其名称返回 FontPosture 。
        参数
        name - 名称 FontPosture
        结果
        FontPosture的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


FontSmoothingType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.text

Enum FontSmoothingType

  • java.lang.Object
    • java.lang.Enum<FontSmoothingType>
      • javafx.scene.text.FontSmoothingType
  • All Implemented Interfaces:
    Serializable ， Comparable<FontSmoothingType>

    public enum FontSmoothingType
extends Enum<FontSmoothingType>
    FontSmoothingType枚举用于指定用于平滑屏幕文本字体边缘的首选机制。
    从以下版本开始：
    JavaFX 2.1

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      GRAY
      指定默认的灰度平滑，最适合图形和动画使用。
      LCD
      指定亚像素LCD文本，利用数字LCD显示面板的特性来实现更高的像素分辨率。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FontSmoothingType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FontSmoothingType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • GRAY

        public static final FontSmoothingType GRAY
        指定默认的灰度平滑，最适合图形和动画使用。

      • LCD

        public static final FontSmoothingType LCD
        指定亚像素LCD文本，利用数字LCD显示面板的特性来实现更高的像素分辨率。 这种模式通常是适当的，其中重要因素是静态文本的可读性，特别是在小尺寸下。

        对LCD文本的请求是一个“提示”，因为实现可能需要在诸如不支持它的合成模式之类的条件下忽略它。 因此，LCD文本对于应用程序应避免使用效果，透明度等至关重要。

    • 方法详细信息

      • values

        public static FontSmoothingType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (FontSmoothingType c : FontSmoothingType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static FontSmoothingType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


FontWeight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.text

Enum FontWeight

  • java.lang.Object
    • java.lang.Enum<FontWeight>
      • javafx.scene.text.FontWeight
  • All Implemented Interfaces:
    Serializable ， Comparable<FontWeight>

    public enum FontWeight
extends Enum<FontWeight>
    指定在系统上搜索字体时可以使用的不同字体权重。 这些名称对应于OpenType font specification的OS / 2表中的预定权重。 CSS 3规范引用的值与序列相同。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BLACK
      代表黑色字体重量（900）。
      BOLD
      代表粗体字体重（700）。
      EXTRA_BOLD
      代表“Extra Bold”字体重量（800）。
      EXTRA_LIGHT
      代表“Extra Light”字体重量（200）。
      LIGHT
      表示轻型字体重量（300）。
      MEDIUM
      表示中等字体重量（500）。
      NORMAL
      表示正常字体重量（400）。
      SEMI_BOLD
      代表“Demi Bold”字体重量（600）。
      THIN
      代表瘦体重（100）。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static FontWeight findByName​(String name)
      以其名称返回 FontWeight 。
      static FontWeight findByWeight​(int weight)
      返回由CSS和OpenType规范定义的权重值最接近的 FontWeight 。
      int getWeight​()
      返回此 FontWeight指定的视觉重量（黑度或厚度）。
      static FontWeight valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FontWeight[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • THIN

        public static final FontWeight THIN
        代表瘦体重（100）。

      • EXTRA_LIGHT

        public static final FontWeight EXTRA_LIGHT
        代表“Extra Light”字体重量（200）。

      • LIGHT

        public static final FontWeight LIGHT
        表示轻型字体重量（300）。

      • NORMAL

        public static final FontWeight NORMAL
        表示正常字体重量（400）。

      • MEDIUM

        public static final FontWeight MEDIUM
        表示中等字体重量（500）。

      • SEMI_BOLD

        public static final FontWeight SEMI_BOLD
        代表“Demi Bold”字体重量（600）。

      • BOLD

        public static final FontWeight BOLD
        代表粗体字体重（700）。

      • EXTRA_BOLD

        public static final FontWeight EXTRA_BOLD
        代表“Extra Bold”字体重量（800）。

      • BLACK

        public static final FontWeight BLACK
        代表黑色字体重量（900）。

    • 方法详细信息

      • values

        public static FontWeight[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (FontWeight c : FontWeight.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static FontWeight valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • getWeight

        public int getWeight​()
        返回此 FontWeight指定的视觉重量（黑度或厚度）。
        结果
        重量

      • findByName

        public static FontWeight findByName​(String name)
        以其名称返回 FontWeight 。
        参数
        name - 名称 FontWeight
        结果
        FontWeight名称

      • findByWeight

        public static FontWeight findByWeight​(int weight)
        返回由CSS和OpenType规范定义的权重值最接近的FontWeight 。 如果两个FontWeight值之间的指定值是等距的，则实施可以自行选择。 此查找不引用字体，因此这完全是映射到FontWeight实例的集合，并不意味着该权重的字体将可用。
        参数
        weight - 重量值
        结果
        最近 FontWeight
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


HitInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.text

Class HitInfo

  • java.lang.Object
    • javafx.scene.text.HitInfo

  • public class HitInfo
extends Object
    表示文本节点中的命中信息。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getCharIndex​()
      该命中信息所指的字符的索引。
      int getInsertionIndex​()
      返回插入位置的索引。
      boolean isLeading​()
      指示命中是否在字符的前缘。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getCharIndex

        public int getCharIndex​()
        该命中信息所指的字符的索引。
        结果
        该命中信息所指的字符的索引

      • isLeading

        public boolean isLeading​()
        指示命中是否在字符的前缘。 如果它是假的，它代表后缘。
        结果
        如果真的，命中是在字符的前沿，否则的后缘

      • getInsertionIndex

        public int getInsertionIndex​()
        返回插入位置的索引。
        结果
        插入位置的索引

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.text (Java SE 9 & JDK 9 )

javafx.scene.text

Classes

  • Font
  • HitInfo
  • Text
  • TextFlow

Enums

  • FontPosture
  • FontSmoothingType
  • FontWeight
  • TextAlignment
  • TextBoundsType


javafx.scene.text (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene.text

为字体和可渲染的文本节点提供一组类。

  • 类摘要
    Class 描述
    Font
    Font类代表字体，用于在屏幕上呈现文本。
    HitInfo
    表示文本节点中的命中信息。
    Text
    Text类定义了一个显示文本的节点。
    TextFlow
    TextFlow是设计用于布置富文本的特殊布局。
  • 枚举摘要
    Enum 描述
    FontPosture
    指定字体是否为斜体
    FontSmoothingType
    FontSmoothingType枚举用于指定用于平滑屏幕文本字体边缘的首选机制。
    FontWeight
    指定在系统上搜索字体时可以使用的不同字体权重。
    TextAlignment
    TextAlignment枚举表示水平文本对齐。
    TextBoundsType
    指定由 Text节点报告的边界的行为。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.text Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.text

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.scene.text.Font
    • javafx.scene.text.HitInfo
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.text.TextFlow
      • javafx.scene.shape.Shape
        • javafx.scene.text.Text

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.text.FontPosture
      • javafx.scene.text.FontSmoothingType
      • javafx.scene.text.FontWeight
      • javafx.scene.text.TextAlignment
      • javafx.scene.text.TextBoundsType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Text (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.text

Class Text

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.shape.Shape
        • javafx.scene.text.Text
  • All Implemented Interfaces:
    Styleable ， EventTarget

    @DefaultProperty("text")
public class Text
extends Shape
    Text类定义了一个显示文本的节点。 段落由'\n'分隔，文本包裹在段落边界。
      import javafx.scene.text.*;

Text t = new Text(10, 50, "This is a test");
t.setFont(new Font(20));
      import javafx.scene.text.*;

Text t = new Text();
text.setFont(new Font(20));
text.setText("First row\nSecond row");
      import javafx.scene.text.*;

Text t = new Text();
text.setFont(new Font(20));
text.setWrappingWidth(200);
text.setTextAlignment(TextAlignment.JUSTIFY)
text.setText("The quick brown fox jumps over the lazy dog");
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyDoubleProperty baselineOffset
      “文字”（或罗马）基线偏离了文本节点的layoutBounds.minY位置。
      ObjectProperty<TextBoundsType> boundsType
      确定如何计算文本节点的边界。
      BooleanProperty caretBias
      IntegerProperty caretPosition
      ReadOnlyObjectProperty<PathElement[]> caretShape
      ObjectProperty<Font> font
      定义文本的字体。
      ObjectProperty<FontSmoothingType> fontSmoothingType
      指定所请求的字体平滑类型：灰色或LCD。
      DoubleProperty lineSpacing
      定义行之间像素的垂直空间。
      IntegerProperty selectionEnd
      ObjectProperty<Paint> selectionFill
      所选文字的填充颜色。
      ReadOnlyObjectProperty<PathElement[]> selectionShape
      IntegerProperty selectionStart
      BooleanProperty strikethrough
      定义每行文本是否应该有一行。
      ObjectProperty<TextAlignment> textAlignment
      在边界框中定义水平文本对齐。
      ObjectProperty<VPos> textOrigin
      以局部坐标定义文本坐标系的起点。
      StringProperty text
      定义要显示的文本字符串。
      BooleanProperty underline
      定义每行文本是否应在其下方有一行。
      DoubleProperty wrappingWidth
      定义用户空间坐标中文本的宽度约束，例如像素，而不是字形或字符数。
      DoubleProperty x
      定义文本原点的X坐标。
      DoubleProperty y
      定义文本原点的Y坐标。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.shape.Shape

        fill, smooth, strokeDashOffset, strokeLineCap, strokeLineJoin, strokeMiterLimit, stroke, strokeType, strokeWidth

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Text​()
      创建一个空的文本实例。
      Text​(double x, double y, String text)
      在包含给定字符串的给定坐标上创建一个Text实例。
      Text​(String text)
      创建一个包含给定字符串的文本的实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      ReadOnlyDoubleProperty baselineOffsetProperty​()
      “文字”（或罗马）基线偏离了文本节点的layoutBounds.minY位置。
      ObjectProperty<TextBoundsType> boundsTypeProperty​()
      确定如何计算文本节点的边界。
      BooleanProperty caretBiasProperty​()
      IntegerProperty caretPositionProperty​()
      PathElement[] caretShape​(int charIndex, boolean caretBias)
      在给定的索引和偏倚上返回插入符号的形状。
      ReadOnlyObjectProperty<PathElement[]> caretShapeProperty​()
      ObjectProperty<Font> fontProperty​()
      定义文本的字体。
      ObjectProperty<FontSmoothingType> fontSmoothingTypeProperty​()
      指定所请求的字体平滑类型：灰色或LCD。
      double getBaselineOffset​()
      获取属性baselineOffset的值。
      TextBoundsType getBoundsType​()
      获取属性boundsType的值。
      int getCaretPosition​()
      获取属性caretPosition的值。
      PathElement[] getCaretShape​()
      在本地坐标中插入符号的形状。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      Font getFont​()
      获取属性字体的值。
      FontSmoothingType getFontSmoothingType​()
      获取属性fontSmoothingType的值。
      double getLineSpacing​()
      获取属性lineSpacing的值。
      int getSelectionEnd​()
      获取属性selectionEnd的值。
      Paint getSelectionFill​()
      获取属性selectionFill的值。
      PathElement[] getSelectionShape​()
      局部坐标选择形状。
      int getSelectionStart​()
      获取属性selectionStart的值。
      String getText​()
      获取属性文本的值。
      TextAlignment getTextAlignment​()
      获取属性textAlignment的值。
      VPos getTextOrigin​()
      获取属性textOrigin的值。
      double getWrappingWidth​()
      获取propertyWidth的值。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      HitInfo hitTest​(Point2D point)
      将本地点映射到内容中的索引。
      boolean isCaretBias​()
      获取属性caretBias的值。
      boolean isStrikethrough​()
      获取属性删除线的值。
      boolean isUnderline​()
      获取属性下划线的值。
      DoubleProperty lineSpacingProperty​()
      定义行之间像素的垂直空间。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      PathElement[] rangeShape​(int start, int end)
      返回局部坐标中文本范围的形状。
      IntegerProperty selectionEndProperty​()
      ObjectProperty<Paint> selectionFillProperty​()
      所选文字的填充颜色。
      ReadOnlyObjectProperty<PathElement[]> selectionShapeProperty​()
      IntegerProperty selectionStartProperty​()
      void setBoundsType​(TextBoundsType value)
      设置属性boundsType的值。
      void setCaretBias​(boolean value)
      插入偏见的内容。
      void setCaretPosition​(int value)
      插入索引的内容。
      void setFont​(Font value)
      设置属性字体的值。
      void setFontSmoothingType​(FontSmoothingType value)
      设置属性fontSmoothingType的值。
      void setLineSpacing​(double spacing)
      设置属性lineSpacing的值。
      void setSelectionEnd​(int value)
      选择内容中的最终索引。
      void setSelectionFill​(Paint paint)
      设置属性selectionFill的值。
      void setSelectionStart​(int value)
      选择开始索引的内容。
      void setStrikethrough​(boolean value)
      设置属性删除线的值。
      void setText​(String value)
      设置属性文本的值。
      void setTextAlignment​(TextAlignment value)
      设置textAlignment属性的值。
      void setTextOrigin​(VPos value)
      设置属性textOrigin的值。
      void setUnderline​(boolean value)
      设置属性下划线的值。
      void setWrappingWidth​(double value)
      设置wrapWidth属性的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      BooleanProperty strikethroughProperty​()
      定义每行文本是否应该有一行。
      ObjectProperty<TextAlignment> textAlignmentProperty​()
      在边界框中定义水平文本对齐。
      ObjectProperty<VPos> textOriginProperty​()
      以局部坐标定义文本坐标系的起点。
      StringProperty textProperty​()
      定义要显示的文本字符串。
      String toString​()
      返回此 Text对象的字符串表示形式。
      BooleanProperty underlineProperty​()
      定义每行文本是否应在其下方有一行。
      PathElement[] underlineShape​(int start, int end)
      返回局部坐标下划线的形状。
      boolean usesMirroring​()
      确定当节点方向是从右到左时是否应该镜像节点。
      DoubleProperty wrappingWidthProperty​()
      定义用户空间坐标中文本的宽度约束，例如像素，而不是字形或字符数。
      DoubleProperty xProperty​()
      定义文本原点的X坐标。
      DoubleProperty yProperty​()
      定义文本原点的Y坐标。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isResizable, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookup, lookupAll, managedProperty, maxHeight, maxWidth, minHeight, minWidth, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, prefHeight, prefWidth, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resize, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, translateXProperty, translateYProperty, translateZProperty, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.shape.Shape

        fillProperty, getFill, getStroke, getStrokeDashArray, getStrokeDashOffset, getStrokeLineCap, getStrokeLineJoin, getStrokeMiterLimit, getStrokeType, getStrokeWidth, intersect, isSmooth, setFill, setSmooth, setStroke, setStrokeDashOffset, setStrokeLineCap, setStrokeLineJoin, setStrokeMiterLimit, setStrokeType, setStrokeWidth, smoothProperty, strokeDashOffsetProperty, strokeLineCapProperty, strokeLineJoinProperty, strokeMiterLimitProperty, strokeProperty, strokeTypeProperty, strokeWidthProperty, subtract, union

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • text

        public final StringProperty textProperty
        定义要显示的文本字符串。
        Default value:
        空字符串
        另请参见：
        getText() ， setText(String)

      • x

        public final DoubleProperty xProperty
        定义文本原点的X坐标。
        Default value:
        0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义文本原点的Y坐标。
        Default value:
        0
        另请参见：
        getY() ， setY(double)

      • font

        public final ObjectProperty<Font> fontProperty
        定义文本的字体。
        Default value:
        字体{}
        另请参见：
        getFont() ， setFont(Font)

      • textOrigin

        public final ObjectProperty<VPos> textOriginProperty
        以局部坐标定义文本坐标系的起点。 注意：如果渲染多行VPos.BASELINE和VPos.TOP定义顶行的原点，而VPos.BOTTOM定义了底行的原点。
        Default value:
        VPos.BASELINE
        另请参见：
        getTextOrigin() ， setTextOrigin(VPos)

      • boundsType

        public final ObjectProperty<TextBoundsType> boundsTypeProperty
        确定如何计算文本节点的边界。 逻辑边界对于文本而言比视觉边界更合适。 有关详细信息，请参阅TextBoundsType 。
        Default value:
        TextBoundsType.LOGICAL
        另请参见：
        getBoundsType() ， setBoundsType(TextBoundsType)

      • wrappingWidth

        public final DoubleProperty wrappingWidthProperty
        定义用户空间坐标中文本的宽度约束，例如像素，而不是字形或字符数。 如果值为> 0文本将根据需要进行行包装以满足此约束。
        Default value:
        0
        另请参见：
        getWrappingWidth() ， setWrappingWidth(double)

      • underline

        public final BooleanProperty underlineProperty
        定义每行文本是否应在其下方有一行。
        Default value:
        假
        另请参见：
        isUnderline() ， setUnderline(boolean)

      • strikethrough

        public final BooleanProperty strikethroughProperty
        定义每行文本是否应该有一行。
        Default value:
        假
        另请参见：
        isStrikethrough() ， setStrikethrough(boolean)

      • textAlignment

        public final ObjectProperty<TextAlignment> textAlignmentProperty
        在边界框中定义水平文本对齐。 边框的宽度由最宽的行定义。 注意：在单行文本的情况下，节点的宽度由文本的宽度决定，对齐设置不起作用。
        Default value:
        TextAlignment.LEFT
        另请参见：
        getTextAlignment() ， setTextAlignment(TextAlignment)

      • lineSpacing

        public final DoubleProperty lineSpacingProperty
        定义行之间像素的垂直空间。
        Default value:
        0
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getLineSpacing() ， setLineSpacing(double)

      • baselineOffset

        public final ReadOnlyDoubleProperty baselineOffsetProperty
        “文字”（或罗马）基线偏离了文本节点的layoutBounds.minY位置。 该值通常对应于字体的最大上升。
        另请参见：
        getBaselineOffset()

      • fontSmoothingType

        public final ObjectProperty<FontSmoothingType> fontSmoothingTypeProperty
        指定所请求的字体平滑类型：灰色或LCD。 边框的宽度由最宽的行定义。 注意：LCD模式不适用于许多情况，例如各种合成模式，其中应用效果和非常大的字形。
        Default value:
        FontSmoothingType.GRAY
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getFontSmoothingType() ， setFontSmoothingType(FontSmoothingType)

      • selectionShape

        public final ReadOnlyObjectProperty<PathElement[]> selectionShapeProperty
        另请参见：
        getSelectionShape()

      • selectionStart

        public final IntegerProperty selectionStartProperty
        另请参见：
        getSelectionStart() ， setSelectionStart(int)

      • selectionEnd

        public final IntegerProperty selectionEndProperty
        另请参见：
        getSelectionEnd() ， setSelectionEnd(int)

      • selectionFill

        public final ObjectProperty<Paint> selectionFillProperty
        所选文字的填充颜色。
        从以下版本开始：
        9
        另请参见：
        getSelectionFill() ， setSelectionFill(Paint)

      • caretShape

        public final ReadOnlyObjectProperty<PathElement[]> caretShapeProperty
        另请参见：
        getCaretShape()

      • caretPosition

        public final IntegerProperty caretPositionProperty
        另请参见：
        getCaretPosition() ， setCaretPosition(int)

      • caretBias

        public final BooleanProperty caretBiasProperty
        另请参见：
        isCaretBias() ， setCaretBias(boolean)

    • 构造方法详细信息

      • Text

        public Text​()
        创建一个空的文本实例。

      • Text

        public Text​(String text)
        创建一个包含给定字符串的文本的实例。
        参数
        text - 要包含在实例中的文本

      • Text

        public Text​(double x,
            double y,
            String text)
        在包含给定字符串的给定坐标上创建一个Text实例。
        参数
        x - 文本的水平位置
        y - 文本的垂直位置
        text - 要包含在实例中的文本

    • 方法详细信息

      • usesMirroring

        public boolean usesMirroring​()
        说明从类别复制： Node
        确定当节点方向是从右到左时是否应该镜像节点。

        当一个节点被镜像时，原点会自动移动到右上角，导致节点布局孩子，并使用镜像转换从右到左绘制。 一些节点可能希望从右到左绘制，而不使用转换。 这些节点将会回答false并实现从右到左的方向，而不使用自动转换。

        重写：
        usesMirroring在 Node
        结果
        如果这个 Node应该被镜像， Node true

      • setText

        public final void setText​(String value)
        设置属性文本的值。
        Property description:
        定义要显示的文本字符串。
        Default value:
        空字符串

      • getText

        public final String getText​()
        获取属性文本的值。
        Property description:
        定义要显示的文本字符串。
        Default value:
        空字符串

      • textProperty

        public final StringProperty textProperty​()
        定义要显示的文本字符串。
        Default value:
        空字符串
        另请参见：
        getText() ， setText(String)

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义文本原点的X坐标。
        Default value:
        0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义文本原点的X坐标。
        Default value:
        0

      • xProperty

        public final DoubleProperty xProperty​()
        定义文本原点的X坐标。
        Default value:
        0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义文本原点的Y坐标。
        Default value:
        0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义文本原点的Y坐标。
        Default value:
        0

      • yProperty

        public final DoubleProperty yProperty​()
        定义文本原点的Y坐标。
        Default value:
        0
        另请参见：
        getY() ， setY(double)

      • setFont

        public final void setFont​(Font value)
        设置属性字体的值。
        Property description:
        定义文本的字体。
        Default value:
        字体{}

      • getFont

        public final Font getFont​()
        获取属性字体的值。
        Property description:
        定义文本的字体。
        Default value:
        字体{}

      • fontProperty

        public final ObjectProperty<Font> fontProperty​()
        定义文本的字体。
        Default value:
        字体{}
        另请参见：
        getFont() ， setFont(Font)

      • setTextOrigin

        public final void setTextOrigin​(VPos value)
        设置属性textOrigin的值。
        Property description:
        以局部坐标定义文本坐标系的起点。 注意：如果渲染多行VPos.BASELINE和VPos.TOP定义顶行的原点，而VPos.BOTTOM定义了底行的原点。
        Default value:
        VPos.BASELINE

      • getTextOrigin

        public final VPos getTextOrigin​()
        获取属性textOrigin的值。
        Property description:
        以局部坐标定义文本坐标系的起点。 注意：如果渲染多行VPos.BASELINE和VPos.TOP定义顶行的原点，而VPos.BOTTOM定义底行的原点。
        Default value:
        VPos.BASELINE

      • textOriginProperty

        public final ObjectProperty<VPos> textOriginProperty​()
        以局部坐标定义文本坐标系的起点。 注意：如果渲染多行VPos.BASELINE和VPos.TOP定义顶行的原点，而VPos.BOTTOM定义底行的原点。
        Default value:
        VPos.BASELINE
        另请参见：
        getTextOrigin() ， setTextOrigin(VPos)

      • setBoundsType

        public final void setBoundsType​(TextBoundsType value)
        设置属性boundsType的值。
        Property description:
        确定如何计算文本节点的边界。 逻辑边界对于文本而言比视觉边界更合适。 有关详细信息，请参阅TextBoundsType 。
        Default value:
        TextBoundsType.LOGICAL

      • getBoundsType

        public final TextBoundsType getBoundsType​()
        获取属性boundsType的值。
        Property description:
        确定如何计算文本节点的边界。 逻辑边界对于文本而言比视觉边界更合适。 有关详细信息，请参阅TextBoundsType 。
        Default value:
        TextBoundsType.LOGICAL

      • boundsTypeProperty

        public final ObjectProperty<TextBoundsType> boundsTypeProperty​()
        确定如何计算文本节点的边界。 逻辑边界对于文本而言比视觉边界更合适。 有关详细信息，请参阅TextBoundsType 。
        Default value:
        TextBoundsType.LOGICAL
        另请参见：
        getBoundsType() ， setBoundsType(TextBoundsType)

      • setWrappingWidth

        public final void setWrappingWidth​(double value)
        设置wrapWidth属性的值。
        Property description:
        定义用户空间坐标中文本的宽度约束，例如像素，而不是字形或字符数。 如果值为> 0文本将根据需要进行行包装以满足此约束。
        Default value:
        0

      • getWrappingWidth

        public final double getWrappingWidth​()
        获取propertyWidth的值。
        Property description:
        定义用户空间坐标中文本的宽度约束，例如像素，而不是字形或字符数。 如果值为> 0文本将根据需要进行行包装以满足此约束。
        Default value:
        0

      • wrappingWidthProperty

        public final DoubleProperty wrappingWidthProperty​()
        定义用户空间坐标中文本的宽度约束，例如像素，而不是字形或字符数。 如果值为> 0文本将根据需要进行行包装以满足此约束。
        Default value:
        0
        另请参见：
        getWrappingWidth() ， setWrappingWidth(double)

      • setUnderline

        public final void setUnderline​(boolean value)
        设置属性下划线的值。
        Property description:
        定义每行文本是否应在其下方有一行。
        Default value:
        假

      • isUnderline

        public final boolean isUnderline​()
        获取属性下划线的值。
        Property description:
        定义每行文本是否应在其下方有一行。
        Default value:
        假

      • underlineProperty

        public final BooleanProperty underlineProperty​()
        定义每行文本是否应在其下方有一行。
        Default value:
        假
        另请参见：
        isUnderline() ， setUnderline(boolean)

      • setStrikethrough

        public final void setStrikethrough​(boolean value)
        设置属性删除线的值。
        Property description:
        定义每行文本是否应该有一行。
        Default value:
        假

      • isStrikethrough

        public final boolean isStrikethrough​()
        获取属性删除线的值。
        Property description:
        定义每行文本是否应该有一行。
        Default value:
        假

      • strikethroughProperty

        public final BooleanProperty strikethroughProperty​()
        定义每行文本是否应该有一行。
        Default value:
        假
        另请参见：
        isStrikethrough() ， setStrikethrough(boolean)

      • setTextAlignment

        public final void setTextAlignment​(TextAlignment value)
        设置textAlignment属性的值。
        Property description:
        在边界框中定义水平文本对齐。 边框的宽度由最宽的行定义。 注意：在单行文本的情况下，节点的宽度由文本的宽度决定，对齐设置不起作用。
        Default value:
        TextAlignment.LEFT

      • getTextAlignment

        public final TextAlignment getTextAlignment​()
        获取属性textAlignment的值。
        Property description:
        在边界框中定义水平文本对齐。 边框的宽度由最宽的行定义。 注意：在单行文本的情况下，节点的宽度由文本的宽度决定，对齐设置不起作用。
        Default value:
        TextAlignment.LEFT

      • textAlignmentProperty

        public final ObjectProperty<TextAlignment> textAlignmentProperty​()
        在边界框中定义水平文本对齐。 边框的宽度由最宽的行定义。 注意：在单行文本的情况下，节点的宽度由文本的宽度决定，对齐设置不起作用。
        Default value:
        TextAlignment.LEFT
        另请参见：
        getTextAlignment() ， setTextAlignment(TextAlignment)

      • setLineSpacing

        public final void setLineSpacing​(double spacing)
        设置属性lineSpacing的值。
        Property description:
        定义行之间像素的垂直空间。
        Default value:
        0
        从以下版本开始：
        JavaFX 8.0

      • getLineSpacing

        public final double getLineSpacing​()
        获取属性lineSpacing的值。
        Property description:
        定义行之间像素的垂直空间。
        Default value:
        0
        从以下版本开始：
        JavaFX 8.0

      • lineSpacingProperty

        public final DoubleProperty lineSpacingProperty​()
        定义行之间像素的垂直空间。
        Default value:
        0
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getLineSpacing() ， setLineSpacing(double)

      • getBaselineOffset

        public final double getBaselineOffset​()
        获取属性baselineOffset的值。
        重写：
        getBaselineOffset在 Node
        Property description:
        “文字”（或罗马）基线偏离了文本节点的layoutBounds.minY位置。 该值通常对应于字体的最大上升。
        结果
        对于不可调整大小的节点，文本基线与layoutBounds.minY的偏移量为 Node.BASELINE_OFFSET_SAME_AS_HEIGHT

      • baselineOffsetProperty

        public final ReadOnlyDoubleProperty baselineOffsetProperty​()
        “文字”（或罗马）基线偏离了文本节点的layoutBounds.minY位置。 该值通常对应于字体的最大上升。
        另请参见：
        getBaselineOffset()

      • setFontSmoothingType

        public final void setFontSmoothingType​(FontSmoothingType value)
        设置属性fontSmoothingType的值。
        Property description:
        指定所请求的字体平滑类型：灰色或LCD。 边框的宽度由最宽的行定义。 注意：LCD模式不适用于许多情况，例如各种合成模式，其中应用效果和非常大的字形。
        Default value:
        FontSmoothingType.GRAY
        从以下版本开始：
        JavaFX 2.1

      • getFontSmoothingType

        public final FontSmoothingType getFontSmoothingType​()
        获取属性fontSmoothingType的值。
        Property description:
        指定所请求的字体平滑类型：灰色或LCD。 边框的宽度由最宽的行定义。 注意：LCD模式不适用于许多情况，例如各种合成模式，其中应用效果和非常大的字形。
        Default value:
        FontSmoothingType.GRAY
        从以下版本开始：
        JavaFX 2.1

      • fontSmoothingTypeProperty

        public final ObjectProperty<FontSmoothingType> fontSmoothingTypeProperty​()
        指定所请求的字体平滑类型：灰色或LCD。 边框的宽度由最宽的行定义。 注意：LCD模式不适用于许多情况，例如各种合成模式，其中应用效果和非常大的字形。
        Default value:
        FontSmoothingType.GRAY
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getFontSmoothingType() ， setFontSmoothingType(FontSmoothingType)

      • getSelectionShape

        public final PathElement[] getSelectionShape​()
        局部坐标选择形状。
        结果
        局部坐标选择的形状
        从以下版本开始：
        9

      • selectionShapeProperty

        public final ReadOnlyObjectProperty<PathElement[]> selectionShapeProperty​()
        另请参见：
        getSelectionShape()

      • setSelectionStart

        public final void setSelectionStart​(int value)
        选择开始索引的内容。 设置为-1以取消设置选择。
        参数
        value - 选择开始索引
        从以下版本开始：
        9

      • getSelectionStart

        public final int getSelectionStart​()
        获取属性selectionStart的值。
        Property description:

      • selectionStartProperty

        public final IntegerProperty selectionStartProperty​()
        另请参见：
        getSelectionStart() ， setSelectionStart(int)

      • setSelectionEnd

        public final void setSelectionEnd​(int value)
        选择内容中的最终索引。 设置为-1以取消设置选择。
        参数
        value - 选择结束索引
        从以下版本开始：
        9

      • getSelectionEnd

        public final int getSelectionEnd​()
        获取属性selectionEnd的值。
        Property description:

      • selectionEndProperty

        public final IntegerProperty selectionEndProperty​()
        另请参见：
        getSelectionEnd() ， setSelectionEnd(int)

      • selectionFillProperty

        public final ObjectProperty<Paint> selectionFillProperty​()
        所选文字的填充颜色。
        从以下版本开始：
        9
        另请参见：
        getSelectionFill() ， setSelectionFill(Paint)

      • setSelectionFill

        public final void setSelectionFill​(Paint paint)
        设置属性selectionFill的值。
        Property description:
        所选文字的填充颜色。
        从以下版本开始：
        9

      • getSelectionFill

        public final Paint getSelectionFill​()
        获取属性selectionFill的值。
        Property description:
        所选文字的填充颜色。
        从以下版本开始：
        9

      • getCaretShape

        public final PathElement[] getCaretShape​()
        在本地坐标中插入符号的形状。
        结果
        在本地坐标中插入符号的形状
        从以下版本开始：
        9

      • caretShapeProperty

        public final ReadOnlyObjectProperty<PathElement[]> caretShapeProperty​()
        另请参见：
        getCaretShape()

      • setCaretPosition

        public final void setCaretPosition​(int value)
        插入索引的内容。 设置为-1以取消设置插入符号。
        参数
        value - 内容中的插入符号索引
        从以下版本开始：
        9

      • getCaretPosition

        public final int getCaretPosition​()
        获取属性caretPosition的值。
        Property description:

      • caretPositionProperty

        public final IntegerProperty caretPositionProperty​()
        另请参见：
        getCaretPosition() ， setCaretPosition(int)

      • setCaretBias

        public final void setCaretBias​(boolean value)
        插入偏见的内容。 true是指朝向主角的偏向。 （真=领先/假=尾随）
        参数
        value - 内容中的插入偏见
        从以下版本开始：
        9

      • isCaretBias

        public final boolean isCaretBias​()
        获取属性caretBias的值。
        Property description:

      • caretBiasProperty

        public final BooleanProperty caretBiasProperty​()
        另请参见：
        isCaretBias() ， setCaretBias(boolean)

      • hitTest

        public final HitInfo hitTest​(Point2D point)
        将本地点映射到内容中的索引。
        参数
        point - 要测试的指定点
        结果
        一个 HitInfo代表发现的字符索引
        从以下版本开始：
        9

      • caretShape

        public final PathElement[] caretShape​(int charIndex,
                                      boolean caretBias)
        在给定的索引和偏倚上返回插入符号的形状。
        参数
        charIndex - 插入符号的字符索引
        caretBias - 插入符号是否偏向字符的 caretBias
        结果
        一个 PathElement的阵列，可以用来创建一个 Shape
        从以下版本开始：
        9

      • rangeShape

        public final PathElement[] rangeShape​(int start,
                                      int end)
        返回局部坐标中文本范围的形状。
        参数
        start - 范围的起始字符索引
        end - 范围的结束字符索引（不包含）
        结果
        一个 PathElement的数组，可以用来创建一个 Shape
        从以下版本开始：
        9

      • underlineShape

        public final PathElement[] underlineShape​(int start,
                                          int end)
        返回局部坐标下划线的形状。
        参数
        start - 范围的起始字符索引
        end - 范围的结束字符索引（不包含）
        结果
        一个 PathElement的数组，可以用来创建一个 Shape
        从以下版本开始：
        9

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Shape
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • toString

        public String toString​()
        返回此 Text对象的字符串表示形式。
        重写：
        toString在 Node
        结果
        这个 Text对象的字符串表示形式。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Node
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TextAlignment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.text

Enum TextAlignment

  • java.lang.Object
    • java.lang.Enum<TextAlignment>
      • javafx.scene.text.TextAlignment
  • All Implemented Interfaces:
    Serializable ， Comparable<TextAlignment>

    public enum TextAlignment
extends Enum<TextAlignment>
    TextAlignment枚举表示水平文本对齐。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CENTER
      表示居中的文本对齐方式（左侧和右侧）。
      JUSTIFY
      表示对齐文本对齐。
      LEFT
      表示左侧的文本对齐方式（左对齐，右对齐）。
      RIGHT
      表示右侧的文本对齐方式（右对齐，左对齐）。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TextAlignment valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextAlignment[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LEFT

        public static final TextAlignment LEFT
        表示左侧的文本对齐方式（左对齐，右对齐）。

      • CENTER

        public static final TextAlignment CENTER
        表示居中的文本对齐方式（左侧和右侧）。

      • RIGHT

        public static final TextAlignment RIGHT
        表示右侧的文本对齐方式（右对齐，左对齐）。

      • JUSTIFY

        public static final TextAlignment JUSTIFY
        表示对齐文本对齐。

    • 方法详细信息

      • values

        public static TextAlignment[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TextAlignment c : TextAlignment.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TextAlignment valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TextBoundsType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.text

Enum TextBoundsType

  • java.lang.Object
    • java.lang.Enum<TextBoundsType>
      • javafx.scene.text.TextBoundsType
  • All Implemented Interfaces:
    Serializable ， Comparable<TextBoundsType>

    public enum TextBoundsType
extends Enum<TextBoundsType>
    指定由Text节点报告的边界的行为。 的设置影响layoutBounds ， boundsInLocal和boundsInParent文本的几何形状可在特定文本的边界而言要被渲染待测量或者-可视边界，或作为字体和字符的属性被呈现-逻辑边界。 视觉边界对于将文本定位为图形更为有用，并且可以在文本周围获得紧密的封闭边界。

    逻辑边界对于相对于其他文本和其他组件（特别是还包含文本的文本）的布局文本很重要。 边界不是特定于正在呈现的文本，因此也会报告高度，其中说明了使用其指定大小的字体的文本的潜在上升和下降。 前导和尾随空格也是文本的逻辑前进宽度的一部分。

    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      LOGICAL
      使用逻辑边界作为计算边界的依据。
      LOGICAL_VERTICAL_CENTER
      使用逻辑垂直居中边界作为计算边界的依据。
      VISUAL
      使用可视边界作为计算边界的依据。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TextBoundsType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextBoundsType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LOGICAL

        public static final TextBoundsType LOGICAL
        使用逻辑边界作为计算边界的依据。

        逻辑边界基于字体度量信息。 宽度是基于字形前进和上升，下降和线间隙的高度。 除了不包括线间隙的最后一行。

        注意：这通常是最快的选择。

      • VISUAL

        public static final TextBoundsType VISUAL
        使用可视边界作为计算边界的依据。

        注意：这可能比使用逻辑边界慢。

      • LOGICAL_VERTICAL_CENTER

        public static final TextBoundsType LOGICAL_VERTICAL_CENTER
        使用逻辑垂直居中边界作为计算边界的依据。

        这种边界类型通常用于将Text节点垂直放置在Text节点的边界内。

        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • values

        public static TextBoundsType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TextBoundsType c : TextBoundsType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TextBoundsType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


TextFlow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.text

Class TextFlow

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.layout.Pane
            • javafx.scene.text.TextFlow
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public class TextFlow
extends Pane
    TextFlow是设计用于布置富文本的特殊布局。 它可以用于在单个文本流中布置多个Text节点。 TextFlow使用文本和每个Text节点的字体加上它自己的宽度和文本对齐方式来确定每个孩子的位置。 单个Text节点可以跨越多条线路，由于包裹，并且由于双向重新排序， Text节点的视觉位置可能与逻辑位置不同。

    任何其他节点，而不是文本，将被视为文本布局中的嵌入对象。 它将使用其首选的宽度，高度和基线偏移量插入到内容中。

    当一个Text节点位于一个TextFlow内部时，其某些属性将被忽略。 例如， Text节点的x和y属性将被忽略，因为节点的位置由父节点决定。 同样， Text节点中的包装宽度被忽略，因为用于包装的宽度是TextFlow的宽度。 该值pickOnBounds一个财产Text设置为false当它被TextFlow的布局。 这是因为单个Text节点的内容可以分割并放置在TextFlow上的不同位置（通常是由于断线和双向重新排序）。

    布局的包装宽度由区域的当前宽度决定。 可以通过设置textflow的首选宽度来指定应用程序。 如果不需要打包，应用程序可以将首选项设置为Double.MAX_VALUE或Region.USE_COMPUTED_SIZE。

    段落由任何文本小孩中的'\n'分隔。

    TextFlow示例：

       Text text1 = new Text("Big italic red text"); text1.setFill(Color.RED); text1.setFont(Font.font("Helvetica", FontPosture.ITALIC, 40)); Text text2 = new Text(" little bold blue text"); text2.setFill(Color.BLUE); text2.setFont(Font.font("Helvetica", FontWeight.BOLD, 10)); TextFlow textFlow = new TextFlow(text1, text2);

    TextFlow布置每个受管孩子，不管孩子的可见属性值如何; 所有布局计算都忽略非托管孩子。

    TextFlow可以使用CSS来设计背景和边框。 有关详细信息，请参阅Region超类。

    可调整范围

    文本流的父级将在布局期间在文本流范围内调整文本流的大小。 默认情况下，文本流根据其内容计算此范围，如下表所示。

    TextFlow Resize Table width height minimum left/right insets top/bottom insets plus the height of the text content preferred left/right insets plus the width of the text content top/bottom insets plus the height of the text content maximum Double.MAX_VALUE Double.MAX_VALUE

    文本流的无界最大宽度和高度是父级的指示，它可以调整大小超出其首选大小，以填充分配给它的空间。

    TextFlow提供了直接设置尺寸范围的属性。 这些属性默认为哨兵值Region.USE_COMPUTED_SIZE，但是应用程序可能会根据需要将它们设置为其他值：

       textflow.setMaxWidth(500);
    应用程序可以通过将这些属性设置回Region.USE_COMPUTED_SIZE来还原计算值。

    默认情况下，TextFlow不会剪切其内容，因此如果小孩的pref大小大于文本流必须分配的空间，则儿童的边界可能会扩展到其自己的边界之外。

    从以下版本开始：
    JavaFX 8.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty lineSpacing
      定义行之间像素的垂直空间。
      ObjectProperty<TextAlignment> textAlignment
      定义水平文本对齐。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextFlow​()
      创建一个空TextFlow布局。
      TextFlow​(Node... children)
      使用给定的子项创建TextFlow布局。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      PathElement[] caretShape​(int charIndex, boolean leading)
      以局部坐标返回插入符号的形状。
      protected double computeMinHeight​(double width)
      计算该区域的最小高度。
      protected double computePrefHeight​(double width)
      计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。
      protected double computePrefWidth​(double height)
      计算给定高度的该区域的首选宽度。
      double getBaselineOffset​()
      基于第一个受管理的子节点计算基线偏移量。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      Orientation getContentBias​()
      返回节点调整大小偏置的方向以进行布局。
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      double getLineSpacing​()
      获取属性lineSpacing的值。
      TextAlignment getTextAlignment​()
      获取属性textAlignment的值。
      HitInfo hitTest​(Point2D point)
      将本地点映射到内容中的索引。
      protected void layoutChildren​()
      在布局传递过程中调用这个 Parent的孩子。
      DoubleProperty lineSpacingProperty​()
      定义行之间像素的垂直空间。
      Object queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)
      该方法由辅助技术调用以请求属性的值。
      PathElement[] rangeShape​(int start, int end)
      返回局部坐标中文本范围的形状。
      void requestLayout​()
      请求在渲染下一个场景之前执行布局传递。
      void setLineSpacing​(double spacing)
      设置属性lineSpacing的值。
      void setTextAlignment​(TextAlignment value)
      设置textAlignment属性的值。
      protected void setWidth​(double value)
      设置属性宽度的值。
      ObjectProperty<TextAlignment> textAlignmentProperty​()
      定义水平文本对齐。
      boolean usesMirroring​()
      确定当节点方向是从右到左时是否应该镜像节点。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.layout.Pane

        getChildren

      • Methods inherited from class javafx.scene.Parent

        getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, computeMaxHeight, computeMaxWidth, computeMinWidth, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isResizable, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • textAlignment

        public final ObjectProperty<TextAlignment> textAlignmentProperty
        定义水平文本对齐。
        Default value:
        TextAlignment.LEFT
        另请参见：
        getTextAlignment() ， setTextAlignment(TextAlignment)

      • lineSpacing

        public final DoubleProperty lineSpacingProperty
        定义行之间像素的垂直空间。
        Default value:
        0
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getLineSpacing() ， setLineSpacing(double)

    • 构造方法详细信息

      • TextFlow

        public TextFlow​()
        创建一个空TextFlow布局。

      • TextFlow

        public TextFlow​(Node... children)
        使用给定的子项创建TextFlow布局。
        参数
        children - 儿童。

    • 方法详细信息

      • hitTest

        public final HitInfo hitTest​(Point2D point)
        将本地点映射到内容中的索引。
        参数
        point - 要测试的指定点
        结果
        一个 HitInfo代表发现的字符索引
        从以下版本开始：
        9

      • caretShape

        public PathElement[] caretShape​(int charIndex,
                                boolean leading)
        以局部坐标返回插入符号的形状。
        参数
        charIndex - 插入符号的字符索引
        leading - 插入符号是否偏离字符的前沿
        结果
        一个 PathElement的数组，可以用来创建一个 Shape
        从以下版本开始：
        9

      • rangeShape

        public final PathElement[] rangeShape​(int start,
                                      int end)
        返回局部坐标中文本范围的形状。
        参数
        start - 范围的起始字符索引
        end - 范围的结束字符索引（不包含）
        结果
        一个 PathElement的阵列，可以用来创建一个 Shape
        从以下版本开始：
        9

      • usesMirroring

        public boolean usesMirroring​()
        描述从类复制： Node
        确定当节点方向是从右到左时是否应该镜像节点。

        当一个节点被镜像时，原点会自动移动到右上角，导致节点布局孩子，并使用镜像转换从右到左绘制。 一些节点可能希望从右到左绘制，而不使用转换。 这些节点将会回复false并实现从右到左的方向，而不使用自动转换。

        重写：
        usesMirroring在 Node
        结果
        如果这个 Node应该镜像， Node true

      • setWidth

        protected void setWidth​(double value)
        从类别复制的描述： Region
        设置属性宽度的值。
        重写：
        setWidth在 Region

      • computePrefWidth

        protected double computePrefWidth​(double height)
        描述从类复制： Region
        计算给定高度的该区域的首选宽度。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有VERTICAL内容偏差，则可以忽略height参数。
        重写：
        computePrefWidth在 Region
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        计算这个区域的首选宽度

      • computePrefHeight

        protected double computePrefHeight​(double width)
        描述从类复制： Region
        计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computePrefHeight在 Region
        参数
        width - 如果首选的高度取决于应该使用的宽度
        结果
        该区域计算的优选高度

      • computeMinHeight

        protected double computeMinHeight​(double width)
        描述从类复制： Region
        计算该区域的最小高度。 默认返回顶部和底部插入的总和。 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。 如果子类没有HORIZONTAL内容偏差，则可以忽略width参数。
        重写：
        computeMinHeight在 Region
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        计算该区域的最小高度

      • requestLayout

        public void requestLayout​()
        描述从类复制： Parent
        请求在渲染下一个场景之前执行布局传递。 这是异步批量发生一次“脉冲”或动画帧。

        如果此父对象是布局根或非托管，则将直接添加到场景的脏布局列表中，否则将调用requestParentLayout。

        重写：
        requestLayout在 Parent

      • getContentBias

        public Orientation getContentBias​()
        描述从类复制： Node
        返回节点调整大小偏置的方向以进行布局。 如果节点类型没有偏差，则返回null。 如果节点可调整大小，并且其高度取决于其宽度，则返回HORIZONTAL，否则如果其宽度取决于其高度，则返回VERTICAL。

        可调整大小的子类应该覆盖此方法以返回适当的值。

        重写：
        getContentBias类 Node
        结果
        width / height依赖的方向，如果没有则为null
        另请参见：
        Node.isResizable() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double)

      • layoutChildren

        protected void layoutChildren​()
        描述从类复制： Parent
        在布局传递过程中调用这个Parent的孩子。 默认情况下，它只会将受管理的可调整大小的内容的大小设置为其首选大小，并且不会执行任何节点定位。

        子类应该根据需要重写此函数以布局内容。

        重写：
        layoutChildren在 Parent

      • setTextAlignment

        public final void setTextAlignment​(TextAlignment value)
        设置textAlignment属性的值。
        Property description:
        定义水平文本对齐。
        Default value:
        TextAlignment.LEFT

      • getTextAlignment

        public final TextAlignment getTextAlignment​()
        获取属性textAlignment的值。
        Property description:
        定义水平文本对齐。
        Default value:
        TextAlignment.LEFT

      • textAlignmentProperty

        public final ObjectProperty<TextAlignment> textAlignmentProperty​()
        定义水平文本对齐。
        Default value:
        TextAlignment.LEFT
        另请参见：
        getTextAlignment() ， setTextAlignment(TextAlignment)

      • setLineSpacing

        public final void setLineSpacing​(double spacing)
        设置属性lineSpacing的值。
        Property description:
        定义行之间像素的垂直空间。
        Default value:
        0
        从以下版本开始：
        JavaFX 8.0

      • getLineSpacing

        public final double getLineSpacing​()
        获取属性lineSpacing的值。
        Property description:
        定义行之间像素的垂直空间。
        Default value:
        0
        从以下版本开始：
        JavaFX 8.0

      • lineSpacingProperty

        public final DoubleProperty lineSpacingProperty​()
        定义行之间像素的垂直空间。
        Default value:
        0
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getLineSpacing() ， setLineSpacing(double)

      • getBaselineOffset

        public final double getBaselineOffset​()
        描述从类复制： Parent
        基于第一个受管理的子节点计算基线偏移量。 如果没有这样的孩子，返回Node.getBaselineOffset() 。
        重写：
        getBaselineOffset在 Parent
        结果
        基线偏移

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        描述从类复制： Region
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Region
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。

      • queryAccessibleAttribute

        public Object queryAccessibleAttribute​(AccessibleAttribute attribute,
                                       Object... parameters)
        该方法由辅助技术调用以请求属性的值。

        子类通常覆盖此方法来实现特定角色所需的属性。
        如果未处理特定属性，则必须调用超类实现。

        重写：
        queryAccessibleAttribute在 Parent
        参数
        attribute - 请求的属性
        parameters - 可选参数列表
        结果
        请求的属性的值
        另请参见：
        AccessibleAttribute
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.text (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.text

  • Packages that use javafx.scene.text
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
  • Classes in javafx.scene.text used by javafx.css
    Class 描述
    Font
    Font类表示字体，用于在屏幕上呈现文本。
  • Classes in javafx.scene.text used by javafx.css.converter
    Class 描述
    Font
    Font类表示字体，用于在屏幕上呈现文本。
    FontPosture
    指定字体是否为斜体
    FontWeight
    指定在系统上搜索字体时可以使用的不同字体权重。
  • Classes in javafx.scene.text used by javafx.scene.canvas
    Class 描述
    Font
    Font类表示字体，用于在屏幕上呈现文本。
    FontSmoothingType
    FontSmoothingType枚举用于指定用于平滑屏幕文本字体边缘的首选机制。
    TextAlignment
    TextAlignment枚举表示水平文本对齐。
  • Classes in javafx.scene.text used by javafx.scene.chart
    Class 描述
    Font
    Font类表示字体，用于在屏幕上呈现文本。
  • Classes in javafx.scene.text used by javafx.scene.control
    Class 描述
    Font
    Font类表示字体，用于在屏幕上呈现文本。
    TextAlignment
    TextAlignment枚举代表水平文本对齐。
  • Classes in javafx.scene.text used by javafx.scene.control.skin
    Class 描述
    HitInfo
    表示文本节点中的命中信息。
  • Classes in javafx.scene.text used by javafx.scene.text
    Class 描述
    Font
    Font类代表字体，用于在屏幕上呈现文本。
    FontPosture
    指定字体是否为斜体
    FontSmoothingType
    FontSmoothingType枚举用于指定用于平滑屏幕文本字体边缘的首选机制。
    FontWeight
    指定在系统上搜索字体时可以使用的不同字体权重。
    HitInfo
    表示文本节点中的命中信息。
    TextAlignment
    TextAlignment枚举表示水平文本对齐。
    TextBoundsType
    指定由 Text节点报告的边界的行为。
  • Classes in javafx.scene.text used by javafx.scene.web
    Class 描述
    FontSmoothingType
    FontSmoothingType枚举用于指定用于平滑屏幕文本字体边缘的首选机制。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.text.Font (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.text.Font

  • Packages that use Font
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of Font in javafx.css

      Methods in javafx.css that return types with arguments of type Font
      Modifier and Type 方法 描述
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function)
      创建CssMetaData <S，Font>，初始值为 getDefault() ，并继承标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的CssMetaData <S，Font>并继承标志。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function)
      创建一个StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建一个具有初始值的StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Font>并继承标志。
      static StyleConverter<ParsedValue[],Font> StyleConverter.getFontConverter​()
      返回一个 StyleConverter ，其转换解析后的表示 Font至 Font 。
      Methods in javafx.css with parameters of type Font
      Modifier and Type | 方法 | 描述
      T ParsedValue.convert​(Font font)
      在这个 ParsedValue上调用 convert的方便方法。
      T StyleConverter.convert​(ParsedValue<F,T> value, Font font)
      从解析的CSS值转换为目标属性类型。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的CssMetaData <S，Font>并继承标志。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建一个具有初始值的StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Font>并继承标志。
      double Size.pixels​(double multiplier, Font font)
      将此大小转换为像素
      double Size.pixels​(Font font)
      如果尺寸不是绝对尺寸，请返回字体大小的乘积，以像素和值为单位。
      abstract double | SizeUnits.pixels​(double value, double multiplier, Font font)
      abstract double | SizeUnits.points​(double value, double multiplier, Font font)
      Method parameters in javafx.css with type arguments of type Font
      Modifier and Type 方法 描述
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function)
      创建一个CssMetaData <S，Font>，初始值为 getDefault() ，并继承标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。
      CssMetaData<S,Font> StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的CssMetaData <S，Font>并继承标志。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function)
      创建一个StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue)
      创建一个具有初始值的StyleableProperty <Font>。
      StyleableProperty<Font> StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Font>并继承标志。
      Constructors in javafx.css with parameters of type Font
      Constructor 描述
      FontCssMetaData​(String property, Font initial)
      从指定的属性和初始字体构造一个FontCSSMetaData对象。

    • Uses of Font in javafx.css.converter

      Methods in javafx.css.converter that return Font
      Modifier and Type | 方法 | 描述
      Font | FontConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)
      Font | FontConverter.convert​(ParsedValue<ParsedValue[],Font> value, Font font)
      Methods in javafx.css.converter that return types with arguments of type Font
      Modifier and Type | 方法 | 描述
      static StyleConverter<ParsedValue[],Font> | FontConverter.getInstance​()
      Methods in javafx.css.converter with parameters of type Font
      Modifier and Type | 方法 | 描述
      Boolean | BooleanConverter.convert​(ParsedValue<String,Boolean> value, Font not_used)
      Color | ColorConverter.convert​(ParsedValue<String,Color> value, Font font)
      Cursor | CursorConverter.convert​(ParsedValue<String,Cursor> value, Font not_used)
      Color | DeriveColorConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)
      Size | DeriveSizeConverter.convert​(ParsedValue<ParsedValue<Size,Size>[],Size> value, Font font)
      Duration | DurationConverter.convert​(ParsedValue<ParsedValue<?,Size>,Duration> value, Font font)
      Effect | EffectConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      Effect | EffectConverter.DropShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      Effect | EffectConverter.InnerShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)
      E | EnumConverter.convert​(ParsedValue<String,E> value, Font not_used)
      Font | FontConverter.convert​(ParsedValue<ParsedValue[],Font> value, Font font)
      Number | FontConverter.FontSizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      FontPosture | FontConverter.FontStyleConverter.convert​(ParsedValue<String,FontPosture> value, Font font)
      FontWeight | FontConverter.FontWeightConverter.convert​(ParsedValue<String,FontWeight> value, Font font)
      Insets | InsetsConverter.convert​(ParsedValue<ParsedValue[],Insets> value, Font font)
      Insets[] | InsetsConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<ParsedValue[],Insets>[],Insets[]> value, Font font)
      Color | LadderConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)
      Paint | PaintConverter.convert​(ParsedValue<ParsedValue<?,Paint>,Paint> value, Font font)
      Paint | PaintConverter.ImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.LinearGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.RadialGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint | PaintConverter.RepeatingImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)
      Paint[] | PaintConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<?,Paint>[],Paint[]> value, Font font)
      Shape | ShapeConverter.convert​(ParsedValue<String,Shape> value, Font font)
      Number | SizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      Number[] | SizeConverter.SequenceConverter.convert​(ParsedValue<ParsedValue[],Number[]> value, Font font)
      Stop | StopConverter.convert​(ParsedValue<ParsedValue[],Stop> value, Font font)
      String | StringConverter.convert​(ParsedValue<String,String> value, Font font)
      String[] | StringConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<String,String>[],String[]> value, Font font)
      String | URLConverter.convert​(ParsedValue<ParsedValue[],String> value, Font font)
      String[] | URLConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<ParsedValue[],String>[],String[]> value, Font font)
      Method parameters in javafx.css.converter with type arguments of type Font
      Modifier and Type | 方法 | 描述
      Font | FontConverter.convert​(ParsedValue<ParsedValue[],Font> value, Font font)

    • Uses of Font in javafx.scene.canvas

      Methods in javafx.scene.canvas that return Font
      Modifier and Type 方法 描述
      Font GraphicsContext.getFont​()
      获取当前字体。
      Methods in javafx.scene.canvas with parameters of type Font
      Modifier and Type 方法 描述
      void GraphicsContext.setFont​(Font f)
      设置当前字体。

    • Uses of Font in javafx.scene.chart

      Methods in javafx.scene.chart that return Font
      Modifier and Type 方法 描述
      Font Axis.getTickLabelFont​()
      获取属性tickLabelFont的值。
      Methods in javafx.scene.chart that return types with arguments of type Font
      Modifier and Type 方法 描述
      ObjectProperty<Font> Axis.tickLabelFontProperty​()
      所有刻度标签的字体
      Methods in javafx.scene.chart with parameters of type Font
      Modifier and Type 方法 描述
      void Axis.setTickLabelFont​(Font value)
      设置属性tickLabelFont的值。

    • Uses of Font in javafx.scene.control

      Methods in javafx.scene.control that return Font
      Modifier and Type 方法 描述
      Font Labeled.getFont​()
      获取属性字体的值。
      Font TextInputControl.getFont​()
      获取属性字体的值。
      Font Tooltip.getFont​()
      获取属性字体的值。
      Methods in javafx.scene.control that return types with arguments of type Font
      Modifier and Type 方法 描述
      ObjectProperty<Font> Labeled.fontProperty​()
      用于标签中文本的默认字体。
      ObjectProperty<Font> TextInputControl.fontProperty​()
      TextInputControl中用于文本的默认字体。
      ObjectProperty<Font> Tooltip.fontProperty​()
      工具提示中用于文本的默认字体。
      Methods in javafx.scene.control with parameters of type Font
      Modifier and Type 方法 描述
      void Labeled.setFont​(Font value)
      设置属性字体的值。
      void TextInputControl.setFont​(Font value)
      设置属性字体的值。
      void Tooltip.setFont​(Font value)
      设置属性字体的值。

    • Uses of Font in javafx.scene.text

      Methods in javafx.scene.text that return Font
      Modifier and Type 方法 描述
      static Font Font.font​(double size)
      根据默认的字体系列名称和给定的字体大小搜索适当的字体。
      static Font Font.font​(String family)
      根据给定的字体系列名称和默认字体大小搜索适当的字体。
      static Font Font.font​(String family, double size)
      根据字体系列名称和大小搜索适当的字体。
      static Font Font.font​(String family, FontPosture posture, double size)
      根据字体系列名称和姿势样式，搜索适合的字体。
      static Font Font.font​(String family, FontWeight weight, double size)
      根据字体系列名称和体重样式搜索适当的字体。
      static Font Font.font​(String family, FontWeight weight, FontPosture posture, double size)
      根据字体系列名称，体重和姿势样式搜索适当的字体。
      static Font Font.getDefault​()
      获取将来自“系统”系列的默认字体，通常为“常规”样式，并且具有与用户桌面环境一致的大小，至可以确定的程度。
      Font Text.getFont​()
      获取属性字体的值。
      static Font Font.loadFont​(InputStream in, double size)
      从指定的输入流加载字体资源。
      static Font Font.loadFont​(String urlStr, double size)
      从指定的URL加载字体资源。
      static Font[] Font.loadFonts​(InputStream in, double size)
      从指定的输入流中加载字体资源。
      static Font[] Font.loadFonts​(String urlStr, double size)
      从指定的URL加载字体资源。
      Methods in javafx.scene.text that return types with arguments of type Font
      Modifier and Type 方法 描述
      ObjectProperty<Font> Text.fontProperty​()
      定义文本的字体。
      Methods in javafx.scene.text with parameters of type Font
      Modifier and Type 方法 描述
      void Text.setFont​(Font value)
      设置属性字体的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.text.FontPosture (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.text.FontPosture

  • Packages that use FontPosture
    软件包 描述
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of FontPosture in javafx.css.converter

      Methods in javafx.css.converter that return FontPosture
      Modifier and Type | 方法 | 描述
      FontPosture | FontConverter.FontStyleConverter.convert​(ParsedValue<String,FontPosture> value, Font font)
      Method parameters in javafx.css.converter with type arguments of type FontPosture
      Modifier and Type | 方法 | 描述
      FontPosture | FontConverter.FontStyleConverter.convert​(ParsedValue<String,FontPosture> value, Font font)

    • Uses of FontPosture in javafx.scene.text

      Methods in javafx.scene.text that return FontPosture
      Modifier and Type 方法 描述
      static FontPosture FontPosture.findByName​(String name)
      以其名称返回 FontPosture 。
      static FontPosture FontPosture.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FontPosture[] FontPosture.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.text with parameters of type FontPosture
      Modifier and Type 方法 描述
      static Font Font.font​(String family, FontPosture posture, double size)
      根据字体系列名称和姿势样式，搜索适合的字体。
      static Font Font.font​(String family, FontWeight weight, FontPosture posture, double size)
      Searches for an appropriate font based on the font family name and weight and posture style.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.text.FontSmoothingType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.text.FontSmoothingType

  • Packages that use FontSmoothingType
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of FontSmoothingType in javafx.scene.canvas

      Methods in javafx.scene.canvas that return FontSmoothingType
      Modifier and Type 方法 描述
      FontSmoothingType GraphicsContext.getFontSmoothingType​()
      获取当前的字体平滑类型。
      Methods in javafx.scene.canvas with parameters of type FontSmoothingType
      Modifier and Type 方法 描述
      void GraphicsContext.setFontSmoothingType​(FontSmoothingType fontsmoothing)
      设置当前的字体平滑类型。

    • Uses of FontSmoothingType in javafx.scene.text

      Methods in javafx.scene.text that return FontSmoothingType
      Modifier and Type 方法 描述
      FontSmoothingType Text.getFontSmoothingType​()
      获取属性fontSmoothingType的值。
      static FontSmoothingType FontSmoothingType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FontSmoothingType[] FontSmoothingType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.text that return types with arguments of type FontSmoothingType
      Modifier and Type 方法 描述
      ObjectProperty<FontSmoothingType> Text.fontSmoothingTypeProperty​()
      指定所请求的字体平滑类型：灰色或LCD。
      Methods in javafx.scene.text with parameters of type FontSmoothingType
      Modifier and Type 方法 描述
      void Text.setFontSmoothingType​(FontSmoothingType value)
      设置属性fontSmoothingType的值。

    • Uses of FontSmoothingType in javafx.scene.web

      Methods in javafx.scene.web that return FontSmoothingType
      Modifier and Type 方法 描述
      FontSmoothingType WebView.getFontSmoothingType​()
      获取属性fontSmoothingType的值。
      Methods in javafx.scene.web that return types with arguments of type FontSmoothingType
      Modifier and Type 方法 描述
      ObjectProperty<FontSmoothingType> WebView.fontSmoothingTypeProperty​()
      指定所请求的字体平滑类型：灰色或LCD。
      Methods in javafx.scene.web with parameters of type FontSmoothingType
      Modifier and Type 方法 描述
      void WebView.setFontSmoothingType​(FontSmoothingType value)
      Sets the value of the property fontSmoothingType.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.text.FontWeight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.text.FontWeight

  • Packages that use FontWeight
    软件包 描述
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of FontWeight in javafx.css.converter

      Methods in javafx.css.converter that return FontWeight
      Modifier and Type | 方法 | 描述
      FontWeight | FontConverter.FontWeightConverter.convert​(ParsedValue<String,FontWeight> value, Font font)
      Method parameters in javafx.css.converter with type arguments of type FontWeight
      Modifier and Type | 方法 | 描述
      FontWeight | FontConverter.FontWeightConverter.convert​(ParsedValue<String,FontWeight> value, Font font)

    • Uses of FontWeight in javafx.scene.text

      Methods in javafx.scene.text that return FontWeight
      Modifier and Type 方法 描述
      static FontWeight FontWeight.findByName​(String name)
      以其名称返回 FontWeight 。
      static FontWeight FontWeight.findByWeight​(int weight)
      返回由CSS和OpenType规范定义的权重值最接近的 FontWeight 。
      static FontWeight FontWeight.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FontWeight[] FontWeight.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.text with parameters of type FontWeight
      Modifier and Type 方法 描述
      static Font Font.font​(String family, FontWeight weight, double size)
      根据字体系列名称和体重样式搜索适当的字体。
      static Font Font.font​(String family, FontWeight weight, FontPosture posture, double size)
      根据字体系列名称，体重和姿势样式搜索适当的字体。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.text.HitInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.text.HitInfo

  • Packages that use HitInfo
    软件包 描述
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of HitInfo in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return HitInfo
      Modifier and Type 方法 描述
      HitInfo TextAreaSkin.getIndex​(double x, double y)
      执行命中测试，映射到内容中的索引。
      HitInfo TextFieldSkin.getIndex​(double x, double y)
      执行命中测试，映射到内容中的索引。
      Methods in javafx.scene.control.skin with parameters of type HitInfo
      Modifier and Type 方法 描述
      void TextAreaSkin.positionCaret​(HitInfo hit, boolean select)
      将插入符号移动到指定的位置。
      void TextFieldSkin.positionCaret​(HitInfo hit, boolean select)
      将插入符号移动到指定的位置。

    • Uses of HitInfo in javafx.scene.text

      Methods in javafx.scene.text that return HitInfo
      Modifier and Type 方法 描述
      HitInfo Text.hitTest​(Point2D point)
      将本地点映射到内容中的索引。
      HitInfo TextFlow.hitTest​(Point2D point)
      将本地点映射到内容中的索引。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.text.Text (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.text.Text

No usage of javafx.scene.text.Text
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.text.TextAlignment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.text.TextAlignment

  • Packages that use TextAlignment
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of TextAlignment in javafx.scene.canvas

      Methods in javafx.scene.canvas that return TextAlignment
      Modifier and Type 方法 描述
      TextAlignment GraphicsContext.getTextAlign​()
      获得当前的 TextAlignment 。
      Methods in javafx.scene.canvas with parameters of type TextAlignment
      Modifier and Type 方法 描述
      void GraphicsContext.setTextAlign​(TextAlignment align)
      定义水平文本对齐，相对于文本 x来源。

    • Uses of TextAlignment in javafx.scene.control

      Methods in javafx.scene.control that return TextAlignment
      Modifier and Type 方法 描述
      TextAlignment Labeled.getTextAlignment​()
      获取属性textAlignment的值。
      TextAlignment Tooltip.getTextAlignment​()
      获取属性textAlignment的值。
      Methods in javafx.scene.control that return types with arguments of type TextAlignment
      Modifier and Type 方法 描述
      ObjectProperty<TextAlignment> Labeled.textAlignmentProperty​()
      指定 文本行多行的行为行 Labeled.contentDisplayProperty()影响图形和文本，此设置仅影响文本边界的多行文本。
      ObjectProperty<TextAlignment> Tooltip.textAlignmentProperty​()
      指定 文本行多行时的行为。
      Methods in javafx.scene.control with parameters of type TextAlignment
      Modifier and Type 方法 描述
      void Labeled.setTextAlignment​(TextAlignment value)
      设置textAlignment属性的值。
      void Tooltip.setTextAlignment​(TextAlignment value)
      设置textAlignment属性的值。

    • Uses of TextAlignment in javafx.scene.text

      Methods in javafx.scene.text that return TextAlignment
      Modifier and Type 方法 描述
      TextAlignment Text.getTextAlignment​()
      获取属性textAlignment的值。
      TextAlignment TextFlow.getTextAlignment​()
      获取属性textAlignment的值。
      static TextAlignment TextAlignment.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextAlignment[] TextAlignment.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.text that return types with arguments of type TextAlignment
      Modifier and Type 方法 描述
      ObjectProperty<TextAlignment> Text.textAlignmentProperty​()
      在边界框中定义水平文本对齐。
      ObjectProperty<TextAlignment> TextFlow.textAlignmentProperty​()
      定义水平文本对齐。
      Methods in javafx.scene.text with parameters of type TextAlignment
      Modifier and Type 方法 描述
      void Text.setTextAlignment​(TextAlignment value)
      设置textAlignment属性的值。
      void TextFlow.setTextAlignment​(TextAlignment value)
      Sets the value of the property textAlignment.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.text.TextBoundsType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.text.TextBoundsType

  • Packages that use TextBoundsType
    软件包 描述
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。

    • Uses of TextBoundsType in javafx.scene.text

      Methods in javafx.scene.text that return TextBoundsType
      Modifier and Type 方法 描述
      TextBoundsType Text.getBoundsType​()
      获取属性boundsType的值。
      static TextBoundsType TextBoundsType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TextBoundsType[] TextBoundsType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.text that return types with arguments of type TextBoundsType
      Modifier and Type 方法 描述
      ObjectProperty<TextBoundsType> Text.boundsTypeProperty​()
      确定如何计算文本节点的边界。
      Methods in javafx.scene.text with parameters of type TextBoundsType
      Modifier and Type 方法 描述
      void Text.setBoundsType​(TextBoundsType value)
      设置属性boundsType的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.text.TextFlow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.text.TextFlow

No usage of javafx.scene.text.TextFlow
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Affine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.transform

Class Affine

  • java.lang.Object
    • javafx.scene.transform.Transform
      • javafx.scene.transform.Affine
  • All Implemented Interfaces:
    Cloneable ， EventTarget

    public class Affine
extends Transform

    Affine类代表一般的仿射变换。 仿射变换执行从2D / 3D坐标到其他2D / 3D坐标的线性映射，同时保持线的“平直度”和“平行度”。 仿射变换可以使用序列旋转，平移，尺度和剪切来构建。

    对于简单的转换应用程序开发人员应使用特定Translate ， Scale ， Rotate ，或Shear变换，这是更轻便，因此对于这个简单的目的更优。 另一方面， Affine课程具有能够代表一般仿射变换和对其进行矩阵运算的优点，因此适合更复杂的变换用法。

    这样的坐标变换可以由3行×4列矩阵表示。 该矩阵将源坐标(x,y,z)转换为目标坐标(x',y',z') ，将它们视为列向量，并根据以下处理将坐标矢量乘以矩阵：

      [ x']   [  mxx  mxy  mxz  tx  ] [ x ]   [ mxx * x + mxy * y + mxz * z + tx ]
      [ y'] = [  myx  myy  myz  ty  ] [ y ] = [ myx * x + myy * y + myz * z + ty ]
      [ z']   [  mzx  mzy  mzz  tz  ] [ z ]   [ mzx * x + mzy * y + mzz * z + tz ]
                                      [ 1 ]
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty mxx
      定义3x4矩阵的X坐标缩放元素。
      DoubleProperty mxy
      定义3x4矩阵的XY坐标元素。
      DoubleProperty mxz
      定义3x4矩阵的XZ坐标元素。
      DoubleProperty myx
      定义3x4矩阵的YX坐标元素。
      DoubleProperty myy
      定义3x4矩阵的Y坐标缩放元素。
      DoubleProperty myz
      定义3x4矩阵的YZ坐标元素。
      DoubleProperty mzx
      定义3x4矩阵的ZX坐标元素。
      DoubleProperty mzy
      定义3x4矩阵的ZY坐标元素。
      DoubleProperty mzz
      定义3x4矩阵的Z坐标缩放元素。
      DoubleProperty tx
      定义3x4矩阵的X坐标转换元素。
      DoubleProperty ty
      定义3x4矩阵的Y坐标转换元素。
      DoubleProperty tz
      定义3x4矩阵的Z坐标转换元素。

      • Properties inherited from class javafx.scene.transform.Transform

        identity, onTransformChanged, type2D

    • 构造方法摘要

      构造方法
      Constructor 描述
      Affine​()
      创建一个包含身份转换的新实例 Affine 。
      Affine​(double[] matrix, MatrixType type, int offset)
      使用由数组指定的转换矩阵创建一个新的 Affine实例。
      Affine​(double mxx, double mxy, double tx, double myx, double myy, double ty)
      用元素值指定的2D变换创建一个新的实例 Affine 。
      Affine​(double mxx, double mxy, double mxz, double tx, double myx, double myy, double myz, double ty, double mzx, double mzy, double mzz, double tz)
      使用由元素值指定的变换创建一个新的实例 Affine 。
      Affine​(Transform transform)
      创建一个填充了指定变换值的新实例 Affine 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void append​(double[] matrix, MatrixType type, int offset)
      将数组指定的变换追加到此实例。
      void append​(double mxx, double mxy, double tx, double myx, double myy, double ty)
      将元素值指定的2D变换附加到此实例。
      void append​(double mxx, double mxy, double mxz, double tx, double myx, double myy, double myz, double ty, double mzx, double mzy, double mzz, double tz)
      将由元素值指定的变换附加到此实例。
      void append​(Transform transform)
      将指定的变换附加到此实例。
      void appendRotation​(double angle)
      将2D旋转追加到此实例。
      void appendRotation​(double angle, double pivotX, double pivotY)
      使用枢轴将2D旋转附加到此实例。
      void appendRotation​(double angle, double pivotX, double pivotY, double pivotZ, double axisX, double axisY, double axisZ)
      将旋转追加到此实例。
      void appendRotation​(double angle, double pivotX, double pivotY, double pivotZ, Point3D axis)
      将旋转追加到此实例。
      void appendRotation​(double angle, Point2D pivot)
      使用枢轴将2D旋转附加到此实例。
      void appendRotation​(double angle, Point3D pivot, Point3D axis)
      将旋转追加到此实例。
      void appendScale​(double sx, double sy)
      将2D刻度追加到此实例。
      void appendScale​(double sx, double sy, double sz)
      追加比例到这个实例。
      void appendScale​(double sx, double sy, double pivotX, double pivotY)
      将具有枢轴的2D刻度附加到此实例。
      void appendScale​(double sx, double sy, double sz, double pivotX, double pivotY, double pivotZ)
      使用pivot附加到此实例的缩放。
      void appendScale​(double sx, double sy, double sz, Point3D pivot)
      使用pivot附加到此实例的缩放。
      void appendScale​(double sx, double sy, Point2D pivot)
      将具有枢轴的2D刻度附加到此实例。
      void appendShear​(double shx, double shy)
      附加剪切到这个实例。
      void appendShear​(double shx, double shy, double pivotX, double pivotY)
      用枢轴附加剪切到这个实例。
      void appendShear​(double shx, double shy, Point2D pivot)
      用枢轴附加剪切到这个实例。
      void appendTranslation​(double tx, double ty)
      将2D翻译附加到此实例。
      void appendTranslation​(double tx, double ty, double tz)
      将翻译附加到此实例。
      Affine clone​()
      返回此转换的深层副本。
      Transform createConcatenation​(Transform transform)
      返回此变换和指定变换的并置。
      Affine createInverse​()
      返回此变换的逆变换。
      Point2D deltaTransform​(double x, double y)
      通过该变换来变换相对幅度矢量。
      Point3D deltaTransform​(double x, double y, double z)
      通过该变换来变换相对幅度矢量。
      double determinant​()
      计算转换矩阵的行列式。
      double getMxx​()
      获取属性mxx的值。
      double getMxy​()
      获取属性mxy的值。
      double getMxz​()
      获取属性mxz的值。
      double getMyx​()
      获取属性myx的值。
      double getMyy​()
      获取属性myy的价值。
      double getMyz​()
      获取属性myz的值。
      double getMzx​()
      获取属性mzx的值。
      double getMzy​()
      获取属性mzy的值。
      double getMzz​()
      获取属性mzz的值。
      double getTx​()
      获取属性tx的值。
      double getTy​()
      获取属性值的值。
      double getTz​()
      获取属性tz的值。
      Point2D inverseDeltaTransform​(double x, double y)
      通过该变换的逆变换相对幅度矢量。
      Point3D inverseDeltaTransform​(double x, double y, double z)
      通过该变换的逆变换相对幅度矢量。
      Point2D inverseTransform​(double x, double y)
      通过该变换的逆变换指定点。
      Point3D inverseTransform​(double x, double y, double z)
      通过该变换的逆变换指定点。
      void invert​()
      将此转换转换到位。
      DoubleProperty mxxProperty​()
      定义3x4矩阵的X坐标缩放元素。
      DoubleProperty mxyProperty​()
      定义3x4矩阵的XY坐标元素。
      DoubleProperty mxzProperty​()
      定义3x4矩阵的XZ坐标元素。
      DoubleProperty myxProperty​()
      定义3x4矩阵的YX坐标元素。
      DoubleProperty myyProperty​()
      定义3x4矩阵的Y坐标缩放元素。
      DoubleProperty myzProperty​()
      定义3x4矩阵的YZ坐标元素。
      DoubleProperty mzxProperty​()
      定义3x4矩阵的ZX坐标元素。
      DoubleProperty mzyProperty​()
      定义3x4矩阵的ZY坐标元素。
      DoubleProperty mzzProperty​()
      定义3x4矩阵的Z坐标缩放元素。
      void prepend​(double[] matrix, MatrixType type, int offset)
      将数组指定的变换预置到此实例。
      void prepend​(double mxx, double mxy, double tx, double myx, double myy, double ty)
      将由元素值指定的2D变换预置到此实例。
      void prepend​(double mxx, double mxy, double mxz, double tx, double myx, double myy, double myz, double ty, double mzx, double mzy, double mzz, double tz)
      将由元素值指定的变换预置到此实例。
      void prepend​(Transform transform)
      将指定的变换预置到此实例。
      void prependRotation​(double angle)
      将2D旋转预置到此实例。
      void prependRotation​(double angle, double pivotX, double pivotY)
      使用枢轴将2D旋转预加到此实例。
      void prependRotation​(double angle, double pivotX, double pivotY, double pivotZ, double axisX, double axisY, double axisZ)
      预先轮换到这个实例。
      void prependRotation​(double angle, double pivotX, double pivotY, double pivotZ, Point3D axis)
      预先轮换到这个实例。
      void prependRotation​(double angle, Point2D pivot)
      使用枢轴将2D旋转预加到此实例。
      void prependRotation​(double angle, Point3D pivot, Point3D axis)
      预先轮换到这个实例。
      void prependScale​(double sx, double sy)
      将2D刻度放在这个实例上。
      void prependScale​(double sx, double sy, double sz)
      为这个例子准备了比例。
      void prependScale​(double sx, double sy, double pivotX, double pivotY)
      使用这个实例的枢轴来预处理二维刻度。
      void prependScale​(double sx, double sy, double sz, double pivotX, double pivotY, double pivotZ)
      使用这个实例的pivot来预览缩放比例。
      void prependScale​(double sx, double sy, double sz, Point3D pivot)
      使用这个实例的pivot来预览缩放比例。
      void prependScale​(double sx, double sy, Point2D pivot)
      使用这个实例的枢轴来预处理二维刻度。
      void prependShear​(double shx, double shy)
      为这个例子预先剪切。
      void prependShear​(double shx, double shy, double pivotX, double pivotY)
      在这种情况下用枢轴预先剪切。
      void prependShear​(double shx, double shy, Point2D pivot)
      在这种情况下用枢轴预先剪切。
      void prependTranslation​(double tx, double ty)
      将2D翻译准备到此实例。
      void prependTranslation​(double tx, double ty, double tz)
      准备翻译到这个实例。
      void setElement​(MatrixType type, int row, int column, double value)
      设置变换矩阵的指定元素。
      void setMxx​(double value)
      设置属性mxx的值。
      void setMxy​(double value)
      设置属性mxy的值。
      void setMxz​(double value)
      设置属性mxz的值。
      void setMyx​(double value)
      设置属性myx的值。
      void setMyy​(double value)
      设置属性myy的值。
      void setMyz​(double value)
      设置属性myz的值。
      void setMzx​(double value)
      设置属性mzx的值。
      void setMzy​(double value)
      设置属性mzy的值。
      void setMzz​(double value)
      设置属性mzz的值。
      void setToIdentity​()
      将此转换重置为身份转换。
      void setToTransform​(double[] matrix, MatrixType type, int offset)
      将此实例的值设置为由数组指定的转换矩阵。
      void setToTransform​(double mxx, double mxy, double tx, double myx, double myy, double ty)
      将此实例的值设置为由元素值指定的2D变换。
      void setToTransform​(double mxx, double mxy, double mxz, double tx, double myx, double myy, double myz, double ty, double mzx, double mzy, double mzz, double tz)
      将此实例的值设置为由元素值指定的变换。
      void setToTransform​(Transform transform)
      将此实例的值设置为指定转换提供的值。
      void setTx​(double value)
      设置属性tx的值。
      void setTy​(double value)
      设置属性ty的值。
      void setTz​(double value)
      设置属性tz的值。
      String toString​()
      返回此 Affine对象的字符串表示形式。
      Point2D transform​(double x, double y)
      通过此转换来转换指定的点。
      Point3D transform​(double x, double y, double z)
      通过此转换来转换指定的点。
      DoubleProperty txProperty​()
      定义3x4矩阵的X坐标转换元素。
      DoubleProperty tyProperty​()
      定义3x4矩阵的Y坐标转换元素。
      DoubleProperty tzProperty​()
      定义3x4矩阵的Z坐标转换元素。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.transform.Transform

        addEventFilter, addEventHandler, affine, affine, buildEventDispatchChain, column, column, deltaTransform, deltaTransform, getElement, getOnTransformChanged, identityProperty, inverseDeltaTransform, inverseDeltaTransform, inverseTransform, inverseTransform, inverseTransform, inverseTransform2DPoints, inverseTransform3DPoints, isIdentity, isType2D, onTransformChangedProperty, removeEventFilter, removeEventHandler, rotate, row, row, scale, scale, setOnTransformChanged, shear, shear, similarTo, toArray, toArray, transform, transform, transform, transform2DPoints, transform3DPoints, transformChanged, translate, type2DProperty

    • Property Detail

      • mxx

        public final DoubleProperty mxxProperty
        定义3x4矩阵的X坐标缩放元素。
        另请参见：
        getMxx() ， setMxx(double)

      • mxy

        public final DoubleProperty mxyProperty
        定义3x4矩阵的XY坐标元素。
        另请参见：
        getMxy() ， setMxy(double)

      • mxz

        public final DoubleProperty mxzProperty
        定义3x4矩阵的XZ坐标元素。
        另请参见：
        getMxz() ， setMxz(double)

      • tx

        public final DoubleProperty txProperty
        定义3x4矩阵的X坐标转换元素。
        另请参见：
        getTx() ， setTx(double)

      • myx

        public final DoubleProperty myxProperty
        定义3x4矩阵的YX坐标元素。
        另请参见：
        getMyx() ， setMyx(double)

      • myy

        public final DoubleProperty myyProperty
        定义3x4矩阵的Y坐标缩放元素。
        另请参见：
        getMyy() ， setMyy(double)

      • myz

        public final DoubleProperty myzProperty
        定义3x4矩阵的YZ坐标元素。
        另请参见：
        getMyz() ， setMyz(double)

      • ty

        public final DoubleProperty tyProperty
        定义3x4矩阵的Y坐标转换元素。
        另请参见：
        getTy() ， setTy(double)

      • mzx

        public final DoubleProperty mzxProperty
        定义3x4矩阵的ZX坐标元素。
        另请参见：
        getMzx() ， setMzx(double)

      • mzy

        public final DoubleProperty mzyProperty
        定义3x4矩阵的ZY坐标元素。
        另请参见：
        getMzy() ， setMzy(double)

      • mzz

        public final DoubleProperty mzzProperty
        定义3x4矩阵的Z坐标缩放元素。
        另请参见：
        getMzz() ， setMzz(double)

      • tz

        public final DoubleProperty tzProperty
        定义3x4矩阵的Z坐标转换元素。
        另请参见：
        getTz() ， setTz(double)

    • 构造方法详细信息

      • Affine

        public Affine​()
        创建包含身份转换的新实例 Affine 。

      • Affine

        public Affine​(Transform transform)
        创建一个 Affine的新实例，填充指定的变换值。
        参数
        transform - transform其矩阵填充到新实例的变换
        异常
        NullPointerException - 如果指定的 transform为空
        从以下版本开始：
        JavaFX 8.0

      • Affine

        public Affine​(double mxx,
              double mxy,
              double tx,
              double myx,
              double myy,
              double ty)
        用元素值指定的2D变换创建一个新的实例 Affine 。
        参数
        mxx - X坐标缩放元素
        mxy - XY坐标元素
        tx - X坐标转换元素
        myx - YX坐标元素
        myy - Y坐标缩放元素
        ty - Y坐标转换元素
        从以下版本开始：
        JavaFX 8.0

      • Affine

        public Affine​(double mxx,
              double mxy,
              double mxz,
              double tx,
              double myx,
              double myy,
              double myz,
              double ty,
              double mzx,
              double mzy,
              double mzz,
              double tz)
        使用由元素值指定的变换创建一个新实例 Affine 。
        参数
        mxx - X坐标缩放元素
        mxy - XY坐标元素
        mxz - XZ坐标元素
        tx - X坐标转换元素
        myx - YX坐标元素
        myy - Y坐标缩放元素
        myz - YZ坐标元素
        ty - Y坐标转换元素
        mzx - ZX坐标元素
        mzy - ZY坐标元素
        mzz - Z坐标缩放元素
        tz - Z坐标转换元素
        从以下版本开始：
        JavaFX 8.0

      • Affine

        public Affine​(double[] matrix,
              MatrixType type,
              int offset)
        使用由数组指定的转换矩阵创建一个新实例 Affine 。
        参数
        matrix - 包含平坦变换矩阵的数组
        type - 阵列中包含的矩阵类型
        offset - 数组中第一个元素的偏移量
        异常
        IndexOutOfBoundsException - 如果阵列对于指定的 type和 offset
        IllegalArgumentException - 如果指定的矩阵不是仿射（2D 3x3矩阵的最后一行不是 [0, 0, 1]或3D 4x4矩阵的最后一行不是 [0, 0, 0, 1] 。
        NullPointerException - 如果指定的 matrix或 type为空
        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • setMxx

        public final void setMxx​(double value)
        设置属性mxx的值。
        Property description:
        定义3x4矩阵的X坐标缩放元素。

      • getMxx

        public final double getMxx​()
        获取属性mxx的值。
        重写：
        getMxx在 Transform
        Property description:
        定义3x4矩阵的X坐标缩放元素。
        结果
        3x4矩阵的X坐标缩放元素

      • mxxProperty

        public final DoubleProperty mxxProperty​()
        定义3x4矩阵的X坐标缩放元素。
        另请参见：
        getMxx() ， setMxx(double)

      • setMxy

        public final void setMxy​(double value)
        设置属性mxy的值。
        Property description:
        定义3x4矩阵的XY坐标元素。

      • getMxy

        public final double getMxy​()
        获取属性mxy的值。
        重写：
        getMxy在 Transform
        Property description:
        定义3x4矩阵的XY坐标元素。
        结果
        3x4矩阵的XY坐标元素

      • mxyProperty

        public final DoubleProperty mxyProperty​()
        定义3x4矩阵的XY坐标元素。
        另请参见：
        getMxy() ， setMxy(double)

      • setMxz

        public final void setMxz​(double value)
        设置属性mxz的值。
        Property description:
        定义3x4矩阵的XZ坐标元素。

      • getMxz

        public final double getMxz​()
        获取属性mxz的值。
        重写：
        getMxz在 Transform
        Property description:
        定义3x4矩阵的XZ坐标元素。
        结果
        3x4矩阵的XZ坐标元素

      • mxzProperty

        public final DoubleProperty mxzProperty​()
        定义3x4矩阵的XZ坐标元素。
        另请参见：
        getMxz() ， setMxz(double)

      • setTx

        public final void setTx​(double value)
        设置属性tx的值。
        Property description:
        定义3x4矩阵的X坐标转换元素。

      • getTx

        public final double getTx​()
        获取属性tx的值。
        重写：
        getTx在 Transform
        Property description:
        定义3x4矩阵的X坐标转换元素。
        结果
        3x4矩阵的X坐标转换元素

      • txProperty

        public final DoubleProperty txProperty​()
        定义3x4矩阵的X坐标转换元素。
        另请参见：
        getTx() ， setTx(double)

      • setMyx

        public final void setMyx​(double value)
        设置属性myx的值。
        Property description:
        定义3x4矩阵的YX坐标元素。

      • getMyx

        public final double getMyx​()
        获取属性myx的值。
        重写：
        getMyx在 Transform
        Property description:
        定义3x4矩阵的YX坐标元素。
        结果
        3x4矩阵的YX坐标元素

      • myxProperty

        public final DoubleProperty myxProperty​()
        定义3x4矩阵的YX坐标元素。
        另请参见：
        getMyx() ， setMyx(double)

      • setMyy

        public final void setMyy​(double value)
        设置属性myy的值。
        Property description:
        定义3x4矩阵的Y坐标缩放元素。

      • getMyy

        public final double getMyy​()
        获取属性myy的价值。
        重写：
        getMyy在 Transform
        Property description:
        定义3x4矩阵的Y坐标缩放元素。
        结果
        3×4矩阵的Y坐标缩放元素

      • myyProperty

        public final DoubleProperty myyProperty​()
        定义3x4矩阵的Y坐标缩放元素。
        另请参见：
        getMyy() ， setMyy(double)

      • setMyz

        public final void setMyz​(double value)
        设置属性myz的值。
        Property description:
        定义3x4矩阵的YZ坐标元素。

      • getMyz

        public final double getMyz​()
        获取属性myz的值。
        重写：
        getMyz在 Transform
        Property description:
        定义3x4矩阵的YZ坐标元素。
        结果
        3x4矩阵的YZ坐标元素

      • myzProperty

        public final DoubleProperty myzProperty​()
        定义3x4矩阵的YZ坐标元素。
        另请参见：
        getMyz() ， setMyz(double)

      • setTy

        public final void setTy​(double value)
        设置属性ty的值。
        Property description:
        定义3x4矩阵的Y坐标转换元素。

      • getTy

        public final double getTy​()
        获取属性值的值。
        重写：
        getTy在 Transform
        Property description:
        定义3x4矩阵的Y坐标转换元素。
        结果
        3×4矩阵的Y坐标转换元素

      • tyProperty

        public final DoubleProperty tyProperty​()
        定义3x4矩阵的Y坐标转换元素。
        另请参见：
        getTy() ， setTy(double)

      • setMzx

        public final void setMzx​(double value)
        设置属性mzx的值。
        Property description:
        定义3x4矩阵的ZX坐标元素。

      • getMzx

        public final double getMzx​()
        获取属性mzx的值。
        重写：
        getMzx在 Transform
        Property description:
        定义3x4矩阵的ZX坐标元素。
        结果
        3x4矩阵的ZX坐标元素

      • mzxProperty

        public final DoubleProperty mzxProperty​()
        定义3x4矩阵的ZX坐标元素。
        另请参见：
        getMzx() ， setMzx(double)

      • setMzy

        public final void setMzy​(double value)
        设置属性mzy的值。
        Property description:
        定义3x4矩阵的ZY坐标元素。

      • getMzy

        public final double getMzy​()
        获取属性mzy的值。
        重写：
        getMzy在 Transform
        Property description:
        定义3x4矩阵的ZY坐标元素。
        结果
        3×4矩阵的ZY坐标元素

      • mzyProperty

        public final DoubleProperty mzyProperty​()
        定义3x4矩阵的ZY坐标元素。
        另请参见：
        getMzy() ， setMzy(double)

      • setMzz

        public final void setMzz​(double value)
        设置属性mzz的值。
        Property description:
        定义3x4矩阵的Z坐标缩放元素。

      • getMzz

        public final double getMzz​()
        获取属性mzz的值。
        重写：
        getMzz在 Transform
        Property description:
        定义3x4矩阵的Z坐标缩放元素。
        结果
        3x4矩阵的Z坐标缩放元素

      • mzzProperty

        public final DoubleProperty mzzProperty​()
        定义3x4矩阵的Z坐标缩放元素。
        另请参见：
        getMzz() ， setMzz(double)

      • setTz

        public final void setTz​(double value)
        设置属性tz的值。
        Property description:
        定义3x4矩阵的Z坐标转换元素。

      • getTz

        public final double getTz​()
        获取属性tz的值。
        重写：
        getTz在 Transform
        Property description:
        定义3x4矩阵的Z坐标转换元素。
        结果
        3×4矩阵的Z坐标转换元素

      • tzProperty

        public final DoubleProperty tzProperty​()
        定义3x4矩阵的Z坐标转换元素。
        另请参见：
        getTz() ， setTz(double)

      • setElement

        public void setElement​(MatrixType type,
                       int row,
                       int column,
                       double value)
        设置变换矩阵的指定元素。
        参数
        type - 要使用的矩阵类型
        row - 基于零的行号
        column - 从零开始的列号
        value - 指定的转换矩阵元素的新值
        异常
        IndexOutOfBoundsException - 如果索引不在指定的矩阵类型内
        IllegalArgumentException - 如果设置该值会破坏变换的亲和性（为了方便起见，该方法允许将2D 3x3矩阵的最后一行的元素设置为 [0, 0, 1] ，将3D 4x4矩阵的最后一行的元素设置为 [0, 0, 0, 1] ）。
        NullPointerException - 如果指定的 type为空
        从以下版本开始：
        JavaFX 8.0

      • determinant

        public double determinant​()
        说明从类别复制Transform
        计算转换矩阵的行列式。 除此之外，行列式可以用于测试这种变换的可逆性 - 如果行列式不等于零，则它是可逆的。
        重写：
        determinant在 Transform
        结果
        转换矩阵的决定因素

      • createConcatenation

        public Transform createConcatenation​(Transform transform)
        描述从类复制： Transform
        返回此变换和指定变换的并置。 将结果变换应用到一个节点具有相同的效果，将两个变换添加到其getTransforms()列表中， this第一次转换和指定的transform秒。
        重写：
        createConcatenation在 Transform
        参数
        transform -变换与串接该转换
        结果
        连接变换

      • createInverse

        public Affine createInverse​()
                     throws NonInvertibleTransformException
        描述从类复制： Transform
        返回此变换的逆变换。
        重写：
        createInverse在 Transform
        结果
        逆变换
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • clone

        public Affine clone​()
        描述从类复制： Transform
        返回此转换的深层副本。
        重写：
        clone在 Transform
        结果
        这个转换的副本
        另请参见：
        Cloneable

      • setToTransform

        public void setToTransform​(Transform transform)
        将此实例的值设置为指定转换提供的值。
        参数
        transform - transform矩阵填充到此实例的变换
        异常
        NullPointerException - 如果指定的 transform为空
        从以下版本开始：
        JavaFX 8.0

      • setToTransform

        public void setToTransform​(double mxx,
                           double mxy,
                           double tx,
                           double myx,
                           double myy,
                           double ty)
        将此实例的值设置为由元素值指定的2D变换。
        参数
        mxx - X坐标缩放元素
        mxy - XY坐标元素
        tx - X坐标转换元素
        myx - YX坐标元素
        myy - Y坐标缩放元素
        ty - Y坐标转换元素
        从以下版本开始：
        JavaFX 8.0

      • setToTransform

        public void setToTransform​(double mxx,
                           double mxy,
                           double mxz,
                           double tx,
                           double myx,
                           double myy,
                           double myz,
                           double ty,
                           double mzx,
                           double mzy,
                           double mzz,
                           double tz)
        将此实例的值设置为由元素值指定的变换。
        参数
        mxx - X坐标缩放元素
        mxy - XY坐标元素
        mxz - XZ坐标元素
        tx - X坐标转换元素
        myx - YX坐标元素
        myy - Y坐标缩放元素
        myz - YZ坐标元素
        ty - Y坐标转换元素
        mzx - ZX坐标元素
        mzy - ZY坐标元素
        mzz - Z坐标缩放元素
        tz - Z坐标转换元素
        从以下版本开始：
        JavaFX 8.0

      • setToTransform

        public void setToTransform​(double[] matrix,
                           MatrixType type,
                           int offset)
        将此实例的值设置为由数组指定的转换矩阵。
        参数
        matrix - 包含平坦变换矩阵的数组
        type - 阵列中包含的矩阵类型
        offset - 数组中第一个元素的偏移量
        异常
        IndexOutOfBoundsException - 如果阵列太短，指定的 type和 offset
        IllegalArgumentException - 如果指定的矩阵不是仿射的（2D 3x3矩阵的最后一行不是 [0, 0, 1]或3D 4x4矩阵的最后一行不是 [0, 0, 0, 1] 。
        NullPointerException - 如果指定的 matrix或 type为null
        从以下版本开始：
        JavaFX 8.0

      • setToIdentity

        public void setToIdentity​()
        将此转换重置为身份转换。
        从以下版本开始：
        JavaFX 8.0

      • invert

        public void invert​()
            throws NonInvertibleTransformException
        将此转换转换到位。
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转
        从以下版本开始：
        JavaFX 8.0

      • append

        public void append​(Transform transform)

        将指定的变换附加到此实例。 该操作以将其应用于节点的方式修改此变换与将其添加到其getTransforms()列表中的效果相同， this第一次转换和指定的transform秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定变换的变换矩阵。

        参数
        transform - 转换为附加到此实例
        异常
        NullPointerException - 如果指定的 transform为空
        从以下版本开始：
        JavaFX 8.0

      • append

        public void append​(double mxx,
                   double mxy,
                   double tx,
                   double myx,
                   double myy,
                   double ty)

        将元素值指定的2D变换附加到此实例。 该操作以将应用于节点的方式修改此变换与将其中的两个变换相加到其getTransforms()列表中，具有相同的效果， this第一次转换和指定的transform秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定变换的变换矩阵。

        参数
        mxx - 要附加的变换的X坐标缩放元素
        mxy - 要附加的变换的XY坐标元素
        tx - 要附加的变换的X坐标转换元素
        myx - 要附加的变换的YX坐标元素
        myy - 要附加的变换的Y坐标缩放元素
        ty - 要附加的变换的Y坐标转换元素
        从以下版本开始：
        JavaFX 8.0

      • append

        public void append​(double mxx,
                   double mxy,
                   double mxz,
                   double tx,
                   double myx,
                   double myy,
                   double myz,
                   double ty,
                   double mzx,
                   double mzy,
                   double mzz,
                   double tz)

        将由元素值指定的变换附加到此实例。 该操作以将其应用于节点的方式修改此变换与将其添加到其getTransforms()列表中的相同效果， this第一次转换和指定的transform秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定变换的变换矩阵。

        参数
        mxx - 要附加的变换的X坐标缩放元素
        mxy - 要附加的变换的XY坐标元素
        mxz - 要附加的变换的XZ坐标元素
        tx - 要附加的变换的X坐标转换元素
        myx - 要附加的变换的YX坐标元素
        myy - 要附加的变换的Y坐标缩放元素
        myz - 要附加的变换的YZ坐标元素
        ty - 要附加的变换的Y坐标转换元素
        mzx - 要附加的变换的ZX坐标元素
        mzy - 要附加的变换的ZY坐标元素
        mzz - 要附加的变换的Z坐标缩放元素
        tz - 要附加的变换的Z坐标转换元素
        从以下版本开始：
        JavaFX 8.0

      • append

        public void append​(double[] matrix,
                   MatrixType type,
                   int offset)

        将数组指定的变换追加到此实例。 该操作以将其应用于节点的方式修改此变换与将其添加到其getTransforms()列表中的效果相同， this第一次转换和指定的transform秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定变换的变换矩阵。

        参数
        matrix - 包含要附加的展平变换矩阵的数组
        type - 阵列中包含的矩阵类型
        offset - 数组中第一个矩阵元素的偏移量
        异常
        IndexOutOfBoundsException - 如果阵列太短，指定的 type和 offset
        IllegalArgumentException - 如果指定的矩阵不是仿射的（2D 3x3矩阵的最后一行不是 [0, 0, 1]或3D 4x4矩阵的最后一行不是 [0, 0, 0, 1] 。
        NullPointerException - 如果指定的 matrix或 type为空
        从以下版本开始：
        JavaFX 8.0

      • prepend

        public void prepend​(Transform transform)

        将指定的变换预置到此实例。 该操作以将其应用于节点的方式修改此变换与将其添加到其getTransforms()列表中的相同效果，指定的第transform和第this转换为第二变换。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定变换的变换矩阵。

        参数
        transform - 转换为此实例
        异常
        NullPointerException - 如果指定的 transform为空
        从以下版本开始：
        JavaFX 8.0

      • prepend

        public void prepend​(double mxx,
                    double mxy,
                    double tx,
                    double myx,
                    double myy,
                    double ty)

        将由元素值指定的2D变换预置到此实例。 该操作以将其应用于节点的方式修改此变换与将其添加到其getTransforms()列表中的相同效果，第transform和第this转换。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定变换的变换矩阵。

        参数
        mxx - 要添加的变换的X坐标缩放元素
        mxy - 要添加的变换的XY坐标元素
        tx - 要添加的变换的X坐标转换元素
        myx - 要添加的变换的YX坐标元素
        myy - 要添加的变换的Y坐标缩放元素
        ty - 要添加的变换的Y坐标转换元素
        从以下版本开始：
        JavaFX 8.0

      • prepend

        public void prepend​(double mxx,
                    double mxy,
                    double mxz,
                    double tx,
                    double myx,
                    double myy,
                    double myz,
                    double ty,
                    double mzx,
                    double mzy,
                    double mzz,
                    double tz)

        将由元素值指定的变换预置到此实例。 该操作以将其应用于节点的方式修改此变换与将其添加到其getTransforms()列表中的相同效果，指定的transform第一和第this转换。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定变换的变换矩阵。

        参数
        mxx - 要添加的变换的X坐标缩放元素
        mxy - 要添加的变换的XY坐标元素
        mxz - 要添加的变换的XZ坐标元素
        tx - 要添加的变换的X坐标转换元素
        myx - 要添加的变换的YX坐标元素
        myy - 要添加的变换的Y坐标缩放元素
        myz - 要添加的变换的YZ坐标元素
        ty - 要添加的变换的Y坐标转换元素
        mzx - 要添加的变换的ZX坐标元素
        mzy - 要添加的变换的ZY坐标元素
        mzz - 要添加的变换的Z坐标缩放元素
        tz - 要添加的变换的Z坐标转换元素
        从以下版本开始：
        JavaFX 8.0

      • prepend

        public void prepend​(double[] matrix,
                    MatrixType type,
                    int offset)

        将数组指定的变换预置到此实例。 该操作以将其应用于节点的方式修改此变换与将其添加到其getTransforms()列表中的相同效果，指定的transform第一和第this转换。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定变换的变换矩阵。

        参数
        matrix - 包含要添加的展平变换矩阵的数组
        type - 数组中包含的矩阵类型
        offset - 数组中第一个矩阵元素的偏移量
        异常
        IndexOutOfBoundsException - 如果阵列太短，指定的 type和 offset
        IllegalArgumentException - 如果指定的矩阵不是仿射（2D 3x3矩阵的最后一行不是 [0, 0, 1]或3D 4x4矩阵的最后一行不是 [0, 0, 0, 1] 。
        NullPointerException - 如果指定的 matrix或 type为空
        从以下版本开始：
        JavaFX 8.0

      • appendTranslation

        public void appendTranslation​(double tx,
                              double ty)

        将2D翻译附加到此实例。 相当于append(new Translate(tx, ty)) 。

        该操作以将其应用于节点的方式修改此变换与将其两个变换添加到其getTransforms()列表中的效果相同， this首先转换和指定的翻译秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定转换的变换矩阵。

        参数
        tx - X坐标转换
        ty - Y坐标转换
        从以下版本开始：
        JavaFX 8.0

      • appendTranslation

        public void appendTranslation​(double tx,
                              double ty,
                              double tz)

        将翻译附加到此实例。 相当于append(new Translate(tx, ty, tz)) 。

        该操作以将其应用于节点的方式修改此变换具有与向其getTransforms()列表添加两个变换相同的效果， this首先转换和指定的翻译秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定转换的变换矩阵。

        参数
        tx - X坐标转换
        ty - Y坐标转换
        tz - Z坐标转换
        从以下版本开始：
        JavaFX 8.0

      • prependTranslation

        public void prependTranslation​(double tx,
                               double ty,
                               double tz)

        准备翻译到这个实例。 相当于prepend(new Translate(tx, ty, tz)) 。

        该操作以将其应用于节点的方式修改此变换具有与向其getTransforms()列表添加两个变换相同的效果，首先转换指定的转换和this转换。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定转换的变换矩阵。

        参数
        tx - X坐标转换
        ty - Y坐标转换
        tz - Z坐标转换
        从以下版本开始：
        JavaFX 8.0

      • prependTranslation

        public void prependTranslation​(double tx,
                               double ty)

        将2D翻译准备到此实例。 相当于prepend(new Translate(tx, ty)) 。

        该操作以将其应用于节点的方式修改此变换具有与向其getTransforms()列表添加两个变换相同的效果，指定的转换首先转换为第二个转换和this转换。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定转换的变换矩阵。

        参数
        tx - X坐标转换
        ty - Y坐标转换
        从以下版本开始：
        JavaFX 8.0

      • appendScale

        public void appendScale​(double sx,
                        double sy)

        将2D刻度追加到此实例。 相当于append(new Scale(sx, sy)) 。

        该操作以将其应用于节点的方式修改此变换与将其两个变换添加到其getTransforms()列表中的效果相同，即this首先转换和指定的刻度秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        从以下版本开始：
        JavaFX 8.0

      • appendScale

        public void appendScale​(double sx,
                        double sy,
                        double pivotX,
                        double pivotY)

        将具有枢轴的2D刻度附加到此实例。 相当于append(new Scale(sx, sy, pivotX, pivotY)) 。

        该操作以将其应用于节点的方式修改此变换与将其两个变换添加到其getTransforms()列表， this首次转换和指定刻度秒的效果相同。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        pivotX - 发生刻度的点的X坐标
        pivotY - 出现刻度的点的Y坐标
        从以下版本开始：
        JavaFX 8.0

      • appendScale

        public void appendScale​(double sx,
                        double sy,
                        Point2D pivot)

        将具有枢轴的2D刻度附加到此实例。 相当于append(new Scale(sx, sy, pivot.getX(), pivot.getY()) 。

        该操作以将其应用于节点的方式修改此变换与将其两个变换添加到其getTransforms()列表， this第一次转换和指定刻度秒的效果相同。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        pivot - 发生规模的点
        异常
        NullPointerException - 如果指定的 pivot为空
        从以下版本开始：
        JavaFX 8.0

      • appendScale

        public void appendScale​(double sx,
                        double sy,
                        double sz)

        追加比例到这个实例。 相当于append(new Scale(sx, sy, sz)) 。

        该操作以将其应用于节点的方式修改此变换具有与向其getTransforms()列表中添加两个变换相同的效果， this首先转换和指定的刻度秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        sz - Z坐标比例因子
        从以下版本开始：
        JavaFX 8.0

      • appendScale

        public void appendScale​(double sx,
                        double sy,
                        double sz,
                        double pivotX,
                        double pivotY,
                        double pivotZ)

        使用pivot附加到此实例的缩放。 相当于append(new Scale(sx, sy, sz, pivotX, pivotY, pivotZ)) 。

        该操作以将其应用于节点的方式修改此变换与将其两个变换添加到其getTransforms()列表， this第一个变换和指定的刻度秒的效果相同。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        sz - Z坐标比例因子
        pivotX - 发生刻度的点的X坐标
        pivotY - 出现刻度的点的Y坐标
        pivotZ - 发生刻度的点的Z坐标
        从以下版本开始：
        JavaFX 8.0

      • appendScale

        public void appendScale​(double sx,
                        double sy,
                        double sz,
                        Point3D pivot)

        使用pivot附加到此实例的缩放。 相当于append(new Scale(sx, sy, sz, pivot.getX(), pivot.getY(), pivot.getZ())) 。

        该操作以将其应用于节点的方式修改此变换与将其转换为getTransforms()列表， this第一次转换和指定刻度秒的效果相同。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        sz - Z坐标比例因子
        pivot - 发生刻度的点
        异常
        NullPointerException - 如果指定的 pivot为空
        从以下版本开始：
        JavaFX 8.0

      • prependScale

        public void prependScale​(double sx,
                         double sy)

        将2D刻度放在这个实例上。 相当于prepend(new Scale(sx, sy)) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的规模第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        从以下版本开始：
        JavaFX 8.0

      • prependScale

        public void prependScale​(double sx,
                         double sy,
                         double pivotX,
                         double pivotY)

        使用这个实例的枢轴来预处理二维刻度。 相当于prepend(new Scale(sx, sy, pivotX, pivotY)) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的规模第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        pivotX - 发生刻度的点的X坐标
        pivotY - 出现刻度的点的Y坐标
        从以下版本开始：
        JavaFX 8.0

      • prependScale

        public void prependScale​(double sx,
                         double sy,
                         Point2D pivot)

        使用这个实例的枢轴来预处理二维刻度。 相当于prepend(new Scale(sx, sy, pivot.getX(), </p>pivot.getY())) 。

        该操作以将其应用于节点的方式修改此变换具有与向其getTransforms()列表添加两个变换相同的效果，指定的比例首先this 。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        pivot - 发生规模的点
        异常
        NullPointerException - 如果指定的 pivot为空
        从以下版本开始：
        JavaFX 8.0

      • prependScale

        public void prependScale​(double sx,
                         double sy,
                         double sz)

        为这个例子准备了比例。 相当于prepend(new Scale(sx, sy, sz)) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的规模第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        sz - Z坐标比例因子
        从以下版本开始：
        JavaFX 8.0

      • prependScale

        public void prependScale​(double sx,
                         double sy,
                         double sz,
                         double pivotX,
                         double pivotY,
                         double pivotZ)

        使用这个实例的pivot来预览缩放比例。 相当于prepend(new Scale(sx, sy, sz, pivotX, pivotY, pivotZ)) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的规模第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        sz - Z坐标比例因子
        pivotX - 发生刻度的点的X坐标
        pivotY - 发生刻度的点的Y坐标
        pivotZ - 出现刻度的点的Z坐标
        从以下版本开始：
        JavaFX 8.0

      • prependScale

        public void prependScale​(double sx,
                         double sy,
                         double sz,
                         Point3D pivot)

        使用这个实例的pivot来预览缩放比例。 相当于prepend(new Scale(sx, sy, sz, pivot.getX(), pivot.getY(), pivot.getZ())) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的规模第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定比例的变换矩阵。

        参数
        sx - X坐标比例因子
        sy - Y坐标比例因子
        sz - Z坐标比例因子
        pivot - 发生刻度的点
        异常
        NullPointerException - 如果指定的 pivot为空
        从以下版本开始：
        JavaFX 8.0

      • appendShear

        public void appendShear​(double shx,
                        double shy)

        附加剪切到这个实例。 相当于append(new Shear(sx, sy)) 。

        该操作以将其应用于节点的方式修改此变换具有与向其getTransforms()列表中添加两个变换相同的效果， this首先转换和指定剪切秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定剪切的变换矩阵。

        参数
        shx - XY坐标元素
        shy - YX坐标元素
        从以下版本开始：
        JavaFX 8.0

      • appendShear

        public void appendShear​(double shx,
                        double shy,
                        double pivotX,
                        double pivotY)

        用枢轴附加剪切到这个实例。 相当于append(new Shear(sx, sy, pivotX, pivotY)) 。

        该操作以将其应用于节点的方式修改此变换具有与向其getTransforms()列表中添加两个变换相同的效果， this首先转换和指定剪切秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定剪切的变换矩阵。

        参数
        shx - XY坐标元素
        shy - YX坐标元素
        pivotX - 剪切枢轴点的X坐标
        pivotY - 剪切枢轴点的Y坐标
        从以下版本开始：
        JavaFX 8.0

      • appendShear

        public void appendShear​(double shx,
                        double shy,
                        Point2D pivot)

        用枢轴附加剪切到这个实例。 相当于append(new Shear(sx, sy, pivot.getX(), pivot.getY())) 。

        该操作以将其应用于节点的方式修改此变换与将其转换为getTransforms()列表， this第一次转换和指定的剪切this具有相同的效果。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定剪切的变换矩阵。

        参数
        shx - XY坐标元素
        shy - YX坐标元素
        pivot - 剪切枢轴点
        异常
        NullPointerException - 如果指定的 pivot为空
        从以下版本开始：
        JavaFX 8.0

      • prependShear

        public void prependShear​(double shx,
                         double shy)

        为这个例子预先剪切。 相当于prepend(new Shear(sx, sy)) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定剪切的第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定剪切的变换矩阵。

        参数
        shx - XY坐标元素
        shy - YX坐标元素
        从以下版本开始：
        JavaFX 8.0

      • prependShear

        public void prependShear​(double shx,
                         double shy,
                         double pivotX,
                         double pivotY)

        在这种情况下用枢轴预先剪切。 相当于prepend(new Shear(sx, sy, pivotX, pivotY)) 。

        该操作以将其应用于节点的方式修改此变换具有与向其getTransforms()列表中添加两个变换相同的效果，指定的剪切和this转换为第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定剪切的变换矩阵。

        参数
        shx - XY坐标元素
        shy - YX坐标元素
        pivotX - 剪切枢轴点的X坐标
        pivotY - 剪切枢轴点的Y坐标
        从以下版本开始：
        JavaFX 8.0

      • prependShear

        public void prependShear​(double shx,
                         double shy,
                         Point2D pivot)

        在这种情况下用枢轴预先剪切。 相当于prepend(new Shear(sx, sy, pivot.getX(), pivot.getY())) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定剪切的第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定剪切的变换矩阵。

        参数
        shx - XY坐标元素
        shy - YX坐标元素
        pivot - 剪切枢轴点
        异常
        NullPointerException - 如果指定的 pivot为空
        从以下版本开始：
        JavaFX 8.0

      • appendRotation

        public void appendRotation​(double angle)

        将2D旋转追加到此实例。 相当于append(new Rotate(angle)) 。

        该操作以将其应用于节点的方式修改此变换与将其两个变换添加到其getTransforms()列表中具有相同的效果， this首先转换和指定的旋转秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        从以下版本开始：
        JavaFX 8.0

      • appendRotation

        public void appendRotation​(double angle,
                           double pivotX,
                           double pivotY)

        使用枢轴将2D旋转附加到此实例。 相当于append(new Rotate(angle, pivotX, pivotY)) 。

        该操作以将其应用于节点的方式修改此变换与将其两个变换添加到其getTransforms()列表中具有相同的效果， this首先转换和指定的旋转秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivotX - 旋转枢轴点的X坐标
        pivotY - 旋转枢轴点的Y坐标
        从以下版本开始：
        JavaFX 8.0

      • appendRotation

        public void appendRotation​(double angle,
                           Point2D pivot)

        使用枢轴将2D旋转附加到此实例。 相当于append(new Rotate(angle, pivot.getX(), pivot.getY())) 。

        该操作以将其应用于节点的方式修改此变换与将其两个变换添加到其getTransforms()列表中具有相同的效果， this首先转换和指定的旋转秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivot - 旋转枢轴点
        异常
        NullPointerException - 如果指定的 pivot为空
        从以下版本开始：
        JavaFX 8.0

      • appendRotation

        public void appendRotation​(double angle,
                           double pivotX,
                           double pivotY,
                           double pivotZ,
                           double axisX,
                           double axisY,
                           double axisZ)

        将旋转追加到此实例。 相当于append(new Rotate(angle, pivotX, pivotY, pivotZ, new Point3D(axisX, axisY, axisZ))) 。

        该操作以将其应用于节点的方式修改此变换与将其两个变换添加到其getTransforms()列表中具有相同的效果， this首先转换和指定的旋转秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivotX - 旋转枢轴点的X坐标
        pivotY - 旋转枢轴点的Y坐标
        pivotZ - 旋转枢轴点的Z坐标
        axisX - 旋转轴的X坐标值
        axisY - 旋转轴的Y坐标值
        axisZ - 旋转轴的Z坐标值
        从以下版本开始：
        JavaFX 8.0

      • appendRotation

        public void appendRotation​(double angle,
                           double pivotX,
                           double pivotY,
                           double pivotZ,
                           Point3D axis)

        将旋转追加到此实例。 相当于append(new Rotate(angle, pivotX, pivotY, pivotZ, axis)) 。

        该操作以将其应用于节点的方式修改此变换与将其转换为getTransforms()列表this和指定的第二个转换具有相同的效果。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivotX - 旋转枢轴点的X坐标
        pivotY - 旋转枢轴点的Y坐标
        pivotZ - 旋转枢轴点的Z坐标
        axis - 旋转轴
        异常
        NullPointerException - 如果指定的 axis为空
        从以下版本开始：
        JavaFX 8.0

      • appendRotation

        public void appendRotation​(double angle,
                           Point3D pivot,
                           Point3D axis)

        将旋转追加到此实例。 相当于append(new Rotate(angle, pivot.getX(), pivot.getY(), pivot.getZ(), axis)) 。

        该操作以将其应用于节点的方式修改此变换具有与向其getTransforms()列表添加两个变换相同的效果， this首先转换和指定的旋转秒。

        从矩阵的角度来看，该变换的变换矩阵在右边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivot - 旋转枢轴点
        axis - 旋转轴
        异常
        NullPointerException - 如果指定的 pivot或 axis为空
        从以下版本开始：
        JavaFX 8.0

      • prependRotation

        public void prependRotation​(double angle)

        将2D旋转预置到此实例。 相当于prepend(new Rotate(angle)) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的旋转第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        从以下版本开始：
        JavaFX 8.0

      • prependRotation

        public void prependRotation​(double angle,
                            double pivotX,
                            double pivotY)

        使用枢轴将2D旋转预加到此实例。 相当于prepend(new Rotate(angle, pivotX, pivotY)) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的旋转第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivotX - 旋转枢轴点的X坐标
        pivotY - 旋转枢轴点的Y坐标
        从以下版本开始：
        JavaFX 8.0

      • prependRotation

        public void prependRotation​(double angle,
                            Point2D pivot)

        使用枢轴将2D旋转预加到此实例。 相当于prepend(new Rotate(angle, pivot.getX(), pivot.getY())) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的旋转第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivot - 旋转枢轴点
        异常
        NullPointerException - 如果指定的 pivot为空
        从以下版本开始：
        JavaFX 8.0

      • prependRotation

        public void prependRotation​(double angle,
                            double pivotX,
                            double pivotY,
                            double pivotZ,
                            double axisX,
                            double axisY,
                            double axisZ)

        预先轮换到这个实例。 相当于prepend(new Rotate(angle, pivotX, pivotY, pivotZ, new Point3D(axisX, axisY, axisZ))) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的旋转第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivotX - 旋转枢轴点的X坐标
        pivotY - 旋转枢轴点的Y坐标
        pivotZ - 旋转枢轴点的Z坐标
        axisX - 旋转轴的X坐标值
        axisY - 旋转轴的Y坐标值
        axisZ - 旋转轴的Z坐标值
        从以下版本开始：
        JavaFX 8.0

      • prependRotation

        public void prependRotation​(double angle,
                            double pivotX,
                            double pivotY,
                            double pivotZ,
                            Point3D axis)

        预先轮换到这个实例。 相当于prepend(new Rotate(angle, pivotX, pivotY, pivotZ, axis)) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的旋转第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivotX - 旋转枢轴点的X坐标
        pivotY - 旋转枢轴点的Y坐标
        pivotZ - 旋转枢轴点的Z坐标
        axis - 旋转轴
        异常
        NullPointerException - 如果指定的 axis为空
        从以下版本开始：
        JavaFX 8.0

      • prependRotation

        public void prependRotation​(double angle,
                            Point3D pivot,
                            Point3D axis)

        预先轮换到这个实例。 相当于prepend(new Rotate(angle, pivot.getX(), pivot.getY(), pivot.getZ(), axis)) 。

        的操作修改的方式，将其施加到一个节点具有如添加两个变换到其相同的效果此变换getTransforms()列表中，指定的旋转第一和this变换第二。

        从矩阵的角度来看，该变换的变换矩阵在左边乘以指定旋转的变换矩阵。

        参数
        angle - 以度为单位的旋转角度
        pivot - 旋转枢轴点
        axis - 旋转轴
        异常
        NullPointerException - 如果指定的 pivot或 axis为null
        从以下版本开始：
        JavaFX 8.0

      • transform

        public Point2D transform​(double x,
                         double y)
        描述从类复制： Transform
        通过此转换来转换指定的点。 该方法只能用于2D变换。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        转化点

      • transform

        public Point3D transform​(double x,
                         double y,
                         double z)
        描述从类复制： Transform
        通过此转换来转换指定的点。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        转化点

      • deltaTransform

        public Point2D deltaTransform​(double x,
                              double y)
        描述从类别复制Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        deltaTransform在 Transform
        参数
        x - 矢量在X轴方向的幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的变换的相对幅度向量

      • deltaTransform

        public Point3D deltaTransform​(double x,
                              double y,
                              double z)
        描述从类复制： Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        deltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的变换的相对幅度向量

      • inverseTransform

        public Point2D inverseTransform​(double x,
                                double y)
                         throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换指定点。 该方法只能用于2D变换。
        重写：
        inverseTransform在类 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        逆转点
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • inverseTransform

        public Point3D inverseTransform​(double x,
                                double y,
                                double z)
                         throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换指定点。
        重写：
        inverseTransform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        逆转点
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • inverseDeltaTransform

        public Point2D inverseDeltaTransform​(double x,
                                     double y)
                              throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的逆变换相对幅度向量
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • inverseDeltaTransform

        public Point3D inverseDeltaTransform​(double x,
                                     double y,
                                     double z)
                              throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的逆变换相对幅度向量
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • toString

        public String toString​()
        返回此 Affine对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of this Affine object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.scene.transform (Java SE 9 & JDK 9 )

javafx.scene.transform

Classes

  • Affine
  • Rotate
  • Scale
  • Shear
  • Transform
  • TransformChangedEvent
  • Translate

Enums

  • MatrixType

Exceptions

  • NonInvertibleTransformException


javafx.scene.transform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.scene.transform

提供一组方便的类来对Affine对象执行旋转，缩放，剪切和转换转换。

  • 类摘要
    Class 描述
    Affine
    Affine类代表一般的仿射变换。
    Rotate
    该类表示一个 Affine对象，它绕坐标点旋转坐标。
    Scale
    此类表示一个 Affine对象，可根据指定的因素缩放坐标。
    Shear
    该类代表一个 Affine对象，它通过指定的乘数来剪切坐标。
    Transform
    这个类是不同仿射变换的基类。
    TransformChangedEvent
    当它的任何属性发生变化时，这个事件被触发。
    Translate
    该类表示一个 Affine对象，它根据指定的因素转换坐标。
  • 枚举摘要
    Enum 描述
    MatrixType
    指定转换矩阵的类型。
  • 异常摘要
    异常 描述
    NonInvertibleTransformException
    NonInvertibleTransformException类表示如果执行的操作需要处于非可逆状态的 Transform对象的倒数时抛出异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.transform Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.transform

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javafx.event.Event (implements java.lang.Cloneable)
        • javafx.scene.transform.TransformChangedEvent
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • javafx.scene.transform.NonInvertibleTransformException
    • javafx.scene.transform.Transform (implements java.lang.Cloneable, javafx.event.EventTarget)
      • javafx.scene.transform.Affine
      • javafx.scene.transform.Rotate
      • javafx.scene.transform.Scale
      • javafx.scene.transform.Shear
      • javafx.scene.transform.Translate

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.transform.MatrixType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


MatrixType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.transform

Enum MatrixType

  • java.lang.Object
    • java.lang.Enum<MatrixType>
      • javafx.scene.transform.MatrixType
  • All Implemented Interfaces:
    Serializable ， Comparable<MatrixType>

    public enum MatrixType
extends Enum<MatrixType>
    指定转换矩阵的类型。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      MT_2D_2x3
      包含以下值的2行和3列的2D仿射变换矩阵：
      MT_2D_3x3
      3行3列的2D变换矩阵。
      MT_3D_3x4
      包含以下值的3行和4列的3D仿射变换矩阵：
      MT_3D_4x4
      4行4列的3D变换矩阵。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int columns​()
      返回此类型矩阵中的列数。
      int elements​()
      返回此类型的矩阵中的元素数。
      boolean is2D​()
      指定这是否是2D变换矩阵
      int rows​()
      返回此类型的矩阵中的行数。
      static MatrixType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MatrixType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MT_2D_2x3

        public static final MatrixType MT_2D_2x3
        包含以下值的2行和3列的2D仿射变换矩阵：
          mxx, mxy, tx,
 myx, myy, ty

      • MT_2D_3x3

        public static final MatrixType MT_2D_3x3
        3行3列的2D变换矩阵。 对于仿射变换，最后一行是常数，因此矩阵包含以下值：
          mxx, mxy, tx,
 myx, myy, ty,
   0,   0,  1

      • MT_3D_3x4

        public static final MatrixType MT_3D_3x4
        包含以下值的3行和4列的3D仿射变换矩阵：
          mxx, mxy, mxz, tx,
 myx, myy, myz, ty,
 mzx, mzy, mzz, tz

      • MT_3D_4x4

        public static final MatrixType MT_3D_4x4
        4行4列的3D变换矩阵。 对于仿射变换，最后一行是常数，因此矩阵包含以下值：
          mxx, mxy, mxz, tx,
 myx, myy, myz, ty,
 mzx, mzy, mzz, tz,
   0,   0,   0,  1

    • 方法详细信息

      • values

        public static MatrixType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (MatrixType c : MatrixType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static MatrixType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • elements

        public int elements​()
        返回此类型的矩阵中的元素数。
        结果
        这种类型的矩阵中的元素的数量

      • rows

        public int rows​()
        返回此类型的矩阵中的行数。
        结果
        这种类型的矩阵中的行数

      • columns

        public int columns​()
        返回此类型矩阵中的列数。
        结果
        这种类型矩阵中的列数

      • is2D

        public boolean is2D​()
        指定这是否是2D变换矩阵
        结果
        如果这是一个2D变换矩阵，则为真，如果这是一个3D变换矩阵，则为false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


NonInvertibleTransformException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.transform

Class NonInvertibleTransformException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javafx.scene.transform.NonInvertibleTransformException
  • All Implemented Interfaces:
    Serializable

    public class NonInvertibleTransformException
extends 异常
    NonInvertibleTransformException类表示如果执行的操作需要处于非可逆状态的 Transform对象的倒数时抛出异常。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NonInvertibleTransformException​(String message)
      使用指定的详细消息创建一个新实例 NonInvertibleTransformException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NonInvertibleTransformException

        public NonInvertibleTransformException​(String message)
        创建一个具有指定详细消息的新实例 NonInvertibleTransformException 。
        参数
        message - the detail message
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Rotate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.transform

Class Rotate

  • java.lang.Object
    • javafx.scene.transform.Transform
      • javafx.scene.transform.Rotate
  • All Implemented Interfaces:
    Cloneable ， EventTarget

    public class Rotate
extends Transform
    此类代表一个Affine对象，它绕坐标点旋转坐标。 该操作等效于平移坐标，使锚点位于原点（S1），然后绕新原点（S2）旋转它们，最后平移，使得中间原点恢复到原始锚点的坐标（S3）。

    例如，表示Z轴周围的新旋转（theta，x，y，z）的返回变换的矩阵为：

      [   cos(theta)    -sin(theta)   0    x-x*cos+y*sin  ]
              [   sin(theta)     cos(theta)   0    y-x*sin-y*cos  ]
              [      0               0        1          z        ]

    例如，要在（50,30）的锚点处绕Z轴旋转文本30度：

       Text text = new Text("This is a test"); text.setX(10); text.setY(50); text.setFont(new Font(20)); text.getTransforms().add(new Rotate(30, 50, 30));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty angle
      定义以度为单位的旋转角度。
      ObjectProperty<Point3D> axis
      定义枢轴点的旋转轴。
      DoubleProperty pivotX
      定义旋转枢轴点的X坐标。
      DoubleProperty pivotY
      定义旋转枢轴点的Y坐标。
      DoubleProperty pivotZ
      定义旋转枢轴点的Z坐标。

      • Properties inherited from class javafx.scene.transform.Transform

        identity, onTransformChanged, type2D

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Point3D X_AXIS
      指定X轴作为旋转轴。
      static Point3D Y_AXIS
      指定Y轴作为旋转轴。
      static Point3D Z_AXIS
      指定Z轴作为旋转轴。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Rotate​()
      创建默认的旋转变换（标识）。
      Rotate​(double angle)
      创建二维旋转变换。
      Rotate​(double angle, double pivotX, double pivotY)
      用枢轴创建二维旋转变换。
      Rotate​(double angle, double pivotX, double pivotY, double pivotZ)
      创建一个简单的旋转变换与三维枢轴。
      Rotate​(double angle, double pivotX, double pivotY, double pivotZ, Point3D axis)
      用枢轴创建三维旋转变换。
      Rotate​(double angle, Point3D axis)
      创建一个三维旋转变换。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DoubleProperty angleProperty​()
      定义以度为单位的旋转角度。
      ObjectProperty<Point3D> axisProperty​()
      定义枢轴点的旋转轴。
      Rotate clone​()
      返回此转换的深层副本。
      Transform createConcatenation​(Transform transform)
      返回此变换和指定变换的并置。
      Transform createInverse​()
      返回此变换的逆变换。
      Point2D deltaTransform​(double x, double y)
      通过该变换来变换相对幅度矢量。
      Point3D deltaTransform​(double x, double y, double z)
      通过该变换来变换相对幅度矢量。
      double getAngle​()
      获取属性角度的值。
      Point3D getAxis​()
      获取属性轴的值。
      double getMxx​()
      获取3x4矩阵的X坐标缩放元素。
      double getMxy​()
      获取3x4矩阵的XY坐标元素。
      double getMxz​()
      获取3x4矩阵的XZ坐标元素。
      double getMyx​()
      获取3x4矩阵的YX坐标元素。
      double getMyy​()
      获取3x4矩阵的Y坐标缩放元素。
      double getMyz​()
      获取3x4矩阵的YZ坐标元素。
      double getMzx​()
      获取3x4矩阵的ZX坐标元素。
      double getMzy​()
      获取3x4矩阵的ZY坐标元素。
      double getMzz​()
      获取3x4矩阵的Z坐标缩放元素。
      double getPivotX​()
      获取属性pivotX的值。
      double getPivotY​()
      获取属性pivotY的值。
      double getPivotZ​()
      获取属性pivotZ的值。
      double getTx​()
      获取3x4矩阵的X坐标转换元素。
      double getTy​()
      获取3x4矩阵的Y坐标转换元素。
      double getTz​()
      获取3x4矩阵的Z坐标转换元素。
      Point2D inverseDeltaTransform​(double x, double y)
      通过该变换的逆变换相对幅度矢量。
      Point3D inverseDeltaTransform​(double x, double y, double z)
      通过该变换的逆变换相对幅度矢量。
      Point2D inverseTransform​(double x, double y)
      通过该变换的逆变换指定点。
      Point3D inverseTransform​(double x, double y, double z)
      通过该变换的逆变换指定点。
      DoubleProperty pivotXProperty​()
      定义旋转枢轴点的X坐标。
      DoubleProperty pivotYProperty​()
      定义旋转枢轴点的Y坐标。
      DoubleProperty pivotZProperty​()
      定义旋转枢轴点的Z坐标。
      void setAngle​(double value)
      设置属性角度的值。
      void setAxis​(Point3D value)
      设置属性轴的值。
      void setPivotX​(double value)
      设置属性pivotX的值。
      void setPivotY​(double value)
      设置属性pivotY的值。
      void setPivotZ​(double value)
      设置属性pivotZ的值。
      String toString​()
      返回此 Rotate对象的字符串表示形式。
      Point2D transform​(double x, double y)
      通过此转换来转换指定的点。
      Point3D transform​(double x, double y, double z)
      通过此转换来转换指定的点。
      protected void transformChanged​()
      每当任何一个参数发生变化时，所有转换都必须调用此方法。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.transform.Transform

        addEventFilter, addEventHandler, affine, affine, buildEventDispatchChain, column, column, deltaTransform, deltaTransform, determinant, getElement, getOnTransformChanged, identityProperty, inverseDeltaTransform, inverseDeltaTransform, inverseTransform, inverseTransform, inverseTransform, inverseTransform2DPoints, inverseTransform3DPoints, isIdentity, isType2D, onTransformChangedProperty, removeEventFilter, removeEventHandler, rotate, row, row, scale, scale, setOnTransformChanged, shear, shear, similarTo, toArray, toArray, transform, transform, transform, transform2DPoints, transform3DPoints, translate, type2DProperty

    • Property Detail

      • angle

        public final DoubleProperty angleProperty
        定义以度为单位的旋转角度。
        另请参见：
        getAngle() ， setAngle(double)

      • pivotX

        public final DoubleProperty pivotXProperty
        定义旋转枢轴点的X坐标。
        Default value:
        0.0
        另请参见：
        getPivotX() ， setPivotX(double)

      • pivotY

        public final DoubleProperty pivotYProperty
        定义旋转枢轴点的Y坐标。
        Default value:
        0.0
        另请参见：
        getPivotY() ， setPivotY(double)

      • pivotZ

        public final DoubleProperty pivotZProperty
        定义旋转枢轴点的Z坐标。
        Default value:
        0.0
        另请参见：
        getPivotZ() ， setPivotZ(double)

      • axis

        public final ObjectProperty<Point3D> axisProperty
        定义枢轴点的旋转轴。
        另请参见：
        getAxis() ， setAxis(Point3D)

    • 字段详细信息

      • X_AXIS

        public static final Point3D X_AXIS
        指定X轴作为旋转轴。

      • Y_AXIS

        public static final Point3D Y_AXIS
        指定Y轴作为旋转轴。

      • Z_AXIS

        public static final Point3D Z_AXIS
        指定Z轴作为旋转轴。

    • 构造方法详细信息

      • Rotate

        public Rotate​()
        创建默认的旋转变换（标识）。

      • Rotate

        public Rotate​(double angle)
        创建二维旋转变换。 枢轴点设置为（0,0）
        参数
        angle - 以度为单位的旋转角度

      • Rotate

        public Rotate​(double angle,
              Point3D axis)
        创建一个三维旋转变换。 枢轴点设置为（0,0,0）
        参数
        angle - 以度为单位的旋转角度
        axis - 旋转轴

      • Rotate

        public Rotate​(double angle,
              double pivotX,
              double pivotY)
        用枢轴创建二维旋转变换。
        参数
        angle - 以度为单位的旋转角度
        pivotX - 旋转枢轴点的X坐标
        pivotY - 旋转枢轴点的Y坐标

      • Rotate

        public Rotate​(double angle,
              double pivotX,
              double pivotY,
              double pivotZ)
        创建一个简单的旋转变换与三维枢轴。
        参数
        angle - 以度为单位的旋转角度
        pivotX - 旋转枢轴点的X坐标
        pivotY - 旋转枢轴点的Y坐标
        pivotZ - 旋转枢轴点的Z坐标

      • Rotate

        public Rotate​(double angle,
              double pivotX,
              double pivotY,
              double pivotZ,
              Point3D axis)
        用枢轴创建三维旋转变换。
        参数
        angle - 以度为单位的旋转角度
        pivotX - 旋转枢轴点的X坐标
        pivotY - 旋转枢轴点的Y坐标
        pivotZ - 旋转枢轴点的Z坐标
        axis - 旋转轴

    • 方法详细信息

      • setAngle

        public final void setAngle​(double value)
        设置属性角度的值。
        Property description:
        定义以度为单位的旋转角度。

      • getAngle

        public final double getAngle​()
        获取属性角度的值。
        Property description:
        定义以度为单位的旋转角度。

      • angleProperty

        public final DoubleProperty angleProperty​()
        定义以度为单位的旋转角度。
        另请参见：
        getAngle() ， setAngle(double)

      • setPivotX

        public final void setPivotX​(double value)
        设置属性pivotX的值。
        Property description:
        定义旋转枢轴点的X坐标。
        Default value:
        0.0

      • getPivotX

        public final double getPivotX​()
        获取属性pivotX的值。
        Property description:
        定义旋转枢轴点的X坐标。
        Default value:
        0.0

      • pivotXProperty

        public final DoubleProperty pivotXProperty​()
        定义旋转枢轴点的X坐标。
        Default value:
        0.0
        另请参见：
        getPivotX() ， setPivotX(double)

      • setPivotY

        public final void setPivotY​(double value)
        设置属性pivotY的值。
        Property description:
        定义旋转枢轴点的Y坐标。
        Default value:
        0.0

      • getPivotY

        public final double getPivotY​()
        获取属性pivotY的值。
        Property description:
        定义旋转枢轴点的Y坐标。
        Default value:
        0.0

      • pivotYProperty

        public final DoubleProperty pivotYProperty​()
        定义旋转枢轴点的Y坐标。
        Default value:
        0.0
        另请参见：
        getPivotY() ， setPivotY(double)

      • setPivotZ

        public final void setPivotZ​(double value)
        设置属性pivotZ的值。
        Property description:
        定义旋转枢轴点的Z坐标。
        Default value:
        0.0

      • getPivotZ

        public final double getPivotZ​()
        获取属性pivotZ的值。
        Property description:
        定义旋转枢轴点的Z坐标。
        Default value:
        0.0

      • pivotZProperty

        public final DoubleProperty pivotZProperty​()
        定义旋转枢轴点的Z坐标。
        Default value:
        0.0
        另请参见：
        getPivotZ() ， setPivotZ(double)

      • setAxis

        public final void setAxis​(Point3D value)
        设置属性轴的值。
        Property description:
        定义枢轴点的旋转轴。

      • getAxis

        public final Point3D getAxis​()
        获取属性轴的值。
        Property description:
        定义枢轴点的旋转轴。

      • axisProperty

        public final ObjectProperty<Point3D> axisProperty​()
        定义枢轴点的旋转轴。
        另请参见：
        getAxis() ， setAxis(Point3D)

      • getMxx

        public double getMxx​()
        描述从类复制： Transform
        获取3x4矩阵的X坐标缩放元素。
        重写：
        getMxx在 Transform
        结果
        3x4矩阵的X坐标缩放元素

      • getMxy

        public double getMxy​()
        描述从类复制： Transform
        获取3x4矩阵的XY坐标元素。
        重写：
        getMxy在 Transform
        结果
        3x4矩阵的XY坐标元素

      • getMxz

        public double getMxz​()
        描述从类复制： Transform
        获取3x4矩阵的XZ坐标元素。
        重写：
        getMxz在 Transform
        结果
        3x4矩阵的XZ坐标元素

      • getTx

        public double getTx​()
        描述从类复制： Transform
        获取3x4矩阵的X坐标转换元素。
        重写：
        getTx在 Transform
        结果
        3x4矩阵的X坐标转换元素

      • getMyx

        public double getMyx​()
        描述从类复制： Transform
        获取3x4矩阵的YX坐标元素。
        重写：
        getMyx在 Transform
        结果
        3x4矩阵的YX坐标元素

      • getMyy

        public double getMyy​()
        描述从类复制： Transform
        获取3x4矩阵的Y坐标缩放元素。
        重写：
        getMyy在 Transform
        结果
        3×4矩阵的Y坐标缩放元素

      • getMyz

        public double getMyz​()
        描述从类复制： Transform
        获取3x4矩阵的YZ坐标元素。
        重写：
        getMyz在 Transform
        结果
        3x4矩阵的YZ坐标元素

      • getTy

        public double getTy​()
        描述从类复制： Transform
        获取3x4矩阵的Y坐标转换元素。
        重写：
        getTy在 Transform
        结果
        3×4矩阵的Y坐标转换元素

      • getMzx

        public double getMzx​()
        描述从类复制： Transform
        获取3x4矩阵的ZX坐标元素。
        重写：
        getMzx在 Transform
        结果
        3x4矩阵的ZX坐标元素

      • getMzy

        public double getMzy​()
        描述从类复制： Transform
        获取3x4矩阵的ZY坐标元素。
        重写：
        getMzy在 Transform
        结果
        3×4矩阵的ZY坐标元素

      • getMzz

        public double getMzz​()
        描述从类别复制： Transform
        获取3x4矩阵的Z坐标缩放元素。
        重写：
        getMzz在 Transform
        结果
        3x4矩阵的Z坐标缩放元素

      • getTz

        public double getTz​()
        描述从类复制： Transform
        获取3x4矩阵的Z坐标转换元素。
        重写：
        getTz在 Transform
        结果
        3×4矩阵的Z坐标转换元素

      • createConcatenation

        public Transform createConcatenation​(Transform transform)
        描述从类复制： Transform
        返回此变换和指定变换的并置。 将结果变换应用于节点具有将二变换添加到其getTransforms()列表， this第一次转换和指定的transform秒的效果。
        重写：
        createConcatenation在 Transform
        参数
        transform - 转换为与此变换连接
        结果
        连接变换

      • createInverse

        public Transform createInverse​()
                        throws NonInvertibleTransformException
        描述从类复制： Transform
        返回此变换的逆变换。
        重写：
        createInverse在 Transform
        结果
        逆变换
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • clone

        public Rotate clone​()
        描述从类复制： Transform
        返回此转换的深层副本。
        重写：
        clone在 Transform
        结果
        这个转换的副本
        另请参见：
        Cloneable

      • transform

        public Point2D transform​(double x,
                         double y)
        描述从类复制： Transform
        通过此转换来转换指定的点。 该方法只能用于2D变换。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        转化点

      • transform

        public Point3D transform​(double x,
                         double y,
                         double z)
        描述从类复制： Transform
        通过此转换来转换指定的点。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        转化点

      • deltaTransform

        public Point2D deltaTransform​(double x,
                              double y)
        描述从类复制： Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        deltaTransform在 Transform
        参数
        x - X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的变换后的相对幅度向量

      • deltaTransform

        public Point3D deltaTransform​(double x,
                              double y,
                              double z)
        描述从类别复制： Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        deltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的变换后的相对幅度向量

      • inverseTransform

        public Point2D inverseTransform​(double x,
                                double y)
        描述从类复制： Transform
        通过该变换的逆变换指定点。 该方法只能用于2D变换。
        重写：
        inverseTransform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        逆转点

      • inverseTransform

        public Point3D inverseTransform​(double x,
                                double y,
                                double z)
        描述从类复制： Transform
        通过该变换的逆变换指定点。
        重写：
        inverseTransform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        逆转点

      • inverseDeltaTransform

        public Point2D inverseDeltaTransform​(double x,
                                     double y)
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的逆变换相对幅度向量

      • inverseDeltaTransform

        public Point3D inverseDeltaTransform​(double x,
                                     double y,
                                     double z)
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的逆变换相对幅度向量

      • toString

        public String toString​()
        返回此 Rotate对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 Rotate对象的字符串表示形式。

      • transformChanged

        protected void transformChanged​()
        描述从类复制： Transform
        每当任何一个参数发生变化时，所有转换都必须调用此方法。 当变换的任何属性无效时，通常会调用它（如果设置了无效属性，则跳过该调用就可以了）。
        重写：
        transformChanged在 Transform
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Scale (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.transform

Class Scale

  • java.lang.Object
    • javafx.scene.transform.Transform
      • javafx.scene.transform.Scale
  • All Implemented Interfaces:
    Cloneable ， EventTarget

    public class Scale
extends Transform
    此类表示一个Affine对象，可根据指定的因素缩放坐标。 表示缩放变换的矩阵如下：
      [ x   0   0   (1-x)*pivotX ]
              [ 0   y   0   (1-y)*pivotY ]
              [ 0   0   z   (1-z)*pivotZ ]
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty pivotX
      定义刻度出现点的X坐标。
      DoubleProperty pivotY
      定义关于刻度出现点的Y坐标。
      DoubleProperty pivotZ
      定义刻度出现点的Z坐标。
      DoubleProperty x
      定义坐标沿X轴方向缩放的因子。
      DoubleProperty y
      定义坐标沿Y轴方向缩放的因子。
      DoubleProperty z
      定义坐标沿Z轴方向缩放的因子。

      • Properties inherited from class javafx.scene.transform.Transform

        identity, onTransformChanged, type2D

    • 构造方法摘要

      构造方法
      Constructor 描述
      Scale​()
      创建一个默认的Scale（标识）。
      Scale​(double x, double y)
      创建二维刻度。
      Scale​(double x, double y, double z)
      创建一个三维刻度。
      Scale​(double x, double y, double pivotX, double pivotY)
      用枢轴创建二维刻度。
      Scale​(double x, double y, double z, double pivotX, double pivotY, double pivotZ)
      用枢轴创建三维刻度。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Scale clone​()
      返回此转换的深层副本。
      Transform createConcatenation​(Transform transform)
      返回此变换和指定变换的并置。
      Scale createInverse​()
      返回此变换的逆变换。
      Point2D deltaTransform​(double x, double y)
      通过该变换来变换相对幅度矢量。
      Point3D deltaTransform​(double x, double y, double z)
      通过该变换来变换相对幅度矢量。
      double getMxx​()
      获取3x4矩阵的X坐标缩放元素。
      double getMyy​()
      获取3x4矩阵的Y坐标缩放元素。
      double getMzz​()
      获取3x4矩阵的Z坐标缩放元素。
      double getPivotX​()
      获取属性pivotX的值。
      double getPivotY​()
      获取属性pivotY的值。
      double getPivotZ​()
      获取属性pivotZ的值。
      double getTx​()
      获取3x4矩阵的X坐标转换元素。
      double getTy​()
      获取3x4矩阵的Y坐标转换元素。
      double getTz​()
      获取3x4矩阵的Z坐标转换元素。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      double getZ​()
      获取属性z的值。
      Point2D inverseDeltaTransform​(double x, double y)
      通过该变换的逆变换相对幅度矢量。
      Point3D inverseDeltaTransform​(double x, double y, double z)
      通过该变换的逆变换相对幅度矢量。
      Point2D inverseTransform​(double x, double y)
      通过该变换的逆变换指定点。
      Point3D inverseTransform​(double x, double y, double z)
      通过该变换的逆变换指定点。
      DoubleProperty pivotXProperty​()
      定义刻度出现点的X坐标。
      DoubleProperty pivotYProperty​()
      定义关于刻度出现点的Y坐标。
      DoubleProperty pivotZProperty​()
      定义刻度出现点的Z坐标。
      void setPivotX​(double value)
      设置属性pivotX的值。
      void setPivotY​(double value)
      设置属性pivotY的值。
      void setPivotZ​(double value)
      设置属性pivotZ的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      void setZ​(double value)
      设置属性z的值。
      String toString​()
      返回此 Scale对象的字符串表示形式。
      Point2D transform​(double x, double y)
      通过此转换来转换指定的点。
      Point3D transform​(double x, double y, double z)
      通过此转换来转换指定的点。
      DoubleProperty xProperty​()
      定义坐标沿X轴方向缩放的因子。
      DoubleProperty yProperty​()
      定义坐标沿Y轴方向缩放的因子。
      DoubleProperty zProperty​()
      定义坐标沿Z轴方向缩放的因子。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.transform.Transform

        addEventFilter, addEventHandler, affine, affine, buildEventDispatchChain, column, column, deltaTransform, deltaTransform, determinant, getElement, getMxy, getMxz, getMyx, getMyz, getMzx, getMzy, getOnTransformChanged, identityProperty, inverseDeltaTransform, inverseDeltaTransform, inverseTransform, inverseTransform, inverseTransform, inverseTransform2DPoints, inverseTransform3DPoints, isIdentity, isType2D, onTransformChangedProperty, removeEventFilter, removeEventHandler, rotate, row, row, scale, scale, setOnTransformChanged, shear, shear, similarTo, toArray, toArray, transform, transform, transform, transform2DPoints, transform3DPoints, transformChanged, translate, type2DProperty

    • Property Detail

      • x

        public final DoubleProperty xProperty
        定义坐标沿X轴方向缩放的因子。 默认值为1.0 。
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义坐标沿Y轴方向缩放的因子。 默认值为1.0 。
        另请参见：
        getY() ， setY(double)

      • z

        public final DoubleProperty zProperty
        定义坐标沿Z轴方向缩放的因子。 默认值为1.0 。
        另请参见：
        getZ() ， setZ(double)

      • pivotX

        public final DoubleProperty pivotXProperty
        定义刻度出现点的X坐标。
        Default value:
        0.0
        另请参见：
        getPivotX() ， setPivotX(double)

      • pivotY

        public final DoubleProperty pivotYProperty
        定义关于刻度出现点的Y坐标。
        Default value:
        0.0
        另请参见：
        getPivotY() ， setPivotY(double)

      • pivotZ

        public final DoubleProperty pivotZProperty
        定义刻度出现点的Z坐标。
        Default value:
        0.0
        另请参见：
        getPivotZ() ， setPivotZ(double)

    • 构造方法详细信息

      • Scale

        public Scale​()
        创建一个默认的Scale（标识）。

      • Scale

        public Scale​(double x,
             double y)
        创建二维刻度。 枢轴点设置为（0,0）
        参数
        x - 坐标沿X轴缩放的因子
        y - 坐标沿Y轴缩放的因子

      • Scale

        public Scale​(double x,
             double y,
             double pivotX,
             double pivotY)
        用枢轴创建二维刻度。
        参数
        x - 坐标沿X轴缩放的因子
        y - 坐标沿Y轴缩放的因子
        pivotX - 刻度出现点的X坐标
        pivotY - 关于刻度 pivotY的Y坐标

      • Scale

        public Scale​(double x,
             double y,
             double z)
        创建一个三维刻度。 枢轴点设置为（0,0,0）
        参数
        x - 坐标沿X轴缩放的因子
        y - 坐标沿Y轴缩放的因子
        z - 坐标沿Z轴缩放的因子

      • Scale

        public Scale​(double x,
             double y,
             double z,
             double pivotX,
             double pivotY,
             double pivotZ)
        用枢轴创建三维刻度。
        参数
        x - 坐标沿X轴缩放的因子
        y - 坐标沿着Y轴缩放的因子
        z - 坐标沿Z轴缩放的因子
        pivotX - 刻度出现点的X坐标
        pivotY - 关于刻度 pivotY的Y坐标
        pivotZ - 刻度出现点的Z坐标

    • 方法详细信息

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义坐标沿X轴方向缩放的因子。 默认值为1.0 。

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义坐标沿X轴方向缩放的因子。 默认值为1.0 。

      • xProperty

        public final DoubleProperty xProperty​()
        定义坐标沿X轴方向缩放的因子。 默认值为1.0 。
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义坐标沿Y轴方向缩放的因子。 默认值为1.0 。

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义坐标沿Y轴方向缩放的因子。 默认值为1.0 。

      • yProperty

        public final DoubleProperty yProperty​()
        定义坐标沿Y轴方向缩放的因子。 默认值为1.0 。
        另请参见：
        getY() ， setY(double)

      • setZ

        public final void setZ​(double value)
        设置属性z的值。
        Property description:
        定义坐标沿Z轴方向缩放的因子。 默认值为1.0 。

      • getZ

        public final double getZ​()
        获取属性z的值。
        Property description:
        定义坐标沿Z轴方向缩放的因子。 默认值为1.0 。

      • zProperty

        public final DoubleProperty zProperty​()
        定义坐标沿Z轴方向缩放的因子。 默认值为1.0 。
        另请参见：
        getZ() ， setZ(double)

      • setPivotX

        public final void setPivotX​(double value)
        设置属性pivotX的值。
        Property description:
        定义刻度出现点的X坐标。
        Default value:
        0.0

      • getPivotX

        public final double getPivotX​()
        获取属性pivotX的值。
        Property description:
        定义刻度出现点的X坐标。
        Default value:
        0.0

      • pivotXProperty

        public final DoubleProperty pivotXProperty​()
        定义刻度出现点的X坐标。
        Default value:
        0.0
        另请参见：
        getPivotX() ， setPivotX(double)

      • setPivotY

        public final void setPivotY​(double value)
        设置属性pivotY的值。
        Property description:
        定义关于刻度出现点的Y坐标。
        Default value:
        0.0

      • getPivotY

        public final double getPivotY​()
        获取属性pivotY的值。
        Property description:
        定义关于刻度出现点的Y坐标。
        Default value:
        0.0

      • pivotYProperty

        public final DoubleProperty pivotYProperty​()
        定义关于刻度出现点的Y坐标。
        Default value:
        0.0
        另请参见：
        getPivotY() ， setPivotY(double)

      • setPivotZ

        public final void setPivotZ​(double value)
        设置属性pivotZ的值。
        Property description:
        定义刻度出现点的Z坐标。
        Default value:
        0.0

      • getPivotZ

        public final double getPivotZ​()
        获取属性pivotZ的值。
        Property description:
        定义刻度出现点的Z坐标。
        Default value:
        0.0

      • pivotZProperty

        public final DoubleProperty pivotZProperty​()
        定义刻度出现点的Z坐标。
        Default value:
        0.0
        另请参见：
        getPivotZ() ， setPivotZ(double)

      • getMxx

        public double getMxx​()
        描述从类复制： Transform
        获取3x4矩阵的X坐标缩放元素。
        重写：
        getMxx在 Transform
        结果
        3x4矩阵的X坐标缩放元素

      • getMyy

        public double getMyy​()
        描述从类复制： Transform
        获取3x4矩阵的Y坐标缩放元素。
        重写：
        getMyy在 Transform
        结果
        3×4矩阵的Y坐标缩放元素

      • getMzz

        public double getMzz​()
        描述从类复制： Transform
        获取3x4矩阵的Z坐标缩放元素。
        重写：
        getMzz在 Transform
        结果
        3x4矩阵的Z坐标缩放元素

      • getTx

        public double getTx​()
        描述从类复制： Transform
        获取3x4矩阵的X坐标转换元素。
        重写：
        getTx在 Transform
        结果
        3x4矩阵的X坐标转换元素

      • getTy

        public double getTy​()
        描述从类复制： Transform
        获取3x4矩阵的Y坐标转换元素。
        重写：
        getTy在 Transform
        结果
        3×4矩阵的Y坐标转换元素

      • getTz

        public double getTz​()
        描述从类复制： Transform
        获取3x4矩阵的Z坐标转换元素。
        重写：
        getTz在 Transform
        结果
        3×4矩阵的Z坐标转换元素

      • createConcatenation

        public Transform createConcatenation​(Transform transform)
        描述从类复制： Transform
        返回此变换和指定变换的并置。 将结果变换应用到一个节点具有相同的效果，将两个变换添加到其getTransforms()列表中， this第一次转换和指定的transform秒。
        重写：
        createConcatenation在 Transform
        参数
        transform - 转换为与此变换连接
        结果
        连接变换

      • createInverse

        public Scale createInverse​()
                    throws NonInvertibleTransformException
        描述从类复制： Transform
        返回此变换的逆变换。
        重写：
        createInverse在 Transform
        结果
        逆变换
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • clone

        public Scale clone​()
        描述从类别复制： Transform
        返回此转换的深层副本。
        重写：
        clone在 Transform
        结果
        这个转换的副本
        另请参见：
        Cloneable

      • transform

        public Point2D transform​(double x,
                         double y)
        描述从类复制： Transform
        通过此转换来转换指定的点。 该方法只能用于2D变换。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        转化点

      • transform

        public Point3D transform​(double x,
                         double y,
                         double z)
        说明从类别复制： Transform
        通过此转换来转换指定的点。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        转化点

      • deltaTransform

        public Point2D deltaTransform​(double x,
                              double y)
        描述从类复制： Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        deltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的变换后的相对幅度向量

      • deltaTransform

        public Point3D deltaTransform​(double x,
                              double y,
                              double z)
        描述从类复制： Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        deltaTransform在 Transform
        参数
        x - 矢量在X轴方向的幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的变换后的相对幅度向量

      • inverseTransform

        public Point2D inverseTransform​(double x,
                                double y)
                         throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换指定点。 该方法只能用于2D变换。
        重写：
        inverseTransform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        逆转点
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • inverseTransform

        public Point3D inverseTransform​(double x,
                                double y,
                                double z)
                         throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换指定点。
        重写：
        inverseTransform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        逆转点
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • inverseDeltaTransform

        public Point2D inverseDeltaTransform​(double x,
                                     double y)
                              throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的逆变换相对幅度向量
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • inverseDeltaTransform

        public Point3D inverseDeltaTransform​(double x,
                                     double y,
                                     double z)
                              throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的逆变换相对幅度向量
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • toString

        public String toString​()
        返回此 Scale对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 Scale对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Shear (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.transform

Class Shear

  • java.lang.Object
    • javafx.scene.transform.Transform
      • javafx.scene.transform.Shear
  • All Implemented Interfaces:
    Cloneable ， EventTarget

    public class Shear
extends Transform
    该类代表一个Affine对象，它通过指定的乘数来剪切坐标。 代表剪切变换的矩阵如下：
      [   1   x   0   -x*pivotY ]
      [   y   1   0   -y*pivotX ]
      [   0   0   1   0   ]

    例如：

       Text text = new Text("Using Shear for pseudo-italic font"); text.setX(20); text.setY(50); text.setFont(new Font(20)); text.getTransforms().add(new Shear(-0.35, 0));
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty pivotX
      定义剪切枢轴点的X坐标。
      DoubleProperty pivotY
      定义剪切枢轴点的Y坐标。
      DoubleProperty x
      定义坐标沿正X轴方向移动的乘数，作为其Y坐标系数。
      DoubleProperty y
      定义坐标在正Y轴的方向上作为其X坐标系数的乘数。

      • Properties inherited from class javafx.scene.transform.Transform

        identity, onTransformChanged, type2D

    • 构造方法摘要

      构造方法
      Constructor 描述
      Shear​()
      创建默认剪切（身份）。
      Shear​(double x, double y)
      创建一个新的剪切实例。
      Shear​(double x, double y, double pivotX, double pivotY)
      用枢轴创建一个新的剪切实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Shear clone​()
      返回此转换的深层副本。
      Transform createConcatenation​(Transform transform)
      返回此变换和指定变换的并置。
      Transform createInverse​()
      返回此变换的逆变换。
      Point2D deltaTransform​(double x, double y)
      通过该变换来变换相对幅度矢量。
      Point3D deltaTransform​(double x, double y, double z)
      通过该变换来变换相对幅度矢量。
      double getMxy​()
      获取3x4矩阵的XY坐标元素。
      double getMyx​()
      获取3x4矩阵的YX坐标元素。
      double getPivotX​()
      获取属性pivotX的值。
      double getPivotY​()
      获取属性pivotY的值。
      double getTx​()
      获取3x4矩阵的X坐标转换元素。
      double getTy​()
      获取3x4矩阵的Y坐标转换元素。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      Point2D inverseDeltaTransform​(double x, double y)
      通过该变换的逆变换相对幅度矢量。
      Point3D inverseDeltaTransform​(double x, double y, double z)
      通过该变换的逆变换相对幅度矢量。
      Point2D inverseTransform​(double x, double y)
      通过该变换的逆变换指定点。
      Point3D inverseTransform​(double x, double y, double z)
      通过该变换的逆变换指定点。
      DoubleProperty pivotXProperty​()
      定义剪切枢轴点的X坐标。
      DoubleProperty pivotYProperty​()
      定义剪切枢轴点的Y坐标。
      void setPivotX​(double value)
      设置属性pivotX的值。
      void setPivotY​(double value)
      设置属性pivotY的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      String toString​()
      返回此 Shear对象的字符串表示形式。
      Point2D transform​(double x, double y)
      通过此转换来转换指定的点。
      Point3D transform​(double x, double y, double z)
      通过此转换来转换指定的点。
      DoubleProperty xProperty​()
      定义坐标沿正X轴方向移动的乘数，作为其Y坐标系数。
      DoubleProperty yProperty​()
      定义坐标在正Y轴的方向上作为其X坐标系数的乘数。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.transform.Transform

        addEventFilter, addEventHandler, affine, affine, buildEventDispatchChain, column, column, deltaTransform, deltaTransform, determinant, getElement, getMxx, getMxz, getMyy, getMyz, getMzx, getMzy, getMzz, getOnTransformChanged, getTz, identityProperty, inverseDeltaTransform, inverseDeltaTransform, inverseTransform, inverseTransform, inverseTransform, inverseTransform2DPoints, inverseTransform3DPoints, isIdentity, isType2D, onTransformChangedProperty, removeEventFilter, removeEventHandler, rotate, row, row, scale, scale, setOnTransformChanged, shear, shear, similarTo, toArray, toArray, transform, transform, transform, transform2DPoints, transform3DPoints, transformChanged, translate, type2DProperty

    • Property Detail

      • x

        public final DoubleProperty xProperty
        定义坐标沿正X轴方向移动的乘数，作为其Y坐标系数。 典型值在-1到1之间，独占。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义坐标在正Y轴的方向上作为其X坐标系数的乘数。 典型值在-1到1之间，独占。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • pivotX

        public final DoubleProperty pivotXProperty
        定义剪切枢轴点的X坐标。
        Default value:
        0.0
        另请参见：
        getPivotX() ， setPivotX(double)

      • pivotY

        public final DoubleProperty pivotYProperty
        定义剪切枢轴点的Y坐标。
        Default value:
        0.0
        另请参见：
        getPivotY() ， setPivotY(double)

    • 构造方法详细信息

      • Shear

        public Shear​()
        创建默认剪切（身份）。

      • Shear

        public Shear​(double x,
             double y)
        创建一个新的剪切实例。 枢轴点设置为（0,0）
        参数
        x - 坐标在正X轴方向上偏移的乘数作为其Y坐标系数
        y - 坐标在正Y轴方向上移动的乘数作为其X坐标系数

      • Shear

        public Shear​(double x,
             double y,
             double pivotX,
             double pivotY)
        用枢轴创建一个新的剪切实例。
        参数
        x - 坐标在正X轴方向上偏移的乘数作为其Y坐标系数
        y - 坐标在正Y轴的方向上作为其X坐标系数的乘数
        pivotX - 剪切枢轴点的X坐标
        pivotY - 剪切枢轴点的Y坐标

    • 方法详细信息

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义坐标沿正X轴方向移动的乘数，作为其Y坐标系数。 典型值在-1到1之间，独占。
        Default value:
        0.0

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义坐标沿正X轴方向移动的乘数，作为其Y坐标系数。 典型值在-1到1之间，独占。
        Default value:
        0.0

      • xProperty

        public final DoubleProperty xProperty​()
        定义坐标沿正X轴方向移动的乘数，作为其Y坐标系数。 典型值在-1到1之间，独占。
        Default value:
        0.0
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义坐标在正Y轴的方向上作为其X坐标系数的乘数。 典型值在-1到1之间，独占。
        Default value:
        0.0

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义坐标在正Y轴的方向上作为其X坐标系数的乘数。 典型值在-1到1之间，独占。
        Default value:
        0.0

      • yProperty

        public final DoubleProperty yProperty​()
        定义坐标在正Y轴的方向上作为其X坐标系数的乘数。 典型值在-1到1之间，独占。
        Default value:
        0.0
        另请参见：
        getY() ， setY(double)

      • setPivotX

        public final void setPivotX​(double value)
        设置属性pivotX的值。
        Property description:
        定义剪切枢轴点的X坐标。
        Default value:
        0.0

      • getPivotX

        public final double getPivotX​()
        获取属性pivotX的值。
        Property description:
        定义剪切枢轴点的X坐标。
        Default value:
        0.0

      • pivotXProperty

        public final DoubleProperty pivotXProperty​()
        定义剪切枢轴点的X坐标。
        Default value:
        0.0
        另请参见：
        getPivotX() ， setPivotX(double)

      • setPivotY

        public final void setPivotY​(double value)
        设置属性pivotY的值。
        Property description:
        定义剪切枢轴点的Y坐标。
        Default value:
        0.0

      • getPivotY

        public final double getPivotY​()
        获取属性pivotY的值。
        Property description:
        定义剪切枢轴点的Y坐标。
        Default value:
        0.0

      • pivotYProperty

        public final DoubleProperty pivotYProperty​()
        定义剪切枢轴点的Y坐标。
        Default value:
        0.0
        另请参见：
        getPivotY() ， setPivotY(double)

      • getMxy

        public double getMxy​()
        描述从类复制： Transform
        获取3x4矩阵的XY坐标元素。
        重写：
        getMxy在 Transform
        结果
        3x4矩阵的XY坐标元素

      • getMyx

        public double getMyx​()
        描述从类别复制： Transform
        获取3x4矩阵的YX坐标元素。
        重写：
        getMyx在 Transform
        结果
        3x4矩阵的YX坐标元素

      • getTx

        public double getTx​()
        描述从类复制： Transform
        获取3x4矩阵的X坐标转换元素。
        重写：
        getTx在 Transform
        结果
        3x4矩阵的X坐标转换元素

      • getTy

        public double getTy​()
        描述从类复制： Transform
        获取3x4矩阵的Y坐标转换元素。
        重写：
        getTy在 Transform
        结果
        3×4矩阵的Y坐标转换元素

      • createConcatenation

        public Transform createConcatenation​(Transform transform)
        描述从类复制： Transform
        返回此变换和指定变换的并置。 应用所得的变换到节点具有作为添加两个变换到其相同的效果getTransforms()列表， this变换第一和指定transform秒。
        重写：
        createConcatenation在 Transform
        参数
        transform - 转换为与此变换连接
        结果
        连接变换

      • createInverse

        public Transform createInverse​()
        说明从类别复制： Transform
        返回此变换的逆变换。
        重写：
        createInverse在 Transform
        结果
        逆变换

      • clone

        public Shear clone​()
        描述从类复制： Transform
        返回此转换的深层副本。
        重写：
        clone在 Transform
        结果
        这个转换的副本
        另请参见：
        Cloneable

      • transform

        public Point2D transform​(double x,
                         double y)
        描述从类复制： Transform
        通过此转换来转换指定的点。 该方法只能用于2D变换。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        转化点

      • transform

        public Point3D transform​(double x,
                         double y,
                         double z)
        描述从类复制： Transform
        通过此转换来转换指定的点。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        转化点

      • deltaTransform

        public Point2D deltaTransform​(double x,
                              double y)
        描述从类复制： Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        deltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的变换的相对幅度向量

      • deltaTransform

        public Point3D deltaTransform​(double x,
                              double y,
                              double z)
        描述从类复制： Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        deltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的变换后的相对幅度向量

      • inverseTransform

        public Point2D inverseTransform​(double x,
                                double y)
                         throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换指定点。 该方法只能用于2D变换。
        重写：
        inverseTransform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        逆转点
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • inverseTransform

        public Point3D inverseTransform​(double x,
                                double y,
                                double z)
                         throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换指定点。
        重写：
        inverseTransform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        逆转点
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • inverseDeltaTransform

        public Point2D inverseDeltaTransform​(double x,
                                     double y)
                              throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的逆变换相对幅度向量
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • inverseDeltaTransform

        public Point3D inverseDeltaTransform​(double x,
                                     double y,
                                     double z)
                              throws NonInvertibleTransformException
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的逆变换相对幅度向量
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转

      • toString

        public String toString​()
        返回此 Shear对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 Shear对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Transform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.transform

Class Transform

  • java.lang.Object
    • javafx.scene.transform.Transform
  • All Implemented Interfaces:
    Cloneable ， EventTarget
    已知直接子类：
    Affine ， Rotate ， Scale ， Shear ， Translate

    public abstract class Transform
extends Object
implements Cloneable, EventTarget
    这个类是不同仿射变换的基类。 它提供了简单转换的工厂方法 - 旋转，缩放，剪切和翻译。 它允许获得任何变换的变换矩阵元素。

    例：

       Rectangle rect = new Rectangle(50,50, Color.RED); rect.getTransforms().add(new Rotate(45,0,0)); //rotate by 45 degrees
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty identity
      确定这是否是当前的身份转换。
      ObjectProperty<EventHandler<? super TransformChangedEvent>> onTransformChanged
      只要变换改变其任何参数，就调用onTransformChanged事件处理程序。
      ReadOnlyBooleanProperty type2D
      确定这是否是2D变换。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Transform​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      <T extends Event>
      void             		addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      为此转换注册事件过滤器。
      <T extends Event>
      void             		addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      注册一个事件处理程序到这个变换。
      static Affine affine​(double mxx, double myx, double mxy, double myy, double tx, double ty)
      从12个数值返回新的 Affine对象，表示3x4仿射变换矩阵的6个可指定条目。
      static Affine affine​(double mxx, double mxy, double mxz, double tx, double myx, double myy, double myz, double ty, double mzx, double mzy, double mzz, double tz)
      从12个数字值返回新的 Affine对象，表示3x4仿射变换矩阵的12个可指定条目。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此目标构建事件调度链。
      Transform clone​()
      返回此转换的深层副本。
      double[] column​(MatrixType type, int column)
      返回一个包含转换矩阵列的数组。
      double[] column​(MatrixType type, int column, double[] array)
      返回一个包含转换矩阵列的数组。
      Transform createConcatenation​(Transform transform)
      返回此变换和指定变换的并置。
      Transform createInverse​()
      返回此变换的逆变换。
      Point2D deltaTransform​(double x, double y)
      通过该变换来变换相对幅度矢量。
      Point3D deltaTransform​(double x, double y, double z)
      通过该变换来变换相对幅度矢量。
      Point2D deltaTransform​(Point2D point)
      通过此变换转换由指定的 Point2D实例表示的相对幅度向量。
      Point3D deltaTransform​(Point3D point)
      通过此变换转换由指定的 Point3D实例表示的相对幅度向量。
      double determinant​()
      计算转换矩阵的行列式。
      double getElement​(MatrixType type, int row, int column)
      获取转换矩阵的指定元素。
      double getMxx​()
      获取3x4矩阵的X坐标缩放元素。
      double getMxy​()
      获取3x4矩阵的XY坐标元素。
      double getMxz​()
      获取3x4矩阵的XZ坐标元素。
      double getMyx​()
      获取3x4矩阵的YX坐标元素。
      double getMyy​()
      获取3x4矩阵的Y坐标缩放元素。
      double getMyz​()
      获取3x4矩阵的YZ坐标元素。
      double getMzx​()
      获取3x4矩阵的ZX坐标元素。
      double getMzy​()
      获取3x4矩阵的ZY坐标元素。
      double getMzz​()
      获取3x4矩阵的Z坐标缩放元素。
      EventHandler<? super TransformChangedEvent> getOnTransformChanged​()
      获取onTransformChanged事件处理程序。
      double getTx​()
      获取3x4矩阵的X坐标转换元素。
      double getTy​()
      获取3x4矩阵的Y坐标转换元素。
      double getTz​()
      获取3x4矩阵的Z坐标转换元素。
      ReadOnlyBooleanProperty identityProperty​()
      确定这是否是当前的身份转换。
      Point2D inverseDeltaTransform​(double x, double y)
      通过该变换的逆变换相对幅度矢量。
      Point3D inverseDeltaTransform​(double x, double y, double z)
      通过该变换的逆变换相对幅度矢量。
      Point2D inverseDeltaTransform​(Point2D point)
      通过该变换的逆变换由指定的 Point2D实例表示的相对幅度向量。
      Point3D inverseDeltaTransform​(Point3D point)
      将由指定的 Point3D实例表示的相对幅度矢量转换为该变换的倒数。
      Point2D inverseTransform​(double x, double y)
      通过该变换的逆变换指定点。
      Point3D inverseTransform​(double x, double y, double z)
      通过该变换的逆变换指定点。
      Bounds inverseTransform​(Bounds bounds)
      通过该变换的倒数转换指定的边界。
      Point2D inverseTransform​(Point2D point)
      通过该变换的逆变换指定点。
      Point3D inverseTransform​(Point3D point)
      通过该变换的逆变换指定点。
      void inverseTransform2DPoints​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过这个变换的逆变换一个坐标数组。
      void inverseTransform3DPoints​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过该变换的倒数转换浮点坐标数组。
      boolean isIdentity​()
      获取属性标识的值。
      boolean isType2D​()
      获取属性type2D的值。
      ObjectProperty<EventHandler<? super TransformChangedEvent>> onTransformChangedProperty​()
      只要变换改变其任何参数，就调用onTransformChanged事件处理程序。
      <T extends Event>
      void             		removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此转换中注销先前注册的事件过滤器。
      <T extends Event>
      void             		removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此转换中注销先前注册的事件处理程序。
      static Rotate rotate​(double angle, double pivotX, double pivotY)
      返回一个 Rotate对象，旋转枢轴点周围的坐标。
      double[] row​(MatrixType type, int row)
      返回一个包含转换矩阵行的数组。
      double[] row​(MatrixType type, int row, double[] array)
      返回一个包含转换矩阵行的数组。
      static Scale scale​(double x, double y)
      返回表示缩放变换的 Scale对象。
      static Scale scale​(double x, double y, double pivotX, double pivotY)
      返回表示缩放变换的 Scale对象。
      void setOnTransformChanged​(EventHandler<? super TransformChangedEvent> value)
      设置onTransformChanged事件处理程序，当变换改变其任何参数时，调用它。
      static Shear shear​(double x, double y)
      返回表示剪切变换的 Shear对象。
      static Shear shear​(double x, double y, double pivotX, double pivotY)
      返回表示剪切变换的 Shear对象。
      boolean similarTo​(Transform transform, Bounds range, double maxDelta)
      检查这个变换是否类似于指定的变换。
      double[] toArray​(MatrixType type)
      返回一个包含展平变换矩阵的数组。
      double[] toArray​(MatrixType type, double[] array)
      返回一个包含展平变换矩阵的数组。
      Point2D transform​(double x, double y)
      通过此转换来转换指定的点。
      Point3D transform​(double x, double y, double z)
      通过此转换来转换指定的点。
      Bounds transform​(Bounds bounds)
      通过此转换转换指定的边界。
      Point2D transform​(Point2D point)
      通过此转换来转换指定的点。
      Point3D transform​(Point3D point)
      通过此转换来转换指定的点。
      void transform2DPoints​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过此转换来转换坐标数组。
      void transform3DPoints​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过此变换来转换浮点坐标数组。
      protected void transformChanged​()
      每当任何一个参数发生变化时，所有转换都必须调用此方法。
      static Translate translate​(double x, double y)
      返回表示转换变换的对象 Translate 。
      ReadOnlyBooleanProperty type2DProperty​()
      确定这是否是2D变换。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • type2D

        public final ReadOnlyBooleanProperty type2DProperty
        确定这是否是2D变换。 如果沿Z轴没有影响，则变换为2D。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isType2D()

      • identity

        public final ReadOnlyBooleanProperty identityProperty
        确定这是否是当前的身份转换。 身份转换对转换的节点没有影响。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isIdentity()

      • onTransformChanged

        public final ObjectProperty<EventHandler<? super TransformChangedEvent>> onTransformChangedProperty
        只要变换改变其任何参数，就调用onTransformChanged事件处理程序。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnTransformChanged() ， setOnTransformChanged(EventHandler)

    • 构造方法详细信息

      • Transform

        public Transform​()

    • 方法详细信息

      • affine

        public static Affine affine​(double mxx,
                            double myx,
                            double mxy,
                            double myy,
                            double tx,
                            double ty)
        从12个数值返回一个新的 Affine对象，表示3x4仿射变换矩阵的6个可指定条目。
        参数
        mxx - 3x4矩阵的X坐标缩放元素
        myx - 3x4矩阵的Y坐标剪切元素
        mxy - 3x4矩阵的X坐标剪切元素
        myy - 3x4矩阵的Y坐标缩放元素
        tx - 3x4矩阵的X坐标转换元素
        ty - 3x4矩阵的Y坐标转换元素
        结果
        一个新的 Affine对象派生自指定的参数

      • affine

        public static Affine affine​(double mxx,
                            double mxy,
                            double mxz,
                            double tx,
                            double myx,
                            double myy,
                            double myz,
                            double ty,
                            double mzx,
                            double mzy,
                            double mzz,
                            double tz)
        从12个数字值返回新的 Affine对象，表示3x4仿射变换矩阵的12个可指定条目。
        参数
        mxx - 3x4矩阵的X坐标缩放元素
        mxy - 3x4矩阵的XY元素
        mxz - 3x4矩阵的XZ元素
        tx - 3x4矩阵的X坐标转换元素
        myx - 3x4矩阵的YX元素
        myy - 3x4矩阵的Y坐标缩放元素
        myz - 3x4矩阵的YZ元素
        ty - 3x4矩阵的Y坐标转换元素
        mzx - 3x4矩阵的ZX元素
        mzy - 3x4矩阵的ZY元素
        mzz - 3x4矩阵的Z坐标缩放元素
        tz - 3x4矩阵的Z坐标转换元素
        结果
        一个新的 Affine对象派生自指定的参数

      • translate

        public static Translate translate​(double x,
                                  double y)
        返回表示转换变换的Translate对象。

        这相当于：

          new Translate(x, y);
        参数
        x - translate x值
        y - translate y值
        结果
        X- 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X-

      • rotate

        public static Rotate rotate​(double angle,
                            double pivotX,
                            double pivotY)
        返回一个Rotate对象，旋转枢轴点周围的坐标。

        这相当于：

          new Rotate(angle, pivotX, pivotY);
        参数
        angle - 旋转角度
        pivotX - 枢轴x值
        pivotY - 枢轴y值
        结果
        旋转对象，旋转枢轴点附近的坐标

      • scale

        public static Scale scale​(double x,
                          double y)
        返回表示缩放变换的Scale对象。

        这相当于：

          new Scale(x, y);
        参数
        x - 比例x值
        y - 比例y值
        结果
        Scale对象表示缩放变换

      • scale

        public static Scale scale​(double x,
                          double y,
                          double pivotX,
                          double pivotY)
        返回表示缩放变换的Scale对象。 返回的比例操作将是关于给定的枢轴点。

        这相当于：

          new Scale(x, y, pivotX, pivotY);
        参数
        x - 刻度x值
        y - 比例y值
        pivotX - 枢轴x值
        pivotY - 枢轴y值
        结果
        Scale对象表示缩放变换

      • shear

        public static Shear shear​(double x,
                          double y)
        返回表示剪切变换的Shear对象。

        这相当于：

          new Shear(x, y);
        参数
        x - 剪切x值
        y - 剪切y值
        结果
        剪切物体代表剪切变换

      • shear

        public static Shear shear​(double x,
                          double y,
                          double pivotX,
                          double pivotY)
        返回表示剪切变换的Shear对象。

        这相当于：

          new Shear(x, y, pivotX, pivotY);
        参数
        x - 剪切x值
        y - 剪切y值
        pivotX - 枢轴x值
        pivotY - 枢轴y值
        结果
        剪切物体代表剪切变换

      • getMxx

        public double getMxx​()
        获取3x4矩阵的X坐标缩放元素。
        结果
        3x4矩阵的X坐标缩放元素
        从以下版本开始：
        JavaFX 2.2

      • getMxy

        public double getMxy​()
        获取3x4矩阵的XY坐标元素。
        结果
        3x4矩阵的XY坐标元素
        从以下版本开始：
        JavaFX 2.2

      • getMxz

        public double getMxz​()
        获取3x4矩阵的XZ坐标元素。
        结果
        3x4矩阵的XZ坐标元素
        从以下版本开始：
        JavaFX 2.2

      • getTx

        public double getTx​()
        获取3x4矩阵的X坐标转换元素。
        结果
        3x4矩阵的X坐标转换元素
        从以下版本开始：
        JavaFX 2.2

      • getMyx

        public double getMyx​()
        获取3x4矩阵的YX坐标元素。
        结果
        3x4矩阵的YX坐标元素
        从以下版本开始：
        JavaFX 2.2

      • getMyy

        public double getMyy​()
        获取3x4矩阵的Y坐标缩放元素。
        结果
        3×4矩阵的Y坐标缩放元素
        从以下版本开始：
        JavaFX 2.2

      • getMyz

        public double getMyz​()
        获取3x4矩阵的YZ坐标元素。
        结果
        3x4矩阵的YZ坐标元素
        从以下版本开始：
        JavaFX 2.2

      • getTy

        public double getTy​()
        获取3x4矩阵的Y坐标转换元素。
        结果
        3×4矩阵的Y坐标转换元素
        从以下版本开始：
        JavaFX 2.2

      • getMzx

        public double getMzx​()
        获取3x4矩阵的ZX坐标元素。
        结果
        3x4矩阵的ZX坐标元素
        从以下版本开始：
        JavaFX 2.2

      • getMzy

        public double getMzy​()
        获取3x4矩阵的ZY坐标元素。
        结果
        3×4矩阵的ZY坐标元素
        从以下版本开始：
        JavaFX 2.2

      • getMzz

        public double getMzz​()
        获取3x4矩阵的Z坐标缩放元素。
        结果
        3x4矩阵的Z坐标缩放元素
        从以下版本开始：
        JavaFX 2.2

      • getTz

        public double getTz​()
        获取3x4矩阵的Z坐标转换元素。
        结果
        3×4矩阵的Z坐标转换元素
        从以下版本开始：
        JavaFX 2.2

      • getElement

        public double getElement​(MatrixType type,
                         int row,
                         int column)
        获取转换矩阵的指定元素。
        参数
        type - 获取值的矩阵类型
        row - 从零开始的行号
        column - 基于零的列号
        结果
        指定的变换矩阵元素的值
        异常
        IllegalArgumentException - 如果为3D变换请求2D矩阵类型
        IndexOutOfBoundsException - 如果索引不在指定的矩阵类型内
        NullPointerException - 如果指定的 type为空
        从以下版本开始：
        JavaFX 8.0

      • determinant

        public double determinant​()
        计算转换矩阵的行列式。 除此之外，行列式可以用于测试这种变换的可逆性 - 如果行列式不等于零，则它是可逆的。
        结果
        转换矩阵的决定因素
        从以下版本开始：
        JavaFX 8.0

      • isType2D

        public final boolean isType2D​()
        获取属性type2D的值。
        Property description:
        确定这是否是2D变换。 如果沿Z轴没有影响，则变换为2D。
        从以下版本开始：
        JavaFX 8.0

      • type2DProperty

        public final ReadOnlyBooleanProperty type2DProperty​()
        确定这是否是2D变换。 如果沿Z轴没有影响，则变换为2D。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isType2D()

      • isIdentity

        public final boolean isIdentity​()
        获取属性标识的值。
        Property description:
        确定这是否是当前的身份转换。 身份转换对转换的节点没有影响。
        从以下版本开始：
        JavaFX 8.0

      • identityProperty

        public final ReadOnlyBooleanProperty identityProperty​()
        确定这是否是当前的身份转换。 身份转换对转换的节点没有影响。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isIdentity()

      • similarTo

        public boolean similarTo​(Transform transform,
                         Bounds range,
                         double maxDelta)
        检查这个变换是否类似于指定的变换。 如果range任何一个点被转换为不超过maxDelta点，则这两个变换被认为是类似的。
        参数
        transform - 转换为与此变换进行比较
        range - 比较两个变换的兴趣区域
        maxDelta - 通过两个变换从 range转换任何单个点的结果的最大允许距离
        结果
        如果转换根据指定的标准相似，则为true
        异常
        NullPointerException - 如果指定的 transform或 range为空
        从以下版本开始：
        JavaFX 8.0

      • toArray

        public double[] toArray​(MatrixType type,
                        double[] array)
        返回一个包含展平变换矩阵的数组。 如果请求的矩阵类型适合指定的数组，则返回其中。 否则，将创建一个新数组。
        参数
        type - 要在数组中填充的矩阵类型
        array - 要存储矩阵的元素的数组，如果它是非空且足够大的; 否则，为此创建一个新数组。
        结果
        包含表示该变换的请求的矩阵类型的元素的数组
        异常
        IllegalArgumentException - 如果为3D变换请求2D矩阵类型
        NullPointerException - 如果指定的 type为空
        从以下版本开始：
        JavaFX 8.0

      • toArray

        public double[] toArray​(MatrixType type)
        返回一个包含展平变换矩阵的数组。
        参数
        type - 要在数组中填充的矩阵类型
        结果
        包含表示该变换的请求的矩阵类型的元素的数组
        异常
        IllegalArgumentException - 如果为3D变换请求2D矩阵类型
        NullPointerException - 如果指定的 type为空
        从以下版本开始：
        JavaFX 8.0

      • row

        public double[] row​(MatrixType type,
                    int row,
                    double[] array)
        返回一个包含转换矩阵行的数组。 如果请求的矩阵类型的行适合指定的数组，则返回其中。 否则，将创建一个新数组。
        参数
        type - 要在数组中填充其行的矩阵类型
        row - 该行的从零开始的索引
        array - 要存储行的元素的数组，如果它不是非空且足够大; 否则，为此创建一个新数组。
        结果
        包含表示该变换的所请求的矩阵类型的请求行的数组
        异常
        IllegalArgumentException - 如果为3D变换请求2D矩阵类型
        IndexOutOfBoundsException - 如果 row索引不在指定矩阵类型的行数内
        NullPointerException - 如果指定的 type为空
        从以下版本开始：
        JavaFX 8.0

      • row

        public double[] row​(MatrixType type,
                    int row)
        返回一个包含转换矩阵行的数组。
        参数
        type - 要在数组中填充其行的矩阵类型
        row - 行的零 row引
        结果
        包含表示该变换的所请求的矩阵类型的请求行的数组
        异常
        IllegalArgumentException - 如果为3D变换请求2D矩阵类型
        IndexOutOfBoundsException - 如果 row索引不在指定矩阵类型的行数内
        NullPointerException - 如果指定的 type为空
        从以下版本开始：
        JavaFX 8.0

      • column

        public double[] column​(MatrixType type,
                       int column,
                       double[] array)
        返回一个包含转换矩阵列的数组。 如果所请求的矩阵类型的列适合指定的数组，则返回其中。 否则，将创建一个新数组。
        参数
        type - 其列要在数组中填充的矩阵类型
        column - 从零开始的列索引
        array - 要存储列的元素的数组，如果它是非空且足够大的; 否则，为此创建一个新数组。
        结果
        包含表示该变换的请求的矩阵类型的请求列的数组
        异常
        IllegalArgumentException - 如果为3D变换请求2D矩阵类型
        IndexOutOfBoundsException - 如果 column索引不在指定矩阵类型的列数之内
        NullPointerException - 如果指定的 type为空
        从以下版本开始：
        JavaFX 8.0

      • column

        public double[] column​(MatrixType type,
                       int column)
        返回一个包含转换矩阵列的数组。
        参数
        type - 其列要在数组中填充的矩阵类型
        column - 从零开始的列索引
        结果
        包含表示该变换的请求的矩阵类型的请求列的数组
        异常
        IllegalArgumentException - 如果为3D变换请求2D矩阵类型
        IndexOutOfBoundsException - 如果 column索引不在指定矩阵类型的列数之内
        NullPointerException - 如果指定的 type为空
        从以下版本开始：
        JavaFX 8.0

      • createConcatenation

        public Transform createConcatenation​(Transform transform)
        返回此变换和指定变换的并置。 将结果变换应用于一个节点具有相同的效果，将两个变换添加到其getTransforms()列表中， this第一次转换和指定的transform秒。
        参数
        transform - 转换为与此变换连接
        结果
        连接变换
        异常
        NullPointerException - 如果指定的 transform为空
        从以下版本开始：
        JavaFX 8.0

      • createInverse

        public Transform createInverse​()
                        throws NonInvertibleTransformException
        返回此变换的逆变换。
        结果
        逆变换
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转
        从以下版本开始：
        JavaFX 8.0

      • clone

        public Transform clone​()
        返回此转换的深层副本。
        重写：
        clone在 Object
        结果
        这个转换的副本
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        Cloneable

      • transform

        public Point2D transform​(double x,
                         double y)
        通过此转换来转换指定的点。 该方法只能用于2D变换。
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        转化点
        异常
        IllegalStateException - 如果这是一个3D变换
        从以下版本开始：
        JavaFX 8.0

      • transform

        public Point2D transform​(Point2D point)
        通过此转换来转换指定的点。 该方法只能用于2D变换。
        参数
        point - 要转化的点
        结果
        转化点
        异常
        IllegalStateException - 如果这是一个3D变换
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • transform

        public Point3D transform​(double x,
                         double y,
                         double z)
        通过此转换来转换指定的点。
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        转化点
        从以下版本开始：
        JavaFX 8.0

      • transform

        public Point3D transform​(Point3D point)
        通过此转换来转换指定的点。
        参数
        point - 要转化的点
        结果
        转化点
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • transform

        public Bounds transform​(Bounds bounds)
        通过此转换转换指定的边界。
        参数
        bounds - 要转化的范围
        结果
        转化的界限
        从以下版本开始：
        JavaFX 8.0

      • transform2DPoints

        public void transform2DPoints​(double[] srcPts,
                              int srcOff,
                              double[] dstPts,
                              int dstOff,
                              int numPts)
        通过此转换来转换坐标数组。 两个坐标阵列部分可以完全相同，也可以是相同阵列的重叠部分，而不影响结果的有效性。 该方法确保在前一个操作可以被转换之前，不会覆盖源坐标。 坐标以[x0, y0, x1, y1, ..., xn, yn]的顺序从指定的偏移开始存储在阵列中。 该方法只能用于2D变换。
        参数
        srcPts - 包含源点坐标的数组。 每个点被存储为一对x，y坐标。
        srcOff - 要在源数组中转换的第一个点的偏移量
        dstPts - 返回转换点坐标的阵列。 每个点被存储为一对x，y坐标。
        dstOff - 存储在目标数组中的第一个转换点的位置的偏移量
        numPts - 要转换的积分数
        异常
        IllegalStateException - 如果这是一个3D变换
        NullPointerException - 如果是 srcPts或（@code dstPts}为空
        从以下版本开始：
        JavaFX 8.0

      • transform3DPoints

        public void transform3DPoints​(double[] srcPts,
                              int srcOff,
                              double[] dstPts,
                              int dstOff,
                              int numPts)
        通过此变换来转换浮点坐标数组。 三个坐标阵列部分可以完全相同或可以是相同阵列的重叠部分，而不会影响结果的有效性。 该方法确保在前一个操作可以被转换之前，不会覆盖源坐标。 坐标以[x0, y0, z0, x1, y1, z1, ..., xn, yn, zn]的顺序从指定的偏移开始存储在阵列中。
        参数
        srcPts - 包含源点坐标的数组。 每个点被存储为x，y，z坐标的一个tiplet。
        srcOff - 要在源数组中转换的第一个点的偏移量
        dstPts - 返回转换点坐标的阵列。 每个点被存储为x，y，z坐标的三元组。
        dstOff - 存储在目标数组中的第一个转换点的位置的偏移量
        numPts - 要转换的积分数
        异常
        NullPointerException - 如果是 srcPts或（@code dstPts}为空
        从以下版本开始：
        JavaFX 8.0

      • deltaTransform

        public Point2D deltaTransform​(double x,
                              double y)
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的经变换的相对幅度向量
        异常
        IllegalStateException - 如果这是一个3D变换
        从以下版本开始：
        JavaFX 8.0

      • deltaTransform

        public Point2D deltaTransform​(Point2D point)
        通过此变换转换由指定的Point2D实例表示的相对幅度向量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        参数
        point - 相对幅度矢量
        结果
        由 Point2D实例表示的变换后的相对幅度向量
        异常
        IllegalStateException - 如果这是一个3D变换
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • deltaTransform

        public Point3D deltaTransform​(double x,
                              double y,
                              double z)
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        参数
        x - 矢量在X轴方向的幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的变换的相对幅度向量
        从以下版本开始：
        JavaFX 8.0

      • deltaTransform

        public Point3D deltaTransform​(Point3D point)
        通过此变换转换由指定的Point3D实例表示的相对幅度向量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        参数
        point - 相对幅度矢量
        结果
        由 Point3D实例表示的变换的相对幅度向量
        异常
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • inverseTransform

        public Point2D inverseTransform​(double x,
                                double y)
                         throws NonInvertibleTransformException
        通过该变换的逆变换指定点。 该方法只能用于2D变换。
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        逆转点
        异常
        IllegalStateException - 如果这是一个3D变换
        NonInvertibleTransformException - 如果这个变换不能被反转
        从以下版本开始：
        JavaFX 8.0

      • inverseTransform

        public Point2D inverseTransform​(Point2D point)
                         throws NonInvertibleTransformException
        通过该变换的逆变换指定点。 该方法只能用于2D变换。
        参数
        point - 要转化的点
        结果
        逆转点
        异常
        IllegalStateException - 如果这是一个3D变换
        NonInvertibleTransformException - 如果这个变换不能被反转
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • inverseTransform

        public Point3D inverseTransform​(double x,
                                double y,
                                double z)
                         throws NonInvertibleTransformException
        通过该变换的逆变换指定点。
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        逆转点
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转
        从以下版本开始：
        JavaFX 8.0

      • inverseTransform

        public Point3D inverseTransform​(Point3D point)
                         throws NonInvertibleTransformException
        通过该变换的逆变换指定点。
        参数
        point - 要转化的点
        结果
        逆转点
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • inverseTransform

        public Bounds inverseTransform​(Bounds bounds)
                        throws NonInvertibleTransformException
        通过该变换的倒数转换指定的边界。
        参数
        bounds - 要转化的范围
        结果
        反向变化的界限
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转
        NullPointerException - 如果指定的 bounds为空
        从以下版本开始：
        JavaFX 8.0

      • inverseTransform2DPoints

        public void inverseTransform2DPoints​(double[] srcPts,
                                     int srcOff,
                                     double[] dstPts,
                                     int dstOff,
                                     int numPts)
                              throws NonInvertibleTransformException
        通过这个变换的逆变换一个坐标数组。 两个坐标阵列部分可以完全相同，也可以是相同阵列的重叠部分，而不影响结果的有效性。 该方法确保在前一个操作可以被转换之前，不会覆盖源坐标。 坐标以[x0, y0, x1, y1, ..., xn, yn]的顺序从指定的偏移开始存储在阵列中。 该方法只能用于2D变换。
        参数
        srcPts - 包含源点坐标的数组。 每个点被存储为一对x，y坐标。
        srcOff - 要在源数组中转换的第一个点的偏移量
        dstPts - 返回转换点坐标的阵列。 每个点被存储为一对x，y坐标。
        dstOff - 存储在目标数组中的第一个转换点的位置的偏移量
        numPts - 要转换的积分数
        异常
        IllegalStateException - 如果这是一个3D变换
        NonInvertibleTransformException - 如果这个变换不能被反转
        NullPointerException - 如果是 srcPts或（@code dstPts）为空
        从以下版本开始：
        JavaFX 8.0

      • inverseTransform3DPoints

        public void inverseTransform3DPoints​(double[] srcPts,
                                     int srcOff,
                                     double[] dstPts,
                                     int dstOff,
                                     int numPts)
                              throws NonInvertibleTransformException
        通过该变换的倒数转换浮点坐标数组。 三个坐标阵列部分可以完全相同或可以是相同阵列的重叠部分，而不会影响结果的有效性。 该方法确保在前一个操作可以被转换之前，不会覆盖源坐标。 坐标以[x0, y0, z0, x1, y1, z1, ..., xn, yn, zn]的顺序从指定的偏移开始存储在阵列中。
        参数
        srcPts - 包含源点坐标的数组。 每个点被存储为x，y，z坐标的三元组。
        srcOff - 要在源数组中转换的第一个点的偏移量
        dstPts - 返回转换点坐标的阵列。 每个点被存储为x，y，z坐标的三元组。
        dstOff - 存储在目标数组中的第一个转换点的位置的偏移量
        numPts - 要转换的点数
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转
        NullPointerException - 如果是 srcPts或（@code dstPts）为null
        从以下版本开始：
        JavaFX 8.0

      • inverseDeltaTransform

        public Point2D inverseDeltaTransform​(double x,
                                     double y)
                              throws NonInvertibleTransformException
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        参数
        x - 矢量在X轴方向的幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的逆变换相对幅度向量
        异常
        IllegalStateException - 如果这是一个3D变换
        NonInvertibleTransformException - 如果这个变换不能被反转
        从以下版本开始：
        JavaFX 8.0

      • inverseDeltaTransform

        public Point2D inverseDeltaTransform​(Point2D point)
                              throws NonInvertibleTransformException
        将由指定的Point2D实例表示的相对幅度向量转换为该变换的倒数。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        参数
        point - 相对幅度矢量
        结果
        由 Point2D实例表示的逆变换相对幅度向量
        异常
        IllegalStateException - 如果这是一个3D变换
        NonInvertibleTransformException - 如果这个变换不能被反转
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • inverseDeltaTransform

        public Point3D inverseDeltaTransform​(double x,
                                     double y,
                                     double z)
                              throws NonInvertibleTransformException
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        参数
        x - X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的逆变换相对幅度向量
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转
        从以下版本开始：
        JavaFX 8.0

      • inverseDeltaTransform

        public Point3D inverseDeltaTransform​(Point3D point)
                              throws NonInvertibleTransformException
        将由指定的Point3D实例表示的相对幅度向量转换为该变换的倒数。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        参数
        point - 相对幅度矢量
        结果
        由 Point3D实例表示的逆变换相对幅度向量
        异常
        NonInvertibleTransformException - 如果这个变换不能被反转
        NullPointerException - 如果指定的 point为空
        从以下版本开始：
        JavaFX 8.0

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        说明从接口EventTarget复制
        为此目标构建事件调度链。 事件调度链包含可能对处理针对EventTarget的事件感兴趣的事件调度EventTarget 。 此事件目标不会自动添加到链中，因此如果要处理事件，则需要为链接添加一个EventDispatcher 。

        在事件目标是某些层次结构的一部分的情况下，它的链通常是从从层次结构的根被收集到事件目标的事件分派器构建的。

        事件调度链是通过修改提供的初始事件调度链来构建的。 返回的链应该在其末端具有初始链，所以调度员应该放在初始链上。

        调用者不应该假定初始链条保持不变，也不会返回值引用不同的链。

        Specified by:
        buildEventDispatchChain接口 EventTarget
        参数
        tail
        结果
        此目标的结果事件调度链

      • addEventHandler

        public final <T extends Event> void addEventHandler​(EventType<T> eventType,
                                                    EventHandler<? super T> eventHandler)

        注册一个事件处理程序到这个变换。 首先处理任何事件过滤器，然后处理指定的onFoo事件处理程序，最后处理通过此方法注册的任何事件处理程序。

        目前唯一送到Transform事件是TransformChangedEvent ，它的单一类型是TRANSFORM_CHANGED 。

        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 处理程序接收的事件的类型
        eventHandler - 要注册的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空
        从以下版本开始：
        JavaFX 8.0

      • removeEventHandler

        public final <T extends Event> void removeEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        从此转换中注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空
        从以下版本开始：
        JavaFX 8.0

      • addEventFilter

        public final <T extends Event> void addEventFilter​(EventType<T> eventType,
                                                   EventHandler<? super T> eventFilter)

        为此转换注册事件过滤器。 注册事件过滤器在任何关联的事件处理程序之前获取事件。

        目前唯一送到Transform事件是TransformChangedEvent ，它是单一的类型TRANSFORM_CHANGED 。

        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 过滤器接收的事件的类型
        eventFilter - 要注册的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空
        从以下版本开始：
        JavaFX 8.0

      • removeEventFilter

        public final <T extends Event> void removeEventFilter​(EventType<T> eventType,
                                                      EventHandler<? super T> eventFilter)
        从此转换中注销先前注册的事件过滤器。 一个过滤器可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销过滤器。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 要注销的事件类型
        eventFilter - 要注销的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空
        从以下版本开始：
        JavaFX 8.0

      • setOnTransformChanged

        public final void setOnTransformChanged​(EventHandler<? super TransformChangedEvent> value)
        设置onTransformChanged事件处理程序，当变换改变其任何参数时，调用它。
        参数
        value - 事件处理程序可以为空清除它
        从以下版本开始：
        JavaFX 8.0

      • getOnTransformChanged

        public final EventHandler<? super TransformChangedEvent> getOnTransformChanged​()
        获取onTransformChanged事件处理程序。
        结果
        先前由 setOnTransformChanged设置的事件处理程序，如果未设置处理程序，则为null。
        从以下版本开始：
        JavaFX 8.0

      • onTransformChangedProperty

        public final ObjectProperty<EventHandler<? super TransformChangedEvent>> onTransformChangedProperty​()
        只要变换改变其任何参数，就调用onTransformChanged事件处理程序。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnTransformChanged() ， setOnTransformChanged(EventHandler)

      • transformChanged

        protected void transformChanged​()
        每当任何一个参数发生变化时，所有转换都必须调用此方法。 当变换的任何属性无效时，通常会调用它（如果设置了无效属性，则跳过该调用就可以了）。
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TransformChangedEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.transform

Class TransformChangedEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.transform.TransformChangedEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class TransformChangedEvent
extends Event
    当它的任何属性发生变化时，这个事件被触发。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<TransformChangedEvent> ANY
      所有变换事件类型的公共超类型。
      static EventType<TransformChangedEvent> TRANSFORM_CHANGED
      TransformChangedEvent唯一有效的EventType。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      TransformChangedEvent​()
      创建一个新的 TransformChangedEvent ，事件类型为 TRANSFORM_CHANGED 。
      TransformChangedEvent​(Object source, EventTarget target)
      构造一个新的 TransformChangedEvent与指定的事件源和目标。

    • 方法摘要

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TRANSFORM_CHANGED

        public static final EventType<TransformChangedEvent> TRANSFORM_CHANGED
        TransformChangedEvent唯一有效的EventType。

      • ANY

        public static final EventType<TransformChangedEvent> ANY
        所有变换事件类型的公共超类型。

    • 构造方法详细信息

      • TransformChangedEvent

        public TransformChangedEvent​()
        创建一个新的TransformChangedEvent ，事件类型为TRANSFORM_CHANGED 。 事件的源和目标设置为NULL_SOURCE_TARGET 。

      • TransformChangedEvent

        public TransformChangedEvent​(Object source,
                             EventTarget target)
        构造一个新的TransformChangedEvent与指定的事件源和目标。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。 所有TransformChangedEvents的类型设置为TRANSFORM_CHANGED 。
        参数
        source - 发送事件的事件源
        target - 与事件关联的事件目标
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Translate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.scene.transform

Class Translate

  • java.lang.Object
    • javafx.scene.transform.Transform
      • javafx.scene.transform.Translate
  • All Implemented Interfaces:
    Cloneable ， EventTarget

    public class Translate
extends Transform
    该类表示一个Affine对象，它根据指定的因素转换坐标。 代表翻译变换的矩阵如下：
      [   1    0    0    x  ]
              [   0    1    0    y  ]
              [   0    0    1    z  ]
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      DoubleProperty x
      定义坐标在X轴方向上平移的距离
      DoubleProperty y
      定义坐标在Y轴方向上平移的距离
      DoubleProperty z
      定义坐标在Z轴方向上平移的距离

      • Properties inherited from class javafx.scene.transform.Transform

        identity, onTransformChanged, type2D

    • 构造方法摘要

      构造方法
      Constructor 描述
      Translate​()
      创建默认的Translate（identity）。
      Translate​(double x, double y)
      创建一个二维的翻译。
      Translate​(double x, double y, double z)
      创建一个三维翻译。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Translate clone​()
      返回此转换的深层副本。
      Transform createConcatenation​(Transform transform)
      返回此变换和指定变换的并置。
      Translate createInverse​()
      返回此变换的逆变换。
      Point2D deltaTransform​(double x, double y)
      通过该变换来变换相对幅度矢量。
      Point3D deltaTransform​(double x, double y, double z)
      通过该变换来变换相对幅度矢量。
      Point2D deltaTransform​(Point2D point)
      通过该变换转换由指定的 Point2D实例表示的相对幅度向量。
      Point3D deltaTransform​(Point3D point)
      通过该变换转换由指定的 Point3D实例表示的相对幅度向量。
      double getTx​()
      获取3x4矩阵的X坐标转换元素。
      double getTy​()
      获取3x4矩阵的Y坐标转换元素。
      double getTz​()
      获取3x4矩阵的Z坐标转换元素。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      double getZ​()
      获取属性z的值。
      Point2D inverseDeltaTransform​(double x, double y)
      通过该变换的逆变换相对幅度矢量。
      Point3D inverseDeltaTransform​(double x, double y, double z)
      通过该变换的逆变换相对幅度矢量。
      Point2D inverseDeltaTransform​(Point2D point)
      将由指定的 Point2D实例表示的相对幅度向量转换为该变换的倒数。
      Point3D inverseDeltaTransform​(Point3D point)
      通过该变换的逆变换由指定的 Point3D实例表示的相对幅度向量。
      Point2D inverseTransform​(double x, double y)
      通过该变换的逆变换指定点。
      Point3D inverseTransform​(double x, double y, double z)
      通过该变换的逆变换指定点。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      void setZ​(double value)
      设置属性z的值。
      String toString​()
      返回此 Translate对象的字符串表示形式。
      Point2D transform​(double x, double y)
      通过此转换来转换指定的点。
      Point3D transform​(double x, double y, double z)
      通过此转换来转换指定的点。
      DoubleProperty xProperty​()
      定义坐标在X轴方向上平移的距离
      DoubleProperty yProperty​()
      定义坐标在Y轴方向上平移的距离
      DoubleProperty zProperty​()
      定义坐标在Z轴方向上平移的距离

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.transform.Transform

        addEventFilter, addEventHandler, affine, affine, buildEventDispatchChain, column, column, determinant, getElement, getMxx, getMxy, getMxz, getMyx, getMyy, getMyz, getMzx, getMzy, getMzz, getOnTransformChanged, identityProperty, inverseTransform, inverseTransform, inverseTransform, inverseTransform2DPoints, inverseTransform3DPoints, isIdentity, isType2D, onTransformChangedProperty, removeEventFilter, removeEventHandler, rotate, row, row, scale, scale, setOnTransformChanged, shear, shear, similarTo, toArray, toArray, transform, transform, transform, transform2DPoints, transform3DPoints, transformChanged, translate, type2DProperty

    • Property Detail

      • x

        public final DoubleProperty xProperty
        定义坐标在X轴方向上平移的距离
        另请参见：
        getX() ， setX(double)

      • y

        public final DoubleProperty yProperty
        定义坐标在Y轴方向上平移的距离
        另请参见：
        getY() ， setY(double)

      • z

        public final DoubleProperty zProperty
        定义坐标在Z轴方向上平移的距离
        另请参见：
        getZ() ， setZ(double)

    • 构造方法详细信息

      • Translate

        public Translate​()
        创建默认的Translate（identity）。

      • Translate

        public Translate​(double x,
                 double y)
        创建一个二维的翻译。
        参数
        x - 坐标在X轴方向上平移的距离
        y - 坐标在Y轴方向上平移的距离

      • Translate

        public Translate​(double x,
                 double y,
                 double z)
        创建一个三维翻译。
        参数
        x - 坐标在X轴方向上平移的距离
        y - 坐标在Y轴方向上平移的距离
        z - 坐标在Z轴方向平移的距离

    • 方法详细信息

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        定义坐标在X轴方向上平移的距离

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        定义坐标在X轴方向上平移的距离

      • xProperty

        public final DoubleProperty xProperty​()
        定义坐标在X轴方向上平移的距离
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        定义坐标在Y轴方向上平移的距离

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        定义坐标在Y轴方向上平移的距离

      • yProperty

        public final DoubleProperty yProperty​()
        定义坐标在Y轴方向上平移的距离
        另请参见：
        getY() ， setY(double)

      • setZ

        public final void setZ​(double value)
        设置属性z的值。
        Property description:
        定义坐标在Z轴方向上平移的距离

      • getZ

        public final double getZ​()
        获取属性z的值。
        Property description:
        定义坐标在Z轴方向上平移的距离

      • zProperty

        public final DoubleProperty zProperty​()
        定义坐标在Z轴方向上平移的距离
        另请参见：
        getZ() ， setZ(double)

      • getTx

        public double getTx​()
        描述从类复制： Transform
        获取3x4矩阵的X坐标转换元素。
        重写：
        getTx在 Transform
        结果
        3x4矩阵的X坐标转换元素

      • getTy

        public double getTy​()
        说明从类别复制： Transform
        获取3x4矩阵的Y坐标转换元素。
        重写：
        getTy在 Transform
        结果
        3×4矩阵的Y坐标转换元素

      • getTz

        public double getTz​()
        描述从类复制： Transform
        获取3x4矩阵的Z坐标转换元素。
        重写：
        getTz在 Transform
        结果
        3×4矩阵的Z坐标转换元素

      • createConcatenation

        public Transform createConcatenation​(Transform transform)
        描述从类复制： Transform
        返回此变换和指定变换的并置。 将结果变换应用到一个节点具有相同的效果，将两个变换添加到其getTransforms()列表中， this第一次转换和指定的transform秒。
        重写：
        createConcatenation在 Transform
        参数
        transform - 转换为与此变换连接
        结果
        连接变换

      • createInverse

        public Translate createInverse​()
        描述从类复制： Transform
        返回此变换的逆变换。
        重写：
        createInverse在 Transform
        结果
        逆变换

      • clone

        public Translate clone​()
        描述从类复制： Transform
        返回此转换的深层副本。
        重写：
        clone在 Transform
        结果
        这个转换的副本
        另请参见：
        Cloneable

      • transform

        public Point2D transform​(double x,
                         double y)
        描述从类复制： Transform
        通过此转换来转换指定的点。 该方法只能用于2D变换。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        转化点

      • transform

        public Point3D transform​(double x,
                         double y,
                         double z)
        描述从类复制： Transform
        通过此转换来转换指定的点。
        重写：
        transform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        转化点

      • deltaTransform

        public Point2D deltaTransform​(double x,
                              double y)
        描述从类复制： Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        deltaTransform在 Transform
        参数
        x - 矢量在X轴方向的幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的变换的相对幅度向量

      • deltaTransform

        public Point2D deltaTransform​(Point2D point)
        描述从类复制： Transform
        通过此变换转换由指定的Point2D实例表示的相对幅度向量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        deltaTransform在 Transform
        参数
        point - 相对幅度矢量
        结果
        由 Point2D实例表示的变换的相对幅度向量

      • deltaTransform

        public Point3D deltaTransform​(double x,
                              double y,
                              double z)
        描述从类复制： Transform
        通过该变换来变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        deltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 在Y轴方向上的向量幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的变换后的相对幅度向量

      • deltaTransform

        public Point3D deltaTransform​(Point3D point)
        描述从类复制： Transform
        通过该变换转换由指定的Point3D实例表示的相对幅度向量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        deltaTransform在 Transform
        参数
        point - 相对幅度矢量
        结果
        由 Point3D实例表示的变换后的相对幅度向量

      • inverseTransform

        public Point2D inverseTransform​(double x,
                                double y)
        描述从类复制： Transform
        通过该变换的逆变换指定点。 该方法只能用于2D变换。
        重写：
        inverseTransform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        结果
        逆转点

      • inverseTransform

        public Point3D inverseTransform​(double x,
                                double y,
                                double z)
        描述从类： Transform复制
        通过该变换的逆变换指定点。
        重写：
        inverseTransform在 Transform
        参数
        x - 点的X坐标
        y - 点的Y坐标
        z - 点的Z坐标
        结果
        逆转点

      • inverseDeltaTransform

        public Point2D inverseDeltaTransform​(double x,
                                     double y)
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        结果
        由 Point2D实例表示的逆变换相对幅度向量

      • inverseDeltaTransform

        public Point2D inverseDeltaTransform​(Point2D point)
        描述从类复制： Transform
        将由指定的Point2D实例表示的相对幅度向量转换为该变换的倒数。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。 该方法只能用于2D变换。
        重写：
        inverseDeltaTransform在 Transform
        参数
        point - 相对幅度矢量
        结果
        由 Point2D实例表示的逆变换相对幅度向量

      • inverseDeltaTransform

        public Point3D inverseDeltaTransform​(double x,
                                     double y,
                                     double z)
        描述从类复制： Transform
        通过该变换的逆变换相对幅度矢量。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        inverseDeltaTransform在 Transform
        参数
        x - 在X轴方向的向量幅度
        y - 矢量在Y轴方向的幅度
        z - 矢量在Z轴方向的幅度
        结果
        由 Point3D实例表示的逆变换相对幅度向量

      • inverseDeltaTransform

        public Point3D inverseDeltaTransform​(Point3D point)
        描述从类复制： Transform
        将由指定的Point3D实例表示的相对幅度向量转换为该变换的倒数。 在不应用仿射变换矩阵的平移分量的情况下变换矢量。
        重写：
        inverseDeltaTransform在 Transform
        参数
        point - 相对幅度矢量
        结果
        由 Point3D实例表示的逆变换相对幅度向量

      • toString

        public String toString​()
        返回此 Translate对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这是一个 Translate对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.transform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.transform

  • Packages that use javafx.scene.transform
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
  • Classes in javafx.scene.transform used by javafx.scene
    Class 描述
    Transform
    这个类是不同仿射变换的基类。
  • Classes in javafx.scene.transform used by javafx.scene.canvas
    Class 描述
    Affine
    Affine类代表一般的仿射变换。
  • Classes in javafx.scene.transform used by javafx.scene.transform
    Class 描述
    Affine
    Affine类代表一般的仿射变换。
    MatrixType
    指定转换矩阵的类型。
    NonInvertibleTransformException
    NonInvertibleTransformException类表示如果执行的操作需要处于非可逆状态的 Transform对象的倒数时抛出异常。
    Rotate
    该类表示一个 Affine对象，它绕坐标点旋转坐标。
    Scale
    此类表示一个 Affine对象，可根据指定的因素对坐标进行缩放。
    Shear
    该类代表一个 Affine对象，它通过指定的乘数来剪切坐标。
    Transform
    这个类是不同仿射变换的基类。
    TransformChangedEvent
    当它的任何属性发生变化时，这个事件被触发。
    Translate
    该类表示一个 Affine对象，它根据指定的因素转换坐标。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.transform.Affine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.transform.Affine

  • Packages that use Affine
    软件包 描述
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.transform
    提供一组方便的类来为 Affine对象执行旋转，缩放，剪切和转换转换。

    • Uses of Affine in javafx.scene.canvas

      Methods in javafx.scene.canvas that return Affine
      Modifier and Type 方法 描述
      Affine GraphicsContext.getTransform​()
      返回当前变换的副本。
      Affine GraphicsContext.getTransform​(Affine xform)
      将当前变换复制到提供的对象中，创建一个新的Affine对象（如果为null），并返回包含副本的对象。
      Methods in javafx.scene.canvas with parameters of type Affine
      Modifier and Type 方法 描述
      Affine GraphicsContext.getTransform​(Affine xform)
      将当前变换复制到提供的对象中，如果为null，则创建一个新的Affine对象，并返回包含副本的对象。
      void GraphicsContext.setTransform​(Affine xform)
      设置当前变换。
      void GraphicsContext.transform​(Affine xform)
      将输入与当前变换相连。

    • Uses of Affine in javafx.scene.transform

      Methods in javafx.scene.transform that return Affine
      Modifier and Type | 方法 | 描述
      static Affine Transform.affine​(double mxx, double myx, double mxy, double myy, double tx, double ty)
      从12个数字值返回一个新的 Affine对象，表示3x4仿射变换矩阵的6个可指定条目。
      static Affine Transform.affine​(double mxx, double mxy, double mxz, double tx, double myx, double myy, double myz, double ty, double mzx, double mzy, double mzz, double tz)
      从12个数字值返回新的 Affine对象，表示3x4仿射变换矩阵的12个可指定条目。
      Affine | Affine.clone​()
      Affine | Affine.createInverse​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.transform.MatrixType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.transform.MatrixType

  • Packages that use MatrixType
    软件包 描述
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

    • Uses of MatrixType in javafx.scene.transform

      Methods in javafx.scene.transform that return MatrixType
      Modifier and Type 方法 描述
      static MatrixType MatrixType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MatrixType[] MatrixType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.transform with parameters of type MatrixType
      Modifier and Type 方法 描述
      void Affine.append​(double[] matrix, MatrixType type, int offset)
      将数组指定的变换追加到此实例。
      double[] Transform.column​(MatrixType type, int column)
      返回一个包含转换矩阵列的数组。
      double[] Transform.column​(MatrixType type, int column, double[] array)
      返回一个包含转换矩阵列的数组。
      double Transform.getElement​(MatrixType type, int row, int column)
      获取转换矩阵的指定元素。
      void Affine.prepend​(double[] matrix, MatrixType type, int offset)
      将数组指定的变换预置到此实例。
      double[] Transform.row​(MatrixType type, int row)
      返回一个包含转换矩阵行的数组。
      double[] Transform.row​(MatrixType type, int row, double[] array)
      返回一个包含转换矩阵行的数组。
      void Affine.setElement​(MatrixType type, int row, int column, double value)
      设置变换矩阵的指定元素。
      void Affine.setToTransform​(double[] matrix, MatrixType type, int offset)
      将此实例的值设置为由数组指定的转换矩阵。
      double[] Transform.toArray​(MatrixType type)
      返回一个包含展平变换矩阵的数组。
      double[] Transform.toArray​(MatrixType type, double[] array)
      返回一个包含展平变换矩阵的数组。
      Constructors in javafx.scene.transform with parameters of type MatrixType
      Constructor 描述
      Affine​(double[] matrix, MatrixType type, int offset)
      使用由数组指定的转换矩阵创建一个新的 Affine实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.transform.NonInvertibleTransformException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.transform.NonInvertibleTransformException

  • Packages that use NonInvertibleTransformException
    软件包 描述
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

    • Uses of NonInvertibleTransformException in javafx.scene.transform

      Methods in javafx.scene.transform that throw NonInvertibleTransformException
      Modifier and Type | 方法 | 描述
      Affine | Affine.createInverse​()
      Transform | Rotate.createInverse​()
      Scale | Scale.createInverse​()
      Transform Transform.createInverse​()
      返回此变换的逆变换。
      Point2D | Affine.inverseDeltaTransform​(double x, double y)
      Point3D | Affine.inverseDeltaTransform​(double x, double y, double z)
      Point2D | Scale.inverseDeltaTransform​(double x, double y)
      Point3D | Scale.inverseDeltaTransform​(double x, double y, double z)
      Point2D | Shear.inverseDeltaTransform​(double x, double y)
      Point3D | Shear.inverseDeltaTransform​(double x, double y, double z)
      Point2D Transform.inverseDeltaTransform​(double x, double y)
      通过该变换的逆变换相对幅度矢量。
      Point3D Transform.inverseDeltaTransform​(double x, double y, double z)
      通过该变换的逆变换相对幅度矢量。
      Point2D Transform.inverseDeltaTransform​(Point2D point)
      将由指定的 Point2D实例表示的相对幅度向量转换为该变换的倒数。
      Point3D Transform.inverseDeltaTransform​(Point3D point)
      通过该变换的逆变换由指定的 Point3D实例表示的相对幅度向量。
      Point2D | Affine.inverseTransform​(double x, double y)
      Point3D | Affine.inverseTransform​(double x, double y, double z)
      Point2D | Scale.inverseTransform​(double x, double y)
      Point3D | Scale.inverseTransform​(double x, double y, double z)
      Point2D | Shear.inverseTransform​(double x, double y)
      Point3D | Shear.inverseTransform​(double x, double y, double z)
      Point2D Transform.inverseTransform​(double x, double y)
      通过该变换的逆变换指定点。
      Point3D Transform.inverseTransform​(double x, double y, double z)
      通过该变换的逆变换指定点。
      Bounds Transform.inverseTransform​(Bounds bounds)
      通过该变换的倒数转换指定的边界。
      Point2D Transform.inverseTransform​(Point2D point)
      通过该变换的逆变换指定点。
      Point3D Transform.inverseTransform​(Point3D point)
      通过该变换的逆变换指定点。
      void Transform.inverseTransform2DPoints​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过这个变换的逆变换一个坐标数组。
      void Transform.inverseTransform3DPoints​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过该变换的倒数转换浮点坐标数组。
      void Affine.invert​()
      将此转换转换到位。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.transform.Rotate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.transform.Rotate

  • Packages that use Rotate
    软件包 描述
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

    • Uses of Rotate in javafx.scene.transform

      Methods in javafx.scene.transform that return Rotate
      Modifier and Type | 方法 | 描述
      Rotate | Rotate.clone​()
      static Rotate Transform.rotate​(double angle, double pivotX, double pivotY)
      返回一个 Rotate对象，旋转枢轴点周围的坐标。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.transform.Scale (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.transform.Scale

  • Packages that use Scale
    软件包 描述
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。

    • Uses of Scale in javafx.scene.transform

      Methods in javafx.scene.transform that return Scale
      Modifier and Type | 方法 | 描述
      Scale | Scale.clone​()
      Scale | Scale.createInverse​()
      static Scale Transform.scale​(double x, double y)
      返回表示缩放变换的 Scale对象。
      static Scale Transform.scale​(double x, double y, double pivotX, double pivotY)
      返回表示缩放变换的 Scale对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.transform.Shear (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.transform.Shear

  • Packages that use Shear
    软件包 描述
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

    • Uses of Shear in javafx.scene.transform

      Methods in javafx.scene.transform that return Shear
      Modifier and Type | 方法 | 描述
      Shear | Shear.clone​()
      static Shear Transform.shear​(double x, double y)
      返回表示剪切变换的 Shear对象。
      static Shear Transform.shear​(double x, double y, double pivotX, double pivotY)
      返回表示剪切变换的 Shear对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.transform.Transform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.transform.Transform

  • Packages that use Transform
    软件包 描述
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

    • Uses of Transform in javafx.scene

      Methods in javafx.scene that return Transform
      Modifier and Type 方法 描述
      Transform Node.getLocalToParentTransform​()
      获取属性localToParentTransform的值。
      Transform Node.getLocalToSceneTransform​()
      获取属性localToSceneTransform的值。
      Transform SnapshotParameters.getTransform​()
      获取当前的变换。
      Methods in javafx.scene that return types with arguments of type Transform
      Modifier and Type 方法 描述
      ObservableList<Transform> Node.getTransforms​()
      定义的ObservableList Transform个对象被应用到这个Node 。
      ReadOnlyObjectProperty<Transform> Node.localToParentTransformProperty​()
      保存计算的本地到父变换的仿射变换。
      ReadOnlyObjectProperty<Transform> Node.localToSceneTransformProperty​()
      拥有计算的局部到场景变换的仿射变换。
      Methods in javafx.scene with parameters of type Transform
      Modifier and Type 方法 描述
      void SnapshotParameters.setTransform​(Transform transform)
      将转换设置为指定的值。

    • Uses of Transform in javafx.scene.transform

      Subclasses of Transform in javafx.scene.transform
      Modifier and Type Class 描述
      class  Affine
      Affine类代表一般的仿射变换。
      class  Rotate
      该类表示一个 Affine对象，它绕坐标点旋转坐标。
      class  Scale
      该类表示一个 Affine对象，它根据指定的因素缩放坐标。
      class  Shear
      该类代表一个 Affine对象，它通过指定的乘数来剪切坐标。
      class  Translate
      该类表示一个 Affine对象，它根据指定的因素转换坐标。
      Methods in javafx.scene.transform that return Transform
      Modifier and Type | 方法 | 描述
      Transform Transform.clone​()
      返回此转换的深层副本。
      Transform | Affine.createConcatenation​(Transform transform)
      Transform | Rotate.createConcatenation​(Transform transform)
      Transform | Scale.createConcatenation​(Transform transform)
      Transform | Shear.createConcatenation​(Transform transform)
      Transform Transform.createConcatenation​(Transform transform)
      返回此变换和指定变换的并置。
      Transform | Translate.createConcatenation​(Transform transform)
      Transform | Rotate.createInverse​()
      Transform | Shear.createInverse​()
      Transform Transform.createInverse​()
      返回此变换的逆变换。
      Methods in javafx.scene.transform with parameters of type Transform
      Modifier and Type | 方法 | 描述
      void Affine.append​(Transform transform)
      将指定的变换附加到此实例。
      Transform | Affine.createConcatenation​(Transform transform)
      Transform | Rotate.createConcatenation​(Transform transform)
      Transform | Scale.createConcatenation​(Transform transform)
      Transform | Shear.createConcatenation​(Transform transform)
      Transform Transform.createConcatenation​(Transform transform)
      返回此变换和指定变换的并置。
      Transform | Translate.createConcatenation​(Transform transform)
      void Affine.prepend​(Transform transform)
      将指定的变换预置到此实例。
      void Affine.setToTransform​(Transform transform)
      将此实例的值设置为指定转换提供的值。
      boolean Transform.similarTo​(Transform transform, Bounds range, double maxDelta)
      检查这个变换是否类似于指定的变换。
      Constructors in javafx.scene.transform with parameters of type Transform
      Constructor 描述
      Affine​(Transform transform)
      创建一个填充了指定变换值的新实例 Affine 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.transform.TransformChangedEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.transform.TransformChangedEvent

  • Packages that use TransformChangedEvent
    软件包 描述
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。

    • Uses of TransformChangedEvent in javafx.scene.transform

      Fields in javafx.scene.transform with type parameters of type TransformChangedEvent
      Modifier and Type Field 描述
      static EventType<TransformChangedEvent> TransformChangedEvent.ANY
      所有变换事件类型的公共超类型。
      static EventType<TransformChangedEvent> TransformChangedEvent.TRANSFORM_CHANGED
      TransformChangedEvent唯一有效的EventType。
      Methods in javafx.scene.transform that return types with arguments of type TransformChangedEvent
      Modifier and Type 方法 描述
      EventHandler<? super TransformChangedEvent> Transform.getOnTransformChanged​()
      获取onTransformChanged事件处理程序。
      ObjectProperty<EventHandler<? super TransformChangedEvent>> Transform.onTransformChangedProperty​()
      只要变换改变其任何参数，就调用onTransformChanged事件处理程序。
      Method parameters in javafx.scene.transform with type arguments of type TransformChangedEvent
      Modifier and Type 方法 描述
      void Transform.setOnTransformChanged​(EventHandler<? super TransformChangedEvent> value)
      设置onTransformChanged事件处理程序，当变换改变其任何参数时，调用它。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.transform.Translate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.transform.Translate

  • Packages that use Translate
    软件包 描述
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

    • Uses of Translate in javafx.scene.transform

      Methods in javafx.scene.transform that return Translate
      Modifier and Type | 方法 | 描述
      Translate | Translate.clone​()
      Translate | Translate.createInverse​()
      static Translate Transform.translate​(double x, double y)
      返回表示转换变换的 Translate对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


HTMLEditor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class HTMLEditor

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control
            • javafx.scene.web.HTMLEditor
  • All Implemented Interfaces:
    Styleable ， EventTarget ， Skinnable

    public class HTMLEditor
extends Control
    允许用户编辑文本并将样式应用于此文本的控件。 底层数据模型是HTML，尽管这不是最终用户可视地显示的。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.scene.control.Control

        contextMenu, skin, tooltip

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

      • Properties inherited from class javafx.scene.layout.Region

        background, border, cacheShape, centerShape, height, insets, maxHeight, maxWidth, minHeight, minWidth, opaqueInsets, padding, prefHeight, prefWidth, scaleShape, shape, snapToPixel, width

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

      • Fields inherited from class javafx.scene.layout.Region

        USE_COMPUTED_SIZE, USE_PREF_SIZE

    • 构造方法摘要

      构造方法
      Constructor 描述
      HTMLEditor​()
      创建HTMLEditor控件的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Skin<?> createDefaultSkin​()
      为此控件创建一个新的默认皮肤实例。
      String getHtmlText​()
      返回编辑器的HTML内容。
      void print​(PrinterJob job)
      使用给定的打印机作业打印编辑器的内容。
      void setHtmlText​(String htmlText)
      设置编辑器的HTML内容。

      • Methods inherited from class javafx.scene.control.Control

        computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, contextMenuProperty, executeAccessibleAction, getBaselineOffset, getClassCssMetaData, getContextMenu, getControlCssMetaData, getCssMetaData, getInitialFocusTraversable, getSkin, getTooltip, isResizable, layoutChildren, queryAccessibleAttribute, setContextMenu, setSkin, setTooltip, skinProperty, tooltipProperty

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        getChildren, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, lookup, needsLayoutProperty, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from class javafx.scene.layout.Region

        backgroundProperty, borderProperty, cacheShapeProperty, centerShapeProperty, getBackground, getBorder, getHeight, getInsets, getMaxHeight, getMaxWidth, getMinHeight, getMinWidth, getOpaqueInsets, getPadding, getPrefHeight, getPrefWidth, getShape, getUserAgentStylesheet, getWidth, heightProperty, insetsProperty, isCacheShape, isCenterShape, isScaleShape, isSnapToPixel, layoutInArea, layoutInArea, layoutInArea, layoutInArea, maxHeight, maxHeightProperty, maxWidth, maxWidthProperty, minHeight, minHeightProperty, minWidth, minWidthProperty, opaqueInsetsProperty, paddingProperty, positionInArea, positionInArea, prefHeight, prefHeightProperty, prefWidth, prefWidthProperty, resize, scaleShapeProperty, setBackground, setBorder, setCacheShape, setCenterShape, setHeight, setMaxHeight, setMaxSize, setMaxWidth, setMinHeight, setMinSize, setMinWidth, setOpaqueInsets, setPadding, setPrefHeight, setPrefSize, setPrefWidth, setScaleShape, setShape, setSnapToPixel, setWidth, shapeProperty, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, snapToPixelProperty, widthProperty

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • 构造方法详细信息

      • HTMLEditor

        public HTMLEditor​()
        创建HTMLEditor控件的新实例。

    • 方法详细信息

      • createDefaultSkin

        protected Skin<?> createDefaultSkin​()
        描述从类复制： Control
        为此控件创建一个新的默认皮肤实例。 如果没有通过CSS -fx-skin提供皮肤或者在具有setSkin(...)的子类中显式设置，则会调用此控件创建皮肤。
        重写：
        createDefaultSkin在 Control
        结果
        此控件的默认皮肤的新实例。 如果为null，则控件将没有皮肤，除非由css提供。

      • getHtmlText

        public String getHtmlText​()
        返回编辑器的HTML内容。
        结果
        HTML内容

      • setHtmlText

        public void setHtmlText​(String htmlText)
        设置编辑器的HTML内容。 请注意，如果提供的HTML的<body>标签上的contentEditable属性未设置为true，则HTMLEditor将变为只读。 您可以确保文本保持可编辑，方法是确保正文出现：
           <body contentEditable="true">
        参数
        htmlText - 将完整的HTML标记放入编辑器。 这应该包括所有正常的HTML元素，从<html>开始，并包括一个<body> 。

      • print

        public void print​(PrinterJob job)
        使用给定的打印机作业打印编辑器的内容。

        此方法不修改作业的状态，也不调用PrinterJob.endJob() ，因此该作业可以安全地重用。

        参数
        job - 用于打印的打印机作业
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HTMLEditorSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class HTMLEditorSkin

  • java.lang.Object
    • javafx.scene.control.SkinBase<HTMLEditor>
      • javafx.scene.web.HTMLEditorSkin
  • All Implemented Interfaces:
    Skin<HTMLEditor>

    public class HTMLEditorSkin
extends SkinBase<HTMLEditor>
    HTML编辑器皮肤。
    从以下版本开始：
    9
    另请参见：
    HTMLEditor

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  HTMLEditorSkin.Command
      表示可以传递到HTMLEditor Web引擎的命令。

    • 构造方法摘要

      构造方法
      Constructor 描述
      HTMLEditorSkin​(HTMLEditor control)
      创建一个新的HTMLEditorSkin实例，将必要的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void layoutChildren​(double x, double y, double w, double h)
      在场景图的布局过程中调用。
      void performCommand​(HTMLEditorSkin.Command command)
      某些命令的特殊情况处理。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.scene.control.SkinBase

        computeBaselineOffset, computeMaxHeight, computeMaxWidth, computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, consumeMouseEvents, dispose, executeAccessibleAction, getChildren, getClassCssMetaData, getCssMetaData, getNode, getSkinnable, layoutInArea, layoutInArea, layoutInArea, positionInArea, positionInArea, pseudoClassStateChanged, queryAccessibleAttribute, registerChangeListener, snappedBottomInset, snappedLeftInset, snappedRightInset, snappedTopInset, snapPosition, snapPositionX, snapPositionY, snapSize, snapSizeX, snapSizeY, snapSpace, snapSpaceX, snapSpaceY, unregisterChangeListeners

    • 构造方法详细信息

      • HTMLEditorSkin

        public HTMLEditorSkin​(HTMLEditor control)
        创建一个新的HTMLEditorSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
        参数
        control - 这个皮肤应该安装到的控件。

    • 方法详细信息

      • performCommand

        public void performCommand​(HTMLEditorSkin.Command command)
        某些命令的特殊情况处理。 随着时间的推移，这可能会扩展到处理其他命令。 当前支持的命令列表是：
        • 胆大
        • ITALIC
        • 强调
        参数
        command - 命令

      • layoutChildren

        protected void layoutChildren​(double x,
                              double y,
                              double w,
                              double h)
        在场景图的布局过程中调用。
        重写：
        layoutChildren在 SkinBase<HTMLEditor>
        参数
        x - x位置
        y - y位置
        w - 宽度
        h - 高度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HTMLEditorSkin.Command (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Enum HTMLEditorSkin.Command

  • java.lang.Object
    • java.lang.Enum<HTMLEditorSkin.Command>
      • javafx.scene.web.HTMLEditorSkin.Command
  • All Implemented Interfaces:
    Serializable ， Comparable<HTMLEditorSkin.Command>
    Enclosing class:
    HTMLEditorSkin

    public static enum HTMLEditorSkin.Command
extends Enum<HTMLEditorSkin.Command>
    表示可以传递到HTMLEditor Web引擎的命令。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALIGN_CENTER
      ALIGN_JUSTIFY
      ALIGN_LEFT
      ALIGN_RIGHT
      BACKGROUND_COLOR
      BOLD
      BULLETS
      COPY
      CUT
      FONT_FAMILY
      FONT_SIZE
      FOREGROUND_COLOR
      FORMAT
      INDENT
      INSERT_HORIZONTAL_RULE
      INSERT_NEW_LINE
      INSERT_TAB
      ITALIC
      NUMBERS
      OUTDENT
      PASTE
      REDO
      STRIKETHROUGH
      UNDERLINE
      UNDO

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getCommand​()
      static HTMLEditorSkin.Command valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HTMLEditorSkin.Command[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CUT

        public static final HTMLEditorSkin.Command CUT

      • COPY

        public static final HTMLEditorSkin.Command COPY

      • PASTE

        public static final HTMLEditorSkin.Command PASTE

      • UNDO

        public static final HTMLEditorSkin.Command UNDO

      • REDO

        public static final HTMLEditorSkin.Command REDO

      • INSERT_HORIZONTAL_RULE

        public static final HTMLEditorSkin.Command INSERT_HORIZONTAL_RULE

      • ALIGN_LEFT

        public static final HTMLEditorSkin.Command ALIGN_LEFT

      • ALIGN_CENTER

        public static final HTMLEditorSkin.Command ALIGN_CENTER

      • ALIGN_RIGHT

        public static final HTMLEditorSkin.Command ALIGN_RIGHT

      • ALIGN_JUSTIFY

        public static final HTMLEditorSkin.Command ALIGN_JUSTIFY

      • BULLETS

        public static final HTMLEditorSkin.Command BULLETS

      • NUMBERS

        public static final HTMLEditorSkin.Command NUMBERS

      • INDENT

        public static final HTMLEditorSkin.Command INDENT

      • OUTDENT

        public static final HTMLEditorSkin.Command OUTDENT

      • FORMAT

        public static final HTMLEditorSkin.Command FORMAT

      • FONT_FAMILY

        public static final HTMLEditorSkin.Command FONT_FAMILY

      • FONT_SIZE

        public static final HTMLEditorSkin.Command FONT_SIZE

      • BOLD

        public static final HTMLEditorSkin.Command BOLD

      • ITALIC

        public static final HTMLEditorSkin.Command ITALIC

      • UNDERLINE

        public static final HTMLEditorSkin.Command UNDERLINE

      • STRIKETHROUGH

        public static final HTMLEditorSkin.Command STRIKETHROUGH

      • FOREGROUND_COLOR

        public static final HTMLEditorSkin.Command FOREGROUND_COLOR

      • BACKGROUND_COLOR

        public static final HTMLEditorSkin.Command BACKGROUND_COLOR

      • INSERT_NEW_LINE

        public static final HTMLEditorSkin.Command INSERT_NEW_LINE

      • INSERT_TAB

        public static final HTMLEditorSkin.Command INSERT_TAB

    • 方法详细信息

      • values

        public static HTMLEditorSkin.Command[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (HTMLEditorSkin.Command c : HTMLEditorSkin.Command.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static HTMLEditorSkin.Command valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • getCommand

        public String getCommand​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


javafx.scene.web (Java SE 9 & JDK 9 )

javafx.scene.web

Classes

  • HTMLEditor
  • HTMLEditorSkin
  • PopupFeatures
  • PromptData
  • WebEngine
  • WebErrorEvent
  • WebEvent
  • WebHistory
  • WebView

Enums

  • HTMLEditorSkin.Command


javafx.scene.web (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.web

Package javafx.scene.web

该软件包提供了加载和显示Web内容的方法。 其功能由两个核心类实现：

WebEngine是一种非可视化组件，能够加载网页，为其创建DOM对象，并在页面内运行脚本。

WebView是一个Node ，呈现由WebEngine管理的WebEngine 。 每个WebView都有一个WebEngine与它相关联。 该关联是在WebView被实例化建立的，后来不能改变。

应在FX用户线程上创建和操作WebEngine和WebView 。

下面的代码片段显示了一个典型的使用场景：

   WebView webView = new WebView(); WebEngine webEngine = webView.getEngine(); webEngine.load("http://javafx.com"); // add webView to the scene
  • 类摘要
    Class 描述
    HTMLEditor
    允许用户编辑文本并将样式应用于此文本的控件。
    HTMLEditorSkin
    HTML编辑器皮肤。
    PopupFeatures
    此类描述了由JavaScript window.open函数指定的Web弹出窗口的功能。
    PromptData
    这个类封装了传递给JavaScript prompt()函数的数据：一个消息和一个默认值。
    WebEngine
    WebEngine是一个能够一次管理一个网页的非可视对象。
    WebErrorEvent
    一个事件指示WebEngine错误。
    WebEvent<T>
    WebEvent实例被传递到EventHandler通过在网页上运行的JavaScript注册的WebEngine 。
    WebHistory
    WebHistory类表示与WebEngine实例相关联的会话历史。
    WebView
    WebView是一个Node ，管理一个WebEngine并显示其内容。
  • 枚举摘要
    Enum 描述
    HTMLEditorSkin.Command
    表示可以传递到HTMLEditor Web引擎的命令。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.scene.web Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.scene.web

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javafx.event.Event (implements java.lang.Cloneable)
        • javafx.scene.web.WebErrorEvent
        • javafx.scene.web.WebEvent<T>
    • javafx.scene.Node (implements javafx.event.EventTarget, javafx.css.Styleable)
      • javafx.scene.Parent
        • javafx.scene.layout.Region
          • javafx.scene.control.Control (implements javafx.scene.control.Skinnable)
            • javafx.scene.web.HTMLEditor
        • javafx.scene.web.WebView
    • javafx.scene.web.PopupFeatures
    • javafx.scene.web.PromptData
    • javafx.scene.control.SkinBase<C> (implements javafx.scene.control.Skin<C>)
      • javafx.scene.web.HTMLEditorSkin
    • javafx.scene.web.WebEngine
    • javafx.scene.web.WebHistory
    • javafx.scene.web.WebHistory.Entry

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.scene.web.HTMLEditorSkin.Command
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


PopupFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class PopupFeatures

  • java.lang.Object
    • javafx.scene.web.PopupFeatures

  • public final class PopupFeatures
extends Object
    此类描述了由JavaScript window.open函数指定的Web弹出窗口的功能。 实例被传递到使用WebEngine.setCreatePopupHandler(javafx.util.Callback<javafx.scene.web.PopupFeatures, javafx.scene.web.WebEngine>)方法在WebEngine上注册的弹出窗口处理程序。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WebEngine ， WebEngine.setCreatePopupHandler(javafx.util.Callback<javafx.scene.web.PopupFeatures, javafx.scene.web.WebEngine>)

    • 构造方法摘要

      构造方法
      Constructor 描述
      PopupFeatures​(boolean menu, boolean status, boolean toolbar, boolean resizable)
      创建一个新的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean hasMenu​()
      返回菜单栏是否存在。
      boolean hasStatus​()
      返回状态栏是否应该存在。
      boolean hasToolbar​()
      返回是否存在工具栏。
      boolean isResizable​()
      返回弹出窗口是否应该调整大小。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PopupFeatures

        public PopupFeatures​(boolean menu,
                     boolean status,
                     boolean toolbar,
                     boolean resizable)
        创建一个新的实例。
        参数
        menu - 是否应存在菜单栏
        status - 状态栏是否应该存在
        toolbar - 是否应存在工具栏
        resizable - 弹出窗口是否应该调整大小

    • 方法详细信息

      • hasMenu

        public final boolean hasMenu​()
        返回菜单栏是否存在。
        结果
        如果菜单栏应该存在，则为true

      • hasStatus

        public final boolean hasStatus​()
        返回状态栏是否应该存在。
        结果
        如果状态栏应该存在，则为true

      • hasToolbar

        public final boolean hasToolbar​()
        返回是否存在工具栏。
        结果
        如果工具栏应存在，则为true

      • isResizable

        public final boolean isResizable​()
        返回弹出窗口是否应该调整大小。
        结果
        如果弹出窗口应该可调整大小，则为true
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PromptData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class PromptData

  • java.lang.Object
    • javafx.scene.web.PromptData

  • public final class PromptData
extends Object
    这个类封装了传递给JavaScript prompt()函数的数据：一个消息和一个默认值。 实例被传递到prompt在所注册的处理程序WebEngine使用WebEngine.setPromptHandler(javafx.util.Callback<javafx.scene.web.PromptData, java.lang.String>)方法。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WebEngine ， WebEngine.setPromptHandler(javafx.util.Callback<javafx.scene.web.PromptData, java.lang.String>)

    • 构造方法摘要

      构造方法
      Constructor 描述
      PromptData​(String message, String defaultValue)
      创建一个新的实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getDefaultValue​()
      返回此数据对象携带的默认值。
      String getMessage​()
      返回此数据对象携带的消息。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PromptData

        public PromptData​(String message,
                  String defaultValue)
        创建一个新的实例。
        参数
        message - 此数据对象携带的消息
        defaultValue - 此数据对象携带的默认值

    • 方法详细信息

      • getMessage

        public final String getMessage​()
        返回此数据对象携带的消息。
        结果
        消息

      • getDefaultValue

        public final String getDefaultValue​()
        返回此数据对象携带的默认值。
        结果
        the default value
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.scene.web (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.scene.web

  • Packages that use javafx.scene.web
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
  • Classes in javafx.scene.web used by javafx.scene.web
    Class 描述
    HTMLEditor
    允许用户编辑文本并将样式应用于此文本的控件。
    HTMLEditorSkin.Command
    表示可以传递到HTMLEditor Web引擎的命令。
    PopupFeatures
    此类描述了由JavaScript window.open函数指定的Web弹出窗口的功能。
    PromptData
    这个类封装了传递给JavaScript prompt()函数的数据：一个消息和一个默认值。
    WebEngine
    WebEngine是一个能够一次管理一个网页的非可视对象。
    WebErrorEvent
    一个事件指示一个WebEngine错误。
    WebEvent
    WebEvent实例被传递到EventHandler通过在网页上运行的JavaScript注册WebEngine 。
    WebHistory
    WebHistory类表示与WebEngine实例相关联的会话历史。
    WebHistory.Entry
    Entry类表示会话历史中的单个条目。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


WebEngine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class WebEngine

  • java.lang.Object
    • javafx.scene.web.WebEngine

  • public final class WebEngine
extends Object
    WebEngine是一个能够一次管理一个网页的非视觉对象。 它加载网页，创建他们的文档模型，根据需要应用样式，并在页面上运行JavaScript。 它提供对当前页面的文档模型的访问，并实现Java应用程序和页面的JavaScript代码之间的双向通信。

    加载网页

    WebEngine类提供了两种将内容加载到WebEngine对象中的方法：

    • 从使用load(java.lang.String)方法的任意URL。 此方法使用java.net包进行网络访问和协议处理。
    • 从使用loadContent(java.lang.String, java.lang.String)和loadContent(java.lang.String)方法的内存中的字符串。

    加载总是发生在后台线程上。 调度后台作业后立即启动加载的方法。 要跟踪进度和/或取消作业，请使用getLoadWorker()方法中提供的Worker实例。

    以下示例在加载成功完成时更改了阶段标题：

       import javafx.concurrent.Worker.State; final Stage stage; webEngine.getLoadWorker().stateProperty().addListener( new ChangeListener<State>() { public void changed(ObservableValue ov, State oldState, State newState) { if (newState == State.SUCCEEDED) { stage.setTitle(webEngine.getLocation()); } } }); webEngine.load("http://javafx.com");

    用户界面回调

    可以向WebEngine对象注册多个用户界面回调。 当在页面上运行的脚本请求执行用户界面操作时，例如打开弹出窗口或更改状态文本，这些回调将被调用。 一个WebEngine对象不能在内部处理这样的请求，所以它将请求传递给相应的回调。 如果没有为特定操作定义回调，则会默认忽略该请求。

    下表显示了JavaScript用户界面方法和属性及其对应的WebEngine回调：

    JavaScript Callback Table JavaScript method/property WebEngine callback window.alert() onAlert window.confirm() confirmHandler window.open() createPopupHandler window.open() and
    window.close() onVisibilityChanged window.prompt() promptHandler Setting window.status onStatusChanged Setting any of the following:
    window.innerWidth, window.innerHeight,
    window.outerWidth, window.outerHeight,
    window.screenX, window.screenY,
    window.screenLeft, window.screenTop onResized

    以下示例显示了调整浏览器窗口大小的回调：

       Stage stage; webEngine.setOnResized( new EventHandler<WebEvent<Rectangle2D>>() { public void handle(WebEvent<Rectangle2D> ev) { Rectangle2D r = ev.getData(); stage.setWidth(r.getWidth()); stage.setHeight(r.getHeight()); } });

    访问文档模型

    WebEngine对象为其网页创建和管理文档对象模型（DOM）。 可以使用Java DOM Core类来访问和修改该模型。 getDocument()方法提供对模型根的访问。 此外，还支持DOM事件规范来定义Java代码中的事件处理程序。

    以下示例将Java事件侦听器附加到网页的元素。 单击该元素将导致应用程序退出：

       EventListener listener = new EventListener() { public void handleEvent(Event ev) { Platform.exit(); } }; Document doc = webEngine.getDocument(); Element el = doc.getElementById("exit-app"); ((EventTarget) el).addEventListener("click", listener, false);

    评估JavaScript表达式

    可以使用executeScript(java.lang.String)方法在当前页面的上下文中执行任意JavaScript代码。 例如：

       webEngine.executeScript("history.back()");

    执行结果将返回给调用者，如下一节所述。

    将JavaScript值映射到Java对象

    JavaScript值使用明显的Java类来表示：null变为Java null; 一个布尔变成了一个java.lang.Boolean ; 一个字符串变成了一个java.lang.String 。 一个数字可以是java.lang.Double或一个java.lang.Integer ，取决于。 未定义的值映射到值为"undefined"的特定唯一String对象。

    如果结果是一个JavaScript对象，它将被包装为JSObject类的一个实例。 （作为一个特殊情况，如果JavaScript对象是JavaRuntimeObject中讨论的JavaRuntimeObject ，那么将提取原始的Java对象。） JSObject类是一种代理，可以访问其底层JavaScript对象的方法和属性。 最常用的JSObject方法是getMember （读取命名属性）， setMember （用于设置或定义属性）和call （以调用函数值属性）。

    DOM Node被映射到一个对象，它们都扩展了JSObject并实现了相应的DOM接口。 要获得一个JSObject对象为Node只是做一个演员：

      JSObject jdoc = (JSObject) webEngine.getDocument();

    在某些情况下，上下文提供了指导转换的特定Java类型。 例如，如果从JavaScript表达式设置Java String字段，则JavaScript值将转换为字符串。

    将Java对象映射到JavaScript值

    JSObject方法setMember和call的参数将Java对象传递给JavaScript环境。 这大致上述的JavaScript到Java映射的逆：爪哇String ， Number ，或Boolean对象被转换到明显的JavaScript值。 将一个JSObject对象转换为原始的包装JavaScript对象。 否则将创建一个JavaRuntimeObject 。 这是作为Java对象的代理的JavaScript对象，因为JavaRuntimeObject访问属性导致访问具有相同名称的Java字段或方法。

    需要注意的是，Java对象使用结合JSObject.setMember ， JSObject.setSlot ，并JSObject.call使用弱引用来实现。 这意味着Java对象可以被垃圾回收，导致对JavaScript对象的后续访问不起作用。

    从JavaScript回调Java

    JSObject.setMember方法有助于将JavaScript的上调从Java转换为Java代码，如以下示例所示。 Java代码建立了一个名为app的新JavaScript对象。 该对象有一个公共成员，方法exit 。

       public class JavaApplication { public void exit() { Platform.exit(); } } ... JavaApplication javaApp = new JavaApplication(); JSObject window = (JSObject) webEngine.executeScript("window"); window.setMember("app", javaApp);
    然后，您可以从HTML页面引用对象和方法：
       <a href="" onclick="app.exit()">Click here to exit application</a>

    当用户点击链接时，应用程序关闭。

    请注意，在上述示例中，应用程序保留对JavaApplication实例的引用。 这是JavaScript的回调执行所需方法所必需的。

    在以下示例中，该应用程序不包含对Java对象的引用：

       JSObject window = (JSObject) webEngine.executeScript("window"); window.setMember("app", new JavaApplication());

    在这种情况下，由于属性值是本地对象， "new JavaApplication()"该值可能会在下一个GC循环中被垃圾回收。

    当用户点击链接时，它不保证执行回调方法exit 。

    如果有多个具有给定名称的Java方法，那么引擎将选择一个与调用中的参数数相匹配的方法。 （Varargs不处理。）如果有多个具有正确数量的参数，则选择未指定的。

    您可以通过在“扩展方法名称”中列出参数类型来选择特定的重载方法，其格式为"method_name(param_type1,...,param_typen)" 。 通常你会写JavaScript表达式：

      receiver["method_name(param_type1,...,param_typeN)"](arg1,...,argN)

    Java类和方法必须都被声明为public。

    将应用程序部署为模块

    如果传递给JavaScript的任何Java类都在命名模块中，那么javafx.web模块必须能够反映javafx.web 。 如果模块opens将包含的包至少为javafx.web模块，则可以反射访问类。 否则，将不会调用该方法，并且不会产生错误或警告。

    例如，如果com.foo.MyClass在foo.app模块中，则module-info.java可能如下所示：

      module foo.app { opens com.foo to javafx.web; }

    或者，如果模块exports无条件地包含包装，则可以反射地访问类。

    穿线

    必须仅从JavaFX应用程序线程创建和访问WebEngine对象。 此规则也适用于从WebEngine对象获取的任何DOM和JavaScript对象。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<Callback<String,Boolean>> confirmHandler
      JavaScript confirm处理程序属性。
      ObjectProperty<Callback<PopupFeatures,WebEngine>> createPopupHandler
      JavaScript弹出窗口处理程序属性。
      ReadOnlyObjectProperty<Document> document
      当前网页的文档对象。
      BooleanProperty javaScriptEnabled
      指定是否启用JavaScript执行。
      ReadOnlyStringProperty location
      当前网页的URL。
      ObjectProperty<EventHandler<WebEvent<String>>> onAlert
      JavaScript alert处理程序属性。
      ObjectProperty<EventHandler<WebErrorEvent>> onError
      当发生错误时调用事件处理程序。
      ObjectProperty<EventHandler<WebEvent<Rectangle2D>>> onResized
      JavaScript窗口调整大小处理程序属性。
      ObjectProperty<EventHandler<WebEvent<String>>> onStatusChanged
      JavaScript状态处理程序属性。
      ObjectProperty<EventHandler<WebEvent<Boolean>>> onVisibilityChanged
      JavaScript窗口可见性处理器属性。
      ObjectProperty<Callback<PromptData,String>> promptHandler
      JavaScript prompt处理程序属性。
      ReadOnlyStringProperty title
      当前网页的标题。
      StringProperty userAgent
      指定用户代理ID字符串。
      ObjectProperty<File> userDataDirectory
      指定此 WebEngine用于存储本地用户数据的目录。
      StringProperty userStyleSheetLocation
      用户样式表的位置为字符串URL。

    • 构造方法摘要

      构造方法
      Constructor 描述
      WebEngine​()
      创建一个新的引擎。
      WebEngine​(String url)
      创建一个新的引擎并加载一个网页。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<Callback<String,Boolean>> confirmHandlerProperty​()
      JavaScript confirm处理程序属性。
      ObjectProperty<Callback<PopupFeatures,WebEngine>> createPopupHandlerProperty​()
      JavaScript弹出窗口处理程序属性。
      ReadOnlyObjectProperty<Document> documentProperty​()
      当前网页的文档对象。
      Object executeScript​(String script)
      在当前页面的上下文中执行脚本。
      Callback<String,Boolean> getConfirmHandler​()
      获取属性confirmHandler的值。
      Callback<PopupFeatures,WebEngine> getCreatePopupHandler​()
      获取属性createPopupHandler的值。
      Document getDocument​()
      获取属性文档的值。
      WebHistory getHistory​()
      返回会话历史记录对象。
      Worker<Void> getLoadWorker​()
      返回可用于跟踪加载进度的Worker对象。
      String getLocation​()
      获取属性位置的值。
      EventHandler<WebEvent<String>> getOnAlert​()
      获取属性onAlert的值。
      EventHandler<WebErrorEvent> getOnError​()
      获取属性onError的值。
      EventHandler<WebEvent<Rectangle2D>> getOnResized​()
      获取属性onResized的值。
      EventHandler<WebEvent<String>> getOnStatusChanged​()
      获取属性onStatusChanged的值。
      EventHandler<WebEvent<Boolean>> getOnVisibilityChanged​()
      获取属性onVisibilityChanged的值。
      Callback<PromptData,String> getPromptHandler​()
      获取属性promptHandler的值。
      String getTitle​()
      获取属性标题的值。
      String getUserAgent​()
      获取属性userAgent的值。
      File getUserDataDirectory​()
      获取属性userDataDirectory的值。
      String getUserStyleSheetLocation​()
      获取属性userStyleSheetLocation的值。
      boolean isJavaScriptEnabled​()
      获取属性javaScriptEnabled的值。
      BooleanProperty javaScriptEnabledProperty​()
      指定是否启用JavaScript执行。
      void load​(String url)
      将网页加载到此引擎中。
      void loadContent​(String content)
      直接加载给定的HTML内容。
      void loadContent​(String content, String contentType)
      直接载入给定的内容。
      ReadOnlyStringProperty locationProperty​()
      当前网页的URL。
      ObjectProperty<EventHandler<WebEvent<String>>> onAlertProperty​()
      JavaScript alert处理程序属性。
      ObjectProperty<EventHandler<WebErrorEvent>> onErrorProperty​()
      当发生错误时调用事件处理程序。
      ObjectProperty<EventHandler<WebEvent<Rectangle2D>>> onResizedProperty​()
      JavaScript窗口调整大小处理程序属性。
      ObjectProperty<EventHandler<WebEvent<String>>> onStatusChangedProperty​()
      JavaScript状态处理程序属性。
      ObjectProperty<EventHandler<WebEvent<Boolean>>> onVisibilityChangedProperty​()
      JavaScript窗口可见性处理器属性。
      void print​(PrinterJob job)
      使用给定的打印机作业打印当前网页。
      ObjectProperty<Callback<PromptData,String>> promptHandlerProperty​()
      JavaScript prompt处理程序属性。
      void reload​()
      重新加载当前页面，无论是从URL加载还是直接从 loadContent方法中的一个字符串加载。
      void setConfirmHandler​(Callback<String,Boolean> handler)
      设置属性confirmHandler的值。
      void setCreatePopupHandler​(Callback<PopupFeatures,WebEngine> handler)
      设置属性createPopupHandler的值。
      void setJavaScriptEnabled​(boolean value)
      设置属性javaScriptEnabled的值。
      void setOnAlert​(EventHandler<WebEvent<String>> handler)
      设置属性onAlert的值。
      void setOnError​(EventHandler<WebErrorEvent> handler)
      设置属性onError的值。
      void setOnResized​(EventHandler<WebEvent<Rectangle2D>> handler)
      设置属性onResized的值。
      void setOnStatusChanged​(EventHandler<WebEvent<String>> handler)
      设置属性onStatusChanged的值。
      void setOnVisibilityChanged​(EventHandler<WebEvent<Boolean>> handler)
      设置属性onVisibilityChanged的值。
      void setPromptHandler​(Callback<PromptData,String> handler)
      设置属性promptHandler的值。
      void setUserAgent​(String value)
      设置属性userAgent的值。
      void setUserDataDirectory​(File value)
      设置属性userDataDirectory的值。
      void setUserStyleSheetLocation​(String value)
      设置属性userStyleSheetLocation的值。
      ReadOnlyStringProperty titleProperty​()
      当前网页的标题。
      StringProperty userAgentProperty​()
      指定用户代理ID字符串。
      ObjectProperty<File> userDataDirectoryProperty​()
      指定此 WebEngine用于存储本地用户数据的目录。
      StringProperty userStyleSheetLocationProperty​()
      用户样式表的位置为字符串URL。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • document

        public final ReadOnlyObjectProperty<Document> documentProperty
        当前网页的文档对象。 如果网页加载失败，则值为null 。
        另请参见：
        getDocument()

      • location

        public final ReadOnlyStringProperty locationProperty
        当前网页的URL。 如果当前页面没有URL，则该值为空字符串。
        另请参见：
        getLocation()

      • title

        public final ReadOnlyStringProperty titleProperty
        当前网页的标题。 如果当前页面没有标题，则值为null 。
        另请参见：
        getTitle()

      • javaScriptEnabled

        public final BooleanProperty javaScriptEnabledProperty
        指定是否启用JavaScript执行。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        isJavaScriptEnabled() ， setJavaScriptEnabled(boolean)

      • userStyleSheetLocation

        public final StringProperty userStyleSheetLocationProperty
        用户样式表的位置为字符串URL。

        这应该是一个本地URL，即无论是'data:' ， 'file:' ，或'jar:' 。 出于安全考虑，不允许使用远程URL。

        Default value:
        空值
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getUserStyleSheetLocation() ， setUserStyleSheetLocation(String)

      • userDataDirectory

        public final ObjectProperty<File> userDataDirectoryProperty
        指定此WebEngine用于存储本地用户数据的目录。

        如果此属性的值不是null ，则WebEngine将尝试将本地用户数据存储在相应的目录中。 如果此属性的值为null ，则WebEngine将尝试将本地用户数据存储在自动选择的系统相关用户和应用程序特定目录中。

        当WebEngine第一次即将开始加载网页或执行脚本时，它会检查它是否可以实际使用此属性指定的目录。 如果由于某种原因检查失败，则WebEngine调用WebEngine.onError事件处理程序（如果有），描述原因的WebErrorEvent 。 如果调用的事件处理程序修改了userDataDirectory属性，那么WebEngine在处理程序返回时立即重试新值。 如果处理程序不修改userDataDirectory属性（这是默认值），则WebEngine不会继续，而没有本地用户数据。

        一旦WebEngine开始加载网页或执行脚本，对此属性的更改对WebEngine存储或将存储本地用户数据的位置没有影响。

        目前，此属性指定的目录仅用于存储支持window.localStorage对象的数据。 将来可以添加更多类型的数据。

        Default value:
        null
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getUserDataDirectory() ， setUserDataDirectory(File)

      • userAgent

        public final StringProperty userAgentProperty
        指定用户代理ID字符串。 该字符串是User-Agent HTTP标头的值。
        Default value:
        系统依赖
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getUserAgent() ， setUserAgent(String)

      • onAlert

        public final ObjectProperty<EventHandler<WebEvent<String>>> onAlertProperty
        JavaScript alert处理程序属性。 当在网页上运行的脚本调用alert函数时，将调用此处理程序。
        另请参见：
        getOnAlert() ， setOnAlert(EventHandler)

      • onStatusChanged

        public final ObjectProperty<EventHandler<WebEvent<String>>> onStatusChangedProperty
        JavaScript状态处理程序属性。 当在网页上运行的脚本设置window.status属性时，调用此处理程序。
        另请参见：
        getOnStatusChanged() ， setOnStatusChanged(EventHandler)

      • onResized

        public final ObjectProperty<EventHandler<WebEvent<Rectangle2D>>> onResizedProperty
        JavaScript窗口调整大小处理程序属性。 当在网页上运行的脚本移动或调整window对象大小时，将调用此处理程序。
        另请参见：
        getOnResized() ， setOnResized(EventHandler)

      • onVisibilityChanged

        public final ObjectProperty<EventHandler<WebEvent<Boolean>>> onVisibilityChangedProperty
        JavaScript窗口可见性处理器属性。 当在Web页面上运行的脚本改变window对象的可见性时，将调用此处理程序。
        另请参见：
        getOnVisibilityChanged() ， setOnVisibilityChanged(EventHandler)

      • createPopupHandler

        public final ObjectProperty<Callback<PopupFeatures,WebEngine>> createPopupHandlerProperty
        JavaScript弹出窗口处理程序属性。 当在网页上运行的脚本请求创建弹出窗口时，将调用此处理程序。

        为了满足此请求，处理程序可以创建新的WebEngine ，附加可见性处理程序和可选的大小调整处理程序，并返回新创建的引擎。 要阻止弹出窗口，处理程序应返回null 。

        默认情况下，安装了一个弹出窗口处理程序，可在此WebEngine中打开弹出窗口。

        另请参见：
        getCreatePopupHandler() ， setCreatePopupHandler(Callback)

      • confirmHandler

        public final ObjectProperty<Callback<String,Boolean>> confirmHandlerProperty
        JavaScript confirm处理程序属性。 当在网页上运行的脚本调用confirm函数时，调用此处理程序。

        一个实现可能会显示一个对话框，带有和否选项，并返回用户的选择。

        另请参见：
        getConfirmHandler() ， setConfirmHandler(Callback)

      • promptHandler

        public final ObjectProperty<Callback<PromptData,String>> promptHandlerProperty
        JavaScript prompt处理程序属性。 当在网页上运行的脚本调用prompt函数时，调用此处理程序。

        实现可能会显示一个带有文本字段的对话框，并返回用户的输入。

        另请参见：
        getPromptHandler() ， setPromptHandler(Callback)

      • onError

        public final ObjectProperty<EventHandler<WebErrorEvent>> onErrorProperty
        当发生错误时调用事件处理程序。
        Default value:
        null
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnError() ， setOnError(EventHandler)

    • 构造方法详细信息

      • WebEngine

        public WebEngine​()
        创建一个新的引擎。

      • WebEngine

        public WebEngine​(String url)
        创建一个新的引擎并加载一个网页。
        参数
        url - 要加载的网页的URL

    • 方法详细信息

      • getLoadWorker

        public final Worker<Void> getLoadWorker​()
        返回可用于跟踪加载进度的Worker对象。
        结果
        Worker对象

      • getDocument

        public final Document getDocument​()
        获取属性文档的值。
        Property description:
        当前网页的文档对象。 如果网页加载失败，则值为null 。

      • documentProperty

        public final ReadOnlyObjectProperty<Document> documentProperty​()
        当前网页的文档对象。 如果网页加载失败，则值为null 。
        另请参见：
        getDocument()

      • getLocation

        public final String getLocation​()
        获取属性位置的值。
        Property description:
        当前网页的URL。 如果当前页面没有URL，则该值为空字符串。

      • locationProperty

        public final ReadOnlyStringProperty locationProperty​()
        当前网页的URL。 如果当前页面没有URL，则该值为空字符串。
        另请参见：
        getLocation()

      • getTitle

        public final String getTitle​()
        获取属性标题的值。
        Property description:
        当前网页的标题。 如果当前页面没有标题，则值为null 。

      • titleProperty

        public final ReadOnlyStringProperty titleProperty​()
        当前网页的标题。 如果当前页面没有标题，则值为null 。
        另请参见：
        getTitle()

      • setJavaScriptEnabled

        public final void setJavaScriptEnabled​(boolean value)
        设置属性javaScriptEnabled的值。
        Property description:
        指定是否启用JavaScript执行。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2

      • isJavaScriptEnabled

        public final boolean isJavaScriptEnabled​()
        获取属性javaScriptEnabled的值。
        Property description:
        指定是否启用JavaScript执行。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2

      • javaScriptEnabledProperty

        public final BooleanProperty javaScriptEnabledProperty​()
        指定是否启用JavaScript执行。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        isJavaScriptEnabled() ， setJavaScriptEnabled(boolean)

      • setUserStyleSheetLocation

        public final void setUserStyleSheetLocation​(String value)
        设置属性userStyleSheetLocation的值。
        Property description:
        用户样式表的位置为字符串URL。

        这应该是一个本地URL，即无论是'data:' ， 'file:' ，或'jar:' 。 出于安全考虑，不允许使用远程URL。

        Default value:
        空值
        从以下版本开始：
        JavaFX 2.2

      • getUserStyleSheetLocation

        public final String getUserStyleSheetLocation​()
        获取属性userStyleSheetLocation的值。
        Property description:
        用户样式表的位置为字符串URL。

        这应该是一个本地URL，即无论是'data:' ， 'file:' ，或'jar:' 。 出于安全考虑，不允许使用远程URL。

        Default value:
        空值
        从以下版本开始：
        JavaFX 2.2

      • userStyleSheetLocationProperty

        public final StringProperty userStyleSheetLocationProperty​()
        用户样式表的位置为字符串URL。

        这应该是一个本地URL，即无论是'data:' ， 'file:' ，或'jar:' 。 出于安全考虑，不允许使用远程URL。

        Default value:
        空值
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getUserStyleSheetLocation() ， setUserStyleSheetLocation(String)

      • getUserDataDirectory

        public final File getUserDataDirectory​()
        获取属性userDataDirectory的值。
        Property description:
        指定此WebEngine要用于存储本地用户数据的目录。

        如果此属性的值不是null ，则WebEngine将尝试将本地用户数据存储在相应的目录中。 如果此属性的值为null ，则WebEngine将尝试将本地用户数据存储在自动选择的系统相关用户和应用程序特定目录中。

        当WebEngine即将开始加载网页或第一次执行脚本时，它会检查它是否可以实际使用此属性指定的目录。 如果由于某些原因检查失败，则WebEngine调用WebEngine.onError事件处理程序（如果有），描述原因的WebErrorEvent 。 如果调用的事件处理程序修改了userDataDirectory属性，那么WebEngine在处理程序返回时立即重试新值。 如果处理程序不修改userDataDirectory属性（这是默认值），则WebEngine将WebEngine继续使用本地用户数据。

        一旦WebEngine已经开始加载网页或执行脚本，对此属性的更改对WebEngine存储或将存储本地用户数据的位置没有影响。

        目前，此属性指定的目录仅用于存储支持window.localStorage对象的数据。 将来可以添加更多类型的数据。

        Default value:
        null
        从以下版本开始：
        JavaFX 8.0

      • setUserDataDirectory

        public final void setUserDataDirectory​(File value)
        设置属性userDataDirectory的值。
        Property description:
        指定此WebEngine用于存储本地用户数据的目录。

        如果此属性的值不是null ，则WebEngine将尝试将本地用户数据存储在相应的目录中。 如果此属性的值为null ，则WebEngine将尝试将本地用户数据存储在自动选择的系统相关的用户和应用程序特定目录中。

        当WebEngine第一次即将开始加载网页或执行脚本时，它会检查它是否可以实际使用此属性指定的目录。 如果由于某种原因检查失败，则WebEngine调用WebEngine.onError事件处理程序（如果有），描述原因的WebErrorEvent 。 如果调用的事件处理程序修改了userDataDirectory属性，那么WebEngine在处理程序返回时立即重试新值。 如果处理程序不修改userDataDirectory属性（这是默认值），则WebEngine不会继续，而没有本地用户数据。

        一旦WebEngine开始加载网页或执行脚本，对此属性的更改对WebEngine存储或将存储本地用户数据的位置没有影响。

        目前，此属性指定的目录仅用于存储支持window.localStorage对象的数据。 将来可以添加更多类型的数据。

        Default value:
        null
        从以下版本开始：
        JavaFX 8.0

      • userDataDirectoryProperty

        public final ObjectProperty<File> userDataDirectoryProperty​()
        指定此WebEngine要用于存储本地用户数据的目录。

        如果此属性的值不是null ，则WebEngine将尝试将本地用户数据存储在相应的目录中。 如果此属性的值为null ，则WebEngine将尝试将本地用户数据存储在自动选择的系统相关用户和应用程序特定目录中。

        当WebEngine第一次即将开始加载网页或执行脚本时，它会检查它是否可以实际使用此属性指定的目录。 如果由于某种原因检查失败，则WebEngine调用WebEngine.onError事件处理程序（如果有），描述原因的WebErrorEvent 。 如果调用的事件处理程序修改了userDataDirectory属性，那么WebEngine在处理程序返回时立即重试新值。 如果处理程序不修改userDataDirectory属性（这是默认值），则WebEngine将WebEngine继续，而没有本地用户数据。

        一旦WebEngine开始加载网页或执行脚本，对此属性的更改对WebEngine存储或将存储本地用户数据的位置没有影响。

        目前，此属性指定的目录仅用于存储支持window.localStorage对象的数据。 将来可以添加更多类型的数据。

        Default value:
        null
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getUserDataDirectory() ， setUserDataDirectory(File)

      • setUserAgent

        public final void setUserAgent​(String value)
        设置属性userAgent的值。
        Property description:
        指定用户代理ID字符串。 该字符串是User-Agent HTTP头的值。
        Default value:
        系统依赖
        从以下版本开始：
        JavaFX 8.0

      • getUserAgent

        public final String getUserAgent​()
        获取属性userAgent的值。
        Property description:
        指定用户代理ID字符串。 此字符串是User-Agent HTTP标头的值。
        Default value:
        系统依赖
        从以下版本开始：
        JavaFX 8.0

      • userAgentProperty

        public final StringProperty userAgentProperty​()
        指定用户代理ID字符串。 该字符串是User-Agent HTTP标头的值。
        Default value:
        系统依赖
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getUserAgent() ， setUserAgent(String)

      • getOnAlert

        public final EventHandler<WebEvent<String>> getOnAlert​()
        获取属性onAlert的值。
        Property description:
        JavaScript alert处理程序属性。 当在网页上运行的脚本调用alert函数时，调用此处理程序。

      • setOnAlert

        public final void setOnAlert​(EventHandler<WebEvent<String>> handler)
        设置属性onAlert的值。
        Property description:
        JavaScript alert处理程序属性。 当在网页上运行的脚本调用alert函数时，调用此处理程序。

      • onAlertProperty

        public final ObjectProperty<EventHandler<WebEvent<String>>> onAlertProperty​()
        JavaScript alert处理程序属性。 当在网页上运行的脚本调用alert函数时，将调用此处理程序。
        另请参见：
        getOnAlert() ， setOnAlert(EventHandler)

      • getOnStatusChanged

        public final EventHandler<WebEvent<String>> getOnStatusChanged​()
        获取属性onStatusChanged的值。
        Property description:
        JavaScript状态处理程序属性。 当在网页上运行的脚本设置window.status属性时，调用此处理程序。

      • setOnStatusChanged

        public final void setOnStatusChanged​(EventHandler<WebEvent<String>> handler)
        设置属性onStatusChanged的值。
        Property description:
        JavaScript状态处理程序属性。 当在网页上运行的脚本设置window.status属性时，调用此处理程序。

      • onStatusChangedProperty

        public final ObjectProperty<EventHandler<WebEvent<String>>> onStatusChangedProperty​()
        JavaScript状态处理程序属性。 当在网页上运行的脚本设置window.status属性时，调用此处理程序。
        另请参见：
        getOnStatusChanged() ， setOnStatusChanged(EventHandler)

      • getOnResized

        public final EventHandler<WebEvent<Rectangle2D>> getOnResized​()
        获取属性onResized的值。
        Property description:
        JavaScript窗口调整大小处理程序属性。 当在网页上运行的脚本移动或调整window对象大小时，将调用此处理程序。

      • setOnResized

        public final void setOnResized​(EventHandler<WebEvent<Rectangle2D>> handler)
        设置属性onResized的值。
        Property description:
        JavaScript窗口调整大小处理程序属性。 当在网页上运行的脚本移动或调整window对象大小时，将调用此处理程序。

      • onResizedProperty

        public final ObjectProperty<EventHandler<WebEvent<Rectangle2D>>> onResizedProperty​()
        JavaScript窗口调整大小处理程序属性。 当在网页上运行的脚本移动或调整window对象大小时，将调用此处理程序。
        另请参见：
        getOnResized() ， setOnResized(EventHandler)

      • getOnVisibilityChanged

        public final EventHandler<WebEvent<Boolean>> getOnVisibilityChanged​()
        获取属性onVisibilityChanged的值。
        Property description:
        JavaScript窗口可见性处理器属性。 当在网页上运行的脚本改变window对象的可见性时，调用此处理程序。

      • setOnVisibilityChanged

        public final void setOnVisibilityChanged​(EventHandler<WebEvent<Boolean>> handler)
        设置属性onVisibilityChanged的值。
        Property description:
        JavaScript窗口可见性处理器属性。 当在网页上运行的脚本改变window对象的可见性时，将调用此处理程序。

      • onVisibilityChangedProperty

        public final ObjectProperty<EventHandler<WebEvent<Boolean>>> onVisibilityChangedProperty​()
        JavaScript窗口可见性处理器属性。 当在网页上运行的脚本改变window对象的可见性时，将调用此处理程序。
        另请参见：
        getOnVisibilityChanged() ， setOnVisibilityChanged(EventHandler)

      • getCreatePopupHandler

        public final Callback<PopupFeatures,WebEngine> getCreatePopupHandler​()
        获取属性createPopupHandler的值。
        Property description:
        JavaScript弹出窗口处理程序属性。 当在网页上运行的脚本请求创建弹出窗口时，将调用此处理程序。

        为了满足此请求，处理程序可以创建一个新的WebEngine ，附加可见性处理程序和可选的大小调整处理程序，并返回新创建的引擎。 要阻止弹出窗口，处理程序应返回null 。

        默认情况下，安装了一个弹出式处理程序，可在此WebEngine中打开弹出窗口。

      • setCreatePopupHandler

        public final void setCreatePopupHandler​(Callback<PopupFeatures,WebEngine> handler)
        设置属性createPopupHandler的值。
        Property description:
        JavaScript弹出窗口处理程序属性。 当在网页上运行的脚本请求创建弹出窗口时，将调用此处理程序。

        要满足此请求，处理程序可以创建新的WebEngine ，附加可见性处理程序和可选的大小调整处理程序，并返回新创建的引擎。 要阻止弹出窗口，处理程序应返回null 。

        默认情况下，安装了一个弹出窗口处理程序，可在此WebEngine中打开弹出窗口。

      • createPopupHandlerProperty

        public final ObjectProperty<Callback<PopupFeatures,WebEngine>> createPopupHandlerProperty​()
        JavaScript弹出窗口处理程序属性。 当在网页上运行的脚本请求创建弹出窗口时，将调用此处理程序。

        为了满足此请求，处理程序可以创建新的WebEngine ，附加可见性处理程序和可选的大小调整处理程序，并返回新创建的引擎。 要阻止弹出窗口，处理程序应返回null 。

        默认情况下，安装了一个弹出窗口处理程序，可在此WebEngine中打开弹出窗口。

        另请参见：
        getCreatePopupHandler() ， setCreatePopupHandler(Callback)

      • getConfirmHandler

        public final Callback<String,Boolean> getConfirmHandler​()
        获取属性confirmHandler的值。
        Property description:
        JavaScript confirm处理程序属性。 当在网页上运行的脚本调用confirm函数时，调用此处理程序。

        一个实现可能会显示一个对话框，带有和否选项，并返回用户的选择。

      • setConfirmHandler

        public final void setConfirmHandler​(Callback<String,Boolean> handler)
        设置属性confirmHandler的值。
        Property description:
        JavaScript confirm处理程序属性。 当在网页上运行的脚本调用confirm函数时，调用此处理程序。

        一个实现可能会显示一个对话框，带有和否选项，并返回用户的选择。

      • confirmHandlerProperty

        public final ObjectProperty<Callback<String,Boolean>> confirmHandlerProperty​()
        JavaScript confirm处理程序属性。 当在网页上运行的脚本调用confirm函数时，调用此处理程序。

        一个实现可能会显示一个对话框，带有和否选项，并返回用户的选择。

        另请参见：
        getConfirmHandler() ， setConfirmHandler(Callback)

      • getPromptHandler

        public final Callback<PromptData,String> getPromptHandler​()
        获取属性promptHandler的值。
        Property description:
        JavaScript prompt处理程序属性。 当在网页上运行的脚本调用prompt函数时，调用此处理程序。

        实现可能会显示一个带有文本字段的对话框，并返回用户的输入。

      • setPromptHandler

        public final void setPromptHandler​(Callback<PromptData,String> handler)
        设置属性promptHandler的值。
        Property description:
        JavaScript prompt处理程序属性。 当在网页上运行的脚本调用prompt函数时，调用此处理程序。

        实现可能会显示一个带有文本字段的对话框，并返回用户的输入。

      • promptHandlerProperty

        public final ObjectProperty<Callback<PromptData,String>> promptHandlerProperty​()
        JavaScript prompt处理程序属性。 当在网页上运行的脚本调用prompt函数时，调用此处理程序。

        实现可能会显示一个带有文本字段的对话框，并返回用户的输入。

        另请参见：
        getPromptHandler() ， setPromptHandler(Callback)

      • getOnError

        public final EventHandler<WebErrorEvent> getOnError​()
        获取属性onError的值。
        Property description:
        当发生错误时调用事件处理程序。
        Default value:
        null
        从以下版本开始：
        JavaFX 8.0

      • setOnError

        public final void setOnError​(EventHandler<WebErrorEvent> handler)
        设置属性onError的值。
        Property description:
        当发生错误时调用事件处理程序。
        Default value:
        null
        从以下版本开始：
        JavaFX 8.0

      • onErrorProperty

        public final ObjectProperty<EventHandler<WebErrorEvent>> onErrorProperty​()
        当发生错误时调用事件处理程序。
        Default value:
        null
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getOnError() ， setOnError(EventHandler)

      • load

        public void load​(String url)
        将网页加载到此引擎中。 此方法启动异步加载并立即返回。
        参数
        url - 要加载的网页的URL

      • loadContent

        public void loadContent​(String content)
        直接加载给定的HTML内容。 当您在内存中组合HTML字符串或从某些无法通过URL访问的系统加载时，此方法非常有用（例如，HTML文本可能来自数据库）。 和load(String)一样 ，这个方法是异步的。
        参数
        content - 要加载的HTML内容

      • loadContent

        public void loadContent​(String content,
                        String contentType)
        直接载入给定的内容。 当您将内容组合在内存中或从某些无法通过URL访问的系统加载（例如，SVG文本可能来自数据库）时，此方法很有用。 与load(String)一样 ，此方法是异步的。 此方法还允许您指定要加载的字符串的内容类型，因此可以选择性地支持除了HTML之外的其他类型。
        参数
        content - 要加载的HTML内容
        contentType - 要加载的内容类型

      • reload

        public void reload​()
        重新加载当前页面，无论是从URL加载还是直接从 loadContent方法之一的字符串加载。

      • getHistory

        public WebHistory getHistory​()
        返回会话历史记录对象。
        结果
        历史对象
        从以下版本开始：
        JavaFX 2.2

      • executeScript

        public Object executeScript​(String script)
        在当前页面的上下文中执行脚本。
        参数
        script - 脚本
        结果
        执行结果，使用以下规则转换为Java对象：
        • JavaScript Int32转换为java.lang.Integer
        • 其他JavaScript编号至java.lang.Double
        • JavaScript字符串到java.lang.String
        • JavaScript布尔值为java.lang.Boolean
        • JavaScript null至null
        • 大多数JavaScript对象被打包为netscape.javascript.JSObject
        • JavaScript JSNode对象被映射到netscape.javascript.JSObject实例，也实现了org.w3c.dom.Node
        • 一个特殊的例子是JavaScript类JavaRuntimeObject ，用于将Java对象包装为JavaScript值 - 在这种情况下，我们只是提取原始的Java值。

      • print

        public void print​(PrinterJob job)
        使用给定的打印机作业打印当前网页。

        此方法不修改作业的状态，也不调用PrinterJob.endJob() ，因此该作业可以安全地重用。

        参数
        job - 用于打印的打印机作业
        从以下版本开始：
        JavaFX 8.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WebErrorEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class WebErrorEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.web.WebErrorEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class WebErrorEvent
extends Event
    一个事件指示WebEngine错误。 保留可选的文本消息和与错误相关联的可选异常。
    从以下版本开始：
    JavaFX 8.0
    另请参见：
    WebEngine.onError ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<WebErrorEvent> ANY
      所有 WebErrorEvent类型的常用超类型。
      static EventType<WebErrorEvent> USER_DATA_DIRECTORY_ALREADY_IN_USE
      当WebEngine检测到其用户数据目录已在不同VM中运行的WebEngine已在使用时，会发生此事件。
      static EventType<WebErrorEvent> USER_DATA_DIRECTORY_IO_ERROR
      当WebEngine在尝试创建或访问用户数据目录时遇到I / O错误时，会发生此事件。
      static EventType<WebErrorEvent> USER_DATA_DIRECTORY_SECURITY_ERROR
      当WebEngine在尝试创建或访问用户数据目录时遇到安全错误时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)
      创建一个新的 WebErrorEvent 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getException​()
      返回与此事件关联的异常。
      String getMessage​()
      返回与此事件关联的文本消息。
      String toString​()
      返回此EventObject的String表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<WebErrorEvent> ANY
        所有 WebErrorEvent类型的公共超类型。

      • USER_DATA_DIRECTORY_ALREADY_IN_USE

        public static final EventType<WebErrorEvent> USER_DATA_DIRECTORY_ALREADY_IN_USE
        当WebEngine检测到其用户数据目录WebEngine在不同VM中运行的WebEngine已在使用时，会发生此事件。

        通常，多个WebEngine实例可以共享单个用户数据目录，只要它们在同一VM中运行。 WebEngine在不同虚拟机中运行的实例WebEngine共享相同的用户数据目录。

        当WebEngine第一次即将开始加载网页或执行脚本时，它会检查其userDataDirectory是否已在不同VM中运行的WebEngine使用。 如果是后者，那么WebEngine调用WebEngine.onError事件处理程序（如果有的话），其中包含一个USER_DATA_DIRECTORY_ALREADY_IN_USE事件。 如果调用的事件处理程序修改了userDataDirectory属性，则WebEngine将在处理程序返回时立即重试新的用户数据目录。 如果处理程序不修改userDataDirectory属性（这是默认值），则WebEngine不会继续使用用户数据目录。

      • USER_DATA_DIRECTORY_IO_ERROR

        public static final EventType<WebErrorEvent> USER_DATA_DIRECTORY_IO_ERROR
        当WebEngine尝试创建或访问用户数据目录时遇到I / O错误时，会发生此事件。

        当WebEngine第一次即将开始加载网页或执行脚本时，它会检查是否可以创建或访问其userDataDirectory 。 如果检查失败并出现I / O错误（例如java.io.IOException ），则WebEngine调用WebEngine.onError事件处理程序（如果有），并发生USER_DATA_DIRECTORY_IO_ERROR事件。 如果调用的事件处理程序修改了userDataDirectory属性，那么WebEngine在处理程序返回时立即重试新的用户数据目录。 如果处理程序不修改userDataDirectory属性（这是默认值），则WebEngine将WebEngine继续使用用户数据目录。

      • USER_DATA_DIRECTORY_SECURITY_ERROR

        public static final EventType<WebErrorEvent> USER_DATA_DIRECTORY_SECURITY_ERROR
        当WebEngine在尝试创建或访问用户数据目录时遇到安全错误时，会发生此事件。

        当WebEngine第一次即将开始加载网页或执行脚本时，它会检查是否可以创建或访问其userDataDirectory 。 如果检查失败并出现安全错误（如java.lang.SecurityException ），则WebEngine调用WebEngine.onError事件处理程序（如果有的话），并发生USER_DATA_DIRECTORY_SECURITY_ERROR事件。 如果调用的事件处理程序修改了userDataDirectory属性，则WebEngine在处理程序返回时立即重试新的用户数据目录。 如果处理程序不修改userDataDirectory属性（这是默认值），则WebEngine不会继续使用用户数据目录。

    • 构造方法详细信息

      • WebErrorEvent

        public WebErrorEvent​(Object source,
                     EventType<WebErrorEvent> type,
                     String message,
                     Throwable exception)
        创建一个新的 WebErrorEvent 。
        参数
        source - 发送事件的事件源
        type - 事件类型
        message - 与事件相关联的文本消息; 可能是null
        exception - 与事件相关的异常; 可能是null

    • 方法详细信息

      • getMessage

        public String getMessage​()
        返回与此事件关联的文本消息。
        结果
        与此事件相关联的文本消息，如果没有此类消息， null

      • getException

        public Throwable getException​()
        返回与此事件关联的异常。
        结果
        与此事件相关的异常，如果没有此类异常， null

      • toString

        public String toString​()
        返回此EventObject的String表示形式。
        重写：
        toString在 EventObject
        结果
        这个EventObject的一个String表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


WebEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class WebEvent<T>

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.scene.web.WebEvent<T>
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public final class WebEvent<T>
extends Event
    WebEvent实例被传递到EventHandler通过在网页上运行的JavaScript注册WebEngine 。 事件持有T类型的单个数据项。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    WebEngine ， WebEngine.setOnAlert(javafx.event.EventHandler<javafx.scene.web.WebEvent<java.lang.String>>) ， WebEngine.setOnResized(javafx.event.EventHandler<javafx.scene.web.WebEvent<javafx.geometry.Rectangle2D>>) ， WebEngine.setOnStatusChanged(javafx.event.EventHandler<javafx.scene.web.WebEvent<java.lang.String>>) ， WebEngine.setOnVisibilityChanged(javafx.event.EventHandler<javafx.scene.web.WebEvent<java.lang.Boolean>>) ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<WebEvent> ALERT
      当脚本调用JavaScript alert函数时，会发生此事件。
      static EventType<WebEvent> ANY
      所有Web事件类型的常用超类型。
      static EventType<WebEvent> RESIZED
      当脚本更改JavaScript window对象的位置时，会发生此事件。
      static EventType<WebEvent> STATUS_CHANGED
      当脚本更改状态行文本时，会发生此事件。
      static EventType<WebEvent> VISIBILITY_CHANGED
      当脚本更改JavaScript window对象的可见性时，会发生此事件。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      WebEvent​(Object source, EventType<WebEvent> type, T data)
      创建一个新的事件对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T getData​()
      返回此事件携带的数据项。
      String toString​()
      返回此 WebEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, copyFor, fireEvent, getEventType, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<WebEvent> ANY
        所有Web事件类型的常用超类型。

      • RESIZED

        public static final EventType<WebEvent> RESIZED
        当脚本更改JavaScript window对象的位置时，会发生此事件。

      • STATUS_CHANGED

        public static final EventType<WebEvent> STATUS_CHANGED
        当脚本更改状态行文本时，会发生此事件。

      • VISIBILITY_CHANGED

        public static final EventType<WebEvent> VISIBILITY_CHANGED
        当脚本更改JavaScript window对象的可见性时，会发生此事件。

      • ALERT

        public static final EventType<WebEvent> ALERT
        当脚本调用JavaScript alert函数时，会发生此事件。

    • 构造方法详细信息

      • WebEvent

        public WebEvent​(Object source,
                EventType<WebEvent> type,
                T data)
        创建一个新的事件对象。
        参数
        source - 事件源
        type - 事件类型
        data - 数据项

    • 方法详细信息

      • getData

        public T getData​()
        返回此事件携带的数据项。
        结果
        数据项

      • toString

        public String toString​()
        返回此 WebEvent对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        这个 WebEvent对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


WebHistory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class WebHistory

  • java.lang.Object
    • javafx.scene.web.WebHistory

  • public final class WebHistory
extends Object
    WebHistory类代表与WebEngine实例相关联的会话历史。 的单个实例WebHistory用于特定Web引擎可以通过获得WebEngine.getHistory()方法。 历史基本上是条目列表。 每个条目表示访问页面，它提供对相关页面信息的访问，例如URL，标题以及页面上次访问的日期。 列表中的条目按照从最早到最晚访问相应页面的顺序排列。 该列表可以通过使用getEntries()方法获得。 历史记录和相应的条目列表将以WebEngine进行网络浏览。 根据浏览器操作，该列表可能会扩展或缩小。 这些更改可以由列表公开的ObservableList API来监听。 与当前访问页面相关联的历史记录条目的索引由currentIndexProperty()表示。 当前索引可用于使用go(int)方法导航到历史记录中的任何条目。 maxSizeProperty()设置最大历史记录大小，即历史列表的大小。
    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyIntegerProperty currentIndex
      定义历史上当前 Entry的指数。
      IntegerProperty maxSize
      定义历史记录列表的最大大小。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      class  WebHistory.Entry
      Entry类表示会话历史中的单个条目。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyIntegerProperty currentIndexProperty​()
      定义历史上当前的 Entry的索引。
      int getCurrentIndex​()
      获取属性currentIndex的值。
      ObservableList<WebHistory.Entry> getEntries​()
      返回历史记录中所有条目的不可修改的可观察列表。
      int getMaxSize​()
      获取属性maxSize的值。
      void go​(int offset)
      将Web引擎导航到相对于当前条目的指定位置内由 Entry对象定义的URL。
      IntegerProperty maxSizeProperty​()
      定义历史记录列表的最大大小。
      void setMaxSize​(int value)
      设置属性maxSize的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • currentIndex

        public ReadOnlyIntegerProperty currentIndexProperty
        定义历史上当前Entry的指数。 当前条目是与当前加载的页面相关联的条目。 该索引属于(index >= 0 && index < getEntries().size())的范围。
        另请参见：
        getCurrentIndex()

      • maxSize

        public IntegerProperty maxSizeProperty
        定义历史记录列表的最大大小。 如果列表达到其最大值并添加了新条目，则第一个条目将从历史记录中删除。

        为此属性指定的值不能为负值，否则抛出IllegalArgumentException 。

        Default value:
        100
        另请参见：
        getMaxSize() ， setMaxSize(int)

    • 方法详细信息

      • currentIndexProperty

        public ReadOnlyIntegerProperty currentIndexProperty​()
        定义历史上当前Entry的指数。 当前条目是与当前加载的页面相关联的条目。 该指数属于(index >= 0 && index < getEntries().size())的范围。
        另请参见：
        getCurrentIndex()

      • getCurrentIndex

        public int getCurrentIndex​()
        获取属性currentIndex的值。
        Property description:
        定义历史上当前Entry的指数。 当前条目是与当前加载的页面相关联的条目。 该指数属于(index >= 0 && index < getEntries().size())的范围。

      • maxSizeProperty

        public IntegerProperty maxSizeProperty​()
        定义历史记录列表的最大大小。 如果列表达到其最大值并添加了新条目，则第一个条目将从历史记录中删除。

        为此属性指定的值不能为负值，否则抛出IllegalArgumentException 。

        Default value:
        100
        另请参见：
        getMaxSize() ， setMaxSize(int)

      • setMaxSize

        public void setMaxSize​(int value)
        设置属性maxSize的值。
        Property description:
        定义历史记录列表的最大大小。 如果列表达到其最大值并添加了新条目，则第一个条目将从历史记录中删除。

        为此属性指定的值不能为负值，否则抛出IllegalArgumentException 。

        Default value:
        100

      • getMaxSize

        public int getMaxSize​()
        获取属性maxSize的值。
        Property description:
        定义历史记录列表的最大大小。 如果列表达到其最大值并添加了新条目，则第一个条目将从历史记录中删除。

        为此属性指定的值不能为负值，否则抛出IllegalArgumentException 。

        Default value:
        100

      • getEntries

        public ObservableList<WebHistory.Entry> getEntries​()
        返回历史记录中所有条目的不可修改的可观察列表。
        结果
        所有历史记录列表

      • go

        public void go​(int offset)
        throws IndexOutOfBoundsException
        将Web引擎导航到Entry对象在相对于当前条目的指定位置中定义的URL。 负offset值指定当前条目之前的位置，正值offset值指定当前条目之后的位置。 例如，-1分到前一个条目，1分到下一个条目，分别对应于按下网页浏览器的“后退”和“转发”按钮。 零offset值被默认忽略（no-op）。 有效入场点应属于[0..size-1]的愤怒。 否则，抛出IndexOutOfBoundsException 。
        参数
        offset - 负值指定当前条目之前的位置，正值指定当前条目后的位置，零值不起作用
        异常
        IndexOutOfBoundsException - 如果有效进入位置超出范围
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WebHistory.Entry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class WebHistory.Entry

  • java.lang.Object
    • javafx.scene.web.WebHistory.Entry
  • Enclosing class:
    WebHistory

    public final class WebHistory.Entry
extends Object
    Entry类表示会话历史中的单个条目。 入口实例与访问页面相关联。
    从以下版本开始：
    JavaFX 2.2

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyObjectProperty<Date> lastVisitedDate
      定义最后访问的页面Date 。
      ReadOnlyObjectProperty<String> title
      定义页面的标题。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Date getLastVisitedDate​()
      获取属性lastVisitedDate的值。
      String getTitle​()
      获取属性标题的值。
      String getUrl​()
      返回页面的URL。
      ReadOnlyObjectProperty<Date> lastVisitedDateProperty​()
      定义页面最后访问的Date 。
      ReadOnlyObjectProperty<String> titleProperty​()
      定义页面的标题。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Property Detail

      • title

        public ReadOnlyObjectProperty<String> titleProperty
        定义页面的标题。
        另请参见：
        getTitle()

      • lastVisitedDate

        public ReadOnlyObjectProperty<Date> lastVisitedDateProperty
        定义页面最后访问的Date 。
        另请参见：
        getLastVisitedDate()

    • 方法详细信息

      • getUrl

        public String getUrl​()
        返回页面的URL。
        结果
        网页的网址

      • titleProperty

        public ReadOnlyObjectProperty<String> titleProperty​()
        定义页面的标题。
        另请参见：
        getTitle()

      • getTitle

        public String getTitle​()
        获取属性标题的值。
        Property description:
        定义页面的标题。

      • lastVisitedDateProperty

        public ReadOnlyObjectProperty<Date> lastVisitedDateProperty​()
        定义页面最后访问的Date 。
        另请参见：
        getLastVisitedDate()

      • getLastVisitedDate

        public Date getLastVisitedDate​()
        获取属性lastVisitedDate的值。
        Property description:
        定义页面最后访问的Date 。

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WebView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.web
软件包 javafx.scene.web

Class WebView

  • java.lang.Object
    • javafx.scene.Node
      • javafx.scene.Parent
        • javafx.scene.web.WebView
  • All Implemented Interfaces:
    Styleable ， EventTarget

    public final class WebView
extends Parent
    WebView是一个Node ，管理一个WebEngine并显示其内容。 相关联的WebEngine在施工时自动创建，之后不能更改。 WebView处理鼠标和一些键盘事件，并自动管理滚动，所以没有必要把它放入一个ScrollPane 。

    WebView对象必须仅通过FX线程创建和访问。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      BooleanProperty contextMenuEnabled
      指定是否启用了上下文菜单。
      DoubleProperty fontScale
      指定应用于字体的比例因子。
      ObjectProperty<FontSmoothingType> fontSmoothingType
      指定所请求的字体平滑类型：灰色或LCD。
      ReadOnlyDoubleProperty height
      这个高度 WebView 。
      DoubleProperty maxHeight
      最大高度属性。
      DoubleProperty maxWidth
      最大宽度属性。
      DoubleProperty minHeight
      最小高度属性。
      DoubleProperty minWidth
      最小宽度属性。
      DoubleProperty prefHeight
      首选高度属性。
      DoubleProperty prefWidth
      首选宽度属性。
      ReadOnlyDoubleProperty width
      此宽度为 WebView 。
      DoubleProperty zoom
      当前缩放因子应用于整个页面内容。

      • Properties inherited from class javafx.scene.Node

        accessibleHelp, accessibleRoleDescription, accessibleRole, accessibleText, blendMode, boundsInLocal, boundsInParent, cacheHint, cache, clip, cursor, depthTest, disabled, disable, effectiveNodeOrientation, effect, eventDispatcher, focused, focusTraversable, hover, id, inputMethodRequests, layoutBounds, layoutX, layoutY, localToParentTransform, localToSceneTransform, managed, mouseTransparent, nodeOrientation, onContextMenuRequested, onDragDetected, onDragDone, onDragDropped, onDragEntered, onDragExited, onDragOver, onInputMethodTextChanged, onKeyPressed, onKeyReleased, onKeyTyped, onMouseClicked, onMouseDragEntered, onMouseDragExited, onMouseDragged, onMouseDragOver, onMouseDragReleased, onMouseEntered, onMouseExited, onMouseMoved, onMousePressed, onMouseReleased, onRotate, onRotationFinished, onRotationStarted, onScrollFinished, onScroll, onScrollStarted, onSwipeDown, onSwipeLeft, onSwipeRight, onSwipeUp, onTouchMoved, onTouchPressed, onTouchReleased, onTouchStationary, onZoomFinished, onZoom, onZoomStarted, opacity, parent, pickOnBounds, pressed, rotate, rotationAxis, scaleX, scaleY, scaleZ, scene, style, translateX, translateY, translateZ, viewOrder, visible

      • Properties inherited from class javafx.scene.Parent

        needsLayout

    • Field Summary

      • Fields inherited from class javafx.scene.Node

        BASELINE_OFFSET_SAME_AS_HEIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      WebView​()
      创建一个 WebView对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      BooleanProperty contextMenuEnabledProperty​()
      指定是否启用了上下文菜单。
      DoubleProperty fontScaleProperty​()
      指定应用于字体的比例因子。
      ObjectProperty<FontSmoothingType> fontSmoothingTypeProperty​()
      指定所请求的字体平滑类型：灰色或LCD。
      protected ObservableList<Node> getChildren​()
      获取这个 Parent的孩子列表。
      static List<CssMetaData<? extends Styleable,?>> | getClassCssMetaData​()
      List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
      该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
      WebEngine getEngine​()
      返回 WebEngine对象。
      double getFontScale​()
      获取属性fontScale的值。
      FontSmoothingType getFontSmoothingType​()
      获取属性fontSmoothingType的值。
      double getHeight​()
      获取属性高度的值。
      double getMaxHeight​()
      获取属性maxHeight的值。
      double getMaxWidth​()
      获取属性maxWidth的值。
      double getMinHeight​()
      获取属性minHeight的值。
      double getMinWidth​()
      获取属性minWidth的值。
      double getPrefHeight​()
      获取属性prefHeight的值。
      double getPrefWidth​()
      获取属性prefWidth的值。
      double getWidth​()
      获取属性宽度的值。
      double getZoom​()
      获取属性变焦的值。
      ReadOnlyDoubleProperty heightProperty​()
      这个高度 WebView 。
      boolean isContextMenuEnabled​()
      获取属性contextMenuEnabled的值。
      boolean isResizable​()
      指示该节点是否可以由父节点调整大小。
      double maxHeight​(double width)
      在布局期间调用以确定此节点的最大高度。
      DoubleProperty maxHeightProperty​()
      最大高度属性。
      double maxWidth​(double height)
      在布局期间调用以确定此节点的最大宽度。
      DoubleProperty maxWidthProperty​()
      最大宽度属性。
      double minHeight​(double width)
      在布局期间调用以确定此节点的最小高度。
      DoubleProperty minHeightProperty​()
      最小高度属性。
      double minWidth​(double height)
      在布局期间调用以确定此节点的最小宽度。
      DoubleProperty minWidthProperty​()
      最小宽度属性。
      double prefHeight​(double width)
      在布局期间调用以确定此节点的首选高度。
      DoubleProperty prefHeightProperty​()
      首选高度属性。
      double prefWidth​(double height)
      在布局期间调用以确定此节点的首选宽度。
      DoubleProperty prefWidthProperty​()
      首选宽度属性。
      void resize​(double width, double height)
      如果节点可调整大小，将其布局边界设置为指定的宽度和高度。
      void setContextMenuEnabled​(boolean value)
      设置属性contextMenuEnabled的值。
      void setFontScale​(double value)
      设置属性fontScale的值。
      void setFontSmoothingType​(FontSmoothingType value)
      设置属性fontSmoothingType的值。
      void setMaxHeight​(double value)
      设置属性maxHeight的值。
      void setMaxSize​(double maxWidth, double maxHeight)
      设置最大宽度和高度的便利方法。
      void setMaxWidth​(double value)
      设置属性maxWidth的值。
      void setMinHeight​(double value)
      设置属性minHeight的值。
      void setMinSize​(double minWidth, double minHeight)
      设置最小宽度和高度的方便方法。
      void setMinWidth​(double value)
      设置属性minWidth的值。
      void setPrefHeight​(double value)
      设置属性prefHeight的值。
      void setPrefSize​(double prefWidth, double prefHeight)
      设置首选宽度和高度的便利方法。
      void setPrefWidth​(double value)
      设置属性prefWidth的值。
      void setZoom​(double value)
      设置属性缩放的值。
      ReadOnlyDoubleProperty widthProperty​()
      此宽度为 WebView 。
      DoubleProperty zoomProperty​()
      当前缩放因子应用于整个页面内容。

      • Methods inherited from class javafx.scene.Node

        accessibleHelpProperty, accessibleRoleDescriptionProperty, accessibleRoleProperty, accessibleTextProperty, addEventFilter, addEventHandler, applyCss, autosize, blendModeProperty, boundsInLocalProperty, boundsInParentProperty, buildEventDispatchChain, cacheHintProperty, cacheProperty, clipProperty, computeAreaInScreen, contains, contains, cursorProperty, depthTestProperty, disabledProperty, disableProperty, effectiveNodeOrientationProperty, effectProperty, eventDispatcherProperty, executeAccessibleAction, fireEvent, focusedProperty, focusTraversableProperty, getAccessibleHelp, getAccessibleRole, getAccessibleRoleDescription, getAccessibleText, getBlendMode, getBoundsInLocal, getBoundsInParent, getCacheHint, getClip, getContentBias, getCursor, getDepthTest, getEffect, getEffectiveNodeOrientation, getEventDispatcher, getId, getInitialCursor, getInitialFocusTraversable, getInputMethodRequests, getLayoutBounds, getLayoutX, getLayoutY, getLocalToParentTransform, getLocalToSceneTransform, getNodeOrientation, getOnContextMenuRequested, getOnDragDetected, getOnDragDone, getOnDragDropped, getOnDragEntered, getOnDragExited, getOnDragOver, getOnInputMethodTextChanged, getOnKeyPressed, getOnKeyReleased, getOnKeyTyped, getOnMouseClicked, getOnMouseDragEntered, getOnMouseDragExited, getOnMouseDragged, getOnMouseDragOver, getOnMouseDragReleased, getOnMouseEntered, getOnMouseExited, getOnMouseMoved, getOnMousePressed, getOnMouseReleased, getOnRotate, getOnRotationFinished, getOnRotationStarted, getOnScroll, getOnScrollFinished, getOnScrollStarted, getOnSwipeDown, getOnSwipeLeft, getOnSwipeRight, getOnSwipeUp, getOnTouchMoved, getOnTouchPressed, getOnTouchReleased, getOnTouchStationary, getOnZoom, getOnZoomFinished, getOnZoomStarted, getOpacity, getParent, getProperties, getPseudoClassStates, getRotate, getRotationAxis, getScaleX, getScaleY, getScaleZ, getScene, getStyle, getStyleableParent, getStyleClass, getTransforms, getTranslateX, getTranslateY, getTranslateZ, getTypeSelector, getUserData, getViewOrder, hasProperties, hoverProperty, idProperty, inputMethodRequestsProperty, intersects, intersects, isCache, isDisable, isDisabled, isFocused, isFocusTraversable, isHover, isManaged, isMouseTransparent, isPickOnBounds, isPressed, isVisible, layoutBoundsProperty, layoutXProperty, layoutYProperty, localToParent, localToParent, localToParent, localToParent, localToParent, localToParentTransformProperty, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToScene, localToSceneTransformProperty, localToScreen, localToScreen, localToScreen, localToScreen, localToScreen, lookupAll, managedProperty, mouseTransparentProperty, nodeOrientationProperty, notifyAccessibleAttributeChanged, onContextMenuRequestedProperty, onDragDetectedProperty, onDragDoneProperty, onDragDroppedProperty, onDragEnteredProperty, onDragExitedProperty, onDragOverProperty, onInputMethodTextChangedProperty, onKeyPressedProperty, onKeyReleasedProperty, onKeyTypedProperty, onMouseClickedProperty, onMouseDragEnteredProperty, onMouseDragExitedProperty, onMouseDraggedProperty, onMouseDragOverProperty, onMouseDragReleasedProperty, onMouseEnteredProperty, onMouseExitedProperty, onMouseMovedProperty, onMousePressedProperty, onMouseReleasedProperty, onRotateProperty, onRotationFinishedProperty, onRotationStartedProperty, onScrollFinishedProperty, onScrollProperty, onScrollStartedProperty, onSwipeDownProperty, onSwipeLeftProperty, onSwipeRightProperty, onSwipeUpProperty, onTouchMovedProperty, onTouchPressedProperty, onTouchReleasedProperty, onTouchStationaryProperty, onZoomFinishedProperty, onZoomProperty, onZoomStartedProperty, opacityProperty, parentProperty, parentToLocal, parentToLocal, parentToLocal, parentToLocal, parentToLocal, pickOnBoundsProperty, pressedProperty, pseudoClassStateChanged, relocate, removeEventFilter, removeEventHandler, requestFocus, resizeRelocate, rotateProperty, rotationAxisProperty, scaleXProperty, scaleYProperty, scaleZProperty, sceneProperty, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, sceneToLocal, screenToLocal, screenToLocal, screenToLocal, setAccessibleHelp, setAccessibleRole, setAccessibleRoleDescription, setAccessibleText, setBlendMode, setCache, setCacheHint, setClip, setCursor, setDepthTest, setDisable, setDisabled, setEffect, setEventDispatcher, setEventHandler, setFocused, setFocusTraversable, setHover, setId, setInputMethodRequests, setLayoutX, setLayoutY, setManaged, setMouseTransparent, setNodeOrientation, setOnContextMenuRequested, setOnDragDetected, setOnDragDone, setOnDragDropped, setOnDragEntered, setOnDragExited, setOnDragOver, setOnInputMethodTextChanged, setOnKeyPressed, setOnKeyReleased, setOnKeyTyped, setOnMouseClicked, setOnMouseDragEntered, setOnMouseDragExited, setOnMouseDragged, setOnMouseDragOver, setOnMouseDragReleased, setOnMouseEntered, setOnMouseExited, setOnMouseMoved, setOnMousePressed, setOnMouseReleased, setOnRotate, setOnRotationFinished, setOnRotationStarted, setOnScroll, setOnScrollFinished, setOnScrollStarted, setOnSwipeDown, setOnSwipeLeft, setOnSwipeRight, setOnSwipeUp, setOnTouchMoved, setOnTouchPressed, setOnTouchReleased, setOnTouchStationary, setOnZoom, setOnZoomFinished, setOnZoomStarted, setOpacity, setPickOnBounds, setPressed, setRotate, setRotationAxis, setScaleX, setScaleY, setScaleZ, setStyle, setTranslateX, setTranslateY, setTranslateZ, setUserData, setViewOrder, setVisible, snapshot, snapshot, startDragAndDrop, startFullDrag, styleProperty, toBack, toFront, toString, translateXProperty, translateYProperty, translateZProperty, usesMirroring, viewOrderProperty, visibleProperty

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class javafx.scene.Parent

        computeMinHeight, computeMinWidth, computePrefHeight, computePrefWidth, getBaselineOffset, getChildrenUnmodifiable, getManagedChildren, getStylesheets, isNeedsLayout, layout, layoutChildren, lookup, needsLayoutProperty, queryAccessibleAttribute, requestLayout, requestParentLayout, setNeedsLayout, updateBounds

      • Methods inherited from interface javafx.css.Styleable

        getStyleableNode

    • Property Detail

      • width

        public ReadOnlyDoubleProperty widthProperty
        此宽度为 WebView 。
        另请参见：
        getWidth()

      • height

        public ReadOnlyDoubleProperty heightProperty
        这个高度 WebView 。
        另请参见：
        getHeight()

      • zoom

        public final DoubleProperty zoomProperty
        当前缩放因子应用于整个页面内容。
        Default value:
        1.0
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getZoom() ， setZoom(double)

      • fontScale

        public DoubleProperty fontScaleProperty
        指定应用于字体的比例因子。 此设置影响文本内容，但不影响图像和固定大小的元素。
        Default value:
        1.0
        另请参见：
        getFontScale() ， setFontScale(double)

      • minWidth

        public DoubleProperty minWidthProperty
        最小宽度属性。
        另请参见：
        getMinWidth() ， setMinWidth(double)

      • minHeight

        public DoubleProperty minHeightProperty
        最小高度属性。
        另请参见：
        getMinHeight() ， setMinHeight(double)

      • prefWidth

        public DoubleProperty prefWidthProperty
        首选宽度属性。
        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • prefHeight

        public DoubleProperty prefHeightProperty
        首选高度属性。
        另请参见：
        getPrefHeight() ， setPrefHeight(double)

      • maxWidth

        public DoubleProperty maxWidthProperty
        最大宽度属性。
        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • maxHeight

        public DoubleProperty maxHeightProperty
        最大高度属性。
        另请参见：
        getMaxHeight() ， setMaxHeight(double)

      • fontSmoothingType

        public final ObjectProperty<FontSmoothingType> fontSmoothingTypeProperty
        指定所请求的字体平滑类型：灰色或LCD。 边框的宽度由最宽的行定义。 注意：LCD模式不适用于许多情况，例如各种合成模式，其中应用效果和非常大的字形。
        Default value:
        FontSmoothingType.LCD
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getFontSmoothingType() ， setFontSmoothingType(FontSmoothingType)

      • contextMenuEnabled

        public final BooleanProperty contextMenuEnabledProperty
        指定是否启用了上下文菜单。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        isContextMenuEnabled() ， setContextMenuEnabled(boolean)

    • 构造方法详细信息

      • WebView

        public WebView​()
        创建一个 WebView对象。

    • 方法详细信息

      • getEngine

        public final WebEngine getEngine​()
        返回 WebEngine对象。
        结果
        WebEngine

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        此宽度为 WebView 。

      • widthProperty

        public ReadOnlyDoubleProperty widthProperty​()
        此宽度为 WebView 。
        另请参见：
        getWidth()

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        这个高度 WebView 。

      • heightProperty

        public ReadOnlyDoubleProperty heightProperty​()
        这个高度 WebView 。
        另请参见：
        getHeight()

      • setZoom

        public final void setZoom​(double value)
        设置属性缩放的值。
        Property description:
        当前缩放因子应用于整个页面内容。
        Default value:
        1.0
        从以下版本开始：
        JavaFX 8.0

      • getZoom

        public final double getZoom​()
        获取属性变焦的值。
        Property description:
        当前缩放因子应用于整个页面内容。
        Default value:
        1.0
        从以下版本开始：
        JavaFX 8.0

      • zoomProperty

        public final DoubleProperty zoomProperty​()
        当前缩放因子应用于整个页面内容。
        Default value:
        1.0
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getZoom() ， setZoom(double)

      • setFontScale

        public final void setFontScale​(double value)
        设置属性fontScale的值。
        Property description:
        指定应用于字体的比例因子。 此设置影响文本内容，但不影响图像和固定大小的元素。
        Default value:
        1.0

      • getFontScale

        public final double getFontScale​()
        获取属性fontScale的值。
        Property description:
        指定应用于字体的比例因子。 此设置影响文本内容，但不影响图像和固定大小的元素。
        Default value:
        1.0

      • fontScaleProperty

        public DoubleProperty fontScaleProperty​()
        指定应用于字体的比例因子。 此设置影响文本内容，但不影响图像和固定大小的元素。
        Default value:
        1.0
        另请参见：
        getFontScale() ， setFontScale(double)

      • isResizable

        public boolean isResizable​()
        描述从类复制： Node
        指示该节点是否可以由父节点调整大小。 如果此方法返回true，那么在布局过程中，父节点将通过调用node.resize（width，height）来调整节点的大小（理想情况下在其大小范围内）。 所有区域，控件和WebView都是可调整大小的类，它们在应用所有尺寸和CSS样式信息后，依赖于他们的父母在布局期间调整大小。

        如果此方法返回false，那么在布局期间父（）不能调整它大小（resize（）是一个no-op），并且它应该返回其layoutBounds的最小，首选和最大大小。 组，文本和所有形状都不能调整大小，因此通过设置适当的属性（例如矩形的宽度/高度，文本上的文本等），依赖于应用程序来建立其大小。 在布局期间，仍然可以重新定位不可调整大小的节点。

        重写：
        isResizable在 Node
        结果
        该布局期间该节点类型是否可以由其父节点调整大小
        另请参见：
        Node.getContentBias() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double) ，
Node.resize(double, double) ，
Node.getLayoutBounds()

      • resize

        public void resize​(double width,
                   double height)
        描述从类复制： Node
        如果节点可调整大小，将其布局边界设置为指定的宽度和高度。 如果节点不能调整大小，这个方法是无效的。

        这个方法通常只能通过parentChildren（）方法由父节点调用。 所有Parent类将自动调整大小可调整大小的子项，因此应用程序直接进行的调整大小将被节点的父级覆盖，除非子级不受管理。

        父母负责确保宽度和高度值落在可调整大小的节点的首选范围内。 如果父级只需要将节点的大小调整为其首选大小，则可以使用autosize（）方法。

        重写：
        resize在 Node
        参数
        width - 目标布局限制宽度
        height - 目标布局界定高度
        另请参见：
        Node.isResizable() ，
Node.getContentBias() ，
Node.autosize() ，
Node.minWidth(double) ，
Node.minHeight(double) ，
Node.prefWidth(double) ，
Node.prefHeight(double) ，
Node.maxWidth(double) ，
Node.maxHeight(double) ，
Node.getLayoutBounds()

      • minWidth

        public final double minWidth​(double height)
        在布局期间调用以确定此节点的最小宽度。
        重写：
        minWidth在 Parent
        参数
        height - 如果最小宽度取决于应该使用的高度
        结果
        在布局期间该节点应该调整大小的最小宽度
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • minHeight

        public final double minHeight​(double width)
        在布局期间调用以确定此节点的最小高度。
        重写：
        minHeight在 Parent
        参数
        width - 如果最小高度取决于应该使用的宽度
        结果
        在布局期间该节点应该调整大小的最小高度
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • prefWidth

        public final double prefWidth​(double height)
        在布局期间调用以确定此节点的首选宽度。
        重写：
        prefWidth在 Parent
        参数
        height - 如果首选宽度取决于应该使用的高度
        结果
        在布局期间该节点应该调整大小的首选宽度
        另请参见：
        Node.isResizable() ，
Node.getContentBias() ，
Node.autosize()

      • prefHeight

        public final double prefHeight​(double width)
        在布局期间调用以确定此节点的首选高度。
        重写：
        prefHeight在 Parent
        参数
        width - 如果偏好的高度取决于应该使用的宽度
        结果
        在布局期间该节点应该调整大小的首选高度
        另请参见：
        Node.getContentBias() ， Node.autosize()

      • maxWidth

        public final double maxWidth​(double height)
        在布局期间调用以确定此节点的最大宽度。
        重写：
        maxWidth在 Node
        参数
        height - 如果最大宽度取决于应该使用的高度
        结果
        在布局期间该节点应该调整大小的最大宽度
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • maxHeight

        public final double maxHeight​(double width)
        在布局期间调用以确定此节点的最大高度。
        重写：
        maxHeight在 Node
        参数
        width - 如果最大高度取决于它应该使用的宽度
        结果
        在布局期间该节点应该调整大小的最大高度
        另请参见：
        Node.isResizable() ， Node.getContentBias()

      • minWidthProperty

        public DoubleProperty minWidthProperty​()
        最小宽度属性。
        另请参见：
        getMinWidth() ， setMinWidth(double)

      • setMinWidth

        public final void setMinWidth​(double value)
        设置属性minWidth的值。
        Property description:
        最小宽度属性。

      • getMinWidth

        public final double getMinWidth​()
        获取属性minWidth的值。
        Property description:
        最小宽度属性。

      • minHeightProperty

        public DoubleProperty minHeightProperty​()
        最小高度属性。
        另请参见：
        getMinHeight() ， setMinHeight(double)

      • setMinHeight

        public final void setMinHeight​(double value)
        设置属性minHeight的值。
        Property description:
        最小高度属性。

      • getMinHeight

        public final double getMinHeight​()
        获取属性minHeight的值。
        Property description:
        最小高度属性。

      • setMinSize

        public void setMinSize​(double minWidth,
                       double minHeight)
        设置最小宽度和高度的方便方法。
        参数
        minWidth - 最小宽度
        minHeight - 最小高度

      • prefWidthProperty

        public DoubleProperty prefWidthProperty​()
        首选宽度属性。
        另请参见：
        getPrefWidth() ， setPrefWidth(double)

      • setPrefWidth

        public final void setPrefWidth​(double value)
        设置属性prefWidth的值。
        Property description:
        首选宽度属性。

      • getPrefWidth

        public final double getPrefWidth​()
        获取属性prefWidth的值。
        Property description:
        首选宽度属性。

      • prefHeightProperty

        public DoubleProperty prefHeightProperty​()
        首选高度属性。
        另请参见：
        getPrefHeight() ， setPrefHeight(double)

      • setPrefHeight

        public final void setPrefHeight​(double value)
        设置属性prefHeight的值。
        Property description:
        首选高度属性。

      • getPrefHeight

        public final double getPrefHeight​()
        获取属性prefHeight的值。
        Property description:
        首选高度属性。

      • setPrefSize

        public void setPrefSize​(double prefWidth,
                        double prefHeight)
        设置首选宽度和高度的便利方法。
        参数
        prefWidth - 首选宽度
        prefHeight - 首选高度

      • maxWidthProperty

        public DoubleProperty maxWidthProperty​()
        最大宽度属性。
        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • setMaxWidth

        public final void setMaxWidth​(double value)
        设置属性maxWidth的值。
        Property description:
        最大宽度属性。

      • getMaxWidth

        public final double getMaxWidth​()
        获取属性maxWidth的值。
        Property description:
        最大宽度属性。

      • maxHeightProperty

        public DoubleProperty maxHeightProperty​()
        最大高度属性。
        另请参见：
        getMaxHeight() ， setMaxHeight(double)

      • setMaxHeight

        public final void setMaxHeight​(double value)
        设置属性maxHeight的值。
        Property description:
        最大高度属性。

      • getMaxHeight

        public final double getMaxHeight​()
        获取属性maxHeight的值。
        Property description:
        最大高度属性。

      • setMaxSize

        public void setMaxSize​(double maxWidth,
                       double maxHeight)
        设置最大宽度和高度的便利方法。
        参数
        maxWidth - 最大宽度
        maxHeight - 最大高度

      • setFontSmoothingType

        public final void setFontSmoothingType​(FontSmoothingType value)
        设置属性fontSmoothingType的值。
        Property description:
        指定所请求的字体平滑类型：灰色或LCD。 边框的宽度由最宽的行定义。 注意：LCD模式不适用于许多情况，例如各种合成模式，其中应用效果和非常大的字形。
        Default value:
        FontSmoothingType.LCD
        从以下版本开始：
        JavaFX 2.2

      • getFontSmoothingType

        public final FontSmoothingType getFontSmoothingType​()
        获取属性fontSmoothingType的值。
        Property description:
        指定所请求的字体平滑类型：灰色或LCD。 边框的宽度由最宽的行定义。 注意：LCD模式不适用于许多情况，例如各种合成模式，其中应用效果和非常大的字形。
        Default value:
        FontSmoothingType.LCD
        从以下版本开始：
        JavaFX 2.2

      • fontSmoothingTypeProperty

        public final ObjectProperty<FontSmoothingType> fontSmoothingTypeProperty​()
        指定所请求的字体平滑类型：灰色或LCD。 边框的宽度由最宽的行定义。 注意：LCD模式不适用于许多情况，例如各种合成模式，其中应用效果和非常大的字形。
        Default value:
        FontSmoothingType.LCD
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getFontSmoothingType() ， setFontSmoothingType(FontSmoothingType)

      • setContextMenuEnabled

        public final void setContextMenuEnabled​(boolean value)
        设置属性contextMenuEnabled的值。
        Property description:
        指定是否启用了上下文菜单。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2

      • isContextMenuEnabled

        public final boolean isContextMenuEnabled​()
        获取属性contextMenuEnabled的值。
        Property description:
        指定是否启用了上下文菜单。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2

      • contextMenuEnabledProperty

        public final BooleanProperty contextMenuEnabledProperty​()
        指定是否启用了上下文菜单。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        isContextMenuEnabled() ， setContextMenuEnabled(boolean)

      • getClassCssMetaData

        public static List<CssMetaData<? extends Styleable,?>> getClassCssMetaData​()
        结果
        与此类相关联的CssMetaData可能包括其类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getCssMetaData

        public List<CssMetaData<? extends Styleable,?>> getCssMetaData​()
        该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。
        Specified by:
        getCssMetaData在接口 Styleable
        重写：
        getCssMetaData在 Node
        结果
        与该节点相关联的CssMetaData，其可以包括其超类的CssMetaData。
        从以下版本开始：
        JavaFX 8.0

      • getChildren

        protected ObservableList<Node> getChildren​()
        描述从类复制： Parent
        获取此Parent的孩子列表。

        有关设置Parent的子列表的场景图结构限制，请参阅Node的类文档。 如果对子列表的更改违反了这些限制，则忽略该更改，并恢复子列表的先前值。 在这种情况下抛出一个IllegalArgumentException 。

        如果这个Parent节点被连接到Scene连接到Window被showning（ Window.isShowing() ），那么其子女的名单必须只在JavaFX应用程序线程修改。 如果违反限制，则抛出一个IllegalStateException 。

        注意子类：如果您重写此方法，则必须从实现中返回调用此超级方法的结果。 从任何getChildren（）实现返回的实际列表实例必须是由此父项所拥有和管理的列表。 推翻这种方法的唯一典型的目的是推广这种方法。

        重写：
        getChildren在 Parent
        结果
        这个 Parent的孩子 Parent 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javafx.scene.web.HTMLEditor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.HTMLEditor

  • Packages that use HTMLEditor
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of HTMLEditor in javafx.scene.web

      Constructors in javafx.scene.web with parameters of type HTMLEditor
      Constructor 描述
      HTMLEditorSkin​(HTMLEditor control)
      创建一个新的HTMLEditorSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.HTMLEditorSkin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.HTMLEditorSkin

No usage of javafx.scene.web.HTMLEditorSkin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.HTMLEditorSkin.Command (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.HTMLEditorSkin.Command

  • Packages that use HTMLEditorSkin.Command
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of HTMLEditorSkin.Command in javafx.scene.web

      Methods in javafx.scene.web that return HTMLEditorSkin.Command
      Modifier and Type 方法 描述
      static HTMLEditorSkin.Command HTMLEditorSkin.Command.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HTMLEditorSkin.Command[] HTMLEditorSkin.Command.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.scene.web with parameters of type HTMLEditorSkin.Command
      Modifier and Type 方法 描述
      void HTMLEditorSkin.performCommand​(HTMLEditorSkin.Command command)
      某些命令的特殊情况处理。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.PopupFeatures (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.PopupFeatures

  • Packages that use PopupFeatures
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of PopupFeatures in javafx.scene.web

      Methods in javafx.scene.web that return types with arguments of type PopupFeatures
      Modifier and Type 方法 描述
      ObjectProperty<Callback<PopupFeatures,WebEngine>> WebEngine.createPopupHandlerProperty​()
      JavaScript弹出窗口处理程序属性。
      Callback<PopupFeatures,WebEngine> WebEngine.getCreatePopupHandler​()
      获取属性createPopupHandler的值。
      Method parameters in javafx.scene.web with type arguments of type PopupFeatures
      Modifier and Type 方法 描述
      void WebEngine.setCreatePopupHandler​(Callback<PopupFeatures,WebEngine> handler)
      设置属性createPopupHandler的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.PromptData (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.PromptData

  • Packages that use PromptData
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of PromptData in javafx.scene.web

      Methods in javafx.scene.web that return types with arguments of type PromptData
      Modifier and Type 方法 描述
      Callback<PromptData,String> WebEngine.getPromptHandler​()
      获取属性promptHandler的值。
      ObjectProperty<Callback<PromptData,String>> WebEngine.promptHandlerProperty​()
      JavaScript prompt处理程序属性。
      Method parameters in javafx.scene.web with type arguments of type PromptData
      Modifier and Type 方法 描述
      void WebEngine.setPromptHandler​(Callback<PromptData,String> handler)
      设置属性promptHandler的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.WebEngine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.WebEngine

  • Packages that use WebEngine
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of WebEngine in javafx.scene.web

      Methods in javafx.scene.web that return WebEngine
      Modifier and Type 方法 描述
      WebEngine WebView.getEngine​()
      返回 WebEngine对象。
      Methods in javafx.scene.web that return types with arguments of type WebEngine
      Modifier and Type 方法 描述
      ObjectProperty<Callback<PopupFeatures,WebEngine>> WebEngine.createPopupHandlerProperty​()
      JavaScript弹出窗口处理程序属性。
      Callback<PopupFeatures,WebEngine> WebEngine.getCreatePopupHandler​()
      获取属性createPopupHandler的值。
      Method parameters in javafx.scene.web with type arguments of type WebEngine
      Modifier and Type 方法 描述
      void WebEngine.setCreatePopupHandler​(Callback<PopupFeatures,WebEngine> handler)
      设置属性createPopupHandler的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.WebErrorEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.WebErrorEvent

  • Packages that use WebErrorEvent
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of WebErrorEvent in javafx.scene.web

      Fields in javafx.scene.web with type parameters of type WebErrorEvent
      Modifier and Type Field 描述
      static EventType<WebErrorEvent> WebErrorEvent.ANY
      所有 WebErrorEvent类型的常用超类型。
      static EventType<WebErrorEvent> WebErrorEvent.USER_DATA_DIRECTORY_ALREADY_IN_USE
      当WebEngine检测到其用户数据目录WebEngine不同的VM中运行的WebEngine使用时，会发生此事件。
      static EventType<WebErrorEvent> WebErrorEvent.USER_DATA_DIRECTORY_IO_ERROR
      当WebEngine在尝试创建或访问用户数据目录时遇到I / O错误时，会发生此事件。
      static EventType<WebErrorEvent> WebErrorEvent.USER_DATA_DIRECTORY_SECURITY_ERROR
      当WebEngine在尝试创建或访问用户数据目录时遇到安全错误时，会发生此事件。
      Methods in javafx.scene.web that return types with arguments of type WebErrorEvent
      Modifier and Type 方法 描述
      EventHandler<WebErrorEvent> WebEngine.getOnError​()
      获取属性onError的值。
      ObjectProperty<EventHandler<WebErrorEvent>> WebEngine.onErrorProperty​()
      当发生错误时调用事件处理程序。
      Method parameters in javafx.scene.web with type arguments of type WebErrorEvent
      Modifier and Type 方法 描述
      void WebEngine.setOnError​(EventHandler<WebErrorEvent> handler)
      设置属性onError的值。
      Constructor parameters in javafx.scene.web with type arguments of type WebErrorEvent
      Constructor 描述
      WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)
      创建一个新的 WebErrorEvent 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.WebEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.WebEvent

  • Packages that use WebEvent
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of WebEvent in javafx.scene.web

      Fields in javafx.scene.web with type parameters of type WebEvent
      Modifier and Type Field 描述
      static EventType<WebEvent> WebEvent.ALERT
      当脚本调用JavaScript alert函数时，会发生此事件。
      static EventType<WebEvent> WebEvent.ANY
      所有Web事件类型的常用超类型。
      static EventType<WebEvent> WebEvent.RESIZED
      当脚本更改JavaScript window对象的位置时，会发生此事件。
      static EventType<WebEvent> WebEvent.STATUS_CHANGED
      当脚本更改状态行文本时，会发生此事件。
      static EventType<WebEvent> WebEvent.VISIBILITY_CHANGED
      当脚本更改JavaScript window对象的可见性时，会发生此事件。
      Methods in javafx.scene.web that return types with arguments of type WebEvent
      Modifier and Type 方法 描述
      EventHandler<WebEvent<String>> WebEngine.getOnAlert​()
      获取属性onAlert的值。
      EventHandler<WebEvent<Rectangle2D>> WebEngine.getOnResized​()
      获取属性onResized的值。
      EventHandler<WebEvent<String>> WebEngine.getOnStatusChanged​()
      获取属性onStatusChanged的值。
      EventHandler<WebEvent<Boolean>> WebEngine.getOnVisibilityChanged​()
      获取属性onVisibilityChanged的值。
      ObjectProperty<EventHandler<WebEvent<String>>> WebEngine.onAlertProperty​()
      JavaScript alert处理程序属性。
      ObjectProperty<EventHandler<WebEvent<Rectangle2D>>> WebEngine.onResizedProperty​()
      JavaScript窗口调整大小处理程序属性。
      ObjectProperty<EventHandler<WebEvent<String>>> WebEngine.onStatusChangedProperty​()
      JavaScript状态处理程序属性。
      ObjectProperty<EventHandler<WebEvent<Boolean>>> WebEngine.onVisibilityChangedProperty​()
      JavaScript窗口可见性处理器属性。
      Method parameters in javafx.scene.web with type arguments of type WebEvent
      Modifier and Type 方法 描述
      void WebEngine.setOnAlert​(EventHandler<WebEvent<String>> handler)
      设置属性onAlert的值。
      void WebEngine.setOnResized​(EventHandler<WebEvent<Rectangle2D>> handler)
      设置属性onResized的值。
      void WebEngine.setOnStatusChanged​(EventHandler<WebEvent<String>> handler)
      设置属性onStatusChanged的值。
      void WebEngine.setOnVisibilityChanged​(EventHandler<WebEvent<Boolean>> handler)
      设置属性onVisibilityChanged的值。
      Constructor parameters in javafx.scene.web with type arguments of type WebEvent
      Constructor 描述
      WebEvent​(Object source, EventType<WebEvent> type, T data)
      Creates a new event object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.WebHistory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.WebHistory

  • Packages that use WebHistory
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of WebHistory in javafx.scene.web

      Methods in javafx.scene.web that return WebHistory
      Modifier and Type 方法 描述
      WebHistory WebEngine.getHistory​()
      返回会话历史记录对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.WebHistory.Entry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.WebHistory.Entry

  • Packages that use WebHistory.Entry
    软件包 描述
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of WebHistory.Entry in javafx.scene.web

      Methods in javafx.scene.web that return types with arguments of type WebHistory.Entry
      Modifier and Type 方法 描述
      ObservableList<WebHistory.Entry> WebHistory.getEntries​()
      返回历史记录中所有条目的不可修改的可观察列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.scene.web.WebView (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.scene.web.WebView

No usage of javafx.scene.web.WebView
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


DirectoryChooser (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Class DirectoryChooser

  • java.lang.Object
    • javafx.stage.DirectoryChooser

  • public final class DirectoryChooser
extends Object
    提供对标准目录选择器对话框的支持。 这些对话框具有独立于JavaFX的平台UI组件的外观和感觉。 在某些可能限制文件访问或不属于用户模型（例如某些移动或嵌入式设备）的平台上，打开目录对话框可能总是导致无操作（即返回空文件）。
    从以下版本开始：
    JavaFX 2.1

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<File> initialDirectory
      显示对话框的初始目录。
      StringProperty title
      显示对话框的标题。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DirectoryChooser​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      File getInitialDirectory​()
      获取属性initialDirectory的值。
      String getTitle​()
      获取属性标题的值。
      ObjectProperty<File> initialDirectoryProperty​()
      显示对话框的初始目录。
      void setInitialDirectory​(File value)
      设置属性initialDirectory的值。
      void setTitle​(String value)
      设置属性标题的值。
      File showDialog​(Window ownerWindow)
      显示新的目录选择对话框。
      StringProperty titleProperty​()
      显示对话框的标题。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • title

        public final StringProperty titleProperty
        显示对话框的标题。
        另请参见：
        getTitle() ， setTitle(String)

      • initialDirectory

        public final ObjectProperty<File> initialDirectoryProperty
        显示对话框的初始目录。
        另请参见：
        getInitialDirectory() ， setInitialDirectory(File)

    • 构造方法详细信息

      • DirectoryChooser

        public DirectoryChooser​()

    • 方法详细信息

      • setTitle

        public final void setTitle​(String value)
        设置属性标题的值。
        Property description:
        显示对话框的标题。

      • getTitle

        public final String getTitle​()
        获取属性标题的值。
        Property description:
        显示对话框的标题。

      • titleProperty

        public final StringProperty titleProperty​()
        显示对话框的标题。
        另请参见：
        getTitle() ， setTitle(String)

      • setInitialDirectory

        public final void setInitialDirectory​(File value)
        设置属性initialDirectory的值。
        Property description:
        显示对话框的初始目录。

      • getInitialDirectory

        public final File getInitialDirectory​()
        获取属性initialDirectory的值。
        Property description:
        显示对话框的初始目录。

      • initialDirectoryProperty

        public final ObjectProperty<File> initialDirectoryProperty​()
        显示对话框的初始目录。
        另请参见：
        getInitialDirectory() ， setInitialDirectory(File)

      • showDialog

        public File showDialog​(Window ownerWindow)
        显示新的目录选择对话框。 该方法直到显示的对话框被关闭才返回。 返回值指定用户选择的目录，如果没有选择，则指定null 。 如果设置了目录选择对话框的所有者窗口，则在显示对话框时，将阻止对话框所有者链中所有窗口的输入。
        参数
        ownerWindow - 显示对话框的所有者窗口
        结果
        所选目录或 null如果没有选择目录
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileChooser (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Class FileChooser

  • java.lang.Object
    • javafx.stage.FileChooser

  • public final class FileChooser
extends Object
    提供对标准平台文件对话框的支持。 这些对话框具有独立于JavaFX的平台UI组件的外观和感觉。

    在某些可能限制文件访问或不是用户模型的一部分（例如，某些移动或嵌入式设备）的平台上，打开文件对话框可能总是导致无操作（即，空文件是回）。

    A FileChooser可用于调用文件打开对话框，用于选择单个文件（ showOpenDialog ），用于选择多个文件的文件打开对话框（ showOpenMultipleDialog ）和文件保存对话框（ showSaveDialog ）。 显示对话框的配置由调用相应的show*Dialog方法之前设置的FileChooser属性的值控制。 此配置包括对话框的标题，对话框中显示的初始目录和列出的文件的扩展过滤器。 对于尚未明确设置值的配置属性，显示的对话框使用其平台默认值。 调用show对话框方法将被阻止，直到用户选择或取消对话框为止。 如果对话框被取消，则返回值指定所选文件或等于null 。

    例：

       FileChooser fileChooser = new FileChooser(); fileChooser.setTitle("Open Resource File"); fileChooser.getExtensionFilters().addAll( new ExtensionFilter("Text Files", "*.txt"), new ExtensionFilter("Image Files", "*.png", "*.jpg", "*.gif"), new ExtensionFilter("Audio Files", "*.wav", "*.mp3", "*.aac"), new ExtensionFilter("All Files", "*.*")); File selectedFile = fileChooser.showOpenDialog(mainStage); if (selectedFile != null) { mainStage.display(selectedFile); }
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<File> initialDirectory
      显示文件对话框的初始目录。
      ObjectProperty<String> initialFileName
      显示对话框的初始文件名。
      ObjectProperty<FileChooser.ExtensionFilter> selectedExtensionFilter
      此属性用于为下一个显示的对话框预先选择扩展过滤器，并从被忽略的对话框中读取用户选择的扩展过滤器。
      StringProperty title
      显示文件对话框的标题。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  FileChooser.ExtensionFilter
      定义一个扩展过滤器，用于过滤可以在FileDialog中根据文件扩展名选择哪些文件。

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileChooser​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<FileChooser.ExtensionFilter> getExtensionFilters​()
      获取显示文件对话框中使用的扩展过滤器。
      File getInitialDirectory​()
      获取属性initialDirectory的值。
      String getInitialFileName​()
      获取属性initialFileName的值。
      FileChooser.ExtensionFilter getSelectedExtensionFilter​()
      获取selectedExtensionFilter属性的值。
      String getTitle​()
      获取属性标题的值。
      ObjectProperty<File> initialDirectoryProperty​()
      显示文件对话框的初始目录。
      ObjectProperty<String> initialFileNameProperty​()
      显示对话框的初始文件名。
      ObjectProperty<FileChooser.ExtensionFilter> selectedExtensionFilterProperty​()
      此属性用于为下一个显示的对话框预先选择扩展过滤器，并从被忽略的对话框中读取用户选择的扩展过滤器。
      void setInitialDirectory​(File value)
      设置属性initialDirectory的值。
      void setInitialFileName​(String value)
      设置属性initialFileName的值。
      void setSelectedExtensionFilter​(FileChooser.ExtensionFilter filter)
      设置属性selectedExtensionFilter的值。
      void setTitle​(String value)
      设置属性标题的值。
      File showOpenDialog​(Window ownerWindow)
      显示一个新的文件打开对话框。
      List<File> showOpenMultipleDialog​(Window ownerWindow)
      显示一个新的文件打开对话框，其中可以选择多个文件。
      File showSaveDialog​(Window ownerWindow)
      显示一个新的文件保存对话框。
      StringProperty titleProperty​()
      显示文件对话框的标题。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • title

        public final StringProperty titleProperty
        显示文件对话框的标题。
        另请参见：
        getTitle() ， setTitle(String)

      • initialDirectory

        public final ObjectProperty<File> initialDirectoryProperty
        显示文件对话框的初始目录。
        另请参见：
        getInitialDirectory() ， setInitialDirectory(File)

      • initialFileName

        public final ObjectProperty<String> initialFileNameProperty
        显示对话框的初始文件名。

        此属性主要用于显示的文件保存对话框作为要保存的文件的初始文件名。 如果设置为文件打开对话框，则只有在相应的平台在其文件打开对话框中提供对此类属性的支持时，才会对显示的对话框产生任何影响。

        从以下版本开始：
        JavaFX 2.2.40
        另请参见：
        getInitialFileName() ， setInitialFileName(String)

      • selectedExtensionFilter

        public final ObjectProperty<FileChooser.ExtensionFilter> selectedExtensionFilterProperty
        此属性用于为下一个显示的对话框预先选择扩展过滤器，并从被忽略的对话框中读取用户选择的扩展过滤器。

        当显示文件对话框时，将选中selectedExtensionFilter。 如果selectedExtensionFilter的值为null或不包含在扩展过滤器列表中，则将选择扩展名过滤器列表中的第一个扩展过滤器。 否则，将激活指定的selectedExtensionFilter。

        关闭对话框后，此属性的值将更新为与对话框中的用户选定的扩展过滤器相匹配。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getSelectedExtensionFilter() ， setSelectedExtensionFilter(FileChooser.ExtensionFilter)

    • 构造方法详细信息

      • FileChooser

        public FileChooser​()

    • 方法详细信息

      • setTitle

        public final void setTitle​(String value)
        设置属性标题的值。
        Property description:
        显示文件对话框的标题。

      • getTitle

        public final String getTitle​()
        获取属性标题的值。
        Property description:
        显示文件对话框的标题。

      • titleProperty

        public final StringProperty titleProperty​()
        显示文件对话框的标题。
        另请参见：
        getTitle() ， setTitle(String)

      • setInitialDirectory

        public final void setInitialDirectory​(File value)
        设置属性initialDirectory的值。
        Property description:
        显示文件对话框的初始目录。

      • getInitialDirectory

        public final File getInitialDirectory​()
        获取属性initialDirectory的值。
        Property description:
        显示文件对话框的初始目录。

      • initialDirectoryProperty

        public final ObjectProperty<File> initialDirectoryProperty​()
        显示文件对话框的初始目录。
        另请参见：
        getInitialDirectory() ， setInitialDirectory(File)

      • setInitialFileName

        public final void setInitialFileName​(String value)
        设置属性initialFileName的值。
        Property description:
        显示对话框的初始文件名。

        此属性主要用于显示的文件保存对话框作为要保存的文件的初始文件名。 如果设置为文件打开对话框，则只有在相应的平台在其文件打开对话框中提供对此类属性的支持时，才会对显示的对话框产生任何影响。

        从以下版本开始：
        JavaFX 2.2.40

      • getInitialFileName

        public final String getInitialFileName​()
        获取属性initialFileName的值。
        Property description:
        显示对话框的初始文件名。

        此属性主要用于显示的文件保存对话框作为要保存的文件的初始文件名。 如果设置为文件打开对话框，则只有在相应的平台在其文件打开对话框中提供对此类属性的支持时，才会对显示的对话框产生任何影响。

        从以下版本开始：
        JavaFX 2.2.40

      • initialFileNameProperty

        public final ObjectProperty<String> initialFileNameProperty​()
        显示对话框的初始文件名。

        此属性主要用于显示的文件保存对话框作为要保存的文件的初始文件名。 如果设置为文件打开对话框，则只有在相应的平台在其文件打开对话框中提供对此类属性的支持时，才会对显示的对话框产生任何影响。

        从以下版本开始：
        JavaFX 2.2.40
        另请参见：
        getInitialFileName() ， setInitialFileName(String)

      • getExtensionFilters

        public ObservableList<FileChooser.ExtensionFilter> getExtensionFilters​()
        获取显示文件对话框中使用的扩展过滤器。 列表中只有一个扩展过滤器在显示的对话框中随时处于活动状态，并且仅显示与此扩展过滤器对应的文件。 列表中的第一个扩展过滤器在对话框被调用时被激活。 然后，用户可以从列表中将活动扩展过滤器切换到任何其他扩展过滤器，并以这种方式控制显示文件的集合。
        结果
        此对话框中使用的扩展过滤器的可观察列表

      • selectedExtensionFilterProperty

        public final ObjectProperty<FileChooser.ExtensionFilter> selectedExtensionFilterProperty​()
        此属性用于为下一个显示的对话框预先选择扩展过滤器，并从被忽略的对话框中读取用户选择的扩展过滤器。

        当显示文件对话框时，将选中selectedExtensionFilter。 如果selectedExtensionFilter的值为null或不包含在扩展过滤器列表中，则将选择扩展名过滤器列表中的第一个扩展过滤器。 否则，将激活指定的selectedExtensionFilter。

        关闭对话框后，此属性的值将更新为与对话框中的用户选定的扩展过滤器相匹配。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getSelectedExtensionFilter() ， setSelectedExtensionFilter(FileChooser.ExtensionFilter)

      • setSelectedExtensionFilter

        public final void setSelectedExtensionFilter​(FileChooser.ExtensionFilter filter)
        设置属性selectedExtensionFilter的值。
        Property description:
        此属性用于为下一个显示的对话框预先选择扩展过滤器，并从被忽略的对话框中读取用户选择的扩展过滤器。

        当显示文件对话框时，将选中selectedExtensionFilter。 如果selectedExtensionFilter的值为null或不包含在扩展过滤器列表中，则将选择扩展名过滤器列表中的第一个扩展过滤器。 否则，将激活指定的selectedExtensionFilter。

        关闭对话框后，此属性的值将更新为与对话框中的用户选定的扩展过滤器相匹配。

        从以下版本开始：
        JavaFX 8.0

      • getSelectedExtensionFilter

        public final FileChooser.ExtensionFilter getSelectedExtensionFilter​()
        获取selectedExtensionFilter属性的值。
        Property description:
        此属性用于为下一个显示的对话框预先选择扩展过滤器，并从被忽略的对话框中读取用户选择的扩展过滤器。

        当显示文件对话框时，将选中selectedExtensionFilter。 如果selectedExtensionFilter的值为null或不包含在扩展过滤器列表中，则将选择扩展名过滤器列表中的第一个扩展过滤器。 否则，将激活指定的selectedExtensionFilter。

        关闭对话框后，此属性的值将更新为与对话框中的用户选定的扩展过滤器相匹配。

        从以下版本开始：
        JavaFX 8.0

      • showOpenDialog

        public File showOpenDialog​(Window ownerWindow)
        显示一个新的文件打开对话框。 该方法不会返回，直到显示的打开的对话框被关闭。 返回值指定用户选择的文件或null如果未选择）。 如果设置了文件对话框的所有者窗口，则在显示文件对话框时，将阻止对话框所有者链中所有窗口的输入。
        参数
        ownerWindow - 显示文件对话框的所有者窗口
        结果
        所选文件或 null如果没有选择文件）

      • showOpenMultipleDialog

        public List<File> showOpenMultipleDialog​(Window ownerWindow)
        显示一个新的文件打开对话框，其中可以选择多个文件。 该方法不会返回，直到显示的打开的对话框被关闭。 返回值指定用户选择的文件或null如果没有进行选择。 如果设置了文件对话框的所有者窗口，则在显示文件对话框时，将阻止对话框所有者链中所有窗口的输入。

        返回的列表是不可修改的，每次修改尝试都会抛出UnsupportedOperationException 。

        参数
        ownerWindow - 显示文件对话框的所有者窗口
        结果
        所选文件或 null如果没有选择文件

      • showSaveDialog

        public File showSaveDialog​(Window ownerWindow)
        显示一个新的文件保存对话框。 直到显示的文件保存对话框被关闭时，该方法才会返回。 返回值指定用户选择的文件或null如果没有进行选择。 如果设置了文件对话框的所有者窗口，则在显示文件对话框时，将阻止对话框所有者链中所有窗口的输入。
        参数
        ownerWindow - 显示文件对话框的所有者窗口
        结果
        所选文件或 null如果没有选择文件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileChooser.ExtensionFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Class FileChooser.ExtensionFilter

  • java.lang.Object
    • javafx.stage.FileChooser.ExtensionFilter
  • Enclosing class:
    FileChooser

    public static final class FileChooser.ExtensionFilter
extends Object
    定义一个扩展过滤器，用于过滤可以在FileDialog中根据文件扩展名选择哪些文件。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ExtensionFilter​(String description, String... extensions)
      创建一个具有指定描述和文件扩展名的 ExtensionFilter 。
      ExtensionFilter​(String description, List<String> extensions)
      创建一个具有指定描述和文件扩展名的 ExtensionFilter 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getDescription​()
      获取此 ExtensionFilter的描述。
      List<String> getExtensions​()
      获取此 ExtensionFilter的文件扩展名。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ExtensionFilter

        public ExtensionFilter​(String description,
                       String... extensions)
        创建一个具有指定描述和文件扩展名的ExtensionFilter 。

        文件扩展名应以*.<extension>格式指定。

        参数
        description - 过滤器的文本描述
        extensions - 接受的文件扩展名
        异常
        NullPointerException - 如果描述或扩展名是 null
        IllegalArgumentException - 如果描述或扩展名为空

      • ExtensionFilter

        public ExtensionFilter​(String description,
                       List<String> extensions)
        创建一个具有指定描述和文件扩展名的ExtensionFilter 。

        文件扩展名应以*.<extension>格式指定。

        参数
        description - 过滤器的文本描述
        extensions - 接受的文件扩展名
        异常
        NullPointerException - 如果描述或扩展名是 null
        IllegalArgumentException - 如果描述或扩展名为空

    • 方法详细信息

      • getDescription

        public String getDescription​()
        获取此 ExtensionFilter的说明。
        结果
        说明

      • getExtensions

        public List<String> getExtensions​()
        获取此ExtensionFilter的文件扩展名。

        返回的列表是不可修改的，每次修改尝试都会抛出UnsupportedOperationException 。

        结果
        文件扩展名
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.stage (Java SE 9 & JDK 9 )

javafx.stage

Classes

  • DirectoryChooser
  • FileChooser
  • FileChooser.ExtensionFilter
  • Popup
  • PopupWindow
  • Screen
  • Stage
  • Window
  • WindowEvent

Enums

  • Modality
  • PopupWindow.AnchorLocation
  • StageStyle


javafx.stage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.graphics

Package javafx.stage

提供JavaFX内容的顶级容器类。

  • 类摘要
    Class 描述
    DirectoryChooser
    提供对标准目录选择器对话框的支持。
    FileChooser
    提供对标准平台文件对话框的支持。
    FileChooser.ExtensionFilter
    定义一个扩展过滤器，用于过滤可以在FileDialog中根据文件扩展名选择哪些文件。
    Popup
    弹出窗口是用于场景图形的特殊的类似窗口的容器。
    PopupWindow
    PopupWindow是各种不同类型的基于弹出窗口的窗口的父级，包括Popup和Tooltip和ContextMenu 。
    Screen
    描述诸如监视器之类的图形目的地的特征。
    Stage
    JavaFX Stage类是顶级的JavaFX容器。
    Window
    托管场景的顶层窗口，用户与之交互的顶级窗口。
    WindowEvent
    与窗口显示/隐藏操作相关的事件。
  • 枚举摘要
    Enum 描述
    Modality
    该枚举定义了一个 Stage的可能的模式类型。
    PopupWindow.AnchorLocation
    锚定点选择的锚位置常数。
    StageStyle
    This enum defines the possible styles for a Stage.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.stage Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.stage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.stage.DirectoryChooser
    • java.util.EventObject (implements java.io.Serializable)
      • javafx.event.Event (implements java.lang.Cloneable)
        • javafx.stage.WindowEvent
    • javafx.stage.FileChooser
    • javafx.stage.FileChooser.ExtensionFilter
    • javafx.stage.Screen
    • javafx.stage.Window (implements javafx.event.EventTarget)
      • javafx.stage.PopupWindow
        • javafx.stage.Popup
      • javafx.stage.Stage

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javafx.stage.Modality
      • javafx.stage.PopupWindow.AnchorLocation
      • javafx.stage.StageStyle
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Modality (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Enum Modality

  • java.lang.Object
    • java.lang.Enum<Modality>
      • javafx.stage.Modality
  • All Implemented Interfaces:
    Serializable ， Comparable<Modality>

    public enum Modality
extends Enum<Modality>
    该枚举定义了一个 Stage的可能的模式类型。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APPLICATION_MODAL
      定义阻止事件传递到任何其他应用程序窗口的模态窗口。
      NONE
      定义不是模态的顶级窗口，并且不会阻止任何其他窗口。
      WINDOW_MODAL
      定义一个模态窗口，阻止事件传递到其整个所有者窗口层次结构。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Modality valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Modality[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NONE

        public static final Modality NONE
        定义不是模态的顶级窗口，并且不会阻止任何其他窗口。

      • WINDOW_MODAL

        public static final Modality WINDOW_MODAL
        定义一个模态窗口，阻止事件传递到其整个所有者窗口层次结构。 注意：模式设置为WINDOW_MODAL但其所有者为空的阶段被视为其模态设置为NONE。

      • APPLICATION_MODAL

        public static final Modality APPLICATION_MODAL
        定义阻止事件传递到任何其他应用程序窗口的模态窗口。

    • 方法详细信息

      • values

        public static Modality[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Modality c : Modality.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Modality valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Popup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Class Popup

  • java.lang.Object
    • javafx.stage.Window
      • javafx.stage.PopupWindow
        • javafx.stage.Popup
  • All Implemented Interfaces:
    EventTarget

    public class Popup
extends PopupWindow
    弹出窗口是用于场景图形的特殊的类似窗口的容器。 它通常用于工具提示，如通知，下拉框，菜单等。 弹出窗口没有装饰，并且基本上作为一个没有装饰的专用场景/窗口，是透明的，并且填充空白。
    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      • Properties inherited from class javafx.stage.PopupWindow

        anchorLocation, anchorX, anchorY, autoFix, autoHide, consumeAutoHidingEvents, hideOnEscape, onAutoHide, ownerNode, ownerWindow

      • Properties inherited from class javafx.stage.Window

        eventDispatcher, focused, forceIntegerRenderScale, height, onCloseRequest, onHidden, onHiding, onShowing, onShown, opacity, outputScaleX, outputScaleY, renderScaleX, renderScaleY, scene, showing, width, x, y

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javafx.stage.PopupWindow

        PopupWindow.AnchorLocation

    • 构造方法摘要

      构造方法
      Constructor 描述
      Popup​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObservableList<Node> getContent​()
      Node的ObservableList将在此 Popup上呈现。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.stage.PopupWindow

        anchorLocationProperty, anchorXProperty, anchorYProperty, autoFixProperty, autoHideProperty, consumeAutoHidingEventsProperty, getAnchorLocation, getAnchorX, getAnchorY, getConsumeAutoHidingEvents, getOnAutoHide, getOwnerNode, getOwnerWindow, hide, hideOnEscapeProperty, isAutoFix, isAutoHide, isHideOnEscape, onAutoHideProperty, ownerNodeProperty, ownerWindowProperty, setAnchorLocation, setAnchorX, setAnchorY, setAutoFix, setAutoHide, setConsumeAutoHidingEvents, setHideOnEscape, setOnAutoHide, setScene, show, show, show

      • Methods inherited from class javafx.stage.Window

        addEventFilter, addEventHandler, buildEventDispatchChain, centerOnScreen, eventDispatcherProperty, fireEvent, focusedProperty, forceIntegerRenderScaleProperty, getEventDispatcher, getHeight, getOnCloseRequest, getOnHidden, getOnHiding, getOnShowing, getOnShown, getOpacity, getOutputScaleX, getOutputScaleY, getProperties, getRenderScaleX, getRenderScaleY, getScene, getUserData, getWidth, getWindows, getX, getY, hasProperties, heightProperty, isFocused, isForceIntegerRenderScale, isShowing, onCloseRequestProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, opacityProperty, outputScaleXProperty, outputScaleYProperty, removeEventFilter, removeEventHandler, renderScaleXProperty, renderScaleYProperty, requestFocus, sceneProperty, setEventDispatcher, setEventHandler, setForceIntegerRenderScale, setHeight, setOnCloseRequest, setOnHidden, setOnHiding, setOnShowing, setOnShown, setOpacity, setRenderScaleX, setRenderScaleY, setUserData, setWidth, setX, setY, show, showingProperty, sizeToScene, widthProperty, xProperty, yProperty

    • 构造方法详细信息

      • Popup

        public Popup​()

    • 方法详细信息

      • getContent

        public final ObservableList<Node> getContent​()
        Node的ObservableList将在此Popup上呈现。 内容形成弹出窗口的完整视觉表示。 弹出窗口没有内在的视觉效果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PopupWindow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Class PopupWindow

  • java.lang.Object
    • javafx.stage.Window
      • javafx.stage.PopupWindow
  • All Implemented Interfaces:
    EventTarget
    已知直接子类：
    Popup ， PopupControl

    public abstract class PopupWindow
extends Window
    PopupWindow是各种不同类型的基于弹出窗口的窗口的父级，包括Popup和Tooltip和ContextMenu 。

    PopupWindow是没有窗口装饰或标题栏的辅助窗口。 它不会在操作系统中显示为顶级窗口。 它通常用于工具提示，如通知，下拉框，菜单等。

    如果没有所有者，则无法显示 PopupWindow。 PopupWindows要求存在所有者窗口才能显示。 但是，可以提前创建一个PopupWindow，并且在首次显示之前只需设置所有者（或更改所有者）即可。 当PopupWindow可见时，尝试更改所有者将导致IllegalStateException。

    PopupWindow封装了弹出窗口常用的大部分行为和功能，例如按下“esc”键时关闭的能力，或者隐藏所有窗口时隐藏所有子弹出窗口的功能。 这些功能可以通过属性启用或禁用。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<PopupWindow.AnchorLocation> anchorLocation
      指定弹出式定位中使用的弹出式锚点。
      ReadOnlyDoubleProperty anchorX
      指定屏幕上弹出锚点的x坐标。
      ReadOnlyDoubleProperty anchorY
      指定屏幕上弹出锚点的y坐标。
      BooleanProperty autoFix
      这个便利变量指示当显示弹出窗口时，是否应自动更正其位置，使其不会最终定位在屏幕外。
      BooleanProperty autoHide
      指定弹出窗口是否应该自动隐藏。
      BooleanProperty consumeAutoHidingEvents
      指定是否应该使用引起Popup隐藏的事件。
      BooleanProperty hideOnEscape
      指定在弹出对焦时按下未处理的转义键时是否应该隐藏PopupWindow。
      ObjectProperty<EventHandler<Event>> onAutoHide
      autoHide运行后调用。
      ReadOnlyObjectProperty<Node> ownerNode
      该弹出窗口的所有者的节点。
      ReadOnlyObjectProperty<Window> ownerWindow
      作为此弹出窗口的父窗口。

      • Properties inherited from class javafx.stage.Window

        eventDispatcher, focused, forceIntegerRenderScale, height, onCloseRequest, onHidden, onHiding, onShowing, onShown, opacity, outputScaleX, outputScaleY, renderScaleX, renderScaleY, scene, showing, width, x, y

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  PopupWindow.AnchorLocation
      锚定点选择的锚位置常数。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PopupWindow​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectProperty<PopupWindow.AnchorLocation> anchorLocationProperty​()
      指定弹出式定位中使用的弹出式锚点。
      ReadOnlyDoubleProperty anchorXProperty​()
      指定屏幕上弹出锚点的x坐标。
      ReadOnlyDoubleProperty anchorYProperty​()
      指定屏幕上弹出锚点的y坐标。
      BooleanProperty autoFixProperty​()
      这个便利变量指示当显示弹出窗口时，是否应自动更正其位置，使其不会最终定位在屏幕外。
      BooleanProperty autoHideProperty​()
      指定弹出窗口是否应该自动隐藏。
      BooleanProperty consumeAutoHidingEventsProperty​()
      指定是否应该使用引起Popup隐藏的事件。
      PopupWindow.AnchorLocation getAnchorLocation​()
      获取属性anchorLocation的值。
      double getAnchorX​()
      获取属性anchorX的值。
      double getAnchorY​()
      获取属性anchorY的值。
      boolean getConsumeAutoHidingEvents​()
      获取属性consumeAutoHidingEvents的值。
      EventHandler<Event> getOnAutoHide​()
      获取属性onAutoHide的值。
      Node getOwnerNode​()
      获取属性ownerNode的值。
      Window getOwnerWindow​()
      获取属性ownerWindow的值。
      void hide​()
      隐藏此弹出窗口及其所有子项
      BooleanProperty hideOnEscapeProperty​()
      指定在弹出对焦时按下未处理的转义键时是否应该隐藏PopupWindow。
      boolean isAutoFix​()
      获取属性autoFix的值。
      boolean isAutoHide​()
      获取属性autoHide的值。
      boolean isHideOnEscape​()
      获取属性hideOnEscape的值。
      ObjectProperty<EventHandler<Event>> onAutoHideProperty​()
      autoHide运行后调用。
      ReadOnlyObjectProperty<Node> ownerNodeProperty​()
      该弹出窗口的所有者的节点。
      ReadOnlyObjectProperty<Window> ownerWindowProperty​()
      作为此弹出窗口的父窗口。
      void setAnchorLocation​(PopupWindow.AnchorLocation value)
      设置属性anchorLocation的值。
      void setAnchorX​(double value)
      设置属性anchorX的值。
      void setAnchorY​(double value)
      设置属性anchorY的值。
      void setAutoFix​(boolean value)
      设置属性autoFix的值。
      void setAutoHide​(boolean value)
      设置属性autoHide的值。
      void setConsumeAutoHidingEvents​(boolean value)
      设置属性consumeAutoHidingEvents的值。
      void setHideOnEscape​(boolean value)
      设置属性hideOnEscape的值。
      void setOnAutoHide​(EventHandler<Event> value)
      设置属性onAtotoHide的值。
      protected void setScene​(Scene scene)
      注意子类：PopupWindow使用的场景是非常具体由PopupWindow管理的。
      void show​(Node ownerNode, double anchorX, double anchorY)
      显示屏幕上指定位置的弹出窗口。
      void show​(Window owner)
      显示弹出窗口。
      void show​(Window ownerWindow, double anchorX, double anchorY)
      显示屏幕上指定位置的弹出窗口。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.stage.Window

        addEventFilter, addEventHandler, buildEventDispatchChain, centerOnScreen, eventDispatcherProperty, fireEvent, focusedProperty, forceIntegerRenderScaleProperty, getEventDispatcher, getHeight, getOnCloseRequest, getOnHidden, getOnHiding, getOnShowing, getOnShown, getOpacity, getOutputScaleX, getOutputScaleY, getProperties, getRenderScaleX, getRenderScaleY, getScene, getUserData, getWidth, getWindows, getX, getY, hasProperties, heightProperty, isFocused, isForceIntegerRenderScale, isShowing, onCloseRequestProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, opacityProperty, outputScaleXProperty, outputScaleYProperty, removeEventFilter, removeEventHandler, renderScaleXProperty, renderScaleYProperty, requestFocus, sceneProperty, setEventDispatcher, setEventHandler, setForceIntegerRenderScale, setHeight, setOnCloseRequest, setOnHidden, setOnHiding, setOnShowing, setOnShown, setOpacity, setRenderScaleX, setRenderScaleY, setUserData, setWidth, setX, setY, show, showingProperty, sizeToScene, widthProperty, xProperty, yProperty

    • Property Detail

      • ownerWindow

        public final ReadOnlyObjectProperty<Window> ownerWindowProperty
        作为此弹出窗口的父窗口。 所有弹出窗口必须有一个所有者窗口。
        另请参见：
        getOwnerWindow()

      • ownerNode

        public final ReadOnlyObjectProperty<Node> ownerNodeProperty
        该弹出窗口的所有者的节点。 所有弹出窗口必须具有所有者窗口，但不需要与所有者节点相关联。 如果自动隐藏弹出窗口具有所有者节点，则所有者节点内的鼠标按键不会导致弹出窗口隐藏。
        另请参见：
        getOwnerNode()

      • autoFix

        public final BooleanProperty autoFixProperty
        这个便利变量指示当显示弹出窗口时，是否应自动更正其位置，使其不会最终定位在屏幕外。
        Default value:
        真正
        另请参见：
        isAutoFix() ， setAutoFix(boolean)

      • autoHide

        public final BooleanProperty autoHideProperty
        指定弹出窗口是否应该自动隐藏。 如果弹出窗口失去焦点，并且autoHide为true，则弹出窗口将被自动隐藏。

        唯一的例外是使用show(javafx.scene.Node, double, double)指定了所有者节点。 聚焦所有者Node不会隐藏PopupWindow。

        Default value:
        假
        另请参见：
        isAutoHide() ， setAutoHide(boolean)

      • onAutoHide

        public final ObjectProperty<EventHandler<Event>> onAutoHideProperty
        autoHide运行后调用。
        另请参见：
        getOnAutoHide() ， setOnAutoHide(EventHandler)

      • hideOnEscape

        public final BooleanProperty hideOnEscapeProperty
        指定在弹出对焦时按下未处理的转义键时是否应该隐藏PopupWindow。
        Default value:
        真正
        另请参见：
        isHideOnEscape() ， setHideOnEscape(boolean)

      • consumeAutoHidingEvents

        public final BooleanProperty consumeAutoHidingEventsProperty
        指定是否应该使用引起Popup隐藏的事件。 使用该事件阻止它在弹出窗口的所有者窗口中触发一些额外的UI响应。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getConsumeAutoHidingEvents() ， setConsumeAutoHidingEvents(boolean)

      • anchorX

        public final ReadOnlyDoubleProperty anchorXProperty
        指定屏幕上弹出锚点的x坐标。 如果anchorLocation设置为WINDOW_TOP_LEFT或WINDOW_BOTTOM_LEFT则x和anchorX值将相同。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getAnchorX() ， setAnchorX(double)

      • anchorY

        public final ReadOnlyDoubleProperty anchorYProperty
        指定屏幕上弹出锚点的y坐标。 如果anchorLocation设置为WINDOW_TOP_LEFT或WINDOW_TOP_RIGHT则y和anchorY值将相同。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getAnchorY() ， setAnchorY(double)

      • anchorLocation

        public final ObjectProperty<PopupWindow.AnchorLocation> anchorLocationProperty
        指定弹出式定位中使用的弹出式锚点。 该点可以设置为弹出窗口的一角或其内容的一角。 在这种情况下，内容角是从弹出根节点的布局边界导出的。

        一般来说，锚定位置的更改不会改变当前的窗口位置。 而不是这样， anchorX和anchorY值被重新计算以对应于新的锚点。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getAnchorLocation() ， setAnchorLocation(PopupWindow.AnchorLocation)

    • 构造方法详细信息

      • PopupWindow

        public PopupWindow​()

    • 方法详细信息

      • getOwnerWindow

        public final Window getOwnerWindow​()
        获取属性ownerWindow的值。
        Property description:
        作为此弹出窗口的父窗口。 所有弹出窗口必须有一个所有者窗口。

      • ownerWindowProperty

        public final ReadOnlyObjectProperty<Window> ownerWindowProperty​()
        作为此弹出窗口的父窗口。 所有弹出窗口必须有一个所有者窗口。
        另请参见：
        getOwnerWindow()

      • getOwnerNode

        public final Node getOwnerNode​()
        获取属性ownerNode的值。
        Property description:
        该弹出窗口的所有者的节点。 所有弹出窗口必须具有所有者窗口，但不需要与所有者节点相关联。 如果自动隐藏弹出窗口具有所有者节点，则所有者节点内的鼠标按键不会导致弹出窗口隐藏。

      • ownerNodeProperty

        public final ReadOnlyObjectProperty<Node> ownerNodeProperty​()
        该弹出窗口的所有者的节点。 所有弹出窗口必须具有所有者窗口，但不需要与所有者节点相关联。 如果自动隐藏弹出窗口具有所有者节点，则所有者节点内的鼠标按键不会导致弹出窗口隐藏。
        另请参见：
        getOwnerNode()

      • setScene

        protected final void setScene​(Scene scene)
        注意子类：PopupWindow使用的场景是非常具体由PopupWindow管理的。 该方法被覆盖以抛出UnsupportedOperationException。 您不能指定自己的场景。
        重写：
        setScene在 Window
        参数
        scene - 要在此窗口中呈现的场景

      • setAutoFix

        public final void setAutoFix​(boolean value)
        设置属性autoFix的值。
        Property description:
        这个便利变量指示当显示弹出窗口时，是否应自动更正其位置，使其不会最终定位在屏幕外。
        Default value:
        真正

      • isAutoFix

        public final boolean isAutoFix​()
        获取属性autoFix的值。
        Property description:
        这个便利变量指示当显示弹出窗口时，是否应自动更正其位置，使其不会最终定位在屏幕外。
        Default value:
        真正

      • autoFixProperty

        public final BooleanProperty autoFixProperty​()
        这个便利变量指示当显示弹出窗口时，是否应自动更正其位置，使其不会最终定位在屏幕外。
        Default value:
        真正
        另请参见：
        isAutoFix() ， setAutoFix(boolean)

      • setAutoHide

        public final void setAutoHide​(boolean value)
        设置属性autoHide的值。
        Property description:
        指定弹出窗口是否应该自动隐藏。 如果弹出窗口失去焦点，并且autoHide为true，则弹出窗口将被自动隐藏。

        唯一的例外是使用show(javafx.scene.Node, double, double)指定了所有者节点。 聚焦所有者Node不会隐藏PopupWindow。

        Default value:
        假

      • isAutoHide

        public final boolean isAutoHide​()
        获取属性autoHide的值。
        Property description:
        指定弹出窗口是否应该自动隐藏。 如果弹出窗口失去焦点，并且autoHide为true，则弹出窗口将被自动隐藏。

        唯一的例外是使用show(javafx.scene.Node, double, double)指定了所有者节点。 聚焦所有者Node不会隐藏PopupWindow。

        Default value:
        假

      • autoHideProperty

        public final BooleanProperty autoHideProperty​()
        指定弹出窗口是否应该自动隐藏。 如果弹出窗口失去焦点，并且autoHide为true，则弹出窗口将被自动隐藏。

        唯一的例外是使用show(javafx.scene.Node, double, double)指定了所有者节点。 聚焦所有者Node不会隐藏PopupWindow。

        Default value:
        假
        另请参见：
        isAutoHide() ， setAutoHide(boolean)

      • setOnAutoHide

        public final void setOnAutoHide​(EventHandler<Event> value)
        设置属性onAtotoHide的值。
        Property description:
        autoHide运行后调用。

      • getOnAutoHide

        public final EventHandler<Event> getOnAutoHide​()
        获取属性onAutoHide的值。
        Property description:
        autoHide运行后调用。

      • onAutoHideProperty

        public final ObjectProperty<EventHandler<Event>> onAutoHideProperty​()
        autoHide运行后调用。
        另请参见：
        getOnAutoHide() ， setOnAutoHide(EventHandler)

      • setHideOnEscape

        public final void setHideOnEscape​(boolean value)
        设置属性hideOnEscape的值。
        Property description:
        指定在弹出对焦时按下未处理的转义键时是否应该隐藏PopupWindow。
        Default value:
        真正

      • isHideOnEscape

        public final boolean isHideOnEscape​()
        获取属性hideOnEscape的值。
        Property description:
        指定在弹出对焦时按下未处理的转义键时是否应该隐藏PopupWindow。
        Default value:
        真正

      • hideOnEscapeProperty

        public final BooleanProperty hideOnEscapeProperty​()
        指定在弹出对焦时按下未处理的转义键时是否应该隐藏PopupWindow。
        Default value:
        真正
        另请参见：
        isHideOnEscape() ， setHideOnEscape(boolean)

      • setConsumeAutoHidingEvents

        public final void setConsumeAutoHidingEvents​(boolean value)
        设置属性consumeAutoHidingEvents的值。
        Property description:
        指定是否应该使用引起Popup隐藏的事件。 使用该事件阻止它在弹出窗口的所有者窗口中触发一些额外的UI响应。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2

      • getConsumeAutoHidingEvents

        public final boolean getConsumeAutoHidingEvents​()
        获取属性consumeAutoHidingEvents的值。
        Property description:
        指定是否应该使用引起Popup隐藏的事件。 使用该事件阻止它在弹出窗口的所有者窗口中触发一些额外的UI响应。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2

      • consumeAutoHidingEventsProperty

        public final BooleanProperty consumeAutoHidingEventsProperty​()
        指定是否应该使用引起Popup隐藏的事件。 使用该事件阻止它在弹出窗口的所有者窗口中触发一些额外的UI响应。
        Default value:
        真正
        从以下版本开始：
        JavaFX 2.2
        另请参见：
        getConsumeAutoHidingEvents() ， setConsumeAutoHidingEvents(boolean)

      • show

        public void show​(Window owner)
        显示弹出窗口。
        参数
        owner - 弹出窗口的所有者。 这不能为空。
        异常
        NullPointerException - 如果owner为null
        IllegalArgumentException - 如果指定的所有者窗口将在窗口层次结构中创建循环

      • show

        public void show​(Node ownerNode,
                 double anchorX,
                 double anchorY)
        显示屏幕上指定位置的弹出窗口。 弹出窗口被定位成使得其锚点（ anchorLocation ）以指定的anchorX和anchorY坐标显示。

        弹出窗口与指定的所有者节点相关联。 包含呼叫时所有者节点的Window成为显示弹出窗口的所有者窗口。

        请注意，当autoHideProperty()设置为true时，鼠标按下所有者节点将不会隐藏PopupWindow。

        参数
        ownerNode - 弹出窗口的所有者节点。 它不能为空，必须与窗口相关联。
        anchorX - 弹出式锚点在屏幕坐标中的x位置
        anchorY - 弹出式锚点在屏幕坐标中的y位置
        异常
        NullPointerException - 如果ownerNode为null
        IllegalArgumentException - 如果指定的所有者节点不与窗口相关联，或者窗口将在窗口层次结构中创建循环

      • show

        public void show​(Window ownerWindow,
                 double anchorX,
                 double anchorY)
        显示屏幕上指定位置的弹出窗口。 弹出窗口的定位方式使其锚点（ anchorLocation ）以指定的anchorX和anchorY坐标显示。
        参数
        ownerWindow - 弹出窗口的所有者。 这不能为空。
        anchorX - 弹出锚点在屏幕坐标中的x位置
        anchorY - 弹出锚点在屏幕坐标中的y位置
        异常
        NullPointerException - 如果ownerWindow为空
        IllegalArgumentException - 如果指定的所有者窗口将在窗口层次结构中创建循环

      • hide

        public void hide​()
        隐藏此弹出窗口及其所有子项
        重写：
        hide在 Window

      • setAnchorX

        public final void setAnchorX​(double value)
        设置属性anchorX的值。
        Property description:
        指定屏幕上弹出锚点的x坐标。 如果anchorLocation设置为WINDOW_TOP_LEFT或WINDOW_BOTTOM_LEFT则x和anchorX值将相同。
        从以下版本开始：
        JavaFX 8.0

      • getAnchorX

        public final double getAnchorX​()
        获取属性anchorX的值。
        Property description:
        指定屏幕上弹出锚点的x坐标。 如果anchorLocation设置为WINDOW_TOP_LEFT或WINDOW_BOTTOM_LEFT则x和anchorX值将相同。
        从以下版本开始：
        JavaFX 8.0

      • anchorXProperty

        public final ReadOnlyDoubleProperty anchorXProperty​()
        指定屏幕上弹出锚点的x坐标。 如果anchorLocation设置为WINDOW_TOP_LEFT或WINDOW_BOTTOM_LEFT则x和anchorX值将相同。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getAnchorX() ， setAnchorX(double)

      • setAnchorY

        public final void setAnchorY​(double value)
        设置属性anchorY的值。
        Property description:
        指定屏幕上弹出锚点的y坐标。 如果anchorLocation设置为WINDOW_TOP_LEFT或WINDOW_TOP_RIGHT则y和anchorY值将相同。
        从以下版本开始：
        JavaFX 8.0

      • getAnchorY

        public final double getAnchorY​()
        获取属性anchorY的值。
        Property description:
        指定屏幕上弹出锚点的y坐标。 如果anchorLocation设置为WINDOW_TOP_LEFT或WINDOW_TOP_RIGHT则y和anchorY值将相同。
        从以下版本开始：
        JavaFX 8.0

      • anchorYProperty

        public final ReadOnlyDoubleProperty anchorYProperty​()
        指定屏幕上弹出锚点的y坐标。 如果anchorLocation设置为WINDOW_TOP_LEFT或WINDOW_TOP_RIGHT则y和anchorY值将相同。
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getAnchorY() ， setAnchorY(double)

      • setAnchorLocation

        public final void setAnchorLocation​(PopupWindow.AnchorLocation value)
        设置属性anchorLocation的值。
        Property description:
        指定弹出式定位中使用的弹出式锚点。 该点可以设置为弹出窗口的一角或其内容的一角。 在这种情况下，内容角是从弹出根节点的布局边界导出的。

        一般来说，锚定位置的更改不会改变当前的窗口位置。 而不是这样， anchorX和anchorY值被重新计算以对应于新的锚点。

        从以下版本开始：
        JavaFX 8.0

      • getAnchorLocation

        public final PopupWindow.AnchorLocation getAnchorLocation​()
        获取属性anchorLocation的值。
        Property description:
        指定弹出式定位中使用的弹出式锚点。 该点可以设置为弹出窗口的一角或其内容的一角。 在这种情况下，内容角是从弹出根节点的布局边界导出的。

        一般来说，锚定位置的更改不会改变当前的窗口位置。 而不是这样， anchorX和anchorY值被重新计算以对应于新的锚点。

        从以下版本开始：
        JavaFX 8.0

      • anchorLocationProperty

        public final ObjectProperty<PopupWindow.AnchorLocation> anchorLocationProperty​()
        指定弹出式定位中使用的弹出式锚点。 该点可以设置为弹出窗口的一角或其内容的一角。 在这种情况下，内容角是从弹出根节点的布局边界导出的。

        一般来说，锚定位置的更改不会改变当前的窗口位置。 而不是这样， anchorX和anchorY值被重新计算以对应于新的锚点。

        从以下版本开始：
        JavaFX 8.0
        另请参见：
        getAnchorLocation() ， setAnchorLocation(PopupWindow.AnchorLocation)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PopupWindow.AnchorLocation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Enum PopupWindow.AnchorLocation

  • java.lang.Object
    • java.lang.Enum<PopupWindow.AnchorLocation>
      • javafx.stage.PopupWindow.AnchorLocation
  • All Implemented Interfaces:
    Serializable ， Comparable<PopupWindow.AnchorLocation>
    Enclosing class:
    PopupWindow

    public static enum PopupWindow.AnchorLocation
extends Enum<PopupWindow.AnchorLocation>
    锚定点选择的锚位置常数。
    从以下版本开始：
    JavaFX 8.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CONTENT_BOTTOM_LEFT
      代表左下角的内容。
      CONTENT_BOTTOM_RIGHT
      代表最右下角的内容。
      CONTENT_TOP_LEFT
      代表左上角的角落。
      CONTENT_TOP_RIGHT
      代表右上角的内容。
      WINDOW_BOTTOM_LEFT
      代表左下角的角落。
      WINDOW_BOTTOM_RIGHT
      表示右下角的角落。
      WINDOW_TOP_LEFT
      代表左上角的角落。
      WINDOW_TOP_RIGHT
      代表右上角的角落。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PopupWindow.AnchorLocation valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PopupWindow.AnchorLocation[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • WINDOW_TOP_LEFT

        public static final PopupWindow.AnchorLocation WINDOW_TOP_LEFT
        代表左上角的角落。

      • WINDOW_TOP_RIGHT

        public static final PopupWindow.AnchorLocation WINDOW_TOP_RIGHT
        代表右上角的角落。

      • WINDOW_BOTTOM_LEFT

        public static final PopupWindow.AnchorLocation WINDOW_BOTTOM_LEFT
        代表左下角的角落。

      • WINDOW_BOTTOM_RIGHT

        public static final PopupWindow.AnchorLocation WINDOW_BOTTOM_RIGHT
        表示右下角的角落。

      • CONTENT_TOP_LEFT

        public static final PopupWindow.AnchorLocation CONTENT_TOP_LEFT
        代表左上角的角落。

      • CONTENT_TOP_RIGHT

        public static final PopupWindow.AnchorLocation CONTENT_TOP_RIGHT
        代表右上角的内容。

      • CONTENT_BOTTOM_LEFT

        public static final PopupWindow.AnchorLocation CONTENT_BOTTOM_LEFT
        代表左下角的内容。

      • CONTENT_BOTTOM_RIGHT

        public static final PopupWindow.AnchorLocation CONTENT_BOTTOM_RIGHT
        代表最右下角的内容。

    • 方法详细信息

      • values

        public static PopupWindow.AnchorLocation[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PopupWindow.AnchorLocation c : PopupWindow.AnchorLocation.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PopupWindow.AnchorLocation valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Screen (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Class Screen

  • java.lang.Object
    • javafx.stage.Screen

  • public final class Screen
extends Object
    描述诸如监视器之类的图形目的地的特征。 在桌面区域可跨越多个物理屏幕设备的虚拟设备多屏幕环境中， Screen对象的边界相对于Screen.primary 。

    例如：

       Rectangle2D primaryScreenBounds = Screen.getPrimary().getVisualBounds(); //set Stage boundaries to visible bounds of the main screen stage.setX(primaryScreenBounds.getMinX()); stage.setY(primaryScreenBounds.getMinY()); stage.setWidth(primaryScreenBounds.getWidth()); stage.setHeight(primaryScreenBounds.getHeight()); stage.show();
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      Rectangle2D getBounds​()
      获得这个 Screen的界限。
      double getDpi​()
      获得 Screen的分辨率（每英寸点数）。
      double getOutputScaleX​()
      获取 Screen在水平（ X ）方向的推荐输出比例因子。
      double getOutputScaleY​()
      获取垂直（ Y ）方向的 Screen的推荐输出比例因子。
      static Screen getPrimary​()
      主要 Screen 。
      static ObservableList<Screen> getScreens​()
      当前可用的 Screens的可观察列表。
      static ObservableList<Screen> getScreensForRectangle​(double x, double y, double width, double height)
      返回与所提供的矩形相交的ObservableList为 Screens 。
      static ObservableList<Screen> getScreensForRectangle​(Rectangle2D r)
      返回与所提供的矩形相交的ObservableList为 Screens 。
      Rectangle2D getVisualBounds​()
      获得这个 Screen的视觉界限。
      int hashCode​()
      返回此 Screen对象的哈希码。
      String toString​()
      返回此 Screen对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getPrimary

        public static Screen getPrimary​()
        主要 Screen 。
        结果
        主屏幕

      • getScreens

        public static ObservableList<Screen> getScreens​()
        目前可 Screens列表。
        结果
        当前可用屏幕的可观察列表

      • getScreensForRectangle

        public static ObservableList<Screen> getScreensForRectangle​(double x,
                                                            double y,
                                                            double width,
                                                            double height)
        返回与所提供的矩形相交的ObservableList为 Screens 。
        参数
        x - 指定矩形区域左上角的x坐标
        y - 指定矩形区域左上角的y坐标
        width - 指定矩形区域的宽度
        height - 指定矩形区域的高度
        结果
        一个 Screens的ObservableList，其中 Screen.bounds与提供的矩形相交

      • getScreensForRectangle

        public static ObservableList<Screen> getScreensForRectangle​(Rectangle2D r)
        返回与所提供的矩形相交的ObservableList为 Screens 。
        参数
        r - 指定的 Rectangle2D
        结果
        一个 Screens的可观察 Screens ，其中 Screen.bounds与提供的矩形相交

      • getBounds

        public final Rectangle2D getBounds​()
        获得这个Screen的界限。 这些边界将被调整为outputScale以便调整一个Window与这些边界和outputScale相同的outputScale将这个Screen将覆盖整个屏幕。
        结果
        这个边界 Screen

      • getVisualBounds

        public final Rectangle2D getVisualBounds​()
        获得这个Screen的视觉界限。 这些边界是本地窗口系统中的对象，如任务栏和菜单栏。 这些限制由Screen.bounds包含。
        结果
        这个 Screen的视觉界限

      • getDpi

        public final double getDpi​()
        获得 Screen的分辨率（每英寸点数）。
        结果
        这个 Screen的分辨率

      • getOutputScaleX

        public final double getOutputScaleX​()
        获取Screen的水平（ X ）方向的推荐输出比例因子。 该比例因子应适用于场景，以补偿输出设备的分辨率和观看距离。 视觉范围将相对于此比例因子进行报告。
        结果
        屏幕的推荐输出比例因子。
        从以下版本开始：
        9

      • getOutputScaleY

        public final double getOutputScaleY​()
        获取Screen在垂直（ Y ）方向的推荐输出比例因子。 该比例因子将被应用于场景，以补偿输出设备的分辨率和观看距离。 视觉范围将相对于此比例因子进行报告。
        结果
        屏幕的推荐输出比例因子。
        从以下版本开始：
        9

      • hashCode

        public int hashCode​()
        返回此 Screen对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 Screen对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象等于obj参数; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回此 Screen对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个 Screen对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Stage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Class Stage

  • java.lang.Object
    • javafx.stage.Window
      • javafx.stage.Stage
  • All Implemented Interfaces:
    EventTarget

    public class Stage
extends Window
    JavaFX Stage类是顶级的JavaFX容器。 主要阶段由平台构建。 附加阶段对象可以由应用程序构造。

    必须在JavaFX应用程序线程上构建和修改舞台对象。

    JavaFX应用程序线程是作为JavaFX运行时启动过程的一部分而创建的。 有关更多信息，请参阅Application类和Platform.startup(Runnable)方法。

    许多Stage属性是只读的，因为它们可以由底层平台外部更改，因此不能被绑定。

    样式

    舞台有以下风格之一：

    • StageStyle.DECORATED - 一个坚实的白色背景和平台装饰的舞台。
    • StageStyle.UNDECORATED - 一个坚实的白色背景，没有装饰的舞台。
    • StageStyle.TRANSPARENT - 一个透明背景，没有装饰的舞台。
    • StageStyle.UTILITY - 一个坚实的白色背景和最小平台装饰的舞台。

    必须在舞台可见之前对样式进行初始化。

    在某些平台上，装饰可能无法使用。 例如，在某些移动或嵌入式设备上。 在这些情况下，将接受对装饰或UTILITY窗口的请求，但不会显示装饰。

    所有者

    舞台可以选择拥有所有者窗口。 当窗户是舞台的所有者时，它被认为是舞台的父母。

    所有阶段与父窗口相关联。 拥有的舞台将永远在其父窗口之上。 当父窗口关闭或图标化时，所有拥有的窗口也将受到影响。 所有阶段不能独立图标化。

    所有者必须在舞台可见之前进行初始化。

    情态

    舞台有以下方式之一：

    • Modality.NONE - 不阻止任何其他窗口的阶段。
    • Modality.WINDOW_MODAL - 阻止输入事件从其所有者（父）到其根传送到所有窗口的阶段。 它的根是没有所有者的最接近的祖先窗口。
    • Modality.APPLICATION_MODAL - 阻止输入事件从同一应用程序传递到所有窗口的阶段，除了来自其子层次结构的窗口。

    当一个窗口被模态阶段阻止时，它的Z序相对于它的祖先被保留，并且它没有接收到输入事件和没有窗口激活事件，而是继续动画化并且呈现正常。 请注意，显示模态阶段不一定会阻止来电者。 show()方法立即返回，无论舞台的形态如何。 如果您需要阻止调用方，直到模态阶段被隐藏（关闭），请使用showAndWait()方法。 必须在舞台可见之前初始化模态。

    例：

       import javafx.application.Application; import javafx.scene.Group; import javafx.scene.Scene; import javafx.scene.text.Font; import javafx.scene.text.Text; import javafx.stage.Stage; public class HelloWorld extends Application { @Override public void start(Stage stage) { Text text = new Text(10, 40, "Hello World!"); text.setFont(new Font(40)); Scene scene = new Scene(new Group(text)); stage.setTitle("Welcome to JavaFX!"); stage.setScene(scene); stage.sizeToScene(); stage.show(); } public static void main(String[] args) { Application.launch(args); } }

    在Windows上生成以下内容：

    在Mac OSX上生成以下内容：

    Mac OSX上的JavaFX Stage的可视化渲染

    在Linux上生成以下内容：

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ReadOnlyBooleanProperty alwaysOnTop
      定义这个 Stage是否保持在其他窗口之上。
      ObjectProperty<String> fullScreenExitHint
      ObjectProperty<KeyCombination> fullScreenExitKey
      获取全屏幕退出组合键的属性。
      ReadOnlyBooleanProperty fullScreen
      指定此 Stage是否应为全屏，未装饰的窗口。
      ReadOnlyBooleanProperty iconified
      定义 Stage是否被图标化。
      DoubleProperty maxHeight
      定义这个 Stage的最大高度。
      ReadOnlyBooleanProperty maximized
      定义 Stage是否最大化。
      DoubleProperty maxWidth
      定义此 Stage的最大宽度。
      DoubleProperty minHeight
      定义 Stage的最小高度。
      DoubleProperty minWidth
      定义 Stage的最小宽度。
      BooleanProperty resizable
      定义用户是否可以调整 Stage的大小。
      StringProperty title
      定义 Stage的标题。

      • Properties inherited from class javafx.stage.Window

        eventDispatcher, focused, forceIntegerRenderScale, height, onCloseRequest, onHidden, onHiding, onShowing, onShown, opacity, outputScaleX, outputScaleY, renderScaleX, renderScaleY, scene, showing, width, x, y

    • 构造方法摘要

      构造方法
      Constructor 描述
      Stage​()
      创建一个新的装饰实例 Stage 。
      Stage​(StageStyle style)
      创建一个新的实例 Stage 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ReadOnlyBooleanProperty alwaysOnTopProperty​()
      定义这个 Stage是否保持在其他窗口之上。
      void close​()
      关闭此 Stage 。
      ObjectProperty<String> fullScreenExitHintProperty​()
      ObjectProperty<KeyCombination> fullScreenExitKeyProperty​()
      获取全屏幕退出组合键的属性。
      ReadOnlyBooleanProperty fullScreenProperty​()
      指定此 Stage应该是全屏，未装饰的窗口。
      String getFullScreenExitHint​()
      获取属性fullScreenExitHint的值。
      KeyCombination getFullScreenExitKeyCombination​()
      获取用于退出全屏模式的当前顺序。
      ObservableList<Image> getIcons​()
      获取窗口装饰中使用的图标图像和最小化时。
      double getMaxHeight​()
      获取属性maxHeight的值。
      double getMaxWidth​()
      获取属性maxWidth的值。
      double getMinHeight​()
      获取属性minHeight的值。
      double getMinWidth​()
      获取属性minWidth的值。
      Modality getModality​()
      检索此阶段的模态属性。
      Window getOwner​()
      检索该阶段的所有者窗口，或者取消未知阶段的空值。
      StageStyle getStyle​()
      检索此阶段的样式属性。
      String getTitle​()
      获取属性标题的值。
      ReadOnlyBooleanProperty iconifiedProperty​()
      定义 Stage是否被图标化。
      void initModality​(Modality modality)
      指定此阶段的模式。
      void initOwner​(Window owner)
      指定此阶段的所有者窗口，或者指定顶级，未知级别的空值。
      void initStyle​(StageStyle style)
      指定此阶段的样式。
      boolean isAlwaysOnTop​()
      获取属性alwaysOnTop的值。
      boolean isFullScreen​()
      获取属性fullScreen的值。
      boolean isIconified​()
      获取图标属性的值。
      boolean isMaximized​()
      获取最大化的属性值。
      boolean isResizable​()
      获取属性可调整大小的值。
      DoubleProperty maxHeightProperty​()
      定义 Stage的最大高度。
      ReadOnlyBooleanProperty maximizedProperty​()
      定义 Stage是否最大化。
      DoubleProperty maxWidthProperty​()
      定义此 Stage的最大宽度。
      DoubleProperty minHeightProperty​()
      定义 Stage的最小高度。
      DoubleProperty minWidthProperty​()
      定义此 Stage的最小宽度。
      BooleanProperty resizableProperty​()
      定义用户是否可以调整 Stage的大小。
      void setAlwaysOnTop​(boolean value)
      设置属性alwaysOnTop的值。
      void setFullScreen​(boolean value)
      设置属性fullScreen的值。
      void setFullScreenExitHint​(String value)
      指定用户进入全屏模式时显示的文字，通常用于指示用户从全屏模式退出的方式。
      void setFullScreenExitKeyCombination​(KeyCombination keyCombination)
      指定将允许用户退出全屏模式的KeyCombination。
      void setIconified​(boolean value)
      设置图标属性的值。
      void setMaxHeight​(double value)
      设置属性maxHeight的值。
      void setMaximized​(boolean value)
      设置最大化的属性的值。
      void setMaxWidth​(double value)
      设置属性maxWidth的值。
      void setMinHeight​(double value)
      设置属性minHeight的值。
      void setMinWidth​(double value)
      设置属性minWidth的值。
      void setResizable​(boolean value)
      设置属性可调整大小的值。
      void setScene​(Scene value)
      指定此舞台上要使用的场景。
      void setTitle​(String value)
      设置属性标题的值。
      void show​()
      尝试通过将可见性设置为true来显示此窗口
      void showAndWait​()
      显示此阶段，并等待它在返回给调用者之前被隐藏（关闭）。
      StringProperty titleProperty​()
      定义 Stage的标题。
      void toBack​()
      发送 Window到背景。
      void toFront​()
      把 Window带到前台。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javafx.stage.Window

        addEventFilter, addEventHandler, buildEventDispatchChain, centerOnScreen, eventDispatcherProperty, fireEvent, focusedProperty, forceIntegerRenderScaleProperty, getEventDispatcher, getHeight, getOnCloseRequest, getOnHidden, getOnHiding, getOnShowing, getOnShown, getOpacity, getOutputScaleX, getOutputScaleY, getProperties, getRenderScaleX, getRenderScaleY, getScene, getUserData, getWidth, getWindows, getX, getY, hasProperties, heightProperty, hide, isFocused, isForceIntegerRenderScale, isShowing, onCloseRequestProperty, onHiddenProperty, onHidingProperty, onShowingProperty, onShownProperty, opacityProperty, outputScaleXProperty, outputScaleYProperty, removeEventFilter, removeEventHandler, renderScaleXProperty, renderScaleYProperty, requestFocus, sceneProperty, setEventDispatcher, setEventHandler, setForceIntegerRenderScale, setHeight, setOnCloseRequest, setOnHidden, setOnHiding, setOnShowing, setOnShown, setOpacity, setRenderScaleX, setRenderScaleY, setUserData, setWidth, setX, setY, showingProperty, sizeToScene, widthProperty, xProperty, yProperty

    • Property Detail

      • fullScreen

        public final ReadOnlyBooleanProperty fullScreenProperty
        指定此Stage应该是全屏，未装饰的窗口。

        全屏模式的实现是平台和配置文件相关的。

        当设置为true ， Stage将在可见时尝试进入全屏模式。 设置为false以返回Stage到窗口模式。 如果此属性设置在JavaFX应用程序线程之外的线程上，则抛出一个IllegalStateException 。

        全屏模式将被退出（以及fullScreen属性将被设置为false ）如全屏幕Stage失去焦点，或者如果另一Stage进入全屏模式在同一Screen 。 请注意，全屏模式下的Stage可以看不见，而不会丢失其全屏状态，当Stage变为可见时，将再次进入全屏模式。

        如果平台支持多个屏幕，应用程序可以Screen在进入全屏模式之前将其位置设置在Screen的范围内，控制哪个Screen舞台进入全屏模式。

        然而，在全屏模式下一次， Stage的x ， y ， width和height变量将继续表示窗口的非全屏幕的位置和尺寸; 同为iconified ， resizable ， style ，并opacity 。 如果在全屏模式下更改任何这些属性，则在退出全屏模式时， Stage将假定这些属性。

        如果同时设置更多的Stage模式，其重要性顺序为iconified fullScreen， maximized （从最强到最弱）。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        用户可以随时按ESC无条件退出全屏模式。

        如果存在安全管理员，则应用程序必须具有FXPermission “无限制FULLScreen ”才能进入全屏模式而无限制。 未经许可的应用程序将受到以下限制：

        • 应用程序只能进入全屏模式以响应用户输入。 更具体地，允许鼠标（ Node.mousePressed/mouseReleased/mouseClicked ）或键盘（ Node.keyPressed/keyReleased/keyTyped ）事件处理程序进行输入。 响应ESC键，不允许进入全屏模式。 尝试从任何其他上下文进入全屏模式将被忽略。

          如果Stage被构造为全屏但不可见，它将变为可见时将进入全屏模式，同时限制当允许发生这种情况时，将fullScreen设置为true 。

        • 如果应用程序被允许进入全屏模式，它将具有有限的键盘输入。 它将仅从以下密钥接收KEY_PRESSED和KEY_RELEASED事件： UP, DOWN, LEFT, RIGHT, SPACE, TAB, PAGE_UP, PAGE_DOWN, HOME, END, ENTER
        Default value:
        假
        另请参见：
        isFullScreen() ， setFullScreen(boolean)

      • title

        public final StringProperty titleProperty
        定义 Stage的标题。
        Default value:
        空字符串
        另请参见：
        getTitle() ， setTitle(String)

      • iconified

        public final ReadOnlyBooleanProperty iconifiedProperty
        定义Stage是否被图标化。

        如果同时设置更多的Stage模式，那么它们的重要性顺序是图标fullScreen ; maximized （从最强到最弱）。

        在某些移动和嵌入式平台上，将此属性设置为true将隐藏Stage但不会显示其图标。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        另请参见：
        isIconified() ， setIconified(boolean)

      • maximized

        public final ReadOnlyBooleanProperty maximizedProperty
        定义Stage是否最大化。

        在情况下，更多的Stage模式同时设置其重要性顺序是iconified ， fullScreen ，最大化（从最强到最弱）。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isMaximized() ， setMaximized(boolean)

      • alwaysOnTop

        public final ReadOnlyBooleanProperty alwaysOnTopProperty
        定义这个Stage是否保持在其他窗口之上。

        如果某些其他窗口已经始终在顶部，则这些窗口之间的相对顺序是未指定的（取决于平台）。

        如果存在安全管理员，则应用程序必须具有FXPermission “setWindowAlwaysOnTop”，以使此属性具有任何效果。 如果应用程序没有权限，尝试设置此属性将被忽略，属性值将恢复为false 。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        从以下版本开始：
        JavaFX 8u20
        另请参见：
        isAlwaysOnTop() ， setAlwaysOnTop(boolean)

      • resizable

        public final BooleanProperty resizableProperty
        定义用户是否可以调整Stage的大小。 您可能仍然以编程方式更改舞台的大小。 这是一个提示，允许实现可选地使用户可以调整舞台。

        警告：自8.0以来，财产无法束缚，并将扔RuntimeException尝试这样做。 这是因为可调整大小的设置在某些系统上是异步的，或者通常可能由系统/窗口管理器设置。
        仍然允许双向绑定，因为它们不会阻止系统的属性设置。

        Default value:
        真正
        另请参见：
        isResizable() ， setResizable(boolean)

      • minWidth

        public final DoubleProperty minWidthProperty
        定义这个 Stage的最小宽度。
        Default value:
        0
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getMinWidth() ， setMinWidth(double)

      • minHeight

        public final DoubleProperty minHeightProperty
        定义这个 Stage的最小高度。
        Default value:
        0
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getMinHeight() ， setMinHeight(double)

      • maxWidth

        public final DoubleProperty maxWidthProperty
        定义此 Stage的最大宽度。
        Default value:
        Double.MAX_VALUE
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • maxHeight

        public final DoubleProperty maxHeightProperty
        定义 Stage的最大高度。
        Default value:
        Double.MAX_VALUE
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getMaxHeight() ， setMaxHeight(double)

      • fullScreenExitKey

        public final ObjectProperty<KeyCombination> fullScreenExitKeyProperty
        获取全屏幕退出组合键的属性。
        从以下版本开始：
        JavaFX 8.0

      • fullScreenExitHint

        public final ObjectProperty<String> fullScreenExitHintProperty
        另请参见：
        getFullScreenExitHint() ， setFullScreenExitHint(String)

    • 构造方法详细信息

      • Stage

        public Stage​()
        创建一个新的装饰实例 Stage 。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此构造函数。

      • Stage

        public Stage​(StageStyle style)
        创建一个新的实例 Stage 。
        参数
        style - 风格的 Stage
        异常
        IllegalStateException - 如果该构造函数在除JavaFX应用程序线程之外的线程上调用。

    • 方法详细信息

      • setScene

        public final void setScene​(Scene value)
        指定此舞台上要使用的场景。
        重写：
        setScene在 Window

      • show

        public final void show​()
        尝试通过将可见性设置为true来显示此窗口
        重写：
        show在 Window

      • showAndWait

        public void showAndWait​()
        显示此阶段，并等待它在返回给调用者之前被隐藏（关闭）。 此方法暂时阻止当前事件的处理，并启动嵌套事件循环来处理其他事件。 必须在FX应用程序线程上调用此方法。

        通过以下方式之一隐藏（关闭）舞台：

        • 该应用程序在此阶段调用Window.hide()或close()方法
        • 此阶段具有非空的所有者窗口，其所有者已关闭
        • 用户通过窗口系统关闭窗口（例如，通过按下窗口装饰中的关闭按钮）

        舞台被隐藏后，应用程序已从事件处理程序返回到事件循环，嵌套事件循环将终止，此方法返回给调用者。

        例如，考虑以下不同事件处理程序的以下操作序列，假设执行顺序如下所示：

          void evtHander1(...) {
     stage1.showAndWait();
     doSomethingAfterStage1Closed(...)
 }

 void evtHander2(...) {
     stage1.hide();
     doSomethingElseHere(...)
 }
        evtHandler1将阻止对showAndWait的调用。 它将在stage1隐藏后继续执行，当前事件处理程序（在本例中为evtHandler2）返回到事件循环。 这意味着doSomethingElseHere将在doSomethingAfterStage1Closed之前执行。

        showAndWait可能会显示多个舞台。 每次调用都将启动一个新的嵌套事件循环。 阶段可能以任何顺序隐藏，但是特定的嵌套事件循环（因此相关阶段的showAndWait方法）将仅在所有内部事件循环也终止后才会终止。

        例如，考虑以下不同事件处理程序的以下操作序列，假设执行顺序如下所示：

          void evtHander1() {
     stage1.showAndWait();
     doSomethingAfterStage1Closed(...)
 }

 void evtHander2() {
     stage2.showAndWait();
     doSomethingAfterStage2Closed(...)
 }

 void evtHander3() {
     stage1.hide();
     doSomethingElseHere(...)
 }

 void evtHander4() {
     stage2.hide();
     doSomethingElseHereToo(...)
 }
        evtHandler1将阻止对stage1.showAndWait的调用，启动一个嵌套事件循环，就像上一个例子一样。 evtHandler2将阻塞对stage2.showAndWait的调用，启动另一个（内部）嵌套事件循环。 第一次调用stage1.showAndWait将在stage1隐藏后继续执行，但只有在stage2.showAndWait已经终止的内部嵌套事件循环之后才能继续执行。 这意味着在evtHandler2返回之后，对stage1.showAndWait的调用将不会返回。 执行顺序是：stage1.showAndWait，stage2.showAndWait，stage1.hide，doSomethingElseHere，stage2.hide，doSomethingElseHereToo，doSomethingAfterStage2Closed，doSomethingAfterStage1Closed。

        不能在主阶段或已经可见的阶段调用此方法。 另外，它必须从输入事件处理程序或从Runnable的run方法调用传递给Platform.runLater 。 在动画或布局处理过程中不得调用它。

        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。
        IllegalStateException - 如果在动画或布局处理期间调用此方法。
        IllegalStateException - 如果在初级阶段调用此方法。
        IllegalStateException - 如果这个阶段已经显示。
        从以下版本开始：
        JavaFX 2.2

      • initStyle

        public final void initStyle​(StageStyle style)
        指定此阶段的样式。 这必须在使舞台可见之前完成。 风格是以下之一：StageStyle.DECORATED，StageStyle.UNDECORATED，StageStyle.TRANSPARENT或StageStyle.UTILITY。
        Default value:
        StageStyle.DECORATED
        参数
        style - 这个阶段的风格。
        异常
        IllegalStateException - 如果在舞台已经可见之后设置了此属性。

      • getStyle

        public final StageStyle getStyle​()
        检索此阶段的样式属性。
        结果
        舞台风格。

      • initModality

        public final void initModality​(Modality modality)
        指定此阶段的模式。 这必须在使舞台可见之前完成。 模态是以下之一：Modality.NONE，Modality.WINDOW_MODAL或Modality.APPLICATION_MODAL。
        Default value:
        Modality.NONE
        参数
        modality - 这个阶段的模式。
        异常
        IllegalStateException - 如果此属性在舞台已显示后设置。
        IllegalStateException - 如果这个阶段是初级阶段。

      • getModality

        public final Modality getModality​()
        检索此阶段的模态属性。
        结果
        的模式。

      • initOwner

        public final void initOwner​(Window owner)
        指定此阶段的所有者窗口，或者指定顶级，未知级别的空值。 这必须在使舞台可见之前完成。
        Default value:
        空值
        参数
        owner - 这个阶段的主人。
        异常
        IllegalStateException - 如果此属性在舞台已显示后设置。
        IllegalStateException - 如果这个阶段是初级阶段。

      • getOwner

        public final Window getOwner​()
        检索该阶段的所有者窗口，或者取消未知阶段的空值。
        结果
        所有者窗口。

      • setFullScreen

        public final void setFullScreen​(boolean value)
        设置属性fullScreen的值。
        Property description:
        指定此Stage是否应为全屏，未装饰的窗口。

        全屏模式的实现是平台和配置文件相关的。

        当设置为true ， Stage将在可见时尝试进入全屏模式。 设置为false以将Stage返回到窗口模式。 如果此属性设置在JavaFX应用程序线程之外的线程上，则抛出一个IllegalStateException 。

        全屏模式将被退出（以及fullScreen属性将被设置为false ）如全屏幕Stage失去焦点，或者如果另一Stage进入全屏模式在同一Screen 。 请注意，全屏模式下的Stage在不失去全屏状态的情况下变为不可见，并且当Stage变为可见时将再次进入全屏模式。

        如果平台支持多个屏幕，应用程序可以Screen在进入全屏模式之前将其位置设置在Screen的范围内来控制哪个Screen舞台将进入全屏模式。

        然而，在全屏模式下一次， Stage的x ， y ， width和height变量将继续表示窗口的非全屏幕的位置和尺寸; 同为iconified ， resizable ， style ，并opacity 。 如果在全屏模式下更改任何这些属性，则在退出全屏模式时， Stage将假定这些属性。

        如果同时设置更多的Stage模式，它们的重要性顺序为iconified fullScreen， maximized （从最强到最弱）。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        用户可以随时按ESC无条件退出全屏模式。

        如果存在安全管理员，则应用程序必须具有FXPermission “无限制FULLScreen ”才能进入全屏模式而无限制。 未经许可的应用程序将受到以下限制：

        • 应用程序只能进入全屏模式以响应用户输入。 更具体地说，从鼠标（ Node.mousePressed/mouseReleased/mouseClicked ）或键盘（ Node.keyPressed/keyReleased/keyTyped ）事件处理程序允许输入。 响应ESC键，不允许进入全屏模式。 尝试从任何其他上下文进入全屏模式将被忽略。

          如果Stage被构造为全屏但不可见，则在可见时将进入全屏模式，同时限制当允许发生这种情况时，将fullScreen设置为true 。

        • 如果应用程序被允许进入全屏模式，它将具有有限的键盘输入。 它将仅从以下键接收KEY_PRESSED和KEY_RELEASED事件： UP, DOWN, LEFT, RIGHT, SPACE, TAB, PAGE_UP, PAGE_DOWN, HOME, END, ENTER
        Default value:
        假

      • isFullScreen

        public final boolean isFullScreen​()
        获取属性fullScreen的值。
        Property description:
        指定此Stage是否应为全屏，未装饰的窗口。

        全屏模式的实现是平台和配置文件相关的。

        当设置为true ， Stage将在可见时尝试进入全屏模式。 设置为false以返回Stage到窗口模式。 如果此属性设置在JavaFX应用程序线程之外的线程上，则抛出一个IllegalStateException 。

        全屏模式将被退出（以及fullScreen属性将被设置为false ）如全屏幕Stage失去焦点，或者如果另一Stage进入全屏模式在同一Screen 。 请注意，全屏模式下的Stage在不失去全屏状态的情况下变为不可见，并且当Stage变为可见时将再次进入全屏模式。

        如果平台支持多个屏幕，应用程序可以Screen在进入全屏模式之前将其位置设置在Screen的范围内来控制舞台将进入全屏模式的哪一个Screen 。

        然而，在全屏模式下一次， Stage的x ， y ， width和height变量将继续表示窗口的非全屏幕的位置和尺寸; 同为iconified ， resizable ， style ，并opacity 。 如果在全屏模式下更改任何这些属性，则在退出全屏模式时， Stage将假定这些属性。

        如果同时设置更多的Stage模式，它们的重要性顺序为iconified fullScreen， maximized （从最强到最弱）。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        用户可以随时按ESC无条件退出全屏模式。

        如果存在安全管理员，则应用程序必须具有FXPermission “无限制FULLScreen ”才能进入全屏模式而无限制。 未经许可的应用程序将受到以下限制：

        • 应用程序只能进入全屏模式以响应用户输入。 更具体地说，从鼠标（ Node.mousePressed/mouseReleased/mouseClicked ）或键盘（ Node.keyPressed/keyReleased/keyTyped ）事件处理程序允许输入。 响应ESC键，不允许进入全屏模式。 尝试从任何其他上下文进入全屏模式将被忽略。

          如果Stage被构造为全屏但不可见，则在可见时将进入全屏模式，同时限制当允许发生这种情况时，将fullScreen设置为true 。

        • 如果应用程序被允许进入全屏模式，它将具有有限的键盘输入。 它将仅从以下键接收KEY_PRESSED和KEY_RELEASED事件： UP, DOWN, LEFT, RIGHT, SPACE, TAB, PAGE_UP, PAGE_DOWN, HOME, END, ENTER
        Default value:
        假

      • fullScreenProperty

        public final ReadOnlyBooleanProperty fullScreenProperty​()
        指定此Stage是否应为全屏，未装饰的窗口。

        全屏模式的实现是平台和配置文件相关的。

        当设置为true ， Stage将在可见时尝试进入全屏模式。 设置为false以返回Stage到窗口模式。 如果此属性设置在JavaFX应用程序线程之外的线程上，则抛出一个IllegalStateException 。

        全屏模式将被退出（以及fullScreen属性将被设置为false ）如全屏幕Stage失去焦点，或者如果另一Stage进入全屏模式在同一Screen 。 请注意，全屏模式下的Stage可以变为不可见，而不会丢失其全屏状态，并且当Stage变为可见时将再次进入全屏模式。

        如果平台支持多个屏幕，应用程序可以Screen在进入全屏模式之前将其位置设置在Screen的范围内来控制舞台将进入全屏模式。

        然而，在全屏模式下一次， Stage的x ， y ， width和height变量将继续表示窗口的非全屏幕的位置和尺寸; 同为iconified ， resizable ， style ，并opacity 。 如果在全屏模式下对这些属性中的任何一个进行了更改，则在退出全屏模式时， Stage将承担这些属性。

        如果同时设置更多的Stage模式，它们的重要性顺序是iconified fullScreen， maximized （从最强到最弱）。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        用户可以随时按ESC无条件退出全屏模式。

        如果存在安全管理员，应用程序必须具有FXPermission “ unrestrictedFullScreen ”才能进入全屏模式而无限制。 未经许可的应用程序将受到以下限制：

        • 应用程序只能进入全屏模式以响应用户输入。 更具体地说，从鼠标（ Node.mousePressed/mouseReleased/mouseClicked ）或键盘（ Node.keyPressed/keyReleased/keyTyped ）事件处理程序允许输入。 响应ESC键，不允许进入全屏模式。 尝试从任何其他上下文进入全屏模式将被忽略。

          如果Stage被构造为全屏，但不可见，它将变为可见时将进入全屏模式，同时限制当允许发生这种情况时，将fullScreen设置为true 。

        • 如果应用程序被允许进入全屏模式，它将具有有限的键盘输入。 它将仅从以下密钥接收KEY_PRESSED和KEY_RELEASED事件： UP, DOWN, LEFT, RIGHT, SPACE, TAB, PAGE_UP, PAGE_DOWN, HOME, END, ENTER
        Default value:
        假
        另请参见：
        isFullScreen() ， setFullScreen(boolean)

      • getIcons

        public final ObservableList<Image> getIcons​()
        获取窗口装饰中使用的图标图像和最小化时。 图像应该是相同图像的不同大小，并且将选择最佳尺寸，例如。 16x16,32,32。
        结果
        这个窗口的图标的可观察的列表

      • setTitle

        public final void setTitle​(String value)
        设置属性标题的值。
        Property description:
        定义 Stage的标题。
        Default value:
        空字符串

      • getTitle

        public final String getTitle​()
        获取属性标题的值。
        Property description:
        定义 Stage的标题。
        Default value:
        空字符串

      • titleProperty

        public final StringProperty titleProperty​()
        定义 Stage的标题。
        Default value:
        空字符串
        另请参见：
        getTitle() ， setTitle(String)

      • setIconified

        public final void setIconified​(boolean value)
        设置图标属性的值。
        Property description:
        定义Stage是否被图标化。

        如果同时设置更多的Stage模式，则它们的重要性顺序是图标fullScreen ; maximized （从最强到最弱）。

        在某些移动和嵌入式平台上，将此属性设置为true将隐藏Stage但不显示其图标。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假

      • isIconified

        public final boolean isIconified​()
        获取图标属性的值。
        Property description:
        定义Stage是否被图标化。

        如果同时设置更多的Stage模式，则它们的重要性顺序是图标fullScreen ; maximized （从最强到最弱）。

        在某些移动和嵌入式平台上，将此属性设置为true将隐藏Stage但不显示其图标。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假

      • iconifiedProperty

        public final ReadOnlyBooleanProperty iconifiedProperty​()
        定义Stage是否被图标化。

        如果同时设置更多的Stage模式，则它们的重要性顺序是图标fullScreen ; maximized （从最强到最弱）。

        在某些移动和嵌入式平台上，将此属性设置为true将隐藏Stage但不显示其图标。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        另请参见：
        isIconified() ， setIconified(boolean)

      • setMaximized

        public final void setMaximized​(boolean value)
        设置最大化的属性的值。
        Property description:
        定义Stage是否最大化。

        在情况下，更多的Stage模式同时设置其重要性顺序是iconified ， fullScreen ，最大化（从最强到最弱）。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        从以下版本开始：
        JavaFX 8.0

      • isMaximized

        public final boolean isMaximized​()
        获取最大化的属性值。
        Property description:
        定义Stage是否最大化。

        在情况下，更多的Stage模式同时设置其重要性顺序是iconified ， fullScreen ，最大化（从最强到最弱）。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        从以下版本开始：
        JavaFX 8.0

      • maximizedProperty

        public final ReadOnlyBooleanProperty maximizedProperty​()
        定义Stage是否最大化。

        在情况下，更多的Stage模式同时设置其重要性顺序是iconified ， fullScreen ，最大化（从最强到最弱）。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        从以下版本开始：
        JavaFX 8.0
        另请参见：
        isMaximized() ， setMaximized(boolean)

      • setAlwaysOnTop

        public final void setAlwaysOnTop​(boolean value)
        设置属性alwaysOnTop的值。
        Property description:
        定义这个Stage是否保持在其他窗口之上。

        如果某些其他窗口已经始终在顶部，则这些窗口之间的相对顺序是未指定的（取决于平台）。

        如果存在安全管理员，应用程序必须具有FXPermission “setWindowAlwaysOnTop”，以使此属性具有任何效果。 如果应用程序没有权限，尝试设置此属性将被忽略，属性值将恢复为false 。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        从以下版本开始：
        JavaFX 8u20

      • isAlwaysOnTop

        public final boolean isAlwaysOnTop​()
        获取属性alwaysOnTop的值。
        Property description:
        定义这个Stage是否保持在其他窗口的顶部。

        如果某些其他窗口已经始终在顶部，则这些窗口之间的相对顺序是未指定的（取决于平台）。

        如果存在安全管理员，应用程序必须具有FXPermission “setWindowAlwaysOnTop”，以使此属性具有任何效果。 如果应用程序没有权限，尝试设置此属性将被忽略，属性值将恢复为false 。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        从以下版本开始：
        JavaFX 8u20

      • alwaysOnTopProperty

        public final ReadOnlyBooleanProperty alwaysOnTopProperty​()
        定义这个Stage是否保持在其他窗口之上。

        如果某些其他窗口已经始终在顶部，则这些窗口之间的相对顺序是未指定的（取决于平台）。

        如果存在安全管理员，应用程序必须具有FXPermission “setWindowAlwaysOnTop”，以使此属性具有任何效果。 如果应用程序没有权限，尝试设置此属性将被忽略，属性值将恢复为false 。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        Default value:
        假
        从以下版本开始：
        JavaFX 8u20
        另请参见：
        isAlwaysOnTop() ， setAlwaysOnTop(boolean)

      • setResizable

        public final void setResizable​(boolean value)
        设置属性可调整大小的值。
        Property description:
        定义用户是否可以调整Stage的大小。 您可能仍然以编程方式更改舞台的大小。 这是一个提示，允许实现可选地使用户可以调整舞台。

        警告：自8.0以来，财产无法束缚，并将扔RuntimeException尝试这样做。 这是因为可调整大小的设置在某些系统上是异步的，或者通常可能由系统/窗口管理器设置。
        仍然允许双向绑定，因为它们不会阻止系统的属性设置。

        Default value:
        真正

      • isResizable

        public final boolean isResizable​()
        获取属性可调整大小的值。
        Property description:
        定义用户是否可以调整Stage的大小。 您可能仍然以编程方式更改舞台的大小。 这是一个提示，允许实现可选地使用户可以调整舞台。

        警告：自8.0以来，该属性无法绑定，并将扔RuntimeException尝试这样做。 这是因为可调整大小的设置在某些系统上是异步的，或者通常可能由系统/窗口管理器设置。
        仍然允许双向绑定，因为它们不会阻止系统的属性设置。

        Default value:
        真正

      • resizableProperty

        public final BooleanProperty resizableProperty​()
        定义用户是否可以调整Stage的大小。 您可能仍然以编程方式更改舞台的大小。 这是一个提示，允许实现可选地使用户可以调整舞台。

        警告：自8.0以来，财产无法束缚，并将扔RuntimeException尝试这样做。 这是因为可调整大小的设置在某些系统上是异步的，或者通常可能由系统/窗口管理器设置。
        仍然允许双向绑定，因为它们不会阻止系统的属性设置。

        Default value:
        真正
        另请参见：
        isResizable() ， setResizable(boolean)

      • setMinWidth

        public final void setMinWidth​(double value)
        设置属性minWidth的值。
        Property description:
        定义此 Stage的最小宽度。
        Default value:
        0
        从以下版本开始：
        JavaFX 2.1

      • getMinWidth

        public final double getMinWidth​()
        获取属性minWidth的值。
        Property description:
        定义 Stage的最小宽度。
        Default value:
        0
        从以下版本开始：
        JavaFX 2.1

      • minWidthProperty

        public final DoubleProperty minWidthProperty​()
        定义此 Stage的最小宽度。
        Default value:
        0
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getMinWidth() ， setMinWidth(double)

      • setMinHeight

        public final void setMinHeight​(double value)
        设置属性minHeight的值。
        Property description:
        定义这个 Stage的最小高度。
        Default value:
        0
        从以下版本开始：
        JavaFX 2.1

      • getMinHeight

        public final double getMinHeight​()
        获取属性minHeight的值。
        Property description:
        定义 Stage的最小高度。
        Default value:
        0
        从以下版本开始：
        JavaFX 2.1

      • minHeightProperty

        public final DoubleProperty minHeightProperty​()
        定义 Stage的最小高度。
        Default value:
        0
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getMinHeight() ， setMinHeight(double)

      • setMaxWidth

        public final void setMaxWidth​(double value)
        设置属性maxWidth的值。
        Property description:
        定义此 Stage的最大宽度。
        Default value:
        Double.MAX_VALUE
        从以下版本开始：
        JavaFX 2.1

      • getMaxWidth

        public final double getMaxWidth​()
        获取属性maxWidth的值。
        Property description:
        定义此 Stage的最大宽度。
        Default value:
        Double.MAX_VALUE
        从以下版本开始：
        JavaFX 2.1

      • maxWidthProperty

        public final DoubleProperty maxWidthProperty​()
        定义此 Stage的最大宽度。
        Default value:
        Double.MAX_VALUE
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getMaxWidth() ， setMaxWidth(double)

      • setMaxHeight

        public final void setMaxHeight​(double value)
        设置属性maxHeight的值。
        Property description:
        定义这个 Stage的最大高度。
        Default value:
        Double.MAX_VALUE
        从以下版本开始：
        JavaFX 2.1

      • getMaxHeight

        public final double getMaxHeight​()
        获取属性maxHeight的值。
        Property description:
        定义这个 Stage的最大高度。
        Default value:
        Double.MAX_VALUE
        从以下版本开始：
        JavaFX 2.1

      • maxHeightProperty

        public final DoubleProperty maxHeightProperty​()
        定义这个 Stage的最大高度。
        Default value:
        Double.MAX_VALUE
        从以下版本开始：
        JavaFX 2.1
        另请参见：
        getMaxHeight() ， setMaxHeight(double)

      • toFront

        public void toFront​()
        把Window带到前台。 如果Window已经在前台，没有明显的区别。

      • toBack

        public void toBack​()
        发送Window到背景。 如果Window已经在后台没有可见的区别。 此操作将此Window在支持堆叠的平台上的堆叠顺序的底部。

      • close

        public void close​()
        关闭此Stage 。 此电话相当于hide() 。

      • setFullScreenExitKeyCombination

        public final void setFullScreenExitKeyCombination​(KeyCombination keyCombination)
        指定将允许用户退出全屏模式的KeyCombination。 KeyCombination.NO_MATCH的值不会与任何KeyEvent匹配，因此用户无法从全屏模式中退出。 值为null表示应使用默认平台特定的密钥组合。

        当进入全屏模式时，将进行此值的内部副本，并将用于触发退出模式。 如果存在安全管理员，应用程序必须具有“无限制FULLScreen ” FXPermission来修改退出组合键。 如果应用程序没有权限，则此属性的值将被忽略，在这种情况下将使用默认组合键。

        参数
        keyCombination - 退出的组合键
        从以下版本开始：
        JavaFX 8.0

      • getFullScreenExitKeyCombination

        public final KeyCombination getFullScreenExitKeyCombination​()
        获取用于退出全屏模式的当前顺序。
        结果
        当前设置（系统默认为空）
        从以下版本开始：
        JavaFX 8.0

      • fullScreenExitKeyProperty

        public final ObjectProperty<KeyCombination> fullScreenExitKeyProperty​()
        获取全屏幕退出组合键的属性。
        从以下版本开始：
        JavaFX 8.0

      • setFullScreenExitHint

        public final void setFullScreenExitHint​(String value)
        指定用户进入全屏模式时显示的文字，通常用于指示用户从全屏模式退出的方式。 值为null将导致显示默认的每个语言环境消息。 如果设置为空字符串，则不会显示任何消息。

        如果存在安全管理员，则应用程序必须具有FXPermission “ unrestrictedFullScreen ”才能修改退出提示。 如果应用程序没有权限，该属性的值将被忽略，在这种情况下将显示默认消息。

        参数
        value - 要显示的字符串。
        从以下版本开始：
        JavaFX 8.0

      • getFullScreenExitHint

        public final String getFullScreenExitHint​()
        获取属性fullScreenExitHint的值。
        Property description:

      • fullScreenExitHintProperty

        public final ObjectProperty<String> fullScreenExitHintProperty​()
        另请参见：
        getFullScreenExitHint() ， setFullScreenExitHint(String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StageStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Enum StageStyle

  • java.lang.Object
    • java.lang.Enum<StageStyle>
      • javafx.stage.StageStyle
  • All Implemented Interfaces:
    Serializable ， Comparable<StageStyle>

    public enum StageStyle
extends Enum<StageStyle>
    此枚举定义了 Stage的可能样式。
    从以下版本开始：
    JavaFX 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DECORATED
      定义一个正常的 Stage风格与一个坚实的白色背景和平台装饰。
      TRANSPARENT
      定义 Stage风格，透明背景，无装饰。
      UNDECORATED
      定义一个 Stage风格与纯白色背景，没有装饰。
      UNIFIED
      定义一个 Stage风格的平台装饰，并消除客户区域和装饰品之间的边界。
      UTILITY
      定义一个 Stage风格的白色固体背景和用于实用工具窗口的最小的平台装饰。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static StageStyle valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StageStyle[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DECORATED

        public static final StageStyle DECORATED
        定义一个正常的 Stage风格，具有坚实的白色背景和平台装饰。

      • UNDECORATED

        public static final StageStyle UNDECORATED
        定义一个 Stage风格与纯白色背景，没有装饰。

      • TRANSPARENT

        public static final StageStyle TRANSPARENT
        定义一个Stage风格的透明背景，没有装饰。 这是一个条件功能; 检查是否支持使用Platform.isSupported(javafx.application.ConditionalFeature) 。 如果该平台不支持此功能，则此样式将降级为StageStyle.UNDECORATED

      • UTILITY

        public static final StageStyle UTILITY
        定义一个 Stage样式，具有纯白色背景和用于实用工具窗口的最小平台装饰。

      • UNIFIED

        public static final StageStyle UNIFIED
        定义Stage风格的平台装饰，并消除客户区域和装饰品之间的边界。 客户区背景与装饰统一。 这是一个条件功能，检查是否支持，请参阅Platform.isSupported(javafx.application.ConditionalFeature) 。 如果该平台不支持该功能，则此样式将降级为StageStyle.DECORATED

        `注意：要看到效果， Scene覆盖Stage应该有Color.TRANSPARENT

        从以下版本开始：
        JavaFX 8.0

    • 方法详细信息

      • values

        public static StageStyle[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (StageStyle c : StageStyle.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static StageStyle valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Uses of Package javafx.stage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.stage

  • Packages that use javafx.stage
    软件包 描述
    javafx.application
    提供应用程序生命周期类。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.stage
    提供JavaFX内容的顶级容器类。
  • Classes in javafx.stage used by javafx.application
    Class 描述
    Stage
    JavaFX Stage类是顶级的JavaFX容器。
  • Classes in javafx.stage used by javafx.print
    Class 描述
    Window
    托管场景的顶层窗口，用户与之交互的顶级窗口。
  • Classes in javafx.stage used by javafx.scene
    Class 描述
    Window
    托管场景的顶层窗口，用户与之交互的顶级窗口。
  • Classes in javafx.stage used by javafx.scene.control
    Class 描述
    Modality
    该枚举定义了一个 Stage的可能的模式类型。
    PopupWindow
    PopupWindow是各种不同类型的基于弹出窗口的窗口的父级，包括Popup和Tooltip和ContextMenu 。
    StageStyle
    此枚举定义了 Stage可能的样式。
    Window
    托管场景的顶层窗口，用户与之交互的顶级窗口。
  • Classes in javafx.stage used by javafx.stage
    Class 描述
    FileChooser.ExtensionFilter
    定义一个扩展过滤器，用于过滤可以在FileDialog中根据文件扩展名选择哪些文件。
    Modality
    此枚举定义了一个 Stage的可能的模式类型。
    PopupWindow
    PopupWindow是各种不同类型的基于弹出窗口的窗口的父级，包括Popup和Tooltip以及ContextMenu 。
    PopupWindow.AnchorLocation
    锚定点选择的锚位置常数。
    Screen
    描述诸如监视器之类的图形目的地的特征。
    StageStyle
    此枚举定义了 Stage的可能样式。
    Window
    托管场景的顶层窗口，用户与之交互的顶级窗口。
    WindowEvent
    与窗口显示/隐藏操作相关的事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Window (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Class Window

  • java.lang.Object
    • javafx.stage.Window
  • All Implemented Interfaces:
    EventTarget
    已知直接子类：
    PopupWindow ， Stage

    public class Window
extends Object
implements EventTarget
    托管场景的顶层窗口，用户与之交互的顶级窗口。 一个窗口可能是Stage ， PopupWindow ，或其他这样的顶级水平。 窗口也用于基于浏览器插件的部署。

    必须在JavaFX应用程序线程上构建和修改窗口对象。

    JavaFX应用程序线程是作为JavaFX运行时启动过程的一部分而创建的。 有关详细信息，请参阅Application类和Platform.startup(Runnable)方法。

    从以下版本开始：
    JavaFX 2.0

    • Property Summary

      Properties
      Type Property 描述
      ObjectProperty<EventDispatcher> eventDispatcher
      指定此节点的事件分派器。
      ReadOnlyBooleanProperty focused
      这个 Window是否具有键盘或输入焦点。
      BooleanProperty forceIntegerRenderScale
      当相关的输出比例有变化时，控制系统默认情况下是否设置整数渲染比例的布尔属性。
      ReadOnlyDoubleProperty height
      这个高度 Window 。
      ObjectProperty<EventHandler<WindowEvent>> onCloseRequest
      当有外部请求关闭此 Window 。
      ObjectProperty<EventHandler<WindowEvent>> onHidden
      在窗口被隐藏之后调用。
      ObjectProperty<EventHandler<WindowEvent>> onHiding
      在Window被隐藏之前调用。
      ObjectProperty<EventHandler<WindowEvent>> onShowing
      在窗口显示之前调用。
      ObjectProperty<EventHandler<WindowEvent>> onShown
      在窗口显示之后调用。
      DoubleProperty opacity
      将 Window的不透明度定义为0.0和1.0之间的值。
      ReadOnlyDoubleProperty outputScaleX
      Window将在渲染和将输出合成到屏幕或其他目标设备的所有阶段中应用于水平场景坐标的比例。
      ReadOnlyDoubleProperty outputScaleY
      Window将适用于垂直场景坐标在绘制和合成输出到屏幕或其他目标设备的所有阶段的比例。
      DoubleProperty renderScaleX
      当渲染其 Scene到渲染缓冲区时， Window将使用的水平刻度。
      DoubleProperty renderScaleY
      当渲染 Scene到渲染缓冲区时， Window将使用的垂直刻度。
      ReadOnlyObjectProperty<Scene> scene
      Scene要在这个 Window上呈现。
      ReadOnlyBooleanProperty showing
      是否显示 Window （即，在用户系统上打开）。
      ReadOnlyDoubleProperty width
      此宽度为 Window 。
      ReadOnlyDoubleProperty x
      这个 Window在屏幕上的水平位置。
      ReadOnlyDoubleProperty y
      这个 Window在屏幕上的垂直位置。

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | Window​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      <T extends Event>
      void             		addEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      向此节点注册事件过滤器。
      <T extends Event>
      void             		addEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      向此节点注册事件处理程序。
      EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
      为此窗口构建事件调度链。
      void centerOnScreen​()
      在此窗口中设置x和y属性，以便它在curent屏幕上居中。
      ObjectProperty<EventDispatcher> eventDispatcherProperty​()
      指定此节点的事件分派器。
      void fireEvent​(Event event)
      触发指定的事件。
      ReadOnlyBooleanProperty focusedProperty​()
      该 Window是否具有键盘或输入焦点。
      BooleanProperty forceIntegerRenderScaleProperty​()
      当相关的输出比例有变化时，控制系统默认情况下是否设置整数渲染比例的布尔属性。
      EventDispatcher getEventDispatcher​()
      获取属性eventDispatcher的值。
      double getHeight​()
      获取属性高度的值。
      EventHandler<WindowEvent> getOnCloseRequest​()
      获取属性onCloseRequest的值。
      EventHandler<WindowEvent> getOnHidden​()
      获取属性onHidden的值。
      EventHandler<WindowEvent> getOnHiding​()
      获取属性onHiding的值。
      EventHandler<WindowEvent> getOnShowing​()
      获取属性onShowing的值。
      EventHandler<WindowEvent> getOnShown​()
      获取onShown属性的值。
      double getOpacity​()
      获取属性不透明度的值。
      double getOutputScaleX​()
      获取属性outputScaleX的值。
      double getOutputScaleY​()
      获取属性outputScaleY的值。
      ObservableMap<Object,Object> getProperties​()
      返回此节点上属性的可观察图，主要由应用程序开发人员使用。
      double getRenderScaleX​()
      获取属性renderScaleX的值。
      double getRenderScaleY​()
      获取属性renderScaleY的值。
      Scene getScene​()
      获取属性场景的值。
      Object getUserData​()
      返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
      double getWidth​()
      获取属性宽度的值。
      static ObservableList<Window> getWindows​()
      返回一个包含对当前显示的JavaFX窗口的引用的列表。
      double getX​()
      获取属性x的值。
      double getY​()
      获取属性y的值。
      boolean hasProperties​()
      测试窗口是否具有属性。
      ReadOnlyDoubleProperty heightProperty​()
      这个高度 Window 。
      void hide​()
      尝试通过将可见性设置为false来隐藏此窗口。
      boolean isFocused​()
      获取关注的属性的值。
      boolean isForceIntegerRenderScale​()
      获取属性forceIntegerRenderScale的值。
      boolean isShowing​()
      获取显示的属性的值。
      ObjectProperty<EventHandler<WindowEvent>> onCloseRequestProperty​()
      当有外部请求关闭此 Window 。
      ObjectProperty<EventHandler<WindowEvent>> onHiddenProperty​()
      在窗口被隐藏之后调用。
      ObjectProperty<EventHandler<WindowEvent>> onHidingProperty​()
      在Window被隐藏之前调用。
      ObjectProperty<EventHandler<WindowEvent>> onShowingProperty​()
      在窗口显示之前调用。
      ObjectProperty<EventHandler<WindowEvent>> onShownProperty​()
      在窗口显示之后调用。
      DoubleProperty opacityProperty​()
      将 Window的不透明度定义为0.0和1.0之间的值。
      ReadOnlyDoubleProperty outputScaleXProperty​()
      Window将在渲染和将输出合成到屏幕或其他目标设备的所有阶段中应用于水平场景坐标的比例。
      ReadOnlyDoubleProperty outputScaleYProperty​()
      Window将在渲染和将输出合成到屏幕或其他目标设备的所有阶段中应用于垂直场景坐标的比例。
      <T extends Event>
      void             		removeEventFilter​(EventType<T> eventType, EventHandler<? super T> eventFilter)
      从此节点注销先前注册的事件过滤器。
      <T extends Event>
      void             		removeEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      从此节点注销先前注册的事件处理程序。
      DoubleProperty renderScaleXProperty​()
      当渲染其 Scene到渲染缓冲区时， Window将使用的水平刻度。
      DoubleProperty renderScaleYProperty​()
      当渲染 Scene到渲染缓冲区时， Window将使用的垂直刻度。
      void requestFocus​()
      要求这个 Window得到输入焦点。
      ReadOnlyObjectProperty<Scene> sceneProperty​()
      Scene将在此呈现 Window 。
      void setEventDispatcher​(EventDispatcher value)
      设置属性eventDispatcher的值。
      protected <T extends Event>
      void             		setEventHandler​(EventType<T> eventType, EventHandler<? super T> eventHandler)
      设置要用于此事件类型的处理程序。
      void setForceIntegerRenderScale​(boolean forced)
      设置属性forceIntegerRenderScale的值。
      void setHeight​(double value)
      设置属性高度的值。
      void setOnCloseRequest​(EventHandler<WindowEvent> value)
      设置属性onCloseRequest的值。
      void setOnHidden​(EventHandler<WindowEvent> value)
      设置属性onHidden的值。
      void setOnHiding​(EventHandler<WindowEvent> value)
      设置属性onHiding的值。
      void setOnShowing​(EventHandler<WindowEvent> value)
      设置属性onShowing的值。
      void setOnShown​(EventHandler<WindowEvent> value)
      设置属性onShown的值。
      void setOpacity​(double value)
      设置属性不透明度的值。
      void setRenderScaleX​(double scale)
      设置属性renderScaleX的值。
      void setRenderScaleY​(double scale)
      设置属性renderScaleY的值。
      protected void setScene​(Scene value)
      设置属性场景的值。
      void setUserData​(Object value)
      用于设置可以在以后检索的单个Object属性的便利方法。
      void setWidth​(double value)
      设置属性宽度的值。
      void setX​(double value)
      设置属性x的值。
      void setY​(double value)
      设置属性y的值。
      protected void show​()
      尝试通过将可见性设置为true来显示此窗口
      ReadOnlyBooleanProperty showingProperty​()
      该 Window是否显示（即在用户系统上打开）。
      void sizeToScene​()
      设置此窗口的宽度和高度以匹配此窗口场景的内容大小。
      ReadOnlyDoubleProperty widthProperty​()
      该宽度为 Window 。
      ReadOnlyDoubleProperty xProperty​()
      这个 Window在屏幕上的水平位置。
      ReadOnlyDoubleProperty yProperty​()
      这个 Window在屏幕上的垂直位置。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Property Detail

      • outputScaleX

        public final ReadOnlyDoubleProperty outputScaleXProperty
        Window将在渲染和将输出合成到屏幕或其他目标设备的所有阶段中应用于水平场景坐标的比例。 该属性在不同时间由系统异步更新，包括：
        • 窗口创建
        • 在将窗口移动到Screen之前的某个时间点，可能是在更新Screen属性之前或之后。
        • 响应于输出缩放的用户偏好的变化。
        从以下版本开始：
        9
        另请参见：
        getOutputScaleX()

      • outputScaleY

        public final ReadOnlyDoubleProperty outputScaleYProperty
        Window将适用于垂直场景坐标在渲染和合成输出到屏幕或其他目标设备的所有阶段的规模。 该属性在不同时间由系统异步更新，包括：
        • 窗口创建
        • 在将窗口移动到新的Screen某个时间点，可能在更新Screen属性之前或之后。
        • 响应于输出缩放的用户偏好的变化。
        从以下版本开始：
        9
        另请参见：
        getOutputScaleY()

      • forceIntegerRenderScale

        public final BooleanProperty forceIntegerRenderScaleProperty
        当相关的输出比例有变化时，控制系统默认情况下是否设置整数渲染比例的布尔属性。 renderScale属性将直接更新，并与相关的outputScale属性中的任何更改同时更新，但可以通过后续调用setRenderScale设置器或通过适当使用绑定来覆盖这些值。 此属性不会阻止直接使用renderScale属性对象或方便设置器方法设置非整数值。
        Default value:
        假
        从以下版本开始：
        9
        另请参见：
        isForceIntegerRenderScale() ， setForceIntegerRenderScale(boolean)

      • renderScaleX

        public final DoubleProperty renderScaleXProperty
        Window将其Scene渲染到渲染缓冲区时将使用的水平刻度。 每当outputScaleX属性发生更改时，此属性将自动更新，并且可以通过调用setRenderScaleX()响应outputScaleX属性上的侦听器或通过适当绑定来覆盖该属性。
        Default value:
        outputScaleX
        从以下版本开始：
        9
        另请参见：
        getRenderScaleX() ， setRenderScaleX(double)

      • renderScaleY

        public final DoubleProperty renderScaleYProperty
        当渲染其Scene到渲染缓冲区时， Window将使用的垂直刻度。 每当outputScaleY属性发生更改时，该属性将自动更新，可以通过调用setRenderScaleY()响应outputScaleY属性上的侦听器或通过适当绑定来覆盖该属性。
        Default value:
        outputScaleY
        从以下版本开始：
        9
        另请参见：
        getRenderScaleY() ， setRenderScaleY(double)

      • x

        public final ReadOnlyDoubleProperty xProperty
        这个Window在屏幕上的水平位置。 更改此属性将水平移动Window 。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。
        另请参见：
        getX() ， setX(double)

      • y

        public final ReadOnlyDoubleProperty yProperty
        这个Window在屏幕上的垂直位置。 更改此属性将垂直移动Window 。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。
        另请参见：
        getY() ， setY(double)

      • width

        public final ReadOnlyDoubleProperty widthProperty
        该宽度为Window 。 更改此属性将缩小或扩大Window的宽度。 该值包括可由操作系统添加的任何和所有装饰，例如可调整大小的框架句柄。 典型应用将会改变Scene的宽度。 如果应用程序从未设置此Window将从场景中获取宽度。 最终用户调整窗口大小不会被视为设置应用程序的宽度。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        另请参见：
        getWidth() ， setWidth(double)

      • height

        public final ReadOnlyDoubleProperty heightProperty
        这个高度Window 。 更改此属性将缩小或提高Window的高度。 该值包括操作系统可能添加的任何和所有装饰，例如标题栏。 典型应用将设置Scene高度。 如果应用程序从未设置此窗口，则此窗口将从场景中取出高度。 最终用户调整此窗口大小并不算作应用程序设置的高度。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        另请参见：
        getHeight() ， setHeight(double)

      • focused

        public final ReadOnlyBooleanProperty focusedProperty
        该Window是否具有键盘或输入焦点。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        另请参见：
        isFocused()

      • scene

        public final ReadOnlyObjectProperty<Scene> sceneProperty
        Scene要呈现在这个Window 。 只能有一个Scene上Window的时间，并且Scene只能是一个Window一次。 设置一个Scene在不同Window将导致旧Window到新的收益之前失去了参考。 您可以Scene在Window上互换Scene ，即使是Stage的实例，并将fullScreen设置为true。 如果Window的宽度或高度未被应用程序设置，则设置场景将导致该Window从该场景中取走其宽度或高度。 最终用户调整此窗口大小并不算作应用程序设置宽度或高度。 如果此属性设置在JavaFX应用程序线程之外的线程上，则抛出一个IllegalStateException 。
        Default value:
        空值
        另请参见：
        getScene() ， setScene(Scene)

      • opacity

        public final DoubleProperty opacityProperty
        将Window的不透明度定义为0.0和1.0之间的值。 不透明度反映在Window ，其Decoration及其Scene内容中。 在不支持不透明度的JavaFX运行时平台上，为此变量分配一个值将没有明显差异。 具有0％不透明度的Window是完全半透明的。 通常，具有0％不透明度的Window将不会收到任何鼠标事件。
        Default value:
        1.0
        另请参见：
        getOpacity() ， setOpacity(double)

      • onCloseRequest

        public final ObjectProperty<EventHandler<WindowEvent>> onCloseRequestProperty
        当有外部请求关闭这个Window 。 安装的事件处理程序可以通过消耗接收的事件来阻止关闭窗口。
        另请参见：
        getOnCloseRequest() ， setOnCloseRequest(EventHandler)

      • onShowing

        public final ObjectProperty<EventHandler<WindowEvent>> onShowingProperty
        在窗口显示之前调用。
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • onShown

        public final ObjectProperty<EventHandler<WindowEvent>> onShownProperty
        在窗口显示之后调用。
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • onHiding

        public final ObjectProperty<EventHandler<WindowEvent>> onHidingProperty
        在Window被隐藏之前调用。
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • onHidden

        public final ObjectProperty<EventHandler<WindowEvent>> onHiddenProperty
        在窗口被隐藏之后调用。 当隐藏Window ，调用此事件处理程序，允许开发人员在Window关闭时清理资源或执行其他任务。
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

      • showing

        public final ReadOnlyBooleanProperty showingProperty
        该Window是否显示（即，在用户系统上打开）。 窗口可能是“显示”，但是由于窗口被渲染在另一个窗口后面或由于窗口被放置在监视器之外，用户可能无法看到它。
        Default value:
        假
        另请参见：
        isShowing()

      • eventDispatcher

        public final ObjectProperty<EventDispatcher> eventDispatcherProperty
        指定此节点的事件分派器。 默认事件调度程序将接收的事件发送到已注册的事件处理程序和过滤器。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到替换的调度程序，以维护节点的默认事件处理行为。
        另请参见：
        getEventDispatcher() ， setEventDispatcher(EventDispatcher)

    • 构造方法详细信息

      • Window

        protected Window​()

    • 方法详细信息

      • getWindows

        public static ObservableList<Window> getWindows​()
        返回一个包含对当前显示的JavaFX窗口的引用的列表。 该列表是不可修改的 - 尝试修改此列表将导致在运行时抛出一个UnsupportedOperationException 。
        结果
        包含当前显示的所有窗口的列表。
        从以下版本开始：
        9

      • sizeToScene

        public void sizeToScene​()
        设置此窗口的宽度和高度以匹配此窗口场景的内容大小。

      • centerOnScreen

        public void centerOnScreen​()
        在此窗口中设置x和y属性，以便它在curent屏幕上居中。 当前屏幕是从当前窗口边界和所有屏幕的视觉界限的交集确定的。

      • getOutputScaleX

        public final double getOutputScaleX​()
        获取属性outputScaleX的值。
        Property description:
        Window将在渲染和将输出合成到屏幕或其他目标设备的所有阶段中应用于水平场景坐标的比例。 该属性在不同时间由系统异步更新，包括：
        • 窗口创建
        • 在将窗口移动到新的Screen ，可能在更新Screen属性之前或之后。
        • 响应于输出缩放的用户偏好的变化。
        从以下版本开始：
        9

      • outputScaleXProperty

        public final ReadOnlyDoubleProperty outputScaleXProperty​()
        Window将在渲染和将输出合成到屏幕或其他目标设备的所有阶段中应用于水平场景坐标的比例。 该属性在不同时间由系统异步更新，包括：
        • 窗口创建
        • 在将窗口移动到新的Screen ，可能在更新Screen属性之前或之后。
        • 响应于输出缩放的用户偏好的变化。
        从以下版本开始：
        9
        另请参见：
        getOutputScaleX()

      • getOutputScaleY

        public final double getOutputScaleY​()
        获取属性outputScaleY的值。
        Property description:
        Window将适用于垂直场景坐标在渲染和合成输出到屏幕或其他目标设备的所有阶段的规模。 该属性在不同时间由系统异步更新，包括：
        • 窗口创建
        • 在移动窗口的某个时候， Screen可能在更新Screen属性之前或之后。
        • 响应于输出缩放的用户偏好的变化。
        从以下版本开始：
        9

      • outputScaleYProperty

        public final ReadOnlyDoubleProperty outputScaleYProperty​()
        Window将适用于垂直场景坐标在渲染和合成输出到屏幕或其他目标设备的所有阶段的规模。 该属性在不同时间由系统异步更新，包括：
        • 窗口创建
        • 在移动窗口的某个Screen ，可能在更新Screen属性之前或之后的新的Screen 。
        • 响应于输出缩放的用户偏好的变化。
        从以下版本开始：
        9
        另请参见：
        getOutputScaleY()

      • setForceIntegerRenderScale

        public final void setForceIntegerRenderScale​(boolean forced)
        设置属性forceIntegerRenderScale的值。
        Property description:
        当相关的输出比例有变化时，控制系统默认情况下是否设置整数渲染比例的布尔属性。 renderScale属性将直接更新，并与相关联的outputScale属性中的任何更改同时更新，但可以通过后续调用setRenderScale设置器或通过适当使用绑定来覆盖这些值。 该属性不会直接使用renderScale属性对象或方便设置器方法来阻止设置非整数。
        Default value:
        假
        从以下版本开始：
        9

      • isForceIntegerRenderScale

        public final boolean isForceIntegerRenderScale​()
        获取属性forceIntegerRenderScale的值。
        Property description:
        当相关的输出比例有变化时，控制系统默认情况下是否设置整数渲染比例的布尔属性。 renderScale属性将直接更新，并与相关联的outputScale属性中的任何更改同时更新，但可以通过后续调用setRenderScale设置器或通过适当使用绑定来覆盖这些值。 此属性不会阻止直接使用renderScale属性对象或方便设置器方法设置非整数级别。
        Default value:
        假
        从以下版本开始：
        9

      • forceIntegerRenderScaleProperty

        public final BooleanProperty forceIntegerRenderScaleProperty​()
        当相关的输出比例有变化时，控制系统默认情况下是否设置整数渲染比例的布尔属性。 renderScale属性将直接更新，并与相关联的outputScale属性中的任何更改同时更新，但可以通过后续调用setRenderScale设置器或通过适当使用绑定来覆盖这些值。 该属性不会阻止直接使用renderScale属性对象或方便设置器方法设置非整数级别。
        Default value:
        假
        从以下版本开始：
        9
        另请参见：
        isForceIntegerRenderScale() ， setForceIntegerRenderScale(boolean)

      • setRenderScaleX

        public final void setRenderScaleX​(double scale)
        设置属性renderScaleX的值。
        Property description:
        当渲染Scene到渲染缓冲区时， Window将使用的水平刻度。 每当outputScaleX属性发生更改时，该属性将自动更新，并且可以通过调用setRenderScaleX()响应outputScaleX属性上的侦听器或通过适当绑定来覆盖该属性。
        Default value:
        outputScaleX
        从以下版本开始：
        9

      • getRenderScaleX

        public final double getRenderScaleX​()
        获取属性renderScaleX的值。
        Property description:
        当渲染其Scene到渲染缓冲区时， Window将使用的水平刻度。 每当outputScaleX属性发生更改时，该属性将自动更新，并且可以通过调用setRenderScaleX()以响应outputScaleX属性上的侦听器或通过适当绑定来覆盖该属性。
        Default value:
        outputScaleX
        从以下版本开始：
        9

      • renderScaleXProperty

        public final DoubleProperty renderScaleXProperty​()
        当渲染其Scene到渲染缓冲区时， Window将使用的水平刻度。 只要outputScaleX属性发生更改，该属性就会自动更新，并且可以通过调用setRenderScaleX()响应outputScaleX属性上的侦听器或通过适当绑定来覆盖该属性。
        Default value:
        outputScaleX
        从以下版本开始：
        9
        另请参见：
        getRenderScaleX() ， setRenderScaleX(double)

      • setRenderScaleY

        public final void setRenderScaleY​(double scale)
        设置属性renderScaleY的值。
        Property description:
        Window将其Scene渲染到渲染缓冲区时将使用的垂直刻度。 每当outputScaleY属性发生更改时，该属性将自动更新，并且可以通过调用setRenderScaleY()以响应outputScaleY属性上的侦听器或通过适当绑定来覆盖该属性。
        Default value:
        outputScaleY
        从以下版本开始：
        9

      • getRenderScaleY

        public final double getRenderScaleY​()
        获取属性renderScaleY的值。
        Property description:
        当渲染其Scene到渲染缓冲区时， Window将使用的垂直刻度。 只要outputScaleY属性发生更改，该属性就会自动更新，可以通过调用setRenderScaleY()响应outputScaleY属性上的侦听器或通过适当绑定来覆盖outputScaleY属性。
        Default value:
        outputScaleY
        从以下版本开始：
        9

      • renderScaleYProperty

        public final DoubleProperty renderScaleYProperty​()
        当渲染Scene到渲染缓冲区时， Window将使用的垂直刻度。 每当outputScaleY属性发生更改时，该属性将自动更新，并且可以通过调用setRenderScaleY()响应outputScaleY属性上的侦听器或通过适当绑定来覆盖该属性。
        Default value:
        outputScaleY
        从以下版本开始：
        9
        另请参见：
        getRenderScaleY() ， setRenderScaleY(double)

      • setX

        public final void setX​(double value)
        设置属性x的值。
        Property description:
        这个Window在屏幕上的水平位置。 更改此属性将水平移动Window 。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

      • getX

        public final double getX​()
        获取属性x的值。
        Property description:
        这个水平位置的这个Window在屏幕上。 更改此属性将水平移动Window 。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

      • xProperty

        public final ReadOnlyDoubleProperty xProperty​()
        这个水平位置的这个Window在屏幕上。 更改此属性将水平移动Window 。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。
        另请参见：
        getX() ， setX(double)

      • setY

        public final void setY​(double value)
        设置属性y的值。
        Property description:
        这个Window在屏幕上的垂直位置。 更改此属性将垂直移动Window 。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

      • getY

        public final double getY​()
        获取属性y的值。
        Property description:
        这个Window在屏幕上的垂直位置。 更改此属性将垂直移动Window 。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

      • yProperty

        public final ReadOnlyDoubleProperty yProperty​()
        这个Window在屏幕上的垂直位置。 更改此属性将垂直移动Window 。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。
        另请参见：
        getY() ， setY(double)

      • setWidth

        public final void setWidth​(double value)
        设置属性宽度的值。
        Property description:
        这个宽度Window 。 更改此属性将缩小或扩大Window的宽度。 该值包括可由操作系统添加的任何和所有装饰，例如可调整大小的框架句柄。 典型的应用将会改变Scene的宽度。 如果Window从应用程序未设置，则将从场景中获取宽度。 最终用户调整窗口大小不会被视为设置应用程序的宽度。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

      • getWidth

        public final double getWidth​()
        获取属性宽度的值。
        Property description:
        这个宽度Window 。 更改此属性将缩小或扩大Window的宽度。 该值包括可由操作系统添加的任何和所有装饰，例如可调整大小的框架句柄。 典型应用将会改变Scene的宽度。 如果Window从应用程序未设置，它将从场景中获取宽度。 最终用户调整窗口大小不会被视为设置应用程序的宽度。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

      • widthProperty

        public final ReadOnlyDoubleProperty widthProperty​()
        这个宽度Window 。 更改此属性将缩小或扩大Window的宽度。 该值包括可由操作系统添加的任何和所有装饰，例如可调整大小的框架句柄。 典型的应用将会改变Scene的宽度。 如果应用程序从未设置，此Window将从场景中获取宽度。 最终用户调整窗口大小不会被视为设置应用程序的宽度。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        另请参见：
        getWidth() ， setWidth(double)

      • setHeight

        public final void setHeight​(double value)
        设置属性高度的值。
        Property description:
        这个高度Window 。 更改此属性将缩小或提高Window的高度。 该值包括操作系统可能添加的任何和所有装饰，例如标题栏。 典型的应用将会改变Scene的高度。 如果应用程序从未设置此窗口，则此窗口将从场景中取出高度。 最终用户调整此窗口大小并不算作应用程序设置的高度。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

      • getHeight

        public final double getHeight​()
        获取属性高度的值。
        Property description:
        这个高度Window 。 更改此属性将缩小或提高Window的高度。 该值包括操作系统可能添加的任何和所有装饰，例如标题栏。 典型应用将设置Scene高度。 如果应用程序从未设置此窗口，则此窗口将从场景中取出高度。 最终用户调整此窗口大小并不算作应用程序设置的高度。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

      • heightProperty

        public final ReadOnlyDoubleProperty heightProperty​()
        这个高度Window 。 更改此属性将缩小或提高Window的高度。 该值包括操作系统可能添加的任何和所有装饰，例如标题栏。 典型的应用将会改变Scene的高度。 如果应用程序从未设置此窗口，则此窗口将从场景中取出高度。 最终用户调整此窗口大小并不算作应用程序设置的高度。 如果这个Window是实例Stage ，改变这个属性不会在视觉上影响Window而fullScreen是真的，但会被兑现Window一次fullScreen为假。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        另请参见：
        getHeight() ， setHeight(double)

      • requestFocus

        public final void requestFocus​()
        要求这个 Window得到输入焦点。

      • isFocused

        public final boolean isFocused​()
        获取关注的属性的值。
        Property description:
        该Window是否具有键盘或输入焦点。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

      • focusedProperty

        public final ReadOnlyBooleanProperty focusedProperty​()
        该Window是否具有键盘或输入焦点。

        该属性是只读的，因为它可以由底层平台外部更改，因此不能绑定。

        另请参见：
        isFocused()

      • getProperties

        public final ObservableMap<Object,Object> getProperties​()
        返回此节点上属性的可观察图，主要由应用程序开发人员使用。
        结果
        该节点上属性的可观察地图主要由应用程序开发人员使用
        从以下版本开始：
        JavaFX 8u40

      • hasProperties

        public boolean hasProperties​()
        测试窗口是否具有属性。
        结果
        如果节点有属性，则为true。
        从以下版本开始：
        JavaFX 8u40

      • setUserData

        public void setUserData​(Object value)
        用于设置可以在以后检索的单个Object属性的便利方法。 这在功能上等同于调用getProperties（）。put（Object key，Object value）方法。 这可以稍后通过调用getUserData()来检索。
        参数
        value - 要存储的值 - 以后可以通过调用 getUserData()检索。
        从以下版本开始：
        JavaFX 8u40

      • getUserData

        public Object getUserData​()
        返回先前设置的Object属性，如果没有使用 setUserData(java.lang.Object)方法设置此属性，则返回null。
        结果
        先前设置的对象，如果没有设置属性或设置为null，则为null。
        从以下版本开始：
        JavaFX 8u40

      • setScene

        protected void setScene​(Scene value)
        设置属性场景的值。
        Property description:
        要在Scene上呈现Window 。 只能有一个Scene上Window的时间，并且Scene只能是一个Window一次。 设置一个Scene在不同Window将导致旧Window到新的收益之前失去了参考。 您可以Scene在Window上互换Scene ，即使它是Stage一个实例，而fullScreen设置为true。 如果这个Window的宽度或高度从未被应用程序设置，则设置场景将导致该Window从该场景中取走其宽度或高度。 最终用户调整此窗口大小并不算作应用程序设置宽度或高度。 如果此属性设置在JavaFX应用程序线程之外的线程上，则抛出一个IllegalStateException 。
        Default value:
        空值

      • getScene

        public final Scene getScene​()
        获取属性场景的值。
        Property description:
        要在Scene上呈现Window 。 只能有一个Scene上Window的时间，并且Scene只能是一个Window一次。 在不同的Scene上设置Window将导致旧的Window在新的获取之前丢失参考。 您可以Scene在Window上互换Scene ，即使是Stage的实例，并将fullScreen设置为true。 如果Window的宽度或高度从未被应用程序设置，则设置场景将导致Window从该场景中取走其宽度或高度。 最终用户调整此窗口大小并不算作应用程序设置宽度或高度。 如果此属性设置在除JavaFX应用程序线程之外的线程上，则抛出一个IllegalStateException 。
        Default value:
        空值

      • sceneProperty

        public final ReadOnlyObjectProperty<Scene> sceneProperty​()
        Scene要呈现在这个Window 。 只能有一个Scene上Window的时间，并且Scene只能是一个Window一次。 设置一个Scene在不同Window将导致旧Window到新的收益之前失去了参考。 您可以Scene在Window上互换Scene ，即使是Stage的实例，并将fullScreen设置为true。 如果Window的宽度或高度未被应用程序设置，则设置场景将导致该Window从该场景中取走其宽度或高度。 最终用户调整此窗口大小并不算作应用程序设置宽度或高度。 如果此属性设置在JavaFX应用程序线程之外的线程上，则抛出一个IllegalStateException 。
        Default value:
        空值
        另请参见：
        getScene() ， setScene(Scene)

      • setOpacity

        public final void setOpacity​(double value)
        设置属性不透明度的值。
        Property description:
        将Window的不透明度定义为0.0和1.0之间的值。 不透明度反映在Window ，其Decoration及其Scene内容中。 在不支持不透明度的JavaFX运行时平台上，为此变量分配一个值将没有明显差异。 具有0％不透明度的Window是完全半透明的。 通常，具有0％不透明度的Window将不会收到任何鼠标事件。
        Default value:
        1.0

      • getOpacity

        public final double getOpacity​()
        获取属性不透明度的值。
        Property description:
        将Window的不透明度定义为0.0和1.0之间的值。 不透明度反映在Window ，其Decoration及其Scene内容中。 在不支持不透明度的JavaFX运行时平台上，为此变量分配一个值将没有明显差异。 具有0％不透明度的Window是完全半透明的。 通常，具有0％不透明度的Window将不会收到任何鼠标事件。
        Default value:
        1.0

      • opacityProperty

        public final DoubleProperty opacityProperty​()
        将Window的不透明度定义为0.0和1.0之间的值。 不透明度反映在Window ，其Decoration及其Scene内容中。 在不支持不透明度的JavaFX运行时平台上，为此变量分配一个值将没有明显差异。 具有0％不透明度的Window是完全半透明的。 通常，具有0％不透明度的Window将不会收到任何鼠标事件。
        Default value:
        1.0
        另请参见：
        getOpacity() ， setOpacity(double)

      • setOnCloseRequest

        public final void setOnCloseRequest​(EventHandler<WindowEvent> value)
        设置属性onCloseRequest的值。
        Property description:
        当有外部请求关闭此Window 。 安装的事件处理程序可以通过消耗接收的事件来阻止关闭窗口。

      • getOnCloseRequest

        public final EventHandler<WindowEvent> getOnCloseRequest​()
        获取属性onCloseRequest的值。
        Property description:
        当有外部请求关闭这个Window 。 安装的事件处理程序可以通过消耗接收的事件来阻止关闭窗口。

      • onCloseRequestProperty

        public final ObjectProperty<EventHandler<WindowEvent>> onCloseRequestProperty​()
        当有外部请求关闭此Window 。 安装的事件处理程序可以通过消耗接收的事件来阻止关闭窗口。
        另请参见：
        getOnCloseRequest() ， setOnCloseRequest(EventHandler)

      • setOnShowing

        public final void setOnShowing​(EventHandler<WindowEvent> value)
        设置属性onShowing的值。
        Property description:
        在窗口显示之前调用。

      • getOnShowing

        public final EventHandler<WindowEvent> getOnShowing​()
        获取属性onShowing的值。
        Property description:
        在窗口显示之前调用。

      • onShowingProperty

        public final ObjectProperty<EventHandler<WindowEvent>> onShowingProperty​()
        在窗口显示之前调用。
        另请参见：
        getOnShowing() ， setOnShowing(EventHandler)

      • setOnShown

        public final void setOnShown​(EventHandler<WindowEvent> value)
        设置属性onShown的值。
        Property description:
        在窗口显示之后调用。

      • getOnShown

        public final EventHandler<WindowEvent> getOnShown​()
        获取onShown属性的值。
        Property description:
        在窗口显示之后调用。

      • onShownProperty

        public final ObjectProperty<EventHandler<WindowEvent>> onShownProperty​()
        在窗口显示之后调用。
        另请参见：
        getOnShown() ， setOnShown(EventHandler)

      • setOnHiding

        public final void setOnHiding​(EventHandler<WindowEvent> value)
        设置属性onHiding的值。
        Property description:
        在Window被隐藏之前调用。

      • getOnHiding

        public final EventHandler<WindowEvent> getOnHiding​()
        获取属性onHiding的值。
        Property description:
        在Window被隐藏之前调用。

      • onHidingProperty

        public final ObjectProperty<EventHandler<WindowEvent>> onHidingProperty​()
        在Window被隐藏之前调用。
        另请参见：
        getOnHiding() ， setOnHiding(EventHandler)

      • setOnHidden

        public final void setOnHidden​(EventHandler<WindowEvent> value)
        设置属性onHidden的值。
        Property description:
        在窗口被隐藏之后调用。 当隐藏Window ，将调用此事件处理程序，以允许开发人员在Window关闭时清理资源或执行其他任务。

      • getOnHidden

        public final EventHandler<WindowEvent> getOnHidden​()
        获取属性onHidden的值。
        Property description:
        在窗口被隐藏之后调用。 当隐藏Window ，将调用此事件处理程序，以允许开发人员在Window关闭时清理资源或执行其他任务。

      • onHiddenProperty

        public final ObjectProperty<EventHandler<WindowEvent>> onHiddenProperty​()
        在窗口被隐藏之后调用。 当隐藏Window ，将调用此事件处理程序，以允许开发人员在Window关闭时清理资源或执行其他任务。
        另请参见：
        getOnHidden() ， setOnHidden(EventHandler)

      • isShowing

        public final boolean isShowing​()
        获取显示的属性的值。
        Property description:
        该Window是否显示（即在用户系统上打开）。 窗口可能是“显示”，但是由于窗口被渲染在另一个窗口后面或由于窗口被放置在监视器之外，用户可能无法看到它。
        Default value:
        假

      • showingProperty

        public final ReadOnlyBooleanProperty showingProperty​()
        该Window是否显示（即，在用户系统上打开）。 窗口可能是“显示”，但是由于窗口被渲染在另一个窗口后面或由于窗口被放置在监视器之外，用户可能无法看到它。
        Default value:
        假
        另请参见：
        isShowing()

      • show

        protected void show​()
        尝试通过将可见性设置为true来显示此窗口
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。

      • hide

        public void hide​()
        尝试通过将可见性设置为false来隐藏此窗口。
        异常
        IllegalStateException - 如果在除JavaFX应用程序线程之外的线程上调用此方法。

      • setEventDispatcher

        public final void setEventDispatcher​(EventDispatcher value)
        设置属性eventDispatcher的值。
        Property description:
        指定此节点的事件分派器。 默认事件调度程序将接收的事件发送到已注册的事件处理程序和过滤器。 当使用新的EventDispatcher替换值时，新的分派器应将事件转发到替换的分派器，以维护节点的默认事件处理行为。

      • getEventDispatcher

        public final EventDispatcher getEventDispatcher​()
        获取属性eventDispatcher的值。
        Property description:
        指定此节点的事件分派器。 默认事件调度程序将接收的事件发送到已注册的事件处理程序和过滤器。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到已替换的调度程序，以维护节点的默认事件处理行为。

      • eventDispatcherProperty

        public final ObjectProperty<EventDispatcher> eventDispatcherProperty​()
        指定此节点的事件分派器。 默认事件调度程序将接收的事件发送到已注册的事件处理程序和过滤器。 当使用新的EventDispatcher替换值时，新的调度程序应将事件转发到替换的调度程序，以维护节点的默认事件处理行为。
        另请参见：
        getEventDispatcher() ， setEventDispatcher(EventDispatcher)

      • addEventHandler

        public final <T extends Event> void addEventHandler​(EventType<T> eventType,
                                                    EventHandler<? super T> eventHandler)
        向此节点注册事件处理程序。 当事件传送的冒泡阶段节点收到指定类型的Event时，调用处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 由处理程序接收的事件的类型
        eventHandler - 要注册的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • removeEventHandler

        public final <T extends Event> void removeEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        从此节点注销先前注册的事件处理程序。 一个处理程序可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 要注销的事件类型
        eventHandler - 要注销的处理程序
        异常
        NullPointerException - 如果事件类型或处理程序为空

      • addEventFilter

        public final <T extends Event> void addEventFilter​(EventType<T> eventType,
                                                   EventHandler<? super T> eventFilter)
        向此节点注册事件过滤器。 当事件传送的捕获阶段，当节点接收到指定类型的Event时，将调用该过滤器。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 过滤器接收的事件的类型
        eventFilter - 要注册的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空

      • removeEventFilter

        public final <T extends Event> void removeEventFilter​(EventType<T> eventType,
                                                      EventHandler<? super T> eventFilter)
        从此节点注销先前注册的事件过滤器。 一个过滤器可能已被注册用于不同的事件类型，因此调用者需要指定特定的事件类型，从中注销过滤器。
        参数类型
        T - 过滤器的特定事件类
        参数
        eventType - 要注销的事件类型
        eventFilter - 要注销的过滤器
        异常
        NullPointerException - 如果事件类型或过滤器为空

      • setEventHandler

        protected final <T extends Event> void setEventHandler​(EventType<T> eventType,
                                                       EventHandler<? super T> eventHandler)
        设置要用于此事件类型的处理程序。 一次只能有一个这样的处理程序。 这个处理程序被保证被首先调用。 这用于注册用户定义的onFoo事件处理程序。
        参数类型
        T - 处理程序的特定事件类
        参数
        eventType - 与给定eventHandler关联的事件类型
        eventHandler - 要注册的处理程序，或者取消注册为null
        异常
        NullPointerException - 如果事件类型为空

      • fireEvent

        public final void fireEvent​(Event event)
        触发指定的事件。

        必须在FX用户线程上调用此方法。

        参数
        event - 事件触发

      • buildEventDispatchChain

        public EventDispatchChain buildEventDispatchChain​(EventDispatchChain tail)
        为此窗口构建事件调度链。
        Specified by:
        buildEventDispatchChain在接口 EventTarget
        参数
        tail - 建立起来的初始链
        结果
        the resulting event dispatch chain for this window
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


WindowEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.graphics
软件包 javafx.stage

Class WindowEvent

  • java.lang.Object
    • java.util.EventObject
      • javafx.event.Event
        • javafx.stage.WindowEvent
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class WindowEvent
extends Event
    与窗口显示/隐藏操作相关的事件。
    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static EventType<WindowEvent> ANY
      所有窗口事件类型的常用超类型。
      static EventType<WindowEvent> WINDOW_CLOSE_REQUEST
      当有外部请求关闭该窗口时，此事件将传递到窗口。
      static EventType<WindowEvent> WINDOW_HIDDEN
      此事件发生在隐藏后的窗口上。
      static EventType<WindowEvent> WINDOW_HIDING
      此事件发生在隐藏之前的窗口上。
      static EventType<WindowEvent> WINDOW_SHOWING
      此事件发生在显示之前的窗口上。
      static EventType<WindowEvent> WINDOW_SHOWN
      此事件发生在显示之后的窗口上。

      • Fields inherited from class javafx.event.Event

        consumed, eventType, NULL_SOURCE_TARGET, target

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      WindowEvent​(Window source, EventType<? extends Event> eventType)
      构造一个新的 Event与指定的事件源，目标和类型。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      WindowEvent copyFor​(Object newSource, EventTarget newTarget)
      使用指定的事件源和目标创建并返回此事件的副本。
      WindowEvent copyFor​(Object newSource, EventTarget newTarget, EventType<WindowEvent> type)
      用给定的字段替换给定事件的副本。
      EventType<WindowEvent> getEventType​()
      获取此事件的事件类型。
      String toString​()
      返回此 WindowEvent对象的字符串表示形式。

      • Methods inherited from class javafx.event.Event

        clone, consume, fireEvent, getTarget, isConsumed

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANY

        public static final EventType<WindowEvent> ANY
        所有窗口事件类型的常用超类型。

      • WINDOW_SHOWING

        public static final EventType<WindowEvent> WINDOW_SHOWING
        此事件发生在显示之前的窗口上。

      • WINDOW_SHOWN

        public static final EventType<WindowEvent> WINDOW_SHOWN
        此事件发生在显示之后的窗口上。

      • WINDOW_HIDING

        public static final EventType<WindowEvent> WINDOW_HIDING
        此事件发生在隐藏之前的窗口上。

      • WINDOW_HIDDEN

        public static final EventType<WindowEvent> WINDOW_HIDDEN
        此事件发生在隐藏后的窗口上。

      • WINDOW_CLOSE_REQUEST

        public static final EventType<WindowEvent> WINDOW_CLOSE_REQUEST
        当有外部请求关闭该窗口时，此事件将传递到窗口。 如果事件没有被任何安装的窗口事件处理程序使用，则此事件的默认处理程序将关闭相应的窗口。

    • 构造方法详细信息

      • WindowEvent

        public WindowEvent​(Window source,
                   EventType<? extends Event> eventType)
        使用指定的事件源，目标和类型构造新的Event 。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        参数
        source - 发送事件的事件源
        eventType - 事件类型

    • 方法详细信息

      • toString

        public String toString​()
        返回此 WindowEvent对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        这个 WindowEvent对象的字符串表示形式。

      • copyFor

        public WindowEvent copyFor​(Object newSource,
                           EventTarget newTarget)
        描述从类复制： Event
        使用指定的事件源和目标创建并返回此事件的副本。 如果源或目标设置为null ，它将被替换为NULL_SOURCE_TARGET值。
        重写：
        copyFor在 Event
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        结果
        事件副本与新的源和目标

      • copyFor

        public WindowEvent copyFor​(Object newSource,
                           EventTarget newTarget,
                           EventType<WindowEvent> type)
        用给定的字段替换给定事件的副本。
        参数
        newSource - 复制事件的新来源
        newTarget - 复制事件的新目标
        type - 新的eventType
        结果
        事件副本与字段被替换
        从以下版本开始：
        JavaFX 8.0

      • getEventType

        public EventType<WindowEvent> getEventType​()
        描述从类复制： Event
        获取此事件的事件类型。 同一个Event类的对象可以有不同的事件类型。 这些事件类型进一步指定发生什么样的事件。
        重写：
        getEventType在 Event
        结果
        the event type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Class javafx.stage.DirectoryChooser (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.DirectoryChooser

No usage of javafx.stage.DirectoryChooser
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.FileChooser (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.FileChooser

No usage of javafx.stage.FileChooser
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.FileChooser.ExtensionFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.FileChooser.ExtensionFilter

  • Packages that use FileChooser.ExtensionFilter
    软件包 描述
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of FileChooser.ExtensionFilter in javafx.stage

      Methods in javafx.stage that return FileChooser.ExtensionFilter
      Modifier and Type 方法 描述
      FileChooser.ExtensionFilter FileChooser.getSelectedExtensionFilter​()
      获取selectedExtensionFilter属性的值。
      Methods in javafx.stage that return types with arguments of type FileChooser.ExtensionFilter
      Modifier and Type 方法 描述
      ObservableList<FileChooser.ExtensionFilter> FileChooser.getExtensionFilters​()
      获取显示文件对话框中使用的扩展过滤器。
      ObjectProperty<FileChooser.ExtensionFilter> FileChooser.selectedExtensionFilterProperty​()
      此属性用于为下一个显示的对话框预先选择扩展过滤器，并从被忽略的对话框中读取用户选择的扩展过滤器。
      Methods in javafx.stage with parameters of type FileChooser.ExtensionFilter
      Modifier and Type 方法 描述
      void FileChooser.setSelectedExtensionFilter​(FileChooser.ExtensionFilter filter)
      设置属性selectedExtensionFilter的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.Modality (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.Modality

  • Packages that use Modality
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of Modality in javafx.scene.control

      Methods in javafx.scene.control that return Modality
      Modifier and Type 方法 描述
      Modality Dialog.getModality​()
      检索此对话框的模态属性。
      Methods in javafx.scene.control with parameters of type Modality
      Modifier and Type 方法 描述
      void Dialog.initModality​(Modality modality)
      指定此对话框的模态。

    • Uses of Modality in javafx.stage

      Methods in javafx.stage that return Modality
      Modifier and Type 方法 描述
      Modality Stage.getModality​()
      检索此阶段的模态属性。
      static Modality Modality.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Modality[] Modality.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.stage with parameters of type Modality
      Modifier and Type 方法 描述
      void Stage.initModality​(Modality modality)
      指定此阶段的模式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.Popup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.Popup

No usage of javafx.stage.Popup
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.PopupWindow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.PopupWindow

  • Packages that use PopupWindow
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of PopupWindow in javafx.scene.control

      Subclasses of PopupWindow in javafx.scene.control
      Modifier and Type Class 描述
      class  ContextMenu
      一个包含菜单项的ObservableList的弹出控件。
      class  PopupControl
      PopupWindow的扩展，允许CSS样式。
      class  Tooltip
      工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。

    • Uses of PopupWindow in javafx.stage

      Subclasses of PopupWindow in javafx.stage
      Modifier and Type Class 描述
      class  Popup
      弹出窗口是用于场景图形的特殊的类似窗口的容器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.PopupWindow.AnchorLocation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.PopupWindow.AnchorLocation

  • Packages that use PopupWindow.AnchorLocation
    软件包 描述
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of PopupWindow.AnchorLocation in javafx.stage

      Methods in javafx.stage that return PopupWindow.AnchorLocation
      Modifier and Type 方法 描述
      PopupWindow.AnchorLocation PopupWindow.getAnchorLocation​()
      获取属性anchorLocation的值。
      static PopupWindow.AnchorLocation PopupWindow.AnchorLocation.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PopupWindow.AnchorLocation[] PopupWindow.AnchorLocation.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.stage that return types with arguments of type PopupWindow.AnchorLocation
      Modifier and Type 方法 描述
      ObjectProperty<PopupWindow.AnchorLocation> PopupWindow.anchorLocationProperty​()
      指定弹出式定位中使用的弹出式锚点。
      Methods in javafx.stage with parameters of type PopupWindow.AnchorLocation
      Modifier and Type 方法 描述
      void PopupWindow.setAnchorLocation​(PopupWindow.AnchorLocation value)
      设置属性anchorLocation的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.Screen (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.Screen

  • Packages that use Screen
    软件包 描述
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of Screen in javafx.stage

      Methods in javafx.stage that return Screen
      Modifier and Type 方法 描述
      static Screen Screen.getPrimary​()
      主要 Screen 。
      Methods in javafx.stage that return types with arguments of type Screen
      Modifier and Type 方法 描述
      static ObservableList<Screen> Screen.getScreens​()
      当前可用的可观察列表 Screens 。
      static ObservableList<Screen> Screen.getScreensForRectangle​(double x, double y, double width, double height)
      返回与所提供的矩形相交的ObservableList为 Screens 。
      static ObservableList<Screen> Screen.getScreensForRectangle​(Rectangle2D r)
      返回与所提供的矩形相交的ObservableList Screens 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.Stage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.Stage

  • Packages that use Stage
    软件包 描述
    javafx.application
    提供应用程序生命周期类。

    • Uses of Stage in javafx.application

      Methods in javafx.application with parameters of type Stage
      Modifier and Type 方法 描述
      abstract void Application.start​(Stage primaryStage)
      所有JavaFX应用程序的主要入口点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.StageStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.StageStyle

  • Packages that use StageStyle
    软件包 描述
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of StageStyle in javafx.scene.control

      Methods in javafx.scene.control with parameters of type StageStyle
      Modifier and Type 方法 描述
      void Dialog.initStyle​(StageStyle style)
      指定此对话框的样式。

    • Uses of StageStyle in javafx.stage

      Methods in javafx.stage that return StageStyle
      Modifier and Type 方法 描述
      StageStyle Stage.getStyle​()
      检索此阶段的样式属性。
      static StageStyle StageStyle.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StageStyle[] StageStyle.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javafx.stage with parameters of type StageStyle
      Modifier and Type 方法 描述
      void Stage.initStyle​(StageStyle style)
      指定此阶段的样式。
      Constructors in javafx.stage with parameters of type StageStyle
      Constructor 描述
      Stage​(StageStyle style)
      创建一个新的实例 Stage 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.Window (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.Window

  • Packages that use Window
    软件包 描述
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of Window in javafx.print

      Methods in javafx.print with parameters of type Window
      Modifier and Type 方法 描述
      boolean PrinterJob.showPageSetupDialog​(Window owner)
      显示页面设置对话框。
      boolean PrinterJob.showPrintDialog​(Window owner)
      显示打印对话框。

    • Uses of Window in javafx.scene

      Methods in javafx.scene that return Window
      Modifier and Type 方法 描述
      Window Scene.getWindow​()
      获取属性窗口的值。
      Methods in javafx.scene that return types with arguments of type Window
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Window> Scene.windowProperty​()
      该 Window为这 Scene

    • Uses of Window in javafx.scene.control

      Subclasses of Window in javafx.scene.control
      Modifier and Type Class 描述
      class  ContextMenu
      一个包含菜单项的ObservableList的弹出控件。
      class  PopupControl
      PopupWindow的扩展，允许CSS样式。
      class  Tooltip
      工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。
      Methods in javafx.scene.control that return Window
      Modifier and Type 方法 描述
      Window Dialog.getOwner​()
      检索该对话框的所有者窗口，或者取消未知对话框的null。
      Methods in javafx.scene.control with parameters of type Window
      Modifier and Type 方法 描述
      void Dialog.initOwner​(Window window)
      指定该对话框的所有者Window ，或者对于顶级的未知对话框，该值为null。

    • Uses of Window in javafx.stage

      Subclasses of Window in javafx.stage
      Modifier and Type Class 描述
      class  Popup
      弹出窗口是用于场景图形的特殊的类似窗口的容器。
      class  PopupWindow
      PopupWindow是各种不同类型的基于弹出窗口的窗口的父级，包括Popup和Tooltip和ContextMenu 。
      class  Stage
      JavaFX Stage类是顶级的JavaFX容器。
      Methods in javafx.stage that return Window
      Modifier and Type 方法 描述
      Window Stage.getOwner​()
      检索该阶段的所有者窗口，或者取消未知阶段的空值。
      Window PopupWindow.getOwnerWindow​()
      获取属性ownerWindow的值。
      Methods in javafx.stage that return types with arguments of type Window
      Modifier and Type 方法 描述
      static ObservableList<Window> Window.getWindows​()
      返回一个包含对当前显示的JavaFX窗口的引用的列表。
      ReadOnlyObjectProperty<Window> PopupWindow.ownerWindowProperty​()
      作为此弹出窗口的父窗口。
      Methods in javafx.stage with parameters of type Window
      Modifier and Type 方法 描述
      void Stage.initOwner​(Window owner)
      指定此阶段的所有者窗口，或者指定顶级，未知级别的空值。
      void PopupWindow.show​(Window owner)
      显示弹出窗口。
      void PopupWindow.show​(Window ownerWindow, double anchorX, double anchorY)
      显示屏幕上指定位置的弹出窗口。
      File DirectoryChooser.showDialog​(Window ownerWindow)
      显示新的目录选择对话框。
      File FileChooser.showOpenDialog​(Window ownerWindow)
      显示一个新的文件打开对话框。
      List<File> FileChooser.showOpenMultipleDialog​(Window ownerWindow)
      显示一个新的文件打开对话框，其中可以选择多个文件。
      File FileChooser.showSaveDialog​(Window ownerWindow)
      显示一个新的文件保存对话框。
      Constructors in javafx.stage with parameters of type Window
      Constructor 描述
      WindowEvent​(Window source, EventType<? extends Event> eventType)
      使用指定的事件源，目标和类型构造新的 Event 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.stage.WindowEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.stage.WindowEvent

  • Packages that use WindowEvent
    软件包 描述
    javafx.stage
    提供JavaFX内容的顶级容器类。

    • Uses of WindowEvent in javafx.stage

      Fields in javafx.stage with type parameters of type WindowEvent
      Modifier and Type Field 描述
      static EventType<WindowEvent> WindowEvent.ANY
      所有窗口事件类型的常用超类型。
      static EventType<WindowEvent> WindowEvent.WINDOW_CLOSE_REQUEST
      当有外部请求关闭该窗口时，此事件将传递到窗口。
      static EventType<WindowEvent> WindowEvent.WINDOW_HIDDEN
      此事件发生在隐藏后的窗口上。
      static EventType<WindowEvent> WindowEvent.WINDOW_HIDING
      此事件发生在隐藏之前的窗口上。
      static EventType<WindowEvent> WindowEvent.WINDOW_SHOWING
      此事件发生在显示之前的窗口上。
      static EventType<WindowEvent> WindowEvent.WINDOW_SHOWN
      此事件发生在显示之后的窗口上。
      Methods in javafx.stage that return WindowEvent
      Modifier and Type | 方法 | 描述
      WindowEvent | WindowEvent.copyFor​(Object newSource, EventTarget newTarget)
      WindowEvent WindowEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<WindowEvent> type)
      用给定的字段替换给定事件的副本。
      Methods in javafx.stage that return types with arguments of type WindowEvent
      Modifier and Type | 方法 | 描述
      EventType<WindowEvent> | WindowEvent.getEventType​()
      EventHandler<WindowEvent> Window.getOnCloseRequest​()
      获取属性onCloseRequest的值。
      EventHandler<WindowEvent> Window.getOnHidden​()
      获取属性onHidden的值。
      EventHandler<WindowEvent> Window.getOnHiding​()
      获取属性onHiding的值。
      EventHandler<WindowEvent> Window.getOnShowing​()
      获取属性onShowing的值。
      EventHandler<WindowEvent> Window.getOnShown​()
      获取onShown属性的值。
      ObjectProperty<EventHandler<WindowEvent>> Window.onCloseRequestProperty​()
      当有外部请求关闭此 Window 。
      ObjectProperty<EventHandler<WindowEvent>> Window.onHiddenProperty​()
      在窗口被隐藏之后调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onHidingProperty​()
      在Window被隐藏之前调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onShowingProperty​()
      在窗口显示之前调用。
      ObjectProperty<EventHandler<WindowEvent>> Window.onShownProperty​()
      在窗口显示之后调用。
      Method parameters in javafx.stage with type arguments of type WindowEvent
      Modifier and Type 方法 描述
      WindowEvent WindowEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<WindowEvent> type)
      用给定的字段替换给定事件的副本。
      void Window.setOnCloseRequest​(EventHandler<WindowEvent> value)
      设置属性onCloseRequest的值。
      void Window.setOnHidden​(EventHandler<WindowEvent> value)
      设置属性onHidden的值。
      void Window.setOnHiding​(EventHandler<WindowEvent> value)
      设置属性onHiding的值。
      void Window.setOnShowing​(EventHandler<WindowEvent> value)
      设置属性onShowing的值。
      void Window.setOnShown​(EventHandler<WindowEvent> value)
      设置属性onShown的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util

Interface Builder<T>

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Builder<T>
    代表构建器的界面。 构建器是用于构建其他对象的对象。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      T build​()
      构建并返回对象。

    • 方法详细信息

      • build

        T build​()
        构建并返回对象。
        结果
        物体
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BuilderFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util

Interface BuilderFactory

  • 所有已知实现类：
    JavaFXBuilderFactory
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface BuilderFactory
    界面代表建筑工厂。 建造工厂用于生产建筑商。
    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Builder<?> getBuilder​(Class<?> type)
      返回适用于构造给定类型实例的构建器。

    • 方法详细信息

      • getBuilder

        Builder<?> getBuilder​(Class<?> type)
        返回适用于构造给定类型实例的构建器。
        参数
        type - 给定类型或null
        结果
        一个给定类型的建筑工，或 null如果这个工厂不生产这种类型的建筑商。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Callback (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util

Interface Callback<P,R>

  • 参数类型
    P - 提供给 call方法的参数的类型。
    R - call方法的返回类型。
    所有已知实现类：
    MapValueFactory ， PropertyValueFactory ， TreeItemPropertyValueFactory
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Callback<P,R>
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。

    回调用两个通用参数定义：第一个参数指定传递给call方法的对象的类型，第二个参数指定方法的返回类型。

    从以下版本开始：
    JavaFX 2.0

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      R call​(P param)
      call方法在需要时被调用，并且被赋予类型为P的单个参数，并且要求返回类型为R的对象。

    • 方法详细信息

      • call

        R call​(P param)
        call方法在需要时被调用，并且被赋予类型为P的单个参数，要求返回类型为R的对象。
        参数
        param - 应该确定返回值的单个参数。
        结果
        可以基于所提供的参数值来确定类型R的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Duration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util

Class Duration

  • java.lang.Object
    • javafx.util.Duration
  • All Implemented Interfaces:
    Serializable ， Comparable<Duration>

    public class Duration
extends Object
implements Comparable<Duration>, Serializable

    定义持续时间的类。 持续时间实例是不可变的，因此被替换而不是修改，类似于BigDecimal 。 持续时间可以使用构造函数创建，或静态构造方法之一，如seconds(double)或minutes(double) 。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Duration INDEFINITE
      无限期。
      static Duration ONE
      持续时间为1毫秒。
      static Duration UNKNOWN
      一段时间的未知数量。
      static Duration ZERO
      持续时间为0（无时间）。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Duration​(double millis)
      创建一个新的持续时间，具有潜在的分数毫秒分辨率。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Duration add​(Duration other)
      添加此实例和另一个Duration实例以返回一个新的Duration实例。
      int compareTo​(Duration d)
      比较由此对象和指定对象表示的持续时间。
      Duration divide​(double n)
      将此实例除以一个数字以返回一个新的Duration实例。
      Duration divide​(Duration other)
      已过时。
      这种方法通过不考虑单位产生令人惊讶的结果。 改用divide(double) 。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      boolean greaterThan​(Duration other)
      如果指定的持续时间大于（>）此实例，则返回true。
      boolean greaterThanOrEqualTo​(Duration other)
      如果指定的持续时间大于或等于（> =）此实例，则返回true。
      int hashCode​()
      返回此 Duration对象的哈希码。
      static Duration hours​(double h)
      返回一个表示指定小时数的Duration实例的Factory方法。
      boolean isIndefinite​()
      获取此Duration实例是否是不确定的。
      boolean isUnknown​()
      获取此Duration实例是否为未知。
      boolean lessThan​(Duration other)
      如果指定的持续时间小于（<），则返回true。
      boolean lessThanOrEqualTo​(Duration other)
      如果指定的持续时间小于或等于（<=），则返回true。
      static Duration millis​(double ms)
      返回一个指定数毫秒的Duration实例的Factory方法。
      static Duration minutes​(double m)
      返回一个表示指定分钟数的Duration实例的Factory方法。
      Duration multiply​(double n)
      将此实例与代表毫秒的数字相乘并返回新的持续时间。
      Duration multiply​(Duration other)
      已过时。
      这种方法通过不考虑单位产生令人惊讶的结果。 改用multiply(double) 。
      Duration negate​()
      从此实例返回一个具有负数毫秒的新的Duration实例。
      static Duration seconds​(double s)
      返回一个表示指定秒数的Duration实例的Factory方法。
      Duration subtract​(Duration other)
      从此实例中减去其他Duration实例以返回一个新的Duration实例。
      double toHours​()
      返回此期间的小时数，如果期间为INDEFINITE，则为Double.POSITIVE_INFINITY，如果期间为UNKNOWN，则返回NaN。
      double toMillis​()
      返回此期间的毫秒数或Double.POSITIVE_INFINITY，如果期间为INDEFINITE，则返回NaN（如果期间为UNKNOWN）。
      double toMinutes​()
      如果期间为INDEFINITE，则返回此期间的分钟数或Double.POSITIVE_INFINITY，如果期间为UNKNOWN，则返回NaN。
      double toSeconds​()
      返回此期间的秒数，如果期间为INDEFINITE，则返回Double.POSITIVE_INFINITY，如果期间为UNKNOWN，则返回NaN。
      String toString​()
      返回此 Duration对象的字符串表示形式。
      static Duration valueOf​(String time)
      在一段指定时间内返回一个Duration实例的Factory方法。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ZERO

        public static final Duration ZERO
        持续时间为0（无时间）。

      • ONE

        public static final Duration ONE
        持续时间为1毫秒。

      • INDEFINITE

        public static final Duration INDEFINITE
        无限期。

      • UNKNOWN

        public static final Duration UNKNOWN
        一段时间的未知数量。

    • 构造方法详细信息

      • Duration

        public Duration​(double millis)
        创建一个新的持续时间，具有潜在的分数毫秒分辨率。
        参数
        millis - 毫秒数

    • 方法详细信息

      • valueOf

        public static Duration valueOf​(String time)
        在一段指定时间内返回一个Duration实例的Factory方法。 语法为“[number] [ms | s | m | h]”。
        参数
        time - 正确格式化的非空字符串。 前导空格或尾随空格将无法正确解析。 如果时间为空，则抛出NullPointerException异常。
        结果
        一个持续时间由 time表示

      • millis

        public static Duration millis​(double ms)
        返回一个指定数毫秒的Duration实例的Factory方法。
        参数
        ms - 毫秒数
        结果
        指定毫秒数的Duration实例

      • seconds

        public static Duration seconds​(double s)
        返回一个表示指定秒数的Duration实例的Factory方法。
        参数
        s - 秒数
        结果
        指定秒数的Duration实例

      • minutes

        public static Duration minutes​(double m)
        返回一个表示指定分钟数的Duration实例的Factory方法。
        参数
        m - 分钟数
        结果
        指定分钟数的持续时间实例

      • hours

        public static Duration hours​(double h)
        返回一个表示指定小时数的Duration实例的Factory方法。
        参数
        h - 小时数
        结果
        一个表示指定小时数的持续时间实例

      • toMillis

        public double toMillis​()
        返回此期间的毫秒数或Double.POSITIVE_INFINITY，如果期间为INDEFINITE，则返回NaN（如果期间为UNKNOWN）。
        结果
        持续时间以毫秒为单位

      • toSeconds

        public double toSeconds​()
        返回此期间的秒数，如果期间为INDEFINITE，则返回Double.POSITIVE_INFINITY，如果期间为UNKNOWN，则返回NaN。
        结果
        持续时间以秒为单位

      • toMinutes

        public double toMinutes​()
        如果期间为INDEFINITE，则返回此期间的分钟数或Double.POSITIVE_INFINITY，如果期间为UNKNOWN，则返回NaN。
        结果
        持续时间以分数分钟

      • toHours

        public double toHours​()
        返回此期间的小时数，如果期间为INDEFINITE，则为Double.POSITIVE_INFINITY，如果期间为UNKNOWN，则返回NaN。
        结果
        持续时间为小时

      • add

        public Duration add​(Duration other)
        添加此实例和另一个Duration实例以返回一个新的Duration实例。 如果任一实例为INDEFINITE，请返回INDEFINITE。 如果任一实例为UNKNOWN，则返回UNKNOWN。 此方法不会更改被调用的持续时间实例的值。
        参数
        other - 不能为空
        结果
        将这个持续时间添加到其他持续时间的结果。 这与millis + other.millis使用双重算术相同

      • subtract

        public Duration subtract​(Duration other)
        从此实例中减去其他Duration实例以返回一个新的Duration实例。 如果任一实例为UNKNOWN，则返回UNKNOWN。 否则，如果任一实例为INDEFINITE，则返回INDEFINITE。 此方法不会更改被调用的持续时间实例的值。
        参数
        other - 不能为空
        结果
        从该持续时间中减去其他持续时间的结果。 这与millis - other.millis使用双重算术相同

      • multiply

        @Deprecated
public Duration multiply​(Duration other)
        已过时。 这种方法通过不考虑单位产生令人惊讶的结果。 改用multiply(double) 。
        将此实例与一个数字相乘以返回一个新的Duration实例。 如果任一实例为INDEFINITE，请返回INDEFINITE。 如果“持续时间”实例为“未知”，则返回UNKNOWN。 此方法不会更改被调用的持续时间实例的值。
        参数
        other - 不能为空
        结果
        这个持续时间与其他持续时间相乘的结果。 这与millis * other.millis使用双重算术相同

      • multiply

        public Duration multiply​(double n)
        将此实例与代表毫秒的数字相乘并返回新的持续时间。 如果被叫的持续时间实例为INDEFINITE，则返回INDEFINITE。 如果被叫的持续时间实例为UNKNOWN，则返回UNKNOWN。 此方法不会更改被调用的持续时间实例的值。
        参数
        n - 以分数毫秒为单位乘以的量
        结果
        这个持续时间与n相乘的结果。 这与使用双重算术的millis * n相同

      • divide

        public Duration divide​(double n)
        将此实例除以一个数字以返回一个新的Duration实例。 如果被叫的持续时间实例为INDEFINITE，则返回INDEFINITE。 如果被叫的持续时间实例为UNKNOWN，则返回UNKNOWN。 此方法不会更改被调用的持续时间实例的值。
        参数
        n - 以分数毫秒为单位的分数
        结果
        将这个持续时间除以n的结果。 这与使用双算术的millis / n相同

      • divide

        @Deprecated
public Duration divide​(Duration other)
        已过时。 这种方法通过不考虑单位产生令人惊讶的结果。 改用divide(double) 。
        将此实例除以另一个持续时间以返回比率。 如果两个实例都是INDEFINITE，返回NaN。 如果此实例为INDEFINITE，则返回POSITIVE_INFINITY如果其他实例为INDEFINITE，则返回0.0。 此函数不会更改被调用的持续时间实例的值。
        参数
        other - 不能为空
        结果
        这个持续时间除以另一个持续时间的结果。 这与使用双重算术的millis / other.millis相同

      • negate

        public Duration negate​()
        从此实例返回一个具有负数毫秒的新的Duration实例。 例如， Duration.millis(50).negate()返回一个持续时间为-50毫秒。 如果被叫的持续时间实例为INDEFINITE，则返回INDEFINITE。 此函数不会更改被调用的持续时间实例的值。
        结果
        否定这一持续时间的结果。 这与使用双重算术的-millis相同

      • isIndefinite

        public boolean isIndefinite​()
        获取此Duration实例是否是不确定的。 如果持续时间等于Duration.INDEFINITE，则持续时间是不定期的。
        结果
        如果此持续时间相当于Duration.INDEFINITE或Double.POSITIVE_INFINITY，则为true。

      • isUnknown

        public boolean isUnknown​()
        获取此Duration实例是否为未知。 如果持续时间为Duration.UNKNOWN，则持续时间为未知。
        结果
        如果此持续时间相当于Duration.UNKNOWN或Double.isNaN（millis），则为true

      • lessThan

        public boolean lessThan​(Duration other)
        如果指定的持续时间小于（<），则返回true。 INDEFINITE被视为正无穷大。
        参数
        other - 不能为空
        结果
        如果millis <other.millis使用双重算术，则为true

      • lessThanOrEqualTo

        public boolean lessThanOrEqualTo​(Duration other)
        如果指定的持续时间小于或等于（<=），则返回true。 INDEFINITE被视为正无穷大。
        参数
        other - 不能为空
        结果
        如果millis <= other.millis使用双重算术，则为true

      • greaterThan

        public boolean greaterThan​(Duration other)
        如果指定的持续时间大于（>）此实例，则返回true。 INDEFINITE被视为正无穷大。
        参数
        other - 不能为空
        结果
        如果millis> other.millis使用双重算术

      • greaterThanOrEqualTo

        public boolean greaterThanOrEqualTo​(Duration other)
        如果指定的持续时间大于或等于（> =）此实例，则返回true。 INDEFINITE被视为正无穷大。
        参数
        other - 不能为空
        结果
        如果millis> = other.millis则使用双重算术

      • toString

        public String toString​()
        返回此 Duration对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        这是 Duration对象的字符串表示形式。

      • compareTo

        public int compareTo​(Duration d)
        比较由此对象和指定对象表示的持续时间。 返回一个负整数，零或正整数，因为该持续时间小于，等于或大于指定的持续时间。
        Specified by:
        compareTo在接口 Comparable<Duration>
        参数
        d - 要比较的持续时间。
        结果
        负整数，零或正整数，因为该持续时间小于，等于或大于指定的持续时间。

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象等于obj参数; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 Duration对象的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 Duration对象的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


FXPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util

Class FXPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javafx.util.FXPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class FXPermission
extends BasicPermission
    此类用于JavaFX权限。 一个FXPermission包含目标名称，但没有操作列表; 你有指定的权限，或者你没有。

    目标名称是JavaFX权限的名称（见下文）。 命名约定遵循层次化属性命名约定。 此外，星号可用于表示所有JavaFX权限。

    下表列出了所有可能的FXPermission目标名称，每个都提供了许可允许的描述以及授权许可的风险的讨论。

    FXPermission Table Permission Target Name What the Permission Allows Risks of Allowing this Permission accessClipboard Posting and retrieval of information to and from the system clipboard This would allow a malicious application to share or read potentially sensitive or confidential information. accessWindowList Accessing the list of all JavaFX Windows Providing access to the complete list of all JavaFX windows could give a malicious application the ability to modify a security dialog. createRobot Creating JavaFX Robot objects The JavaFX Robot object allows code to generate native-level mouse and keyboard events as well as read the screen. It could allow malicious code to control the system, run other programs, read the display, and deny mouse and keyboard access to the user. createTransparentWindow Creating transparent windows Transparent windows are not limited to a rectangular region that obscures what is underneath the window. This can make it difficult to distinguish parts of the window from other application windows or the platform desktop, and can be used to allow a malicious application to trick a user into entering sensitive data, especially in conjunction with either setWindowAlwaysOnTop or unrestrictedFullScreen. loadFont Loading a custom font, either via the Font.loadFont(java.lang.String, double) method or a jar file containing embedded fonts listed in the jar manifest Loading a custom font might allow a malicious application to provide a malformed font. Such a font could crash the application, allowing the malicious application to take control of the system, if there are any bugs in the underlying platform font implementation. modifyFXMLClassLoader Setting the ClassLoader used to load FXML objects, and removing the restriction against loading system classes Allowing an application to set an arbitrary ClassLoader might enable a malicious application to load classes with elevated permissions. Also removing the restriction against loading system classes with a null ClassLoader, might allow the application access to classes they would otherwise be denied from accessing. setWindowAlwaysOnTop Setting the always-on-top property of a window: Stage.setAlwaysOnTop(boolean) The malicious window might make itself look and behave like the platform desktop, so that information entered by the unsuspecting user is captured and subsequently misused, especially in conjunction with the createTransparentWindow permission. unrestrictedFullScreen Allow unrestricted full-screen access, including keyboard events and warning banner This permission allows an application to enter full-screen mode at any time, override the warning banner, and disable the function of the ESC key to exit from full-screen mode. All keyboard input will be delivered to the application while in full-screen mode, rather than being limited to KEY_PRESSED and KEY_RELEASED events for a subset of keys. See Stage.setFullScreen(boolean). This could allow a malicious window to look and behave like the platform desktop, so that information entered by the unsuspecting user is captured and subsequently misused, especially in conjunction with the createTransparentWindow permission.
    从以下版本开始：
    9
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FXPermission​(String name)
      创建一个新的 FXPermission与指定的名称。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • FXPermission

        public FXPermission​(String name)
        创建一个具有指定名称的新的FXPermission 。 该名称是FXPermission的符号名称，例如“accessClipboard”，“createTransparentWindow”等。星号可用于指示所有JavaFX权限。
        参数
        name - name的名称
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.util (Java SE 9 & JDK 9 )

javafx.util

Interfaces

  • Builder
  • BuilderFactory
  • Callback

Classes

  • Duration
  • FXPermission
  • Pair
  • StringConverter


javafx.util (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.util

包含各种实用程序和助手类。

  • 接口摘要
    接口 描述
    Builder<T>
    代表构建器的界面。
    BuilderFactory
    界面代表建筑工厂。
    Callback<P,R>
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。
  • 类摘要
    Class 描述
    Duration
    定义持续时间的类。
    FXPermission
    此类用于JavaFX权限。
    Pair<K,V>
    一个方便的类来表示名称 - 值对。
    StringConverter<T>
    Converter定义了字符串和对象之间的转换行为。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.util Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.util.Duration (implements java.lang.Comparable<T>, java.io.Serializable)
    • javafx.util.Pair<K,V> (implements java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javafx.util.FXPermission
    • javafx.util.StringConverter<T>

Interface Hierarchy

  • javafx.util.Builder<T>
  • javafx.util.BuilderFactory
  • javafx.util.Callback<P,R>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Pair (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util

Class Pair<K,V>

  • java.lang.Object
    • javafx.util.Pair<K,V>
  • All Implemented Interfaces:
    Serializable

    public class Pair<K,V>
extends Object
implements Serializable

    一个方便的类来表示名称 - 值对。

    从以下版本开始：
    JavaFX 2.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      Pair​(K key, V value)
      创建一个新的对

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      测试这个 Pair与另一个 Object平等。
      K getKey​()
      获得这对的钥匙。
      V getValue​()
      获取此对的值。
      int hashCode​()
      为此产生一个哈希码 Pair 。
      String toString​()
      String这个 Pair表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Pair

        public Pair​(K key,
            V value)
        创建一个新的对
        参数
        key - 这对的关键
        value - 此对使用的值

    • 方法详细信息

      • getKey

        public K getKey​()
        获得这对的钥匙。
        结果
        这对的钥匙

      • getValue

        public V getValue​()
        获取此对的值。
        结果
        这对的价值

      • toString

        public String toString​()

        String这个Pair表示。

        始终使用默认名称/值分隔符'='。

        重写：
        toString在 Object
        结果
        String这个 Pair代表

      • hashCode

        public int hashCode​()

        为此Pair生成哈希码。

        使用Pair的名称和值来计算哈希码。

        重写：
        hashCode在 Object
        结果
        这个 Pair哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object o)

        测试这Pair与另一个Object 。

        如果Object待测试不是Pair或是null ，则此方法返回false 。

        当且仅当名称和值都相等时，两个Pair被认为是相等的。

        重写：
        equals在 Object
        参数
        o - Object要与 Pair进行平等测试
        结果
        true如果给定的 Object等于这个 Pair其他 false
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util

Class StringConverter<T>

  • java.lang.Object
    • javafx.util.StringConverter<T>
  • 已知直接子类：
    BigDecimalStringConverter ， BigIntegerStringConverter ， BooleanStringConverter ， ByteStringConverter ， CharacterStringConverter ， DateTimeStringConverter ， DefaultStringConverter ， DoubleStringConverter ， FloatStringConverter ， FormatStringConverter ， IntegerStringConverter ， LocalDateStringConverter ， LocalDateTimeStringConverter ， LocalTimeStringConverter ， LongStringConverter ， NumberAxis.DefaultFormatter ， NumberStringConverter ， ShortStringConverter

    public abstract class StringConverter<T>
extends Object
    Converter定义了字符串和对象之间的转换行为。 字符串的对象和格式的类型由Converter的子类定义。
    从以下版本开始：
    JavaFX 2.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringConverter​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract T fromString​(String string)
      将提供的字符串转换为由特定转换器定义的对象。
      abstract String toString​(T object)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StringConverter

        public StringConverter​()

    • 方法详细信息

      • toString

        public abstract String toString​(T object)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        参数
        object - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。

      • fromString

        public abstract T fromString​(String string)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        参数
        string - 要转换的 String
        结果
        传入的字符串的对象表示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.util (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.util

  • Packages that use javafx.util
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.util
    包含各种实用程序和助手类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
  • Classes in javafx.util used by javafx.animation
    Class 描述
    Duration
    定义持续时间的类。
  • Classes in javafx.util used by javafx.beans.binding
    Class 描述
    StringConverter
    Converter定义了字符串和对象之间的转换行为。
  • Classes in javafx.util used by javafx.beans.property
    Class 描述
    StringConverter
    Converter定义了字符串和对象之间的转换行为。
  • Classes in javafx.util used by javafx.collections
    Class 描述
    Callback
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。
  • Classes in javafx.util used by javafx.concurrent
    Class 描述
    Callback
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。
    Duration
    定义持续时间的类。
  • Classes in javafx.util used by javafx.css
    Class 描述
    Duration
    定义持续时间的类。
  • Classes in javafx.util used by javafx.css.converter
    Class 描述
    Duration
    定义持续时间的类。
  • Classes in javafx.util used by javafx.fxml
    Class 描述
    Builder
    代表构建器的界面。
    BuilderFactory
    界面代表建筑工厂。
    Callback
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。
  • Classes in javafx.util used by javafx.scene
    Class 描述
    Callback
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。
  • Classes in javafx.util used by javafx.scene.chart
    Class 描述
    StringConverter
    Converter定义了字符串和对象之间的转换行为。
  • Classes in javafx.util used by javafx.scene.control
    Class 描述
    Callback
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。
    Duration
    定义持续时间的类。
    StringConverter
    Converter定义了字符串和对象之间的转换行为。
  • Classes in javafx.util used by javafx.scene.control.cell
    Class 描述
    Callback
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。
    StringConverter
    Converter定义了字符串和对象之间的转换行为。
  • Classes in javafx.util used by javafx.scene.control.skin
    Class 描述
    Callback
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。
    StringConverter
    Converter定义了字符串和对象之间的转换行为。
  • Classes in javafx.util used by javafx.scene.media
    Class 描述
    Duration
    定义持续时间的类。
    Pair
    一个方便的类来表示名称 - 值对。
  • Classes in javafx.util used by javafx.scene.web
    Class 描述
    Callback
    回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。
  • Classes in javafx.util used by javafx.util
    Class 描述
    Builder
    代表构建器的界面。
    Duration
    定义持续时间的类。
  • Classes in javafx.util used by javafx.util.converter
    Class 描述
    StringConverter
    Converter defines conversion behavior between strings and objects.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.Duration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.Duration

  • Packages that use Duration
    软件包 描述
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.util
    包含各种实用程序和助手类。

    • Uses of Duration in javafx.animation

      Methods in javafx.animation that return Duration
      Modifier and Type 方法 描述
      Duration Animation.getCurrentTime​()
      获取属性currentTime的值。
      Duration Animation.getCycleDuration​()
      获取属性cycleDuration的值。
      Duration Animation.getDelay​()
      获取属性延迟的值。
      Duration FadeTransition.getDuration​()
      获取属性持续时间的值。
      Duration FillTransition.getDuration​()
      获取属性持续时间的值。
      Duration PathTransition.getDuration​()
      获取属性持续时间的值。
      Duration PauseTransition.getDuration​()
      获取属性持续时间的值。
      Duration RotateTransition.getDuration​()
      获取属性持续时间的值。
      Duration ScaleTransition.getDuration​()
      获取属性持续时间的值。
      Duration StrokeTransition.getDuration​()
      获取属性持续时间的值。
      Duration TranslateTransition.getDuration​()
      获取属性持续时间的值。
      Duration KeyFrame.getTime​()
      返回此 KeyFrame的时间偏移量。
      Duration Animation.getTotalDuration​()
      获取属性totalDuration的值。
      Methods in javafx.animation that return types with arguments of type Duration
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Duration> Animation.currentTimeProperty​()
      定义 Animation的播放位置。
      ReadOnlyObjectProperty<Duration> Animation.cycleDurationProperty​()
      只读变量指示 Animation的一个周期的持续时间：从时间0到动画结束所需的时间（默认为 rate为1.0）。
      ObjectProperty<Duration> Animation.delayProperty​()
      延迟动画的开始。
      ObjectProperty<Duration> FadeTransition.durationProperty​()
      持续时间 FadeTransition 。
      ObjectProperty<Duration> FillTransition.durationProperty​()
      这个 FillTransition的持续时间。
      ObjectProperty<Duration> PathTransition.durationProperty​()
      这个 Transition的持续时间。
      ObjectProperty<Duration> PauseTransition.durationProperty​()
      这个 Transition的持续时间。
      ObjectProperty<Duration> RotateTransition.durationProperty​()
      这个 RotateTransition的持续时间。
      ObjectProperty<Duration> ScaleTransition.durationProperty​()
      这个 ScaleTransition的持续时间。
      ObjectProperty<Duration> StrokeTransition.durationProperty​()
      这个 StrokeTransition的持续时间。
      ObjectProperty<Duration> TranslateTransition.durationProperty​()
      这个 TranslateTransition的持续时间。
      ObservableMap<String,Duration> Animation.getCuePoints​()
      提示点可用于标记 Animation重要位置。
      ReadOnlyObjectProperty<Duration> Animation.totalDurationProperty​()
      只读变量表示此 Animation的总持续时间，包括重复。
      Methods in javafx.animation with parameters of type Duration
      Modifier and Type 方法 描述
      void Animation.jumpTo​(Duration time)
      Animation这个 Animation给定的位置。
      void Animation.playFrom​(Duration time)
      从一个特定的位置播放这个 Animation一个方便的方法。
      protected void Animation.setCycleDuration​(Duration value)
      设置属性cycleDuration的值。
      void Animation.setDelay​(Duration value)
      设置属性延迟的值。
      void FadeTransition.setDuration​(Duration value)
      设置属性持续时间的值。
      void FillTransition.setDuration​(Duration value)
      设置属性持续时间的值。
      void PathTransition.setDuration​(Duration value)
      设置属性持续时间的值。
      void PauseTransition.setDuration​(Duration value)
      设置属性持续时间的值。
      void RotateTransition.setDuration​(Duration value)
      设置属性持续时间的值。
      void ScaleTransition.setDuration​(Duration value)
      设置属性持续时间的值。
      void StrokeTransition.setDuration​(Duration value)
      设置属性持续时间的值。
      void TranslateTransition.setDuration​(Duration value)
      设置属性持续时间的值。
      static Interpolator Interpolator.TANGENT​(Duration t, double v)
      创建切线内插器，切线和切线相同。
      static Interpolator Interpolator.TANGENT​(Duration t1, double v1, Duration t2, double v2)
      创建切线插值器。
      Constructors in javafx.animation with parameters of type Duration
      Constructor 描述
      FadeTransition​(Duration duration)
      构造函数为 FadeTransition
      FadeTransition​(Duration duration, Node node)
      构造函数为 FadeTransition
      FillTransition​(Duration duration)
      构造函数为 FillTransition
      FillTransition​(Duration duration, Color fromValue, Color toValue)
      构造函数为 FillTransition
      FillTransition​(Duration duration, Shape shape)
      构造函数为 FillTransition
      FillTransition​(Duration duration, Shape shape, Color fromValue, Color toValue)
      构造函数为 FillTransition
      KeyFrame​(Duration time, String name, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, KeyValue... values)
      构造函数 KeyFrame
      KeyFrame​(Duration time, EventHandler<ActionEvent> onFinished, KeyValue... values)
      构造函数 KeyFrame
      PathTransition​(Duration duration, Shape path)
      构造函数为 PathTransition 。
      PathTransition​(Duration duration, Shape path, Node node)
      构造函数为 PathTransition 。
      PauseTransition​(Duration duration)
      构造函数为 PauseTransition 。
      RotateTransition​(Duration duration)
      构造函数为 RotateTransition
      RotateTransition​(Duration duration, Node node)
      构造函数为 RotateTransition
      ScaleTransition​(Duration duration)
      构造函数为 ScaleTransition
      ScaleTransition​(Duration duration, Node node)
      构造函数为 ScaleTransition
      StrokeTransition​(Duration duration)
      构造函数为 StrokeTransition
      StrokeTransition​(Duration duration, Color fromValue, Color toValue)
      构造函数为 StrokeTransition
      StrokeTransition​(Duration duration, Shape shape)
      构造函数为 StrokeTransition
      StrokeTransition​(Duration duration, Shape shape, Color fromValue, Color toValue)
      构造函数为 StrokeTransition
      TranslateTransition​(Duration duration)
      构造函数为 TranslateTransition
      TranslateTransition​(Duration duration, Node node)
      构造函数为 TranslateTransition

    • Uses of Duration in javafx.concurrent

      Fields in javafx.concurrent with type parameters of type Duration
      Modifier and Type Field 描述
      static Callback<ScheduledService<?>,Duration> ScheduledService.EXPONENTIAL_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况下以指数方式 backoffStrategy重新执行之间的时间段。
      static Callback<ScheduledService<?>,Duration> ScheduledService.LINEAR_BACKOFF_STRATEGY
      对于 backoffStrategy属性的回调实现，将在失败的情况 backoffStrategy性地回退重新执行之间的时间段。
      static Callback<ScheduledService<?>,Duration> ScheduledService.LOGARITHMIC_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况下对数地 backoffStrategy重新执行之间的时间段。
      Methods in javafx.concurrent that return Duration
      Modifier and Type 方法 描述
      Duration ScheduledService.getCumulativePeriod​()
      获取属性cumulativePeriod的值。
      Duration ScheduledService.getDelay​()
      获取属性延迟的值。
      Duration ScheduledService.getMaximumCumulativePeriod​()
      获取属性maximumCumulativePeriod的值。
      Duration ScheduledService.getPeriod​()
      获取属性期间的值。
      Methods in javafx.concurrent that return types with arguments of type Duration
      Modifier and Type 方法 描述
      ObjectProperty<Callback<ScheduledService<?>,Duration>> ScheduledService.backoffStrategyProperty​()
      计算在每次故障时添加到期间的时间量。
      ReadOnlyObjectProperty<Duration> ScheduledService.cumulativePeriodProperty​()
      迭代之间使用的当前累积周期。
      ObjectProperty<Duration> ScheduledService.delayProperty​()
      首次启动ScheduledService之间的初始延迟，以及何时开始运行。
      Callback<ScheduledService<?>,Duration> ScheduledService.getBackoffStrategy​()
      获取属性backoffStrategy的值。
      ObjectProperty<Duration> ScheduledService.maximumCumulativePeriodProperty​()
      累积百分比的最大允许值。
      ObjectProperty<Duration> ScheduledService.periodProperty​()
      允许在最后一次运行开始和下次运行开始之间的最短时间。
      Methods in javafx.concurrent with parameters of type Duration
      Modifier and Type 方法 描述
      void ScheduledService.setDelay​(Duration value)
      设置属性延迟的值。
      void ScheduledService.setMaximumCumulativePeriod​(Duration value)
      设置属性maximumCumulativePeriod的值。
      void ScheduledService.setPeriod​(Duration value)
      设置属性周期的值。
      Method parameters in javafx.concurrent with type arguments of type Duration
      Modifier and Type 方法 描述
      void ScheduledService.setBackoffStrategy​(Callback<ScheduledService<?>,Duration> value)
      设置属性backoffStrategy的值。

    • Uses of Duration in javafx.css

      Methods in javafx.css that return types with arguments of type Duration
      Modifier and Type 方法 描述
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function)
      创建一个具有Duration.BLACK的初始值的CssMetaData <S，Duration>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Duration>并继承标志。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function)
      创建一个StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建一个具有初始值的StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Duration>并继承标志。
      static StyleConverter<?,Duration> StyleConverter.getDurationConverter​()
      返回一个StyleConverter ，将持续时间的字符串表示形式转换为Duration 。
      Methods in javafx.css with parameters of type Duration
      Modifier and Type 方法 描述
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Duration>并继承标志。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建一个具有初始值的StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Duration>并继承标志。
      Method parameters in javafx.css with type arguments of type Duration
      Modifier and Type 方法 描述
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function)
      创建一个具有Duration.BLACK的初始值的CssMetaData <S，Duration>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。
      CssMetaData<S,Duration> StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Duration>并继承标志。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function)
      创建一个StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue)
      创建一个具有初始值的StyleableProperty <Duration>。
      StyleableProperty<Duration> StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Duration>并继承标志。

    • Uses of Duration in javafx.css.converter

      Methods in javafx.css.converter that return Duration
      Modifier and Type | 方法 | 描述
      Duration | DurationConverter.convert​(ParsedValue<ParsedValue<?,Size>,Duration> value, Font font)
      Methods in javafx.css.converter that return types with arguments of type Duration
      Modifier and Type | 方法 | 描述
      static StyleConverter<ParsedValue<?,Size>,Duration> | DurationConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Duration
      Modifier and Type | 方法 | 描述
      Duration | DurationConverter.convert​(ParsedValue<ParsedValue<?,Size>,Duration> value, Font font)

    • Uses of Duration in javafx.scene.control

      Methods in javafx.scene.control that return Duration
      Modifier and Type 方法 描述
      Duration Tooltip.getHideDelay​()
      获取属性hideDelay的值。
      Duration Tooltip.getShowDelay​()
      获取属性showDelay的值。
      Duration Tooltip.getShowDuration​()
      获取属性showDuration的值。
      Methods in javafx.scene.control that return types with arguments of type Duration
      Modifier and Type 方法 描述
      ObjectProperty<Duration> Tooltip.hideDelayProperty​()
      在鼠标离开节点后继续显示工具提示的持续时间。
      ObjectProperty<Duration> Tooltip.showDelayProperty​()
      进入悬停节点的鼠标与相关联的工具提示之间的延迟将显示给用户。
      ObjectProperty<Duration> Tooltip.showDurationProperty​()
      工具提示应保持显示的持续时间，直到用户不再可见。
      Methods in javafx.scene.control with parameters of type Duration
      Modifier and Type 方法 描述
      void Tooltip.setHideDelay​(Duration hideDelay)
      设置属性hideDelay的值。
      void Tooltip.setShowDelay​(Duration showDelay)
      设置属性showDelay的值。
      void Tooltip.setShowDuration​(Duration showDuration)
      设置属性showDuration的值。

    • Uses of Duration in javafx.scene.media

      Methods in javafx.scene.media that return Duration
      Modifier and Type 方法 描述
      Duration MediaPlayer.getBufferProgressTime​()
      检索 bufferProgressTime的价值。
      Duration MediaPlayer.getCurrentTime​()
      检索当前媒体时间。
      Duration MediaPlayer.getCycleDuration​()
      以秒为单位检索循环持续时间。
      Duration Media.getDuration​()
      检索介质的持续时间（以秒为单位）。
      Duration MediaPlayer.getStartTime​()
      检索开始时间。
      Duration MediaPlayer.getStopTime​()
      检索停止时间。
      Duration MediaPlayer.getTotalDuration​()
      检索总播放持续时间，包括所有周期（重复）。
      Methods in javafx.scene.media that return types with arguments of type Duration
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<Duration> MediaPlayer.bufferProgressTimeProperty​()
      当前的缓冲位置指示可以播放多少媒体，而不会停止 MediaPlayer 。
      ReadOnlyObjectProperty<Duration> MediaPlayer.currentTimeProperty​()
      当前媒体播放时间。
      ReadOnlyObjectProperty<Duration> MediaPlayer.cycleDurationProperty​()
      这个玩家的 startTime和 stopTime之间的时间量。
      ReadOnlyObjectProperty<Duration> Media.durationProperty​()
      源介质的持续时间（以秒为单位）。
      Pair<String,Duration> MediaMarkerEvent.getMarker​()
      检索事件代表的标记。
      ObservableMap<String,Duration> Media.getMarkers​()
      检索此 Media实例上定义的标记。
      ObjectProperty<Duration> MediaPlayer.startTimeProperty​()
      媒体应该开始播放的时间偏移，或重复播放时重新启动。
      ObjectProperty<Duration> MediaPlayer.stopTimeProperty​()
      重播时媒体应停止播放或重新启动的时间偏移。
      ReadOnlyObjectProperty<Duration> MediaPlayer.totalDurationProperty​()
      播放时间的总量，如果允许玩，直到完成。
      Methods in javafx.scene.media with parameters of type Duration
      Modifier and Type 方法 描述
      void MediaPlayer.seek​(Duration seekTime)
      寻找播放器一个新的播放时间。
      void MediaPlayer.setStartTime​(Duration value)
      设置开始时间。
      void MediaPlayer.setStopTime​(Duration value)
      设置停止时间。

    • Uses of Duration in javafx.util

      Fields in javafx.util declared as Duration
      Modifier and Type Field 描述
      static Duration Duration.INDEFINITE
      无限期。
      static Duration Duration.ONE
      持续时间为1毫秒。
      static Duration Duration.UNKNOWN
      一段时间的未知数量。
      static Duration Duration.ZERO
      持续时间为0（无时间）。
      Methods in javafx.util that return Duration
      Modifier and Type 方法 描述
      Duration Duration.add​(Duration other)
      添加此实例和另一个Duration实例以返回一个新的Duration实例。
      Duration Duration.divide​(double n)
      将此实例除以一个数字以返回一个新的Duration实例。
      Duration Duration.divide​(Duration other)
      已过时。
      这种方法通过不考虑单位产生令人惊讶的结果。 改用divide(double) 。
      static Duration Duration.hours​(double h)
      返回一个表示指定小时数的Duration实例的Factory方法。
      static Duration Duration.millis​(double ms)
      返回一个指定数毫秒的Duration实例的Factory方法。
      static Duration Duration.minutes​(double m)
      返回一个表示指定分钟数的Duration实例的Factory方法。
      Duration Duration.multiply​(double n)
      将此实例与代表毫秒的数字相乘并返回新的持续时间。
      Duration Duration.multiply​(Duration other)
      已过时。
      这种方法通过不考虑单位产生令人惊讶的结果。 改用multiply(double) 。
      Duration Duration.negate​()
      从此实例返回一个具有负数毫秒的新的Duration实例。
      static Duration Duration.seconds​(double s)
      返回一个表示指定秒数的Duration实例的Factory方法。
      Duration Duration.subtract​(Duration other)
      从此实例中减去其他Duration实例以返回一个新的Duration实例。
      static Duration Duration.valueOf​(String time)
      在一段指定时间内返回一个Duration实例的Factory方法。
      Methods in javafx.util with parameters of type Duration
      Modifier and Type 方法 描述
      Duration Duration.add​(Duration other)
      添加此实例和另一个Duration实例以返回一个新的Duration实例。
      int Duration.compareTo​(Duration d)
      比较由此对象和指定对象表示的持续时间。
      Duration Duration.divide​(Duration other)
      已过时。
      这种方法通过不考虑单位产生令人惊讶的结果。 改用divide(double) 。
      boolean Duration.greaterThan​(Duration other)
      如果指定的持续时间大于（>）此实例，则返回true。
      boolean Duration.greaterThanOrEqualTo​(Duration other)
      如果指定的持续时间大于或等于（> =）此实例，则返回true。
      boolean Duration.lessThan​(Duration other)
      如果指定的持续时间小于（<），则返回true。
      boolean Duration.lessThanOrEqualTo​(Duration other)
      如果指定的持续时间小于或等于（<=），则返回true。
      Duration Duration.multiply​(Duration other)
      已过时。
      这种方法通过不考虑单位产生令人惊讶的结果。 改用multiply(double) 。
      Duration Duration.subtract​(Duration other)
      Subtract other Duration instance from this instance to return a new Duration instance.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.FXPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.FXPermission

No usage of javafx.util.FXPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.Pair (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.Pair

  • Packages that use Pair
    软件包 描述
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。

    • Uses of Pair in javafx.scene.media

      Methods in javafx.scene.media that return Pair
      Modifier and Type 方法 描述
      Pair<String,Duration> MediaMarkerEvent.getMarker​()
      检索事件代表的标记。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.StringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.StringConverter

  • Packages that use StringConverter
    软件包 描述
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of StringConverter in javafx.beans.binding

      Methods in javafx.beans.binding with parameters of type StringConverter
      Modifier and Type 方法 描述
      static <T> void Bindings.bindBidirectional​(Property<String> stringProperty, Property<T> otherProperty, StringConverter<T> converter)
      在String - Property和另一个Property使用指定的StringConverter生成双向绑定（或“反向绑定”）进行转换。

    • Uses of StringConverter in javafx.beans.property

      Methods in javafx.beans.property with parameters of type StringConverter
      Modifier and Type 方法 描述
      <T> void StringProperty.bindBidirectional​(Property<T> other, StringConverter<T> converter)
      在这个 StringProperty和另一个任意属性之间创建双向绑定。

    • Uses of StringConverter in javafx.scene.chart

      Subclasses of StringConverter in javafx.scene.chart
      Modifier and Type Class 描述
      static class  NumberAxis.DefaultFormatter
      NumberAxis的默认数字格式化程序，与自动量程保持同步，并适当地格式化值。
      Methods in javafx.scene.chart that return StringConverter
      Modifier and Type 方法 描述
      StringConverter<T> ValueAxis.getTickLabelFormatter​()
      获取属性tickLabelFormatter的值。
      Methods in javafx.scene.chart that return types with arguments of type StringConverter
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<T>> ValueAxis.tickLabelFormatterProperty​()
      StringConverter用于格式化刻度线标签。
      Methods in javafx.scene.chart with parameters of type StringConverter
      Modifier and Type 方法 描述
      void ValueAxis.setTickLabelFormatter​(StringConverter<T> value)
      设置属性tickLabelFormatter的值。

    • Uses of StringConverter in javafx.scene.control

      Fields in javafx.scene.control declared as StringConverter
      Modifier and Type Field 描述
      static StringConverter<String> TextFormatter.IDENTITY_STRING_CONVERTER
      该字符串转换器将文本转换为相同的String值。
      Methods in javafx.scene.control that return StringConverter
      Modifier and Type 方法 描述
      StringConverter<T> ChoiceBox.getConverter​()
      获取属性转换器的值。
      StringConverter<T> ComboBox.getConverter​()
      获取属性转换器的值。
      StringConverter<LocalDate> DatePicker.getConverter​()
      获取属性转换器的值。
      StringConverter<T> SpinnerValueFactory.getConverter​()
      获取属性转换器的值。
      StringConverter<Double> Slider.getLabelFormatter​()
      获取属性labelFormatter的值。
      StringConverter<V> TextFormatter.getValueConverter​()
      值之间的转换器和文本。
      Methods in javafx.scene.control that return types with arguments of type StringConverter
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<T>> ChoiceBox.converterProperty​()
      允许一种方式来指定如何表示项目列表中的对象。
      ObjectProperty<StringConverter<T>> ComboBox.converterProperty​()
      将用户输入的输入（当ComboBox为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。
      ObjectProperty<StringConverter<LocalDate>> DatePicker.converterProperty​()
      将输入文本转换为类型为LocalDate的对象，反之亦然。
      ObjectProperty<StringConverter<T>> SpinnerValueFactory.converterProperty​()
      将用户输入的输入（当微调器为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。
      ObjectProperty<StringConverter<Double>> Slider.labelFormatterProperty​()
      用于格式化主要刻度的标签的功能。
      Methods in javafx.scene.control with parameters of type StringConverter
      Modifier and Type 方法 描述
      void ChoiceBox.setConverter​(StringConverter<T> value)
      设置属性转换器的值。
      void ComboBox.setConverter​(StringConverter<T> value)
      设置属性转换器的值。
      void DatePicker.setConverter​(StringConverter<LocalDate> value)
      设置属性转换器的值。
      void SpinnerValueFactory.setConverter​(StringConverter<T> newValue)
      设置属性转换器的值。
      void Slider.setLabelFormatter​(StringConverter<Double> value)
      设置属性labelFormatter的值。
      Constructors in javafx.scene.control with parameters of type StringConverter
      Constructor 描述
      TextFormatter​(StringConverter<V> valueConverter)
      使用提供的值转换器创建一个新的格式化器。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue)
      使用提供的值转换器和默认值创建一个新的格式化器。
      TextFormatter​(StringConverter<V> valueConverter, V defaultValue, UnaryOperator<TextFormatter.Change> filter)
      使用提供的过滤器，值转换器和默认值创建一个新的格式化器。

    • Uses of StringConverter in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return StringConverter
      Modifier and Type 方法 描述
      StringConverter<T> CheckBoxListCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> CheckBoxTableCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<TreeItem<T>> CheckBoxTreeCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> CheckBoxTreeTableCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> ChoiceBoxListCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> ChoiceBoxTableCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> ChoiceBoxTreeCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> ChoiceBoxTreeTableCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> ComboBoxListCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> ComboBoxTableCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> ComboBoxTreeCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> ComboBoxTreeTableCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> TextFieldListCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> TextFieldTableCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> TextFieldTreeCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      StringConverter<T> TextFieldTreeTableCell.getConverter​()
      返回此单元格中使用的StringConverter 。
      Methods in javafx.scene.control.cell that return types with arguments of type StringConverter
      Modifier and Type 方法 描述
      ObjectProperty<StringConverter<T>> CheckBoxListCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> CheckBoxTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<TreeItem<T>>> CheckBoxTreeCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> CheckBoxTreeTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ChoiceBoxListCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ChoiceBoxTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ChoiceBoxTreeCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ChoiceBoxTreeTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ComboBoxListCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ComboBoxTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ComboBoxTreeCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> ComboBoxTreeTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> TextFieldListCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> TextFieldTableCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> TextFieldTreeCell.converterProperty​()
      StringConverter属性。
      ObjectProperty<StringConverter<T>> TextFieldTreeTableCell.converterProperty​()
      StringConverter属性。
      Methods in javafx.scene.control.cell with parameters of type StringConverter
      Modifier and Type 方法 描述
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> TextFieldListCell.forListView​(StringConverter<T> converter)
      提供TextField ，允许在单元格双击时或当调用ListView.edit(int)时编辑单元格内容。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> TextFieldTableCell.forTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时调用单元格内容，或者调用TableView.edit(int, javafx.scene.control.TableColumn)时。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个用于TreeTableColumn电池厂的电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> TextFieldTreeTableCell.forTreeTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在单元格双击时或当调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时编辑单元格内容。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> TextFieldTreeCell.forTreeView​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时或当调用TreeView.edit(javafx.scene.control.TreeItem)时编辑单元格内容。
      void CheckBoxListCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void CheckBoxTableCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void CheckBoxTreeCell.setConverter​(StringConverter<TreeItem<T>> value)
      设置要在此单元格中使用的StringConverter 。
      void CheckBoxTreeTableCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void ChoiceBoxListCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void ChoiceBoxTableCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void ChoiceBoxTreeCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void ChoiceBoxTreeTableCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void ComboBoxListCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void ComboBoxTableCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void ComboBoxTreeCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void ComboBoxTreeTableCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void TextFieldListCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void TextFieldTableCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void TextFieldTreeCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      void TextFieldTreeTableCell.setConverter​(StringConverter<T> value)
      设置要在此单元格中使用的StringConverter 。
      Constructors in javafx.scene.control.cell with parameters of type StringConverter
      Constructor 描述
      CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxListCell。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个带有自定义字符串转换器的CheckBoxTableCell。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      通过单元格工厂创建一个用于TreeView控件的CheckBoxTreeCell 。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxTreeTableCell。
      ChoiceBoxListCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxListCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxTableCell实例，使用给定的项目来填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTableCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时显示ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将该项目转换为用户可读的形式。
      ChoiceBoxTreeTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBoxTreeTableCell实例，给定的项目用于填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeTableCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxListCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxListCell实例，给定的项目用于填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxListCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxTableCell实例，给定的项目用于在显示ComboBox时显示ComboBox ，而StringConverter用于将该项目转换为用户可读的形式。
      ComboBoxTableCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的表单。
      ComboBoxTreeCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeTableCell​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ComboBoxTreeTableCell实例，其中给定的项目用于填充ComboBox ，并显示StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeTableCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      TextFieldListCell​(StringConverter<T> converter)
      创建一个TextFieldListCell，它在编辑模式时提供TextField ，允许编辑单元格内容。
      TextFieldTableCell​(StringConverter<T> converter)
      创建一个TextFieldTableCell，当进入编辑模式时，可以编辑TextField单元格内容。
      TextFieldTreeCell​(StringConverter<T> converter)
      创建一个TextFieldTreeCell，当它进入编辑模式时，它允许编辑单元格内容，提供一个TextField 。
      TextFieldTreeTableCell​(StringConverter<T> converter)
      创建一个TextFieldTreeTableCell，当进入编辑模式时，可以编辑TextField单元格内容。

    • Uses of StringConverter in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return StringConverter
      Modifier and Type 方法 描述
      protected StringConverter<Color> ColorPickerSkin.getConverter​()
      子类负责获取转换器。
      protected StringConverter<T> ComboBoxListViewSkin.getConverter​()
      子类负责获取转换器。
      protected abstract StringConverter<T> ComboBoxPopupControl.getConverter​()
      子类负责获取转换器。
      protected StringConverter<LocalDate> DatePickerSkin.getConverter​()
      子类负责获取转换器。

    • Uses of StringConverter in javafx.util.converter

      Subclasses of StringConverter in javafx.util.converter
      Modifier and Type Class 描述
      class  BigDecimalStringConverter
      StringConverter实现BigDecimal值。
      class  BigIntegerStringConverter
      StringConverter实现BigInteger值。
      class  BooleanStringConverter
      StringConverter实现Boolean （和布尔基元）值。
      class  ByteStringConverter
      StringConverter实现Byte （和字节基元）值。
      class  CharacterStringConverter
      StringConverter实现为Character （和char基元）值。
      class  CurrencyStringConverter
      StringConverter代表货币的Number值的实现。
      class  DateStringConverter
      StringConverter实现Date值。
      class  DateTimeStringConverter
      StringConverter代表日期和时间的Date值的实现。
      class  DefaultStringConverter
      StringConverter实现String值。
      class  DoubleStringConverter
      StringConverter实施Double （和双原始）值。
      class  FloatStringConverter
      StringConverter实现Float （和浮点数）值。
      class  FormatStringConverter<T>
      StringConverter实现可以使用Format实例。
      class  IntegerStringConverter
      StringConverter实现Integer （和int原语）值。
      class  LocalDateStringConverter
      StringConverter实现LocalDate值。
      class  LocalDateTimeStringConverter
      StringConverter实现LocalDateTime值。
      class  LocalTimeStringConverter
      StringConverter实现LocalTime值。
      class  LongStringConverter
      StringConverter Long （和长基元）值的实现。
      class  NumberStringConverter
      StringConverter实现Number值。
      class  PercentageStringConverter
      StringConverter实施Number个值代表百分比。
      class  ShortStringConverter
      StringConverter实现Short值。
      class  TimeStringConverter
      StringConverter代表时间的Date值的实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.util.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.util.Builder

  • Packages that use Builder
    软件包 描述
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.util
    包含各种实用程序和助手类。

    • Uses of Builder in javafx.fxml

      Methods in javafx.fxml that return Builder
      Modifier and Type 方法 描述
      Builder<?> JavaFXBuilderFactory.getBuilder​(Class<?> type)
      返回指定类型的构建器，如果不使用构建器，则返回null。

    • Uses of Builder in javafx.util

      Methods in javafx.util that return Builder
      Modifier and Type 方法 描述
      Builder<?> BuilderFactory.getBuilder​(Class<?> type)
      返回适用于构造给定类型实例的构建器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.util.BuilderFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.util.BuilderFactory

  • Packages that use BuilderFactory
    软件包 描述
    javafx.fxml
    包含用于从标记加载对象层次结构的类。

    • Uses of BuilderFactory in javafx.fxml

      Classes in javafx.fxml that implement BuilderFactory
      Modifier and Type Class 描述
      class  JavaFXBuilderFactory
      JavaFX构建工厂。
      Methods in javafx.fxml that return BuilderFactory
      Modifier and Type 方法 描述
      BuilderFactory FXMLLoader.getBuilderFactory​()
      返回此装载器使用的构建器工厂。
      Methods in javafx.fxml with parameters of type BuilderFactory
      Modifier and Type 方法 描述
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      从FXML文档加载对象层次结构。
      void FXMLLoader.setBuilderFactory​(BuilderFactory builderFactory)
      设置此装载器使用的构建器工厂。
      Constructors in javafx.fxml with parameters of type BuilderFactory
      Constructor 描述
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)
      创建一个新的FXMLLoader实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javafx.util.Callback (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javafx.util.Callback

  • Packages that use Callback
    软件包 描述
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。

    • Uses of Callback in javafx.collections

      Methods in javafx.collections with parameters of type Callback
      Modifier and Type 方法 描述
      static <E> ObservableList<E> FXCollections.observableArrayList​(Callback<E,Observable[]> extractor)
      创建一个由arraylist支持的新的可观察列表。
      static <E> ObservableList<E> FXCollections.observableList​(List<E> list, Callback<E,Observable[]> extractor)
      构造由指定列表支持的ObservableList。

    • Uses of Callback in javafx.concurrent

      Fields in javafx.concurrent declared as Callback
      Modifier and Type Field 描述
      static Callback<ScheduledService<?>,Duration> ScheduledService.EXPONENTIAL_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况下以指数方式 backoffStrategy重新执行之间的时间段。
      static Callback<ScheduledService<?>,Duration> ScheduledService.LINEAR_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况 backoffStrategy性地回退重新执行之间的时间段。
      static Callback<ScheduledService<?>,Duration> ScheduledService.LOGARITHMIC_BACKOFF_STRATEGY
      backoffStrategy属性的回调实现将在失败的情况下对数地退避重新执行之间的时间间隔。
      Methods in javafx.concurrent that return Callback
      Modifier and Type 方法 描述
      Callback<ScheduledService<?>,Duration> ScheduledService.getBackoffStrategy​()
      获取属性backoffStrategy的值。
      Methods in javafx.concurrent that return types with arguments of type Callback
      Modifier and Type 方法 描述
      ObjectProperty<Callback<ScheduledService<?>,Duration>> ScheduledService.backoffStrategyProperty​()
      计算在每次故障时添加到期间的时间量。
      Methods in javafx.concurrent with parameters of type Callback
      Modifier and Type 方法 描述
      void ScheduledService.setBackoffStrategy​(Callback<ScheduledService<?>,Duration> value)
      设置属性backoffStrategy的值。

    • Uses of Callback in javafx.fxml

      Methods in javafx.fxml that return Callback
      Modifier and Type 方法 描述
      Callback<Class<?>,Object> FXMLLoader.getControllerFactory​()
      返回此装载器使用的控制器工厂。
      Methods in javafx.fxml with parameters of type Callback
      Modifier and Type 方法 描述
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      从FXML文档加载对象层次结构。
      void FXMLLoader.setControllerFactory​(Callback<Class<?>,Object> controllerFactory)
      设置此装载机使用的控制器工厂。
      Constructors in javafx.fxml with parameters of type Callback
      Constructor 描述
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)
      创建一个新的FXMLLoader实例。

    • Uses of Callback in javafx.scene

      Methods in javafx.scene with parameters of type Callback
      Modifier and Type 方法 描述
      void Node.snapshot​(Callback<SnapshotResult,Void> callback, SnapshotParameters params, WritableImage image)
      在下一帧获取该节点的快照，并在映像准备就绪时调用指定的回调方法。
      void Scene.snapshot​(Callback<SnapshotResult,Void> callback, WritableImage image)
      在下一帧拍摄此场景的快照，并在图像准备就绪时调用指定的回调方法。

    • Uses of Callback in javafx.scene.control

      Fields in javafx.scene.control declared as Callback
      Modifier and Type Field 描述
      static Callback<TableView.ResizeFeatures,Boolean> TableView.CONSTRAINED_RESIZE_POLICY
      确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。
      static Callback<TreeTableView.ResizeFeatures,Boolean> TreeTableView.CONSTRAINED_RESIZE_POLICY
      确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。
      static Callback<TableColumn<?,?>,TableCell<?,?>> TableColumn.DEFAULT_CELL_FACTORY
      如果在TableColumn实例上未指定cellFactory，则默认情况下将使用该实例。
      static Callback<TreeTableColumn<?,?>,TreeTableCell<?,?>> TreeTableColumn.DEFAULT_CELL_FACTORY
      如果在TreeTableColumn实例上未指定cellFactory，则默认情况下将使用该实例。
      static Callback<TableView,Boolean> TableView.DEFAULT_SORT_POLICY
      如果没有指定其他策略，则此TableView将使用默认值 sort policy 。
      static Callback<TreeTableView,Boolean> TreeTableView.DEFAULT_SORT_POLICY
      如果没有指定其他策略，则该TreeTableView将使用默认值 sort policy 。
      static Callback<TableView.ResizeFeatures,Boolean> TableView.UNCONSTRAINED_RESIZE_POLICY
      非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。
      static Callback<TreeTableView.ResizeFeatures,Boolean> TreeTableView.UNCONSTRAINED_RESIZE_POLICY
      非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。
      Methods in javafx.scene.control that return Callback
      Modifier and Type 方法 描述
      Callback<ListView<T>,ListCell<T>> ComboBox.getCellFactory​()
      获取属性cellFactory的值。
      Callback<ListView<T>,ListCell<T>> ListView.getCellFactory​()
      返回当前的单元格工厂。
      Callback<TableColumn<S,T>,TableCell<S,T>> TableColumn.getCellFactory​()
      获取属性cellFactory的值。
      Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> TreeTableColumn.getCellFactory​()
      获取属性cellFactory的值。
      Callback<TreeView<T>,TreeCell<T>> TreeView.getCellFactory​()
      返回用于创建TreeCells的单元格工厂，用于表示TreeView中的项目，如果未设置自定义单元格工厂，则返回null。
      Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> TableColumn.getCellValueFactory​()
      获取属性cellValueFactory的值。
      Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> TreeTableColumn.getCellValueFactory​()
      获取属性cellValueFactory的值。
      Callback<TableView.ResizeFeatures,Boolean> TableView.getColumnResizePolicy​()
      获取属性columnResizePolicy的值。
      Callback<TreeTableView.ResizeFeatures,Boolean> TreeTableView.getColumnResizePolicy​()
      获取属性columnResizePolicy的值。
      Callback<DatePicker,DateCell> DatePicker.getDayCellFactory​()
      获取属性dayCellFactory的值。
      Callback<Integer,Node> Pagination.getPageFactory​()
      返回页面工厂回调函数。
      Callback<ButtonType,R> Dialog.getResultConverter​()
      获取属性resultConverter的值。
      Callback<TableView<S>,TableRow<S>> TableView.getRowFactory​()
      获取属性rowFactory的值。
      Callback<TreeTableView<S>,TreeTableRow<S>> TreeTableView.getRowFactory​()
      获取属性rowFactory的值。
      Callback<TableView<S>,Boolean> TableView.getSortPolicy​()
      获取属性sortPolicy的值。
      Callback<TreeTableView<S>,Boolean> TreeTableView.getSortPolicy​()
      获取属性sortPolicy的值。
      Methods in javafx.scene.control that return types with arguments of type Callback
      Modifier and Type 方法 描述
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> ComboBox.cellFactoryProperty​()
      提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。
      ObjectProperty<Callback<ListView<T>,ListCell<T>>> ListView.cellFactoryProperty​()
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      ObjectProperty<Callback<TableColumn<S,T>,TableCell<S,T>>> TableColumn.cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      ObjectProperty<Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>> TreeTableColumn.cellFactoryProperty​()
      该列中所有单元格的单元格工厂。
      ObjectProperty<Callback<TreeView<T>,TreeCell<T>>> TreeView.cellFactoryProperty​()
      表示将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
      ObjectProperty<Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> TableColumn.cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。
      ObjectProperty<Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>>> TreeTableColumn.cellValueFactoryProperty​()
      单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。
      ObjectProperty<Callback<TableView.ResizeFeatures,Boolean>> TableView.columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      ObjectProperty<Callback<TreeTableView.ResizeFeatures,Boolean>> TreeTableView.columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      ObjectProperty<Callback<DatePicker,DateCell>> DatePicker.dayCellFactoryProperty​()
      可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。
      ObjectProperty<Callback<Integer,Node>> Pagination.pageFactoryProperty​()
      当应用程序或用户选择页面时调用的pageFactory回调函数。
      ObjectProperty<Callback<ButtonType,R>> Dialog.resultConverterProperty​()
      将用户点击的ButtonType转换为可通过result属性返回的结果的API 。
      ObjectProperty<Callback<TableView<S>,TableRow<S>>> TableView.rowFactoryProperty​()
      一个产生TableRow的函数。
      ObjectProperty<Callback<TreeTableView<S>,TreeTableRow<S>>> TreeTableView.rowFactoryProperty​()
      一个生成TreeTableRow的函数。
      ObjectProperty<Callback<TableView<S>,Boolean>> TableView.sortPolicyProperty​()
      排序策略指定如何执行此TableView中的排序。
      ObjectProperty<Callback<TreeTableView<S>,Boolean>> TreeTableView.sortPolicyProperty​()
      排序策略指定如何执行此TreeTableView中的排序。
      Methods in javafx.scene.control with parameters of type Callback
      Modifier and Type 方法 描述
      void ComboBox.setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
      设置属性cellFactory的值。
      void ListView.setCellFactory​(Callback<ListView<T>,ListCell<T>> value)
      设置要在ListView中使用的新单元格工厂。
      void TableColumn.setCellFactory​(Callback<TableColumn<S,T>,TableCell<S,T>> value)
      设置属性cellFactory的值。
      void TreeTableColumn.setCellFactory​(Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> value)
      设置属性cellFactory的值。
      void TreeView.setCellFactory​(Callback<TreeView<T>,TreeCell<T>> value)
      设置将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。
      void TableColumn.setCellValueFactory​(Callback<TableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
      设置属性cellValueFactory的值。
      void TreeTableColumn.setCellValueFactory​(Callback<TreeTableColumn.CellDataFeatures<S,T>,ObservableValue<T>> value)
      设置属性cellValueFactory的值。
      void TableView.setColumnResizePolicy​(Callback<TableView.ResizeFeatures,Boolean> callback)
      设置属性columnResizePolicy的值。
      void TreeTableView.setColumnResizePolicy​(Callback<TreeTableView.ResizeFeatures,Boolean> callback)
      设置属性columnResizePolicy的值。
      void DatePicker.setDayCellFactory​(Callback<DatePicker,DateCell> value)
      设置属性dayCellFactory的值。
      void Pagination.setPageFactory​(Callback<Integer,Node> value)
      设置页面工厂回调函数。
      void Dialog.setResultConverter​(Callback<ButtonType,R> value)
      设置属性resultConverter的值。
      void TableView.setRowFactory​(Callback<TableView<S>,TableRow<S>> value)
      设置属性rowFactory的值。
      void TreeTableView.setRowFactory​(Callback<TreeTableView<S>,TreeTableRow<S>> value)
      设置属性rowFactory的值。
      void TableView.setSortPolicy​(Callback<TableView<S>,Boolean> callback)
      设置属性sortPolicy的值。
      void TreeTableView.setSortPolicy​(Callback<TreeTableView<S>,Boolean> callback)
      设置属性sortPolicy的值。

    • Uses of Callback in javafx.scene.control.cell

      Classes in javafx.scene.control.cell that implement Callback
      Modifier and Type Class 描述
      class  MapValueFactory<T>
      Callback界面的方便实现，专为TableColumn cell value factory中使用而设计。
      class  PropertyValueFactory<S,T>
      Callback界面的方便实现，专为TableColumn cell value factory使用而设计。
      class  TreeItemPropertyValueFactory<S,T>
      Callback界面的方便实现，专为TreeTableColumn cell value factory使用而设计。
      Methods in javafx.scene.control.cell that return Callback
      Modifier and Type 方法 描述
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(T... items)
      创建ComboBox单元格工厂，用于ListView控件。
      static Callback<ListView<String>,ListCell<String>> TextFieldListCell.forListView​()
      提供TextField ，允许在双击单元格时或当调用ListView.edit(int)时编辑单元格内容。
      static <T> Callback<ListView<T>,ListCell<T>> TextFieldListCell.forListView​(StringConverter<T> converter)
      提供TextField ，使单元格内容的编辑在小区双击，或者当ListView.edit(int)被调用。
      static <S> Callback<TableColumn<S,Boolean>,TableCell<S,Boolean>> CheckBoxTableCell.forTableColumn​(TableColumn<S,Boolean> column)
      创建一个用于TableColumn电池厂的电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(T... items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S> Callback<TableColumn<S,Double>,TableCell<S,Double>> ProgressBarTableCell.forTableColumn​()
      提供了一个ProgressBar ，它允许从0.0到1.0进行数字值的轻松可视化。
      static <S> Callback<TableColumn<S,String>,TableCell<S,String>> TextFieldTableCell.forTableColumn​()
      提供TextField ，允许在单元格双击时或当调用TableView.edit(int, javafx.scene.control.TableColumn)时对单元格内容进行编辑。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> TextFieldTableCell.forTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在单元格双击时或当调用TableView.edit(int, javafx.scene.control.TableColumn)时编辑单元格内容。
      static <S> Callback<TreeTableColumn<S,Boolean>,TreeTableCell<S,Boolean>> CheckBoxTreeTableCell.forTreeTableColumn​(TreeTableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(T... items)
      创建ComboBox单元格工厂用于TreeTableColumn控件。
      static <S> Callback<TreeTableColumn<S,Double>,TreeTableCell<S,Double>> ProgressBarTreeTableCell.forTreeTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0轻松显示数字值。
      static <S> Callback<TreeTableColumn<S,String>,TreeTableCell<S,String>> TextFieldTreeTableCell.forTreeTableColumn​()
      提供了一个TextField ，允许在双击单元格时调用单元格内容，或者调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> TextFieldTreeTableCell.forTreeTableColumn​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时或当调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时编辑单元格内容。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​()
      创建在TreeView控件中使用的单元格工厂，尽管在TreeView中使用时有一个主要假设：此单元格工厂假定TreeView根和所有子节点都是CheckBoxTreeItem的实例，而不是正常使用的默认的TreeItem类。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(T... items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, ObservableList<T> items)
      创建ComboBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(T... items)
      创建ComboBox单元格工厂用于TreeView控件。
      static Callback<TreeView<String>,TreeCell<String>> TextFieldTreeCell.forTreeView​()
      提供TextField ，允许在双击单元格时调用单元格内容，或者调用TreeView.edit(javafx.scene.control.TreeItem)时。
      static <T> Callback<TreeView<T>,TreeCell<T>> TextFieldTreeCell.forTreeView​(StringConverter<T> converter)
      提供TextField ，允许在双击单元格时或当调用TreeView.edit(javafx.scene.control.TreeItem)时编辑单元格内容。
      Callback<T,ObservableValue<Boolean>> CheckBoxListCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<Integer,ObservableValue<Boolean>> CheckBoxTableCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<TreeItem<T>,ObservableValue<Boolean>> CheckBoxTreeCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<Integer,ObservableValue<Boolean>> CheckBoxTreeTableCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Methods in javafx.scene.control.cell that return types with arguments of type Callback
      Modifier and Type 方法 描述
      ObjectProperty<Callback<T,ObservableValue<Boolean>>> CheckBoxListCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<TreeItem<T>,ObservableValue<Boolean>>> CheckBoxTreeCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTreeTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      Methods in javafx.scene.control.cell with parameters of type Callback
      Modifier and Type 方法 描述
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建用于ListView控件的单元格工厂。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个用于TableColumn电池厂的电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个用于TreeTableColumn电池厂的电池厂 。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      void CheckBoxListCell.setSelectedStateCallback​(Callback<T,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTableCell.setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTreeCell.setSelectedStateCallback​(Callback<TreeItem<T>,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTreeTableCell.setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      Constructors in javafx.scene.control.cell with parameters of type Callback
      Constructor 描述
      CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxListCell。
      CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxListCell。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      使用自定义的Callback创建一个默认的CheckBoxTableCell，以检索给定单元格索引的ObservableValue。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个带有自定义字符串转换器的CheckBoxTableCell。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxTreeTableCell与自定义Callback检索给定单元格索引的ObservableValue。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxTreeTableCell。

    • Uses of Callback in javafx.scene.control.skin

      Methods in javafx.scene.control.skin that return Callback
      Modifier and Type 方法 描述
      Callback<VirtualFlow<T>,T> VirtualFlow.getCellFactory​()
      返回当前的单元格工厂。
      Methods in javafx.scene.control.skin that return types with arguments of type Callback
      Modifier and Type 方法 描述
      ObjectProperty<Callback<VirtualFlow<T>,T>> VirtualFlow.cellFactoryProperty​()
      设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。
      Methods in javafx.scene.control.skin with parameters of type Callback
      Modifier and Type 方法 描述
      void VirtualFlow.setCellFactory​(Callback<VirtualFlow<T>,T> value)
      设置要在VirtualFlow中使用的新单元格工厂。

    • Uses of Callback in javafx.scene.web

      Methods in javafx.scene.web that return Callback
      Modifier and Type 方法 描述
      Callback<String,Boolean> WebEngine.getConfirmHandler​()
      获取属性confirmHandler的值。
      Callback<PopupFeatures,WebEngine> WebEngine.getCreatePopupHandler​()
      获取属性createPopupHandler的值。
      Callback<PromptData,String> WebEngine.getPromptHandler​()
      获取属性promptHandler的值。
      Methods in javafx.scene.web that return types with arguments of type Callback
      Modifier and Type 方法 描述
      ObjectProperty<Callback<String,Boolean>> WebEngine.confirmHandlerProperty​()
      JavaScript confirm处理程序属性。
      ObjectProperty<Callback<PopupFeatures,WebEngine>> WebEngine.createPopupHandlerProperty​()
      JavaScript弹出窗口处理程序属性。
      ObjectProperty<Callback<PromptData,String>> WebEngine.promptHandlerProperty​()
      JavaScript prompt处理程序属性。
      Methods in javafx.scene.web with parameters of type Callback
      Modifier and Type 方法 描述
      void WebEngine.setConfirmHandler​(Callback<String,Boolean> handler)
      设置属性confirmHandler的值。
      void WebEngine.setCreatePopupHandler​(Callback<PopupFeatures,WebEngine> handler)
      设置属性createPopupHandler的值。
      void WebEngine.setPromptHandler​(Callback<PromptData,String> handler)
      Sets the value of the property promptHandler.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


BigDecimalStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class BigDecimalStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<BigDecimal>
      • javafx.util.converter.BigDecimalStringConverter

  • public class BigDecimalStringConverter
extends StringConverter<BigDecimal>

    StringConverter实现BigDecimal值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      BigDecimalStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigDecimal fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(BigDecimal value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BigDecimalStringConverter

        public BigDecimalStringConverter​()

    • 方法详细信息

      • fromString

        public BigDecimal fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<BigDecimal>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(BigDecimal value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<BigDecimal>
        参数
        value - 要转换的类型为 T的对象
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BigIntegerStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class BigIntegerStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<BigInteger>
      • javafx.util.converter.BigIntegerStringConverter

  • public class BigIntegerStringConverter
extends StringConverter<BigInteger>

    StringConverter实现BigInteger值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      BigIntegerStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(BigInteger value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BigIntegerStringConverter

        public BigIntegerStringConverter​()

    • 方法详细信息

      • fromString

        public BigInteger fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<BigInteger>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(BigInteger value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<BigInteger>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BooleanStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class BooleanStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Boolean>
      • javafx.util.converter.BooleanStringConverter

  • public class BooleanStringConverter
extends StringConverter<Boolean>

    StringConverter Boolean （和布尔基元）值的实现。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      BooleanStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Boolean fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(Boolean value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BooleanStringConverter

        public BooleanStringConverter​()

    • 方法详细信息

      • fromString

        public Boolean fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Boolean>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Boolean value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Boolean>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ByteStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class ByteStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Byte>
      • javafx.util.converter.ByteStringConverter

  • public class ByteStringConverter
extends StringConverter<Byte>

    StringConverter实施Byte （和原始字节）值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      ByteStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Byte fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(Byte value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ByteStringConverter

        public ByteStringConverter​()

    • 方法详细信息

      • fromString

        public Byte fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Byte>
        参数
        value - String转换
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Byte value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Byte>
        参数
        value - 要转换的类型为 T的对象
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CharacterStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class CharacterStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Character>
      • javafx.util.converter.CharacterStringConverter

  • public class CharacterStringConverter
extends StringConverter<Character>

    StringConverter实现Character （和char基元）值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      CharacterStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Character fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(Character value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CharacterStringConverter

        public CharacterStringConverter​()

    • 方法详细信息

      • fromString

        public Character fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Character>
        参数
        value - 转换 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Character value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Character>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CurrencyStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class CurrencyStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Number>
      • javafx.util.converter.NumberStringConverter
        • javafx.util.converter.CurrencyStringConverter

  • public class CurrencyStringConverter
extends NumberStringConverter

    StringConverter代表货币的Number值的实现。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    PercentageStringConverter ， NumberStringConverter ， StringConverter

    • 构造方法摘要

      构造方法
      Constructor 描述
      CurrencyStringConverter​()
      CurrencyStringConverter​(String pattern)
      CurrencyStringConverter​(NumberFormat numberFormat)
      CurrencyStringConverter​(Locale locale)
      CurrencyStringConverter​(Locale locale, String pattern)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected NumberFormat getNumberFormat​()
      返回一个NumberFormat实例，用于格式化和解析StringConverter 。

      • Methods inherited from class javafx.util.converter.NumberStringConverter

        fromString, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CurrencyStringConverter

        public CurrencyStringConverter​()

      • CurrencyStringConverter

        public CurrencyStringConverter​(Locale locale)

      • CurrencyStringConverter

        public CurrencyStringConverter​(String pattern)

      • CurrencyStringConverter

        public CurrencyStringConverter​(Locale locale,
                               String pattern)

      • CurrencyStringConverter

        public CurrencyStringConverter​(NumberFormat numberFormat)

    • 方法详细信息

      • getNumberFormat

        protected NumberFormat getNumberFormat​()

        返回一个NumberFormat实例，用于格式化和解析StringConverter 。

        重写：
        getNumberFormat在 NumberStringConverter
        结果
        a NumberFormat instance for formatting and parsing in this StringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DateStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class DateStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Date>
      • javafx.util.converter.DateTimeStringConverter
        • javafx.util.converter.DateStringConverter

  • public class DateStringConverter
extends DateTimeStringConverter

    StringConverter实现Date值。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    TimeStringConverter ， DateTimeStringConverter

    • Field Summary

      • Fields inherited from class javafx.util.converter.DateTimeStringConverter

        dateFormat, dateStyle, locale, pattern, timeStyle

    • 构造方法摘要

      构造方法
      Constructor 描述
      DateStringConverter​()
      创建StringConverter为Date值，使用DateFormat.DEFAULT日期样式。
      DateStringConverter​(int dateStyle)
      创建StringConverter为Date值，使用指定DateFormat日期样式。
      DateStringConverter​(String pattern)
      使用指定的模式为Date值创建StringConverter 。
      DateStringConverter​(DateFormat dateFormat)
      使用指定的DateFormat格式化程序为Date创建一个StringConverter值。
      DateStringConverter​(Locale locale)
      创建StringConverter的Date值，使用指定的区域设置和DateFormat.DEFAULT日期风格。
      DateStringConverter​(Locale locale, int dateStyle)
      使用指定的区域设置和DateFormat日期样式，为Date创建一个StringConverter值。
      DateStringConverter​(Locale locale, String pattern)
      使用指定的区域设置和模式为Date创建一个StringConverter值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected DateFormat getDateFormat​()
      返回一个DateFormat实例，用于格式化和解析StringConverter 。

      • Methods inherited from class javafx.util.converter.DateTimeStringConverter

        fromString, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DateStringConverter

        public DateStringConverter​()
        使用DateFormat.DEFAULT日期风格为Date创建一个StringConverter的值。

      • DateStringConverter

        public DateStringConverter​(int dateStyle)
        使用指定的DateFormat日期样式为Date创建一个StringConverter值。
        参数
        dateStyle - 给定的格式化样式。 例如，美国地区的“M / d / yy”为DateFormat.SHORT 。
        从以下版本开始：
        JavaFX 8u40

      • DateStringConverter

        public DateStringConverter​(Locale locale)
        创建StringConverter为Date值，使用指定的语言环境和DateFormat.DEFAULT日期样式。
        参数
        locale - 给定的区域设置。

      • DateStringConverter

        public DateStringConverter​(Locale locale,
                           int dateStyle)
        创建StringConverter为Date值，使用指定的语言环境和DateFormat日期样式。
        参数
        locale - 给定的区域设置。
        dateStyle - 给定的格式化样式。 例如，美国地区的“M / d / yy”为DateFormat.SHORT 。
        从以下版本开始：
        JavaFX 8u40

      • DateStringConverter

        public DateStringConverter​(String pattern)
        创建StringConverter为Date值，使用指定的模式。
        参数
        pattern - 描述日期格式的模式。

      • DateStringConverter

        public DateStringConverter​(Locale locale,
                           String pattern)
        创建StringConverter为Date值，使用指定的语言环境和模式。
        参数
        locale - 给定的区域设置。
        pattern - 描述日期格式的模式。

      • DateStringConverter

        public DateStringConverter​(DateFormat dateFormat)
        使用DateFormat格式化程序为Date创建一个StringConverter值。
        参数
        dateFormat - 用于格式化和解析的DateFormat 。

    • 方法详细信息

      • getDateFormat

        protected DateFormat getDateFormat​()

        返回一个DateFormat实例，用于在此StringConverter中进行格式化和解析。

        重写：
        getDateFormat在 DateTimeStringConverter
        结果
        a DateFormat instance for formatting and parsing in this StringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DateTimeStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class DateTimeStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Date>
      • javafx.util.converter.DateTimeStringConverter
  • 已知直接子类：
    DateStringConverter ， TimeStringConverter

    public class DateTimeStringConverter
extends StringConverter<Date>

    StringConverter代表日期和时间的Date值的实现。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    DateStringConverter ， TimeStringConverter

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      protected DateFormat | dateFormat
      protected int | dateStyle
      protected Locale | locale
      protected String | pattern
      protected int | timeStyle

    • 构造方法摘要

      构造方法
      Constructor 描述
      DateTimeStringConverter​()
      创建StringConverter为Date值，使用DateFormat.DEFAULT种样式的日期和时间。
      DateTimeStringConverter​(int dateStyle, int timeStyle)
      为Date创建StringConverter ，使用指定的DateFormat样式进行日期和时间。
      DateTimeStringConverter​(String pattern)
      创建StringConverter为Date值，使用指定的模式。
      DateTimeStringConverter​(DateFormat dateFormat)
      使用DateFormat格式化程序为Date创建一个StringConverter值。
      DateTimeStringConverter​(Locale locale)
      创建StringConverter为Date值，使用指定的语言环境和DateFormat.DEFAULT种风格的日期和时间。
      DateTimeStringConverter​(Locale locale, int dateStyle, int timeStyle)
      使用Date值创建StringConverter ，使用指定的区域设置和日期和时间的DateFormat样式。
      DateTimeStringConverter​(Locale locale, String pattern)
      创建StringConverter为Date值，使用指定的语言环境和模式。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Date fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      protected DateFormat getDateFormat​()
      返回一个DateFormat实例，用于格式化和解析StringConverter 。
      String toString​(Date value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • locale

        protected final Locale locale

      • pattern

        protected final String pattern

      • dateFormat

        protected final DateFormat dateFormat

      • dateStyle

        protected final int dateStyle
        从以下版本开始：
        JavaFX 8u40

      • timeStyle

        protected final int timeStyle
        从以下版本开始：
        JavaFX 8u40

    • 构造方法详细信息

      • DateTimeStringConverter

        public DateTimeStringConverter​()
        创建StringConverter为Date值，使用DateFormat.DEFAULT种样式的日期和时间。

      • DateTimeStringConverter

        public DateTimeStringConverter​(int dateStyle,
                               int timeStyle)
        创建StringConverter为Date值，使用指定DateFormat种样式的日期和时间。
        参数
        dateStyle - 给定的格式化样式。 例如，美国地区的“M / d / yy”为DateFormat.SHORT 。
        timeStyle - 给定的格式化样式。 例如，美国地区的“h：mm a”为DateFormat.SHORT 。
        从以下版本开始：
        JavaFX 8u40

      • DateTimeStringConverter

        public DateTimeStringConverter​(Locale locale)
        创建StringConverter的Date值，使用指定的区域设置和DateFormat.DEFAULT样式的日期和时间。
        参数
        locale - 给定的区域设置。

      • DateTimeStringConverter

        public DateTimeStringConverter​(Locale locale,
                               int dateStyle,
                               int timeStyle)
        使用Date值创建StringConverter ，使用指定的区域设置和DateFormat样式进行日期和时间。
        参数
        locale - 给定的区域设置。
        dateStyle - 给定的格式化样式。 例如，美国地区的“M / d / yy”为DateFormat.SHORT 。
        timeStyle - 给定的格式化样式。 例如，美国地区的“h：mm a”为DateFormat.SHORT 。
        从以下版本开始：
        JavaFX 8u40

      • DateTimeStringConverter

        public DateTimeStringConverter​(String pattern)
        创建一个StringConverter的Date值，使用指定的模式。
        参数
        pattern - 描述日期和时间格式的模式。

      • DateTimeStringConverter

        public DateTimeStringConverter​(Locale locale,
                               String pattern)
        创建StringConverter为Date值，使用指定的语言环境和模式。
        参数
        locale - 给定的地区。
        pattern - 描述日期和时间格式的模式。

      • DateTimeStringConverter

        public DateTimeStringConverter​(DateFormat dateFormat)
        为Date创建一个StringConverter值，使用指定的DateFormat格式化程序。
        参数
        dateFormat - 用于格式化和解析的DateFormat 。

    • 方法详细信息

      • fromString

        public Date fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Date>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Date value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Date>
        参数
        value - 要转换的类型为 T的对象
        结果
        传入的对象的字符串表示形式。

      • getDateFormat

        protected DateFormat getDateFormat​()

        返回一个DateFormat实例，用于格式化和解析StringConverter 。

        结果
        一个DateFormat实例，用于格式化和解析StringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DefaultStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class DefaultStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<String>
      • javafx.util.converter.DefaultStringConverter

  • public class DefaultStringConverter
extends StringConverter<String>

    270724866813304实现String值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      DefaultStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(String value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultStringConverter

        public DefaultStringConverter​()

    • 方法详细信息

      • toString

        public String toString​(String value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<String>
        参数
        value - 要转换的类型为 T的对象
        结果
        传入的对象的字符串表示形式。

      • fromString

        public String fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<String>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DoubleStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class DoubleStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Double>
      • javafx.util.converter.DoubleStringConverter

  • public class DoubleStringConverter
extends StringConverter<Double>

    StringConverter实现Double （和双原语）值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      DoubleStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Double fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(Double value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DoubleStringConverter

        public DoubleStringConverter​()

    • 方法详细信息

      • fromString

        public Double fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Double>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Double value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Double>
        参数
        value - 要转换的类型为 T的对象
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FloatStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class FloatStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Float>
      • javafx.util.converter.FloatStringConverter

  • public class FloatStringConverter
extends StringConverter<Float>

    StringConverter Float （和浮点元素 ）值的实现。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      FloatStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Float fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(Float value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FloatStringConverter

        public FloatStringConverter​()

    • 方法详细信息

      • fromString

        public Float fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Float>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Float value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Float>
        参数
        value - 要转换的类型为 T的对象
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FormatStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class FormatStringConverter<T>

  • java.lang.Object
    • javafx.util.StringConverter<T>
      • javafx.util.converter.FormatStringConverter<T>

  • public class FormatStringConverter<T>
extends StringConverter<T>

    StringConverter实现可以使用Format实例。

    从以下版本开始：
    JavaFX 2.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      FormatStringConverter​(Format format)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      protected Format getFormat​()
      返回一个Format实例，用于格式化和解析StringConverter 。
      String toString​(T value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FormatStringConverter

        public FormatStringConverter​(Format format)

    • 方法详细信息

      • fromString

        public T fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<T>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(T value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<T>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。

      • getFormat

        protected Format getFormat​()

        返回一个Format实例，用于格式化和解析StringConverter 。

        结果
        一个Format实例，用于格式化和解析StringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntegerStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class IntegerStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Integer>
      • javafx.util.converter.IntegerStringConverter

  • public class IntegerStringConverter
extends StringConverter<Integer>

    StringConverter实现Integer （和int原语）值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      IntegerStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Integer fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(Integer value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IntegerStringConverter

        public IntegerStringConverter​()

    • 方法详细信息

      • fromString

        public Integer fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Integer>
        参数
        value - 转换 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Integer value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Integer>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javafx.util.converter (Java SE 9 & JDK 9 )

javafx.util.converter

Classes

  • BigDecimalStringConverter
  • BigIntegerStringConverter
  • BooleanStringConverter
  • ByteStringConverter
  • CharacterStringConverter
  • CurrencyStringConverter
  • DateStringConverter
  • DateTimeStringConverter
  • DefaultStringConverter
  • DoubleStringConverter
  • FloatStringConverter
  • FormatStringConverter
  • IntegerStringConverter
  • LocalDateStringConverter
  • LocalDateTimeStringConverter
  • LocalTimeStringConverter
  • LongStringConverter
  • NumberStringConverter
  • PercentageStringConverter
  • ShortStringConverter
  • TimeStringConverter


javafx.util.converter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module javafx.base

Package javafx.util.converter

此包用于JavaFX的标准字符串转换器。

包装规格

此软件包适用于JavaFX的标准string converters 。 这些实现的示例用例包括：
  • JavaFX binding API用于在绑定需要此对象时将对象转换为和从字符串转换。
  • 在JavaFX UI控件中，如ComboBox和ChoiceBox
  • 类摘要
    Class 描述
    BigDecimalStringConverter
    StringConverter实现BigDecimal值。
    BigIntegerStringConverter
    StringConverter实现为BigInteger值。
    BooleanStringConverter
    StringConverter实现为Boolean （和布尔基元）值。
    ByteStringConverter
    StringConverter实现Byte （和字节基元）值。
    CharacterStringConverter
    StringConverter实现Character （和char基元）值。
    CurrencyStringConverter
    StringConverter实现代表货币的Number值。
    DateStringConverter
    StringConverter实现Date值。
    DateTimeStringConverter
    StringConverter代表日期和时间的Date值的实现。
    DefaultStringConverter
    StringConverter实现String值。
    DoubleStringConverter
    StringConverter实现Double （和双原语）值。
    FloatStringConverter
    StringConverter实现Float （和浮点元素 ）值。
    FormatStringConverter<T>
    StringConverter实现可以使用Format实例。
    IntegerStringConverter
    StringConverter实现Integer （和int原语）值。
    LocalDateStringConverter
    StringConverter实现LocalDate值。
    LocalDateTimeStringConverter
    StringConverter实现LocalDateTime值。
    LocalTimeStringConverter
    StringConverter实现LocalTime值。
    LongStringConverter
    StringConverter实现Long （和长基元）值。
    NumberStringConverter
    StringConverter实现Number值。
    PercentageStringConverter
    StringConverter实现Number代表百分比的值。
    ShortStringConverter
    StringConverter实现Short值。
    TimeStringConverter
    StringConverter实现为代表时间的Date值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javafx.util.converter Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javafx.util.converter

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javafx.util.StringConverter<T>
      • javafx.util.converter.BigDecimalStringConverter
      • javafx.util.converter.BigIntegerStringConverter
      • javafx.util.converter.BooleanStringConverter
      • javafx.util.converter.ByteStringConverter
      • javafx.util.converter.CharacterStringConverter
      • javafx.util.converter.DateTimeStringConverter
        • javafx.util.converter.DateStringConverter
        • javafx.util.converter.TimeStringConverter
      • javafx.util.converter.DefaultStringConverter
      • javafx.util.converter.DoubleStringConverter
      • javafx.util.converter.FloatStringConverter
      • javafx.util.converter.FormatStringConverter<T>
      • javafx.util.converter.IntegerStringConverter
      • javafx.util.converter.LocalDateStringConverter
      • javafx.util.converter.LocalDateTimeStringConverter
      • javafx.util.converter.LocalTimeStringConverter
      • javafx.util.converter.LongStringConverter
      • javafx.util.converter.NumberStringConverter
        • javafx.util.converter.CurrencyStringConverter
        • javafx.util.converter.PercentageStringConverter
      • javafx.util.converter.ShortStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


LocalDateStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class LocalDateStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<LocalDate>
      • javafx.util.converter.LocalDateStringConverter

  • public class LocalDateStringConverter
extends StringConverter<LocalDate>

    StringConverter实现LocalDate值。

    从以下版本开始：
    JavaFX 8u40
    另请参见：
    LocalTimeStringConverter ， LocalDateTimeStringConverter

    • 构造方法摘要

      构造方法
      Constructor 描述
      LocalDateStringConverter​()
      创建StringConverter为LocalDate值，使用基于默认格式化器和解析器IsoChronology ， FormatStyle.SHORT ，以及用户的Locale 。
      LocalDateStringConverter​(DateTimeFormatter formatter, DateTimeFormatter parser)
      使用提供的格式化程序和解析器为LocalDate值创建{#link StringConverter}值。
      LocalDateStringConverter​(FormatStyle dateStyle)
      根据IsoChronology ，指定的FormatStyle和用户的Locale ，使用默认格式化程序和解析器为LocalDate创建一个LocalDate的值。
      LocalDateStringConverter​(FormatStyle dateStyle, Locale locale, Chronology chronology)
      创建一个字符串转换LocalDate个使用默认的格式和语法分析器，它会根据所提供的值FormatStyle ， Locale ，并Chronology 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      LocalDate fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(LocalDate value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LocalDateStringConverter

        public LocalDateStringConverter​()
        创建StringConverter为LocalDate值，使用基于默认格式化器和解析器IsoChronology ， FormatStyle.SHORT ，以及用户的Locale 。

        该转换器确保了toString（）和fromString（）方法之间的对称性。 由DateTimeFormatter使用的许多默认基于区域设置的模式将仅在字符串格式化时显示年份的两位数字。 这将导致像1955这样的值显示为55，这反过来将被解析为2055.该转换器修改两位数年份模式，始终使用四位数字。 输入解析不受影响，因此在这些区域设置中，两位数的年份值仍然可以按预期方式宽松地解析。

      • LocalDateStringConverter

        public LocalDateStringConverter​(FormatStyle dateStyle)
        创建StringConverter为LocalDate值，使用基于默认格式化器和解析器IsoChronology ，指定FormatStyle ，以及用户的Locale 。
        参数
        dateStyle - 默认格式化程序和解析器将使用的FormatStyle 。 如果为null，则将使用FormatStyle.SHORT 。

      • LocalDateStringConverter

        public LocalDateStringConverter​(DateTimeFormatter formatter,
                                DateTimeFormatter parser)
        使用提供的格式化程序和解析器为LocalDate值创建{#link StringConverter}。

        例如，要使用固定模式转换两种方式：

         String pattern = "yyyy-MM-dd";
 DateTimeFormatter formatter = DateTimeFormatter.ofPattern(pattern);
 StringConverter<LocalDate> converter =
     DateTimeStringConverter.getLocalDateStringConverter(formatter, null);
        请注意，可以创建格式化程序和解析器， 以根据需要处理非默认值Locale和Chronology 。
        参数
        formatter - 将用于通过toString（）方法格式化的DateTimeFormatter的实例。 如果为null，则将使用默认格式化程序。
        parser - 将用于通过fromString（）方法进行解析的DateTimeFormatter的实例。 这可以与格式化程序相同。 如果为null，则将使用格式化程序，如果也为空，则将使用默认解析器。

      • LocalDateStringConverter

        public LocalDateStringConverter​(FormatStyle dateStyle,
                                Locale locale,
                                Chronology chronology)
        创建一个字符串转换LocalDate个使用默认的格式和语法分析器，它会根据所提供的值FormatStyle ， Locale ，并Chronology 。
        参数
        dateStyle - 默认格式化程序和解析器将使用的FormatStyle 。 如果为null，则将使用FormatStyle.SHORT 。
        locale - 默认格式化程序和解析器将使用的Locale 。 如果为null，那么将使用Locale.getDefault(Locale.Category.FORMAT) 。
        chronology - 默认格式化程序和解析器将使用的Chronology 。 如果为null，则将使用IsoChronology.INSTANCE 。

    • 方法详细信息

      • fromString

        public LocalDate fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<LocalDate>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(LocalDate value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<LocalDate>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LocalDateTimeStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class LocalDateTimeStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<LocalDateTime>
      • javafx.util.converter.LocalDateTimeStringConverter

  • public class LocalDateTimeStringConverter
extends StringConverter<LocalDateTime>

    StringConverter实现LocalDateTime值。

    从以下版本开始：
    JavaFX 8u40
    另请参见：
    LocalDateStringConverter ， LocalTimeStringConverter

    • 构造方法摘要

      构造方法
      Constructor 描述
      LocalDateTimeStringConverter​()
      创建StringConverter为LocalDateTime值，使用基于默认格式化器和解析器IsoChronology ， FormatStyle.SHORT的日期和时间，以及用户的Locale 。
      LocalDateTimeStringConverter​(DateTimeFormatter formatter, DateTimeFormatter parser)
      创建StringConverter为LocalDateTime使用提供的格式化器和解析器值。
      LocalDateTimeStringConverter​(FormatStyle dateStyle, FormatStyle timeStyle)
      使用LocalDateTime值创建StringConverter ，使用基于IsoChronology的默认格式化程序和解析器，日期和时间的指定值为FormatStyle ，以及用户的Locale 。
      LocalDateTimeStringConverter​(FormatStyle dateStyle, FormatStyle timeStyle, Locale locale, Chronology chronology)
      创建StringConverter为LocalDateTime使用默认格式化器和解析器，其将基于所提供的值FormatStyle个 S， Locale ，和Chronology 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      LocalDateTime fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(LocalDateTime value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LocalDateTimeStringConverter

        public LocalDateTimeStringConverter​()
        创建StringConverter为LocalDateTime值，使用基于默认格式化器和解析器IsoChronology ， FormatStyle.SHORT的日期和时间，以及用户的Locale 。

        该转换器确保了toString（）和fromString（）方法之间的对称性。 由DateTimeFormatter使用的许多默认基于语言环境的模式在格式化为字符串的年份中只显示两位数字。 这将导致像1955这样的值显示为55，这反过来将被解析为2055.该转换器修改两位数年份模式，始终使用四位数字。 输入解析不受影响，因此在这些区域设置中仍然可以按预期方式分析两位数的年份值。

      • LocalDateTimeStringConverter

        public LocalDateTimeStringConverter​(FormatStyle dateStyle,
                                    FormatStyle timeStyle)
        使用LocalDateTime值创建StringConverter ，使用基于IsoChronology的默认格式化程序和解析器，日期和时间的指定值为FormatStyle ，以及用户的Locale 。
        参数
        dateStyle - FormatStyle将由默认格式化程序和解析器用于日期。 如果为null，则将使用FormatStyle.SHORT 。
        timeStyle - FormatStyle将被默认格式化程序和解析器用于该时间。 如果为null，那么将使用FormatStyle.SHORT 。

      • LocalDateTimeStringConverter

        public LocalDateTimeStringConverter​(DateTimeFormatter formatter,
                                    DateTimeFormatter parser)
        使用提供的格式化程序和解析器为LocalDateTime值创建一个StringConverter值。

        例如，要使用固定模式转换两种方式：

         String pattern = "yyyy-MM-dd HH:mm";
 DateTimeFormatter formatter = DateTimeFormatter.ofPattern(pattern);
 StringConverter<LocalDateTime> converter =
     DateTimeStringConverter.getLocalDateTimeConverter(formatter, null);
        请注意，格式化程序和解析器可以根据需要创建，以处理非默认值Locale和Chronology 。
        参数
        formatter -的实例DateTimeFormatter将被用于由toString（）方法格式化。 如果为null，则将使用默认格式化程序。
        parser -的实例DateTimeFormatter其将用于由所述fromString（）方法解析。 这可以与格式化程序相同。 如果为null，则将使用格式化程序，如果也为空，则将使用默认解析器。

      • LocalDateTimeStringConverter

        public LocalDateTimeStringConverter​(FormatStyle dateStyle,
                                    FormatStyle timeStyle,
                                    Locale locale,
                                    Chronology chronology)
        使用默认格式化程序和解析器为LocalDateTime创建一个LocalDateTime值，这将基于提供的FormatStyle s， Locale和Chronology 。
        参数
        dateStyle - FormatStyle将被默认格式化程序和解析器用于日期。 如果为null，那么将使用FormatStyle.SHORT 。
        timeStyle - FormatStyle将被默认格式化程序和解析器用于该时间。 如果为null，则将使用FormatStyle.SHORT 。
        locale - 默认格式化程序和解析器将使用的Locale 。 如果为null，那么将使用Locale.getDefault(Locale.Category.FORMAT) 。
        chronology - 默认格式化程序和解析器将使用的Chronology 。 如果为null，那么将使用IsoChronology.INSTANCE 。

    • 方法详细信息

      • fromString

        public LocalDateTime fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<LocalDateTime>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(LocalDateTime value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<LocalDateTime>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LocalTimeStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class LocalTimeStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<LocalTime>
      • javafx.util.converter.LocalTimeStringConverter

  • public class LocalTimeStringConverter
extends StringConverter<LocalTime>

    StringConverter实现LocalTime值。

    从以下版本开始：
    JavaFX 8u40
    另请参见：
    LocalDateStringConverter ， LocalDateTimeStringConverter

    • 构造方法摘要

      构造方法
      Constructor 描述
      LocalTimeStringConverter​()
      为LocalTime创建StringConverter ，使用默认格式化程序和解析器（ FormatStyle.SHORT ）和用户的Locale 。
      LocalTimeStringConverter​(DateTimeFormatter formatter, DateTimeFormatter parser)
      使用提供的格式化程序和解析器为LocalTime创建一个StringConverter值，它们负责选择所需的Locale 。
      LocalTimeStringConverter​(FormatStyle timeStyle)
      为LocalTime创建一个StringConverter值，使用默认格式化程序和解析器与指定的FormatStyle并基于用户的Locale 。
      LocalTimeStringConverter​(FormatStyle timeStyle, Locale locale)
      为LocalTime创建一个StringConverter值，使用指定的FormatStyle和Locale的默认格式化程序和解析器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      LocalTime fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(LocalTime value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LocalTimeStringConverter

        public LocalTimeStringConverter​()
        创建StringConverter为LocalTime值，使用默认格式化器和解析器与FormatStyle.SHORT ，和用户的Locale 。

      • LocalTimeStringConverter

        public LocalTimeStringConverter​(FormatStyle timeStyle)
        创建StringConverter为LocalTime值，使用默认格式化器和解析器使用指定FormatStyle ，并根据用户的Locale 。
        参数
        timeStyle - 默认格式化程序和解析器将使用的FormatStyle 。 如果为null，那么将使用FormatStyle.SHORT 。

      • LocalTimeStringConverter

        public LocalTimeStringConverter​(FormatStyle timeStyle,
                                Locale locale)
        为LocalTime创建一个StringConverter值，使用具有指定的FormatStyle和Locale的默认格式化程序和解析器。
        参数
        timeStyle - 默认格式化程序和解析器将使用的FormatStyle 。 如果为null，那么将使用FormatStyle.SHORT 。
        locale - 默认格式化程序和解析器将使用的Locale 。 如果为null，那么将使用Locale.getDefault(Locale.Category.FORMAT) 。

      • LocalTimeStringConverter

        public LocalTimeStringConverter​(DateTimeFormatter formatter,
                                DateTimeFormatter parser)
        使用提供的格式化程序和解析器为LocalTime创建一个StringConverter值，它们负责选择所需的Locale 。

        例如，固定模式可用于转换两种方式：

         String pattern = "HH:mm:ss";
 DateTimeFormatter formatter = DateTimeFormatter.ofPattern(pattern);
 StringConverter<LocalTime> converter =
     DateTimeStringConverter.getLocalTimeConverter(formatter, null);
        参数
        formatter -的实例DateTimeFormatter将被用于由toString（）方法格式化。 如果为null，则将使用默认格式化程序。
        parser -的实例DateTimeFormatter其将用于由所述fromString（）方法解析。 这可以与格式化程序相同。 如果为空，则将使用格式化程序，如果也为空，则将使用默认解析器。

    • 方法详细信息

      • fromString

        public LocalTime fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<LocalTime>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(LocalTime value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<LocalTime>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class LongStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Long>
      • javafx.util.converter.LongStringConverter

  • public class LongStringConverter
extends StringConverter<Long>

    StringConverter实现Long （和长基元）值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      LongStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Long fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(Long value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LongStringConverter

        public LongStringConverter​()

    • 方法详细信息

      • fromString

        public Long fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Long>
        参数
        value - String转换
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Long value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Long>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NumberStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class NumberStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Number>
      • javafx.util.converter.NumberStringConverter
  • 已知直接子类：
    CurrencyStringConverter ， PercentageStringConverter

    public class NumberStringConverter
extends StringConverter<Number>

    StringConverter实现Number值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      NumberStringConverter​()
      NumberStringConverter​(String pattern)
      NumberStringConverter​(NumberFormat numberFormat)
      NumberStringConverter​(Locale locale)
      NumberStringConverter​(Locale locale, String pattern)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Number fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      protected NumberFormat getNumberFormat​()
      返回一个NumberFormat实例，用于格式化和解析StringConverter 。
      String toString​(Number value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NumberStringConverter

        public NumberStringConverter​()

      • NumberStringConverter

        public NumberStringConverter​(Locale locale)

      • NumberStringConverter

        public NumberStringConverter​(String pattern)

      • NumberStringConverter

        public NumberStringConverter​(Locale locale,
                             String pattern)

      • NumberStringConverter

        public NumberStringConverter​(NumberFormat numberFormat)

    • 方法详细信息

      • fromString

        public Number fromString​(String value)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Number>
        参数
        value - 要转换的 String
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Number value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Number>
        参数
        value - 要转换的对象 T
        结果
        传入的对象的字符串表示形式。

      • getNumberFormat

        protected NumberFormat getNumberFormat​()

        返回一个NumberFormat实例，用于格式化和解析StringConverter 。

        结果
        一个用于格式化和解析的NumberFormat实例，在这StringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PercentageStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class PercentageStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Number>
      • javafx.util.converter.NumberStringConverter
        • javafx.util.converter.PercentageStringConverter

  • public class PercentageStringConverter
extends NumberStringConverter

    StringConverter实施Number个值代表百分比。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    CurrencyStringConverter ， NumberStringConverter ， StringConverter

    • 构造方法摘要

      构造方法
      Constructor 描述
      PercentageStringConverter​()
      PercentageStringConverter​(NumberFormat numberFormat)
      PercentageStringConverter​(Locale locale)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      NumberFormat getNumberFormat​()
      返回一个NumberFormat实例，用于格式化和解析StringConverter 。

      • Methods inherited from class javafx.util.converter.NumberStringConverter

        fromString, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PercentageStringConverter

        public PercentageStringConverter​()

      • PercentageStringConverter

        public PercentageStringConverter​(Locale locale)

      • PercentageStringConverter

        public PercentageStringConverter​(NumberFormat numberFormat)

    • 方法详细信息

      • getNumberFormat

        public NumberFormat getNumberFormat​()

        返回一个NumberFormat实例，用于格式化和解析StringConverter 。

        重写：
        getNumberFormat在 NumberStringConverter
        结果
        a NumberFormat instance for formatting and parsing in this StringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ShortStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class ShortStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Short>
      • javafx.util.converter.ShortStringConverter

  • public class ShortStringConverter
extends StringConverter<Short>

    StringConverter实现Short值。

    从以下版本开始：
    JavaFX 2.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      ShortStringConverter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Short fromString​(String text)
      将提供的字符串转换为由特定转换器定义的对象。
      String toString​(Short value)
      将提供的对象转换为其字符串形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ShortStringConverter

        public ShortStringConverter​()

    • 方法详细信息

      • fromString

        public Short fromString​(String text)
        将提供的字符串转换为由特定转换器定义的对象。 字符串的格式和结果对象的类型由特定的转换器定义。
        Specified by:
        fromString在 StringConverter<Short>
        参数
        text - String转换
        结果
        传入的字符串的对象表示。

      • toString

        public String toString​(Short value)
        将提供的对象转换为其字符串形式。 返回的字符串的格式由特定的转换器定义。
        Specified by:
        toString在 StringConverter<Short>
        参数
        value - 要转换的类型为 T的对象
        结果
        传入的对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TimeStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module javafx.base
软件包 javafx.util.converter

Class TimeStringConverter

  • java.lang.Object
    • javafx.util.StringConverter<Date>
      • javafx.util.converter.DateTimeStringConverter
        • javafx.util.converter.TimeStringConverter

  • public class TimeStringConverter
extends DateTimeStringConverter

    StringConverter代表时间的Date值的实现。

    从以下版本开始：
    JavaFX 2.1
    另请参见：
    DateStringConverter ， DateTimeStringConverter

    • Field Summary

      • Fields inherited from class javafx.util.converter.DateTimeStringConverter

        dateFormat, dateStyle, locale, pattern, timeStyle

    • 构造方法摘要

      构造方法
      Constructor 描述
      TimeStringConverter​()
      使用DateFormat.DEFAULT时间风格创建StringConverter的Date值。
      TimeStringConverter​(int timeStyle)
      创建StringConverter为Date值，使用指定DateFormat时间样式。
      TimeStringConverter​(String pattern)
      使用指定的模式为Date创建一个StringConverter值。
      TimeStringConverter​(DateFormat dateFormat)
      使用DateFormat格式化程序为Date创建一个StringConverter值。
      TimeStringConverter​(Locale locale)
      使用指定的区域设置和DateFormat.DEFAULT时间风格为Date值创建StringConverter 。
      TimeStringConverter​(Locale locale, int timeStyle)
      创建StringConverter的Date值，使用指定的区域设置和DateFormat时间风格。
      TimeStringConverter​(Locale locale, String pattern)
      使用指定的区域设置和模式为Date创建一个StringConverter值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected DateFormat getDateFormat​()
      返回一个DateFormat实例，用于格式化和解析StringConverter 。

      • Methods inherited from class javafx.util.converter.DateTimeStringConverter

        fromString, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TimeStringConverter

        public TimeStringConverter​()
        使用DateFormat.DEFAULT时间风格创建StringConverter的Date值。

      • TimeStringConverter

        public TimeStringConverter​(int timeStyle)
        创建StringConverter的Date值，使用指定的DateFormat时间风格。
        参数
        timeStyle - 给定的格式化样式。 例如，美国地区的“h：mm a”为DateFormat.SHORT 。
        从以下版本开始：
        JavaFX 8u40

      • TimeStringConverter

        public TimeStringConverter​(Locale locale)
        使用指定的区域设置和DateFormat.DEFAULT时间风格创建StringConverter的Date值。
        参数
        locale - 给定的区域设置。

      • TimeStringConverter

        public TimeStringConverter​(Locale locale,
                           int timeStyle)
        创建StringConverter的Date值，使用指定的区域设置和DateFormat时间风格。
        参数
        locale - 给定的区域设置。
        timeStyle - 给定的格式化样式。 例如，美国地区的“h：mm a”为DateFormat.SHORT 。
        从以下版本开始：
        JavaFX 8u40

      • TimeStringConverter

        public TimeStringConverter​(String pattern)
        创建StringConverter为Date值，使用指定的模式。
        参数
        pattern - 描述时间格式的模式。

      • TimeStringConverter

        public TimeStringConverter​(Locale locale,
                           String pattern)
        创建StringConverter为Date值，使用指定的语言环境和模式。
        参数
        locale - 给定的语言环境。
        pattern - 描述时间格式的模式。

      • TimeStringConverter

        public TimeStringConverter​(DateFormat dateFormat)
        为Date创建一个StringConverter值，使用指定的DateFormat格式化程序。
        参数
        dateFormat - 要用于格式化和解析的DateFormat 。

    • 方法详细信息

      • getDateFormat

        protected DateFormat getDateFormat​()

        返回一个DateFormat实例，用于格式化和解析StringConverter 。

        重写：
        getDateFormat在 DateTimeStringConverter
        结果
        a DateFormat instance for formatting and parsing in this StringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javafx.util.converter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javafx.util.converter

  • Packages that use javafx.util.converter
    软件包 描述
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
  • Classes in javafx.util.converter used by javafx.util.converter
    Class 描述
    DateTimeStringConverter
    StringConverter代表日期和时间的Date值的实现。
    NumberStringConverter
    StringConverter实现Number值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.BigDecimalStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.BigDecimalStringConverter

No usage of javafx.util.converter.BigDecimalStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.BigIntegerStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.BigIntegerStringConverter

No usage of javafx.util.converter.BigIntegerStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.BooleanStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.BooleanStringConverter

No usage of javafx.util.converter.BooleanStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.ByteStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.ByteStringConverter

No usage of javafx.util.converter.ByteStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.CharacterStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.CharacterStringConverter

No usage of javafx.util.converter.CharacterStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.CurrencyStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.CurrencyStringConverter

No usage of javafx.util.converter.CurrencyStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.DateStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.DateStringConverter

No usage of javafx.util.converter.DateStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.DateTimeStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.DateTimeStringConverter

  • Packages that use DateTimeStringConverter
    软件包 描述
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of DateTimeStringConverter in javafx.util.converter

      Subclasses of DateTimeStringConverter in javafx.util.converter
      Modifier and Type Class 描述
      class  DateStringConverter
      StringConverter实现Date值。
      class  TimeStringConverter
      StringConverter实现代表时间的Date值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.DefaultStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.DefaultStringConverter

No usage of javafx.util.converter.DefaultStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.DoubleStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.DoubleStringConverter

No usage of javafx.util.converter.DoubleStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.FloatStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.FloatStringConverter

No usage of javafx.util.converter.FloatStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.FormatStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.FormatStringConverter

No usage of javafx.util.converter.FormatStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.IntegerStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.IntegerStringConverter

No usage of javafx.util.converter.IntegerStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.LocalDateStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.LocalDateStringConverter

No usage of javafx.util.converter.LocalDateStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.LocalDateTimeStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.LocalDateTimeStringConverter

No usage of javafx.util.converter.LocalDateTimeStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.LocalTimeStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.LocalTimeStringConverter

No usage of javafx.util.converter.LocalTimeStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.LongStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.LongStringConverter

No usage of javafx.util.converter.LongStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.NumberStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.NumberStringConverter

  • Packages that use NumberStringConverter
    软件包 描述
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。

    • Uses of NumberStringConverter in javafx.util.converter

      Subclasses of NumberStringConverter in javafx.util.converter
      Modifier and Type Class 描述
      class  CurrencyStringConverter
      StringConverter代表货币的Number值的实现。
      class  PercentageStringConverter
      StringConverter表示百分比的值的Number值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.PercentageStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.PercentageStringConverter

No usage of javafx.util.converter.PercentageStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.ShortStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.ShortStringConverter

No usage of javafx.util.converter.ShortStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javafx.util.converter.TimeStringConverter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javafx.util.converter.TimeStringConverter

No usage of javafx.util.converter.TimeStringConverter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AccessibilityProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibilityProvider

  • java.lang.Object
    • javax.accessibility.AccessibilityProvider

  • public abstract class AccessibilityProvider
extends Object
    用于辅助技术的服务提供商接口（SPI）。

    此服务提供程序类提供从平台特定的可访问性API到Java Accessibility API的映射。

    每个服务提供商实现都被命名，可以通过activate()方法激活。 当初始化默认的toolkit时，可以加载服务提供商。

    API Note:
    每个平台通常会有一个提供程序，例如Windows或Linux，以支持屏幕阅读器和放大镜的可访问性。 但是，可以激活多个服务提供商。 例如，可以通过激活支持屏幕阅读器和屏幕放大器来激活提供通过询问Java可访问性API获得的视觉结果的测试工具。
    从以下版本开始：
    9
    另请参见：
    Toolkit.getDefaultToolkit() ， ServiceLoader

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AccessibilityProvider​()
      初始化新的辅助功能提供程序。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract void activate​()
      激活此服务提供商提供的支持。
      abstract String getName​()
      返回此服务提供商的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibilityProvider

        protected AccessibilityProvider​()
        初始化新的辅助功能提供程序。
        异常
        SecurityException - 如果安全管理器已安装并且它已拒绝RuntimePermission "accessibilityProvider"

    • 方法详细信息

      • getName

        public abstract String getName​()
        返回此服务提供商的名称。 该名称用于查找所请求的服务提供商。
        结果
        该服务提供商的名称

      • activate

        public abstract void activate​()
        激活此服务提供商提供的支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Accessible (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface Accessible

  • 所有已知实现类：
    AbstractColorChooserPanel ， Applet ， BasicArrowButton ， BasicComboBoxRenderer ， BasicComboBoxRenderer.UIResource ， BasicComboPopup ， BasicInternalFrameTitlePane.SystemMenuBar ， BasicToolBarUI.DragWindow ， Box ， Box.Filler ， Button ， Canvas ， CellRendererPane ， Checkbox ， CheckboxMenuItem ， Choice ， DefaultListCellRenderer ， DefaultListCellRenderer.UIResource ， DefaultTableCellRenderer ， DefaultTableCellRenderer.UIResource ， DefaultTreeCellEditor.DefaultTextField ， DefaultTreeCellRenderer ， Dialog ， FileDialog ， Frame ， HTMLEditorKit ， ImageIcon ， JApplet ， JButton ， JCheckBox ， JCheckBoxMenuItem ， JColorChooser ， JComboBox ， JDesktopPane ， JDialog ， JEditorPane ， JFileChooser ， JFormattedTextField ， JFrame ， JInternalFrame ， JInternalFrame.JDesktopIcon ， JLabel ， JLayer ， JLayeredPane ， JList ， JList.AccessibleJList.AccessibleJListChild ， JMenu ， JMenuBar ， JMenuItem ， JOptionPane ， JPanel ， JPasswordField ， JPopupMenu ， JPopupMenu.Separator ， JProgressBar ， JRadioButton JRadioButton ， JRadioButtonMenuItem ， JRootPane ， JScrollBar ， JScrollPane ， JScrollPane.ScrollBar ， JSeparator ， JSlider ， JSpinner ， JSpinner.DateEditor ， JSpinner.DefaultEditor ， JSpinner.ListEditor ， JSpinner.NumberEditor ， JSplitPane ， JTabbedPane ， JTable ， JTable.AccessibleJTable.AccessibleJTableCell ， JTableHeader ， JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry ， JTextArea ， JTextComponent ， JTextField ， JTextPane ， JToggleButton ， JToolBar ， JToolBar.Separator ， JToolTip ， JTree ， JTree.AccessibleJTree.AccessibleJTreeNode ， JViewport ， JWindow ， Label ， List ， List.AccessibleAWTList.AccessibleAWTListChild ， Menu ， MenuBar ， MenuItem ， MetalComboBoxButton ， MetalComboBoxUI.MetalComboPopup ， MetalFileChooserUI.FileRenderer ， MetalFileChooserUI.FilterComboBoxRenderer ， MetalScrollButton ， Panel ， PopupMenu ， ProgressMonitor ， Scrollbar ， ScrollPane ， TextArea ， TextComponent ， TextField ， Translator ， Window

    public interface Accessible
    接口Accessible是可访问性包的主要界面。 支持可访问性包的所有组件都必须实现此接口。 它包含一个单一的方法， getAccessibleContext() ，它返回AccessibleContext类的一个实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AccessibleContext getAccessibleContext​()
      返回与此对象关联的 AccessibleContext 。

    • 方法详细信息

      • getAccessibleContext

        AccessibleContext getAccessibleContext​()
        返回与此对象关联的AccessibleContext 。 在大多数情况下，返回值不应该是null如果对象实现了接口Accessible 。 如果组件开发人员创建一个实现Accessible的对象的子类，并且该子类不是Accessible ，则开发人员应该覆盖getAccessibleContext方法以返回null 。
        结果
        与此对象关联的 AccessibleContext
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleAction

  • 所有已知实现类：
    AbstractButton.AccessibleAbstractButton ， AccessibleHyperlink ， Button.AccessibleAWTButton ， Checkbox.AccessibleAWTCheckbox ， CheckboxMenuItem.AccessibleAWTCheckboxMenuItem ， Choice.AccessibleAWTChoice ， JButton.AccessibleJButton ， JCheckBox.AccessibleJCheckBox ， JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem ， JComboBox.AccessibleJComboBox ， JEditorPane.AccessibleJEditorPane ， JEditorPane.AccessibleJEditorPaneHTML ， JEditorPane.JEditorPaneAccessibleHypertextSupport ， JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink ， JList.AccessibleJList.AccessibleJListChild ， JMenu.AccessibleJMenu ， JMenuItem.AccessibleJMenuItem ， JPasswordField.AccessibleJPasswordField ， JRadioButton.AccessibleJRadioButton ， JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem ， JSpinner.AccessibleJSpinner ， JTextArea.AccessibleJTextArea ， JTextComponent.AccessibleJTextComponent ， JTextField.AccessibleJTextField ， JToggleButton.AccessibleJToggleButton ， JTree.AccessibleJTree.AccessibleJTreeNode ， Menu.AccessibleAWTMenu ， MenuItem.AccessibleAWTMenuItem ， PopupMenu.AccessibleAWTPopupMenu

    public interface AccessibleAction
    任何可以执行一个或多个操作的对象都应该支持AccessibleAction接口。 该界面提供了辅助技术的标准机制，以确定哪些操作以及告诉对象执行它们。 任何可以被操纵的对象都应该支持这个接口。 应用程序可以首先获得AccessibleContext （见Accessible ），然后调用AccessibleContext.getAccessibleAction()方法来确定对象是否支持AccessibleAction接口。 如果返回值不是null ，则该对象支持该接口。
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleContext.getAccessibleAction()

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String CLICK
      使组件执行其默认操作的操作。
      static String DECREMENT
      减少值的动作。
      static String INCREMENT
      增加值的动作。
      static String TOGGLE_EXPAND
      如果展开并导致树状节点折叠的动作，如果已折叠则展开。
      static String TOGGLE_POPUP
      一个弹出窗口在隐藏并隐藏（如果可见）时变得可见的操作。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean doAccessibleAction​(int i)
      对对象执行指定的操作。
      int getAccessibleActionCount​()
      返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。
      String getAccessibleActionDescription​(int i)
      返回对象的指定操作的描述。

    • 字段详细信息

      • TOGGLE_EXPAND

        static final String TOGGLE_EXPAND
        如果展开并导致树状节点折叠的动作，如果已折叠则展开。
        从以下版本开始：
        1.5

      • INCREMENT

        static final String INCREMENT
        增加值的动作。
        从以下版本开始：
        1.5

      • DECREMENT

        static final String DECREMENT
        减少值的动作。
        从以下版本开始：
        1.5

      • CLICK

        static final String CLICK
        使组件执行其默认操作的操作。
        从以下版本开始：
        1.6

      • TOGGLE_POPUP

        static final String TOGGLE_POPUP
        一个弹出窗口在隐藏并隐藏（如果可见）时变得可见的操作。
        从以下版本开始：
        1.6

    • 方法详细信息

      • getAccessibleActionCount

        int getAccessibleActionCount​()
        返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。
        结果
        该对象中基于零的操作数

      • getAccessibleActionDescription

        String getAccessibleActionDescription​(int i)
        返回对象的指定操作的描述。
        参数
        i - 零操作的索引
        结果
        一个 String描述的动作
        另请参见：
        getAccessibleActionCount()

      • doAccessibleAction

        boolean doAccessibleAction​(int i)
        对对象执行指定的操作。
        参数
        i - 从零开始的行动指数
        结果
        true如果执行了动作; 否则false
        另请参见：
        getAccessibleActionCount()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleAttributeSequence (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleAttributeSequence

  • java.lang.Object
    • javax.accessibility.AccessibleAttributeSequence

  • public class AccessibleAttributeSequence
extends Object
    该类将共享相同连续属性集的文本的跨度以及该组属性一起收集。 它由AccessibleContext类的实现者使用，以生成ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED事件。
    另请参见：
    AccessibleContext ， AccessibleContext.ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED

    • Field Summary

      Fields
      Modifier and Type Field 描述
      AttributeSet attributes
      文本属性。
      int endIndex
      文本序列的结束索引。
      int startIndex
      文本序列的起始索引。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleAttributeSequence​(int start, int end, AttributeSet attr)
      构造具有给定参数的 AccessibleAttributeSequence 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • startIndex

        public int startIndex
        文本序列的起始索引。

      • endIndex

        public int endIndex
        文本序列的结束索引。

      • attributes

        public AttributeSet attributes
        文本属性。

    • 构造方法详细信息

      • AccessibleAttributeSequence

        public AccessibleAttributeSequence​(int start,
                                   int end,
                                   AttributeSet attr)
        构造具有给定参数的 AccessibleAttributeSequence 。
        参数
        start - 文本跨度的起始索引
        end - 文本跨度的结束索引
        attr - AttributeSet本跨度共享的 AttributeSet
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleBundle

  • java.lang.Object
    • javax.accessibility.AccessibleBundle
  • 已知直接子类：
    AccessibleRelation ， AccessibleRole ， AccessibleState

    public abstract class AccessibleBundle
extends Object
    用于维护强类型枚举的基类。 这是AccessibleState和AccessibleRole的超类。

    toDisplayString()方法允许您从ResourceBundle中定义的键从预定义的ResourceBundle获取与区域设置无关的键的本地化字符串。 这个本地化的字符串旨在被人类所读取。

    另请参见：
    AccessibleRole ， AccessibleState

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected String key
      州的独立名称。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleBundle​()
      构造一个 AccessibleBundle 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toDisplayString​()
      使用默认语言环境获取描述密钥的本地化字符串。
      protected String toDisplayString​(String resourceBundleName, Locale locale)
      获取密钥作为本地化字符串。
      String toDisplayString​(Locale locale)
      获取密钥作为本地化字符串。
      String toString​()
      使用默认语言环境获取描述密钥的本地化字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • key

        protected String key
        州的独立名称。 这是一个程序名称，不是人类阅读的。
        另请参见：
        toDisplayString(java.lang.String, java.util.Locale)

    • 构造方法详细信息

      • AccessibleBundle

        public AccessibleBundle​()
        构造一个 AccessibleBundle 。

    • 方法详细信息

      • toDisplayString

        protected String toDisplayString​(String resourceBundleName,
                                 Locale locale)
        获取密钥作为本地化字符串。 如果找不到密钥的本地化字符串，将返回存储在角色中的区域设置独立密钥。 此方法仅用于子类，以便它们可以指定其自己的资源束，其中包含其密钥的本地化字符串。
        参数
        resourceBundleName - 要用于查找的资源包的名称
        locale - 要获取本地化字符串的语言环境
        结果
        键的本地化字符串

      • toDisplayString

        public String toDisplayString​(Locale locale)
        获取密钥作为本地化字符串。 如果找不到密钥的本地化字符串，将返回存储在角色中的区域设置独立密钥。
        参数
        locale - 要获取本地化字符串的语言环境
        结果
        键的本地化字符串

      • toDisplayString

        public String toDisplayString​()
        使用默认语言环境获取描述密钥的本地化字符串。
        结果
        使用默认语言环境描述密钥的本地化字符串

      • toString

        public String toString​()
        使用默认语言环境获取描述密钥的本地化字符串。
        重写：
        toString在 Object
        结果
        使用默认语言环境描述密钥的本地化字符串
        另请参见：
        toDisplayString(java.lang.String, java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleComponent

  • All Known Subinterfaces:
    AccessibleExtendedComponent
    所有已知实现类：
    AbstractButton.AccessibleAbstractButton ， Applet.AccessibleApplet ， Box.AccessibleBox ， Box.Filler.AccessibleBoxFiller ， Button.AccessibleAWTButton ， Canvas.AccessibleAWTCanvas ， CellRendererPane.AccessibleCellRendererPane ， Checkbox.AccessibleAWTCheckbox ， CheckboxMenuItem.AccessibleAWTCheckboxMenuItem ， Choice.AccessibleAWTChoice ， Component.AccessibleAWTComponent ， Container.AccessibleAWTContainer ， Dialog.AccessibleAWTDialog ， Frame.AccessibleAWTFrame ， JApplet.AccessibleJApplet ， JButton.AccessibleJButton ， JCheckBox.AccessibleJCheckBox ， JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem ， JColorChooser.AccessibleJColorChooser ， JComboBox.AccessibleJComboBox ， JComponent.AccessibleJComponent ， JDesktopPane.AccessibleJDesktopPane ， JDialog.AccessibleJDialog ， JEditorPane.AccessibleJEditorPane ， JEditorPane.AccessibleJEditorPaneHTML ， JEditorPane.JEditorPaneAccessibleHypertextSupport ， JFileChooser.AccessibleJFileChooser ， JFrame.AccessibleJFrame ， JInternalFrame.AccessibleJInternalFrame ， JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon ， JLabel.AccessibleJLabel ， JLayeredPane.AccessibleJLayeredPane ， JList.AccessibleJList ， JList.AccessibleJList.AccessibleJListChild ， JMenu.AccessibleJMenu ， JMenuBar.AccessibleJMenuBar ， JMenuItem.AccessibleJMenuItem ， JOptionPane.AccessibleJOptionPane ， JPanel.AccessibleJPanel ， JPasswordField.AccessibleJPasswordField ， JPopupMenu.AccessibleJPopupMenu ， JProgressBar.AccessibleJProgressBar ， JRadioButton.AccessibleJRadioButton ， JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem ， JRootPane.AccessibleJRootPane ， JScrollBar.AccessibleJScrollBar ， JScrollPane.AccessibleJScrollPane ， JSeparator.AccessibleJSeparator ， JSlider.AccessibleJSlider ， JSpinner.AccessibleJSpinner ， JSplitPane.AccessibleJSplitPane ， JTabbedPane.AccessibleJTabbedPane ， JTable.AccessibleJTable ， JTable.AccessibleJTable.AccessibleJTableCell ， JTableHeader.AccessibleJTableHeader ， JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry ， JTextArea.AccessibleJTextArea ， JTextComponent.AccessibleJTextComponent ， JTextField.AccessibleJTextField ， JToggleButton.AccessibleJToggleButton ， JToolBar.AccessibleJToolBar ， JToolTip.AccessibleJToolTip ， JTree.AccessibleJTree ， JTree.AccessibleJTree.AccessibleJTreeNode ， JViewport.AccessibleJViewport ， JWindow.AccessibleJWindow ， Label.AccessibleAWTLabel ， List.AccessibleAWTList ， List.AccessibleAWTList.AccessibleAWTListChild ， Menu.AccessibleAWTMenu ， MenuBar.AccessibleAWTMenuBar ， MenuComponent.AccessibleAWTMenuComponent ， MenuItem.AccessibleAWTMenuItem ， Panel.AccessibleAWTPanel ， PopupMenu.AccessibleAWTPopupMenu ， Scrollbar.AccessibleAWTScrollBar ， ScrollPane.AccessibleAWTScrollPane ， TextArea.AccessibleAWTTextArea ， TextComponent.AccessibleAWTTextComponent ， TextField.AccessibleAWTTextField ， Translator ， Window.AccessibleAWTWindow

    public interface AccessibleComponent
    应该在屏幕上呈现的任何对象支持AccessibleComponent界面。 该界面提供了辅助技术的标准机制来确定和设置对象的图形表示。 应用程序可以通过首先获得其AccessibleContext然后调用AccessibleContext.getAccessibleComponent()方法来确定对象是否支持AccessibleComponent接口。 如果返回值不是null ，则该对象支持该接口。
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleContext.getAccessibleComponent()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addFocusListener​(FocusListener l)
      新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
      boolean contains​(Point p)
      检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
      Accessible getAccessibleAt​(Point p)
      返回 Accessible小孩，如果存在，则包含在本地坐标 Point 。
      Color getBackground​()
      获取此对象的背景颜色。
      Rectangle getBounds​()
      以 Rectangle对象的形式获取此对象的边界。
      Cursor getCursor​()
      获取此对象的光标。
      Font getFont​()
      获取此对象的字体。
      FontMetrics getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      Color getForeground​()
      获取此对象的前景色。
      Point getLocation​()
      以指定对象的左上角的点的形式获取对象相对于父对象的位置。
      Point getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Dimension getSize​()
      以 Dimension对象的形式返回此对象的大小。
      boolean isEnabled​()
      确定对象是否已启用。
      boolean isFocusTraversable​()
      返回此对象是否可以接受焦点。
      boolean isShowing​()
      确定对象是否正在显示。
      boolean isVisible​()
      确定对象是否可见。
      void removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
      void requestFocus​()
      请求关注此对象。
      void setBackground​(Color c)
      设置此对象的背景颜色。
      void setBounds​(Rectangle r)
      以 Rectangle对象的形式设置此对象的边界。
      void setCursor​(Cursor cursor)
      设置此对象的光标。
      void setEnabled​(boolean b)
      设置对象的已启用状态。
      void setFont​(Font f)
      设置此对象的字体。
      void setForeground​(Color c)
      设置此对象的前景色。
      void setLocation​(Point p)
      设置对象相对于父对象的位置。
      void setSize​(Dimension d)
      调整此对象的大小，使其具有宽度和高度。
      void setVisible​(boolean b)
      设置对象的可见状态。

    • 方法详细信息

      • getBackground

        Color getBackground​()
        获取此对象的背景颜色。
        结果
        对象的背景颜色（如果支持）; 否则， null
        另请参见：
        setBackground(java.awt.Color)

      • setBackground

        void setBackground​(Color c)
        设置此对象的背景颜色。
        参数
        c - 背景的新颜色
        另请参见：
        setBackground(java.awt.Color)

      • getForeground

        Color getForeground​()
        获取此对象的前景色。
        结果
        对象的前景颜色（如果支持）; 否则， null
        另请参见：
        setForeground(java.awt.Color)

      • setForeground

        void setForeground​(Color c)
        设置此对象的前景色。
        参数
        c - 前景的新颜色
        另请参见：
        getForeground()

      • getCursor

        Cursor getCursor​()
        获取此对象的光标。
        结果
        对象的光标（如果支持）; 否则， null
        另请参见：
        setCursor(java.awt.Cursor)

      • setCursor

        void setCursor​(Cursor cursor)
        设置此对象的光标。
        参数
        cursor - 对象的新光标
        另请参见：
        getCursor()

      • getFont

        Font getFont​()
        获取此对象的字体。
        结果
        该对象的字体，如果支持; 否则， null
        另请参见：
        setFont(java.awt.Font)

      • setFont

        void setFont​(Font f)
        设置此对象的字体。
        参数
        f - 对象的新字体
        另请参见：
        getFont()

      • getFontMetrics

        FontMetrics getFontMetrics​(Font f)
        获取此对象的 FontMetrics 。
        参数
        f - 要获取字体指标的字体
        结果
        FontMetrics ，如果支持，则该对象; 否则， null
        另请参见：
        getFont()

      • isEnabled

        boolean isEnabled​()
        确定对象是否已启用。 启用的对象也将在其AccessibleStateSets设置AccessibleState.ENABLED状态。
        结果
        如果对象启用， true ; 否则， false
        另请参见：
        setEnabled(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.ENABLED ， AccessibleStateSet

      • setEnabled

        void setEnabled​(boolean b)
        设置对象的已启用状态。
        参数
        b - 如果是true ，启用此对象; 否则，禁用它
        另请参见：
        isEnabled()

      • isVisible

        boolean isVisible​()
        确定对象是否可见。 注意：这意味着该对象意图可见; 然而，它可能不会显示在屏幕上，因为该对象包含的对象之一当前不可见。 要确定对象是否在屏幕上显示，请使用isShowing()

        可见的对象也将在其AccessibleStateSets设置AccessibleState.VISIBLE状态。

        结果
        true如果对象可见; 否则， false
        另请参见：
        setVisible(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.VISIBLE ， AccessibleStateSet

      • setVisible

        void setVisible​(boolean b)
        设置对象的可见状态。
        参数
        b - 如果是true ，则显示此对象; 否则隐藏它
        另请参见：
        isVisible()

      • isShowing

        boolean isShowing​()
        确定对象是否正在显示。 这是通过检查对象及其祖先的可见性来确定的。 注意：即使对象被另一个遮挡（例如，它被拉下的菜单下方），这将返回true 。
        结果
        true如果对象显示; 否则， false

      • contains

        boolean contains​(Point p)
        检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
        参数
        p - 相对于对象坐标系的点
        结果
        true如果对象包含点; 否则false
        另请参见：
        getBounds()

      • getLocationOnScreen

        Point getLocationOnScreen​()
        返回对象在屏幕上的位置。
        结果
        屏幕上物体的位置; null如果此对象不在屏幕上
        另请参见：
        getBounds() ， getLocation()

      • getLocation

        Point getLocation​()
        以指定对象的左上角的点的形式获取对象相对于父对象的位置。
        结果
        Point一个实例，表示屏幕坐标空间中对象边界的左上角; null如果此对象或其父对象不在屏幕上
        另请参见：
        getBounds() ， getLocationOnScreen()

      • setLocation

        void setLocation​(Point p)
        设置对象相对于父对象的位置。
        参数
        p - 左上角的新位置
        另请参见：
        getLocation()

      • getBounds

        Rectangle getBounds​()
        以Rectangle对象的形式获取此对象的边界。 边界指定相对于其父对象的宽度，高度和位置。
        结果
        表示该组件边界的矩形; null如果此对象不在屏幕上。
        另请参见：
        contains(java.awt.Point)

      • setBounds

        void setBounds​(Rectangle r)
        以Rectangle对象的形式设置此对象的边界。 边界指定相对于其父对象的宽度，高度和位置。
        参数
        r - 表示此组件边界的矩形
        另请参见：
        getBounds()

      • getSize

        Dimension getSize​()
        以Dimension对象的形式返回此对象的大小。 Dimension对象的height字段包含此对象的高度，而Dimension对象的width字段包含此对象的宽度。
        结果
        一个Dimension对象，指示该组件的大小; null如果此对象不在屏幕上
        另请参见：
        setSize(java.awt.Dimension)

      • setSize

        void setSize​(Dimension d)
        调整此对象的大小，使其具有宽度和高度。
        参数
        d - 指定对象的新大小的维度
        另请参见：
        getSize()

      • getAccessibleAt

        Accessible getAccessibleAt​(Point p)
        返回 Accessible小孩，如果存在，则包含在本地坐标 Point 。
        参数
        p - 相对于该对象的坐标系的点
        结果
        Accessible ，如果存在，在指定的位置; 否则null

      • isFocusTraversable

        boolean isFocusTraversable​()
        返回此对象是否可以接受焦点。 可以接受焦点的对象也将在其AccessibleStateSets设置AccessibleState.FOCUSABLE状态。
        结果
        true如果对象可以接受焦点; 否则false
        另请参见：
        AccessibleContext.getAccessibleStateSet() ， AccessibleState.FOCUSABLE ， AccessibleState.FOCUSED ， AccessibleStateSet

      • requestFocus

        void requestFocus​()
        请求关注此对象。 如果此对象无法接受焦点，则不会发生任何事情。 否则，对象将尝试重点。
        另请参见：
        isFocusTraversable()

      • addFocusListener

        void addFocusListener​(FocusListener l)
        新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
        参数
        l - 焦点侦听器
        另请参见：
        removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        void removeFocusListener​(FocusListener l)
        删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
        参数
        l - 焦点侦听器
        另请参见：
        addFocusListener(java.awt.event.FocusListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleContext

  • java.lang.Object
    • javax.accessibility.AccessibleContext
  • 已知直接子类：
    Component.AccessibleAWTComponent ， ImageIcon.AccessibleImageIcon ， JList.AccessibleJList.AccessibleJListChild ， JTable.AccessibleJTable.AccessibleJTableCell ， JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry ， JTree.AccessibleJTree.AccessibleJTreeNode ， MenuComponent.AccessibleAWTMenuComponent ， ProgressMonitor.AccessibleProgressMonitor ， Translator

    @JavaBean(description="Minimal information that all accessible objects return")
public abstract class AccessibleContext
extends Object
    AccessibleContext表示所有可访问对象返回的最小信息。 该信息包括可访问的名称，描述，角色和对象的状态，以及有关其父和孩子的信息。 AccessibleContext还包含用于获取有关组件的更多特定辅助功能信息的方法。 如果组件支持它们，这些方法将返回一个实现一个或多个以下接口的对象：
    • AccessibleAction - 对象可以执行一个或多个操作。 该界面提供了辅助技术的标准机制，以确定哪些操作是什么，并告诉对象执行它们。 任何可以被操纵的对象都应该支持这个接口。
    • AccessibleComponent - 对象具有图形表示。 该界面提供了辅助技术的标准机制，以确定和设置对象的图形表示。 屏幕上呈现的任何对象都应该支持该界面。
    • AccessibleSelection - 该对象允许其子选项。 该界面提供辅助技术的标准机制，以确定对象当前选定的子项，并修改其选择集。 任何可以选择子项的对象都应该支持该接口。
    • AccessibleText - 对象在显示器上显示可编辑的文本信息。 该界面提供了辅助技术通过其内容，属性和空间位置访问该文本的标准机制。 任何包含可编辑文本的对象都应该支持该接口。
    • AccessibleValue - 对象支持数值。 该界面提供了辅助技术的标准机制，用于确定和设置对象的当前值，以及获取其最小值和最大值。 任何支持数值的对象都应该支持这个接口。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String ACCESSIBLE_ACTION_PROPERTY
      常数用于指示受支持的操作集已更改。
      static String ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY
      用于确定组件的活动后代何时已更改的常数。
      static String ACCESSIBLE_CARET_PROPERTY
      常数用于确定 accessibleText插入符号何时发生变化。
      static String ACCESSIBLE_CHILD_PROPERTY
      常数用于确定何时 Accessible子组件被添加/从对象中删除。
      static String ACCESSIBLE_COMPONENT_BOUNDS_CHANGED
      PropertyChangeEvent ，其指示组件边界中发生更改。
      static String ACCESSIBLE_DESCRIPTION_PROPERTY
      常数用于确定 accessibleDescription属性何时发生变化。
      static String ACCESSIBLE_HYPERTEXT_OFFSET
      用于指示超文本元素已经接收焦点的常数。
      static String ACCESSIBLE_INVALIDATE_CHILDREN
      PropertyChangeEvent ，这表明一个组件的孩子，如树或文本发生了重大变化。
      static String ACCESSIBLE_NAME_PROPERTY
      常数用于确定 accessibleName属性何时更改。
      static String ACCESSIBLE_SELECTION_PROPERTY
      常数用于确定 accessibleSelection发生变化。
      static String ACCESSIBLE_STATE_PROPERTY
      常数用于确定何时 accessibleStateSet属性已更改。
      static String ACCESSIBLE_TABLE_CAPTION_CHANGED
      常数用于表示表格已更改。
      static String ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED
      常数用于指示列描述已更改。
      static String ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED
      常量用于指示列标题已更改。
      static String ACCESSIBLE_TABLE_MODEL_CHANGED
      用于表示表数据已更改的常数。
      static String ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED
      常数用于指示行描述已更改。
      static String ACCESSIBLE_TABLE_ROW_HEADER_CHANGED
      用于指示行标题已更改的常量。
      static String ACCESSIBLE_TABLE_SUMMARY_CHANGED
      常数用于表示表格摘要已更改。
      static String ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED
      PropertyChangeEvent ，表示文本属性已更改。
      static String ACCESSIBLE_TEXT_PROPERTY
      PropertyChangeEvent ，表示文本已更改。
      static String ACCESSIBLE_VALUE_PROPERTY
      常数用于确定 accessibleValue属性何时发生变化。
      static String ACCESSIBLE_VISIBLE_DATA_PROPERTY
      用于确定对象的视觉外观何时改变的常数。
      protected String accessibleDescription
      包含对象描述的本地化字符串。
      protected String accessibleName
      包含对象名称的本地化字符串。
      protected Accessible accessibleParent
      该对象的可访问父级。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleContext​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addPropertyChangeListener​(PropertyChangeListener listener)
      添加一个 PropertyChangeListener到监听器列表。
      void firePropertyChange​(String propertyName, Object oldValue, Object newValue)
      支持报告绑定属性更改。
      AccessibleAction getAccessibleAction​()
      获取支持一个或多个操作的此对象关联的 AccessibleAction 。
      abstract Accessible getAccessibleChild​(int i)
      返回对象的指定的 Accessible子对象。
      abstract int getAccessibleChildrenCount​()
      返回对象的可访问子对象的数量。
      AccessibleComponent getAccessibleComponent​()
      获取与此对象关联的 AccessibleComponent具有图形表示。
      String getAccessibleDescription​()
      获取此对象的 accessibleDescription属性。
      AccessibleEditableText getAccessibleEditableText​()
      获取与该对象相关联的 AccessibleEditableText ，该对象在显示屏上显示可编辑文本。
      AccessibleIcon[] getAccessibleIcon​()
      获取与具有一个或多个关联图标的对象关联的 AccessibleIcons 。
      abstract int getAccessibleIndexInParent​()
      在其可访问的父项中获取此对象的基于0的索引。
      String getAccessibleName​()
      获取此对象的 accessibleName属性。
      Accessible getAccessibleParent​()
      获取此对象的 Accessible父项。
      AccessibleRelationSet getAccessibleRelationSet​()
      获取与对象关联的 AccessibleRelationSet 。
      abstract AccessibleRole getAccessibleRole​()
      获得此对象的作用。
      AccessibleSelection getAccessibleSelection​()
      获取与此对象关联的 AccessibleSelection ，允许选择其 Accessible孩子。
      abstract AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleTable getAccessibleTable​()
      获取与对象关联的 AccessibleTable 。
      AccessibleText getAccessibleText​()
      获取与此对象相关联的 AccessibleText在显示器上呈现文本。
      AccessibleValue getAccessibleValue​()
      获取与此对象关联的 AccessibleValue支持 Numerical值。
      abstract Locale getLocale​()
      获取组件的区域设置。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除 PropertyChangeListener 。
      void setAccessibleDescription​(String s)
      设置此对象的可访问描述。
      void setAccessibleName​(String s)
      设置此对象的本地化可访问名称。
      void setAccessibleParent​(Accessible a)
      设置此对象的 Accessible父对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ACCESSIBLE_NAME_PROPERTY

        public static final String ACCESSIBLE_NAME_PROPERTY
        常数用于确定accessibleName属性何时发生变化。 旧值在PropertyChangeEvent将是旧的accessibleName和新值将是新的accessibleName 。
        另请参见：
        getAccessibleName() ， addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • ACCESSIBLE_DESCRIPTION_PROPERTY

        public static final String ACCESSIBLE_DESCRIPTION_PROPERTY
        常数用于确定何时accessibleDescription属性已更改。 旧值在PropertyChangeEvent将是旧的accessibleDescription和新值将是新的accessibleDescription 。
        另请参见：
        getAccessibleDescription() ， addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • ACCESSIBLE_STATE_PROPERTY

        public static final String ACCESSIBLE_STATE_PROPERTY
        常数用于确定何时accessibleStateSet属性已更改。 旧值将为旧AccessibleState ，新值将在AccessibleState中新增accessibleStateSet 。 例如，如果支持垂直和水平状态的组件将其方向从垂直方向改变为水平，则旧值将为AccessibleState.VERTICAL ，新值将为AccessibleState.HORIZONTAL 。 请注意，这两个值也可以是null 。 例如，当组件从启用变为禁用时，旧值将为AccessibleState.ENABLED ，新值将为null 。
        另请参见：
        getAccessibleStateSet() ， AccessibleState ， AccessibleStateSet ， addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • ACCESSIBLE_VALUE_PROPERTY

        public static final String ACCESSIBLE_VALUE_PROPERTY
        常数用于确定accessibleValue属性何时更改。 在旧值PropertyChangeEvent将是一个Number表示旧值和新值将是一个Number表示新值。
        另请参见：
        getAccessibleValue() ， addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • ACCESSIBLE_SELECTION_PROPERTY

        public static final String ACCESSIBLE_SELECTION_PROPERTY
        常数用于确定accessibleSelection发生变化。 PropertyChangeEvent中的旧值和新值目前保留供将来使用。
        另请参见：
        getAccessibleSelection() ， addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • ACCESSIBLE_CARET_PROPERTY

        public static final String ACCESSIBLE_CARET_PROPERTY
        常数用于确定accessibleText插入符号何时发生变化。 PropertyChangeEvent的旧值将是表示旧插入位置的整数，新值将是表示新/当前插入符位置的整数。
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • ACCESSIBLE_VISIBLE_DATA_PROPERTY

        public static final String ACCESSIBLE_VISIBLE_DATA_PROPERTY
        用于确定对象的视觉外观何时改变的常数。 PropertyChangeEvent中的旧值和新值目前保留供将来使用。
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • ACCESSIBLE_CHILD_PROPERTY

        public static final String ACCESSIBLE_CHILD_PROPERTY
        常数用于确定何时从对象中添加/删除孩子Accessible 。 如果添加了一个Accessible小孩，旧值将为null ，新值将为Accessible 。 如果一个Accessible小孩被删除，旧值将是Accessible小孩，新值将为null 。
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY

        public static final String ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY
        用于确定组件的活动后代何时已更改的常数。 活动后代用于列表，树和表等对象，可能有暂时的子项。 当活动后代发生变化时，属性更改事件的旧值Accessible表示上一个活动子项的Accessible ，新值将为表示当前活动子项的Accessible 。
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • ACCESSIBLE_TABLE_CAPTION_CHANGED

        public static final String ACCESSIBLE_TABLE_CAPTION_CHANGED
        常数用于表示表格已更改。 PropertyChangeEvent的旧值将是Accessible表示前一个表格标题，新值将是一个Accessible表示新的表格标题。
        另请参见：
        Accessible ， AccessibleTable ， Constant Field Values

      • ACCESSIBLE_TABLE_SUMMARY_CHANGED

        public static final String ACCESSIBLE_TABLE_SUMMARY_CHANGED
        常数用于表示表格摘要已更改。 PropertyChangeEvent的旧值将为Accessible表示前一表格摘要，新值将为新表表摘要的Accessible 。
        另请参见：
        Accessible ， AccessibleTable ， Constant Field Values

      • ACCESSIBLE_TABLE_MODEL_CHANGED

        public static final String ACCESSIBLE_TABLE_MODEL_CHANGED
        用于表示表数据已更改的常数。 PropertyChangeEvent的旧值将为null ，新值为AccessibleTableModelChange表示表的变动。
        另请参见：
        AccessibleTable ， AccessibleTableModelChange ， Constant Field Values

      • ACCESSIBLE_TABLE_ROW_HEADER_CHANGED

        public static final String ACCESSIBLE_TABLE_ROW_HEADER_CHANGED
        用于指示行标题已更改的常量。 PropertyChangeEvent的旧值将为null ，新值为AccessibleTableModelChange表示标头更改。
        另请参见：
        AccessibleTable ， AccessibleTableModelChange ， Constant Field Values

      • ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED

        public static final String ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED
        常数用于指示行描述已更改。 PropertyChangeEvent的旧值将为null ，新值为Integer表示行索引。
        另请参见：
        AccessibleTable ， Constant Field Values

      • ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED

        public static final String ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED
        常量用于指示列标题已更改。 PropertyChangeEvent的旧值将为null ，新值将为AccessibleTableModelChange表示标头更改。
        另请参见：
        AccessibleTable ， AccessibleTableModelChange ， Constant Field Values

      • ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED

        public static final String ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED
        常数用于指示列描述已更改。 PropertyChangeEvent的旧值将为null ，新值将为Integer表示列索引。
        另请参见：
        AccessibleTable ， Constant Field Values

      • ACCESSIBLE_ACTION_PROPERTY

        public static final String ACCESSIBLE_ACTION_PROPERTY
        常数用于指示受支持的操作集已更改。 PropertyChangeEvent的旧值将是Integer代表支持的旧数量的操作，新值将为Integer表示支持的新操作数。
        另请参见：
        AccessibleAction ， Constant Field Values

      • ACCESSIBLE_HYPERTEXT_OFFSET

        public static final String ACCESSIBLE_HYPERTEXT_OFFSET
        用于指示超文本元素已经接收焦点的常数。 PropertyChangeEvent的旧值将是Integer表示上一个具有焦点的元素的文档中的起始索引，新值将是Integer表示当前具有焦点的元素的文档中的起始索引。 值-1表示元素没有或没有焦点。
        另请参见：
        AccessibleHyperlink ， Constant Field Values

      • ACCESSIBLE_TEXT_PROPERTY

        public static final String ACCESSIBLE_TEXT_PROPERTY
        PropertyChangeEvent这表明文本已经改变。
        对于文本插入时， oldValue是null和newValue是AccessibleTextSequence指定插入的文本。
        对于文本删除， oldValue是一个AccessibleTextSequence指定被删除的文本， newValue是null 。
        对于文本替换， oldValue是一个AccessibleTextSequence指定旧文本，而newValue是一个指定新文本的AccessibleTextSequence 。
        另请参见：
        getAccessibleText() ， addPropertyChangeListener(java.beans.PropertyChangeListener) ， AccessibleTextSequence ， Constant Field Values

      • ACCESSIBLE_INVALIDATE_CHILDREN

        public static final String ACCESSIBLE_INVALIDATE_CHILDREN
        PropertyChangeEvent这表明组件像树或文本的孩子发生了重大变化。 此更改通知事件侦听器它需要重新获取子组件的状态。 oldValue是null ，而newValue是孩子成为无效的组件。
        从以下版本开始：
        1.5
        另请参见：
        getAccessibleText() ， addPropertyChangeListener(java.beans.PropertyChangeListener) ， AccessibleTextSequence ， Constant Field Values

      • ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED

        public static final String ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED
        PropertyChangeEvent ，表示文本属性已更改。
        对于属性插入时， oldValue是null和newValue是AccessibleAttributeSequence指定插入的属性。
        对于属性删除， oldValue是一个AccessibleAttributeSequence指定被删除的属性， newValue是null 。
        对于属性替换， oldValue是一个AccessibleAttributeSequence指定旧属性，而newValue是一个指定新属性的AccessibleAttributeSequence 。
        从以下版本开始：
        1.5
        另请参见：
        getAccessibleText() ， addPropertyChangeListener(java.beans.PropertyChangeListener) ， AccessibleAttributeSequence ， Constant Field Values

      • ACCESSIBLE_COMPONENT_BOUNDS_CHANGED

        public static final String ACCESSIBLE_COMPONENT_BOUNDS_CHANGED
        PropertyChangeEvent ，其指示组件边界中发生更改。 oldValue是旧的组件界限，而newValue是新的组件界限。
        从以下版本开始：
        1.5
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ， Constant Field Values

      • accessibleParent

        protected Accessible accessibleParent
        该对象的可访问父级。
        另请参见：
        getAccessibleParent() ， setAccessibleParent(javax.accessibility.Accessible)

      • accessibleName

        protected String accessibleName
        包含对象名称的本地化字符串。
        另请参见：
        getAccessibleName() ， setAccessibleName(java.lang.String)

      • accessibleDescription

        protected String accessibleDescription
        包含对象描述的本地化字符串。
        另请参见：
        getAccessibleDescription() ， setAccessibleDescription(java.lang.String)

    • 构造方法详细信息

      • AccessibleContext

        public AccessibleContext​()

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName​()
        获取此对象的accessibleName属性。 一个对象的accessibleName属性是一个本地化的String ，它指定对象的目的。 例如，标签或按钮的accessibleName属性可能是标签或按钮本身的文本。 在不显示其名称的对象的情况下， accessibleName仍应设置。 例如，在文本字段的情况下，用于输入城市名称， accessibleName为en_US的语言环境可以为“city”。
        结果
        对象的本地化名称; null如果此对象没有名称
        另请参见：
        setAccessibleName(java.lang.String)

      • setAccessibleName

        @BeanProperty(preferred=true,
              description="Sets the accessible name for the component.")
public void setAccessibleName​(String s)
        设置此对象的本地化可访问名称。 更改名称将导致PropertyChangeEvent为被解雇ACCESSIBLE_NAME_PROPERTY财产。
        参数
        s - 对象的新的本地化名称
        另请参见：
        getAccessibleName() ， addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleDescription

        public String getAccessibleDescription​()
        获取此对象的accessibleDescription属性。 该对象的accessibleDescription属性是描述对象目的的简短本地化短语。 例如，在“取消”按钮的情况下， accessibleDescription可以是“忽略更改并关闭对话框”。
        结果
        对象的本地化描述; null如果此对象没有描述
        另请参见：
        setAccessibleDescription(java.lang.String)

      • setAccessibleDescription

        @BeanProperty(preferred=true,
              description="Sets the accessible description for the component.")
public void setAccessibleDescription​(String s)
        设置此对象的可访问描述。 更改名称将导致PropertyChangeEvent为被解雇ACCESSIBLE_DESCRIPTION_PROPERTY财产。
        参数
        s - 对象的新的本地化描述
        另请参见：
        setAccessibleName(java.lang.String) ， addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleRole

        public abstract AccessibleRole getAccessibleRole​()
        获得此对象的作用。 该对象的作用是通用目的或使用该对象的类。 例如，按钮的作用是AccessibleRole.PUSH_BUTTON 。 提供了AccessibleRole中的角色，因此组件开发人员可以从一组预定义角色中进行选择。 这使得辅助技术能够为各种调整的组件子类提供一致的界面（例如，对于所有类似按钮的组件使用AccessibleRole.PUSH_BUTTON ），以及区分行为不同的子类（例如， AccessibleRole.CHECK_BOX为AccessibleRole.RADIO_BUTTON ，收音机为AccessibleRole.RADIO_BUTTON纽扣）。

        注意， AccessibleRole类也是可扩展的，所以定制组件开发人员可以定义自己的AccessibleRole ，如果一组预定义角色不足。

        结果
        描述对象角色的 AccessibleRole一个实例
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public abstract AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态集。 一个对象的AccessibleStateSet由一组唯一的AccessibleStates 。 在改变AccessibleStateSet对象将导致PropertyChangeEvent为被解雇ACCESSIBLE_STATE_PROPERTY财产。
        结果
        一个 AccessibleStateSet的实例包含对象的当前状态集
        另请参见：
        AccessibleStateSet ， AccessibleState ， addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleParent

        public Accessible getAccessibleParent​()
        获取此对象的 Accessible父项。
        结果
        该对象的父母Accessible ; null如果此对象没有Accessible父对象

      • setAccessibleParent

        public void setAccessibleParent​(Accessible a)
        设置此对象的Accessible父对象。 这意味着仅在实际组件的父级不应被视为组件的可访问父级的情况下使用，并且是只能由可访问子级的父级调用的方法。
        参数
        a - - Accessible要设置为父级

      • getAccessibleIndexInParent

        public abstract int getAccessibleIndexInParent​()
        在其可访问的父项中获取此对象的基于0的索引。
        结果
        该对象在其父项中的基于0的索引; -1如果此对象没有可访问的父对象。
        另请参见：
        getAccessibleParent() ，
getAccessibleChildrenCount() ，
getAccessibleChild(int)

      • getAccessibleChildrenCount

        public abstract int getAccessibleChildrenCount​()
        返回对象的可访问子对象的数量。
        结果
        对象的可访问子的数量。

      • getAccessibleChild

        public abstract Accessible getAccessibleChild​(int i)
        返回对象的指定的Accessible子对象。 Accessible对象的Accessible子项为零，因此Accessible小孩的第一个子项为索引0，第二个子项为索引1，依此类推。
        参数
        i - 基于零的儿童索引
        结果
        对象的 Accessible小孩
        另请参见：
        getAccessibleChildrenCount()

      • getLocale

        public abstract Locale getLocale​()
                          throws IllegalComponentStateException
        获取组件的区域设置。 如果组件没有区域设置，则返回其父项的区域设置。
        结果
        这个组件的区域设置。 如果此组件没有区域设置，则返回其父项的区域设置。
        异常
        IllegalComponentStateException - 如果组件没有自己的区域设置，并且尚未添加到包含层次结构中，以便可以从包含的父项确定区域设置

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener listener)
        添加一个PropertyChangeListener到监听器列表。 监听器针对所有Accessible属性注册，当这些属性更改时将被调用。
        参数
        listener - 要添加的PropertyChangeListener
        另请参见：
        ACCESSIBLE_NAME_PROPERTY ， ACCESSIBLE_DESCRIPTION_PROPERTY ， ACCESSIBLE_STATE_PROPERTY ， ACCESSIBLE_VALUE_PROPERTY ， ACCESSIBLE_SELECTION_PROPERTY ， ACCESSIBLE_TEXT_PROPERTY ， ACCESSIBLE_VISIBLE_DATA_PROPERTY

      • removePropertyChangeListener

        public void removePropertyChangeListener​(PropertyChangeListener listener)
        从侦听器列表中删除PropertyChangeListener 。 这将删除所有属性注册的PropertyChangeListener 。
        参数
        listener - 要删除的PropertyChangeListener

      • getAccessibleAction

        public AccessibleAction getAccessibleAction​()
        获取支持一个或多个操作的此对象关联的 AccessibleAction 。
        结果
        AccessibleAction如果由对象支持; 否则返回null
        另请参见：
        AccessibleAction

      • getAccessibleComponent

        public AccessibleComponent getAccessibleComponent​()
        获取与该对象关联的 AccessibleComponent ，该对象具有图形表示。
        结果
        AccessibleComponent如果由对象支持; 否则返回null
        另请参见：
        AccessibleComponent

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection​()
        获取与此对象关联的 AccessibleSelection ，允许其 Accessible孩子被选中。
        结果
        AccessibleSelection如果由对象支持; 否则返回null
        另请参见：
        AccessibleSelection

      • getAccessibleText

        public AccessibleText getAccessibleText​()
        获取与该对象相关联的 AccessibleText在显示器上显示文本。
        结果
        AccessibleText如果由对象支持; 否则返回null
        另请参见：
        AccessibleText

      • getAccessibleEditableText

        public AccessibleEditableText getAccessibleEditableText​()
        获取与此对象相关联的 AccessibleEditableText ，在显示屏上显示可编辑文本。
        结果
        AccessibleEditableText如果被对象支持; 否则返回null
        从以下版本开始：
        1.4
        另请参见：
        AccessibleEditableText

      • getAccessibleValue

        public AccessibleValue getAccessibleValue​()
        获取与此对象关联的 AccessibleValue ，该对象支持 Numerical值。
        结果
        AccessibleValue如果由对象支持; 否则返回null
        另请参见：
        AccessibleValue

      • getAccessibleIcon

        public AccessibleIcon[] getAccessibleIcon​()
        获取与具有一个或多个关联图标的对象关联的 AccessibleIcons 。
        结果
        一个AccessibleIcon的数组，如果被对象支持; 否则返回null
        从以下版本开始：
        1.3
        另请参见：
        AccessibleIcon

      • getAccessibleRelationSet

        public AccessibleRelationSet getAccessibleRelationSet​()
        获取与对象关联的 AccessibleRelationSet 。
        结果
        一个AccessibleRelationSet如果被对象支持; 否则返回null
        从以下版本开始：
        1.3
        另请参见：
        AccessibleRelationSet

      • getAccessibleTable

        public AccessibleTable getAccessibleTable​()
        获取与对象关联的 AccessibleTable 。
        结果
        一个AccessibleTable如果被对象支持; 否则返回null
        从以下版本开始：
        1.3
        另请参见：
        AccessibleTable

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               Object oldValue,
                               Object newValue)
        支持报告绑定属性更改。 如果oldValue和newValue不相等，并且PropertyChangeEvent侦听器列表不为空，则向每个侦听器发送一个PropertyChange事件。 一般来说，这是由Accessible对象本身使用，不应由应用程序调用。
        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 该物业的旧值
        newValue - 物业的新价值
        另请参见：
        PropertyChangeSupport ， addPropertyChangeListener(java.beans.PropertyChangeListener) ， removePropertyChangeListener(java.beans.PropertyChangeListener) ， ACCESSIBLE_NAME_PROPERTY ， ACCESSIBLE_DESCRIPTION_PROPERTY ， ACCESSIBLE_STATE_PROPERTY ， ACCESSIBLE_VALUE_PROPERTY ， ACCESSIBLE_SELECTION_PROPERTY ， ACCESSIBLE_TEXT_PROPERTY ， ACCESSIBLE_VISIBLE_DATA_PROPERTY
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleEditableText (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleEditableText

  • All Superinterfaces:
    AccessibleText
    所有已知实现类：
    JEditorPane.AccessibleJEditorPane ， JEditorPane.AccessibleJEditorPaneHTML ， JEditorPane.JEditorPaneAccessibleHypertextSupport ， JPasswordField.AccessibleJPasswordField ， JSpinner.AccessibleJSpinner ， JTextArea.AccessibleJTextArea ， JTextComponent.AccessibleJTextComponent ， JTextField.AccessibleJTextField

    public interface AccessibleEditableText
extends AccessibleText
    AccessibleEditableText接口应由在显示器上显示可编辑文本信息的所有类实现。 随着AccessibleText接口，该接口提供了辅助技术通过其内容，属性和空间位置访问该文本的标准机制。 应用程序可确定对象是否支持AccessibleEditableText通过首先获得接口其AccessibleContext （见Accessible ），然后调用AccessibleContext.getAccessibleEditableText()的方法AccessibleContext 。 如果返回值不是null ，则该对象支持该接口。
    从以下版本开始：
    1.4
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleContext.getAccessibleText() ， AccessibleContext.getAccessibleEditableText()

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void cut​(int startIndex, int endIndex)
      将两个索引之间的文本剪切到系统剪贴板中。
      void delete​(int startIndex, int endIndex)
      删除两个索引之间的文本。
      String getTextRange​(int startIndex, int endIndex)
      返回两个索引之间的文本字符串。
      void insertTextAtIndex​(int index, String s)
      在指定的索引处插入指定的字符串。
      void paste​(int startIndex)
      将文本从系统剪贴板粘贴到从指定索引开始的文本。
      void replaceText​(int startIndex, int endIndex, String s)
      用指定的字符串替换两个索引之间的文本。
      void selectText​(int startIndex, int endIndex)
      选择两个索引之间的文本。
      void setAttributes​(int startIndex, int endIndex, AttributeSet as)
      为两个索引之间的文本设置属性。
      void setTextContents​(String s)
      将文本内容设置为指定的字符串。

      • Methods inherited from interface javax.accessibility.AccessibleText

        getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart

    • 方法详细信息

      • setTextContents

        void setTextContents​(String s)
        将文本内容设置为指定的字符串。
        参数
        s - 设置文本内容的字符串

      • insertTextAtIndex

        void insertTextAtIndex​(int index,
                       String s)
        在指定的索引处插入指定的字符串。
        参数
        index - 将插入字符串的文本中的索引
        s - 要插入文本的字符串

      • getTextRange

        String getTextRange​(int startIndex,
                    int endIndex)
        返回两个索引之间的文本字符串。
        参数
        startIndex - 文本中的起始索引
        endIndex - 文本中的结尾索引
        结果
        索引之间的文本字符串

      • delete

        void delete​(int startIndex,
            int endIndex)
        删除两个索引之间的文本。
        参数
        startIndex - 文本中的起始索引
        endIndex - 文本中的结束索引

      • cut

        void cut​(int startIndex,
         int endIndex)
        将两个索引之间的文本剪切到系统剪贴板中。
        参数
        startIndex - 文本中的起始索引
        endIndex - 文本中的结束索引

      • paste

        void paste​(int startIndex)
        将文本从系统剪贴板粘贴到从指定索引开始的文本。
        参数
        startIndex - 文本中的起始索引

      • replaceText

        void replaceText​(int startIndex,
                 int endIndex,
                 String s)
        用指定的字符串替换两个索引之间的文本。
        参数
        startIndex - 文本中的起始索引
        endIndex - 文本中的结束索引
        s - 用于替换两个索引之间的文本的字符串

      • selectText

        void selectText​(int startIndex,
                int endIndex)
        选择两个索引之间的文本。
        参数
        startIndex - 文本中的起始索引
        endIndex - 文本中的结束索引

      • setAttributes

        void setAttributes​(int startIndex,
                   int endIndex,
                   AttributeSet as)
        为两个索引之间的文本设置属性。
        参数
        startIndex - 文本中的起始索引
        endIndex - 文本中的结尾索引
        as - 属性集
        另请参见：
        AttributeSet
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleExtendedComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleExtendedComponent

  • All Superinterfaces:
    AccessibleComponent
    所有已知实现类：
    AbstractButton.AccessibleAbstractButton ， JButton.AccessibleJButton ， JCheckBox.AccessibleJCheckBox ， JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem ， JColorChooser.AccessibleJColorChooser ， JComboBox.AccessibleJComboBox ， JComponent.AccessibleJComponent ， JDesktopPane.AccessibleJDesktopPane ， JEditorPane.AccessibleJEditorPane ， JEditorPane.AccessibleJEditorPaneHTML ， JEditorPane.JEditorPaneAccessibleHypertextSupport ， JFileChooser.AccessibleJFileChooser ， JInternalFrame.AccessibleJInternalFrame ， JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon ， JLabel.AccessibleJLabel ， JLayeredPane.AccessibleJLayeredPane ， JList.AccessibleJList ， JMenu.AccessibleJMenu ， JMenuBar.AccessibleJMenuBar ， JMenuItem.AccessibleJMenuItem ， JOptionPane.AccessibleJOptionPane ， JPanel.AccessibleJPanel ， JPasswordField.AccessibleJPasswordField ， JPopupMenu.AccessibleJPopupMenu ， JProgressBar.AccessibleJProgressBar ， JRadioButton.AccessibleJRadioButton ， JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem ， JRootPane.AccessibleJRootPane ， JScrollBar.AccessibleJScrollBar ， JScrollPane.AccessibleJScrollPane ， JSeparator.AccessibleJSeparator ， JSlider.AccessibleJSlider ， JSpinner.AccessibleJSpinner ， JSplitPane.AccessibleJSplitPane ， JTabbedPane.AccessibleJTabbedPane ， JTable.AccessibleJTable ， JTableHeader.AccessibleJTableHeader ， JTextArea.AccessibleJTextArea ， JTextComponent.AccessibleJTextComponent ， JTextField.AccessibleJTextField ， JToggleButton.AccessibleJToggleButton ， JToolBar.AccessibleJToolBar ， JToolTip.AccessibleJToolTip ， JTree.AccessibleJTree ， JViewport.AccessibleJViewport

    public interface AccessibleExtendedComponent
extends AccessibleComponent
    应该在屏幕上呈现的任何对象支持AccessibleExtendedComponent接口。 该界面提供辅助技术的标准机制来确定对象的扩展图形表示。 应用程序可以通过首先获取其AccessibleContext然后调用AccessibleContext.getAccessibleComponent()方法来确定对象是否支持AccessibleExtendedComponent接口。 如果返回值不是null ，返回值的类型是AccessibleExtendedComponent ，则该对象支持该接口。
    从以下版本开始：
    1.4
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleContext.getAccessibleComponent()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AccessibleKeyBinding getAccessibleKeyBinding​()
      返回与此对象关联的键绑定。
      String getTitledBorderText​()
      返回标题边框文本。
      String getToolTipText​()
      返回工具提示文本。

      • Methods inherited from interface javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 方法详细信息

      • getToolTipText

        String getToolTipText​()
        返回工具提示文本。
        结果
        工具提示文本（如果支持）;对象; 否则， null

      • getTitledBorderText

        String getTitledBorderText​()
        返回标题边框文本。
        结果
        对象的标题边框文本（如果支持）; 否则， null

      • getAccessibleKeyBinding

        AccessibleKeyBinding getAccessibleKeyBinding​()
        返回与此对象关联的键绑定。
        结果
        对象的关键绑定（如果支持）; 否则， null
        另请参见：
        AccessibleKeyBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleExtendedTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleExtendedTable

  • All Superinterfaces:
    AccessibleTable
    所有已知实现类：
    JTable.AccessibleJTable

    public interface AccessibleExtendedTable
extends AccessibleTable
    AccessibleExtendedTable类提供了以二维表格格式显示数据的用户界面组件的扩展信息。 应用程序可以通过首先获取其AccessibleContext然后调用AccessibleContext.getAccessibleTable()方法来确定对象是否支持AccessibleExtendedTable接口。 如果返回值不是null ，返回值的类型是AccessibleExtendedTable ，则该对象支持该接口。
    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getAccessibleColumn​(int index)
      返回表中索引的列号。
      int getAccessibleIndex​(int r, int c)
      返回表中行和列的索引。
      int getAccessibleRow​(int index)
      返回表中索引的行号。

      • Methods inherited from interface javax.accessibility.AccessibleTable

        getAccessibleAt, getAccessibleCaption, getAccessibleColumnCount, getAccessibleColumnDescription, getAccessibleColumnExtentAt, getAccessibleColumnHeader, getAccessibleRowCount, getAccessibleRowDescription, getAccessibleRowExtentAt, getAccessibleRowHeader, getAccessibleSummary, getSelectedAccessibleColumns, getSelectedAccessibleRows, isAccessibleColumnSelected, isAccessibleRowSelected, isAccessibleSelected, setAccessibleCaption, setAccessibleColumnDescription, setAccessibleColumnHeader, setAccessibleRowDescription, setAccessibleRowHeader, setAccessibleSummary

    • 方法详细信息

      • getAccessibleRow

        int getAccessibleRow​(int index)
        返回表中索引的行号。
        参数
        index - 表中的从零开始的索引。 索引是从行== 0和列== 0的表单元格偏移量。
        结果
        如果存在，则表的基于零的行; 否则-1

      • getAccessibleColumn

        int getAccessibleColumn​(int index)
        返回表中索引的列号。
        参数
        index - 表中的从零开始的索引。 索引是从行== 0和列== 0的表单元格偏移量。
        结果
        表的零基列存在; 否则-1

      • getAccessibleIndex

        int getAccessibleIndex​(int r,
                       int c)
        返回表中行和列的索引。
        参数
        r - 表的零为一行
        c - 表的零基列
        结果
        表中的基于零的索引存在; 否则-1。 索引是从行== 0和列== 0的表单元格偏移量。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleExtendedText (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleExtendedText

  • 所有已知实现类：
    JEditorPane.AccessibleJEditorPane ， JEditorPane.AccessibleJEditorPaneHTML ， JEditorPane.JEditorPaneAccessibleHypertextSupport ， JPasswordField.AccessibleJPasswordField ， JTextArea.AccessibleJTextArea ， JTextComponent.AccessibleJTextComponent ， JTextField.AccessibleJTextField

    public interface AccessibleExtendedText
    该AccessibleExtendedText接口包含不被提供的其他方法AccessibleText接口。

    应用程序可确定对象是否支持AccessibleExtendedText通过首先获得接口其AccessibleContext （见Accessible ），然后调用AccessibleContext.getAccessibleText()的方法AccessibleContext 。 如果返回值为AccessibleExtendedText的实例，则该对象支持该接口。

    从以下版本开始：
    1.5
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleContext.getAccessibleText()

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ATTRIBUTE_RUN
      常数用于表示应检索的文本部分是具有相同文本属性的连续文本。
      static int LINE
      常数用于表示应检索的文本的一部分是文本行。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Rectangle getTextBounds​(int startIndex, int endIndex)
      返回两个索引之间文本的边界矩形。
      String getTextRange​(int startIndex, int endIndex)
      返回两个索引之间的文本。
      AccessibleTextSequence getTextSequenceAfter​(int part, int index)
      给定索引后返回 AccessibleTextSequence 。
      AccessibleTextSequence getTextSequenceAt​(int part, int index)
      返回给定索引的 AccessibleTextSequence 。
      AccessibleTextSequence getTextSequenceBefore​(int part, int index)
      返回给定索引前的 AccessibleTextSequence 。

    • 字段详细信息

      • LINE

        static final int LINE
        常数用于表示应检索的文本的一部分是文本行。
        另请参见：
        AccessibleText.getAtIndex(int, int) ，
AccessibleText.getAfterIndex(int, int) ，
AccessibleText.getBeforeIndex(int, int) ，
Constant Field Values

      • ATTRIBUTE_RUN

        static final int ATTRIBUTE_RUN
        常数用于表示应检索的文本部分是具有相同文本属性的连续文本。
        另请参见：
        AccessibleText.getAtIndex(int, int) ，
AccessibleText.getAfterIndex(int, int) ，
AccessibleText.getBeforeIndex(int, int) ，
Constant Field Values

    • 方法详细信息

      • getTextRange

        String getTextRange​(int startIndex,
                    int endIndex)
        返回两个索引之间的文本。
        参数
        startIndex - 文本中的起始索引
        endIndex - 文本中的结束索引
        结果
        如果索引有效，则为文本字符串。 否则返回null 。

      • getTextSequenceAt

        AccessibleTextSequence getTextSequenceAt​(int part,
                                         int index)
        返回给定索引的 AccessibleTextSequence 。
        参数
        part -在 CHARACTER ， WORD ， SENTENCE ， LINE或者 ATTRIBUTE_RUN检索
        index - 文本中的索引
        结果
        一个AccessibleTextSequence指定如果part和index有效的文本。 否则返回null 。
        另请参见：
        AccessibleText.CHARACTER ， AccessibleText.WORD ， AccessibleText.SENTENCE

      • getTextSequenceAfter

        AccessibleTextSequence getTextSequenceAfter​(int part,
                                            int index)
        给定索引后返回 AccessibleTextSequence 。
        参数
        part -在 CHARACTER ， WORD ， SENTENCE ， LINE或者 ATTRIBUTE_RUN检索
        index - 文本中的索引
        结果
        一个AccessibleTextSequence指定part和index有效的文本。 否则返回null 。
        另请参见：
        AccessibleText.CHARACTER ， AccessibleText.WORD ， AccessibleText.SENTENCE

      • getTextSequenceBefore

        AccessibleTextSequence getTextSequenceBefore​(int part,
                                             int index)
        返回给定索引前的 AccessibleTextSequence 。
        参数
        part -在 CHARACTER ， WORD ， SENTENCE ， LINE或者 ATTRIBUTE_RUN检索
        index - 文本中的索引
        结果
        一个AccessibleTextSequence指定如果part和index有效的文本。 否则返回null 。
        另请参见：
        AccessibleText.CHARACTER ， AccessibleText.WORD ， AccessibleText.SENTENCE

      • getTextBounds

        Rectangle getTextBounds​(int startIndex,
                        int endIndex)
        返回两个索引之间文本的边界矩形。
        参数
        startIndex - 文本中的起始索引
        endIndex - 文本中的结束索引
        结果
        如果索引有效，文本的边界矩形。 否则返回null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleHyperlink (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleHyperlink

  • java.lang.Object
    • javax.accessibility.AccessibleHyperlink
  • All Implemented Interfaces:
    AccessibleAction
    已知直接子类：
    JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

    public abstract class AccessibleHyperlink
extends Object
implements AccessibleAction
    在超文本文件中封装链接或一组链接（例如客户端图像映射）
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleText ， AccessibleContext.getAccessibleText()

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleHyperlink​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract boolean doAccessibleAction​(int i)
      对对象执行指定的操作。
      abstract Object getAccessibleActionAnchor​(int i)
      返回一个表示链接锚点的对象，适用于该链接。
      abstract int getAccessibleActionCount​()
      返回此链接中可用操作的数量如果有多个可用操作，则第一个不被视为此LINK对象的“默认”操作（例如，在HTML图像映射中）。
      abstract String getAccessibleActionDescription​(int i)
      返回此特定链接操作的字符串描述。
      abstract Object getAccessibleActionObject​(int i)
      返回表示链接操作的对象，适用于该链接。
      abstract int getEndIndex​()
      获取此链接结束的超文本文件的索引。
      abstract int getStartIndex​()
      获取此链接开始的超文本文件的索引。
      abstract boolean isValid​()
      由于链接关联的文档可能已更改，因此此方法将返回此链接是否仍然有效（相对于其引用的文档）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleHyperlink

        public AccessibleHyperlink​()

    • 方法详细信息

      • isValid

        public abstract boolean isValid​()
        由于链接关联的文档可能已更改，因此此方法将返回此链接是否仍然有效（相对于其引用的文档）。
        结果
        一个标志，表示这个链接是否仍然是有效的 AccessibleHypertext它属于

      • getAccessibleActionCount

        public abstract int getAccessibleActionCount​()
        返回此链接中可用操作的数量如果有多个可用操作，则第一个不被视为此LINK对象的“默认”操作（例如，在HTML图像映射中）。 一般来说，链接中只有一个AccessibleAction 。
        Specified by:
        getAccessibleActionCount接口 AccessibleAction
        结果
        该对象中基于零的操作数

      • doAccessibleAction

        public abstract boolean doAccessibleAction​(int i)
        对对象执行指定的操作。
        Specified by:
        doAccessibleAction接口 AccessibleAction
        参数
        i - 基于零的操作索引
        结果
        true如果执行动作; 否则false
        另请参见：
        getAccessibleActionCount()

      • getAccessibleActionDescription

        public abstract String getAccessibleActionDescription​(int i)
        返回此特定链接操作的字符串描述。 这应该是与锚定文本相关联的文本字符串，这应该是锚文本。 例如HTML：<a HREF="http://www.sun.com/access">辅助功能</a>，此方法将返回“辅助功能”。

        同样，从这个HTML：<a href="#top"> <img src =“top-hat.gif”alt =“top hat”> </a>这个方法会返回“顶帽”

        Specified by:
        getAccessibleActionDescription在接口 AccessibleAction
        参数
        i - 零操作的索引
        结果
        字符串描述的动作
        另请参见：
        getAccessibleActionCount()

      • getAccessibleActionObject

        public abstract Object getAccessibleActionObject​(int i)
        返回表示链接操作的对象，适用于该链接。 例如HTML：<a HREF="http://www.sun.com/access">辅助功能</a>此方法将返回一个java.net.URL（“http://www.sun.com/access html的“）;
        参数
        i - 零操作的索引
        结果
        表示超文本链接本身的对象
        另请参见：
        getAccessibleActionCount()

      • getAccessibleActionAnchor

        public abstract Object getAccessibleActionAnchor​(int i)
        返回一个表示链接锚点的对象，适用于该链接。 例如HTML：<a href="http://www.sun.com/access">辅助功能</a>，此方法将返回包含文本“辅助功能”的String 。

        同样，从这个HTML：<a href="#top"> <img src =“top-hat.gif”alt =“top hat”> </a>这可能会返回对象ImageIcon（“top-hat.gif “，”顶帽“）;

        参数
        i - 零操作的索引
        结果
        表示超文本锚的对象
        另请参见：
        getAccessibleActionCount()

      • getStartIndex

        public abstract int getStartIndex​()
        获取此链接开始的超文本文件的索引。
        结果
        链接开始索引

      • getEndIndex

        public abstract int getEndIndex​()
        获取此链接结束的超文本文件的索引。
        结果
        链接结束索引
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleHypertext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleHypertext

  • All Superinterfaces:
    AccessibleText
    所有已知实现类：
    JEditorPane.JEditorPaneAccessibleHypertextSupport

    public interface AccessibleHypertext
extends AccessibleText
    AccessibleHypertext类是在显示器上显示超文本信息的所有类的基类。 该类提供了辅助技术通过其内容，属性和空间位置访问该文本的标准机制。 它还提供了操纵超链接的标准机制。 应用程序可确定对象是否支持AccessibleHypertext通过首先获得接口其AccessibleContext （见Accessible ），然后调用AccessibleContext.getAccessibleText()的方法AccessibleContext 。 如果返回值是扩展为AccessibleHypertext的类，则该对象支持AccessibleHypertext 。
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleText ， AccessibleContext.getAccessibleText()

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AccessibleHyperlink getLink​(int linkIndex)
      返回此超文本文件的第n个链接。
      int getLinkCount​()
      返回此超文本文件中的链接数。
      int getLinkIndex​(int charIndex)
      将索引返回到与此字符索引相关联的超链接数组中，如果没有与此索引相关联的超链接，则返回-1。

      • Methods inherited from interface javax.accessibility.AccessibleText

        getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart

    • 方法详细信息

      • getLinkCount

        int getLinkCount​()
        返回此超文本文件中的链接数。
        结果
        此超文本文件中的链接数

      • getLink

        AccessibleHyperlink getLink​(int linkIndex)
        返回此超文本文件的第n个链接。
        参数
        linkIndex - 在这个超文本的链接内
        结果
        封装第n个链接的链接对象

      • getLinkIndex

        int getLinkIndex​(int charIndex)
        将索引返回到与此字符索引相关联的超链接数组中，如果没有与此索引相关联的超链接，则返回-1。
        参数
        charIndex - 文本中的索引
        结果
        索引到这个超文本文档的超链接集
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleIcon (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleIcon

  • 所有已知实现类：
    ImageIcon.AccessibleImageIcon

    public interface AccessibleIcon
    任何具有相关联图标（例如按钮）的对象都应支持AccessibleIcon界面。 该界面提供辅助技术的标准机制，以获取有关图标的描述性信息。 应用程序可以通过首先获得其AccessibleContext （见Accessible ），然后调用AccessibleContext.getAccessibleIcon()方法来确定对象是否支持AccessibleIcon接口。 如果返回值不是null ，则该对象支持该接口。
    从以下版本开始：
    1.3
    另请参见：
    Accessible ， AccessibleContext

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getAccessibleIconDescription​()
      获取图标的描述。
      int getAccessibleIconHeight​()
      获取图标的高度。
      int getAccessibleIconWidth​()
      获取图标的宽度。
      void setAccessibleIconDescription​(String description)
      设置图标的描述。

    • 方法详细信息

      • getAccessibleIconDescription

        String getAccessibleIconDescription​()
        获取图标的描述。 这意味着是对象的简短文本描述。 例如，它可以呈现给盲人以给出图标的目的的指示。
        结果
        图标的描述

      • setAccessibleIconDescription

        void setAccessibleIconDescription​(String description)
        设置图标的描述。 这意味着是对象的简短文本描述。 例如，它可以呈现给盲人以给出图标的目的的指示。
        参数
        description - 图标说明

      • getAccessibleIconWidth

        int getAccessibleIconWidth​()
        获取图标的宽度。
        结果
        图标的宽度

      • getAccessibleIconHeight

        int getAccessibleIconHeight​()
        获取图标的高度。
        结果
        图标的高度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleKeyBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleKeyBinding

  • public interface AccessibleKeyBinding
    任何具有键盘绑定（如键盘助记符和/或键盘快捷方式）的对象都可以支持AccessibleKeyBinding界面，可用于选择对象。 该界面提供了辅助技术的标准机制，以确定此对象存在的键绑定。 任何具有这种密钥绑定的对象都应该支持该接口。
    从以下版本开始：
    1.4
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object getAccessibleKeyBinding​(int i)
      返回此对象的键绑定。
      int getAccessibleKeyBindingCount​()
      返回此对象的键绑定数。

    • 方法详细信息

      • getAccessibleKeyBindingCount

        int getAccessibleKeyBindingCount​()
        返回此对象的键绑定数。
        结果
        该对象的基于零的键绑定数

      • getAccessibleKeyBinding

        Object getAccessibleKeyBinding​(int i)
        返回此对象的键绑定。 返回的值是一个java.lang.Object ，它必须根据密钥的底层实现来转换为适当的类型。
        参数
        i - 基于零的键绑定索引
        结果
        一个 javax.lang.Object它指定了键绑定
        另请参见：
        getAccessibleKeyBindingCount()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleRelation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleRelation

  • java.lang.Object
    • javax.accessibility.AccessibleBundle
      • javax.accessibility.AccessibleRelation

  • public class AccessibleRelation
extends AccessibleBundle
    AccessibleRelation类描述了实现AccessibleRelation的对象与一个或多个其他对象之间的关系。 对象与其他对象的实际关系定义为AccessibleRelationSet ，它是一组AccessibleRelations 。

    AccessibleBundle.toDisplayString()方法允许您从本类中定义的键从预定义的ResourceBundle获取与区域设置无关键的本地化字符串。

    这个类中的常量表现出强类型的普通对象角色枚举。 如果此类中的常量不足以描述对象的角色，则应从此类生成子类，并应以类似的方式提供常量。

    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String CHILD_NODE_OF
      表示对象是一个或多个对象的子节点。
      static String CHILD_NODE_OF_PROPERTY
      表示两个或多个对象之间的 CHILD_NODE_OF关系已更改。
      static String CONTROLLED_BY
      表示对象由一个或多个目标对象控制。
      static String CONTROLLED_BY_PROPERTY
      标识正在进行控制的目标对象已更改。
      static String CONTROLLER_FOR
      表示对象是一个或多个目标对象的控制器。
      static String CONTROLLER_FOR_PROPERTY
      标识目标对象的控制器已更改。
      static String EMBEDDED_BY
      表示对象嵌入到一个或多个对象中。
      static String EMBEDDED_BY_PROPERTY
      表示两个或多个对象之间的 EMBEDDED_BY关系已更改。
      static String EMBEDS
      表示对象中嵌入了一个或多个对象。
      static String EMBEDS_PROPERTY
      表示两个或多个对象之间的 EMBEDS关系已更改。
      static String FLOWS_FROM
      表示一个对象与第二个对象在逻辑上邻接，第二个对象发生在对象之前。
      static String FLOWS_FROM_PROPERTY
      表示两个对象之间的 FLOWS_FROM关系已更改。
      static String FLOWS_TO
      表示对象与第二个对象在逻辑上邻接，第二个对象发生在对象之后。
      static String FLOWS_TO_PROPERTY
      表示两个对象之间的 FLOWS_TO关系发生变化。
      static String LABEL_FOR
      表示一个对象是一个或多个目标对象的标签。
      static String LABEL_FOR_PROPERTY
      标识标签的目标组已更改。
      static String LABELED_BY
      表示一个对象被一个或多个目标对象标记。
      static String LABELED_BY_PROPERTY
      标识正在进行标签的对象已更改。
      static String MEMBER_OF
      表示对象是一个或多个目标对象组的成员。
      static String MEMBER_OF_PROPERTY
      标识组成员资格已更改。
      static String PARENT_WINDOW_OF
      表示对象是一个或多个对象的父窗口。
      static String PARENT_WINDOW_OF_PROPERTY
      表示两个或多个对象之间的 PARENT_WINDOW_OF关系已更改。
      static String SUBWINDOW_OF
      表示对象是一个或多个对象的子窗口。
      static String SUBWINDOW_OF_PROPERTY
      表示两个或多个对象之间的 SUBWINDOW_OF关系已更改。

      • Fields inherited from class javax.accessibility.AccessibleBundle

        key

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleRelation​(String key)
      使用给定的区域设置独立键创建一个新的 AccessibleRelation 。
      AccessibleRelation​(String key, Object target)
      使用给定的区域设置独立键创建一个新的 AccessibleRelation 。
      AccessibleRelation​(String key, Object[] target)
      使用给定的区域设置独立键创建一个新的 AccessibleRelation 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getKey​()
      返回此关系的关键。
      Object[] getTarget​()
      返回此关系的目标对象。
      void setTarget​(Object target)
      设置此关系的目标对象。
      void setTarget​(Object[] target)
      设置此关系的目标对象。

      • Methods inherited from class javax.accessibility.AccessibleBundle

        toDisplayString, toDisplayString, toDisplayString, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • LABEL_FOR

        public static final String LABEL_FOR
        表示一个对象是一个或多个目标对象的标签。
        另请参见：
        getTarget() ， CONTROLLER_FOR ， CONTROLLED_BY ， LABELED_BY ， MEMBER_OF

      • LABELED_BY

        public static final String LABELED_BY
        表示一个对象被一个或多个目标对象标记。
        另请参见：
        getTarget() ， CONTROLLER_FOR ， CONTROLLED_BY ， LABEL_FOR ， MEMBER_OF

      • MEMBER_OF

        public static final String MEMBER_OF
        表示对象是一个或多个目标对象组的成员。
        另请参见：
        getTarget() ， CONTROLLER_FOR ， CONTROLLED_BY ， LABEL_FOR ， LABELED_BY

      • CONTROLLER_FOR

        public static final String CONTROLLER_FOR
        表示对象是一个或多个目标对象的控制器。
        另请参见：
        getTarget() ， CONTROLLED_BY ， LABEL_FOR ， LABELED_BY ， MEMBER_OF

      • CONTROLLED_BY

        public static final String CONTROLLED_BY
        表示对象由一个或多个目标对象控制。
        另请参见：
        getTarget() ， CONTROLLER_FOR ， LABEL_FOR ， LABELED_BY ， MEMBER_OF

      • FLOWS_TO

        public static final String FLOWS_TO
        表示对象与第二个对象在逻辑上邻接，第二个对象发生在对象之后。 一个例子是一段文本，运行到页面的末尾，并在下一页继续使用一个插入的文本页脚和/或文本标题。 段落的两个部分是单独的文本元素，但相关的是第二个元素是第一个元素的延续。 换句话说，第一个元素“流向”第二个元素。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • FLOWS_FROM

        public static final String FLOWS_FROM
        表示一个对象与第二个对象在逻辑上邻接，第二个对象发生在对象之前。 一个例子是一段文本，运行到页面的末尾，并在下一页继续使用一个插入的文本页脚和/或文本标题。 段落的两个部分是单独的文本元素，但相关的是第二个元素是第一个元素的延续。 换句话说，第二个元素“从第二个元素流出”。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • SUBWINDOW_OF

        public static final String SUBWINDOW_OF
        表示对象是一个或多个对象的子窗口。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • PARENT_WINDOW_OF

        public static final String PARENT_WINDOW_OF
        表示对象是一个或多个对象的父窗口。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • EMBEDS

        public static final String EMBEDS
        表示对象中嵌入了一个或多个对象。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • EMBEDDED_BY

        public static final String EMBEDDED_BY
        表示对象嵌入到一个或多个对象中。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • CHILD_NODE_OF

        public static final String CHILD_NODE_OF
        表示对象是一个或多个对象的子节点。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • LABEL_FOR_PROPERTY

        public static final String LABEL_FOR_PROPERTY
        标识标签的目标组已更改。
        另请参见：
        Constant Field Values

      • LABELED_BY_PROPERTY

        public static final String LABELED_BY_PROPERTY
        标识正在进行标签的对象已更改。
        另请参见：
        Constant Field Values

      • MEMBER_OF_PROPERTY

        public static final String MEMBER_OF_PROPERTY
        标识组成员资格已更改。
        另请参见：
        Constant Field Values

      • CONTROLLER_FOR_PROPERTY

        public static final String CONTROLLER_FOR_PROPERTY
        标识目标对象的控制器已更改。
        另请参见：
        Constant Field Values

      • CONTROLLED_BY_PROPERTY

        public static final String CONTROLLED_BY_PROPERTY
        标识正在进行控制的目标对象已更改。
        另请参见：
        Constant Field Values

      • FLOWS_TO_PROPERTY

        public static final String FLOWS_TO_PROPERTY
        表示两个对象之间的 FLOWS_TO关系发生了变化。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • FLOWS_FROM_PROPERTY

        public static final String FLOWS_FROM_PROPERTY
        表示两个对象之间的 FLOWS_FROM关系已更改。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • SUBWINDOW_OF_PROPERTY

        public static final String SUBWINDOW_OF_PROPERTY
        表示两个或多个对象之间的 SUBWINDOW_OF关系已更改。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • PARENT_WINDOW_OF_PROPERTY

        public static final String PARENT_WINDOW_OF_PROPERTY
        表示两个或多个对象之间的 PARENT_WINDOW_OF关系已更改。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • EMBEDS_PROPERTY

        public static final String EMBEDS_PROPERTY
        表示两个或多个对象之间的 EMBEDS关系已更改。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • EMBEDDED_BY_PROPERTY

        public static final String EMBEDDED_BY_PROPERTY
        表示两个或多个对象之间的 EMBEDDED_BY关系已更改。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • CHILD_NODE_OF_PROPERTY

        public static final String CHILD_NODE_OF_PROPERTY
        表示两个或多个对象之间的 CHILD_NODE_OF关系已更改。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • AccessibleRelation

        public AccessibleRelation​(String key)
        使用给定的区域设置独立键创建一个新的AccessibleRelation 。 密钥String应该是关系的区域设置独立密钥。 它不打算用作实际的String显示给用户。 要获取本地化的字符串，请使用AccessibleBundle.toDisplayString() 。
        参数
        key - 关系的区域设置独立名称
        另请参见：
        AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)

      • AccessibleRelation

        public AccessibleRelation​(String key,
                          Object target)
        使用给定的区域设置独立键创建一个新的AccessibleRelation 。 密钥String应该是关系的区域设置独立密钥。 它不是用作实际显示给用户的String 。 要获取本地化的字符串，请使用AccessibleBundle.toDisplayString() 。
        参数
        key - 关系的区域设置独立名称
        target - 此关系的目标对象
        另请参见：
        AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)

      • AccessibleRelation

        public AccessibleRelation​(String key,
                          Object[] target)
        使用给定的区域设置独立键创建一个新的AccessibleRelation 。 密钥String应该是该关系的区域设置独立密钥。 它不是用作实际显示给用户的String 。 要获取本地化的字符串，请使用AccessibleBundle.toDisplayString() 。
        参数
        key - 关系的区域设置独立名称
        target - 此关系的目标对象
        另请参见：
        AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)

    • 方法详细信息

      • getKey

        public String getKey​()
        返回此关系的关键。
        结果
        这个关系的关键
        另请参见：
        CONTROLLER_FOR ， CONTROLLED_BY ， LABEL_FOR ， LABELED_BY ， MEMBER_OF

      • getTarget

        public Object[] getTarget​()
        返回此关系的目标对象。
        结果
        一个包含此关系的目标对象的数组

      • setTarget

        public void setTarget​(Object target)
        设置此关系的目标对象。
        参数
        target - 此关系的目标对象

      • setTarget

        public void setTarget​(Object[] target)
        设置此关系的目标对象。
        参数
        target - an array containing the target objects for this relation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleRelationSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleRelationSet

  • java.lang.Object
    • javax.accessibility.AccessibleRelationSet

  • public class AccessibleRelationSet
extends Object
    AccessibleRelationSet类决定一个组件的关系集。 组件的关系集是一组描述组件与其他组件的关系的AccessibleRelation对象。
    从以下版本开始：
    1.3
    另请参见：
    AccessibleRelation

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Vector<AccessibleRelation> relations
      Vector每个条目代表 AccessibleRelation 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleRelationSet​()
      创建一个新的空关系集。
      AccessibleRelationSet​(AccessibleRelation[] relations)
      与传递的关系数组中包含的初始关系创建一个新的关系。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(AccessibleRelation relation)
      添加与当前关系集的新关系。
      void addAll​(AccessibleRelation[] relations)
      将所有关系添加到现有关系集中。
      void clear​()
      从当前关系集中删除所有关系。
      boolean contains​(String key)
      返回关系集是否包含与指定键匹配的关系。
      AccessibleRelation get​(String key)
      返回与指定键匹配的关系。
      boolean remove​(AccessibleRelation relation)
      从当前关系集中删除关系。
      int size​()
      返回关系集中的关系数。
      AccessibleRelation[] toArray​()
      将当前关系集返回为 AccessibleRelation的数组。
      String toString​()
      使用默认语言环境创建表示集合中所有关系的本地化字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • relations

        protected Vector<AccessibleRelation> relations
        Vector每个条目代表 AccessibleRelation 。
        另请参见：
        add(javax.accessibility.AccessibleRelation) ，
addAll(javax.accessibility.AccessibleRelation[]) ，
remove(javax.accessibility.AccessibleRelation) ，
contains(java.lang.String) ，
get(java.lang.String) ，
size() ，
toArray() ，
clear()

    • 构造方法详细信息

      • AccessibleRelationSet

        public AccessibleRelationSet​()
        创建一个新的空关系集。

      • AccessibleRelationSet

        public AccessibleRelationSet​(AccessibleRelation[] relations)
        创建与传递的关系数组中包含的初始关系集的新关系。重复的条目将被忽略。
        参数
        relations - 描述关系集的 AccessibleRelation的数组

    • 方法详细信息

      • add

        public boolean add​(AccessibleRelation relation)
        添加与当前关系集的新关系。 如果关系已经在关系集中，则指定关系的目标与现有关系的目标相结合。 否则，将新关系添加到关系集中。
        参数
        relation - 添加到关系集中的关系
        结果
        如果关系被添加到关系集中， true ; false如果关系集不变

      • addAll

        public void addAll​(AccessibleRelation[] relations)
        将所有关系添加到现有关系集中。 重复的条目将被忽略。
        参数
        relations - AccessibleRelation描述关系集的数组

      • remove

        public boolean remove​(AccessibleRelation relation)
        从当前关系集中删除关系。 如果关系不在集合中，关系集将不变，返回值为false 。 如果关系在关系集中，它将从集合中移除，返回值将为true 。
        参数
        relation - 从关系集中删除的关系
        结果
        true如果关系在关系集中; false如果关系集不变

      • clear

        public void clear​()
        从当前关系集中删除所有关系。

      • size

        public int size​()
        返回关系集中的关系数。
        结果
        关系集中的关系数

      • contains

        public boolean contains​(String key)
        返回关系集是否包含与指定键匹配的关系。
        参数
        key - AccessibleRelation键
        结果
        true如果关系在关系集中; 否则false

      • get

        public AccessibleRelation get​(String key)
        返回与指定键匹配的关系。
        参数
        key - AccessibleRelation键
        结果
        该关系（如果存在）与指定的键匹配。 否则返回null 。

      • toArray

        public AccessibleRelation[] toArray​()
        将当前关系集返回为 AccessibleRelation的数组。
        结果
        AccessibleRelation数组接触当前关系

      • toString

        public String toString​()
        使用默认语言环境创建表示集合中所有关系的本地化字符串。
        重写：
        toString在 Object
        结果
        逗号分隔本地化字符串
        另请参见：
        AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleResourceBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleResourceBundle

  • java.lang.Object
    • java.util.ResourceBundle
      • java.util.ListResourceBundle
        • javax.accessibility.AccessibleResourceBundle
  • 已过时。
    从Java平台1.3版开始，此类已被弃用

    @Deprecated
public class AccessibleResourceBundle
extends ListResourceBundle
    包含可访问性包中的本地化字符串的资源束。 这只适用于Java辅助功能的内部使用，并不意味着由辅助技术或应用程序使用。

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.util.ResourceBundle

        ResourceBundle.Control

    • Field Summary

      • Fields inherited from class java.util.ResourceBundle

        parent

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleResourceBundle​()
      已过时。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Object[][] getContents​()
      已过时。
      返回编程键和本地化显示字符串之间的映射。

      • Methods inherited from class java.util.ListResourceBundle

        getKeys, handleGetObject, handleKeySet

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.util.ResourceBundle

        clearCache, clearCache, containsKey, getBaseBundleName, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getLocale, getObject, getString, getStringArray, keySet, setParent

    • 构造方法详细信息

      • AccessibleResourceBundle

        public AccessibleResourceBundle​()
        已过时。

    • 方法详细信息

      • getContents

        public Object[][] getContents​()
        已过时。
        返回编程键和本地化显示字符串之间的映射。
        Specified by:
        getContents在 ListResourceBundle
        结果
        表示键值对的 Object阵列的阵列
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleRole (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleRole

  • java.lang.Object
    • javax.accessibility.AccessibleBundle
      • javax.accessibility.AccessibleRole

  • public class AccessibleRole
extends AccessibleBundle
    AccessibleRole类确定组件的作用。 组件的作用描述其通用功能。 （EG，“按钮”，“表”或“列表”。）

    AccessibleBundle.toDisplayString()方法允许您从本类中定义的键从预定义的ResourceBundle获取与区域设置无关的键的本地化字符串。

    这个类中的常量表现出强类型的普通对象角色枚举。 这个类的公共构造函数被有意地省略，应用程序应该使用这个类的一个常量。 如果此类中的常量不足以描述对象的角色，则应从此类生成子类，并应以类似的方式提供常量。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static AccessibleRole ALERT
      对象用于提醒用户有关某些内容。
      static AccessibleRole AWT_COMPONENT
      一个AWT组件，但没有其他的知道它。
      static AccessibleRole CANVAS
      可以被绘制并用于捕获事件的对象。
      static AccessibleRole CHECK_BOX
      可以选中或取消选中的选项，并为当前状态提供单独的指示符。
      static AccessibleRole COLOR_CHOOSER
      允许用户选择颜色的专用窗格。
      static AccessibleRole COLUMN_HEADER
      数据列的标题。
      static AccessibleRole COMBO_BOX
      用户可以选择的选项列表。
      static AccessibleRole DATE_EDITOR
      A DATE_EDITOR是允许用户编辑 java.util.Date和 java.util.Time对象的组件。
      static AccessibleRole DESKTOP_ICON
      一个图标化的内部框架在一个 DESKTOP_PANE 。
      static AccessibleRole DESKTOP_PANE
      支持这些内部框架的内部框架和图标化版本的窗格。
      static AccessibleRole DIALOG
      标题栏和边框的顶级窗口。
      static AccessibleRole DIRECTORY_PANE
      允许用户导航并选择目录内容的窗格。
      static AccessibleRole EDITBAR
      指示对象的角色用作计算值的公式。
      static AccessibleRole FILE_CHOOSER
      一个专门的对话框，用于显示目录中的文件，并允许用户选择文件，浏览不同的目录或指定文件名。
      static AccessibleRole FILLER
      填充用户界面空间的对象。
      static AccessibleRole FONT_CHOOSER
      A FONT_CHOOSER是一个组件，可让用户为字体选择各种属性。
      static AccessibleRole FOOTER
      文字页脚。
      static AccessibleRole FRAME
      带有标题栏，边框，菜单栏等的顶级窗口
      static AccessibleRole GLASS_PANE
      保证在其下方的所有窗格的顶部绘制的窗格。
      static AccessibleRole GROUP_BOX
      一个 GROUP_BOX是一个简单的容器，其中包含一个边框，并在其中包含组件。
      static AccessibleRole HEADER
      文字标题
      static AccessibleRole HTML_CONTAINER
      一个包含 Accessibles的集合的对象一起表示 HTML内容。
      static AccessibleRole HYPERLINK
      超文本锚。
      static AccessibleRole ICON
      一个小的固定大小的图片，通常用于装饰组件。
      static AccessibleRole INTERNAL_FRAME
      由桌面窗格剪辑的类似帧的对象。
      static AccessibleRole LABEL
      用于在界面中呈现图标或短字符串的对象。
      static AccessibleRole LAYERED_PANE
      一个专门的窗格，允许其子层被绘制，提供一个堆叠顺序的形式。
      static AccessibleRole LIST
      向对象呈现对象的列表，并允许用户选择一个或多个对象。
      static AccessibleRole LIST_ITEM
      在列表中呈现元素的对象。
      static AccessibleRole MENU
      通常在菜单栏中找到的对象，其中包含用户可以选择的操作列表。
      static AccessibleRole MENU_BAR
      通常在应用程序的主对话框顶部绘制的对象，其中包含用户可以选择的菜单列表。
      static AccessibleRole MENU_ITEM
      一个通常包含在菜单中的对象，呈现用户可以选择的动作。
      static AccessibleRole OPTION_PANE
      主要用途在 DIALOG内的专用窗格。
      static AccessibleRole PAGE_TAB
      作为页面选项卡列表的子对象。
      static AccessibleRole PAGE_TAB_LIST
      一个对象，通过对象提供的一些机制，一次显示一系列面板（或页面选项卡）。
      static AccessibleRole PANEL
      通常用于分组对象的通用容器。
      static AccessibleRole PARAGRAPH
      一段文字。
      static AccessibleRole PASSWORD_TEXT
      用于密码的文本对象，或文本内容未被显示给用户的其他地方。
      static AccessibleRole POPUP_MENU
      通常用于向用户提供选项列表的临时窗口，然后在用户选择其中一个选项时隐藏。
      static AccessibleRole PROGRESS_BAR
      用于指示任务已完成多少的对象。
      static AccessibleRole PROGRESS_MONITOR
      指示对象的角色监视某些操作的进度。
      static AccessibleRole PUSH_BUTTON
      用户可以操纵的对象来告诉应用程序做某事。
      static AccessibleRole RADIO_BUTTON
      一个专门的复选框将导致同一组中的其他单选按钮在选中时被取消选中。
      static AccessibleRole ROOT_PANE
      具有玻璃窗格和分层窗格作为其子项的专用窗格。
      static AccessibleRole ROW_HEADER
      一行数据的标题。
      static AccessibleRole RULER
      标尺是用于测量距离的对象。
      static AccessibleRole SCROLL_BAR
      通常用于允许用户递增地查看大量数据的对象。
      static AccessibleRole SCROLL_PANE
      允许用户逐步查看大量信息的对象。
      static AccessibleRole SEPARATOR
      通常包含在菜单中的对象以提供菜单中的内容的视觉和逻辑分离。
      static AccessibleRole SLIDER
      允许用户从有界范围内进行选择的对象。
      static AccessibleRole SPIN_BOX
      A SPIN_BOX是一个简单的旋转器组件，其主要用途是简单的数字。
      static AccessibleRole SPLIT_PANE
      同时提供另外两个面板的专门面板。
      static AccessibleRole STATUS_BAR
      A STATUS_BAR是可以向用户包含多个状态信息标签的简单组件。
      static AccessibleRole SWING_COMPONENT
      一个Swing组件，但没有其他的知道它。
      static AccessibleRole TABLE
      用于根据行和列提供信息的对象。
      static AccessibleRole TEXT
      向用户显示文本的对象。
      static AccessibleRole TOGGLE_BUTTON
      可以检查或取消选中的专用按钮，但不提供当前状态的单独指示器。
      static AccessibleRole TOOL_BAR
      通常由按钮或切换按钮组成的酒吧或调色板。
      static AccessibleRole TOOL_TIP
      提供有关另一个对象的信息的对象。
      static AccessibleRole TREE
      用于向用户呈现分层信息的对象。
      static AccessibleRole UNKNOWN
      该对象包含一些 Accessible信息，但其作用不明。
      static AccessibleRole VIEWPORT
      通常在滚动窗格中使用的对象。
      static AccessibleRole WINDOW
      没有标题或边框的顶级窗口。

      • Fields inherited from class javax.accessibility.AccessibleBundle

        key

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AccessibleRole​(String key)
      使用给定的区域设置独立键创建一个新的 AccessibleRole 。

    • 方法摘要

      • Methods inherited from class javax.accessibility.AccessibleBundle

        toDisplayString, toDisplayString, toDisplayString, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ALERT

        public static final AccessibleRole ALERT
        对象用于提醒用户有关某些内容。

      • COLUMN_HEADER

        public static final AccessibleRole COLUMN_HEADER
        数据列的标题。

      • CANVAS

        public static final AccessibleRole CANVAS
        可以被绘制并用于捕获事件的对象。
        另请参见：
        FRAME ， GLASS_PANE ， LAYERED_PANE

      • COMBO_BOX

        public static final AccessibleRole COMBO_BOX
        用户可以选择的选项列表。 还可以选择允许用户输入自己的选择。

      • DESKTOP_ICON

        public static final AccessibleRole DESKTOP_ICON
        一个图标化的内部框架在一个 DESKTOP_PANE 。
        另请参见：
        DESKTOP_PANE ， INTERNAL_FRAME

      • HTML_CONTAINER

        public static final AccessibleRole HTML_CONTAINER
        一个包含Accessibles的集合的对象共同代表HTML内容。 孩子Accessibles将包括实施对象AccessibleText ， AccessibleHypertext ， AccessibleIcon ，等接口。
        从以下版本开始：
        1.6
        另请参见：
        HYPERLINK ， AccessibleText ， AccessibleHypertext ， AccessibleHyperlink ， AccessibleIcon

      • INTERNAL_FRAME

        public static final AccessibleRole INTERNAL_FRAME
        由桌面窗格剪辑的类似帧的对象。 桌面窗格，内部框架和桌面图标对象通常用于在应用程序中创建多个文档界面。
        另请参见：
        DESKTOP_ICON ， DESKTOP_PANE ， FRAME

      • DESKTOP_PANE

        public static final AccessibleRole DESKTOP_PANE
        支持这些内部框架的内部框架和图标化版本的窗格。
        另请参见：
        DESKTOP_ICON ， INTERNAL_FRAME

      • OPTION_PANE

        public static final AccessibleRole OPTION_PANE
        主要用于 DIALOG专用窗格。
        另请参见：
        DIALOG

      • WINDOW

        public static final AccessibleRole WINDOW
        没有标题或边框的顶级窗口。
        另请参见：
        FRAME ， DIALOG

      • FRAME

        public static final AccessibleRole FRAME
        具有标题栏，边框，菜单栏等的顶级窗口。它通常用作应用程序的主窗口。
        另请参见：
        DIALOG ， CANVAS ， WINDOW

      • DIALOG

        public static final AccessibleRole DIALOG
        标题栏和边框的顶级窗口。 对话框类似于框架，但它具有较少的属性，并且通常用作应用程序的辅助窗口。
        另请参见：
        FRAME ， WINDOW

      • COLOR_CHOOSER

        public static final AccessibleRole COLOR_CHOOSER
        允许用户选择颜色的专用窗格。

      • DIRECTORY_PANE

        public static final AccessibleRole DIRECTORY_PANE
        允许用户导航并选择目录内容的窗格。 可以由文件选择器使用。
        另请参见：
        FILE_CHOOSER

      • FILE_CHOOSER

        public static final AccessibleRole FILE_CHOOSER
        一个专门的对话框，用于显示目录中的文件，并允许用户选择文件，浏览不同的目录或指定文件名。 可以使用目录窗格来显示目录的内容。
        另请参见：
        DIRECTORY_PANE

      • FILLER

        public static final AccessibleRole FILLER
        填充用户界面空间的对象。 它通常用于界面来调整组件之间的间距，但不能用于其他目的。

      • HYPERLINK

        public static final AccessibleRole HYPERLINK
        超文本锚。

      • ICON

        public static final AccessibleRole ICON
        一个小的固定大小的图片，通常用于装饰组件。

      • LABEL

        public static final AccessibleRole LABEL
        用于在界面中呈现图标或短字符串的对象。

      • ROOT_PANE

        public static final AccessibleRole ROOT_PANE
        具有玻璃窗格和分层窗格作为其子项的专用窗格。
        另请参见：
        GLASS_PANE ， LAYERED_PANE

      • GLASS_PANE

        public static final AccessibleRole GLASS_PANE
        保证在其下方的所有窗格的顶部绘制的窗格。
        另请参见：
        ROOT_PANE ， CANVAS

      • LAYERED_PANE

        public static final AccessibleRole LAYERED_PANE
        一个专门的窗格，允许其子层被绘制，提供一个堆叠顺序的形式。 这通常是保存菜单栏的窗格以及窗口中包含大部分可视组件的窗格。
        另请参见：
        GLASS_PANE ， ROOT_PANE

      • LIST

        public static final AccessibleRole LIST
        向对象呈现对象的列表，并允许用户选择一个或多个对象。 列表通常包含在滚动窗格中。
        另请参见：
        SCROLL_PANE ， LIST_ITEM

      • LIST_ITEM

        public static final AccessibleRole LIST_ITEM
        在列表中呈现元素的对象。 列表通常包含在滚动窗格中。
        另请参见：
        SCROLL_PANE ， LIST

      • MENU_BAR

        public static final AccessibleRole MENU_BAR
        通常在应用程序的主对话框顶部绘制的对象，其中包含用户可以选择的菜单列表。 例如，菜单栏可能包含“文件”，“编辑”和“帮助”的菜单。
        另请参见：
        MENU ， POPUP_MENU ， LAYERED_PANE

      • POPUP_MENU

        public static final AccessibleRole POPUP_MENU
        通常用于向用户提供选项列表的临时窗口，然后在用户选择其中一个选项时隐藏。
        另请参见：
        MENU ， MENU_ITEM

      • MENU

        public static final AccessibleRole MENU
        通常在菜单栏中找到的对象，其中包含用户可以选择的操作列表。 菜单可以有任何对象作为其子项，但通常它们是菜单项，其他菜单或基本对象，如单选按钮，复选框或分隔符。 例如，应用程序可能具有包含“剪切”和“粘贴”的菜单项的“编辑”菜单。
        另请参见：
        MENU_BAR ， MENU_ITEM ， SEPARATOR ， RADIO_BUTTON ， CHECK_BOX ， POPUP_MENU

      • MENU_ITEM

        public static final AccessibleRole MENU_ITEM
        一个通常包含在菜单中的对象，呈现用户可以选择的动作。 例如，“编辑”菜单中的“剪切”菜单项将是用户可以选择剪切文档中所选区域的动作。
        另请参见：
        MENU_BAR ， SEPARATOR ， POPUP_MENU

      • SEPARATOR

        public static final AccessibleRole SEPARATOR
        通常包含在菜单中的对象以提供菜单中的内容的视觉和逻辑分离。 例如，应用程序的“文件”菜单可能包含“打开”，“关闭”和“退出”的菜单项，并在“关闭”和“退出”菜单项之间放置一个分隔符。
        另请参见：
        MENU ， MENU_ITEM

      • PAGE_TAB_LIST

        public static final AccessibleRole PAGE_TAB_LIST
        一个对象，通过对象提供的一些机制，一次显示一系列面板（或页面选项卡）。 最常见的机制是面板顶部的选项卡列表。 页面选项卡列表的子项都是页面选项卡。
        另请参见：
        PAGE_TAB

      • PAGE_TAB

        public static final AccessibleRole PAGE_TAB
        作为页面选项卡列表的子对象。 其唯一的孩子是当用户从页面选项卡列表中的选项卡列表中选择页面选项卡时，将显示给用户的面板。
        另请参见：
        PAGE_TAB_LIST

      • PANEL

        public static final AccessibleRole PANEL
        通常用于分组对象的通用容器。

      • PROGRESS_BAR

        public static final AccessibleRole PROGRESS_BAR
        用于指示任务已完成多少的对象。

      • PASSWORD_TEXT

        public static final AccessibleRole PASSWORD_TEXT
        用于密码的文本对象，或文本内容未被显示给用户的其他地方。

      • PUSH_BUTTON

        public static final AccessibleRole PUSH_BUTTON
        用户可以操纵的对象来告诉应用程序做某事。
        另请参见：
        CHECK_BOX ， TOGGLE_BUTTON ， RADIO_BUTTON

      • TOGGLE_BUTTON

        public static final AccessibleRole TOGGLE_BUTTON
        可以检查或取消选中的专用按钮，但不提供当前状态的单独指示器。
        另请参见：
        PUSH_BUTTON ， CHECK_BOX ， RADIO_BUTTON

      • CHECK_BOX

        public static final AccessibleRole CHECK_BOX
        可以选中或取消选中的选项，并为当前状态提供单独的指示符。
        另请参见：
        PUSH_BUTTON ， TOGGLE_BUTTON ， RADIO_BUTTON

      • RADIO_BUTTON

        public static final AccessibleRole RADIO_BUTTON
        一个专门的复选框将导致同一组中的其他单选按钮在选中时被取消选中。
        另请参见：
        PUSH_BUTTON ， TOGGLE_BUTTON ， CHECK_BOX

      • ROW_HEADER

        public static final AccessibleRole ROW_HEADER
        一行数据的标题。

      • SCROLL_PANE

        public static final AccessibleRole SCROLL_PANE
        允许用户逐步查看大量信息的对象。 它的孩子可以包括滚动条和视口。
        另请参见：
        SCROLL_BAR ， VIEWPORT

      • SCROLL_BAR

        public static final AccessibleRole SCROLL_BAR
        通常用于允许用户递增地查看大量数据的对象。 通常仅由滚动窗格使用。
        另请参见：
        SCROLL_PANE

      • VIEWPORT

        public static final AccessibleRole VIEWPORT
        通常在滚动窗格中使用的对象。 它表示用户可以看到的整个数据的部分。 当用户操纵滚动条时，视口的内容可以改变。
        另请参见：
        SCROLL_PANE

      • SLIDER

        public static final AccessibleRole SLIDER
        允许用户从有界范围内进行选择的对象。 例如，可以使用滑块来选择0到100之间的数字。

      • SPLIT_PANE

        public static final AccessibleRole SPLIT_PANE
        同时提供另外两个面板的专门面板。 在两个面板之间是用户可以操纵的分隔线，使一个面板更大，另一个面板更小。

      • TABLE

        public static final AccessibleRole TABLE
        用于根据行和列提供信息的对象。 一个例子可能包括电子表格应用程序。

      • TEXT

        public static final AccessibleRole TEXT
        向用户显示文本的对象。 该文本通常可由用户编辑，而不是标签。
        另请参见：
        LABEL

      • TREE

        public static final AccessibleRole TREE
        用于向用户呈现分层信息的对象。 树中的各个节点可以被折叠和扩展，以提供树的内容的选择性披露。

      • TOOL_BAR

        public static final AccessibleRole TOOL_BAR
        通常由按钮或切换按钮组成的酒吧或调色板。 它通常用于为应用程序提供最常用的功能。

      • TOOL_TIP

        public static final AccessibleRole TOOL_TIP
        提供有关另一个对象的信息的对象。 当用户使鼠标悬停在与工具提示相关联的对象上时，工具提示的accessibleDescription属性通常会以小的“帮助气泡”显示给用户。

      • AWT_COMPONENT

        public static final AccessibleRole AWT_COMPONENT
        一个AWT组件，但没有其他的知道它。
        另请参见：
        SWING_COMPONENT ， UNKNOWN

      • SWING_COMPONENT

        public static final AccessibleRole SWING_COMPONENT
        一个Swing组件，但没有其他的知道它。
        另请参见：
        AWT_COMPONENT ， UNKNOWN

      • UNKNOWN

        public static final AccessibleRole UNKNOWN
        该对象包含一些 Accessible信息，但其作用尚不清楚。
        另请参见：
        AWT_COMPONENT ， SWING_COMPONENT

      • STATUS_BAR

        public static final AccessibleRole STATUS_BAR
        A STATUS_BAR是可以向用户包含多个状态信息标签的简单组件。

      • DATE_EDITOR

        public static final AccessibleRole DATE_EDITOR
        A DATE_EDITOR是允许用户编辑 java.util.Date和 java.util.Time对象的组件。

      • SPIN_BOX

        public static final AccessibleRole SPIN_BOX
        A SPIN_BOX是一个简单的微调组件，其主要用途是简单的数字。

      • FONT_CHOOSER

        public static final AccessibleRole FONT_CHOOSER
        A FONT_CHOOSER是一个组件，可让用户为字体选择各种属性。

      • GROUP_BOX

        public static final AccessibleRole GROUP_BOX
        A GROUP_BOX是一个简单的容器，其中包含一个边框，并在其中包含组件。

      • HEADER

        public static final AccessibleRole HEADER
        文字标题
        从以下版本开始：
        1.5

      • FOOTER

        public static final AccessibleRole FOOTER
        文字页脚。
        从以下版本开始：
        1.5

      • PARAGRAPH

        public static final AccessibleRole PARAGRAPH
        一段文字。
        从以下版本开始：
        1.5

      • RULER

        public static final AccessibleRole RULER
        标尺是用于测量距离的对象。
        从以下版本开始：
        1.5

      • EDITBAR

        public static final AccessibleRole EDITBAR
        指示对象的角色用作计算值的公式。 一个例子是电子表格单元格中的公式。
        从以下版本开始：
        1.5

      • PROGRESS_MONITOR

        public static final AccessibleRole PROGRESS_MONITOR
        指示对象的角色监视某些操作的进度。
        从以下版本开始：
        1.5

    • 构造方法详细信息

      • AccessibleRole

        protected AccessibleRole​(String key)
        使用给定的区域设置独立键创建一个新的AccessibleRole 。 这不应该是公共的方法。 相反，它用于创建此文件中的常量以使其成为强类型枚举。 这个类的子类应该执行类似的策略。

        密钥String应该是角色的区域设置独立密钥。 它不是用作实际显示给用户的String 。 要获取本地化的字符串，请使用AccessibleBundle.toDisplayString() 。

        参数
        key - 角色的区域设置独立名称
        另请参见：
        AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleSelection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleSelection

  • 所有已知实现类：
    CheckboxMenuItem.AccessibleAWTCheckboxMenuItem ， JComboBox.AccessibleJComboBox ， JList.AccessibleJList ， JMenu.AccessibleJMenu ， JMenuBar.AccessibleJMenuBar ， JTabbedPane.AccessibleJTabbedPane ， JTable.AccessibleJTable ， JTree.AccessibleJTree ， JTree.AccessibleJTree.AccessibleJTreeNode ， List.AccessibleAWTList ， Menu.AccessibleAWTMenu ， MenuBar.AccessibleAWTMenuBar ， MenuComponent.AccessibleAWTMenuComponent ， MenuItem.AccessibleAWTMenuItem ， PopupMenu.AccessibleAWTPopupMenu

    public interface AccessibleSelection
    该AccessibleSelection接口提供了辅助技术的标准机制，以确定当前所选择的孩子是什么，以及修改选择集。 任何可以选择子项的对象都应该支持AccessibleSelection接口。 应用程序可以首先获得AccessibleContext （见Accessible ），然后调用AccessibleContext.getAccessibleSelection()方法来确定对象是否支持AccessibleSelection接口。 如果返回值不是null ，则该对象支持该接口。
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleContext.getAccessibleSelection()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addAccessibleSelection​(int i)
      将对象的指定的 Accessible子对象添加到对象的选择中。
      void clearAccessibleSelection​()
      清除对象中的选择，以使对象中没有子对象被选中。
      Accessible getAccessibleSelection​(int i)
      返回表示对象的指定选定子对象的 Accessible 。
      int getAccessibleSelectionCount​()
      返回当前选择的 Accessible孩子的数量。
      boolean isAccessibleChildSelected​(int i)
      确定是否选择了此对象的当前子级。
      void removeAccessibleSelection​(int i)
      从对象的选择中删除对象的指定子对象。
      void selectAllAccessibleSelection​()
      如果对象支持多个选择，则导致选择对象的每个子对象。

    • 方法详细信息

      • getAccessibleSelectionCount

        int getAccessibleSelectionCount​()
        返回当前选择的Accessible孩子的数量。 如果没有选择小孩，则返回值为0。
        结果
        当前选择的项目数

      • getAccessibleSelection

        Accessible getAccessibleSelection​(int i)
        返回表示对象的指定选定子对象的Accessible 。 如果没有选择，或者选择的孩子比传入的整数少，则返回值将为null 。

        请注意，该索引代表第i个所选子项，该子与第i个子不同。

        参数
        i - 所选子女的从零开始的索引
        结果
        第i个选定的孩子
        另请参见：
        getAccessibleSelectionCount()

      • isAccessibleChildSelected

        boolean isAccessibleChildSelected​(int i)
        确定是否选择了此对象的当前子级。
        参数
        i - 这个 Accessible对象中的小孩的从零开始的索引
        结果
        true如果选择了该对象的当前子对象; 其他false
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        void addAccessibleSelection​(int i)
        添加指定Accessible子对象的对象的选择。 如果对象支持多个选择，则指定的子项将添加到任何现有的选择中，否则将替换对象中的任何现有选择。 如果指定的子项已被选中，则此方法无效。
        参数
        i - 小孩的从零开始的索引
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • removeAccessibleSelection

        void removeAccessibleSelection​(int i)
        从对象的选择中删除对象的指定子对象。 如果当前未选择指定的项目，则此方法无效。
        参数
        i - 小孩的从零开始的索引
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        void clearAccessibleSelection​()
        清除对象中的选择，以使对象中没有子对象被选中。

      • selectAllAccessibleSelection

        void selectAllAccessibleSelection​()
        如果对象支持多个选择，则导致选择对象的每个子对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleState (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleState

  • java.lang.Object
    • javax.accessibility.AccessibleBundle
      • javax.accessibility.AccessibleState

  • public class AccessibleState
extends AccessibleBundle
    AccessibleState类描述了组件的特定状态。 组件的实际状态定义为AccessibleStateSet ，它是一组AccessibleStates 。

    AccessibleBundle.toDisplayString()方法允许您从ResourceBundle中定义的键从预定义的ResourceBundle获取与区域设置无关的键的本地化字符串。

    这个类中的常量表现出强类型的普通对象角色枚举。 这个类的公共构造函数被有意地省略，应用程序应该使用这个类的一个常量。 如果此类中的常量不足以描述对象的角色，则应从此类生成子类，并应以类似的方式提供常量。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static AccessibleState ACTIVE
      表示窗口当前是活动窗口。
      static AccessibleState ARMED
      表示对象已布防。
      static AccessibleState BUSY
      表示当前对象正在忙。
      static AccessibleState CHECKED
      表示此对象当前已被选中。
      static AccessibleState COLLAPSED
      表示此对象已折叠。
      static AccessibleState EDITABLE
      表示用户可以更改此对象的内容。
      static AccessibleState ENABLED
      表示此对象已启用。
      static AccessibleState EXPANDABLE
      表示此对象允许逐渐披露其子项。
      static AccessibleState EXPANDED
      表示此对象已展开。
      static AccessibleState FOCUSABLE
      表示此对象可以接受键盘焦点，这意味着通过在键盘上打字产生的所有事件通常会在焦点时传递给它。
      static AccessibleState FOCUSED
      表示此对象当前具有键盘焦点。
      static AccessibleState HORIZONTAL
      表示此对象的方向是水平的。
      static AccessibleState ICONIFIED
      表示此对象被最小化，仅由图标表示。
      static AccessibleState INDETERMINATE
      表示对象状态不确定。
      static AccessibleState MANAGES_DESCENDANTS
      表示此对象负责管理其子组件。
      static AccessibleState MODAL
      在用户可以与不同窗口中的对象进行交互之前，表示必须使用此对象完成任务。
      static AccessibleState MULTI_LINE
      表示此（文本）对象可以包含多行文本。
      static AccessibleState MULTISELECTABLE
      表示此对象允许同时选择多个子项。
      static AccessibleState OPAQUE
      表示此对象绘制其矩形区域内的每个像素。
      static AccessibleState PRESSED
      表示此对象当前按下。
      static AccessibleState RESIZABLE
      表示此对象的大小不固定。
      static AccessibleState SELECTABLE
      表示此对象是允许其子项被选中的对象的子对象，并且该子对象是可选择的其中一个子对象。
      static AccessibleState SELECTED
      表示此对象是允许其子项被选中的对象的子对象，并且该子对象是已选择的其中一个子对象。
      static AccessibleState SHOWING
      表示此对象，对象的父对象，父对象的父对象等都可见。
      static AccessibleState SINGLE_LINE
      表示此（文本）对象只能包含一行文本。
      static AccessibleState TRANSIENT
      表示此对象是短暂的。
      static AccessibleState TRUNCATED
      指示文本被边框矩形截断并且某些文本不显示在屏幕上的状态。
      static AccessibleState VERTICAL
      表示此对象的方向是垂直的。
      static AccessibleState VISIBLE
      表示此对象可见。

      • Fields inherited from class javax.accessibility.AccessibleBundle

        key

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AccessibleState​(String key)
      使用给定的区域设置独立键创建一个新的 AccessibleState 。

    • 方法摘要

      • Methods inherited from class javax.accessibility.AccessibleBundle

        toDisplayString, toDisplayString, toDisplayString, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ACTIVE

        public static final AccessibleState ACTIVE
        表示窗口当前是活动窗口。 这包括窗口，对话框，框架等。此外，此状态用于指示组件（如列表，表或树）的当前活动子项。 例如，列表的活动子项是在其周围绘制一个矩形的小孩。
        另请参见：
        AccessibleRole.WINDOW ， AccessibleRole.FRAME ， AccessibleRole.DIALOG

      • PRESSED

        public static final AccessibleState PRESSED
        表示此对象当前按下。 这通常与按钮相关联，并指示用户在指针在按钮上方按下鼠标按钮，但尚未释放鼠标按钮。
        另请参见：
        AccessibleRole.PUSH_BUTTON

      • ARMED

        public static final AccessibleState ARMED
        表示对象已布防。 这通常用于按下但尚未释放的按钮，鼠标指针仍然在按钮上。
        另请参见：
        AccessibleRole.PUSH_BUTTON

      • BUSY

        public static final AccessibleState BUSY
        表示当前对象正在忙。 这通常用于诸如进度条，滑块或滚动条之类的对象，以指示它们处于转换状态。
        另请参见：
        AccessibleRole.PROGRESS_BAR ， AccessibleRole.SCROLL_BAR ， AccessibleRole.SLIDER

      • CHECKED

        public static final AccessibleState CHECKED
        表示此对象当前已被选中。 这通常用于诸如切换按钮，单选按钮和复选框的对象。
        另请参见：
        AccessibleRole.TOGGLE_BUTTON ， AccessibleRole.RADIO_BUTTON ， AccessibleRole.CHECK_BOX

      • EDITABLE

        public static final AccessibleState EDITABLE
        表示用户可以更改此对象的内容。 这通常主要用于允许用户输入文本的对象。 如果启用了其他对象，例如滚动条和滑块，则可以自动编辑。
        另请参见：
        ENABLED

      • EXPANDABLE

        public static final AccessibleState EXPANDABLE
        表示此对象允许逐渐披露其子项。 这通常与分层对象（如树）一起使用，并且通常与EXPANDED或COLLAPSED状态配对。
        另请参见：
        EXPANDED ， COLLAPSED ， AccessibleRole.TREE

      • COLLAPSED

        public static final AccessibleState COLLAPSED
        表示此对象已折叠。 这通常与EXPANDABLE状态配对，并用于提供渐进式披露的对象，如树。
        另请参见：
        EXPANDABLE ， EXPANDED ， AccessibleRole.TREE

      • EXPANDED

        public static final AccessibleState EXPANDED
        表示此对象已展开。 这通常与EXPANDABLE状态配对，并用于提供渐进式披露的对象，如树。
        另请参见：
        EXPANDABLE ， COLLAPSED ， AccessibleRole.TREE

      • ENABLED

        public static final AccessibleState ENABLED
        表示此对象已启用。 从对象的状态集中缺少此状态表示此对象未启用。 未启用的对象不能被用户操纵。 在图形显示中，通常会显示为灰色。

      • FOCUSABLE

        public static final AccessibleState FOCUSABLE
        表示此对象可以接受键盘焦点，这意味着通过在键盘上打字产生的所有事件通常会在焦点时传递给它。
        另请参见：
        FOCUSED

      • FOCUSED

        public static final AccessibleState FOCUSED
        表示此对象当前具有键盘焦点。
        另请参见：
        FOCUSABLE

      • ICONIFIED

        public static final AccessibleState ICONIFIED
        表示此对象被最小化，仅由图标表示。 这通常只与帧和内部帧相关联。
        另请参见：
        AccessibleRole.FRAME ， AccessibleRole.INTERNAL_FRAME

      • MODAL

        public static final AccessibleState MODAL
        在用户可以与不同窗口中的对象进行交互之前，表示必须使用此对象完成任务。 这通常只与对话框相关联。
        另请参见：
        AccessibleRole.DIALOG

      • OPAQUE

        public static final AccessibleState OPAQUE
        表示此对象绘制其矩形区域内的每个像素。 非不透明组件仅绘制其一些像素，允许其下方的像素“显示”。 因此，不完全绘制其像素的组件提供了一定程度的透明度。
        另请参见：
        Accessible.getAccessibleContext() ，
AccessibleContext.getAccessibleComponent() ，
AccessibleComponent.getBounds()

      • RESIZABLE

        public static final AccessibleState RESIZABLE
        表示此对象的大小不固定。
        另请参见：
        Accessible.getAccessibleContext() ，
AccessibleContext.getAccessibleComponent() ，
AccessibleComponent.getSize() ，
AccessibleComponent.setSize(java.awt.Dimension)

      • MULTISELECTABLE

        public static final AccessibleState MULTISELECTABLE
        表示此对象允许同时选择多个子项。
        另请参见：
        Accessible.getAccessibleContext() ， AccessibleContext.getAccessibleSelection() ， AccessibleSelection

      • SELECTABLE

        public static final AccessibleState SELECTABLE
        表示此对象是允许其子项被选中的对象的子对象，并且该子对象是可选择的其中一个子对象。
        另请参见：
        SELECTED ， Accessible.getAccessibleContext() ， AccessibleContext.getAccessibleSelection() ， AccessibleSelection

      • SELECTED

        public static final AccessibleState SELECTED
        表示此对象是允许其子项被选中的对象的子对象，并且该子对象是已选择的其中一个子对象。
        另请参见：
        SELECTABLE ， Accessible.getAccessibleContext() ， AccessibleContext.getAccessibleSelection() ， AccessibleSelection

      • SHOWING

        public static final AccessibleState SHOWING
        表示此对象，对象的父对象，父对象的父对象等都可见。 请注意，这并不一定意味着对象被画在屏幕上。 它可能被一些其他显示对象遮挡。
        另请参见：
        VISIBLE

      • VISIBLE

        public static final AccessibleState VISIBLE
        表示此对象可见。 注意：这意味着该对象意图可见; 然而，它可能不会在屏幕上显示，因为该对象包含的对象之一是不可见的。
        另请参见：
        SHOWING

      • VERTICAL

        public static final AccessibleState VERTICAL
        表示此对象的方向是垂直的。 这通常与诸如滚动条，滑块和进度条的对象相关联。
        另请参见：
        VERTICAL ， AccessibleRole.SCROLL_BAR ， AccessibleRole.SLIDER ， AccessibleRole.PROGRESS_BAR

      • HORIZONTAL

        public static final AccessibleState HORIZONTAL
        表示此对象的方向是水平的。 这通常与诸如滚动条，滑块和进度条的对象相关联。
        另请参见：
        HORIZONTAL ， AccessibleRole.SCROLL_BAR ， AccessibleRole.SLIDER ， AccessibleRole.PROGRESS_BAR

      • SINGLE_LINE

        public static final AccessibleState SINGLE_LINE
        表示此（文本）对象只能包含一行文本。

      • MULTI_LINE

        public static final AccessibleState MULTI_LINE
        表示此（文本）对象可以包含多行文本。

      • TRANSIENT

        public static final AccessibleState TRANSIENT
        表示此对象是短暂的。 辅助技术不应该将PropertyChange监听器添加到具有瞬态状态的对象中，因为该对象永远不会生成任何事件。 通常创建瞬态对象以回答Java辅助功能方法查询，但是否则不会保持链接到底层对象（例如，Swing中的列表，表和树下的那些对象，其中只有一个实际的UI Component对所有的实际列表/表/树元素下的数据对象）。
        从以下版本开始：
        1.5

      • MANAGES_DESCENDANTS

        public static final AccessibleState MANAGES_DESCENDANTS
        表示此对象负责管理其子组件。 这通常用于具有大量子组件的树和表，并且仅在需要时才创建对象，否则保留虚拟。 应用程序不应直接管理子组件。
        从以下版本开始：
        1.5

      • INDETERMINATE

        public static final AccessibleState INDETERMINATE
        表示对象状态不确定。 一个示例是部分粗体，部分不粗体的选定文本。 在这种情况下，与所选文本相关联的属性是不确定的。
        从以下版本开始：
        1.5

      • TRUNCATED

        public static final AccessibleState TRUNCATED
        指示文本被边框矩形截断并且某些文本不显示在屏幕上的状态。 一个例子是电子表格单元格中被单元格边界截断的文本。
        从以下版本开始：
        1.5

    • 构造方法详细信息

      • AccessibleState

        protected AccessibleState​(String key)
        使用给定的区域设置独立键创建一个新的AccessibleState 。 这不应该是公共的方法。 相反，它用于创建此文件中的常量以使其成为强类型枚举。 这个类的子类应该执行类似的策略。

        密钥String应该是状态的区域设置独立密钥。 它不是用作实际的String来显示给用户。 要获取本地化的字符串，请使用AccessibleBundle.toDisplayString() 。

        参数
        key - 状态的区域设置独立名称
        另请参见：
        AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleStateSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleStateSet

  • java.lang.Object
    • javax.accessibility.AccessibleStateSet

  • public class AccessibleStateSet
extends Object
    AccessibleStateSet类确定组件的状态集。 组件的状态集是一组AccessibleState对象和描述。 EG，对象的当前整体状态，如是否启用，具有焦点等。
    另请参见：
    AccessibleState

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Vector<AccessibleState> states
      Vector每个条目代表 AccessibleState 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleStateSet​()
      创建一个新的空状态集。
      AccessibleStateSet​(AccessibleState[] states)
      创建一个新状态，其中包含在状态数组中的初始状态集合。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(AccessibleState state)
      如果当前状态集不存在，则添加一个新状态。
      void addAll​(AccessibleState[] states)
      将所有状态添加到现有状态集。
      void clear​()
      从当前状态集中删除所有状态。
      boolean contains​(AccessibleState state)
      检查当前状态是否处于状态集。
      boolean remove​(AccessibleState state)
      从当前状态集中删除状态。
      AccessibleState[] toArray​()
      将当前状态设置为 AccessibleState的数组。
      String toString​()
      使用默认语言环境创建表示集合中所有状态的本地化字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • states

        protected Vector<AccessibleState> states
        Vector每个条目代表 AccessibleState 。
        另请参见：
        add(javax.accessibility.AccessibleState) ，
addAll(javax.accessibility.AccessibleState[]) ，
remove(javax.accessibility.AccessibleState) ，
contains(javax.accessibility.AccessibleState) ，
toArray() ，
clear()

    • 构造方法详细信息

      • AccessibleStateSet

        public AccessibleStateSet​()
        创建一个新的空状态集。

      • AccessibleStateSet

        public AccessibleStateSet​(AccessibleState[] states)
        创建一个新状态，其中包含在传入的状态数组中的初始状态集。重复的条目将被忽略。
        参数
        states - 描述状态集的 AccessibleState的数组

    • 方法详细信息

      • add

        public boolean add​(AccessibleState state)
        如果当前状态集不存在，则添加一个新状态。 如果状态已经处于状态集，状态集不变，返回值为false 。 否则，将状态添加到状态集，返回值为true 。
        参数
        state - 要添加到状态集的状态
        结果
        true如果状态被添加到状态集; false如果状态设置不变

      • addAll

        public void addAll​(AccessibleState[] states)
        将所有状态添加到现有状态集。 重复的条目将被忽略。
        参数
        states - AccessibleState描述状态集的数组

      • remove

        public boolean remove​(AccessibleState state)
        从当前状态集中删除状态。 如果状态不在集合中，则状态集将不变，返回值为false 。 如果状态处于设置状态，它将从集合中删除，返回值将为true 。
        参数
        state - 从状态集中删除的状态
        结果
        true如果状态处于状态集; false如果状态集将不变

      • clear

        public void clear​()
        从当前状态集中删除所有状态。

      • contains

        public boolean contains​(AccessibleState state)
        检查当前状态是否处于状态集。
        参数
        state - 状态
        结果
        true如果状态处于状态集; 否则false

      • toArray

        public AccessibleState[] toArray​()
        将当前状态设置为 AccessibleState的数组。
        结果
        AccessibleState包含当前状态的数组

      • toString

        public String toString​()
        使用默认语言环境创建表示集合中所有状态的本地化字符串。
        重写：
        toString在 Object
        结果
        逗号分隔本地化字符串
        另请参见：
        AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleStreamable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleStreamable

  • public interface AccessibleStreamable
    所述AccessibleStreamable接口应该由实施AccessibleContext呈现在显示屏幕上的部件的后面的原始流的任何组分。 这些组件的示例是HTML，位图图像和MathML。 实现AccessibleStreamable的对象提供两件事情：对象支持的MIME类型列表以及每个MIME类型的流接口以获取数据。
    从以下版本开始：
    1.5
    另请参见：
    AccessibleContext

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      DataFlavor[] getMimeTypes​()
      为此对象支持的MIME类型返回一个 DataFlavor对象的数组。
      InputStream getStream​(DataFlavor flavor)
      为 InputStream返回 DataFlavor 。

    • 方法详细信息

      • getMimeTypes

        DataFlavor[] getMimeTypes​()
        返回此对象支持的MIME类型的 DataFlavor对象的数组。
        结果
        一个 DataFlavor对象的数组，用于此对象支持的MIME类型

      • getStream

        InputStream getStream​(DataFlavor flavor)
        为 InputStream返回 DataFlavor 。
        参数
        flavor - DataFlavor
        结果
        一个ImputStream如果这个DataFlavor的输入流存在。 否则返回null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleTable

  • All Known Subinterfaces:
    AccessibleExtendedTable
    所有已知实现类：
    JTable.AccessibleJTable

    public interface AccessibleTable
    AccessibleTable类描述了以二维表格格式显示数据的用户界面组件。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Accessible getAccessibleAt​(int r, int c)
      返回表中指定行和列的 Accessible 。
      Accessible getAccessibleCaption​()
      返回表的标题。
      int getAccessibleColumnCount​()
      返回表中的列数。
      Accessible getAccessibleColumnDescription​(int c)
      返回表中指定列的描述文本。
      int getAccessibleColumnExtentAt​(int r, int c)
      返回表中指定行和列的 Accessible占用的列数。
      AccessibleTable getAccessibleColumnHeader​()
      返回列标题为 AccessibleTable 。
      int getAccessibleRowCount​()
      返回表中的行数。
      Accessible getAccessibleRowDescription​(int r)
      返回表中指定行的描述。
      int getAccessibleRowExtentAt​(int r, int c)
      返回表中指定行和列的 Accessible占用的行数。
      AccessibleTable getAccessibleRowHeader​()
      返回行标题为 AccessibleTable 。
      Accessible getAccessibleSummary​()
      返回表的摘要说明。
      int[] getSelectedAccessibleColumns​()
      返回表中选定的列。
      int[] getSelectedAccessibleRows​()
      返回表中选定的行。
      boolean isAccessibleColumnSelected​(int c)
      返回一个布尔值，指示是否选择了指定的列。
      boolean isAccessibleRowSelected​(int r)
      返回一个布尔值，指示是否选择了指定的行。
      boolean isAccessibleSelected​(int r, int c)
      返回一个布尔值，指示是否选择了在指定的行和列可访问。
      void setAccessibleCaption​(Accessible a)
      设置表格的标题。
      void setAccessibleColumnDescription​(int c, Accessible a)
      设置表中指定列的描述文本。
      void setAccessibleColumnHeader​(AccessibleTable table)
      设置列标题。
      void setAccessibleRowDescription​(int r, Accessible a)
      设置表的指定行的描述文本。
      void setAccessibleRowHeader​(AccessibleTable table)
      设置行标题。
      void setAccessibleSummary​(Accessible a)
      设置表的摘要说明。

    • 方法详细信息

      • getAccessibleCaption

        Accessible getAccessibleCaption​()
        返回表的标题。
        结果
        表的标题

      • setAccessibleCaption

        void setAccessibleCaption​(Accessible a)
        设置表格的标题。
        参数
        a - 表格的标题

      • getAccessibleSummary

        Accessible getAccessibleSummary​()
        返回表的摘要说明。
        结果
        表的总结描述

      • setAccessibleSummary

        void setAccessibleSummary​(Accessible a)
        设置表的摘要说明。
        参数
        a - 表的简要说明

      • getAccessibleRowCount

        int getAccessibleRowCount​()
        返回表中的行数。
        结果
        表中的行数

      • getAccessibleColumnCount

        int getAccessibleColumnCount​()
        返回表中的列数。
        结果
        表中的列数

      • getAccessibleAt

        Accessible getAccessibleAt​(int r,
                           int c)
        返回表中指定行和列的 Accessible 。
        参数
        r - 从零开始的一行表
        c - 表的零基列
        结果
        在指定的行和列的 Accessible

      • getAccessibleRowExtentAt

        int getAccessibleRowExtentAt​(int r,
                             int c)
        返回表中指定行和列的 Accessible占用的行数。
        参数
        r - 从零开始的一行表
        c - 从零开始的列表
        结果
        在给定的指定（行，列） Accessible占用的行数为 Accessible

      • getAccessibleColumnExtentAt

        int getAccessibleColumnExtentAt​(int r,
                                int c)
        返回表中指定行和列的 Accessible占用的列数。
        参数
        r - 表的零为一行
        c - 表的零基列
        结果
        给定指定行和列的 Accessible占用的列数

      • getAccessibleRowHeader

        AccessibleTable getAccessibleRowHeader​()
        返回行标题为 AccessibleTable 。
        结果
        一个表示行标题的 AccessibleTable

      • setAccessibleRowHeader

        void setAccessibleRowHeader​(AccessibleTable table)
        设置行标题。
        参数
        table - 表示行标题的 AccessibleTable

      • getAccessibleColumnHeader

        AccessibleTable getAccessibleColumnHeader​()
        返回列标题为 AccessibleTable 。
        结果
        一个表示列标题的 AccessibleTable

      • setAccessibleColumnHeader

        void setAccessibleColumnHeader​(AccessibleTable table)
        设置列标题。
        参数
        table - 一个表示列标题的 AccessibleTable

      • getAccessibleRowDescription

        Accessible getAccessibleRowDescription​(int r)
        返回表中指定行的描述。
        参数
        r - 表的零为一行
        结果
        行的描述

      • setAccessibleRowDescription

        void setAccessibleRowDescription​(int r,
                                 Accessible a)
        设置表的指定行的描述文本。
        参数
        r - 表的零为一行
        a - 行的描述

      • getAccessibleColumnDescription

        Accessible getAccessibleColumnDescription​(int c)
        返回表中指定列的描述文本。
        参数
        c - 表的零基列
        结果
        列的文本描述

      • setAccessibleColumnDescription

        void setAccessibleColumnDescription​(int c,
                                    Accessible a)
        设置表中指定列的描述文本。
        参数
        c - 表的零基列
        a - 列的文本描述

      • isAccessibleSelected

        boolean isAccessibleSelected​(int r,
                             int c)
        返回一个布尔值，指示是否选择了在指定的行和列可访问。
        参数
        r - 表的零为一行
        c - 表的零基列
        结果
        布尔值true如果行和列可访问。 否则，布尔值为false

      • isAccessibleRowSelected

        boolean isAccessibleRowSelected​(int r)
        返回一个布尔值，指示是否选择了指定的行。
        参数
        r - 表的零为一行
        结果
        布尔值true如果指定的行被选中。 否则， false 。

      • isAccessibleColumnSelected

        boolean isAccessibleColumnSelected​(int c)
        返回一个布尔值，指示是否选择了指定的列。
        参数
        c - 从零开始的列表
        结果
        如果指定的列被选中， true布尔值true 。 否则， false 。

      • getSelectedAccessibleRows

        int[] getSelectedAccessibleRows​()
        返回表中选定的行。
        结果
        所选列的数组，其中每个元素都是表的基于零的行

      • getSelectedAccessibleColumns

        int[] getSelectedAccessibleColumns​()
        返回表中选定的列。
        结果
        所选列的数组，其中每个元素都是表的从零开始的列
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AccessibleTableModelChange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleTableModelChange

  • 所有已知实现类：
    JTable.AccessibleJTable.AccessibleJTableModelChange

    public interface AccessibleTableModelChange
    AccessibleTableModelChange界面描述了对表模型的更改。 模型变化的属性可以通过以下方法获得：
    • public int getType();
    • public int getFirstRow();
    • public int getLastRow();
    • public int getFirstColumn();
    • public int getLastColumn();
    getType（）返回的模型更改类型将是以下之一：
    • INSERT - 已插入一个或多个行和/或列
    • UPDATE - 某些表数据已更改
    • DELETE - 一个或多个行和/或列已被删除
    表的受影响区域可以由指定行和列范围的其他四种方法确定
    从以下版本开始：
    1.3
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleContext.getAccessibleTable()

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DELETE
      标识行和/或列的删除。
      static int INSERT
      标识新行和/或列的插入。
      static int UPDATE
      标识对现有数据的更改。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getFirstColumn​()
      返回更改的第一列。
      int getFirstRow​()
      返回更改的第一行。
      int getLastColumn​()
      返回更改的最后一列。
      int getLastRow​()
      返回更改的最后一行。
      int getType​()
      返回事件的类型。

    • 字段详细信息

      • INSERT

        static final int INSERT
        标识新行和/或列的插入。
        另请参见：
        Constant Field Values

      • UPDATE

        static final int UPDATE
        标识对现有数据的更改。
        另请参见：
        Constant Field Values

      • DELETE

        static final int DELETE
        标识行和/或列的删除。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getType

        int getType​()
        返回事件的类型。
        结果
        事件的类型
        另请参见：
        INSERT ， UPDATE ， DELETE

      • getFirstRow

        int getFirstRow​()
        返回更改的第一行。
        结果
        第一行更改

      • getLastRow

        int getLastRow​()
        返回更改的最后一行。
        结果
        最后一行更改

      • getFirstColumn

        int getFirstColumn​()
        返回更改的第一列。
        结果
        第一列改变了

      • getLastColumn

        int getLastColumn​()
        返回更改的最后一列。
        结果
        最后一列更改
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleText (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleText

  • All Known Subinterfaces:
    AccessibleEditableText ， AccessibleHypertext
    所有已知实现类：
    AbstractButton.AccessibleAbstractButton ， JButton.AccessibleJButton ， JCheckBox.AccessibleJCheckBox ， JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem ， JEditorPane.AccessibleJEditorPane ， JEditorPane.AccessibleJEditorPaneHTML ， JEditorPane.JEditorPaneAccessibleHypertextSupport ， JLabel.AccessibleJLabel ， JMenu.AccessibleJMenu ， JMenuItem.AccessibleJMenuItem ， JPasswordField.AccessibleJPasswordField ， JRadioButton.AccessibleJRadioButton ， JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem ， JSpinner.AccessibleJSpinner ， JTextArea.AccessibleJTextArea ， JTextComponent.AccessibleJTextComponent ， JTextField.AccessibleJTextField ， JToggleButton.AccessibleJToggleButton ， ProgressMonitor.AccessibleProgressMonitor ， TextArea.AccessibleAWTTextArea ， TextComponent.AccessibleAWTTextComponent ， TextField.AccessibleAWTTextField

    public interface AccessibleText
    AccessibleText接口应由显示文本信息的所有类实现。 该界面提供了辅助技术通过其内容，属性和空间位置访问该文本的标准机制。 应用程序可确定对象是否支持AccessibleText通过首先获得接口其AccessibleContext （见Accessible ），然后调用AccessibleContext.getAccessibleText()的方法AccessibleContext 。 如果返回值不是null ，则该对象支持该接口。
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleContext.getAccessibleText()

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CHARACTER
      常数用于表示应检索的文本部分是一个字符。
      static int SENTENCE
      常数用于表示应检索的部分文本是一个句子。
      static int WORD
      常数用于表示应检索的文本部分是一个单词。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getAfterIndex​(int part, int index)
      给定索引后返回 String 。
      String getAtIndex​(int part, int index)
      返回给定索引的 String 。
      String getBeforeIndex​(int part, int index)
      返回给定索引前的 String 。
      int getCaretPosition​()
      返回插入符号的从零开始的偏移量。
      AttributeSet getCharacterAttribute​(int i)
      给定索引返回给定字符的 AttributeSet 。
      Rectangle getCharacterBounds​(int i)
      将给定索引处的字符的边框确定为字符串。
      int getCharCount​()
      返回字符数（有效指标）。
      int getIndexAtPoint​(Point p)
      给定局部坐标点，返回该点下的字符的从零开始的索引。
      String getSelectedText​()
      返回所选文本的部分。
      int getSelectionEnd​()
      返回所选文本中的结束偏移量。
      int getSelectionStart​()
      返回所选文本中的起始偏移量。

    • 字段详细信息

      • CHARACTER

        static final int CHARACTER
        常数用于表示应检索的文本部分是一个字符。
        另请参见：
        getAtIndex(int, int) ，
getAfterIndex(int, int) ，
getBeforeIndex(int, int) ，
Constant Field Values

      • WORD

        static final int WORD
        常数用于表示应检索的文本部分是一个单词。
        另请参见：
        getAtIndex(int, int) ，
getAfterIndex(int, int) ，
getBeforeIndex(int, int) ，
Constant Field Values

      • SENTENCE

        static final int SENTENCE
        常数用于表示应检索的部分文本是一个句子。

        一句话是一串表达一个断言，一个问题，一个命令，一个愿望，一个感叹号或一个动作的表现的单词。 在英文语言中，字符串通常以大写字母开头，并以适当的结尾标点符号结尾; 例如期间，问题或感叹号。 其他地区可能会使用不同的大小写和/或标点符号。

        另请参见：
        getAtIndex(int, int) ，
getAfterIndex(int, int) ，
getBeforeIndex(int, int) ，
Constant Field Values

    • 方法详细信息

      • getIndexAtPoint

        int getIndexAtPoint​(Point p)
        给定局部坐标点，返回该点下的字符的从零开始的索引。 如果该点无效，此方法返回-1。
        参数
        p - 局部坐标点
        结果
        基于零的索引号为Point p ; 如果点无效返回-1。

      • getCharacterBounds

        Rectangle getCharacterBounds​(int i)
        将给定索引处的字符的边框确定为字符串。 边界以局部坐标返回。 如果索引无效，则返回空矩形。
        参数
        i - 索引到字符串
        结果
        字符的边框的屏幕坐标，如果索引无效返回一个空矩形。

      • getCharCount

        int getCharCount​()
        返回字符数（有效指标）。
        结果
        字符数

      • getCaretPosition

        int getCaretPosition​()
        返回插入符号的从零开始的偏移量。

        注意：插入符号右侧的索引值将与偏移量相同（插入符号在两个字符之间）。

        结果
        插入符号的零基偏移量

      • getAtIndex

        String getAtIndex​(int part,
                  int index)
        返回给定索引的 String 。
        参数
        part - 要检索的CHARACTER，WORD或SENTENCE
        index - 文本中的索引
        结果
        信，字或句子

      • getAfterIndex

        String getAfterIndex​(int part,
                     int index)
        给定索引后返回 String 。
        参数
        part - 要检索的CHARACTER，WORD或SENTENCE
        index - 文本中的索引
        结果
        信，字或句子

      • getBeforeIndex

        String getBeforeIndex​(int part,
                      int index)
        返回给定索引前的 String 。
        参数
        part - 要检索的CHARACTER，WORD或SENTENCE
        index - 文本中的索引
        结果
        信，字或句子

      • getCharacterAttribute

        AttributeSet getCharacterAttribute​(int i)
        给定索引的给定字符返回 AttributeSet 。
        参数
        i - 文本中的从零开始的索引
        结果
        的 AttributeSet

      • getSelectionStart

        int getSelectionStart​()
        返回所选文本中的起始偏移量。 如果没有选择，但是有一个插入符号，开始和结束偏移将是一样的。
        结果
        索引进入文本的开始选择

      • getSelectionEnd

        int getSelectionEnd​()
        返回所选文本中的结束偏移量。 如果没有选择，但是有一个插入符号，开始和结束偏移将是一样的。
        结果
        索引到文本的结尾的选择

      • getSelectedText

        String getSelectedText​()
        返回所选文本的部分。
        结果
        the String portion of the text that is selected
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleTextSequence (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Class AccessibleTextSequence

  • java.lang.Object
    • javax.accessibility.AccessibleTextSequence

  • public class AccessibleTextSequence
extends Object
    这个类收集了文本跨度的关键细节。 它使用的类的实现者AccessibleExtendedText ，以返回的请求三重String ，并开始和结束indicies /偏移到文本的更大的机构，该String从何而来。
    另请参见：
    AccessibleExtendedText

    • Field Summary

      Fields
      Modifier and Type Field 描述
      int endIndex
      文本序列的结束索引。
      int startIndex
      文本序列的起始索引。
      String text
      文本。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleTextSequence​(int start, int end, String txt)
      构造具有给定参数的 AccessibleTextSequence 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • startIndex

        public int startIndex
        文本序列的起始索引。

      • endIndex

        public int endIndex
        文本序列的结束索引。

      • text

        public String text
        文本。

    • 构造方法详细信息

      • AccessibleTextSequence

        public AccessibleTextSequence​(int start,
                              int end,
                              String txt)
        构造具有给定参数的 AccessibleTextSequence 。
        参数
        start - 文本跨度的起始索引
        end - 文本跨度的结束索引
        txt - String本跨度共享的 String
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


AccessibleValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.accessibility

Interface AccessibleValue

  • 所有已知实现类：
    AbstractButton.AccessibleAbstractButton ， Button.AccessibleAWTButton ， Checkbox.AccessibleAWTCheckbox ， CheckboxMenuItem.AccessibleAWTCheckboxMenuItem ， JButton.AccessibleJButton ， JCheckBox.AccessibleJCheckBox ， JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem ， JInternalFrame.AccessibleJInternalFrame ， JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon ， JMenu.AccessibleJMenu ， JMenuItem.AccessibleJMenuItem ， JProgressBar.AccessibleJProgressBar ， JRadioButton.AccessibleJRadioButton ， JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem ， JScrollBar.AccessibleJScrollBar ， JSlider.AccessibleJSlider ， JSpinner.AccessibleJSpinner ， JSplitPane.AccessibleJSplitPane ， JToggleButton.AccessibleJToggleButton ， Menu.AccessibleAWTMenu ， MenuItem.AccessibleAWTMenuItem ， PopupMenu.AccessibleAWTPopupMenu ， Scrollbar.AccessibleAWTScrollBar

    public interface AccessibleValue
    AccessibleValue接口应该由支持数值的任何对象（例如滚动条）支持。 该界面提供了辅助技术的标准机制，用于确定和设置数值以及获取最小值和最大值。 应用程序可以首先获取AccessibleContext （见Accessible ），然后调用AccessibleContext.getAccessibleValue()方法来确定对象是否支持AccessibleValue接口。 如果返回值不是null ，则该对象支持该接口。
    另请参见：
    Accessible ， Accessible.getAccessibleContext() ， AccessibleContext ， AccessibleContext.getAccessibleValue()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Number getCurrentAccessibleValue​()
      获取此对象的值作为 Number 。
      Number getMaximumAccessibleValue​()
      获取此对象的最大值作为 Number 。
      Number getMinimumAccessibleValue​()
      以 Number获取此对象的 Number 。
      boolean setCurrentAccessibleValue​(Number n)
      将此对象的值设置为 Number 。

    • 方法详细信息

      • getCurrentAccessibleValue

        Number getCurrentAccessibleValue​()
        获取此对象的值作为Number 。 如果值未设置，返回值为null 。
        结果
        对象的值
        另请参见：
        setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        boolean setCurrentAccessibleValue​(Number n)
        将此对象的值设置为 Number 。
        参数
        n - 用于该值的数字
        结果
        true如果设置了该值; 其他false
        另请参见：
        getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        Number getMinimumAccessibleValue​()
        将该对象的最小值作为 Number 。
        结果
        物体的最小值; null如果此对象没有最小值
        另请参见：
        getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        Number getMaximumAccessibleValue​()
        以 Number获取此对象的 Number 。
        结果
        物体的最大值; null如果此对象没有最大值
        另请参见：
        getMinimumAccessibleValue()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.accessibility (Java SE 9 & JDK 9 )

javax.accessibility

Interfaces

  • Accessible
  • AccessibleAction
  • AccessibleComponent
  • AccessibleEditableText
  • AccessibleExtendedComponent
  • AccessibleExtendedTable
  • AccessibleExtendedText
  • AccessibleHypertext
  • AccessibleIcon
  • AccessibleKeyBinding
  • AccessibleSelection
  • AccessibleStreamable
  • AccessibleTable
  • AccessibleTableModelChange
  • AccessibleText
  • AccessibleValue

Classes

  • AccessibilityProvider
  • AccessibleAttributeSequence
  • AccessibleBundle
  • AccessibleContext
  • AccessibleHyperlink
  • AccessibleRelation
  • AccessibleRelationSet
  • AccessibleResourceBundle
  • AccessibleRole
  • AccessibleState
  • AccessibleStateSet
  • AccessibleTextSequence


javax.accessibility (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package javax.accessibility

定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。 如果一个Java应用程序完全支持Java Accessibility API，那么它应该与诸如屏幕阅读器，屏幕放大器等的辅助技术兼容并且友好。使用完全支持Java Accessibility API的Java应用程序，没有屏幕阅读器关闭屏幕模型是必要的，因为API提供通常包含在离屏模型中的所有信息。

Java Accessibility API包由8个Java编程语言接口和6个Java编程语言类组成。 这些在下面描述。

Interface Accessible

Interface Accessible是Java Accessibility API的主界面。 支持Java Accessibility API的所有组件都必须实现此接口。 它包含一个单一的方法， getAccessibleContext ，它返回AccessibleContext类的一个实例。 Sun认为，实现此接口是作为Java应用程序用户界面一部分的每个对象的绝对最低要求，如果该程序与辅助技术兼容。

Class AccessibleContext

AccessibleContext表示所有可访问对象返回的最小信息，并通过在实现Accessible接口的对象上调用getAccessibleContext方法获得。 该信息包括对象的可访问名称，描述， role和state ，以及有关对象的父项和子项的信息。 此外，还包括JavaBeans的属性更改支持，以允许辅助技术在可访问属性的值更改时学习。 AccessibleContext还包含获取有关组件的更多特定辅助功能信息的方法。 如果组件支持它，这些方法将返回一个实现一个或多个以下接口的对象：
  • AccessibleAction - 对象可以执行一个或多个操作。 该界面提供了辅助技术的标准机制来确定哪些操作是什么，并告诉对象来执行这些操作。 当AccessibleContext上调用getAccessibleAction方法时，任何可以被操纵的对象都应该返回一个实现该接口的对象。
  • AccessibleComponent - 对象具有图形表示。 该界面提供了辅助技术的标准机制，以确定和设置对象的图形表示。 当在getAccessibleComponent上调用getAccessibleComponent方法时，屏幕上呈现的任何对象都应返回实现此接口的对象。
  • AccessibleSelection - 该对象允许其子选项。 该界面提供了辅助技术的标准机制，以确定当前选定的儿童以及修改选择集。 当AccessibleContext上调用getAccessibleSelection方法时，任何具有可以选择的子项的对象都应该返回一个实现该接口的对象。
  • AccessibleText - 对象在显示器上显示可编辑的文本信息。 该界面提供了辅助技术通过其内容，属性和空间位置访问该文本的标准机制。 包含可编辑文本的任何对象应在AccessibleContext上调用getAccessibleText方法时返回实现此接口的对象。
  • AccessibleHypertext - 该对象在显示器上显示超文本信息。 该界面提供辅助技术的标准机制，通过其内容，属性和空间位置访问该超文本。 包含超文本的任何对象应该在AccessibleContext上调用getAccessibleText方法时返回实现此接口的对象。
  • AccessibleValue - 对象支持数值。 该界面提供了辅助技术的标准机制，用于确定和设置对象的当前值以及最小值和最大值。 在AccessibleContext上调用getAccessibleValue方法时，任何支持数值的对象都应该返回一个实现该接口的对象。

Class AccessibleRole

该类将Accessible对象的角色封装在用户界面中，并通过在getAccessibleRole上调用getAccessibleRole方法获得 。 可访问角色包括“复选框”，“菜单项”，“面板”等。这些角色由此类中的常量标识，如AccessibleRole.CHECK_BOX, AccessibleRole.MENU_ITEM,和AccessibleRole.PANEL 。 这个类中的常量表现出强类型的普通对象角色枚举。 这个类的公共构造函数被有意地省略，应用程序应该使用这个类的一个常量。 虽然这个类预定义了大量的标准角色列表，但是它是可扩展的，因此在将来可以添加额外的程序员定义的角色，而不需要修改基类。

Class AccessibleState

此类封装了Accessible对象的特定状态。 可访问状态包括“武装”，“忙”，“检查”，“聚焦”等。这些角色由此类中的常量标识，如AccessibleState.ARMED, AccessibleState.BUSY, AccessibleState.CHECKED,和AccessibleState.FOCUSED 。 可访问对象的所有状态的总和称为AccessibleStateSet ，可以通过在getAccessibleStateSet上调用getAccessibleStateSet方法获得 。

这个类中的常量表现出强类型的普通对象角色枚举。 这个类的公共构造函数被有意地省略，应用程序应该使用这个类的一个常量。 虽然这个类预先定义了大量的标准角色，但是它是可扩展的，所以在将来可以添加额外的程序员定义的角色，而不需要修改基类。

Class AccessibleStateSet

该类封装了Accessible对象的状态集合，并通过在getAccessibleStateSet上调用getAccessibleStateSet方法获得 。 由于对象可能具有多个状态（例如，它可能是“已检查”和“聚焦”），因此需要封装这些状态的集合。 该类中的方法提供了在状态集上检索个人AccessibleStates 。

Class AccessibleBundle

此类用于维护强类型枚举。 它是AccessibleRole和AccessibleState类的超类。 程序员通常不会直接与这个类进行交互，而是使用AccessibleRole和AccessibleState类。

Interface AccessibleAction

任何可以执行一个或多个操作的对象都应支持AccessibleAction接口。 该界面提供了辅助技术的标准机制，以确定哪些操作以及告诉对象执行这些操作。 任何可以被操纵的对象都应该支持这个接口。

应用程序可以通过首先获得其AccessibleContext （见Accessible ），然后再调用getAccessibleAction方法AccessibleContext来确定对象是否支持AccessibleAction接口。 如果返回值不是null ，则该对象支持该接口。

Interface AccessibleComponent

AccessibleComponent界面应由屏幕上呈现的任何对象支持。 该界面提供了辅助技术的标准机制来确定和设置对象的图形表示。

应用程序可确定是否一个目的是通过首先获得支持AccessibleComponent接口其AccessibleContext （见Accessible ），然后调用getAccessibleComponent的方法AccessibleContext 。 如果返回值不是null ，则该对象支持该接口。

Interface AccessibleSelection

AccessibleSelection接口提供了辅助技术的标准机制，以确定当前所选择的孩子是什么，以及修改选择集。 具有可以选择的子项的任何对象都应该支持AccessibleSelection接口。

应用程序可确定是否一个目的是通过首先获得支持AccessibleSelection接口其AccessibleContext （见Accessible ），然后调用getAccessibleSelection的方法AccessibleContext 。 如果返回值不是null ，则该对象支持该接口。

Interface AccessibleText

界面AccessibleText是制作丰富，可编辑文字的合约。 并非所有显示在屏幕上的文字都是丰富且可编辑的（例如，包含在按钮，标签，菜单等中的文本，用户不期望操作）。 然而，包含可编辑文本的对象必须实现AccessibleText接口，如果它们与辅助技术进行互操作。

该界面提供了在像素坐标和给定像素坐标处的文本之间进行的支持，用于在文本中的给定位置之前，之前或之后检索字母，单词和句子。 该界面提供支持在文本中的给定位置（字体，字体大小，样式等）检索字符的属性，以及获取所选文本（如果有），文本长度和文字插入符的位置。

应用程序可确定是否一个目的是通过首先获得支持AccessibleText接口其AccessibleContext （见Accessible ），然后调用getAccessibleText的方法AccessibleContext 。 如果返回值不是null ，则该对象支持该接口。

Interface AccessibleHypertext

任何在显示器上显示超文本信息的对象都应支持AccessibleHypertext接口。 该界面提供了辅助技术通过其内容，属性和空间位置访问该文本的标准机制。 它还提供了操纵hyperlinks的标准机制。 应用程序可确定是否一个目的是通过首先获得支持AccessibleHypertext的接口其AccessibleContext （见Accessible ），然后调用的AccessibleContext的（）方法AccessibleContext 。 如果返回值是扩展AccessibleHypertext的类，则该对象支持AccessibleHypertext。

Interface AccessibleHyperlink

超链接的对象应该支持AccessibleHyperlink界面。 将通过在AccessibleHypertext对象上调用getLink方法来返回实现此接口的对象。

Interface AccessibleValue

AccessibleValue接口应支持任何支持数值的对象（例如滚动条）。 该界面提供了辅助技术的标准机制，用于确定和设置数值以及获取最小值和最大值。

应用程序可确定是否一个目的是通过首先获得支持的AccessibleValue接口其AccessibleContext （见Accessible ），然后调用getAccessibleValue的方法AccessibleContext 。 如果返回值不是null ，则该对象支持该接口。

从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    Accessible
    接口 Accessible是可访问性包的主要接口。
    AccessibleAction
    任何可以执行一个或多个操作的对象都应该支持 AccessibleAction界面。
    AccessibleComponent
    应该在屏幕上呈现的任何对象支持 AccessibleComponent界面。
    AccessibleEditableText
    AccessibleEditableText接口应由在显示器上显示可编辑文本信息的所有类实现。
    AccessibleExtendedComponent
    应该在屏幕上呈现的任何对象支持 AccessibleExtendedComponent界面。
    AccessibleExtendedTable
    AccessibleExtendedTable类提供有关以二维表格格式显示数据的用户界面组件的扩展信息。
    AccessibleExtendedText
    该 AccessibleExtendedText接口包含不被提供的其他方法 AccessibleText接口。
    AccessibleHypertext
    AccessibleHypertext类是在显示器上显示超文本信息的所有类的基类。
    AccessibleIcon
    AccessibleIcon接口应该由具有关联图标的任何对象（例如按钮）支持。
    AccessibleKeyBinding
    任何具有键盘绑定（如键盘助记符和/或键盘快捷键）的对象都可以支持 AccessibleKeyBinding界面，可用于选择对象。
    AccessibleSelection
    该 AccessibleSelection接口提供了辅助技术的标准机制，以确定当前所选择的孩子是什么，以及修改选择集。
    AccessibleStreamable
    所述 AccessibleStreamable接口应该由实施 AccessibleContext呈现在显示屏幕上的部件的后面的原始流的任何组分。
    AccessibleTable
    AccessibleTable描述了以二维表格格式显示数据的用户界面组件。
    AccessibleTableModelChange
    AccessibleTableModelChange界面描述了对表模型的更改。
    AccessibleText
    AccessibleText接口应由显示文本信息的所有类实现。
    AccessibleValue
    AccessibleValue接口应支持任何支持数值的对象（例如滚动条）。
  • 类摘要
    Class 描述
    AccessibilityProvider
    用于辅助技术的服务提供商接口（SPI）。
    AccessibleAttributeSequence
    该类将共享相同连续属性集的文本的跨度以及该组属性一起收集。
    AccessibleBundle
    用于维护强类型枚举的基类。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
    AccessibleHyperlink
    在超文本文件中封装链接或一组链接（例如客户端图像映射）
    AccessibleRelation
    类 AccessibleRelation描述了实现 AccessibleRelation的对象与一个或多个其他对象之间的关系。
    AccessibleRelationSet
    AccessibleRelationSet类确定一个组件的关系集。
    AccessibleResourceBundle Deprecated.
    从Java平台1.3版开始，此类已被弃用
    AccessibleRole
    AccessibleRole类确定组件的作用。
    AccessibleState
    AccessibleState类描述了组件的特定状态。
    AccessibleStateSet
    AccessibleStateSet类确定组件的状态集。
    AccessibleTextSequence
    这个类收集了文本跨度的关键细节。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.accessibility Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.accessibility

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.accessibility.AccessibilityProvider
    • javax.accessibility.AccessibleAttributeSequence
    • javax.accessibility.AccessibleBundle
      • javax.accessibility.AccessibleRelation
      • javax.accessibility.AccessibleRole
      • javax.accessibility.AccessibleState
    • javax.accessibility.AccessibleContext
    • javax.accessibility.AccessibleHyperlink (implements javax.accessibility.AccessibleAction)
    • javax.accessibility.AccessibleRelationSet
    • javax.accessibility.AccessibleStateSet
    • javax.accessibility.AccessibleTextSequence
    • java.util.ResourceBundle
      • java.util.ListResourceBundle
        • javax.accessibility.AccessibleResourceBundle

Interface Hierarchy

  • javax.accessibility.Accessible
  • javax.accessibility.AccessibleAction
  • javax.accessibility.AccessibleComponent
    • javax.accessibility.AccessibleExtendedComponent
  • javax.accessibility.AccessibleExtendedText
  • javax.accessibility.AccessibleIcon
  • javax.accessibility.AccessibleKeyBinding
  • javax.accessibility.AccessibleSelection
  • javax.accessibility.AccessibleStreamable
  • javax.accessibility.AccessibleTable
    • javax.accessibility.AccessibleExtendedTable
  • javax.accessibility.AccessibleTableModelChange
  • javax.accessibility.AccessibleText
    • javax.accessibility.AccessibleEditableText
    • javax.accessibility.AccessibleHypertext
  • javax.accessibility.AccessibleValue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package javax.accessibility (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.accessibility

  • Packages that use javax.accessibility
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
  • Classes in javax.accessibility used by com.sun.java.accessibility.util
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要界面。
    AccessibleComponent
    应该在屏幕上呈现的任何对象支持 AccessibleComponent界面。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
    AccessibleRole
    AccessibleRole类确定组件的作用。
    AccessibleStateSet
    AccessibleStateSet类确定组件的状态集。
  • Classes in javax.accessibility used by java.applet
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要接口。
    AccessibleComponent
    应该在屏幕上呈现的任何对象支持 AccessibleComponent接口。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
    AccessibleRole
    AccessibleRole类确定组件的作用。
    AccessibleStateSet
    AccessibleStateSet类确定组件的状态集。
  • Classes in javax.accessibility used by java.awt
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要接口。
    AccessibleAction
    任何可以执行一个或多个操作的对象都应支持 AccessibleAction接口。
    AccessibleComponent
    应该在屏幕上呈现的任何对象支持 AccessibleComponent接口。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
    AccessibleRole
    AccessibleRole类确定组件的作用。
    AccessibleSelection
    这个 AccessibleSelection接口提供了辅助技术的标准机制，以确定当前所选择的孩子是什么，以及修改选择集。
    AccessibleStateSet
    AccessibleStateSet类确定组件的状态集。
    AccessibleText
    AccessibleText界面应由所有显示文本信息的类实现。
    AccessibleValue
    AccessibleValue接口应支持任何支持数值的对象（例如滚动条）。
  • Classes in javax.accessibility used by javax.accessibility
    Class 描述
    Accessible
    接口 Accessible是辅助功能包的主界面。
    AccessibleAction
    任何可以执行一个或多个操作的对象都应支持 AccessibleAction接口。
    AccessibleBundle
    用于维护强类型枚举的基类。
    AccessibleComponent
    应该在屏幕上呈现的任何对象支持 AccessibleComponent接口。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
    AccessibleEditableText
    AccessibleEditableText接口应由在显示器上显示可编辑文本信息的所有类实现。
    AccessibleHyperlink
    在超文本文件中封装链接或一组链接（例如客户端图像映射）
    AccessibleIcon
    任何具有关联图标（例如按钮）的对象都应支持 AccessibleIcon接口。
    AccessibleKeyBinding
    任何具有键盘绑定（如键盘助记符和/或键盘快捷键）的对象都可以支持 AccessibleKeyBinding界面，可用于选择对象。
    AccessibleRelation
    AccessibleRelation类描述了实现 AccessibleRelation的对象与一个或多个其他对象之间的关系。
    AccessibleRelationSet
    AccessibleRelationSet类确定组件的关系集。
    AccessibleRole
    AccessibleRole类确定组件的作用。
    AccessibleSelection
    该 AccessibleSelection界面提供了辅助技术的标准机制，以确定当前所选择的孩子是什么，以及修改选择集。
    AccessibleState
    AccessibleState类描述了组件的特定状态。
    AccessibleStateSet
    AccessibleStateSet类确定组件的状态集。
    AccessibleTable
    AccessibleTable描述了以二维表格格式显示数据的用户界面组件。
    AccessibleText
    AccessibleText接口应由显示器上显示文本信息的所有类实现。
    AccessibleTextSequence
    这个类收集了文本跨度的关键细节。
    AccessibleValue
    AccessibleValue接口应该由支持数值的任何对象（例如滚动条）支持。
  • Classes in javax.accessibility used by javax.swing
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要接口。
    AccessibleAction
    任何可以执行一个或多个操作的对象都应支持 AccessibleAction接口。
    AccessibleComponent
    AccessibleComponent界面应由屏幕上呈现的任何对象支持。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
    AccessibleEditableText
    AccessibleEditableText接口应该由显示器上显示可编辑文本信息的所有类实现。
    AccessibleExtendedComponent
    应该在屏幕上呈现的任何对象支持 AccessibleExtendedComponent接口。
    AccessibleExtendedTable
    AccessibleExtendedTable类提供了以二维表格格式显示数据的用户界面组件的扩展信息。
    AccessibleExtendedText
    该 AccessibleExtendedText接口包含不被提供的其他方法 AccessibleText接口。
    AccessibleHyperlink
    在超文本文件中封装链接或一组链接（例如客户端图像映射）
    AccessibleHypertext
    AccessibleHypertext类是在显示器上显示超文本信息的所有类的基类。
    AccessibleIcon
    AccessibleIcon接口应该由具有关联图标的任何对象（例如按钮）支持。
    AccessibleKeyBinding
    任何具有键盘绑定（如键盘助记符和/或键盘快捷方式）的对象都可以支持 AccessibleKeyBinding接口，可用于选择对象。
    AccessibleRelationSet
    AccessibleRelationSet类确定组件的关系集。
    AccessibleRole
    AccessibleRole类确定组件的作用。
    AccessibleSelection
    该 AccessibleSelection界面提供了辅助技术的标准机制，以确定当前所选择的孩子是什么，以及修改选择集。
    AccessibleStateSet
    AccessibleStateSet类确定组件的状态集。
    AccessibleTable
    类 AccessibleTable描述了以二维表格式呈现数据的用户界面组件。
    AccessibleTableModelChange
    AccessibleTableModelChange接口描述了对表模型的更改。
    AccessibleText
    AccessibleText接口应由显示文本信息的所有类实现。
    AccessibleTextSequence
    这个类收集了文本跨度的关键细节。
    AccessibleValue
    AccessibleValue接口应支持任何支持数值的对象（例如滚动条）。
  • Classes in javax.accessibility used by javax.swing.colorchooser
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要接口。
  • Classes in javax.accessibility used by javax.swing.plaf
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要接口。
  • Classes in javax.accessibility used by javax.swing.plaf.basic
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要接口。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
  • Classes in javax.accessibility used by javax.swing.plaf.metal
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要接口。
  • Classes in javax.accessibility used by javax.swing.plaf.multi
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要界面。
  • Classes in javax.accessibility used by javax.swing.table
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要接口。
    AccessibleAction
    任何可以执行一个或多个操作的对象都应支持 AccessibleAction接口。
    AccessibleComponent
    应该在屏幕上呈现的任何对象支持 AccessibleComponent接口。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
    AccessibleExtendedComponent
    应该在屏幕上呈现的任何对象支持 AccessibleExtendedComponent接口。
    AccessibleRole
    AccessibleRole类决定组件的作用。
    AccessibleSelection
    该 AccessibleSelection接口提供了辅助技术的标准机制，以确定当前所选择的孩子是什么，以及修改选择集。
    AccessibleStateSet
    AccessibleStateSet类确定组件的状态集。
    AccessibleText
    AccessibleText接口应由在显示器上显示文本信息的所有类实现。
    AccessibleValue
    AccessibleValue接口应支持任何支持数值的对象（例如滚动条）。
  • Classes in javax.accessibility used by javax.swing.text
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要界面。
    AccessibleAction
    任何可以执行一个或多个操作的对象都应该支持 AccessibleAction接口。
    AccessibleComponent
    应该在屏幕上呈现的任何对象支持 AccessibleComponent接口。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
    AccessibleEditableText
    AccessibleEditableText接口应由在显示器上显示可编辑文本信息的所有类实现。
    AccessibleExtendedComponent
    AccessibleExtendedComponent界面应由屏幕上呈现的任何对象支持。
    AccessibleExtendedText
    该 AccessibleExtendedText接口包含不被提供的其他方法 AccessibleText接口。
    AccessibleRole
    AccessibleRole类确定组件的作用。
    AccessibleStateSet
    AccessibleStateSet类确定组件的状态集。
    AccessibleText
    AccessibleText接口应由显示文本信息的所有类实现。
    AccessibleTextSequence
    这个类收集了文本跨度的关键细节。
  • Classes in javax.accessibility used by javax.swing.text.html
    Class 描述
    Accessible
    接口 Accessible是可访问性包的主要界面。
    AccessibleContext
    AccessibleContext表示所有可访问对象返回的最小信息。
  • Classes in javax.accessibility used by javax.swing.tree
    Class 描述
    Accessible
    Interface Accessible is the main interface for the accessibility package.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibilityProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibilityProvider

No usage of javax.accessibility.AccessibilityProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleAttributeSequence (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleAttributeSequence

No usage of javax.accessibility.AccessibleAttributeSequence
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleBundle

  • Packages that use AccessibleBundle
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。

    • Uses of AccessibleBundle in javax.accessibility

      Subclasses of AccessibleBundle in javax.accessibility
      Modifier and Type Class 描述
      class  AccessibleRelation
      AccessibleRelation描述了实现 AccessibleRelation的对象与一个或多个其他对象之间的关系。
      class  AccessibleRole
      AccessibleRole类确定组件的作用。
      class  AccessibleState
      AccessibleState类描述了一个组件的特定状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleContext

  • Packages that use AccessibleContext
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。

    • Uses of AccessibleContext in com.sun.java.accessibility.util

      Subclasses of AccessibleContext in com.sun.java.accessibility.util
      Modifier and Type Class 描述
      class  Translator
      Translator类为不实现接口Accessible对象提供了一个到接口Accessible的翻译。
      Methods in com.sun.java.accessibility.util that return AccessibleContext
      Modifier and Type 方法 描述
      AccessibleContext Translator.getAccessibleContext​()
      返回此对象。

    • Uses of AccessibleContext in java.applet

      Subclasses of AccessibleContext in java.applet
      Modifier and Type Class 描述
      protected class  Applet.AccessibleApplet
      已过时。
      这个类实现了 Applet类的可访问性支持。
      Methods in java.applet that return AccessibleContext
      Modifier and Type 方法 描述
      AccessibleContext Applet.getAccessibleContext​()
      已过时。
      获取与此Applet关联的AccessibleContext。

    • Uses of AccessibleContext in java.awt

      Subclasses of AccessibleContext in java.awt
      Modifier and Type Class 描述
      protected class  Button.AccessibleAWTButton
      该类为 Button类实现可访问性支持。
      protected class  Canvas.AccessibleAWTCanvas
      这个类实现了 Canvas类的可访问性支持。
      protected class  Checkbox.AccessibleAWTCheckbox
      该类实现 Checkbox类的可访问性支持。
      protected class  CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
      用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。
      protected class  Choice.AccessibleAWTChoice
      这个类实现了 Choice类的可访问性支持。
      protected class  Component.AccessibleAWTComponent
      组件的内部类用于为辅助功能提供默认支持。
      protected class  Container.AccessibleAWTContainer
      Container的内部类用于为辅助功能提供默认支持。
      protected class  Dialog.AccessibleAWTDialog
      这个类实现了 Dialog类的可访问性支持。
      protected class  Frame.AccessibleAWTFrame
      该类实现了 Frame课程的可访问性支持。
      protected class  Label.AccessibleAWTLabel
      这个类实现了 Label类的可访问性支持。
      protected class  List.AccessibleAWTList
      该类实现 List类的可访问性支持。
      protected class  List.AccessibleAWTList.AccessibleAWTListChild
      此类实现对List子项的可访问性支持。
      protected class  Menu.AccessibleAWTMenu
      菜单的内部类用于提供对辅助功能的默认支持。
      protected class  MenuBar.AccessibleAWTMenuBar
      MenuBar的内部类用于为辅助功能提供默认支持。
      protected class  MenuComponent.AccessibleAWTMenuComponent
      内部类 MenuComponent用于提供对辅助功能的默认支持。
      protected class  MenuItem.AccessibleAWTMenuItem
      MenuItem的内部类用于为辅助功能提供默认支持。
      protected class  Panel.AccessibleAWTPanel
      这个类实现了 Panel类的可访问性支持。
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。
      protected class  Scrollbar.AccessibleAWTScrollBar
      这个类实现了 Scrollbar类的可访问性支持。
      protected class  ScrollPane.AccessibleAWTScrollPane
      该类实现 ScrollPane类的辅助功能支持。
      protected class  TextArea.AccessibleAWTTextArea
      这个类实现了 TextArea类的可访问性支持。
      protected class  TextComponent.AccessibleAWTTextComponent
      该类为 TextComponent类实现可访问性支持。
      protected class  TextField.AccessibleAWTTextField
      这个类实现了 TextField类的可访问性支持。
      protected class  Window.AccessibleAWTWindow
      这个类实现了 Window课程的可访问性支持。
      Fields in java.awt declared as AccessibleContext
      Modifier and Type Field 描述
      protected AccessibleContext Component.accessibleContext
      该 AccessibleContext与此 Component相关联。
      Methods in java.awt that return AccessibleContext
      Modifier and Type 方法 描述
      AccessibleContext Button.getAccessibleContext​()
      获取 AccessibleContext与此 Button相关联。
      AccessibleContext Canvas.getAccessibleContext​()
      获取与此Canvas关联的AccessibleContext。
      AccessibleContext Checkbox.getAccessibleContext​()
      获取与此复选框相关联的AccessibleContext。
      AccessibleContext CheckboxMenuItem.getAccessibleContext​()
      获取与此CheckboxMenuItem关联的AccessibleContext。
      AccessibleContext Choice.getAccessibleContext​()
      获取 AccessibleContext与此 Choice相关联。
      AccessibleContext Component.getAccessibleContext​()
      获取 AccessibleContext与此 Component相关联。
      AccessibleContext Dialog.getAccessibleContext​()
      获取与此对话框关联的AccessibleContext。
      AccessibleContext Frame.getAccessibleContext​()
      获取与此Frame相关联的AccessibleContext。
      AccessibleContext Label.getAccessibleContext​()
      获取与此Label相关联的AccessibleContext。
      AccessibleContext List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleContext​()
      获取此对象的AccessibleContext。
      AccessibleContext List.getAccessibleContext​()
      获取 AccessibleContext与此 List相关联。
      AccessibleContext Menu.getAccessibleContext​()
      获取与此菜单关联的AccessibleContext。
      AccessibleContext MenuBar.getAccessibleContext​()
      获取与此MenuBar关联的AccessibleContext。
      AccessibleContext MenuComponent.getAccessibleContext​()
      获取 AccessibleContext与此 MenuComponent相关联。
      AccessibleContext MenuItem.getAccessibleContext​()
      获取与此MenuItem关联的AccessibleContext。
      AccessibleContext Panel.getAccessibleContext​()
      获取与此面板关联的AccessibleContext。
      AccessibleContext PopupMenu.getAccessibleContext​()
      获取 AccessibleContext与此 PopupMenu相关联。
      AccessibleContext Scrollbar.getAccessibleContext​()
      获取 AccessibleContext与此 Scrollbar相关联。
      AccessibleContext ScrollPane.getAccessibleContext​()
      获取与此ScrollPane关联的AccessibleContext。
      AccessibleContext TextArea.getAccessibleContext​()
      返回 AccessibleContext与此 TextArea相关联。
      AccessibleContext TextComponent.getAccessibleContext​()
      获取与此TextComponent关联的AccessibleContext。
      AccessibleContext TextField.getAccessibleContext​()
      获取与此TextField关联的AccessibleContext。
      AccessibleContext Window.getAccessibleContext​()
      获取与此窗口关联的AccessibleContext。

    • Uses of AccessibleContext in javax.accessibility

      Methods in javax.accessibility that return AccessibleContext
      Modifier and Type 方法 描述
      AccessibleContext Accessible.getAccessibleContext​()
      返回与此对象关联的 AccessibleContext 。

    • Uses of AccessibleContext in javax.swing

      Subclasses of AccessibleContext in javax.swing
      Modifier and Type Class 描述
      protected class  AbstractButton.AccessibleAbstractButton
      这个类实现了 AbstractButton类的可访问性支持。
      protected class  Box.AccessibleBox
      这个类实现了 Box类的可访问性支持。
      protected class  Box.Filler.AccessibleBoxFiller
      这个类实现了 Box.Filler类的可访问性支持。
      protected class  CellRendererPane.AccessibleCellRendererPane
      该类实现了 CellRendererPane课程的可访问性支持。
      protected class  ImageIcon.AccessibleImageIcon
      这个类实现了 ImageIcon类的可访问性支持。
      protected class  JApplet.AccessibleJApplet
      已过时。
      这个类实现了 JApplet类的可访问性支持。
      protected class  JButton.AccessibleJButton
      这个类实现了 JButton类的可访问性支持。
      protected class  JCheckBox.AccessibleJCheckBox
      这个类实现了 JCheckBox类的可访问性支持。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      这个类实现了 JCheckBoxMenuItem类的可访问性支持。
      protected class  JColorChooser.AccessibleJColorChooser
      这个类实现了 JColorChooser类的可访问性支持。
      protected class  JComboBox.AccessibleJComboBox
      这个类实现了 JComboBox类的可访问性支持。
      class  JComponent.AccessibleJComponent
      JComponent的内部类用于为辅助功能提供默认支持。
      protected class  JDesktopPane.AccessibleJDesktopPane
      这个类实现了 JDesktopPane类的可访问性支持。
      protected class  JDialog.AccessibleJDialog
      这个类实现了 JDialog类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPane
      这个类实现了 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供对 AccessibleHypertext支持，并且用于在此 EditorKit安装的 JEditorPane是 JEditorPane的实例的 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回。
      protected class  JFileChooser.AccessibleJFileChooser
      这个类实现了 JFileChooser类的可访问性支持。
      protected class  JFrame.AccessibleJFrame
      该类实现 JFrame类的可访问性支持。
      protected class  JInternalFrame.AccessibleJInternalFrame
      该类实现了 JInternalFrame类的可访问性支持。
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      该类为 JInternalFrame.JDesktopIcon类实现可访问性支持。
      protected class  JLabel.AccessibleJLabel
      该类用于获取此对象的可访问角色。
      protected class  JLayeredPane.AccessibleJLayeredPane
      这个类实现了 JLayeredPane类的可访问性支持。
      protected class  JList.AccessibleJList
      该类实现 JList类的可访问性支持。
      protected class  JList.AccessibleJList.AccessibleJListChild
      该类实现适用于列表子级的辅助功能支持。
      protected class  JMenu.AccessibleJMenu
      该类为 JMenu类实现可访问性支持。
      protected class  JMenuBar.AccessibleJMenuBar
      该类实现 JMenuBar类的辅助功能支持。
      protected class  JMenuItem.AccessibleJMenuItem
      这个类实现了 JMenuItem类的可访问性支持。
      protected class  JOptionPane.AccessibleJOptionPane
      该类为 JOptionPane类实现可访问性支持。
      protected class  JPanel.AccessibleJPanel
      这个类实现了 JPanel类的可访问性支持。
      protected class  JPasswordField.AccessibleJPasswordField
      这个类实现了 JPasswordField类的可访问性支持。
      protected class  JPopupMenu.AccessibleJPopupMenu
      该类实现了 JPopupMenu类的可访问性支持。
      protected class  JProgressBar.AccessibleJProgressBar
      该类为 JProgressBar类实现可访问性支持。
      protected class  JRadioButton.AccessibleJRadioButton
      该类实现 JRadioButton类的辅助功能支持。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      这个类实现了 JRadioButtonMenuItem类的辅助功能支持。
      protected class  JRootPane.AccessibleJRootPane
      这个类实现了 JRootPane类的可访问性支持。
      protected class  JScrollBar.AccessibleJScrollBar
      该类实现 JScrollBar类的可访问性支持。
      protected class  JScrollPane.AccessibleJScrollPane
      这个类实现了 JScrollPane类的可访问性支持。
      protected class  JSeparator.AccessibleJSeparator
      这个类实现了 JSeparator类的可访问性支持。
      protected class  JSlider.AccessibleJSlider
      该类实现 JSlider类的可访问性支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner实现 JSpinner类的可访问性支持。
      protected class  JSplitPane.AccessibleJSplitPane
      这个类实现了 JSplitPane类的可访问性支持。
      protected class  JTabbedPane.AccessibleJTabbedPane
      这个类实现了 JTabbedPane类的可访问性支持。
      protected class  JTable.AccessibleJTable
      这个类实现了 JTable类的可访问性支持。
      protected class  JTable.AccessibleJTable.AccessibleJTableCell
      该类提供了适用于表单元格的Java Accessibility API的实现。
      protected class  JTextArea.AccessibleJTextArea
      该类实现 JTextArea类的辅助功能支持。
      protected class  JTextField.AccessibleJTextField
      这个类实现了 JTextField类的可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      这个类实现了 JToggleButton类的可访问性支持。
      protected class  JToolBar.AccessibleJToolBar
      该类实现 JToolBar类的可访问性支持。
      protected class  JToolTip.AccessibleJToolTip
      这个类实现了 JToolTip类的可访问性支持。
      protected class  JTree.AccessibleJTree
      这个类实现了 JTree类的可访问性支持。
      protected class  JTree.AccessibleJTree.AccessibleJTreeNode
      这个类为 JTree孩子实现可访问性支持。
      protected class  JViewport.AccessibleJViewport
      这个类实现了 JViewport类的可访问性支持。
      protected class  JWindow.AccessibleJWindow
      这个类实现了 JWindow类的可访问性支持。
      protected class  ProgressMonitor.AccessibleProgressMonitor
      AccessibleProgressMonitor实现 ProgressMonitor类的辅助功能支持。
      Fields in javax.swing declared as AccessibleContext
      Modifier and Type Field 描述
      protected AccessibleContext CellRendererPane.accessibleContext
      AccessibleContext与此 CellRendererPan相关联
      protected AccessibleContext JApplet.accessibleContext
      已过时。
      AccessibleContext与此 JApplet相关联
      protected AccessibleContext JColorChooser.accessibleContext
      可访问的上下文。
      protected AccessibleContext JDialog.accessibleContext
      AccessibleContext与此 JDialog相关联
      protected AccessibleContext JFileChooser.accessibleContext
      AccessibleContext与此 JFileChooser相关联
      protected AccessibleContext JFrame.accessibleContext
      可访问的上下文属性。
      protected AccessibleContext JWindow.accessibleContext
      可访问的上下文属性。
      protected AccessibleContext ProgressMonitor.accessibleContext
      AccessibleContext为 ProgressMonitor
      Methods in javax.swing that return AccessibleContext
      Modifier and Type 方法 描述
      AccessibleContext Box.Filler.getAccessibleContext​()
      获取与此Box.Filler相关联的AccessibleContext。
      AccessibleContext Box.getAccessibleContext​()
      获取与此Box关联的AccessibleContext。
      AccessibleContext CellRendererPane.getAccessibleContext​()
      获取与此CellRendererPane关联的AccessibleContext。
      AccessibleContext ImageIcon.getAccessibleContext​()
      获取与此ImageIcon关联的AccessibleContext。
      AccessibleContext JApplet.getAccessibleContext​()
      已过时。
      获取与此JApplet关联的AccessibleContext。
      AccessibleContext JButton.getAccessibleContext​()
      获取 AccessibleContext与此 JButton相关联。
      AccessibleContext JCheckBox.getAccessibleContext​()
      获取与此JCheckBox关联的AccessibleContext。
      AccessibleContext JCheckBoxMenuItem.getAccessibleContext​()
      获取与此JCheckBoxMenuItem关联的AccessibleContext。
      AccessibleContext JColorChooser.getAccessibleContext​()
      获取与此JColorChooser关联的AccessibleContext。
      AccessibleContext JComboBox.getAccessibleContext​()
      获取与此JComboBox关联的AccessibleContext。
      AccessibleContext JDesktopPane.getAccessibleContext​()
      获取 AccessibleContext与此 JDesktopPane相关联。
      AccessibleContext JDialog.getAccessibleContext​()
      获取与此JDialog关联的AccessibleContext。
      AccessibleContext JEditorPane.getAccessibleContext​()
      获取与此JEditorPane关联的AccessibleContext。
      AccessibleContext JFileChooser.getAccessibleContext​()
      获取与此JFileChooser关联的AccessibleContext。
      AccessibleContext JFrame.getAccessibleContext​()
      获取与此JFrame关联的AccessibleContext。
      AccessibleContext JInternalFrame.getAccessibleContext​()
      获取 AccessibleContext与此 JInternalFrame相关联。
      AccessibleContext JInternalFrame.JDesktopIcon.getAccessibleContext​()
      获取与此JDesktopIcon关联的AccessibleContext。
      AccessibleContext JLabel.getAccessibleContext​()
      获取此对象的AccessibleContext
      AccessibleContext JLayer.getAccessibleContext​()
      获取与此 JLayer相关联的AccessibleContext。
      AccessibleContext JLayeredPane.getAccessibleContext​()
      获取与此JLayeredPane关联的AccessibleContext。
      AccessibleContext JList.AccessibleJList.AccessibleJListChild.getAccessibleContext​()
      获取此对象的AccessibleContext。
      AccessibleContext JList.getAccessibleContext​()
      获取 AccessibleContext与此 JList相关联。
      AccessibleContext JMenu.getAccessibleContext​()
      获取与此JMenu关联的AccessibleContext。
      AccessibleContext JMenuBar.getAccessibleContext​()
      获取与此JMenuBar关联的AccessibleContext。
      AccessibleContext JMenuItem.getAccessibleContext​()
      返回 AccessibleContext与此相关 JMenuItem 。
      AccessibleContext JOptionPane.getAccessibleContext​()
      返回与此JOptionPane关联的 AccessibleContext 。
      AccessibleContext JPanel.getAccessibleContext​()
      获取与此JPanel关联的AccessibleContext。
      AccessibleContext JPasswordField.getAccessibleContext​()
      返回 AccessibleContext与此 JPasswordField相关联。
      AccessibleContext JPopupMenu.getAccessibleContext​()
      获取与此JPopupMenu关联的AccessibleContext。
      AccessibleContext JProgressBar.getAccessibleContext​()
      获取 AccessibleContext与此 JProgressBar相关联。
      AccessibleContext JRadioButton.getAccessibleContext​()
      获取与此JRadioButton关联的AccessibleContext。
      AccessibleContext JRadioButtonMenuItem.getAccessibleContext​()
      获取与此JRadioButtonMenuItem关联的AccessibleContext。
      AccessibleContext JRootPane.getAccessibleContext​()
      获取 AccessibleContext与此 JRootPane相关联。
      AccessibleContext JScrollBar.getAccessibleContext​()
      获取与此JScrollBar关联的AccessibleContext。
      AccessibleContext JScrollPane.getAccessibleContext​()
      获取与此JScrollPane关联的AccessibleContext。
      AccessibleContext JSeparator.getAccessibleContext​()
      获取与此JSeparator关联的AccessibleContext。
      AccessibleContext JSlider.getAccessibleContext​()
      获取与此JSlider相关联的AccessibleContext。
      AccessibleContext JSpinner.getAccessibleContext​()
      获得 AccessibleContext的 JSpinner
      AccessibleContext JSplitPane.getAccessibleContext​()
      获取与此JSplitPane关联的AccessibleContext。
      AccessibleContext JTabbedPane.getAccessibleContext​()
      获取与此JTabbedPane关联的AccessibleContext。
      AccessibleContext JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleContext​()
      获取与此组件关联的 AccessibleContext 。
      AccessibleContext JTable.getAccessibleContext​()
      获取与此JTable关联的AccessibleContext。
      AccessibleContext JTextArea.getAccessibleContext​()
      获取与此JTextArea关联的AccessibleContext。
      AccessibleContext JTextField.getAccessibleContext​()
      获取 AccessibleContext与此 JTextField相关联。
      AccessibleContext JToggleButton.getAccessibleContext​()
      获取与此JToggleButton关联的AccessibleContext。
      AccessibleContext JToolBar.getAccessibleContext​()
      获取与此JToolBar关联的AccessibleContext。
      AccessibleContext JToolTip.getAccessibleContext​()
      获取与此JToolTip关联的AccessibleContext。
      AccessibleContext JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleContext​()
      获取与此树节点相关联的AccessibleContext。
      AccessibleContext JTree.getAccessibleContext​()
      获取与此JTree关联的AccessibleContext。
      AccessibleContext JViewport.getAccessibleContext​()
      获取与此JViewport关联的AccessibleContext。
      AccessibleContext JWindow.getAccessibleContext​()
      获取与此JWindow关联的AccessibleContext。
      AccessibleContext ProgressMonitor.getAccessibleContext​()
      获得 AccessibleContext为 ProgressMonitor
      protected AccessibleContext JTable.AccessibleJTable.AccessibleJTableCell.getCurrentAccessibleContext​()
      获取表单元格渲染器的AccessibleContext。

    • Uses of AccessibleContext in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return AccessibleContext
      Modifier and Type 方法 描述
      AccessibleContext BasicComboPopup.getAccessibleContext​()
      获取与此BasicComboPopup关联的AccessibleContext。

    • Uses of AccessibleContext in javax.swing.table

      Subclasses of AccessibleContext in javax.swing.table
      Modifier and Type Class 描述
      protected class  JTableHeader.AccessibleJTableHeader
      这个类实现了 JTableHeader类的可访问性支持。
      protected class  JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
      该类提供了适用于JTableHeader条目的Java Accessibility API的实现。
      Methods in javax.swing.table that return AccessibleContext
      Modifier and Type 方法 描述
      AccessibleContext JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleContext​()
      获取与此对象关联的AccessibleContext。
      AccessibleContext JTableHeader.getAccessibleContext​()
      获取与此JTableHeader关联的AccessibleContext。

    • Uses of AccessibleContext in javax.swing.text

      Subclasses of AccessibleContext in javax.swing.text
      Modifier and Type Class 描述
      class  JTextComponent.AccessibleJTextComponent
      这个类实现 JTextComponent类的辅助功能支持。
      Methods in javax.swing.text that return AccessibleContext
      Modifier and Type 方法 描述
      AccessibleContext JTextComponent.getAccessibleContext​()
      获取 AccessibleContext与此 JTextComponent相关联。

    • Uses of AccessibleContext in javax.swing.text.html

      Methods in javax.swing.text.html that return AccessibleContext
      Modifier and Type 方法 描述
      AccessibleContext HTMLEditorKit.getAccessibleContext​()
      返回与此编辑器工具包关联的AccessibleContext
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleHyperlink (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleHyperlink

  • Packages that use AccessibleHyperlink
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AccessibleHyperlink in javax.accessibility

      Methods in javax.accessibility that return AccessibleHyperlink
      Modifier and Type 方法 描述
      AccessibleHyperlink AccessibleHypertext.getLink​(int linkIndex)
      返回此超文本文件的第n个链接。

    • Uses of AccessibleHyperlink in javax.swing

      Subclasses of AccessibleHyperlink in javax.swing
      Modifier and Type Class 描述
      class  JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
      一个HTML链接。
      Methods in javax.swing that return AccessibleHyperlink
      Modifier and Type 方法 描述
      AccessibleHyperlink JEditorPane.JEditorPaneAccessibleHypertextSupport.getLink​(int linkIndex)
      将索引返回到索引的超链接数组中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleRelation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleRelation

  • Packages that use AccessibleRelation
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。

    • Uses of AccessibleRelation in javax.accessibility

      Fields in javax.accessibility with type parameters of type AccessibleRelation
      Modifier and Type Field 描述
      protected Vector<AccessibleRelation> AccessibleRelationSet.relations
      Vector每个条目代表 AccessibleRelation 。
      Methods in javax.accessibility that return AccessibleRelation
      Modifier and Type 方法 描述
      AccessibleRelation AccessibleRelationSet.get​(String key)
      返回与指定键匹配的关系。
      AccessibleRelation[] AccessibleRelationSet.toArray​()
      将当前关系集返回为 AccessibleRelation的数组。
      Methods in javax.accessibility with parameters of type AccessibleRelation
      Modifier and Type 方法 描述
      boolean AccessibleRelationSet.add​(AccessibleRelation relation)
      添加与当前关系集的新关系。
      void AccessibleRelationSet.addAll​(AccessibleRelation[] relations)
      将所有关系添加到现有关系集中。
      boolean AccessibleRelationSet.remove​(AccessibleRelation relation)
      从当前关系集中删除关系。
      Constructors in javax.accessibility with parameters of type AccessibleRelation
      Constructor 描述
      AccessibleRelationSet​(AccessibleRelation[] relations)
      与传递的关系数组中包含的初始关系创建一个新的关系。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleRelationSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleRelationSet

  • Packages that use AccessibleRelationSet
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AccessibleRelationSet in javax.accessibility

      Methods in javax.accessibility that return AccessibleRelationSet
      Modifier and Type 方法 描述
      AccessibleRelationSet AccessibleContext.getAccessibleRelationSet​()
      获取与对象关联的 AccessibleRelationSet 。

    • Uses of AccessibleRelationSet in javax.swing

      Methods in javax.swing that return AccessibleRelationSet
      Modifier and Type 方法 描述
      AccessibleRelationSet AbstractButton.AccessibleAbstractButton.getAccessibleRelationSet​()
      获取与此对象关联的AccessibleRelationSet（如果存在）。
      AccessibleRelationSet JLabel.AccessibleJLabel.getAccessibleRelationSet​()
      获取与此对象关联的AccessibleRelationSet（如果存在）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleResourceBundle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleResourceBundle

No usage of javax.accessibility.AccessibleResourceBundle
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleRole (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleRole

  • Packages that use AccessibleRole
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of AccessibleRole in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return AccessibleRole
      Modifier and Type 方法 描述
      AccessibleRole Translator.getAccessibleRole​()
      获取此对象的角色。

    • Uses of AccessibleRole in java.applet

      Methods in java.applet that return AccessibleRole
      Modifier and Type 方法 描述
      AccessibleRole Applet.AccessibleApplet.getAccessibleRole​()
      获取此对象的角色。

    • Uses of AccessibleRole in java.awt

      Methods in java.awt that return AccessibleRole
      Modifier and Type 方法 描述
      AccessibleRole Button.AccessibleAWTButton.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole Canvas.AccessibleAWTCanvas.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole Checkbox.AccessibleAWTCheckbox.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole Choice.AccessibleAWTChoice.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole Component.AccessibleAWTComponent.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole Dialog.AccessibleAWTDialog.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole Frame.AccessibleAWTFrame.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole Label.AccessibleAWTLabel.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole List.AccessibleAWTList.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole Menu.AccessibleAWTMenu.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole MenuBar.AccessibleAWTMenuBar.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole MenuComponent.AccessibleAWTMenuComponent.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole MenuItem.AccessibleAWTMenuItem.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole Panel.AccessibleAWTPanel.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole PopupMenu.AccessibleAWTPopupMenu.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole Scrollbar.AccessibleAWTScrollBar.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole ScrollPane.AccessibleAWTScrollPane.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole TextComponent.AccessibleAWTTextComponent.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole Window.AccessibleAWTWindow.getAccessibleRole​()
      获取此对象的角色。

    • Uses of AccessibleRole in javax.accessibility

      Fields in javax.accessibility declared as AccessibleRole
      Modifier and Type Field 描述
      static AccessibleRole AccessibleRole.ALERT
      对象用于提醒用户有关某些内容。
      static AccessibleRole AccessibleRole.AWT_COMPONENT
      一个AWT组件，但没有其他的知道它。
      static AccessibleRole AccessibleRole.CANVAS
      可以被绘制并用于捕获事件的对象。
      static AccessibleRole AccessibleRole.CHECK_BOX
      可以选中或取消选中的选项，并为当前状态提供单独的指示符。
      static AccessibleRole AccessibleRole.COLOR_CHOOSER
      允许用户选择颜色的专用窗格。
      static AccessibleRole AccessibleRole.COLUMN_HEADER
      数据列的标题。
      static AccessibleRole AccessibleRole.COMBO_BOX
      用户可以选择的选项列表。
      static AccessibleRole AccessibleRole.DATE_EDITOR
      A DATE_EDITOR是允许用户编辑 java.util.Date和 java.util.Time对象的组件。
      static AccessibleRole AccessibleRole.DESKTOP_ICON
      一个图标化的内部框架在一个 DESKTOP_PANE 。
      static AccessibleRole AccessibleRole.DESKTOP_PANE
      支持这些内部框架的内部框架和图标化版本的窗格。
      static AccessibleRole AccessibleRole.DIALOG
      标题栏和边框的顶级窗口。
      static AccessibleRole AccessibleRole.DIRECTORY_PANE
      允许用户导航并选择目录内容的窗格。
      static AccessibleRole AccessibleRole.EDITBAR
      指示对象的角色用作计算值的公式。
      static AccessibleRole AccessibleRole.FILE_CHOOSER
      一个专门的对话框，用于显示目录中的文件，并允许用户选择文件，浏览不同的目录或指定文件名。
      static AccessibleRole AccessibleRole.FILLER
      填充用户界面空间的对象。
      static AccessibleRole AccessibleRole.FONT_CHOOSER
      A FONT_CHOOSER是一个组件，可让用户为字体选择各种属性。
      static AccessibleRole AccessibleRole.FOOTER
      文字页脚。
      static AccessibleRole AccessibleRole.FRAME
      带有标题栏，边框，菜单栏等的顶级窗口
      static AccessibleRole AccessibleRole.GLASS_PANE
      保证在其下方的所有窗格的顶部绘制的窗格。
      static AccessibleRole AccessibleRole.GROUP_BOX
      A GROUP_BOX是一个简单的容器，其中包含一个边框，并在其中包含组件。
      static AccessibleRole AccessibleRole.HEADER
      文字标题
      static AccessibleRole AccessibleRole.HTML_CONTAINER
      一个包含 Accessibles的集合的对象一起表示 HTML内容。
      static AccessibleRole AccessibleRole.HYPERLINK
      超文本锚。
      static AccessibleRole AccessibleRole.ICON
      一个小的固定大小的图片，通常用于装饰组件。
      static AccessibleRole AccessibleRole.INTERNAL_FRAME
      由桌面窗格剪辑的类似帧的对象。
      static AccessibleRole AccessibleRole.LABEL
      用于在界面中呈现图标或短字符串的对象。
      static AccessibleRole AccessibleRole.LAYERED_PANE
      一个专门的窗格，允许其子层被绘制，提供一个堆叠顺序的形式。
      static AccessibleRole AccessibleRole.LIST
      向对象呈现对象的列表，并允许用户选择一个或多个对象。
      static AccessibleRole AccessibleRole.LIST_ITEM
      在列表中呈现元素的对象。
      static AccessibleRole AccessibleRole.MENU
      通常在菜单栏中找到的对象，其中包含用户可以选择的操作列表。
      static AccessibleRole AccessibleRole.MENU_BAR
      通常在应用程序的主对话框顶部绘制的对象，其中包含用户可以选择的菜单列表。
      static AccessibleRole AccessibleRole.MENU_ITEM
      一个通常包含在菜单中的对象，呈现用户可以选择的动作。
      static AccessibleRole AccessibleRole.OPTION_PANE
      主要用于 DIALOG专用窗格。
      static AccessibleRole AccessibleRole.PAGE_TAB
      作为页面选项卡列表的子对象。
      static AccessibleRole AccessibleRole.PAGE_TAB_LIST
      一个对象，通过对象提供的一些机制，一次显示一系列面板（或页面选项卡）。
      static AccessibleRole AccessibleRole.PANEL
      通常用于分组对象的通用容器。
      static AccessibleRole AccessibleRole.PARAGRAPH
      一段文字。
      static AccessibleRole AccessibleRole.PASSWORD_TEXT
      用于密码的文本对象，或文本内容未被显示给用户的其他地方。
      static AccessibleRole AccessibleRole.POPUP_MENU
      通常用于向用户提供选项列表的临时窗口，然后在用户选择其中一个选项时隐藏。
      static AccessibleRole AccessibleRole.PROGRESS_BAR
      用于指示任务已完成多少的对象。
      static AccessibleRole AccessibleRole.PROGRESS_MONITOR
      指示对象的角色监视某些操作的进度。
      static AccessibleRole AccessibleRole.PUSH_BUTTON
      用户可以操纵的对象来告诉应用程序做某事。
      static AccessibleRole AccessibleRole.RADIO_BUTTON
      一个专门的复选框将导致同一组中的其他单选按钮在选中时被取消选中。
      static AccessibleRole AccessibleRole.ROOT_PANE
      具有玻璃窗格和分层窗格作为其子项的专用窗格。
      static AccessibleRole AccessibleRole.ROW_HEADER
      一行数据的标题。
      static AccessibleRole AccessibleRole.RULER
      标尺是用于测量距离的对象。
      static AccessibleRole AccessibleRole.SCROLL_BAR
      通常用于允许用户递增地查看大量数据的对象。
      static AccessibleRole AccessibleRole.SCROLL_PANE
      允许用户逐步查看大量信息的对象。
      static AccessibleRole AccessibleRole.SEPARATOR
      通常包含在菜单中的对象以提供菜单中的内容的视觉和逻辑分离。
      static AccessibleRole AccessibleRole.SLIDER
      允许用户从有界范围内进行选择的对象。
      static AccessibleRole AccessibleRole.SPIN_BOX
      A SPIN_BOX是一个简单的微调组件，其主要用途是简单的数字。
      static AccessibleRole AccessibleRole.SPLIT_PANE
      同时提供另外两个面板的专门面板。
      static AccessibleRole AccessibleRole.STATUS_BAR
      A STATUS_BAR是一个简单的组件，可以向用户包含多个状态信息标签。
      static AccessibleRole AccessibleRole.SWING_COMPONENT
      一个Swing组件，但没有其他的知道它。
      static AccessibleRole AccessibleRole.TABLE
      用于根据行和列提供信息的对象。
      static AccessibleRole AccessibleRole.TEXT
      向用户显示文本的对象。
      static AccessibleRole AccessibleRole.TOGGLE_BUTTON
      可以检查或取消选中的专用按钮，但不提供当前状态的单独指示器。
      static AccessibleRole AccessibleRole.TOOL_BAR
      通常由按钮或切换按钮组成的酒吧或调色板。
      static AccessibleRole AccessibleRole.TOOL_TIP
      提供有关另一个对象的信息的对象。
      static AccessibleRole AccessibleRole.TREE
      用于向用户呈现分层信息的对象。
      static AccessibleRole AccessibleRole.UNKNOWN
      该对象包含一些 Accessible信息，但其作用尚不清楚。
      static AccessibleRole AccessibleRole.VIEWPORT
      通常在滚动窗格中使用的对象。
      static AccessibleRole AccessibleRole.WINDOW
      没有标题或边框的顶级窗口。
      Methods in javax.accessibility that return AccessibleRole
      Modifier and Type 方法 描述
      abstract AccessibleRole AccessibleContext.getAccessibleRole​()
      获得此对象的作用。

    • Uses of AccessibleRole in javax.swing

      Methods in javax.swing that return AccessibleRole
      Modifier and Type | 方法 | 描述
      AccessibleRole Box.AccessibleBox.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole Box.Filler.AccessibleBoxFiller.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole CellRendererPane.AccessibleCellRendererPane.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole ImageIcon.AccessibleImageIcon.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JButton.AccessibleJButton.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JCheckBox.AccessibleJCheckBox.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JColorChooser.AccessibleJColorChooser.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JComboBox.AccessibleJComboBox.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JComponent.AccessibleJComponent.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JDesktopPane.AccessibleJDesktopPane.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JFileChooser.AccessibleJFileChooser.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JInternalFrame.AccessibleJInternalFrame.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JLabel.AccessibleJLabel.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JLayeredPane.AccessibleJLayeredPane.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole | JList.AccessibleJList.AccessibleJListChild.getAccessibleRole​()
      AccessibleRole JList.AccessibleJList.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JMenu.AccessibleJMenu.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JMenuBar.AccessibleJMenuBar.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JMenuItem.AccessibleJMenuItem.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JOptionPane.AccessibleJOptionPane.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JPanel.AccessibleJPanel.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JPasswordField.AccessibleJPasswordField.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JPopupMenu.AccessibleJPopupMenu.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JProgressBar.AccessibleJProgressBar.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JRadioButton.AccessibleJRadioButton.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JRootPane.AccessibleJRootPane.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JScrollBar.AccessibleJScrollBar.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JScrollPane.AccessibleJScrollPane.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JSeparator.AccessibleJSeparator.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JSlider.AccessibleJSlider.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JSpinner.AccessibleJSpinner.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JSplitPane.AccessibleJSplitPane.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JTabbedPane.AccessibleJTabbedPane.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JTable.AccessibleJTable.getAccessibleRole​()
      获得此对象的作用。
      AccessibleRole JToggleButton.AccessibleJToggleButton.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JToolBar.AccessibleJToolBar.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JToolTip.AccessibleJToolTip.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JTree.AccessibleJTree.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole JViewport.AccessibleJViewport.getAccessibleRole​()
      获取此对象的角色。
      AccessibleRole ProgressMonitor.AccessibleProgressMonitor.getAccessibleRole​()
      获得此对象的作用。

    • Uses of AccessibleRole in javax.swing.table

      Methods in javax.swing.table that return AccessibleRole
      Modifier and Type | 方法 | 描述
      AccessibleRole | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleRole​()
      AccessibleRole JTableHeader.AccessibleJTableHeader.getAccessibleRole​()
      获取此对象的角色。

    • Uses of AccessibleRole in javax.swing.text

      Methods in javax.swing.text that return AccessibleRole
      Modifier and Type 方法 描述
      AccessibleRole JTextComponent.AccessibleJTextComponent.getAccessibleRole​()
      获得此对象的作用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleState (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleState

  • Packages that use AccessibleState
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。

    • Uses of AccessibleState in javax.accessibility

      Fields in javax.accessibility declared as AccessibleState
      Modifier and Type Field 描述
      static AccessibleState AccessibleState.ACTIVE
      表示窗口当前是活动窗口。
      static AccessibleState AccessibleState.ARMED
      表示对象已布防。
      static AccessibleState AccessibleState.BUSY
      表示当前对象正在忙。
      static AccessibleState AccessibleState.CHECKED
      表示此对象当前已被选中。
      static AccessibleState AccessibleState.COLLAPSED
      表示此对象已折叠。
      static AccessibleState AccessibleState.EDITABLE
      表示用户可以更改此对象的内容。
      static AccessibleState AccessibleState.ENABLED
      表示此对象已启用。
      static AccessibleState AccessibleState.EXPANDABLE
      表示此对象允许逐渐披露其子项。
      static AccessibleState AccessibleState.EXPANDED
      表示此对象已展开。
      static AccessibleState AccessibleState.FOCUSABLE
      表示此对象可以接受键盘焦点，这意味着通过在键盘上打字产生的所有事件通常会在焦点时传递给它。
      static AccessibleState AccessibleState.FOCUSED
      表示此对象当前具有键盘焦点。
      static AccessibleState AccessibleState.HORIZONTAL
      表示此对象的方向是水平的。
      static AccessibleState AccessibleState.ICONIFIED
      表示此对象被最小化，仅由图标表示。
      static AccessibleState AccessibleState.INDETERMINATE
      表示对象状态不确定。
      static AccessibleState AccessibleState.MANAGES_DESCENDANTS
      表示此对象负责管理其子组件。
      static AccessibleState AccessibleState.MODAL
      在用户可以与不同窗口中的对象进行交互之前，表示必须使用此对象完成任务。
      static AccessibleState AccessibleState.MULTI_LINE
      表示此（文本）对象可以包含多行文本。
      static AccessibleState AccessibleState.MULTISELECTABLE
      表示此对象允许同时选择多个子项。
      static AccessibleState AccessibleState.OPAQUE
      表示此对象绘制其矩形区域内的每个像素。
      static AccessibleState AccessibleState.PRESSED
      表示此对象当前按下。
      static AccessibleState AccessibleState.RESIZABLE
      表示此对象的大小不固定。
      static AccessibleState AccessibleState.SELECTABLE
      表示此对象是允许其子项被选中的对象的子对象，并且该子对象是可选择的其中一个子对象。
      static AccessibleState AccessibleState.SELECTED
      表示此对象是允许其子项被选中的对象的子对象，并且该子对象是已选择的其中一个子对象。
      static AccessibleState AccessibleState.SHOWING
      表示此对象，对象的父对象，父对象的父对象等都可见。
      static AccessibleState AccessibleState.SINGLE_LINE
      表示此（文本）对象只能包含一行文本。
      static AccessibleState AccessibleState.TRANSIENT
      表示此对象是短暂的。
      static AccessibleState AccessibleState.TRUNCATED
      指示文本被边框矩形截断并且某些文本不显示在屏幕上的状态。
      static AccessibleState AccessibleState.VERTICAL
      表示此对象的方向是垂直的。
      static AccessibleState AccessibleState.VISIBLE
      表示此对象可见。
      Fields in javax.accessibility with type parameters of type AccessibleState
      Modifier and Type Field 描述
      protected Vector<AccessibleState> AccessibleStateSet.states
      Vector每个条目代表 AccessibleState 。
      Methods in javax.accessibility that return AccessibleState
      Modifier and Type 方法 描述
      AccessibleState[] AccessibleStateSet.toArray​()
      将当前状态设置为 AccessibleState的数组。
      Methods in javax.accessibility with parameters of type AccessibleState
      Modifier and Type 方法 描述
      boolean AccessibleStateSet.add​(AccessibleState state)
      如果当前状态集不存在，则添加一个新状态。
      void AccessibleStateSet.addAll​(AccessibleState[] states)
      将所有状态添加到现有状态集。
      boolean AccessibleStateSet.contains​(AccessibleState state)
      检查当前状态是否处于状态集。
      boolean AccessibleStateSet.remove​(AccessibleState state)
      从当前状态集中删除状态。
      Constructors in javax.accessibility with parameters of type AccessibleState
      Constructor 描述
      AccessibleStateSet​(AccessibleState[] states)
      Creates a new state with the initial set of states contained in the array of states passed in.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleStateSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleStateSet

  • Packages that use AccessibleStateSet
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of AccessibleStateSet in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return AccessibleStateSet
      Modifier and Type 方法 描述
      AccessibleStateSet Translator.getAccessibleStateSet​()
      给定一个已经填充的状态的这个对象的状态。

    • Uses of AccessibleStateSet in java.applet

      Methods in java.applet that return AccessibleStateSet
      Modifier and Type 方法 描述
      AccessibleStateSet Applet.AccessibleApplet.getAccessibleStateSet​()
      获取此对象的状态。

    • Uses of AccessibleStateSet in java.awt

      Methods in java.awt that return AccessibleStateSet
      Modifier and Type 方法 描述
      AccessibleStateSet Checkbox.AccessibleAWTCheckbox.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet Component.AccessibleAWTComponent.getAccessibleStateSet​()
      获取此对象的状态。
      AccessibleStateSet Dialog.AccessibleAWTDialog.getAccessibleStateSet​()
      获取此对象的状态。
      AccessibleStateSet Frame.AccessibleAWTFrame.getAccessibleStateSet​()
      获取此对象的状态。
      AccessibleStateSet List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet List.AccessibleAWTList.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet MenuComponent.AccessibleAWTMenuComponent.getAccessibleStateSet​()
      获取此对象的状态。
      AccessibleStateSet Scrollbar.AccessibleAWTScrollBar.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet TextArea.AccessibleAWTTextArea.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet TextComponent.AccessibleAWTTextComponent.getAccessibleStateSet​()
      获取TextComponent的状态集。
      AccessibleStateSet TextField.AccessibleAWTTextField.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet Window.AccessibleAWTWindow.getAccessibleStateSet​()
      获取此对象的状态。

    • Uses of AccessibleStateSet in javax.accessibility

      Methods in javax.accessibility that return AccessibleStateSet
      Modifier and Type 方法 描述
      abstract AccessibleStateSet AccessibleContext.getAccessibleStateSet​()
      获取此对象的状态集。

    • Uses of AccessibleStateSet in javax.swing

      Methods in javax.swing that return AccessibleStateSet
      Modifier and Type | 方法 | 描述
      AccessibleStateSet AbstractButton.AccessibleAbstractButton.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet ImageIcon.AccessibleImageIcon.getAccessibleStateSet​()
      获取此对象的状态。
      AccessibleStateSet JComboBox.AccessibleJComboBox.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JComponent.AccessibleJComponent.getAccessibleStateSet​()
      获取此对象的状态。
      AccessibleStateSet JDialog.AccessibleJDialog.getAccessibleStateSet​()
      获取此对象的状态。
      AccessibleStateSet JEditorPane.AccessibleJEditorPane.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JFrame.AccessibleJFrame.getAccessibleStateSet​()
      获取此对象的状态。
      AccessibleStateSet | JList.AccessibleJList.AccessibleJListChild.getAccessibleStateSet​()
      AccessibleStateSet JList.AccessibleJList.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JMenuBar.AccessibleJMenuBar.getAccessibleStateSet​()
      获取此对象的可访问状态集。
      AccessibleStateSet JProgressBar.AccessibleJProgressBar.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JScrollBar.AccessibleJScrollBar.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JSlider.AccessibleJSlider.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JSplitPane.AccessibleJSplitPane.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JTextArea.AccessibleJTextArea.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JTextField.AccessibleJTextField.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet JToolBar.AccessibleJToolBar.getAccessibleStateSet​()
      获取此对象的状态。
      AccessibleStateSet JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleStateSet ProgressMonitor.AccessibleProgressMonitor.getAccessibleStateSet​()
      获取此对象的状态集。
      static AccessibleStateSet SwingUtilities.getAccessibleStateSet​(Component c)
      获取此对象的状态。

    • Uses of AccessibleStateSet in javax.swing.table

      Methods in javax.swing.table that return AccessibleStateSet
      Modifier and Type | 方法 | 描述
      AccessibleStateSet | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleStateSet​()

    • Uses of AccessibleStateSet in javax.swing.text

      Methods in javax.swing.text that return AccessibleStateSet
      Modifier and Type 方法 描述
      AccessibleStateSet JTextComponent.AccessibleJTextComponent.getAccessibleStateSet​()
      Gets the state set of the JTextComponent.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.accessibility.AccessibleTextSequence (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.accessibility.AccessibleTextSequence

  • Packages that use AccessibleTextSequence
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of AccessibleTextSequence in javax.accessibility

      Methods in javax.accessibility that return AccessibleTextSequence
      Modifier and Type 方法 描述
      AccessibleTextSequence AccessibleExtendedText.getTextSequenceAfter​(int part, int index)
      给定索引后返回 AccessibleTextSequence 。
      AccessibleTextSequence AccessibleExtendedText.getTextSequenceAt​(int part, int index)
      返回给定索引的 AccessibleTextSequence 。
      AccessibleTextSequence AccessibleExtendedText.getTextSequenceBefore​(int part, int index)
      返回给定索引前的 AccessibleTextSequence 。

    • Uses of AccessibleTextSequence in javax.swing

      Methods in javax.swing that return AccessibleTextSequence
      Modifier and Type 方法 描述
      AccessibleTextSequence JPasswordField.AccessibleJPasswordField.getTextSequenceAfter​(int part, int index)
      返回 AccessibleTextSequence给定后 index 。
      AccessibleTextSequence JPasswordField.AccessibleJPasswordField.getTextSequenceAt​(int part, int index)
      返回 AccessibleTextSequence在给定 index 。
      AccessibleTextSequence JPasswordField.AccessibleJPasswordField.getTextSequenceBefore​(int part, int index)
      返回 AccessibleTextSequence之前给定的 index 。

    • Uses of AccessibleTextSequence in javax.swing.text

      Methods in javax.swing.text that return AccessibleTextSequence
      Modifier and Type 方法 描述
      AccessibleTextSequence JTextComponent.AccessibleJTextComponent.getTextSequenceAfter​(int part, int index)
      返回 AccessibleTextSequence给定后 index 。
      AccessibleTextSequence JTextComponent.AccessibleJTextComponent.getTextSequenceAt​(int part, int index)
      返回 AccessibleTextSequence在给定的 index 。
      AccessibleTextSequence JTextComponent.AccessibleJTextComponent.getTextSequenceBefore​(int part, int index)
      返回 AccessibleTextSequence之前给定的 index 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.Accessible (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.Accessible

  • Packages that use Accessible
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of Accessible in com.sun.java.accessibility.util

      Classes in com.sun.java.accessibility.util that implement Accessible
      Modifier and Type Class 描述
      class  Translator
      Translator类为不实现接口Accessible对象提供了一个到接口Accessible的翻译。
      Methods in com.sun.java.accessibility.util that return Accessible
      Modifier and Type 方法 描述
      static Accessible Translator.getAccessible​(Object o)
      获取实现接口 Accessible的对象。
      static Accessible EventQueueMonitor.getAccessibleAt​(Point p)
      在屏幕上的给定点获取Accessible对象。
      Accessible Translator.getAccessibleAt​(Point p)
      返回包含在本地坐标Point（如果存在）的可访问子项。
      Accessible Translator.getAccessibleChild​(int i)
      返回对象的第n个可访问的小孩。
      Accessible Translator.getAccessibleParent​()
      获取此对象的可访问父级。

    • Uses of Accessible in java.applet

      Classes in java.applet that implement Accessible
      Modifier and Type Class 描述
      class  Applet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of Accessible in java.awt

      Classes in java.awt that implement Accessible
      Modifier and Type Class 描述
      class  Button
      这个类创建一个标记的按钮。
      class  Canvas
      A Canvas组件表示应用程序可以绘制的屏幕的空白矩形区域，或者应用程序可以从中捕获来自用户的输入事件。
      class  Checkbox
      复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。
      class  CheckboxMenuItem
      此类表示可以包含在菜单中的复选框。
      class  Choice
      Choice课程提供了弹出菜单的选择。
      class  Dialog
      Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
      class  FileDialog
      FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
      class  Frame
      A Frame是具有标题和边框的顶级窗口。
      class  Label
      A Label对象是用于将文本放置在容器中的组件。
      class  List
      List组件向用户显示文本项的滚动列表。
      protected class  List.AccessibleAWTList.AccessibleAWTListChild
      此类实现对List子项的可访问性支持。
      class  Menu
      Menu对象是从菜单栏部署的下拉菜单组件。
      class  MenuBar
      MenuBar类封装了平台与框架绑定的菜单栏的概念。
      class  MenuItem
      菜单中的所有项目必须属于类 MenuItem或其子类之一。
      class  Panel
      Panel是最简单的容器类。
      class  PopupMenu
      一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。
      class  Scrollbar
      Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。
      class  ScrollPane
      一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。
      class  TextArea
      一个 TextArea对象是一个显示文本的多行区域。
      class  TextComponent
      TextComponent类是允许编辑某些文本的任何组件的超类。
      class  TextField
      TextField对象是允许编辑单行文本的文本组件。
      class  Window
      一个 Window对象是没有边框的顶级窗口，没有菜单。
      Methods in java.awt that return Accessible
      Modifier and Type 方法 描述
      Accessible Component.AccessibleAWTComponent.getAccessibleAt​(Point p)
      返回 Accessible小孩，如果存在，则包含在本地坐标 Point 。
      Accessible Container.AccessibleAWTContainer.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
      Accessible List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleAt​(Point p)
      返回 Accessible小孩，如果存在，则包含在本地坐标 Point 。
      Accessible List.AccessibleAWTList.getAccessibleAt​(Point p)
      返回包含在本地坐标Point（如果存在）的Accessible子项。
      Accessible MenuComponent.AccessibleAWTMenuComponent.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
      Accessible Component.AccessibleAWTComponent.getAccessibleChild​(int i)
      返回对象的第n个 Accessible子对象。
      Accessible Container.AccessibleAWTContainer.getAccessibleChild​(int i)
      返回对象的第n个 Accessible子对象。
      Accessible List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleChild​(int i)
      返回对象的指定Accessible子对象。
      Accessible List.AccessibleAWTList.getAccessibleChild​(int i)
      返回对象的第n个可访问子对象。
      Accessible MenuComponent.AccessibleAWTMenuComponent.getAccessibleChild​(int i)
      返回对象的第n个 Accessible子对象。
      Accessible Component.AccessibleAWTComponent.getAccessibleParent​()
      获取此对象的 Accessible父项。
      Accessible MenuComponent.AccessibleAWTMenuComponent.getAccessibleParent​()
      获取此对象的 Accessible父项。
      Accessible List.AccessibleAWTList.getAccessibleSelection​(int i)
      返回表示对象中指定的选定项的Accessible。
      Accessible MenuComponent.AccessibleAWTMenuComponent.getAccessibleSelection​(int i)
      返回表示对象中指定的选定子项的 Accessible 。

    • Uses of Accessible in javax.accessibility

      Fields in javax.accessibility declared as Accessible
      Modifier and Type Field 描述
      protected Accessible AccessibleContext.accessibleParent
      该对象的可访问父级。
      Methods in javax.accessibility that return Accessible
      Modifier and Type 方法 描述
      Accessible AccessibleComponent.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在的话）包含在本地坐标 Point 。
      Accessible AccessibleTable.getAccessibleAt​(int r, int c)
      返回表中指定行和列的 Accessible 。
      Accessible AccessibleTable.getAccessibleCaption​()
      返回表的标题。
      abstract Accessible AccessibleContext.getAccessibleChild​(int i)
      返回对象的指定的 Accessible子对象。
      Accessible AccessibleTable.getAccessibleColumnDescription​(int c)
      返回表中指定列的描述文本。
      Accessible AccessibleContext.getAccessibleParent​()
      获取此对象的父母 Accessible 。
      Accessible AccessibleTable.getAccessibleRowDescription​(int r)
      返回表中指定行的描述。
      Accessible AccessibleSelection.getAccessibleSelection​(int i)
      返回表示对象的指定选定子对象的 Accessible 。
      Accessible AccessibleTable.getAccessibleSummary​()
      返回表的摘要说明。
      Methods in javax.accessibility with parameters of type Accessible
      Modifier and Type 方法 描述
      void AccessibleTable.setAccessibleCaption​(Accessible a)
      设置表格的标题。
      void AccessibleTable.setAccessibleColumnDescription​(int c, Accessible a)
      设置表中指定列的描述文本。
      void AccessibleContext.setAccessibleParent​(Accessible a)
      设置此对象的 Accessible父对象。
      void AccessibleTable.setAccessibleRowDescription​(int r, Accessible a)
      设置表的指定行的描述文本。
      void AccessibleTable.setAccessibleSummary​(Accessible a)
      设置表的摘要说明。

    • Uses of Accessible in javax.swing

      Classes in javax.swing that implement Accessible
      Modifier and Type Class 描述
      class  Box
      一个使用BoxLayout对象作为其布局管理器的轻量级容器。
      static class  Box.Filler
      参与布局但没有视图的轻量级组件的实现。
      class  CellRendererPane
      此类插入到单元格渲染器和使用它们的组件之间。
      class  DefaultListCellRenderer
      渲染列表中的项目。
      static class  DefaultListCellRenderer.UIResource
      实现UIResource的DefaultListCellRenderer的子类。
      class  ImageIcon
      从图像绘制图标的图标界面的实现。
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      class  JButton
      实现“推”按钮。
      class  JCheckBox
      复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
      class  JCheckBoxMenuItem
      可以选择或取消选择的菜单项。
      class  JColorChooser
      JColorChooser提供了一个设计用于允许用户操纵和选择颜色的控件窗格。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      class  JDesktopPane
      用于创建多文档界面或虚拟桌面的容器。
      class  JDialog
      创建对话窗口的主要类。
      class  JEditorPane
      用于编辑各种内容的文本组件。
      class  JFileChooser
      JFileChooser为用户提供了一种简单的选择文件的机制。
      class  JFormattedTextField
      JFormattedTextField扩展了 JTextField增加了格式化任意值的支持，以及一旦用户编辑文本，就检索特定的对象。
      class  JFrame
      扩展版本的 java.awt.Frame ，增加了对JFC / Swing组件架构的支持。
      class  JInternalFrame
      一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。
      static class  JInternalFrame.JDesktopIcon
      该组件代表 JInternalFrame的图标化版本。
      class  JLabel
      用于短文本字符串或图像的显示区域，或两者。
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并接收其边框内生成的所有 AWTEvent的通知。
      class  JLayeredPane
      JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。
      class  JList<E>
      显示对象列表并允许用户选择一个或多个项目的组件。
      protected class  JList.AccessibleJList.AccessibleJListChild
      该类实现适用于列表子级的辅助功能支持。
      class  JMenu
      一个菜单的实现 - 一个包含 JMenuItem s的弹出窗口，当用户在 JMenuBar上选择一个项目时 JMenuBar 。
      class  JMenuBar
      一个菜单栏的实现。
      class  JMenuItem
      菜单中项目的实现。
      class  JOptionPane
      JOptionPane可以方便地弹出一个标准对话框，提示用户获取值或通知他们某些东西。
      class  JPanel
      JPanel是一个通用的轻量级容器。
      class  JPasswordField
      JPasswordField是一个轻量级组件，允许编辑单行文本，其中视图表示某些内容是键入的，但不显示原始字符。
      class  JPopupMenu
      弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。
      static class  JPopupMenu.Separator
      弹出菜单特定的分隔符。
      class  JProgressBar
      可视化显示某些任务进度的组件。
      class  JRadioButton
      单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
      class  JRadioButtonMenuItem
      单选按钮菜单项的实现。
      class  JRootPane
      通过在后台使用一个轻量级容器 JFrame ， JDialog ， JWindow ， JApplet ，并 JInternalFrame 。
      class  JScrollBar
      一个滚动条的实现。
      class  JScrollPane
      提供轻量级组件的可滚动视图。
      protected class  JScrollPane.ScrollBar
      默认情况下， JScrollPane创建作为此类的实例的滚动条。
      class  JSeparator
      JSeparator提供了一种用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。
      class  JSlider
      允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。
      class  JSpinner
      单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。
      static class  JSpinner.DateEditor
      一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。
      static class  JSpinner.DefaultEditor
      更专业的编辑器的简单基础类，用于显示模型当前值的只读视图，并具有 JFormattedTextField 。
      static class  JSpinner.ListEditor
      一个 JSpinner的编辑器，其型号是 SpinnerListModel 。
      static class  JSpinner.NumberEditor
      一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
      class  JSplitPane
      JSplitPane用于划分两个（只有两个） Component s。
      class  JTabbedPane
      通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。
      class  JTable
      JTable用于显示和编辑单元格的常规二维表。
      protected class  JTable.AccessibleJTable.AccessibleJTableCell
      该类提供了适用于表单元格的Java Accessibility API的实现。
      class  JTextArea
      A JTextArea是显示纯文本的多行区域。
      class  JTextField
      JTextField是一个轻量级组件，允许编辑单行文本。
      class  JTextPane
      可以用图形化的属性标记的文本组件。
      class  JToggleButton
      一个两状态按钮的实现。
      class  JToolBar
      JToolBar提供了一个组件，可用于显示常用的 Action或控件。
      static class  JToolBar.Separator
      工具栏特定的分隔符。
      class  JToolTip
      用于显示组件的“提示”。
      class  JTree
      将一组分层数据显示为轮廓的控件。
      protected class  JTree.AccessibleJTree.AccessibleJTreeNode
      该类为 JTree孩子实现可访问性支持。
      class  JViewport
      您可以通过它查看基础信息的“视口”或“舷窗”。
      class  JWindow
      A JWindow是可以显示在用户桌面上任何位置的容器。
      class  ProgressMonitor
      一类监视某些操作的进度。
      Methods in javax.swing that return Accessible
      Modifier and Type | 方法 | 描述
      Accessible JEditorPane.AccessibleJEditorPaneHTML.getAccessibleAt​(Point p)
      返回Accessible小组（如果存在）包含在本地坐标Point。
      Accessible | JList.AccessibleJList.AccessibleJListChild.getAccessibleAt​(Point p)
      Accessible JList.AccessibleJList.getAccessibleAt​(Point p)
      返回包含在本地坐标 Point中的 Accessible子 Point （如果存在）。
      Accessible JTabbedPane.AccessibleJTabbedPane.getAccessibleAt​(Point p)
      返回包含在本地坐标 Point中的 Accessible子 Point （如果存在）。
      Accessible | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAt​(Point p)
      Accessible | JTable.AccessibleJTable.getAccessibleAt​(int r, int c)
      Accessible JTable.AccessibleJTable.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果有的话）包含在本地坐标 Point 。
      Accessible JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAt​(Point p)
      返回 Accessible子，如果存在，则包含在本地坐标 Point 。
      Accessible JTree.AccessibleJTree.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
      static Accessible SwingUtilities.getAccessibleAt​(Component c, Point p)
      返回包含在本地坐标 Point中的 Accessible子 Point （如果存在）。
      Accessible JTable.AccessibleJTable.getAccessibleCaption​()
      返回表的标题。
      Accessible ImageIcon.AccessibleImageIcon.getAccessibleChild​(int i)
      返回对象的第n个可访问子对象。
      Accessible JComboBox.AccessibleJComboBox.getAccessibleChild​(int i)
      返回对象的第n个可访问子对象。
      Accessible JComponent.AccessibleJComponent.getAccessibleChild​(int i)
      返回对象的第n个可访问子对象。
      Accessible JEditorPane.AccessibleJEditorPaneHTML.getAccessibleChild​(int i)
      返回对象的指定Accessible子对象。
      Accessible | JList.AccessibleJList.AccessibleJListChild.getAccessibleChild​(int i)
      Accessible JList.AccessibleJList.getAccessibleChild​(int i)
      返回对象的第n个可访问子对象。
      Accessible JMenu.AccessibleJMenu.getAccessibleChild​(int i)
      返回对象的第n个可访问子对象。
      Accessible JRootPane.AccessibleJRootPane.getAccessibleChild​(int i)
      返回对象的指定Accessible子对象。
      Accessible JSpinner.AccessibleJSpinner.getAccessibleChild​(int i)
      返回对象的指定Accessible子对象。
      Accessible JTabbedPane.AccessibleJTabbedPane.getAccessibleChild​(int i)
      返回对象的指定Accessible子对象。
      Accessible JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleChild​(int i)
      返回对象的指定的 Accessible子对象。
      Accessible JTable.AccessibleJTable.getAccessibleChild​(int i)
      返回对象的第n个 Accessible子对象。
      Accessible JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleChild​(int i)
      返回对象的指定Accessible子对象。
      Accessible JTree.AccessibleJTree.getAccessibleChild​(int i)
      返回对象的第n个可访问子对象。
      Accessible ProgressMonitor.AccessibleProgressMonitor.getAccessibleChild​(int i)
      返回对象的指定Accessible子对象。
      static Accessible SwingUtilities.getAccessibleChild​(Component c, int i)
      返回对象的第n个可访问子对象。
      Accessible JTable.AccessibleJTable.getAccessibleColumnDescription​(int c)
      返回表中指定列的描述。
      Accessible ImageIcon.AccessibleImageIcon.getAccessibleParent​()
      获取此对象的可访问父项。
      Accessible JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleParent​()
      获取此对象的 Accessible父项。
      Accessible JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleParent​()
      获取此对象的Accessible父项。
      Accessible ProgressMonitor.AccessibleProgressMonitor.getAccessibleParent​()
      获取此对象的可访问父项。
      Accessible JTable.AccessibleJTable.getAccessibleRowDescription​(int r)
      返回表中指定行的描述。
      Accessible JComboBox.AccessibleJComboBox.getAccessibleSelection​(int i)
      返回代表弹出窗口中指定的选定子项的Accessible。
      Accessible JList.AccessibleJList.getAccessibleSelection​(int i)
      返回表示对象中指定的选定项的Accessible。
      Accessible JMenu.AccessibleJMenu.getAccessibleSelection​(int i)
      如果选择了一个，返回当前选择的子菜单，否则为空（只能有一个选项，只能是子菜单，否则菜单项不会被选中）。
      Accessible JMenuBar.AccessibleJMenuBar.getAccessibleSelection​(int i)
      如果选择了一个菜单，返回当前选择的菜单，否则返回null。
      Accessible | JTabbedPane.AccessibleJTabbedPane.getAccessibleSelection​(int i)
      Accessible JTable.AccessibleJTable.getAccessibleSelection​(int i)
      返回一个 Accessible表示对象中指定的选定子项。
      Accessible JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleSelection​(int i)
      返回表示对象中指定的选定项的Accessible。
      Accessible JTree.AccessibleJTree.getAccessibleSelection​(int i)
      返回表示对象中指定的选定项的Accessible。
      Accessible JTable.AccessibleJTable.getAccessibleSummary​()
      返回表的摘要说明。
      Methods in javax.swing with parameters of type Accessible
      Modifier and Type 方法 描述
      void JTable.AccessibleJTable.setAccessibleCaption​(Accessible a)
      设置表格的标题。
      void JTable.AccessibleJTable.setAccessibleColumnDescription​(int c, Accessible a)
      设置表的指定列的描述文本。
      void JTable.AccessibleJTable.setAccessibleRowDescription​(int r, Accessible a)
      设置表的指定行的描述文本。
      void JTable.AccessibleJTable.setAccessibleSummary​(Accessible a)
      设置表的摘要说明。
      Constructors in javax.swing with parameters of type Accessible
      Constructor 描述
      AccessibleJTreeNode​(JTree t, TreePath p, Accessible ap)
      构造一个AccessibleJTreeNode

    • Uses of Accessible in javax.swing.colorchooser

      Classes in javax.swing.colorchooser that implement Accessible
      Modifier and Type Class 描述
      class  AbstractColorChooserPanel
      这是颜色选择器的抽象超类。

    • Uses of Accessible in javax.swing.plaf

      Methods in javax.swing.plaf that return Accessible
      Modifier and Type 方法 描述
      Accessible ComponentUI.getAccessibleChild​(JComponent c, int i)
      返回对象的 i th Accessible小孩。

    • Uses of Accessible in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement Accessible
      Modifier and Type Class 描述
      class  BasicArrowButton
      JButton对象在其中一个主要方向上绘制了一个缩放的箭头。
      class  BasicComboBoxRenderer
      ComboBox渲染器
      static class  BasicComboBoxRenderer.UIResource
      BasicComboBoxRenderer的子类实现UIResource。
      class  BasicComboPopup
      这是 ComboPopup接口的基本实现。
      class  BasicInternalFrameTitlePane.SystemMenuBar
      这个类应该被视为一个“受保护”的内部类。
      protected class  BasicToolBarUI.DragWindow
      在拖动 JToolBar期间出现的窗口。
      Methods in javax.swing.plaf.basic that return Accessible
      Modifier and Type | 方法 | 描述
      Accessible | BasicComboBoxUI.getAccessibleChild​(JComponent c, int i)

    • Uses of Accessible in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement Accessible
      Modifier and Type Class 描述
      class  MetalComboBoxButton
      JButton子类来帮助MetalComboBoxUI
      class  MetalComboBoxUI.MetalComboPopup
      已过时。
      从Java 2平台v1.4开始。
      protected class  MetalFileChooserUI.FileRenderer
      已过时。
      截至JDK版本9.过时的课程。
      class  MetalFileChooserUI.FilterComboBoxRenderer
      渲染不同类型的尺寸和样式。
      class  MetalScrollButton
      金属滚动条箭头的JButton对象。

    • Uses of Accessible in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return Accessible
      Modifier and Type 方法 描述
      Accessible MultiButtonUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiColorChooserUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiComboBoxUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiDesktopIconUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiDesktopPaneUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiFileChooserUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiInternalFrameUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiLabelUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiListUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiMenuBarUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiMenuItemUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiOptionPaneUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiPanelUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiPopupMenuUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiProgressBarUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiRootPaneUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiScrollBarUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiScrollPaneUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiSeparatorUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiSliderUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiSpinnerUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiSplitPaneUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiTabbedPaneUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiTableHeaderUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiTableUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiTextUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiToolBarUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiToolTipUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiTreeUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。
      Accessible MultiViewportUI.getAccessibleChild​(JComponent a, int b)
      在此对象处理的每个UI上调用 getAccessibleChild方法。

    • Uses of Accessible in javax.swing.table

      Classes in javax.swing.table that implement Accessible
      Modifier and Type Class 描述
      class  DefaultTableCellRenderer
      在 JTable渲染（显示）单个单元格的标准类。
      static class  DefaultTableCellRenderer.UIResource
      DefaultTableCellRenderer的子类实现 UIResource 。
      class  JTableHeader
      这是管理 JTable的标题的 JTable 。
      protected class  JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
      该类提供了适用于JTableHeader条目的Java Accessibility API的实现。
      Methods in javax.swing.table that return Accessible
      Modifier and Type | 方法 | 描述
      Accessible | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAt​(Point p)
      Accessible JTableHeader.AccessibleJTableHeader.getAccessibleAt​(Point p)
      返回Accessible小组（如果存在）包含在本地坐标Point。
      Accessible | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleChild​(int i)
      Accessible JTableHeader.AccessibleJTableHeader.getAccessibleChild​(int i)
      返回对象的第n个可访问子对象。

    • Uses of Accessible in javax.swing.text

      Classes in javax.swing.text that implement Accessible
      Modifier and Type Class 描述
      class  JTextComponent
      JTextComponent是摆动文本组件的基类。

    • Uses of Accessible in javax.swing.text.html

      Classes in javax.swing.text.html that implement Accessible
      Modifier and Type Class 描述
      class  HTMLEditorKit
      Swing JEditorPane文本组件通过称为EditorKit的插件机制来支持不同类型的内容。

    • Uses of Accessible in javax.swing.tree

      Classes in javax.swing.tree that implement Accessible
      Modifier and Type Class 描述
      class  DefaultTreeCellEditor.DefaultTextField
      TextField未提供编辑器时使用。
      class  DefaultTreeCellRenderer
      在树中显示一个条目。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleAction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleAction

  • Packages that use AccessibleAction
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of AccessibleAction in java.awt

      Classes in java.awt that implement AccessibleAction
      Modifier and Type Class 描述
      protected class  Button.AccessibleAWTButton
      这个类实现 Button类的可访问性支持。
      protected class  Checkbox.AccessibleAWTCheckbox
      该类实现 Checkbox类的可访问性支持。
      protected class  CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
      用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。
      protected class  Choice.AccessibleAWTChoice
      该类实现 Choice类的可访问性支持。
      protected class  Menu.AccessibleAWTMenu
      菜单的内部类用于提供对辅助功能的默认支持。
      protected class  MenuItem.AccessibleAWTMenuItem
      MenuItem的内部类用于为辅助功能提供默认支持。
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。
      Methods in java.awt that return AccessibleAction
      Modifier and Type 方法 描述
      AccessibleAction Button.AccessibleAWTButton.getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      AccessibleAction Checkbox.AccessibleAWTCheckbox.getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      AccessibleAction CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      AccessibleAction Choice.AccessibleAWTChoice.getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      AccessibleAction MenuItem.AccessibleAWTMenuItem.getAccessibleAction​()
      获取与此对象关联的AccessibleAction。

    • Uses of AccessibleAction in javax.accessibility

      Classes in javax.accessibility that implement AccessibleAction
      Modifier and Type Class 描述
      class  AccessibleHyperlink
      在超文本文件中封装链接或一组链接（例如客户端图像映射）
      Methods in javax.accessibility that return AccessibleAction
      Modifier and Type 方法 描述
      AccessibleAction AccessibleContext.getAccessibleAction​()
      获取支持一个或多个操作的此对象关联的 AccessibleAction 。

    • Uses of AccessibleAction in javax.swing

      Classes in javax.swing that implement AccessibleAction
      Modifier and Type Class 描述
      protected class  AbstractButton.AccessibleAbstractButton
      这个类实现 AbstractButton类的可访问性支持。
      protected class  JButton.AccessibleJButton
      该类为 JButton类实现可访问性支持。
      protected class  JCheckBox.AccessibleJCheckBox
      该类实现 JCheckBox类的可访问性支持。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      该类实现 JCheckBoxMenuItem类的可访问性支持。
      protected class  JComboBox.AccessibleJComboBox
      这个类实现 JComboBox类的辅助功能支持。
      protected class  JEditorPane.AccessibleJEditorPane
      该类实现 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供对 AccessibleHypertext支持，并且在 EditorKit安装的 JEditorPane是 JEditorPane的实例的情况下 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText 。
      class  JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
      一个HTML链接。
      protected class  JList.AccessibleJList.AccessibleJListChild
      该类实现适用于列表子级的辅助功能支持。
      protected class  JMenu.AccessibleJMenu
      该类为 JMenu类实现可访问性支持。
      protected class  JMenuItem.AccessibleJMenuItem
      该类实现 JMenuItem类的可访问性支持。
      protected class  JPasswordField.AccessibleJPasswordField
      该类为 JPasswordField类实现可访问性支持。
      protected class  JRadioButton.AccessibleJRadioButton
      该类为 JRadioButton类实现可访问性支持。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      该类实现 JRadioButtonMenuItem类的可访问性支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner实现 JSpinner类的可访问性支持。
      protected class  JTextArea.AccessibleJTextArea
      该类实现 JTextArea类的可访问性支持。
      protected class  JTextField.AccessibleJTextField
      该类为 JTextField类实现可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      该类实现 JToggleButton类的可访问性支持。
      protected class  JTree.AccessibleJTree.AccessibleJTreeNode
      该类为 JTree孩子实现可访问性支持。
      Methods in javax.swing that return AccessibleAction
      Modifier and Type 方法 描述
      AccessibleAction AbstractButton.AccessibleAbstractButton.getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      AccessibleAction JComboBox.AccessibleJComboBox.getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      AccessibleAction JList.AccessibleJList.AccessibleJListChild.getAccessibleAction​()
      获取支持一个或多个操作的此对象关联的 AccessibleAction 。
      AccessibleAction JSpinner.AccessibleJSpinner.getAccessibleAction​()
      获取与支持一个或多个操作的此对象关联的AccessibleAction。
      AccessibleAction JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAction​()
      获取与此对象关联的 AccessibleAction如果存在）。
      AccessibleAction JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAction​()
      获取与此对象关联的AccessibleAction。

    • Uses of AccessibleAction in javax.swing.table

      Methods in javax.swing.table that return AccessibleAction
      Modifier and Type | 方法 | 描述
      AccessibleAction | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAction​()

    • Uses of AccessibleAction in javax.swing.text

      Classes in javax.swing.text that implement AccessibleAction
      Modifier and Type Class 描述
      class  JTextComponent.AccessibleJTextComponent
      这个类实现 JTextComponent类的可访问性支持。
      Methods in javax.swing.text that return AccessibleAction
      Modifier and Type | 方法 | 描述
      AccessibleAction | JTextComponent.AccessibleJTextComponent.getAccessibleAction​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleComponent

  • Packages that use AccessibleComponent
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of AccessibleComponent in com.sun.java.accessibility.util

      Classes in com.sun.java.accessibility.util that implement AccessibleComponent
      Modifier and Type Class 描述
      class  Translator
      Translator类为不实现接口Accessible对象提供了一个到接口Accessible的翻译。

    • Uses of AccessibleComponent in java.applet

      Classes in java.applet that implement AccessibleComponent
      Modifier and Type Class 描述
      protected class  Applet.AccessibleApplet
      已过时。
      这个类实现了 Applet类的可访问性支持。

    • Uses of AccessibleComponent in java.awt

      Classes in java.awt that implement AccessibleComponent
      Modifier and Type Class 描述
      protected class  Button.AccessibleAWTButton
      该类为 Button类实现可访问性支持。
      protected class  Canvas.AccessibleAWTCanvas
      这个类实现了 Canvas类的辅助功能支持。
      protected class  Checkbox.AccessibleAWTCheckbox
      这个类实现了 Checkbox类的可访问性支持。
      protected class  CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
      用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。
      protected class  Choice.AccessibleAWTChoice
      这个类实现了 Choice类的可访问性支持。
      protected class  Component.AccessibleAWTComponent
      组件的内部类用于为辅助功能提供默认支持。
      protected class  Container.AccessibleAWTContainer
      Container的内部类用于为辅助功能提供默认支持。
      protected class  Dialog.AccessibleAWTDialog
      这个类实现了 Dialog类的可访问性支持。
      protected class  Frame.AccessibleAWTFrame
      这个类实现了 Frame类的辅助功能支持。
      protected class  Label.AccessibleAWTLabel
      这个类实现了 Label类的可访问性支持。
      protected class  List.AccessibleAWTList
      这个类实现了 List类的可访问性支持。
      protected class  List.AccessibleAWTList.AccessibleAWTListChild
      此类实现对List子项的可访问性支持。
      protected class  Menu.AccessibleAWTMenu
      菜单的内部类用于提供对辅助功能的默认支持。
      protected class  MenuBar.AccessibleAWTMenuBar
      MenuBar的内部类用于为辅助功能提供默认支持。
      protected class  MenuComponent.AccessibleAWTMenuComponent
      内部类 MenuComponent用于提供对辅助功能的默认支持。
      protected class  MenuItem.AccessibleAWTMenuItem
      MenuItem的内部类用于为辅助功能提供默认支持。
      protected class  Panel.AccessibleAWTPanel
      这个类实现了 Panel类的可访问性支持。
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。
      protected class  Scrollbar.AccessibleAWTScrollBar
      这个类实现了 Scrollbar类的可访问性支持。
      protected class  ScrollPane.AccessibleAWTScrollPane
      这个类实现了 ScrollPane类的可访问性支持。
      protected class  TextArea.AccessibleAWTTextArea
      该类为 TextArea类实现可访问性支持。
      protected class  TextComponent.AccessibleAWTTextComponent
      这个类实现了 TextComponent类的可访问性支持。
      protected class  TextField.AccessibleAWTTextField
      这个类实现了 TextField类的可访问性支持。
      protected class  Window.AccessibleAWTWindow
      这个类实现了 Window类的可访问性支持。
      Methods in java.awt that return AccessibleComponent
      Modifier and Type 方法 描述
      AccessibleComponent Component.AccessibleAWTComponent.getAccessibleComponent​()
      获取与此对象关联的 AccessibleComponent如果存在）。
      AccessibleComponent MenuComponent.AccessibleAWTMenuComponent.getAccessibleComponent​()
      获取与此对象关联的 AccessibleComponent如果存在）。

    • Uses of AccessibleComponent in javax.accessibility

      Subinterfaces of AccessibleComponent in javax.accessibility
      Modifier and Type 接口 描述
      interface  AccessibleExtendedComponent
      应该在屏幕上呈现的任何对象支持 AccessibleExtendedComponent接口。
      Methods in javax.accessibility that return AccessibleComponent
      Modifier and Type 方法 描述
      AccessibleComponent AccessibleContext.getAccessibleComponent​()
      获取与该对象关联的 AccessibleComponent ，该对象具有图形表示。

    • Uses of AccessibleComponent in javax.swing

      Classes in javax.swing that implement AccessibleComponent
      Modifier and Type Class 描述
      protected class  AbstractButton.AccessibleAbstractButton
      这个类实现了 AbstractButton类的可访问性支持。
      protected class  Box.AccessibleBox
      该类实现 Box类的可访问性支持。
      protected class  Box.Filler.AccessibleBoxFiller
      这个类实现了 Box.Filler类的可访问性支持。
      protected class  CellRendererPane.AccessibleCellRendererPane
      该类为 CellRendererPane类实现可访问性支持。
      protected class  JApplet.AccessibleJApplet
      已过时。
      这个类实现了 JApplet类的可访问性支持。
      protected class  JButton.AccessibleJButton
      这个类实现了 JButton类的可访问性支持。
      protected class  JCheckBox.AccessibleJCheckBox
      这个类实现了 JCheckBox类的可访问性支持。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      该类实现 JCheckBoxMenuItem类的可访问性支持。
      protected class  JColorChooser.AccessibleJColorChooser
      这个类实现了 JColorChooser类的可访问性支持。
      protected class  JComboBox.AccessibleJComboBox
      这个类实现了 JComboBox类的可访问性支持。
      class  JComponent.AccessibleJComponent
      JComponent的内部类用于为辅助功能提供默认支持。
      protected class  JDesktopPane.AccessibleJDesktopPane
      该类为 JDesktopPane类实现可访问性支持。
      protected class  JDialog.AccessibleJDialog
      这个类实现了 JDialog类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPane
      该类为 JEditorPane类实现可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供对 AccessibleHypertext支持，并且用于在此 EditorKit安装的 JEditorPane是 JEditorPane的实例的 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText
      protected class  JFileChooser.AccessibleJFileChooser
      这个类实现了 JFileChooser类的可访问性支持。
      protected class  JFrame.AccessibleJFrame
      这个类实现了 JFrame类的可访问性支持。
      protected class  JInternalFrame.AccessibleJInternalFrame
      该类实现了 JInternalFrame类的可访问性支持。
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      这个类实现了 JInternalFrame.JDesktopIcon类的可访问性支持。
      protected class  JLabel.AccessibleJLabel
      该类用于获取此对象的可访问角色。
      protected class  JLayeredPane.AccessibleJLayeredPane
      这个类实现了 JLayeredPane类的可访问性支持。
      protected class  JList.AccessibleJList
      这个类实现了 JList类的可访问性支持。
      protected class  JList.AccessibleJList.AccessibleJListChild
      该类实现适用于列表子级的辅助功能支持。
      protected class  JMenu.AccessibleJMenu
      这个类实现了 JMenu类的可访问性支持。
      protected class  JMenuBar.AccessibleJMenuBar
      该类实现 JMenuBar类的可访问性支持。
      protected class  JMenuItem.AccessibleJMenuItem
      该类实现了 JMenuItem课程的可访问性支持。
      protected class  JOptionPane.AccessibleJOptionPane
      这个类实现了 JOptionPane课程的可访问性支持。
      protected class  JPanel.AccessibleJPanel
      该类实现了 JPanel类的可访问性支持。
      protected class  JPasswordField.AccessibleJPasswordField
      这个类实现了 JPasswordField类的可访问性支持。
      protected class  JPopupMenu.AccessibleJPopupMenu
      这个类实现了 JPopupMenu类的可访问性支持。
      protected class  JProgressBar.AccessibleJProgressBar
      这个类实现了 JProgressBar类的可访问性支持。
      protected class  JRadioButton.AccessibleJRadioButton
      这个类实现了 JRadioButton类的可访问性支持。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      这个类实现了 JRadioButtonMenuItem类的可访问性支持。
      protected class  JRootPane.AccessibleJRootPane
      这个类实现 JRootPane类的可访问性支持。
      protected class  JScrollBar.AccessibleJScrollBar
      该类实现了 JScrollBar课程的可访问性支持。
      protected class  JScrollPane.AccessibleJScrollPane
      该类实现 JScrollPane类的可访问性支持。
      protected class  JSeparator.AccessibleJSeparator
      这个类实现了 JSeparator类的可访问性支持。
      protected class  JSlider.AccessibleJSlider
      该类为 JSlider类实现可访问性支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner实现 JSpinner类的辅助功能支持。
      protected class  JSplitPane.AccessibleJSplitPane
      这个类实现了 JSplitPane类的可访问性支持。
      protected class  JTabbedPane.AccessibleJTabbedPane
      该类实现 JTabbedPane课程的辅助功能支持。
      protected class  JTable.AccessibleJTable
      该类实现了 JTable类的可访问性支持。
      protected class  JTable.AccessibleJTable.AccessibleJTableCell
      该类提供了适用于表单元格的Java Accessibility API的实现。
      protected class  JTextArea.AccessibleJTextArea
      该类实现 JTextArea类的可访问性支持。
      protected class  JTextField.AccessibleJTextField
      该类实现了 JTextField课程的可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      该类实现 JToggleButton类的辅助功能支持。
      protected class  JToolBar.AccessibleJToolBar
      这个类实现了 JToolBar类的可访问性支持。
      protected class  JToolTip.AccessibleJToolTip
      这个类实现了 JToolTip类的可访问性支持。
      protected class  JTree.AccessibleJTree
      这个类实现了对 JTree类的可访问性支持。
      protected class  JTree.AccessibleJTree.AccessibleJTreeNode
      该类为 JTree孩子实现可访问性支持。
      protected class  JViewport.AccessibleJViewport
      该类实现 JViewport类的辅助功能支持。
      protected class  JWindow.AccessibleJWindow
      这个类实现了 JWindow类的可访问性支持。
      Methods in javax.swing that return AccessibleComponent
      Modifier and Type 方法 描述
      AccessibleComponent JList.AccessibleJList.AccessibleJListChild.getAccessibleComponent​()
      获取与此对象关联的AccessibleComponent。
      AccessibleComponent JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleComponent​()
      获取与此对象关联的 AccessibleComponent如果存在）。
      AccessibleComponent JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleComponent​()
      获取与此对象关联的AccessibleComponent。
      AccessibleComponent ProgressMonitor.AccessibleProgressMonitor.getAccessibleComponent​()
      获取与此对象关联的AccessibleComponent，该对象具有图形表示形式。

    • Uses of AccessibleComponent in javax.swing.table

      Classes in javax.swing.table that implement AccessibleComponent
      Modifier and Type Class 描述
      protected class  JTableHeader.AccessibleJTableHeader
      该类为 JTableHeader类实现可访问性支持。
      protected class  JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
      该类提供了适用于JTableHeader条目的Java Accessibility API的实现。
      Methods in javax.swing.table that return AccessibleComponent
      Modifier and Type 方法 描述
      AccessibleComponent JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleComponent​()
      获取与此对象关联的AccessibleComponent。

    • Uses of AccessibleComponent in javax.swing.text

      Classes in javax.swing.text that implement AccessibleComponent
      Modifier and Type Class 描述
      class  JTextComponent.AccessibleJTextComponent
      该类为 JTextComponent类实现可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleEditableText (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleEditableText

  • Packages that use AccessibleEditableText
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of AccessibleEditableText in javax.accessibility

      Methods in javax.accessibility that return AccessibleEditableText
      Modifier and Type 方法 描述
      AccessibleEditableText AccessibleContext.getAccessibleEditableText​()
      获取与此对象相关联的 AccessibleEditableText ，显示在显示屏上的可编辑文本。

    • Uses of AccessibleEditableText in javax.swing

      Classes in javax.swing that implement AccessibleEditableText
      Modifier and Type Class 描述
      protected class  JEditorPane.AccessibleJEditorPane
      这个类实现了 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供支持 AccessibleHypertext ，并且在当所使用 EditorKit安装在该 JEditorPane是实例 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回。
      protected class  JPasswordField.AccessibleJPasswordField
      该类实现 JPasswordField类的可访问性支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner实现 JSpinner类的辅助功能支持。
      protected class  JTextArea.AccessibleJTextArea
      这个类实现 JTextArea类的可访问性支持。
      protected class  JTextField.AccessibleJTextField
      这个类实现了 JTextField类的可访问性支持。

    • Uses of AccessibleEditableText in javax.swing.text

      Classes in javax.swing.text that implement AccessibleEditableText
      Modifier and Type Class 描述
      class  JTextComponent.AccessibleJTextComponent
      该类实现 JTextComponent类的辅助功能支持。
      Methods in javax.swing.text that return AccessibleEditableText
      Modifier and Type 方法 描述
      AccessibleEditableText JTextComponent.AccessibleJTextComponent.getAccessibleEditableText​()
      Returns the AccessibleEditableText interface for this text component.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleExtendedComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleExtendedComponent

  • Packages that use AccessibleExtendedComponent
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of AccessibleExtendedComponent in javax.swing

      Classes in javax.swing that implement AccessibleExtendedComponent
      Modifier and Type Class 描述
      protected class  AbstractButton.AccessibleAbstractButton
      这个类实现了 AbstractButton类的可访问性支持。
      protected class  JButton.AccessibleJButton
      这个类实现了 JButton类的可访问性支持。
      protected class  JCheckBox.AccessibleJCheckBox
      该类实现 JCheckBox类的可访问性支持。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      这个类实现了 JCheckBoxMenuItem类的可访问性支持。
      protected class  JColorChooser.AccessibleJColorChooser
      该类为 JColorChooser类实现可访问性支持。
      protected class  JComboBox.AccessibleJComboBox
      该类为 JComboBox类实现可访问性支持。
      class  JComponent.AccessibleJComponent
      JComponent的内部类用于为辅助功能提供默认支持。
      protected class  JDesktopPane.AccessibleJDesktopPane
      该类实现了 JDesktopPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPane
      这个类实现 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供对 AccessibleHypertext支持，并且在 EditorKit安装的 JEditorPane是 JEditorPane的实例的情况下 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回。
      protected class  JFileChooser.AccessibleJFileChooser
      这个类实现了 JFileChooser类的可访问性支持。
      protected class  JInternalFrame.AccessibleJInternalFrame
      该类实现 JInternalFrame课程的可访问性支持。
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      该类实现 JInternalFrame.JDesktopIcon类的辅助功能支持。
      protected class  JLabel.AccessibleJLabel
      该类用于获取此对象的可访问角色。
      protected class  JLayeredPane.AccessibleJLayeredPane
      这个类实现了 JLayeredPane类的可访问性支持。
      protected class  JList.AccessibleJList
      这个类实现了 JList类的可访问性支持。
      protected class  JMenu.AccessibleJMenu
      这个类实现了 JMenu类的可访问性支持。
      protected class  JMenuBar.AccessibleJMenuBar
      这个类实现了 JMenuBar类的可访问性支持。
      protected class  JMenuItem.AccessibleJMenuItem
      这个类实现 JMenuItem类的可访问性支持。
      protected class  JOptionPane.AccessibleJOptionPane
      这个类实现了 JOptionPane类的可访问性支持。
      protected class  JPanel.AccessibleJPanel
      这个类实现了 JPanel类的可访问性支持。
      protected class  JPasswordField.AccessibleJPasswordField
      这个类实现了 JPasswordField类的可访问性支持。
      protected class  JPopupMenu.AccessibleJPopupMenu
      这个类实现了 JPopupMenu类的可访问性支持。
      protected class  JProgressBar.AccessibleJProgressBar
      这个类实现了 JProgressBar类的可访问性支持。
      protected class  JRadioButton.AccessibleJRadioButton
      这个类实现了 JRadioButton类的可访问性支持。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      该类实现了 JRadioButtonMenuItem类的可访问性支持。
      protected class  JRootPane.AccessibleJRootPane
      该类实现 JRootPane类的可访问性支持。
      protected class  JScrollBar.AccessibleJScrollBar
      这个类实现了 JScrollBar类的可访问性支持。
      protected class  JScrollPane.AccessibleJScrollPane
      这个类实现了 JScrollPane类的可访问性支持。
      protected class  JSeparator.AccessibleJSeparator
      这个类实现了 JSeparator类的可访问性支持。
      protected class  JSlider.AccessibleJSlider
      这个类实现了 JSlider类的可访问性支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner实现 JSpinner类的可访问性支持。
      protected class  JSplitPane.AccessibleJSplitPane
      该类为 JSplitPane类实现可访问性支持。
      protected class  JTabbedPane.AccessibleJTabbedPane
      这个类实现了 JTabbedPane类的可访问性支持。
      protected class  JTable.AccessibleJTable
      这个类实现了 JTable类的可访问性支持。
      protected class  JTextArea.AccessibleJTextArea
      该类实现 JTextArea类的可访问性支持。
      protected class  JTextField.AccessibleJTextField
      该类实现 JTextField类的可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      这个类实现了 JToggleButton类的可访问性支持。
      protected class  JToolBar.AccessibleJToolBar
      这个类实现了 JToolBar类的可访问性支持。
      protected class  JToolTip.AccessibleJToolTip
      这个类实现 JToolTip类的可访问性支持。
      protected class  JTree.AccessibleJTree
      这个类实现了 JTree类的可访问性支持。
      protected class  JViewport.AccessibleJViewport
      这个类实现了 JViewport类的可访问性支持。

    • Uses of AccessibleExtendedComponent in javax.swing.table

      Classes in javax.swing.table that implement AccessibleExtendedComponent
      Modifier and Type Class 描述
      protected class  JTableHeader.AccessibleJTableHeader
      这个类实现了 JTableHeader类的可访问性支持。

    • Uses of AccessibleExtendedComponent in javax.swing.text

      Classes in javax.swing.text that implement AccessibleExtendedComponent
      Modifier and Type Class 描述
      class  JTextComponent.AccessibleJTextComponent
      这个类实现了 JTextComponent类的可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleExtendedTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleExtendedTable

  • Packages that use AccessibleExtendedTable
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AccessibleExtendedTable in javax.swing

      Classes in javax.swing that implement AccessibleExtendedTable
      Modifier and Type Class 描述
      protected class  JTable.AccessibleJTable
      该类实现 JTable类的可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleExtendedText (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleExtendedText

  • Packages that use AccessibleExtendedText
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of AccessibleExtendedText in javax.swing

      Classes in javax.swing that implement AccessibleExtendedText
      Modifier and Type Class 描述
      protected class  JEditorPane.AccessibleJEditorPane
      这个类实现了 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供支持 AccessibleHypertext ，并且在当所使用 EditorKit安装在该 JEditorPane是实例 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回。
      protected class  JPasswordField.AccessibleJPasswordField
      这个类实现了 JPasswordField类的可访问性支持。
      protected class  JTextArea.AccessibleJTextArea
      这个类实现了 JTextArea类的可访问性支持。
      protected class  JTextField.AccessibleJTextField
      该类实现了 JTextField类的可访问性支持。

    • Uses of AccessibleExtendedText in javax.swing.text

      Classes in javax.swing.text that implement AccessibleExtendedText
      Modifier and Type Class 描述
      class  JTextComponent.AccessibleJTextComponent
      这个类实现了 JTextComponent类的可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleHypertext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleHypertext

  • Packages that use AccessibleHypertext
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AccessibleHypertext in javax.swing

      Classes in javax.swing that implement AccessibleHypertext
      Modifier and Type Class 描述
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleIcon (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleIcon

  • Packages that use AccessibleIcon
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AccessibleIcon in javax.accessibility

      Methods in javax.accessibility that return AccessibleIcon
      Modifier and Type 方法 描述
      AccessibleIcon[] AccessibleContext.getAccessibleIcon​()
      获取与具有一个或多个关联图标的对象关联的 AccessibleIcons 。

    • Uses of AccessibleIcon in javax.swing

      Classes in javax.swing that implement AccessibleIcon
      Modifier and Type Class 描述
      protected class  ImageIcon.AccessibleImageIcon
      该类为 ImageIcon类实现可访问性支持。
      Methods in javax.swing that return AccessibleIcon
      Modifier and Type 方法 描述
      AccessibleIcon[] AbstractButton.AccessibleAbstractButton.getAccessibleIcon​()
      如果有一个或多个存在，获取与该对象相关联的AccessibleIcons。
      AccessibleIcon[] JLabel.AccessibleJLabel.getAccessibleIcon​()
      如果有一个或多个存在，获取与该对象相关联的AccessibleIcons。
      AccessibleIcon[] JList.AccessibleJList.AccessibleJListChild.getAccessibleIcon​()
      Returns the icon for the element renderer, as the only item of an array of AccessibleIcons or a null array if the renderer component contains no icons.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleKeyBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleKeyBinding

  • Packages that use AccessibleKeyBinding
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AccessibleKeyBinding in javax.accessibility

      Methods in javax.accessibility that return AccessibleKeyBinding
      Modifier and Type 方法 描述
      AccessibleKeyBinding AccessibleExtendedComponent.getAccessibleKeyBinding​()
      返回与此对象关联的键绑定。

    • Uses of AccessibleKeyBinding in javax.swing

      Methods in javax.swing that return AccessibleKeyBinding
      Modifier and Type 方法 描述
      AccessibleKeyBinding AbstractButton.AccessibleAbstractButton.getAccessibleKeyBinding​()
      返回与此对象关联的键绑定
      AccessibleKeyBinding JComponent.AccessibleJComponent.getAccessibleKeyBinding​()
      返回与此对象关联的键绑定
      AccessibleKeyBinding JLabel.AccessibleJLabel.getAccessibleKeyBinding​()
      返回与此对象关联的键绑定
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleSelection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleSelection

  • Packages that use AccessibleSelection
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。

    • Uses of AccessibleSelection in java.awt

      Classes in java.awt that implement AccessibleSelection
      Modifier and Type Class 描述
      protected class  CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
      用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。
      protected class  List.AccessibleAWTList
      该类为 List类实现可访问性支持。
      protected class  Menu.AccessibleAWTMenu
      菜单的内部类用于提供对辅助功能的默认支持。
      protected class  MenuBar.AccessibleAWTMenuBar
      MenuBar的内部类用于为辅助功能提供默认支持。
      protected class  MenuComponent.AccessibleAWTMenuComponent
      内部类 MenuComponent用于提供对辅助功能的默认支持。
      protected class  MenuItem.AccessibleAWTMenuItem
      MenuItem的内部类用于为辅助功能提供默认支持。
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。
      Methods in java.awt that return AccessibleSelection
      Modifier and Type 方法 描述
      AccessibleSelection List.AccessibleAWTList.getAccessibleSelection​()
      获取与此对象关联的AccessibleSelection。
      AccessibleSelection MenuComponent.AccessibleAWTMenuComponent.getAccessibleSelection​()
      获取与此对象关联的 AccessibleSelection ，允许其 Accessible孩子被选中。

    • Uses of AccessibleSelection in javax.accessibility

      Methods in javax.accessibility that return AccessibleSelection
      Modifier and Type 方法 描述
      AccessibleSelection AccessibleContext.getAccessibleSelection​()
      获取与此对象关联的 AccessibleSelection ，允许其 Accessible孩子被选中。

    • Uses of AccessibleSelection in javax.swing

      Classes in javax.swing that implement AccessibleSelection
      Modifier and Type Class 描述
      protected class  JComboBox.AccessibleJComboBox
      这个类实现了 JComboBox类的可访问性支持。
      protected class  JList.AccessibleJList
      这个类实现了 JList类的可访问性支持。
      protected class  JMenu.AccessibleJMenu
      该类实现 JMenu类的可访问性支持。
      protected class  JMenuBar.AccessibleJMenuBar
      该类为 JMenuBar类实现可访问性支持。
      protected class  JTabbedPane.AccessibleJTabbedPane
      这个类实现了 JTabbedPane类的可访问性支持。
      protected class  JTable.AccessibleJTable
      该类为 JTable类实现可访问性支持。
      protected class  JTree.AccessibleJTree
      该类为 JTree类实现可访问性支持。
      protected class  JTree.AccessibleJTree.AccessibleJTreeNode
      该类为 JTree孩子实现可访问性支持。
      Methods in javax.swing that return AccessibleSelection
      Modifier and Type | 方法 | 描述
      AccessibleSelection JComboBox.AccessibleJComboBox.getAccessibleSelection​()
      获取与此对象关联的AccessibleSelection。
      AccessibleSelection | JList.AccessibleJList.AccessibleJListChild.getAccessibleSelection​()
      AccessibleSelection JList.AccessibleJList.getAccessibleSelection​()
      获取与此对象关联的AccessibleSelection。
      AccessibleSelection JMenu.AccessibleJMenu.getAccessibleSelection​()
      获取与此对象关联的AccessibleSelection。
      AccessibleSelection JMenuBar.AccessibleJMenuBar.getAccessibleSelection​()
      获取与此对象关联的AccessibleSelection。
      AccessibleSelection JTabbedPane.AccessibleJTabbedPane.getAccessibleSelection​()
      获取与此对象关联的 AccessibleSelection 。
      AccessibleSelection JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleSelection​()
      获取与此对象相关联的 AccessibleSelection如果存在）。
      AccessibleSelection JTable.AccessibleJTable.getAccessibleSelection​()
      获取与此对象关联的AccessibleSelection。
      AccessibleSelection JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleSelection​()
      获取与此对象关联的AccessibleSelection（如果存在）。
      AccessibleSelection JTree.AccessibleJTree.getAccessibleSelection​()
      Get the AccessibleSelection associated with this object.

    • Uses of AccessibleSelection in javax.swing.table

      Methods in javax.swing.table that return AccessibleSelection
      Modifier and Type | 方法 | 描述
      AccessibleSelection | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleSelection​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleStreamable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleStreamable

No usage of javax.accessibility.AccessibleStreamable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleTable

  • Packages that use AccessibleTable
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AccessibleTable in javax.accessibility

      Subinterfaces of AccessibleTable in javax.accessibility
      Modifier and Type 接口 描述
      interface  AccessibleExtendedTable
      AccessibleExtendedTable类提供了以二维表格格式显示数据的用户界面组件的扩展信息。
      Methods in javax.accessibility that return AccessibleTable
      Modifier and Type 方法 描述
      AccessibleTable AccessibleTable.getAccessibleColumnHeader​()
      返回列标题为 AccessibleTable 。
      AccessibleTable AccessibleTable.getAccessibleRowHeader​()
      返回行标题为 AccessibleTable 。
      AccessibleTable AccessibleContext.getAccessibleTable​()
      获取与对象关联的 AccessibleTable 。
      Methods in javax.accessibility with parameters of type AccessibleTable
      Modifier and Type 方法 描述
      void AccessibleTable.setAccessibleColumnHeader​(AccessibleTable table)
      设置列标题。
      void AccessibleTable.setAccessibleRowHeader​(AccessibleTable table)
      设置行标题。

    • Uses of AccessibleTable in javax.swing

      Classes in javax.swing that implement AccessibleTable
      Modifier and Type Class 描述
      protected class  JTable.AccessibleJTable
      该类实现 JTable类的可访问性支持。
      Methods in javax.swing that return AccessibleTable
      Modifier and Type 方法 描述
      AccessibleTable JTable.AccessibleJTable.getAccessibleColumnHeader​()
      返回列标题为 AccessibleTable 。
      AccessibleTable JTable.AccessibleJTable.getAccessibleRowHeader​()
      返回行标题为 AccessibleTable 。
      AccessibleTable JTable.AccessibleJTable.getAccessibleTable​()
      获取与此对象关联的 AccessibleTable 。
      Methods in javax.swing with parameters of type AccessibleTable
      Modifier and Type 方法 描述
      void JTable.AccessibleJTable.setAccessibleColumnHeader​(AccessibleTable a)
      将列标题设置为 AccessibleTable 。
      void JTable.AccessibleJTable.setAccessibleRowHeader​(AccessibleTable a)
      将行标题设置为 AccessibleTable 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleTableModelChange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleTableModelChange

  • Packages that use AccessibleTableModelChange
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AccessibleTableModelChange in javax.swing

      Classes in javax.swing that implement AccessibleTableModelChange
      Modifier and Type Class 描述
      protected class  JTable.AccessibleJTable.AccessibleJTableModelChange
      描述可访问表模型的变化。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleText (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleText

  • Packages that use AccessibleText
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of AccessibleText in java.awt

      Classes in java.awt that implement AccessibleText
      Modifier and Type Class 描述
      protected class  TextArea.AccessibleAWTTextArea
      该类实现 TextArea类的可访问性支持。
      protected class  TextComponent.AccessibleAWTTextComponent
      该类实现 TextComponent类的辅助功能支持。
      protected class  TextField.AccessibleAWTTextField
      该类实现 TextField类的可访问性支持。
      Methods in java.awt that return AccessibleText
      Modifier and Type 方法 描述
      AccessibleText TextComponent.AccessibleAWTTextComponent.getAccessibleText​()
      获取与此对象关联的AccessibleText。

    • Uses of AccessibleText in javax.accessibility

      Subinterfaces of AccessibleText in javax.accessibility
      Modifier and Type 接口 描述
      interface  AccessibleEditableText
      AccessibleEditableText接口应该由显示器上显示可编辑文本信息的所有类实现。
      interface  AccessibleHypertext
      AccessibleHypertext类是在显示器上显示超文本信息的所有类的基类。
      Methods in javax.accessibility that return AccessibleText
      Modifier and Type 方法 描述
      AccessibleText AccessibleContext.getAccessibleText​()
      获取与该对象相关联的 AccessibleText在显示器上显示文本。

    • Uses of AccessibleText in javax.swing

      Classes in javax.swing that implement AccessibleText
      Modifier and Type Class 描述
      protected class  AbstractButton.AccessibleAbstractButton
      这个类实现 AbstractButton类的可访问性支持。
      protected class  JButton.AccessibleJButton
      该类为 JButton类实现可访问性支持。
      protected class  JCheckBox.AccessibleJCheckBox
      该类为 JCheckBox类实现可访问性支持。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      这个类实现 JCheckBoxMenuItem类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPane
      该类为 JEditorPane类实现可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供对 AccessibleHypertext支持，并且用于在此 EditorKit安装的 JEditorPane是 JEditorPane的实例的 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText 。
      protected class  JLabel.AccessibleJLabel
      该类用于获取此对象的可访问角色。
      protected class  JMenu.AccessibleJMenu
      该类为 JMenu类实现可访问性支持。
      protected class  JMenuItem.AccessibleJMenuItem
      该类实现 JMenuItem类的辅助功能支持。
      protected class  JPasswordField.AccessibleJPasswordField
      该类实现 JPasswordField类的辅助功能支持。
      protected class  JRadioButton.AccessibleJRadioButton
      该类实现 JRadioButton类的可访问性支持。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      这个类实现了 JRadioButtonMenuItem类的可访问性支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner实现对 JSpinner类的可访问性支持。
      protected class  JTextArea.AccessibleJTextArea
      该类实现 JTextArea类的可访问性支持。
      protected class  JTextField.AccessibleJTextField
      这个类实现 JTextField类的可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      该类实现 JToggleButton类的可访问性支持。
      protected class  ProgressMonitor.AccessibleProgressMonitor
      AccessibleProgressMonitor实现 ProgressMonitor类的辅助功能支持。
      Methods in javax.swing that return AccessibleText
      Modifier and Type | 方法 | 描述
      AccessibleText | AbstractButton.AccessibleAbstractButton.getAccessibleText​()
      AccessibleText JEditorPane.AccessibleJEditorPaneHTML.getAccessibleText​()
      返回可访问的文本。
      AccessibleText | JLabel.AccessibleJLabel.getAccessibleText​()
      AccessibleText | JList.AccessibleJList.AccessibleJListChild.getAccessibleText​()
      AccessibleText JPasswordField.AccessibleJPasswordField.getAccessibleText​()
      获得 AccessibleText的 JPasswordField 。
      AccessibleText JSpinner.AccessibleJSpinner.getAccessibleText​()
      获取与该对象相关联的AccessibleText在显示器上呈现文本。
      AccessibleText JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleText​()
      获取与此对象关联的 AccessibleText如果存在）。
      AccessibleText JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleText​()
      获取与此对象关联的AccessibleText（如果存在）。
      AccessibleText ProgressMonitor.AccessibleProgressMonitor.getAccessibleText​()
      获取与该对象相关联的AccessibleText在显示器上呈现文本。

    • Uses of AccessibleText in javax.swing.table

      Methods in javax.swing.table that return AccessibleText
      Modifier and Type | 方法 | 描述
      AccessibleText | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleText​()

    • Uses of AccessibleText in javax.swing.text

      Classes in javax.swing.text that implement AccessibleText
      Modifier and Type Class 描述
      class  JTextComponent.AccessibleJTextComponent
      该类实现 JTextComponent类的可访问性支持。
      Methods in javax.swing.text that return AccessibleText
      Modifier and Type 方法 描述
      AccessibleText JTextComponent.AccessibleJTextComponent.getAccessibleText​()
      获取与此对象关联的AccessibleText。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.accessibility.AccessibleValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.accessibility.AccessibleValue

  • Packages that use AccessibleValue
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。

    • Uses of AccessibleValue in java.awt

      Classes in java.awt that implement AccessibleValue
      Modifier and Type Class 描述
      protected class  Button.AccessibleAWTButton
      该类实现 Button类的可访问性支持。
      protected class  Checkbox.AccessibleAWTCheckbox
      该类实现 Checkbox类的辅助功能支持。
      protected class  CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
      用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。
      protected class  Menu.AccessibleAWTMenu
      菜单的内部类用于提供对辅助功能的默认支持。
      protected class  MenuItem.AccessibleAWTMenuItem
      MenuItem的内部类用于为辅助功能提供默认支持。
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。
      protected class  Scrollbar.AccessibleAWTScrollBar
      该类实现了 Scrollbar类的辅助功能支持。
      Methods in java.awt that return AccessibleValue
      Modifier and Type 方法 描述
      AccessibleValue Button.AccessibleAWTButton.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue Checkbox.AccessibleAWTCheckbox.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue MenuItem.AccessibleAWTMenuItem.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue Scrollbar.AccessibleAWTScrollBar.getAccessibleValue​()
      获取与此对象关联的 AccessibleValue 。

    • Uses of AccessibleValue in javax.accessibility

      Methods in javax.accessibility that return AccessibleValue
      Modifier and Type 方法 描述
      AccessibleValue AccessibleContext.getAccessibleValue​()
      获取与此对象关联的 AccessibleValue ，该对象支持 Numerical值。

    • Uses of AccessibleValue in javax.swing

      Classes in javax.swing that implement AccessibleValue
      Modifier and Type Class 描述
      protected class  AbstractButton.AccessibleAbstractButton
      这个类实现 AbstractButton类的可访问性支持。
      protected class  JButton.AccessibleJButton
      这个类实现了 JButton类的可访问性支持。
      protected class  JCheckBox.AccessibleJCheckBox
      该类为 JCheckBox类实现可访问性支持。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      该类实现 JCheckBoxMenuItem类的可访问性支持。
      protected class  JInternalFrame.AccessibleJInternalFrame
      该类实现 JInternalFrame类的可访问性支持。
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      这个类实现了 JInternalFrame.JDesktopIcon类的可访问性支持。
      protected class  JMenu.AccessibleJMenu
      这个类实现了 JMenu类的可访问性支持。
      protected class  JMenuItem.AccessibleJMenuItem
      这个类实现了 JMenuItem类的辅助功能支持。
      protected class  JProgressBar.AccessibleJProgressBar
      这个类实现了 JProgressBar类的可访问性支持。
      protected class  JRadioButton.AccessibleJRadioButton
      这个类实现了 JRadioButton类的可访问性支持。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      这个类实现了 JRadioButtonMenuItem类的可访问性支持。
      protected class  JScrollBar.AccessibleJScrollBar
      这个类实现了 JScrollBar类的可访问性支持。
      protected class  JSlider.AccessibleJSlider
      这个类实现了 JSlider类的可访问性支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner实现了 JSpinner类的辅助功能支持。
      protected class  JSplitPane.AccessibleJSplitPane
      该类实现了 JSplitPane类的可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      这个类实现了 JToggleButton类的可访问性支持。
      Methods in javax.swing that return AccessibleValue
      Modifier and Type | 方法 | 描述
      AccessibleValue AbstractButton.AccessibleAbstractButton.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue JInternalFrame.AccessibleJInternalFrame.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue | JList.AccessibleJList.AccessibleJListChild.getAccessibleValue​()
      AccessibleValue JProgressBar.AccessibleJProgressBar.getAccessibleValue​()
      获取与此对象关联的 AccessibleValue 。
      AccessibleValue JScrollBar.AccessibleJScrollBar.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue JSlider.AccessibleJSlider.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue JSpinner.AccessibleJSpinner.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue JSplitPane.AccessibleJSplitPane.getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      AccessibleValue JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleValue​()
      获取与此对象关联的 AccessibleValue如果存在）。
      AccessibleValue JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleValue​()
      获取与此对象关联的AccessibleValue（如果存在）。
      AccessibleValue ProgressMonitor.AccessibleProgressMonitor.getAccessibleValue​()
      获取与此对象关联的AccessibleValue，该对象支持数值。

    • Uses of AccessibleValue in javax.swing.table

      Methods in javax.swing.table that return AccessibleValue
      Modifier and Type | 方法 | 描述
      AccessibleValue | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleValue​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ActivationDataFlavor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class ActivationDataFlavor

  • java.lang.Object
    • java.awt.datatransfer.DataFlavor
      • javax.activation.ActivationDataFlavor
  • All Implemented Interfaces:
    Externalizable ， Serializable ， Cloneable

    public class ActivationDataFlavor
extends DataFlavor
    ActivationDataFlavor类是一个特殊的子类，为java.awt.datatransfer.DataFlavor 。 它允许JAF通过新的构造函数设置DataFlavor类存储的所有三个值。 它还包含改进的MIME解析在equals方法。 除了改进的解析，其语义与JDK的DataFlavor类的语义相同。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.awt.datatransfer.DataFlavor

        allHtmlFlavor, fragmentHtmlFlavor, imageFlavor, javaFileListFlavor, javaJVMLocalObjectMimeType, javaRemoteObjectMimeType, javaSerializedObjectMimeType, plainTextFlavor, selectionHtmlFlavor, stringFlavor

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivationDataFlavor​(Class representationClass, String humanPresentableName)
      构造一个表示MimeType的DataFlavor。
      ActivationDataFlavor​(Class representationClass, String mimeType, String humanPresentableName)
      构造一个表示任意Java对象的DataFlavor。
      ActivationDataFlavor​(String mimeType, String humanPresentableName)
      构造一个表示MimeType的DataFlavor。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(DataFlavor dataFlavor)
      将传入的DataFlavor与此DataFlavor进行比较; 调用isMimeTypeEqual方法。
      String getHumanPresentableName​()
      返回人类可呈现的名称。
      String getMimeType​()
      返回此DataFlavor的MIME类型。
      Class getRepresentationClass​()
      返回代表类。
      boolean isMimeTypeEqual​(String mimeType)
      MIME类型的字符串表示形式相当于此DataFlavor的MIME类型。
      protected String normalizeMimeType​(String mimeType)
      已过时。
      protected String normalizeMimeTypeParameter​(String parameterName, String parameterValue)
      已过时。
      void setHumanPresentableName​(String humanPresentableName)
      设置人性化的名称。

      • Methods inherited from class java.awt.datatransfer.DataFlavor

        clone, equals, equals, getDefaultRepresentationClass, getDefaultRepresentationClassAsString, getParameter, getPrimaryType, getReaderForText, getSubType, getTextPlainUnicodeFlavor, hashCode, isFlavorJavaFileListType, isFlavorRemoteObjectType, isFlavorSerializedObjectType, isFlavorTextType, isMimeTypeEqual, isMimeTypeSerializedObject, isRepresentationClassByteBuffer, isRepresentationClassCharBuffer, isRepresentationClassInputStream, isRepresentationClassReader, isRepresentationClassRemote, isRepresentationClassSerializable, match, readExternal, selectBestTextFlavor, toString, tryToLoadClass, writeExternal

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ActivationDataFlavor

        public ActivationDataFlavor​(Class representationClass,
                            String mimeType,
                            String humanPresentableName)
        构造一个表示任意Java对象的DataFlavor。 该构造函数是JDK DataFlavor的扩展，它允许显式设置所有三个DataFlavor属性。

        返回的DataFlavor将具有以下特征：

        representationClass = representationClass
        mimeType = mimeType
        humanName = humanName

        参数
        representationClass - 此DataFlavor中使用的类
        mimeType - 此类表示的数据的MIME类型
        humanPresentableName - 人类 humanPresentableName的名字

      • ActivationDataFlavor

        public ActivationDataFlavor​(Class representationClass,
                            String humanPresentableName)
        构造一个表示MimeType的DataFlavor。

        返回的DataFlavor将具有以下特征：

        如果mimeType是“application / x-java-serialized-object; class =”，则结果与上述调用新的DataFlavor（Class.forName（））相同。

        除此以外：

        representationClass = InputStream

        mimeType = mimeType

        参数
        representationClass - 此DataFlavor中使用的类
        humanPresentableName - 人的 humanPresentableName名称的味道

      • ActivationDataFlavor

        public ActivationDataFlavor​(String mimeType,
                            String humanPresentableName)
        构造一个表示MimeType的DataFlavor。

        返回的DataFlavor将具有以下特征：

        如果mimeType是“application / x-java-serialized-object; class =”，则结果与上述调用新的DataFlavor（Class.forName（））相同：否则：

        representationClass = InputStream

        mimeType = mimeType

        参数
        mimeType - 由此类表示的数据的MIME类型
        humanPresentableName - 人的 humanPresentableName名称的味道

    • 方法详细信息

      • getMimeType

        public String getMimeType​()
        返回此DataFlavor的MIME类型。
        重写：
        getMimeType在 DataFlavor
        结果
        MIME类型

      • getRepresentationClass

        public Class getRepresentationClass​()
        返回代表类。
        重写：
        getRepresentationClass在 DataFlavor
        结果
        代表类

      • getHumanPresentableName

        public String getHumanPresentableName​()
        返回人类可呈现的名称。
        重写：
        getHumanPresentableName在 DataFlavor
        结果
        人性化的名字

      • setHumanPresentableName

        public void setHumanPresentableName​(String humanPresentableName)
        设置人性化的名称。
        重写：
        setHumanPresentableName在 DataFlavor
        参数
        humanPresentableName - 要设置的名称

      • equals

        public boolean equals​(DataFlavor dataFlavor)
        将传入的DataFlavor与此DataFlavor进行比较; 调用isMimeTypeEqual方法。
        重写：
        equals在 DataFlavor
        参数
        dataFlavor - 与DataFlavor进行比较
        结果
        如果MIME类型和表示类是相同的，则为true
        另请参见：
        DataFlavor.selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

      • isMimeTypeEqual

        public boolean isMimeTypeEqual​(String mimeType)
        MIME类型的字符串表示形式相当于此DataFlavor的MIME类型。

        ActivationDataFlavor将MIME类型的比较委托给JavaBeans激活框架一部分中包含的MimeType类。 这提供了比DataFlavor类中通常可用的更强大的比较。

        重写：
        isMimeTypeEqual在 DataFlavor
        参数
        mimeType - MIME类型
        结果
        如果相同的MIME类型为true

      • normalizeMimeTypeParameter

        protected String normalizeMimeTypeParameter​(String parameterName,
                                            String parameterValue)
        已过时。
        调用DataFlavor为每个MIME类型参数调用DataFlavor子类来处理特殊参数，如text / plain字符集参数，其值不区分大小写。 （MIME类型参数值应该区分大小写）。

        为每个参数名称/值对调用此方法，并应返回parameterValue的归一化表示。 此方法从未被此实现调用。

        重写：
        normalizeMimeTypeParameter在 DataFlavor
        参数
        parameterName - 参数名称
        parameterValue - 参数值
        结果
        归一化参数值

      • normalizeMimeType

        protected String normalizeMimeType​(String mimeType)
        已过时。
        调用每个MIME类型的字符串，以使DataFlavor子类型有机会改变MIME类型的规范化是如何实现的。 一种可能的用途是在传入的MIME类型字符串中不存在的情况下添加默认参数/值对。此方法从未被此实现调用。
        重写：
        normalizeMimeType在 DataFlavor
        参数
        mimeType - MIME类型
        结果
        归一化的MIME类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CommandInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class CommandInfo

  • java.lang.Object
    • javax.activation.CommandInfo

  • public class CommandInfo
extends Object
    CommandMap实现使用CommandInfo类来描述命令请求的结果。 它向请求者提供请求的动词以及bean的实例。 还有一种方法将返回实现该命令的类的名称，但不能保证返回有效的值 。 这样做的原因是允许CommandMap的子类CommandMap中的CommandMap隐含提供特殊的行为。 例如，CommandMap可以动态生成JavaBean。 在这种情况下，可能无法仅从类名称创建具有所有正确状态信息的对象。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      CommandInfo​(String verb, String className)
      CommandInfo的构造方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getCommandClass​()
      返回命令的类名。
      String getCommandName​()
      返回命令动词。
      Object getCommandObject​(DataHandler dh, ClassLoader loader)
      返回实例化的JavaBean组件。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CommandInfo

        public CommandInfo​(String verb,
                   String className)
        CommandInfo的构造方法。
        参数
        verb - CommandInfo所命令的命令动词。
        className - 命令的全限定类名。

    • 方法详细信息

      • getCommandName

        public String getCommandName​()
        返回命令动词。
        结果
        命令动词。

      • getCommandClass

        public String getCommandClass​()
        返回命令的类名。 这个方法可以在CommandMap子类CommandInfo为其自身目的的情况下返回null。 换句话说，可能无法通过仅知道其类名称在命令中创建正确的状态。 不要依赖此方法返回有效值！
        结果
        命令的类名，或 null

      • getCommandObject

        public Object getCommandObject​(DataHandler dh,
                               ClassLoader loader)
                        throws IOException,
                               ClassNotFoundException
        返回实例化的JavaBean组件。

        如果java.beans.Beans可见，则调用java.beans.Beans#instantiate方法将组件实例化为JavaBeans组件。 当java.beans.Beans不可见（当java.desktop模块不可读或当运行时映像不包含java.desktop模块时），则该命令的类将使用其公共无参数构造函数进行加载和实例化。

        组件类需要公开。

        如果bean实现了javax.activation.CommandObject接口，则调用其setCommandContext方法。

        如果DataHandler参数为空，那么该bean将被实例化，没有数据。 注意：如果由于某种原因，当该方法尝试访问其InputStream时，传递的DataHandler会抛出IOExceptions，这可能很有用。 它将允许调用者检索对bean的引用，如果它可以被实例化。

        如果bean不实现CommandObject接口，则此方法将检查它是否实现了java.io.Externalizable接口。 如果是这样，如果可以从DataHandler获取InputStream，那么bean的readExternal方法将被调用。

        参数
        dh - 描述要传递给命令的数据的DataHandler。
        loader - 用于实例化bean的ClassLoader。
        结果
        豆
        异常
        IOException - 用于读取数据的失败
        ClassNotFoundException - 如果找不到命令对象类
        另请参见：
        Beans.instantiate(java.lang.ClassLoader, java.lang.String) ， CommandObject
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CommandMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class CommandMap

  • java.lang.Object
    • javax.activation.CommandMap
  • 已知直接子类：
    MailcapCommandMap

    public abstract class CommandMap
extends Object
    CommandMap类为系统中可用的命令对象的注册表提供了一个接口。 预计开发人员可以使用该包附带的CommandMap实现（MailcapCommandMap）或开发自己的。 注意，这个类中的一些方法是抽象的。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      CommandMap​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract DataContentHandler createDataContentHandler​(String mimeType)
      找到与MIME类型相对应的DataContentHandler。
      DataContentHandler createDataContentHandler​(String mimeType, DataSource ds)
      找到与MIME类型相对应的DataContentHandler。
      abstract CommandInfo[] getAllCommands​(String mimeType)
      获取此类型的所有可用命令。
      CommandInfo[] getAllCommands​(String mimeType, DataSource ds)
      获取此类型的所有可用命令。
      abstract CommandInfo getCommand​(String mimeType, String cmdName)
      获取与MIME类型相对应的默认命令。
      CommandInfo getCommand​(String mimeType, String cmdName, DataSource ds)
      获取与MIME类型相对应的默认命令。
      static CommandMap getDefaultCommandMap​()
      获取默认的CommandMap。
      String[] getMimeTypes​()
      获取此命令映射已知的所有MIME类型。
      abstract CommandInfo[] getPreferredCommands​(String mimeType)
      从MIME类型获取首选命令列表。
      CommandInfo[] getPreferredCommands​(String mimeType, DataSource ds)
      从MIME类型获取首选命令列表。
      static void setDefaultCommandMap​(CommandMap commandMap)
      设置默认的CommandMap。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CommandMap

        public CommandMap​()

    • 方法详细信息

      • getDefaultCommandMap

        public static CommandMap getDefaultCommandMap​()
        获取默认的CommandMap。
        • 在以前将CommandMap实例设置为某个值（通过setDefaultCommandMap ）返回CommandMap的情况下。
        • 在没有设置CommandMap的情况下，CommandMap创建一个MailcapCommandMap的实例，并将其设置为默认值，返回其值。
        结果
        CommandMap

      • setDefaultCommandMap

        public static void setDefaultCommandMap​(CommandMap commandMap)
        设置默认的CommandMap。 通过使用null调用此方法将CommandMap重置为默认值。
        参数
        commandMap - 新的默认CommandMap。
        异常
        SecurityException - 如果主叫方没有更改默认的权限

      • getPreferredCommands

        public abstract CommandInfo[] getPreferredCommands​(String mimeType)
        从MIME类型获取首选命令列表。 实际语义由CommandMap的实现决定。
        参数
        mimeType - MIME类型
        结果
        表示命令Beans的CommandInfo类。

      • getPreferredCommands

        public CommandInfo[] getPreferredCommands​(String mimeType,
                                          DataSource ds)
        从MIME类型获取首选命令列表。 实际语义由CommandMap的实现决定。

        DataSource提供了额外的信息，例如文件名，CommandMap实现可能用于进一步优化返回的命令列表。 这个类中的实现只是调用忽略这个参数的getPreferredCommands方法。

        参数
        mimeType - MIME类型
        ds - 数据的DataSource
        结果
        表示命令Beans的CommandInfo类。
        从以下版本开始：
        1.6，JAF 1.1

      • getAllCommands

        public abstract CommandInfo[] getAllCommands​(String mimeType)
        获取此类型的所有可用命令。 此方法应返回此MIME类型的所有可能的命令。
        参数
        mimeType - MIME类型
        结果
        表示所有命令的CommandInfo对象。

      • getAllCommands

        public CommandInfo[] getAllCommands​(String mimeType,
                                    DataSource ds)
        获取此类型的所有可用命令。 此方法应返回此MIME类型的所有可能的命令。

        DataSource提供了CommandMap实现可能用于进一步优化返回的命令列表的额外信息，例如文件名。 这个类中的实现只是调用忽略这个参数的getAllCommands方法。

        参数
        mimeType - MIME类型
        ds - 数据的DataSource
        结果
        表示所有命令的CommandInfo对象。
        从以下版本开始：
        1.6，JAF 1.1

      • getCommand

        public abstract CommandInfo getCommand​(String mimeType,
                                       String cmdName)
        获取与MIME类型相对应的默认命令。
        参数
        mimeType - MIME类型
        cmdName - 命令名
        结果
        CommandInfo对应的命令。

      • getCommand

        public CommandInfo getCommand​(String mimeType,
                              String cmdName,
                              DataSource ds)
        获取与MIME类型相对应的默认命令。

        DataSource提供了额外的信息，例如文件名，CommandMap实现可能用于进一步细化所选择的命令。 这个类中的实现只是调用忽略这个参数的getCommand方法。

        参数
        mimeType - MIME类型
        cmdName - 命令名
        ds - 数据的DataSource
        结果
        CommandInfo对应的命令。
        从以下版本开始：
        1.6，JAF 1.1

      • createDataContentHandler

        public abstract DataContentHandler createDataContentHandler​(String mimeType)
        找到与MIME类型相对应的DataContentHandler。 用于确定此的机制和语义由特定CommandMap的实现决定。
        参数
        mimeType - MIME类型
        结果
        DataContentHandler为MIME类型

      • createDataContentHandler

        public DataContentHandler createDataContentHandler​(String mimeType,
                                                   DataSource ds)
        找到与MIME类型相对应的DataContentHandler。 用于确定此的机制和语义由特定CommandMap的实现决定。

        DataSource提供了额外的信息，例如文件名，CommandMap实现可能用于进一步优化DataContentHandler的选择。 这个类中的实现只是调用忽略这个参数的createDataContentHandler方法。

        参数
        mimeType - MIME类型
        ds - 数据的DataSource
        结果
        DataContentHandler为MIME类型
        从以下版本开始：
        1.6，JAF 1.1

      • getMimeTypes

        public String[] getMimeTypes​()
        获取此命令映射已知的所有MIME类型。 如果命令映射不支持此操作，则返回null。
        结果
        MIME类型数组作为字符串，如果不支持，则为null
        从以下版本开始：
        1.6，JAF 1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CommandObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Interface CommandObject

  • public interface CommandObject
    Activation Framework感知的JavaBeans组件实现此接口，以找出要求执行的命令动词，并获取表示他们应该操作的数据的DataHandler。 也可以使用不实现此接口的JavaBean。 这样的命令可以使用Externalizable接口获取数据，或使用特定于应用的方法。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void setCommandContext​(String verb, DataHandler dh)
      使用要处理的动词来初始化命令，以及描述将要操作的数据的DataHandler。

    • 方法详细信息

      • setCommandContext

        void setCommandContext​(String verb,
                       DataHandler dh)
                throws IOException
        使用要处理的动词来初始化命令，以及描述将要操作的数据的DataHandler。 注意：呼叫者可以通过null作为DataHandler的值。
        参数
        verb - 此对象引用的命令动词。
        dh - DataHandler。
        异常
        IOException - for failures accessing data
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DataContentHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Interface DataContentHandler

  • public interface DataContentHandler

    DataContentHandler接口由可用于扩展DataHandler实现可传输接口的功能的对象实现。 通过DataContentHandlers框架可以扩展，将DataContentHandlers对象，并将对象写入到流中。

    DataContentHandler的实现应该是一个带有public no-arg构造函数的公共类。 如果实现类在一个命名模块中，那么它应该在一个导出到模块java.activation的API包中。

    应用程序通常不直接在DataContentHandlers中调用方法。 相反，应用程序调用DataHandler中的等效方法。 DataHandler将尝试使用当前的DataContentHandlerFactory找到与其MIME类型相对应的适当的DataContentHandler。 DataHandler然后调用DataContentHandler中的方法。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object getContent​(DataSource ds)
      以最优选的形式返回表示数据的对象。
      Object getTransferData​(DataFlavor df, DataSource ds)
      返回表示要传输的数据的对象。
      DataFlavor[] getTransferDataFlavors​()
      返回一个DataFlavor对象数组，指示可以提供数据的风格。
      void writeTo​(Object obj, String mimeType, OutputStream os)
      将对象转换为指定MIME类型的字节流，并将其写入输出流。

    • 方法详细信息

      • getTransferDataFlavors

        DataFlavor[] getTransferDataFlavors​()
        返回一个DataFlavor对象数组，指示可以提供数据的风格。数组应根据提供数据的偏好（从最丰富的描述到最少描述）排序。
        结果
        DataFlavors。

      • getTransferData

        Object getTransferData​(DataFlavor df,
                       DataSource ds)
                throws UnsupportedFlavorException,
                       IOException
        返回表示要传输的数据的对象。 返回的对象的类由flavor的表示类定义。
        参数
        df - 表示请求类型的DataFlavor。
        ds - 表示要转换的数据的DataSource。
        结果
        构造的对象。
        异常
        UnsupportedFlavorException - 如果处理程序不支持请求的风味
        IOException - 如果无法访问数据

      • getContent

        Object getContent​(DataSource ds)
           throws IOException
        以最优选的形式返回表示数据的对象。 通常这将是getTransferDataFlavors方法返回的第一个DataFlavor描述的形式。
        参数
        ds - 表示要转换的数据的DataSource。
        结果
        构造的对象。
        异常
        IOException - 如果无法访问数据

      • writeTo

        void writeTo​(Object obj,
             String mimeType,
             OutputStream os)
      throws IOException
        将对象转换为指定MIME类型的字节流，并将其写入输出流。
        参数
        obj - 要转换的对象。
        mimeType - 生成的字节流所请求的MIME类型。
        os - 写入转换后的字节流的输出流。
        异常
        IOException - 写入流的错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DataContentHandlerFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Interface DataContentHandlerFactory

  • public interface DataContentHandlerFactory
    该界面定义了一个DataContentHandlers的工厂。 此接口的实现应将MIME类型映射到DataContentHandler的实例。 实现此接口的类的设计模式与java.net.URL使用的ContentHandler机制java.net.URL 。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      DataContentHandler createDataContentHandler​(String mimeType)
      为MIME类型创建一个新的DataContentHandler对象。

    • 方法详细信息

      • createDataContentHandler

        DataContentHandler createDataContentHandler​(String mimeType)
        为MIME类型创建一个新的DataContentHandler对象。
        参数
        mimeType - 创建DataContentHandler的MIME类型。
        结果
        新的 DataContentHandler ，如果没有找到， DataContentHandler null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DataHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class DataHandler

  • java.lang.Object
    • javax.activation.DataHandler
  • All Implemented Interfaces:
    Transferable

    public class DataHandler
extends Object
implements Transferable
    DataHandler类为许多不同来源和格式的数据提供了一致的界面。 它使用DataContentHandlers管理简单的流到字符串转换和相关操作。 它提供对可以对数据操作的命令的访问。 命令是使用CommandMap找到的。

    DataHandler和可传输接口

    DataHandler实现了可传输接口，以便数据可用于AWT数据传输操作，如剪切和粘贴和拖放。 Transferable接口的实现依赖于与DataHandler的特定实例中表示的数据的MIME类型相对应的已安装DataContentHandler对象的可用性。

    DataHandler和CommandMaps

    DataHandler跟踪当前用于为命令请求（ getCommand, getAllCommands, getPreferredCommands ）提供服务的CommandMap。 DataHandler的每个实例可能使用与其相关联的CommandMap，使用setCommandMap方法。 如果没有设置CommandMap，DataHandler会在CommandMap中调用getDefaultCommandMap方法，并使用它返回的值。 有关详细信息，请参阅CommandMap 。

    DataHandler和URL

    当使用URL构造时，当前的DataHandler实现创建一个URLDataSource的私有实例。

    从以下版本开始：
    1.6
    另请参见：
    CommandMap ， DataContentHandler ， DataSource ， URLDataSource

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataHandler​(Object obj, String mimeType)
      创建一个表示此MIME类型对象的 DataHandler实例。
      DataHandler​(URL url)
      创建引用URL的 DataHandler实例。
      DataHandler​(DataSource ds)
      创建引用指定的DataSource的 DataHandler实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CommandInfo[] getAllCommands​()
      返回此类型数据的所有命令。
      Object getBean​(CommandInfo cmdinfo)
      一个方便的方法，它接受CommandInfo对象并实例化相应的命令，通常是一个JavaBean组件。
      CommandInfo getCommand​(String cmdName)
      获取命令 cmdName 。
      Object getContent​()
      以其首选对象形式返回数据。
      String getContentType​()
      返回从源对象检索的此对象的MIME类型。
      DataSource getDataSource​()
      返回与此DataHandler实例关联的DataSource。
      InputStream getInputStream​()
      获取此对象的InputStream。
      String getName​()
      返回数据对象的名称。
      OutputStream getOutputStream​()
      获取此DataHandler的OutputStream以允许覆盖底层数据。
      CommandInfo[] getPreferredCommands​()
      返回此类型数据的 首选命令。
      Object getTransferData​(DataFlavor flavor)
      返回表示要传输的数据的对象。
      DataFlavor[] getTransferDataFlavors​()
      返回此数据可用的DataFlavors。
      boolean isDataFlavorSupported​(DataFlavor flavor)
      返回此对象是否支持指定的数据flavor。
      void setCommandMap​(CommandMap commandMap)
      设置CommandMap以供DataHandler使用。
      static void setDataContentHandlerFactory​(DataContentHandlerFactory newFactory)
      设置DataContentHandlerFactory。
      void writeTo​(OutputStream os)
      将数据写入 OutputStream 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DataHandler

        public DataHandler​(DataSource ds)
        创建引用指定的DataSource的DataHandler实例。 数据以字节流形式存在。 DataSource将提供一个InputStream来访问数据。
        参数
        ds - DataSource

      • DataHandler

        public DataHandler​(Object obj,
                   String mimeType)
        创建一个表示此MIME类型对象的DataHandler实例。 当应用程序已经具有Java对象形式的数据的内存中表示时，将使用此构造函数。
        参数
        obj - Java对象
        mimeType - 对象的MIME类型

      • DataHandler

        public DataHandler​(URL url)
        创建引用URL的DataHandler实例。 DataHandler内部创建一个URLDataSource实例来表示URL。
        参数
        url - 一个URL对象

    • 方法详细信息

      • getDataSource

        public DataSource getDataSource​()
        返回与此DataHandler实例关联的DataSource。

        对于已使用DataSource实例化的DataHandler，此方法返回用于创建DataHandler对象的DataSource。 在其他情况下，DataHandler根据用于构造DataHandler的数据构建DataSource。 为DataHandler创建的DataSource 未实例化DataSource为缓存高性能的原因。

        结果
        此DataHandler的有效DataSource对象

      • getName

        public String getName​()
        返回数据对象的名称。 如果此DataHandler是使用DataSource创建的，则此方法调用到DataSource.getName方法，否则返回null 。
        结果
        对象的名称

      • getContentType

        public String getContentType​()
        返回从源对象检索的此对象的MIME类型。 请注意，这是具有参数的完整类型。
        结果
        MIME类型

      • getInputStream

        public InputStream getInputStream​()
                           throws IOException
        获取此对象的InputStream。

        对于使用DataSource实例化的DataHandler，DataHandler调用DataSource.getInputStream方法并将结果返回给调用者。

        对于使用Object实例化的DataHandler，DataHandler首先尝试为对象找到一个DataContentHandler。 如果DataHandler找不到此MIME类型的DataContentHandler，则会引发UnsupportedDataTypeException。 如果成功，它将创建一个管道和一个线程。 线程使用DataContentHandler的writeTo方法将流数据写入管道的一端。 管道的另一端返回给调用者。 由于创建线程以复制数据，因此在复制期间可能发生的IOExceptions不能传播回调用者。 结果是一个空的流。

        结果
        InputStream表示此数据
        异常
        IOException - 如果发生I / O错误
        另请参见：
        DataContentHandler.writeTo(java.lang.Object, java.lang.String, java.io.OutputStream) ， UnsupportedDataTypeException

      • writeTo

        public void writeTo​(OutputStream os)
             throws IOException
        将数据写入OutputStream 。

        如果DataHandler是使用DataSource创建的，writeTo将检索InputStream，并将InputStream中的字节复制到传入的OutputStream。

        如果DataHandler是使用对象创建的，writeTo将检索对象类型的DataContentHandler。 如果的DataContentHandler被发现，它调用writeTo的方法DataContentHandler 。

        参数
        os - 要写入的OutputStream
        异常
        IOException - 如果发生I / O错误

      • getOutputStream

        public OutputStream getOutputStream​()
                             throws IOException
        获取此DataHandler的OutputStream以允许覆盖底层数据。 如果DataHandler是使用DataSource创建的，则调用DataSource的getOutputStream方法。 否则返回null 。
        结果
        OutputStream
        异常
        IOException - 创建OutputStream的失败
        另请参见：
        DataSource.getOutputStream() ， URLDataSource

      • getTransferDataFlavors

        public DataFlavor[] getTransferDataFlavors​()
        返回此数据可用的DataFlavors。

        返回一个DataFlavor对象数组，表示可以提供数据的风格。数组通常根据提供数据的偏好进行排序，从最丰富的描述到最不丰富的描述。

        DataHandler尝试查找与数据的MIME类型相对应的DataContentHandler。 如果找到，DataHandler会调用DataContentHandler的getTransferDataFlavors方法。

        如果无法找到DataContentHandler，并且如果使用DataSource（或URL）创建了DataHandler，则会返回一个表示此对象的MIME类型和java.io.InputStream类的java.io.InputStream 。 如果使用对象和MIME类型创建了DataHandler，那么getTransferDataFlavors将返回一个表示此对象的MIME类型和对象类的DataFlavor。

        Specified by:
        getTransferDataFlavors在接口 Transferable
        结果
        一系列可以传输此数据的数据风格
        另请参见：
        DataContentHandler.getTransferDataFlavors()

      • isDataFlavorSupported

        public boolean isDataFlavorSupported​(DataFlavor flavor)
        返回此对象是否支持指定的数据flavor。

        该方法遍历从getTransferDataFlavors返回的DataFlavors，将每个与指定的风味进行比较。

        Specified by:
        isDataFlavorSupported在接口 Transferable
        参数
        flavor - 要求的数据风味
        结果
        如果支持数据风格，则为true
        另请参见：
        getTransferDataFlavors()

      • getTransferData

        public Object getTransferData​(DataFlavor flavor)
                       throws UnsupportedFlavorException,
                              IOException
        返回表示要传输的数据的对象。 返回的对象的类由数据风格的表示类定义。

        对于使用DataSources或URL创建的DataHandler：

        DataHandler尝试为此MIME类型定位DataContentHandler。 如果找到，则将DataFlavor中传递的数据和数据类型传递给其getTransferData方法。 如果DataHandler无法找到DataContentHandler，并且flavor指定此对象的MIME类型和java.io.InputStream类，则返回此对象的InputStream。 否则会引发UnsupportedFlavorException。

        对于使用对象创建的DataHandler：

        DataHandler尝试为此MIME类型定位DataContentHandler。 如果找到，则DataFlavor中传递的数据和数据类型将传递给其getTransferData方法。 如果DataHandler找不到DataContentHandler，并且flavor指定此对象的MIME类型及其类，则会返回此DataHandler的引用对象。 否则会引发UnsupportedFlavorException。

        Specified by:
        getTransferData在接口 Transferable
        参数
        flavor - 要求的数据风味
        结果
        物体
        异常
        UnsupportedFlavorException - 如果数据无法转换为请求的风味
        IOException - 如果发生I / O错误
        另请参见：
        ActivationDataFlavor

      • setCommandMap

        public void setCommandMap​(CommandMap commandMap)
        设置CommandMap以供DataHandler使用。 将其设置为null会导致CommandMap恢复为CommandMap.getDefaultCommandMap方法返回的CommandMap。 更改CommandMap或将其设置为null ，将清除从上一个CommandMap缓存的任何数据。
        参数
        commandMap - 要在此DataHandler中使用的CommandMap
        另请参见：
        CommandMap.setDefaultCommandMap(javax.activation.CommandMap)

      • getPreferredCommands

        public CommandInfo[] getPreferredCommands​()
        返回此类型数据的首选命令。 该方法调用与此DataHandler实例相关联的CommandMap中的getPreferredCommands方法。 此方法返回一个表示可用命令子集的数组。 在存在由DataHandler表示的MIME类型的多个命令的情况下，安装的CommandMap将选择相应的命令。
        结果
        表示首选命令的CommandInfo对象
        另请参见：
        CommandMap.getPreferredCommands(java.lang.String)

      • getAllCommands

        public CommandInfo[] getAllCommands​()
        返回此类型数据的所有命令。 此方法返回一个包含此DataHandler表示的数据类型的所有命令的数组。 此DataHandler表示的底层数据的MIME类型用于调用与此DataHandler关联的CommandMap的getAllCommands方法。
        结果
        表示所有命令的CommandInfo对象
        另请参见：
        CommandMap.getAllCommands(java.lang.String)

      • getCommand

        public CommandInfo getCommand​(String cmdName)
        获取命令cmdName 。 使用由DataHandler中安装的CommandMap定义的搜索语义。 此DataHandler表示的底层数据的MIME类型用于调用与此DataHandler关联的CommandMap的getCommand方法。
        参数
        cmdName - 命令名
        结果
        CommandInfo对应的命令
        另请参见：
        CommandMap.getCommand(java.lang.String, java.lang.String)

      • getContent

        public Object getContent​()
                  throws IOException
        以其首选对象形式返回数据。

        如果使用对象实例化了DataHandler，则返回该对象。

        如果DataHandler用DataSource实例化，则此方法使用DataContentHandler返回此DataHandler表示的数据的内容对象。 如果没有找到DataContentHandler数据类型，那么DataHandler将为数据返回一个InputStream。

        结果
        内容。
        异常
        IOException - 如果在此操作期间发生IOException。

      • getBean

        public Object getBean​(CommandInfo cmdinfo)
        一个方便的方法，它接受CommandInfo对象并实例化相应的命令，通常是一个JavaBean组件。

        这种方法调用了CommandInfo的getCommandObject方法，其中ClassLoader用于加载javax.activation.DataHandler类。

        参数
        cmdinfo - 与命令对应的CommandInfo
        结果
        实例化的命令对象

      • setDataContentHandlerFactory

        public static void setDataContentHandlerFactory​(DataContentHandlerFactory newFactory)
        设置DataContentHandlerFactory。 首先调用DataContentHandlerFactory来查找DataContentHandlers。 DataContentHandlerFactory只能设置一次。

        如果DataContentHandlerFactory已经被设置，这个方法会抛出一个错误。

        参数
        newFactory - DataContentHandlerFactory
        异常
        Error - 如果工厂已经定义。
        另请参见：
        DataContentHandlerFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DataSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Interface DataSource

  • 所有已知实现类：
    FileDataSource ， URLDataSource

    public interface DataSource
    DataSource接口为JavaBean激活框架提供了任意数据集合的抽象。 它为该数据提供了一种类型，并在适当的情况下以InputStreams和OutputStreams的形式进行InputStreams 。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getContentType​()
      此方法以字符串的形式返回数据的MIME类型。
      InputStream getInputStream​()
      此方法返回一个表示数据的 InputStream ，如果不能这样做，则会抛出相应的异常。
      String getName​()
      返回此对象，其中对象的名称是依赖于底层的对象的性质 名称 。
      OutputStream getOutputStream​()
      此方法返回一个 OutputStream ，如果不能这样做，可以写入数据并抛出适当的异常。

    • 方法详细信息

      • getInputStream

        InputStream getInputStream​()
                    throws IOException
        此方法返回一个表示数据的InputStream ，如果不能这样做，则会抛出相应的异常。 请注意，每次调用此方法时，必须返回新的InputStream对象，并且流必须位于数据的开头。
        结果
        一个InputStream
        异常
        IOException - 创建InputStream的失败

      • getOutputStream

        OutputStream getOutputStream​()
                      throws IOException
        该方法返回一个可以写入数据的OutputStream ，如果不能这样做，则会抛出相应的异常。 请注意，每次调用此方法时，必须返回一个新的OutputStream对象，并且流必须位于数据要写入的位置。
        结果
        一个OutputStream
        异常
        IOException - 创建OutputStream的失败

      • getContentType

        String getContentType​()
        此方法以字符串的形式返回数据的MIME类型。 它应该总是返回一个有效的类型。 建议如果DataSource实现无法确定数据类型，则getContentType返回“application / octet-stream”。
        结果
        MIME类型

      • getName

        String getName​()
        返回此对象，其中对象的名称是依赖于底层的对象的性质名称 。 DataSources封装文件可能会选择返回对象的文件名。 （通常这将是文件名的最后一个组件，而不是整个路径名。）
        结果
        对象的名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileDataSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class FileDataSource

  • java.lang.Object
    • javax.activation.FileDataSource
  • All Implemented Interfaces:
    DataSource

    public class FileDataSource
extends Object
implements DataSource
    FileDataSource类实现了一个封装文件的简单DataSource对象。 它通过FileTypeMap对象提供数据打字服务。

    FileDataSource打字语义

    FileDataSource类将文件的数据类型转换为从FileTypeMap类子类的对象。 setFileTypeMap方法可用于显式设置FileDataSource实例的FileTypeMap。 如果没有设置FileTypeMap，FileDataSource将调用FileTypeMap的getDefaultFileTypeMap方法来获取系统的默认FileTypeMap。

    从以下版本开始：
    1.6
    另请参见：
    DataSource ， FileTypeMap ， MimetypesFileTypeMap

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileDataSource​(File file)
      从File对象创建FileDataSource。
      FileDataSource​(String name)
      从指定的路径名创建一个FileDataSource。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getContentType​()
      此方法以字符串的形式返回数据的MIME类型。
      File getFile​()
      返回与此FileDataSource对应的File对象。
      InputStream getInputStream​()
      此方法将返回一个表示数据的InputStream，如果不能执行此操作将抛出IOException。
      String getName​()
      返回此对象的 名称 。
      OutputStream getOutputStream​()
      此方法将返回一个表示数据的OutputStream，如果不能执行此操作将抛出IOException。
      void setFileTypeMap​(FileTypeMap map)
      将FileTypeMap设置为与此FileDataSource一起使用

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileDataSource

        public FileDataSource​(File file)
        从File对象创建FileDataSource。 注意：在调用需要打开文件的方法之前，文件才会被打开。
        参数
        file - 该文件

      • FileDataSource

        public FileDataSource​(String name)
        从指定的路径名创建一个FileDataSource。 注意：在调用需要打开文件的方法之前，文件才会被打开。
        参数
        name - 与系统相关的文件名。

    • 方法详细信息

      • getInputStream

        public InputStream getInputStream​()
                           throws IOException
        此方法将返回一个表示数据的InputStream，如果不能执行此操作将抛出IOException。 此方法将返回一个新的InputStream实例，每次调用。
        Specified by:
        getInputStream在接口 DataSource
        结果
        一个InputStream
        异常
        IOException - 创建InputStream的失败

      • getOutputStream

        public OutputStream getOutputStream​()
                             throws IOException
        此方法将返回一个表示数据的OutputStream，如果不能执行此操作将抛出IOException。 此方法将返回每个调用的OutputStream的新实例。
        Specified by:
        getOutputStream在接口 DataSource
        结果
        一个OutputStream
        异常
        IOException - 创建OutputStream的失败

      • getContentType

        public String getContentType​()
        此方法以字符串的形式返回数据的MIME类型。 此方法使用当前安装的FileTypeMap。 如果没有明确设置FileTypeMap，FileDataSource将在FileTypeMap上调用getDefaultFileTypeMap方法来获取默认的FileTypeMap。 注意：默认情况下，使用的FileTypeMap将是MimetypesFileTypeMap。
        Specified by:
        getContentType在接口 DataSource
        结果
        MIME类型
        另请参见：
        FileTypeMap.getDefaultFileTypeMap()

      • getName

        public String getName​()
        返回此对象的名称 。 FileDataSource将返回对象的文件名。
        Specified by:
        getName在接口 DataSource
        结果
        对象的名称。
        另请参见：
        DataSource

      • getFile

        public File getFile​()
        返回与此FileDataSource对应的File对象。
        结果
        由该对象表示的文件的File对象。

      • setFileTypeMap

        public void setFileTypeMap​(FileTypeMap map)
        将FileTypeMap设置为与此FileDataSource一起使用
        参数
        map - 此对象的FileTypeMap。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileTypeMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class FileTypeMap

  • java.lang.Object
    • javax.activation.FileTypeMap
  • 已知直接子类：
    MimetypesFileTypeMap

    public abstract class FileTypeMap
extends Object
    FileTypeMap是一个抽象类，为文件提供数据输入界面。 该类的实现将实现将从文件名或File对象中导出内容类型的getContentType方法。 FileTypeMaps可以使用任何方案来确定数据类型，从检查文件的文件扩展名（如MimetypesFileTypeMap）打开文件并尝试从文件的内容派生类型。 FileDataSource类使用默认的FileTypeMap（MimetypesFileTypeMap除非已更改）来确定文件的内容类型。
    从以下版本开始：
    1.6
    另请参见：
    FileTypeMap ， FileDataSource ， MimetypesFileTypeMap

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileTypeMap​()
      默认构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract String getContentType​(File file)
      返回文件对象的类型。
      abstract String getContentType​(String filename)
      返回传入的文件的类型。
      static FileTypeMap getDefaultFileTypeMap​()
      返回系统的默认FileTypeMap。
      static void setDefaultFileTypeMap​(FileTypeMap fileTypeMap)
      设置系统的默认FileTypeMap。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileTypeMap

        public FileTypeMap​()
        默认构造函数。

    • 方法详细信息

      • getContentType

        public abstract String getContentType​(File file)
        返回文件对象的类型。 此方法应始终返回有效的MIME类型。
        参数
        file - 要输入的文件。
        结果
        内容类型。

      • getContentType

        public abstract String getContentType​(String filename)
        返回传入的文件的类型。此方法应始终返回有效的MIME类型。
        参数
        filename - 文件的路径名。
        结果
        内容类型。

      • setDefaultFileTypeMap

        public static void setDefaultFileTypeMap​(FileTypeMap fileTypeMap)
        设置系统的默认FileTypeMap。 该实例将返回给getDefaultFileTypeMap的调用者。
        参数
        fileTypeMap - FileTypeMap。
        异常
        SecurityException - 如果主叫方没有更改默认的权限

      • getDefaultFileTypeMap

        public static FileTypeMap getDefaultFileTypeMap​()
        返回系统的默认FileTypeMap。 如果调用了setDefaultFileTypeMap，则返回该实例，否则返回一个MimetypesFileTypeMap的实例。
        结果
        默认的FileTypeMap
        另请参见：
        setDefaultFileTypeMap(javax.activation.FileTypeMap)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.activation (Java SE 9 & JDK 9 )

javax.activation

Interfaces

  • CommandObject
  • DataContentHandler
  • DataContentHandlerFactory
  • DataSource

Classes

  • ActivationDataFlavor
  • CommandInfo
  • CommandMap
  • DataHandler
  • FileDataSource
  • FileTypeMap
  • MailcapCommandMap
  • MimeType
  • MimeTypeParameterList
  • MimetypesFileTypeMap
  • URLDataSource

Exceptions

  • MimeTypeParseException
  • UnsupportedDataTypeException


javax.activation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.activation

Package javax.activation

  • 接口摘要
    接口 描述
    CommandObject
    Activation Framework感知的JavaBeans组件实现此接口，以找出要求执行的命令动词，并获取表示他们应该操作的数据的DataHandler。
    DataContentHandler
    DataContentHandler接口由可用于扩展DataHandler实现可传输接口的功能的对象实现。
    DataContentHandlerFactory
    该界面定义了一个 DataContentHandlers的工厂。
    DataSource
    DataSource接口为JavaBean激活框架提供了任意数据集合的抽象。
  • 类摘要
    Class 描述
    ActivationDataFlavor
    ActivationDataFlavor类是一个特殊的子类，为 java.awt.datatransfer.DataFlavor 。
    CommandInfo
    CommandMap实现使用CommandInfo类来描述命令请求的结果。
    CommandMap
    CommandMap类为系统中可用的命令对象的注册表提供了一个接口。
    DataHandler
    DataHandler类为许多不同来源和格式的数据提供了一致的界面。
    FileDataSource
    FileDataSource类实现了一个封装文件的简单DataSource对象。
    FileTypeMap
    FileTypeMap是一个抽象类，为文件提供数据输入界面。
    MailcapCommandMap
    MailcapCommandMap扩展了CommandMap抽象类。
    MimeType
    多功能Internet邮件扩展（MIME）类型，如RFC 2045和2046中所定义。
    MimeTypeParameterList
    RFC 2045和2046中定义的MimeType的参数列表。
    MimetypesFileTypeMap
    该类扩展了FileTypeMap，并通过其文件扩展名提供了文件的数据输入。
    URLDataSource
    URLDataSource类提供了一个在DataSource接口中包装一个 URL对象的对象。
  • 异常摘要
    异常 描述
    MimeTypeParseException
    封装MimeType解析相关异常的类。
    UnsupportedDataTypeException
    表示请求的操作不支持请求的数据类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.activation Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.activation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.activation.CommandInfo
    • javax.activation.CommandMap
      • javax.activation.MailcapCommandMap
    • java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
      • javax.activation.ActivationDataFlavor
    • javax.activation.DataHandler (implements java.awt.datatransfer.Transferable)
    • javax.activation.FileDataSource (implements javax.activation.DataSource)
    • javax.activation.FileTypeMap
      • javax.activation.MimetypesFileTypeMap
    • javax.activation.MimeType (implements java.io.Externalizable)
    • javax.activation.MimeTypeParameterList
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • javax.activation.UnsupportedDataTypeException
        • javax.activation.MimeTypeParseException
    • javax.activation.URLDataSource (implements javax.activation.DataSource)

Interface Hierarchy

  • javax.activation.CommandObject
  • javax.activation.DataContentHandler
  • javax.activation.DataContentHandlerFactory
  • javax.activation.DataSource
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


MailcapCommandMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class MailcapCommandMap

  • java.lang.Object
    • javax.activation.CommandMap
      • javax.activation.MailcapCommandMap

  • public class MailcapCommandMap
extends CommandMap
    MailcapCommandMap扩展了CommandMap抽象类。 它实现了一个CommandMap，其配置基于mailcap文件（ RFC 1524 ）。 MailcapCommandMap可以通过编程方式和配置文件进行配置。

    Mailcap文件搜索顺序：

    MailcapCommandMap在用户系统的各个地方查看mailcap文件条目。 当请求在MailcapCommandMap中搜索命令时，它将按以下顺序搜索mailcap文件：

    1. 向MailcapCommandMap实例编程添加条目。
    2. 文件.mailcap在用户的主目录中。
    3. Java运行时中的文件mailcap 。
    4. 名称为META-INF/mailcap的文件或资源。
    5. 名称为META-INF/mailcap.default的文件或资源（通常仅在activation.jar文件中找到）。

    （当前的实现在java.home /conf目录中的Java运行时中查找mailcap文件，否则在目录java.home /lib ，其中java.home是“java.home”系统属性的值请注意，“conf”目录在JDK 9中引入。）

    Mailcap文件格式：

    Mailcap文件必须符合mailcap文件规范（RFC 1524， A User Agent Configuration Mechanism For Multimedia Mail Format Information ）。 文件格式由与特定MIME类型相对应的条目组成。 一般来说，规范指定了客户端在他们自己不能在指定的MIME类型上运行时使用的应用程序 。 MailcapCommandMap通过在mailcap文件中使用参数机制来扩展此规范，允许将JavaBeans（tm）组件指定为MIME类型的特定命令。

    当解析一个mailcap文件时，MailcapCommandMap会识别某些参数签名，特别是以x-java-开头的参数名称。 MailcapCommandMap使用此签名来查找包含在其注册表中的命令条目。 x-java-<name>读取具有表单x-java-<name>参数名称，用于标识名称为name的命令。 当名称为content-handler ，MailcapCommandMap将此参数表示的类识别为DataContentHandler 。 无论命令名称如何，一般处理所有其他命令。 命令实现由JavaBean（tm）组件的完全限定类名指定。 例如; 用于查看某些数据的命令可以指定为： x-java-view=com.foo.ViewBean 。

    当命令名为fallback-entry时，命令的值可能为true或false 。 包含x-java-fallback-entry=true参数的MIME类型的x-java-fallback-entry=true定义了该MIME类型的回退命令，只有在没有找到非后备条目的情况下才会使用。 例如，表单text/*; ; x-java-fallback-entry=true; x-java-view=com.sun.TextViewer的条目指定了用于任何文本MIME类型的视图命令。 仅当无法找到MIME类型的非后备视图命令时，才能使用此视图命令。

    MailcapCommandMap感知mailcap文件具有以下一般形式：

       # Comments begin with a '#' and continue to the end of the line. <mime type>; ; <parameter list> # Where a parameter list consists of one or more parameters, # where parameters look like: x-java-view=com.sun.TextViewer # and a parameter list looks like: text/plain; ; x-java-view=com.sun.TextViewer; x-java-edit=com.sun.TextEdit # Note that mailcap entries that do not contain 'x-java' parameters # and comply to RFC 1524 are simply ignored: image/gif; /usr/dt/bin/sdtimage %s
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      MailcapCommandMap​()
      默认构造函数。
      MailcapCommandMap​(InputStream is)
      构造函数允许调用者指定一个包含mailcap文件的 InputStream 。
      MailcapCommandMap​(String fileName)
      构造函数允许调用者指定 mailcap文件的路径。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addMailcap​(String mail_cap)
      将条目添加到注册表。
      DataContentHandler createDataContentHandler​(String mimeType)
      返回指定MIME类型的DataContentHandler。
      CommandInfo[] getAllCommands​(String mimeType)
      获取此MIME类型的MailcapCommandMap的此实例已知的所有mailcap文件中的所有可用命令。
      CommandInfo getCommand​(String mimeType, String cmdName)
      获取对应于MIME类型的 cmdName对应的命令。
      String[] getMimeTypes​()
      获取此命令映射已知的所有MIME类型。
      String[] getNativeCommands​(String mimeType)
      获取给定MIME类型的本机命令。
      CommandInfo[] getPreferredCommands​(String mimeType)
      获取MIME类型的首选命令列表。

      • Methods inherited from class javax.activation.CommandMap

        createDataContentHandler, getAllCommands, getCommand, getDefaultCommandMap, getPreferredCommands, setDefaultCommandMap

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MailcapCommandMap

        public MailcapCommandMap​()
        默认构造函数。

      • MailcapCommandMap

        public MailcapCommandMap​(String fileName)
                  throws IOException
        构造函数允许调用者指定 mailcap文件的路径。
        参数
        fileName - 要打开的 mailcap文件的名称
        异常
        IOException - 如果文件无法访问

      • MailcapCommandMap

        public MailcapCommandMap​(InputStream is)
        构造函数允许调用者指定一个包含mailcap文件的 InputStream 。
        参数
        is - 要打开的 mailcap文件的InputStream

    • 方法详细信息

      • getPreferredCommands

        public CommandInfo[] getPreferredCommands​(String mimeType)
        获取MIME类型的首选命令列表。 MailcapCommandMap按照上述Mailcap 文件搜索顺序搜索mailcap文件 。

        搜索结果是MailcapCommandMap此实例已知的所有mailcap文件中可用命令的一个适当子集。 特定命令的第一个条目被认为是首选命令。

        Specified by:
        getPreferredCommands在 CommandMap
        参数
        mimeType - MIME类型
        结果
        表示首选命令的CommandInfo对象。

      • getAllCommands

        public CommandInfo[] getAllCommands​(String mimeType)
        获取此MIME类型的MailcapCommandMap的此实例已知的所有mailcap文件中的所有可用命令。
        Specified by:
        getAllCommands在 CommandMap
        参数
        mimeType - MIME类型
        结果
        表示所有命令的CommandInfo对象。

      • getCommand

        public CommandInfo getCommand​(String mimeType,
                              String cmdName)
        获取MIME类型的 cmdName相应的命令。
        Specified by:
        getCommand在 CommandMap
        参数
        mimeType - MIME类型
        cmdName - 命令名称
        结果
        CommandInfo对象对应的命令。

      • addMailcap

        public void addMailcap​(String mail_cap)
        将条目添加到注册表。 在其他条目之前，以编程方式添加条目。

        传入的字符串应该是mailcap格式。

        参数
        mail_cap - 一个正确格式化的mailcap字符串

      • createDataContentHandler

        public DataContentHandler createDataContentHandler​(String mimeType)
        返回指定MIME类型的DataContentHandler。
        Specified by:
        createDataContentHandler在 CommandMap
        参数
        mimeType - MIME类型
        结果
        DataContentHandler

      • getMimeTypes

        public String[] getMimeTypes​()
        获取此命令映射已知的所有MIME类型。
        重写：
        getMimeTypes在 CommandMap
        结果
        MIME类型数组作为字符串
        从以下版本开始：
        1.6，JAF 1.1

      • getNativeCommands

        public String[] getNativeCommands​(String mimeType)
        获取给定MIME类型的本机命令。 返回一个字符串数组，每个字符串是整个mailcap文件条目。 应用程序将需要解析该条目以提取实际的命令以及它需要的任何属性。 有关mailcap条目语法的详细信息，请参阅RFC 1524 。 仅返回指定MIME类型的视图命令的mailcap条目。
        参数
        mimeType - MIME类型
        结果
        本地命令条目数组
        从以下版本开始：
        1.6，JAF 1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MimeType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class MimeType

  • java.lang.Object
    • javax.activation.MimeType
  • All Implemented Interfaces:
    Externalizable ， Serializable

    public class MimeType
extends Object
implements Externalizable
    多功能Internet邮件扩展（MIME）类型，如RFC 2045和2046中所定义。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MimeType​()
      默认构造函数。
      MimeType​(String rawdata)
      从String构建MimeType的构造方法。
      MimeType​(String primary, String sub)
      构造函数，它使用给定的主类型和子类型构建MimeType，但具有空参数列表。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getBaseType​()
      返回此对象的String表示，而不包含参数列表。
      String getParameter​(String name)
      检索与给定名称相关联的值，如果没有当前关联，则返回null。
      MimeTypeParameterList getParameters​()
      检索此对象的参数列表。
      String getPrimaryType​()
      检索此对象的主要类型。
      String getSubType​()
      检索此对象的子类型。
      boolean match​(String rawdata)
      确定此对象的主要类型和子类型是否与rawdata中描述的内容类型相同。
      boolean match​(MimeType type)
      确定此对象的主类型和子类型是否与给定类型中的相同。
      void readExternal​(ObjectInput in)
      该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。
      void removeParameter​(String name)
      删除与给定名称相关联的任何值。
      void setParameter​(String name, String value)
      设置与给定名称相关联的值，替换任何先前的关联。
      void setPrimaryType​(String primary)
      将此对象的主要类型设置为给定的String。
      void setSubType​(String sub)
      将此对象的子类型设置为给定的String。
      String toString​()
      返回此对象的String表示。
      void writeExternal​(ObjectOutput out)
      该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput对象，字符串和数组的writeObject方法来保存其内容。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MimeType

        public MimeType​()
        默认构造函数。

      • MimeType

        public MimeType​(String rawdata)
         throws MimeTypeParseException
        从String构建MimeType的构造方法。
        参数
        rawdata - MIME类型字符串
        异常
        MimeTypeParseException - 如果MIME类型无法解析

      • MimeType

        public MimeType​(String primary,
                String sub)
         throws MimeTypeParseException
        构造函数，它使用给定的主类型和子类型构建MimeType，但具有空参数列表。
        参数
        primary - 主MIME类型
        sub - MIME子类型
        异常
        MimeTypeParseException - 如果主类型或子类型不是有效的标记

    • 方法详细信息

      • getPrimaryType

        public String getPrimaryType​()
        检索此对象的主要类型。
        结果
        主要MIME类型

      • setPrimaryType

        public void setPrimaryType​(String primary)
                    throws MimeTypeParseException
        将此对象的主要类型设置为给定的String。
        参数
        primary - 主MIME类型
        异常
        MimeTypeParseException - 如果主类型不是有效的标记

      • getSubType

        public String getSubType​()
        检索此对象的子类型。
        结果
        MIME子类型

      • setSubType

        public void setSubType​(String sub)
                throws MimeTypeParseException
        将此对象的子类型设置为给定的String。
        参数
        sub - MIME子类型
        异常
        MimeTypeParseException - 如果子类型不是有效的标记

      • getParameters

        public MimeTypeParameterList getParameters​()
        检索此对象的参数列表。
        结果
        表示参数的MimeTypeParameterList对象

      • getParameter

        public String getParameter​(String name)
        检索与给定名称相关联的值，如果没有当前关联，则返回null。
        参数
        name - 参数名称
        结果
        参数的价值

      • setParameter

        public void setParameter​(String name,
                         String value)
        设置与给定名称相关联的值，替换任何先前的关联。
        参数
        name - 参数名称
        value - 参数值

      • removeParameter

        public void removeParameter​(String name)
        删除与给定名称相关联的任何值。
        参数
        name - 参数名称

      • toString

        public String toString​()
        返回此对象的String表示。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • getBaseType

        public String getBaseType​()
        返回此对象的String表示，而不包含参数列表。
        结果
        MIME类型和子类型

      • match

        public boolean match​(MimeType type)
        确定此对象的主类型和子类型是否与给定类型中的相同。
        参数
        type - 要比较的MimeType对象
        结果
        如果他们匹配的话

      • match

        public boolean match​(String rawdata)
              throws MimeTypeParseException
        确定此对象的主要类型和子类型是否与rawdata中描述的内容类型相同。
        参数
        rawdata - 要比较的MIME类型字符串
        结果
        如果他们匹配的话
        异常
        MimeTypeParseException - 如果MIME类型无法解析

      • writeExternal

        public void writeExternal​(ObjectOutput out)
                   throws IOException
        该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput对象，字符串和数组的writeObject方法来保存其内容。
        Specified by:
        writeExternal在接口 Externalizable
        参数
        out - 要写入的ObjectOutput对象
        异常
        IOException - 包括可能发生的任何I / O异常

      • readExternal

        public void readExternal​(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
        该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。 readExternal方法必须以与writeExternal写的相同的顺序读取相同的值。
        Specified by:
        readExternal在接口 Externalizable
        参数
        in - 要读取的ObjectInput对象
        异常
        ClassNotFoundException - 如果无法找到正在还原的对象的类。
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MimeTypeParameterList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class MimeTypeParameterList

  • java.lang.Object
    • javax.activation.MimeTypeParameterList

  • public class MimeTypeParameterList
extends Object
    在RFC 2045和2046中定义的MimeType的参数列表。对象的主要类型必须已被剥离。
    从以下版本开始：
    1.6
    另请参见：
    MimeType

    • 构造方法摘要

      构造方法
      Constructor 描述
      MimeTypeParameterList​()
      默认构造函数。
      MimeTypeParameterList​(String parameterList)
      使用传入的数据构造一个新的MimeTypeParameterList。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String get​(String name)
      检索与给定名称相关联的值，如果没有当前关联，则返回null。
      Enumeration getNames​()
      检索此列表中所有名称的枚举。
      boolean isEmpty​()
      确定此列表是否为空。
      protected void parse​(String parameterList)
      用于从String解析参数列表的例程。
      void remove​(String name)
      删除与给定名称相关联的任何值。
      void set​(String name, String value)
      设置与给定名称相关联的值，替换任何先前的关联。
      int size​()
      返回此列表中的名称/值对数。
      String toString​()
      返回此对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MimeTypeParameterList

        public MimeTypeParameterList​()
        默认构造函数。

      • MimeTypeParameterList

        public MimeTypeParameterList​(String parameterList)
                      throws MimeTypeParseException
        使用传入的数据构造一个新的MimeTypeParameterList。
        参数
        parameterList - RFC parameterList兼容参数列表。
        异常
        MimeTypeParseException - 如果MIME类型无法解析

    • 方法详细信息

      • parse

        protected void parse​(String parameterList)
              throws MimeTypeParseException
        用于从String解析参数列表的例程。
        参数
        parameterList - RFC parameterList兼容参数列表。
        异常
        MimeTypeParseException - 如果MIME类型无法解析

      • size

        public int size​()
        返回此列表中的名称/值对数。
        结果
        参数数量

      • isEmpty

        public boolean isEmpty​()
        确定此列表是否为空。
        结果
        如果没有参数，则为true

      • get

        public String get​(String name)
        检索与给定名称相关联的值，如果没有当前关联，则返回null。
        参数
        name - 参数名称
        结果
        参数的值

      • set

        public void set​(String name,
                String value)
        设置与给定名称相关联的值，替换任何先前的关联。
        参数
        name - 参数名称
        value - 参数的值

      • remove

        public void remove​(String name)
        删除与给定名称相关联的任何值。
        参数
        name - 参数名称

      • getNames

        public Enumeration getNames​()
        检索此列表中所有名称的枚举。
        结果
        枚举所有参数名称

      • toString

        public String toString​()
        返回此对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MimeTypeParseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class MimeTypeParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.activation.MimeTypeParseException
  • All Implemented Interfaces:
    Serializable

    public class MimeTypeParseException
extends 异常
    封装MimeType解析相关异常的类。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MimeTypeParseException​()
      构造一个没有指定的详细信息的MimeTypeParseException。
      MimeTypeParseException​(String s)
      构造具有指定详细消息的MimeTypeParseException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MimeTypeParseException

        public MimeTypeParseException​()
        构造一个没有指定的详细信息的MimeTypeParseException。

      • MimeTypeParseException

        public MimeTypeParseException​(String s)
        构造具有指定详细消息的MimeTypeParseException。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MimetypesFileTypeMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class MimetypesFileTypeMap

  • java.lang.Object
    • javax.activation.FileTypeMap
      • javax.activation.MimetypesFileTypeMap

  • public class MimetypesFileTypeMap
extends FileTypeMap
    该类扩展了FileTypeMap，并通过其文件扩展名提供了文件的数据输入。 它使用.mime.types格式。

    MIME类型文件搜索顺序：

    MimetypesFileTypeMap在用户系统的不同位置查看MIME类型文件条目。 当请求在MimetypesFileTypeMap中搜索MIME类型时，它按以下顺序搜索MIME类型文件：

    1. 以编程方式将条目添加到MimetypesFileTypeMap实例。
    2. 文件.mime.types在用户的主目录中。
    3. 文件mime.types在Java运行时。
    4. 名称为META-INF/mime.types的文件或资源。
    5. 名称为META-INF/mimetypes.default的文件或资源（通常仅在activation.jar文件中找到）。

    （当前的实现在java.home /conf目录中的Java运行时中查找mime.types文件，否则在目录java.home /lib ，其中java.home是“java.home”系统属性的值请注意，“conf”目录在JDK 9中引入。）

    MIME类型文件格式：

       # comments begin with a '#' # the format is <mime type> <space separated file extensions> # for example: text/plain txt text TXT # this would map file.txt, file.text, and file.TXT to # the mime type "text/plain"
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      MimetypesFileTypeMap​()
      默认构造函数。
      MimetypesFileTypeMap​(InputStream is)
      构造一个MimetypesFileTypeMap，其中包含从InputStream中添加的程序化条目。
      MimetypesFileTypeMap​(String mimeTypeFileName)
      构造MimetypesFileTypeMap，并从命名文件中添加程序化条目。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addMimeTypes​(String mime_types)
      将MIME类型值添加到注册表。
      String getContentType​(File f)
      返回文件对象的MIME类型。
      String getContentType​(String filename)
      根据指定的文件名返回MIME类型。

      • Methods inherited from class javax.activation.FileTypeMap

        getDefaultFileTypeMap, setDefaultFileTypeMap

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MimetypesFileTypeMap

        public MimetypesFileTypeMap​()
        默认构造函数。

      • MimetypesFileTypeMap

        public MimetypesFileTypeMap​(String mimeTypeFileName)
                     throws IOException
        构造MimetypesFileTypeMap，并从命名文件中添加程序化条目。
        参数
        mimeTypeFileName - 文件名
        异常
        IOException - 读取文件时出错

      • MimetypesFileTypeMap

        public MimetypesFileTypeMap​(InputStream is)
        构造一个MimetypesFileTypeMap，其中包含从InputStream中添加的程序化条目。
        参数
        is - 要读取的输入流

    • 方法详细信息

      • addMimeTypes

        public void addMimeTypes​(String mime_types)
        将MIME类型值添加到注册表。
        参数
        mime_types - 一个.mime.types格式的条目字符串。

      • getContentType

        public String getContentType​(File f)
        返回文件对象的MIME类型。 该类的实现调用getContentType(f.getName()) 。
        Specified by:
        getContentType在 FileTypeMap
        参数
        f - 该文件
        结果
        该文件的MIME类型

      • getContentType

        public String getContentType​(String filename)
        根据指定的文件名返回MIME类型。 按照MIME类型文件搜索顺序，如上所述搜索MIME类型条目。 如果没有找到条目，则返回类型“application / octet-stream”。
        Specified by:
        getContentType在 FileTypeMap
        参数
        filename - 文件名
        结果
        该文件的MIME类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnsupportedDataTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class UnsupportedDataTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.activation.UnsupportedDataTypeException
  • All Implemented Interfaces:
    Serializable

    public class UnsupportedDataTypeException
extends IOException
    表示请求的操作不支持请求的数据类型。
    从以下版本开始：
    1.6
    另请参见：
    DataHandler ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnsupportedDataTypeException​()
      构造一个UnsupportedDataTypeException，没有详细消息。
      UnsupportedDataTypeException​(String s)
      构造具有指定消息的UnsupportedDataTypeException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnsupportedDataTypeException

        public UnsupportedDataTypeException​()
        构造一个UnsupportedDataTypeException，没有详细消息。

      • UnsupportedDataTypeException

        public UnsupportedDataTypeException​(String s)
        构造具有指定消息的UnsupportedDataTypeException。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


URLDataSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.activation
软件包 javax.activation

Class URLDataSource

  • java.lang.Object
    • javax.activation.URLDataSource
  • All Implemented Interfaces:
    DataSource

    public class URLDataSource
extends Object
implements DataSource
    URLDataSource类提供了一个在DataSource接口中包装一个URL对象的对象。 URLDataSource简化了JavaBeans激活框架内由URL描述的数据的处理，因为此类可用于创建新的DataHandler。 注意：DataHandler对象使用URL构造时，内部将创建一个URLDataSource。
    从以下版本开始：
    1.6
    另请参见：
    DataSource ， DataHandler

    • 构造方法摘要

      构造方法
      Constructor 描述
      URLDataSource​(URL url)
      URLDataSource构造函数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getContentType​()
      返回URL内容类型头字段的值。
      InputStream getInputStream​()
      来自URL的getInputStream方法。
      String getName​()
      在用于实例化对象的URL上调用 getFile方法。
      OutputStream getOutputStream​()
      来自URL的getOutputStream方法。
      URL getURL​()
      返回用于创建此DataSource的URL。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • URLDataSource

        public URLDataSource​(URL url)
        URLDataSource构造函数。 URLDataSource类将不会打开与URL的连接，直到调用需要它的方法。
        参数
        url - 要封装在此对象中的URL。

    • 方法详细信息

      • getContentType

        public String getContentType​()
        返回URL内容类型头字段的值。 在检索URLConnection对象后，它调用URL的URLConnection.getContentType方法。 注意：此方法尝试在URL上调用openConnection方法。 如果此方法失败，或者如果内容类型未从URLConnection返回，则getContentType返回“application / octet-stream”作为内容类型。
        Specified by:
        getContentType在接口 DataSource
        结果
        内容类型。

      • getName

        public String getName​()
        在用于实例化对象的URL上调用 getFile方法。
        Specified by:
        getName在接口 DataSource
        结果
        调用URL的getFile方法的结果。

      • getInputStream

        public InputStream getInputStream​()
                           throws IOException
        来自URL的getInputStream方法。 在URL上调用openStream方法。
        Specified by:
        getInputStream在界面 DataSource
        结果
        InputStream。
        异常
        IOException - 创建InputStream的失败

      • getOutputStream

        public OutputStream getOutputStream​()
                             throws IOException
        来自URL的getOutputStream方法。 首先尝试获取URL的URLConnection对象。 如果成功，则返回URLConnection上的getOutputStream方法。
        Specified by:
        getOutputStream在界面 DataSource
        结果
        OutputStream。
        异常
        IOException - 创建OutputStream的失败

      • getURL

        public URL getURL​()
        返回用于创建此DataSource的URL。
        结果
        网址。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.activation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.activation

  • Packages that use javax.activation
    软件包 描述
    javax.activation
    javax.xml.bind.attachment
    该包由基于MIME的包处理器实现，可以在基于MIME的包格式中解释和创建优化的二进制数据。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
  • Classes in javax.activation used by javax.activation
    Class 描述
    CommandInfo
    CommandMap实现使用CommandInfo类来描述命令请求的结果。
    CommandMap
    CommandMap类为系统中可用的命令对象的注册表提供了一个接口。
    DataContentHandler
    DataContentHandler接口由可用于扩展DataHandler实现可传输接口的功能的对象实现。
    DataContentHandlerFactory
    该界面定义了一个 DataContentHandlers的工厂。
    DataHandler
    DataHandler类为许多不同来源和格式的数据提供了一致的界面。
    DataSource
    DataSource接口为JavaBean激活框架提供了任意数据集合的抽象。
    FileTypeMap
    FileTypeMap是一个抽象类，为文件提供数据输入界面。
    MimeType
    多功能Internet邮件扩展（MIME）类型，如RFC 2045和2046中所定义。
    MimeTypeParameterList
    RFC 2045和2046中定义的MimeType的参数列表。
    MimeTypeParseException
    封装MimeType解析相关异常的类。
  • Classes in javax.activation used by javax.xml.bind.attachment
    Class 描述
    DataHandler
    DataHandler类为许多不同来源和格式的数据提供了一致的界面。
  • Classes in javax.activation used by javax.xml.soap
    Class 描述
    DataHandler
    DataHandler类为许多不同来源和格式的数据提供了一致的界面。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.ActivationDataFlavor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.ActivationDataFlavor

No usage of javax.activation.ActivationDataFlavor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.CommandInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.CommandInfo

  • Packages that use CommandInfo
    软件包 描述
    javax.activation

    • Uses of CommandInfo in javax.activation

      Methods in javax.activation that return CommandInfo
      Modifier and Type 方法 描述
      abstract CommandInfo[] CommandMap.getAllCommands​(String mimeType)
      获取此类型的所有可用命令。
      CommandInfo[] CommandMap.getAllCommands​(String mimeType, DataSource ds)
      获取此类型的所有可用命令。
      CommandInfo[] DataHandler.getAllCommands​()
      返回此类型数据的所有命令。
      CommandInfo[] MailcapCommandMap.getAllCommands​(String mimeType)
      获取此MIME类型的MailcapCommandMap的此实例已知的所有mailcap文件中的所有可用命令。
      abstract CommandInfo CommandMap.getCommand​(String mimeType, String cmdName)
      获取与MIME类型相对应的默认命令。
      CommandInfo CommandMap.getCommand​(String mimeType, String cmdName, DataSource ds)
      获取与MIME类型相对应的默认命令。
      CommandInfo DataHandler.getCommand​(String cmdName)
      获取命令 cmdName 。
      CommandInfo MailcapCommandMap.getCommand​(String mimeType, String cmdName)
      获取MIME类型的 cmdName对应的命令。
      abstract CommandInfo[] CommandMap.getPreferredCommands​(String mimeType)
      从MIME类型获取首选命令列表。
      CommandInfo[] CommandMap.getPreferredCommands​(String mimeType, DataSource ds)
      从MIME类型获取首选命令列表。
      CommandInfo[] DataHandler.getPreferredCommands​()
      返回此类型数据的 首选命令。
      CommandInfo[] MailcapCommandMap.getPreferredCommands​(String mimeType)
      获取MIME类型的首选命令列表。
      Methods in javax.activation with parameters of type CommandInfo
      Modifier and Type 方法 描述
      Object DataHandler.getBean​(CommandInfo cmdinfo)
      A convenience method that takes a CommandInfo object and instantiates the corresponding command, usually a JavaBean component.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.CommandMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.CommandMap

  • Packages that use CommandMap
    软件包 描述
    javax.activation

    • Uses of CommandMap in javax.activation

      Subclasses of CommandMap in javax.activation
      Modifier and Type Class 描述
      class  MailcapCommandMap
      MailcapCommandMap扩展了CommandMap抽象类。
      Methods in javax.activation that return CommandMap
      Modifier and Type 方法 描述
      static CommandMap CommandMap.getDefaultCommandMap​()
      获取默认的CommandMap。
      Methods in javax.activation with parameters of type CommandMap
      Modifier and Type 方法 描述
      void DataHandler.setCommandMap​(CommandMap commandMap)
      设置CommandMap以供DataHandler使用。
      static void CommandMap.setDefaultCommandMap​(CommandMap commandMap)
      设置默认的CommandMap。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.DataHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.DataHandler

  • Packages that use DataHandler
    软件包 描述
    javax.activation
    javax.xml.bind.attachment
    该包由基于MIME的包处理器实现，可以在基于MIME的包格式中解释和创建优化的二进制数据。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。

    • Uses of DataHandler in javax.activation

      Methods in javax.activation with parameters of type DataHandler
      Modifier and Type 方法 描述
      Object CommandInfo.getCommandObject​(DataHandler dh, ClassLoader loader)
      返回实例化的JavaBean组件。
      void CommandObject.setCommandContext​(String verb, DataHandler dh)
      使用要处理的动词来初始化命令，以及描述将要操作的数据的DataHandler。

    • Uses of DataHandler in javax.xml.bind.attachment

      Methods in javax.xml.bind.attachment that return DataHandler
      Modifier and Type 方法 描述
      abstract DataHandler AttachmentUnmarshaller.getAttachmentAsDataHandler​(String cid)
      根据content-id查询MIME内容， cid ，并作为DataHandler返回。
      Methods in javax.xml.bind.attachment with parameters of type DataHandler
      Modifier and Type 方法 描述
      abstract String AttachmentMarshaller.addMtomAttachment​(DataHandler data, String elementNamespace, String elementLocalName)
      考虑MIME内容 data作为附件的优化二进制存储。
      abstract String AttachmentMarshaller.addSwaRefAttachment​(DataHandler data)
      添加MIME data作为附件并返回附件的content-id，cid。

    • Uses of DataHandler in javax.xml.soap

      Methods in javax.xml.soap that return DataHandler
      Modifier and Type 方法 描述
      abstract DataHandler AttachmentPart.getDataHandler​()
      获取 DataHandler对象的 AttachmentPart对象。
      Methods in javax.xml.soap with parameters of type DataHandler
      Modifier and Type 方法 描述
      AttachmentPart SOAPMessage.createAttachmentPart​(DataHandler dataHandler)
      创建一个 AttachmentPart对象，并使用给定的 DataHandler对象进行填充。
      abstract void AttachmentPart.setDataHandler​(DataHandler dataHandler)
      将给定 DataHandler对象作为此数据处理程序 AttachmentPart对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.FileDataSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.FileDataSource

No usage of javax.activation.FileDataSource
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.FileTypeMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.FileTypeMap

  • Packages that use FileTypeMap
    软件包 描述
    javax.activation

    • Uses of FileTypeMap in javax.activation

      Subclasses of FileTypeMap in javax.activation
      Modifier and Type Class 描述
      class  MimetypesFileTypeMap
      该类扩展了FileTypeMap，并通过其文件扩展名提供了文件的数据输入。
      Methods in javax.activation that return FileTypeMap
      Modifier and Type 方法 描述
      static FileTypeMap FileTypeMap.getDefaultFileTypeMap​()
      返回系统的默认FileTypeMap。
      Methods in javax.activation with parameters of type FileTypeMap
      Modifier and Type 方法 描述
      static void FileTypeMap.setDefaultFileTypeMap​(FileTypeMap fileTypeMap)
      设置系统的默认FileTypeMap。
      void FileDataSource.setFileTypeMap​(FileTypeMap map)
      将FileTypeMap设置为与此FileDataSource一起使用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.MailcapCommandMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.MailcapCommandMap

No usage of javax.activation.MailcapCommandMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.MimeType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.MimeType

  • Packages that use MimeType
    软件包 描述
    javax.activation

    • Uses of MimeType in javax.activation

      Methods in javax.activation with parameters of type MimeType
      Modifier and Type 方法 描述
      boolean MimeType.match​(MimeType type)
      Determine if the primary and sub type of this object is the same as what is in the given type.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.MimeTypeParameterList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.MimeTypeParameterList

  • Packages that use MimeTypeParameterList
    软件包 描述
    javax.activation

    • Uses of MimeTypeParameterList in javax.activation

      Methods in javax.activation that return MimeTypeParameterList
      Modifier and Type 方法 描述
      MimeTypeParameterList MimeType.getParameters​()
      Retrieve this object's parameter list.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.MimeTypeParseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.MimeTypeParseException

  • Packages that use MimeTypeParseException
    软件包 描述
    javax.activation

    • Uses of MimeTypeParseException in javax.activation

      Methods in javax.activation that throw MimeTypeParseException
      Modifier and Type 方法 描述
      boolean MimeType.match​(String rawdata)
      确定此对象的主要类型和子类型是否与rawdata中描述的内容类型相同。
      protected void MimeTypeParameterList.parse​(String parameterList)
      用于从String解析参数列表的例程。
      void MimeType.setPrimaryType​(String primary)
      将此对象的主要类型设置为给定的String。
      void MimeType.setSubType​(String sub)
      将此对象的子类型设置为给定的String。
      Constructors in javax.activation that throw MimeTypeParseException
      Constructor 描述
      MimeType​(String rawdata)
      从String构建MimeType的构造方法。
      MimeType​(String primary, String sub)
      构造函数，它使用给定的主类型和子类型构建MimeType，但具有空参数列表。
      MimeTypeParameterList​(String parameterList)
      Constructs a new MimeTypeParameterList with the passed in data.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.MimetypesFileTypeMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.MimetypesFileTypeMap

No usage of javax.activation.MimetypesFileTypeMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.UnsupportedDataTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.UnsupportedDataTypeException

No usage of javax.activation.UnsupportedDataTypeException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activation.URLDataSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activation.URLDataSource

No usage of javax.activation.URLDataSource
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.activation.CommandObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.activation.CommandObject

No usage of javax.activation.CommandObject
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.activation.DataContentHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.activation.DataContentHandler

  • Packages that use DataContentHandler
    软件包 描述
    javax.activation

    • Uses of DataContentHandler in javax.activation

      Methods in javax.activation that return DataContentHandler
      Modifier and Type 方法 描述
      abstract DataContentHandler CommandMap.createDataContentHandler​(String mimeType)
      找到与MIME类型相对应的DataContentHandler。
      DataContentHandler CommandMap.createDataContentHandler​(String mimeType, DataSource ds)
      找到与MIME类型相对应的DataContentHandler。
      DataContentHandler DataContentHandlerFactory.createDataContentHandler​(String mimeType)
      为MIME类型创建一个新的DataContentHandler对象。
      DataContentHandler MailcapCommandMap.createDataContentHandler​(String mimeType)
      返回指定MIME类型的DataContentHandler。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.activation.DataContentHandlerFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.activation.DataContentHandlerFactory

  • Packages that use DataContentHandlerFactory
    软件包 描述
    javax.activation

    • Uses of DataContentHandlerFactory in javax.activation

      Methods in javax.activation with parameters of type DataContentHandlerFactory
      Modifier and Type 方法 描述
      static void DataHandler.setDataContentHandlerFactory​(DataContentHandlerFactory newFactory)
      Sets the DataContentHandlerFactory.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.activation.DataSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.activation.DataSource

  • Packages that use DataSource
    软件包 描述
    javax.activation

    • Uses of DataSource in javax.activation

      Classes in javax.activation that implement DataSource
      Modifier and Type Class 描述
      class  FileDataSource
      FileDataSource类实现了一个封装文件的简单DataSource对象。
      class  URLDataSource
      URLDataSource类提供了一个在DataSource接口中包装一个 URL对象的对象。
      Methods in javax.activation that return DataSource
      Modifier and Type 方法 描述
      DataSource DataHandler.getDataSource​()
      返回与此DataHandler实例关联的DataSource。
      Methods in javax.activation with parameters of type DataSource
      Modifier and Type 方法 描述
      DataContentHandler CommandMap.createDataContentHandler​(String mimeType, DataSource ds)
      找到与MIME类型相对应的DataContentHandler。
      CommandInfo[] CommandMap.getAllCommands​(String mimeType, DataSource ds)
      获取此类型的所有可用命令。
      CommandInfo CommandMap.getCommand​(String mimeType, String cmdName, DataSource ds)
      获取与MIME类型相对应的默认命令。
      Object DataContentHandler.getContent​(DataSource ds)
      以最优选的形式返回表示数据的对象。
      CommandInfo[] CommandMap.getPreferredCommands​(String mimeType, DataSource ds)
      从MIME类型获取首选命令列表。
      Object DataContentHandler.getTransferData​(DataFlavor df, DataSource ds)
      返回表示要传输的数据的对象。
      Constructors in javax.activation with parameters of type DataSource
      Constructor 描述
      DataHandler​(DataSource ds)
      创建引用指定DataSource的 DataHandler实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


ActivityCompletedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.corba
软件包 javax.activity

Class ActivityCompletedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.activity.ActivityCompletedException
  • All Implemented Interfaces:
    Serializable

    public class ActivityCompletedException
extends RemoteException
    可能会在访问活动上下文的任何方法上抛出此异常，并指示活动中正在进行的工作是不可能的。 这可能是因为已经通过CompletionStatusFailOnly指示完成活动，或者由于超时而结束。 此异常将通过org.omg.CORBA.ACTIVITY_COMPLETED系统异常通过ORB边界传播。 应用程序应通过尝试完成活动来处理此错误。
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivityCompletedException​()
      构造一个具有null作为其详细消息的新实例。
      ActivityCompletedException​(String message)
      构造具有指定详细消息的新实例。
      ActivityCompletedException​(String message, Throwable cause)
      构造一个新的可抛出指定的详细信息和原因。
      ActivityCompletedException​(Throwable cause)
      构造具有指定原因的新的throwable。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ActivityCompletedException

        public ActivityCompletedException​()
        构造一个具有null作为其详细消息的新实例。

      • ActivityCompletedException

        public ActivityCompletedException​(String message)
        构造具有指定详细消息的新实例。
        参数
        message - 详细信息。

      • ActivityCompletedException

        public ActivityCompletedException​(Throwable cause)
        构造具有指定原因的新的throwable。
        参数
        cause - Throwable类型的链接异常。

      • ActivityCompletedException

        public ActivityCompletedException​(String message,
                                  Throwable cause)
        构造一个新的可抛出指定的详细信息和原因。
        参数
        message - 详细信息。
        cause - Throwable类型的链接异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ActivityRequiredException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.corba
软件包 javax.activity

Class ActivityRequiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.activity.ActivityRequiredException
  • All Implemented Interfaces:
    Serializable

    public class ActivityRequiredException
extends RemoteException
    如果活动上下文是强制性的方法未收到活动上下文，则容器将抛出此异常。 此异常表示部署或应用程序配置错误。 该异常将通过org.omg.CORBA.ACTIVITY_REQUIRED系统异常通过ORB边界传播。
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActivityRequiredException​()
      构造一个具有null作为其详细消息的新实例。
      ActivityRequiredException​(String message)
      构造具有指定详细消息的新实例。
      ActivityRequiredException​(String message, Throwable cause)
      构造一个新的可抛出指定的详细信息和原因。
      ActivityRequiredException​(Throwable cause)
      构造具有指定原因的新的throwable。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ActivityRequiredException

        public ActivityRequiredException​()
        构造一个具有null作为其详细消息的新实例。

      • ActivityRequiredException

        public ActivityRequiredException​(String message)
        构造具有指定详细消息的新实例。
        参数
        message - 详细信息。

      • ActivityRequiredException

        public ActivityRequiredException​(Throwable cause)
        构造具有指定原因的新的throwable。
        参数
        cause - Throwable类型的链接异常。

      • ActivityRequiredException

        public ActivityRequiredException​(String message,
                                 Throwable cause)
        构造一个新的可抛出指定的详细信息和原因。
        参数
        message - 详细信息。
        cause - Throwable类型的链接异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidActivityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.corba
软件包 javax.activity

Class InvalidActivityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.activity.InvalidActivityException
  • All Implemented Interfaces:
    Serializable

    public class InvalidActivityException
extends RemoteException
    可以在访问Activity上下文的任何方法上抛出此异常，并指示与尝试调用相关联的尝试调用或活动上下文与Activity的当前状态不兼容。 如果在禁止Activity上下文的方法上接收到Activity上下文，则它也可能被容器抛出。 该异常将通过org.omg.CORBA.INVALID_ACTIVITY系统异常跨越J2EE活动服务ORB边界传播。 应用程序应通过尝试完成活动来处理此错误。
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidActivityException​()
      构造一个具有null作为其详细消息的新实例。
      InvalidActivityException​(String message)
      构造具有指定详细消息的新实例。
      InvalidActivityException​(String message, Throwable cause)
      构造一个新的可抛出指定的详细信息和原因。
      InvalidActivityException​(Throwable cause)
      构造具有指定原因的新的throwable。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidActivityException

        public InvalidActivityException​()
        构造一个具有null作为其详细消息的新实例。

      • InvalidActivityException

        public InvalidActivityException​(String message)
        构造具有指定详细消息的新实例。
        参数
        message - 详细信息。

      • InvalidActivityException

        public InvalidActivityException​(Throwable cause)
        构造具有指定原因的新的throwable。
        参数
        cause - Throwable类型的链接异常。

      • InvalidActivityException

        public InvalidActivityException​(String message,
                                Throwable cause)
        构造一个新的可抛出指定的详细信息和原因。
        参数
        message - 详细信息。
        cause - Throwable类型的链接异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.activity (Java SE 9 & JDK 9 )

javax.activity

Exceptions

  • ActivityCompletedException
  • ActivityRequiredException
  • InvalidActivityException


javax.activity (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.corba

Package javax.activity

包含ORB机械在解组时抛出的活动服务相关异常。
从以下版本开始：
1.5
  • 异常摘要
    异常 描述
    ActivityCompletedException
    可能会在访问活动上下文的任何方法上抛出此异常，并指示活动中正在进行的工作是不可能的。
    ActivityRequiredException
    如果活动上下文是强制性的方法未收到活动上下文，则容器将抛出此异常。
    InvalidActivityException
    可以在访问Activity上下文的任何方法上抛出此异常，并指示与尝试调用相关联的尝试调用或活动上下文与Activity的当前状态不兼容。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.activity Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.activity

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.activity.ActivityCompletedException
            • javax.activity.ActivityRequiredException
            • javax.activity.InvalidActivityException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package javax.activity (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.activity

No usage of javax.activity
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activity.ActivityCompletedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activity.ActivityCompletedException

No usage of javax.activity.ActivityCompletedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activity.ActivityRequiredException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activity.ActivityRequiredException

No usage of javax.activity.ActivityRequiredException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.activity.InvalidActivityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.activity.InvalidActivityException

No usage of javax.activity.InvalidActivityException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Generated (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws.annotation
软件包 javax.annotation

Annotation Type Generated

  • @Documented
@Retention(SOURCE)
@Target({PACKAGE,TYPE,ANNOTATION_TYPE,METHOD,CONSTRUCTOR,字段,LOCAL_VARIABLE,PARAMETER})
public @interface Generated
    生成的注释用于标记已生成的源代码。 它也可以用于在单个文件中区分用户编写的代码和生成的代码。 使用时，值元素必须具有代码生成器的名称。 推荐的约定是在值字段中使用代码生成器的完全限定名称。

    例如：com.company.package.classname。 date元素用于指示源生成的日期。 日期元素必须遵循ISO 8601标准。 例如，date元素将具有以下值2001-07-04T12：08：56.235-0700，表示美国太平洋时间时区的当地时间2001-07-04 12:08:56。

    comment元素是代码生成器可能希望包含在生成的代码中的任何注释的占位符。

    从以下版本开始：
    1.6，通用注释1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String[] value
      值元素必须具有代码生成器的名称。

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      String comments
      代码生成器可能希望包含在生成的代码中的任何注释的占位符。
      String date
      生成源的日期

    • Element Detail

      • value

        String[] value
        值元素必须具有代码生成器的名称。 推荐的惯例是使用代码生成器的完全限定名称。 例如：com.acme.generator.CodeGen。

      • date

        String date
        生成源的日期
        Default:
        “”

      • comments

        String comments
        代码生成器可能希望包含在生成的代码中的任何注释的占位符。
        Default:
        “”
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


javax.annotation (Java SE 9 & JDK 9 )

javax.annotation

Enums

  • Resource.AuthenticationType

注解类型

  • Generated
  • PostConstruct
  • PreDestroy
  • Resource
  • Resources


javax.annotation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.xml.ws.annotation

Package javax.annotation

  • 枚举摘要
    Enum 描述
    Resource.AuthenticationType
    资源的两种可能的认证类型。
  • 注解类型摘要
    Annotation Type 描述
    Generated
    生成的注释用于标记已生成的源代码。
    PostConstruct
    PostConstruct注释用于需要执行相关性注入后执行任何初始化的方法。
    PreDestroy
    PreDestroy注释在方法上用作回调通知，表明实例正在被容器移除。
    Resource
    资源注释标记应用程序需要的资源。
    Resources
    此类用于允许多个资源声明。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.annotation Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.annotation

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.annotation.Generated (implements java.lang.annotation.Annotation)
  • javax.annotation.PostConstruct (implements java.lang.annotation.Annotation)
  • javax.annotation.PreDestroy (implements java.lang.annotation.Annotation)
  • javax.annotation.Resource (implements java.lang.annotation.Annotation)
  • javax.annotation.Resources (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.annotation.Resource.AuthenticationType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


PostConstruct (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws.annotation
软件包 javax.annotation

Annotation Type PostConstruct

  • @Documented
@Retention(RUNTIME)
@Target(METHOD)
public @interface PostConstruct
    PostConstruct注释用于需要执行相关性注入后执行任何初始化的方法。 必须在该类投入使用之前调用此方法。 必须在支持依赖注入的所有类上支持此注释。 即使该类不请求任何注入的资源，也必须调用PostConstruct注释的方法。 只有一种方法可以使用此注释进行注释。 应用PostConstruct注释的方法必须满足以下所有条件：
    • 除了拦截器的情况下，该方法必须不具有任何参数，在这种情况下，它将接受由Interceptor规范定义的InvocationContext对象。
    • 在拦截器类上定义的方法必须具有以下签名之一：

      void <METHOD>（InvocationContext）

      Object <METHOD>（InvocationContext）抛出异常

      注意：PostConstruct拦截器方法不能抛出应用程序异常，但是除了生命周期事件之外，如果相同的拦截器方法在业务或超时方法上插入，则它可能被声明为抛出检查的异常，包括java.lang.Exception。 如果PostConstruct拦截器方法返回值，容器将被忽略。

    • 在非拦截器类上定义的方法必须具有以下签名：

      void <METHOD>（）

    • PostConstruct应用的方法可以是public，protected，private或private。
    • 除了应用程序客户端，该方法绝对不是静态的。
    • 该方法可能是最终的。
    • 如果该方法抛出一个未经检查的异常，则该类绝不能投入使用，除非EJB可以处理异常甚至从它们恢复。
    从以下版本开始：
    1.6，通用注释1.0
    另请参见：
    PreDestroy ， Resource
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


PreDestroy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws.annotation
软件包 javax.annotation

Annotation Type PreDestroy

  • @Documented
@Retention(RUNTIME)
@Target(METHOD)
public @interface PreDestroy
    PreDestroy注释在方法上用作回调通知，表明实例正在被容器移除。 通过PreDestroy注释的方法通常用于释放其持有的资源。 除了Java EE 5中的应用程序客户端容器之外，所有支持PostConstruct的容器管理对象必须支持此注释。应用PreDestroy注释的方法必须满足以下所有条件：
    • 除了拦截器的情况下，该方法必须不具有任何参数，在这种情况下，它将接受由Interceptor规范定义的InvocationContext对象。
    • 在拦截器类上定义的方法必须具有以下签名之一：

      void <METHOD>（InvocationContext）

      Object <METHOD>（InvocationContext）抛出异常

      注意：PreDestroy拦截器方法不能抛出应用程序异常，但是除了生命周期事件之外，如果相同的拦截器方法在业务或超时方法上插入，则可能会声明抛出检查的异常，包括java.lang.Exception。 如果PreDestroy拦截器方法返回一个值，容器将被忽略。

    • 在非拦截器类上定义的方法必须具有以下签名：

      void <METHOD>（）

    • PreDestroy应用的方法可能是公共的，受保护的，私有的或私有的。
    • 该方法不能是静态的。
    • 该方法可能是最终的。
    • 如果该方法抛出未经检查的异常，则忽略它，除非EJB可以处理异常的EJB。
    从以下版本开始：
    1.6，通用注释1.0
    另请参见：
    PostConstruct ， Resource
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


Resource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws.annotation
软件包 javax.annotation

Annotation Type Resource

  • @Target({TYPE,字段,METHOD})
@Retention(RUNTIME)
public @interface Resource
    资源注释标记应用程序需要的资源。 该注释可以应用于应用程序组件类，或者应用于组件类的字段或方法。 当注释应用于字段或方法时，容器将在初始化组件时将所请求资源的实例注入到应用程序组件中。 如果注释应用于组件类，则注释声明应用程序将在运行时查找的资源。

    即使此注释未标记为继承，需要部署工具来检查任何组件类的所有超类，以便在所有超类中发现此注释的所有用途。 所有这些注释实例都指定应用程序组件所需的资源。 请注意，此注释可能会显示在专用字段和超类的方法上; 在这些情况下，容器也需要进行注射。

    从以下版本开始：
    1.6，通用注释1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      Resource.AuthenticationType authenticationType
      用于此资源的身份验证类型。
      String description
      该资源的描述。
      String lookup
      引用指向的资源的名称。
      String mappedName
      该资源应映射到的产品特定名称。
      String name
      资源的JNDI名称。
      boolean shareable
      指示此资源是否可以在此组件与其他组件之间共享。
      Class<?> type
      资源的Java类型。

    • Element Detail

      • name

        String name
        资源的JNDI名称。 对于字段注释，默认值为字段名称。 对于方法注释，默认值为与该方法对应的JavaBeans属性名称。 对于类注释，没有默认值，必须指定。
        Default:
        “”

      • lookup

        String lookup
        引用指向的资源的名称。 它可以使用全局JNDI名称链接到任何兼容的资源。
        从以下版本开始：
        1.7，常见注释1.1
        Default:
        “”

      • type

        Class<?> type
        资源的Java类型。 对于字段注释，默认值是字段的类型。 对于方法注释，默认值是JavaBeans属性的类型。 对于类注释，没有默认值，必须指定。
        Default:
        java.lang.Object.class

      • authenticationType

        Resource.AuthenticationType authenticationType
        用于此资源的身份验证类型。 可以为表示任何支持类型的连接工厂的资源指定这一点，不能为其他类型的资源指定。
        Default:
        javax.annotation.Resource.AuthenticationType.CONTAINER

      • shareable

        boolean shareable
        指示此资源是否可以在此组件与其他组件之间共享。 可以为表示任何支持类型的连接工厂的资源指定这一点，不能为其他类型的资源指定。
        Default:
        真正

      • mappedName

        String mappedName
        该资源应映射到的产品特定名称。 该资源的名称（由name元素定义或默认值）是使用该资源的应用程序组件本地的名称。 （它是JNDI java:comp/env命名空间中的一个名称。）许多应用程序服务器提供了一种将这些本地名称映射到应用程序服务器已知的资源名称的方法。 此映射名称通常是全局 JNDI名称，但可以是任何形式的名称。

        应用程序服务器不需要支持任何特定形式或类型的映射名称，也不支持使用映射名称的功能。 映射名称取决于产品，通常依赖于安装。 不使用映射名称是可移植的。

        Default:
        “”

      • description

        String description
        该资源的描述。 该描述预期是部署应用程序的系统的默认语言。 该描述可以提供给部署者以帮助选择正确的资源。
        Default:
        “”
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


Resource.AuthenticationType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.xml.ws.annotation
软件包 javax.annotation

Enum Resource.AuthenticationType

  • java.lang.Object
    • java.lang.Enum<Resource.AuthenticationType>
      • javax.annotation.Resource.AuthenticationType
  • All Implemented Interfaces:
    Serializable ， Comparable<Resource.AuthenticationType>
    Enclosing class:
    Resource

    public static enum Resource.AuthenticationType
extends Enum<Resource.AuthenticationType>
    资源的两种可能的认证类型。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APPLICATION
      CONTAINER

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Resource.AuthenticationType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Resource.AuthenticationType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONTAINER

        public static final Resource.AuthenticationType CONTAINER

      • APPLICATION

        public static final Resource.AuthenticationType APPLICATION

    • 方法详细信息

      • values

        public static Resource.AuthenticationType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Resource.AuthenticationType c : Resource.AuthenticationType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Resource.AuthenticationType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


Resources (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws.annotation
软件包 javax.annotation

Annotation Type Resources

  • @Documented
@Retention(RUNTIME)
@Target(TYPE)
public @interface Resources
    此类用于允许多个资源声明。
    从以下版本开始：
    1.6，通用注释1.0
    另请参见：
    Resource

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      Resource[] value
      用于多个资源声明的数组。

    • Element Detail

      • value

        Resource[] value
        用于多个资源声明的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


Uses of Package javax.annotation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.annotation

  • Packages that use javax.annotation
    软件包 描述
    javax.annotation
  • Classes in javax.annotation used by javax.annotation
    Class 描述
    Resource.AuthenticationType
    The two possible authentication types for a resource.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.Generated (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.Generated

No usage of javax.annotation.Generated
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.PostConstruct (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.PostConstruct

No usage of javax.annotation.PostConstruct
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.PreDestroy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.PreDestroy

No usage of javax.annotation.PreDestroy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.Resource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.Resource

No usage of javax.annotation.Resource
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.Resource.AuthenticationType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.Resource.AuthenticationType

  • Packages that use Resource.AuthenticationType
    软件包 描述
    javax.annotation

    • Uses of Resource.AuthenticationType in javax.annotation

      Methods in javax.annotation that return Resource.AuthenticationType
      Modifier and Type 方法 描述
      static Resource.AuthenticationType Resource.AuthenticationType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Resource.AuthenticationType[] Resource.AuthenticationType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.Resources (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.Resources

No usage of javax.annotation.Resources
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AbstractProcessor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.annotation.processing

Class AbstractProcessor

  • java.lang.Object
    • javax.annotation.processing.AbstractProcessor
  • All Implemented Interfaces:
    Processor

    public abstract class AbstractProcessor
extends Object
implements Processor
    一个抽象的注释处理器，被设计为大多数具体注解处理器的一个方便的超类。 此类检查注释值来计算options ， annotation types ，并source version其亚型支持。

    吸气剂方法可以用issue warnings关于在处理器已经被使用之后可用的设施的值得注意的条件是initialized 。

    子类可以覆盖该类中任何方法的实现和规范，只要符合该方法的一般Processor合同即可。

    从以下版本开始：
    1.6

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected ProcessingEnvironment processingEnv
      由工具框架提供的处理环境。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractProcessor​()
      调用子类的构造方法。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Iterable<? extends Completion> getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回一个空的可迭代的完成。
      Set<String> getSupportedAnnotationTypes​()
      如果使用SupportedAnnotationTypes注释处理器类，则返回与注释具有相同字符串集的不可修改集。
      Set<String> getSupportedOptions​()
      如果处理器类注释为SupportedOptions ，则返回一个不可修改的集合，该集合与注释具有相同的字符串集。
      SourceVersion getSupportedSourceVersion​()
      如果处理器类注释为SupportedSourceVersion ，则返回注释中的源版本。
      void init​(ProcessingEnvironment processingEnv)
      通过将 processingEnv字段设置为 processingEnv参数的值，通过处理环境初始化处理器。
      protected boolean isInitialized​()
      返回 true如果该对象已 initialized ， false否则。
      abstract boolean process​(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv)
      对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • processingEnv

        protected ProcessingEnvironment processingEnv
        由工具框架提供的处理环境。

    • 构造方法详细信息

      • AbstractProcessor

        protected AbstractProcessor​()
        调用子类的构造方法。

    • 方法详细信息

      • getSupportedOptions

        public Set<String> getSupportedOptions​()
        如果使用SupportedOptions注释处理器类，则返回与注释具有相同字符串集的不可修改集合。 如果类没有这样注释，则返回一个空集合。
        Specified by:
        getSupportedOptions在接口 Processor
        结果
        该处理器识别的选项，如果没有，则为空集
        另请参见：
        SupportedOptions

      • getSupportedAnnotationTypes

        public Set<String> getSupportedAnnotationTypes​()
        如果使用SupportedAnnotationTypes注释处理器类，则返回与注释具有相同字符串集的不可修改集。 如果类没有这样注释，则返回一个空集合。 如果source version不支持模块，换句话说，如果它小于或等于RELEASE_8 ，则任何前导的module prefixes都将从名称中删除。
        Specified by:
        getSupportedAnnotationTypes接口 Processor
        结果
        该处理器支持的注释类型的名称，如果没有，则为空集
        另请参见：
        SupportedAnnotationTypes

      • getSupportedSourceVersion

        public SourceVersion getSupportedSourceVersion​()
        如果处理器类注释为SupportedSourceVersion ，则返回注释中的源版本。 如果类没有这样注释，则返回SourceVersion.RELEASE_6 。
        Specified by:
        getSupportedSourceVersion在接口 Processor
        结果
        该处理器支持的最新的源版本
        另请参见：
        SupportedSourceVersion ， ProcessingEnvironment.getSourceVersion()

      • init

        public void init​(ProcessingEnvironment processingEnv)
        通过将processingEnv字段设置为processingEnv参数的值，通过处理环境初始化处理器。 如果在同一对象上多次调用此方法，则将抛出IllegalStateException 。
        Specified by:
        init接口 Processor
        参数
        processingEnv - 工具框架向处理器提供访问环境的环境
        异常
        IllegalStateException - 如果这个方法被调用不止一次。

      • process

        public abstract boolean process​(Set<? extends TypeElement> annotations,
                                RoundEnvironment roundEnv)
        对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。 如果返回true ，则会声明注释类型，并且不会要求后续处理器处理它们; 如果返回false ，注释类型是无人认领的，并且可能要求后续处理器处理它们。 处理器可以总是返回相同的布尔值，或者可以根据其自己选择的标准来改变结果。

        如果处理器支持"*"并且根元素没有注释，输入集将为空。 A Processor必须优雅地处理一组空的注释。

        Specified by:
        process在接口 Processor
        参数
        annotations - 请求处理的注释类型
        roundEnv - 有关当前和前一轮的信息的环境
        结果
        该处理器是否声明该组注释类型

      • getCompletions

        public Iterable<? extends Completion> getCompletions​(Element element,
                                                     AnnotationMirror annotation,
                                                     ExecutableElement member,
                                                     String userText)
        返回一个空的可迭代的完成。
        Specified by:
        getCompletions在接口 Processor
        参数
        element - 要注释的元素
        annotation - （可能是部分的）注释被应用于元素
        member - 注释成员返回可能的完成
        userText - 要完成的源代码文本
        结果
        建议完成注释

      • isInitialized

        protected boolean isInitialized​()
        返回 true如果该对象已 initialized ， false否则。
        结果
        true如果此对象已初始化，否则为 false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Completion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.annotation.processing

Interface Completion

  • public interface Completion
    A建议completion用于注释。 完成是作为注释的一部分插入到程序中的文本。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getMessage​()
      返回有关完成的信息性消息。
      String getValue​()
      返回建议完成的文本。

    • 方法详细信息

      • getValue

        String getValue​()
        返回建议完成的文本。
        结果
        建议完成的文字。

      • getMessage

        String getMessage​()
        返回有关完成的信息性消息。
        结果
        关于完成的信息性消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Completions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.annotation.processing

Class Completions

  • java.lang.Object
    • javax.annotation.processing.Completions

  • public class Completions
extends Object
    组装Completion对象的实用类。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Completion of​(String value)
      返回值的完成和空消息
      static Completion of​(String value, String message)
      返回值和消息的完成。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • of

        public static Completion of​(String value,
                            String message)
        返回值和消息的完成。
        参数
        value - 完成的文本
        message - 有关完成的消息
        结果
        完成提供的价值和信息

      • of

        public static Completion of​(String value)
        返回值的完成和空消息
        参数
        value - 完成的文字
        结果
        一个完成的值和一个空的消息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Filer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.annotation.processing

Interface Filer

  • public interface Filer
    该接口支持通过注释处理器创建新文件。 以这种方式创建的文件将通过实现此界面的注释处理工具知道，更好地使工具能够管理它们。 这样创建的源和类文件将由27072964482488的工具在round of processing之后的close方法被调用在Writer或OutputStream用于写入文件的内容。 区分三种文件：源文件，类文件和辅助资源文件。

    有两个不同的支持位置（逻辑文件系统中的子树），其中放置了新创建的文件：一个用于new source files ，一个用于new class files 。 （这些可能在工具的命令行上指定，例如使用诸如-s和-d标志。）新的源文件和新类文件的实际位置在该工具的特定运行中可能是或不是不同的。 可以在任一位置创建资源文件。 资源的读写方法采用相对名称参数。 相对名称是由'/'分隔的非空，非空序列的路径段。 '.'和'..'是无效路径段。 有效的相对名称必须与“无路径”的规则匹配 ，即RFC 3986 ，第3.3节。

    文件创建方法采用可变数量的参数，以允许将源元素作为工具基础设施的提示来提供更好的管理依赖关系。 发起元素是引起注释处理器尝试创建新文件的类型或包（代表package-info文件）或模块（代表module-info文件）。 例如，如果注释处理器尝试创建源文件（ GeneratedFromUserSource ）以响应处理

      @Generate
  public class UserSource {}
    UserSource的类型元素应作为创建方法调用的一部分传递，如：
          filer.createSourceFile("GeneratedFromUserSource",
                             eltUtils.getTypeElement("UserSource"));
    如果没有原始元素，则不需要通过。 该信息可以在增量环境中使用，以确定需要重新运行处理器或删除生成的文件。 非增量环境可以忽略始发元素信息。

    在每次运行注释处理工具期间，只能创建一个具有给定路径名的文件。 如果该文件在首次尝试创建之前已经存在，则旧的内容将被删除。 任何后续尝试在运行期间创建相同的文件将会抛出一个FilerException ，同时也将尝试为相同类型的名称或相同的包名称创建类文件和源文件。 该工具的initial inputs被认为是由第零轮创造的; 因此，尝试创建与其中一个输入对应的源文件或类文件将导致一个FilerException 。

    一般来说，处理器不得有意试图覆盖某些处理器未生成的现有文件。 A Filer可能会拒绝尝试打开与现有类型相对应的文件，如java.lang.Object 。 同样，注释处理工具的调用者也不得故意地配置工具，使得发现的处理器将尝试覆盖未生成的现有文件。

    如果环境配置为使得该类型可访问，则处理器可以指示通过包括javax.annotation.Generated注释来生成源文件或类文件。

    API Note:
    覆盖文件的一些效果可以通过使用装饰器样式来实现。 不是直接修改类，而是设计类，以便通过注释处理生成其超类，或者通过注释处理生成类的子类。 如果生成子类，则可以将父类设计为使用工厂而不是公共构造函数，以便仅将子类实例提供给父类的客户端。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      JavaFileObject createClassFile​(CharSequence name, Element... originatingElements)
      创建一个新的类文件，并返回一个对象以允许写入它。
      FileObject createResource​(JavaFileManager.Location location, CharSequence moduleAndPkg, CharSequence relativeName, Element... originatingElements)
      创建一个新的辅助资源文件进行写入并返回一个文件对象。
      JavaFileObject createSourceFile​(CharSequence name, Element... originatingElements)
      创建一个新的源文件并返回一个对象以允许写入它。
      FileObject getResource​(JavaFileManager.Location location, CharSequence moduleAndPkg, CharSequence relativeName)
      返回一个读取现有资源的对象。

    • 方法详细信息

      • createSourceFile

        JavaFileObject createSourceFile​(CharSequence name,
                                Element... originatingElements)
                         throws IOException
        创建一个新的源文件并返回一个对象以允许写入它。 可以创建类型的源文件或包。 文件的名称和路径（相对于root output location for source files ）基于要在该文件中声明的项目的名称以及项目的指定模块（如果有）。 如果在单个文件（即单个编译单元）中声明了多个类型，则该文件的名称应对应于主体顶级类型的名称（例如公共的）。

        还可以创建源文件来保存有关包的信息，包括包注释。 要为命名包创建源文件，请将name参数作为包的名称，后跟".package-info" ; 要创建一个未命名包的源文件，请使用"package-info" 。

        可选模块名称前缀为类型名称或包名称，并使用“ / ”字符分隔。 例如，为了创建用于类型源文件a.B在模块foo ，使用name的论点"foo/a.B" 。

        如果没有给出明确的模块前缀，并且在环境中支持模块，则推断出合适的模块。 如果一个合适的模块不能被推断FilerException被抛出。 实现可以使用关于注释处理工具的配置的信息作为推断的一部分。

        不支持在命名模块中为未命名的软件包创建源文件。

        API Note:
        使用特定charset来编码文件的内容，一个OutputStreamWriter与所选择的字符集可以从所创建的OutputStream从返回的对象。 如果从返回对象的Writer直接用于写入，则其字符集由实现确定。 注释处理工具可能有一个-encoding标志或类似选项用于指定此; 否则，它通常将是平台的默认编码。

        为了避免后续的错误，源文件的内容应与用于此运行的source version兼容。

        Implementation Note:
        在参考实现中，如果注释处理工具正在处理单个模块M ，则M被用作在没有显式模块前缀的情况下创建的文件的模块。 如果该工具正在处理多个模块，而Elements.getPackageElement(package-of(name))返回一个软件包，则拥有返回软件包的模块将用作目标模块。 如果不能使用上述规则确定，则可以使用单独的选项来提供目标模块。
        参数
        name - 在此文件中声明的主体类型的规范（完全限定）名称或包信息文件后跟 ".package-info"的包名称
        originatingElements - 与此文件创建有关的类型或包或模块元素可能会被删除或 null
        结果
        一个 JavaFileObject写新的源文件
        异常
        FilerException - 如果已经创建了相同的路径名，则已经创建了相同的类型，如果目标模块不可写，则该名称对于被请求创建的实体无效，如果目标模块不可写，或者当环境不支持模块时指定一个模块。
        IOException - 如果无法创建该文件
        See The Java™ Language Specification:
        7.3编译单位

      • createClassFile

        JavaFileObject createClassFile​(CharSequence name,
                               Element... originatingElements)
                        throws IOException
        创建一个新的类文件，并返回一个对象以允许写入它。 可以创建类型的类文件或包。 文件的名称和路径（相对于root output location for class files ）基于要声明的项目的名称以及项目的指定模块（如果有）。

        也可以创建一个类文件来保存有关包的信息，包括包注释。 要为命名包创建一个类文件，请将name参数作为包的名称，后跟".package-info" ; 不支持为未命名的包创建类文件。

        可选模块名称以类型名称或包名称为前缀，并使用“ / ”字符分隔。 例如，要在模块foo为类型a.B创建类文件，请使用name参数"foo/a.B" 。

        如果没有给出明确的模块前缀，并且在环境中支持模块，则推断出合适的模块。 如果一个合适的模块不能被推断FilerException被抛出。 实现可以使用关于注释处理工具的配置的信息作为推断的一部分。

        不支持在命名模块中为未命名的包创建类文件。

        API Note:
        为了避免后续的错误，类文件的内容应与用于此运行的 source version兼容。
        Implementation Note:
        在参考实现中，如果注释处理工具正在处理单个模块M ，则M被用作在没有显式模块前缀的情况下创建的文件的模块。 如果该工具正在处理多个模块，而Elements.getPackageElement(package-of(name))返回一个软件包，则拥有返回软件包的模块将用作目标模块。 如果不能使用上述规则确定，则可以使用单独的选项来提供目标模块。
        参数
        name - 要编写的类型的二进制名称或包信息文件后跟 ".package-info"的包名称
        originatingElements - 与此文件的创建有关的类型或包或模块元素可能会被删除或 null
        结果
        一个 JavaFileObject写新的类文件
        异常
        FilerException - 如果已经创建了相同的路径名，则已经创建了相同的类型，如果目标模块不可写，或者指定模块时，该名称对于类型无效，如果目标模块无法确定环境不支持模块。
        IOException - 如果无法创建该文件

      • createResource

        FileObject createResource​(JavaFileManager.Location location,
                          CharSequence moduleAndPkg,
                          CharSequence relativeName,
                          Element... originatingElements)
                   throws IOException
        创建一个新的辅助资源文件进行写入并返回一个文件对象。 该文件可能与新创建的源文件，新创建的二进制文件或其他支持的位置一起定位。 必须支持位置CLASS_OUTPUT和SOURCE_OUTPUT 。 该资源可以相对于某些模块和/或包（源和类文件）以及相对路径名从其中命名。 在宽松的意义上说，新文件的全名是串接location ， moduleAndPkg ，并relativeName 。 如果moduleAndPkg包含“ / ”字样，“前的前缀/ ”字就是模块名和后缀后的“ / ”字是软件包的名称。 软件包后缀可能为空。 如果moduleAndPkg不包含“ / ”字符，则整个参数将被解释为包名称。

        如果给定的位置既不是module oriented location也不是output location containing multiple modules ，并且给出了显式模块前缀，则抛出FilerException 。

        如果给定位置是面向模块的位置，或者包含多个模块的输出位置，并且没有给出明确的模块前缀，则推断出合适的模块。 如果一个合适的模块不能被推断FilerException被抛出。 实现可以使用关于注释处理工具的配置的信息作为推断的一部分。

        即使文件的完整路径名对应于新的源文件或新类文件的完整路径名，也不会通过此方法创建的文件进行注释处理。

        Implementation Note:
        在参考实现中，如果注释处理工具正在处理单个模块M ，则M被用作在没有显式模块前缀的情况下创建的文件的模块。 如果工具正在处理多个模块，并Elements.getPackageElement(package-of(name))返回一包，拥有该返回包模块被用作目标模块。 如果不能使用上述规则确定，则可以使用单独的选项来提供目标模块。
        参数
        location - 新文件的位置
        moduleAndPkg - 相对于该文件应该命名的模块和/或包，或空字符串，如果没有
        relativeName - 文件的最终路径名组件
        originatingElements - 与此文件创建有关的类型或包或模块元素可能会被删除或 null
        结果
        一个 FileObject写新的资源
        异常
        IOException - 如果无法创建该文件
        FilerException - 如果已经创建了相同的路径名，如果目标模块无法确定，或者目标模块不可写，或者是否指定了明确的目标模块，并且该位置不支持它。
        IllegalArgumentException - 对于不受支持的位置
        IllegalArgumentException - 如果 moduleAndPkg是 moduleAndPkg
        IllegalArgumentException - 如果 relativeName不是相对的

      • getResource

        FileObject getResource​(JavaFileManager.Location location,
                       CharSequence moduleAndPkg,
                       CharSequence relativeName)
                throws IOException
        返回一个读取现有资源的对象。 必须支持位置CLASS_OUTPUT和SOURCE_OUTPUT 。

        如果moduleAndPkg包含“ / ”字样，“前的前缀/ ”字就是模块名和后缀后的“ / ”字是软件包的名称。 包后缀可能为空; 但是，如果存在模块名称，那么它必须是非空的。 如果moduleAndPkg不包含“ / ”字符，则整个参数将被解释为包名称。

        如果给定位置既不是module oriented location ，也不是output location containing multiple modules ，并且给出了显式模块前缀，则抛出FilerException 。

        如果给定位置是面向模块的位置，或者包含多个模块的输出位置，并且没有给出明确的模块前缀，则推断出合适的模块。 如果一个合适的模块不能被推断FilerException被抛出。 实现可以使用关于注释处理工具的配置的信息作为推断的一部分。

        Implementation Note:
        在参考实现中，如果注释处理工具正在处理单个模块M ，则M被用作在没有显式模块前缀的情况下读取的文件的模块。 如果该工具正在处理多个模块，而Elements.getPackageElement(package-of(name))返回一个软件包，则拥有返回软件包的模块将用作源模块。 如果不能使用上述规则确定，则可以使用单独的选项来提供目标模块。
        参数
        location - 文件的位置
        moduleAndPkg - 应该搜索文件的模块和/或包，或空字符串，如果没有
        relativeName - 文件的最终路径名组件
        结果
        一个读取文件的对象
        异常
        FilerException - 如果相同的路径名已经被打开用于写入，如果源模块不能被确定，或者目标模块不可写，或者是否指定了明确的目标模块，并且该位置不支持它。
        IOException - 如果文件无法打开
        IllegalArgumentException - 对于不受支持的位置
        IllegalArgumentException - 如果 moduleAndPkg是 moduleAndPkg
        IllegalArgumentException - 如果 relativeName不是相对的
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FilerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.annotation.processing

Class FilerException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.annotation.processing.FilerException
  • All Implemented Interfaces:
    Serializable

    public class FilerException
extends IOException
    表示Filer检测到尝试打开违反Filer提供的担保的Filer 。 这些保证包括不要多次创建相同的文件，而不是创建与同一类型或程序包相对应的多个文件，而不是为具有无效名称的类型创建文件。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FilerException​(String s)
      使用指定的详细消息构造异常。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FilerException

        public FilerException​(String s)
        使用指定的详细消息构造异常。
        参数
        s - the detail message, which should include the name of the file attempting to be opened; may be null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Generated (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.compiler
软件包 javax.annotation.processing

Annotation Type Generated

  • @Documented
@Retention(SOURCE)
@Target({PACKAGE,TYPE,METHOD,CONSTRUCTOR,字段,LOCAL_VARIABLE,PARAMETER})
public @interface Generated
    生成的注释用于标记已生成的源代码。 它也可以用于在单个文件中区分用户编写的代码和生成的代码。

    例子：

      @Generated("com.example.Generator")
      @Generated(value="com.example.Generator", date= "2017-07-04T12:08:56.235-0700")
      @Generated(value="com.example.Generator", date= "2017-07-04T12:08:56.235-0700",
      comments= "comment 1")
    从以下版本开始：
    9

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String[] value
      值元素必须具有代码生成器的名称。

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      String comments
      代码生成器可能希望包含在生成的代码中的任何注释的占位符。
      String date
      生成源的日期

    • Element Detail

      • value

        String[] value
        值元素必须具有代码生成器的名称。 名称是代码生成器的完全限定名称。
        结果
        代码生成器的名称

      • date

        String date
        生成源的日期 日期元素必须遵循ISO 8601标准。 例如，date元素将具有以下值2017-07-04T12：08：56.235-0700，其代表2017-07-04 12:08:56当地时间在美国太平洋时间时区。
        结果
        生成源的日期
        Default:
        “”

      • comments

        String comments
        代码生成器可能希望包含在生成的代码中的任何注释的占位符。
        结果
        注释生成的代码包括
        Default:
        ""
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


javax.annotation.processing (Java SE 9 & JDK 9 )

javax.annotation.processing

Interfaces

  • Completion
  • Filer
  • Messager
  • ProcessingEnvironment
  • Processor
  • RoundEnvironment

Classes

  • AbstractProcessor
  • Completions

Exceptions

  • FilerException

注解类型

  • Generated
  • SupportedAnnotationTypes
  • SupportedOptions
  • SupportedSourceVersion


javax.annotation.processing (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.compiler

Package javax.annotation.processing

用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。

除非在特定实现中另有规定，否则应该预期此程序包中方法返回的集合将被调用者不可修改，并且对并发访问是不安全的。

除非另有说明，如果给出一个null参数，该包中的方法将抛出一个NullPointerException 。

从以下版本开始：
1.6
  • 接口摘要
    接口 描述
    Completion
    A建议 completion用于注释。
    Filer
    该接口支持通过注释处理器创建新文件。
    Messager
    A Messager为注释处理器提供报告错误消息，警告和其他通知的方式。
    ProcessingEnvironment
    注释处理工具框架将为 provide an annotation processor with an object implementing this interface，因此处理器可以使用框架提供的工具来编写新文件，报告错误消息和查找其他实用程序。
    Processor
    注释处理器的界面。
    RoundEnvironment
    注释处理工具框架将为 provide an annotation processor with an object implementing this interface ，使得处理器可以查询关于一轮注释处理的信息。
  • 类摘要
    Class 描述
    AbstractProcessor
    一个抽象的注释处理器，被设计为大多数具体注解处理器的一个方便的超类。
    Completions
    组装Completion对象的实用类。
  • 异常摘要
    异常 描述
    FilerException
    表示Filer检测到尝试打开将违反Filer提供的担保的Filer 。
  • 注解类型摘要
    Annotation Type 描述
    Generated
    生成的注释用于标记已生成的源代码。
    SupportedAnnotationTypes
    用于指示注释处理器支持的注释类型的注释。
    SupportedOptions
    用于指示注释处理器支持哪些选项的注释。
    SupportedSourceVersion
    用于指示注释处理器支持的最新源版本的注释。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.annotation.processing Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.annotation.processing

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.annotation.processing.AbstractProcessor (implements javax.annotation.processing.Processor)
    • javax.annotation.processing.Completions
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • javax.annotation.processing.FilerException

Interface Hierarchy

  • javax.annotation.processing.Completion
  • javax.annotation.processing.Filer
  • javax.annotation.processing.Messager
  • javax.annotation.processing.ProcessingEnvironment
  • javax.annotation.processing.Processor
  • javax.annotation.processing.RoundEnvironment

Annotation Type Hierarchy

  • javax.annotation.processing.Generated (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedAnnotationTypes (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedOptions (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedSourceVersion (implements java.lang.annotation.Annotation)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Messager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.annotation.processing

Interface Messager

  • public interface Messager
    A Messager为注释处理器提供报告错误消息，警告和其他通知的方式。 可以传递元素，注释和注释值以提供消息的位置提示。 但是，这样的位置提示可能不可用或只是近似。

    打印邮件error kind将raise an error 。

    请注意，通过此界面中的方法“打印”的消息可能显示为也可能不会显示为像System.out或System.err这样的位置的文本输出。 实现可以选择以不同的方式呈现这些信息，例如窗口中的消息。

    从以下版本开始：
    1.6
    另请参见：
    ProcessingEnvironment.getLocale()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void printMessage​(Diagnostic.Kind kind, CharSequence msg)
      打印指定类型的消息。
      void printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e)
      在元素的位置打印指定类型的消息。
      void printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a)
      在注释元素的注释镜像的位置打印指定类型的消息。
      void printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v)
      在注释元素的注释镜像内的注释值的位置打印指定类型的消息。

    • 方法详细信息

      • printMessage

        void printMessage​(Diagnostic.Kind kind,
                  CharSequence msg)
        打印指定类型的消息。
        参数
        kind - 那种消息
        msg - 消息，或空字符串（如果没有）

      • printMessage

        void printMessage​(Diagnostic.Kind kind,
                  CharSequence msg,
                  Element e)
        在元素的位置打印指定类型的消息。
        参数
        kind - 那种消息
        msg - 消息，或空字符串（如果没有）
        e - 用作位置提示的元素

      • printMessage

        void printMessage​(Diagnostic.Kind kind,
                  CharSequence msg,
                  Element e,
                  AnnotationMirror a)
        在注释元素的注释镜像的位置打印指定类型的消息。
        参数
        kind - 消息的种类
        msg - 消息，或空字符串（如果没有）
        e - 注释元素
        a - 用作位置提示的注释

      • printMessage

        void printMessage​(Diagnostic.Kind kind,
                  CharSequence msg,
                  Element e,
                  AnnotationMirror a,
                  AnnotationValue v)
        在注释元素的注释镜像内的注释值的位置打印指定类型的消息。
        参数
        kind - 那种消息
        msg - 消息，或空字符串（如果没有）
        e - 注释元素
        a - 包含注释值的注释
        v - the annotation value to use as a position hint
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProcessingEnvironment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.annotation.processing

Interface ProcessingEnvironment

  • public interface ProcessingEnvironment
    注释处理工具框架将由provide an annotation processor with an object implementing this interface进行处理，因此处理器可以使用框架提供的工具来编写新文件，报告错误消息和查找其他实用程序。

    第三方可能希望在该接口周围的设施对象上提供增值封装，例如允许多个处理器协调编写单个源文件的Filer扩展。 为了实现这一点，在上下文中运行的处理器，其中通过API它们的副作用可能是彼此可见，该工具基础设施必须提供相应的设施对象.equals ， Filer S中的.equals ，等等。 另外，必须能够配置工具调用，使得从正在运行的批注处理器的角度来看，至少所选择的辅助类子集被视为由同一类加载器加载。 （由于设备对象管理共享状态，包装类的实现必须知道相同的基础设施对象是否已被包装。）

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Elements getElementUtils​()
      返回一些用于操作元素的实用方法的实现
      Filer getFiler​()
      返回用于创建新的源，类或辅助文件的文件管理器。
      Locale getLocale​()
      如果没有语言环境 null则返回当前语言环境或 null 。
      Messager getMessager​()
      返回用于报告错误，警告和其他通知的信使。
      Map<String,String> getOptions​()
      返回传递给注解处理工具的处理器特定选项。
      SourceVersion getSourceVersion​()
      返回任何生成的 source和 class文件应符合的源版本。
      Types getTypeUtils​()
      返回一些用于对类型进行操作的实用方法的实现。

    • 方法详细信息

      • getOptions

        Map<String,String> getOptions​()
        返回传递给注解处理工具的处理器特定选项。 选项以选项名称的形式返回到选项值。 对于没有值的选项，地图中的相应值为null 。

        有关如何传递处理器特定选项的详细信息，请参阅特定工具基础架构的文档。 例如，命令行实现可以通过使用已知字符串前缀它们来区分处理器特定的选项，如"-A" ; 其他工具实现可以遵循不同的约定或提供替代机制。 给定的实现还可以提供实现特定的方式来查找传递给工具的选项以及处理器特定的选项。

        结果
        处理器特定的选项传递给工具

      • getMessager

        Messager getMessager​()
        返回用于报告错误，警告和其他通知的信使。
        结果
        消息员

      • getFiler

        Filer getFiler​()
        返回用于创建新的源，类或辅助文件的文件管理器。
        结果
        文件管理员

      • getElementUtils

        Elements getElementUtils​()
        返回一些用于操作元素的实用方法的实现
        结果
        元素实用程序

      • getTypeUtils

        Types getTypeUtils​()
        返回一些用于对类型进行操作的实用方法的实现。
        结果
        类型工具

      • getSourceVersion

        SourceVersion getSourceVersion​()
        返回任何生成的 source和 class文件应符合的源版本。
        结果
        生成的源和类文件应符合的源版本
        另请参见：
        Processor.getSupportedSourceVersion()

      • getLocale

        Locale getLocale​()
        如果没有语言环境null则返回当前语言环境或null 。 该地区可用于提供本地化的messages 。
        结果
        当前的区域设置或 null如果没有区域设置生效
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Processor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.annotation.processing

Interface Processor

  • 所有已知实现类：
    AbstractProcessor

    public interface Processor
    注释处理器的界面。

    注释处理按rounds的顺序进行。 在每一轮中，可能会要求处理器process在上一轮产生的源文件和类文件上发现的注释的一个子集。 第一轮处理的输入是工具运行的初始输入; 这些初始输入可以被认为是虚拟第五轮处理的输出。 如果一个处理器被要求在给定的一轮进行处理，那么将被要求处理后续的回合，包括最后一轮，即使没有注释来处理它。 工具基础设施还可能要求处理器处理由工具操作隐含生成的文件。

    Processor每个实现Processor必须提供一个公共的无参数构造函数，供工具用来实例化处理器。 工具基础设施将与实现此接口的类进行交互，如下所示：

    1. 如果没有使用现有的Processor对象，要创建一个处理器的实例，该工具将调用处理器类的无参数构造函数。
    2. 接下来，该工具使用适当的ProcessingEnvironment调用init方法。
    3. 此后，工具调用getSupportedAnnotationTypes ， getSupportedOptions ，并getSupportedSourceVersion 。 这些方法只能在每次运行时调用一次，而不是每轮调用。
    4. 适当时，该工具在Processor对象上调用process方法; 不会为每一轮创建一个新的Processor对象。
    如果在没有遵循上述协议的情况下创建和使用处理器对象，则该接口规范未定义处理器的行为。

    该工具使用发现过程来查找注释处理器并决定是否应该运行它们。 通过配置工具，可以控制一组潜在的处理器。 例如，对于JavaCompiler ，候选处理器的运行列表可以是set directly或由用于service-style查询的search path控制。 其他工具实现可能具有不同的配置机制，如命令行选项; 有关详细信息，请参阅特定工具的文档。 哪个处理器的工具要求run是root elements上的注释类型270729923870703 ，什么是annotation types a processor supports ，以及是否处理器claims the annotation types it processes 。 处理器将被要求处理其支持的注释类型的子集，可能是一个空集。 对于给定的一轮，该工具计算出在根元素中包含的元素上的注释类型集合。 如果存在至少一个注释类型，那么当处理器声明注释类型时，它们将从一组不匹配的注释类型中移除。 当该组为空或没有更多的处理器可用时，该轮已经运行完成。 如果没有注释类型，则注释处理仍然发生，但只有支持处理所有注释类型的通用处理器 （ "*" ）可以声明（空）注释类型集。

    如果存在于包含在一个回合的根元素内的元素上存在该类型的至少一个注释，则认为注释类型存在。 为此，一个类型参数被认为是由它的generic element包围 。 为此， 不会将包元素封装在该包中的顶级类型。 （当处理package-info文件时，将创建一个表示包的根元素。）同样，为此， 不会将模块元素封装在该模块中。 （当处理module-info文件时，会创建表示模块的根元素。）在计算是否存在注释类型时，将忽略type uses上的注释 ，而不是元素上的注释。

    如果符合AnnotatedConstruct中给出的定义，则存在注释 。 简而言之，如果通过继承直接存在或存在，则认为出于发现的目的存在注释。 通过由容器注释包装，注释不被认为是存在的。 在操作上，这相当于一个元素上存在的注释，当且仅当它被包含在该元素上调用的Elements.getAllAnnotationMirrors(Element)的结果中时。 由于容器注释中的注释不被认为是存在的，为了正确处理repeatable annotation types ，建议处理器将可重复的注释类型及其包含的注释类型同时包含在处理器的一组supported annotation types中。

    请注意，如果处理器支持"*"并返回true ，则会声明所有注释。 因此，用于例如实现附加有效性检查的通用处理器应该返回false ，以便不阻止其他这样的检查器能够运行。

    如果处理器引发未捕获的异常，则该工具可能会停止其他活动注释处理器。 如果处理器出现错误，则当前轮次将完成，后续轮次将显示为error was raised 。 由于注释处理器在协作环境中运行，所以处理器只能在没有错误恢复或报告可行的情况下抛出未捕获的异常。

    工具环境不需要支持以多线程方式访问环境资源的注释处理器（ per round或cross-round） 。

    如果返回有关注解处理器的配置信息的方法返回null ，则返回其他无效输入或抛出异常，则工具基础结构必须将其视为错误条件。

    为了在不同的工具实现中运行时保持稳定，注释处理器应具有以下属性：

    1. 处理给定输入的结果不是存在或不存在其他输入（正交性）的函数。
    2. 处理相同的输入产生相同的输出（一致性）。
    3. 处理输入A后跟处理输入B相当于处理B然后A （交换）
    4. 处理输入并不依赖于其他注释处理器的输出（独立性）

    Filer接口讨论了处理器如何对文件进行操作的限制。

    API Note:
    该接口的实现者可能会发现扩展AbstractProcessor而不是直接实现该接口是方便的。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Iterable<? extends Completion> getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回到工具基础结构，可以对注释的建议完成进行迭代。
      Set<String> getSupportedAnnotationTypes​()
      返回此处理器支持的注释类型的名称。
      Set<String> getSupportedOptions​()
      返回此处理器识别的选项。
      SourceVersion getSupportedSourceVersion​()
      返回此注释处理器支持的最新的源版本。
      void init​(ProcessingEnvironment processingEnv)
      使用处理环境初始化处理器。
      boolean process​(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv)
      对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。

    • 方法详细信息

      • getSupportedOptions

        Set<String> getSupportedOptions​()
        返回此处理器识别的选项。 处理工具的实现必须提供一种从处理器特定的选项中传递到工具本身的选项的方式，参见getOptions 。

        在集合中返回的每个字符串必须是一个周期分隔的序列identifiers ：

        SupportedOptionString:
        Identifiers
        Identifiers:
        Identifier
        Identifier . Identifiers
        Identifier:
        Syntactic identifier, including keywords and literals

        工具可能会使用这些信息来确定用户提供的任何选项是否被任何处理器无法识别，在这种情况下，它可能希望报告警告。

        结果
        此处理器识别的选项或空集合（如果没有）
        另请参见：
        SupportedOptions

      • getSupportedAnnotationTypes

        Set<String> getSupportedAnnotationTypes​()
        返回此处理器支持的注释类型的名称。 结果的元素可能是支持的注释类型的规范（完全限定）名称。 或者它可能是形式“的name.* ”代表了集中的所有注释类型的规范名称以“开头的name. ”。 在任何一种情况下，注释类型的名称可以前面加上一个模块名称，后跟一个"/"字符。 例如，如果处理器支持"a.B" ，则可以包括多个名为a.B注释类型，它们位于不同的模块中。 要在Foo模块中只支持a.B ，而是使用"Foo/a.B" 。 如果包含模块名称，则只匹配该模块中的注释。 特别地，如果在不支持模块的环境中给出模块名称，例如为没有模块的source version配置的注释处理环境，则具有模块名称的注释类型不匹配。 最后， "*"本身表示所有注释类型的集合，包括空集合。 请注意，处理器不应要求"*"除非它实际上处理所有文件; 声称不必要的注释可能会导致某些环境中的性能下降。

        在集合中返回的每个字符串必须被以下语法接受：

        SupportedAnnotationTypeString:
        ModulePrefix opt TypeName DotStar opt
        *
        ModulePrefix:
        ModuleName /
        DotStar:
        . *
        其中TypeName和ModuleName如The Java™ Language Specification中所定义。
        API Note:
        当在支持模块的环境中运行时，鼓励处理器在描述支持的注释类型时包含模块前缀。 方法AbstractProcessor.getSupportedAnnotationTypes提供了在没有模块的环境中运行时剥离模块前缀的支持。
        结果
        该处理器支持的注释类型的名称
        另请参见：
        SupportedAnnotationTypes
        See The Java™ Language Specification:
        3.8标识符，6.5确定名称的含义

      • getSupportedSourceVersion

        SourceVersion getSupportedSourceVersion​()
        返回此注释处理器支持的最新的源版本。
        结果
        该注释处理器支持的最新的源版本。
        另请参见：
        SupportedSourceVersion ， ProcessingEnvironment.getSourceVersion()

      • init

        void init​(ProcessingEnvironment processingEnv)
        使用处理环境初始化处理器。
        参数
        processingEnv - 工具框架为处理器提供的设施的环境

      • process

        boolean process​(Set<? extends TypeElement> annotations,
                RoundEnvironment roundEnv)
        对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。 如果返回true ，则会声明注释类型，并且不会要求后续处理器处理它们; 如果返回false ，则注释类型是无人认领的，并且后处理器可能被要求处理它们。 处理器可以总是返回相同的布尔值，或者可以根据其自己选择的标准来改变结果。

        如果处理器支持"*"且根元素没有注释，输入集将为空。 A Processor必须优雅地处理一组空的注释。

        参数
        annotations - 请求处理的注释类型
        roundEnv - 有关当前和前一轮的信息的环境
        结果
        该处理器是否声明该组注释类型

      • getCompletions

        Iterable<? extends Completion> getCompletions​(Element element,
                                              AnnotationMirror annotation,
                                              ExecutableElement member,
                                              String userText)
        返回到工具基础结构，可以对注释的建议完成进行迭代。 由于要求完成，关于注释提供的信息可能不完整，就像源代码片段一样。 处理器可能返回一个空的迭代。 注解处理器应集中努力于提供完井用于注释成员已知的处理器附加有效性约束，例如int构件，其值应在1和10或应用公知的语法来识别，诸如字符串构件之间位于正则表达式或URL。

        由于不完整的程序被建模，一些参数可能只有部分信息，或可能是null 。 element和userText至少一个必须是非null 。 如果element是非null ，则annotation和member可以是null 。 处理器可能不会抛出NullPointerException如果某些参数是null ; 如果处理器根据提供的信息没有提供完成，则可以返回空的迭代。 处理器还可以使用空值字符串返回单个完成，并且描述为什么没有完成。

        完成信息丰富，并可能反映注释处理器执行的其他有效性检查。 例如，考虑简单的注释：

         @MersennePrime {
    int value();
 }
        （A Mersenne素数是素数的形式的2 N - 1）给定一个AnnotationMirror此注释类型，在所有这样的素数的列表int范围而不检查任何其他参数可以返回getCompletions ：
         import static javax.annotation.processing.Completions.*;
 ...
 return Arrays.asList(of("3"),
                      of("7"),
                      of("31"),
                      of("127"),
                      of("8191"),
                      of("131071"),
                      of("524287"),
                      of("2147483647"));
        一整套完整的数据将包括每个素材的数量：
         return Arrays.asList(of("3",          "M2"),
                      of("7",          "M3"),
                      of("31",         "M5"),
                      of("127",        "M7"),
                      of("8191",       "M13"),
                      of("131071",     "M17"),
                      of("524287",     "M19"),
                      of("2147483647", "M31"));
        但是，如果userText可用，则可以检查是否只有Mersenne素数的一个子集是有效的。 例如，如果用户键入
        @MersennePrime(1
        价值userText将为"1" ; 只有两个素数是可能的完成：
         return Arrays.asList(of("127",        "M7"),
                      of("131071",     "M17"));
        有时没有有效的完成是可能的。 例如，从9开始，没有范围内的梅森素食
        @MersennePrime(9
        在这种情况下，适当的回应是返回一个空的完成列表，
         return Collections.emptyList();
        或一个空的完成与一个有用的消息
         return Arrays.asList(of("", "No in-range Mersenne primes start with 9"));
        参数
        element - 要注释的元素
        annotation - （可能是部分的）注释被应用于元素
        member - 注释成员返回可能的完成
        userText - 要完成的源代码文本
        结果
        建议完成注释
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RoundEnvironment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.annotation.processing

Interface RoundEnvironment

  • public interface RoundEnvironment
    注释处理工具框架将为 provide an annotation processor with an object implementing this interface ，使得处理器可以查询关于一轮注释处理的信息。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      boolean errorRaised​()
      如果在上一轮处理中出现错误，则返回true ; 否则返回false 。
      Set<? extends Element> getElementsAnnotatedWith​(Class<? extends Annotation> a)
      返回使用给定注释类型注释的元素。
      Set<? extends Element> getElementsAnnotatedWith​(TypeElement a)
      返回使用给定注释类型注释的元素。
      default Set<? extends Element> getElementsAnnotatedWithAny​(Set<Class<? extends Annotation>> annotations)
      返回使用一个或多个给定注释类型注释的元素。
      default Set<? extends Element> getElementsAnnotatedWithAny​(TypeElement... annotations)
      返回使用一个或多个给定注释类型注释的元素。
      Set<? extends Element> getRootElements​()
      返回上一轮生成的注释处理的root elements 。
      boolean processingOver​()
      返回true如果由此轮生成的类型不会受到后续轮注的处理; 否则返回false 。

    • 方法详细信息

      • processingOver

        boolean processingOver​()
        返回true如果由此轮生成的类型不会受到后续轮注的处理; 否则返回false 。
        结果
        true如果此轮生成的类型不会受到后续轮注的处理; 否则返回false

      • errorRaised

        boolean errorRaised​()
        返回true如果在上一轮处理中出现错误; 否则返回false 。
        结果
        true如果在前一轮处理中出现错误; 否则返回false

      • getRootElements

        Set<? extends Element> getRootElements​()
        返回上一轮生成的注释处理的root elements 。
        结果
        上一轮生成的注释处理的根元素，如果没有，则为空集

      • getElementsAnnotatedWith

        Set<? extends Element> getElementsAnnotatedWith​(TypeElement a)
        返回使用给定注释类型注释的元素。 注释可以直接显示或继承。 仅返回本轮注释处理中包含的包元素，模块元素和类型元素，或者返回在其中声明的成员，构造函数，参数或类型参数的声明。 包含的类型元素为root types ，嵌套在其中的任何成员类型。 包的元素不包括在内，因为该包的package-info文件已创建。 同样，模块的元素也不被认为是因为该模块的一个module-info文件被创建
        参数
        a - 请求的注释类型
        结果
        用给定注释类型注释的元素，如果没有，则为空集
        异常
        IllegalArgumentException - 如果参数不表示注释类型

      • getElementsAnnotatedWithAny

        default Set<? extends Element> getElementsAnnotatedWithAny​(TypeElement... annotations)
        返回使用一个或多个给定注释类型注释的元素。
        API Note:
        当通过查找注释类型及其包含的注释类型同时处理重复注释时，此方法可能很有用。
        实现要求：
        此方法的默认实现将创建一个空结果集，迭代参数数组中的注释，每个注释上调用getElementsAnnotatedWith(TypeElement) ，并将这些结果添加到结果集中。 最后，结果集的内容作为不可修改的集合返回。
        参数
        annotations - 请求的注释类型
        结果
        用一个或多个给定注释类型注释的元素，如果没有，则为空集
        异常
        IllegalArgumentException - 如果参数集的任何元素不表示注释类型
        从以下版本开始：
        9
        See The Java™ Language Specification:
        9.6.3可重复注释类型

      • getElementsAnnotatedWith

        Set<? extends Element> getElementsAnnotatedWith​(Class<? extends Annotation> a)
        返回使用给定注释类型注释的元素。 注释可以直接显示或继承。 仅返回本轮注释处理中包含的包元素，模块元素和类型元素，或者返回在其中声明的成员，构造函数，参数或类型参数的声明。 包含的类型元素为root types ，嵌套在其中的任何成员类型。 软件包中的元素不被认为包括在内，因为该软件包的package-info文件已创建。 同样，模块的元素也不被认为是因为该模块的一个module-info文件被创建
        参数
        a - 请求的注释类型
        结果
        用给定注释类型注释的元素，如果没有，则为空集
        异常
        IllegalArgumentException - 如果参数不表示注释类型

      • getElementsAnnotatedWithAny

        default Set<? extends Element> getElementsAnnotatedWithAny​(Set<Class<? extends Annotation>> annotations)
        返回使用一个或多个给定注释类型注释的元素。
        API Note:
        当通过查找注释类型及其包含的注释类型同时处理重复注释时，此方法可能很有用。
        实现要求：
        此方法的默认实现将创建一个空结果集，迭代在每个注释上调用getElementsAnnotatedWith(Class)的参数集中的注释，并将这些结果添加到结果集。 最后，结果集的内容作为不可修改的集合返回。
        参数
        annotations - 请求的注释类型
        结果
        用一个或多个给定注释类型注释的元素，如果没有，则为空集
        异常
        IllegalArgumentException - 如果参数集的任何元素不表示注释类型
        从以下版本开始：
        9
        See The Java™ Language Specification:
        9.6.3可重复注释类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SupportedAnnotationTypes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.compiler
软件包 javax.annotation.processing

Annotation Type SupportedAnnotationTypes

  • @Documented
@Target(TYPE)
@Retention(RUNTIME)
public @interface SupportedAnnotationTypes
    用于指示注释处理器支持的注释类型的注释。 Processor.getSupportedAnnotationTypes()方法可以从该注释的值构建其结果，如AbstractProcessor.getSupportedAnnotationTypes()所示 。 只能使用strings conforming to the grammar作为值。
    从以下版本开始：
    1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String[] value
      返回支持的注释类型的名称。

    • Element Detail

      • value

        String[] value
        返回支持的注释类型的名称。
        结果
        支持的注释类型的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


SupportedOptions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.compiler
软件包 javax.annotation.processing

Annotation Type SupportedOptions

  • @Documented
@Target(TYPE)
@Retention(RUNTIME)
public @interface SupportedOptions
    用于指示注释处理器支持哪些选项的注释。 Processor.getSupportedOptions()方法可以从此注释的值构造其结果，如AbstractProcessor.getSupportedOptions()所述 。 只能使用strings conforming to the grammar作为值。
    从以下版本开始：
    1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String[] value
      返回支持的选项。

    • Element Detail

      • value

        String[] value
        返回支持的选项。
        结果
        支持的选项
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


SupportedSourceVersion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.compiler
软件包 javax.annotation.processing

Annotation Type SupportedSourceVersion

  • @Documented
@Target(TYPE)
@Retention(RUNTIME)
public @interface SupportedSourceVersion
    用于指示注释处理器支持的最新源版本的注释。 Processor.getSupportedSourceVersion()方法可以从该注释的值构建其结果，如AbstractProcessor.getSupportedSourceVersion()所做 。
    从以下版本开始：
    1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      SourceVersion value
      返回支持的最新版本。

    • Element Detail

      • value

        SourceVersion value
        返回支持的最新版本。
        结果
        最新支持的源代码版本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


Uses of Package javax.annotation.processing (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.annotation.processing

  • Packages that use javax.annotation.processing
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model.util
    协助处理 program elements和 types的公用事业 。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
  • Classes in javax.annotation.processing used by com.sun.source.util
    Class 描述
    ProcessingEnvironment
    注释处理工具框架将由 provide an annotation processor with an object implementing this interface进行处理，因此处理器可以使用框架提供的工具来编写新文件，报告错误消息以及查找其他工具。
  • Classes in javax.annotation.processing used by javax.annotation.processing
    Class 描述
    Completion
    建议用于注释的 completion 。
    Filer
    该接口支持通过注释处理器创建新文件。
    Messager
    A Messager提供注释处理器报告错误消息，警告和其他通知的方式。
    ProcessingEnvironment
    注释处理工具框架将为 provide an annotation processor with an object implementing this interface，因此处理器可以使用框架提供的工具来编写新文件，报告错误消息和查找其他实用程序。
    Processor
    注释处理器的界面。
    RoundEnvironment
    注释处理工具框架将为 provide an annotation processor with an object implementing this interface ，使得处理器可以查询关于一轮注释处理的信息。
  • Classes in javax.annotation.processing used by javax.lang.model.util
    Class 描述
    SupportedSourceVersion
    用于指示注释处理器支持的最新源版本的注释。
  • Classes in javax.annotation.processing used by javax.tools
    Class 描述
    Processor
    The interface for an annotation processor.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.processing.AbstractProcessor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.processing.AbstractProcessor

No usage of javax.annotation.processing.AbstractProcessor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.processing.Completions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.processing.Completions

No usage of javax.annotation.processing.Completions
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.processing.FilerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.processing.FilerException

No usage of javax.annotation.processing.FilerException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.processing.Generated (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.processing.Generated

No usage of javax.annotation.processing.Generated
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.processing.SupportedAnnotationTypes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.processing.SupportedAnnotationTypes

No usage of javax.annotation.processing.SupportedAnnotationTypes
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.processing.SupportedOptions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.processing.SupportedOptions

No usage of javax.annotation.processing.SupportedOptions
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.annotation.processing.SupportedSourceVersion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.annotation.processing.SupportedSourceVersion

  • Packages that use SupportedSourceVersion
    软件包 描述
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of SupportedSourceVersion in javax.lang.model.util

      Classes in javax.lang.model.util with annotations of type SupportedSourceVersion
      Modifier and Type Class 描述
      class  AbstractAnnotationValueVisitor6<R,P>
      具有默认行为的注释值的骨架访问者适用于 RELEASE_6源版本。
      class  AbstractAnnotationValueVisitor7<R,P>
      注释值的骨架访问者，默认行为适用于 RELEASE_7源版本。
      class  AbstractAnnotationValueVisitor8<R,P>
      具有默认行为的注释值的骨骼访问者适用于 RELEASE_8源版本。
      class  AbstractAnnotationValueVisitor9<R,P>
      注释值的骨架访问者，默认行为适用于 RELEASE_9源版本。
      class  AbstractElementVisitor6<R,P>
      具有适用于 RELEASE_6源版本的默认行为的程序元素的骨架访问者。
      class  AbstractElementVisitor7<R,P>
      具有适用于 RELEASE_7源版本的默认行为的程序元素的骨架访问者。
      class  AbstractElementVisitor8<R,P>
      程序元素的骨架访问者，默认行为适用于 RELEASE_8源版本。
      class  AbstractElementVisitor9<R,P>
      具有适用于 RELEASE_9源版本的默认行为的程序元素的骨架访问者。
      class  AbstractTypeVisitor6<R,P>
      类型的骨骼访问者，具有适合 RELEASE_6源版本的默认行为。
      class  AbstractTypeVisitor7<R,P>
      具有适用于 RELEASE_7源版本的默认行为类型的骨架访问者。
      class  AbstractTypeVisitor8<R,P>
      类型的骨骼访问者，具有适合 RELEASE_8源版本的默认行为。
      class  AbstractTypeVisitor9<R,P>
      类型的骨架访问者，具有适用于 RELEASE_9源版本的默认行为。
      class  ElementKindVisitor6<R,P>
      程序元素的访问者根据其kind的默认行为适合RELEASE_6源版本。
      class  ElementKindVisitor7<R,P>
      程序元素的访问者基于他们的kind默认行为适合RELEASE_7源版本。
      class  ElementKindVisitor8<R,P>
      基于他们的kind程序元素的访问者的默认行为适合RELEASE_8源版本。
      class  ElementKindVisitor9<R,P>
      基于他们的kind程序元素的访问者的默认行为适合RELEASE_9源版本。
      class  ElementScanner6<R,P>
      具有适用于 RELEASE_6源版本的默认行为的程序元素的扫描访问者。
      class  ElementScanner7<R,P>
      具有适用于 RELEASE_7源版本的默认行为的程序元素的扫描访问者。
      class  ElementScanner8<R,P>
      具有适用于 RELEASE_8源版本的默认行为的程序元素的扫描访问者。
      class  ElementScanner9<R,P>
      具有默认行为的程序元素的扫描访问者适用于 RELEASE_9源版本。
      class  SimpleAnnotationValueVisitor6<R,P>
      注释值的简单访问者，默认行为适用于 RELEASE_6源版本。
      class  SimpleAnnotationValueVisitor7<R,P>
      注释值的简单访问者，默认行为适用于 RELEASE_7源版本。
      class  SimpleAnnotationValueVisitor8<R,P>
      注释值的简单访问者，默认行为适用于 RELEASE_8源版本。
      class  SimpleAnnotationValueVisitor9<R,P>
      注释值的简单访问者，默认行为适用于 RELEASE_9源版本。
      class  SimpleElementVisitor6<R,P>
      程序元素的简单访问者，默认行为适用于 RELEASE_6源版本。
      class  SimpleElementVisitor7<R,P>
      一个简单的程序元素访问者，默认行为适用于 RELEASE_7源版本。
      class  SimpleElementVisitor8<R,P>
      程序元素的简单访问者，默认行为适用于 RELEASE_8源版本。
      class  SimpleElementVisitor9<R,P>
      一个简单的访问程序元素的默认行为适用于 RELEASE_9源版本。
      class  SimpleTypeVisitor6<R,P>
      类型的简单访问者，默认行为适用于 RELEASE_6源版本。
      class  SimpleTypeVisitor7<R,P>
      类型的简单访问者，默认行为适用于 RELEASE_7源版本。
      class  SimpleTypeVisitor8<R,P>
      类型的简单访问者，默认行为适用于 RELEASE_8源版本。
      class  SimpleTypeVisitor9<R,P>
      类型的简单访问者，默认行为适用于 RELEASE_9源版本。
      class  TypeKindVisitor6<R,P>
      基于他们的kind类型的访问者的默认行为适用于RELEASE_6源版本。
      class  TypeKindVisitor7<R,P>
      基于他们的kind类型的访问者的默认行为适用于RELEASE_7源版本。
      class  TypeKindVisitor8<R,P>
      基于他们的kind类型的访问者 ，默认行为适用于RELEASE_8源版本。
      class  TypeKindVisitor9<R,P>
      A visitor of types based on their kind with default behavior appropriate for the RELEASE_9 source version.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.annotation.processing.Completion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.annotation.processing.Completion

  • Packages that use Completion
    软件包 描述
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。

    • Uses of Completion in javax.annotation.processing

      Methods in javax.annotation.processing that return Completion
      Modifier and Type 方法 描述
      static Completion Completions.of​(String value)
      返回值的完成和空消息
      static Completion Completions.of​(String value, String message)
      返回值和消息的完成。
      Methods in javax.annotation.processing that return types with arguments of type Completion
      Modifier and Type 方法 描述
      Iterable<? extends Completion> AbstractProcessor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回一个空的可迭代的完成。
      Iterable<? extends Completion> Processor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回到工具基础结构，可以对注释的建议完成进行迭代。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.annotation.processing.Filer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.annotation.processing.Filer

  • Packages that use Filer
    软件包 描述
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。

    • Uses of Filer in javax.annotation.processing

      Methods in javax.annotation.processing that return Filer
      Modifier and Type 方法 描述
      Filer ProcessingEnvironment.getFiler​()
      返回用于创建新的源，类或辅助文件的文件管理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.annotation.processing.Messager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.annotation.processing.Messager

  • Packages that use Messager
    软件包 描述
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。

    • Uses of Messager in javax.annotation.processing

      Methods in javax.annotation.processing that return Messager
      Modifier and Type 方法 描述
      Messager ProcessingEnvironment.getMessager​()
      返回用于报告错误，警告和其他通知的信使。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.annotation.processing.ProcessingEnvironment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.annotation.processing.ProcessingEnvironment

  • Packages that use ProcessingEnvironment
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。

    • Uses of ProcessingEnvironment in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ProcessingEnvironment
      Modifier and Type 方法 描述
      static DocTrees DocTrees.instance​(ProcessingEnvironment env)
      返回给定的ProcessingEnvironment的DocTrees对象。
      static JavacTask JavacTask.instance​(ProcessingEnvironment processingEnvironment)
      返回 JavacTask的 ProcessingEnvironment 。
      static Trees Trees.instance​(ProcessingEnvironment env)
      返回给定ProcessingEnvironment的Trees对象。

    • Uses of ProcessingEnvironment in javax.annotation.processing

      Fields in javax.annotation.processing declared as ProcessingEnvironment
      Modifier and Type Field 描述
      protected ProcessingEnvironment AbstractProcessor.processingEnv
      由工具框架提供的处理环境。
      Methods in javax.annotation.processing with parameters of type ProcessingEnvironment
      Modifier and Type 方法 描述
      void AbstractProcessor.init​(ProcessingEnvironment processingEnv)
      通过将 processingEnv字段设置为 processingEnv参数的值，通过处理环境初始化处理器。
      void Processor.init​(ProcessingEnvironment processingEnv)
      使用处理环境初始化处理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.annotation.processing.Processor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.annotation.processing.Processor

  • Packages that use Processor
    软件包 描述
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。

    • Uses of Processor in javax.annotation.processing

      Classes in javax.annotation.processing that implement Processor
      Modifier and Type Class 描述
      class  AbstractProcessor
      一个抽象的注释处理器，被设计为大多数具体注解处理器的一个方便的超类。

    • Uses of Processor in javax.tools

      Method parameters in javax.tools with type arguments of type Processor
      Modifier and Type 方法 描述
      void JavaCompiler.CompilationTask.setProcessors​(Iterable<? extends Processor> processors)
      设置处理器（用于注释处理）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.annotation.processing.RoundEnvironment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.annotation.processing.RoundEnvironment

  • Packages that use RoundEnvironment
    软件包 描述
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。

    • Uses of RoundEnvironment in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type RoundEnvironment
      Modifier and Type 方法 描述
      abstract boolean AbstractProcessor.process​(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv)
      对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。
      boolean Processor.process​(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv)
      对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AEADBadTagException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class AEADBadTagException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.crypto.BadPaddingException
            • javax.crypto.AEADBadTagException
  • All Implemented Interfaces:
    Serializable

    public class AEADBadTagException
extends BadPaddingException
    当以AEAD模式运行的Cipher （例如GCM / CCM）无法验证提供的认证标签时，会抛出此异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AEADBadTagException​()
      构造一个没有详细消息的AEADBadTagException。
      AEADBadTagException​(String msg)
      构造具有指定详细消息的AEADBadTagException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AEADBadTagException

        public AEADBadTagException​()
        构造一个没有详细消息的AEADBadTagException。

      • AEADBadTagException

        public AEADBadTagException​(String msg)
        构造具有指定详细消息的AEADBadTagException。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BadPaddingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class BadPaddingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.crypto.BadPaddingException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AEADBadTagException

    public class BadPaddingException
extends GeneralSecurityException
    当期望输入数据的特定填充机制但数据未正确填充时，会抛出此异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BadPaddingException​()
      构造一个没有详细消息的BadPaddingException。
      BadPaddingException​(String msg)
      构造具有指定详细消息的BadPaddingException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • BadPaddingException

        public BadPaddingException​()
        构造一个没有详细消息的BadPaddingException。 详细消息是描述此特定异常的字符串。

      • BadPaddingException

        public BadPaddingException​(String msg)
        构造具有指定详细消息的BadPaddingException。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Cipher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class Cipher

  • java.lang.Object
    • javax.crypto.Cipher
  • 已知直接子类：
    NullCipher

    public class Cipher
extends Object
    该类提供加密和解密的加密密码的功能。 它构成了Java加密扩展（JCE）框架的核心。

    为了创建一个Cipher对象，应用程序调用Cipher的getInstance方法，并将所请求的转换的名称传递给它。 可选地，可以指定提供者的名称。

    转换是描述要在给定输入上执行的操作（或操作集）的字符串，以产生一些输出。 转换总是包括加密算法的名称（例如， DES ），并且可以跟随有反馈模式和填充方案。

    转换形式如下：

    • “ 算法/模式/填充 ”或
    • “ 算法 ”

    （在后一种情况下，使用模式和填充方案的提供者特定的默认值）。 例如，以下是有效的转换：

      Cipher c = Cipher.getInstance("DES/CBC/PKCS5Padding");
    使用诸如CFB和OFB模式，块密码可以以比密码的实际块大OFB单位加密数据。 当请求这样的模式时，您可以通过将该号码追加到“ DES/CFB8/NoPadding ”和“ DES/OFB32/PKCS5Padding ”转换中所示的模式名称来指定要一次处理的位数。 如果没有指定此类号码，则使用特定于提供者的默认值。 （例如，SunJCE提供程序对DES使用默认值为64位）。因此，通过使用诸如CFB8或OFB8之类的8位模式，块密码可以转换为面向字节的流密码。

    诸如使用关联数据的认证加密（AEAD）等模式为机密数据和未加密的附加关联数据（AAD）提供真实性保证。 （有关AEAD和AAD算法（如GCM / CCM）的更多信息，请参阅RFC 5116。 ）计算认证标签时可以使用机密数据和AAD数据（类似于Mac ）。 该标签在加密期间附加到密文，并在解密后进行验证。

    AEAD模式如GCM / CCM在开始密文真实性计算之前执行所有的AAD真实性计算。 为了避免必须在内部缓冲器的密文实施方案中，所有数据AAD必须提供给GCM / CCM的实现（经由updateAAD方法）密文被处理之前 （通过update种doFinal方法）。

    注意，GCM模式对于使用给定密钥加密的IV具有唯一性要求。 当GCM加密重复IVs时，这些用法将遭受伪造攻击。 因此，在使用GCM模式的每个加密操作之后，呼叫者应使用具有不同IV值的GCM参数重新初始化密码对象。

      GCMParameterSpec s = ...;
     cipher.init(..., s);

     // If the GCM parameters were generated by the provider, it can
     // be retrieved by:
     // cipher.getParameters().getParameterSpec(GCMParameterSpec.class);

     cipher.updateAAD(...);  // AAD
     cipher.update(...);     // Multi-part update
     cipher.doFinal(...);    // conclusion of operation

     // Use a different IV value for every encryption
     byte[] newIv = ...;
     s = new GCMParameterSpec(s.getTLen(), newIv);
     cipher.init(..., s);
     ...
    Java平台的每个实现都需要支持以下标准的Cipher转换，括号中的键入：
    • AES/CBC/NoPadding （128）
    • AES/CBC/PKCS5Padding （128）
    • AES/ECB/NoPadding （128）
    • AES/ECB/PKCS5Padding （128）
    • AES/GCM/NoPadding （128）
    • DES/CBC/NoPadding （56）
    • DES/CBC/PKCS5Padding （56）
    • DES/ECB/NoPadding （56）
    • DES/ECB/PKCS5Padding （56）
    • DESede/CBC/NoPadding （168）
    • DESede/CBC/PKCS5Padding （168）
    • DESede/ECB/NoPadding （168）
    • DESede/ECB/PKCS5Padding （168）
    • RSA/ECB/PKCS1Padding （ RSA/ECB/PKCS1Padding ）
    • RSA/ECB/OAEPWithSHA-1AndMGF1Padding （ RSA/ECB/OAEPWithSHA-1AndMGF1Padding ）
    • RSA/ECB/OAEPWithSHA-256AndMGF1Padding （ RSA/ECB/OAEPWithSHA-256AndMGF1Padding ）
    这些转换在Java安全标准算法名称规范的Cipher section中进行了描述。 请参阅实施的发行文档，以查看是否支持其他转换。
    从以下版本开始：
    1.4
    另请参见：
    KeyGenerator ， SecretKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DECRYPT_MODE
      常数用于将密码初始化为解密模式。
      static int ENCRYPT_MODE
      常数用于将密码初始化为加密模式。
      static int PRIVATE_KEY
      用于指示要解除密钥的常数是“私钥”。
      static int PUBLIC_KEY
      用于指示待解除密钥的常数是“公钥”。
      static int SECRET_KEY
      用于指示要解开的密钥的常数是“密钥”。
      static int UNWRAP_MODE
      常数用于将密码初始化为密钥解包模式。
      static int WRAP_MODE
      常数用于将密码初始化为密钥包装模式。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Cipher​(CipherSpi cipherSpi, Provider provider, String transformation)
      创建一个Cipher对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] doFinal​()
      完成多部分加密或解密操作，这取决于该密码如何初始化。
      byte[] doFinal​(byte[] input)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int doFinal​(byte[] output, int outputOffset)
      完成多部分加密或解密操作，这取决于该密码如何初始化。
      byte[] doFinal​(byte[] input, int inputOffset, int inputLen)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int doFinal​(byte[] input, int inputOffset, int inputLen, byte[] output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int doFinal​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int doFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      String getAlgorithm​()
      返回此 Cipher对象的算法名称。
      int getBlockSize​()
      返回块大小（以字节为单位）。
      ExemptionMechanism getExemptionMechanism​()
      返回与此密码一起使用的豁免机制对象。
      static Cipher getInstance​(String transformation)
      返回实现指定转换的 Cipher对象。
      static Cipher getInstance​(String transformation, String provider)
      返回实现指定转换的 Cipher对象。
      static Cipher getInstance​(String transformation, Provider provider)
      返回实现指定转换的 Cipher对象。
      byte[] getIV​()
      返回新缓冲区中的初始化向量（IV）。
      static int getMaxAllowedKeyLength​(String transformation)
      根据已安装的JCE管辖区策略文件，返回指定转换的最大密钥长度。
      static AlgorithmParameterSpec getMaxAllowedParameterSpec​(String transformation)
      返回一个AlgorithmParameterSpec对象，该对象包含根据管辖区策略文件的最大密码参数值。
      int getOutputSize​(int inputLen)
      给定输入长度为 inputLen （以字节为单位），返回输出缓冲区需要保存下一个 update或 doFinal操作的结果的字节长度。
      AlgorithmParameters getParameters​()
      返回与此密码一起使用的参数。
      Provider getProvider​()
      返回此 Cipher对象的提供者。
      void init​(int opmode, Certificate certificate)
      使用给定证书中的公钥初始化此密码。
      void init​(int opmode, Certificate certificate, SecureRandom random)
      使用给定证书中的公钥和随机源初始化此密码。
      void init​(int opmode, Key key)
      用密钥初始化此密码。
      void init​(int opmode, Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此密码。
      void init​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      void init​(int opmode, Key key, SecureRandom random)
      用密钥和随机源初始化此密码。
      void init​(int opmode, Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此密码。
      void init​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      Key unwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
      打开以前包装的钥匙。
      byte[] update​(byte[] input)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      byte[] update​(byte[] input, int inputOffset, int inputLen)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      int update​(byte[] input, int inputOffset, int inputLen, byte[] output)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      int update​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      int update​(ByteBuffer input, ByteBuffer output)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      void updateAAD​(byte[] src)
      继续进行附加认证数据（AAD）的多部分更新。
      void updateAAD​(byte[] src, int offset, int len)
      使用所提供的缓冲区的子集，继续进行附加认证数据（AAD）的多部分更新。
      void updateAAD​(ByteBuffer src)
      继续进行附加认证数据（AAD）的多部分更新。
      byte[] wrap​(Key key)
      包裹钥匙

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ENCRYPT_MODE

        public static final int ENCRYPT_MODE
        常数用于将密码初始化为加密模式。
        另请参见：
        Constant Field Values

      • DECRYPT_MODE

        public static final int DECRYPT_MODE
        常数用于将密码初始化为解密模式。
        另请参见：
        Constant Field Values

      • WRAP_MODE

        public static final int WRAP_MODE
        常数用于将密码初始化为密钥包装模式。
        另请参见：
        Constant Field Values

      • UNWRAP_MODE

        public static final int UNWRAP_MODE
        常数用于将密码初始化为密钥解包模式。
        另请参见：
        Constant Field Values

      • PUBLIC_KEY

        public static final int PUBLIC_KEY
        用于指示待解除密钥的常数是“公钥”。
        另请参见：
        Constant Field Values

      • PRIVATE_KEY

        public static final int PRIVATE_KEY
        用于指示要解除密钥的常数是“私钥”。
        另请参见：
        Constant Field Values

      • SECRET_KEY

        public static final int SECRET_KEY
        用于指示要解开的密钥的常数是“密钥”。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Cipher

        protected Cipher​(CipherSpi cipherSpi,
                 Provider provider,
                 String transformation)
        创建一个Cipher对象。
        参数
        cipherSpi - 代表
        provider - 提供商
        transformation - 转型

    • 方法详细信息

      • getInstance

        public static final Cipher getInstance​(String transformation)
                                throws NoSuchAlgorithmException,
                                       NoSuchPaddingException
        返回实现指定转换的Cipher对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装CipherSpi实现的新Cipher对象。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        transformation - 转换的名称，例如DES / CBC / PKCS5Padding 。 有关标准转换名称的信息，请参阅Java Security Standard Algorithm Names Specification中的密码部分。
        结果
        一个实现请求的转换的密码
        异常
        NoSuchAlgorithmException - 如果 transformation为 null ，为空，格式无效，或者如果没有 Provider支持指定算法的 CipherSpi实现
        NoSuchPaddingException - 如果 transformation包含不可用的填充方案
        另请参见：
        Provider

      • getInstance

        public static final Cipher getInstance​(String transformation,
                                       String provider)
                                throws NoSuchAlgorithmException,
                                       NoSuchProviderException,
                                       NoSuchPaddingException
        返回实现指定转换的Cipher对象。

        返回从指定提供程序封装CipherSpi实现的新Cipher对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        transformation - 转换的名称，例如DES / CBC / PKCS5Padding 。 有关标准转换名称的信息，请参阅Java Security Standard Algorithm Names Specification中的“密码”部分。
        provider - 提供商的名称。
        结果
        一个实现请求的转换的密码
        异常
        IllegalArgumentException - 如果 provider是 null或空
        NoSuchAlgorithmException - 如果 transformation为 null ，为空，格式无效，或者指定算法的 CipherSpi实现不能从指定的提供者获得
        NoSuchPaddingException - 如果 transformation包含不可用的填充方案
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        另请参见：
        Provider

      • getInstance

        public static final Cipher getInstance​(String transformation,
                                       Provider provider)
                                throws NoSuchAlgorithmException,
                                       NoSuchPaddingException
        返回实现指定转换的Cipher对象。

        返回从指定的Provider对象封装CipherSpi实现的新Cipher对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        transformation - 转换的名称，例如DES / CBC / PKCS5Padding 。 有关标准转换名称的信息，请参阅Java Security Standard Algorithm Names Specification中的“密码”部分。
        provider - 提供商。
        结果
        一个实现请求的转换的密码
        异常
        IllegalArgumentException - 如果 provider是 null
        NoSuchAlgorithmException - 如果 transformation为 null ， null空，格式无效，或者指定的算法的 CipherSpi实现不能从指定的 Provider对象获得
        NoSuchPaddingException - 如果 transformation包含不可用的填充方案
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此 Cipher对象的提供者。
        结果
        这个 Cipher对象的提供者

      • getAlgorithm

        public final String getAlgorithm​()
        返回此Cipher对象的算法名称。

        这是在创建此Cipher对象的getInstance呼叫之一中指定的名称。

        结果
        这个 Cipher对象的算法名称。

      • getBlockSize

        public final int getBlockSize​()
        返回块大小（以字节为单位）。
        结果
        块大小（以字节为单位），如果底层算法不是块密码，则为0

      • getOutputSize

        public final int getOutputSize​(int inputLen)
        给定输入长度为inputLen （以字节为单位），返回输出缓冲区需要保存下一个update或doFinal操作的结果的字节长度。

        此呼叫考虑了来自以前的update呼叫，填充和AEAD标记的任何未处理（缓冲）数据。

        下一个update或doFinal调用的实际输出长度可能小于此方法返回的长度。

        参数
        inputLen - 输入长度（以字节为单位）
        结果
        所需的输出缓冲区大小（以字节为单位）
        异常
        IllegalStateException - 如果此密码处于错误状态（例如尚未初始化）

      • getIV

        public final byte[] getIV​()
        返回新缓冲区中的初始化向量（IV）。

        这在创建随机IV的情况下或在基于密码的加密或解密的情况下是有用的，其中IV是从用户提供的密码导出的。

        结果
        新缓冲区中的初始化向量，如果底层算法不使用IV，或者如果IV尚未设置，则为null。

      • getParameters

        public final AlgorithmParameters getParameters​()
        返回与此密码一起使用的参数。

        返回的参数可能与用于初始化此密码的参数相同，或者如果该密码需要算法参数但未被任何初始化，则可能包含底层密码实现使用的默认值和随机参数值的组合。

        结果
        与此密码一起使用的参数，如果此密码不使用任何参数，则为null。

      • getExemptionMechanism

        public final ExemptionMechanism getExemptionMechanism​()
        返回与此密码一起使用的豁免机制对象。
        结果
        与此密码一起使用的豁免机制对象，如果此密码不使用任何豁免机制，则为null。

      • init

        public final void init​(int opmode,
                       Key key)
                throws InvalidKeyException
        用密钥初始化此密码。

        根据opmode的值，对以下四个操作之一进行密码初始化：加密，解密，密钥包装或密钥解opmode 。

        如果此密码需要不能从给定的key导出的任何算法参数，则底层加密实现应该自动生成所需参数（使用特定于提供者的默认值或随机值），如果它被初始化为加密或密钥包装，以及提出一个InvalidKeyException如果它被初始化解密或密钥解包。 可以使用getParameters或getIV （如果参数为IV）检索生成的参数。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），则将使用最高优先级安装的提供者的SecureRandom实现作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，将会使用系统提供的随机源。）

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        key - 关键
        异常
        InvalidKeyException - 如果给定的密钥 InvalidKeyException初始化该密码，或者需要不能从给定密钥确定的算法参数，或者给定的密钥具有超过最大允许密钥大小的密钥大小（从配置的管辖区策略文件确定） 。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE但是模式不是由底层的 CipherSpi实现的。

      • init

        public final void init​(int opmode,
                       Key key,
                       SecureRandom random)
                throws InvalidKeyException
        用密钥和随机源初始化此密码。

        根据opmode的值，密码被初始化为以下四个操作之一：加密，解密，密钥包装或密钥解opmode 。

        如果此密码需要不能从给定的key导出的任何算法参数，则底层加密实现应该自动生成所需参数（使用提供者特定的默认值或随机值），如果它被初始化为加密或密钥包装，以及如果正在初始化解密或密钥解包，请提出一个InvalidKeyException 。 可以使用getParameters或getIV （如果参数为IV）检索生成的参数。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），它将从random得到它们。

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        key - 加密密钥
        random - 随机性的来源
        异常
        InvalidKeyException - 如果给定的密钥 InvalidKeyException初始化该密码，或者需要不能从给定密钥确定的算法参数，或者如果给定密钥具有超过最大允许密钥大小的密钥大小（从配置的管辖区策略文件确定） 。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE但是模式不是由底层的 CipherSpi实现的。

      • init

        public final void init​(int opmode,
                       Key key,
                       AlgorithmParameterSpec params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
        使用密钥和一组算法参数初始化此密码。

        根据opmode的值，密码被初始化为以下四个操作之一：加密，解密，密钥包装或密钥解opmode 。

        如果此密码需要任何算法参数，并且params为null，则底层加密实现应该自动生成所需参数（使用特定于提供者的默认值或随机值），如果正在初始化加密或密钥包装，并提出一个InvalidAlgorithmParameterException if正在为解密或密钥解包进行初始化。 生成的参数可以使用getParameters或getIV （如果参数为IV）检索。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），则将使用最高优先级安装的提供者的SecureRandom实现作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，将会使用系统提供的随机源。）

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        key - 加密密钥
        params - 算法参数
        异常
        InvalidKeyException - 如果给定的密钥不适用于初始化此密码，或者其keysize超过最大允许密钥大小（从配置的管辖区策略文件确定）。
        InvalidAlgorithmParameterException - 如果给定的算法参数不适用于此密码，或者该密码需要算法参数，并且 params为空，或者给定的算法参数意味着超过合法限制的密码强度（由配置的管辖区策略文件确定）。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE但模式不是由底层的 CipherSpi实现的。

      • init

        public final void init​(int opmode,
                       Key key,
                       AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
        使用密钥，一组算法参数和随机源初始化此密码。

        根据opmode的值，密码被初始化为以下四个操作之一：加密，解密，密钥包装或密钥解opmode 。

        如果此密码需要任何算法参数，并且params为null，则底层加密实现应该自动生成所需参数（使用特定于提供者的默认值或随机值），如果它被初始化为加密或密钥包装，并提出一个InvalidAlgorithmParameterException if正在为解密或密钥解包进行初始化。 可以使用getParameters或getIV （如果参数为IV）检索生成的参数。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），它将从random获得。

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        key - 加密密钥
        params - 算法参数
        random - 随机性的来源
        异常
        InvalidKeyException - 如果给定的密钥不适合初始化此密码，或者其keysize超过了最大允许密钥大小（从配置的管辖区策略文件确定）。
        InvalidAlgorithmParameterException - 如果给定的算法参数不适合该密码，或者该密码需要算法参数，并且 params为空，或者给定的算法参数意味着超过合法限制（从配置的管辖区策略文件确定）的加密强度。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE但是模式不是由底层的 CipherSpi实现的。

      • init

        public final void init​(int opmode,
                       Key key,
                       AlgorithmParameters params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
        使用密钥和一组算法参数初始化此密码。

        根据opmode的值，为以下四个操作之一初始化加密：加密，解密，密钥包装或密钥解opmode 。

        如果此密码需要任何算法参数，并且params为null，则底层加密实现应该自动生成所需参数（使用特定于提供者的默认值或随机值），如果正在初始化加密或密钥包装，并提出一个InvalidAlgorithmParameterException if正在为解密或密钥解包进行初始化。 生成的参数可以使用getParameters或getIV （如果参数为IV）检索。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），它将使用最高优先级安装的提供商的SecureRandom实现作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，将会使用系统提供的随机源。）

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        key - 加密密钥
        params - 算法参数
        异常
        InvalidKeyException - 如果给定的密钥不适合初始化此密码，或者其keysize超过允许的最大密钥大小（根据配置的管辖区策略文件确定）。
        InvalidAlgorithmParameterException - 如果给定的算法参数不适合该密码，或者该密码需要算法参数，并且 params为空，或者给定的算法参数意味着超过合法限制（从配置的管辖区策略文件确定）的加密强度。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE但是模式不是由底层的 CipherSpi实现的。

      • init

        public final void init​(int opmode,
                       Key key,
                       AlgorithmParameters params,
                       SecureRandom random)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
        使用密钥，一组算法参数和随机源初始化此密码。

        根据opmode的值，密码被初始化为以下四个操作之一：加密，解密，密钥包装或密钥解opmode 。

        如果此密码需要任何算法参数，并且params为null，则底层加密实现应该自动生成所需参数（使用特定于提供者的默认值或随机值），如果它被初始化为加密或密钥包装，并提出一个InvalidAlgorithmParameterException if正在为解密或密钥解包进行初始化。 可以使用getParameters或getIV （如果参数为IV）检索生成的参数。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），它将从random获得。

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        key - 加密密钥
        params - 算法参数
        random - 随机性的来源
        异常
        InvalidKeyException - 如果给定的密钥不适合初始化此密码，或者其keysize超过了允许的最大密钥大小（从配置的管辖区策略文件中确定）。
        InvalidAlgorithmParameterException -如果给定的算法参数不适合此cipher，或此cipher要求使用算法参数和 params为空，或者给定的算法参数所含的加密强度将超过法律限制（由已配置的仲裁策略文件确定）。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE但是模式不是由底层的 CipherSpi实现的。

      • init

        public final void init​(int opmode,
                       Certificate certificate)
                throws InvalidKeyException
        使用给定证书中的公钥初始化此密码。

        根据opmode的值，密码被初始化为以下四个操作之一：加密，解密，密钥包装或密钥解opmode 。

        如果证书是类型X.509，并且密钥使用扩展字段被标记为关键，并且密钥使用扩展字段的值意味着证书中的公钥及其相应的私钥不应被用于操作代表opmode的值，一个InvalidKeyException被抛出。

        如果该密码需要任何不能从给定证书中的公开密钥导出的算法参数，则底层密码实现应该自动生成所需参数（使用特定于提供者的默认值或随机值），如果它被初始化为加密，密钥包装，并提出一个InvalidKeyException如果正在初始化解密或密钥解包。 可以使用getParameters或getIV （如果参数为IV）检索生成的参数。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），则将使用最高优先级安装的提供者的SecureRandom实现作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，将会使用系统提供的随机源。）

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        certificate - 证书
        异常
        InvalidKeyException - 如果给定证书中的公钥不适合初始化该密码，或者该密码需要不能从给定证书中的公钥确定的算法参数，或给定证书中的公钥密钥大小具有密钥大小超过最大允许密钥大小（由配置的管辖区策略文件确定）。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE但是模式不是由底层的 CipherSpi实现的。

      • init

        public final void init​(int opmode,
                       Certificate certificate,
                       SecureRandom random)
                throws InvalidKeyException
        使用给定证书中的公钥和随机源初始化此密码。

        根据opmode的值，为以下四个操作之一初始化加密：加密，解密，密钥包装或密钥解opmode 。

        如果证书是类型X.509，并且密钥使用扩展字段被标记为关键，并且密钥使用扩展字段的值意味着证书中的公钥及其相应的私钥不应被用于操作由opmode ，抛出InvalidKeyException 。

        如果该密码需要在给定的certificate不能从公钥中导出的任何算法参数，则底层加密实现应该自动生成所需参数（使用特定于提供者的默认值或随机值），如果它被初始化为加密，密钥包装，并提出一个InvalidKeyException如果它被初始化解密或密钥解包。 生成的参数可以使用getParameters或getIV （如果参数为IV）检索。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），它将从random获得。

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        certificate - 证书
        random - 随机的来源
        异常
        InvalidKeyException - 如果给定证书中的公钥不适合初始化该密码，或者该密码需要不能根据给定证书中的公开密钥确定算法参数，或给定证书中公开密钥的keyize具有密钥长度超过最大允许密钥大小（由配置的管辖区策略文件确定）。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE但模式不是由底层的 CipherSpi实现的。

      • update

        public final byte[] update​(byte[] input)
        继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。

        处理input缓冲区中的字节，结果存储在新的缓冲区中。

        如果input的长度为零，此方法返回null 。

        参数
        input - 输入缓冲区
        结果
        具有结果的新缓冲区，如果底层密码是块密码，并且输入数据太短，导致新的块，则为null。
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）

      • update

        public final byte[] update​(byte[] input,
                           int inputOffset,
                           int inputLen)
        继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。

        第一inputLen字节在input缓冲区中，从inputOffset以下，被处理，并且结果被存储在新的缓冲器。

        如果inputLen为零，此方法返回null 。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        结果
        具有结果的新缓冲区，如果底层密码是块密码，并且输入数据太短，导致新的块，则为null。
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）

      • update

        public final int update​(byte[] input,
                        int inputOffset,
                        int inputLen,
                        byte[] output)
                 throws ShortBufferException
        继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。

        第一inputLen字节在input缓冲区中，从inputOffset以下，被处理，并且结果被存储在output缓冲器。

        如果output缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用getOutputSize确定输出缓冲区应该有多大。

        如果inputLen为零，则此方法返回零长度。

        注意：该方法应该是复制安全的，这意味着input和output缓冲区可以引用相同的字节数组，当结果被复制到输出缓冲区中时，没有未处理的输入数据被覆盖。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        output - 结果的缓冲区
        结果
        output存储的字节数
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果

      • update

        public final int update​(byte[] input,
                        int inputOffset,
                        int inputLen,
                        byte[] output,
                        int outputOffset)
                 throws ShortBufferException
        继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。

        第一inputLen字节在input缓冲区中，从inputOffset以下，被处理，并且结果被存储在output缓冲区中，从outputOffset以下。

        如果output缓冲区太小而不能保存结果，则抛出ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用getOutputSize来确定输出缓冲区应该有多大。

        如果inputLen为零，则此方法返回零长度。

        注意：该方法应该是安全的，这意味着input和output缓冲区可以引用相同的字节数组，并且当结果被复制到输出缓冲区中时，没有未处理的输入数据被覆盖。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        output - 结果的缓冲区
        outputOffset - output中存储结果的偏移量
        结果
        output存储的字节数
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果

      • update

        public final int update​(ByteBuffer input,
                        ByteBuffer output)
                 throws ShortBufferException
        继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。

        所有input.remaining()起始字节input.position()被处理。 结果存储在输出缓冲区中。 返回时，输入缓冲区的位置将等于其限制; 其限制将不会改变。 输出缓冲区的位置将提前n，其中n是此方法返回的值; 输出缓冲区的限制将不会改变。

        如果output.remaining()字节不足以保存结果，则抛出ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用getOutputSize来确定输出缓冲区应该有多大。

        注意：该方法应该是复制安全的，这意味着input和output缓冲区可以引用相同的内存块，并且当结果被复制到输出缓冲区中时，没有未处理的输入数据被覆盖。

        参数
        input - 输入ByteBuffer
        output - 输出ByteByffer
        结果
        output存储的字节数
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        IllegalArgumentException - 如果输入和输出是相同的对象
        ReadOnlyBufferException - 输出缓冲区是否为只读
        ShortBufferException - 输出缓冲区空间不足的情况
        从以下版本开始：
        1.5

      • doFinal

        public final byte[] doFinal​()
                     throws IllegalBlockSizeException,
                            BadPaddingException
        完成多部分加密或解密操作，这取决于该密码如何初始化。

        在以前的update操作中可能已经缓冲的输入数据被处理，并且应用填充（如果请求）。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在一个新的缓冲区。

        完成后，该方法将此密码对象重置为先前通过调用init初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用init指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        结果
        新的缓冲区结果
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        IllegalBlockSizeException - 如果该密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        BadPaddingException - 如果该密码处于解密模式，并且已经请求了（un）填充，但是解密的数据不受适当的填充字节的限制
        AEADBadTagException - 如果该密码在AEAD模式（例如GCM / CCM）中解密，并且接收到的认证标签与计算值不匹配

      • doFinal

        public final int doFinal​(byte[] output,
                         int outputOffset)
                  throws IllegalBlockSizeException,
                         ShortBufferException,
                         BadPaddingException
        完成多部分加密或解密操作，这取决于该密码如何初始化。

        在以前的update操作中可能已经缓冲的输入数据被处理，并且应用填充（如果请求）。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在output缓冲区中，从outputOffset开始。

        如果output缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用getOutputSize确定输出缓冲区应该有多大。

        完成后，该方法将此密码对象重置为先前通过调用init初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用init指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        参数
        output - 结果的缓冲区
        outputOffset - output中存储结果的偏移量
        结果
        output存储的字节数
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        IllegalBlockSizeException - 如果该密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果
        BadPaddingException - 如果此密码处于解密模式，并且（un）填充已被请求，但是解密的数据不受适当的填充字节的限制
        AEADBadTagException - 如果该密码在AEAD模式（如GCM / CCM）中解密，并且接收的认证标签与计算值不匹配

      • doFinal

        public final byte[] doFinal​(byte[] input)
                     throws IllegalBlockSizeException,
                            BadPaddingException
        在单一部分操作中加密或解密数据，或完成多部分操作。 数据被加密或解密，这取决于这个密码如何初始化。

        input缓冲区中的字节以及在以前的update操作中可能已缓冲的任何输入字节都将被处理，并应用填充（如果请求）。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在一个新的缓冲区。

        完成后，该方法将此密码对象重置为先前通过调用init初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用init指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        参数
        input - 输入缓冲区
        结果
        新的缓冲区结果
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        IllegalBlockSizeException - 如果此密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        BadPaddingException - 如果该密码处于解密模式，并且已经请求了（un）填充，但是解密的数据不受适当的填充字节的限制
        AEADBadTagException - 如果该密码在AEAD模式（如GCM / CCM）中解密，并且接收的认证标签与计算值不匹配

      • doFinal

        public final byte[] doFinal​(byte[] input,
                            int inputOffset,
                            int inputLen)
                     throws IllegalBlockSizeException,
                            BadPaddingException
        在单一部分操作中加密或解密数据，或完成多部分操作。 数据被加密或解密，这取决于这个密码如何初始化。

        第一inputLen字节在input缓冲区中，从inputOffset以下，并且可能在上一次期间已缓存的任何输入字节update操作，进行处理，填充（如果要求）被施加。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在一个新的缓冲区。

        完成后，该方法将此密码对象重置为先前通过调用init初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用init指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        结果
        新的缓冲区结果
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        IllegalBlockSizeException - 如果该密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        BadPaddingException - 如果此密码处于解密模式，并且（un）填充已被请求，但解密的数据不受适当的填充字节的约束
        AEADBadTagException - 如果该密码在AEAD模式（如GCM / CCM）中解密，并且接收的认证标签与计算值不匹配

      • doFinal

        public final int doFinal​(byte[] input,
                         int inputOffset,
                         int inputLen,
                         byte[] output)
                  throws ShortBufferException,
                         IllegalBlockSizeException,
                         BadPaddingException
        在单一部分操作中加密或解密数据，或完成多部分操作。 数据被加密或解密，这取决于这个密码如何初始化。

        第一inputLen字节在input缓冲区中，从inputOffset以下，并且可能在上一次期间已缓存的任何输入字节update操作，进行处理，填充（如果要求）被施加。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在output缓冲区中。

        如果output缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用getOutputSize来确定输出缓冲区应该有多大。

        完成后，此方法将此密码对象重置为先前通过调用init初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用init指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        注意：该方法应该是复制安全的，这意味着input和output缓冲区可以引用相同的字节数组，当结果被复制到输出缓冲区中时，没有未处理的输入数据被覆盖。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        output - 结果的缓冲区
        结果
        output存储的字节数
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        IllegalBlockSizeException - 如果此密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果
        BadPaddingException - 如果此密码处于解密模式，并且（un）填充已被请求，但解密的数据不受适当的填充字节的限制
        AEADBadTagException - 如果该密码在AEAD模式（例如GCM / CCM）中解密，并且接收的认证标签与计算值不匹配

      • doFinal

        public final int doFinal​(byte[] input,
                         int inputOffset,
                         int inputLen,
                         byte[] output,
                         int outputOffset)
                  throws ShortBufferException,
                         IllegalBlockSizeException,
                         BadPaddingException
        在单一部分操作中加密或解密数据，或完成多部分操作。 数据被加密或解密，这取决于这个密码如何初始化。

        第一inputLen字节在input缓冲区中，从inputOffset以下，并且可能在上一次期间已缓存的任何输入字节update操作，进行处理，填充（如果要求）被施加。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在output缓冲区中，从outputOffset开始。

        如果output缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用getOutputSize确定输出缓冲区应该有多大。

        完成后，此方法将此密码对象重置为先前通过调用init初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用init指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        注意：该方法应该是安全的，这意味着input和output缓冲区可以引用相同的字节数组，当结果被复制到输出缓冲区中时，没有未处理的输入数据被覆盖。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        output - 结果的缓冲区
        outputOffset - output中存储结果的偏移量
        结果
        output存储的字节数
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        IllegalBlockSizeException - 如果该密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果
        BadPaddingException - 如果该密码处于解密模式，并且已经请求了（un）填充，但解密的数据不受适当的填充字节的限制
        AEADBadTagException - 如果该密码在AEAD模式（如GCM / CCM）中解密，并且接收的认证标签与计算值不匹配

      • doFinal

        public final int doFinal​(ByteBuffer input,
                         ByteBuffer output)
                  throws ShortBufferException,
                         IllegalBlockSizeException,
                         BadPaddingException
        在单一部分操作中加密或解密数据，或完成多部分操作。 数据被加密或解密，这取决于这个密码如何初始化。

        所有input.remaining()起始字节input.position()被处理。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在输出缓冲区中。 返回时，输入缓冲区的位置将等于其限制; 其限制将不会改变。 输出缓冲区的位置将提前n，其中n是此方法返回的值; 输出缓冲区的限制将不会改变。

        如果output.remaining()字节不足以保存结果，则抛出ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用getOutputSize来确定输出缓冲区应该有多大。

        完成后，此方法将此密码对象重置为先前通过调用init初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用init指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        注意：该方法应该是安全的，这意味着input和output缓冲区可以引用相同的字节数组，当结果被复制到输出缓冲区中时，没有未处理的输入数据被覆盖。

        参数
        input - 输入ByteBuffer
        output - 输出ByteBuffer
        结果
        output存储的字节数
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）
        IllegalArgumentException - 如果输入和输出是相同的对象
        ReadOnlyBufferException - 输出缓冲区是否为只读
        IllegalBlockSizeException - 如果该密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        ShortBufferException - 输出缓冲区空间不足
        BadPaddingException - 如果该密码处于解密模式，并且已经请求了（un）填充，但是解密的数据不受适当的填充字节的限制
        AEADBadTagException - 如果该密码在AEAD模式（例如GCM / CCM）中解密，并且接收到的认证标签与计算值不匹配
        从以下版本开始：
        1.5

      • wrap

        public final byte[] wrap​(Key key)
                  throws IllegalBlockSizeException,
                         InvalidKeyException
        包裹钥匙
        参数
        key - 要包装的关键。
        结果
        包裹的钥匙。
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）。
        IllegalBlockSizeException - 如果该密码是块密码，则不需要填充，并且要包装的密钥的编码长度不是块大小的倍数。
        InvalidKeyException - 如果使用该密码将密钥包装是不可能或不安全的（例如，硬件保护密钥正在传递给仅软件密码）。
        UnsupportedOperationException - 如果不支持 CipherSpi的相应方法。

      • unwrap

        public final Key unwrap​(byte[] wrappedKey,
                        String wrappedKeyAlgorithm,
                        int wrappedKeyType)
                 throws InvalidKeyException,
                        NoSuchAlgorithmException
        打开以前包装的钥匙。
        参数
        wrappedKey - 要解开的关键。
        wrappedKeyAlgorithm - 与包裹密钥相关联的算法。
        wrappedKeyType - 包装密钥的类型。 这必须是一个SECRET_KEY ， PRIVATE_KEY ，或PUBLIC_KEY 。
        结果
        展开的钥匙。
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化）。
        NoSuchAlgorithmException - 如果没有安装的提供商可以为 wrappedKeyType创建类型为 wrappedKeyType的 wrappedKeyAlgorithm 。
        InvalidKeyException - 如果 wrappedKey不表示 wrappedKeyType的 wrappedKeyAlgorithm类型的打包密钥。
        UnsupportedOperationException - 如果不支持 CipherSpi的相应方法。

      • getMaxAllowedKeyLength

        public static final int getMaxAllowedKeyLength​(String transformation)
                                        throws NoSuchAlgorithmException
        根据已安装的JCE管辖区策略文件，返回指定转换的最大密钥长度。 如果安装JCE无限制权限策略文件，则返回Integer.MAX_VALUE。 有关默认密钥大小和JCE管辖区策略文件的更多信息，请参阅JDK Providers Documentation中的加密默认值和限制。
        参数
        transformation - 密码转换。
        结果
        最大密钥长度，以位或Integer.MAX_VALUE为单位。
        异常
        NullPointerException - 如果 transformation为空。
        NoSuchAlgorithmException - 如果 transformation不是有效的转换，即以“算法”或“算法/模式/填充”的形式。
        从以下版本开始：
        1.5

      • getMaxAllowedParameterSpec

        public static final AlgorithmParameterSpec getMaxAllowedParameterSpec​(String transformation)
                                                               throws NoSuchAlgorithmException
        返回一个AlgorithmParameterSpec对象，该对象包含根据管辖区策略文件的最大密码参数值。 如果安装了JCE无限制权限策略文件，或策略文件中指定转换的参数没有最大限制，则返回null。
        参数
        transformation - 密码转换。
        结果
        一个保存最大值的AlgorithmParameterSpec或null。
        异常
        NullPointerException - 如果 transformation为空。
        NoSuchAlgorithmException - 如果 transformation不是有效的转换，即以“算法”或“算法/模式/填充”的形式。
        从以下版本开始：
        1.5

      • updateAAD

        public final void updateAAD​(byte[] src)
        继续进行附加认证数据（AAD）的多部分更新。

        当使用AEAD（GCM / CCM）等模式运行时，调用此方法可以为密码提供AAD。 如果此密码在GCM或CCM模式下运行，则必须在密文开始操作之前（通过update和doFinal方法）提供所有AAD。

        参数
        src - 包含其他认证数据的缓冲区
        异常
        IllegalArgumentException - 如果 src字节数组为空
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化），则不接受AAD，或者如果在GCM或CCM模式下运行，并且 update方法之一已被调用用于主动加密/解密操作
        UnsupportedOperationException -如果在相应的方法 CipherSpi尚未覆盖的实现
        从以下版本开始：
        1.7

      • updateAAD

        public final void updateAAD​(byte[] src,
                            int offset,
                            int len)
        使用所提供的缓冲区的子集，继续进行附加认证数据（AAD）的多部分更新。

        当使用AEAD（GCM / CCM）等模式运行时，调用此方法可以为密码提供AAD。 如果此密码在GCM或CCM模式下运行，则必须在密文开始操作之前（通过update和doFinal方法）提供所有AAD。

        参数
        src - 包含AAD的缓冲区
        offset - 其中AAD输入开始的 src中的偏移量
        len - AAD字节数
        异常
        IllegalArgumentException - 如果 src字节数组为空，或 offset或 length小于0，或 offset和 len的总和大于 src字节数组的长度
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化），则不接受AAD，或者以GCM或CCM模式运行，并且已经为 update方法之一调用了主动加密/解密操作
        UnsupportedOperationException -如果在相应的方法 CipherSpi尚未覆盖的实现
        从以下版本开始：
        1.7

      • updateAAD

        public final void updateAAD​(ByteBuffer src)
        继续进行附加认证数据（AAD）的多部分更新。

        当使用AEAD（GCM / CCM）等模式运行时，调用此方法可以为密码提供AAD。 如果此密码在GCM或CCM模式下运行，则必须在密文开始操作之前（通过update和doFinal方法）提供所有AAD。

        所有src.remaining()起始字节src.position()被处理。 返回时，输入缓冲区的位置将等于其限制; 其限制将不会改变。

        参数
        src - 包含AAD的缓冲区
        异常
        IllegalArgumentException - 如果 src ByteBuffer为空
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化），则不接受AAD，或者如果在GCM或CCM模式下运行，并且已经为 update方法之一调用了主动加密/解密操作
        UnsupportedOperationException -如果在相应的方法 CipherSpi尚未覆盖的实现
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


CipherInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class CipherInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • javax.crypto.CipherInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class CipherInputStream
extends FilterInputStream
    CipherInputStream由InputStream和Cipher组成，使得read（）方法返回从底层InputStream读入但是由Cipher额外处理的数据。 密码必须在被CipherInputStream使用之前完全初始化。

    例如，如果将密码初始化为解密，则CipherInputStream将在返回解密的数据之前尝试读取数据并将其解密。

    该类严格遵守其祖先类java.io.FilterInputStream和java.io.InputStream的语义，特别是失败语义。 这个类只有在其祖先类中指定的方法，并覆盖它们全部。 此外，此类捕获其祖先类不抛出的所有异常。 特别地， skip方法跳过，而available方法仅计算已封装密码处理的数据。

    对于使用此类的程序员，不要使用在此类中未定义或覆盖的方法（例如后来添加到其中一个超类的新方法或构造函数），因为这些方法的设计和实现不太可能考虑到对CipherInputStream的安全性影响。

    从以下版本开始：
    1.4
    另请参见：
    InputStream ， FilterInputStream ， Cipher ， CipherOutputStream

    • Field Summary

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CipherInputStream​(InputStream is)
      从InputStream构造CipherInputStream，而不指定密码。
        CipherInputStream​(InputStream is, Cipher c)
      从InputStream和Cipher构造一个CipherInputStream。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      返回可以从该输入流读取而不阻塞的字节数。
      void close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      boolean markSupported​()
      测试这个输入流是否支持 mark和 reset方法，而不是。
      int read​()
      从该输入流读取下一个数据字节。
      int read​(byte[] b)
      从该输入流读取最多 b.length字节的数据到字节数组。
      int read​(byte[] b, int off, int len)
      从该输入流读取最多 len个字节的数据为字节数组。
      long skip​(long n)
      跳过 n字节的字节，可从该输入流中读取而不阻塞。

      • Methods inherited from class java.io.FilterInputStream

        mark, reset

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CipherInputStream

        public CipherInputStream​(InputStream is,
                         Cipher c)
        从InputStream和Cipher构造一个CipherInputStream。
        注意：如果指定的输入流或密码为空，则在使用NullPointerException时可能会稍后抛出。
        参数
        is - 要处理的输入流
        c - 一个初始化的Cipher对象

      • CipherInputStream

        protected CipherInputStream​(InputStream is)
        从InputStream构造CipherInputStream，而不指定密码。 这具有使用NullCipher构造CipherInputStream的效果。
        注意：如果指定的输入流为空，则在使用NullPointerException时可能会稍后抛出。
        参数
        is - 要处理的输入流

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        从该输入流读取下一个数据字节。 值字节作为int返回，范围为0至255 。 如果没有字节可用，因为流已经到达，则返回值-1 。 该方法阻塞直到输入数据可用，检测到流的结尾，或抛出异常。
        重写：
        read在 FilterInputStream
        结果
        数据的下一个字节，如果达到流的末尾， -1 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterInputStream.in

      • read

        public int read​(byte[] b)
         throws IOException
        从该输入流读取最多b.length个字节的数据为字节数组。

        该read的方法InputStream调用read的三个参数方法与参数b ， 0 ，并b.length 。

        重写：
        read在 FilterInputStream
        参数
        b - 读取数据的缓冲区。
        结果
        读入缓冲区的总字节数，或 -1是没有更多的数据，因为已经到达流的结束。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        InputStream.read(byte[], int, int)

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从该输入流读取最多len个字节的数据为字节数组。 此方法将阻塞，直到某些输入可用。 如果第一个参数是null,最多len个字节被读取并丢弃。
        重写：
        read在 FilterInputStream
        参数
        b - 读取数据的缓冲区。
        off - 目标阵列中的起始偏移量 buf
        len - 读取的最大字节数。
        结果
        读入缓冲区的总字节数，如果没有更多的数据，因为已经到达流的末尾，那么 -1 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        InputStream.read()

      • skip

        public long skip​(long n)
          throws IOException
        从可从该输入流读取的字节中跳过n字节的字节，无阻塞。

        可能会跳过比请求的字节少的字节。 跳过的实际字节数等于n或调用available的结果，以较小者为准。 如果n小于0，则不会跳过任何字节。

        返回实际跳过的字节数。

        重写：
        skip在 FilterInputStream
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果发生I / O错误。

      • available

        public int available​()
              throws IOException
        返回可以从该输入流读取而不阻塞的字节数。 该available方法InputStream回报0 。 这个方法应该被子类覆盖。
        重写：
        available在 FilterInputStream
        结果
        可以从此输入流中读取而不阻塞的字节数。
        异常
        IOException - 如果发生I / O错误。

      • close

        public void close​()
           throws IOException
        关闭此输入流并释放与流相关联的任何系统资源。

        该close的方法CipherInputStream调用close其底层输入流的方法。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 FilterInputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterInputStream.in

      • markSupported

        public boolean markSupported​()
        测试这个输入流是否支持 mark和 reset方法，而不是。
        重写：
        markSupported在 FilterInputStream
        结果
        false ，因为这个类不支持 mark和 reset方法。
        另请参见：
        InputStream.mark(int) ， InputStream.reset()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CipherOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class CipherOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • javax.crypto.CipherOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class CipherOutputStream
extends FilterOutputStream
    CipherOutputStream由OutputStream和Cipher组成，以便write（）方法首先在将数据写入底层OutputStream之前处理数据。 密码必须在被CipherOutputStream使用之前被完全初始化。

    例如，如果将密码初始化为加密，CipherOutputStream会在写出加密数据之前尝试加密数据。

    该类严格遵守其祖先类java.io.OutputStream和java.io.FilterOutputStream的语义，特别是失败语义。 这个类只有在其祖先类中指定的方法，并覆盖它们全部。 此外，此类捕获其祖先类不抛出的所有异常。

    对于使用此类的程序员，不要使用在此类中未定义或覆盖的方法（例如后来添加到其中一个超类的新方法或构造函数），因为这些方法的设计和实现不太可能考虑到对CipherOutputStream的安全影响。

    从以下版本开始：
    1.4
    另请参见：
    OutputStream ， FilterOutputStream ， Cipher ， CipherInputStream

    • Field Summary

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CipherOutputStream​(OutputStream os)
      在不指定密码的情况下，从OutputStream构造CipherOutputStream。
        CipherOutputStream​(OutputStream os, Cipher c)
      从OutputStream和Cipher构造一个CipherOutputStream。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此输出流并释放与此流相关联的任何系统资源。
      void flush​()
      通过强制已经由封装的密码对象处理的任何缓冲的输出字节被写出来刷新输出流。
      void write​(byte[] b)
      将 b.length字节从指定的字节数组写入此输出流。
      void write​(byte[] b, int off, int len)
      从指定的字节数组写入 len字节，从偏移量 off开始输出到此输出流。
      void write​(int b)
      将指定的字节写入此输出流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CipherOutputStream

        public CipherOutputStream​(OutputStream os,
                          Cipher c)
        从OutputStream和Cipher构造一个CipherOutputStream。
        注意：如果指定的输出流或密码为空，则NullPointerException在使用时可能会被稍后抛出。
        参数
        os - OutputStream对象
        c - 一个初始化的Cipher对象

      • CipherOutputStream

        protected CipherOutputStream​(OutputStream os)
        在不指定密码的情况下，从OutputStream构造CipherOutputStream。 这具有使用NullCipher构造CipherOutputStream的效果。
        注意：如果指定的输出流为空，则使用NullPointerException可能会稍后抛出。
        参数
        os - OutputStream对象

    • 方法详细信息

      • write

        public void write​(int b)
           throws IOException
        将指定的字节写入此输出流。
        重写：
        write在 FilterOutputStream
        参数
        b - byte 。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b)
           throws IOException
        将b.length字节从指定的字节数组写入此输出流。

        该write的方法CipherOutputStream调用write的三个参数与三个参数的方法b ， 0 ，并b.length 。

        重写：
        write在 FilterOutputStream
        参数
        b - 数据。
        异常
        NullPointerException - 如果 b为空。
        IOException - 如果发生I / O错误。
        另请参见：
        write(byte[], int, int)

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        从指定的字节数组写入 len字节，从偏移量 off开始输出到此输出流。
        重写：
        write在 FilterOutputStream
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.write(int)

      • flush

        public void flush​()
           throws IOException
        通过强制已经由封装的密码对象处理的任何缓冲的输出字节被写出来刷新输出流。

        由封装密码缓冲并等待被其处理的任何字节都不会被写出。 例如，如果封装的密码是块密码，并且使用write方法之一写入的总字节数小于密码的块大小，则不会写入字节。

        Specified by:
        flush在接口 Flushable
        重写：
        flush在 FilterOutputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • close

        public void close​()
           throws IOException
        关闭此输出流并释放与此流相关联的任何系统资源。

        此方法调用封装密码对象的doFinal方法，这将导致处理由封装密码缓冲的任何字节。 通过调用此输出流的flush方法来写出结果。

        该方法将封装的密码对象重置为初始状态，并调用底层输出流的close方法。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 FilterOutputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.flush() ， FilterOutputStream.out
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CipherSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class CipherSpi

  • java.lang.Object
    • javax.crypto.CipherSpi

  • public abstract class CipherSpi
extends Object
    该类定义了Cipher类的 （ SPI ）。 该类中的所有抽象方法必须由希望提供特定密码算法的实现的每个加密服务提供商来实现。

    为了创建一个Cipher的实例，封装了这个CipherSpi类的一个实例，一个应用程序调用了Cipher引擎类的27073038545870工厂方法之一，并指定了请求的转换 。 可选地，应用程序还可以指定提供者的名称。

    转换是描述要在给定输入上执行的操作（或操作集）的字符串，以产生一些输出。 转换总是包括加密算法的名称（例如， DES ），并且可以跟随有反馈模式和填充方案。

    转换形式如下：

    • “ 算法/模式/填充 ”或
    • “ 算法 ”

    （在后一种情况下，使用模式和填充方案的提供者特定的默认值）。 例如，以下是有效的转换：

      Cipher c = Cipher.getInstance("DES/CBC/PKCS5Padding");

    提供者可以为算法/模式/填充的每个组合提供单独的类，或者可以决定提供表示对应于算法或算法/模式或算法//填充 （注意双斜杠）的子变换的更多通用类，其中情况下所请求模式和/或填充由自动设定getInstance的方法Cipher ，其调用engineSetMode种engineSetPadding的提供者的子类的方法CipherSpi 。

    提供者主类中的Cipher属性可能具有以下格式之一：

    •   // provider's subclass of "CipherSpi" implements "algName" with
     // pluggable mode and padding
     Cipher.algName
    •   // provider's subclass of "CipherSpi" implements "algName" in the
     // specified "mode", with pluggable padding
     Cipher.algName/mode
    •   // provider's subclass of "CipherSpi" implements "algName" with the
     // specified "padding", with pluggable mode
     Cipher.algName//padding
    •   // provider's subclass of "CipherSpi" implements "algName" with the
     // specified "mode" and "padding"
     Cipher.algName/mode/padding

    例如，提供者可以提供的一个子类CipherSpi实现DES / ECB / PKCS5Padding，一个实现DES / CBC / PKCS5Padding，一个实现DES / CFB / PKCS5Padding，和又一一个实现DES / OFB / PKCS5Padding。 该提供商将在其主类中具有以下Cipher属性：

    •   Cipher.DES/ECB/PKCS5Padding
    •   Cipher.DES/CBC/PKCS5Padding
    •   Cipher.DES/CFB/PKCS5Padding
    •   Cipher.DES/OFB/PKCS5Padding

    另一个提供者可以针对上述各种模式实现一个类（即，一个用于ECB的类，一个用于CBC ，一个用于CBC ，一个用于CFB ，另一个用于OFB ），一个类用于PKCS5Padding ，以及一个通用的DES类，分类为CipherSpi 。 该提供商在其主类中将具有以下Cipher属性：

    •   Cipher.DES

    Cipher引擎类的getInstance工厂方法遵循这些规则，以便实例化一个提供者的CipherSpi的实现，用于“ 算法 ”形式的转换：

    1. 检查提供者是否已经为指定的“ 算法 ”注册了一个CipherSpi的子类。

      如果答案为YES，则实例化该类，对于其模式和填充方案默认值（由提供者提供）使用。

      如果答案是否定的，扔一个NoSuchAlgorithmException例外。

    Cipher引擎类的getInstance工厂方法遵循这些规则，以便实例化一个供应商的CipherSpi的实现，用于“ algorithm / mode / padding ”形式的转换：

    1. 检查提供者是否已经为指定的“ algorithm / mode / padding ”转换注册了一个CipherSpi的子类。

      如果答案为YES，则将其实例化。

      如果答案为否，请转到下一步。

    2. 检查提供者是否注册了子转换“ 算法/模式 ”的子集CipherSpi 。

      如果答案为YES，则将其实例化，并在新实例上调用engineSetPadding(padding) 。

      如果答案为否，请转到下一步。

    3. 检查提供者是否注册了子转换“ 算法// padding ”（注意双斜杠）的子类为CipherSpi 。

      如果答案为YES，则将其实例化，并在新实例上调用engineSetMode(mode) 。

      如果答案为否，请转到下一步。

    4. 检查提供者是否已经为子转换“ 算法 ”注册了一个CipherSpi的子类。

      如果答案为YES，则将其实例化，并在新实例上调用engineSetMode(mode)和engineSetPadding(padding) 。

      如果答案为NO，则抛出NoSuchAlgorithmException异常。

    从以下版本开始：
    1.4
    另请参见：
    KeyGenerator ， SecretKey

    • 构造方法摘要

      构造方法
      Constructor 描述
      CipherSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract byte[] engineDoFinal​(byte[] input, int inputOffset, int inputLen)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected abstract int engineDoFinal​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected int engineDoFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected abstract int engineGetBlockSize​()
      返回块大小（以字节为单位）。
      protected abstract byte[] engineGetIV​()
      返回新缓冲区中的初始化向量（IV）。
      protected int engineGetKeySize​(Key key)
      以位为单位返回给定键对象的键大小。
      protected abstract int engineGetOutputSize​(int inputLen)
      给定输入长度为 inputLen （以字节为单位），返回输出缓冲区需要保存下一个 update或 doFinal操作的结果的字节长度。
      protected abstract AlgorithmParameters engineGetParameters​()
      返回与此密码一起使用的参数。
      protected abstract void engineInit​(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void engineInit​(int opmode, Key key, SecureRandom random)
      用密钥和随机源初始化此密码。
      protected abstract void engineInit​(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用密钥，一组算法参数和随机源初始化此密码。
      protected abstract void engineSetMode​(String mode)
      设置此密码的模式。
      protected abstract void engineSetPadding​(String padding)
      设置这个密码的填充机制。
      protected Key engineUnwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
      打开以前包装的钥匙。
      protected abstract byte[] engineUpdate​(byte[] input, int inputOffset, int inputLen)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      protected abstract int engineUpdate​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      protected int engineUpdate​(ByteBuffer input, ByteBuffer output)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      protected void engineUpdateAAD​(byte[] src, int offset, int len)
      使用所提供的缓冲区的子集，继续进行附加认证数据（AAD）的多部分更新。
      protected void engineUpdateAAD​(ByteBuffer src)
      继续进行附加认证数据（AAD）的多部分更新。
      protected byte[] engineWrap​(Key key)
      包裹钥匙

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CipherSpi

        public CipherSpi​()

    • 方法详细信息

      • engineSetMode

        protected abstract void engineSetMode​(String mode)
                               throws NoSuchAlgorithmException
        设置此密码的模式。
        参数
        mode - 密码模式
        异常
        NoSuchAlgorithmException - 如果请求的密码模式不存在

      • engineSetPadding

        protected abstract void engineSetPadding​(String padding)
                                  throws NoSuchPaddingException
        设置这个密码的填充机制。
        参数
        padding - 填充机制
        异常
        NoSuchPaddingException - 如果请求的填充机制不存在

      • engineGetBlockSize

        protected abstract int engineGetBlockSize​()
        返回块大小（以字节为单位）。
        结果
        块大小（以字节为单位），如果底层算法不是块密码，则为0

      • engineGetOutputSize

        protected abstract int engineGetOutputSize​(int inputLen)
        给定输入长度为inputLen （以字节为单位），返回输出缓冲区需要保存下一个update或doFinal操作的结果的字节长度。

        此呼叫考虑了来自以前的update呼叫，填充和AEAD标记的任何未处理（缓冲）数据。

        下一个update或doFinal调用的实际输出长度可能小于此方法返回的长度。

        参数
        inputLen - 输入长度（以字节为单位）
        结果
        所需的输出缓冲区大小（以字节为单位）

      • engineGetIV

        protected abstract byte[] engineGetIV​()
        返回新缓冲区中的初始化向量（IV）。

        这在基于密码的加密或解密的上下文中是有用的，其中IV是从用户提供的密码短语导出的。

        结果
        新缓冲区中的初始化向量，如果底层算法不使用IV，或者如果IV尚未设置，则为null。

      • engineGetParameters

        protected abstract AlgorithmParameters engineGetParameters​()
        返回与此密码一起使用的参数。

        返回的参数可能与用于初始化此密码的参数相同，或者如果该密码需要算法参数但未被任何初始化，则可能包含底层密码实现使用的默认值和随机参数值的组合。

        结果
        与此密码一起使用的参数，如果此密码不使用任何参数，则为null。

      • engineInit

        protected abstract void engineInit​(int opmode,
                                   Key key,
                                   SecureRandom random)
                            throws InvalidKeyException
        用密钥和随机源初始化此密码。

        根据opmode的值，对以下四个操作之一进行密码初始化：加密，解密，密钥包装或密钥解opmode 。

        如果此密码需要不能从给定的key导出的任何算法参数，则底层的密码实现应该自动生成所需的参数（使用提供者特定的默认值或随机值），如果它被初始化为加密或密钥包装，以及提出一个InvalidKeyException如果它被初始化解密或密钥解包。 可以使用engineGetParameters或engineGetIV （如果参数为IV）检索生成的参数。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），它将从random获得。

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        key - 加密密钥
        random - 随机性的来源
        异常
        InvalidKeyException - 如果给定的密钥不适合初始化该密码，或者需要不能从给定密钥确定的算法参数。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE未被密码实现。

      • engineInit

        protected abstract void engineInit​(int opmode,
                                   Key key,
                                   AlgorithmParameterSpec params,
                                   SecureRandom random)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException
        使用密钥，一组算法参数和随机源初始化此密码。

        根据opmode的值，密码被初始化为以下四个操作之一：加密，解密，密钥包装或密钥解opmode 。

        如果此密码需要任何算法参数，并且params为null，则底层加密实现应该自动生成所需参数（使用提供者特定的默认值或随机值），如果它被初始化为加密或密钥包装，并且提出一个InvalidAlgorithmParameterException if正在为解密或密钥解包进行初始化。 生成的参数可以使用engineGetParameters或engineGetIV （如果参数为IV）检索。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），它将从random得到它们。

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        key - 加密密钥
        params - 算法参数
        random - 随机性的来源
        异常
        InvalidKeyException - 如果给定的密钥不适合初始化此密码
        InvalidAlgorithmParameterException - 如果给定的算法参数不适合该密码，或者该密码需要算法参数，并且 params为空。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE未被密码实现。

      • engineInit

        protected abstract void engineInit​(int opmode,
                                   Key key,
                                   AlgorithmParameters params,
                                   SecureRandom random)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException
        使用密钥，一组算法参数和随机源初始化此密码。

        根据opmode的值，密码被初始化为以下四个操作之一：加密，解密，密钥包装或密钥解opmode 。

        如果此密码需要任何算法参数，并且params为null，则底层加密实现应该自动生成所需参数（使用特定于提供者的默认值或随机值），如果正在初始化加密或密钥包装，并提出一个InvalidAlgorithmParameterException if正在为解密或密钥解包进行初始化。 可以使用engineGetParameters或engineGetIV （如果参数为IV）检索生成的参数。

        如果该密码需要不能从输入参数导出的算法参数，并且没有合理的提供者特定的默认值，则初始化必然会失败。

        如果这个密码（包括其底层反馈或填充方案）需要任何随机字节（例如，用于参数生成），它将从random获得。

        请注意，当一个Cipher对象被初始化时，它将失去所有先前获取的状态。 换句话说，初始化一个Cipher相当于创建一个新的Cipher实例并对其进行初始化。

        参数
        opmode -此cipher的操作模式（这是下列之一： ENCRYPT_MODE ， DECRYPT_MODE ， WRAP_MODE或 UNWRAP_MODE ）
        key - 加密密钥
        params - 算法参数
        random - 随机性的来源
        异常
        InvalidKeyException - 如果给定的密钥不适合初始化此密码
        InvalidAlgorithmParameterException - 如果给定的算法参数不适合该密码，或者该密码需要算法参数，并且 params为空。
        UnsupportedOperationException - 如果 opmode是 WRAP_MODE或 UNWRAP_MODE未被密码实现。

      • engineUpdate

        protected abstract byte[] engineUpdate​(byte[] input,
                                       int inputOffset,
                                       int inputLen)
        继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。

        第一inputLen字节在input缓冲区中，从inputOffset以下，被处理，并且结果被存储在新的缓冲器。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        结果
        具有结果的新缓冲区，如果底层密码是块密码，并且输入数据太短，导致新的块，则为null。

      • engineUpdate

        protected abstract int engineUpdate​(byte[] input,
                                    int inputOffset,
                                    int inputLen,
                                    byte[] output,
                                    int outputOffset)
                             throws ShortBufferException
        继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。

        第一inputLen字节在input缓冲区中，从inputOffset以下，被处理，并且结果被存储在output缓冲区中，从outputOffset以下。

        如果output缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        output - 结果的缓冲区
        outputOffset - output中存储结果的偏移量
        结果
        output存储的字节数
        异常
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果

      • engineUpdate

        protected int engineUpdate​(ByteBuffer input,
                           ByteBuffer output)
                    throws ShortBufferException
        继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。

        所有input.remaining()起始字节input.position()被处理。 结果存储在输出缓冲区中。 返回时，输入缓冲区的位置将等于其限制; 其限制将不会改变。 输出缓冲区的位置将提前n，其中n是此方法返回的值; 输出缓冲区的限制将不会改变。

        如果output.remaining()字节不足以保存结果，则抛出ShortBufferException 。

        子类应该考虑覆盖此方法，如果它们可以比字节数组更有效地处理ByteBuffers。

        参数
        input - 输入ByteBuffer
        output - 输出ByteByffer
        结果
        output存储的字节数
        异常
        ShortBufferException - 如果输出缓冲区中没有足够的空间
        NullPointerException - 如果任一参数是 null
        从以下版本开始：
        1.5

      • engineDoFinal

        protected abstract byte[] engineDoFinal​(byte[] input,
                                        int inputOffset,
                                        int inputLen)
                                 throws IllegalBlockSizeException,
                                        BadPaddingException
        在单一部分操作中加密或解密数据，或完成多部分操作。 数据被加密或解密，这取决于这个密码如何初始化。

        第一inputLen字节在input缓冲区中，从inputOffset以下，并且可能在上一次期间已缓存的任何输入字节update操作，进行处理，填充（如果要求）被施加。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在一个新的缓冲区。

        完成后，此方法将此密码对象重置为先前通过调用engineInit初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用engineInit指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        结果
        新的缓冲区结果
        异常
        IllegalBlockSizeException - 如果该密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        BadPaddingException - 如果该密码处于解密模式，并且已经请求了（un）填充，但是解密的数据不受适当的填充字节的限制
        AEADBadTagException - 如果该密码在AEAD模式（例如GCM / CCM）中解密，并且接收的认证标签与计算值不匹配

      • engineDoFinal

        protected abstract int engineDoFinal​(byte[] input,
                                     int inputOffset,
                                     int inputLen,
                                     byte[] output,
                                     int outputOffset)
                              throws ShortBufferException,
                                     IllegalBlockSizeException,
                                     BadPaddingException
        在单一部分操作中加密或解密数据，或完成多部分操作。 数据被加密或解密，这取决于这个密码如何初始化。

        第一inputLen字节在input缓冲区中，从inputOffset以下，并且可能在上一次期间已缓存的任何输入字节update操作，进行处理，填充（如果要求）被施加。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在output缓冲区中，从outputOffset开始。

        如果output缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。

        完成后，此方法将此密码对象重置为先前通过调用engineInit初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用engineInit指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        参数
        input - 输入缓冲区
        inputOffset - input中的输入开始的偏移量
        inputLen - 输入长度
        output - 结果的缓冲区
        outputOffset - 其中存储结果的偏移量为 output
        结果
        output存储的字节数
        异常
        IllegalBlockSizeException - 如果该密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果
        BadPaddingException - 如果该密码处于解密模式，并且已经请求了（un）填充，但是解密的数据不受适当的填充字节的限制
        AEADBadTagException - 如果该密码在AEAD模式（例如GCM / CCM）中解密，并且接收到的认证标签与计算值不匹配

      • engineDoFinal

        protected int engineDoFinal​(ByteBuffer input,
                            ByteBuffer output)
                     throws ShortBufferException,
                            IllegalBlockSizeException,
                            BadPaddingException
        在单一部分操作中加密或解密数据，或完成多部分操作。 数据被加密或解密，这取决于这个密码如何初始化。

        所有input.remaining()起始字节input.position()被处理。 如果正在使用诸如GCM / CCM的AEAD模式，则在加密的情况下附加认证标签，或者在解密的情况下验证认证标签。 结果存储在输出缓冲区中。 返回时，输入缓冲区的位置将等于其限制; 其限制将不会改变。 输出缓冲区的位置将提前n，其中n是此方法返回的值; 输出缓冲区的限制将不会改变。

        如果output.remaining()字节不足以保存结果，则抛出ShortBufferException 。

        完成后，该方法将此密码对象重置为先前通过调用engineInit初始化的状态。 也就是说，对象被重置并可用于加密或解密（取决于在调用engineInit指定的操作模式）更多的数据。

        注意：如果发生任何异常，则可能需要重新设置此密码对象，然后才能再次使用。

        子类应该考虑覆盖此方法，如果它们可以比字节数组更有效地处理ByteBuffers。

        参数
        input - 输入ByteBuffer
        output - 输出ByteByffer
        结果
        output存储的字节数
        异常
        IllegalBlockSizeException - 如果该密码是块密码，则不会请求填充（仅在加密模式下），并且由该密码处理的数据的总输入长度不是块大小的倍数; 或者如果此加密算法无法处理提供的输入数据。
        ShortBufferException - 如果输出缓冲区中没有足够的空间
        BadPaddingException - 如果该密码处于解密模式，并且已经请求了（un）填充，但解密的数据不受适当的填充字节的限制
        AEADBadTagException - 如果该密码在AEAD模式（例如GCM / CCM）中解密，并且接收到的认证标签与计算值不匹配
        NullPointerException - 如果任一参数是 null
        从以下版本开始：
        1.5

      • engineWrap

        protected byte[] engineWrap​(Key key)
                     throws IllegalBlockSizeException,
                            InvalidKeyException
        包裹钥匙

        这个具体的方法已经添加到这个以前定义的抽象类中。 （为了向后兼容，它不能是抽象的。）提供者可以覆盖它来包装密钥。 如果给定的键无法被包装，这样的覆盖应该会引发IllegalBlockSizeException或InvalidKeyException（在指定的情况下）。 如果此方法未被覆盖，则会始终抛出UnsupportedOperationException异常。

        参数
        key - 要包装的关键。
        结果
        包裹的钥匙。
        异常
        IllegalBlockSizeException - 如果该密码是块密码，则不请求填充，并且要包装的密钥的编码长度不是块大小的倍数。
        InvalidKeyException - 如果使用此密码将密钥包装是不可能或不安全的（例如，硬件保护密钥正在传递给仅软件密码）。
        UnsupportedOperationException - 如果不支持此方法。

      • engineUnwrap

        protected Key engineUnwrap​(byte[] wrappedKey,
                           String wrappedKeyAlgorithm,
                           int wrappedKeyType)
                    throws InvalidKeyException,
                           NoSuchAlgorithmException
        打开以前包装的钥匙。

        这个具体的方法已经添加到这个以前定义的抽象类中。 （为了向后兼容，它不能是抽象的。）提供者可以覆盖它以解开以前包装的密钥。 如果给定的包装密钥无法解开，这样的覆盖应该会抛出InvalidKeyException。 如果此方法未被覆盖，则会始终抛出UnsupportedOperationException异常。

        参数
        wrappedKey - 要解开的关键。
        wrappedKeyAlgorithm - 与包裹密钥相关联的算法。
        wrappedKeyType - 包装密钥的类型。 这是一个SECRET_KEY ， PRIVATE_KEY ，或PUBLIC_KEY 。
        结果
        展开的钥匙。
        异常
        NoSuchAlgorithmException - 如果没有安装的提供商可以为 wrappedKeyType创建类型为 wrappedKeyType的 wrappedKeyAlgorithm 。
        InvalidKeyException - 如果 wrappedKey不表示 wrappedKeyType的 wrappedKeyAlgorithm类型的包裹密钥。
        UnsupportedOperationException - 如果不支持此方法。

      • engineGetKeySize

        protected int engineGetKeySize​(Key key)
                        throws InvalidKeyException
        以位为单位返回给定键对象的键大小。

        这个具体的方法已经添加到这个以前定义的抽象类中。 如果它不被提供程序覆盖，它将抛出一个UnsupportedOperationException 。

        参数
        key - 关键对象。
        结果
        给定键对象的键大小。
        异常
        InvalidKeyException - 如果 key无效。

      • engineUpdateAAD

        protected void engineUpdateAAD​(byte[] src,
                               int offset,
                               int len)
        使用所提供的缓冲区的子集，继续进行附加认证数据（AAD）的多部分更新。

        当使用AEAD（GCM / CCM）等模式运行时，调用此方法可以为密码提供AAD。 如果此密码在GCM或CCM模式下运行，则必须在密文开始操作之前（通过update和doFinal方法）提供所有AAD。

        参数
        src - 包含AAD的缓冲区
        offset - 偏移量在 src ，其中AAD输入开始
        len - AAD字节数
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化），则不接受AAD，或者在GCM或CCM模式下运行，并且已经为 update方法之一调用了主动加密/解密操作
        UnsupportedOperationException - 如果此方法尚未被实现覆盖
        从以下版本开始：
        1.7

      • engineUpdateAAD

        protected void engineUpdateAAD​(ByteBuffer src)
        继续进行附加认证数据（AAD）的多部分更新。

        当使用AEAD（GCM / CCM）等模式运行时，调用此方法可以为密码提供AAD。 如果此密码在GCM或CCM模式下运行，则必须在密文开始操作之前（通过update和doFinal方法）提供所有AAD。

        所有src.remaining()起始字节src.position()被处理。 返回时，输入缓冲区的位置将等于其限制; 其限制将不会改变。

        参数
        src - 包含AAD的缓冲区
        异常
        IllegalStateException - 如果此密码处于错误状态（例如，尚未初始化），则不接受AAD，或者如果以GCM或CCM模式运行，并且 update方法之一已经被用于主动加密/解密操作
        UnsupportedOperationException - 如果此方法尚未被实现覆盖
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EncryptedPrivateKeyInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class EncryptedPrivateKeyInfo

  • java.lang.Object
    • javax.crypto.EncryptedPrivateKeyInfo

  • public class EncryptedPrivateKeyInfo
extends Object
    该类实现PKCS＃8中定义的EncryptedPrivateKeyInfo类型。

    其ASN.1定义如下：

      EncryptedPrivateKeyInfo ::=  SEQUENCE {
     encryptionAlgorithm   AlgorithmIdentifier,
     encryptedData   OCTET STRING }

 AlgorithmIdentifier  ::=  SEQUENCE  {
     algorithm              OBJECT IDENTIFIER,
     parameters             ANY DEFINED BY algorithm OPTIONAL  }
    从以下版本开始：
    1.4
    另请参见：
    PKCS8EncodedKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      EncryptedPrivateKeyInfo​(byte[] encoded)
      从其ASN.1编码构造（即解析）一个 EncryptedPrivateKeyInfo 。
      EncryptedPrivateKeyInfo​(String algName, byte[] encryptedData)
      根据加密算法名称和加密数据构建一个 EncryptedPrivateKeyInfo 。
      EncryptedPrivateKeyInfo​(AlgorithmParameters algParams, byte[] encryptedData)
      从加密算法参数和加密数据构建一个 EncryptedPrivateKeyInfo 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getAlgName​()
      返回加密算法。
      AlgorithmParameters getAlgParameters​()
      返回加密算法使用的算法参数。
      byte[] getEncoded​()
      返回此对象的ASN.1编码。
      byte[] getEncryptedData​()
      返回加密数据。
      PKCS8EncodedKeySpec getKeySpec​(Key decryptKey)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec getKeySpec​(Key decryptKey, String providerName)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec getKeySpec​(Key decryptKey, Provider provider)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      PKCS8EncodedKeySpec getKeySpec​(Cipher cipher)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EncryptedPrivateKeyInfo

        public EncryptedPrivateKeyInfo​(byte[] encoded)
                        throws IOException
        从其ASN.1编码构造（即解析）一个 EncryptedPrivateKeyInfo 。
        参数
        encoded - 该对象的ASN.1编码。 复制数组的内容以防止后续修改。
        异常
        NullPointerException - 如果 encoded为空。
        IOException - 如果在解析ASN.1编码时发生错误。

      • EncryptedPrivateKeyInfo

        public EncryptedPrivateKeyInfo​(String algName,
                               byte[] encryptedData)
                        throws NoSuchAlgorithmException
        根据加密算法名称和加密数据构建一个EncryptedPrivateKeyInfo 。

        注意：该构造函数将使用null作为算法参数的值。 如果加密算法的参数值不为空，则应使用不同的构造函数，例如EncryptedPrivateKeyInfo（AlgorithmParameters，byte []）。

        参数
        algName - 加密算法名称。 有关标准密码算法名称的信息，请参阅Java Security Standard Algorithm Names文档。
        encryptedData - 加密数据。 复制encrypedData的内容以防止构建此对象时的后续修改。
        异常
        NullPointerException - 如果 algName或 encryptedData为空。
        IllegalArgumentException - 如果 encryptedData为空，即0长度。
        NoSuchAlgorithmException - 如果不支持指定的algName。

      • EncryptedPrivateKeyInfo

        public EncryptedPrivateKeyInfo​(AlgorithmParameters algParams,
                               byte[] encryptedData)
                        throws NoSuchAlgorithmException
        从加密算法参数和加密数据构建一个 EncryptedPrivateKeyInfo 。
        参数
        algParams - 加密算法的算法参数。 algParams.getEncoded()应该返回EncryptedPrivateKeyInfo类型的AlgorithmIdentifer组件的parameters字段的ASN.1编码字节。
        encryptedData - 加密数据。 复制encrypedData的内容以防止构建此对象时的后续修改。
        异常
        NullPointerException - 如果 algParams或 encryptedData为空。
        IllegalArgumentException - 如果 encryptedData为空，即0长度。
        NoSuchAlgorithmException - 如果不支持指定的指定的 algParams参数 algParams参数。

    • 方法详细信息

      • getAlgName

        public String getAlgName​()
        返回加密算法。

        注意：如果此类映射可用，则在构造函数中返回标准名称而不是指定的名称。 有关标准密码算法名称的信息，请参阅Java Security Standard Algorithm Names文档。

        结果
        加密算法名称。

      • getAlgParameters

        public AlgorithmParameters getAlgParameters​()
        返回加密算法使用的算法参数。
        结果
        算法参数。

      • getEncryptedData

        public byte[] getEncryptedData​()
        返回加密数据。
        结果
        加密数据。 每次调用此方法时都会返回一个新数组。

      • getKeySpec

        public PKCS8EncodedKeySpec getKeySpec​(Cipher cipher)
                               throws InvalidKeySpecException
        从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
        注意：为了成功检索附带的PKCS8EncodedKeySpec对象， cipher需要初始化为Cipher.DECRYPT_MODE或Cipher.UNWRAP_MODE，具有与生成加密数据相同的密钥和参数。
        参数
        cipher - 将用于解密加密数据的初始化密码对象。
        结果
        PKCS8EncodedKeySpec对象。
        异常
        NullPointerException - 如果 cipher为空。
        InvalidKeySpecException - 如果给定的密码对于加密数据不合适或加密的数据被破坏并且不能被解密。

      • getKeySpec

        public PKCS8EncodedKeySpec getKeySpec​(Key decryptKey)
                               throws NoSuchAlgorithmException,
                                      InvalidKeyException
        从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
        参数
        decryptKey - 用于解密加密数据的密钥。
        结果
        PKCS8EncodedKeySpec对象。
        异常
        NullPointerException - 如果 decryptKey为空。
        NoSuchAlgorithmException - 如果找不到适当的密码来解密加密数据。
        InvalidKeyException - 如果 decryptKey不能用于解密加密数据或解密结果不是有效的PKCS8KeySpec。
        从以下版本开始：
        1.5

      • getKeySpec

        public PKCS8EncodedKeySpec getKeySpec​(Key decryptKey,
                                      String providerName)
                               throws NoSuchProviderException,
                                      NoSuchAlgorithmException,
                                      InvalidKeyException
        从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
        参数
        decryptKey - 用于解密加密数据的密钥。
        providerName - 将使用Cipher实现的提供程序的名称。
        结果
        PKCS8EncodedKeySpec对象。
        异常
        NullPointerException - 如果 decryptKey或 providerName为空。
        NoSuchProviderException - 如果没有提供者 providerName被注册。
        NoSuchAlgorithmException - 如果找不到适当的密码来解密加密数据。
        InvalidKeyException - 如果 decryptKey不能用于解密加密数据或解密结果不是有效的PKCS8KeySpec。
        从以下版本开始：
        1.5

      • getKeySpec

        public PKCS8EncodedKeySpec getKeySpec​(Key decryptKey,
                                      Provider provider)
                               throws NoSuchAlgorithmException,
                                      InvalidKeyException
        从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
        参数
        decryptKey - 用于解密加密数据的密钥。
        provider - 将使用Cipher实现的提供程序的名称。
        结果
        PKCS8EncodedKeySpec对象。
        异常
        NullPointerException - 如果 decryptKey或 provider为空。
        NoSuchAlgorithmException - 如果在 provider找不到适当的密码来解密加密数据。
        InvalidKeyException - 如果 decryptKey不能用于解密加密数据或解密结果不是有效的PKCS8KeySpec。
        从以下版本开始：
        1.5

      • getEncoded

        public byte[] getEncoded​()
                  throws IOException
        返回此对象的ASN.1编码。
        结果
        ASN.1编码。 每次调用此方法时都会返回一个新数组。
        异常
        IOException - 如果构建其ASN.1编码时发生错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExemptionMechanism (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class ExemptionMechanism

  • java.lang.Object
    • javax.crypto.ExemptionMechanism

  • public class ExemptionMechanism
extends Object
    这个类提供了豁免机制的功能，其中的例子是密钥恢复 ， 密钥弱化和密钥托管 。

    使用豁免机制的应用程序或小程序可能被授予比没有加密功能的更强的加密能力。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ExemptionMechanism​(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
      创建一个ExemptionMechanism对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] genExemptionBlob​()
      生成豁免机制密钥blob。
      int genExemptionBlob​(byte[] output)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中。
      int genExemptionBlob​(byte[] output, int outputOffset)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中，从 outputOffset开始。
      static ExemptionMechanism getInstance​(String algorithm)
      返回一个实现指定的豁免机制算法的 ExemptionMechanism对象。
      static ExemptionMechanism getInstance​(String algorithm, String provider)
      返回实现指定的免除机制算法的 ExemptionMechanism对象。
      static ExemptionMechanism getInstance​(String algorithm, Provider provider)
      返回一个 ExemptionMechanism对象，该对象实现指定的免除机制算法。
      String getName​()
      返回此 ExemptionMechanism对象的豁免机制名称。
      int getOutputSize​(int inputLen)
      给定输入长度为 inputLen （以字节为单位），返回输出缓冲区需要保存下一个 genExemptionBlob操作结果的字节长度。
      Provider getProvider​()
      返回此 ExemptionMechanism对象的提供者。
      void init​(Key key)
      使用密钥初始化此豁免机制。
      void init​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      void init​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      boolean isCryptoAllowed​(Key key)
      返回此豁免机制是否已成功生成结果blob。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ExemptionMechanism

        protected ExemptionMechanism​(ExemptionMechanismSpi exmechSpi,
                             Provider provider,
                             String mechanism)
        创建一个ExemptionMechanism对象。
        参数
        exmechSpi - 代表
        provider - 提供商
        mechanism - 豁免机制

    • 方法详细信息

      • getName

        public final String getName​()
        返回此ExemptionMechanism对象的豁免机制名称。

        这是在创建此ExemptionMechanism对象的getInstance调用之一中指定的名称。

        结果
        该 ExemptionMechanism对象的豁免机制名称。

      • getInstance

        public static final ExemptionMechanism getInstance​(String algorithm)
                                            throws NoSuchAlgorithmException
        返回实现指定的免除机制算法的ExemptionMechanism对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装ExemptionMechanismSpi实现的新的ExemptionMechanism对象。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 请求豁免机制的标准名称。 有关标准豁免机制名称的信息，请参阅Java Security Standard Algorithm Names Specification中的“豁免机制”部分。
        结果
        新的 ExemptionMechanism对象
        异常
        NoSuchAlgorithmException - 如果否 Provider支持指定算法的 ExemptionMechanismSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final ExemptionMechanism getInstance​(String algorithm,
                                                   String provider)
                                            throws NoSuchAlgorithmException,
                                                   NoSuchProviderException
        返回一个ExemptionMechanism对象，实现指定的豁免机制算法。

        返回从指定的提供程序封装ExemptionMechanismSpi实现的新的ExemptionMechanism对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        algorithm - 请求的豁免机制的标准名称。 有关标准豁免机制名称的信息，请参阅Java Security Standard Algorithm Names Specification中的“豁免机制”部分。
        provider - 提供商的名称。
        结果
        新的 ExemptionMechanism对象
        异常
        IllegalArgumentException - 如果 provider是 null或空
        NoSuchAlgorithmException - 如果指定算法的 ExemptionMechanismSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final ExemptionMechanism getInstance​(String algorithm,
                                                   Provider provider)
                                            throws NoSuchAlgorithmException
        返回一个实现指定的豁免机制算法的ExemptionMechanism对象。

        返回从指定的Provider对象封装ExemptionMechanismSpi实现的新的ExemptionMechanism对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 请求的豁免机制的标准名称。 有关标准豁免机制名称的信息，请参阅Java Security Standard Algorithm Names Specification中的“豁免机制”部分。
        provider - 提供商。
        结果
        新的 ExemptionMechanism对象
        异常
        IllegalArgumentException - 如果 provider为空
        NoSuchAlgorithmException - 如果指定的算法的 ExemptionMechanismSpi实现不能从指定的 Provider object
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此 ExemptionMechanism对象的提供者。
        结果
        这是 ExemptionMechanism对象的提供者。

      • isCryptoAllowed

        public final boolean isCryptoAllowed​(Key key)
                              throws ExemptionMechanismException
        返回此豁免机制是否已成功生成结果blob。

        该方法还确保传入的密钥与初始化和生成阶段中使用的豁免机制相同。

        参数
        key - 密码将要使用的密钥。
        结果
        该豁免机制是否成功生成了同一关键字的结果库; 如果key为空，则为false。
        异常
        ExemptionMechanismException - 如果在确定结果blob是否已被此豁免机制对象成功生成时遇到问题。

      • getOutputSize

        public final int getOutputSize​(int inputLen)
                        throws IllegalStateException
        给定输入长度为inputLen （以字节为单位），返回输出缓冲区需要保存下一个genExemptionBlob操作结果的字节长度。

        下一个genExemptionBlob调用的实际输出长度可能小于此方法返回的长度。

        参数
        inputLen - 输入长度（以字节为单位）
        结果
        所需的输出缓冲区大小（以字节为单位）
        异常
        IllegalStateException - 如果此豁免机制处于错误状态（例如尚未初始化）

      • init

        public final void init​(Key key)
                throws InvalidKeyException,
                       ExemptionMechanismException
        使用密钥初始化此豁免机制。

        如果此豁免机制需要不能从给定的key导出的任何算法参数，则基础豁免机制实现应该自身生成所需参数（使用提供者特定的默认值）; 在算法参数必须由调用者指定的情况下，会引发InvalidKeyException 。

        参数
        key - 这个豁免机制的关键
        异常
        InvalidKeyException - 如果给定的密钥不适用于此豁免机制。
        ExemptionMechanismException - 如果在初始化过程中遇到问题。

      • init

        public final void init​(Key key,
                       AlgorithmParameterSpec params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException,
                       ExemptionMechanismException
        使用密钥和一组算法参数初始化此豁免机制。

        如果此豁免机制需要任何算法参数，并且params为null，则基础豁免机制实现应该自身生成所需参数（使用提供者特定的默认值）; 在算法参数必须由调用者指定的情况下，会引发InvalidAlgorithmParameterException 。

        参数
        key - 这个豁免机制的关键
        params - 算法参数
        异常
        InvalidKeyException - 如果给定的密钥不适用于此豁免机制。
        InvalidAlgorithmParameterException - 如果给定的算法参数不适用于此豁免机制。
        ExemptionMechanismException - 如果在初始化过程中遇到问题。

      • init

        public final void init​(Key key,
                       AlgorithmParameters params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException,
                       ExemptionMechanismException
        使用密钥和一组算法参数初始化此豁免机制。

        如果此豁免机制需要任何算法参数，并且params为null，则基础豁免机制实现应该自身生成所需参数（使用提供者特定的默认值）; 在算法参数必须由调用者指定的情况下，会引发InvalidAlgorithmParameterException 。

        参数
        key - 这个豁免机制的关键
        params - 算法参数
        异常
        InvalidKeyException - 如果给定的密钥不适用于此豁免机制。
        InvalidAlgorithmParameterException - 如果给定的算法参数不适用于此豁免机制。
        ExemptionMechanismException - 如果在初始化过程中遇到问题。

      • genExemptionBlob

        public final byte[] genExemptionBlob​()
                              throws IllegalStateException,
                                     ExemptionMechanismException
        生成豁免机制密钥blob。
        结果
        具有结果键blob的新缓冲区。
        异常
        IllegalStateException - 如果此豁免机制处于错误状态（例如，尚未初始化）。
        ExemptionMechanismException - 如果在生成过程中遇到问题。

      • genExemptionBlob

        public final int genExemptionBlob​(byte[] output)
                           throws IllegalStateException,
                                  ShortBufferException,
                                  ExemptionMechanismException
        生成豁免机制密钥blob，并将结果存储在output缓冲区中。

        如果output缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用getOutputSize确定输出缓冲区应该有多大。

        参数
        output - 结果的缓冲区
        结果
        存储在 output的字节数
        异常
        IllegalStateException - 如果此豁免机制处于错误状态（例如，尚未初始化）。
        ShortBufferException - 如果给定的输出缓冲区太小，不能容纳结果。
        ExemptionMechanismException - 如果在生成过程中遇到问题。

      • genExemptionBlob

        public final int genExemptionBlob​(byte[] output,
                                  int outputOffset)
                           throws IllegalStateException,
                                  ShortBufferException,
                                  ExemptionMechanismException
        生成豁免机制键blob，并将结果存储在output缓冲区中，从outputOffset开始。

        如果output缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用getOutputSize来确定输出缓冲区应该有多大。

        参数
        output - 结果的缓冲区
        outputOffset - 存储结果的 output中的偏移量
        结果
        存储在 output的字节数
        异常
        IllegalStateException - 如果此豁免机制处于错误状态（例如，尚未初始化）。
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果。
        ExemptionMechanismException - 如果在生成过程中遇到问题。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExemptionMechanismException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class ExemptionMechanismException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.crypto.ExemptionMechanismException
  • All Implemented Interfaces:
    Serializable

    public class ExemptionMechanismException
extends GeneralSecurityException
    这是通用的ExemptionMechanism异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ExemptionMechanismException​()
      构造一个没有详细消息的ExemptionMechanismException。
      ExemptionMechanismException​(String msg)
      构造具有指定详细消息的ExemptionMechanismException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ExemptionMechanismException

        public ExemptionMechanismException​()
        构造一个没有详细消息的ExemptionMechanismException。 （详细消息是描述此特定异常的字符串。）

      • ExemptionMechanismException

        public ExemptionMechanismException​(String msg)
        构造具有指定详细消息的ExemptionMechanismException。 （详细消息是描述此特定异常的字符串。）
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExemptionMechanismSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class ExemptionMechanismSpi

  • java.lang.Object
    • javax.crypto.ExemptionMechanismSpi

  • public abstract class ExemptionMechanismSpi
extends Object
    该类定义了ExemptionMechanism类的 （ SPI ）。 该类中的所有抽象方法必须由希望提供特定豁免机制实施的每个加密服务提供商来实现。
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      ExemptionMechanismSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      protected abstract byte[] engineGenExemptionBlob​()
      生成豁免机制密钥blob。
      protected abstract int engineGenExemptionBlob​(byte[] output, int outputOffset)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中，从 outputOffset开始。
      protected abstract int engineGetOutputSize​(int inputLen)
      给定输入长度为 inputLen （以字节为单位），返回输出缓冲区需要保存下一个 engineGenExemptionBlob操作结果的字节长度。
      protected abstract void engineInit​(Key key)
      使用密钥初始化此豁免机制。
      protected abstract void engineInit​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      protected abstract void engineInit​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ExemptionMechanismSpi

        public ExemptionMechanismSpi​()

    • 方法详细信息

      • engineGetOutputSize

        protected abstract int engineGetOutputSize​(int inputLen)
        给定输入长度为inputLen （以字节为单位），返回输出缓冲区需要保存下一个engineGenExemptionBlob操作结果的字节长度。

        下一个engineGenExemptionBlob调用的实际输出长度可能小于此方法返回的长度。

        参数
        inputLen - 输入长度（以字节为单位）
        结果
        所需的输出缓冲区大小（以字节为单位）

      • engineInit

        protected abstract void engineInit​(Key key)
                            throws InvalidKeyException,
                                   ExemptionMechanismException
        使用密钥初始化此豁免机制。

        如果此豁免机制需要不能从给定的key导出的任何算法参数，则基础豁免机制实现应该自身生成所需参数（使用提供者特定的默认值）; 在算法参数必须由调用者指定的情况下，会引发InvalidKeyException 。

        参数
        key - 这个豁免机制的关键
        异常
        InvalidKeyException - 如果给定的密钥不适用于此豁免机制。
        ExemptionMechanismException - 如果在初始化过程中遇到问题。

      • engineInit

        protected abstract void engineInit​(Key key,
                                   AlgorithmParameterSpec params)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException,
                                   ExemptionMechanismException
        使用密钥和一组算法参数初始化此豁免机制。

        如果此豁免机制需要任何算法参数，并且params为null，则基础豁免机制实现应该自身生成所需参数（使用提供者特定的默认值）; 在算法参数必须由调用者指定的情况下，会引发InvalidAlgorithmParameterException 。

        参数
        key - 这个豁免机制的关键
        params - 算法参数
        异常
        InvalidKeyException - 如果给定的密钥不适用于此豁免机制。
        InvalidAlgorithmParameterException - 如果给定的算法参数不适用于此豁免机制。
        ExemptionMechanismException - 如果在初始化过程中遇到问题。

      • engineInit

        protected abstract void engineInit​(Key key,
                                   AlgorithmParameters params)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException,
                                   ExemptionMechanismException
        使用密钥和一组算法参数初始化此豁免机制。

        如果此豁免机制需要任何算法参数，并且params为null，则基础豁免机制实现应该自己生成所需参数（使用提供者特定的默认值）; 在算法参数必须由调用者指定的情况下，会引发InvalidAlgorithmParameterException 。

        参数
        key - 这个豁免机制的关键
        params - 算法参数
        异常
        InvalidKeyException - 如果给定的密钥不适用于此豁免机制。
        InvalidAlgorithmParameterException - 如果给定的算法参数不适用于此豁免机制。
        ExemptionMechanismException - 如果在初始化过程中遇到问题。

      • engineGenExemptionBlob

        protected abstract byte[] engineGenExemptionBlob​()
                                          throws ExemptionMechanismException
        生成豁免机制密钥blob。
        结果
        具有结果键blob的新缓冲区。
        异常
        ExemptionMechanismException - 如果在生成过程中遇到问题。

      • engineGenExemptionBlob

        protected abstract int engineGenExemptionBlob​(byte[] output,
                                              int outputOffset)
                                       throws ShortBufferException,
                                              ExemptionMechanismException
        生成豁免机制密钥blob，并将结果存储在output缓冲区中，从outputOffset开始。

        如果output缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。 在这种情况下，使用较大的输出缓冲区重复此呼叫。 使用engineGetOutputSize确定输出缓冲区应该有多大。

        参数
        output - 结果的缓冲区
        outputOffset - output中的结果存储的偏移量
        结果
        存储在 output的字节数
        异常
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果。
        ExemptionMechanismException - 如果在生成过程中遇到问题。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IllegalBlockSizeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class IllegalBlockSizeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.crypto.IllegalBlockSizeException
  • All Implemented Interfaces:
    Serializable

    public class IllegalBlockSizeException
extends GeneralSecurityException
    当提供给块密码的数据长度不正确时，抛出此异常，即与密码的块大小不匹配。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalBlockSizeException​()
      构造一个没有详细消息的IllegalBlockSizeException。
      IllegalBlockSizeException​(String msg)
      构造具有指定详细消息的IllegalBlockSizeException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalBlockSizeException

        public IllegalBlockSizeException​()
        构造一个没有详细消息的IllegalBlockSizeException。 详细消息是描述此特定异常的字符串。

      • IllegalBlockSizeException

        public IllegalBlockSizeException​(String msg)
        构造具有指定详细消息的IllegalBlockSizeException。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.crypto (Java SE 9 & JDK 9 )

javax.crypto

Interfaces

  • SecretKey

Classes

  • Cipher
  • CipherInputStream
  • CipherOutputStream
  • CipherSpi
  • EncryptedPrivateKeyInfo
  • ExemptionMechanism
  • ExemptionMechanismSpi
  • KeyAgreement
  • KeyAgreementSpi
  • KeyGenerator
  • KeyGeneratorSpi
  • Mac
  • MacSpi
  • NullCipher
  • SealedObject
  • SecretKeyFactory
  • SecretKeyFactorySpi

Exceptions

  • AEADBadTagException
  • BadPaddingException
  • ExemptionMechanismException
  • IllegalBlockSizeException
  • NoSuchPaddingException
  • ShortBufferException


javax.crypto (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package javax.crypto

提供加密操作的类和接口。 此包中定义的加密操作包括加密，密钥生成和密钥协商以及消息认证码（MAC）生成。

对加密的支持包括对称，非对称，块和流密码。 此包还支持安全流和密封对象。

此包中提供的许多类都是基于提供者的。 类本身定义了应用程序可以编写的编程接口。 然后，实现本身可以由独立的第三方供应商编写，并根据需要无缝地插入。 因此，应用程序开发人员可以利用任何数量的基于提供者的实现，而无需添加或重写代码。

  • Java Security Standard Algorithm Names Specification

相关文档

有关进一步的文档，请参阅：
  • Java Cryptography Architecture (JCA) Reference Guide
  • How to Implement a Provider in the Java Cryptography Architecture
从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    SecretKey
    一个秘密（对称）键。
  • 类摘要
    Class 描述
    Cipher
    该类提供加密和解密的加密密码的功能。
    CipherInputStream
    CipherInputStream由InputStream和Cipher组成，使得read（）方法返回从底层InputStream读入但是由Cipher额外处理的数据。
    CipherOutputStream
    CipherOutputStream由OutputStream和Cipher组成，以便write（）方法首先在将数据写入底层OutputStream之前处理数据。
    CipherSpi
    该类定义了 Cipher类的 （ SPI ）。
    EncryptedPrivateKeyInfo
    该类实现了PKCS＃8中定义的 EncryptedPrivateKeyInfo类型。
    ExemptionMechanism
    这个类提供了豁免机制的功能，其中的例子是 密钥恢复 ， 密钥弱化和 密钥托管 。
    ExemptionMechanismSpi
    该类定义了 ExemptionMechanism类的 （ SPI ）。
    KeyAgreement
    该类提供了密钥协议（或密钥交换）协议的功能。
    KeyAgreementSpi
    该类定义了 KeyAgreement类的 （ SPI ）。
    KeyGenerator
    该类提供了一个秘密（对称）密钥生成器的功能。
    KeyGeneratorSpi
    该类定义了 KeyGenerator类的 （ SPI ）。
    Mac
    该类提供了“消息验证码”（MAC）算法的功能。
    MacSpi
    该类定义了 Mac类的 （ SPI ）。
    NullCipher
    NullCipher类是提供“身份密码”的类，不会转换纯文本。
    SealedObject
    该类使程序员能够使用加密算法创建对象并保护其机密性。
    SecretKeyFactory
    这个类代表一个秘密密钥的工厂。
    SecretKeyFactorySpi
    该类定义了 SecretKeyFactory类的 （ SPI ）。
  • 异常摘要
    异常 描述
    AEADBadTagException
    当以AEAD模式（如GCM / CCM）运行的Cipher无法验证提供的认证标记时，会抛出此异常。
    BadPaddingException
    当期望输入数据的特定填充机制但数据未正确填充时，会抛出此异常。
    ExemptionMechanismException
    这是通用的ExemptionMechanism异常。
    IllegalBlockSizeException
    当提供给块密码的数据长度不正确时，抛出此异常，即与密码的块大小不匹配。
    NoSuchPaddingException
    当请求特定的填充机制但在环境中不可用时抛出此异常。
    ShortBufferException
    This exception is thrown when an output buffer provided by the user is too short to hold the operation result.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.crypto Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.crypto

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.crypto.Cipher
      • javax.crypto.NullCipher
    • javax.crypto.CipherSpi
    • javax.crypto.EncryptedPrivateKeyInfo
    • javax.crypto.ExemptionMechanism
    • javax.crypto.ExemptionMechanismSpi
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • javax.crypto.CipherInputStream
    • javax.crypto.KeyAgreement
    • javax.crypto.KeyAgreementSpi
    • javax.crypto.KeyGenerator
    • javax.crypto.KeyGeneratorSpi
    • javax.crypto.Mac (implements java.lang.Cloneable)
    • javax.crypto.MacSpi
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • javax.crypto.CipherOutputStream
    • javax.crypto.SealedObject (implements java.io.Serializable)
    • javax.crypto.SecretKeyFactory
    • javax.crypto.SecretKeyFactorySpi
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.security.GeneralSecurityException
          • javax.crypto.BadPaddingException
            • javax.crypto.AEADBadTagException
          • javax.crypto.ExemptionMechanismException
          • javax.crypto.IllegalBlockSizeException
          • javax.crypto.NoSuchPaddingException
          • javax.crypto.ShortBufferException

Interface Hierarchy

  • javax.security.auth.Destroyable
    • javax.crypto.SecretKey (also extends java.security.Key)
  • java.io.Serializable
    • java.security.Key
      • javax.crypto.SecretKey (also extends javax.security.auth.Destroyable)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


KeyAgreement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class KeyAgreement

  • java.lang.Object
    • javax.crypto.KeyAgreement

  • public class KeyAgreement
extends Object
    该类提供了密钥协议（或密钥交换）协议的功能。

    密钥生成器（ KeyPairGenerator或KeyGenerator ）， KeyFactory或由于密钥协商协议的中间阶段的结果而产生的建立共享秘密的密钥是创建的。

    对于密钥交换中的每个记者，需要调用doPhase 。 例如，如果这个密钥交换与另一方doPhase ，则doPhase需要被调用一次， lastPhase标志设置为true 。 如果这个密钥交换是与另外两个方， doPhase需要调用两次，首次将lastPhase标志设置为false ，第二次将其设置为true 。 密钥交换中可能存在任何数量的参与方。

    Java平台的每个实现都需要支持以下标准KeyAgreement算法：

    • DiffieHellman
    该算法在Java安全标准算法名称规范的KeyAgreement section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.4
    另请参见：
    KeyGenerator ， SecretKey

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected KeyAgreement​(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
      创建一个KeyAgreement对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Key doPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      byte[] generateSecret​()
      生成共享密钥并将其返回到新的缓冲区。
      int generateSecret​(byte[] sharedSecret, int offset)
      生成共享密钥，并将其放入缓冲区 sharedSecret （从 offset开始）。
      SecretKey generateSecret​(String algorithm)
      创建共享密钥，并将其作为指定算法的 SecretKey对象返回。
      String getAlgorithm​()
      返回此 KeyAgreement对象的算法名称。
      static KeyAgreement getInstance​(String algorithm)
      返回实现指定密钥协议算法的 KeyAgreement对象。
      static KeyAgreement getInstance​(String algorithm, String provider)
      返回实现指定密钥协商算法的 KeyAgreement对象。
      static KeyAgreement getInstance​(String algorithm, Provider provider)
      返回实现指定密钥协商算法的 KeyAgreement对象。
      Provider getProvider​()
      返回此 KeyAgreement对象的提供者。
      void init​(Key key)
      使用给定的密钥初始化此密钥协议，该密钥需要包含此密钥协议所需的所有算法参数。
      void init​(Key key, SecureRandom random)
      用给定的密钥和随机源初始化这个密钥协商。
      void init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数集初始化此密钥协议。
      void init​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyAgreement

        protected KeyAgreement​(KeyAgreementSpi keyAgreeSpi,
                       Provider provider,
                       String algorithm)
        创建一个KeyAgreement对象。
        参数
        keyAgreeSpi - 代表
        provider - 提供商
        algorithm - 算法

    • 方法详细信息

      • getAlgorithm

        public final String getAlgorithm​()
        返回此KeyAgreement对象的算法名称。

        这是在创建此KeyAgreement对象的getInstance呼叫之一中指定的名称。

        结果
        这个 KeyAgreement对象的算法名称。

      • getInstance

        public static final KeyAgreement getInstance​(String algorithm)
                                      throws NoSuchAlgorithmException
        返回实现指定密钥协商算法的KeyAgreement对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装KeyAgreementSpi实现的新KeyAgreement对象。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与由Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 所请求的密钥协商算法的标准名称。 看到该协议密钥部分Java Security Standard Algorithm Names Specification有关标准算法名称的信息。
        结果
        新的 KeyAgreement对象
        异常
        NoSuchAlgorithmException - 如果否 Provider支持指定算法的 KeyAgreementSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final KeyAgreement getInstance​(String algorithm,
                                             String provider)
                                      throws NoSuchAlgorithmException,
                                             NoSuchProviderException
        返回实现指定的密钥协商算法的KeyAgreement对象。

        返回从指定提供程序封装KeyAgreementSpi实现的新KeyAgreement对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        参数
        algorithm - 所请求的密钥协商算法的标准名称。 看到该协议密钥部分Java Security Standard Algorithm Names Specification有关标准算法名称的信息。
        provider - 提供商的名称。
        结果
        新的 KeyAgreement对象
        异常
        IllegalArgumentException - 如果 provider是 null或为空
        NoSuchAlgorithmException - 如果指定算法的 KeyAgreementSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final KeyAgreement getInstance​(String algorithm,
                                             Provider provider)
                                      throws NoSuchAlgorithmException
        返回实现指定的密钥协商算法的KeyAgreement对象。

        返回从指定的Provider对象封装KeyAgreementSpi实现的新KeyAgreement对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 所请求的密钥协商算法的标准名称。 看到该协议密钥部分Java Security Standard Algorithm Names Specification有关标准算法名称的信息。
        provider - 提供商。
        结果
        新的 KeyAgreement对象
        异常
        IllegalArgumentException - 如果 provider是 null
        NoSuchAlgorithmException - 如果指定的算法的 KeyAgreementSpi实现不能从指定的Provider对象获得
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此 KeyAgreement对象的提供者。
        结果
        这个 KeyAgreement对象的提供者

      • init

        public final void init​(Key key)
                throws InvalidKeyException
        使用给定的密钥初始化此密钥协议，该密钥需要包含此密钥协议所需的所有算法参数。

        如果此密钥协议需要任意随机字节，则将使用最高优先级安装提供程序的SecureRandom实现作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，将会使用系统提供的随机源。）

        参数
        key - 党的私人信息。 例如，在Diffie-Hellman密钥协议的情况下，这将是该方自己的Diffie-Hellman私钥。
        异常
        InvalidKeyException - 如果给定的密钥对于该密钥协议是不合适的，例如，是错误的类型或具有不兼容的算法类型。

      • init

        public final void init​(Key key,
                       SecureRandom random)
                throws InvalidKeyException
        用给定的密钥和随机源初始化这个密钥协商。 给定密钥需要包含此密钥协议所需的所有算法参数。

        如果密钥协商算法需要随机字节，则从给定的随机源获得它们， random 。 但是，如果底层算法实现不需要任何随机字节，则忽略random 。

        参数
        key - 派对的私人信息。 例如，在Diffie-Hellman密钥协议的情况下，这将是该方自己的Diffie-Hellman私钥。
        random - 随机性的来源
        异常
        InvalidKeyException - 如果给定的密钥对于该密钥协议是不合适的，例如，是错误的类型或具有不兼容的算法类型。

      • init

        public final void init​(Key key,
                       AlgorithmParameterSpec params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
        使用给定的密钥和算法参数集初始化此密钥协议。

        如果这个密钥协议需要任意随机字节，它将使用最高优先级的安装提供商的SecureRandom实现作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，将会使用系统提供的随机源。）

        参数
        key - 党的私人信息。 例如，在Diffie-Hellman密钥协议的情况下，这将是该方自己的Diffie-Hellman私钥。
        params - 密钥协商参数
        异常
        InvalidKeyException - 如果给定的密钥对于该密钥协议是不合适的，例如，是错误的类型或具有不兼容的算法类型。
        InvalidAlgorithmParameterException - 如果给定的参数不适用于此密钥协议。

      • init

        public final void init​(Key key,
                       AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
        使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
        参数
        key - 党的私人信息。 例如，在Diffie-Hellman密钥协议的情况下，这将是该方自己的Diffie-Hellman私钥。
        params - 密钥协商参数
        random - 随机性的来源
        异常
        InvalidKeyException - 如果给定的密钥对于该密钥协议是不合适的，例如，是错误的类型或具有不兼容的算法类型。
        InvalidAlgorithmParameterException - 如果给定的参数不适合此密钥协议。

      • doPhase

        public final Key doPhase​(Key key,
                         boolean lastPhase)
                  throws InvalidKeyException,
                         IllegalStateException
        执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
        参数
        key - 这个阶段的关键。 例如，在双方之间的Diffie-Hellman的情况下，这将是对方的Diffie-Hellman公钥。
        lastPhase - 表示这是否是此密钥协议的最后一个阶段的标志。
        结果
        由此阶段产生的（中间）密钥，如果此阶段不产生密钥，则为null
        异常
        InvalidKeyException - 如果给定的键不适合此阶段。
        IllegalStateException - 如果此密钥协议尚未初始化。

      • generateSecret

        public final byte[] generateSecret​()
                            throws IllegalStateException
        生成共享密钥并将其返回到新的缓冲区。

        该方法重置此KeyAgreement对象，以便可以重新用于进一步的关键协议。 除非使用init方法之一重新初始化该密钥协议，否则相同的私有信息和算法参数将用于后续密钥协议。

        结果
        新的缓冲区与共享的秘密
        异常
        IllegalStateException - 如果此密钥协议尚未完成

      • generateSecret

        public final int generateSecret​(byte[] sharedSecret,
                                int offset)
                         throws IllegalStateException,
                                ShortBufferException
        生成共享密钥，并将其放入缓冲区sharedSecret （从offset开始）。

        如果sharedSecret缓冲区太小，无法保存结果，则抛出一个ShortBufferException 。 在这种情况下，应该使用较大的输出缓冲区来重复此调用。

        此方法重置此KeyAgreement对象，以便可以重新用于进一步的关键协议。 除非使用init方法重新初始化此密钥协议，否则相同的私有信息和算法参数将用于后续密钥协议。

        参数
        sharedSecret - 共享密码的缓冲区
        offset - sharedSecret中的共享密钥将被存储的偏移量
        结果
        将字节数放入 sharedSecret
        异常
        IllegalStateException - 如果此密钥协议尚未完成
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存秘密

      • generateSecret

        public final SecretKey generateSecret​(String algorithm)
                               throws IllegalStateException,
                                      NoSuchAlgorithmException,
                                      InvalidKeyException
        创建共享密钥，并将其作为指定算法的SecretKey对象返回。

        此方法重置此KeyAgreement对象，以便可以重新用于进一步的关键协议。 除非使用init方法重新初始化该密钥协议，否则相同的私有信息和算法参数将用于后续密钥协议。

        参数
        algorithm - 所请求的秘密密钥算法
        结果
        共享密钥
        异常
        IllegalStateException - 如果此关键协议尚未完成
        NoSuchAlgorithmException - 如果指定的秘密密钥算法不可用
        InvalidKeyException - 如果共享密钥材料不能用于生成指定算法的密钥（例如，密钥材料太短）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyAgreementSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class KeyAgreementSpi

  • java.lang.Object
    • javax.crypto.KeyAgreementSpi

  • public abstract class KeyAgreementSpi
extends Object
    此类定义了KeyAgreement类的 （ SPI ）。 该类中的所有抽象方法必须由希望提供特定密钥协商算法的实现的每个加密服务提供商来实现。

    密钥生成器（ KeyPairGenerator或KeyGenerator ）， KeyFactory或由密钥协商协议（ engineDoPhase ）的中间阶段的结果创建的共享秘密中涉及的密钥是创建的。

    对于密钥交换中的每个记者，需要调用engineDoPhase 。 例如，如果与另一方进行密钥交换， engineDoPhase需要调用lastPhase一次，其中lastPhase标志设置为true 。 如果与另外两方进行密钥交换， engineDoPhase需要调用engineDoPhase两次，首次将lastPhase标志设置为false ，第二次将其设置为true 。 密钥交换中可能存在任何数量的参与方。

    从以下版本开始：
    1.4
    另请参见：
    KeyGenerator ， SecretKey

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyAgreementSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      protected abstract Key engineDoPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      protected abstract byte[] engineGenerateSecret​()
      生成共享密钥并将其返回到新的缓冲区。
      protected abstract int engineGenerateSecret​(byte[] sharedSecret, int offset)
      生成共享密钥，并将其放入缓冲区 sharedSecret （从 offset开始）。
      protected abstract SecretKey engineGenerateSecret​(String algorithm)
      创建共享密钥，并将其作为请求的算法类型的秘密密钥对象返回。
      protected abstract void engineInit​(Key key, SecureRandom random)
      用给定的密钥和随机源初始化这个密钥协商。
      protected abstract void engineInit​(Key key, AlgorithmParameterSpec params, SecureRandom random)
      使用给定的密钥，算法参数集合和随机源初始化此密钥协议。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyAgreementSpi

        public KeyAgreementSpi​()

    • 方法详细信息

      • engineInit

        protected abstract void engineInit​(Key key,
                                   SecureRandom random)
                            throws InvalidKeyException
        用给定的密钥和随机源初始化这个密钥协商。 给定密钥需要包含此密钥协议所需的所有算法参数。

        如果密钥协商算法需要随机字节，则从给定的随机源获取它们， random 。 然而，如果底层算法实现不需要任何随机字节，则忽略random 。

        参数
        key - 党的私人信息。 例如，在Diffie-Hellman密钥协议的情况下，这将是该方自己的Diffie-Hellman私钥。
        random - 随机性的来源
        异常
        InvalidKeyException - 如果给定的密钥对于该密钥协议是不合适的，例如，是错误的类型或具有不兼容的算法类型。

      • engineInit

        protected abstract void engineInit​(Key key,
                                   AlgorithmParameterSpec params,
                                   SecureRandom random)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException
        使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
        参数
        key - 党的私人信息。 例如，在Diffie-Hellman密钥协议的情况下，这将是该方自己的Diffie-Hellman私钥。
        params - 密钥协商参数
        random - 随机的来源
        异常
        InvalidKeyException - 如果给定的密钥对于该密钥协议是不合适的，例如，是错误的类型或具有不兼容的算法类型。
        InvalidAlgorithmParameterException - 如果给定的参数不适合此密钥协议。

      • engineDoPhase

        protected abstract Key engineDoPhase​(Key key,
                                     boolean lastPhase)
                              throws InvalidKeyException,
                                     IllegalStateException
        执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
        参数
        key - 这个阶段的关键。 例如，在双方之间的Diffie-Hellman的情况下，这将是对方的Diffie-Hellman公钥。
        lastPhase - 表示这是否是此密钥协议的最后一个阶段的标志。
        结果
        由此阶段产生的（中间）密钥，如果此阶段不产生密钥，则为null
        异常
        InvalidKeyException - 如果给定的键不适合此阶段。
        IllegalStateException - 如果此密钥协议尚未初始化。

      • engineGenerateSecret

        protected abstract byte[] engineGenerateSecret​()
                                        throws IllegalStateException
        生成共享密钥并将其返回到新的缓冲区。

        此方法重置此KeyAgreementSpi对象，以便可以重新用于进一步的关键协议。 除非使用engineInit方法重新初始化该密钥协议，否则将使用相同的私有信息和算法参数用于后续密钥协议。

        结果
        新的缓冲区与共享的秘密
        异常
        IllegalStateException - 如果此关键协议尚未完成

      • engineGenerateSecret

        protected abstract int engineGenerateSecret​(byte[] sharedSecret,
                                            int offset)
                                     throws IllegalStateException,
                                            ShortBufferException
        生成共享密钥，并将其放入缓冲区sharedSecret ，从offset开始。

        如果sharedSecret缓冲区太小而不能保存结果，则抛出一个ShortBufferException 。 在这种情况下，应该使用较大的输出缓冲区来重复此调用。

        此方法重置此KeyAgreementSpi对象，以便可以重新用于进一步的关键协议。 除非使用engineInit方法重新初始化此密钥协议，否则相同的私有信息和算法参数将用于后续密钥协议。

        参数
        sharedSecret - 共享密码的缓冲区
        offset - sharedSecret中的共享密钥将被存储的偏移量
        结果
        将字节数放入 sharedSecret
        异常
        IllegalStateException - 如果此密钥协议尚未完成
        ShortBufferException - 如果给定的输出缓冲区太小，不能容纳秘密

      • engineGenerateSecret

        protected abstract SecretKey engineGenerateSecret​(String algorithm)
                                           throws IllegalStateException,
                                                  NoSuchAlgorithmException,
                                                  InvalidKeyException
        创建共享密钥，并将其作为请求的算法类型的秘密密钥对象返回。

        此方法重置此KeyAgreementSpi对象，以便可以重新用于进一步的关键协议。 除非使用engineInit方法重新初始化此密钥协议，否则相同的私有信息和算法参数将用于后续密钥协议。

        参数
        algorithm - 所请求的密钥算法
        结果
        共享密钥
        异常
        IllegalStateException - 如果此密钥协议尚未完成
        NoSuchAlgorithmException - 如果所请求的密钥算法不可用
        InvalidKeyException - 如果共享密钥资料不能用于生成请求的算法类型的密钥（例如，密钥材料太短）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyGenerator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class KeyGenerator

  • java.lang.Object
    • javax.crypto.KeyGenerator

  • public class KeyGenerator
extends Object
    该类提供了一个秘密（对称）密钥生成器的功能。

    密钥生成器使用getInstance类方法之一构建。

    KeyGenerator对象是可重用的，即在生成一个密钥之后，可以重新使用相同的KeyGenerator对象来生成其他密钥。

    有两种方式来生成一个密钥：以一种算法无关的方式，并以一种算法特定的方式。 两者之间的唯一区别是对象的初始化：

    • 独立于算法的初始化

      所有密钥生成器共享一个密钥长度的概念和随机源 。 这个KeyGenerator类中有一个init方法，它接受这两个通用共享的参数类型。 还有一个只需要一个keysize参数，并且使用最高优先级安装的提供程序的SecureRandom实现作为随机源（或者如果没有一个已安装的提供程序提供SecureRandom实现，则是系统提供的随机源），以及一个只是一个随机的来源。

      由于当您调用上述与算法无关的init方法时，没有指定其他参数，因此提供者如何处理与每个密钥相关的特定于算法的参数（如果有的话）。

    • 特定于算法的初始化

      对于一组特定于算法的参数已存在的情况，有两个init方法具有AlgorithmParameterSpec参数。 一个还有一个SecureRandom参数，另一个使用最高优先级安装的提供程序的SecureRandom实现作为随机源（或者如果没有一个已安装的提供程序提供SecureRandom实现，则是系统提供的随机源）。

    如果客户端没有显式初始化KeyGenerator（通过调用init方法），则每个提供程序都必须提供（并记录）默认的初始化。 有关JDK提供程序使用的KeyGenerator默认值的信息，请参阅JDK Providers文档的Keysize Restriction部分。 不过，请注意，不同提供商的默认值可能会有所不同。 此外，提供者的默认值可能会在将来的版本中更改。 因此，建议显式地初始化KeyGenerator，而不是依赖于提供者特定的默认值。

    Java平台的每个实现都需要支持以下标准的KeyGenerator算法，括号中的键入：

    • AES （128）
    • DES （56）
    • DESede （168）
    • HmacSHA1
    • HmacSHA256
    这些算法在Java安全标准算法名称规范的KeyGenerator section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.4
    另请参见：
    SecretKey

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected KeyGenerator​(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
      创建一个KeyGenerator对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SecretKey generateKey​()
      生成一个秘密密钥。
      String getAlgorithm​()
      返回此 KeyGenerator对象的算法名称。
      static KeyGenerator getInstance​(String algorithm)
      返回一个生成指定算法的密钥的 KeyGenerator对象。
      static KeyGenerator getInstance​(String algorithm, String provider)
      返回一个 KeyGenerator对象，该对象为指定的算法生成密钥。
      static KeyGenerator getInstance​(String algorithm, Provider provider)
      返回产生指定算法的密钥的 KeyGenerator对象。
      Provider getProvider​()
      返回此 KeyGenerator对象的提供者。
      void init​(int keysize)
      初始化此密钥生成器用于某些密钥大小。
      void init​(int keysize, SecureRandom random)
      使用用户提供的随机源，初始化该密钥生成器以进行某些密钥化。
      void init​(SecureRandom random)
      初始化此密钥生成器。
      void init​(AlgorithmParameterSpec params)
      使用指定的参数集初始化此密钥生成器。
      void init​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化此密钥生成器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyGenerator

        protected KeyGenerator​(KeyGeneratorSpi keyGenSpi,
                       Provider provider,
                       String algorithm)
        创建一个KeyGenerator对象。
        参数
        keyGenSpi - 代表
        provider - 提供商
        algorithm - 算法

    • 方法详细信息

      • getAlgorithm

        public final String getAlgorithm​()
        返回此KeyGenerator对象的算法名称。

        这是在创建此KeyGenerator对象的getInstance呼叫之一中指定的名称。

        结果
        这个 KeyGenerator对象的算法名称。

      • getInstance

        public static final KeyGenerator getInstance​(String algorithm)
                                      throws NoSuchAlgorithmException
        返回一个生成指定算法的密钥的KeyGenerator对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装KeyGeneratorSpi实现的新KeyGenerator对象。

        请注意，可以通过Security.getProviders()方法检索已注册提供商的列表。

        Implementation Note:
        JDK参考实现还使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 所请求密钥算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyGenerator部分。
        结果
        新的 KeyGenerator对象
        异常
        NoSuchAlgorithmException - 如果否 Provider支持指定算法的 KeyGeneratorSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final KeyGenerator getInstance​(String algorithm,
                                             String provider)
                                      throws NoSuchAlgorithmException,
                                             NoSuchProviderException
        返回一个KeyGenerator对象，生成指定算法的密钥。

        返回从指定提供程序封装KeyGeneratorSpi实现的新KeyGenerator对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        algorithm - 请求密钥算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyGenerator部分。
        provider - 提供商的名称。
        结果
        新的 KeyGenerator对象
        异常
        IllegalArgumentException - 如果 provider是 null或为空
        NoSuchAlgorithmException - 如果指定算法的 KeyGeneratorSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final KeyGenerator getInstance​(String algorithm,
                                             Provider provider)
                                      throws NoSuchAlgorithmException
        返回产生指定算法的密钥的KeyGenerator对象。

        返回从指定的Provider对象封装KeyGeneratorSpi实现的新KeyGenerator对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 所请求密钥算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的KeyGenerator部分。
        provider - 提供商。
        结果
        新的 KeyGenerator对象
        异常
        IllegalArgumentException - 如果 provider是 null
        NoSuchAlgorithmException - 如果指定的算法的 KeyGeneratorSpi实现不能从指定的 Provider对象获得
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此 KeyGenerator对象的提供者。
        结果
        这个 KeyGenerator对象的提供者

      • init

        public final void init​(SecureRandom random)
        初始化此密钥生成器。
        参数
        random - 该发生器的随机性来源

      • init

        public final void init​(AlgorithmParameterSpec params)
                throws InvalidAlgorithmParameterException
        使用指定的参数集初始化此密钥生成器。

        如果这个密钥生成器需要任何随机字节，它将使用最高优先级的安装提供者的SecureRandom实现作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，将会使用系统提供的随机源。）

        参数
        params - 密钥生成参数
        异常
        InvalidAlgorithmParameterException - 如果给定的参数不适合此密钥生成器

      • init

        public final void init​(AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidAlgorithmParameterException
        使用指定的参数集和用户提供的随机源初始化此密钥生成器。
        参数
        params - 密钥生成参数
        random - 该密钥生成器的随机源
        异常
        InvalidAlgorithmParameterException - 如果 params不适合此密钥生成器

      • init

        public final void init​(int keysize)
        初始化此密钥生成器用于某些密钥大小。

        如果这个密钥生成器需要任何随机字节，它将使用最高优先级安装的提供者的SecureRandom实现作为随机源。 （如果没有一个已安装的提供商提供SecureRandom的实现，将会使用系统提供的随机源。）

        参数
        keysize - keysize 。 这是一个以比特数表示的算法特定度量。
        异常
        InvalidParameterException - 如果keysize错误或不支持。

      • init

        public final void init​(int keysize,
                       SecureRandom random)
        使用用户提供的随机源，初始化该密钥生成器以进行某些密钥化。
        参数
        keysize - keysize 。 这是一个以比特数表示的算法特定度量。
        random - 此密钥生成器的随机源
        异常
        InvalidParameterException - 如果keysize错误或不支持。

      • generateKey

        public final SecretKey generateKey​()
        生成一个秘密密钥。
        结果
        新的钥匙
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyGeneratorSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class KeyGeneratorSpi

  • java.lang.Object
    • javax.crypto.KeyGeneratorSpi

  • public abstract class KeyGeneratorSpi
extends Object
    该类定义了KeyGenerator类的 （ SPI ）。 该类中的所有抽象方法必须由希望提供特定算法的密钥生成器的实现的每个加密服务提供商来实现。

    如果客户端没有显式初始化KeyGenerator（通过调用init方法），则每个提供程序都必须提供（并记录）默认的初始化。 有关JDK提供程序使用的KeyGenerator默认值的信息，请参阅JDK Providers文档的Keysize Restriction部分。 不过，请注意，不同提供商的默认值可能会有所不同。 此外，提供者的默认值可能会在将来的版本中更改。 因此，建议显式地初始化KeyGenerator，而不是依赖于提供者特定的默认值。

    从以下版本开始：
    1.4
    另请参见：
    SecretKey

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyGeneratorSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      protected abstract SecretKey engineGenerateKey​()
      生成一个秘密密钥。
      protected abstract void engineInit​(int keysize, SecureRandom random)
      使用给定的随机源初始化该密钥生成器以进行某些密钥化。
      protected abstract void engineInit​(SecureRandom random)
      初始化密钥生成器。
      protected abstract void engineInit​(AlgorithmParameterSpec params, SecureRandom random)
      使用指定的参数集和用户提供的随机源初始化密钥生成器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyGeneratorSpi

        public KeyGeneratorSpi​()

    • 方法详细信息

      • engineInit

        protected abstract void engineInit​(SecureRandom random)
        初始化密钥生成器。
        参数
        random - 这个发电机的随机性来源

      • engineInit

        protected abstract void engineInit​(AlgorithmParameterSpec params,
                                   SecureRandom random)
                            throws InvalidAlgorithmParameterException
        使用指定的参数集和用户提供的随机源初始化密钥生成器。
        参数
        params - 关键代码参数
        random - 该密钥生成器的随机源
        异常
        InvalidAlgorithmParameterException - 如果 params不适合此密钥生成器

      • engineInit

        protected abstract void engineInit​(int keysize,
                                   SecureRandom random)
        使用给定的随机源初始化该密钥生成器以进行某些密钥化。
        参数
        keysize - keysize 。 这是一个以比特数表示的算法特定度量。
        random - 该密钥生成器的随机源
        异常
        InvalidParameterException - 如果 InvalidParameterException错误或不支持。

      • engineGenerateKey

        protected abstract SecretKey engineGenerateKey​()
        生成一个秘密密钥。
        结果
        the new key
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Mac (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class Mac

  • java.lang.Object
    • javax.crypto.Mac
  • All Implemented Interfaces:
    Cloneable

    public class Mac
extends Object
implements Cloneable
    该类提供了“消息验证码”（MAC）算法的功能。

    MAC提供了一种基于秘密密钥来检查在不可靠介质上传输或存储在信息中的信息的完整性的方法。 通常，在共享密钥的两方之间使用消息认证码，以验证在这些方之间传输的信息。

    基于加密散列函数的MAC机制被称为HMAC。 HMAC可以与任何加密散列函数一起使用，例如MD5或SHA-1与秘密共享密钥的组合。 HMAC在RFC 2104中规定。

    Java平台的每个实现都需要支持以下标准的Mac算法：

    • HmacMD5
    • HmacSHA1
    • HmacSHA256
    这些算法在Java安全标准算法名称规范的Mac section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Mac​(MacSpi macSpi, Provider provider, String algorithm)
      创建MAC对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      如果提供程序实现是可克隆的，则返回克隆。
      byte[] doFinal​()
      完成MAC操作。
      byte[] doFinal​(byte[] input)
      处理给定的字节数组，并完成MAC操作。
      void doFinal​(byte[] output, int outOffset)
      完成MAC操作。
      String getAlgorithm​()
      返回此 Mac对象的算法名称。
      static Mac getInstance​(String algorithm)
      返回实现指定MAC算法的 Mac对象。
      static Mac getInstance​(String algorithm, String provider)
      返回实现指定MAC算法的 Mac对象。
      static Mac getInstance​(String algorithm, Provider provider)
      返回实现指定MAC算法的 Mac对象。
      int getMacLength​()
      以字节为单位返回MAC的长度。
      Provider getProvider​()
      返回此 Mac对象的提供者。
      void init​(Key key)
      使用给定的键初始化此 Mac对象。
      void init​(Key key, AlgorithmParameterSpec params)
      使用给定的密钥和算法参数初始化此 Mac对象。
      void reset​()
      复位此 Mac对象。
      void update​(byte input)
      处理给定的字节。
      void update​(byte[] input)
      处理给定的字节数组。
      void update​(byte[] input, int offset, int len)
      处理第一 len字节 input ，起始于 offset以下。
      void update​(ByteBuffer input)
      处理 input.remaining()字节的ByteBuffer input ，从 input.position()开始。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Mac

        protected Mac​(MacSpi macSpi,
              Provider provider,
              String algorithm)
        创建MAC对象。
        参数
        macSpi - 代表
        provider - 提供商
        algorithm - 算法

    • 方法详细信息

      • getAlgorithm

        public final String getAlgorithm​()
        返回此Mac对象的算法名称。

        这是在创建此Mac对象的getInstance呼叫之一中指定的名称。

        结果
        这个 Mac对象的算法名称。

      • getInstance

        public static final Mac getInstance​(String algorithm)
                             throws NoSuchAlgorithmException
        返回实现指定MAC算法的Mac对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个提供者封装MacSpi实现的新Mac对象。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能与Security.getProviders()返回的提供商的顺序不同。
        参数
        algorithm - 请求的MAC算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的Mac部分。
        结果
        新的 Mac对象
        异常
        NoSuchAlgorithmException - 如果没有 Provider支持指定算法的 MacSpi实现
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final Mac getInstance​(String algorithm,
                                    String provider)
                             throws NoSuchAlgorithmException,
                                    NoSuchProviderException
        返回实现指定MAC算法的Mac对象。

        返回从指定的提供程序封装MacSpi实现的新Mac对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，注册提供商的列表可以通过Security.getProviders()方法检索。

        参数
        algorithm - 请求的MAC算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的Mac部分。
        provider - 提供商的名称。
        结果
        新的 Mac对象
        异常
        IllegalArgumentException - 如果 provider是 null或为空
        NoSuchAlgorithmException - 如果指定算法的 MacSpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final Mac getInstance​(String algorithm,
                                    Provider provider)
                             throws NoSuchAlgorithmException
        返回实现指定MAC算法的Mac对象。

        返回从指定的Provider对象封装MacSpi实现的新Mac对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 请求的MAC算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的Mac部分。
        provider - 提供商。
        结果
        新的 Mac对象
        异常
        IllegalArgumentException - 如果 provider是 null
        NoSuchAlgorithmException - 如果指定的算法的 MacSpi实现不能从指定的 Provider对象获得
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此 Mac对象的提供者。
        结果
        这个 Mac对象的提供者。

      • getMacLength

        public final int getMacLength​()
        以字节为单位返回MAC的长度。
        结果
        MAC长度（以字节为单位）。

      • init

        public final void init​(Key key)
                throws InvalidKeyException
        使用给定的键初始化此 Mac对象。
        参数
        key - 关键。
        异常
        InvalidKeyException - 如果给定的密钥不适合初始化该MAC。

      • init

        public final void init​(Key key,
                       AlgorithmParameterSpec params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
        使用给定的密钥和算法参数初始化此 Mac对象。
        参数
        key - 关键。
        params - 算法参数。
        异常
        InvalidKeyException - 如果给定的密钥不适合初始化该MAC。
        InvalidAlgorithmParameterException - 如果给定的算法参数不适合该MAC。

      • update

        public final void update​(byte input)
                  throws IllegalStateException
        处理给定的字节。
        参数
        input - 要处理的输入字节。
        异常
        IllegalStateException - 如果此 Mac尚未初始化。

      • update

        public final void update​(byte[] input)
                  throws IllegalStateException
        处理给定的字节数组。
        参数
        input - 要处理的字节数组。
        异常
        IllegalStateException - 如果这个 Mac尚未初始化。

      • update

        public final void update​(byte[] input,
                         int offset,
                         int len)
                  throws IllegalStateException
        处理第一 len字节 input ，起始于 offset以下。
        参数
        input - 输入缓冲区。
        offset - input中的输入开始的偏移量。
        len - 要处理的字节数。
        异常
        IllegalStateException - 如果这个 Mac尚未初始化。

      • update

        public final void update​(ByteBuffer input)
        处理input.remaining()字节的ByteBuffer input ，从input.position()开始。 返回时，缓冲区的位置将等于其限制; 其限制将不会改变。
        参数
        input - ByteBuffer
        异常
        IllegalStateException - 如果此 Mac尚未初始化。
        从以下版本开始：
        1.5

      • doFinal

        public final byte[] doFinal​()
                     throws IllegalStateException
        完成MAC操作。

        调用此方法将此Mac对象重置为先前通过调用init(Key)或init(Key, AlgorithmParameterSpec)初始化的状态。 也就是说，如果需要，通过对update和doFinal新呼叫，对象被重置并可用于从相同的密钥生成另一个MAC。 （为了使用不同的键重新使用Mac对象，必须通过调用init(Key)或init(Key, AlgorithmParameterSpec)重新初始化该对象。

        结果
        MAC结果。
        异常
        IllegalStateException - 如果这个 Mac尚未初始化。

      • doFinal

        public final void doFinal​(byte[] output,
                          int outOffset)
                   throws ShortBufferException,
                          IllegalStateException
        完成MAC操作。

        调用此方法将此Mac对象重置为先前通过调用init(Key)或init(Key, AlgorithmParameterSpec)初始化的状态。 也就是说，如果需要，通过对update和doFinal新呼叫，对象被重置并可用于从相同的密钥生成另一个MAC。 （为了使用不同的密钥重新使用Mac对象，必须通过调用init(Key)或init(Key, AlgorithmParameterSpec)重新初始化该对象。

        MAC结果存储在output ，从outOffset开始。

        参数
        output - 存储MAC结果的缓冲区
        outOffset - 存储MAC的 output中的偏移量
        异常
        ShortBufferException - 如果给定的输出缓冲区太小，不能保存结果
        IllegalStateException - 如果此 Mac尚未初始化。

      • doFinal

        public final byte[] doFinal​(byte[] input)
                     throws IllegalStateException
        处理给定的字节数组，并完成MAC操作。

        调用此方法将此Mac对象重置为之前通过调用init(Key)或init(Key, AlgorithmParameterSpec)初始化的状态。 也就是说，如果需要，通过对update和doFinal新呼叫，对象被重置并可用于从相同的密钥生成另一个MAC。 （为了使用不同的密钥重新使用此Mac对象，必须通过调用init(Key)或init(Key, AlgorithmParameterSpec)重新初始化该对象。

        参数
        input - 以字节为单位的数据
        结果
        MAC结果。
        异常
        IllegalStateException - 如果这个 Mac尚未初始化。

      • reset

        public final void reset​()
        重设此Mac对象。

        调用此方法将此Mac对象重置为之前通过调用init(Key)或init(Key, AlgorithmParameterSpec)初始化的状态。 也就是说，如果需要，通过对update和doFinal新呼叫，该对象被重置并可用于从相同的密钥生成另一个MAC。 （为了使用不同的密钥重新使用此Mac对象，必须通过调用init(Key)或init(Key, AlgorithmParameterSpec)重新初始化该对象。

      • clone

        public final Object clone​()
                   throws CloneNotSupportedException
        如果提供程序实现是可克隆的，则返回克隆。
        重写：
        clone在 Object
        结果
        一个克隆，如果提供者实现是可克隆的。
        异常
        CloneNotSupportedException - 如果这是在不支持 Cloneable的委托上调用的。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MacSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class MacSpi

  • java.lang.Object
    • javax.crypto.MacSpi

  • public abstract class MacSpi
extends Object
    该类定义了Mac类的 （ SPI ）。 该类中的所有抽象方法必须由希望提供特定MAC算法的实现的每个加密服务提供商来实现。

    实现可以实现Cloneable接口。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      MacSpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      如果实现是可克隆的，则返回克隆。
      protected abstract byte[] engineDoFinal​()
      完成MAC计算并重置MAC进一步使用，维护MAC初始化的秘密密钥。
      protected abstract int engineGetMacLength​()
      以字节为单位返回MAC的长度。
      protected abstract void engineInit​(Key key, AlgorithmParameterSpec params)
      用给定（秘密）密钥和算法参数初始化MAC。
      protected abstract void engineReset​()
      重置MAC进一步使用，维护MAC初始化的秘密密钥。
      protected abstract void engineUpdate​(byte input)
      处理给定的字节。
      protected abstract void engineUpdate​(byte[] input, int offset, int len)
      处理第一 len字节 input ，起始于 offset以下。
      protected void engineUpdate​(ByteBuffer input)
      处理 input.remaining()字节的ByteBuffer input ，从 input.position()开始。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MacSpi

        public MacSpi​()

    • 方法详细信息

      • engineGetMacLength

        protected abstract int engineGetMacLength​()
        以字节为单位返回MAC的长度。
        结果
        MAC长度（以字节为单位）。

      • engineInit

        protected abstract void engineInit​(Key key,
                                   AlgorithmParameterSpec params)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException
        用给定（秘密）密钥和算法参数初始化MAC。
        参数
        key - （秘密）键。
        params - 算法参数。
        异常
        InvalidKeyException - 如果给定的密钥不适合初始化该MAC。
        InvalidAlgorithmParameterException - 如果给定的算法参数不适合该MAC。

      • engineUpdate

        protected abstract void engineUpdate​(byte input)
        处理给定的字节。
        参数
        input - 要处理的输入字节。

      • engineUpdate

        protected abstract void engineUpdate​(byte[] input,
                                     int offset,
                                     int len)
        处理第一 len字节 input ，起始于 offset以下。
        参数
        input - 输入缓冲区。
        offset - input中的输入开始的偏移量。
        len - 要处理的字节数。

      • engineUpdate

        protected void engineUpdate​(ByteBuffer input)
        处理input.remaining()字节的ByteBuffer input ，从input.position()开始。 返回时，缓冲区的位置将等于其限制; 其限制将不会改变。

        子类应该考虑覆盖此方法，如果它们可以比字节数组更有效地处理ByteBuffers。

        参数
        input - ByteBuffer
        从以下版本开始：
        1.5

      • engineDoFinal

        protected abstract byte[] engineDoFinal​()
        完成MAC计算并重置MAC进一步使用，维护MAC初始化的秘密密钥。
        结果
        MAC结果。

      • engineReset

        protected abstract void engineReset​()
        重置MAC进一步使用，维护MAC初始化的秘密密钥。

      • clone

        public Object clone​()
             throws CloneNotSupportedException
        如果实现是可克隆的，则返回克隆。
        重写：
        clone在 Object
        结果
        一个克隆，如果实现是可克隆的。
        异常
        CloneNotSupportedException - 如果在不支持 Cloneable的实现上 Cloneable 。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NoSuchPaddingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class NoSuchPaddingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.crypto.NoSuchPaddingException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchPaddingException
extends GeneralSecurityException
    当请求特定的填充机制但在环境中不可用时抛出此异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchPaddingException​()
      构造一个没有详细消息的NoSuchPaddingException。
      NoSuchPaddingException​(String msg)
      构造具有指定详细消息的NoSuchPaddingException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchPaddingException

        public NoSuchPaddingException​()
        构造一个没有详细消息的NoSuchPaddingException。 详细消息是描述此特定异常的字符串。

      • NoSuchPaddingException

        public NoSuchPaddingException​(String msg)
        构造具有指定详细消息的NoSuchPaddingException。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NullCipher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class NullCipher

  • java.lang.Object
    • javax.crypto.Cipher
      • javax.crypto.NullCipher

  • public class NullCipher
extends Cipher
    NullCipher类是提供“身份密码”的类，不会转换纯文本。 因此，密文与明文相同。 所有初始化方法都不执行，而blockize设置为1个字节。
    从以下版本开始：
    1.4

    • Field Summary

      • Fields inherited from class javax.crypto.Cipher

        DECRYPT_MODE, ENCRYPT_MODE, PRIVATE_KEY, PUBLIC_KEY, SECRET_KEY, UNWRAP_MODE, WRAP_MODE

    • 构造方法摘要

      构造方法
      Constructor 描述
      NullCipher​()
      创建一个NullCipher对象。

    • 方法摘要

      • Methods inherited from class javax.crypto.Cipher

        doFinal, doFinal, doFinal, doFinal, doFinal, doFinal, doFinal, getAlgorithm, getBlockSize, getExemptionMechanism, getInstance, getInstance, getInstance, getIV, getMaxAllowedKeyLength, getMaxAllowedParameterSpec, getOutputSize, getParameters, getProvider, init, init, init, init, init, init, init, init, unwrap, update, update, update, update, update, updateAAD, updateAAD, updateAAD, wrap

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NullCipher

        public NullCipher​()
        创建一个NullCipher对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SealedObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class SealedObject

  • java.lang.Object
    • javax.crypto.SealedObject
  • All Implemented Interfaces:
    Serializable

    public class SealedObject
extends Object
implements Serializable
    该类使程序员能够使用加密算法创建对象并保护其机密性。

    给定任何可序列化对象，可以创建一个SealedObject，以序列化格式（即“深度拷贝”）封装原始对象，并使用DES等加密算法对其序列化内容进行封装（加密），以保护其机密性。 加密的内容可以随后被解密（使用相应的算法使用正确的解密密钥）并解串行化，产生原始对象。

    请注意，在应用于SealedObject之前，必须使用正确的算法，密钥，填充方案等将密码对象完全初始化。

    密封的原始物体可以通过两种不同的方法进行回收：

    • 通过使用Cipher对象的getObject方法。

      该方法需要一个完全初始化的对象，用与Cipher对象相同的算法，密钥，填充方案等进行初始化。

      这种方法的优点在于，开封密封对象的一方不需要知道解密密钥。 例如，在一方已经用所需的解密密钥初始化密码对象之后，它可以将密码对象交给另一方，然后该密码对象就开封密封对象。

    • 通过使用中的所述一个getObject种方法称取一个Key对象。

      在这种方法中， getObject方法为适当的解密算法创建一个密码对象，并使用给定的解密密钥和存储在密封对象中的算法参数（如果有的话）进行初始化。

      这种方法的优点在于，开封对象的方不需要跟踪用于密封对象的参数（例如，IV）。

    从以下版本开始：
    1.4
    另请参见：
    Cipher ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] encodedParams
      密码密码使用的密码参数，以默认格式编码。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        SealedObject​(Serializable object, Cipher c)
      从任何可序列化对象构造一个SealedObject。
      protected SealedObject​(SealedObject so)
      从传入的SealedObject构造一个SealedObject对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getAlgorithm​()
      返回用于密封此对象的算法。
      Object getObject​(Key key)
      检索原始（封装）对象。
      Object getObject​(Key key, String provider)
      检索原始（封装）对象。
      Object getObject​(Cipher c)
      检索原始（封装）对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • encodedParams

        protected byte[] encodedParams
        密码密码使用的密码参数，以默认格式编码。

        即cipher.getParameters().getEncoded() 。

    • 构造方法详细信息

      • SealedObject

        public SealedObject​(Serializable object,
                    Cipher c)
             throws IOException,
                    IllegalBlockSizeException
        从任何可序列化对象构造一个SealedObject。

        给定的对象被序列化，并且其序列化内容使用给定的密码进行加密，该密码必须被完全初始化。

        可能在加密操作中使用的任何算法参数都存储在新的SealedObject 。

        参数
        object - 要密封的物体; 可以为空。
        c - 用于密封对象的密码。
        异常
        NullPointerException - 如果给定的密码为空。
        IOException - 如果在序列化期间发生错误
        IllegalBlockSizeException - 如果给定的密码是块密码，则不会请求填充，并且总输入长度（即，序列化对象内容的长度）不是密码块大小的倍数

      • SealedObject

        protected SealedObject​(SealedObject so)
        从传入的SealedObject构造一个SealedObject对象。
        参数
        so - 一个SealedObject对象
        异常
        NullPointerException - 如果给定的密封对象为空。

    • 方法详细信息

      • getAlgorithm

        public final String getAlgorithm​()
        返回用于密封此对象的算法。
        结果
        用于密封该对象的算法。

      • getObject

        public final Object getObject​(Key key)
                       throws IOException,
                              ClassNotFoundException,
                              NoSuchAlgorithmException,
                              InvalidKeyException
        检索原始（封装）对象。

        该方法为密封操作中使用的算法创建一个密码。 如果默认提供程序包提供了该算法的实现，则使用包含该实现的Cipher的实例。 如果算法在默认包中不可用，则会搜索其他包。 使用给定的key和密封操作中使用的参数（如果有的话），将密码对象初始化以进行解密。

        封装的对象在被返回之前是未密封的并被解除序列化的。

        参数
        key - 用于打开对象的密钥。
        结果
        原来的对象。
        异常
        IOException - 如果在排序期间发生错误。
        ClassNotFoundException - 如果在排序期间发生错误。
        NoSuchAlgorithmException - 如果 NoSuchAlgorithmException对象的算法不可用。
        InvalidKeyException - 如果给定的键不能用于 InvalidKeyException对象（例如，它有错误的算法）。
        NullPointerException - 如果 key为空。

      • getObject

        public final Object getObject​(Cipher c)
                       throws IOException,
                              ClassNotFoundException,
                              IllegalBlockSizeException,
                              BadPaddingException
        检索原始（封装）对象。

        封装的对象是未密封的（使用给定的Cipher，假设密码已被正确初始化）并被取消序列化，然后返回。

        参数
        c - 用于开封对象的密码
        结果
        原来的对象。
        异常
        NullPointerException - 如果给定的密码为空。
        IOException - 如果在排序期间发生错误
        ClassNotFoundException - 如果在排序期间发生错误
        IllegalBlockSizeException - 如果给定的密码是块密码，则不会请求填充，总输入长度不是密码块大小的倍数
        BadPaddingException - 如果给定的密码已经被初始化用于解密，并且已经指定了填充，但是输入数据没有适当的预期填充字节

      • getObject

        public final Object getObject​(Key key,
                              String provider)
                       throws IOException,
                              ClassNotFoundException,
                              NoSuchAlgorithmException,
                              NoSuchProviderException,
                              InvalidKeyException
        检索原始（封装）对象。

        该方法使用从给定的provider的该算法的实现，为密封操作中使用的算法创建一个密码。 使用给定的key和在密封操作中使用的参数（如果有的话），将密码对象初始化以进行解密。

        封装的对象在被返回之前是未密封的并被解除序列化的。

        参数
        key - 用于打开对象的密钥。
        provider - provider对象的算法提供者的名称。
        结果
        原来的对象。
        异常
        IllegalArgumentException - 如果给定的提供者为空或为空。
        IOException - 如果在排序期间发生错误。
        ClassNotFoundException - 如果在排序期间发生错误。
        NoSuchAlgorithmException - 如果 NoSuchAlgorithmException对象的算法不可用。
        NoSuchProviderException - 如果给定的提供者未配置。
        InvalidKeyException - 如果给定的键不能用于 InvalidKeyException对象（例如，它的算法错误）。
        NullPointerException - 如果 key为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


SecretKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Interface SecretKey

  • All Superinterfaces:
    Destroyable ， Key ， Serializable
    All Known Subinterfaces:
    PBEKey
    所有已知实现类：
    EncryptionKey ， KerberosKey ， SecretKeySpec

    public interface SecretKey
extends Key, Destroyable
    一个秘密（对称）键。 该接口的目的是为所有密钥接口分组（并提供类型安全性）。

    该接口的提供者实现必须覆盖从Object继承的equals和hashCode方法，从而基于其基础密钥材料比较密钥，而不是基于引用。 实现应该覆盖来自Destroyable接口的默认destroy和isDestroyed方法，以使敏感密钥信息被销毁，清除，或者在这种信息是不可变的，未引用的情况下。 最后，由于SecretKey是Serializable ，实现还应该覆盖ObjectOutputStream.writeObject(java.lang.Object)以防止已被破坏的密钥被序列化。

    实现此接口的密钥返回字符串RAW作为其编码格式（参见getFormat ），并返回原始密钥字节作为getEncoded方法调用的结果。 （ getFormat和getEncoded方法从Key父接口继承。）

    从以下版本开始：
    1.4
    另请参见：
    SecretKeyFactory ， Cipher

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      从J2SE 1.4起设置为指示序列化兼容性的类指纹。

    • 方法摘要

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        从J2SE 1.4起设置为指示序列化兼容性的类指纹。
        另请参见：
        Constant Field Values
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


SecretKeyFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class SecretKeyFactory

  • java.lang.Object
    • javax.crypto.SecretKeyFactory

  • public class SecretKeyFactory
extends Object
    这个类代表一个秘密密钥的工厂。

    主要工厂用于将键 （ Key型的不透明加密密钥）转换为密钥规范 （基础密钥材料的透明表示），反之亦然。 秘密密钥工厂仅在秘密（对称）密钥上运行。

    关键工厂是双向的，即它们允许从给定的密钥规范（密钥材料）构建一个不透明的密钥对象，或以适当的格式检索密钥对象的基础密钥材料。

    应用程序开发人员应参考其提供商的文档，以了解generateSecret和getKeySpec方法支持哪些关键规范。 例如，由“SunJCE”提供商提供的DES秘密密钥工厂支持DESKeySpec作为DES密钥的透明表示，该提供商的三重DES密钥密钥工厂支持DESedeKeySpec作为三重DES密钥的透明表示。

    Java平台的每个实现都需要支持以下标准的SecretKeyFactory算法：

    • DES
    • DESede
    这些算法在Java安全标准算法名称规范的SecretKeyFactory section中进行了描述。 请参阅发行说明文件以了解是否支持其他算法。
    从以下版本开始：
    1.4
    另请参见：
    SecretKey ， DESKeySpec ， DESedeKeySpec ， PBEKeySpec

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SecretKeyFactory​(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
      创建一个SecretKeyFactory对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SecretKey generateSecret​(KeySpec keySpec)
      根据提供的密钥规范（密钥材料）生成一个 SecretKey对象。
      String getAlgorithm​()
      返回此 SecretKeyFactory对象的算法名称。
      static SecretKeyFactory getInstance​(String algorithm)
      返回转换指定算法的密钥的 SecretKeyFactory对象。
      static SecretKeyFactory getInstance​(String algorithm, String provider)
      返回转换指定算法的密钥的 SecretKeyFactory对象。
      static SecretKeyFactory getInstance​(String algorithm, Provider provider)
      返回一个转换指定算法的密钥的 SecretKeyFactory对象。
      KeySpec getKeySpec​(SecretKey key, Class<?> keySpec)
      以请求的格式返回给定键对象的规范（关键材料）。
      Provider getProvider​()
      返回此 SecretKeyFactory对象的提供者。
      SecretKey translateKey​(SecretKey key)
      将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SecretKeyFactory

        protected SecretKeyFactory​(SecretKeyFactorySpi keyFacSpi,
                           Provider provider,
                           String algorithm)
        创建一个SecretKeyFactory对象。
        参数
        keyFacSpi - 代表
        provider - 提供商
        algorithm - 秘密密钥算法

    • 方法详细信息

      • getInstance

        public static final SecretKeyFactory getInstance​(String algorithm)
                                          throws NoSuchAlgorithmException
        返回一个转换指定算法的密钥的SecretKeyFactory对象。

        此方法遍历已注册的安全提供程序列表，从最优选的提供程序开始。 返回从支持指定算法的第一个Provider中封装SecretKeyFactorySpi实现的新SecretKeyFactory对象。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        Implementation Note:
        JDK参考实现另外使用jdk.security.provider.preferred Security属性来确定指定算法的首选提供者顺序。 这可能不同于Security.getProviders()返回的提供商的顺序 。
        参数
        algorithm - 所请求密钥算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的SecretKeyFactory部分。
        结果
        新的 SecretKeyFactory对象
        异常
        NoSuchAlgorithmException Provider SecretKeyFactorySpi
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final SecretKeyFactory getInstance​(String algorithm,
                                                 String provider)
                                          throws NoSuchAlgorithmException,
                                                 NoSuchProviderException
        返回一个转换指定算法的密钥的SecretKeyFactory对象。

        返回从指定提供程序封装SecretKeyFactorySpi实现的新SecretKeyFactory对象。 指定的提供者必须在安全提供程序列表中注册。

        请注意，可以通过Security.getProviders()方法检索注册提供商的列表。

        参数
        algorithm - 所请求密钥算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的SecretKeyFactory部分。
        provider - 提供商的名称。
        结果
        新的 SecretKeyFactory对象
        异常
        IllegalArgumentException - 如果 provider是 null或空
        NoSuchAlgorithmException - 如果指定算法的 SecretKeyFactorySpi实现不能从指定的提供者获得
        NoSuchProviderException - 如果指定的提供程序未在安全提供程序列表中注册
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getInstance

        public static final SecretKeyFactory getInstance​(String algorithm,
                                                 Provider provider)
                                          throws NoSuchAlgorithmException
        返回一个转换指定算法的密钥的SecretKeyFactory对象。

        返回从指定的Provider对象封装SecretKeyFactorySpi实现的新SecretKeyFactory对象。 请注意，指定的Provider对象不必在提供者列表中注册。

        参数
        algorithm - 所请求密钥算法的标准名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names Specification中的SecretKeyFactory部分。
        provider - 提供商。
        结果
        新的 SecretKeyFactory对象
        异常
        IllegalArgumentException - 如果 provider是 null
        NoSuchAlgorithmException - 如果指定的算法的 SecretKeyFactorySpi实现不能从指定的 Provider对象获得
        NullPointerException - 如果 algorithm是 null
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider​()
        返回此 SecretKeyFactory对象的提供者。
        结果
        这个 SecretKeyFactory对象的提供者

      • getAlgorithm

        public final String getAlgorithm​()
        返回此SecretKeyFactory对象的算法名称。

        这是在创建此SecretKeyFactory对象的getInstance调用之一中指定的名称。

        结果
        这个 SecretKeyFactory对象的算法名称。

      • generateSecret

        public final SecretKey generateSecret​(KeySpec keySpec)
                               throws InvalidKeySpecException
        根据提供的密钥规范（密钥材料）生成一个 SecretKey对象。
        参数
        keySpec - 秘密密钥的规范（密钥材料）
        结果
        密钥
        异常
        InvalidKeySpecException - 如果给定的密钥规范不适合该秘密密钥工厂产生密钥。

      • getKeySpec

        public final KeySpec getKeySpec​(SecretKey key,
                                Class<?> keySpec)
                         throws InvalidKeySpecException
        以请求的格式返回给定键对象的规范（关键材料）。
        参数
        key - 关键
        keySpec - 要求退还关键材料的要求格式
        结果
        请求格式的基础密钥规范（密钥材料）
        异常
        InvalidKeySpecException - 如果请求的密钥规范对于给定的密钥是不合适的（例如，与 key和 keySpec相关联的算法不匹配，或者 key引用加密硬件设备上的密钥，而 keySpec是基于软件的密钥的规范）或者给定的密钥不能被处理（例如，给定的密钥具有该秘密密钥工厂不支持的算法或格式）。

      • translateKey

        public final SecretKey translateKey​(SecretKey key)
                             throws InvalidKeyException
        将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。
        参数
        key - 提供者未知或不信任的关键
        结果
        翻译密钥
        异常
        InvalidKeyException - 如果该密钥工厂无法处理给定的密钥。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SecretKeyFactorySpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class SecretKeyFactorySpi

  • java.lang.Object
    • javax.crypto.SecretKeyFactorySpi

  • public abstract class SecretKeyFactorySpi
extends Object
    该类定义了SecretKeyFactory类的 （ SPI ）。 该类中的所有抽象方法必须由希望为特定算法提供秘密密钥工厂的实现的每个加密服务提供商实现。

    提供商应记录其密钥工厂支持的所有关键规范。 例如，由“SunJCE”提供商提供的DES秘密密钥工厂支持DESKeySpec作为DES密钥的透明表示，该提供商的三重DES密钥密钥工厂支持DESedeKeySpec作为三重DES密钥的透明表示。

    从以下版本开始：
    1.4
    另请参见：
    SecretKey ， DESKeySpec ， DESedeKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      SecretKeyFactorySpi​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      protected abstract SecretKey engineGenerateSecret​(KeySpec keySpec)
      根据提供的密钥规范（密钥材料）生成一个 SecretKey对象。
      protected abstract KeySpec engineGetKeySpec​(SecretKey key, Class<?> keySpec)
      以请求的格式返回给定键对象的规范（关键材料）。
      protected abstract SecretKey engineTranslateKey​(SecretKey key)
      将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SecretKeyFactorySpi

        public SecretKeyFactorySpi​()

    • 方法详细信息

      • engineGenerateSecret

        protected abstract SecretKey engineGenerateSecret​(KeySpec keySpec)
                                           throws InvalidKeySpecException
        根据提供的密钥规范（密钥材料）生成一个 SecretKey对象。
        参数
        keySpec - 密钥的规范（密钥材料）
        结果
        密钥
        异常
        InvalidKeySpecException - 如果给定的密钥规范不适合该秘密密钥工厂产生密钥。

      • engineGetKeySpec

        protected abstract KeySpec engineGetKeySpec​(SecretKey key,
                                            Class<?> keySpec)
                                     throws InvalidKeySpecException
        以请求的格式返回给定键对象的规范（关键材料）。
        参数
        key - 关键
        keySpec - 要求退还关键材料的要求格式
        结果
        请求格式的基础密钥规范（密钥材料）
        异常
        InvalidKeySpecException - 如果所请求的密钥规范对于给定的密钥是不合适的（例如，与 key和 keySpec相关联的算法不匹配，或者 key引用加密硬件设备上的密钥，而 keySpec是基于软件的密钥的规范）或者给定的密钥不能被处理（例如，给定的密钥具有该秘密密钥工厂不支持的算法或格式）。

      • engineTranslateKey

        protected abstract SecretKey engineTranslateKey​(SecretKey key)
                                         throws InvalidKeyException
        将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。
        参数
        key - 提供者未知或不信任的关键
        结果
        翻译密钥
        异常
        InvalidKeyException - if the given key cannot be processed by this secret-key factory.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ShortBufferException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto

Class ShortBufferException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.crypto.ShortBufferException
  • All Implemented Interfaces:
    Serializable

    public class ShortBufferException
extends GeneralSecurityException
    当用户提供的输出缓冲区太短而不能保存操作结果时，抛出此异常。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ShortBufferException​()
      构造一个没有详细消息的ShortBufferException。
      ShortBufferException​(String msg)
      构造具有指定详细消息的ShortBufferException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ShortBufferException

        public ShortBufferException​()
        构造一个没有详细消息的ShortBufferException。 详细消息是描述此特定异常的字符串。

      • ShortBufferException

        public ShortBufferException​(String msg)
        构造具有指定详细消息的ShortBufferException。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.crypto (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.crypto

  • Packages that use javax.crypto
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
  • Classes in javax.crypto used by java.security
    Class 描述
    SecretKey
    一个秘密（对称）键。
  • Classes in javax.crypto used by javax.crypto
    Class 描述
    BadPaddingException
    当期望输入数据的特定填充机制但数据未正确填充时，会抛出此异常。
    Cipher
    该类提供加密和解密的加密密码的功能。
    CipherSpi
    该类定义了 Cipher类的 （ SPI ）。
    ExemptionMechanism
    这个类提供了豁免机制的功能，其中的例子是 密钥恢复 ， 密钥弱化和 密钥托管 。
    ExemptionMechanismException
    这是通用的ExemptionMechanism异常。
    ExemptionMechanismSpi
    该类定义了 ExemptionMechanism类的 （ SPI ）。
    IllegalBlockSizeException
    当提供给块密码的数据长度不正确时，抛出此异常，即与密码的块大小不匹配。
    KeyAgreement
    该类提供了密钥协议（或密钥交换）协议的功能。
    KeyAgreementSpi
    该类定义了 KeyAgreement类的 （ SPI ）。
    KeyGenerator
    该类提供了一个秘密（对称）密钥生成器的功能。
    KeyGeneratorSpi
    该类定义了 KeyGenerator类的 （ SPI ）。
    Mac
    该类提供了“消息验证码”（MAC）算法的功能。
    MacSpi
    该类定义了 Mac类的 （ SPI ）。
    NoSuchPaddingException
    当请求特定的填充机制但在环境中不可用时抛出此异常。
    SealedObject
    该类使程序员能够使用加密算法创建对象并保护其机密性。
    SecretKey
    一个秘密（对称）键。
    SecretKeyFactory
    这个类代表一个秘密密钥的工厂。
    SecretKeyFactorySpi
    该类定义了 SecretKeyFactory类的 （ SPI ）。
    ShortBufferException
    当用户提供的输出缓冲区太短而不能保存操作结果时，抛出此异常。
  • Classes in javax.crypto used by javax.crypto.interfaces
    Class 描述
    SecretKey
    一个秘密（对称）键。
  • Classes in javax.crypto used by javax.crypto.spec
    Class 描述
    SecretKey
    一个秘密（对称）键。
  • Classes in javax.crypto used by javax.security.auth.kerberos
    Class 描述
    SecretKey
    一个秘密（对称）键。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.AEADBadTagException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.AEADBadTagException

No usage of javax.crypto.AEADBadTagException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.BadPaddingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.BadPaddingException

  • Packages that use BadPaddingException
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of BadPaddingException in javax.crypto

      Subclasses of BadPaddingException in javax.crypto
      Modifier and Type Class 描述
      class  AEADBadTagException
      当以AEAD模式（例如GCM / CCM）运行的Cipher无法验证提供的认证标签时，会抛出此异常。
      Methods in javax.crypto that throw BadPaddingException
      Modifier and Type 方法 描述
      byte[] Cipher.doFinal​()
      完成多部分加密或解密操作，这取决于该密码如何初始化。
      byte[] Cipher.doFinal​(byte[] input)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(byte[] output, int outputOffset)
      完成多部分加密或解密操作，这取决于该密码如何初始化。
      byte[] Cipher.doFinal​(byte[] input, int inputOffset, int inputLen)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(byte[] input, int inputOffset, int inputLen, byte[] output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected abstract byte[] CipherSpi.engineDoFinal​(byte[] input, int inputOffset, int inputLen)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected abstract int CipherSpi.engineDoFinal​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected int CipherSpi.engineDoFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      Object SealedObject.getObject​(Cipher c)
      Retrieves the original (encapsulated) object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.Cipher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.Cipher

  • Packages that use Cipher
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of Cipher in javax.crypto

      Subclasses of Cipher in javax.crypto
      Modifier and Type Class 描述
      class  NullCipher
      NullCipher类是提供“身份密码”的类，不会转换纯文本。
      Methods in javax.crypto that return Cipher
      Modifier and Type 方法 描述
      static Cipher Cipher.getInstance​(String transformation)
      返回实现指定转换的 Cipher对象。
      static Cipher Cipher.getInstance​(String transformation, String provider)
      返回实现指定转换的 Cipher对象。
      static Cipher Cipher.getInstance​(String transformation, Provider provider)
      返回实现指定转换的 Cipher对象。
      Methods in javax.crypto with parameters of type Cipher
      Modifier and Type 方法 描述
      PKCS8EncodedKeySpec EncryptedPrivateKeyInfo.getKeySpec​(Cipher cipher)
      从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。
      Object SealedObject.getObject​(Cipher c)
      检索原始（封装）对象。
      Constructors in javax.crypto with parameters of type Cipher
      Constructor 描述
      CipherInputStream​(InputStream is, Cipher c)
      从InputStream和Cipher构造一个CipherInputStream。
      CipherOutputStream​(OutputStream os, Cipher c)
      从OutputStream和Cipher构造一个CipherOutputStream。
      SealedObject​(Serializable object, Cipher c)
      从任何可序列化对象构造一个SealedObject。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.CipherInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.CipherInputStream

No usage of javax.crypto.CipherInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.CipherOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.CipherOutputStream

No usage of javax.crypto.CipherOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.CipherSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.CipherSpi

  • Packages that use CipherSpi
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of CipherSpi in javax.crypto

      Constructors in javax.crypto with parameters of type CipherSpi
      Constructor 描述
      Cipher​(CipherSpi cipherSpi, Provider provider, String transformation)
      创建一个Cipher对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.EncryptedPrivateKeyInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.EncryptedPrivateKeyInfo

No usage of javax.crypto.EncryptedPrivateKeyInfo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.ExemptionMechanism (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.ExemptionMechanism

  • Packages that use ExemptionMechanism
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of ExemptionMechanism in javax.crypto

      Methods in javax.crypto that return ExemptionMechanism
      Modifier and Type 方法 描述
      ExemptionMechanism Cipher.getExemptionMechanism​()
      返回与此密码一起使用的豁免机制对象。
      static ExemptionMechanism ExemptionMechanism.getInstance​(String algorithm)
      返回一个 ExemptionMechanism对象，该对象实现指定的豁免机制算法。
      static ExemptionMechanism ExemptionMechanism.getInstance​(String algorithm, String provider)
      返回一个 ExemptionMechanism对象，实现指定的免除机制算法。
      static ExemptionMechanism ExemptionMechanism.getInstance​(String algorithm, Provider provider)
      返回一个 ExemptionMechanism对象，实现指定的豁免机制算法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.ExemptionMechanismException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.ExemptionMechanismException

  • Packages that use ExemptionMechanismException
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of ExemptionMechanismException in javax.crypto

      Methods in javax.crypto that throw ExemptionMechanismException
      Modifier and Type 方法 描述
      protected abstract byte[] ExemptionMechanismSpi.engineGenExemptionBlob​()
      生成豁免机制密钥blob。
      protected abstract int ExemptionMechanismSpi.engineGenExemptionBlob​(byte[] output, int outputOffset)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中，从 outputOffset开始。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key)
      使用密钥初始化此豁免机制。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      protected abstract void ExemptionMechanismSpi.engineInit​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      byte[] ExemptionMechanism.genExemptionBlob​()
      生成豁免机制密钥blob。
      int ExemptionMechanism.genExemptionBlob​(byte[] output)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中。
      int ExemptionMechanism.genExemptionBlob​(byte[] output, int outputOffset)
      生成豁免机制键blob，并将结果存储在 output缓冲区中，从 outputOffset开始。
      void ExemptionMechanism.init​(Key key)
      使用密钥初始化此豁免机制。
      void ExemptionMechanism.init​(Key key, AlgorithmParameters params)
      使用密钥和一组算法参数初始化此豁免机制。
      void ExemptionMechanism.init​(Key key, AlgorithmParameterSpec params)
      使用密钥和一组算法参数初始化此豁免机制。
      boolean ExemptionMechanism.isCryptoAllowed​(Key key)
      Returns whether the result blob has been generated successfully by this exemption mechanism.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.ExemptionMechanismSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.ExemptionMechanismSpi

  • Packages that use ExemptionMechanismSpi
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of ExemptionMechanismSpi in javax.crypto

      Constructors in javax.crypto with parameters of type ExemptionMechanismSpi
      Constructor 描述
      ExemptionMechanism​(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
      创建一个ExemptionMechanism对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.IllegalBlockSizeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.IllegalBlockSizeException

  • Packages that use IllegalBlockSizeException
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of IllegalBlockSizeException in javax.crypto

      Methods in javax.crypto that throw IllegalBlockSizeException
      Modifier and Type 方法 描述
      byte[] Cipher.doFinal​()
      完成多部分加密或解密操作，这取决于该密码如何初始化。
      byte[] Cipher.doFinal​(byte[] input)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(byte[] output, int outputOffset)
      完成多部分加密或解密操作，这取决于该密码如何初始化。
      byte[] Cipher.doFinal​(byte[] input, int inputOffset, int inputLen)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(byte[] input, int inputOffset, int inputLen, byte[] output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected abstract byte[] CipherSpi.engineDoFinal​(byte[] input, int inputOffset, int inputLen)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected abstract int CipherSpi.engineDoFinal​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected int CipherSpi.engineDoFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected byte[] CipherSpi.engineWrap​(Key key)
      包裹钥匙
      Object SealedObject.getObject​(Cipher c)
      检索原始（封装）对象。
      byte[] Cipher.wrap​(Key key)
      包裹钥匙
      Constructors in javax.crypto that throw IllegalBlockSizeException
      Constructor 描述
      SealedObject​(Serializable object, Cipher c)
      从任何可序列化对象构造一个SealedObject。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.KeyAgreement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.KeyAgreement

  • Packages that use KeyAgreement
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of KeyAgreement in javax.crypto

      Methods in javax.crypto that return KeyAgreement
      Modifier and Type 方法 描述
      static KeyAgreement KeyAgreement.getInstance​(String algorithm)
      返回实现指定密钥协商算法的 KeyAgreement对象。
      static KeyAgreement KeyAgreement.getInstance​(String algorithm, String provider)
      返回实现指定密钥协商算法的 KeyAgreement对象。
      static KeyAgreement KeyAgreement.getInstance​(String algorithm, Provider provider)
      返回实现指定的密钥协商算法的 KeyAgreement对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.KeyAgreementSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.KeyAgreementSpi

  • Packages that use KeyAgreementSpi
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of KeyAgreementSpi in javax.crypto

      Constructors in javax.crypto with parameters of type KeyAgreementSpi
      Constructor 描述
      KeyAgreement​(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
      创建一个KeyAgreement对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.KeyGenerator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.KeyGenerator

  • Packages that use KeyGenerator
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of KeyGenerator in javax.crypto

      Methods in javax.crypto that return KeyGenerator
      Modifier and Type 方法 描述
      static KeyGenerator KeyGenerator.getInstance​(String algorithm)
      返回一个生成指定算法的密钥的 KeyGenerator对象。
      static KeyGenerator KeyGenerator.getInstance​(String algorithm, String provider)
      返回一个产生指定算法的密钥的 KeyGenerator对象。
      static KeyGenerator KeyGenerator.getInstance​(String algorithm, Provider provider)
      返回一个生成指定算法的密钥的 KeyGenerator对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.KeyGeneratorSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.KeyGeneratorSpi

  • Packages that use KeyGeneratorSpi
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of KeyGeneratorSpi in javax.crypto

      Constructors in javax.crypto with parameters of type KeyGeneratorSpi
      Constructor 描述
      KeyGenerator​(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
      创建一个KeyGenerator对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.Mac (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.Mac

  • Packages that use Mac
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of Mac in javax.crypto

      Methods in javax.crypto that return Mac
      Modifier and Type 方法 描述
      static Mac Mac.getInstance​(String algorithm)
      返回实现指定MAC算法的 Mac对象。
      static Mac Mac.getInstance​(String algorithm, String provider)
      返回实现指定MAC算法的 Mac对象。
      static Mac Mac.getInstance​(String algorithm, Provider provider)
      返回实现指定MAC算法的 Mac对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.MacSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.MacSpi

  • Packages that use MacSpi
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of MacSpi in javax.crypto

      Constructors in javax.crypto with parameters of type MacSpi
      Constructor 描述
      Mac​(MacSpi macSpi, Provider provider, String algorithm)
      创建MAC对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.NoSuchPaddingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.NoSuchPaddingException

  • Packages that use NoSuchPaddingException
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of NoSuchPaddingException in javax.crypto

      Methods in javax.crypto that throw NoSuchPaddingException
      Modifier and Type 方法 描述
      protected abstract void CipherSpi.engineSetPadding​(String padding)
      设置这个密码的填充机制。
      static Cipher Cipher.getInstance​(String transformation)
      返回实现指定转换的 Cipher对象。
      static Cipher Cipher.getInstance​(String transformation, String provider)
      返回实现指定转换的 Cipher对象。
      static Cipher Cipher.getInstance​(String transformation, Provider provider)
      返回实现指定转换的 Cipher对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.NullCipher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.NullCipher

No usage of javax.crypto.NullCipher
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.SealedObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.SealedObject

  • Packages that use SealedObject
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of SealedObject in javax.crypto

      Constructors in javax.crypto with parameters of type SealedObject
      Constructor 描述
      SealedObject​(SealedObject so)
      从传入的SealedObject构造一个SealedObject对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.SecretKeyFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.SecretKeyFactory

  • Packages that use SecretKeyFactory
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of SecretKeyFactory in javax.crypto

      Methods in javax.crypto that return SecretKeyFactory
      Modifier and Type 方法 描述
      static SecretKeyFactory SecretKeyFactory.getInstance​(String algorithm)
      返回一个转换指定算法的密钥的 SecretKeyFactory对象。
      static SecretKeyFactory SecretKeyFactory.getInstance​(String algorithm, String provider)
      返回转换指定算法的密钥的 SecretKeyFactory对象。
      static SecretKeyFactory SecretKeyFactory.getInstance​(String algorithm, Provider provider)
      返回转换指定算法的密钥的 SecretKeyFactory对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.SecretKeyFactorySpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.SecretKeyFactorySpi

  • Packages that use SecretKeyFactorySpi
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of SecretKeyFactorySpi in javax.crypto

      Constructors in javax.crypto with parameters of type SecretKeyFactorySpi
      Constructor 描述
      SecretKeyFactory​(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
      创建一个SecretKeyFactory对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.ShortBufferException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.ShortBufferException

  • Packages that use ShortBufferException
    软件包 描述
    javax.crypto
    提供加密操作的类和接口。

    • Uses of ShortBufferException in javax.crypto

      Methods in javax.crypto that throw ShortBufferException
      Modifier and Type 方法 描述
      int Cipher.doFinal​(byte[] output, int outputOffset)
      完成多部分加密或解密操作，这取决于该密码如何初始化。
      int Cipher.doFinal​(byte[] input, int inputOffset, int inputLen, byte[] output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      int Cipher.doFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      void Mac.doFinal​(byte[] output, int outOffset)
      完成MAC操作。
      protected abstract int CipherSpi.engineDoFinal​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected int CipherSpi.engineDoFinal​(ByteBuffer input, ByteBuffer output)
      在单一部分操作中加密或解密数据，或完成多部分操作。
      protected abstract int KeyAgreementSpi.engineGenerateSecret​(byte[] sharedSecret, int offset)
      生成共享密钥，并将其放入缓冲区 sharedSecret ，从 offset开始。
      protected abstract int ExemptionMechanismSpi.engineGenExemptionBlob​(byte[] output, int outputOffset)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中，从 outputOffset开始。
      protected abstract int CipherSpi.engineUpdate​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      protected int CipherSpi.engineUpdate​(ByteBuffer input, ByteBuffer output)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      int KeyAgreement.generateSecret​(byte[] sharedSecret, int offset)
      生成共享密钥，并将其放入缓冲区 sharedSecret ，从 offset开始。
      int ExemptionMechanism.genExemptionBlob​(byte[] output)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中。
      int ExemptionMechanism.genExemptionBlob​(byte[] output, int outputOffset)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中，从 outputOffset开始。
      int Cipher.update​(byte[] input, int inputOffset, int inputLen, byte[] output)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      int Cipher.update​(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
      int Cipher.update​(ByteBuffer input, ByteBuffer output)
      继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.crypto.SecretKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.crypto.SecretKey

  • Packages that use SecretKey
    软件包 描述
    java.security
    提供安全框架的类和接口。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。

    • Uses of SecretKey in java.security

      Methods in java.security that return SecretKey
      Modifier and Type 方法 描述
      SecretKey KeyStore.SecretKeyEntry.getSecretKey​()
      从此条目获取 SecretKey 。
      Constructors in java.security with parameters of type SecretKey
      Constructor 描述
      SecretKeyEntry​(SecretKey secretKey)
      构造一个 SecretKeyEntry与 SecretKey 。
      SecretKeyEntry​(SecretKey secretKey, Set<KeyStore.Entry.Attribute> attributes)
      构造一个 SecretKeyEntry与 SecretKey及相关条目中的属性。

    • Uses of SecretKey in javax.crypto

      Methods in javax.crypto that return SecretKey
      Modifier and Type 方法 描述
      protected abstract SecretKey KeyGeneratorSpi.engineGenerateKey​()
      生成一个秘密密钥。
      protected abstract SecretKey KeyAgreementSpi.engineGenerateSecret​(String algorithm)
      创建共享密钥，并将其作为请求的算法类型的秘密密钥对象返回。
      protected abstract SecretKey SecretKeyFactorySpi.engineGenerateSecret​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成 SecretKey对象。
      protected abstract SecretKey SecretKeyFactorySpi.engineTranslateKey​(SecretKey key)
      将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。
      SecretKey KeyGenerator.generateKey​()
      生成一个秘密密钥。
      SecretKey KeyAgreement.generateSecret​(String algorithm)
      创建共享密钥，并将其作为指定算法的 SecretKey对象返回。
      SecretKey SecretKeyFactory.generateSecret​(KeySpec keySpec)
      从提供的密钥规范（密钥材料）生成一个 SecretKey对象。
      SecretKey SecretKeyFactory.translateKey​(SecretKey key)
      将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。
      Methods in javax.crypto with parameters of type SecretKey
      Modifier and Type 方法 描述
      protected abstract KeySpec SecretKeyFactorySpi.engineGetKeySpec​(SecretKey key, Class<?> keySpec)
      以请求的格式返回给定键对象的规范（关键材料）。
      protected abstract SecretKey SecretKeyFactorySpi.engineTranslateKey​(SecretKey key)
      将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。
      KeySpec SecretKeyFactory.getKeySpec​(SecretKey key, Class<?> keySpec)
      以请求的格式返回给定键对象的规范（关键材料）。
      SecretKey SecretKeyFactory.translateKey​(SecretKey key)
      将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。

    • Uses of SecretKey in javax.crypto.interfaces

      Subinterfaces of SecretKey in javax.crypto.interfaces
      Modifier and Type 接口 描述
      interface  PBEKey
      与PBE密钥的接口。

    • Uses of SecretKey in javax.crypto.spec

      Classes in javax.crypto.spec that implement SecretKey
      Modifier and Type Class 描述
      class  SecretKeySpec
      该类以独立于提供商的方式指定密钥。

    • Uses of SecretKey in javax.security.auth.kerberos

      Classes in javax.security.auth.kerberos that implement SecretKey
      Modifier and Type Class 描述
      class  EncryptionKey
      此类封装了Kerberos中使用的EncryptionKey。
      class  KerberosKey
      该类封装了Kerberos主体的长期密钥。
      Methods in javax.security.auth.kerberos that return SecretKey
      Modifier and Type 方法 描述
      SecretKey KerberosTicket.getSessionKey​()
      Returns the session key associated with this ticket.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


DHKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.interfaces

Interface DHKey

  • All Known Subinterfaces:
    DHPrivateKey ， DHPublicKey

    public interface DHKey
    与Diffie-Hellman密钥的接口。
    从以下版本开始：
    1.4
    另请参见：
    DHParameterSpec ， DHPublicKey ， DHPrivateKey

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      DHParameterSpec getParams​()
      返回关键参数。

    • 方法详细信息

      • getParams

        DHParameterSpec getParams​()
        返回关键参数。
        结果
        the key parameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DHPrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.interfaces

Interface DHPrivateKey

  • All Superinterfaces:
    Destroyable ， DHKey ， Key ， PrivateKey ， Serializable

    public interface DHPrivateKey
extends DHKey, PrivateKey
    与Diffie-Hellman私钥的接口。
    从以下版本开始：
    1.4
    另请参见：
    DHKey ， DHPublicKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      从J2SE 1.4起设置为指示序列化兼容性的类指纹。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getX​()
      返回私有值， x 。

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from interface javax.crypto.interfaces.DHKey

        getParams

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        从J2SE 1.4起设置为指示序列化兼容性的类指纹。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getX

        BigInteger getX​()
        返回私有值， x 。
        结果
        私有价值， x
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DHPublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.interfaces

Interface DHPublicKey

  • All Superinterfaces:
    DHKey ， Key ， PublicKey ， Serializable

    public interface DHPublicKey
extends DHKey, PublicKey
    与Diffie-Hellman公钥的接口。
    从以下版本开始：
    1.4
    另请参见：
    DHKey ， DHPrivateKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      从J2SE 1.4起设置为指示序列化兼容性的类指纹。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BigInteger getY​()
      返回公共值， y 。

      • Methods inherited from interface javax.crypto.interfaces.DHKey

        getParams

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        从J2SE 1.4起设置为指示序列化兼容性的类指纹。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getY

        BigInteger getY​()
        返回公共值， y 。
        结果
        公共价值， y
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javax.crypto.interfaces (Java SE 9 & JDK 9 )

javax.crypto.interfaces

Interfaces

  • DHKey
  • DHPrivateKey
  • DHPublicKey
  • PBEKey


javax.crypto.interfaces (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package javax.crypto.interfaces

提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。

请注意，这些接口仅适用于密钥实现，其密钥资料可访问和可用。 这些接口不适用于其密钥材料驻留在不可访问的受保护存储（如硬件设备）中的密钥实现。

有关如何使用这些接口的更多开发者信息，包括有关如何为硬件设备设计Key类的信息，请参阅加密提供程序开发人员指南：

  • How to Implement a Provider in the Java Cryptography Architecture

包装规格

  • PKCS＃3：Diffie-Hellman Key-Agreement Standard，版本1.4，1993年11月。

相关文档

有关进一步的文档，请参阅：
  • Java Cryptography Architecture (JCA) Reference Guide
从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    DHKey
    与Diffie-Hellman密钥的接口。
    DHPrivateKey
    与Diffie-Hellman私钥的接口。
    DHPublicKey
    与Diffie-Hellman公钥的接口。
    PBEKey
    与PBE密钥的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.crypto.interfaces Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.crypto.interfaces

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.security.auth.Destroyable
    • java.security.PrivateKey (also extends java.security.Key)
      • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey)
    • javax.crypto.SecretKey (also extends java.security.Key)
      • javax.crypto.interfaces.PBEKey
  • javax.crypto.interfaces.DHKey
    • javax.crypto.interfaces.DHPrivateKey (also extends java.security.PrivateKey)
    • javax.crypto.interfaces.DHPublicKey (also extends java.security.PublicKey)
  • java.io.Serializable
    • java.security.Key
      • java.security.PrivateKey (also extends javax.security.auth.Destroyable)
        • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey)
      • java.security.PublicKey
        • javax.crypto.interfaces.DHPublicKey (also extends javax.crypto.interfaces.DHKey)
      • javax.crypto.SecretKey (also extends javax.security.auth.Destroyable)
        • javax.crypto.interfaces.PBEKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


PBEKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.interfaces

Interface PBEKey

  • All Superinterfaces:
    Destroyable ， Key ， SecretKey ， Serializable

    public interface PBEKey
extends SecretKey
    与PBE密钥的接口。
    从以下版本开始：
    1.4
    另请参见：
    PBEKeySpec ， SecretKey

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long serialVersionUID
      从J2SE 1.4起设置为指示序列化兼容性的类指纹。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getIterationCount​()
      返回迭代计数，如果未指定则返回0。
      char[] getPassword​()
      返回密码。
      byte[] getSalt​()
      如果没有指定，则返回salt或null。

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from interface java.security.Key

        getAlgorithm, getEncoded, getFormat

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        从J2SE 1.4起设置为指示序列化兼容性的类指纹。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getPassword

        char[] getPassword​()
        返回密码。

        注意：此方法应返回密码副本。 呼叫者有责任在不再需要密码信息后将其清除。

        结果
        密码。

      • getSalt

        byte[] getSalt​()
        如果没有指定，则返回salt或null。

        注意：此方法应返回盐的副本。 呼叫者有责任在不再需要盐信息后将其清除掉。

        结果
        盐。

      • getIterationCount

        int getIterationCount​()
        返回迭代计数，如果未指定则返回0。
        结果
        迭代计数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Package javax.crypto.interfaces (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.crypto.interfaces

  • Packages that use javax.crypto.interfaces
    软件包 描述
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
  • Classes in javax.crypto.interfaces used by javax.crypto.interfaces
    Class 描述
    DHKey
    与Diffie-Hellman密钥的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.crypto.interfaces.DHKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.crypto.interfaces.DHKey

  • Packages that use DHKey
    软件包 描述
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。

    • Uses of DHKey in javax.crypto.interfaces

      Subinterfaces of DHKey in javax.crypto.interfaces
      Modifier and Type 接口 描述
      interface  DHPrivateKey
      与Diffie-Hellman私钥的接口。
      interface  DHPublicKey
      与Diffie-Hellman公钥的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.crypto.interfaces.DHPrivateKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.crypto.interfaces.DHPrivateKey

No usage of javax.crypto.interfaces.DHPrivateKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.crypto.interfaces.DHPublicKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.crypto.interfaces.DHPublicKey

No usage of javax.crypto.interfaces.DHPublicKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.crypto.interfaces.PBEKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.crypto.interfaces.PBEKey

No usage of javax.crypto.interfaces.PBEKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


DESedeKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class DESedeKeySpec

  • java.lang.Object
    • javax.crypto.spec.DESedeKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class DESedeKeySpec
extends Object
implements KeySpec
    该类指定DES-EDE（“triple-DES”）键。
    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DES_EDE_KEY_LEN
      定义DESede密钥长度的常数（以字节为单位）。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DESedeKeySpec​(byte[] key)
      创建使用前24个字节在一个DESedeKeySpec对象， key作为DES-EDE密钥的密钥材料。
      DESedeKeySpec​(byte[] key, int offset)
      创建使用前24个字节在一个DESedeKeySpec对象， key ，在开始 offset以下，作为DES-EDE密钥的密钥材料。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getKey​()
      返回DES-EDE键。
      static boolean isParityAdjusted​(byte[] key, int offset)
      检查给定的DES-EDE密钥是否从 offset开始进行奇偶校验。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DES_EDE_KEY_LEN

        public static final int DES_EDE_KEY_LEN
        定义DESede密钥长度的常数（以字节为单位）。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DESedeKeySpec

        public DESedeKeySpec​(byte[] key)
              throws InvalidKeyException
        创建使用前24个字节在一个DESedeKeySpec对象， key作为DES-EDE密钥的密钥材料。

        构成DES-EDE密钥的字节是key[0]和key[23]之间的key[0]

        参数
        key - 具有DES-EDE密钥资料的缓冲区。 缓冲区的前24个字节被复制以防止后续修改。
        异常
        NullPointerException - 如果 key为空。
        InvalidKeyException - 如果给定的密钥材料短于24个字节。

      • DESedeKeySpec

        public DESedeKeySpec​(byte[] key,
                     int offset)
              throws InvalidKeyException
        创建使用前24个字节在一个DESedeKeySpec对象， key ，在开始offset以下，作为DES-EDE密钥的密钥材料。

        构成DES-EDE密钥的字节是key[offset]和key[offset+23]之间的key[offset] 。

        参数
        key - 具有DES-EDE密钥的缓冲区。 从offset开始的缓冲区的前24个字节被复制以防止后续修改。
        offset -在偏移 key的DES-EDE密钥的开始。
        异常
        NullPointerException - 如果 key为空。
        InvalidKeyException - 如果给定的密钥材料（从 offset开始，小于24个字节）

    • 方法详细信息

      • getKey

        public byte[] getKey​()
        返回DES-EDE键。
        结果
        DES-EDE键。 每次调用此方法时都会返回一个新数组。

      • isParityAdjusted

        public static boolean isParityAdjusted​(byte[] key,
                                       int offset)
                                throws InvalidKeyException
        检查给定的DES-EDE密钥是否从 offset开始进行奇偶校验。
        参数
        key - 保存键值的字节数组
        offset - 字节数组的偏移量
        结果
        如果给定的DES-EDE密钥是奇偶校验调整的，则为真，否则为false
        异常
        NullPointerException - 如果 key为空。
        InvalidKeyException - 如果给定的密钥材料（从 offset开始，小于24个字节）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DESKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class DESKeySpec

  • java.lang.Object
    • javax.crypto.spec.DESKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class DESKeySpec
extends Object
implements KeySpec
    该类指定一个DES密钥。
    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DES_KEY_LEN
      定义DES密钥长度的常量（以字节为单位）。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DESKeySpec​(byte[] key)
      创建使用前8个字节中一个DESKeySpec对象， key作为DES密钥的密钥材料。
      DESKeySpec​(byte[] key, int offset)
      创建使用前8个字节中一个DESKeySpec对象， key ，在开始 offset以下，作为DES密钥的密钥材料。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getKey​()
      返回DES密钥材料。
      static boolean isParityAdjusted​(byte[] key, int offset)
      检查给定的DES密钥材料，从 offset包括起始）进行奇偶校验调整。
      static boolean isWeak​(byte[] key, int offset)
      检查给定的DES密钥材料是弱还是弱弱。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DES_KEY_LEN

        public static final int DES_KEY_LEN
        定义DES密钥长度的常量（以字节为单位）。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DESKeySpec

        public DESKeySpec​(byte[] key)
           throws InvalidKeyException
        创建使用前8个字节中一个DESKeySpec对象， key作为DES密钥的密钥材料。

        构成DES密钥的字节是key[0]和key[7]之间的字节。

        参数
        key - 具有DES密钥资料的缓冲区。 复制缓冲区的前8个字节以防止后续修改。
        异常
        NullPointerException - 如果给定的密钥资料是 null
        InvalidKeyException - 如果给定的密钥材料短于8个字节。

      • DESKeySpec

        public DESKeySpec​(byte[] key,
                  int offset)
           throws InvalidKeyException
        创建使用前8个字节中一个DESKeySpec对象， key ，在开始offset以下，作为DES密钥的密钥材料。

        构成DES密钥的字节是key[offset]和key[offset+7]之间的字节。

        参数
        key - 具有DES密钥资料的缓冲区。 从offset开始的缓冲区的前8个字节被复制以防止后续修改。
        offset - 在 key的偏移量，其中DES密钥材料启动。
        异常
        NullPointerException - 如果给定的密钥材料是 null
        InvalidKeyException - 如果给定的密钥材料（从 offset开始）小于8个字节。

    • 方法详细信息

      • getKey

        public byte[] getKey​()
        返回DES密钥材料。
        结果
        DES的关键材料。 每次调用此方法时都会返回一个新数组。

      • isParityAdjusted

        public static boolean isParityAdjusted​(byte[] key,
                                       int offset)
                                throws InvalidKeyException
        检查从 offset开始，给出的DES密钥材料是否进行奇偶校验。
        参数
        key - 具有DES密钥资料的缓冲区。
        offset - 在 key的偏移量，其中DES密钥材料启动。
        结果
        如果给定的DES密钥材料是奇偶校验调整的，则为真，否则为false。
        异常
        InvalidKeyException - 如果给定的密钥材料是 null ，或从 offset开始，短于8个字节。

      • isWeak

        public static boolean isWeak​(byte[] key,
                             int offset)
                      throws InvalidKeyException
        检查给定的DES密钥材料是弱还是弱弱。
        参数
        key - 具有DES密钥资料的缓冲区。
        offset - 在 key的偏移量，其中DES密钥材料启动。
        结果
        如果给定的DES密钥材料为弱或半弱，则为真，否则为false。
        异常
        InvalidKeyException - 如果给定的密钥材料是 null ，或从 offset开始，短于8个字节。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DHGenParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class DHGenParameterSpec

  • java.lang.Object
    • javax.crypto.spec.DHGenParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class DHGenParameterSpec
extends Object
implements AlgorithmParameterSpec
    此类指定用于生成Diffie-Hellman密钥协议中使用的Diffie-Hellman（系统）参数的参数集。 这通常由中央机关完成。

    中央机关在计算参数后，必须将这些信息发送给寻求秘密密钥协商的各方。

    从以下版本开始：
    1.4
    另请参见：
    DHParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      DHGenParameterSpec​(int primeSize, int exponentSize)
      构造用于生成Diffie-Hellman（系统）参数的参数集。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getExponentSize​()
      返回随机指数（私有值）的位大小。
      int getPrimeSize​()
      返回素数模数的大小。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DHGenParameterSpec

        public DHGenParameterSpec​(int primeSize,
                          int exponentSize)
        构造用于生成Diffie-Hellman（系统）参数的参数集。 构造的参数集可以用于初始化一个AlgorithmParameterGenerator对象，用于生成Diffie-Hellman参数。
        参数
        primeSize - 素数模数的大小（以位为单位）。
        exponentSize - 随机指数的大小（以位为单位）。

    • 方法详细信息

      • getPrimeSize

        public int getPrimeSize​()
        返回素数模数的大小。
        结果
        质量模数的大小（以位为单位）

      • getExponentSize

        public int getExponentSize​()
        返回随机指数（私有值）的位大小。
        结果
        随机指数（私有值）的位大小
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DHParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class DHParameterSpec

  • java.lang.Object
    • javax.crypto.spec.DHParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class DHParameterSpec
extends Object
implements AlgorithmParameterSpec
    该类指定与PKCS＃3： Diffie-Hellman密钥协商标准中指定的Diffie-Hellman算法一起使用的参数集合。

    中央权力机构生成参数并将其提供给寻求生成秘密密钥的两个实体。 参数是素数p ，基数g ，以及可选的私有值的位长度， l 。

    可能的是，多个参数实例可能由给定的中央机构生成，并且可能有多个中央权限。 事实上，每个人都可能是自己的中央权威，不同的实体有不同的参数。

    请注意，此类不对指定的参数执行任何验证。 因此，即使它们为空，也会直接返回指定的值。

    从以下版本开始：
    1.4
    另请参见：
    KeyAgreement

    • 构造方法摘要

      构造方法
      Constructor 描述
      DHParameterSpec​(BigInteger p, BigInteger g)
      使用质数模数 p和基本生成器 g构造Diffie-Hellman的参数集。
      DHParameterSpec​(BigInteger p, BigInteger g, int l)
      使用质数模数 p ，基本产生器 g和随机指数（私有值）的位大小（ l构造Diffie-Hellman的参数集。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getG​()
      返回基本生成器 g 。
      int getL​()
      返回随机指数（私有值）的大小（ l ）。
      BigInteger getP​()
      返回素数模数 p 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DHParameterSpec

        public DHParameterSpec​(BigInteger p,
                       BigInteger g)
        使用质数模数 p和基本生成器 g构造Diffie-Hellman的参数集。
        参数
        p - 质量模量
        g - 基地发电机

      • DHParameterSpec

        public DHParameterSpec​(BigInteger p,
                       BigInteger g,
                       int l)
        使用素数模式 p ，基本产生器 g和随机指数（私有值）的位大小（ l构造Diffie-Hellman的参数集。
        参数
        p - 质量模数
        g - 基本生成器
        l - 随机指数（私有值）的位大小

    • 方法详细信息

      • getP

        public BigInteger getP​()
        返回素数模数 p 。
        结果
        模数 p

      • getG

        public BigInteger getG​()
        返回基本生成器 g 。
        结果
        基座发生器 g

      • getL

        public int getL​()
        返回随机指数（私有值）的大小（ l ）。
        结果
        随机指数（私有值）的位大小（ l ），如果此大小尚未设置，则为0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DHPrivateKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class DHPrivateKeySpec

  • java.lang.Object
    • javax.crypto.spec.DHPrivateKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class DHPrivateKeySpec
extends Object
implements KeySpec
    该类指定具有相关参数的Diffie-Hellman私钥。

    请注意，此类不对指定的参数执行任何验证。 因此，即使它们为空，也会直接返回指定的值。

    从以下版本开始：
    1.4
    另请参见：
    DHPublicKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      DHPrivateKeySpec​(BigInteger x, BigInteger p, BigInteger g)
      具有私有值 x ，素数模数 p和基本生成器 g 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getG​()
      返回基本生成器 g 。
      BigInteger getP​()
      返回素数模数 p 。
      BigInteger getX​()
      返回私有值 x 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DHPrivateKeySpec

        public DHPrivateKeySpec​(BigInteger x,
                        BigInteger p,
                        BigInteger g)
        具有私有值 x ，素数模数 p和基本生成器 g 。
        参数
        x - 私有价值x
        p - 质量模数p
        g - 基地发电机g

    • 方法详细信息

      • getX

        public BigInteger getX​()
        返回私有值 x 。
        结果
        私有价值 x

      • getP

        public BigInteger getP​()
        返回质数模数 p 。
        结果
        模数 p

      • getG

        public BigInteger getG​()
        返回基本生成器 g 。
        结果
        基座发生器 g
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DHPublicKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class DHPublicKeySpec

  • java.lang.Object
    • javax.crypto.spec.DHPublicKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class DHPublicKeySpec
extends Object
implements KeySpec
    该类指定具有相关参数的Diffie-Hellman公钥。

    请注意，此类不对指定的参数执行任何验证。 因此，即使它们为空，也会直接返回指定的值。

    从以下版本开始：
    1.4
    另请参见：
    DHPrivateKeySpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      DHPublicKeySpec​(BigInteger y, BigInteger p, BigInteger g)
      具有公开值 y ，质数模数 p和基本生成器 g 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger getG​()
      返回基本生成器 g 。
      BigInteger getP​()
      返回素数模数 p 。
      BigInteger getY​()
      返回公共值 y 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DHPublicKeySpec

        public DHPublicKeySpec​(BigInteger y,
                       BigInteger p,
                       BigInteger g)
        具有公开值 y ，素数模数 p和基本生成器 g 。
        参数
        y - 公共价值y
        p - 质量模数p
        g - 基地发电机g

    • 方法详细信息

      • getY

        public BigInteger getY​()
        返回公共值 y 。
        结果
        公开号 y

      • getP

        public BigInteger getP​()
        返回素数模数 p 。
        结果
        质量模数 p

      • getG

        public BigInteger getG​()
        返回基本生成器 g 。
        结果
        基本产生器 g
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GCMParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class GCMParameterSpec

  • java.lang.Object
    • javax.crypto.spec.GCMParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class GCMParameterSpec
extends Object
implements AlgorithmParameterSpec
    指定使用伽罗瓦/计数器模式（GCM）模式的Cipher所需的一组参数。

    简单的块密码模式（如CBC）通常只需要一个初始化向量（如IvParameterSpec ），但GCM需要这些参数：

    • IV ：初始化向量（IV）
    • tLen ：认证标签T的长度（以比特为单位）

    除了这里描述的参数外，其他GCM输入/输出（附加认证数据（AAD），密钥，分组密码，简单/密文和认证标签）都在Cipher类中处理。

    请参见RFC 5116有关具有关联数据（AEAD）算法的认证加密的更多信息，以及NIST Special Publication 800-38D “NIST推荐用于块密码操作模式：伽罗瓦/计数器模式（GCM）和GMAC”。

    GCM规范规定，对于某些应用程序， tLen可能只有值{ tLen }或{ tLen }。 可以为此类指定其他值，但并不是所有的CSP实现都将支持它们。

    从以下版本开始：
    1.7
    另请参见：
    Cipher

    • 构造方法摘要

      构造方法
      Constructor 描述
      GCMParameterSpec​(int tLen, byte[] src)
      使用指定的认证标签位长度和IV缓冲区构造GCMParameterSpec。
      GCMParameterSpec​(int tLen, byte[] src, int offset, int len)
      使用指定的身份验证标记位长度和指定缓冲区的子集作为IV构造一个GCMParameterSpec对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getIV​()
      返回初始化向量（IV）。
      int getTLen​()
      返回认证标签长度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GCMParameterSpec

        public GCMParameterSpec​(int tLen,
                        byte[] src)
        使用指定的认证标签位长度和IV缓冲区构造GCMParameterSpec。
        参数
        tLen - 认证标签长度（以位为单位）
        src - IV源缓冲区。 复制缓冲区的内容以防止后续修改。
        异常
        IllegalArgumentException - 如果 tLen为负数，或 src为空。

      • GCMParameterSpec

        public GCMParameterSpec​(int tLen,
                        byte[] src,
                        int offset,
                        int len)
        使用指定的身份验证标记位长度和指定缓冲区的子集作为IV构造一个GCMParameterSpec对象。
        参数
        tLen - 认证标签长度（以位为单位）
        src - IV源缓冲区。 复制缓冲区的内容以防止后续修改。
        offset - 在 src的偏移，其中IV开始
        len - IV字节数
        异常
        IllegalArgumentException - 如果 tLen为负，则 src为空， len或 offset为负，或者 offset和 len和大于 src字节数组的长度。

    • 方法详细信息

      • getTLen

        public int getTLen​()
        返回认证标签长度。
        结果
        认证标签长度（以位为单位）

      • getIV

        public byte[] getIV​()
        返回初始化向量（IV）。
        结果
        四。 每次调用此方法时都会创建一个新数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IvParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class IvParameterSpec

  • java.lang.Object
    • javax.crypto.spec.IvParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class IvParameterSpec
extends Object
implements AlgorithmParameterSpec
    该类指定初始化向量 （IV）。 使用IV的实例是反馈模式中的密码，例如CBC模式下的DES和具有OAEP编码操作的RSA密码。
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      IvParameterSpec​(byte[] iv)
      使用 iv的字节作为IV创建IvParameterSpec对象。
      IvParameterSpec​(byte[] iv, int offset, int len)
      创建使用第一构造一个IvParameterSpec对象 len字节 iv ，在开始 offset以下，作为IV。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getIV​()
      返回初始化向量（IV）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IvParameterSpec

        public IvParameterSpec​(byte[] iv)
        使用 iv的字节作为IV创建IvParameterSpec对象。
        参数
        iv - 具有IV的缓冲区。 复制缓冲区的内容以防止后续修改。
        异常
        NullPointerException - 如果 iv是 null

      • IvParameterSpec

        public IvParameterSpec​(byte[] iv,
                       int offset,
                       int len)
        创建使用第一构造一个IvParameterSpec对象len字节iv ，在开始offset以下，作为IV。

        构成IV的字节是iv[offset]和iv[offset+len-1]之间的字节。

        参数
        iv - 具有IV的缓冲区。 从offset包括起始）开始的缓冲区的第一个len个字节被复制以防止后续修改。
        offset - 在 iv的偏移量，其中IV开始。
        len - IV字节数。
        异常
        IllegalArgumentException - 如果 iv是 null或 (iv.length - offset < len)
        ArrayIndexOutOfBoundsException - 抛出 offset或 len索引字节外的 iv 。

    • 方法详细信息

      • getIV

        public byte[] getIV​()
        返回初始化向量（IV）。
        结果
        初始化向量（IV）。 每次调用此方法时都会返回一个新数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.crypto.spec (Java SE 9 & JDK 9 )

javax.crypto.spec

Classes

  • DESedeKeySpec
  • DESKeySpec
  • DHGenParameterSpec
  • DHParameterSpec
  • DHPrivateKeySpec
  • DHPublicKeySpec
  • GCMParameterSpec
  • IvParameterSpec
  • OAEPParameterSpec
  • PBEKeySpec
  • PBEParameterSpec
  • PSource
  • PSource.PSpecified
  • RC2ParameterSpec
  • RC5ParameterSpec
  • SecretKeySpec


javax.crypto.spec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package javax.crypto.spec

提供关键规范和算法参数规范的类和接口。

关键规范是构成关键材料的透明表示。 密钥可以以特定于算法的方式或与算法无关的编码格式（例如ASN.1）来指定。 此软件包包含Diffie-Hellman公钥和私钥的关键规范，以及DES，Triple DES和PBE密钥的关键规范。

算法参数规范是与算法一起使用的参数集合的透明表示。 该包包含与Diffie-Hellman，DES，Triple DES，PBE，RC2和RC5算法一起使用的参数的算法参数规范。

  • PKCS＃3：Diffie-Hellman Key-Agreement Standard，版本1.4，1993年11月。
  • PKCS＃5：基于密码的加密标准，版本1.5，1993年11月。
  • 联邦信息处理标准出版物（FIPS PUB）46-2：数据加密标准（DES）

相关文档

有关算法参数和关键规格信息的文档，请参阅：
  • Java Cryptography Architecture (JCA) Reference Guide
  • How to Implement a Provider in the Java Cryptography Architecture
从以下版本开始：
1.4
  • 类摘要
    Class 描述
    DESedeKeySpec
    该类指定DES-EDE（“triple-DES”）键。
    DESKeySpec
    该类指定一个DES密钥。
    DHGenParameterSpec
    此类指定用于生成Diffie-Hellman密钥协议中使用的Diffie-Hellman（系统）参数的参数集。
    DHParameterSpec
    该类指定与PKCS＃3： Diffie-Hellman密钥协商标准中指定的Diffie-Hellman算法一起使用的参数集合。
    DHPrivateKeySpec
    该类指定具有相关参数的Diffie-Hellman私钥。
    DHPublicKeySpec
    该类指定具有相关参数的Diffie-Hellman公钥。
    GCMParameterSpec
    指定使用伽罗瓦/计数器模式（GCM）模式的Cipher所需的一组参数。
    IvParameterSpec
    该类指定 初始化向量 （IV）。
    OAEPParameterSpec
    此类指定与OAEP填充一起使用的参数集，如 PKCS #1标准中所定义。
    PBEKeySpec
    用户选择的密码，可用于基于密码的加密（ PBE ）。
    PBEParameterSpec
    此类指定与 PKCS #5标准中定义的基于密码的加密（PBE）一起使用的参数集。
    PSource
    该类指定在OAEP填充中编码输入P的源，如 PKCS #1标准中所定义。
    PSource.PSpecified
    该类用于在OAEP填充中明确指定编码输入P的值。
    RC2ParameterSpec
    该类指定与 RC2算法一起使用的参数。
    RC5ParameterSpec
    该类指定与 RC5算法一起使用的参数。
    SecretKeySpec
    该类以独立于提供商的方式指定密钥。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.crypto.spec Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.crypto.spec

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.crypto.spec.DESedeKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DESKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DHGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHPrivateKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DHPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.GCMParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.IvParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.OAEPParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.PBEKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.PBEParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.PSource
      • javax.crypto.spec.PSource.PSpecified
    • javax.crypto.spec.RC2ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.RC5ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.SecretKeySpec (implements java.security.spec.KeySpec, javax.crypto.SecretKey)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


OAEPParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class OAEPParameterSpec

  • java.lang.Object
    • javax.crypto.spec.OAEPParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class OAEPParameterSpec
extends Object
implements AlgorithmParameterSpec
    该类指定与OAEP填充一起使用的参数集，如PKCS #1标准中所定义。 其PKCS＃1标准中的ASN.1定义如下：
      RSAES-OAEP-params ::= SEQUENCE {
   hashAlgorithm      [0] OAEP-PSSDigestAlgorithms     DEFAULT sha1,
   maskGenAlgorithm   [1] PKCS1MGFAlgorithms  DEFAULT mgf1SHA1,
   pSourceAlgorithm   [2] PKCS1PSourceAlgorithms  DEFAULT pSpecifiedEmpty
 }
    哪里
      OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-sha1 PARAMETERS NULL   }|
   { OID id-sha256 PARAMETERS NULL }|
   { OID id-sha384 PARAMETERS NULL }|
   { OID id-sha512 PARAMETERS NULL },
   ...  -- Allows for future expansion --
 }
 PKCS1MGFAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-mgf1 PARAMETERS OAEP-PSSDigestAlgorithms },
   ...  -- Allows for future expansion --
 }
 PKCS1PSourceAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-pSpecified PARAMETERS OCTET STRING },
   ...  -- Allows for future expansion --
 }

    注意：OAEPParameterSpec.DEFAULT使用以下消息：消息摘要 - “SHA-1”掩码生成函数（mgf） - mgf的“MGF1”参数 - MGF1ParameterSpec.SHA1编码输入源 - PSource.PSpecified.DEFAULT

    从以下版本开始：
    1.5
    另请参见：
    MGF1ParameterSpec ， PSource

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static OAEPParameterSpec DEFAULT
      OAEP参数设置为所有默认值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      OAEPParameterSpec​(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
      构造为使用指定的消息摘要算法在PKCS＃1标准中定义的OAEP冗余参数集 mdName ，掩码生成函数算法 mgfName ，掩码生成函数参数 mgfSpec编码输入P的，和源 pSrc 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getDigestAlgorithm​()
      返回消息摘要算法名称。
      String getMGFAlgorithm​()
      返回掩码生成函数算法名称。
      AlgorithmParameterSpec getMGFParameters​()
      返回掩码生成函数的参数。
      PSource getPSource​()
      返回编码输入P的来源。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT

        public static final OAEPParameterSpec DEFAULT
        OAEP参数设置为所有默认值。

    • 构造方法详细信息

      • OAEPParameterSpec

        public OAEPParameterSpec​(String mdName,
                         String mgfName,
                         AlgorithmParameterSpec mgfSpec,
                         PSource pSrc)
        构造为使用指定的消息摘要算法在PKCS＃1标准中定义的OAEP冗余参数集 mdName ，掩码生成函数算法 mgfName ，掩码生成函数参数 mgfSpec编码输入P的，和源 pSrc 。
        参数
        mdName - 消息摘要的算法名称。
        mgfName - 掩码生成函数的算法名称。
        mgfSpec - 掩码生成函数的参数。 如果指定为null，则由getMGFParameters（）返回null。
        pSrc - 编码输入的源
        异常
        NullPointerException -如果 mdName ， mgfName ，或 pSrc为null。

    • 方法详细信息

      • getDigestAlgorithm

        public String getDigestAlgorithm​()
        返回消息摘要算法名称。
        结果
        消息摘要算法名称。

      • getMGFAlgorithm

        public String getMGFAlgorithm​()
        返回掩码生成函数算法名称。
        结果
        面具生成函数算法名称。

      • getMGFParameters

        public AlgorithmParameterSpec getMGFParameters​()
        返回掩码生成函数的参数。
        结果
        掩膜生成功能的参数。

      • getPSource

        public PSource getPSource​()
        返回编码输入P的来源。
        结果
        the source of encoding input P.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PBEKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class PBEKeySpec

  • java.lang.Object
    • javax.crypto.spec.PBEKeySpec
  • All Implemented Interfaces:
    KeySpec

    public class PBEKeySpec
extends Object
implements KeySpec
    用户选择的密码，可用于基于密码的加密（ PBE ）。

    该密码可以被看作是某种原始密钥材料，使用它的加密机制从该密钥材料获得加密密钥。

    不同的PBE机制可能会消耗每个密码字符的不同位。 例如， PKCS #5中定义的PBE机制仅查看每个字符的低位8位，而PKCS＃12查看每个字符的所有16位。

    您可以通过创建相应密钥工厂的实例将密码字符转换为PBE密钥。 例如，PKCS＃5的秘密密钥工厂将仅从每个密码字符的低8位构造一个PBE密钥，而PKCS＃12的秘密密钥工厂将占用每个字符的所有16位。

    还要注意，这个类将密码存储为char数组而不是String对象（这似乎更合乎逻辑），因为String类是不可变的，当不再需要存储在其中的密码时，没有办法覆盖其内部值。 因此，此类请求密码为char数组，因此完成后可以覆盖该字符串。

    从以下版本开始：
    1.4
    另请参见：
    SecretKeyFactory ， PBEParameterSpec

    • 构造方法摘要

      构造方法
      Constructor 描述
      PBEKeySpec​(char[] password)
      使用密码的构造方法。
      PBEKeySpec​(char[] password, byte[] salt, int iterationCount)
      构造函数采用密码，盐，迭代计数，生成固定密钥大小的PBE密码的PBEKey。
      PBEKeySpec​(char[] password, byte[] salt, int iterationCount, int keyLength)
      构造函数，它使用密码，盐，迭代计数和待导出的密钥长度来生成可变密钥大小的PBE密码的PBEKey。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clearPassword​()
      清除密码的内部副本。
      int getIterationCount​()
      返回迭代计数，如果未指定则返回0。
      int getKeyLength​()
      返回要导出的密钥长度，如果未指定则返回0。
      char[] getPassword​()
      返回密码的副本。
      byte[] getSalt​()
      如果没有指定，则返回salt的副本。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PBEKeySpec

        public PBEKeySpec​(char[] password)
        使用密码的构造方法。 如果指定了null，则使用空的char []。

        注意： password在存储在新的PBEKeySpec对象之前被克隆。

        参数
        password - 密码。

      • PBEKeySpec

        public PBEKeySpec​(char[] password,
                  byte[] salt,
                  int iterationCount,
                  int keyLength)
        构造函数，它使用密码，盐，迭代计数和待导出的密钥长度来生成可变密钥大小的PBE密码的PBEKey。 如果为password指定了null，则使用空字符[]。

        注意： password和salt在被存储在新的PBEKeySpec对象之前被克隆。

        参数
        password - 密码。
        salt - 盐。
        iterationCount - 迭代计数。
        keyLength - 要导出的密钥长度。
        异常
        NullPointerException - 如果 salt为空。
        IllegalArgumentException - 如果 salt为空，即0长度， iterationCount或 keyLength不为正。

      • PBEKeySpec

        public PBEKeySpec​(char[] password,
                  byte[] salt,
                  int iterationCount)
        构造函数采用密码，盐，迭代计数，生成固定密钥大小的PBE密码的PBEKey。 如果为password指定了null，则使用空字符[]。

        注意： password和salt被存储在新的PBEKeySpec对象之前被克隆。

        参数
        password - 密码。
        salt - 盐。
        iterationCount - 迭代计数。
        异常
        NullPointerException - 如果 salt为空。
        IllegalArgumentException - 如果 salt为空，即0长度，或 iterationCount不为正。

    • 方法详细信息

      • clearPassword

        public final void clearPassword​()
        清除密码的内部副本。

      • getPassword

        public final char[] getPassword​()
        返回密码的副本。

        注意：此方法返回密码的副本。 呼叫者有责任在不再需要密码信息后将其清除。

        结果
        密码。
        异常
        IllegalStateException - 如果通过调用 clearPassword方法清除了密码。

      • getSalt

        public final byte[] getSalt​()
        如果没有指定，则返回salt的副本。

        注意：此方法应返回盐的副本。 呼叫者有责任在不再需要盐信息后将其清除掉。

        结果
        盐。

      • getIterationCount

        public final int getIterationCount​()
        返回迭代计数，如果未指定则返回0。
        结果
        迭代计数。

      • getKeyLength

        public final int getKeyLength​()
        返回要导出的密钥长度，如果未指定则返回0。

        注意：这用于指示可变密钥大小密码对密钥长度的偏好。 实际的密钥大小取决于每个提供者的实现。

        结果
        the to-be-derived key length.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PBEParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class PBEParameterSpec

  • java.lang.Object
    • javax.crypto.spec.PBEParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class PBEParameterSpec
extends Object
implements AlgorithmParameterSpec
    该类指定了基于密码的加密（PBE）使用的参数集，如 PKCS #5标准中所定义。
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      PBEParameterSpec​(byte[] salt, int iterationCount)
      构建PKCS＃5标准中定义的基于密码的加密参数集。
      PBEParameterSpec​(byte[] salt, int iterationCount, AlgorithmParameterSpec paramSpec)
      构建PKCS＃5标准中定义的基于密码的加密参数集。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getIterationCount​()
      返回迭代计数。
      AlgorithmParameterSpec getParameterSpec​()
      返回密码算法参数规范。
      byte[] getSalt​()
      返回盐。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PBEParameterSpec

        public PBEParameterSpec​(byte[] salt,
                        int iterationCount)
        构建PKCS＃5标准中定义的基于密码的加密参数集。
        参数
        salt - 盐。 复制salt的内容以防止后续修改。
        iterationCount - 迭代计数。
        异常
        NullPointerException - 如果 salt为空。

      • PBEParameterSpec

        public PBEParameterSpec​(byte[] salt,
                        int iterationCount,
                        AlgorithmParameterSpec paramSpec)
        构建PKCS＃5标准中定义的基于密码的加密参数集。
        参数
        salt - 盐。 复制salt的内容以防止后续修改。
        iterationCount - 迭代计数。
        paramSpec - 密码算法参数规范，可能为null。
        异常
        NullPointerException - 如果 salt为空。
        从以下版本开始：
        1.8

    • 方法详细信息

      • getSalt

        public byte[] getSalt​()
        返回盐。
        结果
        盐。 每次调用此方法时都会返回一个新数组。

      • getIterationCount

        public int getIterationCount​()
        返回迭代计数。
        结果
        迭代计数

      • getParameterSpec

        public AlgorithmParameterSpec getParameterSpec​()
        返回密码算法参数规范。
        结果
        参数规范，如果没有设置，则为null。
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class PSource

  • java.lang.Object
    • javax.crypto.spec.PSource
  • 已知直接子类：
    PSource.PSpecified

    public class PSource
extends Object
    该类指定了在OAEP填充中编码输入P的源，如PKCS #1标准中所定义。
      PKCS1PSourceAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-pSpecified PARAMETERS OCTET STRING },
   ...  -- Allows for future expansion --
 }
    从以下版本开始：
    1.5

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  PSource.PSpecified
      该类用于在OAEP填充中明确指定编码输入P的值。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected PSource​(String pSrcName)
      使用指定的PSource算法构建PKCS＃1标准中定义的OAEP填充的编码输入P的源。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getAlgorithm​()
      返回PSource算法名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PSource

        protected PSource​(String pSrcName)
        使用指定的PSource算法构建PKCS＃1标准中定义的OAEP填充的编码输入P的源。
        参数
        pSrcName - 编码输入源的算法
        异常
        NullPointerException - 如果 pSrcName为空。

    • 方法详细信息

      • getAlgorithm

        public String getAlgorithm​()
        返回PSource算法名称。
        结果
        PSource算法名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PSource.PSpecified (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class PSource.PSpecified

  • java.lang.Object
    • javax.crypto.spec.PSource
      • javax.crypto.spec.PSource.PSpecified
  • Enclosing class:
    PSource

    public static final class PSource.PSpecified
extends PSource
    该类用于在OAEP填充中明确指定编码输入P的值。
    从以下版本开始：
    1.5

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.crypto.spec.PSource

        PSource.PSpecified

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PSource.PSpecified DEFAULT
      编码输入P的值等于byte [0]。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PSpecified​(byte[] p)
      使用指定值 p明确构建源作为编码输入P.

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getValue​()
      返回编码输入P的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.crypto.spec.PSource

        getAlgorithm

    • 字段详细信息

      • DEFAULT

        public static final PSource.PSpecified DEFAULT
        编码输入P的值等于byte [0]。

    • 构造方法详细信息

      • PSpecified

        public PSpecified​(byte[] p)
        使用指定值 p作为编码输入P明确构建源。注意：
        参数
        p - 编码输入的值。 复制数组的内容以防止后续修改。
        异常
        NullPointerException - 如果 p为空。

    • 方法详细信息

      • getValue

        public byte[] getValue​()
        返回编码输入P的值。
        结果
        编码输入P的值。每次调用此方法时都会返回一个新数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


RC2ParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class RC2ParameterSpec

  • java.lang.Object
    • javax.crypto.spec.RC2ParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class RC2ParameterSpec
extends Object
implements AlgorithmParameterSpec
    此类指定与RC2算法一起使用的参数。

    参数由有效的密钥大小和可选的8字节初始化向量（IV）组成（仅在反馈模式下）。

    该类可用于初始化实现RC2算法的Cipher对象。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      RC2ParameterSpec​(int effectiveKeyBits)
      根据给定的有效密钥大小（以位为单位）构建RC2的参数集。
      RC2ParameterSpec​(int effectiveKeyBits, byte[] iv)
      从给定的有效密钥大小（以比特）和8字节的IV构造一个RC2参数集。
      RC2ParameterSpec​(int effectiveKeyBits, byte[] iv, int offset)
      从给定的有效密钥大小（以位）和IV构造一个RC2参数集。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      测试指定对象和此对象之间的相等性。
      int getEffectiveKeyBits​()
      以位为单位返回有效密钥大小。
      byte[] getIV​()
      如果此参数集不包含IV，则返回IV或null。
      int hashCode​()
      计算对象的哈希码值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RC2ParameterSpec

        public RC2ParameterSpec​(int effectiveKeyBits)
        根据给定的有效密钥大小（以位为单位）构建RC2的参数集。
        参数
        effectiveKeyBits - 有效密钥大小（以比特为单位）。

      • RC2ParameterSpec

        public RC2ParameterSpec​(int effectiveKeyBits,
                        byte[] iv)
        从给定的有效密钥大小（以比特）和8字节的IV构造一个RC2参数集。

        构成IV的字节是iv[0]和iv[7]之间的字节。

        参数
        effectiveKeyBits - 有效密钥大小（以比特为单位）。
        iv - 具有8字节IV的缓冲区。 复制缓冲区的前8个字节以防止后续修改。
        异常
        IllegalArgumentException - 如果 iv为空。

      • RC2ParameterSpec

        public RC2ParameterSpec​(int effectiveKeyBits,
                        byte[] iv,
                        int offset)
        从给定的有效密钥大小（以位）和IV构造一个RC2参数集。

        IV取自iv ，起始于offset 。 构成IV的字节是iv[offset]和iv[offset+7]之间的字节。

        参数
        effectiveKeyBits - 有效的密钥大小（以比特为单位）。
        iv - 具有IV的缓冲区。 从offset开始的缓冲区的前8个字节被复制以防止后续修改。
        offset - 偏移在 iv其中8字节IV启动。
        异常
        IllegalArgumentException - 如果 iv为空。

    • 方法详细信息

      • getEffectiveKeyBits

        public int getEffectiveKeyBits​()
        以位为单位返回有效密钥大小。
        结果
        有效的密钥大小以位为单位。

      • getIV

        public byte[] getIV​()
        如果此参数集不包含IV，则返回IV或null。
        结果
        IV或如果此参数集不包含IV，则为null。 每次调用此方法时都会返回一个新数组。

      • equals

        public boolean equals​(Object obj)
        测试指定对象和此对象之间的相等性。 如果两个RC2ParameterSpec对象的有效密钥大小和IV相等，则它们被认为是相等的。 （两个IV引用被认为是相等的，如果两者都是null ）
        重写：
        equals在 Object
        参数
        obj - 要测试与此对象相等的对象。
        结果
        如果对象被视为相等， obj true，如果 obj为空， obj false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算对象的哈希码值。 相等的对象也将具有相同的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RC5ParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class RC5ParameterSpec

  • java.lang.Object
    • javax.crypto.spec.RC5ParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec

    public class RC5ParameterSpec
extends Object
implements AlgorithmParameterSpec
    该类指定与RC5算法一起使用的参数。

    这些参数包括版本号，回合计数，字大小和可选的初始化向量（IV）（仅在反馈模式中）。

    该类可用于初始化Cipher实现由RSA Security LLC或由RSA Security授权的任何方提供的RC5算法的对象。

    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      RC5ParameterSpec​(int version, int rounds, int wordSize)
      从给定版本，圆数和字大小（以位为单位）构造RC5的参数集。
      RC5ParameterSpec​(int version, int rounds, int wordSize, byte[] iv)
      从给定版本，回合数，字大小（以位为单位）和IV构造RC5的参数集。
      RC5ParameterSpec​(int version, int rounds, int wordSize, byte[] iv, int offset)
      从给定版本，回合数，字大小（以位为单位）和IV构造RC5的参数集。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      测试指定对象和此对象之间的相等性。
      byte[] getIV​()
      如果此参数集不包含IV，则返回IV或null。
      int getRounds​()
      返回轮数。
      int getVersion​()
      返回版本。
      int getWordSize​()
      以位为单位返回字大小。
      int hashCode​()
      计算对象的哈希码值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RC5ParameterSpec

        public RC5ParameterSpec​(int version,
                        int rounds,
                        int wordSize)
        从给定版本，圆数和字大小（以位为单位）构造RC5的参数集。
        参数
        version - 版本。
        rounds - 回合数。
        wordSize - 字大小（以位为单位）。

      • RC5ParameterSpec

        public RC5ParameterSpec​(int version,
                        int rounds,
                        int wordSize,
                        byte[] iv)
        从给定版本，回合数，字大小（以位为单位）和IV构造RC5的参数集。

        请注意，IV（块大小）的大小必须是字大小的两倍。 构成IV的字节是iv[0]和iv[2*(wordSize/8)-1]之间的字节。

        参数
        version - 版本。
        rounds - 回合数。
        wordSize - 字大小（以位为单位）。
        iv - 具有IV的缓冲区。 缓冲区的第一个2*(wordSize/8)字节被复制以防止后续修改。
        异常
        IllegalArgumentException - 如果 iv是 null或 (iv.length < 2 * (wordSize / 8))

      • RC5ParameterSpec

        public RC5ParameterSpec​(int version,
                        int rounds,
                        int wordSize,
                        byte[] iv,
                        int offset)
        从给定版本，回合数，字大小（以位为单位）和IV构造RC5的参数集。

        IV取自iv ，起始于offset 。 请注意，从offset包括起始）开始的IV（块大小）的大小必须是字大小的两倍。 构成IV的字节是iv[offset]和iv[offset+2*(wordSize/8)-1]之间的字节。

        参数
        version - 版本。
        rounds - 回合数。
        wordSize - 字大小（以位为单位）。
        iv - 具有IV的缓冲区。 第一2*(wordSize/8)字节在开始缓冲的offset包容被复制到防止后续修改。
        offset - 在 iv的偏移，其中IV开始。
        异常
        IllegalArgumentException - 如果 iv是 null或 (iv.length - offset < 2 * (wordSize / 8))

    • 方法详细信息

      • getVersion

        public int getVersion​()
        返回版本。
        结果
        的版本。

      • getRounds

        public int getRounds​()
        返回轮数。
        结果
        轮次数。

      • getWordSize

        public int getWordSize​()
        以位为单位返回字大小。
        结果
        单词大小以位为单位。

      • getIV

        public byte[] getIV​()
        如果此参数集不包含IV，则返回IV或null。
        结果
        IV或如果此参数集不包含IV，则为null。 每次调用此方法时都会返回一个新数组。

      • equals

        public boolean equals​(Object obj)
        测试指定对象和此对象之间的相等性。 如果两个RC5ParameterSpec对象的版本号，回合数，字长和IV相等，则两个RC5ParameterSpec对象被认为是相等的。 （两个IV引用被认为是相等的，如果两者都是null ）
        重写：
        equals在 Object
        参数
        obj - 要测试与此对象相等的对象。
        结果
        如果对象被视为相等， obj true，如果 obj为空， obj false。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算对象的哈希码值。 相等的对象也将具有相同的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SecretKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 javax.crypto.spec

Class SecretKeySpec

  • java.lang.Object
    • javax.crypto.spec.SecretKeySpec
  • All Implemented Interfaces:
    Serializable ， Key ， KeySpec ， SecretKey ， Destroyable

    public class SecretKeySpec
extends Object
implements KeySpec, SecretKey
    该类以独立于提供商的方式指定密钥。

    它可以用于从字节数组构造SecretKey ，而无需经过（基于提供者的） SecretKeyFactory 。

    此类仅对可以表示为字节数组并且没有与其相关联的关键参数的原始密钥（例如DES或三重DES密钥）有用。

    从以下版本开始：
    1.4
    另请参见：
    SecretKey ， SecretKeyFactory ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SecretKeySpec​(byte[] key, int offset, int len, String algorithm)
      根据给定的字节数组的秘密密钥，使用所述第一 len的字节 key ，起始于 offset以下。
      SecretKeySpec​(byte[] key, String algorithm)
      从给定的字节数组构造一个秘密密钥。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      测试指定对象和此对象之间的相等性。
      String getAlgorithm​()
      返回与该密钥相关联的算法的名称。
      byte[] getEncoded​()
      返回此密钥的密钥材料。
      String getFormat​()
      返回此密钥的编码格式的名称。
      int hashCode​()
      计算对象的哈希码值。

      • Methods inherited from interface javax.security.auth.Destroyable

        destroy, isDestroyed

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SecretKeySpec

        public SecretKeySpec​(byte[] key,
                     String algorithm)
        从给定的字节数组构造一个秘密密钥。

        该构造函数不检查给定字节是否确实指定了指定算法的秘密密钥。 例如，如果算法为DES，则该构造函数不会检查key是否为8字节长，也不会检查弱或半弱的密钥。 为了执行这些检查，应该使用特定于算法的密钥规范类（在这种情况下为DESKeySpec ）。

        参数
        key - 密钥的关键材料。 复制数组的内容以防止后续修改。
        algorithm - 与给定密钥材料相关联的秘密密钥算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names文档。
        异常
        IllegalArgumentException - 如果 algorithm为空或 key为空或为空。

      • SecretKeySpec

        public SecretKeySpec​(byte[] key,
                     int offset,
                     int len,
                     String algorithm)
        根据给定的字节数组的秘密密钥，使用所述第一len的字节key ，起始于offset以下。

        构成秘密密钥的字节是key[offset]和key[offset+len-1]之间的字节。

        该构造函数不检查给定字节是否确实指定了指定算法的秘密密钥。 例如，如果算法为DES，则该构造函数不会检查key是否为8字节长，并且也不会检查弱或半弱的密钥。 为了执行这些检查，必须使用特定于算法的密钥规范类（在这种情况下为DESKeySpec ）。

        参数
        key - 密钥的关键材料。 从offset包括）开始的阵列的第一个len字节被复制以防止后续修改。
        offset - key中的关键材料启动时的偏移量。
        len - 关键材料的长度。
        algorithm - 与给定密钥材料相关联的秘密密钥算法的名称。 有关标准算法名称的信息，请参阅Java Security Standard Algorithm Names文档。
        异常
        IllegalArgumentException - 如果 algorithm为null或 key为空，空或太短，即 key.length-offset<len 。
        ArrayIndexOutOfBoundsException - 抛出 offset或 len索引字节外的 key 。

    • 方法详细信息

      • getAlgorithm

        public String getAlgorithm​()
        返回与该密钥相关联的算法的名称。
        Specified by:
        getAlgorithm在接口 Key
        结果
        秘密密钥算法。

      • getFormat

        public String getFormat​()
        返回此密钥的编码格式的名称。
        Specified by:
        getFormat在接口 Key
        结果
        字符串“RAW”。

      • getEncoded

        public byte[] getEncoded​()
        返回此密钥的密钥材料。
        Specified by:
        getEncoded接口 Key
        结果
        关键材料。 每次调用此方法时都会返回一个新数组。

      • hashCode

        public int hashCode​()
        计算对象的哈希码值。 相等的对象也将具有相同的哈希码。
        重写：
        hashCode Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        测试指定对象和此对象之间的相等性。 如果两个SecretKeySpec对象都是具有相同的不区分大小写的算法名称和密钥编码的SecretKey实例，则它们被认为是相等的。
        重写：
        equals在 Object
        参数
        obj - 测试与此对象相等的对象。
        结果
        如果对象被视为相等， obj true，如果 obj为空， obj false。
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.crypto.spec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.crypto.spec

  • Packages that use javax.crypto.spec
    软件包 描述
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
  • Classes in javax.crypto.spec used by javax.crypto.interfaces
    Class 描述
    DHParameterSpec
    该类指定与PKCS＃3： Diffie-Hellman密钥协商标准中指定的Diffie-Hellman算法一起使用的参数集合。
  • Classes in javax.crypto.spec used by javax.crypto.spec
    Class 描述
    OAEPParameterSpec
    该类指定与OAEP填充一起使用的参数集，如 PKCS #1标准中所定义。
    PSource
    该类指定了在OAEP填充中编码输入P的源，如 PKCS #1标准中所定义。
    PSource.PSpecified
    该类用于在OAEP填充中明确指定编码输入P的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.DESedeKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.DESedeKeySpec

No usage of javax.crypto.spec.DESedeKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.DESKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.DESKeySpec

No usage of javax.crypto.spec.DESKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.DHGenParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.DHGenParameterSpec

No usage of javax.crypto.spec.DHGenParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.DHParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.DHParameterSpec

  • Packages that use DHParameterSpec
    软件包 描述
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。

    • Uses of DHParameterSpec in javax.crypto.interfaces

      Methods in javax.crypto.interfaces that return DHParameterSpec
      Modifier and Type 方法 描述
      DHParameterSpec DHKey.getParams​()
      返回关键参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.DHPrivateKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.DHPrivateKeySpec

No usage of javax.crypto.spec.DHPrivateKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.DHPublicKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.DHPublicKeySpec

No usage of javax.crypto.spec.DHPublicKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.GCMParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.GCMParameterSpec

No usage of javax.crypto.spec.GCMParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.IvParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.IvParameterSpec

No usage of javax.crypto.spec.IvParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.OAEPParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.OAEPParameterSpec

  • Packages that use OAEPParameterSpec
    软件包 描述
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of OAEPParameterSpec in javax.crypto.spec

      Fields in javax.crypto.spec declared as OAEPParameterSpec
      Modifier and Type Field 描述
      static OAEPParameterSpec OAEPParameterSpec.DEFAULT
      OAEP参数设置为所有默认值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.PBEKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.PBEKeySpec

No usage of javax.crypto.spec.PBEKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.PBEParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.PBEParameterSpec

No usage of javax.crypto.spec.PBEParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.PSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.PSource

  • Packages that use PSource
    软件包 描述
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of PSource in javax.crypto.spec

      Subclasses of PSource in javax.crypto.spec
      Modifier and Type Class 描述
      static class  PSource.PSpecified
      该类用于在OAEP填充中明确指定编码输入P的值。
      Methods in javax.crypto.spec that return PSource
      Modifier and Type 方法 描述
      PSource OAEPParameterSpec.getPSource​()
      返回编码输入P的来源。
      Constructors in javax.crypto.spec with parameters of type PSource
      Constructor 描述
      OAEPParameterSpec​(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
      构造为使用指定的消息摘要算法在PKCS＃1标准中定义的OAEP冗余参数集 mdName ，掩码生成函数算法 mgfName ，掩码生成函数参数 mgfSpec编码输入P的，和源 pSrc 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.PSource.PSpecified (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.PSource.PSpecified

  • Packages that use PSource.PSpecified
    软件包 描述
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。

    • Uses of PSource.PSpecified in javax.crypto.spec

      Fields in javax.crypto.spec declared as PSource.PSpecified
      Modifier and Type Field 描述
      static PSource.PSpecified PSource.PSpecified.DEFAULT
      编码输入P的值等于byte [0]。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.RC2ParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.RC2ParameterSpec

No usage of javax.crypto.spec.RC2ParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.RC5ParameterSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.RC5ParameterSpec

No usage of javax.crypto.spec.RC5ParameterSpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.crypto.spec.SecretKeySpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.crypto.spec.SecretKeySpec

No usage of javax.crypto.spec.SecretKeySpec
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


IIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Class IIOException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.imageio.IIOException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    IIOInvalidTreeException

    public class IIOException
extends IOException
    用于发信号读取和写入操作失败的异常类。

    除了消息字符串外，还保留对另一个Throwable （ Error或异常 ）的引用。 此引用（如果非null ）引用导致此异常发生的事件。 例如，从IOException读取的File将被存储在那里。

    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IIOException​(String message)
      构造一个 IIOException与给定的消息 String 。
      IIOException​(String message, Throwable cause)
      构造一个 IIOException与给定的消息 String和一个 Throwable这是其根本原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IIOException

        public IIOException​(String message)
        构造一个IIOException与给定的消息String 。 没有根本原因设定; getCause将返回null 。
        参数
        message - 错误信息。
        另请参见：
        Throwable.getMessage()

      • IIOException

        public IIOException​(String message,
                    Throwable cause)
        构造一个 IIOException与给定的消息 String和一个 Throwable这是其根本原因。
        参数
        message - 错误信息。
        cause - 导致此异常发生的 Throwable （ Error或 异常 ）。
        另请参见：
        Throwable.getCause(), Throwable.getMessage()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IIOImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Class IIOImage

  • java.lang.Object
    • javax.imageio.IIOImage

  • public class IIOImage
extends Object
    用于聚合图像的简单容器类，一组缩略图（预览）图像，以及表示与该图像相关联的元数据的对象。

    图像数据可以采用RenderedImage或Raster 。 阅读器方法返回IIOImage将始终返回BufferedImage使用RenderedImage参考。 接受IIOImage作者方法将始终接受一个RenderedImage ，并且可以选择接受一个Raster 。

    getRenderedImage和getRaster将返回非null值。 子类负责确保此行为。

    另请参见：
    ImageReader.readAll(int, ImageReadParam) ，
ImageReader.readAll(java.util.Iterator) ，
ImageWriter.write(javax.imageio.metadata.IIOMetadata, IIOImage, ImageWriteParam) ，
ImageWriter.write(IIOImage) ，
ImageWriter.writeToSequence(IIOImage, ImageWriteParam) ，
ImageWriter.writeInsert(int, IIOImage, ImageWriteParam)

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected RenderedImage image
      参考 RenderedImage 。
      protected IIOMetadata metadata
      包含与图像相关联的元数据的 IIOMetadata对象。
      protected Raster raster
      Raster被引用。
      protected List<? extends BufferedImage> thumbnails
      A List的 BufferedImage缩略图，或 null 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      IIOImage​(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 Raster ，和缩略图和元数据与之相关联。
      IIOImage​(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 RenderedImage ，和缩略图和元数据与之相关联。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      IIOMetadata getMetadata​()
      返回对当前 IIOMetadata对象的引用，或者是 null没有设置。
      int getNumThumbnails​()
      返回此 IIOImage存储的缩略图数。
      Raster getRaster​()
      如果只有 RenderedImage可用，则返回当前设置的 Raster或 null 。
      RenderedImage getRenderedImage​()
      如果只有一个 Raster可用，则返回当前设置的 RenderedImage ，或 null 。
      BufferedImage getThumbnail​(int index)
      返回与主图像相关联的缩略图。
      List<? extends BufferedImage> getThumbnails​()
      返回当前 List缩略图 BufferedImage S，或 null ，如果没有设置。
      boolean hasRaster​()
      如果这 IIOImage存储 Raster而不是 true则返回 RenderedImage 。
      void setMetadata​(IIOMetadata metadata)
      将 IIOMetadata设置为新对象，或 null 。
      void setRaster​(Raster raster)
      设置当前的 Raster 。
      void setRenderedImage​(RenderedImage image)
      设置当前的 RenderedImage 。
      void setThumbnails​(List<? extends BufferedImage> thumbnails)
      将缩略图到一个新的列表 List的 BufferedImage S，或 null 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • image

        protected RenderedImage image
        参考的 RenderedImage 。

      • raster

        protected Raster raster
        参考 Raster 。

      • thumbnails

        protected List<? extends BufferedImage> thumbnails
        A List的BufferedImage缩略图，或null 。 非BufferedImage对象不能存储在此List 。

      • metadata

        protected IIOMetadata metadata
        包含与图像相关联的元数据的 IIOMetadata对象。

    • 构造方法详细信息

      • IIOImage

        public IIOImage​(RenderedImage image,
                List<? extends BufferedImage> thumbnails,
                IIOMetadata metadata)
        构造一个IIOImage含有RenderedImage ，和缩略图和元数据与之相关联。

        所有参数通过参考存储。

        thumbnails参数必须为null或仅包含BufferedImage对象。

        参数
        image - a RenderedImage 。
        thumbnails - a List （ BufferedImage ）或 null 。
        metadata - 一个 IIOMetadata对象，或 null 。
        异常
        IllegalArgumentException - 如果 image为 null 。

      • IIOImage

        public IIOImage​(Raster raster,
                List<? extends BufferedImage> thumbnails,
                IIOMetadata metadata)
        构造一个IIOImage含有Raster ，和缩略图和元数据与之相关联。

        所有参数通过参考存储。

        参数
        raster - a Raster 。
        thumbnails - a List的 BufferedImage s或 null 。
        metadata - 一个 IIOMetadata对象，或 null 。
        异常
        IllegalArgumentException - 如果 raster是 null 。

    • 方法详细信息

      • getRenderedImage

        public RenderedImage getRenderedImage​()
        如果只有 Raster可用，则返回当前设置的 RenderedImage或 null 。
        结果
        一个 RenderedImage或 null 。
        另请参见：
        setRenderedImage(java.awt.image.RenderedImage)

      • setRenderedImage

        public void setRenderedImage​(RenderedImage image)
        设置当前的RenderedImage 。 该值通过引用存储。 任何现有的Raster被丢弃。
        参数
        image - a RenderedImage 。
        异常
        IllegalArgumentException - 如果 image是 null 。
        另请参见：
        getRenderedImage()

      • hasRaster

        public boolean hasRaster​()
        如果这个 IIOImage存储 Raster而不是 true则返回 RenderedImage 。
        结果
        true如果有一个 Raster可用。

      • getRaster

        public Raster getRaster​()
        如果只有一个 RenderedImage可用，则返回当前设置的 Raster或 null 。
        结果
        一个 Raster ，或 null 。
        另请参见：
        setRaster(java.awt.image.Raster)

      • setRaster

        public void setRaster​(Raster raster)
        设置当前的Raster 。 该值通过引用存储。 任何现有的RenderedImage被丢弃。
        参数
        raster - a Raster 。
        异常
        IllegalArgumentException - 如果 raster是 null 。
        另请参见：
        getRaster()

      • getNumThumbnails

        public int getNumThumbnails​()
        返回此 IIOImage存储的缩略图数。
        结果
        缩略图的数量，作为一个 int 。

      • getThumbnail

        public BufferedImage getThumbnail​(int index)
        返回与主图像相关联的缩略图。
        参数
        index - 所需缩略图的索引。
        结果
        缩略图，作为 BufferedImage 。
        异常
        IndexOutOfBoundsException - 如果提供的索引为负或大于最大有效索引。
        ClassCastException - 如果在给定索引的缩略图列表中遇到非 BufferedImage对象。
        另请参见：
        getThumbnails() ， setThumbnails(java.util.List<? extends java.awt.image.BufferedImage>)

      • getThumbnails

        public List<? extends BufferedImage> getThumbnails​()
        返回当前List缩略图BufferedImage S，或null ，如果没有设置。 返回实时参考。
        结果
        目前 List的 BufferedImage缩略图，或 null 。
        另请参见：
        getThumbnail(int) ， setThumbnails(java.util.List<? extends java.awt.image.BufferedImage>)

      • setThumbnails

        public void setThumbnails​(List<? extends BufferedImage> thumbnails)
        将缩略图到一个新的列表List的BufferedImage S，或null 。 对以前的List的引用被丢弃。

        thumbnails参数必须为null或仅包含BufferedImage对象。

        参数
        thumbnails - a List的 BufferedImage缩略图，或 null 。
        另请参见：
        getThumbnail(int) ， getThumbnails()

      • getMetadata

        public IIOMetadata getMetadata​()
        返回对当前 IIOMetadata对象的引用，或者是 null没有设置。
        结果
        一个 IIOMetadata对象，或 null 。
        另请参见：
        setMetadata(javax.imageio.metadata.IIOMetadata)

      • setMetadata

        public void setMetadata​(IIOMetadata metadata)
        将 IIOMetadata设置为新对象，或 null 。
        参数
        metadata - 一个 IIOMetadata对象，或 null 。
        另请参见：
        getMetadata()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


IIOParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Class IIOParam

  • java.lang.Object
    • javax.imageio.IIOParam
  • 已知直接子类：
    ImageReadParam ， ImageWriteParam

    public abstract class IIOParam
extends Object
    描述流如何解码或编码的所有类的超类。 此类包含ImageReadParam和ImageWriteParam共享的所有变量和方法。

    该类提供了指定源区域和目标区域的机制。 读取时，源是流，内存中的映像是目标。 写作时，这些都是相反的。 在写入的情况下，目的地区域可以仅与支持像素替换的写入器一起使用。

    可以使用可移动的子采样网格为读者和作者指定抽取次采样。

    可以选择源和目的地频带的子集。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected IIOParamController controller
      该 IIOParamController将用于提供此设置 IIOParam对象时 activateController方法被调用。
      protected IIOParamController defaultController
      当调用 activateController方法时，默认的 IIOParamController将用于为此 IIOParam对象提供设置。
      protected Point destinationOffset
      应放置左上角解码像素的目的地偏移量。
      protected ImageTypeSpecifier destinationType
      一个 ImageTypeSpecifier用于在读取时生成目标图像，或者在写入时设置输出颜色类型。
      protected int[] sourceBands
      int s的阵列，表示将使用哪些源频段，或 null 。
      protected Rectangle sourceRegion
      源区域，如果没有设置， null 。
      protected int sourceXSubsampling
      在水平方向应用抽取次采样。
      protected int sourceYSubsampling
      在垂直方向应用抽取次采样。
      protected int subsamplingXOffset
      在采样之前应用于子采样网格的水平偏移。
      protected int subsamplingYOffset
      在二次采样之前应用于子采样网格的垂直偏移。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected IIOParam​()
      受保护的构造函数只能由子类调用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean activateController​()
      激活此 IIOParam对象的已安装的 IIOParamController ，并返回结果值。
      IIOParamController getController​()
      返回当前安装的 IIOParamController 。
      IIOParamController getDefaultController​()
      返回默认的 IIOParamController ，如果有一个，不管当前安装的控制器。
      Point getDestinationOffset​()
      返回目标图像中要放置像素的偏移量。
      ImageTypeSpecifier getDestinationType​()
      返回读取的返回图像的类型，如果通过调用 setDestination(ImageTypeSpecifier)设置的图像的类型为 ImageTypeSpecifier 。
      int[] getSourceBands​()
      返回要使用的源频带集。
      Rectangle getSourceRegion​()
      返回要使用的源区域。
      int getSourceXSubsampling​()
      返回每个像素前进的源列数。
      int getSourceYSubsampling​()
      返回每个像素的行数。
      int getSubsamplingXOffset​()
      返回子采样网格的水平偏移。
      int getSubsamplingYOffset​()
      返回子采样网格的垂直偏移。
      boolean hasController​()
      如果为此 IIOParam对象安装了控制器，则返回 true 。
      void setController​(IIOParamController controller)
      设置 IIOParamController用于在调用 activateController方法时为该 IIOParam对象提供设置，覆盖任何默认控制器。
      void setDestinationOffset​(Point destinationOffset)
      指定目标图像中的未来解码像素的偏移量，读取时或写入区域的位置。
      void setDestinationType​(ImageTypeSpecifier destinationType)
      使用 ImageTypeSpecifier设置目标图像的所需图像类型。
      void setSourceBands​(int[] sourceBands)
      设置要使用的源频带的索引。
      void setSourceRegion​(Rectangle sourceRegion)
      设置感兴趣的源区域。
      void setSourceSubsampling​(int sourceXSubsampling, int sourceYSubsampling, int subsamplingXOffset, int subsamplingYOffset)
      指定抽取次采样以应用于I / O。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • sourceRegion

        protected Rectangle sourceRegion
        源区域，如果没有设置， null 。

      • sourceXSubsampling

        protected int sourceXSubsampling
        在水平方向应用抽取次采样。 默认值为1 。 该值不能为负数或0。

      • sourceYSubsampling

        protected int sourceYSubsampling
        在垂直方向应用抽取次采样。 默认值为1 。 该值不能为负数或0。

      • subsamplingXOffset

        protected int subsamplingXOffset
        在采样之前应用于子采样网格的水平偏移。 要使用的第一个像素将从该区域的原点偏移该量，或者如果未指定区域，则将偏移该图像。

      • subsamplingYOffset

        protected int subsamplingYOffset
        在二次采样之前应用于子采样网格的垂直偏移。 要使用的第一个像素将从该区域的原点偏移该量，或者如果未指定区域，则将偏移该图像。

      • sourceBands

        protected int[] sourceBands
        int s的阵列指示将使用哪些源频段，或null 。 如果是null ， null使用的源频带集合如setSourceBands方法的注释所述。 不应该允许任何价值为负数。

      • destinationType

        protected ImageTypeSpecifier destinationType
        一个ImageTypeSpecifier用于在读取时生成目标图像，或者在写入时设置输出颜色类型。 如果未设置，则值为null 。 默认值为null 。

      • destinationOffset

        protected Point destinationOffset
        应放置左上角解码像素的目的地偏移量。 默认值为（0，0）。

      • defaultController

        protected IIOParamController defaultController
        当调用activateController方法时，默认的IIOParamController将用于为此IIOParam对象提供设置。 这个默认值应该由子类设置，选择提供自己的默认控制器（通常是GUI）来设置参数。
        另请参见：
        IIOParamController ， getDefaultController() ， activateController()

      • controller

        protected IIOParamController controller
        该IIOParamController将用于提供此设置IIOParam对象时activateController方法被调用。 此值覆盖任何默认控制器，即使为空。
        另请参见：
        IIOParamController ， setController(IIOParamController) ， hasController() ， activateController()

    • 构造方法详细信息

      • IIOParam

        protected IIOParam​()
        受保护的构造函数只能由子类调用。

    • 方法详细信息

      • setSourceRegion

        public void setSourceRegion​(Rectangle sourceRegion)
        设置感兴趣的源区域。 感兴趣的区域被描述为一个矩形，源图像的左上角是像素（0,0），并且向下和向右增加值。 实际使用的像素数将取决于setSourceSubsampling设置的子采样因子。 如果子采样被设置为使得该数字为零，则将抛出IllegalStateException 。

        由该方法指定的感兴趣的源区域将根据需要进行修剪以适应源边界以及实际I / O时的目标偏移量，宽度和高度。

        null的sourceRegion将删除任何区域规范，导致使用整个图像。

        参数
        sourceRegion - a Rectangle指定感兴趣的源区域，或 null 。
        异常
        IllegalArgumentException - 如果 sourceRegion为非 null而 sourceRegion.x或 sourceRegion.y为负。
        IllegalArgumentException - 如果 sourceRegion为非 null而 sourceRegion.width或 sourceRegion.height为负或为0。
        IllegalStateException - 如果子采样使得该区域将具有二次采样宽度或零度的高度。
        另请参见：
        getSourceRegion() ，
setSourceSubsampling(int, int, int, int) ，
setDestinationOffset(java.awt.Point) ，
getDestinationOffset()

      • getSourceRegion

        public Rectangle getSourceRegion​()
        返回要使用的源区域。 返回的值是由最近调用的setSourceRegion ，如果没有区域设置， null 。
        结果
        源区域为 Rectangle ，或 null 。
        另请参见：
        setSourceRegion(java.awt.Rectangle)

      • setSourceSubsampling

        public void setSourceSubsampling​(int sourceXSubsampling,
                                 int sourceYSubsampling,
                                 int subsamplingXOffset,
                                 int subsamplingYOffset)
        指定抽取次采样以应用于I / O。 sourceXSubsampling和sourceYSubsampling参数指定子采样周期（ 即 ，每个源像素之后要提前的行数和列数）。 具体来说，1的周期将使用每行或列; 一个2的周期将使用每隔一行或一列。 subsamplingXOffset和subsamplingYOffset参数指定了第一subsamplingXOffset采样像素的区域（或图像）原点的偏移量。 调整子样本网格的原点对于在将非常大的源图像进行子采样到将被组装成完整的子采样图像的目的地区域时避免接缝是有用的。 大多数用户都希望将这些参数保留在0。

        要使用的像素数和扫描线的数量如下计算。

        扫描线中子采样像素的数量由下式给出

        truncate[(width - subsamplingXOffset + sourceXSubsampling - 1) / sourceXSubsampling] 。

        如果区域是这样的宽度为零，则抛出一个IllegalStateException 。

        可以类似地计算要使用的扫描线的数量。

        如果该区域用于创建大图像的子采样图块，其中图块宽度和高度不是子采样周期的倍数，则将二次采样网格设置为开始于源区域原点以外的位置的功能非常有用。 如果子采样网格从块到块不保持一致，则在块边界处将存在伪像。 通过调整每个瓦片的子采样网格偏移量进行补偿，可以避免这些伪像。 折衷的是，为了避免这些工件，瓷砖的尺寸不一样。 在这种情况下使用的网格偏移量由下式给出：
        网格偏移= [周期 - （区域偏移模周期）]模周期）

        如果sourceXSubsampling或sourceYSubsampling为0或IllegalArgumentException将抛出IllegalArgumentException 。

        如果subsamplingXOffset或subsamplingYOffset为负数或大于或等于相应期间，将抛出IllegalArgumentException 。

        没有unsetSourceSubsampling方法; 只需调用setSourceSubsampling(1, 1, 0, 0)即可恢复默认值。

        参数
        sourceXSubsampling - 要在像素之间前进的列数。
        sourceYSubsampling - 要在像素之间推进的行数。
        subsamplingXOffset - 区域内的第一 subsamplingXOffset的水平偏移，或者如果没有设置区域，则在图像内。
        subsamplingYOffset - 区域内的第一 subsamplingYOffset的水平偏移，或者如果没有设置区域，则在图像内。
        异常
        IllegalArgumentException - 如果任一周期为负或0，或者任一电网偏移为负或大于相应周期。
        IllegalStateException - 如果源区域使得子采样输出将不包含像素。

      • getSourceXSubsampling

        public int getSourceXSubsampling​()
        返回每个像素前进的源列数。

        如果未调用setSourceSubsampling ，则返回1（正确的值）。

        结果
        源子采样X周期。
        另请参见：
        setSourceSubsampling(int, int, int, int) ， getSourceYSubsampling()

      • getSourceYSubsampling

        public int getSourceYSubsampling​()
        返回每个像素的行数。

        如果未调用setSourceSubsampling ，则返回1（正确的值）。

        结果
        源子采样Y期。
        另请参见：
        setSourceSubsampling(int, int, int, int) ， getSourceXSubsampling()

      • getSubsamplingXOffset

        public int getSubsamplingXOffset​()
        返回子采样网格的水平偏移。

        如果未调用setSourceSubsampling ，则返回0（这是正确的值）。

        结果
        源子采样网格X偏移。
        另请参见：
        setSourceSubsampling(int, int, int, int) ， getSubsamplingYOffset()

      • getSubsamplingYOffset

        public int getSubsamplingYOffset​()
        返回子采样网格的垂直偏移。

        如果未调用setSourceSubsampling ，则返回0（正确的值）。

        结果
        源子采样网格Y偏移。
        另请参见：
        setSourceSubsampling(int, int, int, int) ， getSubsamplingXOffset()

      • setSourceBands

        public void setSourceBands​(int[] sourceBands)
        设置要使用的源频带的索引。 不允许重复索引。

        A null值表示将使用所有源频段。

        在读取时，如果已经指定了大于最大可用源频带索引的值，或者要使用的源频带和目标频带数量不同，读写器将抛出IllegalArgumentException 。 可以使用ImageReader.checkReadParamBandSettings方法自动执行此测试。

        语义上，一个副本是由阵列组成的; 对此调用之后的数组内容的更改对此IIOParam没有任何影响。

        参数
        sourceBands - 要使用的整数带索引数组。
        异常
        IllegalArgumentException - 如果 sourceBands包含负值或重复值。
        另请参见：
        getSourceBands() ，
ImageReadParam.setDestinationBands(int[]) ，
ImageReader.checkReadParamBandSettings(javax.imageio.ImageReadParam, int, int)

      • getSourceBands

        public int[] getSourceBands​()
        返回要使用的源频带集。 返回的值是通过最近一次调用设置为setSourceBands ，或null如果已经有过任何呼叫setSourceBands 。

        语义上，返回的数组是一个副本; 此调用之后对数组内容的更改对此IIOParam 。

        结果
        要使用的一组源频段，或 null 。
        另请参见：
        setSourceBands(int[])

      • setDestinationType

        public void setDestinationType​(ImageTypeSpecifier destinationType)
        使用ImageTypeSpecifier设置目标图像的所需图像类型。

        当读取时，如果使用此方法设置了目的地的布局，则每次调用ImageReader read方法将使用提供的类型说明符指定的格式返回新的BufferedImage 。 作为副作用，任何目的地BufferedImage组由ImageReadParam.setDestination(BufferedImage)将不再被设定为目的地。 换句话说，这种方法可能被认为是调用setDestination((BufferedImage)null) 。

        当写入时，目的地类型可能用于确定图像的颜色类型。 SampleModel信息将被忽略，可能是null 。 例如，4带图像可以表示CMYK或RGBA数据。 如果设置了目的地类型，其ColorModel将覆盖图像本身上的任何ColorModel 。 当使用setSourceBands时，这是至关重要的，因为图像的ColorModel将引用整个图像，而不是要写入的频带子集。

        参数
        destinationType - 用于确定目的地布局和颜色类型的 ImageTypeSpecifier 。
        另请参见：
        getDestinationType()

      • getDestinationType

        public ImageTypeSpecifier getDestinationType​()
        如果通过调用setDestination(ImageTypeSpecifier)设置了读取，则返回要返回的图像的类型，如ImageTypeSpecifier 。 如果没有设置，则返回null 。
        结果
        描述目的地类型的 ImageTypeSpecifier ，或 null 。
        另请参见：
        setDestinationType(javax.imageio.ImageTypeSpecifier)

      • setDestinationOffset

        public void setDestinationOffset​(Point destinationOffset)
        指定目标图像中的未来解码像素的偏移量，读取时或写入区域的位置。

        当读取时，要在目的地BufferedImage写入的区域将从该偏移开始，并且具有由感兴趣的源区域，子采样参数和目的地边界确定的宽度和高度。

        正常写入不受此方法的影响，只能使用ImageWriter.replacePixels执行写操作。 对于这样的写入，指定的偏移量在其像素被修改的输出流图像内。

        没有unsetDestinationOffset方法; 只需拨打setDestinationOffset(new Point(0, 0))即可恢复默认值。

        参数
        destinationOffset - 目的地的偏移量，为 Point 。
        异常
        IllegalArgumentException - 如果 destinationOffset是 null 。
        另请参见：
        getDestinationOffset() ， ImageWriter.replacePixels(java.awt.image.RenderedImage, javax.imageio.ImageWriteParam)

      • getDestinationOffset

        public Point getDestinationOffset​()
        返回目标图像中要放置像素的偏移量。

        如果setDestinationOffsets尚未被调用，则返回一个具有零X和Y值的Point （这是正确的值）。

        结果
        目的地偏移量为 Point 。
        另请参见：
        setDestinationOffset(java.awt.Point)

      • setController

        public void setController​(IIOParamController controller)
        设置IIOParamController被用来提供用于此设置IIOParam对象时activateController方法被调用时，重写所有默认控制器。 如果参数为null ，则不会使用任何控制器，包括任何默认值。 要恢复默认值，请使用setController(getDefaultController()) 。
        参数
        controller - 适当的 IIOParamController或 null 。
        另请参见：
        IIOParamController ， getController() ， getDefaultController() ， hasController() ， activateController()

      • getController

        public IIOParamController getController​()
        返回当前安装的IIOParamController 。 这可能是默认的，如果有一个， null ，或者最近通话的说法setController 。
        结果
        目前安装的是 IIOParamController ，或 null 。
        另请参见：
        IIOParamController ， setController(javax.imageio.IIOParamController) ， getDefaultController() ， hasController() ， activateController()

      • getDefaultController

        public IIOParamController getDefaultController​()
        返回默认值IIOParamController ，如果有一个，不管当前安装的控制器。 如果没有默认控制器，则返回null 。
        结果
        默认为 IIOParamController ，或 null 。
        另请参见：
        IIOParamController ， setController(IIOParamController) ， getController() ， hasController() ， activateController()

      • hasController

        public boolean hasController​()
        如果为此IIOParam对象安装了控制器，则返回true 。 这将返回true如果getController不会返回null 。
        结果
        true如果安装了控制器。
        另请参见：
        IIOParamController ， setController(IIOParamController) ， getController() ， getDefaultController() ， activateController()

      • activateController

        public boolean activateController​()
        激活已安装的IIOParamController对于此IIOParam对象并返回结果值。 当此方法返回true ，此IIOParam对象的所有值将准备好进行下一次读取或写入操作。 如果返回false则此对象中的设置不会受到干扰（ 即用户取消了该操作）。

        通常，控制器将是为特定插件提供IIOParam子类的用户界面的GUI。 控制器不需要GUI。

        结果
        true如果控制器正常完成。
        异常
        IllegalStateException - 如果当前没有安装控制器。
        另请参见：
        IIOParamController ， setController(IIOParamController) ， getController() ， getDefaultController() ， hasController()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


IIOParamController (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Interface IIOParamController

  • public interface IIOParamController
    要由可以通过放置GUI以从用户获取值或通过其他方式确定IIOParam对象的设置的对象来实现的接口。 此接口仅指定调用控制器的通用activate方法，而不考虑控制器如何获取值（ 即 ，控制器是否放置GUI或仅计算一组值与此接口无关）。

    在activate方法中，控制器通过查询IIOParam对象的get方法来获取初始值，通过任何方式修改值，然后调用IIOParam对象的set方法来修改适当的设置。 通常，这些set方法将在最终提交时一次被调用，以便取消操作不会干扰现有值。 一般来说，应用程序可能期望当activate方法返回true ， IIOParam对象可以在读或写操作中使用。

    供应商可以选择为其为特定插件定义的IIOParam子类提供GUI。 这些可以在对应的IIOParam子类中设置为默认控制器。

    应用程序可以覆盖任何默认GUI，并提供自己的控制器嵌入到自己的框架中。 所需要的是， activate方法以模态方式运行（直到取消或提交之前才返回），尽管它不需要显式地显示模态对话框。 这种非模态GUI组件将大致如下编码：

      class MyGUI extends SomeComponent implements IIOParamController {

    public MyGUI() {
        // ...
        setEnabled(false);
    }

    public boolean activate(IIOParam param) {
        // disable other components if desired
        setEnabled(true);
        // go to sleep until either cancelled or committed
        boolean ret = false;
        if (!cancelled) {
            // set values on param
            ret = true;
        }
        setEnabled(false);
        // enable any components disabled above
        return ret;
    }

    或者，诸如数据库查找或命令行解析的算法过程可以用作控制器，在这种情况下， activate方法将简单地查找或计算设置，调用IIOParam.setXXX方法，并返回true 。

    另请参见：
    IIOParam.setController(javax.imageio.IIOParamController) ，
IIOParam.getController() ，
IIOParam.getDefaultController() ，
IIOParam.hasController() ，
IIOParam.activateController()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean activate​(IIOParam param)
      激活控制器。

    • 方法详细信息

      • activate

        boolean activate​(IIOParam param)
        激活控制器。 如果true返回，在所有设置IIOParam对象应该是准备在读或写操作使用。 如果false返回，在没有设置IIOParam对象会被干扰（ 也就是说 ，用户取消了该操作）。
        参数
        param - 要修改的 IIOParam对象。
        结果
        true如果 IIOParam已被修改，否则为 false 。
        异常
        IllegalArgumentException - if param is null or is not an instance of the correct class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageIO (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Class ImageIO

  • java.lang.Object
    • javax.imageio.ImageIO

  • public final class ImageIO
extends Object
    一个包含静态方便的方法，用于定位 ImageReader和 ImageWriter s，并执行简单的编码和解码。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ImageInputStream createImageInputStream​(Object input)
      返回一个 ImageInputStream ，它将从给定的 Object获取其输入。
      static ImageOutputStream createImageOutputStream​(Object output)
      返回一个 ImageOutputStream ，将其输出发送给给定的 Object 。
      static File getCacheDirectory​()
      返回当前值设置由 setCacheDirectory ，或 null如果没有明确的设定已经取得进展。
      static ImageReader getImageReader​(ImageWriter writer)
      返回一个 ImageReader对应于给定 ImageWriter ，如果有一个或 null如果插件在此 ImageWriter没有指定相应 ImageReader ，如果给定 ImageWriter未注册。
      static Iterator<ImageReader> getImageReaders​(Object input)
      返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码所提供的 Object ，通常为 ImageInputStream 。
      static Iterator<ImageReader> getImageReadersByFormatName​(String formatName)
      返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码命名格式。
      static Iterator<ImageReader> getImageReadersByMIMEType​(String MIMEType)
      返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码具有给定MIME类型的文件。
      static Iterator<ImageReader> getImageReadersBySuffix​(String fileSuffix)
      返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够使用给定的后缀解码文件。
      static Iterator<ImageTranscoder> getImageTranscoders​(ImageReader reader, ImageWriter writer)
      返回一个 Iterator其中包含所有当前注册的 ImageTranscoder s，声称能够在给定的 ImageReader和 ImageWriter的元数据之间进行转码。
      static ImageWriter getImageWriter​(ImageReader reader)
      返回一个 ImageWriter对应于给定的 ImageReader ，如果有一个，或 null如果这个 ImageReader的插件没有指定相应的 ImageWriter ，或者如果给定的 ImageReader没有注册。
      static Iterator<ImageWriter> getImageWriters​(ImageTypeSpecifier type, String formatName)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够以给定格式对给定布局（使用 ImageTypeSpecifier指定）的图像进行编码。
      static Iterator<ImageWriter> getImageWritersByFormatName​(String formatName)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够对命名格式进行编码。
      static Iterator<ImageWriter> getImageWritersByMIMEType​(String MIMEType)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够对具有给定MIME类型的文件进行编码。
      static Iterator<ImageWriter> getImageWritersBySuffix​(String fileSuffix)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter ，声称能够使用给定的后缀对文件进行编码。
      static String[] getReaderFileSuffixes​()
      返回一个 String的数组，列出与当前注册读者集合所理解的格式相关联的所有文件后缀。
      static String[] getReaderFormatNames​()
      返回一个 String的数组，列出了当前注册读者集所理解的所有非正式格式名称。
      static String[] getReaderMIMETypes​()
      返回一个 String的数组，列出了当前注册读者集所理解的所有MIME类型。
      static boolean getUseCache​()
      如果没有进行显式设置，则返回当前设置的 setUseCache ，或 true 。
      static String[] getWriterFileSuffixes​()
      返回一个 String的数组， String列出了与当前注册作者集合所理解的格式相关联的所有文件后缀。
      static String[] getWriterFormatNames​()
      返回一个 String的数组， String列出了当前注册作者集所理解的所有非正式格式名称。
      static String[] getWriterMIMETypes​()
      返回一个 String的数组， String列出了当前注册作者集所理解的所有MIME类型。
      static BufferedImage read​(File input)
      作为对所提供的 File进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。
      static BufferedImage read​(InputStream input)
      作为对所提供的 InputStream进行解码的结果，返回 BufferedImage ，其中自动从当前注册的 ImageReader选择。
      static BufferedImage read​(URL input)
      作为对所提供的 URL进行解码的结果，返回 BufferedImage ，其中自动从当前注册的 ImageReader选择。
      static BufferedImage read​(ImageInputStream stream)
      作为对所提供的 ImageInputStream进行解码的结果，返回 BufferedImage ，其中自动从当前注册的 ImageReader选择。
      static void scanForPlugins​()
      扫描应用程序类路径上的插件，加载其服务提供者类，并为每个发现的 IIORegistry注册一个服务提供者实例。
      static void setCacheDirectory​(File cacheDirectory)
      设置要创建缓存文件的目录。
      static void setUseCache​(boolean useCache)
      设置一个标志，指示在创建 ImageInputStream和 ImageOutputStream s时是否应使用基于磁盘的缓存文件。
      static boolean write​(RenderedImage im, String formatName, File output)
      使用支持给定格式的任意 ImageWriter写入图像到 File 。
      static boolean write​(RenderedImage im, String formatName, OutputStream output)
      使用支持给定格式的任意 ImageWriter写入图像到 OutputStream 。
      static boolean write​(RenderedImage im, String formatName, ImageOutputStream output)
      使用支持给定格式的任意 ImageWriter写入图像到 ImageOutputStream 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • scanForPlugins

        public static void scanForPlugins​()
        扫描应用程序类路径上的插件，加载其服务提供者类，并为每个找到的服务提供者实例注册IIORegistry 。

        需要这种方法，因为应用程序类路径在理论上可以改变，或者额外的插件可能变得可用。 API的每次调用不会重新扫描类路径，而是仅在第一次调用时自动扫描类路径。 客户端可以调用此方法来提示重新扫描。 因此，该方法只需要由复杂的应用程序调用，这些应用程序可以在运行时动态创建新的插件。

        所述getResources上下文的方法ClassLoader用于定位包含文件的JAR文件命名为META-INF/services/javax.imageio.spi. 类名 ， 类名 ，其中是一个ImageReaderSpi ， ImageWriterSpi ， ImageTranscoderSpi ， ImageInputStreamSpi ，或ImageOutputStreamSpi ，沿着应用程序类路径。

        找到的文件的内容指示实现上述服务提供商接口的实际实现类的名称; 然后使用默认的类加载器来加载这些类中的每一个，并实例化每个类的实例，然后将其放入注册表中以备以后检索。

        搜索的位置的确切位置取决于Java运行时环境的实现。

        另请参见：
        ClassLoader.getResources(java.lang.String)

      • setUseCache

        public static void setUseCache​(boolean useCache)
        设置一个标志，指示在创建ImageInputStream s和ImageOutputStream s时是否应使用基于磁盘的缓存文件。

        当从标准InputStream读取时，可能需要将先前读取的信息保存在缓存中，因为底层流不允许重新读取数据。 类似地，当写入标准OutputStream ，可以使用高速缓存来允许改变先前写入的值，然后将其刷新到最终目的地。

        高速缓存可能驻留在主内存或磁盘上。 将此标志设置为false不允许将磁盘用于未来的流，这在使用小图像时可能是有利的，因为删除了创建和销毁文件的开销。

        启动时，该值设置为true 。

        参数
        useCache - a boolean指示是否应使用缓存文件，如果是可选的。
        另请参见：
        getUseCache()

      • getUseCache

        public static boolean getUseCache​()
        如果没有进行显式设置，则返回 setUseCache设置的当前值，或 true 。
        结果
        如果基于磁盘的缓存可用于 ImageInputStream s和 ImageOutputStream s， ImageOutputStream 。
        另请参见：
        setUseCache(boolean)

      • setCacheDirectory

        public static void setCacheDirectory​(File cacheDirectory)
        设置要创建缓存文件的目录。 值null表示要使用系统相关的默认临时文件目录。 如果getUseCache返回false，则忽略此值。
        参数
        cacheDirectory - a指定目录的 File 。
        异常
        SecurityException - 如果安全管理器拒绝对目录的访问。
        IllegalArgumentException - 如果 cacheDir不是 null但不是目录。
        另请参见：
        File.createTempFile(String, String, File) ， getCacheDirectory()

      • getCacheDirectory

        public static File getCacheDirectory​()
        返回当前值设置由 setCacheDirectory ，或 null如果没有明确的设定已经取得进展。
        结果
        一个 File指示将创建高速缓存文件的目录，或 null以指示系统相关的默认临时文件目录。
        另请参见：
        setCacheDirectory(java.io.File)

      • createImageInputStream

        public static ImageInputStream createImageInputStream​(Object input)
                                               throws IOException
        返回一个ImageInputStream ，它将从给定的Object获取其输入。 该组ImageInputStreamSpi与注册的小号IIORegistry类查询和第一个即能取从所提供的对象的输入被用来创建返回ImageInputStream 。 如果没有合适的ImageInputStreamSpi ，则返回null 。

        当前缓存设置从getUseCache和getCacheDirectory将被用于控制缓存。

        参数
        input -一个 Object被用作输入源，例如 File ，可读 RandomAccessFile ，或 InputStream 。
        结果
        一个 ImageInputStream或 null 。
        异常
        IllegalArgumentException - 如果 input是 null 。
        IOException - 如果需要缓存文件但无法创建。
        另请参见：
        ImageInputStreamSpi

      • createImageOutputStream

        public static ImageOutputStream createImageOutputStream​(Object output)
                                                 throws IOException
        返回一个ImageOutputStream ，将其输出发送给给定的Object 。 该组ImageOutputStreamSpi与注册的小号IIORegistry类查询和对应的第一个是能够从所提供的对象发送输出被用来创建返回ImageOutputStream 。 如果没有合适的ImageOutputStreamSpi ，则返回null 。

        当前缓存设置从getUseCache和getCacheDirectory将用于控制缓存。

        参数
        output -一个 Object用作输出目的地，例如 File ，可写 RandomAccessFile ，或 OutputStream 。
        结果
        一个 ImageOutputStream ，或 null 。
        异常
        IllegalArgumentException - 如果 output是 null 。
        IOException - 如果需要缓存文件但无法创建。
        另请参见：
        ImageOutputStreamSpi

      • getReaderFormatNames

        public static String[] getReaderFormatNames​()
        返回一个 String的数组， String列出了当前注册读者集所理解的所有非正式格式名称。
        结果
        一个 String的阵列。

      • getReaderMIMETypes

        public static String[] getReaderMIMETypes​()
        返回一个 String的数组， String列出了当前注册读者集所理解的所有MIME类型。
        结果
        一个 String的数组。

      • getReaderFileSuffixes

        public static String[] getReaderFileSuffixes​()
        返回一个 String的数组，列出与当前注册读者集合所理解的格式相关联的所有文件后缀。
        结果
        一个 String的数组。
        从以下版本开始：
        1.6

      • getImageReaders

        public static Iterator<ImageReader> getImageReaders​(Object input)
        返回一个Iterator其中包含所有当前注册的ImageReader ，声称能够解码所提供的Object ，通常为ImageInputStream 。

        在从该方法退出时，流位置保留在其先前位置。

        参数
        input - 包含编码图像数据的 ImageInputStream或其他 Object 。
        结果
        一个 Iterator包含 ImageReader s。
        异常
        IllegalArgumentException - 如果 input是 null 。
        另请参见：
        ImageReaderSpi.canDecodeInput(java.lang.Object)

      • getImageReadersByFormatName

        public static Iterator<ImageReader> getImageReadersByFormatName​(String formatName)
        返回一个 Iterator其中包含所有当前注册的 ImageReader ，声称能够解码命名格式。
        参数
        formatName - 一个包含格式的非正式名称（ 例如 “jpeg”或“tiff”）的 String 。
        结果
        一个 Iterator包含 ImageReader s。
        异常
        IllegalArgumentException - 如果 formatName是 null 。
        另请参见：
        ImageReaderWriterSpi.getFormatNames()

      • getImageReadersBySuffix

        public static Iterator<ImageReader> getImageReadersBySuffix​(String fileSuffix)
        返回一个 Iterator其中包含所有当前注册的 ImageReader ，声称能够解码具有给定后缀的文件。
        参数
        fileSuffix - 包含文件后缀（ 例如 “jpg”或“tiff”）的 String 。
        结果
        一个 Iterator包含 ImageReader s。
        异常
        IllegalArgumentException - 如果 fileSuffix是 null 。
        另请参见：
        ImageReaderWriterSpi.getFileSuffixes()

      • getImageReadersByMIMEType

        public static Iterator<ImageReader> getImageReadersByMIMEType​(String MIMEType)
        返回一个 Iterator其中包含所有当前注册的 ImageReader ，声称能够解码具有给定MIME类型的文件。
        参数
        MIMEType - 包含文件后缀（ 例如 ，“image / jpeg”或“image / x-bmp”）的 String 。
        结果
        一个 Iterator包含 ImageReader s。
        异常
        IllegalArgumentException - 如果 MIMEType是 null 。
        另请参见：
        ImageReaderWriterSpi.getMIMETypes()

      • getWriterFormatNames

        public static String[] getWriterFormatNames​()
        返回一个 String的数组， String列出了当前注册作者集所理解的所有非正式格式名称。
        结果
        一个 String的数组。

      • getWriterMIMETypes

        public static String[] getWriterMIMETypes​()
        返回一个 String的数组， String列出了当前注册作者集所理解的所有MIME类型。
        结果
        一个 String的数组。

      • getWriterFileSuffixes

        public static String[] getWriterFileSuffixes​()
        返回一个 String的数组， String列出了与当前注册作者集合所理解的格式相关联的所有文件后缀。
        结果
        一个 String的阵列。
        从以下版本开始：
        1.6

      • getImageWritersByFormatName

        public static Iterator<ImageWriter> getImageWritersByFormatName​(String formatName)
        返回一个 Iterator其中包含所有当前注册的 ImageWriter ，声称能够对命名格式进行编码。
        参数
        formatName - 一个包含格式的非正式名称（ 例如 “jpeg”或“tiff”）的 String 。
        结果
        一个 Iterator包含 ImageWriter的。
        异常
        IllegalArgumentException - 如果 formatName是 null 。
        另请参见：
        ImageReaderWriterSpi.getFormatNames()

      • getImageWritersBySuffix

        public static Iterator<ImageWriter> getImageWritersBySuffix​(String fileSuffix)
        返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够使用给定的后缀对文件进行编码。
        参数
        fileSuffix - 包含文件后缀（ 例如 “jpg”或“tiff”）的 String 。
        结果
        一个 Iterator包含 ImageWriter s。
        异常
        IllegalArgumentException - 如果 fileSuffix是 null 。
        另请参见：
        ImageReaderWriterSpi.getFileSuffixes()

      • getImageWritersByMIMEType

        public static Iterator<ImageWriter> getImageWritersByMIMEType​(String MIMEType)
        返回一个 Iterator其中包含所有当前注册的 ImageWriter ，声称能够对具有给定MIME类型的文件进行编码。
        参数
        MIMEType - 包含文件后缀（ 例如 “image / jpeg”或“image / x-bmp”）的 String 。
        结果
        一个 Iterator包含 ImageWriter s。
        异常
        IllegalArgumentException - 如果 MIMEType是 null 。
        另请参见：
        ImageReaderWriterSpi.getMIMETypes()

      • getImageWriter

        public static ImageWriter getImageWriter​(ImageReader reader)
        返回一个ImageWriter对应于给定的ImageReader ，如果有一个，或null如果这个ImageReader的插件没有指定相应的ImageWriter ，或者如果给定的ImageReader没有注册。 此机制可用于获得ImageWriter将理解非像素元数据的内部结构（由作为编码IIOMetadata由所生成的对象） ImageReader 。 通过从ImageReader获取该数据并将其传递给使用此方法获得的ImageWriter ，客户端程序可以读取图像，以某种方式进行修改，并将其写回保留所有元数据，而无需了解结构的任何内容的元数据，甚至关于图像格式。 请注意，此方法返回“首选”作者，它是javax.imageio.spi.ImageReaderSpi.getImageWriterSpiNames()返回的列表中的第一个。
        参数
        reader - 注册的一个实例 ImageReader 。
        结果
        一个 ImageWriter ，或null。
        异常
        IllegalArgumentException - 如果 reader是 null 。
        另请参见：
        getImageReader(ImageWriter) ， ImageReaderSpi.getImageWriterSpiNames()

      • getImageReader

        public static ImageReader getImageReader​(ImageWriter writer)
        返回一个ImageReader对应的ImageWriter ，如果有一个，或null如果这个ImageWriter的插件没有指定相应的ImageReader ，或者如果给定的ImageWriter没有注册。 该方法主要用于与getImageWriter(ImageReader)对称。 请注意，此方法返回“首选”阅读器，它是javax.imageio.spi.ImageWriterSpi返回的列表中的第一个。 getImageReaderSpiNames() 。
        参数
        writer - 注册的一个实例 ImageWriter 。
        结果
        一个 ImageReader ，或null。
        异常
        IllegalArgumentException - 如果 writer是 null 。
        另请参见：
        getImageWriter(ImageReader) ， ImageWriterSpi.getImageReaderSpiNames()

      • getImageWriters

        public static Iterator<ImageWriter> getImageWriters​(ImageTypeSpecifier type,
                                                    String formatName)
        返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够以给定格式编码给定布局（使用 ImageTypeSpecifier指定）的图像。
        参数
        type - 表示要写入的图像的布局的 ImageTypeSpecifier 。
        formatName -的非正式名称 format 。
        结果
        一个 Iterator包含 ImageWriter s。
        异常
        IllegalArgumentException - 如果任何参数是 null 。
        另请参见：
        ImageWriterSpi.canEncodeImage(ImageTypeSpecifier)

      • getImageTranscoders

        public static Iterator<ImageTranscoder> getImageTranscoders​(ImageReader reader,
                                                            ImageWriter writer)
        返回一个 Iterator其中包含所有当前注册的 ImageTranscoder s，声称能够在给定的 ImageReader和 ImageWriter的元数据之间进行转码。
        参数
        reader - a ImageReader 。
        writer - a ImageWriter 。
        结果
        一个 Iterator包含 ImageTranscoder s。
        异常
        IllegalArgumentException - 如果 reader或 writer是 null 。

      • read

        public static BufferedImage read​(File input)
                          throws IOException
        作为对所提供的File进行解码的结果，返回BufferedImage ，其中自动从当前注册的那些中选择一个ImageReader 。 File包裹在一个ImageInputStream 。 如果没有注册的ImageReader声称能够读取结果流，则返回null 。

        getUseCache和getCacheDirectory的当前缓存设置将用于在创建的ImageInputStream中控制缓存。

        请注意，没有read方法将文件名作为String ; 在从文件名创建File之后，请使用此方法。

        此方法不试图定位ImageReader s表示可直接从读File ; 这可以使用IIORegistry和ImageReaderSpi完成。

        参数
        input - a File要阅读。
        结果
        一个 BufferedImage包含输入，或经解码内容 null 。
        异常
        IllegalArgumentException - 如果 input是 null 。
        IOException - 如果读取期间发生错误或无法创建所需的ImageInputStream时。

      • read

        public static BufferedImage read​(InputStream input)
                          throws IOException
        作为对所提供的InputStream进行解码的结果，返回BufferedImage ，其中自动从当前注册的那些中选择一个ImageReader 。 InputStream包裹在一个ImageInputStream 。 如果没有注册的ImageReader声称能够读取生成的流，则返回null 。

        getUseCache和getCacheDirectory的当前缓存设置将用于在创建的ImageInputStream中控制缓存。

        此方法不试图定位ImageReader s表示可以直接从读取InputStream ; 这可以使用IIORegistry和ImageReaderSpi完成。

        读取操作完成后，此方法不关闭提供的InputStream ; 如果需要，呼叫者有责任关闭流。

        参数
        input - 要阅读的 InputStream 。
        结果
        一个 BufferedImage包含输入，或经解码内容 null 。
        异常
        IllegalArgumentException - 如果 input是 null 。
        IOException - 如果读取期间发生错误或无法创建所需的ImageInputStream。

      • read

        public static BufferedImage read​(URL input)
                          throws IOException
        作为对所提供的URL进行解码的结果，返回BufferedImage ，其中自动从当前注册的那些中选择一个ImageReader 。 一个InputStream从得到URL ，其被包裹在一个ImageInputStream 。 如果没有注册ImageReader声称能够读取结果流，则返回null 。

        getUseCache和getCacheDirectory的当前缓存设置将用于在创建的ImageInputStream中控制缓存。

        此方法不试图定位ImageReader s表示可直接从读URL ; 这可以使用IIORegistry和ImageReaderSpi完成。

        参数
        input - a URL阅读。
        结果
        一个 BufferedImage包含输入的解码内容，或 null 。
        异常
        IllegalArgumentException - 如果 input是 null 。
        IOException - 如果读取期间出现错误或无法创建所需的ImageInputStream。

      • read

        public static BufferedImage read​(ImageInputStream stream)
                          throws IOException
        作为对所提供的ImageInputStream进行解码的结果，返回BufferedImage ，其中自动从当前注册的ImageReader选择一个ImageReader 。 如果没有注册ImageReader声称能够读取流，则返回null 。

        与此类中的大多数其他的方法，这种方法并关闭提供ImageInputStream的读操作完成后，除非null返回，在这种情况下，该方法不会关闭该流。

        参数
        stream - 一个 ImageInputStream要阅读。
        结果
        一个 BufferedImage包含输入，或经解码内容 null 。
        异常
        IllegalArgumentException - 如果 stream是 null 。
        IOException - 读取期间是否发生错误。

      • write

        public static boolean write​(RenderedImage im,
                            String formatName,
                            ImageOutputStream output)
                     throws IOException
        使用支持给定格式的任意ImageWriter写入图像到ImageOutputStream 。 图像被写入从当前流指针开始的ImageOutputStream ，如果存在，则从该点向前覆盖现有流数据。

        写入操作完成后，此方法不关闭提供的ImageOutputStream ; 如果需要，呼叫者有责任关闭流。

        参数
        im - a RenderedImage待写。
        formatName - a String包含格式的非正式名称。
        output - ImageOutputStream 。
        结果
        false如果没有找到合适的作者。
        异常
        IllegalArgumentException - 如果任何参数是 null 。
        IOException - 写入时是否发生错误。

      • write

        public static boolean write​(RenderedImage im,
                            String formatName,
                            File output)
                     throws IOException
        使用支持给定格式的任意ImageWriter写入图像到File 。 如果已经存在File ，则其内容将被丢弃。
        参数
        im - a RenderedImage待写。
        formatName - 一个包含格式的非正式名称的 String 。
        output - a File要写入。
        结果
        false如果没有找到合适的作者。
        异常
        IllegalArgumentException - 如果任何参数是 null 。
        IOException - 如果在写入过程中出现错误或无法创建所需的ImageOutputStream。

      • write

        public static boolean write​(RenderedImage im,
                            String formatName,
                            OutputStream output)
                     throws IOException
        使用支持给定格式的任意ImageWriter写入图像到OutputStream 。

        写入操作完成后，此方法不关闭提供的OutputStream ; 如果需要，呼叫者有责任关闭流。

        当前缓存设置从getUseCache和getCacheDirectory将用于控制缓存。

        参数
        im - a RenderedImage待写。
        formatName - a String包含格式的非正式名称。
        output - OutputStream 。
        结果
        false如果没有找到合适的作者。
        异常
        IllegalArgumentException - 如果任何参数是 null 。
        IOException - 如果写入期间发生错误或无法创建所需的ImageOutputStream。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Class ImageReader

  • java.lang.Object
    • javax.imageio.ImageReader

  • public abstract class ImageReader
extends Object
    用于解析和解码图像的抽象超类。 这个类必须由在Java Image I / O框架的上下文中读取的类进行子类化。

    ImageReader对象通常由特定格式的服务提供商接口（SPI）类实例化。 服务提供商类（例如， ImageReaderSpi实例）已注册到IIORegistry ，它们用于格式识别和呈现可用格式的读者和作者。

    当设置输入源（使用setInput方法）时，可能将其标记为“仅向前寻找”。 此设置意味着输入源中包含的图像只能按顺序读取，可能允许读取器避免缓存包含与先前读取的图像相关联的数据的输入的部分。

    另请参见：
    ImageWriter ， IIORegistry ， ImageReaderSpi

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Locale[] availableLocales
      可用于本地化警告消息的 Locale的数组，如果不支持本地化， null 。
      protected boolean ignoreMetadata
      true如果当前输入源已被标记为允许元数据被 setInput忽略。
      protected Object input
      所述 ImageInputStream或其它 Object通过 setInput和由检索 getInput 。
      protected Locale locale
      目前 Locale用于定位，或 null ;如果没有设置。
      protected int minIndex
      读取的最小有效索引，最初为0。
      protected ImageReaderSpi originatingProvider
      该 ImageReaderSpi认为这个实例化对象，或者 null如果其身份未知或不存在。
      protected List<IIOReadProgressListener> progressListeners
      A List当前注册的 IIOReadProgressListener s，默认初始化为 null ，这是一个空的 List代名词。
      protected boolean seekForwardOnly
      true如果当前的输入源已被标记为允许仅转发寻找 setInput 。
      protected List<IIOReadUpdateListener> updateListeners
      A List当前注册的 IIOReadUpdateListener s，默认初始化为 null ，这是一个空的 List代名词。
      protected List<IIOReadWarningListener> warningListeners
      A List当前注册的 IIOReadWarningListener s，默认初始化为 null ，这是一个空的 List同义词。
      protected List<Locale> warningLocales
      一个 List的 Locale与每个当前注册的 IIOReadWarningListener相关联，默认初始化为 null ，这是一个空的 List同义词。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ImageReader​(ImageReaderSpi originatingProvider)
      构造一个 ImageReader并将其 originatingProvider字段设置为提供的值。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void abort​()
      请求中止任何当前的读取操作。
      protected boolean abortRequested​()
      如果从读取器被实例化或者 clearAbortRequest以来，如果已经进行了中止当前读取操作的请求，则返回 true 。
      void addIIOReadProgressListener​(IIOReadProgressListener listener)
      将 IIOReadProgressListener添加到已注册进度侦听器的列表中。
      void addIIOReadUpdateListener​(IIOReadUpdateListener listener)
      将 IIOReadUpdateListener添加到已注册的更新监听器列表中。
      void addIIOReadWarningListener​(IIOReadWarningListener listener)
      将 IIOReadWarningListener添加到已注册的警告侦听器列表中。
      boolean canReadRaster​()
      如果此插件支持只读取Raster的像素数据，则返回true 。
      protected static void checkReadParamBandSettings​(ImageReadParam param, int numSrcBands, int numDstBands)
      读者可以使用一种实用方法来测试 ImageReadParam的源和目标频带设置的 ImageReadParam 。
      protected void clearAbortRequest​()
      清除任何先前的中止请求。
      protected static void computeRegions​(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion)
      计算感兴趣的源区域和感兴趣的目的地区域，考虑源图像的宽度和高度，可选的目标图像和可选的 ImageReadParam 。
      void dispose​()
      允许释放此对象持有的任何资源。
      float getAspectRatio​(int imageIndex)
      将给定图像的宽高比（即其宽度除以其高度）返回为 float 。
      Locale[] getAvailableLocales​()
      返回可用于本地化警告侦听器和压缩设置的 Locale s的数组。
      ImageReadParam getDefaultReadParam​()
      返回适用于此格式的默认 ImageReadParam对象。
      protected static BufferedImage getDestination​(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
      返回要写入的解码像素数据的 BufferedImage 。
      String getFormatName​()
      返回一个 String标识输入源的格式。
      abstract int getHeight​(int imageIndex)
      返回输入源中给定图像的高度（以像素为单位）。
      abstract IIOMetadata getImageMetadata​(int imageIndex)
      返回一个 IIOMetadata与给定图像，或相关联的对象包含元数据 null如果读取器不支持读取元数据，被设置为忽略元数据，或者，如果没有元数据可用。
      IIOMetadata getImageMetadata​(int imageIndex, String formatName, Set<String> nodeNames)
      返回一个 IIOMetadata表示与给定图像，或相关联的元数据对象 null如果读取器不支持读取元数据或没有可用的。
      abstract Iterator<ImageTypeSpecifier> getImageTypes​(int imageIndex)
      返回一个 Iterator其中包含可以解码给定图像的可能的图像类型，格式为 ImageTypeSpecifiers s。
      Object getInput​()
      返回先前设置为输入源的 ImageInputStream或其他 Object 。
      Locale getLocale​()
      如果没有设置，返回当前设置的 Locale或 null 。
      int getMinIndex​()
      返回读取图像，缩略图或图像元数据的最低有效索引。
      abstract int getNumImages​(boolean allowSearch)
      返回当前输入源可用的图像数量，不包括缩略图。
      int getNumThumbnails​(int imageIndex)
      返回与给定图像相关联的缩略图预览图像的数量。
      ImageReaderSpi getOriginatingProvider​()
      返回传递给构造函数的 ImageReaderSpi 。
      ImageTypeSpecifier getRawImageType​(int imageIndex)
      返回一个 ImageTypeSpecifier表示 SampleModel和 ColorModel ，其最接近地表示图像的“原始”内部格式。
      protected static Rectangle getSourceRegion​(ImageReadParam param, int srcWidth, int srcHeight)
      读者可以使用一种实用方法来计算应该读取的源图像的区域，同时考虑到所提供的 ImageReadParam中的任何源区域和子采样偏移设置。
      abstract IIOMetadata getStreamMetadata​()
      返回一个 IIOMetadata表示与输入源作为一个整体（即，不与任何特定图像相关联）相关联的元数据对象，或者 null如果读取器不支持读取元数据，被设置为忽略元数据，或者，如果没有元数据可用。
      IIOMetadata getStreamMetadata​(String formatName, Set<String> nodeNames)
      返回一个 IIOMetadata对象，表示与整个输入源相关联的元数据（即，与任何特定图像无关）。
      int getThumbnailHeight​(int imageIndex, int thumbnailIndex)
      返回索引的缩略图预览图像的高度 thumbnailIndex ，通过索引的图像关联 ImageIndex 。
      int getThumbnailWidth​(int imageIndex, int thumbnailIndex)
      返回由索引的缩略图的预览图像的宽度 thumbnailIndex ，与由索引的图像相关联 ImageIndex 。
      int getTileGridXOffset​(int imageIndex)
      返回给定图像中瓦片（0，0）左上角的X坐标。
      int getTileGridYOffset​(int imageIndex)
      返回给定图像中瓦片（0，0）左上角的Y坐标。
      int getTileHeight​(int imageIndex)
      返回给定图像中图块的高度。
      int getTileWidth​(int imageIndex)
      返回给定图像中图块的宽度。
      abstract int getWidth​(int imageIndex)
      返回输入源中给定图像的宽度（以像素为单位）。
      boolean hasThumbnails​(int imageIndex)
      如果给定的图像具有与其相关联的缩略图预览图像，则返回 true 。
      boolean isIgnoringMetadata​()
      如果当前输入源已被标记为允许通过将 true作为 ignoreMetadata参数传递给 setInput方法的 ignoreMetadata来忽略元数据，则返回 true 。
      boolean isImageTiled​(int imageIndex)
      如果图像被组织成 瓦片 ，则返回 true ，即相等大小的非重叠矩形。
      boolean isRandomAccessEasy​(int imageIndex)
      返回 true如果给定图像的存储格式不会对随机访问像素造成固有的障碍。
      boolean isSeekForwardOnly​()
      返回 true如果当前输入源已被标记为寻找前进，则只能通过将 true作为 seekForwardOnly参数传递给 setInput方法。
      protected void processImageComplete​()
      通过调用他们的 imageComplete方法将所读取的图像的完成广播到所有注册的 IIOReadProgressListener 。
      protected void processImageProgress​(float percentageDone)
      通过调用其 imageProgress方法，将目前的图像完成百分比广播到所有注册的 IIOReadProgressListener 。
      protected void processImageStarted​(int imageIndex)
      通过调用其 imageStarted方法将所读取的图像的开始广播到所有注册的 IIOReadProgressListener 。
      protected void processImageUpdate​(BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      通过调用其 imageUpdate方法，将一组样本的更新广播到所有注册的 IIOReadUpdateListener 。
      protected void processPassComplete​(BufferedImage theImage)
      通过调用他们的 passComplete方法，将所有已注册的 IIOReadUpdateListener传送到所有注册的 IIOReadUpdateListener 。
      protected void processPassStarted​(BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      通过调用他们的 passStarted方法，将所有注册的 IIOReadUpdateListener的广告传播到开始。
      protected void processReadAborted​()
      通过调用它们的 readAborted方法，广播已经中止所有注册的所有注册的 IIOReadProgressListener 。
      protected void processSequenceComplete​()
      通过调用他们的 sequenceComplete方法，将所有注册的 IIOReadProgressListener的图像读取序列的完成广播。
      protected void processSequenceStarted​(int minIndex)
      通过调用 sequenceStarted方法，将所有注册的 IIOReadProgressListener的图像序列的开始广播。
      protected void processThumbnailComplete​()
      通过调用 thumbnailComplete方法，将所有注册的 IIOReadProgressListener s的缩略图读取完成。
      protected void processThumbnailPassComplete​(BufferedImage theThumbnail)
      通过调用他们的 thumbnailPassComplete方法，将所有注册的 IIOReadUpdateListener的缩略图遍历传递结束广播。
      protected void processThumbnailPassStarted​(BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      通过调用他们的 thumbnailPassStarted方法，将所有注册的 IIOReadUpdateListener的缩略图遍历的开始广播。
      protected void processThumbnailProgress​(float percentageDone)
      通过调用其 thumbnailProgress方法将所有已注册的 IIOReadProgressListener的缩略图完成的当前百分比广播。
      protected void processThumbnailStarted​(int imageIndex, int thumbnailIndex)
      通过调用 thumbnailStarted方法，将所有注册的 IIOReadProgressListener的缩略图读取的开始广播。
      protected void processThumbnailUpdate​(BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      通过调用其 thumbnailUpdate方法将缩略图中的一组样本的更新广播到所有注册的 IIOReadUpdateListener 。
      protected void processWarningOccurred​(String warning)
      通过拨打他们的 warningOccurred方法向所有注册的 IIOReadWarningListener发送一条警告消息。
      protected void processWarningOccurred​(String baseName, String keyword)
      通过使用从 ResourceBundle获取的字符串调用其 warningOccurred方法向所有注册的 IIOReadWarningListener广播本地化警告消息。
      BufferedImage read​(int imageIndex)
      读取由 imageIndex索引的图像，并将其作为完整的 BufferedImage返回，使用默认值 ImageReadParam 。
      abstract BufferedImage read​(int imageIndex, ImageReadParam param)
      阅读由 imageIndex索引的图像，并将其作为完整的 BufferedImage返回，使用附带的 ImageReadParam 。
      IIOImage readAll​(int imageIndex, ImageReadParam param)
      读取由索引的图像 imageIndex并返回一个 IIOImage包含图像，缩略图和相关联的图像元数据，使用所提供的 ImageReadParam 。
      Iterator<IIOImage> readAll​(Iterator<? extends ImageReadParam> params)
      返回 Iterator包含所有图像，缩略图和元数据，开始由下式给出的指数在 getMinIndex ，从形式的输入源 IIOImage对象。
      RenderedImage readAsRenderedImage​(int imageIndex, ImageReadParam param)
      返回一个 RenderedImage对象，其中包含由 imageIndex索引的图像的内容。
      boolean readerSupportsThumbnails​()
      如果此阅读器理解的图像格式支持与之相关的缩略图预览图像，则返回 true 。
      Raster readRaster​(int imageIndex, ImageReadParam param)
      返回包含来自图像流的原始像素数据的新的 Raster对象，而不应用任何颜色转换。
      BufferedImage readThumbnail​(int imageIndex, int thumbnailIndex)
      返回 thumbnailIndex索引的缩略图预览图像，与 ImageIndex索引的图像相关联，为 BufferedImage 。
      BufferedImage readTile​(int imageIndex, int tileX, int tileY)
      读取 tileX和 tileY参数指示的 tileX ，将其作为 BufferedImage返回。
      Raster readTileRaster​(int imageIndex, int tileX, int tileY)
      返回一个新的 Raster对象，其中包含来自图块的原始像素数据，而不应用任何颜色转换。
      void removeAllIIOReadProgressListeners​()
      删除所有当前注册的 IIOReadProgressListener对象。
      void removeAllIIOReadUpdateListeners​()
      删除所有当前注册的 IIOReadUpdateListener对象。
      void removeAllIIOReadWarningListeners​()
      删除所有当前注册的 IIOReadWarningListener对象。
      void removeIIOReadProgressListener​(IIOReadProgressListener listener)
      从注册进度侦听器列表中删除 IIOReadProgressListener 。
      void removeIIOReadUpdateListener​(IIOReadUpdateListener listener)
      从注册的更新监听器列表中删除一个 IIOReadUpdateListener 。
      void removeIIOReadWarningListener​(IIOReadWarningListener listener)
      从注册的错误侦听器列表中删除 IIOReadWarningListener 。
      void reset​()
      将 ImageReader恢复到初始状态。
      void setInput​(Object input)
      设置要用于给定的 ImageInputStream或其他 Object的输入源。
      void setInput​(Object input, boolean seekForwardOnly)
      设置要用于给定的 ImageInputStream或其他 Object的输入源。
      void setInput​(Object input, boolean seekForwardOnly, boolean ignoreMetadata)
      设置要用于给定的 ImageInputStream或其他 Object的输入源。
      void setLocale​(Locale locale)
      将此 ImageReader的当前 Locale设置为给定值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • originatingProvider

        protected ImageReaderSpi originatingProvider
        该ImageReaderSpi认为这个实例化对象，或者null如果其身份未知或不存在。 默认情况下初始化为null 。

      • input

        protected Object input
        所述ImageInputStream或其它Object通过setInput和由检索getInput 。 默认情况下，它被初始化为null 。

      • seekForwardOnly

        protected boolean seekForwardOnly
        true如果当前的输入源已被标记为允许只有前向寻找setInput 。 默认值为false 。
        另请参见：
        minIndex ， setInput(java.lang.Object, boolean, boolean)

      • ignoreMetadata

        protected boolean ignoreMetadata
        true如果当前输入源已被标记为允许setInput忽略元数据。 默认值为false 。
        另请参见：
        setInput(java.lang.Object, boolean, boolean)

      • minIndex

        protected int minIndex
        读取的最小有效索引，最初为0.当 seekForwardOnly为 true ，各种方法可能会在尝试访问与具有较低索引的图像相关联的数据时抛出 IndexOutOfBoundsException 。
        另请参见：
        seekForwardOnly ， setInput(java.lang.Object, boolean, boolean)

      • availableLocales

        protected Locale[] availableLocales
        可用于本地化警告消息的 Locale的数组，如果不支持本地化， null 。

      • locale

        protected Locale locale
        目前 Locale用于定位，或 null ;如果没有设置。

      • warningListeners

        protected List<IIOReadWarningListener> warningListeners
        A List目前注册的 IIOReadWarningListener s，默认初始化为 null ，这是一个空的 List同义词。

      • warningLocales

        protected List<Locale> warningLocales
        一个 List的 Locale与每个当前注册的 IIOReadWarningListener相关联，默认初始化为 null ，这是一个空的 List同义词。

      • progressListeners

        protected List<IIOReadProgressListener> progressListeners
        A List当前注册的 IIOReadProgressListener s，默认初始化为 null ，这是一个空的 List同义词。

      • updateListeners

        protected List<IIOReadUpdateListener> updateListeners
        A List当前注册的 IIOReadUpdateListener s，默认初始化为 null ，这是一个空的 List代名词。

    • 构造方法详细信息

      • ImageReader

        protected ImageReader​(ImageReaderSpi originatingProvider)
        构造一个ImageReader并将其originatingProvider字段设置为提供的值。

        使用扩展的子类应提供带有签名(ImageReaderSpi,Object)的构造(ImageReaderSpi,Object) ，以便检索扩展对象。 如果扩展对象不合适，则应抛出一个IllegalArgumentException 。

        参数
        originatingProvider -在 ImageReaderSpi即调用此构造，或 null 。

    • 方法详细信息

      • getFormatName

        public String getFormatName​()
                     throws IOException
        返回一个String标识输入源的格式。

        默认实现返回originatingProvider.getFormatNames()[0] 。 可能没有源服务提供商的实现，或希望使用不同命名策略的实现应该覆盖此方法。

        结果
        格式名称，作为 String 。
        异常
        IOException - 如果从输入源读取信息发生错误。

      • getOriginatingProvider

        public ImageReaderSpi getOriginatingProvider​()
        返回传递给构造函数的ImageReaderSpi 。 请注意，此值可能为null 。
        结果
        一个 ImageReaderSpi ，或 null 。
        另请参见：
        ImageReaderSpi

      • setInput

        public void setInput​(Object input,
                     boolean seekForwardOnly,
                     boolean ignoreMetadata)
        设置要用于给定的ImageInputStream或其他Object的输入源。 必须在使用任何查询或读取方法之前设置输入源。 如果input是null ，任何当前设置的输入源将被删除。 无论如何， minIndex的值将被初始化为0。

        seekForwardOnly参数控制是否getMinIndex每个图像（或缩略图或图像元数据）是否增加getMinIndex返回的值。 如果seekForwardOnly是真的，那么一个电话read(index)会抛出一个IndexOutOfBoundsException如果是index < this.minIndex ; 否则， minIndex的值将设置为index 。 如果seekForwardOnly为false ，价值minIndex将保持0无论任何读操作。

        ignoreMetadata参数（如果设置为true ）允许读者忽略读取期间遇到的任何元数据。 在后续调用getStreamMetadata种getImageMetadata方法可能会返回null和IIOImage从返回readAll可能返回null从他们getMetadata方法。 设置此参数可能会使读者更有效地工作。 读者可以选择忽略此设置并正常返回元数据。

        子类应该注意根据前一个流来删除任何缓存的信息，例如标题信息或部分解码的图像数据。

        的一般使用Object比其他ImageInputStream旨在用于直接与捕获设备或图像协议交互的读取器。 这套法律课由读者服务提供商的getInputTypes方法发布; 大多数读者将返回一个仅包含ImageInputStream.class的单元素数组，表示它们只接受一个ImageInputStream 。

        默认实现对input返回的列表检查input参数，如果参数不是列表中的一个类的实例， originatingProvider.getInputTypes()失败。 如果始发提供商设置为null ，则只有在ImageInputStream才能接受输入。

        参数
        input - ImageInputStream或其他 Object用于将来的解码。
        seekForwardOnly - 如果是 true ，图像和元数据只能从此输入源的升序读取。
        ignoreMetadata - 如果是 true ，读取期间可能会忽略元数据。
        异常
        IllegalArgumentException - 如果 input不是始发服务提供商的 getInputTypes方法返回的其中一个类的实例，或者不是 ImageInputStream 。
        另请参见：
        ImageInputStream ， getInput() ， ImageReaderSpi.getInputTypes()

      • setInput

        public void setInput​(Object input,
                     boolean seekForwardOnly)
        设置要用于给定的ImageInputStream或其他Object的输入源。 必须在使用任何查询或读取方法之前设置输入源。 如果input为null ，则任何当前设置的输入源都将被删除。 无论如何， minIndex的值将被初始化为0。

        seekForwardOnly参数控制是否getMinIndex返回的值，因为getMinIndex每个图像（或缩略图或图像元数据）。 如果seekForwardOnly是真的，那么一个read(index)的调用将抛出一个IndexOutOfBoundsException如果是index < this.minIndex ; 否则， minIndex的值将设置为index 。 如果seekForwardOnly为false ，价值minIndex将保持0无论任何读操作。

        此方法相当于setInput(input, seekForwardOnly, false) 。

        参数
        input - ImageInputStream或其他 Object用于将来的解码。
        seekForwardOnly - 如果是 true ，图像和元数据只能从此输入源的升序读取。
        异常
        IllegalArgumentException - 如果 input不是始发服务提供商的 getInputTypes方法返回的一个类的实例，或者不是 ImageInputStream 。
        另请参见：
        getInput()

      • setInput

        public void setInput​(Object input)
        设置要用于给定的ImageInputStream或其他Object的输入源。 必须在使用任何查询或读取方法之前设置输入源。 如果input为null ，则任何当前设置的输入源都将被删除。 无论如何， minIndex的值将被初始化为0。

        此方法相当于setInput(input, false, false) 。

        参数
        input - ImageInputStream或其他 Object用于将来的解码。
        异常
        IllegalArgumentException - 如果 input不是由始发服务提供商的 getInputTypes方法返回的类的一个实例，或者不是 ImageInputStream 。
        另请参见：
        getInput()

      • getInput

        public Object getInput​()
        返回先前设置为输入源的ImageInputStream或其他Object 。 如果输入源尚未设置，则返回null 。
        结果
        该 Object将被用于未来解码，或 null 。
        另请参见：
        ImageInputStream ， setInput(java.lang.Object, boolean, boolean)

      • isSeekForwardOnly

        public boolean isSeekForwardOnly​()
        返回 true如果当前输入源已经被标记为只通过将寻求前进 true为 seekForwardOnly参数传递给 setInput方法。
        结果
        true如果输入源仅向前寻找。
        另请参见：
        setInput(java.lang.Object, boolean, boolean)

      • isIgnoringMetadata

        public boolean isIgnoringMetadata​()
        返回 true如果当前输入源已经被标记为允许元数据通过传递被忽略 true为 ignoreMetadata参数传递给 setInput方法。
        结果
        true如果元数据可能被忽略。
        另请参见：
        setInput(java.lang.Object, boolean, boolean)

      • getMinIndex

        public int getMinIndex​()
        返回读取图像，缩略图或图像元数据的最低有效索引。 如果seekForwardOnly()为false ，则该值通常保持为0，表示随机访问是可能的。 否则，它将包含最近访问的索引的值，并以单调方式增加。
        结果
        阅读的最低法定指数。

      • getAvailableLocales

        public Locale[] getAvailableLocales​()
        返回可用于本地化警告侦听器和压缩设置的Locale s的数组。 返回值为null表示不支持本地化。

        如果availableLocales实例变量为非null ，默认实现将返回克隆，否则返回null 。

        结果
        的阵列 Locale可用于作为参数为s setLocale ，或 null 。

      • setLocale

        public void setLocale​(Locale locale)
        将此ImageReader的当前Locale设置为给定值。 值null删除任何以前的设置，并指示阅读器应将其视为合适的本地化。
        参数
        locale - 所需的 Locale或 null 。
        异常
        IllegalArgumentException - 如果 locale不是 null但不是 getAvailableLocales返回的值 getAvailableLocales 。
        另请参见：
        getLocale()

      • getLocale

        public Locale getLocale​()
        返回当前设置 Locale ，或 null ;如果没有设置。
        结果
        目前为 Locale ，或 null 。
        另请参见：
        setLocale(java.util.Locale)

      • getNumImages

        public abstract int getNumImages​(boolean allowSearch)
                          throws IOException
        返回当前输入源可用的图像数量，不包括缩略图。

        请注意，某些图像格式（如动画GIF）不会指定流中存在多少图像。 因此，确定图像的数量将需要扫描整个流，并且可能需要用于缓冲的存储器。 如果read顺序处理图像，可以通过增加索引直接调用read更有效，直到抛出IndexOutOfBoundsException以指示不再有图像可用。 allowSearch参数可能设置为false以表示false详尽的搜索; 返回值将为-1 ，表示需要进行搜索。 如果输入已与指定seekForwardOnly设定为true ，此方法将引发IllegalStateException如果allowSearch设定为true 。

        参数
        allowSearch - 如果是true ，即使需要搜索，也会返回真实的图像数量。 如果是false ，读者可以返回-1而不执行搜索。
        结果
        如 int ，或 -1如果 allowSearch是 false并且需要搜索，图像的数量。
        异常
        IllegalStateException - 如果输入源尚未设置，或者输入是否已被指定为 seekForwardOnly设置为 true 。
        IOException - 如果从输入源读取信息时发生错误。
        另请参见：
        setInput(java.lang.Object, boolean, boolean)

      • getWidth

        public abstract int getWidth​(int imageIndex)
                      throws IOException
        返回输入源中给定图像的宽度（以像素为单位）。

        如果图像可以呈现为用户指定的大小，则此方法返回默认宽度。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        图像的宽度，如 int 。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 如果从输入源读取宽度信息发生错误。

      • getHeight

        public abstract int getHeight​(int imageIndex)
                       throws IOException
        返回输入源中给定图像的高度（以像素为单位）。

        如果图像可以呈现为用户指定的大小，则此方法返回默认高度。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        图像的高度，作为一个 int 。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 如果从输入源读取高度信息发生错误。

      • isRandomAccessEasy

        public boolean isRandomAccessEasy​(int imageIndex)
                           throws IOException
        如果给定图像的存储格式不会对随机访问像素造成固有的障碍，则返回true 。 对于大多数压缩格式（如JPEG），此方法应返回false ，除了感兴趣的区域之外，还可能需要解码图像的大部分。

        这只是一个希望有效的计划的提示; 所有读者必须能够读取ImageReadParam指定的任意区域。

        请注意，从该方法返回false格式可能允许平铺（ 例如 ，JPEG中的重新启动标记），并且随机访问在瓦片上可能会相当有效。 见isImageTiled 。

        所有图像保证支持简单的随机访问或保证不支持简单随机访问的false分别返回true或false而不访问任何图像数据。 在这种情况下，即使没有设置输入源或图像索引超出范围，也不必抛出异常。

        默认实现返回false 。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        如果读取给定图像的感兴趣区域可能是有效的， true 。
        异常
        IllegalStateException - 如果需要输入源来确定返回值，但没有设置。
        IndexOutOfBoundsException - 如果必须访问图像以确定返回值，但提供的索引超出范围。
        IOException - 如果阅读期间发生错误。

      • getAspectRatio

        public float getAspectRatio​(int imageIndex)
                     throws IOException
        将给定图像的宽高比（即其宽度除以其高度）返回为float 。 对于固有可调整尺寸的图像，该方法提供了一种确定给定期望高度的适当宽度的方法，反之亦然。 对于不可调整大小的图像，使用真实的宽度和高度。

        默认实现只是返回(float)getWidth(imageIndex)/getHeight(imageIndex) 。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        一个表示给定图像的纵横比的 float 。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 读取时是否发生错误。

      • getRawImageType

        public ImageTypeSpecifier getRawImageType​(int imageIndex)
                                   throws IOException
        返回一个ImageTypeSpecifier表示SampleModel和ColorModel ，其最接近地表示图像的“原始”内部格式。 如果没有紧密匹配，则应返回保存图像中最多信息的类型。 返回的值也应包含在getImageTypes返回的值列表中。

        默认实现只是从getImageType提供的列表中返回第一个条目。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        一个 ImageTypeSpecifier 。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 如果从输入源读取格式信息发生错误。

      • getImageTypes

        public abstract Iterator<ImageTypeSpecifier> getImageTypes​(int imageIndex)
                                                    throws IOException
        返回一个Iterator其中包含可以解码给定图像的可能的图像类型，格式为ImageTypeSpecifiers 。 将返回至少一个合法的图像类型。

        迭代器的第一个元素应该是用于以尽可能少的损失解码图像的最“自然”类型。 例如，对于JPEG图像，第一个条目应该是RGB图像，即使图像数据内部存储在YCbCr颜色空间中。

        参数
        imageIndex - 图像的索引为 retrieved 。
        结果
        一个 Iterator含有至少一个 ImageTypeSpecifier表示建议的图像类型对于当前给定的图像进行解码。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 如果从输入源读取格式信息发生错误。
        另请参见：
        ImageReadParam.setDestination(BufferedImage) ， ImageReadParam.setDestinationType(ImageTypeSpecifier)

      • getDefaultReadParam

        public ImageReadParam getDefaultReadParam​()
        返回适用于此格式的默认对象ImageReadParam 。 所有子类应为所有参数定义一组默认值，并使用此调用返回它们。 可以在设置输入源之前调用此方法。

        默认实现构造并返回不允许源缩放的新的ImageReadParam对象（ 即 ，它返回new ImageReadParam() 。

        结果
        可以使用一组默认设置来控制解码过程的 ImageReadParam对象。

      • getStreamMetadata

        public abstract IIOMetadata getStreamMetadata​()
                                       throws IOException
        返回一个 IIOMetadata对象，表示与输入源整体相关的元数据（即不与任何特定图像相关联），如果阅读器不支持读取元数据，则 null ，被设置为忽略元数据，或者没有元数据可用。
        结果
        一个 IIOMetadata对象，或 null 。
        异常
        IOException - 读取期间是否发生错误。

      • getStreamMetadata

        public IIOMetadata getStreamMetadata​(String formatName,
                                     Set<String> nodeNames)
                              throws IOException
        返回表示与整个输入源相关联的元数据（即，不与任何特定图像相关联）的IIOMetadata对象。 如果没有这样的数据，则返回null 。

        所生成的元数据对象仅负责以formatName命名的格式返回文档。 在返回的任何文档中，只需要返回名称为nodeNames节点。 以这种方式，基于什么信息实际需要，读取器完成的元数据处理的量可以保持最小。

        如果formatName不是受支持的元数据格式的名称，则返回null 。

        在所有情况下，返回一个比严格必要的更有能力的元数据对象是合法的。 格式名称和节点名称仅仅是可用于减少读者工作量的提示。

        在检查格式名称是否支持后，默认实现只返回调用getStreamMetadata()的结果。 如果不是，则返回null 。

        参数
        formatName - 可用于从返回的 IIOMetadata对象检索文档的元数据格式名称。
        nodeNames - a Set包含可能包含在检索到的文档中的节点的名称。
        结果
        一个 IIOMetadata对象，或 null 。
        异常
        IllegalArgumentException - 如果 formatName是 null 。
        IllegalArgumentException - 如果 nodeNames是 null 。
        IOException - 读取时是否发生错误。

      • getImageMetadata

        public abstract IIOMetadata getImageMetadata​(int imageIndex)
                                      throws IOException
        返回一个 IIOMetadata与给定图像，或相关联的对象包含元数据 null如果读取器不支持读取元数据，被设置为忽略元数据，或者，如果没有元数据可用。
        参数
        imageIndex - 要检索其元数据的图像的索引。
        结果
        一个 IIOMetadata对象，或 null 。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 读取时是否发生错误。

      • getImageMetadata

        public IIOMetadata getImageMetadata​(int imageIndex,
                                    String formatName,
                                    Set<String> nodeNames)
                             throws IOException
        返回一个IIOMetadata表示与给定图像，或相关联的元数据对象null如果读取器不支持读取元数据或没有可用的。

        生成的元数据对象只负责以formatName命名的格式返回文档。 在返回的任何文档中，只需要返回名称为nodeNames成员节点。 以这种方式，基于什么信息实际需要，读取器完成的元数据处理的量可以保持最小。

        如果formatName不是支持的元数据格式的名称， null可能会返回null 。

        在所有情况下，返回一个比严格必要的更有能力的元数据对象是合法的。 格式名称和节点名称仅仅是可用于减少读者工作量的提示。

        在检查格式名称被支持后，默认实现只是返回调用getImageMetadata(imageIndex)的结果。 如果不是，则返回null 。

        参数
        imageIndex - 要检索其元数据的图像的索引。
        formatName - 可用于从返回的 IIOMetadata对象中检索文档的元数据格式名称。
        nodeNames - a Set包含可能包含在检索到的文档中的节点的名称。
        结果
        一个 IIOMetadata对象，或 null 。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IllegalArgumentException - 如果 formatName是 null 。
        IllegalArgumentException - 如果 nodeNames是 null 。
        IOException - 读取时是否发生错误。

      • read

        public BufferedImage read​(int imageIndex)
                   throws IOException
        读取imageIndex索引的图像，并将其作为完整的BufferedImage返回，使用默认值ImageReadParam 。 这是一个方便的方法，调用read(imageIndex, null) 。

        返回根据第一将被格式化的图像ImageTypeSpecifier从返回getImageTypes 。

        任何注册IIOReadProgressListener对象将通过调用它们的通知imageStarted方法，然后通过调用其imageProgress方法读取进展。 最后他们将会调用它们的imageComplete方法。 当像素被解码时，在读取期间的其他时间可以更新对象IIOReadUpdateListener 。 最后， IIOReadWarningListener对象将收到在解码期间发生的任何非致命警告的通知。

        参数
        imageIndex - 要检索的图像的索引。
        结果
        图像的所需部分为 BufferedImage 。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 读取时是否发生错误。

      • read

        public abstract BufferedImage read​(int imageIndex,
                                   ImageReadParam param)
                            throws IOException
        读取imageIndex索引的图像，并将其作为完整的BufferedImage返回，使用附带的ImageReadParam 。

        将使用getDestination方法定义的算法选择实际的BufferedImage返回getDestination 。

        任何注册IIOReadProgressListener对象将通过调用它们的通知imageStarted方法，然后通过调用其imageProgress方法读取进展。 最后他们将会调用它们的imageComplete方法。 IIOReadUpdateListener对象可以在其他时间读出期间像素被解码被更新。 最后， IIOReadWarningListener对象将收到在解码期间发生的任何非致命警告的通知。

        要读取的源频带组和要写入的目标频带由所提供的ImageReadParam上的getSourceBands和getDestinationBands ImageReadParam 。 如果由这些方法返回的数组的长度不同，则源频带集包含较大的可用源索引，或者目标频带集合包含大于最大合法目标索引的索引的索引，抛出IllegalArgumentException 。

        如果提供的ImageReadParam包含此读卡器不支持的可选设置值（ 例如源渲染大小或任何特定于格式的设置），它们将被忽略。

        参数
        imageIndex - 要检索的图像的索引。
        param - 一个 ImageReadParam用于控制阅读过程，或 null 。
        结果
        图像的所需部分为 BufferedImage 。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IllegalArgumentException - 如果由 param.getSourceBands和 param.getDestinationBands指定的源和目标频带的长度不同或包括超出范围的索引。
        IllegalArgumentException - 如果生成的图像的宽度或高度小于1。
        IOException - 读取时是否发生错误。

      • readAll

        public IIOImage readAll​(int imageIndex,
                        ImageReadParam param)
                 throws IOException
        读取由索引的图像imageIndex并返回一个IIOImage包含图像，缩略图和相关联的图像元数据，使用所提供的ImageReadParam 。

        实际BufferedImage由返回引用IIOImage将使用由定义的算法来选择getDestination方法。

        任何注册IIOReadProgressListener对象将通过调用它们的通知imageStarted方法，然后通过调用其imageProgress方法读取进展。 最后他们将会调用它们的imageComplete方法。 IIOReadUpdateListener对象可以在其他时间读出期间像素被解码被更新。 最后， IIOReadWarningListener对象将收到在解码期间发生的任何非致命警告的通知。

        要读取的源频带组和要写入的目标频带由所提供的ImageReadParam上的getSourceBands和getDestinationBands ImageReadParam 。 如果这些方法返回的数组的长度不同，则源频带集包含一个较大的索引，即最大的可用源索引，或者目标频段集合包含大于最大合法目标索引的索引，抛出一个IllegalArgumentException 。

        无论区域设置如何，缩略图将全部返回。

        如果提供的ImageReadParam包含此读卡器不支持的可选设置值（ 例如源渲染大小或特定于格式的设置），则这些值将被忽略。

        参数
        imageIndex - 要检索的图像的索引。
        param -一个 ImageReadParam用来控制读取过程中，或 null 。
        结果
        包含图像的期望部分，一组缩略图和相关联的图像元数据的 IIOImage 。
        异常
        IllegalStateException - 如果输入源未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IllegalArgumentException - 如果由 param.getSourceBands和 param.getDestinationBands指定的源和目标频带 param.getSourceBands param.getDestinationBands不同或包括超出界限的索引。
        IllegalArgumentException - 如果生成的图像的宽度或高度小于1。
        IOException - 如果在阅读期间发生错误。

      • readAll

        public Iterator<IIOImage> readAll​(Iterator<? extends ImageReadParam> params)
                           throws IOException
        返回Iterator包含所有图像，缩略图和元数据，开始由下式给出的指数在getMinIndex ，从形式的输入源IIOImage对象。 提供一个包含ImageReadParam对象的Iterator ; 从输入源读取的每个图像消耗一个元素，直到没有更多的图像可用。 如果读取的参数Iterator用尽了元素，但是仍然有更多的图像可以从输入源，默认读参数用于剩余的图像。

        如果params为null ，则所有图像都将使用默认阅读参数。

        实际BufferedImage由返回引用IIOImage将使用由定义的算法来选择getDestination方法。

        任何已注册的IIOReadProgressListener对象将通过其sequenceStarted方法一次通知。 然后，对于每个图像解码，就会有一个电话imageStarted ，然后调用imageProgress作为读取进展，最后到imageComplete 。 sequenceComplete方法将在最后一个图像解码后调用。 IIOReadUpdateListener对象可以在其他时间读出期间像素被解码被更新。 最后， IIOReadWarningListener对象将收到在解码期间发生的任何非致命警告的通知。

        要读取的源频带组和要写入的目标频带由所提供的ImageReadParam和getDestinationBands调用getSourceBands和getDestinationBands确定。 如果这些方法返回的数组的长度不同，则源频带集包含一个较大的索引，即最大的可用源索引，或者目标频带组包含大于最大合法目的地索引的索引，抛出一个IllegalArgumentException 。

        无论区域设置如何，缩略图将全部返回。

        如果提供的任何ImageReadParam包含此读卡器不支持的可选设置值（ 例如源渲染大小或任何特定于格式的设置），它们将被忽略。

        参数
        params - 一个 Iterator包含 ImageReadParam对象。
        结果
        一个 Iterator表示输入源的内容为 IIOImage s。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IllegalArgumentException -如果任何非 null的元件 params不是 ImageReadParam 。
        IllegalArgumentException - 如果由 param.getSourceBands和 param.getDestinationBands指定的源和目标频带的长度不同或包括超出界限的索引。
        IllegalArgumentException - 如果生成的图像的宽度或高度小于1。
        IOException - 读取时是否发生错误。
        另请参见：
        ImageReadParam ， IIOImage

      • canReadRaster

        public boolean canReadRaster​()
        返回true如果此插件支持读取只是一个Raster像素数据。 如果此方法返回false ，则调用readRaster或readTileRaster将抛出一个UnsupportedOperationException 。

        默认实现返回false 。

        结果
        true如果这个插件支持阅读原始的 Raster s。
        另请参见：
        readRaster(int, javax.imageio.ImageReadParam) ， readTileRaster(int, int, int)

      • readRaster

        public Raster readRaster​(int imageIndex,
                         ImageReadParam param)
                  throws IOException
        返回包含来自图像流的原始像素数据的新的Raster对象，而不应用任何颜色转换。 应用程序必须确定如何通过其他方式解释像素数据。 所提供的ImageReadParam对象中的任何目的地或图像类型参数都将被忽略，但所有其他参数的使用方式与read方法完全相同，只是将任何目标偏移量用作逻辑而不是物理偏移量。 返回的Raster的大小将始终是剪辑到实际图像的源区域的大小。 流中的逻辑偏移本身将被忽略。

        该方法允许通常应用颜色转换的格式（例如JPEG）和通常不具有相关联的颜色空间的格式（例如遥感或医学成像数据）来提供对原始像素数据的访问。

        任何已注册的readUpdateListener都被忽略，因为没有BufferedImage ，但所有其他监听器被完全称为read方法。

        如果canReadRaster()返回false ，此方法将抛出一个UnsupportedOperationException 。

        如果提供的ImageReadParam包含此读卡器不支持的可选设置值（ 例如源渲染大小或任何特定于格式的设置），它们将被忽略。

        默认实现会抛出一个UnsupportedOperationException 。

        参数
        imageIndex - 要读取的图像的索引。
        param -一个 ImageReadParam用来控制读取过程中，或 null 。
        结果
        图像的所需部分为 Raster 。
        异常
        UnsupportedOperationException - 如果这个插件不支持阅读原始的 Raster s。
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 读数时是否发生错误。
        另请参见：
        canReadRaster() ， read(int) ， Raster

      • isImageTiled

        public boolean isImageTiled​(int imageIndex)
                     throws IOException
        如果图像被组织成瓦片 ，即相等大小的非重叠矩形，则返回true 。

        阅读器插件可以选择是否在存储图像时露出存在的平铺。 甚至可以选择在没有明确存在的情况下发布平铺。 一般来说，如果存在访问各个瓦片的某些优势（速度或空间），则仅应该对平铺进行通告。 无论读者是否通告平铺，它必须能够读取ImageReadParam指定的任意矩形区域。

        所有图像保证被平铺或保证不被平铺的阅读器可以分别返回true或false而不访问任何图像数据。 在这种情况下，即使没有设置输入源或图像索引超出范围，也不必抛出异常。

        默认实现只是返回false 。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        true如果图像是平铺的。
        异常
        IllegalStateException - 如果需要输入源来确定返回值，但没有设置。
        IndexOutOfBoundsException - 如果必须访问映像以确定返回值，但提供的索引超出范围。
        IOException - 读取时是否发生错误。

      • getTileWidth

        public int getTileWidth​(int imageIndex)
                 throws IOException
        返回给定图像中图块的宽度。

        默认实现只是返回getWidth(imageIndex) ，这对于非平铺图像是正确的。 支持平铺的读者应该覆盖此方法。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        瓷砖的宽度。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 读取期间是否发生错误。

      • getTileHeight

        public int getTileHeight​(int imageIndex)
                  throws IOException
        返回给定图像中图块的高度。

        默认实现简单地返回getHeight(imageIndex) ，这对于非平铺图像是正确的。 支持平铺的读者应该覆盖此方法。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        瓷砖的高度。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IOException - 读取时是否发生错误。

      • getTileGridXOffset

        public int getTileGridXOffset​(int imageIndex)
                       throws IOException
        返回给定图像中瓦片（0，0）左上角的X坐标。

        瓦片网格X偏移总是具有相同值（通常为0）的读取器可以返回该值而不访问任何图像数据。 在这种情况下，即使没有设置输入源或图像索引超出范围，也不必抛出异常。

        默认实现只返回0，这对于大多数格式的非平铺图像和平铺图像是正确的。 支持平铺（0，0）偏移量的读者应该覆盖此方法。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        瓦片网格的X偏移量。
        异常
        IllegalStateException - 如果需要输入源来确定返回值，但没有设置。
        IndexOutOfBoundsException - 如果必须访问映像以确定返回值，但提供的索引超出范围。
        IOException - 读数时是否发生错误。

      • getTileGridYOffset

        public int getTileGridYOffset​(int imageIndex)
                       throws IOException
        返回给定图像中瓦片（0，0）左上角的Y坐标。

        瓦片网格Y偏移总是具有相同值（通常为0）的读取器可以返回该值而不访问任何图像数据。 在这种情况下，即使没有设置输入源或图像索引超出范围，也不必抛出异常。

        默认实现只返回0，这对于大多数格式的非平铺图像和平铺图像是正确的。 支持平铺（0，0）偏移量的读者应该覆盖此方法。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        瓦片网格的Y偏移量。
        异常
        IllegalStateException - 如果需要输入源来确定返回值，但没有设置。
        IndexOutOfBoundsException - 如果必须访问映像以确定返回值，但提供的索引超出范围。
        IOException - 读数时是否发生错误。

      • readTile

        public BufferedImage readTile​(int imageIndex,
                              int tileX,
                              int tileY)
                       throws IOException
        读取tileX和tileY参数指示的tileX ，将其作为BufferedImage返回。 如果参数超出范围，则抛出一个IllegalArgumentException 。 如果图像不平铺，值0,0将返回整个图像; 任何其他值将导致抛出IllegalArgumentException 。

        此方法仅仅是一个方便相当于调用read(int, ImageReadParam)用read参数指定具有偏移量的源极区域tileX*getTileWidth(imageIndex) ， tileY*getTileHeight(imageIndex)和宽度和高度getTileWidth(imageIndex) ， getTileHeight(imageIndex) ; 子采样因子为1，偏移为0.要对图块进行子采样，请使用指定此区域的读参数和不同的子采样参数调用read 。

        如果tileX和tileY为0，默认实现将返回整个映像，否则返回一个IllegalArgumentException 。

        参数
        imageIndex - 要检索的图像的索引。
        tileX - 要检索的图块的列索引（以0开头）。
        tileY - 要检索的图块的行索引（以0开头）。
        结果
        瓷砖为 BufferedImage 。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果 imageIndex是超出范围。
        IllegalArgumentException - 如果图块索引超出界限。
        IOException - 读取时是否发生错误。

      • readTileRaster

        public Raster readTileRaster​(int imageIndex,
                             int tileX,
                             int tileY)
                      throws IOException
        返回一个新的Raster对象，其中包含来自图块的原始像素数据，而不应用任何颜色转换。 应用程序必须确定如何通过其他方式解释像素数据。

        如果canReadRaster()返回false ，此方法将抛出UnsupportedOperationException 。

        默认实现检查是否支持阅读Raster ，如果是readRaster(imageIndex, null)，如果tileX和tileY为0，或者抛出一个IllegalArgumentException否则。

        参数
        imageIndex - 要检索的图像的索引。
        tileX - 要检索的图块的列索引（以0开头）。
        tileY - 要检索的图块的行索引（以0开头）。
        结果
        瓷砖为 Raster 。
        异常
        UnsupportedOperationException - 如果这个插件不支持阅读原始的 Raster s。
        IllegalArgumentException - 如果图块索引超出范围。
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果 imageIndex超出范围。
        IOException - 读数时是否发生错误。
        另请参见：
        readTile(int, int, int) ， readRaster(int, javax.imageio.ImageReadParam) ， Raster

      • readAsRenderedImage

        public RenderedImage readAsRenderedImage​(int imageIndex,
                                         ImageReadParam param)
                                  throws IOException
        返回一个RenderedImage对象，其中包含由imageIndex索引的图像的内容。 默认情况下，返回的图像只是由BufferedImage返回的read(imageIndex, param) 。

        该方法的语义可能与其他read方法的语法有所不同。 首先， ImageReadParam设置的任何目标图像和/或图像类型可能会被忽略。 第二，通常的听众电话不能保证制作，或者是有意义的。 这是因为返回的图像在返回时可能未完全填充像素数据，或者确实在任何时候。

        如果提供的ImageReadParam包含此读卡器不支持的可选设置值（ 例如源渲染大小或特定于格式的设置），它们将被忽略。

        默认实现只是调用read(imageIndex, param) 。

        参数
        imageIndex - 要检索的图像的索引。
        param -一个 ImageReadParam用来控制读取过程中，或 null 。
        结果
        一个 RenderedImage对象，提供图像的视图。
        异常
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的索引超出范围。
        IllegalArgumentException - 如果由 param.getSourceBands和 param.getDestinationBands指定的源和目标频带的长度不同或包括超出范围的索引。
        IllegalArgumentException - 如果生成的图像的宽度或高度小于1。
        IOException - 读取时是否发生错误。

      • readerSupportsThumbnails

        public boolean readerSupportsThumbnails​()
        如果此阅读器理解的图像格式支持与其关联的缩略图预览图像，则返回true 。 默认实现返回false 。

        如果此方法返回false ，则hasThumbnails和getNumThumbnails将分别返回false和0 ，而readThumbnail将抛出UnsupportedOperationException ，无论其论点如何。

        不支持缩略图的读者不需要实现与缩略图相关的任何方法。

        结果
        true如果支持缩略图。

      • hasThumbnails

        public boolean hasThumbnails​(int imageIndex)
                      throws IOException
        如果给定的图像具有与其相关联的缩略图预览图像，则返回true 。 如果格式不支持缩略图（ readerSupportsThumbnails返回false ）， false时将忽略输入源是否已经设置退回或是否imageIndex是在边界。

        如果getNumThumbnails返回大于0的值，则默认实现将返回true 。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        true如果给定的图像有缩略图。
        异常
        IllegalStateException - 如果阅读器支持缩略图，但输入源尚未设置。
        IndexOutOfBoundsException - 如果读者支持缩略图，但 imageIndex是超出范围。
        IOException - 读取时是否发生错误。

      • getNumThumbnails

        public int getNumThumbnails​(int imageIndex)
                     throws IOException
        返回与给定图像相关联的缩略图预览图像的数量。 如果格式不支持缩略图，（ readerSupportsThumbnails返回false ）， 0时将忽略输入源是否已经设置退回或是否imageIndex是在边界。

        默认实现返回0，而不检查其参数。

        参数
        imageIndex - 要查询的图像的索引。
        结果
        与给定图像相关联的缩略图数量。
        异常
        IllegalStateException - 如果阅读器支持缩略图，但输入源尚未设置。
        IndexOutOfBoundsException - 如果读者支持缩略图，但 imageIndex是超出范围。
        IOException - 读取时是否发生错误。

      • getThumbnailWidth

        public int getThumbnailWidth​(int imageIndex,
                             int thumbnailIndex)
                      throws IOException
        返回由索引的缩略图的预览图像的宽度thumbnailIndex ，与由索引的图像相关联ImageIndex 。

        如果读者不支持缩略图，（ readerSupportsThumbnails返回false ），将抛出一个UnsupportedOperationException 。

        默认实现只是返回readThumbnail(imageindex, thumbnailIndex).getWidth() 。 因此，如果可能，子类应该覆盖此方法，以避免强制缩略图被读取。

        参数
        imageIndex - 要检索的图像的索引。
        thumbnailIndex - 要检索的缩略图的索引。
        结果
        所需缩略图的宽度为 int 。
        异常
        UnsupportedOperationException - 如果不支持缩略图。
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果任何一个提供的索引超出范围。
        IOException - 读取时是否发生错误。

      • getThumbnailHeight

        public int getThumbnailHeight​(int imageIndex,
                              int thumbnailIndex)
                       throws IOException
        返回索引的缩略图预览图像的高度thumbnailIndex ，通过索引的图像关联ImageIndex 。

        如果读者不支持缩略图，（ readerSupportsThumbnails返回false ），将抛出一个UnsupportedOperationException 。

        默认实现只是返回readThumbnail(imageindex, thumbnailIndex).getHeight() 。 因此，如果可能，子类应该覆盖此方法，以避免强制缩略图被读取。

        参数
        imageIndex - 要检索的图像的索引。
        thumbnailIndex - 要检索的缩略图的索引。
        结果
        所需缩略图的高度为 int 。
        异常
        UnsupportedOperationException - 如果不支持缩略图。
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果提供的任何一个索引超出范围。
        IOException - 读数时是否发生错误。

      • readThumbnail

        public BufferedImage readThumbnail​(int imageIndex,
                                   int thumbnailIndex)
                            throws IOException
        返回由thumbnailIndex索引的缩略图预览图像，与ImageIndex作为BufferedImage索引的图像相关联。

        任何注册IIOReadProgressListener对象将通过调用它们的通知thumbnailStarted ， thumbnailProgress ，并thumbnailComplete方法。

        如果读者不支持缩略图，（ readerSupportsThumbnails返回false ），无论输入源是设置还是索引处于边界，将抛出UnsupportedOperationException 。

        默认实现会抛出一个UnsupportedOperationException 。

        参数
        imageIndex - 要检索的图像的索引。
        thumbnailIndex - 要检索的缩略图的索引。
        结果
        所需的缩略图为 BufferedImage 。
        异常
        UnsupportedOperationException - 如果不支持缩略图。
        IllegalStateException - 如果输入源尚未设置。
        IndexOutOfBoundsException - 如果任何一个提供的索引超出范围。
        IOException - 读取时是否发生错误。

      • abort

        public void abort​()
        请求中止任何当前的读取操作。 中止后图像的内容将不确定。

        读者应在每次读取操作开始时调用clearAbortRequest ，并在读取期间定期轮询值abortRequested 。

      • abortRequested

        protected boolean abortRequested​()
        返回 true是否已经做出了中止当前读取操作的请求，因为读者被实例化或 clearAbortRequest被调用。
        结果
        true如果当前的读取操作应该被中止。
        另请参见：
        abort() ， clearAbortRequest()

      • clearAbortRequest

        protected void clearAbortRequest​()
        清除任何先前的中止请求。 此方法被调用后， abortRequested将返回false 。
        另请参见：
        abort() ， abortRequested()

      • addIIOReadWarningListener

        public void addIIOReadWarningListener​(IIOReadWarningListener listener)
        将IIOReadWarningListener添加到已注册警告侦听器的列表中。 如果listener为null ，则不会抛出异常，不会执行任何操作。 发送给给定侦听器的消息将被本地化，如果可能，匹配当前的Locale 。 如果没有设置Locale ，警告消息可能会按照读者认为合适的方式进行本地化。
        参数
        listener - 要注册的 IIOReadWarningListener 。
        另请参见：
        removeIIOReadWarningListener(javax.imageio.event.IIOReadWarningListener)

      • removeIIOReadWarningListener

        public void removeIIOReadWarningListener​(IIOReadWarningListener listener)
        从注册的错误侦听器列表中删除IIOReadWarningListener 。 如果侦听器以前未注册，或者如果listener为null ，则不会抛出任何异常，也不会执行任何操作。
        参数
        listener - 要注销的IIOReadWarningListener。
        另请参见：
        addIIOReadWarningListener(javax.imageio.event.IIOReadWarningListener)

      • removeAllIIOReadWarningListeners

        public void removeAllIIOReadWarningListeners​()
        删除所有当前注册的IIOReadWarningListener对象。

        默认实现将warningListeners和warningLocales实例变量设置为null 。

      • addIIOReadProgressListener

        public void addIIOReadProgressListener​(IIOReadProgressListener listener)
        在注册进度侦听器列表中添加一个IIOReadProgressListener 。 如果listener是null ，则不会抛出异常，也不会采取任何行动。
        参数
        listener - 要注册的IIOReadProgressListener。
        另请参见：
        removeIIOReadProgressListener(javax.imageio.event.IIOReadProgressListener)

      • removeIIOReadProgressListener

        public void removeIIOReadProgressListener​(IIOReadProgressListener listener)
        从注册进度侦听器列表中删除IIOReadProgressListener 。 如果监听者以前没有注册，或者如果listener为null ，则不会抛出任何异常，也不会采取任何行动。
        参数
        listener - 要注销的IIOReadProgressListener。
        另请参见：
        addIIOReadProgressListener(javax.imageio.event.IIOReadProgressListener)

      • removeAllIIOReadProgressListeners

        public void removeAllIIOReadProgressListeners​()
        删除所有当前注册的IIOReadProgressListener对象。

        默认实现将progressListeners实例变量设置为null 。

      • addIIOReadUpdateListener

        public void addIIOReadUpdateListener​(IIOReadUpdateListener listener)
        将IIOReadUpdateListener添加到已注册的更新监听器列表中。 如果listener为null ，则不会抛出异常，不会执行任何操作。 听众将接收像素更新的通知，因为图像和缩略图被解码，包括渐进通过的开始和结束。

        如果没有更新听众存在，读者可以选择对目的地图像和/或缩略图的像素执行更少的更新，这可以导致更有效的解码。

        例如，在逐行JPEG解码中，每个遍历包含对一组系数的更新，如果听众存在，则该系数将必须被转换为像素值并且被转换为每个遍的RGB颜色空间。 如果没有听众存在，则可以简单地累积系数，并且最终结果被转换并仅一次进行颜色转换。

        无论中间更新是否被执行，解码的最终结果将是相同的。 因此，如果只需要最终的图像，则可能不会注册任何IIOReadUpdateListener 。 通常，通过与本地CPU处理相比非常慢的网络连接获取图像时，逐行更新最有效; 通过快速连接，逐行更新可能实际上会减慢图像的呈现。

        参数
        listener - 要注册的IIOReadUpdateListener。
        另请参见：
        removeIIOReadUpdateListener(javax.imageio.event.IIOReadUpdateListener)

      • removeIIOReadUpdateListener

        public void removeIIOReadUpdateListener​(IIOReadUpdateListener listener)
        从注册的更新监听器列表中删除IIOReadUpdateListener 。 如果监听者以前没有注册，或者如果listener是null ，则不会抛出异常，也不会采取任何行动。
        参数
        listener - 要注销的IIOReadUpdateListener。
        另请参见：
        addIIOReadUpdateListener(javax.imageio.event.IIOReadUpdateListener)

      • removeAllIIOReadUpdateListeners

        public void removeAllIIOReadUpdateListeners​()
        删除所有当前注册的IIOReadUpdateListener对象。

        默认实现将updateListeners实例变量设置为null 。

      • processSequenceStarted

        protected void processSequenceStarted​(int minIndex)
        通过调用他们的sequenceStarted方法，将所有注册的IIOReadProgressListener的图像读取序列的开始广播。 子类可以方便地使用这种方法。
        参数
        minIndex - 正在读取的最低索引。

      • processSequenceComplete

        protected void processSequenceComplete​()
        通过调用它们的sequenceComplete方法，将所有注册的IIOReadProgressListener的图像读取序列的完成广播。 子类可以方便地使用这种方法。

      • processImageStarted

        protected void processImageStarted​(int imageIndex)
        通过调用imageStarted方法将所读取的图像的开始广播到所有注册的IIOReadProgressListener 。 子类可以方便地使用这种方法。
        参数
        imageIndex - 要读取的图像的索引。

      • processImageProgress

        protected void processImageProgress​(float percentageDone)
        通过调用他们的imageProgress方法，将目前的图像完成百分比广播到所有注册的IIOReadProgressListener 。 子类可以方便地使用这种方法。
        参数
        percentageDone - 目前的完成百分比，为 float 。

      • processImageComplete

        protected void processImageComplete​()
        通过调用他们的imageComplete方法将所读取的图像的完成广播到所有注册的IIOReadProgressListener 。 子类可以方便地使用这种方法。

      • processThumbnailStarted

        protected void processThumbnailStarted​(int imageIndex,
                                       int thumbnailIndex)
        通过调用thumbnailStarted方法，将所有注册的IIOReadProgressListener s的缩略图读取的开始广播。 子类可以方便地使用这种方法。
        参数
        imageIndex - 与缩略图关联的图像的索引。
        thumbnailIndex - 缩略图的索引。

      • processThumbnailProgress

        protected void processThumbnailProgress​(float percentageDone)
        通过调用其thumbnailProgress方法将目前的缩略图完成百分比广播到所有注册的IIOReadProgressListener 。 子类可以方便地使用这种方法。
        参数
        percentageDone - 目前的完成百分比，为 float 。

      • processThumbnailComplete

        protected void processThumbnailComplete​()
        通过调用thumbnailComplete方法将所有注册的IIOReadProgressListener的缩略图读取完成。 子类可以方便地使用这种方法。

      • processReadAborted

        protected void processReadAborted​()
        通过调用它们的readAborted方法广播已读取已被中止到所有注册的IIOReadProgressListener 。 子类可以方便地使用这种方法。

      • processPassStarted

        protected void processPassStarted​(BufferedImage theImage,
                                  int pass,
                                  int minPass,
                                  int maxPass,
                                  int minX,
                                  int minY,
                                  int periodX,
                                  int periodY,
                                  int[] bands)
        通过调用他们的passStarted方法，将所有注册的IIOReadUpdateListener s的渐进通过开始广播。 子类可以方便地使用这种方法。
        参数
        theImage - BufferedImage正在更新。
        pass - 当前通过的索引，以0开头。
        minPass - 将被解码的 minPass的索引。
        maxPass - 将被解码的最后一次通过的索引。
        minX - 包含在通过中的左上角像素的X坐标。
        minY - 通过中包含的左上角像素的X坐标。
        periodX - 像素之间的水平分隔。
        periodY - 像素之间的垂直分隔。
        bands -的阵列 int以及指示该组中的目的地的受影响的频带。

      • processImageUpdate

        protected void processImageUpdate​(BufferedImage theImage,
                                  int minX,
                                  int minY,
                                  int width,
                                  int height,
                                  int periodX,
                                  int periodY,
                                  int[] bands)
        通过调用其imageUpdate方法，将一组样本的更新广播到所有注册的IIOReadUpdateListener 。 子类可以方便地使用这种方法。
        参数
        theImage - BufferedImage正在更新。
        minX - 包含在通过中的左上角像素的X坐标。
        minY - 通过中包含的左上角像素的X坐标。
        width - 要更新的区域的总宽度，包括要跳过的像素，如果是 periodX > 1 。
        height - 正在更新的区域的总高度，包括如果 periodY > 1被跳过的像素。
        periodX - 像素之间的水平间隔。
        periodY - 像素之间的垂直分隔。
        bands - int s的数组，表示目的地受影响的一组。

      • processPassComplete

        protected void processPassComplete​(BufferedImage theImage)
        通过调用他们的passComplete方法，将所有注册的IIOReadUpdateListener的广播结束广播。 子类可以方便地使用这种方法。
        参数
        theImage - BufferedImage正在更新。

      • processThumbnailPassStarted

        protected void processThumbnailPassStarted​(BufferedImage theThumbnail,
                                           int pass,
                                           int minPass,
                                           int maxPass,
                                           int minX,
                                           int minY,
                                           int periodX,
                                           int periodY,
                                           int[] bands)
        通过调用他们的thumbnailPassStarted方法将所有注册的IIOReadUpdateListener的缩略图遍历的开始广播。 子类可以方便地使用这种方法。
        参数
        theThumbnail - 正在更新的 BufferedImage缩略图。
        pass - 当前通过的索引，从0开始。
        minPass - 将被解码的 minPass的索引。
        maxPass - 将被解码的最后一次通过的索引。
        minX - 通过中包含的左上角像素的X坐标。
        minY - 通过中包含的左上角像素的X坐标。
        periodX - 像素之间的水平分隔。
        periodY - 像素之间的垂直分隔。
        bands -的阵列 int以及指示该组中的目的地的受影响的频带。

      • processThumbnailUpdate

        protected void processThumbnailUpdate​(BufferedImage theThumbnail,
                                      int minX,
                                      int minY,
                                      int width,
                                      int height,
                                      int periodX,
                                      int periodY,
                                      int[] bands)
        通过调用其thumbnailUpdate方法，将缩略图中的一组样本的更新广播到所有注册的IIOReadUpdateListener 。 子类可以方便地使用这种方法。
        参数
        theThumbnail - 正在更新的 BufferedImage缩略图。
        minX - 通过中包含的左上角像素的X坐标。
        minY - 包含在通行证中的左上角像素的X坐标。
        width - 正在更新的区域的总宽度，包括如果 periodX > 1被跳过的像素。
        height - 正在更新的区域的总高度，包括如果 periodY > 1被跳过的像素。
        periodX - 像素之间的水平分隔。
        periodY - 像素之间的垂直分隔。
        bands -的阵列 int以及指示该组中的目的地的受影响的频带。

      • processThumbnailPassComplete

        protected void processThumbnailPassComplete​(BufferedImage theThumbnail)
        通过调用他们的thumbnailPassComplete方法，将所有注册的IIOReadUpdateListener s的缩略图IIOReadUpdateListener通过thumbnailPassComplete 。 子类可以方便地使用这种方法。
        参数
        theThumbnail - 正在更新的 BufferedImage缩略图。

      • processWarningOccurred

        protected void processWarningOccurred​(String warning)
        通过拨打其warningOccurred方法向所有注册的IIOReadWarningListener发送警告信息。 子类可以方便地使用这种方法。
        参数
        warning - 要发送的警告消息。
        异常
        IllegalArgumentException - 如果 warning是 null 。

      • processWarningOccurred

        protected void processWarningOccurred​(String baseName,
                                      String keyword)
        通过使用从ResourceBundle获取的字符串调用其warningOccurred方法向所有注册的IIOReadWarningListener播放本地化警告消息。 子类可以方便地使用这种方法。
        参数
        baseName - 包含本地化警告消息的一组 ResourceBundle的基本名称。
        keyword - 用于索引 ResourceBundle的集合内的警告消息的关键字。
        异常
        IllegalArgumentException - 如果 baseName是 null 。
        IllegalArgumentException - 如果 keyword是 null 。
        IllegalArgumentException - 如果不适合，可能会找到 ResourceBundle 。
        IllegalArgumentException - 如果在定位的 ResourceBundle找不到命名的资源。
        IllegalArgumentException - 如果从 ResourceBundle检索的对象不是 String 。

      • reset

        public void reset​()
        将ImageReader恢复到初始状态。

        默认实现调用setInput(null, false) ， setLocale(null) ， removeAllIIOReadUpdateListeners() ， removeAllIIOReadWarningListeners() ， removeAllIIOReadProgressListeners() ，并clearAbortRequest 。

      • dispose

        public void dispose​()
        允许释放此对象持有的任何资源。 在调用此方法之后调用其他方法（不包括finalize ）的结果未定义。

        当应用程序知道它们将不再使用ImageReader时，这个方法很重要。 否则，读者可以继续无限期地持有资源。

        超类中的这个方法的默认实现什么都不做。 子类实现应确保释放所有资源，特别是本地资源。

      • getSourceRegion

        protected static Rectangle getSourceRegion​(ImageReadParam param,
                                           int srcWidth,
                                           int srcHeight)
        读者可以使用一种实用方法来计算应该读取的源图像的区域，同时考虑到所提供的ImageReadParam中的任何源区域和子采样偏移设置。 不考虑实际的子采样因子，目的地大小和目的地偏移，因此必须进行进一步的剪切。 computeRegions方法执行所有必要的剪辑。
        参数
        param - 正在使用的 ImageReadParam ，或 null 。
        srcWidth - 源图像的宽度。
        srcHeight - 源图像的高度。
        结果
        源区域为 Rectangle 。

      • computeRegions

        protected static void computeRegions​(ImageReadParam param,
                                     int srcWidth,
                                     int srcHeight,
                                     BufferedImage image,
                                     Rectangle srcRegion,
                                     Rectangle destRegion)
        计算感兴趣的源区域和目标区域，将源图像的宽度和高度，可选的目标图像和可选的ImageReadParam考虑在内。 源区域以整个源图像开始。 然后被剪切到ImageReadParam指定的源区域，如果指定了。

        如果任一目标偏移量为负值，则源区域被剪切，以使其左上角与目标图像的左上角重合，并考虑子采样。 然后将结果剪切到右侧和底部的目标图像，如果指定了目标图像，则将子采样和目标偏移量纳入考虑。

        类似地，目的地区域以源图像开始，被转换为ImageReadParam给出的目的地偏移量，如果有的话，最后被剪切到目标图像，如果有的话。

        如果源或目的地区域的宽度或高度为0，则抛出IllegalArgumentException 。

        如果仅需要源限幅，则可以使用getSourceRegion>方法。

        参数
        param - a ImageReadParam或 null 。
        srcWidth - 源图像的宽度。
        srcHeight - 源图像的高度。
        image - 一个 BufferedImage ，将是目标图像，或 null 。
        srcRegion - 一个 Rectangle ，将填充感兴趣的源区域。
        destRegion - 一个 Rectangle ，将填充目的地区域。
        异常
        IllegalArgumentException - 如果 srcRegion是 null 。
        IllegalArgumentException - 如果 dstRegion是 null 。
        IllegalArgumentException - 如果生成的源或目的地区域为空。

      • checkReadParamBandSettings

        protected static void checkReadParamBandSettings​(ImageReadParam param,
                                                 int numSrcBands,
                                                 int numDstBands)
        读者可以使用一种实用方法来测试ImageReadParam的源和目标频带设置的ImageReadParam 。 一旦读取器知道源图像在输入流中存在的频带的数量以及正被写入的目的图像的频带数量，则可以调用该方法。

        该方法检索的源和目标频带设定从使用PARAM阵列getSourceBands种getDestinationBands方法（或认为它们是null如果param是null ）。 如果源频带设置阵列是null ，那么它被认为等于阵列{ 0, 1, ..., numSrcBands - 1 } ，类似地用于目的频带设置阵列。

        然后，该方法测试两个数组的长度相等，并且两个数组都不包含大于最大可用带索引的值。

        任何失败导致抛出IllegalArgumentException ; 成功导致该方法静默地返回。

        参数
        param - 用于阅读图像的 ImageReadParam 。
        numSrcBands - 输入源中存在的图像的频带数。
        numDstBands - 正在写入目标图像中的频带数。
        异常
        IllegalArgumentException - 如果 param包含源和/或目标带子集的无效规范。

      • getDestination

        protected static BufferedImage getDestination​(ImageReadParam param,
                                              Iterator<ImageTypeSpecifier> imageTypes,
                                              int width,
                                              int height)
                                       throws IIOException
        返回应写入的解码像素数据的BufferedImage 。 图像通过检查提供的ImageReadParam如果不是null ; 如果其getDestination方法返回非null值，那么该图像将被简单地返回。 否则， param.getDestinationType方法来确定是否指定了特定的图像类型。 如果是这样，则返回ImageTypeSpecifier正在检查它等于那些包含在之后使用imageTypes 。

        如果param是null或上述步骤没有产生图像或ImageTypeSpecifier ，则使用从imageTypes参数获得的第一个值。 通常，呼叫者将设置imageTypes的值为getImageTypes(imageIndex) 。

        接下来，通过调用computeRegions确定图像的尺寸。 正在解码的图像的实际宽度和高度以width和height参数的width height 。

        参数
        param -一个 ImageReadParam被用于获取目标图像或图像类型，或 null 。
        imageTypes - 一个 Iterator的 ImageTypeSpecifier s，指示合法的图像类型，默认为第一个。
        width - 要解码的图像或图块的真实宽度。
        height - 正在解码的图像或瓦片的真实宽度。
        结果
        应写入解码像素数据的 BufferedImage 。
        异常
        IIOException -如果 ImageTypeSpecifier由指定 param不会匹配任何法律措施的 imageTypes 。
        IllegalArgumentException - 如果 imageTypes为 null或为空，或者从其中检索不是类型为 ImageTypeSpecifier的对象。
        IllegalArgumentException - 如果生成的图像的宽度或高度小于1。
        IllegalArgumentException - 如果 width和 height的产品大于 Integer.MAX_VALUE 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageReadParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Class ImageReadParam

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
  • 已知直接子类：
    JPEGImageReadParam ， TIFFImageReadParam

    public class ImageReadParam
extends IIOParam
    描述流如何解码的类。 该类或其子类的实例用于向ImageReader实例提供规定的“how-to”信息。

    编码为文件或流的一部分的图像可以被认为在多个维度上延伸：宽度和高度的空间维度，频带的数量以及逐行解码通路的数量。 该类允许选择所有这些维度中的图像的连续（超）矩形子区域进行解码。 此外，空间维度可以不连续地二次采样。 最后，可以通过使用BufferedImage或使用ImageTypeSpecifier控制目标图像的ColorModel和SampleModel来指定颜色和格式转换。

    一个ImageReadParam对象用于指定如何在Java Image I / O框架的上下文中从流中输入的图像或一组图像进行转换。 用于特定图像格式的ImageReadParam将从其ImageReader实现的getDefaultReadParam方法返回ImageReadParam实例。

    由ImageReadParam实例维护的状态与被解码的任何特定图像无关。 当实际解码发生时，将读取参数中设置的值与正在从流解码的图像的实际属性和将接收解码的像素数据的目的地BufferedImage 。 例如，使用setSourceRegion设置的源区域将首先与实际的有效源区域相交。 结果将按getDestinationOffset返回的值进行getDestinationOffset ，并将生成的矩形与实际有效目的地区域相交，以生成将要写入的目标区域。

    由ImageReadParam指定的参数应用于图像，如下所示。 首先，如果通过setSourceRenderSize设置了渲染尺寸，则整个解码图像以getSourceRenderSize给出的大小呈现。 否则，图像的自然尺寸由ImageReader.getWidth和ImageReader.getHeight 。

    接下来，图像被裁剪针对由指定的源区getSourceXOffset ， getSourceYOffset ， getSourceWidth ，和getSourceHeight 。

    然后根据IIOParam.setSourceSubsampling中给出的因素对所得区域进行二次采样。 第一个像素，每行的像素数以及行数都取决于子采样设置。 呼叫的最小X和所得矩形（Y坐标minX ， minY ），其宽度w和其高度h 。

    该矩形是通过（偏移getDestinationOffset().x ， getDestinationOffset().y ）和针对目的地边界裁剪。 如果没有设置目的地图像，目的地被定义为宽度为getDestinationOffset().x + w ，高度为getDestinationOffset().y + h以便可以将源区域的所有像素写入目的地。

    在二次抽样之后，在目标图像内着陆，以getSourceMinProgressivePass和getSourceNumProgressivePasses指定的逐行通过之一进行写入的getSourceNumProgressivePasses将传递到下一步。

    最后，根据setDestinationBands的评论中描述的算法将每个像素的源样本映射到目标频带。

    插件编写者可以通过提供实现附加的插件特定接口的子类来扩展ImageReadParam的功能。 插件可以记录哪些接口可用，以及如何使用它们。 读者将默认忽略他们不知道的ImageReadParam子类的任何扩展功能。 而且，通过getDefaultReadParam创建自己的ImageReadParam实例时，它们可能会忽略它们通常禁用的任何可选功能。

    请注意，除非存在某种能力的查询方法，否则必须由所有ImageReader实施支持（ 例如，源渲染大小是可选的，但必须支持子抽样）。

    另请参见：
    ImageReader ， ImageWriter ， ImageWriteParam

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected boolean canSetSourceRenderSize
      true如果这个 ImageReadParam允许设置源渲染维度。
      protected BufferedImage destination
      当前目的地 BufferedImage或 null如果没有设置）。
      protected int[] destinationBands
      要使用的一组目的地频段，作为 int的阵列。
      protected int minProgressivePass
      从源读取的逐行传递的最小索引。
      protected int numProgressivePasses
      从源头读取的最大次数。
      protected Dimension sourceRenderSize
      源的所需渲染宽度和高度，如果 canSetSourceRenderSize是 true或 null 。

      • Fields inherited from class javax.imageio.IIOParam

        controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageReadParam​()
      构造一个 ImageReadParam 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean canSetSourceRenderSize​()
      返回 true如果该读取器允许源图像以任意大小呈现，作为解码过程的一部分，通过 setSourceRenderSize方法。
      BufferedImage getDestination​()
      返回 BufferedImage目前由设置 setDestination方法，或者 null ，如果没有设置。
      int[] getDestinationBands​()
      返回将放置数据的频带索引集。
      int getSourceMaxProgressivePass​()
      如果 getSourceNumProgressivePasses等于 Integer.MAX_VALUE ，则返回 Integer.MAX_VALUE 。
      int getSourceMinProgressivePass​()
      返回将被解码的第一个循环遍的索引。
      int getSourceNumProgressivePasses​()
      返回将被解码的渐进道次数。
      Dimension getSourceRenderSize​()
      如果通过 setSourceRenderSize方法设置，则返回源映像在解码过程中渲染的宽度和高度。
      void setDestination​(BufferedImage destination)
      提供 BufferedImage作为解码像素数据的目的地。
      void setDestinationBands​(int[] destinationBands)
      设置要放置数据的目标频带的索引。
      void setDestinationType​(ImageTypeSpecifier destinationType)
      使用 ImageTypeSpecifier设置目标图像的所需图像类型。
      void setSourceProgressivePasses​(int minPass, int numPasses)
      设置将被解码的渐进道次的范围。
      void setSourceRenderSize​(Dimension size)
      如果图像能够以任意大小呈现，请将源宽度和高度设置为提供的值。

      • Methods inherited from class javax.imageio.IIOParam

        activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setSourceBands, setSourceRegion, setSourceSubsampling

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • canSetSourceRenderSize

        protected boolean canSetSourceRenderSize
        true如果这个ImageReadParam允许设置源渲染维度。 默认值为false 。 子类必须手动设置此值。

        不支持设置源渲染大小的ImageReader s应将此值设置为false 。

      • sourceRenderSize

        protected Dimension sourceRenderSize
        源的所需渲染宽度和高度（ canSetSourceRenderSize为true ，或null 。

        ImageReader s不支持设置源渲染大小可能会忽略此值。

      • destination

        protected BufferedImage destination
        当前目的地BufferedImage或null如果没有设置）。 默认值为null 。

      • destinationBands

        protected int[] destinationBands
        要使用的一组目的地频段，作为int的阵列。 默认值为null ，表示所有目的地频段应按顺序写入。

      • minProgressivePass

        protected int minProgressivePass
        从源读取的逐行传递的最小索引。 默认情况下，该值设置为0，表示从第一个可用通过开始的通过应被解码。

        子类应确保此值为非负数。

      • numProgressivePasses

        protected int numProgressivePasses
        从源头读取的最大次数。 默认情况下，该值设置为Integer.MAX_VALUE ，这表示应该解码传递到最后一个可用通过的包含的通行证。

        子类应确保此值为正。 另外，如果值不是Integer.MAX_VALUE ，那么minProgressivePass + numProgressivePasses - 1不应超过Integer.MAX_VALUE 。

    • 构造方法详细信息

      • ImageReadParam

        public ImageReadParam​()
        构造一个 ImageReadParam 。

    • 方法详细信息

      • setDestinationType

        public void setDestinationType​(ImageTypeSpecifier destinationType)
        描述从类复制： IIOParam
        使用ImageTypeSpecifier设置目标图像的所需图像类型。

        读取时，如果使用此方法设置了目的地的布局，则每次调用ImageReader read方法将使用提供的类型说明符指定的格式返回新的BufferedImage 。 作为副作用，任何目的地BufferedImage组由ImageReadParam.setDestination(BufferedImage)将不再被设定为目的地。 换句话说，这种方法可以被认为是调用setDestination((BufferedImage)null) 。

        当写入时，目的地类型可能用于确定图像的颜色类型。 SampleModel信息将被忽略，可能是null 。 例如，4带图像可以表示CMYK或RGBA数据。 如果设置了目的地类型，其ColorModel将覆盖图像本身的任何ColorModel 。 当使用setSourceBands时，这是至关重要的，因为图像的ColorModel将引用整个图像，而不是要写入的频带子集。

        重写：
        setDestinationType在 IIOParam
        参数
        destinationType - 用于确定目的地布局和颜色类型的 ImageTypeSpecifier 。
        另请参见：
        IIOParam.getDestinationType()

      • setDestination

        public void setDestination​(BufferedImage destination)
        提供BufferedImage作为解码像素数据的目的地。 当前设置的图像将被写入read ， readAll ，并readRaster方法，以及对它的引用将由这些方法返回。

        来自上述方法的像素数据将从getDestinationOffset指定的偏移开始写入。

        如果destination是null ，那么这些方法将返回一个新创建的BufferedImage 。

        在读出时，该图像被检查以验证其ColorModel和SampleModel对应于之一ImageTypeSpecifier从传回的ImageReader的getImageTypes方法。 如果没有，读者会抛出一个IIOException 。

        参数
        destination - 要写入的BufferedImage，或 null 。
        另请参见：
        getDestination()

      • getDestination

        public BufferedImage getDestination​()
        返回 BufferedImage目前由设置 setDestination方法，或者 null ，如果没有设置。
        结果
        要写的BufferedImage。
        另请参见：
        setDestination(java.awt.image.BufferedImage)

      • setDestinationBands

        public void setDestinationBands​(int[] destinationBands)
        设置要放置数据的目标频带的索引。 不允许重复索引。

        A null值表示将使用所有目标频带。

        如果没有指定目的地图像，则选择目的地频带子集不会影响读取的输出图像中的频带数; 创建的目标图像仍然具有相同数量的带，就像该方法从未被调用一样。 如果需要目标图像中的不同数量的频带，则必须使用ImageReadParam.setDestination方法提供图像。

        在阅读或写入时，如果已经指定了大于最大目的地频段索引的值，或者要使用的源频带和目标频带数量不同，读写器将抛出IllegalArgumentException 。 ImageReader.checkReadParamBandSettings方法可用于自动化此测试。

        参数
        destinationBands - 要使用的整数带索引数组。
        异常
        IllegalArgumentException - 如果 destinationBands包含负值或重复值。
        另请参见：
        getDestinationBands() ，
IIOParam.getSourceBands() ，
ImageReader.checkReadParamBandSettings(javax.imageio.ImageReadParam, int, int)

      • getDestinationBands

        public int[] getDestinationBands​()
        返回将放置数据的频带索引集。 如果没有设置值，则返回null ，表示将使用所有目标频带。
        结果
        要使用的目的地频段的索引，或 null 。
        另请参见：
        setDestinationBands(int[])

      • canSetSourceRenderSize

        public boolean canSetSourceRenderSize​()
        返回true如果这个读出器允许源图像以任意大小来呈现作为解码过程的一部分，由所述的装置setSourceRenderSize方法。 如果此方法返回false ，则对setSourceRenderSize调用将抛出一个UnsupportedOperationException 。
        结果
        true如果设置源渲染大小被支持。
        另请参见：
        setSourceRenderSize(java.awt.Dimension)

      • setSourceRenderSize

        public void setSourceRenderSize​(Dimension size)
                         throws UnsupportedOperationException
        如果图像能够以任意大小呈现，请将源宽度和高度设置为提供的值。 请注意，值从返回getWidth种getHeight方法上ImageReader不受此方法; 他们将继续返回图像的默认大小。 类似地，如果图像也是平铺的，则按照默认大小给出图块的宽度和高度。

        通常，宽度和高度应该被选择为使得宽度与高度的比率近似于从ImageReader.getAspectRatio返回的图像的纵横比。

        如果此插件不允许设置渲染大小，则将抛出UnsupportedOperationException 。

        要删除渲染大小设置，请传递null的值为size 。

        参数
        size - 一个 Dimension表示所需的宽度和高度。
        异常
        IllegalArgumentException - 如果宽度或高度为负或为0。
        UnsupportedOperationException - 如果此插件不支持图像调整大小。
        另请参见：
        getSourceRenderSize() ，
ImageReader.getWidth(int) ，
ImageReader.getHeight(int) ，
ImageReader.getAspectRatio(int)

      • getSourceRenderSize

        public Dimension getSourceRenderSize​()
        返回源图像在解码过程中渲染的宽度和高度（如果已通过setSourceRenderSize方法设置）。 A null值表示没有设置。
        结果
        源图像的渲染宽度和高度为 Dimension 。
        另请参见：
        setSourceRenderSize(java.awt.Dimension)

      • setSourceProgressivePasses

        public void setSourceProgressivePasses​(int minPass,
                                       int numPasses)
        设置将被解码的渐进道次的范围。 超出此范围的通过将被忽略。

        逐行通过是整个图像的重新编码，通常是逐渐更高的有效分辨率，但是需要更大的传输带宽。 逐行编码的最常用的用法是以JPEG格式发现，其中连续通过包括高频图像内容的更详细的表示。

        基于流中可用的实际通过次数，在解码期间确定要解码的实际传送次数。 因此，如果minPass + numPasses - 1大于最后可用路径的索引，解码将以该路径结束。

        numPasses的Integer.MAX_VALUE值表示应该读取minPass所有通行证。 否则，最后一次通过的指数（ 即 minPass + numPasses - 1 ）不得超过Integer.MAX_VALUE 。

        没有unsetSourceProgressivePasses方法; 通过致电setSourceProgressivePasses(0, Integer.MAX_VALUE)可以获得相同的效果。

        参数
        minPass - 要解码的 minPass的索引。
        numPasses - 要解码的最大通过次数。
        异常
        IllegalArgumentException - 如果 minPass为负数， numPasses为负数或为 numPasses则 numPasses为 Integer.MAX_VALUE但 minPass + numPasses - 1为 INTEGER.MAX_VALUE 。
        另请参见：
        getSourceMinProgressivePass() ， getSourceMaxProgressivePass()

      • getSourceMinProgressivePass

        public int getSourceMinProgressivePass​()
        返回将被解码的第一个循环遍的索引。 如果没有设置值，则返回0（这是正确的值）。
        结果
        将被解码的第一遍的索引。
        另请参见：
        setSourceProgressivePasses(int, int) ， getSourceNumProgressivePasses()

      • getSourceMaxProgressivePass

        public int getSourceMaxProgressivePass​()
        如果getSourceNumProgressivePasses等于Integer.MAX_VALUE ，则返回Integer.MAX_VALUE 。 否则返回getSourceMinProgressivePass() + getSourceNumProgressivePasses() - 1 。
        结果
        要读取的最后一次通过的索引，或 Integer.MAX_VALUE 。

      • getSourceNumProgressivePasses

        public int getSourceNumProgressivePasses​()
        返回将被解码的渐进道次数。 如果没有设置值，将返回Integer.MAX_VALUE （这是正确的值）。
        结果
        将被解码的通过次数。
        另请参见：
        setSourceProgressivePasses(int, int) ， getSourceMinProgressivePass()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageTranscoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Interface ImageTranscoder

  • 所有已知实现类：
    ImageWriter

    public interface ImageTranscoder
    提供元数据转码功能的界面。

    任何图像都可以通过执行读取操作，然后进行写入操作，进行代码转换（写入与原始存储的格式不同的格式）。 但是，由于格式差异，在此过程中可能会发生数据丢失。

    一般来说，当可以创建特定于格式的元数据对象以便尽可能多地封装关于图像及其关联的元数据的信息时，通过用于执行编码的特定ImageWriter可以理解的方式，将获得最佳结果。

    一个ImageTranscoder可以用于将转换IIOMetadata通过所供给的对象ImageReader （每流和每个图像元数据表示）转换成相应的由一个特定的对象适合于编码ImageWriter 。 在ImageWriter直接调用该接口的方法的情况下，输出将适用于该作者。

    将IIOMetadata对象转换为写入器特定格式的内部细节将根据操作的上下文而变化。 通常， ImageWriter将检查传入的对象，看看它是否实现了作者所熟悉的附加接口。 这可能是这种情况，例如，如果对象是通过与作者写入的读写器插件的读操作获得的。 在这种情况下，写入器可以通过其插件特定的接口访问传入的对象。 在这种情况下，如果图像文件格式保持不变，则重新编码可能接近无损。 如果格式发生变化，作者可能仍然尝试保留尽可能多的信息。

    如果传入对象没有实现写入器已知的任何其他接口，则作者无需通过标准IIOMetadata接口访问它，如IIOMetadata.getAsTree提供的树视图。 在这种情况下，可能会有重大的信息丢失。

    独立的ImageTranscoder基本上起着与上述例子中作者插件相同的作用。 它必须熟悉读写器插件使用的专用接口，并手动实例化作者可使用的对象。 生成的元数据对象可以由作者直接使用。

    作为标准API的一部分，没有提供ImageTranscoder独立实现。 相反，该接口的目的是提供一种在需要时由应用程序创建和发现实现的方法。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      IIOMetadata convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可以使用其文档接口或特定于将用于编码的writer插件的其他接口进行修改。
      IIOMetadata convertStreamMetadata​(IIOMetadata inData, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可使用文档接口或特定于编写器插件的其他接口进行修改，该接口将用于编码。

    • 方法详细信息

      • convertStreamMetadata

        IIOMetadata convertStreamMetadata​(IIOMetadata inData,
                                  ImageWriteParam param)
        返回可用于编码的IIOMetadata对象，并可使用其文档接口或特定于将用于编码的writer插件的其他接口进行可选修改。

        可能会为可能影响流元数据结构的情况提供可选的ImageWriteParam 。

        如果提供的ImageWriteParam包含此作者或代码转换器ImageWriteParam可选设置值，则它们将被忽略。

        参数
        inData - 表示流元数据的 IIOMetadata对象，用于初始化返回对象的状态。
        param -一个 ImageWriteParam将被用于对图像，或编码 null 。
        结果
        一个 IIOMetadata对象，如果插件不提供元数据编码功能， null 。
        异常
        IllegalArgumentException - 如果 inData是 null 。

      • convertImageMetadata

        IIOMetadata convertImageMetadata​(IIOMetadata inData,
                                 ImageTypeSpecifier imageType,
                                 ImageWriteParam param)
        返回可用于编码的IIOMetadata对象，并可使用其文档接口或特定于将用于编码的writer插件的其他接口进行可选修改。

        可能会为可能影响图像元数据结构的情况提供ImageWriteParam 。

        如果提供的ImageWriteParam包含此作者或代码转换器ImageWriteParam可选设置值，它们将被忽略。

        参数
        inData - 表示图像元数据的 IIOMetadata对象，用于初始化返回对象的状态。
        imageType - 表示元数据将与之相关联的图像的布局和颜色信息的 ImageTypeSpecifier 。
        param -一个 ImageWriteParam将被用于对图像，或编码 null 。
        结果
        一个 IIOMetadata对象，如果插件不提供元数据编码功能， null 。
        异常
        IllegalArgumentException - 如果 inData或 imageType任一个是 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageTypeSpecifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Class ImageTypeSpecifier

  • java.lang.Object
    • javax.imageio.ImageTypeSpecifier

  • public class ImageTypeSpecifier
extends Object
    允许以方便的方式指定图像的格式（特别是其 SampleModel和 ColorModel ）的类。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected ColorModel colorModel
      ColorModel用作原型。
      protected SampleModel sampleModel
      A SampleModel用作原型。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageTypeSpecifier​(ColorModel colorModel, SampleModel sampleModel)
      构造一个 ImageTypeSpecifier直接从 ColorModel和 SampleModel 。
      ImageTypeSpecifier​(RenderedImage image)
      构造一个 ImageTypeSpecifier从 RenderedImage 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static ImageTypeSpecifier createBanded​(ColorSpace colorSpace, int[] bankIndices, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied)
      返回带状图像格式的说明符，将使用 ComponentColorModel和 BandedSampleModel将每个通道存储在单独的阵列中。
      BufferedImage createBufferedImage​(int width, int height)
      根据此对象中体现的规范，创建一个给定宽度和高度的 BufferedImage 。
      static ImageTypeSpecifier createFromBufferedImageType​(int bufferedImageType)
      返回一个 ImageTypeSpecifier ，编码一个标准的 BufferedImage类型（ TYPE_CUSTOM ）。
      static ImageTypeSpecifier createFromRenderedImage​(RenderedImage image)
      返回一个 ImageTypeSpecifier编码的布局 RenderedImage （其可以是 BufferedImage ）。
      static ImageTypeSpecifier createGrayscale​(int bits, int dataType, boolean isSigned)
      返回一个灰度图像格式的说明符，该格式将将给定位深度的像素包装为指定数据类型的数组元素。
      static ImageTypeSpecifier createGrayscale​(int bits, int dataType, boolean isSigned, boolean isAlphaPremultiplied)
      返回一个用于灰度加Alpha图像格式的说明符，它将给定位深度的像素包装为指定数据类型的数组元素。
      static ImageTypeSpecifier createIndexed​(byte[] redLUT, byte[] greenLUT, byte[] blueLUT, byte[] alphaLUT, int bits, int dataType)
      返回索引颜色图像格式的说明符，该格式将给定位深度的索引值包装为指定数据类型的数组元素。
      static ImageTypeSpecifier createInterleaved​(ColorSpace colorSpace, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied)
      返回一个交织图像格式的说明符，它将使用 ComponentColorModel和 PixelInterleavedSampleModel将每个像素组件存储在单独的字节，短或整数中。
      static ImageTypeSpecifier createPacked​(ColorSpace colorSpace, int redMask, int greenMask, int blueMask, int alphaMask, int transferType, boolean isAlphaPremultiplied)
      返回一个打包图像格式的说明符，该格式将使用 DirectColorModel和打包的 SampleModel来存储单个字节，短或整数的每个像素。
      boolean equals​(Object o)
      如果给定的 Object是 ImageTypeSpecifier并且具有与该对象相同的 SampleModel和 ColorModel ，则返回 true 。
      int getBitsPerBand​(int band)
      返回用于表示给定波段的样本的位数。
      int getBufferedImageType​()
      返回一个包含从 BufferedImage描述图像格式的枚举常量值的int。
      ColorModel getColorModel​()
      返回此对象指定的 ColorModel 。
      int getNumBands​()
      返回此对象指定的频带数。
      int getNumComponents​()
      返回此对象指定的颜色成分数。
      SampleModel getSampleModel​()
      根据此对象中封装的设置，返回 SampleModel 。
      SampleModel getSampleModel​(int width, int height)
      根据封装在此对象内的设置，返回 SampleModel 。
      int hashCode​()
      返回此ImageTypeSpecifier的哈希码。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • colorModel

        protected ColorModel colorModel
        ColorModel被用作原型。

      • sampleModel

        protected SampleModel sampleModel
        A SampleModel用作原型。

    • 构造方法详细信息

      • ImageTypeSpecifier

        public ImageTypeSpecifier​(ColorModel colorModel,
                          SampleModel sampleModel)
        构造一个ImageTypeSpecifier直接从ColorModel和SampleModel 。 主叫方有责任提供兼容的参数。
        参数
        colorModel - a ColorModel 。
        sampleModel - a SampleModel 。
        异常
        IllegalArgumentException - 如果任一参数是 null 。
        IllegalArgumentException - 如果 sampleModel与 colorModel不兼容。

      • ImageTypeSpecifier

        public ImageTypeSpecifier​(RenderedImage image)
        构造一个ImageTypeSpecifier从RenderedImage 。 如果使用BufferedImage使用其中一种工厂方法createFromRenderedImage或createFromBufferedImageType ，以获得更准确的结果。
        参数
        image - a RenderedImage 。
        异常
        IllegalArgumentException - 如果参数是 null 。

    • 方法详细信息

      • createPacked

        public static ImageTypeSpecifier createPacked​(ColorSpace colorSpace,
                                              int redMask,
                                              int greenMask,
                                              int blueMask,
                                              int alphaMask,
                                              int transferType,
                                              boolean isAlphaPremultiplied)
        返回一个打包图像格式的说明符，该格式将使用 DirectColorModel和打包的 SampleModel来存储单个字节，短或整数的每个像素。
        参数
        colorSpace - 所需的 ColorSpace 。
        redMask - 连续的掩码表示红色通道的位置。
        greenMask - 连续的掩码表示绿色通道的位置。
        blueMask - 连续的掩码表示蓝色通道的位置。
        alphaMask - 连续的掩码表示Alpha通道的位置。
        transferType - 所需的 SampleModel传输类型。
        isAlphaPremultiplied - true如果颜色通道将被alpha通道预乘。
        结果
        一个 ImageTypeSpecifier具有所需的特性。
        异常
        IllegalArgumentException - 如果 colorSpace是 null 。
        IllegalArgumentException - 如果 colorSpace不是类型 TYPE_RGB 。
        IllegalArgumentException - 如果没有掩码至少设置1位。
        IllegalArgumentException -如果 transferType如果不是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或 DataBuffer.TYPE_INT 。

      • createInterleaved

        public static ImageTypeSpecifier createInterleaved​(ColorSpace colorSpace,
                                                   int[] bandOffsets,
                                                   int dataType,
                                                   boolean hasAlpha,
                                                   boolean isAlphaPremultiplied)
        返回用于交错图像格式的说明符，将使用 ComponentColorModel和 PixelInterleavedSampleModel将每个像素组件存储在单独的字节，短或int中。
        参数
        colorSpace - 所需的 ColorSpace 。
        bandOffsets - 表示每个频带的偏移的 int的阵列。
        dataType - 所需的数据类型，作为 DataBuffer类的枚举之一。
        如果需要alpha通道，则为 hasAlpha - true 。
        isAlphaPremultiplied - true如果颜色通道将被alpha通道预乘。
        结果
        一个 ImageTypeSpecifier具有所需的特性。
        异常
        IllegalArgumentException - 如果 colorSpace是 null 。
        IllegalArgumentException - 如果 bandOffsets是 null 。
        IllegalArgumentException - 如果 dataType不是合法的 DataBuffer.TYPE_*常量之一。
        IllegalArgumentException - 如果 bandOffsets.length不等于颜色空间分量的数量，如果 hasAlpha为 true ，则加1。

      • createBanded

        public static ImageTypeSpecifier createBanded​(ColorSpace colorSpace,
                                              int[] bankIndices,
                                              int[] bandOffsets,
                                              int dataType,
                                              boolean hasAlpha,
                                              boolean isAlphaPremultiplied)
        返回带状图像格式的说明符，将使用 ComponentColorModel和 BandedSampleModel将每个通道存储在单独的阵列中。
        参数
        colorSpace - 所需的 ColorSpace 。
        bankIndices - 表示存储每个频带的存储体的阵列 int s。
        bandOffsets - int s的数组，表示其银行中每个频带的起始偏移量。
        dataType - 所需的数据类型，作为 DataBuffer类中的枚举之一。
        如果需要alpha通道，则为 hasAlpha - true 。
        isAlphaPremultiplied - true如果颜色通道将被alpha通道预乘。
        结果
        一个 ImageTypeSpecifier具有所需的特性。
        异常
        IllegalArgumentException - 如果 colorSpace是 null 。
        IllegalArgumentException - 如果 bankIndices是 null 。
        IllegalArgumentException - 如果 bandOffsets是 null 。
        IllegalArgumentException - 如果 bankIndices和 bandOffsets的长度不同。
        IllegalArgumentException - 如果 bandOffsets.length不等于颜色空间分量的数量，如果 hasAlpha为 true ，则加1。
        IllegalArgumentException - 如果 dataType不是合法的 DataBuffer.TYPE_*常数之一。

      • createGrayscale

        public static ImageTypeSpecifier createGrayscale​(int bits,
                                                 int dataType,
                                                 boolean isSigned)
        返回一个灰度图像格式的说明符，该格式将将给定位深度的像素包装为指定数据类型的数组元素。
        参数
        bits - 每个灰度值的位数（1,2,4,8或16）。
        dataType - 所需的数据类型，作为 DataBuffer类的枚举之一。
        如果要表示负值， isSigned - true 。
        结果
        一个 ImageTypeSpecifier具有所需的特点。
        异常
        IllegalArgumentException - 如果 bits不是1,2,4,8或16中的一个。
        IllegalArgumentException -如果 dataType不是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_SHORT ，或 DataBuffer.TYPE_USHORT 。
        IllegalArgumentException - 如果 bits大于给定的 dataType的位大小。

      • createGrayscale

        public static ImageTypeSpecifier createGrayscale​(int bits,
                                                 int dataType,
                                                 boolean isSigned,
                                                 boolean isAlphaPremultiplied)
        返回一个用于灰度加Alpha图像格式的说明符，它将给定位深度的像素包装为指定数据类型的数组元素。
        参数
        bits - 每个灰度值的位数（1,2,4,8或16）。
        dataType - 所需的数据类型，作为 DataBuffer类中的枚举之一。
        isSigned - true如果要表示负值。
        如果亮度通道将被alpha通道预乘，则 isAlphaPremultiplied - true 。
        结果
        一个 ImageTypeSpecifier具有所需的特性。
        异常
        IllegalArgumentException - 如果 bits不是1,2,4,8或16中的一个。
        IllegalArgumentException -如果 dataType不是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_SHORT ，或 DataBuffer.TYPE_USHORT 。
        IllegalArgumentException - 如果 bits大于给定的 dataType的位大小。

      • createIndexed

        public static ImageTypeSpecifier createIndexed​(byte[] redLUT,
                                               byte[] greenLUT,
                                               byte[] blueLUT,
                                               byte[] alphaLUT,
                                               int bits,
                                               int dataType)
        返回索引颜色图像格式的说明符，该格式将给定位深度的索引值包装为指定数据类型的数组元素。
        参数
        redLUT - 包含每个索引的红色值的 byte的数组。
        greenLUT -的阵列 byte含*每个索引的绿色值秒。
        blueLUT - 包含每个索引的蓝色值的 byte的数组。
        alphaLUT - 包含每个索引的alpha值的 byte的数组，或 null创建完全不透明的LUT。
        bits - 每个索引中的位数。
        dataType - 所需的输出类型，作为 DataBuffer类的枚举之一。
        结果
        一个 ImageTypeSpecifier具有所需的特性。
        异常
        IllegalArgumentException - 如果 redLUT是 null 。
        IllegalArgumentException - 如果 greenLUT是 null 。
        IllegalArgumentException - 如果 blueLUT是 null 。
        IllegalArgumentException - 如果 bits不是1,2,4,8或16中的一个。
        IllegalArgumentException - 如果非 null LUT参数的长度不完全为 1 << bits 。
        IllegalArgumentException -如果 dataType不是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_USHORT ，或 DataBuffer.TYPE_INT 。
        IllegalArgumentException - 如果 bits大于给定的 dataType的位大小。

      • createFromBufferedImageType

        public static ImageTypeSpecifier createFromBufferedImageType​(int bufferedImageType)
        返回一个 ImageTypeSpecifier ，它编码一个标准的 BufferedImage类型（ TYPE_CUSTOM ）。
        参数
        bufferedImageType - 表示标准 BufferedImage类型之一的int。
        结果
        一个 ImageTypeSpecifier具有所需的特性。
        异常
        IllegalArgumentException - 如果 bufferedImageType不是标准类型之一，或者等于 TYPE_CUSTOM 。
        另请参见：
        BufferedImage ， BufferedImage.TYPE_INT_RGB ， BufferedImage.TYPE_INT_ARGB ， BufferedImage.TYPE_INT_ARGB_PRE ， BufferedImage.TYPE_INT_BGR ， BufferedImage.TYPE_3BYTE_BGR ， BufferedImage.TYPE_4BYTE_ABGR ， BufferedImage.TYPE_4BYTE_ABGR_PRE ， BufferedImage.TYPE_USHORT_565_RGB ， BufferedImage.TYPE_USHORT_555_RGB ， BufferedImage.TYPE_BYTE_GRAY ， BufferedImage.TYPE_USHORT_GRAY ， BufferedImage.TYPE_BYTE_BINARY ， BufferedImage.TYPE_BYTE_INDEXED

      • createFromRenderedImage

        public static ImageTypeSpecifier createFromRenderedImage​(RenderedImage image)
        返回一个 ImageTypeSpecifier编码的布局 RenderedImage （其可以是 BufferedImage ）。
        参数
        image - a RenderedImage 。
        结果
        一个 ImageTypeSpecifier具有所需的特性。
        异常
        IllegalArgumentException - 如果 image是 null 。

      • getBufferedImageType

        public int getBufferedImageType​()
        返回一个包含从 BufferedImage描述图像格式的枚举常数值的 BufferedImage 。
        结果
        一个 int代表 BufferedImage类型。
        另请参见：
        BufferedImage ， BufferedImage.TYPE_CUSTOM ， BufferedImage.TYPE_INT_RGB ， BufferedImage.TYPE_INT_ARGB ， BufferedImage.TYPE_INT_ARGB_PRE ， BufferedImage.TYPE_INT_BGR ， BufferedImage.TYPE_3BYTE_BGR ， BufferedImage.TYPE_4BYTE_ABGR ， BufferedImage.TYPE_4BYTE_ABGR_PRE ， BufferedImage.TYPE_USHORT_565_RGB ， BufferedImage.TYPE_USHORT_555_RGB ， BufferedImage.TYPE_BYTE_GRAY ， BufferedImage.TYPE_USHORT_GRAY ， BufferedImage.TYPE_BYTE_BINARY ， BufferedImage.TYPE_BYTE_INDEXED

      • getNumComponents

        public int getNumComponents​()
        返回此对象指定的颜色成分数。 这是与ColorModel.getNumComponents返回的值相同的值
        结果
        图像中的组件数量。

      • getNumBands

        public int getNumBands​()
        返回此对象指定的频带数。 这是与SampleModel.getNumBands返回的值相同的值
        结果
        图像中的乐队数量。

      • getBitsPerBand

        public int getBitsPerBand​(int band)
        返回用于表示给定波段的样本的位数。
        参数
        band - 要查询的乐队的索引，作为int。
        结果
        一个指定位数的int。
        异常
        IllegalArgumentException - 如果 band为负数或大于最大频带指数。

      • getSampleModel

        public SampleModel getSampleModel​()
        根据封装在此对象内的设置，返回SampleModel 。 SampleModel的宽度和高度将被设置为任意值。
        结果
        一个 SampleModel具有任意维度。

      • getSampleModel

        public SampleModel getSampleModel​(int width,
                                  int height)
        根据封装在此对象内的设置，返回一个SampleModel 。 SampleModel的宽度和高度将被设置为提供的值。
        参数
        width - 返回的所需宽度 SampleModel 。
        height - 所需的高度为 SampleModel 。
        结果
        一个给定尺寸的 SampleModel 。
        异常
        IllegalArgumentException - 如果 width或 height为负数或零。
        IllegalArgumentException - 如果 width和 height的产品大于 Integer.MAX_VALUE

      • getColorModel

        public ColorModel getColorModel​()
        返回此对象指定的 ColorModel 。
        结果
        一个 ColorModel 。

      • createBufferedImage

        public BufferedImage createBufferedImage​(int width,
                                         int height)
        根据此对象中体现的规范，创建一个给定宽度和高度的 BufferedImage 。
        参数
        width - 返回的所需宽度 BufferedImage 。
        height - 所需的高度返回的 BufferedImage 。
        结果
        一个新的 BufferedImage
        异常
        IllegalArgumentException - 如果 width或 height为负数或零。
        IllegalArgumentException - 如果 width和 height的产品大于 Integer.MAX_VALUE ，或者如果存储图像所需的数组元素数大于 Integer.MAX_VALUE 。

      • equals

        public boolean equals​(Object o)
        如果给定的 Object是 ImageTypeSpecifier并且具有与该对象相同的 SampleModel和 ColorModel ，则返回 true 。
        重写：
        equals在 Object
        参数
        o - 要平等比较的 Object 。
        结果
        true如果给定的对象是等效的 ImageTypeSpecifier 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此ImageTypeSpecifier的哈希码。
        重写：
        hashCode在 Object
        结果
        此ImageTypeSpecifier的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageWriteParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Class ImageWriteParam

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageWriteParam
  • 已知直接子类：
    BMPImageWriteParam ， JPEGImageWriteParam

    public class ImageWriteParam
extends IIOParam
    描述流如何编码的类。 该类或其子类的实例用于向ImageWriter实例提供规定的“how-to”信息。

    用于特定图像格式的插件可以定义该类的子类，并从其ImageWriter实现的getDefaultWriteParam方法返回该类的对象。 例如，内置的JPEG writer插件将返回javax.imageio.plugins.jpeg.JPEGImageWriteParam实例。

    要写入的图像的区域由首先将图像的实际边界与由IIOParam.setSourceRegion指定的矩形IIOParam.setSourceRegion （如果有的话）确定。 如果生成的矩形的宽度或高度为零，作者将抛出一个IIOException 。 如果交集不为空，则写入将从第一个子采样像素开始，并根据IIOParam.setSourceSubsampling指定的水平和垂直子采样因子在相交的边界内包含附加像素。

    可以在四种模式之一中设置诸如平铺，逐行编码和压缩的各种特征。 MODE_DISABLED禁用功能; MODE_DEFAULT启用具有写入控制参数值的功能; MODE_EXPLICIT启用该功能并允许使用set方法提供其他参数; 和MODE_COPY_FROM_METADATA从传递给作者的流和图像元数据对象复制相关参数值。 所有功能的默认值为MODE_COPY_FROM_METADATA 。 鼓励在子类中提供的非标准功能，但不需要使用类似的方案。

    插件编写者可以通过提供实现附加的插件特定接口的子类来扩展ImageWriteParam的功能。 插件可以记录哪些接口可用，以及如何使用它们。 作家将默认忽略他们不知道的ImageWriteParam子类的任何扩展功能。 此外，他们可能忽略通过getDefaultWriteParam创建自己的ImageWriteParam实例时通常禁用的任何可选功能。

    请注意，除非存在某种功能的查询方法，否则必须由所有ImageWriter实现支持（ 例如逐行编码是可选的，但必须支持子采样）。

    另请参见：
    ImageReadParam

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected boolean canOffsetTiles
      A boolean是 true如果这个 ImageWriteParam允许设置平铺网格偏移参数。
      protected boolean canWriteCompressed
      A boolean是 true如果这个作者可以使用压缩编写图像。
      protected boolean canWriteProgressive
      A boolean是 true如果这个 ImageWriteParam允许图像被写入逐渐增加的质量通行序列。
      protected boolean canWriteTiles
      A boolean是 true如果这个 ImageWriteParam允许设置瓦片宽度和瓦片高度参数。
      protected int compressionMode
      模式控制压缩设置，必须将其设置为四个 MODE_* 。
      protected float compressionQuality
      A float包含当前的压缩质量设置。
      protected String compressionType
      A String包含当前压缩类型的名称，如果没有设置， null 。
      protected String[] compressionTypes
      一个包含可用压缩类型名称的 String的数组。
      protected Locale locale
      A Locale用于本地化压缩类型名称和质量描述，或 null使用默认值 Locale 。
      static int MODE_COPY_FROM_METADATA
      可通入的方法，如恒定值 setTilingMode ， setProgressiveMode ，或 setCompressionMode以启用该功能用于以后的写入。
      static int MODE_DEFAULT
      可通入的方法，如恒定值 setTilingMode ， setProgressiveMode和 setCompressionMode启用该功能用于以后的写入。
      static int MODE_DISABLED
      可以传递给诸如 setProgressiveMode和 setCompressionMode方法的 setTilingMode setProgressiveMode ，以禁用将来写入的特征。
      static int MODE_EXPLICIT
      可以传递给诸如 setTilingMode或 setCompressionMode方法的常量值，以启用未来写入的功能。
      protected Dimension[] preferredTileSizes
      一组优选的瓷砖尺寸范围对。
      protected int progressiveMode
      控制逐行编码的模式，必须设置为四个 MODE_*值之一，除了 MODE_EXPLICIT 。
      protected int tileGridXOffset
      如果已经设置了平铺，则瓦片网格原点应从图像原点水平偏移，否则为0。
      protected int tileGridYOffset
      如果平铺已设置，则瓦片网格原点应与图像原点垂直偏移，否则为0。
      protected int tileHeight
      每个瓦片的高度如果平铺已设置，否则为0。
      protected int tileWidth
      每个瓦片的宽度如果已经设置了平铺，否则为0。
      protected int tilingMode
      模式控制平铺设置，其中必须设置为四个 MODE_*值之一。
      protected boolean tilingSet
      A boolean ，如果已经指定了平铺参数，则为 true 。

      • Fields inherited from class javax.imageio.IIOParam

        controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ImageWriteParam​()
      构造一个空的 ImageWriteParam 。
        ImageWriteParam​(Locale locale)
      构造一个 ImageWriteParam集使用给定的 Locale 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean canOffsetTiles​()
      如果作者在写入时可以执行非零网格偏移的平铺，则返回 true 。
      boolean canWriteCompressed​()
      如果此作者支持压缩，则返回 true 。
      boolean canWriteProgressive​()
      返回 true如果作者可以将图像写成一系列逐渐提高质量的通行证。
      boolean canWriteTiles​()
      如果作家在写作时可以执行平铺，则返回 true 。
      float getBitRate​(float quality)
      返回 float指示在给定质量水平的输入图像数据的每个位的输出数据的位数的估计。
      int getCompressionMode​()
      如果支持压缩，则返回当前压缩模式。
      float getCompressionQuality​()
      返回当前的压缩质量设置。
      String[] getCompressionQualityDescriptions​()
      返回 String的数组，可以与 getCompressionQualityValues一起使用，作为设置或显示压缩质量等级的用户界面的一部分。
      float[] getCompressionQualityValues​()
      返回 float s的数组，可以与 getCompressionQualityDescriptions一起使用，作为设置或显示压缩质量级别的用户界面的一部分。
      String getCompressionType​()
      返回当前设置的压缩类型，如果没有设置，则返回 null 。
      String[] getCompressionTypes​()
      返回一个可用的压缩类型列表，如数组或 String s，或 null如果可能不使用这些接口选择压缩类型。
      Locale getLocale​()
      如果仅支持默认值 Locale则返回当前设置的 Locale或 null 。
      String getLocalizedCompressionTypeName​()
      返回当前压缩类型名称的本地化版本，使用 Locale通过返回 getLocale 。
      Dimension[] getPreferredTileSizes​()
      返回一个 Dimension s的数组，表示图块的合法尺寸范围，因为它们将被编码在输出文件或流中。
      int getProgressiveMode​()
      返回以逐行方式写入流的当前模式。
      int getTileGridXOffset​()
      返回图像的水平瓦片网格偏移，因为它将被写入输出流。
      int getTileGridYOffset​()
      返回图像的垂直瓦片网格偏移，因为它将被写入输出流。
      int getTileHeight​()
      返回图像中每个图块的高度，因为它将被写入输出流。
      int getTileWidth​()
      返回图像中每个图块的宽度，因为它将被写入输出流。
      int getTilingMode​()
      如果支持平铺，返回当前的平铺模式。
      boolean isCompressionLossless​()
      如果当前压缩类型提供无损压缩，则返回 true 。
      void setCompressionMode​(int mode)
      指定是否执行压缩，如果需要确定压缩参数。
      void setCompressionQuality​(float quality)
      将压缩质量设置为 0和 1之间的值。
      void setCompressionType​(String compressionType)
      将压缩类型设置为 getCompressionTypes指示的值 getCompressionTypes 。
      void setProgressiveMode​(int mode)
      指定写入器将以逐行模式写入图像，以使流包含一系列增加质量的扫描。
      void setTiling​(int tileWidth, int tileHeight, int tileGridXOffset, int tileGridYOffset)
      指定图像应该平铺在输出流中。
      void setTilingMode​(int mode)
      确定图像是否将平铺在输出流中，如果是，将确定平铺参数的确定方式。
      void unsetCompression​()
      删除任何以前的压缩类型和质量设置。
      void unsetTiling​()
      删除通过调用 setTiling指定的任何以前的瓦片网格参数。

      • Methods inherited from class javax.imageio.IIOParam

        activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setDestinationType, setSourceBands, setSourceRegion, setSourceSubsampling

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • MODE_DISABLED

        public static final int MODE_DISABLED
        可通入的方法，如恒定值setTilingMode ， setProgressiveMode和setCompressionMode到用于以后的写入禁用的特征。 也就是说，当设置此模式时，流将不会被平铺，渐进或压缩，相关的访问器方法将抛出一个IllegalStateException 。
        另请参见：
        MODE_EXPLICIT ， MODE_COPY_FROM_METADATA ， MODE_DEFAULT ， setProgressiveMode(int) ， getProgressiveMode() ， setTilingMode(int) ， getTilingMode() ， setCompressionMode(int) ， getCompressionMode() ， Constant Field Values

      • MODE_DEFAULT

        public static final int MODE_DEFAULT
        可通入的方法，如恒定值setTilingMode ， setProgressiveMode和setCompressionMode启用该功能用于以后的写入。 也就是说，当启用此模式时，流将按照插件依赖方式由作者内部选择的合理默认进行平铺，渐进或压缩，相关的访问者方法将会抛出一个IllegalStateException 。
        另请参见：
        MODE_DISABLED ， MODE_EXPLICIT ， MODE_COPY_FROM_METADATA ， setProgressiveMode(int) ， getProgressiveMode() ， setTilingMode(int) ， getTilingMode() ， setCompressionMode(int) ， getCompressionMode() ， Constant Field Values

      • MODE_EXPLICIT

        public static final int MODE_EXPLICIT
        可以传递给诸如setTilingMode或setCompressionMode方法的常数值，以使能够用于将来写入的特征。 也就是说，当设置此模式时，流将根据提供给set中相应的set方法的附加信息进行平铺或压缩，并从相应的get方法中检索。 请注意，逐行输出不支持此模式。
        另请参见：
        MODE_DISABLED ， MODE_COPY_FROM_METADATA ， MODE_DEFAULT ， setProgressiveMode(int) ， getProgressiveMode() ， setTilingMode(int) ， getTilingMode() ， setCompressionMode(int) ， getCompressionMode() ， Constant Field Values

      • MODE_COPY_FROM_METADATA

        public static final int MODE_COPY_FROM_METADATA
        可通入的方法，如恒定值setTilingMode ， setProgressiveMode ，或setCompressionMode以启用该功能用于以后的写入。 也就是说，当启用此模式时，流将被平铺，渐进或压缩，基于传入到写入操作中的流和/或图像元数据的内容，并且任何相关的访问器方法将抛出一个IllegalStateException 。

        这是所有功能的默认模式，因此包括元数据在内的读取（包括元数据）的读取将尽可能保留尽可能多的信息。

        另请参见：
        MODE_DISABLED ， MODE_EXPLICIT ， MODE_DEFAULT ， setProgressiveMode(int) ， getProgressiveMode() ， setTilingMode(int) ， getTilingMode() ， setCompressionMode(int) ， getCompressionMode() ， Constant Field Values

      • canWriteTiles

        protected boolean canWriteTiles
        A boolean是true如果这个ImageWriteParam允许设置瓦片宽度和瓦片高度参数。 默认值为false 。 子类必须手动设置该值。

        不支持写入false贴的子类应确保此值设置为false 。

      • tilingMode

        protected int tilingMode
        该模式控制平铺设置，其中必须设置为四个MODE_* 。 默认值为MODE_COPY_FROM_METADATA 。

        不写图块的子类可能会忽略此值。

        另请参见：
        MODE_DISABLED ， MODE_EXPLICIT ， MODE_COPY_FROM_METADATA ， MODE_DEFAULT ， setTilingMode(int) ， getTilingMode()

      • preferredTileSizes

        protected Dimension[] preferredTileSizes
        一组优选的瓷砖尺寸范围对。 默认值为null ，表示没有首选尺寸。 如果值不是null ，则它的长度必须至少为2。

        不支持写图块的子类可能会忽略此值。

        另请参见：
        getPreferredTileSizes()

      • tilingSet

        protected boolean tilingSet
        A boolean如果已经指定了平铺参数，则为true 。

        不支持写图块的子类可能会忽略此值。

      • tileWidth

        protected int tileWidth
        每个瓦片的宽度如果已经设置了平铺，否则为0。

        不支持平铺的子类可能忽略此值。

      • tileHeight

        protected int tileHeight
        每个瓦片的高度如果平铺已设置，否则为0。 初始值为0 。

        不支持平铺的子类可能忽略此值。

      • canOffsetTiles

        protected boolean canOffsetTiles
        A boolean是true如果这个ImageWriteParam允许设置平铺网格偏移参数。 默认值为false 。 子类必须手动设置该值。

        不支持编写图块的子类，或支持写入但不支持拼贴的子类必须确保将此值设置为false 。

      • tileGridXOffset

        protected int tileGridXOffset
        如果已经设置了平铺，则瓦片网格原点应从图像原点水平偏移，否则为0。 初始值为0 。

        不支持偏移图块的子类可能忽略此值。

      • tileGridYOffset

        protected int tileGridYOffset
        如果平铺已设置，则瓦片网格原点应与图像原点垂直偏移，否则为0。 初始值为0 。

        不支持偏移图块的子类可能忽略此值。

      • canWriteProgressive

        protected boolean canWriteProgressive
        A boolean是true如果这个ImageWriteParam允许图像被写入作为逐渐增加的质量通行序列。 默认值为false 。 子类必须手动设置该值。

        不支持逐行编码的子类必须确保此值设置为false 。

      • progressiveMode

        protected int progressiveMode
        控制逐行编码的模式，必须设置为四个MODE_* ，除了MODE_EXPLICIT 。 默认值为MODE_COPY_FROM_METADATA 。

        不支持逐行编码的子类可能忽略此值。

        另请参见：
        MODE_DISABLED ， MODE_EXPLICIT ， MODE_COPY_FROM_METADATA ， MODE_DEFAULT ， setProgressiveMode(int) ， getProgressiveMode()

      • canWriteCompressed

        protected boolean canWriteCompressed
        A boolean是true如果这个作者可以使用压缩书写图像。 默认值为false 。 子类必须手动设置该值。

        不支持压缩的子类必须确保此值设置为false 。

      • compressionMode

        protected int compressionMode
        模式控制压缩设置，必须将其设置为四个MODE_*值。 默认值为MODE_COPY_FROM_METADATA 。

        不支持压缩的子类可能忽略此值。

        另请参见：
        MODE_DISABLED ， MODE_EXPLICIT ， MODE_COPY_FROM_METADATA ， MODE_DEFAULT ， setCompressionMode(int) ， getCompressionMode()

      • compressionTypes

        protected String[] compressionTypes
        String的数组包含可用压缩类型的名称。 子类必须手动设置该值。

        不支持压缩的子类可能忽略此值。

      • compressionType

        protected String compressionType
        A String包含当前压缩类型的名称，如果没有设置， null 。

        不支持压缩的子类可能忽略此值。

      • compressionQuality

        protected float compressionQuality
        A float包含当前的压缩质量设置。 初始值为1.0F 。

        不支持压缩的子类可能忽略此值。

      • locale

        protected Locale locale
        A Locale用于本地化压缩类型名称和质量描述，或null使用默认值Locale 。 子类必须手动设置该值。

    • 构造方法详细信息

      • ImageWriteParam

        protected ImageWriteParam​()
        构造一个空的ImageWriteParam 。 子类可以正确设置实例变量。

      • ImageWriteParam

        public ImageWriteParam​(Locale locale)
        构造一个 ImageWriteParam集使用给定的 Locale 。
        参数
        locale -一个 Locale使用本地化压缩类型名称和质量描述，或 null 。

    • 方法详细信息

      • getLocale

        public Locale getLocale​()
        如果仅支持默认值 Locale则返回当前设置的 Locale或 null 。
        结果
        目前为 Locale ，或 null 。

      • canWriteTiles

        public boolean canWriteTiles​()
        如果作家在写作时可以执行true则返回true 。 如果这个方法返回false ，那么setTiling会抛出一个UnsupportedOperationException 。
        结果
        true如果作者支持平铺。
        另请参见：
        canOffsetTiles() ， setTiling(int, int, int, int)

      • canOffsetTiles

        public boolean canOffsetTiles​()
        如果作者在写入时可以执行非零网格偏移的平铺，则返回true 。 如果此方法返回false ，则setTiling将抛出一个UnsupportedOperationException如果网格偏移参数不为零。 如果canWriteTiles返回false ，此方法也将返回false 。
        结果
        true如果作者支持非零瓦片偏移。
        另请参见：
        canWriteTiles() ， setTiling(int, int, int, int)

      • setTilingMode

        public void setTilingMode​(int mode)
        确定图像是否将平铺在输出流中，如果是，将确定平铺参数的确定方式。 模式解释如下：
        • MODE_DISABLED - 图像不会被平铺。 setTiling将会抛出一个IllegalStateException 。
        • MODE_DEFAULT - 图像将使用默认参数进行平铺。 setTiling会抛出一个IllegalStateException 。
        • MODE_EXPLICIT - 图像将按照setTiling中给出的参数进行平铺。 任何先前设置的平铺参数都将被丢弃。
        • MODE_COPY_FROM_METADATA - 图像将符合传入到写入的元数据对象。 setTiling会抛出一个IllegalStateException 。
        参数
        mode - 用于平铺的模式。
        异常
        UnsupportedOperationException - 如果 canWriteTiles返回 false 。
        IllegalArgumentException - 如果 mode不是上面列出的一种模式。
        另请参见：
        setTiling(int, int, int, int) ， getTilingMode()

      • getTilingMode

        public int getTilingMode​()
        如果支持平铺，返回当前的平铺模式。 否则会抛出一个UnsupportedOperationException 。
        结果
        当前的平铺模式。
        异常
        UnsupportedOperationException - 如果 canWriteTiles返回 false 。
        另请参见：
        setTilingMode(int)

      • getPreferredTileSizes

        public Dimension[] getPreferredTileSizes​()
        返回一个Dimension s的数组，表示瓦片的合法尺寸范围，因为它们将被编码在输出文件或流中。 返回的数组是一个副本。

        信息作为一组对返回; 一对的第一个元素包含（包括）最小宽度和高度，第二个元素包含（包含）最大宽度和高度。 在一起，每对都定义了一个有效的大小范围。 要指定固定的大小，请对两个元素使用相同的宽度和高度。 要指定任意范围，使用值null代替Dimension的实际数组。

        如果在构造函数中没有指定数组，但是允许平铺，那么此方法将返回null 。

        结果
        Dimension的阵列至少有两个，即 null 。
        异常
        UnsupportedOperationException - 如果插件不支持 UnsupportedOperationException 。

      • setTiling

        public void setTiling​(int tileWidth,
                      int tileHeight,
                      int tileGridXOffset,
                      int tileGridYOffset)
        指定图像应该平铺在输出流中。 tileWidth和tileHeight参数指定文件中图块的宽度和高度。 如果图块宽度或高度大于图像的宽度或高度，则图像不会在该维度中平铺。

        如果canOffsetTiles返回false ，则tileGridXOffset和tileGridYOffset参数必须为零。

        参数
        tileWidth - 每个瓷砖的宽度。
        tileHeight - 每个瓷砖的高度。
        tileGridXOffset - 瓦片网格的水平偏移。
        tileGridYOffset - 瓦片网格的垂直偏移。
        异常
        UnsupportedOperationException - 如果插件不支持平铺。
        IllegalStateException - 如果平铺模式不是 MODE_EXPLICIT 。
        UnsupportedOperationException - 如果插件不支持网格偏移，并且网格偏移量不为零。
        IllegalArgumentException - 如果瓷砖尺寸不在 getPreferredTileSizes返回的允许范围之内。
        IllegalArgumentException - 如果 tileWidth或 tileHeight小于或等于0。
        另请参见：
        canWriteTiles ，
canOffsetTiles ，
getTileWidth() ，
getTileHeight() ，
getTileGridXOffset() ，
getTileGridYOffset()

      • unsetTiling

        public void unsetTiling​()
        删除通过调用setTiling指定的任何以前的瓦片网格参数。

        默认实现将实例变量tileWidth ， tileHeight ， tileGridXOffset ，并tileGridYOffset至0 。

        异常
        UnsupportedOperationException - 如果插件不支持 UnsupportedOperationException 。
        IllegalStateException - 如果平铺模式不是 MODE_EXPLICIT 。
        另请参见：
        setTiling(int, int, int, int)

      • getTileWidth

        public int getTileWidth​()
        返回图像中每个图块的宽度，因为它将被写入输出流。 如果未设置平铺参数，则抛出IllegalStateException 。
        结果
        要用于编码的瓦片宽度。
        异常
        UnsupportedOperationException - 如果插件不支持 UnsupportedOperationException 。
        IllegalStateException - 如果平铺模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果平铺参数尚未设置。
        另请参见：
        setTiling(int, int, int, int) ， getTileHeight()

      • getTileHeight

        public int getTileHeight​()
        返回图像中每个图块的高度，因为它将被写入输出流。 如果未设置平铺参数，则抛出IllegalStateException 。
        结果
        要用于编码的瓦片高度。
        异常
        UnsupportedOperationException - 如果插件不支持平铺。
        IllegalStateException - 如果平铺模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果平铺参数尚未设置。
        另请参见：
        setTiling(int, int, int, int) ， getTileWidth()

      • getTileGridXOffset

        public int getTileGridXOffset​()
        返回图像的水平瓦片网格偏移，因为它将被写入输出流。 如果未设置平铺参数，则抛出IllegalStateException 。
        结果
        瓦片网格X偏移量用于编码。
        异常
        UnsupportedOperationException - 如果插件不支持 UnsupportedOperationException 。
        IllegalStateException - 如果平铺模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果平铺参数尚未设置。
        另请参见：
        setTiling(int, int, int, int) ， getTileGridYOffset()

      • getTileGridYOffset

        public int getTileGridYOffset​()
        返回图像的垂直瓦片网格偏移，因为它将被写入输出流。 如果未设置平铺参数，则抛出IllegalStateException 。
        结果
        瓦片网格Y偏移量用于编码。
        异常
        UnsupportedOperationException - 如果插件不支持 UnsupportedOperationException 。
        IllegalStateException - 如果平铺模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果平铺参数尚未设置。
        另请参见：
        setTiling(int, int, int, int) ， getTileGridXOffset()

      • canWriteProgressive

        public boolean canWriteProgressive​()
        返回 true如果作者可以将图像作为逐渐增加的质量的一系列通过书写出来。
        结果
        true如果作者支持逐行编码。
        另请参见：
        setProgressiveMode(int) ， getProgressiveMode()

      • setProgressiveMode

        public void setProgressiveMode​(int mode)
        指定写入器将以逐行模式写入图像，以使流包含一系列增加质量的扫描。 如果不支持渐进式编码，则会抛出UnsupportedOperationException 。

        模式参数确定如何选择progression参数，并且必须是MODE_DISABLED ， MODE_COPY_FROM_METADATA ，或MODE_DEFAULT 。 否则抛出一个IllegalArgumentException 。

        模式解释如下：

        • MODE_DISABLED - 无进展。 使用它来关闭进度。
        • MODE_COPY_FROM_METADATA - 输出图像将使用传入作者的元数据对象中发现的任何进度参数。
        • MODE_DEFAULT - 图像将逐步写入，并由作者选择参数。

        默认值为MODE_COPY_FROM_METADATA 。

        参数
        mode - 在输出流中设置进度的模式。
        异常
        UnsupportedOperationException - 如果作者不支持逐行编码。
        IllegalArgumentException - 如果 mode不是上面列出的一种模式。
        另请参见：
        getProgressiveMode()

      • getProgressiveMode

        public int getProgressiveMode​()
        返回以逐行方式写入流的当前模式。
        结果
        逐行编码的当前模式。
        异常
        UnsupportedOperationException - 如果作者不支持逐行编码。
        另请参见：
        setProgressiveMode(int)

      • canWriteCompressed

        public boolean canWriteCompressed​()
        如果此作者支持压缩，则返回 true 。
        结果
        true如果作者支持压缩。

      • setCompressionMode

        public void setCompressionMode​(int mode)
        指定是否执行压缩，如果需要确定压缩参数。 mode参数必须是四种模式之一，解释如下：
        • MODE_DISABLED - 如果模式设置为MODE_DISABLED ，查询或修改压缩类型或参数的方法将抛出IllegalStateException （如果插件通常支持压缩）。 一些作者，例如JPEG，通常不提供未压缩的输出。 在这种情况下，尝试将模式设置为MODE_DISABLED将会抛出一个UnsupportedOperationException并且不会改变模式。
        • MODE_EXPLICIT - 使用此ImageWriteParam指定的压缩类型和质量设置进行压缩。 任何先前设置的压缩参数都被丢弃。
        • MODE_COPY_FROM_METADATA - 使用传入到作者的元数据对象中指定的任何压缩参数。
        • MODE_DEFAULT - 使用默认压缩参数。

        默认值为MODE_COPY_FROM_METADATA 。

        参数
        mode - 在输出流中设置压缩的模式。
        异常
        UnsupportedOperationException - 如果写入程序不支持压缩，或者不支持请求的模式。
        IllegalArgumentException - 如果 mode不是上面列出的一种模式。
        另请参见：
        getCompressionMode()

      • getCompressionMode

        public int getCompressionMode​()
        如果支持压缩，则返回当前压缩模式。
        结果
        当前压缩模式。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        另请参见：
        setCompressionMode(int)

      • getCompressionTypes

        public String[] getCompressionTypes​()
        返回可用压缩类型的列表，如数组或String s或null如果可能无法使用这些接口选择压缩类型。 返回的数组是一个副本。

        如果作者仅提供单一的强制性压缩形式，则不需要提供任何命名的压缩类型。 命名的压缩类型只能在用户能够在不同方案之间进行有意义的选择的地方使用。

        默认实现检查是否支持压缩，如果不支持， UnsupportedOperationException抛出UnsupportedOperationException 。 否则，如果它是非null ，则返回一个compressionTypes实例变量的克隆，否则返回null 。

        结果
        String的数组包含（非本地化）可用压缩类型的名称，或 null 。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。

      • setCompressionType

        public void setCompressionType​(String compressionType)
        将压缩类型设置为getCompressionTypes指示的值getCompressionTypes 。 如果传入值为null ，则删除任何先前的设置。

        默认实现检查压缩是否受支持，压缩模式是否为MODE_EXPLICIT 。 如果是这样，它调用getCompressionTypes并检查是否compressionType是合法值之一。 如果是，则设置compressionType实例变量。 如果compressionType为null ，则不执行任何检查，将设置实例变量。

        参数
        compressionType -一个的 String通过返回小号 getCompressionTypes ，或 null ，以消除任何先前的设置。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        UnsupportedOperationException - 如果没有可设置的压缩类型。
        IllegalArgumentException - 如果 compressionType是非 null但不是由 getCompressionTypes返回的值 getCompressionTypes 。
        另请参见：
        getCompressionTypes() ，
getCompressionType() ，
unsetCompression()

      • getCompressionType

        public String getCompressionType​()
        返回当前设置的压缩类型，如果没有设置，则返回null 。 从String返回的类型中返回getCompressionTypes 。 如果没有设置压缩类型，则返回null 。

        默认实现检查压缩是否受支持，压缩模式是否为MODE_EXPLICIT 。 如果是，则返回compressionType实例变量的值。

        结果
        当前压缩类型为 String ，如果没有设置类型， null 。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        另请参见：
        setCompressionType(java.lang.String)

      • unsetCompression

        public void unsetCompression​()
        删除任何以前的压缩类型和质量设置。

        默认实现将实例变量compressionType为null ，实例变量compressionQuality为1.0F 。

        异常
        UnsupportedOperationException - 如果插件不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        另请参见：
        setCompressionType(java.lang.String) ， setCompressionQuality(float)

      • getLocalizedCompressionTypeName

        public String getLocalizedCompressionTypeName​()
        返回当前压缩类型名称的本地化版本，使用Locale通过返回getLocale 。

        默认实现检查压缩是否受支持，压缩模式是否为MODE_EXPLICIT 。 如果是，如果compressionType是non-null ，那么返回的值是getCompressionType 。

        结果
        一个 String包含当前压缩类型的名称的本地化版本。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果没有设置压缩类型。

      • isCompressionLossless

        public boolean isCompressionLossless​()
        如果当前压缩类型提供无损压缩，则返回true 。 如果插件仅提供一种强制性的压缩类型，则可以先调用此方法，而不setCompressionType调用setCompressionType 。

        如果有多种压缩类型，但没有设置，则抛出IllegalStateException 。

        默认实现检查是否支持压缩，压缩模式是MODE_EXPLICIT 。 如果是，如果getCompressionTypes()是null或getCompressionType()是非null true作为方便返回。

        结果
        true如果当前的压缩类型是无损的。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果一组合法的压缩类型是非 null ，当前的压缩类型是 null 。

      • setCompressionQuality

        public void setCompressionQuality​(float quality)
        将压缩质量设置为0和1之间的值。 默认情况下，仅支持单个压缩质量设置; 作者可以提供ImageWriteParam扩展版本，提供更多的控制。 对于有损压缩方案，压缩质量应该控制文件大小和图像质量之间的折衷（例如，通过在编写JPEG图像时选择量化表）。 对于无损方案，可以使用压缩质量来控制文件大小和执行压缩所花费的时间之间的折衷（例如，通过优化行过滤器并在编写PNG图像时设置ZLIB压缩级别）。

        0.0的压缩质量设置最通俗地解释为“高压缩是重要的”，而1.0的设置最通常被解释为“高图像质量很重要”。

        如果有多种压缩类型，但没有设置，则抛出IllegalStateException 。

        默认实现检查是否支持压缩，压缩模式为MODE_EXPLICIT 。 如果是，如果getCompressionTypes()返回null或compressionType是非null它设置的compressionQuality实例变量。

        参数
        quality -一个 float之间 0和 1指示期望的质量水平。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果一组法定压缩类型为非 null ，当前压缩类型为 null 。
        IllegalArgumentException - 如果 quality不在 0和 1之间，包括在内。
        另请参见：
        getCompressionQuality()

      • getCompressionQuality

        public float getCompressionQuality​()
        返回当前的压缩质量设置。

        如果有多种压缩类型，但没有设置，则抛出IllegalStateException 。

        默认实现检查压缩是否受支持，而压缩模式是MODE_EXPLICIT 。 如果是，如果getCompressionTypes()为null或getCompressionType()为非null ，则返回compressionQuality实例变量的值。

        结果
        当前的压缩质量设置。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果一组法定压缩类型为非 null ，当前压缩类型为 null 。
        另请参见：
        setCompressionQuality(float)

      • getBitRate

        public float getBitRate​(float quality)
        返回float指示在给定质量水平下每个输入图像数据位的输出数据的位数的估计。 该值通常在0和1之间，较小的值表示更多的压缩。 使用特殊值-1.0F表示没有可用的估计。

        如果有多种压缩类型，但没有设置，则抛出IllegalStateException 。

        默认实现检查压缩是否受支持，压缩模式是MODE_EXPLICIT 。 如果是，如果getCompressionTypes()是null或getCompressionType()是非null ，而quality是在界限内，则返回-1.0 。

        参数
        quality - 要查询比特率的质量设置。
        结果
        压缩比特率的估计，如果没有估计可用， -1.0F 。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果一组法定压缩类型是非 null ，当前的压缩类型是 null 。
        IllegalArgumentException - 如果 quality不在 0和 1之间，包括在内。

      • getCompressionQualityDescriptions

        public String[] getCompressionQualityDescriptions​()
        返回String s的数组，可以与getCompressionQualityValues一起使用，作为设置或显示压缩质量级别的用户界面的一部分。 所述String具有索引i提供质量水平之间的范围内的描述getCompressionQualityValues[i]和getCompressionQualityValues[i + 1] 。 需要注意的是阵列的长度从返回getCompressionQualityValues将始终是一个大于从返回getCompressionQualityDescriptions 。

        作为一个例子，字符串“好”，“较好”和“最佳”可与范围相关[0, .33) ， [.33, .66) ，并[.66, 1.0] 。 在这种情况下， getCompressionQualityDescriptions将返回{ "Good", "Better", "Best" }而getCompressionQualityValues将返回{ 0.0F, .33F, .66F, 1.0F } 。

        如果没有可用的描述，则返回null 。 如果null从返回getCompressionQualityValues ，这种方法也必须返回null 。

        这个说明应该是本地化的，由Locale返回的getLocale ，如果是非null 。

        如果有多种压缩类型，但没有设置， IllegalStateException抛出IllegalStateException 。

        默认实现检查压缩是否受支持，压缩模式是MODE_EXPLICIT 。 如果是，如果getCompressionTypes()是null或getCompressionType()是非null ，它返回null 。

        结果
        String的数组包含压缩质量等级的本地化描述。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果一组法定压缩类型是非 null ，当前的压缩类型是 null 。
        另请参见：
        getCompressionQualityValues()

      • getCompressionQualityValues

        public float[] getCompressionQualityValues​()
        返回float的数组，可以与getCompressionQualityDescriptions一起使用，作为设置或显示压缩质量等级的用户界面的一部分。 有关详细信息，请参阅getCompressionQualityDescriptions 。

        如果没有可用的描述，则返回null 。 如果null从返回getCompressionQualityDescriptions ，这种方法也必须返回null 。

        如果有多种压缩类型，但没有设置，则抛出IllegalStateException 。

        默认实现检查压缩是否受支持，而压缩模式是MODE_EXPLICIT 。 如果是，如果getCompressionTypes()是null或getCompressionType()是非null ，它返回null 。

        结果
        float s的阵列，表示 String的 getCompressionQualityDescriptions描述的压缩质量水平之间的边界。
        异常
        UnsupportedOperationException - 如果作者不支持压缩。
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        IllegalStateException - 如果一组法定压缩类型是非 null ，当前的压缩类型是 null 。
        另请参见：
        getCompressionQualityDescriptions()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio

Class ImageWriter

  • java.lang.Object
    • javax.imageio.ImageWriter
  • All Implemented Interfaces:
    ImageTranscoder

    public abstract class ImageWriter
extends Object
implements ImageTranscoder
    用于编码和写入图像的抽象超类。 该类必须由在Java Image I / O框架的上下文中写出图像的类子类化。

    ImageWriter对象通常由服务提供商类针对特定格式实例化。 服务提供商类已注册到IIORegistry ，它们用于格式识别和呈现可用格式的读者和作者。

    另请参见：
    ImageReader ， ImageWriteParam ， IIORegistry ， ImageWriterSpi

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Locale[] availableLocales
      可用于本地化警告消息和压缩设置值的 Locale s阵列，如果不支持本地化， null 。
      protected Locale locale
      目前 Locale用于定位，或 null ;如果没有设置。
      protected ImageWriterSpi originatingProvider
      该 ImageWriterSpi认为这个实例化对象，或者 null如果其身份未知或不存在。
      protected Object output
      所述 ImageOutputStream或其它 Object通过设置 setOutput ，并通过检索 getOutput 。
      protected List<IIOWriteProgressListener> progressListeners
      A List当前注册的 IIOWriteProgressListener s，默认初始化为 null ，这是一个空的 List代名词。
      protected List<IIOWriteWarningListener> warningListeners
      A List当前注册的 IIOWriteWarningListener s，默认初始化为 null ，这是一个空的 List代名词。
      protected List<Locale> warningLocales
      甲 List的 Locale S，一个用于的每个元素 warningListeners ，默认情况下初始化 null ，它与空同义 List 。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ImageWriter​(ImageWriterSpi originatingProvider)
      构造一个 ImageWriter并将其 originatingProvider实例变量设置为提供的值。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void abort​()
      请求中止任何当前的写入操作。
      protected boolean abortRequested​()
      返回 true是否已经作出中止当前写入操作的请求自从writer被实例化或 clearAbortRequest被调用。
      void addIIOWriteProgressListener​(IIOWriteProgressListener listener)
      在注册进度监听器列表中添加一个 IIOWriteProgressListener 。
      void addIIOWriteWarningListener​(IIOWriteWarningListener listener)
      将 IIOWriteWarningListener添加到已注册警告监听器的列表中。
      boolean canInsertEmpty​(int imageIndex)
      如果作者支持在给定索引处插入新的空的图像，则返回 true 。
      boolean canInsertImage​(int imageIndex)
      如果作者支持在给定索引处插入新图像，则返回 true 。
      boolean canRemoveImage​(int imageIndex)
      如果作者支持在给定索引处删除现有图像，则返回 true 。
      boolean canReplaceImageMetadata​(int imageIndex)
      返回 true ，如果它是可以替换与现有的图像与索引相关联的图像元数据 imageIndex 。
      boolean canReplacePixels​(int imageIndex)
      如果作者允许使用 replacePixels方法替换给定图像的像素，则返回 true 。
      boolean canReplaceStreamMetadata​()
      如果可以替换已经存在于输出中的流元数据，则返回 true 。
      boolean canWriteEmpty​()
      返回 true如果作者支持写入一个包含未定义像素值的单个图像的完整图像流，并将相关元数据和缩略图写入输出。
      boolean canWriteRasters​()
      返回 true如果采取方法 IIOImage参数能够与处理的 Raster （相对于 RenderedImage ）源图像。
      boolean canWriteSequence​()
      如果作者能够将图像附加到已经包含标题信息和可能的先前图像的图像流中，则返回 true 。
      protected void clearAbortRequest​()
      清除任何先前的中止请求。
      abstract IIOMetadata convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可使用其文档接口或特定于将用于编码的写入程序插件的其他接口进行可选修改。
      abstract IIOMetadata convertStreamMetadata​(IIOMetadata inData, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可使用其文档接口或特定于将用于编码的writer插件的其他接口进行可选修改。
      void dispose​()
      允许释放此对象持有的任何资源。
      void endInsertEmpty​()
      完成插入一个以前调用 prepareInsertEmpty开始的新映像。
      void endReplacePixels​()
      终止一系列调用 replacePixels 。
      void endWriteEmpty​()
      完成了以前致电 prepareWriteEmpty开始的新图像的写作。
      void endWriteSequence​()
      完成 prepareWriteSequence开始的一系列图像的写作。
      Locale[] getAvailableLocales​()
      返回可用于本地化警告侦听器和压缩设置的 Locale s的数组。
      abstract IIOMetadata getDefaultImageMetadata​(ImageTypeSpecifier imageType, ImageWriteParam param)
      返回一个包含用于对给定类型的图像进行编码的默认值的 IIOMetadata对象。
      abstract IIOMetadata getDefaultStreamMetadata​(ImageWriteParam param)
      返回一个包含用于编码图像流的默认值的 IIOMetadata对象。
      ImageWriteParam getDefaultWriteParam​()
      返回一个包含默认值的文件格式的适当类型的新的 ImageWriteParam对象，即，如果未指定 ImageWriteParam对象将使用的那些值。
      Locale getLocale​()
      如果没有设置，返回当前设置的 Locale ，或 null 。
      int getNumThumbnailsSupported​(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata)
      给定图像类型以及编码期间将要使用的任何其他写入参数和元数据对象，返回由正在写入的格式支持的缩略图数。
      ImageWriterSpi getOriginatingProvider​()
      返回 ImageWriterSpi创建此对象 ImageWriter ，或者 null如果这个对象不是通过创建 IIORegistry 。
      Object getOutput​()
      返回 ImageOutputStream或其他 Object由最近调用的 setOutput方法设置。
      Dimension[] getPreferredThumbnailSizes​(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata)
      返回 Dimension的数组，表示缩略图的合法大小范围，因为它们将被编码在输出文件或流中。
      void prepareInsertEmpty​(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将未定义像素值的新图像插入到现有图像流中。
      void prepareReplacePixels​(int imageIndex, Rectangle region)
      准备作者处理一系列对 replacePixels方法的调用。
      void prepareWriteEmpty​(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将一个完整的图像流写入到包含未定义像素值的单个图像和关联的元数据和缩略图中。
      void prepareWriteSequence​(IIOMetadata streamMetadata)
      使用提供的流元数据对象准备流以接受一系列后续的 writeToSequence调用。
      protected void processImageComplete​()
      通过调用他们的 imageComplete方法广播完成对所有注册的 IIOWriteProgressListener的图像的写入。
      protected void processImageProgress​(float percentageDone)
      通过调用其 imageProgress方法，将所有注册的 IIOWriteProgressListener的图像完成的当前百分比广播。
      protected void processImageStarted​(int imageIndex)
      通过调用 imageStarted方法，将所有注册的 IIOWriteProgressListener的图像写入的开始广播。
      protected void processThumbnailComplete​()
      通过调用 thumbnailComplete方法广播完成对所有注册的 IIOWriteProgressListener的缩略图写入。
      protected void processThumbnailProgress​(float percentageDone)
      通过调用其 thumbnailProgress方法将所有已注册的 IIOWriteProgressListener的缩略图完成的当前百分比广播。
      protected void processThumbnailStarted​(int imageIndex, int thumbnailIndex)
      通过调用 thumbnailStarted方法，向所有注册的 IIOWriteProgressListener缩略图写入的开始。
      protected void processWarningOccurred​(int imageIndex, String warning)
      通过拨打 warningOccurred方法向所有注册的 IIOWriteWarningListener发送一条警告消息。
      protected void processWarningOccurred​(int imageIndex, String baseName, String keyword)
      通过使用从 ResourceBundle获取的字符串调用其 warningOccurred方法向所有注册的 IIOWriteWarningListener发送本地化警告消息。
      protected void processWriteAborted​()
      通过调用它们的 writeAborted方法广播已经中止所有注册的所有注册的 IIOWriteProgressListener 。
      void removeAllIIOWriteProgressListeners​()
      删除所有当前注册的 IIOWriteProgressListener对象。
      void removeAllIIOWriteWarningListeners​()
      删除所有当前注册的 IIOWriteWarningListener对象。
      void removeIIOWriteProgressListener​(IIOWriteProgressListener listener)
      从注册进度监听器列表中删除 IIOWriteProgressListener 。
      void removeIIOWriteWarningListener​(IIOWriteWarningListener listener)
      从注册的警告监听器列表中删除 IIOWriteWarningListener 。
      void removeImage​(int imageIndex)
      从流中删除图像。
      void replaceImageMetadata​(int imageIndex, IIOMetadata imageMetadata)
      替换与现有图像相关联的图像元数据。
      void replacePixels​(Raster raster, ImageWriteParam param)
      用给定的 Raster的一部分替换已经存在于输出中的图像的一部分。
      void replacePixels​(RenderedImage image, ImageWriteParam param)
      用给定图像的一部分替换已经存在于输出中的图像的一部分。
      void replaceStreamMetadata​(IIOMetadata streamMetadata)
      用新信息替换输出中的流元数据。
      void reset​()
      将 ImageWriter恢复到初始状态。
      void setLocale​(Locale locale)
      将此 ImageWriter的当前 Locale设置为给定值。
      void setOutput​(Object output)
      将目的地设置为给定的 ImageOutputStream或其他 Object 。
      void write​(RenderedImage image)
      将包含单个图像的完整图像流附加到输出的默认元数据和缩略图。
      void write​(IIOImage image)
      将含有默认元数据和缩略图的单个图像的完整图像流附加到输出。
      abstract void write​(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param)
      将包含单个图像和关联流以及图像元数据和缩略图的完整图像流附加到输出。
      void writeInsert​(int imageIndex, IIOImage image, ImageWriteParam param)
      将新图像插入到现有图像流中。
      void writeToSequence​(IIOImage image, ImageWriteParam param)
      将单个图像和可能关联的元数据和缩略图附加到输出。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • originatingProvider

        protected ImageWriterSpi originatingProvider
        该ImageWriterSpi认为这个实例化对象，或者null如果其身份未知或不存在。 默认情况下，它被初始化为null 。

      • output

        protected Object output
        所述ImageOutputStream或其它Object通过设置setOutput ，并通过检索getOutput 。 默认情况下，它被初始化为null 。

      • availableLocales

        protected Locale[] availableLocales
        的阵列Locale可用于本地化警告消息和压缩设置值，或S null如果不支持定位。 默认情况下，它被初始化为null 。

      • locale

        protected Locale locale
        目前Locale用于定位，或null ;如果没有设置。 默认情况下，它被初始化为null 。

      • warningListeners

        protected List<IIOWriteWarningListener> warningListeners
        A List当前注册的 IIOWriteWarningListener s，默认初始化为 null ，这是一个空的 List同义词。

      • warningLocales

        protected List<Locale> warningLocales
        甲 List的 Locale S，一个用于的每个元素 warningListeners ，默认情况下初始化 null ，它与空同义 List 。

      • progressListeners

        protected List<IIOWriteProgressListener> progressListeners
        A List当前注册的 IIOWriteProgressListener s，默认初始化为 null ，这是空的 List代名词。

    • 构造方法详细信息

      • ImageWriter

        protected ImageWriter​(ImageWriterSpi originatingProvider)
        构造一个ImageWriter并将其originatingProvider实例变量设置为提供的值。

        使用扩展的子类应提供带有签名(ImageWriterSpi, Object)的构造函数，以检索扩展对象。 如果扩展对象不合适，则应抛出一个IllegalArgumentException 。

        参数
        originatingProvider -所述 ImageWriterSpi被构造该对象，或 null 。

    • 方法详细信息

      • getOriginatingProvider

        public ImageWriterSpi getOriginatingProvider​()
        返回ImageWriterSpi创建此对象ImageWriter ，或者null如果这个对象不是通过创建IIORegistry 。

        默认实现返回值为originatingProvider实例变量。

        结果
        一个 ImageWriterSpi或 null 。
        另请参见：
        ImageWriterSpi

      • setOutput

        public void setOutput​(Object output)
        将目的地设置为给定的ImageOutputStream或其他Object 。 假设目的地准备好接受数据，并且不会在每次写入结束时关闭。 这允许分布式成像应用程序通过单个网络连接传输一系列图像。 如果output是null ，则任何当前设置的输出将被删除。

        如果output是ImageOutputStream ，调用到write ， writeToSequence ，和prepareWriteEmpty / endWriteEmpty方法将保留流的现有内容。 其它的写入方法，例如writeInsert ， replaceStreamMetadata ， replaceImageMetadata ， replacePixels ， prepareInsertEmpty / endInsertEmpty ，和endWriteSequence ，所需要的流的全部内容是可读的和可写的，并且可以改变流的任何部分。

        的一般使用Object比其他ImageOutputStream旨在用于直接与输出装置或图像协议交互的作家。 这套法律课由作者的服务提供者的getOutputTypes方法发布; 大多数作家将返回一个仅包含ImageOutputStream.class的单元素数组，表示它们只接受一个ImageOutputStream 。

        检查output之后，默认实现将output的值设置为output ，与发起提供者发布的一组类别output （如果有）。

        参数
        output - ImageOutputStream或其他 Object用于将来的写作。
        异常
        IllegalArgumentException - 如果 output不是由始发服务提供商的 getOutputTypes方法返回的类之一的实例。
        另请参见：
        getOutput()

      • getOutput

        public Object getOutput​()
        返回ImageOutputStream或其他Object设置的最新调用setOutput方法。 如果没有设置目的地，则返回null 。

        默认实现返回值为output实例变量。

        结果
        所述 Object最近使用指定 setOutput ，或 null 。
        另请参见：
        setOutput(java.lang.Object)

      • getAvailableLocales

        public Locale[] getAvailableLocales​()
        返回可用于本地化警告侦听器和压缩设置的Locale s的数组。 返回值为null表示不支持本地化。

        如果它是非null ，则默认实现将返回availableLocales实例变量的克隆，否则返回null 。

        结果
        可以用作 Locale的参数的 setLocale ，或 null 。

      • setLocale

        public void setLocale​(Locale locale)
        将此ImageWriter的当前Locale设置为给定值。 值null删除任何以前的设置，并指示作者应将其视为合适的本地化。

        默认实现检查locale与getAvailableLocales返回的值，并设置locale实例变量（如果找到）。 如果locale为null ，则实例变量设置为null而不进行任何检查。

        参数
        locale - 期望的 Locale或 null 。
        异常
        IllegalArgumentException - 如果 locale不是 null但不是由 getAvailableLocales返回的值 getAvailableLocales 。
        另请参见：
        getLocale()

      • getLocale

        public Locale getLocale​()
        如果没有设置，返回当前设置的Locale或null 。

        默认实现返回值为locale实例变量。

        结果
        目前为 Locale ，或 null 。
        另请参见：
        setLocale(java.util.Locale)

      • getDefaultWriteParam

        public ImageWriteParam getDefaultWriteParam​()
        返回一个包含默认值的文件格式的适当类型的新的ImageWriteParam对象，即，如果未指定ImageWriteParam对象将使用的那些值。 这是一个起点，用于调整一些参数，否则只能保留默认设置。

        默认实现构造并返回不允许平铺，逐行编码或压缩的新的ImageWriteParam对象，并且将对当前的Locale进行本地化（ 即通过调用new ImageWriteParam(getLocale())获得的new ImageWriteParam(getLocale()) 。

        个别插件可能会返回一个ImageWriteParam的实例，并启用其他可选功能，否则可能会返回一个插件特定子类的ImageWriteParam 。

        结果
        一个新的 ImageWriteParam对象包含默认值。

      • getDefaultStreamMetadata

        public abstract IIOMetadata getDefaultStreamMetadata​(ImageWriteParam param)
        返回包含用于编码图像流的默认值的IIOMetadata对象。 可以使用由IIOMetadata.getAsTree方法返回的XML树结构， IIOMetadataController对象或通过插件特定接口来操纵对象的内容，并将得到的数据提供给采用流元数据参数的write方法之一。

        可能会为可能影响流元数据结构的情况提供可选的ImageWriteParam 。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        不使用流元数据的作者（ 例如 ，单图像格式的作者）应返回null 。

        参数
        param -一个 ImageWriteParam将被用于对图像，或编码 null 。
        结果
        一个 IIOMetadata对象。

      • getDefaultImageMetadata

        public abstract IIOMetadata getDefaultImageMetadata​(ImageTypeSpecifier imageType,
                                                    ImageWriteParam param)
        返回一个包含用于对给定类型的图像进行编码的默认值的IIOMetadata对象。 可以使用由IIOMetadata.getAsTree方法返回的XML树结构， IIOMetadataController对象或通过插件特定接口来操纵对象的内容，并将得到的数据提供给采用流元数据参数的write方法之一。

        可能会为可能影响图像元数据结构的情况提供ImageWriteParam 。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        参数
        imageType - 表示要稍后写入的图像格式的 ImageTypeSpecifier 。
        param -一个 ImageWriteParam将被用于对图像，或编码 null 。
        结果
        一个 IIOMetadata对象。

      • convertStreamMetadata

        public abstract IIOMetadata convertStreamMetadata​(IIOMetadata inData,
                                                  ImageWriteParam param)
        描述从接口ImageTranscoder复制
        返回可用于编码的IIOMetadata对象，并可使用其文档接口或特定于将用于编码的写入程序插件的其他接口进行可选修改。

        可能会为可能影响流元数据结构的情况提供可选的ImageWriteParam 。

        如果提供的ImageWriteParam包含此作者或代码转换器ImageWriteParam可选设置值，它们将被忽略。

        Specified by:
        convertStreamMetadata在接口 ImageTranscoder
        参数
        inData - 表示流元数据的 IIOMetadata对象，用于初始化返回对象的状态。
        param -一个 ImageWriteParam将被用于对图像，或编码 null 。
        结果
        一个 IIOMetadata对象，或 null如果插件不提供元数据编码功能。

      • convertImageMetadata

        public abstract IIOMetadata convertImageMetadata​(IIOMetadata inData,
                                                 ImageTypeSpecifier imageType,
                                                 ImageWriteParam param)
        描述从接口ImageTranscoder复制
        返回可用于编码的IIOMetadata对象，并可以使用其文档接口或特定于将用于编码的writer插件的其他接口进行可选修改。

        可能会为可能影响图像元数据结构的情况提供可选的ImageWriteParam 。

        如果提供的ImageWriteParam包含此写入器或代码转换器ImageWriteParam可选设置值，它们将被忽略。

        Specified by:
        convertImageMetadata在接口 ImageTranscoder
        参数
        inData - 表示图像元数据的 IIOMetadata对象，用于初始化返回对象的状态。
        imageType - 表示元数据将与之相关联的图像的布局和颜色信息的 ImageTypeSpecifier 。
        param -一个 ImageWriteParam将被用于对图像，或编码 null 。
        结果
        一个 IIOMetadata对象，或 null如果插件不提供元数据编码功能。

      • getNumThumbnailsSupported

        public int getNumThumbnailsSupported​(ImageTypeSpecifier imageType,
                                     ImageWriteParam param,
                                     IIOMetadata streamMetadata,
                                     IIOMetadata imageMetadata)
        给定图像类型以及编码期间将要使用的任何其他写入参数和元数据对象，返回由正在写入的格式支持的缩略图数。 返回值为-1表示信息不足。

        可以可选地为可能影响缩略图处理的情况提供一个ImageWriteParam 。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        默认实现返回0。

        参数
        imageType -一个 ImageTypeSpecifier指示图像的类型将被写入，或 null 。
        param -在 ImageWriteParam将被用于书写，或 null 。
        streamMetadata - 将用于写入的 IIOMetadata对象，或 null 。
        imageMetadata - 将用于写入的 IIOMetadata对象，或 null 。
        结果
        提供的参数可能写入的缩略图数量，如果信息不足， -1 。

      • getPreferredThumbnailSizes

        public Dimension[] getPreferredThumbnailSizes​(ImageTypeSpecifier imageType,
                                              ImageWriteParam param,
                                              IIOMetadata streamMetadata,
                                              IIOMetadata imageMetadata)
        返回Dimension s的数组，表示缩略图的合法大小范围，因为它们将被编码在输出文件或流中。 这些信息只是咨询; 作者将根据需要调整所提供的缩略图大小。

        信息作为一组对返回; 一对的第一个元素包含（包括）最小宽度和高度，第二个元素包含（包含）最大宽度和高度。 在一起，每对都定义了一个有效的大小范围。 要指定固定的大小，这两个元素将显示相同的宽度和高度。 返回值为null表示大小是任意的或未知的。

        可以可选地为可能影响缩略图处理的情况提供ImageWriteParam 。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        默认实现返回null 。

        参数
        imageType -一个 ImageTypeSpecifier指示图像的类型将被写入，或 null 。
        param -在 ImageWriteParam将被用于书写，或 null 。
        streamMetadata - 将用于写入的 IIOMetadata对象，或 null 。
        imageMetadata - 将用于写入的 IIOMetadata对象，或 null 。
        结果
        Dimension秒的阵列至少有两个，即 null 。

      • canWriteRasters

        public boolean canWriteRasters​()
        返回true如果采取方法IIOImage参数能够与处理的Raster （相对于RenderedImage ）源图像。 如果此方法返回false ，那么这些方法将抛出UnsupportedOperationException如果与供给IIOImage含有Raster 。

        默认实现返回false 。

        结果
        true如果支持 Raster源。

      • write

        public abstract void write​(IIOMetadata streamMetadata,
                           IIOImage image,
                           ImageWriteParam param)
                    throws IOException
        将包含单个图像和关联流以及图像元数据和缩略图的完整图像流附加到输出。 包括任何必要的标题信息。 如果输出为ImageOutputStream ，则其当前查找位置之前的现有内容不受影响，无需读取或写入。

        必须使用setOutput方法预先设置输出。

        可以可选地提供流元数据; 如果是null ，将使用默认流元数据。

        如果canWriteRasters返回true ，则IIOImage可能包含一个Raster源码。 否则，它必须包含一个RenderedImage源。

        如果需要，提供的缩略图将被调整大小，超过支持的数字的任何缩略图将被忽略。 如果格式需要未提供的附加缩略图，则作者应在内部生成它们。

        可以可选地提供ImageWriteParam来控制写入过程。 如果param为null ，则将使用默认的写入参数。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        参数
        streamMetadata - 表示流元数据的 IIOMetadata对象，或 null使用默认值。
        image - 包含要写入的图像，缩略图和元数据的 IIOImage对象。
        param - 一个 ImageWriteParam或 null使用默认值 ImageWriteParam 。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 image包含一个 Raster和 canWriteRasters返回 false 。
        IllegalArgumentException - 如果 image是 null 。
        IOException - 写入时是否发生错误。

      • write

        public void write​(IIOImage image)
           throws IOException
        将含有默认元数据和缩略图的单个图像的完整图像流附加到输出。 这个方法是write(null, image, null)的缩写。
        参数
        image - 一个包含要写入的图像，缩略图和元数据的 IIOImage对象。
        异常
        IllegalStateException - 如果输出未设置。
        IllegalArgumentException - 如果 image是 null 。
        UnsupportedOperationException - 如果 image包含一个 Raster和 canWriteRasters返回 false 。
        IOException - 如果写入时发生错误。

      • write

        public void write​(RenderedImage image)
           throws IOException
        将包含单个图像的完整图像流附加到输出的默认元数据和缩略图。 该方法是write(null, new IIOImage(image, null, null), null)的缩写。
        参数
        image - a RenderedImage待写。
        异常
        IllegalStateException - 如果输出未设置。
        IllegalArgumentException - 如果 image是 null 。
        IOException - 如果写入时发生错误。

      • canWriteSequence

        public boolean canWriteSequence​()
        如果作者能够将图像附加到已经包含标题信息和可能的先前图像的图像流中，则返回true 。

        如果canWriteSequence返回false ，则writeToSequence和endWriteSequence将会抛出一个UnsupportedOperationException 。

        默认实现返回false 。

        结果
        true如果可以依次附加图像。

      • prepareWriteSequence

        public void prepareWriteSequence​(IIOMetadata streamMetadata)
                          throws IOException
        使用提供的流元数据对象准备流以接受一系列后续的writeToSequence调用。 如果元数据应该在图像数据之前，则会将元数据写入流中。 如果参数为null ，则使用默认流元数据。

        如果输出为ImageOutputStream ，则刷新当前查找位置之前的输出的现有内容，并且不需要可读写。 如果格式要求endWriteSequence能够快退来补丁头信息，例如在单个TIFF文件中的一系列图像，则由该方法写入的元数据必须保留在流的可写部分。 其他格式可以在此方法之后和每个图像之后刷新流。

        如果canWriteSequence返回false ，这个方法会抛出一个UnsupportedOperationException 。

        必须使用setOutput方法事先设置输出。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则抛出一个UnsupportedOperationException 。

        参数
        streamMetadata - 流元数据对象，或 null 。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canWriteSequence返回 false 。
        IOException - 如果写入流元数据发生错误。

      • writeToSequence

        public void writeToSequence​(IIOImage image,
                            ImageWriteParam param)
                     throws IOException
        将单个图像和可能关联的元数据和缩略图附加到输出。 如果输出为ImageOutputStream ，则当前查找位置之前的输出的现有内容可能被刷新，并且不需要读取或写入，除非当endWriteSequence时插件需要能够修补标题信息（ 例如 TIFF）。

        如果canWriteSequence返回false ，这个方法会抛出一个UnsupportedOperationException 。

        必须使用setOutput方法预先设置输出。

        prepareWriteSequence必须事先调用，或者抛出一个IllegalStateException 。

        如果canWriteRasters返回true ，则IIOImage可能包含Raster源。 否则，它必须包含一个RenderedImage源。

        如果需要，提供的缩略图将被调整大小，超过支持的数字的任何缩略图将被忽略。 如果格式需要未提供的附加缩略图，写入程序将在内部生成它们。

        可以可选地提供ImageWriteParam以控制写入过程。 如果param是null ，将使用默认的写参数。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则会抛出一个UnsupportedOperationException 。

        参数
        image - 包含要写入的图像，缩略图和元数据的 IIOImage对象。
        param - 一个 ImageWriteParam ，或 null使用默认值 ImageWriteParam 。
        异常
        IllegalStateException - 如果输出未设置，或 prepareWriteSequence未被调用。
        UnsupportedOperationException - 如果 canWriteSequence返回 false 。
        IllegalArgumentException - 如果 image是 null 。
        UnsupportedOperationException - 如果 image包含一个 Raster和 canWriteRasters返回 false 。
        IOException - 写入时是否发生错误。

      • endWriteSequence

        public void endWriteSequence​()
                      throws IOException
        完成prepareWriteSequence开始的一系列图像的写作。 写出在图像序列结尾应该出现的任何流元数据，并且如果需要，则在序列开始处的任何头信息被修补。 如果输出是一个ImageOutputStream ，序列结尾的流元数据的数据被刷新，不需要读写。

        如果canWriteSequence返回false ，这个方法会抛出一个UnsupportedOperationException 。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则会抛出一个UnsupportedOperationException 。

        异常
        IllegalStateException - 如果输出未设置，或 prepareWriteSequence尚未被调用。
        UnsupportedOperationException - 如果 canWriteSequence返回 false 。
        IOException - 写入时是否发生错误。

      • canReplaceStreamMetadata

        public boolean canReplaceStreamMetadata​()
                                 throws IOException
        如果可以替换已经存在于输出中的流元数据，则返回true 。

        默认的实现抛出IllegalStateException如果输出为null ，否则返回false 。

        结果
        true如果允许流元数据的替换。
        异常
        IllegalStateException - 如果输出未设置。
        IOException - 如果在查询期间发生I / O错误。

      • replaceStreamMetadata

        public void replaceStreamMetadata​(IIOMetadata streamMetadata)
                           throws IOException
        用新信息替换输出中的流元数据。 如果输出是一个ImageOutputStream ，则流的先前内容被检查并且可能被编辑以为新数据腾出空间。 输出的所有先前内容必须可用于阅读和写入。

        如果canReplaceStreamMetadata返回false ，将抛出一个UnsupportedOperationException 。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则会抛出一个UnsupportedOperationException 。

        参数
        streamMetadata - 表示流元数据的 IIOMetadata对象，或 null使用默认值。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果canReplaceStreamMetadata返回false 。 模式不包括
        IOException - 写入时是否发生错误。

      • canReplaceImageMetadata

        public boolean canReplaceImageMetadata​(int imageIndex)
                                throws IOException
        返回true ，如果它是可以替换与现有的图像与索引相关联的图像元数据imageIndex 。 如果此方法返回false ，则呼叫replaceImageMetadata(imageIndex)将会抛出一个UnsupportedOperationException 。

        不支持任何图像元数据替换的作者可以返回false而不对索引执行边界检查。

        默认的实现抛出IllegalStateException如果输出为null ，否则返回false不检查的值imageIndex 。

        参数
        imageIndex - 要替换其元数据的图像的索引。
        结果
        true如果可以替换给定图像的图像元数据。
        异常
        IllegalStateException - 如果输出未设置。
        IndexOutOfBoundsException - 如果作者一般支持图像元数据替换，但 imageIndex小于0或大于最大可用索引。
        IOException - 如果在查询期间发生I / O错误。

      • replaceImageMetadata

        public void replaceImageMetadata​(int imageIndex,
                                 IIOMetadata imageMetadata)
                          throws IOException
        替换与现有图像相关联的图像元数据。

        如果canReplaceImageMetadata(imageIndex)返回false ，则会抛出UnsupportedOperationException 。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则会抛出一个UnsupportedOperationException 。

        参数
        imageIndex - 要替换其元数据的图像的索引。
        imageMetadata - 表示图像元数据的 IIOMetadata对象，或 null 。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canReplaceImageMetadata返回 false 。
        IndexOutOfBoundsException - 如果 imageIndex小于0或大于最大可用索引。
        IOException - 写入时是否发生错误。

      • canInsertImage

        public boolean canInsertImage​(int imageIndex)
                       throws IOException
        如果作者支持在给定索引处插入新图像，则返回true 。 索引大于或等于插入索引的现有图像的索引将增加1. imageIndex的-1值可用于表示大于当前最大索引的索引。

        不支持任何图像插入的作者可能会返回false而不对索引执行边界检查。

        默认的实现抛出IllegalStateException如果输出为null ，否则返回false不检查的值imageIndex 。

        参数
        imageIndex - 要插入图像的索引。
        结果
        如果可以在给定的索引处插入图像， true 。
        异常
        IllegalStateException - 如果输出未设置。
        IndexOutOfBoundsException - 如果作者一般支持图像插入，但 imageIndex小于-1或大于最大可用索引。
        IOException - 如果在查询期间发生I / O错误。

      • writeInsert

        public void writeInsert​(int imageIndex,
                        IIOImage image,
                        ImageWriteParam param)
                 throws IOException
        将新图像插入到现有图像流中。 索引大于imageIndex现有图像被保留，并且它们的索引各自增加1.对于imageIndex -1的值可以用于表示大于先前最大索引的索引; 也就是说，它将使图像逻辑地附加到序列的末尾。 如果输出是一个ImageOutputStream ，整个流必须是可读写的。

        如果canInsertImage(imageIndex)返回false ，将抛出UnsupportedOperationException 。

        可以可选地提供ImageWriteParam来控制写入过程。 如果param是null ，将使用默认的写参数。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        默认的实现抛出IllegalStateException如果输出为null ，否则会引发UnsupportedOperationException 。

        参数
        imageIndex - 写入图像的索引。
        image - 包含要写入的图像，缩略图和元数据的 IIOImage对象。
        param - 一个 ImageWriteParam ，或 null使用默认 ImageWriteParam 。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canInsertImage(imageIndex)返回 false 。
        IllegalArgumentException - 如果 image是 null 。
        IndexOutOfBoundsException - 如果 imageIndex小于-1或大于最大可用索引。
        UnsupportedOperationException - 如果 image包含一个 Raster和 canWriteRasters返回 false 。
        IOException - 写入时是否发生错误。

      • canRemoveImage

        public boolean canRemoveImage​(int imageIndex)
                       throws IOException
        如果作者支持在给定索引处删除现有图像，则返回true 。 索引大于插入索引的现有图像的索引将减少1。

        不支持任何图像删除的作者可以返回false而不对索引执行边界检查。

        默认的实现抛出IllegalStateException如果输出为null ，否则返回false不检查的值imageIndex 。

        参数
        imageIndex - 要删除的图像的索引。
        结果
        true如果可以删除给定的图像。
        异常
        IllegalStateException - 如果输出未设置。
        IndexOutOfBoundsException - 如果作者一般支持图像删除，但 imageIndex小于0或大于最大可用索引。
        IOException - 如果在查询期间发生I / O错误。

      • removeImage

        public void removeImage​(int imageIndex)
                 throws IOException
        从流中删除图像。

        如果canRemoveImage(imageIndex)返回false，将抛出一个UnsupportedOperationException 。

        删除可能会导致或可能不会导致实际文件大小的减少。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则会抛出一个UnsupportedOperationException 。

        参数
        imageIndex - 要删除的图像的索引。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canRemoveImage(imageIndex)返回 false 。
        IndexOutOfBoundsException - 如果 imageIndex小于0或大于最大可用索引。
        IOException - 如果在删除期间发生I / O错误。

      • canWriteEmpty

        public boolean canWriteEmpty​()
                      throws IOException
        如果作者支持写入一个包含未定义像素值的单个图像的完整图像流，并将相关元数据和缩略图写入输出，则返回true 。 可以通过将来调用replacePixels方法来定义像素值。 如果输出为ImageOutputStream ，则其当前查找位置之前的现有内容不受影响，无需读取或写入。

        默认的实现抛出IllegalStateException如果输出为null ，否则返回false 。

        结果
        true如果写入完整的图像流与后面要定义的内容被支持。
        异常
        IllegalStateException - 如果输出未设置。
        IOException - 查询期间是否发生I / O错误。

      • prepareWriteEmpty

        public void prepareWriteEmpty​(IIOMetadata streamMetadata,
                              ImageTypeSpecifier imageType,
                              int width,
                              int height,
                              IIOMetadata imageMetadata,
                              List<? extends BufferedImage> thumbnails,
                              ImageWriteParam param)
                       throws IOException
        开始将一个完整的图像流写入到包含未定义像素值的单个图像和关联的元数据和缩略图中。 像素值将由将来调用replacePixels方法定义。 如果输出为ImageOutputStream ，则其当前查找位置之前的现有内容不受影响，不需要读取或写入。

        在endWriteEmpty发生呼叫之前，写入不完整。 调用prepareReplacePixels ， replacePixels ，并endReplacePixels可调用之间发生prepareWriteEmpty和endWriteEmpty 。 但是，对prepareWriteEmpty调用不能嵌套，并且调用prepareWriteEmpty和prepareInsertEmpty可能不会散置。

        如果canWriteEmpty返回false ，将抛出UnsupportedOperationException 。

        可以可选地提供一个ImageWriteParam来控制写入过程。 如果param为null ，则将使用默认的写参数。

        如果提供的ImageWriteParam包含此作者不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        默认的实现抛出IllegalStateException如果输出为null ，否则会引发UnsupportedOperationException 。

        参数
        streamMetadata - 表示流元数据的 IIOMetadata对象，或 null使用默认值。
        imageType - 描述图像布局的 ImageTypeSpecifier 。
        width - 图像的宽度。
        height - 图像的高度。
        imageMetadata - 表示图像元数据的 IIOMetadata对象，或 null 。
        thumbnails - 一个 List的 BufferedImage此图像的缩略图，或 null 。
        param - 一个 ImageWriteParam或 null使用默认的 ImageWriteParam 。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canWriteEmpty返回 false 。
        IllegalStateException - 如果以前的电话是 prepareWriteEmpty ，而没有对 endWriteEmpty的相应调用。
        IllegalStateException - 如果以前的电话是 prepareInsertEmpty ，而没有对 endInsertEmpty的相应调用。
        IllegalArgumentException - 如果 imageType是 null或 thumbnails包含 null引用或 BufferedImage的对象。
        IllegalArgumentException - 如果宽度或高度小于1。
        IOException - 写入时是否发生I / O错误。

      • endWriteEmpty

        public void endWriteEmpty​()
                   throws IOException
        完成了以前致电prepareWriteEmpty开始的新图像的写作。

        如果canWriteEmpty()返回false ，将抛出UnsupportedOperationException 。

        默认的实现抛出IllegalStateException如果输出为null ，否则会引发UnsupportedOperationException 。

        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canWriteEmpty(imageIndex)返回 false 。
        IllegalStateException - 如果以前拨打 prepareWriteEmpty没有对应的电话 endWriteEmpty尚未做出。
        IllegalStateException - 如果先前致电 prepareInsertEmpty没有相应的电话 endInsertEmpty已经做出了。
        IllegalStateException - 如果未对 prepareReiplacePixels进行匹配调用， endReplacePixels拨打 endReplacePixels 。
        IOException - 写入时是否发生I / O错误。

      • canInsertEmpty

        public boolean canInsertEmpty​(int imageIndex)
                       throws IOException
        如果作者支持在给定索引处插入新的空图像，则返回true 。 图像的像素值未定义，可以使用replacePixels方法指定。 索引大于或等于插入索引的现有图像的索引将增加1. imageIndex的-1值可用于表示大于当前最大索引的索引。

        不支持插入空图像的作者可能会返回false而不对索引执行边界检查。

        默认的实现抛出IllegalStateException如果输出为null ，否则返回false不检查的值imageIndex 。

        参数
        imageIndex - 要插入图像的索引。
        结果
        true如果可以在给定索引处插入空图像。
        异常
        IllegalStateException - 如果输出未设置。
        IndexOutOfBoundsException - 如果作者一般支持空图像插入，但 imageIndex小于-1或大于最大可用索引。
        IOException - 如果在查询期间发生I / O错误。

      • prepareInsertEmpty

        public void prepareInsertEmpty​(int imageIndex,
                               ImageTypeSpecifier imageType,
                               int width,
                               int height,
                               IIOMetadata imageMetadata,
                               List<? extends BufferedImage> thumbnails,
                               ImageWriteParam param)
                        throws IOException
        开始将未定义像素值的新图像插入到现有图像流中。 索引大于imageIndex现有图像被保留，其索引各自增加1.可以使用imageIndex的值表示大于前一大索引的索引; 也就是说，它将使图像逻辑地附加到序列的末尾。 如果输出为ImageOutputStream ，则整个流都必须是可读写的。

        以后可以使用replacePixels方法提供图像内容。 调用endInsertEmpty之前，插入不完整。 调用prepareReplacePixels ， replacePixels ，并endReplacePixels可调用之间发生prepareInsertEmpty和endInsertEmpty 。 但是，拨打prepareInsertEmpty不能嵌套，而对prepareWriteEmpty和prepareInsertEmpty可能不会散布。

        如果canInsertEmpty(imageIndex)返回false ，将抛出UnsupportedOperationException 。

        可以可选地提供ImageWriteParam来控制写入过程。 如果param是null ，将使用默认的写参数。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或特定于格式的设置），它们将被忽略。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则抛出一个UnsupportedOperationException 。

        参数
        imageIndex - 写入图像的索引。
        imageType - 描述图像布局的 ImageTypeSpecifier 。
        width - 图像的宽度。
        height - 图像的高度。
        imageMetadata - 表示图像元数据的 IIOMetadata对象，或 null 。
        thumbnails - a List的 BufferedImage此图片的缩略图，或 null 。
        param - 一个 ImageWriteParam或 null使用默认值 ImageWriteParam 。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canInsertEmpty(imageIndex)返回 false 。
        IndexOutOfBoundsException - 如果 imageIndex小于-1或大于最大可用索引。
        IllegalStateException - 如果以前的电话是 prepareInsertEmpty ，而没有对 endInsertEmpty的相应调用。
        IllegalStateException - 如果以前的电话是 prepareWriteEmpty ，而没有对 endWriteEmpty的相应调用。
        IllegalArgumentException - 如果 imageType是 null或 thumbnails包含 null引用或 BufferedImage的对象。
        IllegalArgumentException - 如果宽度或高度小于1。
        IOException - 写入时是否发生I / O错误。

      • endInsertEmpty

        public void endInsertEmpty​()
                    throws IOException
        完成插入一个以前调用prepareInsertEmpty开始的新映像。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则会抛出一个UnsupportedOperationException 。

        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canInsertEmpty(imageIndex)返回 false 。
        IllegalStateException - 如果以前没有对 prepareInsertEmpty进行相应调用的呼叫，则没有进行 endInsertEmpty 。
        IllegalStateException - 如果先前致电 prepareWriteEmpty没有相应的调用 endWriteEmpty已经做出了。
        IllegalStateException -如果一个呼叫 prepareReplacePixels已经没有匹配的呼叫作出 endReplacePixels 。
        IOException - 写入时是否发生I / O错误。

      • canReplacePixels

        public boolean canReplacePixels​(int imageIndex)
                         throws IOException
        如果作者允许使用replacePixels方法替换给定图像的像素，则返回true 。

        不支持任何像素替换的作者可能会返回false而不对索引执行边界检查。

        默认的实现抛出IllegalStateException如果输出为null ，否则返回false不检查的值imageIndex 。

        参数
        imageIndex - 要替换其像素的图像的索引。
        结果
        true如果可以替换给定图像的像素。
        异常
        IllegalStateException - 如果输出未设置。
        IndexOutOfBoundsException - 如果作者一般支持像素替换，但 imageIndex小于0或大于最大可用索引。
        IOException - 如果在查询期间发生I / O错误。

      • prepareReplacePixels

        public void prepareReplacePixels​(int imageIndex,
                                 Rectangle region)
                          throws IOException
        准备作者处理一系列对replacePixels方法的电话。 受影响的像素区域将与所提供的像素区域相对

        如果canReplacePixels返回false ，将会抛出UnsupportedOperationException 。

        默认的实现抛出IllegalStateException如果输出为null ，否则会引发UnsupportedOperationException 。

        参数
        imageIndex - 要替换其像素的图像的索引。
        region - 将用于剪辑未来像素区域的 Rectangle 。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canReplacePixels(imageIndex)返回 false 。
        IndexOutOfBoundsException - 如果 imageIndex小于0或大于最大可用索引。
        IllegalStateException -如果以前调用 prepareReplacePixels没有相应地调用 endReplacePixels （ 即嵌套是不允许的）。
        IllegalArgumentException - 如果 region为 null或宽度或高度小于1。
        IOException - 在准备过程中是否发生I / O错误。

      • replacePixels

        public void replacePixels​(RenderedImage image,
                          ImageWriteParam param)
                   throws IOException
        用给定图像的一部分替换已经存在于输出中的图像的一部分。 图像数据必须匹配或可转换为现有图像的图像布局。

        目的地区域在param参数中指定，并将被剪切到图像边界和提供给prepareReplacePixels的区域。 源的至少一个像素不能被裁剪，或抛出异常。

        可以可选地提供一个ImageWriteParam来控制写入过程。 如果param是null ，将使用默认的写参数。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        此方法只能在调用prepareReplacePixels后调用，否则将抛出IllegalStateException 。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则抛出一个UnsupportedOperationException 。

        参数
        image - 一个包含源像素的 RenderedImage 。
        param - 一个 ImageWriteParam ，或 null使用默认值 ImageWriteParam 。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canReplacePixels(imageIndex)返回 false 。
        IllegalStateException - 如果没有以前的呼叫 prepareReplacePixels没有匹配的呼叫 endReplacePixels 。
        IllegalArgumentException - 如果满足以下条件：
        • image是null 。
        • 相交区域不包含至少一个像素。
        • image的布局不匹配，或者这个作者不能将其转换为现有的图像布局。
        IOException - 写入时是否发生I / O错误。

      • replacePixels

        public void replacePixels​(Raster raster,
                          ImageWriteParam param)
                   throws IOException
        用给定的Raster的一部分替换已经存在于输出中的图像的一部分。 图像数据必须匹配或可转换为现有图像的图像布局。

        可以可选地提供ImageWriteParam来控制写入过程。 如果param为null ，则将使用默认的写参数。

        目标区域在param参数中指定，并将被剪切到图像边界和提供给prepareReplacePixels的区域。 源的至少一个像素不能被裁剪，或抛出异常。

        如果提供的ImageWriteParam包含此写入程序不支持的可选设置值（ 例如逐行编码或任何特定于格式的设置），它们将被忽略。

        此方法只能在调用prepareReplacePixels后调用，否则将抛出IllegalStateException 。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则抛出一个UnsupportedOperationException 。

        参数
        raster - 包含源像素的 Raster 。
        param - 一个 ImageWriteParam或 null使用默认值 ImageWriteParam 。
        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canReplacePixels(imageIndex)返回 false 。
        IllegalStateException - 如果以前没有拨打 prepareReplacePixels而没有匹配的呼叫到 endReplacePixels 。
        UnsupportedOperationException - 如果 canWriteRasters返回 false 。
        IllegalArgumentException - 如果满足以下条件：
        • raster是null 。
        • 相交区域不包含至少一个像素。
        • raster的布局不匹配，或者这个作者不能将其转换为现有的图像布局。
        IOException - 写入时是否发生I / O错误。

      • endReplacePixels

        public void endReplacePixels​()
                      throws IOException
        终止一个呼叫序列到replacePixels 。

        如果canReplacePixels返回false ，将会抛出UnsupportedOperationException 。

        如果输出为null ，默认实现会抛出一个IllegalStateException ，否则抛出一个UnsupportedOperationException 。

        异常
        IllegalStateException - 如果输出未设置。
        UnsupportedOperationException - 如果 canReplacePixels(imageIndex)返回 false 。
        IllegalStateException - 如果以前没有拨打 prepareReplacePixels没有匹配的呼叫到 endReplacePixels 。
        IOException - 写入时是否发生I / O错误。

      • abort

        public void abort​()
        请求中止任何当前的写入操作。 中止输出后的内容将不确定。

        作者在每次写入操作开始时应调用clearAbortRequest ，并在写入期间定期轮询abortRequested的值。

      • abortRequested

        protected boolean abortRequested​()
        返回 true是否已经作出中止当前写入操作的请求自从writer被实例化或 clearAbortRequest被调用。
        结果
        true如果当前写入操作应该中止。
        另请参见：
        abort() ， clearAbortRequest()

      • clearAbortRequest

        protected void clearAbortRequest​()
        清除任何先前的中止请求。 此方法被调用后， abortRequested将返回false 。
        另请参见：
        abort() ， abortRequested()

      • addIIOWriteWarningListener

        public void addIIOWriteWarningListener​(IIOWriteWarningListener listener)
        将IIOWriteWarningListener添加到已注册的警告监听器列表中。 如果listener为null ，则不会抛出异常，也不会采取任何措施。 发送给给定侦听器的消息将被本地化，如果可能，匹配当前的Locale 。 如果没有设置Locale ，警告消息可能会按照写入者的身份进行本地化。
        参数
        listener - 要注册的 IIOWriteWarningListener 。
        另请参见：
        removeIIOWriteWarningListener(javax.imageio.event.IIOWriteWarningListener)

      • removeIIOWriteWarningListener

        public void removeIIOWriteWarningListener​(IIOWriteWarningListener listener)
        从注册的警告监听器列表中删除IIOWriteWarningListener 。 如果听众以前没有注册，或者如果listener是null ，则不会抛出异常，也不会采取任何操作。
        参数
        listener - 要注销的 IIOWriteWarningListener 。
        另请参见：
        addIIOWriteWarningListener(javax.imageio.event.IIOWriteWarningListener)

      • removeAllIIOWriteWarningListeners

        public void removeAllIIOWriteWarningListeners​()
        删除所有当前注册的IIOWriteWarningListener对象。

        默认实现将warningListeners和warningLocales实例变量设置为null 。

      • addIIOWriteProgressListener

        public void addIIOWriteProgressListener​(IIOWriteProgressListener listener)
        在注册进度侦听器列表中添加一个IIOWriteProgressListener 。 如果listener是null ，将不会抛出异常，也不会采取任何行动。
        参数
        listener - 要注册的 IIOWriteProgressListener 。
        另请参见：
        removeIIOWriteProgressListener(javax.imageio.event.IIOWriteProgressListener)

      • removeIIOWriteProgressListener

        public void removeIIOWriteProgressListener​(IIOWriteProgressListener listener)
        从注册进度侦听器列表中删除IIOWriteProgressListener 。 如果监听者以前没有注册，或者如果listener是null ，则不会抛出异常，也不会采取任何行动。
        参数
        listener - 要注销的 IIOWriteProgressListener 。
        另请参见：
        addIIOWriteProgressListener(javax.imageio.event.IIOWriteProgressListener)

      • removeAllIIOWriteProgressListeners

        public void removeAllIIOWriteProgressListeners​()
        删除所有当前注册的IIOWriteProgressListener对象。

        默认实现将progressListeners实例变量设置为null 。

      • processImageStarted

        protected void processImageStarted​(int imageIndex)
        通过调用他们的imageStarted方法，将所有注册的IIOWriteProgressListener的图像写入的开始广播。 子类可以方便地使用这种方法。
        参数
        imageIndex - 要写入的图像的索引。

      • processImageProgress

        protected void processImageProgress​(float percentageDone)
        通过调用其imageProgress方法，将目前的图像完成百分比广播到所有注册的IIOWriteProgressListener 。 子类可以方便地使用这种方法。
        参数
        percentageDone - 目前的完成百分比，为 float 。

      • processImageComplete

        protected void processImageComplete​()
        通过调用imageComplete方法，广播完成对所有注册的IIOWriteProgressListener的图像写入。 子类可以方便地使用这种方法。

      • processThumbnailStarted

        protected void processThumbnailStarted​(int imageIndex,
                                       int thumbnailIndex)
        通过调用其thumbnailStarted方法，将所有注册的IIOWriteProgressListener的缩略图写入的开始广播。 子类可以方便地使用这种方法。
        参数
        imageIndex - 与缩略图关联的图像的索引。
        thumbnailIndex - 缩略图的索引。

      • processThumbnailProgress

        protected void processThumbnailProgress​(float percentageDone)
        通过调用其thumbnailProgress方法将所有已注册的IIOWriteProgressListener的缩略图完成的当前百分比广播。 子类可以方便地使用这种方法。
        参数
        percentageDone - 目前的完成百分比，为 float 。

      • processThumbnailComplete

        protected void processThumbnailComplete​()
        通过调用thumbnailComplete方法，广播完成对所有注册的IIOWriteProgressListener的缩略图写入。 子类可以方便地使用这种方法。

      • processWriteAborted

        protected void processWriteAborted​()
        通过调用它们的writeAborted方法来广播已经中止所有注册的所有注册的IIOWriteProgressListener 。 子类可以方便地使用这种方法。

      • processWarningOccurred

        protected void processWarningOccurred​(int imageIndex,
                                      String warning)
        通过致电warningOccurred方式向所有注册的IIOWriteWarningListener发送警告消息。 子类可以方便地使用这种方法。
        参数
        imageIndex - 发生警告的图像的索引。
        warning - 警告信息。
        异常
        IllegalArgumentException - 如果 warning是 null 。

      • processWarningOccurred

        protected void processWarningOccurred​(int imageIndex,
                                      String baseName,
                                      String keyword)
        广播本地化警告消息给所有注册IIOWriteWarningListener通过调用它们的S warningOccurred法从拍摄字符串ResourceBundle 。 子类可以方便地使用这种方法。
        参数
        imageIndex - 发生警告的图像的索引。
        baseName - 包含本地化警告消息的一组 ResourceBundle s的基本名称。
        keyword - 用于索引 ResourceBundle秒内的警告消息的关键字。
        异常
        IllegalArgumentException - 如果 baseName是 null 。
        IllegalArgumentException - 如果 keyword是 null 。
        IllegalArgumentException - 如果不适合，可能会找到 ResourceBundle 。
        IllegalArgumentException - 如果在位于的位置 ResourceBundle命名的资源 ResourceBundle 。
        IllegalArgumentException - 如果从 ResourceBundle检索的对象不是 String 。

      • reset

        public void reset​()
        将ImageWriter恢复到初始状态。

        默认实现调用setOutput(null) ， setLocale(null) ， removeAllIIOWriteWarningListeners() ， removeAllIIOWriteProgressListeners() ，并clearAbortRequest 。

      • dispose

        public void dispose​()
        允许释放此对象持有的任何资源。 在调用此方法之后调用其他方法（不包括finalize ）的结果未定义。

        当应用程序知道他们将不再使用此方法时，调用此方法很重要ImageWriter 。 否则，作者可以继续无限期地持有资源。

        超类中的这个方法的默认实现什么都不做。 子类实现应确保释放所有资源，特别是本地资源。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javax.imageio (Java SE 9 & JDK 9 )

javax.imageio

Interfaces

  • IIOParamController
  • ImageTranscoder

Classes

  • IIOImage
  • IIOParam
  • ImageIO
  • ImageReader
  • ImageReadParam
  • ImageTypeSpecifier
  • ImageWriteParam
  • ImageWriter

Exceptions

  • IIOException


javax.imageio (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package javax.imageio

Java Image I / O API的主要包。

许多常见的图像I / O操作可以使用ImageIO类的静态方法来执行。

此包包含用于描述图像文件内容的基本类和接口，包括元数据和缩略图（ IIOImage ）; 用于控制图像读取处理（ ImageReader ， ImageReadParam ，和ImageTypeSpecifier ）和图像写入处理（ ImageWriter和ImageWriteParam ）; 用于在格式（ ImageTranscoder ）之间执行代码转换和用于报告错误（ IIOException ）。

javax.imageio的所有实现都提供以下标准映像格式插件：

Reading Writing Notes Metadata BMP yes yes none BMP metadata format GIF yes yes GIF plug-in notes GIF metadata format JPEG yes yes none JPEG metadata format PNG yes yes none PNG metadata format TIFF yes yes TIFF plug-in notes TIFF metadata format WBMP yes yes none WBMP metadata format

标准插件说明

Standard plug-in for GIF image format

ImageIO的提供ImageReader和ImageWriter插件为Graphics Interchange Format (GIF)的图像格式。 这些是“标准”GIF插件，意味着包含在JRE中的插件，与标准扩展中包含的插件或第三方插件不同。 以下注释和元数据规范适用于标准插件。

编写GIF图像

GIF图像编写器插件可保证满足以下要求的图像无损写入：
  • 频带数为1;
  • 每个样本的位数不大于8;
  • 颜色分量的大小不大于8;

默认情况下，GIF writer插件创建版本“89a”图像。 通过明确设置流元数据中的版本，可以将其更改为“87a”（请参阅GIF Stream Metadata Format Specification ）。

GIF作家插件支持通过ImageWriter类中定义的标准序列写入方法创建动画GIF图像。

如果满足以下条件之一，则将全局颜色表写入输出流：

  • 提供包含GlobalColorTable元素的流元数据;
  • 正在写入一个序列，并为序列中的第一个图像提供包含LocalColorTable元素的图像元数据;
  • 图像元数据不提供或不包含LocalColorTable元素。

在第一种情况下，使用流元数据中的全局颜色表，在第二种情况下，使用图像元数据中的局部颜色表，在第三种情况下，从（第一）图像的ColorModel或SampleModel创建全局颜色表。

仅当将包含LocalColorTable元素的图像元数据提供给写入程序或将图像元数据未提供给写入器并且将从映像本身生成的本地颜色表不等于时，本地颜色表才会写入输出流全局颜色表。

只有将包含GraphicControlExtension元素的图像元素提供给写入程序，或者没有提供图像元数据，并且从图像生成的本地颜色表需要透明索引，则图形控制扩展块才会写入输出流。 应用程序，纯文本和注释扩展块只有通过图像元数据提供给写入程序时才会写入。

可以通过所提供的ImageWriteParam实例的逐行模式来控制隔行图像的写入。 如果逐行模式为MODE_DISABLED则将写入非隔行扫描图像。 如果逐行模式为MODE_DEFAULT则将写入隔行扫描图像。 如果逐行模式为MODE_COPY_FROM_METADATA ，则使用元数据设置（如果提供，否则将写入隔行扫描图像）。

GIF图像编写器插件支持以原始GIF流元数据格式javax_imageio_gif_stream_1.0或标准元数据格式javax_imageio_1.0将提供给写入器的元数据的输出流元数据设置为，并将提供给作者的元数据的输出图像元数据设置为本地GIF图像元数据格式javax_imageio_gif_image_1.0或标准元数据格式javax_imageio_1.0 。 标准元数据格式到GIF本地流和图像元数据格式的映射在表here中给出 。

从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    IIOParamController
    要由可以通过放置GUI以从用户获取值或通过其他方式确定 IIOParam对象的设置的对象来实现的接口。
    ImageTranscoder
    提供元数据转码功能的界面。
  • 类摘要
    Class 描述
    IIOImage
    用于聚合图像的简单容器类，一组缩略图（预览）图像，以及表示与该图像相关联的元数据的对象。
    IIOParam
    描述流如何解码或编码的所有类的超类。
    ImageIO
    一个包含静态方便方法的类，用于定位 ImageReader和 ImageWriter ，并执行简单的编码和解码。
    ImageReader
    用于解析和解码图像的抽象超类。
    ImageReadParam
    描述流如何解码的类。
    ImageTypeSpecifier
    允许以方便的方式指定图像的格式（特别是其 SampleModel和 ColorModel ）的类。
    ImageWriteParam
    描述流如何编码的类。
    ImageWriter
    用于编码和写入图像的抽象超类。
  • 异常摘要
    异常 描述
    IIOException
    用于发信号读取和写入操作失败的异常类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.imageio Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.imageio

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.imageio.IIOImage
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
      • javax.imageio.ImageWriteParam
    • javax.imageio.ImageIO
    • javax.imageio.ImageReader
    • javax.imageio.ImageTypeSpecifier
    • javax.imageio.ImageWriter (implements javax.imageio.ImageTranscoder)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • javax.imageio.IIOException

Interface Hierarchy

  • javax.imageio.IIOParamController
  • javax.imageio.ImageTranscoder
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package javax.imageio (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.imageio

  • Packages that use javax.imageio
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.event
    一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.plugins.bmp
    包含内置BMP插件使用的公共类的软件包。
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
  • Classes in javax.imageio used by javax.imageio
    Class 描述
    IIOException
    用于发信号读取和写入操作失败的异常类。
    IIOImage
    用于聚合图像的简单容器类，一组缩略图（预览）图像，以及表示与该图像相关联的元数据的对象。
    IIOParam
    描述流如何解码或编码的所有类的超类。
    IIOParamController
    要由可以通过放置GUI以从用户获取值或通过其他方式确定 IIOParam对象的设置的对象来实现的接口。
    ImageReader
    用于解析和解码图像的抽象超类。
    ImageReadParam
    描述流如何解码的类。
    ImageTranscoder
    提供元数据转码功能的界面。
    ImageTypeSpecifier
    允许以方便的方式指定图像的格式（特别是其 SampleModel和 ColorModel ）的类。
    ImageWriteParam
    描述流如何编码的类。
    ImageWriter
    用于编码和写入图像的抽象超类。
  • Classes in javax.imageio used by javax.imageio.event
    Class 描述
    ImageReader
    用于解析和解码图像的抽象超类。
    ImageWriter
    用于编码和写入图像的抽象超类。
  • Classes in javax.imageio used by javax.imageio.metadata
    Class 描述
    IIOException
    用于发信号读取和写入操作失败的异常类。
    ImageTypeSpecifier
    允许以方便的方式指定图像格式（特别是其 SampleModel和 ColorModel ）的类。
  • Classes in javax.imageio used by javax.imageio.plugins.bmp
    Class 描述
    IIOParam
    描述流如何解码或编码的所有类的超类。
    ImageWriteParam
    描述流如何编码的类。
  • Classes in javax.imageio used by javax.imageio.plugins.jpeg
    Class 描述
    IIOParam
    描述流如何解码或编码的所有类的超类。
    ImageReadParam
    描述流如何解码的类。
    ImageWriteParam
    描述流如何编码的类。
  • Classes in javax.imageio used by javax.imageio.plugins.tiff
    Class 描述
    IIOParam
    描述流如何解码或编码的所有类的超类。
    ImageReadParam
    描述流如何解码的类。
  • Classes in javax.imageio used by javax.imageio.spi
    Class 描述
    ImageReader
    用于解析和解码图像的抽象超类。
    ImageTranscoder
    提供元数据转码功能的界面。
    ImageTypeSpecifier
    允许以方便的方式指定图像的格式（特别是其 SampleModel和 ColorModel ）的类。
    ImageWriter
    用于编码和写入图像的抽象超类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.IIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.IIOException

  • Packages that use IIOException
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。

    • Uses of IIOException in javax.imageio

      Methods in javax.imageio that throw IIOException
      Modifier and Type 方法 描述
      protected static BufferedImage ImageReader.getDestination​(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
      返回应写入解码像素数据的 BufferedImage 。

    • Uses of IIOException in javax.imageio.metadata

      Subclasses of IIOException in javax.imageio.metadata
      Modifier and Type Class 描述
      class  IIOInvalidTreeException
      一个 IIOInvalidTreeException当被试图抛出 IIOMetadata对象来解析树 IIOMetadataNode小号失败。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.IIOImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.IIOImage

  • Packages that use IIOImage
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of IIOImage in javax.imageio

      Methods in javax.imageio that return IIOImage
      Modifier and Type 方法 描述
      IIOImage ImageReader.readAll​(int imageIndex, ImageReadParam param)
      读取由索引的图像 imageIndex并返回一个 IIOImage包含图像，缩略图和相关联的图像元数据，使用所提供的 ImageReadParam 。
      Methods in javax.imageio that return types with arguments of type IIOImage
      Modifier and Type 方法 描述
      Iterator<IIOImage> ImageReader.readAll​(Iterator<? extends ImageReadParam> params)
      返回 Iterator包含所有图像，缩略图和元数据，开始由下式给出的指数在 getMinIndex ，从形式的输入源 IIOImage对象。
      Methods in javax.imageio with parameters of type IIOImage
      Modifier and Type 方法 描述
      void ImageWriter.write​(IIOImage image)
      将含有默认元数据和缩略图的单个图像的完整图像流附加到输出。
      abstract void ImageWriter.write​(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param)
      将包含单个图像和关联流以及图像元数据和缩略图的完整图像流附加到输出。
      void ImageWriter.writeInsert​(int imageIndex, IIOImage image, ImageWriteParam param)
      将新图像插入到现有图像流中。
      void ImageWriter.writeToSequence​(IIOImage image, ImageWriteParam param)
      Appends a single image and possibly associated metadata and thumbnails, to the output.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.IIOParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.IIOParam

  • Packages that use IIOParam
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.plugins.bmp
    包含内置BMP插件使用的公共类的软件包。
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of IIOParam in javax.imageio

      Subclasses of IIOParam in javax.imageio
      Modifier and Type Class 描述
      class  ImageReadParam
      描述流如何解码的类。
      class  ImageWriteParam
      描述流如何编码的类。
      Methods in javax.imageio with parameters of type IIOParam
      Modifier and Type 方法 描述
      boolean IIOParamController.activate​(IIOParam param)
      激活控制器。

    • Uses of IIOParam in javax.imageio.plugins.bmp

      Subclasses of IIOParam in javax.imageio.plugins.bmp
      Modifier and Type Class 描述
      class  BMPImageWriteParam
      用于编码BMP格式的图像的 ImageWriteParam的子类。

    • Uses of IIOParam in javax.imageio.plugins.jpeg

      Subclasses of IIOParam in javax.imageio.plugins.jpeg
      Modifier and Type Class 描述
      class  JPEGImageReadParam
      此类增加了在使用内置JPEG阅读器插件时设置JPEG量化和霍夫曼表的功能。
      class  JPEGImageWriteParam
      该类增加了在使用内置JPEG writer插件时设置JPEG量化和霍夫曼表的能力，并请求为图像计算优化的霍夫曼表。

    • Uses of IIOParam in javax.imageio.plugins.tiff

      Subclasses of IIOParam in javax.imageio.plugins.tiff
      Modifier and Type Class 描述
      class  TIFFImageReadParam
      ImageReadParam的子类允许控制TIFF读取过程。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.ImageIO (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.ImageIO

No usage of javax.imageio.ImageIO
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.ImageReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.ImageReader

  • Packages that use ImageReader
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.event
    一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of ImageReader in javax.imageio

      Methods in javax.imageio that return ImageReader
      Modifier and Type 方法 描述
      static ImageReader ImageIO.getImageReader​(ImageWriter writer)
      返回 ImageReader对应于给定的 ImageWriter ，如果有一个，或 null如果这个 ImageWriter的插件没有指定相应的 ImageReader ，或者如果给定的 ImageWriter没有注册。
      Methods in javax.imageio that return types with arguments of type ImageReader
      Modifier and Type 方法 描述
      static Iterator<ImageReader> ImageIO.getImageReaders​(Object input)
      返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码所提供的 Object ，通常为 ImageInputStream 。
      static Iterator<ImageReader> ImageIO.getImageReadersByFormatName​(String formatName)
      返回一个 Iterator其中包含所有当前已注册的 ImageReader ，声称能够解码命名格式。
      static Iterator<ImageReader> ImageIO.getImageReadersByMIMEType​(String MIMEType)
      返回一个 Iterator其中包含所有当前注册的 ImageReader ，声称能够解码具有给定MIME类型的文件。
      static Iterator<ImageReader> ImageIO.getImageReadersBySuffix​(String fileSuffix)
      返回一个 Iterator其中包含所有当前注册的 ImageReader ，声称能够使用给定的后缀解码文件。
      Methods in javax.imageio with parameters of type ImageReader
      Modifier and Type 方法 描述
      static Iterator<ImageTranscoder> ImageIO.getImageTranscoders​(ImageReader reader, ImageWriter writer)
      返回一个 Iterator其中包含所有当前注册的 ImageTranscoder ，声称能够在给定的 ImageReader和 ImageWriter的元数据之间进行转码。
      static ImageWriter ImageIO.getImageWriter​(ImageReader reader)
      返回一个 ImageWriter对应于给定 ImageReader ，如果有一个或 null如果插件在此 ImageReader没有指定相应 ImageWriter ，如果给定 ImageReader未注册。

    • Uses of ImageReader in javax.imageio.event

      Methods in javax.imageio.event with parameters of type ImageReader
      Modifier and Type 方法 描述
      void IIOReadProgressListener.imageComplete​(ImageReader source)
      报告当前图像读取操作已完成。
      void IIOReadProgressListener.imageProgress​(ImageReader source, float percentageDone)
      报告当前完成近似程度 read调用相关的 ImageReader 。
      void IIOReadProgressListener.imageStarted​(ImageReader source, int imageIndex)
      报告图像读取操作开始。
      void IIOReadUpdateListener.imageUpdate​(ImageReader source, BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      报告图像的给定区域已更新。
      void IIOReadUpdateListener.passComplete​(ImageReader source, BufferedImage theImage)
      报告当前的读取操作已经完成了逐行通过。
      void IIOReadUpdateListener.passStarted​(ImageReader source, BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      报告当前读取操作即将开始逐行传递。
      void IIOReadProgressListener.readAborted​(ImageReader source)
      通过阅读器的 abort方法报告读取已被中止。
      void IIOReadProgressListener.sequenceComplete​(ImageReader source)
      报告一系列读取操作已完成。
      void IIOReadProgressListener.sequenceStarted​(ImageReader source, int minIndex)
      报告一系列读操作开始。
      void IIOReadProgressListener.thumbnailComplete​(ImageReader source)
      报告缩略图读取操作已完成。
      void IIOReadUpdateListener.thumbnailPassComplete​(ImageReader source, BufferedImage theThumbnail)
      报告当前缩略图读取操作已经完成了逐行通过。
      void IIOReadUpdateListener.thumbnailPassStarted​(ImageReader source, BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      报告当前的缩略图读取操作即将开始逐行传递。
      void IIOReadProgressListener.thumbnailProgress​(ImageReader source, float percentageDone)
      报告相关 ImageReader内当前 getThumbnail电话的大致完成程度。
      void IIOReadProgressListener.thumbnailStarted​(ImageReader source, int imageIndex, int thumbnailIndex)
      报告缩略图读取操作开始。
      void IIOReadUpdateListener.thumbnailUpdate​(ImageReader source, BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      报告缩略图的给定区域已更新。
      void IIOReadWarningListener.warningOccurred​(ImageReader source, String warning)
      报告解码中出现非致命错误。

    • Uses of ImageReader in javax.imageio.spi

      Methods in javax.imageio.spi that return ImageReader
      Modifier and Type 方法 描述
      ImageReader ImageReaderSpi.createReaderInstance​()
      返回与此服务提供程序相关联的 ImageReader实现的实例。
      abstract ImageReader ImageReaderSpi.createReaderInstance​(Object extension)
      返回与此服务提供程序相关联的 ImageReader实现的实例。
      Methods in javax.imageio.spi with parameters of type ImageReader
      Modifier and Type 方法 描述
      boolean ImageReaderSpi.isOwnReader​(ImageReader reader)
      如果传递的 ImageReader对象是与此服务提供商关联的 ImageReader的实例，则返回 true 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.ImageReadParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.ImageReadParam

  • Packages that use ImageReadParam
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of ImageReadParam in javax.imageio

      Methods in javax.imageio that return ImageReadParam
      Modifier and Type 方法 描述
      ImageReadParam ImageReader.getDefaultReadParam​()
      返回适用于此格式的默认对象 ImageReadParam 。
      Methods in javax.imageio with parameters of type ImageReadParam
      Modifier and Type 方法 描述
      protected static void ImageReader.checkReadParamBandSettings​(ImageReadParam param, int numSrcBands, int numDstBands)
      读者可以使用一种实用方法来测试 ImageReadParam的源和目标频带设置的 ImageReadParam 。
      protected static void ImageReader.computeRegions​(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion)
      计算感兴趣的源区域和感兴趣的目的地区域，将源图像的宽度和高度，可选的目标图像和可选的 ImageReadParam考虑在内。
      protected static BufferedImage ImageReader.getDestination​(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
      返回应写入解码像素数据的 BufferedImage 。
      protected static Rectangle ImageReader.getSourceRegion​(ImageReadParam param, int srcWidth, int srcHeight)
      读者可以使用一种实用方法来计算应该读取的源图像的区域，同时考虑到所提供的 ImageReadParam中的任何源区域和子采样偏移设置。
      abstract BufferedImage ImageReader.read​(int imageIndex, ImageReadParam param)
      读取 imageIndex索引的图像，并将其作为完整的 BufferedImage返回，使用附带的 ImageReadParam 。
      IIOImage ImageReader.readAll​(int imageIndex, ImageReadParam param)
      读取由索引的图像 imageIndex并返回一个 IIOImage包含图像，缩略图和相关联的图像元数据，使用所提供的 ImageReadParam 。
      RenderedImage ImageReader.readAsRenderedImage​(int imageIndex, ImageReadParam param)
      返回一个 RenderedImage对象，其中包含由 imageIndex索引的图像的内容。
      Raster ImageReader.readRaster​(int imageIndex, ImageReadParam param)
      返回包含来自图像流的原始像素数据的新的 Raster对象，而不应用任何颜色转换。
      Method parameters in javax.imageio with type arguments of type ImageReadParam
      Modifier and Type 方法 描述
      Iterator<IIOImage> ImageReader.readAll​(Iterator<? extends ImageReadParam> params)
      返回 Iterator包含所有图像，缩略图和元数据，开始由下式给出的指数在 getMinIndex ，从形式的输入源 IIOImage对象。

    • Uses of ImageReadParam in javax.imageio.plugins.jpeg

      Subclasses of ImageReadParam in javax.imageio.plugins.jpeg
      Modifier and Type Class 描述
      class  JPEGImageReadParam
      此类增加了在使用内置JPEG阅读器插件时设置JPEG量化和霍夫曼表的功能。

    • Uses of ImageReadParam in javax.imageio.plugins.tiff

      Subclasses of ImageReadParam in javax.imageio.plugins.tiff
      Modifier and Type Class 描述
      class  TIFFImageReadParam
      ImageReadParam的子类允许控制TIFF读取过程。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.ImageTypeSpecifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.ImageTypeSpecifier

  • Packages that use ImageTypeSpecifier
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of ImageTypeSpecifier in javax.imageio

      Fields in javax.imageio declared as ImageTypeSpecifier
      Modifier and Type Field 描述
      protected ImageTypeSpecifier IIOParam.destinationType
      一个 ImageTypeSpecifier用于在读取时生成目标图像，或者在写入时设置输出颜色类型。
      Methods in javax.imageio that return ImageTypeSpecifier
      Modifier and Type 方法 描述
      static ImageTypeSpecifier ImageTypeSpecifier.createBanded​(ColorSpace colorSpace, int[] bankIndices, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied)
      返回带状图像格式的说明符，将使用 ComponentColorModel和 BandedSampleModel将每个通道存储在单独的阵列中。
      static ImageTypeSpecifier ImageTypeSpecifier.createFromBufferedImageType​(int bufferedImageType)
      返回一个 ImageTypeSpecifier ，它编码了一个标准的 BufferedImage类型（ TYPE_CUSTOM ）。
      static ImageTypeSpecifier ImageTypeSpecifier.createFromRenderedImage​(RenderedImage image)
      返回一个 ImageTypeSpecifier编码的布局 RenderedImage （其可以是 BufferedImage ）。
      static ImageTypeSpecifier ImageTypeSpecifier.createGrayscale​(int bits, int dataType, boolean isSigned)
      返回一个灰度图像格式的说明符，该格式将将给定位深度的像素包装为指定数据类型的数组元素。
      static ImageTypeSpecifier ImageTypeSpecifier.createGrayscale​(int bits, int dataType, boolean isSigned, boolean isAlphaPremultiplied)
      返回一个用于灰度加Alpha图像格式的说明符，它将给定位深度的像素包装为指定数据类型的数组元素。
      static ImageTypeSpecifier ImageTypeSpecifier.createIndexed​(byte[] redLUT, byte[] greenLUT, byte[] blueLUT, byte[] alphaLUT, int bits, int dataType)
      返回索引颜色图像格式的说明符，该格式将给定位深度的索引值包装为指定数据类型的数组元素。
      static ImageTypeSpecifier ImageTypeSpecifier.createInterleaved​(ColorSpace colorSpace, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied)
      返回一个交织图像格式的说明符，该格式将使用 ComponentColorModel和 PixelInterleavedSampleModel将每个像素组件存储在单独的字节，短或int中。
      static ImageTypeSpecifier ImageTypeSpecifier.createPacked​(ColorSpace colorSpace, int redMask, int greenMask, int blueMask, int alphaMask, int transferType, boolean isAlphaPremultiplied)
      返回一个用于打包图像格式的说明符，它将使用 DirectColorModel和打包的 SampleModel来存储单个字节，短或int中打包的每个像素。
      ImageTypeSpecifier IIOParam.getDestinationType​()
      如果通过调用 setDestination(ImageTypeSpecifier)设置了读取，返回要返回的图像的类型，如 ImageTypeSpecifier 。
      ImageTypeSpecifier ImageReader.getRawImageType​(int imageIndex)
      返回一个 ImageTypeSpecifier表示 SampleModel和 ColorModel ，其最接近地表示图像的“原始”内部格式。
      Methods in javax.imageio that return types with arguments of type ImageTypeSpecifier
      Modifier and Type 方法 描述
      abstract Iterator<ImageTypeSpecifier> ImageReader.getImageTypes​(int imageIndex)
      返回一个 Iterator其中包含可以解码给定图像的可能的图像类型，格式为 ImageTypeSpecifiers 。
      Methods in javax.imageio with parameters of type ImageTypeSpecifier
      Modifier and Type | 方法 | 描述
      IIOMetadata ImageTranscoder.convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可使用其文档接口或特定于将用于编码的writer插件的其他接口进行可选修改。
      abstract IIOMetadata | ImageWriter.convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      abstract IIOMetadata ImageWriter.getDefaultImageMetadata​(ImageTypeSpecifier imageType, ImageWriteParam param)
      返回一个包含用于对给定类型的图像进行编码的默认值的 IIOMetadata对象。
      static Iterator<ImageWriter> ImageIO.getImageWriters​(ImageTypeSpecifier type, String formatName)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够以给定格式对给定布局（使用 ImageTypeSpecifier指定）的图像进行编码。
      int ImageWriter.getNumThumbnailsSupported​(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata)
      给定图像类型以及编码期间将要使用的任何其他写入参数和元数据对象，返回由正在写入的格式支持的缩略图数。
      Dimension[] ImageWriter.getPreferredThumbnailSizes​(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata)
      返回一个 Dimension的数组，表示缩略图的合法大小范围，因为它们将被编码在输出文件或流中。
      void ImageWriter.prepareInsertEmpty​(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将未定义像素值的新图像插入到现有图像流中。
      void ImageWriter.prepareWriteEmpty​(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将一个完整的图像流写入到包含未定义像素值的单个图像和关联的元数据和缩略图中。
      void IIOParam.setDestinationType​(ImageTypeSpecifier destinationType)
      使用 ImageTypeSpecifier设置目标图像的所需图像类型。
      void | ImageReadParam.setDestinationType​(ImageTypeSpecifier destinationType)
      Method parameters in javax.imageio with type arguments of type ImageTypeSpecifier
      Modifier and Type 方法 描述
      protected static BufferedImage ImageReader.getDestination​(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
      返回要写入的解码像素数据的 BufferedImage 。

    • Uses of ImageTypeSpecifier in javax.imageio.metadata

      Methods in javax.imageio.metadata with parameters of type ImageTypeSpecifier
      Modifier and Type | 方法 | 描述
      boolean IIOMetadataFormat.canNodeAppear​(String elementName, ImageTypeSpecifier imageType)
      如果允许元素 true的元素（及其下面的子树）显示给由 ImageTypeSpecifier定义的给定类型的图像，则 ImageTypeSpecifier 。
      abstract boolean | IIOMetadataFormatImpl.canNodeAppear​(String elementName, ImageTypeSpecifier imageType)

    • Uses of ImageTypeSpecifier in javax.imageio.spi

      Methods in javax.imageio.spi with parameters of type ImageTypeSpecifier
      Modifier and Type 方法 描述
      abstract boolean ImageWriterSpi.canEncodeImage​(ImageTypeSpecifier type)
      如果与此服务提供商相关联的 ImageWriter实现能够对具有给定布局的图像进行编码，则返回 true 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.ImageWriteParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.ImageWriteParam

  • Packages that use ImageWriteParam
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.plugins.bmp
    包含内置BMP插件使用的公共类的软件包。
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。

    • Uses of ImageWriteParam in javax.imageio

      Methods in javax.imageio that return ImageWriteParam
      Modifier and Type 方法 描述
      ImageWriteParam ImageWriter.getDefaultWriteParam​()
      返回一个包含默认值的文件格式的适当类型的新的 ImageWriteParam对象，即，如果未指定 ImageWriteParam对象将使用的那些值。
      Methods in javax.imageio with parameters of type ImageWriteParam
      Modifier and Type | 方法 | 描述
      IIOMetadata ImageTranscoder.convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可使用其文档接口或特定于将用于编码的writer插件的其他接口进行可选修改。
      abstract IIOMetadata | ImageWriter.convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      IIOMetadata ImageTranscoder.convertStreamMetadata​(IIOMetadata inData, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可使用其文档接口或特定于将用于编码的写入程序插件的其他接口进行修改。
      abstract IIOMetadata | ImageWriter.convertStreamMetadata​(IIOMetadata inData, ImageWriteParam param)
      abstract IIOMetadata ImageWriter.getDefaultImageMetadata​(ImageTypeSpecifier imageType, ImageWriteParam param)
      返回包含用于对给定类型的图像进行编码的默认值的 IIOMetadata对象。
      abstract IIOMetadata ImageWriter.getDefaultStreamMetadata​(ImageWriteParam param)
      返回包含用于编码图像流的默认值的 IIOMetadata对象。
      int ImageWriter.getNumThumbnailsSupported​(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata)
      给定图像类型以及编码期间将要使用的任何其他写入参数和元数据对象，返回由正在写入的格式支持的缩略图数。
      Dimension[] ImageWriter.getPreferredThumbnailSizes​(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata)
      返回 Dimension的数组，表示缩略图的合法尺寸范围，因为它们将被编码在输出文件或流中。
      void ImageWriter.prepareInsertEmpty​(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将未定义像素值的新图像插入到现有图像流中。
      void ImageWriter.prepareWriteEmpty​(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将一个完整的图像流写入到包含未定义像素值的单个图像和关联的元数据和缩略图中。
      void ImageWriter.replacePixels​(Raster raster, ImageWriteParam param)
      用给定的 Raster的一部分替换已经存在于输出中的图像的一部分。
      void ImageWriter.replacePixels​(RenderedImage image, ImageWriteParam param)
      用给定图像的一部分替换已经存在于输出中的图像的一部分。
      abstract void ImageWriter.write​(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param)
      将包含单个图像和关联流以及图像元数据和缩略图的完整图像流附加到输出。
      void ImageWriter.writeInsert​(int imageIndex, IIOImage image, ImageWriteParam param)
      将新图像插入到现有图像流中。
      void ImageWriter.writeToSequence​(IIOImage image, ImageWriteParam param)
      将单个图像和可能关联的元数据和缩略图附加到输出。

    • Uses of ImageWriteParam in javax.imageio.plugins.bmp

      Subclasses of ImageWriteParam in javax.imageio.plugins.bmp
      Modifier and Type Class 描述
      class  BMPImageWriteParam
      用于编码BMP格式的图像的 ImageWriteParam的子类。

    • Uses of ImageWriteParam in javax.imageio.plugins.jpeg

      Subclasses of ImageWriteParam in javax.imageio.plugins.jpeg
      Modifier and Type Class 描述
      class  JPEGImageWriteParam
      This class adds the ability to set JPEG quantization and Huffman tables when using the built-in JPEG writer plug-in, and to request that optimized Huffman tables be computed for an image.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.ImageWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.ImageWriter

  • Packages that use ImageWriter
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.event
    一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of ImageWriter in javax.imageio

      Methods in javax.imageio that return ImageWriter
      Modifier and Type 方法 描述
      static ImageWriter ImageIO.getImageWriter​(ImageReader reader)
      返回一个 ImageWriter对应于给定的 ImageReader ，如果有一个，或 null如果这个 ImageReader的插件没有指定相应的 ImageWriter ，或者如果给定的 ImageReader没有注册。
      Methods in javax.imageio that return types with arguments of type ImageWriter
      Modifier and Type 方法 描述
      static Iterator<ImageWriter> ImageIO.getImageWriters​(ImageTypeSpecifier type, String formatName)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够以给定格式对给定布局（使用 ImageTypeSpecifier指定）的图像进行编码。
      static Iterator<ImageWriter> ImageIO.getImageWritersByFormatName​(String formatName)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter ，声称能够对命名格式进行编码。
      static Iterator<ImageWriter> ImageIO.getImageWritersByMIMEType​(String MIMEType)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter ，声称能够对具有给定MIME类型的文件进行编码。
      static Iterator<ImageWriter> ImageIO.getImageWritersBySuffix​(String fileSuffix)
      返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够使用给定的后缀对文件进行编码。
      Methods in javax.imageio with parameters of type ImageWriter
      Modifier and Type 方法 描述
      static ImageReader ImageIO.getImageReader​(ImageWriter writer)
      返回一个 ImageReader对应于给定的 ImageWriter ，如果有一个，或 null如果这个 ImageWriter的插件没有指定相应的 ImageReader ，或者如果给定的 ImageWriter没有注册。
      static Iterator<ImageTranscoder> ImageIO.getImageTranscoders​(ImageReader reader, ImageWriter writer)
      返回一个 Iterator其中包含所有当前注册的 ImageTranscoder s，声称能够在给定的 ImageReader和 ImageWriter的元数据之间进行转码。

    • Uses of ImageWriter in javax.imageio.event

      Methods in javax.imageio.event with parameters of type ImageWriter
      Modifier and Type 方法 描述
      void IIOWriteProgressListener.imageComplete​(ImageWriter source)
      报告图像写入操作已完成。
      void IIOWriteProgressListener.imageProgress​(ImageWriter source, float percentageDone)
      报告相关 ImageWriter内的当前 write电话的大致完成程度。
      void IIOWriteProgressListener.imageStarted​(ImageWriter source, int imageIndex)
      报告图像写入操作开始。
      void IIOWriteProgressListener.thumbnailComplete​(ImageWriter source)
      报告缩略图写入操作已完成。
      void IIOWriteProgressListener.thumbnailProgress​(ImageWriter source, float percentageDone)
      报告相关 ImageWriter内当前缩略图写入的近似程度。
      void IIOWriteProgressListener.thumbnailStarted​(ImageWriter source, int imageIndex, int thumbnailIndex)
      报告缩略图写入操作开始。
      void IIOWriteWarningListener.warningOccurred​(ImageWriter source, int imageIndex, String warning)
      报告编码中出现非致命错误。
      void IIOWriteProgressListener.writeAborted​(ImageWriter source)
      报告写入已经通过作者的 abort方法中止。

    • Uses of ImageWriter in javax.imageio.spi

      Methods in javax.imageio.spi that return ImageWriter
      Modifier and Type 方法 描述
      ImageWriter ImageWriterSpi.createWriterInstance​()
      返回与此服务提供商关联的 ImageWriter实现的实例。
      abstract ImageWriter ImageWriterSpi.createWriterInstance​(Object extension)
      返回与此服务提供商关联的 ImageWriter实现的实例。
      Methods in javax.imageio.spi with parameters of type ImageWriter
      Modifier and Type 方法 描述
      boolean ImageWriterSpi.isOwnWriter​(ImageWriter writer)
      如果传递的 ImageWriter对象是与此服务提供商关联的 ImageWriter的实例，则返回 true 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.IIOParamController (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.IIOParamController

  • Packages that use IIOParamController
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of IIOParamController in javax.imageio

      Fields in javax.imageio declared as IIOParamController
      Modifier and Type Field 描述
      protected IIOParamController IIOParam.controller
      该 IIOParamController将用于提供此设置 IIOParam对象时 activateController方法被调用。
      protected IIOParamController IIOParam.defaultController
      当调用 activateController方法时，默认的 IIOParamController将用于为此 IIOParam对象提供设置。
      Methods in javax.imageio that return IIOParamController
      Modifier and Type 方法 描述
      IIOParamController IIOParam.getController​()
      返回当前安装的 IIOParamController 。
      IIOParamController IIOParam.getDefaultController​()
      返回默认的 IIOParamController ，如果有一个，不管当前安装的控制器。
      Methods in javax.imageio with parameters of type IIOParamController
      Modifier and Type 方法 描述
      void IIOParam.setController​(IIOParamController controller)
      设置 IIOParamController用于在调用 activateController方法时为该 IIOParam对象提供设置，覆盖任何默认控制器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.ImageTranscoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.ImageTranscoder

  • Packages that use ImageTranscoder
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of ImageTranscoder in javax.imageio

      Classes in javax.imageio that implement ImageTranscoder
      Modifier and Type Class 描述
      class  ImageWriter
      用于编码和写入图像的抽象超类。
      Methods in javax.imageio that return types with arguments of type ImageTranscoder
      Modifier and Type 方法 描述
      static Iterator<ImageTranscoder> ImageIO.getImageTranscoders​(ImageReader reader, ImageWriter writer)
      返回一个 Iterator其中包含所有当前注册的 ImageTranscoder ，声称能够在给定的 ImageReader和 ImageWriter之间的元数据之间进行转码。

    • Uses of ImageTranscoder in javax.imageio.spi

      Methods in javax.imageio.spi that return ImageTranscoder
      Modifier and Type 方法 描述
      abstract ImageTranscoder ImageTranscoderSpi.createTranscoderInstance​()
      返回与此服务提供程序相关联的 ImageTranscoder实现的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


IIOReadProgressListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.event

Interface IIOReadProgressListener

  • All Superinterfaces:
    EventListener

    public interface IIOReadProgressListener
extends EventListener
    ImageReader实现通过呼叫者通知其图像和缩略图读取进度方法的接口。

    此接口接收解码进展（经由一般指示imageProgress种thumbnailProgress指示当整个图像已经被更新（通过方法），和事件imageStarted ， imageComplete ， thumbnailStarted和thumbnailComplete方法）。 希望在发生像素更新时通知应用程序（例如，在逐行解码期间）应提供IIOReadUpdateListener 。

    另请参见：
    IIOReadUpdateListener ， ImageReader.addIIOReadProgressListener(javax.imageio.event.IIOReadProgressListener) ， ImageReader.removeIIOReadProgressListener(javax.imageio.event.IIOReadProgressListener)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void imageComplete​(ImageReader source)
      报告当前图像读取操作已完成。
      void imageProgress​(ImageReader source, float percentageDone)
      报告当前完成近似程度 read调用相关的 ImageReader 。
      void imageStarted​(ImageReader source, int imageIndex)
      报告图像读取操作开始。
      void readAborted​(ImageReader source)
      通过阅读器的 abort方法报告读取已被中止。
      void sequenceComplete​(ImageReader source)
      报告一系列读取操作已完成。
      void sequenceStarted​(ImageReader source, int minIndex)
      报告一系列读操作开始。
      void thumbnailComplete​(ImageReader source)
      报告缩略图读取操作已完成。
      void thumbnailProgress​(ImageReader source, float percentageDone)
      报告在相关 ImageReader内的当前 getThumbnail电话的大致完成程度。
      void thumbnailStarted​(ImageReader source, int imageIndex, int thumbnailIndex)
      报告缩略图读取操作开始。

    • 方法详细信息

      • sequenceStarted

        void sequenceStarted​(ImageReader source,
                     int minIndex)
        报告一系列读操作开始。 ImageReader实现都必须从他们恰好一次调用此方法readAll(Iterator)方法。
        参数
        source - 调用此方法的 ImageReader对象。
        minIndex - 要读取的第一个图像的索引。

      • sequenceComplete

        void sequenceComplete​(ImageReader source)
        报告一系列读取操作已完成。 ImageReader实现需要从其readAll(Iterator)方法调用此方法一次。
        参数
        source - 调用此方法的 ImageReader对象。

      • imageStarted

        void imageStarted​(ImageReader source,
                  int imageIndex)
        报告图像读取操作开始。 在开始图像读取操作时，所有ImageReader实现都需要调用此方法一次。
        参数
        source - 调用此方法的 ImageReader对象。
        imageIndex - 在其包含的输入文件或流中读取的映像的索引。

      • imageProgress

        void imageProgress​(ImageReader source,
                   float percentageDone)
        报告当前read通话的大致完成程度ImageReader 。

        完成程度表示为从0.0F到100.0F的百分比。 理想情况下，百分比应按剩余完成时间计算，但使用更精确定义的度量（如像素解码或部分输入流消耗）通常更为实用。 在任何情况下，在给定的读取操作期间对该方法的调用序列应该提供单调递增的百分比值序列。 不需要提供确切的值0和100 ，因为这些可以由被呼叫者从其他方法推断出来。

        每个特定的ImageReader实现可以以任何需要的频率调用此方法。 一个经验法则是将其称为每5％的标记。

        参数
        source - 这个方法的 ImageReader对象。
        percentageDone - 已完成的解码大致百分比。

      • imageComplete

        void imageComplete​(ImageReader source)
        报告当前图像读取操作已完成。 在每次图像读取操作完成后，所有ImageReader实现都需要调用此方法一次。
        参数
        source - 调用此方法的 ImageReader对象。

      • thumbnailStarted

        void thumbnailStarted​(ImageReader source,
                      int imageIndex,
                      int thumbnailIndex)
        报告缩略图读取操作开始。 所有ImageReader实现都需要在开始缩略图读取操作时调用此方法一次。
        参数
        source - 调用此方法的 ImageReader对象。
        imageIndex - 在其包含的输入文件或流中读取图像的索引。
        thumbnailIndex - 正在读取的缩略图的索引。

      • thumbnailProgress

        void thumbnailProgress​(ImageReader source,
                       float percentageDone)
        报告当前完成近似程度getThumbnail调用相关的内ImageReader 。 语义与imageProgress相同。
        参数
        source - 调用此方法的 ImageReader对象。
        percentageDone - 已完成的解码大致百分比。

      • thumbnailComplete

        void thumbnailComplete​(ImageReader source)
        报告缩略图读取操作已完成。 在每个缩略图读取操作完成后，需要所有ImageReader实现来调用此方法一次。
        参数
        source - 调用此方法的 ImageReader对象。

      • readAborted

        void readAborted​(ImageReader source)
        通过阅读器的abort方法报告读取已被中止。 不会再发出通知。
        参数
        source - 调用此方法的 ImageReader对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IIOReadUpdateListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.event

Interface IIOReadUpdateListener

  • All Superinterfaces:
    EventListener

    public interface IIOReadUpdateListener
extends EventListener
    ImageReader实现使用的接口来通知呼叫者其图像和像素更新的缩略图读取方法。
    另请参见：
    ImageReader.addIIOReadUpdateListener(javax.imageio.event.IIOReadUpdateListener) ， ImageReader.removeIIOReadUpdateListener(javax.imageio.event.IIOReadUpdateListener)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void imageUpdate​(ImageReader source, BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      报告图像的给定区域已更新。
      void passComplete​(ImageReader source, BufferedImage theImage)
      报告当前的读取操作已经完成了逐行通过。
      void passStarted​(ImageReader source, BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      报告当前读取操作即将开始逐行传递。
      void thumbnailPassComplete​(ImageReader source, BufferedImage theThumbnail)
      报告当前缩略图读取操作已经完成了逐行通过。
      void thumbnailPassStarted​(ImageReader source, BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      报告当前的缩略图读取操作即将开始逐行传递。
      void thumbnailUpdate​(ImageReader source, BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      报告缩略图的给定区域已更新。

    • 方法详细信息

      • passStarted

        void passStarted​(ImageReader source,
                 BufferedImage theImage,
                 int pass,
                 int minPass,
                 int maxPass,
                 int minX,
                 int minY,
                 int periodX,
                 int periodY,
                 int[] bands)
        报告当前读取操作即将开始逐行传递。 支持逐行编码的格式的读者应该使用它来读取逐步编码的图像时每次通过完成时通知客户端。

        将由通被更新的区域的估计值由所指示的minX ， minY ， width ，和height参数。 如果通行隔行扫描，即只更新所选行或列，则periodX和periodY参数将指示子采样的程度。 可能受影响的一组频带由bands的值bands 。

        参数
        source - 调用此方法的 ImageReader对象。
        theImage - BufferedImage正在更新。
        pass - 即将开始的通行证号码，以0开头。
        minPass - 将被解码的 minPass的索引。
        maxPass - 将被解码的最后一次通过的索引。
        minX - 最左边更新的像素列的X坐标。
        minY - 最上面更新的像素行的Y坐标。
        periodX - 更新像素之间的水平间距; 值1表示没有间隙。
        periodY - 更新像素之间的垂直间距; 值1表示没有间隙。
        bands - int s的阵列，表示可能更新的设定波段。

      • imageUpdate

        void imageUpdate​(ImageReader source,
                 BufferedImage theImage,
                 int minX,
                 int minY,
                 int width,
                 int height,
                 int periodX,
                 int periodY,
                 int[] bands)
        报告图像的给定区域已更新。 应用程序可能会选择重新显示指定的区域，例如，以提供逐行显示效果，或执行其他增量处理。

        注意，不同的图像格式读取器可以以各种不同的顺序产生解码像素。 许多读者将以简单的从上至下，从左到右的顺序生成像素，但其他可能会使用多次交错，平铺等。根据网络速度，更新的顺序甚至可能不同于呼叫。 ， 例如。 对此方法的调用并不能保证所有指定的像素实际上已被更新，只是在指定的某个子区域内发生了一些活动。

        特定的ImageReader实现可以选择提供更新的频率。 每个更新指定自上次更新以来图像的给定区域已被更新。 的区域是由它的空间边界框（描述minX ， minY ， width ，和height ）; X和Y子采样因子（ periodX和periodY ）; 和一组更新的乐队（ bands ）。 例如，更新：

          minX = 10
 minY = 20
 width = 3
 height = 4
 periodX = 2
 periodY = 3
 bands = { 1, 3 }
        将指示以下像素的频带1和3已更新：
          (10, 20) (12, 20) (14, 20)
 (10, 23) (12, 23) (14, 23)
 (10, 26) (12, 26) (14, 26)
 (10, 29) (12, 29) (14, 29)
        参数
        source - 调用此方法的 ImageReader对象。
        theImage - BufferedImage正在更新。
        minX - 最左边更新的像素列的X坐标。
        minY - 最上面更新的像素行的Y坐标。
        width - 水平更新的像素数。
        height - 垂直更新像素的数量。
        periodX - 更新像素之间的水平间距; 值1表示没有间隙。
        periodY - 更新像素之间的垂直间距; 值1表示没有间隙。
        bands - 表示正在更新哪些频带的 int的阵列。

      • passComplete

        void passComplete​(ImageReader source,
                  BufferedImage theImage)
        报告当前的读取操作已经完成了逐行通过。 支持逐行编码的格式的读者应该使用它来读取逐步编码的图像时每次通过完成时通知客户端。
        参数
        source - ImageReader对象调用此方法。
        theImage - BufferedImage正在更新。
        另请参见：
        ImageReadParam.setSourceProgressivePasses(int, int)

      • thumbnailPassStarted

        void thumbnailPassStarted​(ImageReader source,
                          BufferedImage theThumbnail,
                          int pass,
                          int minPass,
                          int maxPass,
                          int minX,
                          int minY,
                          int periodX,
                          int periodY,
                          int[] bands)
        报告当前的缩略图读取操作即将开始逐行传递。 支持逐行编码的格式的读者应该在读取逐步编码的缩略图时，使用这种方式来通知客户每次传递完成。
        参数
        source - 调用此方法的 ImageReader对象。
        theThumbnail - 正在更新的 BufferedImage缩略图。
        pass - 即将开始的通行证号码，以0开头。
        minPass - 将被解码的 minPass的索引。
        maxPass - 将被解码的最后一次通过的索引。
        minX - 最左边更新的像素列的X坐标。
        minY - 最上面更新的像素行的Y坐标。
        periodX - 更新像素之间的水平间距; 值1表示没有间隙。
        periodY - 更新像素之间的垂直间距; 值1表示没有间隙。
        bands -的阵列 int以及指示可以被更新该组条带。
        另请参见：
        passStarted(javax.imageio.ImageReader, java.awt.image.BufferedImage, int, int, int, int, int, int, int, int[])

      • thumbnailUpdate

        void thumbnailUpdate​(ImageReader source,
                     BufferedImage theThumbnail,
                     int minX,
                     int minY,
                     int width,
                     int height,
                     int periodX,
                     int periodY,
                     int[] bands)
        报告缩略图的给定区域已更新。 应用程序可能会选择重新显示指定的区域，例如，以提供逐行显示效果，或执行其他增量处理。
        参数
        source - 调用此方法的 ImageReader对象。
        theThumbnail - 正在更新的 BufferedImage缩略图。
        minX - 最左边更新的像素列的X坐标。
        minY - 最上面更新的像素行的Y坐标。
        width - 水平更新像素的数量。
        height - 垂直更新像素的数量。
        periodX - 更新像素之间的水平间距; 值1表示没有间隙。
        periodY - 更新像素之间的垂直间距; 值1表示没有间隙。
        bands - 表示正在更新哪些频带的 int s的数组。
        另请参见：
        imageUpdate(javax.imageio.ImageReader, java.awt.image.BufferedImage, int, int, int, int, int, int, int[])

      • thumbnailPassComplete

        void thumbnailPassComplete​(ImageReader source,
                           BufferedImage theThumbnail)
        报告当前缩略图读取操作已经完成了逐行通过。 支持逐行编码的格式的读者应该在读取逐步编码的缩略图时，使用这种方式来通知客户每次传递完成。
        参数
        source - 调用此方法的 ImageReader对象。
        theThumbnail - 正在更新的 BufferedImage缩略图。
        另请参见：
        passComplete(javax.imageio.ImageReader, java.awt.image.BufferedImage)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IIOReadWarningListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.event

Interface IIOReadWarningListener

  • All Superinterfaces:
    EventListener

    public interface IIOReadWarningListener
extends EventListener
    ImageReader实现使用的界面来通知呼叫者其图像和缩略图读取警告方法（非致命错误）。 致命错误导致相关的读取方法抛出一个IIOException 。

    本地化是通过将Locale与IIOReadWarningListener相关联处理的，因为它已注册ImageReader 。 提供本地化消息是由ImageReader决定的。

    另请参见：
    ImageReader.addIIOReadWarningListener(javax.imageio.event.IIOReadWarningListener) ， ImageReader.removeIIOReadWarningListener(javax.imageio.event.IIOReadWarningListener)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void warningOccurred​(ImageReader source, String warning)
      报告解码中出现非致命错误。

    • 方法详细信息

      • warningOccurred

        void warningOccurred​(ImageReader source,
                     String warning)
        报告解码中出现非致命错误。 在调用此方法后，解码将继续。 应用程序可能会选择显示对话框，将警告打印到控制台，忽略警告或采取任何其他选择的操作。
        参数
        source - 调用此方法的 ImageReader对象。
        warning - a String containing the warning.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IIOWriteProgressListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.event

Interface IIOWriteProgressListener

  • All Superinterfaces:
    EventListener

    public interface IIOWriteProgressListener
extends EventListener
    ImageWriter实现使用的接口通知呼叫者他们的图像写入方法的进度。
    另请参见：
    ImageWriter.write(javax.imageio.metadata.IIOMetadata, javax.imageio.IIOImage, javax.imageio.ImageWriteParam)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void imageComplete​(ImageWriter source)
      报告图像写入操作已完成。
      void imageProgress​(ImageWriter source, float percentageDone)
      报告当前完成近似程度 write调用相关的内 ImageWriter 。
      void imageStarted​(ImageWriter source, int imageIndex)
      报告图像写入操作开始。
      void thumbnailComplete​(ImageWriter source)
      报告缩略图写入操作已完成。
      void thumbnailProgress​(ImageWriter source, float percentageDone)
      报告相关 ImageWriter内当前缩略图写入的完成程度。
      void thumbnailStarted​(ImageWriter source, int imageIndex, int thumbnailIndex)
      报告缩略图写入操作开始。
      void writeAborted​(ImageWriter source)
      报告写入已经通过作者的 abort方法中止。

    • 方法详细信息

      • imageStarted

        void imageStarted​(ImageWriter source,
                  int imageIndex)
        报告图像写入操作开始。 在开始图像写入操作时，所有ImageWriter实现都需要调用此方法一次。
        参数
        source - 调用此方法的 ImageWriter对象。
        imageIndex - 图像的索引被写入其包含的输入文件或流中。

      • imageProgress

        void imageProgress​(ImageWriter source,
                   float percentageDone)
        报告当前完成近似程度write调用相关的内ImageWriter 。

        完成度表示为指示正在写入哪个图像的指标，并且从0.0F变为100.0F的百分比表示当前图像的输出量。 理想情况下，百分比应按剩余完成时间计算，但使用更精确定义的度量（如像素解码或部分输入流消耗）通常更为实用。 在任何情况下，在给定的读取操作期间对该方法的调用序列应该提供单调递增的百分比值序列。 没有必要提供确切的值0和100 ，因为这些可以由被呼叫者从其他方法推断出来。

        每个特定的ImageWriter实现可以以任何需要的频率调用此方法。 一个经验法则是将其称为每5％的标记。

        参数
        source - 调用此方法的 ImageWriter对象。
        percentageDone - 已完成的解码大致百分比。

      • imageComplete

        void imageComplete​(ImageWriter source)
        报告图像写入操作已完成。 所有ImageWriter实现都需要在每次图像写入操作完成后调用此方法一次。
        参数
        source - 调用此方法的 ImageWriter对象。

      • thumbnailStarted

        void thumbnailStarted​(ImageWriter source,
                      int imageIndex,
                      int thumbnailIndex)
        报告缩略图写入操作开始。 在开始缩略图写入操作时，所有ImageWriter实现都需要调用此方法一次。
        参数
        source - 调用此方法的 ImageWrite对象。
        imageIndex - 图像的索引在其包含的输入文件或流中被写入。
        thumbnailIndex - 正在写入缩略图的索引。

      • thumbnailProgress

        void thumbnailProgress​(ImageWriter source,
                       float percentageDone)
        报告相关ImageWriter内当前缩略图写入的近似程度。 语义与imageProgress相同。
        参数
        source - 调用此方法的 ImageWriter对象。
        percentageDone - 已完成的解码大致百分比。

      • thumbnailComplete

        void thumbnailComplete​(ImageWriter source)
        报告缩略图写入操作已完成。 所有ImageWriter实现都需要在完成每个缩略图写入操作时调用此方法一次。
        参数
        source - 调用此方法的 ImageWriter对象。

      • writeAborted

        void writeAborted​(ImageWriter source)
        报告写入已经通过作者的abort方法中止。 不会再发出通知。
        参数
        source - 调用此方法的 ImageWriter对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IIOWriteWarningListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.event

Interface IIOWriteWarningListener

  • All Superinterfaces:
    EventListener

    public interface IIOWriteWarningListener
extends EventListener
    ImageWriter实现的接口通知呼叫者他们的图像和缩略图读取警告方法（非致命错误）。 致命错误导致相关的读取方法抛出一个IIOException 。

    本地化是通过将Locale与每个IIOWriteWarningListener相关联处理的，因为它注册了一个ImageWriter 。 提供本地化的消息是ImageWriter 。

    另请参见：
    ImageWriter.addIIOWriteWarningListener(javax.imageio.event.IIOWriteWarningListener) ， ImageWriter.removeIIOWriteWarningListener(javax.imageio.event.IIOWriteWarningListener)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void warningOccurred​(ImageWriter source, int imageIndex, String warning)
      报告编码中出现非致命错误。

    • 方法详细信息

      • warningOccurred

        void warningOccurred​(ImageWriter source,
                     int imageIndex,
                     String warning)
        报告编码中出现非致命错误。 调用此方法后，编码将继续。 应用程序可能会选择显示对话框，将警告打印到控制台，忽略警告或采取任何其他选择的操作。
        参数
        source - ImageWriter对象调用此方法。
        imageIndex - 生成警告的图像的索引，从0开始。
        warning - 一个包含警告的 String 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.imageio.event (Java SE 9 & JDK 9 )

javax.imageio.event

Interfaces

  • IIOReadProgressListener
  • IIOReadUpdateListener
  • IIOReadWarningListener
  • IIOWriteProgressListener
  • IIOWriteWarningListener


javax.imageio.event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package javax.imageio.event

一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。

IIOReadProgressListener界面允许通知已成功读取的图像的百分比。

IIOReadUpdateListener接口允许通知已读取的图像部分。 这对于在加载图像时实现动态显示是有用的。

IIOReadWarningListener接口允许在阅读期间通知非致命错误。

IIOWriteWarningListener和IIOWriteProgressListener接口为IIOWriteProgressListener程序执行类似的功能。

从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    IIOReadProgressListener
    ImageReader实现使用的界面来通知呼叫者他们的图像和缩略图读取进度方法。
    IIOReadUpdateListener
    通过 ImageReader实现来通知呼叫者他们的图像和缩略图读取像素更新方法的接口。
    IIOReadWarningListener
    ImageReader
    IIOWriteProgressListener
    由 ImageWriter实现使用的接口通知呼叫者他们的图像写入方法的进度。
    IIOWriteWarningListener
    ImageWriter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.imageio.event Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.imageio.event

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • java.util.EventListener
    • javax.imageio.event.IIOReadProgressListener
    • javax.imageio.event.IIOReadUpdateListener
    • javax.imageio.event.IIOReadWarningListener
    • javax.imageio.event.IIOWriteProgressListener
    • javax.imageio.event.IIOWriteWarningListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package javax.imageio.event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.imageio.event

  • Packages that use javax.imageio.event
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
  • Classes in javax.imageio.event used by javax.imageio
    Class 描述
    IIOReadProgressListener
    ImageReader实现使用的界面来通知呼叫者他们的图像和缩略图读取进度方法。
    IIOReadUpdateListener
    ImageReader实现使用的界面来通知呼叫者他们的图像和缩略图读取像素更新方法。
    IIOReadWarningListener
    通过 ImageReader实现通知呼叫者其图像和缩略图读取警告方法（非致命错误）的界面。
    IIOWriteProgressListener
    ImageWriter实现的接口通知呼叫者他们的图像写入方法的进度。
    IIOWriteWarningListener
    ImageWriter实现使用的界面来通知呼叫者他们的图像和缩略图读取警告方法（非致命错误）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.event.IIOReadProgressListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.event.IIOReadProgressListener

  • Packages that use IIOReadProgressListener
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of IIOReadProgressListener in javax.imageio

      Fields in javax.imageio with type parameters of type IIOReadProgressListener
      Modifier and Type Field 描述
      protected List<IIOReadProgressListener> ImageReader.progressListeners
      A List当前注册的 IIOReadProgressListener s，默认初始化为 null ，这是一个空的 List代名词。
      Methods in javax.imageio with parameters of type IIOReadProgressListener
      Modifier and Type 方法 描述
      void ImageReader.addIIOReadProgressListener​(IIOReadProgressListener listener)
      在注册进度监听器列表中添加一个 IIOReadProgressListener 。
      void ImageReader.removeIIOReadProgressListener​(IIOReadProgressListener listener)
      从注册进度侦听器列表中删除 IIOReadProgressListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.event.IIOReadUpdateListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.event.IIOReadUpdateListener

  • Packages that use IIOReadUpdateListener
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of IIOReadUpdateListener in javax.imageio

      Fields in javax.imageio with type parameters of type IIOReadUpdateListener
      Modifier and Type Field 描述
      protected List<IIOReadUpdateListener> ImageReader.updateListeners
      A List目前注册的 IIOReadUpdateListener ，默认初始化为 null ，这是一个空的 List同义词。
      Methods in javax.imageio with parameters of type IIOReadUpdateListener
      Modifier and Type 方法 描述
      void ImageReader.addIIOReadUpdateListener​(IIOReadUpdateListener listener)
      将 IIOReadUpdateListener添加到注册的更新监听器列表中。
      void ImageReader.removeIIOReadUpdateListener​(IIOReadUpdateListener listener)
      从注册的更新监听器列表中删除 IIOReadUpdateListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.event.IIOReadWarningListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.event.IIOReadWarningListener

  • Packages that use IIOReadWarningListener
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of IIOReadWarningListener in javax.imageio

      Fields in javax.imageio with type parameters of type IIOReadWarningListener
      Modifier and Type Field 描述
      protected List<IIOReadWarningListener> ImageReader.warningListeners
      A List当前注册的 IIOReadWarningListener s，默认初始化为 null ，这是一个空的 List同义词。
      Methods in javax.imageio with parameters of type IIOReadWarningListener
      Modifier and Type 方法 描述
      void ImageReader.addIIOReadWarningListener​(IIOReadWarningListener listener)
      将 IIOReadWarningListener添加到已注册警告侦听器的列表中。
      void ImageReader.removeIIOReadWarningListener​(IIOReadWarningListener listener)
      从注册的错误侦听器列表中删除一个 IIOReadWarningListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.event.IIOWriteProgressListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.event.IIOWriteProgressListener

  • Packages that use IIOWriteProgressListener
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of IIOWriteProgressListener in javax.imageio

      Fields in javax.imageio with type parameters of type IIOWriteProgressListener
      Modifier and Type Field 描述
      protected List<IIOWriteProgressListener> ImageWriter.progressListeners
      A List目前注册的 IIOWriteProgressListener s，默认初始化为 null ，这是一个空的 List代名词。
      Methods in javax.imageio with parameters of type IIOWriteProgressListener
      Modifier and Type 方法 描述
      void ImageWriter.addIIOWriteProgressListener​(IIOWriteProgressListener listener)
      在注册进度监听器列表中添加一个 IIOWriteProgressListener 。
      void ImageWriter.removeIIOWriteProgressListener​(IIOWriteProgressListener listener)
      从注册进度侦听器列表中删除 IIOWriteProgressListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.event.IIOWriteWarningListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.event.IIOWriteWarningListener

  • Packages that use IIOWriteWarningListener
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of IIOWriteWarningListener in javax.imageio

      Fields in javax.imageio with type parameters of type IIOWriteWarningListener
      Modifier and Type Field 描述
      protected List<IIOWriteWarningListener> ImageWriter.warningListeners
      A List目前注册的 IIOWriteWarningListener s，默认初始化为 null ，这是一个空的 List代名词。
      Methods in javax.imageio with parameters of type IIOWriteWarningListener
      Modifier and Type 方法 描述
      void ImageWriter.addIIOWriteWarningListener​(IIOWriteWarningListener listener)
      将 IIOWriteWarningListener添加到已注册警告监听器的列表中。
      void ImageWriter.removeIIOWriteWarningListener​(IIOWriteWarningListener listener)
      从注册的警告监听器列表中删除 IIOWriteWarningListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


IIOInvalidTreeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.metadata

Class IIOInvalidTreeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.imageio.IIOException
            • javax.imageio.metadata.IIOInvalidTreeException
  • All Implemented Interfaces:
    Serializable

    public class IIOInvalidTreeException
extends IIOException
    一个IIOInvalidTreeException当被试图抛出IIOMetadata对象来解析树IIOMetadataNode小号失败。 可能存储导致解析错误的节点。 与任何解析错误一样，实际错误可能发生在与检测到错误的不同点。 getOffendingNode返回的节点只能被视为问题的实际性质的线索。
    另请参见：
    IIOMetadata.setFromTree(java.lang.String, org.w3c.dom.Node) ， IIOMetadata.mergeTree(java.lang.String, org.w3c.dom.Node) ， IIOMetadataNode ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Node offendingNode
      Node导致解析错误，或者是 null 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      IIOInvalidTreeException​(String message, Throwable cause, Node offendingNode)
      构造一个 IIOInvalidTreeException与消息字符串，来导致此异常的异常的参考，并以参考 Node导致解析错误。
      IIOInvalidTreeException​(String message, Node offendingNode)
      构造一个 IIOInvalidTreeException其中包含一条消息字符串，并引用了导致解析错误的 Node 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Node getOffendingNode​()
      返回导致解析错误的 Node 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 字段详细信息

      • offendingNode

        protected Node offendingNode
        该 Node ，导致了解析错误，或 null 。

    • 构造方法详细信息

      • IIOInvalidTreeException

        public IIOInvalidTreeException​(String message,
                               Node offendingNode)
        构造一个 IIOInvalidTreeException其中包含一条消息字符串，并引用了导致解析错误的 Node 。
        参数
        message - a String包含解析失败的原因。
        offendingNode - 导致异常的DOM Node ，或 null 。

      • IIOInvalidTreeException

        public IIOInvalidTreeException​(String message,
                               Throwable cause,
                               Node offendingNode)
        构造一个 IIOInvalidTreeException与消息字符串，来导致此异常的异常的参考，并以参考 Node导致解析错误。
        参数
        message - a String包含解析失败的原因。
        cause - 导致该异常发生的 Throwable （ Error或 异常 ）或 null 。
        offendingNode - 导致异常的DOM Node ，或 null 。

    • 方法详细信息

      • getOffendingNode

        public Node getOffendingNode​()
        返回导致解析错误的 Node 。
        结果
        有罪的 Node 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


IIOMetadata (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.metadata

Class IIOMetadata

  • java.lang.Object
    • javax.imageio.metadata.IIOMetadata

  • public abstract class IIOMetadata
extends Object
    由与图像和流相关联的元数据（非图像数据）的对象扩展的抽象类。 插件表示使用不透明的插件特定对象的元数据。 然而，这些对象提供了访问其内部信息的能力，作为支持XML DOM接口的IIOMetadataNode对象以及用于存储非文本数据和检索有关法律数据值的信息的附加接口。 这种树的格式依赖于插件，但插件可能选择支持下述插件中性格式。 单个插件可以支持多个元数据格式，其名称可以通过调用getMetadataFormatNames来确定。 该插件还可以支持被称为“本地”格式的单一特殊格式，其被设计为无损地对其元数据进行编码。 这种格式通常将专门设计为使用特定的文件格式，以便可以以相同的格式加载和保存图像，而不会丢失元数据，但对于不同的图像在ImageReader和ImageWriter之间传输元数据可能不太有用格式。 要像图像文件格式一样无损地转换两种本机格式，必须使用ImageTranscoder对象。
    另请参见：
    ImageReader.getImageMetadata(int) ， ImageReader.getStreamMetadata() ， ImageReader.readAll(int, javax.imageio.ImageReadParam) ， ImageWriter.getDefaultStreamMetadata(javax.imageio.ImageWriteParam) ， ImageWriter.getDefaultImageMetadata(javax.imageio.ImageTypeSpecifier, javax.imageio.ImageWriteParam) ， ImageWriter.write(javax.imageio.metadata.IIOMetadata, javax.imageio.IIOImage, javax.imageio.ImageWriteParam) ， ImageWriter.convertImageMetadata(javax.imageio.metadata.IIOMetadata, javax.imageio.ImageTypeSpecifier, javax.imageio.ImageWriteParam) ， ImageWriter.convertStreamMetadata(javax.imageio.metadata.IIOMetadata, javax.imageio.ImageWriteParam) ， IIOImage ， ImageTranscoder

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected IIOMetadataController controller
      该 IIOMetadataController将用于提供此设置 IIOMetadata对象时 activateController方法被调用。
      protected IIOMetadataController defaultController
      一个 IIOMetadataController被建议用作控制器此 IIOMetadata对象。
      protected String[] extraMetadataFormatClassNames
      实现 IIOMetadataFormat的类的名称数组，并表示此插件支持的标准和本地格式的元数据格式，初始化为 null并通过构造函数进行设置。
      protected String[] extraMetadataFormatNames
      该插件支持的格式数组，不包括标准格式和原生格式，初始化为 null并通过构造函数进行设置。
      protected String nativeMetadataFormatClassName
      实现 IIOMetadataFormat并表示原生元数据格式的类的名称，初始化为 null并通过构造函数设置。
      protected String nativeMetadataFormatName
      该对象的本机元数据格式的名称，初始化为 null并通过构造函数进行设置。
      protected boolean standardFormatSupported
      一个布尔值，指示具体子类是否支持通过构造函数设置的标准元数据格式。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected IIOMetadata​()
      构造一个空的 IIOMetadata对象。
      protected IIOMetadata​(boolean standardMetadataFormatSupported, String nativeMetadataFormatName, String nativeMetadataFormatClassName, String[] extraMetadataFormatNames, String[] extraMetadataFormatClassNames)
      构造具有给定格式名称和格式类名的 IIOMetadata对象，以及指示是否支持标准格式的布尔值。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean activateController​()
      激活此 IIOMetadata对象的已安装的 IIOMetadataController ，并返回结果值。
      abstract Node getAsTree​(String formatName)
      根据给定元数据格式定义的约定，返回一个XML DOM Node对象，该对象表示该对象中包含的元数据树的根。
      IIOMetadataController getController​()
      返回当前安装的 IIOMetadataController 。
      IIOMetadataController getDefaultController​()
      返回默认的 IIOMetadataController ，如果有一个，不管当前安装的控制器。
      String[] getExtraMetadataFormatNames​()
      返回的数组 String含的附加的元数据格式，比天然和标准格式，此插件中的识别名字小号 getAsTree ， setFromTree ，和 mergeTree方法。
      IIOMetadataFormat getMetadataFormat​(String formatName)
      返回一个 IIOMetadataFormat对象描述给定的元数据格式，或 null如果没有可用的描述。
      String[] getMetadataFormatNames​()
      返回数组 String包含的所有元数据格式的名称，包括本地和标准格式，通过此插件的认为科学 getAsTree ， setFromTree ，并 mergeTree方法。
      String getNativeMetadataFormatName​()
      返回此插件的“本机”元数据格式的名称，通常允许以该插件处理的格式存储的元数据进行无损编码和传输。
      protected IIOMetadataNode getStandardChromaNode​()
      返回 IIOMetadataNode表示标准的色度信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode getStandardCompressionNode​()
      返回 IIOMetadataNode表示标准的压缩信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode getStandardDataNode​()
      返回 IIOMetadataNode表示标准的数据格式信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode getStandardDimensionNode​()
      返回 IIOMetadataNode表示标准的尺寸信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode getStandardDocumentNode​()
      返回 IIOMetadataNode表示标准的文档信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode getStandardTextNode​()
      返回 IIOMetadataNode表示标准的文字信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode getStandardTileNode​()
      返回 IIOMetadataNode表示标准的平铺信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode getStandardTransparencyNode​()
      返回 IIOMetadataNode表示标准的透明度信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode getStandardTree​()
      根据标准 javax_imageio_1.0元数据格式的约定，返回表示包含在该对象内的元数据的一个 IIOMetadataNode的树的实用方法。
      boolean hasController​()
      如果为此 IIOMetadata对象安装了控制器，则返回 true 。
      abstract boolean isReadOnly​()
      返回 true如果此对象不支持 mergeTree ， setFromTree ，并 reset方法。
      boolean isStandardMetadataFormatSupported​()
      返回 true如果标准元数据格式是由支持 getMetadataFormat ， getAsTree ， setFromTree ，并 mergeTree 。
      abstract void mergeTree​(String formatName, Node root)
      从XML DOM Node的树中更改此 IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。
      abstract void reset​()
      将此对象中存储的所有数据重置为默认值，通常是在构建后立即处于该对象的状态，尽管精确的语义是插件特定的。
      void setController​(IIOMetadataController controller)
      设置 IIOMetadataController被用来提供用于此设置 IIOMetadata对象时 activateController方法被调用时，重写所有默认控制器。
      void setFromTree​(String formatName, Node root)
      从XML DOM Node的树中设置此 IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • standardFormatSupported

        protected boolean standardFormatSupported
        一个布尔值，指示具体子类是否支持通过构造函数设置的标准元数据格式。

      • nativeMetadataFormatName

        protected String nativeMetadataFormatName
        此对象的本机元数据格式的名称，初始化为 null并通过构造函数设置。

      • nativeMetadataFormatClassName

        protected String nativeMetadataFormatClassName
        实现 IIOMetadataFormat并表示原生元数据格式的类的名称，初始化为 null并通过构造函数设置。

      • extraMetadataFormatNames

        protected String[] extraMetadataFormatNames
        该插件支持的格式名称不同于标准和本机格式，初始化为 null并通过构造函数进行设置。

      • extraMetadataFormatClassNames

        protected String[] extraMetadataFormatClassNames
        实现 IIOMetadataFormat的类的名称数组，并表示该插件支持的标准和本机格式之外的元数据格式，初始化为 null并通过构造函数进行设置。

      • defaultController

        protected IIOMetadataController defaultController
        一个IIOMetadataController被建议用作控制器此IIOMetadata对象。 它可以通过getDefaultController检索。 要安装默认控制器，请致电setController(getDefaultController()) 。 这个实例变量应该由子类设置，它们选择提供自己的默认控制器（通常是GUI）来设置参数。
        另请参见：
        IIOMetadataController ， getDefaultController()

      • controller

        protected IIOMetadataController controller
        该IIOMetadataController将用于提供此设置IIOMetadata对象时activateController方法被调用。 该值覆盖任何默认控制器，即使是null 。
        另请参见：
        IIOMetadataController ， setController(IIOMetadataController) ， hasController() ， activateController()

    • 构造方法详细信息

      • IIOMetadata

        protected IIOMetadata​()
        构造一个空的IIOMetadata对象。 子类负责为所有受保护的实例变量提供值，这些变量将允许任何未被覆盖的方法的默认实现来满足他们的合同。 例如， extraMetadataFormatNames不应该有0。

      • IIOMetadata

        protected IIOMetadata​(boolean standardMetadataFormatSupported,
                      String nativeMetadataFormatName,
                      String nativeMetadataFormatClassName,
                      String[] extraMetadataFormatNames,
                      String[] extraMetadataFormatClassNames)
        构造具有给定格式名称和格式类名称的IIOMetadata对象，以及指示是否支持标准格式的布尔值。

        此构造函数不会尝试检查类名的有效性。 无效的类名称可能会在以后的调用中产生异常getMetadataFormat 。

        参数
        standardMetadataFormatSupported - true如果此对象可以使用标准元数据格式返回或接受DOM树。
        nativeMetadataFormatName - 原生元数据格式的名称，如 String ，如果没有本机格式， null 。
        nativeMetadataFormatClassName - 本机元数据格式的类的名称，如果没有本机格式， null 。
        extraMetadataFormatNames - 表示此对象支持的其他格式的 String s的数组，如果没有， null 。
        extraMetadataFormatClassNames -的阵列 String以及指示由该对象，或支持的其他任何格式的类名称 null如果有没有。
        异常
        IllegalArgumentException - 如果 extraMetadataFormatNames长度为0。
        IllegalArgumentException - 如果 extraMetadataFormatNames和 extraMetadataFormatClassNames既不都是 null ，也不是相同的长度。

    • 方法详细信息

      • isStandardMetadataFormatSupported

        public boolean isStandardMetadataFormatSupported​()
        返回true如果标准元数据格式是由支持getMetadataFormat ， getAsTree ， setFromTree ，并mergeTree 。

        默认实现返回值为standardFormatSupported实例变量。

        结果
        如果支持标准元数据格式，则为 true 。
        另请参见：
        getAsTree(java.lang.String) ，
setFromTree(java.lang.String, org.w3c.dom.Node) ，
mergeTree(java.lang.String, org.w3c.dom.Node) ，
getMetadataFormat(java.lang.String)

      • isReadOnly

        public abstract boolean isReadOnly​()
        返回 true如果此对象不支持 mergeTree ， setFromTree ，并 reset方法。
        结果
        如果这个 IIOMetadata对象无法修改， IIOMetadata true。

      • getNativeMetadataFormatName

        public String getNativeMetadataFormatName​()
        返回此插件的“本机”元数据格式的名称，通常允许以该插件处理的格式存储的元数据进行无损编码和传输。 如果不支持这样的格式，将返回null 。

        “本机”元数据格式的结构和内容由创建此IIOMetadata对象的插件定义。 简单格式的插件通常会为根创建一个虚拟节点，然后创建一系列表示各个标签，块或关键字/值对的子节点。 插件可以选择是否记录其本机格式。

        默认实现返回值为nativeMetadataFormatName实例变量。

        结果
        原生格式的名称，或 null 。
        另请参见：
        getExtraMetadataFormatNames() ， getMetadataFormatNames()

      • getExtraMetadataFormatNames

        public String[] getExtraMetadataFormatNames​()
        返回的数组String含的附加的元数据格式，比天然和标准格式，此插件中的识别名字小号getAsTree ， setFromTree ，和mergeTree方法。 如果没有这样的附加格式，则返回null 。

        默认实现返回一个extraMetadataFormatNames实例变量的克隆。

        结果
        String的长度至少为1的数组，或 null 。
        另请参见：
        getAsTree(java.lang.String) ，
setFromTree(java.lang.String, org.w3c.dom.Node) ，
mergeTree(java.lang.String, org.w3c.dom.Node) ，
getNativeMetadataFormatName() ，
getMetadataFormatNames()

      • getMetadataFormatNames

        public String[] getMetadataFormatNames​()
        返回数组String包含的所有元数据格式的名称，包括本地和标准格式，通过此插件的认为科学getAsTree ， setFromTree ，并mergeTree方法。 如果没有这样的格式，则返回null 。

        默认实现调用getNativeMetadataFormatName ， isStandardMetadataFormatSupported ，并getExtraMetadataFormatNames并返回合并后的结果。

        结果
        一个 String的阵列。
        另请参见：
        getNativeMetadataFormatName() ，
isStandardMetadataFormatSupported() ，
getExtraMetadataFormatNames()

      • getMetadataFormat

        public IIOMetadataFormat getMetadataFormat​(String formatName)
        返回一个IIOMetadataFormat对象描述给定的元数据格式，或null如果没有可用的描述。 提供的名称必须是getMetadataFormatNames返回的其中一个（ 即 ，本机格式名称，标准格式名称或由getExtraMetadataFormatNames返回的其中一个）。

        默认实现根据全局标准元数据格式名称检查名称，如果支持该格式则返回该格式。 否则，它会检查本机格式名称，后跟任何其他格式名称。 如果找到匹配项，它会根据IIOMetadataFormat从nativeMetadataFormatClassName或extraMetadataFormatClassNames检索IIOMetadataFormat类的名称，并使用其getInstance方法构建该类的实例。

        参数
        formatName - 所需的元数据格式。
        结果
        一个 IIOMetadataFormat对象。
        异常
        IllegalArgumentException - 如果 formatName是 null或不是插件识别的名称之一。
        IllegalStateException - 如果与格式名称对应的类无法加载。

      • getAsTree

        public abstract Node getAsTree​(String formatName)
        根据给定的元数据格式定义的约定，返回一个XML DOM Node对象，该对象表示该对象中包含的元数据树的根。

        可以使用getMetadataFormatNames方法查询可用元数据格式的名称。

        参数
        formatName - 所需的元数据格式。
        结果
        形成树的根的XML DOM Node对象。
        异常
        IllegalArgumentException - 如果 formatName是 null或不是由 getMetadataFormatNames返回的名称 getMetadataFormatNames 。
        另请参见：
        getMetadataFormatNames() ，
setFromTree(java.lang.String, org.w3c.dom.Node) ，
mergeTree(java.lang.String, org.w3c.dom.Node)

      • mergeTree

        public abstract void mergeTree​(String formatName,
                               Node root)
                        throws IIOInvalidTreeException
        从XML DOM Node的树中更改此IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。 之前的状态仅在必要时被改变以适应给定树中存在的节点。 如果树结构或内容无效，将抛出IIOInvalidTreeException 。

        由于树或子树可能与另一棵树合并的语义完全是格式特定的，插件作者可以以任何最适合格式的方式实现此方法，包括简单地将所有现有状态替换为给定树。

        参数
        formatName - 所需的元数据格式。
        root - 形成树根的XML DOM Node对象。
        异常
        IllegalStateException - 如果此对象是只读的。
        IllegalArgumentException - 如果 formatName是 null或不是由 getMetadataFormatNames返回的名称 getMetadataFormatNames 。
        IllegalArgumentException - 如果 root是 null 。
        IIOInvalidTreeException - 如果无法使用给定格式的规则成功解析树。
        另请参见：
        getMetadataFormatNames() ，
getAsTree(java.lang.String) ，
setFromTree(java.lang.String, org.w3c.dom.Node)

      • getStandardChromaNode

        protected IIOMetadataNode getStandardChromaNode​()
        返回IIOMetadataNode表示标准的色度信息javax_imageio_1.0元数据格式，或null如果没有这样的信息是可用的。 该方法旨在由公用程序getStandardTree 。

        默认实现返回null 。

        如果子类希望支持标准元数据格式，则子类应该重写此方法以生成适当的子树。

        结果
        一个 IIOMetadataNode ，或 null 。
        另请参见：
        getStandardTree()

      • getStandardCompressionNode

        protected IIOMetadataNode getStandardCompressionNode​()
        返回IIOMetadataNode表示标准的压缩信息javax_imageio_1.0元数据格式，或null如果没有这样的信息是可用的。 该方法意图由实用程序getStandardTree 。

        默认实现返回null 。

        如果子类希望支持标准元数据格式，则子类应该重写此方法以生成适当的子树。

        结果
        一个 IIOMetadataNode ，或 null 。
        另请参见：
        getStandardTree()

      • getStandardDataNode

        protected IIOMetadataNode getStandardDataNode​()
        返回IIOMetadataNode表示标准的数据格式信息javax_imageio_1.0元数据格式，或null如果没有这样的信息是可用的。 该方法旨在由公用程序getStandardTree 。

        默认实现返回null 。

        如果子类希望支持标准元数据格式，则子类应该重写此方法以生成适当的子树。

        结果
        一个 IIOMetadataNode或 null 。
        另请参见：
        getStandardTree()

      • getStandardDimensionNode

        protected IIOMetadataNode getStandardDimensionNode​()
        返回IIOMetadataNode表示标准的尺寸信息javax_imageio_1.0元数据格式，或null如果没有这样的信息是可用的。 该方法意图由公用程序getStandardTree 。

        默认实现返回null 。

        如果子类希望支持标准元数据格式，则子类应该重写此方法以生成适当的子树。

        结果
        一个 IIOMetadataNode ，或 null 。
        另请参见：
        getStandardTree()

      • getStandardDocumentNode

        protected IIOMetadataNode getStandardDocumentNode​()
        返回IIOMetadataNode表示标准的文档信息javax_imageio_1.0元数据格式，或null如果没有这样的信息是可用的。 该方法旨在由公用程序getStandardTree 。

        默认实现返回null 。

        如果子类希望支持标准元数据格式，则子类应该重写此方法以生成适当的子树。

        结果
        一个 IIOMetadataNode或 null 。
        另请参见：
        getStandardTree()

      • getStandardTextNode

        protected IIOMetadataNode getStandardTextNode​()
        返回IIOMetadataNode表示标准的文字信息javax_imageio_1.0元数据格式，或null如果没有这样的信息是可用的。 该方法旨在由效用程序getStandardTree 。

        默认实现返回null 。

        如果子类希望支持标准元数据格式，则子类应该重写此方法以生成适当的子树。

        结果
        一个 IIOMetadataNode或 null 。
        另请参见：
        getStandardTree()

      • getStandardTileNode

        protected IIOMetadataNode getStandardTileNode​()
        返回IIOMetadataNode表示标准的平铺信息javax_imageio_1.0元数据格式，或null如果没有这样的信息是可用的。 该方法旨在由效用程序getStandardTree 。

        默认实现返回null 。

        如果子类希望支持标准元数据格式，则子类应该重写此方法以生成适当的子树。

        结果
        一个 IIOMetadataNode或 null 。
        另请参见：
        getStandardTree()

      • getStandardTransparencyNode

        protected IIOMetadataNode getStandardTransparencyNode​()
        返回IIOMetadataNode表示标准的透明度信息javax_imageio_1.0元数据格式，或null如果没有这样的信息是可用的。 该方法旨在由实用程序getStandardTree 。

        默认实现返回null 。

        如果子类希望支持标准元数据格式，则子类应该重写此方法以生成适当的子树。

        结果
        一个 IIOMetadataNode ，或 null 。

      • getStandardTree

        protected final IIOMetadataNode getStandardTree​()
        根据标准javax_imageio_1.0元数据格式的约定，返回表示包含在该对象内的元数据的一个IIOMetadataNode的树的实用方法。

        该方法调用各种getStandard*Node方法来提供根源于根节点子节点的每个子树。 如果这些方法中的任何一个返回null ，相应的子树将被省略。 如果全部返回null ，将返回由单个根节点组成的树。

        结果
        一个 IIOMetadataNode表示 javax_imageio_1.0格式的元数据树的根。
        另请参见：
        getStandardChromaNode() ，
getStandardCompressionNode() ，
getStandardDataNode() ，
getStandardDimensionNode() ，
getStandardDocumentNode() ，
getStandardTextNode() ，
getStandardTileNode() ，
getStandardTransparencyNode()

      • setFromTree

        public void setFromTree​(String formatName,
                        Node root)
                 throws IIOInvalidTreeException
        从XML DOM Node的树中设置此IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。 以前的状态被丢弃。 如果树的结构或内容无效，将抛出一个IIOInvalidTreeException 。

        默认实现调用reset后跟mergeTree(formatName, root) 。

        参数
        formatName - 所需的元数据格式。
        root - 形成树根的XML DOM Node对象。
        异常
        IllegalStateException - 如果此对象是只读的。
        IllegalArgumentException - 如果 formatName是 null或不是由 getMetadataFormatNames返回的名称 getMetadataFormatNames 。
        IllegalArgumentException - 如果 root是 null 。
        IIOInvalidTreeException - 如果不能使用给定格式的规则成功解析树。
        另请参见：
        getMetadataFormatNames() ，
getAsTree(java.lang.String) ，
mergeTree(java.lang.String, org.w3c.dom.Node)

      • reset

        public abstract void reset​()
        将此对象中存储的所有数据重置为默认值，通常是在构建后立即处于该对象的状态，尽管精确的语义是插件特定的。 请注意，有很多可能的默认值，具体取决于对象的创建方式。
        异常
        IllegalStateException - 如果此对象是只读的。
        另请参见：
        ImageReader.getStreamMetadata() ，
ImageReader.getImageMetadata(int) ，
ImageWriter.getDefaultStreamMetadata(javax.imageio.ImageWriteParam) ，
ImageWriter.getDefaultImageMetadata(javax.imageio.ImageTypeSpecifier, javax.imageio.ImageWriteParam)

      • setController

        public void setController​(IIOMetadataController controller)
        设置IIOMetadataController被用来提供用于此设置IIOMetadata对象时activateController方法被调用时，重写所有默认控制器。 如果参数为null ，则不会使用任何控制器，包括任何默认值。 要恢复默认值，请使用setController(getDefaultController()) 。

        默认实现将controller实例变量设置为提供的值。

        参数
        controller - 适当的 IIOMetadataController或 null 。
        另请参见：
        IIOMetadataController ， getController() ， getDefaultController() ， hasController() ， activateController()

      • getController

        public IIOMetadataController getController​()
        返回当前安装的IIOMetadataController 。 这可能是默认的，如果有一个， null ，或者最近通话的说法setController 。

        默认实现返回controller实例变量的值。

        结果
        目前安装的是 IIOMetadataController ，或 null 。
        另请参见：
        IIOMetadataController ， setController(javax.imageio.metadata.IIOMetadataController) ， getDefaultController() ， hasController() ， activateController()

      • getDefaultController

        public IIOMetadataController getDefaultController​()
        返回默认的IIOMetadataController ，如果有一个，不管当前安装的控制器。 如果没有默认控制器，则返回null 。

        默认实现返回值为defaultController实例变量。

        结果
        默认为 IIOMetadataController ，或 null 。
        另请参见：
        IIOMetadataController ， setController(IIOMetadataController) ， getController() ， hasController() ， activateController()

      • hasController

        public boolean hasController​()
        如果为此IIOMetadata对象安装了控制器，则返回true 。

        如果getController方法返回非null值，默认实现将返回true 。

        结果
        true如果安装了控制器。
        另请参见：
        IIOMetadataController ， setController(IIOMetadataController) ， getController() ， getDefaultController() ， activateController()

      • activateController

        public boolean activateController​()
        激活此IIOMetadata对象的已安装的IIOMetadataController ，并返回结果值。 当此方法返回true ，此IIOMetadata对象的所有值将准备好进行下一次写入操作。 如果返回false则此对象中的设置不会受到干扰（ 即用户取消了该操作）。

        通常，控制器将是为特定插件提供IIOMetadata子类的用户界面的GUI。 控制器不需要GUI。

        默认实现调用getController和电话activate对返回的对象，如果hasController回报true 。

        结果
        true如果控制器正常完成。
        异常
        IllegalStateException - 如果当前没有安装控制器。
        另请参见：
        IIOMetadataController ， setController(IIOMetadataController) ， getController() ， getDefaultController() ， hasController()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


IIOMetadataController (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.metadata

Interface IIOMetadataController

  • public interface IIOMetadataController
    要由可以通过建立GUI以从用户获取值或通过其他方式确定IIOMetadata对象的设置的对象来实现的接口。 该接口仅指定调用控制器的通用activate方法，而不考虑控制器如何获取值（ 即 ，控制器是否提供GUI或仅计算一组值与此接口无关）。

    在activate方法中，控制器通过使用XML DOM树或插件特定接口查询IIOMetadata对象的设置来获取初始值，通过任何方式修改值，然后使用setFromTree或mergeTree修改IIOMetadata对象的设置方法或插件特定的界面。 一般来说，应用程序可能会期望当activate方法返回true ， IIOMetadata对象可以在写操作中使用。

    供应商可以选择为其为特定插件定义的IIOMetadata子类提供GUI。 这些可以在相应的IIOMetadata子类中设置为默认控制器。

    或者，可以使用诸如数据库查找或命令行解析之类的算法过程作为控制器，在这种情况下， activate方法将简单地查找或计算设置，调用IIOMetadata设置其状态的方法，并返回true 。

    另请参见：
    IIOMetadata.setController(javax.imageio.metadata.IIOMetadataController) ，
IIOMetadata.getController() ，
IIOMetadata.getDefaultController() ，
IIOMetadata.hasController() ，
IIOMetadata.activateController()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean activate​(IIOMetadata metadata)
      激活控制器。

    • 方法详细信息

      • activate

        boolean activate​(IIOMetadata metadata)
        激活控制器。 如果true返回，在所有设置IIOMetadata对象应该是准备在写操作使用。 如果false返回，在没有设置IIOMetadata对象会被干扰（ 也就是说 ，用户取消了该操作）。
        参数
        metadata - 要修改的 IIOMetadata对象。
        结果
        true如果 IIOMetadata已被修改，否则为 false 。
        异常
        IllegalArgumentException - if metadata is null or is not an instance of the correct class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IIOMetadataFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.metadata

Interface IIOMetadataFormat

  • 所有已知实现类：
    IIOMetadataFormatImpl

    public interface IIOMetadataFormat
    描述从IIOMetadata.getAsTree返回的元数据文档的结构并传递给IIOMetadata.setFromTree和mergeTree 。 文档结构通过对属于给定父元素类型的子元素的类型和数量的一组约束来描述，这些子元素可以属于元素的属性的名称，类型和值，以及Object的类型和值可以存储在节点处的引用。

    注意：实现此接口的类应该包含一个声明为public static getInstance()的方法，它返回该类的一个实例。 通常，一个实现将仅构造一个实例并将其缓存以供将来调用getInstance 。

    如果插件作为命名模块的一部分提供，该模块必须将包含实现类的包导出到

      java.desktop
    模块通过合格的导出。 除非有其他原因，否则不推荐出口不合格。 导出包未能导致运行时访问失败。

    该类可以描述的结构是使用XML文档类型定义（DTD）可表达的结构的一个子集，其中添加了关于属性的数据类型的一些基本信息，以及在节点内存储Object引用的能力。 将来，XML Schemas可以用于表示这些结构，还有许多其他结构。

    IIOMetadataFormat描述的结构和DTD之间的差异如下：

    • 元素可能不包含文本或使用嵌入的标签混合文本。
    • 元素的子元素必须符合CHILD_*常数的文档中描述的几种简单模式之一;
    • 元素的内存中表示可以包含对Object的引用。 没有规定文字表示这些对象。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CHILD_POLICY_ALL
      一个由 getChildPolicy返回的常数，以表示元素必须具有每个其合法子元素的单个实例。
      static int CHILD_POLICY_CHOICE
      一个由 getChildPolicy返回的 getChildPolicy ，表示一个元素必须有零个或一个孩子，从其合法的子元素中选择。
      static int CHILD_POLICY_EMPTY
      一个常数由 getChildPolicy返回，表示某个元素可能没有任何子项。
      static int CHILD_POLICY_MAX
      最大有效 CHILD_POLICY_*常数，用于范围检查。
      static int CHILD_POLICY_REPEAT
      一个由 getChildPolicy返回的 getChildPolicy ，表示一个元素必须有零个或多个独特的合法子元素的实例。
      static int CHILD_POLICY_SEQUENCE
      一个由 getChildPolicy返回的 getChildPolicy ，表示一个元素必须有其任何法定子元素的实例序列。
      static int CHILD_POLICY_SOME
      一个由 getChildPolicy返回的 getChildPolicy以表示元素必须具有每个其合法子元素的零个或一个实例。
      static int DATATYPE_BOOLEAN
      一个由 getAttributeDataType返回的 getAttributeDataType指示属性的值是布尔值“true”或“false”之一。
      static int DATATYPE_DOUBLE
      由 getAttributeDataType返回的 getAttributeDataType表示属性的值是双精度十进制浮点数的字符串表示形式。
      static int DATATYPE_FLOAT
      由 getAttributeDataType返回的 getAttributeDataType表示属性的值是十进制浮点数的字符串表示形式。
      static int DATATYPE_INTEGER
      由 getAttributeDataType返回的 getAttributeDataType指示属性的值是整数的字符串表示形式。
      static int DATATYPE_STRING
      一个由 getAttributeDataType返回的 getAttributeDataType表示一个属性的值是一般的Unicode字符串。
      static int VALUE_ARBITRARY
      由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为单个任意值。
      static int VALUE_ENUMERATION
      由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为多个枚举值之一。
      static int VALUE_LIST
      由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为值列表或数组。
      static int VALUE_NONE
      一个由 getObjectValueType返回的 getObjectValueType ，表示没有用户对象。
      static int VALUE_RANGE
      由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为值范围。
      static int VALUE_RANGE_MAX_INCLUSIVE
      由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为一个值范围。
      static int VALUE_RANGE_MAX_INCLUSIVE_MASK
      一个可以用 VALUE_RANGE或以 VALUE_RANGE取得的 VALUE_RANGE_MAX_INCLUSIVE ，并用 VALUE_RANGE_MIN_INCLUSIVE取得 VALUE_RANGE_MIN_MAX_INCLUSIVE 。
      static int VALUE_RANGE_MIN_INCLUSIVE
      由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为一定范围的值。
      static int VALUE_RANGE_MIN_INCLUSIVE_MASK
      可以用 VALUE_RANGE取得 VALUE_RANGE_MIN_INCLUSIVE ，并用 VALUE_RANGE_MAX_INCLUSIVE获得 VALUE_RANGE_MIN_MAX_INCLUSIVE 。
      static int VALUE_RANGE_MIN_MAX_INCLUSIVE
      由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为值范围。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean canNodeAppear​(String elementName, ImageTypeSpecifier imageType)
      如果 true元素（及其下面的子树）允许出现在由 ImageTypeSpecifier定义的给定类型的图像的元数据文档中。
      int getAttributeDataType​(String elementName, String attrName)
      返回以 DATATYPE_开头的常量 DATATYPE_ ，表示指定元素中给定属性的值的格式和解释。
      String getAttributeDefaultValue​(String elementName, String attrName)
      如果没有默认值可用，则返回命名属性的默认值（如果它未显式存在于命名元素中）， String ，或 null 。
      String getAttributeDescription​(String elementName, String attrName, Locale locale)
      返回 String含有指定属性，或的描述 null 。
      String[] getAttributeEnumerations​(String elementName, String attrName)
      返回一个包含指定元素中给定属性的合法枚举值的数组 String 。
      int getAttributeListMaxLength​(String elementName, String attrName)
      返回可用于定义此属性的列表项的最大数量。
      int getAttributeListMinLength​(String elementName, String attrName)
      返回可用于定义此属性的列表项的最小数量。
      String getAttributeMaxValue​(String elementName, String attrName)
      返回属性的最大合法值。
      String getAttributeMinValue​(String elementName, String attrName)
      返回属性的最小合法值。
      String[] getAttributeNames​(String elementName)
      返回一个 String的数组，列出可能与命名元素相关联的属性的名称。
      int getAttributeValueType​(String elementName, String attrName)
      返回以 VALUE_开头的常量 VALUE_ ，指示指定元素中给定属性的值是否是任意的，被限制在指定范围内，被限制为一组枚举值中的一个，或者是空格分隔的列表的任意值。
      String[] getChildNames​(String elementName)
      返回一个 String的数组，表示允许作为命名元素的子元素的元素的名称，按照它们应该出现的顺序。
      int getChildPolicy​(String elementName)
      返回以 CHILD_POLICY_开头的常量 CHILD_POLICY_ ，指示命名元素的 CHILD_POLICY_的合法模式。
      String getElementDescription​(String elementName, Locale locale)
      返回一个 String其中包含命名元素的描述，或 null 。
      int getElementMaxChildren​(String elementName)
      返回具有子策略 CHILD_POLICY_REPEAT的命名元素的最大子 CHILD_POLICY_REPEAT 。
      int getElementMinChildren​(String elementName)
      返回具有子策略 CHILD_POLICY_REPEAT的命名元素的最 CHILD_POLICY_REPEAT 。
      int getObjectArrayMaxLength​(String elementName)
      返回可用于定义指定元素中的 Object引用的最大数组元素数。
      int getObjectArrayMinLength​(String elementName)
      返回可能用于定义指定元素中的 Object引用的最小数组元素数。
      Class<?> getObjectClass​(String elementName)
      返回存储在元素中的 Object参考的 Class类型。
      Object getObjectDefaultValue​(String elementName)
      返回一个 Object其中包含命名元素中的 Object引用的默认值。
      Object[] getObjectEnumerations​(String elementName)
      返回一个 Object的数组， Object包含命名元素中的 Object引用的合法枚举值。
      Comparable<?> getObjectMaxValue​(String elementName)
      返回指定元素中 Object引用的最大合法值。
      Comparable<?> getObjectMinValue​(String elementName)
      返回指定元素中 Object引用的最小合法值。
      int getObjectValueType​(String elementName)
      返回以 VALUE_开头的枚举值 VALUE_ ，指示 Object引用允许的值（枚举，范围或数组）的 Object 。
      String getRootName​()
      返回格式的根元素的名称。
      boolean isAttributeRequired​(String elementName, String attrName)
      如果命名的属性必须存在于命名的元素中，则返回 true 。

    • 字段详细信息

      • CHILD_POLICY_EMPTY

        static final int CHILD_POLICY_EMPTY
        一个常数由getChildPolicy返回，表示某个元素可能没有任何子项。 换句话说，它需要是叶节点。
        另请参见：
        Constant Field Values

      • CHILD_POLICY_ALL

        static final int CHILD_POLICY_ALL
        一个由getChildPolicy返回的getChildPolicy以表示元素必须具有每个其合法子元素的单个实例。 在DTD术语中，元素的内容由序列a,b,c,d,...定义。
        另请参见：
        Constant Field Values

      • CHILD_POLICY_SOME

        static final int CHILD_POLICY_SOME
        一个由getChildPolicy返回的常数，以表示元素必须按顺序具有其每个合法子元素的零个或一个实例。 在DTD术语中，元素的内容由序列a?,b?,c?,d?,...定义。
        另请参见：
        Constant Field Values

      • CHILD_POLICY_CHOICE

        static final int CHILD_POLICY_CHOICE
        由getChildPolicy返回的getChildPolicy表示元素必须有零个或一个小孩，从其合法的子元素中选出。 在DTD术语中，元素的内容由选择a|b|c|d|...定义。
        另请参见：
        Constant Field Values

      • CHILD_POLICY_SEQUENCE

        static final int CHILD_POLICY_SEQUENCE
        一个由getChildPolicy返回的getChildPolicy ，表示一个元素必须具有任何其合法子元素的实例序列。 在DTD术语中，元素的内容由序列(a|b|c|d|...)*定义。
        另请参见：
        Constant Field Values

      • CHILD_POLICY_REPEAT

        static final int CHILD_POLICY_REPEAT
        一个由getChildPolicy返回的getChildPolicy ，表示一个元素必须有零个或多个独特的合法子元素的实例。 在DTD术语中，元素的内容由星号表达式a*定义。
        另请参见：
        Constant Field Values

      • CHILD_POLICY_MAX

        static final int CHILD_POLICY_MAX
        最大有效 CHILD_POLICY_*常数，用于范围检查。
        另请参见：
        Constant Field Values

      • VALUE_NONE

        static final int VALUE_NONE
        由 getObjectValueType返回的 getObjectValueType表示没有用户对象。
        另请参见：
        Constant Field Values

      • VALUE_ARBITRARY

        static final int VALUE_ARBITRARY
        由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为单个任意值。
        另请参见：
        Constant Field Values

      • VALUE_RANGE

        static final int VALUE_RANGE
        由getAttributeValueType和getObjectValueType返回的常数表示可以将属性或用户对象设置为值范围。 范围的最小值和最大值都是独占的。 建议两端的整数范围是包含的，唯一的范围只能用于浮点数据。
        另请参见：
        VALUE_RANGE_MIN_MAX_INCLUSIVE ， Constant Field Values

      • VALUE_RANGE_MIN_INCLUSIVE_MASK

        static final int VALUE_RANGE_MIN_INCLUSIVE_MASK
        可以用VALUE_RANGE或以VALUE_RANGE取得的VALUE_RANGE_MIN_INCLUSIVE ，并用VALUE_RANGE_MAX_INCLUSIVE获得VALUE_RANGE_MIN_MAX_INCLUSIVE 。

        类似地，该值可以与值getAttributeValueType或getObjectValueType一起确定，以确定范围的最小值是否包含在内。

        另请参见：
        Constant Field Values

      • VALUE_RANGE_MAX_INCLUSIVE_MASK

        static final int VALUE_RANGE_MAX_INCLUSIVE_MASK
        一个可以用VALUE_RANGE获得VALUE_RANGE_MAX_INCLUSIVE ，并用VALUE_RANGE_MIN_INCLUSIVE获得VALUE_RANGE_MIN_MAX_INCLUSIVE 。

        类似地，可以使用值getAttributeValueType或getObjectValueType来确定该范围的最大值是否包含在内。

        另请参见：
        Constant Field Values

      • VALUE_RANGE_MIN_INCLUSIVE

        static final int VALUE_RANGE_MIN_INCLUSIVE
        由getAttributeValueType和getObjectValueType返回的getAttributeValueType来指示属性或用户对象可能被设置为一个值的范围。 范围的最小值（但不是最大值）是包含值。
        另请参见：
        Constant Field Values

      • VALUE_RANGE_MAX_INCLUSIVE

        static final int VALUE_RANGE_MAX_INCLUSIVE
        一个由getAttributeValueType和getObjectValueType返回的getAttributeValueType ，以指示属性或用户对象可以设置为一个值的范围。 范围的最大值（但不是最小值）是包含值。
        另请参见：
        Constant Field Values

      • VALUE_RANGE_MIN_MAX_INCLUSIVE

        static final int VALUE_RANGE_MIN_MAX_INCLUSIVE
        由getAttributeValueType和getObjectValueType返回的常数表示可以将属性或用户对象设置为值范围。 范围的最小值和最大值都是包含值。 建议两端的整数范围是包含的，唯一的范围只能用于浮点数据。
        另请参见：
        Constant Field Values

      • VALUE_ENUMERATION

        static final int VALUE_ENUMERATION
        由getAttributeValueType和getObjectValueType返回的常数表示可以将属性或用户对象设置为多个枚举值之一。 在属性的情况下，这些值为String s; 对于对象，它们是Object s实现给定的类或接口。

        类型为DATATYPE_BOOLEAN属性值应标记为枚举。

        另请参见：
        Constant Field Values

      • VALUE_LIST

        static final int VALUE_LIST
        一个常数由getAttributeValueType和getObjectValueType返回，以表示属性或用户对象可能被设置为列表或数组。 在属性的情况下，列表将由String内的空格分隔值String ; 对于对象，将使用数组。
        另请参见：
        Constant Field Values

      • DATATYPE_STRING

        static final int DATATYPE_STRING
        一个由 getAttributeDataType返回的 getAttributeDataType表示属性的值是一般的Unicode字符串。
        另请参见：
        Constant Field Values

      • DATATYPE_BOOLEAN

        static final int DATATYPE_BOOLEAN
        由getAttributeDataType返回的getAttributeDataType指示属性的值是布尔值“true”或“false”之一。 类型为DATATYPE_BOOLEAN的属性值应该被标记为枚举，并且允许的值应该是字符串文字值“TRUE”或“FALSE”，尽管插件也可以识别较低或混合的大小写等价物。
        另请参见：
        Constant Field Values

      • DATATYPE_INTEGER

        static final int DATATYPE_INTEGER
        由 getAttributeDataType返回的 getAttributeDataType指示属性的值是整数的字符串表示形式。
        另请参见：
        Constant Field Values

      • DATATYPE_FLOAT

        static final int DATATYPE_FLOAT
        由 getAttributeDataType返回的 getAttributeDataType指示属性的值是十进制浮点数的字符串表示形式。
        另请参见：
        Constant Field Values

      • DATATYPE_DOUBLE

        static final int DATATYPE_DOUBLE
        由 getAttributeDataType返回的 getAttributeDataType表示属性的值是双精度十进制浮点数的字符串表示形式。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getRootName

        String getRootName​()
        返回格式的根元素的名称。
        结果
        一个 String 。

      • canNodeAppear

        boolean canNodeAppear​(String elementName,
                      ImageTypeSpecifier imageType)
        如果true元素（及其下面的子树）允许出现在由ImageTypeSpecifier定义的给定类型的图像的元数据文档中。 例如，元数据文档格式可能包含描述图像基本颜色的元素，这在编写灰度图像时不允许。
        参数
        elementName - 要查询的元素的名称。
        imageType - 指示将与元数据相关联的图像的类型的 ImageTypeSpecifier 。
        结果
        true如果节点对于给定类型的图像是有意义的。

      • getElementMinChildren

        int getElementMinChildren​(String elementName)
        返回具有子策略CHILD_POLICY_REPEAT的命名元素的最CHILD_POLICY_REPEAT 。 例如，表示颜色主要信息的元素可能需要至少有3个小孩，每个小学一个。
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 int 。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的合法元素名称。
        IllegalArgumentException - 如果named元素没有子策略 CHILD_POLICY_REPEAT 。

      • getElementMaxChildren

        int getElementMaxChildren​(String elementName)
        返回具有子策略CHILD_POLICY_REPEAT的命名元素的最大子CHILD_POLICY_REPEAT 。 例如，可以允许在8位调色板中表示条目的元素重复多达256次。 可以使用值Integer.MAX_VALUE来指定没有上限。
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 int 。
        异常
        IllegalArgumentException - 如果 elementName为 null或不是此格式的合法元素名称。
        IllegalArgumentException - 如果named元素没有子策略 CHILD_POLICY_REPEAT 。

      • getElementDescription

        String getElementDescription​(String elementName,
                             Locale locale)
        返回一个String其中包含命名元素的描述，或null 。 如果可能，说明将被本地化为所提供的Locale 。

        如果locale为null ，当前的默认Locale由归国Locale.getLocale将被使用。

        参数
        elementName - 元素的名称。
        locale - 将尝试本地化的 Locale 。
        结果
        元素描述。
        异常
        IllegalArgumentException - 如果 elementName为 null ，或不是此格式的法定元素名称。

      • getChildPolicy

        int getChildPolicy​(String elementName)
        返回从 CHILD_POLICY_开始的常量 CHILD_POLICY_ ，指示命名元素的 CHILD_POLICY_的合法模式。
        参数
        elementName - 要查询的元素的名称。
        结果
        其中一个 CHILD_POLICY_*常量。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的合法元素名称。

      • getChildNames

        String[] getChildNames​(String elementName)
        返回一个String s的数组，表示允许作为命名元素的子元素的元素的名称，按照它们应该出现的顺序。 如果该元素不能有子元素，则返回null 。
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 String的数组，或null。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的法定元素名称。

      • getAttributeNames

        String[] getAttributeNames​(String elementName)
        返回一个 String的数组，列出可能与命名元素相关联的属性的名称。
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 String的数组。
        异常
        IllegalArgumentException - 如果 elementName为 null或不是此格式的合法元素名称。

      • getAttributeValueType

        int getAttributeValueType​(String elementName,
                          String attrName)
        返回从 VALUE_开始的常量 VALUE_ ，指示指定元素中给定属性的值是否是任意的，被限制在指定范围内，被限制为一组枚举值之一，或是空格分隔的列表的任意值。
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        其中一个 VALUE_*常量。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的法定元素名称。
        IllegalArgumentException - 如果 attrName是 null或不是此元素的合法属性名称。

      • getAttributeDataType

        int getAttributeDataType​(String elementName,
                         String attrName)
        返回以DATATYPE_开头的常量DATATYPE_ ，表示指定元素中给定属性的值的格式和解释。 如果getAttributeValueType返回VALUE_LIST ，则合法值是返回数据类型的值的空白列表。
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        一个 DATATYPE_*常量。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的法定元素名称。
        IllegalArgumentException - 如果 attrName是 null或不是此元素的合法属性名称。

      • isAttributeRequired

        boolean isAttributeRequired​(String elementName,
                            String attrName)
        如果命名的属性必须在命名的元素中，则返回 true 。
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        true如果属性必须存在。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的法定元素名称。
        IllegalArgumentException - 如果 attrName是 null或不是此元素的合法属性名称。

      • getAttributeDefaultValue

        String getAttributeDefaultValue​(String elementName,
                                String attrName)
        如果没有默认值可用，则返回命名属性的默认值（如果它未显式存在于命名元素中）， String ，或 null 。
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        一个 String包含默认值，或 null 。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的法定元素名称。
        IllegalArgumentException - 如果 attrName是 null或不是此元素的合法属性名称。

      • getAttributeEnumerations

        String[] getAttributeEnumerations​(String elementName,
                                  String attrName)
        返回一个String的数组， String包含指定元素中给定属性的合法枚举值。 仅当getAttributeValueType返回VALUE_ENUMERATION才应该调用此方法。
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        一个 String的数组。
        异常
        IllegalArgumentException - 如果 elementName为 null或不是此格式的合法元素名称。
        IllegalArgumentException - 如果 attrName是 null或不是此元素的合法属性名称。
        IllegalArgumentException - 如果给定的属性未定义为枚举。

      • getAttributeMinValue

        String getAttributeMinValue​(String elementName,
                            String attrName)
        返回属性的最小合法值。 该值是否包含或排除可以由值getAttributeValueType确定。 该值返回为String ; 其解释取决于getAttributeDataType的值。 只有getAttributeValueType返回VALUE_RANGE_*才应该调用此方法。
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        一个 String包含该属性的最小合法值。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的法定元素名称。
        IllegalArgumentException - 如果 attrName为 null或不是此元素的合法属性名称。
        IllegalArgumentException - 如果给定属性未定义为范围。

      • getAttributeMaxValue

        String getAttributeMaxValue​(String elementName,
                            String attrName)
        返回属性的最大合法值。 该值是否包含或排除可以由值getAttributeValueType确定。 该值返回为String ; 其解释取决于getAttributeDataType的值。 此方法只能在getAttributeValueType返回VALUE_RANGE_* 。
        参数
        elementName - 要查询的元素的名称，作为 String 。
        attrName - 要查询的属性的名称。
        结果
        一个 String包含该属性的最大合法值。
        异常
        IllegalArgumentException - 如果 elementName为 null或不是此格式的合法元素名称。
        IllegalArgumentException - 如果 attrName为 null或不是此元素的合法属性名称。
        IllegalArgumentException - 如果给定属性未定义为范围。

      • getAttributeListMinLength

        int getAttributeListMinLength​(String elementName,
                              String attrName)
        返回可用于定义此属性的列表项的最小数量。 属性本身定义为包含多个空格分隔的项目的String 。 仅当getAttributeValueType返回VALUE_LIST才应该调用此方法。
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        属性的列表项的最小合法数量。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的合法元素名称。
        IllegalArgumentException - 如果 attrName是 null或不是此元素的合法属性名称。
        IllegalArgumentException - 如果给定的属性未定义为列表。

      • getAttributeListMaxLength

        int getAttributeListMaxLength​(String elementName,
                              String attrName)
        返回可用于定义此属性的列表项的最大数量。 可以使用值Integer.MAX_VALUE来指定没有上限。 属性本身定义为包含多个空格分隔的项目的String 。 该方法只能在getAttributeValueType返回VALUE_LIST 。
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        属性的列表项的最大合法数量。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的法定元素名称。
        IllegalArgumentException - 如果 attrName是 null或不是此元素的合法属性名称。
        IllegalArgumentException - 如果给定属性未定义为列表。

      • getAttributeDescription

        String getAttributeDescription​(String elementName,
                               String attrName,
                               Locale locale)
        返回String含有指定属性，或的描述null 。 如果可能，说明将被本地化为所提供的Locale 。

        如果locale为null ，当前的默认Locale由归国Locale.getLocale将被使用。

        参数
        elementName - 元素的名称。
        attrName - 属性的名称。
        locale - 将尝试本地化的 Locale 。
        结果
        属性描述。
        异常
        IllegalArgumentException - 如果 elementName为 null ，或不是此格式的合法元素名称。
        IllegalArgumentException - 如果 attrName是 null或不是此元素的合法属性名称。

      • getObjectValueType

        int getObjectValueType​(String elementName)
        返回从VALUE_开始的枚举值VALUE_ ，指示Object引用允许的值（枚举，范围或数组）的Object 。 如果给定元素中没有存储对象值，则该方法的结果为VALUE_NONE 。

        Object其法定值定义为范围的引用必须实现Comparable接口。

        参数
        elementName - 要查询的元素的名称。
        结果
        其中一个 VALUE_*常量。
        异常
        IllegalArgumentException - 如果 elementName为 null或不是此格式的法定元素名称。
        另请参见：
        Comparable

      • getObjectClass

        Class<?> getObjectClass​(String elementName)
        返回存储在元素中的Object参考的Class类型。 如果此元素可能不包含Object引用，则将抛出IllegalArgumentException 。 如果类类型是数组，则此字段指示底层类型（ 例如 ，对于int的数组，此方法将返回int.class ）。

        Object其法定值定义为范围的引用必须实现Comparable接口。

        参数
        elementName - 要查询的元素的名称。
        结果
        一个 Class对象。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的合法元素名称。
        IllegalArgumentException - 如果指定的元素不能包含对象值（ 即 ，如果为 getObjectValueType(elementName) == VALUE_NONE ）。

      • getObjectDefaultValue

        Object getObjectDefaultValue​(String elementName)
        返回一个 Object s，其中包含命名元素中的 Object引用的默认值。
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 Object 。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的合法元素名称。
        IllegalArgumentException - 如果命名的元素不能包含对象值（ 即 ，如果为 getObjectValueType(elementName) == VALUE_NONE ）。

      • getObjectEnumerations

        Object[] getObjectEnumerations​(String elementName)
        返回一个Object的数组， Object包含命名元素中的Object引用的合法枚举值。 该方法只能在getObjectValueType返回VALUE_ENUMERATION 。

        与接受枚举值的节点相关联的Object必须等于由==运算符定义的此方法返回的值之一（与Object.equals方法相反）。

        参数
        elementName - 要查询的元素的名称。
        结果
        一个 Object的数组。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的合法元素名称。
        IllegalArgumentException - 如果命名的元素不能包含对象值（ 即 ，如果为 getObjectValueType(elementName) == VALUE_NONE ）。
        IllegalArgumentException - 如果 Object未定义为枚举。

      • getObjectMinValue

        Comparable<?> getObjectMinValue​(String elementName)
        返回指定元素中Object引用的最小合法值。 该值是否包含或排除可以由值getObjectValueType确定。 只有当getObjectValueType返回以VALUE_RANGE开头的常量之一时，才应该调用此方法。
        参数
        elementName - 要查询的元素的名称。
        结果
        该属性的最小合法值。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的法定元素名称。
        IllegalArgumentException - 如果指定的元素不能包含对象值（ 即 ，如果为 getObjectValueType(elementName) == VALUE_NONE ）。
        IllegalArgumentException - 如果 Object未定义为范围。

      • getObjectMaxValue

        Comparable<?> getObjectMaxValue​(String elementName)
        返回指定元素中Object引用的最大合法值。 该值是否包含或排除可以由值getObjectValueType确定。 仅当getObjectValueType返回以VALUE_RANGE开头的常量之一时，才应该调用此方法。
        参数
        elementName - 要查询的元素的名称。
        结果
        该属性的最小合法值。
        异常
        IllegalArgumentException - 如果 elementName为 null或不是此格式的法定元素名称。
        IllegalArgumentException - 如果命名的元素不能包含对象值（ 即 ，如果为 getObjectValueType(elementName) == VALUE_NONE ）。
        IllegalArgumentException - 如果 Object未定义为范围。

      • getObjectArrayMinLength

        int getObjectArrayMinLength​(String elementName)
        返回可用于定义指定元素中Object引用的最小数组元素数。 该方法只能在getObjectValueType返回VALUE_LIST 。
        参数
        elementName - 要查询的元素的名称。
        结果
        Object参考的最小有效数组长度。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的合法元素名称。
        IllegalArgumentException - 如果指定的元素不能包含对象值（ 即 ，如果为 getObjectValueType(elementName) == VALUE_NONE ）。
        IllegalArgumentException - 如果 Object不是数组。

      • getObjectArrayMaxLength

        int getObjectArrayMaxLength​(String elementName)
        返回可用于定义指定元素中的Object引用的最大数组元素数。 可以使用值Integer.MAX_VALUE来指定没有上限。 此方法只能在getObjectValueType返回VALUE_LIST 。
        参数
        elementName - 要查询的元素的名称。
        结果
        Object参考的最大有效数组长度。
        异常
        IllegalArgumentException - 如果 elementName是 null或不是此格式的法定元素名称。
        IllegalArgumentException - 如果命名元素不能包含对象值（ 即 ，如果为 getObjectValueType(elementName) == VALUE_NONE ）。
        IllegalArgumentException - 如果 Object不是数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


IIOMetadataFormatImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.metadata

Class IIOMetadataFormatImpl

  • java.lang.Object
    • javax.imageio.metadata.IIOMetadataFormatImpl
  • All Implemented Interfaces:
    IIOMetadataFormat

    public abstract class IIOMetadataFormatImpl
extends Object
implements IIOMetadataFormat
    一个具体的类，提供可重用的IIOMetadataFormat接口的实现。 另外，表示标准的静态实例，插件中性javax_imageio_1.0格式由getStandardFormatInstance方法提供。

    为了提供元素和属性的局部描述，一个ResourceBundle用的基本名称this.getClass().getName() + "Resources"应通过所使用的通常的机构供给ResourceBundle.getBundle 。 简而言之，子类根据命名约定提供一个或多个附加类（默认情况下，扩展为IIMetadataFormatImpl的子类的完全限定名称，加上字符串“资源”，以及以下划线分隔的国家/地区，语言和变体代码） 。 在运行时，调用getElementDescription或getAttributeDescription将尝试根据提供的区域设置动态加载这些类，并将使用元素名称或元素名称后跟一个'/'字符，后跟属性名称作为键。 该密钥将提供给ResourceBundle的getString方法，并返回所得到的节点或属性的本地化描述。

    子类可以使用setResourceBaseName方法为资源束提供不同的基本名称。

    如果需要，一个子类可以选择自己的定位机制，覆盖所提供的getElementDescription和getAttributeDescription 。

    另请参见：
    ResourceBundle.getBundle(String,Locale)

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String standardMetadataFormatName
      A String常量包含标准格式名称， "javax_imageio_1.0" 。

      • Fields inherited from interface javax.imageio.metadata.IIOMetadataFormat

        CHILD_POLICY_ALL, CHILD_POLICY_CHOICE, CHILD_POLICY_EMPTY, CHILD_POLICY_MAX, CHILD_POLICY_REPEAT, CHILD_POLICY_SEQUENCE, CHILD_POLICY_SOME, DATATYPE_BOOLEAN, DATATYPE_DOUBLE, DATATYPE_FLOAT, DATATYPE_INTEGER, DATATYPE_STRING, VALUE_ARBITRARY, VALUE_ENUMERATION, VALUE_LIST, VALUE_NONE, VALUE_RANGE, VALUE_RANGE_MAX_INCLUSIVE, VALUE_RANGE_MAX_INCLUSIVE_MASK, VALUE_RANGE_MIN_INCLUSIVE, VALUE_RANGE_MIN_INCLUSIVE_MASK, VALUE_RANGE_MIN_MAX_INCLUSIVE

    • 构造方法摘要

      构造方法
      Constructor 描述
      IIOMetadataFormatImpl​(String rootName, int childPolicy)
      构造一个空白的 IIOMetadataFormatImpl实例，具有给定的根元素名称和子策略（ CHILD_POLICY_REPEAT ）。
      IIOMetadataFormatImpl​(String rootName, int minChildren, int maxChildren)
      构造一个空白的 IIOMetadataFormatImpl实例，给定的根元素名称和子策略为 CHILD_POLICY_REPEAT 。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected void addAttribute​(String elementName, String attrName, int dataType, boolean required, int listMinLength, int listMaxLength)
      将新属性添加到由值列表定义的先前定义的元素中。
      protected void addAttribute​(String elementName, String attrName, int dataType, boolean required, String defaultValue)
      将新属性添加到可以设置为任意值的先前定义的元素。
      protected void addAttribute​(String elementName, String attrName, int dataType, boolean required, String defaultValue, String minValue, String maxValue, boolean minInclusive, boolean maxInclusive)
      向先前定义的元素添加一个新属性，该元素将由一系列值定义。
      protected void addAttribute​(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)
      向先前定义的元素添加一个新属性，该元素将由一组枚举值定义。
      protected void addBooleanAttribute​(String elementName, String attrName, boolean hasDefaultValue, boolean defaultValue)
      向先前定义的元素添加一个新属性，该元素将由枚举值 TRUE和 FALSE ，数据类型为 DATATYPE_BOOLEAN 。
      protected void addChildElement​(String elementName, String parentName)
      将一个现有元素添加到给定父节点类型的合法子节点列表中。
      protected void addElement​(String elementName, String parentName, int childPolicy)
      使用非 CHILD_POLICY_REPEAT以外的子策略向此元数据文档格式添加新元素类型。
      protected void addElement​(String elementName, String parentName, int minChildren, int maxChildren)
      将新元素类型添加到此元数据文档格式，子策略为 CHILD_POLICY_REPEAT 。
      protected void addObjectValue​(String elementName, Class<?> classType, int arrayMinLength, int arrayMaxLength)
      允许给定类类型的一个 Object引用存储在实现命名元素的节点中。
      protected <T> void addObjectValue​(String elementName, Class<T> classType, boolean required, T defaultValue)
      允许给定类类型的 Object引用存储在实现命名元素的节点中。
      protected <T> void addObjectValue​(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
      允许 Object定类类型的 Object引用存储在实现命名元素的节点中。
      protected <T extends Object & Comparable<? super T>>
      void             		addObjectValue​(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
      允许给定类类型的 Object引用存储在实现命名元素的节点中。
      abstract boolean canNodeAppear​(String elementName, ImageTypeSpecifier imageType)
      如果 true元素（及其下面的子树）被允许出现在由 ImageTypeSpecifier定义的给定类型的图像的元数据文档中，则 ImageTypeSpecifier 。
      int getAttributeDataType​(String elementName, String attrName)
      返回以 DATATYPE_开头的常量 DATATYPE_ ，表示指定元素中给定属性的值的格式和解释。
      String getAttributeDefaultValue​(String elementName, String attrName)
      如果没有默认值可用，则返回命名属性的默认值（如果它未显式存在于命名元素中）， String ，或 null 。
      String getAttributeDescription​(String elementName, String attrName, Locale locale)
      返回一个 String其中包含命名属性的描述，或 null 。
      String[] getAttributeEnumerations​(String elementName, String attrName)
      返回一个包含指定元素中给定属性的合法枚举值的数组 String 。
      int getAttributeListMaxLength​(String elementName, String attrName)
      返回可用于定义此属性的列表项的最大数量。
      int getAttributeListMinLength​(String elementName, String attrName)
      返回可用于定义此属性的列表项的最小数量。
      String getAttributeMaxValue​(String elementName, String attrName)
      返回属性的最大合法值。
      String getAttributeMinValue​(String elementName, String attrName)
      返回属性的最小合法值。
      String[] getAttributeNames​(String elementName)
      返回一个 String的数组，列出可能与命名元素相关联的属性的名称。
      int getAttributeValueType​(String elementName, String attrName)
      返回以 VALUE_开头的常量 VALUE_ ，指示指定元素中给定属性的值是否是任意的，被限制在指定范围内，被限制为一组枚举值之一，或是空格分隔的列表的任意值。
      String[] getChildNames​(String elementName)
      返回一个 String s的数组，表示允许作为命名元素的子元素的元素的名称，按照它们应该出现的顺序。
      int getChildPolicy​(String elementName)
      返回从 CHILD_POLICY_开始的常量 CHILD_POLICY_ ，指示命名元素的子代的合法模式。
      String getElementDescription​(String elementName, Locale locale)
      返回 String含有指定元素，或的描述 null 。
      int getElementMaxChildren​(String elementName)
      返回具有子策略 CHILD_POLICY_REPEAT的命名元素的最大子 CHILD_POLICY_REPEAT 。
      int getElementMinChildren​(String elementName)
      返回具有子策略 CHILD_POLICY_REPEAT的命名元素的最 CHILD_POLICY_REPEAT 。
      int getObjectArrayMaxLength​(String elementName)
      返回可用于定义指定元素中的 Object引用的最大数组元素数。
      int getObjectArrayMinLength​(String elementName)
      返回可用于定义指定元素中的 Object引用的最小数组元素数。
      Class<?> getObjectClass​(String elementName)
      返回 Class类型的 Object参考存储在元素内。
      Object getObjectDefaultValue​(String elementName)
      返回一个 Object s，其中包含命名元素中的 Object引用的默认值。
      Object[] getObjectEnumerations​(String elementName)
      返回一个 Object的数组， Object包含命名元素中的 Object引用的合法枚举值。
      Comparable<?> getObjectMaxValue​(String elementName)
      返回指定元素中 Object引用的最大合法值。
      Comparable<?> getObjectMinValue​(String elementName)
      返回指定元素中 Object引用的最小合法值。
      int getObjectValueType​(String elementName)
      返回以 VALUE_开头的枚举值 VALUE_ ，指示 Object引用允许的值（枚举，范围或数组）的 Object 。
      protected String getResourceBaseName​()
      返回当前设置的基本名称，以查找 ResourceBundle s。
      String getRootName​()
      返回格式的根元素的名称。
      static IIOMetadataFormat getStandardFormatInstance​()
      返回描述 javax.imageio.metadata包的注释中描述的标准，插件中性 javax.imageio_1.0元数据文档格式的 IIOMetadataFormat对象。
      boolean isAttributeRequired​(String elementName, String attrName)
      如果命名的属性必须存在于命名的元素中，则返回 true 。
      protected void removeAttribute​(String elementName, String attrName)
      从先前定义的元素中删除一个属性。
      protected void removeElement​(String elementName)
      从格式中移除元素。
      protected void removeObjectValue​(String elementName)
      不允许将 Object引用存储在实现命名元素的节点中。
      protected void setResourceBaseName​(String resourceBaseName)
      设置一个新的基本名称来定位 ResourceBundle s，其中包含此格式的元素和属性说明。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • standardMetadataFormatName

        public static final String standardMetadataFormatName
        A String常量包含标准格式名称， "javax_imageio_1.0" 。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • IIOMetadataFormatImpl

        public IIOMetadataFormatImpl​(String rootName,
                             int childPolicy)
        构造一个空白的IIOMetadataFormatImpl实例，具有给定的根元素名称和子策略（ CHILD_POLICY_REPEAT ）。 附加元素及其属性和Object参考信息可以使用各种add方法添加。
        参数
        rootName - 根元素的名称。
        childPolicy - CHILD_POLICY_*常数之一，不包括 CHILD_POLICY_REPEAT 。
        异常
        IllegalArgumentException - 如果 rootName是 null 。
        IllegalArgumentException - 如果 childPolicy不是预定义的常量之一。

      • IIOMetadataFormatImpl

        public IIOMetadataFormatImpl​(String rootName,
                             int minChildren,
                             int maxChildren)
        构造一个空白的IIOMetadataFormatImpl实例，给定的根元素名称和子策略为CHILD_POLICY_REPEAT 。 附加元素及其属性和Object参考信息可以使用各种add方法添加。
        参数
        rootName - 根元素的名称。
        minChildren - 节点的最 minChildren数。
        maxChildren - 节点的最大子节点数。
        异常
        IllegalArgumentException - 如果 rootName是 null 。
        IllegalArgumentException - 如果 minChildren为负数或大于 maxChildren 。

    • 方法详细信息

      • setResourceBaseName

        protected void setResourceBaseName​(String resourceBaseName)
        设置一个新的基本名称来定位ResourceBundle s，其中包含此格式的元素和属性的描述。

        在第一次调用此方法之前，基本名称将等于this.getClass().getName() + "Resources" 。

        参数
        resourceBaseName - 一个包含新基本名称的 String 。
        异常
        IllegalArgumentException - 如果 resourceBaseName是 null 。
        另请参见：
        getResourceBaseName()

      • getResourceBaseName

        protected String getResourceBaseName​()
        返回当前设置的基本名称，以查找 ResourceBundle s。
        结果
        一个包含基本名称的 String 。
        另请参见：
        setResourceBaseName(java.lang.String)

      • addElement

        protected void addElement​(String elementName,
                          String parentName,
                          int childPolicy)
        使用 CHILD_POLICY_REPEAT以外的子策略向此元数据文档格式添加新元素类型。
        参数
        elementName - 新元素的名称。
        parentName - 将作为新元素的父元素的元素的名称。
        childPolicy - CHILD_POLICY_*常量之一，不包括 CHILD_POLICY_REPEAT ，表示新元素的子策略。
        异常
        IllegalArgumentException - 如果 parentName为 null ，或不是此格式的法定元素名称。
        IllegalArgumentException - 如果 childPolicy不是预定义的常量之一。

      • addElement

        protected void addElement​(String elementName,
                          String parentName,
                          int minChildren,
                          int maxChildren)
        将新元素类型添加到此元数据文档格式，子策略为 CHILD_POLICY_REPEAT 。
        参数
        elementName - 新元素的名称。
        parentName - 将作为新元素的父元素的元素的名称。
        minChildren - 节点的最 minChildren节点数。
        maxChildren - 节点的最大子节点数。
        异常
        IllegalArgumentException - 如果 parentName为 null ，或不是此格式的合法元素名称。
        IllegalArgumentException - 如果 minChildren为负数或大于 maxChildren 。

      • addChildElement

        protected void addChildElement​(String elementName,
                               String parentName)
        将一个现有元素添加到给定父节点类型的合法子节点列表中。
        参数
        parentName - 将作为元素的新父元素的元素的名称。
        elementName - 要作为子级添加的元素的名称。
        异常
        IllegalArgumentException - 如果 elementName是 null ，或者不是此格式的合法元素名称。
        IllegalArgumentException - 如果 parentName为 null ，或不是此格式的合法元素名称。

      • removeElement

        protected void removeElement​(String elementName)
        从格式中移除元素。 如果没有给定名称的元素存在，则不会发生任何事情，也不会抛出异常。
        参数
        elementName - 要删除的元素的名称。

      • addAttribute

        protected void addAttribute​(String elementName,
                            String attrName,
                            int dataType,
                            boolean required,
                            String defaultValue)
        将新属性添加到可以设置为任意值的先前定义的元素。
        参数
        elementName - 元素的名称。
        attrName - 要添加的属性的名称。
        dataType - 属性的数据类型（字符串格式）， DATATYPE_*常量之一。
        required - true如果属性必须存在。
        defaultValue - 属性的默认值，或 null 。
        异常
        IllegalArgumentException - 如果 elementName为 null ，或不是此格式的合法元素名称。
        IllegalArgumentException - 如果 attrName是 null 。
        IllegalArgumentException - 如果 dataType不是预定义的常量之一。

      • addAttribute

        protected void addAttribute​(String elementName,
                            String attrName,
                            int dataType,
                            boolean required,
                            String defaultValue,
                            List<String> enumeratedValues)
        向先前定义的元素添加一个新属性，该元素将由一组枚举值定义。
        参数
        elementName - 元素的名称。
        attrName - 要添加的属性的名称。
        dataType - 属性的数据类型（字符串格式）， DATATYPE_*常量之一。
        required - true如果属性必须存在。
        defaultValue - 属性的默认值，或 null 。
        enumeratedValues - a List的 String s包含属性的合法值。
        异常
        IllegalArgumentException - 如果 elementName是 null ，或者不是此格式的合法元素名称。
        IllegalArgumentException - 如果 attrName是 null 。
        IllegalArgumentException - 如果 dataType不是预定义的常量之一。
        IllegalArgumentException - 如果 enumeratedValues是 null 。
        IllegalArgumentException - 如果 enumeratedValues不包含至少一个条目。
        IllegalArgumentException - 如果 enumeratedValues包含不是 String或 null 。

      • addAttribute

        protected void addAttribute​(String elementName,
                            String attrName,
                            int dataType,
                            boolean required,
                            String defaultValue,
                            String minValue,
                            String maxValue,
                            boolean minInclusive,
                            boolean maxInclusive)
        向先前定义的元素添加一个新属性，该元素将由一系列值定义。
        参数
        elementName - 元素的名称。
        attrName - 要添加的属性的名称。
        dataType - 属性的数据类型（字符串格式）， DATATYPE_*常量之一。
        required - true如果属性必须存在。
        defaultValue - 属性的默认值，或 null 。
        minValue - minValue的最小（包括或排除取决于值 minInclusive ）合法值，为 String 。
        maxValue - maxValue的最大（包括或排除取决于 minInclusive的值）法定值，作为 String 。
        如果是 true ， minValue minInclusive - true 。
        maxInclusive - true如果是 maxValue是包含的。
        异常
        IllegalArgumentException - 如果 elementName是 null ，或者不是此格式的法定元素名称。
        IllegalArgumentException - 如果 attrName是 null 。
        IllegalArgumentException - 如果 dataType不是预定义的常量之一。

      • addAttribute

        protected void addAttribute​(String elementName,
                            String attrName,
                            int dataType,
                            boolean required,
                            int listMinLength,
                            int listMaxLength)
        将新属性添加到由值列表定义的先前定义的元素中。
        参数
        elementName - 元素的名称。
        attrName - 要添加的属性的名称。
        dataType - 属性的数据类型（字符串格式）， DATATYPE_*常量之一。
        required - true如果属性必须存在。
        listMinLength - 列表项的最小合法数量。
        listMaxLength - 列表项的最大合法数量。
        异常
        IllegalArgumentException - 如果 elementName为 null ，或不是此格式的法定元素名称。
        IllegalArgumentException - 如果 attrName是 null 。
        IllegalArgumentException - 如果 dataType不是预定义的常量之一。
        IllegalArgumentException - 如果 listMinLength为负数或大于 listMaxLength 。

      • addBooleanAttribute

        protected void addBooleanAttribute​(String elementName,
                                   String attrName,
                                   boolean hasDefaultValue,
                                   boolean defaultValue)
        向先前定义的元素添加一个新属性，该元素将由枚举值 TRUE和 FALSE ，数据类型为 DATATYPE_BOOLEAN 。
        参数
        elementName - 元素的名称。
        attrName - 要添加的属性的名称。
        hasDefaultValue - true如果应该存在默认值。
        defaultValue - 属性的默认值为 boolean ，如果 hasDefaultValue为 false ，则忽略 hasDefaultValue值。
        异常
        IllegalArgumentException - 如果 elementName为 null ，或不是此格式的合法元素名称。
        IllegalArgumentException - 如果 attrName是 null 。

      • removeAttribute

        protected void removeAttribute​(String elementName,
                               String attrName)
        从先前定义的元素中删除一个属性。 如果给定元素中没有给定名称的属性，则不会发生任何事情，也不会抛出任何异常。
        参数
        elementName - 元素的名称。
        attrName - 要删除的属性的名称。
        异常
        IllegalArgumentException - 如果 elementName是 null ，或者不是此格式的法定元素名称。

      • addObjectValue

        protected <T> void addObjectValue​(String elementName,
                                  Class<T> classType,
                                  boolean required,
                                  T defaultValue)
        允许Object要被存储在实现指定元素的节点给定类型的参考。 Object的值不受其类型的约束。

        如果以前允许Object引用，以前的设置将被覆盖。

        参数类型
        T - 对象的类型。
        参数
        elementName - 元素的名称。
        classType - 一个 Class变量，指示对象值的合法类类型。
        如果对象值必须存在， required - true 。
        defaultValue - Object参考的默认值，或 null 。
        异常
        IllegalArgumentException - 如果 elementName是 null ，或者不是此格式的合法元素名称。

      • addObjectValue

        protected <T> void addObjectValue​(String elementName,
                                  Class<T> classType,
                                  boolean required,
                                  T defaultValue,
                                  List<? extends T> enumeratedValues)
        允许给定类类型的Object引用存储在实现命名元素的节点中。 Object的值必须是enumeratedValues给出的值enumeratedValues 。

        如果以前允许Object引用，则以前的设置将被覆盖。

        参数类型
        T - 对象的类型。
        参数
        elementName - 元素的名称。
        classType - 一个 Class变量，指示对象值的合法类类型。
        required - true如果一个对象值必须存在。
        defaultValue - Object参考的默认值，或 null 。
        enumeratedValues - 一个 List的 Object其中包含对象引用的合法值。
        异常
        IllegalArgumentException - 如果 elementName是 null ，或者不是此格式的法定元素名称。
        IllegalArgumentException - 如果 enumeratedValues是 null 。
        IllegalArgumentException - 如果 enumeratedValues不包含至少一个条目。
        IllegalArgumentException - 如果 enumeratedValues包含不是由 classType表示的类型的实例的元素，或者是 null 。

      • addObjectValue

        protected <T extends Object & Comparable<? super T>> void addObjectValue​(String elementName,
                                                                         Class<T> classType,
                                                                         T defaultValue,
                                                                         Comparable<? super T> minValue,
                                                                         Comparable<? super T> maxValue,
                                                                         boolean minInclusive,
                                                                         boolean maxInclusive)
        允许给定类类型的Object引用存储在实现命名元素的节点中。 Object的值必须在minValue和maxValue给出的范围内。 此外，类类型必须实现Comparable接口。

        如果以前允许Object引用，则以前的设置将被覆盖。

        参数类型
        T - 对象的类型。
        参数
        elementName - 元素的名称。
        classType - 一个 Class变量，指示对象值的合法类类型。
        defaultValue - 的默认值
        minValue - 最小（包括或排除取决于 minInclusive的值）对象值的合法值，作为 String 。
        maxValue - 最大（包括或排除取决于 minInclusive的值）对象值的合法值，作为 String 。
        minInclusive - true如果是 minValue ）。
        maxInclusive - true如果 maxValue是包容。
        异常
        IllegalArgumentException - 如果 elementName为 null ，或不是此格式的合法元素名称。

      • addObjectValue

        protected void addObjectValue​(String elementName,
                              Class<?> classType,
                              int arrayMinLength,
                              int arrayMaxLength)
        允许Object要被存储在实现指定元素的节点给定类型的参考。 Object的值必须由classType给出的类类型的classType ，至少有arrayMinLength和最多arrayMaxLength元素。

        如果以前允许引用Object ，以前的设置将被覆盖。

        参数
        elementName - 元素的名称。
        classType - 一个 Class变量，指示对象值的合法类类型。
        arrayMinLength - 数组的最小合法长度。
        arrayMaxLength - 阵列最大合法长度。
        异常
        IllegalArgumentException - 如果 elementName不是此格式的合法元素名称。

      • removeObjectValue

        protected void removeObjectValue​(String elementName)
        不允许将 Object引用存储在实现命名元素的节点中。
        参数
        elementName - 元素的名称。
        异常
        IllegalArgumentException - 如果 elementName不是此格式的合法元素名称。

      • getRootName

        public String getRootName​()
        描述从接口IIOMetadataFormat复制
        返回格式的根元素的名称。
        Specified by:
        getRootName在接口 IIOMetadataFormat
        结果
        一个 String 。

      • canNodeAppear

        public abstract boolean canNodeAppear​(String elementName,
                                      ImageTypeSpecifier imageType)
        描述从接口IIOMetadataFormat复制
        如果允许元素true的元素（及其下面的子树）显示给由ImageTypeSpecifier定义的给定类型的图像，则ImageTypeSpecifier 。 例如，元数据文档格式可能包含描述图像基本颜色的元素，这在编写灰度图像时不允许。
        Specified by:
        canNodeAppear在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        imageType - 表示将与元数据相关联的图像类型的 ImageTypeSpecifier 。
        结果
        true如果节点对于给定类型的图像是有意义的。

      • getElementMinChildren

        public int getElementMinChildren​(String elementName)
        描述从接口IIOMetadataFormat复制
        返回具有子策略CHILD_POLICY_REPEAT的命名元素的最CHILD_POLICY_REPEAT 。 例如，表示颜色主要信息的元素可能需要至少有3个小孩，每个小学一个。
        Specified by:
        getElementMinChildren在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 int 。

      • getElementMaxChildren

        public int getElementMaxChildren​(String elementName)
        描述从接口IIOMetadataFormat复制
        返回具有子策略CHILD_POLICY_REPEAT的命名元素的最大子CHILD_POLICY_REPEAT 。 例如，可以允许在8位调色板中表示条目的元素重复多达256次。 可以使用值Integer.MAX_VALUE来指定没有上限。
        Specified by:
        getElementMaxChildren在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 int 。

      • getElementDescription

        public String getElementDescription​(String elementName,
                                    Locale locale)
        返回String含有指定元素，或的描述null 。 如果可能，说明将被本地化为所提供的Locale 。

        默认的实现会首先找到一个ResourceBundle利用当前资源基本名称由设置setResourceBaseName和供应Locale ，使用中的注释中描述的应变机制ResourceBundle.getBundle 。 如果找到一个ResourceBundle ，则元素名称将用作其getString方法的键，并返回结果。 如果没有找到ResourceBundle ，或者没有这样的密钥， null将被退回。

        如果locale为null ，当前的默认Locale由归国Locale.getLocale将被使用。

        Specified by:
        getElementDescription在接口 IIOMetadataFormat
        参数
        elementName - 元素的名称。
        locale - 将尝试本地化的 Locale 。
        结果
        元素描述。
        异常
        IllegalArgumentException - 如果 elementName为 null ，或不是此格式的合法元素名称。
        另请参见：
        setResourceBaseName(java.lang.String)

      • getChildPolicy

        public int getChildPolicy​(String elementName)
        描述从界面IIOMetadataFormat复制
        返回从 CHILD_POLICY_开始的常量 CHILD_POLICY_ ，指示命名元素的子代的合法模式。
        Specified by:
        getChildPolicy在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        其中一个 CHILD_POLICY_*常量。

      • getChildNames

        public String[] getChildNames​(String elementName)
        说明从接口IIOMetadataFormat复制
        返回一个String s的数组，表示允许作为命名元素的子元素的元素的名称，按照它们应该出现的顺序。 如果该元素不能有子项，则返回null 。
        Specified by:
        getChildNames在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        一个数组为 String s，或为null。

      • getAttributeNames

        public String[] getAttributeNames​(String elementName)
        说明从接口IIOMetadataFormat复制
        返回一个 String的数组，列出可能与命名元素相关联的属性的名称。
        Specified by:
        getAttributeNames在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 String的阵列。

      • getAttributeValueType

        public int getAttributeValueType​(String elementName,
                                 String attrName)
        说明从接口IIOMetadataFormat复制
        返回以 VALUE_开头的常量 VALUE_ ，指示指定元素中给定属性的值是否是任意的，被限制在指定范围内，被限制为一组枚举值之一，或者是空格分隔的列表的任意值。
        Specified by:
        getAttributeValueType接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        其中一个 VALUE_*常数。

      • getAttributeDataType

        public int getAttributeDataType​(String elementName,
                                String attrName)
        描述从接口IIOMetadataFormat复制
        返回以DATATYPE_开头的常量DATATYPE_ ，表示指定元素中给定属性的值的格式和解释。 如果getAttributeValueType返回VALUE_LIST ，则合法值是返回数据类型的值的空白列表。
        Specified by:
        getAttributeDataType在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        其中一个 DATATYPE_*常量。

      • isAttributeRequired

        public boolean isAttributeRequired​(String elementName,
                                   String attrName)
        说明从接口IIOMetadataFormat复制
        如果命名的属性必须在命名的元素中，则返回 true 。
        Specified by:
        isAttributeRequired在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        true如果属性必须存在。

      • getAttributeDefaultValue

        public String getAttributeDefaultValue​(String elementName,
                                       String attrName)
        说明从接口IIOMetadataFormat复制
        如果没有默认值可用，则返回命名属性的默认值（如果它未显式存在于命名元素中）， String ，或 null 。
        Specified by:
        getAttributeDefaultValue在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        一个 String包含默认值，或 null 。

      • getAttributeEnumerations

        public String[] getAttributeEnumerations​(String elementName,
                                         String attrName)
        描述从接口IIOMetadataFormat复制
        返回一个包含指定元素中给定属性的合法枚举值的数组String 。 此方法只能在getAttributeValueType返回VALUE_ENUMERATION被调用。
        Specified by:
        getAttributeEnumerations在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        一个 String的阵列。

      • getAttributeMinValue

        public String getAttributeMinValue​(String elementName,
                                   String attrName)
        描述从接口IIOMetadataFormat复制
        返回属性的最小合法值。 该值是否包含或排除可以由值getAttributeValueType确定。 该值返回为String ; 其解释取决于getAttributeDataType的价值。 该方法只能在getAttributeValueType返回VALUE_RANGE_* 。
        Specified by:
        getAttributeMinValue在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        一个 String包含该属性的最小合法值。

      • getAttributeMaxValue

        public String getAttributeMaxValue​(String elementName,
                                   String attrName)
        说明从接口IIOMetadataFormat复制
        返回属性的最大合法值。 该值是否包含或排除可以由值getAttributeValueType确定。 该值返回为String ; 其解释取决于getAttributeDataType的值。 仅当getAttributeValueType返回VALUE_RANGE_*才应该调用此方法。
        Specified by:
        getAttributeMaxValue接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称，作为 String 。
        attrName - 要查询的属性的名称。
        结果
        一个 String包含该属性的最大合法值。

      • getAttributeListMinLength

        public int getAttributeListMinLength​(String elementName,
                                     String attrName)
        说明从接口IIOMetadataFormat复制
        返回可用于定义此属性的列表项的最小数量。 属性本身定义为包含多个空格分隔的项目的String 。 仅当getAttributeValueType返回VALUE_LIST才应该调用此方法。
        Specified by:
        getAttributeListMinLength在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        属性的列表项的最小合法数量。

      • getAttributeListMaxLength

        public int getAttributeListMaxLength​(String elementName,
                                     String attrName)
        说明从接口IIOMetadataFormat复制
        返回可用于定义此属性的列表项的最大数量。 可以使用值Integer.MAX_VALUE来指定没有上限。 属性本身定义为包含多个空格分隔的项目的String 。 该方法只能在getAttributeValueType返回VALUE_LIST被调用。
        Specified by:
        getAttributeListMaxLength在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        attrName - 要查询的属性的名称。
        结果
        属性的列表项的最大合法数量。

      • getAttributeDescription

        public String getAttributeDescription​(String elementName,
                                      String attrName,
                                      Locale locale)
        返回一个String其中包含命名属性的描述，或null 。 如果可能，说明将被本地化为所提供的Locale 。

        默认的实现会首先找到一个ResourceBundle利用当前资源基本名称由设置setResourceBaseName和供应Locale ，使用中的注释中描述的应变机制ResourceBundle.getBundle 。 如果找到一个ResourceBundle ，那么元素名称后跟一个“/”字符后跟属性名称（ elementName + "/" + attrName ）将被用作其getString方法的键，并返回结果。 如果没有找到ResourceBundle ，或者没有这样的密钥， null将被退回。

        如果locale为null ，当前的默认Locale由归国Locale.getLocale将被使用。

        Specified by:
        getAttributeDescription在接口 IIOMetadataFormat
        参数
        elementName - 元素的名称。
        attrName - 属性的名称。
        locale - 将尝试本地化的 Locale ，或 null 。
        结果
        属性描述。
        异常
        IllegalArgumentException - 如果 elementName是 null ，或者不是此格式的合法元素名称。
        IllegalArgumentException - 如果 attrName是 null或不是此元素的合法属性名称。
        另请参见：
        setResourceBaseName(java.lang.String)

      • getObjectValueType

        public int getObjectValueType​(String elementName)
        说明从接口IIOMetadataFormat复制
        返回以VALUE_开头的枚举值VALUE_ ，指示Object引用允许的值（枚举，范围或数组）的Object 。 如果给定元素中没有存储对象值，则该方法的结果将为VALUE_NONE 。

        Object引用的法定值定义为范围必须实现Comparable接口。

        Specified by:
        getObjectValueType接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        其中一个 VALUE_*常量。
        另请参见：
        Comparable

      • getObjectClass

        public Class<?> getObjectClass​(String elementName)
        描述从接口IIOMetadataFormat复制
        返回Class类型的Object存储在元素中引用。 如果此元素可能不包含Object引用，则将抛出IllegalArgumentException 。 如果类类型是数组，则该字段指示底层类型（ 例如 ，对于int的数组，此方法将返回int.class ）。

        Object引用的法定值定义为范围必须实现Comparable接口。

        Specified by:
        getObjectClass在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 Class对象。

      • getObjectDefaultValue

        public Object getObjectDefaultValue​(String elementName)
        说明从界面： IIOMetadataFormat复制
        返回一个 Object其中包含命名元素中的 Object引用的默认值。
        Specified by:
        getObjectDefaultValue接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 Object 。

      • getObjectEnumerations

        public Object[] getObjectEnumerations​(String elementName)
        说明从接口IIOMetadataFormat复制
        返回一个Object的数组， Object包含命名元素中的Object引用的合法枚举值。 该方法只能在getObjectValueType返回VALUE_ENUMERATION 。

        与接受枚举值的节点相关联的Object必须等于由==运算符定义的此方法返回的值之一（与Object.equals方法相反）。

        Specified by:
        getObjectEnumerations在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        一个 Object的阵列。

      • getObjectMinValue

        public Comparable<?> getObjectMinValue​(String elementName)
        说明从接口IIOMetadataFormat复制
        返回指定元素中Object引用的最小合法值。 该值是否包含或排除可以由值getObjectValueType确定。 只有当getObjectValueType返回以VALUE_RANGE开头的常量之一时，才应该调用此方法。
        Specified by:
        getObjectMinValue在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        该属性的最小合法值。

      • getObjectMaxValue

        public Comparable<?> getObjectMaxValue​(String elementName)
        描述从接口IIOMetadataFormat复制
        返回指定元素中Object引用的最大合法值。 该值是否包含或排除可由getObjectValueType的值确定。 仅当getObjectValueType返回以VALUE_RANGE开头的常量之一时，才应该调用此方法。
        Specified by:
        getObjectMaxValue在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        该属性的最小合法值。

      • getObjectArrayMinLength

        public int getObjectArrayMinLength​(String elementName)
        说明从界面IIOMetadataFormat复制
        返回可用于定义指定元素中的Object引用的最小数组元素数。 该方法只能在getObjectValueType返回VALUE_LIST 。
        Specified by:
        getObjectArrayMinLength在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        Object参考的最小有效数组长度。

      • getObjectArrayMaxLength

        public int getObjectArrayMaxLength​(String elementName)
        描述从接口IIOMetadataFormat复制
        返回可用于定义指定元素中的Object引用的最大数组元素数。 可以使用Integer.MAX_VALUE的值来指定没有上限。 该方法只能在getObjectValueType返回VALUE_LIST被调用。
        Specified by:
        getObjectArrayMaxLength在接口 IIOMetadataFormat
        参数
        elementName - 要查询的元素的名称。
        结果
        Object参考的最大有效数组长度。

      • getStandardFormatInstance

        public static IIOMetadataFormat getStandardFormatInstance​()
        描述 IIOMetadataFormat对象，描述 javax.imageio.metadata包的注释中描述的标准，插件中性 javax.imageio_1.0元数据文档格式。
        结果
        一个预定义的 IIOMetadataFormat实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


IIOMetadataNode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.metadata

Class IIOMetadataNode

  • java.lang.Object
    • javax.imageio.metadata.IIOMetadataNode
  • All Implemented Interfaces:
    Element ， Node ， NodeList

    public class IIOMetadataNode
extends Object
implements Element, NodeList
    表示元数据树中的节点的类，其实现org.w3c.dom.Element接口，并且还允许通过getUserObject和setUserObject方法存储非文本对象。

    此类不适用于一般的XML处理。 特别地，在Image I / O API中创建的Element节点与Sun的org.w3.dom API的标准实现创建的节点不兼容。 特别地，该实现被调整为简单的用途，并且对于密集处理可能不能很好地执行。

    命名空间在此实现中被忽略。 术语“标签名称”和“节点名称”总是被认为是同义词。 注：DOM Level 3的规格增加了一些新的方法到Node ， Element和Attr这是价值的未接口IIOMetadataNode实施或规范。 从IIOMetadataNode返回的IIOMetadataNode或Attr实例调用此类方法将导致抛出DOMException 。

    另请参见：
    IIOMetadata.getAsTree(java.lang.String) ，
IIOMetadata.setFromTree(java.lang.String, org.w3c.dom.Node) ，
IIOMetadata.mergeTree(java.lang.String, org.w3c.dom.Node)

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 构造方法摘要

      构造方法
      Constructor 描述
      IIOMetadataNode​()
      构造一个空的 IIOMetadataNode 。
      IIOMetadataNode​(String nodeName)
      构造具有给定节点名称的 IIOMetadataNode 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Node appendChild​(Node newChild)
      将节点 newChild添加到此节点的子节点列表的末尾。
      Node cloneNode​(boolean deep)
      返回此节点的副本。
      short compareDocumentPosition​(Node other)
      这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。
      String getAttribute​(String name)
      按名称检索属性值。
      Attr getAttributeNode​(String name)
      按名称检索属性节点。
      Attr getAttributeNodeNS​(String namespaceURI, String localName)
      相当于 getAttributeNode(localName) 。
      String getAttributeNS​(String namespaceURI, String localName)
      相当于 getAttribute(localName) 。
      NamedNodeMap getAttributes​()
      返回包含此节点的属性的 NamedNodeMap 。
      String getBaseURI​()
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      NodeList getChildNodes​()
      返回包含此节点的所有子节点的 NodeList 。
      NodeList getElementsByTagName​(String name)
      返回 NodeList所有子孙的 Elements具有给定标记名称，在文档顺序。
      NodeList getElementsByTagNameNS​(String namespaceURI, String localName)
      相当于 getElementsByTagName(localName) 。
      Object getFeature​(String feature, String version)
      这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。
      Node getFirstChild​()
      返回此节点的第一个子节点，如果该节点没有子节点，则返回 null 。
      Node getLastChild​()
      返回此节点的最后一个子节点，如果该节点没有子节点，则返回 null 。
      int getLength​()
      列表中的节点数。
      String getLocalName​()
      相当于 getNodeName 。
      String getNamespaceURI​()
      返回 null ，因为不支持命名空间。
      Node getNextSibling​()
      返回此节点的下一个兄弟节点，如果节点没有下一个兄弟节点，则返回 null 。
      String getNodeName​()
      返回与此节点相关联的节点名称。
      short getNodeType​()
      返回节点类型，始终为 ELEMENT_NODE 。
      String getNodeValue​()
      返回与该节点关联的值。
      Document getOwnerDocument​()
      退货 null ，由于 IIOMetadataNode不属于任何 Document 。
      Node getParentNode​()
      返回此节点的父节点。
      String getPrefix​()
      返回 null ，因为不支持命名空间。
      Node getPreviousSibling​()
      返回此节点的上一个同级，如果此节点没有以前的同级，则返回 null 。
      TypeInfo getSchemaTypeInfo​()
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      String getTagName​()
      相当于 getNodeName 。
      String getTextContent​()
      这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。
      Object getUserData​(String key)
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      Object getUserObject​()
      返回与此节点相关联的 Object值。
      boolean hasAttribute​(String name)
      返回 true当具有给定名称的属性在此元素上指定或具有默认值 false 。
      boolean hasAttributeNS​(String namespaceURI, String localName)
      相当于 hasAttribute(localName) 。
      boolean hasAttributes​()
      返回此节点（如果它是一个元素）是否具有任何属性。
      boolean hasChildNodes​()
      如果此节点具有子节点，则返回 true 。
      Node insertBefore​(Node newChild, Node refChild)
      插入节点 newChild现有的子节点之前 refChild 。
      boolean isDefaultNamespace​(String namespaceURI)
      这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。
      boolean isEqualNode​(Node node)
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      boolean isSameNode​(Node node)
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      boolean isSupported​(String feature, String version)
      返回 false因为不支持DOM功能。
      Node item​(int index)
      返回集合中的 index项目。
      String lookupNamespaceURI​(String prefix)
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      String lookupPrefix​(String namespaceURI)
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      void normalize​()
      没有，因为 IIOMetadataNode的不包含 Text孩子。
      void removeAttribute​(String name)
      按名称删除属性。
      Attr removeAttributeNode​(Attr oldAttr)
      删除指定的属性节点。
      void removeAttributeNS​(String namespaceURI, String localName)
      相当于 removeAttribute(localName) 。
      Node removeChild​(Node oldChild)
      从子列表中删除由 oldChild指示的子节点，并返回。
      Node replaceChild​(Node newChild, Node oldChild)
      替换子节点 oldChild与 newChild儿童的名单，并返回 oldChild节点。
      void setAttribute​(String name, String value)
      添加一个新属性。
      Attr setAttributeNode​(Attr newAttr)
      添加一个新的属性节点。
      Attr setAttributeNodeNS​(Attr newAttr)
      相当于 setAttributeNode(newAttr) 。
      void setAttributeNS​(String namespaceURI, String qualifiedName, String value)
      相当于 setAttribute(qualifiedName, value) 。
      void setIdAttribute​(String name, boolean isId)
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      void setIdAttributeNode​(Attr idAttr, boolean isId)
      这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。
      void setIdAttributeNS​(String namespaceURI, String localName, boolean isId)
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      void setNodeValue​(String nodeValue)
      设置与此节点相关联的 String值。
      void setPrefix​(String prefix)
      不支持命名空间，
      void setTextContent​(String textContent)
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      Object setUserData​(String key, Object data, UserDataHandler handler)
      IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
      void setUserObject​(Object userObject)
      设置与该节点关联的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IIOMetadataNode

        public IIOMetadataNode​()
        构造一个空的 IIOMetadataNode 。

      • IIOMetadataNode

        public IIOMetadataNode​(String nodeName)
        构造具有给定节点名称的 IIOMetadataNode 。
        参数
        nodeName - 节点的名称，作为 String 。

    • 方法详细信息

      • getNodeName

        public String getNodeName​()
        返回与此节点相关联的节点名称。
        Specified by:
        getNodeName在接口 Node
        结果
        节点名称，作为 String 。

      • getNodeValue

        public String getNodeValue​()
        返回与该节点关联的值。
        Specified by:
        getNodeValue在接口 Node
        结果
        节点值，作为 String 。

      • setNodeValue

        public void setNodeValue​(String nodeValue)
        设置与此节点相关联的 String值。
        Specified by:
        setNodeValue在接口 Node

      • getNodeType

        public short getNodeType​()
        返回节点类型，始终为 ELEMENT_NODE 。
        Specified by:
        getNodeType在接口 Node
        结果
        short价值 ELEMENT_NODE 。

      • getParentNode

        public Node getParentNode​()
        返回此节点的父节点。 一个null值表示该节点是其自己的树的根。 要将节点添加到现有的树，使用的一个insertBefore ， replaceChild ，或appendChild方法。
        Specified by:
        getParentNode在接口 Node
        结果
        父母，作为一个 Node 。
        另请参见：
        insertBefore(org.w3c.dom.Node, org.w3c.dom.Node) ，
replaceChild(org.w3c.dom.Node, org.w3c.dom.Node) ，
appendChild(org.w3c.dom.Node)

      • getChildNodes

        public NodeList getChildNodes​()
        返回一个包含此节点的所有子节点的NodeList 。 如果没有孩子，这是一个NodeList包含节点的NodeList 。
        Specified by:
        getChildNodes在接口 Node
        结果
        孩子们为 NodeList

      • getFirstChild

        public Node getFirstChild​()
        返回此节点的第一个子节点，如果该节点没有子节点，则返回 null 。
        Specified by:
        getFirstChild在接口 Node
        结果
        第一个孩子，作为 Node ，或 null

      • getLastChild

        public Node getLastChild​()
        返回此节点的最后一个子节点，如果该节点没有子节点，则返回 null 。
        Specified by:
        getLastChild在接口 Node
        结果
        最后一个孩子，作为 Node ，或 null 。

      • getPreviousSibling

        public Node getPreviousSibling​()
        返回此节点的上一个兄弟节点，如果此节点没有以前的兄弟节点，则返回 null 。
        Specified by:
        getPreviousSibling在接口 Node
        结果
        以前的兄弟姐妹，作为 Node ，或 null 。

      • getNextSibling

        public Node getNextSibling​()
        返回此节点的下一个兄弟节点，如果节点没有下一个兄弟节点，则返回 null 。
        Specified by:
        getNextSibling在接口 Node
        结果
        下一个兄弟姐妹，如 Node或 null 。

      • getAttributes

        public NamedNodeMap getAttributes​()
        返回包含此节点属性的 NamedNodeMap 。
        Specified by:
        getAttributes在接口 Node
        结果
        一个 NamedNodeMap包含此节点的属性。

      • getOwnerDocument

        public Document getOwnerDocument​()
        退货 null ，因为 IIOMetadataNode不属于任何 Document 。
        Specified by:
        getOwnerDocument在接口 Node
        结果
        null 。

      • insertBefore

        public Node insertBefore​(Node newChild,
                         Node refChild)
        插入节点newChild现有的子节点之前refChild 。 如果refChild是null ， newChild在子列表的末尾插入newChild 。
        Specified by:
        insertBefore在接口 Node
        参数
        newChild - 要插入的 Node 。
        refChild - 参考 Node 。
        结果
        该节点被插入。
        异常
        IllegalArgumentException - 如果 newChild是 null 。

      • replaceChild

        public Node replaceChild​(Node newChild,
                         Node oldChild)
        替换子节点 oldChild与 newChild儿童的名单，并返回 oldChild节点。
        Specified by:
        replaceChild在接口 Node
        参数
        newChild - 要插入的 Node 。
        oldChild - 要更换的 Node 。
        结果
        节点被替换。
        异常
        IllegalArgumentException - 如果 newChild是 null 。

      • removeChild

        public Node removeChild​(Node oldChild)
        从小孩列表中删除 oldChild指示的子节点，并返回。
        Specified by:
        removeChild在接口 Node
        参数
        oldChild - 要删除的 Node 。
        结果
        节点被删除。
        异常
        IllegalArgumentException - 如果 oldChild是 null 。

      • appendChild

        public Node appendChild​(Node newChild)
        将节点 newChild添加到此节点的子节点列表的末尾。
        Specified by:
        appendChild在接口 Node
        参数
        newChild - 要插入的 Node 。
        结果
        节点被添加。
        异常
        IllegalArgumentException - 如果 newChild是 null 。

      • hasChildNodes

        public boolean hasChildNodes​()
        如果此节点具有子节点，则返回 true 。
        Specified by:
        hasChildNodes在接口 Node
        结果
        true如果此节点有子节点。

      • cloneNode

        public Node cloneNode​(boolean deep)
        返回此节点的副本。 重复节点没有父节点（ getParentNode返回null ）。 如果正在执行浅克隆（ deep是false ），新节点将不会有任何子节点或兄弟节点。 如果正在执行深克隆，则新节点将构成完整克隆子树的根。
        Specified by:
        cloneNode在接口 Node
        参数
        deep - 如果是true ，递归地克隆指定节点下的子树; 如果是false ，则只克隆节点本身。
        结果
        重复节点。

      • normalize

        public void normalize​()
        没有，因为 IIOMetadataNode的不包含 Text孩子。
        Specified by:
        normalize在接口 Node

      • isSupported

        public boolean isSupported​(String feature,
                           String version)
        返回 false因为不支持DOM功能。
        Specified by:
        isSupported在接口 Node
        参数
        feature - a String ，被忽略。
        version - a String ，被忽略。
        结果
        false 。

      • getNamespaceURI

        public String getNamespaceURI​()
                       throws DOMException
        返回 null ，因为不支持命名空间。
        Specified by:
        getNamespaceURI在接口 Node
        异常
        DOMException

      • getPrefix

        public String getPrefix​()
        返回 null ，因为不支持命名空间。
        Specified by:
        getPrefix在接口 Node
        结果
        null 。
        另请参见：
        setPrefix(java.lang.String)

      • setPrefix

        public void setPrefix​(String prefix)
        不支持命名空间，
        Specified by:
        setPrefix在接口 Node
        参数
        prefix - a String ，被忽略。
        另请参见：
        getPrefix()

      • getLocalName

        public String getLocalName​()
        相当于 getNodeName 。
        Specified by:
        getLocalName在接口 Node
        结果
        节点名称，作为 String 。

      • getTagName

        public String getTagName​()
        相当于 getNodeName 。
        Specified by:
        getTagName在接口 Element
        结果
        节点名称，作为 String

      • getAttribute

        public String getAttribute​(String name)
        按名称检索属性值。
        Specified by:
        getAttribute接口 Element
        参数
        name - 要检索的属性的名称。
        结果
        Attr值作为字符串，或空字符串，如果该属性没有指定或默认值。

      • getAttributeNS

        public String getAttributeNS​(String namespaceURI,
                             String localName)
        相当于 getAttribute(localName) 。
        Specified by:
        getAttributeNS在接口 Element
        参数
        namespaceURI - 要检索的属性的命名空间URI。
        localName - 要检索的属性的本地名称。
        结果
        Attr值作为字符串，或空字符串，如果该属性没有指定或默认值。
        另请参见：
        setAttributeNS(java.lang.String, java.lang.String, java.lang.String)

      • setAttribute

        public void setAttribute​(String name,
                         String value)
        描述从接口Element复制
        添加一个新属性。 如果具有该名称的属性已经存在于元素中，则其值将更改为value参数的值。 这个值是一个简单的字符串; 它不被解析，因为它被设置。 因此，任何标记（例如要被识别为实体引用的语法）被视为文本文本，并且在写出时需要被实现适当地转义。 为了分配包含实体引用的属性值，用户必须创建一个Attr节点加上任何Text和EntityReference节点，构建适当的子树，并使用setAttributeNode将其分配为属性的值。
        要使用限定名称和命名空间URI设置属性，请使用setAttributeNS方法。
        Specified by:
        setAttribute接口 Element
        参数
        name - 要创建或更改的属性的名称。
        value - 以字符串形式设置的值。

      • setAttributeNS

        public void setAttributeNS​(String namespaceURI,
                           String qualifiedName,
                           String value)
        相当于 setAttribute(qualifiedName, value) 。
        Specified by:
        setAttributeNS在接口 Element
        参数
        namespaceURI - 要创建或更改的属性的命名空间URI。
        qualifiedName - 要创建或更改的属性的限定名称。
        value - 以字符串形式设置的值。
        另请参见：
        getAttributeNS(java.lang.String, java.lang.String)

      • removeAttribute

        public void removeAttribute​(String name)
        说明从界面Element复制
        按名称删除属性。 如果在DTD中定义了已删除属性的默认值，则在适用时，会立即出现一个新属性，默认值以及相应的名称空间URI，本地名称和前缀。 该实现可能类似地处理来自其他模式的默认值，但应用程序应使用Document.normalizeDocument()来保证此信息是最新的。
        如果没有找到具有此名称的属性，则此方法无效。
        要通过本地名称和命名空间URI删除属性，请使用removeAttributeNS方法。
        Specified by:
        removeAttribute在接口 Element
        参数
        name - 要删除的属性的名称。

      • removeAttributeNS

        public void removeAttributeNS​(String namespaceURI,
                              String localName)
        相当于 removeAttribute(localName) 。
        Specified by:
        removeAttributeNS在接口 Element
        参数
        namespaceURI - 要删除的属性的命名空间URI。
        localName - 要删除的属性的本地名称。

      • getAttributeNode

        public Attr getAttributeNode​(String name)
        说明从界面Element复制
        按名称检索属性节点。
        要通过限定名称和命名空间URI检索属性节点，请使用getAttributeNodeNS方法。
        Specified by:
        getAttributeNode在接口 Element
        参数
        name - 要检索的属性的名称（ nodeName ）。
        结果
        具有指定名称（ nodeName ）或 null的 Attr节点，如果没有此类属性。

      • getAttributeNodeNS

        public Attr getAttributeNodeNS​(String namespaceURI,
                               String localName)
        相当于 getAttributeNode(localName) 。
        Specified by:
        getAttributeNodeNS在接口 Element
        参数
        namespaceURI - 要检索的属性的命名空间URI。
        localName - 要检索的属性的本地名称。
        结果
        具有指定属性本地名称和命名空间URI的 Attr节点或 null如果没有这样的属性。
        另请参见：
        setAttributeNodeNS(org.w3c.dom.Attr)

      • setAttributeNode

        public Attr setAttributeNode​(Attr newAttr)
                      throws DOMException
        描述从接口Element复制
        添加一个新的属性节点。 如果具有该名称的属性（ nodeName ）已经存在于元素中，则会被新的属性替换。 替换属性节点本身不起作用。
        要添加具有限定名称和命名空间URI的新属性节点，请使用setAttributeNodeNS方法。
        Specified by:
        setAttributeNode接口 Element
        参数
        newAttr - 要添加到属性列表的 Attr节点。
        结果
        如果 newAttr属性替换现有属性，则返回替换的 Attr节点，否则返回 null 。
        异常
        DOMException - WRONG_DOCUMENT_ERR：如果newAttr是从创建该元素的文档创建的文档而newAttr的。
        NO_MODIFICATION_ALLOWED_ERR：如果此节点是只读的，则引发。
        INUSE_ATTRIBUTE_ERR：如果newAttr已经是另一个Element对象的属性，则Element 。 DOM用户必须显式克隆Attr节点，以便在其他元素中重新使用它们。

      • setAttributeNodeNS

        public Attr setAttributeNodeNS​(Attr newAttr)
        相当于 setAttributeNode(newAttr) 。
        Specified by:
        setAttributeNodeNS在接口 Element
        参数
        newAttr - 要添加到属性列表的 Attr节点。
        结果
        如果 newAttr属性用相同的本地名称和命名空间URI替换现有属性，则返回替换的 Attr节点，否则返回 null 。
        另请参见：
        getAttributeNodeNS(java.lang.String, java.lang.String)

      • removeAttributeNode

        public Attr removeAttributeNode​(Attr oldAttr)
        描述从接口Element复制
        删除指定的属性节点。 如果在DTD中定义了已删除的Attr节点的默认值，则在适用时，将立即出现一个新节点，并显示默认值以及相应的命名空间URI，本地名称和前缀。 该实现可能类似地处理来自其他模式的默认值，但应用程序应使用Document.normalizeDocument()来保证此信息是最新的。
        Specified by:
        removeAttributeNode在接口 Element
        参数
        oldAttr - 要从属性列表中删除的 Attr节点。
        结果
        已删除的 Attr节点。

      • getElementsByTagName

        public NodeList getElementsByTagName​(String name)
        说明从接口Element复制
        返回 NodeList所有子孙的 Elements具有给定标记名称，在文档顺序。
        Specified by:
        getElementsByTagName在接口 Element
        参数
        name - 要匹配的标签的名称。 特殊值“*”匹配所有标签。
        结果
        匹配的列表 Element节点。

      • getElementsByTagNameNS

        public NodeList getElementsByTagNameNS​(String namespaceURI,
                                       String localName)
        相当于 getElementsByTagName(localName) 。
        Specified by:
        getElementsByTagNameNS接口 Element
        参数
        namespaceURI - 要匹配的元素的命名空间URI。 特殊值“*”匹配所有命名空间。
        localName - 要匹配的元素的本地名称。 特殊值“*”与所有本地名称相匹配。
        结果
        一个新的 NodeList对象包含所有匹配的 Elements 。

      • hasAttributes

        public boolean hasAttributes​()
        描述从接口Node复制
        返回此节点（如果它是一个元素）是否具有任何属性。
        Specified by:
        hasAttributes在接口 Node
        结果
        返回 true如果此节点具有任何属性， false否则。

      • hasAttribute

        public boolean hasAttribute​(String name)
        说明从界面Element复制
        返回 true当具有给定名称的属性在此元素上指定或具有默认值 false 。
        Specified by:
        hasAttribute在接口 Element
        参数
        name - 要查找的属性的名称。
        结果
        true如果在该元素上指定了具有给定名称的属性，或者具有默认值， false 。

      • hasAttributeNS

        public boolean hasAttributeNS​(String namespaceURI,
                              String localName)
        相当于 hasAttribute(localName) 。
        Specified by:
        hasAttributeNS在接口 Element
        参数
        namespaceURI - 要查找的属性的命名空间URI。
        localName - 要查找的属性的本地名称。
        结果
        true如果指定了具有给定的本地名称和命名空间URI的属性，或者在该元素上具有默认值， false 。

      • getLength

        public int getLength​()
        描述从接口NodeList复制
        列表中的节点数。 有效子节点索引的范围为0到length-1含）。
        Specified by:
        getLength在接口 NodeList

      • item

        public Node item​(int index)
        描述从接口NodeList复制
        返回集合中的index项目。 如果index大于或等于列表中的节点数，则返回null 。
        Specified by:
        item在接口 NodeList
        参数
        index - 索引到集合。
        结果
        该节点在 index位置在 NodeList ，或 null如果那不是有效的索引。

      • getUserObject

        public Object getUserObject​()
        返回与此节点相关联的 Object值。
        结果
        用户 Object 。
        另请参见：
        setUserObject(java.lang.Object)

      • setUserObject

        public void setUserObject​(Object userObject)
        设置与该节点关联的值。
        参数
        userObject - 用户 Object 。
        另请参见：
        getUserObject()

      • setIdAttribute

        public void setIdAttribute​(String name,
                           boolean isId)
                    throws DOMException
        IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        setIdAttribute在接口 Element
        参数
        name - 属性的名称。
        isId - 属性是否是类型ID。
        异常
        DOMException - 永远。

      • setIdAttributeNS

        public void setIdAttributeNS​(String namespaceURI,
                             String localName,
                             boolean isId)
                      throws DOMException
        IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        setIdAttributeNS在接口 Element
        参数
        namespaceURI - 属性的命名空间URI。
        localName - 属性的本地名称。
        isId - 属性是否为类型ID。
        异常
        DOMException - 永远。

      • setIdAttributeNode

        public void setIdAttributeNode​(Attr idAttr,
                               boolean isId)
                        throws DOMException
        对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        setIdAttributeNode在接口 Element
        参数
        idAttr - 属性节点。
        isId - 属性是否为类型ID。
        异常
        DOMException - 永远。

      • getSchemaTypeInfo

        public TypeInfo getSchemaTypeInfo​()
                           throws DOMException
        IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        getSchemaTypeInfo在接口 Element
        异常
        DOMException - 永远。

      • setUserData

        public Object setUserData​(String key,
                          Object data,
                          UserDataHandler handler)
                   throws DOMException
        对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        setUserData在接口 Node
        参数
        key - 将对象关联到的关键。
        data - 与给定键相关联的对象，或 null以删除与该键的任何现有关联。
        handler - 与该键关联的处理程序，或 null 。
        结果
        返回以前与此节点上的给定键相关联的 null如果没有，则返回 DOMUserData 。
        异常
        DOMException - 永远。

      • getUserData

        public Object getUserData​(String key)
                   throws DOMException
        IIOMetadataNode不支持此DOM 3级方法，并会抛出一个 DOMException 。
        Specified by:
        getUserData在接口 Node
        参数
        key - 对象所关联的关键字。
        结果
        返回与此节点上的给定键相关联的 null如果没有，则返回 DOMUserData 。
        异常
        DOMException - 永远。

      • getFeature

        public Object getFeature​(String feature,
                         String version)
                  throws DOMException
        IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        getFeature在接口 Node
        参数
        feature - 请求的功能的名称。 请注意，功能名称之前的任何加号“+”将被忽略，因为在此方法的上下文中不重要。
        version - 这是要测试的功能的版本号。
        结果
        返回一个对象，该对象实现指定功能和版本（如果有的话）的专用API，如果没有实现与该功能关联的接口的对象，则null 。 如果此方法返回的DOMObject实现了Node接口，则必须委托给主核心Node ，而不返回与主核心Node （如属性，子节点等）不一致的结果。
        异常
        DOMException - 永远。

      • isSameNode

        public boolean isSameNode​(Node node)
                   throws DOMException
        IIOMetadataNode不支持此DOM 3级方法，并将抛出 DOMException 。
        Specified by:
        isSameNode在接口 Node
        参数
        node - 要测试的节点。
        结果
        返回 true如果节点是相同的， false否则。
        异常
        DOMException - 永远。

      • isEqualNode

        public boolean isEqualNode​(Node node)
                    throws DOMException
        IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        isEqualNode在接口 Node
        参数
        node - 与...相比较的节点。
        结果
        返回 true如果节点相等， false否则。
        异常
        DOMException - 永远。

      • lookupNamespaceURI

        public String lookupNamespaceURI​(String prefix)
                          throws DOMException
        这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。
        Specified by:
        lookupNamespaceURI在接口 Node
        参数
        prefix - 要查找的前缀。 如果此参数为null ，则该方法将返回默认名称空间URI（如果有）。
        结果
        如果没有找到，返回相关的命名空间URI或 null 。
        异常
        DOMException - 永远。

      • isDefaultNamespace

        public boolean isDefaultNamespace​(String namespaceURI)
                           throws DOMException
        这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。
        Specified by:
        isDefaultNamespace在接口 Node
        参数
        namespaceURI - 要查找的命名空间URI。
        结果
        返回 true如果指定 namespaceURI是默认的命名空间， false否则。
        异常
        DOMException - 永远。

      • lookupPrefix

        public String lookupPrefix​(String namespaceURI)
                    throws DOMException
        这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。
        Specified by:
        lookupPrefix在接口 Node
        参数
        namespaceURI - 要查找的命名空间URI。
        结果
        如果找到，返回一个关联的命名空间前缀，如果没有找到，返回null 。 如果多个前缀与命名空间前缀相关联，则返回的命名空间前缀取决于实现。
        异常
        DOMException - 永远。

      • getTextContent

        public String getTextContent​()
                      throws DOMException
        IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        getTextContent在接口 Node
        异常
        DOMException - 永远。

      • setTextContent

        public void setTextContent​(String textContent)
                    throws DOMException
        对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        setTextContent在接口 Node
        异常
        DOMException - 永远。

      • compareDocumentPosition

        public short compareDocumentPosition​(Node other)
                              throws DOMException
        IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        compareDocumentPosition在接口 Node
        参数
        other - 与参考节点进行比较的节点。
        结果
        返回节点相对于参考节点的位置。
        异常
        DOMException - 永远。

      • getBaseURI

        public String getBaseURI​()
                  throws DOMException
        对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
        Specified by:
        getBaseURI在接口 Node
        异常
        DOMException - 永远。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.imageio.metadata (Java SE 9 & JDK 9 )

javax.imageio.metadata

Interfaces

  • IIOMetadataController
  • IIOMetadataFormat

Classes

  • IIOMetadata
  • IIOMetadataFormatImpl
  • IIOMetadataNode

Exceptions

  • IIOInvalidTreeException


javax.imageio.metadata (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package javax.imageio.metadata

处理读写元数据的Java Image I / O API的一个包。

当读取图像时，其每个流和每个图像元数据可用作IIOMetadata对象。 该对象的内部特定于创建它的插件。 其内容可以以Document的形式被访问，其被实现为IIOMetadataNode对象的树。

在写入图像时，可以通过定义或修改IIOMetadata对象来设置其元数据。 这样的对象可以从ImageWriter或ImageTranscoder （从javax.imageio包）获得。 一旦获得这样的对象，其内容可以通过由Document组成的IIOMetadataNode进行修改。 可以使用IIOMetadataFormat对象来可选地描述文档格式。

包含在XML Document中的元数据的格式由一个字符串来标识，该字符串显示为IIOMetadataNode对象的树的IIOMetadataNode 。 此字符串包含版本号，例如“javax_imageio_jpeg_image_1.0”。 读者和作者可能支持相同基本格式的多个版本，Image I / O API具有允许通过将字符串传递给用于获取IIOMetadata对象的方法/构造函数来指定要使用哪个版本的方法。 在某些情况下，更新版本可能与预期旧版本的程序严格兼容（例如，请参阅下面的“JPEG元数据使用说明”的本机元数据格式部分）。

插件可能会选择支持standard (plug-in neutral) format 。 该格式不提供元数据的无损编码，但允许以通用方式访问部分元数据。

每个标准插件都支持所谓的“本机”元数据格式，可以无损地对其元数据进行编码：

  • BMP metadata
  • GIF metadata
  • JPEG metadata
  • PNG metadata
  • TIFF metadata
  • WBMP metadata
从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    IIOMetadataController
    要由可以通过建立GUI以从用户获取值或通过其他方式确定 IIOMetadata对象的设置的对象来实现的接口。
    IIOMetadataFormat
    描述从 IIOMetadata.getAsTree返回并传递给 IIOMetadata.setFromTree和 mergeTree的元数据文档的结构的对象。
  • 类摘要
    Class 描述
    IIOMetadata
    由与图像和流相关联的元数据（非图像数据）的对象扩展的抽象类。
    IIOMetadataFormatImpl
    一个具体的类，提供 IIOMetadataFormat接口的可重用实现。
    IIOMetadataNode
    表示元数据树中的节点的类，其实现 org.w3c.dom.Element接口，并且还允许通过 getUserObject和 setUserObject方法存储非文本对象。
  • 异常摘要
    异常 描述
    IIOInvalidTreeException
    An IIOInvalidTreeException is thrown when an attempt by an IIOMetadata object to parse a tree of IIOMetadataNodes fails.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.imageio.metadata Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.imageio.metadata

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.imageio.metadata.IIOMetadata
    • javax.imageio.metadata.IIOMetadataFormatImpl (implements javax.imageio.metadata.IIOMetadataFormat)
    • javax.imageio.metadata.IIOMetadataNode (implements org.w3c.dom.Element, org.w3c.dom.NodeList)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • javax.imageio.IIOException
            • javax.imageio.metadata.IIOInvalidTreeException

Interface Hierarchy

  • javax.imageio.metadata.IIOMetadataController
  • javax.imageio.metadata.IIOMetadataFormat
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package javax.imageio.metadata (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.imageio.metadata

  • Packages that use javax.imageio.metadata
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
  • Classes in javax.imageio.metadata used by javax.imageio
    Class 描述
    IIOMetadata
    由与图像和流相关联的元数据（非图像数据）的对象扩展的抽象类。
  • Classes in javax.imageio.metadata used by javax.imageio.metadata
    Class 描述
    IIOInvalidTreeException
    一个 IIOInvalidTreeException当被试图抛出 IIOMetadata对象来解析树 IIOMetadataNode小号失败。
    IIOMetadata
    由与图像和流相关联的元数据（非图像数据）的对象扩展的抽象类。
    IIOMetadataController
    要由可以通过放置GUI以从用户获取值或通过其他方式确定 IIOMetadata对象的设置的对象来实现的接口。
    IIOMetadataFormat
    描述从 IIOMetadata.getAsTree返回并传递给 IIOMetadata.setFromTree和 mergeTree的元数据文档的结构的对象。
    IIOMetadataNode
    表示元数据树中的节点的类，其实现 org.w3c.dom.Element接口，并且还允许通过 getUserObject和 setUserObject方法存储非文本对象。
  • Classes in javax.imageio.metadata used by javax.imageio.plugins.tiff
    Class 描述
    IIOInvalidTreeException
    一个 IIOInvalidTreeException当被试图抛出 IIOMetadata对象来解析树 IIOMetadataNode小号失败。
    IIOMetadata
    由与图像和流相关联的元数据（非图像数据）的对象扩展的抽象类。
  • Classes in javax.imageio.metadata used by javax.imageio.spi
    Class 描述
    IIOMetadataFormat
    An object describing the structure of metadata documents returned from IIOMetadata.getAsTree and passed to IIOMetadata.setFromTree and mergeTree.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.metadata.IIOInvalidTreeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.metadata.IIOInvalidTreeException

  • Packages that use IIOInvalidTreeException
    软件包 描述
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of IIOInvalidTreeException in javax.imageio.metadata

      Methods in javax.imageio.metadata that throw IIOInvalidTreeException
      Modifier and Type 方法 描述
      abstract void IIOMetadata.mergeTree​(String formatName, Node root)
      从XML DOM Node的树中更改此 IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。
      void IIOMetadata.setFromTree​(String formatName, Node root)
      从XML DOM Node的树中设置此 IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。

    • Uses of IIOInvalidTreeException in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that throw IIOInvalidTreeException
      Modifier and Type 方法 描述
      static TIFFDirectory TIFFDirectory.createFromMetadata​(IIOMetadata tiffImageMetadata)
      从图像元数据对象的内容创建一个 TIFFDirectory实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.metadata.IIOMetadata (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.metadata.IIOMetadata

  • Packages that use IIOMetadata
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of IIOMetadata in javax.imageio

      Fields in javax.imageio declared as IIOMetadata
      Modifier and Type Field 描述
      protected IIOMetadata IIOImage.metadata
      包含与图像相关联的元数据的 IIOMetadata对象。
      Methods in javax.imageio that return IIOMetadata
      Modifier and Type | 方法 | 描述
      IIOMetadata ImageTranscoder.convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可使用其文档接口或特定于将用于编码的writer插件的其他接口进行修改。
      abstract IIOMetadata | ImageWriter.convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      IIOMetadata ImageTranscoder.convertStreamMetadata​(IIOMetadata inData, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可以使用其文档接口或特定于将用于编码的writer插件的其他接口进行可选修改。
      abstract IIOMetadata | ImageWriter.convertStreamMetadata​(IIOMetadata inData, ImageWriteParam param)
      abstract IIOMetadata ImageWriter.getDefaultImageMetadata​(ImageTypeSpecifier imageType, ImageWriteParam param)
      返回一个包含用于对给定类型的图像进行编码的默认值的 IIOMetadata对象。
      abstract IIOMetadata ImageWriter.getDefaultStreamMetadata​(ImageWriteParam param)
      返回一个包含用于编码图像流的默认值的 IIOMetadata对象。
      abstract IIOMetadata ImageReader.getImageMetadata​(int imageIndex)
      返回一个 IIOMetadata与给定图像，或相关联的对象包含元数据 null如果读取器不支持读取元数据，被设置为忽略元数据，或者，如果没有元数据可用。
      IIOMetadata ImageReader.getImageMetadata​(int imageIndex, String formatName, Set<String> nodeNames)
      返回一个 IIOMetadata表示与给定图像，或相关联的元数据对象 null如果读取器不支持读取元数据或没有可用的。
      IIOMetadata IIOImage.getMetadata​()
      返回对当前 IIOMetadata对象的引用，或者 null没有设置。
      abstract IIOMetadata ImageReader.getStreamMetadata​()
      返回一个 IIOMetadata表示与输入源作为一个整体（即，不与任何特定图像相关联）相关联的元数据对象，或者 null如果读取器不支持读取元数据，被设置为忽略元数据，或者，如果没有元数据可用。
      IIOMetadata ImageReader.getStreamMetadata​(String formatName, Set<String> nodeNames)
      返回一个 IIOMetadata对象，表示与整个输入源相关联的元数据（即，不与任何特定图像相关联）。
      Methods in javax.imageio with parameters of type IIOMetadata
      Modifier and Type | 方法 | 描述
      IIOMetadata ImageTranscoder.convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可使用其文档接口或特定于将用于编码的writer插件的其他接口进行修改。
      abstract IIOMetadata | ImageWriter.convertImageMetadata​(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
      IIOMetadata ImageTranscoder.convertStreamMetadata​(IIOMetadata inData, ImageWriteParam param)
      返回可用于编码的 IIOMetadata对象，并可使用其文档接口或特定于将用于编码的writer插件的其他接口进行修改。
      abstract IIOMetadata | ImageWriter.convertStreamMetadata​(IIOMetadata inData, ImageWriteParam param)
      int ImageWriter.getNumThumbnailsSupported​(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata)
      给定图像类型以及编码期间将要使用的任何其他写入参数和元数据对象，返回由正在写入的格式支持的缩略图数。
      Dimension[] ImageWriter.getPreferredThumbnailSizes​(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata)
      返回 Dimension的数组，表示缩略图的合法大小范围，因为它们将被编码在输出文件或流中。
      void ImageWriter.prepareInsertEmpty​(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将未定义像素值的新图像插入到现有图像流中。
      void ImageWriter.prepareWriteEmpty​(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将一个完整的图像流写入到包含未定义像素值的单个图像和关联的元数据和缩略图中。
      void ImageWriter.prepareWriteSequence​(IIOMetadata streamMetadata)
      使用提供的流元数据对象准备流以接受一系列后续的 writeToSequence调用。
      void ImageWriter.replaceImageMetadata​(int imageIndex, IIOMetadata imageMetadata)
      替换与现有图像相关联的图像元数据。
      void ImageWriter.replaceStreamMetadata​(IIOMetadata streamMetadata)
      用新信息替换输出中的流元数据。
      void IIOImage.setMetadata​(IIOMetadata metadata)
      将 IIOMetadata设置为新对象，或 null 。
      abstract void ImageWriter.write​(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param)
      将包含单个图像和关联流以及图像元数据和缩略图的完整图像流附加到输出。
      Constructors in javax.imageio with parameters of type IIOMetadata
      Constructor 描述
      IIOImage​(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 Raster ，和缩略图和元数据与之相关联。
      IIOImage​(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 RenderedImage ，和缩略图和元数据与之相关联。

    • Uses of IIOMetadata in javax.imageio.metadata

      Methods in javax.imageio.metadata with parameters of type IIOMetadata
      Modifier and Type 方法 描述
      boolean IIOMetadataController.activate​(IIOMetadata metadata)
      激活控制器。

    • Uses of IIOMetadata in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return IIOMetadata
      Modifier and Type 方法 描述
      IIOMetadata TIFFDirectory.getAsMetadata​()
      将目录转换为元数据对象。
      Methods in javax.imageio.plugins.tiff with parameters of type IIOMetadata
      Modifier and Type 方法 描述
      static TIFFDirectory TIFFDirectory.createFromMetadata​(IIOMetadata tiffImageMetadata)
      从图像元数据对象的内容创建一个 TIFFDirectory实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.metadata.IIOMetadataFormatImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.metadata.IIOMetadataFormatImpl

No usage of javax.imageio.metadata.IIOMetadataFormatImpl
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.metadata.IIOMetadataNode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.metadata.IIOMetadataNode

  • Packages that use IIOMetadataNode
    软件包 描述
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。

    • Uses of IIOMetadataNode in javax.imageio.metadata

      Methods in javax.imageio.metadata that return IIOMetadataNode
      Modifier and Type 方法 描述
      protected IIOMetadataNode IIOMetadata.getStandardChromaNode​()
      返回 IIOMetadataNode表示标准的色度信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode IIOMetadata.getStandardCompressionNode​()
      返回 IIOMetadataNode表示标准的压缩信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode IIOMetadata.getStandardDataNode​()
      返回 IIOMetadataNode表示标准的数据格式信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode IIOMetadata.getStandardDimensionNode​()
      返回 IIOMetadataNode表示标准的尺寸信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode IIOMetadata.getStandardDocumentNode​()
      返回 IIOMetadataNode表示标准的文档信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode IIOMetadata.getStandardTextNode​()
      返回 IIOMetadataNode表示标准的文字信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode IIOMetadata.getStandardTileNode​()
      返回表示标准 javax_imageio_1.0元数据格式的 null信息的 null如果没有此类信息可用，则返回 IIOMetadataNode 。
      protected IIOMetadataNode IIOMetadata.getStandardTransparencyNode​()
      返回 IIOMetadataNode表示标准的透明度信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。
      protected IIOMetadataNode IIOMetadata.getStandardTree​()
      根据标准 javax_imageio_1.0元数据格式的约定，返回表示此对象中包含的元数据的一个 IIOMetadataNode s的树的实用方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.metadata.IIOMetadataController (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.metadata.IIOMetadataController

  • Packages that use IIOMetadataController
    软件包 描述
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。

    • Uses of IIOMetadataController in javax.imageio.metadata

      Fields in javax.imageio.metadata declared as IIOMetadataController
      Modifier and Type Field 描述
      protected IIOMetadataController IIOMetadata.controller
      该 IIOMetadataController将用于提供此设置 IIOMetadata对象时 activateController方法被调用。
      protected IIOMetadataController IIOMetadata.defaultController
      一个 IIOMetadataController被建议用作控制器此 IIOMetadata对象。
      Methods in javax.imageio.metadata that return IIOMetadataController
      Modifier and Type 方法 描述
      IIOMetadataController IIOMetadata.getController​()
      返回当前安装的 IIOMetadataController 。
      IIOMetadataController IIOMetadata.getDefaultController​()
      返回默认的 IIOMetadataController ，如果有一个，不管当前安装的控制器。
      Methods in javax.imageio.metadata with parameters of type IIOMetadataController
      Modifier and Type 方法 描述
      void IIOMetadata.setController​(IIOMetadataController controller)
      设置 IIOMetadataController用于在调用 activateController方法时为该 IIOMetadata对象提供设置，覆盖任何默认控制器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.metadata.IIOMetadataFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.metadata.IIOMetadataFormat

  • Packages that use IIOMetadataFormat
    软件包 描述
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of IIOMetadataFormat in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement IIOMetadataFormat
      Modifier and Type Class 描述
      class  IIOMetadataFormatImpl
      一个具体的类，提供可重用的 IIOMetadataFormat接口的实现。
      Methods in javax.imageio.metadata that return IIOMetadataFormat
      Modifier and Type 方法 描述
      IIOMetadataFormat IIOMetadata.getMetadataFormat​(String formatName)
      返回一个 IIOMetadataFormat对象描述给定的元数据格式，或 null如果没有可用的描述。
      static IIOMetadataFormat IIOMetadataFormatImpl.getStandardFormatInstance​()
      返回描述 javax.imageio.metadata包的注释中描述的 IIOMetadataFormat对象，描述标准，插件中性 javax.imageio_1.0元数据文档格式。

    • Uses of IIOMetadataFormat in javax.imageio.spi

      Methods in javax.imageio.spi that return IIOMetadataFormat
      Modifier and Type 方法 描述
      IIOMetadataFormat ImageReaderWriterSpi.getImageMetadataFormat​(String formatName)
      返回一个 IIOMetadataFormat对象描述给定的图像的元数据格式，或 null如果没有可用的描述。
      IIOMetadataFormat ImageReaderWriterSpi.getStreamMetadataFormat​(String formatName)
      Returns an IIOMetadataFormat object describing the given stream metadata format, or null if no description is available.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


BMP Metadata Format Specification

The XML schema for the native image metadata format is as follows:
<?xml version="1.0" encoding="UTF-8"?>

<!-- Schema for BMP native image metadata format. -->

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            xmlns="http://javax.imageio.plugins"
            targetNamespace="http://javax.imageio.plugins">

  <!-- Coordinates of a point in the CIE XYZ color space. -->
  <xsd:complexType name="XYZPoint">
    <xsd:sequence>
      <xsd:element name="X" type="xsd:double"/>
      <xsd:element name="Y" type="xsd:double"/>
      <xsd:element name="Z" type="xsd:double"/>
    </xsd:sequence>
  </xsd:complexType>

  <!-- BMP Schema 1.0 root element. -->
  <xsd:element name="javax_imageio_bmp_1.0">
    <xsd:complexType>
      <xsd:sequence>

        <!-- BMP version string -->
        <xsd:element name="BMPVersion" type="xsd:string"/>

        <!-- Bitmap width -->
        <xsd:element name="Width" type="xsd:unsignedInt"/>

        <!-- Bitmap height -->
        <xsd:element name="Height" type="xsd:unsignedInt"/>

        <!-- Number of bits per pixel -->
        <xsd:element name="BitsPerPixel" type="xsd:unsignedShort"/>

        <!-- Compression type -->
        <xsd:element name="Compression" type="xsd:unsignedInt" minOccurs="0"/>

        <!-- Image size in bytes -->
        <xsd:element name="ImageSize" type="xsd:unsignedInt" minOccurs="0"/>

    <!-- Resolution in pixels per unit distance -->
        <xsd:element name="PixelsPerMeter" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="X" type="xsd:unsignedInt"/>
              <xsd:element name="Y" type="xsd:unsignedInt"/>
            </xsd:sequence>
      </xsd:complexType>
        </xsd:element> <!-- PixelsPerMeter -->

    <!-- Number of color indexes in the color table actually used -->
        <xsd:element name="ColorsUsed" type="xsd:unsignedInt" minOccurs="0"/>

    <!-- Number of color indexes considered important for display -->
        <xsd:element name="ColorsImportant" type="xsd:unsignedInt"
             minOccurs="0"/>

    <!-- Color masks; present for BI_BITFIELDS compression only -->
        <xsd:element name="Mask" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="Red" type="xsd:unsignedInt"/>
              <xsd:element name="Green" type="xsd:unsignedInt"/>
              <xsd:element name="Blue" type="xsd:unsignedInt"/>
              <xsd:element name="Alpha" type="xsd:unsignedInt" minOccurs="0"/>
            </xsd:sequence>
      </xsd:complexType>
    </xsd:element>

        <!-- Color space  -->
        <xsd:element name="ColorSpaceType" type="xsd:unsignedInt"
             minOccurs="0"/>

    <!-- CIE XYZ for the LCS_CALIBRATED_RGB color space -->
        <xsd:element name="CIEXYZEndpoints" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="Red" type="XYZPoint"/>
              <xsd:element name="Green" type="XYZPoint"/>
              <xsd:element name="Blue" type="XYZPoint"/>
            </xsd:sequence>
      </xsd:complexType>
        </xsd:element>

    <!-- Gamma values for the LCS_CALIBRATED_RGB color space -->
        <xsd:element name="Gamma" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="Red" type="xsd:unsignedInt"/>
              <xsd:element name="Green" type="xsd:unsignedInt"/>
              <xsd:element name="Blue" type="xsd:unsignedInt"/>
            </xsd:sequence>
      </xsd:complexType>
    </xsd:element>

    <!-- Rendering intent -->
        <xsd:element name="Intent" type="xsd:unsignedInt" minOccurs="0"/>

    <!-- The image colormap -->
        <xsd:element name="Palette" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="PaletteEntry">
            <xsd:complexType>
                  <xsd:sequence>
                    <xsd:element name="Red" type="xsd:unsignedByte"/>
                    <xsd:element name="Green" type="xsd:unsignedByte"/>
                    <xsd:element name="Blue" type="xsd:unsignedByte"/>
                    <xsd:element name="Alpha" type="xsd:unsignedByte" minOccurs="0"/>
                  </xsd:sequence>
            </xsd:complexType>
              </xsd:element>
            </xsd:sequence>
      </xsd:complexType>
    </xsd:element>

      </xsd:sequence>
    </xsd:complexType>
  </xsd:element> <!-- bmp_image_1.0 -->

</xsd:schema>
@since 1.5


GIF Metadata Format Specification

GIF Stream Metadata Format Specification

The GIF stream metadata format encodes the information stored in the per-file header, namely the file version, logical screen descriptor, and the global color table.

The logical screen descriptor describes the overall width and height of an animated file, as well as information about the color resolution (number of bits per pixel) and pixel aspect ratio.

The global color table contains a color lookup table that is used for images that do not have their own local color table.

<!DOCTYPE "javax_imageio_gif_stream_1.0" [

  <!ELEMENT "javax_imageio_gif_stream_1.0" (Version?,
    LogicalScreenDescriptor?, GlobalColorTable?)>

    <!ELEMENT "Version" EMPTY>
      <!-- The file version, either 87a or 89a -->
      <!ATTLIST "Version" "value" ("87a" | "89a") #REQUIRED>
        <!-- The version string -->

    <!ELEMENT "LogicalScreenDescriptor" EMPTY>
      <!-- The logical screen descriptor, except for the global color table -->
      <!ATTLIST "LogicalScreenDescriptor" "logicalScreenWidth" #CDATA
         #REQUIRED>
        <!-- The width in pixels of the whole picture -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "LogicalScreenDescriptor" "logicalScreenHeight" #CDATA
         #REQUIRED>
        <!-- The height in pixels of the whole picture -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "LogicalScreenDescriptor" "colorResolution" #CDATA
         #REQUIRED>
        <!-- The number of bits of color resolution, beteen 1 and 8 -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 8 (inclusive) -->
      <!ATTLIST "LogicalScreenDescriptor" "pixelAspectRatio" #CDATA
         #REQUIRED>
        <!-- If 0, indicates square pixels, else W/H = (value + 15)/64 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "GlobalColorTable" (ColorTableEntry)*>
      <!-- The global color table -->
      <!-- Min children: 2 -->
      <!-- Max children: 256 -->
      <!ATTLIST "GlobalColorTable" "sizeOfGlobalColorTable" ("2" |
        "4" | "8" | "16" | "32" | "64" | "128" | "256") #REQUIRED>
        <!-- The number of entries in the global color table -->
      <!ATTLIST "GlobalColorTable" "backgroundColorIndex" #CDATA
         #REQUIRED>
        <!-- The index of the color table entry to be used as a background -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->
      <!ATTLIST "GlobalColorTable" "sortFlag" ("TRUE" | "FALSE")
         #REQUIRED>
        <!-- True if the global color table is sorted by frequency -->

      <!ELEMENT "ColorTableEntry" EMPTY>
        <!-- A global color table entry -->
        <!ATTLIST "ColorTableEntry" "index" #CDATA #REQUIRED>
          <!-- The index of the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "red" #CDATA #REQUIRED>
          <!-- The red value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "green" #CDATA #REQUIRED>
          <!-- The green value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
]>

GIF Image Metadata Format Specification

The GIF image metadata format encodes the image descriptor, local color table, and extension information assciated with a single image within a GIF file, typically a frame of an animation.

The image description contains the offset of the frame within the logical screen described in the stream metadata, as well as the width and height of the frame and whether it is used interlaced encoding.

The local color table, if present, supersedes the global color table for the frame at hand.

The graphic control extension contains information on how the frame is to be incorporated into the animation. The disposal method indicates whether the current frame should remain in place (doNotDispose), be restored to the backgound color as specified in the stream metadata (restoreToBackgroundColor), or be restored to the previous frame contents (restoreToPrevious) prior to displaying the subsequent frame.

The user input flag indicates whether the animation should pause for user input before advancing to the next frame. The transparent color flag and index indicate a color index for which pixels of the frame should not be drawn. The delay time indicates how long the frame should be displayed, in hundredths of a second. If the user input flag is set and the delay time is 0, the frame is intended to be advanced only on user input.

<!DOCTYPE "javax_imageio_gif_image_1.0" [

  <!ELEMENT "javax_imageio_gif_image_1.0" (ImageDescriptor?,
    LocalColorTable?, GraphicControlExtension?, PlainTextExtension?,
    ApplicationExtensions?, CommentExtensions?)>

    <!ELEMENT "ImageDescriptor" EMPTY>
      <!-- The image descriptor -->
      <!ATTLIST "ImageDescriptor" "imageLeftPosition" #CDATA #REQUIRED>
        <!-- The X offset of the image relative to the screen origin -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "imageTopPosition" #CDATA #REQUIRED>
        <!-- The Y offset of the image relative to the screen origin -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "imageWidth" #CDATA #REQUIRED>
        <!-- The width of the image -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "imageHeight" #CDATA #REQUIRED>
        <!-- The height of the image -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "interlaceFlag" ("TRUE" | "FALSE")
         #REQUIRED>
        <!-- True if the image is stored using interlacing -->

    <!ELEMENT "LocalColorTable" (ColorTableEntry)*>
      <!-- The local color table -->
      <!-- Min children: 2 -->
      <!-- Max children: 256 -->
      <!ATTLIST "LocalColorTable" "sizeOfLocalColorTable" ("2" |
        "4" | "8" | "16" | "32" | "64" | "128" | "256") #REQUIRED>
        <!-- The number of entries in the local color table -->
      <!ATTLIST "LocalColorTable" "sortFlag" ("TRUE" | "FALSE")
         #REQUIRED>
        <!-- True if the local color table is sorted by frequency -->

      <!ELEMENT "ColorTableEntry" EMPTY>
        <!-- A local color table entry -->
        <!ATTLIST "ColorTableEntry" "index" #CDATA #REQUIRED>
          <!-- The index of the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "red" #CDATA #REQUIRED>
          <!-- The red value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "green" #CDATA #REQUIRED>
          <!-- The green value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "GraphicControlExtension" EMPTY>
      <!-- A graphic control extension -->
      <!ATTLIST "GraphicControlExtension" "disposalMethod" ("none" |
        "doNotDispose" | "restoreToBackgroundColor" |
        "restoreToPrevious" | "undefinedDisposalMethod4" |
        "undefinedDisposalMethod5" | "undefinedDisposalMethod6" |
        "undefinedDisposalMethod7") #REQUIRED>
        <!-- The disposal method for this frame -->
      <!ATTLIST "GraphicControlExtension" "userInputFlag" ("TRUE" |
        "FALSE") #REQUIRED>
        <!-- True if the frame should be advanced based on user input -->
      <!ATTLIST "GraphicControlExtension" "transparentColorFlag" (
        "TRUE" | "FALSE") #REQUIRED>
        <!-- True if a transparent color exists -->
      <!ATTLIST "GraphicControlExtension" "delayTime" #CDATA #REQUIRED>
        <!-- The time to delay between frames, in hundredths of a second -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "GraphicControlExtension" "transparentColorIndex"
         #CDATA #REQUIRED>
        <!-- The transparent color, if transparentColorFlag is true -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "PlainTextExtension" EMPTY>
      <!-- A plain text (text grid) extension -->
      <!ATTLIST "PlainTextExtension" "textGridLeft" #CDATA #REQUIRED>
        <!-- The X offset of the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textGridTop" #CDATA #REQUIRED>
        <!-- The Y offset of the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textGridWidth" #CDATA #REQUIRED>
        <!-- The number of columns in the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textGridHeight" #CDATA #REQUIRED>
        <!-- The number of rows in the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "characterCellWidth" #CDATA
         #REQUIRED>
        <!-- The width of a character cell -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "characterCellHeight" #CDATA
         #REQUIRED>
        <!-- The height of a character cell -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textForegroundColor" #CDATA
         #REQUIRED>
        <!-- The text foreground color index -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textBackgroundColor" #CDATA
         #REQUIRED>
        <!-- The text background color index -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "ApplicationExtensions" (ApplicationExtension)*>
      <!-- A set of application extensions -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "ApplicationExtension" EMPTY>
        <!-- An application extension -->
        <!-- User object: array of byte -->
        <!-- Min length: 0 -->
        <!-- Max length: 2147483647 -->
        <!ATTLIST "ApplicationExtension" "applicationID" #CDATA
           #REQUIRED>
          <!-- The application ID -->
          <!-- Data type: String -->
        <!ATTLIST "ApplicationExtension" "authenticationCode" #CDATA
           #REQUIRED>
          <!-- The authentication code -->
          <!-- Data type: String -->

    <!ELEMENT "CommentExtensions" (CommentExtension)*>
      <!-- A set of comments -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "CommentExtension" EMPTY>
        <!-- A comment -->
        <!ATTLIST "CommentExtension" "value" #CDATA #REQUIRED>
          <!-- The comment -->
          <!-- Data type: String -->
]>

Mapping of Standard to GIF Native Stream Metadata
Standard Metadata Component | GIF Native Stream Metadata Component
/Chroma/Palette/PaletteEntry@index | /GlobalColorTable/ColorTableEntry@index
/Chroma/Palette/PaletteEntry@red | /GlobalColorTable/ColorTableEntry@red
/Chroma/Palette/PaletteEntry@green | /GlobalColorTable/ColorTableEntry@green
/Chroma/Palette/PaletteEntry@blue | /GlobalColorTable/ColorTableEntry@blue
/Chroma/BackgroundIndex@value | /GlobalColorTable@backgroundColorIndex
/Data/BitsPerSample@value | /LogicalScreenDescriptor@colorResolution
/Dimension/PixelAspectRatio@value | /LogicalScreenDescriptor@pixelAspectRatio
/Dimension/HorizontalScreenSize@value | /LogicalScreenDescriptor@logicalScreenWidth
/Dimension/VerticalScreenSize@value | /LogicalScreenDescriptor@logicalScreenHeight
/Document/FormatVersion@value | /Version@value
Mapping of Standard to GIF Native Image Metadata
Standard Metadata Component | GIF Native Image Metadata Component
/Chroma/Palette/PaletteEntry@index | /LocalColorTable/ColorTableEntry@index
/Chroma/Palette/PaletteEntry@red | /LocalColorTable/ColorTableEntry@red
/Chroma/Palette/PaletteEntry@green | /LocalColorTable/ColorTableEntry@green
/Chroma/Palette/PaletteEntry@blue | /LocalColorTable/ColorTableEntry@blue
/Dimension/HorizontalPixelOffset@value | /ImageDescriptor@imageLeftPosition
/Dimension/VerticalPixelOffset@value | /ImageDescriptor@imageTopPosition
/Text/TextEntry@value | /CommentExtensions/CommentExtension@value
/Transparency/TransparentIndex@value | /GraphicControlExtension@transparentColorIndex (/GraphicControlExtension@transparentColorFlag is also set to "TRUE")


JPEG Metadata Format Specification and Usage Notes

JPEG Metadata
Abbreviated Streams
Sources of Tables
Colorspace Transformations and Conventional Markers
Thumbnail Images
Progressive Encoding
Native Metadata Format Tree Structure and Editing
Image Metadata DTD
Stream Metadata DTD

NOTE: It is important to call dispose() on the JPEG reader and writer objects when they are no longer needed, as they consume significant native resources which are not adequately recovered by garbage collection. Both reader and writer call dispose() in their finalizers, but those finalizers may not be called before the native code has exhausted native memory.

The JPEG writer does not support replacing pixels.

JPEG Metadata

JPEG metadata consists of the data contained in marker segments in a JPEG stream. The image metadata object returned from a read describes the contents of the marker segments between the SOI marker and the EOI marker for that image. The image metadata object passed into a write determines the contents of the stream between the SOI marker and the EOI marker for that image, subject to the controls in any ImageWriteParam.

Stream metadata is used only for tables-only images found (or to be placed) at the beginning of a stream containing abbreviated images. Tables-only images are not treated as images and do not consume an image index. The stream metadata object returned from a read describes the contents of the marker segments between the SOI marker and the EOI marker for the single tables-only image at the beginning of the stream, if one is present. If no tables-only image is present at the front of the stream, the getStreamMetadata method of ImageReader returns null. If stream metadata is provided to the writer, a single tables-only image containing the tables from the stream metadata object will be written at the beginning of the stream. If the stream metadata object contains no tables, default tables will be written. As the sole purpose of stream metadata is for specifying tables-only images at the front of abbreviated streams, the stream metadata argument is useful only on the ImageWriter.prepareWriteSequence method. It is ignored on all other methods.

The ImageWriter.getDefaultStreamMetadata method returns an object containing the tables from the ImageWriteParam argument, if it is a JPEGImageWriteParam and contains tables. Otherwise, the returned object will contain default tables.

The ImageWriter.getDefaultImageMetadata method returns a metadata object containing no tables if the ImageWriteParam argument contains tables. Otherwise the returned metadata object will contain default visually lossless tables. Of course, only a JPEGImageWriteParam may contain tables.

If ignoreMetadata is set to true when the input is set on the reader, stream metadata will not be available, but image metadata will.

Abbreviated Streams

Both the reader and the writer retain their tables from one operation to the next, thus permitting the use of abbreviated streams quite naturally, with a few minor restrictions:
  1. Abbreviated streams may contain only one tables-only image, which must come first in the stream. Subsequent tables-only images will cause undefined behavior.
  2. Abbreviated streams must be read fully and in order. No random access is allowed, in either direction. The same image may be read multiple times. If a call is made with an image index that is not the same as or one greater than the most recent call (or 0 if no calls have been made), then an IllegalArgumentException is thrown.
These restrictions mean that streams may contain abbreviated images interspersed with images containing tables. As required by JPEG, any tables appearing in the stream override previous tables, regardless of the source of the previous tables.

Note that once a tables-only image has been read, it's contents is available as stream metadata from the reader until either another tables-only image is read from another stream or the reader is reset. Changing the input does not reset the stream metadata. This is useful for reading the tables from one file, then changing the input to read an abbreviated stream containing a sequence of images. The tables will be used automatically, and will remain available as "stream" metadata.

Abbreviated streams are written using the sequence methods of ImageWriter. Stream metadata is used to write a tables-only image at the beginning of the stream, and the tables are set up for use, using ImageWriter.prepareWriteSequence. If no stream metadata is supplied to ImageWriter.prepareWriteSequence, then no tables-only image is written. If stream metadata containing no tables is supplied to ImageWriter.prepareWriteSequence, then a tables-only image containing default visually lossless tables is written.

Sources of Tables

Images are written with tables if tables are present in their metadata objects or without them if no tables are present in their metadata objects. If no metadata object is present then the tables are written. The tables used for compression are taken from one of the following sources, which are consulted in order:

  1. If there is an ImageWriteParam and the compression mode is set to EXPLICIT, default tables constructed using the quality setting are used. They are written only if the metadata contains tables or if there is no metadata, but they replace the tables in the metadata.
  2. If there is an ImageWriteParam and the compression mode is set to DEFAULT, default visually lossles tables are used. They are written only if the metadata contains tables or if there is no metadata, but they replace the tables in the metadata.
  3. Otherwise the compression mode on the ImageWriteParam must be MODE_COPY_FROM_METADATA, in which case the following are used:
    1. the tables in the image metadata, if present
    2. the tables in the stream metadata, if present
    3. the tables in the JPEGImageWriteParam, if present
    4. default visually lossless tables
    Tables are written only if they are taken from image metadata.
This ordering implements the design intention that tables should be included in JPEGImageWriteParams only as a means of specifying tables when no other source is available, and this can occur only when writing to an abbreviated stream without tables using known non-standard tables for compression.

When reading, tables in a JPEGImageReadParam are consulted only if tables have not been set by any previous read. Tables set from a JPEGImageReadParam are overridden by any tables present in the stream being read.

Note that if no image metadata object is specified for a particular image, a default object is used, which includes default tables.

Colorspace Transformations and Conventional Markers

Colorspace transformations are controlled by the destination type for both reading and writing of images. When Rasters are read, no colorspace transformation is performed, and any destination type is ignored. A warning is sent to any listeners if a destination type is specified in this case. When Rasters are written, any destination type is used to interpret the bands. This might result in a JFIF or Adobe header being written, or different component ids being written to the frame and scan headers. If values present in a metadata object do not match the destination type, the destination type is used and a warning is sent to any listeners.

Optional ColorSpace support: Handling of PhotoYCC (YCC), PhotoYCCA (YCCA), RGBA and YCbCrA color spaces by the standard plugin, as described below, is dependent on capabilities of the libraries used to interpret the JPEG data. Thus all consequential behaviors are optional. If the support is not available when decoding, the color space will be treated as unrecognized and the appropriate default color space for the specified number of component channels may be used. When writing, an Exception may be thrown if no suitable conversion can be applied before encoding. But where the support for these color spaces is available, the behavior must be as documented.

When reading, the contents of the stream are interpreted by the usual JPEG conventions, as follows:

  • If a JFIF APP0 marker segment is present, the colorspace is known to be either grayscale or YCbCr. If an APP2 marker segment containing an embedded ICC profile is also present, then the YCbCr is converted to RGB according to the formulas given in the JFIF spec, and the ICC profile is assumed to refer to the resulting RGB space.
  • If an Adobe APP14 marker segment is present, the colorspace is determined by consulting the transform flag. The transform flag takes one of three values:
    • 2 - The image is encoded as YCCK (implicitly converted from CMYK on encoding).
    • 1 - The image is encoded as YCbCr (implicitly converted from RGB on encoding).
    • 0 - Unknown. 3-channel images are assumed to be RGB, 4-channel images are assumed to be CMYK.
  • If neither marker segment is present, the following procedure is followed: Single-channel images are assumed to be grayscale, and 2-channel images are assumed to be grayscale with an alpha channel. For 3- and 4-channel images, the component ids are consulted. If these values are 1-3 for a 3-channel image, then the image is assumed to be YCbCr. Subject to the availability of the optional color space support described above, if these values are 1-4 for a 4-channel image, then the image is assumed to be YCbCrA. If these values are > 4, they are checked against the ASCII codes for 'R', 'G', 'B', 'A', 'C', 'c'. These can encode the following colorspaces:

    RGB
    RGBA
    YCC (as 'Y','C','c'), assumed to be PhotoYCC
    YCCA (as 'Y','C','c','A'), assumed to be PhotoYCCA

    Otherwise, 3-channel subsampled images are assumed to be YCbCr, 3-channel non-subsampled images are assumed to be RGB, 4-channel subsampled images are assumed to be YCCK, and 4-channel, non-subsampled images are assumed to be CMYK.

  • All other images are declared uninterpretable and an exception is thrown if an attempt is made to read one as a BufferedImage. Such an image may be read only as a Raster. If an image is interpretable but there is no Java ColorSpace available corresponding to the encoded colorspace (e.g. YCbCr), then ImageReader.getRawImageType will return null.
Once an encoded colorspace is determined, then the target colorspace is determined as follows:
  • If a destination type is not set, then the following default transformations take place after upsampling: YCbCr (and YCbCrA) images are converted to RGB (and RGBA) using the conversion provided by the underlying IJG library and either the built-in sRGB ColorSpace or a custom RGB ColorSpace object based on an embedded ICC profile is used to create the output ColorModel. PhotoYCC and PhotoYCCA images are not converted. CMYK and YCCK images are currently not supported.
  • If a destination image or type is set, it is used as follows: If the IJG library provides an appropriate conversion, it is used. Otherwise the default library conversion is followed by a colorspace conversion in Java.
  • Bands are selected AFTER any library colorspace conversion. If a subset of either source or destination bands is used, then the default library conversions are used with no further conversion in Java, regardless of any destination type.
  • An exception is thrown if an attempt is made to read an image in an unsupported jpeg colorspace as a BufferedImage (e.g. CMYK). Such images may be read as Rasters. If an image colorspace is unsupported or uninterpretable, then ImageReader.getImageTypes will return an empty Iterator. If a subset of the raw bands are required, a Raster must be obtained first and the bands obtained from that.

For writing, the color transformation to apply is determined as follows:

If a subset of the source bands is to be written, no color conversion is performed. Any destination, if set, must match the number of bands that will be written, and serves as an interpretation of the selected bands, rather than a conversion request. This behavior is identical to that for Rasters. If all the bands are to be written and an image (as opposed to a Raster) is being written, any destination type is ignored and a warning is sent to any listeners.

If a destination type is used and any aspect of the metadata object, if there is one, is not compatible with that type, the destination type is used, the metadata written is modified from that provided, and a warning is sent to listeners. This includes the app0JFIF and app14Adobe nodes. The component ids in the sof and sos nodes are not modified, however, as unless a app0JFIF node is present, any values may be used.

When a full image is written, a destination colorspace will be chosen based on the image contents and the metadata settings, according to the following algorithm:

If no metadata object is specified, then the following defaults apply:

  • Grayscale images are written with a JFIF APP0 marker segment. Grayscale images with alpha are written with no special marker. As required by JFIF, the component ids in the frame and scan header is set to 1.
  • RGB images are converted to YCbCr, subsampled in the chrominance channels by half both vertically and horizontally, and written with a JFIF APP0 marker segment. If the ColorSpace of the image is based on an ICCProfile (it is an instance of ICC_ColorSpace, but is not one of the standard built-in ColorSpaces), then that profile is embedded in an APP2 marker segment. As required by JFIF, the component ids in the frame and scan headers are set to 1, 2, and 3.
  • Subject to the optional library support described above, RGBA images are converted to YCbCrA, subsampled in the chrominance channels by half both vertically and horizontally, and written without any special marker segments. The component ids in the frame and scan headers are set to 1, 2, 3, and 4.
  • Subject to the optional library support described above, PhotoYCC and YCCAimages are subsampled by half in the chrominance channels both vertically and horizontally and written with an Adobe APP14 marker segment and 'Y','C', and 'c' (and 'A' if an alpha channel is present) as component ids in the frame and scan headers.
Default metadata objects for these image types will reflect these settings.

If a metadata object is specified, then the number of channels in the frame and scan headers must always match the number of bands to be written, or an exception is thrown. app0JFIF and app14Adobe nodes may appear in the same metadata object only if the app14Adobe node indicates YCbCr, and the component ids are JFIF compatible (0-2). The various image types are processed in the following ways:
(All multi-channel images are subsampled according to the sampling factors in the frame header node of the metadata object, regardless of color space.)

  • Grayscale Images:
    • If an app0JFIF node is present in the metadata object, a JFIF APP0 marker segment is written.
    • If an app14Adobe node is present in the metadata object, it is checked for validity (transform must be UNKNOWN) and written.
    • If neither node is present in the metadata object, no special marker segment is written.
  • Grayscale Images with an Alpha Channel:
    • If an app0JFIF node is present in the metadata object, it is ignored and a warning is sent to listeners, as JFIF does not support 2-channel images.
    • If an app14Adobe node is present in the metadata object, it is checked for validity (transform must be UNKNOWN) and written. If transform is not UNKNOWN, a warning is sent to listeners and the correct transform is written.
    • If neither node is present in the metadata object, no special marker segment is written.
  • RGB Images:
    • If an app0JFIF node is present in the metadata object, the image is converted to YCbCr and written with a JFIF APP0 marker segment. If the ColorSpace of the image is based on a non-standard ICC Profile, then that profile is embedded in an APP2 marker segment. If the ColorSpace is not based on a non-standard ICC Profile, but an app2ICC node appears in the metadata, then an APP2 marker segment is written with the appropriate standard profile. Note that the profile must specify an RGB color space, as the file must be JFIF compliant.
    • If an app14Adobe node is present in the metadata object, the image is converted according to the color transform setting and written with an Adobe APP14 marker segment. Component ids are written just as they appear in the frame and scan headers. The color transform must be either YCbCr or UNKNOWN. If it is UNKNOWN, the image is not color converted.
    • If neither node is present, the component ids in the frame header are consulted. If these indicate a colorspace as described above, then the image is converted to that colorspace if possible. If the component ids do not indicate a colorspace, then the sampling factors are consulted. If the image is to be subsampled, it is converted to YCbCr first. If the image is not to be subsampled, then no conversion is applied. No special marker segmentss are written.
  • RGBA images: Subject to the optional library support described above,
    • If an app0JFIF node is present in the metadata object, it is ignored and a warning is sent to listeners, as JFIF does not support 4-channel images.
    • If an app14Adobe node is present in the metadata object, the image is written with an Adobe APP14 marker segment. No colorspace conversion is performed. Component ids are written just as they appear in the frame and scan headers. The color transform must be UNKNOWN. If it is not, a warning is sent to listeners.
    • If no app14Adobe node is present, the component ids in the frame header are consulted. If these indicate a colorspace as described above, then the image is converted to that colorspace if possible. If the component ids do not indicate a colorspace, then the sampling factors are consulted. If the image is to be subsampled, it is converted to YCbCrA. If the image is not to be subsampled, then no conversion is applied. No special marker segments are written.
  • PhotoYCC Images: Subject to the optional library support described above,
    • If an app0JFIF node is present in the metadata object, the image is converted to sRGB, and then to YCbCr during encoding, and a JFIF APP0 marker segment is written.
    • If an app14Adobe node is present in the metadata object, no conversion is applied, and an Adobe APP14 marker segment is written. The color transform must be YCC. If it is not, a warning is sent to listeners.
    • If neither node is present in the metadata object, no conversion is applied, and no special marker segment is written.
  • PhotoYCCA Images: Subject to the optional library support described above,
    • If an app0JFIF node is present in the metadata object, it is ignored and a warning is sent to listeners, as JFIF does not support 4-channel images.
    • If an app14Adobe node is present in the metadata object, no conversion is applied, and an Adobe APP14 marker segment is written. The color transform must be UNKNOWN. If it is not, a warning is sent to listeners.
    • If neither node is present in the metadata object, no conversion is applied, and no special marker segment is written.

Thumbnail Images

Thumbnails are supported by the use of JFIF and JFIF extension marker segments. Thumbnails provided on the write methods determine the thumbnails that will be included. app0JFIF and app0JFXX nodes present in the metadata do not contain any thumbnail pixel data. However, the kinds of thumbnails written depend on the contents of the metadata object, as follows. Any thumbnail which is to be written as an indexed or RGB image and which is larger than 255 by 255 will be clipped, not scaled, to 255 by 255. Thumbnails written as JPEG images may be any size. A warning is sent to any listeners whenever a thumbnail is clipped.
  • If there is a single thumbnail, it is processed as follows:
    • If the thumbnail image is an RGB palette image, it is processed as follows:
      • If no app0JFXX node is present in the metadata, or the first app0JFXX node present in the metadata contains a JFIFthumbPalette element, a palette thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains another thumbnail form (RGB or JPEG), the palette image is expanded to RGB and the indicated thumbnail form is written.
    • If the thumbnail image is an RGB image, it is processed as follows:
      • If no app0JFXX node is present in the metadata, the thumbnail is written as part of the JFIF APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbRGB element, an RGB thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbJPEG element, a JPEG thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbPalette element, an RGB thumbnail is written in a JFXX APP0 marker segment and a warning is sent to any listeners.
    • If the thumbnail image is a grayscale image, it is processed as follows:
      • If no app0JFXX node is present in the metadata, the thumbnail is expanded to RGB and written as part of the JFIF APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbRGB element, the thumbnail is expanded to RGB and written in a separate JFXX RGB marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbJPEG element, a JPEG thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbPalette element, a JPEG thumbnail is written in a JFXX APP0 marker segment and a warning is sent to any listeners.
    • Any other thumbnail image types are ignored and a warning is sent to any listeners.
  • If there are multiple thumbnails, each one is processed as above, except that no thumbnail is placed in the JFIF APP0 segment, and the app0JFXX node consulted for each thumbnail is the app0JFXX node from the metadata that occurs in the same sequence as the thumbnail. I.e. the first app0JFXX node applies to the first thumbnail, the second node to the second thumbnail, and so on. If there are fewer app0JFXX nodes in the metadata than thumbnails, then those thumbnails are considered to have no matching app0JFXX node. An RGB thumbnail with no matching app0JFXX node is written in a JFXX APP0 marker segment. A grayscale thumbnail with no matching app0JFXX node is written as a JPEG image to a JFXX APP0 marker segment.

Note that as the only mechanism for storing thumbnails is via the JFIF or JFIF extension marker segments, only grayscale or RGB images may have thumbnails. If thumbnails are present when writing any other type of image, the thumbnails are ignored and a warning is sent to any warning listeners.

Progressive Encoding

Progressive encoding must be enabled on the ImageWriteParam passed in to a write operation, or the image will be written sequentially, regardless of the scan headers included in the metadata object. If progressive encoding is enabled and set to copy from metadata, then the sequence of scan headers from the metadata is used to write the image. If progressive encoding is enabled and set to use a default, then the scans in the metadata are ignored and a default set of scans is used. Progressive encoding always forces optimized Huffman tables to be used. Any Huffman tables present in the metadata will be ignored, and a warning will be sent to any warning listeners. If Huffman-table optimization is requested on the ImageWriteParam, all Huffman tables in the metadata or in the ImageWriteParam itself are ignored, and a warning will be sent to any warning listeners if any such tables are present.

Native Metadata Format Tree Structure and Editing

The DTDs below describe just the trees of metadata objects actually returned by the IIOMetadata object. They do not include nodes corresponding to SOI, EOI, or RST markers, as these parsing delimiters do not carry any meaningful metadata.

The first node is always a JPEGvariety node. In the javax_imageio_jpeg_image_1.0 version of the JPEG metadata format, this node may have one child, an app0JFIF node, indicating that the JPEG stream contains a JFIF marker segment and related data, or no children, indicating that the stream contains no JFIF marker. In future versions of the JPEG metadata format, other varieties of JPEG metadata may be supported (e.g. Exif) by defining other types of nodes which may appear as a child of the JPEGvariety node.

(Note that an application wishing to interpret Exif metadata given a metadata tree structure in the javax_imageio_jpeg_image_1.0 format must check for an unknown marker segment with a tag indicating an APP1 marker and containing data identifying it as an Exif marker segment. Then it may use application-specific code to interpret the data in the marker segment. If such an application were to encounter a metadata tree formatted according to a future version of the JPEG metadata format, the Exif marker segment might not be unknown in that format - it might be structured as a child node of the JPEGvariety node. Thus, it is important for an application to specify which version to use by passing the string identifying the version to the method/constructor used to obtain an IIOMetadata object.)

On reading, JFXX and app2ICC nodes occur as children of an app0JFIF node. This is true regardless of where the JFXX APP0 and APP2 marker segments actually occur in the stream. The ordering of nodes within the markerSequence node corresponds to the ordering of marker segments found in the JPEG stream.

On writing, any JFXX and app2ICC nodes must occur as children of an app0JFIF node, itself a child of a JPEGvariety node, which must always be the first node. (If the stream is not to be JFIF compliant, no app0JFIF node should be provided, and the JPEGvariety node should have no children.) Any JFIF APP0, JFXX APP0, and APP2 marker segments are written first, followed by all Adobe APP14, APPn, COM and unknown segments in the order in which their corresponding nodes appear in the markerSequence node, followed by DQT (and DHT for non-progressive writes) marker segments, followed by the SOF and SOS marker segments. For progressive writes using metadata to control progression, the SOS segments are used in the order in which their corresponding nodes occur in the markerSequence node.

The reset, mergeTree and setFromTree operations have the following semantics for the JPEG plug-in metadata object:

reset - A call to reset will restore the metadata object to the same state it had immediately after creation, whether this came about from reading a stream or by obtaining a default object from the ImageWriter. This is true regardless of how many times the metadata object has been modified since creation.

mergeTree - Native Format
The mergeTree operation accepts valid trees conforming to the DTD below, and merges the nodes using the following ordering rules. In all cases, only data present in the new node is changed in a corresponding existing node, if any. This means that nodes cannot be removed using mergeTree. To remove nodes, use setFromTree. The tree must consist of IIOMetadataNodes.

  • app0JFIF
    • If an app0JFIF node already exists, the contents of the new one modify the existing one.
    • If there is no such node, a new one is created and inserted in the appropriate position.
  • dqt
    • If there already exist dqt nodes in the sequence, then each table in the node replaces the first table, in any dqt node, with the same table id.
    • If none of the existing dqt nodes contain a table with the same id, then the table is added to the last existing dqt node.
    • If there are no dqt nodes, then a new one is created and added as follows:
      • If there are dht nodes, the new dqt node is inserted before the first one.
      • If there are no dht nodes, the new dqt node is inserted before an sof node, if there is one.
      • If there is no sof node, the new dqt node is inserted before the first sos node, if there is one.
      • If there is no sos node, the new dqt node is added to the end of the sequence.
  • dht
    • If there already exist dht nodes in the sequence, then each table in the node replaces the first table, in any dht node, with the same table class and table id.
    • If none of the existing dht nodes contain a table with the same class and id, then the table is added to the last existing dht node.
    • If there are no dht nodes, then a new one is created and added as follows:
      • If there are dqt nodes, the new dht node is inserted immediately following the last dqt node.
      • If there are no dqt nodes, the new dht node is inserted before an sof node, if there is one.
      • If there is no sof node, the new dht node is inserted before the first sos node, if there is one.
      • If there is no sos node, the new dht node is added to the end of the sequence.
  • dri
    • If there already exists a dri node, the restart interval value is updated.
    • If there is no dri node, then a new one is created and added as follows:
      • If there is an sof node, the new dri node is inserted before it.
      • If there is no sof node, the new dri node is inserted before the first sos node, if there is one.
      • If there is no sos node, the new dri node is added to the end of the sequence.
  • com
    A new com node is created and inserted as follows:
    • If there already exist com nodes, the new one is inserted after the last one.
    • If there are no com nodes, the new com node is inserted after the app14Adobe node, if there is one.
    • If there is no app14Adobe node, the new com node is inserted at the beginning of the sequence.
  • app14Adobe
    • If there already exists an app14Adobe node, then its attributes are updated from the node.
    • If there is no app14Adobe node, then a new one is created and added as follows:
      • The new app14Adobe node is inserted after the last unknown node, if there are any.
      • If there are no unknown nodes, the new app14Adobe node is inserted at the beginning of the sequence.
  • unknown
    A new unknown node is created and added to the sequence as follows:
    • If there already exist unknown marker nodes, the new one is inserted after the last one.
    • If there are no unknown nodes, the new unknown node is inserted before the app14Adobe node, if there is one.
    • If there is no app14Adobe node, the new unknown node is inserted at the beginning of the sequence.
  • sof
    • If there already exists an sof node in the sequence, then its values are updated from the node.
    • If there is no sof node, then a new one is created and added as follows:
      • If there are any sos nodes, the new sof node is inserted before the first one.
      • If there is no sos node, the new sof node is added to the end of the sequence.
  • sos
    • If there already exists a single sos node, then the values are updated from the node.
    • If there are more than one existing sos nodes, then an IIOInvalidTreeException is thrown, as sos nodes cannot be merged into a set of progressive scans.
    • If there are no sos nodes, a new one is created and added to the end of the sequence.

mergeTree - Standard Format
The mergeTree operation, when given a tree in the standard format, will modify the native tree in the following ways:

  • Chroma - The ColorSpaceType subnode of a Chroma node may change the target colorspace of the compressed image. The selection of a new colorspace can cause a number of changes, in keeping with the algorithms described above: app0JFIF and app14Adobe nodes may be added or removed, subsampling may be added or removed, component ids may be changed, and sof and sos nodes will be updated accordingly. If necessary, additional quantization and huffman tables are added. In the case of quantization tables, the default will be scaled to match the quality level of any existing tables. No tables are added to metadata that does not already contain tables. If the existing metadata specifies progressive encoding, then the number of channels must not change. Any Transparency node is also taken into account, as an explicit value of none for the Alpha subnode can cause the removal of an alpha channel, and anything other than none can cause the addition of an alpha channel.
  • Dimension - A PixelAspectRatio specification can cause the contents of an app0JFIF node to change, if there is one present, or the addition of an app0JFIF node containing appropriate values, if there can be one. An appropriate pair of integers is computed from the floating-point ratio for inclusion in the node.
  • Text - Each uncompressed text item is converted to a com node and inserted according to the rules above for merging com nodes.

setFromTree - Native Format
The setFromTree operation, when given a tree in the native format described below, will simply replace the existing tree in its entirety with the new one. The tree must consist of IIOMetadataNodes.

setFromTree - Standard Format
The setFromTree operation, when given a tree in the standard format, performs a reset followed by a merge of the new tree.

Image Metadata DTD

<!DOCTYPE "javax_imageio_jpeg_image_1.0" [

  <!ELEMENT "javax_imageio_jpeg_image_1.0" (JPEGvariety, markerSequence)>

    <!ELEMENT "JPEGvariety" (app0JFIF)>
      <!-- A node grouping all marker segments specific to the variety of
              stream being read/written (e.g. JFIF) - may be empty -->

      <!ELEMENT "app0JFIF" (JFXX?, app2ICC?)>
        <!ATTLIST "app0JFIF" "majorVersion" #CDATA "1">
          <!-- The major JFIF version number -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app0JFIF" "minorVersion" #CDATA "2">
          <!-- The minor JFIF version number -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app0JFIF" "resUnits" ("0" | "1" | "2") "0">
          <!-- The resolution units for Xdensisty and Ydensity (0 = no
               units, just aspect ratio; 1 = dots/inch; 2 = dots/cm) -->
        <!ATTLIST "app0JFIF" "Xdensity" #CDATA "1">
          <!-- The horizontal density or aspect ratio numerator -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app0JFIF" "Ydensity" #CDATA "1">
          <!-- The vertical density or aspect ratio denominator -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app0JFIF" "thumbWidth" #CDATA "0">
          <!-- The width of the thumbnail, or 0 if there isn't one -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app0JFIF" "thumbHeight" #CDATA "0">
          <!-- The height of the thumbnail, or 0 if there isn't one -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

        <!ELEMENT "JFXX" (app0JFXX)*>
          <!-- Min children: 1 -->

        <!ELEMENT "app0JFXX" (JFIFthumbJPEG | JFIFthumbPalette |
          JFIFthumbRGB)>
          <!-- A JFIF extension marker segment -->
          <!ATTLIST "app0JFXX" "extensionCode" ("16" | "17" | "19")
             #IMPLIED>
            <!-- The JFXX extension code identifying thumbnail type: (16 =
                 JPEG, 17 = indexed, 19 = RGB -->

          <!ELEMENT "JFIFthumbJPEG" (markerSequence?)>
            <!-- A JFIF thumbnail in JPEG format (no JFIF segments
                 permitted) -->

          <!ELEMENT "JFIFthumbPalette" EMPTY>
            <!-- A JFIF thumbnail as an RGB indexed image -->
            <!ATTLIST "JFIFthumbPalette" "thumbWidth" #CDATA #IMPLIED>
              <!-- The width of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->
            <!ATTLIST "JFIFthumbPalette" "thumbHeight" #CDATA #IMPLIED>
              <!-- The height of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->

          <!ELEMENT "JFIFthumbRGB" EMPTY>
            <!-- A JFIF thumbnail as an RGB image -->
            <!ATTLIST "JFIFthumbRGB" "thumbWidth" #CDATA #IMPLIED>
              <!-- The width of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->
            <!ATTLIST "JFIFthumbRGB" "thumbHeight" #CDATA #IMPLIED>
              <!-- The height of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->

        <!ELEMENT "app2ICC" EMPTY>
          <!-- An ICC profile APP2 marker segment -->
          <!-- Optional User object: java.awt.color.ICC_Profile -->

    <!ELEMENT "markerSequence" (dqt | dht | dri | com | unknown |
      app14Adobe | sof | sos)*>
      <!-- A node grouping all non-jfif marker segments -->

      <!ELEMENT "dqt" (dqtable)*>
        <!-- A Define Quantization Table(s) marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->

        <!ELEMENT "dqtable" EMPTY>
          <!-- A single quantization table -->
          <!-- User object: javax.imageio.plugins.jpeg.JPEGQTable -->
          <!ATTLIST "dqtable" "elementPrecision" #CDATA "0">
            <!-- The number of bits in each table element (0 = 8, 1 = 16)
                 -->
            <!-- Data type: Integer -->
          <!ATTLIST "dqtable" "qtableId" ("0" | "1" | "2" | "3") #REQUIRED>

      <!ELEMENT "dht" (dhtable)*>
        <!-- A Define Huffman Table(s) marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->

        <!ELEMENT "dhtable" EMPTY>
          <!-- A single Huffman table -->
          <!-- User object: javax.imageio.plugins.jpeg.JPEGHuffmanTable -->
          <!ATTLIST "dhtable" "class" ("0" | "1") #REQUIRED>
            <!-- Indicates whether this is a DC (0) or an AC (1) table -->
          <!ATTLIST "dhtable" "htableId" ("0" | "1" | "2" | "3") #REQUIRED>
            <!-- The table id -->

      <!ELEMENT "dri" EMPTY>
        <!-- A Define Restart Interval marker segment -->
        <!ATTLIST "dri" "interval" #CDATA #REQUIRED>
          <!-- The restart interval in MCUs -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "com" EMPTY>
        <!-- A Comment marker segment. The user object contains the actual
             bytes. -->
        <!-- User object: array of [B -->
        <!-- Min length: 1 -->
        <!-- Max length: 65533 -->
        <!ATTLIST "com" "comment" #CDATA #IMPLIED>
          <!-- The comment as a string (used only if user object is null)
               -->
          <!-- Data type: String -->

      <!ELEMENT "unknown" EMPTY>
        <!-- An unrecognized marker segment. The user object contains the
             data not including length. -->
        <!-- User object: array of [B -->
        <!-- Min length: 1 -->
        <!-- Max length: 65533 -->
        <!ATTLIST "unknown" "MarkerTag" #CDATA #REQUIRED>
          <!-- The tag identifying this marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "app14Adobe" EMPTY>
        <!-- An Adobe APP14 marker segment -->
        <!ATTLIST "app14Adobe" "version" #CDATA "100">
          <!-- The version of Adobe APP14 marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 100 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app14Adobe" "flags0" #CDATA "0">
          <!-- The flags0 variable of an APP14 marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app14Adobe" "flags1" #CDATA "0">
          <!-- The flags1 variable of an APP14 marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app14Adobe" "transform" ("0" | "1" | "2") #REQUIRED>
          <!-- The color transform applied to the image (0 = Unknown, 1 =
               YCbCr, 2 = YCCK) -->

      <!ELEMENT "sof" (componentSpec)*>
        <!-- A Start Of Frame marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->
        <!ATTLIST "sof" "process" ("0" | "1" | "2") #IMPLIED>
          <!-- The JPEG process (0 = Baseline sequential, 1 = Extended
               sequential, 2 = Progressive) -->
        <!ATTLIST "sof" "samplePrecision" #CDATA "8">
          <!-- The number of bits per sample -->
          <!-- Data type: Integer -->
        <!ATTLIST "sof" "numLines" #CDATA #IMPLIED>
          <!-- The number of lines in the image -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "sof" "samplesPerLine" #CDATA #IMPLIED>
          <!-- The number of samples per line -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "sof" "numFrameComponents" ("1" | "2" | "3" | "4")
           #IMPLIED>
          <!-- The number of components in the image -->

        <!ELEMENT "componentSpec" EMPTY>
          <!-- A component specification for a frame -->
          <!ATTLIST "componentSpec" "componentId" #CDATA #REQUIRED>
            <!-- The id for this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 0 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "componentSpec" "HsamplingFactor" #CDATA #REQUIRED>
            <!-- The horizontal sampling factor for this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 1 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "componentSpec" "VsamplingFactor" #CDATA #REQUIRED>
            <!-- The vertical sampling factor for this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 1 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "componentSpec" "QtableSelector" ("0" | "1" | "2" |
            "3") #REQUIRED>
            <!-- The quantization table to use for this component -->

      <!ELEMENT "sos" (scanComponentSpec)*>
        <!-- A Start Of Scan marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->
        <!ATTLIST "sos" "numScanComponents" ("1" | "2" | "3" | "4")
           #REQUIRED>
          <!-- The number of components in the scan -->
        <!ATTLIST "sos" "startSpectralSelection" #CDATA "0">
          <!-- The first spectral band included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 63 (inclusive) -->
        <!ATTLIST "sos" "endSpectralSelection" #CDATA "63">
          <!-- The last spectral band included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 63 (inclusive) -->
        <!ATTLIST "sos" "approxHigh" #CDATA "0">
          <!-- The highest bit position included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 15 (inclusive) -->
        <!ATTLIST "sos" "approxLow" #CDATA "0">
          <!-- The lowest bit position included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 15 (inclusive) -->

        <!ELEMENT "scanComponentSpec" EMPTY>
          <!-- A component specification for a scan -->
          <!ATTLIST "scanComponentSpec" "componentSelector" #CDATA
             #REQUIRED>
            <!-- The id of this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 0 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "scanComponentSpec" "dcHuffTable" ("0" | "1" | "2" |
            "3") #REQUIRED>
            <!-- The huffman table to use for encoding DC coefficients -->
          <!ATTLIST "scanComponentSpec" "acHuffTable" ("0" | "1" | "2" |
            "3") #REQUIRED>
            <!-- The huffman table to use for encoding AC coefficients -->
]>

Stream Metadata DTD

<!DOCTYPE "javax_imageio_jpeg_stream_1.0" [
  <!ELEMENT "javax_imageio_jpeg_stream_1.0" (dqt |
                      dht |
                      dri |
                      com |
                      unknown)*>

  <!-- All elements are as defined above for image metadata -->
]>


PNG Metadata Format Specification

The PNG native format encodes the complete contents of a PNG file chunk by chunk, except for the IDAT chunks that contain the actual image data. Chunks that are not defined in the PNG 1.2 specification are stored under the UnknownChunks element. Note that it is the responsibility of application software to implement the rules for PNG readers, writers, and editors (e.g., the rules concerning unsafe-to-copy chunks) described in the PNG specification. The Image I/O library is not, in and of itself, a PNG reader, writer, or editor in the sense of the specification. Rather, it is a tool that may be used to build PNG readers, writers, and editors.

The image's actual width, height, bit depth, and color type will override any values passed to the writer via metadata, with one exception. If the image has an IndexColorModel, the color table entries will be checked to determine if they form a uniform grayscale ramp. If so, the image will normally be encoded using as grayscale instead of palette color. However, if the color type set in the metadata is "Palette", palette color will be used.

If no metadata is supplied when encoding an image, the header is initialized from the image being encoded, and no optional chunks are included.

The semantics of the standard chunks are described in the PNG specification. Note that there are some restrictions on which chunks may appear for each color type. In particular,

  • A PLTE chunk may not appear in a Gray or GrayAlpha image
  • hIST and tRNS chunks require a prior PLTE chunk
  • A tRNS chunk may not appear in GrayAlpha and RGBA images
The child nodes of the bKGD, sBIT, and tRNS chunks must match the image's color type.

Certain chunks may meaningfully appear multiple times in a PNG file, in particular the text-related chunks. In order to simplify the metadata format, multiple instances of these chunks are consolidated under a single parent node (e.g., the tEXt node), which may have zero or more children (e.g., tEXtEntry nodes). If no children are present, no chunk will be written. Similarly, unknown chunks are stored as children of a single UnknownChunks node.

It is not possible to control the ordering of the chunks as they are written, or to determine the order of the chunks in a file being read.

<!DOCTYPE "javax_imageio_png_1.0" [

  <!ELEMENT "javax_imageio_png_1.0" (IHDR?, PLTE?, bKGD?, cHRM?,
    gAMA?, hIST?, iCCP?, iTXt?, pHYS?, sBIT?, sPLT?, sRGB?, tEXt?,
    tIME?, tRNS?, zTXt?, UnknownChunks?)>

    <!ELEMENT "IHDR" EMPTY>
      <!-- The IHDR chunk, containing the header -->
      <!ATTLIST "IHDR" "width" #CDATA #REQUIRED>
        <!-- The width of the image in pixels -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "IHDR" "height" #CDATA #REQUIRED>
        <!-- The height of the image in pixels -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "IHDR" "bitDepth" ("1" | "2" | "4" | "8" | "16")
         #REQUIRED>
        <!-- The bit depth of the image samples -->
      <!ATTLIST "IHDR" "colorType" ("Grayscale" | "RGB" | "Palette" |
        "GrayAlpha" | "RGBAlpha") #REQUIRED>
        <!-- The color type of the image -->
      <!ATTLIST "IHDR" "compressionMethod" ("deflate") #REQUIRED>
        <!-- The compression used for image data, always "deflate" -->
      <!ATTLIST "IHDR" "filterMethod" ("adaptive") #REQUIRED>
        <!-- The filtering method used for compression, always "adaptive" -->
      <!ATTLIST "IHDR" "interlaceMethod" ("none" | "adam7") #REQUIRED>
        <!-- The interlacing method, "none" or "adam7" -->

    <!ELEMENT "PLTE" (PLTEEntry)*>
      <!-- The PLTE chunk, containing the palette -->
      <!-- Min children: 1 -->
      <!-- Max children: 256 -->

      <!ELEMENT "PLTEEntry" EMPTY>
        <!-- A palette entry -->
        <!ATTLIST "PLTEEntry" "index" #CDATA #REQUIRED>
          <!-- The index of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "PLTEEntry" "red" #CDATA #REQUIRED>
          <!-- The red value of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "PLTEEntry" "green" #CDATA #REQUIRED>
          <!-- The green value of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "PLTEEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "bKGD" (bKGD_Grayscale | bKGD_RGB | bKGD_Palette)>
      <!-- The bKGD chunk, containing the background color -->

      <!ELEMENT "bKGD_Grayscale" EMPTY>
        <!-- A grayscale background color, for Gray and GrayAlpha images -->
        <!ATTLIST "bKGD_Grayscale" "gray" #CDATA #REQUIRED>
          <!-- A gray value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "bKGD_RGB" EMPTY>
        <!-- An RGB background color, for RGB and RGBAlpha images -->
        <!ATTLIST "bKGD_RGB" "red" #CDATA #REQUIRED>
          <!-- A red value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "bKGD_RGB" "green" #CDATA #REQUIRED>
          <!-- A green value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "bKGD_RGB" "blue" #CDATA #REQUIRED>
          <!-- A blue value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "bKGD_Palette" EMPTY>
        <!-- A background palette index -->
        <!ATTLIST "bKGD_Palette" "index" #CDATA #REQUIRED>
          <!-- A palette index to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "cHRM" EMPTY>
      <!-- The cHRM chunk, containing color calibration -->
      <!ATTLIST "cHRM" "whitePointX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the white point, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "whitePointY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the white point, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "redX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the red primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "redY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the red primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "greenX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the green primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "greenY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the green primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "blueX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the blue primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "blueY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the blue primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->

    <!ELEMENT "gAMA" EMPTY>
      <!-- The gAMA chunk, containing the image gamma -->
      <!ATTLIST "gAMA" "value" #CDATA #REQUIRED>
        <!-- The image gamma, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->

    <!ELEMENT "hIST" (hISTEntry)*>
      <!-- The hIST chunk, containing histogram information  -->
      <!-- Min children: 1 -->
      <!-- Max children: 256 -->

      <!ELEMENT "hISTEntry" EMPTY>
        <!-- A histogram entry -->
        <!ATTLIST "hISTEntry" "index" #CDATA #REQUIRED>
          <!-- The palette index of this histogram entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "hISTEntry" "value" #CDATA #REQUIRED>
          <!-- The frequency of this histogram entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

    <!ELEMENT "iCCP" EMPTY>
      <!-- The iCCP chunk, containing an ICC color profile -->
      <!-- User object: array of byte -->
      <!-- Min length: 0 -->
      <!-- Max length: 2147483647 -->
      <!ATTLIST "iCCP" "profileName" #CDATA #REQUIRED>
        <!-- The name of this ICC profile -->
        <!-- Data type: String -->
      <!ATTLIST "iCCP" "compressionMethod" ("deflate") #REQUIRED>
        <!-- The compression method used to store this ICC profile -->

    <!ELEMENT "iTXt" (iTXtEntry)*>
      <!-- The iTXt chunk, containing internationalized text -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "iTXtEntry" EMPTY>
        <!-- A localized text entry -->
        <!ATTLIST "iTXtEntry" "keyword" #CDATA #REQUIRED>
          <!-- The keyword -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "compressionFlag" ("TRUE" | "FALSE")
           #REQUIRED>
        <!ATTLIST "iTXtEntry" "compressionMethod" #CDATA #REQUIRED>
          <!-- The compression method used to store this iTXt entry -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "languageTag" #CDATA #REQUIRED>
          <!-- The ISO tag describing the language this iTXt entry -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "translatedKeyword" #CDATA #REQUIRED>
          <!-- The translated keyword for iTXt entry -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "text" #CDATA #REQUIRED>
          <!-- The localized text -->
          <!-- Data type: String -->

    <!ELEMENT "pHYS" EMPTY>
      <!-- The pHYS chunk, containing the pixel size and aspect ratio -->
      <!ATTLIST "pHYS" "pixelsPerUnitXAxis" #CDATA #REQUIRED>
        <!-- The number of horizontal pixels per unit, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "pHYS" "pixelsPerUnitYAxis" #CDATA #REQUIRED>
        <!-- The number of vertical pixels per unit, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "pHYS" "unitSpecifier" ("unknown" | "meter") #REQUIRED>
        <!-- The unit specifier for this chunk (i.e., meters) -->

    <!ELEMENT "sBIT" (sBIT_Grayscale | sBIT_GrayAlpha | sBIT_RGB |
      sBIT_RGBAlpha | sBIT_Palette)>
      <!-- The sBIT chunk, containing significant bit information -->

      <!ELEMENT "sBIT_Grayscale" EMPTY>
        <!-- Significant bit information for gray samples -->
        <!ATTLIST "sBIT_Grayscale" "gray" #CDATA #REQUIRED>
          <!-- The number of significant bits of the gray samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_GrayAlpha" EMPTY>
        <!-- Significant bit information for gray and alpha samples -->
        <!ATTLIST "sBIT_GrayAlpha" "gray" #CDATA #REQUIRED>
          <!-- The number of significant bits of the gray samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_GrayAlpha" "alpha" #CDATA #REQUIRED>
          <!-- The number of significant bits of the alpha samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_RGB" EMPTY>
        <!-- Significant bit information for RGB samples -->
        <!ATTLIST "sBIT_RGB" "red" #CDATA #REQUIRED>
          <!-- The number of significant bits of the red samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGB" "green" #CDATA #REQUIRED>
          <!-- The number of significant bits of the green samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGB" "blue" #CDATA #REQUIRED>
          <!-- The number of significant bits of the blue samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_RGBAlpha" EMPTY>
        <!-- Significant bit information for RGBA samples -->
        <!ATTLIST "sBIT_RGBAlpha" "red" #CDATA #REQUIRED>
          <!-- The number of significant bits of the red samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGBAlpha" "green" #CDATA #REQUIRED>
          <!-- The number of significant bits of the green samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGBAlpha" "blue" #CDATA #REQUIRED>
          <!-- The number of significant bits of the blue samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGBAlpha" "alpha" #CDATA #REQUIRED>
          <!-- The number of significant bits of the alpha samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_Palette" EMPTY>
        <!-- Significant bit information for RGB palette entries -->
        <!ATTLIST "sBIT_Palette" "red" #CDATA #REQUIRED>
          <!-- The number of significant bits of the red palette entries -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_Palette" "green" #CDATA #REQUIRED>
          <!-- The number of significant bits of the green palette entries -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_Palette" "blue" #CDATA #REQUIRED>
          <!-- The number of significant bits of the blue palette entries -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "sPLT" (sPLTEntry)*>
      <!-- The sPLT chunk, containing a suggested palette -->
      <!-- Min children: 1 -->
      <!-- Max children: 256 -->

      <!ELEMENT "sPLTEntry" EMPTY>
        <!-- A suggested palette entry -->
        <!ATTLIST "sPLTEntry" "index" #CDATA #REQUIRED>
          <!-- The index of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "red" #CDATA #REQUIRED>
          <!-- The red value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "green" #CDATA #REQUIRED>
          <!-- The green value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "alpha" #CDATA #REQUIRED>
          <!-- The blue value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "sRGB" EMPTY>
      <!-- The sRGB chunk, containing rendering intent information -->
      <!ATTLIST "sRGB" "renderingIntent" ("Perceptual" |
        "Relative colorimetric" | "Saturation" |
        "Absolute colorimetric") #REQUIRED>
        <!-- The rendering intent -->

    <!ELEMENT "tEXt" (tEXtEntry)*>
      <!-- The tEXt chunk, containing text -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "tEXtEntry" EMPTY>
        <!-- A text entry -->
        <!ATTLIST "tEXtEntry" "keyword" #CDATA #REQUIRED>
          <!-- The keyword -->
          <!-- Data type: String -->
        <!ATTLIST "tEXtEntry" "value" #CDATA #REQUIRED>
          <!-- The text -->
          <!-- Data type: String -->

    <!ELEMENT "tIME" EMPTY>
      <!-- The tIME chunk, containing the image modification time -->
      <!ATTLIST "tIME" "year" #CDATA #REQUIRED>
        <!-- The year when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "tIME" "month" #CDATA #REQUIRED>
        <!-- The month when the image was last modified, 1 = January -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 12 (inclusive) -->
      <!ATTLIST "tIME" "day" #CDATA #REQUIRED>
        <!-- The day of the month when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 31 (inclusive) -->
      <!ATTLIST "tIME" "hour" #CDATA #REQUIRED>
        <!-- The hour when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 23 (inclusive) -->
      <!ATTLIST "tIME" "minute" #CDATA #REQUIRED>
        <!-- The minute when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 59 (inclusive) -->
      <!ATTLIST "tIME" "second" #CDATA #REQUIRED>
        <!-- The second when the image was last modified, 60 = leap second -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 60 (inclusive) -->

    <!ELEMENT "tRNS" (tRNS_Grayscale | tRNS_RGB | tRNS_Palette)>
      <!-- The tRNS chunk, containing transparency information -->

      <!ELEMENT "tRNS_Grayscale" EMPTY>
        <!-- A grayscale value that should be considered transparent -->
        <!ATTLIST "tRNS_Grayscale" "gray" #CDATA #REQUIRED>
          <!-- The gray value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "tRNS_RGB" EMPTY>
        <!-- An RGB value that should be considered transparent -->
        <!ATTLIST "tRNS_RGB" "red" #CDATA #REQUIRED>
          <!-- The red value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "tRNS_RGB" "green" #CDATA #REQUIRED>
          <!-- The green value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "tRNS_RGB" "blue" #CDATA #REQUIRED>
          <!-- The blure value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "tRNS_Palette" EMPTY>
        <!-- A palette index that should be considered transparent -->
        <!ATTLIST "tRNS_Palette" "index" #CDATA #REQUIRED>
          <!-- A palette index to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "tRNS_Palette" "alpha" #CDATA #REQUIRED>
          <!-- The transparency associated with the palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "zTXt" (zTXtEntry)*>
      <!-- The zTXt chunk, containing compressed text -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "zTXtEntry" EMPTY>
        <!-- A compressed text entry -->
        <!-- User object: array of byte -->
        <!-- Min length: 0 -->
        <!-- Max length: 2147483647 -->
        <!ATTLIST "zTXtEntry" "keyword" #CDATA #REQUIRED>
          <!-- The keyword -->
          <!-- Data type: String -->
        <!ATTLIST "zTXtEntry" "compressionMethod" ("deflate")
           #REQUIRED>
          <!-- The compressed text -->

    <!ELEMENT "UnknownChunks" (UnknownChunk)*>
      <!-- A set of unknown chunks -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "UnknownChunk" EMPTY>
        <!-- Unknown chunk data stored as a byte array -->
        <!-- User object: array of byte -->
        <!-- Min length: 0 -->
        <!-- Max length: 2147483647 -->
        <!ATTLIST "UnknownChunk" "type" #CDATA #REQUIRED>
          <!-- The 4-character type of the unknown chunk -->
          <!-- Data type: String -->
]>


Standard Metadata Format Specification

Standard (Plug-in Neutral) Metadata Format Specification

The plug-in neutral "javax_imageio_1.0" format consists of a root node named "javax_imageio_1.0" which has child nodes "chroma", "compression", "dimension", "document", "text", "tile", and "transparency". The format is described by the following DTD:

<!DOCTYPE "javax_imageio_1.0" [

  <!ELEMENT "javax_imageio_1.0" (Chroma?, Compression?, Data?, Dimension?,
    Document?, Text?, Transparency?)>

    <!ELEMENT "Chroma" (ColorSpaceType?, NumChannels?, Gamma?,
      BlackIsZero?, Palette?, BackgroundIndex?, BackgroundColor?)>
      <!-- Chroma (color) information -->

      <!ELEMENT "ColorSpaceType" EMPTY>
        <!-- The raw color space of the image -->
        <!ATTLIST "ColorSpaceType" "name" ("XYZ" | "Lab" | "Luv" |
          "YCbCr" | "Yxy" | "YCCK" | "PhotoYCC" | "RGB" | "GRAY" | "HSV" |
          "HLS" | "CMYK" | "CMY" | "2CLR" | "3CLR" | "4CLR" | "5CLR" |
          "6CLR" | "7CLR" | "8CLR" | "9CLR" | "ACLR" | "BCLR" | "CCLR" |
          "DCLR" | "ECLR" | "FCLR") #REQUIRED>

      <!ELEMENT "NumChannels" EMPTY>
        <!-- The number of channels in the raw image, including alpha -->
        <!ATTLIST "NumChannels" "value" #CDATA #REQUIRED>
          <!-- Data type: List of Integer -->

      <!ELEMENT "Gamma" EMPTY>
        <!-- The image gamma -->
        <!ATTLIST "Gamma" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "BlackIsZero" EMPTY>
        <!-- True if smaller values represent darker shades -->
        <!ATTLIST "BlackIsZero" "value" ("TRUE" | "FALSE") "TRUE">

      <!ELEMENT "Palette" (PaletteEntry)*>
        <!-- Palette-color information -->

        <!ELEMENT "PaletteEntry" EMPTY>
          <!-- A palette entry -->
          <!ATTLIST "PaletteEntry" "index" #CDATA #REQUIRED>
            <!-- The index of the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "red" #CDATA #REQUIRED>
            <!-- The red value for the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "green" #CDATA #REQUIRED>
            <!-- The green value for the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "blue" #CDATA #REQUIRED>
            <!-- The blue value for the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "alpha" #CDATA "255">
            <!-- The alpha value for the palette entry -->
            <!-- Data type: Integer -->

      <!ELEMENT "BackgroundIndex" EMPTY>
        <!-- A palette index to be used as a background -->
        <!ATTLIST "BackgroundIndex" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "BackgroundColor" EMPTY>
        <!-- An RGB triple to be used as a background -->
        <!ATTLIST "BackgroundColor" "red" #CDATA #REQUIRED>
          <!-- The red background value -->
          <!-- Data type: Integer -->
        <!ATTLIST "BackgroundColor" "green" #CDATA #REQUIRED>
          <!-- The green background value -->
          <!-- Data type: Integer -->
        <!ATTLIST "BackgroundColor" "blue" #CDATA #REQUIRED>
          <!-- The blue background value -->
          <!-- Data type: Integer -->

    <!ELEMENT "Compression" (CompressionTypeName?, Lossless?,
      NumProgressiveScans?, BitRate?)>
      <!-- Compression information -->

      <!ELEMENT "CompressionTypeName" EMPTY>
        <!-- The name of the compression scheme in use -->
        <!ATTLIST "CompressionTypeName" "value" #CDATA #REQUIRED>
          <!-- Data type: String -->

      <!ELEMENT "Lossless" EMPTY>
        <!-- True if the compression scheme is lossless -->
        <!ATTLIST "Lossless" "value" ("TRUE" | "FALSE") "TRUE">

      <!ELEMENT "NumProgressiveScans" EMPTY>
        <!-- The number of progressive scans used in the image encoding -->
        <!ATTLIST "NumProgressiveScans" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "BitRate" EMPTY>
        <!-- The estimated bit rate of the compression scheme -->
        <!ATTLIST "BitRate" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

    <!ELEMENT "Data" (PlanarConfiguration?, SampleFormat?, BitsPerSample?,
      SignificantBitsPerSample?, SampleMSB?)>
      <!-- Information on the image layout -->

      <!ELEMENT "PlanarConfiguration" EMPTY>
        <!-- The organization of image samples in the stream -->
        <!ATTLIST "PlanarConfiguration" "value" ("PixelInterleaved" |
          "PlaneInterleaved" | "LineInterleaved" | "TileInterleaved")
           #REQUIRED>

      <!ELEMENT "SampleFormat" EMPTY>
        <!-- The numeric format of image samples -->
        <!ATTLIST "SampleFormat" "value" ("SignedIntegral" |
          "UnsignedIntegral" | "Real" | "Index") #REQUIRED>

      <!ELEMENT "BitsPerSample" EMPTY>
        <!-- The number of bits per sample -->
        <!ATTLIST "BitsPerSample" "value" #CDATA #REQUIRED>
          <!-- A list of integers, one per channel -->
          <!-- Data type: List of Integer -->
          <!-- Min length: 1 -->

      <!ELEMENT "SignificantBitsPerSample" EMPTY>
        <!-- The number of significant bits per sample -->
        <!ATTLIST "SignificantBitsPerSample" "value" #CDATA #REQUIRED>
          <!-- A list of integers, one per channel -->
          <!-- Data type: List of Integer -->
          <!-- Min length: 1 -->

      <!ELEMENT "SampleMSB" EMPTY>
        <!-- The position of the most significant bit of each sample -->
        <!ATTLIST "SampleMSB" "value" #CDATA #REQUIRED>
          <!-- A list of integers, one per channel -->
          <!-- Data type: List of Integer -->
          <!-- Min length: 1 -->

    <!ELEMENT "Dimension" (PixelAspectRatio?, ImageOrientation?,
      HorizontalPixelSize?, VerticalPixelSize?,
      HorizontalPhysicalPixelSpacing?, VerticalPhysicalPixelSpacing?,
      HorizontalPosition?, VerticalPosition?, HorizontalPixelOffset?,
      VerticalPixelOffset?, HorizontalScreenSize?, VerticalScreenSize?)>
      <!-- Dimension information -->

      <!ELEMENT "PixelAspectRatio" EMPTY>
        <!-- The width of a pixel divided by its height -->
        <!ATTLIST "PixelAspectRatio" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "ImageOrientation" EMPTY>
        <!-- The desired orientation of the image in terms of flips and
             counter-clockwise rotations -->
        <!ATTLIST "ImageOrientation" "value" ("Normal" | "Rotate90" |
          "Rotate180" | "Rotate270" | "FlipH" | "FlipV" |
          "FlipHRotate90" | "FlipVRotate90") #REQUIRED>

      <!ELEMENT "HorizontalPixelSize" EMPTY>
        <!-- The width of a pixel, in millimeters, as it should be rendered
             on media -->
        <!ATTLIST "HorizontalPixelSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "VerticalPixelSize" EMPTY>
        <!-- The height of a pixel, in millimeters, as it should be
             rendered on media -->
        <!ATTLIST "VerticalPixelSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "HorizontalPhysicalPixelSpacing" EMPTY>
        <!-- The horizontal distance in the subject of the image, in
             millimeters, represented by one pixel at the center of the
             image -->
        <!ATTLIST "HorizontalPhysicalPixelSpacing" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "VerticalPhysicalPixelSpacing" EMPTY>
        <!-- The vertical distance in the subject of the image, in
             millimeters, represented by one pixel at the center of the
             image -->
        <!ATTLIST "VerticalPhysicalPixelSpacing" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "HorizontalPosition" EMPTY>
        <!-- The horizontal position, in millimeters, where the image
             should be rendered on media -->
        <!ATTLIST "HorizontalPosition" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "VerticalPosition" EMPTY>
        <!-- The vertical position, in millimeters, where the image should
             be rendered on media -->
        <!ATTLIST "VerticalPosition" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "HorizontalPixelOffset" EMPTY>
        <!-- The horizontal position, in pixels, where the image should be
             rendered onto a raster display -->
        <!ATTLIST "HorizontalPixelOffset" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "VerticalPixelOffset" EMPTY>
        <!-- The vertical position, in pixels, where the image should be
             rendered onto a raster display -->
        <!ATTLIST "VerticalPixelOffset" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "HorizontalScreenSize" EMPTY>
        <!-- The width, in pixels, of the raster display into which the
             image should be rendered -->
        <!ATTLIST "HorizontalScreenSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "VerticalScreenSize" EMPTY>
        <!-- The height, in pixels, of the raster display into which the
             image should be rendered -->
        <!ATTLIST "VerticalScreenSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

    <!ELEMENT "Document" (FormatVersion?, SubimageInterpretation?,
      ImageCreationTime?, ImageModificationTime?)>
      <!-- Document information -->

      <!ELEMENT "FormatVersion" EMPTY>
        <!-- The version of the format used by the stream -->
        <!ATTLIST "FormatVersion" "value" #CDATA #REQUIRED>
          <!-- Data type: String -->

      <!ELEMENT "SubimageInterpretation" EMPTY>
        <!-- The interpretation of this image in relation to the other
             images stored in the same stream -->
        <!ATTLIST "SubimageInterpretation" "value" ("Standalone" |
          "SinglePage" | "FullResolution" | "ReducedResolution" |
          "PyramidLayer" | "Preview" | "VolumeSlice" | "ObjectView" |
          "Panorama" | "AnimationFrame" | "TransparencyMask" |
          "CompositingLayer" | "SpectralSlice" | "Unknown") #REQUIRED>

      <!ELEMENT "ImageCreationTime" EMPTY>
        <!-- The time of image creation -->
        <!ATTLIST "ImageCreationTime" "year" #CDATA #REQUIRED>
          <!-- The full year (e.g., 1967, not 67) -->
          <!-- Data type: Integer -->
        <!ATTLIST "ImageCreationTime" "month" #CDATA #REQUIRED>
          <!-- The month, with January = 1 -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 12 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "day" #CDATA #REQUIRED>
          <!-- The day of the month -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 31 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "hour" #CDATA "0">
          <!-- The hour from 0 to 23 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 23 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "minute" #CDATA "0">
          <!-- The minute from 0 to 59 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 59 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "second" #CDATA "0">
          <!-- The second from 0 to 60 (60 = leap second) -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 60 (inclusive) -->

      <!ELEMENT "ImageModificationTime" EMPTY>
        <!-- The time of the last image modification -->
        <!ATTLIST "ImageModificationTime" "year" #CDATA #REQUIRED>
          <!-- The full year (e.g., 1967, not 67) -->
          <!-- Data type: Integer -->
        <!ATTLIST "ImageModificationTime" "month" #CDATA #REQUIRED>
          <!-- The month, with January = 1 -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 12 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "day" #CDATA #REQUIRED>
          <!-- The day of the month -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 31 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "hour" #CDATA "0">
          <!-- The hour from 0 to 23 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 23 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "minute" #CDATA "0">
          <!-- The minute from 0 to 59 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 59 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "second" #CDATA "0">
          <!-- The second from 0 to 60 (60 = leap second) -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 60 (inclusive) -->

    <!ELEMENT "Text" (TextEntry)*>
      <!-- Text information -->

      <!ELEMENT "TextEntry" EMPTY>
        <!-- A text entry -->
        <!ATTLIST "TextEntry" "keyword" #CDATA #IMPLIED>
          <!-- A keyword associated with the text entry -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "value" #CDATA #REQUIRED>
          <!-- the text entry -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "language" #CDATA #IMPLIED>
          <!-- The language of the text -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "encoding" #CDATA #IMPLIED>
          <!-- The encoding of the text -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "compression" ("none" | "lzw" | "zip" |
          "bzip" | "other") "none">
          <!-- The method used to compress the text -->

    <!ELEMENT "Transparency" (Alpha?, TransparentIndex?,
      TransparentColor?, TileTransparencies?, TileOpacities?)>
      <!-- Transparency information -->

      <!ELEMENT "Alpha" EMPTY>
        <!-- The type of alpha information contained in the image -->
        <!ATTLIST "Alpha" "value" ("none" | "premultiplied" |
          "nonpremultiplied") "none">

      <!ELEMENT "TransparentIndex" EMPTY>
        <!-- A palette index to be treated as transparent -->
        <!ATTLIST "TransparentIndex" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "TransparentColor" EMPTY>
        <!-- An RGB color to be treated as transparent -->
        <!ATTLIST "TransparentColor" "value" #CDATA #REQUIRED>
          <!-- Data type: List of Integer -->

      <!ELEMENT "TileTransparencies" (TransparentTile)*>
        <!-- A list of completely transparent tiles -->

        <!ELEMENT "TransparentTile" EMPTY>
          <!-- The index of a completely transparent tile -->
          <!ATTLIST "TransparentTile" "x" #CDATA #REQUIRED>
            <!-- The tile's X index -->
            <!-- Data type: Integer -->
          <!ATTLIST "TransparentTile" "y" #CDATA #REQUIRED>
            <!-- The tile's Y index -->
            <!-- Data type: Integer -->

      <!ELEMENT "TileOpacities" (OpaqueTile)*>
        <!-- A list of completely opaque tiles -->

        <!ELEMENT "OpaqueTile" EMPTY>
          <!-- The index of a completely opaque tile -->
          <!ATTLIST "OpaqueTile" "x" #CDATA #REQUIRED>
            <!-- The tile's X index -->
            <!-- Data type: Integer -->
          <!ATTLIST "OpaqueTile" "y" #CDATA #REQUIRED>
            <!-- The tile's Y index -->
            <!-- Data type: Integer -->
]>


TIFF Metadata Format Specification and Usage Notes

Reading Images

  • Color Conversion
  • Color Spaces
  • ICC Profiles
  • Metadata Issues
    • Native to Standard Metadata Mapping
  • Reading Exif Images
    • Reading Uncompressed Exif Images
    • Reading Compressed Exif Images
Writing Images
  • Compression
  • Color Conversion
  • ICC Profiles
  • Metadata Issues
    • Standard to Native Metadata Mapping
  • Writing Exif Images
    • Writing Uncompressed Exif Images
    • Writing Compressed Exif Images
Native Stream Metadata Format
Native Image Metadata Format

Reading Images

TIFF images are read by an ImageReader which may be controlled by its public interface as well as via a supplied TIFFImageReadParam.

Color Conversion

If the source image data have photometric type CIE L*a*b* or YCbCr, and the destination color space type is RGB, then the source image data will be automatically converted to RGB using an internal color converter.

Color Spaces

The raw color space assigned by default, i.e., in the absence of a user-supplied ImageTypeSpecifier, will be the first among the following which applies:
  • A color space created from the ICC Profile metadata field if it is present and compatible with the image data layout.
  • sRGB if the image is monochrome/bilevel (a two-level color map is created internally).
  • sRGB if the image is palette-color.
  • Linear RGB if the image has three samples per pixel, has photometric type CIE L*a*b*, or has photometric type YCbCr and is not JPEG-compressed.
    •
  • A default CMYK color space if the image has photometric type CMYK and four samples per pixel.
  • Grayscale if the image has one or two samples per pixel and uniformly 1, 2, 4, 8, 16, or 32 bits per sample or is floating point.
  • sRGB if the image has three or four samples per pixel and uniformly 1, 2, 4, 8, 16, or 32 bits per sample or is floating point.
  • A fabricated, generic color space if the image has more than four samples per pixel and the number of bits per sample for all bands is the same and is a multiple of 8.
  • Grayscale if the image has one or two samples per pixel regardless of the number of bits per sample.
  • sRGB if the image has three or four samples per pixel regardless of the number of bits per sample.
  • A fabricated, generic color space if the image has more than four samples per pixel regardless of the number of bits per sample.

The normalized color coordinate transformations used for the default CMYK color space are defined as follows:

  • CMYK to linear RGB
    R = (1 - K)*(1 - C)
G = (1 - K)*(1 - M)
B = (1 - K)*(1 - Y)
  • Linear RGB to CMYK
    K = min{1 - R, 1 - G, 1 - B}
if(K != 1) {
    C = (1 - R - K)/(1 - K)
    M = (1 - G - K)/(1 - K)
    Y = (1 - B - K)/(1 - K)
} else {
    C = M = Y = 0
}

The generic color space used when no other color space can be inferred is provided merely to enable the data to be loaded. It is not intended to provide accurate conversions of any kind.

If the data are known to be in a color space not correctly handled by the foregoing, then an ImageTypeSpecifier should be supplied to the reader and should be derived from a color space which is correct for the data in question.

ICC Profiles

If an ICC profile is contained in the image metadata ( BaselineTIFFTagSet.TAG_ICC_PROFILE, tag number 34675), an attempt will be made to use it to create the color space of the loaded image. It will be used if the data layout is of component type and the number of samples per pixel equals or is one greater than the number of components described by the ICC profile. If the ICC profile is not used then the color space will be inferred in one of the subsequent steps described above.

If for some reason the embedded ICC profile is not used automatically, then it may be used manually by following this procedure:

  1. Obtain the image metadata from ImageReader.getImageMetadata
  2. Extract the ICC profile field and its value.
  3. Create an ICC_ColorSpace from an ICC_Profile created from the ICC profile field data using ICC_Profile.getInstance(byte[]).
  4. Create an ImageTypeSpecifier from the new color space using one of its factory methods which accepts an ICC_ColorSpace.
  5. Create a compatible ImageReadParam and set the ImageTypeSpecifier using ImageReadParam.setDestinationType.
  6. Pass the parameter object to the appropriate read method.

If the inferred color space not based on the ICC Profile field is compatible with the ICC profile-based color space, then a second ImageTypeSpecifier derived from this inferred color space will be included in the Iterator returned by ImageReader.getImageTypes. If the iterator contains more than one type, the first one will be based on the ICC profile and the second on the inferred color space.

Metadata Issues

By default all recognized fields in the TIFF image file directory (IFD) are loaded into the native image metadata object. Which fields are loaded may be controlled by setting which TIFF tags the reader is allowed to recognize, whether to read fields with unrecognized tags, and whether to ignore all metadata. The reader is informed to disregard all metadata as usual via the ignoreMetadata parameter of ImageReader.setInput(Object,boolean,boolean). It is informed of which TIFFTags to recognize or not to recognize via TIFFImageReadParam.addAllowedTagSet(TIFFTagSet) and TIFFImageReadParam.removeAllowedTagSet(TIFFTagSet). If ignoreMetadata is true, then only metadata essential to reading the image will be loaded into the native image metadata object. If ignoreMetadata is false, then the reader will by default load into the native image metadata object only those fields which are either essential to reading the image or have a TIFFTag contained in the one of the allowed TIFFTagSets. Reading of fields with tags not in the allowed TIFFTagSets may be forced by passing in a TIFFImageReadParam on which TIFFImageReadParam.setReadUnknownTags(boolean) has been invoked with parameter true.

Use of a TIFFDirectory object may simplify gaining access to metadata values. An instance of TIFFDirectory may be created from the IIOMetadata object returned by the TIFF reader using the TIFFDirectory.createFromMetadata method.

Mapping of TIFF Native Image Metadata to the Standard Metadata Format
The derivation of standard metadata format javax_imageio_1.0 elements from TIFF native image metadata is given in the following table.

Standard Metadata Element | Derivation from TIFF Fields
/Chroma/ColorSpaceType@name | PhotometricInterpretation: WhiteIsZero, BlackIsZero, TransparencyMask = "GRAY"; RGB, PaletteColor => "RGB"; CMYK => "CMYK"; YCbCr => "YCbCr"; CIELab, ICCLab => "Lab".
/Chroma/NumChannels@value | SamplesPerPixel
/Chroma/BlackIsZero@value | "TRUE" <=> PhotometricInterpretation => WhiteIsZero
/Chroma/Palette | ColorMap
/Compression/CompressionTypeName@value | Compression: Uncompressed => "none"; CCITT 1D => "CCITT RLE"; Group 3 Fax => "CCITT T.4"; Group 4 Fax => "CCITT T.6"; LZW => "LZW"; JPEG => "Old JPEG"; New JPEG => "JPEG"; Zlib =>> "ZLib"; PackBits => "PackBits"; Deflate => "Deflate"; Exif JPEG => "JPEG".
/Compression/Lossless@value | Compression: JPEG or New JPEG => "FALSE"; otherwise "TRUE".
/Data/PlanarConfiguration@value | Chunky => "PixelInterleaved"; Planar => "PlaneInterleaved".
/Data/SampleFormat@value | PhotometricInterpretation PaletteColor => "Index"; SampleFormat unsigned integer data => "UnsignedIntegral"; SampleFormat two's complement signed integer data => "SignedIntegral"; SampleFormat IEEE floating point data => "Real"; otherwise element not emitted.
/Data/BitsPerSample@value | BitsPerSample as a space-separated list.
/Data/SampleMSB@value | FillOrder: left-to-right => space-separated list of BitsPerSample-1; right-to-left => space-separated list of 0s.
/Dimension/PixelAspectRatio@value | (1/XResolution)/(1/YResolution)
/Dimension/ImageOrientation@value | Orientation
/Dimension/HorizontalPixelSize@value | 1/XResolution in millimeters if ResolutionUnit is not None.
/Dimension/VerticalPixelSize@value | 1/YResolution in millimeters if ResolutionUnit is not None.
/Dimension/HorizontalPosition@value | XPosition in millimeters if ResolutionUnit is not None.
/Dimension/VerticalPosition@value | YPosition in millimeters if ResolutionUnit is not None.
/Document/FormatVersion@value | 6.0
/Document/SubimageInterpretation@value | NewSubFileType: transparency => "TransparencyMask"; reduced-resolution => "ReducedResolution"; single page => "SinglePage".
/Document/ImageCreationTime@value | DateTime
/Text/TextEntry | DocumentName, ImageDescription, Make, Model, PageName, Software, Artist, HostComputer, InkNames, Copyright: /Text/TextEntry@keyword = field name, /Text/TextEntry@value = field value. Example: TIFF Software field => /Text/TextEntry@keyword = "Software", /Text/TextEntry@value = Name and version number of the software package(s) used to create the image.
/Transparency/Alpha@value | ExtraSamples: associated alpha => "premultiplied"; unassociated alpha => "nonpremultiplied".

Reading Exif Images

The TIFF reader may be used to read an uncompressed Exif image or the contents of the APP1 marker segment of a compressed Exif image.
Reading Uncompressed Exif Images
An uncompressed Exif image is a one- or two-page uncompressed TIFF image with a specific ordering of its IFD and image data content. Each pixel has three 8-bit samples with photometric interpretation RGB or YCbCr. The image stream must contain a single primary image and may contain a single thumbnail which if present must also be uncompressed. The usual ImageReader methods may be used to read the image data and metadata:

    ImageInputStream input;
    ImageReader tiffReader;
    ImageReadParam tiffReadParam;

    tiffReader.setInput(input);

    // Read primary image and IFD.
    BufferedImage image = tiffReader.read(0, tiffReadParam);
    IIOMetadata primaryIFD = tiffReader.getImageMetadata(0);

    // Read thumbnail if present.
    BufferedImage thumbnail = null;
    if (tiffReader.getNumImages(true) > 1) {
        thumbnail = tiffReader.read(1, tiffReadParam);
    }
Note that the Exif thumbnail is treated as a separate page in the TIFF stream and not as a thumbnail, i.e., tiffReader.hasThumbnails(0) will return false.
Reading Compressed Exif Images
A compressed Exif image is a 3-band ISO/IEC 10918-1 baseline DCT JPEG stream with an inserted APP1 marker segment. The parameters of the marker segment after the length are the 6-byte sequence {'E', 'x', 'i', 'f', 0x00, 0x00} followed by a complete TIFF stream. The embedded TIFF stream contains a primary IFD describing the JPEG image optionally followed by a thumbnail IFD and compressed or uncompressed thumbnail image data. Note that the embedded TIFF stream does not contain any image data associated with the primary IFD nor any descriptive fields which duplicate information found in the JPEG stream itself.

The parameter content of the APP1 marker segment may be obtained from the user object of the associated Node in a javax_imageio_jpeg_image_1.0 native image metadata tree extracted from the image metadata object returned by the JPEG reader. This APP1 Exif node will be a child of the node named "markerSequence" and will have name unknown and an attribute named MarkerTag with integral value 0xE1 (String value "225"). The user object of this node will be a byte array which starts with the six bytes {'E', 'x', 'i', 'f', '0', '0'}. The primary IFD and the thumbnail IFD and image may be read from the user object by the usual ImageReader methods:

    ImageReader jpegReader;
    ImageReader tiffReader;

    // Obtain the APP1 Exif marker data from the JPEG image metadata.
    IIOMetadata jpegImageMetadata = jpegReader.getImageMetadata(0);
    String nativeFormat = jpegImageMetadata.getNativeMetadataFormatName();
    Node jpegImageMetadataTree = jpegImageMetadata.getAsTree(nativeFormat);

    // getExifMarkerData() returns the byte array which is the user object
    // of the APP1 Exif marker node.
    byte[] app1Params = getExifMarkerData(jpegImageMetadataTree);
    if (app1Params == null) {
        throw new IIOException("APP1 Exif marker not found.");
    }

    // Set up input, skipping Exif ID 6-byte sequence.
    MemoryCacheImageInputStream app1ExifInput
        = new MemoryCacheImageInputStream
            (new ByteArrayInputStream(app1Params, 6, app1Params.length - 6));
    tiffReader.setInput(app1ExifInput);

    // Read primary IFD.
    IIOMetadata primaryIFD = tiffReader.getImageMetadata(0);

    // Read thumbnail if present.
    BufferedImage thumbnail = null;
    if (tiffReader.getNumImages(true) > 1) {
        thumbnail = tiffReader.read(1, tiffReadParam);
    }

    // Read the primary image.
    BufferedImage image = jpegReader.read(0);
Note that tiffReader.getNumImages(true) returns the number of IFDs in the embedded TIFF stream including those corresponding to empty images. Calling tiffReader.read(0, readParam) will throw an exception as the primary image in the embedded TIFF stream is always empty; the primary image should be obtained using the JPEG reader itself.

Writing Images

TIFF images are written by a ImageWriter which may be controlled by its public interface as well as via a supplied ImageWriteParam. For an ImageWriteParam returned by the getDefaultWriteParam() method of the TIFF ImageWriter, the canWriteTiles() and canWriteCompressed() methods will return true; the canOffsetTiles() and canWriteProgressive() methods will return false.

The TIFF writer supports many optional capabilities including writing tiled images, inserting images, writing or inserting empty images, and replacing image data. Pixels may be replaced in either empty or non-empty images but if and only if the data are not compressed.

If tiles are being written, then each of their dimensions will be rounded to the nearest multiple of 16 per the TIFF specification. If JPEG-in-TIFF compression is being used, and tiles are being written each tile dimension will be rounded to the nearest multiple of 8 times the JPEG minimum coded unit (MCU) in that dimension. If JPEG-in-TIFF compression is being used and strips are being written, the number of rows per strip is rounded to a multiple of 8 times the maximum MCU over both dimensions.

Compression

The compression type may be set via the setCompressionType() method of the ImageWriteParam after setting the compression mode to MODE_EXPLICIT. The set of innately supported compression types is listed in the following table:
Supported Compression Types
Compression Type | 描述 | Reference
CCITT RLE | Modified Huffman compression | TIFF 6.0 Specification, Section 10
CCITT T.4 | CCITT T.4 bilevel encoding/Group 3 facsimile compression | TIFF 6.0 Specification, Section 11
CCITT T.6 | CCITT T.6 bilevel encoding/Group 4 facsimile compression | TIFF 6.0 Specification, Section 11
LZW | LZW compression | TIFF 6.0 Specification, Section 13
JPEG | "New" JPEG-in-TIFF compression | TIFF Technical Note #2
ZLib | "Deflate/Inflate" compression (see note following this table) | Adobe Photoshop® TIFF Technical Notes (PDF)
PackBits | Byte-oriented, run length compression | TIFF 6.0 Specification, Section 9
Deflate | "Zip-in-TIFF" compression (see note following this table) | ZLIB Compressed Data Format Specification, DEFLATE Compressed Data Format Specification
Exif JPEG | Exif-specific JPEG compression (see note following this table) | Exif 2.2 Specification (PDF), section 4.5.5, "Basic Structure of Thumbnail Data"

Old-style JPEG compression as described in section 22 of the TIFF 6.0 Specification is not supported.

The CCITT compression types are applicable to bilevel (1-bit) images only. The JPEG compression type is applicable to byte grayscale (1-band) and RGB (3-band) images only.

ZLib and Deflate compression are identical except for the value of the TIFF Compression field: for ZLib the Compression field has value 8 whereas for Deflate it has value 32946 (0x80b2). In both cases each image segment (strip or tile) is written as a single complete zlib data stream.

"Exif JPEG" is a compression type used when writing the contents of an APP1 Exif marker segment for inclusion in a JPEG native image metadata tree. The contents appended to the output when this compression type is used are a function of whether an empty or non-empty image is written. If the image is empty, then a TIFF IFD adhering to the specification of a compressed Exif primary IFD is appended. If the image is non-empty, then a complete IFD and image adhering to the specification of a compressed Exif thumbnail IFD and image are appended. Note that the data of the empty image may not later be appended using the pixel replacement capability of the TIFF writer.

If ZLib/Deflate or JPEG compression is used, the compression quality may be set. For ZLib/Deflate the supplied floating point quality value is rescaled to the range [1, 9] and truncated to an integer to derive the Deflate compression level. For JPEG the floating point quality value is passed directly to the JPEG writer plug-in which interprets it in the usual way.

Color Conversion

If the source image data color space type is RGB, and the destination photometric type is CIE L*a*b* or YCbCr, then the source image data will be automatically converted from RGB using an internal color converter.

ICC Profiles

An ICC Profile field will be written if either:
  • one is present in the native image metadata IIOMetadata instance supplied to the writer, or
  • the ColorSpace of the destination ImageTypeSpecifier is an instance of ICC_ColorSpace which is not one of the standard color spaces defined by the CS_* constants in the ColorSpace class. The destination type is set via ImageWriteParam.setDestinationType(ImageTypeSpecifier) and defaults to the ImageTypeSpecifier of the image being written.

Metadata Issues

Some behavior of the writer is affected by or may affect the contents of the image metadata which may be supplied by the user.

For bilevel images, the FillOrder, and T4Options fields affect the output data. The data will be filled right-to-left if FillOrder is present with a value of 2 (BaselineTIFFTagSet.FILL_ORDER_RIGHT_TO_LEFT) and will be filled left-to-right otherwise. The value of T4Options specifies whether the data should be 1D- or 2D-encoded and whether EOL padding should be used.

For all images the value of the RowsPerStrip field is used to the set the number of rows per strip if the image is not tiled. The default number of rows per strip is either 8 or the number of rows which would fill no more than 8 kilobytes, whichever is larger.

For all images the tile dimensions may be set using the TileWidth and TileLength field values if the tiling mode is ImageWriteParam.MODE_COPY_FROM_METADATA. If this mode is set but the fields are not, their respective default values are the image width and height.

When using JPEG-in-TIFF compression, a JPEGTables field will be written to the IFD and abbreviated JPEG streams to each strip or tile if and only if a JPEGTables field is contained in the metadata object provided to the writer. If the contents of the JPEGTables field is a valid tables-only JPEG stream, then it will be used; otherwise the contents of the field will be replaced with default visually lossless tables. If no such JPEGTables field is present in the metadata, then no JPEGTables field will be written to the output and each strip or tile will be written as a separate, self-contained JPEG stream.

When using Deflate/ZLib or LZW compression, if the image has 8 bits per sample, a horizontal differencing predictor will be used if the Predictor field is present with a value of 2 (BaselineTIFFTagSet.PREDICTOR_HORIZONTAL_DIFFERENCING). If prediction is so requested but the image does not have 8 bits per sample the field will be reset to have the value 1 (BaselineTIFFTagSet.PREDICTOR_NONE).

Some fields may be added or modified:

  • PhotometricInterpretation if not present.
  • PlanarConfiguration if this field is present with value Planar is is reset to Chunky.
  • Compression always.
  • BitsPerSample if the image is not bilevel.
  • SamplesPerPixel always.
  • ExtraSamples if an alpha channel is present.
  • SampleFormat if not present and the data are 16- or 32-bit integers or floating point.
  • ColorMap if the PhotometricInterpretation is RGBPalette.
  • ImageWidth and ImageLength always.
  • TileWidth, TileLength, TileOffsets, and TileByteCounts if a tiled image is being written.
  • RowsPerStrip, StripOffsets, and StripByteCounts if a tiled image is not being written.
  • XResolution, YResolution, and ResolutionUnit if none of these is present.
  • YCbCrSubsampling and YCbCrPositioning if the photometric interpretation is YCbCr and the compression type is not JPEG (only [1, 1] subsampling and cosited positioning are supported for non-JPEG YCbCr output).
  • YCbCrSubsampling, YCbCrPositioning, and ReferenceBlackWhite: if the compression type is JPEG and the color space is RGB these will be reset to [2, 2] centered subsampling with no headroom/footroom (0:255,128:255,128:255).

Some fields may be removed:

  • BitsPerSample if the image is bilevel.
  • ExtraSamples if the image does not have an alpha channel.
  • ColorMap if the photometric interpretation is not RGBPalette.
  • TileWidth, TileLength, TileOffsets, and TileByteCounts if tiling is not being used.
  • RowsPerStrip, StripOffsets, and StripByteCounts if tiling is being used.
  • YCbCrSubsampling, YCbCrPositioning, and ReferenceBlackWhite if the compression type is JPEG and the color space is grayscale.
  • JPEGProc, JPEGInterchangeFormat, JPEGInterchangeFormatLength, JPEGRestartInterval, JPEGLosslessPredictors, JPEGPointTransforms, JPEGQTables, JPEGDCTables, and JPEGACTables if the compression type is JPEG.

Other fields present in the supplied metadata are uninterpreted and will be written as supplied.

If an Exif image is being written, the set of fields present and their values will be modified such that the result is in accord with the Exif 2.2 specification.

Setting up the image metadata to write to a TIFF stream may be simplified by using the TIFFDirectory class which represents a TIFF IFD. A field in a TIFF IFD is represented by an instance of TIFFField. For each field to be written a TIFFField may be added to the TIFFDirectory and the latter converted to an IIOMetadata object by invoking TIFFDirectory.getAsMetadata. The IIOMetadata object so obtained may then be passed to the TIFF writer.

Mapping of the Standard Metadata Format to TIFF Native Image Metadata
The derivation of TIFF native image metadata elements from the standard metadata format javax_imageio_1.0 is given in the following table.

TIFF Field | Derivation from Standard Metadata Elements
PhotometricInterpretation | /Chroma/ColorSpaceType@name: "GRAY" and /Chroma/BlackIsZero@value = "FALSE" => WhiteIsZero; "GRAY" and /Document/SubimageInterpretation@value = "TransparencyMask" => TransparencyMask; "RGB" and /Chroma/Palette present => PaletteColor; "GRAY" => BlackIsZero; "RGB" => RGB; "YCbCr" => YCbCr; "CMYK" => CMYK; "Lab" => CIELab.
SamplesPerPixel | /Chroma/NumChannels@value
ColorMap | /Chroma/Palette
Compression | /Compression/CompressionTypeName@value: "none" => Uncompressed; "CCITT RLE" => CCITT 1D; "CCITT T.4" => Group 3 Fax; "CCITT T.6" => Group 4 Fax; "LZW" => LZW; "Old JPEG" => JPEG; "JPEG" => New JPEG; "ZLib" => ZLib; "PackBits" => PackBits; "Deflate" => Deflate.
PlanarConfiguration | /Data/PlanarConfiguration@value: "PixelInterleaved" => Chunky; "PlaneInterleaved" => Planar.
SampleFormat | /Data/SampleFormat@value: "SignedIntegral" => two's complement signed integer data; "UnsignedIntegral" => unsigned integer data; "Real" => IEEE floating point data; "Index" => unsigned integer data.
BitsPerSample | /Data/BitsPerSample@value: space-separated list parsed to char array.
FillOrder | /Data/SampleMSB@value: if all values in space-separated list are 0s => right-to-left; otherwise => left-to-right.
XResolution | (10 / /Dimension/HorizontalPixelSize@value) or (10 / (/Dimension/VerticalPixelSize@value * /Dimension/PixelAspectRatio@value))
YResolution | (10 / /Dimension/VerticalPixelSize@value) or (10 / (/Dimension/HorizontalPixelSize@value / /Dimension/PixelAspectRatio@value))
ResolutionUnit | Centimeter if XResolution or YResolution set; otherwise None.
Orientation | /Dimension/ImageOrientation@value
XPosition | /Dimension/HorizontalPosition@value / 10
YPosition | /Dimension/VerticalPosition@value / 10
NewSubFileType | /Document/SubimageInterpretation@value: "TransparencyMask" => transparency mask; "ReducedResolution" => reduced-resolution; "SinglePage" => single page.
DateTime | /Document/ImageCreationTime@value
DocumentName, ImageDescription, Make, Model, PageName, Software, Artist, HostComputer, InkNames, Copyright | /Text/TextEntry: if /Text/TextEntry@keyword is the name of any of the TIFF Fields, e.g., "Software", then the field is added with content /Text/TextEntry@value and count 1.
ExtraSamples | /Transparency/Alpha@value: "premultiplied" => associated alpha, count 1; "nonpremultiplied" => unassociated alpha, count 1.

Writing Exif Images

The TIFF writer may be used to write an uncompressed Exif image or the contents of the APP1 marker segment of a compressed Exif image.
Writing Uncompressed Exif Images
When writing a sequence of images each image is normally recorded as {IFD, IFD Value, Image Data}. The Exif specification requires that an uncompressed Exif image be structured as follows:
  1. Image File Header
  2. Primary IFD
  3. Primary IFD Value
  4. Thumbnail IFD
  5. Thumbnail IFD Value
  6. Thumbnail Image Data
  7. Primary Image Data
To meet the requirement of the primary image data being recorded last, the primary image must be written initially as an empty image and have its data added via pixel replacement after the thumbnail IFD and image data have been written:

    ImageWriter tiffWriter;
    ImageWriteParam tiffWriteParam;
    IIOMetadata tiffStreamMetadata;
    IIOMetadata primaryIFD;
    BufferedImage image;
    BufferedImage thumbnail;

    // Specify uncompressed output.
    tiffWriteParam.setCompressionMode(ImageWriteParam.MODE_DISABLED);

    if (thumbnail != null) {
        // Write the TIFF header.
        tiffWriter.prepareWriteSequence(tiffStreamMetadata);

        // Append the primary IFD.
        tiffWriter.prepareInsertEmpty(-1, // append
                new ImageTypeSpecifier(image),
                image.getWidth(),
                image.getHeight(),
                primaryIFD,
                null, // thumbnails
                tiffWriteParam);
        tiffWriter.endInsertEmpty();

        // Append the thumbnail image data.
        tiffWriter.writeToSequence(new IIOImage(thumbnail, null, null),
                tiffWriteParam);

        // Insert the primary image data.
        tiffWriter.prepareReplacePixels(0, new Rectangle(image.getWidth(),
                image.getHeight()));
        tiffWriter.replacePixels(image, tiffWriteParam);
        tiffWriter.endReplacePixels();

        // End writing.
        tiffWriter.endWriteSequence();
    } else {
        // Write only the primary IFD and image data.
        tiffWriter.write(tiffStreamMetadata,
                new IIOImage(image, null, primaryIFD),
                tiffWriteParam);
    }
Writing Compressed Exif Images
The structure of the embedded TIFF stream in the APP1 segment of a compressed Exif image is identical to the uncompressed Exif image structure except that there are no primary image data, i.e., the primary IFD does not refer to any image data.

    ImageWriter tiffWriter;
    ImageWriteParam tiffWriteParam;
    IIOMetadata tiffStreamMetadata;
    BufferedImage image;
    BufferedImage thumbnail;
    IIOMetadata primaryIFD;
    ImageOutputStream output;

    // Set up an output to contain the APP1 Exif TIFF stream.
    ByteArrayOutputStream baos = new ByteArrayOutputStream();
    MemoryCacheImageOutputStream app1ExifOutput =
        new MemoryCacheImageOutputStream(baos);
    tiffWriter.setOutput(app1ExifOutput);

    // Set compression for the thumbnail.
    tiffWriteParam.setCompressionMode(ImageWriteParam.MODE_EXPLICIT);
    tiffWriteParam.setCompressionType("Exif JPEG");

    // Write the APP1 Exif TIFF stream.
    if (thumbnail != null) {
        // Write the TIFF header.
        tiffWriter.prepareWriteSequence(tiffStreamMetadata);

        // Append the primary IFD.
        tiffWriter.prepareInsertEmpty(-1, // append
                new ImageTypeSpecifier(image),
                image.getWidth(),
                image.getHeight(),
                primaryIFD,
                null, // thumbnails
                tiffWriteParam);
        tiffWriter.endInsertEmpty();

        // Append the thumbnail IFD and image data.
        tiffWriter.writeToSequence(new IIOImage(thumbnail, null,
                null), tiffWriteParam);

        // End writing.
        tiffWriter.endWriteSequence();
    } else {
        // Write only the primary IFD.
        tiffWriter.prepareWriteEmpty(tiffStreamMetadata,
                new ImageTypeSpecifier(image),
                image.getWidth(),
                image.getHeight(),
                primaryIFD,
                null, // thumbnails
                tiffWriteParam);
        tiffWriter.endWriteEmpty();
    }

    // Flush data into byte stream.
    app1ExifOutput.flush();

    // Create APP1 parameter array.
    byte[] app1Parameters = new byte[6 + baos.size()];

    // Add APP1 Exif ID bytes.
    app1Parameters[0] = (byte) 'E';
    app1Parameters[1] = (byte) 'x';
    app1Parameters[2] = (byte) 'i';
    app1Parameters[3] = (byte) 'f';
    app1Parameters[4] = app1Parameters[5] = (byte) 0;

    // Append TIFF stream to APP1 parameters.
    System.arraycopy(baos.toByteArray(), 0, app1Parameters, 6, baos.size());

    // Create the APP1 Exif node to be added to native JPEG image metadata.
    IIOMetadataNode app1Node = new IIOMetadataNode("unknown");
    app1Node.setAttribute("MarkerTag", String.valueOf(0xE1));
    app1Node.setUserObject(app1Parameters);

    // Append the APP1 Exif marker to the "markerSequence" node.
    IIOMetadata jpegImageMetadata =
        jpegWriter.getDefaultImageMetadata(new ImageTypeSpecifier(image),
            jpegWriteParam);
    String nativeFormat = jpegImageMetadata.getNativeMetadataFormatName();
    Node tree = jpegImageMetadata.getAsTree(nativeFormat);
    NodeList children = tree.getChildNodes();
    int numChildren = children.getLength();
    for (int i = 0; i < numChildren; i++) {
        Node child = children.item(i);
        if (child.getNodeName().equals("markerSequence")) {
            child.appendChild(app1Node);
            break;
        }
    }
    jpegImageMetadata.setFromTree(nativeFormat, tree);

    // Write the JPEG image data including the APP1 Exif marker.
    jpegWriter.setOutput(output);
    jpegWriter.write(new IIOImage(image, null, jpegImageMetadata));
The "unknown" node created above would be appended to the "markerSequence" node of the native JPEG image metadata and written to the JPEG stream when the primary image is written using the JPEG writer.

Stream Metadata

The DTD for the TIFF native stream metadata format is as follows:
<!DOCTYPE "javax_imageio_tiff_stream_1.0" [

  <!ELEMENT "javax_imageio_tiff_stream_1.0" (ByteOrder)>

    <!ELEMENT "ByteOrder" EMPTY>
      <!-- The stream byte order -->
      <!ATTLIST "ByteOrder" "value" #CDATA #REQUIRED>
        <!-- One of "BIG_ENDIAN" or "LITTLE_ENDIAN" -->
        <!-- Data type: String -->
]>

Image Metadata

The DTD for the TIFF native image metadata format is as follows:
<!DOCTYPE "javax_imageio_tiff_image_1.0" [

  <!ELEMENT "javax_imageio_tiff_image_1.0" (TIFFIFD)*>

    <!ELEMENT "TIFFIFD" (TIFFField | TIFFIFD)*>
      <!-- An IFD (directory) containing fields -->
      <!ATTLIST "TIFFIFD" "tagSets" #CDATA #REQUIRED>
        <!-- Data type: String -->
      <!ATTLIST "TIFFIFD" "parentTagNumber" #CDATA #IMPLIED>
        <!-- The tag number of the field pointing to this IFD -->
        <!-- Data type: Integer -->
      <!ATTLIST "TIFFIFD" "parentTagName" #CDATA #IMPLIED>
        <!-- A mnemonic name for the field pointing to this IFD, if known
             -->
        <!-- Data type: String -->

      <!ELEMENT "TIFFField" (TIFFBytes | TIFFAsciis |
        TIFFShorts | TIFFSShorts | TIFFLongs | TIFFSLongs |
        TIFFRationals | TIFFSRationals |
        TIFFFloats | TIFFDoubles | TIFFUndefined)>
        <!-- A field containing data -->
        <!ATTLIST "TIFFField" "number" #CDATA #REQUIRED>
          <!-- The tag number asociated with the field -->
          <!-- Data type: String -->
        <!ATTLIST "TIFFField" "name" #CDATA #IMPLIED>
          <!-- A mnemonic name associated with the field, if known -->
          <!-- Data type: String -->

        <!ELEMENT "TIFFBytes" (TIFFByte)*>
          <!-- A sequence of TIFFByte nodes -->

          <!ELEMENT "TIFFByte" EMPTY>
            <!-- An integral value between 0 and 255 -->
            <!ATTLIST "TIFFByte" "value" #CDATA #IMPLIED>
              <!-- The value -->
              <!-- Data type: String -->
            <!ATTLIST "TIFFByte" "description" #CDATA #IMPLIED>
              <!-- A description, if available -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFAsciis" (TIFFAscii)*>
          <!-- A sequence of TIFFAscii nodes -->

          <!ELEMENT "TIFFAscii" EMPTY>
            <!-- A String value -->
            <!ATTLIST "TIFFAscii" "value" #CDATA #IMPLIED>
              <!-- The value -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFShorts" (TIFFShort)*>
          <!-- A sequence of TIFFShort nodes -->

          <!ELEMENT "TIFFShort" EMPTY>
            <!-- An integral value between 0 and 65535 -->
            <!ATTLIST "TIFFShort" "value" #CDATA #IMPLIED>
              <!-- The value -->
              <!-- Data type: String -->
            <!ATTLIST "TIFFShort" "description" #CDATA #IMPLIED>
              <!-- A description, if available -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFSShorts" (TIFFSShort)*>
          <!-- A sequence of TIFFSShort nodes -->

          <!ELEMENT "TIFFSShort" EMPTY>
            <!-- An integral value between -32768 and 32767 -->
            <!ATTLIST "TIFFSShort" "value" #CDATA #IMPLIED>
              <!-- The value -->
              <!-- Data type: String -->
            <!ATTLIST "TIFFSShort" "description" #CDATA #IMPLIED>
              <!-- A description, if available -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFLongs" (TIFFLong)*>
          <!-- A sequence of TIFFLong nodes -->

          <!ELEMENT "TIFFLong" EMPTY>
            <!-- An integral value between 0 and 4294967295 -->
            <!ATTLIST "TIFFLong" "value" #CDATA #IMPLIED>
              <!-- The value -->
              <!-- Data type: String -->
            <!ATTLIST "TIFFLong" "description" #CDATA #IMPLIED>
              <!-- A description, if available -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFSLongs" (TIFFSLong)*>
          <!-- A sequence of TIFFSLong nodes -->

          <!ELEMENT "TIFFSLong" EMPTY>
            <!-- An integral value between -2147483648 and 2147482647 -->
            <!ATTLIST "TIFFSLong" "value" #CDATA #IMPLIED>
              <!-- The value -->
              <!-- Data type: String -->
            <!ATTLIST "TIFFSLong" "description" #CDATA #IMPLIED>
              <!-- A description, if available -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFRationals" (TIFFRational)*>
          <!-- A sequence of TIFFRational nodes -->

          <!ELEMENT "TIFFRational" EMPTY>
            <!-- A rational value consisting of an unsigned numerator and
                 denominator -->
            <!ATTLIST "TIFFRational" "value" #CDATA #IMPLIED>
              <!-- The numerator and denominator, separated by a slash -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFSRationals" (TIFFSRational)*>
          <!-- A sequence of TIFFSRational nodes -->

          <!ELEMENT "TIFFSRational" EMPTY>
            <!-- A rational value consisting of a signed numerator and
                 denominator -->
            <!ATTLIST "TIFFSRational" "value" #CDATA #IMPLIED>
              <!-- The numerator and denominator, separated by a slash -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFFloats" (TIFFFloat)*>
          <!-- A sequence of TIFFFloat nodes -->

          <!ELEMENT "TIFFFloat" EMPTY>
            <!-- A single-precision floating-point value -->
            <!ATTLIST "TIFFFloat" "value" #CDATA #IMPLIED>
              <!-- The value -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFDoubles" (TIFFDouble)*>
          <!-- A sequence of TIFFDouble nodes -->

          <!ELEMENT "TIFFDouble" EMPTY>
            <!-- A double-precision floating-point value -->
            <!ATTLIST "TIFFDouble" "value" #CDATA #IMPLIED>
              <!-- The value -->
              <!-- Data type: String -->

        <!ELEMENT "TIFFUndefined" EMPTY>
          <!-- Uninterpreted byte data -->
          <!ATTLIST "TIFFUndefined" "value" #CDATA #IMPLIED>
            <!-- A list of comma-separated byte values -->
            <!-- Data type: String -->
]>
@since 9


WBMP Metadata Format Specification

The XML schema for the native image metadata format is as follows:
<?xml version="1.0" encoding="UTF-8"?>
<!-- Schema for WBMP native image metadata format. -->

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            xmlns="http://javax.imageio.plugins"
            targetNamespace="http://javax.imageio.plugins">

  <!-- WBMP Schema 1.0 root element. -->
  <xsd:element name="javax_imageio_wbmp_1.0">
    <xsd:sequence>

      <!-- WBMP image type -->
      <xsd:element name="WBMPType" type="xsd:unsignedInt"/>

      <!-- Bitmap width -->
      <xsd:element name="Width" type="xsd:unsignedInt"/>

      <!-- Bitmap height -->
      <xsd:element name="Height" type="xsd:unsignedInt"/>

     </xsd:sequence>
  </xsd:element> <!-- wbmp_image_1.0 -->

</xsd:schema>
@since 1.5


BMPImageWriteParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.bmp

Class BMPImageWriteParam

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageWriteParam
        • javax.imageio.plugins.bmp.BMPImageWriteParam

  • public class BMPImageWriteParam
extends ImageWriteParam
    用于编码BMP格式的图像的ImageWriteParam的子类。

    该类允许在编写BMP格式的图像文件时规定各种参数。 默认情况下，数据布局是自下而上的，像素以自下而上的顺序存储，第一条扫描线最后存储。

    可以使用具有相应类型字符串的setCompressionType()方法来指定要使用的特定压缩方案。 当且仅当与要写入的图像类型兼容时，才能使用指定的压缩方案。 如果指定的压缩方案与正在写入的图像类型不兼容，那么BMP图像编写IOException将抛出IOException 。 如果压缩类型未明确设置，那么getCompressionType()将返回null 。 在这种情况下，BMP图像编写器将选择支持给定图像编码的压缩类型，而不会损失颜色分辨率。

    压缩类型字符串和每种支持的图像类型列在下表中：

    Compression Types Type String Description Image Types BI_RGB Uncompressed RLE <= 8-bits/sample BI_RLE8 8-bit Run Length Encoding <= 8-bits/sample BI_RLE4 4-bit Run Length Encoding <= 4-bits/sample BI_BITFIELDS Packed data 16 or 32 bits/sample

    • Field Summary

      • Fields inherited from class javax.imageio.IIOParam

        controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset

      • Fields inherited from class javax.imageio.ImageWriteParam

        canOffsetTiles, canWriteCompressed, canWriteProgressive, canWriteTiles, compressionMode, compressionQuality, compressionType, compressionTypes, locale, MODE_COPY_FROM_METADATA, MODE_DEFAULT, MODE_DISABLED, MODE_EXPLICIT, preferredTileSizes, progressiveMode, tileGridXOffset, tileGridYOffset, tileHeight, tileWidth, tilingMode, tilingSet

    • 构造方法摘要

      构造方法
      Constructor 描述
      BMPImageWriteParam​()
      构造一个 BMPImageWriteParam对象，其所有参数的默认值为 null Locale 。
      BMPImageWriteParam​(Locale locale)
      构造一个 BMPImageWriteParam集，以使用给定的 Locale和所有参数的默认值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean isTopDown​()
      返回 topDown参数的值。
      void setTopDown​(boolean topDown)
      如果设置，数据将以自上而下的方式写出，第一条扫描线首先写入。

      • Methods inherited from class javax.imageio.IIOParam

        activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setDestinationType, setSourceBands, setSourceRegion, setSourceSubsampling

      • Methods inherited from class javax.imageio.ImageWriteParam

        canOffsetTiles, canWriteCompressed, canWriteProgressive, canWriteTiles, getBitRate, getCompressionMode, getCompressionQuality, getCompressionQualityDescriptions, getCompressionQualityValues, getCompressionType, getCompressionTypes, getLocale, getLocalizedCompressionTypeName, getPreferredTileSizes, getProgressiveMode, getTileGridXOffset, getTileGridYOffset, getTileHeight, getTileWidth, getTilingMode, isCompressionLossless, setCompressionMode, setCompressionQuality, setCompressionType, setProgressiveMode, setTiling, setTilingMode, unsetCompression, unsetTiling

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BMPImageWriteParam

        public BMPImageWriteParam​(Locale locale)
        构造一个 BMPImageWriteParam集，以使用给定的 Locale和所有参数的默认值。
        参数
        locale -一个 Locale使用本地化压缩类型名称和质量描述，或 null 。

      • BMPImageWriteParam

        public BMPImageWriteParam​()
        构造一个 BMPImageWriteParam对象，其中所有参数的默认值为 null Locale 。

    • 方法详细信息

      • setTopDown

        public void setTopDown​(boolean topDown)
        如果设置，数据将以自上而下的方式写出，第一条扫描线首先写入。
        参数
        topDown - 数据是否以自上而下的顺序写入。

      • isTopDown

        public boolean isTopDown​()
        返回topDown参数的值。 默认值为false 。
        结果
        数据是否以自上而下的顺序写入。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.imageio.plugins.bmp (Java SE 9 & JDK 9 )

javax.imageio.plugins.bmp

Classes

  • BMPImageWriteParam


javax.imageio.plugins.bmp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package javax.imageio.plugins.bmp

包含内置BMP插件使用的公共类的软件包。
从以下版本开始：
1.5
  • 类摘要
    Class 描述
    BMPImageWriteParam
    用于编码BMP格式的图像的 ImageWriteParam的子类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.imageio.plugins.bmp Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.imageio.plugins.bmp

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageWriteParam
        • javax.imageio.plugins.bmp.BMPImageWriteParam
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Package javax.imageio.plugins.bmp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.imageio.plugins.bmp

No usage of javax.imageio.plugins.bmp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.bmp.BMPImageWriteParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.bmp.BMPImageWriteParam

No usage of javax.imageio.plugins.bmp.BMPImageWriteParam
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


javax.imageio.plugins.jpeg (Java SE 9 & JDK 9 )

javax.imageio.plugins.jpeg

Classes

  • JPEGHuffmanTable
  • JPEGImageReadParam
  • JPEGImageWriteParam
  • JPEGQTable


javax.imageio.plugins.jpeg (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package javax.imageio.plugins.jpeg

支持内置JPEG插件的类。

此软件包包含一些内置JPEG读写器插件的支持类。 提供用于表示量化和霍夫曼表的类，并且在读取和写入过程中提供ImageReadParam和ImageWriteParam扩展以供应表。 有关内置JPEG插件的操作的详细信息，请参阅JPEG metadata format specification and usage notes 。

从以下版本开始：
1.4
  • 类摘要
    Class 描述
    JPEGHuffmanTable
    一个封装单个JPEG霍夫曼表的类。
    JPEGImageReadParam
    此类增加了在使用内置JPEG阅读器插件时设置JPEG量化和霍夫曼表的功能。
    JPEGImageWriteParam
    该类增加了在使用内置JPEG writer插件时设置JPEG量化和霍夫曼表的能力，并请求为图像计算优化的霍夫曼表。
    JPEGQTable
    一个封装单个JPEG量化表的类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.imageio.plugins.jpeg Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.imageio.plugins.jpeg

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
        • javax.imageio.plugins.jpeg.JPEGImageReadParam
      • javax.imageio.ImageWriteParam
        • javax.imageio.plugins.jpeg.JPEGImageWriteParam
    • javax.imageio.plugins.jpeg.JPEGHuffmanTable
    • javax.imageio.plugins.jpeg.JPEGQTable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


JPEGHuffmanTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.jpeg

Class JPEGHuffmanTable

  • java.lang.Object
    • javax.imageio.plugins.jpeg.JPEGHuffmanTable

  • public class JPEGHuffmanTable
extends Object
    一个封装单个JPEG霍夫曼表的类。 为从JPEG规范的附录K获取的“标准”表提供了字段。 这些是用作默认值的表。

    有关标准JPEG插件的操作的更多信息，请参阅JPEG metadata format specification and usage notes

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static JPEGHuffmanTable StdACChrominance
      标准AC色度霍夫曼表。
      static JPEGHuffmanTable StdACLuminance
      标准AC亮度霍夫曼表。
      static JPEGHuffmanTable StdDCChrominance
      标准直流色度霍夫曼表。
      static JPEGHuffmanTable StdDCLuminance
      标准直流亮度霍夫曼表。

    • 构造方法摘要

      构造方法
      Constructor 描述
      JPEGHuffmanTable​(short[] lengths, short[] values)
      创建一个霍夫曼表并进行初始化。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      short[] getLengths​()
      返回一个 short s的数组， short包含Huffman表中每个长度的值的数量。
      short[] getValues​()
      返回一个 short s的数组， short包含通过增加其相应代码的长度而排列的值。
      String toString​()
      返回代表这个霍夫曼表的 String 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • StdDCLuminance

        public static final JPEGHuffmanTable StdDCLuminance
        标准直流亮度霍夫曼表。

      • StdDCChrominance

        public static final JPEGHuffmanTable StdDCChrominance
        标准直流色度霍夫曼表。

      • StdACLuminance

        public static final JPEGHuffmanTable StdACLuminance
        标准AC亮度霍夫曼表。

      • StdACChrominance

        public static final JPEGHuffmanTable StdACChrominance
        标准AC色度霍夫曼表。

    • 构造方法详细信息

      • JPEGHuffmanTable

        public JPEGHuffmanTable​(short[] lengths,
                        short[] values)
        创建一个霍夫曼表并进行初始化。 复制输入数组。 阵列必须描述可能的霍夫曼表。 例如，3个代码不能用单个位表示。
        参数
        lengths -的阵列 short S其中 lengths[k]等于值的数目与对应长度的码 k + 1比特。
        values - 一个包含值增加代码长度的数组。
        异常
        IllegalArgumentException -如果 lengths或 values为空，长度 lengths大于16的长度， values是大于256，如果在任何值 lengths或 values小于零，或者如果阵列不描述有效的霍夫曼表。

    • 方法详细信息

      • getLengths

        public short[] getLengths​()
        返回一个short的数组， short包含霍夫曼表中每个长度的值的数量。 返回的数组是一个副本。
        结果
        一个 short阵列，其中 array[k-1]等于表 k的值的数量。
        另请参见：
        getValues()

      • getValues

        public short[] getValues​()
        返回一个short的数组， short包含通过增加相应代码的长度而排列的值。 数组的解释取决于从getLengths返回的值。 返回的数组是一个副本。
        结果
        一个 short数组的值。
        另请参见：
        getLengths()

      • toString

        public String toString​()
        返回代表这个霍夫曼表的 String 。
        重写：
        toString在 Object
        结果
        一个 String代表这个霍夫曼表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


JPEGImageReadParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.jpeg

Class JPEGImageReadParam

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
        • javax.imageio.plugins.jpeg.JPEGImageReadParam

  • public class JPEGImageReadParam
extends ImageReadParam
    此类增加了在使用内置JPEG阅读器插件时设置JPEG量化和霍夫曼表的功能。 该类的一个实例将从内置的JPEG ImageReader的getDefaultImageReadParam方法返回。

    这些添加的唯一目的是允许用于解码缩写流的表的规范。 内置的JPEG阅读器也可以接受普通的ImageReadParam ，这对于解码非缩写的流是足够的。

    虽然缩写流的表格通常是通过首先阅读另一个仅包含表格的缩略图流而获得的，但在某些应用程序中，表格提前固定。 该类允许从客户端代码直接指定表。 如果在流中或JPEGImageReadParam未指定任何表，则该流被推定为使用“标准”视觉无损表。 有关默认表的更多信息，请参阅JPEGQTable和JPEGHuffmanTable 。

    内置JPEG读取器的getDefaultReadParam方法返回的默认值JPEGImageReadParam不包含表。 默认表可以从表JPEGQTable和JPEGHuffmanTable等级获得。

    如果流包含表，则忽略JPEGImageReadParam中给出的表。 此外，如果流中的第一图像包含表，并且后续的图像不包含表，则在第一图像中给出的表用于所有缩写图像。 一旦从流中读取表，只能由随后从同一个流读取的表覆盖它们。 为了指定新表，必须调用读者的setInput方法来更改流。

    请注意，此类不提供获取流中找到的表的方法。 这些可以通过查阅读者返回的IIOMetadata对象从流中提取出来。

    有关内置JPEG插件的操作的详细信息，请参阅JPEG metadata format specification and usage notes 。

    • Field Summary

      • Fields inherited from class javax.imageio.IIOParam

        controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset

      • Fields inherited from class javax.imageio.ImageReadParam

        canSetSourceRenderSize, destination, destinationBands, minProgressivePass, numProgressivePasses, sourceRenderSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      JPEGImageReadParam​()
      构造一个 JPEGImageReadParam 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean areTablesSet​()
      如果表当前设置，则返回 true 。
      JPEGHuffmanTable[] getACHuffmanTables​()
      返回在最近调用 setDecodeTables或 null如果表当前未设置）时设置的AC Huffman表数组的副本。
      JPEGHuffmanTable[] getDCHuffmanTables​()
      返回最近调用 setDecodeTables设置的DC Huffman表数组的副本，如果表当前未设置，则 null 。
      JPEGQTable[] getQTables​()
      返回在最近调用的 setDecodeTables或 null如果表当前未设置）时设置的量化表数组的副本。
      void setDecodeTables​(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables)
      设置用于解码缩写流的量化和霍夫曼表。
      void unsetDecodeTables​()
      删除当前设置的任何量化和霍夫曼表。

      • Methods inherited from class javax.imageio.IIOParam

        activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setSourceBands, setSourceRegion, setSourceSubsampling

      • Methods inherited from class javax.imageio.ImageReadParam

        canSetSourceRenderSize, getDestination, getDestinationBands, getSourceMaxProgressivePass, getSourceMinProgressivePass, getSourceNumProgressivePasses, getSourceRenderSize, setDestination, setDestinationBands, setDestinationType, setSourceProgressivePasses, setSourceRenderSize

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JPEGImageReadParam

        public JPEGImageReadParam​()
        构造一个 JPEGImageReadParam 。

    • 方法详细信息

      • areTablesSet

        public boolean areTablesSet​()
        如果表当前设置，则返回 true 。
        结果
        true如果表存在。

      • setDecodeTables

        public void setDecodeTables​(JPEGQTable[] qTables,
                            JPEGHuffmanTable[] DCHuffmanTables,
                            JPEGHuffmanTable[] ACHuffmanTables)
        设置用于解码缩写流的量化和霍夫曼表。 每种类型最多可能有4个表。 一旦在流中遇到表，就忽略这些表。 所有参数必须为非null 。 霍夫曼表的两个阵列必须具有相同数量的元素。 流中的帧和扫描头中的表格符号被假定为等同于这些数组中的索引。 参数数组由此方法复制。
        参数
        qTables - 量化表对象的数组。
        DCHuffmanTables - 一个霍夫曼表对象的数组。
        ACHuffmanTables - 一个霍夫曼表对象的数组。
        异常
        IllegalArgumentException - 如果任何参数是 null ，有超过4个元素，或者DC和AC表的数量不同。
        另请参见：
        unsetDecodeTables()

      • unsetDecodeTables

        public void unsetDecodeTables​()
        删除当前设置的任何量化和霍夫曼表。
        另请参见：
        setDecodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

      • getQTables

        public JPEGQTable[] getQTables​()
        返回最近调用 setDecodeTables设置的量化表数组的副本，如果表当前未设置，则 null 。
        结果
        一组 JPEGQTable对象，或 null 。
        另请参见：
        setDecodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

      • getDCHuffmanTables

        public JPEGHuffmanTable[] getDCHuffmanTables​()
        返回在最近调用 setDecodeTables或 null如果表当前未设置）时设置的DC Huffman表阵列的副本。
        结果
        一组 JPEGHuffmanTable对象，或 null 。
        另请参见：
        setDecodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

      • getACHuffmanTables

        public JPEGHuffmanTable[] getACHuffmanTables​()
        返回最近调用 setDecodeTables或 null如果表当前未设置）时设置的AC Huffman表数组的副本。
        结果
        一组 JPEGHuffmanTable对象，或 null 。
        另请参见：
        setDecodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JPEGImageWriteParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.jpeg

Class JPEGImageWriteParam

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageWriteParam
        • javax.imageio.plugins.jpeg.JPEGImageWriteParam

  • public class JPEGImageWriteParam
extends ImageWriteParam
    该类增加了在使用内置JPEG writer插件时设置JPEG量化和霍夫曼表的能力，并请求为图像计算优化的霍夫曼表。 该类的一个实例将从内置的JPEG ImageWriter的getDefaultImageWriteParam方法中返回。

    这些添加的主要目的是允许表的规范用于编码缩写的流。 内置的JPEG作者也会接受普通的ImageWriteParam ，在这种情况下，作者将在内部构建必要的表格。

    在任一情况下， ImageWriteParam的质量设置与底层库具有相同的含义：1.00表示全部1的量化表，0.75表示“标准”，视觉无损量化表，0.00表示全部255的浓缩表。

    虽然缩写流的表格通常首先编写仅包含表格的缩写流来指定，但在某些应用程序中，表格提前固定。 该类允许从客户端代码直接指定表。

    通常，这些表在传递给写入程序的IIOMetadata对象中指定，并且这些对象中包含的任何表都将写入流中。 如果在元数据中没有指定表，则会写入一个缩写的流。 如果元数据中没有表，而在JPEGImageWriteParam没有指定表，则使用“标准”视觉无损表编码缩写流。 当必须写入缩写流，而不首先向流中写入任何表时，必须使用此类来指定表。 为了使用这个类，传递给写入程序的元数据对象不能包含任何表，也不能提供流元数据。 有关默认表的更多信息，请参阅JPEGQTable和JPEGHuffmanTable 。

    默认JPEGImageWriteParam由返回getDefaultWriteParam作家的方法不包含表。 默认表包含在作者返回的默认IIOMetadata对象中。

    如果元数据包含表，则忽略JPEGImageWriteParam中给出的表。 此外，一旦写入了一组表，只有元数据中的表可以覆盖它们以用于后续写入，无论是相同的流还是不同的。 为了使用这个类来指定新的表，必须调用writer的reset方法。

    有关内置JPEG插件的操作的详细信息，请参阅JPEG metadata format specification and usage notes 。

    • Field Summary

      • Fields inherited from class javax.imageio.IIOParam

        controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset

      • Fields inherited from class javax.imageio.ImageWriteParam

        canOffsetTiles, canWriteCompressed, canWriteProgressive, canWriteTiles, compressionMode, compressionQuality, compressionType, compressionTypes, locale, MODE_COPY_FROM_METADATA, MODE_DEFAULT, MODE_DISABLED, MODE_EXPLICIT, preferredTileSizes, progressiveMode, tileGridXOffset, tileGridYOffset, tileHeight, tileWidth, tilingMode, tilingSet

    • 构造方法摘要

      构造方法
      Constructor 描述
      JPEGImageWriteParam​(Locale locale)
      构造一个 JPEGImageWriteParam 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean areTablesSet​()
      如果表当前设置，则返回 true 。
      JPEGHuffmanTable[] getACHuffmanTables​()
      返回在最近调用 setEncodeTables或 null如果表当前未设置）时设置的AC Huffman表数组的副本。
      String[] getCompressionQualityDescriptions​()
      返回 String的数组，可以与 getCompressionQualityValues一起使用，作为设置或显示压缩质量等级的用户界面的一部分。
      float[] getCompressionQualityValues​()
      返回 float的数组，可以与 getCompressionQualityDescriptions一起使用，作为设置或显示压缩质量等级的用户界面的一部分。
      JPEGHuffmanTable[] getDCHuffmanTables​()
      返回在最近调用 setEncodeTables或 null如果表当前未设置）时设置的DC Huffman表数组的副本。
      boolean getOptimizeHuffmanTables​()
      返回传递到最近一次调用值 setOptimizeHuffmanTables ，或者 false如果 setOptimizeHuffmanTables从未被调用。
      JPEGQTable[] getQTables​()
      返回最近调用 setEncodeTables设置的量化表数组的副本，如果表当前未设置，则 null 。
      boolean isCompressionLossless​()
      返回 false因为JPEG插件仅支持有损压缩。
      void setEncodeTables​(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables)
      设置用于编码缩写流的量化和霍夫曼表。
      void setOptimizeHuffmanTables​(boolean optimize)
      告诉作者为写入过程的一部分，为图像生成优化的霍夫曼表。
      void unsetCompression​()
      删除任何以前的压缩质量设置。
      void unsetEncodeTables​()
      删除当前设置的任何量化和霍夫曼表。

      • Methods inherited from class javax.imageio.IIOParam

        activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setDestinationType, setSourceBands, setSourceRegion, setSourceSubsampling

      • Methods inherited from class javax.imageio.ImageWriteParam

        canOffsetTiles, canWriteCompressed, canWriteProgressive, canWriteTiles, getBitRate, getCompressionMode, getCompressionQuality, getCompressionType, getCompressionTypes, getLocale, getLocalizedCompressionTypeName, getPreferredTileSizes, getProgressiveMode, getTileGridXOffset, getTileGridYOffset, getTileHeight, getTileWidth, getTilingMode, setCompressionMode, setCompressionQuality, setCompressionType, setProgressiveMode, setTiling, setTilingMode, unsetTiling

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JPEGImageWriteParam

        public JPEGImageWriteParam​(Locale locale)
        构造一个JPEGImageWriteParam 。 不支持平铺。 支持逐行编码。 默认逐行模式为MODE_DISABLED。 支持单一形式的压缩，名为“JPEG”。 默认压缩质量为0.75。
        参数
        locale -一个 Locale由超类用于本地化压缩类型名称和质量描述，或 null 。

    • 方法详细信息

      • unsetCompression

        public void unsetCompression​()
        删除任何以前的压缩质量设置。

        默认实现将压缩质量重置为0.75F 。

        重写：
        unsetCompression在 ImageWriteParam
        异常
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。
        另请参见：
        ImageWriteParam.setCompressionType(java.lang.String) ， ImageWriteParam.setCompressionQuality(float)

      • isCompressionLossless

        public boolean isCompressionLossless​()
        返回 false因为JPEG插件仅支持有损压缩。
        重写：
        isCompressionLossless ImageWriteParam
        结果
        false 。
        异常
        IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT 。

      • getCompressionQualityDescriptions

        public String[] getCompressionQualityDescriptions​()
        描述从类别复制ImageWriteParam
        返回String的数组，可以与getCompressionQualityValues一起使用，作为设置或显示压缩质量等级的用户界面的一部分。 所述String具有索引i提供质量水平之间的范围内的描述getCompressionQualityValues[i]和getCompressionQualityValues[i + 1] 。 需要注意的是阵列的长度从返回getCompressionQualityValues将始终是一个大于从返回getCompressionQualityDescriptions 。

        作为一个例子，字符串“好”，“较好”和“最佳”可与范围相关[0, .33) ， [.33, .66) ，并[.66, 1.0] 。 在这种情况下， getCompressionQualityDescriptions将返回{ "Good", "Better", "Best" }而getCompressionQualityValues将返回{ 0.0F, .33F, .66F, 1.0F } 。

        如果没有可用的描述，则返回null 。 如果null从返回getCompressionQualityValues ，这种方法也必须返回null 。

        该说明应本地化为Locale由归国getLocale ，如果它是非null 。

        如果有多种压缩类型，但没有设置，则抛出一个IllegalStateException 。

        默认实现检查压缩是否受支持，压缩模式是否为MODE_EXPLICIT 。 如果是，如果getCompressionTypes()是null或getCompressionType()是非null ，它将返回null 。

        重写：
        getCompressionQualityDescriptions在 ImageWriteParam
        结果
        String的数组包含压缩质量等级的本地化描述。
        另请参见：
        ImageWriteParam.getCompressionQualityValues()

      • getCompressionQualityValues

        public float[] getCompressionQualityValues​()
        描述从类复制： ImageWriteParam
        返回float的数组，可以与getCompressionQualityDescriptions一起使用，作为设置或显示压缩质量级别的用户界面的一部分。 有关详细信息，请参阅getCompressionQualityDescriptions 。

        如果没有可用的描述，则返回null 。 如果null从返回getCompressionQualityDescriptions ，这种方法也必须返回null 。

        如果有多种压缩类型，但没有设置，则抛出一个IllegalStateException 。

        默认实现检查压缩是否受支持，而压缩模式是MODE_EXPLICIT 。 如果是，如果getCompressionTypes()是null或getCompressionType()是非null ，它返回null 。

        重写：
        getCompressionQualityValues在 ImageWriteParam
        结果
        float s的阵列表示 String s从 getCompressionQualityDescriptions描述的压缩质量水平之间的边界。
        另请参见：
        ImageWriteParam.getCompressionQualityDescriptions()

      • areTablesSet

        public boolean areTablesSet​()
        如果表当前设置，则返回 true 。
        结果
        true如果表存在。

      • setEncodeTables

        public void setEncodeTables​(JPEGQTable[] qTables,
                            JPEGHuffmanTable[] DCHuffmanTables,
                            JPEGHuffmanTable[] ACHuffmanTables)
        设置用于编码缩写流的量化和霍夫曼表。 每种类型最多可能有4个表。 如果在元数据中指定了表，则忽略这些表。 所有参数必须是非null 。 霍夫曼表的两个阵列必须具有相同数量的元素。 假设元数据中的帧和扫描头中的表格符号等同于这些数组中的索引。 参数数组由此方法复制。
        参数
        qTables - 量化表对象数组。
        DCHuffmanTables - 一组霍夫曼表对象。
        ACHuffmanTables - 一组霍夫曼表对象。
        异常
        IllegalArgumentException - 如果任何参数是 null或有多于4个元素，或者DC和AC表的数量不同。
        另请参见：
        unsetEncodeTables()

      • unsetEncodeTables

        public void unsetEncodeTables​()
        删除当前设置的任何量化和霍夫曼表。
        另请参见：
        setEncodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

      • getQTables

        public JPEGQTable[] getQTables​()
        返回最近调用 setEncodeTables或 null如果表当前未设置）设置的量化表数组的副本。
        结果
        一组 JPEGQTable对象，或 null 。
        另请参见：
        setEncodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

      • getDCHuffmanTables

        public JPEGHuffmanTable[] getDCHuffmanTables​()
        返回在最近调用 setEncodeTables或 null如果表当前未设置）时设置的DC Huffman表数组的副本。
        结果
        一组 JPEGHuffmanTable对象，或 null 。
        另请参见：
        setEncodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

      • getACHuffmanTables

        public JPEGHuffmanTable[] getACHuffmanTables​()
        返回最近调用 setEncodeTables或 null如果表当前未设置）时设置的AC霍夫曼表数组的副本。
        结果
        一个 JPEGHuffmanTable对象的数组，或 null 。
        另请参见：
        setEncodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

      • setOptimizeHuffmanTables

        public void setOptimizeHuffmanTables​(boolean optimize)
        告诉作者为写入过程的一部分，为图像生成优化的霍夫曼表。 默认值为false 。 如果此标志设置为true ，它将覆盖元数据中指定的任何表。 请注意，这意味着使用此标志设置为true任何图像将始终包含霍夫曼表。
        参数
        optimize - 一个布尔值，表示写入时是否生成优化的霍夫曼表。
        另请参见：
        getOptimizeHuffmanTables()

      • getOptimizeHuffmanTables

        public boolean getOptimizeHuffmanTables​()
        返回传递到最近一次调用值 setOptimizeHuffmanTables ，或者 false如果 setOptimizeHuffmanTables从未被调用。
        结果
        true如果作者将生成优化的霍夫曼表。
        另请参见：
        setOptimizeHuffmanTables(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JPEGQTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.jpeg

Class JPEGQTable

  • java.lang.Object
    • javax.imageio.plugins.jpeg.JPEGQTable

  • public class JPEGQTable
extends Object
    一个封装单个JPEG量化表的类。 元素以自然的顺序出现（而不是锯齿形顺序）。 为从JPEG规范的附录K获得的“标准”表以及常规用于视觉无损编码的默认表提供了静态变量。

    有关标准JPEG插件的操作的更多信息，请参阅JPEG metadata format specification and usage notes

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static JPEGQTable K1Div2Luminance
      JPEG规范中给出的采样亮度量化表，表K.1，所有元素除以2。
      static JPEGQTable K1Luminance
      JPEG规范中给出的样本亮度量化表，表K.1。
      static JPEGQTable K2Chrominance
      JPEG规范中给出的样本色度量化表，表K.2。
      static JPEGQTable K2Div2Chrominance
      JPEG规范中给出的样本色度量化表，表K.1，所有元素除以2。

    • 构造方法摘要

      构造方法
      Constructor 描述
      JPEGQTable​(int[] table)
      从参数构造一个量化表，它必须包含自然顺序的64个元素（不是zig-zag顺序）。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      JPEGQTable getScaledInstance​(float scaleFactor, boolean forceBaseline)
      返回一个新的量化表，其中值乘以 scaleFactor ，然后钳位到范围1..32767（如果 forceBaseline为真，则 forceBaseline到1..255）。
      int[] getTable​()
      以自然（不是之字形）顺序的 int的数组返回当前量化表的副本。
      String toString​()
      返回表示该量化表的 String 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • K1Luminance

        public static final JPEGQTable K1Luminance
        JPEG规范中给出的样本亮度量化表，表K.1。 根据规范，这些值产生“良好”的质量输出。
        另请参见：
        K1Div2Luminance

      • K1Div2Luminance

        public static final JPEGQTable K1Div2Luminance
        在JPEG规范中给出的样本亮度量化表，表K.1，所有元素除以2.根据规范，这些值产生“非常好”的质量输出。 这是通常用于“视觉无损”编码的表，如果使用默认表和质量设置，则使用默认亮度表。
        另请参见：
        K1Luminance

      • K2Chrominance

        public static final JPEGQTable K2Chrominance
        JPEG规范中给出的样本色度量化表，表K.2。 根据规范，这些值产生“良好”的质量输出。
        另请参见：
        K2Div2Chrominance

      • K2Div2Chrominance

        public static final JPEGQTable K2Div2Chrominance
        JPEG规范中给出的样本色度量化表，表K.1，所有元素除以2.根据规范，这些值产生“非常好”的质量输出。 这是通常用于“视觉无损”编码的表，如果使用默认表和质量设置，则使用默认色度表。
        另请参见：
        K2Chrominance

    • 构造方法详细信息

      • JPEGQTable

        public JPEGQTable​(int[] table)
        从参数构造一个量化表，它必须包含自然顺序的64个元素（不是zig-zag顺序）。 复制品由输入数组组成。
        参数
        table - 量化表，作为 int数组。
        异常
        IllegalArgumentException - 如果 table是 null或 table.length不等于64。

    • 方法详细信息

      • getTable

        public int[] getTable​()
        以自然（不是之字形）顺序的 int的数组返回当前量化表的副本。
        结果
        当前量化表的副本。

      • getScaledInstance

        public JPEGQTable getScaledInstance​(float scaleFactor,
                                    boolean forceBaseline)
        返回一个新的量化表，其中值乘以scaleFactor ，然后钳位到范围1..32767（如果forceBaseline为真，则forceBaseline到1..255）。

        scaleFactor小于1的值倾向于提高表的质量水平，并且值大于1.0会降低表的质量水平。

        参数
        scaleFactor - 表的乘数。
        forceBaseline - 如果为 true ，则值将被钳位到范围1..255
        结果
        一个新的量化表，它是当前表的线性倍数。

      • toString

        public String toString​()
        返回表示该量化表的 String 。
        重写：
        toString在 Object
        结果
        代表该量化表的 String 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


Uses of Package javax.imageio.plugins.jpeg (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.imageio.plugins.jpeg

  • Packages that use javax.imageio.plugins.jpeg
    软件包 描述
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。
  • Classes in javax.imageio.plugins.jpeg used by javax.imageio.plugins.jpeg
    Class 描述
    JPEGHuffmanTable
    一个封装单个JPEG霍夫曼表的类。
    JPEGQTable
    一个封装单个JPEG量化表的类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.jpeg.JPEGHuffmanTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.jpeg.JPEGHuffmanTable

  • Packages that use JPEGHuffmanTable
    软件包 描述
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。

    • Uses of JPEGHuffmanTable in javax.imageio.plugins.jpeg

      Fields in javax.imageio.plugins.jpeg declared as JPEGHuffmanTable
      Modifier and Type Field 描述
      static JPEGHuffmanTable JPEGHuffmanTable.StdACChrominance
      标准AC色度霍夫曼表。
      static JPEGHuffmanTable JPEGHuffmanTable.StdACLuminance
      标准AC亮度霍夫曼表。
      static JPEGHuffmanTable JPEGHuffmanTable.StdDCChrominance
      标准直流色度霍夫曼表。
      static JPEGHuffmanTable JPEGHuffmanTable.StdDCLuminance
      标准直流亮度霍夫曼表。
      Methods in javax.imageio.plugins.jpeg that return JPEGHuffmanTable
      Modifier and Type 方法 描述
      JPEGHuffmanTable[] JPEGImageReadParam.getACHuffmanTables​()
      返回在最近调用 setDecodeTables或 null上设置的AC Huffman表数组的副本，如果表当前未设置，则 null 。
      JPEGHuffmanTable[] JPEGImageWriteParam.getACHuffmanTables​()
      返回在最近调用 setEncodeTables或 null设置的AC Huffman表数组的副本，如果表当前未设置。
      JPEGHuffmanTable[] JPEGImageReadParam.getDCHuffmanTables​()
      返回最近调用 setDecodeTables设置的DC Huffman表数组的副本，如果表当前未设置，则 null 。
      JPEGHuffmanTable[] JPEGImageWriteParam.getDCHuffmanTables​()
      返回在最近调用 setEncodeTables或 null如果表当前未设置）时设置的DC Huffman表数组的副本。
      Methods in javax.imageio.plugins.jpeg with parameters of type JPEGHuffmanTable
      Modifier and Type 方法 描述
      void JPEGImageReadParam.setDecodeTables​(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables)
      设置用于解码缩写流的量化和霍夫曼表。
      void JPEGImageWriteParam.setEncodeTables​(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables)
      设置用于编码缩写流的量化和霍夫曼表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.jpeg.JPEGImageReadParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.jpeg.JPEGImageReadParam

No usage of javax.imageio.plugins.jpeg.JPEGImageReadParam
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.jpeg.JPEGImageWriteParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.jpeg.JPEGImageWriteParam

No usage of javax.imageio.plugins.jpeg.JPEGImageWriteParam
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.jpeg.JPEGQTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.jpeg.JPEGQTable

  • Packages that use JPEGQTable
    软件包 描述
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。

    • Uses of JPEGQTable in javax.imageio.plugins.jpeg

      Fields in javax.imageio.plugins.jpeg declared as JPEGQTable
      Modifier and Type Field 描述
      static JPEGQTable JPEGQTable.K1Div2Luminance
      JPEG规范中给出的采样亮度量化表，表K.1，所有元素除以2。
      static JPEGQTable JPEGQTable.K1Luminance
      JPEG规范中给出的样本亮度量化表，表K.1。
      static JPEGQTable JPEGQTable.K2Chrominance
      JPEG规范中给出的样本色度量化表，表K.2。
      static JPEGQTable JPEGQTable.K2Div2Chrominance
      JPEG规范中给出的样本色度量化表，表K.1，所有元素除以2。
      Methods in javax.imageio.plugins.jpeg that return JPEGQTable
      Modifier and Type 方法 描述
      JPEGQTable[] JPEGImageReadParam.getQTables​()
      返回最近调用 setDecodeTables或 null如果表当前未设置）设置的量化表阵列的副本。
      JPEGQTable[] JPEGImageWriteParam.getQTables​()
      返回在最近调用 setEncodeTables或 null如果表当前未设置）时设置的量化表数组的副本。
      JPEGQTable JPEGQTable.getScaledInstance​(float scaleFactor, boolean forceBaseline)
      返回一个新的量化表，其中值乘以 scaleFactor ，然后钳位到范围1..32767（如果 forceBaseline为真， forceBaseline 1..255）。
      Methods in javax.imageio.plugins.jpeg with parameters of type JPEGQTable
      Modifier and Type 方法 描述
      void JPEGImageReadParam.setDecodeTables​(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables)
      设置用于解码缩写流的量化和霍夫曼表。
      void JPEGImageWriteParam.setEncodeTables​(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables)
      设置用于编码缩写流的量化和霍夫曼表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


BaselineTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class BaselineTIFFTagSet

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFTagSet
      • javax.imageio.plugins.tiff.BaselineTIFFTagSet

  • public final class BaselineTIFFTagSet
extends TIFFTagSet
    表示在基准TIFF规范中找到的一组标签的类以及一些常见的附加标签。

    此类中包含的非基准标签为：

    • JPEGTables
    • ICC Profile

    该类中包含的基线标签的非基线值为

    • Compression标签值：
      • JPEG-in-TIFF compression
      • Zlib-in-TIFF compression
      • Deflate compression
    • PhotometricInterpretation标签值：
      • ICCLAB  photometric interpretation
    从以下版本开始：
    9
    另请参见：
    TIFF 6.0 Specification

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int COMPRESSION_CCITT_RLE
      与“压缩”标签一起使用的值。
      static int COMPRESSION_CCITT_T_4
      与“压缩”标签一起使用的值。
      static int COMPRESSION_CCITT_T_6
      与“压缩”标签一起使用的值。
      static int COMPRESSION_DEFLATE
      与“压缩”标签一起使用的值。
      static int COMPRESSION_JPEG
      与“压缩”标签一起使用的值。
      static int COMPRESSION_LZW
      与“压缩”标签一起使用的值。
      static int COMPRESSION_NONE
      与“压缩”标签一起使用的值。
      static int COMPRESSION_OLD_JPEG
      与“压缩”标签一起使用的值。
      static int COMPRESSION_PACKBITS
      与“压缩”标签一起使用的值。
      static int COMPRESSION_ZLIB
      与“压缩”标签一起使用的值。
      static int EXTRA_SAMPLES_ASSOCIATED_ALPHA
      与“ExtraSamples”标签一起使用的值。
      static int EXTRA_SAMPLES_UNASSOCIATED_ALPHA
      与“ExtraSamples”标签一起使用的值。
      static int EXTRA_SAMPLES_UNSPECIFIED
      与“ExtraSamples”标签一起使用的值。
      static int FILL_ORDER_LEFT_TO_RIGHT
      与“FillOrder”标签一起使用的值。
      static int FILL_ORDER_RIGHT_TO_LEFT
      与“FillOrder”标签一起使用的值。
      static int GRAY_RESPONSE_UNIT_HUNDRED_THOUSANDTHS
      与“GrayResponseUnit”标签一起使用的值。
      static int GRAY_RESPONSE_UNIT_HUNDREDTHS
      与“GrayResponseUnit”标签一起使用的值。
      static int GRAY_RESPONSE_UNIT_TEN_THOUSANDTHS
      与“GrayResponseUnit”标签一起使用的值。
      static int GRAY_RESPONSE_UNIT_TENTHS
      与“GrayResponseUnit”标签一起使用的值。
      static int GRAY_RESPONSE_UNIT_THOUSANDTHS
      与“GrayResponseUnit”标签一起使用的值。
      static int INK_SET_CMYK
      与“InkSet”标签一起使用的值。
      static int INK_SET_NOT_CMYK
      与“InkSet”标签一起使用的值。
      static int JPEG_PROC_BASELINE
      与“JPEGProc”标签一起使用的值。
      static int JPEG_PROC_LOSSLESS
      与“JPEGProc”标签一起使用的值。
      static int NEW_SUBFILE_TYPE_REDUCED_RESOLUTION
      与“NewSubfileType”标签一起使用的掩码。
      static int NEW_SUBFILE_TYPE_SINGLE_PAGE
      与“NewSubfileType”标签一起使用的掩码。
      static int NEW_SUBFILE_TYPE_TRANSPARENCY
      与“NewSubfileType”标签一起使用的掩码。
      static int ORIENTATION_ROW_0_BOTTOM_COLUMN_0_LEFT
      与“Orientation”标签一起使用的值。
      static int ORIENTATION_ROW_0_BOTTOM_COLUMN_0_RIGHT
      与“Orientation”标签一起使用的值。
      static int ORIENTATION_ROW_0_LEFT_COLUMN_0_BOTTOM
      与“Orientation”标签一起使用的值。
      static int ORIENTATION_ROW_0_LEFT_COLUMN_0_TOP
      与“Orientation”标签一起使用的值。
      static int ORIENTATION_ROW_0_RIGHT_COLUMN_0_BOTTOM
      与“Orientation”标签一起使用的值。
      static int ORIENTATION_ROW_0_RIGHT_COLUMN_0_TOP
      与“Orientation”标签一起使用的值。
      static int ORIENTATION_ROW_0_TOP_COLUMN_0_LEFT
      与“Orientation”标签一起使用的值。
      static int ORIENTATION_ROW_0_TOP_COLUMN_0_RIGHT
      与“Orientation”标签一起使用的值。
      static int PHOTOMETRIC_INTERPRETATION_BLACK_IS_ZERO
      用于“光度测量解释”标签的值。
      static int PHOTOMETRIC_INTERPRETATION_CIELAB
      用于“光度测量解释”标签的值。
      static int PHOTOMETRIC_INTERPRETATION_CMYK
      用于“光度测量解释”标签的值。
      static int PHOTOMETRIC_INTERPRETATION_ICCLAB
      用于“光度测量解释”标签的值。
      static int PHOTOMETRIC_INTERPRETATION_PALETTE_COLOR
      用于“光度测量解释”标签的值。
      static int PHOTOMETRIC_INTERPRETATION_RGB
      用于“光度测量解释”标签的值。
      static int PHOTOMETRIC_INTERPRETATION_TRANSPARENCY_MASK
      用于“光度测量解释”标签的值。
      static int PHOTOMETRIC_INTERPRETATION_WHITE_IS_ZERO
      用于“光度测量解释”标签的值。
      static int PHOTOMETRIC_INTERPRETATION_Y_CB_CR
      用于“光度测量解释”标签的值。
      static int PLANAR_CONFIGURATION_CHUNKY
      与“PlanarConfiguration”标签一起使用的值。
      static int PLANAR_CONFIGURATION_PLANAR
      与“PlanarConfiguration”标签一起使用的值。
      static int PREDICTOR_HORIZONTAL_DIFFERENCING
      与“Predictor”标签一起使用的值。
      static int PREDICTOR_NONE
      与“Predictor”标签一起使用的值。
      static int RESOLUTION_UNIT_CENTIMETER
      与“ResolutionUnit”标签一起使用的值。
      static int RESOLUTION_UNIT_INCH
      与“ResolutionUnit”标签一起使用的值。
      static int RESOLUTION_UNIT_NONE
      与“ResolutionUnit”标签一起使用的值。
      static int SAMPLE_FORMAT_FLOATING_POINT
      与“SampleFormat”标签一起使用的值。
      static int SAMPLE_FORMAT_SIGNED_INTEGER
      与“SampleFormat”标签一起使用的值。
      static int SAMPLE_FORMAT_UNDEFINED
      与“SampleFormat”标签一起使用的值。
      static int SAMPLE_FORMAT_UNSIGNED_INTEGER
      与“SampleFormat”标签一起使用的值。
      static int SUBFILE_TYPE_FULL_RESOLUTION
      与“SubfileType”标签一起使用的值。
      static int SUBFILE_TYPE_REDUCED_RESOLUTION
      与“SubfileType”标签一起使用的值。
      static int SUBFILE_TYPE_SINGLE_PAGE
      与“SubfileType”标签一起使用的值。
      static int T4_OPTIONS_2D_CODING
      与“T4Options”标签一起使用的面具。
      static int T4_OPTIONS_EOL_BYTE_ALIGNED
      与“T4Options”标签一起使用的面具。
      static int T4_OPTIONS_UNCOMPRESSED
      与“T4Options”标签一起使用的面具。
      static int T6_OPTIONS_UNCOMPRESSED
      与“T6Options”标签一起使用的面具。
      static int TAG_ARTIST
      指定“艺术家”标签的常数。
      static int TAG_BITS_PER_SAMPLE
      指定“BitsPerSample”标记的常量。
      static int TAG_CELL_LENGTH
      指定“cell_length”标签的常量。
      static int TAG_CELL_WIDTH
      指定“Cell_Width”标签的常量。
      static int TAG_COLOR_MAP
      常量指定“ColorMap”标签。
      static int TAG_COMPRESSION
      指定“压缩”标签的常量。
      static int TAG_COPYRIGHT
      指定“版权”标签的常数。
      static int TAG_DATE_TIME
      常量指定“DateTime”标签。
      static int TAG_DOCUMENT_NAME
      指定“document_name”标签的常量。
      static int TAG_DOT_RANGE
      常量指定“DotRange”标签。
      static int TAG_EXTRA_SAMPLES
      指定“ExtraSamples”标签的常量。
      static int TAG_FILL_ORDER
      常量指定“fill_order”标签。
      static int TAG_FREE_BYTE_COUNTS
      常量指定“FreeByteCounts”标签。
      static int TAG_FREE_OFFSETS
      常量指定“FreeOffset”标签。
      static int TAG_GRAY_RESPONSE_CURVE
      指定“GrayResponseCurve”标签的常量。
      static int TAG_GRAY_RESPONSE_UNIT
      指定“GrayResponseUnit”标签的常量。
      static int TAG_HALFTONE_HINTS
      指定“HalftoneHints”标签的常量。
      static int TAG_HOST_COMPUTER
      指定“HostComputer”标签的常量。
      static int TAG_ICC_PROFILE
      指定“ICC配置文件”标签的常量。
      static int TAG_IMAGE_DESCRIPTION
      指定“Image_description”标签的常量。
      static int TAG_IMAGE_LENGTH
      常量指定“ImageLength”标签。
      static int TAG_IMAGE_WIDTH
      指定“ImageWidth”标签的常量。
      static int TAG_INK_NAMES
      指定“InkNames”标签的常量。
      static int TAG_INK_SET
      常量指定“InkSet”标签。
      static int TAG_JPEG_AC_TABLES
      指定“JPEGACTables”标签的常量。
      static int TAG_JPEG_DC_TABLES
      常量指定“JPEGDCTables”标签。
      static int TAG_JPEG_INTERCHANGE_FORMAT
      指定“JPEGInterchangeFormat”标签的常量。
      static int TAG_JPEG_INTERCHANGE_FORMAT_LENGTH
      常量指定“JPEGInterchangeFormatLength”标签。
      static int TAG_JPEG_LOSSLESS_PREDICTORS
      指定“JPEGLosslessPredictors”标签的常量。
      static int TAG_JPEG_POINT_TRANSFORMS
      常量指定“JPEGPointTransforms”标签。
      static int TAG_JPEG_PROC
      常量指定“JPEGProc”标签。
      static int TAG_JPEG_Q_TABLES
      指定“JPEGQTables”标签的常量。
      static int TAG_JPEG_RESTART_INTERVAL
      指定“JPEGRestartInterval”标记的常量。
      static int TAG_JPEG_TABLES
      常量指定“JPEGTables”标签。
      static int TAG_MAKE
      指定“Make”标签的常量。
      static int TAG_MAX_SAMPLE_VALUE
      指定“Max_sample_value”标记的常量。
      static int TAG_MIN_SAMPLE_VALUE
      指定“Min_sample_value”标签的常量。
      static int TAG_MODEL
      常量指定“模型”标签。
      static int TAG_NEW_SUBFILE_TYPE
      常量指定“NewSubfileType”标签。
      static int TAG_NUMBER_OF_INKS
      常量指定“NumberOfInks”标签。
      static int TAG_ORIENTATION
      常量指定“方向”标签。
      static int TAG_PAGE_NAME
      常量指定“PageName”标签。
      static int TAG_PAGE_NUMBER
      指定“PageNumber”标签的常量。
      static int TAG_PHOTOMETRIC_INTERPRETATION
      指定“光度测量解释”标签的常数。
      static int TAG_PLANAR_CONFIGURATION
      常量指定“PlanarConfiguration”标签。
      static int TAG_PREDICTOR
      指定“Predictor”标签的常量。
      static int TAG_PRIMARY_CHROMATICITES
      常量指定“PrimaryChromaticites”标签。
      static int TAG_REFERENCE_BLACK_WHITE
      指定“ReferenceBlackWhite”标签的常量。
      static int TAG_RESOLUTION_UNIT
      指定“ResolutionUnit”标签的常量。
      static int TAG_ROWS_PER_STRIP
      指定“Rows_per_strip”标签的常量。
      static int TAG_S_MAX_SAMPLE_VALUE
      指定“SMaxSampleValue”标签的常量。
      static int TAG_S_MIN_SAMPLE_VALUE
      指定“SMinSampleValue”标签的常量。
      static int TAG_SAMPLE_FORMAT
      常量指定“SampleFormat”标签。
      static int TAG_SAMPLES_PER_PIXEL
      指定“Samples_per_pixel”标签的常量。
      static int TAG_SOFTWARE
      常量指定“软件”标签。
      static int TAG_STRIP_BYTE_COUNTS
      指定“Strip_byte_counts”标签的常量。
      static int TAG_STRIP_OFFSETS
      指定“Strip_offsets”标签的常量。
      static int TAG_SUBFILE_TYPE
      指定“SubfileType”标签的常量。
      static int TAG_T4_OPTIONS
      常量指定“T4Options”标签。
      static int TAG_T6_OPTIONS
      常量指定“T6Options”标签。
      static int TAG_TARGET_PRINTER
      指定“TargetPrinter”标签的常量。
      static int TAG_THRESHHOLDING
      指定“阈值”标签的常数。
      static int TAG_TILE_BYTE_COUNTS
      常量指定“TileByteCounts”标签。
      static int TAG_TILE_LENGTH
      常量指定“TileLength”标签。
      static int TAG_TILE_OFFSETS
      常量指定“TileOffset”标签。
      static int TAG_TILE_WIDTH
      常量指定“TileWidth”标签。
      static int TAG_TRANSFER_FUNCTION
      指定“TransferFunction”标签的常量。
      static int TAG_TRANSFER_RANGE
      指定“TransferRange”标签的常量。
      static int TAG_WHITE_POINT
      常量指定“白点”标签。
      static int TAG_X_POSITION
      指定“XPosition”标签的常量。
      static int TAG_X_RESOLUTION
      常量指定“XResolution”标签。
      static int TAG_Y_CB_CR_COEFFICIENTS
      指定“YCbCrCoefficients”标签的常量。
      static int TAG_Y_CB_CR_POSITIONING
      常量指定“YCbCrPositioning”标签。
      static int TAG_Y_CB_CR_SUBSAMPLING
      指定“YCbCrSubsampling”标签的常量。
      static int TAG_Y_POSITION
      常量指定“YPosition”标签。
      static int TAG_Y_RESOLUTION
      指定“YResolution”标签的常量。
      static int THRESHHOLDING_NONE
      与“阈值”标签一起使用的值。
      static int THRESHHOLDING_ORDERED_DITHER
      与“阈值”标签一起使用的值。
      static int THRESHHOLDING_RANDOMIZED_DITHER
      与“阈值”标签一起使用的值。
      static int Y_CB_CR_POSITIONING_CENTERED
      与“YCbCrPositioning”标签一起使用的值。
      static int Y_CB_CR_POSITIONING_COSITED
      与“YCbCrPositioning”标签一起使用的值。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static BaselineTIFFTagSet getInstance​()
      返回一个 BaselineTIFFTagSet的共享实例。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.imageio.plugins.tiff.TIFFTagSet

        getTag, getTag, getTagNames, getTagNumbers

    • 字段详细信息

      • TAG_NEW_SUBFILE_TYPE

        public static final int TAG_NEW_SUBFILE_TYPE
        常量指定“NewSubfileType”标签。
        另请参见：
        NEW_SUBFILE_TYPE_REDUCED_RESOLUTION ， NEW_SUBFILE_TYPE_SINGLE_PAGE ， NEW_SUBFILE_TYPE_TRANSPARENCY ， Constant Field Values

      • NEW_SUBFILE_TYPE_REDUCED_RESOLUTION

        public static final int NEW_SUBFILE_TYPE_REDUCED_RESOLUTION
        与“NewSubfileType”标签一起使用的掩码。
        另请参见：
        TAG_NEW_SUBFILE_TYPE ， Constant Field Values

      • NEW_SUBFILE_TYPE_SINGLE_PAGE

        public static final int NEW_SUBFILE_TYPE_SINGLE_PAGE
        与“NewSubfileType”标签一起使用的掩码。
        另请参见：
        TAG_NEW_SUBFILE_TYPE ， Constant Field Values

      • NEW_SUBFILE_TYPE_TRANSPARENCY

        public static final int NEW_SUBFILE_TYPE_TRANSPARENCY
        与“NewSubfileType”标签一起使用的掩码。
        另请参见：
        TAG_NEW_SUBFILE_TYPE ， Constant Field Values

      • TAG_SUBFILE_TYPE

        public static final int TAG_SUBFILE_TYPE
        指定“SubfileType”标签的常量。
        另请参见：
        SUBFILE_TYPE_FULL_RESOLUTION ， SUBFILE_TYPE_REDUCED_RESOLUTION ， SUBFILE_TYPE_SINGLE_PAGE ， Constant Field Values

      • SUBFILE_TYPE_FULL_RESOLUTION

        public static final int SUBFILE_TYPE_FULL_RESOLUTION
        与“SubfileType”标签一起使用的值。
        另请参见：
        TAG_SUBFILE_TYPE ， Constant Field Values

      • SUBFILE_TYPE_REDUCED_RESOLUTION

        public static final int SUBFILE_TYPE_REDUCED_RESOLUTION
        与“SubfileType”标签一起使用的值。
        另请参见：
        TAG_SUBFILE_TYPE ， Constant Field Values

      • SUBFILE_TYPE_SINGLE_PAGE

        public static final int SUBFILE_TYPE_SINGLE_PAGE
        与“SubfileType”标签一起使用的值。
        另请参见：
        TAG_SUBFILE_TYPE ， Constant Field Values

      • TAG_IMAGE_WIDTH

        public static final int TAG_IMAGE_WIDTH
        指定“ImageWidth”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_IMAGE_LENGTH

        public static final int TAG_IMAGE_LENGTH
        常量指定“ImageLength”标签。
        另请参见：
        Constant Field Values

      • TAG_BITS_PER_SAMPLE

        public static final int TAG_BITS_PER_SAMPLE
        指定“BitsPerSample”标记的常量。
        另请参见：
        Constant Field Values

      • TAG_COMPRESSION

        public static final int TAG_COMPRESSION
        指定“压缩”标签的常量。
        另请参见：
        COMPRESSION_NONE ， COMPRESSION_CCITT_RLE ， COMPRESSION_CCITT_T_4 ， COMPRESSION_CCITT_T_6 ， COMPRESSION_LZW ， COMPRESSION_OLD_JPEG ， COMPRESSION_JPEG ， COMPRESSION_ZLIB ， COMPRESSION_PACKBITS ， COMPRESSION_DEFLATE ， Constant Field Values

      • COMPRESSION_NONE

        public static final int COMPRESSION_NONE
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， Constant Field Values

      • COMPRESSION_CCITT_RLE

        public static final int COMPRESSION_CCITT_RLE
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， Constant Field Values

      • COMPRESSION_CCITT_T_4

        public static final int COMPRESSION_CCITT_T_4
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， Constant Field Values

      • COMPRESSION_CCITT_T_6

        public static final int COMPRESSION_CCITT_T_6
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， Constant Field Values

      • COMPRESSION_LZW

        public static final int COMPRESSION_LZW
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， Constant Field Values

      • COMPRESSION_OLD_JPEG

        public static final int COMPRESSION_OLD_JPEG
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， Constant Field Values

      • COMPRESSION_JPEG

        public static final int COMPRESSION_JPEG
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， TIFF Specification Supplement 2 ， Constant Field Values

      • COMPRESSION_ZLIB

        public static final int COMPRESSION_ZLIB
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， TIFF Specification Supplement 2 ， Constant Field Values

      • COMPRESSION_PACKBITS

        public static final int COMPRESSION_PACKBITS
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， Constant Field Values

      • COMPRESSION_DEFLATE

        public static final int COMPRESSION_DEFLATE
        与“压缩”标签一起使用的值。
        另请参见：
        TAG_COMPRESSION ， DEFLATE specification ， TIFF Specification Supplement 2 ， Constant Field Values

      • TAG_PHOTOMETRIC_INTERPRETATION

        public static final int TAG_PHOTOMETRIC_INTERPRETATION
        指定“光度测量解释”标签的常数。
        另请参见：
        PHOTOMETRIC_INTERPRETATION_WHITE_IS_ZERO ， PHOTOMETRIC_INTERPRETATION_BLACK_IS_ZERO ， PHOTOMETRIC_INTERPRETATION_RGB ， PHOTOMETRIC_INTERPRETATION_PALETTE_COLOR ， PHOTOMETRIC_INTERPRETATION_TRANSPARENCY_MASK ， PHOTOMETRIC_INTERPRETATION_Y_CB_CR ， PHOTOMETRIC_INTERPRETATION_CIELAB ， PHOTOMETRIC_INTERPRETATION_ICCLAB ， Constant Field Values

      • PHOTOMETRIC_INTERPRETATION_WHITE_IS_ZERO

        public static final int PHOTOMETRIC_INTERPRETATION_WHITE_IS_ZERO
        用于“光度测量解释”标签的值。
        另请参见：
        TAG_PHOTOMETRIC_INTERPRETATION ， Constant Field Values

      • PHOTOMETRIC_INTERPRETATION_BLACK_IS_ZERO

        public static final int PHOTOMETRIC_INTERPRETATION_BLACK_IS_ZERO
        用于“光度测量解释”标签的值。
        另请参见：
        TAG_PHOTOMETRIC_INTERPRETATION ， Constant Field Values

      • PHOTOMETRIC_INTERPRETATION_RGB

        public static final int PHOTOMETRIC_INTERPRETATION_RGB
        用于“光度测量解释”标签的值。
        另请参见：
        TAG_PHOTOMETRIC_INTERPRETATION ， Constant Field Values

      • PHOTOMETRIC_INTERPRETATION_PALETTE_COLOR

        public static final int PHOTOMETRIC_INTERPRETATION_PALETTE_COLOR
        用于“光度测量解释”标签的值。
        另请参见：
        TAG_PHOTOMETRIC_INTERPRETATION ， Constant Field Values

      • PHOTOMETRIC_INTERPRETATION_TRANSPARENCY_MASK

        public static final int PHOTOMETRIC_INTERPRETATION_TRANSPARENCY_MASK
        用于“光度测量解释”标签的值。
        另请参见：
        TAG_PHOTOMETRIC_INTERPRETATION ， Constant Field Values

      • PHOTOMETRIC_INTERPRETATION_CMYK

        public static final int PHOTOMETRIC_INTERPRETATION_CMYK
        用于“光度测量解释”标签的值。
        另请参见：
        TAG_PHOTOMETRIC_INTERPRETATION ， Constant Field Values

      • PHOTOMETRIC_INTERPRETATION_Y_CB_CR

        public static final int PHOTOMETRIC_INTERPRETATION_Y_CB_CR
        用于“光度测量解释”标签的值。
        另请参见：
        TAG_PHOTOMETRIC_INTERPRETATION ， Constant Field Values

      • PHOTOMETRIC_INTERPRETATION_CIELAB

        public static final int PHOTOMETRIC_INTERPRETATION_CIELAB
        用于“光度测量解释”标签的值。
        另请参见：
        TAG_PHOTOMETRIC_INTERPRETATION ， Constant Field Values

      • PHOTOMETRIC_INTERPRETATION_ICCLAB

        public static final int PHOTOMETRIC_INTERPRETATION_ICCLAB
        用于“光度测量解释”标签的值。
        另请参见：
        TAG_PHOTOMETRIC_INTERPRETATION ， TIFF Specification Supplement 1 ， Constant Field Values

      • TAG_THRESHHOLDING

        public static final int TAG_THRESHHOLDING
        指定“阈值”标签的常数。
        另请参见：
        THRESHHOLDING_NONE ， THRESHHOLDING_ORDERED_DITHER ， THRESHHOLDING_RANDOMIZED_DITHER ， Constant Field Values

      • THRESHHOLDING_NONE

        public static final int THRESHHOLDING_NONE
        与“阈值”标签一起使用的值。
        另请参见：
        TAG_THRESHHOLDING ， Constant Field Values

      • THRESHHOLDING_ORDERED_DITHER

        public static final int THRESHHOLDING_ORDERED_DITHER
        与“阈值”标签一起使用的值。
        另请参见：
        TAG_THRESHHOLDING ， Constant Field Values

      • THRESHHOLDING_RANDOMIZED_DITHER

        public static final int THRESHHOLDING_RANDOMIZED_DITHER
        与“阈值”标签一起使用的值。
        另请参见：
        TAG_THRESHHOLDING ， Constant Field Values

      • TAG_CELL_WIDTH

        public static final int TAG_CELL_WIDTH
        指定“Cell_Width”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_CELL_LENGTH

        public static final int TAG_CELL_LENGTH
        指定“cell_length”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_FILL_ORDER

        public static final int TAG_FILL_ORDER
        常量指定“fill_order”标签。
        另请参见：
        FILL_ORDER_LEFT_TO_RIGHT ， FILL_ORDER_RIGHT_TO_LEFT ， Constant Field Values

      • FILL_ORDER_LEFT_TO_RIGHT

        public static final int FILL_ORDER_LEFT_TO_RIGHT
        与“FillOrder”标签一起使用的值。
        另请参见：
        TAG_FILL_ORDER ， Constant Field Values

      • FILL_ORDER_RIGHT_TO_LEFT

        public static final int FILL_ORDER_RIGHT_TO_LEFT
        与“FillOrder”标签一起使用的值。
        另请参见：
        TAG_FILL_ORDER ， Constant Field Values

      • TAG_DOCUMENT_NAME

        public static final int TAG_DOCUMENT_NAME
        指定“document_name”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_IMAGE_DESCRIPTION

        public static final int TAG_IMAGE_DESCRIPTION
        指定“Image_description”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_MAKE

        public static final int TAG_MAKE
        指定“Make”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_MODEL

        public static final int TAG_MODEL
        常量指定“模型”标签。
        另请参见：
        Constant Field Values

      • TAG_STRIP_OFFSETS

        public static final int TAG_STRIP_OFFSETS
        指定“Strip_offsets”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_ORIENTATION

        public static final int TAG_ORIENTATION
        常量指定“方向”标签。
        另请参见：
        ORIENTATION_ROW_0_TOP_COLUMN_0_LEFT ， ORIENTATION_ROW_0_TOP_COLUMN_0_RIGHT ， ORIENTATION_ROW_0_BOTTOM_COLUMN_0_RIGHT ， ORIENTATION_ROW_0_BOTTOM_COLUMN_0_LEFT ， ORIENTATION_ROW_0_LEFT_COLUMN_0_TOP ， ORIENTATION_ROW_0_RIGHT_COLUMN_0_TOP ， ORIENTATION_ROW_0_RIGHT_COLUMN_0_BOTTOM ， ORIENTATION_ROW_0_LEFT_COLUMN_0_BOTTOM ， Constant Field Values

      • ORIENTATION_ROW_0_TOP_COLUMN_0_LEFT

        public static final int ORIENTATION_ROW_0_TOP_COLUMN_0_LEFT
        与“Orientation”标签一起使用的值。
        另请参见：
        TAG_ORIENTATION ， Constant Field Values

      • ORIENTATION_ROW_0_TOP_COLUMN_0_RIGHT

        public static final int ORIENTATION_ROW_0_TOP_COLUMN_0_RIGHT
        与“Orientation”标签一起使用的值。
        另请参见：
        TAG_ORIENTATION ， Constant Field Values

      • ORIENTATION_ROW_0_BOTTOM_COLUMN_0_RIGHT

        public static final int ORIENTATION_ROW_0_BOTTOM_COLUMN_0_RIGHT
        与“Orientation”标签一起使用的值。
        另请参见：
        TAG_ORIENTATION ， Constant Field Values

      • ORIENTATION_ROW_0_BOTTOM_COLUMN_0_LEFT

        public static final int ORIENTATION_ROW_0_BOTTOM_COLUMN_0_LEFT
        与“Orientation”标签一起使用的值。
        另请参见：
        TAG_ORIENTATION ， Constant Field Values

      • ORIENTATION_ROW_0_LEFT_COLUMN_0_TOP

        public static final int ORIENTATION_ROW_0_LEFT_COLUMN_0_TOP
        与“Orientation”标签一起使用的值。
        另请参见：
        TAG_ORIENTATION ， Constant Field Values

      • ORIENTATION_ROW_0_RIGHT_COLUMN_0_TOP

        public static final int ORIENTATION_ROW_0_RIGHT_COLUMN_0_TOP
        与“Orientation”标签一起使用的值。
        另请参见：
        TAG_ORIENTATION ， Constant Field Values

      • ORIENTATION_ROW_0_RIGHT_COLUMN_0_BOTTOM

        public static final int ORIENTATION_ROW_0_RIGHT_COLUMN_0_BOTTOM
        与“Orientation”标签一起使用的值。
        另请参见：
        TAG_ORIENTATION ， Constant Field Values

      • ORIENTATION_ROW_0_LEFT_COLUMN_0_BOTTOM

        public static final int ORIENTATION_ROW_0_LEFT_COLUMN_0_BOTTOM
        与“Orientation”标签一起使用的值。
        另请参见：
        TAG_ORIENTATION ， Constant Field Values

      • TAG_SAMPLES_PER_PIXEL

        public static final int TAG_SAMPLES_PER_PIXEL
        指定“Samples_per_pixel”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_ROWS_PER_STRIP

        public static final int TAG_ROWS_PER_STRIP
        指定“Rows_per_strip”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_STRIP_BYTE_COUNTS

        public static final int TAG_STRIP_BYTE_COUNTS
        指定“Strip_byte_counts”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_MIN_SAMPLE_VALUE

        public static final int TAG_MIN_SAMPLE_VALUE
        指定“Min_sample_value”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_MAX_SAMPLE_VALUE

        public static final int TAG_MAX_SAMPLE_VALUE
        指定“Max_sample_value”标记的常量。
        另请参见：
        Constant Field Values

      • TAG_X_RESOLUTION

        public static final int TAG_X_RESOLUTION
        常量指定“XResolution”标签。
        另请参见：
        Constant Field Values

      • TAG_Y_RESOLUTION

        public static final int TAG_Y_RESOLUTION
        指定“YResolution”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_PLANAR_CONFIGURATION

        public static final int TAG_PLANAR_CONFIGURATION
        常量指定“PlanarConfiguration”标签。
        另请参见：
        PLANAR_CONFIGURATION_CHUNKY ， PLANAR_CONFIGURATION_PLANAR ， Constant Field Values

      • PLANAR_CONFIGURATION_CHUNKY

        public static final int PLANAR_CONFIGURATION_CHUNKY
        与“PlanarConfiguration”标签一起使用的值。
        另请参见：
        TAG_PLANAR_CONFIGURATION ， Constant Field Values

      • PLANAR_CONFIGURATION_PLANAR

        public static final int PLANAR_CONFIGURATION_PLANAR
        与“PlanarConfiguration”标签一起使用的值。
        另请参见：
        TAG_PLANAR_CONFIGURATION ， Constant Field Values

      • TAG_PAGE_NAME

        public static final int TAG_PAGE_NAME
        常量指定“PageName”标签。
        另请参见：
        Constant Field Values

      • TAG_X_POSITION

        public static final int TAG_X_POSITION
        指定“XPosition”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_Y_POSITION

        public static final int TAG_Y_POSITION
        常量指定“YPosition”标签。
        另请参见：
        Constant Field Values

      • TAG_FREE_OFFSETS

        public static final int TAG_FREE_OFFSETS
        常量指定“FreeOffset”标签。
        另请参见：
        Constant Field Values

      • TAG_FREE_BYTE_COUNTS

        public static final int TAG_FREE_BYTE_COUNTS
        常量指定“FreeByteCounts”标签。
        另请参见：
        Constant Field Values

      • TAG_GRAY_RESPONSE_UNIT

        public static final int TAG_GRAY_RESPONSE_UNIT
        指定“GrayResponseUnit”标签的常量。
        另请参见：
        GRAY_RESPONSE_UNIT_TENTHS ， GRAY_RESPONSE_UNIT_HUNDREDTHS ， GRAY_RESPONSE_UNIT_THOUSANDTHS ， GRAY_RESPONSE_UNIT_TEN_THOUSANDTHS ， GRAY_RESPONSE_UNIT_HUNDRED_THOUSANDTHS ， Constant Field Values

      • GRAY_RESPONSE_UNIT_TENTHS

        public static final int GRAY_RESPONSE_UNIT_TENTHS
        与“GrayResponseUnit”标签一起使用的值。
        另请参见：
        TAG_GRAY_RESPONSE_UNIT ， Constant Field Values

      • GRAY_RESPONSE_UNIT_HUNDREDTHS

        public static final int GRAY_RESPONSE_UNIT_HUNDREDTHS
        与“GrayResponseUnit”标签一起使用的值。
        另请参见：
        TAG_GRAY_RESPONSE_UNIT ， Constant Field Values

      • GRAY_RESPONSE_UNIT_THOUSANDTHS

        public static final int GRAY_RESPONSE_UNIT_THOUSANDTHS
        与“GrayResponseUnit”标签一起使用的值。
        另请参见：
        TAG_GRAY_RESPONSE_UNIT ， Constant Field Values

      • GRAY_RESPONSE_UNIT_TEN_THOUSANDTHS

        public static final int GRAY_RESPONSE_UNIT_TEN_THOUSANDTHS
        与“GrayResponseUnit”标签一起使用的值。
        另请参见：
        TAG_GRAY_RESPONSE_UNIT ， Constant Field Values

      • GRAY_RESPONSE_UNIT_HUNDRED_THOUSANDTHS

        public static final int GRAY_RESPONSE_UNIT_HUNDRED_THOUSANDTHS
        与“GrayResponseUnit”标签一起使用的值。
        另请参见：
        TAG_GRAY_RESPONSE_UNIT ， Constant Field Values

      • TAG_GRAY_RESPONSE_CURVE

        public static final int TAG_GRAY_RESPONSE_CURVE
        指定“GrayResponseCurve”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_T4_OPTIONS

        public static final int TAG_T4_OPTIONS
        常量指定“T4Options”标签。
        另请参见：
        T4_OPTIONS_2D_CODING ， T4_OPTIONS_UNCOMPRESSED ， T4_OPTIONS_EOL_BYTE_ALIGNED ， Constant Field Values

      • T4_OPTIONS_2D_CODING

        public static final int T4_OPTIONS_2D_CODING
        与“T4Options”标签一起使用的面具。
        另请参见：
        TAG_T4_OPTIONS ， Constant Field Values

      • T4_OPTIONS_UNCOMPRESSED

        public static final int T4_OPTIONS_UNCOMPRESSED
        与“T4Options”标签一起使用的面具。
        另请参见：
        TAG_T4_OPTIONS ， Constant Field Values

      • T4_OPTIONS_EOL_BYTE_ALIGNED

        public static final int T4_OPTIONS_EOL_BYTE_ALIGNED
        与“T4Options”标签一起使用的面具。
        另请参见：
        TAG_T4_OPTIONS ， Constant Field Values

      • TAG_T6_OPTIONS

        public static final int TAG_T6_OPTIONS
        常量指定“T6Options”标签。
        另请参见：
        T6_OPTIONS_UNCOMPRESSED ， Constant Field Values

      • T6_OPTIONS_UNCOMPRESSED

        public static final int T6_OPTIONS_UNCOMPRESSED
        与“T6Options”标签一起使用的面具。
        另请参见：
        TAG_T6_OPTIONS ， Constant Field Values

      • TAG_RESOLUTION_UNIT

        public static final int TAG_RESOLUTION_UNIT
        指定“ResolutionUnit”标签的常量。
        另请参见：
        RESOLUTION_UNIT_NONE ， RESOLUTION_UNIT_INCH ， RESOLUTION_UNIT_CENTIMETER ， Constant Field Values

      • RESOLUTION_UNIT_NONE

        public static final int RESOLUTION_UNIT_NONE
        与“ResolutionUnit”标签一起使用的值。
        另请参见：
        TAG_RESOLUTION_UNIT ， Constant Field Values

      • RESOLUTION_UNIT_INCH

        public static final int RESOLUTION_UNIT_INCH
        与“ResolutionUnit”标签一起使用的值。
        另请参见：
        TAG_RESOLUTION_UNIT ， Constant Field Values

      • RESOLUTION_UNIT_CENTIMETER

        public static final int RESOLUTION_UNIT_CENTIMETER
        与“ResolutionUnit”标签一起使用的值。
        另请参见：
        TAG_RESOLUTION_UNIT ， Constant Field Values

      • TAG_PAGE_NUMBER

        public static final int TAG_PAGE_NUMBER
        指定“PageNumber”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_TRANSFER_FUNCTION

        public static final int TAG_TRANSFER_FUNCTION
        指定“TransferFunction”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_SOFTWARE

        public static final int TAG_SOFTWARE
        常量指定“软件”标签。
        另请参见：
        Constant Field Values

      • TAG_DATE_TIME

        public static final int TAG_DATE_TIME
        常量指定“DateTime”标签。
        另请参见：
        Constant Field Values

      • TAG_ARTIST

        public static final int TAG_ARTIST
        指定“艺术家”标签的常数。
        另请参见：
        Constant Field Values

      • TAG_HOST_COMPUTER

        public static final int TAG_HOST_COMPUTER
        指定“HostComputer”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_PREDICTOR

        public static final int TAG_PREDICTOR
        指定“Predictor”标签的常量。
        另请参见：
        TAG_WHITE_POINT ， TAG_PRIMARY_CHROMATICITES ， TAG_COLOR_MAP ， TAG_HALFTONE_HINTS ， TAG_TILE_WIDTH ， TAG_TILE_LENGTH ， TAG_TILE_OFFSETS ， TAG_TILE_BYTE_COUNTS ， Constant Field Values

      • PREDICTOR_NONE

        public static final int PREDICTOR_NONE
        与“Predictor”标签一起使用的值。
        另请参见：
        TAG_PREDICTOR ， Constant Field Values

      • PREDICTOR_HORIZONTAL_DIFFERENCING

        public static final int PREDICTOR_HORIZONTAL_DIFFERENCING
        与“Predictor”标签一起使用的值。
        另请参见：
        TAG_PREDICTOR ， Constant Field Values

      • TAG_WHITE_POINT

        public static final int TAG_WHITE_POINT
        常量指定“白点”标签。
        另请参见：
        Constant Field Values

      • TAG_PRIMARY_CHROMATICITES

        public static final int TAG_PRIMARY_CHROMATICITES
        常量指定“PrimaryChromaticites”标签。
        另请参见：
        Constant Field Values

      • TAG_COLOR_MAP

        public static final int TAG_COLOR_MAP
        常量指定“ColorMap”标签。
        另请参见：
        Constant Field Values

      • TAG_HALFTONE_HINTS

        public static final int TAG_HALFTONE_HINTS
        指定“HalftoneHints”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_TILE_WIDTH

        public static final int TAG_TILE_WIDTH
        常量指定“TileWidth”标签。
        另请参见：
        Constant Field Values

      • TAG_TILE_LENGTH

        public static final int TAG_TILE_LENGTH
        常量指定“TileLength”标签。
        另请参见：
        Constant Field Values

      • TAG_TILE_OFFSETS

        public static final int TAG_TILE_OFFSETS
        常量指定“TileOffset”标签。
        另请参见：
        Constant Field Values

      • TAG_TILE_BYTE_COUNTS

        public static final int TAG_TILE_BYTE_COUNTS
        常量指定“TileByteCounts”标签。
        另请参见：
        Constant Field Values

      • TAG_INK_SET

        public static final int TAG_INK_SET
        常量指定“InkSet”标签。
        另请参见：
        INK_SET_CMYK ， INK_SET_NOT_CMYK ， Constant Field Values

      • INK_SET_CMYK

        public static final int INK_SET_CMYK
        与“InkSet”标签一起使用的值。
        另请参见：
        TAG_INK_SET ， Constant Field Values

      • INK_SET_NOT_CMYK

        public static final int INK_SET_NOT_CMYK
        与“InkSet”标签一起使用的值。
        另请参见：
        TAG_INK_SET ， Constant Field Values

      • TAG_INK_NAMES

        public static final int TAG_INK_NAMES
        指定“InkNames”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_NUMBER_OF_INKS

        public static final int TAG_NUMBER_OF_INKS
        常量指定“NumberOfInks”标签。
        另请参见：
        Constant Field Values

      • TAG_DOT_RANGE

        public static final int TAG_DOT_RANGE
        常量指定“DotRange”标签。
        另请参见：
        Constant Field Values

      • TAG_TARGET_PRINTER

        public static final int TAG_TARGET_PRINTER
        指定“TargetPrinter”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_EXTRA_SAMPLES

        public static final int TAG_EXTRA_SAMPLES
        指定“ExtraSamples”标签的常量。
        另请参见：
        EXTRA_SAMPLES_UNSPECIFIED ， EXTRA_SAMPLES_ASSOCIATED_ALPHA ， EXTRA_SAMPLES_UNASSOCIATED_ALPHA ， Constant Field Values

      • EXTRA_SAMPLES_UNSPECIFIED

        public static final int EXTRA_SAMPLES_UNSPECIFIED
        与“ExtraSamples”标签一起使用的值。
        另请参见：
        TAG_EXTRA_SAMPLES ， Constant Field Values

      • EXTRA_SAMPLES_ASSOCIATED_ALPHA

        public static final int EXTRA_SAMPLES_ASSOCIATED_ALPHA
        与“ExtraSamples”标签一起使用的值。
        另请参见：
        TAG_EXTRA_SAMPLES ， Constant Field Values

      • EXTRA_SAMPLES_UNASSOCIATED_ALPHA

        public static final int EXTRA_SAMPLES_UNASSOCIATED_ALPHA
        与“ExtraSamples”标签一起使用的值。
        另请参见：
        TAG_EXTRA_SAMPLES ， Constant Field Values

      • TAG_SAMPLE_FORMAT

        public static final int TAG_SAMPLE_FORMAT
        常量指定“SampleFormat”标签。
        另请参见：
        SAMPLE_FORMAT_UNSIGNED_INTEGER ， SAMPLE_FORMAT_SIGNED_INTEGER ， SAMPLE_FORMAT_FLOATING_POINT ， SAMPLE_FORMAT_UNDEFINED ， Constant Field Values

      • SAMPLE_FORMAT_UNSIGNED_INTEGER

        public static final int SAMPLE_FORMAT_UNSIGNED_INTEGER
        与“SampleFormat”标签一起使用的值。
        另请参见：
        TAG_SAMPLE_FORMAT ， Constant Field Values

      • SAMPLE_FORMAT_SIGNED_INTEGER

        public static final int SAMPLE_FORMAT_SIGNED_INTEGER
        与“SampleFormat”标签一起使用的值。
        另请参见：
        TAG_SAMPLE_FORMAT ， Constant Field Values

      • SAMPLE_FORMAT_FLOATING_POINT

        public static final int SAMPLE_FORMAT_FLOATING_POINT
        与“SampleFormat”标签一起使用的值。
        另请参见：
        TAG_SAMPLE_FORMAT ， Constant Field Values

      • SAMPLE_FORMAT_UNDEFINED

        public static final int SAMPLE_FORMAT_UNDEFINED
        与“SampleFormat”标签一起使用的值。
        另请参见：
        TAG_SAMPLE_FORMAT ， Constant Field Values

      • TAG_S_MIN_SAMPLE_VALUE

        public static final int TAG_S_MIN_SAMPLE_VALUE
        指定“SMinSampleValue”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_S_MAX_SAMPLE_VALUE

        public static final int TAG_S_MAX_SAMPLE_VALUE
        指定“SMaxSampleValue”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_TRANSFER_RANGE

        public static final int TAG_TRANSFER_RANGE
        指定“TransferRange”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_JPEG_TABLES

        public static final int TAG_JPEG_TABLES
        常量指定“JPEGTables”标签。
        另请参见：
        TIFF Specification Supplement 2 ， JPEG-in-TIFF compression ， Constant Field Values

      • TAG_JPEG_PROC

        public static final int TAG_JPEG_PROC
        常量指定“JPEGProc”标签。
        另请参见：
        Constant Field Values

      • JPEG_PROC_BASELINE

        public static final int JPEG_PROC_BASELINE
        与“JPEGProc”标签一起使用的值。
        另请参见：
        TAG_JPEG_PROC ， Constant Field Values

      • JPEG_PROC_LOSSLESS

        public static final int JPEG_PROC_LOSSLESS
        与“JPEGProc”标签一起使用的值。
        另请参见：
        TAG_JPEG_PROC ， Constant Field Values

      • TAG_JPEG_INTERCHANGE_FORMAT

        public static final int TAG_JPEG_INTERCHANGE_FORMAT
        指定“JPEGInterchangeFormat”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_JPEG_INTERCHANGE_FORMAT_LENGTH

        public static final int TAG_JPEG_INTERCHANGE_FORMAT_LENGTH
        常量指定“JPEGInterchangeFormatLength”标签。
        另请参见：
        Constant Field Values

      • TAG_JPEG_RESTART_INTERVAL

        public static final int TAG_JPEG_RESTART_INTERVAL
        指定“JPEGRestartInterval”标记的常量。
        另请参见：
        Constant Field Values

      • TAG_JPEG_LOSSLESS_PREDICTORS

        public static final int TAG_JPEG_LOSSLESS_PREDICTORS
        指定“JPEGLosslessPredictors”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_JPEG_POINT_TRANSFORMS

        public static final int TAG_JPEG_POINT_TRANSFORMS
        常量指定“JPEGPointTransforms”标签。
        另请参见：
        Constant Field Values

      • TAG_JPEG_Q_TABLES

        public static final int TAG_JPEG_Q_TABLES
        指定“JPEGQTables”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_JPEG_DC_TABLES

        public static final int TAG_JPEG_DC_TABLES
        常量指定“JPEGDCTables”标签。
        另请参见：
        Constant Field Values

      • TAG_JPEG_AC_TABLES

        public static final int TAG_JPEG_AC_TABLES
        指定“JPEGACTables”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_Y_CB_CR_COEFFICIENTS

        public static final int TAG_Y_CB_CR_COEFFICIENTS
        指定“YCbCrCoefficients”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_Y_CB_CR_SUBSAMPLING

        public static final int TAG_Y_CB_CR_SUBSAMPLING
        指定“YCbCrSubsampling”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_Y_CB_CR_POSITIONING

        public static final int TAG_Y_CB_CR_POSITIONING
        常量指定“YCbCrPositioning”标签。
        另请参见：
        Y_CB_CR_POSITIONING_CENTERED ， Y_CB_CR_POSITIONING_COSITED ， Constant Field Values

      • Y_CB_CR_POSITIONING_CENTERED

        public static final int Y_CB_CR_POSITIONING_CENTERED
        与“YCbCrPositioning”标签一起使用的值。
        另请参见：
        TAG_Y_CB_CR_POSITIONING ， Constant Field Values

      • Y_CB_CR_POSITIONING_COSITED

        public static final int Y_CB_CR_POSITIONING_COSITED
        与“YCbCrPositioning”标签一起使用的值。
        另请参见：
        TAG_Y_CB_CR_POSITIONING ， Constant Field Values

      • TAG_REFERENCE_BLACK_WHITE

        public static final int TAG_REFERENCE_BLACK_WHITE
        指定“ReferenceBlackWhite”标签的常量。
        另请参见：
        Constant Field Values

      • TAG_COPYRIGHT

        public static final int TAG_COPYRIGHT
        指定“版权”标签的常数。
        另请参见：
        Constant Field Values

      • TAG_ICC_PROFILE

        public static final int TAG_ICC_PROFILE
        指定“ICC配置文件”标签的常量。
        另请参见：
        ICC Specification, section B.4: Embedding ICC profiles in TIFF files ， Constant Field Values

    • 方法详细信息

      • getInstance

        public static BaselineTIFFTagSet getInstance​()
        返回一个 BaselineTIFFTagSet的共享实例。
        结果
        一个 BaselineTIFFTagSet实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ExifGPSTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class ExifGPSTagSet

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFTagSet
      • javax.imageio.plugins.tiff.ExifGPSTagSet

  • public final class ExifGPSTagSet
extends TIFFTagSet
    代表在Exif GPS Info IFD中找到的标签的类。

    字段定义引用的数据类型的定义可以在TIFFTag类中找到。

    从以下版本开始：
    9
    另请参见：
    ExifTIFFTagSet

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ALTITUDE_REF_SEA_LEVEL
      与“GPSAltitudeRef”标签一起使用的值。
      static int ALTITUDE_REF_SEA_LEVEL_REFERENCE
      与“GPSAltitudeRef”标签一起使用的值。
      static String DEST_DISTANCE_REF_KILOMETERS
      与“GPSDestDistanceRef”标签一起使用的值。
      static String DEST_DISTANCE_REF_KNOTS
      与“GPSDestDistanceRef”标签一起使用的值。
      static String DEST_DISTANCE_REF_MILES
      与“GPSDestDistanceRef”标签一起使用的值。
      static int DIFFERENTIAL_CORRECTION_APPLIED
      与“GPSDifferential”标签一起使用的值。
      static int DIFFERENTIAL_CORRECTION_NONE
      与“GPSDifferential”标签一起使用的值。
      static String DIRECTION_REF_MAGNETIC
      与“GPSTrackRef”，“GPSImgDirectionRef”和“GPSDestBearingRef”标签一起使用的值。
      static String DIRECTION_REF_TRUE
      与“GPSTrackRef”，“GPSImgDirectionRef”和“GPSDestBearingRef”标签一起使用的值。
      static String GPS_VERSION_2_2
      与“GPSVersionID”标签一起使用以指示GPS版本2.2的值。
      static String LATITUDE_REF_NORTH
      与“GPSLatitudeRef”和“GPSDestLatitudeRef”标签一起使用的值。
      static String LATITUDE_REF_SOUTH
      与“GPSLatitudeRef”和“GPSDestLatitudeRef”标签一起使用的值。
      static String LONGITUDE_REF_EAST
      与“GPSLongitudeRef”和“GPSDestLongitudeRef”标签一起使用的值。
      static String LONGITUDE_REF_WEST
      与“GPSLongitudeRef”和“GPSDestLongitudeRef”标签一起使用的值。
      static String MEASURE_MODE_2D
      要与“GPSMeasureMode”标签一起使用的值。
      static String MEASURE_MODE_3D
      要与“GPSMeasureMode”标签一起使用的值。
      static String SPEED_REF_KILOMETERS_PER_HOUR
      与“GPSSpeedRef”标签一起使用的值。
      static String SPEED_REF_KNOTS
      与“GPSSpeedRef”标签一起使用的值。
      static String SPEED_REF_MILES_PER_HOUR
      与“GPSSpeedRef”标签一起使用的值。
      static String STATUS_MEASUREMENT_IN_PROGRESS
      200：200454545“
      static String STATUS_MEASUREMENT_INTEROPERABILITY
      与“GPSStatus”标签一起使用的值。
      static int TAG_GPS_ALTITUDE
      指示海拔高度（RATIONAL，count = 1）的标签。
      static int TAG_GPS_ALTITUDE_REF
      指示高度参考的标签（类型BYTE，count = 1）;
      static int TAG_GPS_AREA_INFORMATION
      指示GPS区域名称的标签（类型UNDEFINED）。
      static int TAG_GPS_DATE_STAMP
      指示GPS日期的标签（类型ASCII，计数11）。
      static int TAG_GPS_DEST_BEARING
      指示目的地轴承的标签（类型为RATIONAL，count = 1）。
      static int TAG_GPS_DEST_BEARING_REF
      指示目的地的轴承参考的标签（ASCII，count = 2）。
      static int TAG_GPS_DEST_DISTANCE
      指示与目的地的距离（类型为RATIONAL，count = 1）的标签。
      static int TAG_GPS_DEST_DISTANCE_REF
      指示距离目的地的参考的标签（ASCII，count = 2）。
      static int TAG_GPS_DEST_LATITUDE
      指示目的地纬度的标签（类型为RATIONAL，count = 3）。
      static int TAG_GPS_DEST_LATITUDE_REF
      指示目的地纬度参考的标签（ASCII，count = 2）。
      static int TAG_GPS_DEST_LONGITUDE
      指示目的地经度的标签（类型为RATIONAL，count = 3）。
      static int TAG_GPS_DEST_LONGITUDE_REF
      指示目的地经度参考的标签（ASCII，count = 2）。
      static int TAG_GPS_DIFFERENTIAL
      指示GPS差分校正的标签（类型SHORT，计数= 1）。
      static int TAG_GPS_DOP
      指示测量精度的标签（类型RATIONAL，count = 1）。
      static int TAG_GPS_IMG_DIRECTION
      指示图像方向的标签（类型为RATIONAL，count = 1）。
      static int TAG_GPS_IMG_DIRECTION_REF
      指示图像方向参考的标签（ASCII，count = 2）。
      static int TAG_GPS_LATITUDE
      指示纬度（RATIONAL，count = 3）的标签。
      static int TAG_GPS_LATITUDE_REF
      指示北纬或南纬的标签（ASCII，count = 2）。
      static int TAG_GPS_LONGITUDE
      指示经度的标签（类型为RATIONAL，count = 3）。
      static int TAG_GPS_LONGITUDE_REF
      表示东经或西经的标签（ASCII，count = 2）。
      static int TAG_GPS_MAP_DATUM
      指示使用大地测量数据的标签（ASCII码）。
      static int TAG_GPS_MEASURE_MODE
      指示GPS测量模式的标签（ASCII，count = 2）。
      static int TAG_GPS_PROCESSING_METHOD
      指示GPS处理方法名称的标签（类型UNDEFINED）。
      static int TAG_GPS_SATELLITES
      指示用于测量的GPS卫星的标签（ASCII码）。
      static int TAG_GPS_SPEED
      指示GPS接收机速度的标签（类型为RATIONAL，count = 1）。
      static int TAG_GPS_SPEED_REF
      指示速度单位的标签（ASCII，count = 2）。
      static int TAG_GPS_STATUS
      指示GPS接收器状态的标签（ASCII，count = 2）。
      static int TAG_GPS_TIME_STAMP
      指示GPS时间（原子钟）（RATIONAL，count = 3）的标签。
      static int TAG_GPS_TRACK
      指示移动方向的标签（类型为RATIONAL，count = 1）。
      static int TAG_GPS_TRACK_REF
      指示移动方向参考的标签（ASCII，count = 2）。
      static int TAG_GPS_VERSION_ID
      指示GPS标签版本的标签（类型BYTE，计数= 4）。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ExifGPSTagSet getInstance​()
      返回一个 ExifGPSTagSet的共享实例。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.imageio.plugins.tiff.TIFFTagSet

        getTag, getTag, getTagNames, getTagNumbers

    • 字段详细信息

      • TAG_GPS_VERSION_ID

        public static final int TAG_GPS_VERSION_ID
        指示GPS标签版本的标签（类型BYTE，计数= 4）。
        另请参见：
        GPS_VERSION_2_2 ， Constant Field Values

      • GPS_VERSION_2_2

        public static final String GPS_VERSION_2_2
        与“GPSVersionID”标签一起使用以指示GPS版本2.2的值。 该值等于字节数组{'2', '2', '0', '0'}的US-ASCII编码。
        另请参见：
        TAG_GPS_VERSION_ID ， Constant Field Values

      • TAG_GPS_LATITUDE_REF

        public static final int TAG_GPS_LATITUDE_REF
        指示北纬或南纬的标签（ASCII，count = 2）。
        另请参见：
        LATITUDE_REF_NORTH ， LATITUDE_REF_SOUTH ， Constant Field Values

      • TAG_GPS_LATITUDE

        public static final int TAG_GPS_LATITUDE
        指示纬度（RATIONAL，count = 3）的标签。
        另请参见：
        Constant Field Values

      • TAG_GPS_LONGITUDE_REF

        public static final int TAG_GPS_LONGITUDE_REF
        表示东经或西经的标签（ASCII，count = 2）。
        另请参见：
        LONGITUDE_REF_EAST ， LONGITUDE_REF_WEST ， Constant Field Values

      • TAG_GPS_LONGITUDE

        public static final int TAG_GPS_LONGITUDE
        指示经度的标签（类型为RATIONAL，count = 3）。
        另请参见：
        Constant Field Values

      • TAG_GPS_ALTITUDE_REF

        public static final int TAG_GPS_ALTITUDE_REF
        指示高度参考的标签（类型BYTE，count = 1）;
        另请参见：
        ALTITUDE_REF_SEA_LEVEL ， ALTITUDE_REF_SEA_LEVEL_REFERENCE ， Constant Field Values

      • TAG_GPS_ALTITUDE

        public static final int TAG_GPS_ALTITUDE
        指示海拔高度（RATIONAL，count = 1）的标签。
        另请参见：
        Constant Field Values

      • TAG_GPS_TIME_STAMP

        public static final int TAG_GPS_TIME_STAMP
        指示GPS时间（原子钟）（RATIONAL，count = 3）的标签。
        另请参见：
        Constant Field Values

      • TAG_GPS_SATELLITES

        public static final int TAG_GPS_SATELLITES
        指示用于测量的GPS卫星的标签（ASCII码）。
        另请参见：
        Constant Field Values

      • TAG_GPS_STATUS

        public static final int TAG_GPS_STATUS
        指示GPS接收器状态的标签（ASCII，count = 2）。
        另请参见：
        STATUS_MEASUREMENT_IN_PROGRESS ， STATUS_MEASUREMENT_INTEROPERABILITY ， Constant Field Values

      • TAG_GPS_MEASURE_MODE

        public static final int TAG_GPS_MEASURE_MODE
        指示GPS测量模式的标签（ASCII，count = 2）。
        另请参见：
        MEASURE_MODE_2D ， MEASURE_MODE_3D ， Constant Field Values

      • TAG_GPS_DOP

        public static final int TAG_GPS_DOP
        指示测量精度的标签（类型RATIONAL，count = 1）。
        另请参见：
        Constant Field Values

      • TAG_GPS_SPEED_REF

        public static final int TAG_GPS_SPEED_REF
        指示速度单位的标签（ASCII，count = 2）。
        另请参见：
        SPEED_REF_KILOMETERS_PER_HOUR ， SPEED_REF_MILES_PER_HOUR ， SPEED_REF_KNOTS ， Constant Field Values

      • TAG_GPS_SPEED

        public static final int TAG_GPS_SPEED
        指示GPS接收机速度的标签（类型为RATIONAL，count = 1）。
        另请参见：
        Constant Field Values

      • TAG_GPS_TRACK_REF

        public static final int TAG_GPS_TRACK_REF
        指示移动方向参考的标签（ASCII，count = 2）。
        另请参见：
        DIRECTION_REF_TRUE ， DIRECTION_REF_MAGNETIC ， Constant Field Values

      • TAG_GPS_TRACK

        public static final int TAG_GPS_TRACK
        指示移动方向的标签（类型为RATIONAL，count = 1）。
        另请参见：
        Constant Field Values

      • TAG_GPS_IMG_DIRECTION_REF

        public static final int TAG_GPS_IMG_DIRECTION_REF
        指示图像方向参考的标签（ASCII，count = 2）。
        另请参见：
        DIRECTION_REF_TRUE ， DIRECTION_REF_MAGNETIC ， Constant Field Values

      • TAG_GPS_IMG_DIRECTION

        public static final int TAG_GPS_IMG_DIRECTION
        指示图像方向的标签（类型为RATIONAL，count = 1）。
        另请参见：
        Constant Field Values

      • TAG_GPS_MAP_DATUM

        public static final int TAG_GPS_MAP_DATUM
        指示使用大地测量数据的标签（ASCII码）。
        另请参见：
        Constant Field Values

      • TAG_GPS_DEST_LATITUDE_REF

        public static final int TAG_GPS_DEST_LATITUDE_REF
        指示目的地纬度参考的标签（ASCII，count = 2）。
        另请参见：
        LATITUDE_REF_NORTH ， LATITUDE_REF_SOUTH ， Constant Field Values

      • TAG_GPS_DEST_LATITUDE

        public static final int TAG_GPS_DEST_LATITUDE
        指示目的地纬度的标签（类型为RATIONAL，count = 3）。
        另请参见：
        Constant Field Values

      • TAG_GPS_DEST_LONGITUDE_REF

        public static final int TAG_GPS_DEST_LONGITUDE_REF
        指示目的地经度参考的标签（ASCII，count = 2）。
        另请参见：
        LONGITUDE_REF_EAST ， LONGITUDE_REF_WEST ， Constant Field Values

      • TAG_GPS_DEST_LONGITUDE

        public static final int TAG_GPS_DEST_LONGITUDE
        指示目的地经度的标签（类型为RATIONAL，count = 3）。
        另请参见：
        Constant Field Values

      • TAG_GPS_DEST_BEARING_REF

        public static final int TAG_GPS_DEST_BEARING_REF
        指示目的地的轴承参考的标签（ASCII，count = 2）。
        另请参见：
        DIRECTION_REF_TRUE ， DIRECTION_REF_MAGNETIC ， Constant Field Values

      • TAG_GPS_DEST_BEARING

        public static final int TAG_GPS_DEST_BEARING
        指示目的地轴承的标签（类型为RATIONAL，count = 1）。
        另请参见：
        Constant Field Values

      • TAG_GPS_DEST_DISTANCE_REF

        public static final int TAG_GPS_DEST_DISTANCE_REF
        指示距离目的地的参考的标签（ASCII，count = 2）。
        另请参见：
        DEST_DISTANCE_REF_KILOMETERS ， DEST_DISTANCE_REF_MILES ， DEST_DISTANCE_REF_KNOTS ， Constant Field Values

      • TAG_GPS_DEST_DISTANCE

        public static final int TAG_GPS_DEST_DISTANCE
        指示与目的地的距离（类型为RATIONAL，count = 1）的标签。
        另请参见：
        Constant Field Values

      • TAG_GPS_PROCESSING_METHOD

        public static final int TAG_GPS_PROCESSING_METHOD
        指示GPS处理方法名称的标签（类型UNDEFINED）。
        另请参见：
        Constant Field Values

      • TAG_GPS_AREA_INFORMATION

        public static final int TAG_GPS_AREA_INFORMATION
        指示GPS区域名称的标签（类型UNDEFINED）。
        另请参见：
        Constant Field Values

      • TAG_GPS_DATE_STAMP

        public static final int TAG_GPS_DATE_STAMP
        指示GPS日期的标签（类型ASCII，计数11）。
        另请参见：
        Constant Field Values

      • TAG_GPS_DIFFERENTIAL

        public static final int TAG_GPS_DIFFERENTIAL
        指示GPS差分校正的标签（类型SHORT，计数= 1）。
        另请参见：
        DIFFERENTIAL_CORRECTION_NONE ， DIFFERENTIAL_CORRECTION_APPLIED ， Constant Field Values

      • LATITUDE_REF_NORTH

        public static final String LATITUDE_REF_NORTH
        与“GPSLatitudeRef”和“GPSDestLatitudeRef”标签一起使用的值。
        另请参见：
        TAG_GPS_LATITUDE_REF ， TAG_GPS_DEST_LATITUDE_REF ， Constant Field Values

      • LATITUDE_REF_SOUTH

        public static final String LATITUDE_REF_SOUTH
        与“GPSLatitudeRef”和“GPSDestLatitudeRef”标签一起使用的值。
        另请参见：
        TAG_GPS_LATITUDE_REF ， TAG_GPS_DEST_LATITUDE_REF ， Constant Field Values

      • LONGITUDE_REF_EAST

        public static final String LONGITUDE_REF_EAST
        与“GPSLongitudeRef”和“GPSDestLongitudeRef”标签一起使用的值。
        另请参见：
        TAG_GPS_LONGITUDE_REF ， TAG_GPS_DEST_LONGITUDE_REF ， Constant Field Values

      • LONGITUDE_REF_WEST

        public static final String LONGITUDE_REF_WEST
        与“GPSLongitudeRef”和“GPSDestLongitudeRef”标签一起使用的值。
        另请参见：
        TAG_GPS_LONGITUDE_REF ， TAG_GPS_DEST_LONGITUDE_REF ， Constant Field Values

      • ALTITUDE_REF_SEA_LEVEL

        public static final int ALTITUDE_REF_SEA_LEVEL
        与“GPSAltitudeRef”标签一起使用的值。
        另请参见：
        TAG_GPS_ALTITUDE_REF ， Constant Field Values

      • ALTITUDE_REF_SEA_LEVEL_REFERENCE

        public static final int ALTITUDE_REF_SEA_LEVEL_REFERENCE
        与“GPSAltitudeRef”标签一起使用的值。
        另请参见：
        TAG_GPS_ALTITUDE_REF ， Constant Field Values

      • STATUS_MEASUREMENT_IN_PROGRESS

        public static final String STATUS_MEASUREMENT_IN_PROGRESS
        200：200454545“
        另请参见：
        TAG_GPS_STATUS ， Constant Field Values

      • STATUS_MEASUREMENT_INTEROPERABILITY

        public static final String STATUS_MEASUREMENT_INTEROPERABILITY
        200：200454545“
        另请参见：
        TAG_GPS_STATUS ， Constant Field Values

      • MEASURE_MODE_2D

        public static final String MEASURE_MODE_2D
        要与“GPSMeasureMode”标签一起使用的值。
        另请参见：
        TAG_GPS_MEASURE_MODE ， Constant Field Values

      • MEASURE_MODE_3D

        public static final String MEASURE_MODE_3D
        要与“GPSMeasureMode”标签一起使用的值。
        另请参见：
        TAG_GPS_MEASURE_MODE ， Constant Field Values

      • SPEED_REF_KILOMETERS_PER_HOUR

        public static final String SPEED_REF_KILOMETERS_PER_HOUR
        与“GPSSpeedRef”标签一起使用的值。
        另请参见：
        TAG_GPS_SPEED_REF ， Constant Field Values

      • SPEED_REF_MILES_PER_HOUR

        public static final String SPEED_REF_MILES_PER_HOUR
        与“GPSSpeedRef”标签一起使用的值。
        另请参见：
        TAG_GPS_SPEED_REF ， Constant Field Values

      • SPEED_REF_KNOTS

        public static final String SPEED_REF_KNOTS
        与“GPSSpeedRef”标签一起使用的值。
        另请参见：
        TAG_GPS_SPEED_REF ， Constant Field Values

      • DIRECTION_REF_TRUE

        public static final String DIRECTION_REF_TRUE
        与“GPSTrackRef”，“GPSImgDirectionRef”和“GPSDestBearingRef”标签一起使用的值。
        另请参见：
        TAG_GPS_TRACK_REF ， TAG_GPS_IMG_DIRECTION_REF ， TAG_GPS_DEST_BEARING_REF ， Constant Field Values

      • DIRECTION_REF_MAGNETIC

        public static final String DIRECTION_REF_MAGNETIC
        与“GPSTrackRef”，“GPSImgDirectionRef”和“GPSDestBearingRef”标签一起使用的值。
        另请参见：
        TAG_GPS_TRACK_REF ， TAG_GPS_IMG_DIRECTION_REF ， TAG_GPS_DEST_BEARING_REF ， Constant Field Values

      • DEST_DISTANCE_REF_KILOMETERS

        public static final String DEST_DISTANCE_REF_KILOMETERS
        与“GPSDestDistanceRef”标签一起使用的值。
        另请参见：
        TAG_GPS_DEST_DISTANCE_REF ， Constant Field Values

      • DEST_DISTANCE_REF_MILES

        public static final String DEST_DISTANCE_REF_MILES
        与“GPSDestDistanceRef”标签一起使用的值。
        另请参见：
        TAG_GPS_DEST_DISTANCE_REF ， Constant Field Values

      • DEST_DISTANCE_REF_KNOTS

        public static final String DEST_DISTANCE_REF_KNOTS
        与“GPSDestDistanceRef”标签一起使用的值。
        另请参见：
        TAG_GPS_DEST_DISTANCE_REF ， Constant Field Values

      • DIFFERENTIAL_CORRECTION_NONE

        public static final int DIFFERENTIAL_CORRECTION_NONE
        与“GPSDifferential”标签一起使用的值。
        另请参见：
        TAG_GPS_DIFFERENTIAL ， Constant Field Values

      • DIFFERENTIAL_CORRECTION_APPLIED

        public static final int DIFFERENTIAL_CORRECTION_APPLIED
        与“GPSDifferential”标签一起使用的值。
        另请参见：
        TAG_GPS_DIFFERENTIAL ， Constant Field Values

    • 方法详细信息

      • getInstance

        public static ExifGPSTagSet getInstance​()
        返回一个 ExifGPSTagSet的共享实例。
        结果
        一个 ExifGPSTagSet例子。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ExifInteroperabilityTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class ExifInteroperabilityTagSet

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFTagSet
      • javax.imageio.plugins.tiff.ExifInteroperabilityTagSet

  • public final class ExifInteroperabilityTagSet
extends TIFFTagSet
    代表在Exif互操作性IFD中找到的标签的类。
    从以下版本开始：
    9
    另请参见：
    ExifTIFFTagSet

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String INTEROPERABILITY_INDEX_R98
      要与“InteroperabilityIndex”标签一起使用的值。
      static String INTEROPERABILITY_INDEX_THM
      要与“InteroperabilityIndex”标签一起使用的值。
      static int TAG_INTEROPERABILITY_INDEX
      指示互操作性规则（ASCII类型）的标识的标签。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ExifInteroperabilityTagSet getInstance​()
      返回共享实例 ExifInteroperabilityTagSet 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.imageio.plugins.tiff.TIFFTagSet

        getTag, getTag, getTagNames, getTagNumbers

    • 字段详细信息

      • TAG_INTEROPERABILITY_INDEX

        public static final int TAG_INTEROPERABILITY_INDEX
        指示互操作性规则（ASCII类型）的标识的标签。
        另请参见：
        INTEROPERABILITY_INDEX_R98 ， INTEROPERABILITY_INDEX_THM ， Constant Field Values

      • INTEROPERABILITY_INDEX_R98

        public static final String INTEROPERABILITY_INDEX_R98
        要与“InteroperabilityIndex”标签一起使用的值。 表示符合推荐Exif互操作性规则（ExifR98）的R98文件规范的文件，或指定为相机文件系统的设计规则（ASCII类型）规定的DCF基本文件。
        另请参见：
        TAG_INTEROPERABILITY_INDEX ， Constant Field Values

      • INTEROPERABILITY_INDEX_THM

        public static final String INTEROPERABILITY_INDEX_THM
        要与“InteroperabilityIndex”标签一起使用的值。 表示符合“摄像机文件系统设计规则”（Type ASCII）规定的DCF缩略图文件的文件。
        另请参见：
        TAG_INTEROPERABILITY_INDEX ， Constant Field Values

    • 方法详细信息

      • getInstance

        public static ExifInteroperabilityTagSet getInstance​()
        返回共享实例 ExifInteroperabilityTagSet 。
        结果
        ExifInteroperabilityTagSet实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ExifParentTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class ExifParentTIFFTagSet

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFTagSet
      • javax.imageio.plugins.tiff.ExifParentTIFFTagSet

  • public final class ExifParentTIFFTagSet
extends TIFFTagSet
    包含用于引用Exif和GPS IFD的TIFF标签的类。 如果需要Exif支持，则应该通过TIFFImageReadParam.addAllowedTagSet方法将该标签集添加到根标签集中。
    从以下版本开始：
    9

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TAG_EXIF_IFD_POINTER
      标签指向Exif IFD（类型LONG）。
      static int TAG_GPS_INFO_IFD_POINTER
      标签指向GPS信息IFD（类型LONG）。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ExifParentTIFFTagSet getInstance​()
      返回一个 ExifParentTIFFTagSet的共享实例。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.imageio.plugins.tiff.TIFFTagSet

        getTag, getTag, getTagNames, getTagNumbers

    • 字段详细信息

      • TAG_EXIF_IFD_POINTER

        public static final int TAG_EXIF_IFD_POINTER
        标签指向Exif IFD（类型LONG）。
        另请参见：
        Constant Field Values

      • TAG_GPS_INFO_IFD_POINTER

        public static final int TAG_GPS_INFO_IFD_POINTER
        标签指向GPS信息IFD（类型LONG）。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getInstance

        public static ExifParentTIFFTagSet getInstance​()
        返回一个 ExifParentTIFFTagSet的共享实例。
        结果
        一个 ExifParentTIFFTagSet实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ExifTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class ExifTIFFTagSet

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFTagSet
      • javax.imageio.plugins.tiff.ExifTIFFTagSet

  • public final class ExifTIFFTagSet
extends TIFFTagSet
    代表在Exif IFD中找到的标签的类。 Exif是用于注释大多数数码相机制造商使用的图像的标准。 Exif规范可以在http://www.exif.org/Exif2-2.PDF找到。

    字段定义引用的数据类型的定义可以在TIFFTag类中找到。

    从以下版本开始：
    9

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int COLOR_SPACE_SRGB
      与“ColorSpace”标签一起使用的值。
      static int COLOR_SPACE_UNCALIBRATED
      与“ColorSpace”标签一起使用的值。
      static int COMPONENTS_CONFIGURATION_B
      要与“ComponentsConfiguration”标签一起使用的值。
      static int COMPONENTS_CONFIGURATION_CB
      要与“ComponentsConfiguration”标签一起使用的值。
      static int COMPONENTS_CONFIGURATION_CR
      要与“ComponentsConfiguration”标签一起使用的值。
      static int COMPONENTS_CONFIGURATION_DOES_NOT_EXIST
      要与“ComponentsConfiguration”标签一起使用的值。
      static int COMPONENTS_CONFIGURATION_G
      要与“ComponentsConfiguration”标签一起使用的值。
      static int COMPONENTS_CONFIGURATION_R
      要与“ComponentsConfiguration”标签一起使用的值。
      static int COMPONENTS_CONFIGURATION_Y
      要与“ComponentsConfiguration”标签一起使用的值。
      static int CONTRAST_HARD
      与“对比度”标签一起使用的值。
      static int CONTRAST_NORMAL
      与“对比度”标签一起使用的值。
      static int CONTRAST_SOFT
      与“对比度”标签一起使用的值。
      static int CUSTOM_RENDERED_CUSTOM
      与“CustomRendered”标签一起使用的值。
      static int CUSTOM_RENDERED_NORMAL
      与“CustomRendered”标签一起使用的值。
      static String EXIF_VERSION_2_1
      要与ExifVersion标签一起使用的值来表示Exif版本2.1。
      static String EXIF_VERSION_2_2
      要与ExifVersion标签一起使用以指示Exif版本2.2的值。
      static int EXPOSURE_MODE_AUTO_BRACKET
      与“ExposureMode”标签一起使用的值。
      static int EXPOSURE_MODE_AUTO_EXPOSURE
      与“ExposureMode”标签一起使用的值。
      static int EXPOSURE_MODE_MANUAL_EXPOSURE
      与“ExposureMode”标签一起使用的值。
      static int EXPOSURE_PROGRAM_ACTION_PROGRAM
      与“ExposureProgram”标签一起使用的值。
      static int EXPOSURE_PROGRAM_APERTURE_PRIORITY
      与“ExposureProgram”标签一起使用的值。
      static int EXPOSURE_PROGRAM_CREATIVE_PROGRAM
      与“ExposureProgram”标签一起使用的值。
      static int EXPOSURE_PROGRAM_LANDSCAPE_MODE
      与“ExposureProgram”标签一起使用的值。
      static int EXPOSURE_PROGRAM_MANUAL
      与“ExposureProgram”标签一起使用的值。
      static int EXPOSURE_PROGRAM_MAX_RESERVED
      与“ExposureProgram”标签一起使用的值。
      static int EXPOSURE_PROGRAM_NORMAL_PROGRAM
      与“ExposureProgram”标签一起使用的值。
      static int EXPOSURE_PROGRAM_NOT_DEFINED
      与“ExposureProgram”标签一起使用的值。
      static int EXPOSURE_PROGRAM_PORTRAIT_MODE
      与“ExposureProgram”标签一起使用的值。
      static int EXPOSURE_PROGRAM_SHUTTER_PRIORITY
      与“ExposureProgram”标签一起使用的值。
      static int FILE_SOURCE_DSC
      与“FileSource”标签一起使用的值。
      static int FLASH_DID_NOT_FIRE
      与“Flash”标签一起使用的值，表示闪光灯未触发。
      static int FLASH_FIRED
      与“Flash”标签一起使用的值，表示闪光灯闪光，但闪光灯返回状态未知。
      static int FLASH_MASK_FIRED
      一个与“Flash”标签一起使用的面具，表示闪光灯闪光。
      static int FLASH_MASK_FUNCTION_NOT_PRESENT
      与“Flash”标签一起使用的掩码，表示不存在闪光灯功能。
      static int FLASH_MASK_MODE_AUTO
      与“Flash”标签一起使用的掩码，表示自动模式。
      static int FLASH_MASK_MODE_FLASH_FIRING
      与“Flash”标签一起使用的面具，表示强制闪光灯闪光模式。
      static int FLASH_MASK_MODE_FLASH_SUPPRESSION
      与“Flash”标签一起使用的掩码，表示强制闪存抑制模式。
      static int FLASH_MASK_RED_EYE_REDUCTION
      与“Flash”标签一起使用的面具，表示支持红眼。
      static int FLASH_MASK_RETURN_DETECTED
      与“Flash”标签一起使用的掩码，指示检测到闪光灯返回光。
      static int FLASH_MASK_RETURN_NOT_DETECTED
      与“Flash”标签一起使用的掩码，指示未检测到闪光灯返回光。
      static int FLASH_STROBE_RETURN_LIGHT_DETECTED
      与“Flash”标签一起使用的值，表示闪光灯闪烁，并检测到闪光灯返回光。
      static int FLASH_STROBE_RETURN_LIGHT_NOT_DETECTED
      与“Flash”标签一起使用的值，表示闪光灯闪光，但没有检测到闪光灯返回光。
      static int FOCAL_PLANE_RESOLUTION_UNIT_CENTIMETER
      与“FocalPlaneXResolution”标签一起使用的值。
      static int FOCAL_PLANE_RESOLUTION_UNIT_INCH
      与“FocalPlaneXResolution”标签一起使用的值。
      static int FOCAL_PLANE_RESOLUTION_UNIT_NONE
      要与“FocalPlaneResolutionUnit”标签一起使用的值。
      static int GAIN_CONTROL_HIGH_GAIN_DOWN
      与“GainControl”标签一起使用的值。
      static int GAIN_CONTROL_HIGH_GAIN_UP
      与“GainControl”标签一起使用的值。
      static int GAIN_CONTROL_LOW_GAIN_DOWN
      与“GainControl”标签一起使用的值。
      static int GAIN_CONTROL_LOW_GAIN_UP
      与“GainControl”标签一起使用的值。
      static int GAIN_CONTROL_NONE
      与“GainControl”标签一起使用的值。
      static int LIGHT_SOURCE_CLOUDY_WEATHER
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_COOL_WHITE_FLUORESCENT
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_D50
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_D55
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_D65
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_D75
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_DAY_WHITE_FLUORESCENT
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_DAYLIGHT
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_DAYLIGHT_FLUORESCENT
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_FINE_WEATHER
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_FLASH
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_FLUORESCENT
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_ISO_STUDIO_TUNGSTEN
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_OTHER
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_SHADE
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_STANDARD_LIGHT_A
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_STANDARD_LIGHT_B
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_STANDARD_LIGHT_C
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_TUNGSTEN
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_UNKNOWN
      与“LightSource”标签一起使用的值。
      static int LIGHT_SOURCE_WHITE_FLUORESCENT
      与“LightSource”标签一起使用的值。
      static int METERING_MODE_AVERAGE
      与“MeteringMode”标签一起使用的值。
      static int METERING_MODE_CENTER_WEIGHTED_AVERAGE
      与“MeteringMode”标签一起使用的值。
      static int METERING_MODE_MAX_RESERVED
      与“MeteringMode”标签一起使用的值。
      static int METERING_MODE_MIN_RESERVED
      与“MeteringMode”标签一起使用的值。
      static int METERING_MODE_MULTI_SPOT
      与“MeteringMode”标签一起使用的值。
      static int METERING_MODE_OTHER
      与“MeteringMode”标签一起使用的值。
      static int METERING_MODE_PARTIAL
      与“MeteringMode”标签一起使用的值。
      static int METERING_MODE_PATTERN
      与“MeteringMode”标签一起使用的值。
      static int METERING_MODE_SPOT
      与“MeteringMode”标签一起使用的值。
      static int METERING_MODE_UNKNOWN
      与“MeteringMode”标签一起使用的值。
      static int SATURATION_HIGH
      新新200的X- 200 X- 200 200 X- 200 200：
      static int SATURATION_LOW
      新新200的X- 200 X- 200 200 X- 200 200：
      static int SATURATION_NORMAL
      新新200的X- 200 X- 200 200 X- 200 200：
      static int SCENE_CAPTURE_TYPE_LANDSCAPE
      要与“SceneCaptureType”标签一起使用的值。
      static int SCENE_CAPTURE_TYPE_NIGHT_SCENE
      要与“SceneCaptureType”标签一起使用的值。
      static int SCENE_CAPTURE_TYPE_PORTRAIT
      要与“SceneCaptureType”标签一起使用的值。
      static int SCENE_CAPTURE_TYPE_STANDARD
      要与“SceneCaptureType”标签一起使用的值。
      static int SCENE_TYPE_DSC
      要与“SceneType”标签一起使用的值。
      static int SENSING_METHOD_COLOR_SEQUENTIAL_AREA_SENSOR
      与“SensingMethod”标签一起使用的值。
      static int SENSING_METHOD_COLOR_SEQUENTIAL_LINEAR_SENSOR
      与“SensingMethod”标签一起使用的值。
      static int SENSING_METHOD_NOT_DEFINED
      与“SensingMethod”标签一起使用的值。
      static int SENSING_METHOD_ONE_CHIP_COLOR_AREA_SENSOR
      与“SensingMethod”标签一起使用的值。
      static int SENSING_METHOD_THREE_CHIP_COLOR_AREA_SENSOR
      与“SensingMethod”标签一起使用的值。
      static int SENSING_METHOD_TRILINEAR_SENSOR
      与“SensingMethod”标签一起使用的值。
      static int SENSING_METHOD_TWO_CHIP_COLOR_AREA_SENSOR
      与“SensingMethod”标签一起使用的值。
      static int SHARPNESS_HARD
      与“Sharpness”标签一起使用的值。
      static int SHARPNESS_NORMAL
      与“Sharpness”标签一起使用的值。
      static int SHARPNESS_SOFT
      与“Sharpness”标签一起使用的值。
      static int SUBJECT_DISTANCE_RANGE_CLOSE_VIEW
      与“SubjectDistanceRange”标签一起使用的值。
      static int SUBJECT_DISTANCE_RANGE_DISTANT_VIEW
      与“SubjectDistanceRange”标签一起使用的值。
      static int SUBJECT_DISTANCE_RANGE_MACRO
      与“SubjectDistanceRange”标签一起使用的值。
      static int SUBJECT_DISTANCE_RANGE_UNKNOWN
      与“SubjectDistanceRange”标签一起使用的值。
      static int TAG_APERTURE_VALUE
      指示镜头光圈的标签（类型RATIONAL）。
      static int TAG_BRIGHTNESS_VALUE
      指示亮度值的标签（类型SRATIONAL）。
      static int TAG_CFA_PATTERN
      指示当使用单芯片彩色区域传感器（类型UNDEFINED）时图像传感器的滤色器阵列几何图案的标签。
      static int TAG_COLOR_SPACE
      指示颜色空间信息的标签（类型为SHORT）。
      static int TAG_COMPONENTS_CONFIGURATION
      包含组件配置信息（类型UNDEFINED，count = 4）的标签。
      static int TAG_COMPRESSED_BITS_PER_PIXEL
      指示每像素的压缩比特数的标签（类型RATIONAL）。
      static int TAG_CONTRAST
      指示拍摄图像时由相机应用的对比度处理方向的标签。
      static int TAG_CUSTOM_RENDERED
      指示对图像数据使用特殊处理的标签，例如用于输出的渲染。
      static int TAG_DATE_TIME_DIGITIZED
      指示图像作为数字数据存储的日期和时间的标签（ASCII类型）。
      static int TAG_DATE_TIME_ORIGINAL
      指示生成原始图像的日期和时间的标签（ASCII码）。
      static int TAG_DEVICE_SETTING_DESCRIPTION
      指示特定相机模型的拍摄条件的信息的标签。
      static int TAG_DIGITAL_ZOOM_RATIO
      指示拍摄图像时的数码变焦比的标签。
      static int TAG_EXIF_VERSION
      包含Exif版本号（类型UNDEFINED，count = 4）的标签。
      static int TAG_EXPOSURE_BIAS_VALUE
      指示曝光偏差的标签（类型SRATIONAL）。
      static int TAG_EXPOSURE_INDEX
      指示在拍摄图像时在相机或输入设备上选择的曝光指数的标签（类型为RATIONAL）的标签。
      static int TAG_EXPOSURE_MODE
      指示拍摄图像时设置的曝光模式的标签。
      static int TAG_EXPOSURE_PROGRAM
      指示拍摄照片时用于设置曝光的节目类别的标签（类型为SHORT）。
      static int TAG_EXPOSURE_TIME
      指示曝光时间的标签（以秒为单位）（类型为RATIONAL）。
      static int TAG_F_NUMBER
      指示F数字的标签（类型RATIONAL）。
      static int TAG_FILE_SOURCE
      指示图像源（类型UNDEFINED）的标签。
      static int TAG_FLASH
      指示闪光灯闪光状态和闪光灯返回状态的标签（类型为SHORT）。
      static int TAG_FLASH_ENERGY
      指示拍摄图像时的频闪能量的标签，如“光束功率秒（BCPS）”（类型RATIONAL）所测量。
      static int TAG_FLASHPIX_VERSION
      指示FlashPix版本号（类型UNDEFINED，count = 4）的标签。
      static int TAG_FOCAL_LENGTH
      指示透镜实际焦距的标签，单位为毫米（类型为RATIONAL）。
      static int TAG_FOCAL_LENGTH_IN_35MM_FILM
      一个标签表示等效焦距，假设为35mm胶片相机，单位为毫米。
      static int TAG_FOCAL_PLANE_RESOLUTION_UNIT
      表示测量FocalPlaneXResolution和FocalPlaneYResolution（键入SHORT）的单位。
      static int TAG_FOCAL_PLANE_X_RESOLUTION
      指示相机焦平面上的每个FocalPlaneResolutionUnit的图像宽度（X）方向上的像素数（类型为RATIONAL）。
      static int TAG_FOCAL_PLANE_Y_RESOLUTION
      指示相机焦平面上的每个FocalPlaneResolutionUnit的图像高度（Y）方向上的像素数（类型为RATIONAL）。
      static int TAG_GAIN_CONTROL
      指示整体图像增益调整程度的标签。
      static int TAG_GPS_INFO_IFD_POINTER
      指向GPS信息IFD（类型LONG）的标签。
      static int TAG_IMAGE_UNIQUE_ID
      指示为每个图像唯一地分配的标识符的标签。
      static int TAG_INTEROPERABILITY_IFD_POINTER
      指向互操作性IFD（类型LONG）的标签。
      static int TAG_ISO_SPEED_RATINGS
      指示ISO 12232 xiv （类型SHORT）中规定的相机或输入设备的ISO感光度和ISO纬度的标签。
      static int TAG_LIGHT_SOURCE
      指示光源类型的标签（类型为SHORT）。
      static int TAG_MAKER_NOTE
      指示制造商定义的制造商注释（类型UNDEFINED）的标签。
      static int TAG_MARKER_NOTE
      指示制造商定义的标记笔记（类型UNDEFINED）的标签。
      static int TAG_MAX_APERTURE_VALUE
      指示镜头最小F数的标签（类型RATIONAL）。
      static int TAG_METERING_MODE
      指示测光模式的标签（类型为SHORT）。
      static int TAG_OECF
      指示ISO 14254 xv （类型UNDEFINED）中规定的光电转换功能的标签。
      static int TAG_PIXEL_X_DIMENSION
      指示像素X尺寸的标签（类型为SHORT或LONG）。
      static int TAG_PIXEL_Y_DIMENSION
      指示像素Y尺寸的标签（类型为SHORT或LONG）。
      static int TAG_RELATED_SOUND_FILE
      指示相关声音文件名称的标签（类型为ASCII）。
      static int TAG_SATURATION
      指示拍摄图像时照相机应用的饱和度处理方向的标签。
      static int TAG_SCENE_CAPTURE_TYPE
      指示被拍摄的场景的类型的标签。
      static int TAG_SCENE_TYPE
      指示场景类型的标签（UNDEFINED类型）。
      static int TAG_SENSING_METHOD
      指示相机或输入设备上传感器类型的标签（类型为SHORT）。
      static int TAG_SHARPNESS
      指示当拍摄图像时由照相机应用的清晰度处理的方向的标签。
      static int TAG_SHUTTER_SPEED_VALUE
      指示快门速度的标签（类型SRATIONAL）。
      static int TAG_SPATIAL_FREQUENCY_RESPONSE
      根据ISO 12233 xvi （类型UNDEFINED）中指定的指示照相机或输入设备空间频率表和图像宽度，图像高度和对角线方向方向上的SFR值的标签。
      static int TAG_SPECTRAL_SENSITIVITY
      指示所使用的相机的每个通道的光谱灵敏度的标签（类型ASCII）。
      static int TAG_SUB_SEC_TIME
      用于记录“DateTime”标签（ASCII类型）的秒数的标签。
      static int TAG_SUB_SEC_TIME_DIGITIZED
      用于记录“DateTimeDigitized”标签（ASCII类型）的秒数的标签。
      static int TAG_SUB_SEC_TIME_ORIGINAL
      用于记录“DateTimeOriginal”标记（ASCII类型）的秒数的标签。
      static int TAG_SUBJECT_AREA
      指示整个场景中主要被摄体的位置和面积的标签。
      static int TAG_SUBJECT_DISTANCE
      指示与被摄体距离的标签，以米为单位（类型为RATIONAL）。
      static int TAG_SUBJECT_DISTANCE_RANGE
      指示与被摄体距离的标签。
      static int TAG_SUBJECT_LOCATION
      指示场景中主要被摄体的中心像素的列和行的标签（类型SHORT，count = 2）。
      static int TAG_USER_COMMENT
      指示用户评论的标签（类型UNDEFINED）。
      static int TAG_WHITE_BALANCE
      指示拍摄图像时设置的白平衡模式的标签。
      static int WHITE_BALANCE_AUTO
      要与“WhiteBalance”标签一起使用的值。
      static int WHITE_BALANCE_MANUAL
      要与“WhiteBalance”标签一起使用的值。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ExifTIFFTagSet getInstance​()
      返回一个 ExifTIFFTagSet的共享实例。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.imageio.plugins.tiff.TIFFTagSet

        getTag, getTag, getTagNames, getTagNumbers

    • 字段详细信息

      • TAG_GPS_INFO_IFD_POINTER

        public static final int TAG_GPS_INFO_IFD_POINTER
        指向GPS信息IFD（类型LONG）的标签。 此标签已被ExifParentTIFFTagSet.TAG_GPS_INFO_IFD_POINTER取代。
        另请参见：
        Constant Field Values

      • TAG_INTEROPERABILITY_IFD_POINTER

        public static final int TAG_INTEROPERABILITY_IFD_POINTER
        指向互操作性IFD（类型LONG）的标签。
        另请参见：
        Constant Field Values

      • TAG_EXIF_VERSION

        public static final int TAG_EXIF_VERSION
        包含Exif版本号（类型UNDEFINED，count = 4）的标签。 符合Exif 2.1标准使用ASCII值“0210”（无终止NUL）表示。
        另请参见：
        EXIF_VERSION_2_1 ， EXIF_VERSION_2_2 ， Constant Field Values

      • EXIF_VERSION_2_1

        public static final String EXIF_VERSION_2_1
        要与ExifVersion标签一起使用的值来表示Exif版本2.1。 该值等于字节数组{'0', '2', '1', '0'}的US-ASCII编码。
        另请参见：
        TAG_EXIF_VERSION ， Constant Field Values

      • EXIF_VERSION_2_2

        public static final String EXIF_VERSION_2_2
        要与ExifVersion标签一起使用以指示Exif版本2.2的值。 该值等于字节数组{'0', '2', '2', '0'}的US-ASCII编码。
        另请参见：
        TAG_EXIF_VERSION ， Constant Field Values

      • TAG_FLASHPIX_VERSION

        public static final int TAG_FLASHPIX_VERSION
        指示FlashPix版本号（类型UNDEFINED，count = 4）的标签。
        另请参见：
        Constant Field Values

      • TAG_COLOR_SPACE

        public static final int TAG_COLOR_SPACE
        指示颜色空间信息的标签（类型为SHORT）。 合法值由COLOR_SPACE_*常数给出。
        另请参见：
        COLOR_SPACE_SRGB ， COLOR_SPACE_UNCALIBRATED ， Constant Field Values

      • COLOR_SPACE_SRGB

        public static final int COLOR_SPACE_SRGB
        与“ColorSpace”标签一起使用的值。
        另请参见：
        TAG_COLOR_SPACE ， Constant Field Values

      • COLOR_SPACE_UNCALIBRATED

        public static final int COLOR_SPACE_UNCALIBRATED
        与“ColorSpace”标签一起使用的值。
        另请参见：
        TAG_COLOR_SPACE ， Constant Field Values

      • TAG_COMPONENTS_CONFIGURATION

        public static final int TAG_COMPONENTS_CONFIGURATION
        包含组件配置信息（类型UNDEFINED，count = 4）的标签。
        另请参见：
        COMPONENTS_CONFIGURATION_DOES_NOT_EXIST ， COMPONENTS_CONFIGURATION_Y ， COMPONENTS_CONFIGURATION_CB ， COMPONENTS_CONFIGURATION_CR ， COMPONENTS_CONFIGURATION_R ， COMPONENTS_CONFIGURATION_G ， COMPONENTS_CONFIGURATION_B ， Constant Field Values

      • COMPONENTS_CONFIGURATION_DOES_NOT_EXIST

        public static final int COMPONENTS_CONFIGURATION_DOES_NOT_EXIST
        要与“ComponentsConfiguration”标签一起使用的值。
        另请参见：
        TAG_COMPONENTS_CONFIGURATION ， Constant Field Values

      • COMPONENTS_CONFIGURATION_Y

        public static final int COMPONENTS_CONFIGURATION_Y
        要与“ComponentsConfiguration”标签一起使用的值。
        另请参见：
        TAG_COMPONENTS_CONFIGURATION ， Constant Field Values

      • COMPONENTS_CONFIGURATION_CB

        public static final int COMPONENTS_CONFIGURATION_CB
        要与“ComponentsConfiguration”标签一起使用的值。
        另请参见：
        TAG_COMPONENTS_CONFIGURATION ， Constant Field Values

      • COMPONENTS_CONFIGURATION_CR

        public static final int COMPONENTS_CONFIGURATION_CR
        要与“ComponentsConfiguration”标签一起使用的值。
        另请参见：
        TAG_COMPONENTS_CONFIGURATION ， Constant Field Values

      • COMPONENTS_CONFIGURATION_R

        public static final int COMPONENTS_CONFIGURATION_R
        要与“ComponentsConfiguration”标签一起使用的值。
        另请参见：
        TAG_COMPONENTS_CONFIGURATION ， Constant Field Values

      • COMPONENTS_CONFIGURATION_G

        public static final int COMPONENTS_CONFIGURATION_G
        要与“ComponentsConfiguration”标签一起使用的值。
        另请参见：
        TAG_COMPONENTS_CONFIGURATION ， Constant Field Values

      • COMPONENTS_CONFIGURATION_B

        public static final int COMPONENTS_CONFIGURATION_B
        要与“ComponentsConfiguration”标签一起使用的值。
        另请参见：
        TAG_COMPONENTS_CONFIGURATION ， Constant Field Values

      • TAG_COMPRESSED_BITS_PER_PIXEL

        public static final int TAG_COMPRESSED_BITS_PER_PIXEL
        指示每像素的压缩比特数的标签（类型RATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_PIXEL_X_DIMENSION

        public static final int TAG_PIXEL_X_DIMENSION
        指示像素X尺寸的标签（类型为SHORT或LONG）。 此值记录压缩文件的有意义图像的有效宽度，无论是否有填充或重新启动标记。
        另请参见：
        Constant Field Values

      • TAG_PIXEL_Y_DIMENSION

        public static final int TAG_PIXEL_Y_DIMENSION
        指示像素Y尺寸的标签（类型为SHORT或LONG）。 此值记录压缩文件的有意义图像的有效高度，无论是否有填充或重新启动标记。
        另请参见：
        Constant Field Values

      • TAG_MAKER_NOTE

        public static final int TAG_MAKER_NOTE
        指示制造商定义的制造商注释（类型UNDEFINED）的标签。
        另请参见：
        Constant Field Values

      • TAG_MARKER_NOTE

        public static final int TAG_MARKER_NOTE
        指示制造商定义的标记笔记（类型UNDEFINED）的标签。 此标签已被TAG_MAKER_NOTE取代。
        另请参见：
        Constant Field Values

      • TAG_USER_COMMENT

        public static final int TAG_USER_COMMENT
        指示用户评论的标签（类型UNDEFINED）。 前8个字节用于指定字符编码。
        另请参见：
        Constant Field Values

      • TAG_RELATED_SOUND_FILE

        public static final int TAG_RELATED_SOUND_FILE
        指示相关声音文件名称的标签（类型为ASCII）。
        另请参见：
        Constant Field Values

      • TAG_DATE_TIME_ORIGINAL

        public static final int TAG_DATE_TIME_ORIGINAL
        指示生成原始图像的日期和时间的标签（ASCII码）。
        另请参见：
        Constant Field Values

      • TAG_DATE_TIME_DIGITIZED

        public static final int TAG_DATE_TIME_DIGITIZED
        指示图像作为数字数据存储的日期和时间的标签（ASCII类型）。
        另请参见：
        Constant Field Values

      • TAG_SUB_SEC_TIME

        public static final int TAG_SUB_SEC_TIME
        用于记录“DateTime”标签（ASCII类型）的秒数的标签。
        另请参见：
        Constant Field Values

      • TAG_SUB_SEC_TIME_ORIGINAL

        public static final int TAG_SUB_SEC_TIME_ORIGINAL
        用于记录“DateTimeOriginal”标记（ASCII类型）的秒数的标签。
        另请参见：
        Constant Field Values

      • TAG_SUB_SEC_TIME_DIGITIZED

        public static final int TAG_SUB_SEC_TIME_DIGITIZED
        用于记录“DateTimeDigitized”标签（ASCII类型）的秒数的标签。
        另请参见：
        Constant Field Values

      • TAG_EXPOSURE_TIME

        public static final int TAG_EXPOSURE_TIME
        指示曝光时间的标签（以秒为单位）（类型为RATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_F_NUMBER

        public static final int TAG_F_NUMBER
        指示F数字的标签（类型RATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_EXPOSURE_PROGRAM

        public static final int TAG_EXPOSURE_PROGRAM
        指示拍摄照片时用于设置曝光的节目类别的标签（类型为SHORT）。
        另请参见：
        EXPOSURE_PROGRAM_NOT_DEFINED ， EXPOSURE_PROGRAM_MANUAL ， EXPOSURE_PROGRAM_NORMAL_PROGRAM ， EXPOSURE_PROGRAM_APERTURE_PRIORITY ， EXPOSURE_PROGRAM_SHUTTER_PRIORITY ， EXPOSURE_PROGRAM_CREATIVE_PROGRAM ， EXPOSURE_PROGRAM_ACTION_PROGRAM ， EXPOSURE_PROGRAM_PORTRAIT_MODE ， EXPOSURE_PROGRAM_LANDSCAPE_MODE ， EXPOSURE_PROGRAM_MAX_RESERVED ， Constant Field Values

      • EXPOSURE_PROGRAM_NOT_DEFINED

        public static final int EXPOSURE_PROGRAM_NOT_DEFINED
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • EXPOSURE_PROGRAM_MANUAL

        public static final int EXPOSURE_PROGRAM_MANUAL
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • EXPOSURE_PROGRAM_NORMAL_PROGRAM

        public static final int EXPOSURE_PROGRAM_NORMAL_PROGRAM
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • EXPOSURE_PROGRAM_APERTURE_PRIORITY

        public static final int EXPOSURE_PROGRAM_APERTURE_PRIORITY
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • EXPOSURE_PROGRAM_SHUTTER_PRIORITY

        public static final int EXPOSURE_PROGRAM_SHUTTER_PRIORITY
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • EXPOSURE_PROGRAM_CREATIVE_PROGRAM

        public static final int EXPOSURE_PROGRAM_CREATIVE_PROGRAM
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • EXPOSURE_PROGRAM_ACTION_PROGRAM

        public static final int EXPOSURE_PROGRAM_ACTION_PROGRAM
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • EXPOSURE_PROGRAM_PORTRAIT_MODE

        public static final int EXPOSURE_PROGRAM_PORTRAIT_MODE
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • EXPOSURE_PROGRAM_LANDSCAPE_MODE

        public static final int EXPOSURE_PROGRAM_LANDSCAPE_MODE
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • EXPOSURE_PROGRAM_MAX_RESERVED

        public static final int EXPOSURE_PROGRAM_MAX_RESERVED
        与“ExposureProgram”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_PROGRAM ， Constant Field Values

      • TAG_SPECTRAL_SENSITIVITY

        public static final int TAG_SPECTRAL_SENSITIVITY
        指示所使用的相机的每个通道的光谱灵敏度的标签（类型ASCII）。 标签值是与ASTM标准兼容的ASCII字符串。
        另请参见：
        Constant Field Values

      • TAG_ISO_SPEED_RATINGS

        public static final int TAG_ISO_SPEED_RATINGS
        指示ISO 12232 xiv （类型SHORT）中规定的相机或输入设备的ISO感光度和ISO纬度的标签。
        另请参见：
        Constant Field Values

      • TAG_OECF

        public static final int TAG_OECF
        指示ISO 14254 xv （类型UNDEFINED）中规定的光电转换功能的标签。 OECF是相机光学输入和图像值之间的关系。
        另请参见：
        Constant Field Values

      • TAG_SHUTTER_SPEED_VALUE

        public static final int TAG_SHUTTER_SPEED_VALUE
        指示快门速度的标签（类型SRATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_APERTURE_VALUE

        public static final int TAG_APERTURE_VALUE
        指示镜头光圈的标签（类型RATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_BRIGHTNESS_VALUE

        public static final int TAG_BRIGHTNESS_VALUE
        指示亮度值的标签（类型SRATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_EXPOSURE_BIAS_VALUE

        public static final int TAG_EXPOSURE_BIAS_VALUE
        指示曝光偏差的标签（类型SRATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_MAX_APERTURE_VALUE

        public static final int TAG_MAX_APERTURE_VALUE
        指示镜头最小F数的标签（类型RATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_SUBJECT_DISTANCE

        public static final int TAG_SUBJECT_DISTANCE
        指示与被摄体距离的标签，以米为单位（类型为RATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_METERING_MODE

        public static final int TAG_METERING_MODE
        指示测光模式的标签（类型为SHORT）。
        另请参见：
        METERING_MODE_UNKNOWN ， METERING_MODE_AVERAGE ， METERING_MODE_CENTER_WEIGHTED_AVERAGE ， METERING_MODE_SPOT ， METERING_MODE_MULTI_SPOT ， METERING_MODE_PATTERN ， METERING_MODE_PARTIAL ， METERING_MODE_MIN_RESERVED ， METERING_MODE_MAX_RESERVED ， METERING_MODE_OTHER ， Constant Field Values

      • METERING_MODE_UNKNOWN

        public static final int METERING_MODE_UNKNOWN
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • METERING_MODE_AVERAGE

        public static final int METERING_MODE_AVERAGE
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • METERING_MODE_CENTER_WEIGHTED_AVERAGE

        public static final int METERING_MODE_CENTER_WEIGHTED_AVERAGE
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • METERING_MODE_SPOT

        public static final int METERING_MODE_SPOT
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • METERING_MODE_MULTI_SPOT

        public static final int METERING_MODE_MULTI_SPOT
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • METERING_MODE_PATTERN

        public static final int METERING_MODE_PATTERN
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • METERING_MODE_PARTIAL

        public static final int METERING_MODE_PARTIAL
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • METERING_MODE_MIN_RESERVED

        public static final int METERING_MODE_MIN_RESERVED
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • METERING_MODE_MAX_RESERVED

        public static final int METERING_MODE_MAX_RESERVED
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • METERING_MODE_OTHER

        public static final int METERING_MODE_OTHER
        与“MeteringMode”标签一起使用的值。
        另请参见：
        TAG_METERING_MODE ， Constant Field Values

      • TAG_LIGHT_SOURCE

        public static final int TAG_LIGHT_SOURCE
        指示光源类型的标签（类型为SHORT）。
        另请参见：
        LIGHT_SOURCE_UNKNOWN ， LIGHT_SOURCE_DAYLIGHT ， LIGHT_SOURCE_FLUORESCENT ， LIGHT_SOURCE_TUNGSTEN ， LIGHT_SOURCE_STANDARD_LIGHT_A ， LIGHT_SOURCE_STANDARD_LIGHT_B ， LIGHT_SOURCE_STANDARD_LIGHT_C ， LIGHT_SOURCE_D55 ， LIGHT_SOURCE_D65 ， LIGHT_SOURCE_D75 ， LIGHT_SOURCE_OTHER ， Constant Field Values

      • LIGHT_SOURCE_UNKNOWN

        public static final int LIGHT_SOURCE_UNKNOWN
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_DAYLIGHT

        public static final int LIGHT_SOURCE_DAYLIGHT
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_FLUORESCENT

        public static final int LIGHT_SOURCE_FLUORESCENT
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_TUNGSTEN

        public static final int LIGHT_SOURCE_TUNGSTEN
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_FLASH

        public static final int LIGHT_SOURCE_FLASH
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_FINE_WEATHER

        public static final int LIGHT_SOURCE_FINE_WEATHER
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_CLOUDY_WEATHER

        public static final int LIGHT_SOURCE_CLOUDY_WEATHER
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_SHADE

        public static final int LIGHT_SOURCE_SHADE
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_DAYLIGHT_FLUORESCENT

        public static final int LIGHT_SOURCE_DAYLIGHT_FLUORESCENT
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_DAY_WHITE_FLUORESCENT

        public static final int LIGHT_SOURCE_DAY_WHITE_FLUORESCENT
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_COOL_WHITE_FLUORESCENT

        public static final int LIGHT_SOURCE_COOL_WHITE_FLUORESCENT
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_WHITE_FLUORESCENT

        public static final int LIGHT_SOURCE_WHITE_FLUORESCENT
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_STANDARD_LIGHT_A

        public static final int LIGHT_SOURCE_STANDARD_LIGHT_A
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_STANDARD_LIGHT_B

        public static final int LIGHT_SOURCE_STANDARD_LIGHT_B
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_STANDARD_LIGHT_C

        public static final int LIGHT_SOURCE_STANDARD_LIGHT_C
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_D55

        public static final int LIGHT_SOURCE_D55
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_D65

        public static final int LIGHT_SOURCE_D65
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_D75

        public static final int LIGHT_SOURCE_D75
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_D50

        public static final int LIGHT_SOURCE_D50
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_ISO_STUDIO_TUNGSTEN

        public static final int LIGHT_SOURCE_ISO_STUDIO_TUNGSTEN
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • LIGHT_SOURCE_OTHER

        public static final int LIGHT_SOURCE_OTHER
        与“LightSource”标签一起使用的值。
        另请参见：
        TAG_LIGHT_SOURCE ， Constant Field Values

      • TAG_FLASH

        public static final int TAG_FLASH
        指示闪光灯闪光状态和闪光灯返回状态的标签（类型为SHORT）。
        另请参见：
        FLASH_DID_NOT_FIRE ， FLASH_FIRED ， FLASH_STROBE_RETURN_LIGHT_NOT_DETECTED ， FLASH_STROBE_RETURN_LIGHT_DETECTED ， Constant Field Values

      • FLASH_DID_NOT_FIRE

        public static final int FLASH_DID_NOT_FIRE
        与“Flash”标签一起使用的值，表示闪光灯未触发。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_FIRED

        public static final int FLASH_FIRED
        与“Flash”标签一起使用的值，表示闪光灯闪光，但闪光灯返回状态未知。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_STROBE_RETURN_LIGHT_NOT_DETECTED

        public static final int FLASH_STROBE_RETURN_LIGHT_NOT_DETECTED
        与“Flash”标签一起使用的值，表示闪光灯闪光，但没有检测到闪光灯返回光。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_STROBE_RETURN_LIGHT_DETECTED

        public static final int FLASH_STROBE_RETURN_LIGHT_DETECTED
        与“Flash”标签一起使用的值，表示闪光灯闪烁，并检测到闪光灯返回光。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_MASK_FIRED

        public static final int FLASH_MASK_FIRED
        一个与“Flash”标签一起使用的面具，表示闪光灯闪光。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_MASK_RETURN_NOT_DETECTED

        public static final int FLASH_MASK_RETURN_NOT_DETECTED
        与“Flash”标签一起使用的掩码，指示未检测到闪光灯返回光。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_MASK_RETURN_DETECTED

        public static final int FLASH_MASK_RETURN_DETECTED
        与“Flash”标签一起使用的掩码，指示检测到闪光灯返回光。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_MASK_MODE_FLASH_FIRING

        public static final int FLASH_MASK_MODE_FLASH_FIRING
        与“Flash”标签一起使用的面具，表示强制闪光灯闪光模式。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_MASK_MODE_FLASH_SUPPRESSION

        public static final int FLASH_MASK_MODE_FLASH_SUPPRESSION
        与“Flash”标签一起使用的掩码，表示强制闪存抑制模式。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_MASK_MODE_AUTO

        public static final int FLASH_MASK_MODE_AUTO
        与“Flash”标签一起使用的掩码，表示自动模式。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_MASK_FUNCTION_NOT_PRESENT

        public static final int FLASH_MASK_FUNCTION_NOT_PRESENT
        与“Flash”标签一起使用的掩码，表示不存在闪光灯功能。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • FLASH_MASK_RED_EYE_REDUCTION

        public static final int FLASH_MASK_RED_EYE_REDUCTION
        与“Flash”标签一起使用的面具，表示支持红眼。
        另请参见：
        TAG_FLASH ， Constant Field Values

      • TAG_FOCAL_LENGTH

        public static final int TAG_FOCAL_LENGTH
        指示透镜实际焦距的标签，单位为毫米（类型为RATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_SUBJECT_AREA

        public static final int TAG_SUBJECT_AREA
        指示整个场景中主要被摄体的位置和面积的标签。
        另请参见：
        Constant Field Values

      • TAG_FLASH_ENERGY

        public static final int TAG_FLASH_ENERGY
        指示拍摄图像时的频闪能量的标签，如“光束功率秒（BCPS）”（类型RATIONAL）所测量。
        另请参见：
        Constant Field Values

      • TAG_SPATIAL_FREQUENCY_RESPONSE

        public static final int TAG_SPATIAL_FREQUENCY_RESPONSE
        根据ISO 12233 xvi （类型UNDEFINED）中指定的指示照相机或输入设备空间频率表和图像宽度，图像高度和对角线方向方向上的SFR值的标签。
        另请参见：
        Constant Field Values

      • TAG_FOCAL_PLANE_X_RESOLUTION

        public static final int TAG_FOCAL_PLANE_X_RESOLUTION
        指示相机焦平面上的每个FocalPlaneResolutionUnit的图像宽度（X）方向上的像素数（类型为RATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_FOCAL_PLANE_Y_RESOLUTION

        public static final int TAG_FOCAL_PLANE_Y_RESOLUTION
        指示相机焦平面上的每个FocalPlaneResolutionUnit的图像高度（Y）方向上的像素数（类型为RATIONAL）。
        另请参见：
        Constant Field Values

      • TAG_FOCAL_PLANE_RESOLUTION_UNIT

        public static final int TAG_FOCAL_PLANE_RESOLUTION_UNIT
        表示测量FocalPlaneXResolution和FocalPlaneYResolution（键入SHORT）的单位。
        另请参见：
        FOCAL_PLANE_RESOLUTION_UNIT_NONE ， FOCAL_PLANE_RESOLUTION_UNIT_INCH ， FOCAL_PLANE_RESOLUTION_UNIT_CENTIMETER ， Constant Field Values

      • FOCAL_PLANE_RESOLUTION_UNIT_NONE

        public static final int FOCAL_PLANE_RESOLUTION_UNIT_NONE
        要与“FocalPlaneResolutionUnit”标签一起使用的值。
        另请参见：
        TAG_FOCAL_PLANE_RESOLUTION_UNIT ， Constant Field Values

      • FOCAL_PLANE_RESOLUTION_UNIT_INCH

        public static final int FOCAL_PLANE_RESOLUTION_UNIT_INCH
        与“FocalPlaneXResolution”标签一起使用的值。
        另请参见：
        TAG_FOCAL_PLANE_RESOLUTION_UNIT ， Constant Field Values

      • FOCAL_PLANE_RESOLUTION_UNIT_CENTIMETER

        public static final int FOCAL_PLANE_RESOLUTION_UNIT_CENTIMETER
        与“FocalPlaneXResolution”标签一起使用的值。
        另请参见：
        TAG_FOCAL_PLANE_RESOLUTION_UNIT ， Constant Field Values

      • TAG_SUBJECT_LOCATION

        public static final int TAG_SUBJECT_LOCATION
        指示场景中主要被摄体的中心像素的列和行的标签（类型SHORT，count = 2）。
        另请参见：
        Constant Field Values

      • TAG_EXPOSURE_INDEX

        public static final int TAG_EXPOSURE_INDEX
        指示在拍摄图像时在相机或输入设备上选择的曝光指数的标签（类型为RATIONAL）的标签。
        另请参见：
        Constant Field Values

      • TAG_SENSING_METHOD

        public static final int TAG_SENSING_METHOD
        指示相机或输入设备上传感器类型的标签（类型为SHORT）。
        另请参见：
        SENSING_METHOD_NOT_DEFINED ， SENSING_METHOD_ONE_CHIP_COLOR_AREA_SENSOR ， SENSING_METHOD_TWO_CHIP_COLOR_AREA_SENSOR ， SENSING_METHOD_THREE_CHIP_COLOR_AREA_SENSOR ， SENSING_METHOD_COLOR_SEQUENTIAL_AREA_SENSOR ， SENSING_METHOD_TRILINEAR_SENSOR ， SENSING_METHOD_COLOR_SEQUENTIAL_LINEAR_SENSOR ， Constant Field Values

      • SENSING_METHOD_NOT_DEFINED

        public static final int SENSING_METHOD_NOT_DEFINED
        与“SensingMethod”标签一起使用的值。
        另请参见：
        TAG_SENSING_METHOD ， Constant Field Values

      • SENSING_METHOD_ONE_CHIP_COLOR_AREA_SENSOR

        public static final int SENSING_METHOD_ONE_CHIP_COLOR_AREA_SENSOR
        与“SensingMethod”标签一起使用的值。
        另请参见：
        TAG_SENSING_METHOD ， Constant Field Values

      • SENSING_METHOD_TWO_CHIP_COLOR_AREA_SENSOR

        public static final int SENSING_METHOD_TWO_CHIP_COLOR_AREA_SENSOR
        与“SensingMethod”标签一起使用的值。
        另请参见：
        TAG_SENSING_METHOD ， Constant Field Values

      • SENSING_METHOD_THREE_CHIP_COLOR_AREA_SENSOR

        public static final int SENSING_METHOD_THREE_CHIP_COLOR_AREA_SENSOR
        与“SensingMethod”标签一起使用的值。
        另请参见：
        TAG_SENSING_METHOD ， Constant Field Values

      • SENSING_METHOD_COLOR_SEQUENTIAL_AREA_SENSOR

        public static final int SENSING_METHOD_COLOR_SEQUENTIAL_AREA_SENSOR
        与“SensingMethod”标签一起使用的值。
        另请参见：
        TAG_SENSING_METHOD ， Constant Field Values

      • SENSING_METHOD_TRILINEAR_SENSOR

        public static final int SENSING_METHOD_TRILINEAR_SENSOR
        与“SensingMethod”标签一起使用的值。
        另请参见：
        TAG_SENSING_METHOD ， Constant Field Values

      • SENSING_METHOD_COLOR_SEQUENTIAL_LINEAR_SENSOR

        public static final int SENSING_METHOD_COLOR_SEQUENTIAL_LINEAR_SENSOR
        与“SensingMethod”标签一起使用的值。
        另请参见：
        TAG_SENSING_METHOD ， Constant Field Values

      • TAG_FILE_SOURCE

        public static final int TAG_FILE_SOURCE
        指示图像源（类型UNDEFINED）的标签。
        另请参见：
        FILE_SOURCE_DSC ， Constant Field Values

      • FILE_SOURCE_DSC

        public static final int FILE_SOURCE_DSC
        与“FileSource”标签一起使用的值。
        另请参见：
        TAG_FILE_SOURCE ， Constant Field Values

      • TAG_SCENE_TYPE

        public static final int TAG_SCENE_TYPE
        指示场景类型的标签（UNDEFINED类型）。
        另请参见：
        SCENE_TYPE_DSC ， Constant Field Values

      • SCENE_TYPE_DSC

        public static final int SCENE_TYPE_DSC
        要与“SceneType”标签一起使用的值。
        另请参见：
        TAG_SCENE_TYPE ， Constant Field Values

      • TAG_CFA_PATTERN

        public static final int TAG_CFA_PATTERN
        指示当使用单芯片彩色区域传感器（类型UNDEFINED）时图像传感器的滤色器阵列几何图案的标签。
        另请参见：
        Constant Field Values

      • TAG_CUSTOM_RENDERED

        public static final int TAG_CUSTOM_RENDERED
        指示对图像数据使用特殊处理的标签，例如用于输出的渲染。
        另请参见：
        Constant Field Values

      • CUSTOM_RENDERED_NORMAL

        public static final int CUSTOM_RENDERED_NORMAL
        与“CustomRendered”标签一起使用的值。
        另请参见：
        TAG_CUSTOM_RENDERED ， Constant Field Values

      • CUSTOM_RENDERED_CUSTOM

        public static final int CUSTOM_RENDERED_CUSTOM
        与“CustomRendered”标签一起使用的值。
        另请参见：
        TAG_CUSTOM_RENDERED ， Constant Field Values

      • TAG_EXPOSURE_MODE

        public static final int TAG_EXPOSURE_MODE
        指示拍摄图像时设置的曝光模式的标签。
        另请参见：
        Constant Field Values

      • EXPOSURE_MODE_AUTO_EXPOSURE

        public static final int EXPOSURE_MODE_AUTO_EXPOSURE
        与“ExposureMode”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_MODE ， Constant Field Values

      • EXPOSURE_MODE_MANUAL_EXPOSURE

        public static final int EXPOSURE_MODE_MANUAL_EXPOSURE
        与“ExposureMode”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_MODE ， Constant Field Values

      • EXPOSURE_MODE_AUTO_BRACKET

        public static final int EXPOSURE_MODE_AUTO_BRACKET
        与“ExposureMode”标签一起使用的值。
        另请参见：
        TAG_EXPOSURE_MODE ， Constant Field Values

      • TAG_WHITE_BALANCE

        public static final int TAG_WHITE_BALANCE
        指示拍摄图像时设置的白平衡模式的标签。
        另请参见：
        Constant Field Values

      • WHITE_BALANCE_AUTO

        public static final int WHITE_BALANCE_AUTO
        要与“WhiteBalance”标签一起使用的值。
        另请参见：
        TAG_WHITE_BALANCE ， Constant Field Values

      • WHITE_BALANCE_MANUAL

        public static final int WHITE_BALANCE_MANUAL
        要与“WhiteBalance”标签一起使用的值。
        另请参见：
        TAG_WHITE_BALANCE ， Constant Field Values

      • TAG_DIGITAL_ZOOM_RATIO

        public static final int TAG_DIGITAL_ZOOM_RATIO
        指示拍摄图像时的数码变焦比的标签。
        另请参见：
        Constant Field Values

      • TAG_FOCAL_LENGTH_IN_35MM_FILM

        public static final int TAG_FOCAL_LENGTH_IN_35MM_FILM
        一个标签表示等效焦距，假设为35mm胶片相机，单位为毫米。
        另请参见：
        Constant Field Values

      • TAG_SCENE_CAPTURE_TYPE

        public static final int TAG_SCENE_CAPTURE_TYPE
        指示被拍摄的场景的类型的标签。
        另请参见：
        Constant Field Values

      • SCENE_CAPTURE_TYPE_STANDARD

        public static final int SCENE_CAPTURE_TYPE_STANDARD
        要与“SceneCaptureType”标签一起使用的值。
        另请参见：
        TAG_SCENE_CAPTURE_TYPE ， Constant Field Values

      • SCENE_CAPTURE_TYPE_LANDSCAPE

        public static final int SCENE_CAPTURE_TYPE_LANDSCAPE
        要与“SceneCaptureType”标签一起使用的值。
        另请参见：
        TAG_SCENE_CAPTURE_TYPE ， Constant Field Values

      • SCENE_CAPTURE_TYPE_PORTRAIT

        public static final int SCENE_CAPTURE_TYPE_PORTRAIT
        要与“SceneCaptureType”标签一起使用的值。
        另请参见：
        TAG_SCENE_CAPTURE_TYPE ， Constant Field Values

      • SCENE_CAPTURE_TYPE_NIGHT_SCENE

        public static final int SCENE_CAPTURE_TYPE_NIGHT_SCENE
        要与“SceneCaptureType”标签一起使用的值。
        另请参见：
        TAG_SCENE_CAPTURE_TYPE ， Constant Field Values

      • TAG_GAIN_CONTROL

        public static final int TAG_GAIN_CONTROL
        指示整体图像增益调整程度的标签。
        另请参见：
        Constant Field Values

      • GAIN_CONTROL_NONE

        public static final int GAIN_CONTROL_NONE
        与“GainControl”标签一起使用的值。
        另请参见：
        TAG_GAIN_CONTROL ， Constant Field Values

      • GAIN_CONTROL_LOW_GAIN_UP

        public static final int GAIN_CONTROL_LOW_GAIN_UP
        与“GainControl”标签一起使用的值。
        另请参见：
        TAG_GAIN_CONTROL ， Constant Field Values

      • GAIN_CONTROL_HIGH_GAIN_UP

        public static final int GAIN_CONTROL_HIGH_GAIN_UP
        与“GainControl”标签一起使用的值。
        另请参见：
        TAG_GAIN_CONTROL ， Constant Field Values

      • GAIN_CONTROL_LOW_GAIN_DOWN

        public static final int GAIN_CONTROL_LOW_GAIN_DOWN
        与“GainControl”标签一起使用的值。
        另请参见：
        TAG_GAIN_CONTROL ， Constant Field Values

      • GAIN_CONTROL_HIGH_GAIN_DOWN

        public static final int GAIN_CONTROL_HIGH_GAIN_DOWN
        与“GainControl”标签一起使用的值。
        另请参见：
        TAG_GAIN_CONTROL ， Constant Field Values

      • TAG_CONTRAST

        public static final int TAG_CONTRAST
        指示拍摄图像时由相机应用的对比度处理方向的标签。
        另请参见：
        Constant Field Values

      • CONTRAST_NORMAL

        public static final int CONTRAST_NORMAL
        与“对比度”标签一起使用的值。
        另请参见：
        TAG_CONTRAST ， Constant Field Values

      • CONTRAST_SOFT

        public static final int CONTRAST_SOFT
        与“对比度”标签一起使用的值。
        另请参见：
        TAG_CONTRAST ， Constant Field Values

      • CONTRAST_HARD

        public static final int CONTRAST_HARD
        与“对比度”标签一起使用的值。
        另请参见：
        TAG_CONTRAST ， Constant Field Values

      • TAG_SATURATION

        public static final int TAG_SATURATION
        指示拍摄图像时照相机应用的饱和度处理方向的标签。
        另请参见：
        Constant Field Values

      • SATURATION_NORMAL

        public static final int SATURATION_NORMAL
        新新200的X- 200 X- 200 200 X- 200 200：
        另请参见：
        TAG_SATURATION ， Constant Field Values

      • SATURATION_LOW

        public static final int SATURATION_LOW
        新新200的X- 200 X- 200 200 X- 200 200：
        另请参见：
        TAG_SATURATION ， Constant Field Values

      • SATURATION_HIGH

        public static final int SATURATION_HIGH
        新新200的X- 200 X- 200 200 X- 200 200：
        另请参见：
        TAG_SATURATION ， Constant Field Values

      • TAG_SHARPNESS

        public static final int TAG_SHARPNESS
        指示当拍摄图像时由照相机应用的清晰度处理的方向的标签。
        另请参见：
        Constant Field Values

      • SHARPNESS_NORMAL

        public static final int SHARPNESS_NORMAL
        与“Sharpness”标签一起使用的值。
        另请参见：
        TAG_SHARPNESS ， Constant Field Values

      • SHARPNESS_SOFT

        public static final int SHARPNESS_SOFT
        与“Sharpness”标签一起使用的值。
        另请参见：
        TAG_SHARPNESS ， Constant Field Values

      • SHARPNESS_HARD

        public static final int SHARPNESS_HARD
        与“Sharpness”标签一起使用的值。
        另请参见：
        TAG_SHARPNESS ， Constant Field Values

      • TAG_DEVICE_SETTING_DESCRIPTION

        public static final int TAG_DEVICE_SETTING_DESCRIPTION
        指示特定相机模型的拍摄条件的信息的标签。
        另请参见：
        Constant Field Values

      • TAG_SUBJECT_DISTANCE_RANGE

        public static final int TAG_SUBJECT_DISTANCE_RANGE
        指示与被摄体距离的标签。
        另请参见：
        Constant Field Values

      • SUBJECT_DISTANCE_RANGE_UNKNOWN

        public static final int SUBJECT_DISTANCE_RANGE_UNKNOWN
        与“SubjectDistanceRange”标签一起使用的值。
        另请参见：
        TAG_SUBJECT_DISTANCE_RANGE ， Constant Field Values

      • SUBJECT_DISTANCE_RANGE_MACRO

        public static final int SUBJECT_DISTANCE_RANGE_MACRO
        与“SubjectDistanceRange”标签一起使用的值。
        另请参见：
        TAG_SUBJECT_DISTANCE_RANGE ， Constant Field Values

      • SUBJECT_DISTANCE_RANGE_CLOSE_VIEW

        public static final int SUBJECT_DISTANCE_RANGE_CLOSE_VIEW
        与“SubjectDistanceRange”标签一起使用的值。
        另请参见：
        TAG_SUBJECT_DISTANCE_RANGE ， Constant Field Values

      • SUBJECT_DISTANCE_RANGE_DISTANT_VIEW

        public static final int SUBJECT_DISTANCE_RANGE_DISTANT_VIEW
        与“SubjectDistanceRange”标签一起使用的值。
        另请参见：
        TAG_SUBJECT_DISTANCE_RANGE ， Constant Field Values

      • TAG_IMAGE_UNIQUE_ID

        public static final int TAG_IMAGE_UNIQUE_ID
        指示为每个图像唯一地分配的标识符的标签。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getInstance

        public static ExifTIFFTagSet getInstance​()
        返回一个 ExifTIFFTagSet的共享实例。
        结果
        一个 ExifTIFFTagSet例子。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


FaxTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class FaxTIFFTagSet

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFTagSet
      • javax.imageio.plugins.tiff.FaxTIFFTagSet

  • public final class FaxTIFFTagSet
extends TIFFTagSet
    表示在 TIFF-F （RFC 2036）文件中找到的额外标签的类。
    从以下版本开始：
    9

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CLEAN_FAX_DATA_ERRORS_CORRECTED
      与“CleanFaxData”标签一起使用的值。
      static int CLEAN_FAX_DATA_ERRORS_UNCORRECTED
      与“CleanFaxData”标签一起使用的值。
      static int CLEAN_FAX_DATA_NO_ERRORS
      与“CleanFaxData”标签一起使用的值。
      static int TAG_BAD_FAX_LINES
      指示不良传真线路数量的标签（类型为短或长）。
      static int TAG_CLEAN_FAX_DATA
      标签表示干净传真数据的行数（类型为SHORT）。
      static int TAG_CONSECUTIVE_BAD_LINES
      指示连续不良行的数量的标签（类型为SHORT或LONG）。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FaxTIFFTagSet getInstance​()
      返回一个 FaxTIFFTagSet的共享实例。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.imageio.plugins.tiff.TIFFTagSet

        getTag, getTag, getTagNames, getTagNumbers

    • 字段详细信息

      • TAG_BAD_FAX_LINES

        public static final int TAG_BAD_FAX_LINES
        指示不良传真线路数量的标签（类型为短或长）。
        另请参见：
        Constant Field Values

      • TAG_CLEAN_FAX_DATA

        public static final int TAG_CLEAN_FAX_DATA
        标签表示干净传真数据的行数（类型为SHORT）。
        另请参见：
        CLEAN_FAX_DATA_NO_ERRORS ， CLEAN_FAX_DATA_ERRORS_CORRECTED ， CLEAN_FAX_DATA_ERRORS_UNCORRECTED ， Constant Field Values

      • CLEAN_FAX_DATA_NO_ERRORS

        public static final int CLEAN_FAX_DATA_NO_ERRORS
        与“CleanFaxData”标签一起使用的值。
        另请参见：
        TAG_CLEAN_FAX_DATA ， Constant Field Values

      • CLEAN_FAX_DATA_ERRORS_CORRECTED

        public static final int CLEAN_FAX_DATA_ERRORS_CORRECTED
        与“CleanFaxData”标签一起使用的值。
        另请参见：
        TAG_CLEAN_FAX_DATA ， Constant Field Values

      • CLEAN_FAX_DATA_ERRORS_UNCORRECTED

        public static final int CLEAN_FAX_DATA_ERRORS_UNCORRECTED
        与“CleanFaxData”标签一起使用的值。
        另请参见：
        TAG_CLEAN_FAX_DATA ， Constant Field Values

      • TAG_CONSECUTIVE_BAD_LINES

        public static final int TAG_CONSECUTIVE_BAD_LINES
        指示连续不良行的数量的标签（类型为SHORT或LONG）。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getInstance

        public static FaxTIFFTagSet getInstance​()
        返回一个 FaxTIFFTagSet的共享实例。
        结果
        一个 FaxTIFFTagSet例子。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


GeoTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class GeoTIFFTagSet

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFTagSet
      • javax.imageio.plugins.tiff.GeoTIFFTagSet

  • public final class GeoTIFFTagSet
extends TIFFTagSet
    代表GeoTIFF IFD中找到的标签的类。 GeoTIFF是注释地理参考或地理编码光栅图像的标准。 该类不处理GeoKey期从一个GeoKeyDirectoryTag引用那些不TIFF标签本身。

    字段定义引用的数据类型的定义可以在TIFFTag类中找到。

    从以下版本开始：
    9

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TAG_GEO_ASCII_PARAMS
      用于存储所有ASCII值的 标签GeoKey s的标签。
      static int TAG_GEO_DOUBLE_PARAMS
      用于存储所有 double GeoKey的标签。
      static int TAG_GEO_KEY_DIRECTORY
      用于存储 GeoKey目录的标签。
      static int TAG_MODEL_PIXEL_SCALE
      用于在模型空间单位中指定栅格像素间距的大小的标签。
      static int TAG_MODEL_TIE_POINT
      用于存储光栅到模型tiepoint对的标签。
      static int TAG_MODEL_TRANSFORMATION
      用于指定光栅空间和模型空间之间的转换矩阵的标记。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static GeoTIFFTagSet getInstance​()
      返回一个 GeoTIFFTagSet的共享实例。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.imageio.plugins.tiff.TIFFTagSet

        getTag, getTag, getTagNames, getTagNumbers

    • 字段详细信息

      • TAG_MODEL_PIXEL_SCALE

        public static final int TAG_MODEL_PIXEL_SCALE
        用于在模型空间单位中指定栅格像素间距的大小的标签。
        另请参见：
        Constant Field Values

      • TAG_MODEL_TRANSFORMATION

        public static final int TAG_MODEL_TRANSFORMATION
        用于指定光栅空间和模型空间之间的转换矩阵的标记。
        另请参见：
        Constant Field Values

      • TAG_MODEL_TIE_POINT

        public static final int TAG_MODEL_TIE_POINT
        用于存储光栅到模型tiepoint对的标签。
        另请参见：
        Constant Field Values

      • TAG_GEO_KEY_DIRECTORY

        public static final int TAG_GEO_KEY_DIRECTORY
        用于存储 GeoKey目录的标签。
        另请参见：
        Constant Field Values

      • TAG_GEO_DOUBLE_PARAMS

        public static final int TAG_GEO_DOUBLE_PARAMS
        用于存储所有 double GeoKey的标签。
        另请参见：
        Constant Field Values

      • TAG_GEO_ASCII_PARAMS

        public static final int TAG_GEO_ASCII_PARAMS
        用于存储所有ASCII值的 标签GeoKey s的标签。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getInstance

        public static GeoTIFFTagSet getInstance​()
        返回一个 GeoTIFFTagSet的共享实例。
        结果
        一个 GeoTIFFTagSet例子。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javax.imageio.plugins.tiff (Java SE 9 & JDK 9 )

javax.imageio.plugins.tiff

Classes

  • BaselineTIFFTagSet
  • ExifGPSTagSet
  • ExifInteroperabilityTagSet
  • ExifParentTIFFTagSet
  • ExifTIFFTagSet
  • FaxTIFFTagSet
  • GeoTIFFTagSet
  • TIFFDirectory
  • TIFFField
  • TIFFImageReadParam
  • TIFFTag
  • TIFFTagSet


javax.imageio.plugins.tiff (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package javax.imageio.plugins.tiff

内置TIFF插件使用的公共类。

此软件包包含支持内置TIFF读写器插件的类。 提供了简化与元数据交互的类，包括数字摄影中常见的Exif元数据，以及ImageReadParam的扩展，允许指定允许读取哪些元数据标签。 有关内置TIFF插件的操作的更多信息，请参阅TIFF metadata format specification and usage notes 。

从以下版本开始：
9
  • 类摘要
    Class 描述
    BaselineTIFFTagSet
    表示在基准TIFF规范中找到的一组标签的类以及一些常见的附加标签。
    ExifGPSTagSet
    代表在Exif GPS Info IFD中找到的标签的类。
    ExifInteroperabilityTagSet
    代表在Exif互操作性IFD中找到的标签的类。
    ExifParentTIFFTagSet
    包含用于引用Exif和GPS IFD的TIFF标签的类。
    ExifTIFFTagSet
    代表在Exif IFD中找到的标签的类。
    FaxTIFFTagSet
    表示在 TIFF-F （RFC 2036）文件中找到的额外标签的类。
    GeoTIFFTagSet
    代表GeoTIFF IFD中找到的标签的类。
    TIFFDirectory
    简化与TIFF本地图像元数据交互的便利类。
    TIFFField
    表示TIFF 6.0图像文件目录中的字段的类。
    TIFFImageReadParam
    ImageReadParam的子类允许控制TIFF读取过程。
    TIFFTag
    定义TIFF标签概念的类。
    TIFFTagSet
    A class representing a set of TIFF tags.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.imageio.plugins.tiff Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.imageio.plugins.tiff

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
        • javax.imageio.plugins.tiff.TIFFImageReadParam
    • javax.imageio.plugins.tiff.TIFFDirectory (implements java.lang.Cloneable)
    • javax.imageio.plugins.tiff.TIFFField (implements java.lang.Cloneable)
    • javax.imageio.plugins.tiff.TIFFTag
    • javax.imageio.plugins.tiff.TIFFTagSet
      • javax.imageio.plugins.tiff.BaselineTIFFTagSet
      • javax.imageio.plugins.tiff.ExifGPSTagSet
      • javax.imageio.plugins.tiff.ExifInteroperabilityTagSet
      • javax.imageio.plugins.tiff.ExifParentTIFFTagSet
      • javax.imageio.plugins.tiff.ExifTIFFTagSet
      • javax.imageio.plugins.tiff.FaxTIFFTagSet
      • javax.imageio.plugins.tiff.GeoTIFFTagSet
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


TIFFDirectory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class TIFFDirectory

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFDirectory
  • All Implemented Interfaces:
    Cloneable

    public class TIFFDirectory
extends Object
implements Cloneable
    简化与TIFF本地图像元数据交互的便利类。 TIFF图像元数据树表示来自TIFF 6.0流的图像文件目录（IFD）。 IFD由多个IFD条目组成，每个IFD条目将识别标签号与兼容值相关联。 A TIFFDirectory实例对应于IFD，并且包含一组TIFFField ，其各自对应于IFD中的IFD条目。

    阅读时，可以通过将ImageReader.getImageMetadata()返回的值传递给TIFFDirectory来创建一个TIFFDirectory 。 目录中的TIFFField可以使用此类中提供的访问器方法获取。

    当写入时，一个IIOMetadata对象供的一个write()的方法ImageWriter可以由创建TIFFDirectory通过getAsMetadata() 。 TIFFDirectory本身可以通过构造或由IIOMetadata返回的IIOMetadata对象创建 。 目录中的TIFFField可以使用此类中提供的mutator方法设置。

    A TIFFDirectory知道与其相关联的组中的标签号码为TIFFTagSet 。 当从本机图像元数据对象创建TIFFDirectory ，这些标记集是从TIFFIFD节点的tagSets属性派生的。

    A TIFFDirectory也可能有父母TIFFTag 。 如果目录代表IFD，而不是图像的根IFD，则会发生这种情况。 父标签是IFD条目的标签，它是指向由TIFFDirectory表示的IFD的指针。 该父母TIFFTag的TIFFTag.isIFDPointer()方法必须返回true 。 当从本机图像元数据对象创建TIFFDirectory ，父标记集是从对应的TIFFIFD节点的parentTagName属性设置的。 请注意，具有非null父标记的TIFFDirectory实例将包含在TIFFField实例的数据字段中，该实例的标签字段等于包含的目录的父标记。

    例如考虑一个Exif图像。 与Exif流中的Exif IFD对应的TIFFDirectory实例将具有父标记TAG_EXIF_IFD_POINTER，并且在其已知标签集的组中将包括ExifTIFFTagSet 。 对应于此Exif IFD的TIFFDirectory将包含在TIFFField的数据字段中，该数据字段又将包含在对应于Exif映像的主IFD的TIFFDirectory ，该IFD本身将具有一个null父标记。

    请注意，此实现不同步。 如果多个线程并发使用TIFFDirectory实例，并且至少有一个线程修改目录，例如，通过添加或删除TIFFField或TIFFTagSet s，则必须从外部进行同步。

    从以下版本开始：
    9
    另请参见：
    IIOMetadata ， TIFFField ， TIFFTag ， TIFFTagSet

    • 构造方法摘要

      构造方法
      Constructor 描述
      TIFFDirectory​(TIFFTagSet[] tagSets, TIFFTag parentTag)
      构造一个TIFFDirectory ，它知道一组TIFFTagSet s。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addTagSet​(TIFFTagSet tagSet)
      将一个元素添加到该目录知道的TIFFTagSet的组中。
      void addTIFFField​(TIFFField f)
      将TIFF字段添加到目录。
      TIFFDirectory clone​()
      克隆目录及其中包含的所有字段。
      boolean containsTIFFField​(int tagNumber)
      确定具有给定标签号的TIFF字段是否包含在此目录中。
      static TIFFDirectory createFromMetadata​(IIOMetadata tiffImageMetadata)
      从图像元数据对象的内容创建一个 TIFFDirectory实例。
      IIOMetadata getAsMetadata​()
      将目录转换为元数据对象。
      int getNumTIFFFields​()
      返回此目录中的TIFFField个数。
      TIFFTag getParentTag​()
      返回父TIFFTag这个目录如果已定义或null其他。
      TIFFTag getTag​(int tagNumber)
      如果与此目录相关联的TIFFTagSet中没有此类标记，则返回TIFFTag ，其标签号等于tagNumber或null 。
      TIFFTagSet[] getTagSets​()
      返回此目录知道的TIFFTagSet s。
      TIFFField getTIFFField​(int tagNumber)
      从目录中检索TIFF字段。
      TIFFField[] getTIFFFields​()
      从目录中检索所有TIFF字段。
      void removeTagSet​(TIFFTagSet tagSet)
      从目录中知道的TIFFTagSet组中删除一个元素。
      void removeTIFFField​(int tagNumber)
      从目录中删除TIFF字段。
      void removeTIFFFields​()
      从目录中删除所有TIFF字段。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TIFFDirectory

        public TIFFDirectory​(TIFFTagSet[] tagSets,
                     TIFFTag parentTag)
        构造一个TIFFDirectory ，它知道给定的一组TIFFTagSet s。 也可以指定可选的父项TIFFTag 。
        参数
        tagSets - 与此目录相关联的 TIFFTagSets 。
        parentTag - 该目录的父母TIFFTag ; 可能是null 。
        异常
        NullPointerException - 如果 tagSets是 null 。

    • 方法详细信息

      • createFromMetadata

        public static TIFFDirectory createFromMetadata​(IIOMetadata tiffImageMetadata)
                                        throws IIOInvalidTreeException
        从图像元数据对象的内容创建一个TIFFDirectory实例。 提供的对象必须支持TIFF ImageWriter插件支持的图像元数据格式。 这通常是TIFF本机图像元数据格式javax_imageio_tiff_image_1.0或Java Image I / O标准元数据格式javax_imageio_1.0 。
        参数
        tiffImageMetadata - 支持兼容图像元数据格式的元数据对象。
        结果
        A TIFFDirectory从提供的元数据对象的内容中填充。
        异常
        NullPointerException - 如果 tiffImageMetadata是 null 。
        IllegalArgumentException - 如果 tiffImageMetadata不支持兼容的图像元数据格式。
        IIOInvalidTreeException - 如果提供的元数据对象无法解析。

      • getTagSets

        public TIFFTagSet[] getTagSets​()
        返回此目录知道的TIFFTagSet s。
        结果
        该 TIFFTagSet与此 TIFFDirectory相关联。

      • addTagSet

        public void addTagSet​(TIFFTagSet tagSet)
        将一个元素添加到该目录知道的TIFFTagSet的组中。
        参数
        tagSet - 要添加的 TIFFTagSet 。
        异常
        NullPointerException - 如果 tagSet是 null 。

      • removeTagSet

        public void removeTagSet​(TIFFTagSet tagSet)
        从目录中知道的TIFFTagSet的组中删除一个元素。
        参数
        tagSet - 要删除的 TIFFTagSet 。
        异常
        NullPointerException - 如果 tagSet是 null 。

      • getParentTag

        public TIFFTag getParentTag​()
        如果已经定义了该目录，则返回该目录的母版本TIFFTag ，否则返回null 。
        结果
        父 TIFFTag如此 TIFFDiectory或者 null 。

      • getTag

        public TIFFTag getTag​(int tagNumber)
        如果与此目录相关联的TIFFTagSet中没有此类标签，则返回TIFFTag ，其标签号等于tagNumber或null 。
        参数
        tagNumber - 感兴趣的标签号。
        结果
        相应的 TIFFTag或 null 。

      • getNumTIFFFields

        public int getNumTIFFFields​()
        返回此目录中的TIFFField的数量。
        结果
        该 TIFFField的数量在这 TIFFDirectory 。

      • containsTIFFField

        public boolean containsTIFFField​(int tagNumber)
        确定具有给定标签号的TIFF字段是否包含在此目录中。
        参数
        tagNumber - 标签号。
        结果
        无论是TIFFTag等于标签号码tagNumber是存在于该TIFFDirectory 。

      • addTIFFField

        public void addTIFFField​(TIFFField f)
        将TIFF字段添加到目录。
        参数
        f - 要添加的字段。
        异常
        NullPointerException - 如果 f是 null 。

      • getTIFFField

        public TIFFField getTIFFField​(int tagNumber)
        从目录中检索TIFF字段。
        参数
        tagNumber - 与该字段关联的标签的标签号。
        结果
        A TIFFField ，如果不存在这样的字段，请求的标签号为 null 。

      • removeTIFFField

        public void removeTIFFField​(int tagNumber)
        从目录中删除TIFF字段。
        参数
        tagNumber - 与该字段关联的标签的标签号。

      • getTIFFFields

        public TIFFField[] getTIFFFields​()
        从目录中检索所有TIFF字段。
        结果
        所有TIFF字段的数组按数字增加标签号的顺序排列。

      • removeTIFFFields

        public void removeTIFFFields​()
        从目录中删除所有TIFF字段。

      • getAsMetadata

        public IIOMetadata getAsMetadata​()
        将目录转换为元数据对象。
        结果
        从这个 TIFFDirectory的内容中初始化的元数据实例。

      • clone

        public TIFFDirectory clone​()
                    throws CloneNotSupportedException
        克隆目录及其中包含的所有字段。
        重写：
        clone在 Object
        结果
        这个 TIFFDirectory的克隆。
        异常
        CloneNotSupportedException - 如果实例无法克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TIFFField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class TIFFField

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFField
  • All Implemented Interfaces:
    Cloneable

    public final class TIFFField
extends Object
implements Cloneable
    表示TIFF 6.0图像文件目录中的字段的类。

    TIFF图像文件目录（IFD）中的字段被定义为伴随有相同数据类型的值序列的标签号。 TIFF 6.0定义了12种数据类型; TIFF技术说明1中的第13类型IFD在TIFF Specification Supplement 1中定义。这些TIFF数据类型由Java常量引用，并在内部映射到Java语言数据类型和类型名称，如下所示：

    TIFF Data Type to Java Data Type Mapping TIFF Data Type Java Constant Java Data Type Java Type Name BYTE TIFFTag.TIFF_BYTE byte "Byte" ASCII TIFFTag.TIFF_ASCII String "Ascii" SHORT TIFFTag.TIFF_SHORT char "Short" LONG TIFFTag.TIFF_LONG long "Long" RATIONAL TIFFTag.TIFF_RATIONAL long[2] {numerator, denominator} "Rational" SBYTE TIFFTag.TIFF_SBYTE byte "SByte" UNDEFINED TIFFTag.TIFF_UNDEFINED byte "Undefined" SSHORT TIFFTag.TIFF_SSHORT short "SShort" SLONG TIFFTag.TIFF_SLONG int "SLong" SRATIONAL TIFFTag.TIFF_SRATIONAL int[2] {numerator, denominator} "SRational" FLOAT TIFFTag.TIFF_FLOAT float "Float" DOUBLE TIFFTag.TIFF_DOUBLE double "Double" IFD TIFFTag.TIFF_IFD_POINTER long "IFDPointer"
    从以下版本开始：
    9
    另请参见：
    TIFFDirectory ， TIFFTag

    • 构造方法摘要

      构造方法
      Constructor 描述
      TIFFField​(TIFFTag tag, int type, int count)
      使用 createArrayForType()构造数据数组，并使用提供的参数和创建的数组调用 TIFFField(TIFFTag,int,int,Object) 。
      TIFFField​(TIFFTag tag, int type, int count, Object data)
      构造一个 TIFFField与任意数据。
      TIFFField​(TIFFTag tag, int type, long offset, TIFFDirectory dir)
      构造一个具有IFD偏移量和内容的 TIFFField 。
      TIFFField​(TIFFTag tag, long value)
      构造具有单个非负整数值的 TIFFField 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TIFFField clone​()
      克隆该字段及其中包含的所有信息。
      static Object createArrayForType​(int dataType, int count)
      创建一个适合指定数据类型的数组。
      static TIFFField createFromMetadataNode​(TIFFTagSet tagSet, Node node)
      从TIFF本机图像元数据节点创建一个 TIFFField 。
      byte[] getAsBytes​()
      将数据作为未解释的数组返回 byte 。
      char[] getAsChars​()
      返回 TIFFTag.TIFF_SHORT数据作为阵列 char S（无符号的16位整数）。
      double getAsDouble​(int index)
      以 double形式返回任何格式的 double 。
      double[] getAsDoubles​()
      返回 TIFFTag.TIFF_DOUBLE数据作为 double s（64位浮点值）的数组。
      float getAsFloat​(int index)
      以 float格式返回任何格式的 float 。
      float[] getAsFloats​()
      返回 TIFFTag.TIFF_FLOAT数据作为 float s（32位浮点值）的数组。
      int getAsInt​(int index)
      以 int形式返回任何格式的 int 。
      int[] getAsInts​()
      返回 TIFFTag.TIFF_SLONG数据作为阵列 int秒（带符号的32位整数）。
      long getAsLong​(int index)
      以 long格式返回任何格式的 long 。
      long[] getAsLongs​()
      返回 TIFFTag.TIFF_LONG或 TIFF_IFD_POINTER数据作为 long s（带符号的64位整数）的数组。
      Node getAsNativeNode​()
      返回 TIFFField作为名为 "TIFFField"或 "TIFFIFD"的节点，如TIFF本机图像元数据规范中所述。
      long[] getAsRational​(int index)
      返回一个TIFFTag.TIFF_RATIONAL数据项作为一个双元素的int数组。
      long[][] getAsRationals​()
      返回 TIFFTag.TIFF_RATIONAL数据作为2元件数组的数组 long秒。
      short[] getAsShorts​()
      返回 TIFFTag.TIFF_SSHORT数据作为 short s（带符号的16位整数）的数组。
      int[] getAsSRational​(int index)
      返回 TIFFTag.TIFF_SRATIONAL作为一个二单元阵列的数据项 int秒。
      int[][] getAsSRationals​()
      返回 TIFFTag.TIFF_SRATIONAL数据作为2元件数组的数组 int秒。
      String getAsString​(int index)
      返回 TIFFTag.TIFF_ASCII值作为 String 。
      int getCount​()
      返回字段中存在的数据项数。
      Object getData​()
      返回与该字段关联的数据对象的引用。
      TIFFDirectory getDirectory​()
      返回相关联的 TIFFDirectory （如果可用）。
      TIFFTag getTag​()
      检索与此字段关联的标签。
      int getTagNumber​()
      检索范围 [0,65535]的标签号。
      int getType​()
      返回字段中存储的数据类型。
      static int getTypeByName​(String typeName)
      返回与提供的数据类型名称相对应的数据类型常量。
      static String getTypeName​(int dataType)
      返回提供的数据类型常量的名称。
      String getValueAsString​(int index)
      返回一个 String其中包含数据项的人性化版本。
      boolean hasDirectory​()
      返回字段是否有一个 TIFFDirectory 。
      boolean isIntegral​()
      指示与该字段相关联的值是否为整数数据类型。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TIFFField

        public TIFFField​(TIFFTag tag,
                 int type,
                 int count,
                 Object data)
        构造具有任意数据的TIFFField 。 type参数必须是tag.isDataTypeOK()返回true的值。 data参数必须是适合于TIFF字段类型的Java类型的数组。

        请注意，无论该值所需的字节数如何， TIFFField的值（数据）将始终为实际字段值。 尽管事实是，与字段相对应的TIFF IFD条目实际上可以包含字段值的偏移而不是值本身（当且仅当该值适合4个字节时才发生）。 换句话说，字段的值已经从TIFF流中读取了。 （当该字段表示非基准IFD的内容时，可能会出现这种情况的例外情况，在这种情况下，数据将为long[]其中包含IFD的偏移量， TIFFDirectory返回的TIFFDirectory将是其内容。

        参数
        tag - 与此字段关联的标签。
        type - TIFFTag.TIFF_*常量中的一个，表示写入TIFF流的字段的数据类型。
        count - 数据值的数量。
        data - 字段的实际数据内容。
        异常
        NullPointerException - 如果是 tag == null 。
        IllegalArgumentException - 如果 type不是 TIFFTag.TIFF_*数据类型常量之一。
        IllegalArgumentException - 如果 type是所提供的 TIFFTag的不可接受的数据类型。
        IllegalArgumentException - 如果是 count < 0 。
        IllegalArgumentException - 如果 count < 1和 type是 TIFF_RATIONAL或 TIFF_SRATIONAL 。
        IllegalArgumentException - 如果 count != 1和 type是 TIFF_IFD_POINTER 。
        NullPointerException - 如果是 data == null 。
        IllegalArgumentException - 如果 data是与指定类型不兼容的类的实例。
        IllegalArgumentException - 如果数据数组的大小错误。
        IllegalArgumentException -如果所述数据数组的类型是 TIFF_LONG ， TIFF_RATIONAL ，或 TIFF_IFD_POINTER和任何元素是负的或大于 0xffffffff 。

      • TIFFField

        public TIFFField​(TIFFTag tag,
                 int type,
                 int count)
        使用 createArrayForType()构造数据数组，并使用提供的参数和创建的数组调用 TIFFField(TIFFTag,int,int,Object) 。
        参数
        tag - 与此字段关联的标签。
        type - TIFFTag.TIFF_*常量中的一个，表示写入TIFF流的字段的数据类型。
        count - 数据值的数量。
        异常
        NullPointerException - 如果是 tag == null 。
        IllegalArgumentException - 如果 type不是 TIFFTag.TIFF_*数据类型常量之一。
        IllegalArgumentException - 如果 type是所提供的 TIFFTag不可接受的数据类型。
        IllegalArgumentException - 如果是 count < 0 。
        IllegalArgumentException - 如果 count < 1和 type是 TIFF_RATIONAL或 TIFF_SRATIONAL 。
        IllegalArgumentException - 如果 count != 1和 type是 TIFF_IFD_POINTER 。
        另请参见：
        TIFFField(TIFFTag,int,int,Object)

      • TIFFField

        public TIFFField​(TIFFTag tag,
                 long value)
        构造具有单个非负整数值的TIFFField 。 该字段的类型为TIFF_SHORT如果value为[0,0xffff] ，并键入TIFF_LONG如果value为[0x10000,0xffffffff] 。 该领域的计数将是统一的。
        参数
        tag - 与此字段关联的标签。
        value - 与此字段关联的值。
        异常
        NullPointerException - 如果是 tag == null 。
        IllegalArgumentException - 如果 value不在 [0,0xffffffff] 。
        IllegalArgumentException -如果 value是 [0,0xffff]和 TIFF_SHORT是不可接受的类型为 TIFFTag ，或者如果 value是 [0x10000,0xffffffff]和 TIFF_LONG是不可接受的类型为 TIFFTag 。

      • TIFFField

        public TIFFField​(TIFFTag tag,
                 int type,
                 long offset,
                 TIFFDirectory dir)
        构造一个具有IFD偏移量和内容的TIFFField 。 偏移量将作为该字段的数据存储为long[] {offset} 。 该目录将不被克隆。 该领域的计数将是统一的。
        参数
        tag - 与此字段关联的标签。
        type - 其中一个常数 TIFFTag.TIFF_LONG或 TIFFTag.TIFF_IFD_POINTER 。
        offset - IFD偏移量。
        dir - 目录。
        异常
        NullPointerException - 如果是 tag == null 。
        IllegalArgumentException - 如果 type是所提供的 TIFFTag不可接受的数据类型。
        IllegalArgumentException - 如果 type既不是 TIFFTag.TIFF_LONG也不是 TIFFTag.TIFF_IFD_POINTER 。
        IllegalArgumentException - 如果是 offset <= 0 。
        NullPointerException - 如果是 dir == null 。
        另请参见：
        TIFFField(TIFFTag,int,int,Object)

    • 方法详细信息

      • createFromMetadataNode

        public static TIFFField createFromMetadataNode​(TIFFTagSet tagSet,
                                               Node node)
        从TIFF本机图像元数据节点创建一个TIFFField 。 如果该值"number"中没有找到该节点的属性tagSet那么新TIFFTag名称为TIFFTag.UNKNOWN_TAG_NAME将被创建并分配到外地。
        参数
        tagSet -该 TIFFTagSet到的 TIFFTag领域的所属。
        node - 本机TIFF图像元数据 TIFFField节点。
        结果
        一个新的 TIFFField 。
        异常
        IllegalArgumentException -如果Node参数含量不粘附到TIFFField由定义的元件结构TIFF native image metadata format specification ，或者如果节点属性和数据的组合不是每法律TIFFField(TIFFTag,int,int,Object)构造规范。 请注意，可能会在此类异常情况下设置原因。

      • getTag

        public TIFFTag getTag​()
        检索与此字段关联的标签。
        结果
        相关联的 TIFFTag 。

      • getTagNumber

        public int getTagNumber​()
        检索 [0,65535]范围内的标签号。
        结果
        标签号。

      • getType

        public int getType​()
        返回字段中存储的数据类型。 对于TIFF 6.0流，该值将等于TIFFTag.TIFF_*常量之一。 对于TIFF的未来修订，更高的值是可能的。
        结果
        字段值的数据类型。

      • getTypeName

        public static String getTypeName​(int dataType)
        返回提供的数据类型常量的名称。
        参数
        dataType - TIFFTag.TIFF_*常量之一，表示字段写入TIFF流的数据类型。
        结果
        与提供的类型常量对应的类型名称。
        异常
        IllegalArgumentException - 如果 dataType不是 TIFFTag.TIFF_*数据类型常量之一。

      • getTypeByName

        public static int getTypeByName​(String typeName)
        返回与提供的数据类型名称相对应的数据类型常量。 如果名称未知，将返回-1 。
        参数
        typeName - 类型名称。
        结果
        其中一个 TIFFTag.TIFF_*常量或 -1如果该名称不被识别。

      • createArrayForType

        public static Object createArrayForType​(int dataType,
                                        int count)
        创建一个适合指定数据类型的数组。
        参数
        dataType - TIFFTag.TIFF_*数据类型常量之一。
        count - 数组中的值的数量。
        结果
        适用于指定数据类型的数组。
        异常
        IllegalArgumentException - 如果 dataType不是 TIFFTag.TIFF_*数据类型常量之一。
        IllegalArgumentException - 如果是 count < 0 。
        IllegalArgumentException - 如果 count < 1和 type是 TIFF_RATIONAL或 TIFF_SRATIONAL 。
        IllegalArgumentException - 如果 count != 1和 type是 TIFF_IFD_POINTER 。

      • getAsNativeNode

        public Node getAsNativeNode​()
        返回TIFFField作为名为"TIFFField"或"TIFFIFD"的节点，如TIFF本机图像元数据规范中所述。 该节点将被命名为"TIFFIFD"当且仅当hasDirectory()个回报true和字段的类型为TIFFTag.TIFF_LONG或者TIFFTag.TIFF_IFD_POINTER 。
        结果
        一个 Node命名为 "TIFFField"或者 "TIFFIFD" 。

      • isIntegral

        public boolean isIntegral​()
        指示与该字段相关联的值是否为整数数据类型。
        结果
        场类型是否为积分。

      • getCount

        public int getCount​()
        返回字段中存在的数据项数。 对于TIFFTag.TIFF_ASCII字段，返回的值为String s，而不是文件表示中的数据总长度。
        结果
        存在于该字段中的数据项的数量。

      • getData

        public Object getData​()
        返回与该字段关联的数据对象的引用。
        结果
        字段的数据对象。

      • getAsBytes

        public byte[] getAsBytes​()
        以byte的无法解释的数组的byte返回数据。 类型字段的必须之一TIFFTag.TIFF_BYTE ， TIFF_SBYTE ，或TIFF_UNDEFINED 。

        对于TIFFTag.TIFF_BYTE格式的数据，应用程序在将数据推广到较长的整数类型时必须小心，以避免符号扩展。

        结果
        数据作为未解释的字节数组。
        异常
        ClassCastException -如果字段的类型是不 TIFF_BYTE ， TIFF_SBYTE ，或 TIFF_UNDEFINED 。

      • getAsChars

        public char[] getAsChars​()
        返回 TIFFTag.TIFF_SHORT数据作为 char s（无符号16位整数）的数组。
        结果
        数据为 char的数组。
        异常
        ClassCastException - 如果该字段不是类型 TIFF_SHORT 。

      • getAsShorts

        public short[] getAsShorts​()
        返回 TIFFTag.TIFF_SSHORT数据作为 short （有符号的16位整数）的数组。
        结果
        数据为 short的数组。
        异常
        ClassCastException - 如果字段不是类型 TIFF_SSHORT 。

      • getAsInts

        public int[] getAsInts​()
        返回 TIFFTag.TIFF_SLONG数据作为阵列 int秒（带符号的32位整数）。
        结果
        数据为 int的数组。
        异常
        ClassCastException -如果字段的类型是不 TIFF_SHORT ， TIFF_SSHORT ，或 TIFF_SLONG 。

      • getAsLongs

        public long[] getAsLongs​()
        返回 TIFFTag.TIFF_LONG或 TIFF_IFD_POINTER数据作为 long s（带符号的64位整数）的数组。
        结果
        数据为 long的数组。
        异常
        ClassCastException - 如果该字段不是类型 TIFF_LONG或 TIFF_IFD_POINTER 。

      • getAsFloats

        public float[] getAsFloats​()
        返回 TIFFTag.TIFF_FLOAT数据作为 float s（32位浮点值）的数组。
        结果
        数据为 float的数组。
        异常
        ClassCastException - 如果字段不是类型 TIFF_FLOAT 。

      • getAsDoubles

        public double[] getAsDoubles​()
        返回 TIFFTag.TIFF_DOUBLE数据作为 double s（64位浮点值）的数组。
        结果
        数据为 double的数组。
        异常
        ClassCastException - 如果字段不是类型 TIFF_DOUBLE 。

      • getAsSRationals

        public int[][] getAsSRationals​()
        返回 TIFFTag.TIFF_SRATIONAL数据作为2元件数组的数组 int秒。
        结果
        数据作为一系列符号理性。
        异常
        ClassCastException - 如果字段不是类型 TIFF_SRATIONAL 。

      • getAsRationals

        public long[][] getAsRationals​()
        返回 TIFFTag.TIFF_RATIONAL数据作为2元件数组的数组 long秒。
        结果
        数据作为无符号理性的数组。
        异常
        ClassCastException - 如果字段不是类型 TIFF_RATIONAL 。

      • getAsInt

        public int getAsInt​(int index)
        以int形式返回任何格式的int 。

        TIFFTag.TIFF_BYTE值被视为无符号; 也就是说，不会发生符号扩展，返回的值将在[0，255]范围内。 TIFF_SBYTE数据将返回范围[ TIFF_SBYTE ]。

        A TIFF_UNDEFINED价值被视为是一个TIFF_BYTE 。

        在数据TIFF_SLONG ， TIFF_LONG ， TIFF_FLOAT ， TIFF_DOUBLE或者TIFF_IFD_POINTER格式简单地转换为int ，并可从截断受到影响。

        TIFF_SRATIONAL或TIFF_RATIONAL格式中的数据通过使用双精度算术将分子除以分母，然后转换为int来进行int 。 可能会发生精度损失和截断。

        TIFF_ASCII格式的数据TIFF_ASCII Double.parseDouble方法进行解析，结果为int 。

        参数
        index - 数据的索引。
        结果
        给定指数的数据为 int 。

      • getAsLong

        public long getAsLong​(int index)
        以long形式返回任何格式的long 。

        TIFFTag.TIFF_BYTE和TIFF_UNDEFINED数据被视为无符号; 也就是说，不会发生符号扩展，返回的值将在[0，255]范围内。 TIFF_SBYTE数据将返回范围[ TIFF_SBYTE ]。

        TIFF_FLOAT和TIFF_DOUBLE中的数据简单地转换为long并可能遭受截断。

        TIFF_SRATIONAL或TIFF_RATIONAL格式的数据通过使用双精度算术将分子除以分母，然后转换为long来进行long 。 可能会发生精度损失和截断。

        TIFF_ASCII格式的数据TIFF_ASCII Double.parseDouble方法进行解析，结果转换为long 。

        参数
        index - 数据的索引。
        结果
        给定指数的数据为 long 。

      • getAsFloat

        public float getAsFloat​(int index)
        以float形式返回任何格式的float 。

        TIFFTag.TIFF_BYTE和TIFF_UNDEFINED数据被视为无符号; 也就是说，不会发生符号扩展，返回的值将在[0，255]范围内。 TIFF_SBYTE数据将返回范围[ TIFF_SBYTE ]。

        在数据TIFF_SLONG ， TIFF_LONG ， TIFF_DOUBLE ，或TIFF_IFD_POINTER格式简单地转换为float ，并可从截断受到影响。

        TIFF_SRATIONAL或TIFF_RATIONAL格式中的数据通过使用双精度算术将分子除以分母然后转换为float来进行float 。

        TIFF_ASCII格式的数据TIFF_ASCII Double.parseDouble方法进行解析，结果转换为float 。

        参数
        index - 数据的索引。
        结果
        给定指数的数据为 float 。

      • getAsDouble

        public double getAsDouble​(int index)
        以double形式返回任何格式的double 。

        TIFFTag.TIFF_BYTE和TIFF_UNDEFINED数据被视为无符号; 也就是说，不会发生符号扩展，返回的值将在[0，255]范围内。 TIFF_SBYTE数据将返回范围[ TIFF_SBYTE ]。

        TIFF_SRATIONAL或TIFF_RATIONAL格式中的数据通过使用双精度算术将分子除以分母来进行评估。

        TIFF_ASCII格式的数据TIFF_ASCII Double.parseDouble方法进行解析。

        参数
        index - 数据的索引。
        结果
        给定索引的数据为 double 。

      • getAsString

        public String getAsString​(int index)
        返回 TIFFTag.TIFF_ASCII值作为 String 。
        参数
        index - 数据的索引。
        结果
        给定指数的数据为 String 。
        异常
        ClassCastException - 如果字段不是类型 TIFF_ASCII 。

      • getAsSRational

        public int[] getAsSRational​(int index)
        返回 TIFFTag.TIFF_SRATIONAL作为一个二单元阵列的数据项 int秒。
        参数
        index - 数据的索引。
        结果
        给定指数的数据作为签名理性。
        异常
        ClassCastException - 如果字段不是类型 TIFF_SRATIONAL 。

      • getAsRational

        public long[] getAsRational​(int index)
        返回一个TIFFTag.TIFF_RATIONAL数据项作为一个双元素的int数组。
        参数
        index - 数据的索引。
        结果
        给定指数的数据为无符号理性。
        异常
        ClassCastException - 如果字段不是类型 TIFF_RATIONAL 。

      • getValueAsString

        public String getValueAsString​(int index)
        返回一个String包含数据项的人性化版本。 类型TIFFTag.TIFF_RATIONAL或TIFF_SRATIONAL数据表示为由'/'字符分隔的一对整数。 如果TIFFTag.TIFF_RATIONAL或TIFF_SRATIONAL的分子是分母的整数倍，则该值表示为"q/1" ，其中q是分子和分母的商。
        参数
        index - 数据的索引。
        结果
        给定指数的数据为 String 。
        异常
        ClassCastException - 如果该字段不是法定字段类型之一。

      • hasDirectory

        public boolean hasDirectory​()
        返回字段是否有一个 TIFFDirectory 。
        结果
        如果且仅当getDirectory（）返回非空值，则为true。

      • getDirectory

        public TIFFDirectory getDirectory​()
        返回相关联的TIFFDirectory （如果可用）。 如果没有设置目录，那么将返回null 。
        结果
        TIFFDirectory实例或null。

      • clone

        public TIFFField clone​()
                throws CloneNotSupportedException
        克隆该字段及其中包含的所有信息。
        重写：
        clone中的 Object
        结果
        这个克隆 TIFFField 。
        异常
        CloneNotSupportedException - 如果实例无法克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TIFFImageReadParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class TIFFImageReadParam

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
        • javax.imageio.plugins.tiff.TIFFImageReadParam

  • public final class TIFFImageReadParam
extends ImageReadParam
    ImageReadParam的子类允许控制TIFF读取过程。

    由于TIFF是可扩展格式，读者需要有关TIFF扩展使用的任何标签的信息，以便发出有意义的元数据。 此外，TIFF扩展可以定义新的压缩类型。 这两种类型的关于扩展的信息可以由该接口提供。

    额外的TIFF标签必须组织成TIFFTagSet s。 A TIFFTagSet可以通过addAllowedTagSet方法提供给读者。 默认情况下，标签设置BaselineTIFFTagSet ， FaxTIFFTagSet ， ExifParentTIFFTagSet ，并GeoTIFFTagSet都包括在内。

    对应于字段的强制读取TIFFTag不是在任何允许的TIFFTagSet S可以通过来实现setReadUnknownTags 。

    从以下版本开始：
    9

    • Field Summary

      • Fields inherited from class javax.imageio.IIOParam

        controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset

      • Fields inherited from class javax.imageio.ImageReadParam

        canSetSourceRenderSize, destination, destinationBands, minProgressivePass, numProgressivePasses, sourceRenderSize

    • 构造方法摘要

      构造方法
      Constructor 描述
      TIFFImageReadParam​()
      构造一个 TIFFImageReadParam 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addAllowedTagSet​(TIFFTagSet tagSet)
      将 TIFFTagSet对象添加到允许的标签集列表中。
      List<TIFFTagSet> getAllowedTagSets​()
      返回 List包含允许 TIFFTagSet对象。
      boolean getReadUnknownTags​()
      检索是否读取对应于未知的字段 TIFFTag的设置。
      void removeAllowedTagSet​(TIFFTagSet tagSet)
      从允许的标签集列表中删除一个 TIFFTagSet对象。
      void setReadUnknownTags​(boolean readUnknownTags)
      设置是否读取对应于 TIFFTag的字段不在允许的 TIFFTagSet 。

      • Methods inherited from class javax.imageio.IIOParam

        activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setSourceBands, setSourceRegion, setSourceSubsampling

      • Methods inherited from class javax.imageio.ImageReadParam

        canSetSourceRenderSize, getDestination, getDestinationBands, getSourceMaxProgressivePass, getSourceMinProgressivePass, getSourceNumProgressivePasses, getSourceRenderSize, setDestination, setDestinationBands, setDestinationType, setSourceProgressivePasses, setSourceRenderSize

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TIFFImageReadParam

        public TIFFImageReadParam​()
        构造一个TIFFImageReadParam 。 由定义的标签TIFFTagSet小号BaselineTIFFTagSet ， FaxTIFFTagSet ， ExifParentTIFFTagSet ，并GeoTIFFTagSet将得到支持。
        另请参见：
        BaselineTIFFTagSet ， FaxTIFFTagSet ， ExifParentTIFFTagSet ， GeoTIFFTagSet

    • 方法详细信息

      • addAllowedTagSet

        public void addAllowedTagSet​(TIFFTagSet tagSet)
        将TIFFTagSet对象添加到允许的标签集列表中。 尝试将重复的对象添加到列表中没有任何效果。
        参数
        tagSet - a TIFFTagSet 。
        异常
        IllegalArgumentException - 如果 tagSet是 null 。

      • removeAllowedTagSet

        public void removeAllowedTagSet​(TIFFTagSet tagSet)
        从允许的标签集列表中删除TIFFTagSet对象。 去除是基于equals所述的方法TIFFTagSet ，其通常被定义为引用相等。
        参数
        tagSet - a TIFFTagSet 。
        异常
        IllegalArgumentException - 如果 tagSet是 null 。

      • getAllowedTagSets

        public List<TIFFTagSet> getAllowedTagSets​()
        返回 List包含允许 TIFFTagSet对象。
        结果
        一个 List的 TIFFTagSet s。

      • setReadUnknownTags

        public void setReadUnknownTags​(boolean readUnknownTags)
        设置是否读取对应于TIFFTag的字段不在允许的TIFFTagSet 。 默认设置为false 。 如果TIFF ImageReader忽略了元数据，则true的设置将被覆盖，因为所有元数据都被忽略，除了读取图像本身所必需的元数据外。
        参数
        readUnknownTags - 是否读取无法识别的标签的字段

      • getReadUnknownTags

        public boolean getReadUnknownTags​()
        检索是否读取对应于未知的字段的设置 TIFFTag s。
        结果
        是否读取无法识别的标签的字段
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TIFFTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class TIFFTag

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFTag

  • public class TIFFTag
extends Object
    定义TIFF标签概念的类。 TIFF标签是可能出现在图像文件目录（IFD）中的键。 在IFD中，每个标签具有与其相关联的一些数据，其可以由给定数据类型的零个或多个值组成。 标签和值的组合称为IFD条目或TIFF字段。

    标准（“基线”）tiff流的根IFD中使用的实际标签值在BaselineTIFFTagSet类中定义。

    从以下版本开始：
    9
    另请参见：
    BaselineTIFFTagSet ， TIFFField ， TIFFTagSet

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int MAX_DATATYPE
      表示TIFF数据类型的数字最大常数。
      static int MIN_DATATYPE
      表示TIFF数据类型的数字最小的常数。
      static int TIFF_ASCII
      标记为空终止的ASCII字符串。
      static int TIFF_BYTE
      8位无符号整数的标志。
      static int TIFF_DOUBLE
      标志为64位IEEE双精度。
      static int TIFF_FLOAT
      32位IEEE浮标的标志。
      static int TIFF_IFD_POINTER
      TIFF技术说明1中TIFF技术说明1中定义的IFD指针标志。
      static int TIFF_LONG
      32位无符号整数的标志。
      static int TIFF_RATIONAL
      32位无符号整数的标志。
      static int TIFF_SBYTE
      8位有符号整数的标志。
      static int TIFF_SHORT
      标志为16位无符号整数。
      static int TIFF_SLONG
      32位有符号整数的标志。
      static int TIFF_SRATIONAL
      32位有符号整数的标志。
      static int TIFF_SSHORT
      标志为16位有符号整数。
      static int TIFF_UNDEFINED
      8位未解释字节的标志。
      static String UNKNOWN_TAG_NAME
      分配给具有未知标签号的标签的名称。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TIFFTag​(String name, int number, int dataTypes)
      构造具有给定名称，标签号和法定数据类型集合的 TIFFTag 。
      TIFFTag​(String name, int number, int dataTypes, int count)
      构造具有给定名称，标签号，法定数据类型集合和值计数的 TIFFTag 。
      TIFFTag​(String name, int number, TIFFTagSet tagSet)
      构造一个 TIFFTag与给定的名称，标签号和 TIFFTagSet它参考。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void addValueName​(int value, String name)
      为此标签的数据可能需要的特定值添加一个助记符名称。
      int getCount​()
      返回此标签的值计数。
      int getDataTypes​()
      返回指示可用于存储与标签相关联的数据的数据类型集的位掩码。
      String getName​()
      返回标记的名称，因为它将显示在图像元数据中。
      int[] getNamedValues​()
      返回定义助记符名称的值的数组。
      int getNumber​()
      返回用于表示标签的整数。
      static int getSizeOfType​(int dataType)
      返回用于存储给定数据类型的值的字节数。
      TIFFTagSet getTagSet​()
      返回此标签是其中的 TIFFTagSet 。
      String getValueName​(int value)
      返回与该标签的数据可能占用的特定值相关联的助记符名称，如果没有名称，则 null 。
      boolean hasValueNames​()
      如果存在与该标签相关联的数据的合法值集合的助记名称，则返回 true 。
      boolean isDataTypeOK​(int dataType)
      如果给定的数据类型可以用于与此标签关联的数据，则返回 true 。
      boolean isIFDPointer​()
      如果此标记用于指向包含其他标记的IFD结构，则返回 true 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • TIFF_BYTE

        public static final int TIFF_BYTE
        8位无符号整数的标志。
        另请参见：
        Constant Field Values

      • TIFF_ASCII

        public static final int TIFF_ASCII
        标记为空终止的ASCII字符串。
        另请参见：
        Constant Field Values

      • TIFF_SHORT

        public static final int TIFF_SHORT
        标志为16位无符号整数。
        另请参见：
        Constant Field Values

      • TIFF_LONG

        public static final int TIFF_LONG
        32位无符号整数的标志。
        另请参见：
        Constant Field Values

      • TIFF_RATIONAL

        public static final int TIFF_RATIONAL
        32位无符号整数的标志。
        另请参见：
        Constant Field Values

      • TIFF_SBYTE

        public static final int TIFF_SBYTE
        8位有符号整数的标志。
        另请参见：
        Constant Field Values

      • TIFF_UNDEFINED

        public static final int TIFF_UNDEFINED
        8位未解释字节的标志。
        另请参见：
        Constant Field Values

      • TIFF_SSHORT

        public static final int TIFF_SSHORT
        标志为16位有符号整数。
        另请参见：
        Constant Field Values

      • TIFF_SLONG

        public static final int TIFF_SLONG
        32位有符号整数的标志。
        另请参见：
        Constant Field Values

      • TIFF_SRATIONAL

        public static final int TIFF_SRATIONAL
        32位有符号整数的标志。
        另请参见：
        Constant Field Values

      • TIFF_FLOAT

        public static final int TIFF_FLOAT
        32位IEEE浮标的标志。
        另请参见：
        Constant Field Values

      • TIFF_DOUBLE

        public static final int TIFF_DOUBLE
        标志为64位IEEE双精度。
        另请参见：
        Constant Field Values

      • TIFF_IFD_POINTER

        public static final int TIFF_IFD_POINTER
        TIFF技术说明1中TIFF技术说明1中定义的IFD指针标志。
        另请参见：
        Constant Field Values

      • MIN_DATATYPE

        public static final int MIN_DATATYPE
        表示TIFF数据类型的数字最小的常数。
        另请参见：
        Constant Field Values

      • MAX_DATATYPE

        public static final int MAX_DATATYPE
        表示TIFF数据类型的数字最大常数。
        另请参见：
        Constant Field Values

      • UNKNOWN_TAG_NAME

        public static final String UNKNOWN_TAG_NAME
        分配给具有未知标签号的标签的名称。 这样的标签可以例如在读取IFD时被创建，并且遇到不在阅读器已知的任何TIFFTagSet的标签号。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • TIFFTag

        public TIFFTag​(String name,
               int number,
               int dataTypes,
               int count)
        构造具有给定名称，标签号，法定数据类型集合和值计数的TIFFTag 。 负值计数表示任意数量的值合法或所需计数由IFD中其他字段的值确定。 非负数指定相关字段必须包含的值的数量。 该标签将没有关联的TIFFTagSet 。

        如果有助记符名称与标签的合法数据值相关联，则应在每个名称的新实例上调用addValueName() 。 助记符名称仅适用于具有整数数据类型的标签。

        有关如何将数据类型转换为位掩码的说明，请参阅getDataTypes()的文档。

        参数
        name - 标签的名称。
        number - 用于表示标签的数字。
        dataTypes - 指示该标签的法定数据类型集的位掩码。
        count - 此标记的值计数。
        异常
        NullPointerException - 如果name为null。
        IllegalArgumentException - 如果number为负数或dataTypes为负数或指定超出范围类型。

      • TIFFTag

        public TIFFTag​(String name,
               int number,
               TIFFTagSet tagSet)
        构造一个TIFFTag具有给定的名称，标签号和TIFFTagSet 。 法定数据类型设置为TIFF_LONG和TIFF_IFD_POINTER ，值计数为1。 TIFFTagSet将代表IFD指出的TIFFTag的一组。 A TIFFTag表示IFD指针，当且仅当tagSet为非null或数据类型TIFF_IFD_POINTER合法时。
        参数
        name - 标签的名称。
        number - 用于表示标签的数字。
        tagSet - 该标签所属的 TIFFTagSet 。
        异常
        NullPointerException - 如果name或tagSet为null。
        IllegalArgumentException - 如果number为负数。
        另请参见：
        TIFFTag(String, int, int, int)

      • TIFFTag

        public TIFFTag​(String name,
               int number,
               int dataTypes)
        构造具有给定名称，标签号和法定数据类型的TIFFTag 。 标签的值计数将是未定义的，它将没有关联的TIFFTagSet 。
        参数
        name - 标签的名称。
        number - 用于表示标签的数字。
        dataTypes - 指示该标签的法定数据类型集合的位掩码。
        异常
        NullPointerException - 如果name为null。
        IllegalArgumentException - 如果number为负数或dataTypes为负数或指定超出范围类型。
        另请参见：
        TIFFTag(String, int, int, int)

    • 方法详细信息

      • getSizeOfType

        public static int getSizeOfType​(int dataType)
        返回用于存储给定数据类型的值的字节数。
        参数
        dataType - 要查询的数据类型。
        结果
        用于存储给定数据类型的字节数。
        异常
        IllegalArgumentException - 如果 datatype小于 MIN_DATATYPE或大于 MAX_DATATYPE 。

      • getName

        public String getName​()
        返回标记的名称，因为它将显示在图像元数据中。
        结果
        标签名称，作为 String 。

      • getNumber

        public int getNumber​()
        返回用于表示标签的整数。
        结果
        标签号，作为 int 。

      • getDataTypes

        public int getDataTypes​()
        返回指示可用于存储与标签相关联的数据的数据类型集的位掩码。 例如，可以存储SHORT和LONG值的标签将返回以下值：
          (1 << TIFFTag.TIFF_SHORT) | (1 << TIFFTag.TIFF_LONG)
        结果
        一个 int包含编码有效数据类型集的位掩码。

      • getCount

        public int getCount​()
        返回此标签的值计数。 如果此值为正，则表示具有此标记的TIFFField的所需数量值。 如果值为负，则计数未定义。 在后一种情况下，可以导出计数，例如， BitsPerSample字段的值的数量是SamplesPerPixel ，或者可以是大多数US-ASCII字段的情况下的变量。
        结果
        该标签的值计数。

      • isDataTypeOK

        public boolean isDataTypeOK​(int dataType)
        如果给定的数据类型可以用于与此标签关联的数据，则返回 true 。
        参数
        dataType -要查询的数据类型的一个 TIFF_BYTE ， TIFF_SHORT等
        结果
        一个 boolean指示给定的数据类型是否可以与该标签一起使用。
        异常
        IllegalArgumentException - 如果 datatype小于 MIN_DATATYPE或大于 MAX_DATATYPE 。

      • getTagSet

        public TIFFTagSet getTagSet​()
        返回该标签是其中的 TIFFTagSet 。
        结果
        包含 TIFFTagSet 。

      • isIFDPointer

        public boolean isIFDPointer​()
        如果此标记用于指向包含其他标记的IFD结构，则返回true 。 A TIFFTag表示IFD指针，当且仅当其TIFFTagSet为非null或数据类型TIFF_IFD_POINTER合法时。 当且仅当getTagSet() != null或isDataTypeOK(TIFF_IFD_POINTER) == true才能满足此条件。

        许多TIFF扩展使用IFD机制来限制可能出现在根IFD中的新标签的数量。

        结果
        如果此标签指向IFD， true 。

      • hasValueNames

        public boolean hasValueNames​()
        如果存在与该标签关联的数据的合法值集合的助记名称，则返回true 。 助记符名称仅适用于具有整数数据类型的标签。
        结果
        true如果助记符值名称可用。

      • addValueName

        protected void addValueName​(int value,
                            String name)
        为此标签的数据可能需要的特定值添加一个助记符名称。 助记符名称仅适用于具有整数数据类型的标签。
        参数
        value - 数据值。
        name - 与值相关联的名称。

      • getValueName

        public String getValueName​(int value)
        返回与该标签的数据可能占用的特定值相关联的助记符名称，如果没有名称，则null 。 助记符名称仅适用于具有整数数据类型的标签。
        参数
        value - 数据值。
        结果
        与该值相关联的助记符名称，作为 String 。

      • getNamedValues

        public int[] getNamedValues​()
        返回定义助记符名称的值的数组。 方法getValueName()将仅返回非null仅用于返回数组中包含的值。 助记符名称仅适用于具有整数数据类型的标签。
        结果
        有一个助记符名称的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


TIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.plugins.tiff

Class TIFFTagSet

  • java.lang.Object
    • javax.imageio.plugins.tiff.TIFFTagSet
  • 已知直接子类：
    BaselineTIFFTagSet ， ExifGPSTagSet ， ExifInteroperabilityTagSet ， ExifParentTIFFTagSet ， ExifTIFFTagSet ， FaxTIFFTagSet ， GeoTIFFTagSet

    public class TIFFTagSet
extends Object
    代表一组TIFF标签的类。 集合中的每个标签必须具有唯一的编号（这是TIFF规范本身的限制）。

    此类及其子类负责在原始标签号码和TIFFTag对象之间进行映射，其中包含有关每个标签的附加信息，例如标签的名称，法定数据类型以及某些或所有数据值的助记符名称。

    从以下版本开始：
    9
    另请参见：
    TIFFTag

    • 构造方法摘要

      构造方法
      Constructor 描述
      TIFFTagSet​(List<TIFFTag> tags)
      构造一个 TIFFTagSet ，给出一个 List的 TIFFTag对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TIFFTag getTag​(int tagNumber)
      从该集合返回与给定标签号相关联的 null如果该数字没有标签，则返回 TIFFTag 。
      TIFFTag getTag​(String tagName)
      返回 TIFFTag具有给定标记名称，或者 null如果指定的标记不属于这个标签集。
      SortedSet<String> getTagNames​()
      检索不可修改的词典增加的标签名称集合。
      SortedSet<Integer> getTagNumbers​()
      检索一个不可修改的数字增加的标签号集合。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TIFFTagSet

        public TIFFTagSet​(List<TIFFTag> tags)
        构造一个 TIFFTagSet ，给出一个 List的 TIFFTag对象。
        参数
        tags - 一个 List对象，包含要添加到此标签集的 TIFFTag对象。
        异常
        IllegalArgumentException - 如果 tags为 null ，或包含不是 TIFFTag类的实例的对象。

    • 方法详细信息

      • getTag

        public TIFFTag getTag​(int tagNumber)
        从该集合返回与给定标签号相关联的 null如果该数字没有标签，则返回 TIFFTag 。
        参数
        tagNumber - 要检索的标签的编号。
        结果
        编号为 TIFFTag或 null 。

      • getTag

        public TIFFTag getTag​(String tagName)
        返回 TIFFTag具有给定标记名称，或者 null如果指定的标记不属于这个标签集。
        参数
        tagName - 要检索的标签的名称，作为 String 。
        结果
        名为 TIFFTag ，或 null 。
        异常
        IllegalArgumentException - 如果 tagName是 null 。

      • getTagNumbers

        public SortedSet<Integer> getTagNumbers​()
        检索一个不可修改的数字增加的标签号集合。

        返回的对象是不可修改的，包含所有的标签号TIFFTag S IN此TIFFTagSet按升序排序Comparable.compareTo(Object) 。

        结果
        此集合中的所有标签号。

      • getTagNames

        public SortedSet<String> getTagNames​()
        检索不可修改的词典增加的标签名称集合。

        返回的对象是不可修改的，包含所有的标签名称TIFFTag S IN此TIFFTagSet按升序排序Comparable.compareTo(Object) 。

        结果
        此集合中的所有标签名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.imageio.plugins.tiff (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.imageio.plugins.tiff

  • Packages that use javax.imageio.plugins.tiff
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。
  • Classes in javax.imageio.plugins.tiff used by javax.imageio.plugins.tiff
    Class 描述
    BaselineTIFFTagSet
    表示在基准TIFF规范中找到的一组标签的类以及一些常见的附加标签。
    ExifGPSTagSet
    代表在Exif GPS Info IFD中找到的标签的类。
    ExifInteroperabilityTagSet
    代表在Exif互操作性IFD中找到的标签的类。
    ExifParentTIFFTagSet
    包含用于引用Exif和GPS IFD的TIFF标签的类。
    ExifTIFFTagSet
    代表在Exif IFD中找到的标签的类。
    FaxTIFFTagSet
    表示在 TIFF-F （RFC 2036）文件中找到的额外标签的类。
    GeoTIFFTagSet
    代表GeoTIFF IFD中找到的标签的类。
    TIFFDirectory
    简化与TIFF本地图像元数据交互的便利类。
    TIFFField
    表示TIFF 6.0图像文件目录中的字段的类。
    TIFFTag
    定义TIFF标签概念的类。
    TIFFTagSet
    代表一组TIFF标签的类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.BaselineTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.BaselineTIFFTagSet

  • Packages that use BaselineTIFFTagSet
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of BaselineTIFFTagSet in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return BaselineTIFFTagSet
      Modifier and Type 方法 描述
      static BaselineTIFFTagSet BaselineTIFFTagSet.getInstance​()
      返回一个 BaselineTIFFTagSet的共享实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.ExifGPSTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.ExifGPSTagSet

  • Packages that use ExifGPSTagSet
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of ExifGPSTagSet in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return ExifGPSTagSet
      Modifier and Type 方法 描述
      static ExifGPSTagSet ExifGPSTagSet.getInstance​()
      返回 ExifGPSTagSet的共享实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.ExifInteroperabilityTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.ExifInteroperabilityTagSet

  • Packages that use ExifInteroperabilityTagSet
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of ExifInteroperabilityTagSet in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return ExifInteroperabilityTagSet
      Modifier and Type 方法 描述
      static ExifInteroperabilityTagSet ExifInteroperabilityTagSet.getInstance​()
      返回共享实例 ExifInteroperabilityTagSet 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.ExifParentTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.ExifParentTIFFTagSet

  • Packages that use ExifParentTIFFTagSet
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of ExifParentTIFFTagSet in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return ExifParentTIFFTagSet
      Modifier and Type 方法 描述
      static ExifParentTIFFTagSet ExifParentTIFFTagSet.getInstance​()
      返回一个 ExifParentTIFFTagSet的共享实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.ExifTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.ExifTIFFTagSet

  • Packages that use ExifTIFFTagSet
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of ExifTIFFTagSet in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return ExifTIFFTagSet
      Modifier and Type 方法 描述
      static ExifTIFFTagSet ExifTIFFTagSet.getInstance​()
      返回一个 ExifTIFFTagSet的共享实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.FaxTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.FaxTIFFTagSet

  • Packages that use FaxTIFFTagSet
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of FaxTIFFTagSet in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return FaxTIFFTagSet
      Modifier and Type 方法 描述
      static FaxTIFFTagSet FaxTIFFTagSet.getInstance​()
      返回一个 FaxTIFFTagSet的共享实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.GeoTIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.GeoTIFFTagSet

  • Packages that use GeoTIFFTagSet
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of GeoTIFFTagSet in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return GeoTIFFTagSet
      Modifier and Type 方法 描述
      static GeoTIFFTagSet GeoTIFFTagSet.getInstance​()
      返回一个 GeoTIFFTagSet的共享实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.TIFFDirectory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.TIFFDirectory

  • Packages that use TIFFDirectory
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of TIFFDirectory in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return TIFFDirectory
      Modifier and Type 方法 描述
      TIFFDirectory TIFFDirectory.clone​()
      克隆目录及其中包含的所有字段。
      static TIFFDirectory TIFFDirectory.createFromMetadata​(IIOMetadata tiffImageMetadata)
      从图像元数据对象的内容创建 TIFFDirectory实例。
      TIFFDirectory TIFFField.getDirectory​()
      返回相关的 TIFFDirectory （如果有）。
      Constructors in javax.imageio.plugins.tiff with parameters of type TIFFDirectory
      Constructor 描述
      TIFFField​(TIFFTag tag, int type, long offset, TIFFDirectory dir)
      构造一个具有IFD偏移量和内容的 TIFFField 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.TIFFField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.TIFFField

  • Packages that use TIFFField
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of TIFFField in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return TIFFField
      Modifier and Type 方法 描述
      TIFFField TIFFField.clone​()
      克隆该字段及其中包含的所有信息。
      static TIFFField TIFFField.createFromMetadataNode​(TIFFTagSet tagSet, Node node)
      从TIFF本机图像元数据节点创建 TIFFField 。
      TIFFField TIFFDirectory.getTIFFField​(int tagNumber)
      从目录中检索TIFF字段。
      TIFFField[] TIFFDirectory.getTIFFFields​()
      从目录中检索所有TIFF字段。
      Methods in javax.imageio.plugins.tiff with parameters of type TIFFField
      Modifier and Type 方法 描述
      void TIFFDirectory.addTIFFField​(TIFFField f)
      将TIFF字段添加到目录。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.TIFFImageReadParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.TIFFImageReadParam

No usage of javax.imageio.plugins.tiff.TIFFImageReadParam
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.TIFFTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.TIFFTag

  • Packages that use TIFFTag
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of TIFFTag in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return TIFFTag
      Modifier and Type 方法 描述
      TIFFTag TIFFDirectory.getParentTag​()
      返回父TIFFTag这个目录如果已定义或null其他。
      TIFFTag TIFFDirectory.getTag​(int tagNumber)
      如果与该目录相关联的TIFFTagSet s中没有此类标签，则返回TIFFTag ，其标签号等于tagNumber或null 。
      TIFFTag TIFFField.getTag​()
      检索与此字段关联的标签。
      TIFFTag TIFFTagSet.getTag​(int tagNumber)
      返回该集合中与给定标签号相关联的 null如果该号码中没有标签，则返回 TIFFTag 。
      TIFFTag TIFFTagSet.getTag​(String tagName)
      返回 TIFFTag具有给定标记名称，或者 null如果指定的标记不属于这个标签集。
      Constructors in javax.imageio.plugins.tiff with parameters of type TIFFTag
      Constructor 描述
      TIFFDirectory​(TIFFTagSet[] tagSets, TIFFTag parentTag)
      构造一个TIFFDirectory ，它知道给定的一组TIFFTagSet s。
      TIFFField​(TIFFTag tag, int type, int count)
      使用 createArrayForType()构造数据数组，并使用提供的参数和创建的数组调用 TIFFField(TIFFTag,int,int,Object) 。
      TIFFField​(TIFFTag tag, int type, int count, Object data)
      构造具有任意数据的 TIFFField 。
      TIFFField​(TIFFTag tag, int type, long offset, TIFFDirectory dir)
      构造具有IFD偏移量和内容的 TIFFField 。
      TIFFField​(TIFFTag tag, long value)
      构造具有单个非负整数值的 TIFFField 。
      Constructor parameters in javax.imageio.plugins.tiff with type arguments of type TIFFTag
      Constructor 描述
      TIFFTagSet​(List<TIFFTag> tags)
      构造一个 TIFFTagSet ，给出一个 List的 TIFFTag对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.plugins.tiff.TIFFTagSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.plugins.tiff.TIFFTagSet

  • Packages that use TIFFTagSet
    软件包 描述
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。

    • Uses of TIFFTagSet in javax.imageio.plugins.tiff

      Subclasses of TIFFTagSet in javax.imageio.plugins.tiff
      Modifier and Type Class 描述
      class  BaselineTIFFTagSet
      表示在基准TIFF规范中找到的一组标签的类以及一些常见的附加标签。
      class  ExifGPSTagSet
      代表在Exif GPS Info IFD中找到的标签的类。
      class  ExifInteroperabilityTagSet
      代表在Exif互操作性IFD中找到的标签的类。
      class  ExifParentTIFFTagSet
      包含用于引用Exif和GPS IFD的TIFF标签的类。
      class  ExifTIFFTagSet
      代表在Exif IFD中找到的标签的类。
      class  FaxTIFFTagSet
      表示在 TIFF-F （RFC 2036）文件中找到的额外标签的类。
      class  GeoTIFFTagSet
      代表GeoTIFF IFD中找到的标签的类。
      Methods in javax.imageio.plugins.tiff that return TIFFTagSet
      Modifier and Type 方法 描述
      TIFFTagSet TIFFTag.getTagSet​()
      返回该标签是其中的 TIFFTagSet 。
      TIFFTagSet[] TIFFDirectory.getTagSets​()
      返回此目录知道的TIFFTagSet s。
      Methods in javax.imageio.plugins.tiff that return types with arguments of type TIFFTagSet
      Modifier and Type 方法 描述
      List<TIFFTagSet> TIFFImageReadParam.getAllowedTagSets​()
      返回 List包含允许 TIFFTagSet对象。
      Methods in javax.imageio.plugins.tiff with parameters of type TIFFTagSet
      Modifier and Type 方法 描述
      void TIFFImageReadParam.addAllowedTagSet​(TIFFTagSet tagSet)
      将 TIFFTagSet对象添加到允许的标签集列表中。
      void TIFFDirectory.addTagSet​(TIFFTagSet tagSet)
      将一个元素添加到该目录知道的TIFFTagSet的组中。
      static TIFFField TIFFField.createFromMetadataNode​(TIFFTagSet tagSet, Node node)
      从TIFF本机图像元数据节点创建一个 TIFFField 。
      void TIFFImageReadParam.removeAllowedTagSet​(TIFFTagSet tagSet)
      从允许的标签集列表中删除一个 TIFFTagSet对象。
      void TIFFDirectory.removeTagSet​(TIFFTagSet tagSet)
      从目录中知道的TIFFTagSet的组中删除一个元素。
      Constructors in javax.imageio.plugins.tiff with parameters of type TIFFTagSet
      Constructor 描述
      TIFFDirectory​(TIFFTagSet[] tagSets, TIFFTag parentTag)
      构造一个TIFFDirectory ，它知道给定的一组TIFFTagSet s。
      TIFFTag​(String name, int number, TIFFTagSet tagSet)
      构造一个 TIFFTag具有给定名称，标签号码和 TIFFTagSet它所指。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


IIORegistry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Class IIORegistry

  • java.lang.Object
    • javax.imageio.spi.ServiceRegistry
      • javax.imageio.spi.IIORegistry

  • public final class IIORegistry
extends ServiceRegistry
    服务提供商实例的注册表。 可以通过在包含它们的JAR文件中的元信息在运行时检测服务提供者类。 意图是加载和检查所有可用的服务提供商类是相对便宜的。 这些类可以在它们被用来定位和实例在这种情况下，情况更重量级的类，将执行工作实际， ImageReader ， ImageWriter ， ImageTranscoder ， ImageInputStream ，并ImageOutputStream 。 一旦该类被实例化，从Java平台发现的服务提供者就会自动加载。

    当调用registerApplicationClasspathSpis方法时，将加载在应用程序类路径上的JAR文件的元信息部分中声明的服务提供程序实例。 要声明服务提供商， services子目录将放置在每个JAR文件中的META-INF目录中。 此目录包含每个服务提供程序接口的文件，该接口在JAR文件中具有一个或多个实现类。 例如，如果JAR文件包含一个名为com.mycompany.imageio.MyFormatReaderSpi的类，该类实现了ImageReaderSpi接口，则JAR文件将包含一个名为

      META-INF/services/javax.imageio.spi.ImageReaderSpi
    包含行：
      com.mycompany.imageio.MyFormatReaderSpi

    服务提供商类旨在轻量化并快速加载。 这些接口的实现应避免对其他类和本地代码的复杂依赖。

    也可以手动添加未自动找到的服务提供者，并删除那些正在使用ServiceRegistry类接口的服务提供商。 因此，应用程序可以根据自己的需要定制注册表的内容。

    有关声明服务提供商的更多详细信息以及JAR格式，请参阅JAR File Specification 。

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.imageio.spi.ServiceRegistry

        ServiceRegistry.Filter

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static IIORegistry getDefaultInstance​()
      返回Image I / O API使用的默认 IIORegistry实例。
      void registerApplicationClasspathSpis​()
      注册应用程序类路径中找到的所有可用服务提供商，使用默认值 ClassLoader 。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.imageio.spi.ServiceRegistry

        contains, deregisterAll, deregisterAll, deregisterServiceProvider, deregisterServiceProvider, finalize, getCategories, getServiceProviderByClass, getServiceProviders, getServiceProviders, lookupProviders, lookupProviders, registerServiceProvider, registerServiceProvider, registerServiceProviders, setOrdering, unsetOrdering

    • 方法详细信息

      • getDefaultInstance

        public static IIORegistry getDefaultInstance​()
        返回Image I / O API使用的默认IIORegistry实例。 该实例应用于所有注册表功能。

        每个ThreadGroup都会收到自己的实例; 这允许不同的Applet在同一个浏览器（例如），每个都有自己的注册表。

        结果
        目前的默认注册表为 ThreadGroup 。

      • registerApplicationClasspathSpis

        public void registerApplicationClasspathSpis​()
        注册应用程序类路径中找到的所有可用服务提供商，使用默认的ClassLoader 。 这种方法通常由ImageIO.scanForPlugins方法调用。
        另请参见：
        ImageIO.scanForPlugins(), ClassLoader.getResources(java.lang.String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IIOServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Class IIOServiceProvider

  • java.lang.Object
    • javax.imageio.spi.IIOServiceProvider
  • All Implemented Interfaces:
    RegisterableService
    已知直接子类：
    ImageInputStreamSpi ， ImageOutputStreamSpi ， ImageReaderWriterSpi ， ImageTranscoderSpi

    public abstract class IIOServiceProvider
extends Object
implements RegisterableService
    所有Image I / O服务提供商接口（SPI）通用功能的超级界面。 有关服务提供程序类的更多信息，请参阅IIORegistry类的类注释。
    另请参见：
    IIORegistry ， ImageReaderSpi ， ImageWriterSpi ， ImageTranscoderSpi ， ImageInputStreamSpi ， ImageOutputStreamSpi

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected String vendorName
      A String从 getVendorName返回，最初为 null 。
      protected String version
      A String从 getVersion返回，最初为null。

    • 构造方法摘要

      构造方法
      Constructor 描述
      IIOServiceProvider​()
      构造一个空白 IIOServiceProvider 。
      IIOServiceProvider​(String vendorName, String version)
      构造具有给定供应商名称和版本标识符的 IIOServiceProvider 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract String getDescription​(Locale locale)
      返回此服务提供商及其相关实现的简短可读的描述。
      String getVendorName​()
      返回负责创建此服务提供商及其关联实施的供应商的名称。
      String getVersion​()
      返回描述此服务提供商及其关联实现的版本号的字符串。
      void onDeregistration​(ServiceRegistry registry, Class<?> category)
      每当Spi课程已从 ServiceRegistry注销时，将会回调。
      void onRegistration​(ServiceRegistry registry, Class<?> category)
      在Spi类已被实例化并在 ServiceRegistry注册后，将被调用一次的 ServiceRegistry 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • vendorName

        protected String vendorName
        A String从getVendorName返回，最初为null 。 构造函数应该将其设置为非null值。

      • version

        protected String version
        A String从getVersion返回，最初为null。 构造函数应该将其设置为非null值。

    • 构造方法详细信息

      • IIOServiceProvider

        public IIOServiceProvider​(String vendorName,
                          String version)
        构造具有给定供应商名称和版本标识符的 IIOServiceProvider 。
        参数
        vendorName - 供应商名称。
        version - 版本标识符。
        异常
        IllegalArgumentException - 如果 vendorName是 null 。
        IllegalArgumentException - 如果 version是 null 。

      • IIOServiceProvider

        public IIOServiceProvider​()
        构造一个空白IIOServiceProvider 。 为了确保getVendorName和getVersion方法将返回非null值，由子类初始化实例变量和/或覆盖方法实现。

    • 方法详细信息

      • onRegistration

        public void onRegistration​(ServiceRegistry registry,
                           Class<?> category)
        在Spi类被实例化并在ServiceRegistry注册后，将被调用一次的ServiceRegistry 。 这可以用于验证环境是否适合此服务，例如可以加载本机库。 如果服务在找到自己的环境中无法运行，则应该从注册表中注销自身。

        只有注册表应该调用这个方法。

        默认实现什么都不做。

        Specified by:
        onRegistration在接口 RegisterableService
        参数
        registry - a ServiceRegistry其中该对象已注册。
        category - 一个 Class对象，指示已注册该对象的注册表类别。
        另请参见：
        ServiceRegistry.registerServiceProvider(Object provider)

      • onDeregistration

        public void onDeregistration​(ServiceRegistry registry,
                             Class<?> category)
        每当Spi课程从ServiceRegistry注销时，这个ServiceRegistry 。

        只有注册表应该调用这个方法。

        默认实现什么都不做。

        Specified by:
        onDeregistration在接口 RegisterableService
        参数
        registry - 一个 ServiceRegistry从该对象正在（全部或部分）注销。
        category - 一个 Class对象，指示此对象正在注销的注册表类别。
        另请参见：
        ServiceRegistry.deregisterServiceProvider(Object provider)

      • getVendorName

        public String getVendorName​()
        返回负责创建此服务提供商及其关联实施的供应商的名称。 由于供应商名称可能用于选择服务提供商，因此它未被本地化。

        默认实现返回值为vendorName实例变量。

        结果
        一个非 null String包含供应商的名称。

      • getVersion

        public String getVersion​()
        返回描述此服务提供商及其关联实现的版本号的字符串。 由于代码转换器可能会使用该版本来识别他们所理解的服务提供商，因此此方法不进行本地化。

        默认实现返回值为version实例变量。

        结果
        一个非 null String包含该服务提供商的版本。

      • getDescription

        public abstract String getDescription​(Locale locale)
        返回此服务提供商及其相关实现的简短可读的描述。 如果可能的Locale ，所生成的字符串应该被本地化为所提供的Locale 。
        参数
        locale - 一个 Locale ，返回值应该对其进行本地化。
        结果
        a String包含此服务提供商的描述。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageInputStreamSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Class ImageInputStreamSpi

  • java.lang.Object
    • javax.imageio.spi.IIOServiceProvider
      • javax.imageio.spi.ImageInputStreamSpi
  • All Implemented Interfaces:
    RegisterableService

    public abstract class ImageInputStreamSpi
extends IIOServiceProvider
    ImageInputStream的服务提供商接口（SPI）。 有关服务提供商界面的更多信息，请参阅IIORegistry类的类注释。

    该接口允许任意对象由ImageInputStream的实例“包装”。 例如，特定的ImageInputStreamSpi可能允许使用通用的InputStream作为输入源; 另一个可能会从URL输入。

    通过将创建ImageInputStream作为可插拔服务，可以在不改变API的情况下处理未来的输入源。 此外， ImageInputStream的高性能实现（例如，特定平台的本机实现）可以由应用程序透明地安装和使用。

    另请参见：
    IIORegistry ， ImageInputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Class<?> inputClass
      一个 Class对象，指示 createInputStreamInstance方法使用的合法对象类型。

      • Fields inherited from class javax.imageio.spi.IIOServiceProvider

        vendorName, version

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ImageInputStreamSpi​()
      构造一个空白 ImageInputStreamSpi 。
        ImageInputStreamSpi​(String vendorName, String version, Class<?> inputClass)
      构造一个给定值的一个 ImageInputStreamSpi 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean canUseCacheFile​()
      返回 true如果 ImageInputStream与此服务提供者关联实现可选择使用了改进的性能和/或内存占用一个缓存文件。
      ImageInputStream createInputStreamInstance​(Object input)
      返回与此服务提供商关联的 ImageInputStream实现的实例。
      abstract ImageInputStream createInputStreamInstance​(Object input, boolean useCache, File cacheDir)
      返回与此服务提供程序相关联的 ImageInputStream实现的实例。
      Class<?> getInputClass​()
      返回表示要由输入源实现的类或接口类型的 Class对象，以便通过 createInputStreamInstance方法“ ImageInputStream ”进行“包装”。
      boolean needsCacheFile​()
      返回 true如果 ImageInputStream与此服务提供相关的实施需要使用一个缓存 File 。

      • Methods inherited from class javax.imageio.spi.IIOServiceProvider

        getDescription, getVendorName, getVersion, onDeregistration, onRegistration

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • inputClass

        protected Class<?> inputClass
        一个 Class对象，表示 createInputStreamInstance方法使用的合法对象类型。

    • 构造方法详细信息

      • ImageInputStreamSpi

        protected ImageInputStreamSpi​()
        构造空白ImageInputStreamSpi 。 初始化实例变量和/或覆盖方法实现的子类是为了提供所有方法的工作版本。

      • ImageInputStreamSpi

        public ImageInputStreamSpi​(String vendorName,
                           String version,
                           Class<?> inputClass)
        构造一个给定值的一个 ImageInputStreamSpi 。
        参数
        vendorName - 供应商名称。
        version - 版本标识符。
        inputClass - 一个 Class对象，指示 createInputStreamInstance方法使用的合法对象类型。
        异常
        IllegalArgumentException - 如果 vendorName是 null 。
        IllegalArgumentException - 如果 version是 null 。

    • 方法详细信息

      • getInputClass

        public Class<?> getInputClass​()
        返回一个Class表示必须由输入源，以便被实现为“包装”在的类或接口类型的对象ImageInputStream经由createInputStreamInstance方法。

        典型的返回值可能包括InputStream.class或URL.class ，但可以使用任何类。

        结果
        一个 Class变量。
        另请参见：
        createInputStreamInstance(Object, boolean, File)

      • canUseCacheFile

        public boolean canUseCacheFile​()
        返回true如果ImageInputStream与此服务提供者关联实现可选择使用了改进的性能和/或内存占用一个缓存文件。 如果false ，该值useCache参数createInputStreamInstance将被忽略。

        默认实现返回false 。

        结果
        true如果缓存文件可以由此服务提供商创建的输入流使用。

      • needsCacheFile

        public boolean needsCacheFile​()
        返回true如果ImageInputStream与此服务提供相关的实施需要使用一个缓存File 。 如果true ，该值useCache参数createInputStreamInstance将被忽略。

        默认实现返回false 。

        结果
        true如果由该服务提供商创建的输入流需要缓存文件。

      • createInputStreamInstance

        public abstract ImageInputStream createInputStreamInstance​(Object input,
                                                           boolean useCache,
                                                           File cacheDir)
                                                    throws IOException
        返回与该服务提供商相关联的ImageInputStream实现的实例。 如果使用缓存文件是可选的，则将参考useCache参数。 在需要缓存或不适用的情况下， useCache的值将被忽略。
        参数
        input - getInputClass返回的类类的对象。
        useCache - 一个 boolean表示是否应该使用缓存文件，如果是可选的。
        cacheDir - 一个 File指示应该创建缓存文件的位置，或 null使用系统目录。
        结果
        一个 ImageInputStream例子。
        异常
        IllegalArgumentException - 如果 input不是正确类的实例，或者是 null 。
        IllegalArgumentException - 如果需要缓存文件，但 cacheDir是非 null并且不是目录。
        IOException - 如果需要缓存文件但无法创建。
        另请参见：
        getInputClass() ，
canUseCacheFile() ，
needsCacheFile()

      • createInputStreamInstance

        public ImageInputStream createInputStreamInstance​(Object input)
                                           throws IOException
        返回与此服务提供商关联的ImageInputStream实现的实例。 如果需要，系统相关的默认临时文件目录中将创建缓存文件。
        参数
        input - getInputClass返回的类类的对象。
        结果
        一个 ImageInputStream例子。
        异常
        IllegalArgumentException - 如果 input不是正确类的实例，或者是 null 。
        IOException - 如果需要缓存文件但无法创建。
        另请参见：
        getInputClass()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageOutputStreamSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Class ImageOutputStreamSpi

  • java.lang.Object
    • javax.imageio.spi.IIOServiceProvider
      • javax.imageio.spi.ImageOutputStreamSpi
  • All Implemented Interfaces:
    RegisterableService

    public abstract class ImageOutputStreamSpi
extends IIOServiceProvider
    服务提供商接口（SPI），用于ImageOutputStream s。 有关服务提供商接口的更多信息，请参阅IIORegistry类的类注释。

    该接口允许任意对象由ImageOutputStream的实例“包裹”。 例如，特定的ImageOutputStreamSpi可能允许使用通用的OutputStream作为目的地; 另一个可能输出到一个File或一个设备，如串行端口。

    通过将ImageOutputStream s的创建视为可插拔服务，可以在不更改API的情况下处理未来的输出目的地。 此外， ImageOutputStream的高性能实现（例如，特定平台的本机实现）可以由应用程序透明地安装和使用。

    另请参见：
    IIORegistry ， ImageOutputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Class<?> outputClass
      一个 Class对象，指示 createInputStreamInstance方法使用的合法对象类型。

      • Fields inherited from class javax.imageio.spi.IIOServiceProvider

        vendorName, version

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ImageOutputStreamSpi​()
      构造一个空白 ImageOutputStreamSpi 。
        ImageOutputStreamSpi​(String vendorName, String version, Class<?> outputClass)
      构造一个给定值的一个 ImageOutputStreamSpi 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean canUseCacheFile​()
      返回 true如果 ImageOutputStream与此服务提供者关联实现可选择使用缓存 File ，以提高性能和/或内存占用。
      ImageOutputStream createOutputStreamInstance​(Object output)
      返回与此服务提供商关联的 ImageOutputStream实现的实例。
      abstract ImageOutputStream createOutputStreamInstance​(Object output, boolean useCache, File cacheDir)
      返回与此服务提供程序相关联的 ImageOutputStream实现的实例。
      Class<?> getOutputClass​()
      返回一个 Class表示必须由输出目的地，以便被实现为“包装”在的类或接口类型的对象 ImageOutputStream经由 createOutputStreamInstance方法。
      boolean needsCacheFile​()
      返回 true如果 ImageOutputStream与此服务提供相关的实施需要使用一个缓存 File 。

      • Methods inherited from class javax.imageio.spi.IIOServiceProvider

        getDescription, getVendorName, getVersion, onDeregistration, onRegistration

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • outputClass

        protected Class<?> outputClass
        一个 Class对象，指示 createInputStreamInstance方法使用的合法对象类型。

    • 构造方法详细信息

      • ImageOutputStreamSpi

        protected ImageOutputStreamSpi​()
        构造一个空白ImageOutputStreamSpi 。 初始化实例变量和/或覆盖方法实现的子类是为了提供所有方法的工作版本。

      • ImageOutputStreamSpi

        public ImageOutputStreamSpi​(String vendorName,
                            String version,
                            Class<?> outputClass)
        构造一个给定值的一个 ImageOutputStreamSpi 。
        参数
        vendorName - 供应商名称。
        version - 版本标识符。
        outputClass - 一个 Class对象，指示 createOutputStreamInstance方法使用的合法对象类型。
        异常
        IllegalArgumentException - 如果 vendorName是 null 。
        IllegalArgumentException - 如果 version是 null 。

    • 方法详细信息

      • getOutputClass

        public Class<?> getOutputClass​()
        返回一个Class表示必须由输出目的地，以便被实现为“包装”在的类或接口类型的对象ImageOutputStream经由createOutputStreamInstance方法。

        典型的返回值可能包括OutputStream.class或File.class ，但可以使用任何类。

        结果
        一个 Class变量。
        另请参见：
        createOutputStreamInstance(Object, boolean, File)

      • canUseCacheFile

        public boolean canUseCacheFile​()
        返回true如果ImageOutputStream与此服务提供者关联实现可选择使用缓存File ，以提高性能和/或内存占用。 如果false ，该值cacheFile参数createOutputStreamInstance将被忽略。

        默认实现返回false 。

        结果
        true如果缓存文件可以由此服务提供商创建的输出流使用。

      • needsCacheFile

        public boolean needsCacheFile​()
        返回true如果ImageOutputStream与此服务提供相关的实施需要使用一个缓存File 。

        默认实现返回false 。

        结果
        true如果此服务提供商创建的输出流需要缓存文件。

      • createOutputStreamInstance

        public abstract ImageOutputStream createOutputStreamInstance​(Object output,
                                                             boolean useCache,
                                                             File cacheDir)
                                                      throws IOException
        返回与此服务提供商关联的ImageOutputStream实现的实例。 如果使用缓存文件是可选的，则将参考useCache参数。 在需要缓存或不适用的情况下， useCache的值将被忽略。
        参数
        output - 由类别返回的对象类型 getOutputClass 。
        useCache - a boolean表示是否应使用缓存文件，如果是可选的。
        cacheDir - 一个 File指示应该创建高速缓存文件的位置，或 null使用系统目录。
        结果
        一个 ImageOutputStream例子。
        异常
        IllegalArgumentException - 如果 output不是正确类的实例，或者是 null 。
        IllegalArgumentException - 如果需要缓存文件，但 cacheDir不是 null并且不是目录。
        IOException - 如果需要缓存文件但无法创建。
        另请参见：
        getOutputClass()

      • createOutputStreamInstance

        public ImageOutputStream createOutputStreamInstance​(Object output)
                                             throws IOException
        返回与此服务提供商相关联的ImageOutputStream实现的实例。 如果需要，系统相关的默认临时文件目录中将创建缓存文件。
        参数
        output - getOutputClass返回的类类的对象。
        结果
        一个 ImageOutputStream实例。
        异常
        IllegalArgumentException - 如果 output不是正确类的实例，或者是 null 。
        IOException - 如果需要缓存文件但无法创建。
        另请参见：
        getOutputClass()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageReaderSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Class ImageReaderSpi

  • java.lang.Object
    • javax.imageio.spi.IIOServiceProvider
      • javax.imageio.spi.ImageReaderWriterSpi
        • javax.imageio.spi.ImageReaderSpi
  • All Implemented Interfaces:
    RegisterableService

    public abstract class ImageReaderSpi
extends ImageReaderWriterSpi
    服务提供商接口（SPI），用于ImageReader s。 有关服务提供程序类的更多信息，请参阅IIORegistry类的类注释。

    每个ImageReaderSpi提供了与它相关联的ImageReader类的几种类型的信息。

    谁定义的SPI类和类的简要描述的供应商的名称是通过提供getVendorName ， getDescription ，并getVersion方法。 这些方法可以被国际化以提供特定于区域的输出。 这些方法主要用于提供可用于组织弹出菜单或其他列表的简短的，可读的信息。

    格式名称，文件后缀，以及与该服务相关联MIME类型的列表可通过的方式获得getFormatNames ， getFileSuffixes ，和getMIMETypes方法。 这些方法可以用于识别基于手动格式选择，文件命名或MIME关联来解码特定文件或流的候选者ImageReader s（例如，当通过HTTP访问文件或作为电子邮件附件时）。

    通过canDecodeInput方法提供了一种更可靠的方法来确定哪些ImageReader可能能够解析特定的数据流。 此方法允许服务提供商检查实际的流内容。

    最后，可以通过调用createReaderInstance方法获得与此服务提供商相关联的ImageReader类的实例。 任何重量级的初始化（如加载本机库或创建大型表）至少应该延迟至首次调用此方法为止。

    另请参见：
    IIORegistry ， ImageReader

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Class<?>[] inputTypes
      一组 Class对象从 getInputTypes返回，最初为 null 。
      static Class<?>[] STANDARD_INPUT_TYPE
      已过时。
      而不是使用这个字段，直接创建等效的数组{ ImageInputStream.class } 。
      protected String[] writerSpiNames
      要从 getImageWriterSpiNames返回的字符串数组，最初为 null 。

      • Fields inherited from class javax.imageio.spi.IIOServiceProvider

        vendorName, version

      • Fields inherited from class javax.imageio.spi.ImageReaderWriterSpi

        extraImageMetadataFormatClassNames, extraImageMetadataFormatNames, extraStreamMetadataFormatClassNames, extraStreamMetadataFormatNames, MIMETypes, names, nativeImageMetadataFormatClassName, nativeImageMetadataFormatName, nativeStreamMetadataFormatClassName, nativeStreamMetadataFormatName, pluginClassName, suffixes, supportsStandardImageMetadataFormat, supportsStandardStreamMetadataFormat

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ImageReaderSpi​()
      构造一个空白 ImageReaderSpi 。
        ImageReaderSpi​(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class<?>[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
      构造一个给定值的一个 ImageReaderSpi 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract boolean canDecodeInput​(Object source)
      如果提供的源对象看起来是由该读者支持的格式，则返回 true 。
      ImageReader createReaderInstance​()
      返回与此服务提供商关联的 ImageReader实现的实例。
      abstract ImageReader createReaderInstance​(Object extension)
      返回与此服务提供商关联的 ImageReader实现的实例。
      String[] getImageWriterSpiNames​()
      返回的数组 String包含所有的完全合格的名称小号 ImageWriterSpi类，可以理解由所使用的内部元数据表示 ImageReader与此服务提供商相关联，或 null如果没有这样的 ImageWriter指定秒。
      Class<?>[] getInputTypes​()
      返回一个 Class对象的数组，指示可以将什么类型的对象用作读者 setInput方法的参数。
      boolean isOwnReader​(ImageReader reader)
      如果传递的 ImageReader对象是与此服务提供商关联的 ImageReader的实例，则返回 true 。

      • Methods inherited from class javax.imageio.spi.IIOServiceProvider

        getDescription, getVendorName, getVersion, onDeregistration, onRegistration

      • Methods inherited from class javax.imageio.spi.ImageReaderWriterSpi

        getExtraImageMetadataFormatNames, getExtraStreamMetadataFormatNames, getFileSuffixes, getFormatNames, getImageMetadataFormat, getMIMETypes, getNativeImageMetadataFormatName, getNativeStreamMetadataFormatName, getPluginClassName, getStreamMetadataFormat, isStandardImageMetadataFormatSupported, isStandardStreamMetadataFormatSupported

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • STANDARD_INPUT_TYPE

        @Deprecated
public static final Class<?>[] STANDARD_INPUT_TYPE
        已过时。 而不是使用这个字段，直接创建等效的数组{ ImageInputStream.class } 。
        一个单元素数组，最初包含 ImageInputStream.class ，从 getInputTypes返回。

      • inputTypes

        protected Class<?>[] inputTypes
        一组 Class对象从 getInputTypes返回，最初为 null 。

      • writerSpiNames

        protected String[] writerSpiNames
        要从 getImageWriterSpiNames返回的字符串数组，最初为 null 。

    • 构造方法详细信息

      • ImageReaderSpi

        protected ImageReaderSpi​()
        构造一个空白ImageReaderSpi 。 初始化实例变量和/或覆盖方法实现的子类是为了提供所有方法的工作版本。

      • ImageReaderSpi

        public ImageReaderSpi​(String vendorName,
                      String version,
                      String[] names,
                      String[] suffixes,
                      String[] MIMETypes,
                      String readerClassName,
                      Class<?>[] inputTypes,
                      String[] writerSpiNames,
                      boolean supportsStandardStreamMetadataFormat,
                      String nativeStreamMetadataFormatName,
                      String nativeStreamMetadataFormatClassName,
                      String[] extraStreamMetadataFormatNames,
                      String[] extraStreamMetadataFormatClassNames,
                      boolean supportsStandardImageMetadataFormat,
                      String nativeImageMetadataFormatName,
                      String nativeImageMetadataFormatClassName,
                      String[] extraImageMetadataFormatNames,
                      String[] extraImageMetadataFormatClassNames)
        构造一个给定值的一个 ImageReaderSpi 。
        参数
        vendorName - 供应商名称，作为非 null String 。
        version - 版本标识符，作为非 null String 。
        names - 表示格式名称的非null数组String 。 必须至少有一个条目。
        suffixes - 表示公共文件后缀的String s的数组。 如果未定义任何后缀，则应提供null 。 长度为0的数组将被归一化为null 。
        MIMETypes - 表示格式的MIME类型的String的数组。 如果未定义MIME类型，则应提供null 。 长度为0的数组将被归一化为null 。
        readerClassName - 相关联的 ImageReader类的完全限定名称，作为非 null String 。
        inputTypes - 长度为至少为1的 Class对象的非 null数组，指示合法输入类型。
        writerSpiNames - 一个数组String命名所有关联的ImageWriter s或null 。 长度为0的数组被归一化为null 。
        supportsStandardStreamMetadataFormat - 表示流元数据对象是否可以使用由标准元数据格式描述的树的 boolean 。
        nativeStreamMetadataFormatName - a String或 null ，将从 getNativeStreamMetadataFormatName返回。
        nativeStreamMetadataFormatClassName - a String或 null ，用于实例化从 getNativeStreamMetadataFormat返回的元数据格式对象。
        extraStreamMetadataFormatNames - 要从getExtraStreamMetadataFormatNames返回的String s或null的数组。 长度为0的数组被归一化为null 。
        extraStreamMetadataFormatClassNames - 用于实例化要从getStreamMetadataFormat返回的元数据格式对象的String s或null的数组。 长度为0的数组被归一化为null 。
        supportsStandardImageMetadataFormat - 表示图像元数据对象是否可以使用由标准元数据格式描述的树的 boolean 。
        nativeImageMetadataFormatName - a String或 null ，将从 getNativeImageMetadataFormatName返回。
        nativeImageMetadataFormatClassName - a String或 null ，用于实例化要从 getNativeImageMetadataFormat返回的元数据格式对象。
        extraImageMetadataFormatNames -的阵列String从返回小号getExtraImageMetadataFormatNames 。 长度为0的数组被归一化为null 。
        extraImageMetadataFormatClassNames - 用于实例化从getImageMetadataFormat返回的元数据格式对象的String s或null的数组。 长度为0的数组被归一化为null 。
        异常
        IllegalArgumentException - 如果 vendorName是 null 。
        IllegalArgumentException - 如果 version是 null 。
        IllegalArgumentException - 如果 names是 null或长度为0。
        IllegalArgumentException - 如果 readerClassName是 null 。
        IllegalArgumentException - 如果 inputTypes为 null或长度为0。

    • 方法详细信息

      • getInputTypes

        public Class<?>[] getInputTypes​()
        返回一个Class对象的数组，指示可以将什么类型的对象用作读者setInput方法的参数。

        对于只接受来自ImageInputStream输入的大多数读者，应该返回包含ImageInputStream.class的单元素数组。

        结果
        null的 Class对象的长度至少为1的数组。

      • canDecodeInput

        public abstract boolean canDecodeInput​(Object source)
                                throws IOException
        返回true如果提供的源对象看起来是这个读者支持的格式。 从这种方法返回true并不能保证阅读将成功，只是基于对流内容的简要检查，似乎有合理的成功机会。 如果源是一个ImageInputStream ，实现将通常检查流的前几个字节与格式相关联的“魔术数”。 一旦实际读取开始，读取器可能仍然在解码完成之前的任何时间指示失败。

        重要的是，对象的状态不会受到干扰，以便其他ImageReaderSpi可以正确地确定它们是否能够解码对象。 特别是，如果该源为ImageInputStream ，一个mark / reset对应该用来保存流位置。

        可能会尝试读取几乎任何流的“raw”格式应该返回false ，以避免被调用而不是更接近的匹配。

        如果source不是由getInputTypes返回的类的一个实例，则该方法应该简单地返回false 。

        参数
        source - 要解码的对象（通常为 ImageInputStream ）。
        结果
        true如果这个流可能被解码。
        异常
        IllegalArgumentException - 如果 source是 null 。
        IOException - 如果在读取流时发生I / O错误。

      • createReaderInstance

        public ImageReader createReaderInstance​()
                                 throws IOException
        返回与此服务提供程序相关联的ImageReader实现的实例。 返回的对象最初将处于初始状态，就好像它的reset方法已被调用一样。

        默认实现只是返回createReaderInstance(null) 。

        结果
        一个 ImageReader实例。
        异常
        IOException - 如果读取器类的加载或初始化期间或在读取器对象的实例化或初始化期间发生错误。

      • createReaderInstance

        public abstract ImageReader createReaderInstance​(Object extension)
                                          throws IOException
        返回与此服务提供程序相关联的ImageReader实现的实例。 返回的对象最初将处于初始状态，就好像其reset方法已被调用一样。

        一个Object可能在施工时提供给插件。 对象的性质是完全插件具体的。

        通常，插件将使用代码（如return new MyImageReader(this)实现此方法。

        参数
        extension - 一个插件特定的扩展对象，可以是 null 。
        结果
        一个 ImageReader例子。
        异常
        IOException - 如果尝试实例化读取器失败。
        IllegalArgumentException - 如果 ImageReader的构造函数抛出一个 IllegalArgumentException来指示扩展对象不合适。

      • isOwnReader

        public boolean isOwnReader​(ImageReader reader)
        如果传入的ImageReader对象是与此服务提供商关联的ImageReader的实例，则返回true 。

        默认实现将reader参数的完全限定类名与传递给构造函数的类名进行比较。 如果需要更复杂的检查，该方法可能会被覆盖。

        参数
        reader - 一个 ImageReader实例。
        结果
        true如果识别 reader 。
        异常
        IllegalArgumentException - 如果 reader是 null 。

      • getImageWriterSpiNames

        public String[] getImageWriterSpiNames​()
        返回一个包含String s的数组， String包含所有ImageWriterSpi类的完全限定名称，可以理解与该服务提供商关联的ImageReader所使用的内部元数据表示，或者如果没有指定null则ImageWriter 。 如果返回非null值，则该值必须为非零长度。

        数组中的第一个项目必须是“首选”作者的服务提供商的名称，因为它将用于实例化由ImageWriter返回的ImageIO.getImageWriter(ImageReader) 。

        这个机制可以用来获得ImageWriters ，这将理解由ImageReader生成的非像素元数据的内部结构（见IIOTreeInfo ）。 通过从ImageReader获取此数据并将其传递给使用此方法获得的ImageWriters之一，客户端程序可以读取图像，以某种方式进行修改，并在保留所有元数据的同时将其写回，而无需了解元数据的内部结构，甚至了解图像格式。

        结果
        String的长度至少为1的数组，包含 ImageWriterSpi或 null 。
        另请参见：
        ImageIO.getImageWriter(ImageReader)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageReaderWriterSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Class ImageReaderWriterSpi

  • java.lang.Object
    • javax.imageio.spi.IIOServiceProvider
      • javax.imageio.spi.ImageReaderWriterSpi
  • All Implemented Interfaces:
    RegisterableService
    已知直接子类：
    ImageReaderSpi ， ImageWriterSpi

    public abstract class ImageReaderWriterSpi
extends IIOServiceProvider
    一个包含实例变量的超类和 ImageReaderSpi和 ImageWriterSpi共同的方法。
    另请参见：
    IIORegistry ， ImageReaderSpi ， ImageWriterSpi

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected String[] extraImageMetadataFormatClassNames
      String的数组，包含该插件支持的任何其他图像元数据格式的类名，最初为 null 。
      protected String[] extraImageMetadataFormatNames
      String的数组，包含该插件支持的任何其他图像元数据格式的名称，最初为 null 。
      protected String[] extraStreamMetadataFormatClassNames
      String的数组，包含此插件支持的任何其他流元数据格式的类名，最初为 null 。
      protected String[] extraStreamMetadataFormatNames
      String的数组，包含该插件支持的任何其他流元数据格式的名称，最初为 null 。
      protected String[] MIMETypes
      要从 getMIMETypes返回的字符串数组，最初为 null 。
      protected String[] names
      要从 getFormatNames返回的字符串数组，最初为 null 。
      protected String nativeImageMetadataFormatClassName
      A String其中包含此插件支持的本机流元数据格式的类名，最初为 null 。
      protected String nativeImageMetadataFormatName
      A String包含此插件支持的本机流元数据格式的名称，最初为 null 。
      protected String nativeStreamMetadataFormatClassName
      A String其中包含此插件支持的本机流元数据格式的类名，最初为 null 。
      protected String nativeStreamMetadataFormatName
      A String其中包含此插件支持的本机流元数据格式的名称，最初为 null 。
      protected String pluginClassName
      A String包含相关插件类的名称，最初为 null 。
      protected String[] suffixes
      要从 getFileSuffixes返回的字符串数组，最初为 null 。
      protected boolean supportsStandardImageMetadataFormat
      一个布尔值，表示此插件是否支持图像元数据的标准元数据格式，最初为 false 。
      protected boolean supportsStandardStreamMetadataFormat
      一个布尔值，表示此插件是否支持流元数据的标准元数据格式，最初为 false 。

      • Fields inherited from class javax.imageio.spi.IIOServiceProvider

        vendorName, version

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageReaderWriterSpi​()
      构造一个空白 ImageReaderWriterSpi 。
      ImageReaderWriterSpi​(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
      构造一个给定值的一个 ImageReaderWriterSpi 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String[] getExtraImageMetadataFormatNames​()
      返回一个包含 String s的数组， String包含由此插件生成或使用的图像元数据对象上的 getAsTree和 setFromTree方法识别的其他文档格式（本机和标准格式）。
      String[] getExtraStreamMetadataFormatNames​()
      返回一个包含 String s的数组， String包含由此插件生成或使用的流元数据对象上的 getAsTree和 setFromTree方法识别的本机和标准格式以外的其他文档格式的名称。
      String[] getFileSuffixes​()
      返回一个包含 String s的数组， String包含与此服务提供商相关联的 ImageReader或 ImageWriter实现通常可用的格式相关联的文件后缀列表。
      String[] getFormatNames​()
      返回 String的数组， String包含与此服务提供商相关联的 ImageReader或 ImageWriter实现通常可用的格式的可读取名称。
      IIOMetadataFormat getImageMetadataFormat​(String formatName)
      返回一个 IIOMetadataFormat对象描述给定的图像的元数据格式，或 null如果没有可用的描述。
      String[] getMIMETypes​()
      返回一个包含 String的数组， String包含与此服务提供商关联的 ImageReader或 ImageWriter实现通常可用的格式相关联的MIME类型列表。
      String getNativeImageMetadataFormatName​()
      返回此插件的“本机”图像元数据格式的名称，通常允许以由该插件处理的格式存储的图像元数据的无损编码和传输。
      String getNativeStreamMetadataFormatName​()
      返回此插件的“本机”流元数据格式的名称，通常允许以该插件处理的格式存储的流元数据进行无损编码和传输。
      String getPluginClassName​()
      返回与该服务提供商关联的 ImageReader或 ImageWriter插件的完全限定类名。
      IIOMetadataFormat getStreamMetadataFormat​(String formatName)
      返回一个 IIOMetadataFormat对象描述给定的流元数据格式，或 null如果没有可用的描述。
      boolean isStandardImageMetadataFormatSupported​()
      返回 true如果标准元数据格式是由所述识别的文档格式中 getAsTree种 setFromTree上产生或通过此插件消耗的图像元数据对象的方法。
      boolean isStandardStreamMetadataFormatSupported​()
      返回 true如果标准元数据格式是由所述识别的文档格式中 getAsTree种 setFromTree上产生或通过此插件消耗的流元数据对象的方法。

      • Methods inherited from class javax.imageio.spi.IIOServiceProvider

        getDescription, getVendorName, getVersion, onDeregistration, onRegistration

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • names

        protected String[] names
        要从getFormatNames返回的字符串数组，最初为null 。 构造函数应该将其设置为非null值。

      • suffixes

        protected String[] suffixes
        要从 getFileSuffixes返回的字符串数组，最初为 null 。

      • MIMETypes

        protected String[] MIMETypes
        要从 getMIMETypes返回的字符串数组，最初为 null 。

      • pluginClassName

        protected String pluginClassName
        A String包含相关插件类的名称，最初为 null 。

      • supportsStandardStreamMetadataFormat

        protected boolean supportsStandardStreamMetadataFormat
        一个布尔值，指示此插件是否支持流元数据的标准元数据格式，最初为 false 。

      • nativeStreamMetadataFormatName

        protected String nativeStreamMetadataFormatName
        A String包含此插件支持的本机流元数据格式的名称，最初为 null 。

      • nativeStreamMetadataFormatClassName

        protected String nativeStreamMetadataFormatClassName
        A String其中包含此插件支持的本机流元数据格式的类名，最初为 null 。

      • extraStreamMetadataFormatNames

        protected String[] extraStreamMetadataFormatNames
        包含 String的数组， String包含此插件支持的任何其他流元数据格式的名称，最初为 null 。

      • extraStreamMetadataFormatClassNames

        protected String[] extraStreamMetadataFormatClassNames
        String的数组包含该插件支持的任何其他流元数据格式的类名，最初为 null 。

      • supportsStandardImageMetadataFormat

        protected boolean supportsStandardImageMetadataFormat
        一个布尔值，表示该插件是否支持图像元数据的标准元数据格式，最初为 false 。

      • nativeImageMetadataFormatName

        protected String nativeImageMetadataFormatName
        A String包含此插件支持的本地流元数据格式的名称，最初为 null 。

      • nativeImageMetadataFormatClassName

        protected String nativeImageMetadataFormatClassName
        A String其中包含此插件支持的本机流元数据格式的类名，最初为 null 。

      • extraImageMetadataFormatNames

        protected String[] extraImageMetadataFormatNames
        String的数组包含该插件支持的任何其他图像元数据格式的名称，最初为 null 。

      • extraImageMetadataFormatClassNames

        protected String[] extraImageMetadataFormatClassNames
        String的数组包含该插件支持的任何其他图像元数据格式的类名，最初为 null 。

    • 构造方法详细信息

      • ImageReaderWriterSpi

        public ImageReaderWriterSpi​(String vendorName,
                            String version,
                            String[] names,
                            String[] suffixes,
                            String[] MIMETypes,
                            String pluginClassName,
                            boolean supportsStandardStreamMetadataFormat,
                            String nativeStreamMetadataFormatName,
                            String nativeStreamMetadataFormatClassName,
                            String[] extraStreamMetadataFormatNames,
                            String[] extraStreamMetadataFormatClassNames,
                            boolean supportsStandardImageMetadataFormat,
                            String nativeImageMetadataFormatName,
                            String nativeImageMetadataFormatClassName,
                            String[] extraImageMetadataFormatNames,
                            String[] extraImageMetadataFormatClassNames)
        构造一个具有给定值的值的 ImageReaderWriterSpi 。
        参数
        vendorName - 供应商名称，非 null String 。
        version - 版本标识符，非 null String 。
        names - 表示格式名称的String的非null数组。 必须至少有一个条目。
        suffixes - 表示公共文件后缀的String s的数组。 如果未定义任何后缀，则应提供null 。 长度为0的数组将被归一化为null 。
        MIMETypes - 表示格式的MIME类型的String的数组。 如果未定义MIME类型，则应提供null 。 长度为0的数组将被归一化为null 。
        pluginClassName - 相关联的 ImageReader或 ImageWriter类的完全限定名称，作为非 null String 。
        supportsStandardStreamMetadataFormat - 表示流元数据对象是否可以使用由标准元数据格式描述的树的 boolean 。
        nativeStreamMetadataFormatName - a String或 null ，将从 getNativeStreamMetadataFormatName返回。
        nativeStreamMetadataFormatClassName - a String或 null ，用于实例化从 getNativeStreamMetadataFormat返回的元数据格式对象。
        extraStreamMetadataFormatNames - 要从getExtraStreamMetadataFormatNames返回的String s或null的数组。 长度为0的数组被归一化为null 。
        extraStreamMetadataFormatClassNames - 用于实例化从getStreamMetadataFormat返回的元数据格式对象的String或null的数组。 长度为0的数组被归一化为null 。
        supportsStandardImageMetadataFormat - 表示图像元数据对象是否可以使用由标准元数据格式描述的树的 boolean 。
        nativeImageMetadataFormatName - a String或 null ，由 getNativeImageMetadataFormatName 。
        nativeImageMetadataFormatClassName - a String或 null ，用于实例化从 getNativeImageMetadataFormat返回的元数据格式对象。
        extraImageMetadataFormatNames -的阵列String从返回小号getExtraImageMetadataFormatNames 。 长度为0的数组被归一化为null 。
        extraImageMetadataFormatClassNames - 用于实例化要从getImageMetadataFormat返回的元数据格式对象的String s或null的数组。 长度为0的数组被归一化为null 。
        异常
        IllegalArgumentException - 如果 vendorName是 null 。
        IllegalArgumentException - 如果 version是 null 。
        IllegalArgumentException - 如果 names为 null或长度为0。
        IllegalArgumentException - 如果 pluginClassName是 null 。

      • ImageReaderWriterSpi

        public ImageReaderWriterSpi​()
        构造一个空白ImageReaderWriterSpi 。 初始化实例变量和/或覆盖方法实现的子类是为了提供所有方法的工作版本。

    • 方法详细信息

      • getFormatNames

        public String[] getFormatNames​()
        返回String的数组， String包含与此服务提供商相关联的ImageReader或ImageWriter实现通常可用的格式的可读取名称。 例如，单个ImageReader可能能够处理PBM和PNM文件。
        结果
        非 null阵列的 String S或长度至少为1，包含与此读取器或写入器相关联的非正式格式名称。

      • getFileSuffixes

        public String[] getFileSuffixes​()
        返回一个包含String s的数组， String包含与此服务提供商关联的ImageReader或ImageWriter实现通常可用的格式相关联的文件后缀列表。 例如，单个ImageReader可能能够处理具有'.pbm'和'.pnm'后缀的文件，或'.jpg'和'.jpeg'后缀。 如果没有已知的文件后缀，将返回null 。

        返回特定后缀不能保证具有该后缀的文件可以被处理; 它仅表示可能值得尝试使用该服务提供商对这样的文件进行解码或编码。

        结果
        String的数组或长度至少为1的数组，其中包含与该读写器相关联的公用文件后缀，或 null 。

      • getMIMETypes

        public String[] getMIMETypes​()
        返回一个包含String的数组， String包含与此服务提供商关联的ImageReader或ImageWriter实现通常可用的格式相关联的MIME类型列表。

        理想情况下，为了描述特定的格式，只需要一个MIME类型。 然而，由于几个原因，有必要将每个服务提供商的类型列表关联起来。 首先，许多常见的图像文件格式不具有标准MIME类型，因此将需要常用的非官方名称列表，例如image/x-pbm和image/x-portable-bitmap 。 某些文件格式具有官方MIME类型，但有时可以使用其以前的非官方名称来引用，例如image/x-png而不是官方的image/png 。 最后，单个服务提供商可能能够从MIME的角度解析多个不同类型，例如image/x-xbitmap和image/x-xpixmap 。

        返回特定的MIME类型并不能保证声称是该类型的文件可以被处理; 它仅表示可能值得尝试使用该服务提供商对这样的文件进行解码或编码。

        结果
        String的数组或长度至少包含与此读者或作者相关联的MIME类型的数组，或 null 。

      • getPluginClassName

        public String getPluginClassName​()
        返回与此服务提供商关联的 ImageReader或 ImageWriter插件的完全限定类名。
        结果
        该类名称，作为非 null String 。

      • isStandardStreamMetadataFormatSupported

        public boolean isStandardStreamMetadataFormatSupported​()
        返回 true如果标准元数据格式是由所述识别的文档格式中 getAsTree种 setFromTree上产生或通过此插件消耗的流元数据对象的方法。
        结果
        true如果流元数据支持标准格式。

      • getNativeStreamMetadataFormatName

        public String getNativeStreamMetadataFormatName​()
        返回此插件的“本机”流元数据格式的名称，通常允许以该插件处理的格式存储的流元数据进行无损编码和传输。 如果不支持此格式，将返回null 。

        默认实现返回nativeStreamMetadataFormatName实例变量，通常由构造函数设置。

        结果
        本机流元数据格式的名称，或 null 。

      • getExtraStreamMetadataFormatNames

        public String[] getExtraStreamMetadataFormatNames​()
        返回一个包含String的数组， String包含由此插件生成或使用的流元数据对象上的getAsTree和setFromTree方法识别的本机和标准格式以外的其他文档格式的名称。

        如果插件不处理元数据，则应返回null。

        这些格式可能会根据读取或写入的特定图像而有所不同; 此方法应指出插件在任何情况下支持的所有其他格式。

        默认实现返回extraStreamMetadataFormatNames实例变量的克隆，通常由构造函数设置。

        结果
        一个 String s的数组，或null。
        另请参见：
        IIOMetadata.getMetadataFormatNames() ，
getExtraImageMetadataFormatNames() ，
getNativeStreamMetadataFormatName()

      • isStandardImageMetadataFormatSupported

        public boolean isStandardImageMetadataFormatSupported​()
        返回 true如果标准元数据格式是由所述识别的文档格式中 getAsTree种 setFromTree上产生或通过此插件消耗的图像元数据对象的方法。
        结果
        true如果图像元数据支持标准格式。

      • getNativeImageMetadataFormatName

        public String getNativeImageMetadataFormatName​()
        返回此插件的“本机”图像元数据格式的名称，通常允许以由该插件处理的格式存储的图像元数据的无损编码和传输。 如果不支持此格式，将返回null 。

        默认实现返回nativeImageMetadataFormatName实例变量，通常由构造函数设置。

        结果
        原生图像元数据格式的名称，或 null 。
        另请参见：
        getExtraImageMetadataFormatNames()

      • getExtraImageMetadataFormatNames

        public String[] getExtraImageMetadataFormatNames​()
        返回一个包含String s的数组， String包含由此插件生成或使用的图像元数据对象上的getAsTree和setFromTree方法识别的其他文档格式（本机和标准格式）。

        如果插件不处理图像元数据，则应返回null。

        这些格式可能会根据读取或写入的特定图像而有所不同; 此方法应指出插件在任何情况下支持的所有其他格式。

        默认实现返回一个由构造函数设置的extraImageMetadataFormatNames实例变量的克隆。

        结果
        一个 String s的数组，或null。
        另请参见：
        IIOMetadata.getMetadataFormatNames() ，
getExtraStreamMetadataFormatNames() ，
getNativeImageMetadataFormatName()

      • getStreamMetadataFormat

        public IIOMetadataFormat getStreamMetadataFormat​(String formatName)
        返回一个IIOMetadataFormat对象描述给定的流元数据格式，或null如果没有可用的描述。 提供的名称必须是本地流元数据格式名称，标准元数据格式名称，或getExtraStreamMetadataFormatNames返回的其中一个。
        参数
        formatName - 所需的流元数据格式。
        结果
        一个 IIOMetadataFormat对象。
        异常
        IllegalArgumentException - 如果 formatName是 null或不是支持的名称。

      • getImageMetadataFormat

        public IIOMetadataFormat getImageMetadataFormat​(String formatName)
        返回一个IIOMetadataFormat对象描述给定的图像的元数据格式，或null如果没有可用的描述。 提供的名称必须是原始图像元数据格式名称，标准元数据格式名称，或getExtraImageMetadataFormatNames返回的其中一个。
        参数
        formatName - 所需的图像元数据格式。
        结果
        一个 IIOMetadataFormat对象。
        异常
        IllegalArgumentException - 如果 formatName是 null或不是支持的名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageTranscoderSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Class ImageTranscoderSpi

  • java.lang.Object
    • javax.imageio.spi.IIOServiceProvider
      • javax.imageio.spi.ImageTranscoderSpi
  • All Implemented Interfaces:
    RegisterableService

    public abstract class ImageTranscoderSpi
extends IIOServiceProvider
    ImageTranscoder的服务提供商接口（SPI）。 有关服务提供程序类的更多信息，请参阅IIORegistry类的类注释。
    另请参见：
    IIORegistry ， ImageTranscoder

    • Field Summary

      • Fields inherited from class javax.imageio.spi.IIOServiceProvider

        vendorName, version

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ImageTranscoderSpi​()
      构造一个空白 ImageTranscoderSpi 。
        ImageTranscoderSpi​(String vendorName, String version)
      构造一个给定值的一个 ImageTranscoderSpi 。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract ImageTranscoder createTranscoderInstance​()
      返回与此服务提供商相关联的 ImageTranscoder实现的实例。
      abstract String getReaderServiceProviderName​()
      返回一个 ImageReaderSpi类的完全限定类名，生成 IIOMetadata对象， IIOMetadata对象可以用作此代码转换器的输入。
      abstract String getWriterServiceProviderName​()
      返回 ImageWriterSpi类的完全限定类名，该类可生成 IIOMetadata此代码转换器输入的 IIOMetadata对象。

      • Methods inherited from class javax.imageio.spi.IIOServiceProvider

        getDescription, getVendorName, getVersion, onDeregistration, onRegistration

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ImageTranscoderSpi

        protected ImageTranscoderSpi​()
        构造一个空白的ImageTranscoderSpi 。 初始化实例变量和/或覆盖方法实现的子类是为了提供所有方法的工作版本。

      • ImageTranscoderSpi

        public ImageTranscoderSpi​(String vendorName,
                          String version)
        构造一个给定值的一个 ImageTranscoderSpi 。
        参数
        vendorName - 供应商名称。
        version - 版本标识符。

    • 方法详细信息

      • getReaderServiceProviderName

        public abstract String getReaderServiceProviderName​()
        返回 ImageReaderSpi类的完全限定类名，该类可生成 IIOMetadata此代码转换器输入的 IIOMetadata对象。
        结果
        一个 String包含完全限定类名的 ImageReaderSpi实现类。
        另请参见：
        ImageReaderSpi

      • getWriterServiceProviderName

        public abstract String getWriterServiceProviderName​()
        返回 ImageWriterSpi类的完全限定类名，该类可生成 IIOMetadata此代码转换器输入的 IIOMetadata对象。
        结果
        一个 String包含完全限定类名的 ImageWriterSpi实现类。
        另请参见：
        ImageWriterSpi

      • createTranscoderInstance

        public abstract ImageTranscoder createTranscoderInstance​()
        返回与此服务提供程序相关联的 ImageTranscoder实现的实例。
        结果
        一个 ImageTranscoder例子。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageWriterSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Class ImageWriterSpi

  • java.lang.Object
    • javax.imageio.spi.IIOServiceProvider
      • javax.imageio.spi.ImageReaderWriterSpi
        • javax.imageio.spi.ImageWriterSpi
  • All Implemented Interfaces:
    RegisterableService

    public abstract class ImageWriterSpi
extends ImageReaderWriterSpi
    服务提供商接口（SPI），用于ImageWriter s。 有关服务提供商类的更多信息，请参阅IIORegistry类的类注释。

    每个ImageWriterSpi提供了与它相关联的ImageWriter类的几种类型的信息。

    谁定义的SPI类和类的简要描述的供应商的名称是通过提供getVendorName ， getDescription ，并getVersion方法。 这些方法可以被国际化以提供特定于区域的输出。 这些方法主要用于提供可用于组织弹出菜单或其他列表的简短的人类可写信息。

    格式名称，文件后缀，以及与该服务相关联MIME类型的列表可通过的方式获得getFormatNames ， getFileSuffixes ，和getMIMEType方法。 这些方法可用于识别基于手动格式选择，文件命名或MIME关联来编写特定文件或流的候选者ImageWriter 。

    通过canEncodeImage方法提供了一种更可靠的方法来确定哪些ImageWriter可能能够解析特定的数据流。 此方法允许服务提供商检查实际的图像内容。

    最后，可以通过调用createWriterInstance方法获得与此服务提供商相关联的ImageWriter类的实例。 任何重量级的初始化（如加载本机库或创建大型表）至少应该延迟至首次调用此方法为止。

    另请参见：
    IIORegistry ， ImageTypeSpecifier ， ImageWriter

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Class<?>[] outputTypes
      一组 Class对象，从 getOutputTypes返回，最初为 null 。
      protected String[] readerSpiNames
      要从 getImageReaderSpiNames返回的字符串数组，最初为 null 。
      static Class<?>[] STANDARD_OUTPUT_TYPE
      已过时。
      而不是使用这个字段，直接创建等效的数组{ ImageOutputStream.class } 。

      • Fields inherited from class javax.imageio.spi.IIOServiceProvider

        vendorName, version

      • Fields inherited from class javax.imageio.spi.ImageReaderWriterSpi

        extraImageMetadataFormatClassNames, extraImageMetadataFormatNames, extraStreamMetadataFormatClassNames, extraStreamMetadataFormatNames, MIMETypes, names, nativeImageMetadataFormatClassName, nativeImageMetadataFormatName, nativeStreamMetadataFormatClassName, nativeStreamMetadataFormatName, pluginClassName, suffixes, supportsStandardImageMetadataFormat, supportsStandardStreamMetadataFormat

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ImageWriterSpi​()
      构造一个空白 ImageWriterSpi 。
        ImageWriterSpi​(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class<?>[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
      构造一个给定值的一个 ImageWriterSpi 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean canEncodeImage​(RenderedImage im)
      返回 true如果 ImageWriter与此服务提供者关联实现能够编码给定的 RenderedImage实例。
      abstract boolean canEncodeImage​(ImageTypeSpecifier type)
      如果与此服务提供商相关联的 ImageWriter实现能够对具有给定布局的图像进行编码，则返回 true 。
      ImageWriter createWriterInstance​()
      返回与该服务提供商相关联的 ImageWriter实现的实例。
      abstract ImageWriter createWriterInstance​(Object extension)
      返回与此服务提供商关联的 ImageWriter实现的实例。
      String[] getImageReaderSpiNames​()
      返回一个包含 String的数组， String包含所有 ImageReaderSpi类的所有完全限定名称，可以理解与该服务提供商关联的 ImageWriter所使用的内部元数据表示，如果没有指定 null则 ImageReaders 。
      Class<?>[] getOutputTypes​()
      返回一个 Class对象的数组，指示可以将什么类型的对象用作作者 setOutput方法的参数。
      boolean isFormatLossless​()
      如果此写入器输出的格式可精确保留像素数据，则返回 true 。
      boolean isOwnWriter​(ImageWriter writer)
      如果传递的 ImageWriter对象是与此服务提供商关联的 ImageWriter的实例，则返回 true 。

      • Methods inherited from class javax.imageio.spi.IIOServiceProvider

        getDescription, getVendorName, getVersion, onDeregistration, onRegistration

      • Methods inherited from class javax.imageio.spi.ImageReaderWriterSpi

        getExtraImageMetadataFormatNames, getExtraStreamMetadataFormatNames, getFileSuffixes, getFormatNames, getImageMetadataFormat, getMIMETypes, getNativeImageMetadataFormatName, getNativeStreamMetadataFormatName, getPluginClassName, getStreamMetadataFormat, isStandardImageMetadataFormatSupported, isStandardStreamMetadataFormatSupported

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • STANDARD_OUTPUT_TYPE

        @Deprecated
public static final Class<?>[] STANDARD_OUTPUT_TYPE
        已过时。 而不是使用这个字段，直接创建等效的数组{ ImageOutputStream.class } 。
        一个单元素数组，最初包含 ImageOutputStream.class ，从 getOutputTypes返回。

      • outputTypes

        protected Class<?>[] outputTypes
        一组 Class对象，从 getOutputTypes返回，最初为 null 。

      • readerSpiNames

        protected String[] readerSpiNames
        要从 getImageReaderSpiNames返回的字符串数组，最初为 null 。

    • 构造方法详细信息

      • ImageWriterSpi

        protected ImageWriterSpi​()
        构造一个空白ImageWriterSpi 。 初始化实例变量和/或覆盖方法实现的子类是为了提供所有方法的工作版本。

      • ImageWriterSpi

        public ImageWriterSpi​(String vendorName,
                      String version,
                      String[] names,
                      String[] suffixes,
                      String[] MIMETypes,
                      String writerClassName,
                      Class<?>[] outputTypes,
                      String[] readerSpiNames,
                      boolean supportsStandardStreamMetadataFormat,
                      String nativeStreamMetadataFormatName,
                      String nativeStreamMetadataFormatClassName,
                      String[] extraStreamMetadataFormatNames,
                      String[] extraStreamMetadataFormatClassNames,
                      boolean supportsStandardImageMetadataFormat,
                      String nativeImageMetadataFormatName,
                      String nativeImageMetadataFormatClassName,
                      String[] extraImageMetadataFormatNames,
                      String[] extraImageMetadataFormatClassNames)
        构造一个给定值的一个 ImageWriterSpi 。
        参数
        vendorName - 供应商名称，作为非 null String 。
        version - 版本标识符，作为非 null String 。
        names - 表示格式名称的非null数组String s。 必须至少有一个条目。
        suffixes - 表示公共文件后缀的String的数组。 如果未定义后缀，则应提供null 。 长度为0的数组将被归一化为null 。
        MIMETypes - 表示格式的MIME类型的String s的数组。 如果未定义任何后缀，则应提供null 。 长度为0的数组将被归一化为null 。
        writerClassName - 相关联的 ImageWriterSpi类的完全限定名称，作为非 null String 。
        outputTypes - 长度为至少为1的 Class对象的数组，指示合法的输出类型。
        readerSpiNames - 数组String的长度至少为1，命名所有关联的ImageReader s的类，或null 。 长度为0的数组被归一化为null 。
        supportsStandardStreamMetadataFormat - 表示流元数据对象是否可以使用由标准元数据格式描述的树的 boolean 。
        nativeStreamMetadataFormatName - a String或 null ，由 getNativeStreamMetadataFormatName 。
        nativeStreamMetadataFormatClassName - a String或 null ，用于实例化从 getNativeStreamMetadataFormat返回的元数据格式对象。
        extraStreamMetadataFormatNames -的阵列String S或null从返回， getExtraStreamMetadataFormatNames 。 长度为0的数组被归一化为null 。
        extraStreamMetadataFormatClassNames - 用于实例化要从getStreamMetadataFormat返回的元数据格式对象的String s或null的数组。 长度为0的数组被归一化为null 。
        supportsStandardImageMetadataFormat - 表示图像元数据对象是否可以使用由标准元数据格式描述的树的 boolean 。
        nativeImageMetadataFormatName - a String或 null ，将从 getNativeImageMetadataFormatName返回。
        nativeImageMetadataFormatClassName - a String或 null ，用于实例化要从 getNativeImageMetadataFormat返回的元数据格式对象。
        extraImageMetadataFormatNames -的阵列String从返回小号getExtraImageMetadataFormatNames 。 长度为0的数组被归一化为null 。
        extraImageMetadataFormatClassNames - 用于实例化要从getImageMetadataFormat返回的元数据格式对象的String s或null的数组。 长度为0的数组被归一化为null 。
        异常
        IllegalArgumentException - 如果 vendorName是 null 。
        IllegalArgumentException - 如果 version是 null 。
        IllegalArgumentException - 如果 names为 null或长度为0。
        IllegalArgumentException - 如果 writerClassName是 null 。
        IllegalArgumentException - 如果 outputTypes是 null或长度为0。

    • 方法详细信息

      • isFormatLossless

        public boolean isFormatLossless​()
        如果此写入器输出的格式可精确保留像素数据，则返回true 。 默认实现返回true 。
        结果
        true如果格式保留了完整的像素精度。

      • getOutputTypes

        public Class<?>[] getOutputTypes​()
        返回一个Class对象的数组，指示可以使用什么类型的对象作为撰写者的setOutput方法的参数。

        对于只输出到ImageOutputStream大多数作者，应该返回包含ImageOutputStream.class的单元素数组。

        结果
        一个长度至少为1的非 null数组的 Class对象。

      • canEncodeImage

        public abstract boolean canEncodeImage​(ImageTypeSpecifier type)
        如果与此服务提供商相关联的ImageWriter实现能够对具有给定布局的图像进行编码，则返回true 。 布局（ 即 ，图像的SampleModel和ColorModel ）由ImageTypeSpecifier对象描述。

        返回值为true并不是编码成功的绝对保证; 编码过程可能由于诸如I / O错误，不一致或畸形数据结构等因素而产生错误。意图是对图像的基本结构进行合理的检查，以便确定它是否在范围的编码格式。 例如，只能编码灰度的格式的服务提供商将返回false如果交给RGB BufferedImage 。 类似地，可以编码8位RGB图像的格式的服务提供商可能拒绝对具有相关联的Alpha通道的图像进行编码。

        不同的ImageWriter s，因此服务提供商，可能会选择或多或少严格。 例如，他们可能接受具有预乘法α的图像，即使它们必须被分割出每个像素，以某种精度损失，以便被存储。

        参数
        type - 指定要写入的图像的布局的 ImageTypeSpecifier 。
        结果
        true如果这个作者可能能够用给定的布局编码图像。
        异常
        IllegalArgumentException - 如果 type是 null 。

      • canEncodeImage

        public boolean canEncodeImage​(RenderedImage im)
        返回true如果ImageWriter与此服务提供者关联实现能够编码给定的RenderedImage实例。 请注意，这包括java.awt.image.BufferedImage实例。

        有关此方法的语义的信息，请参阅canEncodeImage(ImageTypeSpecifier)的讨论。

        参数
        im - 要编码的 RenderedImage的实例。
        结果
        true如果这个作者有可能对这个图像进行编码。
        异常
        IllegalArgumentException - 如果 im是 null 。

      • createWriterInstance

        public ImageWriter createWriterInstance​()
                                 throws IOException
        返回与此服务提供商相关联的ImageWriter实现的实例。 返回的对象最初将处于初始状态，就像其reset方法被调用一样。

        默认实现只是返回createWriterInstance(null) 。

        结果
        一个 ImageWriter例子。
        异常
        IOException - 如果写入器类的加载或初始化期间或在写入器对象的实例化或初始化期间发生错误。

      • createWriterInstance

        public abstract ImageWriter createWriterInstance​(Object extension)
                                          throws IOException
        返回与此服务提供商关联的ImageWriter实现的实例。 返回的对象最初将处于初始状态，就像它的reset方法被调用一样。

        在施工时可以向插件提供Object 。 对象的性质是完全插件具体的。

        通常，插件将使用代码（如return new MyImageWriter(this)来实现此方法。

        参数
        extension - 插件特定的扩展对象，可以是 null 。
        结果
        一个 ImageWriter例子。
        异常
        IOException - 如果尝试实例化写入程序失败。
        IllegalArgumentException - 如果 ImageWriter的构造函数抛出一个 IllegalArgumentException来指示扩展对象不合适。

      • isOwnWriter

        public boolean isOwnWriter​(ImageWriter writer)
        如果传入的 ImageWriter对象是与此服务提供商关联的 ImageWriter的实例，则返回 true 。
        参数
        writer - 一个 ImageWriter实例。
        结果
        true如果 writer认识
        异常
        IllegalArgumentException - 如果 writer是 null 。

      • getImageReaderSpiNames

        public String[] getImageReaderSpiNames​()
        返回的数组String包含所有的所有的完全合格的名称小号ImageReaderSpi类，可以理解由所使用的内部元数据表示ImageWriter与此服务提供商相关联，或null ，如果没有这样的ImageReaders指定。 如果返回非null值，那么它必须具有非零长度。

        数组中的第一个项目必须是“首选”读者的服务提供商的名称，因为它将用于实例化由ImageReader返回的ImageIO.getImageReader(ImageWriter) 。

        该机制可用于获得在ImageReaders理解的结构中将产生非像素元数据（见IIOExtraDataInfo ）的ImageWriter 。 通过读取图像并从使用此方法获取的ImageReaders之一获取此数据，并将其传递给ImageWriter ，客户端程序可以读取图像，以某种方式进行修改，并将其写回保留所有元数据，而不需要了解元数据的内部结构，甚至了解图像格式。

        结果
        String的长度至少为1的数组，包含 ImageReaderSpi s或 null 。
        另请参见：
        ImageIO.getImageReader(ImageWriter), ImageReaderSpi.getImageWriterSpiNames()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


javax.imageio.spi (Java SE 9 & JDK 9 )

javax.imageio.spi

Interfaces

  • RegisterableService
  • ServiceRegistry.Filter

Classes

  • IIORegistry
  • IIOServiceProvider
  • ImageInputStreamSpi
  • ImageOutputStreamSpi
  • ImageReaderSpi
  • ImageReaderWriterSpi
  • ImageTranscoderSpi
  • ImageWriterSpi
  • ServiceRegistry


javax.imageio.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package javax.imageio.spi

包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

javax.imageio.spi软件包包含用于读取，写入和转码图像以及获取图像输入和输出流的服务提供程序接口，以及运行时注册表，用于发现图像I / O服务提供者的已安装实例，并允许新实例被注册动态。

从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    RegisterableService
    服务提供商对象提供的可选接口，可以使用 ServiceRegistry注册。
    ServiceRegistry.Filter
    ServiceRegistry.getServiceProviders使用的简单过滤器接口来选择与任意标准匹配的提供者。
  • 类摘要
    Class 描述
    IIORegistry
    服务提供商实例的注册表。
    IIOServiceProvider
    所有Image I / O服务提供商接口（SPI）通用功能的超级界面。
    ImageInputStreamSpi
    ImageInputStream的服务提供商接口（SPI）。
    ImageOutputStreamSpi
    ImageOutputStream的服务提供商接口（SPI）。
    ImageReaderSpi
    ImageReader的服务提供商接口（SPI）。
    ImageReaderWriterSpi
    包含实例变量的超类和 ImageReaderSpi和 ImageWriterSpi共同的方法。
    ImageTranscoderSpi
    ImageTranscoder的服务提供商接口（SPI）。
    ImageWriterSpi
    ImageWriter的服务提供商接口（SPI）。
    ServiceRegistry
    服务提供商实例的注册表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.imageio.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.imageio.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.imageio.spi.IIOServiceProvider (implements javax.imageio.spi.RegisterableService)
      • javax.imageio.spi.ImageInputStreamSpi
      • javax.imageio.spi.ImageOutputStreamSpi
      • javax.imageio.spi.ImageReaderWriterSpi
        • javax.imageio.spi.ImageReaderSpi
        • javax.imageio.spi.ImageWriterSpi
      • javax.imageio.spi.ImageTranscoderSpi
    • javax.imageio.spi.ServiceRegistry
      • javax.imageio.spi.IIORegistry

Interface Hierarchy

  • javax.imageio.spi.RegisterableService
  • javax.imageio.spi.ServiceRegistry.Filter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


RegisterableService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Interface RegisterableService

  • 所有已知实现类：
    IIOServiceProvider ， ImageInputStreamSpi ， ImageOutputStreamSpi ， ImageReaderSpi ， ImageReaderWriterSpi ， ImageTranscoderSpi ， ImageWriterSpi

    public interface RegisterableService
    可以由服务提供商对象提供的可选接口，该对象将使用ServiceRegistry注册。 如果此接口存在，将执行注册和注销的通知。
    另请参见：
    ServiceRegistry

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void onDeregistration​(ServiceRegistry registry, Class<?> category)
      当实现该接口的对象从给定的删除称为 category给定的 registry 。
      void onRegistration​(ServiceRegistry registry, Class<?> category)
      当将实现此接口的对象添加到给定的 category的给定 registry 。

    • 方法详细信息

      • onRegistration

        void onRegistration​(ServiceRegistry registry,
                    Class<?> category)
        当将实现此接口的对象添加到给定的category的给定registry 。 该对象可能已被注册在另一个类别或类别下。
        参数
        registry - 一个 ServiceRegistry ，其中该对象已被注册。
        category - 一个 Class对象，指示已注册该对象的注册表类别。

      • onDeregistration

        void onDeregistration​(ServiceRegistry registry,
                      Class<?> category)
        当实现该接口的对象从给定的删除称为category给定的registry 。 该对象仍然可以在另一个类别或类别下注册。
        参数
        registry - 一个 ServiceRegistry从该对象正在（全部或部分）注销。
        category - 一个 Class对象，指示该对象正在注销的注册表类别。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServiceRegistry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Class ServiceRegistry

  • java.lang.Object
    • javax.imageio.spi.ServiceRegistry
  • 已知直接子类：
    IIORegistry

    public class ServiceRegistry
extends Object
    服务提供商实例的注册表。

    一个服务是一组众所周知的接口（通常是抽象的）类。 服务提供商是服务的具体实现。 提供者中的类通常实现接口或者子类化服务本身定义的类。

    服务提供商存储在一个或多个类别中 ，每个类别 Class所有成员必须实现的一类接口（由Class对象描述）定义。

    支持的一组类别仅限于以下标准的图像I / O服务类型：

    • ImageInputStreamSpi
    • ImageOutputStreamSpi
    • ImageReaderSpi
    • ImageTranscoderSpi
    • ImageWriterSpi

    尝试加载不是上述类型的子类型的提供程序将导致IllegalArgumentException 。 有关加载服务提供商的一般机制，请参阅ServiceLoader 。

    可以注册一个给定叶类的一个实例（即getClass()返回的实际类，而不是任何继承的类或接口）。 也就是说，假设com.mycompany.mypkg.GreenImageReaderProvider类的子类javax.imageio.spi.ImageReaderSpi 。 如果一个GreenImageReaderProvider实例被注册，它将被存储在由ImageReaderSpi类定义的类别中。 如果注册了一个新的GreenImageReaderProvider实例，它将替换以前的实例。 实际上，服务提供商对象通常是单身，因此这种行为是合适的。

    要声明服务提供商， services目录中的META-INF目录将放在每个JAR文件中。 此目录包含每个服务提供程序接口的文件，该接口在JAR文件中具有一个或多个实现类。 例如，如果JAR文件包含一个名为com.mycompany.mypkg.GreenImageReaderProvider的类，它实现了javax.imageio.spi.ImageReaderSpi接口，则JAR文件将包含一个名为

      META-INF/services/javax.imageio.spi.ImageReaderSpi
    包含行：
      com.mycompany.mypkg.GreenImageReaderProvider

    服务提供商类应该是轻量级的，并且加载速度快。 这些接口的实现应避免对其他类和本地代码的复杂依赖。 更复杂服务的通常模式是为重量级服务注册轻量级代理。

    只要具有适当的运行时权限，应用程序就可以自定义注册表的内容。

    有关声明服务提供商的更多详细信息以及JAR格式，请参阅JAR File Specification 。

    另请参见：
    RegisterableService ， ServiceLoader

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static interface  ServiceRegistry.Filter
      ServiceRegistry.getServiceProviders使用的简单过滤器接口来选择与任意条件匹配的提供者。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ServiceRegistry​(Iterator<Class<?>> categories)
      构造一个 ServiceRegistry实例，其中包含一组从 categories参数获取的类别。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean contains​(Object provider)
      如果 provider当前注册，则返回 true 。
      void deregisterAll​()
      取消注册所有类别的所有当前注册服务提供商。
      void deregisterAll​(Class<?> category)
      取消注册目前在给定类别下注册的所有服务提供商对象。
      void deregisterServiceProvider​(Object provider)
      从包含它的所有类别中删除服务提供商对象。
      <T> boolean deregisterServiceProvider​(T provider, Class<T> category)
      从给定的类别中删除服务提供者对象。
      void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      Iterator<Class<?>> getCategories​()
      返回 Iterator个 Class对象，指示当前的类别集。
      <T> T getServiceProviderByClass​(Class<T> providerClass)
      返回给定类类型的当前注册的服务提供者对象。
      <T> Iterator<T> getServiceProviders​(Class<T> category, boolean useOrdering)
      返回包含给定类别中的所有注册服务提供商的 Iterator 。
      <T> Iterator<T> getServiceProviders​(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
      返回 Iterator一个给定类别中满足由所提供的定义的条件的含服务提供程序对象 ServiceRegistry.Filter对象的 filter方法。
      static <T> Iterator<T> lookupProviders​(Class<T> providerClass)
      使用上下文类加载器定位并递增实例化给定服务的可用提供程序。
      static <T> Iterator<T> lookupProviders​(Class<T> providerClass, ClassLoader loader)
      使用给定的类加载器搜索特定服务类的实现。
      void registerServiceProvider​(Object provider)
      将服务提供者对象添加到注册表。
      <T> boolean registerServiceProvider​(T provider, Class<T> category)
      将服务提供者对象添加到注册表。
      void registerServiceProviders​(Iterator<?> providers)
      添加一组服务提供者对象，从 Iterator到注册表。
      <T> boolean setOrdering​(Class<T> category, T firstProvider, T secondProvider)
      在给定类别中的两个服务提供者对象之间设置成对排序。
      <T> boolean unsetOrdering​(Class<T> category, T firstProvider, T secondProvider)
      在给定类别中的两个服务提供者对象之间设置成对排序。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServiceRegistry

        public ServiceRegistry​(Iterator<Class<?>> categories)
        构造一个ServiceRegistry实例，并从categories参数中获取一组类别。 类别必须都是类规范中列出的一组服务类型的成员。
        参数
        categories - 一个 Iterator包含 Class对象用于定义类别。
        异常
        IllegalArgumentException - 如果 categories是 null ，或者其中一个类别不是允许的服务类型。

    • 方法详细信息

      • lookupProviders

        public static <T> Iterator<T> lookupProviders​(Class<T> providerClass,
                                              ClassLoader loader)
        使用给定的类加载器搜索特定服务类的实现。

        服务类必须是类规范中列出的服务类型之一。 如果不是， IllegalArgumentException将被抛出。

        此方法将给定服务类的名称转换为类注释中所述的提供者配置文件名，然后使用给定类加载器的getResources方法查找具有该名称的所有可用文件。 然后读取并解析这些文件以生成提供者类名称列表。 返回的迭代器使用给定的类加载器来查找列表中的每个元素，然后实例化。

        因为可以将扩展安装到正在运行的Java虚拟机中，所以每次调用此方法时都可能会返回不同的结果。

        参数类型
        T - providerClass的类型。
        参数
        providerClass - 表示正在检测到的服务提供商的类或接口的 Class对象。
        loader - 要用于加载提供程序配置文件并实例化提供程序类的类加载器，如果要使用系统类加载器（或者不启动引导类加载器）， null 。
        结果
        一个Iterator ，以某种任意顺序产生给定服务的提供者对象。 如果提供者配置文件违反了指定的格式，或者不能找到和实例化提供程序类，迭代器将抛出一个Error 。
        异常
        IllegalArgumentException - 如果 providerClass是 null ，或者如果它不是允许的服务类型之一。

      • lookupProviders

        public static <T> Iterator<T> lookupProviders​(Class<T> providerClass)
        使用上下文类加载器定位并递增实例化给定服务的可用提供程序。 这种方便方法相当于：
          ClassLoader cl = Thread.currentThread().getContextClassLoader();
   return Service.providers(service, cl);

        服务类必须是类规范中列出的服务类型之一。 如果不是， IllegalArgumentException将被抛出。

        参数类型
        T - providerClass的类型。
        参数
        providerClass - 一个 Class对象，指示正在检测到的服务提供商的类或接口。
        结果
        一个Iterator ，以某种任意顺序产生给定服务的提供程序对象。 如果提供者配置文件违反指定的格式，或者提供者类不能被发现和实例化，迭代器将抛出一个Error 。
        异常
        IllegalArgumentException - 如果 providerClass是 null ，或者它不是允许的服务类型之一。

      • getCategories

        public Iterator<Class<?>> getCategories​()
        返回Iterator个Class对象的Iterator ，表示当前的类别集。 如果没有类别，迭代器将为空。
        结果
        一个 Iterator包含 Class对象。

      • registerServiceProvider

        public <T> boolean registerServiceProvider​(T provider,
                                           Class<T> category)
        将服务提供者对象添加到注册表。 提供者与给定类别相关联。

        如果provider实现了RegisterableService接口，则其onRegistration方法将被调用。 每次从类别中注销时，将会调用其onDeregistration方法，例如，如果某个类别被删除或注册表被垃圾回收。

        参数类型
        T - 提供者的类型。
        参数
        provider - 服务提供要注册的对象。
        category - 注册提供商的类别。
        结果
        如果没有同一类的提供者以前在同一类别类别中注册，则为true。
        异常
        IllegalArgumentException - 如果 provider是 null 。
        IllegalArgumentException - 如果没有类别对应 category 。
        ClassCastException - 如果提供程序未实现由 Class定义的 category 。

      • registerServiceProvider

        public void registerServiceProvider​(Object provider)
        将服务提供者对象添加到注册表。 该提供程序在其实现的Class的注册表中存在的每个类别中相关联。

        如果provider实现RegisterableService接口，则其onRegistration方法将被称为在其注册的每个类别一次。 它的onDeregistration方法将在每次从类别注销时或注册表完成时被调用。

        参数
        provider - 要注册的服务提供商对象。
        异常
        IllegalArgumentException - 如果 provider是 null 。

      • registerServiceProviders

        public void registerServiceProviders​(Iterator<?> providers)
        将一组服务提供者对象从Iterator到注册表。 每个提供者在其实现的Class的注册表中存在的每个类别内关联。

        对于实现RegisterableService接口的providers每个条目，其onRegistration方法将在其注册的每个类别被调用一次。 它的onDeregistration方法将在每次从类别注销或注册表完成时被调用。

        参数
        providers - 一个包含要注册的服务提供商对象的迭代器。
        异常
        IllegalArgumentException - 如果 providers是 null或包含一个 null条目。

      • deregisterServiceProvider

        public <T> boolean deregisterServiceProvider​(T provider,
                                             Class<T> category)
        从给定的类别中删除服务提供者对象。 如果提供商以前没有注册，则不会发生任何事情，并返回false 。 否则返回true 。 如果与provider相同但不相等（使用== ）至provider对象注册，则不会被注销。

        如果provider实现RegisterableService接口，则其onDeregistration方法将被调用。

        参数类型
        T - 提供者的类型。
        参数
        provider - 要注销的服务提供商对象。
        category - 从中注销提供程序的类别。
        结果
        true如果提供商以前在同一类别类别中注册， false 。
        异常
        IllegalArgumentException - 如果 provider是 null 。
        IllegalArgumentException - 如果没有类别对应 category 。
        ClassCastException - 如果提供程序不实现由 category定义的类。

      • deregisterServiceProvider

        public void deregisterServiceProvider​(Object provider)
        从包含它的所有类别中删除服务提供商对象。
        参数
        provider - 要注销的服务提供商对象。
        异常
        IllegalArgumentException - 如果 provider是 null 。

      • contains

        public boolean contains​(Object provider)
        如果 provider当前注册，则返回 true 。
        参数
        provider - 要查询的服务提供商对象。
        结果
        true如果给定的提供者已被注册。
        异常
        IllegalArgumentException - 如果 provider是 null 。

      • getServiceProviders

        public <T> Iterator<T> getServiceProviders​(Class<T> category,
                                           boolean useOrdering)
        返回包含给定类别中的所有注册服务提供商的Iterator 。 如果useOrdering为false ，则迭代器将以任意顺序返回所有服务器提供程序对象。 否则，订单将尊重已设置的任何成对订单。 如果成对订单的图形包含循环，则不会返回属于循环的任何提供程序。
        参数类型
        T - 类别的类型。
        参数
        category - 要从中检索的类别。
        useOrdering - true如果在订购返回的对象时应考虑成对订单。
        结果
        一个包含给定类别的服务提供者对象的 Iterator ，可能按顺序排列。
        异常
        IllegalArgumentException - 如果没有类别对应 category 。

      • getServiceProviders

        public <T> Iterator<T> getServiceProviders​(Class<T> category,
                                           ServiceRegistry.Filter filter,
                                           boolean useOrdering)
        返回Iterator一个给定类别中满足由所提供的定义的条件的含服务提供程序对象ServiceRegistry.Filter对象的filter方法。

        useOrdering参数使用与getServiceProviders(Class, boolean)相同的规则来控制结果的排序。

        参数类型
        T - 类别的类型。
        参数
        category - 要检索的类别。
        filter - 将调用其 filter方法的 ServiceRegistry.Filter的实例。
        useOrdering - true如果在订购返回的对象时应考虑成对订购。
        结果
        一个包含给定类别的服务提供者对象的 Iterator ，可能是有序的。
        异常
        IllegalArgumentException - 如果没有类别对应 category 。

      • getServiceProviderByClass

        public <T> T getServiceProviderByClass​(Class<T> providerClass)
        返回给定类类型的当前注册的服务提供者对象。 给定类别的最多一个对象允许在任何给定时间被注册。 如果没有注册对象具有所需的类类型，则返回null 。
        参数类型
        T - 提供者的类型。
        参数
        providerClass - 所需服务提供商对象的 Class 。
        结果
        目前注册的服务提供商对象具有所需的 Class类型，或者是 null是不存在的。
        异常
        IllegalArgumentException - 如果 providerClass是 null 。

      • setOrdering

        public <T> boolean setOrdering​(Class<T> category,
                               T firstProvider,
                               T secondProvider)
        在给定类别中的两个服务提供者对象之间设置成对排序。 如果一个或两个对象当前没有在给定类别中注册，或者如果所需的排序已经设置，则不会发生任何事情，并返回false 。 如果提供商之前已经按相反的方向进行订购，那么该订单将被删除。

        getServiceProviders方法的useOrdering参数为true时，排序将被使用。

        参数类型
        T - 类别的类型。
        参数
        category - 一个 Class对象，指示要建立偏好的类别。
        firstProvider - 首选提供商。
        secondProvider -提供到 firstProvider是优选的。
        结果
        true如果先前未设置的顺序建立。
        异常
        IllegalArgumentException - 如果任一提供者是 null或它们是相同的对象。
        IllegalArgumentException - 如果没有类别对应 category 。

      • unsetOrdering

        public <T> boolean unsetOrdering​(Class<T> category,
                                 T firstProvider,
                                 T secondProvider)
        在给定类别中的两个服务提供者对象之间设置成对排序。 如果一个或两个对象当前没有在给定类别中注册，或者如果当前没有设置任何顺序，则不会发生任何事情，并返回false 。

        当它们的useOrdering参数为true时，排序将由getServiceProviders方法使用。

        参数类型
        T - 类别的类型。
        参数
        category - 一个 Class对象，指示优先级要被拆除的类别。
        firstProvider - 以前的首选提供商。
        secondProvider - 以前优先选择的供应商 firstProvider 。
        结果
        true如果以前设置的排序已经解除了。
        异常
        IllegalArgumentException - 如果任一提供者是 null或它们是相同的对象。
        IllegalArgumentException - 如果没有类别对应 category 。

      • deregisterAll

        public void deregisterAll​(Class<?> category)
        取消注册目前在给定类别下注册的所有服务提供商对象。
        参数
        category - 要清空的类别。
        异常
        IllegalArgumentException - 如果没有类别对应 category 。

      • deregisterAll

        public void deregisterAll​()
        取消注册所有类别的所有当前注册服务提供商。

      • finalize

        @Deprecated(since="9")
public void finalize​()
              throws Throwable
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        在垃圾收集之前完成此对象。 调用deregisterAll方法来注销所有当前注册的服务提供商。 不应该从应用程序代码调用此方法。
        重写：
        finalize在 Object
        异常
        Throwable - 如果超类最终化期间发生错误。
        另请参见：
        WeakReference ， PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServiceRegistry.Filter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.spi

Interface ServiceRegistry.Filter

  • Enclosing class:
    ServiceRegistry

    public static interface ServiceRegistry.Filter
    ServiceRegistry.getServiceProviders使用的简单过滤器接口来选择与任意条件匹配的提供者。 实现此接口的类应以利用来定义getServiceProviders的方法ServiceRegistry ，需要一个Filter 。
    另请参见：
    ServiceRegistry.getServiceProviders(Class, ServiceRegistry.Filter, boolean)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean filter​(Object provider)
      返回 true如果给定 provider对象通过这个定义的标准匹配 Filter 。

    • 方法详细信息

      • filter

        boolean filter​(Object provider)
        返回 true如果给定 provider对象通过这个定义的标准匹配 Filter 。
        参数
        provider - 服务提供商 Object 。
        结果
        true if the provider matches the criterion.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.imageio.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.imageio.spi

  • Packages that use javax.imageio.spi
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
  • Classes in javax.imageio.spi used by javax.imageio
    Class 描述
    ImageReaderSpi
    ImageReader的服务提供商接口（SPI）。
    ImageWriterSpi
    ImageWriter的服务提供商接口（SPI）
  • Classes in javax.imageio.spi used by javax.imageio.spi
    Class 描述
    IIORegistry
    服务提供商实例的注册表。
    IIOServiceProvider
    所有Image I / O服务提供商接口（SPI）通用功能的超级界面。
    ImageReaderWriterSpi
    一个包含实例变量的超类和 ImageReaderSpi和 ImageWriterSpi共同的方法。
    RegisterableService
    服务提供商对象提供的可选接口，该对象将使用 ServiceRegistry注册。
    ServiceRegistry
    服务提供商实例的注册表。
    ServiceRegistry.Filter
    ServiceRegistry.getServiceProviders使用的简单过滤器接口来选择与任意标准匹配的提供者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.spi.IIORegistry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.spi.IIORegistry

  • Packages that use IIORegistry
    软件包 描述
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of IIORegistry in javax.imageio.spi

      Methods in javax.imageio.spi that return IIORegistry
      Modifier and Type 方法 描述
      static IIORegistry IIORegistry.getDefaultInstance​()
      返回Image I / O API使用的默认 IIORegistry实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.spi.IIOServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.spi.IIOServiceProvider

  • Packages that use IIOServiceProvider
    软件包 描述
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of IIOServiceProvider in javax.imageio.spi

      Subclasses of IIOServiceProvider in javax.imageio.spi
      Modifier and Type Class 描述
      class  ImageInputStreamSpi
      服务提供商接口（SPI），用于 ImageInputStream s。
      class  ImageOutputStreamSpi
      ImageOutputStream的服务提供商接口（SPI）。
      class  ImageReaderSpi
      服务提供商接口（SPI）为 ImageReader s。
      class  ImageReaderWriterSpi
      一个包含实例变量的超类和 ImageReaderSpi和 ImageWriterSpi共同的方法。
      class  ImageTranscoderSpi
      服务提供商接口（SPI），用于 ImageTranscoder s。
      class  ImageWriterSpi
      The service provider interface (SPI) for ImageWriters.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.spi.ImageInputStreamSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.spi.ImageInputStreamSpi

No usage of javax.imageio.spi.ImageInputStreamSpi
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.spi.ImageOutputStreamSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.spi.ImageOutputStreamSpi

No usage of javax.imageio.spi.ImageOutputStreamSpi
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.spi.ImageReaderSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.spi.ImageReaderSpi

  • Packages that use ImageReaderSpi
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of ImageReaderSpi in javax.imageio

      Fields in javax.imageio declared as ImageReaderSpi
      Modifier and Type Field 描述
      protected ImageReaderSpi ImageReader.originatingProvider
      该 ImageReaderSpi认为这个实例化对象，或者 null如果其身份未知或不存在。
      Methods in javax.imageio that return ImageReaderSpi
      Modifier and Type 方法 描述
      ImageReaderSpi ImageReader.getOriginatingProvider​()
      返回传递给构造函数的 ImageReaderSpi 。
      Constructors in javax.imageio with parameters of type ImageReaderSpi
      Constructor 描述
      ImageReader​(ImageReaderSpi originatingProvider)
      构造一个 ImageReader并将其 originatingProvider字段设置为提供的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.spi.ImageReaderWriterSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.spi.ImageReaderWriterSpi

  • Packages that use ImageReaderWriterSpi
    软件包 描述
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of ImageReaderWriterSpi in javax.imageio.spi

      Subclasses of ImageReaderWriterSpi in javax.imageio.spi
      Modifier and Type Class 描述
      class  ImageReaderSpi
      服务提供商接口（SPI），用于 ImageReader s。
      class  ImageWriterSpi
      服务提供商接口（SPI），用于 ImageWriter s。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.spi.ImageTranscoderSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.spi.ImageTranscoderSpi

No usage of javax.imageio.spi.ImageTranscoderSpi
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.spi.ImageWriterSpi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.spi.ImageWriterSpi

  • Packages that use ImageWriterSpi
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of ImageWriterSpi in javax.imageio

      Fields in javax.imageio declared as ImageWriterSpi
      Modifier and Type Field 描述
      protected ImageWriterSpi ImageWriter.originatingProvider
      该 ImageWriterSpi认为这个实例化对象，或者 null如果其身份未知或不存在。
      Methods in javax.imageio that return ImageWriterSpi
      Modifier and Type 方法 描述
      ImageWriterSpi ImageWriter.getOriginatingProvider​()
      返回 ImageWriterSpi创建此对象 ImageWriter ，或者 null如果这个对象不是通过创建 IIORegistry 。
      Constructors in javax.imageio with parameters of type ImageWriterSpi
      Constructor 描述
      ImageWriter​(ImageWriterSpi originatingProvider)
      构造一个 ImageWriter并将其 originatingProvider实例变量设置为提供的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.spi.ServiceRegistry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.spi.ServiceRegistry

  • Packages that use ServiceRegistry
    软件包 描述
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of ServiceRegistry in javax.imageio.spi

      Subclasses of ServiceRegistry in javax.imageio.spi
      Modifier and Type Class 描述
      class  IIORegistry
      服务提供商实例的注册表。
      Methods in javax.imageio.spi with parameters of type ServiceRegistry
      Modifier and Type 方法 描述
      void IIOServiceProvider.onDeregistration​(ServiceRegistry registry, Class<?> category)
      每当Spi课程从 ServiceRegistry注销时，将会回调。
      void RegisterableService.onDeregistration​(ServiceRegistry registry, Class<?> category)
      当实现该接口的对象从给定的删除称为 category给定的 registry 。
      void IIOServiceProvider.onRegistration​(ServiceRegistry registry, Class<?> category)
      在Spi类已被实例化并在 ServiceRegistry注册后，将被调用一次的 ServiceRegistry 。
      void RegisterableService.onRegistration​(ServiceRegistry registry, Class<?> category)
      当将实现此接口的对象添加到给定的 category的给定 registry 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.spi.RegisterableService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.spi.RegisterableService

  • Packages that use RegisterableService
    软件包 描述
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of RegisterableService in javax.imageio.spi

      Classes in javax.imageio.spi that implement RegisterableService
      Modifier and Type Class 描述
      class  IIOServiceProvider
      所有Image I / O服务提供商接口（SPI）通用功能的超级界面。
      class  ImageInputStreamSpi
      ImageInputStream的服务提供商接口（SPI）。
      class  ImageOutputStreamSpi
      服务提供商接口（SPI），适用于 ImageOutputStream 。
      class  ImageReaderSpi
      ImageReader的服务提供商接口（SPI）。
      class  ImageReaderWriterSpi
      一个包含实例变量的超类和 ImageReaderSpi和 ImageWriterSpi共同的方法。
      class  ImageTranscoderSpi
      ImageTranscoder的服务提供商接口（SPI）。
      class  ImageWriterSpi
      ImageWriter的服务提供商接口（SPI）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.spi.ServiceRegistry.Filter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.spi.ServiceRegistry.Filter

  • Packages that use ServiceRegistry.Filter
    软件包 描述
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of ServiceRegistry.Filter in javax.imageio.spi

      Methods in javax.imageio.spi with parameters of type ServiceRegistry.Filter
      Modifier and Type 方法 描述
      <T> Iterator<T> ServiceRegistry.getServiceProviders​(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
      返回 Iterator一个给定类别中满足由所提供的定义的条件的含服务提供程序对象 ServiceRegistry.Filter对象的 filter方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


FileCacheImageInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Class FileCacheImageInputStream

  • java.lang.Object
    • javax.imageio.stream.ImageInputStreamImpl
      • javax.imageio.stream.FileCacheImageInputStream
  • All Implemented Interfaces:
    Closeable ， DataInput ， AutoCloseable ， ImageInputStream

    public class FileCacheImageInputStream
extends ImageInputStreamImpl
    一个ImageInputStream的实现，从常规的InputStream得到它的输入。 一个文件用于缓存先前读取的数据。

    • Field Summary

      • Fields inherited from class javax.imageio.stream.ImageInputStreamImpl

        bitOffset, byteOrder, flushedPos, streamPos

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileCacheImageInputStream​(InputStream stream, File cacheDir)
      构造一个 FileCacheImageInputStream ，将从给定的 InputStream读取。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此 FileCacheImageInputStream ，关闭并删除缓存文件。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      boolean isCached​()
      返回 true因为这个 ImageInputStream缓存数据，以便向后 ImageInputStream 。
      boolean isCachedFile​()
      返回 true因为这个 ImageInputStream维护一个文件缓存。
      boolean isCachedMemory​()
      返回 false因为这个 ImageInputStream没有维护主内存缓存。
      int read​()
      从流中读取一个字节，并将其作为 int返回0到255之间。
      int read​(byte[] b, int off, int len)
      从流中读取最多 len个字节，并将其存储到 b ，索引号为 off 。

      • Methods inherited from class javax.imageio.stream.ImageInputStreamImpl

        checkClosed, flush, flushBefore, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, length, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileCacheImageInputStream

        public FileCacheImageInputStream​(InputStream stream,
                                 File cacheDir)
                          throws IOException
        构造一个FileCacheImageInputStream ，它将从给定的InputStream读取。

        临时文件用作缓存。 如果cacheDir是非null并且是一个目录，该文件将在那里创建。 如果是null ，将使用系统相关的默认临时文件目录（有关详细信息，请参阅File.createTempFile的文档）。

        参数
        stream - 要阅读的 InputStream 。
        cacheDir - 一个 File指示应该创建缓存文件的位置，或 null使用系统目录。
        异常
        IllegalArgumentException - 如果 stream是 null 。
        IllegalArgumentException - 如果 cacheDir是非 null但不是一个目录。
        IOException - 如果无法创建缓存文件。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        描述从类别复制ImageInputStreamImpl
        从流中读取一个字节，并将其作为int返回0到255之间。如果达到EOF，则返回-1 。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        在发生读取之前，流内的位偏移必须重置为零。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read在 ImageInputStreamImpl
        结果
        流中下一个字节的值，如果达到EOF， -1 。
        异常
        IOException - 如果流已关闭。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        描述从类复制： ImageInputStreamImpl
        读取到len从流字节，并将其存储到b开始于索引off 。 如果没有字节可以读取，因为已经到达流的末尾，则返回-1 。

        在发生读取之前，流内的位偏移必须重置为零。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read在 ImageInputStreamImpl
        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要读取的最大字节数。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        IOException - 如果发生I / O错误。

      • isCached

        public boolean isCached​()
        返回 true因为这个 ImageInputStream缓存数据，以便向后 ImageInputStream 。
        Specified by:
        isCached在接口 ImageInputStream
        重写：
        isCached在 ImageInputStreamImpl
        结果
        true 。
        另请参见：
        isCachedMemory() ， isCachedFile()

      • isCachedFile

        public boolean isCachedFile​()
        返回 true因为这个 ImageInputStream维护一个文件缓存。
        Specified by:
        isCachedFile接口 ImageInputStream
        重写：
        isCachedFile在 ImageInputStreamImpl
        结果
        true 。
        另请参见：
        isCached() ， isCachedMemory()

      • isCachedMemory

        public boolean isCachedMemory​()
        返回 false因为这个 ImageInputStream不维护主内存缓存。
        Specified by:
        isCachedMemory在接口 ImageInputStream
        重写：
        isCachedMemory在 ImageInputStreamImpl
        结果
        false 。
        另请参见：
        isCached() ， isCachedFile()

      • close

        public void close​()
           throws IOException
        关闭此FileCacheImageInputStream ，关闭并删除缓存文件。 源InputStream未关闭。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在接口 ImageInputStream
        重写：
        close在 ImageInputStreamImpl
        异常
        IOException - 如果发生错误。

      • finalize

        @Deprecated(since="9")
protected void finalize​()
                 throws Throwable
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        在垃圾收集之前完成此对象。 调用close方法来关闭任何打开的输入源。 不应该从应用程序代码调用此方法。
        重写：
        finalize在 ImageInputStreamImpl
        异常
        Throwable - 如果在超类最终化期间发生错误。
        另请参见：
        WeakReference ， PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileCacheImageOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Class FileCacheImageOutputStream

  • java.lang.Object
    • javax.imageio.stream.ImageInputStreamImpl
      • javax.imageio.stream.ImageOutputStreamImpl
        • javax.imageio.stream.FileCacheImageOutputStream
  • All Implemented Interfaces:
    Closeable ， DataInput ， DataOutput ， AutoCloseable ， ImageInputStream ， ImageOutputStream

    public class FileCacheImageOutputStream
extends ImageOutputStreamImpl
    一个ImageOutputStream的实现，将其输出写入常规的OutputStream 。 一个文件用于缓存数据，直到它被刷新到输出流。

    • Field Summary

      • Fields inherited from class javax.imageio.stream.ImageInputStreamImpl

        bitOffset, byteOrder, flushedPos, streamPos

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileCacheImageOutputStream​(OutputStream stream, File cacheDir)
      构造一个 FileCacheImageOutputStream ，它将写入给定的 outputStream 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此 FileCacheImageOutputStream 。
      void flushBefore​(long pos)
      在指示的位置之前丢弃流的初始部分。
      boolean isCached​()
      返回 true因为这个 ImageOutputStream缓存数据，以便向后 ImageOutputStream 。
      boolean isCachedFile​()
      返回 true因为这个 ImageOutputStream维护一个文件缓存。
      boolean isCachedMemory​()
      返回 false因为这个 ImageOutputStream不维护主内存缓存。
      long length​()
      返回 -1L以表示该流具有未知长度。
      int read​()
      从流中读取一个字节，并将其作为 int返回0到255之间。
      int read​(byte[] b, int off, int len)
      从流中读取最多 len个字节，并将其存储到 b ，索引号为 off 。
      void seek​(long pos)
      设置当前流位置，并将位偏移重置为0。
      void write​(byte[] b, int off, int len)
      在当前位置写入一串字节。
      void write​(int b)
      将当前位置的单个字节写入流。

      • Methods inherited from interface javax.imageio.stream.ImageInputStream

        flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from class javax.imageio.stream.ImageInputStreamImpl

        checkClosed, finalize, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from class javax.imageio.stream.ImageOutputStreamImpl

        flushBits, write, writeBit, writeBits, writeBoolean, writeByte, writeBytes, writeChar, writeChars, writeChars, writeDouble, writeDoubles, writeFloat, writeFloats, writeInt, writeInts, writeLong, writeLongs, writeShort, writeShorts, writeUTF

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileCacheImageOutputStream

        public FileCacheImageOutputStream​(OutputStream stream,
                                  File cacheDir)
                           throws IOException
        构造一个FileCacheImageOutputStream ，它将写入给定的outputStream 。

        临时文件用作缓存。 如果cacheDir是非null并且是一个目录，该文件将在那里创建。 如果是null ，将使用系统相关的默认临时文件目录（有关详细信息，请参阅File.createTempFile的文档）。

        参数
        stream - 要写的 OutputStream 。
        cacheDir - 一个 File指示应该创建缓存文件的位置，或 null使用系统目录。
        异常
        IllegalArgumentException - 如果 stream是 null 。
        IllegalArgumentException - 如果 cacheDir是非 null但不是一个目录。
        IOException - 如果无法创建缓存文件。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        描述从类复制： ImageInputStreamImpl
        从流中读取一个字节，并将其作为int返回到0到255之间。如果达到EOF，则返回-1 。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        在发生读取之前，流内的位偏移必须重置为零。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read在 ImageInputStreamImpl
        结果
        流中下一个字节的值，如果达到EOF， -1 。
        异常
        IOException - 如果流已关闭。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        说明从类别复制ImageInputStreamImpl
        读取到len从流字节，并将其存储到b开始于索引off 。 如果没有字节可以读取，因为已经到达流的末尾，则返回-1 。

        在发生读取之前，流内的位偏移必须重置为零。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read在 ImageInputStreamImpl
        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要读取的最大字节数。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(int b)
           throws IOException
        描述从接口ImageOutputStream复制
        将当前位置的单个字节写入流。 b的24个高位被忽略。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ImageOutputStream
        Specified by:
        write在 ImageOutputStreamImpl
        参数
        b - 要写入低8位的 int 。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        描述从接口ImageOutputStream复制
        在当前位置写入一串字节。 如果len为0，则不会写入。 字节b[off]首先写入，然后字节b[off + 1]等等。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ImageOutputStream
        Specified by:
        write在 ImageOutputStreamImpl
        参数
        b - 要写入的 byte的数组。
        off - 数据中的起始偏移量。
        len - byte的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • length

        public long length​()
        描述从类别复制ImageInputStreamImpl
        返回-1L以表示该流具有未知长度。 子类必须覆盖此方法以提供实际的长度信息。
        Specified by:
        length在接口 ImageInputStream
        重写：
        length在 ImageInputStreamImpl
        结果
        -1L表示未知长度。

      • seek

        public void seek​(long pos)
          throws IOException
        设置当前流位置，并将位偏移量重置为0.合法查找文件的结尾; 一个EOFException只有在执行读取时才会被抛出。 在执行写入之前，文件长度不会增加。
        Specified by:
        seek在接口 ImageInputStream
        重写：
        seek在 ImageInputStreamImpl
        参数
        pos - 包含所需文件指针位置的 long 。
        异常
        IndexOutOfBoundsException - 如果 pos小于冲洗位置。
        IOException - 如果发生任何其他I / O错误。

      • isCached

        public boolean isCached​()
        返回 true因为这个 ImageOutputStream缓存数据，以便向后 ImageOutputStream 。
        Specified by:
        isCached在接口 ImageInputStream
        重写：
        isCached在 ImageInputStreamImpl
        结果
        true 。
        另请参见：
        isCachedMemory() ， isCachedFile()

      • isCachedFile

        public boolean isCachedFile​()
        返回 true因为这个 ImageOutputStream维护一个文件缓存。
        Specified by:
        isCachedFile在接口 ImageInputStream
        重写：
        isCachedFile在 ImageInputStreamImpl
        结果
        true 。
        另请参见：
        isCached() ， isCachedMemory()

      • isCachedMemory

        public boolean isCachedMemory​()
        返回 false因为这个 ImageOutputStream没有维护主内存缓存。
        Specified by:
        isCachedMemory在接口 ImageInputStream
        重写：
        isCachedMemory在 ImageInputStreamImpl
        结果
        false 。
        另请参见：
        isCached() ， isCachedFile()

      • close

        public void close​()
           throws IOException
        关闭此FileCacheImageOutputStream 。 所有挂起的数据都被刷新到输出，缓存文件被关闭并被删除。 目的地OutputStream未关闭。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在接口 ImageInputStream
        重写：
        close在 ImageInputStreamImpl
        异常
        IOException - 如果发生错误。

      • flushBefore

        public void flushBefore​(long pos)
                 throws IOException
        描述从接口ImageInputStream复制
        在指示的位置之前丢弃流的初始部分。 试图寻求在流的冲洗部分内的偏移量将导致IndexOutOfBoundsException 。

        调用flushBefore可能允许实现此接口的类释放用于存储数据流的内存或磁盘空间等资源。

        Specified by:
        flushBefore在接口 ImageInputStream
        Specified by:
        flushBefore在接口 ImageOutputStream
        重写：
        flushBefore在 ImageInputStreamImpl
        参数
        pos - 一个 long其中包含可能被刷新的流前缀的长度。
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileImageInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Class FileImageInputStream

  • java.lang.Object
    • javax.imageio.stream.ImageInputStreamImpl
      • javax.imageio.stream.FileImageInputStream
  • All Implemented Interfaces:
    Closeable ， DataInput ， AutoCloseable ， ImageInputStream

    public class FileImageInputStream
extends ImageInputStreamImpl
    一个ImageInputStream一个实现，从File或RandomAccessFile获取它的输入。 假设文件内容在对象的生存期内是稳定的。

    • Field Summary

      • Fields inherited from class javax.imageio.stream.ImageInputStreamImpl

        bitOffset, byteOrder, flushedPos, streamPos

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileImageInputStream​(File f)
      构造一个 FileImageInputStream ，它将从给定的 File读取。
      FileImageInputStream​(RandomAccessFile raf)
      构造一个 FileImageInputStream ，将从给定的 RandomAccessFile读取。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      long length​()
      返回底层文件的长度，如果未知，则返回 -1 。
      int read​()
      从流中读取一个字节，并将其作为 int和255之间的 int返回。
      int read​(byte[] b, int off, int len)
      读取到 len从流字节，并将其存储到 b开始于索引 off 。
      void seek​(long pos)
      将当前流位置设置为所需位置。

      • Methods inherited from class javax.imageio.stream.ImageInputStreamImpl

        checkClosed, flush, flushBefore, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileImageInputStream

        public FileImageInputStream​(File f)
                     throws FileNotFoundException,
                            IOException
        构造一个FileImageInputStream ，将从给定的File读取。

        文件内容不得在此对象构建时间与上一次调用read方法的时间之间发生变化。

        参数
        f - a File要阅读。
        异常
        IllegalArgumentException - 如果 f是 null 。
        SecurityException - 如果安全管理器存在并且不允许对该文件的读取访问。
        FileNotFoundException - 如果 f是一个目录或由于任何其他原因无法打开阅读。
        IOException - 如果发生I / O错误。

      • FileImageInputStream

        public FileImageInputStream​(RandomAccessFile raf)
        构造一个FileImageInputStream ，它将从给定的RandomAccessFile读取。

        文件内容不得在此对象构建时间与上一次调用read方法的时间之间发生变化。

        参数
        raf - a RandomAccessFile要阅读。
        异常
        IllegalArgumentException - 如果 raf是 null 。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        描述从类复制： ImageInputStreamImpl
        从流中读取一个字节，并将其作为int返回，从0到255之间。如果达到EOF，则返回-1 。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        在发生读取之前，流内的位偏移必须重置为零。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read在 ImageInputStreamImpl
        结果
        流中下一个字节的值，如果达到EOF， -1 。
        异常
        IOException - 如果流已关闭。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        描述从类别复制： ImageInputStreamImpl
        从流中读取最多len个字节，并将其存储到b从索引off开始。 如果没有字节可以读取，因为已经到达流的末尾，则返回-1 。

        在发生读取之前，流内的位偏移必须重置为零。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        Specified by:
        read接口 ImageInputStream
        Specified by:
        read在 ImageInputStreamImpl
        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要读取的最大字节数。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        IOException - 如果发生I / O错误。

      • length

        public long length​()
        返回底层文件的长度，如果未知，则返回 -1 。
        Specified by:
        length在接口 ImageInputStream
        重写：
        length在 ImageInputStreamImpl
        结果
        文件长度为 long ，或 -1 。

      • seek

        public void seek​(long pos)
          throws IOException
        说明从界面ImageInputStream复制
        将当前流位置设置为所需位置。 下一次读取将发生在此位置。 位偏移设置为0。

        一个IndexOutOfBoundsException如果将被抛出pos比冲洗位置（如通过返回较小getflushedPosition ）。

        寻求文件结尾是合法的; 一个java.io.EOFException只有在执行读取时才会被抛出。

        Specified by:
        seek在接口 ImageInputStream
        重写：
        seek ImageInputStreamImpl
        参数
        pos - 包含所需文件指针位置的 long 。
        异常
        IOException - 如果发生任何其他I / O错误。

      • close

        public void close​()
           throws IOException
        描述从接口ImageInputStream复制
        关闭流。 尝试访问已关闭的流可能会导致IOException或不正确的行为。 调用此方法可能允许实现此接口的类释放与流相关联的资源，如内存，磁盘空间或文件描述符。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close接口 ImageInputStream
        重写：
        close在 ImageInputStreamImpl
        异常
        IOException - 如果发生I / O错误。

      • finalize

        @Deprecated(since="9")
protected void finalize​()
                 throws Throwable
        已过时。 finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用备用的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        在垃圾收集之前完成此对象。 调用close方法来关闭任何打开的输入源。 不应该从应用程序代码调用此方法。
        重写：
        finalize在 ImageInputStreamImpl
        异常
        Throwable - 如果在超类最终化期间发生错误。
        另请参见：
        WeakReference ， PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileImageOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Class FileImageOutputStream

  • java.lang.Object
    • javax.imageio.stream.ImageInputStreamImpl
      • javax.imageio.stream.ImageOutputStreamImpl
        • javax.imageio.stream.FileImageOutputStream
  • All Implemented Interfaces:
    Closeable ， DataInput ， DataOutput ， AutoCloseable ， ImageInputStream ， ImageOutputStream

    public class FileImageOutputStream
extends ImageOutputStreamImpl
    一个实现 ImageOutputStream将其输出直接写入一个 File或 RandomAccessFile 。

    • Field Summary

      • Fields inherited from class javax.imageio.stream.ImageInputStreamImpl

        bitOffset, byteOrder, flushedPos, streamPos

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileImageOutputStream​(File f)
      构造一个 FileImageOutputStream ，它将写入给定的 File 。
      FileImageOutputStream​(RandomAccessFile raf)
      构造一个 FileImageOutputStream ，它将写入给定的 RandomAccessFile 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      long length​()
      返回 -1L以表示该流具有未知长度。
      int read​()
      从流中读取一个字节，并将其作为 int在0到255之间返回。
      int read​(byte[] b, int off, int len)
      从流中读取最多 len个字节，并将其存储到 b ，索引号为 off 。
      void seek​(long pos)
      设置当前流位置，并将位偏移重置为0。
      void write​(byte[] b, int off, int len)
      在当前位置写入一串字节。
      void write​(int b)
      将当前位置的单个字节写入流。

      • Methods inherited from interface javax.imageio.stream.ImageInputStream

        flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from class javax.imageio.stream.ImageInputStreamImpl

        checkClosed, flush, flushBefore, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from interface javax.imageio.stream.ImageOutputStream

        flushBefore

      • Methods inherited from class javax.imageio.stream.ImageOutputStreamImpl

        flushBits, write, writeBit, writeBits, writeBoolean, writeByte, writeBytes, writeChar, writeChars, writeChars, writeDouble, writeDoubles, writeFloat, writeFloats, writeInt, writeInts, writeLong, writeLongs, writeShort, writeShorts, writeUTF

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileImageOutputStream

        public FileImageOutputStream​(File f)
                      throws FileNotFoundException,
                             IOException
        构造一个 FileImageOutputStream ，它将写入给定的 File 。
        参数
        f - a File要写信。
        异常
        IllegalArgumentException - 如果 f是 null 。
        SecurityException - 如果安全管理器存在并且不允许对该文件的写入访问。
        FileNotFoundException - 如果 f不表示常规文件，或者由于任何其他原因无法打开阅读和写入。
        IOException - 如果发生I / O错误。

      • FileImageOutputStream

        public FileImageOutputStream​(RandomAccessFile raf)
        构造一个 FileImageOutputStream ，它将写入给定的 RandomAccessFile 。
        参数
        raf - a RandomAccessFile要写信。
        异常
        IllegalArgumentException - 如果 raf是 null 。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        描述从类复制： ImageInputStreamImpl
        从该流读取单个字节，并返回它作为一个int 0到255，并且如果达到EOF， -1被返回。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        在发生读取之前，流内的位偏移必须重置为零。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read在 ImageInputStreamImpl
        结果
        流中下一个字节的值，如果达到EOF， -1 。
        异常
        IOException - 如果流已关闭。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        描述从类复制： ImageInputStreamImpl
        从流中读取最多len个字节，并将其存储到b ，索引号为off 。 如果没有读取字节，因为已经到达流的末尾，则返回-1 。

        在发生读取之前，流内的位偏移必须重置为零。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read在 ImageInputStreamImpl
        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要读取的最大字节数。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(int b)
           throws IOException
        描述从接口ImageOutputStream复制
        将当前位置的单个字节写入流。 忽略了b的24个高位。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        Specified by:
        write接口 ImageOutputStream
        Specified by:
        write在 ImageOutputStreamImpl
        参数
        b - 要写入低8位的 int 。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        说明从界面ImageOutputStream复制
        在当前位置写入一串字节。 如果len为0， len写任何内容。 字节b[off]先写，然后字节b[off + 1]等等。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        Specified by:
        write接口 ImageOutputStream
        Specified by:
        write在 ImageOutputStreamImpl
        参数
        b - 要写入的 byte的数组。
        off - 数据中的起始偏移量。
        len - byte的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • length

        public long length​()
        描述从类复制： ImageInputStreamImpl
        返回-1L以表示该流具有未知长度。 子类必须覆盖此方法以提供实际的长度信息。
        Specified by:
        length在接口 ImageInputStream
        重写：
        length在 ImageInputStreamImpl
        结果
        -1L表示未知长度。

      • seek

        public void seek​(long pos)
          throws IOException
        设置当前流位置，并将位偏移量重置为0.找到文件末尾是合法的; 一个EOFException只有在执行读取时才会被抛出。 在执行写入之前，文件长度不会增加。
        Specified by:
        seek在接口 ImageInputStream
        重写：
        seek在 ImageInputStreamImpl
        参数
        pos - 包含所需文件指针位置的 long 。
        异常
        IndexOutOfBoundsException - 如果 pos小于冲洗位置。
        IOException - 如果发生任何其他I / O错误。

      • close

        public void close​()
           throws IOException
        说明从界面ImageInputStream复制
        关闭流。 尝试访问已关闭的流可能会导致IOException或错误的行为。 调用此方法可能允许实现此接口的类释放与流相关联的资源，如内存，磁盘空间或文件描述符。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在接口 ImageInputStream
        重写：
        close在 ImageInputStreamImpl
        异常
        IOException - 如果发生I / O错误。

      • finalize

        @Deprecated(since="9")
protected void finalize​()
                 throws Throwable
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按super.finalize()所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        在垃圾收集之前完成此对象。 调用close方法来关闭任何打开的输入源。 不应该从应用程序代码调用此方法。
        重写：
        finalize在 ImageInputStreamImpl
        异常
        Throwable - 如果超类最终化期间发生错误。
        另请参见：
        WeakReference ， PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IIOByteBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Class IIOByteBuffer

  • java.lang.Object
    • javax.imageio.stream.IIOByteBuffer

  • public class IIOByteBuffer
extends Object
    表示对字节数组的可变引用以及该数组中的偏移量和长度的类。 IIOByteBuffer使用ImageInputStream向调用者提供一系列字节，与使用用户提供的字节数组的常规read方法相比，副本可能更少。

    由IIOByteBuffer引用的字节数组通常是属于ImageReader实现的内部数据结构的ImageReader ; 其内容应视为只读，不得修改。

    • 构造方法摘要

      构造方法
      Constructor 描述
      IIOByteBuffer​(byte[] data, int offset, int length)
      构造引用给定字节数组，偏移量和长度的 IIOByteBuffer 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getData​()
      返回对字节数组的引用。
      int getLength​()
      返回由 getData返回的字节数组内的感兴趣的数据的长度。
      int getOffset​()
      返回由 getData的数据开始的 getData返回的字节数组内的偏移量。
      void setData​(byte[] data)
      更新将通过后续调用 getData方法返回的数组引用。
      void setLength​(int length)
      更新后续调用 getLength方法返回的值。
      void setOffset​(int offset)
      更新后续调用 getOffset方法返回的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IIOByteBuffer

        public IIOByteBuffer​(byte[] data,
                     int offset,
                     int length)
        构造引用给定字节数组，偏移量和长度的 IIOByteBuffer 。
        参数
        data - 一个字节数组。
        offset - 数组中的int偏移量。
        length - 一个int指定字节数组内感兴趣数据的长度（以字节为单位）。

    • 方法详细信息

      • getData

        public byte[] getData​()
        返回对字节数组的引用。 返回的值应该被视为只读，并且只应使用getOffset和getLength的值指定的部分。
        结果
        一个字节数组引用。
        另请参见：
        getOffset() ，
getLength() ，
setData(byte[])

      • setData

        public void setData​(byte[] data)
        更新将通过后续调用 getData方法返回的数组引用。
        参数
        data - 包含新数据值的字节数组引用。
        另请参见：
        getData()

      • getOffset

        public int getOffset​()
        返回由 getData的数据开始的 getData返回的字节数组中的偏移量。
        结果
        一个int偏移量。
        另请参见：
        getData() ，
getLength() ，
setOffset(int)

      • setOffset

        public void setOffset​(int offset)
        更新后续调用 getOffset方法返回的值。
        参数
        offset - 一个包含新的偏移值的int。
        另请参见：
        getOffset()

      • getLength

        public int getLength​()
        返回由 getData返回的字节数组内的感兴趣的数据的长度。
        结果
        一个int长度。
        另请参见：
        getData() ，
getOffset() ，
setLength(int)

      • setLength

        public void setLength​(int length)
        更新后续调用 getLength方法返回的值。
        参数
        length - 一个包含新长度值的int。
        另请参见：
        getLength()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Interface ImageInputStream

  • All Superinterfaces:
    AutoCloseable ， Closeable ， DataInput
    All Known Subinterfaces:
    ImageOutputStream
    所有已知实现类：
    FileCacheImageInputStream ， FileCacheImageOutputStream ， FileImageInputStream ， FileImageOutputStream ， ImageInputStreamImpl ， ImageOutputStreamImpl ， MemoryCacheImageInputStream ， MemoryCacheImageOutputStream

    public interface ImageInputStream
extends DataInput, Closeable
    一个可寻求的输入流接口，供ImageReader使用。 诸如InputStream和File的各种输入源以及将来的快速I / O源可以被该接口的适当实现“包装”以供图像I / O API使用。
    另请参见：
    ImageInputStreamImpl ， FileImageInputStream ， FileCacheImageInputStream ， MemoryCacheImageInputStream

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭流。
      void flush​()
      在当前流位置之前丢弃流的初始位置。
      void flushBefore​(long pos)
      在指示的位置之前丢弃流的初始部分。
      int getBitOffset​()
      返回当前的位偏移量，为0到7之间的整数，包括0和7。
      ByteOrder getByteOrder​()
      作为 java.nio.ByteOrder枚举的一个实例，返回从该流读取数据值的字节顺序。
      long getFlushedPosition​()
      返回可以执行搜索的流中的最早位置。
      long getStreamPosition​()
      返回流的当前字节位置。
      boolean isCached​()
      返回 true如果这个 ImageInputStream缓存数据本身以允许向后搜索。
      boolean isCachedFile​()
      返回 true如果这个 ImageInputStream缓存数据本身以允许向后搜索，并且高速缓存保存在临时文件中。
      boolean isCachedMemory​()
      返回 true如果这个 ImageInputStream缓存数据本身以允许向后搜索，并且高速缓存保存在主内存中。
      long length​()
      如果已知，返回流的总长度。
      void mark​()
      在流中标记要通过后续调用返回到 reset 。
      int read​()
      从流中读取一个字节，并将其作为0到255之间的整数返回。
      int read​(byte[] b)
      从流中读取最多 b.length个字节，并将其从索引0开始存储到 b 。
      int read​(byte[] b, int off, int len)
      读取到 len从流字节，并将其存储到 b开始于索引 off 。
      int readBit​()
      从流中读取一位，并将其作为 int返回，值为 0或 1 。
      long readBits​(int numBits)
      从流读取一个bitstring，并将其作为 long返回，第一位读取成为输出的最高有效位。
      boolean readBoolean​()
      从该流读取一个字节，并返回一个 boolean的值 true ，如果它是非零， false ，如果它是零。
      byte readByte​()
      从流中读取一个字节，并将其作为 byte值返回。
      void readBytes​(IIOByteBuffer buf, int len)
      从流中读取最多 len个字节，并修改提供的 IIOByteBuffer以指示可能找到数据的字节数组，偏移量和长度。
      char readChar​()
      相当于 readUnsignedShort ，除了使用 char数据类型返回结果。
      double readDouble​()
      从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 double返回。
      float readFloat​()
      从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 float返回。
      void readFully​(byte[] b)
      从流中读取 b.length个字节，并将其存储到 b从索引 0开始。
      void readFully​(byte[] b, int off, int len)
      从流中读取 len个字节，并将其存储到 b ，索引号为 off 。
      void readFully​(char[] c, int off, int len)
      读取 len从根据当前字节顺序的流字符（无符号的16位整数），并将其存储到 c开始于索引 off 。
      void readFully​(double[] d, int off, int len)
      读取 len根据当前字节顺序从流双打（64位IEEE双精度浮点值），并且将它们存储到 d开始于索引 off 。
      void readFully​(float[] f, int off, int len)
      读取 len根据当前字节顺序从流浮标（32位IEEE单精度浮点值），并且将它们存储到 f开始于索引 off 。
      void readFully​(int[] i, int off, int len)
      读取 len从根据当前字节顺序的流整数（带符号的32位整数），并将其存储到 i开始于索引 off 。
      void readFully​(long[] l, int off, int len)
      读取 len从根据当前字节顺序的流long（有符号的64位整数），并将其存储到 l开始于索引 off 。
      void readFully​(short[] s, int off, int len)
      读取 len从根据当前字节顺序的流短裤（带符号的16位整数），并将其存储到 s开始于索引 off 。
      int readInt​()
      从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 int返回。
      String readLine​()
      从输入流读取下一行文本。
      long readLong​()
      从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 long返回。
      short readShort​()
      从流中读取两个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 short值返回。
      int readUnsignedByte​()
      从流中读取一个字节，并从概念 0xff其转换为int，用 0xff对其进行 0xff ，以剥离任何符号扩展位，并将其作为 byte返回。
      long readUnsignedInt​()
      从流读取4个字节，（在概念上）根据当前字节顺序连接它们，将结果转换为长，将其用 0xffffffffL屏蔽，以剥离任何符号扩展位，并将结果作为无符号返回 long值。
      int readUnsignedShort​()
      从流中读取两个字节，并且（在概念上）根据当前字节顺序连接它们，将结果值转换为 int ，用 0xffff进行掩码，以剥离任何符号扩展名，并将结果作为无符号返回 int价值。
      String readUTF​()
      读取已使用 modified UTF-8格式编码的字符串。
      void reset​()
      在最近不匹配的调用 mark时，将流指针返回到之前的位置，包括位偏移。
      void seek​(long pos)
      将当前流位置设置为所需位置。
      void setBitOffset​(int bitOffset)
      将位偏移设置为0到7之间的整数，包括0和7。
      void setByteOrder​(ByteOrder byteOrder)
      设置用于将来从该流读取数据值的字节顺序。
      int skipBytes​(int n)
      将流位置向前移动给定的字节数。
      long skipBytes​(long n)
      将流位置向前移动给定的字节数。

    • 方法详细信息

      • setByteOrder

        void setByteOrder​(ByteOrder byteOrder)
        设置用于将来从该流读取数据值的字节顺序。 例如，如果以4字节整数读取，字节“0x01 0x02 0x03 0x04”的序列将以反向字节顺序使用网络字节顺序，值为“0x04030201”。

        枚举类java.nio.ByteOrder用于指定字节顺序。 值ByteOrder.BIG_ENDIAN指定所谓的大端或网元字节顺序，其中高位字节先到。 摩托罗拉和Sparc处理器以这种格式存储数据，而英特尔处理器ByteOrder.LITTLE_ENDIAN顺序存储数据。

        字节顺序对从readBits方法返回的结果（或由ImageOutputStream.writeBits写的值）没有影响。

        参数
        byteOrder - ByteOrder.BIG_ENDIAN或 java.nio.ByteOrder.LITTLE_ENDIAN ，表示网络字节顺序或其反向将用于将来读取。
        另请参见：
        ByteOrder ， getByteOrder() ， readBits(int)

      • getByteOrder

        ByteOrder getByteOrder​()
        作为 java.nio.ByteOrder枚举的一个实例，返回从该流读取数据值的字节顺序。
        结果
        一个 ByteOrder.BIG_ENDIAN或 ByteOrder.LITTLE_ENDIAN ，指示正在使用哪个字节顺序。
        另请参见：
        ByteOrder ， setByteOrder(java.nio.ByteOrder)

      • read

        int read​()
  throws IOException
        从流读取单个字节，并将其作为0到255之间的整数返回。如果到达流的结尾，则返回-1。

        在发生读取之前，流内的位偏移被重置为零。

        结果
        来自流的字节值，作为int，或-1表示EOF。
        异常
        IOException - 如果发生I / O错误。

      • read

        int read​(byte[] b)
  throws IOException
        从流中读取最多b.length个字节，并将其存储到从索引0开始的b 。返回读取的字节数。 如果没有字节可以读取，因为已经到达流的结尾，则返回-1。

        在发生读取之前，流内的位偏移被重置为零。

        参数
        b - 要写入的字节数组。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        NullPointerException - 如果 b是 null 。
        IOException - 如果发生I / O错误。

      • read

        int read​(byte[] b,
         int off,
         int len)
  throws IOException
        读取到len从流字节，并将其存储到b开始于索引off 。 返回读取的字节数。 如果没有字节可以读取，因为已经到达流的末尾，则返回-1 。

        在发生读取之前，流内的位偏移被重置为零。

        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要阅读的最大数量为 byte 。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 off + len ，大于 b.length 。
        IOException - 如果发生I / O错误。

      • readBytes

        void readBytes​(IIOByteBuffer buf,
               int len)
        throws IOException
        从流中读取最多len个字节，并修改提供的IIOByteBuffer以指示可能找到数据的字节数组，偏移量和长度。 来电者不应该尝试修改在IIOByteBuffer找到的数据。

        在发生读取之前，流内的位偏移被重置为零。

        参数
        buf - 要修改的IIOByteBuffer对象。
        len - 要阅读的最大数量 byte 。
        异常
        IndexOutOfBoundsException - 如果 len为负数。
        NullPointerException - 如果 buf是 null 。
        IOException - 如果发生I / O错误。

      • readBoolean

        boolean readBoolean​()
             throws IOException
        从该流读取一个字节，并返回一个boolean的值true ，如果它是非零， false ，如果它是零。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readBoolean在接口 DataInput
        结果
        来自流的布尔值。
        异常
        EOFException - 如果到达流的末尾。
        IOException - 如果发生I / O错误。

      • readByte

        byte readByte​()
       throws IOException
        从流中读取一个字节，并将其作为byte值返回。 0x00和0x7f之间的字节值表示0和127之间的整数值。 0x80和0xff之间的值代表从-128到/1 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readByte在接口 DataInput
        结果
        来自流的有符号字节值。
        异常
        EOFException - 如果达到流的结尾。
        IOException - 如果发生I / O错误。

      • readUnsignedByte

        int readUnsignedByte​()
              throws IOException
        从流中读取一个字节，（在概念上）将其转换为int，使用0xff屏蔽它，以便剥离任何符号扩展位，并将其作为byte值返回。

        因此， 0x00和0x7f之间的字节值只是作为0和127之间的整数值返回。 0x80和0xff之间的值通常表示负byte值，将映射到128和255之间的正整数。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readUnsignedByte在接口 DataInput
        结果
        来自流的无符号字节值。
        异常
        EOFException - 如果达到流的结尾。
        IOException - 如果发生I / O错误。

      • readShort

        short readShort​()
         throws IOException
        从流中读取两个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为short值返回。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readShort接口 DataInput
        结果
        从流中签名的短值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        getByteOrder()

      • readUnsignedShort

        int readUnsignedShort​()
               throws IOException
        从流中读取两个字节，并且（在概念上）根据当前字节顺序连接它们，将结果值转换为int ，使用0xffff屏蔽它，以剥离任何符号扩展名，并将结果作为无符号返回价值int 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readUnsignedShort在接口 DataInput
        结果
        来自流的无符号短值，作为int。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        getByteOrder()

      • readChar

        char readChar​()
       throws IOException
        相当于readUnsignedShort ，除了使用char数据类型返回结果。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readChar在接口 DataInput
        结果
        来自流的无符号字符值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        readUnsignedShort()

      • readInt

        int readInt​()
     throws IOException
        读取4个字节从该流，并根据当前字节顺序（概念上）将其连接并返回其结果作为int 。

        流内的位偏移被忽略，并被视为零。

        Specified by:
        readInt在接口 DataInput
        结果
        来自流的已签名的int值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        getByteOrder()

      • readUnsignedInt

        long readUnsignedInt​()
              throws IOException
        从流中读取4个字节，（从概念上讲）根据当前字节顺序连接它们，将结果转换为长时间，用0xffffffffL对其进行0xffffffffL ，以剥离任何符号扩展位，并将结果返回为无符号long值。

        在发生读取之前，流内的位偏移被重置为零。

        结果
        来自流的无符号int值，长久。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        getByteOrder()

      • readLong

        long readLong​()
       throws IOException
        从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为long返回。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readLong在接口 DataInput
        结果
        从流中签名的长值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        getByteOrder()

      • readFloat

        float readFloat​()
         throws IOException
        从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为float返回。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFloat在接口 DataInput
        结果
        来自流的浮点值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        getByteOrder()

      • readDouble

        double readDouble​()
           throws IOException
        从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为double返回。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readDouble在接口 DataInput
        结果
        来自流的双重值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        getByteOrder()

      • readLine

        String readLine​()
         throws IOException
        从输入流读取下一行文本。 它读取连续字节，将每个字节分别转换为字符，直到遇到行终止符或文件结尾; 读取的字符然后作为String返回。 请注意，由于此方法处理字节，它不支持输入完整的Unicode字符集。

        如果在甚至可以读取一个字节之前遇到文件结尾，则返回null 。 否则，读取的每个字节将通过零扩展转换为类型char 。 如果遇到字符'\n' ，则会被丢弃，读取停止。 如果遇到字符'\r' ，则会被丢弃，如果以下字节转换为字符'\n' ，那么也将被丢弃; 阅读然后停止。 如果在遇到任何一个字符'\n'和'\r'之前遇到文件结尾，则读取停止。 一旦读取停止，将返回String ，其中包含所有读取并且不被丢弃的字符。 请注意，此字符串中的每个字符都将具有小于\u0100的值，即(char)256 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readLine在接口 DataInput
        结果
        一个包含流中文本行的字符串。
        异常
        IOException - 如果发生I / O错误。

      • readUTF

        String readUTF​()
        throws IOException
        读取已使用modified UTF-8格式编码的字符串。 readUTF的一般合同是它读取以修改的UTF-8格式编码的Unicode字符串的表示; 这个字符串然后作为一个String返回。

        首先，使用网络字节顺序（无论当前字节顺序设置如何），以readUnsignedShort方式读取和使用两个字节构造无符号16位整数。 该整数值称为UTF长度，并指定要读取的其他字节数。 然后将这些字节通过组合考虑来转换为字符。 每组的长度根据组的第一个字节的值计算。 组之后的字节（如果有的话）是下一组的第一个字节。

        如果组的第一个字节与位模式0xxxxxxx （其中x表示“可能是0或1 ”） 1 ，那么该组由该字节组成。 该字节是零扩展形成一个字符。

        如果组的第一个字节与位模式110xxxxx匹配，则该组由该字节a和第二字节b 。 如果没有字节b （因为字节a是要读取的最后一个字节），或者如果字节b与位模式10xxxxxx不匹配，则抛出UTFDataFormatException 。 否则，该组将转换为字符：

           (char)(((a& 0x1F) << 6) | (b & 0x3F))
        如果一组的第一个字节与位模式1110xxxx匹配，则该组由该字节a和两个多个字节b和c 。 如果没有字节c （因为字节a是要读取的最后两个字节之一），或者字节b或字节c与位模式10xxxxxx不匹配，则抛出UTFDataFormatException 。 否则，该组将转换为字符：
           (char)(((a & 0x0F) << 12) | ((b & 0x3F) << 6) | (c & 0x3F))
        如果组的第一个字节与模式1111xxxx或模式10xxxxxx ，则抛出一个UTFDataFormatException 。

        如果在整个过程中随时遇到文件结尾，则抛出一个java.io.EOFException 。

        通过此过程将每个组转换为一个字符后，以与从输入流中读取相应组的顺序相同的方式收集字符，形成一个返回的String 。

        当前字节顺序设置被忽略。

        在发生读取之前，流内的位偏移被重置为零。

        注意：此方法不应用于执行使用标准UTF-8的图像格式，因为此处使用的修改后的UTF-8与标准UTF-8不兼容。

        Specified by:
        readUTF在接口 DataInput
        结果
        从流中读取的字符串。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        UTFDataFormatException - 如果字节不表示字符串的有效修改的UTF-8编码。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(byte[] b,
               int off,
               int len)
        throws IOException
        读取len从流字节，并将其存储到b开始于索引off 。 如果到达流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 DataInput
        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要阅读的最大数量 byte 。
        异常
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 off + len ，大于 b.length 。
        NullPointerException - 如果 b是 null 。
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(byte[] b)
        throws IOException
        读取b.length从流字节，并将其存储到b开始于索引0 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 DataInput
        参数
        b -的阵列 byte秒。
        异常
        NullPointerException - 如果 b是 null 。
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(short[] s,
               int off,
               int len)
        throws IOException
        读取len从根据当前字节顺序的流短裤（带符号的16位整数），并将其存储到s开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        参数
        s - 要写入的短裤阵列。
        off - 起始位置在 s内写。
        len - 要阅读的最大数量为 short 。
        异常
        IndexOutOfBoundsException - 如果 off为负， len为负数，或 off + len为大于 s.length 。
        NullPointerException - 如果 s是 null 。
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(char[] c,
               int off,
               int len)
        throws IOException
        读取len从根据当前字节顺序的流字符（无符号的16位整数），并将其存储到c开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        参数
        c - 要写入的字符数组。
        off - 起始位置在 c内写。
        len - 要阅读的最大数量 char 。
        异常
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 off + len ，大于 c.length 。
        NullPointerException - 如果 c是 null 。
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(int[] i,
               int off,
               int len)
        throws IOException
        读取len从根据当前字节顺序的流整数（带符号的32位整数），并将其存储到i开始于索引off 。 如果到达流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        参数
        i - 要写入的int数组。
        off - 起始位置在 i内写。
        len - 要阅读的最大数量 int 。
        异常
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 off + len ，大于 i.length 。
        NullPointerException - 如果 i是 null 。
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(long[] l,
               int off,
               int len)
        throws IOException
        读取len从根据当前字节顺序的流long（有符号的64位整数），并将其存储到l开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        参数
        l - 要写入的数组。
        off - 起始位置在 l内写。
        len - 要阅读的最大数量 long 。
        异常
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 off + len ，大于 l.length 。
        NullPointerException - 如果 l是 null 。
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(float[] f,
               int off,
               int len)
        throws IOException
        读取len根据当前字节顺序从流浮标（32位IEEE单精度浮点值），并且将它们存储到f开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        参数
        f - 要写入的浮点数组。
        off - 起始位置在 f内写。
        len - 要阅读的最大数量 float 。
        异常
        IndexOutOfBoundsException - 如果 off为负数， len为负数，或 off + len为大于 f.length 。
        NullPointerException - 如果 f是 null 。
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(double[] d,
               int off,
               int len)
        throws IOException
        读取len根据当前字节顺序从流双打（64位IEEE双精度浮点值），并且将它们存储到d开始于索引off 。 如果到达流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        参数
        d - 要写入的双精度数组。
        off - 起始位置在 d内写。
        len - 要阅读的最大数量 double 。
        异常
        IndexOutOfBoundsException - 如果 off为负数， len ，否则为 off + len ，大于 d.length 。
        NullPointerException - 如果 d是 null 。
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • getStreamPosition

        long getStreamPosition​()
                throws IOException
        返回流的当前字节位置。 下一次读取将从此偏移开始。
        结果
        一个长的包含流的位置。
        异常
        IOException - 如果发生I / O错误。

      • getBitOffset

        int getBitOffset​()
          throws IOException
        返回当前的位偏移量，为0到7之间的整数，包括0和7。 通过调用readBits方法隐式更新位偏移。 值为0表示最高有效位，值为7表示正在读取的字节的最低有效位。

        位偏移量被设置为0时，流被第一次打开，并且通过调用复位为0至seek ， skipBytes ，或任何read或readFully方法。

        结果
        一个 int包含0和7之间的位偏移量（包括0和7）。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        setBitOffset(int)

      • setBitOffset

        void setBitOffset​(int bitOffset)
           throws IOException
        将位偏移设置为0到7之间的整数，包括0和7。 由getStreamPosition返回的流内的字节偏移保持不变。 值为0表示最高有效位，值为7表示正在读取的字节的最低有效位。
        参数
        bitOffset - 所需的偏移量，为0和7之间的 int ，包括0和7。
        异常
        IllegalArgumentException - 如果 bitOffset不在0和7之间，包括0和7。
        IOException - 如果发生I / O错误。
        另请参见：
        getBitOffset()

      • readBit

        int readBit​()
     throws IOException
        从流中读取一位，并将其作为int返回，值为0或1 。 位偏移前进一并减少模8。
        结果
        一个 int包含值 0或 1 。
        异常
        EOFException - 如果流在读取所有位之前到达结束。
        IOException - 如果发生I / O错误。

      • readBits

        long readBits​(int numBits)
       throws IOException
        从流读取一个bitstring，并将其作为long返回，第一位读取成为输出的最高有效位。 读通过指定的字节内开始getStreamPosition ，在由给定的位getBitOffset 。 位偏移提前numBits并减少模8。

        流的字节顺序对此方法没有影响。 该方法的返回值被构造为一次读取一个位，并且移位到返回值的右侧，如以下伪代码所示：

           long accum = 0L; for (int i = 0; i < numBits; i++) { accum <<= 1; // Shift left one bit to make room accum |= readBit(); }
        需要注意的是的结果readBits(32)因此可以不等于的readInt() ，如果正在使用的反向网络字节顺序（即， getByteOrder() == false ）。

        如果在读取所有位之前遇到流的结尾，则抛出一个java.io.EOFException 。

        参数
        numBits - 要读取的位数，为0和64之间的 int （含）。
        结果
        bitstring，作为一个 long最后一位读取存储在最低有效位。
        异常
        IllegalArgumentException - 如果 numBits不在0和64之间，包括0和64之间。
        EOFException - 如果流在读取所有位之前到达结束。
        IOException - 如果发生I / O错误。

      • length

        long length​()
     throws IOException
        如果已知，返回流的总长度。 否则返回-1 。
        结果
        一个 long包含流的长度，如果知道，或者其他 -1 。
        异常
        IOException - 如果发生I / O错误。

      • skipBytes

        int skipBytes​(int n)
       throws IOException
        将流位置向前移动给定的字节数。 这种方法可能只能以比所请求的更少的字节向前跳过，例如，如果到达流的结尾。 在所有情况下，返回实际跳过的字节数。 位置偏移在前进位置之前设置为零。
        Specified by:
        skipBytes接口 DataInput
        参数
        n - 包含要跳过的字节数的 int 。
        结果
        一个表示跳过的字节数的 int 。
        异常
        IOException - 如果发生I / O错误。

      • skipBytes

        long skipBytes​(long n)
        throws IOException
        将流位置向前移动给定的字节数。 该方法与skipBytes(int)相同，只是允许较大的跳跃距离。
        参数
        n - 包含要跳过的字节数的 long 。
        结果
        一个 long代表跳过的字节数。
        异常
        IOException - 如果发生I / O错误。

      • seek

        void seek​(long pos)
   throws IOException
        将当前流位置设置为所需位置。 下一次读取将发生在此位置。 位偏移设置为0。

        一个IndexOutOfBoundsException如果将被抛出pos比冲洗位置（如通过返回较小getflushedPosition ）。

        寻求文件结尾是合法的; 一个java.io.EOFException只有在执行读取时才会抛出。

        参数
        pos - 一个包含所需文件指针位置的 long 。
        异常
        IndexOutOfBoundsException - 如果 pos小于冲洗位置。
        IOException - 如果发生任何其他I / O错误。

      • mark

        void mark​()
        在流中标记要通过后续调用返回到reset 。 与标准InputStream不同，所有ImageInputStream支持标记。 另外，可以任意调用mark和reset 。

        与Reader和InputStream接口声明的mark方法不同，不使用readLimit参数。 调用mark可能会读取任意数量的数据。

        readBits方法使用的位位置由mark和reset每对调用保存并恢复。

        请注意， ImageReader调用flushBefore作为读取操作的一部分是有效的。 因此，如果一个应用程序调用mark之前通过该流至ImageReader ，应用程序不应该假定标记的位置将保持有效的读操作完成后。

      • reset

        void reset​()
    throws IOException
        在最近不匹配的调用mark返回到其之前位置的流指针，包括位偏移量。

        拨打reset没有对应的电话对mark没有影响。

        如果先前标记的位置位于流的废弃部分，则将抛出IOException 。

        异常
        IOException - 如果发生I / O错误。

      • flushBefore

        void flushBefore​(long pos)
          throws IOException
        在指示的位置之前丢弃流的初始部分。 尝试寻求流的冲洗部分内的偏移量将导致一个IndexOutOfBoundsException 。

        调用flushBefore可能允许实现此接口的类释放用于存储流中的数据的资源（如内存或磁盘空间）。

        参数
        pos - 一个 long其中包含可能被刷新的流前缀的长度。
        异常
        IndexOutOfBoundsException - 如果 pos位于流的冲洗部分或超过当前流位置。
        IOException - 如果发生I / O错误。

      • flush

        void flush​()
    throws IOException
        在当前流位置之前丢弃流的初始位置。 相当于flushBefore(getStreamPosition()) 。
        异常
        IOException - 如果发生I / O错误。

      • getFlushedPosition

        long getFlushedPosition​()
        返回可以执行搜索的流中的最早位置。 返回的值将是传递到先前调用的所有值的最大值为flushBefore 。
        结果
        最早寻求法定职位，作为 long 。

      • isCached

        boolean isCached​()
        返回true如果这个ImageInputStream缓存数据本身，以允许向后搜索。 为了节省高速缓存资源，应用程序可以参考这一点，以确定刷新频率或是否进行刷新。
        结果
        true如果这个 ImageInputStream缓存数据。
        另请参见：
        isCachedMemory() ， isCachedFile()

      • isCachedMemory

        boolean isCachedMemory​()
        返回true如果这个ImageInputStream缓存数据本身，以便允许向后搜索，并且高速缓存保存在主内存中。 为了节省高速缓存资源，应用程序可以参考这一点，以确定刷新频率或是否进行刷新。
        结果
        true如果这个 ImageInputStream缓存数据在主内存中。
        另请参见：
        isCached() ， isCachedFile()

      • isCachedFile

        boolean isCachedFile​()
        返回true如果这个ImageInputStream缓存数据本身，以便允许向后搜索，并且高速缓存保存在临时文件中。 为了节省高速缓存资源，应用程序可以参考这一点，以确定刷新频率或是否进行刷新。
        结果
        true如果这个 ImageInputStream数据缓存在一个临时文件中。
        另请参见：
        isCached() ， isCachedMemory()

      • close

        void close​()
    throws IOException
        关闭流。 尝试访问已关闭的流可能会导致IOException或错误的行为。 调用此方法可能允许实现此接口的类释放与流相关联的资源，如内存，磁盘空间或文件描述符。
        Specified by:
        close接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageInputStreamImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Class ImageInputStreamImpl

  • java.lang.Object
    • javax.imageio.stream.ImageInputStreamImpl
  • All Implemented Interfaces:
    Closeable ， DataInput ， AutoCloseable ， ImageInputStream
    已知直接子类：
    FileCacheImageInputStream ， FileImageInputStream ， ImageOutputStreamImpl ， MemoryCacheImageInputStream

    public abstract class ImageInputStreamImpl
extends Object
implements ImageInputStream
    一个实现ImageInputStream接口的抽象类。 该类旨在减少子类必须实现的方法的数量。

    特别地，该类处理大部分或全部字节顺序解释，缓冲，标记/复位，丢弃，关闭和处理的细节。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int bitOffset
      流内的当前位偏移。
      protected ByteOrder byteOrder
      作为枚举类别 java.nio.ByteOrder的实例的流的字节顺序，其中 ByteOrder.BIG_ENDIAN指示网络字节顺序和 ByteOrder.LITTLE_ENDIAN表示相反的顺序。
      protected long flushedPos
      可以丢弃数据的位置。
      protected long streamPos
      流内当前读取的位置。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageInputStreamImpl​()
      构造一个 ImageInputStreamImpl 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      protected void checkClosed​()
      如果流已关闭，则抛出一个 IOException 。
      void close​()
      关闭流。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      void flush​()
      在当前流位置之前丢弃流的初始位置。
      void flushBefore​(long pos)
      在指示的位置之前丢弃流的初始部分。
      int getBitOffset​()
      返回当前的位偏移量，为0到7之间的整数，包括0和7。
      ByteOrder getByteOrder​()
      作为 java.nio.ByteOrder枚举的实例，返回从该流读取数据值的字节顺序。
      long getFlushedPosition​()
      返回可以执行搜索的流中的最早位置。
      long getStreamPosition​()
      返回流的当前字节位置。
      boolean isCached​()
      默认实现返回false。
      boolean isCachedFile​()
      默认实现返回false。
      boolean isCachedMemory​()
      默认实现返回false。
      long length​()
      返回 -1L以指示流长度不明确。
      void mark​()
      将当前流位置推送到标记位置的堆栈。
      abstract int read​()
      从流中读取一个字节，并将其作为 int和255之间的 int返回。
      int read​(byte[] b)
      一个方便的方法，调用 read(b, 0, b.length) 。
      abstract int read​(byte[] b, int off, int len)
      读取到 len从流字节，并将其存储到 b开始于索引 off 。
      int readBit​()
      从该流读取的单个比特，并返回它作为一个 int与值 0或 1 。
      long readBits​(int numBits)
      从流中读取bitstring并将其作为 long返回，第一位读取成为输出的最高有效位。
      boolean readBoolean​()
      从该流读取一个字节，并返回一个 boolean的值 true ，如果它是非零， false ，如果它是零。
      byte readByte​()
      从流中读取一个字节，并以 byte值返回。
      void readBytes​(IIOByteBuffer buf, int len)
      从流读取最多 len个字节，并修改提供的 IIOByteBuffer以指示可能找到数据的字节数组，偏移量和长度。
      char readChar​()
      相当于 readUnsignedShort ，除了使用 char数据类型返回结果。
      double readDouble​()
      从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 double返回。
      float readFloat​()
      从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 float返回。
      void readFully​(byte[] b)
      读取 b.length从流字节，并将其存储到 b开始于索引 0 。
      void readFully​(byte[] b, int off, int len)
      读取 len从流字节，并将其存储到 b开始于索引 off 。
      void readFully​(char[] c, int off, int len)
      读取 len从根据当前字节顺序的流字符（无符号的16位整数），并将其存储到 c开始于索引 off 。
      void readFully​(double[] d, int off, int len)
      读取 len根据当前字节顺序从流双打（64位IEEE双精度浮点值），并且将它们存储到 d开始于索引 off 。
      void readFully​(float[] f, int off, int len)
      读取 len根据当前字节顺序从流浮标（32位IEEE单精度浮点值），并且将它们存储到 f开始于索引 off 。
      void readFully​(int[] i, int off, int len)
      读取 len从根据当前字节顺序的流整数（带符号的32位整数），并将其存储到 i开始于索引 off 。
      void readFully​(long[] l, int off, int len)
      读取 len从根据当前字节顺序的流long（有符号的64位整数），并将其存储到 l开始于索引 off 。
      void readFully​(short[] s, int off, int len)
      读取 len从根据当前字节顺序的流短裤（带符号的16位整数），并将其存储到 s开始于索引 off 。
      int readInt​()
      从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 int返回。
      String readLine​()
      从输入流读取下一行文本。
      long readLong​()
      从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 long返回。
      short readShort​()
      从流中读取两个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 short值返回。
      int readUnsignedByte​()
      从流中读取一个字节，并且（在概念上）将其转换为int，使用 0xff对其进行 0xff ，以便剥离任何符号扩展位，并将其作为 byte值返回。
      long readUnsignedInt​()
      从流中读取4个字节，（概念上）根据当前字节顺序连接它们，将结果转换为长时间，将其用 0xffffffffL屏蔽，以剥离任何符号扩展位，并将结果作为无符号返回 long值。
      int readUnsignedShort​()
      从流中读取两个字节，（在概念上）根据当前字节顺序连接它们，将结果值转换为 int ，使用 0xffff屏蔽它，以便剥离任何符号扩展名，并将结果作为无符号返回价值 int 。
      String readUTF​()
      读取已使用 modified UTF-8格式编码的字符串。
      void reset​()
      从标记位置的堆栈中重置当前流字节和位位置。
      void seek​(long pos)
      将当前流位置设置为所需位置。
      void setBitOffset​(int bitOffset)
      将位偏移设置为0到7之间的整数，包括0和7。
      void setByteOrder​(ByteOrder byteOrder)
      设置用于将来从该流读取数据值的字节顺序。
      int skipBytes​(int n)
      通过致电 seek(getStreamPosition() + n)当前的流位置。
      long skipBytes​(long n)
      通过致电 seek(getStreamPosition() + n)前进当前流位置。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • byteOrder

        protected ByteOrder byteOrder
        作为枚举类别java.nio.ByteOrder的实例的流的字节顺序，其中ByteOrder.BIG_ENDIAN表示网络字节顺序和ByteOrder.LITTLE_ENDIAN表示相反的顺序。 默认值为ByteOrder.BIG_ENDIAN 。

      • streamPos

        protected long streamPos
        流内当前读取的位置。 子类负责将此值保留为任何改写读取位置的方法。

      • bitOffset

        protected int bitOffset
        流内的当前位偏移。 子类负责保持这个值的最新值，它们覆盖改变位偏移的任何方法。

      • flushedPos

        protected long flushedPos
        可以丢弃数据的位置。 寻求更小的位置是不允许的。 flushedPos将始终为> = 0。

    • 构造方法详细信息

      • ImageInputStreamImpl

        public ImageInputStreamImpl​()
        构造一个 ImageInputStreamImpl 。

    • 方法详细信息

      • checkClosed

        protected final void checkClosed​()
                          throws IOException
        如果流已关闭，则抛出一个IOException 。 子类可以从需要流不被关闭的任何方法调用此方法。
        异常
        IOException - 如果流关闭。

      • setByteOrder

        public void setByteOrder​(ByteOrder byteOrder)
        描述从接口ImageInputStream复制
        设置用于将来从该流读取数据值的字节顺序。 例如，如果以4字节整数读取，字节“0x01 0x02 0x03 0x04”的序列将以反向字节顺序使用网络字节顺序，值为“0x04030201”。

        枚举类java.nio.ByteOrder用于指定字节顺序。 值为ByteOrder.BIG_ENDIAN指定所谓的大端或网络字节顺序，其中高位字节首先出现。 摩托罗拉和Sparc处理器以这种格式存储数据，而英特尔处理器按照ByteOrder.LITTLE_ENDIAN顺序存储数据。

        字节顺序对从readBits方法返回的结果（或由ImageOutputStream.writeBits编写的值）没有影响。

        Specified by:
        setByteOrder在接口 ImageInputStream
        参数
        byteOrder - ByteOrder.BIG_ENDIAN或 java.nio.ByteOrder.LITTLE_ENDIAN ，表示网络字节顺序或其反向将用于将来读取。
        另请参见：
        ByteOrder ， ImageInputStream.getByteOrder() ， ImageInputStream.readBits(int)

      • getByteOrder

        public ByteOrder getByteOrder​()
        描述从接口ImageInputStream复制
        作为 java.nio.ByteOrder枚举的实例，返回从该流读取数据值的字节顺序。
        Specified by:
        getByteOrder在接口 ImageInputStream
        结果
        一个 ByteOrder.BIG_ENDIAN或 ByteOrder.LITTLE_ENDIAN ，指示正在使用哪个字节顺序。
        另请参见：
        ByteOrder ， ImageInputStream.setByteOrder(java.nio.ByteOrder)

      • read

        public abstract int read​()
                  throws IOException
        从流中读取一个字节，并将其作为int在0到255之间返回。如果达到EOF，则返回-1 。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        在发生读取之前，流内的位偏移必须重置为零。

        Specified by:
        read在接口 ImageInputStream
        结果
        流中下一个字节的值，如果达到EOF， -1 。
        异常
        IOException - 如果流已关闭。

      • read

        public int read​(byte[] b)
         throws IOException
        一个方便的方法，调用read(b, 0, b.length) 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        read在接口 ImageInputStream
        参数
        b - 要写入的字节数组。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        NullPointerException - 如果 b是 null 。
        IOException - 如果发生I / O错误。

      • read

        public abstract int read​(byte[] b,
                         int off,
                         int len)
                  throws IOException
        从流中读取最多len个字节，并将其存储到b ，索引号为off 。 如果没有字节可以读取，因为已经到达流的末尾，则返回-1 。

        在发生读取之前，流内的位偏移必须重置为零。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        Specified by:
        read接口 ImageInputStream
        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要读取的最大字节数。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        IndexOutOfBoundsException - 如果 off为负数， len为负数，或 off + len大于 b.length 。
        NullPointerException - 如果 b是 null 。
        IOException - 如果发生I / O错误。

      • readBytes

        public void readBytes​(IIOByteBuffer buf,
                      int len)
               throws IOException
        描述从接口ImageInputStream复制
        从流中读取最多len个字节，并修改提供的IIOByteBuffer以指示可能找到数据的字节数组，偏移量和长度。 来电者不应该尝试修改在IIOByteBuffer找到的数据。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readBytes在接口 ImageInputStream
        参数
        buf - 要修改的IIOByteBuffer对象。
        len - 要阅读的最大数量 byte 。
        异常
        IOException - 如果发生I / O错误。

      • readBoolean

        public boolean readBoolean​()
                    throws IOException
        描述从接口ImageInputStream复制
        从该流读取一个字节，并返回一个boolean的值true ，如果它是非零， false ，如果它是零。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readBoolean在接口 DataInput
        Specified by:
        readBoolean在接口 ImageInputStream
        结果
        来自流的布尔值。
        异常
        EOFException - 如果到达流的末尾。
        IOException - 如果发生I / O错误。

      • readByte

        public byte readByte​()
              throws IOException
        描述从接口ImageInputStream复制
        从流中读取一个字节，并将其作为byte值返回。 0x00和0x7f之间的字节值表示0和127之间的整数值。 0x80和0xff之间的值代表从-128到/1 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readByte在接口 DataInput
        Specified by:
        readByte在接口 ImageInputStream
        结果
        来自流的有符号字节值。
        异常
        EOFException - 如果到达流的末尾。
        IOException - 如果发生I / O错误。

      • readUnsignedByte

        public int readUnsignedByte​()
                     throws IOException
        说明从界面： ImageInputStream复制
        从流读取一个字节，（在概念上）将其转换为int，用0xff对其进行0xff ，以剥离任何符号扩展位，并将其作为byte值返回。

        因此， 0x00和0x7f之间的字节值仅作为0和127之间的整数值返回。 0x80和0xff之间的值通常表示负byte值，将映射到128和255之间的正整数。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readUnsignedByte在接口 DataInput
        Specified by:
        readUnsignedByte在接口 ImageInputStream
        结果
        来自流的无符号字节值。
        异常
        EOFException - 如果到达流的末尾。
        IOException - 如果发生I / O错误。

      • readShort

        public short readShort​()
                throws IOException
        描述从接口ImageInputStream复制
        从流读取两个字节，（概念上）根据当前字节顺序连接它们，并将结果作为short返回。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readShort在接口 DataInput
        Specified by:
        readShort在接口 ImageInputStream
        结果
        从流中签名的短值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.getByteOrder()

      • readUnsignedShort

        public int readUnsignedShort​()
                      throws IOException
        描述从接口ImageInputStream复制
        从流中读取两个字节，（在概念上）根据当前字节顺序连接它们，将结果值转换为int ，使用0xffff屏蔽它，以剥离任何符号扩展名，并将结果作为无符号返回价值int 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readUnsignedShort在接口 DataInput
        Specified by:
        readUnsignedShort在接口 ImageInputStream
        结果
        来自流的无符号短值，作为int。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.getByteOrder()

      • readChar

        public char readChar​()
              throws IOException
        描述从接口ImageInputStream复制
        相当于readUnsignedShort ，除了使用char数据类型返回结果。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readChar在接口 DataInput
        Specified by:
        readChar在接口 ImageInputStream
        结果
        来自流的无符号字符值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.readUnsignedShort()

      • readInt

        public int readInt​()
            throws IOException
        说明从接口ImageInputStream复制
        从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为int返回。

        流内的位偏移被忽略，并被视为零。

        Specified by:
        readInt在接口 DataInput
        Specified by:
        readInt接口 ImageInputStream
        结果
        来自流的已签名的int值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.getByteOrder()

      • readUnsignedInt

        public long readUnsignedInt​()
                     throws IOException
        描述从接口ImageInputStream复制
        从流中读取4个字节，并且（在概念上）根据当前字节顺序连接它们，将结果转换为长，将其用0xffffffffL ，以便剥离任何符号扩展位，并将结果作为无符号的long返回值。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readUnsignedInt在接口 ImageInputStream
        结果
        来自流的无符号int值，长久。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.getByteOrder()

      • readLong

        public long readLong​()
              throws IOException
        描述从接口ImageInputStream复制
        从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为long返回。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readLong在接口 DataInput
        Specified by:
        readLong在接口 ImageInputStream
        结果
        从流中签名的长值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.getByteOrder()

      • readFloat

        public float readFloat​()
                throws IOException
        描述从接口ImageInputStream复制
        从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为float返回。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFloat在接口 DataInput
        Specified by:
        readFloat在接口 ImageInputStream
        结果
        来自流的浮点值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.getByteOrder()

      • readDouble

        public double readDouble​()
                  throws IOException
        描述从接口ImageInputStream复制
        从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为double返回。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readDouble在接口 DataInput
        Specified by:
        readDouble在接口 ImageInputStream
        结果
        来自流的双重值。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.getByteOrder()

      • readLine

        public String readLine​()
                throws IOException
        描述从接口ImageInputStream复制
        从输入流读取下一行文本。 它读取连续字节，将每个字节分别转换为字符，直到遇到行终止符或文件结尾; 读取的字符然后作为String返回。 请注意，由于此方法处理字节，它不支持输入完整的Unicode字符集。

        如果在甚至可以读取一个字节之前遇到文件结束，则返回null 。 否则，读取的每个字节将通过零扩展转换为类型char 。 如果遇到字符'\n' ，则会被丢弃，读取停止。 如果遇到字符'\r' ，则将其丢弃，如果以下字节转换为字符'\n' ，则也将被丢弃; 阅读然后停止。 如果在遇到任何一个字符'\n'和'\r'之前遇到文件结尾，则读取停止。 一旦读取停止，将返回一个String ，其中包含读取并且不被丢弃的所有字符。 请注意，此字符串中的每个字符都将具有小于\u0100的值，即(char)256 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readLine在接口 DataInput
        Specified by:
        readLine在接口 ImageInputStream
        结果
        一个包含流中文本行的字符串。
        异常
        IOException - 如果发生I / O错误。

      • readUTF

        public String readUTF​()
               throws IOException
        描述从接口ImageInputStream复制
        读取已使用modified UTF-8格式编码的字符串。 readUTF的一般合同是它读取以修改的UTF-8格式编码的Unicode字符串的表示; 这个字符串然后作为一个String返回。

        首先，使用网络字节顺序（无论当前字节顺序设置如何），以readUnsignedShort方式读取和使用两个字节构造无符号16位整数。 该整数值称为UTF长度，并指定要读取的其他字节数。 然后将这些字节通过组合考虑来转换为字符。 每组的长度根据组的第一个字节的值计算。 组之后的字节（如果有的话）是下一组的第一个字节。

        如果组的第一个字节与位模式0xxxxxxx （其中x表示“可能是0或1 ”） 1 ，那么该组仅由该字节组成。 该字节是零扩展形成一个字符。

        如果组的第一个字节与位模式110xxxxx匹配，则该组由该字节a和第二字节b 。 如果没有字节b （因为字节a是要读取的最后一个字节），或者如果字节b与位模式10xxxxxx不匹配，则抛出UTFDataFormatException 。 否则，该组将转换为字符：

           (char)(((a& 0x1F) << 6) | (b & 0x3F))
        如果组的第一个字节与位模式1110xxxx匹配，则组由该字节a和两个多个字节b和c 。 如果没有字节c （因为字节a是要读取的最后两个字节之一），或者字节b或字节c与位模式10xxxxxx不匹配，则抛出UTFDataFormatException 。 否则，该组将转换为字符：
           (char)(((a & 0x0F) << 12) | ((b & 0x3F) << 6) | (c & 0x3F))
        如果组的第一个字节与模式1111xxxx或模式10xxxxxx ，则抛出一个UTFDataFormatException 。

        如果在整个过程中随时遇到文件结尾，则抛出一个java.io.EOFException 。

        在通过此过程将每个组转换为字符后，以与输入流中读取相应组相同的顺序收集字符，形成返回的String 。

        当前字节顺序设置被忽略。

        在发生读取之前，流内的位偏移被重置为零。

        注意：此方法不应用于执行使用标准UTF-8的图像格式，因为此处使用的修改后的UTF-8与标准UTF-8不兼容。

        Specified by:
        readUTF在接口 DataInput
        Specified by:
        readUTF在接口 ImageInputStream
        结果
        从流中读取的字符串。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        UTFDataFormatException - 如果字节不表示字符串的有效修改的UTF-8编码。
        IOException - 如果发生I / O错误。

      • readFully

        public void readFully​(byte[] b,
                      int off,
                      int len)
               throws IOException
        描述从接口ImageInputStream复制
        从流中读取len个字节，并将其存储到b ，索引号为off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 DataInput
        Specified by:
        readFully在接口 ImageInputStream
        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要阅读的最大数量 byte 。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        public void readFully​(byte[] b)
               throws IOException
        说明从界面ImageInputStream复制
        读取b.length从流字节，并将其存储到b开始于索引0 。 如果到达流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 DataInput
        Specified by:
        readFully在接口 ImageInputStream
        参数
        b -的阵列 byte秒。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        public void readFully​(short[] s,
                      int off,
                      int len)
               throws IOException
        描述从接口ImageInputStream复制
        读取len从根据当前字节顺序的流短裤（带符号的16位整数），并将其存储到s开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 ImageInputStream
        参数
        s - 要写入的短裤阵列。
        off - 起始位置在 s内写。
        len - 要阅读的最大数量 short 。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        public void readFully​(char[] c,
                      int off,
                      int len)
               throws IOException
        描述从接口ImageInputStream复制
        读取len从根据当前字节顺序的流字符（无符号的16位整数），并将其存储到c开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 ImageInputStream
        参数
        c - 要写入的字符数组。
        off - 起始位置在 c内写。
        len - 要阅读的最大数量 char 。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        public void readFully​(int[] i,
                      int off,
                      int len)
               throws IOException
        说明从接口ImageInputStream复制
        读取len从根据当前字节顺序的流整数（带符号的32位整数），并将其存储到i开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 ImageInputStream
        参数
        i - 要写入的int数组。
        off - 起始位置在 i内写。
        len - 要阅读的最大数量 int 。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        public void readFully​(long[] l,
                      int off,
                      int len)
               throws IOException
        描述从接口ImageInputStream复制
        读取len从根据当前字节顺序的流long（有符号的64位整数），并将其存储到l开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 ImageInputStream
        参数
        l - 要写入的数组。
        off - 起始位置在 l内写。
        len - 要阅读的最大数量 long 。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        public void readFully​(float[] f,
                      int off,
                      int len)
               throws IOException
        描述从接口ImageInputStream复制
        读取len根据当前字节顺序从流浮标（32位IEEE单精度浮点值），并且将它们存储到f开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 ImageInputStream
        参数
        f - 要写入的浮点数组。
        off - 起始位置在 f内写。
        len - 要阅读的最大数量 float 。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        public void readFully​(double[] d,
                      int off,
                      int len)
               throws IOException
        描述从接口ImageInputStream复制
        读取len根据当前字节顺序从流双打（64位IEEE双精度浮点值），并且将它们存储到d开始于索引off 。 如果达到流的末尾，将抛出一个java.io.EOFException 。

        在发生读取之前，流内的位偏移被重置为零。

        Specified by:
        readFully在接口 ImageInputStream
        参数
        d - 要写入的双精度数组。
        off - 起始位置在 d内写。
        len - 要阅读的最大数量 double 。
        异常
        EOFException - 如果流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • getStreamPosition

        public long getStreamPosition​()
                       throws IOException
        描述从接口ImageInputStream复制
        返回流的当前字节位置。 下一次读取将从此偏移开始。
        Specified by:
        getStreamPosition在接口 ImageInputStream
        结果
        一个长的包含流的位置。
        异常
        IOException - 如果发生I / O错误。

      • getBitOffset

        public int getBitOffset​()
                 throws IOException
        描述从接口ImageInputStream复制
        返回当前的位偏移量，为0到7之间的整数，包括0和7。 通过调用readBits方法隐式更新位偏移。 值为0表示最高有效位，值为7表示正在读取的字节的最低有效位。

        位偏移量被设置为0时，流被第一次打开，并且通过调用复位为0至seek ， skipBytes ，或任何read或readFully方法。

        Specified by:
        getBitOffset在接口 ImageInputStream
        结果
        一个 int包含0到7之间的位偏移量，包括0和7。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.setBitOffset(int)

      • setBitOffset

        public void setBitOffset​(int bitOffset)
                  throws IOException
        描述从接口ImageInputStream复制
        将位偏移设置为0到7之间的整数，包括0和7。 由getStreamPosition返回的流内的字节偏移量保持不变。 值为0表示最高有效位，值为7表示正在读取的字节的最低有效位。
        Specified by:
        setBitOffset在接口 ImageInputStream
        参数
        bitOffset - 所需的偏移量，为0和7之间的 int ，包括0和7。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        ImageInputStream.getBitOffset()

      • readBit

        public int readBit​()
            throws IOException
        说明从接口ImageInputStream复制
        从流中读取一位，并将其作为int返回，值为0或1 。 位偏移前进一并减少模8。
        Specified by:
        readBit在接口 ImageInputStream
        结果
        一个 int ，其值包含 0或 1 。
        异常
        EOFException - 如果流在读取所有位之前到达结束。
        IOException - 如果发生I / O错误。

      • readBits

        public long readBits​(int numBits)
              throws IOException
        描述从接口ImageInputStream复制
        从流读取一个bitstring，并将其作为long返回，第一位读取成为输出的最高有效位。 读通过指定的字节内开始getStreamPosition ，在由给定的位getBitOffset 。 位偏移提前numBits并减少模8。

        流的字节顺序对此方法没有影响。 该方法的返回值被构造为一次读取一个位，并且移位到返回值的右侧，如以下伪代码所示：

           long accum = 0L; for (int i = 0; i < numBits; i++) { accum <<= 1; // Shift left one bit to make room accum |= readBit(); }
        需要注意的是的结果readBits(32)因此可以不等于的readInt() ，如果正在使用的反向网络字节顺序（即， getByteOrder() == false ）。

        如果在读取所有位之前遇到流的结尾，则抛出一个java.io.EOFException 。

        Specified by:
        readBits在接口 ImageInputStream
        参数
        numBits - 要读取的位数，为0和64之间的 int （含）。
        结果
        bitstring，作为一个 long最后一位读取存储在最低有效位。
        异常
        EOFException - 如果流在读取所有位之前到达结束。
        IOException - 如果发生I / O错误。

      • length

        public long length​()
        返回-1L以表示该流具有未知长度。 子类必须覆盖此方法以提供实际的长度信息。
        Specified by:
        length在接口 ImageInputStream
        结果
        -1L表示未知长度。

      • skipBytes

        public int skipBytes​(int n)
              throws IOException
        通过致电seek(getStreamPosition() + n)前进当前流位置。

        位偏移重置为零。

        Specified by:
        skipBytes在接口 DataInput
        Specified by:
        skipBytes在接口 ImageInputStream
        参数
        n - 要查找的字节数。
        结果
        一个表示跳过的字节数的 int 。
        异常
        IOException - 如果 getStreamPosition在计算起始位置或结束位置时抛出一个 IOException 。

      • skipBytes

        public long skipBytes​(long n)
               throws IOException
        通过致电seek(getStreamPosition() + n)当前的流位置。

        位偏移重置为零。

        Specified by:
        skipBytes在接口 ImageInputStream
        参数
        n - 要查找的字节数。
        结果
        一个 long表示跳过的字节数。
        异常
        IOException - 如果 getStreamPosition在计算起始位置或结束位置时抛出一个 IOException 。

      • seek

        public void seek​(long pos)
          throws IOException
        描述从接口ImageInputStream复制
        将当前流位置设置为所需位置。 下一次读取将发生在此位置。 位偏移设置为0。

        一个IndexOutOfBoundsException如果将被抛出pos比冲洗位置（如通过返回较小getflushedPosition ）。

        寻求文件结尾是合法的; 一个java.io.EOFException只有在执行读取时才会被抛出。

        Specified by:
        seek在接口 ImageInputStream
        参数
        pos - 一个包含所需文件指针位置的 long 。
        异常
        IOException - 如果发生任何其他I / O错误。

      • mark

        public void mark​()
        将当前流位置推送到标记位置的堆栈。
        Specified by:
        mark在接口 ImageInputStream

      • reset

        public void reset​()
           throws IOException
        从标记位置的堆栈中重置当前流字节和位位置。

        如果先前标记的位置位于流的废弃部分，则将抛出IOException 。

        Specified by:
        reset在接口 ImageInputStream
        异常
        IOException - 如果发生I / O错误。

      • flushBefore

        public void flushBefore​(long pos)
                 throws IOException
        描述从接口ImageInputStream复制
        在指示的位置之前丢弃流的初始部分。 试图寻求在流的冲洗部分内的偏移将导致一个IndexOutOfBoundsException 。

        调用flushBefore可能允许实现此接口的类释放用于从流中存储数据的资源（如内存或磁盘空间）。

        Specified by:
        flushBefore在接口 ImageInputStream
        参数
        pos - 一个 long其中包含可能被刷新的流前缀的长度。
        异常
        IOException - 如果发生I / O错误。

      • flush

        public void flush​()
           throws IOException
        说明从界面ImageInputStream复制
        在当前流位置之前丢弃流的初始位置。 相当于flushBefore(getStreamPosition()) 。
        Specified by:
        flush在接口 ImageInputStream
        异常
        IOException - 如果发生I / O错误。

      • getFlushedPosition

        public long getFlushedPosition​()
        说明从接口ImageInputStream复制
        返回可以执行搜索的流中的最早位置。 返回的值将是传递到先前调用的所有值的最大值为flushBefore 。
        Specified by:
        getFlushedPosition在接口 ImageInputStream
        结果
        最早寻求法定职位，作为 long 。

      • isCached

        public boolean isCached​()
        默认实现返回false。 如果子类缓存数据，子类应该重写。
        Specified by:
        isCached在接口 ImageInputStream
        结果
        true如果这个 ImageInputStream缓存数据。
        另请参见：
        ImageInputStream.isCachedMemory() ， ImageInputStream.isCachedFile()

      • isCachedMemory

        public boolean isCachedMemory​()
        默认实现返回false。 子类应该在主存中缓存数据时重写。
        Specified by:
        isCachedMemory在接口 ImageInputStream
        结果
        true如果这个 ImageInputStream缓存数据在主内存中。
        另请参见：
        ImageInputStream.isCached() ， ImageInputStream.isCachedFile()

      • isCachedFile

        public boolean isCachedFile​()
        默认实现返回false。 如果子类缓存临时文件中的数据，子类应该重写。
        Specified by:
        isCachedFile在接口 ImageInputStream
        结果
        true如果这个 ImageInputStream缓存数据在临时文件中。
        另请参见：
        ImageInputStream.isCached() ， ImageInputStream.isCachedMemory()

      • close

        public void close​()
           throws IOException
        描述从接口ImageInputStream复制
        关闭流。 尝试访问已关闭的流可能会导致IOException或错误的行为。 调用此方法可能允许实现此接口的类释放与流相关联的资源，如内存，磁盘空间或文件描述符。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在接口 ImageInputStream
        异常
        IOException - 如果发生I / O错误。

      • finalize

        @Deprecated(since="9")
protected void finalize​()
                 throws Throwable
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        在垃圾收集之前完成此对象。 调用close方法来关闭任何打开的输入源。 不应该从应用程序代码调用此方法。
        重写：
        finalize在 Object
        异常
        Throwable - 如果在超类最终化期间发生错误。
        另请参见：
        WeakReference ， PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


ImageOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Interface ImageOutputStream

  • All Superinterfaces:
    AutoCloseable ， Closeable ， DataInput ， DataOutput ， ImageInputStream
    所有已知实现类：
    FileCacheImageOutputStream ， FileImageOutputStream ， ImageOutputStreamImpl ， MemoryCacheImageOutputStream

    public interface ImageOutputStream
extends ImageInputStream, DataOutput
    一个可寻求的输出流接口，供ImageWriter使用。 诸如OutputStream和File的各种输出目的地以及未来的快速I / O目的地可能被该接口的适当实现“包裹”，以供Image I / O API使用。

    与标准OutputStream不同，ImageOutputStream扩展了其对应的ImageInputStream 。 因此，可以从流中读取它被写入。 尽管用于处理字节对齐写入之前的非零位偏移的语义必须与用于在字节对齐之前处理非零位偏移的语义不同，对齐阅读 当读取字节时，任何位偏移量在读取之前设置为0; 当写入字节时，非零位偏移使得该字节中的剩余位被写为0。 字节对齐的写入开始于下一个字节位置。

    另请参见：
    ImageInputStream

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void flushBefore​(long pos)
      将给定位置之前的所有数据刷新到基础目的地，例如 OutputStream或 File 。
      void write​(byte[] b)
      在当前位置写入一串字节。
      void write​(byte[] b, int off, int len)
      在当前位置写入一串字节。
      void write​(int b)
      将当前位置的单个字节写入流。
      void writeBit​(int bit)
      将由参数的最低有效位给出的单个位写入当前字节位置中当前位偏移量的流。
      void writeBits​(long bits, int numBits)
      将 bits参数的 numBits最低有效位（ bits的顺序）给出的位序列写入当前字节位置当前位偏移量的流。
      void writeBoolean​(boolean v)
      向流中写入一个 boolean值。
      void writeByte​(int v)
      将 v的8位低位写入流。
      void writeBytes​(String s)
      将一个字符串写入输出流。
      void writeChar​(int v)
      该方法是 writeShort的同义词。
      void writeChars​(char[] c, int off, int len)
      在当前位置将一串字符写入流。
      void writeChars​(String s)
      将一个字符串写入输出流。
      void writeDouble​(double v)
      向输出流写入一个由四个字节组成的 double值。
      void writeDoubles​(double[] d, int off, int len)
      将当前位置的一系列双精度写入流。
      void writeFloat​(float v)
      向输出流写入一个由四个字节组成的 float值。
      void writeFloats​(float[] f, int off, int len)
      在当前位置将一系列浮点写入流。
      void writeInt​(int v)
      将 v的32位写入流。
      void writeInts​(int[] i, int off, int len)
      在当前位置写入流的序列。
      void writeLong​(long v)
      将 v的64位写入流。
      void writeLongs​(long[] l, int off, int len)
      在当前位置写入流的序列。
      void writeShort​(int v)
      将 v的16位低位写入流。
      void writeShorts​(short[] s, int off, int len)
      在当前位置写入流的序列。
      void writeUTF​(String s)
      以网络字节顺序将两个字节的长度信息写入输出流，后跟字符串 s中每个字符的 modified UTF-8表示。

      • Methods inherited from interface javax.imageio.stream.ImageInputStream

        close, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, length, mark, read, read, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

    • 方法详细信息

      • write

        void write​(int b)
    throws IOException
        将当前位置的单个字节写入流。 忽略了b的24个高位。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        参数
        b - 要写入低8位的 int 。
        异常
        IOException - 如果发生I / O错误。

      • write

        void write​(byte[] b)
    throws IOException
        在当前位置写入一串字节。 如果b.length为0，则不会写入。 字节b[0]首先写入，然后字节b[1]等等。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        write在接口 DataOutput
        参数
        b - 要写入的 byte的数组。
        异常
        NullPointerException - 如果 b是 null 。
        IOException - 如果发生I / O错误。

      • write

        void write​(byte[] b,
           int off,
           int len)
    throws IOException
        在当前位置写入一串字节。 如果len为0，则不会写入。 首先写入字节b[off] ，然后字节b[off + 1]等等。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        参数
        b - 要写入的 byte的数组。
        off - 数据中的起始偏移量。
        len - byte的 len的数量。
        异常
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 off + len ，大于 b.length 。
        NullPointerException - 如果 b是 null 。
        IOException - 如果发生I / O错误。

      • writeBoolean

        void writeBoolean​(boolean v)
           throws IOException
        向流中写入一个boolean值。 如果v为真，则写入值(byte)1 ; 如果v为false，则写入值(byte)0 。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeBoolean在接口 DataOutput
        参数
        v - boolean 。
        异常
        IOException - 如果发生I / O错误。

      • writeByte

        void writeByte​(int v)
        throws IOException
        将v的8位低位写入流。 忽略了v的24个高位。 （这意味着writeByte与整数参数的作用完全一样） write ）

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeByte在接口 DataOutput
        参数
        v - 包含要写入的字节值的 int 。
        异常
        IOException - 如果发生I / O错误。

      • writeShort

        void writeShort​(int v)
         throws IOException
        将v的16位低位写入流。 v的16位v被忽略。 如果流使用网络字节顺序，则按顺序写入的字节为：
          (byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
        否则写入的字节将为：
          (byte)(v & 0xff)
 (byte)((v >> 8) & 0xff)

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeShort在接口 DataOutput
        参数
        v - 包含要写入的短值的 int 。
        异常
        IOException - 如果发生I / O错误。

      • writeChar

        void writeChar​(int v)
        throws IOException
        这个方法是 writeShort的同义词。
        Specified by:
        writeChar在接口 DataOutput
        参数
        v - 一个包含要写入的char（unsigned short）值的 int 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        writeShort(int)

      • writeInt

        void writeInt​(int v)
       throws IOException
        将v的32位写入流。 如果流使用网络字节顺序，则按顺序写入的字节为：
          (byte)((v >> 24) & 0xff)
 (byte)((v >> 16) & 0xff)
 (byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
        Otheriwse，写入的字节将是：
          (byte)(v & 0xff)
 (byte)((v >> 8) & 0xff)
 (byte)((v >> 16) & 0xff)
 (byte)((v >> 24) & 0xff)

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeInt在接口 DataOutput
        参数
        v - 一个包含要写入的值的 int 。
        异常
        IOException - 如果发生I / O错误。

      • writeLong

        void writeLong​(long v)
        throws IOException
        将v的64位写入流。 如果流使用网络字节顺序，则按顺序写入的字节为：
          (byte)((v >> 56) & 0xff)
 (byte)((v >> 48) & 0xff)
 (byte)((v >> 40) & 0xff)
 (byte)((v >> 32) & 0xff)
 (byte)((v >> 24) & 0xff)
 (byte)((v >> 16) & 0xff)
 (byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
        否则写入的字节将为：
          (byte)(v & 0xff)
 (byte)((v >> 8) & 0xff)
 (byte)((v >> 16) & 0xff)
 (byte)((v >> 24) & 0xff)
 (byte)((v >> 32) & 0xff)
 (byte)((v >> 40) & 0xff)
 (byte)((v >> 48) & 0xff)
 (byte)((v >> 56) & 0xff)

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeLong在接口 DataOutput
        参数
        v - a long包含要写入的值。
        异常
        IOException - 如果发生I / O错误。

      • writeFloat

        void writeFloat​(float v)
         throws IOException
        向输出流写入一个由四个字节组成的float值。 它这样做是因为，如果它首先将这个float值到int在完全相同的方式Float.floatToIntBits方法，然后在的完全相同的方式写入的int值writeInt方法。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeFloat在接口 DataOutput
        参数
        v - a float包含要写入的值。
        异常
        IOException - 如果发生I / O错误。

      • writeDouble

        void writeDouble​(double v)
          throws IOException
        double四个字节组成的double值写入输出流。 它这样做是因为，如果它首先将这个double值到long在完全相同的方式Double.doubleToLongBits方法，然后在完全相同的方式写入长值writeLong方法。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeDouble在接口 DataOutput
        参数
        v - a double包含要写入的值。
        异常
        IOException - 如果发生I / O错误。

      • writeBytes

        void writeBytes​(String s)
         throws IOException
        将一个字符串写入输出流。 对于字符串s中的每个字符，按顺序，一个字节被写入输出流。 如果s为null ，则抛出NullPointerException 。

        如果s.length为零，则不会写入任何字节。 否则，首先写入字符s[0] ，然后写入s[1] ，等等; 写最后一个字符是s[s.length-1] 。 对于每个字符，写入一个字节，低字节，按照writeByte方式。 字符串中每个字符的高8位被忽略。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeBytes接口 DataOutput
        参数
        s - a String包含要写入的值。
        异常
        NullPointerException - 如果 s是 null 。
        IOException - 如果发生I / O错误。

      • writeChars

        void writeChars​(String s)
         throws IOException
        将一个字符串写入输出流。 对于字符串s中的每个字符，按顺序，将两个字节写入输出流，根据当前字节顺序设置进行排序。 如果正在使用网络字节顺序，则首先写入高字节; 否则订单相反。 如果s为null ，则抛出NullPointerException 。

        如果s.length为零，则不会写入任何字节。 否则，首先写入字符s[0] ，然后写入s[1] ，等等; 写最后一个字符是s[s.length-1] 。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeChars在接口 DataOutput
        参数
        s - a String包含要写入的值。
        异常
        NullPointerException - 如果 s是 null 。
        IOException - 如果发生I / O错误。

      • writeUTF

        void writeUTF​(String s)
       throws IOException
        以网络字节顺序将两个字节的长度信息写入输出流，后跟字符串s中每个字符的modified UTF-8表示。 如果s为null ，则抛出NullPointerException 。 字符串s中的每个字符根据字符的值转换为一个，两个或三个字节的组。

        如果字符c在\u0001至\u007f的范围内，则由一个字节表示：

          (byte)c

        如果字符c是\u0000或是在\u0080到\u07ff的范围内，那么它由两个字节表示，按照显示的顺序写：

           (byte)(0xc0 | (0x1f & (c >> 6))) (byte)(0x80 | (0x3f & c))

        如果一个字符c在\u0800到uffff ，那么它由三个字节表示，按照显示的顺序写：

           (byte)(0xe0 | (0x0f & (c >> 12))) (byte)(0x80 | (0x3f & (c >> 6))) (byte)(0x80 | (0x3f & c))

        首先，计算表示s所有字符所需的总字节数。 如果这个数字大于65535 ，则抛出一个UTFDataFormatException 。 否则，这个长度以writeShort方式的方式写入输出流; 之后，写入字符串s中每个字符的一字节，二字节或三字节表示。

        当前字节顺序设置被忽略。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        注意：此方法不应用于执行使用标准UTF-8的图像格式，因为此处使用的修改后的UTF-8与标准UTF-8不兼容。

        Specified by:
        writeUTF在接口 DataOutput
        参数
        s - a String包含要写入的值。
        异常
        NullPointerException - 如果 s是 null 。
        UTFDataFormatException -如果的改性UTF-8表示 s需要超过65536个字节。
        IOException - 如果发生I / O错误。

      • writeShorts

        void writeShorts​(short[] s,
                 int off,
                 int len)
          throws IOException
        在当前位置写入流的序列。 如果len为0，则不会写入。 短s[off]先写，然后短s[off + 1]等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        参数
        s - 要写入的 short的数组。
        off - 数据中的起始偏移量。
        len - short的 len的数量。
        异常
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 off + len ，大于 s.length 。
        NullPointerException - 如果 s是 null 。
        IOException - 如果发生I / O错误。

      • writeChars

        void writeChars​(char[] c,
                int off,
                int len)
         throws IOException
        在当前位置将一串字符写入流。 如果len为0， len写任何内容。 char c[off]是先写的，然后是char c[off + 1] ，等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        参数
        c - 要写入的 char的数组。
        off - 数据中的起始偏移量。
        len - char的 len的数量。
        异常
        IndexOutOfBoundsException - 如果 off为负数， len ，否则为 off + len ，大于 c.length 。
        NullPointerException - 如果 c是 null 。
        IOException - 如果发生I / O错误。

      • writeInts

        void writeInts​(int[] i,
               int off,
               int len)
        throws IOException
        在当前位置写入流的序列。 如果len为0，则不会写入。 int i[off]先写，然后是int i[off + 1] ，等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        参数
        i - 要写入的 int的数组。
        off - 数据中的起始偏移量。
        len - int的 len的数量。
        异常
        IndexOutOfBoundsException - 如果 off为负， len为负数，或 off + len为大于 i.length 。
        NullPointerException - 如果 i是 null 。
        IOException - 如果发生I / O错误。

      • writeLongs

        void writeLongs​(long[] l,
                int off,
                int len)
         throws IOException
        在当前位置写入流的序列。 如果len为0，则不会写入。 长l[off]先写，然后长l[off + 1] ，等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        参数
        l - 要写入的 long的数组。
        off - 数据中的起始偏移量。
        len - long的 len的数量。
        异常
        IndexOutOfBoundsException - 如果 off为负数， len为负数，或 off + len为大于 l.length 。
        NullPointerException - 如果 l是 null 。
        IOException - 如果发生I / O错误。

      • writeFloats

        void writeFloats​(float[] f,
                 int off,
                 int len)
          throws IOException
        在当前位置将一系列浮点写入流。 如果len为0，则不会写入。 浮动f[off]先写，然后浮动f[off + 1]等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        参数
        f - 要编写的 float的数组。
        off - 数据中的起始偏移量。
        len - float的 len的数量。
        异常
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 off + len ，大于 f.length 。
        NullPointerException - 如果 f是 null 。
        IOException - 如果发生I / O错误。

      • writeDoubles

        void writeDoubles​(double[] d,
                  int off,
                  int len)
           throws IOException
        将当前位置的一系列双精度写入流。 如果len为0， len写任何内容。 双d[off]先写，然后双d[off + 1]等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        参数
        d - 要写入的 doubles的数组。
        off - 数据中的起始偏移量。
        len - double的 len的数量。
        异常
        IndexOutOfBoundsException - 如果 off为负数， len ，否则为 off + len ，大于 d.length 。
        NullPointerException - 如果 d是 null 。
        IOException - 如果发生I / O错误。

      • writeBit

        void writeBit​(int bit)
       throws IOException
        将由参数的最低有效位给出的单个位写入当前字节位置中当前位偏移量的流。 参数的高31位被忽略。 给定位替换该位置上的前一位。 位偏移前进一并减少模8。

        如果特定字节的任何位在字节被刷新到目的地时从未被设置，则这些位将自动设置为0。

        参数
        bit - 其最低有效位 bit的 int 。
        异常
        IOException - 如果发生I / O错误。

      • writeBits

        void writeBits​(long bits,
               int numBits)
        throws IOException
        将bits参数的bits参数的从左到右顺序的numBits位给出的位序列写入当前字节位置当前位偏移量的流。 上限的64 - numBits位的参数被忽略。 位偏移提前numBits并减小模8。注意，0的位偏移总是表示字节的最高有效位，并且在遇到位时，位的字节顺序写出。 因此，位写入总是以网络字节顺序有效。 实际流字节顺序设置被忽略。

        位数据可以无限期地累积在存储器中，直到flushBefore 。 那时候，闪存位置之前的所有位数据将被写入。

        如果特定字节的任何位在字节被刷新到目的地时从未被设置，则这些位将自动设置为0。

        参数
        bits -a long包含要写入的位，从位置 numBits - 1的位开始到最低有效位。
        numBits - 一个在0和64之间的 int （含）。
        异常
        IllegalArgumentException - 如果 numBits不在0和64之间，包括0和64之间。
        IOException - 如果发生I / O错误。

      • flushBefore

        void flushBefore​(long pos)
          throws IOException
        将给定位置之前的所有数据刷新到基础目标，例如OutputStream或File 。 试图寻求流的冲洗部分将导致一个IndexOutOfBoundsException 。
        Specified by:
        flushBefore在接口 ImageInputStream
        参数
        pos - 一个 long其中包含可能被刷新到目的地的流前缀的长度。
        异常
        IndexOutOfBoundsException - 如果 pos位于流的冲洗部分或超过当前流位置。
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageOutputStreamImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Class ImageOutputStreamImpl

  • java.lang.Object
    • javax.imageio.stream.ImageInputStreamImpl
      • javax.imageio.stream.ImageOutputStreamImpl
  • All Implemented Interfaces:
    Closeable ， DataInput ， DataOutput ， AutoCloseable ， ImageInputStream ， ImageOutputStream
    已知直接子类：
    FileCacheImageOutputStream ， FileImageOutputStream ， MemoryCacheImageOutputStream

    public abstract class ImageOutputStreamImpl
extends ImageInputStreamImpl
implements ImageOutputStream
    一个实现ImageOutputStream接口的抽象类。 该类旨在减少子类必须实现的方法的数量。

    • Field Summary

      • Fields inherited from class javax.imageio.stream.ImageInputStreamImpl

        bitOffset, byteOrder, flushedPos, streamPos

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageOutputStreamImpl​()
      构造一个 ImageOutputStreamImpl 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected void flushBits​()
      如果位偏移量不为零，则强制当前字节中的剩余位为0，并将流位置提前一位。
      void write​(byte[] b)
      在当前位置写入一串字节。
      abstract void write​(byte[] b, int off, int len)
      在当前位置写入一串字节。
      abstract void write​(int b)
      将当前位置的单个字节写入流。
      void writeBit​(int bit)
      将由参数的最低有效位给出的单个位写入当前字节位置中当前位偏移量的流。
      void writeBits​(long bits, int numBits)
      将 bits参数的 numBits最低有效位由左到右的顺序写入位于当前字节位置当前位偏移的流中的位序列。
      void writeBoolean​(boolean v)
      向流中写入一个 boolean值。
      void writeByte​(int v)
      将 v的8位低位写入流。
      void writeBytes​(String s)
      将一个字符串写入输出流。
      void writeChar​(int v)
      该方法是 writeShort的同义词。
      void writeChars​(char[] c, int off, int len)
      在当前位置将一串字符写入流。
      void writeChars​(String s)
      将一个字符串写入输出流。
      void writeDouble​(double v)
      向输出流写入一个由四个字节组成的 double值。
      void writeDoubles​(double[] d, int off, int len)
      将当前位置的一系列双精度写入流。
      void writeFloat​(float v)
      将一个由四个字节组成的 float值写入输出流。
      void writeFloats​(float[] f, int off, int len)
      在当前位置将一系列浮点写入流。
      void writeInt​(int v)
      将 v的32位写入流。
      void writeInts​(int[] i, int off, int len)
      在当前位置写入流的序列。
      void writeLong​(long v)
      将 v的64位写入流。
      void writeLongs​(long[] l, int off, int len)
      在当前位置写入流的序列。
      void writeShort​(int v)
      将 v位 v位低位位写入流。
      void writeShorts​(short[] s, int off, int len)
      在当前位置写入流的序列。
      void writeUTF​(String s)
      以网络字节顺序将两个字节的长度信息写入输出流，后跟字符串 s中每个字符的 modified UTF-8表示。

      • Methods inherited from interface javax.imageio.stream.ImageInputStream

        close, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, length, mark, read, read, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from class javax.imageio.stream.ImageInputStreamImpl

        checkClosed, close, finalize, flush, flushBefore, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, length, mark, read, read, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from interface javax.imageio.stream.ImageOutputStream

        flushBefore

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ImageOutputStreamImpl

        public ImageOutputStreamImpl​()
        构造一个 ImageOutputStreamImpl 。

    • 方法详细信息

      • write

        public abstract void write​(int b)
                    throws IOException
        描述从接口ImageOutputStream复制
        将当前位置的单个字节写入流。 忽略了b的24个高位。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ImageOutputStream
        参数
        b - 要写入低8位的 int 。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b)
           throws IOException
        描述从接口ImageOutputStream复制
        在当前位置写入一串字节。 如果b.length为0， b.length写任何内容。 字节b[0]首先写入，然后字节b[1]等等。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ImageOutputStream
        参数
        b - 要写入的 byte数组。
        异常
        IOException - 如果发生I / O错误。

      • write

        public abstract void write​(byte[] b,
                           int off,
                           int len)
                    throws IOException
        说明从界面ImageOutputStream复制
        在当前位置写入一串字节。 如果len为0，则不会写入。 字节b[off]首先写入，然后字节b[off + 1]等等。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ImageOutputStream
        参数
        b - 要写入的 byte的数组。
        off - 数据中的起始偏移量。
        len - byte的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • writeBoolean

        public void writeBoolean​(boolean v)
                  throws IOException
        描述从接口ImageOutputStream复制
        向流中写入一个boolean值。 如果v为真，则写入值(byte)1 ; 如果v为假，则写入值(byte)0 。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeBoolean在接口 DataOutput
        Specified by:
        writeBoolean在接口 ImageOutputStream
        参数
        v - boolean 。
        异常
        IOException - 如果发生I / O错误。

      • writeByte

        public void writeByte​(int v)
               throws IOException
        描述从接口ImageOutputStream复制
        将v的8位低位写入流。 v的24位v被忽略。 （这意味着writeByte与整数参数完全一样） write ））

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeByte在接口 DataOutput
        Specified by:
        writeByte在接口 ImageOutputStream
        参数
        v - 包含要写入的字节值的 int 。
        异常
        IOException - 如果发生I / O错误。

      • writeShort

        public void writeShort​(int v)
                throws IOException
        描述从接口ImageOutputStream复制
        将v字节的v位写入流。 v的16位v被忽略。 如果流使用网络字节顺序，则按顺序写入的字节为：
          (byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
        否则写入的字节将为：
          (byte)(v & 0xff)
 (byte)((v >> 8) & 0xff)

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeShort在接口 DataOutput
        Specified by:
        writeShort在接口 ImageOutputStream
        参数
        v - 一个 int其中包含要写入的短值。
        异常
        IOException - 如果发生I / O错误。

      • writeChar

        public void writeChar​(int v)
               throws IOException
        说明从界面ImageOutputStream复制
        该方法是 writeShort的同义词。
        Specified by:
        writeChar在接口 DataOutput
        Specified by:
        writeChar接口 ImageOutputStream
        参数
        v - 包含要写入的char（unsigned short）值的 int 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        ImageOutputStream.writeShort(int)

      • writeInt

        public void writeInt​(int v)
              throws IOException
        描述从接口ImageOutputStream复制
        将v的32位写入流。 如果流使用网络字节顺序，则按顺序写入的字节为：
          (byte)((v >> 24) & 0xff)
 (byte)((v >> 16) & 0xff)
 (byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
        Otheriwse，写入的字节将是：
          (byte)(v & 0xff)
 (byte)((v >> 8) & 0xff)
 (byte)((v >> 16) & 0xff)
 (byte)((v >> 24) & 0xff)

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeInt在接口 DataOutput
        Specified by:
        writeInt在接口 ImageOutputStream
        参数
        v - 一个包含要写入的值的 int 。
        异常
        IOException - 如果发生I / O错误。

      • writeLong

        public void writeLong​(long v)
               throws IOException
        说明从界面ImageOutputStream复制
        将v的64位写入流。 如果流使用网络字节顺序，则按顺序写入的字节为：
          (byte)((v >> 56) & 0xff)
 (byte)((v >> 48) & 0xff)
 (byte)((v >> 40) & 0xff)
 (byte)((v >> 32) & 0xff)
 (byte)((v >> 24) & 0xff)
 (byte)((v >> 16) & 0xff)
 (byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
        否则写入的字节将为：
          (byte)(v & 0xff)
 (byte)((v >> 8) & 0xff)
 (byte)((v >> 16) & 0xff)
 (byte)((v >> 24) & 0xff)
 (byte)((v >> 32) & 0xff)
 (byte)((v >> 40) & 0xff)
 (byte)((v >> 48) & 0xff)
 (byte)((v >> 56) & 0xff)

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeLong在接口 DataOutput
        Specified by:
        writeLong在接口 ImageOutputStream
        参数
        v - a long包含要写入的值。
        异常
        IOException - 如果发生I / O错误。

      • writeFloat

        public void writeFloat​(float v)
                throws IOException
        说明从界面ImageOutputStream复制
        向输出流写入由四个字节组成的float值。 它这样做是因为，如果它首先将这个float值到int在完全相同的方式Float.floatToIntBits方法，然后在的完全相同的方式写入的int值writeInt方法。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeFloat在接口 DataOutput
        Specified by:
        writeFloat在接口 ImageOutputStream
        参数
        v - a float包含要写入的值。
        异常
        IOException - 如果发生I / O错误。

      • writeDouble

        public void writeDouble​(double v)
                 throws IOException
        说明从界面ImageOutputStream复制
        向输出流写入由四个字节组成的double值。 它这样做是因为，如果它首先将这个double值到long在完全相同的方式Double.doubleToLongBits方法，然后在完全相同的方式写入长值writeLong方法。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeDouble接口 DataOutput
        Specified by:
        writeDouble接口 ImageOutputStream
        参数
        v - 一个包含要写入的值的 double 。
        异常
        IOException - 如果发生I / O错误。

      • writeBytes

        public void writeBytes​(String s)
                throws IOException
        描述从接口ImageOutputStream复制
        将一个字符串写入输出流。 对于字符串s中的每个字符，按顺序，一个字节被写入输出流。 如果s为null ，则抛出NullPointerException 。

        如果s.length为零，则不会写入任何字节。 否则，首先写入字符s[0] ，然后写入s[1]等等; 写最后一个字符是s[s.length-1] 。 对于每个字符，写入一个字节，即低位字节，完全符合writeByte方法。 字符串中每个字符的高8位被忽略。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeBytes在接口 DataOutput
        Specified by:
        writeBytes在接口 ImageOutputStream
        参数
        s - a String包含要写入的值。
        异常
        IOException - 如果发生I / O错误。

      • writeChars

        public void writeChars​(String s)
                throws IOException
        说明从界面ImageOutputStream复制
        将一个字符串写入输出流。 对于字符串s中的每个字符，按顺序，将两个字节写入输出流，根据当前字节顺序设置进行排序。 如果正在使用网络字节顺序，则首先写入高字节; 否则订单相反。 如果s为null ，则抛出NullPointerException 。

        如果s.length为零，则不会写入任何字节。 否则，首先写入字符s[0] ，然后写入s[1] ，等等; 写最后一个字符是s[s.length-1] 。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeChars在接口 DataOutput
        Specified by:
        writeChars在接口 ImageOutputStream
        参数
        s - a String包含要写入的值。
        异常
        IOException - 如果发生I / O错误。

      • writeUTF

        public void writeUTF​(String s)
              throws IOException
        描述从接口ImageOutputStream复制
        以网络字节顺序将两个字节的长度信息写入输出流，后跟字符串s中每个字符的modified UTF-8表示。 如果s为null ，则抛出NullPointerException 。 字符串s中的每个字符根据字符的值转换为一个，两个或三个字节的组。

        如果字符c在\u0001至\u007f ，则由一个字节表示：

          (byte)c

        如果字符c是\u0000或者是在\u0080到\u07ff的范围内，那么它由两个字节表示，按照显示的顺序写：

           (byte)(0xc0 | (0x1f & (c >> 6))) (byte)(0x80 | (0x3f & c))

        如果字符c在\u0800至uffff范围内， \u0800 3个字节表示，按照显示的顺序写入：

           (byte)(0xe0 | (0x0f & (c >> 12))) (byte)(0x80 | (0x3f & (c >> 6))) (byte)(0x80 | (0x3f & c))

        首先计算代表s所有字符所需的总字节数。 如果这个数字大于65535 ，则抛出一个UTFDataFormatException 。 否则，该长度以writeShort的方式写入输出流; 之后，写入字符串s中每个字符的一个，两个或三个字节的表示。

        当前字节顺序设置被忽略。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        注意：此方法不应用于执行使用标准UTF-8的图像格式，因为此处使用的修改后的UTF-8与标准UTF-8不兼容。

        Specified by:
        writeUTF在接口 DataOutput
        Specified by:
        writeUTF接口 ImageOutputStream
        参数
        s - a String包含要写入的值。
        异常
        UTFDataFormatException -如果的改性UTF-8表示 s需要超过65536个字节。
        IOException - 如果发生I / O错误。

      • writeShorts

        public void writeShorts​(short[] s,
                        int off,
                        int len)
                 throws IOException
        描述从接口ImageOutputStream复制
        在当前位置写入流的序列。 如果len为0， len写任何内容。 短s[off]先写，然后短s[off + 1] ，等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeShorts在接口 ImageOutputStream
        参数
        s - 要写入的 short的数组。
        off - 数据中的起始偏移量。
        len - short的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • writeChars

        public void writeChars​(char[] c,
                       int off,
                       int len)
                throws IOException
        说明从界面ImageOutputStream复制
        在当前位置将一串字符写入流。 如果len为0， len写任何内容。 char c[off]是先写的，然后是char c[off + 1] ，等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeChars在接口 ImageOutputStream
        参数
        c - 要写入的 char数组。
        off - 数据中的起始偏移量。
        len - char的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • writeInts

        public void writeInts​(int[] i,
                      int off,
                      int len)
               throws IOException
        描述从接口ImageOutputStream复制
        在当前位置写入流的序列。 如果len为0， len写任何内容。 int i[off]先写，然后是int i[off + 1] ，等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeInts在接口 ImageOutputStream
        参数
        i - 要写入的 int的数组。
        off - 数据中的起始偏移量。
        len - int的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • writeLongs

        public void writeLongs​(long[] l,
                       int off,
                       int len)
                throws IOException
        描述从接口ImageOutputStream复制
        在当前位置写入流的序列。 如果len为0， len写任何内容。 长l[off]是先写的，那么长l[off + 1] ，等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeLongs在接口 ImageOutputStream
        参数
        l - 要写入的 long的数组。
        off - 数据中的起始偏移量。
        len - long的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • writeFloats

        public void writeFloats​(float[] f,
                        int off,
                        int len)
                 throws IOException
        描述从接口ImageOutputStream复制
        在当前位置将一系列浮点写入流。 如果len为0，则不会写入。 浮动f[off]先写，然后浮动f[off + 1]等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeFloats在接口 ImageOutputStream
        参数
        f - 要写入的 float的数组。
        off - 数据中的起始偏移量。
        len - float的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • writeDoubles

        public void writeDoubles​(double[] d,
                         int off,
                         int len)
                  throws IOException
        说明从接口ImageOutputStream复制
        将当前位置的一系列双精度写入流。 如果len为0，则不会写入。 双d[off]先写，然后双d[off + 1] ，等等。 流的字节顺序用于确定写入单个字节的顺序。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。

        Specified by:
        writeDoubles在接口 ImageOutputStream
        参数
        d - 要写入的 doubles的数组。
        off - 数据中的起始偏移量。
        len - double的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • writeBit

        public void writeBit​(int bit)
              throws IOException
        说明从界面复制： ImageOutputStream
        将由参数的最低有效位给出的单个位写入当前字节位置中当前位偏移量的流。 参数的高31位被忽略。 给定位替换该位置上的前一位。 位偏移前进一并减少模8。

        如果特定字节的任何位在字节被刷新到目的地时从未被设置，则这些位将自动设置为0。

        Specified by:
        writeBit接口 ImageOutputStream
        参数
        bit - 其最低有效位 bit的 int 。
        异常
        IOException - 如果发生I / O错误。

      • writeBits

        public void writeBits​(long bits,
                      int numBits)
               throws IOException
        说明从界面ImageOutputStream复制
        将bits参数中的bits参数的从左到右顺序的numBits最低有效位给出的位序列写入当前字节位置当前位偏移量的流。 上限的64 - numBits位的参数被忽略。 位偏移提前numBits并减小模8。注意，0的位偏移总是表示字节的最高有效位，并且在遇到位时，位的字节顺序写出。 因此，位写入总是以网络字节顺序有效。 实际流字节顺序设置被忽略。

        位数据可以无限期累积到存储器中，直到flushBefore 。 那时候，闪存位置之前的所有位数据将被写入。

        如果特定字节的任何位在字节被刷新到目的地时从未被设置，则这些位将自动设置为0。

        Specified by:
        writeBits接口 ImageOutputStream
        参数
        bits -a long包含要写入的位，从位置 numBits - 1的位开始到最低有效位。
        numBits - 一个从0到64之间的 int （含）。
        异常
        IOException - 如果发生I / O错误。

      • flushBits

        protected final void flushBits​()
                        throws IOException
        如果位偏移量不为零，则强制当前字节中的剩余位为0，并将流位置提前一位。 该方法应该由write(int)和write(byte[], int, int)方法开头的子类调用。
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.imageio.stream (Java SE 9 & JDK 9 )

javax.imageio.stream

Interfaces

  • ImageInputStream
  • ImageOutputStream

Classes

  • FileCacheImageInputStream
  • FileCacheImageOutputStream
  • FileImageInputStream
  • FileImageOutputStream
  • IIOByteBuffer
  • ImageInputStreamImpl
  • ImageOutputStreamImpl
  • MemoryCacheImageInputStream
  • MemoryCacheImageOutputStream


javax.imageio.stream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package javax.imageio.stream

Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

ImageInputStream接口统一了流媒体和基于文件的操作。 提供了一个抽象基类ImageInputStreamImpl来简化新的ImageInputStream类的编写。 具体实现类（ FileImageInputStream ， FileCacheImageInputStream ，并MemoryCacheImageInputStream ）所提供的允许输入来自File或者InputStream使用或不使用临时缓存文件。

ImageOutputStream接口执行类似的输出功能。 一个抽象基类， ImageOutputStreamImpl提供，用实际实现类（沿FileImageOutputStream ， FileCacheImageOutputStream ，并MemoryCacheImageOutputStream ）提供的，允许输出去一个File或者OutputStream使用或不使用临时缓存文件。

IIOByteBuffer类提供了一种替代方式来执行字节序列读取，从而减少了内部数据复制的数量。

从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    ImageInputStream
    一个可寻求的输入流接口，供 ImageReader使用。
    ImageOutputStream
    一个可寻求的输出流接口，供 ImageWriter使用。
  • 类摘要
    Class 描述
    FileCacheImageInputStream
    一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。
    FileCacheImageOutputStream
    实现 ImageOutputStream将其输出写入常规的 OutputStream 。
    FileImageInputStream
    一个 ImageInputStream的实现，从 File或 RandomAccessFile获取其输入。
    FileImageOutputStream
    实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。
    IIOByteBuffer
    表示对字节数组的可变引用以及该数组中的偏移量和长度的类。
    ImageInputStreamImpl
    一个实现 ImageInputStream接口的抽象类。
    ImageOutputStreamImpl
    一个实现 ImageOutputStream接口的抽象类。
    MemoryCacheImageInputStream
    一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。
    MemoryCacheImageOutputStream
    实现 ImageOutputStream ，将其输出写入常规的 OutputStream 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.imageio.stream Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.imageio.stream

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.imageio.stream.IIOByteBuffer
    • javax.imageio.stream.ImageInputStreamImpl (implements javax.imageio.stream.ImageInputStream)
      • javax.imageio.stream.FileCacheImageInputStream
      • javax.imageio.stream.FileImageInputStream
      • javax.imageio.stream.ImageOutputStreamImpl (implements javax.imageio.stream.ImageOutputStream)
        • javax.imageio.stream.FileCacheImageOutputStream
        • javax.imageio.stream.FileImageOutputStream
        • javax.imageio.stream.MemoryCacheImageOutputStream
      • javax.imageio.stream.MemoryCacheImageInputStream

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • javax.imageio.stream.ImageInputStream (also extends java.io.DataInput)
        • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput)
  • java.io.DataInput
    • javax.imageio.stream.ImageInputStream (also extends java.io.Closeable)
      • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput)
  • java.io.DataOutput
    • javax.imageio.stream.ImageOutputStream (also extends javax.imageio.stream.ImageInputStream)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


MemoryCacheImageInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Class MemoryCacheImageInputStream

  • java.lang.Object
    • javax.imageio.stream.ImageInputStreamImpl
      • javax.imageio.stream.MemoryCacheImageInputStream
  • All Implemented Interfaces:
    Closeable ， DataInput ， AutoCloseable ， ImageInputStream

    public class MemoryCacheImageInputStream
extends ImageInputStreamImpl
    一个ImageInputStream的实现，从常规的InputStream获取它的输入。 存储器缓冲器用于至少缓存丢弃位置和当前读取位置之间的数据。

    一般地，它是优选使用FileCacheImageInputStream从常规读出时InputStream 。 在不可能创建可写入临时文件的情况下提供此类。

    • Field Summary

      • Fields inherited from class javax.imageio.stream.ImageInputStreamImpl

        bitOffset, byteOrder, flushedPos, streamPos

    • 构造方法摘要

      构造方法
      Constructor 描述
      MemoryCacheImageInputStream​(InputStream stream)
      构造一个 MemoryCacheImageInputStream ，将从给定的 InputStream读取。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void close​()
      关闭这个 MemoryCacheImageInputStream ，释放缓存。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      void flushBefore​(long pos)
      在指示的位置之前丢弃流的初始部分。
      boolean isCached​()
      返回 true因为这 ImageInputStream缓存数据以允许向后搜索。
      boolean isCachedFile​()
      返回 false因为这个 ImageInputStream不保存文件缓存。
      boolean isCachedMemory​()
      返回 true因为这个 ImageInputStream维护一个主内存缓存。
      int read​()
      从流中读取一个字节，并将其作为0和255之间的 int返回。
      int read​(byte[] b, int off, int len)
      从流中读取最多 len个字节，并将其存储到 b ，索引号为 off 。

      • Methods inherited from class javax.imageio.stream.ImageInputStreamImpl

        checkClosed, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, length, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MemoryCacheImageInputStream

        public MemoryCacheImageInputStream​(InputStream stream)
        构造一个 MemoryCacheImageInputStream ，将从给定的 InputStream读取。
        参数
        stream - 一个 InputStream要阅读。
        异常
        IllegalArgumentException - 如果 stream是 null 。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        描述从类复制： ImageInputStreamImpl
        从该流读取单个字节，并返回它作为一个int 0到255，并且如果达到EOF， -1被返回。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        在发生读取之前，流内的位偏移必须重置为零。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read中的 ImageInputStreamImpl
        结果
        流中下一个字节的值，如果达到EOF， -1 。
        异常
        IOException - 如果流已关闭。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        描述从类复制： ImageInputStreamImpl
        读取到len从流字节，并将其存储到b开始于索引off 。 如果没有字节可以读取，因为已经到达流的末尾，则返回-1 。

        在发生读取之前，流内的位偏移必须重置为零。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read在 ImageInputStreamImpl
        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要读取的最大字节数。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        IOException - 如果发生I / O错误。

      • flushBefore

        public void flushBefore​(long pos)
                 throws IOException
        描述从接口ImageInputStream复制
        在指示的位置之前丢弃流的初始部分。 尝试寻求流的冲洗部分内的偏移量将导致一个IndexOutOfBoundsException 。

        调用flushBefore可能允许实现此接口的类释放用于存储数据流的内存或磁盘空间等资源。

        Specified by:
        flushBefore在接口 ImageInputStream
        重写：
        flushBefore中的 ImageInputStreamImpl
        参数
        pos - 一个 long其中包含可能被刷新的流前缀的长度。
        异常
        IOException - 如果发生I / O错误。

      • isCached

        public boolean isCached​()
        返回 true因为这 ImageInputStream缓存数据以允许向后搜索。
        Specified by:
        isCached在接口 ImageInputStream
        重写：
        isCached中的 ImageInputStreamImpl
        结果
        true 。
        另请参见：
        isCachedMemory() ， isCachedFile()

      • isCachedFile

        public boolean isCachedFile​()
        返回 false因为这个 ImageInputStream不保存文件缓存。
        Specified by:
        isCachedFile在接口 ImageInputStream
        重写：
        isCachedFile在 ImageInputStreamImpl
        结果
        false 。
        另请参见：
        isCached() ， isCachedMemory()

      • isCachedMemory

        public boolean isCachedMemory​()
        返回 true因为此 ImageInputStream维护主内存缓存。
        Specified by:
        isCachedMemory在接口 ImageInputStream
        重写：
        isCachedMemory在 ImageInputStreamImpl
        结果
        true 。
        另请参见：
        isCached() ， isCachedFile()

      • close

        public void close​()
           throws IOException
        关闭这个MemoryCacheImageInputStream ，释放缓存。 源InputStream未关闭。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在接口 ImageInputStream
        重写：
        close在 ImageInputStreamImpl
        异常
        IOException - 如果发生I / O错误。

      • finalize

        @Deprecated(since="9")
protected void finalize​()
                 throws Throwable
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        在垃圾收集之前完成此对象。 调用close方法来关闭任何打开的输入源。 不应该从应用程序代码调用此方法。
        重写：
        finalize在 ImageInputStreamImpl
        异常
        Throwable - 如果在超类最终化期间发生错误。
        另请参见：
        WeakReference ， PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MemoryCacheImageOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 javax.imageio.stream

Class MemoryCacheImageOutputStream

  • java.lang.Object
    • javax.imageio.stream.ImageInputStreamImpl
      • javax.imageio.stream.ImageOutputStreamImpl
        • javax.imageio.stream.MemoryCacheImageOutputStream
  • All Implemented Interfaces:
    Closeable ， DataInput ， DataOutput ， AutoCloseable ， ImageInputStream ， ImageOutputStream

    public class MemoryCacheImageOutputStream
extends ImageOutputStreamImpl
    一个ImageOutputStream的实现，将其输出写入常规的OutputStream 。 存储器缓冲器用于至少缓存丢弃位置和当前写入位置之间的数据。 唯一的构造函数需要一个OutputStream ，所以这个类可能不用于读/修改/写操作。 读取只能发生在已经写入高速缓存并且尚未刷新的流的部分上。

    • Field Summary

      • Fields inherited from class javax.imageio.stream.ImageInputStreamImpl

        bitOffset, byteOrder, flushedPos, streamPos

    • 构造方法摘要

      构造方法
      Constructor 描述
      MemoryCacheImageOutputStream​(OutputStream stream)
      构造一个 MemoryCacheImageOutputStream ，它将写入给定的 OutputStream 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此 MemoryCacheImageOutputStream 。
      void flushBefore​(long pos)
      在指示的位置之前丢弃流的初始部分。
      boolean isCached​()
      返回 true因为这 ImageOutputStream缓存数据，以便向后 ImageOutputStream 。
      boolean isCachedFile​()
      返回 false因为这个 ImageOutputStream没有维护一个文件缓存。
      boolean isCachedMemory​()
      返回 true因为这个 ImageOutputStream维护一个主内存缓存。
      long length​()
      返回 -1L以表示流长度不明确。
      int read​()
      从流中读取一个字节，并将其作为 int和255之间的 int返回。
      int read​(byte[] b, int off, int len)
      读取到 len从流字节，并将其存储到 b开始于索引 off 。
      void write​(byte[] b, int off, int len)
      在当前位置写入一串字节。
      void write​(int b)
      将当前位置的单个字节写入流。

      • Methods inherited from interface javax.imageio.stream.ImageInputStream

        flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from class javax.imageio.stream.ImageInputStreamImpl

        checkClosed, finalize, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

      • Methods inherited from class javax.imageio.stream.ImageOutputStreamImpl

        flushBits, write, writeBit, writeBits, writeBoolean, writeByte, writeBytes, writeChar, writeChars, writeChars, writeDouble, writeDoubles, writeFloat, writeFloats, writeInt, writeInts, writeLong, writeLongs, writeShort, writeShorts, writeUTF

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MemoryCacheImageOutputStream

        public MemoryCacheImageOutputStream​(OutputStream stream)
        构造一个 MemoryCacheImageOutputStream ，它将写入给定的 OutputStream 。
        参数
        stream - 要写的 OutputStream 。
        异常
        IllegalArgumentException - 如果 stream是 null 。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        描述从类复制： ImageInputStreamImpl
        从流中读取一个字节，并将其作为int和255之间的-1返回。如果达到EOF，则返回-1 。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        在发生读取之前，流内的位偏移必须重置为零。

        Specified by:
        read接口 ImageInputStream
        Specified by:
        read类 ImageInputStreamImpl
        结果
        流中下一个字节的值，如果达到EOF， -1 。
        异常
        IOException - 如果流已关闭。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        描述从类复制： ImageInputStreamImpl
        从流中读取最多len个字节，并将其存储到b ，索引号为off 。 如果没有字节可以读取，因为已经到达流的末尾，则返回-1 。

        在发生读取之前，流内的位偏移必须重置为零。

        子类必须为此方法提供一个实现。 子类实现应该在退出之前更新流位置。

        Specified by:
        read在接口 ImageInputStream
        Specified by:
        read类 ImageInputStreamImpl
        参数
        b - 要写入的字节数组。
        off - 起始位置在 b内写。
        len - 要读取的最大字节数。
        结果
        实际读取的字节数，或 -1表示EOF。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(int b)
           throws IOException
        说明从接口ImageOutputStream复制
        将当前位置的单个字节写入流。 忽略了b的24个高位。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ImageOutputStream
        Specified by:
        write在 ImageOutputStreamImpl
        参数
        b - 要写入低8位的 int 。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        描述从接口ImageOutputStream复制
        在当前位置写入一串字节。 如果len为0，则不会写入。 字节b[off]首先写入，然后字节b[off + 1]等等。

        如果流内的位偏移量不为零，则当前字节的剩余部分用0填充并首先写出。 写入后位偏移将为0。 实施者可以使用flushBits的方法ImageOutputStreamImpl来保证这一点。

        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ImageOutputStream
        Specified by:
        write在 ImageOutputStreamImpl
        参数
        b - 要写入的 byte的数组。
        off - 数据中的起始偏移量。
        len - byte的 len的数量。
        异常
        IOException - 如果发生I / O错误。

      • length

        public long length​()
        描述从类复制： ImageInputStreamImpl
        返回-1L以表示该流具有未知长度。 子类必须覆盖此方法以提供实际的长度信息。
        Specified by:
        length在接口 ImageInputStream
        重写：
        length在 ImageInputStreamImpl
        结果
        -1L表示未知长度。

      • isCached

        public boolean isCached​()
        返回 true因为这 ImageOutputStream缓存数据以允许向后搜索。
        Specified by:
        isCached在接口 ImageInputStream
        重写：
        isCached在 ImageInputStreamImpl
        结果
        true 。
        另请参见：
        isCachedMemory() ， isCachedFile()

      • isCachedFile

        public boolean isCachedFile​()
        返回 false因为这个 ImageOutputStream不保存文件缓存。
        Specified by:
        isCachedFile在接口 ImageInputStream
        重写：
        isCachedFile中的 ImageInputStreamImpl
        结果
        false 。
        另请参见：
        isCached() ， isCachedMemory()

      • isCachedMemory

        public boolean isCachedMemory​()
        返回 true因为该 ImageOutputStream维护主内存缓存。
        Specified by:
        isCachedMemory在接口 ImageInputStream
        重写：
        isCachedMemory在 ImageInputStreamImpl
        结果
        true 。
        另请参见：
        isCached() ， isCachedFile()

      • close

        public void close​()
           throws IOException
        关闭此MemoryCacheImageOutputStream 。 所有挂起的数据都被刷新到输出，缓存被释放。 目的地OutputStream未关闭。
        Specified by:
        close接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在接口 ImageInputStream
        重写：
        close在 ImageInputStreamImpl
        异常
        IOException - 如果发生I / O错误。

      • flushBefore

        public void flushBefore​(long pos)
                 throws IOException
        描述从接口ImageInputStream复制
        在指示的位置之前丢弃流的初始部分。 试图寻求在流的冲洗部分内的偏移将导致一个IndexOutOfBoundsException 。

        调用flushBefore可能允许实现此接口的类释放用于存储流中的数据的资源（如内存或磁盘空间）。

        Specified by:
        flushBefore接口 ImageInputStream
        Specified by:
        flushBefore接口 ImageOutputStream
        重写：
        flushBefore在 ImageInputStreamImpl
        参数
        pos - 一个 long其中包含可能被刷新的流前缀的长度。
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.imageio.stream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.imageio.stream

  • Packages that use javax.imageio.stream
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
  • Classes in javax.imageio.stream used by javax.imageio
    Class 描述
    ImageInputStream
    一个可寻求的输入流接口，供 ImageReader使用。
    ImageOutputStream
    一个可寻求的输出流接口，供 ImageWriter使用。
  • Classes in javax.imageio.stream used by javax.imageio.spi
    Class 描述
    ImageInputStream
    一个可寻求的输入流接口，供 ImageReader使用。
    ImageOutputStream
    一个可寻求的输出流接口，供 ImageWriter使用。
  • Classes in javax.imageio.stream used by javax.imageio.stream
    Class 描述
    IIOByteBuffer
    表示对字节数组的可变引用以及该数组中的偏移量和长度的类。
    ImageInputStream
    一个可寻求的输入流接口，供 ImageReader使用。
    ImageInputStreamImpl
    一个实现 ImageInputStream接口的抽象类。
    ImageOutputStream
    一个可寻求的输出流接口，供 ImageWriter使用。
    ImageOutputStreamImpl
    一个实现 ImageOutputStream接口的抽象类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.stream.FileCacheImageInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.stream.FileCacheImageInputStream

No usage of javax.imageio.stream.FileCacheImageInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.stream.FileCacheImageOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.stream.FileCacheImageOutputStream

No usage of javax.imageio.stream.FileCacheImageOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.stream.FileImageInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.stream.FileImageInputStream

No usage of javax.imageio.stream.FileImageInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.stream.FileImageOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.stream.FileImageOutputStream

No usage of javax.imageio.stream.FileImageOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.stream.IIOByteBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.stream.IIOByteBuffer

  • Packages that use IIOByteBuffer
    软件包 描述
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

    • Uses of IIOByteBuffer in javax.imageio.stream

      Methods in javax.imageio.stream with parameters of type IIOByteBuffer
      Modifier and Type | 方法 | 描述
      void ImageInputStream.readBytes​(IIOByteBuffer buf, int len)
      从流中读取最多 len个字节，并修改提供的 IIOByteBuffer以指示可能找到数据的字节数组，偏移量和长度。
      void | ImageInputStreamImpl.readBytes​(IIOByteBuffer buf, int len)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.stream.ImageInputStreamImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.stream.ImageInputStreamImpl

  • Packages that use ImageInputStreamImpl
    软件包 描述
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

    • Uses of ImageInputStreamImpl in javax.imageio.stream

      Subclasses of ImageInputStreamImpl in javax.imageio.stream
      Modifier and Type Class 描述
      class  FileCacheImageInputStream
      一个 ImageInputStream一个实现，从常规的 InputStream获取它的输入。
      class  FileCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
      class  FileImageInputStream
      一个 ImageInputStream一个实现，从 File或 RandomAccessFile获得它的输入。
      class  FileImageOutputStream
      实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。
      class  ImageOutputStreamImpl
      一个实现 ImageOutputStream接口的抽象类。
      class  MemoryCacheImageInputStream
      一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。
      class  MemoryCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.stream.ImageOutputStreamImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.stream.ImageOutputStreamImpl

  • Packages that use ImageOutputStreamImpl
    软件包 描述
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

    • Uses of ImageOutputStreamImpl in javax.imageio.stream

      Subclasses of ImageOutputStreamImpl in javax.imageio.stream
      Modifier and Type Class 描述
      class  FileCacheImageOutputStream
      实现 ImageOutputStream将其输出写入常规 OutputStream 。
      class  FileImageOutputStream
      实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。
      class  MemoryCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.stream.MemoryCacheImageInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.stream.MemoryCacheImageInputStream

No usage of javax.imageio.stream.MemoryCacheImageInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.imageio.stream.MemoryCacheImageOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.imageio.stream.MemoryCacheImageOutputStream

No usage of javax.imageio.stream.MemoryCacheImageOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.stream.ImageInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.stream.ImageInputStream

  • Packages that use ImageInputStream
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

    • Uses of ImageInputStream in javax.imageio

      Methods in javax.imageio that return ImageInputStream
      Modifier and Type 方法 描述
      static ImageInputStream ImageIO.createImageInputStream​(Object input)
      返回一个 ImageInputStream ，它将从给定的 Object获取其输入。
      Methods in javax.imageio with parameters of type ImageInputStream
      Modifier and Type 方法 描述
      static BufferedImage ImageIO.read​(ImageInputStream stream)
      返回 BufferedImage作为解码所提供的 ImageInputStream的结果，其中自动从当前注册的 ImageReader选择一个 ImageReader 。

    • Uses of ImageInputStream in javax.imageio.spi

      Methods in javax.imageio.spi that return ImageInputStream
      Modifier and Type 方法 描述
      ImageInputStream ImageInputStreamSpi.createInputStreamInstance​(Object input)
      返回与该服务提供商相关联的 ImageInputStream实现的实例。
      abstract ImageInputStream ImageInputStreamSpi.createInputStreamInstance​(Object input, boolean useCache, File cacheDir)
      返回与此服务提供商关联的 ImageInputStream实现的实例。

    • Uses of ImageInputStream in javax.imageio.stream

      Subinterfaces of ImageInputStream in javax.imageio.stream
      Modifier and Type 接口 描述
      interface  ImageOutputStream
      一个可寻求的输出流接口，供 ImageWriter使用。
      Classes in javax.imageio.stream that implement ImageInputStream
      Modifier and Type Class 描述
      class  FileCacheImageInputStream
      一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。
      class  FileCacheImageOutputStream
      ImageOutputStream的实现将其输出写入常规的 OutputStream 。
      class  FileImageInputStream
      一个 ImageInputStream的实现，从 File或 RandomAccessFile获取其输入。
      class  FileImageOutputStream
      实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。
      class  ImageInputStreamImpl
      一个实现 ImageInputStream接口的抽象类。
      class  ImageOutputStreamImpl
      一个实现 ImageOutputStream接口的抽象类。
      class  MemoryCacheImageInputStream
      一个 ImageInputStream的实现，从一个常规的 InputStream获取它的输入。
      class  MemoryCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.imageio.stream.ImageOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.imageio.stream.ImageOutputStream

  • Packages that use ImageOutputStream
    软件包 描述
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

    • Uses of ImageOutputStream in javax.imageio

      Methods in javax.imageio that return ImageOutputStream
      Modifier and Type 方法 描述
      static ImageOutputStream ImageIO.createImageOutputStream​(Object output)
      返回一个 ImageOutputStream ，将其输出发送给给定的 Object 。
      Methods in javax.imageio with parameters of type ImageOutputStream
      Modifier and Type 方法 描述
      static boolean ImageIO.write​(RenderedImage im, String formatName, ImageOutputStream output)
      使用支持给定格式的任意 ImageWriter写入图像到 ImageOutputStream 。

    • Uses of ImageOutputStream in javax.imageio.spi

      Methods in javax.imageio.spi that return ImageOutputStream
      Modifier and Type 方法 描述
      ImageOutputStream ImageOutputStreamSpi.createOutputStreamInstance​(Object output)
      返回与该服务提供商相关联的 ImageOutputStream实现的实例。
      abstract ImageOutputStream ImageOutputStreamSpi.createOutputStreamInstance​(Object output, boolean useCache, File cacheDir)
      返回与此服务提供程序相关联的 ImageOutputStream实现的实例。

    • Uses of ImageOutputStream in javax.imageio.stream

      Classes in javax.imageio.stream that implement ImageOutputStream
      Modifier and Type Class 描述
      class  FileCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
      class  FileImageOutputStream
      实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。
      class  ImageOutputStreamImpl
      一个实现 ImageOutputStream接口的抽象类。
      class  MemoryCacheImageOutputStream
      ImageOutputStream的实现将其输出写入常规 OutputStream 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


BasicService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface BasicService

  • public interface BasicService
    BasicService接口提供对应用程序的代码库的访问，如果应用程序以离线模式运行，以及与给定平台上的本机浏览器的简单交互。

    该界面松动地模拟了AppletContext功能。

    从以下版本开始：
    1.4.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      URL getCodeBase​()
      返回应用程序的代码库。
      boolean isOffline​()
      确定系统是否脱机。
      boolean isWebBrowserSupported​()
      检查当前平台和给定的JNLP客户端是否支持Web浏览器。
      boolean showDocument​(URL url)
      指导客户端上的浏览器显示给定的URL。

    • 方法详细信息

      • getCodeBase

        URL getCodeBase​()
        返回应用程序的代码库。 代码库可以直接在JNLP文件中指定，也可以是包含应用程序主类的JAR文件的位置。
        结果
        具有应用程序代码库的URL，如果应用程序从本地文件系统运行，则为null。

      • isOffline

        boolean isOffline​()
        确定系统是否脱机。 返回值表示JNLP客户端在客户端系统的在线/离线状态下的“最佳猜测”。 返回值不必保证是可靠的，因为有时难以确定客户端系统的真实在线/脱机状态。
        结果
        true如果系统脱机，否则为 false

      • showDocument

        boolean showDocument​(URL url)
        指导客户端上的浏览器显示给定的URL。 这通常会替换当前在浏览器中使用给定URL查看的页面，或者导致浏览器启动，该浏览器将显示给定的URL。
        参数
        url - 一个给出文档位置的URL。 相对URL将相对于代码库。
        结果
        true如果请求成功 false如果 url为空或请求失败。

      • isWebBrowserSupported

        boolean isWebBrowserSupported​()
        检查当前平台和给定的JNLP客户端是否支持Web浏览器。 如果不是这样，那么showDocument(java.net.URL)将永远返回false 。
        结果
        true如果支持Web浏览器，否则为 false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ClipboardService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface ClipboardService

  • public interface ClipboardService
    ClipboardService提供了访问共享系统范围的剪贴板的方法，即使是在不受信任的执行环境中运行的应用程序。 实施者应警告用户让不受信任的应用程序可以访问存储在剪贴板中的潜在机密信息或覆盖剪贴板内容的潜在安全隐患。
    从以下版本开始：
    1.4.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Transferable getContents​()
      返回表示剪贴板当前内容的 Transferable对象。
      void setContents​(Transferable contents)
      将剪贴板的当前内容设置为指定的 Transferable对象。

    • 方法详细信息

      • getContents

        Transferable getContents​()
        返回表示剪贴板当前内容的Transferable对象。 如果剪贴板当前没有内容，则返回null。
        结果
        当前 Transferable对象在剪贴板上。

      • setContents

        void setContents​(Transferable contents)
        将剪贴板的当前内容设置为指定的 Transferable对象。
        参数
        contents - 表示剪贴板内容的 Transferable对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DownloadService2 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface DownloadService2

  • public interface DownloadService2
    为JNLP应用程序提供高速缓存查询服务。 与DownloadService中的方法一起，这允许进行高级编程缓存管理。
    从以下版本开始：
    6.0.18

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  DownloadService2.ResourceSpec
      指定资源查询的模式作为参数，并将结果保留在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec)中 。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ALL
      匹配所有资源 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
      static int APPLET
      匹配applet在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
      static int APPLICATION
      匹配应用程序在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
      static int CLASS
      匹配类文件在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
      static int EXTENSION
      匹配扩展在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
      static int IMAGE
      匹配图像文件在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
      static int JAR
      匹配JAR在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      DownloadService2.ResourceSpec[] getCachedResources​(DownloadService2.ResourceSpec spec)
      返回缓存中与指定资源规范之一匹配的所有资源。
      DownloadService2.ResourceSpec[] getUpdateAvailableResources​(DownloadService2.ResourceSpec spec)
      返回缓存中与指定的资源规范之一匹配的所有资源，并具有从其服务器可用的更新。

    • 字段详细信息

      • ALL

        static final int ALL
        匹配 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec)中的所有资源。
        另请参见：
        Constant Field Values

      • APPLICATION

        static final int APPLICATION
        匹配应用程序在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
        另请参见：
        Constant Field Values

      • APPLET

        static final int APPLET
        匹配applet在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
        另请参见：
        Constant Field Values

      • EXTENSION

        static final int EXTENSION
        匹配扩展在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
        另请参见：
        Constant Field Values

      • JAR

        static final int JAR
        匹配JAR在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
        另请参见：
        Constant Field Values

      • IMAGE

        static final int IMAGE
        匹配图像文件在 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
        另请参见：
        Constant Field Values

      • CLASS

        static final int CLASS
        匹配类文件 getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getCachedResources

        DownloadService2.ResourceSpec[] getCachedResources​(DownloadService2.ResourceSpec spec)
        返回缓存中与指定资源规范之一匹配的所有资源。
        对于查询参数中支持的模式，请参阅DownloadService2.ResourceSpec 。 返回的ResourceSpec对象具有特定的URL和版本属性（即没有模式）。
        参数
        spec - 匹配资源的规范
        结果
        所有资源匹配其中一个规格
        异常
        IllegalArgumentException -
        如果ResourceSpec为空，或者
        如果ResourceSpec包含空或空的URL字符串，或
        如果ResourceSpec包含无效的正则表达式。
        如果ResourceSpec包含不是以下类型之一：
        ALL，APPLICATION，APPLET，EXTENSION，JAR，IMAGE或CLASS。

      • getUpdateAvailableResources

        DownloadService2.ResourceSpec[] getUpdateAvailableResources​(DownloadService2.ResourceSpec spec)
                                                     throws IOException
        返回缓存中与指定的资源规范之一匹配的所有资源，并具有从其服务器可用的更新。
        对于查询参数中支持的模式，请参阅DownloadService2.ResourceSpec 。 返回的ResourceSpec对象具有特定的URL和版本属性（即没有模式）。
        注意：此调用可能会尝试HTTP GET请求来检查更新。
        参数
        spec - 匹配资源的规范
        结果
        所有可用于与其中一个规范匹配的更新的资源
        异常
        IOException - 更新检查中是否出现问题
        IllegalArgumentException -
        如果ResourceSpec为空，或者
        如果ResourceSpec包含空或空的URL字符串，或
        如果ResourceSpec包含无效的正则表达式。
        如果ResourceSpec包含不是以下类型之一：
        ALL，APPLICATION，APPLET，EXTENSION，JAR，IMAGE或CLASS。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


DownloadService2.ResourceSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Class DownloadService2.ResourceSpec

  • java.lang.Object
    • javax.jnlp.DownloadService2.ResourceSpec
  • Enclosing interface:
    DownloadService2

    public static class DownloadService2.ResourceSpec
extends Object
    指定资源查询的模式作为参数，并将结果保留在DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec)中 。
    对于url和version属性，支持{code java.util.regex}中记录的标准正则表达式。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ResourceSpec​(String url, String version, int type)
      创建一个新的ResourceSpec实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      long getExpirationDate​()
      返回资源到期的时间。
      long getLastModified​()
      返回上次修改资源的时间。
      long getSize​()
      返回资源的大小。
      int getType​()
      返回此资源的类型。
      String getUrl​()
      返回此资源的URL。
      String getVersion​()
      返回此资源的版本。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ResourceSpec

        public ResourceSpec​(String url,
                    String version,
                    int type)
        创建一个新的ResourceSpec实例。
        参数
        url - URL模式
        version - 版本模式
        type - 资源类型。 这应该是DownloadService2中定义的以下常量之一：ALL，APPLICATION，APPLET，EXTENSION，JAR，IMAGE或CLASS。

    • 方法详细信息

      • getUrl

        public String getUrl​()
        返回此资源的URL。
        结果
        该资源的URL

      • getVersion

        public String getVersion​()
        返回此资源的版本。
        结果
        该资源的版本

      • getType

        public int getType​()
        返回此资源的类型。
        结果
        该资源的类型

      • getSize

        public long getSize​()
        返回资源的大小。 这仅对作为DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)或DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec)的结果返回的ResourceSpecs有用。
        结果
        资源的大小

      • getLastModified

        public long getLastModified​()
        返回上次修改资源的时间。
        返回的值与System.currentTimeMillis（）的返回值具有相同的语义。
        值0表示未知数。
        结果
        上次修改资源的时间

      • getExpirationDate

        public long getExpirationDate​()
        返回资源到期的时间。
        返回的值与System.currentTimeMillis（）的返回值具有相同的语义。
        值0意味着未知数。
        结果
        the time of expiration of the resource
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DownloadService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface DownloadService

  • public interface DownloadService
    DownloadService服务允许应用程序控制自己的资源如何缓存，以确定当前缓存哪些资源，强制资源被缓存，以及从缓存中删除资源。 JNLP客户端负责提供此服务的具体实现。
    从以下版本开始：
    1.4.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      DownloadServiceListener getDefaultProgressWindow​()
      返回一个默认的DownloadServiceListener实现，当传递给一个load方法时，应该在加载进度时弹出并更新进度窗口。
      boolean isExtensionPartCached​(URL ref, String version, String part)
      如果给定的扩展名的给定部分被缓存，并且在应用程序的JNLP文件中提到扩展名和部分，则返回 true 。
      boolean isExtensionPartCached​(URL ref, String version, String[] parts)
      如果给定的扩展名的给定部分被缓存，并且在应用程序的JNLP文件中提及扩展和部件，则返回 true 。
      boolean isPartCached​(String part)
      如果给定字符串引用的部分被缓存，并且该部分在应用程序的JNLP文件中被提到，则返回 true 。
      boolean isPartCached​(String[] parts)
      如果给定数组引用的部分被缓存，并且这些部分在应用程序的JNLP文件中被提到，则返回 true 。
      boolean isResourceCached​(URL ref, String version)
      如果给定的URL和版本引用的资源被缓存，并且该资源在调用应用程序JNLP文件中被提及，则在调用应用程序JNLP文件的代码库中，或者调用应用程序已被授予所有权限，则返回true 。 。
      void loadExtensionPart​(URL ref, String version, String[] parts, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了部件和扩展名，请下载给定扩展的给定部分。
      void loadExtensionPart​(URL ref, String version, String part, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了部分和扩展名，请下载给定扩展的给定部分。
      void loadPart​(String[] parts, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了这些部分，请下载给定的部分。
      void loadPart​(String part, DownloadServiceListener progress)
      下载给定的部分，如果该部分在应用程序的JNLP文件中被提到。
      void loadResource​(URL ref, String version, DownloadServiceListener progress)
      如果在调用的应用程序JNLP文件中提到资源，请下载给定的资源，是在调用应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。
      void removeExtensionPart​(URL ref, String version, String part)
      如果在应用程序的JNLP文件中提到了部分和扩展名，则从缓存中删除给定扩展的给定部分。
      void removeExtensionPart​(URL ref, String version, String[] parts)
      如果在应用程序的JNLP文件中提到了部件和扩展名，则从缓存中删除给定扩展的给定部分。
      void removePart​(String part)
      如果在应用程序的JNLP文件中提到了该部分，则从缓存中删除给定的部分。
      void removePart​(String[] parts)
      如果在应用程序的JNLP文件中提到了这些部分，则从缓存中删除给定的部分。
      void removeResource​(URL ref, String version)
      如果在调用应用程序JNLP文件中提到资源，则从缓存中删除给定的资源，在调用的应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。

    • 方法详细信息

      • isResourceCached

        boolean isResourceCached​(URL ref,
                         String version)
        如果给定的URL和版本引用的资源被缓存，并且该资源在调用应用程序JNLP文件中被提及，则在调用应用程序JNLP文件的代码库中，或者调用应用程序已被授予所有权限，则返回true 。 。
        参数
        ref - 资源的URL。
        version - 版本字符串，或 null ，无版本。
        结果
        true如果满足上述条件，并且 false否则。

      • isPartCached

        boolean isPartCached​(String part)
        如果给定字符串引用的部分被缓存，并且该部分在应用程序的JNLP文件中被提到，则返回 true 。
        参数
        part - 零件的名称。
        结果
        true如果满足上述条件，并且 false否则。

      • isPartCached

        boolean isPartCached​(String[] parts)
        如果给定数组引用的部分被缓存，并且这些部分在应用程序的JNLP文件中被提到，则返回 true 。
        参数
        parts - 部件名称数组。
        结果
        true如果满足上述条件，并且 false否则。

      • isExtensionPartCached

        boolean isExtensionPartCached​(URL ref,
                              String version,
                              String part)
        如果给定的扩展名的给定部分被缓存，并且扩展名和部分在JNLP文件中被提及，则返回 true 。
        参数
        ref - 资源的URL。
        version - 版本字符串，或 null ，无版本。
        part - 零件的名称。
        结果
        true如果满足上述条件，并且 false否则。

      • isExtensionPartCached

        boolean isExtensionPartCached​(URL ref,
                              String version,
                              String[] parts)
        如果给定扩展的给定部分被缓存，并且在应用程序的JNLP文件中提到扩展和部件，则返回 true 。
        参数
        ref - 资源的URL。
        version - 版本字符串，或 null ，无版本。
        parts - 零件名称数组。
        结果
        true如果满足上述条件，并且 false否则。

      • loadResource

        void loadResource​(URL ref,
                  String version,
                  DownloadServiceListener progress)
           throws IOException
        如果在调用的应用程序JNLP文件中提到资源，请下载给定的资源，是在调用应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。 此方法将阻塞，直到下载完成或发生异常。
        参数
        ref - 资源的URL。
        version - 版本字符串，或 null ，无版本。
        progress - 下载进度回调对象。
        异常
        IOException - 如果发生I / O错误

      • loadPart

        void loadPart​(String part,
              DownloadServiceListener progress)
       throws IOException
        下载给定的部分，如果该部分在应用程序的JNLP文件中被提到。 此方法将阻塞，直到下载完成或发生异常。
        参数
        part - 零件的名称。
        progress - 下载进度回调对象。
        异常
        IOException - 如果发生I / O错误

      • loadPart

        void loadPart​(String[] parts,
              DownloadServiceListener progress)
       throws IOException
        如果在应用程序的JNLP文件中提到了这些部分，请下载给定的部分。 此方法将阻塞，直到下载完成或发生异常。
        参数
        parts - 零件名称数组。
        progress - 下载进度回调对象。
        异常
        IOException - 如果发生I / O错误

      • loadExtensionPart

        void loadExtensionPart​(URL ref,
                       String version,
                       String part,
                       DownloadServiceListener progress)
                throws IOException
        如果在应用程序的JNLP文件中提到了部分和扩展名，请下载给定扩展的给定部分。 此方法将阻塞，直到下载完成或发生异常。
        参数
        ref - 资源的URL。
        version - 版本字符串，或 null ，无版本。
        part - 零件的名称。
        progress - 下载进度回调对象。
        异常
        IOException - 如果发生I / O错误

      • loadExtensionPart

        void loadExtensionPart​(URL ref,
                       String version,
                       String[] parts,
                       DownloadServiceListener progress)
                throws IOException
        如果在应用程序的JNLP文件中提到了部件和扩展名，请下载给定扩展的给定部分。 此方法将阻塞，直到下载完成或发生异常。
        参数
        ref - 资源的URL。
        version - 版本字符串，或 null ，无版本。
        parts - 要加载的零件名称数组。
        progress - 下载进度回调对象。
        异常
        IOException - 如果发生I / O错误

      • removeResource

        void removeResource​(URL ref,
                    String version)
             throws IOException
        如果在调用应用程序JNLP文件中提到资源，则从缓存中删除给定的资源，在调用的应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。
        参数
        ref - 资源的URL。
        version - 版本字符串，或 null无版本。
        异常
        IOException - 如果发生I / O错误

      • removePart

        void removePart​(String part)
         throws IOException
        如果在应用程序的JNLP文件中提到了该部分，则从缓存中删除给定的部分。
        参数
        part - 零件的名称。
        异常
        IOException - 如果发生I / O错误

      • removePart

        void removePart​(String[] parts)
         throws IOException
        如果在应用程序的JNLP文件中提到了这些部分，则从缓存中删除给定的部分。
        参数
        parts - 零件名称数组。
        异常
        IOException - 如果发生I / O错误

      • removeExtensionPart

        void removeExtensionPart​(URL ref,
                         String version,
                         String part)
                  throws IOException
        如果在应用程序的JNLP文件中提到了部分和扩展名，则从缓存中删除给定扩展的给定部分。
        参数
        ref - 资源的URL。
        version - 版本字符串，或 null ，无版本。
        part - 零件的名称。
        异常
        IOException - 如果发生I / O错误

      • removeExtensionPart

        void removeExtensionPart​(URL ref,
                         String version,
                         String[] parts)
                  throws IOException
        如果在应用程序的JNLP文件中提到了部件和扩展名，则从缓存中删除给定扩展的给定部分。
        参数
        ref - 资源的URL。
        version - 版本字符串，或 null ，无版本。
        parts - 零件名称数组。
        异常
        IOException - 如果发生I / O错误

      • getDefaultProgressWindow

        DownloadServiceListener getDefaultProgressWindow​()
        返回一个默认的DownloadServiceListener实现，当传递给一个load方法时，应该在加载进度时弹出并更新进度窗口。
        结果
        A DownloadServiceListener object representing a download progress listener.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DownloadServiceListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface DownloadServiceListener

  • public interface DownloadServiceListener
    DownloadServiceListener提供了一个回调对象实现的接口，可以由一个DownloadService实现使用。 DownloadServiceListener实现的方法应由DownloadService实现在不同的下载阶段调用，允许使用JNLP API的应用程序在DownloadService下载期间显示进度条。
    从以下版本开始：
    1.4.2
    另请参见：
    DownloadService

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void downloadFailed​(URL url, String version)
      如果下载失败或意外中止，JNLP客户端的 DownloadService实现应该调用此方法。
      void progress​(URL url, String version, long readSoFar, long total, int overallPercent)
      一个JNLP客户端的 DownloadService实现应该在下载过程中多次调用该方法。
      void upgradingArchive​(URL url, String version, int patchPercent, int overallPercent)
      JNLP客户端的 DownloadService实现在将缓存资源应用增量更新时至少应该调用此方法。
      void validating​(URL url, String version, long entry, long total, int overallPercent)
      JNLP客户端的 DownloadService实现在验证下载过程中至少应该调用此方法。

    • 方法详细信息

      • progress

        void progress​(URL url,
              String version,
              long readSoFar,
              long total,
              int overallPercent)
        JNLP客户端的DownloadService实现应该在下载过程中多次调用此方法。 A DownloadServiceListener实现可以基于参数显示进度条和/或更新信息。
        参数
        url - 表示正在下载的资源的URL。
        version - 正在下载的资源的版本。
        readSoFar - 到目前为止下载的字节数。
        total - 要下载的字节总数，如果数字未知，则为-1。
        overallPercent - 完整更新操作的百分比，如果百分比未知，则为-1。

      • validating

        void validating​(URL url,
                String version,
                long entry,
                long total,
                int overallPercent)
        JNLP客户端的DownloadService实现在验证下载过程中应至少调用此方法。 验证通常包括确保下载的资源是真实的（适当签名的）。 A DownloadServiceListener实现可以基于参数显示进度条和/或更新信息。
        参数
        url - 表示正在验证的资源的URL。
        version - 要验证的资源的版本。
        entry - 到目前为止验证的JAR条目数。
        total - 要验证的条目总数。
        overallPercent - 完整更新操作的百分比，如果百分比未知，则为-1。

      • upgradingArchive

        void upgradingArchive​(URL url,
                      String version,
                      int patchPercent,
                      int overallPercent)
        JNLP客户端的DownloadService实现在将缓存资源应用增量更新时至少应该调用此方法。 A DownloadServiceListener实现可以基于参数显示进度条和/或更新信息。
        参数
        url - 表示正在修补的资源的URL。
        version - 正在修补的资源的版本。
        patchPercent - 完成补丁操作的百分比，如果百分比未知，则为-1。
        overallPercent - 完整更新操作的百分比，如果百分比未知，则为-1。

      • downloadFailed

        void downloadFailed​(URL url,
                    String version)
        如果下载失败或意外中止，JNLP客户端的DownloadService实现应该调用此方法。 作为响应， DownloadServiceListener实现可以向用户显示更新信息以反映这一点。
        参数
        url - 表示下载失败的资源的URL。
        version - 下载失败的资源的版本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExtendedService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface ExtendedService

  • public interface ExtendedService
    ExtendedService为当前的JNLP API提供了额外的支持，允许应用程序在客户端的文件系统中打开特定的文件。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      FileContents openFile​(File file)
      允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。
      FileContents[] openFiles​(File[] files)
      允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。

    • 方法详细信息

      • openFile

        FileContents openFile​(File file)
               throws IOException
        允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。 如果应用程序没有其他权限访问该文件，JNLP CLient应该向用户警告潜在的安全风险。 该文件的内容作为一个FileContents对象返回。
        参数
        file - 文件对象
        结果
        A FileContents对象，其中包含有关打开文件的信息
        异常
        IOException - - 如果有任何I / O错误

      • openFiles

        FileContents[] openFiles​(File[] files)
                  throws IOException
        允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。 如果应用程序不具有访问文件的权限，JNLP CLient应该向用户警告潜在的安全风险。 每个file的内容在FileContents数组中作为FileContents对象返回。
        参数
        files - 文件数组
        结果
        A FileContents[]对象，其中包含有关每个打开的文件的信息
        异常
        IOException - - 如果有任何I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExtensionInstallerService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface ExtensionInstallerService

  • public interface ExtensionInstallerService
    ExtensionInstallerService由扩展安装程序用于与JNLP客户端通信。 它提供以下类型的功能：
    • 访问优先安装位置，以及有关JNLP客户端的其他信息
    • 操纵JNLP客户端的下载屏幕
    • 使用已安装代码更新JNLP客户端的方法

    安装程序的正常事件顺序是：

    1. 使用ServiceManager.lookup("javax.jnlp.ExtensionInstallerService")获取服务。
    2. 更新状态，航向和安装进展（进展setStatus ， setHeading和updateProgress ）。
    3. 根据是否安装JRE或库，调用setJREInfo或setNativeLibraryInfo
    4. 如果成功调用installSucceeded ，否则调用installFailed 。
    从以下版本开始：
    1.4.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      URL getExtensionLocation​()
      返回正在安装的扩展的位置
      String getExtensionVersion​()
      返回正在安装的扩展程序的版本
      String getInstalledJRE​(URL url, String version)
      返回给定JRE的可执行文件的路径。
      String getInstallPath​()
      返回安装程序建议安装扩展程序的目录。
      void hideProgressBar​()
      隐藏进度条。
      void hideStatusWindow​()
      隐藏状态窗口。
      void installFailed​()
      如果安装失败，应该调用这个。
      void installSucceeded​(boolean needsReboot)
      成功安装扩展程序后，安装程序应调用此操作。
      void setHeading​(String heading)
      更新进度窗口的标题文本。
      void setJREInfo​(String platformVersion, String jrePath)
      通知JNLP客户端JRE的可执行文件的路径，如果这是JRE的安装程序，以及该JRE实现的平台版本。
      void setNativeLibraryInfo​(String path)
      通知JNLP客户端应搜索本机库的目录。
      void setStatus​(String status)
      更新进度窗口的状态文本。
      void updateProgress​(int value)
      更新进度条。

    • 方法详细信息

      • getInstallPath

        String getInstallPath​()
        返回安装程序建议安装扩展程序的目录。安装程序不需要安装在此目录中，这只是一个建议的路径。
        结果
        建议安装程序安装扩展程序的目录

      • getExtensionVersion

        String getExtensionVersion​()
        返回正在安装的扩展程序的版本
        结果
        正在安装的扩展版本

      • getExtensionLocation

        URL getExtensionLocation​()
        返回正在安装的扩展的位置
        结果
        扩展的位置被安装

      • hideProgressBar

        void hideProgressBar​()
        隐藏进度条。 任何后续调用updateProgress将强制它可见。

      • hideStatusWindow

        void hideStatusWindow​()
        隐藏状态窗口。 如果您要向用户提供有关安装进度的反馈意见，则应该仅调用此方法。

      • setHeading

        void setHeading​(String heading)
        更新进度窗口的标题文本。
        参数
        heading - 标题文本

      • setStatus

        void setStatus​(String status)
        更新进度窗口的状态文本。
        参数
        status - 状态文本

      • updateProgress

        void updateProgress​(int value)
        更新进度条。
        参数
        value - 进度条值 - 应在0到100之间。

      • installSucceeded

        void installSucceeded​(boolean needsReboot)
        成功安装扩展程序后，安装程序应调用此操作。 这将导致JNLP客户端重新获得控制权并继续其正常运行。
        参数
        needsReboot - 如果为真，则需要重新启动

      • installFailed

        void installFailed​()
        如果安装失败，应该调用这个。 JNLP客户端将继续运行，并通知用户安装失败。

      • setJREInfo

        void setJREInfo​(String platformVersion,
                String jrePath)
        通知JNLP客户端JRE的可执行文件的路径，如果这是JRE的安装程序，以及该JRE实现的平台版本。
        参数
        platformVersion - 这个JRE实现的平台版本
        jrePath - JRE可执行文件的路径

      • setNativeLibraryInfo

        void setNativeLibraryInfo​(String path)
        通知JNLP客户端应搜索本机库的目录。
        参数
        path - 本机库的搜索路径

      • getInstalledJRE

        String getInstalledJRE​(URL url,
                       String version)
        返回给定JRE的可执行文件的路径。 该方法可以由需要在给定JRE中查找信息的扩展使用，或增强给定的JRE。
        参数
        url - JRE的产品位置
        version - JRE的产品版本
        结果
        给定JRE的可执行文件的路径，如果没有安装JRE， null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileContents (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface FileContents

  • public interface FileContents
    FileContents对象封装文件的名称和内容。 这个类的实现是由使用FileOpenService ， FileSaveService ，并PersistenceService 。

    该FileContents实现由归国PersistenceService.get(java.net.URL) ， FileOpenService ，并FileSaveService如果最大文件长度被设定为小于当前文件长度不应该截断的文件。

    从以下版本开始：
    1.4.2
    另请参见：
    FileOpenService ， FileSaveService

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean canRead​()
      返回是否可以读取文件。
      boolean canWrite​()
      返回是否可以写入文件。
      InputStream getInputStream​()
      从文件获取一个 InputStream 。
      long getLength​()
      获取文件的长度。
      long getMaxLength​()
      获取文件的最大文件长度，由此对象的创建者设置。
      String getName​()
      获取文件名为 String 。
      OutputStream getOutputStream​(boolean overwrite)
      获取一个 OutputStream的文件。
      JNLPRandomAccessFile getRandomAccessFile​(String mode)
      返回一个 JNLPRandomAccessFile表示文件内容的随机访问接口。
      long setMaxLength​(long maxlength)
      设置文件的最大文件长度。

    • 方法详细信息

      • getName

        String getName​()
        throws IOException
        获取文件名为 String 。
        结果
        一个包含文件名的字符串。
        异常
        IOException - 如果发生I / O异常。

      • getInputStream

        InputStream getInputStream​()
                    throws IOException
        从文件获取 InputStream 。
        结果
        一个InputStream到文件。
        异常
        IOException - 如果发生I / O异常。

      • getOutputStream

        OutputStream getOutputStream​(boolean overwrite)
                      throws IOException
        获取该文件的OutputStream 。 JNLP客户端可以实现此接口以返回一个OutputStream子类，该子类限制可以写入流的数据量。
        参数
        overwrite - 如果是 true ，则字节将被写入文件的开头，而不是结束
        结果
        一个来自文件的OutputStream。
        异常
        IOException - 如果发生I / O异常。

      • getLength

        long getLength​()
        throws IOException
        获取文件的长度。
        结果
        文件长度长。
        异常
        IOException - 如果发生I / O异常。

      • canRead

        boolean canRead​()
         throws IOException
        返回是否可以读取文件。
        结果
        如果文件可以读取，则为true，否则为false。
        异常
        IOException - 如果发生I / O异常。

      • canWrite

        boolean canWrite​()
          throws IOException
        返回是否可以写入文件。
        结果
        如果文件可以读取，则为true，否则为false。
        异常
        IOException - 如果发生I / O异常。

      • getRandomAccessFile

        JNLPRandomAccessFile getRandomAccessFile​(String mode)
                                  throws IOException
        返回表示文件内容的随机访问接口的JNLPRandomAccessFile 。 模式参数必须等于“r”或“rw”，表示文件将分别仅为输入或输入和输出打开。 如果模式不等于“r”或“rw”，将抛出IllegalArgumentException异常。
        参数
        mode - 访问模式。
        结果
        一个JNLPRandomAccessFile。
        异常
        IOException - 如果发生I / O异常。

      • getMaxLength

        long getMaxLength​()
           throws IOException
        获取文件的最大文件长度，由此对象的创建者设置。
        结果
        文件的最大长度。
        异常
        IOException - 如果发生I / O异常。

      • setMaxLength

        long setMaxLength​(long maxlength)
           throws IOException
        设置文件的最大文件长度。 JNLP客户端可能会强制设置最大文件长度的限制。 如果最大文件长度设置为小于当前文件大小，则JNLP客户端不应截断文件，但也不应允许进一步写入该文件。
        参数
        maxlength - 请求的最大文件长度。
        结果
        授予的最大文件长度。
        异常
        IOException - 如果发生I / O异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileOpenService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface FileOpenService

  • public interface FileOpenService
    FileOpenService服务允许用户从本地文件系统中选择一个文件，即使是在不受信任的执行环境中运行的应用程序。 JNLP客户端是调解员，因此负责提供具体的实现（如果有的话）。

    此服务提供与基于HTML的表单的文件输入字段类似的功能。

    从以下版本开始：
    1.4.2
    另请参见：
    FileSaveService ， FileContents

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      FileContents openFileDialog​(String pathHint, String[] extensions)
      要求用户选择一个文件。
      FileContents[] openMultiFileDialog​(String pathHint, String[] extensions)
      要求用户选择一个或多个文件。

    • 方法详细信息

      • openFileDialog

        FileContents openFileDialog​(String pathHint,
                            String[] extensions)
                     throws IOException
        要求用户选择一个文件。 所选文件的内容将作为FileContents对象返回。 返回的FileContents对象包含内容以及文件的名称。 完整路径不返回。
        参数
        pathHint - 从应用程序到文件选择器的初始目录的提示。 这可能会被JNLP客户端忽略。
        extensions - 在文件选择器中显示的默认扩展名列表。 例如， String[] { "txt", "java" } 。 这可能会被JNLP客户端忽略。
        结果
        A FileContent对象，其中包含有关所选文件的信息，如果用户未选择文件， null 。
        异常
        IOException - 如果请求以任何方式失败，除了用户没有选择选择文件。

      • openMultiFileDialog

        FileContents[] openMultiFileDialog​(String pathHint,
                                   String[] extensions)
                            throws IOException
        要求用户选择一个或多个文件。 所选文件的内容作为FileContents对象的数组返回。 返回的FileContents对象包含内容以及文件的名称。 完整路径不返回。
        参数
        pathHint - 从应用程序到文件选择器的初始目录的提示。 这可能会被JNLP客户端忽略。
        extensions - 在文件选择器中显示的默认扩展名列表。 例如， String[] { "txt", "java" } 。 这可能会被JNLP客户端忽略。
        结果
        一组 FileContent对象，其中包含有关所选文件的信息，如果用户没有选择文件， null 。
        异常
        IOException - 如果请求以任何方式失败，除了用户没有选择选择文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileSaveService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface FileSaveService

  • public interface FileSaveService
    FileSaveService服务允许用户将文件保存到本地文件系统，即使是在不受信任的执行环境中运行的应用程序。 JNLP客户端是调解员，因此负责提供具体的实现（如果有的话）。

    此服务提供与大多数浏览器提供的“ 另存为”功能相似的功能。

    从以下版本开始：
    1.4.2
    另请参见：
    FileOpenService ， FileContents

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      FileContents saveAsFileDialog​(String pathHint, String[] extensions, FileContents contents)
      要求用户保存文件。
      FileContents saveFileDialog​(String pathHint, String[] extensions, InputStream stream, String name)
      要求用户保存文件。

    • 方法详细信息

      • saveFileDialog

        FileContents saveFileDialog​(String pathHint,
                            String[] extensions,
                            InputStream stream,
                            String name)
                     throws IOException
        要求用户保存文件。
        参数
        pathHint - 从应用程序到要使用的默认目录的提示。 这可能会被JNLP客户端忽略。
        extensions - 在文件选择器中显示的默认扩展名列表。 例如， String[] { "txt", "java" } 。 这些可能会被JNLP客户端忽略。
        stream - 要保存的文件的内容表示为 InputStream
        name - 建议的文件名，可能被JNLP客户端忽略
        结果
        A FileContents对象为保存的文件，如果保存成功，或 null如果用户取消了请求。
        异常
        IOException - 如果请求失败，除了用户选择不保存文件以外的任何方式

      • saveAsFileDialog

        FileContents saveAsFileDialog​(String pathHint,
                              String[] extensions,
                              FileContents contents)
                       throws IOException
        要求用户保存文件。
        参数
        pathHint - 从应用程序到要使用的默认目录的提示。 这可能会被JNLP客户端忽略。
        extensions - 在文件选择器中显示的默认扩展名列表。 例如， String[] { "txt", "java" } 。 这些可能会被JNLP客户端忽略。
        contents - 要保存的文件的内容以及建议的文件名。 建议的文件名可能会被JNLP客户端忽略。
        结果
        A FileContents保存文件的对象，如果保存成功，或 null如果用户取消了请求。
        异常
        IOException - 如果请求失败，除了用户选择不保存文件以外的任何方式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IntegrationService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface IntegrationService

  • public interface IntegrationService
    为JNLP应用程序提供桌面集成。 特别地，该服务提供API以编程方式请求，查询和删除快捷方式，并请求，查询和删除mimetype关联。
    从以下版本开始：
    6.0.18

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean hasAssociation​(String mimetype, String[] extensions)
      检查此应用程序是否与指定的mimetype和文件扩展名相关联。
      boolean hasDesktopShortcut​()
      检查应用程序是否具有桌面快捷方式。
      boolean hasMenuShortcut​()
      检查应用程序是否具有菜单快捷方式。
      boolean removeAssociation​(String mimetype, String[] extensions)
      删除此应用程序的关联作为指定的mimetype的处理程序。
      boolean removeShortcuts​()
      请求删除应用程序的所有快捷方式。
      boolean requestAssociation​(String mimetype, String[] extensions)
      请求将此应用程序注册为指定的MIME类型和文件扩展名的处理程序。
      boolean requestShortcut​(boolean desktop, boolean menu, String submenu)
      请求为此应用程序创建快捷方式。

    • 方法详细信息

      • requestShortcut

        boolean requestShortcut​(boolean desktop,
                        boolean menu,
                        String submenu)
        请求为此应用程序创建快捷方式。 它可以指定出现在系统菜单中，桌面上或两者上。 对于菜单，可以指定应该放置快捷方式的子菜单路径。 具有空或空字符串的菜单请求将将菜单项放在（依赖于平台）的默认菜单路径中。
        参数
        desktop - true如果快捷方式应该出现在桌面上
        menu - true如果快捷方式应出现在系统菜单中
        submenu - 放置快捷方式的子菜单的路径（仅当菜单为真时才有意义）。
        该路径是相对于（依赖于平台的）默认菜单路径。
        结果
        true如果给定的menu和desktop都为假，或者menu和desktop请求的所有快捷方式都已成功创建。 否则为false 。

      • hasDesktopShortcut

        boolean hasDesktopShortcut​()
        检查应用程序是否具有桌面快捷方式。
        结果
        true如果应用程序有一个桌面快捷方式，否则为 false

      • hasMenuShortcut

        boolean hasMenuShortcut​()
        检查应用程序是否具有菜单快捷方式。
        结果
        true如果应用程序有菜单快捷方式，否则为 false

      • removeShortcuts

        boolean removeShortcuts​()
        请求删除应用程序的所有快捷方式。
        结果
        true如果快捷方式已成功删除 false否则

      • requestAssociation

        boolean requestAssociation​(String mimetype,
                           String[] extensions)
        请求将此应用程序注册为指定的MIME类型和文件扩展名的处理程序。
        参数
        mimetype - 将此应用程序注册为该处理程序的mimetype
        extensions - 将此应用程序注册为处理程序的文件扩展名
        结果
        true如果应用程序已成功关联，否则为 false
        异常
        IllegalArgumentException - 如果 mimetype或 extensions是 null ，或者如果 mimetype具有非法的MIME类型语法，或者如果 extensions包含 null或空元素

      • hasAssociation

        boolean hasAssociation​(String mimetype,
                       String[] extensions)
        检查此应用程序是否与指定的mimetype和文件扩展名相关联。
        参数
        mimetype - 检查关联的mimetype
        extensions - 检查关联的文件扩展名
        结果
        true如果此应用程序与指定的mimetype和文件扩展名相关联，否则为 false
        异常
        IllegalArgumentException - 如果 mimetype或 extensions是 null ，或者如果 mimetype具有非法的MIME类型语法，或者如果 extensions为空或包含 null或空元素

      • removeAssociation

        boolean removeAssociation​(String mimetype,
                          String[] extensions)
        删除此应用程序的关联作为指定的mimetype的处理程序。
        参数
        mimetype - 删除关联的mimetype
        extensions - 删除关联的文件扩展名
        结果
        true如果关联已成功删除，否则为 false
        异常
        IllegalArgumentException - 如果 mimetype或 extensions是 null ，或者如果 mimetype具有非法的MIME类型语法，或者如果 extensions包含 null或空元素
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.jnlp (Java SE 9 & JDK 9 )

javax.jnlp

Interfaces

  • BasicService
  • ClipboardService
  • DownloadService
  • DownloadService2
  • DownloadServiceListener
  • ExtendedService
  • ExtensionInstallerService
  • FileContents
  • FileOpenService
  • FileSaveService
  • IntegrationService
  • JNLPRandomAccessFile
  • PersistenceService
  • PrintService
  • ServiceManagerStub
  • SingleInstanceListener
  • SingleInstanceService

Classes

  • DownloadService2.ResourceSpec
  • ServiceManager

Exceptions

  • UnavailableServiceException


javax.jnlp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.jnlp

Package javax.jnlp

JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

使用ServiceManager确定哪些服务可用，并访问这些服务。

从以下版本开始：
1.4.2
另请参见：
ServiceManager
  • 接口摘要
    接口 描述
    BasicService
    BasicService接口提供对应用程序的代码库的访问，如果应用程序以离线模式运行，以及与给定平台上的本机浏览器的简单交互。
    ClipboardService
    ClipboardService提供了访问共享系统范围的剪贴板的方法，即使是在不受信任的执行环境中运行的应用程序。
    DownloadService
    DownloadService服务允许应用程序控制自己的资源如何被缓存，以确定当前缓存其资源，强制资源被缓存，以及从缓存中删除资源。
    DownloadService2
    为JNLP应用程序提供高速缓存查询服务。
    DownloadServiceListener
    DownloadServiceListener提供了一个回调对象实现的接口，可以由一个DownloadService实现使用。
    ExtendedService
    ExtendedService为当前的JNLP API提供了额外的支持，允许应用程序在客户端的文件系统中打开一个特定的文件。
    ExtensionInstallerService
    ExtensionInstallerService由扩展安装程序用于与JNLP客户端进行通信。
    FileContents
    FileContents对象封装文件的名称和内容。
    FileOpenService
    FileOpenService服务允许用户从本地文件系统中选择一个文件，即使是在不受信任的执行环境中运行的应用程序。
    FileSaveService
    FileSaveService服务允许用户将文件保存到本地文件系统，即使是在不受信任的执行环境中运行的应用程序。
    IntegrationService
    为JNLP应用程序提供桌面集成。
    JNLPRandomAccessFile
    该类的实例支持读取和写入随机访问文件。
    PersistenceService
    PersistenceService提供了在客户端系统上本地存储数据的方法，即使对于在不受信任的执行环境中运行的应用程序也是如此。
    PrintService
    PrintService提供了访问打印功能的方法，即使是在不受信任的执行环境中运行的应用程序。
    ServiceManagerStub
    A ServiceManagerStub对象实现JNLP客户端对JNLP服务的特定查找。
    SingleInstanceListener
    SingleInstanceListener是一个JNLP应用程序如果希望支持单实例行为应该实现的接口。
    SingleInstanceService
    SingleInstanceService允许在Java Web Start下启动的应用程序将其自身注册为单例，并在用户尝试启动其新实例时传递新的参数集。
  • 类摘要
    Class 描述
    DownloadService2.ResourceSpec
    指定资源查询的模式作为参数，并将结果保留在 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec)中 。
    ServiceManager
    ServiceManager提供了查找JNLP服务的静态方法。
  • 异常摘要
    异常 描述
    UnavailableServiceException
    当 UnavailableServiceException不存在或不可用的服务时， UnavailableServiceException被抛出 ServiceManager 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.jnlp Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.jnlp

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.jnlp.DownloadService2.ResourceSpec
    • javax.jnlp.ServiceManager
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • javax.jnlp.UnavailableServiceException

Interface Hierarchy

  • javax.jnlp.BasicService
  • javax.jnlp.ClipboardService
  • java.io.DataInput
    • javax.jnlp.JNLPRandomAccessFile (also extends java.io.DataOutput)
  • java.io.DataOutput
    • javax.jnlp.JNLPRandomAccessFile (also extends java.io.DataInput)
  • javax.jnlp.DownloadService
  • javax.jnlp.DownloadService2
  • javax.jnlp.DownloadServiceListener
  • javax.jnlp.ExtendedService
  • javax.jnlp.ExtensionInstallerService
  • javax.jnlp.FileContents
  • javax.jnlp.FileOpenService
  • javax.jnlp.FileSaveService
  • javax.jnlp.IntegrationService
  • javax.jnlp.PersistenceService
  • javax.jnlp.PrintService
  • javax.jnlp.ServiceManagerStub
  • javax.jnlp.SingleInstanceListener
  • javax.jnlp.SingleInstanceService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


JNLPRandomAccessFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface JNLPRandomAccessFile

  • All Superinterfaces:
    DataInput ， DataOutput

    public interface JNLPRandomAccessFile
extends DataInput, DataOutput
    该类的实例支持读取和写入随机访问文件。 随机访问文件的行为类似于存储在文件系统中的大量字节。 有一种游标，或索引到隐含的数组，称为文件指针 ; 输入操作读取从文件指针开始的字节，并使文件指针超过读取的字节。 如果在读/写模式下创建随机访问文件，则输出操作也可用; 输出操作从文件指针开始写入字节，并将文件指针提前到写入的字节。 写入隐式数组的当前端的输出操作会导致扩展数组。 文件指针可以通过读取getFilePointer方法和由设置seek方法。

    这个类中的所有读取例程通常是真的，如果在读取所需的字节数之前到达文件结尾，则抛出一个EOFException （这是一种IOException ）。 如果由于除文件末尾之外的任何原因而无法读取任何字节，则抛出IOException以外的EOFException 。 特别地，如果流已关闭， IOException可能会抛出IOException 。

    鼓励执行实施可能写入文件的最大数量的数据。

    从以下版本开始：
    1.4.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭此随机访问文件流并释放与流相关联的任何系统资源。
      long getFilePointer​()
      返回此文件中的当前偏移量。
      long length​()
      返回此文件的长度。
      int read​()
      从该文件读取一个字节的数据。
      int read​(byte[] b)
      从该文件读取最多 b.length个字节的数据到字节数组。
      int read​(byte[] b, int off, int len)
      从该文件读取最多 len个字节的数据到一个字节数组。
      boolean readBoolean​()
      从此文件读取一个 boolean 。
      byte readByte​()
      从此文件中读取一个带符号的八位值。
      char readChar​()
      从此文件中读取Unicode字符。
      double readDouble​()
      从此文件读取一个 double 。
      float readFloat​()
      从此文件读取一个 float 。
      void readFully​(byte[] b)
      从该文件读取 b.length个字节到字节数组，从当前文件指针开始。
      void readFully​(byte[] b, int off, int len)
      从该文件读取完整的 len字节到字节数组，从当前文件指针开始。
      int readInt​()
      从该文件读取一个带符号的32位整数。
      String readLine​()
      从此文件中读取下一行文本。
      long readLong​()
      从该文件中读取一个带符号的64位整数。
      short readShort​()
      从此文件中读取一个已签名的16位数字。
      int readUnsignedByte​()
      从此文件中读取一个无符号的八位数字。
      int readUnsignedShort​()
      从该文件中读取一个无符号的16位数字。
      String readUTF​()
      从该文件读取字符串。
      void seek​(long pos)
      设置文件指针偏移，从该文件的开头测量，发生下一次读取或写入。
      void setLength​(long newLength)
      设置此文件的长度。
      int skipBytes​(int n)
      尝试跳过超过 n个字节的输入丢弃跳过的字节。
      void write​(byte[] b)
      从指定的字节数组写入 b.length个字节到该文件，从当前文件指针开始。
      void write​(byte[] b, int off, int len)
      从指定的字节数组写入 len个字节，从偏移量 off开始写入此文件。
      void write​(int b)
      将指定的字节写入此文件。
      void writeBoolean​(boolean v)
      将 boolean写入文件作为一个字节值。
      void writeByte​(int v)
      将一个 byte写入文件作为一个字节的值。
      void writeBytes​(String s)
      将字符串作为字节序列写入文件。
      void writeChar​(int v)
      将 char写入文件作为双字节值，高位字节。
      void writeChars​(String s)
      将一个字符串作为字符序列写入文件。
      void writeDouble​(double v)
      使用 long中的 doubleToLongBits方法将双参数转换为 Double ，然后 long值作为八字节数量，高字节优先写入文件。
      void writeFloat​(float v)
      浮子参数的转换 int使用 floatToIntBits方法在类 Float ，然后写入该 int值到该文件作为一个四字节数量，高字节。
      void writeInt​(int v)
      将文件中的 int写入四字节，高位字节。
      void writeLong​(long v)
      向文件写入一个 long作为八字节，高字节优先。
      void writeShort​(int v)
      将 short写入文件为两个字节，高字节为先。
      void writeUTF​(String str)
      使用UTF-8编码以机器无关方式将字符串写入文件。

    • 方法详细信息

      • close

        void close​()
    throws IOException
        关闭此随机访问文件流并释放与流相关联的任何系统资源。 封闭的随机存取文件无法执行输入或输出操作，无法重新打开。
        异常
        IOException - 如果发生I / O错误。

      • length

        long length​()
     throws IOException
        返回此文件的长度。
        结果
        该文件的长度，以字节为单位。
        异常
        IOException - 如果发生I / O错误。

      • getFilePointer

        long getFilePointer​()
             throws IOException
        返回此文件中的当前偏移量。
        结果
        从文件开头的偏移量（以字节为单位），下一次读取或写入发生。
        异常
        IOException - 如果发生I / O错误。

      • read

        int read​()
  throws IOException
        从该文件读取一个字节的数据。 该字节作为0到255（ 0x00-0x0ff ）范围内的整数返回。 如果没有输入可用，此方法将阻止。

        虽然JNLPRandomAccessFile不是JNLPRandomAccessFile的子类， InputStream该方法的行为与InputStream的读取方法InputStream 。

        结果
        数据的下一个字节，如果已经到达文件的末尾， -1 。
        异常
        IOException - 如果发生I / O错误。 如果达到文件结尾，则不会抛出。

      • read

        int read​(byte[] b,
         int off,
         int len)
  throws IOException
        从该文件读取最多len个字节的数据为字节数组。 该方法阻塞，直到输入的至少一个字节可用。

        虽然JNLPRandomAccessFile不是JNLPRandomAccessFile的子类， InputStream该方法的行为与InputStream的read（byte []，int，int）方法InputStream 。

        参数
        b - 读取数据的缓冲区。
        off - 数据的起始偏移量。
        len - 读取的最大字节数。
        结果
        读入缓冲区的总字节数，如果没有更多的数据，因为文件的结尾已经到达， -1 。
        异常
        IOException - 如果发生I / O错误。

      • read

        int read​(byte[] b)
  throws IOException
        从该文件读取最多b.length个字节的数据到一个字节数组。 该方法阻塞，直到输入的至少一个字节可用。

        虽然JNLPRandomAccessFile不是JNLPRandomAccessFile的子类， InputStream该方法的行为与InputStream的read（byte []）方法InputStream 。

        参数
        b - 读取数据的缓冲区。
        结果
        读入缓冲区的总字节数，如果没有更多的数据，因为该文件的结尾已经到达， -1 。
        异常
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(byte[] b)
        throws IOException
        从该文件读取b.length字节到字节数组，从当前文件指针开始。 该方法从文件中重复读取，直到读取所请求的字节数。 该方法阻塞，直到读取所请求的字节数，检测到流的结尾，或抛出异常。
        Specified by:
        readFully在接口 DataInput
        参数
        b - 读取数据的缓冲区。
        异常
        EOFException - 如果此文件在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(byte[] b,
               int off,
               int len)
        throws IOException
        从该文件读取完全len个字节到字节数组，从当前文件指针开始。 该方法从文件中重复读取，直到读取所请求的字节数。 该方法阻塞，直到读取所请求的字节数，检测到流的结尾，或抛出异常。
        Specified by:
        readFully在接口 DataInput
        参数
        b - 读取数据的缓冲区。
        off - 数据的起始偏移量。
        len - 要读取的字节数。
        异常
        EOFException - 如果此文件在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • skipBytes

        int skipBytes​(int n)
       throws IOException
        尝试跳过超过n字节的输入丢弃跳过的字节。

        该方法可能跳过一些较小数量的字节，可能为零。 这可能是由许多条件中的任何一个引起的 n字节之前已经跳过的文件到达结束只有一种可能。 这种方法永远不会抛出一个EOFException 。 返回实际跳过的字节数。 如果n为负数，则不会跳过任何字节。

        Specified by:
        skipBytes在接口 DataInput
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果发生I / O错误。

      • readBoolean

        boolean readBoolean​()
             throws IOException
        从此文件读取一个boolean 。 该方法从文件中读取单个字节，从当前文件指针开始。 价值0代表false 。 任何其他值代表true 。 该方法阻塞直到字节被读取，流的结束被检测到或抛出异常。
        Specified by:
        readBoolean在接口 DataInput
        结果
        boolean读数。
        异常
        EOFException - 如果此文件已到达结束。
        IOException - 如果发生I / O错误。

      • readByte

        byte readByte​()
       throws IOException
        从此文件中读取一个带符号的八位值。 该方法从当前文件指针开始从文件读取一个字节。 如果读取的字节是b ，其中0 <= b <= 255 ，那么结果是：
             (byte)(b)

        该方法阻塞直到字节被读取，流的结束被检测到或抛出异常。

        Specified by:
        readByte在接口 DataInput
        结果
        该文件的下一个字节作为带符号的8位 byte 。
        异常
        EOFException - 如果这个文件已经到了最后。
        IOException - 如果发生I / O错误。

      • readUnsignedByte

        int readUnsignedByte​()
              throws IOException
        从此文件中读取一个无符号的八位数字。 此方法从该文件读取一个字节，从当前文件指针开始，并返回该字节。

        该方法阻塞直到字节被读取，流的结束被检测到或抛出异常。

        Specified by:
        readUnsignedByte在接口 DataInput
        结果
        该文件的下一个字节被解释为无符号的8位数字。
        异常
        EOFException - 如果此文件已到达结束。
        IOException - 如果发生I / O错误。

      • readShort

        short readShort​()
         throws IOException
        从此文件中读取一个已签名的16位数字。 该方法从该文件读取两个字节，从当前文件指针开始。 如果按顺序读取的两个字节是b1和b2 ，其中两个值中的每一个在0和255之间，其结果等于：
             (short)((b1 << 8) | b2)

        此方法将阻塞，直到读取两个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readShort在接口 DataInput
        结果
        该文件的下两个字节被解释为一个有符号的16位数字。
        异常
        EOFException - 如果此文件在读取两个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readUnsignedShort

        int readUnsignedShort​()
               throws IOException
        从该文件中读取一个无符号的16位数字。 该方法从文件中读取两个字节，从当前文件指针开始。 如果读取的字节顺序为b1和b2 ，其中0 <= b1, b2 <= 255 ，则结果等于：
             (b1 << 8) | b2

        此方法将阻塞，直到读取两个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readUnsignedShort在接口 DataInput
        结果
        该文件的下两个字节被解释为无符号16位整数。
        异常
        EOFException - 如果此文件在读取两个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readChar

        char readChar​()
       throws IOException
        从此文件中读取Unicode字符。 该方法从文件中读取两个字节，从当前文件指针开始。 如果读取的字节顺序为b1和b2 ，其中0 <= b1, b2 <= 255 ，则结果等于：
             (char)((b1 << 8) | b2)

        此方法将阻塞，直到读取两个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readChar在接口 DataInput
        结果
        该文件的下两个字节为Unicode字符。
        异常
        EOFException - 如果此文件在读取两个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readInt

        int readInt​()
     throws IOException
        从该文件读取一个带符号的32位整数。 该方法从当前文件指针开始从文件读取4个字节。 如果读取的字节依次是b1 ， b2 ， b3 ，和b4 ，其中0 <= b1, b2, b3, b4 <= 255 ，则结果等于：
             (b1 << 24) | (b2 << 16) + (b3 << 8) + b4

        该方法阻塞，直到读取四个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readInt在接口 DataInput
        结果
        该文件的下四个字节，解释为 int 。
        异常
        EOFException - 如果此文件在读取四个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readLong

        long readLong​()
       throws IOException
        从该文件中读取一个带符号的64位整数。 该方法从文件中读取八个字节，从当前文件指针开始。 如果读取的字节依次是b1 ， b2 ， b3 ， b4 ， b5 ， b6 ， b7 ，并b8,其中：
             0 <= b1, b2, b3, b4, b5, b6, b7, b8 <=255,

        那么结果等于：

             ((long)b1 << 56) + ((long)b2 << 48)
     + ((long)b3 << 40) + ((long)b4 << 32)
     + ((long)b5 << 24) + ((long)b6 << 16)
     + ((long)b7 << 8) + b8

        该方法阻塞，直到读取8个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readLong接口 DataInput
        结果
        该文件的接下来的八个字节，解释为 long 。
        异常
        EOFException - 如果此文件在读取八个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFloat

        float readFloat​()
         throws IOException
        从此文件读取一个float 。 此方法读取一个int值，并从当前文件指针，就好像由readInt方法，然后转换该int为float使用intBitsToFloat在类方法Float 。

        该方法阻塞，直到读取四个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readFloat在接口 DataInput
        结果
        该文件的下四个字节，解释为 float 。
        异常
        EOFException - 如果此文件在读取四个字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        readInt()

      • readDouble

        double readDouble​()
           throws IOException
        从此文件读取一个double 。 此方法读取一个long值，并从当前文件指针，就好像由readLong方法，然后转换该long为double使用longBitsToDouble在类方法Double 。

        该方法阻塞，直到读取8个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readDouble在接口 DataInput
        结果
        该文件的接下来的八个字节，解释为 double 。
        异常
        EOFException - 如果此文件在读取八个字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        readLong()

      • readLine

        String readLine​()
         throws IOException
        从此文件中读取下一行文本。 该方法从文件开始依次读取字节，从当前文件指针开始，直到到达行终止符或文件末尾。 通过将字符的低8位的字节值设置为零，将字符的高8位设置为零，将每个字节转换为字符。 因此，此方法不支持完整的Unicode字符集。

        一行文本由回车字符（ '\r' ），换行字符（ '\n' ），紧跟换行符的回车字符或文件结尾终止。 行终止字符被丢弃，不包括返回的字符串的一部分。

        该方法阻塞，直到读取换行字符，回车并读取其后的字节（以查看它是否为换行符），到达文件的结尾或抛出异常。

        Specified by:
        readLine在接口 DataInput
        结果
        该文件的下一行文本，如果在读取一个字节之前遇到文件结尾，则返回null。
        异常
        IOException - 如果发生I / O错误。

      • readUTF

        String readUTF​()
        throws IOException
        从该文件读取字符串。 字符串已使用修改的UTF-8格式进行编码。

        从当前文件指针开始读取前两个字节，如readUnsignedShort 。 该值给出编码字符串中的以下字节数，而不是生成字符串的长度。 以下字节被解释为以UTF-8格式编码字符的字节，并将其转换为字符。

        该方法阻塞，直到读取所有字节，检测到流的结尾，或抛出异常。

        Specified by:
        readUTF在接口 DataInput
        结果
        一个Unicode字符串。
        异常
        EOFException - 如果此文件在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        UTFDataFormatException - 如果字节不表示Unicode字符串的有效UTF-8编码。
        另请参见：
        readUnsignedShort()

      • seek

        void seek​(long pos)
   throws IOException
        设置文件指针偏移，从该文件的开头测量，发生下一次读取或写入。 偏移可以设置为超出文件的末尾。 设置超出文件末尾的偏移量不会更改文件长度。 文件长度只有在偏移设置超出文件结尾之后才会通过写入进行更改。
        参数
        pos - 从文件开始测量的偏移位置，用于设置文件指针。
        异常
        IOException - 如果 pos小于 0或发生I / O错误。

      • setLength

        void setLength​(long newLength)
        throws IOException
        设置此文件的长度。

        如果由length方法返回的文件的当前长度大于newLength参数，则该文件将被截断。 在这种情况下，如果由getFilePointer方法返回的文件偏移量大于newLength则在此方法返回后，偏移量将等于newLength 。

        如果由length方法返回的文件的当前长度小于newLength参数，则该文件将被扩展。 在这种情况下，文件的扩展部分的内容未定义。

        参数
        newLength - 文件所需的长度
        异常
        IOException - 如果发生I / O错误

      • write

        void write​(int b)
    throws IOException
        将指定的字节写入此文件。 写入从当前文件指针开始。
        Specified by:
        write在接口 DataOutput
        参数
        b - byte 。
        异常
        IOException - 如果发生I / O错误。

      • write

        void write​(byte[] b)
    throws IOException
        从指定的字节数组写入 b.length个字节到该文件，从当前文件指针开始。
        Specified by:
        write在接口 DataOutput
        参数
        b - 数据。
        异常
        IOException - 如果发生I / O错误。

      • write

        void write​(byte[] b,
           int off,
           int len)
    throws IOException
        从指定的字节数组写入 len个字节，从偏移 off开始写入该文件。
        Specified by:
        write在接口 DataOutput
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException - 如果发生I / O错误。

      • writeBoolean

        void writeBoolean​(boolean v)
           throws IOException
        以boolean写入boolean作为单字节值。 值true写为值(byte)1 ; 值false被写出为值(byte)0 。 写入从文件指针的当前位置开始。
        Specified by:
        writeBoolean在接口 DataOutput
        参数
        v - 要写入的 boolean值。
        异常
        IOException - 如果发生I / O错误。

      • writeByte

        void writeByte​(int v)
        throws IOException
        将byte写入文件作为单字节值。 写入从文件指针的当前位置开始。
        Specified by:
        writeByte在接口 DataOutput
        参数
        v - byte值。
        异常
        IOException - 如果发生I / O错误。

      • writeShort

        void writeShort​(int v)
         throws IOException
        向文件写入一个short作为两个字节，高字节优先。 写入从文件指针的当前位置开始。
        Specified by:
        writeShort在接口 DataOutput
        参数
        v - a short待写。
        异常
        IOException - 如果发生I / O错误。

      • writeChar

        void writeChar​(int v)
        throws IOException
        将char写入文件作为双字节值，高字节优先。 写入从文件指针的当前位置开始。
        Specified by:
        writeChar在接口 DataOutput
        参数
        v - 要写入的 char值。
        异常
        IOException - 如果发生I / O错误。

      • writeInt

        void writeInt​(int v)
       throws IOException
        向文件写入一个int作为四字节，高字节优先。 写入从文件指针的当前位置开始。
        Specified by:
        writeInt在接口 DataOutput
        参数
        v - int 。
        异常
        IOException - 如果发生I / O错误。

      • writeLong

        void writeLong​(long v)
        throws IOException
        向文件写入一个long为八字节，高位字节。 写入从文件指针的当前位置开始。
        Specified by:
        writeLong在接口 DataOutput
        参数
        v - a long待写。
        异常
        IOException - 如果发生I / O错误。

      • writeFloat

        void writeFloat​(float v)
         throws IOException
        浮子参数的转换int使用floatToIntBits方法在类Float ，然后写入该int值到该文件作为一个四字节数量，高字节。 写入从文件指针的当前位置开始。
        Specified by:
        writeFloat在接口 DataOutput
        参数
        v - 要写入的 float值。
        异常
        IOException - 如果发生I / O错误。

      • writeDouble

        void writeDouble​(double v)
          throws IOException
        双参数传递给转换long使用doubleToLongBits方法在类Double ，然后写入该long值到该文件作为一个八字节的数量，高字节。 写入从文件指针的当前位置开始。
        Specified by:
        writeDouble在接口 DataOutput
        参数
        v - double值。
        异常
        IOException - 如果发生I / O错误。

      • writeBytes

        void writeBytes​(String s)
         throws IOException
        将字符串作为字节序列写入文件。 字符串中的每个字符顺序地通过丢弃其高8位来写出。 写入从文件指针的当前位置开始。
        Specified by:
        writeBytes在接口 DataOutput
        参数
        s - 要写入的字节串。
        异常
        IOException - 如果发生I / O错误。

      • writeChars

        void writeChars​(String s)
         throws IOException
        将一个字符串作为字符序列写入文件。 每个字符都被写入数据输出流，就好像通过writeChar方法。 写入从文件指针的当前位置开始。
        Specified by:
        writeChars在接口 DataOutput
        参数
        s - 要写入的 String值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        writeChar(int)

      • writeUTF

        void writeUTF​(String str)
       throws IOException
        使用UTF-8编码以机器无关方式将字符串写入文件。

        首先，将两个字节写入文件，从当前文件指针开始，好像通过writeShort方法给出要跟随的字节数。 该值是实际写出的字节数，而不是字符串的长度。 按照长度，字符串的每个字符顺序地使用每个字符的UTF-8编码输出。

        Specified by:
        writeUTF在接口 DataOutput
        参数
        str - 要写入的字符串。
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PersistenceService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface PersistenceService

  • public interface PersistenceService
    PersistenceService提供了在客户端系统上本地存储数据的方法，即使是在不受信任的执行环境中运行的应用程序。 该服务有点类似于cookie机制提供给基于HTML的应用程序。

    持久性数据存储中的每个条目都使用URL命名。 这提供了与传统文件系统类似的层次结构。

    应用程序只能访问存储有基于其代码库的URL的数据。 例如，鉴于代码库http://www.mysite.com/apps/App1/ ，应用程序将被允许访问相关URL的数据：

    • http://www.mysite.com/apps/App1/
    • http://www.mysite.com/apps/
    • http://www.mysite.com/

    该方案允许在同一主机之间的不同应用之间共享数据。 例如，如果另一个应用程序位于http://www.mysite.com/apps/App2/ ，则它们可以在http://www.mysite.com/和http://www.mysite.com/apps/目录之间共享它们之间的数据。

    JNLP客户端应跟踪给定应用程序使用的存储量。 A PersistenceService实现提供了获取当前存储使用和限制并请求更多存储的方法。 存储按每个文件进行分配，但JNLP客户端通常将根据应用程序使用的总存储来授予或拒绝该请求。

    使用此机制存储的数据旨在成为存储在远程服务器上的数据的本地副本。 单个条目可以被标记为缓存的 ，这意味着服务器具有最新的副本，这是脏的 ，这意味着服务器没有最新的副本或临时的副本，这意味着文件总是可以被重新创建。

    从以下版本开始：
    1.4.2

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static int | CACHED
      static int | DIRTY
      static int | TEMPORARY

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long create​(URL url, long maxsize)
      在客户端创建一个以给定的URL命名的永久存储条目。
      void delete​(URL url)
      从客户端日期持久性存储中删除与给定URL相关联的流。
      FileContents get​(URL url)
      返回表示此文件内容的 FileContents对象。
      String[] getNames​(URL url)
      返回一个字符串数组，其中包含给定URL的所有条目的名称。
      int getTag​(URL url)
      返回对应于与给定URL相关联的持久性数据存储条目的标记的当前值的 int 。
      void setTag​(URL url, int tag)
      使用给定的标签值标记与给定URL相关联的持久数据存储条目。

    • 字段详细信息

      • CACHED

        static final int CACHED
        另请参见：
        Constant Field Values

      • TEMPORARY

        static final int TEMPORARY
        另请参见：
        Constant Field Values

      • DIRTY

        static final int DIRTY
        另请参见：
        Constant Field Values

    • 方法详细信息

      • create

        long create​(URL url,
            long maxsize)
     throws MalformedURLException,
            IOException
        在客户端创建一个以给定的URL命名的永久存储条目。
        参数
        url - 表示持久数据存储中条目名称的URL。
        maxsize - 可以写入此条目的最大存储空间。
        结果
        授予的最大存储空间大小（以字节为单位）。
        异常
        MalformedURLException - 如果应用程序被拒绝访问由给定URL表示的持久性数据存储，或者URL为null。
        IOException - 如果发生I / O异常，或者条目已经存在。

      • get

        FileContents get​(URL url)
          throws MalformedURLException,
                 IOException,
                 FileNotFoundException
        返回表示此文件内容的 FileContents对象。
        参数
        url - 表示持久数据存储条目的URL。
        结果
        文件内容为FileContents。
        异常
        IOException - 如果发生I / O错误。
        MalformedURLException - 如果应用程序被拒绝访问由给定URL表示的持久性数据存储，或者URL为null。
        FileNotFoundException - 如果找不到给定URL的持久性存储。

      • delete

        void delete​(URL url)
     throws MalformedURLException,
            IOException
        从客户端日期持久性存储中删除与给定URL相关联的流。
        参数
        url - 表示从永久数据存储中删除的条目的URL。
        异常
        MalformedURLException - 如果应用程序被拒绝访问由给定URL表示的持久性数据存储，或者URL为null。
        IOException - 如果发生I / O异常。

      • getNames

        String[] getNames​(URL url)
           throws MalformedURLException,
                  IOException
        返回一个字符串数组，其中包含给定URL的所有条目的名称。
        参数
        url - 表示搜索条目名称的根目录的URL。
        结果
        一个包含条目名称的 String数组。
        异常
        MalformedURLException - 如果应用程序被拒绝访问由给定URL表示的持久性数据存储，或者URL为null。
        IOException - 如果发生I / O异常。

      • getTag

        int getTag​(URL url)
    throws MalformedURLException,
           IOException
        返回与给定URL相关联的持久性数据存储条目的标签的当前值对应的 int 。
        参数
        url - 表示要求标签值的持久数据存储条目的URL。
        结果
        一个int包含以下标签值之一：
        • CACHED
        • TEMPORARY
        • DIRTY
        异常
        MalformedURLException - 如果应用程序被拒绝访问由给定URL表示的持久性数据存储，或者URL为null。
        IOException - 如果发生I / O异常。

      • setTag

        void setTag​(URL url,
            int tag)
     throws MalformedURLException,
            IOException
        使用给定的标签值标记与给定URL相关联的持久数据存储条目。
        参数
        url - 表示要为其设置标签值的持久性数据存储条目的URL。
        tag - 要设置的标签值。
        异常
        MalformedURLException - 如果应用程序被拒绝访问由给定URL表示的持久性数据存储，或者URL为null。
        IOException - 如果发生I / O异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法


PrintService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface PrintService

  • public interface PrintService
    PrintService提供了访问打印功能的方法，即使是在不受信任的执行环境中运行的应用程序。 使用此服务，应用程序可以向JNLP客户端提交打印作业。 然后，客户端可以向用户显示此请求，如果接受，则将请求排队到打印机。
    从以下版本开始：
    1.4.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      PageFormat getDefaultPage​()
      创建一个新的PageFormat实例，并将其设置为默认的大小和方向。
      boolean print​(Pageable document)
      使用给定的 Pageable对象打印文档
      boolean print​(Printable painter)
      使用给定的 Printable对象打印文档
      PageFormat showPageFormatDialog​(PageFormat page)
      显示允许修改 PageFormat实例的对话框。

    • 方法详细信息

      • getDefaultPage

        PageFormat getDefaultPage​()
        创建一个新的PageFormat实例，并将其设置为默认的大小和方向。
        结果
        一个 PageFormat设置为默认的大小和方向。

      • showPageFormatDialog

        PageFormat showPageFormatDialog​(PageFormat page)
        显示允许修改PageFormat实例的对话框。 page参数用于初始化页面设置对话框中的控件。 如果用户取消了对话框，则该方法将不修改原始的page对象。 如果用户保持对话框，则此方法将返回一个新的PageFormat对象，并显示指定的更改。 在任何一种情况下，原始的page对象不被修改。
        参数
        page - 默认 PageFormat提交给用户进行修改。
        结果
        如果对话框被取消，原始的page对象; 一个新的PageFormat对象，如果对话框被确认，则包含用户指示的格式。

      • print

        boolean print​(Pageable document)
        使用给定的 Pageable对象打印文档
        参数
        document - 要打印的页面。 它不能为空。
        结果
        true如果打印成功，否则为 false 。

      • print

        boolean print​(Printable painter)
        使用给定的 Printable对象打印文档
        参数
        painter - 用于呈现文档的每一页的 Printable 。
        结果
        true如果打印成功，否则为 false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServiceManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Class ServiceManager

  • java.lang.Object
    • javax.jnlp.ServiceManager

  • public final class ServiceManager
extends Object
    ServiceManager提供了查找JNLP服务的静态方法。 这个类是final，不能被实例化。

    请求被委派给一个ServiceManagerStub对象。 该对象必须由JNLP Client在启动时使用setServiceManagerStub方法设置。

    从以下版本开始：
    1.4.2
    另请参见：
    ServiceManagerStub

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static String[] getServiceNames​()
      返回由JNLP Client实现的所有服务的名称。
      static Object lookup​(String name)
      向JNLP客户端询问具有给定名称的服务。
      static void setServiceManagerStub​(ServiceManagerStub stub)
      设置所有 lookup和 getServiceNames请求的委托对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • lookup

        public static Object lookup​(String name)
                     throws UnavailableServiceException
        向JNLP客户端询问具有给定名称的服务。 查找必须是幂等的，这是为相同名称的每个调用返回相同的对象。
        参数
        name - 要查找的服务的名称。
        结果
        实现该服务的对象。 将永远不会返回null 。 相反，将抛出异常。
        异常
        UnavailableServiceException - 如果服务不可用，或者如果 name为空。

      • getServiceNames

        public static String[] getServiceNames​()
        返回由JNLP Client实现的所有服务的名称。
        结果
        JNLP客户端实施的所有服务的名称

      • setServiceManagerStub

        public static void setServiceManagerStub​(ServiceManagerStub stub)
        设置所有lookup和getServiceNames请求的委托对象。 如果存根已设置，则setServiceManagerStub调用将被忽略。

        该方法应该由JNLP Client完全调用一次，并且不会被启动的应用程序调用。

        参数
        stub - 要委托的ServiceManagerStub对象
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServiceManagerStub (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface ServiceManagerStub

  • public interface ServiceManagerStub
    A ServiceManagerStub对象实现JNLP客户端对JNLP服务的特定查找。 该目的与所登记的ServiceManager使用ServiceManager.setServiceManagerStub(javax.jnlp.ServiceManagerStub)方法。
    从以下版本开始：
    1.4.2
    另请参见：
    ServiceManager

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String[] getServiceNames​()
      参见 ServiceManager.getServiceNames()的说明
      Object lookup​(String name)
      参见 ServiceManager.lookup(java.lang.String)的说明

    • 方法详细信息

      • lookup

        Object lookup​(String name)
       throws UnavailableServiceException
        参见 ServiceManager.lookup(java.lang.String)的说明
        参数
        name - 要查找的服务的名称。
        结果
        实现该服务的对象。 null永远不会退回。 相反，将抛出异常。
        异常
        UnavailableServiceException - 如果服务不可用，或者如果 name为空。

      • getServiceNames

        String[] getServiceNames​()
        参见 ServiceManager.getServiceNames()的说明
        结果
        JNLP客户端实施的所有服务的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SingleInstanceListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface SingleInstanceListener

  • public interface SingleInstanceListener
    SingleInstanceListener是一个接口，如果他们希望支持单实例行为，应由JNLP应用程序实现。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void newActivation​(String[] params)
      该方法应该由应用程序来实现，以处理单一实例行为 - 应用程序如何使用params调用应用程序的另一个实例时如何处理参数。

    • 方法详细信息

      • newActivation

        void newActivation​(String[] params)
        该方法应该由应用程序来实现，以处理单一实例行为 - 应用程序如何使用params调用应用程序的另一个实例时如何处理参数。
        参数
        params - 应用程序的参数数组（jnlp文件中提供的参数）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SingleInstanceService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Interface SingleInstanceService

  • public interface SingleInstanceService
    SingleInstanceService允许在Java Web Start下启动的应用程序将其自身注册为单例，并在用户尝试启动其新实例时传递新的参数集。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addSingleInstanceListener​(SingleInstanceListener sil)
      添加指定的SingleInstanceListener来处理应用程序/小应用程序在调用相同应用程序/ applet的另一个实例时的行为方式。
      void removeSingleInstanceListener​(SingleInstanceListener sil)
      删除指定的SingleInstanceListener。

    • 方法详细信息

      • addSingleInstanceListener

        void addSingleInstanceListener​(SingleInstanceListener sil)
        添加指定的SingleInstanceListener来处理应用程序/小应用程序在调用相同应用程序/ applet的另一个实例时的行为方式。 如果SingleInstanceListener sil为null，则不会抛出异常并且不执行任何操作。
        参数
        sil - 要添加的SingleInstanceListener对象

      • removeSingleInstanceListener

        void removeSingleInstanceListener​(SingleInstanceListener sil)
        删除指定的SingleInstanceListener。 如果由参数指定的侦听器以前未添加到应用程序/ applet中，则此方法不执行任何功能，也不会抛出异常。 如果侦听器为空，则不抛出任何异常，也不会执行任何操作。 建议如果应用程序/小程序注册了任何SingleInstanceListener，则应该在应用程序/ applet退出时调用此方法来删除所有侦听器。
        参数
        sil - 要删除的SingleInstanceListener对象
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnavailableServiceException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.jnlp
软件包 javax.jnlp

Class UnavailableServiceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jnlp.UnavailableServiceException
  • All Implemented Interfaces:
    Serializable

    public class UnavailableServiceException
extends 异常
    该 UnavailableServiceException被抛出 ServiceManager当不存在或无法使用服务抬头。
    从以下版本开始：
    1.4.2
    另请参见：
    ServiceManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnavailableServiceException​()
      构造一个 UnavailableServiceException与 null作为其错误详细消息。
      UnavailableServiceException​(String msg)
      构造具有指定详细消息的 UnavailableServiceException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnavailableServiceException

        public UnavailableServiceException​()
        构造一个 UnavailableServiceException与 null作为其错误详细信息。

      • UnavailableServiceException

        public UnavailableServiceException​(String msg)
        构造具有指定详细消息的UnavailableServiceException 。 错误消息字符串s可以稍后通过类java.lang.Throwable的Throwable.getMessage()方法检索。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.jnlp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.jnlp

  • Packages that use javax.jnlp
    软件包 描述
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
  • Classes in javax.jnlp used by javax.jnlp
    Class 描述
    DownloadService2.ResourceSpec
    指定资源查询的模式作为参数，并将结果保留在 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec)中 。
    DownloadServiceListener
    DownloadServiceListener提供了一个回调对象实现的接口，可以由一个DownloadService实现使用。
    FileContents
    FileContents对象封装文件的名称和内容。
    JNLPRandomAccessFile
    该类的实例支持读取和写入随机访问文件。
    ServiceManagerStub
    A ServiceManagerStub对象实现JNLP客户端对JNLP服务的特定查找。
    SingleInstanceListener
    SingleInstanceListener是一个接口，如果他们希望支持单实例行为，应该由JNLP应用程序实现。
    UnavailableServiceException
    当 UnavailableServiceException不存在或不可用的服务时， UnavailableServiceException被抛出 ServiceManager 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jnlp.DownloadService2.ResourceSpec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jnlp.DownloadService2.ResourceSpec

  • Packages that use DownloadService2.ResourceSpec
    软件包 描述
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of DownloadService2.ResourceSpec in javax.jnlp

      Methods in javax.jnlp that return DownloadService2.ResourceSpec
      Modifier and Type 方法 描述
      DownloadService2.ResourceSpec[] DownloadService2.getCachedResources​(DownloadService2.ResourceSpec spec)
      返回缓存中与指定资源规范之一匹配的所有资源。
      DownloadService2.ResourceSpec[] DownloadService2.getUpdateAvailableResources​(DownloadService2.ResourceSpec spec)
      返回缓存中与指定的资源规范之一匹配的所有资源，并具有从其服务器可用的更新。
      Methods in javax.jnlp with parameters of type DownloadService2.ResourceSpec
      Modifier and Type 方法 描述
      DownloadService2.ResourceSpec[] DownloadService2.getCachedResources​(DownloadService2.ResourceSpec spec)
      返回缓存中与指定资源规范之一匹配的所有资源。
      DownloadService2.ResourceSpec[] DownloadService2.getUpdateAvailableResources​(DownloadService2.ResourceSpec spec)
      返回缓存中与指定的资源规范之一匹配的所有资源，并具有从其服务器可用的更新。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jnlp.ServiceManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jnlp.ServiceManager

No usage of javax.jnlp.ServiceManager
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jnlp.UnavailableServiceException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jnlp.UnavailableServiceException

  • Packages that use UnavailableServiceException
    软件包 描述
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of UnavailableServiceException in javax.jnlp

      Methods in javax.jnlp that throw UnavailableServiceException
      Modifier and Type 方法 描述
      static Object ServiceManager.lookup​(String name)
      向JNLP客户端询问具有给定名称的服务。
      Object ServiceManagerStub.lookup​(String name)
      参见 ServiceManager.lookup(java.lang.String)的说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.BasicService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.BasicService

No usage of javax.jnlp.BasicService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.ClipboardService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.ClipboardService

No usage of javax.jnlp.ClipboardService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.DownloadService2 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.DownloadService2

No usage of javax.jnlp.DownloadService2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.DownloadService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.DownloadService

No usage of javax.jnlp.DownloadService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.DownloadServiceListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.DownloadServiceListener

  • Packages that use DownloadServiceListener
    软件包 描述
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of DownloadServiceListener in javax.jnlp

      Methods in javax.jnlp that return DownloadServiceListener
      Modifier and Type 方法 描述
      DownloadServiceListener DownloadService.getDefaultProgressWindow​()
      返回一个默认的DownloadServiceListener实现，当传递给一个load方法时，应该随着进度而弹出并更新一个进度窗口。
      Methods in javax.jnlp with parameters of type DownloadServiceListener
      Modifier and Type 方法 描述
      void DownloadService.loadExtensionPart​(URL ref, String version, String[] parts, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了部件和扩展名，请下载给定扩展的给定部分。
      void DownloadService.loadExtensionPart​(URL ref, String version, String part, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了部分和扩展名，请下载给定扩展的给定部分。
      void DownloadService.loadPart​(String[] parts, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了这些部分，请下载给定的部分。
      void DownloadService.loadPart​(String part, DownloadServiceListener progress)
      下载给定的部分，如果该部分在应用程序的JNLP文件中被提到。
      void DownloadService.loadResource​(URL ref, String version, DownloadServiceListener progress)
      Downloads the given resource, if the resource is either mentioned in the calling applications JNLP file, is within the codebase of the calling applications JNLP file, or if the calling application has been granted all-permissions.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.ExtendedService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.ExtendedService

No usage of javax.jnlp.ExtendedService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.ExtensionInstallerService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.ExtensionInstallerService

No usage of javax.jnlp.ExtensionInstallerService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.FileContents (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.FileContents

  • Packages that use FileContents
    软件包 描述
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of FileContents in javax.jnlp

      Methods in javax.jnlp that return FileContents
      Modifier and Type 方法 描述
      FileContents PersistenceService.get​(URL url)
      返回表示此文件内容的 FileContents对象。
      FileContents ExtendedService.openFile​(File file)
      允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。
      FileContents FileOpenService.openFileDialog​(String pathHint, String[] extensions)
      要求用户选择一个文件。
      FileContents[] ExtendedService.openFiles​(File[] files)
      允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。
      FileContents[] FileOpenService.openMultiFileDialog​(String pathHint, String[] extensions)
      要求用户选择一个或多个文件。
      FileContents FileSaveService.saveAsFileDialog​(String pathHint, String[] extensions, FileContents contents)
      要求用户保存文件。
      FileContents FileSaveService.saveFileDialog​(String pathHint, String[] extensions, InputStream stream, String name)
      要求用户保存文件。
      Methods in javax.jnlp with parameters of type FileContents
      Modifier and Type 方法 描述
      FileContents FileSaveService.saveAsFileDialog​(String pathHint, String[] extensions, FileContents contents)
      要求用户保存文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.FileOpenService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.FileOpenService

No usage of javax.jnlp.FileOpenService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.FileSaveService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.FileSaveService

No usage of javax.jnlp.FileSaveService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.IntegrationService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.IntegrationService

No usage of javax.jnlp.IntegrationService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.JNLPRandomAccessFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.JNLPRandomAccessFile

  • Packages that use JNLPRandomAccessFile
    软件包 描述
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of JNLPRandomAccessFile in javax.jnlp

      Methods in javax.jnlp that return JNLPRandomAccessFile
      Modifier and Type 方法 描述
      JNLPRandomAccessFile FileContents.getRandomAccessFile​(String mode)
      返回表示文件内容的随机访问接口的 JNLPRandomAccessFile 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.PersistenceService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.PersistenceService

No usage of javax.jnlp.PersistenceService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.PrintService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.PrintService

No usage of javax.jnlp.PrintService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.ServiceManagerStub (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.ServiceManagerStub

  • Packages that use ServiceManagerStub
    软件包 描述
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of ServiceManagerStub in javax.jnlp

      Methods in javax.jnlp with parameters of type ServiceManagerStub
      Modifier and Type 方法 描述
      static void ServiceManager.setServiceManagerStub​(ServiceManagerStub stub)
      设置所有 lookup和 getServiceNames请求的委托对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.SingleInstanceListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.SingleInstanceListener

  • Packages that use SingleInstanceListener
    软件包 描述
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of SingleInstanceListener in javax.jnlp

      Methods in javax.jnlp with parameters of type SingleInstanceListener
      Modifier and Type 方法 描述
      void SingleInstanceService.addSingleInstanceListener​(SingleInstanceListener sil)
      添加指定的SingleInstanceListener来处理应用程序/小应用程序在调用相同应用程序/ applet的另一个实例时的行为方式。
      void SingleInstanceService.removeSingleInstanceListener​(SingleInstanceListener sil)
      删除指定的SingleInstanceListener。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.jnlp.SingleInstanceService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.jnlp.SingleInstanceService

No usage of javax.jnlp.SingleInstanceService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


HandlerChain (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws

Annotation Type HandlerChain

  • @Retention(RUNTIME)
@Target({TYPE,METHOD,字段})
public @interface HandlerChain
    从以下版本开始：
    1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String file

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      String name
      已过时。

    • Element Detail

      • file

        String file

      • name

        @Deprecated
String name
        已过时。
        Default:
        “”
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


javax.jws (Java SE 9 & JDK 9 )

javax.jws

Enums

  • WebParam.Mode

注解类型

  • HandlerChain
  • Oneway
  • WebMethod
  • WebParam
  • WebResult
  • WebService


javax.jws (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.xml.ws

Package javax.jws

  • 枚举摘要
    Enum 描述
    WebParam.Mode
  • 注解类型摘要
    Annotation Type 描述
    HandlerChain
    Oneway
    WebMethod
    WebParam
    WebResult
    WebService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.jws Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.jws

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.jws.HandlerChain (implements java.lang.annotation.Annotation)
  • javax.jws.Oneway (implements java.lang.annotation.Annotation)
  • javax.jws.WebMethod (implements java.lang.annotation.Annotation)
  • javax.jws.WebParam (implements java.lang.annotation.Annotation)
  • javax.jws.WebResult (implements java.lang.annotation.Annotation)
  • javax.jws.WebService (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.jws.WebParam.Mode
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Oneway (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws

Annotation Type Oneway

  • @Retention(RUNTIME)
@Target(METHOD)
public @interface Oneway
    从以下版本开始：
    1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


Uses of Package javax.jws (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.jws

  • Packages that use javax.jws
    软件包 描述
    javax.jws
  • Classes in javax.jws used by javax.jws
    Class 描述
    WebParam.Mode
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


WebMethod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws

Annotation Type WebMethod

  • @Retention(RUNTIME)
@Target(METHOD)
public @interface WebMethod
    从以下版本开始：
    1.6

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element | 描述
      String action
      boolean | exclude
      String operationName

    • Element Detail

      • operationName

        String operationName
        Default:
        “”

      • action

        String action
        Default:
        “”

      • exclude

        boolean exclude
        Default:
        假
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


WebParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws

Annotation Type WebParam

  • @Retention(RUNTIME)
@Target(PARAMETER)
public @interface WebParam
    从以下版本开始：
    1.6

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element | 描述
      boolean | header
      WebParam.Mode mode
      String name
      String partName
      String targetNamespace

    • Element Detail

      • name

        String name
        Default:
        “”

      • partName

        String partName
        Default:
        “”

      • targetNamespace

        String targetNamespace
        Default:
        “”

      • mode

        WebParam.Mode mode
        Default:
        javax.jws.WebParam.Mode.IN

      • header

        boolean header
        Default:
        假
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


WebParam.Mode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.xml.ws
软件包 javax.jws

Enum WebParam.Mode

  • java.lang.Object
    • java.lang.Enum<WebParam.Mode>
      • javax.jws.WebParam.Mode
  • All Implemented Interfaces:
    Serializable ， Comparable<WebParam.Mode>
    Enclosing class:
    WebParam

    public static enum WebParam.Mode
extends Enum<WebParam.Mode>

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      IN
      INOUT
      OUT

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static WebParam.Mode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static WebParam.Mode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • IN

        public static final WebParam.Mode IN

      • OUT

        public static final WebParam.Mode OUT

      • INOUT

        public static final WebParam.Mode INOUT

    • 方法详细信息

      • values

        public static WebParam.Mode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (WebParam.Mode c : WebParam.Mode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static WebParam.Mode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


WebResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws

Annotation Type WebResult

  • @Retention(RUNTIME)
@Target(METHOD)
public @interface WebResult
    从以下版本开始：
    1.6

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element | 描述
      boolean | header
      String name
      String partName
      String targetNamespace

    • Element Detail

      • name

        String name
        Default:
        “”

      • partName

        String partName
        Default:
        “”

      • targetNamespace

        String targetNamespace
        Default:
        “”

      • header

        boolean header
        Default:
        假
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


WebService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws

Annotation Type WebService

  • @Retention(RUNTIME)
@Target(TYPE)
public @interface WebService
    从以下版本开始：
    1.6

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      String endpointInterface
      String name
      String portName
      String serviceName
      String targetNamespace
      String wsdlLocation

    • Element Detail

      • name

        String name
        Default:
        “”

      • targetNamespace

        String targetNamespace
        Default:
        “”

      • serviceName

        String serviceName
        Default:
        “”

      • portName

        String portName
        Default:
        “”

      • wsdlLocation

        String wsdlLocation
        Default:
        “”

      • endpointInterface

        String endpointInterface
        Default:
        ""
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


Uses of Class javax.jws.HandlerChain (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.HandlerChain

No usage of javax.jws.HandlerChain
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.Oneway (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.Oneway

No usage of javax.jws.Oneway
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.WebMethod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.WebMethod

No usage of javax.jws.WebMethod
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.WebParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.WebParam

No usage of javax.jws.WebParam
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.WebParam.Mode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.WebParam.Mode

  • Packages that use WebParam.Mode
    软件包 描述
    javax.jws

    • Uses of WebParam.Mode in javax.jws

      Methods in javax.jws that return WebParam.Mode
      Modifier and Type 方法 描述
      static WebParam.Mode WebParam.Mode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static WebParam.Mode[] WebParam.Mode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.WebResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.WebResult

No usage of javax.jws.WebResult
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.WebService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.WebService

No usage of javax.jws.WebService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


InitParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws.soap

Annotation Type InitParam

  • 已过时。

    @Deprecated
public @interface InitParam
    从以下版本开始：
    1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String name
      已过时。
      String value
      已过时。

    • Element Detail

      • name

        String name
        已过时。

      • value

        String value
        已过时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


javax.jws.soap (Java SE 9 & JDK 9 )

javax.jws.soap

Enums

  • SOAPBinding.ParameterStyle
  • SOAPBinding.Style
  • SOAPBinding.Use

注解类型

  • InitParam
  • SOAPBinding
  • SOAPMessageHandler
  • SOAPMessageHandlers


javax.jws.soap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.xml.ws

Package javax.jws.soap

  • 枚举摘要
    Enum 描述
    SOAPBinding.ParameterStyle
    SOAPBinding.Style
    SOAPBinding.Use
  • 注解类型摘要
    Annotation Type | 描述
    InitParam | Deprecated.
    SOAPBinding
    SOAPMessageHandler | Deprecated.
    SOAPMessageHandlers | Deprecated.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.jws.soap Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.jws.soap

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.jws.soap.InitParam (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPBinding (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandler (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandlers (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.jws.soap.SOAPBinding.ParameterStyle
      • javax.jws.soap.SOAPBinding.Style
      • javax.jws.soap.SOAPBinding.Use
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


SOAPBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws.soap

Annotation Type SOAPBinding

  • @Retention(RUNTIME)
@Target({TYPE,METHOD})
public @interface SOAPBinding
    从以下版本开始：
    1.6

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      SOAPBinding.ParameterStyle parameterStyle
      SOAPBinding.Style style
      SOAPBinding.Use use

    • Element Detail

      • style

        SOAPBinding.Style style
        Default:
        javax.jws.soap.SOAPBinding.Style.DOCUMENT

      • use

        SOAPBinding.Use use
        Default:
        javax.jws.soap.SOAPBinding.Use.LITERAL

      • parameterStyle

        SOAPBinding.ParameterStyle parameterStyle
        Default:
        javax.jws.soap.SOAPBinding.ParameterStyle.WRAPPED
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


SOAPBinding.ParameterStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.xml.ws
软件包 javax.jws.soap

Enum SOAPBinding.ParameterStyle

  • java.lang.Object
    • java.lang.Enum<SOAPBinding.ParameterStyle>
      • javax.jws.soap.SOAPBinding.ParameterStyle
  • All Implemented Interfaces:
    Serializable ， Comparable<SOAPBinding.ParameterStyle>
    Enclosing class:
    SOAPBinding

    public static enum SOAPBinding.ParameterStyle
extends Enum<SOAPBinding.ParameterStyle>

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BARE
      WRAPPED

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static SOAPBinding.ParameterStyle valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SOAPBinding.ParameterStyle[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BARE

        public static final SOAPBinding.ParameterStyle BARE

      • WRAPPED

        public static final SOAPBinding.ParameterStyle WRAPPED

    • 方法详细信息

      • values

        public static SOAPBinding.ParameterStyle[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (SOAPBinding.ParameterStyle c : SOAPBinding.ParameterStyle.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static SOAPBinding.ParameterStyle valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


SOAPBinding.Style (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.xml.ws
软件包 javax.jws.soap

Enum SOAPBinding.Style

  • java.lang.Object
    • java.lang.Enum<SOAPBinding.Style>
      • javax.jws.soap.SOAPBinding.Style
  • All Implemented Interfaces:
    Serializable ， Comparable<SOAPBinding.Style>
    Enclosing class:
    SOAPBinding

    public static enum SOAPBinding.Style
extends Enum<SOAPBinding.Style>

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DOCUMENT
      RPC

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static SOAPBinding.Style valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SOAPBinding.Style[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DOCUMENT

        public static final SOAPBinding.Style DOCUMENT

      • RPC

        public static final SOAPBinding.Style RPC

    • 方法详细信息

      • values

        public static SOAPBinding.Style[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (SOAPBinding.Style c : SOAPBinding.Style.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static SOAPBinding.Style valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


SOAPBinding.Use (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.xml.ws
软件包 javax.jws.soap

Enum SOAPBinding.Use

  • java.lang.Object
    • java.lang.Enum<SOAPBinding.Use>
      • javax.jws.soap.SOAPBinding.Use
  • All Implemented Interfaces:
    Serializable ， Comparable<SOAPBinding.Use>
    Enclosing class:
    SOAPBinding

    public static enum SOAPBinding.Use
extends Enum<SOAPBinding.Use>

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ENCODED
      LITERAL

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static SOAPBinding.Use valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SOAPBinding.Use[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LITERAL

        public static final SOAPBinding.Use LITERAL

      • ENCODED

        public static final SOAPBinding.Use ENCODED

    • 方法详细信息

      • values

        public static SOAPBinding.Use[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (SOAPBinding.Use c : SOAPBinding.Use.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static SOAPBinding.Use valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


SOAPMessageHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws.soap

Annotation Type SOAPMessageHandler

  • 已过时。

    @Deprecated
public @interface SOAPMessageHandler
    从以下版本开始：
    1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String className
      已过时。

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      String[] headers
      已过时。
      InitParam[] initParams
      已过时。
      String name
      已过时。
      String[] roles
      已过时。

    • Element Detail

      • className

        String className
        已过时。

      • name

        String name
        已过时。
        Default:
        “”

      • initParams

        InitParam[] initParams
        已过时。
        Default:
        {}

      • roles

        String[] roles
        已过时。
        Default:
        {}

      • headers

        String[] headers
        已过时。
        Default:
        {}
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


SOAPMessageHandlers (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.xml.ws
软件包 javax.jws.soap

Annotation Type SOAPMessageHandlers

  • 已过时。

    @Retention(RUNTIME)
@Target(TYPE)
@Deprecated
public @interface SOAPMessageHandlers
    从以下版本开始：
    1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      SOAPMessageHandler[] value
      已过时。

    • Element Detail

      • value

        SOAPMessageHandler[] value
        已过时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element


Uses of Package javax.jws.soap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.jws.soap

  • Packages that use javax.jws.soap
    软件包 描述
    javax.jws.soap
  • Classes in javax.jws.soap used by javax.jws.soap
    Class 描述
    SOAPBinding.ParameterStyle
    SOAPBinding.Style
    SOAPBinding.Use
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.soap.InitParam (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.soap.InitParam

No usage of javax.jws.soap.InitParam
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.soap.SOAPBinding (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.soap.SOAPBinding

No usage of javax.jws.soap.SOAPBinding
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.soap.SOAPBinding.ParameterStyle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.soap.SOAPBinding.ParameterStyle

  • Packages that use SOAPBinding.ParameterStyle
    软件包 描述
    javax.jws.soap

    • Uses of SOAPBinding.ParameterStyle in javax.jws.soap

      Methods in javax.jws.soap that return SOAPBinding.ParameterStyle
      Modifier and Type 方法 描述
      static SOAPBinding.ParameterStyle SOAPBinding.ParameterStyle.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SOAPBinding.ParameterStyle[] SOAPBinding.ParameterStyle.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.soap.SOAPBinding.Style (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.soap.SOAPBinding.Style

  • Packages that use SOAPBinding.Style
    软件包 描述
    javax.jws.soap

    • Uses of SOAPBinding.Style in javax.jws.soap

      Methods in javax.jws.soap that return SOAPBinding.Style
      Modifier and Type 方法 描述
      static SOAPBinding.Style SOAPBinding.Style.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SOAPBinding.Style[] SOAPBinding.Style.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.soap.SOAPBinding.Use (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.soap.SOAPBinding.Use

  • Packages that use SOAPBinding.Use
    软件包 描述
    javax.jws.soap

    • Uses of SOAPBinding.Use in javax.jws.soap

      Methods in javax.jws.soap that return SOAPBinding.Use
      Modifier and Type 方法 描述
      static SOAPBinding.Use SOAPBinding.Use.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SOAPBinding.Use[] SOAPBinding.Use.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.soap.SOAPMessageHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.soap.SOAPMessageHandler

No usage of javax.jws.soap.SOAPMessageHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.jws.soap.SOAPMessageHandlers (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.jws.soap.SOAPMessageHandlers

No usage of javax.jws.soap.SOAPMessageHandlers
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AnnotatedConstruct (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model

Interface AnnotatedConstruct

  • All Known Subinterfaces:
    ArrayType ， DeclaredType ， Element ， ErrorType ， ExecutableElement ， ExecutableType ， IntersectionType ， ModuleElement ， NoType ， NullType ， PackageElement ， Parameterizable ， PrimitiveType ， QualifiedNameable ， ReferenceType ， TypeElement ， TypeMirror ， TypeParameterElement ， TypeVariable ， UnionType ， VariableElement ， WildcardType

    public interface AnnotatedConstruct
    表示可以注释的构造。 一个构造是一个element或一个type 。 元素上的注释位于声明上 ，而类型上的注释是特定用途的类型名称。 直接呈现 ， 呈现 ， 间接呈现和关联的术语在整个界面中被使用以精确描述本文定义的方法返回哪些注释。

    在下面的定义中，注释A具有注释类型AT 。 如果AT是可重复的注释类型，则包含注释的类型是ATC 。

    注释A 直接存在于构造C上：

    • A被明确或隐含地声明为适用于C的源代码表示。

      通常，如果类型AT的一个注释出现在C表示的源代码中，则A被明确声明为适用于C。 如果有类型的多个注释AT存在于C，则如果AT是可重复的注释类型，类型的注释ATC是implicitly declared上℃。

    • A的表示显示在对C可执行输出，如RuntimeVisibleAnnotations或RuntimeVisibleParameterAnnotations一个类文件的属性。

    注释A 存在于构造C上：

    • A直接出现在C上 。
    • 没有类型AT的注释直接出现在C上 ， C是一个类， AT是可继承的， A在C的超类上。
    注释A 间接存在于构造C上 ：
    • AT是具有包含注释类型ATC的可重复注释类型。
    • 类型ATC的注释直接出现在C上 ， A是包括在调用ATC直接注释的value方法的结果中的注释。
    注释A与构造C 相关联 ：
    • A直接或间接出现在C上 。
    • 没有类型AT的注释直接或间接出现在C上 ， C是一个类， AT是可继承的， A与C的超类相关联。
    从以下版本开始：
    1.8
    See The Java™ Language Specification:
    9.6注释类型，9.6.3.3 @继承

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      <A extends Annotation>
      A             		getAnnotation​(Class<A> annotationType)
      返回指定类型的这种构造的注解，如果这样的注释 存在 ，否则 null 。
      List<? extends AnnotationMirror> getAnnotationMirrors​()
      返回 直接存在于此构造上的注释。
      <A extends Annotation>
      A[]             		getAnnotationsByType​(Class<A> annotationType)
      返回与此构造 关联的注释。

    • 方法详细信息

      • getAnnotationMirrors

        List<? extends AnnotationMirror> getAnnotationMirrors​()
        返回 直接存在于此构造上的注释。
        结果
        该结构上直接出现的注释; 一个空列表，如果没有

      • getAnnotation

        <A extends Annotation> A getAnnotation​(Class<A> annotationType)
        返回指定类型的这种构造的注解，如果这样的注释存在 ，否则null 。

        此方法返回的注释可能包含一个值为Class的元素。 此值无法直接返回：查找和加载类（例如要使用的类加载器）所需的信息不可用，并且该类可能无法加载。 通过对返回的注释调用相关方法，尝试读取Class对象将产生一个MirroredTypeException ，从中可以提取相应的TypeMirror 。 类似地，尝试读取一个Class[]值将导致一个MirroredTypesException 。

        Note: This method is unlike others in this and related interfaces. It operates on runtime reflective information — representations of annotation types currently loaded into the VM — rather than on the representations defined by and used throughout these interfaces. Consequently, calling methods on the returned annotation object can throw many of the exceptions that can be thrown when calling methods on an annotation object returned by core reflection. This method is intended for callers that are written to operate on a known, fixed set of annotation types.
        参数类型
        A - 注释类型
        参数
        annotationType - 对应于注释类型的 Class对象
        结果
        该构造体对于指定注释类型的注释（如果存在），否则为 null
        另请参见：
        getAnnotationMirrors() ， AnnotatedElement.getAnnotation(java.lang.Class<T>) ， EnumConstantNotPresentException ， AnnotationTypeMismatchException ， IncompleteAnnotationException ， MirroredTypeException ， MirroredTypesException
        See The Java™ Language Specification:
        9.6.1注释类型元素

      • getAnnotationsByType

        <A extends Annotation> A[] getAnnotationsByType​(Class<A> annotationType)
        返回与此构造关联的注释。 如果没有与此结构相关联的注释，则返回值是长度为0的数组。计算结果C中直接或间接存在的注释顺序，就好像C上间接存在的注释直接存在于C上的容器注释的顺序，它们在容器注释的值元素中显示的顺序。 该方法与getAnnotation(Class)之间的区别在于，该方法检测其参数是否是可重复的注释类型 ，如果是，则尝试通过“查看”容器注释来查找该类型的一个或多个注释。

        此方法返回的注释可能包含一个值为Class的元素。 此值无法直接返回：查找和加载类（例如要使用的类加载器）所需的信息不可用，并且该类可能无法加载。 通过调用返回注释的相关方法，尝试读取一个Class对象将导致一个MirroredTypeException ，从中可以提取相应的TypeMirror 。 类似地，尝试读取一个Class[]元素将导致一个MirroredTypesException 。

        Note: This method is unlike others in this and related interfaces. It operates on runtime reflective information — representations of annotation types currently loaded into the VM — rather than on the representations defined by and used throughout these interfaces. Consequently, calling methods on the returned annotation object can throw many of the exceptions that can be thrown when calling methods on an annotation object returned by core reflection. This method is intended for callers that are written to operate on a known, fixed set of annotation types.
        参数类型
        A - 注释类型
        参数
        annotationType - 对应于注释类型的 Class对象
        结果
        这个构造体对于指定的注释类型的注释，如果存在于此构造上，否则为空数组
        另请参见：
        getAnnotationMirrors() ， getAnnotation(Class) ， AnnotatedElement.getAnnotationsByType(Class) ， EnumConstantNotPresentException ， AnnotationTypeMismatchException ， IncompleteAnnotationException ， MirroredTypeException ， MirroredTypesException
        See The Java™ Language Specification:
        9.6注释类型，9.6.1注释类型元素
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.lang.model (Java SE 9 & JDK 9 )

javax.lang.model

Interfaces

  • AnnotatedConstruct

Enums

  • SourceVersion

Exceptions

  • UnknownEntityException


javax.lang.model (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.compiler

Package javax.lang.model

用于建模Java编程语言的软件包的类和层次结构。 该包及其子包的成员可用于语言建模和语言处理任务和API，包括但不限于annotation processing框架。

该语言模型遵循基于镜像的设计; 看到

Gilad Bracha and David Ungar. Mirrors: Design Principles for Meta-level Facilities of Object-Oriented Programming Languages. In Proc. of the ACM Conf. on Object-Oriented Programming, Systems, Languages and Applications, October 2004.
特别地，该模型使得静态的语言结构之间的区别，如element表示java.util.Set的家庭，和types可与元件相关联，如原始类型java.util.Set ， java.util.Set<String> ，和java.util.Set<T> 。

除非另有说明，如果给出了null参数，本包中的方法将抛出一个NullPointerException 。

从以下版本开始：
1.6
  • 接口摘要
    接口 描述
    AnnotatedConstruct
    表示可以注释的构造。
  • 枚举摘要
    Enum 描述
    SourceVersion
    源代码版本的Java编程语言。
  • 异常摘要
    异常 描述
    UnknownEntityException
    例外的超类，表示遇到一个未知类型的实体。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.lang.model Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.lang.model

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • javax.lang.model.UnknownEntityException

Interface Hierarchy

  • javax.lang.model.AnnotatedConstruct

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.lang.model.SourceVersion
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


SourceVersion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.compiler
软件包 javax.lang.model

Enum SourceVersion

  • java.lang.Object
    • java.lang.Enum<SourceVersion>
      • javax.lang.model.SourceVersion
  • All Implemented Interfaces:
    Serializable ， Comparable<SourceVersion>

    public enum SourceVersion
extends Enum<SourceVersion>
    源代码版本的Java编程语言。 有关特定源版本的信息，请参阅相应版本的The Java™ Language Specification 。

    请注意，将添加额外的源版本常量来模拟未来版本的语言。

    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      RELEASE_0
      原版。
      RELEASE_1
      Java Platform 1.1认可的版本。
      RELEASE_2
      由Java 2 Platform，Standard Edition v 1.2认可的版本。
      RELEASE_3
      由Java 2 Platform，Standard Edition，v 1.3认可的版本。
      RELEASE_4
      由Java 2 Platform，Standard Edition v 1.4认可的版本。
      RELEASE_5
      由Java 2 Platform，Standard Edition 5.0认可的版本。
      RELEASE_6
      Java Platform，Standard Edition 6认可的版本。
      RELEASE_7
      由Java Platform标准版7认可的版本。
      RELEASE_8
      Java Platform标准版8认可的版本。
      RELEASE_9
      Java Platform，Standard Edition 9认可的版本。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static boolean isIdentifier​(CharSequence name)
      返回 name是否是最新源版本中的语法有效的标识符（简单名称）或关键字。
      static boolean isKeyword​(CharSequence s)
      返回 s是否是最新源版本中的关键字，布尔文字或空文字。
      static boolean isKeyword​(CharSequence s, SourceVersion version)
      返回在给定的源版本中， s是关键字，布尔文字或空文字。
      static boolean isName​(CharSequence name)
      返回 name是否是最新版本的语法有效的限定名称。
      static boolean isName​(CharSequence name, SourceVersion version)
      返回是否 name是给定源版本中的语法有效的限定名称。
      static SourceVersion latest​()
      返回可以建模的最新的源版本。
      static SourceVersion latestSupported​()
      返回当前执行环境完全支持的最新源版本。
      static SourceVersion valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SourceVersion[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • RELEASE_0

        public static final SourceVersion RELEASE_0
        原版。 该语言描述于The Java™ Language Specification, First Edition 。

      • RELEASE_1

        public static final SourceVersion RELEASE_1
        Java Platform 1.1认可的版本。 该语言是RELEASE_0增加了嵌套类，如1.1更新到The Java™ Language Specification, First Edition中所述 。

      • RELEASE_2

        public static final SourceVersion RELEASE_2
        由Java 2 Platform，Standard Edition v 1.2认可的版本。 在The Java™ Language Specification, Second Edition中描述的语言，其中包括strictfp修饰符。

      • RELEASE_3

        public static final SourceVersion RELEASE_3
        由Java 2 Platform，Standard Edition，v 1.3认可的版本。 与RELEASE_2没有重大变化。

      • RELEASE_4

        public static final SourceVersion RELEASE_4
        由Java 2 Platform，Standard Edition v 1.4认可的版本。 增加了一个简单的断言设施。

      • RELEASE_5

        public static final SourceVersion RELEASE_5
        由Java 2 Platform，Standard Edition 5.0认可的版本。 该语言描述于The Java™ Language Specification, Third Edition 。 第一个版本支持泛型，注释，autoboxing，var-args，增强的for循环和十六进制浮点数字。

      • RELEASE_6

        public static final SourceVersion RELEASE_6
        Java Platform，Standard Edition 6认可的版本。与 RELEASE_5没有重大变化。

      • RELEASE_7

        public static final SourceVersion RELEASE_7
        Java Platform，Standard Edition 7认可的版本。此版本中的添加包括构造函数的菱形语法， try -with-resources，开关中的字符串，二进制文字和多重捕获。
        从以下版本开始：
        1.7

      • RELEASE_8

        public static final SourceVersion RELEASE_8
        Java Platform，Standard Edition 8认可的版本。此版本中的添加包括lambda表达式和默认方法。
        从以下版本开始：
        1.8

      • RELEASE_9

        public static final SourceVersion RELEASE_9
        Java Platform，Standard Edition 9认可的版本。此版本中的添加包括模块和从合法标识符名称集中删除单个下划线。
        从以下版本开始：
        9

    • 方法详细信息

      • values

        public static SourceVersion[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (SourceVersion c : SourceVersion.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static SourceVersion valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • latest

        public static SourceVersion latest​()
        返回可以建模的最新的源版本。
        结果
        最新的源代码版本可以建模

      • latestSupported

        public static SourceVersion latestSupported​()
        返回当前执行环境完全支持的最新源版本。 必须退回RELEASE_5或更高版本。
        结果
        完全支持的最新的源版本

      • isIdentifier

        public static boolean isIdentifier​(CharSequence name)
        返回name是否是最新源版本中的语法有效的标识符（简单名称）或关键字。 该方法返回true如果该名称包括一个初始字符为其中Character.isJavaIdentifierStart(int)返回true ，由字符仅遵循其Character.isJavaIdentifierPart(int)返回true 。 此模式匹配常规标识符，关键字和文字"true" ， "false" ，并"null" 。 该方法为所有其他字符串返回false 。
        参数
        name - 要检查的字符串
        结果
        true如果这个字符串是一个语法上有效的标识符或关键字， false否则。

      • isName

        public static boolean isName​(CharSequence name)
        返回name是否是最新版本的语法上有效的限定名称。 与isIdentifier不同，此方法为关键字，布尔文字和空文本返回false 。
        参数
        name - 要检查的字符串
        结果
        true如果这个字符串是一个语法上有效的名字， false否则。
        See The Java™ Language Specification:
        6.2名称和标识符

      • isName

        public static boolean isName​(CharSequence name,
                             SourceVersion version)
        返回是否name是给定源版本中的语法有效的限定名称。 与isIdentifier不同，此方法为关键字，布尔文字和空字面值返回false 。
        参数
        name - 要检查的字符串
        version - 要使用的版本
        结果
        true如果这个字符串是一个语法上有效的名字， false否则。
        从以下版本开始：
        9
        See The Java™ Language Specification:
        6.2名称和标识符

      • isKeyword

        public static boolean isKeyword​(CharSequence s)
        返回 s是否是最新源版本中的关键字，布尔文字或空文字。
        参数
        s - 要检查的字符串
        结果
        true如果 s是一个关键字，或者布尔文字，或者是空文字， false否则。
        See The Java™ Language Specification:
        3.9关键字，3.10.3布尔文字，3.10.7空字面

      • isKeyword

        public static boolean isKeyword​(CharSequence s,
                                SourceVersion version)
        返回在给定的源版本中， s是关键字，布尔文字或空文字。
        参数
        s - 要检查的字符串
        version - 要使用的版本
        结果
        true如果 s是关键字，或布尔文字，或者为空字面值， false 。
        从以下版本开始：
        9
        See The Java™ Language Specification:
        3.9关键字，3.10.3布尔文字，3.10.7空字面
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


UnknownEntityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model

Class UnknownEntityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.lang.model.UnknownEntityException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    UnknownAnnotationValueException ， UnknownDirectiveException ， UnknownElementException ， UnknownTypeException

    public class UnknownEntityException
extends RuntimeException
    例外的超类，表示遇到一个未知类型的实体。 如果语言演变和引入新的构造，就会发生这种情况。 访问者可能会抛出此异常的子类，以指示访问者是为先前版本的语言创建的。
    API Note:
    对于不同种类的未知实体特定的异常的常见超类允许单个catch块容易地提供对这些相关条件的统一处理。
    从以下版本开始：
    1.7
    另请参见：
    UnknownElementException ， UnknownAnnotationValueException ， UnknownTypeException ， Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected UnknownEntityException​(String message)
      创建一个新的 UnknownEntityException与指定的详细消息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownEntityException

        protected UnknownEntityException​(String message)
        创建一个新的 UnknownEntityException具有指定的详细消息。
        参数
        message - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.lang.model (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.lang.model

  • Packages that use javax.lang.model
    软件包 描述
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
  • Classes in javax.lang.model used by javax.annotation.processing
    Class 描述
    SourceVersion
    源代码版本的Java编程语言。
  • Classes in javax.lang.model used by javax.lang.model
    Class 描述
    SourceVersion
    源代码版本的Java编程语言。
  • Classes in javax.lang.model used by javax.lang.model.element
    Class 描述
    AnnotatedConstruct
    表示可以注释的构造。
    UnknownEntityException
    例外的超类，表示遇到一个未知类型的实体。
  • Classes in javax.lang.model used by javax.lang.model.type
    Class 描述
    AnnotatedConstruct
    表示可以注释的构造。
    UnknownEntityException
    例外的超类，表示遇到一个未知类型的实体。
  • Classes in javax.lang.model used by javax.lang.model.util
    Class 描述
    AnnotatedConstruct
    表示可以注释的构造。
  • Classes in javax.lang.model used by javax.tools
    Class 描述
    SourceVersion
    源代码版本的Java编程语言。
  • Classes in javax.lang.model used by jdk.javadoc.doclet
    Class 描述
    SourceVersion
    源代码版本的Java编程语言。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.lang.model.SourceVersion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.lang.model.SourceVersion

  • Packages that use SourceVersion
    软件包 描述
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。

    • Uses of SourceVersion in javax.annotation.processing

      Methods in javax.annotation.processing that return SourceVersion
      Modifier and Type 方法 描述
      SourceVersion ProcessingEnvironment.getSourceVersion​()
      返回任何生成的 source和 class文件应符合的源版本。
      SourceVersion AbstractProcessor.getSupportedSourceVersion​()
      如果处理器类注释为SupportedSourceVersion ，则返回注释中的源版本。
      SourceVersion Processor.getSupportedSourceVersion​()
      返回此注释处理器支持的最新的源版本。

    • Uses of SourceVersion in javax.lang.model

      Methods in javax.lang.model that return SourceVersion
      Modifier and Type 方法 描述
      static SourceVersion SourceVersion.latest​()
      返回可以建模的最新的源版本。
      static SourceVersion SourceVersion.latestSupported​()
      返回当前执行环境完全支持的最新源版本。
      static SourceVersion SourceVersion.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static SourceVersion[] SourceVersion.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javax.lang.model with parameters of type SourceVersion
      Modifier and Type 方法 描述
      static boolean SourceVersion.isKeyword​(CharSequence s, SourceVersion version)
      返回在给定的源版本中， s是关键字，布尔文字或空文字。
      static boolean SourceVersion.isName​(CharSequence name, SourceVersion version)
      返回在给定的源版本中， name是否是语法上有效的限定名称。

    • Uses of SourceVersion in javax.tools

      Methods in javax.tools that return types with arguments of type SourceVersion
      Modifier and Type 方法 描述
      Set<SourceVersion> Tool.getSourceVersions​()
      返回此工具支持的Java™编程语言的源代码版本。

    • Uses of SourceVersion in jdk.javadoc.doclet

      Methods in jdk.javadoc.doclet that return SourceVersion
      Modifier and Type | 方法 | 描述
      SourceVersion DocletEnvironment.getSourceVersion​()
      返回读取的源文件的源版本。
      SourceVersion Doclet.getSupportedSourceVersion​()
      返回此doclet支持的Java编程语言的版本。
      SourceVersion | StandardDoclet.getSupportedSourceVersion​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.lang.model.UnknownEntityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.lang.model.UnknownEntityException

  • Packages that use UnknownEntityException
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。

    • Uses of UnknownEntityException in javax.lang.model.element

      Subclasses of UnknownEntityException in javax.lang.model.element
      Modifier and Type Class 描述
      class  UnknownAnnotationValueException
      表示遇到未知类型的注释值。
      class  UnknownDirectiveException
      表示遇到未知类型的模块指令。
      class  UnknownElementException
      表示遇到未知类型的元素。

    • Uses of UnknownEntityException in javax.lang.model.type

      Subclasses of UnknownEntityException in javax.lang.model.type
      Modifier and Type Class 描述
      class  UnknownTypeException
      表示遇到未知类型的类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.AnnotatedConstruct (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.AnnotatedConstruct

  • Packages that use AnnotatedConstruct
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of AnnotatedConstruct in javax.lang.model.element

      Subinterfaces of AnnotatedConstruct in javax.lang.model.element
      Modifier and Type 接口 描述
      interface  Element
      表示程序元素，如模块，包，类或方法。
      interface  ExecutableElement
      表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
      interface  ModuleElement
      表示一个模块程序元素。
      interface  PackageElement
      表示包程序元素。
      interface  Parameterizable
      用于具有类型参数的元素的mixin接口。
      interface  QualifiedNameable
      用于具有限定名称的元素的mixin接口。
      interface  TypeElement
      表示一个类或接口程序元素。
      interface  TypeParameterElement
      表示通用类，接口，方法或构造函数元素的正式类型参数。
      interface  VariableElement
      表示一个字段， 枚举常量，方法或构造函数参数，局部变量，资源变量或异常参数。

    • Uses of AnnotatedConstruct in javax.lang.model.type

      Subinterfaces of AnnotatedConstruct in javax.lang.model.type
      Modifier and Type 接口 描述
      interface  ArrayType
      表示数组类型。
      interface  DeclaredType
      表示声明的类型，类类型或接口类型。
      interface  ErrorType
      表示无法正确建模的类或接口类型。
      interface  ExecutableType
      表示可执行文件的类型。
      interface  IntersectionType
      表示交叉路口类型。
      interface  NoType
      在没有实际类型适合的情况下使用的伪类型。
      interface  NullType
      表示空类型。
      interface  PrimitiveType
      表示原始类型。
      interface  ReferenceType
      表示参考类型。
      interface  TypeMirror
      表示Java编程语言中的一种类型。
      interface  TypeVariable
      表示一个类型变量。
      interface  UnionType
      表示联合类型。
      interface  WildcardType
      表示通配符类型参数。

    • Uses of AnnotatedConstruct in javax.lang.model.util

      Methods in javax.lang.model.util with parameters of type AnnotatedConstruct
      Modifier and Type 方法 描述
      default Elements.Origin Elements.getOrigin​(AnnotatedConstruct c, AnnotationMirror a)
      返回给定注释镜的 起点 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


AnnotationMirror (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface AnnotationMirror

  • public interface AnnotationMirror
    表示注释。 注释将值与注释类型的每个元素相关联。

    应使用equals方法比较注释。 不能保证任何特定的注释始终由同一个对象表示。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      DeclaredType getAnnotationType​()
      返回此注释的类型。
      Map<? extends ExecutableElement,? extends AnnotationValue> getElementValues​()
      返回此注释元素的值。

    • 方法详细信息

      • getAnnotationType

        DeclaredType getAnnotationType​()
        返回此注释的类型。
        结果
        该注释的类型

      • getElementValues

        Map<? extends ExecutableElement,? extends AnnotationValue> getElementValues​()
        返回此注释元素的值。 这是以将其与相应值相关联的映射形式返回的。 仅包含在注释中明确显示值的元素，而不是隐式假定其默认值的那些元素。 地图的顺序与值在注释源中显示的顺序相匹配。

        请注意，标记注释类型的注释镜像将定义为空贴图。

        要填写默认值，请使用getElementValuesWithDefaults 。

        结果
        这个注释的元素的值，或者没有空的地图
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AnnotationValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface AnnotationValue

  • public interface AnnotationValue
    表示注释类型元素的值。 值为以下类型之一：
    • 一个原始类型的包装类（如Integer ）
    • String
    • TypeMirror
    • VariableElement （表示枚举常数）
    • AnnotationMirror
    • List<? extends AnnotationValue> （以声明顺序表示元素，如果该值为数组）
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      <R,P> R accept​(AnnotationValueVisitor<R,P> v, P p)
      将访问者应用于此值。
      Object getValue​()
      返回值。
      String toString​()
      返回此值的字符串表示形式。

    • 方法详细信息

      • getValue

        Object getValue​()
        返回值。
        结果
        价值

      • toString

        String toString​()
        返回此值的字符串表示形式。 这是以适合于在注释的源代码中表示该值的形式返回的。
        重写：
        toString在 Object
        结果
        该值的字符串表示形式

      • accept

        <R,P> R accept​(AnnotationValueVisitor<R,P> v,
               P p)
        将访问者应用于此值。
        参数类型
        R - 访问者方法的返回类型
        P - 访问者方法的附加参数类型
        参数
        v - 访问者操作此值
        p - 访问者的附加参数
        结果
        访客指定的结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AnnotationValueVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface AnnotationValueVisitor<R,P>

  • 参数类型
    R - 这个访问者的方法的返回类型
    P - 访问者方法的附加参数类型。
    所有已知实现类：
    AbstractAnnotationValueVisitor6 ， AbstractAnnotationValueVisitor7 ， AbstractAnnotationValueVisitor8 ， AbstractAnnotationValueVisitor9 ， SimpleAnnotationValueVisitor6 ， SimpleAnnotationValueVisitor7 ， SimpleAnnotationValueVisitor8 ， SimpleAnnotationValueVisitor9

    public interface AnnotationValueVisitor<R,P>
    注释类型元素的值的访问者，使用访问者设计模式的变体。 与根据类型层次结构的成员的具体类型进行调度的标准访问者不同，该访问者根据存储的数据类型进行调度; 没有明确的子类存储，例如boolean值与int值。 实现此接口的类用于在编译时该值的类型未知时对值进行操作。 当访问者传递给值为accept的方法时，将调用适用于该值的visitXyz方法。

    实现此界面的类可以或可以不抛出NullPointerException如果附加参数p是null ; 有关详细信息，请参阅实施类的文档。

    警告：可能的方法将添加到此界面以适应未来版本的Java编程语言中添加的新的，当前未知的语言结构。 因此，直接实现此接口的访问者类可能与未来的平台版本不兼容。 为了避免这种源不兼容，我们鼓励访问者实现扩展实现此接口的适当抽象访问类。 然而，API通常应该将此访问接口用作参数，返回类型等的类型，而不是抽象类之一。

    请注意，如果添加为默认方法，则可以以源兼容的方式添加适应新语言结构的方法 。 但是，默认方法仅适用于Java SE 8和更高版本，并且Java SE 8中捆绑的javax.lang.model.*软件包也需要在Java SE 7上运行。因此，在扩展javax.lang.model.*以涵盖Java SE 8语言时， 不使用默认方法特征。 然而，默认方法用于仅需要在Java SE 8和更高版本平台上运行的javax.lang.model.*软件包的后续修订版本。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default R visit​(AnnotationValue av)
      方便的方法相当于 visit(av, null) 。
      R visit​(AnnotationValue av, P p)
      访问注释值。
      R visitAnnotation​(AnnotationMirror a, P p)
      访问注释中的注释值。
      R visitArray​(List<? extends AnnotationValue> vals, P p)
      访问注释中的数组值。
      R visitBoolean​(boolean b, P p)
      访问一个注释中的一个 boolean值。
      R visitByte​(byte b, P p)
      访问一个注释中的一个 byte值。
      R visitChar​(char c, P p)
      访问一个注释中的一个 char值。
      R visitDouble​(double d, P p)
      访问一个注释中的一个 double值。
      R visitEnumConstant​(VariableElement c, P p)
      访问注释中的 枚举值。
      R visitFloat​(float f, P p)
      访问一个注释中的一个 float值。
      R visitInt​(int i, P p)
      访问注释中的一个 int值。
      R visitLong​(long i, P p)
      访问一个注释中的一个 long值。
      R visitShort​(short s, P p)
      访问一个注释中的一个 short值。
      R visitString​(String s, P p)
      访问注释中的字符串值。
      R visitType​(TypeMirror t, P p)
      访问注释中的类型值。
      R visitUnknown​(AnnotationValue av, P p)
      访问未知类型的注释值。

    • 方法详细信息

      • visit

        R visit​(AnnotationValue av,
        P p)
        访问注释值。
        参数
        av - 要访问的值
        p - 访客指定的参数
        结果
        访客指定的结果

      • visit

        default R visit​(AnnotationValue av)
        一个方便的方法相当于 visit(av, null) 。
        实现要求：
        默认实现为 visit(av, null) 。
        参数
        av - 要访问的值
        结果
        访客指定的结果

      • visitBoolean

        R visitBoolean​(boolean b,
               P p)
        访问一个注释中的一个 boolean值。
        参数
        b - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitByte

        R visitByte​(byte b,
            P p)
        访问一个注释中的一个 byte值。
        参数
        b - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitChar

        R visitChar​(char c,
            P p)
        访问一个注释中的一个 char值。
        参数
        c - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitDouble

        R visitDouble​(double d,
              P p)
        访问注释中的 double值。
        参数
        d - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitFloat

        R visitFloat​(float f,
             P p)
        访问一个注释中的一个 float值。
        参数
        f - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitInt

        R visitInt​(int i,
           P p)
        访问注释中的一个 int值。
        参数
        i - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitLong

        R visitLong​(long i,
            P p)
        在注释中访问 long值。
        参数
        i - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitShort

        R visitShort​(short s,
             P p)
        访问一个注释中的一个 short值。
        参数
        s - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitString

        R visitString​(String s,
              P p)
        访问注释中的字符串值。
        参数
        s - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitType

        R visitType​(TypeMirror t,
            P p)
        访问注释中的类型值。
        参数
        t - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitEnumConstant

        R visitEnumConstant​(VariableElement c,
                    P p)
        访问注释中的 枚举值。
        参数
        c - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitAnnotation

        R visitAnnotation​(AnnotationMirror a,
                  P p)
        访问注释中的注释值。
        参数
        a - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitArray

        R visitArray​(List<? extends AnnotationValue> vals,
             P p)
        访问注释中的数组值。
        参数
        vals - 正在访问的值
        p - 访客指定的参数
        结果
        访问的结果

      • visitUnknown

        R visitUnknown​(AnnotationValue av,
               P p)
        访问未知类型的注释值。 如果语言发展，并且可以将新种类的值存储在注释中，则可能会发生这种情况。
        参数
        av - 正在访问的未知值
        p - 访客指定的参数
        结果
        访问的结果
        异常
        UnknownAnnotationValueException - 访问者实现可以可选地抛出该异常
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Element (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface Element

  • All Superinterfaces:
    AnnotatedConstruct
    All Known Subinterfaces:
    ExecutableElement ， ModuleElement ， PackageElement ， Parameterizable ， QualifiedNameable ， TypeElement ， TypeParameterElement ， VariableElement

    public interface Element
extends AnnotatedConstruct
    表示程序元素，如模块，包，类或方法。 每个元素表示静态的语言级结构（而不是虚拟机的运行时结构）。

    应使用equals(Object)方法比较元素。 不能保证任何特定元素始终由同一个对象表示。

    要实现基于Element对象类的操作，请使用visitor或使用getKind()方法的结果。 使用instanceof 不一定是确定有效类的对象在这个造型层次，因为一个实现可以选择让单个对象实现多个可靠的成语Element子接口。

    从以下版本开始：
    1.6
    另请参见：
    Elements ， TypeMirror

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      <R,P> R accept​(ElementVisitor<R,P> v, P p)
      将访问者应用于此元素。
      TypeMirror asType​()
      返回此元素定义的类型。
      boolean equals​(Object obj)
      返回 true如果参数表示相同的元件作为 this ，或 false否则。
      <A extends Annotation>
      A             		getAnnotation​(Class<A> annotationType)
      返回指定类型的这种构造的注解，如果这样的注释 存在 ，否则 null 。
      List<? extends AnnotationMirror> getAnnotationMirrors​()
      返回 直接存在于此构造上的注释。
      List<? extends Element> getEnclosedElements​()
      返回由这个元素直接包围的松散元素。
      Element getEnclosingElement​()
      返回这个元素所在的最内层元素。
      ElementKind getKind​()
      返回此元素的 kind 。
      Set<Modifier> getModifiers​()
      返回此元素的修饰符，不包括注释。
      Name getSimpleName​()
      返回此元素的简单（不合格）名称。
      int hashCode​()
      遵守 Object.hashCode的一般合同。

      • Methods inherited from interface javax.lang.model.AnnotatedConstruct

        getAnnotationsByType

    • 方法详细信息

      • asType

        TypeMirror asType​()
        返回此元素定义的类型。

        通用元素定义了一系列类型，而不仅仅是一个类型。 如果这是一个通用元素，则返回原型类型。 这是元素对与其自己的形式类型参数相对应的类型变量的调用。 例如，对于通用类元素C<N extends Number> ，返回参数化类型C<N> 。 Types实用程序界面具有更多的一般方法来获取元素定义的全部范围。

        结果
        该元素定义的类型
        另请参见：
        Types

      • getKind

        ElementKind getKind​()
        返回此元素的 kind 。
        结果
        这种元素的种类

      • getModifiers

        Set<Modifier> getModifiers​()
        返回此元素的修饰符，不包括注释。 包含隐式修饰符，如接口成员的public和static修饰符。
        结果
        该元素的修饰符，如果没有，则为空集

      • getSimpleName

        Name getSimpleName​()
        返回此元素的简单（不合格）名称。 通用类型的名称不包括对其正式类型参数的任何引用。 例如，类型元素java.util.Set<E>的简单名称是"Set" 。 如果此元素表示未命名的package或未命名的module ，则返回一个空名称。 如果代表constructor ，则返回名称“ <init> ”。 如果代表static initializer ，则返回名称“ <clinit> ”。 如果它代表一个anonymous class或instance initializer ，则返回一个空名 。
        结果
        这个元素的简单名称
        另请参见：
        PackageElement.getSimpleName() ，
ExecutableElement.getSimpleName() ，
TypeElement.getSimpleName() ，
VariableElement.getSimpleName() ，
ModuleElement.getSimpleName()

      • getEnclosingElement

        Element getEnclosingElement​()
        返回这个元素所在的最内层元素。
        • 如果这个元素是一个声明在另一个元素的声明中立即包含声明的元素，则返回该另一个元素。
        • 如果是top-level type ，则返回其包。
        • 如果这是一个package ，如果这样的模块存在，则返回其模块。 否则返回null 。
        • 如果是type parameter ，则返回类型参数的the generic element 。
        • 如果这是一个method or constructor parameter ，其中声明返回参数的the executable element 。
        • 如果是module ，则返回null 。
        结果
        封闭元素，如果没有， null
        另请参见：
        Elements.getPackageOf(javax.lang.model.element.Element)

      • getEnclosedElements

        List<? extends Element> getEnclosedElements​()
        返回由这个元素直接包围的松散元素。 A class or interface被认为包含它直接声明的字段，方法，构造函数和成员类型。 A package包含其中的顶级类和接口，但不被视为封装子包。 A module在其中包围包。 封闭元件可包括隐含声明mandated个元素。 目前还没有其他类型的要素包含任何要素; 然而，这可能会随着API或编程语言的发展而改变。
        API Note:
        某些种类的元素可以使用ElementFilter中的方法进行分离。
        结果
        封闭的元素，如果没有空列表
        另请参见：
        TypeElement.getEnclosedElements() ，
PackageElement.getEnclosedElements() ，
ModuleElement.getEnclosedElements() ，
Elements.getAllMembers(javax.lang.model.element.TypeElement)
        See The Java™ Language Specification:
        8.8.9默认构造函数，8.9枚

      • equals

        boolean equals​(Object obj)
        返回 true如果参数表示相同的元件作为 this ，或 false否则。
        重写：
        equals在 Object
        API Note:
        元素的身份涉及不能直接从元素的方法访问的隐含状态，包括关于不相关类型的存在的状态。 通过这些接口的不同实施方式创建的元素对象不应该被预期为即使“相同的”元件被建模相等; 这类似于Class对象通过不同类加载器加载的同一类文件的不等式。
        参数
        obj - 要与此元素进行比较的对象
        结果
        true如果指定的对象表示与此相同的元素
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        遵守 Object.hashCode的一般合同。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        equals(java.lang.Object)

      • getAnnotationMirrors

        List<? extends AnnotationMirror> getAnnotationMirrors​()
        返回直接存在于此构造上的注释。

        要获取继承的注释，请使用getAllAnnotationMirrors 。

        Specified by:
        getAnnotationMirrors在接口 AnnotatedConstruct
        结果
        该结构上直接出现的注释; 一个空列表，如果没有
        从以下版本开始：
        1.6

      • getAnnotation

        <A extends Annotation> A getAnnotation​(Class<A> annotationType)
        返回指定类型的这种构造的注解，如果这样的注释存在 ，否则null 。

        此方法返回的注释可能包含一个值为Class的元素。 此值无法直接返回：查找和加载类（例如要使用的类加载器）所需的信息不可用，并且该类可能无法加载。 通过对返回的注释调用相关方法，尝试读取Class对象将导致一个MirroredTypeException ，从中可以提取相应的TypeMirror 。 类似地，尝试读取一个Class[]值将导致一个MirroredTypesException 。

        Note: This method is unlike others in this and related interfaces. It operates on runtime reflective information — representations of annotation types currently loaded into the VM — rather than on the representations defined by and used throughout these interfaces. Consequently, calling methods on the returned annotation object can throw many of the exceptions that can be thrown when calling methods on an annotation object returned by core reflection. This method is intended for callers that are written to operate on a known, fixed set of annotation types.
        Specified by:
        getAnnotation在接口 AnnotatedConstruct
        参数类型
        A - 注释类型
        参数
        annotationType - 对应于注释类型的 Class对象
        结果
        该构造的注释指定的注释类型，如果存在，否则为 null
        从以下版本开始：
        1.6
        另请参见：
        AnnotatedConstruct.getAnnotationMirrors() ， AnnotatedElement.getAnnotation(java.lang.Class<T>) ， EnumConstantNotPresentException ， AnnotationTypeMismatchException ， IncompleteAnnotationException ， MirroredTypeException ， MirroredTypesException

      • accept

        <R,P> R accept​(ElementVisitor<R,P> v,
               P p)
        将访问者应用于此元素。
        参数类型
        R - 访问者方法的返回类型
        P - 访问者方法的附加参数的类型
        参数
        v - 访问者操作此元素
        p - 访问者的附加参数
        结果
        a visitor-specified result
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ElementKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Enum ElementKind

  • java.lang.Object
    • java.lang.Enum<ElementKind>
      • javax.lang.model.element.ElementKind
  • All Implemented Interfaces:
    Serializable ， Comparable<ElementKind>

    public enum ElementKind
extends Enum<ElementKind>
    一个元素的kind 。

    请注意，可能会添加其他元素种类，以适应未来版本的Java编程语言中添加的新的，当前未知的语言结构。

    从以下版本开始：
    1.6
    另请参见：
    Element

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ANNOTATION_TYPE
      注释类型。
      CLASS
      一个没有被更具体种类描述的课程（如 ENUM ）。
      CONSTRUCTOR
      一个构造函数。
      ENUM
      枚举类型。
      ENUM_CONSTANT
      枚举常数。
      EXCEPTION_PARAMETER
      异常处理程序的参数。
      字段
      一个未被更具体种类描述的字段（如 ENUM_CONSTANT ）。
      INSTANCE_INIT
      一个实例初始化器。
      INTERFACE
      不具体描述的界面（如 ANNOTATION_TYPE ）。
      LOCAL_VARIABLE
      一个局部变量。
      METHOD
      一个方法。
      MODULE
      一个模块
      OTHER
      一个实现保留元素。
      PACKAGE
      一套。
      PARAMETER
      方法或构造函数的参数。
      RESOURCE_VARIABLE
      资源变量。
      STATIC_INIT
      静态初始化程序。
      TYPE_PARAMETER
      一个类型参数。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean isClass​()
      如果这是一种类，则返回 true ： CLASS或 ENUM 。
      boolean isField​()
      如果这是一种字段，则返回 true ： 字段或 ENUM_CONSTANT 。
      boolean isInterface​()
      如果这是一种接口，则返回 true ： INTERFACE或 ANNOTATION_TYPE 。
      static ElementKind valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ElementKind[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PACKAGE

        public static final ElementKind PACKAGE
        一套。

      • ENUM

        public static final ElementKind ENUM
        枚举类型。

      • CLASS

        public static final ElementKind CLASS
        一个没有更具体种类描述的课程（如 ENUM ）。

      • ANNOTATION_TYPE

        public static final ElementKind ANNOTATION_TYPE
        注释类型。

      • INTERFACE

        public static final ElementKind INTERFACE
        不具体描述的界面（如 ANNOTATION_TYPE ）。

      • ENUM_CONSTANT

        public static final ElementKind ENUM_CONSTANT
        枚举常数。

      • 字段

        public static final ElementKind FIELD
        一个未被更具体种类描述的字段（如 ENUM_CONSTANT ）。

      • PARAMETER

        public static final ElementKind PARAMETER
        方法或构造函数的参数。

      • LOCAL_VARIABLE

        public static final ElementKind LOCAL_VARIABLE
        一个局部变量。

      • EXCEPTION_PARAMETER

        public static final ElementKind EXCEPTION_PARAMETER
        异常处理程序的参数。

      • METHOD

        public static final ElementKind METHOD
        一个方法。

      • CONSTRUCTOR

        public static final ElementKind CONSTRUCTOR
        一个构造函数。

      • STATIC_INIT

        public static final ElementKind STATIC_INIT
        静态初始化程序。

      • INSTANCE_INIT

        public static final ElementKind INSTANCE_INIT
        一个实例初始化器。

      • TYPE_PARAMETER

        public static final ElementKind TYPE_PARAMETER
        一个类型参数。

      • OTHER

        public static final ElementKind OTHER
        一个实现保留元素。 这不是你要找的元素。

      • RESOURCE_VARIABLE

        public static final ElementKind RESOURCE_VARIABLE
        资源变量。
        从以下版本开始：
        1.7

      • MODULE

        public static final ElementKind MODULE
        一个模块
        从以下版本开始：
        9

    • 方法详细信息

      • values

        public static ElementKind[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ElementKind c : ElementKind.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ElementKind valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • isClass

        public boolean isClass​()
        如果这是一种类，则返回 true ： CLASS或 ENUM 。
        结果
        true如果这是一种类

      • isInterface

        public boolean isInterface​()
        如果这是一种接口，则返回 true ： INTERFACE或 ANNOTATION_TYPE 。
        结果
        true如果这是一种接口

      • isField

        public boolean isField​()
        如果这是一种字段，则返回 true ： 字段或 ENUM_CONSTANT 。
        结果
        true如果这是一种字段
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ElementVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ElementVisitor<R,P>

  • 参数类型
    R - 这个访问者的方法的返回类型。 对不需要返回结果的访问者使用Void 。
    P - 此访问者方法的附加参数的类型。 对不需要附加参数的访问者使用Void 。
    所有已知实现类：
    AbstractElementVisitor6 ， AbstractElementVisitor7 ， AbstractElementVisitor8 ， AbstractElementVisitor9 ， ElementKindVisitor6 ， ElementKindVisitor7 ， ElementKindVisitor8 ， ElementKindVisitor9 ， ElementScanner6 ， ElementScanner7 ， ElementScanner8 ， ElementScanner9 ， SimpleElementVisitor6 ， SimpleElementVisitor7 ， SimpleElementVisitor8 ， SimpleElementVisitor9

    public interface ElementVisitor<R,P>
    游客的程式元素，以访客设计风格为格局。 实现此接口的类用于在编译时元素的种类未知时对元素进行操作。 当访问者被传递到元素的accept方法时，调用最适用于该元素的visitXyz方法。

    实现此界面的类可以或可以不抛出NullPointerException如果附加参数p是null ; 有关详细信息，请参阅实施类的文档。

    警告：可能的方法将添加到此界面以适应未来版本的Java编程语言中添加的新的，当前未知的语言结构。 因此，直接实现此接口的访问者类可能与未来的平台版本不兼容。 为了避免这种源不兼容，我们鼓励访问者实现扩展实现此接口的适当抽象访问类。 然而，API通常应该将此访问接口用作参数，返回类型等的类型，而不是抽象类之一。

    请注意，如果添加为默认方法，则可以以源兼容的方式添加适应新语言结构的方法 。 但是，默认方法仅在Java SE 8和更高版本上可用，并且Java SE 8中捆绑的javax.lang.model.*软件包也需要在Java SE 7上运行。因此，在扩展javax.lang.model.*以涵盖Java SE 8语言时， 未使用默认方法特征。 然而，默认方法用于仅需要在Java SE 8和更高版本平台上运行的javax.lang.model.*软件包的后续修订版本。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default R visit​(Element e)
      方便的方法相当于 visit(e, null) 。
      R visit​(Element e, P p)
      访问元素
      R visitExecutable​(ExecutableElement e, P p)
      访问可执行元素。
      default R visitModule​(ModuleElement e, P p)
      访问模块元素。
      R visitPackage​(PackageElement e, P p)
      访问包元素。
      R visitType​(TypeElement e, P p)
      访问类型元素。
      R visitTypeParameter​(TypeParameterElement e, P p)
      访问类型参数元素。
      R visitUnknown​(Element e, P p)
      访问一种未知的元素。
      R visitVariable​(VariableElement e, P p)
      访问可变元素。

    • 方法详细信息

      • visit

        R visit​(Element e,
        P p)
        访问元素
        参数
        e - 要访问的元素
        p - 访客指定的参数
        结果
        访客指定的结果

      • visit

        default R visit​(Element e)
        方便的方法相当于 visit(e, null) 。
        实现要求：
        默认实现为 visit(e, null) 。
        参数
        e - 要访问的元素
        结果
        访客指定的结果

      • visitPackage

        R visitPackage​(PackageElement e,
               P p)
        访问包元素。
        参数
        e - 要访问的元素
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitType

        R visitType​(TypeElement e,
            P p)
        访问类型元素。
        参数
        e - 要访问的元素
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitVariable

        R visitVariable​(VariableElement e,
                P p)
        访问可变元素。
        参数
        e - 要访问的元素
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitExecutable

        R visitExecutable​(ExecutableElement e,
                  P p)
        访问可执行元素。
        参数
        e - 要访问的元素
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitTypeParameter

        R visitTypeParameter​(TypeParameterElement e,
                     P p)
        访问类型参数元素。
        参数
        e - 要访问的元素
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitUnknown

        R visitUnknown​(Element e,
               P p)
        访问一种未知的元素。 如果语言发展并且将新种类的元素添加到Element层次结构中，则可能会发生这种情况。
        参数
        e - 要访问的元素
        p - 访客指定的参数
        结果
        访客指定的结果
        异常
        UnknownElementException - 访问者实现可以可选地抛出该异常

      • visitModule

        default R visitModule​(ModuleElement e,
                      P p)
        访问模块元素。
        实现要求：
        访问一个 ModuleElement致电 visitUnknown(e, p) 。
        参数
        e - 要访问的元素
        p - 访客指定的参数
        结果
        访客指定的结果
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExecutableElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ExecutableElement

  • All Superinterfaces:
    AnnotatedConstruct ， Element ， Parameterizable

    public interface ExecutableElement
extends Element, Parameterizable
    表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
    从以下版本开始：
    1.6
    另请参见：
    ExecutableType

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AnnotationValue getDefaultValue​()
      如果此可执行文件是注释类型元素，则返回默认值。
      List<? extends VariableElement> getParameters​()
      返回此可执行文件的形式参数。
      TypeMirror getReceiverType​()
      返回此可执行文件的接收器类型，或NoType用一种NONE如果可执行文件没有接收器类型。
      TypeMirror getReturnType​()
      返回此可执行文件的返回类型。
      Name getSimpleName​()
      返回构造函数，方法或初始值设置的简单名称。
      List<? extends TypeMirror> getThrownTypes​()
      以声明顺序返回此方法或构造函数 throws子句中列出的异常和其他可抛出物。
      List<? extends TypeParameterElement> getTypeParameters​()
      以声明顺序返回此可执行文件的正式类型参数。
      boolean isDefault​()
      返回 true如果此方法是默认的方法，并返回 false否则。
      boolean isVarArgs​()
      返回 true如果此方法或构造接受可变数量的参数，并返回 false否则。

      • Methods inherited from interface javax.lang.model.AnnotatedConstruct

        getAnnotationsByType

      • Methods inherited from interface javax.lang.model.element.Element

        accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getEnclosingElement, getKind, getModifiers, hashCode

    • 方法详细信息

      • getTypeParameters

        List<? extends TypeParameterElement> getTypeParameters​()
        以声明顺序返回此可执行文件的正式类型参数。
        Specified by:
        getTypeParameters在接口 Parameterizable
        结果
        正式类型参数，如果没有，则为空列表

      • getReturnType

        TypeMirror getReturnType​()
        返回此可执行文件的返回类型。 返回NoType用一种VOID如果这个可执行文件是不是一种方法，或者是不返回值的方法。
        结果
        这个可执行文件的返回类型

      • getParameters

        List<? extends VariableElement> getParameters​()
        返回此可执行文件的形式参数。 他们以申报单退回。
        结果
        形式参数，或空列表，如果没有

      • getReceiverType

        TypeMirror getReceiverType​()
        如果可执行文件没有接收器类型，则返回此可执行文件的接收器类型，或NoType ，类型为NONE 。 作为实例方法或内部类的构造函数的可执行文件具有从declaring type派生的接收器类型。 作为静态方法的可执行程序，或非内部类的构造函数，或初始化程序（静态或实例），不具有接收器类型。
        结果
        这种可执行文件的接收器类型
        从以下版本开始：
        1.8

      • isVarArgs

        boolean isVarArgs​()
        返回 true如果此方法或构造接受可变数量的参数，并返回 false否则。
        结果
        true如果此方法或构造函数接受可变数量的参数，否则为 false

      • isDefault

        boolean isDefault​()
        返回 true如果此方法是默认的方法，并返回 false否则。
        结果
        true如果这个方法是一个默认的方法和另外 false
        从以下版本开始：
        1.8

      • getThrownTypes

        List<? extends TypeMirror> getThrownTypes​()
        以声明顺序返回此方法或构造函数 throws子句中列出的异常和其他可抛出物。
        结果
        throws子句中列出的异常和其他可抛出物，如果没有，则为空列表

      • getDefaultValue

        AnnotationValue getDefaultValue​()
        如果此可执行文件是注释类型元素，则返回默认值。 如果此方法不是注释类型元素，或者如果它是没有默认值的注释类型元素，则返回null 。
        结果
        默认值，或 null如果没有

      • getSimpleName

        Name getSimpleName​()
        返回构造函数，方法或初始值设置的简单名称。 对于构造函数，返回名称"<init>" ，对于静态初始化程序，返回名称"<clinit>" ，对于匿名类或实例初始化程序，返回空名称。
        Specified by:
        getSimpleName在接口 Element
        结果
        构造函数，方法或初始化程序的简单名称
        另请参见：
        PackageElement.getSimpleName() ，
getSimpleName() ，
TypeElement.getSimpleName() ，
VariableElement.getSimpleName() ，
ModuleElement.getSimpleName()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.lang.model.element (Java SE 9 & JDK 9 )

javax.lang.model.element

Interfaces

  • AnnotationMirror
  • AnnotationValue
  • AnnotationValueVisitor
  • Element
  • ElementVisitor
  • ExecutableElement
  • ModuleElement
  • ModuleElement.Directive
  • ModuleElement.DirectiveVisitor
  • ModuleElement.ExportsDirective
  • ModuleElement.OpensDirective
  • ModuleElement.ProvidesDirective
  • ModuleElement.RequiresDirective
  • ModuleElement.UsesDirective
  • Name
  • PackageElement
  • Parameterizable
  • QualifiedNameable
  • TypeElement
  • TypeParameterElement
  • VariableElement

Enums

  • ElementKind
  • Modifier
  • ModuleElement.DirectiveKind
  • NestingKind

Exceptions

  • UnknownAnnotationValueException
  • UnknownDirectiveException
  • UnknownElementException


javax.lang.model.element (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.compiler

Package javax.lang.model.element

用于建模Java编程语言元素的接口。 该包中的术语“元素”用于指程序元素，构成程序的声明实体。 元素包括类，接口，方法，构造函数和字段。 该包中的接口不会对方法体内的程序的结构建模; 例如没有for循环或try - finally块的表示。 但是，这些接口可以建立一些仅显示在方法体内的结构，例如局部变量和匿名类。

当在注释处理的上下文中使用时，必须返回正在表示的元素的精确模型。 由于这是一个语言模型，源代码提供了有问题的构造的基准（引用）表示，而不是类似于一个类文件的可执行输出中的表示。 可执行输出可以作为创建建模元素的基础。 然而，将源代码转换为可执行输出的过程可能不允许恢复源代码表示的某些方面。 例如， 27072492122611 retention的注释无法从类文件中恢复，类文件可能无法提供源位置信息。 参数名称可能无法从类文件中恢复。 从类文件创建的元素上的modifiers在某些情况下可能与源文件创建的相同声明的元素可能不同，包括：

  • strictfp在类或接口上
  • final上的一个参数
  • protected ， private ，并static的类和接口
mandated的某些元素在从类文件创建时可能不会被标记为这样。 另外，类文件中的synthetic构造，例如用于实现嵌套类的访问器方法和用于实现协变返回的bridge methods ，是严格在该模型之外的翻译工件。 但是，当对类文件进行操作时，可以对这些元素进行操作，在适当的时候进行筛选。

在注解处理过程中，需要对不完整或错误的程序进行操作; 然而，关于结果模型的性质的担保较少。 如果源代码在语法上没有格式化，或者有一些其他不可恢复的错误，不能通过生成新的类型来删除，则可能提供或不提供模型作为实现质量问题。 如果一个程序在语法上是有效的，但是以某种其他方式是错误的，那么任何返回的模型都不能少于程序中的所有方法体被"throw new RuntimeException();"替换的"throw new RuntimeException();" 。 如果一个程序是指缺少类型xyz，则返回模型必须包含不超过若类型XYZ三个声明被假定为是较少的信息"class Xyz {}" ， "interface Xyz {}" ， "enum Xyz {}" ，或"@interface Xyz {}" 。 如果程序引用了一个缺少的类型Xyz<K1, ... ,Kn> ，则返回的模型必须包含的信息不少于"class Xyz<T1, ... ,Tn> {}"的声明假定为"class Xyz<T1, ... ,Tn> {}"或"interface Xyz<T1, ... ,Tn> {}"

除非在特定实现中另有规定，否则应该预期此程序包中方法返回的集合将被调用者不可修改，并且对并发访问是不安全的。

除非另有说明，如果给出了null参数，则该包中的方法将抛出一个NullPointerException 。

从以下版本开始：
1.6
  • 接口摘要
    接口 描述
    AnnotationMirror
    表示注释。
    AnnotationValue
    表示注释类型元素的值。
    AnnotationValueVisitor<R,P>
    注释类型元素的值的访问者，使用访问者设计模式的变体。
    Element
    表示程序元素，如模块，包，类或方法。
    ElementVisitor<R,P>
    游客的程式元素，以访客设计风格为格局。
    ExecutableElement
    表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
    ModuleElement
    表示一个模块程序元素。
    ModuleElement.Directive
    在本模块的声明中表示一个指令。
    ModuleElement.DirectiveVisitor<R,P>
    模块指令的访问者，以访客设计模式的风格。
    ModuleElement.ExportsDirective
    一个模块的导出包。
    ModuleElement.OpensDirective
    一个开放的模块包。
    ModuleElement.ProvidesDirective
    由模块提供的服务的实现。
    ModuleElement.RequiresDirective
    模块的依赖。
    ModuleElement.UsesDirective
    对模块使用的服务的引用。
    Name
    一个不可变的人物序列。
    PackageElement
    表示包程序元素。
    Parameterizable
    用于具有类型参数的元素的mixin接口。
    QualifiedNameable
    用于具有限定名称的元素的mixin接口。
    TypeElement
    表示一个类或接口程序元素。
    TypeParameterElement
    表示通用类，接口，方法或构造函数元素的正式类型参数。
    VariableElement
    表示一个字段， 枚举常量，方法或构造函数参数，局部变量，资源变量或异常参数。
  • 枚举摘要
    Enum 描述
    ElementKind
    一个元素的 kind 。
    Modifier
    表示程序元素（如类，方法或字段）上的修饰符。
    ModuleElement.DirectiveKind
    一个指令的 kind 。
    NestingKind
    一种类型元素的 嵌套类型。
  • 异常摘要
    异常 描述
    UnknownAnnotationValueException
    表示遇到未知类型的注释值。
    UnknownDirectiveException
    表示遇到未知类型的模块指令。
    UnknownElementException
    表示遇到未知类型的元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类


javax.lang.model.element Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package javax.lang.model.element

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • javax.lang.model.UnknownEntityException
            • javax.lang.model.element.UnknownAnnotationValueException
            • javax.lang.model.element.UnknownDirectiveException
            • javax.lang.model.element.UnknownElementException

Interface Hierarchy

  • javax.lang.model.AnnotatedConstruct
    • javax.lang.model.element.Element
      • javax.lang.model.element.ExecutableElement (also extends javax.lang.model.element.Parameterizable)
      • javax.lang.model.element.ModuleElement (also extends javax.lang.model.element.QualifiedNameable)
      • javax.lang.model.element.PackageElement (also extends javax.lang.model.element.QualifiedNameable)
      • javax.lang.model.element.Parameterizable
        • javax.lang.model.element.ExecutableElement (also extends javax.lang.model.element.Element)
        • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Element, javax.lang.model.element.QualifiedNameable)
      • javax.lang.model.element.QualifiedNameable
        • javax.lang.model.element.ModuleElement (also extends javax.lang.model.element.Element)
        • javax.lang.model.element.PackageElement (also extends javax.lang.model.element.Element)
        • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Element, javax.lang.model.element.Parameterizable)
      • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Parameterizable, javax.lang.model.element.QualifiedNameable)
      • javax.lang.model.element.TypeParameterElement
      • javax.lang.model.element.VariableElement
  • javax.lang.model.element.AnnotationMirror
  • javax.lang.model.element.AnnotationValue
  • javax.lang.model.element.AnnotationValueVisitor<R,P>
  • java.lang.CharSequence
    • javax.lang.model.element.Name
  • javax.lang.model.element.ElementVisitor<R,P>
  • javax.lang.model.element.ModuleElement.Directive
    • javax.lang.model.element.ModuleElement.ExportsDirective
    • javax.lang.model.element.ModuleElement.OpensDirective
    • javax.lang.model.element.ModuleElement.ProvidesDirective
    • javax.lang.model.element.ModuleElement.RequiresDirective
    • javax.lang.model.element.ModuleElement.UsesDirective
  • javax.lang.model.element.ModuleElement.DirectiveVisitor<R,P>

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.lang.model.element.ElementKind
      • javax.lang.model.element.Modifier
      • javax.lang.model.element.ModuleElement.DirectiveKind
      • javax.lang.model.element.NestingKind
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Enum Modifier

  • java.lang.Object
    • java.lang.Enum<Modifier>
      • javax.lang.model.element.Modifier
  • All Implemented Interfaces:
    Serializable ， Comparable<Modifier>

    public enum Modifier
extends Enum<Modifier>
    表示程序元素（如类，方法或字段）上的修饰符。

    并非所有修饰符都适用于各种元素。 当两个或多个修饰符出现在元素的源代码中时，通常，尽管不是必需的，但它们的顺序与下面详细信息部分中列出的常数相同。

    请注意，在将来的平台版本中可能会添加其他修饰符。

    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ABSTRACT
      修饰词 abstract
      DEFAULT
      修饰词 default
      FINAL
      修饰词 final
      NATIVE
      修饰词 native
      PRIVATE
      修饰词 private
      PROTECTED
      修饰词 protected
      PUBLIC
      修饰词 public
      STATIC
      修饰词 static
      STRICTFP
      修饰词 strictfp
      SYNCHRONIZED
      修饰词 synchronized
      TRANSIENT
      修饰词 transient
      VOLATILE
      修饰词 volatile

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      以小写形式返回此修饰符的名称。
      static Modifier valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Modifier[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PUBLIC

        public static final Modifier PUBLIC
        修饰词 public

      • PROTECTED

        public static final Modifier PROTECTED
        修饰词 protected

      • PRIVATE

        public static final Modifier PRIVATE
        修饰词 private

      • ABSTRACT

        public static final Modifier ABSTRACT
        修饰词 abstract

      • DEFAULT

        public static final Modifier DEFAULT
        修饰词 default
        从以下版本开始：
        1.8

      • STATIC

        public static final Modifier STATIC
        修饰词 static

      • FINAL

        public static final Modifier FINAL
        修饰词 final

      • TRANSIENT

        public static final Modifier TRANSIENT
        修饰词 transient

      • VOLATILE

        public static final Modifier VOLATILE
        修饰词 volatile

      • SYNCHRONIZED

        public static final Modifier SYNCHRONIZED
        修饰词 synchronized

      • NATIVE

        public static final Modifier NATIVE
        修饰词 native

      • STRICTFP

        public static final Modifier STRICTFP
        修饰词 strictfp

    • 方法详细信息

      • values

        public static Modifier[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Modifier c : Modifier.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Modifier valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • toString

        public String toString​()
        以小写形式返回此修饰符的名称。
        重写：
        toString在 Enum<Modifier>
        结果
        这个枚举常数的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ModuleElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ModuleElement

  • All Superinterfaces:
    AnnotatedConstruct ， Element ， QualifiedNameable

    public interface ModuleElement
extends Element, QualifiedNameable
    表示一个模块程序元素。 提供有关模块，其指令及其成员的信息的访问。
    从以下版本开始：
    9
    另请参见：
    Elements.getModuleOf(javax.lang.model.element.Element)
    See The Java™ Language Specification:
    7.7模块声明

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  ModuleElement.Directive
      在本模块的声明中表示一个指令。
      static class  ModuleElement.DirectiveKind
      一个指令的 kind 。
      static interface  ModuleElement.DirectiveVisitor<R,P>
      模块指令的访问者，以访客设计模式的风格。
      static interface  ModuleElement.ExportsDirective
      一个模块的导出包。
      static interface  ModuleElement.OpensDirective
      一个开放的模块包。
      static interface  ModuleElement.ProvidesDirective
      由模块提供的服务的实现。
      static interface  ModuleElement.RequiresDirective
      模块的依赖。
      static interface  ModuleElement.UsesDirective
      对模块使用的服务的引用。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends ModuleElement.Directive> getDirectives​()
      返回此模块声明中包含的伪指令。
      List<? extends Element> getEnclosedElements​()
      返回此模块中的包。
      Element getEnclosingElement​()
      返回 null因为模块未被其他元素包围。
      Name getQualifiedName​()
      返回此模块的完全限定名称。
      Name getSimpleName​()
      返回此模块的简单名称。
      boolean isOpen​()
      返回 true ，如果这是一个开放的模块和 false否则。
      boolean isUnnamed​()
      返回 true ，如果这是一个未命名的模块和 false否则。

      • Methods inherited from interface javax.lang.model.AnnotatedConstruct

        getAnnotationsByType

      • Methods inherited from interface javax.lang.model.element.Element

        accept, asType, equals, getAnnotation, getAnnotationMirrors, getKind, getModifiers, hashCode

    • 方法详细信息

      • getQualifiedName

        Name getQualifiedName​()
        返回此模块的完全限定名称。 对于unnamed module ，返回一个空名 。
        Specified by:
        getQualifiedName在接口 QualifiedNameable
        API Note:
        如果模块名称由一个标识符组成，则该方法返回该标识符，即使不是合格的形式，也被认为是模块的全限定名称。 如果模块名称由多个标识符组成，则该方法返回整个名称。
        结果
        该模块的完全限定名称，如果这是一个未命名的模块，则为空名称
        See The Java™ Language Specification:
        6.2名称和标识符

      • getSimpleName

        Name getSimpleName​()
        返回此模块的简单名称。 对于一个unnamed module ，返回一个空名 。
        Specified by:
        getSimpleName在接口 Element
        API Note:
        如果模块名称由一个标识符组成，则该方法返回该标识符。 如果模块名称由多个标识符组成，则该方法返回最右边的这个标识符，这被认为是模块的简单名称。
        结果
        这个模块的简单名称或空名称，如果这是一个未命名的模块
        另请参见：
        PackageElement.getSimpleName() ，
ExecutableElement.getSimpleName() ，
TypeElement.getSimpleName() ，
VariableElement.getSimpleName() ，
getSimpleName()
        See The Java™ Language Specification:
        6.2名称和标识符

      • getEnclosedElements

        List<? extends Element> getEnclosedElements​()
        返回此模块中的包。
        Specified by:
        getEnclosedElements在接口 Element
        结果
        该模块中的包
        另请参见：
        TypeElement.getEnclosedElements() ，
PackageElement.getEnclosedElements() ，
getEnclosedElements() ，
Elements.getAllMembers(javax.lang.model.element.TypeElement)

      • isOpen

        boolean isOpen​()
        返回 true ，如果这是一个开放的模块和 false否则。
        结果
        true如果这是一个开放模块，否则为 false

      • isUnnamed

        boolean isUnnamed​()
        返回 true ，如果这是一个未命名的模块和 false否则。
        结果
        true如果这是一个未命名的模块，否则为 false

      • getEnclosingElement

        Element getEnclosingElement​()
        返回 null因为模块未被其他元素包围。
        Specified by:
        getEnclosingElement接口 Element
        结果
        null
        另请参见：
        Elements.getPackageOf(javax.lang.model.element.Element)

      • getDirectives

        List<? extends ModuleElement.Directive> getDirectives​()
        返回此模块声明中包含的伪指令。
        结果
        在该模块的声明中的指令
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ModuleElement.Directive (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ModuleElement.Directive

  • All Known Subinterfaces:
    ModuleElement.ExportsDirective ， ModuleElement.OpensDirective ， ModuleElement.ProvidesDirective ， ModuleElement.RequiresDirective ， ModuleElement.UsesDirective
    Enclosing interface:
    ModuleElement

    public static interface ModuleElement.Directive
    在本模块的声明中表示一个指令。 模块声明的指令在Java Platform Module System中配置模块。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      <R,P> R accept​(ModuleElement.DirectiveVisitor<R,P> v, P p)
      将访问者应用于此指令。
      ModuleElement.DirectiveKind getKind​()
      返回此指令的 kind 。

    • 方法详细信息

      • getKind

        ModuleElement.DirectiveKind getKind​()
        返回此指令的 kind 。
        结果
        这个指令的种类

      • accept

        <R,P> R accept​(ModuleElement.DirectiveVisitor<R,P> v,
               P p)
        将访问者应用于此指令。
        参数类型
        R - 访问者方法的返回类型
        P - 访问者方法的附加参数的类型
        参数
        v - 访问者操作此指令
        p - 访问者的附加参数
        结果
        访客指定的结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ModuleElement.DirectiveKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Enum ModuleElement.DirectiveKind

  • java.lang.Object
    • java.lang.Enum<ModuleElement.DirectiveKind>
      • javax.lang.model.element.ModuleElement.DirectiveKind
  • All Implemented Interfaces:
    Serializable ， Comparable<ModuleElement.DirectiveKind>
    Enclosing interface:
    ModuleElement

    public static enum ModuleElement.DirectiveKind
extends Enum<ModuleElement.DirectiveKind>
    一个指令的kind 。

    请注意，可能会添加其他指令类型，以适应未来版本的Java编程语言中添加的新的，当前未知的语言结构。

    从以下版本开始：
    9

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      EXPORTS
      “export package-name [to module-name-list]”指令。
      OPENS
      “打开package-name [to module-name-list]”指令。
      PROVIDES
      A“提供service-name with implementation-name”指令。
      REQUIRES
      一个“require（static | transitive）* module-name”指令。
      USES
      A“使用service-name”指令。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ModuleElement.DirectiveKind valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleElement.DirectiveKind[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • REQUIRES

        public static final ModuleElement.DirectiveKind REQUIRES
        一个“require（static | transitive）* module-name”指令。

      • EXPORTS

        public static final ModuleElement.DirectiveKind EXPORTS
        “export package-name [to module-name-list]”指令。

      • OPENS

        public static final ModuleElement.DirectiveKind OPENS
        “打开package-name [to module-name-list]”指令。

      • USES

        public static final ModuleElement.DirectiveKind USES
        A“使用service-name”指令。

      • PROVIDES

        public static final ModuleElement.DirectiveKind PROVIDES
        A“提供service-name with implementation-name”指令。

    • 方法详细信息

      • values

        public static ModuleElement.DirectiveKind[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ModuleElement.DirectiveKind c : ModuleElement.DirectiveKind.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ModuleElement.DirectiveKind valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


ModuleElement.DirectiveVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ModuleElement.DirectiveVisitor<R,P>

  • 参数类型
    R - 这个访问者的方法的返回类型。 对不需要返回结果的访问者使用Void 。
    P - 此访问者方法的附加参数类型。 对不需要附加参数的访问者使用Void 。
    Enclosing interface:
    ModuleElement

    public static interface ModuleElement.DirectiveVisitor<R,P>
    模块指令的访问者，以访客设计模式的风格。 实现此接口的类用于在指令类型在编译时未知时对指令进行操作。 当访问者被传递到指令的accept方法时，将调用适用于该指令的visitXyz方法。

    实现此界面的类可以或可以不抛出NullPointerException如果附加参数p是null ; 有关详细信息，请参阅实施类的文档。

    警告：可能的方法将添加到此界面以适应未来版本的Java编程语言中添加的新的，当前未知的语言结构。 使用默认方法将以源兼容方式添加适应新语言结构的方法 。

    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default R visit​(ModuleElement.Directive d)
      访问任何指令，好像通过传递该指令的 accept方法并传递 null作为附加参数。
      default R visit​(ModuleElement.Directive d, P p)
      访问任何指令，好像通过传递自己的指令的 accept方法。
      R visitExports​(ModuleElement.ExportsDirective d, P p)
      访问 exports指令。
      R visitOpens​(ModuleElement.OpensDirective d, P p)
      访问 opens指令。
      R visitProvides​(ModuleElement.ProvidesDirective d, P p)
      访问 provides指令。
      R visitRequires​(ModuleElement.RequiresDirective d, P p)
      访问 requires指令。
      default R visitUnknown​(ModuleElement.Directive d, P p)
      访问未知的指令。
      R visitUses​(ModuleElement.UsesDirective d, P p)
      访问 uses指令。

    • 方法详细信息

      • visit

        default R visit​(ModuleElement.Directive d)
        访问任何指令，好像通过传递自己的指令的accept方法，并通过null的附加参数。 调用v.visit(d)相当于d.accept(v, null) 。
        实现要求：
        这个实现是 visit(d, null)
        参数
        d - 访问指令
        结果
        访客指定的结果

      • visit

        default R visit​(ModuleElement.Directive d,
                P p)
        访问任何指令，好像通过传递自己的指令的accept方法。 调用v.visit(d, p)相当于d.accept(v, p) 。
        参数
        d - 访问指令
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitRequires

        R visitRequires​(ModuleElement.RequiresDirective d,
                P p)
        访问 requires指令。
        参数
        d - 访问指令
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitExports

        R visitExports​(ModuleElement.ExportsDirective d,
               P p)
        访问 exports指令。
        参数
        d - 访问指令
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitOpens

        R visitOpens​(ModuleElement.OpensDirective d,
             P p)
        访问 opens指令。
        参数
        d - 访问指令
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitUses

        R visitUses​(ModuleElement.UsesDirective d,
            P p)
        访问 uses指令。
        参数
        d - 访问指令
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitProvides

        R visitProvides​(ModuleElement.ProvidesDirective d,
                P p)
        访问 provides指令。
        参数
        d - 访问指令
        p - 访客指定的参数
        结果
        访客指定的结果

      • visitUnknown

        default R visitUnknown​(ModuleElement.Directive d,
                       P p)
        访问未知的指令。 如果语言发展和新的指令被添加，就会发生这种情况。
        实现要求：
        此实现将抛出 new UnknownDirectiveException(d, p) 。
        参数
        d - 访问指令
        p - 访客指定的参数
        结果
        访客指定的结果
        异常
        UnknownDirectiveException - 访问者实现可以可选地抛出该异常
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ModuleElement.ExportsDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ModuleElement.ExportsDirective

  • All Superinterfaces:
    ModuleElement.Directive
    Enclosing interface:
    ModuleElement

    public static interface ModuleElement.ExportsDirective
extends ModuleElement.Directive
    一个模块的导出包。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      PackageElement getPackage​()
      返回正在导出的包。
      List<? extends ModuleElement> getTargetModules​()
      返回要导出软件包的特定模块，如果软件包导出到具有对该模块的可读性的所有模块，则返回null。

      • Methods inherited from interface javax.lang.model.element.ModuleElement.Directive

        accept, getKind

    • 方法详细信息

      • getPackage

        PackageElement getPackage​()
        返回正在导出的包。
        结果
        出口包装

      • getTargetModules

        List<? extends ModuleElement> getTargetModules​()
        返回要导出软件包的特定模块，如果软件包导出到具有对该模块的可读性的所有模块，则返回null。
        结果
        导出包的具体模块
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ModuleElement.OpensDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ModuleElement.OpensDirective

  • All Superinterfaces:
    ModuleElement.Directive
    Enclosing interface:
    ModuleElement

    public static interface ModuleElement.OpensDirective
extends ModuleElement.Directive
    一个开放的模块包。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      PackageElement getPackage​()
      返回正在打开的包。
      List<? extends ModuleElement> getTargetModules​()
      如果程序包打开了对该模块具有可读性的所有模块，则返回打包程序包的特定模块或空值。

      • Methods inherited from interface javax.lang.model.element.ModuleElement.Directive

        accept, getKind

    • 方法详细信息

      • getPackage

        PackageElement getPackage​()
        返回正在打开的包。
        结果
        包装正在打开

      • getTargetModules

        List<? extends ModuleElement> getTargetModules​()
        如果程序包打开了对该模块具有可读性的所有模块，则返回打包程序包的特定模块或空值。
        结果
        打包的具体模块
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ModuleElement.ProvidesDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ModuleElement.ProvidesDirective

  • All Superinterfaces:
    ModuleElement.Directive
    Enclosing interface:
    ModuleElement

    public static interface ModuleElement.ProvidesDirective
extends ModuleElement.Directive
    由模块提供的服务的实现。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends TypeElement> getImplementations​()
      返回正在提供的服务的实现。
      TypeElement getService​()
      返回正在提供的服务。

      • Methods inherited from interface javax.lang.model.element.ModuleElement.Directive

        accept, getKind

    • 方法详细信息

      • getService

        TypeElement getService​()
        返回正在提供的服务。
        结果
        提供服务

      • getImplementations

        List<? extends TypeElement> getImplementations​()
        返回正在提供的服务的实现。
        结果
        提供的服务的实现
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ModuleElement.RequiresDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ModuleElement.RequiresDirective

  • All Superinterfaces:
    ModuleElement.Directive
    Enclosing interface:
    ModuleElement

    public static interface ModuleElement.RequiresDirective
extends ModuleElement.Directive
    模块的依赖。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ModuleElement getDependency​()
      返回所需的模块
      boolean isStatic​()
      返回这是否是静态依赖关系。
      boolean isTransitive​()
      返回这是否是传递依赖关系。

      • Methods inherited from interface javax.lang.model.element.ModuleElement.Directive

        accept, getKind

    • 方法详细信息

      • isStatic

        boolean isStatic​()
        返回这是否是静态依赖关系。
        结果
        这是否是静态依赖

      • isTransitive

        boolean isTransitive​()
        返回这是否是传递依赖关系。
        结果
        这是否是传递依赖

      • getDependency

        ModuleElement getDependency​()
        返回所需的模块
        结果
        the module that is required
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ModuleElement.UsesDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface ModuleElement.UsesDirective

  • All Superinterfaces:
    ModuleElement.Directive
    Enclosing interface:
    ModuleElement

    public static interface ModuleElement.UsesDirective
extends ModuleElement.Directive
    对模块使用的服务的引用。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      TypeElement getService​()
      返回使用的服务。

      • Methods inherited from interface javax.lang.model.element.ModuleElement.Directive

        accept, getKind

    • 方法详细信息

      • getService

        TypeElement getService​()
        返回使用的服务。
        结果
        the service that is used
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Name (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface Name

  • All Superinterfaces:
    CharSequence

    public interface Name
extends CharSequence
    一个不可变的人物序列。 当由相同的实现创建时，实现此接口的对象在彼此比较时必须遵守一般的equals contract 。 因此，来自相同实现的Name对象可用于集合，而来自不同实现的Name s可能在集合中无法正常工作。

    一个空的Name的长度为零。

    在上下文annotation processing ，对于“同一”实施的保障必须包括环境，其中API mediated的副作用processors可能是彼此可见，包括连续的注释处理rounds 。

    从以下版本开始：
    1.6
    另请参见：
    Elements.getName(java.lang.CharSequence)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean contentEquals​(CharSequence cs)
      将此名称与指定的 CharSequence 。
      boolean equals​(Object obj)
      返回 true如果参数表示相同的名字 this和 false否则。
      int hashCode​()
      遵守 Object.hashCode的总合同。

      • Methods inherited from interface java.lang.CharSequence

        charAt, chars, codePoints, length, subSequence, toString

    • 方法详细信息

      • equals

        boolean equals​(Object obj)
        返回true如果参数表示相同的名字this和false否则。

        注意， Name的身份是其字符序列的内容以及创建它的实现的功能。

        重写：
        equals在 Object
        参数
        obj - 要与此元素进行比较的对象
        结果
        true如果指定的对象表示与此相同的名称
        另请参见：
        Element.equals(java.lang.Object)

      • hashCode

        int hashCode​()
        遵守 Object.hashCode的总合同。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        equals(java.lang.Object)

      • contentEquals

        boolean contentEquals​(CharSequence cs)
        将此名称与指定的CharSequence 。 当且仅当该名称代表与指定序列相同的char值时，结果为true 。
        参数
        cs - 比较这个名字的顺序
        结果
        true如果此名称代表与指定序列相同的序列 char ，否则为 false
        另请参见：
        String.contentEquals(CharSequence)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NestingKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Enum NestingKind

  • java.lang.Object
    • java.lang.Enum<NestingKind>
      • javax.lang.model.element.NestingKind
  • All Implemented Interfaces:
    Serializable ， Comparable<NestingKind>

    public enum NestingKind
extends Enum<NestingKind>
    一种类型元素的嵌套类型。 类型元素有四个品种：顶级，成员，本地和匿名。 嵌套类是这里用于表示此分类的非标准术语。

    请注意，未来版本的平台中可能会添加其他嵌套类型。

    示例：下面的类使用它们的嵌套类型进行注释。

 import java.lang.annotation.*;
 import static java.lang.annotation.RetentionPolicy.*;
 import javax.lang.model.element.*;
 import static javax.lang.model.element.NestingKind.*;

 @Nesting(TOP_LEVEL)
 public class NestingExamples {
     @Nesting(MEMBER)
     static class MemberClass1{}

     @Nesting(MEMBER)
     class MemberClass2{}

     public static void main(String... argv) {
         @Nesting(LOCAL)
         class LocalClass{};

         Class<?>[] classes = {
             NestingExamples.class,
             MemberClass1.class,
             MemberClass2.class,
             LocalClass.class
         };

         for(Class<?> clazz : classes) {
             System.out.format("%s is %s%n",
                               clazz.getName(),
                               clazz.getAnnotation(Nesting.class).value());
         }
     }
 }

 @Retention(RUNTIME)
 @interface Nesting {
     NestingKind value();
 }
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ANONYMOUS
      没有名字的类型
      LOCAL
      在类型之外的构造中声明的命名类型。
      MEMBER
      作为另一种类型的命名成员的类型。
      TOP_LEVEL
      顶级类型，不包含在其他类型中。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean isNested​()
      这个常数是否对应于嵌套的类型元素？
      static NestingKind valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static NestingKind[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • TOP_LEVEL

        public static final NestingKind TOP_LEVEL
        顶级类型，不包含在其他类型中。

      • MEMBER

        public static final NestingKind MEMBER
        作为另一种类型的命名成员的类型。
        See The Java™ Language Specification:
        8.5会员类型声明

      • LOCAL

        public static final NestingKind LOCAL
        在类型之外的构造中声明的命名类型。
        See The Java™ Language Specification:
        14.3本地类声明

      • ANONYMOUS

        public static final NestingKind ANONYMOUS
        没有名字的类型
        See The Java™ Language Specification:
        15.9.5匿名类声明

    • 方法详细信息

      • values

        public static NestingKind[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (NestingKind c : NestingKind.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static NestingKind valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • isNested

        public boolean isNested​()
        这个常数是否对应于嵌套的类型元素？ 嵌套类型元素是不是顶级的。 更具体地， 内部类型元素是不是static的任何嵌套类型元素。
        结果
        无论常数是否嵌套
        See The Java™ Language Specification:
        14.3内部类和封闭实例
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法


PackageElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface PackageElement

  • All Superinterfaces:
    AnnotatedConstruct ， Element ， QualifiedNameable

    public interface PackageElement
extends Element, QualifiedNameable
    表示包程序元素。 提供有关该软件包及其成员的信息的访问。
    从以下版本开始：
    1.6
    另请参见：
    Elements.getPackageOf(javax.lang.model.element.Element)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends Element> getEnclosedElements​()
      返回此包中的 top-level类和接口。
      Element getEnclosingElement​()
      如果存在这样的模块，则返回包围模块; 否则返回null 。
      Name getQualifiedName​()
      返回此包的完全限定名称。
      Name getSimpleName​()
      返回此包的简单名称。
      boolean isUnnamed​()
      返回 true如果这是一个未命名的包和 false否则。

      • Methods inherited from interface javax.lang.model.AnnotatedConstruct

        getAnnotationsByType

      • Methods inherited from interface javax.lang.model.element.Element

        accept, asType, equals, getAnnotation, getAnnotationMirrors, getKind, getModifiers, hashCode

    • 方法详细信息

      • getQualifiedName

        Name getQualifiedName​()
        返回此包的完全限定名称。 这也被称为包的规范名称。 对于一个unnamed package ，返回一个空名 。
        Specified by:
        getQualifiedName在接口 QualifiedNameable
        API Note:
        命名包的完全限定名称不是命名包的子包，是其简单名称。 作为另一个命名包的子包的命名包的完全限定名称包含包含包的完全限定名称，后跟“ . ”，后跟子包的简单（成员）名称。
        结果
        该包的完全限定名称，如果这是一个未命名的包，则为空名称
        See The Java™ Language Specification:
        6.7完全合格的名称和规范名称

      • getSimpleName

        Name getSimpleName​()
        返回此包的简单名称。 对于一个unnamed package ，返回一个空名 。
        Specified by:
        getSimpleName在接口 Element
        结果
        这个包的简单名称或一个空名称，如果这是一个未命名的包
        另请参见：
        getSimpleName() ，
ExecutableElement.getSimpleName() ，
TypeElement.getSimpleName() ，
VariableElement.getSimpleName() ，
ModuleElement.getSimpleName()

      • getEnclosedElements

        List<? extends Element> getEnclosedElements​()
        返回此包中的top-level类和接口。 请注意，子包不会被包装包围。
        Specified by:
        getEnclosedElements在接口 Element
        结果
        该包中的顶级类和接口
        另请参见：
        TypeElement.getEnclosedElements() ，
getEnclosedElements() ，
ModuleElement.getEnclosedElements() ，
Elements.getAllMembers(javax.lang.model.element.TypeElement)

      • isUnnamed

        boolean isUnnamed​()
        返回 true如果这是一个未命名的包和 false否则。
        结果
        true如果这是一个未命名的包，否则为 false
        See The Java™ Language Specification:
        7.4.2未命名的软件包

      • getEnclosingElement

        Element getEnclosingElement​()
        如果存在这样的模块，则返回包围模块; 否则返回null 。 如果环境不包含模块，例如为没有模块的source version配置的注释处理环境，则一个模块不存在于一个包的情况。
        Specified by:
        getEnclosingElement在接口 Element
        结果
        封闭模块或 null如果不存在这样的模块
        另请参见：
        Elements.getPackageOf(javax.lang.model.element.Element)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Parameterizable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface Parameterizable

  • All Superinterfaces:
    AnnotatedConstruct ， Element
    All Known Subinterfaces:
    ExecutableElement ， TypeElement

    public interface Parameterizable
extends Element
    用于具有类型参数的元素的mixin接口。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends TypeParameterElement> getTypeParameters​()
      以声明顺序返回元素的形式类型参数。

      • Methods inherited from interface javax.lang.model.AnnotatedConstruct

        getAnnotationsByType

      • Methods inherited from interface javax.lang.model.element.Element

        accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getEnclosingElement, getKind, getModifiers, getSimpleName, hashCode

    • 方法详细信息

      • getTypeParameters

        List<? extends TypeParameterElement> getTypeParameters​()
        以声明顺序返回元素的形式类型参数。
        结果
        the formal type parameters, or an empty list if there are none
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


QualifiedNameable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface QualifiedNameable

  • All Superinterfaces:
    AnnotatedConstruct ， Element
    All Known Subinterfaces:
    ModuleElement ， PackageElement ， TypeElement

    public interface QualifiedNameable
extends Element
    用于具有限定名称的元素的mixin接口。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Name getQualifiedName​()
      返回元素的完全限定名称。

      • Methods inherited from interface javax.lang.model.AnnotatedConstruct

        getAnnotationsByType

      • Methods inherited from interface javax.lang.model.element.Element

        accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getEnclosingElement, getKind, getModifiers, getSimpleName, hashCode

    • 方法详细信息

      • getQualifiedName

        Name getQualifiedName​()
        返回元素的完全限定名称。
        结果
        the fully qualified name of an element
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TypeElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface TypeElement

  • All Superinterfaces:
    AnnotatedConstruct ， Element ， Parameterizable ， QualifiedNameable

    public interface TypeElement
extends Element, Parameterizable, QualifiedNameable
    表示一个类或接口程序元素。 提供关于类型及其成员的信息的访问。 注意，枚举类型是一种类，注释类型是一种接口。

    虽然TypeElement表示类或接口元素 ，但是DeclaredType表示类或接口类型 ，后者是前者的使用（或调用 ）。 通用类型的区别最为明显，单个元素可以定义一整套类型。 例如，元素java.util.Set对应于参数化类型java.util.Set<String>和java.util.Set<Number> （和许多其他），并且对应于原始类型java.util.Set 。

    返回元素列表的这个接口的每个方法都将以顺序返回它们，这些顺序对于基础的程序信息源是很自然的。 例如，如果底层信息源是Java源代码，那么元素将以源代码顺序返回。

    从以下版本开始：
    1.6
    另请参见：
    DeclaredType

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends Element> getEnclosedElements​()
      返回在此类或接口中直接声明的字段，方法，构造函数和成员类型。
      Element getEnclosingElement​()
      返回顶级类型的包，并返回 nested类型的立即包含的元素。
      List<? extends TypeMirror> getInterfaces​()
      返回由此类直接实现的接口类或由此接口扩展的接口类型。
      NestingKind getNestingKind​()
      返回此类型元素的 嵌套类型。
      Name getQualifiedName​()
      返回此类型元素的完全限定名称。
      Name getSimpleName​()
      返回此类型元素的简单名称。
      TypeMirror getSuperclass​()
      返回此类型元素的直接超类。
      List<? extends TypeParameterElement> getTypeParameters​()
      以声明顺序返回此类型元素的形式类型参数。

      • Methods inherited from interface javax.lang.model.AnnotatedConstruct

        getAnnotationsByType

      • Methods inherited from interface javax.lang.model.element.Element

        accept, asType, equals, getAnnotation, getAnnotationMirrors, getKind, getModifiers, hashCode

    • 方法详细信息

      • getEnclosedElements

        List<? extends Element> getEnclosedElements​()
        返回在此类或接口中直接声明的字段，方法，构造函数和成员类型。 这包括任何mandated元素，例如（隐式）默认构造函数和枚举类型的隐式values和valueOf方法。
        Specified by:
        getEnclosedElements在接口 Element
        API Note:
        作为general accuracy requirements的特定实例以及此接口所需的排序行为，将以自然顺序返回包含元素的列表，以获取有关该类型的源的信息源。 例如，如果关于类型的信息源自源文件，则元素将以源代码顺序返回。 （但是，在这种情况下，未指定implicitly declared元素的顺序，例如默认构造函数。）
        结果
        封闭的元素在正确的顺序，或空列表，如果没有
        另请参见：
        getEnclosedElements() ，
PackageElement.getEnclosedElements() ，
ModuleElement.getEnclosedElements() ，
Elements.getAllMembers(javax.lang.model.element.TypeElement)
        See The Java™ Language Specification:
        8.8.9默认构造函数，8.9.3枚举成员

      • getNestingKind

        NestingKind getNestingKind​()
        返回此类型元素的 嵌套类型。
        结果
        这种类型元素的嵌套类型

      • getQualifiedName

        Name getQualifiedName​()
        返回此类型元素的完全限定名称。 更准确地说，它返回规范名称。 对于没有规范名称的本地和匿名类，返回一个空的名称。

        通用类型的名称不包括对其正式类型参数的任何引用。 例如，接口java.util.Set<E>的完全限定名称为“ java.util.Set ”。 嵌套类型使用“ . ”作为分隔符，如“ java.util.Map.Entry ”中所示。

        Specified by:
        getQualifiedName在接口 QualifiedNameable
        结果
        此类或接口的完全限定名称，如果没有，则为空名称
        另请参见：
        Elements.getBinaryName(javax.lang.model.element.TypeElement)
        See The Java™ Language Specification:
        6.7完全合格的名称和规范名称

      • getSimpleName

        Name getSimpleName​()
        返回此类型元素的简单名称。 对于匿名类，返回一个空的名称。
        Specified by:
        getSimpleName在接口 Element
        结果
        这个类或接口的简单名称，匿名类的空名称
        另请参见：
        PackageElement.getSimpleName() ，
ExecutableElement.getSimpleName() ，
getSimpleName() ，
VariableElement.getSimpleName() ，
ModuleElement.getSimpleName()

      • getSuperclass

        TypeMirror getSuperclass​()
        返回此类型元素的直接超类。 如果此类型元素表示接口或类别java.lang.Object ，则返回一个NoType ，其种类为NONE 。
        结果
        直接超类，或者是一个 NoType如果没有

      • getInterfaces

        List<? extends TypeMirror> getInterfaces​()
        返回由此类直接实现的接口类或由此接口扩展的接口类型。
        结果
        由此类直接实现的接口类或由此接口扩展的接口类型，如果没有，则为空列表

      • getTypeParameters

        List<? extends TypeParameterElement> getTypeParameters​()
        以声明顺序返回此类型元素的形式类型参数。
        Specified by:
        getTypeParameters接口 Parameterizable
        结果
        正式类型参数，如果没有，则为空列表

      • getEnclosingElement

        Element getEnclosingElement​()
        返回顶级类型的包，并返回 nested类型的立即包含的元素。
        Specified by:
        getEnclosingElement接口 Element
        结果
        顶级类型的包，用于嵌套类型的立即包含的元素
        另请参见：
        Elements.getPackageOf(javax.lang.model.element.Element)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TypeParameterElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface TypeParameterElement

  • All Superinterfaces:
    AnnotatedConstruct ， Element

    public interface TypeParameterElement
extends Element
    表示通用类，接口，方法或构造函数元素的正式类型参数。 类型参数声明一个TypeVariable 。
    从以下版本开始：
    1.6
    另请参见：
    TypeVariable

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends TypeMirror> getBounds​()
      返回此类型参数的边界。
      Element getEnclosingElement​()
      返回此类型参数的 generic element 。
      Element getGenericElement​()
      返回由此类型参数参数化的通用类，接口，方法或构造函数。

      • Methods inherited from interface javax.lang.model.AnnotatedConstruct

        getAnnotationsByType

      • Methods inherited from interface javax.lang.model.element.Element

        accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getKind, getModifiers, getSimpleName, hashCode

    • 方法详细信息

      • getGenericElement

        Element getGenericElement​()
        返回由此类型参数参数化的通用类，接口，方法或构造函数。
        结果
        由此类型参数参数化的通用类，接口，方法或构造函数

      • getBounds

        List<? extends TypeMirror> getBounds​()
        返回此类型参数的边界。 这些是由用于声明此类型参数的extends子句给出的类型。 如果没有使用明确的extends条款，则java.lang.Object被认为是唯一的约束。
        结果
        此类型参数的边界，如果没有空列表

      • getEnclosingElement

        Element getEnclosingElement​()
        返回此类型参数的 generic element 。
        Specified by:
        getEnclosingElement在接口 Element
        结果
        此类型参数的泛型元素
        另请参见：
        Elements.getPackageOf(javax.lang.model.element.Element)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnknownAnnotationValueException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Class UnknownAnnotationValueException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.lang.model.UnknownEntityException
            • javax.lang.model.element.UnknownAnnotationValueException
  • All Implemented Interfaces:
    Serializable

    public class UnknownAnnotationValueException
extends UnknownEntityException
    表示遇到未知类型的注释值。 如果语言发展，并且可以在注释中存储新的注释值，则可能会发生这种情况。 可能会抛出一个annotation value visitor来表示访问者是为先前版本的语言创建的。
    从以下版本开始：
    1.6
    另请参见：
    AnnotationValueVisitor.visitUnknown(javax.lang.model.element.AnnotationValue, P) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownAnnotationValueException​(AnnotationValue av, Object p)
      创建一个新的 UnknownAnnotationValueException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getArgument​()
      返回附加参数。
      AnnotationValue getUnknownAnnotationValue​()
      返回未知的注释值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownAnnotationValueException

        public UnknownAnnotationValueException​(AnnotationValue av,
                                       Object p)
        创建一个新的UnknownAnnotationValueException 。 可以使用p参数传递附加参数，其中包含遇到未知注释值的上下文的信息; 例如， AnnotationValueVisitor的访问方式可能会传入其附加参数。
        参数
        av - 未知的注释值，可以是 null
        p - 附加参数，可以是 null

    • 方法详细信息

      • getUnknownAnnotationValue

        public AnnotationValue getUnknownAnnotationValue​()
        返回未知的注释值。 如果此异常已被序列化，然后再读入，该值可能不可用。
        结果
        未知元素，如果不可用， null

      • getArgument

        public Object getArgument​()
        返回附加参数。
        结果
        额外的参数，或 null如果不可用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnknownDirectiveException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Class UnknownDirectiveException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.lang.model.UnknownEntityException
            • javax.lang.model.element.UnknownDirectiveException
  • All Implemented Interfaces:
    Serializable

    public class UnknownDirectiveException
extends UnknownEntityException
    表示遇到未知类型的模块指令。 如果语言发展并且新的指令被添加到Directive层次结构中，则可能会发生这种情况。 可能会被抛出一个directive visitor来表示访客是为先前版本的语言创建的。
    从以下版本开始：
    9
    另请参见：
    ModuleElement.DirectiveVisitor.visitUnknown(javax.lang.model.element.ModuleElement.Directive, P) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownDirectiveException​(ModuleElement.Directive d, Object p)
      创建一个新的 UnknownElementException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getArgument​()
      返回附加参数。
      ModuleElement.Directive getUnknownDirective​()
      返回未知指令。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownDirectiveException

        public UnknownDirectiveException​(ModuleElement.Directive d,
                                 Object p)
        创建一个新的UnknownElementException 。 可以使用p参数传递附加参数，其中包含遇到未知伪指令的上下文的信息; 例如， DirectiveVisitor的访问方法可能会传入其附加参数。
        参数
        d - 未知指令，可能是 null
        p - 附加参数，可以是 null

    • 方法详细信息

      • getUnknownDirective

        public ModuleElement.Directive getUnknownDirective​()
        返回未知指令。 如果此异常已被序列化，然后再读入，该值可能不可用。
        结果
        未知的指令，或 null如果不可用）

      • getArgument

        public Object getArgument​()
        返回附加参数。
        结果
        额外的参数，或 null如果不可用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UnknownElementException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Class UnknownElementException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.lang.model.UnknownEntityException
            • javax.lang.model.element.UnknownElementException
  • All Implemented Interfaces:
    Serializable

    public class UnknownElementException
extends UnknownEntityException
    表示遇到未知类型的元素。 如果语言发展，并且将新类型的元素添加到Element层次结构中，则可能会发生这种情况。 可能会抛出一个element visitor来表示访问者是为先前版本的语言创建的。
    从以下版本开始：
    1.6
    另请参见：
    ElementVisitor.visitUnknown(javax.lang.model.element.Element, P) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownElementException​(Element e, Object p)
      创建一个新的 UnknownElementException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getArgument​()
      返回附加参数。
      Element getUnknownElement​()
      返回未知元素。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownElementException

        public UnknownElementException​(Element e,
                               Object p)
        创建一个新的UnknownElementException 。 可以使用p参数传递附加参数，其中包含遇到未知元素的上下文的信息; 例如， ElementVisitor的访问方法可能会传入其附加参数。
        参数
        e - 未知元素，可能是 null
        p - 附加参数可以是 null

    • 方法详细信息

      • getUnknownElement

        public Element getUnknownElement​()
        返回未知元素。 如果此异常已被序列化，然后再读入，该值可能不可用。
        结果
        未知元素，或 null如果不可用）

      • getArgument

        public Object getArgument​()
        返回附加参数。
        结果
        额外的参数，或 null如果不可用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.lang.model.element (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
javax.lang.model.element

  • Packages that use javax.lang.model.element
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
  • Classes in javax.lang.model.element used by com.sun.source.doctree
    Class 描述
    Name
    一个不可变的人物序列。
  • Classes in javax.lang.model.element used by com.sun.source.tree
    Class 描述
    Element
    表示程序元素，如模块，包，类或方法。
    ExecutableElement
    表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
    Modifier
    表示程序元素（如类，方法或字段）上的修饰符。
    Name
    一个不可变的人物序列。
    TypeElement
    表示一个类或接口程序元素。
  • Classes in javax.lang.model.element used by com.sun.source.util
    Class 描述
    AnnotationMirror
    表示注释。
    AnnotationValue
    表示注释类型元素的值。
    Element
    表示程序元素，如模块，包，类或方法。
    ExecutableElement
    表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
    Name
    一个不可变的人物序列。
    PackageElement
    表示包程序元素。
    TypeElement
    表示一个类或接口程序元素。
  • Classes in javax.lang.model.element used by javax.annotation.processing
    Class 描述
    AnnotationMirror
    表示注释。
    AnnotationValue
    表示注释类型元素的值。
    Element
    表示程序元素，如模块，包，类或方法。
    ExecutableElement
    表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
    TypeElement
    表示一个类或接口程序元素。
  • Classes in javax.lang.model.element used by javax.lang.model
    Class 描述
    AnnotationMirror
    表示注释。
  • Classes in javax.lang.model.element used by javax.lang.model.element
    Class 描述
    AnnotationMirror
    表示注释。
    AnnotationValue
    表示注释类型元素的值。
    AnnotationValueVisitor
    注释类型元素的值的访问者，使用访问者设计模式的变体。
    Element
    表示程序元素，如模块，包，类或方法。
    ElementKind
    一个元素的 kind 。
    ElementVisitor
    游客的程式元素，以访客设计风格为格局。
    ExecutableElement
    表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
    Modifier
    表示程序元素（如类，方法或字段）上的修饰符。
    ModuleElement
    表示一个模块程序元素。
    ModuleElement.Directive
    在本模块的声明中表示一个指令。
    ModuleElement.DirectiveKind
    一个指令的 kind 。
    ModuleElement.DirectiveVisitor
    模块指令的访问者，以访客设计模式的风格。
    ModuleElement.ExportsDirective
    一个模块的导出包。
    ModuleElement.OpensDirective
    一个开放的模块包。
    ModuleElement.ProvidesDirective
    由模块提供的服务的实现。
    ModuleElement.RequiresDirective
    模块的依赖。
    ModuleElement.UsesDirective
    对模块使用的服务的引用。
    Name
    一个不可变的人物序列。
    NestingKind
    一种类型元素的 嵌套类型。
    PackageElement
    表示包程序元素。
    Parameterizable
    用于具有类型参数的元素的mixin接口。
    QualifiedNameable
    用于具有限定名称的元素的mixin接口。
    TypeElement
    表示一个类或接口程序元素。
    TypeParameterElement
    表示通用类，接口，方法或构造函数元素的正式类型参数。
    VariableElement
    表示一个字段， 枚举恒定，方法或构造参数，局部变量，变量资源，或异常参数。
  • Classes in javax.lang.model.element used by javax.lang.model.type
    Class 描述
    Element
    表示程序元素，如模块，包，类或方法。
  • Classes in javax.lang.model.element used by javax.lang.model.util
    Class 描述
    AnnotationMirror
    表示注释。
    AnnotationValue
    表示注释类型元素的值。
    AnnotationValueVisitor
    注释类型元素的值的访问者，使用访问者设计模式的变体。
    Element
    表示程序元素，如模块，包，类或方法。
    ElementVisitor
    游客的程式元素，以访客设计风格为格局。
    ExecutableElement
    表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
    ModuleElement
    表示一个模块程序元素。
    ModuleElement.Directive
    在本模块的声明中表示一个指令。
    ModuleElement.ExportsDirective
    一个模块的导出包。
    ModuleElement.OpensDirective
    一个开放的模块包。
    ModuleElement.ProvidesDirective
    由模块提供的服务的实现。
    ModuleElement.RequiresDirective
    模块的依赖。
    ModuleElement.UsesDirective
    对模块使用的服务的引用。
    Name
    一个不可变的人物序列。
    PackageElement
    表示包程序元素。
    TypeElement
    表示一个类或接口程序元素。
    TypeParameterElement
    表示通用类，接口，方法或构造函数元素的正式类型参数。
    VariableElement
    表示一个字段， 枚举常量，方法或构造函数参数，局部变量，资源变量或异常参数。
  • Classes in javax.lang.model.element used by javax.tools
    Class 描述
    Modifier
    表示程序元素（如类，方法或字段）上的修饰符。
    NestingKind
    一种类型元素的 嵌套类型。
  • Classes in javax.lang.model.element used by jdk.javadoc.doclet
    Class 描述
    Element
    表示程序元素，如模块，包，类或方法。
    TypeElement
    表示一个类或接口程序元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


VariableElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.compiler
软件包 javax.lang.model.element

Interface VariableElement

  • All Superinterfaces:
    AnnotatedConstruct ， Element

    public interface VariableElement
extends Element
    表示一个字段， 枚举常量，方法或构造函数参数，局部变量，资源变量或异常参数。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object getConstantValue​()
      如果这是一个初始化为编译 final数的 final字段，则返回此变量的值。
      Element getEnclosingElement​()
      返回此变量的包围元素。
      Name getSimpleName​()
      返回此变量元素的简单名称。

      • Methods inherited from interface javax.lang.model.AnnotatedConstruct

        getAnnotationsByType

      • Methods inherited from interface javax.lang.model.element.Element

        accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getKind, getModifiers, hashCode

    • 方法详细信息

      • getConstantValue

        Object getConstantValue​()
        如果这是一个初始化为编译final数的final字段，则返回此变量的值。 否则返回null 。 该值将是原始类型或String 。 如果值是一个原始类型，它将被包装在适当的包装类（如Integer ）中。

        请注意，并非所有final字段都将具有常量值。 特别地， 枚举常量不被认为是编译时常量。 要具有常量值，字段的类型必须是基本类型或String 。

        结果
        该变量的值如果这是一个 final字段初始化为编译时常量，或者其他情况下为 null
        另请参见：
        Elements.getConstantExpression(Object)
        See The Java™ Language Specification:
        15.28常数表达式，4.12.4最终变量

      • getSimpleName

        Name getSimpleName​()
        返回此变量元素的简单名称。

        对于方法和构造函数参数，每个参数的名称必须与同一可执行文件的所有其他参数的名称不同。 如果原始来源名称不可用，则实现可以合成名称，以符合上述明确要求。

        Specified by:
        getSimpleName在接口 Element
        结果
        这个变量元素的简单名称
        另请参见：
        PackageElement.getSimpleName() ，
ExecutableElement.getSimpleName() ，
TypeElement.getSimpleName() ，
getSimpleName() ，
ModuleElement.getSimpleName()

      • getEnclosingElement

        Element getEnclosingElement​()
        返回此变量的包围元素。 方法或构造函数参数的封闭元素是声明参数的可执行文件。
        Specified by:
        getEnclosingElement在接口 Element
        结果
        这个变量的封闭元素
        另请参见：
        Elements.getPackageOf(javax.lang.model.element.Element)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javax.lang.model.element.ElementKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.lang.model.element.ElementKind

  • Packages that use ElementKind
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。

    • Uses of ElementKind in javax.lang.model.element

      Methods in javax.lang.model.element that return ElementKind
      Modifier and Type 方法 描述
      ElementKind Element.getKind​()
      返回此元素的 kind 。
      static ElementKind ElementKind.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ElementKind[] ElementKind.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.lang.model.element.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.lang.model.element.Modifier

  • Packages that use Modifier
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。

    • Uses of Modifier in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type Modifier
      Modifier and Type 方法 描述
      Set<Modifier> ModifiersTree.getFlags​()
      返回此修饰符树中的标志。

    • Uses of Modifier in javax.lang.model.element

      Methods in javax.lang.model.element that return Modifier
      Modifier and Type 方法 描述
      static Modifier Modifier.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Modifier[] Modifier.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in javax.lang.model.element that return types with arguments of type Modifier
      Modifier and Type 方法 描述
      Set<Modifier> Element.getModifiers​()
      返回此元素的修饰符，不包括注释。

    • Uses of Modifier in javax.tools

      Methods in javax.tools that return Modifier
      Modifier and Type | 方法 | 描述
      Modifier | ForwardingJavaFileObject.getAccessLevel​()
      Modifier JavaFileObject.getAccessLevel​()
      提供关于由该文件对象表示的类的访问级别的提示。
      Modifier SimpleJavaFileObject.getAccessLevel​()
      此实现返回 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.lang.model.element.ModuleElement.DirectiveKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.lang.model.element.ModuleElement.DirectiveKind

  • Packages that use ModuleElement.DirectiveKind
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。

    • Uses of ModuleElement.DirectiveKind in javax.lang.model.element

      Methods in javax.lang.model.element that return ModuleElement.DirectiveKind
      Modifier and Type 方法 描述
      ModuleElement.DirectiveKind ModuleElement.Directive.getKind​()
      返回此指令的 kind 。
      static ModuleElement.DirectiveKind ModuleElement.DirectiveKind.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleElement.DirectiveKind[] ModuleElement.DirectiveKind.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.lang.model.element.NestingKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.lang.model.element.NestingKind

  • Packages that use NestingKind
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。

    • Uses of NestingKind in javax.lang.model.element

      Methods in javax.lang.model.element that return NestingKind
      Modifier and Type 方法 描述
      NestingKind TypeElement.getNestingKind​()
      返回此类型元素的 嵌套类型。
      static NestingKind NestingKind.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static NestingKind[] NestingKind.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of NestingKind in javax.tools

      Methods in javax.tools that return NestingKind
      Modifier and Type | 方法 | 描述
      NestingKind | ForwardingJavaFileObject.getNestingKind​()
      NestingKind JavaFileObject.getNestingKind​()
      提供关于由该文件对象表示的类的嵌套级别的提示。
      NestingKind SimpleJavaFileObject.getNestingKind​()
      This implementation returns null.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.lang.model.element.UnknownAnnotationValueException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.lang.model.element.UnknownAnnotationValueException

No usage of javax.lang.model.element.UnknownAnnotationValueException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.lang.model.element.UnknownDirectiveException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.lang.model.element.UnknownDirectiveException

No usage of javax.lang.model.element.UnknownDirectiveException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Class javax.lang.model.element.UnknownElementException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
javax.lang.model.element.UnknownElementException

No usage of javax.lang.model.element.UnknownElementException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.AnnotationMirror (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.AnnotationMirror

  • Packages that use AnnotationMirror
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of AnnotationMirror in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AnnotationMirror
      Modifier and Type 方法 描述
      abstract TreePath Trees.getPath​(Element e, AnnotationMirror a)
      返回给定元素上的AnnotationMirror的TreePath节点。
      abstract TreePath Trees.getPath​(Element e, AnnotationMirror a, AnnotationValue v)
      返回指定元素上AnnotationMirror的AnnotationValue的TreePath节点。
      abstract 树 Trees.getTree​(Element e, AnnotationMirror a)
      返回给定元素上的AnnotationMirror的Tree节点。
      abstract 树 Trees.getTree​(Element e, AnnotationMirror a, AnnotationValue v)
      返回给定元素上AnnotationMirror的AnnotationValue的Tree节点。

    • Uses of AnnotationMirror in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type AnnotationMirror
      Modifier and Type 方法 描述
      Iterable<? extends Completion> AbstractProcessor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回一个空的可迭代的完成。
      Iterable<? extends Completion> Processor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回到工具基础结构，可以对注释的建议完成进行迭代。
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a)
      在注释元素的注释镜像的位置打印指定类型的消息。
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v)
      在注释元素的注释镜像内的注释值的位置打印指定类型的消息。

    • Uses of AnnotationMirror in javax.lang.model

      Methods in javax.lang.model that return types with arguments of type AnnotationMirror
      Modifier and Type 方法 描述
      List<? extends AnnotationMirror> AnnotatedConstruct.getAnnotationMirrors​()
      返回 直接存在于此构造上的注释。

    • Uses of AnnotationMirror in javax.lang.model.element

      Methods in javax.lang.model.element that return types with arguments of type AnnotationMirror
      Modifier and Type 方法 描述
      List<? extends AnnotationMirror> Element.getAnnotationMirrors​()
      返回 直接存在于此构造上的注释。
      Methods in javax.lang.model.element with parameters of type AnnotationMirror
      Modifier and Type 方法 描述
      R AnnotationValueVisitor.visitAnnotation​(AnnotationMirror a, P p)
      访问注释中的注释值。

    • Uses of AnnotationMirror in javax.lang.model.util

      Methods in javax.lang.model.util that return types with arguments of type AnnotationMirror
      Modifier and Type 方法 描述
      List<? extends AnnotationMirror> Elements.getAllAnnotationMirrors​(Element e)
      返回元素上 存在的所有注释，无论是直接存在还是通过继承存在。
      Methods in javax.lang.model.util with parameters of type AnnotationMirror
      Modifier and Type 方法 描述
      Map<? extends ExecutableElement,? extends AnnotationValue> Elements.getElementValuesWithDefaults​(AnnotationMirror a)
      返回注释元素的值，包括默认值。
      default Elements.Origin Elements.getOrigin​(AnnotatedConstruct c, AnnotationMirror a)
      返回给定注释镜的 起点 。
      R SimpleAnnotationValueVisitor6.visitAnnotation​(AnnotationMirror a, P p)
      访问注释中的注释值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.AnnotationValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.AnnotationValue

  • Packages that use AnnotationValue
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of AnnotationValue in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AnnotationValue
      Modifier and Type 方法 描述
      abstract TreePath Trees.getPath​(Element e, AnnotationMirror a, AnnotationValue v)
      返回指定元素上AnnotationMirror的AnnotationValue的TreePath节点。
      abstract 树 Trees.getTree​(Element e, AnnotationMirror a, AnnotationValue v)
      返回给定元素上AnnotationMirror的AnnotationValue的Tree节点。

    • Uses of AnnotationValue in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type AnnotationValue
      Modifier and Type 方法 描述
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v)
      在注释元素的注释镜像内的注释值的位置打印指定类型的消息。

    • Uses of AnnotationValue in javax.lang.model.element

      Methods in javax.lang.model.element that return AnnotationValue
      Modifier and Type 方法 描述
      AnnotationValue ExecutableElement.getDefaultValue​()
      如果此可执行文件是注释类型元素，则返回默认值。
      AnnotationValue UnknownAnnotationValueException.getUnknownAnnotationValue​()
      返回未知的注释值。
      Methods in javax.lang.model.element that return types with arguments of type AnnotationValue
      Modifier and Type 方法 描述
      Map<? extends ExecutableElement,? extends AnnotationValue> AnnotationMirror.getElementValues​()
      返回此注释元素的值。
      Methods in javax.lang.model.element with parameters of type AnnotationValue
      Modifier and Type 方法 描述
      default R AnnotationValueVisitor.visit​(AnnotationValue av)
      方便的方法相当于 visit(av, null) 。
      R AnnotationValueVisitor.visit​(AnnotationValue av, P p)
      访问注释值。
      R AnnotationValueVisitor.visitUnknown​(AnnotationValue av, P p)
      访问未知类型的注释值。
      Method parameters in javax.lang.model.element with type arguments of type AnnotationValue
      Modifier and Type 方法 描述
      R AnnotationValueVisitor.visitArray​(List<? extends AnnotationValue> vals, P p)
      访问注释中的数组值。
      Constructors in javax.lang.model.element with parameters of type AnnotationValue
      Constructor 描述
      UnknownAnnotationValueException​(AnnotationValue av, Object p)
      创建一个新的 UnknownAnnotationValueException 。

    • Uses of AnnotationValue in javax.lang.model.util

      Methods in javax.lang.model.util that return types with arguments of type AnnotationValue
      Modifier and Type 方法 描述
      Map<? extends ExecutableElement,? extends AnnotationValue> Elements.getElementValuesWithDefaults​(AnnotationMirror a)
      返回注释元素的值，包括默认值。
      Methods in javax.lang.model.util with parameters of type AnnotationValue
      Modifier and Type 方法 描述
      R AbstractAnnotationValueVisitor6.visit​(AnnotationValue av)
      访问注释值，就像通过传递给该值的 accept方法传递 null作为附加参数一样。
      R AbstractAnnotationValueVisitor6.visit​(AnnotationValue av, P p)
      访问任何注释值，就像将其自身传递给该值的 accept一样 。
      R AbstractAnnotationValueVisitor6.visitUnknown​(AnnotationValue av, P p)
      访问未知类型的注释值。
      Method parameters in javax.lang.model.util with type arguments of type AnnotationValue
      Modifier and Type 方法 描述
      R SimpleAnnotationValueVisitor6.visitArray​(List<? extends AnnotationValue> vals, P p)
      访问注释中的数组值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.AnnotationValueVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.AnnotationValueVisitor

  • Packages that use AnnotationValueVisitor
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of AnnotationValueVisitor in javax.lang.model.element

      Methods in javax.lang.model.element with parameters of type AnnotationValueVisitor
      Modifier and Type 方法 描述
      <R,P> R AnnotationValue.accept​(AnnotationValueVisitor<R,P> v, P p)
      将访问者应用于此值。

    • Uses of AnnotationValueVisitor in javax.lang.model.util

      Classes in javax.lang.model.util that implement AnnotationValueVisitor
      Modifier and Type Class 描述
      class  AbstractAnnotationValueVisitor6<R,P>
      注释值的骨架访问者，默认行为适用于 RELEASE_6源版本。
      class  AbstractAnnotationValueVisitor7<R,P>
      注释值的骨架访问者，具有适用于 RELEASE_7源版本的默认行为。
      class  AbstractAnnotationValueVisitor8<R,P>
      具有默认行为的注释值的骨架访问者适用于 RELEASE_8源版本。
      class  AbstractAnnotationValueVisitor9<R,P>
      注释值的骨架访问者，默认行为适用于 RELEASE_9源版本。
      class  SimpleAnnotationValueVisitor6<R,P>
      注释值的简单访问者，默认行为适用于 RELEASE_6源版本。
      class  SimpleAnnotationValueVisitor7<R,P>
      注释值的简单访问者，默认行为适用于 RELEASE_7源版本。
      class  SimpleAnnotationValueVisitor8<R,P>
      注释值的简单访问者，默认行为适用于 RELEASE_8源版本。
      class  SimpleAnnotationValueVisitor9<R,P>
      注释值的简单访问者，默认行为适用于 RELEASE_9源版本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.Element (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.Element

  • Packages that use Element
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的工具 。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。

    • Uses of Element in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type Element
      Modifier and Type 方法 描述
      Iterable<? extends Element> Scope.getLocalElements​()
      返回此范围中直接包含的元素。

    • Uses of Element in com.sun.source.util

      Methods in com.sun.source.util that return Element
      Modifier and Type 方法 描述
      abstract Element DocTrees.getElement​(DocTreePath path)
      返回给定的DocTreePath的叶节点引用的语言模型元素，如果未知，则null 。
      abstract Element Trees.getElement​(TreePath path)
      返回给定TreePath标识的Tree节点的元素。
      Methods in com.sun.source.util that return types with arguments of type Element
      Modifier and Type 方法 描述
      abstract Iterable<? extends Element> JavacTask.analyze​()
      完成所有分析。
      Methods in com.sun.source.util with parameters of type Element
      Modifier and Type 方法 描述
      abstract DocCommentTree DocTrees.getDocCommentTree​(Element e)
      返回给定元素的文档注释树。
      abstract DocCommentTree DocTrees.getDocCommentTree​(Element e, String relativePath)
      返回相对于给定元素指定路径的给定文件的doc注释树。
      abstract TreePath Trees.getPath​(Element e)
      返回给定元素的TreePath节点。
      abstract TreePath Trees.getPath​(Element e, AnnotationMirror a)
      返回给定元素上的AnnotationMirror的TreePath节点。
      abstract TreePath Trees.getPath​(Element e, AnnotationMirror a, AnnotationValue v)
      返回指定元素上AnnotationMirror的AnnotationValue的TreePath节点。
      abstract 树 Trees.getTree​(Element element)
      返回给定元素的Tree节点。
      abstract 树 Trees.getTree​(Element e, AnnotationMirror a)
      返回给定元素上的AnnotationMirror的Tree节点。
      abstract 树 Trees.getTree​(Element e, AnnotationMirror a, AnnotationValue v)
      返回给定元素上AnnotationMirror的AnnotationValue的Tree节点。
      abstract boolean Trees.isAccessible​(Scope scope, Element member, DeclaredType type)
      检查给定元素是否可以作为给定范围内给定类型的成员访问。

    • Uses of Element in javax.annotation.processing

      Methods in javax.annotation.processing that return types with arguments of type Element
      Modifier and Type 方法 描述
      Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith​(Class<? extends Annotation> a)
      返回使用给定注释类型注释的元素。
      Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith​(TypeElement a)
      返回使用给定注释类型注释的元素。
      default Set<? extends Element> RoundEnvironment.getElementsAnnotatedWithAny​(Set<Class<? extends Annotation>> annotations)
      返回使用一个或多个给定注释类型注释的元素。
      default Set<? extends Element> RoundEnvironment.getElementsAnnotatedWithAny​(TypeElement... annotations)
      返回使用一个或多个给定注释类型注释的元素。
      Set<? extends Element> RoundEnvironment.getRootElements​()
      返回上一轮生成的注释处理的root elements 。
      Methods in javax.annotation.processing with parameters of type Element
      Modifier and Type 方法 描述
      JavaFileObject Filer.createClassFile​(CharSequence name, Element... originatingElements)
      创建一个新的类文件，并返回一个对象以允许写入它。
      FileObject Filer.createResource​(JavaFileManager.Location location, CharSequence moduleAndPkg, CharSequence relativeName, Element... originatingElements)
      创建一个新的辅助资源文件进行写入并返回一个文件对象。
      JavaFileObject Filer.createSourceFile​(CharSequence name, Element... originatingElements)
      创建一个新的源文件并返回一个对象以允许写入它。
      Iterable<? extends Completion> AbstractProcessor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回一个空的可迭代的完成。
      Iterable<? extends Completion> Processor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回到工具基础结构，可以对注释的建议完成进行迭代。
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e)
      在元素的位置打印指定类型的消息。
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a)
      在注释元素的注释镜像的位置打印指定类型的消息。
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v)
      在注释元素的注释镜像内的注释值的位置打印指定类型的消息。

    • Uses of Element in javax.lang.model.element

      Subinterfaces of Element in javax.lang.model.element
      Modifier and Type 接口 描述
      interface  ExecutableElement
      表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
      interface  ModuleElement
      表示一个模块程序元素。
      interface  PackageElement
      表示包程序元素。
      interface  Parameterizable
      用于具有类型参数的元素的mixin接口。
      interface  QualifiedNameable
      用于具有限定名称的元素的mixin接口。
      interface  TypeElement
      表示一个类或接口程序元素。
      interface  TypeParameterElement
      表示通用类，接口，方法或构造函数元素的正式类型参数。
      interface  VariableElement
      表示一个字段， 枚举常量，方法或构造函数参数，局部变量，资源变量或异常参数。
      Methods in javax.lang.model.element that return Element
      Modifier and Type 方法 描述
      Element Element.getEnclosingElement​()
      返回这个元素所在的最内层元素。
      Element ModuleElement.getEnclosingElement​()
      返回 null因为模块未被其他元素包围。
      Element PackageElement.getEnclosingElement​()
      如果存在这样的模块，则返回包围模块; 否则返回null 。
      Element TypeElement.getEnclosingElement​()
      返回顶级类型的包，并返回 nested类型的立即包含的元素。
      Element TypeParameterElement.getEnclosingElement​()
      返回此类型参数的 generic element 。
      Element VariableElement.getEnclosingElement​()
      返回此变量的包围元素。
      Element TypeParameterElement.getGenericElement​()
      返回由此类型参数参数化的通用类，接口，方法或构造函数。
      Element UnknownElementException.getUnknownElement​()
      返回未知元素。
      Methods in javax.lang.model.element that return types with arguments of type Element
      Modifier and Type 方法 描述
      List<? extends Element> Element.getEnclosedElements​()
      返回由这个元素直接包围的松散元素。
      List<? extends Element> ModuleElement.getEnclosedElements​()
      返回此模块中的包。
      List<? extends Element> PackageElement.getEnclosedElements​()
      返回此包中的 top-level类和接口。
      List<? extends Element> TypeElement.getEnclosedElements​()
      返回在此类或接口中直接声明的字段，方法，构造函数和成员类型。
      Methods in javax.lang.model.element with parameters of type Element
      Modifier and Type 方法 描述
      default R ElementVisitor.visit​(Element e)
      方便的方法相当于 visit(e, null) 。
      R ElementVisitor.visit​(Element e, P p)
      访问元素
      R ElementVisitor.visitUnknown​(Element e, P p)
      访问一种未知的元素。
      Constructors in javax.lang.model.element with parameters of type Element
      Constructor 描述
      UnknownElementException​(Element e, Object p)
      创建一个新的 UnknownElementException 。

    • Uses of Element in javax.lang.model.type

      Methods in javax.lang.model.type that return Element
      Modifier and Type 方法 描述
      Element DeclaredType.asElement​()
      返回与此类型对应的元素。
      Element TypeVariable.asElement​()
      返回与此类型变量相对应的元素。

    • Uses of Element in javax.lang.model.util

      Methods in javax.lang.model.util that return Element
      Modifier and Type 方法 描述
      Element Types.asElement​(TypeMirror t)
      返回与类型相对应的元素。
      Methods in javax.lang.model.util that return types with arguments of type Element
      Modifier and Type 方法 描述
      List<? extends Element> Elements.getAllMembers​(TypeElement type)
      返回类型元素的所有成员，无论是继承还是直接声明。
      Methods in javax.lang.model.util with parameters of type Element
      Modifier and Type 方法 描述
      TypeMirror Types.asMemberOf​(DeclaredType containing, Element element)
      返回当该元素被视为给定类型的成员或以其他方式直接包含的元素的类型。
      protected R SimpleElementVisitor6.defaultAction​(Element e, P p)
      访问方法的默认操作。
      List<? extends AnnotationMirror> Elements.getAllAnnotationMirrors​(Element e)
      返回元素上 存在的所有注释，无论是直接存在还是通过继承存在。
      String Elements.getDocComment​(Element e)
      返回元素的文档（“Javadoc”）注释的文本。
      default ModuleElement Elements.getModuleOf​(Element type)
      返回元素的模块。
      default Elements.Origin Elements.getOrigin​(Element e)
      返回给定元素的 原点 。
      PackageElement Elements.getPackageOf​(Element type)
      返回元素的包。
      boolean Elements.hides​(Element hider, Element hidden)
      测试一种类型，方法或字段是否隐藏另一种。
      boolean Elements.isDeprecated​(Element e)
      返回 true如果元素已过时， false否则。
      void Elements.printElements​(Writer w, Element... elements)
      以指定的顺序将元素的表示打印到给定的作者。
      R ElementScanner6.scan​(Element e)
      方便方法相当于 v.scan(e, null) 。
      R ElementScanner6.scan​(Element e, P p)
      通过调用e.accept(this, p)处理元素; 此方法可能被子类覆盖。
      R AbstractElementVisitor6.visit​(Element e)
      访问任何程序元素，就像将其自身传递给该元素的 accept方法一样，并通过其他参数传递 null 。
      R AbstractElementVisitor6.visit​(Element e, P p)
      访问任何程序元素，就像将其自身传递给该元素的 accept方法一样。
      R AbstractElementVisitor6.visitUnknown​(Element e, P p)
      访问一种未知的元素。
      Method parameters in javax.lang.model.util with type arguments of type Element
      Modifier and Type 方法 描述
      static List<ExecutableElement> ElementFilter.constructorsIn​(Iterable<? extends Element> elements)
      返回 elements中的构造函数列表。
      static Set<ExecutableElement> ElementFilter.constructorsIn​(Set<? extends Element> elements)
      在 elements返回一组构造 elements 。
      static List<VariableElement> ElementFilter.fieldsIn​(Iterable<? extends Element> elements)
      返回 elements中的字段列表。
      static Set<VariableElement> ElementFilter.fieldsIn​(Set<? extends Element> elements)
      返回 elements中的一组字段。
      static List<ExecutableElement> ElementFilter.methodsIn​(Iterable<? extends Element> elements)
      返回 elements中的方法列表。
      static Set<ExecutableElement> ElementFilter.methodsIn​(Set<? extends Element> elements)
      在 elements返回一组方法。
      static List<ModuleElement> ElementFilter.modulesIn​(Iterable<? extends Element> elements)
      返回 elements中的模块列表。
      static Set<ModuleElement> ElementFilter.modulesIn​(Set<? extends Element> elements)
      返回一组 elements的模块。
      static List<PackageElement> ElementFilter.packagesIn​(Iterable<? extends Element> elements)
      返回 elements中的软件包列表。
      static Set<PackageElement> ElementFilter.packagesIn​(Set<? extends Element> elements)
      在 elements返回一组软件包。
      R ElementScanner6.scan​(Iterable<? extends Element> iterable, P p)
      迭代给定元素并调用每个元素 scan(Element, P) 。
      static List<TypeElement> ElementFilter.typesIn​(Iterable<? extends Element> elements)
      返回 elements中的类型列表。
      static Set<TypeElement> ElementFilter.typesIn​(Set<? extends Element> elements)
      在 elements返回一组类型。

    • Uses of Element in jdk.javadoc.doclet

      Methods in jdk.javadoc.doclet that return types with arguments of type Element
      Modifier and Type 方法 描述
      Set<? extends Element> DocletEnvironment.getIncludedElements​()
      返回文档中应为 included的模块，包和类型元素。
      Set<? extends Element> DocletEnvironment.getSpecifiedElements​()
      调用工具时返回元素 specified 。
      Methods in jdk.javadoc.doclet with parameters of type Element
      Modifier and Type 方法 描述
      boolean DocletEnvironment.isIncluded​(Element e)
      如果文档中的元素应为 included ，则返回true。
      boolean DocletEnvironment.isSelected​(Element e)
      如果元素为 selected，则返回true。
      void Reporter.print​(Diagnostic.Kind kind, Element e, String msg)
      打印错误消息并增加错误计数。
      String Taglet.toString​(List<? extends DocTree> tags, Element element)
      返回要包含在生成的输出中的该标签的一系列实例的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ElementVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ElementVisitor

  • Packages that use ElementVisitor
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements和 types的公用事业 。

    • Uses of ElementVisitor in javax.lang.model.element

      Methods in javax.lang.model.element with parameters of type ElementVisitor
      Modifier and Type 方法 描述
      <R,P> R Element.accept​(ElementVisitor<R,P> v, P p)
      将访问者应用于此元素。

    • Uses of ElementVisitor in javax.lang.model.util

      Classes in javax.lang.model.util that implement ElementVisitor
      Modifier and Type Class 描述
      class  AbstractElementVisitor6<R,P>
      具有适用于 RELEASE_6源版本的默认行为的程序元素的骨架访问者。
      class  AbstractElementVisitor7<R,P>
      具有适用于 RELEASE_7源版本的默认行为的程序元素的骨架访问者。
      class  AbstractElementVisitor8<R,P>
      具有适用于 RELEASE_8源版本的默认行为的程序元素的骨架访问者。
      class  AbstractElementVisitor9<R,P>
      具有适用于 RELEASE_9源版本的默认行为的程序元素的骨架访问者。
      class  ElementKindVisitor6<R,P>
      基于他们的kind程序元素的访问者的默认行为适合RELEASE_6源版本。
      class  ElementKindVisitor7<R,P>
      基于他们的kind的程序元素的访问者的默认行为适合RELEASE_7源版本。
      class  ElementKindVisitor8<R,P>
      基于他们的kind程序元素的访问者 ，默认行为适用于RELEASE_8源版本。
      class  ElementKindVisitor9<R,P>
      基于他们的kind的程序元素的访问者 ，默认行为适用于RELEASE_9源版本。
      class  ElementScanner6<R,P>
      具有适用于 RELEASE_6源版本的默认行为的程序元素的扫描访问者。
      class  ElementScanner7<R,P>
      具有适用于 RELEASE_7源版本的默认行为的程序元素的扫描访问者。
      class  ElementScanner8<R,P>
      具有适用于 RELEASE_8源版本的默认行为的程序元素的扫描访问者。
      class  ElementScanner9<R,P>
      具有适用于 RELEASE_9源版本的默认行为的程序元素的扫描访问者。
      class  SimpleElementVisitor6<R,P>
      一个简单的访问程序元素的默认行为适合 RELEASE_6源版本。
      class  SimpleElementVisitor7<R,P>
      一个简单的访问程序元素的默认行为适用于 RELEASE_7源版本。
      class  SimpleElementVisitor8<R,P>
      一个简单的访问程序元素的默认行为适用于 RELEASE_8源版本。
      class  SimpleElementVisitor9<R,P>
      A simple visitor of program elements with default behavior appropriate for the RELEASE_9 source version.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ExecutableElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ExecutableElement

  • Packages that use ExecutableElement
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的工具 。

    • Uses of ExecutableElement in com.sun.source.tree

      Methods in com.sun.source.tree that return ExecutableElement
      Modifier and Type 方法 描述
      ExecutableElement Scope.getEnclosingMethod​()
      返回包含此范围位置的最内层可执行元素。

    • Uses of ExecutableElement in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ExecutableElement
      Modifier and Type 方法 描述
      abstract MethodTree Trees.getTree​(ExecutableElement method)
      返回给定ExecutableElement的MethodTree节点。

    • Uses of ExecutableElement in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type ExecutableElement
      Modifier and Type 方法 描述
      Iterable<? extends Completion> AbstractProcessor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回一个空的可迭代的完成。
      Iterable<? extends Completion> Processor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回到工具基础结构，可以对注释的建议完成进行迭代。

    • Uses of ExecutableElement in javax.lang.model.element

      Methods in javax.lang.model.element that return types with arguments of type ExecutableElement
      Modifier and Type 方法 描述
      Map<? extends ExecutableElement,? extends AnnotationValue> AnnotationMirror.getElementValues​()
      返回此注释元素的值。
      Methods in javax.lang.model.element with parameters of type ExecutableElement
      Modifier and Type 方法 描述
      R ElementVisitor.visitExecutable​(ExecutableElement e, P p)
      访问可执行元素。

    • Uses of ExecutableElement in javax.lang.model.util

      Methods in javax.lang.model.util that return types with arguments of type ExecutableElement
      Modifier and Type 方法 描述
      static List<ExecutableElement> ElementFilter.constructorsIn​(Iterable<? extends Element> elements)
      返回 elements中的构造函数列表。
      static Set<ExecutableElement> ElementFilter.constructorsIn​(Set<? extends Element> elements)
      返回一组构造函数在 elements 。
      Map<? extends ExecutableElement,? extends AnnotationValue> Elements.getElementValuesWithDefaults​(AnnotationMirror a)
      返回注释元素的值，包括默认值。
      static List<ExecutableElement> ElementFilter.methodsIn​(Iterable<? extends Element> elements)
      返回 elements中的方法列表。
      static Set<ExecutableElement> ElementFilter.methodsIn​(Set<? extends Element> elements)
      在 elements返回一组方法。
      Methods in javax.lang.model.util with parameters of type ExecutableElement
      Modifier and Type 方法 描述
      default boolean Elements.isBridge​(ExecutableElement e)
      返回 true如果可执行元素是bridge方法， false否则。
      boolean Elements.overrides​(ExecutableElement overrider, ExecutableElement overridden, TypeElement type)
      测试一种方法，作为给定类型的成员，覆盖其他方法。
      R ElementKindVisitor6.visitExecutable​(ExecutableElement e, P p)
      访问的可执行元件，指派给该访问方法用于特定kind可执行的CONSTRUCTOR ， INSTANCE_INIT ， METHOD ，或STATIC_INIT 。
      R ElementScanner6.visitExecutable​(ExecutableElement e, P p)
      访问可执行元素。
      R SimpleElementVisitor6.visitExecutable​(ExecutableElement e, P p)
      访问可执行元素。
      R ElementKindVisitor6.visitExecutableAsConstructor​(ExecutableElement e, P p)
      通过调用 defaultAction访问 CONSTRUCTOR可执行元素。
      R ElementKindVisitor6.visitExecutableAsInstanceInit​(ExecutableElement e, P p)
      通过调用 defaultAction访问 INSTANCE_INIT可执行元素。
      R ElementKindVisitor6.visitExecutableAsMethod​(ExecutableElement e, P p)
      通过调用 defaultAction访问 METHOD可执行元素。
      R ElementKindVisitor6.visitExecutableAsStaticInit​(ExecutableElement e, P p)
      Visits a STATIC_INIT executable element by calling defaultAction.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ModuleElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ModuleElement

  • Packages that use ModuleElement
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of ModuleElement in javax.lang.model.element

      Methods in javax.lang.model.element that return ModuleElement
      Modifier and Type 方法 描述
      ModuleElement ModuleElement.RequiresDirective.getDependency​()
      返回所需的模块
      Methods in javax.lang.model.element that return types with arguments of type ModuleElement
      Modifier and Type 方法 描述
      List<? extends ModuleElement> ModuleElement.ExportsDirective.getTargetModules​()
      返回要导出软件包的特定模块，如果软件包导出到具有对该模块的可读性的所有模块，则返回null。
      List<? extends ModuleElement> ModuleElement.OpensDirective.getTargetModules​()
      如果程序包打开了对该模块具有可读性的所有模块，则返回打包程序包的特定模块或空值。
      Methods in javax.lang.model.element with parameters of type ModuleElement
      Modifier and Type 方法 描述
      default R ElementVisitor.visitModule​(ModuleElement e, P p)
      访问模块元素。

    • Uses of ModuleElement in javax.lang.model.util

      Methods in javax.lang.model.util that return ModuleElement
      Modifier and Type 方法 描述
      default ModuleElement Elements.getModuleElement​(CharSequence name)
      返回给出其完全限定名称的模块元素。
      default ModuleElement Elements.getModuleOf​(Element type)
      返回元素的模块。
      Methods in javax.lang.model.util that return types with arguments of type ModuleElement
      Modifier and Type 方法 描述
      default Set<? extends ModuleElement> Elements.getAllModuleElements​()
      返回当前环境中的所有模块元素。
      static List<ModuleElement> ElementFilter.modulesIn​(Iterable<? extends Element> elements)
      返回 elements中的模块列表。
      static Set<ModuleElement> ElementFilter.modulesIn​(Set<? extends Element> elements)
      返回一组 elements的模块。
      Methods in javax.lang.model.util with parameters of type ModuleElement
      Modifier and Type 方法 描述
      default Elements.Origin Elements.getOrigin​(ModuleElement m, ModuleElement.Directive directive)
      返回给定模块指令的 原点 。
      default PackageElement Elements.getPackageElement​(ModuleElement module, CharSequence name)
      如给定模块所示，返回一个给定其全限定名称的包。
      default TypeElement Elements.getTypeElement​(ModuleElement module, CharSequence name)
      返回给定其规范名称的类型元素，从给定的模块中可以看出。
      R AbstractElementVisitor6.visitModule​(ModuleElement e, P p)
      访问模块元素。
      abstract R AbstractElementVisitor9.visitModule​(ModuleElement t, P p)
      以一个子类定义的方式访问一个 ModuleElement 。
      R ElementKindVisitor9.visitModule​(ModuleElement e, P p)
      访问一个 ModuleElement致电 defaultAction 。
      R ElementScanner9.visitModule​(ModuleElement e, P p)
      通过扫描包含的元素访问 ModuleElement 。
      R SimpleElementVisitor9.visitModule​(ModuleElement e, P p)
      Visits a ModuleElement by calling defaultAction.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ModuleElement.Directive (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ModuleElement.Directive

  • Packages that use ModuleElement.Directive
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of ModuleElement.Directive in javax.lang.model.element

      Subinterfaces of ModuleElement.Directive in javax.lang.model.element
      Modifier and Type 接口 描述
      static interface  ModuleElement.ExportsDirective
      一个模块的导出包。
      static interface  ModuleElement.OpensDirective
      一个开放的模块包。
      static interface  ModuleElement.ProvidesDirective
      由模块提供的服务的实现。
      static interface  ModuleElement.RequiresDirective
      模块的依赖。
      static interface  ModuleElement.UsesDirective
      对模块使用的服务的引用。
      Methods in javax.lang.model.element that return ModuleElement.Directive
      Modifier and Type 方法 描述
      ModuleElement.Directive UnknownDirectiveException.getUnknownDirective​()
      返回未知指令。
      Methods in javax.lang.model.element that return types with arguments of type ModuleElement.Directive
      Modifier and Type 方法 描述
      List<? extends ModuleElement.Directive> ModuleElement.getDirectives​()
      返回此模块声明中包含的伪指令。
      Methods in javax.lang.model.element with parameters of type ModuleElement.Directive
      Modifier and Type 方法 描述
      default R ModuleElement.DirectiveVisitor.visit​(ModuleElement.Directive d)
      访问任何指令，好像通过传递自己的该指令的 accept方法并传递 null作为附加参数。
      default R ModuleElement.DirectiveVisitor.visit​(ModuleElement.Directive d, P p)
      访问任何指令，好像通过传递自己的指令的 accept方法。
      default R ModuleElement.DirectiveVisitor.visitUnknown​(ModuleElement.Directive d, P p)
      访问未知的指令。
      Constructors in javax.lang.model.element with parameters of type ModuleElement.Directive
      Constructor 描述
      UnknownDirectiveException​(ModuleElement.Directive d, Object p)
      创建一个新的 UnknownElementException 。

    • Uses of ModuleElement.Directive in javax.lang.model.util

      Methods in javax.lang.model.util with parameters of type ModuleElement.Directive
      Modifier and Type 方法 描述
      default Elements.Origin Elements.getOrigin​(ModuleElement m, ModuleElement.Directive directive)
      返回给定模块指令的 原点 。
      Method parameters in javax.lang.model.util with type arguments of type ModuleElement.Directive
      Modifier and Type 方法 描述
      static List<ModuleElement.ExportsDirective> ElementFilter.exportsIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 exports指令的列表。
      static List<ModuleElement.OpensDirective> ElementFilter.opensIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 opens指令的列表。
      static List<ModuleElement.ProvidesDirective> ElementFilter.providesIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 provides指令的列表。
      static List<ModuleElement.RequiresDirective> ElementFilter.requiresIn​(Iterable<? extends ModuleElement.Directive> directives)
      返回列表 requires的指令 directives 。
      static List<ModuleElement.UsesDirective> ElementFilter.usesIn​(Iterable<? extends ModuleElement.Directive> directives)
      Returns a list of uses directives in directives.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ModuleElement.DirectiveVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ModuleElement.DirectiveVisitor

  • Packages that use ModuleElement.DirectiveVisitor
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。

    • Uses of ModuleElement.DirectiveVisitor in javax.lang.model.element

      Methods in javax.lang.model.element with parameters of type ModuleElement.DirectiveVisitor
      Modifier and Type 方法 描述
      <R,P> R ModuleElement.Directive.accept​(ModuleElement.DirectiveVisitor<R,P> v, P p)
      将访问者应用于此指令。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ModuleElement.ExportsDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ModuleElement.ExportsDirective

  • Packages that use ModuleElement.ExportsDirective
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of ModuleElement.ExportsDirective in javax.lang.model.element

      Methods in javax.lang.model.element with parameters of type ModuleElement.ExportsDirective
      Modifier and Type 方法 描述
      R ModuleElement.DirectiveVisitor.visitExports​(ModuleElement.ExportsDirective d, P p)
      访问 exports指令。

    • Uses of ModuleElement.ExportsDirective in javax.lang.model.util

      Methods in javax.lang.model.util that return types with arguments of type ModuleElement.ExportsDirective
      Modifier and Type 方法 描述
      static List<ModuleElement.ExportsDirective> ElementFilter.exportsIn​(Iterable<? extends ModuleElement.Directive> directives)
      返回列表 exports的指令 directives 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ModuleElement.OpensDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ModuleElement.OpensDirective

  • Packages that use ModuleElement.OpensDirective
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of ModuleElement.OpensDirective in javax.lang.model.element

      Methods in javax.lang.model.element with parameters of type ModuleElement.OpensDirective
      Modifier and Type 方法 描述
      R ModuleElement.DirectiveVisitor.visitOpens​(ModuleElement.OpensDirective d, P p)
      访问 opens指令。

    • Uses of ModuleElement.OpensDirective in javax.lang.model.util

      Methods in javax.lang.model.util that return types with arguments of type ModuleElement.OpensDirective
      Modifier and Type 方法 描述
      static List<ModuleElement.OpensDirective> ElementFilter.opensIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 opens指令的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ModuleElement.ProvidesDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ModuleElement.ProvidesDirective

  • Packages that use ModuleElement.ProvidesDirective
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements和 types的工具 。

    • Uses of ModuleElement.ProvidesDirective in javax.lang.model.element

      Methods in javax.lang.model.element with parameters of type ModuleElement.ProvidesDirective
      Modifier and Type 方法 描述
      R ModuleElement.DirectiveVisitor.visitProvides​(ModuleElement.ProvidesDirective d, P p)
      访问 provides指令。

    • Uses of ModuleElement.ProvidesDirective in javax.lang.model.util

      Methods in javax.lang.model.util that return types with arguments of type ModuleElement.ProvidesDirective
      Modifier and Type 方法 描述
      static List<ModuleElement.ProvidesDirective> ElementFilter.providesIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 provides指令的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ModuleElement.RequiresDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ModuleElement.RequiresDirective

  • Packages that use ModuleElement.RequiresDirective
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of ModuleElement.RequiresDirective in javax.lang.model.element

      Methods in javax.lang.model.element with parameters of type ModuleElement.RequiresDirective
      Modifier and Type 方法 描述
      R ModuleElement.DirectiveVisitor.visitRequires​(ModuleElement.RequiresDirective d, P p)
      访问 requires指令。

    • Uses of ModuleElement.RequiresDirective in javax.lang.model.util

      Methods in javax.lang.model.util that return types with arguments of type ModuleElement.RequiresDirective
      Modifier and Type 方法 描述
      static List<ModuleElement.RequiresDirective> ElementFilter.requiresIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 requires指令的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.ModuleElement.UsesDirective (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.ModuleElement.UsesDirective

  • Packages that use ModuleElement.UsesDirective
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of ModuleElement.UsesDirective in javax.lang.model.element

      Methods in javax.lang.model.element with parameters of type ModuleElement.UsesDirective
      Modifier and Type 方法 描述
      R ModuleElement.DirectiveVisitor.visitUses​(ModuleElement.UsesDirective d, P p)
      访问 uses指令。

    • Uses of ModuleElement.UsesDirective in javax.lang.model.util

      Methods in javax.lang.model.util that return types with arguments of type ModuleElement.UsesDirective
      Modifier and Type 方法 描述
      static List<ModuleElement.UsesDirective> ElementFilter.usesIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 uses指令的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.Name (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.Name

  • Packages that use Name
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。

    • Uses of Name in com.sun.source.doctree

      Methods in com.sun.source.doctree that return Name
      Modifier and Type 方法 描述
      Name AttributeTree.getName​()
      返回属性的名称。
      Name EndElementTree.getName​()
      返回此元素的名称。
      Name EntityTree.getName​()
      返回实体的名称或值。
      Name IdentifierTree.getName​()
      返回标识符的名称。
      Name StartElementTree.getName​()
      返回元素的名称。

    • Uses of Name in com.sun.source.tree

      Methods in com.sun.source.tree that return Name
      Modifier and Type 方法 描述
      Name MemberSelectTree.getIdentifier​()
      返回要选择的成员的名称。
      Name BreakTree.getLabel​()
      返回此 break语句的标签。
      Name ContinueTree.getLabel​()
      返回此 continue语句的标签。
      Name LabeledStatementTree.getLabel​()
      返回标签。
      Name IdentifierTree.getName​()
      返回标识符的名称。
      Name MemberReferenceTree.getName​()
      返回引用的名称。
      Name MethodTree.getName​()
      返回正在声明的方法的名称。
      Name TypeParameterTree.getName​()
      返回type参数的名称。
      Name VariableTree.getName​()
      返回正在声明的变量的名称。
      Name ClassTree.getSimpleName​()
      返回此类型声明的简单名称。

    • Uses of Name in com.sun.source.util

      Methods in com.sun.source.util with parameters of type Name
      Modifier and Type 方法 描述
      AttributeTree DocTreeFactory.newAttributeTree​(Name name, AttributeTree.ValueKind vkind, List<? extends DocTree> value)
      创建一个新的 AttributeTree对象，以表示HTML标签中的HTML属性。
      EndElementTree DocTreeFactory.newEndElementTree​(Name name)
      创建一个新的 EndElement对象，以表示HTML元素的结尾。
      EntityTree DocTreeFactory.newEntityTree​(Name name)
      创建一个新的 EntityTree对象，以表示一个HTML实体。
      IdentifierTree DocTreeFactory.newIdentifierTree​(Name name)
      创建一个新的 IdentifierTree对象，以表示一个标识符，如 @param标签。
      StartElementTree DocTreeFactory.newStartElementTree​(Name name, List<? extends DocTree> attrs, boolean selfClosing)
      创建一个新的 StartElementTree对象，以表示HTML元素的开始。
      UnknownBlockTagTree DocTreeFactory.newUnknownBlockTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownBlockTagTree对象，以表示无法识别的块标记。
      UnknownInlineTagTree DocTreeFactory.newUnknownInlineTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownInlineTagTree对象，以表示无法识别的内联标签。

    • Uses of Name in javax.lang.model.element

      Methods in javax.lang.model.element that return Name
      Modifier and Type 方法 描述
      Name ModuleElement.getQualifiedName​()
      返回此模块的完全限定名称。
      Name PackageElement.getQualifiedName​()
      返回此包的完全限定名称。
      Name QualifiedNameable.getQualifiedName​()
      返回元素的完全限定名称。
      Name TypeElement.getQualifiedName​()
      返回此类型元素的完全限定名称。
      Name Element.getSimpleName​()
      返回此元素的简单（不合格）名称。
      Name ExecutableElement.getSimpleName​()
      返回构造函数，方法或初始值设置的简单名称。
      Name ModuleElement.getSimpleName​()
      返回此模块的简单名称。
      Name PackageElement.getSimpleName​()
      返回此包的简单名称。
      Name TypeElement.getSimpleName​()
      返回此类型元素的简单名称。
      Name VariableElement.getSimpleName​()
      返回此变量元素的简单名称。

    • Uses of Name in javax.lang.model.util

      Methods in javax.lang.model.util that return Name
      Modifier and Type 方法 描述
      Name Elements.getBinaryName​(TypeElement type)
      返回类型元素的 二进制名称 。
      Name Elements.getName​(CharSequence cs)
      返回与参数相同的字符序列的名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.PackageElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.PackageElement

  • Packages that use PackageElement
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements和 types的公用事业 。

    • Uses of PackageElement in com.sun.source.util

      Methods in com.sun.source.util with parameters of type PackageElement
      Modifier and Type 方法 描述
      abstract DocTreePath DocTrees.getDocTreePath​(FileObject fileObject, PackageElement packageElement)
      返回包含给定文件的文档注释树的文档树路径。

    • Uses of PackageElement in javax.lang.model.element

      Methods in javax.lang.model.element that return PackageElement
      Modifier and Type 方法 描述
      PackageElement ModuleElement.ExportsDirective.getPackage​()
      返回正在导出的包。
      PackageElement ModuleElement.OpensDirective.getPackage​()
      返回正在打开的包。
      Methods in javax.lang.model.element with parameters of type PackageElement
      Modifier and Type 方法 描述
      R ElementVisitor.visitPackage​(PackageElement e, P p)
      访问包元素。

    • Uses of PackageElement in javax.lang.model.util

      Methods in javax.lang.model.util that return PackageElement
      Modifier and Type 方法 描述
      PackageElement Elements.getPackageElement​(CharSequence name)
      如果包在环境中是唯一的，则返回给定其全限定名称的包。
      default PackageElement Elements.getPackageElement​(ModuleElement module, CharSequence name)
      如给定模块所示，返回一个给定其全限定名称的包。
      PackageElement Elements.getPackageOf​(Element type)
      返回元素的包。
      Methods in javax.lang.model.util that return types with arguments of type PackageElement
      Modifier and Type 方法 描述
      default Set<? extends PackageElement> Elements.getAllPackageElements​(CharSequence name)
      返回具有给定规范名称的所有包元素。
      static List<PackageElement> ElementFilter.packagesIn​(Iterable<? extends Element> elements)
      返回 elements中的软件包列表。
      static Set<PackageElement> ElementFilter.packagesIn​(Set<? extends Element> elements)
      返回一组 elements的包。
      Methods in javax.lang.model.util with parameters of type PackageElement
      Modifier and Type 方法 描述
      R ElementKindVisitor6.visitPackage​(PackageElement e, P p)
      访问包元素。
      R ElementScanner6.visitPackage​(PackageElement e, P p)
      访问包元素。
      R SimpleElementVisitor6.visitPackage​(PackageElement e, P p)
      访问包元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.Parameterizable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.Parameterizable

  • Packages that use Parameterizable
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。

    • Uses of Parameterizable in javax.lang.model.element

      Subinterfaces of Parameterizable in javax.lang.model.element
      Modifier and Type 接口 描述
      interface  ExecutableElement
      表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
      interface  TypeElement
      表示一个类或接口程序元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类


Uses of Interface javax.lang.model.element.QualifiedNameable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
javax.lang.model.element.QualifiedNameable

  • Packages that use QualifiedNameable
    软件包 描述
    javax.lang.model.element
    用于建模Java编程语言元素的接口。

    • Uses of QualifiedNameable in javax.lang.model.element

      Subinterfaces of QualifiedNameable in javax.lang.model.element
      Modifier and Type 接口 描述
      interface  ModuleElement
      表示一个模块程序元素。
      interface  PackageElement
      表示包程序元素。
      interface  TypeElement
      表示一个类或接口程序元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类